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Chapter 1: What’s new

What's New in Adobe Captivate
Adobe Captivate reimagines the way interactive eLearning is created for a multi-device world. Rapidly author a wide 
range of interactive and responsive HTML5-based eLearning content without programming. 

Read on for a quick introduction to the new features and enhancements introduced in Adobe Captivate 9.0.2, 9.0.1, and 
9 releases.

What's new and changed in Adobe Captivate 9.0.2

Import assets

Import assets and e-learning templates from Adobe Stock and eLearning Brothers and customize your e-learning 
projects.

To import assets from Adobe Stock,

• Click Assets in the main toolbar and click Get Adobe Stock Assets.
To import assets from eLearning Brothers portal,

• Click Assets in the main toolbar and click Get Free eLearning Assets.
For more information, see Importing assets into a Captivate project .

http://helpx.adobe.com/en/captivate/using/importing-assets-captivate-project.html
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Community portal

Performance enhancements in this release

What's new and changed in Adobe Captivate 9.0.1

Join conversations about creating and managing e-learning projects with Adobe Captivate.

To access the community portal,

• Click Community in the main toolbar.
For more information, see Using the Community Portal .

Captivate 9.0.2 comes with several runtime performance enhancements. Some of them are:

• Multi-state objects now load faster.

• Images in a project load faster as there are fewer http calls to the images.

• Changes in timer logic to prevent heavy load on CPU and battery.

http://helpx.adobe.com/en/captivate/using/using-captivate-community-portal.html
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Rulers and guides

Enhanced rulers and guides are added to improve your design experience.

For more information, see:

•  

• How to align objects in Adobe Captivate

Enhancements to the multi-state object feature

Multiple enhancements are added to the multi-state feature that was introduced in Adobe Captivate 9. 

With Adobe Captivate 9.0.1, you can now: 

• Relatively position object states automatically when you move an object on the slide.

• Retain state on slide revisit

In addition, there are some bugs fixed related to undo and redo operations while working with object states.

For more information on these enhancements, see Working with multi-state objects in Adobe Captivate.

Device capture enhancements
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A number of enhancements are added to this device capture feature (applicable for Mac OS only):

• Enhancements to the gesture palette

• The depiction of gestures on the timeline is changed to show them as gestures instead of smart shapes (which was
the case in Adobe Captivate 9)

• Added a timer while recording to indicate the duration of the recording time

• Added an alarm that will sound if you change the recording orientation

• The device audio now plays through the Mac while recording thereby improving the recording audio

For more information, see Capture content from iOS devices (Captivate for MAC feature).Capture content from iOS 
devices (Captivate for MAC feature) 

Captivate Draft app enhancements

For easier usability, the gesture mode has been discontinued and its main feature - the ability to "draw" shapes on screen 
is merged into the edit mode.

The copy and paste feature is also enhanced allowing you to copy and paste objects from one slide to another within a 
project.

Another navigation method is added - the two-finger swipe.

For more information, see Using the Captivate Draft iPad app.Using the Captivate Draft iPad app 

Platform support
Apart from supporting all the operating systems supported by Captivate 9, Captivate 9.0.1 also offers Mac 10.11.3 
support.

For more information, see System Requirements .

What's new and changed in Adobe Captivate 9

http://helpx.adobe.com/en/captivate/system-requirements.html
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Captivate Draft app for iPad Capture content from iOS devices Multi-state objects

Enhanced effects Preview project in LMS Work in Captivate with svg graphics

Additional breakpoints and UI enhancements for responsive projects
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Create knowledge check slides Publish to Adobe Captivate Prime Other features



7
What’s new

Last updated 10/10/2016

Captivate Draft app for iPad

Use the Captivate Draft app for iPad to quickly create content on the go. Create storyboards whenever inspiration 
strikes you, and then export it to the Cloud, to work on it later. You can also send your draft projects to reviewers and 
collaborators. 

For more information, see Using the Captivate Draft iPad appand Review and collaboration in Adobe Captivate Draft

Capture content from iOS devices

You can now connect your iOS device to your computer, and capture actions on the device.

For more information, see Capture content from iOS devices (Captivate for MAC feature)
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Multi-state objects

Objects can now have multiple states. This feature gives you the freedom to manipulate object behavior and appearance 
quickly and easily directly from the Property Inspector.

For more information, see Working with multi-state objects in Adobe Captivate.

Enhanced effects

The effects panel UI has been revamped for a better user-friendly experience. 

New effects have been added. Also motion path effects are now available for responsive projects also.

For more information, see Object effects .

Preview project in LMS

Preview your project in an LMS and verify it is structurally accurate before actual publishing. 

For more information, see Preview LMS.

http://helpx.adobe.com/en/captivate/using/object-effects.html#main-pars_minitoc
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Work in Captivate with svg graphics

Import and edit your svg graphics within Captivate. 

For more information, see Working with SVG images.

Additional breakpoints and UI enhancements for responsive projects

Additional breakpoints are introduced to help you refine your project further. In addition, several UI enhancements 
have been included.

For more information, see Responsive Project Design with Adobe Captivate.

Create knowledge check slides

You can create knowledge check slides to enforce learning activity for learners.

For more information, see Set up knowledge check slides in Adobe Captivate.
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Publish to Adobe Captivate Prime

Adobe Captivate Prime is a new learning management system that you can use to distribute your e-learning content 
over the internet to learners. 

You can now publish your Captivate projects to Captivate Prime. 

For more information, see Publish project to Adobe Captivate Prime

Other features

Emulate geolocation
You can test any geolocation functionality you have set up when you preview your project in the browser. 

For more information, see Emulate geolocation while testing your project.

Introduction of delays in advanced actions
In previous versions of Captivate, a given set of actions in an advanced action gets executed all at the same time and not 
sequentially. This issue is now addressed by the Delay action. 

Syntax:

Delay wait_time seconds

wait_time is the amount of time required before executing the next action.

wait_time can also be parameterized in shared action.

Usage example:

DelayNextActionsBy 2 seconds

Show smartshape1

DelayNextActionsBy 2 seconds

Hide smartshape1

In runtime, show action gets executed at 2 seconds and hide action gets executed at 4 seconds.

Sample workflows:

• Used to execute a set of actions after 'X' seconds the movie has started playing.

• Combined with jump to slide actions.
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• Used to show/hide objects after playing an effect, audio, and so on.

• Combined with change state of action to show objects at desired time interval

Note:Delay does not interfere in movie state (pause or continue).

Exclusive e-learning assets
Click Assets on the toolbar to access more than 30,000 assets available to you free with Adobe Captivate 9.

Using the Captivate Draft iPad app
You can quickly create your e-learning content on-the-go using the Captivate Draft app for iPad. Prepare your draft 
content in collaboration with other content authors while you are away from your desktop/laptop by using Captivate 
Draft.

Drag-and-drop Captivate native objects, smart shapes, set the styles and reuse them in your desktop as Captivate 
project. You can import the iPad app content into a desktop project and also export the project from iPad app. 

Create a project
1 Launch the Captivate Draft app on your iPad.

2 Click the tile named Create New Project as shown here.

3 Start creating your project in the blank slide.

Your project gets autosaved once you move away from the app. View your saved project in the landing page of your 
Adobe Captivate Draft app. 

Create content
You can create different types of content - draw or add objects, add text, and embed media.



12
What’s new

Last updated 10/10/2016

Draw objects
The Captivate Draft app supports the following gestures to insert corresponding objects:

• Square - Draw square shape on the slide to get this object

• Triangle - Draw triangle shape on the slide to get this object

• Circle - Draw circle shape on the slide to get this object

• Line - Draw line shape on the slide to get this object

• Image - Draw x shape on the slide to get this object

• Video - Draw > shape on the slide to get this object

• Text - Draw wave shape vertically on the slide to get this object

• Audio - Draw wave shape on the slide to get this object

• Web Object - Draw infinity shape on the slide to get this object

Simply draw a shape on the screen with your finger to get an object.

Click on the upper right of the screen to access the Help that shows how you can use gestures to quickly draw objects 
on your slide.

Add objects and embed media
Press on the left of the screen. A pop-up menu with shapes appears. To insert corresponding shape objects on the 
slide, press each of these icons.
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You can edit the properties of your objects such as size and fill/stroke color using the options on the right-side.

You can also add audio, video, and web objects. For more information, see Add multimedia.

Add and edit text
Press on the left side menu of the screen. A text area appears on the slide. To start adding the content, double tap 
the text area.

To edit the text, long press on the text inside text area to open a bubble shaped magnifier. You can move your cursor 
around the large text content using it.

Change text properties - You can change the font type, size, and also apply text properties to the text area. From the 
right side menu on the screen, press icon to change the font. You can also edit the text size and color using the size 
and color icons. 

A single tap on the object or text area pops up the text editing menu panel at the top:

Copy To generate a copy of the text area, tap . To paste it anywhere within the project, tap from the toolbar on 
the left. 

Delete To delete the text area, tap . 
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Edit To start editing the content, tap .

z-index If you have multiple overlapped objects/text areas, tap the z-index stack icons to bring up or send down the
object/text area. The white layer on the stack icon represents your selected object/text area position.

Hotspot If you want the user to tap the text to navigate to another slide, tap and select the slide you want to navigate 
to. A hotspot is created for that text area.

Add multimedia
You can add multimedia objects such as images, audio, video, and web objects.

Add audio
You can record audio live in Adobe Captivate Draft. 

Press on the left of the screen. In the submenu pop-up window, press . A recording button appears with a 
message to start recording audio. To start recording the audio, tap the red circle. Tap the red circle again to stop 
recording.

An audio icon at the upper right corner of the slide indicates that the audio is saved to the slide. When you stop the 
audio recording, you can opt to play audio, record again or delete the audio clip. Choose the appropriate option.

The audio files are auto saved into the slides. All the audio slides are represented with an audio icon at the upper right 
corner of the slide for identification. 

At any point in time, you can access the audio clip by tapping the audio icon. You can then choose to play audio, record 
again, or delete the audio clip. 

Add video
You can record videos live in slides or add existing videos. Similarly, you can capture live pictures into the slide or 
import existing images to the slide. 

Press on the left side menu of the screen. In the pop-up submenu, press . A video placeholder area appears on 
the slide.
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On the right-side of the screen, press to record live videos. After recording the video, tap Use Video at the lower-
right corner of the screen to include in the slide. To re-record the video, tap Retake at the lower-left corner of the screen. 
To cancel recording and go back to the slide, press Cancel.

To import existing videos into the slide, press on the right side.

Add images
Press the multimedia icon on the left side menu of the screen. In the pop-up submenu, tap the image icon. An image 
placeholder area appears on the slide.

To take live pictures, press on the right side of the screen.

Press to import existing images into the slide.

Add web object
Press on the left side menu of the screen. In the pop-up submenu press . It creates a web object on the slide. To 
edit/add the url of your choice, double tap the url space.

More editing options are available for the inserted web object.

Copy To generate a copy of the web object, tap . To paste it anywhere within the project, tap on the left side of 
the screen.

Delete To delete the web object, tap . 

Edit To change the URL, tap .

z-index If you have multiple overlapped objects/text areas, tap the z-index stack icons to bring up or send down the
object/text area. The white layer on the stack icon represents your selected object/text area position.
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Hotspot If you want the user to tap the web object to navigate to another slide, tap and select the slide you want to 
navigate to. A hotspot is created for that web object.

Add hotspots
You can branch or inter-link slides within the project by using hotspots.

1 Tap the hotspot icon, then tap on the screen where you want to create a hotspot.

A square hotspot appears on the screen. 

2 Press and drag the corners of the hotspot to increase or decrease the size of it. Change the positions by pressing the 
hotspot and moving it.

3 To delete a hotspot, click the X icon on the upper left corner of the hotspot.

4 To link the slides, press the hotspot, all the slides in the project appear on the screen.



17
What’s new

Last updated 10/10/2016

5 Press the slide you want the hotspot to link to.

A link icon appears on the linked slide.

Note: On any slide, you can use a maximum of four hotspots to link other slides. 

Add slides to a project
You can add blank or question slides to your project.

Add a blank slide
To add a blank slide:

1 Tap on the right side of the screen.

2 Start creating your content in the slide. 

Note: Your slide is autosaved. 

3 To include more slides to your project, repeat the above steps. 

Add a question slide
To add a question slide:

1 Slide your finger across on the right of the screen, and click Add Question Slide in the pane that opens.

A pane offering four question slide options opens up allowing you to create True/False, Multiple Choice, Matching, 
and Sequence type of questions.

2 Select one of the options and edit it according to your requirements.

True/False - Double tap the text area, named 'Type the question here' to add the question text of your choice. 

Multiple Choice Double tap the text area, named 'Type the question here' to add the question text of your choice. 
Double tap the text area, named 'Type the answer here' to add the answer text of your choice. 
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Matching Double tap 'Insert column 1 text here' text area and 'Insert Answer' text area to add your choice of text. A 
minimum of two answers are required for this slide, two answers are shown by default.

Sequence Double tap 'Type the sequence item' to add text. A minimum of two sequence items are required for this 
slide, two sequence items are shown by default. 

3 To add more answer choices to the question in multiple choice, matching and sequence question slides, press on 
the left side of the screen. On the right, you can see '#Answers' icon with the current number of available answers 
being highlighted in circle. Press the icon, a side level scrolling menu appears. You can scroll up or down to add the 
number of answers. A minimum of two answers are shown by default.

4 To edit the fonts of the quiz questions and answers, single press on the text area to select it. Options to modify the 
text, size, and color appear on the right-side of the screen.

Navigate across slides and projects
You can navigate through the project in the following ways:

• Swipe with two fingers right or left to navigate to previous or next slides.

• Double-tap anywhere on the screen and then tap on the next and previous icons that appear at the bottom of the
screen.

To navigate to a specific slide, swipe on the right of the screen to see all the slides in your project. Then tap on the 
slide you want to navigate to. 

To navigate across projects, tap the Home icon to get back to the home screen that lists all your projects. Then tap on 
the project you want to access.

Copy, move, and delete slides in a project
To view the filmstrip with all the slides of your project shown as thumbnails in it, press and swipe to your left.

A long press on the slide on the filmstrip shows the Delete icon on the lower-right of the thumbnail. To delete the slide, 
press on the Delete icon.

To copy a slide, click .

You can also move the slides from one position to another at this state, by dragging and placing them at your desired 
location. 
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View a project in Branching view
To view the branching for your slides, press at the top of the screen.

As shown in the below image, the host and target slides links are shown with red dots on target thumbnail slides. 

Pinch and drag to zoom in and out, so you can see all the branches/links. 

To go to a particular slide, select and press any slide in this view. 

Undo/redo changes
To undo/redo any changes, press the Left Arrow at the top of the screen. To redo changes you made in the slide, press 
the Right Arrow. 
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Preview a project
To preview the project, press the play icon at the top menu. While previewing the content in play mode:

• You can swipe the slide to left or right to move from one slide to another directly.

• To pause the preview mode, press anywhere on the slide.

• You can view green dots zooming in and out indicating the availability of hotspots on the slide.

Export/import a project
You can import and export projects from and to the creative cloud.

Import project from Creative Cloud
1 In the welcome screen/landing page of the Draft app, tap the down-arrow icon at the upper right corner of the 

screen. 

2 If you are connected to the Internet, you are prompted to log in with your Adobe credentials.

3 After signing in, you can import the project from the creative cloud.

Export project to Creative Cloud
1 In the home screen of the Captivate Draft app, a long press on your project thumbnail loads a menu at the top of the 

screen. 

2 To upload the project to Creative Cloud, tap .

3 If you are connected to the Internet, you are prompted to log in with your Adobe credentials.

4 After signing in, you can export the project to the creative cloud.

Import Adobe Captivate Draft project into Captivate
You can import Adobe Captivate Draft (*.cpdx) projects into your desktop Captivate application to refine the project. 
First download the project from the creative cloud to your computer.

Click New Project > Project from Adobe Captivate Draft and navigate to the folder with the *.cpdx project.
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Alternatively, you can click From Adobe Captivate Draft from the home screen as shown in the screenshot below.

Send project for review
To share the project with other resources for review and collaboration, tap . For more information on this workflow, 
see Review and collaboration in Adobe Captivate Draft . 

Capture content from iOS devices (Captivate for MAC 
feature)
Using the Device Capture feature, you can record video demos (*.cpvc projects) of content and apps that are on your 
iOS device. Just plug in the device, and start recording all the actions that you perform on the device.

Note: This feature supports only those iOS devices that are connected to the Mac with a lightning connecter (that is IOS 
devices with IOS 8 and above and with MAC OSX version 10 and above).

Before recording
Decide on the orientation of the device before you start recording. You cannot change device orientation while 
recording as the resolution changes abruptly and Captivate stops the recording.

http://helpx.adobe.com/en/captivate/using/review-and-collaboration-workflow-in-captivate-draft.html#main-pars_text_0
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Connect the device
Use the lightning device connector to connect your iOS device to the Mac.

Record new video demonstrations of your device
1 Click File > Record a new > Device Demo. A screen appears on the monitor displaying the connected device. If there 

is more than one connected device, select the required device from the drop-down list on the left of the Device 
Audio button.
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If the device is not connected properly, Captivate issues a warning beep and displays the following error message:
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If you see this message, unconnect and reconnect the device, and make sure it is unlocked.

2 Select the audio recording options by clicking the Device Audio dropdown and press to start recording. 

You can pause the recording at any point by clicking again.

The timer starts counting the time in seconds at the top of the screen indicating the length of the device capture 
video. 

Note: If you have audio playing on your device, Captivate plays the audio through the Mac, capturing the audio content 
from the device in your recording. 

3 Once you are done with the recording, press on the skin to stop the recording. The project now opens in 
Captivate with all the standard video editing options available to you for editing the video demo.

More Help topics 
Edit videos

Publish video projects

Add gestures
To show the actual device user experience, gesture support is added. 

You can now add and edit gestures such as swipes, taps, pinches, and zooms. When a video demo is open for editing in 
Captivate, all the available gestures appear in the Property Inspector.

http://helpx.adobe.com/en/captivate/using/record-video-demonstrations.html#main-pars_heading_0
http://helpx.adobe.com/en/captivate/using/record-video-demonstrations.html#main-pars_heading_13
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1 Click, drag, and drop the gesture you want to add from the Property Inspector to the stage.

Note: The gesture appears on the timeline as a gesture showing the name of the gesture such as tap or swipe, allowing 
for easier identification of the gesture.

2 Edit the gesture to look and behave the way you want it to.

Working with multi-state objects in Adobe Captivate
Objects can have multiple states within Captivate. This feature allows you to develop interactive content easily without 
using multiple objects, or "hide and show" techniques in a single project.

Using a single object with multiple states, you can unclutter your project timeline and reduce timeline complexity. For 
example, to change image color based on user's actions, you can use different colored states for a single image.

To work with multi-state objects, keep these features of multi-state objects in mind:

• Each object now can have multiple states.

• Interactive objects have in-built states.

• Users can customize the states of static and interactive objects.

• Button and smart shapes have in-built states with associated styles.

• Objects with multiple states can be added to regular slides only.

Support for multi-state objects
All smart shapes, text captions, objects, and media can have multiple states.

Question slide buttons, and drag-and-drop buttons do not support states.
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Note: Feedback captions, rollover objects, and text entry box buttons have in-built states, but they do not support adding 
custom states. 

Add states to an object
1 To add a state to an object, select the object and click + on the right of Object State in the Property Inspector. Enter 

a name for the state in the dialog that pops up and click OK.

2 Click State View to open the State view where you can see the original object and the new state you have created.

The object in focus is highlighted in the project slide. You can choose to add some characters or supplementary 
objects as part of the object in focus.

You can also see that there are two instances of the object. One is the original object in its normal (default) state, and 
the other is the new state of the object.

3 Edit the properties of the object making sure that you are doing the edits in the new state of the object.

Some edits you can do are modifying the shape, color, and size.  

4 Trigger an action for any object with a custom state by clicking Set Action to Object State directly from the Object 
State panel as shown here.

Use the Go to next state and Go to previous state actions to create interactive slideshows to allow the learner to move 
back and forth between different states.You can also use the Change state of action. This action enables you to trigger 

a custom state based on a user's action.

5 Select Retain State on Slide Revisit for a particular state if you want the object to retain that state when a learner 
revisits that slide.
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Move objects and their states
When you move an object that has multiple states, by default the respective states and additional state items move in 
relation to the object.

Delete/reset state
While creating the states, to go back to normal state, right-click on any state in the left pane, and choose reset state. 

You can delete any states apart from default and normal state of an object. Delete and reset states options are available 
in the right-click pop-up window of state. 

To exit State view and return to your slide, click exit state button in the toolbar. 

Objects and their in-built states
Captivate provides the following in-built states that you can customize according to your requirement. You can choose 
the type by using the State drop-down and clicking each state.
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The default state for every object is Normal.

You can add new states using Property inspector and also make your states as default state for an object. To make your 
state the default state, simply choose the state, click the drop-down icon next it, and make it the default state.

You can pre-define project properties for normal, down and rollover states in Object Style Manager as well. 

Note: The Set As default option is not available for interactive objects.For drag and drop interactions, the in-built states 
cannot be set as default states.

Effects behavior when objects have multiple states
When an effect is added to an object, the effect is applicable for all the states of an object. 

In addition, an effect plays across all states of an object. For example, if an object changes state mid-effect, the behavior 
of the effect does not change in any way.

Sample usage
Some samples depicting the usage of object states during interactive content development are shown below:

Object type In-built states

Text captions, highlight boxes, smart shapes, images, characters, 
videos, animations, text animations, equations, and web objects.

Custom state - Custom states are supported for static and interactive 
objects. Users can trigger them through the 'change state of' action.

Button or smart shape used as a button • Normal - the default state of an object

• Rollover - the state when a user hovers mouse cursor over the 
button

• Down - the state when a user clicks the button

Drag and drop interactions (for more information, see Multi-state 
objects in drag and drop interactions)

Drop sources • DragOver

• DropAccept

• DropReject

• DragStart

Drop targets • DragOver

• DropAccept

• DropReject

• DropCorrect

• DropIncorrect

The Drop Correct and Drop Incorrect states are triggered 
based on the Drag and Drop evaluation of the user's 
action when they submit their action.
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Scenario 1 - To change the colors of the dress (object) based on user's click action on respective color codes (shown 
below the object). 

Scenario 2 - To use characters to demonstrate the response for users choice in question slide, use object states and 
change the character's actions.

Property flow for multi-state objects in responsive projects
Property flow in a responsive project is across all states and views.

Captivate maintains a parent-child relationship among the breakpoints from Desktop-to-Tablet views and Tablet-to-
Mobile views respectively. The object states created in a particular breakpoint flow to the lower breakpoint views unless 
you modify the state for a particular view and break the link.

Example to demonstrate this relationship
For example, if you create a button, and add/edit states in a responsive project, the object and its states get added in all 
the other breakpoints.

If you make any edits to these object states in Desktop view, these edits are present in all the other breakpoints. 

If you make any edits to these object states in Tablet Portrait breakpoint, the link between the Tablet Portrait breakpoint 
and the Desktop breakpoint breaks. The object changes in the Desktop view no longer reflect in the Tablet Portrait and 
Mobile views. The objects in the Mobile view now reflect any object changes in the Tablet Portrait view.

Example to demonstrate how the relationship breaks
Consider the following example.

User adds a text entry box to the slide, selects the object, and clicks State View on the Property Inspector. User is 
working in Desktop view.

The State View opens showing the default states of the text entry box that are available. You can edit these states or create 
more states.
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User edits the properties of the in-built states, or creates a state. In this example, the text entry box is made transparent 
in the Down state so that when a learner presses the Submit button, the button becomes transparent.

This change to the object state (which is done in Desktop view) flows across all the breakpoints. 

User next goes to the Tablet Portrait view and edits the Down state further. If these changes deal with responsive 
properties such as character properties, position, or size then the link between the Desktop view and the Tablet Portrait 
view breaks. The Desktop view does not reflect these changes.

From now on, all changes done in the Tablet Portrait view (for that object) flow to the mobile views.
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Best practices to follow
• Customize the normal state of the object before you add custom states

• Mark the Smart shape as a button before you customize button properties

Object properties that do not flow across states
There are some object properties that do not flow across states. 

Properties such as shadow and reflection, text effects, and audio properties do not flow across states. For example, if 
you have an object with multiple states, and if you add a glow to it, the glow is not visible in the other states. Add the 
glow again to all the states.

In addition, text with different formats applied to it does not automatically flow across states.

Consider the below example. The word different has a different format applied to it. You can see that the formatting has 
not flowed to the new state.

To make this text flow across states, right-click the text and select Apply text to all states.

Multi-state objects in drag and drop interactions
Drag and drop interactions provide lot of options where you can use the multi-state nature of objects.

Consider this simple drag-and-drop interaction (choose the correct answer) example below.
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In the above interaction, the LDAP oval object is the drag target and the rectangular options on the right are the drag 
sources. The correct answer 389 is mapped to the LDAP drag target.

Each of these drop sources and the drop target have multiple states that you can customize to enhance the appearance 
and function of this interaction.
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Add all these in-built states by selecting the object and clicking + in the Object State panel in the Property Inspector.

You can set the appearance of each state of the drop target and drop source objects.

Drop target:

• DragOver: This is the state of the object when the learner drags a source over the target.

• DropAccept: This is the state of the object when the learner drops an acceptable source over the target.

• DropReject: This is the state of the object when the learner drops an unacceptable source over the target.

• DropCorrect: This is the state of the object when the learner drops the correct answer over the target and submits
the answer.

• DropIncorrect: This is the state of the object when the learner drops the incorrect answer over the target and submits
the answer.
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Note: See that in spite of the many states, the LPDAP object still is only one object on the timeline above, thus keeping the 
timeline clutter-free.

Similar to the drop target, you can add the in-built states to the drop source as well.

Drop source:

• DragOver: This is the state of the object when you drag it over the target.

• DropAccept: This is the state of the object when you drag the acceptable source to the target.

• DropReject: This is the state of the object when you drag the unacceptable source to the target.

• DragStart: This is the state of the object when you start to drag the source toward the target.

Note: You can also add your own custom states to these objects to enhance your drag-and-drop interaction further.

Review and collaboration in Adobe Captivate Draft
You can collaborate with remote partners on projects directly from the Captivate Draft app on your iPad. 
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After creating your project, you can send a draft for review so that others can provide suggestions for you to incorporate 
into the final project.

When you choose to send a project for review, Adobe Captivate automatically publishes the file to a temporary location 
and sends an email notification with the link to the assigned reviewers.

When you send a project for review, it goes through these states:

Under review state: In this state, the project is undergoing reviews. The author and the reviewer can add comments 
and doodles. However, the project itself is not editable.

Work in progress state: After the review is ended, the project enters the work in progress state, where the author can 
fix all comments received. Once done, the author removes all doodles and comments, and the project gets back into its 
normal state.

Send a project for review
1 From the homepage, long-press the project.

2 Click to send an email notification to a reviewer/collaborator to let them know that a project is available for 
review.

3 Select the review end date from the drop-down if you want to end the review by a particular date. Click None if you 
don't have a review end date. Enter the email addresses of the reviewers separated by commas.
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4 Sign in with your Adobe ID.

An email is sent to the reviewer and the status of the project changes to In Review status.
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In this state, the project is not editable. The project creator and reviewers can only annotate the project.

Note: A reviewer can review a project created using Captivate Draft from any system. The reviewer just needs to click 
on the link in the email to open up the project in a web browser. For more information on reviewing a project, see 
Reviewing a project .

5 You and/or the reviewer can now add comments and doodles to the project by clicking on . Click to publish 
the doodle or comment.

When a reviewer adds a comment, you will see a notification appear on top of your project on the home page of your 
Captivate Draft app.

You can respond to the reviewer's comment by clicking on the comment icon and responding. The reviewer will get 
a notification within his project view.

http://helpx.adobe.com/en/captivate/using/review-and-collaboration-workflow-in-captivate-draft.html#main-pars_header_1
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6 To end the review, long press the project on the home screen and press .

7 Press OK in the confirmation dialog box that appears.

The project exits the review state and can now be edited again.

The comments are retained within the project.
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8 To view the comments on each slide, press at the top of the screen.

9 To remove all doodles and comments from the project, click DONE at the top of the screen, and then click OK.

This action removes all comments/doodles from the project, and changes its state to the normal default state again.

Adding reviewers
You can ask additional reviewers to look through and comment on your project at any time during your review.

Just long-press the project on the home page, and select Add Reviewers. Add reviewers email addresses, and review end 
date and click Send.
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Reviewing a project
When you get an email request to review a Captivate Draft app, just click on the link to open up the project in a web 
browser. 

1 Login to review using your Adobe ID or Google ID.

2 Press to add a comment or a doodle. Press to save it.

3 Click at the top of the screen to view your dashboard, which displays the status of all the projects assigned to 
you for review.

4 Press at the top of the screen to see the branching view of the project.

Publish project to Adobe Captivate Prime
Adobe Captivate Prime is a full featured LMS (Learning Management System), with a learner-first approach, that lets 
you take charge of your learning environment.

You can now publish your completed project to Adobe Captivate Prime.

1 In an open project, click Publish > Publish to Adobe Captivate Prime to open the Publish to Adobe Captivate Prime 
dialog box.
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If you don't have a Captivate Prime account, the Setup/Retrieve Captivate Prime Account option is displayed in the 
Account dropdown. 

If you already have a Captivate Prime account, that account is displayed in the Account dropdown. 

2 Click Publish.

If you don't have a Captivate Prime account, a Captivate Prime pop-up launches with videos that go over the 
Captivate Prime experience. Click Continue to Publish.

3 In the Publish to Captivate Prime window that opens as shown here, enter your account name or email ID that you 
used during registration.

All accounts associated with your email address or account name appear.

If you don't have an account, you can set up one by clicking Create an Account with your Adobe ID.
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4 Sign in with your Adobe ID and password if prompted.

If you do not have an Adobe ID already, you can create one in the following window. Administrators of an 
organization can also login with Adobe ID initially. 

5 Enter the module name, description, and time duration in the fields in the dialog box as shown here.
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Check whether it is a public module or a private module, and enter tags that make it easier for people to find your 
module.

Click Publish to publish your project to Adobe Captivate Prime.

What's New in Adobe Captivate 8.0.1
Adobe Captivate reimagines the way interactive eLearning is created for a multi-device world. Rapidly author a wide 
range of interactive and responsive HTML5-based eLearning content without programming. Adobe Captivate 8.0.1 
release includes phone gap integration, exe publishing, responsive project support for drag-and-drop, custom shapes, 
smart shape conversion of captions, smart positioning, and many feature enhancements.

Adobe Captivate 8.0.1 is an update release which is available to Adobe Captivate 8 customers through Adobe Update 
Manager. 

Read on for a quick introduction to these new features and enhancements, and links to resources offering more 
information. 

What's new and changed

Updated interactions in Captivate 8.0.1
In Captivate 8.0.1, 12 interactions have been updated to provide better user experience on mobile devices. For more 
information, see Creating learning interactions in Adobe Captivate

App packager integration 
Publish apps for devices from within Captivate project instead of using app packager. Choose Publish > Publish for 
Devices (App). It is supported for Android, iOS, and Windows 8 platforms.

For more information on publishing apps for devices in responsive projects, see Publish as Apps for devices 

http://helpx.adobe.com/en/captivate/using/preview-publishing.html#Publish as apps for devices
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For non-responsive/blank projects, see Publish as Apps for devices 

Convert captions to smart shapes
Success/Failure/Hint Captions can be replaced with Smart Shapes. Right-click the Caption and select Convert to Smart-
shape. To revert, right-click and click Revert to text.

For more information, see Captions as smart shapes . 

Responsive drag & drop
Users can drag-and-drop objects in responsive projects with a seamless experience. For more information, see 
Responsive drag-and-drop 

Custom shapes & line support 
Now, you can use custom shapes and line to create your own objects in responsive project. 

For more information, see How to customize smart shapes in Adobe Captivate. 

Publish projects as exe files
Adobe Captivate 8.0.1 enables you to publish your projects as stand-alone executable files for both personal computer 
and for Mac. This publishing option enables you to create a Windows executable file (.exe) or MAC executable file 
(.app). For more information, see Publish projects as executable files

Other enhancements

Map support

Map support is included for selecting geolocation in variables. Users can browse through Google™ integrated maps and 
choose the location. Values are populated automatically. 

For more information, see Geo location map . 

Embed support for web objects

Now, you can embed code in to the properties window along with URL. An option to choose Help (i) is also added. 
Width and height of Video web objects aligns according to the web object container dimensions seamlessly in 
responsive projects. 

For more information, see . 

Symmetrical editing
Shift+draw option added for drawing shapes like circle or square. Now, by pressing shift key authors can draw a circle 
or square symmetrically in projects. 

Shift+control+drag option is included for all shapes enabling authors to draw shapes symmetrically with reference to 
a starting point. 

http://helpx.adobe.com/en/captivate/using/publish-projects-html5-files.html#Publishing projects as app to devices
http://helpx.adobe.com/en/captivate/using/text-captions.html#Convert captions into smart shapes
http://helpx.adobe.com/en/captivate/using/responsive-project.html#Drag and drop interaction
http://helpx.adobe.com/en/captivate/using/preview-publishing.html#Map support
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In the above image, A and B graphs are drawn with reference to Origin (intersection point of x and y-axis) by using 
shift+ctrl+draw. In A, you can see the starting point with crossbar cursor at the origin. When you draw circle with 
shift+ctrl+draw, it moves symmetrically with reference to the starting point (here, the origin). 

In the image C also the pink colored circle is drawn with origin as a starting point, but here shift+ctrl+draw is not used. 

You can notice the difference and the usefulness of this enhancement for drawing. 

Apply position properties across all views 
Now you can update position properties of objects across all views to match the properties of the currently selected text 
element. To support Applying the object position properties across all the views, right click context menu is included. 
This setting relinks objects across the views in responsive projects. 

For more information, see Position properties . 

Apply text and text properties across all views
Now you can reset the properties of responsive text elements or update all views to match the properties of the currently 
selected text element. To support applying the text and text properties across all the views, right click context menu is 
included. This setting relinks objects across the views in responsive projects. 

For more information, see Responsive text . 

Color coding
Now, text objects in different views of responsive projects can have color coding. You can see different color coding in 
text area border in properties window. Earlier, it was applicable for only position properties.

For more information, see Color coding . 

Project size
Project Info panel displays the project content size enabling users to know the size of the projects before publishing. 
Users can choose Windows >Project Info panel to view the size. In non-responsive projects, it displays SWF content 
and HTML content sizes. For responsive projects, only HTML size.

A sample project info view is shown in the below snapshot. Figure A represents responsive project and Figure B 
represents blank project. By default, when you open project info, the size of the project is not displayed in responsive 
and blank projects. Click blue colored Check text to view the size. 

http://helpx.adobe.com/en/captivate/using/responsive-text.html#Apply properties to all views
http://helpx.adobe.com/en/captivate/using/responsive-text.html#Apply properties to all views
http://helpx.adobe.com/en/captivate/using/responsive-text.html#Color coding


46
What’s new

Last updated 10/10/2016

Smart positioning between breakpoints
Smart Positioning is honored in between breakpoints of responsive projects. View published projects seamlessly across 
all device sizes.

For more information, see Smart positioning 

Export responsive views captions to single Word or xml file
Project Captions and Closed Captions in responsive projects can be exported to a single Word™ or xml document. Now, 
it is responsive. Exported documents contain data from all the views of responsive projects. This feature facilitates 
translation of responsive captions, even when the text is different in various views.

Automatic linked files inclusion in output
Open URL/File/Project options copy/paste the linked file to the destination folder if the file is present in an accessible 
location. It copies automatically in the published output folder. (Note: files in next level reference url do not get copied.)

Swatch manager
Swatches are integrated in color palette. Users can load swatch manager from color palette by clicking at the upper-right 
corner as shown in the Figure - B below. In windows menu, swatches menu item is renamed to swatch manager as 
shown in Figure -A below.

http://helpx.adobe.com/en/captivate/using/responsive-project.html#main-pars_header_1
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You can add more colors to the swatch manager:

1 Choose any color from the swatch manager dialog

2 Click eyedropper icon

3 Type the name of your chosen color and 

4 Click OK. 

You can see your chosen color being added to your swatch manager dialog at the bottom. When you click color palette, 
you can notice the new color being shown at the bottom of all other existing colors. You can also include a set of colors 
to the swatch manager by clicking Append and choosing the file. Your new set of colors appear at the bottom row of the 
existing colors in swatch manager dialog. 

Lock individual objects 
Now you can lock or unlock the size and position of individual items contained in group, from within timeline.

fx symbol for objects in timeline
Visual indication added for objects with effects in timeline. fx symbol appears next to object in timeline.

Color tool tip
Color Category is displayed as tool tips in theme color palette. For example, hovering over a color theme displays Title 
component of theme. 

Note: See what's new of What's New in Adobe Captivate 8to understand all the features that were introduced in Adobe 
Captivate 8. 
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What's New in Adobe Captivate 8
Adobe Captivate 8 reimagines the way interactive eLearning is created for a multi-device world. This release includes 
responsive authoring that lets you develop mobile learning content for any screen or device without programming. The 
user interface is redesigned to make it more intuitive for beginners as well as advanced users. New customizable 
interactions, themes, and enhancements to smart shapes let you create more engaging content than ever.

Read on for a quick introduction to these new features and enhancements, and links to resources offering more 
information .

What's new and changed

Responsive projects 

http://helpx.adobe.com/en/captivate/topics.html
http://helpx.adobe.com/en/captivate/topics.html
http://helpx.adobe.com/en/captivate/using/whats-new-cp8.html#main-pars_header
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Redesigned user interface 

http://helpx.adobe.com/en/captivate/using/whats-new-cp8.html#main-pars_header_0
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Native support for HTML5 animations 

http://helpx.adobe.com/en/captivate/using/whats-new-cp8.html#main-pars_header_11
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Enhanced HTML5 publishing 

http://helpx.adobe.com/en/captivate/using/whats-new-cp8.html#main-pars_header_13
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Enhancements to smart shapes 

http://helpx.adobe.com/en/captivate/using/whats-new-cp8.html#main-pars_header_1
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New gaming interactions 

http://helpx.adobe.com/en/captivate/using/whats-new-cp8.html#main-pars_header_8
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Enhancements to shared actions 

http://helpx.adobe.com/en/captivate/using/whats-new-cp8.html#main-pars_header_2
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Import colors from Adobe Photoshop and Adobe Kuler 

http://helpx.adobe.com/en/captivate/using/whats-new-cp8.html#main-pars_header_15
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Other enhancements 

Responsive projects

 Create a single project and author content Create different types of projects in Adobe Captivate- the content adapts 
itself to tablets, mobile, and desktops based on the selected theme. During authoring, you can view the content on stage 
in different screen sizes and edit the content as appropriate. Adobe Captivate helps you ensure content and layout 
integrity across devices by providing relative positioning of objects on stage.

Harness the power of mobile devices by enabling gesture support and location-aware features. Preview your responsive 
projects easily by selecting multiple device layouts on-the-fly. Publish as a single project and Adobe Captivate 
automatically delivers the most appropriate experience for your learners' device.

http://helpx.adobe.com/en/captivate/using/whats-new-cp8.html#main-pars_header_16
http://helpx.adobe.com/captivate/using/
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For more information, see Responsive Project Design with Adobe Captivate

Responsive screen capture
Create a single screen capture that can be used across multiple screens and devices. Adobe Captivate allows you to 
choose the portion of the screen capture you wish to display on smaller screens.

For more information see Responsive capture (Responsive simulation)

Responsive themes
Choose from a bunch of out-of-the-box responsive themes to render differentiated content for multiple devices. You 
can customize these themes to meet your requirements, or create your own themes. You can also save these themes for 
reuse across projects.

For more information, see Responsive Themes

MinMax object sizing
Fix the minimum and maximum size of objects so that they do not rescale across device views. This is especially useful 
for images such as logos, which need to look consistent and be legible at all times. 

For more information, see Min-Max objects 

Gesture-enabled mlearning
Use the multitouch technology embedded in modern user interfaces to allow learners to tap, scroll, pinch, and swipe 
their way through courses. Leverage gesture support to enable more instinctive interaction between the learner and the 
content. 

For more information, see Gestures 

Scrolling support for tablets and mobiles
Easily enable scrolling of content on tablets and mobiles to accommodate content that spills over a single screen. 

For more information, see Slide height . 

Geo-location support
Utilize the GPS capabilities of mobile devices to deliver timely, location-aware content to learners. Create assessments 
that require learners to be at a particular geolocation. 

For more information, see Geo-location . 

Device aware eLearning delivery
Adobe Captivate 8 delivers the appropriate version of the course automatically. It does not matter if your learners are 
using your courses on desktops or mobile devices, Captivate will take care of the content delivery and report to your 
Learning Management solution. 

Even if the learner changes from one device to another while working their way through a course, it delivers the 
appropriate course version. 

Use Captivate’s new cpInfoMobileOS variable to learn which Operating system a learner is using making it possible to 
change the course content based on the current device.

http://helpx.adobe.com/captivate/using/responsive-project.html#Responsive Themes
http://helpx.adobe.com/en/captivate/using/view-specific-properties.html#Min-Max
http://helpx.adobe.com/en/captivate/using/preview-publishing.html#Gestures and Geolocation
http://helpx.adobe.com/en/captivate/using/responsive-project.html#Customizing Slide Height
http://helpx.adobe.com/en/captivate/using/preview-publishing.html#Gestures and Geolocation
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Redesigned user interface

The user interface in Adobe Captivate 8 is redesigned to make authoring simple and efficient. Enjoy authoring with an 
interface that is simple enough for subject matter experts and powerful enough for experienced users. 

Some of the major enhancements in the user interface are described below.

Experience the revamped Toolbar and Welcome screen with an option to view recent projects. Use toggle button to 
show/hide Timeline, which is hidden by default. Customize Theme colors for your projects using varied options such 
as swatches and shades. 

• Support for High DPI (retina display)

• Default Image buttons are updated

• Effects are absolutely timed with objects

• Common JavaScript interface for SWF format and HTML5 to access Adobe Captivate demo (or movie) variables,
functions, and event listeners.

Retina display support
Use Adobe Captivate 8 at a resolution that matches your MAC. Enjoy a superior authoring experience with high-
resolution icons and User Interface assets that make your program elements look crisp.

New toolbar panel
As shown in the image below, an attractive Toolbar panel has been introduced in Adobe Captivate 8. A Down Arrow 
adjacent to the Toolbar icon indicates the optional list of items under it.

Timeline
You can click the Show/hide Timeline button to display Timeline of objects. Double-click Timeline button to hide. 
Timeline button is available at the bottom of the project window. By default, the Timeline is invisible.

For information on Timeline feature, see Working with the timeline in Adobe Captivate

Welcome screen
After launching Adobe Captivate 8, under NEW tab, you can see six thumbnail options for creating new projects, as 
shown in the following image: 
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Choose the thumbnail by clicking it and click Create button to open a brand new project.

From the RECENT tab, you have an option to browse through the recently used projects and open them. Recently used 
projects are displayed as Thumbnails. 

Several sample projects and tutorials are available for you to get started. You can click Monitor icon to view these 
sample projects and tutorials. 

Properties/Windows/Menus appearance
Click any object in the slide and view redesigned Property Inspector. Witness the enhanced appearance of the tabs and 
preview buttons. You can apply styles and preview with Styles Previewoption in Properties. Styles Preview displays a 
drop-down with three unique styles.

All the pop-up window options and menu items have new appearance with colored icons as shown in the image below: 
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Web objects
You can insert Webobjects into the slides using Objects > Web. Type the URL in the Address bar of Property Inspector 
as shown in the image below, and the web page appears in theWeb object. You can also click folder icon adjacent to 
Address bar, and fetch the local content into the web object container.

Webobjects is the native object now. You can browse OAM file (Adobe Edge Animate) pdf, and zip files. Use Auto Load 
option to enable Autoloading of file in Output. If Auto Load is not enabled, user needs to click Play button to view the 
object.

Note: When you zip the published content, ensure that the index.html file is not in any of the internal folders, else it does 
not load as expected.
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Common JS interface
Adobe Captivate 8.0 enables its users to make more powerful yet leaner content using the new JavaScript Interface 
feature. This feature gives a common platform for executing JavaScript actions between SWF and HTML.

Common JavaScript interface for SWF format and HTML5 to access Adobe Captivate demo (or movie) variables, 
functions, and event listeners.

For more information, see Learn about the Common JavaScript interface for Adobe Captivate

Native support for HTML5 animations

Import HTML5 animations into your Adobe Captivate project without requiring any plug-ins. Place animations exactly 
where you need them, resize if required, and publish effortlessly in the HTML5 format. 

1 Open new blank project. 

2 From Toolbar, click Media > HTML5 Animation

3 From the Open dialog, choose any existing Adobe Edge Animate files or zip files and click OK.

4 Resize if required. 

5 From Toolbar, click Publish > Publish for Devices

6 Choose HTML5 output and click Publish. 

Enhanced HTML5 publishing

Deliver eLearning on-the-go with full support for scalable HTML5, new mobile themes, and play bar. Deliver courses 
that are optimized for mobile devices by publishing HTML5 output of your eLearning content.

For more information see Publishing HTML5 output . 

http://helpx.adobe.com/en/captivate/using/preview-publishing.html#Publishing
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Enhancements to smart shapes

With Adobe Captivate 8, you can now customize shapes and reuse them across different slides and projects with ease. 
Use Hover state with fill for color/gradient/image. 

For more information, see How to customize smart shapes in Adobe Captivate

New gaming interactions

Make learning interesting, fun, and interactive for your learners through the new gaming interactions introduced in 
Adobe Captivate 8.

Catch Alpha nums interaction is an accelerometer-based interaction. Your learners can use tilt gesture controls on 
tablets and mobile devices that support accelerometer to play this interaction game. 

Memory game is also revamped in Adobe Captivate 8. For more information, see Using Adobe Captivate 8's new 
learning interactions. 

Shared actions enhancements

Drag-and-drop Shared Actions from Library on to Objects. Now, you can parameterize variables and literals. You can 
use variables as parameters and set different values while creating the project. You can also choose which objects and 
variables can be parameters. Associate actions to different interactive triggers (Success and OnEnter of objects and 
Slides). 

For more information, see Drag-and-Drop Shared Actions on to Objects. 
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Import colors from Adobe Photoshop and Adobe Kuler

Bring your favorite colors from Adobe Photoshop and Adobe Kuler, add them to the swatches, and use them in your 
Adobe Captivate projects. 

You can now import swatches from Adobe Photoshop and Adobe Kuler, or create custom swatches, and apply them to 
Adobe Captivate objects with a single click.

For more information, see Working with swatches in Adobe Captivate

Other enhancements

Changes to preview options

Preview on stage or F3 is now changed to Full screen preview (Preview > Project). Preview the content for each slide or 
for the project. Preview the project in browser (F11) with Primary, Tablet, and Mobile view port size options. Publish 
the content as HTML 5 with support for gestures and geolocation. 

For more information, see Preview and publish responsive projects. 

Popup blocker
Now, you can get rid of annoying notifications that pop up in the middle of your screen capture. You can choose to 
either remove the unwanted popup with a single click or replace it with a notification or a popup of your own.

Remove the unwanted pop-ups in Videos by using Clean Up option automatically or Replace option manually. 

Removing pop-ups using clean up

1 Open the video file in Adobe Captivate 8. 

2 Click Properties button and then click Video Effects Inspector. 

3 Click popup tab. You can see Cleanup popup option to cleanup automatically. 

4 Click Cleanup button from the Cleanup popup option. A cross bar appears.

https://kuler.adobe.com/create/color-wheel
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5 With the help of cross bar, outline the video section you would like to remove. 

Note: If you select the area out of the window dimensions, you get an error message. 

6 Click Cleanup button, as shown in the following snapshot, to remove the unwanted popup.

Note: Cleanup determines the start and end frames of Video and removes the area.

Removing popups using Replace
You can also remove the unwanted popups using Replace. Follow the steps 1 through 3 as in clean up. Replace option 
appears. 

You can click on Replace button and follow the online help instructions to remove the unwanted popup manually. For 
more information, see the following video: 

What’s new in Cp 6
High-definition Screencast Create high-definition product demos with a new capture-as-a-video workflow. Preview 
them instantly and publish them to YouTube, social media (Twitter, Facebook), or as MP4 files. Use the edit mode to 
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enhance your videos with Pan and Zoom effects, or add more objects and Picture-In-Picture videos (PIP). Also, add or 
edit mouse paths and points that you recorded in the video. See Creating video projects for more information.

HTML5 Publishing Publish your Adobe Captivate projects in HTML5 format for use on devices such as iPad and 
iPhones. See Publish projects as HTML5 files for more information.

Themes Spend less time and effort to liven up your courses. Choose from attractive, professionally designed themes 
that blend backgrounds, styles, fonts, and layouts. Apply them within and across projects to maintain a consistent look 
and feel. You can also customize themes to suit your requirements. For more information, see Themes.

Smart shapes Add a wide range of shapes, including circles, rectangles, triangles, callouts, arrows, lines, banners, and 
flowchart symbols, to your eLearning content. Customize them and convert them into buttons. For more information, 
see Creating and editing smart shapes.

Reflections Add a new dimension to text, images, and even videos using reflections. See Add reflection to objects for 
more information.

Object grouping Group a set of smart shapes, images, or other objects so that you can work with them collectively. 
Resize, rotate, time, flip, move, or format all the objects in the group as if they were a single object. See Group objects 
for more information.

Hyperlinks Insert text hyperlinks to direct learners to other sections of the course or external sources for more 
information. See Insert hyperlinksfor more information.

Text margins and custom bullets Improve the appearance and readability of text by adding margins and custom 
bullets.

Pre-test and branch-aware quizzing Use pre-tests to assess the knowledge, skill level, or training needs of individual 
learners. Based on the results, direct learners to the appropriate section, and quiz them at the end to gauge what they 
have learned. See Insert pretests for more information.

Partial and negative scoring Assign a score to each correct option when a question has more than one correct answer. 
Discourage guesswork by penalizing learners for wrong answers. See Multiple-choice question slides and Quiz 
properties for more information.

Remediation Make eLearning content more effective and improve the percentage of successful outcomes using the all-
new remedial workflow. When answering a quiz question incorrectly, let learners revisit the relevant section, 
understand the concept correctly, and retry the question. See Allow users to return to quiz for more information.

Enhanced integration with SCORM and AICC compliant LMSs Publish your courses effortlessly to leading LMSs such as 
Moodle, Blackboard, and Saba, rest assured that your scoring data will integrate smoothly with your LMS. See 
Uploading an Adobe Captivate project to a Learning Management Systemfor more information.

Smart learning interactions Insert aesthetically designed interactive elements to eLearning content with just a click. 
Select from a wide range of stunning out-of-the-box interactions such as Process, Accordion, and Pyramid, customize 
the content and appearance, and you're done. 

Click Insert > Interactions, choose the interaction, and double-click the text placeholders to type your text.

Ready-to-use character images Choose different personas, for example, a business executive or a medical practitioner, 
to add to your Adobe Captivate projects. Click Insert > Characters, choose a category, and click the image you require.

Roundtrip with Microsoft PowerPoint (enhanced) Import your existing presentations, including PowerPoint 2010 
slides in eLearning projects. Bring in objects, animations and multimedia, easily update the content, and keep your 
PowerPoint and Adobe Captivate projects in sync with the dynamically linked import option.

http://helpx.adobe.com/captivate/using/#UnresolvedLink-/XML/en-us/Products/Captivate/6.0/NFAuthoring_6.0/cap_videodemo_vd.xml#WS6029a80579ffffcd-269006f8134fa9f312d-8000
http://helpx.adobe.com/en/captivate/using/publish-projects-html5-files.html#publish_projects_as_html5_files
http://help.adobe.com/en_US/captivate/cp/using/WS6029a80579ffffcd-30b7333c135bd55ad0e-8000.html
http://help.adobe.com/en_US/captivate/cp/using/WS6029a80579ffffcd-385ec4be1351f74caed-8000.html
http://help.adobe.com/en_US/captivate/cp/using/WS16484b78be4e1542-3702703e1352357c072-8000.html
http://help.adobe.com/en_US/captivate/cp/using/WS6029a80579ffffcd5a87e66f135bd55f8cc-7ffc.html
http://help.adobe.com/en_US/captivate/cp/using/WS16484b78be4e1542-6c0fbd1322a4ef33d-8000.html#WS5b3ccc516d4fbf351e63e3d119e95824f7-7ff8
http://help.adobe.com/en_US/captivate/cp/using/WS16484b78be4e1542-6c0fbd1322a4ef33d-8000.html#WS16484b78be4e15422e637a98132059d0e08-8000
http://help.adobe.com/en_US/captivate/cp/using/WS16484b78be4e1542-6c0fbd1322a4ef33d-8000.html#WS16484b78be4e15422e637a98132059d0e08-8000
http://help.adobe.com/en_US/captivate/cp/using/WS6029a80579ffffcd5a87e66f135bd55f8cc-7fff.html
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What's new in Adobe Captivate 7

Roundtripping with Microsoft® PowerPoint 
Import your PowerPoint slides, including PowerPoint 2013, in eLearning projects. Bring in objects, animations, and 
multimedia, easily update the content, and keep your PowerPoint and Adobe Captivate projects in sync dynamically.

Advanced Action templates (Shared actions)
Use Advanced Actions to configure and modify the learning experience by enabling conditional or multiple actions in 
an interaction. Now create Advanced Action templates which can be reused across projects. See Shared actions in 
Adobe Captivate projectsfor more information.

Equation editor
Easily add complex mathematical equations, with operators and scientific symbols, to courses using the multi-purpose 
equation editor from [Math+Magic]™. See Working with mathematical equations in Adobe Captivate 7for more 
information.Working with mathematical equations in Adobe Captivate 7 

Learning notes
 Enable learners to add and edit notes as they take their course, thereby allowing them to place cues within the course 
for reference.

In-course web browsing
 Enable more effective learning by embedding a browser interface within your courses. Allow your learners to access 
additional web-based reference material that complements course content 

In-course YouTube videos
 Stream YouTube videos within your courses, for greater impact and retention. 

Specify which section of the video you want the learner to view, to make it contextually relevant.

Support for GIFT format 
Easily convert offline questions into a GIFT format question bank that you can draw on to create quizzes. Import GIFT 
format questions quickly and conveniently into Adobe Captivate 7 projects to create assessment modules. Maximize 
instructor time by using the same questions in multiple quizzes. See Import questions from GIFT format files (Cp 7)for 
more information.
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Enhanced Accessibility support
Expand your outreach to defense, government, and educational organizations. Easily create simulations and 
demonstrations that address accessibility standards such as Section 508 and Web Content Accessibility Guidelines 2.0 
(WCAG 2.0). Define text equivalents, insert clickable areas that allow keyboard access, and more to help ensure that 
everyone can access your content.

Multiformat publishing
Publish projects in multiple formats (MP4, SWF, EXE, PDF) to the web, desktops, notebooks, tablets, smartphones, 
iOS, and Android™devices, and leading Tin Can-, SCORM- and AICC-compliant LMSs.

Drag-and-drop interactions
Make eLearning fun with drag and drop games, quizzes, and learning modules that users can access on desktops and 
iPads. Choose from a variety of drag-drop combinations based on what a drop target can accept, reject, or replace with 
while providing audio feedback for every user attempt. For more information see Create drag-and-drop interactions in 
Adobe Captivate.

HTML5 support for PowerPoint
Import your Microsoft PowerPoint project including text, shapes, audio and animations into Adobe Captivate and 
publish them directly to HTML5. 

Adobe Captivate App Packager
Embed a range of HTML5 animations and synchronize them with your Adobe Captivate course. Publish the course as 
an app to multiple mobile platforms, including Windows RT—Metro using the PhoneGap Service.

Note: You need to purchase PhoneGap service separately.

Improved social media engagement
Instantly enable social conversations within Adobe Captivate courses with the enhanced Twitter widget. Help learners 
collaborate with you and other learners, in real time, by selecting a specific area within a course and tweeting a question. 
Track all conversations using the Learning Analytics dashboard.

Enhanced interactions library
Easily create engaging courses with a large library of professionally designed interactions, including Hangman and 
Jigsaw, which can be customized to suit your needs. For more information on interactions, see How to create and 
preview learning interactions.

Enhanced quizzing with HTML5
Outupt all your quizzes with Matching, Short Answer, and Fill in the blanks question types to HTML5.
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Record system audio
With Adobe Captivate 6.1, record system audio along with narration in an Adobe Captivate course. Use the system 
audio edit options to modify and synchronize the system audio across your course. For more information, see Working 
with system audio in Adobe Captivate 7.

RTL language support
Widen your learner base by making your courses available in more languages than earlier. Adobe Captivate now 
supports Right-to-Left languages such as Arabic, Hebrew and Urdu. For more information, see Author in right-to-left 
languages.

Publish HTML5 courses to Adobe Connect
Make your content more 'mobile' by publishing as HTML5 to Adobe Connect. Leverage the 'pause-resume anywhere' 
feature to provide seamless learning experience to your users on virtually any device or any browser. 
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Chapter 2: Workspace

Using rulers and guides

Use rulers
Rulers help you accurately place and measure objects in the Captivate design window. The point where 0 appears on 
each ruler is the ruler origin, which is the upper-left corner of the design window.

To show or hide rulers, choose View > Show Rulers or View> Hide Rulers.

Change the unit of measurement
The unit of measurement available in a non-responsive project is pixels. In responsive projects, the default unit of 
measurement is percent. 

To change the unit of measurement in a responsive project, right-click the ruler in a responsive project and select your 
preferred unit. 

You cannot change your unit of measurement in a non-responsive project.
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Use guides
Guides help you align text and graphic objects. In Captivate, you can create ruler guides (straight horizontal or vertical 
lines). 

You can change the default color of guides. For more information, see .

By default, guides are unlocked so that you can move, modify, delete, or revert them, but you can choose to lock them 
into place.

For more information on:

• Deleting or moving guides, see .

• Locking or unlocking guides, see .

• Snapping objects to guides, see Snap objects to guides.

Hover over a guide to find out its exact co-ordinates.

Create guides
You can create guides both on stage and off stage (using the menu) in different ways.

Creating guides on stage
Create guides easily on stage using the following methods:

By dragging
1 If the rulers aren’t showing, choose View > Show Rulers.

2 Position the pointer on the left ruler for a vertical guide or on the top ruler for a horizontal guide.

3 Drag the guide into position.
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By double-clicking
1 If the rulers aren’t showing, choose View > Show Rulers.

2 Double-click on the exact point on the ruler where you want to position your guide.

From existing guides
1 If the rulers aren’t showing, choose View > Show Rulers.

2 Right-click on an existing guide and choose Add New Guide.

A guide is created 20 pixels to the right (vertical guide), or 20 pixels to the bottom (horizontal guide).

Creating guides off stage
You can create a grid at one go, or add guides individually to your Captivate design area.

Creating guides individually
1 Choose View > New Guide.

2 Specify whether it is a horizontal or vertical guide, and specify its position in pixels accordingly from the left of the 
stage or the top. Click OK. 

A new guide is created.

Creating multiple guides
You can create a set of evenly spaced guides at one go.

1 Choose View > Create Multiple Guides.
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2 Specify the number of columns and rows and the required width between each guide. For the gutter, type a value to 
specify the padding around each guide. Later when you specify an object to snap to guide, if the object is within the 
gutter space of a guide, it snaps to that guide.

Select:

• Center Column: if you want to create the guides from the center of the stage.

• Clear Existing Guides: if you want to delete all earlier guides.

Note: All the values specified while creating multiple guides are in pixels.

3 Click OK.

Note: You can create a maximum number of 50 guides at a time using this menu.

A set of guides is created on the stage.

Move or delete guides
To move a guide, drag it.

To delete a single guide:

Right-click the guide and select Delete Guide.

To delete or clear all guides:

Choose View > Clear Guides.

If you cannot delete a guide, check to see if it is locked. Unlock the guide, and then delete it. For information on locking 
and unlocking guides, see Lock and unlock guides.

Lock or unlock guides
To lock or unlock all guides, choose View > Lock Guides to select or deselect the menu command.
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Change the appearance of guides
To change the appearance of guides, do the following:

1 Click Edit > Preferences.

2 Open the Defaults section of the Preferences dialog box.

3 Choose a different color from the Default Guides color and click OK.

Use smart guides
Smart Guides are temporary snap-to guides that appear when you create or manipulate objects. They help you align, 
edit, and transform objects relative to other objects, or by snap-aligning them to guides on the screen.

To turn Smart Guides on or off, check or uncheck View > Show Drawing/Smart Guides .

Guides: Property flow in responsive projects
The behavior of guides is the same as the behavior of any other object in responsive projects.

You can add or delete guides in lower breakpoints, and it is reflected in all the views (both high and low). However, if 
you edit a guide in a lower breakpoint, its link with higher views is broken. 

Working with grids in Adobe Captivate
The Snap To Grid option helps you position objects accurately on a page. A grid is a set of lines to which the objects 
“stick” when the Snap To Grid feature is enabled. When you bring an object close to a grid line, the object snaps to the 
line much in the same way as iron sticks to a magnet. For example, you can stack objects accurately one above the other 
using a grid.

Work with grids
• Select View > Show Grid. The grid is displayed as a matrix of dots on the slide.

• Select View > Snap To Grid.

• Select View > Snap To Object

Snap To Object is applicable only when you are drawing objects on a slide and not when you are editing or moving
them. When both Snap To Grid and Snap To Object options are selected, the Snap To Object option takes
precedence.

Change the dimensions of a grid
1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select General Settings from the Global menu.

3 Change the Grid Size value. The smaller the value, the smaller is the gap between the dots in the grid.
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Adobe Captivate workspace panels
To show or hide panels, select Window and then select the name of the panel.

Align Displays alignment options for objects in a slide. For more information, see How to align objects in Adobe 
Captivate.

Filmstrip Displays a thumbnail view of the slides in the project in the order of their appearance. For more information, 
see Working with the filmstrip.

Mobile Palette Displays options to enable or disable geolocation features in a project and gesture options in a mobile 
project.

Question Pool Displays a thumbnail view of the slides in question pools from where quiz questions are randomly 
picked at run-time. For more information, see Create question pools.

Master Slide Displays the slides that define background and common objects, such as logos, headers, and footers for 
other slides. For more information, see How to work with master slides in Adobe Captivate.

Timeline Displays the timeline of a slide and its objects. For more information, see Working with the timeline in Adobe 
Captivate.

Library Displays all the resources, such as, images and audio files that are currently available for a project. For more 
information, see Adobe Captivate Library .

Project Info Displays the properties associated with the current project.

Quiz Properties Displays the properties associated with quiz slides.

Slide Notes Displays notes that are added for a slide. For more information, see Add and convert slide notes to audio 
files with Adobe Captivate.

Comments Displays review comments provided by reviewers. For more information, see View or sort comments in the 
Adobe Captivate project.

Skin Editor Displays the options for the ‘skin’ of the project output. Using this panel, you can switch between the 
interfaces for playback control, table of contents, and borders, and edit their settings. For more information, see Skins.

Drag and Drop Displays the drag and drop properties of a particular interaction. You can either show or hide 
interactions between objects. For more information, see Create drag-and-drop interactions in Adobe Captivate.

Advanced Interaction Lists the names of all the interactive objects, widgets, questions, and hidden slides in the project. 
For more information, see Edit object information using the Advanced Interaction panel .

Branching View Displays the linkage between the slides in the project and lets you edit the way the slides and objects 
are linked. For more information on Branching View, see How to use the Branching panel in Adobe Captivate.

Progress Indicator Indicates the progress of the conversion of non-flash video files into FLV/F4V format by Adobe 
Media Encoder (AME). For more information, see Inserting non-Flash video file formats.

HTML5 Tracker Shows the objects and features that are not supported in HTML5 output. When you make changes to 
these objects in the project, this panel updates the list accordingly. For more information, see Publish projects as 
HTML5 files 

Swatch Manager Displays the color swatch panel. For more information, see Working with swatches in Adobe 
Captivate.

Effects Enable this option to display or hide effects in the timeline. If you enable the option Enable Effects in Timeline, 
the effect applied to any object displays in the timeline. The screenshot below shows an effect applied to a text object.

http://helpx.adobe.com/en/captivate/using/captivate-library.html#adobe_captivate_library
http://helpx.adobe.com/en/captivate/using/edit-object-information-using-advanced.html#edit_object_information_using_the_advanced_interaction_panel
http://helpx.adobe.com/en/captivate/using/publish-projects-html5-files.html#publish_projects_as_html5_files
http://helpx.adobe.com/en/captivate/using/publish-projects-html5-files.html#publish_projects_as_html5_files
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Workspace Switch between different workspaces and create custom workspaces. For more information, see How to 
customize the Adobe Captivate workspace.

How to undo and redo actions in Adobe Captivate
You can reverse the previous action by using the Undo command.

• From the Edit menu, select Undo [Name of the recent action] or press Control+Z.

Each click reverses one more action. Continue clicking Undo (or pressing Control+Z) to remove as many of the
previous changes as necessary.

When the Undo command is unavailable (dimmed), you cannot undo the previous action.

Adobe Captivate tracks actions from the time you open a project until the time you close the project. Therefore, you 
can undo as many times as you need to, as long as the project remains open.

 You can reverse the action of the Undo command by using the Redo command.

• After you have used the Undo command, from the Edit menu, select Redo or press Control+Y.

Working with the timeline in Adobe Captivate
The Timeline is a visual representation of the timing of all objects on a slide. The Timeline provides an easy way to view, 
at a high level, all objects on a slide and their relationship to each other. 

With the Timeline, you can organize objects and precisely control the timing of objects. For example, on a slide that 
contains a caption, an image, and a highlight box, you can display the caption, then the image 4 seconds later, and then 
the highlight box 2 seconds after that. The Timeline also shows any audio associated with the slide or with objects on 
the slide. You can easily coordinate the timing of audio with the slide using the Timeline.
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A Show/Hide All Items  B Lock/Unlock All Items  C Playhead  D Timeline Header  E Fly-Out Menu  F Move the Playhead to the beginning  G Stop  
H Play  I Move the Playhead to the end  J Mute  K Elapsed Time  L Selected Start Time  M Selected Duration  N Slide Duration  O Zoom Slider  

The major components of the Timeline are objects, the header, and the playhead. The objects on a slide are displayed 
as stacked bars in the right pane of the Timeline. The header at the top of the Timeline indicates time in seconds (and 
parts of seconds). The playhead shows the point in time in which the slide is being viewed.

The Timeline header shows time, in minutes:seconds format. For example, 01:05 indicates 1 minute and 5 seconds. The 
markings helps you see exactly when objects appear. 

You can use the Timeline to hide or lock objects easily. This is useful when a slide contains many objects and you need 
to edit the objects separately.

Show or hide the Timeline
Select Window > Timeline.

Rearrange the Timeline panel
By default, the Timeline panel is docked at the bottom of any slide in an Adobe Captivate project. You can move, resize, 
group, or dock the Timeline panel to suit your requirement.

Change the zoom level of the Timeline panel
Use the slider in the Timeline panel. The center of the slider indicates 100% zoom. To increase the zoom level, drag the 
slider to the right. To reduce the zoom level, drag the slider to the left.

Change the order of object layers
1 Move the mouse over the object in the Timeline panel until the hand icon appears and drag the object up or down 

to reposition it.

2 If you have two objects that overlap on the slide, you need to select the object you want in front by setting the 
stacking order. 
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Changing the stacking order consists of moving objects to the back and front of the slide Stage. The key point to 
remember is that objects at the back of the Stage appear behind other objects. Use one of the following methods to 
set the stacking order:

• Right-click (Windows) or Control-click (Mac OS) an object on the slide, click Arrange, and select one of the
object order options. If necessary, right-click (Windows) or Control-click (Mac OS) other objects on the slide and
adjust their order.

Bring To FrontThis option brings the selected object to the top. When the project plays, the object appears on
top of all others.

Send To BackThis option sends the selected object to the background. When the project plays, the object appears
behind all others.

Bring ForwardThis option moves the object one layer forward.

Send BackwardThis option moves the object one layer back.

• On the Timeline, move the mouse over an object until the hand appears and drag the object up or down to change 
its position in the stacking order. Moving an object higher in the stacking order moves it to the front of the Stage, 
while moving an object lower moves it to the back of the Stage.

Hide objects during editing
 In the Timeline, click the dot below the eye icon in the layer that you want to hide.

The object disappears from the slide and an X icon appears in the column. To display the object on the slide, click 
the X icon.

When you hide an object layer, it is hidden only on the Stage. You can still view the layer when it is previewed or 
published.

Timeline for slidelets
A slidelet is a slide within a slide. A slidelet has its own Timeline. All the objects in the slidelet are displayed in its 
Timeline. When you select a slidelet, the Timeline changes automatically to that of the slidelet. To display the Timeline 
for the slide containing the slidelet, click anywhere outside the slidelet. For more information on slidelets, see How to 
create rollover slidelets in Adobe Captivate.

Lock objects
 In the Timeline, click the dot below the lock icon in the layer that you want to lock.

The layer and its corresponding object cannot be edited or moved until you unlock the layer. To unlock the layer, 
click the lock icon.

Set time for objects and slides using the Timeline
You can change the amount of time an object or slide appears in the movie using its Property Inspector or by using the 
Timeline. You may find this feature useful in several situations. For example, you may want to set exact object timing 
when coordinating a voice-over with a highlight box; you may want the highlight box to appear only when the voice-
over says, “Enter the date here.” 

• Move the mouse over the left or right edge of the slide or object on the Timeline until the resize pointer appears.
Click and drag the edge to the required position in the Timeline.
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• To set two objects to appear at the same time, align their left and right edges. For example, you can set a highlight
box to appear at the same time as an image so that the highlight box can appear over the image.

• To adjust the display time of interactive objects (such as text entry boxes, click boxes, and buttons) rest the pointer
over the line between Active and Inactive in the bar until the slider handle appears. Drag the slider to adjust the
display time.

You can select multiple objects and move them at the same time. Hold down the Shift key and click objects to select 
consecutive stacked objects in the Timeline, or to select nonconsecutive objects, hold down the Control key and
click the objects to move.

You can determine whether keystrokes are played slowly or quickly in a project. If the project has many keystrokes, 
increasing the speed will make the pace of the project faster. However, if keystrokes are critical in the project, you may 
want them to play slowly so users can view them clearly. Use the Timeline to change keystroke speed. Keystrokes are 
contained in a Timeline object named Typing. 

You determine the speed at which the mouse moves on any individual slide in a project. A high mouse speed increases 
the pace at which the project plays. However, if mouse movements are complicated, you may want to decrease the 
mouse speed so users can view all movements. Mouse movement is contained in a Timeline object named Mouse. To 
shorten the amount of time it takes for the mouse movement to play, move the mouse pointer over the left edge of the 
Mouse object until the resize pointer appears. Click and drag the edge to the left.

Preview a slide using the playhead
The red line that moves across the Timeline is the playhead. The playhead moves through the Timeline to indicate how 
the currently displayed slide appears in the project. It is a quick and efficient way to preview a single slide and check 
object timing. 

To see how the playhead functions, press F3. You can stop a playhead when it is playing by clicking it. To drag the 
playhead to a required position, move the mouse over its “head” in the area displaying the time. When the pointer 
appears, drag the playhead to the required position.

 Do one of the following to preview a slide:

• “Scrub” the slide by dragging the playhead to the left or right. As you move the playhead, objects appear and fade 
as they will when users view the slide. Scrubbing gives you the ability to control the pace and view the slide at
any speed from very slowly to very quickly.

• With the playhead in any location on the Timeline, press the Spacebar or F3 to begin playing the slide.

• With the playhead in any location on the Timeline, press in the lower-left corner of the Timeline. (To end
playback, press , or to wait, press .)

Shortcut keys in Adobe Captivate
Shortcut keys provide an easier and quicker way to navigate and use Adobe Captivate. They let you use keyboard key 
combinations instead of a mouse or program menu. The common shortcut keys are listed in the table.

Shortcut key Action

F1 (Win & Mac) Open Adobe Captivate Help (To access dialog-box-level help, click the 
Help button on individual dialog boxes.)

F2 (Win & Mac) Rename the selected object
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F3 (Win & Mac) Test view the current slide

F4 (Win & Mac) Preview the project

F5 (Win & Mac) Record audio

F6 (Win & Mac) Import audio

F7 (Win & Mac) Perform a spelling and grammar check

F8 (Win only) Preview project from current slide

F9 (Win only) Show the Advanced Interaction panel

F10 (Win only) Preview the current slide and the following “N” slides

F11 (Win), Command+F11 (Mac) Preview the project in a web browser (HTML)

F12 (Win), Command+F12 (Mac) Preview the project in a web browser (SWF)

Page Up (win & Mac) Scroll to the previous slide

Page Down (win & Mac) Scroll to the next slide

Alt+A (Win), Option+A (Mac) Create question pool

Alt+Up, Down, Left, Right Arrows (Win), Option+Up, Down, Left, Right 
Arrows

Click the object, click a resize handle, and use these options to resize 
the object in the selected direction by 1 pixel

Control+A (Win), Command+A (Mac) Select all

Control+B (Win), Command+B (Mac) Find audio in the Library/Change text to Bold

Control+C (Win), Command+C (Mac) Copy (slide in Filmstrip, and selected object on stage)

Control+D (Win) Duplicate (slide in Filmstrip, and selected object on stage)

Control+E (Win), Command+E (Mac) Extend the length of the object display time to the end of the slide on 
the Timeline

Control+F (Win), Command+F (Mac) Find/replace a particular object in the project Library

Control+I (Win), Command+I (Mac) Increase the indent (selected object on stage)/Change text to Italics. 
Indentation is equal to the grid size.

Control+L (Win), Command+L (Mac) Sync the selected object to the playhead

Control+M (Win), Command+M (Mac) Merge the selected object with the background

Control+N (Win), Command+N (Mac) Open new project

Control+O (Win), Command+S (Mac) Open the project

Control+Q (Win), Shift+Option+R (Mac) Insert a random question slide

Control+R (Win), Command + R (Mac) Start/record new capture project

Control+S (Win), Command+S (Mac) Save

Control+T (Win), Command+T(Mac) Open project template

Control+U (Win) Underline the selected text

Control+V (Win), Command+V (Mac) Paste what is on the clipboard (for example, slide, image, object, and 
so on)

Control+W (Win), Command+W (Mac) Close the project

Control+X (Win), Command+X (Mac) Cut (selected object on stage)
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Control+Y (Win), Command+Y (Mac) Redo

Control+Z (Win), Command+Z (Mac) Undo

Control+Enter (Win), Conmmand+Enter (Mac) Preview the project

Control+Alt+A (Win), Command+Option+A (Mac) Export PowerPoint slides as animation

Control+Alt+B (Win), Command+Option+B (Mac) Show or hide Filmstrip

Control+Alt+C (Win), Command+Option+C (Mac) Show the Closed Captioning dialog box

Control+Alt+D (Win), Shift+Option+D (Mac) Update the Library

Control+Alt+E (Win), Command+Option+E (Mac) Edit points of polygon drawing object

Control+Alt+F (Win), Command+Option+F (Mac) Find in the Library

Control+Alt+G (win), Command+Option+G (Mac) Create a slide group and autoadjust the rollover area

Control+Alt+H (Win), Command+Option+H (Mac) Hide the selected object

Control+Alt+I (Win), Command+Options+I (Mac) Find PowerPoint slides in the Library

Control+Alt+J (Win), Command+Option+J (Mac) Edit PowerPoint slides

Control+Alt+K (Win), Command+Option+K (Mac) Lock the selected object

Control+Alt+L (Win), Command+Option+L (Mac) Show or hide the Library

Control+Alt+M (Win), Command+Option+M (Mac) Insert master slide

Control+Alt+N (Win), Command+Option+N (Mac) Show slide notes

Control+Alt+O (Win), Command+Option+O (Mac) Record additional slides

Control+Alt+P (Win), Command+Option+P (Mac) Remove a slide group.

Control+Alt+Q (Win), Option+Shift+Q (Mac) Show the Question Pools Manager

Control+Alt+S (Win only) Edit PowerPoint slide

Control+Alt+T (Win), Command+Option+T (Mac) Show or hide the Timeline

Control+Alt+U (Win), Command+Option+U (Mac) Library usage

Control+Alt+V (Win), Command+Option+V (Mac) Import video file

Control+Alt+X (Win), Command+Options X (Mac) Show/hide the SWF-Commenting pane

Control+Alt+Z (Win), Command+Option+Z (Mac) Show/hide the Widget panel

Shift+F7 (Win & Mac) Show objects style manager

Shift+F8 (Win), Command + , (Mac) Preferences dialog box

Shift+F9 (Win), Shift+Command+F9 (Mac) Actions dialog box

Shift+F10 (Win), Shift+Command+F10 (Mac) Table of contents

Shift+F11 (Win), Shift+ Command+F11 (Mac) Skin Editor panel

Shift+F12 (Win), Shift+Option+F12 (Mac) Publish the file

Shift+A (Win & Mac) Insert Animation placeholder

Shift+F (Win & Mac) Insert Flash video placeholder

Shift+R (Win & Mac) Insert rollover caption placeholder
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Shift+O (Win & Mac) Insert rollover image placeholder

Shift+C (Win & Mac) Insert Text Caption placeholder

Shift+V (Win & Mac) Insert video place holder

Shift+M (Win & Mac) Insert Image placeholder

Shift+Q (Win), Option + Q (Mac) Insert Question slide placeholder

Shift+X (Win & Mac) Insert Text Animation placeholder

Shift+Alt+A (Win), Shift+Option+A (Mac) Show Audio Management panel

Shift+Alt+W (Win), Shift+Option+W (Mac) Close all the open projects

Shift+Alt+O (Win), Shift+Option+O (Mac) Insert recording slide placeholder

Shift+Alt+P (Win), Shift+Option+P (Mac) Import Photoshop file

Shift+Alt+S (Win), Shift+Option+A (Mac) Show Speech Management panel

Shift+Alt+V (Win), Shift+Option+V (Mac) Paste as Background

Shift+Alt+Up, Down, Left, Right Arrows (Win), Shift+Option+Up, 
Down, Left, Right Arrows

Click the object, click a resize handle, and use these options to resize 
the object in the selected direction by 10 pixel

Shift+Control+A (Win), Shift+ Command+A (Mac) Add an animation object

Shift+Control+B (Win), Shift+Command+B (Mac) Add a new button

Shift+Control+C (Win), Shift+ Control+C (Mac) Add a new text caption

Shift+Control+D (Win), Command+Shift+D (Mac) View slide properties

Shift+Control+E (Win), Shift+Command+E (Mac) Insert a new zoom area

Shift+Control+F (Win), Shift+Command+F (Mac) Insert an FLV file

Shift+Control+H (Win), Shift+Command+H (Mac) Hide/show slide

Shift+Control+I (Win), Shift+Command+I (Mac) Decrease the indent

Shift+Control+J (win), Shift+Command+J (Mac) Insert a blank slide

Shift+Control+K (Win), Shift+Command+K (Mac) Add a new click box

Shift+Control+L (Win), Shift+Command+L (Mac) Insert a highlight box

Shift+Control+M (Win), Shift+Command+M (Mac) Add a new image

Shift+Control+N (Win), Shift+Command+N (Mac) Add a new animation slide

Shift+Control+O (Win), Shift+Command+O (Mac) Add a new rollover image

Shift+Control+P (Win), Shift+Command+P (Mac) Import PPT

Shift+Control+Q (Win), Shift+Q (Mac) Insert a question slide

Shift+Control+R (Win), Shift+Command+R (Mac) Insert a rollover caption

Shift+Control+S (Win), Shift+Command+S (Mac) Save the project with different name

Shift+Control+T (Win), Shift+Command+T (Mac) Insert a text entry box

Shift+Control+U (Win), Shift+Command+U (Mac) Insert the mouse

Shift+Control+W (Win), Shift+Command+W (Mac) Insert a widget

Shift+Control+X (Win), Shift+Command+X (Mac) Insert a text animation
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Magnification shortcuts

Shortcut keys for recording
The following table lists the default shortcut keys used during recording. These shortcuts should be used only after you 
start the recording process. The same keys function differently when you are editing a project.

Shift+Control+Y (Win), Shift+Command+Y (Mac) Copy the background

Shift+Control+Z (Win), Shift+Command+Z (Mac) Insert Slidelet

Shift + Control + Alt + B (Win), Shift+Command+Option+B (Mac) Show Branching View

Shift+Control+Alt+S (Win), Shift+Command+Option+S (Mac) Insert an image slide

Shift+Control+Alt+E (Win), Shift+Command+Option+E (Mac) Show/Hide effects panel

Shift+Control+V (Win), Shift+Command+V (Mac) Insert stencil slides

Shift+Control+G (Win), Shift +Command+G (Mac) Edit gradient

Shortcut key Magnification level

Control+1 (Win), Command + 1 (Mac) 100%

Control+2 (Win), Command + 2 (Mac) 200%

Control+3(Win), Command + 3 (Mac) 300%

Control+4 (Win), Command + 4 (Mac) 400%

Control+ - (Win), Command + - (Mac) Zoom out

Control++ (Win), Command + + (Mac) Zoom in

Control + 0 (win), Command + 0 (Mac) Best Fit Zoom / Center Align Workspace

Shortcut key Action

Control+R (Win), Command + R (Mac) Start/record new capture project

Control+Alt+O (Win), Command+Option+O (Mac) Record additional slides

End (Win), Command+Enter (Mac) Stop recording

Delete (Win & Mac) Delete the current selection

Pause (Win), Command+F2 (Mac) Pause or resume recording

Print Screen (Win), Command +F6 (Mac) Capture a screenshot manually

F4 (Win & Mac) Preview project

F3 (Win & Mac) Preview single slide

F2 (Win & Mac) Edit caption text

F12 (Win & Mac) Preview project in browser

F4 (Win), Command+F4 (Mac) Auto panning

F3 (Win), Command+F3(Mac) Manual panning

F7 (Win), Command+F7(Mac) Stop panning
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Change shortcut keys for recording
1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select Keys from the Recording menu.

3 To change keys, click once in one of the text boxes and, on the keyboard, press the key or key combination you want 
to use. For example, click inside the To Stop Recording text box and then press Shift+Alt+4. The key combination 
you entered now appears in the To Stop Recording text box. You can use almost any key, including the Control, Alt, 
Shift+Control, and Shift+Alt keys. For example, you could change the stop recording key to Alt+R. 

Working with the filmstrip
The Filmstrip displays all the slides in the project in the order in which they appear when published. 

You can change the order of a slide by dragging it to a new location within the Filmstrip. To select multiple slides, hold 
down the Shift or Control key when clicking on slides. To select all slides, press Control+A.

To change the size of the thumbnails in the Filmstrip, right-click (Windows) or Control-click (Mac OS) on any slide, 
select Filmstrip, and then select Small, Medium, or Large.

If a slide has a label (short title) assigned, the label appears under the slide. It might be easier to move slides and jump 
to a specific slide if you have assigned labels instead of just using the slide number.

A Slide Label  B Slide Number  

A handycam icon appears at the bottom of slides if the slide was recorded in:

• Video Demo mode

• Full Motion Recording (FMR) mode. You can record in the FMR mode by pressing F9 (to start FMR) and F10 (to
end FMR) while doing Automatic or Manual recording.

If a slide has an audio file associated with it, the audio icon appears at the bottom of the slide. You can click the sound 
icon to show a menu with sound options such a Play, Import, and Edit.

F9 (Win), Command+F9 (Mac) Start Full Motion Recording

F10 (Win), Command+F10 (Mac) Stop Full Motion Recording

F11 (Win), Command+F11 (Mac) Snap recording window to mouse

F12 (Win), Command+F12 (Mac) Toggle mouse capture



84
Workspace

Last updated 10/10/2016

If a slide is locked, the lock icon appears on the upper-right corner of the slide. You can click the lock icon to unlock 
the slide.

If a slide contains mouse movement, the mouse icon appears at the bottom of the slide. You can click the mouse icon 
to modify some of mouse properties. For more information on mouse properties, see Change mouse properties.

Disable confirmation messages in Adobe Captivate
Confirmation messages appear when you perform important, and often permanent, actions in Adobe Captivate. The 
confirmation messages give you an opportunity to reconsider your decisions when deleting information or changing 
key attributes. 

If you find that certain messages are not necessary for the way you work or are slowing down your work, you might 
want to disable them. 

1 In an open project, select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Category panel, select Global > General Settings.

3 Click Confirmation Messages in the General Settings panel.

4 In the Confirmation Messages dialog box, deselect the options for which you do not require confirmation messages.

How to customize the Adobe Captivate workspace
You can create a custom workspace by rearranging and resizing document windows and panels. You can save the 
customized workspaces and switch between them.

Rearrange document windows
When you open more than one file, the Document windows are tabbed. To rearrange the tabbed Document windows, 
drag and drop the window’s tab to the new location.

Move panels
• To move a panel, drag it by its tab.

• To move a panel group, drag the title bar.

As you drag the panels, you see blue highlighted drop zones, areas where you can drop the panels. If you drag to an area 
that is not a drop zone, the panel floats freely in the workspace.

Note: The position of the mouse pointer, rather than the position of the panel, activates the drop zone.

Press Ctrl (Windows) or Command (Mac OS) while moving a panel to prevent it from docking. Press Esc while moving 
the panel to cancel the operation.

Dock and undock panels
A dock is a collection of panels or panel groups displayed together, generally in a vertical orientation. You dock and 
undock panels by moving them into and out of a dock.

• To dock a panel, drag it by its tab into the dock, at the top, bottom, or in between other panels.
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• To dock a panel group, drag it by its title bar (the solid empty bar above the tabs) into the dock.

• To remove a panel or panel group from a dock, drag it out of the dock by its tab or title bar. You can also drag it into
another dock or make it free-floating.

• To resize a panel, move the mouse over the edges of the panel. When double-sided arrow appears, drag the panel to 
the required size.

Add and remove panels from docks
If you remove all panels from a dock, the dock disappears. You can create a dock by moving panels to the right edge of 
the workspace until a drop zone appears.

• To remove a panel, right-click (Windows) or Control-click (Mac) its tab and then select Close, or deselect it from
the Window menu.

• To add a panel, select it from the Window menu and dock it wherever you want.

Stack floating panels
When you drag a panel out of its dock but not into a drop zone, the panel floats freely. The floating panel allows you to 
position it anywhere in the workspace. You can stack floating panels or panel groups so that they move as a unit when 
you drag the topmost title bar.

• To stack floating panels, drag a panel by its tab to the drop zone at the bottom of another panel.

• To change the stacking order, drag a panel up or down by its tab.

Note: Be sure to release the tab over the narrow drop zone between panels, rather than the broad drop zone in a title bar.

• To remove a panel or panel group from the stack, so that it floats by itself, drag it out by its tab or title bar.

Resize panels
• To minimize or maximize a panel, panel group, or stack of panels, double-click a tab. You can also single-click the

tab area (the empty space next to the tabs).

• To resize a panel, drag any side of the panel when the mouse cursor turns into an arrow.

Collapse and expand panel icons
You can collapse panels to icons to reduce clutter on the workspace. In some cases, panels are collapsed to icons in the 
default workspace.

• To collapse or expand all panel icons in a column, click the double arrow at the top of the dock.

• To expand a single panel icon, click it.

• To resize panel icons so that you see only the icons (and not the labels), adjust the width of the dock until the text
disappears. To display the icon text again, make the dock wider.

• To collapse an expanded panel back to its icon, click its tab, its icon, or the double arrow in the panel’s title bar.

• To add a floating panel or panel group to an icon dock, drag it in by its tab or title bar. (Panels are automatically
collapsed to icons when added to an icon dock.)

• To move a panel icon (or panel icon group), drag the icon. You can drag panel icons up and down in the dock, into
other docks (where they appear in the panel style of that dock), or outside the dock (where they appear as floating,
expanded panels).
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Save customized workspaces
By saving the current size and position of panels as a named workspace, you can restore that workspace even if you 
move or close a panel. The names of saved workspaces appear in the workspace switcher in the Application bar.

1 Go to Window > Workspace > New Workspace.

2 Type a name for the new workspace, and click OK.

Any changes that are made to the workspace are saved automatically. To revert to the default state of a workspace, select 
Window > Workspace > Reset [Workspace Name].

Switch workspaces
Select a workspace from the workspace switcher in the Application bar.

Rename and delete workspaces
Select Window > Workspace > Manage Workspace.

• To rename a workspace, select the workspace and click Rename.

• To delete a workspace, select the workspace and click Delete.

How to use the Adobe Captivate library

Library overview
An Adobe Captivate library is a repository of resources, such as, audio files, images, and animations. Every Adobe 
Captivate project contains its own library. 

Resources or ‘items’ are automatically added to the library when you use them in the project. However, you can also 
import them into the library and use them when needed.

By default, the Library panel is displayed in all the preset workspaces, except in the Quizzing workspace. To hide (or 
show) the Library panel, select Window > Library.

The items in the library are categorized and organized in folders, such as, Audio, Images, and Media. The following 
information is displayed for each item: 

• Name 

• Type

• Size (in kilobytes)

• Use Count, which indicates the number of times the item is used in the project.

• Date Modified

Note: Click the title of any of these columns to sort the list of items within each folder.

Using the Library panel, you can do the following:

• Edit the properties of the items.

• Reuse the items within a project as well as across other Adobe Captivate projects by exporting or importing them.
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• Synchronize the items with their source files. You can also open and edit the source files directly in the supported
programs.

Import objects into the Library
You can import objects from other Adobe Captivate projects or templates into the library of your current project.

1 Select File > Import > External Library.

2 In the Open dialog box, navigate to and select the Adobe Captivate project or project template from which you want 
to import objects.

3 Click Open. The external library panel appears.

4 Drag-and-drop the required items from the external library panel to the current project’s library.

How to use the Branching panel in Adobe Captivate
The Branching panel (Window > Branching View) provides a visual representation of all links between the slides in a 
project and lets you quickly edit those links. Using this panel, you can analyze and interpret how the slides in a project 
are interlinked. 

The Branching panel is particularly helpful when creating instructional materials containing question slides and 
specifying different paths for right and wrong answers. For example, you can set one action (such as “Go to the next 
slide”) when a user supplies a correct answer, and you can set a different action (such as “Jump To Slide”) when a user 
supplies an incorrect answer. Using the Branching view, you can easily make changes to the branching design.

You can also export the Branching view of an existing Adobe Captivate project into a BMP, JPEG/JPG, PNG, or a GIF 
file.

Panes in the Branching panel

Preview pane
This pane is at the bottom of the panel and displays all the slides in the project. If the pane is not visible, click the arrow 
at the bottom of the panel. 

The rectangle in the pane indicates the slides that are currently displayed in the main pane. To bring a different set of 
slides into the main pane, click and move the rectangle to the required area.

Main pane
This pane is at the center of the panel and is the main area where you interpret and edit the branches in your project. 
The arrows between the slides indicate how they are related to each other.

Black Arrow Indicates that the slide from which the arrow originates does not have any interactive object. During 
runtime, after this slide's duration elapses, the next slide (to which the arrowhead points) appears.

Green Arrow Indicates that the slide from which the arrow originates contains an interactive object. When users click 
this object during runtime, the slide to which the arrowhead points appears.
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Red Arrow Points to the slide that appears when users fail to click an interactive object on the slide from which the 
arrow originates.

When you click an arrow, a pop-up appears and shows the name of the object that links the slides.

Options in this pane:

Create Slide Group Combines the selected slides into a single group. For more information on grouping slides, see 
Grouping slides using the Branching view.

Expand Slide Group Displays all the slides belonging to the selected group. The slides in a group are by default in a 
collapsed state.

Collapse Slide Group Combines the expanded slides of a group back into a group.

Remove Slide Group Ungroups the grouped slides.

Export Branching View Export the Branching view as a BMP, JPEG/JPG, PNG, or a GIF file using the dialog box that 
appears.

Zoom Zooms the main view in or out based on the value selected in the list or the slider.

For more information on using this pane for editing the slide links, see Editing the links between slides.

Unlinked slides pane
This pane lists all the slides that are not linked to any slide in the project. If this pane is not visible, click the arrow on 
the left of the panel.

Editing the links between slides
To change the linkage of a slide, double-click the thumbnail of the slide, and in the pop-up that appears, choose an 
option in the Action (Success) list.

To change the linkage of an interactive object, double-click the thumbnail of the slide, and click the object. In the pop-
up that appears, choose an option from the Action (Success) and Action (Failure) lists, and click the Save icon.

For example, consider Slide 1 has a button. When users click the button, Slide 4 must appear and when the button is 
not clicked (Failure), Slide 23 must appear. Using the pop-up box, you can specify the slides for success and failure 
events accordingly. If the target slide (Slide 23) contains an interactive object that brings the users back to Slide 1, a 
reverse-link to Slide 1 appears below the slide.

The Action (Success) and Action (Failure) lists show the following options:

• Go to the Next Slide

• Go to the Previous Slide

• Jump to Slide

To assign other actions such as send an email or open a URL or a file, use the Property Inspector of the slide. The 
Advanced Interaction panel (Project > Advanced Interaction) helps you view all the interactions in the project.
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Grouping slides using the Branching view
1 Click in the panel (not on any slide), hold down the mouse button, and move the mouse over the slides you want to 

group.

A rectangular marquee appears and the selected slides are highlighted with a bold border around them.

2 Click the Create Slide Group icon. A single group slide appears in the panel.

• To expand the group, click the arrow on the group slide, or select the group slide and click the Expand Slide
Group icon.

• To ungroup the slides, select the group slide and click the Remove Slide Group icon.

Note: Use the Property Inspector to name the group slide. For more information, see Name slide groups and mark them.
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Chapter 3: Creating Projects

Responsive Project Design with Adobe Captivate

Responsive Project Design
With a single project, you can design and create content in multiple layouts for devices. You can also preview using 
Adobe® Edge Inspect across devices.

Create content with five breakpoints: 

• Desktop with a viewport of 1024x627,

• Tablet Landscape with a viewport of 896x627

• Tablet Portrait with a viewport of 768x627

• Mobile Landscape with a viewport of 667x410, and

• Mobile Portrait with a viewport of 360x460

Preview the output using play slide in respective device layouts. Publish the content as HTML5.

Adobe Captivate enables you to drag and drop objects with a seamless experience across all the three breakpoint views 
in responsive projects. 

For information on View-specific properties of Responsive project, see How to apply view specific properties in 
responsive projects

You can view the Align panel by clicking Window > Align.

Creating a Responsive Project
1 After launching Adobe Captivate, click the first thumbnail on the home screen, Responsive Project and click Create. 

Alternatively, you can choose File > New Project > Responsive Project.

2 Click the Desktop, Tablet, and Mobile icons in the Responsive Project layout to navigate through the different 
breakpoints.

You can view the responsive project area divided into six unique breakpoints as shown in the screenshot below. Each 
breakpoint area is a unique authoring space.
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Adaptive design (Smart positioning)
You can see sliders available at the beginning and end of each breakpoint.

By default, five breakpoints are available for you to author content.

If you create content for any device bigger than the viewport size of the mobile layout, you can increase the size by just 
dragging the slider.

Note: Any size above the default viewport size would assume the next higher viewport layout. For example, if you want to 
have the mobile viewport as 450x450 instead of the default values. In such a case, since this size is higher than the Mobile 
and lesser than Tablet, it would assume the layout of Tablet.Smart positioning is allowed in between breakpoints. Adobe 
Captivate enables you to preview the projects with seamless experience in between breakpoints. In other words, users do 
not experience any time lag in preview of output while traversing from one view to another view in between breakpoints.

Customize Theme colors
You can choose the Preset Theme Colors or customize Theme Colors to make your own color schemes.

1 From the Toolbar, click Themes > Theme Colors

2 Choose any one of the Preset Theme Colors from Select Theme Color drop-down and clickCustomize. Customize 
Theme Colors window appears as shown below:

3 Choose the component for which you want to change the colors. You can change the colors of each component of 
slide such as Title, Skin, Sub Title, Slide BG.

4 You can pick the color with the help of Shades, or Swatches, Color Picker, or Eyedropper tools.

5 Click the title of the Preset Theme and use your own title name.

6 Click Save. Now, you can see your customized Theme color displayed in the drop-down list.

You can use Settings wheel icon, to Manage the theme colors: Delete, rename.

Device height
Set different backgrounds in different views through inclusion/exclusion of objects.
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You can also set the device height for each layout by selecting the Device Height check box in the Property Inspector. 
If Device Height is selected, you can see the yellow border for each layout as shown in below screenshots for Mobile 
layout.
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Slide Height can be linked to Device Height by clicking the link icon next to Slide Height in Properties window as 
shown in the screenshot below. Change the slide height for specific view or for all views. 

Slide Height
Adobe Captivate also allows you to customize the height of viewport as per the device height.

Viewport height is the page layout height for Primary (Desktop), Tablet, and Mobile. You can adjust this height to fit 
any specific device height with the help of Slide Height option in Properties.

Note: Unlink the slide height from the device height in order to modify it.

Customizing Slide Height
Let us assume the viewport height and device height for mobile layout is 415. Consider a case where the device height 
is 500, you can adjust the viewport height by moving vertical device height slider until you reach 500. By default, the 
device height is linked with Slide Height. You can de-link it by clicking the link icon next to Slide Height value in the 
Property Inspector. 
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In this case, all the content inside viewport height is visible in mobile device, by default. So, this provision enables you 
to develop content accurately in the layout to match the device height.

If the viewport height is bigger than the device height, then the content beyond device height is visible to the end user 
with the help of a scroll bar in the device. 

Now, you can align any object at center of the slide in all breakpoints of responsive projects. Horizontal and vertical 
center alignment options are introduced in Captivate 9.

1 Insert any smart shape in the primary breakpoint slide. 

2 Click the smart shape and view position tab in Property inspector. 

3 Click Advanced. You can see the horizontal and vertical center alignment options as shown in the snapshot. 

Now, you can align any object at center of the slide in all breakpoints of responsive projects. Horizontal and vertical 
center alignment options are introduced in Captivate 9.

1 Insert any smart shape in the primary breakpoint slide. 

2 Click the smart shape and view position tab in Property inspector. 

3 Click Advanced. You can see the horizontal and vertical center alignment options as shown in the snapshot. 

Align objects
Now, you can align any object at center of the slide in all breakpoints of responsive projects using Captivate's horizontal 
and vertical center alignment options.

1 Insert any shape or object in the primary breakpoint slide.

2 Select it and view the Position panel in the Property Inspector. Click Advanced.

3 Click Advanced. 

You can see the horizontal and vertical center alignment options as shown in the snapshot. 
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4 You can choose horizontal and vertical center alignment options by right-clicking on the object and selecting Align 
as shown here.

5 Alternatively, you can use the icons from the window align panel as shown here. 

Note: Enable the Align panel view, by clicking Window > Align.

Horizontal center alignment - if you apply this alignment, then you can move the object only in vertical direction 
in the slide. Its horizontal movement is restricted. 

Vertical center alignment - if you apply this alignment, then you can move the shape only in horizontal direction 
in the slide. Its vertical movement is restricted. 

Both horizontal and vertical center alignment - if you apply both the alignments then movement is restricted in 
both the directions. 

Color coding of the center and vertical alignment options is supported. The border color of two check box options 
attains the color scheme of breakpoint at which the alignment options are chosen. 

Note: If you have multiple shapes, then you can align a single object on the center of the slide and link the rest of the objects 
to the centered object to achieve slide centered flowcharts at all breakpoints.If you de-align horizontal or vertical center 
option, the object does not move back to its original position. 

Set Default Caption Colors
You can set different default caption Text colors for the breakpoint views. 

1 Choose Edit > Object Style Manager

2 Select Default Caption Style

3 In Text Format, Click drop-down box next to Break Points and choose Desktop, Tablet Portrait, or Mobile Portrait.

4 Choose the color for each breakpoint.
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Capture support for interactions
You can capture the interactions across all views and set autofocus for a specific interaction area in views. Set one smart 
shape as background image in Responsive project and you are allowed to set crop area for background image in 
different views.

Questions and Results slides, along with Master Slides are supported seamlessly across all the views in the Responsive 
Project.

Responsive properties and Themes are applicable for Question slides. Overridden styles are indicated by a star symbol 
in Sample Text area of the Property Inspector.

Responsive capture

Responsive playbar
Make playbar controls responsive. From Windows>Skin Editor, you can create a customized skin by changing the 
playbar controls and saving the changes as a theme. Now, you can make playbar controls appear differently in Primary, 
Tablet, and Mobile views. 

Customize cpMobilePlaybar variable to view different playbar controls in each of the Primary, Tablet, and Mobile views 
outputs. 

1 Go to Playbar Location:

C:\Program Files\Adobe\Adobe Captivate 8 x64\en_US\Gallery\Playbars\HTML\cpPlaybarMobileStep text

Note: The location varies as per the installation directory in your computer. 

2 Create a backup for the playbar you would like to change.

3 Open the playbarScript.js file
cp.responsiveButtons =  
{ 
//"ButtonName": [Primary,Tablet,Mobile], 
"Rewind": [true,true,false], 
"Backward": [true,true,true], 
"Play" : [true,true,true], 
"Slider": [true,true,false], 
"Forward": [true,true,true], 
"CC" : [true,true,true], 
"AudioOn": [true,false,false], 
"Exit" : [true,true,true], 
"FastForward": [true,true,false], 
"TOC" : [true,true,false] 
};

4 If you want each of the playbar control buttons to appear in Primary, Tablet and Mobile views, change the above 
code to [true,true,true] for all the buttons. Save and close the file. 

For example, if you want the "Slider" to appear only in Tablet and Mobile views, then edit the code as follows: 

"Slider" : [false, true, true] 
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Note: If you want a different playbar to be responsive, follow the same procedure mentioned above but copy the 
responsive function in the js file first.The first preference is given to the checkboxes in skin editor. If they are not selected, 
then irrespective of the value of true or false that button does not appear in the playbar.

5 Relaunch Captivate and the playbar is updated. 

Responsive capture (Responsive simulation) 
Create a single screen capture that can be used across multiple screens and devices. Adobe Captivate allows you to 
choose the portion of the screen capture you want to display on smaller screens.

1 Open a Captivate Responsive Project

2 Click Slides > Software Simulation

Record Additional Slides window appears. 

3 Choose the slide after which you want the recorded slide to be inserted and click OK. 

Screen Capture screen window appears. 

4 Select recording type as Automatic or Video demo or Manual and click Record to capture the screens. 

Note: Use manual recording when you want to pick and choose a few screenshots during the recording process. When 
you record using automatic recording, Adobe Captivate captures screenshots automatically and places them on separate 
slides. Automatic recording is the most commonly used recording method in Adobe Captivate.

5 In Responsive Project, click Mobile view.

The screen capture realigns itself and appears as shown here: 
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6 You can observe that the background is skewed. 

You can use a portion of the background image in Mobile view. 

7 In the Property Inspector, click Use portion of background image. You can move the slide capture to the background 
portion of your choice. 

Now, you can notice the difference from previous view. 
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Drag and drop interaction
Adobe Captivate supports drag and drop interactions for responsive projects.

Drag-and-drop interactions provide an interesting and engaging way of assessing your users’ knowledge. This 
interaction lets users answer questions by dragging and dropping objects in the designated areas or objects.

A drag-and-drop interaction involves a drag source and a drop target. Users drag the drag sources and drop them onto 
drop targets.

In responsive project, you can run the drag and drop interaction wizard by choosing Insert > Launch Drag and Drop 
Interaction Wizard. You can also choose Interactions > Drag and drop as shown in the snapshot below: 

All the features of drag and drop interaction in Responsive projects are similar to the blank projects as well. For 
information how to create a drag and drop interaction, various features of the interaction and best practices see Create 
drag-and-drop interactions in Adobe CaptivateCreate drag-and-drop interactions in Adobe Captivate

Working with responsive text in Adobe Captivate

Overview
Responsive text is an important responsive feature. 

You can set text sizes across all breakpoints using Edit > Object style manager> Text format. Sample text displays the 
changes in different views. 

You can also view the dynamic changes in text by moving from one breakpoint to another in Responsive project. You 
can also edit text dynamically in each breakpoint view. 

Link break for text across views
Captivate maintains a parent-child relationship among the breakpoints from Desktop-to-Tablet views and Tablet-to-
Mobile views respectively. The settings you make for a breakpoint exist in all the lower breakpoint views unless you 
modify the settings for a particular view and break the link.

Note: This relationship does not flow from Mobile to tablet and from tablet to Desktop.
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Illustration to demonstrate how link breaks
For example, let us consider that you created text caption in Desktop view, then in tablet view and then in the mobile 
view of responsive project. In this case, if you move to Mobile breakpoint view, you can see three text captions available 
in tihs view. If you click each text caption you can see the text caption border representing the corresponding breakpoint 
view color. You can see this demonstrated in the figure below: 

Now, the first text caption has a link connected to Desktop view. The second text caption has a link connected to tablet 
view. You are able to understand this link based on color coding. Suppose, in mobile view, you modified the text in 
second text caption (that is, the text created earlier in tablet view as shown in the above figure) then the existing link 
for this text caption from tablet view is broken and it is considered as a native text caption for mobile view. You can 
understand this broken link based on the text caption border color for the second text. Now, in this case the second text 
caption also shows orange color and not the blue color. 

Similarly, if you modify the text in first text caption then also the first text caption link with Desktop view will be broken 
and it is considered as a native text caption of mobile view. You can see this illustrated in the below figure. 
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Note: The above illustration demonstrates how a link breaks with reference to text in each view. The links among text 
captions across each view may be broken due to various other factors including but not limited to text, position, and 
position properties. 

Restore link across views
When a link is broken between a mobile and tablet or between a tablet and primary breakpoints, you can restore the 
link by applying the position, text and text properties across all the views. 

Apply properties to all views

Position properties
Now you can update position properties of objects across all views to match the properties of the currently selected text 
element. To support applying the object position properties across all the views, right click context menu is included. 
This setting will re-link objects across the views in responsive projects. 

Suppose you created couple of text captions in primary view but while working on the project, you moved the position 
of text caption un-intentionally in tablet and mobile views. Later, you realized this change and want to retain the 
original position that you are using in primary view to be retained in all other views as well. In this case, you can select 
the text caption in primary view, right-click and click Apply position properties to all views. 

Text and text properties
Reset the properties of responsive text elements or update all views to match the properties of the currently selected 
text element. To support applying the text and text properties across all the views, right click context menu is included. 
This setting will re-link objects across the views in responsive projects. 

For example, let us consider that you created couple of text captions in primary view but modified the text and text 
properties (such as character, style, and so on ) in tablet and mobile views. At a later stage, if you want to retain the 
primary view text and text properties to all the other views, you can do it by right-clicking the text caption in primary 
view and applying the text and text properties to all views. 

Even if you apply multiple text formats like color or font style to each word, the text retains the format in all responsive 
project views. Hierarchical ordered and unordered list of items (such as bulleted text) flow across all views. 

If you already set any text properties for each breakpoint in object style manager (OSM), then the OSM settings are 
retained. Any subsequent change in each breakpoint does not override the OSM settings. 

Auto grow 
Adobe Captivate supports adjusting the text font size to fit the text in the text captions of Primary, Tablet, and Mobile 
views, along with in-between views. But, if you are still facing text truncation issues, use Auto or %Relative size options 
for text caption height and the caption will auto grow to accommodate all the text in the caption. 



102
Creating Projects

Last updated 10/10/2016

Color coding 
Text objects in different views of responsive projects can have color coding. We can see different color coding in text 
area boundaries in properties window. Earlier, it was applicable for only position properties.

In a responsive project, each breakpoint view has a different color. You can see this color at the top of the breakpoint 
view. For example, the purple color in the below image indicates the Desktop view.

Now, the text created in the Desktop view represents the color code of blue around text caption border in properties 
window. Similarly, the text created in Tablet view represents green and text of Mobile view represents orange color code. 

Working with themes in Adobe Captivate
Themes help your project look better with coordinated colors, well-planned layouts for slides, fonts and effects. When 
you create a project, a default theme is applied to the project. You can change the theme by choosing one of the 
preloaded themes that are shipped along with Adobe Captivate. You can customize a theme, save it as a different theme, 
and reuse it for other projects.

Constituents of a theme
Each theme consists of the following:

• Master slides (a minimum of seven)

• Main master slide, prefixed with the name of the theme

• Content master slide

• Question master slides (5 numbers)

• Object styles. For example, the 'Woody' theme contains styles such as Woody caption style, Failure, and Success
captions.

• Skin and TOC settings related to the theme

• Recording defaults

For a description about these slides, see How to work with master slides in Adobe Captivate.

You can modify each of these component of a theme. For more information, see Customize themes.

The Themes bar (Themes > Themes) shows a representative content master slide of a theme.
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Templates and themes
The difference between templates and themes is that templates decide 'when' and 'where' content (including media) is 
to be placed while themes decide how the project looks. For example, consider that you want a standard approach to 
all the elearning courses developed by your team. You require a pretest followed by content and then a post-test. You 
can create a template with the required type of slide placeholders and also decide the number of slides that each of these 
sections contain.

On the other hand, if you need an aquatic theme for the project background with coordinated colors for the slides, you 
apply a theme.

The recommended workflow is to use a theme within the project template. By doing so, you can ensure that the projects 
based on the template use a standard theme.

Apply themes
Click Themes icon in the toolbar, select any default or customized theme of your choice from the drop down and click. 
You get a dialog asking you to confirm if you are ok with overriding existing styles and properties with this new theme. 
Once you confirm, the theme is applied to your project. 

You can browse for more themes from the drop-down, choose any .cptm file and apply the theme to your project. 

For Adobe Captivate to apply themes effectively, ensure that you use uniform styles for objects. For example, all text 
captions can be of a one single style.

You can apply themes to projects directly or use them in project templates for a standard look and feel. 

When you apply a theme to a project:

• For each slide in the project, Adobe Captivate compares the linked master slide layout with those on the master
slides in the theme you apply. If a matching layout is found, the slide is mapped to that master slide. If a match is not 
found, Adobe Captivate creates a new master slide and then maps the slide.

• Objects, layouts, skin editor, and TOC that use default settings of the existing theme are mapped to the respective
default styles in the applied theme. Any overrides to these elements are not retained in the project.

When you copy and paste a slide into another project, the theme of the target project is applied to the slide. If the slide 
contains objects and layouts that were overridden, the overridden settings are retained.

When you record a software simulation in a project, default captions and highlight boxes are mapped to the 
corresponding styles in the project theme.

Customize themes
You can customize a theme by editing the constituent master slides, object styles, skin, theme colors, and TOC settings.

For information on customizing:

• Master slides, see How to work with master slides in Adobe Captivate.

• Object styles, see Working with object styles in Adobe Captivate.

• Theme settings in the skin of a project, see Skins.

• Theme settings in TOC, see Table of contents (TOC) .

• Recording defaults, see Set recording preferences in Adobe Captivate.

• Theme colors, see Customize Theme colors.

To save a customized theme, click Themes > Save Theme. Themes are saved as CPTM files.

http://helpx.adobe.com/en/captivate/using/table-contents-toc.html#table_of_contents_toc
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Reuse themes across projects
1 I f you have modified a theme, save the changes by clicking Theme > Save Theme. The themes are saved as CPTM 

files.

Changes to master slides, object styles, skin editor, and TOC theme settings now become a part of the saved theme.

2 Open the project in which you want to reuse the theme.

3 Click Themes icon on the toolbar to view the drop-down list of default and customized themes, and click the theme 
that you saved earlier to apply it to your project. 

More Help topics 
What's New in Adobe Captivate 8

Create projects

Create different types of projects in Adobe Captivate

Create a project to include software simulation
You can create an Adobe Captivate project by recording events in an application or screen area on your computer. The 
following modes of recording are available.

Automatic Recording

Adobe Captivate captures screenshots automatically and places them in separate slides. For more information, see 
Automatic recording.

Manual Recording

You can manually capture screenshots using this option. The chosen set of screenshots appears sequentially in separate 
slides after the recording is complete. For more information, see Manual recording.

For more information, see Record video demonstrations with Adobe Captivate.

Create a project from PowerPoint presentations
You can import an entire PowerPoint presentation, or only selected slides into an Adobe Captivate project. Each 
PowerPoint slide is imported as a separate slide in the Adobe Captivate project. You can later edit the PowerPoint 
presentations from within Adobe Captivate. 

Create a project from images
Projects created from images can be viewed as a slideshow. Each image is imported into a separate slide.

1 Select File > New Project > Image Slideshow.

2 In the New Image Slideshow dialog box, set the dimensions of the project.

3 Click OK, and select the images that you want to add to your project.

https://helpx.adobe.com/captivate/using/whats-new-cp8.html
https://helpx.adobe.com/captivate/using/create-projects.html
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4 If the Resize/Crop image dialog box appears, set the following options:note: You see the Crop/Resize dialog box only 
when an image exceeds the height or width limits of the project. If you are inserting more than one slide, only those 
images that exceed the dimension limits are displayed in the dialog box.

Fit To Stage Resizes the image to fit the dimensions of the slide.

Crop Displays a bounding box with dimensions corresponding to that of the project. Resize the handles of the box 
to select the area that you want displayed on the slide. If you selected Constrain Proportions, Adobe Captivate 
maintains the height-to-width ratio of the bounding box.

Zoom You can zoom in and zoom out of the image by moving the slider. Alternatively, you can choose from a list 
of standard zoom sizes from the menu.

Constrain Proportions Maintains the height-to-width ratio of the bounding box used to crop the image. This option 
is enabled only when you choose to crop the image. When you disable this option, resize the bounding box, and 
enable the option again; the new dimensions are used thereafter to calculate the ratio.

In addition to the above options, you can also set tone controls (brightness, sharpness, and contrast) and adjust color 
ranges (alpha, hue, and saturation). You can also flip or rotate the image.

Create a project starting with blank slides
You can start with a blank project, and then import slides or images from PowerPoint presentations, images, or other 
Adobe Captivate projects. You can also add a software demonstration, or interactive simulation by recording additional 
slides.

1 Select File > New Project > Blank Project.

2 Select a preset size in the Select list, or specify a custom width and height for the project.

3 Click OK.

The default theme is applied to the new project. The theme contains a set of master slides that you can use for title, 
content, and question slides. For more information, see Working with themes in Adobe Captivate.

Create a responsive project
You can create a project whose content and design can be viewed across multiple devices such as desktop, tablet, and 
mobile. 

More Help topics 
Responsive Project Design

Preview and publish responsive projects

Create template-based projects
Adobe Captivate templates allow you to improve consistency across similar projects or modules of a project and reduce 
the effort required to create new projects.

Create a storyboard and workflow
No matter what project you want to create, it is helpful to do some planning before you start taking screenshots. 
Consider first what you want the user to do, learn, or achieve as a result of viewing your project. Defining this goal 
allows you to create a comprehensive plan for success. Once you have defined the action you want the audience to take, 
you can create the “core” of the project.

http://helpx.adobe.com/en/captivate/using/responsive-project.html
http://helpx.adobe.com/en/captivate/using/preview-publishing.html
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Every movie tells a story. A storyboard is a written version of that story either in the form of text or graphics. It tells you 
whether you have a clear understanding of what you are about to present to your audience. You can use the 5W, 1H rule 
adopted in journalism to get your story straight—who, what, when, where, why, and how.

You can create a workflow readily when you have a storyboard in place. A workflow is the flow of information in a 
project that follows the rules you create for it. For example, you can have a nonlinear presentation in which you can 
move back and forth between slides, skip slides, or set rules for slide sequence. Defining the workflow in advance helps 
you complete your project earlier, with minimal changes during the editing cycle.

If your project includes a great deal of text (captions), a script is the best place to begin. Scripts use text-based pages. 
They are like pages in a book: logical, sequential, and containing as much detail as you care to provide. 

Create project templates
When you want to create similar projects or similar modules in a project, use project templates to ensure consistency 
and save time. Project templates are especially useful when multiple authors are working on different project modules 
or on similar projects.

Project templates help achieve the following:

• Consistency across Adobe Captivate projects.

• Reduced development time for multiple projects due to reuse of design.

• Reuse of project preferences across multiple projects.

In a collaborative environment where the designers work separately from the people creating the content, designers use 
templates to ensure consistency across projects. Content developers do not have to worry about the workflow of the 
project, the various standards involved, or the creation of the layout. All they have to do is follow the instructions in the 
template and provide the required content in the relevant placeholders.

Creating a repository of templates requires a disciplined effort involving all stakeholders. However, the effort pays for 
itself over time in terms of reduced development time for projects.

An Adobe Captivate project template consists of the following:

• Slides with placeholders for various Adobe Captivate objects

• Placeholders for the following:

• Recording slides

• Question slides.

• Master slides. For more information on Master Slides, see How to work with master slides in Adobe Captivate.

You can define and use object styles along with the project templates to ensure a uniform appearance for your projects.

When you create a project using a template, the placeholders in the template are marked with a placeholder icon. The 
icon disappears when you insert an object into a placeholder.

Note: The placeholder objects are not visible when you preview or publish a project created with a project template.

In addition to placeholders, you can add all Adobe Captivate objects and supported media to templates. The template 
serves as a ‘stencil’ only. Users can change the objects and placeholders without any restriction when creating a project 
from the template.

To make a project template more effective, add slide notes providing information or instructions. Include information 
on the recommended types and properties of objects, media, or slides that users are to insert in the placeholders.

1 Select File > New Project > Project Template.
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2 Specify the dimensions of the project template, and click OK.

3 Set preferences for the template using the Edit > Preferences dialog box. The preferences are automatically applied 
when you use the project template to create a project.

4 Choose the look and feel for projects based on the template by clicking Themes > Themes. The Themes bar appears. 
Click the required theme from the Themes bar.

You can also modify the theme to suit your requirements. For more information on themes, see Working with 
themes in Adobe Captivate.

Note: If you do not want to use themes, you can create your own layouts by inserting placeholder objects on the slides 
(Insert > Placeholder Objects).

5 To insert placeholders for slides, select Insert > Placeholder Slides, and choose the type of slide placeholder. 

6 Insert other Adobe Captivate objects, and required media.

Best practice is to add all objects or media that do not change from project to project (for example, a logo) as actual 
objects. Use placeholders for objects or media that are specific to the project.

7 Save the file. The file is saved with a .cptl extension.

Create projects from project templates
1 Select File > New Project > Project From Template.

2 Navigate to the template file and click Open.

3 Double-click the placeholder and do the following: 

• For placeholder objects, use the respective dialog box to add objects to the placeholder. The placeholder is
converted to a concrete object.

• For recording slide placeholders, double-click the placeholder slide to start recording.

• For question slide placeholders, double-click the placeholder slide to insert a question slide.

More Help topics 
Microsoft PowerPoint

Images and rollover images

How to apply view specific properties in responsive 
projects

View-Specific Properties
Apply view specific properties by controlling the size, position, and characters of the object. Create objects in one view 
and make them visible or invisible to other views.

You can also make the objects view specific. For example, you can create objects A, B, and C in Primary breakpoint 
view. But, you would not want to use B in Tablet and C in Mobile breakpoint views. You can achieve this in Responsive 
Project by moving object B out of slide into scrap area in Tablet view. And, by moving object C into scrap area in Mobile 
view.

http://helpx.adobe.com/en/captivate/using/microsoft-powerpoint.html#microsoft_powerpoint
http://helpx.adobe.com/en/captivate/using/images-rollover-images.html
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Alternatively, to make the object appear in only one view, right-Click the object, and choose Exclude from Other Views 
as shown in the screenshot below: 

Applying View Specific Properties
1 Create a Responsive Project and add couple of Smartshape objects in the Primary breakpoint slide

2 Switch to Tablet and Mobile breakpoints and observe You can view the same objects of Primary view in Tablet and 
Mobile views

3 Click the object to highlight it and click Properties > Position tab In Position tab, you can see the object positions 
drop-down boxes highlighted such as Top, Left, Bottom, Right, Height and Width.
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4 Click the drop-down boxes for each position and choose the value types such as %, px (for pixels) and relative % 
(relative to the overlay objects).

5 Now, customize the object position and size in each view differently. You can observe the borders of positions 
highlighted in respective colors of the view breakpoint colors.

Consider a case where you created a smart shape in Primary view and customized its position in Tablet view. Object 
Height and Width properties borders appear in Primary view breakpoint color and rest of the properties appear in 
Tablet view breakpoint color. 

Sample screenshot is shown below: 
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Add any two objects to the slide. In Position tab from Properties, click Checkbox adjacent to Smart Position to view 
the dimensions and links to other objects. Knowing the distances from the slide borders enables you to design 

accurate flowcharts and other drawings. 

Object Position
Smart Position Use this option if you want to follow an object instead of stage in the project.

% Choose this unit if you want object dimension or position to be a percentage of Stage width or height.

Pixel Choose this unit if you want object dimension or position to be a percentage of Stage width or height.

Auto Choose this unit to maintain aspect ratio.

% Relative Choose this option to maintain the overlay position. Appears only to height-related properties. 

Relative Top can work as function of width but not as function of height. You can also use % Relative to link objects.  

Min-Max
Fix the minimum and maximum size of objects so that they do not rescale across device views. This is especially useful 
for images such as logos, which need to look consistent and be legible at all times.

In Responsive project, you can set the Minimum Height, Minimum Width, Maximum Height, and Maximum Width 
for the objects. 

1 Click any object

2 From Position Tab of Property Inspector, Click the arrow button adjacent to Advanced

3 Set the Minimum and Maximum position values.

How to create backup files for Adobe Captivate projects
Adobe Captivate creates a backup file for your project when you save it. When you re-save the project, the changes are 
saved to the backup file too. The backup file is saved with a .bak extension.

If your project file gets corrupt, use the backup file to recover your project. Rename the backup file using a .cptx 
extension, and open it. Changes that you made after the last save, however, are not reflected in the backup file.

The provision to create a backup file is enabled by default in the Preferences dialog box. You can choose to disable the 
option if it interferes with the speed of saving the project.

Note: The size of the backup file might be larger than that of your main project.

1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select General Settings from the Global menu.

3 Select Generate Project Backup.
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Customize the size of an Adobe Captivate project
When you start creating a new project, you are prompted to choose a predefine size for the project. You can also specify 
a custom Width and Height for your project. 

If you want to reuse the custom size frequently, you can save the project size and assign a name to it. By doing so, you 
get to choose the custom size from the Select menu the next time you create a project.

1 In the New <type of project> Project dialog box, click Customize. The Custom Project Size dialog box appears.

2 Click New and type a name for the custom size. For example, “Size for Adobe Projects.”

3 Specify the height and width.

4 Click Save and then click OK.

The saved custom size now appears in the Select list of the New <type of project> Project dialog box.



112

Last updated 10/10/2016

Chapter 4: Slides

Set up knowledge check slides in Adobe Captivate
Captivate provides a Knowledge Check slide that you can use to enforce learning activity for learners. These knowledge 
check slides are useful when you want your learners not to be graded but to test what they learned by attempting some 
questions. 

Features of knowledge check slides
• Knowledge check slide imbibes similar features of question slide without any results, reporting structure and

interaction ids.

• Knowledge check slides do not participate in reviews.

• Random questions are not applicable to this knowledge check slide.

• Master slide and controls usage is similar to question slide.

• Knowledge check slides can be used to impart the learning on specific topics.

Unlike question slide, if the learner passes over the knowledge check slide and returns to it, the knowledge check slide 
resets. 

Add knowledge check slides
1 To add a knowledge check slide in project, click Slides-> Knowledge Check Slide as shown here.

2 Select the type and number of knowledge check slides you want to add.
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The knowledge check slides are added to your project.

3 Set up the knowledge check slides as you would any other question slide.

For more information, see Set up question slides .

Note: Scoring will not be enabled in knowledge check slides. You cannot assign or test a learner based on their answers. 

Edit knowledge check slide properties
For each question slide, do the following in the Quiz Properties panel (Window > Quiz Properties):

1 In the Style area specify whether you want gesture support (for use on devices).

You can also edit the background properties and slide duration of the knowledge check slide.

http://helpx.adobe.com/en/captivate/using/set-question-slides.html#main-pars_minitoc
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Note: If you are working with a responsive project, you can also edit device height and slide height of the knowledge 
check slide.

2 In the Options area, specify the time limit and the captions to be included:

Correct Displays a caption that lets users know that their answer is correct or incorrect.

Incomplete Displays a caption that lets users know that they did not complete the question when they click Skip.

Time Limit Lets you specify a time limit by when the users have to anwer the question. You can specify the time in 
seconds (maximum 1800 seconds). You can also click Timeout Caption to display a message to users that the time 
allotted for the question has expired.

Clear Resets the slide to the initial view. It allows the user to start answering the questions on a slide by clearing the 
entered answers.

Back Takes the user to the previously attempted question slide.

Skip Allows the user to skip the question slide and move to the next slide.

3 In the Action area, specify the number of attempts, the retry message, the failure message, and the action to be taken 
after the learner attempts the question.

Add and convert slide notes to audio files with Adobe 
Captivate
You can add slide notes and convert them into an audio file using the text-to-speech converter in Adobe Captivate. You 
can also convert slide notes to closed captioned text. Unlike slide notes, closed captioned text appears on the slide 
during runtime.

You can also use slide notes to communicate with users who do not have any audio equipment or are hearing impaired. 
Slide notes are also a good location for adding extra information about a slide, such as numerical details, supporting 
materials, or footnote text.

Add slide notes
1 Select Window > Slide Notes.

2 In the Slide Notes panel, click to add a slide note.

3 Type the slide notes.

Use slide notes as instructions for developers or as reminders for unfinished items. Notes are not displayed when the 
movie is played.

Importing and exporting slide notes
Slide notes are automatically imported when you import slides from Microsoft PowerPoint.

If you export your project to Microsoft Word to create handouts, you can choose to include slide notes in the document. 
This feature is useful when you want to add extra information for reviewers when you publish the project as a Microsoft 
Word document.
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Install text to speech converters
If you have not installed the text-to-speech software during installation, do one of the following:

• Install using the Adobe Captivate installation CD. Rerun the installation CD and do one of the following:

• (Windows only)Click Install Text To Speech Voices in the autoplay options.

• Run the .exe (Windows) or the .app (Mac) file in the Add-ons/NeoSpeech Text To Speech Voices folder on the
installation CD.

• Download the installer from one of the following appropriate locations:

• Windows 64-bit: http://www.adobe.com/go/Cp9_win64_voices_installer

• Mac: http://www.adobe.com/go/Cp9_mac_voices_installer

Convert slide notes to speech
You can convert text in the slide notes into an audio file using text-to-speech software from NeoSpeech™. The following 
voices from NeoSpeech are supported in Adobe Captivate:

• Kate: English female voice

• Paul: English male voice

• Bridget: British English female voice

• Julie: US English female voice

• Chloe: Canadian French female voice

You can install NeoSpeech using the Adobe Captivate installation CD or download it from the Adobe website. For 
detailed instructions on how to install NeoSpeech, see Install text to speech converters. 

Note: You can also use third-party voices or the voices installed with your operating system. See Using third-party voices 
for speech text.

When you use NeoSpeech voices, you can modify different aspects of the narration using the native NeoSpeech tags. 
See www.adobe.com/go/learn_neospeechtags_en to know how you can tweak the speed, pitch, and volume of 
NeoSpeech voices.

When you convert text to speech, the audio file is inserted into the corresponding slide. Multiple slide notes are merged 
into a single audio file and appear on the Timeline as a single object. You can also convert slide notes in the panel to 
closed captions in a single click.

The audio file pauses at locations where you have inserted commas or periods in the slide notes.

When you play the movie:

• The slide notes are read aloud to the user.

• The closed caption text on the slide is displayed to the user.

To convert slide notes to speech:

1 Select the check boxes in the text-to-speech column and corresponds to the notes you want to convert to audio.

2 Click Text-to-Speech.

3 In the Speech Management dialog box, select a speech agent and click Generate Audio.

To convert more text to speech, click , type the text, and then click Generate Audio.

Note: When you edit a slide note, click Generate Audio again for the changes to be applied.

http://www.adobe.com/go/Cp9_win64_voices_installer
http://www.adobe.com/go/Cp9_mac_voices_installer
http://www.adobe.com/go/learn_neospeechtags_en
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Convert slide notes to closed captions
To convert slide notes to closed captions:

1 Select the check boxes in the closed captions column that correspond to the notes you want to convert to closed 
captions.

Note: The closed captioning check boxes are dimmed if the slide does not contain audio. If a slide contains video closed 
captions and then you add audio closed captions, the latter takes precedence.

2 Click Text-to-Speech.

3 Click to add more closed captions. Click to remove closed captions.

4 To time a closed caption, click the header of the caption that displays the start and end time, and drag the playhead 
in the audio clip.

5 Click CC Project Settings to change the font, size, color, background, and alignment of the closed captions.

6 To enable the display of closed captions in the published projects, go to Project > Skin Editor, and click Closed 
Captioning.

The ‘CC’ button appears in the playbar. While playing or previewing the project, click the ‘CC’ button to view the 
closed captions.

Using third-party voices for speech text
You can purchase voices from third-party vendors and use them seamlessly in Adobe Captivate. 

Note: Ensure that these voices comply with your operating system’s speech APIs.

Install the voices on your computers using the installers provided by the vendors. The new installed voices get listed in 
the Speech Agent list of the Audio > Speech Management dialog box.

Add speech text to multiple slides
You can add speech text to multiple slides using the Speech Management dialog box. To add variety to the movie, you 
can choose different speech agents for different slides. For example, you can use a male voice and a female voice for 
alternate slides. 

1 Select Audio > Speech Management.

2 In Speech Management dialog box, select the slides to which you want to add the slide notes, and click the + icon.

3 Type the slide notes in the highlighted areas.

4 To generate audio for the slide notes:

a Select the slide notes to be converted to audio.

b In the Speech Agent list, select the voice that you want to use for the audio.

c Click Generate Audio.

Note: When you edit a slide note, click Generate Audio again for the changes to be applied.



117
Slides

Last updated 10/10/2016

Disable closed captions in a slide
You can prevent closed captions from appearing when the movie is played. Clear the check boxes in the closed captions 
column corresponding to the notes in the Slide Notes panel.

Delete slide notes
To delete slide notes, click next to the arrow that corresponds to the slide notes and then click the ‘-’ icon.

Resolving the, “unable to decode and import the selected wav - mp3 file” error
This error may occur when you use Adobe Captivate on Windows Vista. 

To fix this error, register the Adobe DLL.

1 Close Adobe Captivate.

2 Run Command Prompt in the admin mode.

3 Enter the location of the directory where you have installed Adobe Captivate.

4 Run regsvr32 NSAudio.dll. The message, “Registration of DLL successful” is displayed.

5 Right-click Adobe Captivate in the Program Files menu, and select Run As Administrator.

Tips for creating introductory slides in Adobe Captivate
• Add sound. Adobe Captivate makes it easy to add sound to projects, and sound is very powerful in an introduction. 

You can add existing sound files or record your own voice-over. You can include a welcome message or play some
appropriate music.

Adobe Captivate contains a gallery that has buttons, sounds, and animations (in SWF format) for you to use in your
projects. By default, the gallery is stored in the following location when you install Adobe Captivate: C:\Program

Files\Adobe\Adobe Captivate 6\Gallery (on Windows); /Applications/Adobe Captivate 6/Gallery (on Mac OS).

• Use special effects. If you are going to use special effects in your project, why not start off with them? Special effects 
(such as fading, for example) create a polished and professional look right from the start.

• Use animated text. For an easy and impressive introductory slide, use the Adobe Captivate animated text feature.
This is a fast way to create a sophisticated look for your project.

• Use captions strategically. Add multiple captions to your introductory slide and then carefully set their timing so
they fade in and out, one at a time.
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Setting slide properties in Adobe Captivate
You can set the properties for a slide using the Property inspector (Window > Properties). 

Properties panel
Label The name of the slide. The slide label appears under the slide in the Filmstrip. It is a good practice to name slides. 
When multiple users are working on the same project, naming slides helps to identify them easily.

Accessibility Click to open the Slide Accessibility dialog box, which lets you add or type in text that can be read to users 
with disabilities who use screen readers. You can import slide notes to enable accessibility for them. For more 
information, see Add accessibility text to slides.

Master Slide Select the master slide that must be linked to the slide.

Master Slide Objects on Top

Select to place the objects in the master slide on top of other objects on the slide.

Use Master Slide Background

Select to use the background of the master slide as the slide background.

Project Background

Select to use the background settings in the project preferences for the slide. This option is available only if you deselect 
the Use Master Slide Background option.

Stage

Click the box to access the color palette and choose a background color for the slide. You can also apply a gradient fill 
or a pattern fill to the background.

Note:  This option is available if you have not selected project or master slide background.

Background  Select to change the background image on the slide by selecting an image from the project’s Library. This 
option is available when Use Master Slide Background option is not selected.

Quality Select the quality level for the slide: Low (8-bit), Optimized, JPEG, and High Quality.

Note: Selecting the Optimized, JPEG, or High Quality format may increase the file size and the time needed to download 
your project. You should only use a format other than Low (8-bit) when appropriate. 

Display Time Use to change the duration for which the slide plays. The maximum value is 1 hour (3600 seconds).

Transition Select a transition effect for the slide. Transition effects make the slide transition interesting and eye-
catching. 

Action options
You can define the navigation options every time the user views a slide or moves away from the slide. The On Enter 
menu displays the actions that you can set for the slide when it is displayed. The On Exit menu displays actions that you 
can set when the user exits the slide. The following list describes actions available in both the menus:

Note: The options Go To Previous Slide, Go To Next Slide, Go To Last Visited Slide, Jump To Slide, and No Action are 
available only in the On Exit menu.

When you copy an object, actions associated with the object, such as Play Audio, Enable, and Disable are also copied.

Continue The movie moves to the next defined action.
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Open URL Or File A web browser opens with the specified web page if the user has Internet connectivity. Alternatively, 
you could open a specified file for the user.

Open Another Project Opens the specified Adobe Captivate project.

Send E-mail To A draft of the default e-mail editor opens with the e-mail address specified in the To field.

Execute JavaScript Adobe Captivate runs the specified JavaScript.

Execute Advanced Actions Adobe Captivate runs the script written using the application.

Execute Shared Action Lets you associate the object with a shared advanced action. If you choose this option, select a 
shared action from the drop-down list and click {P} to edit the parameters.

Play Audio Adobe Captivate plays the specified audio when the slide is played. The duration for which the audio is 
played is equal to the duration of the slide or the selected audio file, whichever is shorter. If users perform any action 
on the slide, for example, pause the slide, the audio stops and does not play again.

Note: If you use multiple Play Audio actions in Advanced Actions, only the audio corresponding to the first Play Audio 
action is played.

Show The specified object is made visible

Hide The specified object is hidden from the user.

Enable The specified object in the project is enabled. This option is available only for interactive objects.

Disable The specified object in the project gets disabled. This option is available only for interactive objects.

Assign A new value is assigned for a variable.

Increment The value of the specified variable is incremented accordingly.

Decrement The value of the specified variable is decremented accordingly.

Exit The movie exits.

Pause The movie pauses.

Toggle The value of the specified variable toggles from 0 to 1 and from 1 to 0.

Show TOC The TOC gets displayed.

Show Playbar The playbar gets displayed.

Hide TOC The TOC gets hidden.

Hide Playbar The playbar gets hidden.

Lock TOC The TOC gets locked. Clicking a topic in the TOC does not navigate users to the topic.

Unlock TOC The TOC gets unlocked.

Apply Effect When the user performs the required action, the effect associated with the specified object is applied.

Go To The Previous Slide The movie moves to the previous slide.

Go To The Next Slide The movie moves to the next slide.

Go To The Slide Last Visited The movie moves to the previously viewed slide.

Return To Quiz Takes users back to:

• The last attempted question slide if users answered it incorrectly or skipped the question.

• The question after the last attempted question slide if users answered the question correctly.

Jump To Slide The movie moves to the specified slide.
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No Action Nothing happens when the user exits the slide.

Audio options
Fade In [#] Seconds Specifies the time for audio to fade in to full volume. 

Fade Out [#] Seconds Specifies the time for audio to fade out to silence.

Loop Audio Plays the audio file continuously till the slide exits.

Stop Background Audio Stops playing any background audio associated with the slide.

Add Audio Displays the Slide Audio dialog box that you can use to record audio for the slide. 

How to add slide transitions in Adobe Captivate
Transitions are special effects that appear when one slide changes to another. Transitions signal the end of one slide and 
the beginning of another.

1 In the Filmstrip, click the slide for which you want to add a transition effect.

2 In the General area of the Property Inspector, select one of the effects from the Transition list.

3 If you want to apply the transition to all slides, select multiple slides in the Filmstrip and specify the required 
transition effect.

How to work with master slides in Adobe Captivate
Master slides define background and common objects such as logos, headers, and footers for your slides. They provide 
a uniform appearance for your entire project. 

All the artefacts on a master slide, such as, objects and placeholders reflect on the slide that is linked with the master 
slide.

A group of master slides make up a theme. For more information on themes, see Working with themes in Adobe 
Captivate.

When you create a blank project or a project from template, Adobe Captivate uses the default (Blank) theme. A theme 
contains the following types of master slides: 

Main master slide The main master slide is the first slide in the Master Slide panel. The name of this slide is the same 
as the name of the theme. Objects and background color of this master slide appear on all other master slides. Each 
theme has one main master slide.

Content master slides Contains layouts and objects that you can use for content slides, for example, a Title master slide 
can be used for the title of the project. A theme can contain one or more content master slides.

Question master slides Each theme contains a separate master slide for the following question types:

• Matching

• Hot spot

• Likert

• Other question types: multiple choice, fill-in-the-blank, true-false question, short answer, and sequence questions

• Result slide
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Each question master slide contains placeholder questions, answers, and captions with the style related to the theme.

Each slide, except main master slide, contains placeholders for different objects such as text caption, images, or a 
generic content placeholder. A content placeholder lets you insert any of the following:

• Text caption

• Text animation

• Image

• FLV or F4V video (event video)

• SWF animation

You can insert new quiz and content master slides or edit an exiting slide to suit your requirements.

Viewing master slides
1 Select Window > Master Slide.

2 To view and edit a master slide on stage, select it in the master slide panel.

Master slide panel

The Master slide panel displays all master slides your project has. Unless you have added additional master slides, the 
Master Slide panel displays the slides associated with the current theme of the project.

Timeline

There is no timing information for master slides. The timeline for a master slide helps only to order, lock, or hide the 
objects added to it.

Adding a master slide
To add additional master slides, do one of the following actions:

• Insert > Quiz Master Slide and then choose the required type of slide

• Insert > Content Master Slide

Though a project contains multiple master slides, you can link a slide to only one master slide.

Use the Property Inspector (Window > Properties) to:

• Label the master slide: Specify a unique label in the text box.

• Provide background color: Deselect Project Background and then select a color from Stage.

• Insert background images: Click the Browse icon to select a background image.

Add objects to master slides
You can insert the following standard objects to a master slide:

• Text Caption

• Rollover Caption

• Rollover Image

• Highlight Box

• Smart shapes
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All other standard objects are disabled.

You can also insert the following:

• Text Animation

• Widget

• Image

• Animation

• FLV/F4V files (event video)

Note: You cannot add audio to a master slide.

You can add placeholder objects on a master slide. While authoring, you can double-click the placeholders on the slides 
based on the master slide and insert appropriate content. 

To add objects to a master slide, 

1 Select the master slide in the master slide strip.

2  Add objects in the same way as you do in the slides in your project.

Using master slides
When you work on your project slides, use the Property Inspector (Window > Properties) to:

• Link to a different master slide: In the Master Slide drop-down list, make appropriate selection. You can also apply 
a Master Slide to a group of slides.

• Display master slide objects on top of the objects in your slide: Check Master Slide Object on Top.

Note: Objects on the main master slide are always below the objects on other master slides in the Z-order.

Master slide maintains its own timeline. Therefore, master slide objects are not shown on the timeline of the linked 
slide. You cannot adjust the timeline of master slide objects or change their Z-order on a project slide timeline.

• Use master slide background: Select this option to use background color or background image from master slide.

Editing Master slides
Objects on a master slide can be modified only on the master slide. The objects cannot be selected or edited on the slide 
that inherits the master slide.

On the slides in the Filmstrip, you can edit or delete the placeholders that are inherited from a master slide.

Reusing Master slides
• Duplicate master slide: Right-click (Windows) or Control-click (Mac OS) and then select duplicate.

• Copying contents: Select the contents and then click copy.

• Import/Export: You cannot import or export master slides, but you can copy and paste them across projects.

• Import/Export to XML/Microsoft Word: Like the content on your project slides, you can import/export the master 
slide content to XML and Microsoft word.
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How to lock Adobe Captivate slides
Adobe Captivate gives you the option to lock individual slides. When you lock a slide, all objects on the slide can be 
viewed but not edited. This feature is useful if you want to send your project to others for review but do not want them 
to make changes to objects.

You can tell that a slide is locked by looking for the small lock icon. This icon appears below a locked slide in the 
Filmstrip.

 In an open project, right-click (Windows) or Control-click (Mac OS) the slide you want to lock and select Lock Slide.

To select multiple slides, press Shift or Control on the keyboard while clicking on the required slides. To select all slides, 
Edit > Select All.

How to hide or exclude slides in an Adobe Captivate 
project
Adobe Captivate allows you to hide an individual slide in a project; the slide stays in the project but is hidden from view 
when the project is played. This option is useful in several situations, such as if others are reviewing the project, but 
information on certain slides is changing so you want to hide the slides until they are correct.

Hide slides
Right-click (Windows) or Control-click (Mac OS) a slide and select Hide Slide. The slide is dimmed in the Filmstrip 
and the eye is displayed at the bottom of the slide.

To show the slide, right-click (Windows) or Control-click (Mac OS) and select Show Slide or click the eye icon at the 
bottom of the slide in the Filmstrip.

Include or exclude hidden slides when publishing handouts
1 In an open project, select File > Publish.

2 Select Print on the left panel.

3 In Type, select Handouts.

4 In the Handout Layout Options area, select Include Hidden Slides. 

5 Click Publish.

How to group and ungroup slides in Adobe Captivate
When the number of slides becomes unmanageable, you can group them. By expanding and collapsing groups, you can 
view subsets of the slides instead of all slides at once. Groups also provide a useful overview for the project, and they 
provide a convenient way of deleting or hiding multiple slides at once (for example, slides that you don’t want to 
publish).

To help associate slides with their group, you can mark grouped slides with the same border color. The color is not 
displayed when the project is run.
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Create a slide group
1 In an open project, click a slide that you want to group, and use Control-click or Shift-click to select the other slides 

for the group.

2 Right-click (Windows) or Control-click (Mac OS) and select Group > Create.

The selected slides are grouped into a single group slide with their numbers and descriptions displayed on it.

Name slide groups and mark them
1 Click the group slide in the Filmstrip.

2 In the Property Inspector, type a name for the slide group in the Title text box. This title appears at the bottom of 
the grouped slide.

3 From the Color palette, select a color for the border of all the slides in the group. This color is not displayed when 
the project is run.

Expand or collapse a slide group
Right-click (Windows) or Control-click (Mac OS) the group slide and select Group > Expand or Group > Collapse.

A faster way is to click the arrow icon on top of the group slide. 

Ungroup slides
Right-click (Windows) or Control-click (Mac OS) the group slide and select Group > Remove.

Editing slides in an Adobe Captivate project
Use the Property Inspector (Windows > Properties) of the slides to edit them.

Change background color of slides
By default, the slides use the background color that is set in the corresponding master slides.

1 Select the slide (s) in the Filmstrip. To select multiple slides, hold down the Ctrl or the Shift key while selecting the 
slides.

2 In the Property inspector, clear the Use Master Slide Background check box.

Now, the background set in the project preferences is used as default.

3 To use a background other than the one set in the project preferences, clear the Project Background check box and 
click the Stage color palette.

4 Do one of the following:

• Select a color for the background.

• Click to apply a gradient fill. For more information on gradients, see Apply gradient fills.

• Click to apply a pattern or an image as the background fill. For more information on using pattern fills, see
Apply texture fills.
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Using images in the background
By default, the slides use the background that is set in the corresponding master slides.

1 Select the slide (s) in the Filmstrip. To select multiple slides, hold down the Ctrl or the Shift key while selecting the 
slides.

2 In the Property inspector, clear the Use Master Slide Background check box.

3 Click the browse icon below the Background area. 

• If the library does not contain any image, you will be prompted to browse for the image. Navigate to the location 
of the image, select it, and click Open.

• If the library already contains images, you will be prompted to choose an image from the library. Select an image 
and click OK. To use an image that does not exist in the library, click Import in the Select Image from Library
dialog box.

Editing background images
Click the edit icon in the General section of the slide’s Property Inspector. Edit the required attributes of the image in 
the Resize/Crop Image dialog box.

Add plain text to a slide
As you edit a project, you may want to add some text to the slide but not have the text appear as a text caption over the 
slide. There is an easy trick you can use to add plain text to a slide: simply add the text as a transparent text caption.

1 Open the slide on which you want to insert the text caption.

2 Select Insert > Standard Objects > Text Caption. 

3 In the Property Inspector, select Transparent as the Caption Type in the General area.

Note: If you create a transparent caption, avoid underlining text. Underlined text might affect the quality of the text.

Edit text recorded on a slide
When you record text being typed, a new slide is created for every line break. Each line of typed text is treated as a single 
object and appears as a separate layer on the Timeline. You can replace text recorded on a slide with new text along with 
typing effects. For example, if you have recorded text being typed in an editing program and you want to change the 
recorded text on the slide later, you can use this option.

Before you record text being typed, ensure that the option to record keystrokes has been enabled. For more information, 
see Set global recording preferences.

1 In an open project, right-click (Windows) or Control-click (Mac OS) the Typing layer in the Timeline, and select 
Replace With Text Animation.

2 In the General area of the Property Inspector, select one of the options in the Effect menu.

3 Click Properties, type the replacement text on the slide, and then click OK.

The text on the slide is replaced with the entered text. In the Timeline, the typing text object is replaced with the text 
animation object, and the overwritten text appears on the object in the Timeline.
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Label slides
It is easier to identify and keep track of slides using their label instead of their slide number. The label of the slide 
appears under the slide. 

To label a slide, open the slide and enter a name for it in the Label text box of the Property Inspector.

Move to a specific slide
To jump to a specific slide, type the number of the slide in the Application Bar at the top of the Workspace.

Delete Adobe Captivate project slides
Deleting a slide permanently removes the slide from the project. 

 Do one of the following:

• Right-click (Windows) or Control-click (Mac OS) the slide you want to delete, and select Delete from the menu.

• Select the slide, and press Delete.

Change slide order in Adobe Captivate
To reorder slides, select them and drag them to the new position in the Filmstrip. 

You can select multiple slides by pressing Shift or Control on the keyboard while clicking the desired slides. To select all 
slides, select Edit > Select All.

Adding slides to an Adobe Captivate project
Adobe Captivate offers a wide variety of options for adding slides to a project, including recording, importing, and 
copying. You can add different types of slides such as blank, image, quiz, or animation.

Record additional slides for a project
There may be cases in which you record an Adobe Captivate project and begin working at the slide level, only to realize 
that you need to record a few more slides. In this case, you probably don't want to rerecord the entire project but just a 
few actions. Adobe Captivate allows you to do this by recording new slides and inserting the slides in an existing project. 
For more information, see Record additional slides for existing projects.

Copy slides from other projects
1 In an open project, right-click (Windows) or Control-click (Mac OS) the slide to copy. To select multiple slides, press 

Shift or Control on the keyboard, click the slides, and then right-click (Windows) or Control-click (Mac OS).

2 Select Copy.

3 Open the Adobe Captivate project in which you want to paste the slides.
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4 Right-click (Windows) or Control-click (Mac OS) the slide after which you want the new slide or slides to appear. 
(For example, if you want to paste the copied slide as Slide 6 of your project, click the slide currently labeled Slide 5.)

5 Select Paste.

You can also copy Advanced Actions and Shared Actions associated with the slides. To do so, copy the objects and slides 
referenced from within these actions along with the slide to which the actions are assigned.

Enable rescaling of slides during import
Adobe Captivate can automatically resize the content of imported slides according to the dimensions of the project to 
which the slide is being imported. 

1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 Select General Settings from the Global menu.

3 Select Rescale Imported/Pasted slide.

Duplicate slides
Duplicating slides is an easy way to expand your projects. For example, if you carefully design a slide with a certain 
background color, layout, caption, and highlight box, you can simply duplicate that slide and change some of the 
elements or text to add more information to your project.

Master Slides are another way of achieving uniform look and feel for multiple slides.  

 In an open project, do one of the following: 

• Right-click (Windows) or Control-click (Mac OS) the slide to copy and select Duplicate.

• Select a slide and press Control+D.

To select multiple slides, press Shift or Control on the keyboard while clicking the desired slides. To select all slides, 
right-click (Windows) or Control-click (Mac OS) on a slide and select Select All Slides.

The slide or slides you selected are duplicated and placed in the project. You can edit and work with the new slides just 
like the original slides.

Insert blank slides
1 In an open project, right-click (Windows) or Control-click (Mac OS) the slide after which you want the new blank 

slide or slides to appear. 

2 Select Insert > Blank Slide. 

The new slide is added to your project. You can edit and work with the new slide just like other slides in the project.

Insert new or stencil slides
‘Stencil’ slides are those that inherit the master slide associated with the slide that you select.

1 In an open project, right-click (Windows) or Control-click (Mac OS) the slide after which you want the new slide to 
appear. 

2 Select Insert > New Slide. 

A new ‘stencil’ slide appears in the Filmstrip. You can edit the slide as required. You can also associate a different master 
slide using the Property Inspector (General > Master Slide list).
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Insert images as slides
Image slides are slides that have an image inserted into their background. 

1 Open an Adobe Captivate project.

2 Right-click (Windows) or Control-click (Mac OS) the slide after which you want the new image slide or slides to 
appear. 

3 Select Insert > Slide > Image Slide.

4 Browse to and select the image that you want to import in the Open dialog box.

5 If the image that you are trying to import is larger in dimensions than that of your slide, the Resize/Crop Image 
dialog box appears. Do one of the following: 

Fit To Stage Resizes the image to fit the dimensions of the slide.

Crop Displays a bounding box with dimensions corresponding to that of the project. Resize the handles of the box 
to select the area that you want displayed on the slide. If you selected Constrain Proportions, Adobe Captivate 
maintains the height-to-width ratio of the bounding box.

Zoom You can zoom in and zoom out of the image by moving the slider. Alternatively, you can choose from a list 
of standard zoom sizes from the menu.

Constrain Proportions Maintains the height-to-width ratio of the bounding box used to crop the image. This option 
is enabled only when you choose to crop the image. When you disable this option, resize the bounding box, and 
enable the option again; the new dimensions are used thereafter to calculate the ratio.

In addition to the above options, you can also set tone controls (brightness, sharpness, and contrast) and adjust color 
ranges (alpha, hue, and saturation). You can also flip or rotate the image.

Insert slides from a PowerPoint presentation
You can add PowerPoint slides to the end of a project or within a project. 

1 In an open project, select Insert > Slide > PowerPoint slide.

2 Select a PowerPoint presentation and click Open.

3 Select Import Slides and Insert After The Selected Slide Below to add new slides after the slide you select from the 
list and click OK.

4 In the Convert PowerPoint Presentations dialog box, do the following:

• Clear the Include check box of a slide to exclude from importing.

• Clear the Linked check box to remove the linkage to the source PowerPoint file.

• Specify how the slides must advance: Automatically or upon the click of mouse.

Insert animation slides
You can insert a SWF, AVI, or animated GIF file as a new slide. 

Note: Adding animation as a slide is most appropriate with larger animation files.

1 In an open project select Insert > Slide > Animation Slide.

2 Navigate to the animation file you want to insert (SWF, AVI, or animated GIF) and click Open. The animation slide 
is generated and added to the project.
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It is important to set the correct frame rate. All imported animation files play at the rate selected in the project 
Preferences dialog box, regardless of the rate prior to when the file is imported. The default setting is 30 Flash frames 
per second and is appropriate in most cases. You may need to change the rate if you are embedding your Adobe 
Captivate SWF file in another SWF file that has a frame rate different than 30. 

When you create an animation slide, the amount of time the slide is displayed in the project automatically defaults to 
the length of the animation file itself. For example, if the animation file that you use to create a new animation slide is 
only 1.2 seconds in length, the animation slide appears for 1.2 seconds. To change the duration of the slide, click the 
slide in the Filmstrip, and in the Property inspector, enter a new number of seconds in Display Time. Or use the 
Timeline to change the slide display time.
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Chapter 5: Recording Projects

Automatic and manual recording with Captivate

Automatic recording
When you record using automatic recording, Adobe Captivate captures screenshots automatically and places them on 
separate slides. Mouse, keyboard, or system events are the common triggers for capturing screenshots. Automatic 
recording is the most commonly used recording method in Adobe Captivate.

In the recording options (File > Record New Software Simulation) , you choose one of the following autorecording 
modes:

• Demonstration mode

• Training mode

• Assessment mode

• Custom mode

Depending on the mode, one or more of the following objects are added automatically during the recording. You can 
change recording preferences for the various modes. The descriptions for the various modes assume that you have not 
changed the default recording preferences.

Text Captions Text captions are used to point out certain areas on a slide, explain concepts, or provide users with 
additional information. Text captions can be created automatically or manually. If you are autorecording a project, you 
can have Adobe Captivate automatically create text captions. Text captions are generated for the various mouse and 
keyboard events.

The text captions use the labels in the application to describe a step. For example, if the user clicks File in the menu bar, 
a text caption with the text, “Select the File menu” is created automatically. You can later edit the captions to your 
requirements. When the user views the movie, the actions performed during recording are displayed along with the 
captions

Text Entry Boxes Text entry boxes are Adobe Captivate objects that require user input. During recording in some of the 
modes, text entry boxes with default hint, success, or failure captions are added to the slides. You can later edit the text 
in these captions. 

Click Boxes A click box is an object in Adobe Captivate that designates an area around the place where the mouse was 
clicked during recording. Click boxes help users try out an application or website using the movie. After viewers click 
a click box, you can have the project perform different actions. For example, the project resumes playing, opens a new 
project, or opens a specific website.

Highlight boxes Highlight boxes are transparent, colored rectangles that can be placed over areas on a slide to draw 
attention to the area. You can edit the formatting, color, transparency, and size of all highlight boxes. If you 
automatically record a project or slides, Adobe Captivate creates a highlight box for the area on which a mouse event 
occurs. If you have an existing project, you can also add highlight boxes manually.
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Demonstration mode
Use the demonstration mode when you want to demonstrate a procedure or feature. The movie produced in this mode 
however, does not provide any scope for user interaction. The user can only passively view actions that were performed 
when the project was recorded.

When recording a movie in the demonstration mode, Adobe Captivate does the following:

• Adds text captions using the labels of the controls in the application. For example, if the user clicks File in the menu
bar, a text caption with the text, “Select the File menu” is created automatically.

• Adds highlight boxes to highlight those areas where the mouse is clicked.

• Adds text that is typed manually during the recording.

See How to record software simulations in Adobe Captivatefor more information.

Training mode
Use the training mode when you want the user to try the procedure during the movie. The movie moves to the next 
slide only after the user has performed the previous action correctly.

When recording slides in training mode, Adobe Captivate does the following:

• Adds click boxes at places where the user must click the mouse.

• Adds text entry boxes for user input. The failure and hint captions are added to each text entry box.

See How to record software simulations in Adobe Captivatefor more information.

Assessment mode
Use the assessment mode when you want to test how well the user has understood a procedure. You can set a score for 
every correct click. You can also set the number of times the user can attempt a procedure. When the user fails to click 
the right option in the number of attempts provided, the movie moves to the next step. The user does not get any score 
for the failed attempt.

When recording slides in assessment mode, Adobe Captivate does the following:

• Adds click boxes at places where the user must click the mouse.

• Adds text entry boxes for user input. The failure caption is added to each text entry box.

See How to record software simulations in Adobe Captivatefor more information.

Custom mode
Use the custom mode when working on a project where you need a mix of features available in the other modes. This 
mode allows you to achieve the highest level of customization in Adobe Captivate. Using the custom mode, you can 
create a project that is part demo, part training, and also includes assessment. None of the Adobe Captivate objects are 
added by default during recording in the Custom mode.

For example, let us consider a movie meant for training the user on editing a file. In the first few slides for simpler tasks 
like opening the application and opening the file, you can retain the slides created in the demo mode. When you move 
to the slides describing the procedure for editing, you can add the various objects with which the user can interact. 
Finally, you can provide for assessment slides at the end of the project.

See How to record software simulations in Adobe Captivatefor more information.
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Multimode recording
When you record an Adobe Captivate project, you can choose to record in more than one mode. Multimode recording 
helps you save time when working on projects that require outputs in more than one autorecording mode.

See How to record software simulations in Adobe Captivatefor more information.

Manual recording
You can create a project manually by taking screenshots during recording. Use manual recording when you want to pick 
and choose a few screenshots during the recording process. The procedure can get tedious for complicated procedures 
involving many steps.

See How to record software simulations in Adobe Captivatefor more information.

More Help topics 
Text captions

Highlight boxes

Click boxes

Text entry boxes

Set recording preferences

Set recording preferences

Recording in sync

Set recording preferences in Adobe Captivate
Adobe Captivate uses a default set of preferences for panning and other settings when recording or creating projects. 
You can customize these preferences using the various options available in the Preferences dialog box.

Panning
Use panning when you want the recording window to follow the movement of your mouse pointer across the screen. 
Panning helps you capture events across a large screen even when the recording window is smaller than the size of the 
screen.

The following panning options are available in Adobe Captivate:

Automatic Panning The recording window automatically moves along with the pointer whenever you move the mouse 
during recording.

Manual Panning You must manually move the recording window to the area where the next event takes place. In all 
other respects, It is like the automatic panning option.

Set global recording preferences
Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS). In the Preferences dialog box, select 
Settings from the Recording menu.

http://helpx.adobe.com/en/captivate/using/text-captions.html#text_captions
http://helpx.adobe.com/en/captivate/using/highlight-boxes.html#highlight_boxes
http://helpx.adobe.com/en/captivate/using/click-boxes.html#click_boxes
http://helpx.adobe.com/en/captivate/using/text-entry-boxes.html#text_entry_boxes
http://helpx.adobe.com/en/captivate/using/set-recording-preferences.html#set_recording_preferences
http://helpx.adobe.com/en/captivate/using/set-recording-preferences.html#set_recording_preferences
http://helpx.adobe.com/en/captivate/using/recording-sync.html#recording_in_sync
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Set video recording preferences
Adobe Captivate automatically captures some actions in the video mode during autorecording. You can choose to 
disable this feature in the Preferences dialog box. You can also set options to optimize the size of the video SWF file and 
set the color mode for the video file.

Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS). In the Preferences dialog box, select 
Video Demo from the Recording menu.

Option Description

Narration Records audio as you record the project. You cannot enable camera 
sounds or keyboard tap sounds when you have chosen narration for a 
project.

Actions in real time Record actions using their actual speed.

Camera sounds A “camera shutter” sound is played whenever a screenshot is captured 
during recording. It is helpful to turn on this sound so you know 
exactly when a screenshot is captured, especially when using the 
autorecording feature. The camera sound is not included in the 
finished project.

Keystrokes Records keyboard actions like typing text on the screen. Adobe 
Captivate records keyboard input, but does not create a slide for every 
character that is typed.

Hear keyboard tap sounds Determines whether keyboard press sounds are audible during 
recording. The keyboard press sounds are not included in the finished 
project.

Recording Window The red border of the recording window is not displayed during 
recording.

Task Icon Hides the task icon during recording.

This option is available only on Windows.

System Tray Icon Hides the system tray icon during recording. This icon is the small 
Adobe Captivate icon that is displayed in the system tray in the lower-
right corner of the computer screen. Use this option if you do not want 
to record the icon when recording the project.

Move new windows inside recording area Adobe Captivate automatically moves any new window during 
recording into the recording window. Use this option when recording 
an application in which many dialog boxes open as you use the 
application.

Drag and drop actions  Adobe Captivate switches automatically to video mode when 
recording drag-and-drop actions.

Mouse Wheel Actions  Adobe Captivate switches automatically to video mode when 
recording mouse movements.

Option Description

Show mouse in Video Demo Mode Displays mouse movements when the video is played.

Working folder Location of the generated temporary video file on your computer.
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Change keyboard shortcuts for recording
You can choose your own keyboard shortcuts for actions that are involved when recording a project using the 
Preferences dialog box. For example, the End key (in Windows) or Cmd + Enter (Mac OS) is used to stop recording a 
project in Adobe Captivate. You can change that by entering a different key in the dialog box.

1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select Keys - (Global) from the Recording menu. 

3 Click inside the field that you want to change.

4 Type the keyboard shortcut.

Set Preferences for the different modes
Some of the options for recording modes are disabled in Adobe Captivate. The reason for disabling the options is based 
on the logic for recording in that mode. However, you can still enable some of the options if you have a special 
requirement.

For example, one wouldn't usually add text captions in an assessment movie. So, the options for text captions are not 
enabled in Adobe Captivate. You can enable them in the Preferences dialog box if you have a special requirement.

1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS). 

2 In the Preferences dialog box, select Modes from the Recording menu. 

3 In the Mode menu, select the recording mode you want to customize. Then, choose the objects you want to be 
inserted automatically during recording:

Option Description

Add Text Captions Automatically creates captions based on user and system actions 
performed during autorecording. The text captions use the labels in 
the application to describe a step. For example, if the user clicks File in 
the menu bar, a text caption with the text, “Select the File menu” is 
created automatically.

Convert Tool Tips To Rollover Captions Automatically converts any tool tips on the screens you are capturing 
to rollover captions. Tool tips are small floating text windows that 
appear when the mouse hovers over buttons. This option is not 
selected by default for any of the recording modes. 

Use Smart Shapes Instead of Captions Inserts the specified smart shape for captions.

Show Mouse Location And Movement Displays mouse movements during autorecording.
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Note: The options mentioned in the table are enabled or disabled based on the recording mode you have chosen.

Change recording defaults for objects
Adobe Captivate uses a default set of styles when inserting objects such as text captions and highlight boxes during 
recording. You can change these default settings using the Preferences dialog box. 

Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS). In the Preferences dialog box, select 
Defaults from the Recording menu. Change the styles for the objects as required.

To create a new object style, click Create New Style and create a new style in the Object Style Manager.

More Help topics 
Automatic recording

Manual recording

Text captions

Highlight boxes

Record video demonstrations with Adobe Captivate
1 Click Video Demo on the Welcome screen. Or, click File > Record New Video Demo.

The recording window, marked by a red box, and the recording options appear. 

2 Click Screen Area or Application based on what you want to record and specify the associated options:

Screen Area Select this option when you want to capture all events that occur within an area on the screen.

Custom Size Select this option if you want to customize the dimensions of the recorded project. You can choose 
from a list of standard sizes, or define a custom size. The selected application is automatically resized to fit inside 

Add highlight boxes on click Automatically adds a highlight box around the area where the mouse 
is clicked.

Add Click Boxes On Mouse Click • Automatically creates click boxes whenever you click screens you 
are autorecording. 

• Enables or disables the hint, success, and failure captions. 

• Sets the number of times the user can click before the movie moves 
to the next slide. 

• Enables cursor display when the user moves the mouse over the
mouse areas

Automatically Add Text Entry Boxes For Text fields • Automatically creates text entry boxes whenever you click text 
boxes you are autorecording.

• Enables or disables the hint, success, and failure captions. 

• Sets the number of times the user can enter text within the same 
text entry box before the movie moves to the next slide.

Option Description

http://helpx.adobe.com/en/captivate/using/types-recording.html#automatic_recording
http://helpx.adobe.com/en/captivate/using/types-recording.html#manual_recording
http://helpx.adobe.com/en/captivate/using/text-captions.html#text_captions
http://helpx.adobe.com/en/captivate/using/highlight-boxes.html#highlight_boxes
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the boundaries of the recording area. Best practice is to have a clear idea of the dimensions of the project before you 
start recording it.

Full Screen Select this option if you want to set the size of the recording window to the size of your computer 
monitor. The entire computer screen is treated as the recording window. If you work on dual monitors, you can 
choose the monitor that you want to use for recording. Recording in this mode can potentially produce very large 
projects and output file sizes due to the large screen resolution on monitors.

Application Select this option to specify the application which you want to record. The Select The Window To 
Record drop-down lists all the open applications on your computer. Click the required application from this list.

Application Window Select this option if you want to record the entire application window. The dimensions of the 
application are not altered. The recording rectangle is resized to fit the application.

Application Region Select this option if you want to record defined areas in an application. For example, if you are 
recording a window that has three frames, the recording window snaps to individual frames when the mouse moves 
over them. The dimensions of the application are not altered. The recording rectangle is resized to fit the defined 
area in the application.

3 Do one or all of the following:

• Select a panning mode if you want the recording window to follow your movements across the screen. For more 
information, see Panning.

• If you are adding narration during recording, select the type of audio input. In the patch for subscription and
Adobe Software Assurance customers, you can select System Audio to record audio from your computer's
speakers, for example, the sound you hear when error messages pop-up. For more information, see Working with 
system audio in Adobe Captivate 7.

System audio is not supported on Windows XP.

• To change the default settings that Adobe Captivate uses when recording a video demo, click Settings. For more 
information on customizing recording preferences, see Set video recording preferences.

4 Click Record.

5 Press End key (in Windows) or Cmd + Enter (Mac OS) when you have completed the recording.

Note: Alternatively, on Windows, click the task icon or the system tray icon to stop recording. On Mac, click the dock 
icon or the status bar icon.

The preview of the recorded video appears and starts playing. You can do one or all of the following:

• Publish the recorded video as an MP4 file and save it on your computer. To do so, click . For more information,
see Publish video as an MP4 file.

• Directly publish the video to YouTube, Twitter, or Facebook. To do so, click . For more information, see 
Publish video to YouTube.

• Edit the video in Adobe Captivate and enhance it by adding captions, PIP videos, and pan and zoom effect. You can
then publish the video to YouTube, Twitter, Facebook, or save it as an MP4 file.

To edit the video, click Edit. See Edit videosfor more information.

Edit videos
You can enter the video editing mode by clicking Edit in the video preview window.
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A .CPVC file opens in Adobe Captivate. You can now edit the video to split or trim it, add effects, audio, and the 
following objects: 

• Text captions

• Highlight boxes

• Images

• Smart shapes

• Mouse

• Animation

• Picture-In-Picture videos (PIP video)

See Noninteractive Objects and Media for information on adding these objects.

A .CPVC file is slightly different from the regular Adobe Captivate project or a CPTX file. The following table 
summarizes these differences:

CPTX file CPVC file

Is based on a 'slide' paradigm. After recording, you can see the 
individual slides in the Filmstrip.

Is not based on the 'slide' paradigm. After recording, the file contains a 
single video clip that you can see in the Timeline.

You can edit every slide in the Filmstrip by clicking them. You can edit the video clip to cut, copy, or trim it between two points 
using the Video Editing options in the Properties.

http://helpx.adobe.com/en/captivate/topics/noninteractive-objects-and-media.html
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Properties of a video demo project
Click anywhere on the stage outside the recorded video to view the properties of the video demo in the Property 
Inspector.

Stage Click to change the fill color of the project background. You can also apply gradient fills or pattern fills for the 
background. For more information on gradient fills, see Apply gradient fillsand Apply texture fills.

Background Click <<browse icon>> to select an image as the background. This background is visible on the frames 
that do not contain the recorded video. For example, you split the video and insert objects such as a text caption 
between the video clips. The background is applied to the frame with the text caption. 

note: If the image you choose is larger than the dimensions of the video frame, the Resize/Crop Image dialog box appears. 
Choose appropriate options to continue.

Start Time Indicates from which point in Timeline the video is published. By default, the value is set to the beginning 
of the video clip. 

End Time Indicates until which point in Timeline the video is published. By default, the value is set to the end of the 
video clip.

Use Start Time and End Time options to publish a portion of the video. For example, if the total length of the video is 
60 seconds, you can publish a portion of the video from 10 to 45 seconds.

Properties of recorded video clips
Name Type a unique name for the video clip.

Audio Specify the transition, edit, or remove the audio associated with the video clip. See Add audio to a video 
projectfor more information.

Properties of PIP videos
Name Type a unique name for the video clip.

Shadow Click to apply shadow to the video clip. Choose the direction and a preset or customize the shadow effect by 
clicking Custom. For more information, see Apply shadows to objects.

Reflection Click to apply reflection to the video clip. Click the required preset. For more information, see How to add 
reflection to objects in Adobe Captivate.

Transform Resize the dimensions of the video clip or modify the position of the clip by specifying X and y values. You 
can also rotate the clip by specifying an angle.

Click Video Demo on the Welcome screen. Or, click File > Record New Video Demo.

You can insert both interactive and non-interactive objects. You can insert only the non-interactive objects, text captions and 
highlight boxes.

You can insert quizzes. You cannot add quizzes directly. You can create a separate CPTX 
project with assessments, publish the CPVC files as MP4 files, and 
insert into the CPTX project.

You can preview the whole project, the current slide, or specific slides. You can preview either the whole project or the current frame on 
stage.

CPTX file CPVC file
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The recording window, marked by a red box, and the recording options appear. 

Audio Specify the transition, edit, or remove the audio associated with the video clip. See Add audio to a video 
projectfor more information.

Timeline in video projects
The Timeline in video projects is different from CPTX projects in terms of how objects and videos are grouped:

• In video projects, unlike CPTX projects, all objects are placed in a single layer in the Timeline

• PIP videos and recorded video clips are placed in different layers

• Audio and recorded video clips are placed in the same layer

Add pan and zoom effect
The pan and zoom effect helps you draw users' attention to a specific area or an action in the video. For example, in a 
software simulation, you can pan the screen to a group of icons and then zoom in closer to a specific icon.

1 Play the video file using the Play button in the Timeline.

2 Pause (click the play button again) at the point where you require the pan and zoom effect.

3 Click Pan & Zoom in the Timeline. The Pan and Zoom icon appears in the video clip and the Pan & Zoom panel 
appears. 

The Pan & Zoom panel displays the frame at the point you chose in the video.

To move the pan and zoom point to a different location on the video clip, drag-and-drop the icon. 

4 To specify the area to be magnified, resize the blue box around the frame using the handles. Then, drag-and-drop 
the box to the required position on the frame. The smaller the box, the greater is the magnification. 

You can also specify the magnification value in terms of percentage using the Scale slider or box.

5 Use the Speed slider to specify how fast Adobe Captivate has to zoom in. 

To delete a pan and zoom point, click the icon in the timeline and press the Delete key.

Apply transitions to video
1 Click the transition icon that appears at the beginning and end of the video clip.
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2 Choose a transition effect from the Transitions panel. To see a preview of a transition effect, hover your mouse over 
the effect.

3 In the Speed list at the top of the Transition panel, click the required speed for the transition.

To remove the transition effect, click the transition icon, and click No Transition from the Transitions panel.

Split recorded video clips
You can split the video clip to insert separator text or videos (PIP). For example, you can split the video clip to insert a 
summary of what users learnt until that point in the video.

When you split a video clip, the resultant clips continue to exist on the same layer in the Timeline. 

Here's an example of how you can insert separator text between two parts of a video clip:

1 Click the video clip in the Timeline.

2 Click to play the video and click the icon again to pause at the point where you want to split the video. 

3 Click Split in the Timeline. The Timeline now shows two video clips.

Note: Other objects, such as, text captions or highlight boxes in the project are also split along with the video clip. 
Preview the video to adjust the timing of these objects.

4 Drag-and-drop the second clip to create space for the text that you want to insert.

5 Click Insert > Text Caption. The default text caption appears on a separate layer on the Timeline.

6 Drag-and-drop the text caption in the Timeline and position it so that it corresponds to the space between the two 
parts of the video clip.

7 Preview the project to check the timing of the text caption.

Note: The text caption appears as a separate frame or a slide. The background of this screen is the one that you set for 
the video project. To change the background, drag-and-drop the stage anywhere outside the video, and then click Stage 
in the Property Inspector.

You can make the transition between the video clips interesting by adding effects. When you split a video clip, a 
transition icon appears at the split point in the Timeline. Click the icon to choose an effect from the Transitions panel.

Note: Each video clip has a transition icon at the beginning and end. If you move the second video clip, another transition 
icon appears at the beginning of the clip. When you merge the transition icons by placing the video clips adjacent to each 
other, the transition effect used in the subsequent video clip is retained.

Trim video clips
You can trim video clips to cut unwanted portions of the video.

1 Click the video clip in the Timeline.

2 Click to play the video and click the icon again to pause at the point where you want to trim the video. 
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3 Click Trim in the Timeline. Start and end markers that define the region for trimming appear on the video clip. 

4 Click or to move the start and end trim markers to the current playhead position. You can also click and drag 
the trim markers left or right to choose the portion of the video clip for trimming.

Note: Objects, such as, text captions or highlight boxes that are within the cross section of the trim markers are also cut 
along with the video clip. 

5 Click Trim in the Timeline.

Two separate video clips appear with transition icons. Click the icon to choose a transition effect.

Add audio to a video project
You can record or import an audio clip (WAV or mp3 files):

• As background audio for the entire project (Audio > Import to > Background; Audio > Record to > Background).

• As background or narration for any PIP in the project. Click the PIP in the Timeline, and then click Audio > Import 
To > PIP, or Audio > Record To > PIP.

• As video narration to individual video clips in the project. Click the video clip, and then click Audio > Import To >
Video Narration, or Audio > Record To > Video Narration.

If you have split a video clip into multiple clips, you can add separate audio clips to each video clip. To do so, right-
click the video clip, and choose Record To or Import To.

You can record audio as narration for the entire project at once using Audio > Record To > Project Narration.

For information on editing audio, see How to edit audio files with Adobe Captivate.

Edit mouse points
Click the mouse icon and modify the properties in the Property Inspector:

1 Click Edit > Edit Mouse Points. The mouse icons appear on the video clip in the Timeline indicating the frames that 
have mouse actions. 

2 Click the mouse icon and modify the properties in the Property Inspector:

Options Choose the required pointer. Click Browse for any pointers stored on your local disk.

Double Mouse Size Choose to double the size of the pointer.

Show Mouse Toggle to show or hide the mouse action. When you hide the mouse action, the mouse icon is still 
visible on the video clip. However, when you play the video, the action from the previous mouse point to the hidden 
one is not visible.

Smoothen Mouse Path By default, the mouse path is rough, traced by the actual movement of the mouse during 
recording. Select this option to make the mouse path smooth either using a straight line or a curve.
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Reduce Speed Before Click Select this option to slow the mouse movement down before the click occurs. This 
option is useful for a long mouse path that moves quickly and stops suddenly.

note: This option appears only if you have selected Smoothen Mouse Path.

Show Mouse Click Adds a visual click effect to the mouse movement.

Default Displays a quick, small burst of color when the user clicks the slide. You can select a color for the color burst.

Custom Select this option to use a SWF file as a visual click effect. Adobe Captivate includes two effects you can use. 
Test them by clicking the pop-up menu, selecting one, and then clicking Play. View the effect in the small preview 
window on the right.

3 To apply the modified properties to multiple mouse points in the video, click and click one of the options.

Insert mouse actions
In addition to the mouse actions that you capture while recording the video, you can insert new mouse actions into the 
video.

1 Click the video clip in the Timeline.

2 Click to play the video and click the icon again to pause at the point where you want to insert a mouse action. 

3 Click Insert > Mouse. A pointer appears on the frame at the playhead point. Adobe Captivate plots the mouse 
position based on the coordinates derived from the previous and the subsequent mouse points.

4 Drag-and-drop the pointer to the required place on the frame.

5 Edit the properties using the Property Inspector. For details on the different properties you can edit, see Change 
mouse properties.

Recording additional video
1 In the CPVC file, click Insert > Video Recording.

For information on recording video from within CPTX files, see Insert videos in CPTX files (Cp 6).

2 Select the recording options and the area you want to record, and click Record.

The new video clip appears after the existing video clips on the Timeline.

Publish video projects

Publish video as an MP4 file
1 In the full screen mode, click . In the CPVC file, click File > Publish.

2 Specify a title for the project.

3 Specify a folder in which the project must be published. By default, the project is published in the folder specified 
in the project preferences.

4 Click one of the options in the Select Preset list.

Adobe Captivate automatically sets the video settings based on the option you select. If necessary, you can customize 
the settings by selecting the Customize Video Settings check box.
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After publishing a project as an MP4 file, you can do the following:

• Upload it to the device stores or to YouTube. You can also share the video over social media, such as Twitter and
Facebook. See Publish projects as MP4 files with Adobe Captivatefor information.

• Distribute the file to your users as a stand-alone video over email or host it on your web server.

• Stream or embed the MP4 file using Flash.

Publish video to YouTube
In the full screen mode, click . In the CPVC file, click File > Publish to YouTube.

See Upload projects to YouTube directly from Adobe Captivatefor more information.

Publish a specific portion of the video
1 Drag-and-drop the black start and end markers to define the portion of the video you want to publish. 

You can also specify the Start and End time in the Property Inspector. Click anywhere on stage outside the video to 
view the Start and End time.

2 Do one of the following actions:

• Click File > publish to publish the portion of the video as an MP4 file. See Publish video as an MP4 filefor more 
information.

• Click File > Publish to YouTube to publish the portion of the video directly to YouTube. See Upload projects to
YouTube directly from Adobe Captivatefor more information.

Insert videos in CPTX files (Cp 6)
Click the Record additional slides icon ( ), and then click Video Demo in the recording options.

The recording video appears in the Filmstrip with the webcam icon. 

To edit the video, click the slide, and then click Edit Video Demo in the Property Inspector. For information on editing 
videos, see Edit videos.

Click Exit at the upper-left corner to save the changes to the video file and return to the CPTX file.

Insert video demonstrations in CPTX files (Cp 7)
1 Save your video demonstration as a CPVC file.

2 Open the CPTX file in which you want to insert the video demonstration.

3 Click the slide after which you want to insert the video demo, click Insert, and click CPVC Slide.

4 Browse and select the CPVC file you want to insert.

The Property Inspector displays all the properties of the CPVC file. To edit the video, click Edit Video Demo. The CPVC 
file is opened for editing. After completing the edits, click Exit to return to the CPTX file.
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If you edit the CPVC file by directly opening the file in Adobe Captivate, you can update the video included in all CPTX 
projects. To do so, right-click the CPVC file name in Adobe Captivate Library (Media > Video), and click Update.

How to record software simulations in Adobe Captivate
1 Select File > Record New Software Simulation. The recording window appears.

2 Click Screen Area or Application.

Application Select this option if you want to specify the application which you want to record as part of your project. 
In the Select Application menu, select the application that you want to record and select one of the following:

Custom Size Select this option if you want to customize the dimensions of the recorded project. You can choose 
from a list of standard sizes, or define a custom size. The selected application is automatically resized to fit inside 
the boundaries of the recording area. Best practice is to have a clear idea of the dimensions of the project before you 
start recording it.

Application Window Select this option if you want to record the entire application window. The dimensions of the 
application are not altered. The recording rectangle is resized to fit the application.

Application Region Select this option if you want to record defined areas in an application. For example, if you are 
recording a window that has three frames, the recording window snaps to individual frames when the mouse moves 
over them. The dimensions of the application are not altered. The recording rectangle is resized to fit the defined 
area in the application.

Screen Area Select this option when you want to capture all events that occur within an area on the screen.

Custom Size Select this option if you want to record your project using a specific dimension. You can choose from 
a list of standard sizes, or create your own custom size window.

Full Screen Select this option if you want to set the size of the recording window to the size of your monitor screen. 
The entire computer screen is treated as the recording window. If you work on dual monitors, you can choose the 
monitor that you want to use for recording. Recording in this mode can potentially produce large projects and 
output file sizes due to the large screen resolution on monitors.

3 Click Automatic or Manual in the Recording Type area. For more information, see Automatic recording, and 
Manual recording.

4 Do one or all the following:

• Select a panning mode if you want the recording window to follow your movements across the screen. For more 
information, see Panning.

• If you are adding commentary during recording, select the type of audio input.

• To change the default settings that Adobe Captivate uses when recording, click Settings at the bottom of the
recording options. For more information on customizing recording preferences, see Set recording preferences in 
Adobe Captivate.

5 Click Record.

6 If you have selected Manual recording, press Print Screen (Windows) or Command+F6 (Mac) every time you want 
to take a screenshot during the procedure.

7 Press End key (in Windows) or Cmd + Enter (Mac OS) when you have completed recording.

Note: Alternatively, on Windows, click the task icon or the system tray icon to stop recording. On Mac, click the dock 
icon or the status bar icon.
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The recorded slides are now inserted in a new Adobe Captivate project.

For a demonstration of the recording process, see www.adobe.com/go/learn_recordtutorial_en.

Record additional slides for existing projects
1 Open the project in which you want to record additional slides.

2 Click the Record Additional Slides icon ( ).

3 In the Record Additional Slides dialog box, select the slide after which you want the recorded slides to be inserted 
and click OK.

The recording window appears.

4 Set the recording options and click Record.

Note: You can record a video as an additional slide by selecting Video Demo in the recording options.

The newly recorded slides are inserted into your project after the slide you selected.

You can also add slides by importing them from other Adobe Captivate projects or PowerPoint presentations.

Mark slides to revisit after recording
Sometimes, while recording simulations, you may click an option that you initially did not plan for. This action can 
result in unwanted slides in your recorded project. To locate such unwanted screen captures later after recording the 
entire project can be an arduous task, especially if you have many slides.

To locate the slides you want to delete or revisit in a recorded project, press Ctrl + Shift + Z while recording. For 
example, if you click an option on the screen and realized that it was a wrong action during recording, press Ctrl + Shift 
+ Z.

The slide that corresponds to the action is marked with an Undo marker and is hidden in the project.

The Undo marker is basically a transparent text caption on the slide. If you want to retain the slide, select the caption, 
and press Delete. Also, right-click the slide, and click Show Slide to unhide the slide.

Note: Note: You can change the keyboard shortcut for the undo marker in Preferences (Edit > Preferences > Recording > 
Keys (Global)).

To edit the slide, right-click on the slide in the Filmstrip and click Show slide. To delete the marker, click it and press 
Delete.

http://www.adobe.com/go/learn_recordtutorial_en


146
Recording Projects

Last updated 10/10/2016

Recording tips
The following tips and tricks can help you create Adobe Captivate projects quickly and easily, while also giving you 
professional, high-quality results:

Use automatic recording as far as possible Even for projects that need a few manually generated screenshots, consider 
automatic recording. Set the autorecord option, but press Print Screen (Windows) or Command+F6 (Mac) whenever 
you want to take an extra screenshot. This method is effective if you are recording a website that contains many pop-
ups, frames, and special effects. Adobe Captivate plays a camera shutter sound each time a screenshot is automatically 
captured. To generate a screenshot at a place where you do not hear the sound, press Print Screen to manually take a 
screenshot.

For example, if you are recording Microsoft Internet Explorer, there can be dynamic HTML or Flash menus that appear 
only when the mouse rolls over them. Adobe Captivate does not automatically capture the change that occurs on mouse 
rollover. Press Print Screen to manually capture the change.

Go slowly when recording, particularly when recording websites in Internet Explorer Perform actions more slowly 
than you would normally during recording. It is especially important to go slowly when capturing actions on a website 
in Internet Explorer. If you are manually recording, ensure that each web page is loaded before capturing a screenshot.

Wait for the camera shutter sound During autorecording, wait for the shutter sound before performing another action.

If you are manually recording, Adobe Captivate captures screenshots each time you press a designated key or key 
combination. The default capture key is the Print Screen key. Each time you want to capture a screenshot, press the Print 
Screen key; you'll hear the camera shutter sound.

How to pause recording
You can pause while recording an Adobe Captivate project. Any action performed after a project is paused is not 
recorded.

1 Open Adobe Captivate and begin recording a new project or slide.

2 When you want to pause recording, press the Pause/Break key (on Windows) or Cmd + F2 (on Mac OS) on the 
keyboard. When you want to restart recording, press Pause/Break or Cmd + F2 again.

Note: You can change the keys that you want to use for pausing or resuming projects in the Preferences dialog box.
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Chapter 6: Adding and Managing Objects

Object effects
Object effects help you quickly draw users' attention to the required objects on a slide. To see the effects that you can 
apply to objects, right-click an object and select Apply Effects.

You can also create effects in Adobe Animate CC and use them in Adobe Captivate. For more information, see Creating 
custom effects in Adobe Animate CC.
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Accessing the Effects panel

The Effects panel is located within the Timing tab of Property Inspector.

You can access it by:

• Right clicking on an object and select Apply Effect, or,

• Directly access it by opening the Timing tab on the Property Inspector.
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Options on the Effects panel
Animation Trigger The trigger for a specific object effect. The triggers can be time-based or event-based. Object effects 
with the time-based trigger are applied after the previous object is played. Object effects with event-based triggers are 
applied when specific events occur, such as, a click of a button or an entry to a specific slide. 

Applied Effects List The list of different effects that are available categorized into different categories: 

• Basic

• Emphasis

• Entrance

• Exit

• Motion Path

Previews for all the effects are available. Hover on the effect to preview the behavior of the object.

Show/Hide Motion Path Select this check box if you want to show or hide the motion path.

Effect Start Time in seconds when the effect is scheduled to start playing

Effect duration Duration of the effect in seconds

Transition The different entry and exit transition options and timing available for a particular effect.

For a specific object, you can apply effects with both time-based and event-based triggers. Object effects with event-
based triggers take precedence over effects with time-based triggers.

Creating event-based animation triggers
1 Select the object that is the base for the event. For example, to apply an effect to an object after a specific slide begins, 

select the slide.

2 In the Actions panel, select Apply Effect in the On Enter or On Success drop-down lists.

3 In the Object Name drop-down list, select the object to which you want to apply an effect. 

4 (Optional) All triggered effects have an option that allows you to reset the object effect back to the original after the 
effect is played. If you want the object to return to the original, select Reset object after effects. 
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Note: This option is available for triggered events only.

An event-based animation trigger for the selected object is created and listed in the Effects panel. You can choose the 
event-based trigger while applying an effect to this object.

Applying effects to individual objects
1 Right-click (Windows) or Control-click (Mac OS) the object and then select Effects. 

2 In the Animation Trigger drop-down list, select a trigger for the effect. By default, the time-based trigger is selected. 
To apply the object effect when a specific event occurs, create an event-based trigger, and then select it in the Effects 
panel.

3 Click next to the Applied Effects List and select the effect to apply to the object. To use an already saved effect, 
click and locate the XML file that corresponds to the effect. The imported effect is now visible under Custom 
Effects.

You can create a sequence of effects by applying multiple effects to a single object.You can also add effects to groups 
of objects. Simply group a set of objects and apply an effect. When an effect is applied to a group of objects, the entire 

group behaves like a single object, and the effect is applied from the center of the group. Note: Effects applied to 
individual objects are not retained if an effect is applied to an entire group of objects.

4 Preview the effect using one of the previewing methods discussed in Previewing effects.

5 To apply the effect to multiple objects, click and select either

• Apply To All Items To apply the effect to all objects that belong to the object type.

• Apply To All Items Of Same Style To apply to all objects that use the same object style.

6 To apply effects to groups of objects, simply group a set of objects and apply an effect.

When an effect is applied to a group of objects, the entire group behaves like a single object, and the effect is applied 
from the center of the group. 

Note: While applying effects to object groups, keep in mind that effects applied to individual objects are not retained.
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Applying effects to a group of objects
You can apply effects on a group of objects as well as to individual objects in a group. 

To apply effects to a group, simply group the objects on the slide, and then apply an effect on them just like how you 
apply effects to individual objects (see Applying effects to individual objects).

You can then see the effect applied on the group in your timeline. Individual effects applied to different group members 
can also be seen if you expand the object as shown here.

Note: The effects on a group and on individual member objects are summative. For example, if a group of objects is set to 
rotate right, and an individual object is also set to rotate right, then that object rotates to an angle which is the sum of both 
the rotations.

Things to consider when applying effects on groups and individual group members
The ability to apply effects on a group of objects and on individual group members is a very powerful feature and can 
be used to demonstrate a variety of concepts, such as, for example, the movement of planets around the sun, while at 
the same time rotating around their individual axis.

However, keep some of the following tips in mind while using this feature to get the best impact:

• Effects applied on a group that is set to play for rest of project will not display at runtime if:

• Any object is interactive and has feedback shapes enabled

• Some objects have Place Object on Top checked while others don’t

• When a group contains an object that does not support effects (such as Zoom Area) then the group also does not
support effects

• When objects in a group are also used in a drag and drop interaction, then the group effects do not play

• When the group includes a video object

Previewing effects
You can check the status of an object before and after applying the effects using the preview feature.

You can preview the effect associated with an object, in one of the following ways: 

• By clicking the play icon in the Property inspector or

• By moving the mouse over (hovering) over the effect in the Effects panel.

Drag over the playhead in timeline to compare the position of any two effects. At any point in time, you can identify on 
each frame how the object is moving when any motion object moves over a particular effect. 

To preview all the effects on all the objects on the stage, click Preview > Play Slide or click the Play icon in the timeline.
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Defining motion paths for objects
1 Right-click (Windows) or Control-click (Mac OS) the object and select Apply Effect to show the Effects panel in the 

Property Inspector.

2 In the Animation Trigger drop-down list, select a trigger for the effect. By default, the time-based trigger is selected. 
To apply the object effect when a specific event occurs, create an Creating event-based animation triggers, and then 
select it in the Effects panel.

3 Click the Plus icon, select Motion Path from the dropdown menu, and then select the type of motion path you want 
to apply.

4 Click the symbol that appears at the right corner of the object. The direction of the motion path indicated by an 
arrow appears.

5 To change the direction of motion, click the arrowhead and drag it in the new direction.

New effects added
The following custom motion effects are available in the Motion Path drop-down in the Effects panel: 

• CustomCurves To draw custom curved curved motion paths. Click along the path you want the object to move
along to create the motion path. Anchor points are created along the path, tweak these anchor points to refine the
movement of the object.

• CustomLine To draw a motion path consisting of straight lines.

• CustomScribble To draw motion paths following the motion of your hand on the stage. Hold the mouse down and
move across the stage along the path you want the object to take. Anchor points are created along the way, tweak
these anchor points to refine the movement of the object.
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Modifying object effects
Use the Effect Properties panel in the Effects panel to modify the properties of an object effect. To show or hide 
properties, change the default values, or the range of values, edit the <effect_config> section in the XML file of the 
object effect. The XML files for the default object effects are at <Installation folder>/Gallery/Effects (Windows) 
\Applications\ Adobe Captivate 6\Gallery\Effects (Mac OS).

Effects behavior in multi-state objects
When an effect is applied to an object that has multiple states, the effect is seen on all the states of that object.

You cannot edit effects on any state in an object without affecting all the states in that object. 

Timeline effects
You can view all applied effects on the main timeline.
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If you want to simplify your timeline, you can remove the effects from the timeline by going to Windows > Effects > 
Enable/Disable Effects on Timeline.

Creating custom effects in Adobe Animate CC
You can save classic tweens as XML files in Animate CC and then use the effects in Adobe Captivate. To select and apply 
an effect created in Animate CC, right-click on an object and select Apply Effects.

The Effects Panel opens in the Property Inspector.

Click the Browse icon next to the Applied Effects List and navigate to the folder where you have saved the effect file.

You can create the effects with any default duration you want. For a 30 fps project, an effect with 60 frames has a default 
duration of 2 seconds.

To make the parameters of the effect available on the user interface for editing, edit the XML file to specify the required 
parameters. These parameters appear on the left side of the Effects panel.

To enable editing of parameters:

1 Open the XML file and in the Keyframes element, identify the property that you want to make available for editing 
on the user interface.

This property typically has a numerical value assigned to it.

2 Change the numerical value of the property in the Keyframes element to a string.

3 Add a new element, effect_config to the XML file. In this element, add a config_item element for every property that 
you want to make available for editing on the user interface. For details on the elements and attributes that you can 
add in this element, see XML elements for effects configuration parameters.

4 In the config_item element (child of effect_config), add the attribute property_value. 

5 Specify the string that you assigned to the property in step 2 as the value for this attribute.

6 Add the other attributes, such as type and default_value. For more information, see XML elements for effects 
configuration parameters.

7 Repeat steps 4, 5, and 6 to enable editing for as many properties as you want.

XML elements for effects configuration parameters
The hierarchy of the effect_config element is as follows:
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<effect_config> 
   <config_item> 

<effect_property type="number" property_value="BLUR_X" default_value="50"/> 
   </config_item> 
   <config_item> 

<effect_property type="list" property_value="QUALITY" default_value="1"> 
<list_items> 

<list_item> 
</list_item> 

</list_items> 
</effect_property> 

   </config_item> 
   <config_item> 

<effect_property type="color" > 
<effect_sub_property> 
</effect_sub_property> 

</effect_property> 
   </config_item> 
</effect_config>

Element Attribute Value Description

Table 1. 

effect_config effect_type motion_path Type String. Use this 
attribute to display 
the handles for 
editing the x and y 
coordinates of the 
motion path.

config_item display_name Type String. Specify 
the name of the 
configuration item 
(property) displayed 
to users on the 
Effects panel.
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effect_property property_value

This attribute is 
mandatory.

Type String. Specify 
the value of the 
configuration item. 
This value must be 
the same as the one 
that corresponds to 
the appropriate 
property in the 
‘Keyframes’ element.

For example, in the 
Glow.XML file 
(Gallery > Effects > 
Filters), the Keyframe 
element contains 
BLUR_X as the value 
for blurX. To make 
the value of ‘blur’ 
editable from the 
user interface, add 
BLUR_X as the 
property_value in 
the effect_config 
element.

default_value Type number. 
Specify the default 
value displayed on 
the user interface.

valid_range

Syntax: 
valid_range="{{0,255
}}"

Type number. 
Specify the range of 
values applicable for 
the configuration 
item. For example, 
valid_range="{{0,255
}}" indicates that the 
lowest value is 0 and 
the highest is 255.

You can specify the 
attribute ‘modifiers’ 
to modify the value 
specified on the user 
interface.

type

This attribute is 
mandatory.

number Use this type to 
indicate that the 
configuration item is 
a number. You can 
specify the following 
attributes with this 
type:

• valid_range

• increment

• modifiers

• decimal_places

Element Attribute Value Description
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list Use this type to 
indicate that the 
configuration item is 
a drop-down list. You 
can specify the 
following attributes 
with this type:

• name

• value

color Use this type to 
indicate that the 
configuration item is 
to be associated with 
a color palette. You 
can specify the 
following attributes 
with this type:

• rgb

• alpha

bool Use this type to 
indicate that the 
configuration item is 
a Boolean. The 
configuration item is 
associated with a 
check box.The 
default value can be 
true or false.

seperator Use this type to 
separate the 
configuration items 
with a horizontal 
space on the user 
interface.This type 
can be used only for 
the config_item 
element.

increment Type number. 
Specify the value by 
which the parameter 
must be 
incremented when 
you click the 
parameter value, 
hold-down the 
mouse button, and 
move the mouse.

Element Attribute Value Description
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modifiers

Syntax: modifiers= 
"{offset:0,multiplier: 
0.01}"

• offset

• multiplier

Type number. Use 
this attribute to 
modify the value 
specified on the user 
interface. Use Offset 
to increase or 
decrease the value 
specified on the user 
interface. To 
decrease the user-
specified value, use a 
negative number as 
the Offset.

Use multiplier to 
multiply the value 
specified on the user 
interface by a 
number.

This attribute can be 
used with the type 
‘number’ only.

decimal_places Type number. 
Specify the number 
of decimal places to 
be allowed for the 
configuration item. 
For example, a value 
of 3 allows you to 
specify 0.001 and not 
0.00001.

list_item

(child of 
effect_property and 
list_items)

name Type string. Specify 
the name of the list 
item(s).

Element Attribute Value Description
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Best practices for creating effects in Animate CC
• Ensure that the FPS of the Animate application you are creating for effects is 30.

• Ensure the value of ‘property_value’ in the effect_config section of the effect file (XML file) is the same as that of the 
one in the Keyframe section.

• Break a single effect into multiple effects if the number of parameters is more than five. You can then create a
sequence of these effects to achieve the desired result.

• Avoid exporting an effect created using frame by frame animations in Animate. You cannot achieve the desired
results when such effects are used in Adobe Captivate.

Instead, create effects using classic tweens and import these tweens into Adobe Captivate.

• Group the effect parameters by keyframes. You can use the ‘seperator’ type

• to group related properties

• .

• Check if the XML file of the effect exported from Animate is valid, before using it in Adobe Captivate. To do so, open
the XML file in a browser or an XML editor.

Saving and deleting effects
1 Click in the Effects panel.

2 Browse to the location where you want to save the effect or the effect sequence, and click Save. The effect sequence 
is saved as an XML file.

3 To delete an effect, select the effect, and then click .

value Type number. 
Specify the value 
that must be posted 
back to the 
Keyframes section 
when users select a 
list item.

effect_sub_property

(child of 
effect_property)

rgb Use this attribute to 
specify the default 
hexadecimal RGB 
number. For 
example, specify 
rgb=”ff0000” for 
red.This attribute is 
valid for the type 
‘color’ only.

alpha Type number. Use 
this attribute to 
specify the default 
transparency of the 
color.

This attribute is valid 
for the type ‘color’ 
only.

Element Attribute Value Description
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After saving an effect sequence, you can apply it to another object in the project.

When you use the effect sequence again (at least once) in the project, it becomes available in the Advanced Actions 
dialog box. 

Note: However, when you apply the effect sequence using this dialog box, the result of the effect may differ. For example, 
the duration of the effect does not get scaled proportionately based on the object's timeline. See Introducing effects in 
Captivate for more information.

Inserting web objects in Adobe Captivate projects

Overview
You can insert Webobjects into the slides using Objects > Web. Type the URL in the Address bar of Property Inspector 
and the web page appears in theWeb object container. You can also click folder icon adjacent to Address bar, and fetch 
the local content into the web object container.

Webobjects is the native object now. You can browse OAM file (Adobe Edge Animate), pdf, and zip files. Use Auto Load 
option to enable Autoloading of file in Output. If Auto Load is not enabled, user needs to click Play button to view the 
object.

Create web object
1 From the toolbar, choose Objects>Web as shown below: 

2 Enter the url for web object in Address bar. You can also browse for OAM, pdf, and zip files by clicking the folder 
icon adjacent to the address bar. 

http://blogs.adobe.com/captivate/2010/07/a_picture_is_worth_a.html
http://blogs.adobe.com/captivate/2010/07/a_picture_is_worth_a.html
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Note: For any additional help, click the blue colored i icon. 

Select the Auto Load option if you wish to load the object automatically in output. By default, auto load option is 
selected when you create web object. In edit mode, after loading the object user needs to mouse over the object to 
start viewing the content.

If the auto load option is not selected, in the output you need to click the Play button to view the content. 

Choose to show the web object in slide or in new browser window by clicking the Display in drop down. 

For display in slide,

Border Select this option, if you wish to view the border for the web object. 

Scrolling Select this option, if you wish to view the scroll bar when the content of object is bigger than the container. 

Loading Animation Select this option if you want any animation within the web object to load. 

For display in new browser window, 

Default Choose this if you want to view the web object with default browser settings. 

Full Screen Choose this option if you want to view the web object in full screen.

Custom Choose this option if you want to view the web object within your customized width and height 
dimensions. Click the blue-colored values corresponding to width and height and specify your preferred values. 

Embed code support
Click Embed code radio button if you would like to embed any web oject such as a video file. You can paste the embed 
code at the text area. 

For example, you can see the embedded video in mobile view when you paste the following embed code: 

<iframe width="854" height="800" src="//www.youtube.com/embed/o_znYZ7Ry-0" frameborder="0" 
allowfullscreen></iframe>
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You can change the height and width of the embedded video by changing the size of web object container. Video 
maintains its width by following the width of the web object container and maintains its aspect ratio for height.

Note: When you zip the published content, ensure that the index.html file is not in any of the internal folders, else it does 
not load as expected.

Some things to consider when using web objects with Adobe Captivate 9

In Adobe Captivate 9, web objects and HTML 5 animations (when layered with other shapes) 
always appear on top
To work around this issue in HTML5, do the following:

1 In your Captivate installation folder, open the AdobeCaptivate.ini file.

2 Edit the file to change the value of UseWidget7 to 1 as follows:UseWidget7=1

3 Close and re-launch Adobe Captivate. 

You can now position your web objects on top or bottom, and they appear as expected in HTML 5. 

Note: This workaround is applicable for HTML5 publish option and for static pages or animationsonly.

A secured LMS(https) may not allow you to launch unsecured (http) page embedded in a web 
object
When referring to a http website (in a web object) in an https secured LMS environment, the LMS does not allow the 
content to launch an un-secured website. 

The content launches fine in the Captivate preview server because it is http based. However it does not work in SCORM 
cloud or Captivate Prime as those LMSs are https based.
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Click-jacking websites are not supported in a web object
If the simple HTML page in a web object is a redirect to another different web page, then this is not supported in Adobe 
Captivate.

Some websites may not allow you to open it in another page or window. To test whether a site is supported in the Web 
object, you can have a simple HTML page with an iframe, and see if your URL works. If it works there, it will also work 

in the web object.

Some of the website doesn’t allow you to browse from another ones because of Click Jacking. One of the ways web 
sites prevent themselves from this attack is by not displaying when loaded in a Frame or iframe. websites like 
Google, facebook, youtube doesn’t allow them to load in another pages well. As Web object interaction on run time 
loads the website in an iFrame such protected websites when loaded doesn’t show up."

Just to check whether a particular website is click Jacking site or not? Create a sample html with the following 
source code and run that page in you test website. If this shows up it will work fine with WebObject too.

Working with object styles in Adobe Captivate
Object style is a set of visual attributes, such as color and font. Objects in a project automatically inherit the styles 
defined in the theme applied to the project.

You can do the following with object styles:

• Customize object styles by modifying the predefined style attributes

• Import or export custom object styles from one project to another

• Search for objects that use a specific style

Customize object styles
1 Go to Edit > Object Style Manager.

2 From the list of objects, select the object for which you want to customize the style.

Note: Runtime Dialog is for the messages that are displayed when users click the Submit All button. For more 
information on Submit All, see How to enable learners to submit all quiz responses simultaneously.

3 Click Clone, and then enter a name for the custom style.

4 Specify the style properties, and click OK.

5 To apply the style to an object, select the object and then select the object style from the Properties panel.

Editing object styles

Edit object styles using the Properties panel
The changes made to the object styles using the Properties panel are applied only to the selected instances of an object. 
When an object style is modified using this panel, the name of the style is prefixed with a '+' mark. This mark indicates 
that the style is now in an overridden state.

• Click to apply the changes to objects that use specific styles. Click to merge the changes into the style. To
replace any overridden instances of the style in the project, select Replace Overridden Styles.

http://en.wikipedia.org/wiki/Clickjacking
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• Click to create a style that contains the modifications.

Edit object styles using the Object Style Manager
1 Go to Edit > Object Style Manager.

2 From the list of objects, select the object whose style you want to edit.

3 From the list of styles, select the style you want to edit.

4 Modify the properties of the style as required.

5 Do either of the following:

• To apply the changes and continue working with the Object Style Manager, click Apply.

• To apply the changes and exit the Object Style Manager, click OK.

The changes made to the object styles using the Object Style Manager are applied to all instances of the object. However, 
instances of objects that are in the overridden state (indicated by a ‘+’ mark in the Properties panel) are not updated 
with the changes. To update such objects, select the objects and click in the Properties panel.

Export, import, and delete object styles
 Go to Edit > Object Style Manager.

• To export, select an option in the Export drop-down list and then click Export. Select a location to store the
object style (in .cps format).

• To import, click Import and then select the .cps file that corresponds to the required object style.

• To delete, select the style to delete. Select a style to replace the current style, and then click OK.

Finding objects with specific styles
1 Go to Edit > Find And Replace. The Find And Replace panel appears.

2 Select the type of object in the Search In drop-down list.

3 Select the style in the Style drop-down list.

4 Do either of the following:

• To find the objects that use the specified style one after the other, click Find Next.

• To find all the objects in the project that use the specified style, click Find All. The search results are grouped
slide-wise in the Find And Replace panel.

How to rotate objects in Adobe Captivate
You can apply a 2D rotation to objects on a slide. 2-D rotation is turning of an object by an angle about a fixed point, 
which in Adobe Captivate is the center of the object.

You can rotate all objects except the following:

• Slidelet

• Mouse

• Answers for question slide objects
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• Zoom destination and Zoom source

1 Click the object that you want to rotate. A rotation symbol appears at the top handle of the object.

2 Click the symbol and move the mouse in the direction. While you move the mouse, Adobe Captivate displays a
dotted-line preview of the position of the object on the stage. 

3 Release the mouse button when the object is positioned in the required angle.

Alternatively, select the object on stage, and specify the angle of rotation in the Property Inspector (Transform 
accordion > Angle).

When you rotate objects with text, the text is also rotated along with the object.

To reset the rotation angle to 0°, double-click the rotation symbol.

Note: The rotation is not applied to animations and slide videos while they are played on stage. Adobe Captivate applies 
the rotation appropriately in the project preview and published output of the project.

Object rotation and object effects
You can rotate objects through object effects too. If you apply a rotation object effect to an already rotated object, it 
rotates further when the effect gets triggered. 

For example, consider that you have rotated a rectangle by 45°. You then apply the rotation object effect to the rectangle, 
and specify the angle as 30°. You time the effect such that it gets triggered 2 seconds after the slide begins and lasts until 
the end of slide. 

When the project is played, the rectangle is rotated by 45° for the first 2 seconds. For the rest of the slide, the rectangle 
is rotated by 75°.

Rotation of objects in a slidelet
The rotation of objects within a slidelet is limited by the boundaries of the slidelet. This means, if you rotate an object 
and a portion of it potentially protrudes out of the slidelet boundary, then the rotation does not take effect. 

Resize and reposition objects by pixel
You can change the X and Y coordinates and the width and height of the objects in the Transform area of the Property 
Inspector.

How to manage objects with the Main Options toolbar
The Main Options toolbar contains the following icons to help you manage objects:

• Cut, copy, paste, delete, and duplicate

• Record additional slides for the current project

• Record audio

• Record background audio

• Collaborate (using Acrobat.com)

• Bring selected object to front
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• Send selected object to back

• Bring selected objects forward in z-order

• Send selected objects backward in z-order

• Snap to object

• Show/hide grid

• Snap to grid

How to merge objects in a slide
You can merge any object that you create and place on a slide, including images, captions, click boxes, highlight boxes, 
text entry boxes, and buttons. Merging permanently removes the interactivity of the object, making it an image of the 
object.

The merging feature is useful in several situations. For example, suppose you import a large image into a slide that 
contains other objects. You can merge the image into the slide so that it becomes a static background for the other 
objects. You can also make text a permanent part of a slide by creating a transparent text caption and then merging the 
caption.

1 Open the slide that contains the object you want to merge.

2 Right-click (Windows) or Control-click (Mac OS) the object that you want to merge into the slide, for example, an 
image, caption, or click box.

3 Select Merge Into Background from the pop-up menu. 

4 The object is merged into the slide.

Note: Merging objects in a slidelet into the background will merge the object into the slidelet background.

How to manage objects in the library

View objects in the Library
1 Select Window > Library.

The Library panel appears.

2 Open a folder (Audio, Backgrounds, Images, Media) to view the objects in that category.

3 Click an individual object to display it in the Library preview pane.

In addition to viewing image files, you can play audio and animation files in the Library preview pane. 

Reuse an object listed in the Library
1 Select Window > Library.

2 In the Library panel, expand the folder for the category of object you want to reuse.
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3 Click the object that you want to reuse and preview the object in the preview pane.

4 Drag the object to the selected slide or slidelet. The object becomes a part of the slide or slidelet depending on where 
it is placed.

Note: After you copy the object to the slide, editing the properties of the object will not affect other instances of that object 
in the project.

Reuse an object in a different project Library
1 Select Window > Library.

2 In the toolbar of the Library panel, click the browse icon.

3 Navigate to, and select, the project that contains the objects you want to reuse and click Open.

The library for the other project opens in a separate and expandable window.

4 Click to select the object that you want to reuse.

5 Drag the object to the selected slide stage or to the appropriate folder in your current project Library.

The new objects now appear in your current project Library, even if you dragged them directly onto a slide. You can 
reuse them as many times as you want.

Note: After you open the Library of another Adobe Captivate project, that project stays in the Open Library menu. You can 
quickly access that project Library at any time.

Delete unused objects from the Library
1 In the Library panel (Window > Library) of your project, click . The unused items are highlighted in the Library.

2 Click .

More Help topics 
Adobe Captivate Library

How to group objects in Adobe Captivate
To work with your projects faster, you can group objects on a slide. Grouping lets you move, rotate, or edit multiple 
objects as if they were a single object. For example, you select a group and apply a shadow effect. Changes made to the 
group are applied to all the objects in the group at the same time.

1 Hold down the Shift key (on Win) or Command key (on Mac) and click the objects that you want to group. You can 
also select existing groups to combine them into a single group.

Note: Nested grouping is not supported in Adobe Captivate.

2 Click Edit > Create Group.

3 In the Property Inspector, specify a name for the group, if required.

A new ‘folder’ (for example, Group_1) comprising the grouped objects is created in the Timeline.

When you hover your mouse over an object in a group, the outline of the group is marked with dashed-lines. 

http://helpx.adobe.com/en/captivate/using/captivate-library.html#adobe_captivate_library
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When you select an object for grouping, all related objects also get grouped. For example, if you select the ‘Success 
caption’ associated with a click box, failure, hint captions and the click box are also grouped.

You cannot group the following objects:

• Slidelet

• Mouse

• Audio

• Question items and answers

On question slides, you can group only objects, such as, highlight boxes and buttons.

You can ungroup a group of objects and group them again as necessary.

Object groups and z-order
The ‘group’ folder in the Timeline is created on the layer of the object with the hightest z-index. In the ‘group’ folder, 
the objects are stacked with the descending order of z-index (from top to bottom of the Timeline).

You can change the z-order of the grouped objects in one of the following ways:

• Right-click the object stack, click Arrange, and choose the appropriate option.

• Drag-and-drop the object stack at the required level (z-index0.

Ungroup objects
• To ungroup all objects in a group, click the group, and then click Edit > Ungroup.

• To remove a specific object from the group, click the group and then click the object. Right-click on the object, and 
click Remove From Group.

Edit object information using the Advanced Interaction 
panel
The Advanced Interaction panel (Project > Advanced Interaction) provides an overview of all interactive objects in 
your project. The objects are grouped slide-wise. 
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This panel contains the following information that helps you analyze the actions and properties associated with the 
interactive objects:

Slide/Object This column shows the slide number and label, or the type of object. 

Instance Name This column shows the name of the object’s instance.

On Success This column shows the navigation that follows the slide if the user successfully completes an object’s action. 
For more information, see Project navigation using interactive objects.

Attempts This column shows the maximum number of attempts you have set as a limit for an interactive object.

On Failure If an object or slide has the possibility of failure (for example, if an incorrect answer is selected in a multiple-
choice question), this column shows where the slide leads after failure. For more information, see Project navigation 
using interactive objects.

Shortcut View and edit keyboard shortcuts for a slide or object in this column.

Time Limit This column shows the time limit for specific objects.

Points This column shows the total points associated with each scoreable object or question slide.

Add To Total indicates the total value if scored objects are included in the total points.

Include In Quiz Indicates whether the interactive object carries a score for the overall project quiz.

Report Answers Indicates whether or not your project quiz scores are integrated with a learning management system 
(LMS). 

Objective ID and Interaction ID These columns contain the ID numbers, if you assign them, for integration with a 
learning management system (LMS).

Note: To make reviewing the project information easier, click the print icon to print the tabular view of the interactions in 
the panel.

To edit the properties of objects:

1 In an open project, select Project > Advanced Interaction, or press F9. 

The Advanced Interaction panel appears, populated with a collapsible list of all interactive objects in the project.

2 Filter the list by clicking the buttons at the top of the dialog box that correspond to the object types that you want to 
view.

Note: You can choose to filter by all scorable objects, click boxes, text entry boxes, buttons, questions, or hidden slides.

3 Click a slide title or object to select it. The Property Inspector of that object appears and lets you edit the properties.

How to copy, paste, and duplicate objects in Adobe 
Captivate
After you have created an object, you can copy that object and paste it onto the same slide, a different slide in your 
project, or several slides in your project at the same time. This can save you a great deal of time, especially if you create 
intricate objects with specific sizes, colors, and formatting.

You can also copy and paste objects between different projects. 

Note: To reuse media objects that appear in the Library, simply drag the object from the Library onto the slide.

http://help.adobe.com/en_US/captivate/cp/using/WSc1b83f70210cd10143917dad11c8370a5cf-8000.html
http://help.adobe.com/en_US/captivate/cp/using/WSc1b83f70210cd10143917dad11c8370a5cf-8000.html
http://help.adobe.com/en_US/captivate/cp/using/WSc1b83f70210cd10143917dad11c8370a5cf-8000.html
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When objects from a slide are copied into a slidelet, the following properties of the objects are modified:

• If timing for the object is specified as Rest Of Slide or Rest Of Project, it is changed to Rest Of Slidelet.

• The option Synchronize With Project loses its validity for FLV files.

Copy an object to a different slide
1 Open the slide that contains the object.

2 Right-click (Windows) or Control-click (Mac OS) the object and select Copy.

3 Open the slide to which you want to copy the object. 

4 Right-click (Windows) or Control-click (Mac OS) the slide and select Paste.

Copy an object to multiple slides
1 Open the slide that contains the object.

2 Right-click (Windows) or Control-click (Mac OS) the object and select Copy.

3 In the Filmstrip, select the slides to which you want to copy the object. Hold down the Shift key and click consecutive 
slides, or hold down the Control key and select any slides, even if they are not consecutive. 

4 Right-click (Windows) or Control-click (Mac OS) a selected slide and select Paste.

Copy objects from other projects
You can copy and paste objects from other projects. This strategy can save you a great deal of time. For example, 
suppose you have created a detailed object in another project. Simply copy and paste the object into any new projects 
you create.

Note: To reuse media objects from another Adobe Captivate project, open that project Library from within your current 
project Library. Then drag objects directly onto a slide or into the current project Library for easy reuse.

1 Open the Adobe Captivate project that contains the object you want to copy.

2 Right-click (Windows) or Control-click (Mac OS) the object, and select Copy.

3 Open the Adobe Captivate project to which you want to add the object copied in the previous steps.

4 Right-click (Windows) or Control-click (Mac OS) the slide to which you want to add the object.

5 Select Paste.

You can also copy Advanced Actions and Shared Actions associated with the objects. To do so, copy the objects 
referenced from within these actions in addition to the parent object to which the actions are assigned.

Duplicate objects
Duplicating objects is an easy way to reuse content. For example, you can duplicate a detailed caption and change some 
of the text to quickly add more information to your project.

Note: To reuse media objects that appear in the Library, simply drag the object from the Library onto the slide.

1 Open the slide that contains the object you want to duplicate.

2 Right-click (Windows) or Control-click (Mac OS) the object and select Duplicate. 

The object you selected is duplicated and the new object is placed on the slide. You can edit and work with the new 
object just like the original object.
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In Cp 7, hold down the Control key (Windows) or the Command key (Mac) and drag the object to duplicate.

Controlling the visibility of objects
You can hide an object on a slide, and define conditions that must be satisfied for the object to be displayed. 

The following example illustrates how to hide an image on a slide until the user clicks the Show Image button.

1 Select Insert > Image to insert an image on the slide.

2 In the Property Inspector, type a name for the image in the Name text box. For example, My_Image.

3 Clear the Visible check box.

4 Select Insert > Standard Objects > Button.

5 In the Action area of the Property Inspector, select Show in the On Success list, and then select My_Image in the 
Show list.

When you play the movie, the image appears only when you click the button.

How to change the display order of objects in Adobe 
Captivate
Adobe Captivate lets you add multiple objects, such as captions, highlight boxes, animations, or images to slides. You 
specify the order in which objects appear. Use the Timeline to precisely adjust the timing of all objects on a slide. 

1 In an open project, navigate to the slide that contains the objects whose order you want to change.

2 Change the order and timing of objects as required. 

For example, move the mouse over the left or right edge of an object on the Timeline until the resize cursor appears. 
Then drag the edge left or right to change when and for how long the object appears. 

If you have an object that currently appears at the same time the slide appears, but you want a slight delay, move the 
mouse over the center of the object on the Timeline until the hand appears; then drag the entire object so the left 
edge aligns with 2s (a 2-second delay) or 4s (a 4-second delay) in the header.

3 If you have two overlapping objects on the slide, specify the object you want to appear frontmost by setting the 
stacking order. To change the stacking order, move objects to the back or front of the slide Stage. The key point to 
remember is that objects at the back of the Stage appear behind other objects. Use one of the following methods to 
set the stacking order:

• Right-click (Windows) or Control-click (Mac OS) an object on the slide and select one of the object order
options. If necessary, Right-click (Windows) or Control-click (Mac OS) other objects on the slide and adjust their 
order.

• In the Timeline, move the pointer over an object until the hand appears. Then drag the object up or down to
change its position in the stacking order. Moving an object higher in the stacking order moves it to the front of
the Stage. Moving an object lower moves it to the back of the Stage.

Note: If the order for a slidelet is changed, the objects it contains are also moved back or forward along with the slidelet.
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Apply shadows to objects
You can apply shadow effects to all objects in Adobe Captivate, including the placeholder objects. You can also apply 
shadow effects to objects on Master Slides.

1 Select the object on the slide. You can also select multiple objects by holding down the Shift key (Windows) or the 
Control key (Mac).

2 In the Property Inspector, click Enable in the Shadow accordion. The shadow is applied to the object with default 
settings. If you have applied a shadow to any object before, those shadow settings are applied by default.

3 To modify the shadow, do one or both of the following actions:

• Click one of the options in the Direction check list.

• Click one of the preset options, or specify the required properties, such as, color (with transparency), distance,
blur, and angle.

Note: You can modify these properties even after selecting a preset.

4 To apply the effect to multiple objects, click and choose one of the options.

Apply shadows through object effects
Select the object and click Add Effect > Filters > DropShadow in the Effects panel (Windows > Effects).

If you apply a shadow to an object using both Property Inspector and Effects panel, both settings are applied based on 
the effect's timeline. 

For example, consider that you have applied a gray color shadow to a rectangle using the Property Inspector. You then 
apply the shadow object effect to the rectangle, and specify the color as green. You time the effect such that it gets 
triggered 2 seconds after the slide begins and lasts until the end of slide. 

When the project is played, the gray shadow is displayed for the first 2 seconds. After 2 seconds, both gray and green 
color shadows are displayed for the rest of the slide.

Here are the differences between the two methods of applying shadows to objects:

How to align objects in Adobe Captivate

Align multiple objects on a slide
If you have multiple objects on a slide, Adobe Captivate can automatically and perfectly align the objects for you. This 
is an easy way to create 

Through Property Inspector Through Effects panel

The shadow is applied to the object instantly. The shadow is applied based on the timeline of the shadow effect.

The shadow is visible to you at edit time, on stage. The shadow is not visible during edit time. You can see the effect 
applied during the preview or in the published output.

The shadow can be merged with the slide background by clicking 
‘Merge with Background’.

The shadow cannot be merged with the slide background.
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precise

 and professional-looking project slides.

You have many options for aligning objects both vertically and horizontally. Some of the alignment options 

depend

 upon the location of the anchor object. The anchor object is simply the first object you select. You might want to select 
the largest object or the object that appears first as the anchor object. So that you can easily identify the anchor object, 
it appears with white resizing handles, while any subsequent objects you select appear with black resizing handles.

The alignment is based on the registration point of an object, which is the upper left corner of the surrounding box of 
the object. This point is constant in Adobe Captivate and cannot be changed. In objects with thick strokes, the 
registration point is in the center of the strokes.

1 Open the slide in which you want to align the objects. The slide must contain multiple objects.

2 Select Window > Align. The alignment options display above the main toolbar, as shown below:

3 Select the objects on the slide by holding down the Shift key and clicking the individual objects. 

4 Do one of the following:

• Click an alignment option on the alignment toolbar.

• Right-click (Windows) or Control-click (Mac OS) the selected objects, choose Align, and select the appropriate
option from the pop-up menu.

The x (horizontal) and y (vertical) coordinates of the mouse are automatically displayed in the lower-right corner of 
the Adobe Captivate project window as you move the mouse. Knowing exact coordinates can help you place objects in 
a precise location on a slide. When aligning objects, it can be helpful to display the grid.

You can move objects using only the keyboard. Select an object and press an arrow key on your keyboard to move 1 
pixel at a time. To move an item by the number of pixels defined in the grid, select an object and press Control+arrow 
key.

To change the height or width of an object by 1 pixel, hold Alt and press an arrow key. Similarly, hold Alt+Shift and an 
arrow key to change the size 15 pixels at a time.

Align objects using smart guides
Smart guides appear as dotted lines when you drag objects to reposition, resize, or rotate them. Smart guides are vertical 
or horizontal lines through the center of an object. Based on these guides, objects that you drag are aligned with the 
nearest object within the threshold distance.
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Note: Smart guides do not appear when you try to reposition or resize objects using keyboard.

Smart guides are enabled by default. To disable smart guides, click View > Show Drawing/Smart Guides.

Aligning objects on the Timeline
The Timeline lets you align objects easily. For example, you can align objects to the playhead, the start of a slide, the 
end of a slide, another object, or a point in time. 

Display the Adobe Captivate Timeline
1 In an open project, double-click a slide that contains objects you want to align.

2 If it is not open already, show the Timeline by clicking the splitter bar. To expand the Timeline, click the display 
arrow. You can also open the Timeline from the View menu by selecting the Show Timeline option, or using 
Control+Alt+T.

Align an object to the playhead
When you sync an object to the playhead, the object moves to the location of the playhead in the Timeline.

• Right-click (Windows) or Control-click (Mac OS) an object on the Timeline and select Sync With Playhead.

Align an object to the start of a slide
• Click an object on the Timeline and drag it to the left side of the Timeline.

Extend the playing time of an object to the end of a slide
• Right-click (Windows) or Control-click (Mac OS) an object on the Timeline and select Show For Rest Of Slide.
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Align an object to a point in time
• Click an object on the Timeline and drag it to the left or right so that the left edge of the object bar aligns with the

correct time in the header.

For example, if you have a caption that currently appears at the same time the slide displays, but you want a slight
delay, drag the caption so that its left edge aligns with 2s (a 2-second delay) or 4s (a 4-second delay) in the header.

You can select multiple objects and move them at the same time. Hold down the Shift key and click objects to select 
consecutive stacked objects in the Timeline or to select nonconsecutive objects, hold down the Control key and click 
the objects to move.

You can adjust the zoom level of the Timeline easily. Click in the Timeline ruler and spin the mouse wheel on your
mouse to increase or decrease the zoom level.

Align objects with the grid
Adobe Captivate contains an optional grid that you can display while working on individual slides. The grid lets you 
more accurately place and position objects on a slide. 

You can also select the Snap To Grid option if you want objects that are placed near grid lines to automatically “snap” 
to the nearest lines.

Display the grid
Select View > Show Grid in an open project.

The grid, a light pattern of dots, appears on the slide.

Align objects with grid lines
Select View > Snap To Grid in an open project.

To test the snap-to-grid behavior, add an object such as a highlight box to the slide, and then move the box. As you 
move the box, it automatically lines up with the grid lines.

Change the grid scale
1 In an open project, select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Category panel, select Global.

3 In the Grid Size field, enter a new value for Grid size. Larger numbers display fewer grid lines; smaller numbers 
display many grid lines for more precise object placement.

The x (horizontal) and y (vertical) coordinates of the mouse are automatically displayed in the lower-right corner of 
the Adobe Captivate project window as you move the mouse. Knowing exact coordinates can help you place objects in 
a precise location on a slide. 

You can move objects using only the keyboard. Select an object and press an arrow key on your keyboard to move 1 
pixel at a time. To move an item by the number of pixels defined in the grid, select an object and press Control+arrow 
key.

Snap objects to guides
To precisely align objects to guides, use the Snap To Guide menu in View > Snap to Guide.

Object edges will snap to (be pulled toward) the nearest guide when you draw, move, or resize objects.
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The exact range within which an object snaps to guides is called the snap-to zone, which you can adjust by specifying 
the offset.

Keep the following guidelines in mind as you align objects to guides:

• To snap an object to a guide, drag an object toward a guide until one or more of the object’s edges is within the guide’s 
snap-to zone.

• Guides must be visible for objects to snap to them.

To align objects to guides, complete the following steps:

1 Choose View and make sure that Snap to Guide is selected (checked).

2 To specify the snap-to-zone, choose Edit > Preferences > Default > Snap to Guide offset.

3  In the Snap to Guide offset box, set a value between 5 and 25 pixels and click OK.

More Help topics 
Using rulers and guides

How to add reflection to objects in Adobe Captivate
You can add reflection to all objects and placeholders, except the following:

• Mouse

• Click box

• Rollover area

• Zoom area

• Rollover slidelet

• Text animation

• Zoom destination

• Answer items in question slides

1 Select the object on the slide. You can also select multiple objects by holding down the Shift key (Windows) or the
Control key (Mac).

2 In the Property Inspector, click Reflection in the Shadow & Reflection accordion. The reflection is added to the 
object with default settings. If you have added a reflection to any object before, those reflection settings are applied 
by default.

3 To modify the reflection, click one of the preset options.

4 To add reflection to multiple objects, click and choose one of the options.

Note: To get object reflection in the published output, choose Flash Player 10 or later in the publish settings.

http://helpx.adobe.com/en/captivate/using/using-rulers-and-guides.html
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Chapter 7: Noninteractive Objects and 
Media

How to use images and rollover images with Captivate
You can incorporate images into projects as logos, startup screens, pointers, backgrounds, buttons, and more. You can 
add images in the following formats: JPG, JPEG, GIF, PNG, BMP, ICO, EMF, POT, or WMF.

Rollover images consist of an image and a rollover area (the “hot” area). Rollover images appear when the end user 
moves the pointer over the rollover area at runtime. They are useful for heavily detailed slides or for slides that contain 
buttons or toolbars that require explanation.

You can use the same type of graphics for rollover images that you use for traditional images. You can also customize 
the location, outline, and size of the rollover area for rollover images.

Adobe Captivate contains a gallery of buttons, sounds, and animations (in SWF format) for you to use in your projects. 
By default, the gallery is stored in the following location when you install Adobe Captivate: C:\Program 

Files\Adobe\Adobe Captivate 6\Gallery (on Windows) and /Applications/Adobe Captivate 6/Gallery (on Mac OS).

Properties of images and rollover images
You can change the properties of an image using the Image Edit area of the Property Inspector (Window > Properties) 
after selecting the image on the slide.

Image
Name Enter a unique name for the object. You can use this name when defining the visibility conditions for the object. 

Visible Deselect this option if you want the object to be invisible on the slide. Use the Show option to make the object 
visible. For more information, see Controlling the visibility of objects .

Accessibility Click to add accessible text to the object. For details, see Customize accessibility text for objects

Transparent Background Select the color filler icon. All occurrences of one particular color in an image can be made 
transparent. For example, you can make all occurrences of red (#FF0000) transparent. 

Reset To Original Size Restores the image to its original size.

Select Image From Library Click the folder icon. Select this option to reuse an image in your project file. Select the 
image and click OK.

The Select Image from Library dialog box appears with the following options:

Import Import an image stored on your computer or on a network location.

Image Edit
Brightness The brightness of the image. When you increase the value for brightness, the selected image appears 
brighter.

http://helpx.adobe.com/en/captivate/using/controlling-visibility-objects.html#controlling_the_visibility_of_objects
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Sharpness Sharpening enhances the definition of edges in an image. Whether your images come from a digital camera 
or a scanner, most images can benefit from sharpening. The degree of sharpening needed varies according to the quality 
of the digital camera or scanner. Keep in mind that sharpening cannot correct a severely blurred image.

Contrast The contrast between the light and dark areas of an image. When you increase the contrast of an image, the 
brighter areas appear brighter, and the darker areas appear darker. 

Alpha The transparency of the image. At 100% Alpha, the image is opaque. At 0%, the image is transparent and 
becomes invisible.

Hue You can change the colors of an image by changing the values for its hue.

Saturation The intensity of colors in the image. When you increase the saturation value, you increase the intensity of 
the colors.

Gray Scale In a basic sense, you can convert a colored image to monochrome using this effect. Grayscale mode uses 
different shades of gray in an image. In 8-bit images, there can be up to 256 shades of gray. Every pixel of a grayscale 
image has a brightness value ranging from 0 (black) to 255 (white). In 16-bit and 32-bit images, the number of shades 
in an image is much greater than in 8-bit images.

Invert Color Inverts the colors in an image. When you invert an image, the brightness value of each pixel in the 
channels is converted to the inverse value on the 256-step color-values scale. For example, a pixel in a positive image 
with a value of 255 is changed to 0. In the same way, a pixel with a value of 5 is changed to 250.

Flip Flipping an image produces its mirror image. You can flip an image vertically or horizontally.

Rotate Rotate an image either clockwise or counterclockwise 90 at a time.

Crop Click the crop icon. Crops the image handles of the rectangular box to select the area of the image that you want 
displayed.

Fit to Stage Resizes the image to fit the dimensions of the slide.

Shadow and reflection
Shadow Select the check box to apply shadow to the image. Choose one of the presets. You can customize a preset by 
clicking Custom.

Direction Select the direction: inner or outer. The preview of the selected direction is displayed on stage. 

Color Click to select a color for the shadow. Specify the alpha for the color, in percentage, in the adjacent field.

Blur Specify a value, in pixels, for the blur of the shadow.

Angle Specify the angle for the shadow. 

Distance Specify the distance, in pixels, at which the shadow must be displayed.

Reflection Select the check box to add reflection to the image. Choose one of the presets.

Timing
Display For [Time] Specifies how long the image is displayed on the slide.

Appear After [#] Seconds Delay between the first appearance of the slide and the first appearance of the image.

Transition
Effect Transition effect for the image. You can have the image fade in and fade out of the slide during its entry and exit.

In [#] Seconds Specifies the amount of time for the image to fully fade into view.

Out [#] Seconds Specifies the amount of time for the image to completely disappear from view.
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Add an image or rollover image
1 Select the slide to which you want to add an image.

2 Select Insert > Image, or Insert > Standard Objects > Rollover Image.

3 Select an image from the list or browse to a new location for a different image. Click Open. 

4 (If necessary) Resize the image on stage or using the Crop dialog box

(Crop option in Image Edit area of Property Inspector).

Set the following options in the Resize/Crop dialog box.

Fit To Stage Resizes the image to fit the dimensions of the slide.

Crop Displays a bounding box with dimensions corresponding to that of the project. Resize the handles of the box 
to select the area that you want displayed on the slide. If you have selected Constrain Proportions, the height- to-
width ratio of the bounding box is maintained.

Zoom You can zoom in and zoom out of the image by moving the slider. Alternatively, you can choose from a list 
of standard zoom sizes from the menu.

Constrain proportions Maintains the height-to-width ratio of the bounding box used to crop the image. This option 
is enabled only when you choose to crop the image. When you disable this option, resize the bounding box, and 
enable the option again; the new dimensions are used thereafter to calculate the ratio.

5 Set properties and options as required.

6 To snap the rollover area to the edges of an object, press Alt and move the rollover area over that object. 

7 For properties with the icon, select either

• Apply To All Items To apply the effect to all objects that belong to the object type.

• Apply To All Items Of Same Style To apply to all objects that use the same object style.

8 Click OK.

The image is added to the slide. If you added a rollover image, the rollover area is also added. Drag the image to the 
desired location and adjust the rollover area as needed.

You can create a watermark image using a transparency trick. Insert an image and set the transparency to 50%. This 
setting works well with many company logos.

Insert character images
Click Insert > Characters, click one of the options from Category, and click an image.

Working with Adobe Photoshop files
This release features Adobe Photoshop round-tripping with Adobe Captivate. The Photoshop (PSD) files that you 
import to Adobe Captivate are linked to the source. You can start Adobe Photoshop (to edit the files) from within 
Adobe Captivate. 

Also, if you update the source file, Adobe Captivate lets you update the files in the library and the changes reflect in the 
slide.

Note: This feature is available only in Adobe Captivate that is installed as a part of Adobe eLearning Suite.
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Import Photoshop files
You can import a PSD file into your Adobe Captivate project, while preserving Photoshop features. You can select and 
import separate layers of the PSD file, or you can flatten selected layers and import them as a single image. 

Each imported layer is treated as a separate image within the Adobe Captivate project. In the library, a folder with the 
PSD name is created and each imported layer is stored in it in PNG format.

You can resize the imported images to the size of your Adobe Captivate project. You can also apply all other available 
image-editing properties of Adobe Captivate.

When importing a PSD file, you can select and import layer comps. A layer comp is a Photoshop feature that allows 
you to create, manage, and view multiple versions of a layout in a single Photoshop file. See Photoshop Help for more 
information on this feature.

1 In an open project, select File > Import > Photoshop File.

Note: Alternatively, you can use Insert > Image or you can also drag-and-drop the PSD file to the slide.

2 In the Import dialog box, do one of the following:

• To select separate layers of the PSD file, select the Layers option and select each layer that you want to import. To
merge the selected layers before importing, select Merge Layers.

Note: Importing each layer separately increases the size of your image file. To reduce the size of the image, you can merge 
the layers. 

To import the layers that you have not imported before, repeat the above steps and choose the required layers. The 
layers get added to the corresponding PSD folder in the Library.

• To flatten the layers and then import them as a single image, select Flattened Image.

Note: When you flatten layers, you cannot edit each layer separately within Adobe Captivate. Use this option only if you 
are sure that layer editing is not required and the image is ready to use.

• To import any layer comps, click Multiple and select the layer comp from the drop-down list. The layers in the
selected layer comps appear. Select the check boxes corresponding to the layer comps you want to import.

3 Select Scale According To Stage Size to automatically resize the image to the size of your Adobe Captivate project.

Reusing PSD items in the Library
You can reuse PSD items, such as layers and layer comps, using one or all the following ways:

• To reuse a PSD item in a slide, drag-and-drop the item from the Library onto the slide.

• To reuse a PSD item in a different project, open the target project. Then, drag-and-drop the item from the current
project’s Library into the target project. You can also copy and paste the item into the target project.

Alternatively, in the target project, select File > Import > External Library, and open the project from which you want
to import the PSD items. When the Library panel of the selected project appears, select the item and drag-and-drop 
it into the current project.

If a PSD file by the same name exists in the target project, Adobe Captivate matches the modified date of the two
files. If the dates are same, the layers get copied into the corresponding PSD file folder in the Library. If not, the layers 
are copied as normal images.

Edit PSD files
 In the slide or PSD folder in the library, select the imported PSD file, right-click (Windows) or Control-click (Mac 

OS), and then select Edit PSD Source File.



181
Noninteractive Objects and Media

Last updated 10/10/2016

You can also edit the file from image properties (Window > Properties).

Update PSD files
If the files in the Adobe Captivate library and the original files are not in sync, the status column in the library changes 
from to .

To update and bring the resource on slide in sync with the source, 

• Select the PSD on stage, right-click (Windows) or Control-click (Mac OS), and then select Update from Source.

• Click Update in the Property Inspector (Window > Properties).

• Click the status icon in the library.

• Select the PSD folder in the library, right-click (Windows) or Control-click (Mac OS), and then select Update from 
Source.

Note: The first two options update the PSD both on stage and in library. The last two options update the resource only in 
the library and the updated resources do not take effect on stage. 

If you remove or relocate the PSD, then a question mark icon appears in the status column. Click to relink. You can 
also do this action from the Image Properties dialog box.

The procedure for linking to a new PSD file is same as importing a new PSD file.

Working with SVG images
Captivate supports SVG graphics enabling you to develop scalable graphic content.

Import Scalable Vector Graphics into Captivate, and roundtrip them using Illustrator or any other vector editing 
applications.

Inserting SVG images
Insert SVG in either blank or responsive projects by clicking Media->SVG. 

Navigate to the folder where the SVG image is stored and click Open to insert the image into your project.

Editing SVG images
Edit the SVG using Adobe Illustrator or any other vector editing applications by clicking Edit SVG in the Property 
inspector. 
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Note: Edit with Adobe Illustrator option is disabled (as shown below) if Illustrator is not present on that machine. In this 
scenario, when a user clicks Edit SVG, the user is prompted to open the file with another svg image editing application.

You can resize the image from within the Property Inspector using these options:

• Original: Revert the image to its original size – This button is selected by default when the SVG is imported, and
remains selected if you don't modify the image size

• Custom: This button is selected if you change the size of the SVG image

• Fit to Stage: Resize the image so that it fits the stage

• Fit to Bounding Box: Fit the SVG exactly to its bounding container. On further modification, the SVG no longer
maintains its aspect ratio on resize. You can use this option to avoid possible truncation in some SVG images.

Replacing SVG images
You can replace an existing SVG graphic with another one.

1 Click on the SVG image to open the Property Inspector for that image.

2 Click the image name on the Property Inspector.
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3 In the Select Image from Library dialog that opens, click Import. Navigate to the folder and select the image you 
want to use.

Create watermark images
You can create a watermark image by setting the transparency of an image.

1 In an open project, select Insert > Image.

2 Select an image or browse to a new location for a different image. Click Open. The image gets inserted.

3 Set the image Alpha to 50% or lower in the Image Edit area of the Property Inspector. A low number results in a dim 
version of the image and a higher number displays a brighter image.

4 Position the image on the slide as required.

Change JPEG quality
Adobe Captivate automatically sets the quality of JPEG images in projects. However, you can adjust this setting 
depending upon the images used in your project. Using higher percentage values allow high-quality images but also 
increases file size. 

1 In an open project, select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Category panel, select SWF Size And Quality from the Project menu.

3 Enter your preferred value in the JPEG Image Quality text box. 
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More Help topics 
Set audio for noninteractive objects

Fix size and position of noninteractive objects

How to customize smart shapes in Adobe Captivate

Customize Smart Shapes
Customize shapes and reuse them across different slides and projects with ease. Use Hover state with fill for 
color/gradient/image. Now, you can use custom shapes and line to create your own objects in responsive project.

Creating your own Smart Shape
1 From Toolbar, click Shapes > Polygon

2 Draw your own shape in the slide

3 Click the small drop-down list adjacent to Custom

4 Choose Save shape as shown in the screenshot below. 

Your own shape is saved and available for reuse in other slides. You can also customize the properties of your shape 
by choosing the properties from Properties Inspector. 

Now, move to next slide and click Shapes, you can see your customized shape available in the drop-down list to choose, 
as shown in the screenshot below: 

http://helpx.adobe.com/en/captivate/using/set-audio-noninteractive-objects.html#set_audio_for_noninteractive_objects
http://helpx.adobe.com/en/captivate/using/fix-size-position-noninteractive-objects.html#fix_size_and_position_of_noninteractive_objects
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Hover State
1 Click the smart shape you created and Click Use as Button check box in Properties.

2 In State drop-down box, choose Rollover.

3 Choose the color from Fill drop-down. You can observe the color of the smart shape being changed when you hover 
your mouse on the smart shape object.

You can also use down option in State drop-down box to set properties when you release the mouse button down. 

Note: Success/Failure/Hint Captions can be replaced with Smart Shapes. Right-click the Caption and select Convert to 
Smart-shape.

Sharing a custom smart shape
Once you create a custom shape, you can not only use it across projects 

in

 the same 

computer,

 but also use it 
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in

 a different computer where Captivate is installed.

To share a custom shape,

1 Navigate to the folder C:\Users\Public\Documents\Adobe\eLearning Assets\Shapes in the source computer to see 
the custom shape. There are three files for the custom shape:

a PNG file of the new object

b Preview PNG file of the object

c XML of the object

2 Copy the files into the same eLearning Assets folder 

3 in

4  the destination computer.

5 Open a project in the destination computer and choose Shapes > Polygon from the main toolbar.

6 Draw any shape in the slide.

7 Click the drop-down near Custom and you can see the imported shape to choose. Select the shape to use in your 
slides.

Edit and create text captions with Captivate
You can use text captions for the following:Draw attention to specific areas of the slide Use text captions to point out 
menu options or icons or to focus user attention on easily overlooked details. When you are not using voice-over 
narration, you can use text captions instead.Add text to a slideThe only way in which you can add plain text to a slide 
in Adobe Captivate is using transparent text captions. For more information, see Add plain text to a slide.
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You decide how text captions appear (font, size, color, and so on). Adobe Captivate provides a wide variety of 
predefined text caption styles, but you can also create custom styles that match the standards of your company. 

The following types of captions are available in Adobe Captivate:

Regular Use regular captions to “talk” to the viewer about features on the screen. You can have Adobe Captivate 
automatically generate text captions based upon what is recorded. For example, when you click the File menu during 
recording, Adobe Captivate creates a text caption that says “Select the File menu item.” It then places the text caption 
on the slide showing the action. Alternatively, you can insert such text captions into the slides manually and edit them.

Captions for interactive objects Interactive objects are associated with success, failure, and hint captions. These 
captions are automatically generated for the objects when you record in some of the modes. 

Success The success caption is displayed when the user performs the desired action on the object. 

Failure The failure caption is displayed when the user performs an action other than what is set in the application.

Hint You can use hint captions to help users when they are unable to perform a certain task. Hint captions are displayed 
when the user moves the mouse over the object. 

Convert captions into smart shapes
Adobe Captivate 8.0.1 enables you to convert interactive object captions (success, failure and hint) into smart shapes. 

 Click interactions on the toolbar and insert any object on the slide. 

2. In properties inspector > Actions > Display, you can see Success, Failure and Hint captions. Choose one or all of them. 
3. Right-click one of the captions and select Convert to Smart-shape. Shapes pop-up appears. 4. Choose your desired
shape for the caption. In the below snapshot, you can see the first caption as oval smart shape.
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Note: You can set the smart shapes for the entire project by choosing preferences. To set preferences, choose File>Publish 
settings. In the Preferences dialog, click Defaults and click the check box adjacent to Use Smart-shapes for SFH captions 
instead of Text captions as shown in the snapshot below. 

Tips for creating text captions
Here are some tips for creating captions:

• If the caption is strictly text on the slide, use the Transparent caption style.

• Don't use fonts that are not available on most computers. For example, if you use FF Confidential, and the user
doesn't have it on the local computer, some other font is substituted.

• Create a style sheet by formatting a caption and selecting the Apply Properties To All Captions In The Movie check 
box in the Text Caption dialog box. All captions in the SWF file or captions you create use the font, alignment, and
caption style you set.

• Captions can be used as a script for narrations. When you click the Audio button on the main toolbar to open the
Slide Audio dialog box, click the Captions And Slide Notes option. If a caption is attached to the slide, you see it in
the Record Audio dialog box as a script.

• Narrating a caption actually adds an extra degree of accessibility to the demo.

Text caption properties
Use the Property Inspector (Window > Properties) of a text caption to customize it.

Text Caption
Name Enter a unique name for the object. You can use this name when defining the visibility conditions for the object. 

Visible Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the 
Show option. For more information, see Controlling the visibility of objects.
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Style Select a style for the text caption. To define a new style, select Edit > Object Style Manager. For more information 
on object styles, see Working with object styles in Adobe Captivate

Accessibility Click to add accessible text to the object. For details, see Creating accessible projects in Adobe Captivate

General
Caption Type Displays the types of captions available in Adobe Captivate. Each text caption type is named, and a small 
thumbnail image shows what the text caption looks like.

Note: When adding or modifying a text caption, select the caption type before setting the style and format of text in a 
caption. This ensures that style and format changes to text are retained.

Callout Type Five text caption callout types are available. Many of the text caption styles contain text captions with 
directional callouts. You can select a text caption that points in the most appropriate direction.

Character
Use this area to provide the font specifications such as color, style, format, and size for the text.

Format
Use this area to specify text alignment, indentation, numbering, and line spacing. 

Margins Adjust the top, bottom, and side margins between the text and the caption outline, click the required options 
in Margins and specify a value.

Insert Double-click the text caption and then click:

• to insert symbols, such as, copyright or trademark symbols.

• to insert system or user-defined variables.

• to insert hyperlinks.

Shadow and reflection
Shadow Select the check box to apply shadow to the text caption. Choose one of the presets. You can customize a preset 
by clicking Custom.

Direction Select the direction: inner or outer. The preview of the selected direction is displayed on stage. 

Color click to select a color for the shadow. Specify the alpha for the color, in percentage, in the adjacent field.

Blur Specify a value, in pixels, for the blur of the shadow.

Angle Specify the angle for the shadow. 

Distance specify the distance, in pixels, at which the shadow must be displayed.

Reflection Select the check box to add reflection to the text caption. Choose one of the presets.

Timing
Display For [Time] Duration for which the text caption is displayed in the slide. From the pop-up menu, select one of 
the following options:

Specific Time The duration for which the text caption appears on the slide. Set the time in seconds by typing the value 
in the field, or by using the scroll arrows.

Rest Of Slide The text caption is displayed for the entire duration of the slide. 
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Rest Of Project The text caption is displayed for the entire duration of the project. For example, you can use this option 
to display a text caption that displays the name of the company.

Appear After [#] Seconds The text caption appears on the slide after the specified duration.

Transition
Effect Transition effect for the highlight box. You can apply a fade in or fade out effect and set the time for the fading 
effects.

In [#] Seconds Time for the caption to fully fade into view.

Out [#] Seconds Time for the caption to completely disappear.

Add text and text captions

Add a text caption
If you change the settings in the Property Inspector for text captions, they become the default settings. Any text captions 
that you create use the new settings.

If you add a transparent text caption, avoid using bold text; regular text appears clearer than bold text on most 
monitors.

1 In an open project, select the slide to which you want to add a text caption.

2 Select Insert > Standard Objects > Text Caption. You can also right-click (Windows) or Control-click (Mac OS) in 
the slide, choose Insert > Standard Objects from the pop-up menu, and then choose Text Caption.

3 Set the various options for the text caption.

4 For properties with the icon, select either

• Apply To All Items To apply the effect to all objects that belong to the object type.

• Apply To All Items Of Same Style To apply to all objects that use the same object style.

Add plain text to a slide
To add text to the slide without making it appear as a text caption, add the text as a transparent text caption.

Note: If you create a transparent caption, avoid underlining text because doing so can decrease text quality when the project 
is viewed.

After adding the transparent text caption, you may want to merge the caption with the slide background. 

1 In an open project, select the slide to which you want to add a transparent text caption. 

2 Select Insert > Standard Objects > Text Caption. 

3 In the General area of the Property Inspector, select transparent as the Caption Type.

4 Change other options as required.

To add superscript to a slide, select the text, and 

• (On Windows) Press Control +shift + “+”. To add a subscript, select the text, and press Control + “+”.

• (On Mac OS) Press Cmd + shift + "+". To add a subscript, select the text, and press Cmd + "+".



191
Noninteractive Objects and Media

Last updated 10/10/2016

Insert text as a variable
1 Move the cursor to the position in the text where you want to insert the variable.

2 In the Format area of Property Inspector, click the Insert Variable icon.

3 Select one of the following in the Variable Type menu:

• To insert a variable that you have previously created, select User. Select the variable from the Variables menu. For 
more information, see How to create user-defined variables in Adobe Captivate.

• To insert a system variable, select System. Select a system variable from the Variables menu. To filter system
variables by their category, select the corresponding option from the View By menu. When you do not choose a
category, all the system variables are listed in the menu.

4 To change the maximum number of characters that the variable can accommodate, enter a value in the Maximum 
Length field. If the number of characters exceed the value specified in this field, the extra characters are not 
displayed.

Note: Spaces are also considered for the character count.

5 To create a variable or to change the values of a selected variable, click Variables.

6 Click OK.

When you preview the project, the value of the variable is displayed inside the text caption. 

Insert symbols and special characters
1 In the Format area of Property Inspector, click the Insert button.

2 Select a symbol that you want to insert from the menu.

3 For more options, click Other, select the character that you want to insert, and then click OK.

Insert hyperlinks
You can hyperlink text in text captions or drawing objects to do a multitude of things, such as, open a web page, slide, 
or execute advanced actions, when users click the text.

1 Select the phrase or word you want to hyperlink. You can hyperlink text in text captions or drawing objects.

2 Click in the Format accordion of the Property Inspector and specify one of the options in the Link To list. For 
the description of the options, see How to use interactive objects for project navigation.

Note: Only Web Page and Open File actions are supported when a variable is inserted in the object that contains 
hyperlinks.

You can format the text using the options available in the Character accordion of the Property Inspector.

To modify an hyperlink, click in the Format accordion of the Property Inspector.

To delete an hyperlink, click in the Fromat accordion of the Property Insepector.

Add effects to text
You can apply effects to text in:

• Captions

• Drawing objects including smart shapes

• Static text (that do not change at run-time) in questions slides

1 Click the caption or the autoshape.



192
Noninteractive Objects and Media

Last updated 10/10/2016

2 Click the text effects icon ( ) in the Character accordion of the Property Inspector, and do one of the following:

• Click an effect from the presets. To make changes to the preset effects, click Edit Effects.

• Click + to create a custom effect. Select the required options from the list and click OK. To save the settings for
future use, click Save. The saved effect appears along with the presets.

note: To delete a custom effect, click the effect and then click .

• Click Clear Effects to remove the effect from the text.

Note: The text effects are not applied if you insert a variable along with the text. However, the text effects are applied back 
when you remove the variable.

Add text captions automatically during recording
When you record projects or record additional slides for projects, Adobe Captivate can automatically create text 
captions based upon the action recorded. For example, if you record the action of selecting the File menu, Adobe 
Captivate can automatically add a text caption that reads “Select File menu” on the same slide. 

Actions that generate text captions include the following: selecting menus and menu items; pressing buttons; changing 
values in locations such as lists, combo boxes, or check boxes; and opening child windows.

1 In an open project, select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select Modes under the Recording menu.

3 Select the mode of recording for which you want to automatically generate the text captions.

4 Select Add Text Captions.

After you finish recording and the project is generated (including the automatically created captions), view the 
individual slides in Edit mode to see the captions.

Note: Adobe Captivate can automatically generate text captions for all standard Windows user interface elements. It might 
not, however, support nonstandard user interface elements, including menu text in applications created with Delphi®.

Edit text captions

Edit a text caption
If you are resizing a text caption, you cannot make the text caption smaller than the bitmap used to create the text 
caption. For example, the text caption style “Pill” uses bitmaps sized approximately 18 pixels (wide) x 16 pixels (high), 
so these bitmaps could not be resized to 15 x 12 pixels. However, any of the text caption bitmaps can be made larger. If 
you need very small text captions, consider creating custom captions.

To edit a text caption, use the Property Inspector (Window > Properties).

If you have a detailed slide that contains text captions and other objects, you might want to make the text caption a 
permanent part of the background. 

Copy text captions
You can copy and paste text captions between slides. This is a great time-saver, especially if you use the same text 
caption on multiple slides.

1 In an open project, select the slide containing the text caption you want to copy. 

2 Right-click (Windows) or Control-click (Mac OS) the text caption and select Copy. 
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3 Navigate to the slide where you want to paste the caption.

4 Right-click (Windows) or Control-click (Mac OS) in the slide and select Paste.

You can copy and paste more than one text caption at a time by Control-clicking (Windows) or Command-clicking 
(Mac OS) the text captions. Right-click (Windows) or Control-click (Mac OS) one of the selected text captions and 

choose Copy.

Moving and resizing text captions
You can resize text captions manually or automatically and move text captions to new locations on a slide. To move text 
captions on a slide, select the text caption, and drag it to the new location.

Note: If you are resizing a text caption, you cannot make the caption smaller than the bitmap used to create the caption. 
For example, the caption style “Pill” uses bitmaps sized approximately 18 pixels (wide) x 16 pixels (high), so these bitmaps 
could not be resized to 15 x 12 pixels. However, any of the caption bitmaps can be made larger. If you need very small 
captions, consider creating custom captions.

Manually resize a text caption
To manually resize a text caption, select the text caption, and move the pointer over the selection handles. When the 
pointer becomes a resize handle, drag the mouse to resize the object. 

Automatically resize text captions
Adobe Captivate can automatically resize a text caption according to the amount of text in the text caption. If you edit 
the text, the caption is resized to accommodate the altered text. This is an easy way to keep your text captions looking 
balanced and proportional. 

1 In an open project, select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Category panel, select Defaults from the Global menu.

3 Select Autosize Captions.

Change text caption order using the Timeline
Adobe Captivate lets you add multiple captions to each slide. You can specify the order in which these captions appear 
using the Timeline. The Timeline enables you to precisely adjust the timing of all objects, including captions, on a slide. 

1 In an open project, navigate to the slide containing the captions whose order you want to change.

2 In the Timeline (Window > Timeline), change the order and timing of captions as required.

• For example, move the mouse over the left or right edge of a caption on the Timeline until the resize cursor
appears. Then drag the edge left or right. This changes when the caption appears or disappears and how long it
is shown.

• Alternatively, suppose a caption and its slide appear concurrently, but you want a slight delay. To achieve this
effect, move the mouse over the center of the caption on the Timeline until the hand cursor appears. Then drag
the entire caption so the left edge aligns with 2s (a 2-second delay) or 4s (a 4-second delay) in the header.

3 If two captions overlap on the slide, select the caption you want to appear in front by setting the stacking order. To 
change the stacking order, moving captions to the back or front of the slide Stage. The key point to remember is that 
captions at the back of the Stage appear behind other captions. Use one of the following methods to set the stacking 
order:

• Right-click (Windows) or Control-click (Mac OS) a caption on the slide and select one of the caption order
options. If necessary, right-click (Windows) or Control-click (Mac OS) other captions on the slide and adjust
their order.
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• Select a caption. On the Edit view toolbar (next to Slide Properties), click Bring selected objects to the front or
Send selected objects behind.

• On the Timeline, move the mouse over a caption until the hand pointer appears. Drag the caption up or down to
change its position in the stacking order. Moving a caption higher in the stacking order moves it to the front of
the Stage. Moving a caption lower moves it to the back of the Stage.

Captions in other languages

Adding a language for text captions
You can add new languages to the list of existing languages in which text captions are recorded. The list of existing 
languages is available in the Recording dialog box. Text captions of events are stored as 
CaptureTextTemplates_<language>.rdl files in the

• (On Windows) \\Program Files\Adobe\Adobe Captivate 6 directory. For example, the RDL file for Chinese-
Simplified is CaptureTextTemplates_Chinese-Simplified.rdl.

• (On Mac OS) \\Applications\Adobe Captivate 6.

You can use the existing RDL files to record text captions in a desired language.

Record text captions in another language
1 Open Windows Explorer, and navigate to 

• (On Windows) \\Program Files\Adobe\Adobe Captivate 6 directory

• (On Mac OS) /Applications/Adobe Captivate 6

2 Copy a file with an RDL extension.

3 Paste the file in the same location, and rename it according to the new language. For example, if you want to record 
in Polish, rename the file CaptureTextTemplates_Polish.rdl.

4 Open the RDL file in any text editor.

5 In the Object Name and the Event Name tags, change the text for Default Template And Template Attributes to the 
specified language.

6 Save the file.

7 In the Preferences dialog box (Edit > Preferences (on Windows) or Adobe Captivate > Preferences (on Mac OS)), 
select Recording > Settings in Category.

8 In the Generate Captions In, select the added language.

When you record, the text captions are generated in the specified language.

Type text in another language
For Windows

1 Open the Microsoft Windows Control Panel and double-click the Regional And Language Options icon. The 
Regional And Language Options dialog box appears.

2 Click the Languages tab.

3 Click the Details button.

4 In the Settings tab of the Text Services And Input Languages dialog box, click the Add button. 



195
Noninteractive Objects and Media

Last updated 10/10/2016

5 In the Add Input Language dialog box, select a language from the Input Language list. 

6 Click OK. The selected language is included in the Installed Services list.

7 Select the desired language in the Default Input Language list.

8 Click Apply and click OK to save the settings and close the Text Services And Input Languages dialog box. 

9 Click the Regional Options tab, and choose the language you selected in the Default Input Language list.

10 Click Apply and click OK to save the settings and close the Regional And Language Options dialog box. The 
Language bar or the Input Method Editor (IME) appears on the desktop of your computer.

11 Type content in the RDL file. The text appears in the selected language.

If you change the language in the Default Input Language list and the Regional Options tab, the language selected 
in the Language bar is also updated automatically.

For Mac OS

1 In the System Preferences, select International > Input Menu tab.

2 Select from the list of languages.

3 In the Apple menu, select the language.

4 Open the RDL file using a text editor and start typing in the language of your preference.

Localizing text captions
If you are localizing a project that contains text captions, you can export text captions to make the process more 
efficient.

1 Create the initial (“source language”) version of the project, including all necessary text captions.

2 Open the completed project.

3 Select File > Export > Project Captions and Closed Captions.

By default, the Word (DOC) file is saved to your My Documents\My Adobe Captivate Projects folder (on Windows) 
and /Users/<username>/Documents/My Adobe Captivate Projects folder (on Mac OS). Change the location if you 
want. Also, the Word file is named [ProjectName] Captions.doc. You can change the name of the file, if necessary, 
by clicking directly in the File name text box and entering a new name. (Retain the.doc filename extension.) 

4 Click Save.

5 The Word file is generated with the name you specified and saved to the location you selected. A dialog box appears 
asking if you want to view the document. Click Yes to view the document in Word.

6 The Word document contains the slide ID, item ID, original caption text, and the slide number. You can change the 
caption text in the Updated Text Caption Data column. Provide a copy of the Word document to the 
localizer/translator.

7 The localizer/translator should open the Word document and edit the caption text directly in the Updated Text 
Caption Data column in the document, replacing the source language text with the new text.

8 While the localizer/translator is translating the text, make a copy of the original Adobe Captivate project for the new 
language.

Note: When you create a copy of the original project, be sure to keep the original text captions (in the source language) 
in the new project. The original text captions act as placeholders and are overwritten when you import the new 
(localized) text captions.

9 When the text captions are localized, open the copy of the project you created in step 8.
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10 Select File > Import > Project Captions And Closed Captions.

11 Navigate to the localized text captions Word (DOC) file, select the file, and click Open.

12 The new, localized text captions are imported into the project, and all formatting is retained. A dialog box appears 
showing a successful import message. Click OK.

13 Test the new text captions by opening different slides in Edit view and reading the new caption text.

Creating custom text caption styles
You can create custom text caption styles for your Adobe Captivate projects with a graphics program, such as Adobe® 
Fireworks® or Adobe® Photoshop®.

Custom text captions must be in BMP (bitmap) format. In general, each Adobe Captivate text caption has five 
associated bitmap images. 

Naming custom text caption styles
When creating custom text caption styles, be sure to follow the correct naming conventions. Each caption style has a 
unique name, and you must use this name at the beginning of each associated bitmap filename. For example, if you 
create a text caption style named “Brightblue,” the five bitmap images that constitute the new style should be named as 
follows:

• Brightblue1.bmp, an image with no callouts

• Brightblue2.bmp, an image with a callout to the right or upper-right

• Brightblue3.bmp, an image with a callout to the left or upper-left

• Brightblue4.bmp, an image with a callout to the lower right

• Brightblue5.bmp, an image with a callout to the lower left

Storing custom text caption styles
You must store all the bitmap images for a custom text caption style in the Adobe Captivate Captions folder located in 
C:\Program Files\Adobe\Adobe Captivate 4\Gallery\Captions (on Windows) and /Applications/Adobe Captivate 
6/Gallery/Captions (on Mac OS). After you add the five new bitmaps to the captions folder, Adobe Captivate recognizes 
the bitmap files as a new text caption style. The next time you add a new text caption, your new custom style appears 
in the text caption style list.

Create custom text for caption styles
You can create a custom style for the text that appears in the text captions. These preferences are applied only if you did 
not set a style for the text caption earlier. 

1 Open the fonts.ini file, stored in the \\Program Files\Adobe\Adobe Captivate 6\Gallery\Captions folder (on 
Windows) or /Applications/Adobe Captivate 6/Gallery/Captions (on Mac OS), in a text editor.

2 Customize the style for the text caption using the procedure described in the file.

3 Save the file.

4 In an open Adobe Captivate project, select Insert > Standard Objects > Text Caption.

5 In Caption Type, select the caption that you have customized.

The text in the text area changes to the specified style.

6 Edit the text in the text area.
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7 Click OK.

Change text alignment on custom text captions
Sometimes text in custom text captions can appear out of alignment. To solve this problem, set the left, right, top, and 
bottom margins.

Each of the five text caption styles requires different margin settings because text appears in slightly different places in 
each text caption. 

The margin settings are stored in a text file with the extension.fcm. You can use Notepad or WordPad to create or edit 
FCM files.

1 Using Windows Explorer, navigate to C:\Program Files\Adobe\Adobe Captivate 6\Gallery\Captions (on Windows) 
or /Applications/Adobe Captivate 6/Gallery/Captions (on Mac OS). All the text caption BMP and corresponding 
FCM files are located in this folder.

2 Right-click (Windows) or Control-click (Mac OS) the FCM file you want to edit, and select Open With.

3 Select a text editor.

4 Edit the following values as necessary:

• Left Margin is the number of pixels from the left side of the bitmap to the text.

• Right Margin is the number of pixels from the right side of the bitmap to the text.

• Top Margin is the number of pixels from the top of the bitmap to the text.

• Bottom Margin is the number of pixels from the bottom of the bitmap to the text.

5 (Optional) If necessary, you can edit the MarginX and MarginY settings. This can be important if you are adding 
captions automatically.

• MarginX is the number of pixels horizontally from the nearest corner to the tip of the caption callout.

• Margin Y is the number of pixels vertically from the nearest corner to the tip of the caption callout.

Note: The nearest corner is identified in the file open in a text editor under “Corner.” For example, Corner=right, top. 

6 From the File menu, select Save.

A dialog box may appear, asking whether you want to replace the original file. Click Yes.

7 Close the text editor.

Design tips for custom text captions
Colors Don’t use the transparent colors for captions. The upper-left pixel determines which color is transparent. For 
example, if the color in the upper-left pixel is yellow, everything that is the same yellow will be transparent in the text 
caption. Also, the text caption itself can have a gradient background, but the area around (“behind”) the text caption, 
must be a solid color.

Anti-alias Do not anti-alias the edges of your text captions. Your text captions will appear on different screenshots, and 
the anti-alias can cause a jagged halo effect on some screenshots.

Import and export text captions
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Import text captions
You can import text captions from a DOC file. First, you export the text captions from your Adobe Captivate project. 
Adobe Captivate creates a DOC file that preserves all the formatting from the text captions. While the text captions are 
in DOC format, you can make text and formatting changes in a word-processing program. Then you can import the 
text captions back into the Adobe Captivate project using the following steps. 

Note: If you export text captions to a DOC file, that DOC file can only be imported back into the original project. 

Importing and exporting text captions to and from a DOC file can be useful in several situations. For example, if you 
have to edit many captions, it is easier and faster to work in DOC files instead of navigating from slide to slide.

1 In an open project that contains text captions, select File > Export > Project Captions And Closed Captions.

2 Make the necessary changes while the text captions are in DOC format (in the Updated Text Caption Data column), 
and save the DOC file. 

3 Select File > Import > Project Captions And Closed Captions.

4 Select the DOC file that contains the exported text captions.

5 Click Open.

6 An Information dialog box appears, confirming that the import was successful. Click OK.

Export text captions
You can export text captions from an existing Adobe Captivate project into a DOC file if you have Microsoft Word 
installed on your computer. All formatting done in Adobe Captivate is preserved when the text captions open as a DOC 
file. Make text and formatting changes to the text captions while they are in DOC format. Then import them back into 
the Adobe Captivate project. 

Note: If you export text captions to a DOC file, that DOC file can only be imported back into the original project. 

Exporting text captions can be useful in several situations:

• If you intend to record and voice-over narration and create a script, exported text captions can provide the
foundation for the script.

• If you want to provide printed step-by-step instructions, you can export text captions and print the DOC file.

• If a project must be localized, you can export text captions into a DOC file and give it to a translator.

1 In an open project, select File > Export > Project Captions And Closed Captions.

2 In the Save As dialog box, enter a filename for the new DOC file.

Note the default directory where the file will be saved. If you want, navigate to a different location in which to save 
the file.

3 Click Save.

4 The text captions from the project are converted into DOC format. A dialog box appears, confirming that the text 
captions were exported to Word and asking if you would like to view the document. Click Yes.

5 A new DOC file that contains the caption text opens in Word. Make any necessary text changes in the Updated Text 
Caption Data column. The slide number is also included as a reference.

6 Save the document.



199
Noninteractive Objects and Media

Last updated 10/10/2016

Restore default settings for recording modes
If you changed the appearance of text captions, you can restore all text caption settings to their defaults. For example, 
you change the font for text captions to Times New Roman and the font color to green. Click Restore To Default to 
change the font back to the default font Arial and the color to the default blue.

1 In an open project, select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS). 

2 In the Category panel, select Modes under the Recording menu.

3 In the Recording menu, > Modes area, click Restore Defaults.

More Help topics 
Set audio for noninteractive objects

Fix size and position of noninteractive objects

Creating and editing smart shapes
Smart shapes include many categories of readily-available shapes such as arrows, buttons, or basic shapes. You can 
insert and modify such shapes quickly and easily in your Adobe Captivate projects.

You can also convert smart shapes to rollover or any freefrom shapes. You can use smart shapes as buttons too. See Use 
smart shapes as buttonsfor more information.

You can configure a standard look and feel for smart shapes using the Object Style Manager (Edit > Object Style 
Manager). See Working with object styles in Adobe Captivatefor more information.

Note: You can search for smart shapes, and text within them, using the Find dialog box.

Insert smart shapes
1 Click the slide on which you want to insert the smart shape.

2 Click Shapes on Toolbar and click a shape of your choice. The mouse pointer turns into a ‘+’ mark.

3 Click and drag the mouse on the stage to draw the smart shape.

4 Adjust the shape using the white and yellow handles.

Edit smart shapes
1 To convert a smart shape to a freeform shape, right-click the shape, and click Convert To Freeform Shape. 

Black handles appear on the outline of the shape.

http://helpx.adobe.com/en/captivate/using/set-audio-noninteractive-objects.html
http://helpx.adobe.com/en/captivate/using/fix-size-position-noninteractive-objects.html
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2 Click a black handle to see a bezier curve that lets you transform the line into a curve. You can also change the 
position of the point by clicking and dragging the black handle.

3 Click anywhere outside the shape to save the edits.

To edit the shape again, right-click the shape and click Edit Points.

To use a smart shape as a rollover shape, right-click the shape, and click Convert To Rollover Shape.

Customize smart shapes
Customize shapes and reuse them across different slides and projects with ease. Use Hover statewith fill for 
color/gradient/image. 

For more information, see How to customize smart shapes in Adobe Captivate

Flip smart shapes
Click the smart shape and drag one of the handles in the desired direction. For example, to flip an arrow to left, click 
the handle at the tip of the arrow head and drag it all the way to the left so that it flips along the Y-axis.

You can also flip smart shapes using the flip options - flip horizontal ( ) and flip vertical ( ) - in the Transform 
accordion of the Property Inspector.

Apply gradient fills
Use gradient fills to blend colors to create various effects. You can apply gradient fills to slides and drawing objects. You 
can also choose a gradient fill for projects’ background (Preferences > Global > Defaults > Background color).

1 Select the slide or the drawing object to which you want to apply the gradient fill.

2 In the Property Inspector, click the Stage (for slides), or the Fill (for drawing objects) box.

3 Click at the top of the box.

4 Click a preset in the preset row.

Observe that the selected slide or the object changes dynamically on the stage to reflect the changes you do the 
gradient fill. 
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5 To edit the colors, click the color stops and choose the required color.

Note: For drawing objects, set the transparency for the colors (in percentage) using the option adjacent to the Fill palette 
in the Property Inspector.

To delete a color stop, click it and press the Delete key on your keyboard. You can even drag the color stop out of the 
gradient box.

6 To reverse the positioning of colors, click the Reverse Colors icon.

7 Choose the direction for the gradient from the Direction row. 

8 Click the Linear Gradient icon for a linear gradient, or click the Radial gradient icon for a radial gradient.

9 Click a pattern in the Pattern list. 

10 Click the Add To Custom Gradients icon. The gradient fill and the related settings that you used are saved in the 
Custom Gradients row for future use.

Note: Custom gradients are available for use across all projects that you create subsequently. 

To delete a custom gradient, click the delete icon and then click the custom gradient. All custom gradients are 
deleted if you delete the Adobe Captivate preferences folder.

Edit a gradient fill
You can edit the length, position, and angle (for linear fill) of the gradients on Stage.

Note: To edit the colors, patterns, and direction of the gradient, use the Property Inspector.

1 Select the slide or the drawing object.

2 Click Edit > Edit Gradient. 

A line with a thick start and end point appears on the selected object. The start point is denoted with a circle and 
the end point is denoted with a square.

3 To position the line at the required location on the slide or object, drag the start point.

4 To change the angle or the length of the gradient fill, click the end point and drag it in the required direction. Hold 
down the Shift key (Windows) or Control key (Mac) while you move the line to rotate the gradient by 15° shifts.

You can also rotate the line to change the angle of the gradient fill. To do so, hover your mouse over the line. When 
the cursor changes to a rotation symbol, drag the mouse in the required direction.

Apply texture fills
1 Select the object to which you want to apply the texture fill.

2 In the Fill & Stroke accordion of the Property Inspector, click the Stage (for slides) or the Fill (for drawing objects) 
box.

3 In the dialog box that appears, click at the top.

4 Click a texture from the available presets or click the browse icon adjacent to the Custom Image box to choose an 
image.

If the image that you choose is larger than the object, the Resize/Crop Image dialog box appears. To automatically 
scale the image to fit the object, click Fit to Stage. To crop the image, click Crop, and then click and drag the blue 
box on the image to specify the part of the image you want to retain.

• Click Stretch to apply the texture or the image to the entire object.

• Click Tile to apply the texture or the image in a tile pattern. Choose the direction of tiling from the Tile Type list.



202
Noninteractive Objects and Media

Last updated 10/10/2016

Change the stroke and fill properties
Select the object, and set the fill and stroke properties for the object in the Property Inspector (Window > Properties) 
in the Fill & Stroke area. 

You can set the following stroke properties for straight lines:

• Transparency of the line

• Style of the stroke, such as dashes or dots

• Color of the stroke

• Thickness (width) of the stroke

• Arrowheads, circles, diamonds, or squares at the ends of a line

You can set the following stroke and fill properties for the other smart shapes:

• Fill color

• Gradient fill

• Pattern or image fill

• Transparency of the fill color

• Style of the stroke, such as dashes or dots

• Color of the stroke

• Width of the stroke

• Gradient fill for the stroke

• Corners of the object: You can smooth the corners of a rectangle or square to varying degrees by changing the values 
for its corner radius.

Place text inside smart shapes
1 Right-click (Windows) or Control-click (Mac OS) the object, and then select Add Text. You can also double-click 

the object and start typing the text at the cursor.

2 Add text in the text area that appears within the object, and use the Character area of the Property Inspector 
(Window > Properties) to format the text. 

To edit text within objects, right-click (Windows) or Control-click (Mac OS) the object and then select Edit Text. The 
text in the text area within the object is made available for editing. The text option is not available when you have 
selected the line tool.

To add effects to text, click the object and then click in the Character accordion of the Property Inspector.

Replace smart shapes
Right-click the smart shape and click Replace Smart Shape. Click the required shape from the Smart Shape panel.

Use smart shapes as buttons
You can convert any smart shape into an interactive button. To do so, select the smart shape and click Use As Button in 
the Property Inspector.
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Converting smart shapes into buttons provides you more flexibility in the design of project templates and master slides. 
The buttons created from smart shapes act as perpetual buttons when used on master slides that are associated with the 
slides.

You can insert smart shapes and convert them into buttons on question slides too. For buttons created from smart 
shapes, you can assign points using the Reporting accordion in the Property Inspector. For information on the 
properties in this accordion, see Add interactive buttons to your Captivate projects.

Duplicate smart shapes
 Right-click (Windows) or Control-click (Mac OS) the object and then select Duplicate.

Snap lines to objects
When drawing straight lines, you can make them snap to the contours of other Adobe Captivate objects, including free-
form objects. Use this option when you want to precisely connect the end of a straight line to the periphery of an object.

To snap lines to objects, do the following: 

1 Click the Snap To Object icon.

2 Draw the object (rectangle, oval, free-form polygon, and so on). 

When you now draw a straight line, the line snaps to the contours of objects with which it comes in contact.

Resize rollover area to the bounding box of other objects
Right-click (Windows) or Control-click (Mac OS) the rollover area, and select Auto Adjust Rollover Area.

When you now move the rollover area over an object, it assumes the shape of the bounding box of that object. If there 
are overlapping objects, the rollover area is resized to the dimensions of the object with the highest z-order.

How to create zoom areas in Adobe Captivate
Zoom areas help you draw the learner’s attention to important sections of a slide. For example, if you create a simulation 
that includes a step that might be easily overlooked, you can add a zoom area to highlight the step. After you add a zoom 
area, you can add timing, transition, and audio options to the zoom effect. Zoom areas consist of the following: Zoom 
sourceThe area of the slide that you want to magnify.Zoom destination areaThe area in which the magnified portion 
of the slide is displayed.

Properties of zoom destination areas
You can set the properties for a zoom destination area using the Property Inspector (Window > Properties). 

Fill Color of the area within the Zoom Destination Area box. To decide the degree of transparency for the fill color, 
select a value for the option Alpha in the Color menu. The value of 90% is less transparent (more solid) than a value of 
10%.

Stroke Stroke color for the Zoom Destination Area box.

Width Thickness of the border of the Zoom Destination Area box.

Image Image for the zoom destination area. Click the respective icon to add, crop, or delete image.

Last updated 10/10/2016
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Note: You can also change the size and position of the zoom area or zoom destination area directly on the slide. Select the 
box you want to change. When the hand cursor is visible, you can adjust the position of the box. When the double-headed 
arrow cursor is visible, you can adjust the size.

Properties of zoom source areas
You can set the properties for a zoom source area using the Property Inspector (Window > Properties).

Zoom Source
Name Enter a unique name for the object. You can use this name when defining the visibility conditions for the object. 

Visible Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the 
Show option. For more information, see Controlling the visibility of objects 

Style Select a style for the Zoom source. To define a new style, select Edit > Object Style Manager. For more 
information on object styles, see Working with object styles in Adobe Captivate

Fill and Stroke
Fill Color of the area within the Zoom source. 

To decide the degree of transparency for the fill color, select a value for the option Alpha in the Color menu. The value 
of 90% is less transparent (more solid) than a value of 10%.

Stroke Stroke color of the area within the Zoom source.

Fill Outer Area Select this option to fill the area outside the boundaries of the Zoom Area box with the color selected 
in Fill Color. When you choose this option, the area within the Zoom Area box is not colored.

Note: You can observe the fill color around the zoom area only when you preview or publish the project. 

Width Thickness of the border of the Zoom Area box.

Timing
Display For [Time] Specifies the duration for which the zoom area is displayed.

Appear After [#] Seconds Delay between the first appearance of the slide and the first appearance of the zoom area.

Zoom For The duration of the zoom, in tenths of a second.

Transition
Effect The transition effect for the slidelet when it appears and exits the slide.

In and Out The time (in seconds) for the fading effects.

Add zoom areas
1 In an open project, select the slide to which you want to add a zoom area. 

2 Select Insert > Standard Objects > Zoom Area.

3 Set the options for the zoom area as required. 

4 Select the zoom destination area and set its properties using the Property Inspector (Window > Properties).

http://helpx.adobe.com/en/captivate/using/controlling-visibility-objects.html#controlling_the_visibility_of_objects
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More Help topics 
Set audio for noninteractive objects

Fix size and position of noninteractive objects

How to set audio for noninteractive objects
You can add an audio file to noninteractive objects. The audio file is played when the object appears on the slide. 

1 To add audio, go to the Audio area in the Property Inspector (Window > Properties) and then click Add Audio. 

The Object Audio dialog box appears.

Record Audio Click to record. Recording audio requires some basic equipment.

Stop Audio Stops playing the audio file.

Play Audio Plays the audio file.

Import Displays the Import Audio dialog box. This dialog box lets you browse to an audio file and import it. 

Library Opens the Library. The Library lists all audio files that are already part of the currently open Adobe 
Captivate project.

Edit This tab lets you edit the audio file in various ways, such as inserting silent periods and adjusting the volume.

Settings Opens the Audio Settings dialog box. You can change audio settings such as input source, quality level, and 
calibration. Click the Settings button to make your selections.

2 Specify the following in the Audio area:

Stop Slide Audio When Slidelet Appears (for Rollover Slidelet) Any audio associated with the slide stops playing 
when the slidelet appears in the movie.

Fade In [#] Seconds Specifies the time for the audio to fade in to full volume.

Fade Out [#] Seconds Specifies the time for the audio to fade out to silence.

How to create rollover slidelets in Adobe Captivate
In Adobe Captivate, a rollover slidelet is a space on a slide that displays an associated slidelet (a slide within a slide) 
when the mouse is moved over the space. You can insert and display objects in the slidelet using the same procedure as 
that for the slides.

For example, you can create a rollover slidelet for a state on a map so that the demographics of the state are displayed 
when the mouse moves over it. 

Note: You cannot create rollover slidelets on question slides or quiz review slides.

The following is further information about slidelets:

• A slidelet is always linked to a rollover slidelet and is created along with the rollover slidelet.

• You can insert most of the Adobe Captivate objects into a slidelet.

• You can place more than one type of object into a slidelet. The objects become visible when the mouse is moved over 
the rollover slidelet.

http://helpx.adobe.com/en/captivate/using/set-audio-noninteractive-objects.html#set_audio_for_noninteractive_objects
http://helpx.adobe.com/en/captivate/using/fix-size-position-noninteractive-objects.html#fix_size_and_position_of_noninteractive_objects
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• You can drag audio and movie files from the Library into a slidelet.

• If a slidelet times out while an audio or movie file from the slide is running, the file stops running.

• When a slidelet or any of its objects is selected, the displayed Timeline and the corresponding menu options for the 
slide change to that for the slidelet.

• Objects within a slidelet can be hidden or locked, but not the slidelet itself. To hide or lock a slidelet, hide or lock
the corresponding rollover slidelet from the slide Timeline.

• Slidelet objects cannot be dragged outside of the slidelet boundaries.

• When a slidelet is deleted, its associated objects are also deleted, and the Timeline reverts to the slide Timeline.

• Clicking an area outside the slidelet, or on the Filmstrip, reverts the Timeline to that for the corresponding slide.

Properties of slidelets
Select the slidelet and use the Property Inspector (Window > Properties) to set the following properties of a slidelet:

Slidelet
Name Enter a unique name for the object. You can use this name when defining the visibility conditions for the object. 

Style Select a style for the slidelet. To define a new style, select Edit > Object Style Manager. For more information on 
object styles, see Working with object styles in Adobe Captivate

Accessibility Click to add accessible text to the object. For details, see Customize accessibility text for objects

Fill and Stroke
Fill Fill color of the slidelet. To decide the degree of transparency for the fill color, select a value for the option Alpha 
in the Color menu. The value of 90% is less transparent (more solid) than a value of 10%.

Stroke Stroke color of the slidelet.

Width The thickness of the slidelet border.

Show Runtime Shadow Select this option to display a shadow below the slidelet during run time. The shadow gives a 
three-dimensional feel to the slidelet.

Image Background image of the slidelet. Click the respective icon to remove or crop previously selected image.

Shadow and reflection
Shadow Select the check box to apply shadow to the slidelet. Choose one of the presets. You can customize a preset by 
clicking Custom.

Direction Select the direction: inner or outer. The preview of the selected direction is displayed on stage. 

Color click to select a color for the shadow. Specify the alpha for the color, in percentage, in the adjacent field.

Blur Specify a value, in pixels, for the blur of the shadow.

Angle Specify the angle for the shadow. 

Distance specify the distance, in pixels, at which the shadow must be displayed.

Reflection Select the check box to add reflection to the slidelet. Choose one of the presets.

Timing
Display For The duration for which the slidelet is displayed on the slide.
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Transition
Effect The transition effect for the slidelet when it appears and exits the slide.

In and Out The time (in seconds) for the fading effects.

Properties of rollover slidelets
Select the rollover slidelet and use the Property Inspector (Window > Properties) to set the following properties for a 
rollover slidelet:

Rollover Slidelet
Name Enter a unique name for the object. You can use this name when defining the visibility conditions for the object. 

Visible Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the 
Show option. For more information, see Controlling the visibility of objects .

Style Select a style for the rollover slidelet. To define a new style, select Edit > Object Style Manager. For more 
information on object styles, see Working with object styles in Adobe Captivate

Fill and Stroke
Fill Fill color for the rollover slidelet. To decide the degree of transparency for the fill color, select a value for the option 
Alpha in the Color menu. The value of 90% is less transparent (more solid) than a value of 10%.

Stroke Fill color for the rollover slidelet.

Show Border Displays the border of the rollover slidelet. The border is not displayed if you disable this option.

Action
Stick Slidelet The slidelet continues to be displayed even when you move the mouse away from the rollover slidelet 
area.

On Click Define the action to take when the user clicks the rollover slidelet by selecting one of the options in the menu.

Shortcut You can specify a keyboard shortcut for the mouse-click. Users can use the keyboard shortcut instead of using 
the mouse. For example, if you select Control+Shift+Enter as the keyboard shortcut for the mouse-click, the click is 
treated as correct (click within the box) when the users press this combination. If they press the wrong combination, it 
is treated as a click outside the box.

Note: If your Adobe Captivate project is displayed in a browser, set keyboard shortcuts that do not conflict with common 
browser shortcuts. For example, F1 is frequently used as a keyboard shortcut to display Help on Windows. The Control, 
Alt, and Shift keys map to the Control, Option, and Shift keys on Macintosh® computers, respectively.

Shadow and reflection
Shadow Select the check box to apply shadow to the rollover slidelet. Choose one of the presets. You can customize a 
preset by clicking Custom.

Direction Select the direction: inner or outer. The preview of the selected direction is displayed on stage. 

Color click to select a color for the shadow. Specify the alpha for the color, in percentage, in the adjacent field.

Blur Specify a value, in pixels, for the blur of the shadow.

Angle Specify the angle for the shadow. 

Distance specify the distance, in pixels, at which the shadow must be displayed.

Reflection Select the check box to add reflection to the rollover slidelet. Choose one of the presets.

http://helpx.adobe.com/en/captivate/using/controlling-visibility-objects.html#controlling_the_visibility_of_objects
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Timing
Display For The duration for which the rollover slidelet is displayed.

Appear After Delay between the first appearance of the slide and the first appearance of the rollover slidelet.

Hover Delay The time delay before the appearance of the slidelet when the mouse moves over the rollover slidelet.

Transition
Effect The transition effect for the slidelet when it appears and exits the slide.

In and Out The time (in seconds) for the fading effects.

Show Runtime Border When the mouse moves over the rollover slidelet, a border is displayed with the specified color. 

Create a rollover slidelet
1 Select Insert > Standard Objects > Rollover Slidelet. 

2 In the Property Inspector (Window > Properties), set the options for the rollover slidelet as required.

Note: Whenever a new rollover slidelet is inserted, the default timing is Rest Of Slide. If required, you can modify the 
properties later.

Insert objects within a slidelet
1 Select the slidelet by clicking it.

2 Select Insert and choose the object that you want to insert.

3 In the corresponding dialog box that opens, follow the procedure to insert the object.

4 Click OK.

Note: You cannot insert a rollover slidelet, mouse, text entry box, click box, or button within a slidelet. 

To select all objects in a slidelet, right-click (Windows) or Control-click (Mac OS) an object within a slidelet, and choose 
Select All from the pop-up menu.

More Help topics 
Set audio for noninteractive objects

Fix size and position of noninteractive objects

How to create rollover captions in Adobe Captivate
Use rollover captions when you want to display the caption only when the user moves the mouse over a designated area 
on the slide. Rollover captions consist of a caption and a rectangle that marks the designated area, also called the 
rollover area. The caption appears when the user moves the mouse over the rollover area at run time. 

Add rollover captions
1 Select the slide to which you want to add a rollover caption.

2 Select Insert > Standard Objects > Rollover Caption.

http://helpx.adobe.com/en/captivate/using/set-audio-noninteractive-objects.html#set_audio_for_noninteractive_objects
http://helpx.adobe.com/en/captivate/using/fix-size-position-noninteractive-objects.html#fix_size_and_position_of_noninteractive_objects
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3 Set the various options for the caption in the Rollover Caption dialog box. See Text caption propertiesfor more 
information.

4 Click OK. The text caption and the rollover area appear on the slide.

5 Select the rollover area and set the properties using the Property Inspector (Window > Properties).

6 Click Accessibility to add accessible text to the object. For details, see Customize accessibility text for objects

7 For properties with the icon, select either

• Apply To All Items To apply the effect to all objects that belong to the object type.

• Apply To All Items Of Same Style To apply to all objects that use the same object style.

8 Click OK. 

Edit rollover area
Rollover captions and rollover images consist of a caption or image and a rollover area (the “hot” area). The rollover 
area defines where the mouse must be for the caption or image to appear.

1 Open an Adobe Captivate project.

2 Select the slide containing the rollover caption or image.

• To change the size of the rollover area, click one of the handles and drag.

• To move the rollover area to another location, move the mouse over the rollover area until the hand cursor 
appears. Drag the box to the desired location.

• To modify the rollover area attributes, select the rollover area make the required changes in the Property 
Inspector (Window > Properties).

• Customize the following for the rollover area in the Property Inspector if required:

Stroke Stroke color for the rollover area.

Fill Fill color for the rollover area. To decide the degree of transparency for the fill color, select a value for the 
option Alpha in the Color menu. The value of 90% is less transparent (more solid) than a value of 10%.

Width Thickness of the border of the rollover area.

Fill Outer Area Select this option to fill the area outside the boundaries of the rollover area with the color 
selected in Fill Color. When you choose this option, the area within the rollover area is not colored.

Note: You can observe the fill color around the rollover area only when you preview or publish the project.The other tabs 
in the Properties dialog box are similar to those for text captions. See Edit and create text captions with Captivatefor 
more information. 

Convert tooltips to rollover captions
When you record a new project or record additional slides for an existing project, you can set a recording option that 
requires Adobe Captivate to convert tooltips to rollover captions. When this option is selected, Adobe Captivate creates 
a rollover caption for every tooltip that is selected during the recording process.

Converting tooltips to rollover captions is an easy way to automatically create an appropriate and descriptive caption 
for action taking place in a project.

1 In an open project, select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select Modes in the Recording menu.



210
Noninteractive Objects and Media

Last updated 10/10/2016

3 Select Convert Tooltips to Rollover Captions.

4 Click OK.

5 Click Record to begin recording a new project and automatically converting tooltips to rollover captions.

More Help topics 
Set audio for noninteractive objects

Fix size and position of noninteractive objects

Changing mouse properties in Adobe Captivate

Change mouse properties

Options
You can change the properties of the mouse object using its Property Inspector (Window > Properties).

Available Mouse Pointers List  

Displays the available pointers. Click Browse to navigate to a custom file (CUR file format for Windows and PICT for 
Mac).

Double Mouse Size Doubles the size of the pointer.

Straight Pointer Path Select this option to have the pointer follow a straight path between its start and end points. By 
default, the pointer follows a curved path that gives the motion a more realistic look. You can change to a straight path 
if, for example, your project is a demonstration showing how to draw a line in a graphics program.

Reduce Speed Before Click Select this option to slow the mouse movement down before the click occurs. This option 
is useful for a long mouse path that moves quickly and stops suddenly.

Mouse Click Sound Select this option to play a sound when the pointer reaches its destination. Click the pop-up menu 
to select a sound (Single Click or Double Click). You can also select Browse and navigate to a sound file.

Show Mouse Click Adds a visual click effect to the mouse movement.

Default Displays a quick, small burst of color when the user clicks the slide. You can select a color for the color burst.

Custom Select this option to use a SWF file as a visual click effect. Adobe Captivate includes two effects you can use. 
Test them by clicking the pop-up menu, selecting one, and then clicking Play. View the effect in the small preview 
window on the right.

Timing
Display For The time during which the pointer is displayed on the slide. If you select specific time, then specify the 
time.

Appear After Delay between the first appearance of the slide and the first appearance of the slide pointer.

http://helpx.adobe.com/en/captivate/using/set-audio-noninteractive-objects.html#set_audio_for_noninteractive_objects
http://helpx.adobe.com/en/captivate/using/fix-size-position-noninteractive-objects.html#fix_size_and_position_of_noninteractive_objects
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Pointers

Select a custom pointer
1 In an open project, select the slide and then select Insert > Mouse.

2 Click Browse in the Property Inspector (Window > Properties).

3 Select a custom pointer from the list. 

4 Click Open. 

Change pointer size
You can double the size of the pointer. Large pointers emphasize mouse movement and are also helpful if you are 
creating accessible projects. 

Pointer size is set on a slide-by-slide basis, so you choose exactly the slides that require the larger pointer.

1 In an open project, select the slide containing the pointer. 

2 In the Property Inspector (Window > Properties), check Double Mouse Size. 

3 The new double-sized mouse is displayed on the slide.

Note: To restore the original pointer size, follow the steps above and clear Double Mouse Size.

Hide the pointer in an individual slide
 Select the slide and then select Slide > Mouse > Show Mouse.

Hide the pointer for the entire project
1 In an open project, select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Category panel, expand Project, and select Publish Settings.

3 In the Publish Settings panel, clear the option Include Mouse.

Change mouse movements
You can change mouse movements for an individual slide. For example, you may want to emphasize mouse movement 
in a screenshot so that it is more obvious to the viewer.

1 Using the mouse, move the pointer over the end of the mouse line on the slide until the pointer turns into a hand. 

2 Drag the pointer to a new location on the slide.

If you change the pointer on a slide, the starting pointer location changes on the next slide. Preview your project to 
ensure that mouse movement flows smoothly from slide to slide. 

You can’t align mouse movement to a previous slide. Make sure that you manually change the starting point of the 
mouse on the first project slide containing mouse movements.

Mouse paths

Last updated 10/10/2016
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Align mouse paths
You may need the pointer to be completely still during the playback of a slide and have it align properly with the 
previous or next slide. In this case, it is difficult to manually position the pointer correctly. Adobe Captivate can solve 
the problem by automatically aligning the pointer to the same position as the previous or next slide in the project.

1 Right-click (Windows) or Control-click (Mac OS) and select Align To Previous Slide or Align To Next Slide. 

2 Preview your project to see how the pointer is aligned between slides.

Note: If you have mouse movement on the first slide of your project, you can manually change the start point of the 
mouse movement (because you cannot align to a previous slide).

Change shape of mouse paths
By default, Adobe Captivate creates curved mouse paths on slides for a realistic, natural feel. However, a straight mouse 
path is sometimes preferable, for example, showing movement across a toolbar.

You can set the curved or straight mouse movement option for an individual slide.

 In the Property Inspector (Window > Properties) select Straight Pointer Path. 

This option acts like a toggle. Select it again to restore curved paths.

Set mouse click effect
You can set a mouse click color or effect. Use this option to add a quick burst of color or special effect around the pointer 
to emphasize mouse clicks during project playback.

1 In an open project, select a slide containing mouse movement.

2 In the Property Inspector (Window > Properties), 

3 Select Show Mouse Click.

4 Do one of the following:

• Select Default. Click the color box to open the Color dialog box. Select a color and click OK.

• Select Custom. Select an option from the pop-up menu. To preview these options, select one and click Play. The
SWF file plays in the small Preview window on the right. You can also select Browse in the pop-up menu and
navigate to a SWF file.

To view the mouse click color, preview the project.

Change mouse click sounds on an individual slide
You can change the default mouse click sound that plays whenever the mouse reaches the end of its movement path. 
For example, you can change from single clicks to double clicks to reflect the correct action in a workflow. You can also 
suppress all click sounds.

1 Select the mouse object and then in the Property Inspector (Window > Properties), select Show Mouse Click. 

2 Select Show Mouse Click.

3 Do the following:

• If you do not want a mouse click sound to play, deselect Mouse Click Sound.

• For a single-click sound (the sound of a mouse button being pressed once), select Mouse Click Sound and then
select Single Click from the menu.
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• For a double-click sound (the sound of a mouse button being pressed twice), select Mouse Click Sound and then
select Double Click.

• To browse to an alternative sound for a mouse click, select Mouse Click Sound and then click browse button. The 
Open dialog box appears, letting you browse to an mp3 file.

To preview the selected mouse click sound, click the Play button.

Enable the mouse wheel
When recording, you can choose to enable mouse wheel movement to initiate full motion recording. The project starts 
recording in video mode when there is mouse wheel movement during recording.

1 In an open project, Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Category panel of Preferences, expand Recording, and select Settings.

3 In the Smoothen Movements For section, select Mouse Wheel Actions and then click OK.

More Help topics 
Set audio for noninteractive objects

Fix size and position of noninteractive objects

Working with mathematical equations in Adobe 
Captivate 7
Adobe Captivate is integrated with MathMagic™ to let you create and edit Mathematical equations in your courses. 
MathMagic is a multi-purpose equation editor, formula editor, and a scientific symbol editor for various math formats.

The MathMagic equations are stored as a PNG resource in Adobe Captivate. In the Adobe Captivate library, the 
equations are categorized under Equations.

http://helpx.adobe.com/en/captivate/using/set-audio-noninteractive-objects.html#set_audio_for_noninteractive_objects
http://helpx.adobe.com/en/captivate/using/fix-size-position-noninteractive-objects.html#fix_size_and_position_of_noninteractive_objects
http://www.mathmagic.com
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Create equations
1  Click Insert > Equation. The default equation is inserted into the slide and MathMagic opens automatically.

2 Edit the equation in MathMagic as required. For more information, see MathMagic help.

3 Click File > Save to change the changes to the equation in MathMagic.

The changes are automatically reflected in your Adobe Captivate slide.

Edit equations
1 Double-click the equation that you want to edit. The equation is opened in MathMagic.

2 Edit the equation as required. For more information, see MathMagic help.

3 Click File > Save to change the changes to the equation in MathMagic.

The changes are automatically reflected in your Adobe Captivate slide.

Delete equations
 Click the equation and press the Delete key.

Properties of equations
An equation is a noninteractive object in Adobe Captivate, and you can set the following properties for equations:

• Shadow and reflection

• Timing

• Transition

• Audio

• Transform (position, size, and rotate)

For more information, see Adding and managing objects.

Use highlight boxes in Captivate
Use highlight boxes to spotlight areas within a slide. Highlight boxes focus the user’s attention on the required areas of 
the slide.

Properties of highlight boxes
Use the Property Inspector (Window > Properties) of the highlight box to customize it.

http://www.mathmagic.com/download/documentation.html
http://www.mathmagic.com/download/documentation.html
http://help.adobe.com/en_US/captivate/cp/using/WS5b3ccc516d4fbf351e63e3d119e95822ef-8000.html


215
Noninteractive Objects and Media

Last updated 10/10/2016

Highlight Box
Name Enter a unique name for the object. You can use this name when defining the visibility conditions for the object. 

Visible Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the 
Show option. For more information, see Controlling the visibility of objects .

Style Select a style for the highlight box. To define a new style, select Edit > Object Style Manager. For more 
information on object styles, see Working with object styles in Adobe Captivate

Fill & Stroke
Fill Fill color for the highlight box. To decide the degree of transparency for the fill color, select a value for the option 
Alpha in the Color menu. The value of 90% is less transparent (more solid) than a value of 10%.

Stroke Stroke color for the highlight box.

Fill Outer Area Fills the area outside the boundaries of highlight box with the color selected in Fill Color. When you 
choose this option, the area within the highlight box is not colored.

Note:  You can observe the fill color around the highlight box only when you preview or publish the project. 

Width Thickness of the border of the highlight box.

Shadow and reflection
Shadow Select the check box to apply shadow to the highlight box. Choose one of the presets. You can customize a 
preset by clicking Custom.

Direction Select the direction: inner or outer. The preview of the selected direction is displayed on stage. 

Color Click to select a color for the shadow. Specify the alpha for the color, in percentage, in the adjacent field.

Blur Specify a value, in pixels, for the blur of the shadow.

Angle Specify the angle for the shadow. 

Distance specify the distance, in pixels, at which the shadow must be displayed.

Reflection Select the check box to add reflection to the highlight box. Choose one of the presets.

Timing
Display For [Time] Specifies the duration for which the highlight box is displayed on the slide.

Appear After [#] Seconds The highlight box appears on the slide after the specified duration.

Transition
Effect Transition effect for the highlight box. You can apply a fade in or fade out effect and set the time for the fading 
effects.In [#] SecondsTime for the highlight box to fully fade into view.Out [#] SecondsTime for the highlight box to 
completely disappear.

Add highlight boxes
1 Select Insert > Standard Objects > Highlight Box.

2 Use the Property Inspector (Window > Properties) to set the various options for the highlight box.

http://helpx.adobe.com/en/captivate/using/controlling-visibility-objects.html#controlling_the_visibility_of_objects
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More Help topics 
Set audio for noninteractive objects

Fix size and position of noninteractive objects

Working with swatches in Adobe Captivate
The Swatches panel (Window > Swatches) lets you import color swatches from other applications such as Adobe 
Photoshop and Kuler. You can also create swatches by picking colors from open applications on your computer screen. 
Also, you can easily choose colors for fill, stroke, text, and highlight for objects on a slide.

• To create a swatch, click the Eyedropper tool ( ) and then click the required color on your computer screen.
Alternatively, you can click the color picker ( ) to choose a color.

• To import color swatches from applications such as Adobe Photoshop or Kuler, do one of the following actions:

• Click Append to append the swatches to the current set of swatches.

• Click Load to replace the current swatches with the imported swatches.

• To save the swatches and import into other projects, click Save.

• To reset the swatches to factory default, click Reset.

• To clear all the swatches, click Clear.

http://helpx.adobe.com/en/captivate/using/set-audio-noninteractive-objects.html#set_audio_for_noninteractive_objects
http://helpx.adobe.com/en/captivate/using/fix-size-position-noninteractive-objects.html#fix_size_and_position_of_noninteractive_objects
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Fix size and position of non-interactive objects
To specify the exact size and position of the object, in the Property Inspector (Window > Properties), specify the values 
in the Transform area. Using these options instead of dragging the object helps you create consistent objects throughout 
your project.XSpecifies the position of the X coordinate of the object, in pixels.YSpecifies the position of the Y 
coordinate of the object, in pixels.WidthSpecifies the horizontal width of the object, in pixels.HeightSpecifies the 
vertical height of the object, in pixels.Constrain ProportionsMaintains the height-to-width ratio of the object. If either 
the height or width of the object is changed, the other dimension is changed to maintain the relative proportion of the 
object.AngleAngle of rotation of the objects.

Adding animations to an Adobe Captivate project
Adobe Captivate lets you add animation to Adobe Captivate SWF files. This introduces an element of motion that is 
effective and eye-catching for users. Add existing animation files to a slide or use the animated text feature in Adobe 
Captivate.

When you add an animation file to your project, it automatically gets added to the library to the Media folder.

• You can add SWF or GIF animation files directly to a slide. Slides containing an animation file can be edited just like 
other slides containing an object.

Adobe Captivate contains a gallery that has buttons, sounds, and animations (in SWF format) for you to use in your
projects. By default, the gallery is stored in the following location when you install Adobe Captivate: C:\Program

Files\Adobe\Adobe Captivate 6\Gallery (on Windows) or /Applications/Adobe Captivate 6/Gallery (on Mac OS

Note:  If you want to add a Flash animation file (FLA), you must first convert it to a SWF file. To do this conversion, you 
must have the latest Flash version installed on your computer.

• To add animated text, select from a number of interesting effects included with Adobe Captivate. Experiment with
different fonts, colors, and effects to achieve the right look. Slides containing animated text, with their combination 
of text, movement, and sound (if you choose to add audio) make great opening slides for projects.

Note: Device fonts are not displayed in Adobe Captivate. If you import an animation file containing text created with device 
fonts, the animation appears in Adobe Captivate, but the text does not. For animations that will be imported into Adobe 
Captivate, try to use embedded fonts for text.

Properties of animation objects
You can change the properties of animation objects using their Property Inspector (Window > Properties).

Animation name
Name Enter a unique name for the object. You can use this name when defining the visibility conditions for the object. 

Visible Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the 
Show option. For more information, see Controlling the visibility of objects .

Accessibility Click to add accessible text to the object. For details, see Customize accessibility text for objects

Animation
Amimation Info Click the icon to see the key information about the animation file you selected including version, 
width, height, and the number of frames that compose the file. The total duration of the animation file is also shown.

http://helpx.adobe.com/en/captivate/using/controlling-visibility-objects.html#controlling_the_visibility_of_objects
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Linkage Provides the link to the associated animation file. 

Update Click to reflect the modifications to the source file (if edited externally).

Source Link to the source FLA file of the animation SWF file.

Edit Click to edit the FLA file using Adobe Flash from within Adobe Captivate. This option is available only in Adobe 
Captivate that is installed with the Adobe eLearning Suite.

Alpha The transparency of the animation file. A high Alpha value results in a bright version of the animation file and 
a lower value in a dimmer animation.

Swap lets you replace the animation file with another from the Media folder in the library using the Slect Animation 
from the Library dialog box. If library does not have the required file, click Import in the dialog box to import the file 
to the Media folder.

Timing
Display For [Time] The time the animation plays in the project.

Rest Of Slide The animation plays until the slide stops playing. The animation plays once, unless the Loop option is 
selected.

Rest Of Project The animation plays for the length of the project, even on other slides. The animation plays once, unless 
the Loop option is selected.

Duration Of Animation The animation plays for its entire length once.

Specific Time The animation plays for the specified time.

Appear After [#] Seconds Delay between the first appearance of the slide and the first appearance of the animation.

Synchronize With Project Synchronizes the speed at which the animation file plays with the Timeline speed. If you find 
that the animation file is not playing smoothly, test with this option selected and cleared to see which setting gives you 
better results.

Loop Select this option to have the animation file loop (replay continuously).

Transition
Effect Specify a transition effect for the animation. You can make an animation fade in during its entry, and fade out 
during its exit.

In [#] Seconds Specifies the amount of time for the animation to fully fade into view.

Out [#] Seconds Specifies the amount of time for the animation to completely disappear from view.

Shadow and reflection
Shadow Select the check box to apply shadow to the animation. Choose one of the presets. You can customize a preset 
by clicking Custom.

Direction Select the direction: inner or outer. The preview of the selected direction is displayed on stage. 

Color click to select a color for the shadow. Specify the alpha for the color, in percentage, in the adjacent field.

Blur Specify a value, in pixels, for the blur of the shadow.

Angle Specify the angle for the shadow. 

Distance specify the distance, in pixels, at which the shadow must be displayed.

Reflection Select the check box to add reflection to the animation. Choose one of the presets.
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Add animations
1 In an open project, select Insert > Animation.

2 Navigate to the animation file you want to add to the slide, select it, and click Open. 

3 In the Property Inspector, set properties and options as required.

The animation is added to the slide.

Note: Device fonts are not displayed in Adobe Captivate. If you import an animation file containing text created with device 
fonts, the animation appears in Adobe Captivate, but the text will not. For animations that will be imported into Adobe 
Captivate, try to use embedded fonts for text.

Animated text
Animated text is text that has applied special effects. Adobe Captivate offers a wide variety of text animation effects that 
you can experiment with. For example, on the opening slide of a project, you can have text fly-in or fade-in for an eye-
catching start. 

The Property Inspector (Window > Properties) provide a preview of the animated text that you insert.

Text Animation
Name Enter a unique name for the object. You can use this name when defining the visibility conditions for the object. 

Visible Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the 
Show option. For more information, see Controlling the visibility of objects 

General
Effect The animation effect that is applied to the text.

Transparency Specifies a transparency level for the animated text. For a very dim animated text effect, select a high 
number such as 90. For darker text, select a low number such as 10.

Properties Click to display Text Animation Properties dialog box.

Shadow and reflection
Shadow Select the check box to apply shadow to the animated text. Choose one of the presets. You can customize a 
preset by clicking Custom.

Direction Select the direction: inner or outer. The preview of the selected direction is displayed on stage. 

Color click to select a color for the shadow. Specify the alpha for the color, in percentage, in the adjacent field.

Blur Specify a value, in pixels, for the blur of the shadow.

Angle Specify the angle for the shadow. 

Distance specify the distance, in pixels, at which the shadow must be displayed.

Reflection Select the check box to add reflection to the animated text. Choose one of the presets.

Timing
Display For [Time] Specifies the timing of the animated text. Click the pop-up menu and select an option. If you select 
the specific time option, you can enter the exact number of seconds for the animated text to appear.

Appear After [#] Seconds Displays the animated text after the slide has been displayed for the selected number of 
seconds.

http://helpx.adobe.com/en/captivate/using/controlling-visibility-objects.html#controlling_the_visibility_of_objects
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Transition
Loop Select this option to have the animation file continuously loop (play over and over again) as the project plays.

Effect Specify a transition effect for the animation. You can make an animation fade in during its entry, and fade out 
during its exit.

In [#] Seconds Specifies the amount of time for the animation to fully fade into view.

Out [#] Seconds Specifies the amount of time for the animation to completely disappear from view.

Properties of animated text
Use the Text Animation Properties dialog box of the animated text to set its properties.

Set font, transparency, and delay options:

Text The text to which the animation is applied.

Font Specify the font name and then style, size, effects, and colors.

Delay (Frames) The time elapsed, in Flash frames, between the display of one animated letter and the next. If you set a 
low number (for example, 0 or 1), all the letters appear quickly, one after the other. If you set a higher number (for 
example, 30 or 40), each letter appears more distinctly. Try different numbers and watch the text in the Preview window 
to select an appropriate number.

Note: The number you specify in Delay does not change the absolute amount of time the animated text feature appears. 
For example, suppose you specify, in the Options tab) a total animation time of 8 seconds. The value of the Delay option, 
whether it is 1 or 30, does not change the absolute time of 8 seconds.

Loop Select this option to have the animation file continuously loop (play over and over again) as the project plays.

Add animated text
1 Select the slide to which you want to add animated text.

2 Select Insert > Text Animation. 

3 In the Text Animation Properties dialog box, enter the text to animate.

4 Set the various options according to your requirements.

5 For properties with the icon, select either

• Apply To All Items To apply the effect to all objects that belong to the object type.

• Apply To All Items Of Same Style To apply to all objects that use the same object style.

6 Click OK.

The text appears in the preview section of the Property Inspector.

More Help topics 
Set audio for noninteractive objects

Fix size and position of noninteractive objects

Set audio for noninteractive objects

Fix size and position of noninteractive objects

http://helpx.adobe.com/en/captivate/using/set-audio-noninteractive-objects.html#set_audio_for_noninteractive_objects
http://helpx.adobe.com/en/captivate/using/fix-size-position-noninteractive-objects.html#fix_size_and_position_of_noninteractive_objects
http://helpx.adobe.com/en/captivate/using/set-audio-noninteractive-objects.html#set_audio_for_noninteractive_objects
http://helpx.adobe.com/en/captivate/using/fix-size-position-noninteractive-objects.html#fix_size_and_position_of_noninteractive_objects
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Chapter 8: Interactive Objects

Using Adobe Captivate 8's new learning interactions
You can make learning as interesting, fun, and interactive for your learners, through the new gaming interactions 
introduced in Adobe Captivate 8. 

Now, you can call variables from Check Box, DropDown, Radio Button and Scrolling Text interactions to dynamically 
control the interaction properties from your slides. 

Catch Alphanums interaction
Catch Alphanums interaction is an Accelerometer based interaction. You can use tilt gesture controls on accelerometer 
supported tablet and mobile devices, to play this interaction game.

The objective of this game is to catch the missing alphabets or numbers with basket, to make words for questions, within 
the stipulated time and lifeline chances. 

Creating Catch Alphanums
1 From Toolbar, click Interactions > Learning Interactions.

Select Interaction dialog appears. 

2 Scroll down in the dialog window to select Catch AlphaNums interaction, as shown in the following screenshot, and 
click Insert.
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3 Choose one of the options from Add Question with Words or Add Question with Numbers and click OK. 
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4 Add questions of your choice with words or numbers in respective text areas. Add the score you would like to give 
for each correct answer. Add Lifelines, that is the number of chances you want to give to user, to try answering each 
question.

Add Hide Characters, Hide Numbers, and Hide Symbols. The value depends on the answer you have chosen. For 
example, if the answer to your question is five, then you can choose 1, 2, 3 or 4. If you use 5, then by default it would 
reset to 4 (the maximum characters of your answer). 

Click OK. 

Now, the interaction game is ready to play. 

Note: You can include one or many questions. A question with words and another question with numbers can also be 
added as illustrated in the following screenshot. Follow the sample help text provided as default text in the text areas 
and add content. Click the question mark help icons adjacent to each text field/text area to get the self-explanatory 
content and follow the instructions. 
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5 Click Preview button from Toolbar and choose any of the available options to preview the Catch Alphanums game. 

6 Click Publish button from Toolbar and publish the interaction for devices or Adobe Connect as per your choice. 

Catch Alphanums interaction sample output is shown below. 
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Customizing Catch Alphanums
You can customize the appearance of Catch Alphanums game by choosing your screen properties for Instructions, Start 
Screen, Game Screen and End Screen windows. Choose your own text, background colors, themes, banners, fonts and 
so on. 

1 Click Customize button at the bottom right corner of the Configure interaction dialog. 

Configure interaction dialog appears to customize the properties. 
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2 Choose any of the four tabs such as Interactions, Start Screen, Game Screen, and End Screen and Click Edit button 
at the upper-right corner to edit the properties for each tab. For example, in Game Screen tab, you can change colors 
for Theme background, Top and bottom banners, shapes, lifeline text and score text, and Cart. 

Color Settings You have an option to choose either default color settings or theme settings for your screens. In either 
of these settings, you can customize the color properties of screen elements like background, top banner color and 
so on. Your customized settings will be saved and you can go back to these settings by clicking Customize in Color 
settings (as shown in the screenshot below).

Click Variable text in any of the four tabs (Instructions, Start Screen, Game Screen, and End Screen) and type the 
name of the variable as per your choice. This variable stores the game score. You can call this variable from any of 
your project slides. 
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3 Click Preview button to view the changes, after editing the properties and click OK. 

Note: Edit and Preview are toggle buttons. When you are in Editing mode, Preview button appears and if you are in 
Preview mode, Edit button appears. A sample screenshot of Edit mode is shown below. 

Memory game interaction
A revamped version of Memory game interaction is introduced in Adobe Captivate 8 release. 

The objective of this memory game is to find a match for an image or text. By default, the images or text will be hidden. 
When you click each card, an image or text appears. Then you need to find a suitable match for that opened image or 
text by randomly clicking other cards. 

Creating Memory Game
1 From Toolbar, click Interactions > Learning Interactions.

2 Scroll down in the dialog window to select Memory Game interaction, as shown in the following screenshot, and 
click Insert.
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3 Click image icon or text icon in the Configure interaction dialog to add images or text for the game. 
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4 Click Insert Multiple Images button to include multiple images at a time into the game. 

Choose the images from the library or click Import to include your own images. 
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Note: You can delete the image by hovering the mouse over the image and clicking delete icon, as shown below. 

5 Click OK when you complete adding images and text to the interaction. 

A sample output is shown below. 
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Customizing Memory Game
You can customize the appearance of Memory game by choosing your own screen properties for Instructions, Start 
Screen, Game Screen and End Screen windows. Change the card shapes, card borders, card background colors, 
instructions, fonts, screen appearance, hints and so on. 

1 Click Customize button at the bottom right corner of the Configure interaction dialog. 

Configure interaction dialog appears to customize the properties. 
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2 Choose the Start, Game and End screen tabs and change the properties.

Start Screen Modify the font colors of Game name and Play Button text. Change the background color of the 
interaction, add instructions as per your choice, set the time limit for the game and add time duration for the hint 
to appear at start of the game. 

Game Screen Modify the appearance of screen as horizontal or vertical, change the card shapes as rectangular, 
circle, square and so on, change the card border color, and change the card base (background) by choosing your 
color or by adding image.

End Screen Add text of your choice and font colors for Game over text, Time's up text, and Text before score. You 
can also specify the font color for End score. 

Click Variable text in End Screen tab and edit the default name or type a name of the variable as per your choice. 
This variable stores the game score. You can call this varible from any of your project slides.
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Color Settings You have an option to choose either default color settings or theme settings for your screens. In either 
of these settings, you can customize the color properties of screen elements like background, top banner color and 
so on. Your customized settings will be saved and you can go back to these settings by clicking Customize in Color 
settings 

Click OK when you complete making changes.

A sample output after making changes to the card appearance is shown below. 

Add text entry boxes with Adobe Captivate
Text entry boxes are text fields into which users can enter text. Text entry boxes are a great way to test users’ knowledge. 
After the user answers a question, Adobe Captivate matches the answer with the answers that you have set when 
creating the text entry box. You can even provide a hint to the user if you want to.

Add a text entry box
1 Open the slide to which you want to add a text entry box.

2 Select Insert > Standard Objects > Text Entry Box. The text entry box appears on the slide.

3 Size and drag the text entry box as desired. 

4 Double-click the Success, Failure, or Hint captions to edit the text.

5 To change the properties of the text entry box, click the box and change the properties in the Property inspector.
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Properties of text entry boxes
To view the properties of a text entry box, select it on the slide. The Property inspector displays the properties of the 
text entry box.

When you change the properties, the changes are instantly applied to the selected instance of the text entry box. Click 
the Apply to all icon to apply the changes to all the click boxes in the project or to those that use the same object style.

Text Entry Box
Name Enter a unique name for the text entry box. You can use this name when defining the visibility conditions for 
the box. 

Visible Clear this option if you want the text entry box to be invisible when the project is played. The object can be 
made visible when a specific event occurs such as the entry to a slide or exit from a slide. For more information, see 
Controlling the visibility of objects.

Style Select a style for the text entry box. To define a new style, select Edit > Object Style Manager. For more 
information on object styles, see Working with object styles in Adobe Captivate

General
Default Text Displays the default text that appears in the text entry box. The user can overwrite the displayed text to 
type the answer. For example, you can set a default text for the text entry box saying, “Enter the answer here.”

Retain Text Allows users to view their previously entered answer if they return to this slide using the Back button.

Show Text Box Frame Enables or disables the visibility of the text entry box frame. If you do not select this option, only 
the Default Text is displayed to the user.

Password Field Displays asterisks in the text entry box to indicate that the box is a password field. 

Validate User Input Validates the input provided by the users. The box behaves like a form field and accepts any user 
input.

Success Caption The caption displayed when the user provides the correct answer. 

Failure Caption The caption displayed when the user provides an incorrect answer. 

More Options Lets you specify the following options (available in the update for subscription and Adobe Software 
Assurance customers only):

Maximum Length Number of characters that you want to limit the input to.

Auto Submit This option is enabled if you have specified a limit on the number of characters. When you enable this 
option, the users' input is automatically submitted when the limit is reached without them having to click Submit.

Numbers Click if you want only numbers to be entered by users.

Uppercase Click if you want only uppercase characters to be entered into the text entry box. All characters that are 
typed into the box are automatically converted to uppercase even if users type them in lowercase.

Lowercase Click if you want only lowercase characters to be entered into the text entry box. All characters that are 
typed into the box are automatically converted to lowercase even if users type them in uppercase.

None Click to remove any restriction that you have set (numbers, uppercase, or lowercase).

Var Associated Indicates the name of the variable that stores the value entered in the text entry box by users. To specify 
a different variable name, click the ‘X’ icon, type the name of the variable, and click Ok.

On Focus Lost  Select the action that should be performed when the user presses Enter or Tab.
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Character
Family Displays the font family associated with the text entered in the text entry box.

Style Displays the style for the characters entered in the text entry box.

Size Displays the size of the characters entered in the text entry box.

Format Displays the format (bold or italic) for the text entered in the text entry box.

Color Displays the color of the characters entered in the text entry box.

Note: When you change the properties in this section, the object style in the General section is prefixed with a ‘+’ sign. This 
indicates that the style is now in a overridden state. For more information on object styles, see Working with object styles 
in Adobe Captivate

Action
On Success Specifies the event that occurs when a user clicks the box. For the description of the available options, see 
How to use interactive objects for project navigation.

Attempts [#] Specifies the number of times the user can attempt the question before the specified action takes place. 
By default, the number of attempts allowed is infinite. To specify a number, clear the Infinite check box and then click 
the numeral associated with the Attempts option.

Infinite Allows users an unlimited number of attempts.

Last Attempt Specifies the event that should take place after the last attempt. For the description of the available 
options, see How to use interactive objects for project navigation.

• If you select Open URL Or File or Open Another Project, click the inverted arrow icon next to the URL or the
Project field to select the window in which the URL, file, or project appears. Select from Current, New, Parent, and
Top. If you choose New, Parent, or Top, you also have the option to continue playing the original project when the
URL, file, or project opens.

• If you select Send E-mail To, you have the option to continue playing the project while the e-mail message is
prepared and sent.

Shortcut You can specify a keyboard shortcut for the mouse-click. Users can use the keyboard shortcut instead of the 
mouse. For example, suppose you select Control+Shift+Enter as the keyboard shortcut for the mouse-click. The click 
is treated as correct (a click within the box) when users press this combination. If they press the wrong combination, it 
is treated as a click outside the box. 

Note: If your Adobe Captivate project is displayed in a browser, set keyboard shortcuts that do not conflict with common 
browser shortcuts. For example, F1 is frequently used as a keyboard shortcut to display Help. The Control, Alt, and Shift 
keys map to the Control, Option, and Shift keys on Macintosh® computers, respectively.

Options
Success select this check box to include a caption to be displayed when the user clicks inside the click box.

Failure select this check box to include a caption to be displayed when the user clicks outside the click box. 

Hint select this check box to specify a hint to be displayed to users. The hint is displayed when the user moves the 
mouse over the click box.

Pause For Success/Failure Captions select this check box to pauses the project until all success and failure captions are 
displayed.

Show Button Adds a Submit button to the text entry box by default. Click the button to change its properties such as 
the label for the button and the formatting of the characters in the label.
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Show Scrollbar Displays a scroll bar when the user exceeds the space available in the text entry box.

Shadow & Reflection
Shadow Select the check box to apply shadow to the text entry box.

Direction Select the direction: inner or outer. The preview of the selected direction is displayed on stage. 

Presets click one of the images in Presets to apply a shadow with standard angle, distance, blur, and color settings. You 
can customize these settings using the appropriate options in the Shadow accordion.

Color click to select a color for the shadow. Specify the alpha for the color, in percentage, in the adjacent field.

Blur Specify a value, in pixels, for the blur of the shadow.

Angle Specify the angle for the shadow. 

Distance specify the distance, in pixels, at which the shadow must be displayed.

Reflection Select the check box to add reflection to the text caption. Choose one of the presets.

Timing
Display For Specifies how long the text entry box is displayed on the slide.

Appear After Specifies the delay between the first appearance of the slide and the first appearance of the text entry box.

Pause After Specifies the point at which the project pauses so that the user can enter text in the text entry box. The 
project continues only after the user submits the correct answer.

Transition
Effect Displays the transition effect for the text entry box. You can apply a fade in or fade out effect and set the time for 
the fading effects.

Fill And Stroke
Fill indicates the background color of the text entry box. To change the color, click the Fill box and click a color in the 
color palette.

Reporting tab
If you want to keep score for the text entry box or coordinate the score with a learning management system, use the 
Reporting tab. 

Include In Quiz Considers the text entry box as a question in the current quiz. The points assigned to this box are added 
to the score results of the current quiz.

Points The score that you want to assign to the question. The maximum is 100 points, the minimum is 0. The points 
assigned to this text entry box are added to the score results of the current quiz.

Add To Total Includes the points for the correct click in the total score.

Report Answers Sends the quiz score to the learning management system (LMS).

Interaction ID Sends tracking information to your learning management system. Use the interaction ID specified by 
your learning management system.

Audio tab
Fade In [#] Seconds Specifies the number of seconds until the audio fades in to full volume.

Fade Out [#] Seconds Specifies the number of seconds until the audio fade outs to silence.
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Add Audio Allows you to associate an audio with the click box.

Transform
Use this section to define the exact size or location of the text entry box in terms of pixels. You can also specify the 
rotation of a text entry box in this section.

X Position of the text entry box on the X-axis

Y Position of the text entry box on the Y-axis.

W Width of the text entry box.

H Height of the text entry box.

Constrain Proportions Maintains the height-to-width ratio of the text entry box when you resize it.

Angle Angle of rotation of the text entry box.

More Help topics 
Learning management system (LMS)

How to use interactive objects for project navigation
You can define the navigation options using interactive objects according to the following:

• When the user performs the action as defined in the application

• When the user performs an action other than that defined in the application

The following list describes actions available in both the On Enter and On Exit menus in the Property inspector of a 
slide.

Note: The options Go To Previous Slide, Go To Next Slide, Go To Last Visited Slide, and Jump To Slide are available only 
in the On Exit menu.

Continue

The movie moves to the next defined action.

Go To The Previous Slide

The previous slide is displayed to the user.

Go To The Next Slide

The movie moves to the next slide.

Go To The Slide Last Visited

The movie moves to the previously viewed slide.

Jump To Slide

The movie moves to the specified slide.

Open URL Or File

A web browser opens with the specified web page if the user has internet connectivity. Alternatively, you could open a 
specified file for the user.

http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#learning_management_system_lms
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While specifying a URL, click the arrow adjacent to the URL box to open the URL in one of the following ways:

Current In the current browser window in which the Adobe Captivate movie is playing.

New In a new browser window.

Parent In cases where the Adobe Captivate project is a part of an HTML page, choose this option to display the URL 
in the region allotted for the project.

Top In cases where the Adobe Captivate project is a part of an HTML page, choose this option to display the URL in 
the ‘top frame’ of the page. 

Open Another Project

Opens the specified Adobe Captivate project.

Send E-mail To

A draft of the default e-mail editor opens with the e-mail address specified in the To field.

Execute JavaScript

Adobe Captivate runs the specified JavaScript.

Execute Advanced Actions

Adobe Captivate runs the script written in Adobe Captivate.

Execute Shared Action

Lets you associate the object with a shared advanced action. If you choose this option, select a shared action from the 
drop-down list and click {P} to edit the parameters.

Play Audio

Adobe Captivate plays the audio assigned to the interactive object. The audio plays until users click another interactive 
object, or navigate away from the slide. If users do not interact, the audio plays only for the duration of the specified 
audio file and does not loop.

Before the audio ends, if users click another interactive object with audio, the second audio file begins to play.

Note: If you use multiple Play Audio actions in Advanced Actions, only the audio corresponding to the first Play Audio 
action is played.

Stop Triggered Audio

Adobe Captivate stops the latest audio that was triggered by the Play Audio action.

Show

When the user performs the required action, the specified hidden object is made visible
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Hide

When the user performs the required action, the specified object is hidden from the user.

Enable

When the user performs the required action, it activates another object in the project.

Disable

When the user performs the required action, it disables another object in the project.

Assign

When the user performs the required action, the value of the specified variable is set inside the object.

Increment

When the user performs the required action, the value of the specified variable is incremented accordingly.

Decrement

When the user performs the required action, the value of the specified variable is decremented accordingly.

Exit

When users perform the required action, they exit from the movie.

Pause

When users perform the required action, the movie pauses.

Apply Effect

When the user performs the required action, the effect associated with the specified object is applied.

Toggle

When users perform the required action, the specified varible toggles from 0 to 1 and from 1 to 0.

Show TOC

When users perform the required action, the TOC is displayed.

Show Playbar

When users perform the required action, the playbar is displayed.

Hide TOC

When users perform the required aciton, the TOC is hidden.

Hide Playbar

When users performthe required action, the playbar is hidden.

Lock TOC

When users perform the required action, the TOC is locked. Clicking a topic in the TOC does not navigate users to the 
topic.

Unlock TOC

When users perform the required action, the TOC is unlocked.

No Action
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Nothing happens when the user exits the slide.

Creating click boxes in Adobe Captivate
Click boxes are areas on the slide where the user must click before the next action can take place. You can use click boxes 
to demonstrate an application's functionality, for example, by placing them on menus or buttons where the user must 
click. You can determine what happens after the user performs a successful click. For example, the project can advance 
to the next slide, open a URL, or send an e-mail message.

You can insert the following types of click boxes in Adobe Captivate:

• Right-click box

• Left-click box

• Double-click box

Unless specified as a double-click or right-click box in the properties, click boxes act as left-click boxes. You can 
recognize the different kinds of click boxes by their associated icons.

Right-click boxes are not supported in the following cases and act as left-click boxes after you publish the Adobe 
Captivate project:

• Publishing a project as a SWF file (HTML option enabled) unless you:

• Disable accessibility (Edit > Preferences > Project > Publish Settings)

• Publish SWF in a trusted path if you are planning to serve the content from a CD. If the javascript is enabled in
the browser and the content is served from a webserver, this step is not required.

• Publishing a project with 508 compliance enabled.

• Publishing a project to a PDF file.

• Publishing a project as EXE files.

Note: Right-click boxes are not supported during the project preview (Project, From This Slide, and Next ‘n’ Slides preview 
options).

After you have added a click box to your project, you can view and edit its properties using Property inspector. To view 
the properties of a click box in relation with other interactive objects in the project, select Project > Advanced 
Interaction.

Properties of click boxes
To view the properties of a click box, select it on the slide. The Property inspector displays the properties of the click 
box.

When you change the properties, the changes are instantly applied to the selected instance of the click box. Click the 
Apply to all icon to apply the changes to all the click boxes in the project or to those that use the same object style.
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Click Box section
Name Enter a unique name for the object. You can use this name when defining the visibility conditions for the object. 

Visible Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the 
Show option. For more information, see Controlling the visibility of objects .

Action section
On Success Specifies the event that occurs when a user clicks the box, for example, opening another project or a specific 
URL. For the description of the available options, see How to use interactive objects for project navigation.

Attempts [#] Specifies the number of times the user can attempt the question before the specified action takes place. 
By default, the number of attempts allowed is infinite. To specify a number, clear the Infinite check box and then click 
the numeral associated with the Attempts option.

Infinite Allows users an unlimited number of attempts.

Last Attempt Specifies the event that should take place after the last attempt. For the description of the available 
options, see How to use interactive objects for project navigation.

• If you select Open URL Or File or Open Another Project, click the inverted arrow icon next to the URL or the
Project field to select the window in which the URL, file, or project appears. Select from Current, New, Parent, and
Top. If you choose New, Parent, or Top, you also have the option to continue playing the original project when the
URL, file, or project opens.

• If you select Send E-mail To, you have the option to continue playing the project while the e-mail message is
prepared and sent.

Shortcut You can specify a keyboard shortcut for the mouse-click. Users can use the keyboard shortcut instead of the 
mouse. For example, suppose you select Control+Shift+Enter as the keyboard shortcut for the mouse-click. The click 
is treated as correct (a click within the box) when users press this combination. If they press the wrong combination, it 
is treated as a click outside the box.

Note: If your Adobe Captivate project is displayed in a browser, set keyboard shortcuts that do not conflict with common 
browser shortcuts. For example, F1 is frequently used as a keyboard shortcut to display Help. The Control, Alt, and Shift 
keys map to the Control, Option, and Shift keys on Macintosh® computers, respectively.

Options section
Success select this check box to include a caption to be displayed when the user clicks inside the click box.

Failure select this check box to include a caption to be displayed when the user clicks outside the click box. 

Hint select this check box to specify a hint to be displayed to users. The hint is displayed when the user moves the 
mouse over the click box.

Pause For Success/Failure Captions select this check box to pauses the project until all success and failure captions are 
displayed.

Show Hand Cursor Over Hit Area Select this check box to change the pointer to a pointing hand when the user moves 
the pointer over the click box. 

Double Click Select this check box if you want the users to double-click the click box. 

Disable Click Sound Select this check box to disable the click sound that is played when users click inside the click box 
area.

Pause Project Until User Clicks Select this check box to pause the project till the users click the click box. The project 
resumes only after the user clicks the click box.

http://helpx.adobe.com/en/captivate/using/controlling-visibility-objects.html#controlling_the_visibility_of_objects
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Right Click Select this check box if you want the users to right-click on the click box.

Timing section
Display For [Time] Specifies the time for which the click box appears on the slide.

Appear After [#] Seconds Specifies the time after which the click box appears on the slide after the slide starts playing.

Audio section
Fade In [#] Specifies the time for the audio to fade in to full volume.

Fade Out [#] Specifies the time for the audio to fade out to silence.

Stop Slide Audio When Clicked Stops playing the audio file associated with the slide when you click inside the click box 
area. This option stops only the slide audio, not the background audio. Also, using a keyboard shortcut does not stop 
the audio.

Stop Slide Audio When Paused Stops playing the audio file associated with the slide when the project is paused. For 
example, if you have enabled the Pause Project Until User Clicks option, the slide audio stops until the user clicks inside 
the click box area.

Add Audio Allows you to associate an audio with the click box.

Reporting section
You can assign a score to every correct mouse-click and coordinate the score with a learning management system.

Include In Quiz Considers the click box as a question in the current quiz. The points assigned to this click box are added 
to the score results of the current quiz.

Points The score that you want to assign to the question. The maximum is 100 points, the minimum is 0. The points 
assigned to this click box are added to the score results of the current quiz.

Add To Total Includes the points for the correct click in the total score.

Report Answers Sends the quiz score to the learning management system (LMS).

Interaction ID Sends tracking information to your learning management system. Use the interaction ID specified by 
your learning management system.

Transform section
Use this section to define the exact size or location of the click box in terms of pixels. You can also specify the rotation 
of a click box in this section.

X Position of the click box on the X-axis

Y Position of the click box on the Y-axis.

W Width of the click box.

H Height of the click box.

Constrain Proportions Maintains the height-to-width ratio of the click box when you resize it.

Angle Angle of rotation of the click box.

Add a click box
1 Open the slide to which you want to add a click box.
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2 Select Insert > Standard Objects > Click Box. A click box appears on the slide.

3 Size and drag the click box as desired. 

4 Double-click the Success, Failure, or Hint captions to edit the text.

5 To change the properties of the click box, click the box and change the properties in the Property inspector.

More Help topics 
Learning management system (LMS)

Project navigation using interactive objects

Add interactive buttons to your Captivate projects
You can increase the interactivity of your Adobe Captivate projects by adding buttons. To quickly add a button, use the 
default button style (a plain, white rectangle). You can also import custom button images. You can size and position 
buttons on a slide. You determine what happens after the user clicks the button. 

Add a button
Note: Resize any buttons before resizing the project. Resizing a project does not resize the buttons automatically.

1 Open the slide to which you want to add a button.

2 Select Insert > Standard Objects > Button.

Note: You can delete a button at any time by selecting it and pressing the Delete key. When you delete a button, all 
associated objects (such as success and failure captions) are also deleted.

The button appears on the slide.

3 Size and drag the button as desired.

4 Double-click the Success, Failure, or Hint captions to edit the text.

5 To change the properties of the button, click the button and change the properties in the Property inspector.

Properties of buttons
To view the properties of a button, select it on the slide. The Property inspector displays the properties of the button.

When you change the properties, the changes are instantly applied to the selected instance of the button. Click the 
Apply to all icon ( )to apply the changes to all the buttons in the project or to those that use the same object style.

Button
Name Enter a unique name for the button. You can use this name when defining the visibility conditions for the button. 

Visible In Output Clear this option if you want the button to be invisible when the project is played. The object can be 
made visible when a specific event occurs such as the entry to a slide or exit from a slide. For more information, see 
Controlling the visibility of objects .

Style Select a style for the button. To define a new style, select Edit > Object Style Manager. For more information on 
object styles, see Working with object styles in Adobe Captivate

http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#learning_management_system_lms
http://helpx.adobe.com/en/captivate/using/project-navigation-using-interactive-objects.html#project_navigation_using_interactive_objects
http://helpx.adobe.com/en/captivate/using/controlling-visibility-objects.html#controlling_the_visibility_of_objects
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General
OS Button Button with text displayed on it. The look and feel of the button is different on different operating systems.

Caption Type text that you want displayed on the button.

Make Button Transparent Makes the button transparent. When a text button is transparent, only its text appears on the 
slide.

Theme Button Button that you can customize by modifying attributes such as fill color and corner radius. You can have 
text on theme buttons too.

Caption Type text that you want displayed on the button.

Fill Color Color of the button.

Stroke Color for the border of the button.

Width Thickness of the border around the button.

Style The style for the stroke line.

Corner Radius Radius for smoothening the corners of the button.

Image Button Use an image as a button. You can browse to an image available in the gallery or choose from the menu 
displayed.

Make Transparent Creates a button that is transparent.

Character
Family Displays the font family associated with the text entered in the button.

Style Displays the style for the characters entered in the button.

Size Displays the size of the characters entered in the button.

Format Displays the format (bold or italic) for the text entered in the button.

Color Displays the color of the characters entered in the button.

Note: When you change the properties in this section, the object style in the General section is prefixed with a ‘+’ sign. This 
indicates that the style is now in a overridden state. For more information on object styles, see Working with object styles 
in Adobe Captivate

Action
On Success Specifies the event that occurs when a user clicks the button. For the description of the available options, 
see How to use interactive objects for project navigation.

Attempts [#] Specifies the number of times the user can attempt the question before the specified action takes place. 
By default, the number of attempts allowed is infinite. To specify a number, clear the Infinite check box and then click 
the numeral associated with the Attempts option.

Infinite Allows users an unlimited number of attempts.

Last Attempt Specifies the event that should take place after the last attempt. For the description of the available 
options, see How to use interactive objects for project navigation.

• If you select Open URL Or File or Open Another Project, click the inverted arrow icon next to the URL or the
Project field to select the window in which the URL, file, or project appears. Select from Current, New, Parent, and
Top. If you choose New, Parent, or Top, you also have the option to continue playing the original project when the
URL, file, or project opens.
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• If you select Send E-mail To, you have the option to continue playing the project while the e-mail message is
prepared and sent.

Shortcut You can specify a keyboard shortcut for the mouse-click. Users can use the keyboard shortcut instead of the 
mouse. For example, suppose you select Control+Shift+Enter as the keyboard shortcut for the mouse-click. The click 
is treated as correct (a click within the box) when users press this combination. If they press the wrong combination, it 
is treated as a click outside the box. 

Note: If your Adobe Captivate project is displayed in a browser, set keyboard shortcuts that do not conflict with common 
browser shortcuts. For example, F1 is frequently used as a keyboard shortcut to display Help. The Control, Alt, and Shift 
keys map to the Control, Option, and Shift keys on Macintosh® computers, respectively.

Options
Success select this check box to include a caption to be displayed when the user clicks the button.

Failure select this check box to include a caption to be displayed when the user clicks outside the button. 

Hint select this check box to specify a hint to be displayed to users. The hint is displayed when the user moves the 
mouse over the button.

Pause For Success/Failure Captions select this check box to pauses the project until all success and failure captions are 
displayed.

Show Hand Cursor Over Hit Area Select this check box to change the pointer to a pointing hand when the user moves 
the pointer over the button. 

Double Click Select this check box if you want the users to double-click the button. 

Disable Click Sound Select this check box to disable the click sound that is played when users click inside the button 
area.

Shadow & Reflection
Shadow Select the check box to apply shadow to the button.

Direction Select the direction: inner or outer. The preview of the selected direction is displayed on stage. 

Presets click one of the images in Presets to apply a shadow with standard angle, distance, blur, and color settings. You 
can customize these settings using the appropriate options in the Shadow accordion.

Color click to select a color for the shadow. Specify the alpha for the color, in percentage, in the adjacent field.

Blur Specify a value, in pixels, for the blur of the shadow.

Angle Specify the angle for the shadow. 

Distance specify the distance, in pixels, at which the shadow must be displayed.

Reflection Select the check box to add reflection to the text caption. Choose one of the presets.

Timing
Display For Specifies how long the button is displayed on the slide.

Appear After Specifies the delay between the first appearance of the slide and the first appearance of the button.

Pause After Specifies the point at which the project pauses so that the user can click the button. The project continues 
only after the user clicks the button.
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Reporting tab
If you want to keep score for the button or coordinate the score with a learning management system, use the Reporting 
tab. 

Include In Quiz Considers the button as a question in the current quiz. The points assigned to this button are added to 
the score results of the current quiz.

Points The score that you want to assign to the question. The maximum is 100 points, the minimum is 0. The points 
assigned to this button are added to the score results of the current quiz.

Add To Total Includes the points for the correct click in the total score.

Report Answers Sends the quiz score to the learning management system (LMS).

Interaction ID Sends tracking information to your learning management system. Use the interaction ID specified by 
your learning management system.

Audio tab
Fade In [#] Specifies the time for the audio to fade in to full volume.

Fade Out [#] Specifies the time for the audio to fade out to silence.

Stop Slide Audio When Clicked Stops playing the audio file associated with the slide when the users click button. This 
option stops only the slide audio, not the background audio. Also, using a keyboard shortcut does not stop the audio.

Stop Slide Audio When Paused Stops playing the audio file associated with the slide when the project is paused.

Add Audio Allows you to associate an audio with the button.

Transform
Use this section to define the exact size or location of the buttons in terms of pixels. You can also specify the rotation 
of a button in this section.

X Position of the button on the X-axis

Y Position of the button on the Y-axis.

W Width of the button.

H Height of the button.

Constrain Proportions Maintains the height-to-width ratio of the button when you resize it.

Angle Angle of rotation of the button.

Properties of review buttons
The Review button is present on the quiz results slide. When users click the Review button, they are presented with a 
slide that provides a report of the questions that were answered correctly and incorrectly. It also provides the correct 
answers to all the questions. The properties of review buttons are similar to those of normal buttons.

Automatically resize buttons
You can configure Adobe Captivate to automatically resize a button or caption according to the amount of text in the 
button. If you edit the text, the button changes size to accommodate the new text. 

1 In an open project, select Edit > Preferences (on Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select Defaults under the Global menu. 
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3 Select Autosize Buttons in the General panel on the right.

Note: Best practice is to resize buttons before resizing the project. Resizing a project does not resize the buttons 
automatically.

Modify buttons on question slides
You can modify some properties of buttons on question slides. The standard buttons are Clear, Back, Submit, and Skip.

1 Select the question button that you want to modify.

2 In the Quiz Properties panel, set the values for the various options.

Note: Resize any buttons before resizing the project. Resizing a project does not resize the buttons automatically.

More Help topics 
Learning management system (LMS)

Project navigation using interactive objects

Set general quiz preferences

How to add audio to boxes and buttons
You can import an audio file to use with buttons, highlight boxes, click boxes, or text entry boxes. You can use the audio 
files that are available in the Gallery or record your own audio to associate with these objects. The Gallery folder is in 
C:\Program Files\Adobe\Adobe Captivate 6.0 (on Windows) and /Applications/Adobe Captivate 6.0/Gallery/ (on Mac 
OS). 

You can also use the Library to add an audio file that already exists in the project.

The audio file plays when the object appears. You can also associate Audio with Success, Failure, or Hint captions.

Import an audio file
1 Click the click box, text entry box, or the button.

2 In the Audio section of the Property inspector, click Add Audio.

3 In the Object Audio dialog box, click Import (F6).

4 Browse to the audio file you want to add, select the file, and click Open.

5 To listen to and test the audio file, click the Play icon.

6 To change the audio settings such as input devices, quality level, or calibration, click Settings.

7 Click the Edit tab to edit the audio file (change volume, add silence, and change length).

8 Click Save and then Close.

Import an audio file from the Library
1 Click the click box, text entry box, or the button.

2 In the Audio section of the Property inspector, click Add Audio.

3 In the Object Audio dialog box, click Library.

http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#learning_management_system_lms
http://helpx.adobe.com/en/captivate/using/project-navigation-using-interactive-objects.html#project_navigation_using_interactive_objects
http://helpx.adobe.com/en/captivate/using/quiz-preferences.html#set_general_quiz_preferences
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Note: To use the Library option, the Adobe Captivate project must contain one or more audio files. If the project has no 
audio files, the Library option is unavailable.

4 In the Select Audio From The Library dialog box, select the audio file, and click OK. To use an audio file that does 
not exist in the library, click Import.

5 To listen to and test the audio file, click the Play icon.

6 To change the audio settings such as input devices, quality level, or calibration, click Settings.

7 Click the Edit tab to edit the audio file (change volume, add silence, and change length).

8 Click Save and then Close.

How to add JavaScript to boxes and buttons in Adobe 
Captivate
You can add JavaScript to click boxes, text entry boxes, and buttons in Adobe Captivate projects. The JavaScript can run 
when a user clicks inside or outside the box or button. Using JavaScript gives you the opportunity to extend projects in 
numerous ways while adding interactivity.

1 Click the click box, text entry box, or the button.

2 In the Action section of the Property inspector, select Execute JavaScript in the On Success or Last Attempt list as 
required.

3 Click Script_Window.

4 Enter your JavaScript code in the text box and click OK. If you have the JavaScript in another location, copy it and 
paste it into the text box.
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Chapter 9: Audio

View audio details in Adobe Captivate
You can view all audio details (Audio > Audio Management) in one convenient location in Adobe Captivate. This is an 
easy way to see the playing time, size, and other attributes of all the audio files in a single project.

Audio details
Slide/Object The slide name.

Sound The presence (Yes or No) of a sound file.

Duration The length of the sound file, in seconds.

Fade In The presence (Yes or No) of a fade-in effect.

Fade Out The presence (Yes or No) of a fade-out effect.

Size The size of the sound file.

Original Filename The original name of the sound file.

Display Name The name of the file after you have renamed it in Adobe Captivate. If you have not renamed the file, the 
original name is displayed.

Audio Sample Rate (kHz) This rate is the number of times per second the original waveform is translated into digital 
form. A higher sample rate results in a more accurate digital representation of the sound. The sample rate for CD-
quality audio is 44,100 samples per second.

Bitrate (Kbps) This rate is the number of bits a digital file uses in a specific time period, usually expressed as kilobits 
per second. The higher the bit rate at which an audio file is encoded, the higher the sound quality; 128 Kbps is a 
commonly used rate.

Closed Caption Indicates whether a transcript of the dialogue or sound effects has been included in the audio file.

Slide settings
Play click this icon to plays the audio for the selected slide.

Stop click this icon to stop the audio from playing.

Remove Click this icon to remove or delete the audio for the selected slide.

Export Click to opens a Browse For Folder dialog box and export the selected audio file to a folder.

Update Click to pull an updated version of the audio file.

Closed Caption Click this icon to enter a transcript of the dialogue or sound effects included in the audio file. Closed 
captioning improves the accessibility of your project for hearing-impaired users.

Show object level audio Select this check box to display any audio files associated with objects (click boxes, captions, 
buttons, highlight boxes, and so on) in the project.
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Include MP3 files in export Select this check box to include mp3 files when you export audio.

Include WAVE files in export Select this check box to include WAV files when you export audio.

Working with system audio in Adobe Captivate 7
System audio refers to the audio from your computer's speakers. For example, audio associated with YouTube videos 
or the sound you hear when error messages pop-up in some applications. Adobe Captivate lets you capture or record 
system audio while recording a software simulation or a video demo. You can also add system audio to a slide after 
creating a project by recording or importing.

Note: Adobe Captivate does not support recording of system audio on Windows XP. On Mac, ensure that you have installed 
and configured Soundflower to record system audio for Adobe Captivate projects. For more information, see this article.

You can add system audio only to a specific slide. This means, you can import or edit system audio using the following 
options in the Audio menu:

• Import To > Slide

• Record To > Slide

• Edit > Slide

When a slide contains both narration and system audio, the Timeline displays two different layers for both these audio 
waveforms.

A Narration  B System Audio  

However, in a video demo project, the system audio does not exist on a separate layer in the Timeline. Narration and 
system audio are merged into a single audio waveform. The two types of audio are available as two different items in 
the Edit Audio dialog box and Adobe Captivate Library.

You cannot add closed captions to system audio.

More Help topics 
Recording in sync

Edit audio

Insert audio

Preview audio

http://helpx.adobe.com/captivate/kb/system-audio-disabled.html
http://helpx.adobe.com/en/captivate/using/recording-sync.html
http://helpx.adobe.com/en/captivate/using/edit-audio.html
http://helpx.adobe.com/en/captivate/using/insert-audio.html
http://helpx.adobe.com/en/captivate/using/preview-audio.html
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View audio details

Export audio

View narration and system audio waveforms
The default view in the Slide Audio dialog box (Add/Replace or Edit tabs) displays all audio waveforms that are 
currently associated with the slide.

http://helpx.adobe.com/en/captivate/using/view-audio-details.html
http://helpx.adobe.com/en/captivate/using/export-audio.html
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To view:

• Only narration, click the system audio icon ( ).
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• Only system audio, click the narration icon ( ).

• Both narration and system audio, click both narration and system audio icons.

Note: In a video demo project, narration and system audio waveforms are merged in the Timeline. However, the two types 
of audio are separately available for editing in the Edit Audio dialog box and Adobe Captivate Library.

Delete system audio 
Right-click the audio waveform in the Timeline and select Remove.

Note: When you click Remove Audio in the Audio accordion of the Property Inspector, both narration and system audio 
associated with the slide are deleted.

Setting audio recording preferences and recording 
audio
Add sync sound (synchronized sound recording) to your projects by narrating the movie into a microphone as you 
record it. The movie is recorded in the mono format.

Recording equipment
Having the right audio equipment makes a big difference in the quality of recorded audio. 

Computer with sound card The sound card installed with your computer acts as a digital recorder for audio.

Microphone If possible, avoid using the inexpensive microphone packaged with your computer. Also, use a proper 
microphone cable and a stand to hold the microphone while you are recording.

Microphone preamplifier A preamplifier boosts the signal of the microphone. The microphone input of your sound 
card probably includes a preamplifier, but it is most likely of poor quality. When purchasing a preamplifier, you can 
choose a small mixer or a stand-alone version. Mixers let you connect several microphones and devices to one location 
and adjust their volumes independently. Stand-alone preamplifiers are considered better than mixers at filtering out 
unwanted noises.

Speakers  The speakers that came with your computer are probably good enough for recording purposes. You can 
change some of your speaker settings if required. However, if you are working on a laptop, use standard desktop 
computer speakers instead of the built-in laptop speakers.

Headphones Headphones are important because when the microphone is on, speakers can cause distracting feedback. 
Additionally, it is best to use closed-ear headphones that prevent leaking sound (which can be picked up by the 
microphone). 

Media players Any software that can play audio files on your system.

Recording software A wide range of recording software is available. Important software features include editing 
functionality (to fix mistakes), music and sound effect options, and the capability to create the file format you require 
(such as mp3 or WAV). 

Recording area After you have acquired the necessary audio equipment, the most important action you can take before 
recording is an obvious one: find a quiet place to record. Try closing doors, turning off any unnecessary computer 
equipment, turning off or lowering lights, turning off phone ringers, beepers, and pagers. Inform your coworkers that 
recording is in progress.
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Tips for recording audio
Follow these tips to ensure that you are recording the highest quality audio possible.

Setup After you have acquired the necessary audio recording equipment, ensure that it is set up properly. First, plug 
your microphone into your mixer or preamplifier, and then plug the output of that device into your computer sound 
card's “line in.” Plug your headphones into your computer. Then, set the volume on your mixer or preamplifier. Begin 
speaking to test the volume levels, and carefully raise the volume until it shows just under zero.

Sound card settings Open the software application that controls the sound card. The sound settings are located in the 
Control Panel. Select the recording source (Line In) and adjust the volume to 100%.

You control the actual recording level with your mixer or preamplifier.

Audio recording software settings Start your audio recording software. Change the settings as necessary. Note that 
mixers and preamplifiers do not have sound-level controls, so you rely on the meters when recording. While recording, 
ensure that you do not exceed zero on the meters, or the sound will be distorted.

Microphone placement Positioning your microphone correctly can make a big difference in the finished audio file. 
First, get close to the microphone (within 4 to 6 inches), so any other nearby sounds have less chance of being recorded. 
Don't speak down to the microphone; instead, position it above your nose and pointed down at your mouth. Finally, 
position the microphone slightly to the side of your mouth, because this can help soften the sound of the letters S and P. 

Microphone technique Have a glass of water nearby so you can avoid “dry mouth.” Before recording, turn away from 
the microphone, take a deep breath, exhale, take another deep breath, open your mouth, turn back toward the 
microphone, and start speaking. This trick can eliminate breathing and lip-smacking sounds frequently recorded at the 
beginning of audio tracks. Speak slowly and carefully. You may feel that you are speaking artificially slowly, but you 
should be able to adjust the speed later by using your audio recording software. Finally, bear in mind that you don't have 
to get everything right the first time. You can listen and evaluate each recording and rerecord if required.

Audio editing Editing sound is similar to editing text. Listen carefully to your recording. Delete any extraneous sounds 
and then use the options available in your software to polish the track. Add any music or sound effects you require. 
Make sure you save your audio track in the correct format (mp3 or WAV files). 

Adding audio files to Adobe Captivate When you are finished recording the audio file, add it to the Adobe Captivate 
project.

Additional feedback After you add the audio to the Adobe Captivate project, listen to it again. Play the project as users 
normally would. Finally, ask others to preview the Adobe Captivate SWF/audio file. If necessary, edit the audio file 
again. 

Set audio recording preferences
Audio files present the common challenge of balancing quality against size. The higher the sound quality, the larger the 
file size. The more you compress a sound and the lower the sampling rate, the smaller the size and lower the quality. 
Adobe Captivate lets you control the way sound is recorded and compressed based upon your input and output 
requirements. 

Creating audio in Adobe Captivate is essentially a two-part process. You record audio in WAV format, and then Adobe 
Captivate converts the WAV file into an mp3 file. When files are in WAV format, they have a degree of flexibility. You 
can edit and adjust them “downward,” compressing them into mp3 files uniquely tailored to their playback scenario.

When working with audio, keep your users in mind. If a user is likely to access the Adobe Captivate project by using a 
dial-up modem, use a higher compression/lower sampling rate, such as 56 Kbps. However, if you are distributing the 
project on a CD-ROM, you can use a lower compression/higher sampling rate, such as 144 Kbps. In the best 
development case, experiment to find the optimal balance between sound quality and file size for your users.
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Using Adobe Captivate, you can record an audio file for a single slide, group of slides, or for the entire project. 

Note: For slides with unique audio files, the Timeline of the slide is stretched to meet that of the audio file. However, audio 
files for a project are cut short if they exceed the project Timeline. 

1 In an open project, select Audio > Record to and select one of the options:

Slide Record the audio file for the selected slide.

Slides Record the audio file for a group of slides starting with the selected one. To finish defining the range of slides 
included in the group, enter a slide number in the To field of the Record Audio dialog box.

Background Creates background audio for your project. For details, see Create background audio.

Object Sets audio for a selected object on the slide.

2 In the Audio dialog box, configure the following according to your preferences:SWF PreviewThe recording window 
displays a Preview panel where you can view the project as the audio gets recorded.Continuous PlaySelect this 
option if you want the file to play until the end of all the selected slides or the end of the project.Captions and Slide 
NotesUse these options when you want to record voice-over narration that matches the caption text or slide note 
text. Read aloud the text that you have added to these areas when recording audio. Record AudioClick the icon to 
begin recording audio. Play AudioClick the icon to play the audio file after you have completed the recording.Stop 
AudioClick the icon to stop playing the audio file.Edit tabLets you make the following changes to the audio file:

• Select portions of the audio file and copy them.

• Delete portions of the audio file.

• Insert silence.

3 PodcastExport to podcast to save the file in WAV or mp3 format.Fade In and Fade OutSet a time, in seconds, for 
the audio file to fade in and fade out at the beginning and end of the project.Lower Background Audio Volume On 
Slides With Additional AudioAutomatically reduces the background audio volume on slides that have individual 
audio files assigned, such as voice-over narration.Loop AudioThe background audio file replays continuously.Stop 
Audio At End Of ProjectStops the background audio when the project ends. SettingsClick to open the Audio 
Settings dialog box, which lets you set recording device and audio quality.

The Settings dialog box contains the following options:

Audio Input Devices Specifies the type of device you are using to create audio. The options available in your 
computer are listed in the menu.

Bitrate Select the bitrate at which audio encoding must be performed. Select one of the following options based on 
the audio encoding quality you require:

Constant Bitrate options:

CD Bitrate (128 Kbps) Specifies the amount of audio information (in Kbps) that will be stored per second of a 
recording, which is of CD quality.

Near CD Bitrate (96 Kbps) Specifies the amount of audio information (in Kbps) that will be stored per unit second 
of a recording, which is of a near-CD quality. By default, this option is selected.

FM Bitrate (64 Kbps) Specifies the amount of audio information (in Kbps) that will be stored per second of a 
recording, which is of FM radio quality.

Custom Bitrate Specifies the amount of audio information that will be stored per second of a recording, which is of 
a user-defined quality. You can drag the slider bar to set the required bitrate.
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Calibrate Audio Input Click to display the Calibrate Audio Input dialog box. You are prompted to read a sentence 
into the recording device if you are using a microphone. Adobe Captivate uses the sample recording to detect 
optimal recording sensitivity levels. It is important to calibrate your recording device for optimal sound quality.

Calibrate microphone
If you are recording audio for a project, you must set the microphone or recording device to the correct recording level. 
This process is called calibrating the recording device. Adobe Captivate can detect optimal microphone and recording 
sensitivity levels automatically. 

Note: Adobe Captivate must be able to detect a recording device before trying to calibrate. Check that a microphone or 
recording device using “line in” is connected to your computer properly and is turned on before calibrating.

Calibration can be manual or automatic. See www.adobe.com/go/learn_calibration_en for a comparison of manual and 
automatic calibration.

Manual calibration

1 In an open project, select Audio > Settings.

2 Click Calibrate Input.

3 In the Calibrate Audio Input dialog box, specify a Pre-amplifier value between .1 and 100 and then click OK.

The volume gets multiplied by the value you specify. For example, if you specify 5, volume increases five times 
whereas the value .5 decreases the volume by half.Increase/reduce in multiples.

4 Use the Record and Play buttons to test the pre-amplifier value.

Auto-calibration

1 In an open project, select Audio > Settings.

2 Click Calibrate Input. 

3 In the Calibrate audio input dialog box, click Auto Calibrate.

4 To set the correct recording device level, read the following sentence into the microphone until the message Input 
level OK appears: 

“I am setting my microphone recording level for use with Adobe Captivate.” 

5 When you finish, click OK.

Record audio to slides
If you have a microphone connected to your computer, you can record audio to be included on a slide. You can use 
audio for many types of narration or instruction. 

1 In an open project, select Audio > Record to from the main menu, and select one of the available options: Slide, 
Slides, or Background.

2 To set recording options, click Settings in the Slide Audio dialog box and then make the necessary changes. 

Depending on the type of recording (voice-over, music, and so on) and the desired playback (within an EXE file, 
over the Internet, and so on), you may need to adjust audio settings.

3 (Optional) If you have created text captions or slide notes that can be used as a script, click Captions & Slide Notes 
and then add them to the fields in the Captions and Slide Notes tabs.

http://www.adobe.com/go/learn_calibration_en
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4 You can choose to record narration, system audio, or both (in the patch for subscription and Adobe Software 
Assurance customers only)

• To record narration, click the narration icon ( ), and proceed to step 5.

• To record system audio, ensure that the required audio is running on your computer, and click the system audio 
icon ( ).

5 Click Record Audio icon to begin recording.

6 Speak into the microphone or recording device. Or, if you are using a line-in device (such as a CD) or a system file, 
run the file you want to record.

7 When you finish, click Stop Audio icon. 

The audio is converted to mp3 format.

8 Click Play Audio icon to listen to the recording. 

9 (Optional) If you want to add silence or adjust the volume for the audio file, use the options in the Edit tab to change 
the settings.

10 When you finish, click Save.

Record audio while creating a project
Adobe Captivate lets you record an audio track at the same time you record a new Adobe Captivate project. This can 
be a very efficient way to create a full-featured project quickly.

The following procedure describes how to record audio while creating an Adobe Captivate project about an application.

1 Open the application you want to record. (You must do this before recording.)

2 Prepare your audio recording equipment.

3 Open Adobe Captivate. 

4 Select File > Record New Project.

5 Do the following:

• In the Recording type section, select a recording mode

• Select the window you would like to record

• Customize the other available options.

6 In the recording window, select the type of recording, and choose the type of audio input from the Audio menu.

7 Select System Audio to record any audio originating from your computer speakers (in the patch for subscription and 
Adobe Software Assurance customers only).

After creating the project, you can edit, import, or remove system audio.

Note: This option is disabled on Windows XP as Adobe Captivate does not support recording of system audio on 
Windows XP.

8 Click Record.

If this is the first time you are recording audio, a dialog box appears asking if you would like to test audio levels. Click 
Auto Calibrate or set the pre-amplifier value to calibrate the recording device for optimal recording. Follow the 
instructions and when you finish, click OK.

9 As you record the project, speak into your microphone or recording device to create an audio sound track. For 
example, you can explain the actions you are taking or read the text on captions.
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10 When you finish recording, press the End key (in Windows) or (Cmd + Enter) on Mac OS to stop recording.

The audio files you recorded are assigned to the correct slide and saved as individual mp3 files. You can view the 
files in the Library.

Note: If you need to pause the recording of narration, press the Pause/Break key. To restart project recording, press the 
Pause/Break key again on Windows or Cmd+ F2 on Mac OS.

Record audio for objects
You can record an audio file to use with buttons, highlight boxes, click boxes, or text entry boxes. Recording audio 
requires some basic equipment. 

You can also add existing audio to text entry boxes, captions, slides, slidelets, and so on.

1 Right-click (Windows) or Control-click (Mac OS) the object to which you want to add audio, and select Audio > 
Record to.

2 In the Object Audio dialog box, click the Record icon.

3 When you finish recording, click Stop Audio.

4 To listen to and test the audio file, click Play Audio.

How to preview audio in Adobe Captivate
After you add an audio file, you can preview the audio to test it. 

There are two methods for previewing audio. First, you can preview the entire Adobe Captivate project and listen to the 
audio associated with an object, a slide, or the background. This lets you see exactly where the audio begins and ends 
in the project and enables you to experience the audio as your users will. 

Second, if you need to preview only the audio without hearing it in the context of the project, you can open an object, 
slide, or background audio and play the audio file.

Test object audio
1 On stage, select the object with associated audio.

2 In the Property Inspector (Window > Properties), click Edit Audio in the Audio area.

3 In the Object Audio dialog box, click the Play icon to listen to the audio file.

Test slide audio
1 Select the slide that contains audio.

2 Select Audio > Record.

3 In the Property Inspector (Window > Properties), click Edit Audio in the Audio area.In the Object Audio dialog box, 
click the Play icon to listen to the audio file.

Test background audio
1 In an open project, select Audio > Edit > Background Audio.

2 In the Background Audio dialog box, click the Play Audio icon to listen to the audio file.
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How to insert audio into an Adobe Captivate project
Adobe Captivate lets you add narration, music, step-by-step instructions, or almost any sound to your projects. 

You can use audio in Adobe Captivate projects in a variety of ways. For example, you can do the following, all in the 
same project:

• Add a background track that plays for the duration of the project.

• Add sound to an individual slide.

• Add sound to a specific object, such as a caption, click box, highlight box, or button.

Adobe Captivate lets you record your own audio files (using some simple equipment) or import existing files. You can 
record audio files at the same time you record the project, or you can add an audio file later. Imported files can be in 
WAV or mp3 format. If you add a WAV file to a project, Adobe Captivate automatically converts the WAV file to mp3 
format when you publish the project.

After you add audio to a project, you can adjust the timing of objects to fit the sound file precisely. Adobe Captivate 
also contains features for adding silence to audio files and for normalizing audio for all slides so the sound level is 
consistent.

Adobe Captivate contains a gallery that has buttons, sounds, and animations (in SWF format) for you to use in your 
projects. By default, the gallery is stored in the following location when you install Adobe Captivate: 

C:\Program files\Adobe\Adobe Captivate 6\Gallery (on Windows)

or

/Applications/Adobe Captivate 6/Gallery/Captions (for Mac OS).

You can attach an audio file to a button or click box and have the audio play when the user clicks the button or click 
box instead of when the button or click box is displayed. To do this, create the button or click box and select the Success 

Caption option. Make the Success Caption transparent and do not add any text. Add an audio file to the Success Caption.

Import audio
You can import an audio file to use with slides, buttons, highlight boxes, click boxes, or text entry boxes. You can also 
use the Library to add an audio file that is already in your current project.

1 Select the slide or object to which you want to add audio. 

2 In the Property Inspector (Window > Properties), click Add Audio in the Audio area.

3 In the Slide Audio dialog box, click Import.

Adobe Captivate contains a gallery that has buttons, sounds, and animations (in SWF format) for you to use in your 
projects. By default, the gallery is stored in the following location when you install Adobe Captivate: C:\Program 

Files\Adobe\Adobe Captivate 6\Gallery (on Windows) or /Applications/Adobe Captivate 6/Gallery/Captions (on Mac 
OS).

4 Browse to the audio file you want to add, select the file, and click Open.

5 (Optional) To listen to and test the audio file, click Play Audio.

6 Set other options as necessary.

• To edit the audio file (for example, change volume, add silence, change length, and so on), click Edit Audio in
Audio area.
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• If you want the audio to fade in or fade out, set the number of seconds using the options Fade In and Fade Out
in the audio area.

7 When you finish, click Save.

Add audio from library
You can reuse existing audio files for any slide or object in a project.

1 In an open audio project, click the Library panel and then select the file from the Audio folder.

2 Drag and drop the audio object to the object or slide.

Create background audio
You can create background audio for your projects. The audio plays while the slides of your project are shown. 
Background audio can be music, sound effects, or almost any kind of sound you can import or record.

You can use background audio together with individual slide audio for a truly professional effect. Adobe Captivate 
provides an option to lower the volume of background audio when a slide with audio assigned plays. For example, you 
can import a music file and set it to loop continuously as background audio. In that same project, you can record voice-
over narration for individual slides, and when the voice-over audio plays, the music volume is lowered.

1 In an open project, do one of the following:

• Select Audio > Import to > Background to import an existing audio file by navigating to the file, selecting the file, 
and clicking Open.

If you want to use an audio file that is already in your project, click Select Audio From Library.

• Click Record to > Background and follow the instructions to record the background audio.

2 (Optional) Click Play Audio to listen to the audio file.

3 Select from the following options:

Fade In and Fade Out Lets you set a time, in seconds, for the audio file to fade in and fade out at the beginning and 
end of the project.

Loop Audio The background audio file replays continuously.

Stop audio at end of project Stops the background audio when the project ends. 

Adjust background audio volume on slides with audio Use the slider to adjust the background audio volume on 
slides that have individual audio files assigned, such as voice-over narration.

Use a custom keyboard tap sound
Adobe Captivate includes a feature that records a keyboard tap sound whenever you press keys on the keyboard while 
recording a project. You can include or exclude the tap sounds. You can also create a custom keyboard tap sound to use.

1 Create a new sound for keystrokes, or use an existing mp3 file (for example, one of the Windows sound files.)

2 Name the new sound file KeyClick.mp3.

3 Save the file and note the location to which the file is saved.

4 Using Windows Explorer, browse to the Adobe Captivate sound effects folder. (The default location is \\Program 
Files\Adobe\Adobe Captivate 6\Gallery\SoundEffects (on Windows) or /Applications/Adobe Captivate 
6/Gallery/SoundEffects (on Mac OS).
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5 Locate the file named KeyClick.mp3. This is the Adobe Captivate default keystroke sound file.

Note: Before overwriting the file, you may want to copy and place the original KeyClick.mp3 file in a backup folder so 
it can be used again if necessary.

6 Copy the new keyboard tap sound from the location in step 3 above, and paste it into the Adobe Captivate sound 
effects folder. 

7 Select the option Hear Keyboard tap sounds (Preferences > Recording > Settings).

How to export audio from Adobe Captivate

Export audio from slide
1 In an open project, select Audio > Audio Management.

2 Scroll down and click the slide that contains the audio file you want to export.

3 If you want to export mp3 files, select Include MP3 files in export.

4 Click Export.

5 Navigate to the destination folder you want and click OK.

Export audio from project
You can export audio files that have been inserted or recorded. The exported audio files can be used for podcasting.

1 Select Audio > Edit and then select Project.

2 In the Slides Audio dialog box, click Podcast.

3 Save the file in WAV or MP3 format.

How to edit audio files with Adobe Captivate

Edit audio files
You can edit the audio files in your Adobe Captivate project at any time. Using the Edit Audio dialog box, you can listen 
to an audio file, insert silence, adjust volume, and change numerous other options.

1 Select Audio > Edit and then choose Object, Slide, Slides, Project, or Background depending on your requirement.

Note: The Edit option is enabled if a question slide or a project slide contains an audio file. It is disabled for question 
pools and random question slides.
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2 If you are editing slide audio and the slide contains both narration and system audio, then the Edit tab in the Slide 
Audio dialog box displays both the audio waveforms (in the patch for subscription and Adobe Software Assurance 
customers only).

• To edit only narration audio, click the system audio icon ( ). Only the narration audio waveform is displayed 
and you can continue editing the audio.

• To edit only system audio, click the narration icon ( ). Only system audio waveform is displayed and you can
continue editing the audio.

• To perform editing operations simultaneously on both types of audio, click both narration and system audio
icons. Both the audio waveforms are displayed. When you select a portion of one audio waveform, the portion
of the other audio waveform corresponding to the selected time, also gets selected.

At any point in time, if you want to exclude an audio waveform from editing, click the Remove Selection icon ( ) 
corresponding to the waveform.

3 Make any necessary edits in the Slide Audio dialog box.

You can cut and paste sections of the audio file, insert periods of silence to lengthen the audio file, adjust volume, 
import a different audio file, and use more options. 

Cut Selection Click to cut the selected portion of the audio file.

Copy Selection Click to copy the selected portion of the audio file.

Paste Selection Click to paste information from the clipboard. (For example, if you select a section of the audio file, 
and then click the Cut Selection or Copy Selection button, the selected audio is placed on the clipboard. You can 
then use the Paste Selection feature to place the audio located on the clipboard back into any location within the 
audio file.)

Delete Selection Click to remove the selected portion of the audio file. 

Undo Click to undo the last action taken.

Redo Click to redo the last action taken.

Insert Silence Select the portion of the audio file where you want to insert silence, and click Insert Silence. Choose 
from one of the following options: Start Of AudioAdds silence to the beginning of the audio file.End Of AudioAdds 
silence to the end of the audio file.Playhead PositionThis option is available only when you have not selected a 
portion of the audio file. The silence is inserted at the playhead position. Use this option when you want to insert 
an extremely brief period of silence.
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Adjust Volume Click to increase or decrease the sound level of the audio file. There is also an option to fine-tune 
quieter portions of the audio file.

Normalize Select this option to have Adobe Captivate adjust the sound volume automatically. Normalizing audio 
helps keep the sound level consistent between slides.

Dynamics Select this option to amplify quiet sections of the audio to help compensate for variations in audio 
volume.

Ratio Specifies the maximum amplification that will be used. The default setting of 2.0 sets the quietest sections of 
the audio to be amplified by a factor of 2. A higher setting can improve projects with large differences between quiet 
and loud sections, but can also amplify background noise.

Threshold Controls the amplification of background noise. Anything quieter than the noise threshold is not 
amplified. If background noise is amplified too much, setting a higher noise threshold may help solve the problem. 
Note that the Dynamics option does not work well with high noise levels.

Zoom In and Zoom Out Use the slider to enlarge or shrink the waveform.

Settings Click to set various options such as recording device, audio quality level, and recording device calibration.

Podcast Export the audio file as a WAV or mp3. You can later use these files for podcasting. Podcasting refers to 
distributing files over the Internet through web feeds to portable media players, and computers.

Waveform Displays the audio file graphically. The waveform is a visual representation of the audio file.

Record Audio  Click to begin recording audio. (To record, you need a microphone.)

Stop Click to stop playing the audio file.

Play Click to play the audio file.

Status Displays the status of the audio file as playing, ready, and so on.

Playhead Displays the selected location, in seconds, within the audio file. For example, if you are working with an 
audio file that is 10 seconds long and you click in the middle of the file, this playhead area displays approximately 
00.05.00, or 5 seconds. 

Duration Displays the total amount of time it takes for the audio file to play.

Selected Displays the total amount of time selected. For example, suppose you have an audio file that is 20 seconds 
long. If you click at the beginning of the file and drag to the middle, you will have selected approximately a 10-second 
span of the file.

Scale Displays the scale at which the waveform is displayed. (To change the scale, use the Zoom slider).

Library Displays the Select Audio From Library dialog box, where you can browse to a new audio file and import it. 

Click Select Audio From Library to import an audio file from the project’s Library.

4 When you finish editing the audio file, click Save.

Edit audio timing
Adobe Captivate lets you edit the timing of audio files after you record or import them. Having control over the timing 
of audio files gives you the ability to use audio files of different lengths and incorporate them smoothly into projects. 

After you record or import an audio file, the file appears as a waveform in the Slide Audio dialog box. If your project 
contains multiple audio files, you can see which audio files are assigned to specific slides.

 Select Audio > Edit and then choose Slide, Slides, Project or Background (depending on your requirement) and then 
use the Edit tab.
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Note: Edit is enabled if a question slide or a project slide contains an audio file. It is disabled for question pools and random 
question slides.

Audio files in the Adobe Captivate project are displayed as waveforms. Slide numbers are shown along the top of the 
waveform so you can see exactly how the audio files are currently distributed across the slides. 

• To change how audio files are distributed across slides, click a slide divider and move it to the left or right. The
waveform remains static, but you change where the audio file begins to play within the Adobe Captivate project.
This option is particularly useful if you have a long audio file and need to experiment with assigning the file to one
slide or having it play over multiple slides.

• To listen to audio, click a location within the waveform and then click Play Audio. The audio plays from the location
you selected to the end of all the audio in the project. (You can stop the playback at any time by clicking Stop.)

• To zoom in on a particular area of the waveform, click in the waveform and then drag the zoom slider bar.

• To cut or copy and paste audio, select a section of an audio file directly in the waveform, click Cut Selection or Copy 
Selection, click in a different location on the waveform, and click Paste Selection.

• To delete audio, select a section of an audio file directly in the waveform and click Delete.

• You can insert a silent period within an audio file. If you want the silent period to begin in a specific location within
an audio file, click the location directly in the waveform. Click Insert silence. Type in the length of the silent period
you want to add and then select from the pop-up menu a location for the silent period: the location you clicked in
the waveform, the beginning of audio, or the end of audio.

• To adjust the sound level of audio files, click Adjust Volume. Use the slider bar to increase or decrease the volume
and select audio processing options.

• To set recording device and audio quality options, click Settings.

• To add a new audio file, click a location within the waveform, click Library, navigate to a file, and click Open. The
audio file is imported directly into the Adobe Captivate project in the location you specified.

Add silence to an audio file
You can add a period of silence to any audio file that is part of an Adobe Captivate project. This feature is particularly 
useful if you have imported an audio file and need to synchronize the audio with objects and slides. By adding silent 
periods, you can make the existing audio file work in an Adobe Captivate project without having to edit the audio 
extensively.

1 Select Audio > Edit and then choose Slide, Slides, Project or Background (depending on your requirement) and then 
go to the Edit tab.

2 (As per your requirement) Add silence to the beginning of the audio file, to the end, or to a specific location within 
the audio file.

If you want to add silence within the file, click the exact location directly on the waveform. 

Note: The Playhead and Selected information boxes near the bottom of the dialog box can help you choose a precise 
location in the audio file. For example, if you want to add a silent period four seconds into the audio file, click the 
waveform until the Playhead information box displays a number close to four seconds (that is, 00:04.00).

3 Click Insert Silence. 
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4 Select the portion of the audio file where you want to insert silence, and click Insert Silence. Start Of AudioAdds 
silence to the beginning of the audio file.End Of AudioAdds silence to the end of the audio file.Playhead 
PositionThis option is available only when you have not selected a portion of the audio file. The silence is inserted 
at the playhead position. Use this option when you want to insert an extremely brief period of silence.Note: When 
you select a part of an audio file, and then click Insert Silence, the selection is replaced with silence.

5 Click Save.

The silent period is added to the audio file and you can see the silent period in the waveform. The audio file with 
added silence is saved under a new file name.

6 To test the audio file with the silent period added, click the audio icon. 

If you find that you frequently want to add silence at the same position and of the same duration, press S to add it 
without using the Insert Silence dialog box.

Edit audio using Adobe Audition
You can use Adobe Audition to edit audio when you want to go beyond the audio editing options available in Adobe 
Captivate. For example, to apply filters or remove noise, you need an advanced audio editor such as Adobe Audition. 
You can either edit the audio files from slides or batch process by opening multiple files in Adobe Audition using the 
Library panel.

The changes reflect in Adobe Captivate library and the associated slides where the audio files are being used. The saved 
files are reimported to Adobe Captivate with the slide associations intact. 

Note: This feature is available only in Adobe Captivate that is installed as a part of Adobe eLearning Suite.

Editing slide audio
Editing slide audio is helpful when you apply filters that do not affect audio timing. 

Note: The following steps are also applicable for editing background audio.

1 Select the slides with the audio files (that you want to edit).

2 Select Audio and then slide, slides, or project depending on your requirement.

The Slide Audio dialog box appears.

3 In the Edit tab, click Edit With Adobe Audition:

4 Read the instructions and then proceed.

5 Edit the slide audio in Adobe Audition and then save.

6 In the Adobe Captivate prompt, click OK.

Note: If you have edited slide markers in Adobe Audition, the prompt displays a check box to let you import the marker 
changes as well.

When you edit the slide audio file in Adobe Audition:

• If the audio file applies to multiple slides, ensure that you do not modify the audio duration.

• If the audio file applies only to a slide, you can increase the audio duration. If the audio duration exceeds the slide
duration, on reimport, Adobe Captivate increases the slide duration to accommodate the audio. But if the audio is
attached to an item, duration of item is not increased even if the reimported item audio has a longer duration.
However, Adobe Captivate prompts you to increase the display time when you click OK or Apply for the item in the 
Properties dialog box.
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When you edit audio using Adobe Audition, any change in the length of the audio clip, made by moving the slide 
markers, can be imported to Adobe Captivate. However, when you rename, delete, or change the order of slide markers, 
such changes cannot be imported back. For example, if you move the Slide3 marker before Slide2, you are prompted to 
ignore or cancel the edits, or reposition the markers.

Editing audio files from library
1 In the Adobe Captivate library, select the audio files that you want to edit.

2 Right-click (Windows) or Control-click (Mac OS), and then click Edit With Adobe Audition.

Adobe Audition launches. The files you selected are imported and are available for editing.

Note: If this option is not available, select Edit With and choose an appropriate program.

3 Edit the files in Adobe Audition. 

4 Select Save All.

While you edit the audio files in Adobe Audition, you can continue working on your Adobe Captivate project. 

If you modify the exported audio files in Adobe Captivate, they are overridden by the files edited and reimported from 
Adobe Audition. But, if you delete or break the audio files into clips in Adobe Captivate, then those files are not 
reimported.

Add closed captions to an audio file
You can improve the accessibility of your project by adding closed captioning. Closed captioning lets you create 
transcripts for audio files associated with the slides in your project. When an audio file is played for a slide, the 
transcripts are displayed, thus aiding hearing-impaired users.

The option that enables closed captioning is available in the Show Playback Control section of the Skin Editor. For more 
information, see Add and convert slide notes to audio files with Adobe Captivate.

Note: You cannot add closed captions to system audio (available in the patch for subscription and upgrade plan only).

1 Select Audio > Audio Management.

2 Select the slide that contains an audio file to which you want to add a closed caption from the list and then click the 
Closed Caption button .

The following options are available in the Closed Captioning tab of the Slide Audio dialog box:

Add Closed Caption Click the ‘+’ icon to add a caption. A new row appears in the caption window below. Type the 
closed caption text in the row.

Delete Close Caption Click the ‘-’ icon to delete a selected caption row.

Zoom In and Zoom Out Use the slider to increase or decrease magnification of the waveform.

Playbar Use these controls to test the audio file.

Caption & Slide Notes Window Each slide note appears as a row in this window. Click any row to edit or delete the 
text. You can also add Captions to include for your reference.

3 If you want to test the audio file, click the Play button.

4 Click the specific spot in the waveform where you want to add a caption and click ‘+’. 

A new caption row appears with the start time you selected on the waveform.

5 Enter the caption you want to attach to the audio file.



267
Audio

Last updated 10/10/2016

6 To add another row to the caption for the audio file, click add. To remove a row from the caption for the audio file, 
click “-.”

Note: For more precision, you can drag the end and start time markers of your caption if you want to manually adjust 
the timing of each caption.

7 When you have added all the rows you want, click Save.

In the Closed Captioning dialog box, you can add closed captions while the audio is playing by clicking “+’”or by 
pressing Alt+A.

Note: Multiple closed captions must be contiguous. If you do not want a closed caption for an intermediate duration, 
add a blank closed caption for that duration.

Delete audio from a slide
 In an open project, do one of the following. 

• On Filmstrip (Window > Filmstrip), select a slide and click the audio symbol in the lower-right corner of the slide 
and then select Remove.

• Select the slide that contains the audio and then click Remove Audio in the Audio area of the Property Inspector 
(Window > Properties).

Note: Deleting audio using the Property Inspector deletes both narration and system audio (available in the patch for 
subscription and Adobe Software Assurance customers only). To delete any one of the audio, right-click the audio 
waveform in the Timeline and select Remove.

Delete background audio
 In an open project, select Audio > Remove > Background.
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Chapter 10: Video

Multi-slide synchronized video
You can insert video files of all popular formats to the slides in your project. After importing a pre-recorded video, you 
can decide the part of the video that must be played on each slide in sync with the contents.

Note: You cannot add synchronized videos to locked slides, random slides, recording slide placeholder, quiz placeholder 
slides, slides with synchronized video, or slide video placeholder.

Insert synchronized videos
1 Select Video > Insert Video > Multi-slide synchronized video.

2 Specify the file path or the URL of the video.

3 Click the type of the video in the Video Type list.

Progressive Download Video Choose this option if the video is hosted on any internal server, web server, or Adobe 
Media Server (AMS).

Streaming Choose this option if you want to use RTMP streaming. The video must be hosted on AMS.

Flash Video Streaming Service Choose this option if the video is hosted on AMS or any other web server and the 
service provider is one of the Adobe partners. With this option, you can use either RTMP or HTTP streaming.

Note: If your Adobe Captivate project contains FLV/F4V files, ensure that the files contain metadata for the video player 
to function correctly. FLV/F4V files created with Flash Communication Server 1.5.2, FLV Exporter version 1.2, and 
Sorenson Squeeze® 4.0 automatically contain metadata. Sorenson Squeeze 4.0 is included with the Flash Video Kit. If 
you import an FLV file that does not have any metadata, the file will not play correctly in your project.

4 Click Stage or TOC in the Show Video On list based on where you require the video.

5 To insert the video on the slide selected in the Filmstrip, click Modify Slide Duration To Accomodate The Video.

To distribute the video among specific slides, click Distribute Across Slides and then specify the slide numbers.

You can insert the same video to another slide or a group of slides in the same project. When a synchronized video is 
imported into multiple slides, the association between the video and the slides (synchronized video group) is retained 
internally. Any edits that are made to the video timing are updated in all the slides of the synchronized video group.

Note: While placing videos from Adobe Bridge, use the options in the Windows > Progress Indicator panel to insert the 
video into the slide on Stage or the library.

Inserting non-Flash video file formats
Adobe Captivate supports insertion of FLV/F4V files directly as synchronized videos. But to insert non-Flash video 
formats, you need Adobe Media Encoder (AME) to convert the files to FLV/F4V.

1 Select Video > Insert Video > Multi-slide Synchronized Video.

2 Select the file and then click OK.

http://www.adobe.com/products/flashmediaserver/fvss/
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3 In the Video dialog box, click Yes, and then choose a location to save the file in FLV format.

The status of the file conversion is indicated in the Windows > Progress Indicator panel. 

4 After the files are converted, add them to the project by choosing one of the following options in the Progress 
Indicator panel, and clicking Go:

• Import as synchronized video to add the video to the slide on Stage.

• Import to Library to add the video to the project’s library and use it whenever required.

Note: You cannot place non-FLV or non-F4V files from Adobe Bridge. However, you can drag-and-drop the files from 
Adobe Bridge to the slide on Stage in Adobe Captivate.

Edit video timing
The Edit Video dialog box (Video > Edit Video Timing) lets you edit the video timing:

• Edit and preview: Use the edit tab to edit the timing and preview the synchronized video while editing. You can
decide the part of video that must play in each slide. When you edit the timing, it applies only to that particular
synchronized video group.

Play the preview, pause at the point where you want to adjust the video, and then adjust the marker (drag left or
right). Zooming the timeline makes the editing of the video easier. To help you synchronize the slide and the video, 
the slide and video duration are displayed below the timeline.

When you move the marker, a mismatch can occur between the video and the slide duration (for the slide with the
reduced video duration). You can synchronize the duration using the Timeline. Unused video portions outside the
start and end markers can be assigned to adjacent slides (if any in the project). To do this, use and .

You can also preview the synchronized video from library and on stage (using the Edit Video Timing dialog box).On 
stage preview helps you decide the sequence of appearance of various objects as the video plays.

Note: On stage, you can preview only the slides that contain the synchronized video.

• Add a beginning slide and an end slide: For effective control over video distribution, you can, if necessary add
slides before the first slide or after the last slide in your project. This is useful if unused video is present in the
beginning or end. The synchronized video is distributed across these slides also.

To do this, use the (  and ).

• Closed Captioning: If your video has audio content, use the Closed Captioning tab to enter captions for hearing-
impaired users. The text is displayed along with the audio when the slide is played.

Synchronizing objects with video
Using the Timeline, play the video, pause it where you want the object to appear, and move the object to the playhead 
position or insert a new one.

Note: When you play a slide, an error can occur occasionally at the beginning or the end of the video. The video starts or 
ends slightly earlier or after the intended time. This behavior does not exist when the entire project is played. 

Changing the video proportion
You cannot change the proportion of the video, so that the quality is intact.
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Managing synchronized videos
The Video Management dialog box (Video > Video Management) provides the following details: 

• the synchronized videos that you have inserted

• the slide and slide groups to which they belong

• the video type

• URL of the hosted video file

• the placement (if on TOC or stage)

Use this dialog box to:

• Specify video type: The type of video that you insert. For the description of the video types, see the General section 
in Properties of event videos.

• Specify placement: If TOC or Stage. Depending on the placement, an icon appears at the lower-right corner of the 
slide on Filmstrip and on the Timeline:

• if on TOC

• if on stage

You might place the video on TOC in talking heads scenarios where the focus is on objects in the slide (such as text 
or a Flash video). Placing video on TOC, helps you avoid the distraction that playing a synchronized video on stage 
can cause and viewers losing focus.

When you have the synchronized video play on TOC, ensure that you select Show TOC (Project > Table of 
Contents) so that the TOC also is visible while you play the project. 

• Launch Edit Video timing dialog box: Click to edit video timing. For more information on editing the video
timing, see Edit video timing.

• Delete: Click to delete synchronized video.

Updating synchronized videos
1 Modify the source file of the video as required.

2 Open the project in which you want to update the video.

3 In the Media > Video folder of the Library panel, right-click (Windows) or Control-click (Mac) the name of the 
video, and click Update.

The changes reflect on all slides that use the video.

Using audio
You cannot associate additional audio to a synchronized video. Therefore, Adobe recommends that you use audio in 
file and not audio as object ensure proper synchronization.

Setting timing
 In the Timing area of the Property Inspector (Window > Properties), specify the seconds after which the video must 

appear on the specific slide.
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Setting transition
 In the Transition area of the Property Inspector (Window > Properties), specify the transition effects for the video. 

Note: Transition effects do not apply to synchronized videos that are used in the TOC.

Setting the size and position of synchronized videos
1 In the Position & Size area of the Property Inspector (Window > Properties), specify the values for size and position.

Note: Applying arbitrary sizes to video objects degrade the quality of the video on published project.

2 Click to apply the values to all the slides in the synchronized video group. Synchronized video group consists of 
slides into which you imported the synchronized video simultaneously.

Note: Apply to all applies the size and position values only to the group of slides into which the synchronized video was 
imported. These values do not apply to other instances of the video in the project (other synchronized video groups).

Best practices to use synchronized videos effectively
• Use synchronized videos when you want the video to play in synchronisation with the slide contents. For other

purposes, use the FLV file or F4V object, where user gets to control the video (for example, play or pause the video).

• Ensure that the videos have sufficient keyframes. The recommended keyframe interval is at least one keyframe in
every 2 secs.

You can use Adobe Media Encoder (AME) to increase the keyframe interval if necessary. For a 30-fps video,
configure the keyframe-distance to be 60 (frames) in AME (or any other tool of your preference).

• Ensure that the videos have optimal bit-rates so that viewers’ experience is good. Else, many ‘loading...’ messages are 
displayed to the users.

Decide the bit-rates based on the server’s as well as your target users’ bandwidth. For information on calculating bit-
rates, see the article at www.adobe.com/devnet/flash/apps/flv_bitrate_calculator.

• Import video from your local machine rather than from a shared network location. Large videos imported directly
from network locations cause excessive delays and occasional system instability.

• Ensure that the minimum duration for a portion of video on a slide (per synchronized video) is 3 seconds. This
duration is necessary to ensure that at least a couple of keyframes are assigned per slide.

• Ensure that the maximum duration of a synchronized video is 999 seconds (maximum slide duration). If the video
is longer than this duration, distribute it among multiple slides. Videos longer than 999 seconds can cause system
instability.

• Video dimensions:

• Ensure that the video object dimension is the same as that of the original video for optimal quality.

• Do not change the aspect ratio of the video even if you cannot maintain equal dimensions for the video object
and original video. Otherwise, the video loses quality.

• Keep the dimensions of a video that you want to include in the TOC as: Height 144 and Width 196.

Synchronizing video with the project
1 Decide which of the slides in the project need synchronized videos. Set optimal duration for such slides so that 

synchronization is more effective.

2 Arrange the slides in the order in which they must appear in the video. Reordering the slides after importing the 
video is not recommended.

http://www.adobe.com/devnet/flash/apps/flv_bitrate_calculator/
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3 Import the video with distribution to span across slides.

4 Use the Edit Video Timing dialog box to specify which part of the video plays on which slide. For more information 
see Edit video timing.

5 Specify which object must appear at what part of the video clip. For more information, see Synchronizing objects 
with video.

Publishing projects with synchronized videos
By default, the published SWF files with synchronized videos are optimized for progressive downloads of videos. You 
can host the publish folder with the SWF file on a web server without changing any settings.

To host the videos on a server other than the one on which the SWF file exists (for example, a video server) or if you 
want to use streaming or Flash Video Streaming Service (FVSS):

1 Upload the videos to the server.

2 In the Video Management dialog box (Video > Video Management), specify the path of the video on the server.

If streaming, specify the rtmp path. If you are using FVSS, specify the path given by the FVSS provider.

Working with event videos in Adobe Captivate

Properties of event videos
Set the properties for event videos using its Property Inspector (Window > Properties).

Video object
Name Enter a unique name for the object. You can use this name when defining the visibility conditions for the object. 

Visible Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the 
Show option. For more information, see Controlling the visibility of objects .

Accessibility Click to add accessible text to the object. For details, see Customize accessibility text for objects

General
Video Type The type of video that you want to insert:

Progressive Download Video Choose this option if the video is hosted on any internal server, web server, or Adobe 
Media Server (AMS).

Streaming Video Choose this option if you want to use RTMP streaming. The video must be hosted on AMS.

Flash Video Streaming Service Choose this option if the video is hosted on AMS or any other web server and the 
service provider is one of the Adobe partners. With this option, you can use either RTMP or HTTP streaming.

Note: If your Adobe Captivate project contains video files, ensure that the files contain metadata for the video player to 
function correctly. Video files created with Flash Communication Server 1.5.2, FLV Exporter version 1.2, and Sorenson 
Squeeze® 4.0 automatically contain metadata. Sorenson Squeeze 4.0 is included with the Flash Video Kit. If you import an 
FLV file that does not have any metadata, the file will not play correctly in your project.

File Link (appears only when the selected video type is Progressive Download Video) The absolute or relative path to 
the video file.

http://helpx.adobe.com/en/captivate/using/controlling-visibility-objects.html#controlling_the_visibility_of_objects
http://www.adobe.com/products/flashmediaserver/fvss/
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Browse (appears only when the selected video type is Progressive Download Video) Click to navigate to the video file.

Server URI (appears only when the selected video type is Streaming Video) The server name, application name, and 
instance name.

Stream Name (appears only when the selected video type is Streaming Video) The stream name.

URL (appears only when the selected video type is Flash Video Streaming Services) The direct file link provided by 
your Flash Video Streaming Service.

Detect Size Displays the existing size of the inserted video.

Live Video Feed (appears only when the selected video type is Streaming Video) Select this option to insert a live 
video feed.

Auto Play The video begins playing automatically as soon as it appears on the slide.

Auto Rewind The video automatically rewinds to the start position after it completes playing.

Buffer Time (appears only when the selected video type is Streaming Video or Flash Video Streaming Service) Enter 
the amount (time) of video that must be loaded before the video plays in the Adobe Captivate project. (The length of 
actual time it takes to stream video varies depending on the user’s bandwidth.)

Skin The skin (playbar) for the inserted video. A preview of the skin you select appears directly below the Skin menu.

Shadow and reflection
Shadow Select the check box to apply shadow to the video. Choose one of the presets. You can customize a preset by 
clicking Custom.

Direction Select the direction: inner or outer. The preview of the selected direction is displayed on stage. 

Color click to select a color for the shadow. Specify the alpha for the color, in percentage, in the adjacent field.

Blur Specify a value, in pixels, for the blur of the shadow.

Angle Specify the angle for the shadow. 

Distance specify the distance, in pixels, at which the shadow must be displayed.

Reflection Select the check box to add reflection to the video. Choose one of the presets.

Timing
Display For Specifies the time for which the video file is displayed on the slide.

Specific Time Play the video file for a specified time interval.

Rest Of Slide Play the video file for the duration of the slide.

Rest Of Project Play the video file for the duration of the project.

Duration Of File Play the video file until its completion.

Appear After The time after which the video file appears on the slide after it starts playing.

Loop (option disabled if you selected Rest Of Slide or Duration Of Video from the Display For menu) Select this option 
if you want the video to play continuously.

Pause Slide Till End Of Video (option enabled only if you selected Rest Of Slide from the Display For menu) Select this 
option to pause the slide that contains the video until the video has finished playing. This option is enabled only when 
you select Rest Of Slide in the Display For menu.
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Transition
Effect Specify a transition effect for the video file. You can make the video file fade in during its entry, and fade out 
during its exit.

In [#] Seconds Specifies the amount of time for the video file to fully fade into view.

Out [#] Seconds Specifies the amount of time for the video file to completely disappear from view.

Add a video file
Note: Only FLV/F4V files with metadata play in Adobe Captivate projects. If the inserted file does not have metadata, use 
third-party software like FLVMDI to add metadata to the file.

1 In an open project, select Video > Insert Video > Event Video.

2 In the Insert Video dialog box, specify the location of the video file and then click OK.

(Cp 7) In HTML5 output files, the event videos are displayed with a playbar.

Change video quality
In general, color is rendered correctly in Adobe Captivate projects. However, sometimes colors are rendered 
inaccurately, such as when the color scheme varies radically between slides. 

You can fix most of these problems by changing the video quality of the slide. Adobe Captivate provides four levels of 
video quality, even though only the Low option is suggested for most uses.

1 In an open project, select the slide containing the colors you want to correct. 

2 In the Property Inspector (Window > Properties), choose one of the following video options:

Low  The default format for slides. Low is the most efficient choice for most screenshots because it uses 256 
optimized colors.

Optimized This option gives you the highest JPEG quality possible.

JPEG This option is best used when the slide contains a photograph. You can change the quality of JPEG images on 
the Project Preferences dialog box.

High Compared to the Low format of 256 colors, this format uses 16 million colors for the slides. Use this option 
only if the Standard and Optimized options do not offer the correct color depth. This option increases file size 
substantially.

Note: Selecting the JPEG, High Quality, or Optimized format may increase the file size and the time it takes to download 
your project. Use a format other than Standard only when necessary and appropriate.

More Help topics 
Set audio for noninteractive objects

Fix size and position of noninteractive objects

Differences between events and synchronized videos in 
Adobe Captivate
The following scenarios can help you decide the option you must choose:

http://helpx.adobe.com/en/captivate/using/set-audio-noninteractive-objects.html#set_audio_for_noninteractive_objects
http://helpx.adobe.com/en/captivate/using/fix-size-position-noninteractive-objects.html#fix_size_and_position_of_noninteractive_objects
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Scenario: On-demand demonstration

You have to play a video (probably on user interaction) in a slide, for example an on-demand demonstration.

In this case, you can use the event video option. 

Scenario: Talking Heads

A presenter describes the contents on the slide. In such talking heads scenarios, multi-slide synchronized video is the 
effective option. 

The following table shows the differences between the two so that you can decide which option to use:

Event video Multi-slide synchronized video

May not be in sync with the slide Plays in sync with the slide

Can be placed only on stage Can be placed either on stage or TOC

Does not get added to the Library Gets added to the library.

You can preview the video on both slides and in the library.

You can replace or update the file from the library.

Multiple videos can be added to a slide Only one video can be added to multiple slides

Does not support closed captioning Supports closed captioning

Users can play, pause, rewind, or forward the video using the playback 
controls in the skin. 

Users cannot control the slide video. The video plays based on how 
you have synchronized it with the project.
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Chapter 11: Widgets

Creating learning interactions in Adobe Captivate

Updated interactions in Captivate 8.0.1
In Adobe Captivate 8.0.1, the following interactions have been updated to provide better user experience on mobile 
devices:

• Accordion

• Timeline

• Process Tabs

• Glossary

• Process Circle

• Circle Matrix

• Pyramid Matrix

• Pyramid Stack

• Certificate

• Word Search

• Checkbox

• Radio Button

In responsive projects, these interactions autoscale themselves to align for all the views with a fixed ratio. Ensure you 
cover the whole slide when you use these interactions except for Checkbox and Radio Button. Set the top and left 
position properties of slide to 0 and 0, and height and width of object size to 100% and 100% respectively. Users can 
experience seamless alignment of interactions in each view. In Certificate and Word Search interactions, pinch & zoom 
features have been added. Mobile view of Glossary interaction has been enhanced. 

Add learning interactions
Learning interactions enable you to provide interactivity to your Adobe Captivate projects without any effort in 
programming. In Adobe Captivate you can see a wide variety of statically designed interactions. There are several types 
of interactive experiences that a user come across in e learning modules. By inserting these learning interactions in your 
Adobe Captivate projects and adding content around it, you can produce most of the commonly used elearning 
interactive experiences to engage your user.

Adobe Captivate 8 introduces a functionality to call variables from Check Box, DropDown, Radio Button and Scrolling 
Text interactions and dynamically control the interaction properties from your slides.
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Refer Using Adobe Captivate 8's new learning interactionsto learn the latest interactions introduced in Adobe Captiave 
8. 

To insert learning interactions to your slides: 

1 From Toolbar, click Interactions > Learning Interactions.

Select Interaction dialog appears.

2 Click the type of interaction you want to insert in the Select Interaction dialog box, and then click Insert.

Note: You may not find themes feature for all the interactions. The following step on Themes is applicable for 
interactions with themes. 

3 Choose a Theme from the Themes list. Click Custom to customize the selected theme. 

Note: Buttons have three states: Up, Over, and Active. Up is the state when users have not clicked the button. Over is 
the state when users hover their mouse over the buttons. Active state is when users click the button.You have an option 
to choose either default color settings or theme colors settings for your screens. In either of these settings, you can 
customize the color properties of screen elements like background, top banner color and so on. Your customized settings 
will be saved and you can go back to these settings by clicking Customize in Color settings. 
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4 Double-click the button text and the button content area to type your text. Click the + icon to add more buttons and 
click OK. 

Note: To edit the theme or the content in the widget after inserting, double-click the widget on stage. Adobe Captivate 
lets you to resize the learning interactions. Your interaction is inserted in to the slide now. To edit the settings for the 
interaction, double click the interaction.

Features of learning interactions
You can find detailed description of each learning interaction in the following table: 

Note: For some interactions variable provision is available. You can use these variables to store the results and use them in 
your course slides. Variable controlled interactions enable users to call variables and dynamically control interaction 
properties from slides. 

Interaction name  Purpose Variable provision Variable controlled? Features

Accordion Enables you to provide 
information in the form of 
clickable buttons, audio 
and images. 

No No You can use this 
interaction in content 
heavy slides in the form of 
collapsible and 
expandable content, using 
buttons. 

Tabs Used to demonstrate 
content in multiple tabs

No No Enables to spread the 
content across multiple 
tabs instead of cluttering 
in one slide. 

Process Circle Enables you to define any 
business process or 
procedure for learners. 

No No Clicking elements on 
process circle shows a 
panel at which you can 
provide descriptions for 
each of those elements. 

Pyramid Stack Similar to process circle 
except that you can put 
elements in hierarchy 
based on importance. 

No No Clicking elements on 
pyramid stack shows a 
panel at which you can 
provide descriptions for 
each of those elements.

Timeline Enables you to express 
data varied over a time 
sequence. 

No No Clicking button labels on 
time sequence arrow 
shows up the content in 
the panel. You can change 
appearance of all these 
buttons using 
Buttons>Color in 
configure interaction 
dialog. 

Circle Matrix Similar to process circle 
except that it enables you 
to show data in a more 
complex form

No No Clicking numbered 
elements in the circle 
shows up content in side 
tabs.

Pyramid Matrix Similar to Pyramid Stack 
except that it enables you 
to use a complex 
hierarchical structure

No No Clicking label elements on 
pyramid matrix shows a 
side panel at which you 
can provide descriptions 
for each of those elements.
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Glossary Enables learners to view 
unfamiliar terms from 
inside a course. 

No No Modify themes and color 
schemes. You can import 
an xml file with a set of 
pre-defined glossary 
terms. Refer to Sample 
filesfile. 

Certificate Enables you insert 
certificates in your courses

Yes No You can edit default 
variables and add other 
variables.

Word Search Game based interaction No No Allows you to provide 
clues to users to search 
words. Users can choose 
first and last letters of the 
words based on clues 
within a stipulated 
number of attempts. 

Catch AlphaNums Accelerometer based 
interaction. Objective of 
this game is to catch the 
missing alphabets or 
numbers with basket, to 
make words for questions, 
within the stipulated time 
and lifeline chances.

Yes No Refer Using Adobe 
Captivate 8's new learning 
interactionsfor detailed 
usage instructions. 

Checkbox Similar to radio button 
interaction except that 
users can choose multiple 
answers. 

Yes Yes Multiple variables are 
available in this interaction 
for each checkbox item. 

Timer Handy to use this timer 
interaction in your slides 
to jump to other slides 
based on time out feature. 

Yes No Follow the instructions in 
configure interaction 
dialog to design your 
interaction. Option to 
count up or count down 
time. 

Drop Down Enables you to provide 
quick options to your 
learners inside course 
slides so they can select 
the correct option from 
the drop down list of 
choices.

Yes Yes Users selected choice is 
stored in the form of a 
variable which can be 
used to trigger actions in 
slides. 

Hangman Activity based learning 
interaction for users. 

Yes No You can use timer in 
seconds. Store the result in 
variable so you can use it 
in your customized 
screens to display the 
result. 

Hourglass Enables you to use it inside 
slides of your courses so 
you can trigger some 
actions based on time out 
feature. 

Yes No Variable value is 1 if timed 
out else it is 0. 

Follow the detailed 
instructions in configure 
interaction dialog. 

Image Zoom You can insert an image in 
your course slide to enable 
user to zoom and have a 
better view 

No No You can import only .png 
and .jpg image files. 
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Jeopardy Quiz form of gaming 
interaction enabling 
learners to choose 
answers based on user 
provided questions. 

Yes No Jpdy_FScore is a default 
variable, to store the result. 
You can modify it. Each 
question has an amount 
and a score associated. 
Answering correct adds up 
score, wrong answer 
negates it. 

Jigsaw Puzzle Allows users to play while 
they learn. 

Yes No You can store the score in 
variable so you can use it 
in your slides. Allows you 
to add multiple images. 

Memory Game The objective of this 
memory game is to find a 
match for an image or text. 
By default, the images or 
text will be hidden. When 
you click each card, an 
image or text appears. 
Then you need to find a 
suitable match for that 
opened image or text by 
randomly clicking other 
cards.

Yes No memGame_var is default 
variable name to store the 
result. Refer Using Adobe 
Captivate 8's new learning 
interactionsfor detailed 
usage instructions.

You can modify default 
variable names in all 
applicable interactions. 

Millionaire Gaming interaction 
designed in the form of 
famous who wants to be a 
Millionaire game theme. 

Yes No Mlnr_FScore is default 
variable name. 

Follow the instructions in 
configure interaction 
dialog to design the game 
for your end user. 

Notes You can add it in the slide 
so you can type notes at 
run time. 

No No User can change 
background color, modify 
content, save and print the 
contents at run time. 

Radio Button Enables you to provide 
quick questions to your 
learners inside your slides 
so they can choose the 
correct option. 

Yes Yes Option to choose the 
placement as vertical or 
horizontal. 

Answer can be stored in 
the variable so you can use 
it in your courses. 

Table Enables you to represent 
content of your slides in 
the form of tables. 

No No Option to import an 
existing table in the form 
of .csv file. 
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Adobe Captivate update for subscription and Adobe Software Assurance customers provides dynamic updates to 
learning interactions by polling the Adobe interaction store at regular intervals. The collection of interactions installed 
on your machine is compared with the one in the interaction store to determine the new or updated interactions. When 
you open the Select Interaction dialog box, you find that some of the interactions are labelled as:

• New: New interactions that are available for you to use. The label disappears when you click the interaction.

• Updated: Interactions for which updates are available since you last viewed the Select Interaction dialog box. If you 
have the project open for a long period of time, you have to close and reopen the project to view the latest updates.

Scrolling Text Enables you to add 
content in the form of 
scrolling text area inside 
your slides. Text beyond 
the text area dimensions 
will be shown with the 
help of scroll bar. 

Yes Yes Option to make the 
content of scrolling text as 
read only. 

Web Object Enables to insert live 
website url content in 
slides 

No No Useful in compliance and 
policy based courses. 
Note: Clickjacking 
websites is not allowed. 

YouTube Allows you to stream 
YouTube videos in your 
elearning courses. 

No No You can specify sections of 
videos. You can test the 
video before inserting. You 
can specify the time at 
which you want to start 
the video. For example, if a 
video is of 5 minutes, and 
you want to start showing 
the video from 1 min 20 
secs, you just need to 
mention 1 min and 20 secs 
in configuration dialog. 
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Updates to such interactions are dependent on the project data. So, irrespective of whether you have used the 
interaction in the project or not, you get to see the interactions that are tagged as Updated. If you have used the 
interaction in the project, you have to insert the upated one and reenter your data.

• Update: Interactions that you can update retaining your data intact. You can quickly update the interaction by
clicking the Update button under the interaction in the Select Interaction dialog box.

Sample files
glossary.zip

How to create and preview learning interactions
Learning interactions are static widgets that help you get started with standard user interactions, for example, 
interactions using accordions or tabs.

To insert learning interactions:

1 Click Insert > Interactions.

2 Click the type of interaction you want to insert in the Select Interaction dialog box, and then click Insert.

3 Choose a theme from the Themes list.

4 Click Custom to customize the selected theme.

Note: Buttons have three states: Up, Over, and Active. Up is the state when users have not clicked the button. Over is 
the state when users hover their mouse over the buttons. Active state is when users click the button.

5 Double-click the button text and the button content area to type your text. In addition to text, you can also insert 
pictures and audio files in the button content area.

6 Click the ‘+’ icon to add more buttons.

7 Click OK.

8 Modify the required properties of the widget using the Property Inspector. For more information on widget 
properties, see Properties of widgets.

To edit the theme or the content in the widget after inserting, double-click the widget on stage.

Note: Unlike other widgets, Adobe Captivate lets you resize the learning interaction widgets without loss in quality of the 
image on stage. To use this feature, click Refresh Widget in the Property Inspector whenever you resize the widget on stage.

http://helpx.adobe.com/captivate/using/learning-interactions/_jcr_content/main-pars/download/file.res/glossary.zip
http://help.adobe.com/en_US/captivate/cp/using/WSc1b83f70210cd101-65ee33211d86e1ac66-7ffd.html
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Adobe Captivate update for subscription and Adobe Software Assurance customers provides dynamic updates to 
learning interactions by polling the Adobe interaction store at regular intervals. The collection of interactions installed 
on your machine is compared with the one in the interaction store to determine the new or updated interactions. When 
you open the Select Interaction dialog box, you find that some of the interactions are labelled as:

• New: New interactions that are available for you to use. The label disappears when you click the interaction.

• Updated: Interactions for which updates are available since you last viewed the Select Interaction dialog box. If you 
have the project open for a long period of time, you have to close and reopen the project to view the latest updates.

Updates to such interactions are dependent on the project data. So, irrespective of whether you have used the 
interaction in the project or not, you get to see the interactions that are tagged as Updated. If you have used the 
interaction in the project, you have to insert the upated one and reenter your data.

• Update: Interactions that you can update retaining your data intact. You can quickly update the interaction by
clicking the Update button under the interaction in the Select Interaction dialog box.

Previewing learning interactions
• To preview learning interactions on Internet Explorer 9 and Safari, click File > Preview > HTML Ouput On Web

Browser.

• To preview the interactions on other web browsers or devices:

1 Publish the project in HTML5 format.

2 Host the output files on a web server (IIS, Apache, WAMP).
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3 Play the published output using the URL on the required browser.

Create drag-and-drop interactions in Adobe Captivate
Drag-and-drop interactions provide an interesting and engaging way of assessing your users’ knowledge. This 
interaction lets users answer questions by draging and dropping objects in the designated areas or objects.

A drag-and-drop interaction involves a drag source and a drop target. Users drag the drag sources and drop them onto 
drop targets.

Adobe Captivate also lets you group drag sources and drop targets into 'Types'. For example, you can create a type 
Stationery to include drag sources pen, pencil, and eraser. You can then map any item in Stationery to drop target 
‘Office’ and all the items in the type get automatically mapped to the target.

Create drag-and-drop interactions
You can create a drag-and-drop interaction using a wizard or using the Drag & Drop Interaction panel .

You can create a drag-and-drop interaction on any slide except:

• Master slides

• Question Pool slides

• Question Slides

• Placeholder Slides

You can convert any object on a slide into a drag source or a drop target except:

• Interactive objects(TEB, Clickbox, Button)

• Placeholders

• Smart shapes act as button

• Rollover Objects

• Slide Video

• FLV video

• Text animation

• Interactive Widgets

• Mouse

• Zoom Area

• Objects inserted in Rollover Slidelet

• All objects that have the timing set as ‘Rest Of Project’

Object effects too are not supported in a drag-and-drop interaction.

Using the Drag-and-Drop Interaction wizard
1 On the slide on which you want the interaction, insert the objects to be marked as drag sources and drop targets.

2 Click Insert > Launch Drag and Drop Interaction Wizard.

http://helpx.adobe.com/en/captivate/using/drag-and-drop-interaction.html#main-pars_header_1
http://helpx.adobe.com/en/captivate/using/drag-and-drop-interaction.html#main-pars_header_2
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Note: Alternatively, from the toolbar, you can click Interactions > Drag and drop

3 Follow the instructions in the Wizard to choose the drag sources and drop targets, and then to specify the correct 
answers by mapping the sources and targets. Note: You can group the drag sources and drop targets into ‘Types’ 
using the wizard and then map them. For more information, see Types.

4 After you click Finish in the Wizard, the Drag and Drop Interaction Property Inspector appears. You can use this 
Property Inspector to choose specific settings for drag sources and drop targets. For more information, see Edit 
drag-and-drop interactions.

Create drag-and-drop interaction using Property Inspector
1 On the slide on which you want the interaction, insert the objects to be marked as drag sources and drop targets.

2 Click Window > Drag Drop. The Drag and Drop Interaction Property Inspector appears.

3 Click the Create New Interaction icon ( ).

4 To specify the drag sources, click the objects on stage, and click Drag Source in the General accordion of the Drag 
and Drop Interaction Property Inspector. To select multiple objects, Ctrl + click (Windows).

5 To specify the drop targets, click the objects on stage, and click Drop Target in the General accordion of the Drag 
and Drop Interaction Property Inspector. To select multiple objects, Ctrl + click (Windows).

6 To group similar drag sources and drop targets into a ‘Type’, click ‘+’ adjacent to Custom Type. If you have already 
created the types, click the required type from the Custom Type list.

7 To map the drag sources to correct drop targets, click the drag source. A '+' icon appears at the center of the drag 
source. Click and drag the '+' symbol and point the arrow to the correct drop target.

8 To assign an animation effect for the drag sources, click the required effect from the Effects list in the Drag Source 
accordion.

9 Edit different aspects of the drag-and-drop interaction, drag sources, and drop targets using the Drag & Drop 
Interaction panel. For more information, see Edit drag-and-drop interactions.

Best practices for creating drag-and-drop interactions
• Insert all objects that you want to include in the drag-and-drop interaction before invoking the ‘Drag and Drop’

Wizard.

• While adding the objects, rename the objects to meaningful names. Do not rename objects after creating the
interaction.

• Make sure that the interaction name is not the same as that of any drag source, drop target, or Type.

• Ensure that the display time for drag source or drop target is greater than the interaction pause time.
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• Ensure that none of the objects included in a drag-and-drop interaction have 'Appear After' timing set.

• If the output is targeted for iPad, try to create projects in iPad resolution rather than using the 'Scale HTML5 content' 
option as doing so may lead to drag issues on iPads.

• Specify at least one correct answer for a drag-and-drop interaction. Else, the project may hang on the interaction
slide when users try to submit the answers.

• The configuration in Correct Answers may not work as expected if you make any changes to the interaction after
configuring the Correct Answers. So, ensure that you identify and mark drag sources and drop targets, and assign
it to appropriate types, before configuring the Correct Answers.

• If you make any changes to object names or Types, or delete them, ensure to revisit your Correct Answers
configuration and change it appropriately.

• Sometimes the ‘snap’ area or padding of two drop targets may overlap each other. In such cases, Adobe Captivate
executes the drop action based on:

• First, the ‘Accept’ conditions. If the drag source is not configured to be accepted by one of the drop targets, the
source is dropped onto the other drop target.

• Second, Z-order. If both drop targets have the same ‘Accept’ condition, the drop action is executed based on the
Z-order of the drop targets. The Z-order of drop targets is based on Timeline; the drop target that appears later
in the interaction has the highest Z-order.

• Advise your users not to use the play bar or the rewind button to go back to the beginning of the interaction. When 
they do so, the drag sources appear to have returned to their original position even if they had been successfully
dropped onto targets.

Types
Types in the context of drag and drop interactions are categories of drag sources or drop targets that have something 
similar.

By grouping drag sources and drop tragets into 'Types', you not only can map them quickly by just mapping one item 
in a type but also can use different combinations for accept conditions and correct answers. For example, for a given 
drop target, you can specify that only 2 objects from a drag source type can be accepted.

Depending on how you are creating the drag and drop interaction, you can create Types in the Drag and Drop 
interaction Wizard or the panel (Property Inspector). The Types that you create using the Wizard are available for 
editing through the Property Inspector. 
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Edit drag-and-drop interactions

View mapping of drag sources and drop targets
After you complete creating the drag and drop interaction using the Wizard and exit, the mapping disappears on the 
stage. To view the mapping, click Show in the Drag and Drop Interaction panel.

The 'Show' option works as a toggle that you can use to view or hide the mapping as and when required.

Add new drag sources and drop targets
Select the object on the slide and click Drag Source or Drop Target in the General accordion of the Drag and Drop 
Interaction panel.

To map them, click the drag source and drag the '+' symbol to point the arrow to the correct drop target. 

Specify multiple correct answers
Scenario 1: Multiple drag sources are correct answers for a drop target

Create a 'Type' and group them. Then, map the 'Type' to the drop target

Scenario 2: Multiple drop targets can accept one drag source

Create a 'Type' for the drop targets. Then, map the drag source to the 'Type'.

Scenario 3: Only some drag source types are correct for a given drop target

Click the drop target on stage, click Accept in the Drop Target accordion, and select the required drag source types.

Scenario 4: Only some objects in a drag source type are correct answers for a drop target

Click the drop target on stage, click Accept in the Drop Target accordion, and select the required drag source type. 
Uncheck the Accept All check box, and specify the limit on the number of objects as Count.

Scenario 5: Multiple combinations of drag source and drop target mappings are required in a single interaction

Click Correct Answers (Drag and Drop Property Inspector > Interaction Properties), and add additional rows to an 
existing answer set. Or, a new answer set and specify the mapping.
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Scenario 6: Users need to drag and drop objects in a specific order.

In the Correct Answers dialog box, create the order by arranging the answers in the required way and select Sequence 
option under Type.

Map multiple answer sets to drop targets
If a drag and drop interaction warrants multiple correct answer sets, you can specify those using the Correct Answers 
dialog box (Drag and Drop Property Inspector > Interaction Properties accordion > Correct Answers).

Further, for each answer set, you can also specify if the drop targets have to accept answers in any combination specified 
or if the answers have to be provided in the specified sequence only.

1 Open the Correct Answers dialog box (Drag and Drop panel > Interaction Properties accordion > Correct 
Answers).

The first answer set with the mapping that you specified while creating an interaction is already listed.

2 To specify more combinations of answers to the existing answer set:

a Click +. Then, click the row under Drop Target and click the target name from the drop-down list.

b Specify the source for this target, by clicking the row under Drag Source and then clicking a source name from 
the drop-down list.

c Count indicates the number of objects in the drag source type that can be correct answers. By default, this 
number is obtained from the mapping you specified while configuring the interaction. Click the Count row to 
specify a different number.

d If you want users to map the drag sources and drop targets in the order you have specified, click Sequence from 
the Type list.

3 To add a new answer set, click Add New Answer and repeat the steps above.
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Specify the 'Accept' conditions

A List of all drag source types that the selected drop target can accept. To exclude a drag source type from a drop target, 
uncheck the check box corresponding to the drag source type.

B Use this check box to include or exclude all the listed drag source types.

C Select the Accept all check box to specify that the drop target can accept all objects in the selected drag source types. 
In scenarios where you want only some of the objects from a drag source type to be accepted, uncheck the Accept All 
check box and specify the number of objects that can be accepted.

D and E Use these options to specify the number of objects that can be accepted and what happens when users drag 
and drop objects more than the specified number.

Replace Previous object that is dragged and dropped is replaced with the new one.

Go Back The new object goes back to the location on the slide from where it was dragged.

F Standard actions that you can assign to drag sources in a specific type.
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Configure feedback messages
Click the drop target on stage and then select one of the following options in the Drop Target accordion of the Drag 
and Drop Interaction panel:

On Accept In the text caption that appears on stage, type the message to be displayed to users when users drag a correct 
source and drop on the target.

On Reject In the text caption that appears on stage, type the message to be displayed to users when they drag a wrong 
source and drop on the target.

On Hint In the text caption that appears on stage, type the message to be displayed to users when they hover their 
mouse over the drop target.

Assign audio to the drag-and-drop action
When users drag and drop a source to a target, you may want to play audio to make the interaction more interesting. 

• To play audio when drop targets accept an answer, click the drop target, and click an audio file in the Audio list of
the Drop Target accordion. You can click Browse to use an audio clip saved on your computer.

• To play audio when drop targets reject an answer, select Play Audio in the Interaction Properties accordion. When
you select this option, Adobe Captivate plays a default audio clip; you cannot select a custom audio for this scenario
currently.

Configuring drag source properties
To specify the behavior of drag sources during or after they are dropped onto drop targets, use the following options:

Hit Area Padding Refers to the padding around the selected drop target. The drag sources are considered to be dropped 
onto the target when users drop them anywhere within this padding area (that is not necessarily on the target).

Position Click one of the following options to specify how drag sources snap after dropping onto the selected target:

Absolute Drag sources remain at the same location where users drop them.

Anchor Drag sources snap to the selected anchor points. You can select from one of the nine anchor points you see 
under the Anchor option.

Tile Multiple drag sources are piled or placed in the selected order. Select a tiling option in the panel.

Size Edit the default value (100%) if you want to increase or decrease the size of the drag source after they are dropped 
onto the target. A value lesser than 100% decreases the size and a value higher than 100% increases the size.

Opacity Edit the default value (100%) to change the opacity of drag sources after they are dropped onto targets. A value 
of 0 makes the drag sources invisible after they are dropped.

Depth Select Front or Back to specify the z-order of the drag sources after they are dropped onto the target. The first 
source that is dropped is placed in front or back of the drop target. The subsequent objects that are dropped are placed 
in front or back of the previously dropped object.

More Help topics 
Use effects for drag sources and drop targets

Other options in the drag and drop interaction panel

Assign audio to the drag-and-drop action

http://helpx.adobe.com/en/captivate/using/drag-and-drop-interaction.html#main-pars_header_14
http://helpx.adobe.com/en/captivate/using/drag-and-drop-interaction.html#main-pars_header_5
http://helpx.adobe.com/en/captivate/using/drag-and-drop-interaction.html#main-pars_header_8
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Use effects for drag sources and drop targets
• For drag sources, click the drag source on stage, and click an effect from the Effects list Drag Source accordion (in

Drag & Drop Interaction panel).

The effects for drag sources are displayed when users click and drag these objects.

• For drop targets, click the drop target on stage, and click an effect from the Effects list in the Drop Target accordion
(in Drag & Drop Interaction panel).

The effects for drop targets are displayed when users hover their mouse over these objects.

Other options in the Drag and Drop Interaction panel

Interaction properties
Correct Answers Use to specify the 'or' conditions for the correct answers. Mapping drag source types to drop targets 
help you establish an 'and' condition where objects x and y, both can be the correct answers. Correct Answers dialog 
box helps you specify x or y as the correct answers. For more details, see Map multiple answer sets to drop targets .

Use Hand Cursor Hand cursor appears while users drag-and-drop objects.

Send Drag Source to Original Position When dragged sources are dropped outside the drop target, they are sent back 
to the location on the slide from where they were dragged.

If this option is not selected and users move drag sources on the slide, the Go Back option snaps the objects to their last 
position on the slide from where they were dragged. Incorrect answers are automatically sent back to the location from 
where they were dragged.

Redrag the Dropped Source Allows users to redrag a dropped drag source (incorrect or correct) to another drop target.

Note: This feature may not work as expected in this release. Consider using Reset or suggest users to undo the changes.

Action
Reset If multiple attempts are allowed, this option helps you specify if the answers are to be reset when users click 
Submit. 

Note: If you have selected the Reset option as None, ensure that you select Include In Quiz in the Reporting accordion. If 
the slide is not included in quiz, the answers are reset each time when users navigate away and return to the slide.

Options
Pause after n sec The slide pauses at the specified time (n sec) to let users interact. The time is calculated after the slide 
that contains the drag-and-drop interaction starts playing.

Auto Submit Correct answers are immediately submitted without users having to click the Submit button. This option 
is useful in scenarios where an On Success action needs to be triggered immediately after users answer correctly.

Undo Inserts an undo button on the slide. Only the latest drag action by the user is undone.

Reset Inserts a reset button on the slide so that the user can reset the interaction at any point in time.

http://helpx.adobe.com/en/captivate/using/drag-and-drop-interaction.html#main-pars_header_17
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How to use the Twitter widget in Adobe Captivate 
projects
The Twitter widget facilitates in-context collaboration between you (the author) and your users (elearners). It helps you 
simulate a classroom environment in which elearners can ask questions to you and co-elearners in 'real-time'. 

When you publish a project containing the Twitter widget, your users can ask questions from within the project without 
having to log on to Twitter. The questions appear to you and others at the appropriate context of the project in which 
they are asked. 

While the questions can be asked only from a published project, the replies can be provided from any of the following:

• Twitter- accessed through a web browser or a mobile device.

• Within the published Adobe Captivate project using the Reply button that appears when the Twitter icon is clicked.

Adding the Twitter widget to projects
1 Download the Twitter widget from Adobe Exchange. The .zip file that you download contains the following files:

• twitterwidget.swf — The Twitter widget that you can insert into your Adobe Captivate projects.

• Twitteroauth.zip — The OAuth configuration file for authenticating Adobe Captivate when your users try to
access the project with the Twitter widget.

2 Ensure that you have met the prerequisites for using the Twitter widget. See Prerequisitesfor more information.

3 Set up your project by providing a unique name in the Preferences. See Setting up the projectfor more information.

4 Insert the Twitter widget in your project. See Inserting the Twitter widget in projectsfor more information.

Prerequisites
1 Install a Web server and PHP on a computer. You can opt for WAMP (for Windows) or MAMP (for Mac) that 

provides both.

Note: The computer can be the one on which you have installed Adobe Captivate or any other computer on your 
network.

Visit http://www.wampserver.com/en/download.php for downloading WAMP. For step-by-step instructions, see 
http://www.ehow.com/how_5921076_set-up-localhost-computer.html.

Note: Ignore the last step in these instructions that says continue according to the instructions on the WAMP web site.

Visit http://www.mamp.info/en/index.html for downloading MAMP. For step-by-step instructions, see 
http://documentation.mamp.info/en/mamp/installation.

2 On the Windows machine, configure PHP and the web server. See Configuring PHPand Configuring the web 
serverfor more information. This step is not required on Mac as the required parameters are enabled by default with 
MAMP.

3 Set up authentication for Adobe Captivate using OAuth. See Setting up authentication through OAuth

Your users (elearners) do not have to meet these prerequisites. They just need a valid Twitter account to access the 
projects with the Twitter widget.

Configuring PHP
On Windows, enable the CURL library. To do so, click the WAMPSERVER icon in the system tray, select PHP > PHP 
extensions, and then click php_curl.

http://www.wampserver.com/en/download.php
http://www.ehow.com/how_5921076_set-up-localhost-computer.html
http://www.mamp.info/en/index.html
http://documentation.mamp.info/en/documentation/mamp/
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To verify whether or not CURL is enabled, type http://localhost or http://localhost:8080 in a web browser, and click 
phpinfo() in the Tools section. Search for CURL on the page. Check if the row cURL support contains the value enabled.

Configuring the web server
On Windows, enable the rewrite module. To do so, click the WAMPSERVER icon in the system tray, select Apache > 
Apache modules, and then click rewrite_module.

To verify whether or not the rewrite module is enabled, type http://localhost or http://localhost:8080 in a web browser, 
and click phpinfo() in the Tools section. Search for rewrite on the page. Check if the mod_rewrite is listed in the row 
Loaded Modules (apache2handler table).

Setting up authentication through OAuth
1 Right-click (Windows) or Control-click (Mac) the file twitteroauth.zip and click Extract. The contents are extracted 

into the twitteroauth folder.

Note: twitteroauth.zip is available in the TwitterWidget.zip folder that you downloaded from Adobe Exchange. 

2 Place the twitteroauth folder into the root directory of your web server. To access the root directory:

• (on Windows) Click the WAMPSERVER icon in the system tray and click www directory or navigate to
<WAMP_installation_folder>/wamp/www.

• (on Mac) Go to /Applications/MAMP/htdocs

Setting up the project
1 Open the project in which you want to insert the Twitter widget.

2 Go to Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac).

3 In the Preferences dialog box, click Information under Project in the Category list.

4 In the Project Name field, specify a name for your project. Choose a unique name as this name will be used as the 
hash tag in Twitter for the course.

Inserting the Twitter widget in projects
1 Open the Adobe Captivate project in which you want to insert the Twitter widget.

2 Click the first slide in the Filmstrip.

3 Click Insert > Widget. Browse to the location where you have downloaded the twitterwidget.swf, and click open. 
The Widget Properties dialog box appears.

4 In the Username field, type your Twitter account username. This account is considered to be the author's account.

5 In the PHP Location field, specify the location of the twitteroauth folder that you placed in the root directory as a 
URL in the following format:

http://<ipaddress_of_the_web_server>/<twitteroauth_folder_location> 

For example, if you have placed the folder in c:/wamp/www/Twitter/twitteroauth, specify the PHP location as 
follows:

http://<ipaddress_of_the_web_server>/Twitter/twitteroauth 

On Windows, if you are accessing the web server home page using the port number 8080, then specify the port 
number for PHP location too. For example,

http://<ipaddress_of_the_web_server>:8080/Twitter/twitteroauth 
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On Mac, specify the port number 8888. For example, 
http://<ipaddress_of_the_web_server>:8888/Twitter/twitteroauth

6 Click OK. The Twitter widget now appears on your slide. When you publish the output, the widget appears at the 
same position where it appears on the slide. 

7 In the Timing panel of the widget's Property Inspector, click Rest Of Project in the Display For drop-down list.

Before you preview or publish your project, ensure that the status of the WAMP or MAMP server is 'Online'. 

• On Windows, move your mouse on the WAMP server icon in the system tray. If the status indicates that the server
is 'Offline', click the icon and then click Put Online.

• On Mac, launch MAMP. In the welcome screen, if you see a red button against Apache and PHP, click the adjacent
buttons to put them online. The color of the buttons turn green.

Accessing the project outputs with Twitter widget
When you or your users try to access the project published with the Twitter widget, a prompt for the OAuth PIN 
appears.

 Click Generate to generate the PIN.

If you have already logged into Twitter, click Allow to continue with the same account. To log in with a different 
account, click Sign-in.

If you have not logged into Twitter yet, you will be prompted to provide your Twitter username and password.

After you have logged in successfully, the PIN number appears in your default web browser.

Note: If the PIN number does not appear in the browser window, allow the pop-ups in the browser, and try refreshing the 
page.

2. Copy the PIN number and paste it into the OAuth PIN number field in the prompt that appeared in the project.

3. Click Login.

Searching for the project in Twitter
Use the name of the project to search for it in Twitter, TweetDeck, or search.twitter.com. All the tweets (questions and 
replies) that occurred in the project are listed. You can then tweet a reply or a question.

Collaboration workflow
The questions and replies that were tweeted before you or an elearner started viewing the project are grouped into 
conversation threads. You (the author) get to see all the conversation threads on the current slide, irrespective of which 
frame you are viewing. However, other elearners can view only those conversations that have occurred until the frame 
that they are currently viewing.

To view the conversation threads, click the Twitter icon.

All the tweets that occur during the time when you or an elearner is viewing the project output are indicated instantly. 
You (the author) are notified about the tweets that occur on any slide in the project, irrespective of whether or not you 
have viewed that slide yet. However, for other elearners, the tweets are listed in the conversation list that they can view 
when they reach that slide (and frame).

When a new question or a reply is tweeted, a second Twitter icon appears on the slide. This icon disappears as soon as 
all the tweets are viewed. 
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Note: The second Twitter icon differs from the first one in the color of its wing. In the first icon, the wing of the bird is blue 
while in the second the color is yellow. 

All the viewed tweets are added to the conversation lists on the slide. 

The following steps outline the collaboration workflow between an author, Casey, and elearners, Alex and Jaden:

1 Casey creates and publishes an elearning course with a Twitter widget.

2 Alex starts viewing the course and right-clicks on a table on Slide 10 (frame 2), and asks a question.

3 Jaden is also viewing the course at the same time.

• If Jaden too is on Slide 10, frame 2 or has already viewed the slide, an additional Twitter icon appears on Jaden's
machine. Jaden can click the icon to view the question and click reply to provide an answer. As soon as Jaden
views the question, the additional icon disappears and the tweets (question and answer) are added a as a
conversation thread.

• If Jaden has not yet viewed Slide 10, frame 2, the question from Alex appears as a conversation thread. Jaden can 
click the original Twitter icon to view the question.

4 Casey is also viewing the course at the same time. Irrespective of which slide or frame Casey is viewing, an additional 
Twitter icon appears as soon as Alex or Jaden ask a question.

• Casey can click the tweet to go to the context (slide 10, frame 2) and reply to the question.

• Casey can access the older tweets by clicking the original Twitter icon.

How is the 'context' of tweets determined?
The following factors determine the context of a question:

• Frame number

• The location on the slide where the elearner clicks to ask a question

If you or other elearners are viewing the published project, clicking the conversation headers or the new tweets takes 
you to the context (slide and frame).

When you or other elearners view the tweets in the project using Twitter, the context is provided as follows:

FrameNumber, X co-ordinate, Y co-ordinate

For example, 245; 400; 194.

Asking questions
Only elearners (not the author) can ask a question in the project published with the Twitter widget. 

1 Right-click (Windows) or Control-click (Mac), select Ask Question

2 Click inside the Ask A Question dialog box, and type the question

3 Click Send.

Replying to questions
You (the author) and the elearners can reply to any question in the project using the Twitter icon. 

1 Click the Twitter icon to view the questions.
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2 Click Reply to reply to a question or a conversation thread. To address your reply to a specific person, click the arrow 
mark adjacent to the name of the person.

3 Type the reply and click Send.

How to configure widgets and interactions in Adobe 
Captivate

Configure Widgets and Interactions
You can configure Widgets and Interactions before inserting them into the slides. Apply different styles of Themes and 
customize the colors, captions, and so on, with the revamped Widgets and Interactions windows.

Configuring Widgets
1 Click Insert > Widget Choose the Widget of your choice and click Open.

2 Widget Properties window appears as shown below:

Configuring Interactions
1 Click Interactions button on Toolbar

2 Choose Learning Interactions menu item from the drop down menu. 

Select Interactions window appears as shown below: 
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3 Choose the interaction from the list and click Insert. 

Configure interaction window appears as shown below: 
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4 Click Custom to customize the interactions properties and click OK to insert the interaction in your slide. 

Widget and Interactions Properties
Themes On the left pane of the above window, you can see various Themes that you can apply for the Widget or 
Interaction. Click any Theme and it applies to screen dynamically.

Custom Click Custom and you can view various options such as Content, Header, and any other titles based on the 
widget or interaction type. You can apply different styles and colors to screen properties. 

IMPORT Import the existing content into the widget. Only xml format files are allowed. Click View example to see the 
sample xml format file for your reference to create. 

FULL SCREEN Click FULL SCREEN to hide the Themes/Custom window pane to have a better pre-view of your 
configured content.

Go Social

To share your interactions and widgets with online communities, click f, t, and + icons to share with Facebook, twitter, 
and Google + respectively.

Example XML code in Adobe Captivate widgets
Widgets use XML to pass data from Animate to Captivate. The following examples illustrate widgets called by Adobe 
Captivate.

Example 1: Creating objects inside ActionScript
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var _parameters: Object = new Object(); 
_parameters.country = txtCountry.text;  
return _parameters;

This code segment creates an object named _parameters and assigns the field country to it. When the _parameters 
object returns, Adobe Captivate stores it in XML format for future use (for example, for publishing in a certain 
language).

Example 2: Playing a movie containing a widget

if(movieHandle.widgetParams != undefined && movieHandle.widgetParams != '')//at runtime inside 
Captivate movie  
{  
trace("widgetParams = "+movieHandle.widgetParams);  
var x:XML = new XML(movieHandle.widgetParams);  
var countryName = x.firstChild.firstChild.firstChild.firstChild.nodeValue;  
ShowRandomizedCountryName(countryName);  
initDone = true;  
}

The visibility state is undefined for widgets. You set this state using the movieHandle.widgetParams property, which 
contains values derived from Adobe Captivate.

The trace command prints widgetParams, which is a string in XML format. You can access the nodes of the string using 
XML. Read the code to understand how your data is stored so that you can reach the node you need. To parse the string, 
use XML that is an ActionScript construct. For more information, see the ActionScript documentation in Animate CC.

Using Adobe Captivate variables in widgets
To use an Adobe Captivate variable in widgets, specify the variable within $$. You can use both user-defined and system 
variables in widgets. The widget can get and set variables within the Captivate demo.

For example, the user-defined variable $$username$$ in a Certificate widget fetches the name of the user and displays 
it in the certificate.

Using ActionScript 3.0 in widgets
Note: Only ActionScript 3.0 is supported.

Changes in ActionScript from version 2 to version 3 warrant changes in how constructs access Adobe Captivate demos. 
Some of the changes are documented here.

• To declare onEnterFrame specify this.addEventListener("enterFrame",onEnterFrame);

• Use void instead of Void

• External interface takes only two parameters now. For example, ExternalInterface.addCallback("isStatic",isStatic);

• Use parent instead of _parent

• Use the following code in the ActionScript file:function cpSetValue(variable:String, val):void { if (variable ==
'widgetMode') { widgetMode = val; } } ExternalInterface.addCallback("cpSetValue", cpSetValue);
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• The way to get widgetParam has changed in ActionScript 3.0 because of changes in the structure of Captivate
demos:var slide:Object = parent.parent.parent; var slideXMl:XMLList = XMLList(slide.slideXMl); var
parname:String = parent.parent.name; var ItemXML:XMLList = XMLList(slideXMl.ItemList.Item.(@name ==
parname)); widgetParam:String = ItemXML.widgetParams;

• Understand the new way of parsing XML.

Note:  Ensure that the version of ActionScript for the widget matches the ActionScript version used for the Captivate demo. 
ActionScript 2.0 widgets do not work in movies published using ActionScript 3.0, and the other way around.

How to use the different types of widgets in Adobe 
Captivate

Static widget
Static widgets are generic widgets that help you set up user interactions. Static widgets do not interact back with Adobe 
Captivate. This means, you cannot set up success and failure actions to these widgets.

Interactive widget
Interactive widgets change their appearance or function based on user input. You can assign success and failure actions 
to these widgets and make them interact back with Adobe Captivate when users interact with the widgets.

If you are a developer trying to create an interactive widget in Flash, you can explore the code for the button widget. 
The code gives you an idea of how to create interactive widgets. Look for the button widget, FlashButton.fla, on your 
computer in the \\Program Files\Adobe\Adobe Captivate <version number>\Gallery\ Widgets\FlashButton.wdgt (on 
Windows) and /Applications/Adobe Captivate 6/Gallery/Widgets/FlashButton.wdgt (on Mac OS).

The button widget glows when the user moves the pointer over it.

1 Insert a blank slide.

2 Insert the FlashButton.swf file from the Widget panel (Window > Widget).

3 Preview the slide. When you move the pointer over the button, the Button widget glows.

Question widget
You can use question widgets to add new question types in Adobe Captivate. The following procedure explains how to 
insert a widget for multiple choice questions:

1 Insert a blank slide.

2 Insert the widget MCQ_AS3.swf from the Widget panel. Two slides, one with a placeholder for the question and the 
other for the scores are inserted.

3 Type the question and multiple choices as required.

4 To insert another question, insert a blank slide after the slide that contains the question and then insert the widget 
again.

Note: Use the Quiz Properties panel to edit properties such as the points scored per correct answer and the buttons to be 
displayed in the slides.



301
Widgets

Last updated 10/10/2016

Functions in question widgets
Question widgets should implement the following functions in addition to the functions discussed in this topic.

getWidgetQuestionState()

This method is called when the user clicks Submit on the question slide. The method provides the widget with an 
option to restore its state when the quiz is restored in an LMS. This function should return a non-empty string in a way 
that it can restore its state when the widget is reloaded.

setWidgetQuestionState()

Restores the widget to its previous state. setWidgetQuestionState() is called when the widget is reloaded in the LMS.

function getWidgetQuestionState() { trace("get Widget Question State"); return 
"<var1>"+var1+"</var1><var2>"+var2+"</var2>" //Should be a non- empty String.Should not contain _ and ; } 
function setWidgetQuestionState( val:String) { trace("set Widget Question State()" + val ); }

For example, let us consider that the state of the variables is var1=10, var2="Captivate" when Submit is pressed and the 
function is called. Open the Adobe Captivate quiz in LMS, attempt the question, and press Submit. The 
getWidgetQuestionState function is called. Re-open the quiz in LMS. When the widget question is shown, function 
setWidgetQuestion is called with the same string: "<var1>10</var1><var2>Captivate</var2>"

answers()

Displays the review feedback. The function returns an array of Objects() with the following properties.

answerID

A unique ID for every answer.

chosenAnswer

String representing the answer chosen by the learner.

correctAnswer

String representing the correct answer.

For example,

function answers():Array { var answers:Array = new Array(); var ans : Object = new Object(); var ans2 :Object = new 
Object(); ans.answerID = "10"; ans.chosenAnswer = "Hi..Hi..."; ans.correctAnswer = "Hello...Hello..."; 
answers["firstanswer"]= ans; ans2.answerID = "12"; ans2.chosenAnswer = "Hi2..Hi2..."; ans2.correctAnswer = 
"Hello2...Hello2..."; answers["first2answer"]= ans2; return answers; }

Set the properties of widgets with Adobe Captivate
In addition to the parameters defined by the widget developer, Adobe Captivate allows you to set properties for widgets. 
You can modify the properties of a widget using its Property Inspector (Windows > Properties).

Widgets
Name Enter a unique name for the object. You can use this name when defining the visibility conditions for the object. 

Visible Deselect this option if you want the object to be invisible on the slide by default. Use the Show action to make 
the widget visible. For more information, see Controlling the visibility of objects .

http://helpx.adobe.com/en/captivate/using/controlling-visibility-objects.html#controlling_the_visibility_of_objects
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Animation
Object Name Name of the animation object.

Linkage Provides the link to the associated SWF file. 

Update Click to reflect the modifications to the source file (if edited externally).

Source Link to the source FLA file of the animation SWF file.

Edit Click to edit the FLA file using Adobe Flash from within Adobe Captivate.

Alpha The transparency of the widget. At 0% transparency, the widget is opaque, and at 100%, transparency, it is 
invisible.

Widget Properties Click to display the Widget Properties dialog box that shows the parameters that you can use to 
customize the widget. These parameters are available only if the developer creating the widget has made provisions for 
customizing the widget. A snapshot of the widget may be displayed in this dialog box.

Timing
Display For [Time] Specifies how long the widget appears on the slide.

Appear After [#] Seconds Specifies the delay between the first appearance of the slide and the first appearance of the 
widget.

Pause After [#] Seconds Specifies the point at which the project pauses so that the user can follow the instructions in 
the widget.

Note: This field applies only to interactive widgets.

Transition
Effect Transition effect for the widget. You can apply a fade in or fade out effect, and set the time for the fading effects.

Action
On Success The options available if the user successfully fulfills the criteria specified in the widget. For more 
information, see How to use interactive objects for project navigation.

Attempts Define the number of attempts.

Infinite The user can attempt infinite number of times.

Last Attempt The options available if the user fails to fulfill the criteria specified in the widget in the defined number 
of attempts. For more information, see How to use interactive objects for project navigation.

Options
Select the appropriate options from the following:

Success The caption displayed when the user successfully completes the task assigned by the widget. 

Failure The caption displayed when the user does not provide the input required by the widget. 

Hint The caption providing a hint to the user. The hint is displayed when the user moves the pointer over the widget.

Pause For Success/Failure Captions Pauses the project until all success and failure captions are displayed.
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Audio
To add audio to the widget, go to the Audio area in the Property Inspector (Window > Properties) and then click Add 
Audio. 

Fade In [#] SecondsSpecifies the number of seconds until the audio fades in to full volume.Fade Out [#] 
SecondsSpecifies the number of seconds until the audio fades out to silence.AudioDisplays Object Audio dialog box. 
For details, see Set audio for widgets.

Transform
To define the exact size or location of the widget in terms of pixels, or to rotate the widget, click the Transform tab. Select 
from the following options:

X Position of the X coordinate of the object.

Y Position of the Y coordinate of the object.

W The width of the object.

H The height of the object.

Constrain Proportions Maintains the height-to-width ratio when the object is resized.

Angle Angle of rotation of the widget.

Reporting
If you want to keep score for the widget or coordinate the score with a learning management system (LMS), use the 
Reporting tab. 

Include in Quiz The points assigned to the widget are added to the score results for the current quiz.

Points Points assigned to a correct answer. The maximum is 100 points; minimum is 0.

Add to Total The score of the button is added to the quiz total.

Report Answers Sends the score to the learning management system (LMS).

Interaction ID Sends tracking information to the LMS based on the interaction ID specified by the LMS.

Set audio for widgets
You can add an audio file to noninteractive objects. The audio file is played when the object appears on the slide. 

1 To add audio, go to the Audio area in the Property Inspector (Window > Properties) and then click Add Audio. 

The Object Audio dialog box appears.

2 In the Add/Replace tab, use the following options:

Record Audio  Opens the Record Audio dialog box. (Recording audio requires some basic equipment.)

Stop  Stops playing the audio file.

Play  Plays the audio file.

3 In the Edit tab, to edit the audio file in various ways, such as inserting silent periods and adjusting the volume.

4 Click Settings to open the Audio Settings dialog box. You can change audio settings such as input source, quality 
level, and calibration. Click the Settings button to make your selections.

5 Click Import to display the Import Audio dialog box. This dialog box lets you browse to an audio file and import it. 
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6 Click Library to open the Library. The Library lists all audio files that are already part of the currently open Adobe 
Captivate project.

More Help topics 
Project navigation using interactive objects

Learning management system (LMS)

New widget APIs in Adobe Captivate 6
Adobe Captivate 6 provides the following new classes for widget developers to manage external resources in their 
widget:

• CPWidgetInternalResourceLoader

• CPWidgetExternalResourceLoader

CPWidgetInternalResourceLoader
Use this class to use images in a widget. The resources are embedded into the SWF output file as PNG files. You need 
to use ‘ByteArray’ to use these resources.

You can use this class in Stage mode, Edit mode, or at run-time.

This class contains the following functions:

• browseResource

• getResourceStream

browseResource
public function browseResource(): int

This functions works only in Edit mode. Adobe Captivate library is launched and you can select or browse for the 
resource.

This function returns an integer (resource number).

getResourceStream
public function getResourceStream (resourceID:int) : ByteArray

This function works in Stage mode, Edit mode, and at run-time. You need to provide the resource number as the input 
parameter and the function returns the ByteArray for that resource.

CPWidgetExternalResourceLoader
Use this class to use music or video files in a widget. These resources are externalized and are not embedded into the 
Adobe Captivate SWF file. The resources are copied as separate files in the same directory as the SWF output file. 

To use these resources, you need to get the file path of the resources.

This class contains the following functions:

• browseResource

http://helpx.adobe.com/en/captivate/using/project-navigation-using-interactive-objects.html#project_navigation_using_interactive_objects
http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#learning_management_system_lms
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• getResourceStream

getResourcePath
public function getResourcePath (Resource ID:int) : String

This function works in Stage mode, Edit mode, and at run-time. You need to provide the resource number as the input 
parameter and the function returns the path of that resource.

Using the Learner Notes interaction widget
Learner Notes interaction is a widget that your users can use to take notes while viewing your course. These notes are 
'sticky' and are available to users each time they open the course as long as they view the course on the same computer 
and in the same browser they used while creating the notes.

You can configure the interaction to let users add notes at slide level or at the project level. Using this widget, users can 
add multiple notes to a single slide.

Author workflow

Insert Learner Notes interaction
1 Open your Adobe Captivate project. Click Insert > Interactions.

2 In the Interaction dialog box, scroll to the Notes interaction, click the interaction, and click Insert.

The Configure Interaction dialog box appears.

3 Configure the following settings:

Use Default Notes Icon Inserts the default icon for notes. A thumbnail is displayed in the Configuration dialog box.

Use Transparent Icon Lets you insert a transparent widget over any image on the slide. Use this option to use your 
own image for the Notes icon.

Add Notes For Each Slide Lets users insert new notes for every slide.

Add Notes For The Project Lets users insert a single note for the entire project. To display a message to your users as 
the first line in the notes, type the required text as Default Message.

Use Default Storage ID Adobe Captivate assigns a default storage ID for the notes in the course. Storage ID is a 
unique ID using which you can retrieve the notes and use them in another course. Notes are saved as shared objects 
with the extension SOL and you can search for the file using any third-party tool, such as, Everything®.

Type Your Own Storage ID Specify a storage ID (alphanumerical) for the notes if you do not want to use the default 
ID.

4 In the Property Inspector, set the timing of the notes widget as Rest Of Project.

5 (Optional) Specify the following properties for the Notes widget using the Property Inspector. For more 
information, see Widget properties.

6 Best practices:

• Ensure that the Notes widget is the top most object in the slide timeline.

• Do not resize the widget.

http://help.adobe.com/en_US/captivate/cp/using/WSc1b83f70210cd101-65ee33211d86e1ac66-7ffd.html
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• Do not add effects.

Learner workflow
1 Learners start the course and click the Notes widget when required.

2 Type down their notes while the course progresses. To enter long notes, it is a good idea to pause the project, enter 
the notes, and resume the course.

• To hide a note, learners can click the notes widget. They can click the widget again to show the notes.

• To add a new note, learners can click + at the left top corner.

• To delete a note, learners can click X at the right top corner.

• To format text, learners can select the text using the mouse. The formatting options appear.

• To change the background color, learners can click the Background Color icon and choose a color.

How to create WDGT files for SWF and HTML5 outputs in 
Adobe Captivate
The WDGT file is a file with .wdgt extension containing:

• SWF files with links to other SWF files or assets

• HTML version of the widget

• description.xml file that contains information about the linking

The HTML files are required for HTML5 outputs. If you want to generate only SWF output files of your Adobe 
Captivate projects, the WDGT file need not contain the HTML files. 

Creating WDGT files for only SWF outputs
A WDGT file for SWF outputs must contain the following:

• swf (directory): Contains the SWF output file of the widget and other linked resources.

• description.xml (file): Contains information on the SWF and HTML versions of the widget that Adobe Captivate
can use to publish and display the widget to users.

1 Create a new directory and name it as required, for example, mywidget. Then create a subdirectory: swf.

2 Publish the FLA as a SWF file in Flash. Place the SWF file in the swf directory.

3 Create a description.xml file. If the main SWF file, ABC.swf, uses two linked files PQR.swf and XYZ.swf, the 
description.xml file is in the following format:

<?xml version="1.0" encoding="ISO-8859-1" ?>  
<widget>  
<Description>This is a ABC widget(static)</Description> 
<Type>isStatic</Type>  
<Name>ABC.swf</Name>  
<linkedfiles>PQR.swf</linkedfiles>  
<linkedfiles>XYZ.swf</linkedfiles>  
</widget>

4 Place the description.xml file in the root directory, that is mywidget directory in this case.
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5 Compress the root directory (mywidget directory) and change the extension of the file to .wdgt.

6 Place the .wdgt file in <Adobe Captivate installation directory>/Gallery/Widgets.

Creating WDGT files for SWF and HTML5 outputs
A WDGT file for SWF and HTML5 outputs must contain the following files and directories:

• swf (directory): Contains the SWF output file of the widget and other linked resources.

• html5 (directory): Contains the assets and scripts related to the widget created in HTML and javascript. The
following is the typical directory structure:

• images (directory)

• scripts (directory)

• xyz_oam.xml (file)

The html5 directory an contain other asset directories such as themes. You need to create the openAJAX metadata 
xml file (xyz_oam.xml) to store all the widget information such as scripts and assets.

• description.xml (file): Contains information on the SWF and HTML versions of the widget that Adobe Captivate
can use to publish and display the widget to users.

1 Create a new directory and name it as required, for example, myhtmlwidget. Then create the following 
subdirectories:

• swf

• html5

2 Publish the FLA as a SWF file in Flash. Place the SWF file in the swf directory.

3 Create the widget using HTML and Javascript.

4 Place all the assets and scripts in the html5 directory.

5 Create an OpenAjax metadata XML file that stores all the relevant widget information such as the scripts and 
javascript libraries. 

For information on the OpenAjax schema, see this website.

Here is an example:

http://www.openajax.org/member/wiki/OpenAjax_Metadata_1.0_Specification_Widget_Metadata#widget_element
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<?xml version="1.0" encoding="UTF-8"?> 
<!--  

OpenAjax Alliance Widget Specification 
-->  
<widget name="Arrow" id="com.adobe.captivate.dev.sample.widgets.arrow" 

spec="0.1b" jsClass='Arrow' sandbox='true' width='300' height='300' 
xmlns="http://openajax.org/metadata">  

   <requires> 
<libraries> 

<library name="dojo" version="1.7" copy="true" src="js/dojo-release-1.7.1" 
includeRef="false">  

<preload> 
  djConfig="{parseOnLoad:true}" 

</preload>  
      <require type="javascript" src="dojo/dojo.js" copy="false" includeRef="true"/> 

</library> 
<library name ="jQuery" version="1.6.1" copy="true" src="js/jquery1.7.1/jquery-

1.7.1.min.js" type="javascript"/>  
<library name="jQuery.svg" version="1.4.4" copy="false" src="js/jquery.svg" 

includeRef="false"> 
<require type="javascript" src="jquery.svg.js"/> 
<require type="css" src="jquery.svg.css"/> 

</library> 
</libraries> 
<require type="folder" src="assets/svg"/> 

   </requires>  
   <javascript src="js/arrow.js"/>  
   <!--  

Properties are currently ignored by captivate since we expect the widget to do all 
the work that has to be done from widget xml  

  or the widget JSON. Still we give it a stab to see if we can get in property replacement 
   -->  
   <properties>  
     <property name="style" datatype="String" default="AeroArrow"/> 
   </properties>  

   <content type='fragment'> 
   <![CDATA[  

<H1>Hello Widget!!!</H1>  
<div ID="__WID___ArrowShape"/> 

   ]]> 
   </content> 
</widget>

6 Open the javascript that corresponds to the value specified for the jsClass attribute in the metadata XML file. For 
instance, if the jsClass value is Arrow, open arrow.js file from the scripts directory.

7 Ensure that the arrow.js file includes the onLoad() function that invokes the getMovieProps()function. Here is an 
example:
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arrow1 = { 
   onLoad: function() 
   {  

if ( ! this.captivate ){ 
return; 

}  
//Gives access to the the movie handle  
this.movieProps = this.captivate.CPMovieHandle;  
//Gives access to the widget params  
this.movieProps = this.captivate.CPMovieHandle.widgetParams();  
//Function to replace all instances  
//of a Captivate variable by their associated values  
this.movieProps = this.captivate.CPMovieHandle.replaceVariables(varString);  
//Access to the event dispatcher where addEventListener and  
//removeEventListener can be called. Also contains the constants  
//needed for registering for events such as  
//<Widget>.captivate. CPMovieHandle.getMovieProps().eventDispatcher  
//.SLIDE_ENTER_EVENT  
this.movieProps = this.captivate.CPMovieHandle.getMovieProps().eventDispatcher; 
//Access to the variables handle  
this.movieProps = this.captivate.CPMovieHandle.getMovieProps().variablesHandle; 
//Access to the external resource loader  
this.movieProps = 

this.captivate.CPMovieHandle.getMovieProps().ExternalResourceLoader); 
if ( ! this.movieProps ){ 

return; 
} 
this.varHandle = this.movieProps.variablesHandle; 
this.eventDisp = this.movieProps.eventDispatcher; 
// other code  

   };  
   //To unload your widget 
   onUnload: function()  
   {  

/*Unload your widget here*/ 
   }; 
}  
// Ensure that there is a constructor function  
// available for the JavaScript class identified by  
// the 'jsClass' attribute. The constructor has no arguments. 
arrow = function ()  
{  
   return arrow1; 
}

Note:

• Do not directly register browser onload event handlers (for example,
window.addEventListener('load',myCallback,0);) to make the widget portable in many scenarios, including
dynamic run-time scenarios where the widget can be added to the document after the browser's 'load' event has 
occurred.

Instead, widgets must rely on the onLoad callback defined in this specification for notifying that the widget has
finished loading and is ready for rendering.
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• Do not directly register browser onunload event handlers (for example,
window.addEventListener('unload',myCallback,0);) to make the widget portable in many scenarios, including
dynamic run-time scenarios where the widget may be removed from the document much earlier than the page
is unloaded.

Instead, widgets must rely on the onUnload callback defined in this specification for notifying that the widget is 
being removed from the page.

For information on getMovieProps() see, Methods and properties.

8 Place the OpenAjax metadata XML file in the html5 directory.

9 Create the description.xml file.

For information on the schema for the description.xml file, see description.xml schema.

10 Place the description.xml file in the root directory (myhtmlwidget directory in this case).

11 Compress the root directory (myhtmlwidget directory) and change the extension of the file to .wdgt.

12 Place the .wdgt file in <Adobe Captivate installation directory>/Gallery/Widgets.

Sample descripton.xml file
If the main SWF file is ABC.swf, and the openAJAX XML file that you created is XYZ_oam.xml, then the 
description.xml is:

<?xml version="1.0" encoding="ISO-8859-1" ?> 
<!-- widget header  
     spec - compulsorily required. if not present will be treated as spec 1 which doesnt support 
html5 etc  
     version - widget version number 

     type - widget type  
-->
<widget spec="2" name="Certificate" description="This is a test for Process Tabs" 
uri="www.mycomapny.com" version="1.0" type="static">  
   <!-- Authors header - Can contain multiple authors
   -->  
   <authors>  
   <!-- Author header - author info  

   about is to show off some skills like i am cool widget developer. contact me for custom 
widgets  
   --> 
       <author name="Dominique Skyler" email="dominique@mycomapny.com" organization="MyCompany" 
uri="www.mycompany.com">  

<about>Widget Developer</about> 
</author>  

   </authors>  
   <!-- license info - author info 
   -->  

http://help.adobe.com/en_US/captivate/cp/using/WSc1b83f70210cd101-1347a03911dbe5ab9df-8000.html#WSc1b83f70210cd101-1347a03911dbe5ab9df-7ffe
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   <license name="CC" description="Creative Commons License" text="Feel free to use this" 
uri="http://creativecommons.org/licenses/by/3.0/"/>  

   <!-- different output formats supported 
each format has one directory in the wgt file  
paths can refer to other formats by using .. notation 

   -->  
   <formats> 

<!-- for the output format swf 
-->  
<format type="swf">  

<content source="ABC.swf"/> 
</format>  
<!-- for the html5 output --> 
<format type="html5">  

<!-- reference to the oam file --> 
<content source="XYZ.xml"/>   

</format> 
   </formats> 
</widget>

description.xml schema
widget

<widget> is the root element that defines a single widget and includes the following child elements:

• authors

• license

• formats

The <widget> element includes the following attributes:

authors

<authors> is the child element of the <widget> element and includes the following attributes:

Attribute Description Type Compulsory Value

spec Indicates the specification 
on which the XML is based 
on. The default value ‘2’ 
indicates that the XML file 
includes information on 
the HTML version of the 
widget.

Positive integer Yes 2

name Name of the widget. String No NA

description Description of the widget. String No NA

uri URL of the required 
website, for example, 
company’s website. 

String No NA

version Version of the widget. Positive integer. No NA

type The type of the widget: 
static or interactive.

String Yes • static

• interactive



312
Widgets

Last updated 10/10/2016

Note: All these attributes are ignored in this version of Adobe Captivate.

license

<license> is the child element of the <widget> element and includes the following attributes:

Note: All these attributes are ignored in this version of Adobe Captivate.

formats and format

<formats> includes the child element <format>, which includes the names of the SWF and HTML versions of the 
widget.

<format> element includes the following attribute:

content

<content> is the child element of <format> and includes the following attribute:

Attribute Description Type Required Default

name Name of the widget 
developer or author.

String No NA

email Email ID of the widget 
developer or author.

String No NA

organization Name of the organization 
of the widget developer or 
author.

String No NA

uri URL of the organization’s 
website or any other 
website the author wants 
to mention.

String No NA

Attribute Description Type Required Default

name A short name for the 
widget license.

String No NA

description Description of the widget 
license.

String No NA

text The license text that you 
want to display with the 
widget. 

You can also attribute 
licenses for any third-pary 
software used in the 
widget.

String No NA

uri Link to the website where 
widget users can find 
more information on the 
license.

String No NA

Attribute Description Type Required Value

type The type of the source: 
SWF or HTML.

String Yes • swf

• html5
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Defining visibility mode for widgets
By defining the visibility of widgets, developers can make certain facets of the widget available to users for preview or 
customization.

The visibility status of a widget can be set for the following views:

• Widget tab in the property panel (Stage state): Developers can display a snapshot of the widget in this tab.

• Widget Parameters tab in the property panel (Edit state): The snapshot of the object is usually hidden in this mode, 
and only the parameters that can be customized are displayed.

• During run time: Developers can define the visibility of an object based on certain parameters.

• Widgets panel: To display the SWF file in preview mode, set wm==preview in the code.

The visibility state is undefined for widgets. Use the movieHandle.widgetParams property to set the visibility state.

Use the following tips when making visibility decisions:

• Decide whether the widget is visible in the following cases:

• Edit area

• Property Inspector

• During run time

• Optimize the code for drawing. Excessive use of this code can slow down the player. The widget dialog box might
not disappear even after the OK button is clicked.

• Optimize the code in the OnEnterFrame function for the widget so that CPU use is kept to a minimum.

• The drawing code is CPU intensive. Store states inside variables and use them to draw only when required.

• To test for Flash-related issues, you can simulate the way the widget appears on stage within Flash without launching 
Captivate. Hard-code wm = 'Stage' and wm = 'Edit' in the OnEnterFrame function. Similarly, to simulate the
behavior of the widget at run time using Flash, hard-code widgetParam, and then test.

• Use the trace command to debug SWF files. Ensure that you delete the command during final testing as it degrades 
performance.

• Ensure that you publish to the following only:

• Flash 8 and later

• ActionScript 3.0.

Defining the preview movie
You can provide a dummy SWF file that appears in the preview area when the user selects a widget in the Widget panel. 
The dummy SWF file gives users an idea of how the widget works.

Attribute Description Type Required Value

source Refers to the SWF output 
or the HTML version of the 
widget.

String Yes Name of the SWF file or the 
metadata XML file of the 
HMTL version of the 
widget.
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Explore the PieChart.fla to get a better understanding of the procedure for defining a preview movie.

1 Open the PieChart FLA file for the pie chart in Flash. This file is available on your computer in the \\Program 
files\Adobe\Adobe Captivate <Version number>\Gallery\Widgets directory.

2 In the Property Inspector, select the movie outside the Stage. The name of the movie PieChart_prvw is displayed in 
the Property Inspector. 

3 Right-click (Windows) or Control-click (Mac OS) the frame containing the action, and select Actions.

4 Locate the following piece of code. if (wm == 'Preview') { PieChart_prvw._visible = true; }

The code sets the movie to preview mode and displays the movie in the preview area when the user selects the 
widget. If you set the visibility to false, the widget is not displayed in the preview area.

Sample code for defining visibility for different modes
function cpSetValue( variable:String , val ) 
{  
   if(variable == 'movieHandle' ) { 

movieHandle = val;  
mainmov = movieHandle.getMovieProps().variablesHandle; 
}  

    if (variable == 'widgetMode') 
     { 

widgetMode = val; 
     } 
}  
this.onEnterFrame = function()  
{  
var wm:String = widgetMode;//this variable will be provided by Captivate App or Captivate Movie 
   if(wm ==  undefined) 
   {  

wm = widgetMode; 
   }  
   if(wm == undefined) 

wm = 'Stage'; 

   if(wm == 'Edit')//Property inspection inside Captivate app 
   {  

button1.visible=true; 

   }  
   else if (wm == 'Preview') 
   {  

button1.visible=false; 
   }  
   else //this is the stage mode 
   {  

button1.visible=true; 
   }     
}
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How to create static, interactive, and question widgets 
in Adobe Captivate

Create static widgets
1 In Adobe Captivate, select File > New > Widget in Flash. 

2 In the Create New Widget dialog box, select Static in the Widget menu and then click OK.

3 In Flash, select Window > Actions.

4 The Actions panel appears with the template code for the static widget. Customize this code to create your widget.

Create interactive widgets
1 In an open project, select File > New > Widget In Flash. 

2 In the Create New Widget dialog box, do the following:

a In the Widget menu, select Interactive.

b In the ActionScript Version menu, select the ActionScript version that you plan to use when writing the widget 
code in Flash.

c Click OK.

3 In Flash, select Window > Actions.

4 The Actions panel appears with the template code for the interactive widget. Customize this code to create your 
widget.

Create question widgets
1 Select File > New > Widget In Flash. 

2 In the Create New Widget dialog box, select Question and then click OK.

3 In Flash, right-click (Windows) or Control-click (Mac OS) the Actions layer in the Timeline, and select Actions.

4 The Actions panel appears with the template code for the question widget. Customize this code to create your 
widget.

Note: You can add question widgets to question pools. They are treated as any other question slide.

How to add widgets to your Adobe Captivate project
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Add a widget from the Widget panel
By default, the widgets available in the Widget gallery appear in the Widget panel. The Widget gallery is created in the 
\\Program files\Adobe\Adobe Captivate 6\Gallery\Widgets (on Windows) and /Applications/Adobe Captivate 
6/Gallery/Widgets (on Mac OS) when you install the application. The Widget panel shows only those widgets created 
using the ActionScript version 3.0.

1 Select Window > Widget.

2 In the Widget panel, select a widget. A preview of the widget is displayed in the Widget panel.

Note: You can sort the widgets in the Widget panel as Static, Interactive, or Question by selecting the corresponding 
option in the menu.

3 Do one of the following: 

• Click Insert.

• Drag the widget to the slide.

4 In the Widget dialog box, specify the name of the course. For widget options, see Properties of widgets .

Add a widget from the Insert menu
1 Select Insert > Widget.

2 In the Open dialog box, browse to the folder containing the widget, and open it. 

3 In the Widget dialog box, specify the name of the course. For options for the widget, see Properties of widgets .

Accessing Adobe Captivate movie properties

MovieHandle
Adobe Captivate passes a handle to the widget during runtime using the cpSetValue function. The widget has to 
implement something like the following inside its cpSetValue function.function cpSetValue( variable:String , val ) { 
if(variable == 'movieHandle' ) { this.movieHandle = val; } }

function cpSetValue( variable:String , val ) 
{  
   if(variable == 'movieHandle' ) { 

this.movieHandle = val; 
} 
}

Methods and properties
Using MovieHandle, the following properties can be accessed.widgetParamsThe widget parameter provided by the 
widget during edit time. In AS3 it is a function, movieHandle.widgetParams(), and in AS2 it is a property, 
movieHandle.widgetParams.replaceVariables(var:String)Any string with variable names enclosed in $$ is replaced 
with the value of the variable at runtime. For example, movieHandle.replaceVariables( $$JohnDoe$$ scored 
$$cpQuizInfoPointsscored$$ out of $$cpQuizInfoTotalQuizPoints$$) returns "JohnDoe scored 10 out of 100" 
assuming that JohnDoe scored 10 points out of the total 100 that was set in Adobe 
Captivate.getContainerProps()Return the properties of the container. containerTypeReturns one of the following: 

http://helpx.adobe.com/en/captivate/using/properties-widgets.html#properties_of_widgets
http://helpx.adobe.com/en/captivate/using/properties-widgets.html#properties_of_widgets
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Slide, Slidelet, Zoom Destination Slide, Zoom Destination Slidelet, Movie (in case of rest of project 
widget)getSlideProps()Returns the properties of the slide containing the widget. The returned object has the following 
members.slideTypeReturns one of the following: Normal Slide, Question Slide, or Random Question 
Slide.slideHandleHandle to the slide functions. slideHandle supports the following functions: AddNoSkipFrame, 
startFrame, and endFrame.AddNoSkipFrame(frameNum:Number): No frame is skipped at runtime. frameNum refers 
to the frame number with respect to the slide indexed from 1.The Adobe Captivate SWF uses a functionality called 
“pacemaker” at runtime. When there are insufficient system resources, the pacemaker skips frames in a way that the 
user does not notice any glitch in the movie. However, it is possible that a frame containing actions might get skipped 
in the process. AddNoSkipFrame is used to ensure that pacemaker does not skip the specified frame.startFrame returns 
the frame number at which the slide begins. The indexing begins with zero.endFrame returns the frame number at 
which the slide ends. Indexing begins with 0.getMoviePropsReturns the properties of the Adobe Captivate movie that 
is closest to the hierarchy of the widget. The returned object has the following members:contentWidthWidth of the 
movie's content.contentHeightHeight of the movie’s content.variablesHandleSome Adobe Captivate System variables 
are accessed from here. For example, movieHandle.GetMovieProps().varaiblesHandle.myVar = 10;movieHandle 
<deprecated>Handle to the main movie object(rdMovie) in captivate runtime. Only some Adobe Captivate system 
variables are available here.IsWidgetVisibleReturns if the widget is currently visible on stage.isWidgetEnabledReturns 
whether the widget is enabled. A widget is considered as enabled when it is present on the slide or on the Timeline. All 
functions discussed work only if isWidgetEnabled() returns true.

Guidelines for using movieHandle in widgets
The value of movieHandle must be updated by the widget whenever cpSetValue('movieHandle', val) is called. When it 
is called multiple times, the value might not be the same every time. The variables must be updated for every call.

GetSlideProps and GetMovieProps consume a lot of memory resources. So, use these calls sparingly. Best practice is to 
cache the return value to a variable and use the variable. Refer to the following example.var slideProps:Object; var 
movieHandle:Object; function cpSetValue( variable:String , val ) { if ( variable == 'movieHandle' ) { movieHandle = val; 
} } function onWidgetEnabled(){ slideProps = movieHandle.GetSlideProps(); } function myWidgetFunction (){ 
if(slideProps.slideType == "Question Slide" ) { myLabel.Text = "" ; } }

Ensure that operations are carried out during Adobe Captivate runtime only when the widget is enabled. Operations 
on movieHandle (particularly variablesHandle) when the widget is not enabled might lead to unexpected results.

var slideProps:Object;  
var movieHandle:Object; 
function  cpSetValue( variable:String , val ) { 
if ( variable == 'movieHandle' ) {  

movieHandle = val; 

}  
}  
function onWidgetEnabled(){ 
   slideProps =  movieHandle.GetSlideProps(); 
}  
function myWidgetFunction (){ 
   if(slideProps.slideType == "Question Slide" ) { 

myLabel.Text = "" ; 
} 
}
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Chapter 12: Variables and Advanced 
Actions

Shared actions in Adobe Captivate projects
If you have Advanced Actions to be applied to similar scenarios within a project or across projects, you can save the 
script as a template, and reuse them wherever required. For example, an Advanced Action to show/hide items can be 
saved as a template and reused in click-reveal scenarios or a memory game.

Drag-and-drop Shared Actions from Library on to Objects. Now, you can parameterize variables. You can use variables 
as parameters and set different values while creating the project. Associate actions to different interactive triggers 
(Success and OnEnter of objects and Slides).

Note: You can open Adobe Captivate 7 projects in Adobe Captivate 8, and share the Advanced Actions that you have 
used in those projects.

More Help topics 
Advanced Actions

Share actions
1 Open the Advanced Actions dialog box (Project > Advanced Actions), open the action you want to share, and click 

Save As Shared Action.

2 In the Save As Shared Action dialog box, specify a name for the shared action, and type a description that describes 
the action, for example, the purpose of the action.

3 Type a description for each of the parameters used in the action. Generalize the description based on the scenario 
in which you are likely to use them. These descriptions are made available for you to select when you reuse the 
action.

http://helpx.adobe.com/en/captivate/using/advanced-actions.html
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The shared action becomes available in the Advanced Actions dialog box and as a resource in the Adobe Captivate 
library. Now your action is ready to be shared within a project or across different projects.

Best practices
• Insert all the required slides and objects in the project, and then share actions.

• Provide appropriate description for the shared action and parameters to help you easily identify them when you
want to reuse.

• Object groups can be used as parameters in shared actions. By doing so, you save both time and effort.

• Do not use custom effects in shared actions.

• Do not use placeholders as parameters in shared actions.

 Using shared actions within a project
1 Open the Advanced Actions dialog box (Project > Advanced Actions), and click a shared action from Create From 

list. The actions from the shared action are reflected in the dialog box.

For information on how to share actions, see Share actions.
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2 Do one or all of the following:

• Click the required objects from the drop-down lists.

• Add or delete actions as required.

3 Click Save Action to save the advanced action. If you have made many changes, and want to reuse the modified 
action, click Save As Shared Action.

Using shared actions across projects
You can reuse shared actions across projects in any of the following ways:

• Export and import the shared action from the Advanced Actions dialog box or from the Library. For details, see
Export and import shared actions .

• Copy and paste the shared action into the target project(s). For details, see Copy shared actions .

• Drag-and-drop the shared action by opening the source project Library from the target project's Library (Open
Library option). For details, see Drag-and-drop shared actions from an external Library .

Export and import shared actions
1 Export the required shared action as a .cpaa file and save it on your computer using one of the following methods:

• In the Advanced Actions dialog box, click the shared action from the Create From list, and click Export ( ).

• Click the shared action in Adobe Captivate Library, and click Export ( ).

Browse to specify the location for the .cpaa file, and click Export.

2 Import the .cpaa file into the required project using one of the following methods:

• In the Advanced Actions dialog box, click Import ( ).

• Click Import ( ) in Adobe Captivate Library.

3 Assign the shared action to the required objects:

a Click the object on stage and click Execute Shared Actions from the On Success list in the Property Inspector 
(Action accordion).

b Click the action from the Shared Action list, and click to edit the parameters.

http://helpx.adobe.com/en/captivate/using/shared-actions.html#main-pars_header_8
http://helpx.adobe.com/en/captivate/using/shared-actions.html#main-pars_header_5
http://helpx.adobe.com/en/captivate/using/shared-actions.html#main-pars_header_3
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c From the drop-down lists in the Parameter Value column, click the appropriate options for the corresponding 
Parameter Description.

Note: If the parent Advanced Action involves creating a variable, the variable is automatically created in the target 
project too.

Parameterize variables and literals
Now, you can apply parameters to variables and literals and add different values at runtime. You can also choose which 
objects and variables can be parameters. 

1 From Advanced Actions panel, choose any variable (such as Assign Action) and set value as variable and literals

2 Click Save as Shared Action button.

3 In the pop-up window, you can see both the variable and literals being listed as Parameters.

4 You can save the shared action.

5 When you execute this shared action on any object, you can set new parameter values for the object.

For information on how to create Shared Actions, see Share actions
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Copy shared actions
To copy, select the slide containing the object executing the shared action and also the other objects that are used as 
parameters in the shared action. For example, consider that the shared action 'CommonAction' shows the text caption 
'Welcome' and is assigned to a button 'Enter'. Ensure that you copy the text caption along with the button and then paste 
them into the target project. 

Drag-and-drop from an external project Library
Click the Open Library icon in the Library of the source project. Browse and select the project from which you want to 
import the shared action. The external Library opens in a separate window. Drag-and-drop the shared action into the 
Library of the source project.

Drag-and-Drop Shared Actions on to Objects
1 Create an advanced action and save as Shared action item.

2 Click Libraries icon, available next to Properties icon. By default, Libraries icon does not appear. Click Windows > 
Libraries to view.

3 Create an object in the slide.

4 Click the shared action from the Library and drag on to the object as shown in the screenshot below. The Shared 
Action is applied on the object.

Duplicate, Rename, and Delete shared actions
• To duplicate, right-click the shared action in Adobe Captivate Library, and click Duplicate.

• To rename, right-click the shared action in Adobe Captivate Library, and click Rename.

• To delete, right-click the shared action in Adobe Captivate Library, and click Delete.

View Usage details of Shared Actions
Click the shared action in Adobe Captivate Library, and click the Usage icon. Adobe Captivate lists the scenarios in 
which the shared action is triggered.

Tutorial on using scripts in Adobe Captivate projects
The following tutorial helps you get started with using scripting in Adobe Captivate.
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You have been asked to create a login slide with fields to enter the user name and password. 

When the user enters the correct values, the following actions take place:

• The project moves to the next slide.

• A text caption in the next slide displays the message, "Welcome <user name>".

• The default e-mail editor opens with the e-mail ID of the person that must be informed of the login. 

When the user enters incorrect information, a text caption is displayed asking the user to reenter information.

Create variables for the project
1 Select Project > Variables.

2 Create a variable named varUserName, with the value user. For more information, see Create a user-defined variable 
.

3 Create a variable named varPassword with the value password.

Create objects for the slides
1 In an open project, insert two text entry boxes for the user name and password. The text entry boxes must be set to 

act as form fields.

Note: To set a text entry box to act as a form field, select it and then deselect Validate User Input in the Property 
Inspector. 

2 Delete the Submit button from the User Name field.

3 Set the following options for user name:

• In Actions, go to On Success, and select No Action.

• Deselect Infinite Attempts.

Note:  This option is disabled automatically when you disable Validate User Input.

• In the Action area of the Property Inspector, select Continue in the Last Attempt field.

• Associate the field with the variable varUserName in the Var Associated field (General area of the Property 
Inspector).

4 Double-click the text entry field for the password, and set the following options:

• In the On Success field, select Continue.

• Deselect Infinite Attempts.

• In the After Last Attempt menu, select Continue.

• In Variable Associated, select varPassword.

5 Insert a text caption and do the following:

• Enter the following text on the caption: Invalid username/password. Please try again.

• In Name, change the name of the caption to FailureCaption. Deselect the Visible option. Doing so hides the 
caption until the conditions in the script enable the caption.

6 Insert a blank slide.

7 Insert a text caption with the text Welcome and the variable varUserName in the format Welcome 
$$varUserName$$.

http://helpx.adobe.com/en/captivate/using/create-user-defined-variable.html#create_a_user_defined_variable
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8 Save the project as variables.cp.

Create an advanced action for the login slide
The advanced action for the login slide must do the following:

• Check whether the correct information has been entered in the login and password fields.

• Move to the next slide if the information is correct.

• Stay at the login slide if the information is incorrect and display a text caption requesting the user to reenter the login
information.

1 Select Project > Advanced Actions.

2 In the script window, do the following:

a Click Conditional Actions as the Action Type.

b Specify the name of the script as ‘validate’.

c In the IF section, double-click the rows and select the appropriate options in the drop-down lists. See the 
following illustration for the options to select:
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d In the Actions section, double-click the first row and specify the action as Continue.

e Click the Else header, double-click the rows, and specify the appropriate options as shown below.

Now look at individual lines of the code to understand what they do.

The code checks whether the user has used the user and password login credentials in the respective fields.
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This project moves to the next slide if the user name and password are entered correctly. 

If the user information is incorrect, the project stays at the login slide. The text caption with the name FailureCaption 
is displayed. 

Create an advanced action for the e-mail and welcome slide
In the script window, do the following:

create a script named sequential action with the following code:

1 Click Standard Actions as the Action Type.

2 Specify the name of the script as ‘sequentialaction’.

3 Double-click the rows and specify the options as shown below.
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Now look at individual lines of the code to understand what they do.

On successful login, the code opens up the default e-mail editor with the e-mail ID xyz@company.com displayed in the 
To field. 

Displays the text caption containing the text, "Welcome <login name>".
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Variables and Advanced Actions

Apply the advanced action to the login slide
 Double-click the login slide, and set the following actions in the Property Inspector:

• On Enter: Select Continue.

• On Exit: Select Execute Advanced Actions, and in the Action menu, select Validate.

Apply the advanced action to the next slide after login
 Double-click the display slide, and in the Property Inspector, set the following actions:

• On Enter: Select Execute Advanced Action, and choose sequential action in the Action menu.

• On Exit: select Go To Next Slide.

Run the project, and check whether the aims of the project have been achieved.

More tutorials and examples
• Tips by Lieve Weymeis on:

• Customized course menu

• Creating test with multiple scores

• Conclusion based on multiple scores

• Partial scores with customized feedback

Edit or delete user-defined variables in Adobe Captivate
1 Select Project > Variables.

2 In the list of variables, select the variable you want to edit.

3 Do one of the following:

• To edit the variable, modify the value/description of the variable, and click Update.

• To delete the variable from the list, click Remove.

Note: You cannot delete system variables or variables that are being used by text captions. Removing a variable referenced 
by an action resets the action to Continue.

How to create user-defined variables in Adobe Captivate
1 Select Project > Variables.

2 In the Type menu, select User.

3 Click Add New, and enter the following information:

Name Specify a unique name for the variable. Ensure that the name is intuitive enough to help users guess its 
content. For example, a variable storing the version number of a product would have the name ProductVersion or 
VersionNumber. 

http://kb2.adobe.com/community/publishing/855/cpsid_85530.html
http://kb2.adobe.com/community/publishing/852/cpsid_85255.html
http://kb2.adobe.com/community/publishing/852/cpsid_85252.html
http://kb2.adobe.com/community/publishing/857/cpsid_85716.html
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Value Specify a value for the variable. The value that you specify occurs at all instances of occurrence of the variable 
in the document. You can also choose to set the value later by leaving this field blank. Variables with undefined 
values appear as blank spaces in the project.

Description Optionally, add a description for the variable. For example, you could add a note for the authors 
instructing them about when to use the variable.

4 Click Save.

Note: While assigning variables to text entry boxes, you can define the variable using the ‘x’ icon in the Property Inspector. 
For detailed instructions, see this blog by Lieve Weymeis.

Some of the variable names are reserved by ActionScript. Do not use the following variable names when creating your 
variable: 

alpha

currentframe

droptarget

focusrect

ramesloaded

height

buttonMode

byte

cacheAsBitmap

case

cast

catch

filters

final

finally

float

focusEnabled

focusRect

mouseX

mouseY

name

namespace

native

new

switch

synchronized

tabChildren

tabEnabled

tabIndex

textSnapshot

highquality

lockroot

name

parent

quality

rotation

char

class

const

constructor

contextMenu

continue

for

forceSmoothing

framesLoaded

function

get

goto

null

numChildren

opaqueBackground

override

package

parent

this

throw

throws

to

totalFrames

trackAsMenu

http://lilybiri.posterous.com/timesaving-tip-create-associated-variable-for
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Adobe Captivate SWF events
The following table lists the SWF events that are signaled by Adobe Captivate: 

soundbuftime

target

totalframes

url

visible

width

currentFrame

currentLabel

currentLabels

currentScene

debugger

default

graphics

height

hitArea

if

implements

import

private

protected

prototype

public

return

root

transform

transient

true

try

type

typeof

x

xmouse

xscale

y

ymouse

yscale

delete

do

double

doubleClickEnabled

dropTarget

dynamic

in

include

instanceof

interface

internal

intrinsic

rotation

scale9Grid

scaleX

scaleY

scenes

scrollRect

use

useHandCursor

var

virtual

visible

void

abstract

accessibilityProperties

as

blendMode

boolean

break

each

else

enabled

enum

export

extends

false

is

loaderInfo

long

mask

menu

mouseChildren

mouseEnabled

set

short

soundTransform

stage

static

stop

super

volatile

while

Event Signaled when

CPMovieStartEvent The movie starts playing

CPMovieStopEvent After the movie finishes playing

CPMoviePauseEvent The movie is paused

CPMovieResumeEvent The movie resumes playing

CPSlideEnterEvent While entering a slide

CPSlideExitEvent While exiting a slide

CPQuestionSubmitEvent A question is submitted and is evaluated.

CPAnswerSubmitEvent An answer is submitted for the interactive object.

CPEndPlayerScrubbingEvent Users stop scrubbing the playbar. 

CPHideRolloverEvent Users roll their mouse over a rollover object.

CPInteractiveItemSubmitEvent Users click an interactive item.

CPQuestionEventData Users submit an answer to a question.

CPQuestionSkipEvent Users skip a question.
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Subscribe to SWF events
Use the function AddEventListener to subscribe to SWF events.

Example

eventHandle.addEventListener(CPMovieStartEvent.CPMOVIESTARTEVENT,CPEventHandler);

where

eventHandle = movieHandle.getMovieProps().eventDispatcher;

This example illustrates how to print a message when Adobe Captivate movie starts playing.

function CPEventHandler(e:Event):void 
{  
    switch(e.type) 
    {  

case CPMovieStartEvent.CPMOVIESTARTEVENT: 
var startEvt : CPMovieStartEvent;  
startEvt = e as CPMovieStartEvent; 
trace("movie started playing");  
break;  

    } 
}

How to assign advanced actions to an event
You can define multiple actions that are performed sequentially after the occurrence of an event. You can assign 
multiple actions for the following:Interactive objectsYou can define the sequence of actions after the user performs an 
action on an object.SlidesYou can define the sequence of actions when the user enters or exits a slide.Question 
SlidesYou can define the sequence of actions after the user completes answering a question.

For more information on the actions available in Adobe Captivate, see How to use interactive objects for project 
navigation.

To assign advanced action,

1 In the Property Inspector (Window > Properties), select Execute Advanced Actions (in Action Area > On Enter).

2 Click the browse icon.

3 In the Advanced Actions dialog box, specify the details.

4 Click Close. 

CPQuestionSubmitEvent Users submit an answer to a question.

CPShowRolloverEvent Users stop rolling the mouse over a rollover object.

CPStartPlaybarScrubbingEvent Users start scrubbing the playbar.

CPVariableCreatedEvent Users create a variable in Adobe Captivate.

CPVariableValueChangedEvent Users change the value of a variable in Adobe Captivate.

Event Signaled when
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Advanced actions
You can use scripting in Adobe Captivate to do the following:

• Enhance the interactivity of Adobe Captivate projects by handling complex, and condition-based interaction
scenarios.

• Control the movie.

More Help topics 
Shared actions

Advanced Actions model
The scripting for the advanced actions model in Adobe Captivate is based on the Object-Event-Action model.

Events on an interactive object, such as mouse-clicks, trigger actions that are defined for that event. You can handle 
complex interaction scenarios by scripting your own actions and applying them to the various interactive objects. The 
scripting editor in Adobe Captivate helps you script custom actions for interactive objects.

You can use the following options to define actions for interactive objects in Adobe Captivate:

Conditional Action

Provide if … else conditions with 'and', or 'or' operators when scripting actions.

Standard Action

Use a single script to run multiple actions in a sequence. Although the user interface provides a way to run multiple 
actions, it is restricted to the actions available in Adobe Captivate. During scripting, it is possible for you to combine 
actions defined during scripting with predefined actions in Adobe Captivate.

Create advanced actions
1 Select Project > Advanced Actions.

2 Select the action type:

Conditional Action To create an if … else condition for your script.

Standard Action To customize one of the predefined actions in Adobe Captivate.

3 In the Action Name, specify a name for the action.

4 Click the add icon.

5 Complete writing the code with the supplied options. Any option that has not been assigned a value is indicated by 
the red icon. If you do not set these values, it results in an error when you try to save the script.

6 Click Save to save the script.

http://helpx.adobe.com/en/captivate/using/shared-actions.html
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Edit statements
• When editing a script, use the appropriate icons to add, remove, copy, cut, paste, insert, or move a statement (a line

of code).

• Use the drop-down list to change the type from Variable to Literal, or the other way round.

• To remove a decision, select the decision and then click the delete icon.

Edit/delete/duplicate advanced action
1 Select Project > Advanced Actions.

2 In the Existing Actions, select the action that you want to modify or delete.

3 Do one of the following:

• Use the appropriate icon at the upper-right corner to delete or duplicate the action

• To update the advanced action, use the appropriate menu icons to update the statements and then click Update.

Manage conditional actions
• To add a decision tab, click +.

• To delete a decision tab, click the tab, and then click '-'.

• To duplicate a decision tab, click the Duplicate Decision tab.

• To reorder the decision tabs, use the Move Left and Move Right icons.

• To duplicate the entire conditional action (all decision tabs), click the Duplicate Action icon at the top right corner
of the Advanced Actions dialog box.

• To preview the conditional action, click the Preview icon at the top right corner of the Advanced Actions dialog box.

Copy Advanced Actions
You can copy an Advanced Action into another project by copying the objects or slides associated with the Advanced 
Action and pasting them in the target project.

In a project, Advanced Actions can be called from various objects or triggered by many events. The following table 
summarizes the different scenarios and indicates whether the associated Advanced Actions can be copied:

While copying a slide or an object associated with an advanced action, ensure that you copy all objects or slides that are 
referenced within the Advanced Action. For example, consider that an Advanced Action "MyAction" is associated with 
a button. The action contains a 'Show' action that displays an image 'Flower', and a 'Hide' action that hides an image 
'Mango'. Now, if you need 'MyAction' in another project, copy the slide containing the button, and the slides containing 
the images 'Flower' and 'Mango'. Then, paste them into the project.

Advanced Actions associated with... Can be copied?

Objects Yes

Slides/Question slides Yes

Question pools No

Project Preferences (Quiz Pass/Fail) No
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Finding slides in which the script is used
1 Select Project > Advanced Actions.

2 In the Existing Actions, select the action.

3 Click Usage.

The slides in the project that use the selected script are displayed.

Apply advanced actions to slides
1 In the Property Inspector (Window > Properties), go to Action.

2 Select Execute Advanced Actions.

3 In Script, select the script that you want to run from the Action menu.

Apply advanced actions to interactive objects
1 In the Property Inspector (Window > Properties), go to Action.

2 In the action menu, select Execute Advanced Actions. Examples of actions are On Success, On Failure, and Lose 
Focus.

3 In Script, select the script that you want to run from the Action menu.

More Help topics 
Text captions

Widgets

If Advanced Action includes this action... ...then...

Play Audio The audio file is copied into the target project

Variables The variables are copied into the target project. If a variable 
configured in the Advanced Action does not exist in the target project, 
the variable is automatically created. If a variable exists with the same 
name, a new variable with the same name suffixed with a number is 
created.

Jump to Slide The Advanced Action is successfully copied only if the target slide is 
already copied into the target project.

http://helpx.adobe.com/en/captivate/using/text-captions.html#text_captions
http://helpx.adobe.com/en/captivate/topics/widgets.html
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Chapter 13: Creating a Quiz

Import questions from GIFT format files (Cp 7)
Instead of adding question slides in Adobe Captivate manually, you can choose to directly import question banks from 
GIFT files. Creating GIFT format files and importing questions from them is useful if you have to add large number of 
questions in your courses.

GIFT stands for General Import Format Technology using which you can create questions using plain text. These files 
can be saved as text files and can be imported into Adobe Captivate or Moodle.

If you are using Moodle as your LMS, it is most likely that you already have questions in GIFT format. You can export 
the questions from Moodle and import them into your Adobe Captivate courses. Or, you can directly import the files 
stored locally on your computer.

If you do not have the questions in GIFT format, you can quickly format your questions in the GIFT format. Then, save 
the files as simple .txt files, and then import them into Adobe Captivate. Here’s the generic syntax the GIFT format:

::Question title with double colons:: Question goes here {Answers go here}

This article helps you get started with GIFT formatting of your questions. For more information on GIFT format, see 
this article.

Supported question types

Question type Supported?

Multiple-choice

True/False

Short Answer

Matching

Essay

Description

Numerical questions

http://moodle.gprc.ab.ca/pluginfile.php/173928/mod_resource/content/1/GIFT%20Formatting%20Guide.pdf
http://docs.moodle.org/23/en/GIFT_format
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Import questions
1 Click Quiz > Import GIFT Format File.

2 Select the text file that contains the questions in the GIFT format and click Open.

The questions in the file are parsed and imported into Adobe Captivate. If the file contains questions and answers 
that are not supported in Adobe Captivate, an error message appears with the details.

After the questions are imported, you can specify the properties just like you do for any other Adobe Captivate question 
slide. For more information on quiz properties, see Setting quiz preferences for Adobe Captivate.

Note: You can also import questions in GIFT format into question pools. See Create question pools. 

How to enable learners to submit all quiz responses 
simultaneously
To enable users to modify their choice for an answered question, you can use the Submit All button. To insert the 
button, click Submit All in Preferences (Edit > Preferences > Settings > Submit All).

The Submit button on every question slide in the quiz is replaced with the Submit All button. Although users can see 
this button on every slide, Adobe Captivate displays appropriate warnings if they click the button without attempting 
all the answers. These messages can be customized in the Quiz Preferences (Edit > Preferences > Settings > Submit All 
Messages). You can also change the look and feel of the message box using the Object Style Manager (Edit > Object Style 
Manager > Runtime Messages).

Note: The answers are reported to LMS only after users click the Submit All button on the last question slide.

After users click the Submit All button on the last question slide, they can click Return To Quiz to go back and change 
their answers.

How to set up question slides with Adobe Captivate

Multiple-choice question slides
1 Insert the multiple choice question slide (Quiz > Question Slide > Multiple Choice).

The default multiple choice question contains a placeholder question and two answer choices: A and B.

2 Double-click the placeholder question on stage to edit it and type your question.

3 To add more answer choices, edit the number adjacent to Answers in the General accordion of the Quiz Properties 
panel (Window > Quiz Properties).

If the question has more than one correct answer, click Multiple Answers in the Quiz Properties panel.

Note: Select Shuffle Answers (Quiz Properties panel) if you want the choices to appear in a different order each time the 
user returns to this question.
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4 To specify the correct answer (s), click the radio button or the check boxes that correspond to the correct answer 
choices on stage.

5 Select Partial Score to assign partial scores to answers. Then, select the answer item, and specify the points you want 
to award in the Advanced Answer Option in Property Inspector.

Note: You cannot set partial scores for multiple choice questions in question pools. For information on question pools, 
see Using random question slides in Adobe Captivate.

The variable, cpQuizInfoQuestionPartialScoreOn, indicates whether or not partial score is enabled for a question 
slide.

6 Specify other properties for the question slide in the Quiz Properties panel. For detailed information, see Quiz 
properties.

True-or-false question slides
1 Insert the true/false question slide (Quiz > Question Slide > True/False).

The default true-or-false question slide contains a placeholder question and the answer choices: True and False.

2 Double-click the placeholder question to edit it and type your question.

3 To establish the correct answer, click the correct answer—True or False—on stage. You can replace True and False 
with Yes and No if required.

4 Specify other properties for the question slide in the Quiz Properties panel. For detailed information, see Quiz 
properties.

Fill-in-the-blank question slides
1 Insert the fill-in-the-blank question slide (Quiz > Question Slide > Fill-In-The-Blank).

2 To specify the word or a phrase that users need to fill out, do one or all of the following:

• Select a word or phrase, and click Mark Blank in the Quiz Properties panel.

• Type your question in such a way that the answer (a word or a phrase) replaces the word ‘blank’.

3 To provide multiple options that your users can choose from:

a Double click the word/phrase that is marked blank and then use the + button to add additional words/phrases 
that correctly fills in the blank.

b Select Dropdown list instead of User Input.

c Check the words/phrases that correctly fills in the blank.

d Select Shuffle Answ... if you want the choices to appear in a different order each time the user returns to this 
question.

Short-answer question slides
1 Insert the fill-in-the-blank question slide (Quiz > Question Slide > Short Answer).

2 On stage, double-click the placeholder question to replace it with your question. 

3 Double-click inside the answer box that is just below the question. The Correct Entries box appears.

4 Type the sentence or the phrases that constitute correct answers. Use the + button to add multiple entries.
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Matching question slides
1 Insert a matching question slide (Quiz > Question Slide > Matching).

2 In Column 1, click the placeholder text ‘type the item here’. You see that a drop down list appears adjacent to the 
placeholder text. This list helps you specify the correct match for your questions. When your users answer the 
question, the answer is validated against the correct answer you specify in this list.

3 Double-click the placeholder text to replace it with the word or phrase to be matched.

4 In Column 2, double click ‘type the answer here’ to replace it with the answer choices. Do not specify the correct 
match in Column 2; use the drop-down list to specify the correct match. 

5 To add more rows to the columns, specify the required number in the Column 1 and Column 2 fields in the General 
accordion of the Quiz Properties panel.

6 If you want the choices to appear in a different order each time the user returns to this question, click Shuffle 
Column 1 in the Quiz Properties panel.

Hotspot question slides
Hotspot slides contain areas that the user must identify. For example, you can ask the user to identify company products 
from images displayed on the slide. 

Answers to hotspot questions are correct if all the correct hotspots are clicked and none of the incorrect hotspots are 
clicked.

1 Insert a hotspot question slide (Quiz > Question Slide > Hot Spot).

The default hotspot slide contains placeholder text for the question and one hotspot area represented by a rectangle.

2 Double-click the placeholder question and replace it with your question.

3 Specify the number of hotspot areas you require in the Quiz Properties panel (the Answers field in the General 
accordion). You can add a maximum of 10 hotspot areas to a slide.

4 Add objects to the slide, for example, images, that you want to use as hotspots, and position the hotspot areas on 
these objects. 

5 For each hotspot area, set the properties (such as, fill, stroke, correct answer) using the Property Inspector. For more 
information, see Set hot spot properties.

6 Do the following in the Quiz Properties panel:

• To disable mouse clicks on slide areas other than hotspots, click Allow Clicks Only On Hot Spots.

• To customize the animation that appears when users click a hotspot, click Browse, and select the animation.

Set hot spot properties
Click the hotspot area and do the following in the Property Inspector:

1 In the General accordion:

If clicking the hotspot is to be marked as a correct answer, (in the General area of Property Inspector). 

• Click Correct Answer if the hotspot is to be marked as a correct answer when users click it.

• Click Show Hand Cursor Over Hit Area to make the hand icon appear when the mouse is moved over the
hotspot.

2 In the Fill & Stroke accordion:

• To change the default border color, select the hotspot and then use the Stroke option.
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Note: The border color isn’t displayed if the frame width is set to zero.

• Enter a number or use the slider to set the thickness of the hotspot border.

• To change the default, use the Fill option.

Note: The fill color isn’t displayed if the alpha is set to 0%. In the Color menu, specify a value for alpha. An alpha value 
of 0% creates an invisible (or transparent) fill; an alpha value of 100% creates an opaque fill.

3 To apply a shadow effect to hotspot area, click Enable in the Shadow & Reflection accordion. 

4 In the Transform accordion, specify the exact size and position of the hotspot area.

5 Click , where available, to apply the properties to multiple hotspot areas on the slide and across the project.

Sequence question slides
A sequence slide provides a list of items to be arranged in the correct order. For example, you can display a list of Polish 
kings and ask the user to arrange them chronologically.

1 Insert a sequence question slide ((Quiz > Question Slide > Sequence).

2 On stage, type the question replacing the dummy text.

3 Enter the list in the correct order. Adobe Captivate shuffles the answers in the list and displays them to users in 
random sequence.

4 In the Quiz Properties panel, specify the number of choices as Answers in the General accordion.

5 In the Answer Type list, specify the mode in which you want your users to arrange the answers in the list.

Rating scale (Likert) question slides

A rating scale slide displays a statement to which users specify their level of agreement. For example, you can add the 
statement, “I learned valuable information from this presentation” and give the user a range of responses to choose 
from: disagree, somewhat disagree, am neutral, somewhat agree, or agree. 

Rating scale questions are not graded and have no right or wrong answers. You can’t assign a point value or create 
branching on the basis of correctness. You can, however, decide what happens after the user completes the rating scale, 
such as continuing to the next slide, opening another project, or displaying a URL

1 Insert a Rating Scale (Likert) question slide (Quiz > Question Slide > Rating Scale (Likert)).

2 On stage, rephrase the instruction by replacing the default text. 

3 In the General accordion of the Quiz Properties panel (the Answers field), specify the number of rows of survey 
questions you require.

4 To edit the default agreement levels, double-click the text, and replace it with your text. 

You can edit the properties of the Likert Header that contains the agreement levels using the Property Inspector.

5 Complete the After Survey specification in the Action area of the Quiz Properties panel. The After Survey area is 
the same as the If Correct Answer area as described in the general workflow. 
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Question widget slides
You can insert question widgets created as SWF files in Flash into Adobe Captivate. Developers creating the question 
widget in Flash must use a template code for efficient integration of the question widget into Adobe Captivate. For more 
information, see Create question widgets.

1 Select Insert > Widget. 

2 In the Open dialog box, select the question widget that you want to insert.

3 In the Widget Question dialog box, do the following:

1 In the Name field, enter a name for the widget.

2 In the Question field, enter the question.

3 Assign the points that should be awarded to the user who answers the question correctly.

4 Follow the instructions in the Widget Parameters section to create the question.

Quiz properties
For each question slide, do the following in the Quiz Properties panel (Window > Quiz Properties):

1 In the General area:

• Toggle between Survey and Graded options using the Type list.

• (If type is Graded) Edit the number adjacent to Points (1 t0 100) to specify the score a user gets by answering a
question correctly.

• To award negative points to wrong answers, specify the required points as Penalty. Do not include the minus sign 
while specifying this value. The variable, cpQuizInfoNegativepointsOnCurrentQuestionSlide, helps you know if 
a question is configured for negative points.

• Specify the style for numbering the answer choices in the Numbering list.

2 In the Options area, specify the time limit and the captions to be included:

Clear Resets the slide to the initial view. It allows the user to start answering the questions on a slide by clearing the 
entered answers.

Back Takes the user to the previously attempted question slide.

Skip Allows the user to skip the question slide and move to the next slide.

Correct Displays a caption that lets users know that their answer is correct or incorrect.

Incomplete Displays a caption that lets users know that they did not complete the question when they click Skip.

Partial Correct Displays a caption to let users know that they have answered the question partially correct. This 
option appears only in multiple choice question slides for which partial score is enabled.

Time Limit Lets you specify a time limit by when the users have to anwer the question. You can specify the time in 
seconds (maximum 1800 seconds). You can also click Timeout Caption to display a message to users that the time 
allotted for the question has expired.

3 In the Action area, specify the number of attempts, failure levels, and the action to be taken after the users visit the 
slide and the last attempt. 

For more information, see On Success optionsand Last attempt options.

4 In the Reporting area, specify whether you want the answers to be reported along with other parameters chosen in 
quiz preferences (Edit > Preferences > Quiz > Reporting).
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Also, specify an Interaction ID. For more information, see Reporting options.

On Success options
In the Action area of Quiz Properties panel, select the action that should take place after the user provides the correct 
answer from the On Success menu:

Continue The movie moves to the next defined action.

Go To Previous Slide The previous slide is displayed to the user.

Go To Next Slide The movie moves to the next slide.

Go To Last Visited Slide Similar to a back button. The movie moves to the previously viewed slide.

Jump To Slide The movie moves to the specified slide.

Open URL Or File A web browser opens with the specified web page if the user has internet connectivity. Alternatively, 
you could open a specified file for the user.

Open another project Opens the specified Adobe Captivate project.

Send e-mail to A draft of the default e-mail editor opens with the e-mail address specified in the To field.

Execute JavaScript Adobe Captivate runs the specified JavaScript.

Execute Advanced Action Adobe Captivate runs the script written using the application.

Play Audio Adobe Captivate plays the specified audio when the users provide correct answers to the questions. The 
audio plays until users click another interactive object, or navigate away from the slide. If users do not interact, the 
audio plays only for the duration of the specified audio file and does not loop. 

Stop Triggered Audio Adobe Captivate stops the latest audio that was triggered by the Play Audio action.

Show When the user performs the required action on the object, the specified hidden object is made visible

Hide When the user performs the required action on the object, the specified object is hidden from the user.

Assign When the user performs the required action on the object, the value of the specified variable set inside the text 
caption.

Increment When the user performs the required action on the object, the value of the specified variable is incremented 
accordingly.

Decrement When the user performs the required action on the object, the value of the specified variable is 
decremented accordingly.

Multiple Actions When the user performs the required action on the object, multiple actions are performed in the 
order specified by the user.

Show Correct Message

On stage, select the Correct Caption and then replace the dummy text with a caption to display when the user supplies 
a correct answer.

In the Options area of the Quiz Properties, uncheck Correct (in the Captions section) to provide no feedback for a 
correct answer.
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Last attempt options
In the Action area of Quiz Properties panel, specify the following:

Attempts Select the number of times the user can attempt the question. After this number of attempts, the action you 
select from the Action pop-up menu occurs. 

Infinite The user can attempt the question any number of times. 

Failure Levels Specify the number of attempts for which the incorrect message is displayed. For example, if the level is 
set to 2, the error message is displayed for the first two attempts.

Last Attempt The options are the same as for the If Correct Answer area.

Retry Message Display a message when the user supplies an incorrect answer but there are remaining attempts 
available. This option is disabled if failure levels have been set.

In the Options area if Quiz Properties panel, specify the following:

Show Incomplete Message Select Incomplete to display a message (for example, “Please select an answer before 
continuing.”) when the user doesn’t supply an answer. This option is disabled if you have chosen the Drag Drop option. 
On stage, edit the dummy text to specify the appropriate message.

Show Timeout Message Select Timeout Caption to display a timeout message when the user fails to answer the 
question in the specified time. On stage, edit the dummy text to specify the appropriate message.

Reporting options
Use the Reporting area of the Quiz panel to specify the reporting options.

Report Answers Keep a quiz score.

Note: Interactive details like interaction ID, objective ID, and interaction type are not sent to the learning management 
system (LMS) if this option is not selected. However, details of the quiz, such as the total score, result, and quiz state, are 
still sent to the LMS.

Interaction ID If you want the Adobe Captivate project (SWF file) to send tracking information to your LMS, enter the 
interaction ID specified by your LMS.

Answer area properties
Name Enter a unique name for the answer area.

Note:  Although you can provide a name, the answer area is not available in Advanced Actions.

Style Select a style for the answer area. To define a new style, select Edit > Object Style Manager. For more information 
on object styles, see Working with object styles in Adobe Captivate.

Fill & Stroke Use this accordion to specify the fill and stroke properties for the answer area.

Fill Click to fill the answer area with a color and type the transparency (in percentage) in the adjacent field. You can 
also choose a gradient fill or a texture fill. See Apply gradient fillsand Apply texture fillsfor more information.

Stroke Click to fill the stroke with a color. Use the Width slider to specify the width of the stroke line. Choose a style 
for the Stroke line from the Style list.

Corner Radius Specify how much rounded you want the corners of the answer area to be.

Transform Use this section to define the exact size or location of the answer area in terms of pixels. You can also specify 
the rotation of the answer area in this section.

X Position of the text entry box on the X-axi
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Y Position of the text entry box on the Y-axis.

W Width of the text entry box.

H Height of the text entry box.

Constrain Proportions Maintains the height-to-width ratio of the text entry box when you resize it.

More Help topics 
Properties of widgets

Using random question slides in Adobe Captivate
Random question slides display questions that are randomly selected from a question pool to which they are linked. 
These slides help avoid quiz predictability. Random question slides do not have a Timeline of their own but use the 
timing of the question slide chosen at run time.

Note: Random question slides cannot be exported into Flash 8 or Flash CS3.

Create a question pool before creating a random question slide.

Create question pools
1 Select Quiz > Questions Pools Manager. 

2 Click the add button (+) above the left panel to add a question pool.

3 In the text box that appears, type a name for the question pool. 

4 Click the add button (+) above the right panel to add questions to the question pool.

The Insert Questions dialog box appears.

5 Select the question types and specify the number of questions slides of each type that must be inserted. 

6 To import large number of questions from GIFT format files, click Import GIFT File. Select the .txt file that contains 
the questions in GIFT format.

7 (Optional) Click the remove button (–) in the right or left panel to remove questions from the question pools or 
question list.

8 Close the Insert Questions dialog box. The Question Pool panel appears.

9 Select the question slide in the Question pool panel and add the quiz content on stage. For more information, see 
Set up question slides .

Note: Unlike the regular question slides, you cannot directly assign points or scores to the graded questions in question 
pools. You can assign the points to the random question slide using its Property Inspector.

10  Repeat the procedure to add more question pools and questions to them.

Question pools cannot be exported as XML. However, in the Question Pool Manager, you can do the following using 
the right-click menu:

• Drag questions across question pools.

• Copy questions from one pool and paste them into other pools.

• Lock, unlock, hide, and show questions.

http://helpx.adobe.com/en/captivate/using/properties-widgets.html#properties_of_widgets
http://helpx.adobe.com/en/captivate/using/set-question-slides.html#set_up_question_slides
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Note: You can copy, duplicate, or delete the question slides using the Question Pool panel.

Move question slides to a question pool
You can move a question slide or a group of question slides to a question pool. The question slide is removed from the 
main project and placed in the question pool. Alternatively, you can move question slides from a question pool into the 
main project, or to other question pools. 

Question pools do not support slide grouping, so all grouping information is lost when grouped slides are moved into 
pools. Consequently, when the question slides are moved back to the main project, they are not associated with any 
group.

To move question slides across multiple slide groups into a question pool, expand the group, select the question slides, 
and move them to the question pool. 

Note: You cannot undo the movement of question slides to question pools or to the main project.

1 In the Filmstrip, select the question slide that has to be moved to the question pool. 

If required, you can select multiple slides.

2 Right-click (Windows) or Control-click (Mac OS) the slide, select Move Question To, and then select the pool to 
which you want to move the slide. 

Move a question from one question pool to another or to the main project
1 In the Question Pool panel, select the question slide that has to be moved to the question pool or main project.

If required, you can select multiple slides.

2 Right-click (Windows) or Control-click (Mac OS) the slide, select Move Question To, and select either Main Project 
or Pool #.

Import questions from question pools in other projects
1 Select File > Import > Question Pools. 

2 Select the project to import, and click Open.

The question pools appear in the left panel of the Import Question Pools dialog box, and their corresponding 
questions appear in the right panel.

3 Select the questions to import into the current project, and click OK.

Note: When you import question pools, the associated Advanced Actions and Shared Actions are also imported.

Create random question slides
1 Click Quiz > Random Question Slide. A new slide appears in the Filmstrip that will be replaced at run-time with a 

question from the question pool that you select.

2 In the Quiz panel, do the following in the General area:

• From the Question Pool menu, select the pool from which the questions are to be randomly selected. See Create
question poolsfor detailed information.

• Click Add Questions to add additional questions to the pool that you selected.

• Select type as Survey or Graded.

Note:  If you select Survey, only survey questions from the question pool are randomly picked. Similarly, if you select 
Graded, only graded questions from the question pool are randomly picked. 
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If you select Survey and the question pool does not contain any survey questions, a blank slide is displayed to users.

• (If type is Graded) In the Points box, type a number or use the arrows to assign a point value. The range is 0 - 100.

3 In the Action area, do the following:

• For the options On Success and Last Attempt, use the menu to select one of the following actions:

Continue The movie moves to the next defined action.

Go to the previous slide The previous slide is displayed to the user.

Go to the next slide The movie moves to the next slide.

Go to the slide last visited Similar to a back button. The movie moves to the previously viewed slide.

Jump to slide The movie moves to the specified slide.

Open URL Or file A web browser opens with the specified web page if the user has internet connectivity.
Alternatively, you could open a specified file for the user.

Open another project Opens the specified Adobe Captivate project.

Send e-mail to A draft of the default e-mail editor opens with the e-mail address specified in the To field.

Execute JavaScript Adobe Captivate runs the specified JavaScript.

Execute Advanced Actions Adobe Captivate runs the script written using the application.

Assign When the user performs the required action on the object, the value of the specified variable set inside
the text caption.

Increment When the user performs the required action on the object, the value of the specified variable is
incremented accordingly.

Decrement When the user performs the required action on the object, the value of the specified variable is
decremented accordingly.

Multiple Actions When the user performs the required action on the object, multiple actions are performed in
the order specified by the user.

No Action Nothing happens.

Setting quiz preferences for Adobe Captivate

Set general quiz preferences
1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select Settings from the Quiz menu.

3 Enter information in the following fields:

4 Name Enter a name for your quiz. In a project with more than one quiz, naming helps identify a quiz easily.

Required Select one of the following options from the menu:

Optional – The User Can Skip This Quiz Allows users to skip the quiz and move on with the project.
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Required – The User Must Take The Quiz To Continue The project moves to the next slide only after the user has 
moved through all the question slides.

Pass Required – The User Must Pass This QuizTo Continue The project moves to the next slide only after the user 
has scored the required points in the quiz.

Answer All – The User Must Answer Every Question To Continue The project moves to the next slide only after 
the user has answered all the question slides. 

Objective ID The ID of the quiz to which the question slide belongs. In a master quiz containing multiple quizzes, 
an objective ID helps identify the quiz to which the question belongs.

Interaction ID Prefix Every action that the user performs on a question slide is assigned a unique interaction ID. 
For example, when the user attempts a question incorrectly the first time, and gets it right the next time round, 
Adobe Captivate generates two interaction IDs. Use this field if you want to customize the generated interaction IDs 
by prefixing them with the assigned characters.

Shuffle Answers For question slides with multiple answers, the answers are shuffled when the user attempts the 
same question slide the next time.

Submit All Enable this option to let users review and modify answered questions and submit all questions 
simultaneously. For more information, see How to enable learners to submit all quiz responses simultaneously.

Branch Aware Use this option to calculate the final score based only on the questions in the ‘branch’ that users have 
viewed. For example, consider that a project contains a quiz that branches into two modules that in turn contain a 
quiz each. If a user reaches the module with three questions and 10 points each, the total score is considered as 30 
points.

If this option is not enabled, the scores are calculated on the total number of questions in the project and not the 
module that users actually viewed.

Note: Pretests are branch-aware by default

Show Progress Select this option to show users which question number they are currently working on within the quiz. 
For more information, see Set progress indicator preferences.

Allow Backward Movement The user can visit the slides that were attempted previously.

Show Score At End Of Quiz Lets users view their score at the end of the quiz. You can customize the message that 
appears when the user passes or fails the quiz. Click Quiz Result Messages to customize the messages. You can also 
customize the options that you want displayed on the score slide.

Pass Message Customize the text that must be displayed when the user passes the quiz. Alternatively, you can disable 
this option if you do not want to display a message to the user.

Fail Message Customize the text that must be displayed when the user fails the quiz. Alternatively, you can disable this 
option if you do not want to display a message to the user.

E-mail Button Text Specifies the text for the E-mail button. Users can click the button to send an e-mail message to an
address you specify.

Display Score Displays the user’s score on the Results slide.

Display Maximum Possible Score The maximum score possible if all questions were answered correctly.

Display Number of Correct Questions The number of questions the user answered correctly.

Display Total Number of Questions The number of questions the user answered.

Display Accuracy The user’s score as a percentage.
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Display Number Of Quiz Attempts The number of user attempts.

Allow User To Review Quiz Users can review a quiz after they have completed attempting it and the score has been 
displayed. This option allows users to find out questions they answered incorrectly, and their correct answers. You can 
customize the messages provided in the feedback. Click Question Review Messages to customize the feedback 
messages:

Incomplete For incomplete answers.

Correct For correct answers.

Partial Correct For partially correct answers.

Incorrect The answer entered by the user, and the correct answer.

Hide Playbar in Quiz Select this option to hide the playbar on the question and result slides.

Note: Playbar is never displayed for pretest questions.

Quiz reviews
When users review the quiz after attempting to answer it, Adobe Captivate provides feedback graphically through 
images. 

Image/Message Meaning Displayed in Question Type...

Question is answered incorrectly All

Question is answered correctly All

Answer to the question is partially correct Multiple choice questions, if partial score is 
enabled.

For example, if two choices are correct 
answers for the question and user selects one 
of them. 

You did not answer this question completely

(Default message specified in Preferences > 
Quiz > Settings > Question Review Messages)

Question is skipped Any type of ‘graded’ question skipped by the 
user.

Skipped answers Matching question, Sequence question, 
Multiple choice questions, Fill in the blank 
questions with multiple answers

For example, when a user does not select an 
option in the combo box of a matching 
question.

Correct answer All

List of correct answers Matching question, Sequence question, Fill in 
the blank questions

For example, when users answer a sequence 
question incorrectly, the sticky icon provides 
the correct sequence of answers.
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These images are in the <installation folder>/Gallery/Quiz/QuizReviewAssets folder. You can replace the images 
(PNG, FLA, and SWF files) with custom images. However, ensure that you maintain the same size as the default ones 
for best results.

Set pass or fail preferences
You can set the minimum score required to pass a quiz. You can also define the action that should take place after the 
user passes or fails a test.

1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select Pass or Fail from the Quiz menu.

3 In the Pass /Fail options, do one of the following:

• Set the minimum percentage that the user must score to pass the quiz.

• Set the minimum points that the user must score to pass the quiz.

4 To decide the course of the project after the user passes a quiz, select an action in the If Passing Grade section.

Continue The movie moves to the next defined action.

Go To Previous Slide The previous slide is displayed to the user.

Go To Next Slide The movie moves to the next slide.

Go To Last Visited Slide Similar to a back button. The movie moves to the previously viewed slide.

Return To Quiz Takes users back to

• The last attempted question slide if users answered it incorrectly or skipped the question.

• The question after the last attempted question slide if users answered the question correctly.

Jump To Slide The movie moves to the specified slide.

Open URL Or File A web browser opens with the specified web page if the user has internet connectivity. 
Alternatively, you could open a specified file for the user.

Open Other Project Opens the specified Adobe Captivate project.

Send E-mail To A draft of the default e-mail editor opens with the e-mail address specified in the To field.

Execute JavaScript Adobe Captivate runs the specified JavaScript.

Execute Advanced Action Adobe Captivate runs the script written using the application.

Show When the user performs the required action on the object, the specified hidden object is made visible

Hide When the user performs the required action on the object, the specified object is hidden from the user.

Enable When the user performs the required action on the object, it activates another object in the project.

Correct answer (in a hotspot question) Hotspot question

Incorrect answer All

Incorrect answer (in a hotspot question) Hotspot question

This icon is displayed on all the wrong clicks 
by the user in a hotspot question.

Image/Message Meaning Displayed in Question Type...
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Disable When the user performs the required action on the object, it disables another object in the project.

Assign When the user performs the required action on the object, the value of the specified variable is set inside the 
text caption.

Increment When the user performs the required action on the object, the value of the specified variable is 
incremented accordingly.

Decrement When the user performs the required action on the object, the value of the specified variable is 
decremented accordingly.

Multiple Actions When the user performs the required action on the object, multiple actions are performed in the 
order specified by the user.

Apply Effect When the user performs the required action, the effect associated is applied.

No Action Nothing happens when the user exits the slide.

5 To decide the course of the project after the user fails a quiz, select an action in the If Failing Grade section. The 
actions are similar to those in the If Passing Grade section.

Specify messages and button labels
1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select Default Labels from the Quiz menu.

3 Change the default labels and style for the Submit, Submit All, Clear, Skip, and Back buttons in the Default Question 
Button Labels section. The four buttons are displayed on any question slide unless you have disabled them in the 
Property Inspector of that slide.

To create a new style for the labels, click Create New Style. See Working with object styles in Adobe Captivatefor 
more information.

4 Specify the text and the style to be used for the following:

Correct Message Appears when the user provides a correct answer.

Incorrect Message DEFINITION

Retry Message DEFINITION

Incomplete Message Appears when the user does not provide the complete answer to the question.

Timeout Message Appears when the user does not answer the question in the specified time. You can set the time 
using the Property Inspector of the question slide.

Partial Correct Message Appears when users select an answer that is partially correct in case of multiple choice 
questions.

Set progress indicator preferences
The progress bar displays the user’s progress through the questions. 

To set preferences for progress indicator, 

1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).
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2 In the Preferences dialog box, select Quiz > Settings.

3 In the Settings section, select Show Progress.

4 Specify a progress type. This decides how the progress bar displays the user’s progress through the questions.

• Relative Progress lists the current question and the total number of questions (for example, “Question 3 out of
10”).

• Absolute Progress lists just the question number (for example, “Question 3”).

Note: In branched quizzes, the branching path can be indefinite. For example, if users click button A, then they go to 
branch 1 else branch 2. In such cases, Adobe Captivate omits the total number of questions even if Relative Progress is 
selected.

Setting properties

Select the progress indicator on stage and then specify the properties in the Property Inspector.StyleSelect a style for 
the progress indicator. To define a new style, select Edit > Object Style Manager. For more information on object styles, 
see Content reference to: Object style.CharacterSpecify the options to customize the appearance of the text for your 
progress bar.

More Help topics 
Fix size and position of noninteractive objects

Insert question slides in Adobe Captivate projects
Ensure that you have set up the quiz preferences before inserting question slides. For information on quiz preferences, 
see Setting quiz preferences for Adobe Captivate.

1 In an open project, select the slide after which you want to insert question slides. 

2 Select Quiz > Question Slide.

3 Select the question types from the following and specify the number of questions slides of each type that must be 
inserted:

Multiple Choice

Users select one or more correct answers from a list.

True/False

Users choose either True or False (or Yes or No).

Fill-In-The-Blank

Users complete a blank in a sentence or phrase.

Short Answer

Users supply a word or phrase.

Matching

Users match entries in two lists.

Hot Spot

Users move the pointer over areas on the slide.

http://helpx.adobe.com/en/captivate/using/fix-size-position-noninteractive-objects.html#fix_size_and_position_of_noninteractive_objects
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Sequence

Users arrange listed items in the correct sequence.

Rating Scale (Likert)

Users indicate their level of agreement with statements.

Random Question

Displays questions that are randomly selected from a question pool to which they are linked. After you select 
Random Question, select the appropriate question pool in Linked Question Pool. For details, see Using random 
question slides in Adobe Captivate

Note: You can add a widget question slide only to question pools.

4 Specify the number of questions.

5 Specify whether the question is a graded, survey, or a pretest question, and click OK.

Graded Question To evaluate the user using the score you assign for the question. 

Survey Question To get user feedback.

Note: Graded option is not applicable for Rating Scale (Likert) questions.

Pretest To assess users’ knowledge about the subject before they take the course.

New slide(s) with placeholder questions and answers appear in the Filmstrip. For a description of a typical default 
question slide, see Default question slides.

In addition to the question slide that you have chosen, Adobe Captivate inserts a Quiz Results slide after the question 
slides. This slide summarizes the points that a user has scored across all the question slides. For more information on 
the quiz results slide, see Quiz results slide.

After inserting a question slide, replace the placeholder question and answers with the required text. For more 
information on setting up the different types of slides, see Set up question slides .

Default question slides
A typical default question slide contains placeholders for questions, answer choices, interactive buttons, and default 
captions.

http://helpx.adobe.com/en/captivate/using/set-question-slides.html#set_up_question_slides
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A Question type  B Quiz captions  C Quiz buttons  D Question placeholder  E Answer choices  F Review area  G Progress indicator  

Question type Indicates the type of question, such as, multiple choice and true/false that you chose while inserting the 
slides.

Question placeholder Lets you type your question by editing the default text.

Answer choices Let you type the answer choices that you want to provide your users by editing the default text.

You can increase the number of answer choices using the Quiz Properties panel.

Note: The way you designate correct answers for your question varies based on the question type. See Set up question slides 
for information.

Review area Displays a preconfigured message to your users when they review the quiz using the Review Quiz button 
on the Quiz Results slide. You can configure the message in quiz preferences (Edit > Preferences > Quiz > Settings > 
Question Review Messages).

Quiz buttons Lets users reset their answers, skip the question, go back to a previous question, and submit their answers. 
You can choose to hide or show these buttons using the Quiz Properties panel.

Quiz captions Help you provide appropriate messages to the users when they answer the quiz. For more information, 
see Quiz properties.

Progress indicator Indicates the question numbers to users in a relative or absolute way. You can disable the progress 
indicator or change the type in project prefernces. For information, see Set progress indicator preferences.

http://helpx.adobe.com/en/captivate/using/set-question-slides.html#set_up_question_slides
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Quiz results slide
The quiz results slide summarizes the performance of the user at the end of the quiz. You can hide or show the default 
parameters using the Quiz Properties panel.

Users can choose to continue with the course or review the quiz. When users review the quiz, the Review Area in the 
question slides displays a preconfigured message. The message indicates whether the user answered the question 
correctly, or skipped the question. You can customize the review messages in preferences (Edit > Preferences > Quiz > 
Settings > Quiz Review Messages).

By default, the quiz results slide is inserted after the question slides. You can click and drag the slide in the Filmstrip to 
any required location, for example, to the end of the course.

If you delete the slide, you can insert it again by clicking Show Score At The End Of The Quiz in project preferences 
(Edit > Preferences >Quiz > Settings).

How to insert pretests in Adobe Captivate
Pretests or preassessments are used to assess the knowledge of learners before they begin the course. Based on the 
points they score in the pretest, you can direct them to specific slides or modules in the course. This way the learners 
can make optimum use of their time by going through only that content that is relevant to them.

1 Click Quiz > Insert Question Slide.

2 Select the type of questions you want in the pretest and type the number of questions required.

3 In the drop-down list corresponding to each question type, click Pretest.

Differences between pretest and regular quiz questions:

Reporting pretest performance
You can get the following details of pretests reported to an LMS, Acrobat.com, Adobe Connect, or to any server on your 
network:

• Slide views

• User interaction data

Note: You cannot report pretest scores using Adobe Captivate. However, you can get the pretest scores reported to an LMS 
using the Mulit-SCO Packager in Adobe eLearning Suite. For more information, see Adobe eLearning Suite 
documentation.

To enable reporting for pretests, do the following:

1 Click Edit > Preferences > Quiz > Reporting.

Pretest Regular quiz question

Cannot contain random question slides Can contain random question slides

Edit Preset Action No advanced action associated by default

No On Success action On Success Action

Playbar is hidden always in the CPTX project (including regular quiz 
questions if any)

Playbar is available if it is enabled in Skin Editor. You can hide the 
playbar in regular quiz questions by selecting Hide Playbar In Quiz in 
Preferences.

http://help.adobe.com/en_US/elearningsuite/els/extensions/index.html
http://help.adobe.com/en_US/elearningsuite/els/extensions/index.html
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2 Select Enable Reporting For This Project, and choose an appropriate option. If you want the details to be reported 
to an LMS, click SCORM 1.2, SCORM 2004, or AICC based on the standard that your LMS supports.

3 Specify Success/Completion Criteria and Data To Report. For details, see Success/Completion criteria and Data to 
report .

Branching from pretests
1 Click one of the pretest question slides in the Filmstrip.

2 Click Edit Pretest Action in the Action accordion of the Quiz Properties panel.

The default action associated with pretests, CpPrestestAction appears in the Advanced Actions dialog box. 

3 Edit the advanced action by choosing appropriate values in the IF, Actions, and Else sections.

• By default, the Edit Preset Action includes the variable, cpQuizInfoPretestScorePercentage in the IF section. If
you have chosen points instead of percentage as the quiz score in the quiz settings, double-click the variable name 
and choose cpQuizInfoPretestPointScored.

• If you have assigned partial or negative scores for the pretest scores, you can also use other variables, such as,
cpQuizInfoQuestionPartialScoreOn.

Along with pretest, you can include regular quiz questions in individual modules in a course. In such cases, Review 
Quiz on the Result slide takes users to the quiz in the module they viewed and not to the pretest.

Variables for pretests
cpQuizinfoPretestPointsscored Returns the score that users get in the pretest as points. For example, 20.

cpQuizInfoPretestScorePercentage Returns the score that users get in the pretest as percentage. For example, 50%.

How to allow users to return to quiz
The scope of a quiz begins from the first question slide and ends when a user:

• reaches the result slide; or

• the slide before the result slide if the result slide is hidden.

If users navigate to a content or a remedy slide while still in the scope of quiz, you can choose to allow users to return 
to the quiz. To do so, assign the Return To Quiz action to one of the following:

• Any interactive object on the slide. The interactive objects can be click box, botton, or a text entry box.

• Slide Exit action.

Note: This option is not applicable for question slides.

You can assign the Return To Quiz action to existing or new interactive objects. When you assign the action to an 
existing object, Adobe Captivate associates the action only when users navigate to the slide from the quiz. Else, the 
Continue action is associated with the object.

For example, consider that you have a content slide that you want to use as a remedy slide for users who get a question 
wrong. When you change the action for the button on the content slide as Return To Quiz:

• The button behaves like a 'next' button when the users visit the slide for the first time. This behaviour helps you treat
the slide like a regular content slide.

http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#success_completion_criteria
http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#data_to_report
http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#data_to_report
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• The button takes the users back to the quiz.

Using Return To Quiz action
1 Configure your question slides to jump to the required remedy or content slides. To do so, click the Submit button 

and change the Action in the Property Inspector to Jump To Slide and choose the content slide.

2 Do one of the following actions:

• On the content slide or the remedy slide, click any interactive object and click Return To Quiz in the Action list
of the Property Inspector.

• Click the slide and then click Return To Quiz from the On Exit list in the Action accordion of the Property
Inspector.

When users click the interactive object associated with the Return To Quiz action, Adobe Captivate brings users back 
to:

• The last attempted question slide, if the answer provided by users earlier was incorrect or they skipped the question.

• The question after the last attempted question slide if it was answered correctly by users.

• Continues to the next slide if users had not attempted the quiz earlier.

Variable for quiz scope
cpInQuizScope is a read-only system variable that indicates whether users can return to the quiz from a slide. If the 
value of cpInQuizScope is:

• True, users return to the quiz when they exit the slide or click an interactive object that is assigned with the action
Return To Quiz.

• False, users navigate to the next slide in the project.
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Chapter 14: Advanced Editing and Project 
Reviews

How to review Adobe Captivate projects using the AIR 
Review application

Creating reviews for Adobe Captivate projects
After creating and editing an Adobe Captivate project, the author can publish the project for review on an internal 
server.

The project is published as a CREV file, a custom SWF file that is used for review.

Reviewers can review the CREV file by opening it in Adobe Captivate Reviewer, an AIR application. The installer for 
the application, AdobeCaptivateReviewer.air, is present in the location where you installed Adobe Captivate. You can 
also download it from the Adobe website: www.adobe.com/go/cp5_reviewerapp.

When you publish the project on an internal server for review, you can send the AIR application along with the e-mail 
notification for review. 

Note: Reviewers can install Adobe Captivate Reviewer without installing Adobe Captivate on their computers. However, 
they need to install Adobe AIR before installing the application. Adobe AIR can be downloaded for free from the Adobe 
website http://get.adobe.com/air/. Installing the AIR application is a one-time effort.

In a shared review where the author and the reviewers are on a common network, each of them can view comments 
posted by the other. The author, in addition, can accept, reject, or ask for feedback for the comments posted by the 
reviewers. 

Reviewers who are not a part of the shared network can export their comments to an XML file and send it to the author. 
The author can import the XML file into the project, and view comments in the timeline of the slides where the 
reviewers posted them.

During the review cycle, the author and reviewers can view the latest comments posted by refreshing the contents of 
the application. 

Sharing projects for review on an internal server
1 Select File > Send for Shared Review.

2 In the Send for Shared Review dialog box, type a name for the review file (CREV file) and click Next.

http://www.adobe.com/go/cp5_reviewerapp
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3 Use the following options to create the CREV file:Publish FolderThe location where the CREV file is published. 
Click Browse if you want to specify a different location for the generated files. Project Comments FolderSelect this 
option and choose a shared folder, either on your computer or on the network, for storing the comments. Ensure 
that you provide write permissions to the folder. The path to the shared location must begin with a double backslash 
(\\) on Windows. On Mac, prefix the path with smb://.If reviewers do not have access to a shared folder, you can 
choose not to specify a location for the comments. In this case, you can ask the reviewers to export their comments 
to an XML file and send the file to you.When there is no shared network, you can choose not to specify a location. 
The reviewer must export the comments and send them to you. When you import the contents of the XML file, the 
comments are embedded in your project.

4 Select Send Mail, and do the following:

• Select Attach Review (.CREV) File if you want to send the CREV file as an attachment along with the mail. Use
this option when the size of the CREV file is small enough to be sent by e-mail. E-mail filters are configured to
block e-mails that are larger than a specified size.

• Select Attach Adobe Captivate Reviewer if you want to send the AIR installer as an attachment. Use this option
the first time you send a CREV file to a reviewer.

5 Click Email. A draft of the e-mail appears.

6 Customize the body of the draft if you want to provide additional instructions to reviewers.

7 Enter e-mail addresses of reviewers in the To and Cc fields, and click Send.

Note: Do not edit the Adobe Captivate project during the review. If the project changes during the review, the posted 
comments might not appear at the intended locations. If you must edit the project, ask the reviewers to stop their work. 
Then start a fresh review after editing the project.

Set default project comments folder
You can set your preference for the Project Comments Folder in the Preferences dialog box. When you create new 
projects, this location is used when you publish a project for review on an internal server.

1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 Select General Settings.

3 Specify a location for the project comments folder in the Comments At field.

Reviewing Adobe Captivate projects
Ensure that you complete the following procedures before you review a project using the CREV file:

• Install Adobe AIR on your computer. Adobe AIR can be downloaded for free from the Adobe website
http://get.adobe.com/air/.

• Install the Adobe Captivate Reviewer application on your computer. The installer is provided to you by the author
of the Adobe Captivate project. If you have Adobe Captivate installed on your computer, you can locate the installer, 
AdobeCaptivateReviewer.air, at the location where you installed Adobe Captivate.

Install Adobe Captivate Reviewer
1 Double-click the AdobeCaptivateReviewer.air installer.

2 Click Install.

http://get.adobe.com/air/
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3 (Optional) Customize your installation preferences, and specify a location on your computer where to install the 
Adobe Captivate Reviewer.

Open the CREV file using Adobe Captivate Reviewer
1 Download the CREV file onto your computer.

2 Do one of the following:

• Double-click the CREV file . 

• Open Adobe Captivate Reviewer.

3 Based on how the CREV file is shared by the author, the following prompts appear:

• User details. Provide your name and email address. These details are used in your comments and helps authors
to associate your name with your comments.

4 Click Load Captivate Movie, and open the CREV file from your computer.

If the author has not specified a location for storing comments, a dialog box appears indicating that the comments 
have to be exported manually. Click OK.

Add comments to the SWF file
1 Click Play . The seek slider starts moving through the movie.

2  Click Add Comment at the point where you want to add your comment.

3 Add your comment in the Add Comment window.

4 Click Add to add the comment. A marker, indicated by a white dot, is added at this location in the commenting bar 
and the movie continues to play. 

5 Repeat steps 2, 3, and 4 to add more comments.

6 Click Save Comments . 

If the CREV file is hosted on an internal server with a shared network folder, the comments are automatically 
published to this folder. If a folder is not shared on the network, export the comments into an XML file and send it 
to the author. For more information on exporting comments, see Export comments to an XML file.

Edit comments in the SWF file
Comments added to the project are indicated as markers (white dots) at the specific location in the seek bar. To locate 
the comment that you want to edit, move your pointer over the markers. The comment added at a location is displayed 
when the pointer moves over it.

1 Click the marker on the seek bar whose comment you want to edit or delete. The comment is displayed in a pop-up 
window.

2 Edit the comment.

Note: If others have replied to a comment, only the latest comment in the comment thread can be edited.
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Import comments from an XML file
Authors and reviewers can import comments from XML files sent to them. Comments imported from XML files 
appear at the same location in the Timeline if the author has not edited the file during the review process. 

1 Click Import Comments .

2 Browse to the location of the XML file.

3 Click Open.

Authors can alternatively import comments from XML files using the Comments panel in Adobe Captivate.

Export comments to an XML file
Reviewers can export comments to an XML file and send it to the author. The author can import the XML file, provide 
feedback, export the file, and send it to the reviewers.

1 Click Export Comments.

2 In the Browse For Folder dialog box, select the folder where you want to save the XML file, and click OK.

Authors can alternatively export comments to XML files using the Comments panel in Adobe Captivate.

View or sort comments in the AIR application
The author and reviewers can view and sort comments using the AIR application.

Do one of the following:

• To view all comments added to the file, click Show All Comments.

• To sort comments by reviewer name, click Filter Comments. In the Reviewers pop-up menu, select names of the
reviewers to view comments posted by those reviewers.

View or sort comments in the Adobe Captivate project
Authors can view and sort comments in the Adobe Captivate project as well as the AIR application. Some of the options 
available for sorting are available only when the author uses Adobe Captivate to review the project.

1 To view comments added to the file, select Window > Comments. The Comments panel appears. Comments posted 
by reviewers are displayed in the panel.

2 In the View By menu, select one of the following options:

a Select Creation Time to sort comments chronologically.

b Select Reviewer to sort comments by the reviewers’ name.

c Select Status to sort comments according to their status (New, Accepted, or Rejected.)

View the latest comments
To view the latest comments posted by reviewers, click Refresh Comments.

Provide feedback on comments by reviewers
The author can accept, reject, or reply to comments posted by reviewers. Reviewers can view feedback posted by the 
author when they refresh the contents of their application. In the Filmstrip, a comment icon appears below the slides 
that contain comments.
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Comments are also visible on the timeline of individual slides. Authors can use Preview > Play This Slide to view the 
exact location of comments.

1 Open the project sent for review in Adobe Captivate.

2 Select Window > Comments. The Comments panel appears. Comments posted by reviewers are displayed in the 
panel. 

3 Select one or more comments for which you want to provide feedback, and do one of the following:

• Click the reject comments icon to ignore the comment. Optionally, enter a reason for ignoring the comment in
the pop-up window, and click Submit.

• Click the accept reviewer comments icon to accept the comment. Optionally, enter your feedback in the pop-up
window, and click Submit.

note: After you accept or reject a comment, the corresponding icon is displayed for the comment in the review
application, along with any comments.

• Click the Reply To Reviewers Comments icon to request clarification on the comment.

End reviews
In the Windows > Comments panel, click the End Review icon.

Skins
Adobe Captivate is shipped with a default set of skins. You can create a customized skin by changing the various options 
in the Skin Editor and saving the changes as a theme. Skins in Adobe Captivate include the following elements: playback 
controls, border, and table of contents.

Playback controls
The playback controls, consisting of a playbar and a progress bar, allow users to control the movie when it is played. 
The playbar displays buttons that control the movement of a movie. The progress bar tracks progress through the 
movie, showing the location of the current slide.

You can change the appearance of playback controls using the Skin Editor (Project > Skin Editor). You can customize 
the following options for playback controls:

Show Playback Control

Allows you to enable or disable the display of playback control options for users when the movie is played.

Hide playbar in quiz

Allows you to hide the playbar on question slides.

Note: Playbar is always hidden on pretest question slides.

Playbar Overlay

Allows you to place the playbar on top of the content. The playbar does not occupy any extra space. This option is useful 
if you want to keep the size of the movie as desired by the author.

Position

The position of the playbar with respect to the movie. You can place the playbar at any of the four sides of the movie.
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Layout

The alignment of the toolbar with respect to the movie. You can center the playbar controls, align them to left or right, 
or stretch them across the width of the movie.

Play/Pause

Allows your users to pause and resume the project.

Rewind

Replays the movie starting from the first slide.

Forward

Moves the playhead to the next slide.

Closed Captioning

Displays closed captions in your project. Use the Closed Captioning Settings dialog box to change the appearance of 
text in the closed captions.

Back

Enables users to go back to the previous slide.

Close

Allows users to exit the project. This button is important for full-screen projects because it allows the user to close the 
window quickly.

Mute

Allows users to turn off the audio.

Progress bar

Allows users to see their progress as they move through the project. They can also move back and forth in the project 
by dragging the playhead on the progress bar.

Fast Forward

Helps users to play the movie at twice or four times the normal speed.

Alpha

Indicates the transparency of the background color of the playbar.

No Tooltips At Runtime

Allows you to disable tool-tips if you think they do not fit the style of your presentation.

Theme
By default, the values of the settings in the Theme section are inherited from the theme currently applied to the project. 

Playbar Consists of buttons that control the movie when it is played. The Playbar menu lists the available skins for 
playbars in Adobe Captivate. 

Playbar Two Rows Displays the progress bar and playback controls in separate rows.

Playback Colors Indicates the colors used for various parts of the playbar. Click the boxes to change the colors. 

Note: When you save the theme of the project (Themes > Save Theme), changes to the theme settings in the Skin Editor too 
are saved.
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Project border
You can specify the style, size, texture, and width of the border around your project using the Skin Editor dialog 
box.Show BordersAllows you to enable or disable the borders for the movie. The buttons represent the sides of the 
project window to which you want to add borders. You can have borders on any combination of sides.StyleDetermines 
the shape of the border edges. You can choose to have a border with sharp or rounded edges.TextureAllows you to 
choosing an image for the texture of the borders. when you choose a texture, the color settings for the borders are 
overridden. To choose a specific color for your border, select None from the Texture list.WidthDisplays the thickness 
of the project border.ColorDisplays the color of the project border. You can use the color palette or use the eyedropper 
to select and copy a color on your screen.HTML Background ColorDisplays the color for the background area around 
the project.

Custom Flash playback controls
You can create custom Flash playback controls for your project. 

When creating custom SWF playback controls, follow these guidelines:

• Store the source FLA file of the skin in the following location: C:\Program Files\Adobe\Adobe Captivate
6\Templates\PlaybackFLA.

• Do not change the control names or symbols.

• The playbar must be present on the Stage with the instance name pbcBar_mc.

• The playbar must have the cpPlaybar identifier in the Library.

• The Export For ActionScript option must be selected for cpPlaybar in the Library.

• The actions at the action layer must not be changed.

• Store All Buttons must be stored at the Library root.

• Do not change the registration points. The registration point for every symbol is at the center (important for
editing), except for the following symbols:

• - icoProgress (upper-left)

• - icoThumb (top-center)

• - icoThumbBase (upper-left)

• Store the published SWF file of the skin in the following location:

<Installation Directory> \Gallery\Widgets\Playbars; /Applications/Adobe Captivate 6/Gallery/Widgets/Playbars
(on Mac OS). The Skin Editor picks the file from this location.

Flash button-naming conventions
Each SWF button contains three layers: a button, an icon, and an action layer.

The SWF filename consists of the following elements:

• Acronym for playback control (“pbc”)

• Playback element identifier (“Btn” for button, “Bar” for bar, and so on)

• Name of the button (“play”).
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Previewing skins
You can preview the changes you’ve made to your project skin from the Skin Editor dialog box. Whenever you set the 
button colors, add or remove menus, or configure the positions of playbars, the preview reflects the changes 
immediately.

The skin preview displays the first slide of the project. It displays the background image (if present) or the slide color. 
No objects on the first slide are visible in the skin preview.

The skin preview is slow if it has a large background image. To overcome this performance issue, when configuring the 
skins, you can insert a blank slide and set it as the first slide. Then, open the Skin Editor dialog box and configure the 

skin changes. After making these changes, you can hide the first slide. The next slide that has the background image appears 
in the skin preview for final viewing.

Save a customized skin
After you have customized the options in the Skin Editor, you can save your customized set of options as a theme. The 
theme is added to the Skin menu in the Skin Editor. The next time you want to use your customized skin for a project, 
select it from the menu.

1 Select Project > Skin Editor.

2 Customize the settings in the dialog box according to your preferences.

3 Click the save icon, and enter a name for your theme in the Save As dialog box. Click OK.

The new skin you saved is listed in the Skin list.

More Help topics 
Skin editor

Creating accessible projects in Adobe Captivate

Accessibility and Adobe Captivate
You can create output that is compliant with Section 508 for users who have visual or hearing impairments, mobility 
impairments, or other types of disabilities. You can also take steps at the design level to remove obstacles for people 
with disabilities viewing your Adobe Captivate projects. 

These solutions support government agencies in meeting their users’ needs through Section 508 compliance, as well as 
companies who are committed to improving accessibility.

Worldwide accessibility standards
Many countries, including the United States, Australia, Canada, Japan, and countries in the European Union, have 
adopted accessibility standards based on those developed by the World Wide Web Consortium (W3C). W3C publishes 
the Web Content Accessibility Guidelines, a document that prioritizes actions designers should take to make web 
content accessible. For information about the Web Accessibility Initiative, see the W3C website at www.w3.org/WAI.

https://helpx.adobe.com/captivate/using/skin-editor.html
http://www.w3.org/WAI
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In the United States, the law that governs accessibility is commonly known as Section 508, which is an amendment to 
the U.S. Rehabilitation Act. Section 508 prohibits federal agencies from buying, developing, maintaining, or using 
electronic technology that is not accessible to those with disabilities. In addition to mandating standards, Section 508 
allows government employees and the public to sue agencies in federal court for noncompliance. 

For additional information about Section 508, see the following websites:

What is Section 508- compliance?
Section 508 is part of the Rehabilitation Act of 1973 requiring that federal agencies develop, maintain, acquire, or use 
electronic and information technology to make the systems accessible to people with disabilities. The most recent 
(1998) version of Section 508 establishes enforceable, government-wide standards.

What does accessible mean?
In general, an information technology system is accessible for people with disabilities if it can be used in various ways 
that do not depend on a single sense or ability. For example, users should be able to navigate with a keyboard, in 
addition to a mouse (not with a mouse only). Also, the visual and auditory elements of a user interface must 
accommodate both hearing-impaired and visually impaired users.

What other types of assistive software do end users need?
Screen readers or text-to-speech utilities (which read the contents of the active window, menu options, or text you have 
typed) and screen review aids translate onscreen text to speech or to a dynamic, refreshable, Braille display. This 
assistive technology can provide keyboard assistance or shortcuts, captions for speech and sound, and visual warnings 
such as flashing toolbars. Tools available include Windows Eye and JAWS. 

What does Adobe Captivate do to be Section 508 compliant?
Selecting the Enable Accessibility option makes certain elements in Adobe Captivate projects accessible or open to 
accessibility technology. For example, if you select the Enable Accessibility and you have filled in the project name and 
project description text boxes in Project preferences, a screen reader will read the name and description when the 
Adobe Captivate SWF file is played.

The following Adobe Captivate elements are accessible when the Enable Accessibility option is selected:

• Project name (derived from Project Properties)

• Project description (derived from Project Properties)

• Slide accessibility text

• Slide label (derived from Slide Properties)

• Buttons

• Playback controls (The function of each button is read by screen readers)

• Password protection (If an Adobe Captivate SWF file is password protected, the prompt for a password is read by
screen readers)

• Question slides (Title, question, answers, button text, and scoring report are read by screen readers)

Output generated with the Enable Accessibility option is displayed by all supported browsers. However, your output 
may not be Section 508-compliant unless it is viewed with Internet Explorer. Internet Explorer is the only browser with 
support for MSAA (Microsoft Active Accessibility).

To access Flash files using a screen reader, users must have Flash Player 9 or later installed.
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The Access Board is an independent federal agency committed to accessibility for people with disabilities. For more 
information about making your output compliant, see the Access Board website (www.access-board.gov/508.htm).

Adobe Captivate accessibility web page
For the latest information on creating and viewing accessible Adobe Captivate content, visit the Adobe Captivate 
Accessibility Overview page on the Adobe website.

Creating accessible content

Create 508-compliant projects
Create an Adobe Captivate project using the Section 508 option to view and test the output. Generating the Adobe 
Captivate project updates source files containing information about your project and creates output files that you can 
publish for users. Read the tips for authoring and use the following procedure. 

1 In an open project that you want to publish as 508-compliant, select Edit > Preferences (Windows) or Adobe 
Captivate > Preferences (Mac OS).

2 In the Category panel, expand Project, and select Publish Settings.

3 Select Enable Accessibility in the Project panel.

Tips for creating 508-compliant Adobe Captivate SWF and HTML5 files
While Adobe Captivate Section 508 output is compliant for navigation, make sure that other elements are also 
compliant in your project. Assistive software must be able to “read” elements on the screen to visually impaired users. 
Use these tips to design accessible projects.

• In the Project preferences, write a meaningful name and description for your Adobe Captivate projects.

• For users with hearing impairment, add text equivalents for audio elements. For example, when delivering narrative 
audio, it is important to provide captions at the same time. One option is to place a transparent caption in a fixed
location on slides, then synchronize the text with the audio using the Timeline.

http://www.access-board.gov/508.htm
http://www.adobe.com/in/accessibility/products/captivate/best-practices.html
http://www.adobe.com/in/accessibility/products/captivate/best-practices.html
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• If your project contains visual multimedia, provide information about the multimedia for users with visual
impairment. If a name and description are given for visual elements, Adobe Captivate can send the information to
the user through the screen reader. Make sure that audio in your Adobe Captivate projects does not prevent users
from hearing the screen reader.

• Supply text for individual slides that screen readers can read.

• Ensure that color is not the only means of conveying information. For example, if you use blue to indicate active
links, also use bold, italics, underlining, or some other visual clue. In addition, make sure that foreground and
background contrast sufficiently to make text readable by people with low vision or color blindness.

• For users with either visual or mobility impairment, ensure that controls are device independent or accessible by
keyboard.

• Users with cognitive impairments often respond best to uncluttered design that is easily navigable.

• If mouse movement is critical in your Adobe Captivate project, consider making the pointer twice its normal size
for easier viewing.

• Document methods of accessibility for users.

• Avoid looping objects. When a screen reader encounters content meant for Flash Player, the screen reader notifies
the user with audio, such as “Loading….load done.” As content in a project changes, Flash Player sends an event to
the screen reader notifying it of a change. In response, the screen reader returns to the top of the page and begins
reading again. Therefore, a looping text animation on a slide, for example, can cause the screen reader to continually 
return to the top of the page.

• Accessibility in Adobe Captivate demos works better when all the slides have interactive content. If you are using
JAWS 6.1 or later, be aware that JAWS sometimes does not clear the Microsoft Active Accessibility (MSAA) tree. As
a result, the content of previous slides can replay when slides are continuous. This problem does not occur in JAWS 
4.5.

• Ensure that the Accessibility dialog box is not blank. Import slide notes or type appropriate instructions in the
Accessibility dialog box.

• Time your slides and objects appropriately. Provide enough time for the user/screen reader to read the contents on
the slide. You can make use of interactive objects; interactive objects pause the movie until the user interacts.

If you do not factor in sufficient time, the movie advances to the next slide before all objects can be read. In such a
case, some objects on the next slide may not be read by screen readers.

• Specify alt-text for images. Otherwise an image is read as just 'image' by the screen readers.

Specifying Tab order for interactive and non-interactive objects
When using a screen reader, your readers can use:

• The Tab key to navigate through interactive objects. Specify the Tab order by clicking the up and down arrows. The 
Tab key does not work for non-interactive objects. The Tab order works for questions as they are non-interactive.
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• The arrow keys to navigate through interactive and non-interactive objects. For HTML5, use the up and down
cursor keys.

If your course requires your users to navigate through only interactive objects, you can include appropriate instructions 
as accessibility text (Accessibility dialog box).

By default, the interactive objects are read based on their z-order. You can change the order in which a screen reader 
must read the interactive objects when users press the tab key. 

1 Click Tab Order in the Property Inspector of the slide.

All interactive objects, except click boxes and rollover objects, are listed in the Tab Order dialog box. Click boxes are 
not visible at runtime and therefore are not listed in the Tab Order dialog box. For Rollover objects, add accessibility 
text to Rollover Area and users can use arrow keys to navigate to the object.

2 In the Tab Order dialog box, use the arrow keys to place the components in the order in which you want them to be 
read.



368
Advanced Editing and Project Reviews

Last updated 10/10/2016

Add accessibility text to slides
A screen reader can read aloud text that appears on the computer screen. Screen readers are useful for people with 
visual impairment. In Adobe Captivate, you can write text describing each slide for screen readers to read aloud.

1 Open the slide to which you want to add accessible text. 

2 In the Property Inspector, click Accessibility. 

3 Type the text that you want the screen reader to read aloud.

4 To use the slide notes (Text-to-speech and closed captioning included), click Import Slide Notes, and click OK.

Customize accessibility text for objects
You can add accessible text to individual objects on a slide. When the object appears in the movie, the screen reader 
reads that text aloud. If you do not specify accessible text for an object, the screen reader reads the default text. For 
example, if the object is an image, it reads Graphics Image. This default text is generally not sufficiently descriptive to 
help a visually impaired user. Also, objects other than text captions and text entry boxes do not contain any text. 
Accessible text for such objects can help users understand their purpose in the movie.

1 Select the object whose accessibility text you want to customize.

2 In the Property Inspector, click Accessibility.

3 Deselect Auto Label. When Auto Label is selected, the text in the object is read aloud by the screen reader.

4 In the Item Accessibility dialog box, do the following:Accessibility NameEnter the accessibility name. For a text 
caption, you can enter “This text is in a caption,” for example.Accessibility DescriptionAdd a description to clarify 
information for the person using the screen reader. For example, consider the text caption “Select File > Edit Image.” 
You can change the text to “From the File menu, select the Edit Image command. This command is available only 
when an image is selected on the slide.” 

Testing accessible content

Tips for testing
If you are designing your Adobe Captivate project to work with screen readers, download several screen readers. Then 
test your project by playing it in a browser with the screen reader enabled. Make sure that the screen reader is not 
attempting to “talk over” places in your project where you have inserted separate audio. Several screen reader 
applications provide a demonstration version of the software as a free download. Try as many as you can to ensure 
compatibility across screen readers.

If you are creating interactive content, test it and verify that users can navigate your content effectively using only the 
keyboard. This requirement can be especially challenging, because different screen readers work in different ways when 
processing input from the keyboard. For this reason, your Adobe Captivate content might not receive keystrokes as you 
intended. Make sure to test all keyboard shortcuts.

About screen reader technology
Screen readers are programs designed to navigate through a website and read the web content aloud. Visually impaired 
users often rely on this technology.
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JAWS®, or Job Access with Speech, from Freedom Scientific, is one example of a screen reader. You can access the JAWS 
page of the Freedom Scientific website at http://www.freedomscientific.com/products/fs/JAWS-product-page.asp. 
Another commonly used screen reader is Window-Eyes®, from GW Micro®. To access the latest information on 
Window-Eyes, visit the GW Micro website at www.gwmicro.com. For Windows users, Microsoft provides a free, 
downloadable product called Microsoft Reader that contains a text-to-speech component. For more information, visit 
the Microsoft website at www.microsoft.com.

Because different screen readers use varying methods to translate information into speech, the way your content is 
presented to users can vary. As you design accessible projects, keep in mind that you have no control over how a screen 
reader behaves. You have control only over the content, not the screen readers. You cannot force screen readers to read 
specific text at specific times or control the manner in which that content is read. It is important to test your projects 
with various screen readers to ensure that they perform as you expect.

More Help topics 
Learning management system (LMS)

Create a table of contents (TOC) with Adobe Captivate
You can generate a table of contents (TOC) automatically for your Adobe Captivate project. The hierarchy of slides in 
the project is preserved in the TOC. Grouped slides are displayed as subentries under the group name. The name of the 
slides and the group are automatically added as in the project. 

You can specify the position of the TOC with respect to the main slide during editing. At run time, clicking the various 
headings in the TOC displays the corresponding slides in the main panel. 

You can configure the appearance of the TOC using the various available options. You can then save the TOC as a theme 
along with the other skin items like playback controls and borders.

The TOC entry corresponding to the slide displayed is highlighted in the TOC panel as the movie runs through the 
slides. 

A check mark in the Status panel indicates the slides that the user has completed viewing. You can choose to configure 
the project for self-paced learners so that they can start viewing slides from where they left off earlier.

Create a table of contents (TOC)
1 Select Project > Table Of Contents.

2 Select Show TOC if you want to generate the TOC and display it in the project. The slide groups and slides are 
displayed in the same order as they appear in your project, along with their titles. 

Organize a table of contents (TOC)
Grouped slides are classified according to their hierarchy in the project. The slides of a group appear under the group 
name in the TOC in the same order.

You can change the hierarchy and classification of the slides in the TOC. The reorganization affects only the TOC and 
not the order of the slides in the project. You can also choose to hide certain slide entries in the TOC. These entries are 
not displayed in the TOC when the project is played.

Depending on your preferences, you can reorganize the TOC using one or more of the following procedures:

• To move a slide to the next sublevel in the hierarchy, click Move TOC Entry Right.

http://www.freedomscientific.com/products/fs/JAWS-product-page.asp
http://www.gwmicro.com
http://www.microsoft.com
http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#learning_management_system_lms
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• To move a slide to a previous level in the hierarchy, click Move TOC Entry Left.

• To move the slide entries up and down, click Move TOC Entry Up or Move TOC Entry Down.

Note: You can also move the TOC entries by dragging them to another location.

• To create a group within the TOC, click Create Folder Rename the topic in the TOC, and organize slides under it.
You can create up to five sublevels in the TOC menu.

Note: Grouping slides in the TOC does not group them in the project.

• To remove a TOC entry, select the entry in the TOC, and click Delete TOC Entry ( ).

Note: Hiding a TOC entry does not delete the slide from the project.

• To hide the TOC entry for a slide when the project is played, deselect the option for that slide under the eye icon.
The slide is not removed from the project.

• To discard your changes to the TOC, and display the default entries, click Reset TOC.

When you reorganize a project after creating the TOC, the changes are not automatically reflected. Reset the TOC
to view the changes. Any new slide added after creating the TOC is displayed as a hidden entry after you reset the
TOC. Enable the TOC entry by selecting the check box under the eye icon.

Note: If you do not want to preview changes to the skin when you change an option, click Settings, and in the TOC Settings 
dialog box, deselect the Auto Preview option.

Customize the table of contents (TOC)
You can customize the following for the TOC:

• Appearance of the TOC.

• Position of the table of contents with relation to the main panel playing the movie. You can also choose to overlay
the TOC on the main panel playing the movie or display the TOC as a separate panel during run time.

• Display the project information such as the details of the company or the person creating the project in the TOC
panel.

• Display the status of the slides for users during run time. When the Status option is turned on, a check mark appears 
next to slides that the users have completed viewing.

• Allow users to start viewing the project from the slide at which they left off previously when they run the project
again.

1 Select Project > Table Of Contents.

2 Click Settings. The TOC Settings dialog box appears.

3 Set the options for the following:

Style

Select Overlay to overlay the TOC panel on the main movie panel. Ensure that the contents of the movie are not 
hidden when you choose this option. You can use background transparency to achieve optimum results for slides 
with overlay.

Select Separate to display the TOC panel separately from the main movie panel.

Position

Left or right position for the TOC panel.

Background
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Background color of the TOC panel.

Default

Background color of the TOC menu.

Active

Background color of the active TOC entry during run time. During run time, the TOC entry corresponding to the 
slide displayed is highlighted in the TOC panel. This entry is called the active TOC entry.

Rollover

Background color of the TOC entry when the user moves the pointer over the entry at run time.

Gradient

Color gradient for rollover.

Heading

Background color of the header and footer.

Outline

Border color of the TOC menu.

Alpha

Transparency of the background of the TOC menu.

Use the Transparency option to create visually striking TOC panels. You can define an optimum level of 
transparency for the background color of the TOC panel and menu.

Width

The width of the TOC pane in pixels.

4 Modify the settings in the Theme section to configure a different look- and- feel for the TOC. By default, the values 
for these settings are derived from the theme that is currently applied to the project.

Color Click the boxes to modify the colors for various elements of the TOC.

Font Settings The TOC entry level for which you want to specify the font style.

Font The font family and style for the level selected in the Font Settings list.

Note: When you save the theme of the project (Themes > Save Theme), changes to the theme settings in the TOC too 
are saved.

Display project information in the TOC panel
1 Select Project > Table of Contents.

2 Click Info. The TOC Information dialog box appears.

3 Enter the details of the author or company in the respective fields.

4 Click Project Information to use the information that you set in the Project Information menu of the Preferences 
dialog box. The information from the Preferences dialog box is added to the corresponding fields.

5 Click Clear Information to clear information that you have entered in the different fields.

6 Select Auto Preview to have the preview panel reflect a change as soon as you complete that change in a dialog box.
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7 In the Photo section, click the browse icon to select an image to display on the panel. This image can be the logo of 
your organization, or a snapshot of a prominent slide in the project.

8 To change the character format for the project information fields: Click Font Settings to specify the font style for the 
project information.

a Select the field from the Font Settings list.

b Select a font family in the Font list and click on a style: regular, italics, or underlined.

c Specify the size and the color for the characters.

Display the duration and status of the slides during run time
1 Select Project > Table Of Contents.

2 Click Settings. The TOC Settings dialog box appears.

3 In Runtime Options, select Show Duration to display the duration of the slides when the movie plays.

4 Select Status Flag to flag slides that have been viewed with a check mark.

When the Status option is selected, a check mark appears next to slides that the users have completed viewing.

5 Select Clear Button to display the Clear Button to the user during run time. Clicking the Clear button removes all 
the status flags from the movie.

Enable search in the TOC
Adobe Captivate searches for content both within the slides and their labels. Question slides are searched only if you 
enable the option in the settings panel.

1 Select Project > Table Of Contents.

2 Click Settings. The TOC Settings dialog box appears.

3 Select Show Search to provide users with a search field in the TOC.

4 Select Search Quiz to allow users to search content in question slides.

Enable or disable navigation
When you disable navigation, users can’t navigate on their own using the TOC. 

1 Select Project > Table Of Contents.

2 Click Settings in the TOC panel.

3 Use the Enable Navigation toggle.

Enable or disable preview
The Preview panel shows how the TOC looks every time you make edits in the TOC Settings or the TOC Information 
dialog boxes. Previewing helps you explore various options before you arrive at one that best suits your requirements. 
If you have already decided on the settings for the TOC, you can disable this option in the corresponding dialog box.

1 Select Project > Table Of Contents.

2 Click Settings. The TOC Settings dialog box appears.

3 Deselect Auto Preview.
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Allow users to resume sessions
In a self-paced learning scenario, you can set an option to allow users to resume viewing a project from where they left 
off earlier. The status flag is not reset after the project is closed. When the user plays the movie again, the project 
resumes playing from the first slide that is not flagged. 

1 Select Project > Table Of Contents.

2 Click Settings in the TOC panel.

3 Select Self-Paced Learning.

Save the TOC settings as a part of the theme
Changes to the TOC settings, along with other skin settings such as playback controls and borders can be saved as a 
theme. The save themes then can be reused in other projects.

1 After you change the TOC panel and other options in the Skin dialog box, click the save icon.

2 Enter a unique name for the theme and click OK.

More Help topics 
Skins

Save a customized skin

Check spelling and perform find and replace operations 
in Adobe Captivate

Check spelling
You can check spelling in most places where text occurs in your projects, including captions, slide notes, slide names, 
text animations, and quizzes. 

Before checking spelling, set the options for spelling checking. 

1 Open an Adobe Captivate project.

2 Select Project > Check Spelling. Alternatively, you can press F7. 

3 When Adobe Captivate encounters an unrecognized word, the word appears in the Not In Dictionary text box. 
Select the appropriate options based on how you want the discrepancy handled:

Ignore Once Ignores this instance of the unrecognized word.

Ignore All Ignores all instances of the unrecognized word.

Add To Dictionary Adds the unrecognized word to your personal dictionary. The personal dictionary added.txt can 
be found on your computer at the following locations:

• On Windows: \\Documents and Settings\<user name>\Local Settings\Application
Data\Adobe\Linguistics\Dictionaries\Adobe Custom Dictionary\<spelling language>

http://helpx.adobe.com/en/captivate/using/skins.html#skins
http://helpx.adobe.com/en/captivate/using/skins.html#save_a_customized_skin
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• On Mac: <boot>\Users\<user>\Library\Application Support\Adobe\Linguistics\Adobe Custom
Dicitonary\<spelling language>

 You can add words or remove them from the personal dictionary by opening the added.txt file in Notepad, making 
the changes, and saving the file. Words added in this file are not marked incorrect during a spell check by Adobe 
Captivate.

Delete Removes the unrecognized word.

Change Replaces this instance of the unrecognized word with text that you type in the Not In Dictionary text box 
or with the text that is selected in the Suggestions list.

Change All Replaces all instances of the unrecognized word in the same manner.

4 (Optional) The default dictionary used to check spelling is English. To change the language, click the pop-up menu 
in Main Dictionary Language and select a new language. 

5 (Optional) If you want to change how spelling is checked, click Options.

6 When you finish, click Close.

Set spelling check options
Adobe Captivate lets you check spelling in most places where text occurs in your projects, including captions, slide 
notes, slide names, text animations, and quizzes. Before using the spelling checking feature, review the spelling check 
options and change them if necessary.

1 Open the project and select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select General Settings from the Global menu.

3 Click Spelling Preferences.

4 In the Spelling Options dialog box, set the following options:

Ignore Capitalized Words Omits any words from the spelling check that begin with a capital letter such as “Adobe.” 
Consider this option if your text contains many proper nouns.

Ignore All-Caps Words Omits any words from the spelling check composed of all uppercase letters such as “MIDI.” 
Consider this option if your text contains many acronyms.

Ignore Words With Numbers Omits any words from the spelling check that contain digits such as Q2. Consider this 
option if your text contains many symbols or code with numbers.

Ignore Mixed Case Words Omits any words from the spelling check composed of uppercase and lowercase letters 
such as “ActionScript.” 

Ignore Domain Names Omits any words from the spelling check that appear to be Internet domain names such as 
www.adobe.com.

Report Doubled Words Notifies you during the spelling check of any words that appear twice in a row such as “the 
the.” 

Case Sensitive Analyzes capitalized and lowercase versions of words separately. For example, “chicago” and 
“Chicago” would each be checked and the lowercase spelling would be identified as a misspelled word. 

Suggest Split Words Provides two-word suggestions for any misspelled word that appears to be two joined words 
such as suggesting “press the” for “pressthe.” 

Main Dictionary Language Specifies the dictionary language used during the spelling check. The default dictionary 
is English. To change the language, select the new language from the list.

5 When you finish, click OK.
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Change dictionary
By default, the spelling checker uses the English (United States) dictionary. You can change to any dictionary installed 
on your computer at any time. 

1 Open the project and select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Category Panel, select Global.

3 Click Spelling Preferences.

4 In the Spelling Options dialog box, select the dictionary you want to use in the Main Dictionary Language list. All 
dictionaries installed on your computer are listed.

5 Click OK.

Search slides and replace content
You can use the numerous options available in the Adobe Captivate Find feature to search for information on your 
slides. Besides text, you can locate different kinds of objects, such as text animation or a rollover image.

1 Select Edit > Find And Replace. 

The Find And Replace panel appears.

2 Select the object to be searched from the Search In list. The type selection determines which fields are enabled on 
the panel. 

3 To narrow down the search, select the style associated with the object in the Style list.

4 In the Find field, enter the text or object to search for.

Note: The Find field is enabled for All Controls, Text Entry, Button, and Text Animation searches only. In the Adobe 
Captivate update for subscription and Adobe Software Assurance customers, this field is enabled for Slide Notes / Closed 
Caption / Text-To-Speech search too.

5 (Optional) In the Replace field, enter the text that replaces the search string.

Note: The Replace option is enabled for All Controls, Text Entry, Button, and Text Animation searches only. In the 
Adobe Captivate update for subscription and Adobe Software Assurance customers, this field is enabled for Slide Notes 
/ Closed Caption / Text-To-Speech search too.

6 Select any of the following options: 

Whole Word Skip variations of the text. For example, find special, but not specialist.

Match Case For example, find Chair, but not chair.

Quiz Slides Include quiz slides in the search. 

Hidden Items Include hidden slides or controls in the search.

Locked Items Include locked slides or controls in the search.

7 Click any of the following buttons:

Find Next The focus moves to the next occurrence of the text or object.

Find All The search result lists all instances of the text or object.

Replace The selected found text is replaced with the text in the Replace field.

Replace All All instances of the text in the Find field are replaced with the text in the Replace field.
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Note: Use Replace All only when you are sure that the other words in the project are not affected adversely. For example, 
if you choose to replace all instances of “to” with “too,” the word “together,” after the replace operation, is converted to 
“toogether.”

Re-sizing Adobe Captivate projects
You can resize Adobe Captivate projects, even after you have recorded them. Resizing can save you from having to 
rerecord an entire project. For example, suppose you record your project at a width of 640 and height of 480, but then 
decided you need a slightly smaller or larger size.

Resizing a project cannot be “undone” with a toolbar button or key combination such as Control+Z.

Resizing a project numerous times can result in quality deterioration. As far as possible, try to resize a project only once. 

Resize a project
1 In an open project, select Modify > Rescale Project.

2 Under Size, enter an exact custom size in pixels in the Width and Height text boxes (minimum size 100 x 100). 
Alternatively, enter a percentage for width and height, with the current size being 100%. (For example, to make the 
project slightly bigger, enter 110%; to make the project much smaller, enter 50%.) You can also select the Preset Size 
option and choose a commonly used size, such as 640 x 480, from the pop-up menu.

If you want, select the Maintain Aspect Ratio option, which maintains the height and width proportions when the 
image is resized. This option ensures that the image is displayed accurately and is not distorted.

3 If you want to choose from a standard set of sizes, select Preset Size, and choose from the options.

4 You have different options depending on whether the new size you specified is larger or smaller than the original 
size.

Rescale Project To Fit New Size This option resizes the entire project to the new larger size you specified. To also 
rescale any objects in the project, select the Rescale Captions, Highlight Boxes, And Other Objects option.

Keep Project The Same Size And Fill Background With Color This option keeps the project the same size, but creates 
a project background at the size that you specified earlier. For example, if your original project is 550 x 400 pixels 
and you set the new size to 640 x 480, this option keeps the project at 550 x 400 and creates extra space around the 
project of 90 x 80. You can select any background color and choose a position for the project on the background, 
such as center or upper right.

Rescale Project To Fit New Size This option resizes and resamples the project to provide a good quality project. To 
also rescale any objects in the project, select the Rescale Captions, Highlight Boxes, And Other Objects option.

Rescale Captions, Highlight Boxes, And Other Objects Select this option to have Adobe Captivate automatically 
rescale all objects in your project such as captions, highlight boxes, click boxes, and text entry boxes to the new, 
smaller size.

Crop Crops the project to the new size. If you select the Crop option, click Next to open the Crop Area dialog box 
where you can define a crop area. To define the crop area, hold down the left mouse button and drag the Crop 
window (area with green border).

Arrows Move backward or forward one slide at a time through the project.

Slide Lists all the slides in the project. Click the drop-down arrow to select an individual slide.

Apply To All Slides Applies the crop area you defined to all slides in the project.
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5 Click Finish. 

Note: Resize buttons before resizing the project. Resizing a project does not resize the buttons automatically.

View project dimensions
 In an open project, select Modify > Rescale Project. The dimensions of the project are mentioned in the Original 

Project Size section of the Rescale dialog box.

Projects and project preferences

Edit project preferences
You can set project preferences that are applied to all the slides in the project. Some of these settings can overrule 
specific settings that you have set at the slide level. Use the Project menu in the Preferences dialog box to make the 
changes. 

Edit project information
Project properties are visible to users from the Information button that is included with all playback controls. It is 
important to set project properties if you are creating 508-compliant accessible projects.

Select Edit > Preferences > Project > Information (Windows) or Adobe Captivate > Preferences > Project > Information 
(Mac OS) and specify the following properties:

Author Name of the author or authors of the project.

Company Name of the company or organization responsible for the content in the document.

E-mail E-mail address for the company or, if appropriate, of your customer service department.

Website Website address of the company.

Copyright Copyright information for your project.

Project Name A distinctive and descriptive name for your project.

Description Short description of the contents of the project. For example, “This project is a brief overview of Product 
ZYX.” 

Change project size and quality
Select Edit > Preferences > Project > SWF Size And Quality (Windows) or Adobe Captivate > Preferences > Project > 
SWF Size And Quality (Mac OS) and specify the following properties:

Compress Full Motion Recording SWF File Compresses the full motion recording SWF file to a smaller size. Choosing 
this option can increase the time taken to preview or publish the project.

Settings Indicates the quality of the published SWF file. You can select the quality of the SWF file by moving the slider 
bar to the corresponding option: High, Medium, Low, or Custom. When you choose High, Medium, or Low, Adobe 
Captivate uses its internal settings to set the quality of the file. Files of a higher quality are compressed to a lesser extent, 
and therefore might be of a greater file size. You can customize the options for quality when you move the slider to the 
Custom level.

Retain Slide Quality Settings Retains the slide quality settings defined in the Property inspector of the slide.
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BMP Determines the image quality of bitmaps (screenshots) generated during recording. Reducing the image quality 
reduces the file size but can affect the quality of the color in the images. Any bitmap files that you have inserted in the 
project are also affected. 

JPEG Determines the quality of JPEG files that you have inserted in the project. Reducing the image quality reduces 
the file size but can affect the quality of the color in the images. JPEG images are detailed and contain many colors, so 
greatly lowering their quality is not advised. 

Audio Determines the quality of audio files used in the project. Audio files are converted to mp3 format before they 
are published. A file with higher quality does not affect the file size drastically but significantly improves the audio 
quality.

Advanced Project Compression Enables Adobe Captivate to take into account only the difference between two slides 
instead of publishing both the slides. The compression reduces the size of the published project. Choosing this option 
can increase the time taken to preview or publish the project. Compressed projects sometimes do not play as intended 
in Flash Player.

Compress SWF File Compresses the published SWF file. Compressed SWF files can be played only with Flash Player 9 
or later. Choosing this option can increase the time taken to preview or publish the project.

Define how a project starts and ends
Select Edit > Preferences > Project > Start And End (Windows) or Adobe Captivate > Preferences > Project > Start And 
End (Mac OS) and specify the following preferences:

Auto Play The movie starts playing as soon as it is downloaded. If you want the movie to play only after the user clicks 
the Play button, deselect this option. You can display an image until the user starts playing the movie. Click Browse (...) 
to select the image. If you do not select an image, the first slide of the movie is displayed.

Preloader You can add a loading screen to the beginning of your project. A loading screen is useful if the first slide of 
the project is large or contains audio and takes a few moments to appear. 

Adobe Captivate includes predefined loading screen images that you can use. Also, you can create a custom image to 
use as a loading screen. 

You can also create a SWF file to use as a loading screen. In the Adobe Captivate Preloaders folder, there is a sample 
SWF file and FLA file named DefaultPreloader. You can use these files as templates to create your own SWF file. If you 
add a custom loading screen, Adobe Captivate calls the following functions if they exist on the main Timeline of the 
SWF file:

Note: The preloaders available in Adobe Captivate are located in the \\ProgramFiles\Adobe\Adobe Captivate <version 
number>\Gallery\Preloaders folder on Windows.They are available at /Applications/Adobe Captivate 
6/Gallery/Preloaders directory on Mac OS.

function initialize(projectWidth:Number, projectHeight:Number) function 
onProgress(loadedBytes:Number,totalBytes:Number,preloadPercent:Number) function isDone():Boolean

Preload% The percentage of the SWF file that must be downloaded before the file starts playing. After the required 
portion of SWF file has been downloaded, the preloader disappears, and the SWF file starts playing.

Password Protect Project Password that users must enter before they can view the project. In the adjacent box, type the 
correct password to be used by users to successfully view the project. Click Options to specify the following:

Message The message that is displayed to users to explains what they must do when prompted to type a password.

Retry Message The message to be displayed when users enter an incorrect password.

Button Text The text that is displayed on the button that the users click in order to continue viewing the project.
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Project Expiry Date Expiry date for the project. Click Calendar to choose a date. In the adjacent text box, specify the 
message to be displayed to users when the project expires.

When a project expires, it can no longer be viewed.

Fade In On The First Slide Provides a fade-in effect to the first slide of the project.

Action Click the menu and select an action to take place at the end of the project.

Stop Project Stops the project after it plays once.

Loop Project Continuously plays the project. 

Close Project Closes the movie after it stops playing.

Open URL Or File Opens the specified website in a web browser after the movie stops playing.

To load a URL, type the full path to a website (for example, http://www.website.com). Click the inverted arrow icon 
next to the URL box to select the window in which to display the URL, then choose Current, New, Parent, or Top. 

To load a file, click the browse icon, browse to the file, select the file, and click Open.

Execute JavaScript Runs the specified JavaScript after the movie stops playing. Click Script_Window and type the 
javascript to execute. To reuse a script from a file, copy the script onto the clipboard and paste it into the JavaScript 
window. Click the inverted arrow icon next to the Script_Window button to select the window in which to display the 
URL, then choose Current, New, Parent, or Top.

Open Another Project Opens another project after the movie stops playing. Click the browse icon, browse to the 
project file (with the extension .swf, .rd, or .cptx), select the file, and click Open. Click the inverted arrow icon to select 
the window in which to display the file, then choose Current, New, Parent, or Top.

Send E-mail To Sends an e-mail to the specified e-mail address after the movie stops playing. The default mail editor is 
used to send the message. Type the e-mail address in the adjacent box. Click the inverted arrow icon to select the 
window in which to display the file, then choose Current, New, Parent, or Top.

Fade Out On The Last Slide Select this option to have the last slide in the project fade out of view.

Edit default preferences for slides and objects
The changes that you make in the Preferences dialog box are applied to all the slides in the project.

1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS). 

2 In the Preferences dialog box, select Defaults from the Global menu.

3 In the Slide Duration field, change the default time for which slides are displayed in the movie.

4 Set a background color for the slides in the project using the Background Color menu.

5 To change the number of slides displayed when the ‘Preview next n slides’ option is used, change the value of the 
Preview Next n Slides field. The default value is 5.

6 Select an object from the Select menu, and do the following according to your requirements.

• Change the default time for which the selected object appears on the slide.

• Change the default style for the selected object.

7 To resize a text caption according to the amount of text available in it, select Autosize Captions. The text caption 
resizes automatically to accommodate all the text. If you do not choose this option, the extra data is hidden. 
Manually resize the text caption to display the hidden data.
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8 To resize a button according to the amount of text available in it, select Autosize Buttons. The button resizes 
automatically to accommodate the extra data. If you do not choose this option, the extra data is hidden. Manually 
resize the button to display the hidden data.

9 If you want to set the time of the caption automatically in accordance with the amount of data in it, select Calculate 
Caption Timing. Adobe Captivate calculates the time that the viewer requires to read the text and applies it to the 
text caption.

Export and import project preferences
By exporting project preferences you can reuse your set of preferences across projects. Preferences can be saved and 
exported as CPR files. When the CPR file is imported into a project, the preferences mentioned in the CPR file are set 
in the Preferences dialog box.

1 Select File > Export > Preferences.

2 In the Save As dialog box, save your preferences as a CPR file.

3 Click Save.

When you want to import preferences into another project, select File > Import > Import Preferences. Open the file 
from the location where you saved the CPR file.

Author in right-to-left languages
Adobe Captivate lets you author in right-to-left languages such as Arabic or Hebrew.

1 Before creating your project, open Adobe Captivate > Edit > Preferences > General Settings.

2 Select Require Right To Left Composer.

Note: This setting is global. This means, all projects that you create subsequently inherit this setting.

3 Go ahead and create your Adobe Captivate project.

Set project background color
You can set the background color for the project. Whether the background color appears on all slides depends on the 
type of slide and how a screenshot is captured. 

1 In an open project, select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Category panel, select Defaults from the Global menu.

3 Click the box adjacent to the Background Color option, and do the following:

• To fill the background with a color, click a color.

• To apply a gradient fill, click the gradient icon, and then choose the gradient options. For more information on
gradient fills, see Apply gradient fills.

4 Click OK.

Recover damaged projects
Use one or all of the following options to recover damaged or corrupted projects:

• Using the project backup file

• Clearing the project cache
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Clear the project cache
Project cache in Adobe Captivate 6 helps you save and open projects faster. When you create a project in Adobe 
Captivate 6, a corresponding project cache folder is automatically created. This folder is saved in the project cache root 
folder specified in the project Preferences.

Over time, these cache folders may use up your system resources and you may want to delete the folders to optimize 
the resources. You can delete the folders using the ‘Clear Cache’ option in the project Preferences (Edit (Win)/Adobe 
Captivate (Mac) > Preferences > General Settings > Project Cache).

To delete multiple project cache folders, use the Clear Cache application. This application lists all the Adobe Captivate 
project cache folders on the system along with the corresponding project name, size, status of the project (opened or 
closed), date modified, and cache size. Using this information, you can decide which cache folders you want to delete 
and quickly delete multiple cache folders with a single click.

To install and use this utility, perform the following steps:

1 Download dcache.zip and unzip the contents.

2 Double-click the file dcache.zip and follow the on-screen instructions to install the utility.

3 After the installation, the Clear Cache Application opens and lists all the project cache folders in the default cache 
location.

• To view the cache folders in a different location on your system, click Browse, and navigate to the location of the 
folder.

• To delete a cache folder, select the check box that corresponds to the folder and click Clear. To delete all the
folders, click Select All, and then click Clear. Please note that currently opened projects cannot be selected for
deletion.

How to preview projects in Adobe Captivate
Previewing a project before and during the editing of a project helps you notice the changes that are required. This way, 
you can be sure of the final output before you publish it.

1 Open the Adobe Captivate project that you want to preview.

2 In the main toolbar, click the preview icon, and select one of the following options:

Play This Slide Plays only the current slide.

Project Plays the entire project.

http://blogs.adobe.com/captivate/files/2010/09/dcache.zip


382
Advanced Editing and Project Reviews

Last updated 10/10/2016

From This Slide Plays the project from the currently displayed slide to the end.

Next 5 Slides Plays five slides starting with the current slide.

Note: You can change the number from 5 to your desired number of slides using the Preferences dialog box. 

In Web Browser Opens and plays the project in your default web browser.

HTML5 Output in Web Browser Opens the HTML5 output of the project in your default web browser.

In Cp 7, the SWF and HTML5 previews are displayed using the Mongoose webserver integrated with Adobe Captivate. 
In cases where preview on the webserver is not supported (for example, if project includes Open URL or File, or Open 
Another Project actions), the preview appears in the default web browser.

How to create localized Adobe Captivate projects
Localization is the process of adapting information for use in a specific country. The term localization is often used as 
a synonym for translation. However, localization also entails editing information for a particular cultural context. 

Using Adobe Captivate with a localized user interface
If you are creating Adobe Captivate projects that show a website or application that has been created in several 
languages, you can create localized projects for each language.

To create localized Adobe Captivate projects:

1 Create an Adobe Captivate project in your source language using a source language version of the website or 
application. For example, if you created your application in English, you can produce an English-language Adobe 
Captivate project that shows the English application.

2 Export any captions in the project and translate the caption text into the languages you require. Continuing the 
example from step 1, you can take the English-language captions in the English project, export them, and give the 
text to localizers so they can translate it into other languages such as German and Japanese.

3 Open the website or application in the localized forms and record the same steps that were recorded in the source 
language version of the project. When you record the projects, do not automatically include objects. In this example, 
you record Adobe Captivate projects (using the same steps in the English project) of the application after the 
localizers have translated the application user interface into German and Japanese.

4 Import all objects from the source language version of the project. In this example, you import all objects from the 
English version of the project into the German and Japanese projects.

5 Import the localized captions created by translators in step 2. In this example, you open the German and Japanese 
projects and import the Microsoft Word file of the captions that have been translated. 

6 Test the localized versions of the project. In this example, open the German and Japanese projects and ensure that 
the correct user interface is shown, that captions are properly translated and appear on the correct slide, and that 
timing is accurate. If necessary, adjust the timing or resize the captions so that Adobe Captivate displays all the 
translated text correctly.

Localize text captions
If you are localizing a project that contains text captions and closed captions, you can export text captions to make the 
process more efficient.

1 Create the initial (“source language”) version of the project, including all necessary text captions.
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2 Open the completed project.

3 Select File > Export > Project Captions And Closed Captions.

4 By default, the Word (DOC) file is saved to your My Documents\My Adobe Captivate Projects folder. You can 
change the location if you want. If the project file was saved, the location of the default Word file, named 
[ProjectName] Captions.doc, is in the same directory as the one in which the project has been saved. You can change 
the name of the file, if necessary, by clicking directly in the File Name text box and entering a new name. (Retain 
the.doc filename extension.) Click Save.

5 The Word file is generated with the name you specified and saved to the location you selected. A dialog box appears, 
asking if you want to view the document. Click Yes to view the document in Word.

6 The Word document contains the slide ID, item ID, original caption text, and slide number. There is also a column 
named “Updated Text Caption Data” where you can change the caption text. Provide a copy of the Word document 
to the localizer/translator.

7 The localizer/translator opens the Word document and edits the caption text directly in the “Updated Text Caption 
Data” column, replacing the source language text.

8 While the localizer/translator is translating the text, make a copy of the original Adobe Captivate project for the new 
language.

Note: When you create a copy of the original project, keep the original text captions and closed captions (in the source 
language) in the new project. The original captions act as placeholders and are overwritten when you import the new 
(localized) text captions and closed captions.

9 When the text captions are localized, open the copy of the project you created.

10 Select File > Import > Project Captions And Closed Captions.

Note: The Import Project Captions And Closed Captions option is enabled only after you export the captions. You can 
import only those edited caption files that you originally exported from the same project.

11 Navigate to the localized text captions Word (DOC) file, select the file, and click Open.

12 The localized text captions and closed captions are imported into the project and all formatting is retained. A dialog 
box appears showing a successful import message. Click OK.

Test the new text captions by opening different slides in Edit view and reading the new caption text.

How to link Adobe Captivate projects
You can interlink Adobe Captivate projects or link them to other files when using the following features:

• Interactive objects: text entry boxes, click boxes, and buttons

• Question slides

• Slide navigation

• Project action

Make sure all the linked projects or files are in the same folder before you use the procedure to link them.

Link Adobe Captivate projects to other projects
1 Open the project that must be linked with another project. 
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2 Determine the trigger for opening the other project. For example, the project is to be opened when slide 14 begins. 
Or, the project is to be opened when user clicks the button on slide 24.

• If the trigger is based on events related to a slide, click the slide in the Filmstrip and deselect all the objects on the 
slide.

• If the trigger is based on objects, select the object.

3 In the Property Inspector, select one of the following options in On Success, Last Attempt, On Enter, or On Exit lists 
based on the option you chose in step 2:

• Open URL Or File

• Open Other Project

4 Click the browse icon, and use the Open dialog box to link to the file or project.

5 Delete the system path, if any, to make sure that only the filename is displayed in the URL or Project field.

Link Adobe Captivate projects using question slides
1 Open the project to be linked and select Quiz > Question Slide.

2 In the Property Inspector, select Graded as the Type in the General area.

3 In the Action area, select one of the following options in the On Success or Last Attempt fields based on your 
requirement:

• Open URL Or File

• Open Other Project

4 Click the browse icon, and use the Open dialog box to link to the file or project.

5 Delete the system path, if any, to make sure that only the filename is displayed in the URL or Project field.

Import, export, and delete content

Export project content to XML
An Adobe Captivate project file can have the following types of content:

Static content Examples include images (bitmaps, buttons, backgrounds), audio, FLV files, and videos (SWF files). To 
customize static content for different languages, create new files with translated content.

Dynamic content or localizable content Examples include text captions, button text, and slide notes, which can be 
localized in different languages.

When you export the dynamic content of an Adobe Captivate project to an XML file, you can edit and translate content 
in the objects using the XML file. You can edit and translate many objects, including project properties, the Menu 
Manager slides and slide information, and so on. You can export audio items only for closed captions.

After exporting project content to XML, you can import it into any other Adobe Captivate project.

1 Open an Adobe Captivate project and save it with a new filename for a new language.

2 Select File > Export > To XML.

3 In the Save As dialog box, enter a filename for the new XML file.
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4 Make a note of the default directory where you save the file. You can navigate to a different location if desired.

5 Click Save.

Relevant objects in the project are converted into XML format. A dialog box appears, confirming that the XML 
export was successful. Choose whether you want to view the XML file. If you click Yes, the XML file opens in your 
default XML viewer.

6 Open the XML file, and translate all terms specified in the <source> </source> tags inside the <trans-unit> </trans-
unit> tags.

For RTF data (such as text captions), the actual translatable text is present within <g> </g> tags. To change the text 
to a different language, change the font-family field in css-style attribute, and add the corresponding character set. 

Instead of exporting a project to XML, you can publish the project you want to edit and localize. You can then send the 
content in the XML format to an e-mail address. The XML file is sent as an attachment to the e-mail address. You can 
also compress the XML file and send it by e-mail.

Ensure that the Adobe Captivate project file is edited before exporting the XML file.

Note: The Info, Blabber, and Skin tool tips are not exported to XML because such information is stored in Flash Authoring 
Files. After localization, separately create Info, Playbars, and Skin tool tips for the relevant localized version of the Adobe 
Captivate project.

Import project content to XML
Note: After translating the content of the XML file to the required language, import the updated XML file into Adobe 
Captivate. The project content then appears in the required localized language.

If you want to rerecord the project, ensure that you do so before importing the XML file.

1 In an open project, select File > Import > From XML.

2 In the Open box, enter the filename of the XML file or navigate to the XML file.

3 Click Open.

The XML content is imported into the Adobe Captivate project. A dialog box appears, confirming that the XML 
import was successful.

4 Click OK.

Note: If the XML file was sent to you by e-mail, open the e-mail message and save the XML file in the required directory. 
Translate its contents to the required language.

Import and export project preferences
You can export preferences set in one Adobe Captivate project and import them into other Adobe Captivate projects. 
Preferences are exported as an XML file with a .cpr extension. When this file is imported into another Adobe Captivate 
project, the preferences defined in the file are set. 

Note: All preferences in your current project are modified according to those set in the preferences file.

Export project preferences
1 Select File > Export > Preferences.

2 In the File Name field, type a name for the CPR file.

3 Click Save.
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Import project preferences
1 Select File > Import > Preferences.

2 Select the CPR file that contains the preferences you want to import.

3 Click Open.

Delete projects or templates
You can delete Adobe Captivate projects (CPTX files) or templates (CPTL) at any time. When you create Adobe 
Captivate projects and templates, they are saved, by default, to the following locations: 

• Projects are saved in \My Documents\My Adobe Captivate Projects. If you are using Windows® Vista®, the path is
\Users\<Current User>\Documents\My Adobe Captivate Projects.

• Templates are saved in \My Documents\My Adobe Captivate Projects\Templates. If you are using Windows Vista,
the path is \Users\<Current User>\Documents\My Adobe Captivate Projects\Templates.

To delete projects or templates, perform the following steps.

1 Open Windows Explorer.

2 Navigate to the location of the Adobe Captivate project or template (see the default locations listed previously).

3 Right-click (Windows) or Control-click (Mac OS) the project or template and select Delete. 

How to combine multiple SWF files with aggregator
You can combine multiple projects published as SWF files using the Aggregator. You can publish the combined files in 
the Aggregator as SWF output, executable files (Windows and Mac), PDF, HTML, or Zip files. The Aggregator creates 
a table of contents (TOC) using the names of the separate modules (SWF files). TOCs of individual modules are 
displayed under their module name.

The Aggregator currently supports SWF files that are published using Adobe Captivate and that use the same 
ActionScript version. 

Note: You cannot add SWF files created in Flash to an Aggregator project.

To ensure uniformity of TOC settings across a movie, you can set a SWF file as the master movie. The TOC settings of 
the master movie are applied to all the other movies in the Aggregator. Any changes made to the TOC settings by 
individual content creators can be undone using a master movie.

Create an aggregator project
1 Select File > New > Aggregator Project.

2 In the Aggregator dialog box, click Add Module.

3 In the Open dialog box, select the SWF file that you want to add to the Aggregator.

4 Repeat steps 2 and 3 to add more SWF files to the project.

• To set a SWF file as the master movie, select Set As Master Movie. The TOC settings of the SWF file are applied
to the other files in the Aggregator. The project information of the master movie is applied to the Aggregator file.

• If you do not want to display the name of the SWF file in the movie, deselect Include Module Title.
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• To change the position of a SWF file in the menu, select the name of the file. Use the Up and Down Arrow keys
to relocate the movie to the desired location in the menu.

• To delete a movie from the list, select the movie, and click Remove .

• To override the project information set in the TOC of the master movie, click Info. In the TOC Info dialog box,
select Override TOC Info, and change the settings. The TOC information is displayed above the TOC menu of
the Aggregator in the published file. For more information, see Display project information in the TOC panel.

• To add a preloader screen to the project, click the browse icon in the Select Preloader area. Navigate to the image 
you want to use and click Open.

5 Click Save, and save the file as a .aggr file. 

Publish the aggregator project
1 Open the aggregator project.

2 Click the publish icon.

3 In the Aggregator Publish dialog box, do the following:

a In the Format section, select SWF, Win Executable, or Mac Executable based on your requirements.

b In the Title field, specify a unique name for the published file.

c In the Folder field, enter the path to which the files are published. Alternatively, click Browse to specify the path. 
Select Publish Files To Folder if you want Adobe Captivate to create a default folder into which the files are 
published.

4 In the Publish Options section, select one or more options based on the publishing format you have chosen.

• Select Zip Files if you want to publish the files as a single ZIP file. This option is especially useful when you want 
to create a single ZIP file that can be uploaded to a learning management system (LMS) directly.

• Select Export HTML if you want to insert the SWF into an HTML file and publish it.

• Select Export PDF if you want to insert the SWF file into a PDF file and publish it.

• Full Screen if you want the movie to be displayed in full screen of the users’ monitors.

5 If you have chosen Win Executable as the publish format, click the browse icon in the Custom Icon field to assign 
an icon to the published EXE file.

6 Click Publish.
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Chapter 15: Publishing Projects

Preview and publish responsive projects

Overview
Preview on stage or F3 is now changed to Full screen preview (Preview > Project). Preview the content for each slide or 
for the project. Preview the project in browser (F11) for all the view port options. Publish the content as HTML 5 in 
Browser with support for gestures and geolocation.

Preview responsive projects
1 From Toolbar, Click Preview icon.

2 Choose the appropriate menu item from the drop-down list. If you choose View HTML5 in browser, then you have 
an option to view in any of the three breakpoints as shown in the image below:

Preview in Adobe Edge Inspect
Now, you can see the results of your content preview in devices using Adobe Edge Inspect. Click Preview>In Adobe 
Edge Ispect to see how it looks on physical device which has Adobe Edge Inspect installed in it. For more information, 
see the following video: 
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Publish as HTML5 and Adobe Connect video files
To publish the projects as HTML5 and Adobe Connect videos, follow the steps below: 

1 From Toolbar, click Publish icon

2 Choose the appropriate option from Publish for Devices and Publish to Adobe Connect menu items as shown in the 
following screenshot:

3 To publish the output as HTML 5 in browser, choose Publish for Devices. 

Publish for Devices dialog appears as shown in the following screenshot: 

a. Choose the appropriate Project Title, Location, and Click Publish when completed. You can also publish Captivate
projects to Phone Gap.

Note: For more information on Publishing standard blank projects, see Publishing Projects topic. You can continue to 
publish Adobe Captivate non-responsive/blank projects as exe files. 

4 To publish the output to Adobe Connect, choose Publish to Adobe Connect from Publish menu.

A dialog box appears as shown in the following screenshot: 

http://helpx.adobe.com/captivate/topics.html#dynamicpod_reference_16
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5 Choose the appropriate Project Name, server URL and Click Publish when completed.

Publish as apps for devices
Publish for devices (apps) menu is integrated into Adobe Captivate 8.0.1. Now, you can publish Adobe Captivate 
projects as apps to any devices without using the App packager. 

To publish the output as apps for devices, follow the steps below: 

1 Choose Publish for Devices (App) from Publish menu.

A dialog appears as follows: 
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2 Log in using PhoneGap user name and password or use your Adobe ID login credentials to log in to your PhoneGap 
account. Click Register to register for PhoneGap or Adobe ID accounts if you do not have an existing account.

3 Choose App> Create New for new application.

Choose App> Update if you are updating an already existing app in PhoneGap.

4 Mention the version number, name of the app and the Package name for the app. While mentioning the package 
name, ensure that you give unique package name otherwise the existing project is replaced.

5 Click More to choose your personal publishing preferences for the app, like geolocation, gestures, accessibility, and 
so on. 

6 Click Next to provide the required certificate/key information for your app. You can choose iOS or Android or both 
by clicking the check boxes adjacent to them and provide certificate/key information corresponding to each 
platform.

Refer to Create certificates and generate key section for more information. 

7 Click Publish to publish the output as apps for devices. 

Adobe Captivate uses the PhoneGap service at the backend to build the app. After the app is built, you are prompted 
to download the app as shown in the snapshot. Once you click the download, you can see PhoneGap site. 

Create certificates and generate key
Certificates and authentication keys are essential for users to enable security for their accounts and prevent any 
unauthorized access. 

Create certificates for iOS

1 Refer to the apple developer support site and create an app developer certificate. Refer to program enrollment for 

more information. 

2 Refer to the instructions on the PhoneGap build site as mentioned below to convert the certificates into supported 
P12 format and upload the certificates: 

 Convert an apple developer certificate to a P12 on Mac and Windows

Generate keys for Android 

 Refer to the instructions on the PhoneGap build site to generate and upload keys to PhoneGap build.

In Captivate 8.0.1, after you log in with PhoneGap user id and password, click Next in Publish window, and provide 
certificate info in the dialog as shown below: 

Last updated 10/10/2016

https://developer.apple.com/support/technical/certificates/
https://developer.apple.com/support/ios/enrollment.php
http://docs.build.phonegap.com/en_US/signing_signing-ios.md.html#iOS Signing
http://docs.build.phonegap.com/en_US/signing_signing-android.md.html#Android Signing
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Note: AppleKey title in the above snapshot represents the certificate name that you uploaded in PhoneGap build. Your 
certifcates are populated in the Title drop down after you upload them in PhoneGap build website. Similarly, the keys you 
uploaded to PhoneGap build appear in Title drop down. You can continue to publish even if you do not have keys for 
Android by choosing No key selected option. 

Publish for devices from Windows 8 OS
if you publish using Windows 8 OS, you can see an additional option in Publish To as Windows 8. If you choose this 
option, the dialog appears as below: 

Project title, location information, and the options under More are similar to iOS/Android dialog options. Follow the 
steps accordingly.

Note: If you remove preferences of Adobe Captivate, then you have to create certificates again.

Gestures and Geolocation
Gestures for devices have been introduced in Adobe Captivate 8. Now, you can apply the available gestures to your 
Responsive Projects while Publishing projects.

1 Click blue colored no text adjacent to Mobile Gestures and Geolocation in Publish for devices dialog, as shown in 
the following screenshot. A new window appears.
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2 Click checkboxes next to Gesture Configuration and Geolocation in the window as shown in the following image.

Set Geolocation for projects to provide multiple options to end users based on their location. Authors can use 
cpInfoGeoLocation system variable to capture geolocation values and use them based on various user scenarios. You 

can use custom variable to set Latitude, Longitude, and Accuracy (in meters which determines radius) and compare with 
System variable.Creating custom variables:

1 Click Project>Variables 

2 In Variables dialog, click Add New

3 Click Geolocation checkbox and provide latitude, longitude, and accuracy data. 

4 Click Save and OK. 

You can also trigger an action based on the geo-location by clicking the Folder icon and selecting an advanced action 
that you have created.

Emulate geolocation while testing your project
You can now verify whether the geolocation functionality you have set up is working fine before publishing your 
project.

Note: This feature is only applicable if you have created a custom geolocation variable as described in the tip above.

Click Preview to see the project preview in the browser.
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Toggle between the different locations you have set up to preview how the project looks and functions when a learner 
accesses it from that location.

Map support
While creating custom variables, users can browse through Google™ integrated maps and choose the geolocation. 
Latitude, longitude, and location accuracy values are populated based on the chosen geolocation from maps. 

Users can click the globe icon adjacent to Choose from Map in the Variables dialog as shown below: 

Note: To use this map support feature, user should connect to the internet. 

For example, in the above snapshot, a location map of San Francisco city has been chosen from the map and the 
corresponding values are populated. 

Users can type coordinates if they are already aware of them, or select location from map to fetch the values 
automatically.

User Scenario for map support
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Consider a scenario where you have created a course for German speaking people residing in Germany. You can use 
the Google map and choose germany by typing in the search bar. As shown in Figure - A, you have the location accuracy 
value as 334988 meters encompassing most of the area of Germany. 

At a later stage, if you need to expand your course availability to more countries, like Germany, Poland, Denmark, 
Belgium, Austria, and so on, then you can click the red colored pin (at the outer part of circle) and drag it to match your 
locations. Figure -B demonstrates the extended location accuracy values that you would have chosen in this scenario. 

Publish projects as HTML5 files with Adobe Captivate
You can publish Adobe Captivate projects for devices that support HTML5 such as iPad or iPhone. 

1 Open the project and then click File > Publish.

For information on publishing responsive projects, see publishing responsive projects 

2 In the Publish dialog box, click HTML5 in the Output Format.

3 After publishing, do the following:

• If your project contains links to external files (Open URL Or File action), copy the files to the output folder

• If your project contains a link to another Adobe Captivate project (CPTX), copy the project to the Callees folder 
in the output folder.

4 (Optional) To hide the rectangles that appear when objects are clicked in the HTML5 output, select Hide Selection 
Rectangle For Slide Items In HTML5 in Preferences (Edit > Preferences > Publish Settings).

Note: You can view the Interactions in the project only when you view the HTML5 output hosted on a web server. 
Interactions are not visible when you view the published output locally on your computer.

http://helpx.adobe.com/en/captivate/using/preview-publishing.html#Publishing
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You can also publish HTML5 output of projects to Adobe Connect. For more information, see Publish projects to 
Adobe Connect(available only in the update for subscription and Adobe Software Assurance customers).

Publishing projects as apps to devices
From Adobe Captivate 8.0.1 and above versions, you can publish projects to PhoneGap without using a standalone App 
packager application. Publishing to Devices (app) menu item is integrated in Captivate. Follow the steps below: 

1 Choose Publish for Devices (App) from Publish menu.

Note: You can follow the same steps in responsive and non-responsive projects. 

A dialog appears as follows: 

2 Log in using PhoneGap user name and password or use your Adobe ID login credentials to log in to your PhoneGap 
account. Click Register to register for PhoneGap or Adobe ID accounts if you do not have an existing account.

3 Choose App> Create New for new application.

Choose App> Update if you are updating an already existing app in PhoneGap.

4 Mention the version number, name of the app and the Package name for the app. While mentioning the package 
name, ensure that you give unique package name otherwise the existing project is replaced.

5 Click More to choose your personal publishing preferences for the app, like geolocation, gestures, accessibility, and 
so on.

6 Click Next to provide the required certificate information for your app. You can choose iOS or Android or both by 
clicking the check boxes adjacent to them and provide certificate information corresponding to each platform.

Refer to Create certificates and generate key section for more information.

7 Click Publish to publish the output as apps for devices. 
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Adobe Captivate uses the PhoneGap service at the backend to build the app. After the app is built, you are prompted 
to download the app as shown in the snapshot. Once you click the download, you can see PhoneGap site. 

Create certificates and generate key
Certificates and authentication keys are essential for users to enable security for their accounts and prevent any 
unauthorized access. 

Create certificates for iOS

1 Refer to the apple developer support site and create an app developer certificate. Refer toprogram enrollment for 
more information. 

2 Refer to the instructions on the PhoneGap build site as mentioned below to convert the certificates into supported 

P12 format and upload the certificates: 

 Convert an apple developer certificate to a P12 on Mac and Windows

Generate keys for Android 

 Refer to the instructions on the PhoneGap build site to generate and upload keys to PhoneGap build.

In Captivate 8.0.1, after you log in with PhoneGap user id and password, click Next in Publish window, and provide 
certificate info in the dialog as shown below: 

Note: AppleKey title in the above snapshot represents the certificate name that you uploaded in PhoneGap build. Your 
certifcates are populated in the Title drop down after you upload them in PhoneGap build website. Similarly, the keys you 
uploaded to PhoneGap build appear in Title drop down. You can continue to publish even if you do not have keys for 
Android by choosing No key selected option. 

Publish for devices from Windows 8 OS
If you publish using Windows 8 OS, you can see an additional option in Publish To as Windows 8. If you choose this 
option, the dialog appears as below: 

https://developer.apple.com/support/technical/certificates/
https://developer.apple.com/support/ios/enrollment.php
http://docs.build.phonegap.com/en_US/signing_signing-ios.md.html#iOS Signing
http://docs.build.phonegap.com/en_US/signing_signing-android.md.html#Android Signing
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Project title, location information, and the options under More are similar to iOS/Android dialog options. Follow the 
steps accordingly.

Note: If you remove preferences of Adobe Captivate, then you have to create certificates again.

Unsupported objects in HTML5 output
Objects in the project that are not supported in the HTML5 output get dynamically listed in the HTML5 Tracker. To 
view the tracker, click Window > HTML5 Tracker. When you delete or modify such objects in the project, the tracker 
too is updated.

The following objects and slides are not published in the HTML5 output:

• Text and SWF animations (only the first frame is visible).

• Mouse click animations (only one default click effect is supported).

• Question pools, Likert question slides, and random question slides (supported in Cp 7 and later).

• Slide transitions.

• Slide background if a SWF file is used.

• Audio attached to invisible objects.

• Borders (supported in Cp 7 and later).

• Reporting to internal server and Acrobat.com (supported in Cp 7 and later).

• Video streaming using RTMP is not supported in HTML5 output.

Note: FLV files that are created using On2VP6 codec only are supported in the HTML5 output.

• Object effects: (CP 7) The unsupported effects are marked with an asterisk (*) in the object effects list. The effects
marked with double asterisks (**) are rendered differently in HTML5 output compared to a SWF output.

In Cp 6, only the following object effects are supported:

• Entrance

• Fly-in

• Ease-in
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• Exit

• Fly-out

• Ease-out

• Motion path

• Left to Right

• Left to Right Ease

• Pentagon

• Rectangle

• Right to Left Ease

• Right To Left

• Triangle

• Zig Zag

Hosting HTML5 output on web servers for iPad/iPhones
HTML5 output can be accessed on iPads/iPhones only through web browsers. Upload the entire HTML5 output folder 
to a web server root folder and make the URL available to your users. Your users can access the URL from their 
iPad/iPhone and view the content that plays within the web browser.

Webserver root for IIS: C:\Inetpub\wwwroot\

Webserver root for Apache: <Apache install folder>\htdocs\

Accessing HTML5 output from iPads/iPhones
HTML5 output is supported only on iPads with OS version 5 or later.

HTML5 output is supported only on the following browsers:

• Internet Explorer 9 or later

• Safari 5.1 or later

• Google Chrome 17 or later

Type the following URL in one of the above web browsers:

http://<webserver_hostname>:<port>/<HTML5_outputfolder>/

For example, if the HTML5 output folder is MyCpProject, the URL will be:

http://localhost:80/MyCpProject/

Best practices for creating Adobe Captivate projects for iPads

• Use the recommended project resolutions (presets) for iPad.

• Avoid overlapping audio in the project. If at all you need overlapping audio, read the article Adobe Captivate audio 
for iPad.
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• In general, do not have too many overlapping media (especially very short ones) for movies that have to run on IOS 
devices.

• Disable button click sound as it may lead to unexpected behavior on iPad occasionally.

• Disable Scalable HTML Content in the Publish dialog box.

Adobe Captivate audio for iPad
Avoid using overlapping audio in your projects if they are to be used extensively on iPads. 

If you use overlapping audio, the preferences to different types of audio are as follows:

Scenario 1: Different types of audio triggered at the same time

The sequence in this case is:

Object audio > Slide audio > Background audio

Object audio is played first, followed by slide and background audio.

On iOS 6, however, multiple audio clips can be played simultaneously.

Scenario 2: Two or more objects are assigned with audio and appear simultaneously in the Timeline

Audio of the object lower in the z-order of the timeline is played first.

• Case 1: Object 1 has audio for 0-4 seconds and Object 2 has audio for 0-8 seconds. Object 2 is lower in the z-order
of the Timeline.

Audio of Object 2 is played for 8 seconds and then Adobe Captivate checks if there is any other audio at that point
(8th second) in the Timeline. In this case, there is no audio to be played at the 8th second. Therefore, audio of Object 
1 is not played.

• Case 2: Object 1 is lower in the z-order.

Audio of object 1 is played for 4 seconds. A check at 4th second indicates that the audio of object is for 4 more
seconds. So, the audio of second object is played from the beginning. After 8th second when the second object’s
audio is played, a check on the Timeline indicates that there is no more audio to be played.

Scenario 3: Object audio, slide audio, and background audio on a single slide

• Case 1: Object Audio is present from 0-4 seconds and Slide Audio is present at the same time. (no background
audio)

Object Audio is played first for 4 seconds and then the whole Slide audio will be played.

• Case 2: Object Audio is present from 2-6 seconds and slide audio is present at the same time. (no background audio)

First Slide Audio will be played for 2 seconds, then Object Audio for 4 seconds and then Slide Audio again.

• Case 3: Object Audio is present 0-4 seconds, Slide Audio 0-8 seconds and Background Audio is present. (slide
duration let say is 14 seconds)

Object Audio is played for 4 seconds, then slide audio for 8 seconds, then the remaining slide duration background 
audio is played.

Adobe Captivate video on iPads
Avoid using overlapping video if your project is to be extensively used on iPads.

Scenario 1: Two or more videos on the same slide with different durations
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Videos are played one after the other based on their order in the Timeline.

For example, consider that two videos are present on a single slide with the following durations on the timeline:

• Slide_Video1 from 0-8 secondsEvent_Video2 from 4-10 seconds

Slide Video will be played for 8 seconds and then Event Video

Scenario 2: When two videos start at the same time

Video that is lower in the z-order is played first. For example, consider that Video1 is present on a slide from 0-8 seconds 
and Video2 is also present on the same slide from 0-12 seconds.

• When Video 2 is present lower in the z-order, Video 2 is played for 12 seconds and the Video1 is never played.

• When Video1 is present lower in the z-order, Video1 is played for 8 seconds and then Video2 is played until the slide
duration.

Publish projects as executable files
You can create stand-alone, executable files of your Adobe Captivate projects. This publishing option enables you to 
create a Windows executable file (EXE) or MAC executable file (APP).

1 Select File > Publish.

Publish to My Computer dialog appears. 

2 In the Publish To My Computer dialog, choose Publish as > Executable. 

3 Configure the following options:

Publish Type Choose the Publish Type as Windows Executable (*.exe). For Mac, choose MAC Executable (*.app)

Project Title Enter a name for the executable file without adding the extension (.exe/.app).

Location Enter the full path to the folder in which to save the file, or click Browse to locate the folder.
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Icon You can customize the icon that is displayed for the executable file. Click Browse (...) to add a custom icon for 
your file. Ensure that the icon file has a .ico extension (on Windows)/.icns (for Mac).

(Applies only for Windows) You can create a custom icon file using any software meant for that purpose. Ensure that 
the file you create contains seven images of the following dimensions:

• 256x256 32-bit color image

• 48x48 32-bit color image

• 48x48 8-bit color image

• 32x32 32-bit color image

• 32x32 8-bit color image

• 16x16 32-bit color image

• 16x16 8-bit color image

4 (Applies only to EXE) Select from the following output options:

Zip Files Creates a ZIP file containing the EXE file. 

Full Screen Runs the executable file in full screen mode.

Note: If you select AICC or SCORM options for the project, you can’t apply the full screen publishing option.

Generate Autorun For CD An autorun.inf file is generated in the publish directory. The file starts playing as soon as 
the CD is inserted into the computer.

Flash Player Version Adobe Captivate generates the SWF file in the Flash version that you choose. 

More Click more to view more options as the resolution of your project, number of slides, number of audio slides, 
and audio settings. Click Custom to configure audio settings for your project. For more information on how to set 
audio settings, click Set audio recording preferences. 

Force re-publish on all slides Clicking this option forces Captivate to re-compile and re-publish all the slides again 
whether there are changes in each slide or not. Captivate might take longer time to publish the output if Force re-
publish on all slides option is selected. 

Scalable HTML content Enabling this option before pubishing makes your content in the output resize itself to fit 
the user's browser resolution. 

Seamless Tabbing (IE only) Click this option to enable seamless tabbing in IE. 

By default, seamless tabbing feature is disabled, which means if you use tabbing in the output, it stays within the 
output frame. 

Seamless Tabbing feature enables the tabbing to go beyond the flash player simulation in the output and interact 
with the browser's address bar. 

Publish projects as MP4 files with Adobe Captivate
Adobe Captivate lets you publish your projects as MP4 files by choosing any of the following presets: 

• Smart devices, such as, Apple iPad and iPhone.

• YouTube formats, such as, YouTube Widescreen HD, and YouTube Widescreen SD.
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• Any custom settings.

Note: F4V publishing is replaced with MP4 publishing in Adobe Captivate 5.5 and later.

When you select a smart device or a YouTube format, Adobe Captivate automatically sets the optimum video settings 
for the chosen option. 

If you have used a device or a YouTube preset while creating the project, an appropriate option is displayed 
automatically in the Publish dialog box.

1 Click File > Publish 

Alternatively, from the Toolbar Click Publish > Publish to Computer

2 Select Publish as > Video from the Publish to My Computer dialog box. 

3 Specify a title for the project.

4 Specify a folder in which the project must be published. By default, the project is published in the folder specified 
in the project preferences.

5 Click one of the options in the Select Preset list.

Adobe Captivate automatically sets the video settings based on the option you select. If necessary, you can customize 
the settings by selecting the Customize Video Settings check box. For the description of the settings, see Video 
settings.

Note: It is recommended that you retain the default settings for optimized outputs.

6 Click Publish.

After publishing a project as an MP4 file, you can do the following:

• Upload it to the device stores or to YouTube.

• Distribute the file to your users as a stand-alone video over email or host it on your web server.

• Stream or embed the MP4 file using Flash.
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Video settings
Profile The profile of the H.264 encoder/decoder. 

The higher the profile, the higher is the complexity involved to encode or decode.

Baseline For mobile and video conferencing applications

Main For standard-definition digital TV broadcasts

High For applications and devices dealing with high definition

Level The degree of the required decoder for the selected profile. The higher the level, higher is the degree of 
complexity associated with the decoder.

Bitrate Encoding The type of bit rate you want to use.

CBR Constant Bit Rate. For every second of the video, the number of bits used is constant and is equal to the Target Bit 
Rate.

VBR, 1 Pass Variable Bit Rate. Some frames require higher bits than others. If you select this option, the encoder decides 
how many bits to use in such cases. So, the actual bit rate of the video is between the target and maximum bit rate.

Target Bitrate Number of bits per second to be used by the encoder.

Max Bitrate The maximum bit rate to be used by the encoder. This option available only when you choose variable bit 
rate. 

After specifying the video settings, click Test Settings to verify whether the custom settings are valid.

Some best practices while customizing the video settings:

• The higher the profile or level, the greater is the chance of reducing the file size.

• Constant bit rate provides a file with lower size compared to variable bit rate.

When you specify a variable bitrate, the encoder decides when to use more bits to maintain good quality. The file
size increases when more bits are used. You may encounter issues while streaming such files as more number of bits
can be downloaded to show specific sections of a movie.

Upload projects to YouTube directly from Adobe Captivate
1 Click File > Publish to YouTube.

Adobe Captivate converts your project to an MP4 file at the back end. After the conversion is completed, the Adobe 
Captivate Video Publisher dialog box, and the YouTube Login window appears.

2 Specify your YouTube login credentials and select the I’ve Read Adobe Privacy Policy check box.

3 Click Login.

4 In the Adobe Captivate Video Publisher dialog box, specify the title for the project, and type in a description.

5 In the Tags field, type the tags for the project to optimize your users' search for the project. Use commas or 
semicolons to separate multiple tags.

Generally, the tags are the search terms that your users use to search for your project on YouTube. Some examples 
are the subject of your project, or the key terms in the project, or the title.

6 In the Category list, click a category to which your project belongs.

7 Click one of the following options:

• Public: To make your project available for everyone who accesses YouTube.
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• Private: To make your project available to only specific set of users. After uploading the file, log on to YouTube,
and provide permissions for such users. For more information, see this website.

8 Click Terms and Conditions, review them, and click Back.

9 Select the I have read the terms and conditions check box, and click Upload.

The Adobe Captivate Video Publisher displays a message indicating that the video is uploaded successfully.

10 Click Send An email to send the YouTube URLto the required people over mail. to the to the required people. The 
default email application configured on your machine is loaded, and the URL of the project appears in the default 
text of the email.

11 To post the video on Facebook, do the following:

a Select the Facebook check box and log in to Facebook.

If you are accessing Facebook through Adobe Captivate Video Publisher for the first time, you will be prompted 
to go to the Adobe Captivate Social Share app and provide permissions.

b Click Go To App and then click Allow.

c In Adobe Captivate Video Publisher, click Post.

12  To post the video on Twitter, do the following:

a Select the Twitter check box and log on to Twitter.

b Twitter generates a PIN automatically.

c Copy the PIN and paste it in the Enter PIN Here box at the bottom of the dialog box, and then click Set PIN.

d In Adobe Captivate Video Publisher, click Post.

Set publishing preferences in Adobe Captivate
1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select Publish Settings from the Project menu.

3 Set the various options according to your requirements.

Frames Per Second

This option sets the number of Flash frames that appear per second. The default setting is 30 frames per second and 
is appropriate in most cases. For example, with the default setting, a caption that appears for 1 second requires 30 
Flash frames. Dividing the number of frames in a project by 30 gives you the length of the project in seconds. You 
may need to change the rate if you are embedding your Adobe Captivate SWF file in another SWF file that has a 
frame rate other than 30.

Publish Adobe Acrobat Connect Pro Metadata

Adds information to your Adobe Captivate project file (SWF) that makes it easier to integrate the project into Adobe 
Acrobat Connect Pro. The embedded data links the Adobe Captivate CPTX file to the SWF file when you publish 
the project to Connect Server and makes it easier for the Adobe Captivate output file to be found during searches 
done in Adobe Acrobat Connect Pro.

For more information see Adobe Connect .

http://www.google.com/support/youtube/bin/answer.py?answer=157177
http://helpx.adobe.com/en/captivate/using/connect.html#adobe_connect
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Note: Selecting this option increases the size of the project. If you will not use the project with Adobe Acrobat Connect 
Pro, you can clear the option and decrease the size of the finished project file (SWF). However, if there is the possibility 
that the output file (SWF) may be used in Adobe Acrobat Connect Pro, it is a good idea to select the Publish Adobe 
Acrobat Connect Pro Metadata option.

Include Mouse

Includes any recorded mouse movement in the project.

Include Audio

Includes any audio files that have been added to the project.

Publish Audio as Mono

Converts stereo sounds to mono.

Play Tap Audio For Recorded Typing

This option plays tapping sounds in the final project to represent recorded keystrokes. (For example, if you recorded 
an e-mail message being sent, you most likely typed an address to which the e-mail should be sent. The sound of the 
keys being pressed to enter the address was recorded, and using this option, a tapping sound can be played for each 
of the keystrokes.)

Enable Accessibility

Enable this option to make your project accessible to visually impaired users. The text in your project is read aloud 
when users accept the help of a screen reader when viewing the project. In addition, any other accessibility options 
that you have configured in the project are also enabled.

Externalize Resources

When you publish a project as a SWF file, a single SWF file is produced. To reduce the size of the SWF file, you can 
choose to externalize some of its objects (skin, widgets, FMR SWF file, and animations). After publishing, the 
externalized resources reside outside the SWF file, and are referenced by it.

Report quiz results to Acrobat.com or internal server
If you do not want to use a Learning Management System (LMS) for tracking the quiz scores, Adobe Captivate provides 
you with alternate reporting options. You can now choose Acrobat.com or an internal web server as your reporting 
servers. 

After the user submits the quiz result, Adobe Captivate Quiz Results Analyzer, an AIR-based desktop application, lets 
you analyze the assessment report in online and offline modes.

Reporting workflow
1 You create a quiz and set either Acrobat.com or Internal Server as the reporting server preference.

2 User completes the quiz, and submits the result to the reporting server. 

3 You access the report from the server, view, generate, and publish using Adobe Captivate Quiz Results Analyzer.

4 You save the report locally so that it can be analyzed in offline mode.

After you set the reporting preference, the process happens in the background and usually requires no user 
intervention.
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Setting the reporting preferences
1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac). 

2 Select Reporting from the Quiz menu in the Preferences dialog box.

3 Check Enable reporting for this project.

4 Select Acrobat.com or Internal Server and then click Configure.

5 In the Alternate Reporting dialog box, provide the server settings:

• For Acrobat.com: If you have signed up, specify the username and password.

If you are new to Acrobat.com or if you lost your password, click the respective links which take you to
Acrobat.com website where you can register or retrieve your password.

• For Internal Server: Specify the path to the web server as provided in the following example:

http:\\<ip address>\internalServerReporting.php

The internal server can be a web server of your preference.

internalServerReporting.php is the sample PHP that is available in the Adobe Captivate installation folder. You
can either use it or create your own server-side file, for example a PHP or ASP to write files to the server. Ensure 
that the server allows writing to files.

6 Enter the details of the institution that conducts the assessment, department, and course.

Submitting the results
1 After the users complete the quiz, they reach the results slide and then click Post Result.

2 At prompt, the users specify the names and e-mail addresses, and then click Send.

Note: Then name and e-mail address are not verified.

3 Depending on the reporting preference that the author has set, the results are sent to Acrobat.com or internal server.

Viewing the results
Use Adobe Captivate Quiz Results Analyzer for viewing and downloading the results.

Though the user submits the quiz result to Acrobat.com, you cannot directly view the results. If you are using an 
internal web server, manually retrieve the report. Adobe Captivate Quiz Results Analyzer lets you overcome these 
constrains.

Adobe Captivate Quiz Results Analyzer and Offline reporting
Adobe Captivate Quiz Results Analyzer is an AIR-based desktop application that allows you to analyze quiz results that 
are posted on Acrobat.com or internal server.

Use this tool to:

• View results and generate reports

• Save results to a local folder so that they can be viewed in offline mode

• Customize your reports to display or hide the report columns

• Print reports
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• Generate dynamic charts that visually present the results as line charts and bar charts making results easy to
compare. You can also export the reports as CSV.

Note: To use Adobe Captivate Quiz Results Analyzer, you do not require Adobe Captivate installed on your machine.

Installing Adobe Captivate Quiz Results Analyzer
Download the Quiz Results Analyzer.air from Adobe website (www.adobe.com/go/cp5_quizanalyzer) or run it from 
the location where Adobe Captivate is installed. 

Ensure that you have AIR installed because Adobe Captivate Quiz Results Analyzer requires the AIR platform to run. 

You can download AIR from: http://get.adobe.com/air/.

Using the Adobe Captivate Quiz Results Analyzer
Launch the Analyzer and specify the source. The source can be Acrobat.com, Internal server, or (if you have downloaded 
the results) From this computer.

The internal server option appears only if you have added the servers in the preferences of the AIR application. To do 
this, click Options > Preferences and then click Add.

Note: On the internal server, the results are stored in the folder CaptivateResults-<internalservername>.

To download the results to the local computer, click the Download To Disk icon. The results are stored in the folder 
CaptivateResults-<yourAdobeAcrobatID>.

Publish projects as SWF files with Adobe Captivate
You can publish Adobe Captivate projects as SWF files in one of the following formats:

• Flash Player 10 or 10.2

• Flash Player 11

Note: To run projects that you have published using Flash, you must have the same or later version of Flash Player.

1 In an open project, select File > Publish.

2 In the Publish dialog box, select Flash (SWF), and configure the following options:

Project Title

Enter the desired name without the filename extension (.swf).

Folder

Enter the full path for the folder in which to save the file or click Browse to locate the folder. A folder is created with 
the same name as the title, and all published files are moved inside it. If you do not want to create a separate folder 
and want to place the published SWF file in the same folder as the source file, clear the option Publish Files To A 
Folder.

For example, if you have chosen to publish your project variables.swf to the desktop, a folder named variables is 
created on the desktop, and the files are published into this folder. When this option is not chosen, all the published 
files are published directly to the desktop.

Zip Files

http://www.adobe.com/go/cp5_quizanalyzer
http://get.adobe.com/air/
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Creates a ZIP file containing the Flash content (SWF file) and other associated files such as the HTML file required 
to display the SWF file, and a JavaScript for loading the SWF file into the HTML file. When you have enabled 
AICC/SCORM, other supporting files are created. This option is especially useful when you want to create a single 
file for uploading to a learning management system (LMS). For more information, see Configure the project to 
report to LMS.

Full Screen

Opens the file in full screen mode. (You can’t apply this option if you select AICC or SCORM options for the 
project.)

Note: If you select the full screen option, Adobe Captivate generates two HTML files to accommodate the Windows XP 
Service Pack 2 release. Use both HTML files with the SWF file so that when you publish your project users do not receive 
a Service Pack 2 warning message. Link to the HTML file with “fs” added, for example, “myproject_fs.htm.” The HTML 
file with “fs” automatically links to the second HTML file, which, in turn, plays your project.

Generate Autorun For CD

Runs the output file automatically when the CD is inserted into the computer.

Export HTML

Creates a standard JavaScript file that helps embed the SWF file into the generated HTML file.

Export PDF

The generated SWF file is inserted into a PDF file and published. This option is useful to share content over email 
or any other means where the learner doesn't have access to the content through the Flash Player in a browser.

Note: You must have Adobe Acrobat® or Adobe Reader® version 9.0 or later installed on your computer to view the 
output.

Flash Player Version

Adobe Captivate generates the SWF file in the Flash version that you choose.

Seamless Tabbing

Allows users to seamlesslessly tab through Flash content (Adobe Captivate project), and browser controls. This 
option is applicable only for Internet Explorer.

The Project Information area displays useful statistics about the project including the size (resolution), number of 
slides, audio information, e-learning details, accessibility compliance, and the playback control assigned to the project. 
To change any of the options listed in this area, click the blue text.

To change preferences, click Preferences.

After publishing your project as a SWF file, you can use these SWF files independently or include them in web pages. 

Reduce the size of a SWF file
You can reduce the size of the published Flash (SWF) file during the publishing process. However, the quality of the 
published file is compromised.

1 In an open project, select File > Publish.

2 In the left panel, select Flash (SWF).

3 In Flash (SWF) Size And Quality under Project Information in the right panel, click Custom.
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4 In the Settings area, use the slider bar to customize the quality of the file and the file size. For more information, see 
Change project size and quality.

Note: The quality of the file increases as you move to the top of the slider, with a corresponding increase in file size.

5 To use the changed setting whenever the file is published, click Retain Slide Quality Settings.

6 Click OK.

More Help topics 
Learning management system (LMS)

Set publishing preferences

How to upload and share files on Acrobat.com
You can upload Adobe Captivate project files to Acrobat.com and share with users and reviewers instead of sending the 
files by e-mail. 

When you choose to upload or share a project, Adobe Captivate automatically publishes the file to a temporary location 
in one or all of the following formats:

• Adobe Captivate project published as SWF file

• Adobe Captivate project published with output option ZIP

• Adobe Captivate project published with output option PDF

Note: If you choose only CPTX for upload/share, only that file is uploaded and automatic publishing does not occur.

Uploading and sharing files
1 Select File > Collaborate.

2 Select either of the options:

• Upload files

• Upload and share files

Upload Files to Acrobat.com

1 If you have signed up for Acrobat.com, specify the username and password in the Publish to Acrobat.com dialog 
box.

If you are new to Acrobat.com or you lost your password, click the respective links to Acrobat.com website. Follow 
the instructions to register or retrieve your password.

2 After you submit the Acrobat.com credentials, click Sign In.

3 Specify a publish title and check the file types for upload. If files with the same publish title reside on Acrobat.com, 
you are prompted to overwrite. If you do not want to overwrite, but want to upload files, provide a unique publish 
title.

4 Click Upload.

Share Files on Acrobat.com

1 Follow step 1 to step 3 in the section Upload Files to Acrobat.com.

http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#learning_management_system_lms
http://helpx.adobe.com/en/captivate/using/set-publishing-preferences.html#set_publishing_preferences
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2 Click Next and then enter e-mail addresses of people you want to share the files with, e-mail subject, and message.

3 Set one of the following access levels:

Limited access: Only my specific recipients can access and download the file: The recipients must log in with their 
e-mail addresses to access the files. The e-mail addresses using which you shared the files and the e-mail addresses
using which the recipients have signed up for Acrobat.com account must match.

Open access: Anyone who knows the URL can access and download the file: People who know the link can access 
and download the file without signing in to Acrobat.com.

Change the default location of published files
The Adobe Captivate projects are published to the \\Documents and Settings\<user name>\My Documents\My Adobe 
Captivate Projects folder (on Windows) or /Users/<username>/Documents/My Adobe Captivate Projects folder (on 
Mac OS) if you have not made any changes to the settings when publishing the project. You can change this default 
location in the Preferences dialog box.

1 In Adobe Captivate, select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select General Settings from the Global menu.

3 Click the Browse button corresponding to the Publish At field.

4 In the Browse For Folder dialog box, select the folder in which you want the Adobe Captivate projects to be 
published.
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Chapter 16: Using Adobe Captivate with 
Other Applications

Uploading an Adobe Captivate project to a Learning 
Management System
You can use a learning management system (LMS) to distribute a computer-based tutorial created using Adobe 
Captivate over the Internet. A learning management system is used to provide, track, and manage web-based training.

The project that you upload to the LMS must be compliant with the SCORM, AICC standards, or Tin Can API.

SCORM Shareable Content Object Reference Model (SCORM) is a set of specifications used to produce reusable e-
learning objects. It defines communication between a client (such as Adobe Captivate) and a host (usually an LMS). 

SCORM is distributed by Advanced Distributed Learning, an organization under the US Department of Defense.

AICC Aviation Industry CBT [Computer-Based Training] Committee standards define how content for e-learning is 
developed, delivered, and evaluated.

Tin Can API The Tin Can API (sometimes known as the Experience API) is a brand new specification for learning 
technology that makes it possible to collect data about the wide range of experiences a person has (online and offline). 
This API captures data in a consistent format about a person or group’s activities from many technologies. [from 
http://www.tincanapi.com].

Adobe Captivate provides you options to make your projects SCORM/AICC-compliant and also creates the necessary 
files required for compliance to these standards. You can directly upload the published package to an LMS.

Publishing to LMS: Workflow
Use the following workflow to easily create an LMS-ready package using Adobe Captivate and upload it to an LMS:

• Configure the project to report to LMS

• Create a manifest file

• Report button interactions

• View and edit button interactions

• Preview LMS

• Publish the project for an LMS

• Upload to an LMS

Configure the project to report to LMS
1 In an open project, select Quiz > Quiz Preferences. The Preferences dialog box appears with the Quiz Reporting 

category open.

http://www.tincanapi.com
http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#main-pars_header_0
http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#main-pars_header_1
http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#main-pars_header_2
http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#main-pars_heading_7
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2 Select Enable reporting for this project and then select one of the options in the LMS list.

3 If you select Other Standard LMSs in the LMS list, specify one of the following options in the Standard list:

SCORM 1.2 Select if you are using a SCORM 1.2-based LMS. Click Configure to specify the manifest file details. See 
Create a manifest file for more information.

SCORM 2004 Select if you are using a SCORM 2004-based LMS. Click Configure to specify the manifest file details. 
See Create a manifest file for more information.

AICC Select if you are using an AICC-based LMS.

xAPI Select if you have an xAPI or TinCan-based LMS.

4 Specify how you want the status of the course to be reported to LMS.

Incomplete -- > Complete The status of the course is reported as Incomplete in LMS when users launch the course. 
The status changes to Complete when the completion criteria is satisfied.

Incomplete -- > Passed/Failed The status of the course is reported as Incomplete when users launch the course. The 
status changes to Passed/Failed when the completion criteria is satisfied.

User Access Users have successfully completed the course if they launch it from LMS.

http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#main-pars_header_0
http://helpx.adobe.com/en/captivate/using/learning-management-system-lms.html#main-pars_header_0
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Note: Status Representation fields are available only when you choose AICC or SCORM 1.2. However, not all SCORM 
1.2-based or AICC-based LMSs display the status.

5 Specify the success and completion criteria for your course. The status of the course is decided based on whether 
users met these criteria.

Slide Views The course is considered to be complete or successful if users view the specified number or percentage 
of slides.

Tip: For branched quizzes, specify the criterion as percentage of slides. 

Quiz The course is considered to be complete or successful based on the users’ performance in quiz. You can choose 
one of the following criteria:

• Users attempt the quiz: Here, the status is reported as Complete if users attempt the quiz irrespective of whether 
they pass or fail the quiz.

• Users pass the quiz: Here, the status is reported as Complete only if users pass the quiz.

• Users pass or the attempt limit is reached: Here, the status is reported as Complete if users pass the quiz or have
taken all the attempts. For example, if the number of attempts set in the course is 2, and:

• Users take the first attempt and pass, then the status is reported as Complete and Passed.

• Users take the first attempt and fail, then the status is reported as Incomplete and Failed as the attempt limit
is still not reached.

• If users retake the quiz and fail, the status is reported as Complete and Failed.

• If users attempt the quiz again and pass, the status is reported as Complete and Passed.

Note: SCORM 2004 supports two types of status: Success and Completion status. You can configure Adobe Captivate to 
send these two statuses to a SCORM 2004-based LMS separately. For example, criteria for Completion status can be 
‘slide views 100%’ while Success criteria can be ‘quiz is passed’.

6 Specify how the data is reported to LMS. 

Quiz Score Report the quiz score as percentage or as points.

Interaction Data Report user interaction data, for example, the question attempted by users, and the answer 
provided them.

7 In the LMS Initialization text field, type the text that you want to display to users while the course loads in the web 
browser.

8 Click Advanced to specify the following advanced settings:

Send Data on Every Slide Send interaction details after every slide.

Never Send Resume Data The project notifies the LMS when users resume a session after taking a break. Users see 
the page at which they left off earlier. If this option is enabled, users see the first page when they resume the project.

Escape Version and Session ID Converts the version and session ID to its URL encoded values. 

Don’t Escape Characters Supports the escape version and session ID option. Type the characters that must not be 
included in the escape version and session ID.

Create a manifest file
Note: Skip this section if you are using an AICC-compliant LMS. 

1 From the top of the Quiz > Quiz Preferences dialog, click the Configure button.
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The Manifest dialog box opens.

2 Set up the course information. 

Note: Depending on the LMS used, the Manifest dialog box options vary.

Identifier (Required field) The identifier used by the LMS to identify different manifests. A default identifier based 
on the name of your Adobe Captivate project is automatically added to this field. You can change the identifier at 
any time by selecting the text and typing in new text. 

Title (Required field) The title of your project that is displayed to the user viewing the project using an LMS. A 
default title based on the name of your Adobe Captivate project is automatically added to this field. You can change 
the title at any time by selecting the text and typing in new text. 

Description (Required field) The text that the LMS displays to describe your project. A default description based on 
the name of your Adobe Captivate project is automatically added to this field. You can edit the description at any 
time. 

Version (Required field) The version specifies a number that can be used to differentiate manifests with the same 
identifier. For example, if you are uploading the same project after modifying it, use a different version number. 

Duration (Optional field) The time required for learners to complete the project. Adobe Captivate prepopulates this 
field with an approximate value. However, if your project is ‘heavy’, for example, if it contains videos or animations, 
you can revise this value.
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SCO area:

These options are not applicable for xAPI or TinCan-based LMS.

Identifier

(Required field) The LMS uses the identifier to identify different shareable content objects (SCOs). In the Adobe 
Captivate context, SCO means the Adobe Captivate project. A default identifier based on the name of your Adobe 
Captivate project is automatically added to this field. You can change the identifier at any time by selecting the text 
and typing in new text.

Note: A course can contain more than one project. Each project is treated as a distinct SCO. However, Adobe 
Captivate does not support more than one project in a course.

Title

(Required field) A default title based on the name of your Adobe Captivate project is automatically added to this 
field. You can change the title at any time by selecting the text and typing in new text.

The manifest file is generated. To see the manifest file, publish your Adobe Captivate project and create a SWF file. If 
you used the default save location, you see the SWF file and imsmanifest.xml file in your My Documents\My Adobe 
Captivate 6 Projects folder (on Windows) /Users/<username>/Documents/My Adobe Captivate Projects folder (on 
Mac OS).

Files Created 
When you enable reporting for the project by setting the SCORM options, Adobe Captivate creates the following files 
when the project is published:

• Manifest File This file is used to import the Adobe Captivate project into the LMS. The manifest file,
imsmanifest.xml, contains the metadata of the project and its course structure.

• HTML File Launches the Adobe Captivate project from the LMS.

• JavaScript File Acts as a link between the SWF file and the LMS. Adobe Captivate sends tracking data to the LMS
using the JavaScript APIs.

• SWF File The contents of the published project are stored in the SWF file. Other supporting files (.xsd files) contain 
other information required by the LMS.

Report button interactions
Check that you have set up the scoring interactions in your project correctly (that is, they are included in the quiz, and 
have the correct point weightage). 

For more information, see Reporting tab.

View and edit button interactions
Before publishing to the LMS, you can check if the scoring has been set up correctly though the Project > Advanced 
Interaction dialog box.
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If you notice errors in your scoring, you can directly navigate to the interaction and correct it. Double-click the 
interaction to select it and configure its reporting options using the Reporting tab in the Actions panel on the Property 
Inspector.

For more information, see Edit object information using the Advanced Interaction panel.

Preview LMS
Adobe Captivate allows you to verify your learning content in an LMS. This feature enables you to get an early view of 
how your learning content output appears in an LMS application. This is a handy and quick way for you to fix LMS-
related issues before publishing the content to your actual LMS. 

Click Preview icon in the toolbar and choose Preview in SCORM Cloud from the drop-down list. LMS preview window 
appears. You can debug your project in preview mode and also view SCORM communication logs. 
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By default, the communication logs screen appears hidden. Click at the lower right corner of the window, to view 
the communication logs. 

Click to download the logs text file to your computer.

If you close the preview mode inadvertently, a pop-up window appears with three options: 

• Get Results - to view the results of your learning content/quiz content.

• Relaunch the Preview - to go back to the preview mode.

• Close - to close the preview mode and erase all the temporary LMS preview files from the server.

Here is an example of a SCORM result page:
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Publish the project for an LMS
When you choose to zip the published files, the entire set of published files is compressed into a single ZIP file. The ZIP 
file containing the manifest file is also called a PIF (Package Interchange File). SCORM guidelines recommend, but do 
not require, the use of a PIF for transporting content packages between systems. However, some LMSs require you to 
upload the project as a PIF. In any case, it is always simpler to upload a single file to the LMS rather than many files.

1 Open an Adobe Captivate project.

2 Select File > Publish.

3 In the Publish as drop-down, select HTML5/SWF.

4 In Project Title, enter the name without the filename extension (.swf).

5 In the Folder text box, enter the full path to the folder in which to save the file or click Browse to locate the folder.

By default, Zip Files is selected as the output option. Adobe Captivate packages the course into a PIF by creating a 
ZIP file containing the Flash (SWF) file and the HTML file.

6 Click Publish.

After publishing the project, upload the ZIP file to your LMS, and distribute the URL provided by the LMS to your 
users.
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Access Adobe Captivate courses in cross-domain environments
If the web server on which you have hosted your Adobe Captivate HTML5 course and your LMS are in different 
domains, perform the following steps to set up the course:

1  Publish your AICC-based Adobe Captivate course as an HTML5 course.

2  Go to the publish folder and open the index.html file in Wordpad or Notepad.

3 Search for the comment “Uncomment below line to run across domain for HTML5” and uncomment the lines that 
follow this comment.

4 Save the changes in the file and upload your course onto the web server.

Learn about the Common JavaScript interface for Adobe 
Captivate
Adobe Captivate enables its users to make more powerful, yet leaner content using the new JavaScript Interface feature. 
This feature gives a common platform for executing JavaScript actions between SWF and HTML. Also, it makes 
JavaScript access to the actual content easier.

Now, you can write smaller JavaScript snippets to access different variables in the content. You can subscribe to different 
events generated by the content. You can perform all these small but powerful tasks easily without worrying about 
whether the content is SWF content or HTML. 

You can use the common JavaScript interface in two ways: 

1 Execute JavaScript action from Captivate project. 

2 Add JavaScript code to the published HTML at runtime.

See Examples section for more information. 

As depicted in the above diagram, the JavaScript acts as an interface between the browser and your content 
(SWF/HTML5). 

http://helpx.adobe.com/en/captivate/using/common-js-interface.html?cq_ck=1400557514529#Examples
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cpAPIInterface
This object is the main object which holds the complete JavaScript interface. It contains many small utility functions 
which are required often in Execute JavaScript actions. 

cpAPIInterface is an object available in the window scope. To access the interface object, following is the recommended 
use: window.cpAPIInterface

Methods:

Name Description Parameters Usage

getVariableValue Returns the value of the given 
variable name.

- window.cpAPIInterface. 
getVariableValue 
("cpQuizInfoStudentID");

setVariableValue Sets the value of the given 
variable name with the given 
value.

variableName:String window.cpAPIInterface. 
setVariableValue 
("cpQuizInfoStudentID", "John");

play Plays the movie. window.cpAPIInterface. play();

pause Pauses the movie. window.cpAPIInterface. pause();

stop Stops the movie. window.cpAPIInterface. stop();

rewind Rewinds and plays the movie. window.cpAPIInterface. rewind();

next Seeks the movie to the next slide. window.cpAPIInterface. next();

previous Seeks the movie to the previous 
slide.

window.cpAPIInterface. 
previous();

fastForward Increases the movie speed to 2x, 
then 4x and then back to normal 
on consecutive calls.

window.cpAPIInterface. 
fastForward();

getPlaySpeed Returns the movie playback 
speed in Frames per second (fps).

window.cpAPIInterface. 
getPlaySpeed();

getDurationInFrames Returns the total number of 
frames in the movie.

window.cpAPIInterface. 
getDurationInFrames();

getDurationInSeconds Returns the total duration of the 
movie in seconds.

window.cpAPIInterface. 
getDurationInSeconds();

getVolume Returns the volume of the movie 
in percentage.

window.cpAPIInterface. 
getVolume();

setVolume Sets the volume of the movie. volume:Number (range : 0 - 1) window.cpAPIInterface. 
setVolume(0.7);

navigateToTime Seeks to a particular time 
(milliseconds) in the movie.

timeInMilliseconds:Number window.cpAPIInterface. 
navigateToTime(3000);

canNavigateToTime Returns a boolean value showing 
whether you can seek to a 
particular time in the movie or 
not.

timeInMilliseconds:Number window.cpAPIInterface. 
canNavigateToTime(3000);



422
Using Adobe Captivate with Other Applications

Last updated 10/10/2016

cpAPIEventEmitter
This object is similar to any other Event Manager. It provides you the mechanism to subscribe/unsubscribe to different 
events which are generated within the content.

cpAPIEventEmitter is an object available in the window scope. To access the interface object, following is the 
recommended use : window.cpAPIEventEmitter

Methods:

getCurrentFrame Returns the current frame of the 
movie.

window.cpAPIInterface. 
getCurrentFrame();

getCurrentSlideIndex Returns the current slide index of 
the movie.

window.cpAPIInterface. 
getCurrentSlideIndex();

getEventEmitter Returns the handle to the 
cpAPIEventEmitter object.

window.cpAPIInterface. 
getEventEmitter();

Name Description Parameters Usage

add EventListener Adds an event listener function to 
a particular event.

• eventName : One of the event 
names listed in this page.

• eventListenerFunction : Any 
JavaScript function.

• variableName : 

1 optional.

2 One of the Captivate
variable name whose 
value change should 
be notified.

3 Should only be used 
withCPAPI_ 
VARIABLEVALUEC
HANGED event.

• window. cpAPIEventEmitter. 
addEventListener("CPAPI_ 
MOVIESTART", function(){alert
("Movie Started");});

• window. cpAPIEventEmitter. 
addEventListener 
("CPAPI_VARIABLE 
VALUECHANGED", 
function(){alert("Variable Value
Changed");}, 
"cpQuizInfoStudentID");

remove EventListener Removes the event listener 
function for a particular event.

• eventName : One of the event 
names listed in this page.

• eventListenerFunction : Any 
JavaScript function.

• variableName : 

• optional.

• One of the Captivate
variable name whose 
value change should
be notified.

• Should only be used
with CPAPI_
VARIABLEVALUEC
HANGED event.

• window. cpAPIEventEmitter. 
removeEventListener 
("CPAPI_MOVIESTART", 
function() {alert("Movie 
Started");});

• window. cpAPIEventEmitter. 
removeEventListener 
("CPAPI_VARIABLE 
VALUECHANGED", 
function(){alert ("Variable Value
Changed");}, 
"cpQuizInfoStudentID");
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List of Events:

Name Description Event Data Enumerations

CPAPI_SLIDEENTER Notifies that movie has entered a 
new slide.

slideNumber=NUMBER;

frameNumber=NUMBER;

 lcpversion=STRING;

CPAPI_SLIDEEXIT Notifies that movie is exiting a 
slide.

slideNumber=NUMBER;

frameNumber=NUMBER;

lcpversion=STRING;

percentageSlideSeen= 
NUMBER;

CPAPI_ 
STARTPLAYBARSCRUBBING

Notifies that user has started 
seeking the movie using playbar.

CPAPI_ ENDPLAYBARSCRUBBING Notifies that user has stopped 
seeking the movie using playbar.

CPAPI_ INTERACTIVEITEMSUBMIT Notifies that user has performed 
an interaction with an interactive 
item.

frameNumber=NUMBER;includ
edInQuiz=BOOLEAN;issuccess=
BOOLEAN;itemname=STRING;ob
jecttype=NUMBER;questioneve
ntdata= [object 
Object];slideNumber=NUMBER;

CPAPI_MOVIEPAUSE Notifies that movie has paused.

CPAPI_MOVIERESUME Notifies that movie has resumed 
from a paused state.

CPAPI_MOVIESTART Notifies that movie has started.

CPAPI_MOVIESTOP Notifies that movie has stopped.
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CPAPI_QUESTIONSKIP Notifies that user has skipped a 
question slide.

correctAnswer=STRING;infinite
Attempts=BOOLEAN;interactio
nID=NUMBER;objectiveID=STRI
NG;questionAnswered=BOOLEA
N;questionAnsweredCorrectly=
BOOLEAN;questionAttempts=N
UMBER;questionMaxAttempts=
NUMBER;questionMaxScore=N
UMBER;questionNumber=NUM
BER;questionScore=NUMBER;qu
estionScoringType= [object 
Object],{Name:STRING};question
Type=STRING;quizName=STRIN
G;reportAnswers=BOOLEAN;sel
ectedAnswer=STRING;slideNum
ber=NUMBER;

interactionType -

• choice

• true-false

• fill-in

• long-fill-in

• hotspot

• sequencing

• matching

• likert
questionType -

• choice

• true-false

• fill-in

• long-fill-in

• hot-spot

• sequencing

• matching

• likert
questionScoringType ["Name"] 
-

• PretestQuestion

• GradedQuestion

• SurveyQuestion

CPAPI_QUESTIONSUBMIT Notifies that movie has answered 
a question slide.

correctAnswer=STRING;infinite
Attempts=BOOLEAN;interactio
nID=NUMBER;objectiveID=STRI
NG;questionAnswered=BOOLEA
N;questionAnsweredCorrectly= 
BOOLEAN;questionAttempts=N
UMBER;questionMaxAttempts=
NUMBER;questionMaxScore=N
UMBER;questionNumber=NUM
BER;questionScore=NUMBER;qu
estionScoringType=[object 
Object],{Name:STRING};question
Type=STRING;quizName=STRIN
G;reportAnswers=BOOLEAN;sel
ectedAnswer=STRING;slideNum
ber=NUMBER;

CPAPI_ 
VARIABLEVALUECHANGED

Subscribing to this event requires 
an additional parameter - 
variableName. Once subscribed, 
any change to the value of the 
supplied variable will be notified.

captivateVersion=STRING;varN
ame=STRING;oldVal=STRING;ne
wVal=STRING;
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moduleReadyEvent
Captivate content also fires a moduleReadyEvent on the parent window object to notify that the content is loaded. Users 
can use this event as the notification for the availability of the JavaScript interface. Following snippet allows you to add 
a listener to moduleReadyEvent :

window.addEventListener("moduleReadyEvent", function(evt) 
{ 
//evt.Data carries the interface object. 
//It is same as window.cpAPIInterface 
var interfaceObj = evt.Data; 
var eventEmitterObj = interfaceObj.getEventEmitter(); 
});

Examples

Generating a random number
The code below generates a random number between 0 and 1.

alert(Math.random());

The following code generates a number between 1 and 10.

alert(Math.floor((Math.random()*10)+1));

The following code uses a function to generate a random number between two integers that are passed as arguments 

in

 the function.

function getRandomInt(min, max) { 
  var jsRandomNumber = Math.floor(Math.random() * (max - min + 1)) + min; 
  alert(jsRandomNumber); 
} 
getRandomInt(10, 300);

Using Geolocation
Using geolocation, you can use a learner's geographic location to trigger certain events in a course or determine which 
learning objects stay hidden or displayed.

For example, a learner in New York can view only US-centric materials in a course, whereas another learner can view 
only US-centric materials of the same course.

You can configure this scenario using Advanced Actions, but you can also configure geolocation support using 
JavaScript.

1 Create a variable of type Geolocation and assign the following values to the variable:

• Latitude

• Longitude

• Accuracy

2 Create a project with two objects, 

3 ss1
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4  and ss2. 

Depending on the configured Geolocation variable, you will show object ss2 and hide object ss1.

To hide any object, use cp.hide("object_name");To show any object, use cp.show("object_name"); 

5 On the first slide, choose Actions and select Execute JavaScript from the On Enter drop-down list. In the script 
window, enter the following code:
window.cpAPIEventEmitter.CPAPI_SLIDEENTER; 
window.cpAPIInterface.setVariableValue("cpInfoGeoLocation","BLR"); 
if (window.cpAPIInterface.getVariableValue("cpInfoGeoLocation")==="BLR") 
{ 
   cp.hide("ss1"); // hide object ss1 
   cp.show("ss2"); // show object ss2 
}

6 Preview the project. You can see that an object is displayed or hidden based on the Geolocation variable.

Using local storage
With local storage, you can store data locally within the browser. For example,

localStorage.setItem("learnerName","John");

Using the dot notation,

localStorage.learnerName="John";

In local storage, data is persisted even after you close and reopen the browser.

In Adobe Captivate, you can use local storage to transfer variables from one course to the next. To implement local 
storage,

1 In a blank project, create a variable learnerName that stores the name of the learner.

2 Assign the variable to a text entry box. Any name you enter in the box gets assigned to the new variable.

3 Create a button near the text entry box. Enter the following JavaScript code so that the code is triggered when you 
click the button.

localStorage.setItem("learnerName", 
window.cpAPIInterface.getVariableValue("learnerName"));

4 Preview the project in a browser. Enter the name of a learner and click Submit. Once you assign the name to the 
variable, the value is now stored in the local storage.

5 Open the browser's debugger mode. For example, in Chrome, open the debugger mode and click the Resources tab. 
Expand Local Storage and choose the required host.
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You can see the variable value stored in the local storage as a key-value pair.

Using session storage
In session storage, data stored gets cleared when you end a page session. A page session lasts as long as the page is open 
in a browser. If you open the page in a new tab or window, a new session starts.

sessionStorage("learnerName","John");

To get the data from session storage,

var myData = sessionStorage.getItem("learnerName");

To remove data from session storage,

sessionStorage.removeItem("learnerName");

In Captivate, you can store the name of a learner in session storage. For example,

sessionStorage.setItem("newLearner", window.cpAPIInterface.getVariableValue("newLearner"));

1 Name of the learner.

2 Name of the variable.

3 Value of the variable.
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After previewing the project in browser, open the debugger console and in sessionStorage, you can find the name of the 
learner, as shown below:

Incrementing slide counter
The following code gets value of a custom variable "mySlideVisitCounter", increments it whenever user enters a slide 
and sets it back in the content.

//check if window.cpAPIInterface is available 
if(window.cpAPIInterface)  
{ 
//check if window.cpAPIEventEmitter is available 
if(window.cpAPIEventEmitter)  
{ 

//add a listener to CPAPI_SLIDEENTER event 
window.cpAPIEventEmitter.addEventListener("CPAPI_SLIDEENTER",function(e) 

{ 
//get the current value of 

mySlideVisitCounter from Captivate content 
var lSlideVisitCtr = 

window.cpAPIInterface.getVariableValue("mySlideVisitCounter"); 
//increment 

lSlideVisitCtr by 1 
lSlideVisitCtr = 

lSlideVisitCtr + 1; 
//set the value of 

mySlideVisitCounter in the Captivate content 

window.cpAPIInterface.setVariableValue("mySlideVisitCounter",lSlideVisitCtr); 
}); 

} 
}

The above code can be used as follows :

Execute JavaScript action 

a From Captivate project, click Actions tab in Property Inspector

1 Name of the variable.

2 Value of the variable.
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b In OnEnter drop-down, select Execute JavaScript and click Script_Window

c Paste the JavaScript code in the window. 

You can execute javascript action from any Captivate action as shown in the following screenshot: 

1 Modifying the published content 

You can also publish the content and then access the content internals using the JavaScript interface from outside.

Add the following snippet in the published HTML :
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<script> 
var interfaceObj; 
var eventEmitterObj; 
window.addEventListener("moduleReadyEvent", function(evt) 
{ 
   //evt.Data carries the interface object. 
   //It is same as window.cpAPIInterface 
   interfaceObj = evt.Data; 
   eventEmitterObj = interfaceObj.getEventEmitter(); 
}); 
//check if window.cpAPIInterface is available 
if(interfaceObj) 
{ 
   //check if window.cpAPIEventEmitter is available 
   if(eventEmitterObj) 
   { 

//add a listener to CPAPI_SLIDEENTER event 
eventEmitterObj.addEventListener("CPAPI_SLIDEENTER",function(e) 

{ 
//get the current value of 

mySlideVisitCounter from Captivate content  
var lSlideVisitCtr = 

interfaceObj.getVariableValue("mySlideVisitCounter");   
  //increment lSlideVisitCtr by 1 

   lSlideVisitCtr = lSlideVisitCtr + 1; 
//set the value of 

mySlideVisitCounter in the Captivate content 

interfaceObj.setVariableValue("mySlideVisitCounter",lSlideVisitCtr); 
}); 

   } 
} 
</script>

Sample project
You can download the attached sample Captivate project for your reference. 

Common-JS-interface.zip

Support for Adobe Captivate App Packager 
discontinued
From Adobe Captivate 8 version onwards, Adobe Captivate App packager is no longer supported. In Adobe Captivate 
8.0.1, the app packager is integrated into the software with the same functionality as the Adobe Captivate App Packager. 

If you are using Adobe Captivate 8 version, you need to install 8.0.1 patch in order to use the app packager. Refer to 
installation instructions of 8.0.1 patch for more information. 

if you are already using Adobe Captivate 8.0.1, refer to the following help content to start using the built-in app 
packager: 

• For information on publishing apps for devices in responsive projects, see Publish as Apps for devices

http://helpx.adobe.com/captivate/using/common-js-interface/_jcr_content/main-pars/download/file.res/Common-JS-interface.zip
http://helpx.adobe.com/en/captivate/kb/cp8-patch.html##Installation instructions
http://helpx.adobe.com/en/captivate/using/preview-publishing.html#Publish as apps for devices
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• For non-responsive/blank projects, see Publish as Apps for devices

Using Captivate with Animate CC
If you are an Animate developer, use Adobe Captivate to record 

a SWF

 file. Then use the features of Animate CC to edit the file.

Export from Adobe Captivate to Animate CC
You can export a project from Adobe Captivate to Animate CC. You can enhance it or integrate it into a larger project.

Note: You need not have Animate CC installed to perform this task.

When you export an Adobe Captivate project into Animate CC, the project is imported directly to the Stage. The 
imported project contains layers for each type of object. Appropriate Animate CC methods are used to enable any 
Adobe Captivate special effects (for example, tweens to move the mouse pointer). The Flash Library panel shows all 
objects created for the Adobe Captivate project, organized logically into folders.

Import of the following slide elements are supported: highlight box, captions, animation, click box, text entry box, and 
rollover caption.

Most elements in your projects are converted so they look and operate the same in Animate CC as in Adobe Captivate, 
but here are a few exceptions:

• Question slides

• Imported mouse paths are linear, and not curved like in Adobe Captivate.

• Advanced compression

• Playback controller

• 508 compliance

• Drawing objects

• Interactive objects are not completely supported.

• Slide transitions (fade between slides)

1 In an open project, select File > Export > To Flash CC.

2 In the Export To Flash Options dialog box, specify the location and select the elements to export. These options are 
self-explanatory, but note that Hints are a Flash feature, not an Adobe Captivate element that is imported into Flash. 
Hints are not included in the project SWF file.

3 Click Export. If you have installed Animate CC, the exported file opens in Animate CC.

Modifying Adobe Captivate projects in Animate CC
Use the Animate CC Library and movie clip objects to create reusable elements from the original project.

When you become familiar with the structure of the project in Animate CC, you can easily change your entire project 
or place Adobe Captivate elements in it. All the Adobe Captivate project elements are stored in the Animate CC Library 
and organized into folders. Navigate through these folders to select elements for editing.

http://helpx.adobe.com/en/captivate/using/publish-projects-html5-files.html#Publishing projects as app to devices
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The following layers are seen in the Timeline when you open an Adobe Captivate project in Animate CC.

Preloader This is the file that plays until the movie is downloaded to the user’s computer. For example, you could have 
a GIF file that informs the player that the movie is being downloaded until the download is complete.

Actions The global actions defined in a movie. You can define global variables and declarations using the Actions layer 
in the Timeline.

Slides Contains the imported slides in the order in which they appear in the movie.

When you double-click the slide, the Timeline in the next view contains objects corresponding to that slide. Use the 
Timeline to edit the various objects on the slide. Keep double-clicking an object to edit its different parts. The Timeline 
changes to reflect the various parts of the object.

Navigating through projects in Animate CC
Remember these points when you navigate: 

• In the Library panel, a folder named Adobe Captivate Objects contains all slides and objects in the project. (You can 
ignore the objects listed with the prefix “xrd”; these objects are images and sounds that are used in other objects.)
To edit your project, double-click a library item and edit it. The “xrd” files are shown in a folder in the library.

• Another way to navigate is to double-click elements on the Stage (in Animate CC). For example, to edit a movie,
double-click the movie on the Stage. To navigate to an element on a slide, click in the Timeline. Position the playhead
to show an object on the slide (such as a caption or highlight box). Then double-click the object to edit it. This
method has the advantage of showing each element and object in the context in which it is used.

• Unlike Adobe Captivate, Animate CC does not show all objects at one time; Animate CC uses the Timeline to
represent when different objects are shown. Click in the Timeline or drag the playhead to preview the project.

• The Library panel organizes your project and all of the elements it contains, such as slides, captions, and sounds,
into a hierarchy of folders.

Record application in Animate CC
You can now record applications in all Adobe Captivate recording modes from within the Animate CC workspace 
(without launching Adobe Captivate).

1 In Adobe Flash Professional CS6, select Command > Record Application.

2 Click the recording icon and then start recording.

Note: This feature is available only in Adobe Captivate that is installed as a part of Adobe eLearning Suite.

Adobe Flash round-tripping
You can instantly update the SWF files in Adobe Captivate by editing the source FLA files in Adobe Flash. You can 
launch Adobe Flash from within Adobe Captivate.

Using Adobe Flash to edit animation objects and widgets
1 Right-click (Windows) or Control-click (Mac OS) the animation or the widget and then select Edit With Flash. The 

FLA file that is associated with the SWF file is opened for editing in Adobe Flash. 

2 Edit the FLA file, generate a SWF file output, and then save the file in the same location where the original SWF file 
was saved. Also, use the same name for the new SWF file. 

All instances of the SWF file used in the Adobe Captivate project get automatically updated.
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You can also open Adobe Flash manually and edit the FLA file associated with the SWF file. However, you can manually 
synchronize the files by selecting Update in the right-click menu. at the corner of the object or widget indicates that 
the SWF file is not synchronized with its source. indicates that the SWF file is up-to-date and indicates that the 
SWF file is not available.

Replacing animation SWF files
Do one of the following in the Properties panel:

• Click the hyperlinked SWF file, browse to the location where the replacement SWF file is located, and click Open.

• Click Swap. In the Select Animation From the Library dialog box, select the replacement SWF file in the project’s
library. Using this dialog box, you can also import SWF files saved in other locations and then select the file to
replace the current one.

How to publish Captivate projects to Microsoft Word
If you have Microsoft® Word® installed on the same computer as Adobe Captivate, you can publish Adobe Captivate 
projects in Microsoft Word. Your output can be published in various formats: handout, lesson, step-by-step, and 
storyboard.

Publish projects as handouts
You can publish Adobe Captivate projects as handouts in Microsoft Word format. An Adobe Captivate project is 
published into a Word document showing all the slides as they would appear with the options you choose.

1 Open an Adobe Captivate project.

2 Select File > Print.

A Print dialog appears. 



434
Using Adobe Captivate with Other Applications

Last updated 10/10/2016

3 In Project Title, enter the desired name without the filename extension (.doc).

4 In Folder, enter the full path for the folder in which to save the file or click Browse to locate the folder.

5 Select an Export range. The export range is made up of the slides that you want to export to Word. You can select 
all slides, the current slide, a selection, or a range of slides.

6 In Type, select Handouts.

7 Select from the following Handout Layout options:

Use tables in the output Specify the number of slides printed on each page.

Slides per page Specify the number of slides printed on each page of the Word document. A small thumbnail image 
to the right shows a preview of the page layout selected.

Caption Text Print the text of captions underneath the slides on which they appear.

Add blank line for notes Print blank lines with each slide of your project in the Word document. The lines appear 
under the slide if you select Use Tables in the output. If you deselect that option, the blank lines appear to the right 
of the slide.

Slide notes Include slide notes in your Word document. (Users who view your project don’t see these notes.)

Include hidden slides Include slides marked as hidden. (Hidden slides do not appear when the project is viewed.) 

Include mouse path Include mouse paths that appear on slides.

Include objects and questions Include captions, images, click boxes, highlight boxes, and other objects on slides.

Include question pool slides Includes question slides from the question pool.

8 When you finish, click Publish.

Microsoft Word opens with the new project document. Modify the file as desired and save it.
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Note: The DOC file is created using a Microsoft Word template named AdobeCaptivate.dot. This template contains a 
header with the date and a footer with page numbers. If you want to change or remove the information in the header 
or footer, you can edit the DOT file by opening it in Word. When you install Adobe Captivate, the AdobeCaptivate.dot 
template is automatically placed in the program folder: \\Program Files\Adobe\Adobe Captivate 
8\Gallery\PrintOutput (on Windows) or /Applications/Adobe Captivate 8/Gallery/PrintOutput (on Mac OS).

Publish projects as lessons
You can publish Adobe Captivate projects as lessons in Microsoft Word format. An Adobe Captivate project is 
published in a Word document as a lesson, complete with your questions and an answer key.

1 In an open project, Select File > Print.

A Print dialog appears.

2 In Project Title, enter the desired name without the filename extension (.doc).

3 In Folder, enter the full path for the folder in which to save the file or click Browse to locate the folder.

4 Select an export range. The export range is made up of the slides that you want to export to Word. You can select all 
slides, only the current slide, only the current selection, or a range of slides.

5 In Type, select Lesson.

6 Select from the following Template options:

Header text Enter text that you want to appear in the header of the project. 

Footer text Enter text that you want to appear in the footer of the project. 

Include hidden slides Select this option if you want hidden slides to appear in the published project. 

Include quiz question slides Select this option if you want to include quiz question slides in the published project.

Include question pool slides Select this option if you want the published project to include question slides from the 
question pool. 

7 When you finish, click Publish.

Microsoft Word opens with the new project document. Modify the file as desired and save it. 

Note: The Lesson, Storyboard, and Step By Step templates are stored in the Gallery (C:\Program Files\Adobe\Adobe 
Captivate 8\Gallery\PrintOutPut (on Windows) or /Applications/Adobe Captivate 8/Gallery/PrintOutput (on Mac 
OS)). When Adobe Captivate is first launched, these templates are copied to the user profile (for example, C:\Documents 
and Settings\<User>\My Documents\My Adobe Captivate Projects\Templates\PrintOutput).

Publish projects as step-by-step guides
You can publish Adobe Captivate projects as a step-by-step guide in Microsoft Word format. An Adobe Captivate 
project is published in a Word document that lists a summary of the steps taken in the project. For example, if the 
project teaches a user how to navigate to a website, the step-by-step guide lists the steps taken to get there. The step-by-
step guide does not include images of the project slides, but does include images of objects (buttons, links, and so on).

1 Open an Adobe Captivate project.

2 Select File > Print. 

A Print dialog appears.

3 In Project Title, enter the desired name without the filename extension (.doc).

4 In Folder, enter the full path for the folder in which to save the file or click Browse to locate the folder.
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5 Select an export range. The export range is made up of the slides that you want to export to Word. You can select all 
slides, only the current slide, only the current selection, or a range of slides.

6 In Type, select Step By Step.

7 Select from the following Template options:

Header text Enter text that you want to appear in the header of the project. 

Footer text Enter text that you want to appear in the footer of the project. 

Include hidden slides Select this option if you want hidden slides to appear in the published project. 

8 When you finish, click Publish.

Microsoft Word opens with the new project document. Modify the file as desired and save it.

Note: The Lesson, Storyboard, and Step By Step templates are stored in the Gallery (C:\Program Files\Adobe\Adobe 
Captivate 8\Gallery\PrintOutPut on Windows or /Applications/Adobe Captivate 8/Gallery/PrintOutput on Mac OS). 
When Adobe Captivate is first launched, these templates are copied to the user profile (for example, C:\Documents and 
Settings\<User>\My Documents\My Adobe Captivate Projects\Templates\PrintOutput).

Publish projects as storyboards
You can publish Adobe Captivate projects as storyboards in Microsoft Word format. The project is published as a Word 
document that includes a summary of project properties and a detailed view of each slide. Project properties include 
the number of slides used, score setting details, length of the slides, and so on. The detailed view of each slide has a 
summary of slide properties.

If the project has a quiz and you choose Storyboard output, the answers are shown next to the question. There is no 
answer key.

1 Open an Adobe Captivate project.

2 Select File > Print.

A Print dialog appears.

3 In Project Title, enter the desired name without the filename extension (.doc).

4 In Folder, enter the full path for the folder in which to save the file or click Browse to locate the folder.

5 Select an export range. The export range is made up of the slides that you want to export to Word. You can select all 
slides, only the current slide, only the current selection, or a range of slides.

6 In Type, select Storyboard.

7 Select from the following Template options:

Header text Enter text that you want to appear in the header of the project. 

Footer text Enter text that you want to appear in the footer of the project. 

Include hidden slides Select this option if you want the published project to include hidden slides. 

Include quiz question slides Select this option if you want the published project to include quiz question slides.

Include question pool slides Select this option if you want the project to include question slides from the question 
pool.

8 When you are done, click Publish.

Microsoft Word opens with the new project document. Modify the file as desired and save it. 
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Note: The Lesson, Storyboard, and Step By Step templates are stored in the Gallery (C:\Program Files\Adobe\Adobe 
Captivate 8\Gallery\PrintOutPut on Windows or /Applications/Adobe Captivate 8/Gallery/PrintOutput on Mac OS). 
When Adobe Captivate is first launched, these templates are copied to the user profile (for example, C:\Documents and 
Settings\<User>\My Documents\My Adobe Captivate Projects\Templates\PrintOutput).

More Help topics 
Edit project preferences

Using Adobe Connect with Captivate
Use Adobe® Connect™ to host online meetings, presentations, and training over the Internet. The integration between 
Adobe Connect and Adobe Captivate allows you to include interactive software simulations and demonstrations in 
Connect meetings.

The key integration features include the following:

Adobe® Connect™ Training Increase meeting and training effectiveness by adding Adobe Captivate demonstrations 
and interactive simulations. Presenters can use the Sync button to make their actions visible to all participants. If the 
presenter turns off the Sync option, participants can fully interact with the Adobe Captivate demonstration or 
simulation on their individual computers.

Deliver and publish with ease Deliver Adobe Captivate simulations and demonstrations through standard web 
browsers. Adobe Connect users can publish Adobe Captivate projects directly to Adobe Connect, making them 
accessible to others.

Use options for integrating Adobe Captivate and Adobe Connect In Adobe Captivate, you can select two options that 
help Adobe Captivate and Adobe Connect work together smoothly. The Include Adobe Acrobat Connect Metadata 
option adds Connect information to the Adobe Captivate project files. When this option is set, users can search the 
Adobe Captivate project and its contents from Adobe Connect. You can also select Adobe Connect as your quiz 
reporting output option. Use this option in Adobe Connect to track how users work with quizzes and interactive objects 
in Adobe Captivate projects. You can also place the project into a ZIP file for easier uploading. With Adobe Connect 
integration, you can also update video files easily.

Using Adobe Connect for learning management
Adobe Connect lets you easily deliver elearning content through live virtual classrooms and self-paced courses, manage 
participants, and track learner progress. For more information on the Adobe Connect's learning management system 
integration solutions, see www.adobe.com/go/learn_adobeconnectlms_en.

You can leverage the learning management features of Adobe Connect for your Adobe Captivate projects. Do the 
following to upload an Adobe Captivate project to an Adobe Connect server:

• Specify Adobe Connect as the LMS in the Preferences dialog box.

• Publish the project to the Adobe Connect server.

Specify Adobe Connect as the LMS
1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Preferences dialog box, select Reporting from the Quiz menu.

3 Select Adobe Connect.

http://helpx.adobe.com/en/captivate/using/projects-project-preferences.html#edit_project_preferences
http://www.adobe.com/go/learn_adobeconnectlms_en
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4 Click OK.

Publish projects to Adobe Connect
Apart from the SWF file, you can choose to upload source files and any external FLV files to the server. You can also 
choose to upload the project as a single zip file.

1 From Toolbar, click Publish > Publish to Adobe Connect

2 Click folder icon in Publish to Adobe Connect dialog box 

3 Click Add in the Adobe Connect Server dialog box to enter the name and URL of Adobe Connect Server and click 
OK. 

4 In the Publish dialog box, select the options as required.

Publish Project Files (*.cptx)

The source file is uploaded to the server.

Zip Project File

All the published files are uploaded to the server as a single zip file.

Publish Video Files (*.flv)

Publishes any video files that you have imported into the Adobe Captivate project.

SWF

Publish the project as a SWF file.

HTML5 (for subscription and Adobe Software Assurance customers only)

Publish the project as an HTML5 output. 

More

Click More to set your preferences. 

5 Click Publish.

6 In the Adobe Connect window, enter your login credentials.
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7 Click New Folder, and create a folder where you want to upload the project file. Alternatively, you can select any 
existing folder from the list.

8 Click Publish To This Folder.

9 In the Adobe Connect Server window, do the following:

a Enter a name for your project in the Title field.

b If you want to customize the URL for the project, enter a name in the Custom URL field. The URL prefix 
http://<servername>/ is added.

c Enter a description for your project.

d Select the language in which your project has been created.

e Click Finish.

After you have uploaded the content to Adobe Connect, you can make it a part of an existing course or a new course.

Add an Adobe Captivate demo to an Adobe Connect meeting
You can bring an Adobe Captivate project into an Adobe Connect meeting using two different methods:

• Publish the Adobe Captivate project directly to Adobe Connect. Add the project from the Connect Content library
to an Adobe Connect meeting. (Adobe recommends using this option. Adding the Adobe Captivate project from
the Content library ensures that all Adobe Captivate features work properly within Adobe Connect)

• Publish the Adobe Captivate project to create a ZIP file stored on your computer and then add the ZIP file to an
Adobe Connect meeting.

Presenters can use the Sync button so that all participants can view their actions. As the presenter moves the mouse 
or interacts with the demonstration, all meeting participants see the actions on their computers. Presenters can also 
turn off the Sync option so participants can fully interact with the Adobe Captivate demonstration or simulation on 
their individual computers. Presenters can turn the Sync feature off and on as many times as necessary.

Note: The Sync button in Adobe Connect is not displayed if the Adobe Captivate project contains the _skin file.

If you want to include multiple files in an Adobe Connect, ensure that you do the following:

1 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

2 In the Category panel, expand Project, and select Publish Settings.

3 Select Publish Adobe Connect Metadata in the Project panel.

4 Click OK.

5 Select File > Publish.

6 Select Flash (SWF).

7 In Output Options, select ZIP Files.

Upload the ZIP file to an Adobe Connect meeting.

Add an Adobe Captivate project from the Connect Content library to a meeting
1 In Adobe Captivate, create a project.

2 Publish the project to Adobe Connect.

3 Open an existing meeting or create a meeting.

4 Send the meeting URL to the people you want to invite.
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5 Enter the meeting room.

6 Select Pods > Share > Select From Content Library.

7 Select the Adobe Captivate project, and click Open.

8 (Optional) Click the Sync button as necessary so participants either see actions taken by the presenter or they have 
control on their individual computers.

9 Click Stop Sharing to return to the Adobe Connect meeting room.

Add an Adobe Captivate project from your desktop to a meeting
1 In Adobe Captivate, create a project.

2 Publish the project to Flash to create a SWF file.

3 Note the location of the SWF file.

4 Log in to Adobe Connect.

5 Open an existing meeting or create a meeting.

6 Send the meeting URL to the people you want to invite.

7 Enter the meeting room.

8 Select Pods > Share > Select From My Computer.

9 Navigate to the Adobe Captivate SWF file, select the file, and click Open.

10 The upload message appears. When the SWF file has been uploaded, click the Play button on the Adobe Captivate 
playbar to start the project.

11 (Optional) Click the Sync button as necessary so participants either see actions taken by the presenter or they have 
control on their individual computers.

12 Click Stop Sharing to return to the Adobe Connect meeting room.

Add Adobe Connect tracking
You can track how users interact with an Adobe Captivate simulation added to an Adobe Connect meeting. To simplify 
tracking, specify Adobe Connect as the project output option. Access this option from the Quiz settings in the 
Preferences dialog box.

1 Open an Adobe Captivate project.

2 Select Quiz > Quiz Preferences.

3 From the Quiz menu, select Reporting.

4 Select Enable reporting for this project.

5 Select Adobe Connect.

6 Click OK.

Enable Adobe Connect search features
If you enable search, users can search for the Adobe Captivate project from Adobe Connect.

1 Open an Adobe Captivate project.

2 Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

3 In the Category panel, expand Project and select Publish Settings.
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4 Select Publish Adobe Connect Metadata.

5 Click OK.

Note: The Include Adobe Connect Metadata option is selected by default. This option increases the size of the project. 
If you are not going to use the project with Adobe Connect, deselect this option.

How to add Captivate projects to a RoboHelp online help 
system
To add an Adobe Captivate project to a RoboHelp project, create the Adobe Captivate project, add it to the RoboHelp 
project, and select among several display options. Adobe Captivate 6 is supported by RoboHelp 10.

1 Create an Adobe Captivate project. 

2 Publish the project as a Flash SWF file. Select the Export HTML option during the export process and note the 
folder location where the SWF file is stored. 

3 In RoboHelp, open the Help project to which you want to add the Adobe Captivate project. 

4 In the Project Manager, double-click the Project Files folder.

5 From the File menu, select Import > HTML/XHTML File.

6 Navigate to the HTML file of your Adobe Captivate project (created in step 2) and select it.

7 Click Open. 

The HTML file and the FLA file (SWF file) are imported into your RoboHelp project. The SWF file is added to the 
Project Files folder, and a new topic (with the title of the project) is created. 

Note: The HTML file (with the title of the project) that is added to your RoboHelp project is important. If you delete the 
topic, the related SWF file is also deleted from the project. You can, however, leave the topic in your Help project as a 
“hidden” topic. Hidden topics can’t be linked to and don’t appear in the table of contents. Their index markers don’t 
appear in the index. 

Determining how the Adobe Captivate project appears
After you add the FLA file (SWF file) to your RoboHelp project, specify how to display the project. You can place an 
Adobe Captivate project in a new RoboHelp topic and then link to that topic from any other topic in Help.

Display the project within an existing topic
1 In RoboHelp, open the topic you want to use to start the project.

2 Click in the topic. From the Insert menu, select Adobe Captivate Demo. 

3 Browse to the location of your Adobe Captivate file, select it, and click OK.

4 Preview the topic to see what the project looks like, or generate and view your Help system to see how the project 
looks.

Display the project in a window or panel
1 In RoboHelp, create a topic.

2 Add the Adobe Captivate project to the topic. From the Insert menu, select Adobe Captivate Demo. 

3 Browse to the location of your Adobe Captivate file, select it, and click OK.
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4 Save the topic.

5 Open the topic you want to use to start the project.

6 Select the text or image to use as a hypertext link. From the Insert menu, select Hyperlink/Popup.

7 In the Select Destination (File or URL) list, select the topic containing the Adobe Captivate project.

8 In Hyperlink Properties, specify how to display the project:

Display In Auto-Sizing Pop-Up Displays the project in a window that adjusts to accommodate the height and width 
of the project.

Display In Custom-Sized Pop-Up Select a width and height by using the arrows or typing a number.

Display In Frame You have the choice of displaying in a new window or in the same slide as the link from the topic. 
From the pop-up menu next to Display In Frame, select either New Window or Same Slide. If you choose New 
Window, the project appears in the user’s default browser. If you choose Same Slide, your topic replaces the topic the 
user is currently viewing.

9 Click OK.

10 Preview the topic to see what the project looks like, or generate Help. 

Note: You can edit the SWF file you have inserted into RoboHelp only if you have the associated Adobe Captivate project 
saved on your computer.

Import and edit PowerPoint presentations in Captivate
You can import and edit Microsoft PowerPoint presentations in Adobe Captivate. Imported slides can be edited in a 
Microsoft PowerPoint environment from within Adobe Captivate. You can choose to link to the source PowerPoint 
presentation to keep it in sync with the Adobe Captivate project. 

When a PowerPoint presentation is linked to an Adobe Captivate project, Adobe Captivate creates a reference to the 
source presentation. When the linked presentation is opened in Adobe Captivate for editing, the source presentation is 
loaded into Adobe Captivate. Because the source presentation is referenced, and not embedded into the project, linking 
to presentations does not affect the file size of the Adobe Captivate project. 

When you import a presentation into Adobe Captivate without linking to it, the entire source presentation is embedded 
into the project. Editing an embedded presentation does not affect its source file. However, embedding increases the 
file size of the Adobe Captivate project. You can embed the presentation when the location of the Microsoft PowerPoint 
presentation is not fixed. Embedding is also useful when the Adobe Captivate project must be opened on a computer 
that doesn't have access to the Microsoft PowerPoint presentation.

Adobe Captivate supports PowerPoint presentations with the extensions .ppt, .pps, .pptx, and .ppsx. You can import 
PPT and PPS slides even if you do not have PowerPoint installed on your computer. However, you can’t edit them after 
import. To import PPTX and PPSX slides, you must have Microsoft PowerPoint installed on your system. Adobe 
Captivate converts PPTX files to PPT files during import. The information loss that occurs during such conversion is 
documented on the Microsoft website http://office.microsoft.com/en-us/powerpoint/HA101023491033.aspx.

http://office.microsoft.com/en-us/powerpoint/HA101023491033.aspx
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Open, edit, and save the PowerPoint file in Microsoft PowerPoint before importing it into Adobe Captivate. Performing 
this procedure ensures that the PowerPoint version installed on your computer is stable. 

PowerPoint tips
Follow these guidelines when you work with Adobe Captivate and PowerPoint:

• Do not close or use PowerPoint launched by Adobe Captivate during import or round-tripping.

• Launch both Adobe Captivate and PowerPoint in the same mode, that is either both in Admininstrator mode or
both in non-Administrator mode. It is recommended that you launch both in Administrator mode.

• Avoid doing any copy/paste action (even in other applications such as Notepad, or file copy), when Adobe Captivate 
is using PowerPoint.

• Avoid parallel edits. For example, suppose you edit a linked PowerPoint file within Adobe Captivate and the source 
file in Microsoft PowerPoint simultaneously. In such cases, the results are unpredictable.

• Avoid editing PPTX and PPSX files with older Microsoft PowerPoint versions. If you want to edit an embedded
PPTX of PPSX file outside of Adobe Captivate, export the file from the resource Library and then edit the file. The
edited file can then be updated in Adobe Captivate.

• If you have installed any interactive PowerPoint plug-ins, ensure that you launch Microsoft PowerPoint before you
open the presentation in Adobe Captivate for editing.

Scenario PowerPoint version required

Import PPT file Need not install Microsoft PowerPoint if you are importing slides from 
a PPT file.

Import PPTX file (For Windows) Microsoft PowerPoint 2007 or 2010

or

Microsoft PowerPoint 2003 with Office Service Pack 3 (or later) and 
Office compatibility pack.

(For Mac) Microsoft PowerPoint 2008 or 2011

or

Microsoft PowerPoint 2004 with Office 2004 update (11.5 or later) and 
Open XML converter (compatibility pack for Office 2008)

Edit PPT file (For Windows) Microsoft PowerPoint 2003 or Microsoft PowerPoint 
2007 

(For Mac) Microsoft PowerPoint 2004 or Microsoft PowerPoint 2008 or 
2011

Edit PPTX file (For Windows) Microsoft PowerPoint 2003 with Office Service Pack 3 
(or newer) and Office Compatibility Pack (both available as freeware 
on the Microsoft website) 

or 

MicrosoftPowerPoint 2007

(For Mac) Microsoft PowerPoint 2008 or 2011

or

Microsoft PowerPoint 2004 with Office 2004 update (11.5 or later) and 
Open XML converter (compatibility pack for Office 2008)
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• Avoid linking to PowerPoint files over the network on a shared network drive. The results are unpredictable if you
lose connectivity while working with the shared file.

Import PowerPoint presentations into Adobe Captivate
1 In an open project, Select File > Import > PowerPoint Slides.

2 Navigate to and select the PowerPoint presentation file format that you want to import.

3 Click Open.

4 Decide where to place the imported PowerPoint slides in the Adobe Captivate project. Add the slides to the end of 
the project, or click a slide in the list and add the PowerPoint slides after that slide. 

5 Click OK.

6 In the Convert PowerPoint Presentations dialog box, do the following:

a Select the PowerPoint slides to convert to Adobe Captivate project slides. 

b Set navigation preferences for the selected slides.

c If you want to link to the PowerPoint presentation, select Linked. If you want to embed the PowerPoint 
presentation, deselect Linked.

7 Click OK.

The PowerPoint slides are imported into the Adobe Captivate project and they appear in the designated location. If 
necessary, you can change the order of the slides.

Narration in a PowerPoint presentation slide is imported as a sound object and appears as a separate object on the 
Timeline. Even in the linked mode, changes made to the audio file in Adobe Captivate after import are not reflected in 
the respective Microsoft PowerPoint presentation. Similarly, changes made to the audio file in Microsoft PowerPoint 
are not reflected in the Adobe Captivate project. Object sounds are retained in the SWF file that is created from slides 
containing such objects.

Slide labels and notes are imported only during the first import. Any subsequent changes to the labels and notes in 
PowerPoint are not reflected in Adobe Captivate.

Create Adobe Captivate projects from PowerPoint presentations
1 In an open project, Select File > New > Project From MS PowerPoint.

2 Navigate to and select the PowerPoint presentation file format that you want to import.

3 In the Convert PowerPoint Presentations dialog box, do the following:

a Enter the name of the project.

b Select a size for the new Adobe Captivate project. The size displayed is the actual size of the slide in PowerPoint. 
Best practice is not to change the size.

c Select the PowerPoint slides to convert to Adobe Captivate project slides. 

d Set navigation preferences for the selected slides.

e If you want to link to the PowerPoint presentation, select Linked. If you want to embed the PowerPoint 
presentation, deselect Linked.

4 Click OK.
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Insert Adobe Captivate projects into PowerPoint presentations
You can insert Adobe Captivate projects into Microsoft PowerPoint presentations in a few simple steps. Publish an 
Adobe Captivate project as a SWF file. Then open a PowerPoint presentation and insert the published SWF file into a 
slide.note: For information on inserting Adobe Captivate projects into Microsoft PowerPoint 2007, see the topic on 
PowerPoint 2007 on the Microsoft website.

1 Create and edit the project in Adobe Captivate.

2 Publish the project as a SWF file. 

3 Note the location of the saved SWF file.

4 Open the PowerPoint presentation to which you want to add the Adobe Captivate project.

5 In the Developer menu, select More Controls from the Control Toolbox.

6 Select More Controls.

7 From the list of objects, select Shockwave Flash Object. 

8 Drag diagonally to create a box for the project.

You can resize the box in which the project appears. Return to the slide that contains the project in PowerPoint, and 
drag the resizing handles.

9 Right-click (Windows) or Control-click (Mac OS) the box and select Properties. 

10 In the Properties dialog box, click once on the top line, Custom.

11 Click once on the Ellipsis button.

The Property Pages dialog box appears.

12 In Movie URL, enter the location of the SWF file to add. Type the full path, including the filename (for example, 
C\:My Documents\MyFile.swf) or URL to the SWF file that you want to play.

13 Click OK.

14 In the PowerPoint Properties dialog box (opened in step 9), set the following properties:

• Set the Playing property to True to play the file automatically when the slide is displayed. If the SWF file has a
Start/Rewind control built in to it, you can set the Playing property to False.

• If you don't want the animation to play repeatedly, set the Loop property to False. (Click the cell to display a down 
arrow; then click the arrow and select False.)

• Set Embed Movie to True to ensure that the Adobe Captivate project is always included with the PowerPoint
presentation.

15 When you finish setting options, close the Properties dialog box. 

16 Test the project. 

Edit imported PowerPoint slides within Adobe Captivate
You can edit an individual slide or the entire set of slides imported from a PowerPoint presentation within Adobe 
Captivate without launching PowerPoint. If you want to edit only a few slides, edit each slide individually. It is faster 
than editing the entire presentation.

Note: Single-slide edit mode is not supported on Mac.

http://support.microsoft.com/kb/291875
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When you send an Adobe Captivate project with linked slides for editing, send the PowerPoint presentation along with 
the project. Sometimes the recipient has to relink the presentation before editing it.

1 Import the PowerPoint presentation into your project.

2 Open the slides and then navigate to a slide imported from PowerPoint.

3 Right-click (Windows) or Control-click (Mac OS) the slide generated from Microsoft PowerPoint, select Edit with 
Microsoft PowerPoint and then select one of the following options:

Edit Slide Edit the selected slide

Edit Presentation Edit the entire presentation.

Find Presentation In Library Locate the presentation in the library. When you select this option, the presentation is 
highlighted in the library.

Export Animation Convert the selected slide to a SWF file. After conversion, Adobe Captivate prompts you to save 
the SWF file.

4 When you select Edit Slide or Edit Presentation, the PowerPoint editing environment opens within the Adobe 
Captivate window (if you are using Adobe Captivate on Windows. You can edit the slides in Microsoft PowerPoint.

If you are using Adobe Captivate on Mac OS, see Using Adobe Captivate with Microsoft PowerPoint on Mac OS.

5 After you complete editing, click Save PPT.

6 The Adobe Captivate editing environment appears.

7 Save the project.

Update PowerPoint presentation changes made outside Adobe Captivate
Updating is necessary when the PowerPoint file is linked and the changes are made directly in Microsoft PowerPoint.

1 Open the Adobe Captivate project and then navigate to a slide that was imported from the PowerPoint presentation.

2 Right-click (Windows) or Control-click (Mac OS) the slide generated from Microsoft PowerPoint, and then select 
Edit with Microsoft PowerPoint > Find Presentation In Library. When you select this option, the PowerPoint 
presentation containing the slide is highlighted in the library.

3 Right-click (Windows) or Control-click (Mac OS) the presentation in the Presentation folder.

4 Select Update.

Note: If the file in the Adobe Captivate library and the original Microsoft PowerPoint file are not in sync, the color of 
the dot in the status column in the library changes from green to orange . If you remove or relocate the source Microsoft 
PowerPoint file, then a question mark appears in the status column. Click to relink.

Change link type after importing the presentation
1 Open the Adobe Captivate project and then navigate to a slide that was imported from the PowerPoint presentation.

2 Right-click (Windows) or Control-click (Mac OS) the slide generated from Microsoft PowerPoint, and then select 
Edit with Microsoft PowerPoint > Find Presentation in the Library. When you select this option, the PowerPoint 
presentation containing the slide is highlighted in the library.

3 In the Library panel, right-click (Windows) or Control-click (Mac OS) the presentation in the Presentation folder.

4 Do one of the following:

a Select Change To Linked if you have not linked to (embedded) the presentation during import. Specify a location 
for the linked file on your computer.



447
Using Adobe Captivate with Other Applications

Last updated 10/10/2016

b Select Change To Embedded to embed the linked file into your project.

Change the link to the presentation after importing
When you send an Adobe Captivate project for editing, the recipient sometimes has to relink the presentation to the 
project.

1 Open the Adobe Captivate project and navigate to a slide that was imported from the PowerPoint presentation.

2 Right-click (Windows) or Control-click (Mac OS) the slide generated from Microsoft PowerPoint, and then select 
Edit with Microsoft PowerPoint > Find Presentation in the Library.

When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.

3 Right-click (Windows) or Control-click (Mac OS) the presentation.

4 In the Property Inspector, click Update, select the new path, and then click OK. 

Reduce file size of projects with embedded slides
You can import a presentation into an Adobe Captivate project without linking (embedded mode). The entire 
presentation is embedded into the Adobe Captivate project. Slides that are not selected during import are also imported 
into the Adobe Captivate project, but they are not visible in the project. When you choose to reduce the file size, Adobe 
Captivate deletes such slides permanently from the project. This process is irreversible.

1 Open the Adobe Captivate project and navigate to a slide that was imported from the PowerPoint presentation.

2 Right-click (Windows) or Control-click (Mac OS) the slide generated from Microsoft PowerPoint, and then select 
Edit with Microsoft PowerPoint > Find Presentation in the Library.

When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.

3 In the Library panel, right-click (Windows) or Control-click (Mac OS) the presentation in the Presentation folder.

4 Select Compact.note: The Compact option is disabled for linked presentations.

Using Adobe Captivate with Microsoft PowerPoint on Mac OS
The following list describes the changes in behavior when you use Adobe Captivate with Microsoft PowerPoint on Mac 
OS:

• When you select to edit a presentation (added as Adobe Captivate project), the presentation opens in Microsoft
PowerPoint and not in Adobe Captivate. On Microsoft Windows, you can edit the presentation from within Adobe 
Captivate.

When you edit the presentation in Microsoft PowerPoint, you can continue to work in Adobe Captivate.

note: Do not edit the presentation when Adobe Captivate updates the project, else the changes are lost. Let Adobe
Captivate update the project and then modify the presentation.

• You cannot edit and compact PPSX files on Mac with Microsoft PowerPoint 2004 installation (even if you have
installed the converter pack).
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How to package multiple SCOs using the Adobe Multi-
SCORM Packager

About Adobe Multi-SCORM Packager
Using Adobe Multi SCO Packager you can combine multiple elearning projects that contain Shareable Content Objects 
(SCOs). 

Combining multiple learning projects is useful when different modules developed by many authors have to be bundled 
into a single package. Adobe Multi SCO Packager can combine:

• Adobe Captivate® project output: ZIP files with SCORM settings. The project must contain at least one scorable
object.

• Adobe® Flash® learning interactions (SWF files that use LMS Adapter for tracking). Publish a FLA file containing
learning interaction objects as a SWF file.

• Quiz created using Adobe Flash. Publish a FLA file containing the quiz as a SWF file.

• Quiz created using Adobe® Presenter. Publish a ZIP output of the presentation.

• Quiz created using CourseBuilder extension for Adobe Dreamweaver® (converted to SCORM package).

• A combination of the above types.

When you publish the packaged file, a ZIP file containing all the SCOs, and a manifest file are generated. You can 
directly upload the generated ZIP file to an LMS.

Adobe Multi SCO Packager creates a table of contents (TOC) using the names of the separate modules.

Package multiple SCOs
1 Ensure that you have the ZIP (Adobe Captivate, Adobe Presenter) or SWF (Adobe Flash) files of all the required 

elearning projects (SCOs).

2 Open Adobe Multi SCO Packager. To do so, click File > New Project > Multi-SCORM Packager.

The Welcome screen appears.

3 Click one of the following templates:

Multiple SCOsAllows you to add SCOs as individual files. However, you cannot group the files into modules.You 
can add multiple assessments using this template. The final score reported to the LMS is the average user score 
across the assessments.Simple RemediationAllows you to add multiple modules. In each module, you can add 
content files and post-tests. You can add different weightages to each of these modules, total amounting to 100%. 
The score reported to the LMS is the average of the weightages that users score in individual modules.Users can take 
the post-test only after viewing all the content files.Pre-test Or Post-test RollupAllows you to add multiple 
modules, each containing pretests, content, and post-tests. For every module, users are allowed to take pretest first; 
content and post-tests are disabled. If users pass the pretest, they are considered to have completed the module and 
the subsequent module is enabled. If users fail the pretest, the content files are enabled, and after they complete 
viewing all the content files, the post-tests are enabled.You can add different weightages to each of the modules, total 
amounting to 100%. The score reported to the LMS will be the average of the weightages that users score in 
individual modules.
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4 Specify the manifest details for the course you want to create and click OK.

SCORM Version Specify the version of SCORM (1.2 or 2004) based on the LMS you are using.

Identifier The identifier used by the LMS to identify different manifests.

Title The title of your project that is displayed to the user viewing the project using an LMS.

Description The text that the LMS displays to describe your project.

Version The version specifies a number that can be used to differentiate manifests with the same identifier. For 
example, if you are uploading the same project after modifying it, use a different version number. 

Duration The time required for learners to complete the project.

Subject The subject of your Adobe Captivate course.

5 If you chose Multiple SCOs as the template, do the following:

a Click the ‘+’ icon to add the SCOs to the package.

b Select Force Module Sequence to ensure that your users go through the files in the order you see in the packager. 
In the TOC of the published course, your users can see all file names, but will not be able to click a file before 
completingthe previous file.

c Click the Publish icon to publish the course.

6 If you chose Simple Remediation as the template, do the following:

a Click the + Module to add a new module.

b Click + icon in the Content accordion to add content files (SCOs). 

c Click + icon in the Post-test accordion to add post-test.

d Double-click Weightage and type the weightage for the module in percentage.

e Select Force Content Sequence to ensure that your users go through the content and post-test files in the order 
you see in the packager. In the TOC of the published course, your users can see all file names, but will not be able 
to click a file before completingthe previous one.

f Select Force Module Sequence to ensure that your users go through the modules in the order you see in the 
packager. In the TOC of the published course, your users can see all module names, but will not be able to click 
a module before completingthe previous one.

g Click the Publish icon to publish the course.

7 If you chose Pretest or Post-test Rollup template, do the following:

a Click the + Module to add a new module.

b Click + icon in the Pretest accordion to add pretests. 

c Click + icon in the Content accordion to add content files (SCOs). 

d Click + icon in the Post-test accordion to add post-tests.

e Double-click Weightage and type the weightage for the module in percentage.

f Select Force Content Sequence to ensure that your users go through the content and post-test files in the order 
you see in the packager. In the TOC of the published course, your users can see all file names, but will not be able 
to click a file before completingthe previous one.

g Select Force Module Sequence to ensure that your users go through the modules in the order you see in the 
packager. In the TOC of the published course, your users can see all module names, but will not be able to click 
a module before completingthe previous one.
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h Click the Publish icon to publish the course.

8 If the SCO has been created in Flash, the SCO Manifest Details dialog box appears. Enter the details. The SCO 
Identifier and Title are mandatory fields. SCO Identifier must be unique for each SCO and the final course must 
have a corresponding entry in the imsmanifest.xml file. 

9 Click OK.

Publish the packaged files
After you have created and saved a multi-SCO project, you can publish it as a ZIP file that contains a SWF and an HTM 
file. You can directly upload the ZIP file to a learning management system (LMS).

1 Open the Multi SCO project in the SCORM Packager.

2 Click Publish MultiSCO Project.

3 In the Publish SCO Package dialog box, enter a name for the project in the Project Title field.

4 Click Browse to publish your file to an alternative location.

5 Click Publish.

The packaged ZIP file contains resource files of each SCO contained in individual folders and XSD files and 
imsmanifest.xml at the root level. If you change the structure of any SCO by changing the location of XSDs or 
imsmanifest.xml, the packager might not work as intended. Also, the version of SCORM must be same for all courses 
that go into a single package. However, the ActionScript version need not be the same.

Upload packaged files to LMS
After publishing the packaged files as a ZIP file, upload the ZIP file to your LMS. You can then distribute the URL that 
the LMS generates to your users.

When users click the URL to take the course, the interactions are reported based on the options you have chosen. If the 
package that you upload to LMS contains multiple Adobe Captivate SWF files with different reporting options, then:

• The report status is always reported as Complete or Incomplete.

• The data is always reported as Percentage.

Using Adobe Bridge with Captivate
Adobe Bridge is integrated with Adobe Captivate 7 and later. This integration lets you easily organize, browse, locate, 
and import shared creative assets while authoring in Adobe Captivate.

You can perform the following actions to implement an Adobe Captivate-Adobe Bridge workflow:

• Select any content asset from Bridge and insert it in an Adobe Captivate slide.

• Drag-and-drop audio, video, and other types of media from Bridge into the Adobe Captivate 
library.

• Select a PSD file in Bridge and edit it in Adobe Captivate.

Access Bridge from Adobe Captivate

To launch Bridge from within Adobe Captivate, select File > Browse.

 Select File > Browse. 
Note: Alternatively, you can click the Browse Bridge Connection tool button.
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Switch to Adobe Captivate from Bridge

You can quickly return to Adobe Captivate from Bridge.

 Select File > Return to Adobe Captivate.

Place assets in Adobe Captivate

From Bridge, you can place selected assets in Adobe Captivate by dragging them into Adobe Captivate or using the In 
Captivate option from the Place menu.

 Select File > Place > In Captivate.
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Chapter 17: Troubleshooting

Reducing time taken to preview an Adobe Captivate 
project
Adobe Captivate appears to stop responding for a few moments while publishing a project containing a large size full 
motion recording. When a large full motion recording is captured in an Adobe Captivate project, the preview and 
publish operations take a long time.

If you frequently want to preview the project that contains a large full motion recording, set the value of the Compress 
SWF File option to Off (disabled) in the Preferences tab of the Project Preferences dialog box. This will reduce the time 
taken to preview the output. After previewing the output, you can change the value of the Compress SWF File option 
to On (enabled), and then publish your project.

More Help topics 
Set publishing preferences

Preview and publish responsive projects

Preview projects

Creating accessible projects

How to improve the file size of Adobe Captivate output
Adobe Captivate was built with low bandwidth in mind. A typical project with sound (some narration) and a modest 
screen size of 512 x 384 streams at approximately 2–3 kilobytes per second. Your viewers can play this project using a 
56 Kbps (or slower) dial-up modem without waiting more than a few seconds for the project to start. Additionally, there 
are no pauses during playback.

A project that streams well might have the following characteristics:

• File size: 777 KB

• Length: 6 minutes, 12 seconds

• Audio: 286 KB

• Video: 491 KB

• Screen size: 608 x 460

Note: File size depends on several factors. Larger files contain elements such as photos, images, sound tracks, large screen 
sizes, rapid screen transitions, and higher quality video and audio settings.

https://helpx.adobe.com/captivate/using/set-publishing-preferences.html
https://helpx.adobe.com/captivate/using/preview-publishing.html
https://helpx.adobe.com/captivate/using/preview-projects.html
https://helpx.adobe.com/captivate/using/creating-accessible-projects.html
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There are a number of ways to improve the file size of Adobe Captivate output:

• One important factor is the kilobytes per second ratio. Check the bandwidth analysis to find this factor. Don't
despair if your project is large; it is possible for a large project to stream well over the Internet. For example, a 400
KB file might seem large, but if it plays for 5 minutes, it streams easily over a 28.8 Kbps modem. The first slide in a
project always has a longer kilobytes per second ratio, because it is the first slide to load and additional project
information must load with it.

• Consider your color settings and the images included in your project. Two quick tips for reducing file size are to
avoid color gradients and to avoid photo images.

• If you are not going to upload your SWF files to Adobe® Connect™ Enterprise, you can turn off the Include Adobe
Connect Metadata option in the project preferences. This option is on by default, and it adds data to your project
that allows for better integration with Adobe Acrobat Connect Professional. If you do not use Acrobat Connect
Professional, turn this option off to reduce project size.

How to uninstall Adobe Captivate
It is relatively simple to uninstall Adobe Captivate. When you uninstall Adobe Captivate, all of the files you have saved 
in your My Documents\My Adobe Captivate Projects folder are retained.

To uninstall Adobe Captivate on Windows:

1 Click Start > Control Panel.

2 Double-click Add Or Remove Programs.

3 Click the Install/Uninstall tab (if your version of Windows contains this tab).

4 From the list of programs you can remove, select Adobe Captivate x.x.

5 Click Add/Remove.

6 In the Uninstall Options screen, select Remove Preferences and click Uninstall.

The uninstall program removes program files, folders, and registry entries. When the files are removed, the uninstall 
program indicates that the process is complete.

7 Click Done.

To uninstall Adobe Captivate on Mac:

1 Go to Applications\Adobe\Adobe Captivate 6.

2 Click Uninstall Adobe Captivate 6.

3 In the Uninstall Options screen, select Remove Preferences and click Uninstall.

The uninstall program removes program files, folders, and registry entries. When the files are removed, the uninstall 
program indicates that the process is complete.

4 Click Done.
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About the CLIP audio file in Adobe Captivate
The CLIP file appears when a single audio file is distributed over several slides.The CLIP file is generated under the 
following circumstances

• Recording narration for several slides / projects in continuous play mode

• Inserting audio on a slide and then distributing it over several slides.

• Inserting audio, retaining current slide timing, and distributing remaining audio over several slides.

To identify, which recording(Clip).wav is being used on which particular slide, use the Audio Management dialog 
(Audio > Audio management). The column “Display name” displays the audio file linked to the particular slide.

Troubleshooting Flash video file-related errors in Adobe 
Captivate output
Adobe Captivate output does not play if it is published over the network with Flash video (FLV) files in it.

Also, FLV files do not play when the Adobe Captivate project containing progressive FLV is published to a network 
share and viewed by clicking the View Output button. You can play the FLV file in the Adobe Captivate output by 
mapping the network drive in Microsoft Windows Explorer.

The FLV file must contain metadata for the video player to function correctly. FLV files created with Flash 
Communication Server 1.5.2, FLV Exporter version 1.2, and Sorenson Squeeze 4.0 automatically contain metadata. 
Sorenson Squeeze 4.0 is included with the Flash Video Kit.

FLV files will not play when an Adobe Captivate project is hosted on a Windows 2003 web server.

How to fix issues where text does not display in browser
If text in a project is not displaying properly in a browser, the problem could be that a link is calling the Adobe Captivate 
project SWF file instead of the HTM file that corresponds to the SWF file. If you are adding your project to a web page, 
do not link directly to the SWF file. If you link directly to the SWF file, the browser does not know the size at which it 
should display the SWF file, so it simply shows the SWF file at the same size as the browser window. This can result in 
distortions, especially text distortion that causes text to become unreadable. 

To display the SWF file in a browser properly, use the HTM file that can be generated with the SWF file. The HTM file 
contains code that tells the browser the correct size for the project. 

When you publish your project as a SWF file, select the Export HTML option. The HTM file will be saved in the same 
location you specified for the SWF file. The HTM file will have the same name as the SWF file but will have the .htm 
extension. 

If you have installed Adobe® Flash® Player 8 or later, previewing an Adobe Captivate project using a browser causes a 
security settings warning to be displayed. This is because of the security settings configured in Flash Player 8 or later.
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Working with the Skin Editor in Adobe Captivate
The Skin Editor shows the skin preview of the first slide of the project. The preview contains the background color of 
the slide (if any) or the background image. You may experience performance issues when the skin preview shows the 
background image because every setting in the Skin Editor dialog box is applied to the preview immediately. To avoid 
this delay of preview update while editing a skin in the Skin Editor dialog box, you can insert a blank slide as the first 
slide. Then open the Skin Editor dialog box and define all your skin configurations like playbar controls, positions 
menu, and borders. After finalizing the skin configuration, you can hide the first slide (the blank slide inserted) and 
open the Skin Editor dialog box again to preview the final changes. The skin preview will always show the first project 
slide that is not hidden.

Security warning with Flash Player 9 or later
A security warning appears when you launch an external file from a SWF file created in Adobe Captivate. The same 
security warning appears when you launch Flash Help created in either RoboHelp HTML or RoboHelp for Word. This 
is because Flash Player 9 (or later) includes the new Settings Manager, which allows you to manage global privacy 
settings, storage settings, security settings, and automatic notification settings.

To permanently change the settings:

1 Click Settings. 

2 Select Edit Locations. 

3 Select Add Location. 

4 Under Trust This Location, enter the location of the folder that contains your published project. 

5 Click Confirm. 

Recording Applications on Mac
Before you record applications on Mac, ensure that you set the following preference:

1 In the System Preferences, select Universal Access.

2 Select Enable Access for Assistive devices.

When you select File > Record new project and then select Application in Adobe Captivate on Mac, the menu lists the 
applications (for recording) only if you have this option selected.

How to prevent learners from jumping to the result slide 
during quiz
The user should not be able to navigate to the result slides without answering the quiz in the question slides.

When designing an Adobe Captivate project containing result slides, make sure that you do not allow the user to 
navigate or jump to the result slides directly without working through the question slides, or the slides containing 
interactive objects, and that you enable the Reporting option (set to On). It’s important to design the project to help the 
user complete the quiz before navigating to the result slide.
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JavaScript does not appear when previewing Adobe 
Captivate output
JavaScript does not appear while you preview Adobe Captivate output.

If the Execute JavaScript option is selected as action in the Project End options of the Project Preferences dialog box 
(Edit > Preferences > Project > Start and End (Windows) or Adobe Captivate > Preferences > Project > Start and End 
(Mac OS)), Adobe Captivate may not display an error message when the JavaScript is previewed. This is because the 
Show Borders option as set to On (enabled), by default. When this option is on, Adobe Captivate creates multiple SWF 
files—skin SWF files and content SWF files.

To preview JavaScript, set the value of the Show Borders option to Off (disable it) in the Borders tab of the Skin Editor.

How to correct colors in Adobe Captivate slides
In general, color should appear correctly in Adobe Captivate projects. However, there are cases in which colors may 
appear inaccurately, such as when the color scheme varies radically between slides. So if Slide A uses color palette ABC, 
and Slide B uses color palette XYZ, and the two palettes are radically different, Slide B might resort to using palette 
ABC. 

Most of these problems can be fixed by changing the video quality of the slide. Adobe Captivate provides four levels of 
video quality, even though only the Standard option is suggested for most uses.

To change video quality in a slide:

1 In an open project, double-click the slide containing the colors you want to correct. 

2 From the Slide menu, select Video Quality and one of the video options:

Standard The default format for slides. Standard is the most efficient choice for the majority of screenshots because 
it uses 256 optimized colors. Standard slides also compress well, which results in smaller file sizes. 

Optimized This option gives you the highest JPEG quality possible.

JPEG This option is best used when the slide contains a photograph. You can change the quality and compression 
ratio for JPEG images on the Project Preferences dialog box.

High Quality Compared to the Standard format of 256 colors, this format uses 16 million colors for the slides. This 
option should be used only if the Standard and Optimized options do not offer the correct color depth. The file size 
increases dramatically using this option. 

Note: Selecting the JPEG or High Quality format may increase the file size and the time it takes to download your 
project. You should use a format other than Standard only when necessary and appropriate. 

How to avoid choppy full motion recording in Adobe 
Captivate
Note: Applies only if you are using Adobe Captivate on Microsoft Windows.

You can create a smoother full motion project, particularly better mouse movement, by disabling hardware 
acceleration. When hardware acceleration is enabled, it can use a great deal of system resources and result in “choppy” 
full motion recording. Disabling hardware acceleration results in better full motion recording quality.



457
Troubleshooting

Last updated 10/10/2016

To disable hardware acceleration, change this setting in the following location: Start Menu > Settings > Control Panel 
> Display > Settings > Advanced > Troubleshoot.

If you disable hardware acceleration, your computer screen will briefly flicker when you begin and end full motion 
recording. This screen flicker does not harm your computer and does not appear in the final project.

Tips to capture screens while recording a web 
application
When you capture a web-based application or a website from a browser, sometimes the slide does not have the correct 
image.

Whenever you capture a screen, you must listen for the shutter sound. The shutter sound occurs when Adobe Captivate 
has successfully taken the screenshot. When you are capturing from a website or a web-based application and you have 
to click several links, you will hear the shutter sound on every click. After you click a link and a new page is loaded, wait 
for the page to load completely. After the page is fully loaded, you will hear the shutter sound of Adobe Captivate. In 
case you do not hear the shutter sound when the page is fully loaded, press the Print Screen key, which will take the 
screenshot manually. It is recommended that you use Internet Explorer as the browser when capturing a website or a 
web- based application. Following these simple guidelines will enable you to achieve the best results.

How to record applications having elevated permissions 
in Windows Vista or Windows 7
You will have to set administrator permissions for the AdobeCaptivate.exe file to record or capture applications running 
in elevated or administrator mode.

To set administrator permissions for AdobeCaptivate.exe:

1 Locate AdobeCaptivate.exe in your installation directory. If you have not changed any settings during installation, 
you can locate this in the \\Program Files\Adobe\Adobe Captivate 6 folder. 

2 Right-click the file, and select Run As Administrator. The User Account Control (UAC) dialog box appears. 

3 Click Allow. 

How to fix application distortion issues while recording
Note: Applies only if you are using Adobe Captivate on Microsoft Windows.

Application distortion can occur with certain combinations of Microsoft Windows and video cards. The problem can 
be solved by setting the hardware acceleration on your computer to None. You can change this setting in the following 
location: Start Menu > Settings > Control Panel > Display > Settings > Advanced > Troubleshoot.

Note: This issue occurs only when you use Adobe Captivate on Microsoft Windows.

Note: Turning off the hardware acceleration may turn off the display in some computers.
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Synchronize animation timing with the Adobe Captivate 
timeline
If you notice when previewing a project that an animation file you added as an object is displayed for a longer or shorter 
period of time than the duration of the animation file, you can synchronize the animation with the Adobe Captivate 
Timeline to give you greater control over the timing.

1 Select the animation.

2 In the Property Inspector (Window > Properties), select Synchronize With Project in the Timing area.

Note: If the animation file was originally recorded with an audio track, you may find that the audio track is choppy after 
selecting the Synchronize With Project option. The best solution is to separate the animation file and audio so they can be 
used as two distinct objects in the project.
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