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Chapter 1: Encoding quick start and basics

Encoding quick start

To encode a video or audio item, add it to the encoding queue in Adobe Media Encoder, and then select encoding 

presets or custom settings. You can instruct the application to start encoding after you add an item to the queue, or 

you can tell it to wait until you decide to start encoding.

Add an item to the encoding queue
• Drag video or audio files into the queue in Adobe Media Encoder. 

For more information, see “Add and manage items in the encoding queue” on page 7. For a list of supported video and 

audio items, see “File formats supported for import” on page 9. 

Encode the item using presets
• Select formats and presets from the Format and Presets pop-up menus with the item in the queue. 

For more information, see “Encode using presets” on page 11.

Encode the item using custom settings
• Select the item and select Edit > Export Settings, and then choose your settings.

For more information, see “Encode using custom settings” on page 11.

Start the encoding
• Click the Start Queue button. In CS5.5, click the triangle button on the upper right side of the window. 

To start encoding items in the queue automatically (or to turn off the feature), select or deselect the Start Queue 

Automatically When Idle For option in the Preferences dialog box. For more information, see “Preferences” on page 5.

About video and audio encoding and compression

Recording video and audio to a digital format involves balancing quality with file size and bitrate. Most formats use 

compression to reduce file size and bitrate by selectively reducing quality. Compression is essential for reducing the 

size of movies so that they can be stored, transmitted, and played back effectively. 

When exporting a movie file for playback on a specific type of device at a certain bandwidth, you choose an encoder 

(codec). Various encoders use various compression schemes to compress the information. Each encoder has a 

corresponding decoder that decompresses and interprets the data for playback.

A wide range of codecs is available; no single codec is best for all situations. For example, the best codec for 

compressing cartoon animation is generally not efficient for compressing live-action video.

Compression can be lossless (in which no data is discarded from the image) or lossy (in which data is selectively 

discarded).

You can control many of the factors that influence compression and other aspects of encoding in the Export Settings 

dialog box. See “Encoding and exporting” on page 7.
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John Dickinson provides a video tutorial on the Adobe website that demonstrates the use of Adobe Media Encoder 

with After Effects and Premiere Pro.

For more information about encoding and compression options, see this FAQ entry: "FAQ: What is the best format 

for rendering and exporting from After Effects?"

Temporal compression and spatial compression

The two general categories of compression for video and audio data are spatial and temporal. Spatial compression is 

applied to a single frame of data, independent of any surrounding frames. Spatial compression is often called 

intraframe compression.

Temporal compression identifies the differences between frames and stores only those differences, so that frames are 

described based on their difference from the preceding frame. Unchanged areas are repeated from the previous frames. 

Temporal compression is often called interframe compression.

Bitrate

The bitrate (data rate) affects the quality of a video clip and the audience that can download the file given their 

bandwidth constraints.

When you deliver video using the Internet, produce files using lower bitrates. Users with fast Internet connections can 

view the files with little or no delay, but dial-up users must wait for files to download. If you anticipate an audience of 

dial-up users, make short video clips to keep the download times within acceptable limits.

Frame rate

Video is a sequence of images that appear on the screen in rapid succession, giving the illusion of motion. The number 

of frames that appear every second is known as the frame rate, and it is measured in frames per second (fps). The higher 

the frame rate, the more frames per second are used to display the sequence of images, resulting in smoother motion. 

The trade-off for higher quality, however, is that higher frame rates require a larger amount of data, which uses more 

bandwidth.

When working with digitally compressed video, the higher the frame rate, the larger the file size. To reduce the file size, 

lower either the frame rate or the bitrate. If you lower the bitrate and leave the frame rate unchanged, the image quality 

is reduced.

Because video looks much better at native frame rates (the frame rate at which the video was originally recorded), 

Adobe recommends leaving the frame rate high if your delivery channels and playback platforms allow it. For full-

motion NTSC video, use 29.97 fps; for PAL video, use 25 fps. If you lower the frame rate, Adobe Media Encoder drops 

frames at a linear rate. However, if you must reduce the frame rate, the best results come from dividing evenly. For 

example, if your source has a frame rate of 24 fps, then reduce the frame rate to 12 fps, 8 fps, 6 fps, 4 fps, 3 fps, or 2 fps.

For mobile devices, use the device-specific encoding presets. You can also use Adobe Device Central to determine the 

appropriate settings for many specific mobile devices. For information about Device Central, see Device Central Help.

Note: If you are creating a SWF file with embedded video, the frame rate of the video clip and the SWF file must be the 

same. If you use different frame rates for the SWF file and the embedded video clip, playback is inconsistent.

Key frames

Key frames are complete video frames (or images) that are inserted at consistent intervals in a video clip. The frames 

between the key frames contain information on changes that occurs between key frames.

http://goo.gl/2I8lf
http://forums.adobe.com/thread/729526
http://forums.adobe.com/thread/729526
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Note: Key frames are not the same as keyframes, the markers that define animation properties at specific times.

By default, Adobe Media Encoder automatically determines the key frame interval (key frame distance) to use based 

on the frame rate of the video clip. The key frame distance value tells the encoder how often to re-evaluate the video 

image and record a full frame, or key frame, into a file.

If your footage has a lot of scene changes or rapidly moving motion or animation, then the overall image quality may 

benefit from a lower key frame distance. A smaller key frame distance corresponds to a larger output file.

The key frame distance affects the ability of Flash Player to seek (fast-forward or rewind) through an FLV or F4V file. 

Flash Player can only advance from key frame to key frame. So, if you want to skip to different places and pause the 

frames, use a lower key frame distance value. 

When you reduce the key frame distance value, raise the bitrate for the video file to maintain comparable image 

quality.

Image aspect ratio and frame size

As with the frame rate, the frame size for your file is important for producing high-quality video. At a specific bitrate, 

increasing the frame size results in decreased video quality. 

The image aspect ratio is the ratio of the width of an image to its height. The most common image aspect ratios are 4:3 

(standard television), and 16:9 (widescreen and high-definition television).

Pixel aspect ratio

Most computer graphics use square pixels, which have a width-to-height pixel aspect ratio of 1:1. 

In some digital video formats, pixels aren’t square. For example, standard NTSC digital video (DV), has a frame size 

of 720x480 pixels, and it’s displayed at an aspect ratio of 4:3. This means that each pixel is non-square, with a pixel 

aspect ratio (PAR) of 0.91 (a tall, narrow pixel).

Interlaced versus noninterlaced video

Interlaced video consists of two fields that make up each video frame. Each field contains half the number of horizontal 

lines in the frame; the upper field (Field 1) contains all of the odd-numbered lines, and the lower field (Field 2) contains 

all of the even-numbered lines. An interlaced video monitor (such as a television) displays each frame by first drawing 

all of the lines in one field and then drawing all of the lines in the other field. Field order specifies which field is drawn 

first. In NTSC video, new fields are drawn to the screen 59.94 times per second, which corresponds to a frame rate of 

29.97 frames per second.

Noninterlaced video frames are not separated into fields. A progressive-scan monitor (such as a computer monitor) 

displays a noninterlaced video frame by drawing all of the horizontal lines, from top to bottom, in one pass.

Adobe Media Encoder deinterlaces video before encoding whenever you choose to encode an interlaced source to a 

noninterlaced output.

FLV and F4V video formats for Flash Player

The FLV and F4V formats are container formats, each of which is associated with a set of video and audio formats. 

F4V files generally contain video data that is encoded using the H.264 video codec and the AAC audio codec. These 

files can be played by Flash Player 9.0.r115 and later. The H.264 video codec is also referred to as MPEG-4 AVC 

(Advanced Video Coding). The H.264 video codec provides higher quality video at lower bitrates than the On2 VP6 

video codec.
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In addition to the F4V container format, Flash Player 9.0.115.0 and later versions support file formats derived from 

the standard MPEG-4 container format. These file formats include MP4, M4A, MOV, MP4V, 3GP, and 3G2, if they 

contain H.264 video or HE-AAC v2 encoded audio, or both.

FLV files generally contain video data that is encoded using the On2 VP6 or Sorenson Spark codec and audio data 

encoded using an MP3 audio codec. These files can be played by Flash Player 8 and later. Adobe Media Encoder CS5 

can import and encode FLV files using the On2 VP6 video codec, not the Sorenson Spark codec.

Note: Video encoded with the On2 VP6 codec in an FLV container can contain an 8-bit alpha channel (representing 

transparency) to enable compositing of video. Video encoded with the H.264 codec in an F4V container does not include 

an alpha channel.

H.264 and On2 VP6 use both temporal and spatial compression.

For more information about FLV and F4V formats and the H.264 and On2 VP6 encoders, see “Video formats and 

Flash” in Using Flash Professional CS5.

Fabio Sonnati provides recommendations for settings for H.264 (F4V) movies for mobile devices on the Adobe 

website.

High-definition (HD) video

High-definition (HD) video refers to any video format with pixel dimensions greater than those of standard-definition 

(SD) video formats. Typically, standard-definition refers to digital formats with pixel dimensions close to those of 

analog TV standards, such as NTSC and PAL (around 480 or 576 vertical lines, respectively). The most common HD 

formats have pixel dimensions of 1280x720 or 1920x1080, with an image aspect ratio of 16:9.

HD video formats include interlaced and noninterlaced varieties. Typically, the highest-resolution formats are 

interlaced at the higher frame rates, because noninterlaced video at these pixel dimensions would require a 

prohibitively high data rate.

HD video formats are designated by their vertical pixel dimensions, scan mode, and frame or field rate (depending on 

the scan mode). For example, 1080i60 denotes interlaced scanning of 60 interlaced 1920x1080 fields per second, 

whereas 720p30 denotes progressive scanning of 30 noninterlaced 1280x720 frames per second. In both cases, the 

frame rate is approximately 30 frames per second.

Trish and Chris Meyer provide tips for planning and delivering high-definition and widescreen work in articles on the 

ProVideo Coalition website:

• The High-Def Checklist

• Open Wide: Creating That Widescreen Look

Compression tips

Compression tips for video
Work with video in the native format of your project until your final output Use raw footage or the least compressed 

footage that is available to you. Each time that you compress video using a lossy encoder, you reduce the quality of the 

video. Though one generation of quality loss is often acceptable, re-encoding and recompressing already compressed 

video can degrade the quality beyond what is acceptable. Also, video that has already been encoded and compressed may 

contain noise and artifacts that make the next encoding and compression step take more time or produce a larger file.

Make your video as short as possible Trim the beginning and end of your video, and edit your video to remove any 

unnecessary content. See “Crop and trim source before encoding” on page 15.

http://www.adobe.com/devnet/devices/articles/mobile_video_encoding.html
http://www.adobe.com/devnet/devices/articles/mobile_video_encoding.html
http://provideocoalition.com/index.php/cmg_keyframes/story/hd_checklist/
http://provideocoalition.com/index.php/cmg_keyframes/story/open_wide/
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Adjust your compression settings If you compress footage and it looks great, try changing your settings to reduce the 

file size. Test your footage, and modify compression settings until you find the best setting possible for the video you 

are compressing. All video has varying attributes that affect compression and file size; each video needs its own setting 

for the best results. See “Encoding and exporting” on page 7.

Limit rapid movement  Limit movement if you are concerned about file size. Any movement increases file size. Shaky 

camera work, rolls, and zooms are particularly bad in this regard. You can use motion stabilization features in After 

Effects to remove extraneous movement.

Choose appropriate dimensions  See “Image aspect ratio and frame size” on page 3.

Select an appropriate frame rate See “Frame rate” on page 2. 

Choose an appropriate number of key frames See “Key frames” on page 2.

Reduce noise and grain  Noise and grain in source images increase the size of encoded files. Ideally, use utilities in 

Adobe Premiere Pro or After Effects to reduce noise and grain. You can also use the Gaussian blur filter in Adobe 

Media Encoder to help reduce noise, at the expense of image quality. See “Filters export settings” on page 18.

Compression tips for audio
The same considerations exist for audio production as for video production. To achieve good audio compression, you 

must begin with an audio file that is free of distortion and audible artifacts introduced from the source recording. 

If you are encoding material from a CD, try to record the file using direct digital transfer rather than the analog input 

of a sound card. The sound card introduces an unnecessary digital-to-analog and analog-to-digital conversion that can 

create noise in your transferred audio. Direct digital transfer tools are available for both Windows and Mac OS. If you 

must record from an analog source, use the highest quality sound card available.

Note: If your source audio file is monaural (mono), it is recommended that you encode in mono for use with Flash. If you 

are encoding with Adobe Media Encoder, and using an encoding preset, be sure to check if the preset encodes in stereo or 

mono, and select mono if necessary.

Preferences

• To open the Preferences dialog box, choose Edit > Preferences (Windows) or Adobe Media Encoder > Preferences 

(Mac OS).

• To restore default preference settings, hold Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS) 

while the application is starting. 

General
Increment Output File Name If The File With The Same Name Exists By default, if you tell Adobe Media Encoder to 

create an output file with the same name as an existing file in the same location, Adobe Media Encoder will increment 

the name of the new file. For example, if you encode a video clip and create the output file video.flv, and then re-encode 

the same file without first deleting video.flv, Adobe Media Encoder names the next file video_1.flv.

Important: To prevent the overwriting of files, name your files in such a way that they don’t inadvertently overwrite one 

another.

Remove Completed Files From Queue On Exit Removes any encoded items from the encoding queue when you quit 

the application.
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Warn On Stop Queue Or Remove File By default, Adobe Media Encoder prompts you with a warning if you attempt to 

stop encoding, remove a file, or move watch folders during the encoding process.

Play Chime When Finished Encoding In Adobe Media Encoder CS5.5, a chime plays when encoding is done.

Start Queue Automatically When Idle For The encoding process begins automatically within the specified time after an 

item has been added to the queue. The countdown timer is reset when you interact with the application. Deselect this 

option to disable this automatic starting. This preference is switched off by default in Adobe Media Encoder CS5.5.

Show Queue Elapsed Encoding Time Shows the amount of time that has elapsed since the encoding has started in 

Adobe Media Encoder CS5.5.

Preview While Encoding Videos are shown as they are being encoded in the Current Encode section. For best 

performance, uncheck the preference.

Place Output Files In By default, Adobe Media Encoder places exported files in the same folder as the source video clip. 

To choose a different destination folder in which to place encoded media clips, select Place Output Files In option, and 

click Browse. 

Language The language to use with Adobe Media Encoder. For Adobe Media Encoder CS5.5, this preference is 

located in the Appearance category.

Display Format The format and time base to use for time displays. For Adobe Media Encoder CS5.5, this preference 

is located in the Appearance category.

User Interface Brightness Brightness of Adobe Media Encoder interface. For Adobe Media Encoder CS5.5, this 

preference is located in the Appearance category.

Media

See “The media cache database” on page 27.

Metadata
Write XMP ID To Files On Import Writes unique identifier to imported files that don’t already contain one.

For information about other n in the Metadata category, see “Export and thin XMP metadata” on page 20.

Memory
RAM Reserved For Other Applications Adobe Media Encoder shares a memory pool with Adobe Premiere Pro, After 

Effects, and Encore. The RAM Available For value in Adobe Media Encoder CS5 (called “RAM Shared By” in Adobe 

Media Encoder CS5.5) indicates how much memory is in this memory pool. You can affect this value by giving more 

or less RAM to other applications (and the operating system). Give more RAM to the applications that share the 

memory pool by decreasing the RAM Reserved For Other Applications value. 

Important: Don’t set RAM Reserved For Other Applications to be very low. Depriving the operating system and other 

applications of memory can cause poor performance.
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Chapter 2: Encoding and exporting

Add and manage items in the encoding queue

In Adobe Media Encoder, you add source video or audio files, Adobe Premiere Pro sequences, and Adobe After Effects 

compositions to a queue of items to encode.

Import items into the encoding queue

• To add video or audio files, drag one more files into the queue, or click the Add button and choose one or more files.

• Additionally, in Adobe Media Encoder CS5.5, you can double click an open area in the Queue panel and choose 

one or more files.

• To add an Adobe Premiere Pro sequence, choose File > Add Premiere Pro Sequence, select a Premiere Pro project, 

and select a sequence from that project. You can also drag a Premiere Pro project into the queue. A dialog box 

launches, so that you can select a particular sequence. In Adobe Media Encoder CS5.5, you can drag and drop a 

sequence from the Project panel in Adobe Premiere Pro into the queue.

• To add an Adobe After Effects composition, choose File > Add After Effects Composition, select an After Effects 

project, and select a composition from that project. You can also drag an After Effects project into the queue. A 

dialog box launches, so that you can select a particular composition. In Adobe Media Encoder CS5.5, you can drag 

and drop a composition from the Project panel in Adobe After Effects into the queue.

• To add an image sequence, choose File > Add. In the Open dialog box, choose the first file of the image sequence. 

Check the enable checkbox for your file type, and then click the Open button (new in Adobe Media Encoder CS5.5).

Stop encoding the current item

• Choose File > Stop Current File, or click the Stop Queue button.

Interpret items in the encoding queue

When Adobe Media Encoder imports a video asset, it attempts to determine the pixel aspect ratio, frame rate, and field 

order for that asset, as well as how to interpret the alpha channel (transparency) information. If Adobe Media Encoder 

is wrong about any of these characteristics, you can explicitly assign the correct interpretation.

1 Select one or more items in the encoding queue.

2 Choose File > Interpret Footage. You can also right click on the file and choose > Interpret Footage

3 Choose the appropriate interpretation settings.

Add a watch folder to the encoding queue

You can configure Adobe Media Encoder to look for files in certain folders called watch folders. When Adobe Media 

Encoder finds a video or audio file in a watch folder, it encodes the file using the encoding settings assigned to the 

folder, and then exports the encoded file to an Output folder created inside the watch folder. 

1 Choose File > Create Watch Folder.

2 Select the target folder, and click OK. 

3 Choose a format and preset from the menus in the encoding queue next to the folder name.
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The items added to the encoding queue by the watch folder will be encoded along with other items in the queue when 

you start the queue.

Note: If you have the “start queue automatically when idle for” preference selected, encoding begins when the specified 

amount of time has elapsed after the watch folder has added a new item to the encoding queue.

Watch folders in Adobe Media Encoder CS5.5

In Adobe Media Encoder 5.5, the new Watch Folders panel can be used to add and manage folders. You can add a 

watch folder by doing one of the following:

• Choose File > Create Watch Folder.

• Click the Add Folders button.

• Double-click an empty area in the Watch Folders panel.

• Create a folder from Explorer (Windows) or Finder (Mac OS), and then drag it to the Watch Folders panel.

After you create a watch folder in the Watch Folders panel, you can see its name in the left column.

Leave the Auto-Encode Watch Folders checkbox enabled to encode all the items in a watch folder automatically.

Create output in multiple formats from a single source item using watch folders

In Adobe Media Encoder CS5.5, you can generate multiple outputs with a single operation by using watch folders. For 

example, you want to generate a FLV, an AVI movie, and a JPEG thumbnail image whenever you transcode a video 

asset. Follow these steps to create these files with a single user operation:

1 Create a folder using Explorer (Windows) or Finder (Macintosh) called, “My_WatchFolder,” for example.

In Adobe Media Encoder CS5.5, you will be making 3 Watch Folders (inside “My_WatchFolder”), where each one 

points to the same location on disk.

2 Create a new watch folder by clicking the Add Folder button, and then navigate to the folder you just made, 

“My_Watchfolder.”

a Select “FLV” as the format from the Format menu.

b Select a preset from the Preset Menu, and then click OK.

c Click on “Output To.” Select a location where you would like the result to be generated.

3 Create a new Watch Folder item that also points to the folder “My_Watchfolder,” just like you created in Step 2.

a Select “AVI” as the format from the Format menu.

b Select a preset from the Preset Menu, and then click OK.

c Click on “Output To.” Select a location where you would like the result to be generated.

4 Create a new Watch Folder item that also points to the folder “My_Watchfolder,” just like you created in Step 2 and 

Step 3.

a Select “JPEG” as the format from the Format menu.

b Select a preset form the Preset Menu, and then click OK.

c Click on “Output To.” Select a location where you would like the result to be generated.

5 Drag and drop the source file into “My_WatchFolder,” and then click the Start Queue button. In Adobe Media 

Encoder CS5.5, the encoding process begins automatically if Auto-Encode Watch Folders is enabled. 

When complete, each file will be in its expected output locations.
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Save the encoding queue

The encoding queue and all encoding settings are saved automatically when you exit Adobe Media Encoder.

• To manually save the encoding queue, choose File > Save Queue.

Remove items from the encoding queue

1 Select the item, or items that you want to remove from the encoding queue.

2 Click the Remove button, choose Edit > Remove, or press the Delete key. In Adobe Media Encoder CS5.5, you can 

click the Remove button, as well.

Duplicate items in the encoding queue

1 Select the item, or items that you want to duplicate in the encoding queue.

2 Click the Duplicate button, choose Edit > Duplicate, or press Ctrl-D (Windows), or Command-D (Mac OS). In 

Adobe Media Encoder CS5.5, you can click the “Duplicate” button, or right-click the file and choose > Duplicate, 

as well.

Skip items in the encoding queue

Skip items
1 Select the item, or items that you want to skip in the encoding queue.

2 Choose Edit > Skip Selection. In Adobe Media Encoder CS5.5, you can also right-click the file and choose > Skip 

Selection.

Reset a skipped file for encoding
1 Select the items in the encoding queue that you want to reset to the Waiting state.

2 Choose Edit > Reset Status. In Adobe Media Encoder CS5.5, you can also right-click the file and choose > Reset 

Status.

File formats supported for import

Important: The trial version of Adobe Media Encoder CS5 doesn't include some features that depend on third-party 

software components that are only included in the full version of Adobe Media Encoder. The import and export of some 

formats are not supported in the trial version: AVC-Intra, AVCHD, HDV, MPEG-2, MPEG-2 DVD, MPEG-2 Blu-ray, 

and XDCAM. The trial version for Adobe Media Encoder CS5.5 does not have these limitations. It includes all of the items 

that are included in the full, activated version of Adobe Media Encoder CS5.5.

Some filename extensions—such as MOV, AVI, MXF, and FLV—denote container file formats rather than denoting 

a specific audio, video, or image data format. Container files can contain data encoded using various compression and 

encoding schemes. Adobe Media Encoder can import these container files, but the ability to import the data that they 

contain is dependent on which codecs (specifically, decoders) are installed.

By installing additional codecs, you can extend the ability of Adobe Media Encoder to import additional file types. 

Many codecs must be installed into the operating system and work as a component inside the QuickTime or Video for 

Windows formats. Contact the manufacturer of your hardware or software for more information about codecs that 

work with the files that your specific devices or applications create.
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Video and animation formats
• 3GP

• Animated GIF (GIF) (Windows only)

• DV (in MOV or AVI container, or as a containerless DV stream)

• FLV, F4V

Note: The FLV and F4V formats are container formats, each of which is associated with a set of video and audio 

formats. F4V files generally contain video data that is encoded using an H.264 video codec and the AAC audio codec. 

FLV files generally contain video data that is encoded using the On2 VP6 or Sorenson Spark codec and audio data 

encoded using an MP3 audio codec. Adobe Media Encoder CS5, and later, can import FLV files using the On2 VP6 

video codec, not the Sorenson Spark codec.

• QuickTime movie (MOV; on Windows, requires QuickTime player)

• MPEG-1, MPEG-2, and MPEG-4 formats (MPEG, MPE, MPG, M2V, MPA, MP2, M2A, MPV, M2P, M2T, MTS, 

AC3, MP4, M4V, M4A, VOB, 3GP, AVC, h.264)

Note: Several formats associated with specific modern cameras use MPEG-4 encoding. For example, the XDCAM EX 

format uses MP4 files, and the AVCHD format uses MTS files.

• Media eXchange Format (MXF)

• MXF OP1a (new in Adobe Media Encoder CS5.5)

Note: MXF is a container format. Adobe Media Encoder can only import some kinds of data contained within MXF 

files. Adobe Media Encoder can import the Op-Atom variety used by Panasonic cameras using the DV, DVCPRO, 

DVCPRO50, DVCPRO HD, and AVC-Intra codecs to record to Panasonic P2 media. Adobe Media Encoder can also 

import XDCAM HD files in MXF format.

• Netshow (ASF, Windows only)

• RED Raw (R3D)

• Video for Windows (AVI, WAV; on Mac OS, requires QuickTime Player)

• Windows Media (WMV, WMA, ASF; Windows only)

Audio formats
• Adobe Sound Document (ASND; multi-track files imported as merged single track)

• Advanced Audio Coding (AAC, M4A)

• Audio Interchange File Format (AIF, AIFF)

• QuickTime (MOV; on Windows, requires QuickTime player)

• MP3 (MP3, MPEG, MPG, MPA, MPE)

• Video for Windows (AVI, WAV; on Mac OS, requires QuickTime Player)

• Windows Media Audio (WMA; Windows only)

• Waveform (WAV)

Still-image formats
• Photoshop (PSD)

• Bitmap (BMP, DIB, RLE) (Windows only)

• Cineon/DPX (CIN, DPX)
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• GIF

• Icon File (ICO; Windows only)

• JPEG (JPE, JPG, JPEG, JFIF)

• PICT (PIC, PCT)

• Portable Network Graphics (PNG)

• Targa (TGA, ICB, VDA, VST)

• TIFF (TIF)

Note: In Adobe Media Encoder 5.5, you can import files of any still-image format as a sequence. For more information, 

see “Import items into the encoding queue” on page 7.

Project file formats
• Adobe Premiere Pro (PRPROJ)

• After Effects (AEP, AEPX)

Encode and export video and audio

After adding video and audio items to the encoding queue, you can encode and export them from the queue using 

presets or custom settings.

Encode using presets

1 In Adobe Media Encoder, add items to the queue of items to encode. For information, see “Add and manage items 

in the encoding queue” on page 7.

2 Choose a video format most suitable for your output from the Format pop-up menu.

3 Choose a video preset most suitable for your output from the Presets pop-up menu.

4 Choose a location for your export by clicking the text for Output File, and then finding the directory or folder for 

your exports in the Save As dialog box. Click Save.

5 Allow encoding to start automatically, or press the Start Queue button. In CS5.5, cllick the triangle button in the 

upper right of the window.

Your files will begin to be encoded to your desired format, using your chosen preset, and in the location that you chose.

Encode using custom settings

1 In Adobe Media Encoder, add items to the queue of items to encode. For information, see “Add and manage items 

in the encoding queue” on page 7.

2 Select one or more items in the queue and open the Export Settings dialog box by choosing Edit > Export Settings. 

In Adobe Media Encoder CS5.5, you can also right-click on the file and select Export Settings. 

3 Set export options. For more information, see “Export settings reference” on page 15.

4 After setting options, click OK. With the Export Settings dialog box closed, click Start Queue to begin encoding 

your files. In CS5.5, click the triangle button in the upper right of the window.

You can close the Current Encode panel for optimum performance during encoding. View progress of the encoding 

process with the progress bar in the Queue panel instead. 
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You can do any of the following in the Export Settings dialog box:

• Choose a video, audio, or still-image format from the Format menu. For more information, see “File formats 

supported for export” on page 13.

• (Optional) Choose an encoding preset from the Preset menu. 

• Select Export Video, Export Audio, or both.

• (Optional; available for some formats) Open the item in Adobe Device Central by selecting Open In Device Central.

• (Optional) Set settings in the various tabs of the Export Settings dialog box that meet your encoding needs. For 

more information, see “Export settings reference” on page 15.

• (Optional) Specify pre-encoding options, including cropping, trimming, and addition of cue points. (See “Crop and 

trim source before encoding” on page 15 and “Working with cue points for FLV and F4V video files” on page 23.)

• (Optional) Set options for XMP metadata export. (See “Export and thin XMP metadata” on page 20.)

• (Optional) Select Use Maximum Render Quality or Render At Maximum Bit Depth. 

Note: Rendering at a higher color bit depth requires more RAM and slows rendering substantially.

• (Optional) Select Use Frame Blending.

• Specify a filename and location for the encoded file by clicking the underlined text next to Output Name in the 

upper-right section of the Export Settings dialog box and entering a filename and location. If you don’t specify a 

filename, Adobe Media Encoder uses the filename of the source video clip.

Note: When the format is set to P2 Movie, the user-assigned filename is not applied. Instead, such encodes are given 

a six character alphanumeric name by Adobe Media Encoder. The Output Name is saved to the clip’s metadata, and 

is shown as the clip name in Adobe Premiere Pro.

You can specify a destination folder in which to save the encoded file relative to the folder containing the source 

video clip. When specifying a destination folder, keep in mind the following:

• The destination folder you specify must exist. If you specify a folder that does not exist, an error message informs 

you that the file cannot be encoded because the folder cannot be found. 

• When specifying a folder, separate the folder name and the filename using either a forward slash (/) or backward 

slash (\). Use only a forward slash (/) on Mac OS.

In Preferences, you can choose a folder to specify the destination of encoded files. (See “Preferences” on page 5.) 

Monitor encoding progress

While an item is being encoded, the Status column of the encoding queue provides information on the status of each item.

Encoding  The item is currently being encoded. Adobe Media Encoder encodes only one item at a time. You can 

continue to work in Adobe Media Encoder while encoding is in progress. You can add, remove, or reorder items in 

the queue or watch folder.

Waiting The item is in the encoding queue but has not been encoded. You can remove a file from the queue that has 

not been encoded and is not being encoded.

Encoding completed successfully icon  The item has been successfully encoded. Called “Done” in Adobe Media 

Encoder CS5.5.

Encoding stopped by user icon   The user canceled the encoding process while the item was being encoded. Called 

“Stopped” in Adobe Media Encoder CS5.5.
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Error icon   Adobe Media Encoder encountered an error when attempting to encode the specified item. Called 

“Failed” in Adobe Media Encoder CS5.5.

Skip Selection The user can skip one, or more selected files. With the files selected, choose Edit > Skip Selection.

Audible alerts when jobs completed (successfully and with errors)  Adobe Media Encoder CS5.5 has audible alerts. It 

plays an audible alert at the completion of the jobs in the Queue. A different alert sounds if any error conditions are 

detected. These alerts can be disabled in preferences, if you do not want to hear them.

During the encoding process, click the Start Queue button once more if you would like to pause the encoding process 

(new in Adobe Media Encoder CS5.5).

Click the status icon to open the log for any item for which encoding is done, stopped, or failed. 

More Help topics 

“Log files” on page 26

“Preferences” on page 5

File formats supported for export

Important: The trial version of Adobe Media Encoder CS5 doesn't include some features that depend on third-party 

software components that are only included in the full version of Adobe Media Encoder. The import and export of some 

formats are not supported in the trial version. The trial version for Adobe Media Encoder CS5.5 does not have these 

limitations, it is as functional as the retail version.

When you export using Adobe Media Encoder, you select a format in the Export Settings dialog box for your output. 

The format you select determines which Preset options are available. Select the format best suited for your output goal.

Adobe Media Encoder is used both as a standalone application and as a component of Adobe Premiere Pro, After 

Effects, Flash Professional, Soundbooth, and Encore. The formats that Adobe Media Encoder can export depend on 

which of these applications are installed. The version of Adobe Media Encoder that is installed with Flash Professional 

can export to Flash video formats. To export to other video formats, you need the version that comes with the 

Production Premium or Master Collection edition, or with After Effects or Premiere Pro.

Some filename extensions—such as MOV, AVI, MXF, FLV, and F4V—denote container file formats rather than 

denoting a specific audio, video, or image data format. Container files can contain data encoded using various 

compression and encoding schemes. Adobe Media Encoder can encode video and audio data for these container files, 

depending on which codecs (specifically, encoders) are installed. Many codecs must be installed into the operating 

system and work as a component inside the QuickTime or Video for Windows formats.

Depending on what other software you have installed, the following options may be available:

Video and animation
• Animated GIF (Windows only)

• FLV, F4V

Note: The FLV and F4V formats are container formats, each of which is associated with a set of video and audio 

formats. F4V files generally contain video data that is encoded using an H.264 video codec and the AAC audio codec. 

FLV files generally contain video data encoded using the On2 VP6 or Sorenson Spark codec and audio data encoded 

using an MP3 audio codec. Adobe Media Encoder CS5 can encode FLV files using the On2 VP6 video codec, not the 

Sorenson Spark codec.
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• H.264 (AAC, 3GP, MP4, M4V)

• H.264 Blu-ray (M4V)

• MPEG-2 (MPA, M2V, MPG)

• MPEG-2 DVD (M2V)

• MPEG-2 Blu-ray (M2V, WAV)

• MPEG-4

• P2 (MXF)

Note:  MXF is a container format. Adobe Media Encoder can encode and export movies in the Op-Atom variety of 

MXF containers using the DVCPRO25, DVCPRO50, and DVCPRO100, and AVC-Intra codecs.

• MXF OP1a (new in Adobe Media Encoder CS5.5)

• QuickTime movie (MOV; on Windows, requires QuickTime)

• Windows Media (WMV; Windows only)

• Video for Windows (AVI; Windows only)

Still image and still-image sequence
Note: To export a movie as a sequence of still-image files, select Export As Sequence on the Video tab when a still-image 

format is selected.

• Bitmap (BMP; Windows only)

• DPX

• GIF (Windows only)

• JPEG

• PNG

• Targa (TGA)

• TIFF (TIF)

Audio
• Audio Interchange File Format (AIFF; Mac OS only)

• MP3

• Waveform (WAV)

• Advanced Audio Coding (AAC)

• AC3 Dolby audio (available only if Adobe Master Collection, Production Premium, or Premiere Pro is installed)

Codecs installed for different installations of Adobe Media Encoder
• Adobe Master Collection, Adobe Production Premium, or Adobe Premiere Pro: All codecs

• Adobe After Effects: All codecs except Dolby audio

• All other products: FLV, F4V, h.264, MP3
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Export settings reference

Export Settings dialog box overview

To open the Export Settings dialog box, click Settings in the Adobe Media Encoder main application window or choose 

Edit > Export Settings.

Note: There is no Settings button in Adobe Media Encoder CS5.5. You can right click on the asset and choose > Export 

Settings, or choose Edit > Export Settings.

The Export Settings dialog box includes a large viewing area on the left, which includes Source and Output panels.

Other tabs in the Export Settings dialog box include available encoding settings for the selected format.

For information about using the various encoding options in the Export Settings dialog box, see “Encoding and 

exporting” on page 7.

For information about using the controls in the timeline area and the image viewing area to crop and trim the source 

item, see “Crop and trim source before encoding” on page 15.

Image viewing area

• To toggle between previewing an image with or without pixel aspect ratio correction, choose Aspect Ratio 

Correction from the panel menu at the upper right of the Source panel or Output panel.

• To zoom into and out of the preview image, choose zoom level from the Select Zoom Level menu above the 

timeline. 

You can also zoom out by pressing Ctrl+- (hyphen) (), or Command+- (hyphen) (Mac OS). Zoom in by pressing 

Ctrl+= (equal sign) (Windows) or Command+= (equal sign) (Mac OS). These keyboard shortcuts use the main 

keyboard, not the similar keys on the numeric keypad.

Timeline and time display

A time display and a timeline are located under the image viewing area in both the Source panel and Output panel. 

The timeline includes a current-time indicator (playhead), a viewing area bar, and buttons for setting In points and 

Out points.

• To move the current-time indicator, click or drag the current-time display or drag the current-time indicator.

Crop and trim source before encoding

1 In the Export Settings dialog box, click the Source tab.

2 To trim the video such that you only encode and export part of the duration of the source video or audio item, set 

an In point (first frame) and Out point (last frame). You can set the In point or Out point to the current time by 

clicking the Set In Point or Set Out Point button above the timeline, or by dragging the In point or Out point icon 

in the timeline. 

You can also choose to trim to the work area by choosing Work Area (from Adobe After Effects, or Adobe Premiere 

Pro) from the Source Range menu.

Note: Adobe Media Encoder honors timecode information in a source file. If the source starts from 00:00:05:00, then the 

timeline for the item in Adobe Media Encoder also starts from 00:00:05:00, and not from zero. This timecode information 

is included in the encoded output file.

3 To crop the image, click the Crop The Output Video  button in the upper-left corner of the Source panel.

4 To constrain the proportions of the cropped image, choose an option from the Crop Proportions menu.



16USING ADOBE MEDIA ENCODER

Encoding and exporting

Last updated 7/15/2011

5 Do any of the following:

• Drag the sides or corner handles of the crop box.

• Enter values for Left, Top, Right, Bottom, in pixels.

6 Click the Output tab to preview the cropped image. 

7 From the Crop Setting menu on the Output panel, choose one of the following:

Scale To Fit  Adjusts the dimensions of the cropped video to fit within the Frame Width and Frame Height specified 

in the Video tab. If the aspect ratio defined by those values does not match that of the cropped video, then you will 

necessarily have black bars on encoded footage.

Black Borders Applies a black border to the video, even if the target dimension is smaller than the source video.

Change Output Size  Automatically sets the height and width of the output to the height and width of the cropped 

frame. Choose this setting if you want to export content for use with Flash Player or other web applications without 

black borders such as those used with letterboxing or pillarboxing. This option is only available for FLV and F4V 

formats.

Note: To revert to an uncropped image, click the Crop The Output Video  button again.

Video exports settings

Adobe Media Encoder is used both as a standalone application and as a component of Adobe Premiere Pro, After 

Effects, Flash Professional, Soundbooth, and Encore. In some contexts—including rendering and exporting from 

Premiere Pro—you set encoding options in the full Adobe Media Encoder Export Settings dialog box. In other 

contexts—including rendering and exporting from After Effects—you set encoding options in a format-specific 

Options dialog box that only presents a subset of the encoding options.

Adobe Media Encoder ships with many presets, each of which sets the various options to meet the requirements for a 

common target output. In the Export Settings or format-specific Options dialog box, the options available on the 

Video tab depend on the format you’ve specified.

Options not documented here are either specific to the selected format or do not require documentation. For detailed 

information, consult the specifications for the selected format. For example, MPEG formats include many advanced 

options not listed here. For detailed information on options not listed, consult the specifications for the MPEG-2 

(ISO/IEC 13818) format and the Wikipedia website.

Note: Some capture cards and plug-in software provide their own dialog boxes with specific options. If the options you see 

are different from the options described here, see the documentation for your capture card or plug-in.

For general information about compression settings, see “Compression tips” on page 4.

TV Standard Conforms the output to the NTSC standard or to the PAL standard. When set to Automatic (Based On 

Source), Adobe Media Encoder automatically sets this value to match the source. For example, if the source file frame 

rate is 25 fps, Adobe Media Encoder sets the TV standard to PAL.

Frame Dimensions Dimensions, in pixels, of the output frame. When set to Automatic (Based On Source), Adobe 

Media Encoder automatically sets this value to match the frame dimensions of the source. (See “Image aspect ratio and 

frame size” on page 3.)

Frame Rate Frame rate of the output file in frames per second. Some codecs support a specific set of frame rates. When 

set to Automatic (Based On Source), Adobe Media Encoder automatically sets this value to match the frame rate of the 

source. (See “Frame rate” on page 2.)

Field Order or Field Type Specifies whether the output file has progressive frames or frames made up of interlaced 

fields, and if the latter, which field will be written first. Progressive is the correct setting for computer display and 

http://en.wikipedia.org/wiki/Moving_Picture_Experts_Group
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motion picture film. Choose Upper First or Lower First when exporting video for an interlaced medium, such as 

NTSC, or PAL. When set to Automatic (Based On Source), Adobe Media Encoder automatically sets this value to 

match the field order of the source. (See “Interlaced versus noninterlaced video” on page 3.)

Aspect or Pixel Aspect Ratio Select the pixel aspect ratio appropriate for the output type. When the pixel aspect ratio 

(displayed in parentheses) is 1.0, the output will have square pixels; all others will have non-square pixels. Because 

computers generally display pixels as squares, content using non-square pixel aspect ratios appear stretched when 

viewed on a computer but appear with the correct proportions when viewed on a video monitor. When set to 

Automatic (Based On Source), in H.264 Blu-ray, MPEG-2 Blu-ray, or MPEG-2-DVD format, Adobe Media Encoder 

automatically sets this value to match the pixel aspect ratio of the source. (See “Pixel aspect ratio” on page 3.)

Profile Specifies whether Adobe Media Encoder will use the Baseline, Main, or High profile.

Note: Profile and Level settings are relevant to formats that use variants of MPEG encoding, including H.264. 

Recommended settings are often a combination of Profile and Level settings. For example, a common recommendation 

for high-quality encoding for Internet distribution is a setting of High Profile, Level 5.1. For more information, see the 

Wikipedia website.

Level Level used by Adobe Media Encoder, with ranges that differ depending on output format. This setting, in part, 

specifies a maximum bitrate.

Quality Generally, higher values increase rendering time and image quality.

• Good Strikes a balance between image quality and the amount of time it takes to encode video. This is the default 

value.

• Best Creates the best possible image quality, but will take substantially longer to encode video.

• Speed Specifies that the video be encoded as fast as possible. However, the image will be of lower quality. 

Recommended for video content used in testing deployments.

Export As Sequence For still-image export, select this option to export as a sequentially numbered series of still-image 

files.

Header Type Specifies SMPTE/DPX or Cineon header. 

Resize video Selecting this option allows you to change the frame width and frame height from the size of the input 

file or sequence. You can also click a button to maintain the aspect ratio while resizing.

Depth Color depth in bits per pixel.

Encoding Passes Number of times the encoder will analyze the clip before encoding. Multiple passes increase the time 

it takes to encode the file, but generally result in more efficient compression and higher image quality.

M Frames Number of B frames (bi-directional frames) between consecutive I frames (intra-frames) and P frames 

(predicted frames).

N Frames Number of frames between I frames (intra-frames). This value must be a multiple of the M frames value.

Simple Profile Available only when exporting in the FLV video format using the On2 VP6 codec, selecting Simple 

Profile optimizes high-resolution video content that will be played back on older computers or other devices with 

limited memory and processing resources.

Undershoot [% target] Available only when exporting in the FLV video format using the On2 VP6 codec, this option 

lets you specify the percentage of the target data rate to shoot for so that additional data is available in the buffer to 

improve difficult sections.

Closed GOP Every Frequency of each closed group of pictures (closed GOP), which cannot reference frames outside 

of the closed GOP. A GOP consists of a sequence of I, B, and P frames. (This option is available if you choose MPEG-2 

as the format.)

http://en.wikipedia.org/wiki/MPEG-4#Profiles_and_Levels
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Bitrate Number of megabits per second. Different formats present different bitrate options. The minimum bitrate 

differs according to the format. For example, for MPEG-2 DVD, the minimum bitrate is 1.5 Mbps. (See “Bitrate” on 

page 2.)

Bitrate Mode or Bitrate Encoding Specifies whether the codec produces a constant bitrate (CBR) or variable bitrate 

(VBR) in the exported file:

• Constant Delivers a consistent data rate, with the quality potentially fluctuating from frame to frame depending on 

the degree of compression required. 

• Variable Constrained Delivers more consistent quality, with the degree of compression, and therefore the data rate 

allowed to fluctuate.

• Variable Unconstrained Allows the exported file’s data rate to vary without limit, with an option to target an 

average bitrate.

• Constant or CBR •VBR, 1 Pass Variable bitrate, with the encoder making a single pass through the file from 

beginning to end. Single-pass encoding takes less time than dual-pass encoding, but doesn’t achieve the same quality 

in the output.

• VBR, 2 Pass Variable bitrate, with the encoder making two passes through the file, from beginning to end, and then 

from end to beginning. The second pass prolongs the process, but it ensures greater encoding efficiency, and often a 

higher quality output.

Note: When comparing CBR and VBR files of the same content and file size, you can make the following generalizations: 

A CBR file may play back more reliably over a wider range of systems, because a fixed data rate is less demanding on a 

media player and computer processor. However, a VBR file tends to have a higher image quality, because VBR tailors the 

amount of compression to the image content.

Bitrate Level (FLV, F4V, H.264 Blu-ray, and MPEG-2 Blu-ray formats only)  When the Bitrate level is set to Custom, the 

output bitrate can be changed to any value. When the Bitrate Level is set to High, Medium, or Low, the bitrate is set 

automatically based on frame dimensions as a read-only value and cannot be changed. Adobe Media Encoder has 

default presets for the formats which have the Bitrate Level set to automatic.

Key Frame Interval [Seconds] or Set Key Frame Distance (Frames) Number of frames after which the codec will create 

a key frame when exporting video. (See “Key frames” on page 2.)

Optimize Stills or Expand Stills Select this option to use still images efficiently in exported video files. For example, if 

a still image has a duration of 2 seconds in a project set to 30 fps, Adobe Premiere Pro creates one 2-second frame 

instead of 60 frames at 1/30 of a second each. Selecting this option can save disk space for sequences and clips 

containing still images. Deselect this option only if the exported video file exhibits playback problems when displaying 

the still images.

Filters export settings

The Gaussian Blur effect softens the image and eliminates noise. Adobe Media Encoder applies the Gaussian Blur 

effect as a pre-encoding step. This step minimizes the noise that the encoder would otherwise have to encode. It results 

in quicker encoding and smaller output file sizes. Select the Output tab to preview the results of this effect.

Blurriness Amount of blur.

Blur Dimension Direction of the blur. Select either Horizontal And Vertical, Horizontal, or Vertical from the menu.

Note: You can remove noise and grain from a project for reasons other than improved encoding and reduction of 

compressed file size. Consider the Noise & Grain effects, or blur effects, in Adobe Premiere Pro and After Effects.
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Multiplexer export settings

The Multiplexer preset options (sometimes called Format) control how MPEG video and audio data are merged into 

a single stream. The exact options available depend on the MPEG format you choose.

When you choose the MPEG-2 format, all Multiplexer options provided by the MPEG standard are available for 

manual control. In most cases, it’s better to select an MPEG preset specifically targeted to your output medium (such 

as MPEG-2 DVD).

For more information about MPEG options, see the relevant MPEG specifications for MPEG-4 (ISO/IEC 14496) and 

MPEG-2 (ISO/IEC 13818) and the Wikipedia website.

Audio export settings

In the Export Settings dialog box, the options available in the Audio tab depend on the format you’ve specified. 

Options not documented here are either specific to the selected format or do not require documentation because their 

names are self-documenting. For detailed information, consult the specifications for the selected format.

Some audio formats support only uncompressed audio, which has the highest quality but uses more disk space. Some 

formats provide only one codec. Others allow you to choose from a list of supported codecs.

Sample Rate or Frequency Choose a higher rate to increase the frequency at which audio is converted into discrete 

digital values, or sampled. Higher sample rates increase audio quality and file size; lower sample rates decrease quality 

and file size. 

Setting the sample rate in the Export Settings dialog box higher than the sample rate of the audio source doesn’t 

increase quality. Setting a sample rate different from the sample rate of the source file requires resampling and 

additional processing time. You can avoid resampling by capturing audio at the same rate at which you want to export 

it. (See “Compression tips” on page 4.)

Channels or Output Channels Specify how many audio channels are in the exported file. If you choose fewer channels 

than are in the master track of a sequence or project, Adobe Media Encoder downmixes the audio.

Sample Type Choose a higher bit depth to increase accuracy of audio samples. Higher bit depth can improve dynamic 

range and reduce distortion, especially if you add additional processing, such as filtering or resampling. Higher bit 

depths also increase processing time and file size; lower bit rates reduce processing time and file size. 

Setting the bit depth in the Export Settings dialog box higher than the bit depth of the source audio doesn’t increase 

quality.

Audio Interleave Specifies how often audio information is inserted among the video frames in the exported file. See 

your capture card documentation for the recommended setting. A value of one frame means that when a frame is 

played back, the audio for the duration of that frame is loaded into RAM so that it can play until the next frame appears. 

If the audio breaks up when playing, adjust the interleave value. Increasing the value lets the computer store longer 

audio segments, and process them less often. However, higher interleave values require more RAM. Lowering the 

value can make playback smoother. Most hard disks operate best with a 1/2-second to 1-second interleave value.

Setting the value to 0 disables Audio Interleave and speeds rendering time. Consider disabling Audio Interleave for 

projects containing assets with large pixel dimensions.

Bitrate [Kbps] The output bit rate of the audio. Generally, higher bit rates increase both quality and file size.

http://en.wikipedia.org/wiki/Moving_Picture_Experts_Group
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FTP export settings

The FTP tab of the Export Settings dialog box allows you to upload the exported file to a File Transfer Protocol (FTP) 

server that has storage space allocated for file sharing. FTP is a common method for transferring files over a network 

and is especially useful for sharing relatively large files using an Internet connection. The server’s administrator can 

provide you with the details for connecting to the server. 

The FTP tab includes the following options:

Server Name Enter the DNS or IP address of the server on which the FTP site is located.

Port Specify the number assigned to the FTP server’s command port, which is 21 by default.

Remote Directory Enter the location on the FTP server to access, expressed as a file path.

User Login Enter the user’s identity, as designated by the server’s administrator.

Password Enter the password to a password-protected server.

Retries Specify the number of attempts to contact the server if a connection isn’t established.

Send Local File To Recycle Bin (Windows) or Send Local File To Trash (Mac OS) Deletes the local copy of the exported 

file once it’s been uploaded to the FTP server.

Test Verifies the connection with the FTP server.

Audiences export settings

In the Export Settings dialog box, selecting Windows Media (Windows only) as the format exposes the Audiences tab. 

The options on the Audiences tab allow you to output variations of a movie suited to different network speeds. The 

player software associated with the format detects and selects the most appropriate version to ensure smooth playback. 

Windows Media generates a single movie that contains variations for different connection speeds.

Note: Some codec-specific settings are not documented here. For more detailed information regarding a particular codec, 

check the documentation provided by its developer.

Compressed Specifies that the codec you select in the Video tab is applied. Compressed is the default setting, and is 

appropriate for most users.

Add/Remove Audiences Lets you add or remove audiences to create a multi-audience Windows Media (.WMV) video 

file. 

Export and thin XMP metadata

You can choose what XMP metadata (if any) to include in the output file. 

To open the Metadata Export dialog box, click the Metadata button in the lower-right corner of the Export Settings 

dialog box or choose Edit > Edit Metadata.

Note: You can perform many of the same actions in the Metadata category in the Preferences dialog box. (See 

“Preferences” on page 5.) Changes made in the Preferences dialog box don’t apply to selected items in the encoding queue, 

but the templates and rules are available for later assignment through the Metadata Export dialog box.

Specifying how and whether to include XMP metadata on output

Use the Export Options menu to specify whether XMP metadata should be embedded in the output file, stored in a 

sidecar (.xmp) file, both, or neither. 
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If you choose None, then no XMP metadata from the source will be embedded in the file, and none of the other 

controls for XMP metadata export are available. Basic XMP metadata about the exported file—such as export settings 

and start timecode—is always exported, even when None is chosen.

Note: The Embed In Output File options are disabled for files of kinds for which XMP metadata can’t be embedded.

Preserving XMP metadata from sources

Many source assets contain XMP metadata. You can choose which XMP metadata from source assets should be 

preserved in the encoded output files by using a preservation rule.

For single-source clips, preserving XMP metadata ensures that the production metadata from the original source flows 

through to the re-encoded output file. For sequences and compositions, including source metadata preserves the 

metadata from each of the items used to make up that sequence or composition. Excluding existing source metadata 

is often referred to as thinning. You may want to exclude source metadata for security purposes or privacy concerns, 

or to reduce the size of the output file as much as possible.

A preservation rule acts as a filter to specify which XMP metadata from a source item is passed through to an encoded 

output file. The preset preservation rules are Preserve All and Exclude All. Preserve All is the default.

To create your own preservation rule, click New next to the Preservation Rules menu. You can enable individual fields 

or categories by selecting them in the Preservation Rules Editor dialog box. To find specific fields, use the search field 

near the top of the Preservation Rules Editor dialog box. Be sure to give your preservation rule a descriptive name.

You can edit an existing custom preservation rule by choosing it from the Preservation Rules menu and clicking Edit.

Note: Two kinds of source XMP metadata are handled separately from the source XMP metadata controlled by the 

preservation rules: sequence markers and the XMP metadata that is created by the speech analysis features in Adobe 

Premiere Pro and Soundbooth. To include the speech XMP metadata and sequence markers, select Export Master Speech 

Track And Sequence Markers. 

Adding XMP metadata 

An export template specifies what XMP metadata will be written to the output file. For example, you can create an 

export template that includes various XMP metadata from the source files as well as adding your contact information 

and rights-management information to each output file.

The export template acts as a filter; any fields that are not explicitly enabled by the current template will be filtered out. 

The only exceptions are internal properties that are automatically populated with data by the creator application, 

which are always included and are not editable.

To create your own export template, click New next to the Export Template menu. You can enable individual fields or 

categories by selecting them in the Export Template Editor dialog box. To find specific fields, use the search field near 

the top of the Export Template Editor dialog box. Be sure to give your export template a descriptive name.

You can edit an existing custom export template by choosing it from the Export Template menu and clicking Edit.

After you have applied an export template, you can also manually enter values to add specific XMP metadata to the 

current encoding queue items.

Some fields are uneditable and can’t be excluded from output—such as fields that are written automatically by the 

creator application. For example, the Format field in the Dublin Core schema and the Video Frame Rate field in the 

Dynamic Media schema are set by Adobe Media Encoder to accurately describe the output file, and these fields are not 

user-editable. Also, values that are specified by the current export template appear as uneditable; to change these 

values, change the template or apply a different template.
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Any field that doesn’t contain data—either from the template or manually entered—will be excluded from the 

exported XMP metadata. Empty fields are not written to the output file.

Use preview files from Adobe Premiere Pro

When encoding Adobe Premiere Pro sequences, choose Use Previews to use existing preview files (which have already 

been rendered and encoded) for the parts of the sequence for which they are available.

Note: Launch Adobe Media Encoder from Adobe Premiere Pro to use preview files. Choose Export > Media in Premiere 

Pro to launch Adobe Media Encoder. Ensure that “Match Sequence Settings” is selected.

Using existing preview files can make encoding much faster. The disadvantage, however, is that the preview files may 

have been encoded using different settings than those used for the rest of the sequence—for example, the preview files 

may have been encoded using lossy compression.

Working with custom encoding presets

Choosing a format automatically makes available a list of associated presets designed for particular delivery scenarios. 

Adobe Media Encoder uses characteristics of the source item to make its best guess about the best preset to select. You 

can create and save your own presets, export them, or import additional ones.

Note: Adobe Technical Support supports only Adobe Media Encoder presets that are included with Adobe applications.

Create and save a custom preset

1 In the Format menu, select a format.

2 In the Preset menu, select the preset that most closely matches the settings you want, or select Custom.

3 Customize settings in the Export Settings dialog box.

4 Click the Save Preset button .

5 Type a name for the preset, choose whether to save specific categories of parameters as prompted, and click OK.

Encoding presets are saved to the following location:

• Windows: <drive>\Users\<user_name>\AppData\Roaming\Adobe\Common\AME\5.0

• Mac OS: <drive>/Users/<user_name>/Library/Preferences/Adobe/Common/AME/5.0

Note: In Adobe Media Encoder CS5.5, the encoding presets are located in the same location as the Adobe Media Encoder 

CS5 files.

Import a preset

1 Click the Import Preset button .

2 Navigate to the location of the preset, select it, and then click Open.

3 Type a name for the imported preset, specify other options, and then click OK.

You can only import a preset for a given format when that format is selected in the Format menu. For example, If you 

try to add an MPEG 2 preset, you will get an error if the format is set to FLV. Change the format to MPEG 2 first to 

create a new preset.
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Export a preset

1 In the Export Settings dialog box, choose the preset you want to export.

2 Alt-click (Windows) or Option-click (Mac OS) the Save Preset button .

3 Choose the location to save the preset, name it, and then click Save. 

The preset is saved as a file with the filename extension .epr.

Delete custom presets

1 In the Export Settings dialog box, choose the custom preset you want to delete.

2 Do either of the following: 

• To delete a single preset, click the Delete Preset button .

• To delete all custom presets, Ctrl+Alt-click (Windows) or Command+Option-click (Mac OS) the Delete Preset 

button.

Working with cue points for FLV and F4V video files

With Adobe Media Encoder, you can embed cue points in video files for use in Flash Professional and Flash Player 

with ActionScript™ or the Flash FLVPlayback component. Each cue point consists of a name, the time at which it 

occurs in the video, type of cue point, and optional parameters. You specify cue point times using the format 

hour:minute:second:millisecond.

Event cue points are used to trigger ActionScript methods when the cue point is reached, and let you synchronize the 

video playback to other events within the Flash presentation.

Navigation cue points are used for navigation and seeking, and to trigger ActionScript methods when the cue point is 

reached. Embedding a navigation cue point inserts a keyframe at that point in the video.

Note that cue point metadata is stored differently in F4V and FLV file types. See Programming ActionScript 3.0 for 

information on the differences between cue points in F4V and FLV files, and how to use them in Flash Professional.

In addition to embedding cue points within the encoded FLV video file, you can create cue points using the 

FLVPlayback component. Using this component, you can create a cue point that is not embedded in the video file 

itself, providing greater flexibility in triggering events. For more information, see the information on the FLVPlayback 

component in the ActionScript Components Language Reference.

F4V files can contain cue points that are embedded in the data track of the F4V file itself, as well as in the form of XMP 

metadata.

To synchronize an action for a cue point in an F4V video file, you can retrieve the cue point data from the onXMPData 

callback functions and trigger the cue point using the Timer class in ActionScript 3.0. The onXMPData callback 

function receives information specific to XMP metadata that is embedded in the F4V video file. The XMP metadata 

includes cue points as well as other video metadata. XMP metadata is introduced with Flash Player 10 and supported 

by subsequent versions of Flash Player and Adobe AIR. For more information on onXMPData and F4V cue points, see 

Programming ActionScript 3.0.

Cue points can be added as markers in Adobe Premiere Pro and After Effects.
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Create a cue point

1 From the encoding queue, select an item in which you want to embed cue points.

2 If you haven’t specified encoding settings for the item, do so now. Verify that the format is set to FLV or F4V. You 

can only embed cue points in FLV or F4V files. To learn more, see “Encode and export video and audio” on page 11.

3 Choose Edit > Export Settings.

The cue point controls are located beneath the Source and Output panels on the left side of the Export Settings 

dialog box.

4 Move the current-time indicator to the time when you want to embed a cue point.

5 Click the (+) button at the top of the cue point controls.

Adobe Media Encoder embeds a cue point and populates the cue point list with a placeholder for the name of the 

new cue point and the time at which the cue point is located.

6 In the Type column, choose the type of cue point.

7 Enter parameters for the selected cue point. 

Parameters are a set of key-value pairs that you can add to the cue point. The parameters are passed to the cue point 

event handler as members of the single parameter object.

8 (Optional) To save the cue points that you’ve created so that you can apply them to other video clips, click the Save 

Cue Points button.

More Help topics 

“Key frames” on page 2

Remove a cue point

1 Select the cue point in the cue point list.

2 Click the Delete Cue Point button (-), or press the Delete key.

Load previously saved cue point data

1 Click the Load Cue Points button .

2 Select the cue point file you want to import, and click OK.

Note: When you load cue points from a file, any cue points you have created in the cue points list are replaced by the 

cue points in the file.

Adobe Soundbooth and the cue point XML file

Adobe Soundbooth™, a sound editing application, can import and export the cue point XML file. An advantage to 

creating the cue point XML file in Soundbooth is that its Video panel lets you play back video footage while editing 

sound. This lets you insert cue point markers using both the video and audio components of the file. When you are 

ready to encode the video using Adobe Media Encoder, you can import the cue point file from Soundbooth and use the 

cue points to encode the FLV file. To learn more about using Soundbooth to create cue points, and importing the cue 

points XML file into Adobe Media Encoder, see the information on working with Flash and video in Soundbooth Help.

Note: In Adobe Premiere Pro, cue points can also be added with the benefit of full A/V playback and complete transport 

controls. However, cue points imported or exported from an XML file are not supported.
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Cue point XML file

You can export cue points in an XML file so that you can apply it to other video files and share it across platforms. An 

example of the file is shown below:

 <?xml version="1.0" encoding="UTF-8"?>  
 <FLVCoreCuePoints>  
 <CuePoint>  
 <Time>2000</Time>  
 <Type>navigation</Type>  
 <Name>CuePoint1</Name>  
 <Parameters>  
 <Parameter>  
 <Name>CuePoint1</Name>  
 <Value>Introduction</Value>  
 </Parameter>  
 <Parameter>  
 <Name>Cast</Name>  
 <Value>ActorNames</Value>  
 </Parameter>  
 </Parameters>  
 </CuePoint>

Important: If you modify the cue point XML file and insert invalid values or otherwise malformed XML syntax, Adobe 

Media Encoder will not be able to load the file.

The DTD (Document Type Definition) for the cue point XML file is shown below. A DTD defines the valid document 

structure of the XML file, with a list of supported elements and their meaning within the XML file itself.

 <!DOCTYPE FLVCoreCuePoints [  
 <!ELEMENT FLVCoreCuePoints(CuePoint+)>  
 <!-- FLVCoreCuePoints is the root element in the XML file and must contain at least one CuePoint 
element -->  
 <!ELEMENT CuePoint(Time, Type, Name, Parameters?)>  
 <!-- CuePoint contains the data for a particular cue point, and must contain one each of  
 Time, Type, and Name elements, and may contain one Parameters element -->  
 <!ELEMENT Time(#CDATA)>  
 <!-- Time contains the cue point time as an integer in milliseconds -->  
 <!ELEMENT Type(#CDATA)>  
 <!-- Type contains the cue point type as a case-sensitive string, either "event" or "navigation" 
-->  
 <!ELEMENT Name(#CDATA)>  
 <!-- Name contains the cue point name as a text string; it can also contain a parameter name 
when appearing  
 inside a Parameter element -->  
 <!ELEMENT Parameters(Parameter+)>  
 <!-- Parameters contains the cue point's parameters. It must contain at least one Parameter 
element -->  
 <!ELEMENT Parameter(Name, Value)>  
 <!-- Parameter contains the data for one of a cue point's parameters. It must contain one each of  
 Name and Value elements -->  
 <!ELEMENT Value(#CDATA)>  
 <!-- Value contains the value-part of the name-value pair for a cue point parameter -->  
 ]>
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In addition to the restrictions enforced by the cue point XML DTD, the following characteristics apply to the XML 

format:

• All comments regarding the data inside the tags in the DTD will be enforced on read; non-compliant XML will 

result in an error.

• Cue points must appear in ascending time order within the XML file, and there can be only one cue point assigned 

at a given time.

• The XML format is written as UTF-8. Other encoding types are supported if they are properly declared via an XML 

declaration with encoding (for example, <?xml version="1.0" encoding="UTF-16"?> or a BOM marker in the file.

• The only types allowed are event and navigation.

• Time must be specified in milliseconds as an integer. You cannot use decimal points when specifying time (for 

example, 12.123 causes the XML file to fail). 

Log files

Encoding log file

The encoding log file is a plain-text file that contains a record of all files encoded, whether successfully completed or 

not. The encoding status of each file you encode is appended to the end of the file (placing the newest entry at the end 

of the file). The log file adds entries until you manually clear them. To clear log file entries, open the file in a text editor, 

select all of the entries, delete them, and save the empty file using the default filename (AMEEncodingLog.txt).

The log file is stored in the following location:

• Windows XP: C:\Documents and Settings\[user]\Application Data\Adobe\Adobe Media 

Encoder\5.0\AMEEncodingLog.txt

• Windows Vista: C:\Users\[user]\AppData\Roaming\Adobe\Adobe Media Encoder\5.0\AMEEncodingLog.txt

• Mac OS: Macintosh HD/Users/[user]/Library/Application Support/Adobe/Adobe Media 

Encoder/5.0/AMEEncodingLog.txt

To view the log file, choose File > Show Log.

There are two log files:

• AMEEncodingLog.txt: for successfully encoded jobs.

• AMEEncodingErrorLog.txt: for jobs that failed, or were stopped by the user.

Error log file

The error log file is stored in the following location:

• Windows XP: C:\Documents and Settings\[user]\Application Data\Adobe\Adobe Media 

Encoder\5.0\AMEEncodingErrorLog.txt

• Windows Vista: C:\Users\[user]\AppData\Roaming\Adobe\Adobe Media 

Encoder\5.0\AMEEncodingErrorLog.txt

• Mac OS: Macintosh HD/Users/[user]/Library/Application Support/Adobe/Adobe Media 

Encoder/5.0/AMEEncodingErrorLog.txt

To view the error log file, choose File > Show Errors.
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Note: In Adobe Media Encoder CS5.5, log files, and error log files are located in the same location as the Adobe Media 

Encoder CS5 files.

The media cache database

When Adobe Media Encoder imports video and audio in some formats, it processes and caches versions of these items 

that it can readily access. Imported audio files are each conformed to a new .cfa file, and MPEG files are indexed to a 

new .mpgindex file.

Note: When you first import a file, you may experience a delay while the media is being processed and cached.

A database retains links to each of the cached media files. This media cache database is shared with Adobe Media 

Encoder, Adobe Premiere Pro, Encore, After Effects, and Soundbooth, so each of these applications can each read from 

and write to the same set of cached media files. If you change the location of the database from within any of these 

applications, the location is updated for the other applications, too. Each application can use its own cache folder, but 

the same database keeps track of them all.

You can change the locations of the media cache database and the cached files using settings in the Media category of 

preferences. (See “Preferences” on page 5.)

To change the location of the media cache database or the media cache itself, click one of the Browse buttons in the 

Media preferences.

To remove conformed and indexed files from the cache and to remove their entries from the database, click Clean. 

This command only removes files associated with items for which the source file is no longer available.

Important: Before clicking the Clean button, make sure that any storage devices that contain your currently used source 

media are connected to your computer. If footage is determined to be missing because the storage device on which it is 

located is not connected, the associated files in the media cache will be removed. This removal results in the need to 

reconform or re-index the footage when you attempt to use the footage later.

Cleaning the database and cache with the Clean button does not remove files that are associated with footage items 

for which the source files are still available. To manually remove conformed files and index files, navigate to the media 

cache folder and delete the files. The location of the media cache folder is shown in the Media preferences. If the path is 

truncated, click the Browse button to show the path.
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