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Welcome to Pages

 

Pages is a streamlined, yet powerful word-
processing application you use to easily create 
great-looking documents, from a letter, flyer, or 
poster to a monthly newsletter or three-panel 
brochure. This preface provides an overview of the 
features of Pages and a list of resources for learning 
to use it.

 

Pages makes it easy to compose and design a variety of documents on your 
computer. With the Pages tools, you can easily change the layout and look of any 
document as you work. Present your data using any of the tables or charts built right 
into Pages. Incorporate a multitude of text and graphics types—you can even include 
movies and hyperlinks.

And when you’re ready to share your Pages document, it can be exported to several 
different file types, including HTML, PDF, and Microsoft Word.

 

Pages Features at a Glance

 

Use Pages templates, styles, and layout capabilities to create compelling documents 
and enjoy doing it.
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Media-Rich Templates

 

Using the templates that come with Pages, it’s easy to create professional-looking 
documents. You can even create your own templates to suit your specific needs.

Insert text callouts, tables, 
and other formatted 
elements on the fly.

Add graphics with 
drag-and-drop ease.

Insert multiple-column 
layouts.

Use the toolbar buttons 
to format pages and text 
as you type.
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Each template includes building blocks (known as sections) that help you build a full 
document. Choose from a selection of layouts, professionally designed for maximum 
visual impact. All the template components—text, images, tables, charts, and more—
are coordinated to ensure that your documents reflect a precise and professional 
image.

Pages comes with a large assortment of templates:  newsletters, journals, flyers and 
posters, invitations, stationery, resumes, business and creative templates, and 
templates to use for education and marketing documents. 

You can also use the designs and elements in these templates to enhance your 
documents by copying and pasting bullets, chart styles, and background images. Or 
you can create your own templates and share them with your colleagues.
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Styles Done Right

 

Just type into the templates and predefined, coordinated styles are automatically used 
to format paragraphs, characters, and numbered or bulleted lists. You can also select 
different styles, or create your own.

Use the Styles menu to apply 
consistent text formatting in 
your document.

Bring in photos from 
iPhoto using the 
Media Browser.
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Powerful Word Processing

 

Pages provides multiple-column layouts that flow from page to page as you type. It’s 
simple to set up a table of contents, footnotes, headers, footers, page numbers, and 
more for professional and academic reports.

Other word-processing features that save time include spelling corrections as you 
type, navigation using page thumbnails, importing and copying from Microsoft Word 
and AppleWorks, and finding all occurrences of a word or phrase in a document.

Create a table of contents 
that’s updated as you 
add content.

Create bulleted and 
numbered lists.

Style the TOC the 
way you want to.
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Easy-to-Use Media Tools

 

Find items you’ve stored in your iPhoto or iTunes Library, or in your Movies folder, and 
drag them right to a document.

When you add images, you can adjust brightness, contrast, exposure, saturation, hue, 
sharpness, and more right within Pages.

Select the album where 
your picture is located.

Choose iPhoto, iTunes, or 
Movies.

Drag a thumbnail to the 
document window.

Search for a file by name.
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Custom Shapes and Masks

 

Crop images by using masks of different shapes. Choose from the many predrawn 
shapes included with Pages, or create your own custom shape to use as a mask. 
Masking lets you reveal only the part of an image you want to show in a document, 
without altering the original file.

Create a custom mask to 
frame part of a photo.

Position the mask over 
the image, and then 
optionally edit the mask. 
Here, it’s rotated and 
resized.

The original image is 
framed by the mask.
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Realistic 3D Charts

 

Show off two-dimensional data in 3D-rendered bar, line, area, and pie charts. Choose 
realistic wood-grain, metal, and other life-like textures. Apply different lighting styles 
to create interesting shadows.

 

Tables With Calculations and Row Sorting

 

Automate calculations in any cell in a table using arithmetic formulas and values from 
other cells.

Sort cells in ascending or descending, numerical or alphabetical, order. Format 
numbers using currency formatting and dates with international standards.

This table, used in the 
Invoice template, uses 
formulas to automatically 
update cost when 
quantity or unit price 
changes.
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Documents Personalized With Address Book Data

 

Many Pages templates contain Address Book fields, which provide an automatic way 
to insert names, phone numbers, addresses—any data you’ve defined for contacts in 
Address Book—into a document. This capability lets you create a document, such as a 
letter or a contract, and reuse it for different individuals.

 

What’s New in Pages

 

With the enhancements to Pages in iWork ‘06, you can:

Â

 

Create documents using over 20 new templates.

 

Some of the templates take advantage of new features, such as masking with 
shapes and inserting your Address Book contact information as soon as you create a 
letter.

There are templates that help you create posters, flyers, an education scrapbook, 
storyboards, and newsletters. New business templates feature technical reports, 
proposals, meeting notes, brochures, even an expense report and invoice that 
automatically calculate costs.

Drag an Address Book 
contact to the field to 
personalize it.

Your My Card data from 
Address Book is inserted 
automatically.
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Â

 

Personalize documents using Address Book data.

 

You can quickly insert names, phone numbers, addresses—any data defined for 
contacts in Address Book—into a document. This feature, often referred to as 

 

mail 
merge

 

, offers an easy way to reuse documents, such as letters and contracts, for 
multiple individuals.

Â

 

Use tables to calculate and sort values, and display formatted numbers in cells.

 

You can add a formula to a table cell to derive and display a value based on 
numbers in other cells.

Row and column address tabs guide you as you create and edit formulas. Create 
formulas using a single click, or use the powerful Formula Editor to customize your 
formulas.

You can sort some or all of the rows in a table, in ascending or descending order, 
numerically or alphabetically.

Number formats let you tailor the way numbers are displayed in table cells. For 
example, you can apply a number format to cells that hold monetary values so that 
numbers are displayed with a currency symbol (such as $, £, or ¥) in front of them.

Â

 

Customize shapes and images to maximize their impact.

 

Use shapes to mask images (displaying them in polygons, circles, and more) or to 
create other interesting effects in a document.

Pages comes with many predrawn shapes, but you can use the shape editing tools 
to create your own custom shapes. These tools also make it easy to experiment with 
varying the contours and segments of any shape.

You can improve the quality of an image or create interesting effects by adjusting 
brightness, contrast, sharpness, and more.

Â

 

Display data in 3D charts and scatter charts.

 

Almost all charts can be rendered as 3D charts. Now you can display your data in 3D 
bar charts, 3D pie charts, and more, using 3D controls that give you precise control 
over angles and lighting effects.

Scatter charts can be used to show scientific and research data.
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Â

 

Associate comments with text, images, and other objects in your document.

 

Comments are an electronic way to “write in the margin” of a document.

Comments let you make annotations that relate to particular parts of a document 
without actually changing the body of the document. They’re useful for making 
notes to yourself, asking questions of reviewers, conveying editorial suggestions, 
and so on.

Â

 

Navigate through and manage parts of a document using page thumbnails.

 

You can view miniature versions (thumbnails) of all the pages in a document, 
displayed along the side of the document. The thumbnail view offers a quick way to 
go to a specific page and to work with sections in the document. (A section is a 
group of one or more pages that have the same layout, numbering, and other 
document attributes. A chapter is an example of a section.)

Â

 

Use automatic text correction.

 

Automatic text correction lets you fix typos as you work, or automatically replace 
text you type with other text.

You can have Pages automatically change quotes into smart quotes, correct 
common spelling mistakes (replace “teh” with “the”), change (c) to ©, and so on. You 
can also make sure that sentences start with a capital letter, and that email and web 
addresses you type automatically become hyperlinks for Mail or Safari.

Â

 

List all occurrences of a word or phrase in a document at once.

 

You can generate a list of all occurrences of a specific word or phrase in your 
document. If you select an occurrence in the list, the page containing the matching 
text is displayed in the main viewing area. To edit the text, just press Return.

Â

 

Add endnotes to a document.

 

Instead of using footnotes, which are printed at the bottom of a page, you can use 
endnotes. Place endnotes at the end of your document, or at the end of each 
section in your document.
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How to Use Menus

 

To complete many of the tasks in this book (and in Pages Help), you use menu 
commands. The instructions look like this: 

m

 

Choose View > Zoom > Actual Size.

The first term after 

 

Choose

 

 is the menu you click; the next term is the item you choose 
from that menu, and so on, as shown below.

 

Resources for Learning More

 

To get the most from Pages, consult these resources:

User’s Guide
The chapters in this full-color PDF document describe the features of Pages and 
provide easy-to-follow instructions for using Pages. 

Chapter 1 of the guide describes the tools available in Pages, and Chapter 2 shows 
you a step-by-step workflow for creating a document. Remaining chapters provide 
detailed instructions for formatting text, working with styles, creating tables, and so 
on.
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Onscreen Help
To access help from within Pages, choose Help > Pages Help. You can browse through 
the table of contents to find a specific topic, or enter a question in the search field to 
find an answer about how to accomplish a specific task.

You can add the Help button to the Pages toolbar to make Pages Help available in a 
single click. To learn about customizing the toolbar, see “The Toolbar” on page 30.

Help tags are also available for many onscreen items. To see a help tag, let the pointer 
rest over an item for a few seconds.

Pages Tour
For an onscreen demonstration of what you can do with Pages, view the tour.

To see the onscreen tour:
m Choose Help > iWork Tour, and then follow the onscreen instructions.

Web Resources
You can access additional information about Pages on the web.

To access web-based information about Pages:
1 Choose Help > Pages Help.

2 Click a link in the “On the Web” section at the bottom of the main help access page to 
view hot tips, product news, technical articles, and more.

Technical Support
A variety of support options are available to Pages users. For more information, see 
the AppleCare Software Service and Support Guide that comes with your Pages 
documentation or visit www.apple.com/support/pages/ on the web.

To display a help tag, rest 
the pointer over an item.
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1 Overview of Pages

This chapter introduces you to the windows and 
tools you’ll use in Pages.
When you create a Pages document, you must first select a template to start from. 
Pick the one that best fits your purpose and design goals. If you want to start from a 
plain document, without a lot of preformatting, use the Blank template.

You can drag or place objects on a page, including imported graphics, movies, and 
sound, or text boxes, charts, tables, and shapes that you create within Pages. New 
pages are added automatically as you type into your document. You can also add pre-
formatted pages, before or after existing pages, by selecting from those available in 
each template. For more information about this, see “Expanding Your Document” on 
page 37.

In Pages templates, pages contain text and image placeholders, which demonstrate 
the look of the finished document. You can replace the placeholder text with your 
own text by just typing. You can replace placeholder images by dragging an image to 
the placeholder. For more information about working with placeholder text and 
images, see “Step 3:  Add Text” on page 38, and “Step 6:  Save and Share Your 
Document” on page 56.

Using Pages Templates
When you first open the Pages application, the Template Chooser presents a variety of 
document types from which to choose. Select the template you want to use, and then 
click Choose.

A new template contains placeholder text, placeholder images, and other items, 
which represent elements of the finished document.
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Placeholder Text
If you click placeholder text, the entire text area is selected. When you begin typing, 
the placeholder text disappears and is replaced by what you type.

Image Placeholders
Similar to placeholder text, image placeholders indicate the size and placement of 
graphics in a template. Drag your own image to a placeholder to replace it.

Customize the toolbar to 
include the tools you use 
most often.

Placeholder text indicates 
where you can type new 
text, and how your text will 
look on the page.

Image placeholders indicate 
the size and placement of 
graphics in a document 
template.

The Page View control lets you 
zoom in or out so you can see 
your document larger or 
smaller on the screen.

Address Book fields let you 
personalize documents with 
Address Book data.
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Address Book Fields
Address Book fields let you easily insert names, phone numbers, addresses—any data 
you’ve defined for contacts in Address Book—into Pages documents. This capability 
lets you reuse a document, such as a letter or contract, for multiple people by 
inserting person-specific data into Address Book fields in the document. 

Master Objects
Some graphics, such as watermarks or logos, appear on every page. These objects are 
called “master objects.” If you cannot select an object in a template, it’s probably a 
master object. To learn more, see “Adding a Repeated Background Image” on page 75.

The Blank Document Template
If you want to create a document but not use a template that’s designed for a specific 
purpose, you can create a blank document by using the Blank template. Select Blank 
in the Template Chooser, click Choose, and just begin typing.

Changing the Document’s Onscreen Appearance
As you work on your document, you may want to zoom in or out to get a better view 
of what you are doing, or use other techniques for viewing your document.

Zoom Levels
To zoom in or out of the document, do one of the following:
Â Choose View > Zoom > [zoom level].

Â Click the Page View control in the bottom-left corner of the window, and choose a 
magnification level from the pop-up menu.
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You can set the zoom level used when you open a document by choosing Pages > 
Preferences, clicking General, and choosing a zoom level from the Default Zoom pop-
up menu.

Document Page Views
To choose a way to view document pages in the Pages window:

1 Click the Page View control in the bottom-left corner of the window.

2 Choose one of the page view options:

Â One Up presents the pages above and below each other.

Â Two Up presents two pages side-by-side on the screen.

Â Fit Width scales the document to the width of the window. You can stretch the 
Pages window to fill your screen, or make it short or narrow.

Â Fit Page causes a single document page to fill the window.

Layout View
In layout view you can see the outlines of the different text areas of your document, 
including headers, footers, fixed text boxes, column widths, and the document body—
the main area of text in the document. With layout view turned on, document rulers 
and alignment guides become visible. See “Rulers and Alignment Guides” on page 26.

To see layout view:
m Click View in the toolbar and choose Show Layout (or choose View > Show Layout).

When you type in the document body, the text automatically flows onto the next 
page. Other text areas, such as text boxes, do not expand; they remain a fixed size and 
width.

In the following example, you can see the page layout includes two columns at the 
top, two layout breaks, and then three columns, an inline image, and the footer area.
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A layout is part of a document in which you have defined layout margins and 
columns. As the example above illustrates, you can have multiple layouts on a single 
page. A layout break ends one layout and starts a new one with a different number of 
columns. See “Varying Column and Page Layouts” on page 64 for details.

The example above shows an inline image. An inline image is an image placed so that 
it’s anchored to text. An inline image moves with the text around it. There’s a second 
kind of image—a fixed image. A fixed image stays where you place it on a page. Text 
flows around a fixed image as you type. To learn how to place images so that they’re 
inline or fixed, see “Adding Images, Movies, and Sound Files Elsewhere in Your 
Document” on page 42.

Two text columns

An inline image

Three text columns

Layout break

Footers
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Formatting Characters (Invisibles)
As you work in a Pages document, you may want to see the marks that indicate 
character spaces, paragraph breaks, section breaks, or other types of invisible 
elements so that you can check the formatting of your document. In Pages, these 
formatting marks are called invisibles.

To see invisibles:
m Click View in the toolbar and choose Show Invisibles (or choose View > Show 

Invisibles).

The table below shows what each formatting character represents.

Invisible characters

  Space

  
Non-breaking space (Option-Space bar)

Tab

Line break (Shift-Return)

Paragraph break (Return)

Page break

Column break (page 64)

Layout break (page 65)

Section break (page 72)

Anchor point (for inline objects with text wrapping)
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To change the color of invisibles so that they stand out:
m Choose Pages > Preferences, click General, click the Invisibles color box, and then 

select a color.

Rulers and Alignment Guides
As you move fixed graphics and other objects around in a document, alignment 
guides automatically appear to help you position the object on the page. You can also 
use the document rulers or create static alignment guides that remain on the page to 
mark the positions of different objects. To learn how to customize the behavior of 
alignment guides, see “Alignment Guides” on page 45.

You can also use rulers to help place objects precisely on a page, and you can use the 
horizontal ruler to set tab stops, page margins, and column widths. For more 
information about tab stops, page margins, and columns, see “Setting Tab Stops to 
Align Text” on page 92, “Setting Page Margins” on page 61, and “Creating Columns” on 
page 62. You can change units of measure that appear on the rulers to inches, 
centimeters, points, or picas in Pages preferences.

You can also turn on rulers without the other layout elements.

Rulers help you set 
margins and tabs where 
you want them. 

Alignment guides help you 
precisely position objects on 
the page. (Here the 
alignment guides are blue.)

Blue icons on the top ruler 
indicate text indents and 
tab settings. Drag them to 
reset the position of text.

Gray rectangles below 
the rulers indicate 
column margins. Drag 
them to change the 
column gutter widths.
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To make rulers visible without other layout elements:
m Click View in the toolbar and choose Show Rulers (or choose View > Show Rulers or 

press Command-R).

To change the ruler values:
m Choose Pages > Preferences, click General, and choose a unit of measure from the 

Ruler Units pop-up menu.

The Styles Drawer
As you create a document, you may want to use a certain text style for every chapter 
title, heading, bulleted list, and body text paragraph. Each template comes with a 
library of preset styles that you can choose from. The Styles drawer lists and provides a 
preview of all the text styles in the template you are using, so you can create, 
customize, and manage them easily.
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To open the Styles drawer:
m Click View in the toolbar and choose Show Styles Drawer (or choose View > Show 

Styles Drawer).

The Font Panel
Pages uses the Mac OS X Font panel, so you can use any of the fonts on your 
computer in your documents.

To open the Font panel:
m Click Fonts in the toolbar (or choose Format > Font > Show Fonts).

Select a paragraph style 
to apply it to selected 
paragraphs or the 
paragraph that contains 
the cursor.

Select a character style to 
apply it to selected text 
or the word that contains 
the cursor.

Select a list style to apply 
it to selected paragraph 
text or the paragraph 
that contains the cursor.

Click to show and hide list and 
character styles in the drawer.

Press and hold, and then 
choose an option to 
create a new style.
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Use the Font panel to select fonts, font sizes, and other font formatting features, 
including text shadows and strikethrough. For more detailed information about using 
the Font panel and changing the look of text, see Chapter 4, “Formatting Text and 
Paragraphs.”

The Colors Window
You use the Mac OS X Colors window to choose colors for text, drawn objects, or 
shadows.

To open the Colors window:
m Click Colors in the toolbar (or choose View > Show Colors).

For more information about using the Colors window to set the color of lines, text, 
and shapes, see “Using Color and Image Fills” on page 145.

The Inspector Window
The Inspector window puts formatting tools at your fingertips as you work. You can 
format most elements of your document using the ten panes of the Inspector 
window, including document layout, text appearance, size and positioning of 
graphics, and much more.

Open multiple Inspector windows to make working with your document easier. For 
example, if you have a Graphic Inspector window and a Text Inspector window open, 
you’ll have all the text and image formatting options at your fingertips as you work.

To open an Inspector window:
m Click Inspector in the toolbar (or choose View > Show Inspector). 

The buttons at the top of the 
Inspector window open the ten 
Inspectors:  Document, Layout, 
Wrap, Text, Graphic, Metrics, Table, 
Chart, Link, and QuickTime.
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Click one of the buttons at the top to display its Inspector. Hover the pointer over a 
button to display its name. Clicking the fourth button from the left, for example, 
displays the Text Inspector. You can have several Inspector windows open at the same 
time.

To open another Inspector window:
m Press the Option key while clicking an Inspector button (or choose View > New 

Inspector).

The Toolbar
The Pages toolbar gives you one-click access to many of the actions you’ll use when 
creating documents in Pages. As you work in Pages and get to know which 
commands you use most often, you can add, remove, and rearrange toolbar buttons 
to suit your working style.

The default set of toolbar buttons is shown below.

To customize the toolbar:
1 Choose View > Customize Toolbar.

2 Perform one or more of the following actions:

Â To add an item to the toolbar, drag its icon to the toolbar at the top.

Â To remove an item from the toolbar, drag it out of the toolbar.

Add text boxes, shapes, 
tables, and charts.

Create column layouts 
on the fly.

Apply styles to text 
and lists.

Add a comment for 
selected text or object.

Show thumbnails, comments, 
the Styles drawer, rulers, 
invisibles, and more.

Add pre-formatted pages 
to your document.

Open the Inspector window, 
Media Browser, Adjust Image 
window, Colors window, and 
Font panel.
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Â To rearrange items in the toolbar, drag them.

Â To make the toolbar icons smaller, select Use Small Size.

Â To display only icons or only text, choose an option from the Show pop-up menu.

If you frequently reconfigure the toolbar, you can add the Customize button to it.

Note:  You can restore the default set of toolbar buttons by dragging the default set to 
the toolbar. To learn what a button in the Customize dialog does, drag it to the toolbar 
and then hold the pointer over it until a help tag appears.

Moving Around Within a Document
You can use the scroll bars, Previous Page and Next Page buttons, and page 
thumbnails to move around a document.
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To navigate through a document:
m To move forward or back in small increments, click the scroll arrows.

m To scroll quickly, drag the vertical scroller up or down, or the horizontal scroller from 
left to right.

m To move forward or back one page at a time, click the Previous Page and Next Page 
arrows at the bottom of the document window.

m Click View in the toolbar and choose Show Page Thumbnails (or choose View > Show 
Page Thumbnails). Then click in the thumbnail view to go to a particular page. See 
“Using Thumbnails” on page 48 for more information about what you can do with 
thumbnails.

Drag the vertical 
scroller to quickly 
scroll up and down.

Click the scroll arrows 
to move forward or 
back in small 
increments.

Click the Previous Page
or Next Page arrows to

move forward or back a
page at a time.

Drag the horizontal 
scroller to scroll left 
and right.

Click a thumbnail to 
display a particular page.
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Shortcuts
You can use the keyboard to perform many of the Pages menu commands and tasks. 
A comprehensive list of keyboard shortcuts is available in onscreen help.

To see the list of keyboard shortcuts:
m In Pages, choose Help > Keyboard Shortcuts.

Many commands are also available in shortcut menus that you can access directly 
from the object you are working with.

To open a shortcut menu:
m Press the Control key while you click an object.

Shortcut menus are especially useful for working with tables and charts.
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2 Creating a Document Using 
the Pages Templates

This chapter provides a step-by-step workflow for 
creating a document, and tells you where to find 
detailed instructions for formatting text, working 
with styles, creating tables, and so on in subsequent 
chapters.
Before you begin creating a new Pages document, spend a little time thinking about 
its design requirements.  

Step 1:  Think About Your Document’s Design 
Requirements
Document layout and style, the appearance of text, and the use of graphics and other 
media all play a role in a document’s effectiveness. Browse through the information in 
this step to learn about the options that Pages offers in these areas. When you’re 
ready to begin working with an actual Pages document, go to “Step 2:  Create a New 
Document” on page 36.

Importing a Microsoft Word or AppleWorks Document
If you already have a document that you created in Microsoft Word or AppleWorks, 
you can import it into Pages and continue to work on it. Simply drag the Microsoft 
Word or AppleWorks document icon onto the Pages application icon. For more 
information, see “Importing Files Into Your Pages Document” on page 41.

You can also export Pages documents to Microsoft Word, PDF, Rich Text Format 
(RTF), and simple HTML, and you can save documents so they can be opened using 
Pages in iWork ‘05. For more information, see “Exporting to Other Document 
Formats” on page 231.
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Document Layout and Style
Think about how you want the document to appear as a whole, including how it’s laid 
out and how it uses space. Most of these decisions are addressed in Chapter 3, 
“Formatting a Document’s Layout and Table of Contents.”

Â What type of document are you creating and which template most closely matches 
the layout you need?

Â Does the document need a landscape or portrait page orientation? Make sure to set 
this option in the Page Setup dialog before you begin. See “Setting Page Orientation 
and Size” on page 61.

Â If you are designing a unique page layout, are the document margins set the way 
you need? See “Setting Page Margins” on page 61.

Â Will the document be divided into sections with different layouts, page numbering, 
headers and footers, or design elements? See “Varying Document Formatting Using 
Section Breaks” on page 72.

Â Will the document be bound? If so, be aware of how the page numbers, margins, 
and section breaks will fall on the right- and left-facing pages of your document. See 
“Creating a Document With Left- and Right-Facing Pages” on page 66.

Â Does the document layout require columns? See “Creating Columns” on page 62.

Â Will the document require a table of contents? If so, make sure to use consistent 
heading styles throughout the document. See “Using a Table of Contents” on 
page 76.

Appearance of Text
Consider how text will be used in your document to emphasize the organization of 
content and to create a compelling design. Most of these decisions are addressed in 
Chapter 4, “Formatting Text and Paragraphs.”

Â Which fonts will you use in the document?

Â Are there heading styles or fonts that you would like to use consistently throughout 
the document? See Chapter 5, “Working With Styles.”

Â What shape or image would you like to use for bullets? What number styles for 
outlines? See “Creating Bulleted or Numbered Lists and Outlines” on page 96.

Â Will you make use of callouts, sidebars, or other highlighted text in your document? 
See “Creating Callouts, Sidebars, and Highlighted Text” on page 99.
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Graphics and Other Media
Think about how you will use graphical elements in your document, where they will 
appear in the document flow, and what kinds of graphics you might use. 

Â How will images be used in your document?

Â Can you use tables to clearly present information? See Chapter 8, “Creating Tables.”

Â Can you use charts to effectively display data? See Chapter 9, “Creating Charts.”

Â What will be the final format for your document (printed page, HTML, and so on)? 
See “Exporting to Other Document Formats” on page 231.

Â Will you make use of sound or movies in your document? See “Including Sound and 
Movies” on page 139.

Learn about other uses of graphics in Chapter 6, “Working With Graphics and Other 
Media.”

Step 2:  Create a New Document
To start a new Pages document, double-click the Pages icon in the Finder.

Choosing a Template
By using a template, you can easily create a professional-looking document, such as a 
school report, business letter, newsletter, or brochure, without having to do all the 
design work. Each template includes preset styles for titles, headings, tables, 
footnotes, bullets, and other formatting features. 

In the Template Chooser, select a template category in the left column to display 
related templates, and then select the template that best matches the document you 
want to create. If you want to begin in a document without any text or image 
placeholders, select Blank.
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When you have selected a template, a new document opens on your screen.

If you don’t see the Template Chooser when you first open Pages, you can make it 
appear by setting a preference in Pages preferences. Alternatively, you can set Pages 
to automatically open a Blank document or the document template of your choice 
every time you open it.

To make the Template Chooser always appear when you open Pages:
m Choose Pages > Preferences, click General, and then select “For New 

Documents:  Show Template Chooser dialog.”

To always open the same kind of document when you open Pages:
m Choose Pages > Preferences, click General, and select “For New Documents:  Use 

template:  [template name],” and then click Choose. Select a template name, and then 
click Choose.

Expanding Your Document
Each page of a Pages template has a unique design. You can choose to use the page 
designs that are previewed when the document first opens. Or, if the page designs 
don’t meet your needs, you can choose from additional designs that fit the template.
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To add an additional template page following the current page:
m Click Pages in the toolbar and choose a template page (or choose Insert > Pages > 

[template page]).

The new page is added immediately after the page where you placed the insertion 
point.

Step 3:  Add Text
If you start with a blank document, you can just start typing. As you type, the text fills 
the page. As each page is filled, the text automatically flows to the next page.

If you are working with a template that includes text or image placeholders or 
Address Book fields, you can add your own information to the placeholder areas or 
Address Book fields.

Additional pages:
Choose a page from the 
Pages pop-up menu.
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Adding Text to Placeholder Text Areas
Templates contain placeholder text, which shows you what text will look like and 
where it will be placed in the finished document. Placeholder text can be Latin text in 
the document body, text boxes, headers, and elsewhere, or other predefined text, 
such as Education Newsletter.

Main Text Areas
When you click placeholder text in a document template, the entire text area is 
highlighted.

When you type, the placeholder text disappears and is replaced by whatever text you 
are typing. The text you type behaves like regular text.

Text Boxes
Some placeholder text is contained in text boxes or table cells to preserve formatting. 
When you click placeholder text that’s in a text box, a rectangular, gray border 
appears around it when layout view is turned on.

To select the placeholder text inside a text box:
m Click once to select the text box, and then double-click to select the text inside the 

box.

Placeholder text:
The entire text area is 
selected when you click.
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To learn how to change the look of text boxes, see “Creating Callouts, Sidebars, and 
Highlighted Text” on page 99.

Tables
Some tables contain placeholder text. When you select text that’s inside a table cell, a 
yellow rectangle appears around it.

To select the placeholder text inside a table:
m Click once to select the table, and then double-click to select an individual cell and its 

placeholder text.

The text inside the cell is selected for editing when you select the individual cell. You 
can tell it’s placeholder text if it is highlighted blue; otherwise, it’s regular text.

Important:  Text boxes and tables that contain placeholder text are part of the 
template’s default design. To preserve the design, be careful not to press Delete after 
you select the text box or table. Pressing Delete will remove the selected object from 
the page. If you accidentally delete a text box or table, you can immediately recover it 
by choosing Edit > Undo Delete (or pressing Command-Z). In general, if you make a 
mistake or change your mind about something you’ve done, you can immediately 
undo your last actions by using the Undo command.

Columns
Occasionally, templates may contain placeholder text formatted in columns. It may be 
easier to work with text columns if the document layout is visible, but you can also 
hide the layout to see how the finished document will appear.

To show or hide the document layout:
m Click View in the toolbar and choose Show Layout or Hide Layout (or choose View > 

Show Layout or Hide Layout).

It may also help to see other formatting characters (invisibles) as you work, such as 
tabs and paragraph breaks.

Individual table cell 
selected for editing
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To show or hide invisibles:
m Click View in the toolbar and choose Show Invisibles or Hide Invisibles (or choose View 

> Show Invisibles or Hide Invisibles).

Adding Address Book Data
Many of the Pages templates, such as letters and envelopes, include Address Book 
fields that let you personalize documents using contact information you store in 
Address Book.

There are two kinds of Address Book fields:  sender fields and recipient fields. Sender 
fields display information about a document’s distributor, such as a company or 
personal name; sender fields are automatically replaced with any available data from 
your My Card in Address Book. Recipient fields display information for a person who 
will receive the document.

To insert recipient data for one contact:
1 Open a document template that contains recipient fields.

2 Select the contact’s Address Book card and drag it to a recipient field. The card’s data 
appears in all recipient fields in the document. 

3 Save or print the document if desired.

4 To reuse the document with another contact’s data, select another card and drag it to 
a recipient field. The new data replaces the recipient data inserted in step 2. 

Chapter 10, “Personalizing Documents With Address Book Data,” on page 219 provides 
instructions for working with Address Book data, including using Address Book groups 
to personalize a document for multiple recipients in a single pass.

Importing Files Into Your Pages Document
In your Pages document, you can incorporate documents and media files that were 
created using other applications.

To import a document:
m Drag a document created using Microsoft Word or AppleWorks to the Pages 

application icon. A new Pages document opens, and the contents of the imported 
document are displayed.
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From Microsoft Word, you can import styles, tables (including formulas), inline and 
fixed objects, charts, footnotes and endnotes, bookmarks, hyperlinks, lists, sections, 
and more.

From AppleWorks, you can import lists, tables, spreadsheets, charts, inline and fixed 
objects, footnotes and endnotes, bookmarks, hyperlinks, and more.

To import a media file:
m Drag the image, music, or movie file from the Finder or the Pages Media Browser 

(choose View > Show Media Browser) to an open Pages document. See “Using the 
Media Browser” on page 131 for instructions.

Imported media files can include images (such as those that iPhoto supports), PDF 
files, QuickTime movies, or Flash animations.

Step 4:  Add Graphics and Other Media
You can use a variety of media types in a Pages document, including still images, 
movies, sound, drawn shapes, charts, and tables. Movies and sound can be useful if 
you intend your final document to be viewed onscreen in HTML format or as a Pages 
file. For a more complete list of the file types that Pages can accept, see Chapter 6, 
“Working With Graphics and Other Media.”

Placing Images in Image Placeholders
The images you see in Pages templates are image placeholders. They represent the 
size and placement for images that you will add to your document. You can recognize 
an image placeholder by letting your pointer rest over it; a help tag appears 
instructing you to drag your own image into its place.

To replace an image in an image placeholder:
m Drag the image from the Media Browser or Finder to the image placeholder.

Adding Images, Movies, and Sound Files Elsewhere in Your Document
You can add images, movies, or sound files to your Pages document by simply 
dragging them from the Finder to the document window, or by dragging them from 
the Media Browser. The Media Browser displays images that are stored in your iPhoto 
library, sound files that are stored in your iTunes library, and movies that are located in 
the Movies folder in your home folder.
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Note:  Some media files are protected under copyright law. And some downloaded 
music may be played only on the computer where the download occurred. Make sure 
you have permission to use the files you want to add.

To open the Media Browser:
m Click Media in the toolbar (or choose View > Show Media Browser), then choose 

iPhoto, iTunes, or Movies to display the kind of files you want to use.

When you add an object to your document, you can either place it in a fixed position 
on the page (called a fixed object), so that the text flows around it as you type; or 
anchor it to the text (called an inline object), so that it moves with the text around it. If 
you create a fixed object, you can adjust how tightly you want the text to flow around 
it by adjusting the text wrap. To learn more about fixed versus inline objects, see 
“Fixed Objects Versus Inline Objects” on page 124. For more information about text 
wrapping, see “Wrapping Text Around an Object” on page 136.

To add an image inline with the text:
m Place the insertion point where you want the image to appear, and then choose Insert 

> Choose. Select the graphics file and click Insert.

m Command-drag an image from the iPhoto pane of the Media Browser to where you 
want it to appear in the text flow. As you drag the image over the text, the insertion 
point indicates where the image will appear if you drop it.

m Command-drag an image from the Finder to where you want it to appear in the text 
flow. As you drag the image over the text, the insertion point indicates where the 
image will appear if you drop it.

To add a fixed image:
m Click outside the text areas in the document so that no insertion point is visible, 

choose Insert > Choose, and then select the graphics file and click Insert.

m Drag an image from the iPhoto pane of the Media Browser to the document and 
position it where you want it.

m Drag an image from the Finder to the document and position it where you want it.

To change an image from fixed to inline or vice versa:
1 Click Inspector in the toolbar, and click the Wrap Inspector button.

2 Select “Moves with text” to make the image inline. Select “Fixed on page” to make the 
image fixed.
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Images can be cropped, resized, and rotated. Fixed images can be grouped, which 
makes it easy to reposition and resize several graphics that you want to keep together. 
You can also layer graphics, adjust their opacity, and add shadows to create 
interesting visual effects. Images can also be masked (cropped) so that only part of 
the image is visible on the page. For more information about working with images, 
see Chapter 6, “Working With Graphics and Other Media.” To learn about adjusting 
shadows and opacity, see Chapter 7, “Changing Object Properties.”

To learn about adding shapes, tables, and charts, see “Adding Shapes, Tables, and 
Charts” on page 125.

Adding Web and Email Addresses
You can create active hyperlinks to web addresses (URLs) and email addresses. When 
you click a web link, it opens a web browser and displays the webpage you specify. 
When you click an email address, it opens an email program and creates a new email 
message. You can also create bookmarks that let you jump to a specific word or phrase 
in your document. For specific instructions about creating hyperlinks and bookmarks, 
see “Adding Hyperlinks and Bookmarks” on page 141.

Positioning Text and Graphics
Pages provides several tools to help you position text, images, and other objects on 
the page, so you can achieve the design you want. Alignment guides appear in some 
templates—or you can create your own—to align fixed objects anywhere on a page. 
Rulers display page measurements in inches, centimeters, points, or picas, so you can 
easily tell where you are placing an object.

Pages also displays position tags that indicate the X and Y coordinates of an object’s 
top-left corner as you move the object around the page, or the object’s angle as you 
rotate it. When you resize an object, size tags appear, displaying the object’s height 
and width.

Rulers
You can show rulers to help you position objects on the page. Rulers indicate how far 
an object is from the top of the page and the left edge of the page.

To show rulers:
m Click View in the toolbar and choose Show Rulers (or choose View > Show Rulers).



Chapter 2    Creating a Document Using the Pages Templates 45

 

To change the units of measure in the rulers:
1 Choose Pages > Preferences, and click General.

2 Choose an item from the Ruler Units pop-up menu. To display measurements as a 
percentage of the distance across the page, select “Display ruler units as percentage.”

To place the ruler’s horizontal origin point at the center of the page:
m In Pages preferences, click General and select “Place origin at center of ruler.”

When you change ruler settings in Pages preferences, the new settings apply to all 
documents viewed in Pages, until you change the settings again.

Alignment Guides
As you move fixed text boxes and graphics around in the document, blue alignment 
guides appear to help you center and align objects on the page. They appear 
whenever the center or edge of an object aligns with the center or edge of another 
object, or with the center of the page, depending upon your preferences. You can 
create your own alignment guides to help you align objects precisely on a page. 
Alignment guides (even those you create) don’t appear when you print your 
document; they are visible only when you are editing a document.

To place alignment guides on a page:
1 Click View in the toolbar and choose Show Rulers (or choose View > Show Rulers) to 

make the rulers appear at the top and left side of the page.

2 Click outside any areas of the page so that the insertion point is not visible.

3 Place the pointer over a ruler and drag onto the page. A blue alignment guide 
appears.

4 Drag the guide wherever you want it on the page.

To remove alignment guides that you have placed on a page:
m Drag the alignment guide off the edge of the page.

If alignment guides are getting in the way as you work, you can temporarily hide 
them.

To temporarily hide alignment guides:
m Start dragging an object, and then hold down the Command key while dragging.
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You can turn alignment guides and size and position tags on or off in Pages 
preferences. You can also make alignment guides appear only when object edges are 
aligned, or only when object centers are aligned.

When you change alignment guide and tag settings in Pages preferences, the new 
settings apply to all documents viewed in Pages, until you change the settings again.

To change the behavior of alignment guides and tags displayed when you move 
objects:

1 Choose Pages > Preferences, and click General.

2 To turn off size and position tags, deselect “Editing:  Show size and position when 
moving objects.”

3 To turn off the guides that appear when an object’s center aligns with another object 
or the center of the page, deselect “Alignment Guides:  Show guides at object center.”

4 To turn on the alignment guides that appear when an object’s edges align with 
another object or the center of the page, select “Alignment Guides:  Show guides at 
object edges.”

To change the color of alignment guides:
m In Pages preferences, click General, click the Alignment Guides color well, and select a 

color in the Colors window.

Locking Graphics to the Page
After you’ve placed graphics exactly where you want them on the page, you can lock 
them to that position to prevent them from being moved accidentally as you work.

To lock a graphic to its position on the page:
m Select the graphic and choose Arrange > Lock.

You cannot modify a graphic that has been locked to its position on the page. To 
unlock a graphic, choose Arrange > Unlock.

Step 5:  Edit Your Document
After you’ve typed some text in your document, you may want to delete or rearrange 
(copy and paste) parts of it, check your spelling, find and replace specific words or 
phrases with new text, or use comments to make notes to yourself or collect 
information from readers.
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Checking Spelling 
Pages uses the Mac OS X spell-checker to catch spelling errors in your document. You 
can set the spell-checker to flag spelling errors as you type, or you can check your 
entire document or selected text at any time.

To flag misspelled words as you type:
m Choose Edit > Spelling > Check Spelling as You Type.

As you type, misspelled words appear with a red dashed line below them. If you’re not 
sure how to spell the word, you can see a list of possible spellings.

To get a list of spelling suggestions:
1 Hold down the Control key and click the misspelled word. A list of optional spellings 

appears (a word may generate no optional spellings if it cannot be recognized at all).

2 Choose the correct spelling if you see it in the list.

If you know you have spelled the word correctly, and you want to add it to the 
spelling dictionary used for all documents, choose Learn Spelling from the pop-up list.

If you don’t want this word to be flagged as misspelled, and you don’t want to add it 
to the spelling dictionary used for all documents, choose Ignore Spelling from the 
pop-up list. Ignore Spelling works only in the current document until you close it.

After you correct the misspelled word, the red line disappears.

To turn the spell-checker off:
m Choose Edit > Spelling > Check Spelling as You Type to deselect it (make sure the 

checkmark is not visible next to the menu command).

To check spelling in your document one word at a time:
m Place the cursor in a word you want to check, or anywhere in the document, and then 

do one of the following:

Â Choose Edit > Spelling > Check Spelling.

The spell-checker begins checking the spelling of each word in your document, 
beginning wherever you placed your cursor. The first misspelled word found is 
highlighted. You can correct it or choose the same menu command again, to 
continue checking the document. To go through the document more quickly, press 
Command-semicolon (;) to continue checking the document.
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Â Choose Edit > Spelling > Spelling.

The Spelling window opens with a list of suggested spellings. If you don’t see any 
that look correct, you can retype the word using a different spelling and click Guess 
to see a new list of suggestions. Select one and click Correct to apply it to the 
misspelled word. Click Find Next to go to the next misspelled word.

Deleting, Copying, and Pasting Text
If you want to copy or move a chunk of text from one part of the document to 
another, the easiest way to do this is to copy it (or cut it) from its original location, and 
then paste it in the new location. If you copy text, you will not delete it from its 
original location; if you cut text, it will be deleted from its original location.

To copy (or cut) and paste text:
1 Select the text you want to copy or move.

2 Choose Edit > Cut or Copy.

3 Place the text cursor in the location where you want to move the text, then do one of 
the following:

Â Choose Edit > Paste to maintain the original formatting of the pasted text.

Â Choose Edit > Paste and Match Style to change the formatting of the pasted text to 
match the formatting of the text around it.

To completely delete selected text:
m Choose Edit > Delete.

Using Thumbnails
You can view miniature versions (thumbnails) of all the pages in a document. 
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The thumbnail view offers a quick way to go to a specific page and to work with 
sections in the document. A section is a group of one or more pages that have the 
same layout, numbering, and other document attributes. See “Varying Document 
Formatting Using Section Breaks” on page 72 for information about defining sections.

To show and hide the thumbnail view:
m To show the thumbnail view, click View in the toolbar and choose Show Page 

Thumbnails. 

m To show facing pages in the thumbnail view, select Facing Pages in the Document 
Inspector’s Document pane. To open the Inspector, click Inspector in the toolbar (or 
choose View > Show Inspector), then click the Document Inspector button. (See 
“Creating a Document With Left- and Right-Facing Pages” on page 66 for information 
about facing pages.)

m To hide the thumbnail view, click View in the toolbar and choose Hide Page 
Thumbnails.

Click a thumbnail to 
display a particular page.
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To go to a specific page:
m Click its thumbnail. The page appears in the main viewing area.

To select one or more sections in the thumbnail view:
m Click a page. A yellow box surrounds all the page thumbnails that are in the same 

section as the selected page.

m To select multiple adjacent sections, hold down the Shift key, and select the first and 
last section you want.

m You can also select multiple sections by dragging. Click to the left or right of a page 
thumbnail, and then drag up or down to select adjacent sections. 

To move sections:
m Select the sections, click a page thumbnail in one of the selected sections, and drag 

the sections to a new location in the thumbnail view. Sections shift to make room for 
your insertion as you drag.

To delete a section and its contents:
m Select the section in the thumbnail view, and press the Delete key.

To copy (or cut) and paste one or more sections:
1 In the thumbnail view, select the sections you want to copy or cut.

2 Choose Edit > Copy or Edit > Cut.

3 Select the section after which you want to paste the sections.

4 Choose Edit > Paste.

You can also copy and paste one or more sections by Option-dragging selected 
sections to a new destination in the thumbnail view. As you drag, sections shift to 
make room for what you’re pasting.

You can paste a copy of selected sections immediately following them by choosing 
Edit > Duplicate. 

To reuse some or all the pages in a section:
1 Select the section in the thumbnail view.

2 Choose Format > Advanced > Capture Pages. 

3 In the dialog that appears, type a name for the page or pages, use the Include pop-up 
menu to indicate which pages you want to reuse, and then click OK.
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The page or pages are available in the pop-up menu that appears when you click the 
Pages button in the toolbar.

Deleting a Page
To remove a page but not delete the section it’s in:

m Select the text and other objects you want to delete, then press the Delete key.

To remove a page and the section it’s in:
m Select the section in the thumbnail view, and press the Delete key.

m Select the section, and choose Edit > Delete Pages. To use the shortcut menu, Control-
click the section in the thumbnail view, then choose Delete Pages.

Finding and Replacing Text
You can find every instance of a word or phrase in your document. If you want to 
change all instances of a word or phrase in your document—for example, if you are 
writing a letter and you need to change every instance of the name “Rodriguez” to 
“Mr. Rodriguez”—you can do so by using the find and replace feature.

To find or find and replace a word in your document:
1 Choose Edit > Find > Find Panel.

2 Type the word in the Find field.

3 If you want to replace the word with another, type the new word in the Replace field.

4 Depending on how cautious you want to be, do one of the following:

Â Click Next or Previous to highlight the next or previous instance of the word. 
Continue clicking Next or Previous until you locate the instance you are looking for.

Â Click Replace to replace the highlighted instance of the word with the new word, 
and then click Next or Previous to find the next instance.

Â Click Replace & Find to replace the highlighted instance of the word and find the 
next one.

Â Click Replace All to automatically replace all the instances of the word at once 
without your review. To undo this operation, choose Edit > Undo Text Replacement.

Note:  You can’t use the find and replace feature with placeholder text. To find and 
replace text used in a placeholder, you must first undo its definition as placeholder 
text. Click the placeholder text to select it, and then choose Format > Advanced > 
Define as Placeholder Text to remove the checkmark.
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If you want to be more precise about finding content, you can use the Advanced pane 
of the Find & Replace window.

To refine your search criteria:
1 Choose Edit > Find > Find Panel, and then click Advanced.

2 Type the text or phrase in the Find field.

3 If you only want to find the text where it appears in a particular paragraph style (for 
example, Heading 1 style) choose the style from the Style pop-up menu. (For 
information about styles, see Chapter 5, “Working With Styles.”)

4 Choose Entire Document from the In pop-up menu if you want to search the whole 
document, including headers, footers, and text boxes; choose Main Text Body if you 
only want to search the main body text area of the document.

Select to make the 
search case-specific.

Select to find whole 
words only.

Type the text you 
are searching for.

Select to search the document 
to the end and then start from 
the beginning.

Replace text one instance 
at a time, or all at once.

Search backward or forward 
through the document.

Choose the paragraph 
style where the text 
appears.

Choose the paragraph 
style the new text 
should have.

Choose to search the entire document 
or only the main body text.
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5 Select “Match case” if you only want to find instances of the text with the same 
capitalization that you specified in the Find field; otherwise, the search will not take 
capitalization into account.

6 Select “Whole words” if you only want to find instances where the text appears as a 
separate word; otherwise, results will include instances of this text that appear within 
words.

7 If you want to replace the text with a new word or phrase, type it in the Replace field.

8 If you want to change the paragraph style of the new word or phrase, choose a style 
from the Style pop-up menu.

9 Depending on how cautious you want to be, do one of the following:

Â Click Next or Previous to highlight the next or previous instance of the text. 
Continue clicking Next or Previous until you locate the instance you are looking for.

Â Click Replace to replace the highlighted instance of the text with the new text, and 
then click Next or Previous to find the next instance.

Â Click Replace & Find to replace the highlighted instance of the text and find the next 
one.

Â Click Replace All to automatically replace all the instances of the word at once 
without your review. To undo this operation, choose Edit > Undo Text Replacement.

If you frequently use the Find & Replace window, you can add the Find button to the 
Pages toolbar to make it available with a single click. To learn about customizing the 
toolbar, see “The Toolbar” on page 30.

Finding and Listing All Occurrences of a Word or Phrase at Once
You can generate a list of all occurrences of a specific word or phrase (including 
placeholder text) in your document. If you select a search result in the list, the page 
containing the matching text is displayed in the main viewing area, and the text is 
highlighted. 

After selecting an item in the search results list, double-click it or press Return or Enter 
to select the matching text and edit it in the main view.
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Pages searches for a match to the word or phrase in the main body text, headers and 
footers, tables, text boxes, shapes, footnotes and endnotes, and comments.

To show or hide the search sidebar:
m To show the search sidebar, click View in the toolbar and choose Show Search.

m To hide the sidebar, click View in the toolbar and choose Hide Search.

To conduct a search:
1 Show the search sidebar.

2 Type the word or phrase you want to search for in the search field. Results, with page 
references and some text that appears before or after the word or phrase, are listed as 
you type. Searches are not case sensitive, and you can’t search for invisibles. For 
example, you can’t paste the paragraph symbol into the search field and search for it.

3 To view an item in the search results list on the page where it occurs, click it. The page 
is displayed with the word or phrase highlighted. 

Type the word or phrase.

Select an item in the 
resulting list to view where 
the word or phrase occurs 
in the document.
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4 To edit a word or phrase selected in the search results list, double-click it or press 
Return or Enter. Type to replace the selected text, or click the text to edit it.

To list the results of any of the last ten searches since opening the document:
m Click the disclosure triangle in the search field and select a previous search from the 

list. The results for the selected search string appear in the list.

Using Comments
With comments, you can make annotations that relate to particular parts of a 
document without actually changing the document itself. Comments are useful for 
making notes to yourself, asking questions of reviewers, conveying editorial 
suggestions, and so on.

To insert a comment:
1 In an open document, select the words or objects to which the comment will apply. 

The part of the document associated with a comment is called the comment anchor.

2 Click Comment in the toolbar.

3 In the box that appears, type your comment. The size of the comment box grows and 
shrinks to accommodate your comment.

You can use character and paragraph styles to modify the appearance of text in a 
comment.

To change a comment:
m Click the comment and edit it just as you would text and objects elsewhere in your 

document.

The comment has a visible link 
to the information it relates to.
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To delete a comment:
m Click the delete icon in the corner of the comment box or delete the comment’s 

anchor.

To view comments:
m Click View in the toolbar and choose Show Comments (or choose View > Show 

Comments).

If comments are not in view, inserting one displays all comments.

To hide comments:
m Click View in the toolbar and choose Hide Comments (or choose View > Hide 

Comments).

To print comments:
m Print your document with comments visible. Printed pages are adjusted to make room 

for the comments. (If you don’t want to print your document with comments, hide 
comments before printing.)

Step 6:  Save and Share Your Document
When you create a Pages document, all of the graphics and any chart data are 
contained within that document, which can be moved from one computer to another. 
However, fonts are not included as part of the document. If you transfer a Pages 
document to an older computer, make sure the fonts used in the document have 
been installed in the Fonts folder of that computer.

It’s a good idea to save your document often as you work.

To save your document:
1 Choose File > Save, or press Command-S.

2 Type a name for the document.

3 If your file directory isn’t visible, click the disclosure triangle to the right of the Save As 
field.

4 Choose where you want to save the document.

5 Select “Save a copy in iWork ‘05 format” if you want the document to be opened using 
Pages in iWork ‘05.
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6 If you plan to share the document between computers or with other users, click 
Advanced Options.

Â Make sure the “Copy audio and movies into document” checkbox is checked if your 
document contains movie or audio files.

If you don’t select this checkbox, then any audio or video files that you have 
included in your document will not be carried along with it if you transfer your 
document to another computer or send it to someone else. Documents that contain 
media may have large file sizes.

Â Select the “Copy template images into document” checkbox to keep image files that 
were part of the document’s original template with your document if you transfer it 
to another computer or send it to someone else.

7 Click Save.

To learn about exporting your document in other file formats (including Microsoft 
Word, HTML, rich text format, plain text, and PDF), see “Exporting to Other Document 
Formats” on page 231.

As you work on your document, you can save it frequently by pressing Command-S. 
You can also save a backup copy of the last saved version of your document. This way, 
if you change your mind about edits that you have made, you can go back to the 
previous version of the document.

To save a backup copy of your document:
m Choose Pages > Preferences, click General, and select the checkbox labeled “Back up 

previous version when saving.”

When you save the document, the previous version is saved in the same location as 
the document with the words “Backup of” preceding the filename. Only one version—
the last saved version—is backed up.

To save a version of your document with a different name or in a different location:
1 Choose File > Save As.

2 Type a name for your document.

3 Select a location to save the document. Click the disclosure triangle next to the Save 
As field to select the location you want.

4 Click Save or New Folder.
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To see a print preview:
m Choose File > Print, and then click the Preview button in the Print dialog.

To print your document:
1 Choose File > Print.

2 Enter the number of copies you want, if you want multiple copies of the document; or 
select From and enter a page range to print only part of the document.

3 Click Print.

If you print frequently, you can add the Print button to the Pages toolbar. To learn 
about customizing the toolbar, see “The Toolbar” on page 30.

For more information about printing, see “Printing Your Document” on page 224.
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3 Formatting a Document’s 
Layout and Table of Contents

This chapter describes how to set up the overall 
document layout, including margins, column 
layouts, and section breaks, and how to generate a 
table of contents, footnotes, and endnotes.
Before adding content to your document, it’s a good idea to set up the document 
layout—including the page orientation and size, page margins, background graphics 
(watermarks), and any odd/even-numbered page differences. You make most of these 
settings in the Document Inspector and the Layout Inspector.

To open the Document Inspector:
m Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 

Document Inspector button.
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Formatting set in the Document Inspector applies to the entire document. However, 
you can control formatting options for document sections (for example, chapters) 
using the Layout Inspector. For example, you can create a different first page, left 
page, and right page layout for each section, or use different text column layouts in 
different parts of the document. To learn more about creating sections in your 
document, see “Varying Document Formatting Using Section Breaks” on page 72. To 
read about creating columns, see “Creating Columns” on page 62.

The Document Inspector button

Use the TOC pane to set up a table of 
contents for the document. (See page 76.)

Use the Info pane to see document 
statistics, such as word count, date, 
and keywords.

Use the Page Setup dialog to specify 
paper size and orientation.

Set up margins for the left, right, top, 
and bottom edges of the page. You 
can set them separately for documents 
with left- and right-facing pages.

Choose a footnote or endnote style.

Use automatic hyphenation 
throughout the document.

Use any available font ligatures 
throughout the document.

Select the kind of note to create.

Adjust the space between notes.
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Setting Page Orientation and Size
By default, most Pages templates are created for standard paper sizes, with the text 
printed in portrait (vertical) orientation. If your document will require a different paper 
size or you want to print it in landscape (horizontal) orientation, you should set the 
paper size and orientation at the start. This way, as you work in your document, you 
will have a clearer idea of what it’s going to look like.

If you start with a Blank document, it is in portrait orientation by default. “Setting the 
Paper Size and Orientation” on page 224 provides instructions for changing the page 
orientation and setting up paper size.

Setting Page Margins
The default margins for most of the Pages templates, including Blank, are set to one 
inch from the left and right sides of the page, and one inch from the top and bottom. 
This means that the body text of the document will not expand outside of these 
margins.

To change the page margins:
m In the Document pane of the Document Inspector, enter values in the Left, Right, Top, 

and Bottom fields.

If you want to set different margins in different sections of your document, you must 
use the Layout Inspector. To learn about setting layout margins, see “Varying Column 
and Page Layouts” on page 64.

If you are creating a document that will be bound, you may want your document 
margins to take into account which side of the page will go into the binding (the 
inside margin) and which will be the loose edge of each page (the outside margin). To 
do this, you must create a document with left- and right-facing pages. To read about 
this, see “Creating a Document With Left- and Right-Facing Pages” on page 66.
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Creating Columns
In Pages, you can vary the design on different pages of your document by creating 
layouts, separated by layout breaks. A layout is part of a document in which you have 
defined layout margins and columns. You can have multiple layouts in a section of 
your document, or even on a single page.

You can lay out text in up to ten columns, adjusting relative column size and the 
spacing between columns.

To create up to four columns of equal width:
m Click Columns in the toolbar and select the number of columns you want, up to four.

If the Columns button isn’t in the toolbar, or if you want more than four columns, you 
must use the Layout Inspector. You must also use the Layout Inspector if you want to 
make columns with unequal widths.

To create more than four columns:
1 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 

Layout Inspector button.

2 Click Layout in the Layout Inspector if it’s not already selected.

3 Type the number of columns you want in the Columns field. By default, the columns 
have equal widths.

4 To resize the columns:

a Deselect the checkbox labeled “Equal column width”.

b Select a column or gutter width in the table and type a new value, using the same 
units shown in the document rulers.
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After you have created the number of columns you want, you can resize them on the 
fly using the document rulers, rather than entering column and gutter width values in 
the Layout Inspector.

To adjust column widths using the rulers:
1 Click View in the toolbar, and choose Show Rulers.

2 Drag the left or right edges of the gray gutter areas just below the horizontal ruler.

The Layout Inspector button

Select a column or 
gutter width and type 
a new value.

Set the space between 
the current layout and 
the preceding and 
following layouts.

Deselect to set unequal 
column widths.

Set the number 
of columns.

Start the current 
layout at the top 
of a page.

Set the margins for the 
current layout.

The white areas below the 
ruler denote the text area 
within columns.

The gray areas denote 
the column gutters.
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Varying Column and Page Layouts
You can use page, column, and layout breaks to create different text layouts on a 
page.

Page Breaks
When you reach the end of a page, text automatically flows to the next page as you 
type. You can specify that text “break” where you want by inserting a page break.

To create a page break:
1 Click where you want the break to occur.

2 Choose Insert > Page Break.

When you show invisible formatting characters in your document, a page break 
symbol appears like this:

To remove a page break:
1 Click at the beginning of the line that follows the break.

2 Press the Delete key.

Column and Layout Breaks
Column breaks end the text flow in one column (leaving the rest of the column blank) 
and continue it in the next. Layout breaks end one layout and start a new one with a 
different number of columns, different column margins, or blank space before or after 
the layout.

Using column breaks or layout breaks does not affect the headers, footers, page 
numbering, or other formatting features specific to the document or section. (To read 
about section formatting features, see “Varying Document Formatting Using Section 
Breaks” on page 72.)

You can apply the formatting features described here to both single-column layouts 
and multi-column layouts.

To create a column break:
1 Place the cursor after the word where you want to end the text flow.

2 Choose Insert > Column Break.
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The text breaks where your cursor was inserted and continues in the next text 
column. If you insert a column break in a single-column layout, the text continues at 
the top of the next page.

When you show invisible formatting characters in your document, a column break 
symbol appears like this:

To change the number of columns:
1 Place the insertion point after the word where you want to end the current number of 

columns and change to a new layout.

2 Choose Insert > Layout Break.

A layout break is inserted and the insertion point is moved to the top of the next 
layout. When you show invisibles in your document, a layout break symbol appears 
like this:

3 Set the number of columns you want, and format them, in the Layout pane of the 
Layout Inspector.

To change the layout margins of columns:
1 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 

Layout Inspector button.

2 Click Layout in the Layout Inspector.

3 To change the outside margins of the column layout, enter values in the Left and 
Right fields under Layout Margins.

4 To create space above and below the current column layout, enter values in the 
Before and After fields under Layout Margins.

Note:  The new margins cannot extend outside the page margins set for the 
document.

To move a layout to the top of a page:
m Select the checkbox labeled “Layout starts on new page” in the Layout pane of the 

Layout Inspector.
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Creating a Document With Left- and Right-Facing Pages
If you intend to print a document double-sided and bind it, it will have left- and
right-facing pages. In this case you may want to vary the margins and layout on left 
and right pages. For example, you may want the margins that go into the binding to 
be wider than the outside margins (as in this book, for example), or you may want to 
place page numbers on the outer corners of each page. To do this, you need to tell 
Pages that this document has facing pages.

To create different margins for left- and right-facing pages:
1 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 

Document Inspector button.

2 Click Document.

3 Select the checkbox labeled Facing Pages.

To learn about other document formatting options that are available by using facing 
pages, see “Varying Document Formatting Using Section Breaks” on page 72.

4 Set inside and outside margins.

To view facing pages:
m Click View in the toolbar and choose Show Page Thumbnails (or choose View > Show 

Page Thumbnails) to view facing pages in the thumbnail view. See “Using Thumbnails” 
on page 48 for information about using thumbnails.

m Click the Page View control in the bottom-left corner of the window, and choose Two 
Up from the pop-up menu to view facing pages side by side in the main document 
window. 

Select to set the margins for 
left- and right-facing pages 
independently.

Type a value for the 
margin on the outside 
edges of the pages.

Type a value for the 
margin that will go into 
the binding.
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Adding Headers, Footers, Page Numbers, Footnotes, and 
Endnotes
Pages has tools that make it easy to add identifying text on every page, as well as to 
automatically insert and format footnotes and endnotes.

Adding Headers and Footers
Headers and footers appear at the top and bottom margins of a document. Usually, 
they identify the document, author, page number, and so on.

To add a header or footer to your document:
1 Click View in the toolbar and choose Show Layout (or choose View > Show Layout). 

You see the header and footer areas at the top and bottom of the page.

2 Place the insertion point in the header or footer and type, formatting the text as you 
would regular text. (For information about formatting text, see “Formatting Text Size 
and Appearance” on page 79.)

Whatever you type in a header or footer is repeated on every page. If you want to 
change the header and footer text in different sections of your document, see 
“Varying Document Formatting Using Section Breaks” on page 72. To automatically 
generate the correct page number on each page, use formatted text fields, described 
next.
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Using Formatted Text Fields for the Page Numbers, Date, and Time
Formatted text fields allow you to insert text that can be automatically updated. For 
example, inserting the date field shows the current date whenever you open the 
document. Similarly, page number fields keep track of page numbers as you add or 
delete pages. Pages provides formatted text fields for date, page number, and page 
count—the total number of pages in the document. This is useful, for example, if you 
want to label your pages “page 1 of 4.”

To add page numbers:
m Place the insertion point where you want the page number to appear, and then 

choose Insert > Page Number.

To add the page count:
m Place the insertion point where you want the page count to appear, and then choose 

Insert > Page Count.

To add and format the date and time:
1 Place the insertion point where you want the date and time to appear, and then 

choose Insert > Date & Time.

2 Select a date and time format in the dialog.

3 If you want the document to always show the current date and time, select the 
checkbox labeled “Automatically update the date and time when the document is 
opened.”

4 Click Insert.

To edit the date and time format that’s already been inserted:
m Control-click the date and time text, and choose Edit Date & Time from the shortcut 

menu. Select a new format in the dialog, and click Change.

Adding Footnotes and Endnotes
You can add special marks in a document that link to notes at the bottom of a page 
(footnotes) or at the end of a document or section (endnotes). You can’t mix 
footnotes and endnotes in a document, but you can convert notes from one type to 
the other.
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You can use one of the predefined autonumbering styles for the mark that refers to 
the note. Predefined numbering styles are Arabic numbers (1, 2, 3), Roman numerals 
(i, ii, iii), and symbols (*, †, ‡). Numbering can be continuous through the document, 
or restarted for each document section or page. 

Instead of or in addition to using autonumbering, you can use custom marks, which 
you define yourself. There’s no autonumbering for custom marks; if you use custom 
marks, you need to specify the mark you want to use every time you create a footnote 
or endnote.

To add a footnote:
1 Open the Document Inspector. Click Inspector in the toolbar (or choose View > Show 

Inspector), and then click the Document Inspector button. Then click Document.

2 Choose Use Footnotes from the Footnotes & Endnotes pop-up menu.

3 Choose a numbering format.

4 Place the insertion point where you want the footnote mark to appear.

5 Choose Insert > Footnote.

A footnote mark appears and the insertion point moves to the corresponding 
footnote field at the bottom of the page.

6 Type the footnote information. In addition to text, you can use inline shapes, graphics, 
and other objects; see “Adding Fixed and Inline Objects” on page 125 for instructions.

To add an endnote at the end of a document:
1 Open the Document Inspector. Click Inspector in the toolbar (or choose View > Show 

Inspector), and then click the Document Inspector button. Then click Document.

2 Choose Use Document Endnotes from the Footnotes & Endnotes pop-up menu.

3 Choose a numbering format.

4 Place the insertion point where you want the endnote mark to appear.

5 Choose Insert > Endnote.

An endnote mark appears and the insertion point moves to the corresponding 
endnote field, at the end of the document following a section break. If you don’t want 
the endnotes on a new page, delete the section break.

6 Type the endnote information. In addition to text, you can use inline shapes, graphics, 
and other objects; see “Adding Fixed and Inline Objects” on page 125 for instructions.
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To add an endnote at the end of a section:
1 Open the Document Inspector. Click Inspector in the toolbar (or choose View > Show 

Inspector), and then click the Document Inspector button. Then click Document.

2 Choose Use Section Endnotes from the Footnotes & Endnotes pop-up menu.

3 Choose a numbering format.

4 Place the insertion point where you want the endnote mark to appear.

5 Choose Insert > Section Endnote.

An endnote mark appears and the insertion point moves to the corresponding 
endnote field, at the end of the section in which the mark appears. A line separates 
the endnotes from other information in the section.

6 Type the endnote information. In addition to text, you can use inline shapes, graphics, 
and other objects; see “Adding Fixed and Inline Objects” on page 125 for instructions.

To delete a footnote or endnote:
m Delete the mark within your document that refers to the note.

To use a predefined number or symbol format:
m In the Document pane of the Document Inspector, choose a numbering style from the 

Format pop-up menu. The numbering style you choose will be the same throughout 
the document.

To insert a custom mark:
1 Place the insertion point at the location in the document where you want a footnote 

or endnote custom mark to appear.

2 Click the Insert menu, then press the Option key. Choose Custom Endnote, Custom 
Section Endnote, or Custom Footnote. What appears in the menu depends on the 
setting in the Footnotes & Endnotes pop-up menu.

3 In the dialog that appears, type or select a custom mark, and then click OK.

4 The mark appears and the insertion point moves to the appropriate location in the 
document for you to type the note.

To change the numbering format from predefined to custom:
1 Control-click an endnote or footnote mark.

2 Choose Use Custom Mark from the shortcut menu.
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3 In the dialog that appears, type or select a custom mark, and then click OK. The 
custom mark replaces the predefined mark.

To change custom numbering to predefined numbering:
1 Control-click a custom mark.

2 Choose Use Automatic Numbering from the shortcut menu.

The mark that replaces the custom mark reflects the number format settings in the 
Document pane of the Document Inspector.

To restart the numbering of footnotes and section endnotes:
m Choose Restarts on Each Page or Restarts for Each Section from the Numbering pop-

up menu in the Document pane of the Document Inspector. (To learn about dividing 
your document into sections, see “Varying Document Formatting Using Section 
Breaks” on page 72.)

To adjust the space between notes:
m In the Document pane of the Document Inspector, increase or decrease the number 

in the Space Between Notes field.

To format notes:
m Select the note text and/or mark and format it as you would any text using the Font 

panel, the Text Inspector, and the Styles drawer. For more information about how to 
format text, see Chapter 4, “Formatting Text and Paragraphs.”

To convert footnotes to endnotes and vice versa:
m In the Document pane of the Document Inspector, change the setting in the 

Footnotes & Endnotes pop-up menu.

To jump between references and notes:
m In the note, double-click the mark to jump to the location in the document where the 

note is referenced.

m In the document body, click the reference mark to jump to its note.
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Varying Document Formatting Using Section Breaks
Use section breaks in your document wherever you want to separate your document 
into sections with different layouts, numbering, or other document formatting. You 
can use sections to make the following formatting elements different from one part of 
your document to the next:

Â Formatting and layout attributes

Â Headers

Â Footers

Â Page numbering

Â Margins

Â Column layout

Â Master objects (repeated background images)

Creating Sections
A section consists of one or more pages that end with a section break. 

Each Pages template consists of one or more predefined sections. Every time you add 
pages to the document by using the Pages button in the toolbar, you add a new 
section.

You can use the predefined sections as they are, or you can create or remove section 
breaks to define your own sections.

To create a section break:
m Choose Insert > Section Break.

When you show invisibles in your document, you’ll see a section break symbol that 
looks like this:

After you create a section break, changes made to the master objects (see “Using 
Master Objects” on page 74), headers, footers, or page numbering will apply only to 
the section in which you make the changes. 

To remove a section break:
m Click at the beginning of the line that follows the break and press the Delete key.
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Managing Sections
The thumbnail view makes it easy to move sections, duplicate them, copy (or cut) and 
paste them, even capture them so they can be inserted using the Pages button in the 
toolbar. See “Using Thumbnails” on page 48 for instructions.

Defining Section Formatting and Layout Attributes
When you insert a section break, the new document section automatically “inherits” 
all of the formatting and layout attributes of the previous section. To change these 
attributes, use the Layout Inspector to set up new page numbering, headers and 
footers, margins, and columns.

To make headers and footers different in one section of a document:
1 Place the insertion point in the document section you want to change.

2 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 
Layout Inspector button.

3 Click Section.

4 Deselect the checkbox labeled “Use previous headers and footers.”

5 Type the new header or footer in the header or footer area of your document.

To restart page numbering in a document section:
m Select the “Start at” checkbox in the Section pane of the Layout Inspector, and then 

enter the number of the first page of the section.
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To set up different first pages, or left- and right-facing pages, for a document 
section:

1 To make the headers and footers on the first page unique, select the checkbox 
labeled “First page is different” in the Section pane of the Layout Inspector, and then 
change headers and footers.

2 To put different headers and footers on alternate pages, do the following:

a Select the checkbox labeled “Left and right pages are different” in the Section pane 
of the Layout Inspector.

b If you want the first page of the section to always start on the left- or right-facing 
page, choose Left Page or Right Page from the “Section starts on” pop-up menu. 
Otherwise, choose Any Page.

To modify text columns or adjust margins in a document section:
m See “Varying Column and Page Layouts” on page 64 for instructions.

Using Master Objects
A master object is an image that appears in the background on every page of a 
document (such as a watermark). 

Make page numbering 
continuous with the 
previous section or enter 
a number to start 
renumbering pages.

Make headers and footers 
different on the first page 
or alternate pages, or 
continue from the 
previous section.

Make the new section 
begin on a left- or 
right-facing page.
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When you create a new section, it inherits any master object that’s already been 
placed. You can remove or reposition the master objects in subsequent sections, if you 
want. See “Adding a Repeated Background Image,” next, to learn about how to place 
a master object.

Adding a Repeated Background Image
You may want to add watermarks, logos, or other background images that appear in 
the same spot on every page of your document. These repeated graphics are called 
master objects.

Important:  Master objects may not appear on every page, depending on whether 
your document is divided into sections and which settings you have selected in the 
Section pane of the Layout Inspector. If you want to have different master objects for 
different parts of your document, you can divide your document into sections.

To add a master object:
1 Click outside the text flow of your document so that the insertion point is not visible.

2 Add a graphics object. You can add an imported image, drawn shape, table, chart, or 
text box. To learn about how to add a graphic, see Chapter 6, “Working With Graphics 
and Other Media.” Make sure the graphic is a “fixed object” (is not placed inline with 
the text flow).

3 Position the graphic wherever you want it on the page.

4 Choose Format > Advanced > Move Object to Section Master. The selection handles 
disappear from the object, so you can no longer select it.

To edit or move a master object, you must first make master objects selectable for the 
entire document. Master objects look different from other objects because they have 
blue selection handles.

To make master objects selectable:
m Choose Format > Advanced > Make Master Objects Selectable.

Master objects have blue 
selection handles.
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Using a Table of Contents
Pages can automatically generate a table of contents for your document. In order to 
create a table of contents, you need to use consistently styled text for the headings in 
your document. To learn about styled text, see Chapter 5, “Working With Styles.”

Generating a Table of Contents
To create and update a table of contents:

1 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 
Document Inspector button.

2 Click TOC.

3 Select the checkboxes next to the paragraph styles whose text you want to appear in 
the table of contents. For example, if you want all the first-level headings and 
subheadings to appear in the table of contents, select the paragraph style that you 
used for first-level headings and subheadings.

Note:  If the styles you select are not used anywhere in the document, you will see a 
message that your table of contents is empty when you create the table of contents. If 
you select styles that are used for a large amount of text in the document, your table 
of contents will be too full. Take care to select the styles that denote topic headings, 
captions, or other items you want listed in a table of contents.

Click to update the table 
of contents after making 
changes to your 
document.

Select the checkbox in 
the #’s column if you 
want page numbers to 
appear with each entry.

Select the paragraph 
styles whose text you 
want to appear in the 
table of contents.
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4 In the #’s column, select the checkboxes of those styles whose entries you want to 
have an associated page number.

5 Place the insertion point at the beginning of the line where you want the table of 
contents to appear, and then choose Insert > Table of Contents.

Note:  Each table of contents you create lists only the content that follows it, up until 
the next table of contents. If you want a master table of contents for the entire 
document, it must be the only table of contents, and it must be at the beginning of 
the document.

To update the TOC after editing a document:
m Click any entry in the table of contents, or click Update Now in the TOC pane of the 

Document Inspector. You can always change your TOC settings (styles and page 
numbers) later.

Styling a Table of Contents
You can change the look of text in the table of contents as you would any other text. 
You can also add a leader line between the TOC entry and its associated page number. 
To style the table of contents, create new TOC styles, as described below.

To change the look of a table of contents entry:
1 In the table of contents, select the entry type that you want to change (for example, 

all the entries based on first-level headings). All the entries of the same type are 
automatically selected. They cannot be individually selected.

2 Click Style in the toolbar and choose Show Styles Drawer (or choose View > Show 
Styles Drawer). Notice that the Styles drawer now displays a list of table of contents 
styles. The TOC style that corresponds to the selected entry is also selected.
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3 To edit the look of the entry text, do any of the following:

Â Use the Font panel, the Text Inspector, and the Colors window to change the look of 
the text as you would style any paragraph text. To learn about changing the look of 
text, see Chapter 4, “Formatting Text and Paragraphs.”

Â To create leader lines from an entry to its associated page number, select the TOC 
entry, click the tab in the Tab Stops column in the Tabs pane of the Text Inspector, 
and then choose a line style from the Leader pop-up menu.

Â To change the style in the Styles drawer to match the entry, click the arrow to the 
right of the style name and choose Redefine Style From Selection.

Â To create a new TOC style, click the arrow to the right of the style name and choose 
Create New TOC Style From Selection, and then type a name for the new style.

4 To rename the style in the Styles drawer to match the entry, click the arrow next to 
the style name and choose Rename Style. Type a new name for the style.

5 To add a new style, click the Add (+) button at the bottom-left corner of the Styles 
drawer, choose Create New TOC Style From Selection, and then type a name for the 
new style. Select “Apply this new style on creation” if you want it to be applied 
immediately to the selected text.

Click the arrow and 
choose whether to 
redefine the selected 
style, create a new style, 
or just rename it.

When a table of contents 
entry is selected, the 
Styles drawer displays 
table of contents styles.
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4 Formatting Text and 
Paragraphs

This chapter describes how to modify the 
appearance of text and paragraphs, including 
creating lists, aligning text, and using text boxes 
and other techniques to make text stand out.

Formatting Text Size and Appearance
You can do all text formatting using the Pages menus and the Text Inspector window, 
or the Font panel. You can do basic text formatting using the commands in the Pages 
menus. 

Using the Format Menu to Format Text
The items in the Font submenu of the Format menu allow you to make text:
Â Bold or italic

Â Underlined or outlined

Â Bigger or smaller

Â More tightly or loosely spaced

Â Superscript or subscript

To make selected text bold, italic, underlined, outlined, bigger, or smaller:
m Choose Format > Font > [Bold, Italics, Underline, Outline, Bigger, or Smaller].

To make selected text a superscript or subscript:
m Choose Format > Font > Baseline > [Use Default, Superscript, Subscript].

To make selected text all uppercase:
m Choose Format > Font > Capitalization > [None, All Caps, Small Caps].
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If you want to change to a different font, or if you frequently change text formatting, it 
may be easier to use the Font panel and Text Inspector to format text. These tools are 
described in the following sections.

You can also create engaging visual effects with text by changing its shadow color, 
opacity, and orientation on the page. To learn more about these options, see 
Chapter 7, “Changing Object Properties.”

Using the Font Panel to Format Text
The Mac OS X Font panel gives you access to all the fonts installed on your computer. 
It provides a preview of the available typefaces (such as bold and italic) and sizes for 
each font. The buttons in the Font panel let you add underlines, strikethrough lines, 
color, and shadow to text. You can even change the background page color in the 
Font panel.

To open the Font panel:
m Click Fonts in the toolbar (or choose Format > Font > Show Fonts).

Create interesting text 
effects using these buttons.

Preview the selected 
typeface.

Find fonts by typing
a font name in the

search field.

Select a typeface in the 
list to apply it to selected 
text in your document.

Select a font size to apply 
it to selected text in your 
document.

The Action 
pop-up menu
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You can change the appearance of any text in your document by selecting it and then 
selecting options in the Font panel. When you make formatting changes in the Font 
panel, the selected text changes right away, so you can try different formatting 
options and quickly see what looks best.

Here is a summary of what the text effects buttons do, from left to right:

Â The Text Underline pop-up menu lets you choose an underline style (such as single 
or double).

Â The Text Strikethrough pop-up menu lets you choose a strikethrough style (such as 
single or double).

Â The Text Color pop-up menu lets you apply a color to text.

Â The Document Color pop-up menu lets you apply a color behind a paragraph.

Â The Text Shadow button applies a shadow to selected text.

Â The Shadow Opacity, Shadow Blur, Shadow Offset, and Shadow Angle controls 
control the appearance of the shadow.

To change the look and size of text:
1 In the Font panel, select a font style in the Family column and then select the typeface 

in the Typeface column.

If you don't see all the font families you know are installed on your computer, select 
All Fonts in the Collections column or type the name of the font you are looking for in 
the search field at the bottom of the Font panel.

A preview of the selected font appears in the preview pane at the top of the Font 
panel. If you don't see a preview pane, choose Show Preview from the Action pop-up 
menu in the lower-left corner of the Font panel.

2 Adjust the font size using the size slider or other size controls.

3 Adjust the typography settings of the selected font by choosing Typography from the 
Action pop-up menu. In the Typography window, click the disclosure triangles to see 
and select the different typography effects that are available for the selected font. 
Different fonts have different typography effects available. See “Using Advanced 
Typography Features” on page 87 for more information.

To quickly locate fonts you frequently use:
m Organize the fonts you use often into font collections by clicking the Add (+) button 

to create a font collection, and then dragging a typeface into the new collection. 
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To make it easy to change fonts often:
m Leave the Font panel open. If it takes up too much space on your screen, you can 

shrink it by dragging its resize control (the bottom-right corner of the panel), so that 
only the font families and typefaces in your selected font collection are visible. To 
close it, choose Format > Font > Hide Fonts, or click the Fonts button again.

To modify underlining of selected text:
1 Click the Text Underline button in the Font panel (the first button on the left), and 

choose None, Single, or Double from the pop-up menu.

2 To change the underline color, choose Color from the Text Underline pop-up menu, 
and then select a color in the Colors window.

To modify strikethrough lines of selected text:
1 Click the Text Strikethrough button in the Font panel (the second button from the 

left), and choose None, Single, or Double from the pop-up menu.

2 To change the strikethrough color, choose Color from the Text Strikethrough pop-up 
menu, and then select a color in the Colors window.

To modify the color of selected text:
m Click the Text Color button menu in the Font panel (the third button from the left), 

and then select a color in the Colors window.

Note:  You can also modify text color in the Text Inspector, as described on page 91.

To modify the background color of a selected paragraph:
m Click the Document Color button in the Font panel (the fourth button from the left), 

and then select a color in the Colors window.

Note:  You can also modify paragraph background color in the Text Inspector, as 
described in “Setting Paragraph Fill Colors” on page 102.

To create shadows on selected text:
1 Click the Text Shadow button in the Font panel (the fifth button from the left).

2 Drag the shadow opacity slider (the first slider on the left) to the right to make the 
shadow darker.

3 Drag the shadow blur slider (the middle slider) to the right to make the shadow more 
diffuse.
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4 Drag the shadow offset slider (the third slider) to the right to separate the shadow 
from the text.

5 Rotate the Shadow Angle wheel to set the direction of the shadow.

Note:  You can also set text shadows in the Graphic Inspector, as described in “Adding 
Shadows” on page 153.

Adding Accents and Special Characters
If you need to type characters with accent marks (such as ü), mathematical symbols, 
arrows, or other special characters, you can use the International preferences pane or 
the Character Palette. You can also see where characters are located on keyboards 
used for other languages by using the Keyboard Viewer (for example, you can see 
how the keys on an Italian keyboard are laid out). All of these are built-in tools of 
Mac OS X.

To add accent marks to characters:
1 Choose Apple > System Preferences and click International.

2 Click Input Menu, then select the checkbox next to Keyboard Viewer.

3 Choose Show Keyboard Viewer from the Input menu on the right side of the menu 
bar (the one that looks like a flag or alphabetical symbol).

The Keyboard Viewer shows the characters for your keyboard. (If you've selected a 
different keyboard layout or input method in the Input menu, it shows the characters 
for the selected keyboard layout). For example, if U.S. is chosen in the Input menu, you 
see the characters that appear on a U.S. keyboard in the Keyboard Viewer.

4 To see the different accent marks that you can type highlighted in the Keyboard 
Viewer, press Option, or the Option and Shift keys.

The accent mark keys appear with white outlines. Depending on your keyboard, you 
may not need to press any of the modifier keys to see the accent keys.

5 Place the insertion point in your document where you want to type.

6 Press the modifier key you pressed in step 4 (Shift, Option, Option-Shift, or none) and 
press the key on your keyboard that is in the same place as the accent you see in the 
Keyboard Viewer. Then release the modifier key and press the key for the character 
you want to accent.
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The accent key modifies the key you type next. For example, on a U.S. keyboard, to 
make the é appear, press Option and E (the accent key), then press E (the key on 
which you want that accent to appear).

To see keyboard layouts for other languages:
1 Choose Apple > System Preferences and click International.

2 Click Input Menu, then select the checkbox next to Keyboard Viewer.

3 To see the character layout on keyboards used in different countries, select the On 
checkbox next to the country's keyboard layout or input method.

Note:  You must have fonts installed for the language you want to see in the Keyboard 
Viewer.

4 Choose Show Keyboard Viewer from the Input menu on the right side of the menu 
bar (the one that looks like a flag or alphabetical character).

The Keyboard Viewer shows the characters for the keyboard layout or input method 
selected in the Input menu. For example, if U.S. is chosen in the Input menu, you see 
the characters that appear on a U.S. keyboard in the Keyboard Viewer.

5 To see the keyboard layout for a different country, choose its keyboard layout from the 
Input menu.

To type special characters and symbols:
1 Place the insertion point where you want the special character or symbol to appear.

2 Choose Edit > Special Characters to open the Character Palette (or choose Characters 
from the Action pop-up menu in the lower-left corner of the Font panel).

3 Choose the type of characters you want to see from the View pop-up menu at the top 
of the Character Palette. If you don't see the View menu, click the button in the upper-
right corner of the window to show the top portion of the window. Click this button 
again to hide the top portion of the window.
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In Mac OS X version 10.3, the Character Palette looks like this:

Select a character 
category.

Choose the type of 
character you want 
to see.

Select a symbol.

Double-click a symbol 
to insert it in your 
document.
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In Mac OS X version 10.4, the Character Palette looks like this:

4 Click an item in the list on the left to see the characters that are available in each 
category.

5 Double-click the character or symbol on the right that you want to insert into your 
document, or select the character and click Insert. If the character or symbol has 
variations, they appear at the bottom of the window; double-click one to insert it in 
your document.

To use smart quotes so that opening and closing quotation marks aren’t identical:
m Choose Pages > Preferences, click Auto-Correction, and select the checkbox labeled 

“Use smart quotes.”
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Using Advanced Typography Features
Some fonts, such as Zapfino and Hoefler, have advanced typography features, which 
let you create different effects. If you are using a font that has different typography 
effects available, you can change many of them in the Font submenu of the Format 
menu. For example, you may be able to adjust the following:

Â Tracking:  Place characters closer together or farther apart

Â Ligature:  Use or leave out stylish flourishes between letters or at the end or 
beginning of lines that combine two or more text characters into one glyph

Â Baseline:  Move text higher or lower than the text around it

Â Capitalization:  Convert all characters to capital or small capital letters

More advanced typography features are available in the Typography window.

To open the Typography window:
m In the Font panel, choose Typography from the Action pop-up menu (in the lower-left 

corner).

Using Automatic Text Substitution
Pages can be set to recognize and replace text you don’t want with text you do want. 
For example, when you type “teh,” Pages can automatically change it to “the.”

To set up automatic text substitution:
1 Choose Pages > Preferences, and then click Auto-Correction.

2 Make settings as desired:

Â To automatically convert single and double quotation marks to smart quotes so that 
opening and closing quotation marks are not identical, select “Use smart quotes.”

Â To make sure that the first word in a sentence begins with a capital letter, select “Fix 
capitalization.”

Â To automatically convert the letters in 1st, 2nd, 3rd, and so on into superscripts, 
select “Superscript numerical suffixes.”

Ligature not used

Ligature used
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Â To set Pages to automatically detect that something you’ve typed is an email 
address or a URL, select “Automatically detect email and web addresses.” Email and 
web addresses you type automatically become hyperlinks for Mail or Safari.

Â To replace one or more characters with one or more different characters, select 
“Symbol and text substitution.” Then use the rows in the table to define and activate 
specific substitutions. For example, when you type (c), you can have Pages 
automatically convert it to © by putting a checkmark in the On column. 

Â To add a row to the table, click the Add (+) button. To remove a row, click the Delete 
(–) button.

After you specify substitution settings, they’ll apply to any text you change or add in 
any Pages documents.

Setting Text Alignment, Spacing, and Color
The primary tool for adjusting text attributes is the Text Inspector. You can make some 
horizontal alignment adjustments (such as centering text or aligning it on the left) by 
using the Format menu.

Using the Text Inspector
In the Text pane of the Text Inspector, you can change the text color and alignment. 
You can also adjust the spacing between individual text characters and lines.
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To open the Text pane of the Text Inspector:
1 Choose View > Show Inspector (or click Inspector in the toolbar).

2 Click the Text Inspector button, and then click Text.

To align text left, center, right, or justified:
1 Place the cursor in the paragraph you want to change, or select several paragraphs.

2 Click the horizontal alignment buttons at the top of the Text Inspector.

You can align text in a fixed text box to the left, right, center, or justified (aligned to 
both the right and left edges). Text in a fixed text box, table cell, or shape can also 
“grow” from the top, center, or bottom of the text area. 

Drag to adjust the amount 
of space between text and 
the inside borders of text 
boxes, table cells, and 
shapes.

Click to change the color of 
selected text.

The Text Inspector button

Horizontal alignment 
buttons:  Click to align 
selected text left, right, 
center, or to the left and right.

Vertical alignment 
buttons:  Click to align 
text to the top, center, or 
bottom of a fixed text 
box, shape, or table cell.

Character and line 
spacing:  Drag to adjust 
character, line, and 
paragraph spacing for 
selected text.
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To align text to the top, center, or bottom of a text box, table cell, or shape:
1 Select the text box, table cell, or shape you want to change.

2 Click the vertical alignment buttons at the top of the Text Inspector.

To adjust the spacing between lines of text in a paragraph:
1 Place the cursor in the paragraph you want to change, or select several paragraphs.

2 In the Text Inspector, drag the Line slider to adjust the line spacing. 

Dragging the slider to the left brings the selected lines closer together; dragging it to 
the right moves them farther apart. You can also choose Single, Double, or Multiple 
from the Line Spacing pop-up menu, located below the Line field. Choosing Multiple 
lets you set line spacing values between single and double, or greater than double.

To set precise point values for spacing between the lines of text in a paragraph:
1 Place the cursor in the paragraph you want to change, or select multiple paragraphs.

2 Type a point value in the Line field, or click the Up Arrow or Down Arrow next to the 
field.

3 In the Text Inspector, choose a standard line spacing (Single, Double, Multiple), or At 
Least or Between from the Line Spacing pop-up menu (below the Line field).

Â Standard line spacing:  The space between lines is proportional to font size. Use this 
when the relative distance between ascenders (parts of letters that extend to the 
top of the line) and descenders (parts of letters that extend below the line) should 
remain fixed.

Â At Least:  The distance from one line to the next will never be less than the value 
you set, but it may be larger for larger fonts in order to prevent overlapping text 
lines. Use this when the distance between lines should remain fixed, but overlap is 
not desired if the text gets large.

Â Between:  The value you set increases the space between the lines, instead of 
increasing the height of the lines. By contrast, double-spacing doubles the height of 
each line.

Click the text below the 
Line field and choose a 
line spacing option.
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To adjust the amount of space before or after a paragraph:
1 Place the cursor in the paragraph you want to change, or select several paragraphs.

2 In the Text Inspector, drag the Before Paragraph or After Paragraph slider. You can also 
type a specific amount (5 pt, for example) in the text box.

Note:  Spacing before a paragraph does not appear if the paragraph is the first one 
following a layout break, or if it’s the first paragraph in a text box, shape, or table cell. 
Spacing after a paragraph does not appear if it’s the last paragraph before a layout 
break. To set spacing around text in boxes, shapes, and table cells, use the Inset 
Margin control, described in “Formatting a Text Box or Shape” on page 103.

To adjust the amount of space between characters:
1 Place the cursor in the word you want to change, or select a block of text.

2 In the Text Inspector, drag the Character slider. 

Dragging the slider to the left brings the letters closer together; dragging it to the 
right moves them farther apart.

To change text color:
1 Select the word or words you want to change.

2 In the Text Inspector, click the color well.

3 In the Colors window, select a color. To read about using the Colors window, see 
“Using Color and Image Fills” on page 145.

Changes made to text color in the Text Inspector will override text color changes 
made in the Font panel, and vice versa. (To read about the Font panel, see “Using the 
Font Panel to Format Text” on page 80.)

Using the Format Menu to Align Text
To adjust horizontal text alignment in the main document body, you can use the Text 
submenu of the Format menu. If you want to adjust the spacing between individual 
characters or lines, or if you want to align text vertically within a text box, shape, or 
table cell, you must use the Text Inspector. The Text Inspector is also useful if you must 
frequently change text alignment and spacing, because you can keep it open on your 
screen as you work.

To align body text left, center, right, or justified:
m Choose Format > Text > [Align Left, Center, Align Right, Justify].
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Â Align Left:  Begins each line of text against the left margin of a page or column, or 
the left edge of an object

Â Center:  Sets the center of each line of text at the center of a page, column, or 
object

Â Align Right:  Sets each line of text against the right margin of a page or column, or 
the right edge of an object

Â Justify:  Spaces characters in each line so that the lines reach both the left and right 
margins of a page or column, or edges of an object

If you want to indent the first line of text in a paragraph, or learn how to undo 
paragraph indenting, see “Setting Paragraph Indents” on page 95.

Setting Tab Stops to Align Text
If you want to add, delete, or change tab stops in the document body, or inside a fixed 
text box, table cell, or shape, you can do this by using the Tabs pane of the Text 
Inspector, or by manipulating the tab icons directly on the rulers. It may be quicker to 
format a few tab stops by using the rulers, but if you want to create many precisely 
placed tabs, the Text Inspector makes it easy. Both of these methods are described 
below.

Note:  Don’t use these instructions to set tab stops in an ordered list (outline). To learn 
how you can modify the indentation levels for lists, see “Creating Bulleted or 
Numbered Lists and Outlines” on page 96.

Setting Tab Stops Using the Rulers
Some text styles have default tabs already set. You can see the tab icons on the 
horizontal ruler when you click View in the toolbar and choose Show Rulers (or 
choose View > Show Rulers) and select some text on a page.
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You can place tab stops where you want them in the document body or in text boxes.

To set a new tab stop:
m Click the horizontal ruler where you want to set the tab stop.

To change the tabs:
1 Select the text you want to adjust.

2 On the horizontal ruler, drag the blue tab icons to change the location of the tab 
stops.

To change a tab to a different type:
m Control-click the tab icon and choose an option from the shortcut menu. Or double-

click the tab icon in the ruler repeatedly until the type of tab you want appears.

Here is a description of what each tab type does:

Â Left Tab:  Aligns the left side of text with the tab stop

Â Center Tab:  Places the center of text at the tab stop

Â Right Tab:  Aligns the right side of text with the tab stop

Â Decimal Tab:  For numbers, aligns the decimal point with the tab stop (You can set 
a different text character to serve as the decimal tab character; see “Setting Tab 
Stops Using the Text Inspector” below.)

To delete a tab from the ruler:
m Drag it off the ruler.

Blue tab icons appear on 
the horizontal ruler when 
you select tabbed text 
on a page.

Decimal tab
Right tab

Center tab
Left tab

Choose from among 
these tab types.
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Setting Tab Stops Using the Text Inspector
Every document has built-in tab stops, usually spaced half an inch apart across the 
page. In the Tabs pane of the Text Inspector, you can change the default tab spacing 
or the decimal tab character for the entire document. You can also set additional tab 
stops in any paragraph, or add a leader line, so that when you press the Tab key, a 
dashed or dotted line extends across the tabbed distance. This is useful, for example, 
for inserting dashed lines between a chapter title and its page number in a table of 
contents.

To open the Tabs pane of the Text Inspector:
1 Choose View > Show Inspector (or click Inspector in the toolbar).

2 Click the Text Inspector button, and then click Tabs.

Set how far you want the 
first line of each 
paragraph to indent.

If you want to indent a 
paragraph relative to the 
page margins, specify 
how far to indent it.

Add or remove tab stops 
from the column.

Choose a leader line for 
any tab stop selected in 
the Tab Stops column.

For a tab stop selected in 
the Tab Stops column, 
select how you want the 
text to align.

Type a new character to 
change the decimal tab 
character.

Set the default distance 
between tabs.
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To change how far apart tabs are by default:
m In the Tabs pane of the Text Inspector, type a value in the Default Tabs field.

To create new tab stops:
1 Place the insertion point in the paragraph (or on the first line) where you want to set 

the tab stops.

2 Click the Add (+) button in the bottom-left corner of the Tabs pane of the Text 
Inspector. A tab stop setting appears in the Tab Stops column.

3 To change tab spacing, double-click the tab stop in the column and type a new value.

4 With the tab stop selected, select how you want text to align at the tab stop (Left, 
Center, Right, or Decimal Alignment).

5 If you want to add a dashed or dotted line to the tab, choose a line style (or choose 
None) from the Leader pop-up menu.

To use a different decimal tab character for the document:
m Type a new character in the Decimal Tab Character field.

To delete a tab stop:
m Select it in the Tab Stops column, and click the Delete (-) button.

Setting Paragraph Indents
Paragraphs can be formatted so that the first line is indented (or overhangs) as far as 
you want. You can do this in the Tabs pane of the Text Inspector.

To set the first line indent (or overhang) for a paragraph:
1 Select the paragraph or paragraphs you want to change.

2 In the Tabs pane of the Text Inspector, type values in the First Line and Left fields 
under Paragraph Indents. If you want the first line to be indented relative to the 
second line of text, the First Line value should be higher than the value in the Left 
field. If you want the first line to overhang the left side of the paragraph margin, the 
value in the First Line field should be lower than the value in the Left field.

You can set off a paragraph by assigning it different indents than the rest of the 
document. This is useful, for example, when including a long quote in your text. You 
can do this by setting paragraph indents in the Tabs pane of the Text Inspector, or by 
dragging the margin icons in the document ruler.
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To set paragraph indents using the Tabs pane of the Text Inspector:
1 Select the paragraph or paragraphs you want to change.

2 Enter a value in the Left field under Paragraph Indents. 

3 Enter a value in the Right field under Paragraph Indents.

To change paragraph indents using the rulers:
1 Click View in the toolbar and choose Show Rulers (or choose View > Show Rulers).

2 To change the right indent, drag the right indent icon (downward blue triangle on the 
right side of the horizontal ruler) to the position where you want the right edge of the 
paragraph to end.

3 To change the left indent, drag the left indent icon (downward blue triangle on the 
left side of the ruler) to where you want the left edge of the paragraph to begin. 

To change the left margin independently from the left indent, hold down the Option 
key as you drag.

4 To change the first line indent, drag the first line indent (blue rectangle) to where you 
want the first line to start. 

Â If you want the first line to remain flush with the left margin, make sure the 
rectangle aligns with the left indent icon. 

Â If you want to create a hanging indent, drag the rectangle to the left of the left 
indent icon.

Creating Bulleted or Numbered Lists and Outlines
Pages provides pre-formatted bullet and numbering styles for creating simple or 
ordered lists (outlines).

Creating Bulleted or Numbered Lists
Bulleted and numbered lists are simple lists without nested hierarchies of information 
like you would see in an outline.

First line indent Right indent

Left indent
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To create a bulleted or numbered list:
1 Place the cursor in the first line where you want to begin typing list text.

2 Click List in the toolbar, and then choose the list style that you want to use.

You can also choose a list style in the Styles drawer. Click View in the toolbar and 
choose Show Styles Drawer (or choose View > Show Styles Drawer), and then select 
the list style you want. (If you don’t see list styles in the Styles drawer, click the button 
in the lower-right corner of the drawer to make them appear.)

Each template may have different list styles. Most templates provide at least the 
following list styles for simple bulleted or numbered lists:

Â Bullet:  Provides basic, round bullets

Â Numbered List:  Uses Arabic numerals

3 Type your text, pressing Return wherever you want to begin a new bulleted (or 
numbered) line.

4 To include subtext under a bulleted or numbered point, press Shift-Return (called a 
line break) to start the next line without bulleting or numbering it. Press Return again 
at the end of the line to return to a new bulleted or numbered line.

5 When you are finished typing your list, click List in the toolbar and choose None, or 
click None in the Styles drawer.

You can create your own list styles using other text or image bullets provided by 
Pages, or using your own image as a bullet. Numbered lists can also have varied 
numbering styles, or use letters instead. To learn about modifying or creating your 
own list style, see “Modifying and Creating New List Styles” on page 117.

Creating Ordered Lists (Outlines)
Some list styles are formatted to create ordered lists (or outlines). For example, the 
Harvard list style provides different numbering styles for each indent level in your list, 
allowing you to create a hierarchy of information.

Click to make list styles 
appear in the Styles 
drawer.

Select a list style to apply 
it to selected text.
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To create ordered lists (outlines), use the Harvard or Legal list styles.

To create an outline:
1 Place the cursor in the first line where you want to begin typing list text.

2 Click List in the toolbar, and then choose Harvard or Legal. You can also click View in 
the toolbar and choose Show Styles Drawer (or choose View > Show Styles Drawer) 
and select a style. (If you don’t see list styles in the Styles drawer, click the button in 
the bottom-right corner of the Styles drawer. For more information, see “Modifying 
and Creating New List Styles” on page 117.)

3 To indent text to the next list indentation level, click the right Indent Level arrow 
button in the List pane of the Text Inspector (or choose Format > Text > Increase List 
Indent Level).

4 To return to the previous list indent level, click the left Indent Level arrow in the List 
pane of the Text Inspector (or choose Format > Text > Decrease List Indent Level).

Note:  To quickly indent selected text to a higher or lower indent level, you can use 
keyboard shortcuts:

Â Command-right bracket (]):  Increases the indent level of selected text

Â Command-left bracket ([):  Decreases the indent level of selected text

You can also add the following buttons to the Pages toolbar (see “The Toolbar” on 
page 30):

Â Increase:  Increases the indent level of selected text

Â Decrease:  Decreases the indent level of selected text

You can also click and hold a number, and then drag to the right, to the left, down 
and to the right, or down and to the left.

5 To include subtext under an outline point, press Shift-Return to start the next line 
without numbering it. Press Return again at the end of the line to start a new 
numbered line.
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Note:  If you type regular body text paragraphs between outline points, or add or 
delete text between outline points, and the numbering gets lost, select the text with 
incorrect numbering, and then select “Continue from previous” in the Tabs pane of the 
Text Inspector to make the numbering flow continuously. If you need discontinuous 
numbering, select “Start at” and type the number where you want the numbering to 
begin, and then press Return. For more information, see “Modifying and Creating New 
List Styles” on page 117.

6 To return to regular paragraph text at the end of your list, click List in the toolbar and 
choose None, or select None in the Styles drawer. If the text insertion point is 
indented, press Command-left bracket ([) to return to indent level 1, where you can 
begin typing the regular paragraph text.

Creating Callouts, Sidebars, and Highlighted Text
Callouts and sidebars are used to make text stand out from the main body of text in a 
document. Pages offers at least three simple ways to create highlighted text:

Â Adding text to text boxes

Â Adding a background (or fill color) to paragraphs

Â Typing text in shapes

You can also use table cells to hold callouts. To read about working with tables, see 
Chapter 8, “Creating Tables.”

Adding Text Boxes
You can add text boxes to create rectangular blocks of text anywhere on your page. 
You can format text inside a text box as you would any other text—changing colors, 
adding shadows, applying styles, and so on.

Text boxes are created as “fixed” text boxes, which means they are anchored to a 
position on the page. Body text on the page will flow around them.

To add a fixed text box:
1 Click anywhere outside the text areas of your document so that the insertion point is 

not visible.

2 Click Objects in the toolbar, and then choose Text (or choose Insert > Text). A text box 
appears on the page.
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3 Press Command-Return to select the text box, and then drag it to position it where 
you want on the page.

4 Click inside the text box to place the insertion point and type to enter text. The text 
box does not grow automatically if you enter too much text.

5 Drag the selection handles to resize the text box and reveal any hidden text. (Or you 
can create linked text boxes so that the overflow text flows continuously into another 
text box. To read about linked text boxes, see “Linking Text Boxes,” next.)

Note:  To lock the text box to the page so it doesn’t accidentally get moved as you 
work, choose Arrange > Lock.

When you click away from a text box, it’s still there, even though you can’t see it. You 
can click where it was added to view it, or click View in the toolbar and choose Show 
Layout.

To learn about changing the spacing between the text and the inside of the text box 
and about changing the look of a text box, see “Formatting a Text Box or Shape” on 
page 103. 

To create a text box with text copied from your document:
1 Select the text you want, and then choose Edit > Copy.

2 Click anywhere outside the text areas of the document, and then choose Edit > Paste. 
A text box is created, which you can format the way you want.

Linking Text Boxes
If the text you type doesn’t fit in a fixed text box, you can create a linked text box so 
that the text flows from one text box to another. Whenever you edit or format the text 
in the first text box, the linked text box is also affected. Linked text boxes can be 
positioned separate from each other in the document.

To make a linked text box:
1 Create a fixed text box as described above (see “To add a fixed text box:” on page 99).

2 Position and resize the text box as you want, and then type text in it.

When the text box is too full, press Command-Return to select it. A clipping indicator 
appears at the bottom of the text box, indicating that the text extends beyond the 
bottom of the box.
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3 Click the blue square on the right side of the box to create a linked text box.

The new text box has a solid blue square on its left side. This indicates that this text 
box is linked to a previous one.

4 Drag the text boxes to reposition them. The flow of the text inside the boxes always 
follows the order in which the boxes were created, regardless of where you position 
them in the document.

To move linked text boxes:
1 Select all of them, then choose Edit > Copy.

An open blue square on 
the left indicates there are 
no text boxes linked before 
this one.

A clipping indicator shows 
the text extends beyond the 
text box.

An open blue square on 
the right indicates there 
are no text boxes linked 
after this one. Click it to 
create a linked text box.

A filled blue square on 
the right indicates this 
text box is linked before 
another one.

An open blue square 
indicates this text box is 
the last in this series.

A filled blue square on the 
left indicates this text box is 
linked to a previous one.



102 Chapter 4    Formatting Text and Paragraphs

 

2 Select the destination point and choose Edit > Paste.

Note:  If you copy and paste a single linked box, you will create a single unlinked text 
box, identical to the one you copied.

To select only the text in all the linked text boxes:
m Select text in the first box, and then press Command-A.

Setting Paragraph Fill Colors
For some designs, it may be easier to highlight text by placing a paragraph fill color 
behind the text. When you place a paragraph fill color behind text, the color extends 
between the layout margins and moves with the text.

To place a paragraph fill color behind text:
1 Select the paragraph or paragraphs to which you want to add the fill color.

2 Click Inspector in the toolbar (or choose View > Show Inspector), click the Text 
Inspector button, and then click More.

3 In the More pane of the Text Inspector, select the Paragraph Fill checkbox to place a 
fill color behind the text.

4 Click the Fill color well and select a color in the Colors window (for information about 
the Colors window, see “Using Color and Image Fills” on page 145).

Putting Text Inside a Shape
If you want to create callouts or sidebars that are not rectangular, you can place text 
inside a shape. All shapes, except lines, can contain text.

To add text to a shape:
1 Place a shape where you want it on the page. (To learn about adding shapes, see 

“Adding Shapes, Tables, and Charts” on page 125.)

2 Double-click the shape and type the text you want. If the text extends beyond the 
border of the shape, a clipping indicator appears.

Select a fill color.

Select to place a fill 
color behind text.
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3 To resize the shape, select it and drag the selection handles. (If the insertion point is 
inside the shape, press Command-Return to get out of text editing mode and select 
the shape.)

You can format the text within a shape, but you cannot link shapes.

You can rotate a shape while keeping its text horizontal. Instructions are on page 134.

To add text to a shape that’s part of a group:
m Double-click in the text area of any shape in the group. If you resize the group, 

everything resizes except for the text. Of course, you can still select text and change 
its font size. 

See “Grouping and Locking Fixed Objects” on page 135 for details about grouping 
objects.

Formatting a Text Box or Shape
Use the Graphic Inspector to format borders, shadows, and opacity for text boxes or 
shapes. For more information about setting object properties, see Chapter 7, 
“Changing Object Properties.”

Use the Wrap Inspector to set how you want the text on the page to wrap around a 
text box or shape. For more information about setting text wrapping around an 
object, see “Wrapping Text Around an Object” on page 136.

You can create columns in a text box or rectangle by selecting the text box or 
rectangle and choosing the number of columns you want, just as you would add 
columns to the document body. For more information about creating and formatting 
columns, see “Creating Columns” on page 62. You can also place shapes, images, and 
charts inside text boxes and shapes, and you can add tables inside text boxes. Objects 
added inside text boxes and shapes can only be added as inline objects. To read 
about adding inline objects, see “Working With Graphics” on page 123.

The clipping indicator shows 
the text extends beyond the 
borders of a shape.
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You can change the amount of space between text and the inside border of the text 
box, shape, or table cell. This measurement is called the inset margin. The amount of 
space you specify is applied equally around the text on all sides.

To set the spacing between text and the inside of a text box, shape, or table cell:
1 Select the text box, shape, or table cell. (If the insertion point is inside the object, 

Command-Return to get out of text editing mode and select the object.)

2 Click Inspector in the toolbar (or choose View > Show Inspector), click the Text 
Inspector button, and then click Text.

3 In the Text pane of the Text Inspector, drag the Inset Margin slider to the right to 
increase the space between text and the inside border of the object, or type a 
number in the Inset Margin box and press Return. You can also click the arrows to 
increase and decrease space.

Specify how much space 
there is around text inside a 
text box, shape, or table cell.
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5 Working With Styles

This chapter explains how to apply paragraph, 
character, and list styles to quickly and consistently 
change the appearance of text. It also describes 
how to modify existing styles, or create your own.
As you write and format your document, you may want to create different looks for 
different types of text and paragraphs and use them consistently throughout your 
document. For example, you may want to have all top-level headings use the same 
font, color, and line spacing, or you may want all callout text or photo captions to 
have the same look. Applying consistent styles is also important if you’re creating a 
table of contents (to learn more about creating a table of contents, see “Using a Table 
of Contents” on page 76).

The simplest way to make sure that text is consistently formatted is to apply styles. 
Templates include a variety of styles that are suited to the type of document you are 
working in. The style names, such as “Heading,” “Body,” or “Caption,” suggest where 
the style should be used. If you are using a template, you can apply the preset styles 
where you need them.

When you import a document from Microsoft Word, any styles it contains are 
imported into the Pages document and can then be used like any other styles created 
within Pages.
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About Paragraph, Character, and List Styles
Pages provides three different kinds of preformatted styles that you can apply to 
text for different purposes.

Â Paragraph styles:  These styles can be applied only to entire paragraphs (chunks of 
text that end with a carriage return), not to individual words within paragraphs. 
These include styles for headings, body text, callouts, captions, headers, and 
footers. Paragraph styles can include specifications for font, size, text color, 
character and line spacing, text shadow, background color, indentation and 
margins, tab settings, and more. If you want to create a table of contents for your 
document, you need to use paragraph styles when creating headings in your 
document. Most documents will use a greater variety of paragraph styles than 
character or list styles.

Â Character styles:  You can apply a character style to any group of characters, 
including individual words or groups of words, or letters within a paragraph. 
Common examples of character styles are different colors or font sizes used to 
emphasize individual words or phrases. Character styles can be applied to text 
within a paragraph without changing its paragraph style.

Â List styles:  When you want to create simple lists or an outline, you can apply list 
styles to your text. List styles automatically format your text with bullets or 
numbering, depending on which kind of list style you choose. You can also indent 
paragraphs as a block by changing their list indent level (see “Creating Bulleted or 
Numbered Lists and Outlines” on page 96). Some list styles are very basic, for 
simple lists; others, such as Harvard and Legal, allow you to create outlines.

All three of these style types can be seen in the Styles drawer. For more information 
about the Styles drawer, see “The Styles Drawer” on page 27.
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Applying Styles
The easiest way to apply paragraph, list, and character styles is to use the Styles 
drawer.

You can also use buttons in the toolbar:
Â To apply list styles, click the List button.

Â You can add the Character button to the toolbar so that you can add or change 
character styles from the toolbar. To learn about customizing the toolbar, see “The 
Toolbar” on page 30.

To apply a style to a paragraph:
m Select the paragraph or paragraphs you want to change, or select an entire text box 

or shape that contains text. Then do one of the following:

Â Click the Style button in the toolbar and choose the style you want to apply.

Â Click Style in the toolbar and choose Show Styles Drawer (or choose View > Show 
Styles Drawer) to open the Styles drawer. In the Styles drawer, select the style you 
want to apply.

In the Styles drawer, 
select the style you 
want to apply.
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To apply a character style:
1 Select the word or words you want to change.

2 Click Style in the toolbar and choose Show Styles Drawer (or choose View > Show 
Styles Drawer) to open the Styles drawer.

3 In the Styles drawer, select the character style you want to apply. If you don’t see 
character styles, click the button in the bottom-right corner.

To apply a list style:
1 Place the cursor wherever you want to begin typing your list, and then do one of the 

following:

Â Click the List button in the toolbar and choose the style you want to apply.

Â Click Style in the toolbar and choose Show Styles Drawer (or choose View > Show 
Styles Drawer) to open the Styles drawer. In the Styles drawer, select the list style 
you want to apply. If you don’t see the list styles, click the button in the bottom-
right corner.

2 Type your list, pressing Return to begin each new bulleted or numbered point.

Importing Styles From Another Pages Document
You can import styles that have already been defined in another Pages document 
without importing the document’s content.

To import styles:
1 Choose Format > Import Styles.

2 Select the document that contains the styles you want to import, and click Open.

3 Select the styles you want to import in the dialog. Hold down the Command key as 
you click the style names to select multiple styles, or click Select All.

Click to show list styles.

Click to show 
character styles.
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4 To replace styles in your document that have the same name as the styles you are 
importing, select the “Replace duplicates” checkbox. Note that replacing a style will 
affect any text that uses this style, even text within locked objects.

If an imported style has the same name as a style in the open document and you do 
not select the “Replace duplicates” checkbox, a number is appended to the name of 
the imported style. For example, if you copy a style called “Body” to a document that 
already contains a “Body” style, the imported style will be named “Body 2.”

5 Click OK.

Imported styles will be available in the Style pop-up menu in the toolbar and in the 
Styles drawer of your document.

Understanding Style Overrides
When you make changes to individual text attributes—for example, using the Font 
command in the Format menu to apply italics to a paragraph of text formatted with 
Body style—without selecting a new style, you have created a style override. That is, 
the text remains formatted in its original style (Body), but you have applied changes 
(italics) on top of the default style attributes. When you select text to which you have 
applied style overrides, the arrow next to the style name in the Styles drawer is red. 
(The arrow next to a paragraph style name also appears red if you have selected text 
with a character or list style applied.)

Overrides can occur when you change the font, typeface, size, or color of text, or 
apply the text formatting options in the Text submenu of the Format menu, in the 
Font panel, or in the Text Inspector.

If you apply style overrides to some text and then change your mind, you can easily 
return the text to the default attributes of the paragraph style.

When the arrow next to a style 
name is red, it means that you 
have applied changes to this 
style in the selected text.
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To remove style overrides:
1 Click Style in the toolbar and choose Show Styles Drawer (or choose View > Show 

Styles Drawer) to open the Styles drawer. 

2 Select the text you want to change.

3 In the Styles drawer, click the arrow to the right of the selected style and choose 
Revert to Original Style (or double-click the style name). The selected text takes on the 
default attributes of the selected style.

Finding and Replacing Styles
If you want to change the look of your document by changing all instances of a style 
to a different one, you can find and replace the style throughout the document 
without searching for specific text.

To find and replace a style:
1 Click Style in the toolbar and choose Show Styles Drawer (or choose View > Show 

Styles Drawer) to open the Styles drawer. 

2 In the Styles drawer, rest the pointer over the name of the style that you want to 
replace and click the arrow to the right of its name.

3 Choose Select All Uses of [style name]. All instances of the style are selected 
throughout the document.

4 Select the name of the style to which you want to change the selected text.

You can also copy the paragraph or character style of selected text and apply it to 
different text in the same document by pasting it.

To copy and paste a paragraph or character style:
1 Place the insertion point in a paragraph or word whose style you want to copy, and 

then choose Format > Copy Paragraph Style or Copy Character Style.

2 Place the insertion point in a paragraph or word you want to modify, and then choose 
Format > Paste Paragraph Style or Paste Character Style.

The text takes on the new style, but its content is not altered.

If you frequently copy and paste styles, you can add the Copy Style and Paste Style 
buttons to the toolbar. To learn about customizing the toolbar, see “The Toolbar” on 
page 30.
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Modifying and Creating New Paragraph Styles
A paragraph is any block of text followed by a Return character. For these blocks of 
text—including headings, body text, footers, callout text, and so on—you can define 
the appearance, tab spacing, margins, background color, page breaks, and more.

If you don’t find a paragraph style with exactly the look you want in the Pages 
templates, you can modify an existing style, or create a new style.

To modify a paragraph style:
1 Click Style in the toolbar and choose Show Styles Drawer (or choose View > Show 

Styles Drawer) to open the Styles drawer. Select the paragraph style that most closely 
matches the style you want to design, or select Free Form.

2 Type some text and format it to look the way you want. (For information about 
formatting the look of text, see “Formatting Text Size and Appearance” on page 79.)

3 Set the text alignment, character and line spacing, and the spacing before and after 
the paragraph in the Text pane of the Text Inspector. (For more information, see 
“Setting Text Alignment, Spacing, and Color” on page 88.)

4 If the paragraph style requires special tab stops, set them in the Tabs pane of the Text 
Inspector. (For more information, see “Setting Tab Stops to Align Text” on page 92.)

5 If you want the paragraph style to be indented relative to the page margins, set the 
paragraph indents in the Tabs pane of the Text Inspector.

6 Click More in the Text Inspector to select more formatting options, as described 
below:

Set the first line indent.

Set the right indent for 
the paragraph.

Set the left indent for 
the paragraph.



112 Chapter 5    Working With Styles

 

Â Following Paragraph Style:  If you want a particular paragraph style to always 
follow the current style when you press the Return key, choose the style from the 
pop-up menu. For example, you might create a photo caption style that should 
always be followed by a byline style.

Â Pagination & Break:  Select how the paragraph can break across pages. You can 
specify that lines of this paragraph should always stay together on the same page, 
should stay with the following paragraph, or can only appear at the top of a page. 
The last two of these are particularly useful for heading styles. Select the checkbox 
labeled “Prevent widow & orphan lines” to prevent leaving individual lines on the 
following or previous pages.

Â Language:  Choose a language from the pop-up menu to specify the language used 
to spell-check this paragraph. If your document will include quotes or sections in 
another language, you can specify a language for the spelling dictionary used in 
those paragraphs. The spelling dictionary determines how words are spelled and 
hyphenated.

Choose a paragraph style 
to follow the current one 
when you press Return.

Select options to determine 
how the paragraph breaks 
across pages.

Choose a language for the 
spelling dictionary to use.

Add a background 
color to the paragraph.

Remove automatic 
hyphenation or ligatures, 
if they are selected for 
the document.

Set the text above or 
below the surrounding 
text.
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Â Remove hyphenation for paragraph:  Select the checkbox if you want to turn off 
automatic hyphenation for this paragraph style in a document that has automatic 
hyphenation turned on. (To turn it on for the document, use the Document 
Inspector. See page 59.)

Â Remove ligatures:  A ligature is a stylish flourish between letters or at the end or 
beginning of lines. Ligatures are used by some fonts to combine two or more text 
characters into one glyph. Select the checkbox if you don’t want to use ligatures in a 
selected paragraph that has ligatures turned on. (To turn it on for the document, 
use the Document Inspector. See page 59. If any text is selected when you remove 
ligatures, it will be applied to the selected text as a style override, unless you 
complete step 7, below.)

Â Baseline Shift:  A negative number places the text lower than the surrounding text. 
A positive number places the text higher than the surrounding text. Enter a number 
in the field. (If any text is selected when you set the baseline shift, it will be applied 
to the selected text as a style override, unless you complete step 7, below.)

Â Paragraph Fill:  Select the checkbox and click the color well to make a color 
background appear behind the paragraph. For example, you can create a heading 
style that presents white text against a dark background. The color extends from the 
left paragraph margin to the right.

7 In the Styles drawer, click the arrow to the right of the paragraph style name, and 
choose one of the following:

Â Redefine Style From Selection:  Redefines the existing paragraph style for the 
whole document.

If you choose this, your formatting changes will apply to all other instances of this 
style throughout the document. (But any character styles that have been applied 
will not be affected.)

Â Create New Paragraph Style From Selection:  This doesn’t alter the existing style, 
but creates a new style based on the formatting choices you’ve made in the 
previous steps.

If you select this, type a name for the new style, and then click OK.
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To create a new paragraph style from scratch:
1 Select a paragraph of text.

2 Click Style in the toolbar and choose Show Styles Drawer (or choose View > Show 
Styles Drawer) to open the Styles drawer. In the Styles drawer, select Free Form at the 
top of the Paragraph Styles list.

3 Format the selected paragraph text so that it looks the way you want. (To learn about 
formatting text, see Chapter 4, “Formatting Text and Paragraphs.”)

4 Press and hold the Add (+) button at the bottom of the Styles drawer and choose 
Create New Paragraph Style From Selection.

5 Type a name for the new style in the dialog that appears.

6 If you don’t want to apply the new style to the selected text, deselect the checkbox 
labeled “Apply this new style on creation.”

7 Click OK.

Styles you modify or create are available only in the document you’re working in. 
However, they can be imported into other documents or templates. To learn how, see 
“Importing Styles From Another Pages Document” on page 108

Modifying and Creating New Character Styles
Character styles are formatting attributes that are applied to a set of text characters 
(such as a word or a group of words or letters) without changing the style of the 
entire paragraph. Character styles define the look of the text, including font, size, 
color, character spacing, ligature usage, baseline shift, and language. If you can’t find a 
character style that meets your needs, you can modify one of the existing character 
styles or create a new one.

To modify a character style:
1 Click Style in the toolbar and choose Show Styles Drawer (or choose View > Show 

Styles Drawer) to open the Styles drawer, and select the character style that most 
closely matches the style you want to design, or select None.

Press and hold to 
create a style.



Chapter 5    Working With Styles 115

 

If character styles are not visible in the Styles drawer, click the button with the 
underlined character in the bottom-right corner of the drawer.

2 Type some text and then apply some attributes:

Â Select a font typeface and size. For more information, see “Using the Font Panel to 
Format Text” on page 80.

Â Set the text color. For information about changing the color of text, see page 91.

Â Set the character spacing. For more information about setting character spacing, see 
“Setting Text Alignment, Spacing, and Color” on page 88.

Â Set the baseline shift, ligature, and language in the More pane of the Text Inspector. 
For more information, see “Modifying and Creating New Paragraph Styles” on 
page 111.

3 In the Styles drawer, click the arrow to the right of the character style name, and 
choose one of the following:

Â Redefine Style From Selection:  Redefines the existing character style for the whole 
document.

If you choose this, your formatting changes will apply to all other instances of this 
style throughout the document.

Â Create New Character Style From Selection:  This doesn’t alter the existing style, 
but creates a new style based on the formatting choices in the previous steps.

If you select this, you can choose which attributes you want to include as part of the 
new character style. Click the disclosure triangle below the Name field in the “New 
character style” dialog, and then select the attributes you want. Type a name for the 
new style, and then click OK.

Click to show list styles.

Click to show 
character styles.
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To create a new character style from scratch:
1 Select some text.

2 Format the selected text so that it looks the way you want. You can set the font, text 
size, text color, typeface (such as italic or bold), character spacing, and baseline shift. 
(To learn about formatting text, see Chapter 4, “Formatting Text and Paragraphs.”)

3 Press and hold the Add (+) button at the bottom of the Styles drawer and choose 
Create New Character Style From Selection from the pop-up menu.

4 Type a name for the new style.

5 If you want to include only some of the attributes you set in the new character style, 
click the disclosure triangle below the Name field, and select the attributes you want.

6 If you don’t want to apply the new style to the selected text, deselect the checkbox 
labeled “Apply this new style on creation.”

7 Click OK.

Click the disclosure triangle 
to show character attributes.

Click to select only those 
attributes that override the 
selected paragraph style.

Select the attributes to 
include in the new 
character style.
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Modifying and Creating New List Styles
List styles are used to create bulleted and numbered lists. You can also create ordered 
lists (outlines) by using a tiered numbered list style, such as Harvard or Legal. If you 
can’t find a list style that meets your needs, you can modify one of the existing list 
styles, or create a new one.

Use the List pane of the Text Inspector to modify or create new list styles. The 
Inspector allows you to choose different bullets or numbering styles (for example, 
Arabic numerals versus Roman numerals). For bullets, you can choose from a variety 
of text symbols or images supplied by Pages, or you can use an image of your own, or 
have no visible bullet at all.

To open the List pane of the Text Inspector:
1 Click the Inspector button in the toolbar (or choose View > Show Inspector).

2 Click the Text Inspector button, and then click List.

Click to advance to the 
next list indent level.

Adjust bullet size and 
position relative to text.

Choose bullets or 
numbering.

Select an image for 
image bullets.

Adjust bullet indentation 
relative to the first 
paragraph indent.

Set the text indent level 
relative to the bullets.
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To modify a bulleted or numbered list style: 
1 Click Style in the toolbar and choose Show Styles Drawer (or choose View > Show 

Styles Drawer) to open the Styles drawer, and select the bulleted or numbered list 
style that best matches the one you want to design. (Make sure the insertion point is 
visible on the page so that you can select a list style.)

If the list styles are not visible in the Styles drawer, click the button with the bulleted 
list at the bottom of the drawer.

2 Choose one of the following bullet or numbering styles from the Bullets & Numbering 
pop-up menu in the List pane of the Text Inspector:

Â No Bullet:  Choose this if you don’t want visible bullets, but you want to be able to 
specify the amount of indentation for levels in an ordered list.

Â Text Bullet:  Choose this to use a text character as the bullet. You can select one 
from the list or type your own characters in the text field. Some fonts provide 
symbols that can be used as interesting bullets. To use them, open the Character 
Palette (choose Format > Font > Show Fonts, then choose Characters from the 
Action pop-up menu). Select the bullet symbol in the Text Inspector, and then 
double-click the symbol of your choice in the Character Palette. Then press the 
Return key.

Click to show list styles.

Select a color for the text bullet.

For text bullets, choose an 
available character or type a 
character in the text field.
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Â Image Bullet:  Choose this to use one of the available image bullets provided by 
Pages, and then select one in the list.

Â Custom Image:  Choose this to use your own image as a bullet. Use the Open dialog 
to locate and select the image file you want to use. (To change the image, click 
Choose or drag a new image into the well.)

Â Number:  Choose this to create a numbered list. You must also choose a numbering 
style. You can choose Arabic or Roman numerals, or letters.

Â Tiered Numbers:  To read about Tiered Numbers, see “To modify a tiered list style 
for ordered lists:” on page 120.

3 Format the bullets.

Â To increase or reduce the size of a bullet, type a number in the Size field. Selecting 
the “Scale with text” checkbox maintains the image-to-text size ratio of the bullets 
even if you later change the font size.

Â To position the bullet symbol higher or lower relative to the text, type a number in 
the Align box (or click the arrows).

For image bullets, 
select one from the list.

For numbered lists, 
choose a numbering 
style.

Restart numbering, or 
continue with previous 
numbering.

Adjust number 
indentation relative 
to page margin.
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Â To set how far the bullets are indented from the margin, type a number in the Bullet 
Indent field. A higher number indents the list further to the right.

Â To set how far text is indented from the bullet, type a number in the Text Indent 
field. A higher number indents the text further to the right.

4 Click Style in the toolbar and choose Show Styles Drawer (or choose View > Show 
Styles Drawer) to open the Styles drawer.

Notice that one of the list styles is highlighted. This is the style that has been applied 
to the selected text. (If the list styles are not visible, click the button in the bottom of 
the Styles drawer.) The triangle to the right of the style name is red, indicating that 
you have applied overrides to the style by modifying it.

5 Click the red arrow to the right of the selected style in the Styles drawer and choose 
one of the following:

Â Redefine Style From Selection:  Redefines the existing list style for the entire 
document.

If you choose this, your formatting changes will apply to all other instances of this 
style throughout the document.

Â Create New List Style From Selection:  This doesn’t alter the existing style, but 
creates a new style based on your formatting choices.

If you select this, type a name for the new style, and then click OK.

To modify a tiered list style for ordered lists:
1 Click Style in the toolbar and choose Show Styles Drawer (or choose View > Show 

Styles Drawer) to open the Styles drawer, and select the ordered list (outline) style 
that best matches the one you want to design. (Make sure the insertion point is visible 
on the page so that you can select a list style.)

Click to show list styles.
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2 Choose Tiered Numbers from the Bullets & Numbering pop-up menu in the List pane 
of the Text Inspector.

3 Choose the numbering or lettering style that you want from the second pop-up 
menu.

4 Click the right indent level arrow to advance to the second list indent level.

5 Choose the numbering or lettering style that you want for the second list indent level.

6 Repeat steps 4 and 5 until you have set numbering or lettering styles for up to nine 
list indent levels.

7 Click Style in the toolbar and choose Show Styles Drawer (or choose View > Show 
Styles Drawer) to open the Styles drawer.

Notice that one of the list styles is highlighted. This is the style that has been applied 
to the selected text. (If the list styles are not visible, click the button in the bottom-
right of the Styles drawer.) The arrow to the right of the style name is red, indicating 
that you have applied overrides to the style by modifying it.

8 Click the red arrow to the right of the list style name, and choose one of the following:

Â Redefine Style From Selection:  Redefines the existing list style for the entire 
document.

If you choose this, your formatting changes will apply to all other instances of this 
style throughout the document.

Click to advance to the 
next list indent level.

Choose Tiered 
Numbers to create an 
ordered list style.
For each list indent 
level, choose a 
numbering style.

For each list indent level, 
set how far you want to 
indent the number and 
its associated text.
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Â Create New List Style From Selection:  This doesn’t alter the existing style, but 
creates a new style based on your formatting choices in the previous steps.

If you choose this, type a name for the new style, and then click OK.

To create a new list style from scratch:
1 Select some text.

2 Click Inspector in the toolbar (or choose View > Show Inspector), click Text to open 
the Text Inspector, and then click List to open the List pane.

3 Format the selected list text so that it looks the way you want. You can select a symbol 
or image to use as a bullet, and a numbering style. Also, you can set the amount of 
indentation for each list indent level, as described above.

To use different bullet or numbering styles for different list indent levels, see the steps 
for modifying an ordered list style, above.

4 Click the Add (+) button at the bottom-left of the Styles drawer and choose Create 
New List Style From Selection from the pop-up menu.

5 Type a name for the new style.

6 If you don’t want to apply the new style to the selected text, deselect the checkbox 
labeled “Apply new style on creation.”

7 Click OK.
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6 Working With Graphics 
and Other Media

This chapter describes basic techniques for adding 
and modifying various media in your documents.
There are several types of graphics and other media you can include in Pages 
documents, including images (like photographs or PDF files), shapes, tables, and 
charts. For documents that will be viewed onscreen, you can also add movies and 
sound.

Working With Graphics
Pages accepts all QuickTime-supported formats, including the following graphics file 
types:

Â TIFF

Â GIF

Â JPEG

Â PDF

Â PSD

Â EPS

Â PICT

In addition, Pages provides the tools to add basic shapes to your documents, such as 
triangles, rectangles, and arrows, as well as versatile tables and charts. Pages also 
includes a tool you can use to create your own shapes. For more information about 
placing simple shapes, tables, and charts, see “Adding Shapes, Tables, and Charts” on 
page 125.
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Fixed Objects Versus Inline Objects
You can place objects in a Pages document so that they’re inline or fixed.

You can convert objects from inline to fixed, and vice versa. To learn how, see 
“Converting Between Fixed and Inline Objects” on page 127.

Text wraps differently around fixed and inline objects. To learn about text wrapping, 
see “Wrapping Text Around an Object” on page 136.

About Inline and Fixed Objects
Inline objects are embedded in the text flow. If you type more text above them, 
they are pushed along as the text grows. The selection handles on the top of inline 
objects are inactive. You cannot drag these handles to resize the object; you can 
only resize it by dragging the active handles.

If you are placing a graphic or shape inside another shape, text box, or table cell, it 
can only be placed inline with the text. Inline images are automatically resized to fit 
within the layout margins of the document. To move an inline object to a different 
position within the text, select it and drag it until you see the insertion point appear 
where you want to drop it.

Fixed objects are anchored to a position on a page within a document section. 
Typing more text on the page does not affect the position of a fixed object, but you 
can drag it to reposition it wherever you want, or resize it.

The top selection 
handles are inactive for 
inline objects.

Drag the active selection 
handles down or to the 
right to resize.

A close-up view of 
inactive selection handle 
(top) and active selection 
handle (bottom).

Drag any of the selection 
handles to reposition or 
resize fixed objects.
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Adding Fixed and Inline Objects
Whether you are bringing graphics into your Pages document from an external 
source, or creating a shape, table, graph, or text box within Pages, you can place the 
graphics in one of the two ways described above:  fixed on the page or inline with the 
text. The sections below describe in detail how to accomplish each of these tasks.

Importing a Graphics or Media File
Imported media files can include images, PDF files, QuickTime movies, or Flash 
animations.

To add an imported file inline with the text, do one of the following:
m Press the Command key, and then drag the image from the Finder or Media Browser 

to the document window until you see the insertion point at the place where you 
want the image to appear. Release the image when you have placed it where you 
want it.

m Place the insertion point wherever you want the image to appear, choose Insert > 
Choose, select the file, and click Insert.

To add an imported file as a fixed object, do one of the following:
m Drag the file from the Finder or Media Browser to the document and position it where 

you want it.

m Click outside the text areas in the document so that no insertion point is visible, and 
then choose Insert > Choose. Select the file and click Insert.

Imported images can be resized and rotated to change their appearance on a page. 
Images can also be cropped (masked). You can also layer graphics, adjust their opacity, 
and add shadows to create interesting visual effects. For more information about 
working with graphics, see the relevant sections in this chapter. To learn about 
adjusting shadow properties and opacity, see Chapter 7, “Changing Object Properties.”

Adding Shapes, Tables, and Charts
Pages supplies tools to build tables and charts within the document. Pages also lets 
you insert and modify predrawn shapes (rectangles, circles, triangles, arrows, and so 
on) that you can use as simple graphics in your document. You can also draw and 
modify your own custom shapes.
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To add a predrawn shape, table, or chart inline with the text:
1 Place the insertion point wherever you want the object to appear in the text flow.

2 Select the object you want to add:

Â For shapes, click Objects in the toolbar and choose a shape from the Shapes 
submenu (or choose Insert > Shape > [shape type]).

Â For tables, click Objects in the toolbar and choose Table (or choose Insert > Table).

Â For charts, click Objects in the toolbar and choose Chart (or choose Insert > Chart), 
and then select a chart type in the Chart Inspector.

To place a fixed predrawn shape, table, chart, or text box:
1 Click anywhere outside the text areas of the document so that no insertion point is 

visible.

2 Select the object you want to add:

Â For text boxes, click Objects in the toolbar and choose Text (or choose Insert > Text).

Â For shapes, click Objects in the toolbar and choose a shape from the Shapes 
submenu (or choose Insert > Shape > [shape type]).

Â For tables, click Objects in the toolbar and choose Table (or choose Insert > Table).

Â For charts, click Objects in the toolbar and choose Chart (or choose Insert > Chart), 
and then select a chart type in the Chart Inspector.

3 Drag the object to wherever you want it to appear on the page.

Note:  You can also Option-click the Objects button in the toolbar. Release the Option 
key, and then choose a shape, Text, Table, or Chart. Drag the crosshair pointer across 
the document window to draw the object wherever you want it. This produces a fixed 
object.

To create and edit your own shapes:
m See “Adding a Custom Shape” on page 158.

To modify text boxes, tables, charts, and predrawn and custom shapes:
m See Chapter 7, “Changing Object Properties,” to learn about using the Graphics 

Inspector to modify the color, opacity, outline, and shadows of text boxes and 
predrawn and custom shapes.

m See “Editing Predrawn and Custom Shapes” on page 160 and “Putting Text Inside a 
Shape” on page 102 for more instructions pertaining to predrawn and custom shapes.
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m See Chapter 8, “Creating Tables,” to learn about using the Table Inspector to change 
the number of rows and columns in a table, and change the table’s design and 
formatting.

m See Chapter 9, “Creating Charts,” to learn about using the Chart Data Editor to add 
data to a chart and the Chart Inspector to change a chart’s style, axes, labels, and 
other attributes.

Converting Between Fixed and Inline Objects
An image that has been imported inline with text can be easily turned into an object 
that’s fixed on the page, and vice versa. To convert between fixed and inline objects, 
use the Wrap Inspector.

To convert between fixed and inline objects:
1 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 

Wrap Inspector button.

2 Select the object you want to convert in the document, and then do one of the 
following:

Â To make the object inline, select “Moves with text” in the Wrap Inspector. 

You can also select the object and choose Edit > Cut. Place the insertion point 
where you want the object to appear, and then choose Edit > Paste.

Â To make the object fixed, select “Fixed on page” in the Wrap Inspector.

To change the way text wraps around the object, use the wrap controls in the Wrap 
Inspector. For more information about text wrapping, see “Wrapping Text Around an 
Object” on page 136.

Using PDF Files as Graphics
If you intend to greatly enlarge or reduce a graphic’s dimensions, consider converting 
it to a PDF file before bringing it into Pages. PDF files don’t lose their crispness when 
they are significantly resized. Other file types may not retain their clarity as well when 
they are enlarged or reduced.
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PDF files also provide a great way to move tabular data from Excel or AppleWorks 
documents into Pages. If you have extensively formatted tables in Excel or an 
AppleWorks spreadsheet that you want to display in your document, you can save the 
spreadsheet as a PDF file and then place that PDF file on a page as you would any 
other external graphics file.

To convert an Excel or AppleWorks file to a PDF file:
1 In your Excel or AppleWorks spreadsheet, select the table range you want to display in 

your document.

2 Choose File > Print.

3 In the Print dialog, choose Save as PDF from the PDF pop-up menu.

4 In the Save dialog, type a name for the PDF file and select a location, then click Save.

To convert a Grab image to a PDF file:
1 Open Grab. It’s in the Applications/Utilities folder.

2 Choose Capture > Selection to select what you want to create an image of.

3 Choose File > Print to save the image as a PDF.

Cropping (Masking) Images
You can crop images without actually changing the image files by masking parts of 
them. The mask contains a window that defines the boundaries of the cropped image. 
This allows you to import full images but display only part of them within the 
document. You can still reposition and resize images that have been masked.

The default mask is a rectangle, which you can resize as required. You can also use a 
shape as a mask.

To crop an image using the default (rectangular) mask:
1 Import the file you want to mask. The image can be placed as a fixed object or an 

inline object (for more information, see “Fixed Objects Versus Inline Objects” on 
page 124).

2 Select the object and choose Format > Mask. A mask appears over the image with a 
resizable “window” in the center.
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3 Drag the window to center it over the part of the image you want to feature. Drag its 
selection handles to resize it.

Â To constrain the window’s proportions, hold down the Shift key as you drag the 
selection handles.

Â To rotate the window, hold down the Command key as you drag the selection 
handles. (To learn more about manipulating objects using the selection handles, see 
“Selecting, Dragging, and Resizing Objects” on page 133.)

4 Double-click the window to make only the masked area visible. The masked image 
has a dotted line around its visible borders.

Drag the selection handles 
to resize the visible portion 
of the image.
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5 Drag the selection handles to resize or Command-drag to rotate the visible portion of 
the image, or drag the entire image to reposition it on the page. Double-click the 
visible portion of the image if you want to view the invisible portion of it. The visible 
part of the image can also be converted to an inline image by selecting “Moves with 
text” in the Wrap Inspector (see “Adding Fixed and Inline Objects” on page 125 for 
more information).

To crop an image using a predrawn or custom shape as a mask:
1 Import the file you want to mask. The image can be either fixed or inline (for more 

information, see “Fixed Objects Versus Inline Objects” on page 124).

2 Add a shape to the document to use for the mask. If the image is inline, the shape 
must be, too. If the image is fixed, the shape must also be fixed. “Adding Shapes, 
Tables, and Charts” on page 125 tells you how to add both kinds of shapes.

3 Select both the image and the shape.

Drag the selection 
handles to resize or 
Command-drag to 
rotate the visible 
portion of the image.
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4 Choose Format > Mask With Shape. 

5 Drag the shape to center it over the part of the image you want to feature. Drag its 
selection handles to resize it.

6 Edit the mask as desired. You can resize, rotate, and move the mask. You can also edit 
the contour of the mask after double-clicking the edge of the shape. See “Drawing 
and Editing Shapes” on page 158 for instructions.

7 Double-click the image or press Return to make the unmasked area invisible. 

8 The visible part of the image can also be converted to an inline image by selecting 
“Moves with text” in the Wrap Inspector (see “Adding Fixed and Inline Objects” on 
page 125 for more information).

To change the portion of a masked image that’s visible:
1 Double-click the masked image.

2 Click the dotted border of the resizable window to select it.

3 Drag the selection handles to resize or Command-drag to rotate the visible portion of 
the image, or drag the window to feature a different part of the image.

To unmask an image:
m Select the object, and then choose Format > Unmask. The full image becomes visible 

again.

If you frequently mask images, you can add the Mask button to the toolbar to work 
more efficiently. To learn about customizing the toolbar, see “The Toolbar” on page 30.

Using the Media Browser
Images in your iPhoto library, music in your iTunes library, and movies in your Movies 
folder are easily accessible using the Media Browser. You can drag images, music, and 
movies directly from the Media Browser to your document or to an image well in one 
of the Inspectors.

To add an image from iPhoto:
1 Click Media in the toolbar (or choose View > Show Media Browser).

2 Choose iPhoto from the Media Browser pop-up menu and select the album you want.
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3 Drag an image thumbnail directly to the Pages document window to place the image 
inline with text or fixed on the page. See “Adding Fixed and Inline Objects” on 
page 125 for instructions.

Drag a thumbnail to an image well in the Text Inspector or Graphic Inspector to use it 
as an image fill or a custom bullet image (see “Using Color and Image Fills” on 
page 145 and “Modifying and Creating New List Styles” on page 117 for more 
information).

To add music from iTunes:
1 Choose iTunes from the Media Browser pop-up menu, and select the playlist you 

want.

2 Drag a sound file to the document window. See “Adding Fixed and Inline Objects” on 
page 125.

To add a movie:
1 Choose Movies from the Media Browser pop-up menu.

2 Drag a movie thumbnail directly to the document window. See “Adding Fixed and 
Inline Objects” on page 125.

Select the album where 
your picture is located.

Choose iPhoto, iTunes, or 
Movies.

Drag a thumbnail to the 
document window or to 
an image well in one of 
the Inspectors.

Search for a file by name.



Chapter 6    Working With Graphics and Other Media 133

 

Note:  To see your movies listed in the Movies pane of the Media Browser, you must 
place them in the Movies folder in the Finder.

Resizing, Moving, and Layering Text or Graphics Objects
You can work with text and graphics by moving them in front or in back of one 
another, and formatting or manipulating them in similar ways.

Selecting, Dragging, and Resizing Objects
Use the selection handles to quickly resize objects. To constrain an object’s 
proportions or set precise values for its size and location, use the Metrics Inspector. To 
learn about using the Metrics Inspector for precise object manipulation, see 
“Changing the Orientation” on page 155, and “Adjusting Size and Position of Objects” 
on page 156.

To move a fixed object:
m Click the object to select it (the selection handles appear), and then drag it.

Avoid dragging the object by the selection handles because you may inadvertently 
resize the object.

To move an inline object, do one of the following:
Â Click the object to select it, and then drag it until the insertion point appears where 

you want the object in the text.

Â Select the object and choose Edit > Cut. Place the insertion point where you want 
the object to appear, and then choose Edit > Paste.

To resize an object:
1 Click the object to select it. 

If text is selected inside the object, you can select the whole object by pressing 
Command-Return.

2 Move the pointer close to a selection handle until it changes to a double-headed 
arrow. For inline objects, only the bottom and right or left corner selection handles 
can be used to resize it.

3 Drag a selection handle to expand or shrink the object.

Â To resize the object from its center, press the Option key as you drag. 
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Â To constrain the object’s proportions as it expands or shrinks, press the Shift key as 
you drag.

For more information about resizing and changing the contour of shapes, see 
“Drawing and Editing Shapes” on page 158.

To rotate an object:
1 Select the object.

2 Hold down the Command key and move the pointer toward an active selection 
handle until it changes to a curved, double-headed arrow.

3 Drag a selection handle to rotate the object.

To rotate a shape but keep its text horizontal:
m After rotating the shape, choose Format > Shape > Reset Bounding Box.

To flip objects horizontally or vertically:
m Select the object, and then choose Arrange > Flip Horizontally or Flip Vertically.

If you frequently flip objects, you can add the Flip Vertical and Flip Horizontal buttons 
to the toolbar. To learn about customizing the toolbar, see “The Toolbar” on page 30.

To move a fixed object in front or in back of text or another object on the page:
1 Select the object you want to move.

2 Choose Arrange > Bring Forward or Send Backward.

3 Repeat step 2 until the object is in the desired layer.

4 To move an object to the very top or bottom of the stack, choose Arrange > Bring to 
Front or Send to Back.

If you frequently layer objects on the page, you can add the Front, Back, Forward, and 
Backward buttons to the toolbar to work more efficiently. To learn about customizing 
the toolbar, see “The Toolbar” on page 30.

To select a fixed object that’s behind text:
m Place the pointer outside the text area and drag across the page until the object’s 

selection handles appear.

Note:  If clicking an object doesn’t select it, or if it has blue selection handles, it’s a 
master object. To read about master objects, see “Placing Master Objects” on 
page 235.
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To select all objects in a document:
Â To select all the fixed objects in a document (excluding objects on the section 

master), click outside the text area and press Command-A.

Â To select all inline objects and text in a text area, place the insertion point in the text 
area and press Command-A.

Grouping and Locking Fixed Objects
You can group fixed objects together so that they can be moved, copied, resized, and 
oriented as a single object. You can edit text associated with a shape or text object in 
a group, but you can’t modify other attributes of individual objects in the group.

You can lock fixed objects to avoid inadvertently moving them as you work. Inline 
objects cannot be grouped or locked.

To group objects:
1 Hold down the Command (or Shift) key as you select the objects you want to group 

on the page. 

Note:  Locked objects can’t be grouped.

2 Choose Arrange > Group. 

To ungroup a grouped object:
m Select the object and choose Arrange > Ungroup.

Note:  A locked group can’t be ungrouped. You must unlock it first.

To lock objects:
1 Hold down the Command (or Shift) key as you select the objects you want to lock.

2 Choose Arrange > Lock.

After you lock individual or grouped objects, you can’t edit them until you unlock 
them.

To unlock an object:
m Select the object and choose Arrange > Unlock.

If you frequently group and lock objects on the page, you can add the Group, 
Ungroup, Lock, and Unlock buttons to the toolbar. To learn about customizing the 
toolbar, see “The Toolbar” on page 30.



136 Chapter 6    Working With Graphics and Other Media

 

Working With Alpha-Channel Graphics
Alpha-channel graphics contain a transparent area where text or other images can 
show through. You can also use alpha channels to create transparency around 
irregularly shaped images, so the image does not have a rectangular white area 
around it. 

When you bring an alpha-channel image into Pages, there’s nothing else you have to 
do to make the transparency work. Just place it, manipulate it, and move it to the 
back or front as you would any other image.

Many PDF, TIFF, and PSD files contain alpha-channel graphics. You can create your own 
alpha-channel images using applications such as Adobe Photoshop, Corel Draw, 
Adobe Illustrator, and Adobe Acrobat. See the instructions that come with the 
application to learn how to create alpha-channel images.

Wrapping Text Around an Object
When you place any object—images, shapes, charts, and so on—fixed or inline with 
the text, you can decide how you want the text to wrap around it. You can choose to 
make the text hug tightly or loosely around the object, or make the text stay only on 
the top and bottom or one side of the object. To set these options, use the Wrap 
Inspector.

To open the Wrap Inspector:
m Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 

Wrap Inspector button.

This image of a 
magnifying glass has an 
alpha channel that allows 
text to show through the 
glass.

The irregular shape of the 
image is surrounded by an 
alpha channel that allows 
text to show through its 
containing rectangle.
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The settings in the Wrap Inspector affect fixed objects and inline objects differently.

To adjust text wrapping around a fixed object:
1 Select the object.

2 Select the checkbox labeled “Object causes wrap” in the Wrap Inspector.

3 Click a button in the Wrap Inspector to select which side of the object you want the 
text to wrap around.

The Wrap Inspector 
button

Select to place an object 
inline with text or fixed 
on the page.

Select to make text wrap 
around the object using 
the buttons below.

Set how much space to 
leave between the object 
and the surrounding text.

Click to make the text 
wrap tightly or loosely 
around the object.

Set the transparency 
percentage at which text can 
be seen through the object.
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4 To make the text wrap more tightly around an object with an alpha channel, click the 
right Text Fit button. To make it wrap more loosely, click the left Text Fit button.

5 Enter a value in the Extra Space field to specify the minimum space you want to leave 
between the object and the surrounding text.

6 If the object has transparent areas (an alpha channel), set the alpha-channel 
percentage at which you want the text to appear through the transparency (for an 
illustration, see “Working With Alpha-Channel Graphics” on page 136).

To adjust text wrapping around an inline object:
1 Select the object.

2 Select the checkbox labeled “Object causes wrap” in the Wrap Inspector.

3 Click a button in the Wrap Inspector to select how you want the object to be placed 
within the text.

Text wraps to left of object.

Text wraps above and 
below the object.

Text wraps to right of object.

Text wraps only around 
right or left side, 
depending on which side 
has more space.

Text wraps around 
the object.

Text wraps around the 
rectangular bounds of 
an object.

Text wraps around an object with 
an alpha channel more tightly.
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4 To make the text wrap more tightly around an object with an alpha channel, click the 
right Text Fit button. To make it wrap more loosely, click the left Text Fit button.

5 Enter a value in the Extra Space field to specify the minimum space you want to leave 
between the object and the surrounding text.

6 If the object has transparent areas (an alpha channel), set the alpha-channel 
percentage at which you want the text to appear through the transparency (for an 
illustration, see “Working With Alpha-Channel Graphics” on page 136).

Including Sound and Movies
You can add sound, movies, and Flash files to your document if it will be viewed 
onscreen as an HTML file or a Pages file. The movie or sound file will play when the 
viewer double-clicks its icon on a document page.

Pages accepts any QuickTime or iTunes file type, including the following:
Â MOV

Â FLASH

Â MP3

Â MP4

Align object to the left, and 
wrap text around the right.

Object is centered 
between lines of text.

Align object to the right, 
and wrap text around 
the left.

Object is aligned left 
between lines of text.

Object is aligned right 
between lines of text.

Center object, and wrap 
text around both sides.
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Â AIFF

Â AAC

Important:  To make sure that the movies and other media can be played and viewed 
when your document is transferred to another computer, in the Save or Save As 
dialog, click Advanced Options, and make sure the checkbox labeled “Copy audio and 
movies into document” is selected.

In the QuickTime Inspector, you can set the playback volume for sound and movies in 
your document, and specify whether to play media files only once through, or repeat 
continuously.

To set media playback preferences:
1 Click Inspector in the toolbar (or choose View > Show Inspector).

2 Click the QuickTime Inspector button.

3 Click the movie to select it, then drag the Volume slider to the right to increase the 
playback volume or to the left to decrease it.

4 Choose a repeat option from the Repeat pop-up menu:

Â None:  Play only once.

Â Loop:  Repeat continuously.

Â Loop Back and Forth:  Play backward and forward continuously.

You can also specify which frame of the movie to display on the page (called the 
“poster frame”) until the movie starts playing.

Set the playback volume.

Set playback repeat options.

Select which frame of the 
movie displays until it 
begins playing.

Use these controls to view 
the movie as you edit your 
document.

The QuickTime Inspector 
button
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To set the movie poster frame:
1 Click the movie to select it.

2 In the QuickTime Inspector, drag the Poster Frame slider until the movie displays the 
image you want.

Adding Hyperlinks and Bookmarks
Hyperlinks and bookmarks are used in documents that will be viewed onscreen, either 
as HTML files or as Pages documents. You can add hyperlinks to jump to another page 
or to open an email message or a URL on the Internet. Use bookmarks to mark 
passages in the document that you want to refer to as you work.

To add hypertext that links to an email message or webpage:
1 Select the text that you want to turn into a hyperlink.

2 Open the Link Inspector, and in the Hyperlink pane, select “Enable as hyperlink.”

3 Type the required information, as shown below.

Â Webpage:  Supply the URL that you want to link to when the hyperlink is clicked. 
The webpage appears in your default web browser when the link is clicked.

Use this type of hyperlink To open Notes

Webpage A page in a web browser Provide the URL of the page 
you want to open.

Email Message A new mail message with the 
specified subject and 
addressee

Type the address of the email 
recipient and a subject line.

Bookmark Another page in the same 
document

Use this feature to navigate 
quickly through the document 
as you work.



142 Chapter 6    Working With Graphics and Other Media

 

Â Email Message:  Supply the message subject line and the email address of the 
intended recipient. The blank email message appears in your default email 
application when the link is clicked.

Pages detects URLs and email addresses automatically as you type, and converts them 
into hyperlinks. You can disable this feature if you want to.

To turn off automatic detection of URLs and email addresses as you type:
m Choose Pages > Preferences, click Auto-Correction, and deselect the checkbox labeled 

“Automatically detect email and web addresses”.

To add bookmarks to your document:
1 Select the text where you want to create the bookmark.

2 Open the Link Inspector, click Bookmark, and click Add (+).

Type the URL that you want to 
link to.

The Link Inspector button

You can edit the hyperlink text 
displayed in the document.

Select to disable all hyperlinks so 
that you can easily edit them.

Type the message subject.

Type the email address of the 
message recipient.

You can edit the hyperlink text 
displayed in the document.
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To edit and use bookmarks:
1 Click Bookmark in the Link Inspector.

2 Click a bookmark in the list to jump to it in the document.

3 Double-click a bookmark in the list to change its name.

4 Click the Name or Page column header to sort bookmarks by name or page number.

5 Click the Add (+) button to add new bookmarks.

6 Select a bookmark in the list and click the Delete (-) button to delete it.

To add a hyperlink that links to a bookmark:
1 Choose Insert > Hyperlink > Bookmark, or create a bookmark in the Bookmark pane of 

the Link Inspector.

2 Open the Hyperlink pane of the Link Inspector.

3 Select the text you want to turn into a hyperlink, and then click the checkbox labeled 
“Enable as a hyperlink.”

4 Choose Bookmark from the Link To pop-up menu.

Click Name or Page to sort the 
bookmark list.

Click Add or Delete to add new 
bookmarks or delete a 
bookmark selected in the list.

Click a bookmark to jump to it 
in the document; double-click it 
to edit its name.
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5 Choose the bookmark you want to link to from the Name pop-up menu.

To disable hypertext for editing:
m Select the checkbox labeled “Make all hyperlinks inactive” in the Hyperlink pane of the 

Link Inspector.

Choose the bookmark name.
You can edit the hyperlink text 
displayed in the document.

Select to disable all hyperlinks so 
that you can easily edit them.
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7 Changing Object Properties

This chapter describes more advanced features for 
enhancing graphics and other objects in your 
document.
You can directly manipulate object properties such as color, line style and thickness, 
shadow, opacity, and orientation using the Inspectors and the Colors window. You can 
adjust the brightness, color, and other properties of images. You can also draw custom 
shapes and modify both predrawn and custom shapes. This chapter tells you how.

Using Color and Image Fills
You can create interesting effects with color in Pages. A shape can be filled with solid 
color, color gradients, or even with an image, such as a photo or other graphic. 

You can also adjust an object’s opacity (transparency). You can even use fill and 
opacity effects to modify individual bars or pie wedges in charts.

Selecting Colors
You use the Colors window to select color for text, shapes, backgrounds, and shadows 
in Pages.

To open the Colors window:
Â Click Colors in the toolbar (or choose View > Show Colors).

Â Click a color well in one of the Inspectors.
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You can use the color wheel in the Colors window to select colors. The color you 
select appears in the box at the top of the Colors window. You can save that color for 
future use by placing it in the color palette.

To select a color:
1 Click anywhere in the color wheel. The selected color is displayed in the color box at 

the top of the Colors window.

2 To make the color lighter or darker, drag the slider on the right side of the Colors 
window.

3 To make the color more transparent, drag the Opacity slider to the left or enter a 
percentage value in the Opacity field.

To open the color palette:
m Drag the handle at the bottom of the Colors window.

The color selected in the 
color wheel appears in this 
box. (The two colors in this 
box indicate the opacity is 
set to less than 100%)

Use the slider to set 
lighter or darker hues in 
the color wheel.

Drag colors from the 
color box to store them 
in the color palette.

Click to select a color in 
the color wheel.

Drag the Opacity slider to 
the left to make the color 
more transparent.

Click the Search icon and 
then click any item on the 
screen to match its color.
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To save a color in the color palette:
m Drag a color from the color box to the color palette.

To apply the colors you select in the Colors window to an object on the page, you 
must place the color in the appropriate color well in an Inspector pane.

To apply a color to an object on the page:
Â Select a color well in one of the Inspectors, and then click a color in the color wheel.

Â Drag a color from the color palette or color box to a color well in one of the 
Inspectors.

To match the color of another item on the screen:
1 Click the magnifying glass to the left of the color box in the Colors window.

2 Click the item on the screen whose color you want to match. The color appears in the 
color box.

3 Select the item you want to color in the document window, and drag the color from 
the color box to the item.

Filling an Object With Color
Objects can be filled with a solid color or a color gradient, in which two colors 
gradually blend with each other. To change the color of an object, you use the 
Graphic Inspector.

Choose a solid color, a 
color gradient, an image, 
or a tinted image to fill a 
drawn object.
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To open the Graphic Inspector:
m Click Inspector in the toolbar (or chose View > Show Inspector), and then click the 

Graphic Inspector button.

To set the solid fill color of an object:
1 On the page, select the object whose color you want to change.

2 In the Graphic Inspector, choose Color Fill from the Fill pop-up menu.

3 Click the color well below the Fill pop-up menu to open the Colors window.

4 Select a color in the Colors window.

To fill an object with a color gradient:
1 On the page, select the object whose color you want to change.

2 In the Graphic Inspector, choose Gradient Fill from the Fill pop-up menu.

3 Click each color well and choose each color in the Colors window.

4 To set a direction for the gradient, use the Angle wheel or field. To flip it horizontally 
or vertically, click the Angle arrow buttons.

5 To invert the gradient, click the double-headed arrow next to the color wells.

Filling an Object With an Image
You can place an image or a tinted image inside of a drawn shape, text box, chart 
element, or table cell.

To set an image fill for an object:
1 Select the object in which you want to place an image.

Click each color well to 
select colors. Flip the gradient 

orientation or set its 
direction by using the 
arrow buttons, the Angle 
wheel, or by typing a 
value.

Click the double-headed 
arrow to invert the 
gradient.
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2 In the Graphic Inspector, choose Image Fill from the Fill pop-up menu, and select an 
image.

3 To change the image, click Choose, select the image, and click Open (or drag the 
image file from the Finder or Media Browser to the image well in the Graphic 
Inspector).

4 Choose an image scale from the pop-up menu.

Â Scale To Fit resizes the image to fit the object’s dimensions as well as possible. If the 
object’s shape is different from the original image’s, parts of the image may not 
appear; blank space may also appear around the image.

Â Scale To Fill makes the image appear larger or smaller, sizing it to leave minimum 
space around the image, even if the object and image have different shapes.

Â Stretch sizes the image to fit the object’s dimensions but distorts it if the object has 
a shape different from the original image.

Â Original Size places the image inside the object without altering its original 
dimensions. If the image is larger than the object, you see only a part of the image 
in the object. If the image is smaller than the object, there is blank space around it.

Â Tile repeats the image inside the object, if the image is smaller than the object. If 
the image is larger than the object, you see only part of the image inside the object.

Use the pop-up menu to 
set the size of the image 
within the object.

To change the image, 
drag an image to the 
image well.

Original Size

StretchScale to Fit

Tile (large image)

Scale to Fill
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A tinted image fill places a transparent, colored mask over the fill image.

To set a tinted image fill for an object:
1 Select the object in which you want to place an image.

2 In the Graphic Inspector, choose Tinted Image Fill from the Fill pop-up menu, and 
select an image.

3 Click the color well next to the Choose button, and then select a tint color in the 
Colors window. Drag the Opacity slider in the Colors window to make the tint darker 
or lighter. (If you drag the Opacity slider in the Graphic Inspector, it will change the 
opacity of both the tint and the image.)

4 Choose the image scale from the pop-up menu, as described above.

5 To change the image, click Choose, select the image, and click Open (or drag the 
image file from the Finder or Media Browser to the image well in the Graphic 
Inspector).

Adjusting Images
For images, including those you use to fill a shape, you can change the brightness, 
contrast, and other settings to improve the quality of the image or to create 
interesting effects.

To adjust an image:
1 Select the image.

Tile (small image)

Tile (large image)

Click to select a tint color 
for the image.
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2 Click Adjust in the toolbar or choose View > Show Adjust Image to open the Adjust 
Image window.

3 Use the controls to make the following adjustments.

Â Use the Brightness slider to adjust the lightness of the image.

Â Use the Contrast slider to adjust the contrast of light and dark tones. You can make 
shadows darker, sharpen the edges of objects, and make colors stand out more. If 
you increase the contrast of a photo a lot, it looks more like an illustration.

Â Use the Saturation slider to change the color intensity.

Â Use the Temperature slider to introduce more warmth (more orange tones) or 
coldness (more blue tones).

Â Use the Tint slider to change the amount of red or green tones in the image.

Â Use the Sharpness slider to sharpen or soften the image’s focus.

Adjust the lightness.

Adjust the contrast of light 
and dark tones.

Change the color intensity.

Introduce more warmth or coolness.
Change the amount of red 
or green tones.
Sharpen or soften the focus.

Adjust shadows and highlights.

Understand the relationship 
between shadows and highlights.

Change the levels of dark 
and light tones.

Restore original settings.

Enhance colors automatically.
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Â Use the Exposure slider to adjust shadows and highlights.

Â Use the histogram to understand the relationship between shadows (depicted on 
the left side of the display) and highlights (depicted on the right side) in your image.

Â Use the Levels slider to change the levels of light and dark tones.

Â Click the Auto Levels button to have Pages enhance colors automatically.

4 To restore the original settings, click Reset Image. 

To save any changes you made, save the document. The settings at the time you save 
the document are visible anytime you open the Adjust Image window.

Changing Line Style
For drawn objects (shapes), chart elements, and table cells, you can choose a style and 
color for the object’s border, or you can specify no border. You can also put a border 
around imported images. You set border line style and color using the Graphic 
Inspector and the Colors window.

To set the line style and color of an object’s border:
1 Select the object that you want to modify.

2 In the Graphic Inspector, choose a line style (or None) from the Stroke pop-up menu. 
For tables, only a solid line or None is available.

3 To change the line thickness, type a value in the Stroke size field (or click the arrows).

4 To change the line color, click the color well and select a color.

5 To give the line endpoints, such as arrowheads or circles, choose left and right 
endpoints from the pop-up menus.

Enter the line thickness in 
this field.
Choose line endpoints from 
these pop-up menus.

Choose a solid line, 
dotted line, dashed line, 
or no line.

Click the color well to choose 
a line color.
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Note:  The Insert menu and the Shapes pop-up menu (in the toolbar) include lines 
with arrowheads.

You can set the position of lines and objects in the Metrics Inspector. See “Adjusting 
Size and Position of Objects” on page 156.

Adding Shadows
Shadows give your page an appearance of depth. An object’s shadow appears on any 
object behind it. You can create a variety of shadow effects, or remove the shadow 
from an object.

To create or remove a shadow for an object:
1 Select the object you want to modify.

2 In the Graphic Inspector, select the Shadow checkbox to add a shadow to the object. 
Deselect the Shadow checkbox to make the shadow go away.

3 Set the angle for the shadow using the Angle wheel.

4 Adjust the shadow offset by typing a number in the Offset box. 

A high shadow offset value makes an object’s shadow appear longer and slightly 
separated from the object.

5 Set the shadow blur by typing a number in the Blur box. 

A high blur value makes the object’s shadow appear more diffuse; a low value gives 
the shadow more sharply defined edges.

Change the shadow color 
in the color well.

Select the checkbox to 
add a shadow to a 
selected object.

Change the angle of the 
shadow with the Angle 
wheel.

Offset, Blur, and Opacity 
values can change the 
look of the shadow.
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6 Set the shadow opacity by typing a number in the Opacity box. (Shadow opacity is 
separate from object opacity, which is set using the Opacity slider at the bottom of 
the Graphic Inspector.)

7 To change the color for the shadow, click the color well and select a color.

Adjusting Opacity
You can create interesting effects by making objects more opaque or less opaque. 
When you put a low-opacity object on top of another object, for example, the bottom 
object shows through the top object. Depending on how high or low you set the 
opacity, the objects below can be highly visible, partly obscured, or completely 
blocked from view (at 100-percent opacity). You can change opacity settings for any 
visual object on the page, including drawn shapes, pictures and other image files, and 
movies. Set object opacity using the Graphic Inspector.

To change an object’s opacity:
1 Select the object.

2 In the Graphic Inspector, drag the Opacity slider.

This object has the default 
shadow properties.

This object’s shadow is set 
to a different angle.

This object’s shadow has 
a high offset value.

This object’s shadow has 
the lowest blur factor.

This object has a different 
shadow color.

This object’s shadow has 
a high blur factor.
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Note:  For drawn shapes, you can set opacity for fill and stroke colors separately from 
object opacity. If you move the Opacity slider in the Colors window to modify a fill or 
stroke color, that opacity value becomes maximum object opacity. Then, when you 
change the object opacity in the Graphic Inspector, you are changing it relative to the 
opacity you set in the Colors window.

Changing the Orientation
You can flip or rotate any object by using the Metrics Inspector. For example, if you 
have an image of an arrow that you want to use in your document, but you need it to 
point in a different direction, you can reverse its direction vertically or horizontally, or 
point it at any angle.

To open the Metrics Inspector:
m Click Inspector in the toolbar (or choose Choose View > Show Inspector), and then 

click the Metrics Inspector button.

This circle is set to 100% opacity. 
The fill color was set to 50% 
opacity in the Colors window. 
The circle’s outline was set to 
100% opacity in the Colors 
window.

This circle is set to 100% 
opacity.

This circle is set to 
50% opacity.
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To flip or rotate an object:
1 Select the object you want to rotate.

2 In the Metrics Inspector, use the Angle wheel or field to set the direction of the object, 
or click the horizontal or vertical Flip buttons to flip it horizontally or vertically.

Adjusting Size and Position of Objects
In addition to dragging objects and their selection rectangles to resize or reposition 
them on the page, you can use the Metrics Inspector to make precise adjustments to 
their size and position.

To set the precise size of an object:
1 Select the object you want to resize.

2 In the Metrics Inspector, type a number in the Width and Height fields.

Resize images and 
movies to exact 
dimensions by specifying 
height and width.

Flip an image sideways or 
upside down using these 
buttons.

Find the name of the selected 
image or movie here. Drag its 
icon to the page or the Finder 
to make a copy of it.

Rotate an object with 
this wheel or field.

Place an object on the 
page by specifying X and 
Y coordinates.
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To maintain the width/height ratio when you resize an object:
m Select the checkbox labeled “Constrain proportions” in the Metrics Inspector, or hold 

down the Shift key as you drag a selection handle.

To return an image or movie to its original size:
m Select the image or movie and click Original Size in the Metrics Inspector.

To set the precise position of a fixed object:
1 Select the object you want to position.

2 In the Metrics Inspector, enter X and Y values in the Position fields.

The specified coordinates determine the position of the upper-left corner of the 
object’s container box.

Â The X value is measured from the left edge of the page.

Â The Y value is measured from the top edge of the page.

If an object is rotated, the X and Y coordinates specify the upper-left corner of the 
rotated container box.

Lines
For lines, size and position can only be adjusted in the Metrics Inspector if the lines 
are fixed objects, not placed inline with text. (To read more about fixed objects versus 
inline objects, see “Fixed Objects Versus Inline Objects” on page 124.)

When you enter X and Y coordinates for line positions in the Metrics Inspector, the 
Start coordinates represent the first endpoint you created. If you later flip or rotate the 
line, the Start coordinates continue to represent the first endpoint.

Position a fixed line on 
the page by specifying X 
and Y coordinates for its 
second endpoint.

Position a fixed line on 
the page by specifying X 
and Y coordinates for its 
first endpoint.
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Drawing and Editing Shapes
You can use the Draw tool to create your own shapes in a document. 

Working with the shapes you create is the same as working with predrawn shapes. 
Your shapes can contain text. And they can be resized, repositioned, and have the line 
style, color, shadow, opacity, and orientation of your choice.

This section tells you how to create your own custom shapes and how to edit the 
contour of both predrawn and custom shapes.

Adding a Custom Shape
When you first create a custom shape, it’s inserted as a fixed object, but you can make 
it an inline object if you like.

To create a custom shape:
1 Click Objects in the toolbar, choose Shapes, and select the Draw tool icon.

You can also choose Insert > Shape > Draw a Shape.

2 The pointer changes from an arrow to a small pen tip.

Click anywhere in your document to create the first point of the custom shape.

3 To create a second point and connect it with the first point using a straight line, click 
in a second location in the document. 

To create a curved segment instead of a straight one, click in the second location and 
drag the mouse to change the curve angle or extend the curve. Release the mouse 
when you’re satisfied with the curve.

The line that connects the two points has the default stroke style for the template 
you’re using. You can change the line into another kind of line later using the stroke 
settings in the Graphic Inspector.
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4 Repeat step 3 to create additional points as required. Every time you add a new point, 
Pages connects it with the preceding point using a line with the current stroke and 
with the first point using no stroke, and fills the shape with the default fill color for the 
template you’re using. You can change the fill color using the Fill pop-up menu in the 
Graphic Inspector.

To delete a segment you’ve just created, press Delete. Pressing Delete again removes 
the preceding segment, too.

5 To stop drawing and close the shape (add a solid line between the last and first 
points), click the first point.

To stop drawing and leave the shape open (no line between the last and first points) 
so that you can work with it more later, press the Esc (Escape) key or double-click the 
last point created. 

Your new shape is a fixed object that you can move and group like any fixed object. 

To finish and close an open shape:
1 Click once in the shape to select it, and then click it a second time to make it editable.

2 Double-click one of the two points at either end of the open segment.

3 To add additional points, click in other locations as needed.

4 To stop drawing and close the shape, click the point at the end of the open segment.

To change a custom shape to an inline object:
m Select the shape, and then open the Wrap Inspector and click “Moves with text”. 

m Select the shape and choose Edit > Cut. Place the insertion point where you want the 
shape to appear, and then choose Edit > Paste.

Here’s the open segment.
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Editing Predrawn and Custom Shapes 
You can change the contour of predrawn and custom shapes.

To make a predrawn shape editable:
m Select the shape, and then choose Format > Shape > Make Editable.

To make a custom shape editable:
m Click once in the shape to select it, and then click a second time to show its points.

To move one or more points:
m When the shape is editable, click a point and drag it to another location. You can 

move several points at the same time by Shift-clicking multiple points, and then 
dragging.

To delete one or more points:
m When the shape is editable, click a point and then press the Delete key. You can delete 

several points at the same time by Shift-clicking multiple points and then pressing 
Delete.

To add a point:
1 When the shape is editable, press the Option key and hold the pointer over the 

shape’s border. The pointer changes into a pen tip with a +.

2 Click the location on the border where you want to add a point. 

3 Move the point as needed.

To reshape a curve:
1 Make the shape editable.

2 Click a red circular control on the curve you want to reshape. A control handle 
appears on both sides of the circular control.

Click a point and drag it 
to change the shape.
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3 To expand or contract the curve, drag the circular control or one of the control 
handles.

4 To change the angle of the curve, move the control handles clockwise or counter-
clockwise. You achieve different effects when you move the handles together or 
independently of each other. Experiment until you achieve the desired effect.

Â To move the control handles together, press the Option key and drag one or the 
other of them. 

Â To move only one control handle, press the Command key before dragging a 
handle.

To reshape a straight segment:
1 Make the shape editable.

2 Click a point.

3 Drag the point clockwise or counter-clockwise to change the angle between the two 
attached segments.

Drag the point out or in to change the length of one of the segments.

To transform corner points into curved points and vice versa:
m To change a corner point into a curved point, make the shape editable, and then 

double-click the corner point.

m To change a curved point into a corner point, make the shape editable, and then 
double-click the curved point.

m To change all corner points in one or more shapes into curved points, make the 
shapes editable, select the shape(s), and choose Format > Shape > Smooth Path. 

m To change all curved points in one or more shapes into corner points, make the 
shapes editable, select the shape(s), and choose Format > Shape > Sharpen Path.

Drag a control handle or 
rotate one or both 
control handles to 
change the curve.

You can also drag a point 
to modify the curve.
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After a shape is editable, you can use the Smooth Path and Sharpen Path commands 
without making the shape editable again.

Editing Specific Predrawn Shapes
Some predrawn shapes have special built-in editing controls that you can use in 
addition to those described above.

To edit a rounded rectangle:
m Drag the circular control to the left to straighten the corners and to the right to round 

them.

To edit single and double arrows:
m Use the three special controls to increase or decrease the tail’s length and width 

without changing the shape of the arrowhead.

To edit a star:
m When you select a star shape, a slider appears. Drag the slider to increase or decrease 

the number of points in the star. 

Drag to straighten or 
round the corner.

Drag to change 
the tail length.

Drag to change the 
width of the tail or 
the arrowhead.
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To edit a polygon:
m Drag the slider to increase or decrease the number of sides in the polygon.

Drag to change the angles 
between points in the star.

View the number of 
points currently in the 
star.

Drag to increase or 
decrease the number of 
points in the star.

Drag to increase or 
decrease the number of 
sides in the polygon.

View the number of sides 
currently in the polygon.
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8 Creating Tables

Tables are useful for organizing and sorting 
information, creating interesting layouts, and 
performing calculations on numeric data. This 
chapter covers basic table design and usage.
Pages provides powerful features for making attractive, compelling tables that can 
contain text or graphics. Use tables to organize and display data for comparison. By 
filling table cells with graphics, you can also easily create and format graphics layouts. 
By merging and splitting cells, you can easily format forms to be filled out (for 
example, order forms).

This data form, featured 
in the Lab Notes 
template, is a set of tables 
with cells that have color 
and image fills.
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When you use a table to present numeric data, you can use formulas and number 
formatting to automate how values are displayed. For example, you can total or 
average values in a row or column, and display negative numbers in red or in 
parentheses. 

Adding a Table
Tables can be added inline with text or fixed on the page. (To learn about fixed and 
inline objects, see “Fixed Objects Versus Inline Objects” on page 124.) Fixed tables 
cannot span page boundaries, but inline tables can.

This layout, featured in 
the Photo Journal 
template, was made by 
filling some table cells 
with images, and others 
with colors and text.

This table, used in the 
Invoice template, uses 
formulas to automatically 
update cost when 
quantity or unit price 
changes.
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To add a table inline with text:
1 Place the insertion point wherever you want the table to appear in the text flow.

2 Click Objects in the toolbar and choose Table (or choose Insert > Table). The Table 
Inspector opens.

3 To resize the table, drag the available selection handles.

To place a fixed table:
1 Click anywhere outside the text areas of the document so that no insertion point is 

visible.

2 Click Objects in the toolbar and click Table (or choose Insert > Table). A table appears 
on the page.

3 Drag the table to wherever you want it to appear on the page.

You can also draw a table yourself.

To draw a table on the page:
1 Hold down the Option key as you click Objects in the toolbar and choose Table. 

2 Release the Option key and move the pointer over the page until it becomes a 
crosshair.

3 Drag across the page to create a table any size you want. As you drag, the number of 
rows and columns increases or decreases with the size of the table.

To size the table from the center, press the Option key while dragging.

Note:  A table occupies at least one full line of a document. You cannot wrap text 
around the sides of a table. To learn more about wrapping text around objects, see 
“Wrapping Text Around an Object” on page 136.

To resize a table:
Â Drag the available selection handles.

Â If a table spans more than one page, use the Metrics Inspector to resize it. To read 
about resizing objects using the Metrics Inspector, see “Adjusting Size and Position 
of Objects” on page 156.

Â If an inline table spans more than one column, you must resize the column to resize 
the table. To read about resizing objects using the Metrics Inspector, see “Adjusting 
Size and Position of Objects” on page 156. To read about working with columns, see 
“Creating Columns” on page 62.
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Using Table Cells and Borders
You enter text in a table cell by selecting the cell and typing. You put graphics in 
tables by using a background fill in individual cells, the same way you fill an object 
with an image. (For information about adding graphics or setting background colors 
inside table cells, see “Adding Images or Background Colors” on page 177.) You can 
also apply formulas to table cells that contain numbers or Boolean values (TRUE or 
FALSE).

You can apply changes to an entire table at once (by selecting it) or to individual cells 
within a table. To format text or graphics inside table cells or groups of cells, you 
select only the cells you want to work with. You can select table cells and borders 
using the following shortcuts, or by using the selection buttons in the Table Inspector. 
To read about the Table Inspector, see “Formatting Tables” on page 170. To learn about 
selecting cells when using formulas, see “Using Formulas” on page 183.

To select the entire table, do one of the following:
Â If a table cell isn’t selected, click anywhere in the table.

Â If a table cell is already selected, press Command-Return to select the entire table.

Selection handles appear on the edges of the table.

Selecting Table Cells
When a single cell is selected, you can move between cells by pressing the arrow keys 
on your keyboard. If you type text in this mode, you replace text already in the cell. 
You can also use the Tab key to navigate through the cells. Pressing Tab moves you to 
the right and downward; pressing Shift-Tab moves to the left or upwards. If you press 
the Tab key when the bottom-right cell of the table is selected, a new row is added to 
the table.

To select a single table cell:
m If the table or a cell in it is selected, click in the cell. 

m If the table or a cell in it isn’t selected, double-click in the cell.

The border of the selected cell is highlighted in yellow. You can enter text in the cell 
by typing. Any text in the cell is replaced.
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To select a contiguous group of table cells:
m Select the table, double-click a single cell, and hold down the Shift key as you select 

adjacent cells.

To select a discontinuous group of table cells:
m Hold down the Command key as you select cells. Use Command-click to deselect a 

cell in the group.

To select an entire row or column:
1 Click the Inspector button in the toolbar (or choose View > Show Inspector), and then 

click the Table Inspector button.

2 Select a cell in the row or column you want to select.

3 Click the Row or Column button at the bottom of the Table pane.

Selecting Table Cell Borders
If a table spans more than one page or column, selecting the border at the bottom of 
one page or column may also affect the border at the top of the next page or column.

To select multiple borders:
1 Select the table cells whose borders you want to select.

2 Click the Inspector button in the toolbar (or choose View > Show Inspector), and then 
click the Table Inspector button.

3 Click one of the Borders buttons in the Table pane to select all borders, or only the 
inside, outside, horizontal, or vertical borders of the selected cells.

To select an individual border:
Â If the table is selected, click the border.

Â If the table is not selected, double-click the border.

Click Row to select an 
entire table row.

Click Column to select an 
entire table column.

Click a button to select 
cell borders.
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To select one segment of a cell border:
1 Select the table.

2 Option-click to select a single border segment.

3 To select additional border segments, press the Option and Shift keys as you click.

Note:  If the table isn’t selected, Option-double-click to select a single border segment.

Entering and Editing Content in Table Cells

To type content in a table cell:
m If the cell is empty, select it and begin typing.

m To replace specific text already in the cell, select the cell, and then select what you 
want to change. Begin typing.

m To replace everything in the cell, select the cell and begin typing. You can also select 
the cell and then press Return or Enter, which selects everything in the cell, then start 
typing.

m To place the insertion point within content, select the cell, then click the location at 
which you want to place the insertion point. Begin typing.

To switch the contents of two cells:
m Select the cell and drag it to another cell. A blue border appears when you begin to 

drag the cell, and the cell contents are switched.

To copy the contents of one cell into another:
m Select the cell and begin to drag it. A blue border appears when you begin to drag 

the cell. Hold down the Option key as you drag it to another cell.

To delete the contents and background fill of table cells:
m Select the cells and press the Delete key. 

To edit a cell that uses a formula or contains a formatted number:
m Select the cell, and then click in the cell or press Return or Enter to open the Formula 

Editor. See “Formatting Numbers” on page 178 and “Using Formulas” on page 183 for 
additional instructions.
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Formatting Tables
You can design tables in a variety of creative ways simply by changing the thickness 
and color of cell borders, selectively removing cell borders, or merging and splitting 
cells to create useful asymmetries within the table.

Using Table Formatting Controls
You can do basic table formatting—including merging and splitting cells, adding and 
deleting rows and columns, and adding or removing the header row and column— 
using a table formatting menu or the Table Inspector.

To open table formatting menus:
m Select a table or cell(s), and then open the Table Inspector and use the Edit Rows & 

Columns pop-up menu in the Table pane.

m Select a table or cell(s), and then choose Format > Table.

m Select a table or cell(s), and then hold down the Control key as you click the table 
again to open the table’s shortcut menu.

To open the Table Inspector:
m Click Inspector in the toolbar (or choose View > Show Inspector), and click the Table 

Inspector button. Use the Table pane for general table formatting. Use the Numbers 
pane when you want to use formulas (see “Using Formulas” on page 183) or formatted 
numbers (see “Formatting Numbers” on page 178).
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Adding and Deleting Rows and Columns 
To add a new row to a table:

1 Select a table cell or row.

2 Open a table formatting menu and choose Add Row Above or Add Row Below. You 
can use the Edit Rows & Columns pop-up menu in the Table pane of the Table 
Inspector. Alternatively, you can choose Format > Table or hold down the Control key 
as you click the table again.

To add a single row to the end of the table, simply select the last cell in the table and 
press Tab.

You can also add rows to only specific cells. See “Merging, Splitting, and Resizing Table 
Cells” on page 173.

To add a new column to a table:
1 Select a table cell or column.

2 Open a table formatting menu and choose Add Column Before or Add Column After.

Select to add a specially 
formatted header row or column.

The Table Inspector button

Select to make rows resize to 
accommodate content.

Type the number of table 
rows and columns.

Add or delete rows or 
columns, merge cells, split 
rows, or split columns.

Specify column width 
and row height.

Select table columns, 
rows, and borders.
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You can use the Edit Rows & Columns pop-up menu in the Table pane of the Table 
Inspector. Alternatively, you can choose Format > Table or hold down the Control key 
as you click the table again.

You can also add columns to only specific cells. See “Merging, Splitting, and Resizing 
Table Cells” on page 173.

To change the number of rows or columns in a table:
1 Select the table.

2 Click Inspector in the toolbar (or choose View > Show Inspector), and click the Table 
Inspector button. Then click Table.

3 To add or remove rows, type the number of rows you want in the table in the Rows 
field and press Return. Rows are added to or removed from the bottom of the table.

4 To add or remove columns, type the number of columns you want in the Columns 
field and press Return. Columns are added to or removed from the right side of the 
table.

To delete table rows or columns:
1 Select the row or column or a cell in it.

2 Open a table formatting menu and choose Delete Row or Delete Column. You can use 
the Edit Rows & Columns pop-up menu in the Table pane of the Table Inspector. 
Alternatively, you can choose Format > Table or hold down the Control key as you 
click the table again.

Note:  If you select cells and press the Delete key, only the cell contents are deleted.

Creating a Table Header Row or Column
You can add a table header row and column. Header rows appear at the beginning of 
the table on each page (if the table spans more than one page) or the beginning of 
each column or linked text box (if the table spans columns or linked text boxes). 
Header rows and columns look different from the rest of the table cells, but their style 
can be changed like that of any other cells. However, you cannot split a header row 
into multiple rows, or header columns into multiple columns.

If a table spans multiple pages, columns, or text boxes, editing the text or changing 
the look of the header row or column in one place changes it consistently throughout 
the table.
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To add a header row or column:
m Select the table. Click Inspector in the toolbar, click the Table Inspector button, and 

then select the Header Row or Header Column checkbox (or both) in the Table pane.

m Select the table and choose Format > Table > Show Header Row or Format > Table > 
Show Header Column.

Merging, Splitting, and Resizing Table Cells
Merging table cells combines adjacent cells into one, eliminating the border so that 
they behave as a single cell.

Splitting cells divides each selected cell into two equal parts, horizontally (rows) or 
vertically (columns). Both of the new cells have identical background colors or images. 
Any text that was in the original cell remains in the top-most or leftmost cell.

You can split and merge cells using any table formatting menu. To resize table cells, 
use controls in the Table pane of the Table Inspector.

To merge table cells:
1 Select a group of two or more adjacent table cells. The group of cells you choose must 

form a rectangle.

2 Open a table formatting menu and choose Merge Cells.

You can use the Edit Rows & Columns pop-up menu in the Table pane of the Table 
Inspector. Alternatively, you can choose Format > Table or hold down the Control key 
as you click the table again.

Merging horizontally contiguous cells containing only text or a mixture of text, 
numbers, formatted numbers, and formulas joins the content from all the original cells 
as text separated by tabs. Merging vertically contiguous cells containing only text or a 
mixture of text, numbers, formatted numbers, and formulas joins the content from all 
the cells as text separated by carriage returns. 

When merging column cells, the cell background takes on the image or color that was 
in the top-most cell. When merging row cells, the cell background takes on the image 
or color that was in the leftmost cell.

When a cell containing text, a number, a formula, or a formatted number is merged 
with empty cells, the new cell retains the content of the non-empty cell.
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When a cell containing a formatted number is merged with empty cells, the new cell 
retains the formatted number.

To split cells horizontally or vertically:
1 Select a table cell or cells. To split an entire row or column, select all the cells in the 

row or column. 

2 Click Inspector in the toolbar, click the Table Inspector button, click Table, and open 
the Edit Rows & Columns pop-up menu. To split cells into rows, choose Split Rows, 
Add Row Above, or Add Row Below. To split cells into columns, choose Split Columns, 
Add Column Before, or Add Column After.

You can also choose Format > Table > Split Into Rows or Split Into Columns, or hold 
down the Control key as you click the table and choose the command from the 
shortcut menu.

You can repeat the split operation to create smaller and smaller units within a table 
cell. To rejoin split cells, select them and choose Merge Cells from the Edit Rows & 
Columns pop-up menu or choose Format > Table > Merge Cells.

To resize table cells:
m Select the cells and enter values in the Column Width and Row Height fields in the 

Table pane of the Table Inspector, and then press Return.

m Select cell borders and drag to resize.

To make all table cells the same size:
m Select the table and choose Format > Table > Distribute Rows Evenly and Distribute 

Columns Evenly.

If there is too much text in a table cell, a clipping indicator appears at the bottom of 
the cell.

To avoid clipping, you can drag the cell borders to resize them, or drag a selection 
handle to resize the entire table. You can also make table rows automatically shrink or 
expand in height to accommodate the text inside them.

The clipping indicator 
appears when a table cell 
contains more text than 
can be seen.
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To make table rows automatically grow or shrink to fit their contents:
m Select the table, and then select the checkbox labeled “Automatically resize to fit 

content” in the Table pane of the Table Inspector.

With this option selected, table cells automatically get bigger when text extends 
beyond the cell boundary, and adding rows or columns increases the outside 
dimensions of the table. As text is removed from a cell, the row height may decrease 
(if the cell determines the row height). If “Automatically resize to fit content” is not 
selected, Pages tries to keep the outside dimensions of the table the same when you 
add rows and columns. 

Note:  Table cells cannot span multiple pages, columns, or text boxes.

Aligning Text in a Table Cell
You can align text horizontally and vertically in a table cell. To align text, use the Text 
pane of the Text Inspector.

To open the Text pane of the Text Inspector:
m Click the Inspector button in the toolbar (or choose View > Show Inspector), and then 

click the Text Inspector button. Then click Text.

(For more information about the Text pane of the Text Inspector, see “Using the Text 
Inspector” on page 88.)

To align text horizontally within table cells:
m Select one or more cells or the entire table, and click one of the horizontal alignment 

buttons in the Text pane of the Text Inspector.

To align text vertically within cells:
m Select one or more cells or the entire table, and click one of the vertical alignment 

buttons in the Text pane of the Text Inspector.

Align text right.

Justify text (align text 
right and left).

Align text left.

Center text.
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You can specify the amount of space between text and its cell border using the Inset 
Margin slider or field. The amount you specify is applied equally around the text on all 
four sides. 

To adjust the space around text within a table cell:
1 Click the cell (or select the whole table to apply the same setting to all cells).

2 In the Text pane of the Text Inspector, drag the Inset Margin slider to the right to 
increase the space, or enter a value in the field and press Return.

Formatting Cell Borders
You can change the line thickness and color of table cell borders. Or you can hide the 
cell border of any cell.

To set line thickness and color:
1 Select a cell border or set of cell borders (for more information, see “Selecting Table 

Cell Borders” on page 168).

2 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 
Graphic Inspector button.

3 Type a value in the Stroke field.

4 Click the Stroke color well and select a color in the Colors window.

Grow text from the 
bottom of the cell.

Place text at the 
top of the cell.

Begin text in the 
center of the cell.

Choose to show or hide 
the selected cell borders.

Choose a color for 
selected cell borders.

Enter a line thickness for 
selected cell borders.
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To hide a cell border:
1 Select a cell border or set of cell borders.

2 In the Graphic Inspector, choose None from the Stroke pop-up menu.

To create a table with no outside border:
1 Select the table.

2 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 
Table Inspector button.

3 In the Table pane, click the second Borders button to select the outside borders.

4 Click the Graphic Inspector button, and choose None from the Stroke pop-up menu.

Adding Images or Background Colors
You add graphics or color to a table cell using the Fill pop-up menu in the Graphic 
Inspector. You can add images or color to individual table cells, or to the entire table.

To add an image to a table cell:
1 Select a table cell, a group of cells, or the whole table (for more information, see 

“Using Table Cells and Borders” on page 167).

2 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 
Graphic Inspector button.

3 Choose Image Fill from the Fill pop-up menu. (If there’s already an image in the cell, 
click Choose.)

4 Select an image and click Open.

5 Use the Scale pop-up menu to fill the cell the way you want.

Set the scale of the image 
within the cell or table.

Drag a new image to the 
well to change it, or click 
Choose.

Choose an image fill, color fill, tinted 
image fill, or gradient fill for any cell 
or the whole table.
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If you add an image to the entire table, then when you select an individual table cell, 
the Fill pop-up menu in the Graphic Inspector displays None. For more details about 
working with image fills, see “Filling an Object With an Image” on page 148.

To add a background color or gradient fill:
1 Select a table cell, a group of cells, or the whole table (for more information, see 

“Using Table Cells and Borders” on page 167).

2 In the Graphic Inspector, choose Color Fill or Gradient Fill from the Fill pop-up menu.

3 Click the color well (or wells) and select a color or colors in the Colors window.

If you add color to the entire table, then when you select an individual table cell, the 
Fill pop-up menu in the Graphic Inspector displays None. For more details about 
working with color and gradient fills, see “Using Color and Image Fills” on page 145.

Formatting Numbers
When cells in a table contain or will contain numeric data, you can apply a number 
format to them so that values in the cells are displayed in a particular way. For 
example, you can format cells that hold monetary values so that a currency symbol 
(such as $, £, or ¥) appears in front of numbers in them. See “A Tour of Using 
Formulas” on page 183 for an example of how formatted numbers are used in the 
Pages Invoice template.

Defining Number Formats
To define a number format for one or more cells:

1 Select the cell or cells. 

When a selected cell is empty, values entered into it later will be displayed using the 
number format you define. When a selected cell already contains a number, the 
format you define is applied to the number.

2 Open the Table Inspector. Click Inspector in the toolbar (or choose View > Show 
Inspector), and then click the Table Inspector button.

3 Click the Numbers button.

4 Select the Number Format checkbox, and then use the fields below it to define the 
number format.
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If you use the % suffix, data in the cell is displayed followed by the % symbol. If the 
data in the cell is used in a formula, it’s converted into a decimal number. For example, 
3% becomes 0.03. See “Using Formulas” on page 183 for details.

After you define a number format, you can associate the format with multiple cells by 
using autofilling. See “Autofilling” on page 182 for instructions.

Applying Number Formats
To add a value to an empty cell that has a number format:

m Select the cell and type a number. The number format is applied when you press 
Enter or click outside the cell.

To apply a number format to an existing value:
1 Select one or more cells that contain numbers.

2 Open the Table Inspector. Click Inspector in the toolbar (or choose View > Show 
Inspector), and then click the Table Inspector button.

3 Click the Numbers button.

Select to define a display 
format for numbers in 
selected cells. 

Choose or type a symbol to 
precede numbers. 

Select whether to use a 
thousands separator.

Choose or type a symbol 
to follow numbers.

Set the number of 
decimal places to display. 

Select a style for displaying 
negative numbers.
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4 Select the Number Format checkbox, and then use the fields below it to define the 
number format. The format you define is applied to values in the selected cell(s).

To edit a value in a cell that has a number format:
1 Select the cell.

2 Click in the cell or press Return or Enter. The Formula Editor opens, displaying the 
value but not its formatting.

3 Change the value displayed in the Formula Editor.

Note:  If the number format includes the % suffix, the decimal version of the number 
appears in the Formula Editor, as the example above shows.

4 To retain the new value, click the Accept button in the Formula Editor, press Return, or 
click outside the editor.

To cancel your change, click the Cancel button in the Formula Editor or press Esc.

To remove a number format from a cell:
m Select the cell, and then deselect the Number Format checkbox in the Numbers pane 

of the Table Inspector. The number remains, but its formatting is removed.

Sorting Cells
You can sort some or all the rows in a column in ascending or descending order. Rows 
containing cells being sorted are reordered. Header cells aren’t sorted.

To sort:
1 If you want to sort all the cells in a column, select the column, a cell in the column, or 

a column header.

If you want to sort only some of the cells in a column, select those cells.

Rows containing the selection will be reordered.

2 Open the Table Inspector. Click Inspector in the toolbar (or choose View > Show 
Inspector), and then click the Table Inspector button.

Make changes. Cancel button
Discard changes.

Accept button
Save changes.
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3 Click the Numbers button.

4 Use the Sort Column buttons to indicate whether you want to sort in ascending or 
descending order.

The following table describes how different types of data are sorted in ascending or 
descending order. 

Sort selected column cells in 
ascending order. Rows 
containing the cells will be 
reordered.

Sort selected column 
cells in descending order. 
Rows containing the cells 
will be reordered.

Type of data Ascending order Descending order

Text aA–zZ Zz–Aa

Numbers –2, –1, 0, 1, and so on 1, 0, –1, –2, and so on

Cells containing only text, 
mixed with cells containing 
only numbers

–2, –1, 0, 1, and so on, then
aA–zZ

Zz–Aa, then 1, 0, –1, –2, and so 
on

Cells containing a mixture of 
text and numbers

Values starting with numbers 
first (1z, 1Z, a1, A1)

Values starting with text first 
(A1, a1, 1A, 1z)

Empty cells At the bottom At the bottom

Boolean (TRUE, FALSE) Above text Below text
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Autofilling
Autofilling is a feature that lets you paste the contents of the upper-left cell in a 
contiguous group of cells into all other cells in the group. Any data, number 
formatting, or formula associated with the upper-left cell is pasted into all cells in the 
group, but background style formatting isn’t. (See “Using Formulas” on page 183 to 
learn about using formulas in table cells.)

If the upper-left cell is empty, autofilling clears all data from cells in the group. Any 
number formats or formulas associated with cells in the group are changed to match 
those of the upper-left cell.

Autofilling doesn’t set up an ongoing relationship among cells in the group. After 
autofilling, you can change the data, number formatting, or formula in any of the cells 
in the group. 

To autofill a range of cells:
1 Select the cell whose data, number formatting, and/or formula you want to paste into 

other cells.

2 Select adjacent cells to autofill, making sure that the cell whose contents you want to 
paste is the upper-left cell in the group. Cells in the group can be in the same row or 
column and in adjacent rows or columns, but they must be contiguous. See “Selecting 
Table Cells” on page 167 for selection instructions.

3 Open the Table Inspector. Click Inspector in the toolbar (or choose View > Show 
Inspector), and then click the Table Inspector button.

4 Click the Numbers button, and then click the Fill button.

Paste the contents of the 
upper-left selected cell into 
the other selected cells.
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Using Formulas
A formula is a set of operations for deriving a value. You can add a formula to a table 
cell to display a value derived using values in other table cells. 

For example, you can add a formula to the bottom cell of a column that adds the 
numbers in all the other cells in the column. If any of the column values change, the 
total in the bottom cell changes automatically.

Formulas derive values by using operators or functions. 

Â Operators perform operations such as addition (+) and multiplication (*). 

Â Functions are predefined, named operations, such as SUM and AVERAGE.

You don’t need to understand more than this to use formulas in tables. Pages 
templates (such as the Expense Report and Invoice templates) and Pages formula 
editing tools make basic formulas easy to use. “Operators and Functions for Advanced 
Table Formula Users” on page 193 provides information for working with more 
advanced formulas.

A Tour of Using Formulas
Reviewing the formulas built into the Invoice template is a good introduction to Pages 
formulas.

1 Create a new Pages document using the Invoice template. 

Open Pages, choose File > New, click Stationery, select Invoice, and click Choose.

The table in this template uses formulas to derive the values in the Cost column.

A formula in each cell in 
the Cost column 
automatically updates 
totals when quantity or 
unit price changes.
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2 Select the table, then double-click the value in the Cost cell in the first row. The 
Formula Editor opens, revealing that the value is derived using a formula.

The symbol * is the multiplication operator. 

3 To understand which cells B2 and C2 are, look at the reference tabs that appeared on 
the table’s top and left sides when the Formula Editor opened.

The reference tabs help you quickly identify any cell in a table. In a formula, you refer 
to a cell by identifying the column, then the row, creating what’s known as a cell 
reference.

B2 is the cell reference for column B (Quantity), row 2. C2 is the cell reference for 
column C (Unit Price), row 2. The value in row 2 of the Cost column (E2) is derived by 
multiplying Quantity by Unit Price values that reside in row 2.

The formula in the Cost cell 
in the first row multiplies the 
values in two other cells—B2 
and C2.

Columns are referenced 
alphabetically.

Rows are referenced 
numerically.

This is cell B2.
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4 The values in the Unit Price and the Cost column are displayed using a number 
format. 

To see the number format settings, close the Formula Editor by clicking outside the 
table. Then click the table, click the Unit Price cell in the second row, click Inspector in 
the toolbar, select the Table Inspector, and click the Numbers button.

See “Formatting Numbers” on page 178 for instructions for using formatted numbers.

5 If the value in a Quantity cell or in a Unit Price cell changes, the formula associated 
with the Cost cell updates the value it displays.

Double-click the value in B2, type a different number, click outside B2, and notice that 
the value in E2 changes.

6 The value displayed for each cell in the Cost column above the subtotal is derived 
using values in each row. 

To view the formula for a different Cost cell, double-click the cell. For example, double-
click the Cost cell in the third row (E3). Its formula is B3*C3.

7 Click outside the table, click the table, and then double-click E10, the cell in the Cost 
column that’s next to the label “Subtotal.” The formula uses the SUM function to add 
the values in cells E2 through E9. 

In the formula, the cell references are enclosed in parentheses following the function 
name—SUM(E2:E9). E2 and E9 are separated using a colon. The colon is a shorthand 
way to refer to a range of cells, in this case, a range of eight cells.

A $ is displayed in front 
of numbers in the cells. 

The comma is used as 
the thousands separator.

Numbers are displayed using 
two decimal places.

Number formatting is 
active for Unit Price cells.



186 Chapter 8    Creating Tables

 

8 Cells E11 and E12 also contain formulas. Examine the formulas in these cells by clicking 
outside the table, selecting the table, then double-clicking cell E11 or E12. Cell E11 
contains a formula that computes sales tax, and cell E12 contains a formula that sums 
the subtotal and the sales tax.

Adding a Quick Formula
The easiest way to perform a basic calculation using values in a range of adjacent 
table cells is to add a quick formula using the Table Inspector’s Formula pop-up menu.

Â Sum totals the values in the cells.

Â Average calculates the arithmetic mean of the values in the cells.

Â Min determines which value in the cells is the smallest.

Â Max determines which value in the cells is the largest.

Â Count determines how many of the values in the cells are numbers.

Â Product multiplies all the values in the cells.

To perform a basic calculation using column values:
1 Select a range of adjacent cells in a column. 

2 Click Inspector in the toolbar, click the Table Inspector button, and click Numbers.

3 Choose a formula from the Formula pop-up menu.

Pages places the formula and its result in the first empty cell beneath the selected 
cells. If there is no empty cell, Pages creates a new row to hold the result.

If the column has a header cell and you want the formula to use all the values in the 
column, click the header cell before choosing the formula.
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To perform a basic calculation using row values:
1 Select a range of adjacent cells in a row. 

2 Click Inspector in the toolbar, click the Table Inspector button, and click Numbers.

3 Choose a formula from the Formula pop-up menu.

Pages places the formula and its result in the first empty cell to the right of the 
selected cells. If there is no empty cell, Pages creates a new column to hold the result.

If the row has a header cell and you want the formula to use all the values in the row, 
click the header cell before choosing the formula.

Removing a Formula
To remove a formula from a cell:

1 Select the cell.

2 Press the Delete key.

Using the Formula Editor to Add and Edit Formulas
The Formula Editor lets you create and modify formulas. 

To open the Formula Editor:
m Select a table cell and type the equal sign (=).

m Select a table cell that contains a formula, and click in the cell or press Return or Enter.

Insert Formula button 
Press and hold to choose a 
predefined function from 
the pop-up menu.

An equal sign is 
always the first 
element in a formula.

Text field
View or edit a formula 
in this field.

Cancel button
Discard changes.

Accept button
Save changes.
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m Select a table cell, click Inspector in the toolbar, and click the Table Inspector button. 
In the Numbers pane, choose Formula Editor from the Insert Formula pop-up menu.

To add a new formula using the Formula Editor:
1 Select the cell in which you want to display the result of the formula.

2 Open the Formula Editor. For example, type the equal sign (=).

3 Type a formula in the text field, or click the Insert Formula button to use a predefined 
function. 

See “Using Cell References” on page 189 to learn techniques for including cell 
references in your formulas.

See “Using Predefined Functions” on page 191 to learn how to insert a function into a 
formula by using the Formula Editor’s Insert Formula button.

See “Performing Arithmetic Operations” on page 191 to learn how to add a formula 
that performs arithmetic.

See “Operators and Functions for Advanced Table Formula Users” on page 193 for 
detailed information about using specific operators and functions in formulas.

4 Click the Accept button to save your formula.

To edit an existing formula:
m Double-click a table cell that contains a formula. The Formula Editor opens, with the 

formula displayed in the text field. You can use the arrow keys to move the insertion 
point around in the text field.

To save a formula:
m In the Formula Editor, press Return, press Enter, or click the Accept button.

m Click outside the table.

To discard changes you’ve made to a formula:
m In the Formula Editor, press Esc or click the Cancel button.

m To close the Formula Editor and discard changes, click the Close button.
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Using Cell References
When the Formula Editor is open, cell reference tabs appear on the table’s top and left 
sides. 

The reference tabs help you quickly create a cell reference. A cell reference identifies a 
column (using letters) and a row (using numbers). For example, A1 is the top left cell. 
A4 is the cell in the fourth row of the first column.

To add cell references to the Formula Editor’s text field:
m To refer to a specific cell, click to place the insertion point in the text field where you 

want the reference to appear, and then click a cell in the table. The Formula Editor 
inserts a reference to the cell. 

You can also type a cell reference (A4) in the text field, using the reference tabs as 
guides.

m To add a reference to a list of individual cells, click each cell. The Formula Editor 
automatically inserts an addition operator (+) between them.

You can also type multiple cell references separated by a comma (or a semicolon if 
you’re in a locale where the decimal separator is a comma). For example, to sum 
values in three cells, you could type SUM(C2,D2,E2) in the text field of the Formula 
Editor.

Columns are referenced 
alphabetically.

Rows are referenced 
numerically.

This is cell B2.
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m To add a reference to a range of cells, click the Insert Formula button in the Formula 
Editor and choose a function from the pop-up menu. Drag over the cells you want to 
add. The Formula Editor inserts the first and last cell references of the range, separated 
by a colon (A2:A4). See “Using Predefined Functions” on page 191 for more 
information about the Insert Formula button.

You can also type or click the first cell, type a colon, and then type or click the last cell.

m To refer to all the cells in a column, type the column’s letter. If the column has a 
header row, you can click the column header cell instead. 

m To refer to all the cells in a row, enter 1:1 for the first row header, 2:2 for the second 
row header, and so on. If the row has a header column, you can click it instead.

Adding a Formula to Multiple Cells
When a table has header cells, you can use them to quickly add a formula to multiple 
rows or columns.

To use a column header to sum the values in each row:
1 Select the header for the column whose cells you want to contain the formula. We’ll 

use column header C1 as an example.

2 Open the Formula Editor. For example, type the equal sign (=).

3 To add a formula that sums the values in columns A and B, click the column header 
cell for column A, and then click the column header cell for column B. The Formula 
Editor text field displays =A+B.

You could also type A+B in the text field.

4 Click the Accept button or press Return or Enter to save the formula.

Every cell below the header in column C now contains a version of the formula that 
refers to cells in only its row. For example, if you select C2 and type the equal sign (=) 
to open the Formula Editor, you’ll see =A2+B2 displayed in the text field.

As this example illustrates, you can type a cell reference instead of clicking a header 
cell. To refer to all the cells in a column, type the column’s letter, as in the example. To 
refer to all the cells in a row, type 1:1 for the first row header, 2:2 for the second row 
header, and so on.
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Performing Arithmetic Operations
To create a formula that performs an arithmetic operation, you use arithmetic 
operators. For example, to add the values in two columns, you could create a formula 
that looks like this:  A2 + A3 + A5.

Here are the basic arithmetic operators. For complete information about operators 
that Pages supports, see “Defining Formulas That Use Operators” on page 193. 

To add an arithmetic formula to a cell:
1 Select an empty cell for displaying the results of the formula.

2 Open the Formula Editor. For example, type an equal sign (=).

3 Enter the formula in the text field following the equal sign. For example, to enter the 
formula A3 * B5 + B6, in the text field following the equal sign you could:

a Click or type A3.

b Type * (the multiplication operator).

c Click or type B5.

d Click B6 (if you don’t type an operator before clicking, the Formula Editor adds the 
plus sign (+) automatically).

4 Click the Accept button or press Return or Enter to save the formula.

Using Predefined Functions
The Insert Formula button in the Formula Editor lets you quickly add a function to a 
formula.

When you use a function, you name the function and, in parentheses following the 
name, you provide the arguments it needs. Arguments specify the data the function 
will use when it performs its operations. 

To perform this operation Use this arithmetic operator For example

Sum two values + A2 + B2

Subtract one value from 
another value

– A2 – B2

Multiply two values * A2 * B2

Divide one value by another 
value

/ A2 / B2
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Here are some examples of formulas that use functions:

Â SUM(A2:A10). This formula uses the SUM function to add values in nine cells of the 
first column. There is one argument, A2:A10. The colon means the function should 
use the values in cells A2 through A10.

Â AVERAGE (A2,B2,C2). This formula uses the AVERAGE function to compute the 
arithmetic mean of three values in the second row. There are three arguments:  A2, 
B2, and C2.

Here’s a summary of the functions you can add using the Insert Formula button. 

You can also type these and other functions into the text field of the Formula Editor. 
For complete information about all the functions that Pages supports, see “Defining 
Formulas That Use Functions” on page 195.

To use a predefined function in a formula:
1 Select an empty cell for displaying the results of the formula.

2 Open the Formula Editor. For example, type the equal sign (=).

3 Click the Insert Formula button, and choose a function from the pop-up menu.

Pages inserts the function into the text field, followed by a pair of parentheses.

4 Within the parentheses, insert references to cells whose values you want the function 
to use. 

To perform this operation Use this function For example

Sum the values in two or more 
cells

SUM SUM(A2:A5)

Average the values in two or 
more cells

AVERAGE AVERAGE(A2:A5)

Determine the smallest value 
in two or more cells

MIN MIN(A2:A5)

Determine the largest value in 
two or more cells

MAX MAX(A2:A5)

Determine how many values 
in two or more cells are 
numbers

COUNT COUNT(A2:A5)

Multiply the values in two or 
more cells

PRODUCT PRODUCT(A2:A5)
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For example, to refer to nine cells in column A (A2 through A10), you could drag from 
cell A2 to cell A10. You can also:

a Click or type A2.

b Type a colon.

c Click or type A10.

5 Click the Accept button or press Return or Enter to save the formula.

Operators and Functions for Advanced Table Formula Users
After becoming familiar with the Formula Editor and cell references, you can create a 
wide variety of formulas. 

The remainder of this chapter fully describes the operators and functions that you can 
include in your formulas when you type them in the text field of the Formula Editor.

Defining Formulas That Use Operators
You use operators in formulas when you want to perform arithmetic or comparison 
operations:

Â A2 + A3. This formula adds the values in two cells of the first column.

Â A2 > B6. This formula determines whether the value in cell A2 is larger than the 
value in cell B6. If it is, the result is TRUE; otherwise, it is FALSE.

Arithmetic operators perform arithmetic and return numerical results.  

This operator Returns
Example (A2 contains 20 and 
B2 contains 2)

+ The sum of two values A2+B2 returns 22

– The difference between two 
values

A2–B2 returns 18

* The product of two values A2*B2 returns 40
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Comparison operators compare two values and return TRUE or FALSE.  

/ The result of dividing one 
value by another value

A2/B2 returns 10

^ The result of raising one value 
to the power another value

A2^B2 returns 400

% The result of dividing a value 
by 100

A2% returns 0.2 

Notes:
Â When a cell reference points to an empty cell, 0 is the value used. 
Â When a cell reference points to a cell containing FALSE, 0 is used. If the cell

contains TRUE, 1 is used. For example, TRUE + 1 returns 2.
Â Using a text string with an arithmetic operator returns an error. 

For example, 3 + “hello” is not a correct arithmetic operation.

This operator Returns
Example (A2 contains 20 and 
B2 contains 2)

This operator Returns
Example (A2 contains 20 and 
B2 contains 2)

= TRUE if two values are equal A2=B2 returns FALSE

<> TRUE if two values aren’t equal A2<>B2 returns TRUE

> TRUE if the first value is 
greater than the second value 

A2>B2 returns TRUE

< TRUE if the first value is less 
than the second value

A2<B2 returns FALSE

>= TRUE if the first value is 
greater than or equal to the 
second value

A2>=B2 returns TRUE

<= TRUE if the first value is less 
than or equal to the second 
value

A2<=B2 returns FALSE

Notes:
Â Text strings are larger than numbers. For example, “hello” > 5 returns TRUE.
Â TRUE and FALSE can be compared with each other, but not with numbers 

or text strings. TRUE > FALSE, and FALSE < TRUE. 
Â To type a Boolean value (TRUE or FALSE), type an equal sign, type the value 

in the Formula Editor, and press Return.
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Defining Formulas That Use Functions
The following tables provide information about the three kinds of 
functions:  statistical, numerical, and logical. In the tables, these conventions are used 
to describe arguments:

Â The argument placeholders—x, x1, and so forth—represent places where input to 
the functions (such as cell references or constants) should go.

Â The ellipsis (...) following a list of arguments means you can use additional 
arguments. Place a comma between arguments; if you’re in a locale where the 
decimal separator is not a period, place a semicolon between arguments.

Â Functions that don’t require a specific number of arguments (such as AVERAGE) can 
include cell range references (such as A4:A6) instead of or in addition to other 
arguments.

Statistical functions perform statistical calculations. 

This function Returns Examples

AVERAGE(x1 ...) The arithmetic mean of the 
arguments

AVERAGE(2, 3) returns 2.5

COUNT(x1 ...) The number of arguments that 
are numeric

COUNT(1, 2, ”hello”) returns 2
COUNT(A1:A4) returns 2 if A1 
and A2 contain numbers, but 
A3 and A4 are empty

MAX(x1 ...) The value of the largest 
argument

MAX(–1, 42, 7) returns 42

MIN(x1 ...) The value of the smallest 
argument

MIN(–1, 42, 7) returns
–1

Notes:
Â If an argument is a reference to a cell that doesn’t contain a number,

the argument is ignored. TRUE is interpreted as 1, FALSE is interpreted as 0, 
and text strings result in an error.
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Numerical functions perform arithmetic calculations. 

This function Returns Examples Notes

ABS(x) The absolute value of 
the argument

ABS(3.6) returns 3.6
ABS(–3.6) returns 3.6
ABS(TRUE) returns 1

Interprets TRUE as 1 
and FALSE as 0

INT(x) The whole number 
nearest the argument 
that is no larger than 
the argument

INT(3.1) returns 3
INT(3.7) returns 3
INT(–3.1) returns –4
INT(42) returns 42

Interprets TRUE as 1, 
and FALSE and 
references to empty 
cells as 0

MOD(x, y) The remainder after 
dividing x by y

MOD(5,2) returns 1
MOD(–1.2,7) returns 
5.8

The sign of the 
returned value is the 
same as the sign of y. 
Also see note at end 
of table.

PRODUCT(x1 ...) The product of the 
arguments

PRODUCT(2, 4) returns 
8

See note at end of 
table.

ROUND(x, y) The number that 
results after rounding 
x to y decimal places

ROUND(3.1415, 2) 
returns 3.14
ROUND(3.1415, –7) 
returns 0
ROUND(3.1415, 2.7) 
returns 3.14

Rounds y toward 0 to 
the nearest integer. If 
y, after rounding, is 
negative, returns 0.
Also see note at end 
of table.

SIGN(x) 1 if x is greater than 0
0 if x is equal to 0
–1 if x is less than 0

SIGN(42) returns 1
SIGN(0) returns 0
SIGN(–42) returns –1

Interprets TRUE as 1, 
and FALSE and 
references to empty 
cells as 0

SUM(x1 ...) The sum of the 
arguments

SUM(1, 2) returns 3
SUM(1, TRUE) returns 
2

Also see note at end 
of table.

Notes:
Â If an argument of MOD, ROUND, or SUM is a reference to a cell that 

doesn’t contain a number, the argument is ignored. TRUE is interpreted as 1, 
FALSE is interpreted as 0, and text strings result in an error.
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Logical functions determine whether a particular condition is TRUE or FALSE. 

This function Returns Examples Notes

AND(x1 ...) TRUE if all the 
arguments are TRUE, 
otherwise returns 
FALSE

AND(TRUE, TRUE) 
returns TRUE
AND(TRUE, FALSE) 
returns FALSE
AND(TRUE, 0) returns 
FALSE

See note at end of 
table.

ISERROR(x) TRUE if x is erroneous, 
otherwise returns 
FALSE

ISERROR(1/0) returns 
TRUE

NOT(x) TRUE if x is FALSE
FALSE if x is TRUE

NOT(TRUE) returns 
FALSE
NOT(FALSE) returns 
TRUE

Interprets 0 as FALSE 
and all other numbers 
as TRUE

OR(x1 ...) TRUE if any argument 
is TRUE, otherwise 
returns FALSE

OR(TRUE, FALSE) 
returns TRUE
OR(FALSE) returns 
FALSE

See note at end of 
table.

Notes:
Â If an argument of AND or OR is a reference to a cell that doesn’t contain 

TRUE or FALSE, the argument is ignored. When you type arguments, rather 
than referring to cells for values, zero is interpreted as FALSE, any other number 
is interpreted as TRUE, and text strings result in an error.
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9 Creating Charts

You can turn spreadsheet data into attractive 
charts. This chapter outlines the basics of creating 
charts in Pages.
Pages provides tools for creating your own visually appealing charts to present 
numerical data. You can copy and paste your data from a spreadsheet, or type it 
directly into the Chart Data Editor to create and edit your charts right on the page.

About Charts
Charts show the relationship of two types of data with respect to each other. For 
example, if you chart business growth over time, you are showing the relationship 
between the size of the business and the passage of years. If you chart voting results 
among different demographic groups, you are showing the relationship between the 
number of people who voted a certain way and their demographic affiliation. When 
you enter data for a chart, the two different types of data are represented as data 
series and data sets.

Data Series and Data Sets
In a business chart, an example of a data series could be one region’s profits over four 
successive years; the data sets could be all of the regions’ profits for only one of those 
years. In the illustration below, the data series (each region’s profits) are in rows, and 
the data sets (each year’s profits) are in columns. Each individual value (for example, 
17 for Region 1, 2004) is a data point.
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The colored squares next to the row labels (Region 1 and Region 2) show which color 
represents each data series in the chart.

The illustration below shows how this data looks as a column chart.

In this chart, the data series are represented by rows in the Chart Data Editor. The data 
points are represented as a series of dark-colored bars and a series of light-colored 
bars. 

Most charts have three-dimensional (3D) versions. Here’s what the 3D column chart 
looks like for the data series above.

These squares indicate 
which color represents 
each data series.

The data sets contain 
one data point (one bar) 
from each of the data 
series.

These four bars represent 
one data series.

The chart legend denotes 
the two data series.
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Transposing Data Series and Data Sets
You can easily switch the data series and data sets in your charts—without having to 
retype the data—by using the Plot Row vs. Column button in the Chart Data Editor.

The column chart below shows the same data, but with the data sets and data series 
transposed.

This button makes the rows 
of data in the Chart Data 
Editor the data series.

This button makes the 
columns of data in the Chart 
Data Editor the data series.
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For this chart, the data series are represented by columns in the Chart Data Editor 
pictured earlier. There are now four data series represented as four different-colored 
bars.

Data series are represented differently in the different kinds of charts provided by 
Pages.

Â In column charts and bar charts, a data series is represented by a series of bars in 
the same color (as shown above). 

Â In a line chart (also called a graph), a data series is represented by a single line. 

Â In an area chart, a data series is represented by an area shape. 

Â In a pie chart, only a single data set—the first data point in each series—is 
represented on the chart (whichever is listed first in the Chart Data Editor).

Â In a scatter chart, two columns of data are used to plot values for a single data 
series. Each pair of values determines the position of one data point.

Adding a Chart
Charts can be added inline with text or fixed on the page. (To learn about fixed and 
inline objects, see “Fixed Objects Versus Inline Objects” on page 124.) After you have 
added the chart to the page, you can change the chart type and format it by using 
the Chart Inspector, pictured later in this chapter.

These two bars represent 
one data series.

The data sets contain 
one data point (one bar) 
from each of the four 
data series.
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Inserting a Chart
To add a chart inline with text:

1 Place the insertion point wherever you want the chart to appear in the text flow.

2 Click Objects in the toolbar and choose Chart (or choose Insert > Chart). A chart 
containing placeholder data appears on the page. The Chart Inspector and Chart Data 
Editor open.

To place a fixed chart:
1 Click anywhere outside the text areas of the document so that no insertion point is 

visible.

2 Click Objects in the toolbar and choose Chart (or choose Insert > Chart). A chart 
containing placeholder data appears on the page. The Chart Inspector and Chart Data 
Editor open.

3 Drag the chart to wherever you want it to appear on the page.

You can also draw a chart on the page.

To draw a chart on the page:
1 Hold down the Option key while you click Objects in the toolbar and choose Chart.

2 Release the Option key and move the pointer over the page until it becomes a 
crosshair.

3 Drag across the page to create a chart any size you want.

Resizing a Chart
To resize the chart on the page:

m Select the chart in the page and drag the active selection handles.

Selecting a Chart Type
Pages provides numerous types of charts to choose from, including bar charts, 3D bar 
charts, line charts, 3D line charts, pie charts, and more. After you’ve placed a chart on 
a page, you can change its type and format it using the Chart Inspector.

To open the Chart Inspector:
m Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 

Chart Inspector button.
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To select a chart type, do one of the following:
Â Choose Format > Chart > [chart type].

Â In the Chart Inspector, choose a chart from the pop-up menu that appears when 
you click the chart icon in the upper left.

To change a chart from one type to another:
1 Select the chart.

2 In the Chart Inspector, choose a different chart type from the pop-up menu. You can 
also choose Format > Chart > Chart Type > [chart type].

Â If you switch to a pie chart, Pages charts only the first data set in the Chart Data 
Editor. See “Pie Charts” on page 211.

Â If you switch to a scatter chart, each point in the chart requires two values, so every 
series uses two columns in the Chart Data Editor. See “Scatter Charts” on page 215.

Â If you switch to a bar, column, area, or line chart, each series in the new chart 
corresponds to a row in the Chart Data Editor.

Â If you switch to a 3D version of a chart, the Chart Inspector provides controls for 
managing object depth and lighting style. See “Using 3D Charts” on page 217.

The Chart Inspector 
button

Choose a chart type from the 
pop-up menu. 2D charts are 
on the left, and 3D charts are 
on the right.
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Formatting you’ve applied to the chart you’re changing may not be applied to the 
new chart. For example, the color fill attribute has a different default value for each 
type of chart. If you’ve changed a column fill color and then change the chart to be a 
bar chart, the fill color change isn’t retained. 

Â Depending on the type of chart, the attributes that may change when you change a 
chart’s type are show value label, value label position, text style, series stroke, series 
shadow, series fill, data point symbol, and data point fill. 

Â Bar/column charts and stacked bar/column charts share attributes except for value 
label position. Also, bar/column charts have separate fills.

Â 3D chart shadows are shared across chart types.

When you change a chart’s type and the new type has some of the same attributes, 
those attributes don’t change. Shared attributes include axes, gridlines, tick marks, axis 
labels, show minimum value, number format, borders, rotation, shadows, and 3D 
lighting style.

You’ll learn more about these attributes throughout the remainder of this chapter.

Editing Chart Data
To edit chart data, open the Chart Data Editor and enter your data by typing it or by 
copying and pasting from Excel, AppleWorks, or other spreadsheet applications.

To open the Chart Data Editor:
1 Select the chart you want to edit.

2 Choose Format > Chart > Show Data Editor (or click Edit Data in the Chart Inspector).
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To copy data from another spreadsheet into the Chart Data Editor:
1 Open the spreadsheet with the data you want, and select all the relevant cells.

2 Choose Edit > Copy (or press Command-C).

3 Select the top cell in the first column of the Chart Data Editor.

4 Choose Edit > Paste (or press Command-V).

To edit the names of rows and columns or the data in a cell:
m Double-click a cell or a row or column label and type.

To reorder rows or columns in the Chart Data Editor:
m Drag a row or column label to a new position.

To add rows or columns in the Chart Data Editor:
m Click Add Row or Add Column to place a row above the selected row or a column to 

the left of the selected column. If no row or column is selected, the new row or 
column appears at the bottom or right edge of the table. (To see the new row or 
column, you may have to press the Return key or the Tab key, expand the Chart Data 
Editor window, or scroll.)

m Alternatively, select any blank cell, type your data, and press Return. A new row or 
column is automatically created.

To delete rows or columns:
m Select the row or column label and press Delete.

Click these buttons to 
add another row or 
column for data.

Type chart data directly 
into these spreadsheet 
cells.

Drag labels to reorder 
them.
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Formatting Charts
You can resize and reposition charts and chart legends just like any other object. You 
can format chart elements—fonts, colors, axis labels, and tick marks—to suit your 
preferences. You can hide the chart legend. You can adjust the angle and lighting style 
of 3D charts. Most chart formatting tasks are done using the Chart Inspector. You can 
also accomplish many tasks using shortcut menus.

To open a chart’s shortcut menu:
m Hold down the Control key and click a chart.

To hide the chart legend:
1 Click Inspector in the toolbar (or choose View > Show Inspector), and then click the 

Chart Inspector button.

2 Select the chart.

3 In the Chart Inspector, deselect the checkbox labeled Show Legend.

You can also select the legend and press Delete; you can always display the legend 
again by selecting the Show Legend checkbox.

Setting Chart Colors
You can format the bars, wedges, and area shapes that appear on each type of chart 
just as you format any other drawn object. You can give them color fills, gradient fills, 
image fills, shadows, opacity, or different line styles. You set these attributes in the 
Graphic Inspector.

To change the color or image in a bar, wedge, or area shape:
1 Select the item (bar, wedge, or area shape). 

If you select one bar in a bar chart, all the bars in that data series are selected.

2 Change chart properties as you would for any drawn object using the Graphic 
Inspector. 

For more information about changing object properties, see Chapter 7, “Changing 
Object Properties.”
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Changing Chart Fonts
You can change the fonts and text colors used for axis labels, data point labels, and 
legends.

To change chart fonts:
1 Select the text you want to change. 

To change the font on all chart elements, click the chart to select it. If you select the 
text for one data point or axis label, all the text of that kind is also selected. You 
change the font for a chart legend separately.

2 Click Fonts in the toolbar (or choose Format > Font > Show Fonts) to open the Font 
panel.

3 Select a font.

For information about changing text colors, see “Formatting Text Size and 
Appearance” on page 79.

Adding Labels and Axis Markings
Use the Axis pane in the Chart Inspector to format the grid and general look of the 
axes for bar charts, line charts, and area charts. You can set the range of values to be 
displayed along the value axis, the axis on which you read the data point values. For 
column charts (vertical bars), line charts, and area charts, the Y-axis is the value axis. 
For horizontal bar charts, the X-axis is the value axis. For scatter charts, both axes are 
value axes. (Pie charts don’t have a value axis. To read about formatting pie charts, see 
“Pie Charts” on page 211.)
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To show or hide axes and chart borders:
1 Select the chart.

2 In the Chart Inspector, click the Axis button if it is not already selected.

3 Choose one or more items from the Axes & Borders pop-up menu to select it.

A selected item has a checkmark next to it; choose the item again to deselect it.

To set the range of numerical values displayed on the chart grid:
1 Select the chart.

2 In the Chart Inspector, click the Axis button if it is not already selected.

3 To set the value at the chart origin, type a number in the Minimum field (under Value 
Axis Format).

The Minimum value cannot be higher than the minimum value of your entire data set.

4 To set the highest number displayed on the value axis, type a number in the 
Maximum field.

The Maximum value cannot be lower than the maximum value of your entire data set.

5 To specify the number of axis markings between the minimum and maximum values, 
type a number in the Steps field.

To display the minimum data value on the value axis:
1 Select the chart.

2 In the Chart Inspector, click the Axis button if it’s not already selected.

Set styles for labels 
and tick marks along 
the chart grid.

Select units for values in 
the chart.

Show or hide axes and chart 
borders (2D charts only).

Set the range of values 
that appear on the chart 
grid.
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3 Choose Show Value Labels and Show Minimum Value from the Labels, Ticks, & Grids X-
Axis or Y-Axis pop-up menu, depending on the chart.

An item is selected when it has a checkmark next to it.

To specify units for axis values:
1 Select the chart.

2 In the Chart Inspector, click the Axis button if it is not already selected.

3 Under Number Format, type text in the Prefix or Suffix field (or choose a symbol from 
the pop-up menus).

Placing Grid Labels and Tick Marks
The X-Axis and Y-Axis pop-up menus in the Axis pane of the Chart Inspector provide 
an array of options for placing tick marks, labels, and gridlines along the value axis or 
the series axis. The options in these pop-up menus (pictured on the following page) 
vary depending on the kind of chart you select.

For vertical bar charts (column charts), line charts, and area charts, the Y-axis is the 
value axis and the X-axis is the series axis. For horizontal bar charts, the X-axis is the 
value axis. For scatter charts, both axes are value axes. For 3D charts, the X and Y axes 
are the same as their 2D counterparts.

Pop-up menus are pictured on the following page as they appear when a column 
chart is selected.

To place grid labels and tick marks along an axis:
1 Select the chart.

2 In the Chart Inspector, click the Axis button if it is not already selected.
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3 To add grid labels and tick marks along the X-axis, choose an option from the X-Axis 
pop-up menu. The menu for a column chart looks like this:

4 To add grid labels and tick marks to the Y-axis, choose an option from the Y-Axis pop-
up menu. Here’s what the menu looks like for a column chart:

Formatting the Elements in a Data Series
You can use a variety of visual effects to enhance the appearance of data series 
elements.

To add data point labels:
1 Select the chart or an element in a data series.

For all chart types except pie charts, selecting one element (such as a bar) of a series 
automatically selects the full series. For pie charts, you can select individual wedges.

2 In the Chart Inspector, click the Series button. 

3 Choose Show Value from the Data Point Label pop-up menu.

Place tick marks along 
the X-axis.

Show or hide the 
X-axis gridlines.

Set the text direction for 
the series axis labels.

Show or hide series 
axis labels.

Place tick marks along 
the Y-axis.

Show or hide the Y-axis 
gridlines.

Show or hide value axis 
labels.
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4 To specify the number of decimal places you want to display, type a number in the 
Decimals field.

5 To change the position of data point labels, choose an option from the Data Point 
Label pop-up menu.

6 Use the Font panel (Format > Font > Show Fonts) to choose a font, font size, and style 
for the data point labels.

For pie charts, you can show data point labels as a percentage of the whole or as 
absolute values by selecting or deselecting “Show Pie Values as Percentages” in the 
Data Point Label pop-up menu. You can also show the series names.

Some chart styles offer other options for formatting series elements. See the following 
sections for information about special formatting options for pie charts, bar and 
column charts, area and line charts, scatter charts, and 3D charts. 

Pie Charts
For pie charts, Pages charts only the first data set in the Chart Data Editor (the first 
data point for each data series). If the data series are in rows in the Chart Data Editor, 
only the first column is charted; if the data series are in columns in the Chart Data 
Editor, only the first row is charted. Thus, one pie chart represents a single data set, 
and each wedge is one element in that set. Other data sets in the Chart Data Editor 
are maintained, but they are not displayed in the pie chart. You can chart any data set 
by moving it to the first position in its row or column.

To select individual pie wedges:
1 Select the chart, then click to select a single wedge.

2 To select additional wedges, do one of the following:

Â To select all the wedges, choose Edit > Select All (or press Command-A).

Â To select noncontiguous wedges, hold down the Command key as you select each 
wedge.

Â To select a continuous range of wedges, select the first wedge, then hold down the 
Shift key as you select the last wedge.
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On pie charts, in addition to showing values for wedges, you can display the series 
name.

To show a series name in a pie chart:
1 Select the chart or individual pie wedges.

2 In the Chart Inspector, click the Series button. 

3 Choose Show Series Name from the Data Point Label pop-up menu.

4 Choose Inside or Outside from the Data Point Label pop-up menu.

You can separate any (or all) of the pie wedges.

To separate individual pie wedges:
1 Select the individual pie wedges. (To select more than one pie wedge, hold down the 

Command key as you click each wedge.)

2 Drag the pie wedges or the Explode slider until the pie wedges are separated as far as 
you want.

You can also type a number in the Explode field, or use the arrows to increase or 
decrease the number.

You can put shadows on individual pie wedges or on the pie as a whole. Putting 
shadows on individual wedges makes it look like the wedges are in different layers.

Add shadows to 
individual wedges or 
the whole pie.

Separate individual pie 
wedges.

Set a pie wedge apart by 
using the Explode slider 
and giving it a series 
name.
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To put shadows on individual pie wedges:
1 Select the chart or individual pie wedges.

2 In the Chart Inspector, click the Series button.

3 Choose Individual from the Shadow pop-up menu.

4 In the Graphic Inspector, set shadow attributes. (For more information, see “Adding 
Shadows” on page 153.)

To put a shadow on the whole pie:
1 Select the chart.

2 In the Series pane of the Chart Inspector, choose Group from the Shadow 
pop-up menu.

3 In the Graphic Inspector, set shadow attributes. (For more information, see “Adding 
Shadows” on page 153.)

You can also change the opacity of the chart and individual chart elements, such as 
the legend. (For more information, see “Adjusting Opacity” on page 154.)

To rotate a pie chart:
m Select the chart and drag the Rotation Angle wheel in the Series pane of the Chart 

Inspector, or type a value in the Rotation Angle field.

Bar and Column Charts
You can apply shadows to individual data series or to the entire chart. You can adjust 
the opacity for the chart as a whole or for individual series (but not individual bars). 
You can also adjust the spacing between data sets or individual bars.

To adjust spacing between individual bars or data sets:
1 Select the chart.

2 In the Chart Inspector, click the Series button if it is not already selected.

Separate the individual bars 
in the chart.

Separate the data sets in 
the chart.

Add shadows to bars 
or data sets.
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3 To change the space between bars, type a value (or click the arrows) in the “Gap 
between bars” field.

4 To change the space between data sets, type a value in the “Gap between sets” field.

The value is the percentage of the bar thickness. Decreasing the space between the 
bars makes them thicker. You can also move the pointer near a bar edge until it 
becomes a double-headed arrow, then drag to make the bars thicker or thinner.

To put a shadow on each bar:
1 Select the chart or a data series.

2 In the Series pane of the Chart Inspector, choose Individual from the Shadow pop-up 
menu.

If you select one data series and choose an item from the Shadow pop-up menu, the 
choice applies to all series in the chart.

3 In the Graphic Inspector, set shadow attributes. (For more information, see “Adding 
Shadows” on page 153.)

To adjust the opacity of a chart:
m Select the chart and drag the Opacity slider in the Graphic Inspector. For more 

information, see “Adjusting Opacity” on page 154.

Area Charts and Line Charts
In area and line charts, you can use symbols—circles, triangle, squares, and 
diamonds—to represent data points.

To use a symbol for the data points in a series:
1 Select a data series (area shape or line).

The data points in this 
series are represented by 
circles.

The data points in this 
series are represented by 
triangles.
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2 In the Series pane of the Chart Inspector, choose a symbol from the Data Point 
Symbol pop-up menu.

3 Fill the symbol by choosing one of the options in the Symbol Fill pop-up menu.

To set the line color and shadow:
m Use the Stroke and Shadow controls in the Graphic Inspector.

For more information about using the Graphic Inspector to set line color, shadow, and 
the fill for data point symbols, see Chapter 7, “Changing Object Properties.”

Scatter Charts
Scatter charts display data differently from the other kinds of charts. They require at 
least two columns of data to plot values for a single data series. To show multiple data 
series, you use additional two-column pairs. 

Each pair of values determines the position of one data point. The first data value in 
the row is the X-axis of the point. The second data value is the Y-axis of the point.

Here’s what the default scatter chart looks like:

You can view the data for this chart in the Chart Data Editor:

Choose a symbol to use 
for data points.

Fill data point symbols 
with color or images.
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To control the appearance of a scatter chart:
m To format a symbol for a data series, choose a symbol from the Data Point Symbol 

pop-up menu in the Series pane of the Chart Inspector. You can adjust the stroke and 
fill settings of a scatter plot data point symbol by using the Graphic Inspector.

m To specify axis settings, use the Axis pane of the Chart Inspector. Because both axes of 
scatter charts have values, value axis format settings apply to both X-axis and Y-axis. 
Each axis can have its own number format.

Rotating Charts
You can rotate charts by dragging a selection handle (see page 133) or by using the 
Metrics Inspector (see page 155). Pie charts can also be rotated using the Chart 
Inspector (see page 213).

You can’t rotate or flip 3D charts. If a 3D chart is grouped with 2D charts, you can 
rotate the group, but only the 2D charts in it will rotate.
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Using 3D Charts
All the chart types except scatter charts can be displayed as 3D charts. 

Here are 2D and 3D versions of the default pie chart.

And here are 2D and 3D versions of the default line chart.

To select a 3D chart type:
m In the Chart Inspector, choose one from the chart type pop-up menu. You can also 

choose Format > Chart > Chart Type > [3D chart type].

To define 3D scene settings:
m Select a 3D chart, click 3D Scene in the Chart Inspector, and modify the chart’s 

viewing angle and lighting style as desired using the 3D Scene controls.
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To resize a 3D chart:
m Select the chart and drag the active selection handles. The chart is resized through all 

three dimensions.

Click the intersection of the 
arrows and drag to move 
the chart both ways.

Drag an arrow to adjust the 
viewing angle. Click one arrow 
at a time to move the chart in 
a single direction (left-right or 
up-down).

Choose an item from the Lighting 
Style pop-up menu to adjust the 
lighting effect.
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10 Personalizing Documents 
With Address Book Data

This chapter tells you how to use contact 
information stored in Address Book and vCards to 
personalize letters, envelopes, and other Pages 
documents.
You can insert names, phone numbers, addresses—any data you’ve defined for 
contacts in Address Book—into Pages documents. You can also insert data from a 
virtual address card (vCard) that someone has sent you. This capability (sometimes 
referred to as mail merge) lets you reuse a letter, contract, envelope, or other 
document for multiple people when you insert person-specific data into Address Book 
fields in the document. 

Understanding Address Book Fields
When a Pages document contains Address Book fields, contact data is automatically 
inserted into the Address Book fields. Address Book fields identify which Address Book 
or vCard data to insert and where to insert it.

A document can contain two kinds of Address Book fields:

Â A sender field displays information about the document’s distributor. For example, a 
letter can be formatted with a header that uses sender fields to display a company’s 
name, address, and phone number. 

Pages automatically fills sender fields with data from the Address Book card that’s 
designated My Card. But you can use another card to populate sender fields if you 
prefer. 

Â A recipient field displays information for a person who will receive the document. 
For example, you can use recipient fields to insert a person’s name at various 
locations in a letter. 
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When you want to personalize a document for multiple recipients, you specify an 
Address Book group or select multiple individual cards. Pages creates a separate 
version of the content for each contact. In each version of the document, the same 
sender data is used, but the recipient fields are personalized. Personalized results 
can be printed or saved in a new document with a section for each contact.

Using Address Book Fields
Many of the Pages templates have predefined Address Book fields. 

You can also create your own Address Book fields, as “Defining Your Own Address 
Book Fields” on page 222 describes.

To insert sender data:
m Open a document that contains sender fields, such as a letter template. Pages 

automatically inserts data from your Address Book My Card into the fields. If the card 
doesn’t contain data for any of the sender fields, the field label is displayed.

If you want to use a different card for sender data, drag an Address Book card or vCard 
to a sender field in the document. The new card’s data is applied to all sender fields in 
the document.

To insert recipient data for one contact:
1 Open a document template that contains recipient fields.

2 Select the contact’s Address Book card or vCard and drag it to a recipient field. The 
contact’s data appears in all the recipient fields in the document. If the card doesn’t 
contain data for one of the recipient fields, the field label is displayed.

3 Save or print the document if desired.

4 To reuse the document with another contact’s data, select another card and drag it to 
a recipient field. The new data replaces the recipient data inserted in step 2. 

To insert recipient data for all contacts in an Address Book group:
1 Open a document that contains recipient fields.

2 Choose Edit > Merge Address Book Cards, then choose a group or All from the pop-up 
menu.

You can also select a group or All in Address Book and drag it to a recipient field in the 
document.
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3 In the dialog that appears, select “Place merge results in a new document” to create a 
new document that contains a section for each contact in the group. Otherwise, 
select “Send merge results to printer” to print a personalized copy of the document for 
each contact in the group. 

The original document is not affected by the merge. You can reuse it for additional 
merges as required. 

To insert recipient data for contacts in multiple cards:
1 Open a document that contains recipient fields.

2 Select the Address Book cards you want to use, and drag them to a recipient field. 

3 In the dialog that appears, click “Place merge results in a new document” to create a 
new document that contains a section for each contact. Otherwise, click “Send merge 
results to printer” to print a personalized copy of the document for each contact. 

The original document is not affected by the merge. You can reuse it for additional 
merges as required.

To insert data you type into Address Book fields:
1 When you want to use contact information that isn’t in Address Book or a vCard, click 

an Address Book field and type the data you want to use. The Address Book field is 
replaced by the text you type. 

2 To retain the version of the document containing Address Book fields you’ve 
eliminated, choose File > Save As to save your changed document as a new file.

If you don’t need to save your changes, simply choose Edit > Undo Typing to restore 
the original Address Book fields.
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Defining Your Own Address Book Fields
When you need to modify an Address Book field or create new Address Book fields, 
you use the Merge pane of the Link Inspector.

To create an Address Book field:
1 Open a Pages document.

2 Place the insertion point at the location where you want the Address Book field to 
appear.

3 If the Link Inspector isn’t open, choose Insert > Address Book Field. Otherwise, select 
“Enable as an Address Book field” in the Merge pane of the Link Inspector. A 
placeholder for the Address Book field is inserted and highlighted.

4 In the Merge pane of the Link Inspector, open the Type pop-up menu. Choose the 
category that best describes the kind of data you want inserted into the field.

5 From the Field pop-up menu, choose the Address Book field whose data you want to 
insert into the Address Book field. The placeholder text is replaced by the name of the 
Address Book field you selected.

6 Click Sender Field or Recipient Field to indicate the kind of Address Book field you 
want to create.

To create a field with a custom name, select the text in your document that you want 
to use as the Address Book field name, then go to step 3 above.

Choose the category 
describing the data you want 
to insert.

Choose the Address Book 
field that contains the data.

Select to make selected text 
an Address Book field.
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To change an Address Book field to use work, home, or other Address Book data:
m When a document uses an Address Book field that has work, home, or other 

variations, you can quickly switch from one variation to another by choosing Edit > 
Choose Address Label > Home, Work, or Other.

To change an Address Book field label:
1 Click the Address Book field whose label you want to change.

2 Type the new label.

3 Select the new label.

4 If the Link Inspector isn’t open, choose Insert > Address Book Field. Otherwise, select 
“Enable as an Address Book field” in the Merge pane of the Link Inspector.

5 In the Merge pane of the Link Inspector, click the Type pop-up menu. Choose the 
category that best describes the kind of data you want inserted into the field.

6 From the Field pop-up menu, choose the Address Book field whose data you want to 
insert into the Address Book field.

7 Click Sender Field or Recipient Field to indicate the kind of Address Book field you 
want to create.

To change an Address Book field:
m To disable an Address Book field, click it, and then deselect “Enable as an Address Book 

field” in the Merge pane of the Link Inspector. If the Link Inspector isn’t open, click 
Inspector in the toolbar, and then click the Link Inspector button.

m To change the underlying Address Book field, click the Address Book field in your 
document, and open the Link Inspector. In the Merge pane, use the Type and Field 
pop-up menus to specify the new field.

m To change an Address Book field from a sender field to a recipient field or vice versa, 
click the Address Book field and open the Link Inspector. Click Sender Field or 
Recipient field, as appropriate.

m To delete an Address Book field, click it and then press the Delete key.
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11 Printing and Exporting Your 
Document to Other Formats

This chapter describes the various ways you can 
print, view, and share your Pages document. 
In addition to printing or faxing your document, you can share your document 
electronically. By exporting to other document formats, you can collaborate with 
others who use AppleWorks or Microsoft Word. You can also make your document 
available on the web as a PDF file or as an HTML page.

Printing Your Document
Pages and Mac OS X provide you with tools to print all or part of your document in 
various layouts, and to adjust the color of the printed document.

Setting the Paper Size and Orientation
Before you print, you should make sure the paper size and orientation are set the way 
you want by opening the Page Setup dialog.

To set paper size and orientation:
1 Choose File > Page Setup.

2 In the Page Setup dialog, choose the printer you will use from the “Format for” pop-up 
menu.

3 Choose a standard paper size from the Paper Size pop-up menu. 

If you want to set a custom paper size and you’re using Pages with Mac OS X version 
10.3, go to step 4. If you’re using Mac OS X version 10.4, go to step 5.

4 In Mac OS X version 10.3, choose Custom Paper Size from the Settings pop-up menu.
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a Click New and type a name for the new paper size.

b Specify the paper’s height and width in the Paper Size fields, and specify the 
printable area margins you want to use in the Printer Margins fields.

c Click Save.

d Choose Page Attributes from the Settings pop-up menu. Choose the new paper size 
you named in the Paper Size pop-up menu. It will be near the bottom of the list.

e Click OK.

5 In Mac OS X version 10.4, choose Manage Custom Sizes from the Paper Size pop-up 
menu.

Click to create a new 
custom paper size.

Type a name for the 
custom paper size.

Click to duplicate or delete 
a selected paper size.

If you edit the custom 
paper size options, click 
Save to save the changes.

Set the paper height 
and width.

Set the page margins.
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a Click the Add (+) button, and enter values in the Page Size fields.

b Either choose your printer’s default margins from the pop-up menu, or enter your 
own values for margins in the Left, Right, Top, and Bottom fields.

c If you want to change the custom size’s name, double-click the name in the list and 
enter a new name.

d Click OK.

e Choose the new paper size you named from the Paper Size pop-up menu, and click 
OK.

6 Select an orientation option using one of the buttons at the bottom of the Page Setup 
dialog.

Choose a printer to set its 
default page margins.

Delete a selected 
paper size.

Duplicate a selected 
paper size.

Create a new custom 
paper size.
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Printing All or Part of Your Document
You can print your entire document, a selected page range, or only odd or even 
pages. You can also print several pages on a single sheet of paper or print pages in 
reverse order.

To make sure everything is laid out the way you expect, it’s a good idea to preview a 
document before you print it out.

To preview a document for printing:
1 Choose File > Print, and then click the Preview button in the Print dialog.

Preview shows what individual document pages will look like when printed. It doesn’t 
show the effects of some layout options, such as borders. (For more information about 
layout options, see “Setting a Print Layout and Other Options” on page 228.)

2 Select the checkbox labeled Soft Proof at the bottom-left corner of the Preview 
window to take your printer’s capabilities into account. For example, if you’re printing 
a color document to a black-and-white printer, selecting Soft Proof previews the 
document in black and white.

3 Click Print to print your document directly from the Preview window.

For information about using Preview, see Preview Help. (Choose Help > Preview Help 
when the Preview window is active.)

Landscape orientation 
with the top of the page 
on the left side of the 
paperPortrait orientation 

(default for most 
templates)

Landscape orientation 
with the top of the page 
on the right side of the 
paper
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To print the full document or a range of pages:
1 Choose File > Print.

2 Choose the printer you want to use from the Printer pop-up menu. If you don't see 
the printer you want to use and you’re using Pages in Mac OS X version 10.3, choose 
Edit Printer List and add it. In Mac OS X version 10.4, choose Add Printer.

To learn about adding a printer, search for “Adding a printer” in Mac OS Help. To find 
out where the printer you are using is located, pause with the pointer over the 
printer's name when you are choosing it from the Printer pop-up menu.

3 Type the number of copies you want to print in the Copies field, and select the 
checkbox labeled Collated if you want each group of pages to print together in order 
before printing the next group. If you want to print a batch of page 1, then page 2, 
then page 3, and so on, deselect the checkbox.

4 To print the entire document, select All next to Pages.

5 To print a range of pages, select From, and then type the page number of the first 
page in the From field, and the page number of the last page in the “to” field.

6 Click Print.

Setting a Print Layout and Other Options
The Copies & Pages pop-up menu in the Print dialog provides several other printing 
options, including using ColorSync to adjust color (see page 230), printing your 
document in reverse order, printing only odd or even pages, printing a cover page 
(separator page), and more. After you have set your preferred printing options, you 
can save these settings as a preset so that you can use them again without going 
through all the steps.

To print the document pages in reverse order:
m In Mac OS X version 10.3, choose Paper Handling from the Copies & Pages pop-up 

menu, and select the checkbox labeled “Reverse page order.”

m In Mac OS X version 10.4, choose Paper Handling from the Copies & Pages pop-up 
menu, and select Reverse.
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To print only odd or even pages:
m Choose Paper Handling from the Copies & Pages pop-up menu, and select “Odd 

numbered pages” or “Even numbered pages.”

To print several pages on a single sheet of paper:
1 Choose Layout from the pop-up menu below the Presets pop-up menu.

2 Choose the number of pages you want to appear on each sheet from the “Pages per 
Sheet” pop-up menu.

3 Select a layout direction.

4 Choose the line style you want to separate each printed page from the Border pop-up 
menu.

Choose a line style to 
separate the printed 
pages on each sheet.

Print left to right first, 
then down.

Print pages right to 
left first, then down.
Print pages top to 
bottom first, then 
across to the right.

Print pages top to 
bottom first, then 
across to the left.

See a preview of the 
layout you have set up.

Select double-sided
printing options.
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To print double-sided:
m Choose Layout from the pop-up menu below the Presets pop-up menu, and then 

select one of the following:

Â Long-Edge Binding:  Prints the pages to be bound lengthwise.

Â Short-Edge Binding:  Prints the pages to be bound on the short side of the paper.

Note:  Not all printers can print double-sided. Check the documentation that came 
with your printer.

To save your printing options as a preset:
m Choose Save As from the Presets pop-up menu in the Print dialog and type a name for 

the preset.

To use the same settings in the future, choose the preset’s name from the Presets 
pop-up menu.

Adjusting the Document Color With ColorSync
You can make printed documents lighter, darker, or sepia-toned, or add other effects, 
by adding a Quartz filter to your printer output. The filter uses ColorSync technology 
to modify the printed document without modifying the document itself. You can also 
use ColorSync to change the resolution of your document.

Note:  Not all printers can print in color. Check the documentation that came with 
your printer.

To adjust document color:
1 Choose File > Print.

2 Choose ColorSync from the pop-up menu below the Presets pop-up menu in the Print 
dialog.

3 Choose an option from the Color Conversion pop-up menu:

Â Standard:  Uses the default settings in Pages to control the color management of 
the printed document.

Â In Printer:  Lets the printer you’re using control the color management of the 
printed document.

4 Choose an option from the Quartz Filter pop-up menu.

To see a preview of the printed document with the Quartz filter you have chosen, click 
Preview.
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After you have selected the Quartz filter you want, you can save this setting as part of 
your preset, as described above. For more information about ColorSync and Quartz 
filters, see ColorSync Utility Help by opening the ColorSync application (located in 
Applications/Utilities), and then choosing Help > ColorSync Utility Help.

Exporting to Other Document Formats
You can share your Pages documents across different platforms by exporting them to 
other formats, such as Microsoft Word, PDF, or HTML. You can also save a document so 
it can be opened using Pages in iWork ‘05.

To export a document to another file format:
1 Choose File > Export.

2 Choose a format for the document and click Next.

3 Type a new name for the document.

4 Choose where you want to save the document.

5 Click Export.

You can export a Pages document in these formats:

Â PDF:  PDF files can be created using an image quality of good, better, or best. They 
can be viewed or printed in Preview, viewed or printed in Safari on Mac OS X version 
10.4, and edited with a PDF application.

When you export a Pages document on a computer with Mac OS X version 10.4, 
hyperlinks are exported. Hyperlinks are created in the PDF document for table of 
contents entries, footnotes and endnotes, webpages, email messages, and 
bookmarks.

The PDF file is a “Digital Master” PDF file, which is larger than a typical PDF file 
because the resolution of images isn’t scaled down. The PDF file preserves font 
characters used in the document.

Â Word:  Word files can be opened and edited in Microsoft Word on a Mac OS X 
computer or on a Windows computer.

The ColorSync Utility icon



232 Chapter 11    Printing and Exporting Your Document to Other Formats

 

Because of text layout differences between Microsoft Word and Pages, an exported 
Word document may contain a different number of pages than its Pages 
counterpart. Also, special typographic features and some graphics may not display 
as well, particularly those using transparency (alpha channels). Tables and column 
layouts may not export identically, and charts created in Pages appear as static 
images.

Â HTML:  HTML files support sound and movie files and can be viewed in Safari or 
other applications that render HTML.

Some formatting is not preserved. For example, text wrap, headers and footers, 
footnotes, tab stops, and text transparency aren’t exported. Export to PDF if you 
want to preserve all your formatting.

Pages saves the graphics that appear in the document as separate files in a new 
folder. The graphics files folder is labeled with the HTML document’s name followed 
by “_files” and is saved in the same folder as the HTML document. If you move the 
document, move the graphics files with it.

Â RTF:  RTF files retain most of the text formatting and graphics. You can open and 
edit RTF files in a word processor.

Â Plain text:  Plain text files can be opened and edited in a text editing application, 
such as TextEdit. However, exporting to a plain text file removes all your formatting, 
and images aren’t exported.

To save a document as an iWork ‘05 document:
1 Choose File > Save As or File > Save.

2 Select “Save a copy in iWork ‘05 format.”

3 Type a new name for the document.

4 Choose where you want to save the document.

5 Click Save.

Users of Pages in iWork ‘05 can open and use the document, but won’t have access to 
the new, iWork ‘06 features. For example:

Â Address Book fields and comments are removed.

Â Endnotes are converted to footnotes.

Â An image masked with a shape gets a rectangular mask.
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Â A curved or polygonal shape isn’t editable.

Â A custom shape is converted to a predrawn shape.

Â Formulas in table cells are removed, and the last calculated value is displayed.

Â Number formatting isn’t supported, so the last calculated value is displayed with the 
formatting directly applied.

Â 3D charts are converted to 2D charts.
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12 Designing Your Own 
Document Templates

This chapter is for designers who want to create 
their own document templates.
This chapter assumes you are already familiar with the design and formatting features 
of Pages described in earlier chapters.

The templates that come with Pages provide ideas for page designs, and also define 
the look of charts, tables, and text. Within each template, the following attributes can 
be defined:
Â Page orientation

Â Page margins

Â Page numbering

Â Background graphics (watermarks)

Â A variety of text styles, including body text, headers, footers, callouts, and so on

Â Table of contents styles

Â Bullet and numbering styles

Â Object fills and line styles for drawn objects

Â Chart colors and styles

Â Look of tables

Â Additional template page designs

You can modify any of these attributes to create your own templates. Creating your 
own template can also be as simple as selecting an existing template and adding your 
company logo to the page.

If you want to customize an existing template—for example, by adding images, 
changing the placeholder text, or defining new text styles—see the relevant sections 
in this chapter, and then read “Step 4:  Saving a Custom Template” on page 243.
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If you want to design a new template from scratch, begin with a Blank template. It 
may be useful to proceed through all of the sections in this chapter in order.

Step 1:  Setting Up the Document
Before you get into the deeper levels of designing the document, you should make 
sure to specify the general “size and shape” of the document. Doing this first will 
ensure consistency throughout the document. To set up your document, take care of 
these tasks first:

1 Set paper size and orientation.

Consider the paper size and orientation that will be used for the finished document. 
For example, if you are creating a template for envelopes, make sure that you have 
selected the correct envelope size (or created a custom size) before you proceed with 
further document design. To learn about setting the paper size and orientation, see 
“Setting the Paper Size and Orientation” on page 224.

2 Set page margins.

Define the body text area and header and footer text areas. If your document will be 
bound, you can set different margins for right- and left-facing pages. Document 
margins are set in the Document Inspector. For more information, see “Setting Page 
Margins” on page 61 and “Creating a Document With Left- and Right-Facing Pages” on 
page 66.

3 Insert page numbering.

If your document requires page numbering or footnotes, set these up using the 
Document Inspector. For more information, see “Adding Footnotes and Endnotes” on 
page 68.

Placing Master Objects
If you want to add images that appear in the background on every page of your 
document (for example, watermarks), place them first. If you create new sections in 
your document, they will automatically inherit the master objects that you have 
already placed. You can remove or reposition the master objects in subsequent 
sections, if you want.
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To place a master object:
1 Place a fixed graphic anywhere on the page. (Inline objects cannot be used as master 

objects.)

2 Set the object size.

3 Set object opacity. For more information, see “Adjusting Opacity” on page 154.

4 Mask any part of the image you don’t want to appear. For more information, see 
“Cropping (Masking) Images” on page 128.

5 Set the text wrapping the way you want it. For more information, see “Wrapping Text 
Around an Object” on page 136.

6 If you want the object to appear behind text, select it and choose Arrange > Send to 
Back.

7 Choose Format > Advanced > Move Object to Section Master.

After the object has been placed on the section master, it cannot be selected, so you 
can’t accidentally move it. If you want to move it or make changes to it, you can make 
it selectable.

To edit a master object:
m Choose Format > Advanced > Make Master Objects Selectable, and then select the 

object you want and edit it.

Master objects have blue selection handles.

To remove a master object and make it appear only on a single page:
m Choose Format > Advanced > Move Object to Page. The object is no longer repeated 

on each page, but appears only on the selected page. It can be manipulated like any 
other fixed object.

Adding Alignment Guides
Alignment guides created in a template page remain in the template to help whoever 
uses the template position items on the page. The alignment guides appear when the 
rulers or layout are shown, and disappear when rulers or layout are hidden.

Master objects have blue 
selection handles.
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To create alignment guides on a page:
1 Go to the page to which you want to add the alignment guides.

2 Click outside the main body of your document so that the insertion point is not 
visible.

3 Click View in the toolbar and choose Show Rulers (or choose View > Show Rulers).

4 Place the pointer on a ruler and drag the blue alignment guide wherever you want on 
the page. (You can change the color of the alignment guides using Pages 
preferences.)

Step 2:  Defining Styles
A template must have default styles defined for the following elements of a 
document:
Â Paragraph styles

Â Character styles

Â List styles

Â Table of contents styles

Â Text box styles

Â Shape styles

Â Table styles

Â Chart styles

Â Text wrap around objects

You can customize any of these for the template you are creating, or you can use the 
defaults that already exist in the template you started with (including the Blank 
template).

To learn about creating paragraph styles, character styles, and list styles, see 
Chapter 5, “Working With Styles.” To learn about creating styles for the table of 
contents, see “Styling a Table of Contents” on page 77.
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Setting Default Styles for Shapes, Tables, and Charts
The default styles for text boxes, shapes, tables, and charts determine what each of 
these objects looks like when it first appears on the page (for example, the color, size, 
and orientation of the shape that appears when you choose Insert > Shape > [shape]).

You can set default attributes for text boxes, shapes, tables, and graphics by placing 
one of each of these items on a page, formatting it the way you want, and then using 
the Format menu commands to define these new attributes as the defaults.

Defining Attributes for Text Boxes and Shapes
Setting the default attributes for text boxes and for shapes is very similar. Design text 
boxes and shapes just the way you want them, with your preferred fonts, colors, 
opacity, shadows, and so on. (Because line length and orientation cannot be defined 
within a template, line attributes—such as color, thickness, and opacity—must be set 
separately.)

To set default styles for text boxes and shapes:
1 Place a fixed text box and a shape on the page. To read about placing a fixed text box, 

see “Creating Callouts, Sidebars, and Highlighted Text” on page 99. To read about 
placing drawn objects, see “Adding Shapes, Tables, and Charts” on page 125.

2 Type text into the box and shape and then select the text and set its attributes. To 
read about setting text attributes, see “Formatting Text Size and Appearance” on 
page 79.

3 Select the text box and the shape, and set attributes for both (for example, fill color 
and outline style). To read about setting object properties, see Chapter 7, “Changing 
Object Properties.”

4 For the text box and the shape, set text wrapping in the Wrap Inspector. To read about 
setting text wrapping, see “Wrapping Text Around an Object” on page 136.

5 Select the shape or text box and choose Format > Advanced > Define Default Shape 
Style or Define Default Text Box Style.

6 Delete the text box and shape from the page.
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Defining Attributes for Tables
You can design the default table the way you like it, setting the number of rows and 
columns, line styles and colors, text styles, shadows, and so on.

To set default table attributes:
1 Place a table on the page.

2 Select the table and set its attributes. To read about placing and formatting tables, see 
Chapter 8, “Creating Tables.”

3 Set text wrapping around the table.

4 Choose Format > Advanced > Define Default Table Style.

5 Delete the table from the page.

Note:  A table consists of distinct formatting areas, including the header row, header 
column, inside borders, and outside borders. To set default table attributes, you must 
apply each attribute to an entire formatting area. For example, if you change the 
formatting of one cell in a header row, the change will not be saved as part of the 
default table style; you need to change the formatting of all the cells in the header 
row.

Setting Default Chart Styles
For charts, you can set the default chart type—the type of chart that appears when 
you choose Insert > Chart—and also the default look of each chart type. Default 
attributes must be set individually for each chart type.

To set default chart styles and placement:
1 Place a chart on the page.

2 Select the chart and set its attributes. (To read about placing and formatting charts, 
see Chapter 9, “Creating Charts.”)

3 Set the text wrapping around the charts.

4 After you have formatted and positioned all the charts, select each of them, one at a 
time, and choose Format > Advanced > Define Default Style for [chart type] Chart.

5 Select the chart type that you want to be the default (the one that first appears when 
you choose Insert > Chart), and choose Format > Advanced > Make [chart type] the 
Default Chart Type.

6 Delete the charts from the page.
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Defining Default Attributes for Imported Graphics
For imported graphics, you can set default shadows, opacity, and outline (stroke) 
color.

To set default image attributes:
1 Place an image on the page.

2 Select the image and set its attributes. (To read about setting object attributes, see 
“Changing Line Style” on page 152, “Adding Shadows” on page 153, and “Adjusting 
Opacity” on page 154.)

3 Set text wrapping around the image.

4 Choose Format > Advanced > Define Default Image Style.

5 Delete the image from the page.

Step 3:  Creating Placeholder Text and Graphics
Placeholder text and graphics model the look of the finished document. They can also 
provide instructions for the person using the template.

Creating Placeholder Text
If you want to modify placeholder text that already exists in a template, you must 
make it editable.

To edit placeholder text:
1 Choose Format > Advanced > Enable Placeholder Text Authoring.

2 Edit the text as you would normally.

3 Choose Format > Advanced > Disable Placeholder Text Authoring.

You can also set your own text as placeholder text.

To create placeholder text:
1 Type some text on the page and format it the way you want.

2 Select the text in blocks, as you would like template users to be able to edit it, and 
choose Format > Advanced > Define as Placeholder Text.
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Important:  When selecting blocks of text to define as placeholder text, be careful not 
to select the final paragraph break character. Doing so will cause the entire paragraph 
to be deleted when the user begins typing in the placeholder text, and the new text 
will take on the attributes of the following paragraph. To see the paragraph break 
character as you work, click View in the toolbar and choose Show Invisibles (or choose 
View > Show Invisibles).

To remove placeholder text:
m Select it and press Delete.

Creating Placeholder Graphics
Placeholder graphics make it easy for you to size and position graphics correctly by 
simply dragging them onto the placeholders you have created.

To create a placeholder graphic:
1 Place and size a placeholder image on the page (it might be a shaded box with 

instructional text, for example).

2 Select the image and choose Format > Advanced > Define as Image Placeholder.

To make a placeholder image an ordinary image:
m Select it and then deselect “Define as Image Placeholder” in the choose Format > 

Advanced submenu. (A selected item has a checkmark next to it; choose the item 
again to deselect it.)

To delete a placeholder graphic:
m Select the image and press Delete.

Providing Page Designs for Expandable Templates
You may want to make your template expandable so that template users can simply 
insert additional page designs you have created. The page designs are available using 
the Pages command in the Insert menu (for more information, see “Expanding Your 
Document” on page 37).

1 Design a layout of one or more pages, inserting a section break at the beginning and 
end of the layout.
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2 Choose Format > Advanced > Capture Pages. A dialog opens.

3 Type a name for the page design.

4 Choose the number of pages you want to include in the page design from the Include 
pop-up menu.

5 Delete the pages from your template if you want them to appear only in the Pages 
submenu, but not as a regular part of the template.

To manage page layouts you have created:
1 Choose Format > Advanced > Manage Pages. A dialog opens.

2 Select a page title and click the up or down arrow buttons to change its position in 
the list.

Click the Delete (–) button to remove it from the list.

3 Click Done.
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Step 4:  Saving a Custom Template
You can save your new template so that it appears in the Template Chooser. When 
another person opens the template to use it, it opens in exactly the same state as you 
saved it. That means you can choose to leave the Styles drawer open or closed, or 
leave invisibles, rulers, and layout marks visible.

To save the current template as a custom template:
1 Choose File > Save as Template.

2 Type a name for the template.

3 Your template will be saved in the My Templates pane of the Template Chooser. If you 
don't want your template to appear here, save it in another location.

You can create a new Template category by creating a new folder in the following 
location:

[Home Folder]/Library/Application Support/iWork/Pages/Templates

4 Click Save.

To delete a custom template:
m In the Finder, navigate to the folder in which you saved the template, and drag the 

template to the Trash. By default, the folder is:

[Home Folder]/Library/Application Support/iWork/Pages/Templates/My Templates
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layout  23
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