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New Features and
Introduction

Welcome to AutoCAD Architecture 2012! Built on the new AutoCAD® 2012 platform, this
release is targeted in improving AutoCAD Architecture’s performance in terms of speed and
introducing a new feature: corner window. Column Grid and IFC features have also been
enhanced with new and improved workflow.

New Features in AutoCAD Architecture 2012
The following sections list the new and improved features in AutoCAD
Architecture 2012.

■ Overview of Corner Window on page 1958

■ General Information for Exporting Drawing Files to IFC on page 214

■ Grids on page 2749

A Quick Start for Transitioning from AutoCAD to
AutoCAD Architecture

If you have previously accomplished your architectural tasks with AutoCAD
and want to transition to AutoCAD Architecture, you will find that using tools
specifically designed for architects provides additional productivity and benefits
over the AutoCAD drafting methods you used before.

The help system is designed to simplify the transition from AutoCAD to
AutoCAD Architecture. These help components will assist new users with

1
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previous AutoCAD experience to easily segue into working with AutoCAD
Architecture:

■ User Interface Overview An interactive method for exploring the AutoCAD
Architecture user interface.
Available from the Help drop-down menu.

■ Where is My Command? A tool that lists commands by their previous
menu location in AutoCAD Architecture and displays their current location
on the ribbon.
Available from the Help drop-down menu.

■ User Interface Tour A short, introductory video about the AutoCAD
Architecture user interface.
Available from http://www.autodesk.com/autocadarchitecture-uivideo.

The Autodesk Exchange(online) for AutoCAD Architecture provides centralized
access to some of these components and displays when you open the
application.

This overview of tasks and how to accomplish them in AutoCAD Architecture
can help you get an easy start. For additional information about the task, open
the Help topic or watch one of the Getting Started Videos in Autodesk
Exchange(online) for AutoCAD Architecture.

NOTE The software locations for tools, palettes, and catalogs listed below are the
default locations for a standard US install. Customized installations, as well as
localized versions may vary in the tools they supply and the structure of the tool
palettes.

2 | Chapter 1   New Features and Introduction
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More Informa-
tion

Ribbon Locationwith AutoCAD
Architecture
tools

with AutoCAD
tools

How do I…

Work with
Conceptual
Massing?

Home tab  ➤ Build

panel  ➤  Box drop-
down

Mass Elements
and Mass
Groups

SolidsDesign Massing
Studies?

■ Online Help:
Mass Elements
and Mass
Groups on
page 1003

Create a Space
Layout and
Colored Plans?

Home tab  ➤  Build

panel  ➤  Space drop-
down

SpacesPolyline and
Hatch

Create Space
Plans?

■ Online Help:
Space Types on
page 2917
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More Informa-
tion

Ribbon Locationwith AutoCAD
Architecture
tools

with AutoCAD
tools

How do I…

View tab  ➤ Appear-

ance panel  ➤  ➤ 

Themes drop-down

Display Themes
and Spaces

Hatching and
Polylines

Create Color Fill
Plans?

■ Online Help:
Process Over-
view: Creating
Display
Themes on
page 3885

Create Floor
Plans?

Home tab  ➤ Build

panel  ➤ Wall drop-

down  ➤ Wall

WallsLinework or
Multilines

Draw Walls? ■ Online Help:
Walls on page
1159

Home tab  ➤ Build

panel  ➤ Door drop-

down  ➤ Door

DoorsBlocks or Dynam-
ic Blocks

Draw Doors? ■ Online Help:
Doors on page
1871

Home tab  ➤ Build

panel  ➤ Window

drop-down 

WindowsBlocks or Dynam-
ic Blocks

Draw Windows? ■ Online Help:
Windows on
page 1955

Home tab  ➤ Build

panel  ➤ Stair drop-

down  ➤ Stair

StairsLineworkDraw Stairs? ■ Online Help:
Stairs on page
2101

Home tab  ➤ Build

panel  ➤ Stair drop-

down  ➤ Railing

RailingsLineworkDraw Railings? ■ Online Help:
Railings on
page 2305
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More Informa-
tion

Ribbon Locationwith AutoCAD
Architecture
tools

with AutoCAD
tools

How do I…

Home tab  ➤ Build

panel  ➤ Wall drop-

Curtain WallsLineworkDraw Curtain
Walls?

■ Online Help:
Curtain Walls
on page 1415down  ➤ Curtain Wall

Add Furniture
and Fixtures?

Insert tab  ➤ Block

panel  ➤ Multi-View

Block

Multi-View
Blocks

Blocks or Dynam-
ic Blocks

Place Furniture,
Fixtures, and
Equipment?

■ Online Help:
Multi-View
Blocks on page
2891

Create Annota-
tion and
Scheduling?

Annotate tab  ➤ Di-

mensions panel  ➤ 

AEC DimensionsDimensionsDimension
Drawings?

■ Online Help:
AEC Dimen-
sions on page
3387

AEC Dimension drop-
down
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More Informa-
tion

Ribbon Locationwith AutoCAD
Architecture
tools

with AutoCAD
tools

How do I…

Annotate tab  ➤ 

Scheduling panel

Tag ToolsBlocksAdd Schedule
Tags?

■ Online Help:
Adding Tags
Using Schedule
Tag Tools on
page 3756

Annotate tab  ➤ 

Scheduling panel

SchedulesTablesExtract Sched-
ules from
Designs?

■ Online Help:
Managing
Schedule
Tables on page
3766

Schedule Table tab  ➤ 

General panel  ➤ Edit

Property Set
Definitions

AttributesModify Block
Properties for
Scheduling
Data?

■ Online Help:
Property Set
Definitions on
page 3823

Style drop-down  ➤ 

Property Set Defini-

tions

Annotate tab  ➤  Cal-

louts panel  ➤  ➤ 

Callouts and Pro-
ject Navigator

XclipCreate Enlarged
Plans?

■ Online Help:
Working with
Callouts on
page 3687Detail Boundary drop-

down
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More Informa-
tion

Ribbon Locationwith AutoCAD
Architecture
tools

with AutoCAD
tools

How do I…

Annotate tab  ➤  Cal-

louts panel  ➤  Section
drop-down

SectionsLineworkExtract Building
Sections?

■ Online Help:
Placing Section
Callouts on
page 3709

Annotate tab  ➤  Cal-

louts panel  ➤  Eleva-
tion drop-down

ElevationsLineworkExtract Eleva-
tions?

■ Online Help:
Placing Eleva-
tion Callouts
on page 3717

Home tab  ➤ Annota-

tion panel  ➤ Revision

Revision CloudsREVCLOUD
command

Mark up draw-
ing revisions?

■ Online Help:
AEC Content in
the Contentdrop-down  ➤ Revi-

sion Browser on
page 3909

Add Details
and Keynotes?
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More Informa-
tion

Ribbon Locationwith AutoCAD
Architecture
tools

with AutoCAD
tools

How do I…

Home tab  ➤ Details

panel  ➤ Detail Com-

ponents

Detail Compon-
ents

LineworkCreate Details? ■ Online Help:
Detail Compon-
ents on page
3527

Home tab  ➤ Annota-

tion panel  ➤ Keynote
drop-down

KeynotingLeadersAnnotate De-
tails?

■ Online Help:
Keynoting
Tools on page
3608

Work in a Pro-
ject?

Floating View panel

 ➤  Visual Styles

Visual StylesVisual StylesCreate Presenta-
tion Graphics?

■ Online Help:
“Use a Visual
Style to Display
Your Model” in
the AutoCAD
Help

Home tab  ➤ Build

panel  ➤ Tools drop-

Content BrowserWindows® Ex-
plorer and
DesignCenter

Find and Man-
age Content?

■ Online Help:
Content
Browser Over-
view on page
129

down  ➤ Content

Browser
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More Informa-
tion

Ribbon Locationwith AutoCAD
Architecture
tools

with AutoCAD
tools

How do I…

Home tab  ➤ Layers

panel  ➤  Layer Proper-

ties 

Layer Manager,
Layer Key Styles,
Layer Standards

Layer Properties
Manager

Manage Layers? ■ Online Help:
Managing
Drawing Layers
on page 720

■ Online Help:
Working with
Layer Keys on
page 759

■ Online Help:
Creating and
Editing Layer
Standards on
page 774

Quick Access Toolbar

 ➤ 

Project Navigat-
or

Sheet Set Man-
ager

Manage Project
Drawings?

■ Online Help: A
Short Overview
of Drawing
Management

Contacting Autodesk
Autodesk, Inc.

111 McInnis Parkway

San Rafael, CA 94903 USA

Phone: 415-507-5000

Website: http://www.autodesk.com

Sales Information
To purchase additional Autodesk software, contact your local reseller. For the
name of the authorized reseller nearest you, call 1-800-964-6432 or access the
Resellers and Training Centers website, http://www.autodesk.com/resellers/.
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Technical Support
If you have technical questions about the products, you should contact your
local reseller or check the frequently asked questions (Technical Solutions &
FAQS) section and Discussion Groups on the website for AutoCAD Architecture
at http://www.autodesk.com/support. News groups are another good source of
information. You can look through the questions that have already been
posted, or you can post your own questions.

Feedback
Please let us know what you think! Whether you have a suggestion for product
enhancement, a compliment, or a complaint, or if you think you have found
a bug, we would like to know about it.

To make comments and find additional information, visit our website at
http://www.autodesk.com/contact.
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AutoCAD Architecture
Workflow

Workflows in AutoCAD Architecture differ depending on whether you are starting a new
building project or doing additional work on existing drawings. The following topics address
these scenarios separately, mapping typical architectural workflows to instructions for
performing the related tasks in AutoCAD Architecture.

Start a New Project
The following topics map typical architectural workflows to instructions for
using AutoCAD Architecture to carry out an architectural project from start to
finish.

If you are completing drawings that exist outside of an AutoCAD Architecture
structured project, see Work on an Existing Drawing on page 16.

Create a Project

Open the Project Browser on page 322, and create
the project from scratch on page 331, from a-----Set up the project
template on page 328, or from an existing project
on page 330.

Define vertical levels on page 380 and any
horizontal divisions on page 387 for the building
project.

-----
Identify the floor elevations and
any wings of the building

2
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Define the project properties on page 333 and add
detailed information on page 337.

-----Enter the project information

Design Your Building

Create a construct on page 404 in which to add
architectural objects.

-----
Decide on which portion of the
building plan to work

Assign the construct to one of the previously
identified levels on page 380 and divisions on page
387 (if applicable).

-----
Associate the plan to a location
and an elevation

Use wall tools to add the exterior and interior
walls on page 1163, door tools to add the different

-----
Add walls, doors, and windows to
the drawing doors on page 1873, and window tools to add the

different windows on page 1964 required in the
drawing.

Add other architectural objects to the construct,
such as openings on page 2062 and stairs on page
2137 and spaces on page 2987.

-----
Add other design objects to the
drawing
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Annotate Your Design

Create a view on page 453 drawing from the
constructs, and insert information, such as
dimensions on page 3389.

-----Annotate the design

Add tags on page 3754 to objects in the drawings.-----Tag objects

Add schedule tables on page 3747 to the drawings.-----Add schedules

Use callout tools to add a title mark on page 3702
to the sheet.

-----Add a title mark

Publish Your Drawings

Create on page 484 a sheet.
Sheets on page 481 are the final output of a
building design. As you revisit planning stages,-----Make a sheet

any changes you make to constructs, elements,
and views are reflected in sheets.

Add a view on page 465 to the sheet.-----Place the drawing on the sheet
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Create a title block on page 541 for the sheet, and
add fields on page 542 to the title block.

-----Add a title block

Plot or publish drawings on page 276, create an
electronic on page 352 file set to transmit or-----Publish drawings
archive the project, or etransmit on page 508 the
sheets or sheet sets.

Work on an Existing Drawing
This topic follows a typical workflow for completing drawings that were started
independent of an AutoCAD Architecture structured project. An AutoCAD
Architecture structured project automates the processes relating to building
design and documentation.

If you wish to work within an AutoCAD Architecture structured project, see
Start a New Project on page 13.

Add or Modify Architectural Objects

Use wall tools to add the exterior and interior
walls on page 1163, door tools to add the doors on-----

Add walls, doors, and windows to
the drawing page 1873, and window tools to add the windows

on page 1964 required in the drawing.

Add other objects to the construct, such as
openings on page 2062, stairs on page 2137, and
spaces on page 2987.

-----
Add other building objects to the
drawing
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Add an endcap on page 1373 to the drawing.-----
Customize how an opening in the
wall displays in the drawing

Edit the objects, such as walls on page 1190, doors
on page 1883, and windows on page 1974 as needed.

-----Modify the drawing

Edit the wall in place to correctly connect on page
1354 the walls.

-----
Clean up any wall intersections
that do not display correctly

Add or Modify Annotation

Add dimensions on page 3387 to plan drawings, or
edit on page 3422 existing dimensions.

-----
Annotate the drawing with
dimensions

Use callout tools to add a title mark on page 3702
to the drawing.

-----Add callouts

Use tag tools to add tags on page 3754 to objects
in the drawing.

-----Tag objects
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Use schedule tools on page 3747 to create schedule
tables.

-----Add schedules

Publish the Drawings

Create a new drawing file with borders and fields
on page 3489 as needed, save the drawing, and

-----Create a title block for the drawing then drag the drawing onto a tool palette on
page 92. Text inserted in fields updates if it
changes during the life cycle of the drawing.

Select the title block tool to insert on page 545 the
title block you created, or select an architectural
title block template on page 179.

-----Add the title block to the drawing

Plot or publish on page 276 drawings.-----Publish drawings
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The Workspace

The AutoCAD Architecture workspace is a highly customizable graphical user interface designed
to accommodate the various workflows and work styles of architectural professionals. The
topics in this section provide an overview of the available workspace components and describe
how to access and configure them to meet your needs. For detailed instructions on using
workspace components to create and edit architectural objects, refer to the relevant
object-specific topics in Help (Walls, Doors, Windows, and so on).

Changes to the Workspace
The workspace has been redesigned to make it easier and faster for you to find
and use the tools and commands you need for the task at hand. This new user
interface is described in detail in the following sections, but here are the
highlights:

The Ribbon

Similarly to Microsoft Office, AutoCAD Architecture 2012 now uses the ribbon
as the central access point for commands. The ribbon contains a number of
tabs on which commands are grouped according to conceptual task types or
selected objects.

The ribbon replaces the menu bar and the toolbars as the primary command
access point.

3
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The Application Menu

The application menu contains basic commands pertaining to the drawing
as a whole, such as Open, Save, Print, and Export. Like the menu browser it

replaces, the application menu is accessed by clicking  in the upper-left
corner of the workspace.

Workspaces

AutoCAD Architecture is equipped with one single default workspace
(Architecture). The menus and commands associated with the previously
provided workspaces (Design, Document, Detailing, and Visualization) can
now be accessed from the tabs of the ribbon.

NOTE The tool palette groups associated with the previous default workspaces
are still available from the context menu of the tool palettes set.
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Drawing Status Bar Menu

The drawing status bar menu has been removed from AutoCAD Architecture
2012. Commands formerly found there can now be accessed from the
application menu.

Commands on the old menu

Help Access

With the removal of the menu bars, the commands to access Help features
have been moved into the InfoCenter at the top right of the application
window. Here, you can find the online resources of InfoCenter and the Help
menu, which lets you access Help, Tutorials, and other interactive resources.

Toolbars

Toolbars have been removed from AutoCAD Architecture. Commands formerly
found on toolbars can now be accessed from the ribbon.

Autodesk Seek

You can use Autodesk Seek to find product design information. Many content
providers, both corporate partners and individual contributors, publish to
Autodesk Seek. Content includes 3D models, 2D drawings, specifications,
brochures, and other descriptions of products or components.
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Import design content into AutoCAD Architecture

You can also share your own content with others using Autodesk Seek. Upload
drawings or blocks to Autodesk Seek to give your partners and customers ready
access to your content.

For more information, see “Use Autodesk Seek to Add and Share Drawings”
in the AutoCAD Help.

The Workspace Concept
In AutoCAD Architecture, a workspace is the basic user interface that includes
those controls, commands, and palettes you need for your architectural process.
When you first start AutoCAD Architecture, the default Architecture workspace
is displayed.

You can reconfigure the workspace according to your preferences as you work.
You can move or hide various components as needed, display additional
ribbon controls, or add new tools and tool palettes. If desired, you can save
your customizations as a new workspace that you can access for later drawing
sessions. You can also switch from one workspace to another at any time. For
more information, see “Create Task-Based Workspaces” in the AutoCAD Help.
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Default configuration of the Architecture workspace

Workspace Components
The workspace consists of a drawing window with ribbon, tool palettes, and
other controls that you use to set up an architectural project, create your
design, and generate construction documents.

In the following sections, each component of the workspace is described in
detail. Components can be turned off and on for different workspaces,
depending on your requirements.

For an interactive guide to the user interface, click the Help button in the
InfoCenter on the top right of the application window, and click User Interface
Overview.
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The Ribbon
The ribbon is the central location for accessing commands in AutoCAD
Architecture. The ribbon is organized into tabs that reflect common tasks in
the drawing process. There are 2 types of tabs:

■ Static tabs are available regardless of which objects are selected in the
drawing area. The commands on these tabs were previously located on the
menus and toolbars.

Static Home tab

■ Contextual tabs display depending on the object selected in the drawing
area. When you select a door, a contextual tab for doors is displayed. The
commands on the contextual tabs reflect the commands on the context
menu of an object.

Contextual tab for door objects
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Displaying the Ribbon
To display the ribbon if it is not displayed in your workspace, or has been
closed, enter ribbon on the command line.

You can use the  button at the right of the tab names to modify the
appearance of the ribbon as follows:

■ To display only the panel titles of the ribbon tabs, click  (Minimize to
Panel Titles) at the top right of the ribbon.

■ To display only the tab names as titles, click  again (Minimize to Tabs).

■ To redisplay the full ribbon, click  a third time (Show Full Ribbon).

Using the Ribbon

To start a command from the ribbon

1 If the ribbon is not displayed by default, enter ribbon on the command
line.

2 Click the desired tab.

3 Move the cursor over the commands on the tab as needed to view tooltips
describing the commands.

4 Click a command.
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Some ribbon commands are grouped under a drop-down menu. You can
access them by clicking the arrow next to the command.

Some panels have an expansion arrow  to indicate that the panel can
be expanded. The expanded part typically contains commands that are
less frequently used.
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5 The expanded panel is displayed when you click the arrow  . To pin

the expanded part of the panel onscreen, click  .

To tear off a panel from a static ribbon tab

6 If you want a panel from a static tab to remain in your workspace when
you switch to another tab, you can tear the panel off its tab and use it as
a floating palette. To do so, move the cursor over the title bar of the panel,
and then drag the panel off the ribbon and into the drawing area.

To return a floating panel to the ribbon

7 Move the cursor over the floating panel, and click Return Panels to
Ribbon.

To hide and display tabs and panels

8 To hide tabs and panels or display a particular tab or panel, right-click
anywhere on the ribbon and click Tabs or Panels (Show Tabs or Show
Panels if you right-click on an empty area of the ribbon), and click the
tab or panel name to deselect or select it.

A check mark displays beside the tab or panel name if it is selected.
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Locating Commands in the Workspace
The ribbon is intuitive and task-related, and the transition from menus and
toolbars to the new user interface will in most cases be quick and easy.
However, it is a new design, and the following tips might help you make a
more seamless transition.

Where is My Command? Tool

The Where is My Command? tool is a help file that lists commands by their
previous menu location and displays their current location on the ribbon.
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You can access the Where is My Command? tool from the Help menu ➤ Where
is My Command, or from the landing page of the online Help.

Searching the Home Tab

The Home tab contains the most frequently used commands within the
software. Basic object and drawing tools can be found here, as well as frequently
used utilities like modification tools, layers and basic annotation. Use the
Home tab as your starting point in a new drawing.

Finding Commands with the Application Menu

The application menu has a Search mode, where you can enter a command
name or part of it, and see a list of locations in the user interface where the
command can be accessed. For more information, see Using the Application
Menu to Locate Commands on page 37.
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Searching by Context

Commands that refer to a selected object can be found on the contextual tab
of that object.

Door contextual tab

The command layout of the contextual tab of an object is in most cases based
on the structure of commands on the context menu of the object.

Door context menu

For example, on the context menu of a door you can find the Add Selected
command. On the contextual Door tab, you can find the Add Selected
command on the General panel.

Finding More Information about the Ribbon

Use the following resources to find out more about the ribbon.

Click Help menu  ➤ Learning Resources, and choose from these items:

■ User Interface Overview (interactive)
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■ Tutorials

To access the Where is My Command? tool, click Help menu  ➤ Where is My
Command?

The Static Ribbon Tabs
The workspace comprises a set of static tabs that are optimized for architectural
tasks. The default Architecture workspace for the US version of AutoCAD
Architecture 2012 includes the following static tabs on the ribbon:

The Home Tab
The Home tab contains the most frequently used commands within the
software. Basic object and drawing tools can be found here, as well as frequently
used utilities like modification tools, layers, and basic annotation.

■ Build. Contains the basic commands for adding the most commonly used
objects, like walls, doors, and mass elements, as well as commands for
opening the Tool palettes on page 70, The Properties Palette on page 107,
and the Content Browser on page 129.

■ Draw. Contains common linework tools, like lines, polylines, and
rectangles, as well as hatch and boundary tools and AEC Polygons on page
1827.

■ Modify. Contains commands for manipulating objects and linework in a
drawing. In addition to standard commands like Move, Rotate, Erase,
Offset, Mirror, Scale, Array, Explode, Join, there is also a command for
converting AEC objects to mass elements on page 1040 and converting mass
elements to 3D Solids on page 1039.

■ Layers. Contains commands that you need to work with layers. You can
open the Layer Manager on page 720 and the Layer States Manager on page
749 from here.

■ Annotation. Contains basic commands for inserting text, leaders, and
dimensions. For a larger selection of annotation commands, see the
Annotate tab on page 33.
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■ Inquiry. Contains commands for measuring distance and areas, and the
AutoCAD list command. Furthermore, you can find commands for
evaluating architectural spaces on page 3177.

■ Section and Elevation. Contains commands for generating sections on
page 3251 and elevations on page 3321 of your plan or model. To create sections
and elevations with Callouts on page 3687, see the Callouts panel on the
Annotate tab on page 33.

■ Details. Accesses Detail Component Manager on page 3549 from which you
can insert detail components directly into drawings or onto tool palettes.

Floating View Panel
The floating View panel offers access to the commands for views, visual styles,
and the Zoom and Pan tools. This panel is not docked to the ribbon by default,
and you can access it independently of the current ribbon tab. You can dock
the floating View panel to the Home tab, if desired.

The Insert Tab
The Insert tab lets you work with references, multi-view blocks, blocks,
attributes, and content from external sources like Content Browser and
Autodesk Seek.

■ Reference. Contains commands for working with external references (xrefs),
DWF/DWFx files, DGN underlays, and raster images.

■ Block. Contains commands for inserting and editing blocks and multi-view
blocks on page 2905.

■ Attributes. Contains commands for creating and editing attributes.

■ Import. Contains commands for importing WMF, ACIS, 3D Studio Max,
DGN, and LandXML files.
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■ Content. Contains commands for inserting content from Content Browser
on page 129, from DesignCenter, or from Autodesk Inventor into your
drawing.

■ Seek. Lets you search online for prefabricated design content. For more
information about Seek, see “Use Autodesk Seek to Share Drawings” in the
AutoCAD Help.

The Annotate Tab
The Annotate tab contains commands that help you to mark up your drawing
files.

■ Tools. Accesses the Document tool palettes set.

■ Text. Contains all commands for text and text styles and accesses the Fields
editor.

■ Dimensions. Contains commands for inserting and editing both AEC on
page 3387 and AutoCAD dimensions.

■ Scheduling. Contains commands for inserting schedule tables on page 3747
for basic objects, creating and inserting schedule tags on page 3754, and
running a space evaluation on page 3177. Additionally, you can create
schedule table styles on page 3769, and renumber property set data on page
3765.

■ Callouts. Contains commands for placing title marks on page 3702, sections
on page 3709, elevations on page 3717, and detail views on page 3703.

■ Keynoting. Contains commands for adding sheet and reference keynotes
on page 3608, keynote legends on page 3617, opening the keynote editor on
page 3631, and selecting a keynote database on page 3634.

■ Markup. Accesses commands for marking up a drawing for review. You
can add revision clouds on page 3660, mask blocks on page 2867, wipeouts,
open the Markup Set Manager, and load a markup DWF.

■ Annotation Scaling. Commands here let you add the current scale to
objects, display and edit the scale list, and add and delete scales for
annotative objects.
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The Render Tab
The Render tab contains all commands you need to work with rendering,
materials, lights, cameras, and animations.

■ Render. Contains commands for rendering a model or a region of it,
defining render settings, generating a render output file, and opening the
Advanced Render settings palette.

■ Materials. Here, you can open the Materials palette, activate and deactivate
materials and textures, and set the material mapping.

■ Sun and Location. Here you can set parameters for natural sunlight.

■ Lights. Contains commands for setting spotlights and shadows, selecting
international lighting units, and enabling photometric lighting.

■ Camera. Contains commands for creating and adjusting camera views.

■ Animations. Contains commands for creating a WMV animation, as well
as a model walk-through and fly-through.

The View Tab
The View tab is the central location for defining and changing views and
navigating the drawing.

NOTE The View tab contains a number of commands also found on the application
status bar.

■ Navigate. Contains the ViewCube on page 67 and SteeringWheels on page
68, as well as the Pan, Zoom, and Orbit commands.

■ Appearance. Here, you can select predefined views, create new views, open
View Manager, select a visual style, open the Visual Styles Manager, and
define Walk and Fly settings. You can access predefined display themes
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on page 3885. You can also adjust clip planes and access the Regenerate
commands.

■ Coordinates. Contains commands relevant to the World Coordinate System
(WCS) or User Coordinate System (UCS).

■ Viewports. Here you can switch between different viewport configurations,
create new viewports, and clip and join viewports.

■ Face Effects. Contains commands for defining object settings, including
shading, color, face lighting, and x-ray.

■ Edge Effects. Contains command for defining edge settings, including
facet edges, isolines, edge overhang, jitter, and silhouette. You can also
define the color of obscured edges and edge intersections here.

■ Windows. Contains most of the commands that were on the Window
menu in previous versions. Here you can switch between open drawings,
arrange open windows onscreen, lock the workspace windows, display and
hide the drawing window status bar on page 44, turn items on the drawing
window status bar on an off, and display the text window.

The Manage Tab
On the Manage tab, you can find features for advanced users and CAD
managers.

■ Action Recorder. Contains commands for recording and playing action
macros.

■ CAD Standards. Contains commands for configuring AutoCAD standards,
check your drawing for standards violations, and start Layer Translator.

■ Project Standards. Contains commands associated with project standards
on page 599 for an AEC project. You can configure project standards,
synchronize the project with its standards, synchronize standards with
each other, and audit projects and drawings.

■ Style and Display. Accesses the Style Manager on page 870, the Display
Manager on page 791, the AEC Dimension Style Wizard on page 3454, the

The Ribbon | 35



structural member catalog on page 2531, and the structural member wizard
on page 2536. You can also define and insert profiles on page 2853.

■ Applications. Contains commands for loading extra applications, like ARX,
LSP, or VB applications, and running user-defined scripts and VBA macros.
Also accesses the VBA Manager and the Visual Basic and Visual Lisp editors
here.

■ Customization. Accesses the User Interface Editor (CUI) and the Tool
palettes on page 70.

The Application Menu
The application menu contains commands that are relevant for the drawing
as a whole.

The application menu contains commands for the following file operations:

■ Create new drawings and projects

■ Open drawing files, project files, DGN files, and IFC files
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■ Save drawings to the current file format, to AutoCAD 2007 file format, as
DWT file, or as DWS file

■ Export files to DGN, DWF, PDF, IFC, gBXML, and DuctXML formats, and
previous versions of AutoCAD

■ Plot drawings

■ Publish drawings to Map Guide, DWF, PDF, Seek, and eTransmit

■ Access drawing setup and drawing utilities

■ Access the program options

■ Close drawings and projects

■ Exit AutoCAD Architecture

Accessing the Application Menu

To access the application menu, click  at the upper-left corner of the
workspace.

The application menu remains open as long as the cursor is located inside the
application menu window. To close the application menu, either activate a
menu command, or click outside of the application menu window.

Using the Application Menu to Locate Commands
In the application menu, you can search for a command and then select it
from the list of matches. Search results are retrieved from the following
locations:

■ Application menu

■ Static ribbon tabs

■ Any contextual tab currently on display

■ Quick Access toolbar
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You can enter the following strings to search for:

■ Display name of the command in application menu, ribbon or Quick
Access toolbar. For example, you can enter “Style Manager” or “Plot
Preview.”

■ Part of the display name: If you are not sure what the exact name is you
can enter a part of the name, for example “Style” or “Save.” This will
retrieve all commands that contain that string.

■ Actual command name: You can enter the name of a command as it would
be typed on the command line, for example “aecstylemanager” or “dist.”
This will retrieve all locations where this command can be found.

IMPORTANT When searching for AutoCAD Architecture commands, you must
add the Aec prefix (for example, aecwalladd instead of walladd) to the
command.

In addition to instances of the search string, the results include the contents
of the associated tooltip and any search tags you have defined in the Customize
User Interface editor (CUI). For information about search tags, see “Assign
Search Tags” in the AutoCAD Help.

1 At the upper-left corner of the workspace, click  to open
the application menu.

2 In the text entry box at the top of the menu, enter the desired
search term.

A list of matches replaces the regular application menu display.
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3 To select one of the found commands, click it.

4 To return to the regular application menu display, click  at the
right side of the text entry box.

Displaying Recently Opened Documents in the Application Menu
The application menu lets you display a list of recently opened documents
according to preferences you specify.

1 Click  to open the application menu.

2 At the top of the menu, click Recent Documents  .

3 At the top of the menu, under Recent Documents, specify how
you want documents grouped:

■ By access date
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■ By Size

■ By Type (DWG, APJ, and DGN)

■ By Ordered List (alphabetical order)

4 At the top right of the list of documents, click  to specify
whether to display file type icons or preview images next to the
document names.

5 If you want to keep a document in the list, regardless of its

last-saved date, click its pushpin to change the image from 

to  . The document will remain in the list until you unpin it.

Displaying Currently Open Documents in the Application Menu
The application menu lets you display currently open documents.

1 Click  to open the application menu.

2 At the top of the menu, click Open documents  .

3 At the top right of the list of documents, click  to specify
whether to display file type icons or preview images next to the
document names.

Changing the Number of Recent Files and Actions in the
Application Menu

Use this procedure to change the default number (9) of recent documents
displayed in the application menu:
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1 Click  to open the application menu.

2 At the bottom of the application menu, click Options.

3 On the Open and Save tab of the Options dialog, under
Application Menu, change the value for Number of recently-used
files.

4 Click OK.

The Quick Access Toolbar
The Quick Access toolbar is a customizable toolbar located at the top of the
application window, just to the right of the application menu button.

By default, this toolbar contains a set of frequently used commands for the
application. You can add and remove commands as needed.

To add a command from the ribbon

1 On the ribbon, locate the command you want to add.

2 Right-click the command, and click Add to Quick Access Toolbar.

NOTE Not all commands can be added to the Quick Access Toolbar.
If a command is ineligible, the Add to Quick Access Toolbar command
is not visible in the context menu.

To add other commands to the Quick Access Toolbar

3 On the Quick Access Toolbar, click the down arrow at the right
end of the toolbar, and select More Commands.

4 In the Customize User Interface Editor, select the command you
want to add and drag it onto the Quick Access toolbar.

To remove a command from the Quick Access toolbar

 ➤ Select the command on the Quick Access Toolbar, right-click, and
click Remove from Quick Access Toolbar.
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Context Menus
When you right-click in the drawing area, the content of the context menu
depends on the currently selected object(s). For example, if one or more door
objects are selected, a door-specific context menu is displayed as shown.

Door context menu

Most commands that can be found on the context menu of an object exist in
the contextual ribbon tab of the object, too.

If more than one type of object is selected, the context menu includes only
those commands that can be applied to all the selected objects. Likewise, the
ribbon displays a Multiple Objects contextual tab that contains only the
applicable commands. If no objects are selected, the general context menu is
displayed as shown below. This menu contains non-object-specific commands.
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General drawing context menu

Tool Palettes
Tool palettes provide the main method for accessing tools to create objects in
your model. You can have tools for standard objects as well as for objects with
specific styles and properties. Tool palettes are organized by tool palette groups
in a tool palettes set. You can create your own tool palettes, or you can copy
existing tool palettes from the Content Browser.

Design tool palette with tools for standard design objects

For more information, see Working with Tool Palettes on page 70.
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Properties Palette
The Properties palette provides a central location to view and modify both
the physical and graphical properties of an object. The object can be one you
are about to draw, or one that is already selected in the drawing area. Using
the Extended Data tab of the Properties palette, you can also attach other
kinds of information to an object, such as classifications, notes, reference
documents, hyperlinks, and property set data. You typically keep the Properties
palette open during an AutoCAD Architecture session.

Properties Palette for a standard wall object

For more information, see The Properties Palette on page 107.

Drawing Status Bar
Located at the bottom of the drawing area, the drawing status bar displays
status information about the current drawing and provides access to commands
that can be applied to the drawing.
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The drawing status bar contains the following information and controls:

■ Project Information: If the drawing is part of an AutoCAD Architecture
project, this information includes the name of the project and the type of
file, (such as View or Construct). For more information, see Drawing
Management on page 303.

■ Annotation Scale: To change the annotation scale for the current viewport,
click the current value, and select a new one from the list. Changing the
scale may also change the Level of Detail setting described below.

■ Annotation Visibility: Click  to show annotative objects for all scales.

Click  to automatically add scales to annotative objects when the
annotation scale changes.

■ Level of Detail: Shows the current display configuration of the active
viewport and provides a drop-down list from which you can select another
configuration.

■ Cut Plane: Identifies the global cut plane height for the active display
configuration and provides access to a dialog that lets you adjust the setting.
For more information, see Global Cut Planes on page 550.
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■  (Surface Hatch Toggle): Lets you switch the display of surface hatching
on or off. For more information, see Working with Surface Hatches on
page 904.

■  (Layer Key Overrides): Lets you switch layer key overrides on or off in
the Layer Key Overrides dialog. For more information, see Layer Key
Overrides on page 771.

■  (Isolate Objects): Lets you hide or display objects you have selected in
the drawing. For more information, see Editing Objects in Temporary Views
on page 1135.

■  (AEC Project Standards): When a project is loaded, click here to
synchronize or configure standards for the current project. For more
information, see Project Standards on page 599.

■  (Autodesk Trusted DWG): This icon indicates that you have opened a
DWG, DWT, or DWS file that is created using Autodesk applications or
RealDWG™-based applications.

■  (Manage Xrefs): Click to open the External References palette, where
you can reload xrefs that are associated with your current drawing.

■ Missing Standards File(s): When applicable, this warning indicates that
standards files are missing in the current drawing; you can then check
settings for the standards and configure them as necessary. For more
information, see Configuring Project Standards on page 609.

■ Drawing Status Bar Menu: A drop-down list of the settings and commands
available for display on the drawing status bar.
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Showing and Hiding Commands on the Drawing Status Bar
You can specify which features on the drawing status bar menu are shown or
hidden as needed.

1 at the right end of the drawing status bar, click the drawing status
bar menu arrow.

2 Select commands you want show, and clear commands you want
to hide.

Showing and Hiding the Drawing Status Bar
The drawing status bar can be turned on and off from the ribbon or from the
application status bar on page 48. Turning the drawing status bar off will
increase the size of the drawing area.

To show and hide the drawing status bar, click View tab ➤ Windows
panel ➤ Drawing Status Bar.

Command Line
You can directly enter commands using the command line window located
immediately below the drawing status bar.

To hide and display the command line window, click View tab ➤ Windows
panel ➤ Command Line.

If you want to hide the command line window except for its title bar when

you are not using it, click  on the title bar of the command line window.
Moving the cursor over the title bar will redisplay the command line window.
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Application Status Bar
The application status bar contains settings for the current drawing session.
Some settings, such as options for different elevations, only display if you are
working within a project.

The group of commands on the left side of the application status bar can be
displayed as icons or text labels.

Commands displayed as icons

Commands displayed as text labels

To change the display of these commands right-click any of them, and select
Use Icons.

To activate or deactivate any of the commands in this group, click the icon
or label. Blue indicates an active control; gray indicates an inactive control.
To change the settings for one of these commands, right-click the icon or
label, and click Settings.

For detailed information about these options, see “Use Precision Tools” in the
AutoCAD Help.

The following commands and settings are available on the application status
bar:

■ Cursor coordinate values: Controls the coordinate format as either relative
or absolute. For more information, see “Overview of Coordinate Entry” in
the AutoCAD Help.

■  (Snap): Lets you restrict the movement of the cursor to the drawing
grid.
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■  (Grid): Lets you display a rectangular grid as a drawing aid.

■  (Ortho): Lets you restrict cursor movement to horizontal and vertical
directions when creating and modifying objects.

■  (Polar Tracking): Lets you restrict cursor movement to specified angles.

■  (Object Snap): Lets you restrict movement of the cursor to specified
points on objects, such as the midpoint or an intersection point.

■  (Object Snap Tracking): Lets the cursor track along alignment paths
based on other object snap points when specifying points in a command.
This feature can be used only in conjunction with Object Snap.

■  (Dynamic UCS): Lets you temporarily and automatically align the
XY plane of the UCS with a plane on a solid model while creating objects.

■  (Dynamic Input): Lets you enter values for objects directly onscreen
near the cursor. Dynamic input can be turned on and off during creating
or editing an object in the drawing area.

■  (Lineweight): Lets you turn the lineweight display component on or
off for objects in the drawing. In model space, lineweights are displayed
in pixels and do not change when zoomed in or out. Displaying the
lineweight could create some very heavy line display.

■  (Quick Properties): This feature is intended for AutoCAD objects and
is turned off in AutoCAD Architecture.

■  (Model Space) or  (Paper Space): Switches between layouts. For
more information, see “Work with Model Space and Paper Space” in the
AutoCAD Help.

■  (Quick View Layouts): Lets you preview model space and all layouts
in a drawing as a horizontal row of images. Click on a preview image to
display the layout. For more information, see Quick View Tools on page
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65 and “Navigate within a Drawing (Model Space and Layouts)” in the
AutoCAD Help.

■  (Quick View Drawings): Lets you preview all currently open drawings
with their model space and layouts. Click on the preview image to display
the drawing or layout. For more information, see Quick View Tools on
page 65 and “Navigate Between Open Drawings” in the AutoCAD Help.

■  (ShowMotion): Provides an onscreen display that can be used to create,
select, and play back cinematic camera animations called shots. These
animations can be used for presentation purposes or for navigation. For
more information, see “ShowMotion” in the AutoCAD Help.

■  (Pan): Lets you drag the view to reposition it within the drawing area

■  (Zoom): Lets you increase or decrease the apparent size of objects in
the drawing area

■  (SteeringWheel): Lets you display a tracking menu containing different
navigation tools. For more information, see “Navigate with SteeringWheels”
in the AutoCAD Help.

■  (Workspaces): Lets you switch between workspaces. For more
information, see The Workspace Concept on page 22.

■  (Toolbar/Window Positions): Lets you switch between docked windows
and toolbars and floating windows and toolbars.

■ Elevation: Lets you define the elevation of the construct relative to the
level you have selected. This button opens the Elevation Offset worksheet
where you enter or pick the elevation offset.

■  (Replace Z value with current elevation): Can be switched on or off,
replacing the existing Z value with the current elevation.

■  (Clean Screen): Click to switch between the standard screen and a full
screen. In full-screen mode, all toolbars and palettes (except the tool
palettes) are hidden. Hidden palettes retain their current state.
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Showing and Hiding Commands on the Application Status Bar
You can show or hide individual commands on the application status bar
menu.

1 At the right end of the application status bar, click the application
status bar menu arrow.

2 Select commands as desired.

NOTE Alternatively, you can click View tab ➤ Windows panel ➤ Status
Bar to access these commands.

Project Navigator Palette
The Project Navigator palette is the central location to create, modify, and
access AutoCAD Architecture project files. You typically have the Project
Navigator palette open in the workspace while you work on a project. For
more information, see Drawing Management on page 303.
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Project Navigator palette

Finding Information in AutoCAD Architecture
In addition to online help and tutorials, AutoCAD Architecture provides
various ways to quickly access the information you need to be successful with
new and existing features. Review the sections below to learn how you can
get help quickly and with minimal disruption of your workflow.

InfoCenter Toolbar
InfoCenter is a central location where you can search for product-related help
and other information sources. You can search for information through
keywords (or by typing a phrase), display the Communication Center panel
for product updates and announcements, or display the Favorites panel to
access saved topics.

When you enter keywords or type a phrase, and then press ENTER or click
the Search button, you search multiple Help resources in addition to any files
that have been specified in the InfoCenter Settings dialog. The results are
displayed as links on a panel. You can click any of these links to display the
Help topic, article, or document.

52 | Chapter 3   The Workspace



In addition, Communication Center displays Did You Know balloons for
selected feature areas. These balloons provide knowledge base information
and general instructional messages such as tips. You can click on the arrow
icon to expand the balloon to view the detailed information.

For detailed information about InfoCenter, see “Find Information Using
InfoCenter” in the AutoCAD Help.

Help Menu
With the removal of the menu bars, the commands to access Help features
have been moved into the InfoCenter at the top right of the application
window. Here, you can find the Help menu that lets you access Help, Tutorials,
and other interactive resources.
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Communication Center
Communication Center is accessed from the InfoCenter toolbar. This resource
displays links to information about product updates and product
announcements, and may include links to Subscription Center, CAD Manager
specified files, and RSS feeds.

F1 Context Help
For many commands and dialogs you can access a context-related Help topic
using one of the following methods:

■ Press F1 while a command is active or a dialog is open.

■ Press F1 while a ribbon tooltip is displayed.

■ Click the Help button in a dialog.

Tooltips
In addition to interactive tooltips that help you to create and edit objects (see
Direct Editing with Grips and Dynamic Dimensions on page 115), AutoCAD
Architecture provides tooltips that display information about the command,
option, or file over which you pause the cursor.

Command Tooltips
A short description displays whenever you pause the cursor over a command
in any of the following locations:

■ The ribbon

■ The Quick Access toolbar

For some commands, an extended tooltip displays after a user-specified time
interval.
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Standard tooltip for command

Extended tooltip for command

Controlling the Display of Command Tooltips
You can change the display of command tooltips. For extended tooltips you
can define a time interval between the display of the basic tooltip and the
extended tooltip.

1 Click  ➤ Options.

2 Click the Display tab.

3 Under Window Elements, select Show Tooltips.

4 If you want to change the time interval between displaying the
basic tooltip and the extended tooltip, select a different value for
Number of seconds to delay. If you want to turn off the extended
tooltip information completely, deselect Show extended Tooltips.

5 Click OK.
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Dialog and Palette Tooltips
The following dialogs and palettes support extended tooltips:

■ Project Browser dialog

■ Project Navigator palette

■ Drawing Compare palette

Object Rollover Tooltips
When you pause the cursor over an object in the drawing area, an
informational tooltip displays basic information about the object.
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Unlike the rollover tooltips provided for AutoCAD objects, such as lines or
polylines, this information is standardized and cannot be changed. For
information on how to configure rollover tooltips for AutoCAD objects, see
“Customize Rollover Tooltips” in the AutoCAD Customization Guide.

Property Palette Tooltips
The Properties palette displays tooltips when you pause the cursor over a
property in the list.

Thumbnail (Preview) Tooltips
In the Project Navigator, you can display thumbnail previews of project
drawings. The preview can be a graphic or a detail, or a combination of both.
Displaying thumbnails can be helpful when you are navigating large projects
with many drawings.
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To activate preview tooltips in the Project Navigator

1 On the Quick Access Toolbar, click  .

2 In the Project Navigator, open the Constructs, Views, or Sheets
tab.

3 Right-click in the toolbar area at the bottom of the tab.

4 Click Tooltip Style, and select one of these options:

To displayUse this option…

only the name of the drawing file, maxim-
izing the file tree visibility.

Name

only a preview image of the drawing at
the size you specify (Small, Medium, or
Large).

Preview

only a text description of the file, identify-
ing its location, size, last-saved date, and
last editor.

Details

both a a text description and a preview
image at the size you specify (Small, Medi-
um, or Large).

Preview & Details

5 If you want a static display of the preview image or the detailed
file description, right-click in the toolbar area again, and click
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Preview/Details Pane. Regardless of which tooltip style is selected,
this option displays a preview of a selected file in an pane below
the file tree. Use the buttons on the pane's title bar to switch
between the Preview pane containing the image and the Detail
pane containing the text description.

Solution Tips
The intended interaction among objects in an AutoCAD Architecture drawing
depends on various rules about how objects are placed in relation to one
another. Whenever the software identifies a problem with the placement of
objects or their components, a solution tip icon is displayed to identify the
location of the problem, as shown.

Move the cursor over the icon to display a message that describes the problem
and provides one or more possible solutions. Some solution tips provide
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complete instructions for resolving the problem. Where more detailed
instructions are required, you can press F1 to access the relevant topic in Help.

Note that not all object configuration problems have an easily identifiable
cause or a specific solution. This is often true in the case of boolean operations
where an entity such as a body modifier is added to or subtracted from an
object. In these cases, the solution tip identifies the kind of object or
component involved and suggests corrective action. You may be advised to
modify the location or the geometry of the object, but it is essentially a
trial-and-error approach. The messages are tips rather than guaranteed
solutions.

By default, solution tip icons are displayed when you are drafting, but not
during plotting or publishing. You can change these settings in the Options
dialog using the following procedure:

1 Click  ➤ Options.

2 In the Options dialog, click the AEC Editor tab.

3 In the Solution Tip panel, select or clear Drafting and
Plotting/Publishing as desired.

Object Grip Tooltips
Objects in AutoCAD Architecture have grips you can use to manipulate them.
Pause the cursor on a grip to display a tooltip identifying the grip's function.
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Door dimension grips

Many grip tooltips contain additional information on how to use the grip.

Displaying the tooltip for door standard size

For more information, see Direct Editing with Grips and Dynamic Dimensions
on page 115.

Working with Objects in the Workspace
The AutoCAD Architecture workspace is where you add and manipulate the
architectural objects that make up your drawings.
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Adding Objects
You add objects to the drawing with tools.

Tools generally have preset creation parameters called properties. When you
click an object tool to add an object in the drawing, the Properties palette
opens, and you can change properties for the new object if desired. If not,
you can go ahead and place the object in the drawing. For more information,
see Tools on page 85.

Adding a wall to the drawing

Tools are arranged on tool palettes for easy access. To open the default Design
tool palette, click Home tab ➤ Build panel ➤ Tools drop-down ➤ Design Tools

 .

Modifying Objects
You can modify an object using any of the following methods:

■ Object-specific (contextual) ribbon tab: When you select an object, an
object-specific tab is displayed on the ribbon. For example, when you select
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a door, the Door tab displays. The object-specific tab contains commands
that apply to the selected object.

■ Properties palette: The Properties palette is one of the central locations for
entering and changing information about an object. This palette has
categories that group the properties by type.
For detailed information, see The Properties Palette on page 107.

■ Matching properties between objects: You can use the Match Properties
command to copy the style and display properties of one AEC object and
apply them to one or more other objects of the same type. For more
information, see Matching Object Properties on page 124.

■ Context menu: Right-click the object to display its available commands.
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Door context menu

■ Direct editing with grips: Commands for modifying an object are accessible
from the object’s grips. Click an object in a two-dimensional (2D) or
three-dimensional (3D) view to display its grips.
For detailed information about object grips, see Direct Editing with Grips
and Dynamic Dimensions on page 115. Information about grip-editing is
also covered in the individual object topics.
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Window grips for direct editing

View and Navigation Tools
There are various ways to view the model in AutoCAD Architecture. For a
complete description, see “Control the Drawing Views” and “Work with
Multiple Open Drawings” in the AutoCAD Help. The following topics highlight
view and navigation tools in AutoCAD Architecture.

Quick View Tools
Quick View tools make navigating and selecting drawings and layouts easier.

Quick View Layouts

This feature lets you preview and easily switch between model space and all
layouts in the current drawing.

Click  (Quick View Layouts) on the application status bar to display a row
of thumbnail images above the bar:
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Click a thumbnail to navigate to that model space or layout.

You can also easily plot or publish with the buttons that display at the top
corners of the layout thumbnail when the cursor is on it.

For more information, see “Switch Between Layouts in the Current Drawing”
in the AutoCAD Help.

Quick View Drawings

This feature lets you preview and easily switch between model space and

layout in all currently open drawings. Click  (Quick View Drawings) on
the application status bar to display a row of drawing thumbnail images above
the bar:

Move the cursor over a drawing image to display its Save and Close buttons
as well as smaller images of the model space and layouts for that drawing.
When you move the cursor over one of the model/layout images, they enlarge
and the drawing images shrink.

You can also create and open a new drawing using the toolbar that displays
below the drawing thumbnails.

For more information, see “Switch Between Open Drawings” in the AutoCAD
Help.
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ViewCube
The ViewCube is a 3D navigation tool that appears when the 3D graphics
system is enabled and allows you to switch between standard and isometric
views.

Once the ViewCube is displayed, it displays in one of the corners of the
drawing window over the model in an inactive state. When you position the
cursor over the ViewCube, it becomes active. You can switch to one of the
available preset views, roll the current view, or change to the Home view of
the model.

Displaying the ViewCube in the drawing area

 ➤ Click View tab ➤ Navigate panel ➤  ➤ View Cube.

NOTE The View Cube is visible by default. An exception to this are
the 2D Wireframe and 3D Hidden visual styles, where View Cube is
not displayed.

ViewCube is also displayed in the Object Viewers.
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NOTE When ViewCube is displayed in the drawing area, you have access to a
compass and can define a UCS. In an Object Viewer, no UCS option and no
compass are available.

The ViewCube is always turned on in Object Viewers.

For more information, see “View Cube” in the AutoCAD Help.

For information about Object Viewer, see Object Viewer on page 1111.

SteeringWheels
SteeringWheels are tracking menus that are divided into different sections
known as wedges. Each wedge on a wheel represents a single navigation tool.
You can pan, zoom, or manipulate the current view of a model in different
ways.

SteeringWheels can save you time and clicks by combining many of the
common navigation tools into a single interface. Wheels are specific to the
context that a model is being viewed in.
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To display SteeringWheels in the drawing area, click View tab ➤ Navigate
panel ➤ Full Navigation Wheel.

Alternatively, you can right-click in the drawing area (with no objects selected),
and click SteeringWheels.

You can choose from several different wheels, each with its own drafting
theme. Some wheels are designed for 2D navigation, while other wheels are
better suited for 3D navigation.

The SteeringWheels can also be displayed in the Object Viewers.

Showing and Hiding the Steering Wheel in an Object Viewer

1 Open the Object Viewer from the context menu of an object or
from the Style Manager.

2 Right-click in the view area, and click SteeringWheel.
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Alternatively, you can click  .

3 To close the SteeringWheel, right-click, and click Close Wheel, or

click  again.

For detailed information, see “SteeringWheels” in the AutoCAD Help.

ShowMotion
The ShowMotion feature lets you add movement and transitions to captured
camera position called shots. You can create still shots, cinematic shots, or a
recorded walk that allows you to click and drag along the path of desired
animation. Shots can be grouped together to form sequences called view
categories.

To start ShowMotion, click  on the application status bar.

For detailed information, see “ShowMotion” in the AutoCAD Help.

Working with Tool Palettes
Tool palettes provide instant access to a complete inventory of AutoCAD
Architecture tools—such as walls, doors, and windows—in one consistent user
interface. Highly visual, tool palettes include previews of styles. You can create
custom tool palettes that address your specific design needs. For example, you
can create a palette to store a list of commonly used curtain wall, stair, and
window tools.
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Tool palette components

Tool Palettes Set

Tool palettes sets contain groups of tool palettes. You can rename the default
tool palettes set or create a custom tool palettes set. Additionally, you can add,
remove, and rearrange palettes and groups in the set.

You can add tool palettes to the tool palettes set from a tool catalog. For
example, you could create one tool palette set for imperial tools and another
for metric tools. For more information, see Specifying Different Tool Palettes
for the Tool Palettes Set on page 75.

Only one tool palettes set can be active during an AutoCAD Architecture
session, although you can specify different tool palettes for different user
profiles. When that profile is used, the collected tool palettes will be combined
into one tool palettes set.
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Tool Palettes Group

A tool palettes group is a collection of tool palettes. 4 tool palettes groups are
available when you start AutoCAD Architecture: Design, Document, Detailing,
and Visualization. You can add, rename, remove, export, import, and rearrange
tool palettes groups. Tool palettes groups are contained in the tool palettes
set. For more information, see “Organize Tool Palettes” and “Save and Share
Tool Palettes” in the AutoCAD Help.

TIP The quickest way to locate and view an AutoCAD topic referenced in AutoCAD
Architecture Help is to click the Search tab in the Help window, select the Search
titles only option, and then copy and paste or type in the AutoCAD topic name,
and click List Topics.

Tool Palettes

Tool palettes contain collections of tools and represent the individual tabs of
a tool palettes group. A number of tool palettes are available from the AutoCAD
Architecture Sample Palette catalog. You can create new tool palettes in
AutoCAD Architecture or in the Content Browser. Usually you place tools on
tool palettes according to tool type or design phase. For example, you could
place your wall tools on a tool palette called Walls or your preliminary
conceptual tools on a tool palette called Massing Study. When you create a
tool palette in the Content Browser, you can link it to AutoCAD Architecture.
Whenever the tool palette is updated in the Content Browser, the changes
are updated in the tool palette in AutoCAD Architecture too. This is useful for
large projects where consistency of styles and tools is necessary. For more
information, see Working with Tool Palettes from a Central Location on page
82.

Tools

Tools represent the individual objects you can add to a drawing. A tool contains
creation parameters for the object it creates. When you add an object with a
specific tool, the object has the settings you defined in the tool. This eases
the design process and enhances consistency across a project.

For example, you might define a wall tool that contains the style “CMU 8
Furring” and that has automatic cleanup and a baseline offset of 1". Whenever
you add a wall with this tool, the wall has the style CMU 8 Furring, it cleans
up automatically, and it has an offset of 1". For more information, see Tools
on page 85.
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Tool Palettes and the Content Browser

When multiple users are working on a large project, consistency of tools is
especially important. Typically, the objects for the project and their styles and
properties are set up by a CAD manager or system administrator, and then
distributed to the team. The administrator can put tools and palettes in a
central location in the Content Browser and link them to each user’s computer.
Whenever the tools or palettes are updated in the Content Browser, they are
updated on the users’ computers too. For more information, see Content
Browser Overview on page 129 and Working with Tools from a Central Location
on page 101.

Project Tool Palettes

When you are working with an AutoCAD Architecture project, you can design
and associate a project tool palette group to the project. The project tool
palettes contain the tools used in the project, and can be based on project
standards. For detailed information about setting up project tool palettes, see
Setting up Standard Tools in a Project on page 622.

Opening the Tool Palettes Set

To open the tool palettes, set, click Home tab ➤ Build panel ➤ Tools

drop-down ➤ Design Tools  .

Controlling the Appearance of the Tool Palettes Set
Typically, the tool palettes set remains open during the AutoCAD Architecture
session. It is the central location from which you add objects to the drawing
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and start object-related commands. A number of user-definable display options
let you optimally integrate the tool palettes with your workspace.

Docking the Tool Palettes Set
Use this procedure to dock the tool palettes set on the left or right side of your
workspace.

1 In the title bar of the tool palettes set, click  , and then click
Allow Docking.

2 Position the cursor over the title bar, and drag the tool palettes
set to one side of the workspace.

A preview graphic shows the new position of the tool palettes set.

3 Release the tool palettes set when it is in the location you want.

Hiding the Tool Palettes Set
Use this procedure to hide the tool palettes set when it is not in use. The tool
palettes set becomes hidden when you move the cursor away from it, leaving
only the title bar visible. When you move the cursor over the title bar, the
tool palettes set is re-displayed.

Tool palettes set hidden (left) and re-displayed (right)

1 In the title bar of the tool palettes set, click  (Auto-hide).

The tool palettes set is hidden, except for the title bar.
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2 To re-display the tool palettes set, move the cursor over the title
bar.

Adjusting the Transparency of the Tool Palettes Set
Use this procedure to adjust the transparency of the tool palettes set. The more
transparent the tool palettes set, the more easily you can see objects in your
drawing underneath it.

NOTE Transparency is not available if hardware acceleration is enabled.

1 In the title bar of the tool palettes set, click  , and then click
Transparency.

2 To adjust the transparency of the tool palettes set, move the slider.

3 To turn off transparency, select Turn off window transparency.

4 Click OK.

Renaming the Tool Palettes Set
Use this procedure to rename the tool palettes set, for example to name it
with a project or company name.

1 In the title bar of the tool palettes set, click  , and then click
Rename Palette Set.

2 Enter a name for the tool palettes set, and press ENTER.

Specifying Different Tool Palettes for the Tool Palettes Set
Use this procedure to switch between different palette combinations in the
tool palettes set.

Only one tool palettes set can be active during an AutoCAD Architecture
session. You can, however, set different tool palettes for different user profiles.
You do this by collecting tool palettes from several locations (paths) in a profile
and letting the workspace combine them into one tool palettes set.

1 Click  ➤ Options.
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2 Define the tool palettes used for the current session:

■ If you have created a workspace profile containing a tool
palettes path, click the Profiles tab, select the desired profile,
and click Set Current.

■ If you have not created a workspace profile, click the Files tab,
and click the Tool Palettes File Location entry. Then click
Browse, and browse for a folder containing the desired tool
palette.
Add paths to all additional tool palettes to be included in the
tool palettes set of this profile.

3 Click OK.

Creating a New Tool Palettes Set
Use this procedure to create a new tool palettes set.

1 Create a folder in which you will create the new tool palettes set.

The default tool palettes set is in \Documents and
Settings\<Username>\Application Data\Autodesk\ACA
2012\enu\Support\WorkspaceCatalog (Imperial/Metric).

2 Click  ➤ Options.

3 Click the Profiles tab.

4 Click Add to List, and create a profile to contain the new tool
palettes set; for example Design - Metric Palette Set.

5 Select the new profile, and click Set Current.

6 Click the Files tab.

7 Under Tool Palettes File Locations, select the support path for the
previously defined folder in which you will create the new tool
palettes set.

NOTE If you point to a folder already containing a tool palettes set,
a new tool palettes set is not created; instead, the existing tool palettes
set is used in the profile.

8 Click OK.
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In the AutoCAD Architecture workspace, an empty tool palettes
set is displayed.

9 To rename the tool palettes set, click  , and then click Rename
Palette Set.

10 Add tool palettes and tools to the new set:

Then…If you want to…

see Creating a New Tool Palette on
page 78.

add a new empty tool palette

see Adding a Tool Palette from a
Tool Catalog in the Content
Browser on page 83.

add a tool palette from the Content
Browser

see Creating a Tool from an Object
in the Drawing on page 92.

add a tool to a palette

The changes you make are saved to the tool palettes set in the
new profile you created.

To revert back to your original tool palettes set, select your original
profile in the Options dialog.

Creating a New Tool Palettes Group
Use this procedure to create a new tool palettes group.

1 In the title bar of the tool palettes set, click  , and then click
Customize Palettes.

Alternatively, you can click Manage tab ➤ Customization
panel ➤ Tool Palettes.
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2 Select a palette group, right-click, and click New Group.

3 Enter a name for the new group, and press ENTER.

4 Drag the new group folder to the correct position in the tree
structure.

5 Select a tool palette from the left pane for the new tool palettes
group, and drag it into the new group folder.

6 Click Close.

TIP The Customize dialog can be very useful for adding palettes to
project palette groups. For more information, see Displaying the
Project Tool Palette Group on page 637.

Creating a New Tool Palette
Use this procedure to add an empty tool palette to your tool palettes set.

After creating the tool palette, you can add tools to it. For more information,
see Tools on page 85.

1 In the title bar of the tool palettes set, click  , and then click
New Palette.

2 Enter a name for the new tool palette, and press ENTER.
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Defining the Appearance of Tool Palettes
Use this procedure to define the appearance of individual tool palettes.

The display of the tool palettes depends on the settings you specify for the
overall tool palettes set, (as described in Controlling the Appearance of the
Tool Palettes Set on page 73), and the settings you specify for individual tool
palettes. In the tool palettes set, you specify the transparency, size, position,
and auto-hide of the tool palettes set.

On the tool palette, you specify the size of tool images and their arrangement
on the tool palette.

Tool palettes with different sized icons displayed

When you change tool images to a smaller size, you can display more tools
on a tool palette. This might become important if you display different palettes
at the same time, such as the Properties palette or the Project Navigator palette.

To save space, you can also display tool images without tool text below them.
This method is best suited when the icons for your tools are easy to
differentiate. If the icon alone proves insufficient to identify a tool, the tooltip
for each icon provides additional guidance.
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Icon-only display on the tool palette

You can also display tools in a single column on the tool palette. When you
are using a single-column list, tool text is always displayed.

Tool palette in list view
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To change the Tool palette’s appearance

1 Open the tool palette that you want to change.

2 Right-click the palette, and click View Options.

3 In the View Options worksheet, select the desired View style:

Then…If you want to…

select Icon only for View style.view only tool icons

select Icon with text for View style.view tool icons and tool text

select List view for View style.view tool icons and tool text in a
single column list

4 To apply these changes to all palettes in the tool palettes set, select
All Palettes for Apply to.

5 Click OK.

Adding Text and Separator Lines to Tool Palettes
Use this procedure to add separator lines and text to a tool palette.

Separator lines can be useful if you want to create subdivisions on a tool palette
containing many tools. To annotate a separator line, you can insert a text
element.

1 Open the tool palette to which you want to add separator lines
and text.

2 Right-click in the palette between the tools where the separator
should go, and click Add Separator.

A separator line is inserted between the tools.

3 To add text above the separator line, right-click either to the right
of the last tool before the separator line, or to the left of the
separator line itself, and click Add Text.

4 Enter the text you want to display above the separator line, and
press ENTER.

5 To edit the text, select the text item, right-click, and click Rename.
Then, edit the text as necessary.

6 To delete a separator line or a text annotation, select the separator
line or text, right-click, and click Delete.
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Working with Tool Palettes from a Central Location
When multiple users are working on a large project, consistency of tools is
especially important. Typically, the objects for the project and their styles and
properties are set up by a CAD manager or system administrator, and then
distributed to the team. The administrator can put tools and palettes in a
central location in the Content Browser and link them to each user’s computer.
Whenever the tools or palettes are updated in the Content Browser, they are
updated on the users’ computers too. For more information, see Content
Browser Overview on page 129.

Using tool palettes from the Content Browser

TIP If you are working with an AutoCAD Architecture project, you can generate
a tool catalog based on the standard styles of the project. For more information,
see Creating a Tool Catalog for a Project on page 626.
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Adding a Tool Palette from a Tool Catalog in the Content Browser
Use this procedure to link a tool palette from a tool catalog in the Content
Browser to the tool palettes set in AutoCAD Architecture.

For information on creating tool palettes in the Content Browser, see Adding
Content to a Tool Catalog on page 157.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Select the tool catalog containing the tool palette you want to
copy, right-click, and click Properties.

3 Select Link items when added to workspace, and click OK.

4 Open the tool catalog, and navigate to the tool palette.

5 Move the pointer over the i-drop® icon next to the tool palette

so that the pointer image changes to an eyedropper (  ).

To copy multiple tool palettes, press and hold CTRL while clicking
each palette; then position the eyedropper over any of the selected
palettes.

6 Drag the palette to the tool palettes set in the AutoCAD
Architecture workspace.

The tool palette is dropped into the tool palettes set.

7 Right-click on the palette, and click Properties.

The text below the check box displays the name of the catalog in
the Content Browser from which the palette is updated.

If you click that name, it opens the catalog from which the tool
palette was linked.
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8 Select or clear Enable Auto-refresh:

Then…If you want to…

select Enable Auto-refresh.automatically update the linked tool
palette from the Content Browser
when starting AutoCAD Architec-
ture

clear Enable Auto-refresh.update the linked tool palette
manually with one of the methods
described in Updating a Tool
Palette from a Tool Catalog in the
Content Browser on page 84

The name of the tool palette in the Content Browser (from which
the selected tool palette is updated) is displayed under Name.

9 Click OK.

Updating a Tool Palette from a Tool Catalog in the Content
Browser

Use this procedure to update a linked tool palette in the tool palettes set from
its source tool catalog in the Content Browser.

1 Link a tool palette from a catalog in the Content Browser to the
tool palettes set, as described in Adding a Tool Palette from a Tool
Catalog in the Content Browser on page 83.

When a tool palette is linked to the tool palettes set from a catalog
in the Content Browser, a Refresh button is displayed at the
bottom of the palette.
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2 Click the Refresh button to update your local tool palette with
the latest changes from the catalog in the Content Browser.

Alternatively, you can right-click the palette, and click Refresh
Palette.

NOTE You can also update the whole palette set by clicking  in
the tool palettes set, and then clicking Refresh Palette Set. This
command updates all linked tool palettes in the tool palettes set.

Tools
Tools represent the individual objects you can add to a drawing. A tool contains
creation parameters for the object it represents. When you add an object with
a specific tool, the object has the settings you defined in the tool. The use of
tools speeds up the design process and enhances consistency across a project.

For example, you might define a wall tool that contains the CMU 8 Furring
style and has automatic cleanup and a baseline offset of 1". Whenever you
add a wall with this wall tool, the wall has the CMU 8 Furring style, it cleans
up automatically, and it has an offset of 1".

Standard object tools

Based on the tool type, you can define general properties such as:

■ Tool name
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■ Tool description (also used as the tooltip and as the tool description when
the tool is copied to a tool catalog in the Content Browser)

■ Description of objects inserted with this tool

■ Layer key of objects inserted with this tool

■ Layer overrides of objects inserted with this tool

■ Object style (if the tool is style-based)

■ Location of object style (if the tool is style-based)

In addition, you can define object-specific properties that apply to this tool
type. For example, if you create a wall tool, you can set the wall cleanup,
width, height, baseline settings, and the roof/floor lines of walls that are
inserted with this tool.

Style Location

Object styles are located in Styles drawings. To assign a style to an object tool,
you can either point to a style in the current drawing or to a style in an external
drawing. For more information, see Styles and Support Files on page 126.

Tool Types
Tools in AutoCAD Architecture fall into 3 categories.

DescriptionTool Category

An object tool inserts a design object—such
as a wall or a window assembly—into a

Object tools

drawing. An object tool has a specific style
and specific object properties: for example,
a wall tool might be called Brick-4 Brick-4.

Command tools are a graphical represent-
ation of an object-related command. For

Command tools

example, the Browse Property Data tool
opens a dialog box for browsing the prop-
erty data of all objects in a drawing; the
Renumber Data tool renumbers property
data in selected property sets by increment
or by a user-defined number. You can also
create your own tools for each command.
An AutoCAD general-purpose command

86 | Chapter 3   The Workspace



DescriptionTool Category

tool lets you associate any command or
macro. For commands that create an ob-
ject, you can also assign basic AutoCAD
object properties. For a list of available
AutoCAD Architecture command tools, see
Using Command Tools on page 96.

You can create tools for frequently used
AEC Content items that were created with

AEC Content tools

the AEC Content Wizard. For more inform-
ation, see Creating a Tool from AEC Con-
tent in DesignCenter on page 95.

Project Standard Tools

When you are working with an AutoCAD Architecture project, you can set
up standard styles that are updated and synchronized throughout the project
lifecycle. For more information, see Setting up Standards in a Project on page
607.

Creating an Object with a Tool
Use this procedure to create an object with a tool.
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1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Design Tools

 .

2 Click the tool palette that contains the tool for the object you
want to insert.

For example, if you want to insert a bifold double door, click the
Doors palette, and navigate to the Bifold Double Door tool.

3 Click the tool.

4 On the Properties palette, enter any changes you want to make
to the default values.

NOTE Certain values can be set only when you are inserting the
object; for example, the position of a door along the wall into which
it is inserted can be defined only when you are inserting the door.
You cannot change the position for an existing door later. Values that

can be set only during insertion are marked with this symbol  on
the Properties palette.

5 Click in the drawing where you want to insert the object.

6 Follow any additional prompts as required to insert one or more
objects in the drawing, and then press ENTER.
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Changing the Tool Properties
Use this procedure to change the properties of a tool on a tool palette.

You can set these general properties for an object tool:

■ Tool name

■ Tool description (also used as the tooltip and as the tool description when
the copied to a tool catalog in the Content Browser)

■ Description of objects inserted with this tool

■ Layer key of objects inserted with this tool

■ Layer overrides of objects inserted with this tool

■ Object style (if the tool is style-based)

■ Location of object style (if the tool is style-based)

In addition, you can define object-specific properties that apply to this object
type. For example, if you create a wall tool, you can set the wall cleanup,
width, height, baseline settings, and the roof/floor lines for all walls inserted
with this tool.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Design Tools

 .

2 Click a tool palette.

3 Select the tool, right-click, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

6 Expand Basic, and expand General.

7 Enter a description of the objects that you can create using this
tool.

8 Specify a layer key and any layer key overrides; otherwise, the
layer assignments specified in the layer key style in the drawing
are used.

9 Click Browse for Style location, if the location is other than the
current drawing to select an object style.

10 Add object-specific properties.
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NOTE When you click a property to enter a value, the value
underneath the current property is hidden and the property field is
highlighted. Enter a value for the current property in the appropriate
location.

11 Click OK.

Changing a Tool Icon
Use this procedure to change the icon of a tool.

When you add a new tool to a tool palette, it displays either the icon of the
tool it was copied from or a default icon. You can change the icon by selecting
a new one from an image file or from an object in the drawing. You can also
choose to display the icon as simple monochrome linework.

Changing the tool icon

You can use the following image formats for tool icons:

■ PNG

■ GIF

■ JPG

■ BMP

■ TIFF

NOTE Icons in the tool palettes can have a maximum size of 64 x 64 pixels. Larger
images are scaled when inserted. To change the display size of the tool on the
palette, see Defining the Appearance of Tool Palettes on page 79

To copy an icon image from a file

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Design Tools

 .

2 Click the tool palette that contains the tool for which you want
to select a new icon.
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3 Select the tool, right-click, and click Properties.

4 In the Tool Properties worksheet, right-click the existing icon,
and click Specify Image.

5 In the Select Image File dialog, select the image you want to use
as a tool icon, and click Open.

6 Click OK.

7 To display a tool as simple monochrome linework, in the Tool
Properties worksheet, right-click the existing icon, and click
Monochrome.

The monochrome option is not available for all tools.

To create an icon from an object in the drawing

1 Select the tool on the tool palette, right-click, and click Set Image
from Selection.

2 Select the object in the drawing you want to use as a tool icon,
and press ENTER.

The tool icon is created with the last view direction and display configuration
used in the viewer of any tool of this type. For example, if the tool viewer of
the last-used wall tool is set to Top view and the Medium Detail display
configuration, any wall you select in the drawing as a tool icon is displayed
in Top view and with the Medium Detail display configuration.

You cannot create icons from objects that contain custom blocks, curtain
walls, or door/window assemblies with nested styles. If you need to create an
icon based on a custom block, specify an external image.
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Changing a Tool Icon
Use this procedure to change a tool icon after editing the viewer settings of
the tool.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Design Tools

 .

2 Click the tool palette that contains the tool icon you want to
refresh.

3 Select the tool, right-click, and click Properties.

4 In the Tool Properties worksheet, change the viewer settings of
the tool image.

For example, switch from a SW Isometric view to a Top view.

5 Right-click the existing icon, and click Refresh Image.

6 Click OK.

Creating a Tool from an Object in the Drawing
Use this procedure to create a tool from an object in the drawing.

You can create only object tools with this method. For information on creating
command tools, see Using Command Tools on page 96.

92 | Chapter 3   The Workspace



Creating a tool from an object in the drawing

1 Create an object with the appropriate style and properties in the
drawing.

IMPORTANT The drawing containing the style should be saved to
a location where it will be available in the future. Otherwise, the tool
will not be able to access the style, and will revert to the Standard
style.

2 Open the tool palette where you want to create the new tool.

3 Select the object, and drag it onto the tool palette.

4 Define additional properties for the tool, if necessary.

For more information, see Changing the Tool Properties on page
89.

Copying a Tool from a Tool Palette
Use this procedure to copy a tool from one tool palette to another.

1 Open the tool palette that contains the tool you want to copy.

2 Select the tool, right-click, and click Copy.

3 Open the tool palette onto which you want to copy the tool,
right-click, and click Paste.

4 Change the properties of the tool, if necessary.

For more information, see Changing the Tool Properties on page
89.
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Creating a Tool from the Style Manager
Use this procedure to create a tool from a style in the Style Manager.

Creating a tool from the Style Manager

1 Open the tool palette where you want to create the new tool.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Select the style from which you want to create a tool.

For example, if you want to create a wall tool with the Stud-3.625
GWB-0.625 Each Side (1 Hour) style, expand Wall Styles, and
select the Stud-3.625 GWB-0.625 Each Side (1 Hour) style.

4 Drag the style to the tool palette.

A new tool with the selected style is inserted in the tool palette.

5 Click OK to close the Style Manager.

6 Define additional properties for the tool in the tool palette, if
necessary.

For more information, see Changing the Tool Properties on page
89.
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Creating a Tool from AEC Content in DesignCenter
Use this procedure to create a tool from an AEC Content item in DesignCenter.

NOTE You can also create tools from blocks in DesignCenter, but they have slightly
different tool options.

You can drag and drop AEC content items from a DesignCenter folder to a
tool palette. For more information on creating AEC Content, see Adding AEC
Content to Drawings on page 3912.

AutoCAD Architecture provides the Design Tool Catalog and the
Documentation Tool Catalog in the Content Browser. These catalogs already
have tools set up for predefined AEC Content and sample object styles. The
catalogs are available for both metric and imperial units.

Creating a tool from AEC Content in DesignCenter

1 Open the tool palette where you want to create the new tool.

2 Click Insert tab ➤ Content panel ➤ Content Browser
drop-down ➤ Design Center, and navigate to the AEC Content
item from which you want to create a tool.

3 Drag the item to the tool palette.
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A new tool is inserted on the tool palette.

To change the icon of the new tool, see Changing a Tool Icon on
page 90.

NOTE An AEC Content tool uses the last-used viewer settings for a
tool of this type to generate the tool icon. If the last-used viewer
setting is Gouraud 3D view, and the user creates a tool from a 2D
AEC Content item, the tool icon will be invisible. In this case, you
need to change the viewer setting of the tool to a Top view, and
wireframe.

4 Define additional properties for the tool, if necessary.

For more information, see Changing the Tool Properties on page
89.

Using Command Tools
Command tools are used to execute frequently used commands for tasks other
than AEC object creation. For example, the Browse Property Data tool opens
a dialog for browsing the property data of all objects in a drawing; the
Renumber Data tool renumbers property data in selected property sets. There
are a number of preconfigured command tools in the software; you can,
however, create a user-defined command tool from any AutoCAD and
AutoCAD Architecture command, AutoLISP routines, VBA macros and
applications, and scripts.

Using Predefined Command Tools
AutoCAD Architecture provides the following predefined command tools for
commonly used tasks in a default US install:

DescriptionPalette Group/PaletteTool

Generates a horizontal section.Design/DesignHorizontal Sec-
tion

Generates a vertical section.Design/DesignVertical Section

Lets you renumber objects that are
included in a schedule or linked to
schedule tags.

Document/TagRenumber Data
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DescriptionPalette Group/PaletteTool

Lets you edit the property set data
attached to selected objects and
their styles.

Document/SchedulingEdit Property Set
Data

Lets you access and view the data
for all property sets in a drawing.

Document/SchedulingBrowse Property
Set Data

Starts the space evaluation.Document/SchedulingSpace Evaluation

Lets you create a reference copy
from one object to another in Auto-
CAD Architecture.

Content Browser/Stock Tool
Catalog/Helper Tools

AEC Entity Refer-
ence

Lets you define a cross section
through one or more three-dimen-

Content Browser/Stock Tool
Catalog/Helper Tools

Quick Slice

sional (3D) objects in a drawing (in-
cluding mass groups, AutoCAD
blocks, and external references) and
extract a polyline outline that can be
used to produce a profile shape.

Lets you create flat 2D projections
with hidden background lines from

Content Browser/Stock Tool
Catalog/Helper Tools

Hidden Line Pro-
jection

a 3D view of objects in your draw-
ing.

Lets you create freehand sketch
geometry from objects in a drawing.

Content Browser/Stock Tool
Catalog/Helper Tools

Napkin Sketch

Lets you chamfer two walls in a
drawing.

Content Browser/Stock Tool
Catalog/Drafting Tools

Chamfer

Lets you define the boundaries, pat-
tern type, pattern properties, and

Content Browser/Stock Tool
Catalog/Drafting Tools

Hatch and Gradi-
ent

other parameters for hatch and
gradient fill objects.

Lets you create a profile or shrink-
wrap outline around any collection

Content Browser/Stock Tool
Catalog/Drafting Tools

Shrink Wrap

of contiguous linework entities, in-
cluding architectural objects.
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DescriptionPalette Group/PaletteTool

Lets you create and edit welding
symbols.

Content Browser/Stock Tool
Catalog/Drafting Tools

Welding Symbols

Lets you measure the area of an ob-
ject or a user-defined space.

Content Browser/Stock Tool
Catalog/Measurement Tools

Area

Lets you extract object data from
drawings and export it to a table or
external file.

Content Browser/Stock Tool
Catalog/Measurement Tools

Attribute Extrac-
tion

Lets you measure the distance
between 2 user-selected points.

Content Browser/Stock Tool
Catalog/Measurement Tools

Distance

Lets you display the coordinates of
a user-selected location.

Content Browser/Stock Tool
Catalog/Measurement Tools

Point ID

Lets you calculate the mass proper-
ties of regions or 3D solids

Content Browser/Stock Tool
Catalog/Measurement Tools

Region/3D Solid
Mass Properties

Lets you attach objects to cell posi-
tions on layout grids and volume
grids.

Content Browser/Stock Tool
Catalog/Parametric Layout
& Anchoring Tools

Cell Anchor

Lets you attach AEC objects to the
base curve of other AEC objects or

Content Browser/Stock Tool
Catalog/Parametric Layout
& Anchoring Tools

Curve Anchor

linework, such as lines, arcs, circles,
mass elements, polylines, roofs, or
walls.

Lets you anchor objects to nodes on
layout curves or grids with leaders.

Content Browser/Stock Tool
Catalog/Parametric Layout
& Anchoring Tools

Leader Anchor

Lets you attach objects to nodes on
layout curves or grids.

Content Browser/Stock Tool
Catalog/Parametric Layout
& Anchoring Tools

Node Anchor

Lets you attach an AEC object to the
base curve of another AEC object.

Content Browser/Stock Tool
Catalog/Parametric Layout
& Anchoring Tools

Object Anchor
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To use a preconfigured command tool

 ➤ Navigate to the location of the desired command tool in the tool
palettes or in Content Browser:

■ If the command tool is located on a tool palette, click it to
start the command sequence.

■ If the command is located in Content Browser, either drag it
to the drawing area to directly start the command, or drag it
to a tool palette, and start the command from there.

Using User-Defined Command Tools
AutoCAD Architecture has 2 blank command tools that can be customized
for user-defined commands.

■ Command Tool: A simple blank command tool that lets you execute a
number of command sequences. Allowed commands include AutoCAD
and AutoCAD Architecture commands, VBA macros and applications,
AutoLISP routines, and scripts.

■ Command Tool with Properties: Use this tool for commands that generate
AutoCAD objects like lines, AutoCAD dimensions, or solids. The property
settings for color, layer, linetype, and lineweight that you can set in the
tool will only be used when creating AutoCAD objects. If you were to create
an AEC object with this tool, the layer, color, and linetype settings specified
in the display system for this object would take precedence. If you want
to create AEC objects with a command tool, the simple Command Tool is
recommended.

Command tools are created by copying the blank command tool from Content
Browser to a tool palette, and editing the command properties.

Creating a Simple Command Tool

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog ➤ Helper Tools.

3 Move the cursor over the i-drop icon next to the regular command
tool and drag the tool to a tool palette.

4 On the tool palette, select the command tool, right-click, and
click Properties.
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Command tool properties

5 Change the following tool properties as necessary:

DescriptionProperty

Lets you replace the generic com-
mand tool name with a name that
describes the function of the tool.

Name

Lets you add a more detailed de-
scription to the command tool.

Description

Specifies the layer key to define the
layer on which objects created with
this command will be inserted.

Layer key

Defines overrides for the selected
layer key.

Layer overrides

Specifies the command to be ex-
ecuted by the tool. The following

Command

command types are valid within the
Command Tool:

■ AutoCAD and AutoCAD Archi-
tecture commands

■ AutoLISP routines

■ VBA macros and applications

■ Scripts
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DescriptionProperty

By default, the command tool has
no associated image. To add an

Image

image that illustrates the function
of the tool, right-click in the empty
image area, and select an image as
described in Changing a Tool Icon
on page 90.

6 Click OK.

Working with Tools from a Central Location
You can use the Content Browser to store and organize catalog tools in a
central location. A number of stock tools are available in the AutoCAD
Architecture Stock Tool Catalog. Additionally, sample catalogs contain tools
with styles from the Styles drawings. You can copy these tools to a tool palette
and modify them. You can also create your own tool palettes and tools in a
catalog in the Content Browser, copy them to a tool palette, and retain the
link from the Content Browser to the tool palette. In this case, the tool is
refreshed on the tool palette when it is modified in the catalog in the Content
Browser.

NOTE If you want to link a complete tool palette from the Content Browser to
AutoCAD Architecture, see Adding a Tool Palette from a Tool Catalog in the
Content Browser on page 83.

Linking a Tool from a Catalog in the Content Browser
Use this procedure to link a tool from a catalog in the Content Browser to a
tool palette in AutoCAD Architecture.
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Linking a tool from a catalog in the Content Browser

1 Open the tool palette on which you want to place a tool from the
Content Browser.

2 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser , and navigate to the tool palette or category in the
tool catalog that contains the tool you want to copy.

For more information, see Searching for Items in a Tool Catalog
on page 155.

3 Move the pointer over the i-drop icon next to the tool, so that

the pointer image changes to an eyedropper (  ).

To copy multiple tools, press and hold CTRL while clicking each
tool; then position the eyedropper over any of the selected tools.
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You can also select all the tools in the current category by
right-clicking, and clicking Select All.

4 Drag the eyedropper to a tool palette in the tool palettes set.

5 To refresh the tool, select it, right-click, and click Refresh Tool.

Alternatively, you can select the tool in the tool palette, right-click,
and click Properties. Then select Refresh from on the Properties
worksheet.

Refreshing a tool from the Properties worksheet

NOTE When you select Refresh from, all tool properties on the
worksheet are set to read-only. Properties for this tool must be
changed in the Content Browser.

6 Click OK.
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Updating a Tool in AutoCAD Architecture from the Content
Browser

Use this procedure to update a tool in a tool palette when the tool is linked
to the Content Browser.

NOTE You cannot change and update tools from the Stock Tool Catalog in the
Content Browser. Those tools are read-only.

1 Open the tool palette that contains the tool you want to update.

2 Select the tool, right-click, and click Refresh Tool.

Updating a Tool in the Content Browser from a Linked Tool in
AutoCAD Architecture

Use this procedure to update a tool in a catalog in the Content Browser with
the properties of a linked tool from AutoCAD Architecture.

For example, perhaps you have a tool in the Content Browser that adds a Box
mass element of 3 x 3 x 3 meters. You want to change the tool so that it adds
a Box mass element of 4 x 4 x 4 meters. You would first link the mass element
tool from the Content Browser to a tool palette in AutoCAD Architecture.
Then, temporarily deactivate the link and change the dimension properties
of the tool to 4 x 4 x 4 meters. Next, copy the tool back to the Content Browser.
The Content Browser catalog is updated with the new tool properties. Finally,
reactivate the link from the Content Browser tool to the AutoCAD Architecture
palette.

1 Link a tool from a catalog in the Content Browser to a tool palette
as described in Linking a Tool from a Catalog in the Content
Browser on page 101.

2 Select the tool in the tool palette, right-click, and click Properties.

3 On the Tool Properties worksheet, clear Refresh from.

The tool properties can now be edited.

4 Make the necessary changes to the tool properties.

5 Click OK.

6 Select the tool in the tool palette, and copy it to its original
location in the Content Browser catalog.
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NOTE You can copy a tool to a catalog in the Content Browser using
the Copy and Paste commands from the context menu, or by
dragging the tool onto the Content Browser icon in the Windows
task bar. To select multiple tools in a tool palette, use CTRL-A to select
all or drag while holding the CTRL key to create a selection window.

7 Click Yes when prompted to overwrite the previous version of
the tool.

8 If you want to refresh the tool in the AutoCAD Architecture tool
palette from the new version stored in the Content Browser,
re-open the tool properties for the tool on the tool palette, and
select Refresh from.

Removing the Link of a Tool to a Catalog in the Content Browser
Use this procedure to permanently remove the link between a tool and its
source tool in the Content Browser.

NOTE This action cannot be undone.

1 Open the tool palette that contains the tool you want to unlink
from a catalog in the Content Browser.

2 Select the tool, right-click, and click Remove Catalog Link.

Applying the Properties of a Tool to an Existing Object
Use this procedure to apply the properties of a tool to an existing object.

You can apply the properties of a tool to an existing object in two ways:

■ Apply the properties of a tool to an object of the same type: For example,
apply the properties of a wall tool to an existing wall. All object tools have
this functionality.

■ Apply the properties of a tool to a different object type: Using this method,
you convert the object to an object of the same type as the tool. For
example, when you apply the properties of a wall tool to a polyline, the
polyline is converted to a wall with the settings defined in the wall tool.
Depending on their type, various object tool types may have commands
for converting other objects. For detailed information, see the chapters for
the individual objects.

Applying the Properties of a Tool to an Existing Object | 105



1 Open the tool palette that contains the tool with the properties
you want to apply to a different object.

2 Select the tool, and right-click.

3 Define the object type to which to apply the tool properties:

Then…if you want to…

click Apply Tool Properties to <Ob-
ject>. For example, to apply the

apply the properties of the tool to
an object of the same type

tool properties of a door tool to an
existing door, click Apply Tool
Properties to Door.

click Apply Tool Properties

to ➤ <Object>. For example, to

apply the properties of the tool to
an object of a different type

apply the tool properties of a door
tool to an opening, click Apply Tool

Properties to ➤ Door/Window As-
sembly, Opening, Window.

4 Select the object to which to apply the tool properties, and press
ENTER.

Re-Importing Styles for a Tool
Use this procedure to re-import the style of a tool that uses a style from an
external Styles drawing.

When you create a tool, you can assign a style from the current drawing or
from an external Styles drawing. Usually you assign a style from an external
Styles drawing because you can then use that the tool in other drawings as
well.

When the style in the external Styles drawing is changed, you need to update
the tool to reflect these changes.

NOTE When you update the style of a tool, all existing objects inserted with this
tool are also updated.

1 Open the tool palette that contains the tool for which you want
to update the style.

2 Select the tool, right-click, and click Import <Style Name> <Object
Name> Style.
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For example, if you want to update the Brick-4 Furring-4 style of
a wall tool, click Import ‘Brick-4 Furring-4’ Wall Style.

Deleting a Tool
Use this procedure to delete a tool from a tool palette.

When you delete a tool from a tool palette, objects in the drawing that were
inserted with this tool are not deleted.

NOTE If you linked a tool palette from the Content Browser to the tool palettes
set as described in Adding a Tool Palette from a Tool Catalog in the Content
Browser on page 83, you cannot delete individual tools from it. To delete the tool,
delete it from the palette in the Content Browser, and then update the palette in
AutoCAD Architecture as described in Updating a Tool Palette from a Tool Catalog
in the Content Browser on page 84.

1 Open the tool palette that contains the tool you want to delete.

2 Select the tool, right-click, and click Delete Tool.

The Properties Palette
The Properties palette provides a central location to view and modify both
the physical and graphical properties of an object you are about to draw, or
of objects that are selected in the drawing area. Using the Extended Data tab
of the Properties palette, you can also attach other kinds of information to an
object, such as classifications, notes, reference documents, hyperlinks, and
property set data. You typically keep the Properties palette open during an
AutoCAD Architecture session.
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Opening the Properties Palette
Use any of the following methods to open the Properties palette:

■ Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties.

■ Press CTRL+1.

■ Double-click an object in the drawing.

Setting the Appearance of the Properties Palette
The Properties palette is usually kept open during an AutoCAD Architecture
session, because it is the central location from which you add and change
properties of an object.
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Docking the Properties Palette
Use this procedure to dock the Properties palette on the left or right side of
your workspace.

1 In the title bar of the Properties palette, click  , and then click
Allow Docking.

2 Position the cursor over the title bar, and drag the Properties
palette to one side of your workspace.

A preview graphic shows the new position of the Properties palette.

3 Release the Properties palette at the correct location.

Hiding the Properties Palette
Use this procedure to hide the Properties palette when it is not in use. The
Properties palette can be configured to hide when you move the cursor away
from it, leaving only the title bar visible. When you move the cursor over the
title bar, the Properties palette is re-displayed.

Properties palette hidden (left) and re-displayed (right)

1 In the title bar of the Properties palette, click  (Auto-hide).

The Properties palette is hidden, except for the title bar.

2 To re-display the Properties palette, move the cursor over the title
bar.
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Adjusting the Transparency of the Properties Palette
Use this procedure to adjust the transparency of the Properties palette. The
more transparent the Properties palette, the better you can see objects in your
drawing underneath it.

NOTE Transparency is not available if hardware acceleration is enabled.

1 In the title bar of the Properties palette, click  and then click
Transparency.

2 To adjust the transparency of the Properties palette, drag the slider
towards Less or More.

3 To turn off transparency, select Turn off window transparency.

4 Click OK.

The Design Tab
Most properties of an object are entered on the Design tab of the Properties
palette.
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Design tab of a wall

Based on the object, some general object properties you can enter may include:

■ Description of the object

■ Layer key of the object

■ Layer overrides of the object

■ Object style

■ Location of object style

These properties are defined by the properties set in the tool used to create
the object. You can change these properties for an individual object instance.
For more information, see Changing the Tool Properties on page 89.

On the Design tab, you also enter object-specific design properties. The
properties that are available depend on the object you are editing.

■ Dimensions: Most objects in AutoCAD Architecture have dimension settings
for width, height, and other basic features. Many objects have additional
settings and the option to use AutoCAD QuickCalc. A wall, for example,
has additional length and baseline justification settings, and you can use
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QuickCalc to calculate and apply a new rotation. For more information,
see “Use the QuickCalc Calculator” in AutoCAD Help.

■ Location: Most objects in AutoCAD Architecture have settings for the object
location. Anchored objects like windows and doors also have Anchor
properties.

For detailed information about entering properties for a specific object, see
the individual object sections.

The Display Tab
Just as the Design tab of the Properties palette lets you control the physical
properties of an object, the Display tab lets you control the graphical properties
of an object by adjusting the settings for its individual display components,
such as boundaries and hatches. The changes you make on this tab are
immediately visible in the display representation currently in effect, such as
Plan or Model, and you have the option of applying your changes to other
display representations as well. Also, while Design tab settings apply only to
the currently selected object(s), you can specify whether a change you make
to a Display tab property will apply to the selected component for all objects
of that type, all objects of that style, or only the selected object. If the display
component is controlled by material, your changes will apply to any object
that uses that material. For detailed information on how to set up and manage
the display of objects in AutoCAD Architecture, see Display System on page
791.

NOTE To hide the Display tab (or show it if it is currently hidden), enter the
following command on the command line: AecChangeDisplayTabStatus.
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Display properties on the Display tab

The Extended Data Tab
The Extended Data tab of the Properties palette contains the following object
properties:

■ Hyperlink: You can add a hyperlink to an object. For more information,
see “Add Hyperlinks to a Drawing” in AutoCAD Help.

■ Text Notes and Reference Files: You can add a note or an associated
reference file to an object.

■ Property Sets: You can add, edit, and remove property set data for an
object. For more information, see Attaching Property Set Data to Objects
on page 3811.

■ Property Sets From Style: You can add, edit, and remove property set data
for the object style. For more information, see Property Set Data on page
3810.

■ Detail Component Data: You can add, edit, and remove detail component
data for an object. For more information, see Editing Detail Components
in a Drawing on page 3539.
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Property set data on the Extended Data tab

Worksheets
The properties of an object are entered and changed on the Properties palette.
Most properties are directly entered and immediately updated on screen. Some
objects have complex properties that are entered on worksheets accessed from
the Properties palette.

Worksheets are designed to focus on a particular object-specific task. They
display only when they are launched from a palette or from an object.
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Opening the Anchor worksheet

A worksheet is a modal dialog that must be closed before continuing to work
in the drawing.

Direct Editing with Grips and Dynamic Dimensions
You can make design changes in the workspace without using dialogs. With
a single click, you can perform design changes such as adjusting door width
and window height, modifying a wall roofline, or reversing the wall direction.
For some grips, the CTRL key gives you additional manipulation options,
which are identified in the grip tips. For example, the Width grip of a wall
can maintain either the wall baseline or the opposite face of the wall when
dragged. To switch between these options, you use the CTRL key. As you make
design changes, dynamic dimensions display, ensuring that your changes are
precise and accurate.

Direct Editing with Grips and Dynamic Dimensions | 115



Window dimension grips in Plan view and Model view

Different grips are available, depending on the object type. For example, a
wall or a freestanding railing has a direction (arrow) grip to change the
direction of the object. A railing that is attached to a stair or a structural
member does not have a direction grip.

Objects can also have different grips depending on the current view. For
example, a structural beam has an additional Roll grip in Model views that is
not visible in Plan views. Because rolling a beam is a 3D operation that you
can perform only in an isometric view, it makes no sense to display the Roll
grip in Plan views. Similarly, roof and floor line grips are useful only in a 3D
view; therefore, they are displayed only in Model views.
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Curtain wall grips in Plan view and Model view

For detailed information about the grips for AutoCAD Architecture objects,
refer to the illustrations and descriptions in the grip-editing sections of the
individual object topics.

Grip Tips
For a quick description of the function of a specific grip, you can pause the
cursor over the grip to display its grip tip. Each grip has its name displayed in
the grip tip, for example, Flip or Lengthen. In some cases, the grip tip contains
additional information about the grip’s function.
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Grip Color
The color of a grip specifies whether the grip modifies a selected object or
other objects in a drawing. Typically, a grip is used to change a property of a
selected object. However, some grips might change the properties of all other
objects in a drawing with the same style as the selected object. Other grips do
not change the selected object at all, but are used to change the grip-editing
mode of the object.

FunctionGrip Type and Default Color

changes a property of a selected objectObject (Cyan)

changes a property of a selected object and
all other objects with the same style in the
current drawing

Style (Magenta)

does not change any property of any objectAuxiliary (Gray)

You can change the color of these grips on the AEC Editor tab in the Options
dialog which is accessed from the application menu. For more information,
see Changing the AEC Editor Settings on page 197.
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Using the CTRL Key with Grips
Some object grips have multiple functions. For example, a face grip on a free
form mass element has these possible grip modes:

■ Move ortho

■ Move

■ Move plane

■ Pull ortho

■ Pull

■ Push ortho

When a grip has multiple modes, this information is displayed in the grip tip.
To switch between the different grip modes, use the CTRL key.

1 Select the object.

2 Pause the cursor over the grip, to see what grip modes are
available.

The first mode listed is the mode that will be started when you
select the grip without using the CTRL key.

3 Select the grip.

4 Press CTRL to switch to the next editing mode.

NOTE You need to press the CTRL key only once, and then release
it. This switches the grip to the next editing mode. After releasing
the CTRL key, you can start editing the grip. Do not keep pressing
CTRL while editing the grip.

Trigger Grips
Selecting a trigger grip immediately performs an action on an object, as
opposed to a normal drag grip, which you must drag to change a dimension
property. You can use trigger grips to set discrete properties of an object, such
as the swing direction of a door or the justification of a wall. You can also use
trigger grips to change the grip-edit mode of an object. For example, selecting
the Edit Grid grip in a curtain wall opens an edit in place session for the curtain
wall grid. Selecting the Edit In Place grip in an AEC dimension activates
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additional grips for the individual dimension chains, text strings, and extension
lines. A trigger grip typically displays with a circle or an arrow.

AEC dimension before and after activating edit-in-place grip

In some cases, such as with the AEC Dimension edit-in-place grip, the grip-edit
mode is exited when the object is no longer selected. In other cases, you must
click the grip again to exit the grip-edit mode.

Dynamic Dimensions
When you use grips to change the dimension or angle of an object, temporary
dimension objects show you the changes you are making. Use Dynamic Input
to enter a precise value instead of moving a grip. This is active by default, and
selecting a grip displays a text box in which you can enter the desired value

for the associated dimension or angle. Click  (Dynamic Input) on the
application status bar to toggle this off. For more information, see “Use
Dynamic Input” in AutoCAD Help.
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Using dynamic dimensions to change window width

These dynamic dimensions give you instant feedback about your changes.
You can also use the dynamic dimensions to enter new dimension values
directly on screen.
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Three types of dynamic dimensions display on grips:

■ Focal dimensions, which display highlighted in a white rectangular box.
If you type a value while a dynamic dimension is focused, the edit box is
displayed at the dimension text location.

■ Editable dimensions, which display based on the drafting settings you
specify. If you press TAB while a dynamic dimension is focused, the
dimension focus shifts forward to the next editable dimension. You can
continue pressing TAB to cycle forward through all editable dimensions,
or press SHIFT+TAB to cycle backward through all editable dimensions.

■ Non-editable dimensions, which display in black text. These dimensions
typically display the current value of a property that you can modify with
a grip.

You can apply different settings, such as the color of the dynamic dimension
text box, on the Dynamic Input tab in the Drafting Settings dialog box. For
more information, see “Use Dynamic Input” in AutoCAD Help.
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You can select the color of grips and the dynamic dimension linetype on the
AEC Editor tab in Options. For more information, see Changing the AEC Editor
Settings on page 197.

NOTE When a dimension edit box is displayed, pressing ENTER sets the value of
the property that you are editing and ends the grip operation. Pressing TAB sets
the value, changes the focused dimension, and continues the same grip-editing
operation.

NOTE When one or more editable dimensions are displayed, you can always press
TAB to a state where no dimension has focus, during which you can use normal
entry on the command line. You can always reach this non-focused state by
pressing SHIFT+TAB immediately after selecting a grip.

To enter dynamic dimensions

1 Select the grip representing the dimension you want to change.

For example, to change the length of a curtain wall, select one of
its Lengthen grips.

2 Enter the new value on screen.

Grip Constraints
When you select and drag a grip, its final position might not be the same as
the current cursor position, which might be constrained. For example, for the
Lengthen grip on a linear wall, the cursor position is projected to the nearest
point on the wall. Whenever the constrained position of a grip differs from
the current cursor position, dotted lines or arcs display between the cursor
and the grip to indicate how the grip was constrained.

A square-shaped grip typically indicates that the cursor movement is
constrained to a plane. An isosceles triangle-shaped grip indicates that the
cursor movement is constrained to a line or curve.

Temporary Grip Coordinate Systems
When you drag a grip, the current cursor position is typically projected to the
XY plane of the current User Coordinate System (UCS). Some grip-editing
operations are not possible in the current coordinate system. For example, if
the current UCS is in plan, you cannot change the height of a wall while in
an isometric view. For this reason, some grips have their own coordinate
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system that is temporarily set while the grip is active. Once the grip-editing
operation is complete, the UCS is set back to its previous state. To identify
whether a grip is setting a temporary coordinate system, set the UCSICON
system variable to On on the command line, and display the icon at the origin.

Aligning the UCS to an Object Face
Use this procedure to align the currently active UCS to the face of an object.

You can align the UCS to the face of an AEC object or to the face of an
AutoCAD solid. For detailed information about the UCS, see “Use Coordinates
and Coordinate Systems“ in AutoCAD Help. For more information about
working with objects in a temporary section, elevation, or plan view with the
UCS correctly aligned, see Editing Objects in Temporary Views on page 1135.

Aligning the UCS to a pyramid face

1 Click View tab ➤ Coordinates panel ➤ Face  .

2 Select an object face to align to the UCS.

You can select the face of an AEC object or an AutoCAD solid
here. When you move the cursor over a face, it is highlighted
with a temporary hatch.

3 Select the UCS origin point on the selected face.

4 Enter a rotation value for the new UCS.

The UCS is aligned to the object face.

Matching Object Properties
AutoCAD users are likely to be familiar with the Match Properties command
(MATCHPROP), which allows you to quickly copy properties such as layer,
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color, and linetype from one AutoCAD entity and apply them to another.
Beginning with the 2009 releases of AutoCAD Architecture and AutoCAD
MEP, you can also use this command to match style and object display
properties between AEC objects of the same type (for example, 2 different
sizes of door) or between AutoCAD MEP objects of the same type. For AEC
objects of different types (for example, a door and a window) you can use the
command to match basic AutoCAD properties. Likewise, you can match basic
AutoCAD properties between an AutoCAD entity and an AEC object.

When you match properties between style-based AEC objects, both the style
properties and the display properties of the selected source object are applied
to one or more selected destination objects. For non-style-based objects, only
display properties are matched. In either case, the display properties are applied
to all display representations of the destination object.

Object Types for Which Only Display
Properties Are Matched

Object Types for Which Both Style
and Display Properties Are Matched

3D Grid
Ceiling Grid

2D Section
AEC Dimension

Column GridAEC Polygon
Elevation LabelCurtain Wall
Layout CurveCurtain Wall Unit
Layout GridDisplay Theme
Opening RoofDoor

Door Window Assembly
Mask Block
Mass Element
Multi-View Block
Railing
Roof Slab
Schedule Table
Slab
Space
Stair
Structural Members
Wall
Window
Zone

Overrides

When you use the Match Properties command, any style or object overrides
in effect for the source object are applied to all display representations of the
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destination object. Overrides currently in effect for the destination object will
be removed if they conflict with corresponding settings for the source object.
If you want to change a setting for a particular display property in a particular
display representation, the recommended method is to use the Display tab of
the Properties palette. For more information, see Using the Properties Palette
to Change Display Properties on page 793.

To run the Match Properties command:

1 Click Home tab ➤ Modify panel ➤ Match Properties  .

The cursor changes to a paintbrush symbol.

2 Select the source object whose properties you want to copy.

3 Select one or more destination objects to which you want to apply
the properties of the source object.

Source object properties are applied to each destination object as
it is selected.

4 When finished selecting destination objects, press ENTER.

Styles and Support Files
Styles are contained in Styles drawings from which you select a style to add
to your drawing. This ensures smaller templates and a clearer structure of your
drawings. The following table shows the location of the Styles drawings and
other support files.

LocationFiles

C:\ProgramData\Autodesk\ACA 2012\enu\PlottersPlotter Configurations

C:\ProgramData\Autodesk\ACA 2012\enu\Plotters\Plot StylesPlot Styles

C:\ProgramData\Autodesk\ACA 2012\enu\AEC ContentDesignCenter Content

C:\ProgramData\Autodesk\ACA 2012\enu\DetailsDetails

C:\ProgramData\Autodesk\ACA 2012\enu\LayersLayer Standards drawing

C:\ProgramData\Autodesk\ACA 2012\enu\StylesStyles drawings
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LocationFiles

C:\ProgramData\Autodesk\ACA 2012\enu\Styles\<Imperial or
Metric>\Material Definitions.dwg

Material Definitions

C:\ProgramData\Autodesk\ACA 2012\enu\Styles\<Imperial or
Metric>\Schedule Tables.dwg

Schedule Tables

C:\ProgramData\Autodesk\ACA 2012\enu\TemplateDrawing templates

C:\ProgramData\Autodesk\ACA 2012\enu\Template\Evaluation
Templates

Area Evaluation templates

C:\Program Files\AutoCAD Architecture 2012\Sample\Sample
Palette Catalog (Imperial/Metric)

Sample Tool Palette
Catalogs

C:\Program Files\AutoCAD Architecture 2012\Catalogs\Stock-
ToolCatalog

Stock Tool Catalog

C:\Program Files\AutoCAD Architecture 2012\Catalogs\Struc-
tural

Structural Member Cata-
log

C:\My Documents\Autodesk\My Projects\Sample Project 2012Sample Drawing Manage-
ment Project

C:\Documents and Settings\<Username>\Application
Data\Autodesk\ACA 2012\enu\Support\WorkspaceCatalog
(Imperial/Metric)

Default User Workspace
Catalog

Integration of AutoCAD Architecture and AutoCAD
AutoCAD Architecture is integrated with the AutoCAD design platform. The
commands and features of both applications are blended within the user
interface. There are some differences between working in a pure AutoCAD
environment and accessing AutoCAD commands from within AutoCAD
Architecture. These differences are listed in this section.

AutoCAD Tools

■ The Properties palette is not invoked when AutoCAD tools are used to add
objects to a drawing.
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■ AutoCAD tools do not have the same tool properties as AutoCAD
Architecture tools; for example, the layer key.

■ AutoCAD Hatch tools and Block tools cannot have a user-defined tool
image.

■ The tool properties of AutoCAD tools cannot be applied to an existing
AutoCAD object in the drawing.

AutoCAD Tool Palettes

■ When working in AutoCAD, you cannot create and link AutoCAD tool
palettes from the Content Browser.

■ AutoCAD tool palettes do not support palette properties.

Other Differences

■ Properties Palette: When working in AutoCAD, you cannot set the
Properties palette to be transparent.

■ Revision clouds: The Revision cloud feature in AutoCAD is not identical
to the Revision cloud feature in AutoCAD Architecture. Revision clouds
in AutoCAD Architecture have additional scaling and layer key
functionality, as well as the option of adding a Delta symbol.

■ Units: Running the UNITS command from the command line opens the
AutoCAD Architecture Drawing Setup dialog. If you want to open the
AutoCAD Units dialog, enter ddunits on the command line.

WARNING To change the drawing setup of AutoCAD Architecture, you must
use the Drawing Setup command of AutoCAD Architecture. If you change the
units in the AutoCAD Units dialog, AutoCAD Architecture drawing units are
not affected.
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Content Browser

The Content Browser lets you store, share, and exchange AutoCAD Architecture content,
tools, and tool palettes. The Content Browser runs independently of the software, allowing
you to exchange tools and tool palettes with other Autodesk applications.

Content Browser Overview
The Content Browser is a library of tool catalogs containing tools, tool palettes,
and tool packages. You can publish catalogs so that multiple users have access
to standard tools for projects.

Tool Catalogs and Websites

AutoCAD Architecture 2012 tools and content are shared in the Content Browser
using tool catalogs and websites. A tool catalog can contain one or more of the
following items:

■ Tools: For example, you might select a tool to create a customized wall used
throughout a building project.

■ Tool palettes: These contain tools used to support a particular workflow or
task. For example, a tool palette may contain a set of annotation tools used
in a project, or a set of tools to draw each type of door used in a project. A
tool palette is treated as a single object.

■ Tool packages: These are collections of tools that users can select and use.
For example, a tool package may contain a set of productivity tools and
utilities.

A single copy of a tool catalog can be shared among users on your local area
network. If tools in the catalog are updated, you have immediate access to the
latest version of the tools.

4
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Websites containing AutoCAD Architecture tools, and content that you can
download using i-drop® technology, can also function as tool catalogs.

Several tool catalogs are provided with AutoCAD Architecture, and you can
create additional catalogs of your own.

Catalog Libraries

Tool catalogs are organized into catalog libraries, and each AutoCAD
Architecture user has a personal catalog library.

Tool catalog data is not stored in the catalog library. Rather, the catalog library
contains pointers to the physical tool catalogs. It is like the card catalog in a
real library—it tells you where to find a book, but it does not contain the book
itself.

You can sort the catalogs in the library by Last Used, Publisher, Title, or Type.
You can filter the list of catalogs by Type.

You cannot create additional catalog libraries, but you can open the personal
catalog library of another user if you are authorized to do so.

Tool Catalogs Supplied with AutoCAD Architecture
The following tool catalogs are supplied with your personal catalog library:

ContentsCatalog Name

Content tools in imperial units for design
and documentation of multi-view blocks
and symbols.

Design Tool Catalog - Imperial

Content tools in metric units for design and
documentation of multi-view blocks and
symbols.

Design Tool Catalog - Metric

Content tools in imperial units for annota-
tion and documentation.

Documentation Tool Catalog - Imperial

Content tools in metric units for annotation
and documentation.

Documentation Tool Catalog - Metric

An empty tool catalog provided so that
you can create your own tool set.

My Tool Catalog

A tool catalog containing render materials,
lights, cameras and visual styles.

Visualization Catalog

130 | Chapter 4   Content Browser



ContentsCatalog Name

A sampling of tools in imperial units for
objects such as doors, walls, and windows.

Sample Palette Catalog - Imperial

A sampling of tools in metric units for ob-
jects such as doors, walls, and windows.

Sample Palette Catalog - Metric

A catalog that contains the standard stock
tools in AutoCAD Architecture.

Stock Tool Catalog

You cannot add or remove items from the Autodesk-supplied tool catalogs,
but you can create your own tool catalogs. You can also copy other tool
catalogs and website links into your catalog library using the Publish catalog
feature.

Exploring the Content Browser
 ➤ Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .
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The Content Browser window usually is divided into two panes (web pages
displayed in the Content Browser occupy the entire window). Tool catalogs
and their contents are displayed in the right pane. When you start the Content
Browser, your personal catalog library, named <user_name>’s Catalog Library,
displays in the right pane. The left pane is used for navigation, searching for
tools, sorting catalogs, and filtering catalog display. The buttons at the top of
the left pane work much like the equivalent controls in a web browser. Click

 to display the top level of the catalog library in the right pane. This view
is either all the catalogs in the library, or a group of catalogs filtered by type.

You can have more than one instance of the Content Browser open at a time.
To open an additional Content Browser window, press CTRL+N. For more
information, see Working with Multiple Content Browser Windows on page
173.

Viewing a Tool Catalog
To view a tool catalog, click the catalog in the catalog library. For example,
click the Stock Tool catalog to display a window like the following illustration:

View of the Stock Tool catalog
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When you open the Stock Tool catalog, a cover page describing the catalog is
displayed in the right pane. If no cover page is defined for a tool catalog, items
contained in the tool catalog are displayed in the right pane. For information
about specifying a cover page, see Editing Tool Catalog Properties on page 150.

To continue past the cover page to the contents of the tool catalog, click the
catalog name in the left pane of the Content Browser window.

The contents of a tool catalog can be organized into categories. When a tool
catalog is open in the right pane, any categories are listed in the left pane. For
example, the Stock Tool catalog is organized into the categories shown in the
previous illustration.

Categories can be subdivided into one or more levels. If subcategories exist,
a list of subcategories appears when you move the pointer over the category
name in the left pane. For example, in the Stock Tool catalog, move the pointer
over Modeling Tools to see the Mass Element Tools and 3D Solids subcategories.

Displaying subcategories in a category

To open a category or subcategory, click it. For example, click Mass Element
Tools to display the following window:
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Mass Element Tools category of the Stock Tool catalog

Associated with each item in the tool catalog is the following i-drop® icon:

 .

You click the i-drop icon to drag a tool or other tool catalog item into the
AutoCAD Architecture 2012 workspace or into another catalog, tool palette,
or tool package.

You can modify the contents and properties of a tool catalog if you are
authorized to do so, unless the catalog is read-only. Read-only tool catalogs
are identified in the Content Browser title bar when you open the catalog.

A tool catalog category may contain more items than can fit on a page. If
multiple pages are needed, navigation controls appear at the top and bottom
of each page. The Mass Element Tools category shown earlier requires two
pages to display its contents. You can specify the page to be displayed by
clicking the page number or by clicking Next or Prev. (Note that these controls
appear at the bottom of the page too.) You can also change the number of
items that display on a Content Browser page.

Specifying the Number of Rows on a Content Browser Page
Use this procedure to specify the number of rows that display on a Content
Browser page.
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1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Click  to display the catalog library.

3 Click  to display the Content Browser Preferences dialog box.

4 In the Content Browser Preferences dialog box, enter the number
of rows to be displayed on each page. You can specify up to 100
rows, and you must specify at least 5.

5 Click OK.

Using the Items in a Tool Catalog
To use a tool catalog item in AutoCAD Architecture 2012, drag the item into
the software’s workspace. Dragging a tool palette into the workspace adds the
tool palette to the default tool palette set.
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AutoCAD Architecture 2012 tool palette set, with added tool palette

Once added to the tool palette set, the palette remains a part of the set and is
available each time you start AutoCAD Architecture.

You can drag a tool directly into the drawing area from the Content Browser.
For example, with the Mass Element Tools category open in the Stock Tool
Catalog, drag the Arch tool into the drawing area with the i-drop® icon to
begin adding an Arch mass element to your drawing.

If you use a tool frequently, you will save time if you add the tool to a palette
in the tool palette set, where you can access it without using the Content
Browser.

Managing Your Catalog Library
You manage your catalog library by adding and deleting tool catalogs and
website links and by setting catalog properties as needed. You can create a
new catalog or customize existing ones to meet your needs. You can reorganize
tool catalogs by moving and copying items among them.
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Creating a New Tool Catalog
Use this procedure to create a new tool catalog in your catalog library.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Click  to display the catalog library.

3 Click  to create a catalog.

4 In the Add Catalog dialog box, select Create a new catalog.

5 Enter a name for your tool catalog.

Tool catalog names can include spaces and can contain any
characters except the following:\ / : * ? " < > |

NOTE The full path name of the catalog file cannot exceed 255
characters, so be careful about using long catalog names.

The name you assign is used for both the file containing the
catalog definition and the folder containing the catalog’s contents.
The name is also used in the title identifying the tool catalog in
the catalog library. You can change the title displayed in the
catalog library without affecting the file and folder name. For
information about changing the title, see Editing Tool Catalog
Properties on page 150.

6 Identify the folder in which to store your tool catalog:

Then…If you want to…

click OK.store the tool catalog in the default
location

click Browse, select the folder in
which to store the catalog, and
then click OK.

store the tool catalog in a different
location
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The tool catalog is displayed in the catalog library with the following default

graphic image:  . For information about changing the graphic image
and other tool catalog properties, see Editing Tool Catalog Properties on page
150.

Creating a Tool Catalog from Content Drawings
Use this procedure to create a new tool catalog based on existing standards
from the styles in one or more drawings. You specify the styles from which
tools will be created and whether the new tools are organized in categories or
palettes. Note that Content Browser does not have to be open to create a tool
catalog.

WARNING Converting large numbers of tools can slow down your computer
considerably. Depending on your processor and amount of RAM, the conversion
process can take a long time and the application may appear to be non-responsive.
To avoid this, do not convert more than 3000 tools in one Tool Catalog Generator
session. Instead, break up the source drawings, and use multiple instances of Tool
Catalog Generator to achieve the conversion.
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1 Click Manage tab ➤ Customization panel ➤  ➤ Generate Tool

Catalog  .

2 Under Catalog, select Create New Catalog.

3 Enter a name for the new catalog.

4 Click Browse to define the location of the catalog.

By default, a new catalog is saved in C:\My Documents.

5 Under Content Source, specify whether you want the new catalog
to be created from multiple drawings in a folder or from a single
drawing. Then, enter the path for the folder or drawing.

NOTE When you specify a folder as the catalog source, any nested
folders are included in the new tool catalog.

6 Under Tool Organization, specify how you want the tools
organized in the new catalog.

■ To organize the new tools by their source drawing, select Group
tools by source drawing.
This option is well suited for a tool catalog that is generated
from a number of styles drawings. The resulting tools could
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be placed in categories or palettes named “Wall Styles -
Concrete (Imperial)”, “Wall Styles - Brick (Imperial),” etc.

■ To organize the new tools by their object type, select Group
tools by object type.
This option is well suited if you want to merge styles from
various drawings into palettes or categories. The resulting tools
will be placed in categories or palettes named “Walls”, “Doors,”
etc.

NOTE If both options are enabled, the catalog is first grouped
by the drawings and then by the object type, generating
categories from the drawings, and palettes from the object types.
This is implemented because palettes cannot be nested. In this
case the radio buttons for categories and palettes are disabled,
and the Create tools in palettes option is selected for the catalog.

NOTE If neither of the two options is enabled, all new tools will
be generated in the top category of the catalog.

■ To organize the new tools in categories, select Create Tools in
Categories.
If you select Group tools by source drawing, a category will be
created for each source drawing. If you select Group tools by
object type, a category will be created for each object type.

■ To organize the new tools in palettes, select Create Tools in
Palettes.
If you have selected to group tools by their source drawing,
then for each source drawing a palette will be created. If you
have selected to group tools by their object type, then for each
object type a palette will be created.

7 Under Create tools for the following objects, select the object
styles you want to appear as tools in the new catalog.

By default, all available style types are selected. Use the Select All
and Clear All buttons as necessary.

8 Click OK.

A progress bar in the application status bar informs you of the
progress of the catalog generation. This can take a few moments
for a large catalog.
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NOTE Each category and each palette is created in its own ATC file.
The category and palette ATC files are stored in the Palettes or
Categories subfolders within the folder where the new catalog is
created.

After creating a new catalog, you can add it to your Content
Browser library, as described in Adding an Existing Tool Catalog
to Your Catalog Library on page 144.

Adding Tools from Content Drawings to a Tool Catalog
Use this procedure to add tools from one or more drawings to an existing
catalog.

WARNING Converting large numbers of tools can slow down your computer
considerably. Depending on your processor and amount of RAM, the conversion
process can take a long time and the application may appear to be non-responsive.
To avoid this, do not convert more than 3000 tools in one Tool Catalog Generator
session. Instead, break up the source drawings, and use multiple instances of Tool
Catalog Generator to achieve the conversion.
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1 Click Manage tab ➤ Customization panel ➤  ➤ Generate Tool

Catalog  .

2 Under Catalog, select Add to an existing catalog.

3 Enter the name and the path of the catalog.

4 Click Append to Catalog and select Ignore Duplicate Styles if you
want existing styles from being overwritten by styles with the
same name and file path from the appended drawing.

If you clear Ignore Duplicate Styles, existing styles are overwritten
with styles from the appended drawing if they have the same
name and file path.

5 If you want to overwrite the existing catalog, click Overwrite
Catalog.

This deletes the whole catalog and replaces it with the palettes,
categories, and tools from the source drawing(s).
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WARNING You should use that option with great caution, as it will
delete the complete existing catalog. If you just want to overwrite
tools with their up-to-date versions from a content drawing, select
Append to Catalog instead, and verify that Ignore Duplicate Styles is
cleared.

6 Under Content Source, select a project standards drawing or
standards folder to use as source for the new tools.

Then…If you want to…

select Create from drawings in folder, and
then enter the path and folder name under
Type the source location.

add tools from multiple
drawings in a folder

select Create from drawing, and then enter
the path and drawing name under Type the
source drawing.

add tools from a single
drawing

7 Under Tool Organization, specify how the tools should be
organized in the catalog.

■ To organize the resulting tools by their source drawing, select
Group tools by source drawing.
This option is well suited for a tool catalog that is generated
from a number of styles drawings. The resulting tools could
be placed in categories or palettes named “Wall Styles -
Concrete (Imperial),” “Wall Styles - CMU (Imperial),” etc.

■ To organize the resulting tools by their object type, select
Group tools by object type.
This option is well suited if you want to merge styles from
various drawings into a new catalog. The resulting tools will
be placed in categories or palettes named “Walls,” Doors,” etc.

NOTE If both options are enabled, then the tools are first grouped
by the drawings and then by the object type, generating
categories from the drawings, and palettes from the object types.
This is implemented because palettes cannot be nested. In this
case the radio buttons below are disabled and the Create tools
in palettes option is selected for the tools.

NOTE If neither of the two options are enabled, all new tools will
be generated in the top category of the catalog.
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■ To organize the new tools in categories, select Create Tools in
Categories.
If you have selected to group tools by their source drawing,
then for each source drawing a category will be created. If you
have selected to group tools by their object type, then for each
object type a category will be created.

■ To organize the new tools in palettes, select Create Tools in
Palettes.
If you have selected to group tools by their source drawing,
then for each source drawing a palette will be created. If you
have selected to group tools by their object type, then for each
object type a palette will be created.

8 Under Create tools for the following objects, select which object
styles should appear as tools in the catalog.

By default, all available style types are selected. Use the Select All
and Clear All buttons as needed to make your selections.

9 Click OK.

A progress bar in the application status bar indicates the progress
of the tool generation. When a large number of tools are being
added, the process can take a few moments.

NOTE Each category and each palette is created in its own ATC file.
The category and palette ATC files are stored in the Palettes or
Categories subfolders in the folder in which the new catalog is created.

Adding an Existing Tool Catalog to Your Catalog Library
Use this procedure to add an existing tool catalog to your catalog library.

Adding a tool catalog to a catalog library does not physically move or copy
any files. Instead, a pointer to the catalog’s location is added to the catalog
library. If you add a tool catalog that resides on another computer, and then
a tool in that catalog is updated, you always reference the latest version of the
tool in the catalog library.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Click  to display the catalog library.

144 | Chapter 4   Content Browser



3 Click  to create a catalog.

4 In the Add Catalog dialog box, select Add an existing catalog or
website.

5 Enter the location of the tool catalog you want to add, or click
Browse and select a catalog.

Tool catalog files typically have the extension .atc.

6 Click OK.

NOTE Alternatively, you can drag and drop an ATC file from Windows
Explorer to the Content Browser library pane.

Creating a Catalog Install File
Use this procedure to create a registry file that adds catalogs to other users’
Content Browser libraries.

When you add a catalog in Content Browser, it is automatically added to your
Content Browser library (CBL). However, as a CAD manager, you might also
want to automatically install new catalogs into other user’s libraries. In that
case, you can either add a pointer to a catalog in an existing registry file, or
create a new registry file that adds that catalog to the user’s library.

Creating a catalog install file

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Select the catalog that you want to add to a registry file.

When you add a catalog to a registry file, make sure that the
network location of the catalog and all its affiliated files can be
accessed by all users to whom you want the catalog distributed.

3 Shift-Rightclick the catalog.
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4 Click Convert to Registry File.

Then…If you want to…

browse to the desired folder location,
enter a name for the registry file, and
click Open.
In that case, a new registry file (REG) is
created, containing the registry informa-
tion for the selected catalog.

create a new registry file for
the catalog

browse for the registry file, select it and
click Open.
In that case, an entry containing the re-
gistry information for the selected cata-
log is appended to the registry file.

enter the catalog into an exist-
ing registry file

NOTE When you select an existing registry file, the file is not
overwritten, as in standard Windows Save dialogs; the catalog entry
is simply added to the registry file. If you want to overwrite an existing
registry file, you need to delete it from Windows Explorer, and then
create a new one of the same name.

Entering a catalog in a users’ library

5 To enter the catalog reference into the local registry, and thereby
into the user’s catalog library (CBL), run the new registry file.

6 Either place the generated REG file on a generally accessible
network folder, or copy it to the local user machine where the
catalog should be entered.

7 Double-click the REG file on the user’s computer.

8 Click Yes when asked whether you want to add the information
into the local registry.

The catalog is entered into the users’ registry and catalog library.

Publishing Tool Catalogs
The Publish Catalog feature helps you make tool catalogs available for use by
multiple users on a network. You can move and copy catalogs or make them
available from their current location. The feature handles dependent file paths
during the publish catalog operation.
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1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Right-click the tool catalog you want to publish, and click Publish
<catalog_name>.

3 In the Publish Tool Catalog - Step 1 of 4 dialog box, do one of the
following:

Then…If you want to…

click Move it to a new location.move the catalog to a new location
when publishing it

click Copy to another location.copy the catalog to a different loca-
tion

click Leave it in its current location.publish the catalog from its current
location

4 Click Next.

If you are moving or copying the catalog, you are prompted to
specify the destination location.

5 In the Publish Tool Catalog - Step 2 of 4 dialog box, specify the
destination for the tool catalog.

You can enter a path, or click [...] to navigate to the destination
location. You can specify an existing location or create a new
folder.

6 Click Next.

7 In the Publish Tool Catalog - Step 3 of 4 dialog box, specify the
location for any dependent files.

You can enter a path, or click [...] to navigate to the destination
location. You can specify an existing location or create a new
folder.

Dependent files contain information referenced by the tools; for
example, style information. If you select the option Automatically
move (or copy) tool dependent files into the above folder to be
referenced by the publish catalog, the feature attempts to copy
all of the dependent files referenced in the catalog to the
dependent file location you specify. If you do not select this
option, you must verify that the files are already present in the
dependent location. If you select the option Report invalid catalog
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references, the feature generates a report of any dependent files
it cannot locate.

8 To have the publish catalog feature move (or copy) dependent
files, click Automatically move (or copy) tool dependent files into
the above folder to be referenced by the publish catalog.

9 Click Report invalid catalog references to generate an HTML file
containing any dependent files that were not found, and then
click Next.

10 In the Publish Tool Catalog - Step 4 of 4 dialog box, do one of the
following:

Then…If users will…

Click Directly from the location
provided.

access the catalog directly from the
network location you specify

Click From an http:// site or
mapped drive, and enter the loca-
tion name.

access the catalog from an alternate
or aliased location

11 To make the catalog read-only, select Set items in catalog to be
read-only.

12 To prevent catalog items from refreshing when they are dropped
in the workspace, select Set items in catalog to not be refreshable
when drag/dropped into the workspace, and click Finish.

Individual users can specify the location of dependent files, such as styles for
tools, on the AEC Content tab in the Options dialog box. The variable
%AECCONTENT_DIR% is used for tool-dependent file references. This variable
is updated to use the path specified. For example, <Style
href=”%AECCONTENT_DIR%\<DoorStyles\DoorStyles.dwg”/>. For more
information, see Changing the AEC Content Settings on page 201.

Adding a Website to Your Catalog Library
Use this procedure to add a website link to your catalog library. Links are
useful for websites containing AutoCAD Architecture 2012 tools and content
that you can download using i-drop® technology.

You can also add a website link by dragging the URL from the Address bar of
Internet Explorer into the Content Browser window.
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1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Click  to display the catalog library.

3 Click  to create a catalog.

4 In the Add Catalog dialog box, select Add an existing catalog or
website.

5 Enter the location of the website to link:

Then…If you want to…

enter the URL of the website, includ-
ing the http:// prefix.

TIP Here is the easiest way to
specify a URL: 1. Open a web
browser, such as Internet Ex-
plorer. 2. Open the web page
you want to link to. 3. Copy the
URL from your browser’s ad-
dress bar. 4. Paste the URL into
the Add Catalog dialog box.

link to a website on the Internet or
on an intranet

enter the file name, or click Browse
and select the file you want to link
to.

link to a web page in an HTML file
on your computer or on your net-
work

6 Click OK.

The link to the website is represented in the catalog library by a default graphic
image, which you can change. For information about changing this image
and other Tool Catalog properties, see Editing Tool Catalog Properties on page
150.

Opening Web Pages in the Content Browser
Use this procedure to open a web page through a website link in your catalog
library.
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TIP If you have any problem viewing a web page in the Content Browser window,
try opening the page in Internet Explorer.

■ Move your pointer over the website link you want to open, and do one of
the following:

Then…If you want to…

click the link.view the web page in the Content Browser
window

right-click the link, and click Open in New
Window.

view the web page in a new Content
Browser window

right-click the link, and click Open With
Internet Explorer.

view the web page in a new Internet Ex-
plorer window

Editing Tool Catalog Properties
Use this procedure to view and modify the properties of a tool catalog. If you
have write access to the tool catalog, you can select a different source file or
target, and you can change the cover page.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Right-click the desired tool catalog, and click Properties.

3 Edit the properties:

Then…If you want to…

click the image in the Properties
dialog box, and then select a

change the graphic image that
represents the tool catalog in the
catalog library graphic file to use. You can use a

BMP, JPEG, PNG, or TIFF file for
your graphic. The graphic image is
displayed at 90 × 120 pixels. If you
specify an image of a different size,
the image is scaled to fit.
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Then…If you want to…

NOTE The graphic file you se-
lect is copied into the tool
catalog’s image folder.

enter a new title. You can also right-
click the catalog and click Rename
<catalog_name>.

change the title displayed beneath
the tool catalog’s graphic image in
the catalog library

enter a new description.change the descriptive text that
displays when you move the pointer
over the tool catalog’s graphic im-
age

enter the new file in File or Target,
or click Browse to select a tool
catalog file.

change the tool catalog file or
website

enter the new HTML file in Cover
Page, or click Browse to select a
cover page.

change or specify the HTML file that
displays when the tool catalog is
opened

enter a new publisher name.change the publisher of the tool
catalog

select a type from the Type list. For
information on assigning types to

change the type designation for the
catalog

catalogs, see Creating Catalog
Types on page 152.

select Link items when added to
workspace. For information on

define that tools and palettes from
this catalog should be automatically

linking tools to the Contentlinked to the Content Browser when
Browser, see Using Tool Catalogdropped onto the tool palettes set

of AutoCAD Architecture 2012 Items in AutoCAD Architecture on
page 167 and Working with Tools
from a Central Location on page
101.

clear Link items when added to
workspace. Inserting tools without

define that tools and palettes from
this catalog should not retain a link

retaining a link to Content Browserto the Content Browser when
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Then…If you want to…

dropped onto the tool palettes set
of AutoCAD Architecture 2012

would be the right choice if you
want to make changes to a tool in
AutoCAD Architecture that should
not overwritten by the tool proper-
ties in Content Browser; also, un-
linked tools create a better general
performance in AutoCAD Architec-
ture 2012.

4 Click OK.

Creating Catalog Types
Use this procedure to create catalog types. You can assign a type property to
a catalog and then sort and filter your catalogs by type.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Click  to display the catalog library.

3 Click  to display the Content Browser Preferences dialog box.

4 In the Catalog Types area, under New Catalog Type, enter the
name of the type you want to create.

5 Click OK.

6 The new type is added to the list of available types. You can now
assign this type to catalogs by editing their properties. Once the
type is assigned to a catalog, you can sort or filter the display of
catalogs in the Library View by this type.

7 To remove a type, click the type name and click Remove.

NOTE The Type catalog property is cleared for any catalogs associated
with this type.
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Sorting Catalogs in the Library View
Use this procedure to sort the display of catalogs by last-used date, publisher,
title, or type.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Click  to display the catalog library.

3 With the catalog library open in the right pane of the Content
Browser, position the pointer over Sort in the left pane.

4 From the list of available sort options, click the method you want
to use to sort catalogs in the library.

Then…If you want to…

click By Last Used.sort chronologically by when you
last used each catalog

click By Publisher. If the catalog
does not have a publisher property,

sort alphabetically by the publisher
name of each catalog, and then by
title the catalog appears at the bottom

of the display.

click By Title.sort alphabetically by catalog title

click By Type. If the catalog does
not have a type assigned, the cata-

sort by catalog type

log appears at the bottom of the
display.

Filtering Catalogs in the Library View
Use this procedure to filter the display of catalogs in the Library View.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Click  to display the catalog library.

3 With the catalog library open in the right pane of the Content
Browser, position the pointer over Filter in the left pane.
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4 From the list of available types, click the type of catalog you want
to view.

To display all the catalogs in the library, click All Catalogs.

NOTE To filter catalogs by Type, you must assign a type to each catalog in the
library. For more information, see Creating Catalog Types on page 152.

Removing a Tool Catalog or Website Link
Use this procedure to remove a tool catalog or website link from your catalog
library.

When you remove a tool catalog or website link, only a pointer to the item
is removed; no files or web pages are physically deleted.

1 With the catalog library open in the right pane of the Content
Browser, right-click the tool catalog or website link to delete, and
click Remove <catalog_name> from Library.

2 When prompted, click Yes to confirm deletion, or click No to
cancel deletion.

Opening a Different Catalog Library
Use this procedure to open a catalog library other than your personal catalog
library, or to reopen your personal catalog library.

A catalog library is stored in a file having the extension .cbl. The default file
name for your personal catalog library is ContentBrowserLibrary.cbl; it is stored
in the folder C:\My Documents\Autodesk\My Content Browser Library\ACA 2012.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Click  to display the current open catalog library.

3 Right-click the catalog library name, and click Open New Library.

4 In the Open dialog box, select the catalog library that you want
to open.
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Renaming a Catalog Library
Use this procedure to rename the currently open catalog library. The name
change affects the title of the catalog library displayed in the Content Browser,
but no files are renamed.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Click  to display the catalog library.

3 Click  to display the Content Browser Preferences dialog box.

4 Under Library Name, enter the new library name.

5 Click OK.

Searching for Items in a Tool Catalog
You can use the Search feature to help you find a particular tool. You can
search across multiple catalogs or search a particular tool catalog, tool palette,
or tool package. For example, if you are looking for a tool to help you create
a 3D desk, you could search on the keywords 3D desk. The search applies to
all the catalogs currently displayed (filtered). Narrow the search by filtering
the catalog display.

The Search feature looks at the text in the following properties of tool catalog
items for the keywords you specify:

■ Name

■ Description

■ Keywords

The Search tool is only as helpful as the tool names and descriptions that you
assign. A tool name should indicate the tool’s function, and the description
should indicate the tool’s use.

If you enter a search term containing more than one word, the Search feature
looks for items containing both words. You can also join multiple search words
with AND, &, or +. To retrieve items containing any of the search words, enter
OR or | between search terms. To exclude a word from the search, precede the
word with !. Use * as a wild-card string and ? as a wild-card character. Search
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is not case sensitive by default. To use a particular case in a search, surround
the word in quotes.

Search results are displayed in the right pane of the Content Browser window.
The following illustration shows the results of a search on the term 3D desk
in the Content catalogs group:

The search term and the number of items found are listed on the line below
the tool catalog name. If multiple pages are returned, you can specify the page
to display by clicking the page number or by clicking Next or Prev.

Performing a Search
Use this procedure to search across multiple catalogs or to search all or part
of a tool catalog.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Filter the library to display the catalogs you want to search:

Then…If you want to…

display the catalog library and then
filter the display to include the
catalogs you want to search.

search for tools across multiple
catalogs

open the tool catalog you want to
search.

search for tools only within a specif-
ic catalog

open the category you want to
search, and select the box labeled
in <category name>.

search for tools only within a specif-
ic category and its subcategories
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Then…If you want to…

open the tool palette you want to
search, and select the box labeled
in <palette name>.

search for tools only on a specific
tool palette

leave the box under the search term
clear.

search for tools anywhere in the
open catalog

3 Enter the terms to search for under Search.

4 Click GO.

Items that match your search criteria are displayed in the right
pane of the Content Browser. To go to the catalog containing an
item, click that item. To view the source catalog of an item,
right-click the item.

5 To perform another search, click the  button located near the
top of the left pane.

Adding Content to a Tool Catalog
Tool catalogs can contain tools, tool palettes, and tool packages, which may
be organized into categories.

Categorizing the Items in a Tool Catalog
You can define categories and subcategories in a tool catalog to organize a
large number of items. For example, the Stock Tool catalog contains dozens
of tools. If these tools were not grouped into categories, you would have to
scroll through page after page to find a particular tool. To make it easier to
find tools, the Stock Tool catalog is organized into categories and subcategories,
as shown in the following diagram:

ContentsCategory Name

Architectural Object Tools ■ Wall, Curtain Wall, and Curtain Wall
Unit

■ Opening, Door, Window, and
Door/Window Assembly

■ Roof, Roof Slab and Slab

■ Ceiling Grid
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ContentsCategory Name

■ Stair, Stair Tower, and Railing

■ Space and Space Boundary

■ Structural Members and Column Grid

Drafting Tools ■ AEC Dimensions

■ Callouts and Title Mark

■ Text, Leaders, Keynotes, Legend

■ Masking Block

■ Hatching and Gradient

■ Chamfer and Fillet

■ Shrink Wrap Tool

■ Welding Symbols

Helper Tools ■ AEC Entity Reference

■ AEC Polygon

■ Camera

■ Horizontal and Vertical Design Sections

■ Hidden Line Removal Tool and Napkin
Sketch

Measurement Tools ■ Area, Distance, and Point ID

Mass Element Tools:Modeling Tools

■ Box, Arch, Pyramid, Extrusion, and so
on

■ Mass Group

■ Convert to Mass Elements

3D Solids Tools:

■ 3D Solid Box, Cylinder, Convert to 3D
Solids
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ContentsCategory Name

Parametric Layout and Anchoring Tools ■ Layout Curve

■ Layout Grid (2D and 3D)

■ Object Anchor, Node Anchor, Cell An-
chor, Volume Anchor

Scheduling and Reporting Tools ■ Space Evaluation

■ Display Theme

■ Tag Tool

■ Schedule Table

■ Property Data Browse and Renumber
Tools

About Tool Palettes

A tool palette is a collection of tools used to support a task. For example, a
palette might contain tools to create the different types of doors (single-hinged,
double-hinged, revolving, and so on) used in a building project. Storing a tool
palette in a tool catalog makes the palette available to multiple users.

The date and time at which the tool palette was created and last modified are
identified in the Tool Palette Properties dialog box. To view the dialog box,
right-click the tool palette, and click Properties. For information about other
tool palette properties, see Adding a Tool Palette to a Tool Catalog on page
160.

About Tool Packages

A tool package is a group of tools stored together for distribution. For example,
a package might contain a set of productivity tools and utilities.

The date and time at which the tool package was created and last modified
are identified in the Tool Package Properties dialog box. To view the dialog
box, right-click the tool package, and click Properties. For information about
other tool package properties, see Adding a Tool Package to a Tool Catalog on
page 161.
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Customizing Tools

You customize a tool by copying it to a palette in the AutoCAD Architecture
2012 tool palette set, modifying the tool’s properties, and then copying it
back to its original location in the tool catalog.

Defining Categories in a Tool Catalog
Use this procedure to define categories and subcategories in a tool catalog.

Categories are listed in the left pane of the Content Browser, below the name
of the open tool catalog.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Open the tool catalog in which to define categories.

3 Select the location for the new category:

Then…If the tool catalog…

in the left pane of the Content
Browser, navigate to the desired

already has one or more categories
defined and you want to add a
subcategory category, and click the category

name.

in the left pane of the Content
Browser, click the catalog name.

is not currently divided into categor-
ies and is open to a cover page

do nothing; this is where you define
your first category.

is not currently divided into categor-
ies and the content page is dis-
played

4 In the right pane of the Content Browser window, right-click a
blank area, and click Add Category.

5 Enter a name for the category, and click OK.

6 To define additional categories and subcategories, continue from
step 2.

Adding a Tool Palette to a Tool Catalog
Use this procedure to add a tool palette to a tool catalog. You must have write
access to the tool catalog in order to add a palette.
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You can also drag a tool palette from the AutoCAD Architecture 2012
workspace into a tool catalog. Click the tab of the tool palette to drag it.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Open the tool catalog in which to add the tool palette.

To add the palette to a specific category in the catalog, open that
category.

If no graphics appear at the bottom of the left pane, the tool
catalog is read-only, and you cannot add a tool palette.

3 Click  in the left pane of the Content Browser.

4 In the Tool Palette Properties dialog box, enter a name for the
tool palette, and enter any other desired properties:

Then…If you want to…

enter a description.add a description to be displayed
in the tool catalog and queried in
catalog search operations

enter the terms for keywords.define terms that will be found
during a search of the tool catalog

enter a publisher.identify the publisher of the tool
palette

Adding a Tool Package to a Tool Catalog
Use this procedure to add a tool package to a tool catalog. You must have
write access to the tool catalog in order to add a package.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Open the tool catalog in which to add the tool package.

To add the package to a specific category in the catalog, open that
category.
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3 Click  in the left pane of the Content Browser.

4 In the Package Properties dialog box, enter a name for the tool
package, and enter any other desired properties:

Then…If you want to…

enter a description.add a description to be displayed
in the tool catalog and queried in
catalog search operations

enter the terms for keywords.define terms that will be found
during a search of the tool package

enter a publisher.identify the publisher of the tool
package

If the tool catalog is read-only, the Package Properties dialog box
is displayed, but you cannot enter anything in it.

Adding Tools to a Tool Catalog
Use this procedure to add a tool to a tool catalog or to a tool palette or tool
package stored in a catalog. You must have write access to the tool catalog in
order to add a tool to it.

You can also drag a tool from a tool palette in the AutoCAD Architecture 2012
workspace to a tool catalog in the Content Browser.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Open the tool catalog in which to add a tool.

If you are adding the tool to a specific category in the catalog or
to a palette or package in a specific category, open that category.

3 Double click the image to open the palette or package if you are
adding the tool to a tool palette or tool package.

4 In the AutoCAD Architecture 2012 workspace, open the tool
palette that contains the tool to add to the tool catalog.

5 Right-click the tool, and click Copy.
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6 In the right pane of the Content Browser window, right-click in
a blank area, and click Paste.

NOTE If there is no Paste option on the shortcut menu, then the
pointer is probably positioned over a tool, even though the space
may appear to be blank. Move the pointer and try again.

Copying and Moving Tool Palettes and Tool Packages
Use this procedure to copy or move tool palettes or tool packages between
tool catalogs or between categories in the same catalog. To copy an item, you
must have write access to the catalog you are copying to. To move an item,
you must have write access to both the catalog you are copying from and the
catalog you are copying to.

You can also open multiple Content Browser windows and drag tool palettes
and tool packages from one window to another. For information about using
multiple windows to copy and move items, see Dragging Catalog Items Between
Content Browser Windows on page 175.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Open the tool catalog containing the tool palette or tool package
to copy or move. If the item is located in a specific category of
the catalog, open that category.

3 Right-click the item, and select an action:

Then…If you want to…

click Copy.add a copy of the tool palette or
tool package in another location

click Cut.move the tool palette or tool pack-
age to another location, deleting it
from its original location

4 Select the item’s destination:

Then…If the destination is…

click that category in the left pane
of the Content Browser window.

a category within the current tool
catalog
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Then…If the destination is…

click  to return to the catalog
library, and then click the tool
catalog.

another tool catalog

click  to return to the catalog
library, click the tool catalog you

a category in another tool catalog

are copying to, and then select its
category in the left pane of the
Content Browser window.

5 In the right pane of the Content Browser window, right-click in
a blank area, and click Paste.

NOTE If there is no Paste option on the shortcut menu, then the
pointer is probably positioned over a catalog item, even though the
space may appear to be blank. Move the pointer and try again.

Copying and Moving Tools
Use this procedure to copy or move tools between tool palettes, tool packages,
or tool catalogs.

You can also open multiple Content Browser windows and drag items from
one window to another. For information about using multiple windows to
copy and move items, see Working with Multiple Content Browser Windows
on page 173.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Open the tool catalog containing the tool to copy or move.

3 Open the item containing the tool to copy or move:

Then…If the tool is in…

open the category.a category of the tool catalog
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Then…If the tool is in…

open the category for that tool
palette, if necessary, and then click
the tool palette.

a tool palette in the tool catalog

open the category for that tool
package, if necessary, and then click
the tool package.

a tool package in the tool catalog

4 Right-click the tool, and select an action:

Then…If you want to…

click Copy.add a copy of the tool in another
location

click Cut.move the tool to another location,
deleting it from its original location

5 If the destination of the tool is in a different tool catalog, click

 to return to the catalog library, and then click the tool catalog
to open it.

6 Open the destination of the tool:

Then…If the destination is…

open the category.a category of the tool catalog

open the category for that tool
palette, if necessary, and then click
the tool palette.

a tool palette in the tool catalog

open the category for that tool
package, if necessary, and then click
the tool package.

a tool package in the tool catalog

7 In the right pane of the Content Browser window, right-click in
a blank area, and click Paste.

NOTE If there is no Paste option on the shortcut menu, then the
pointer is probably positioned over a catalog item, even though the
space may appear to be blank. Move the pointer and try again.
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Customizing a Tool
Use this procedure to modify a tool that is stored in a tool catalog.

When you begin this procedure, both the AutoCAD Architecture tool palette
set and the Content Browser window should be visible, so that you can drag
items between them.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Open the tool catalog that contains the tool to customize. If the
tool is located in a specific category of the catalog, open that
category.

3 Move the pointer over the i-drop® icon next to the tool you want,

so that the pointer image changes to an eyedropper (  ).

4 Click the eyedropper and drag it to a palette in the tool palette
set.

If the tool palette does not accept the tool, it might be because
the palette is set to allow updates only from a linked tool palette
in a tool catalog. To check this, right-click on the palette, click
Properties, and look at the Refresh from setting. If Refresh from
is selected, the palette is linked to a palette in a tool catalog. To
break the link, clear Refresh from. For more information about
linked tool palettes, see Using the Items in a Tool Catalog on page
135.

5 Right-click the copy of the tool in the tool palette set, and click
Properties.

6 In the Tool Properties worksheet, clear Refresh from.

If Refresh from is selected, the tool is linked to its source in the
tool catalog and can be updated only from the source tool.

7 Make any property changes, and then click OK.

8 Drag the tool from the tool palette set back to its original location
in the Content Browser.

TIP Right-click the title bar of the Autodesk Content Browser, and
select Always on Top before dragging the tool to the Content Browser.

9 When prompted to confirm catalog item replacement, click Yes.
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Deleting Tool Catalog Items
Use this procedure to delete a tool palette, tool package, or tool in a tool
catalog. You must have write access to the tool catalog in order to delete items.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Open the tool catalog containing the item to delete. If the item
is located in a specific category of the catalog, open the category.

3 Right-click the item, and click Delete.

4 When prompted, click Yes to delete the item, or click No to cancel
deletion.

Using Tool Catalog Items
Tools from catalogs can be used immediately in the drawing area or stored in
a palette in the tool palette set. You can add a catalog tool palette or tools in
a tool package to the tool palette set.

TIP To keep the Content Browser window in view while other applications are
active, right-click the title bar of the Autodesk Content Browser, and select Always
on Top.

Linked and Unlinked Tool Catalog Items
When you copy a tool or tool palette from the Content Browser to the tool
palette set, you can choose whether the copy retains its association with the
original. Linking the copy to the original means that, if you copy the item
back to its original location, the Content Browser assumes you are updating
the original item. This is the default behavior. If you change the original, you
can update a linked copy using a single mouse click. To make working easier
for you, you can set a whole tool catalog to be linked or unlinked. When a
tool catalog is linked, all tools and palettes contained in it are dropped into
the AutoCAD Architecture palettes set as linked items by default. When a tool
catalog has been set to unlinked, all items in it are dropped as unlinked.

An unlinked copy of a tool or tool palette is treated as a new item, with no
relationship to the original item. If you copy an unlinked item back to its
original location in a tool catalog, the Content Browser simply adds it to the
catalog; you end up with two copies of that item with the same name.
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Any time you copy an item from the Stock Tool catalog to the tool palette
set, the item is treated as unlinked.

You can tell whether an item in the tool palette set is linked by right-clicking
the item and clicking Properties. If Refresh from is activated and a source is
listed, as shown below, the item is linked.

Refresh from property of a linked palette

If you select Enable Auto-Refresh, each time you start the software, any linked
tool palettes will be updated to reflect any changes made to the tool palette
and its contents in the tool catalog.

Using a Tool in the AutoCAD Architecture Workspace
Use this procedure to use a tool from a tool catalog in the AutoCAD
Architecture 2012 workspace. You can also copy tools stored in a tool package
to a tool palette in the tool palette set.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Open the tool catalog containing the tool you want to use. If the
tool is located in a specific category of the catalog, open that
category.

3 Move the pointer over the i-drop® icon next to the tool, so that

the pointer image changes to an eyedropper (  ).

To select multiple tools to copy, press and hold CTRL while clicking
each tool; then position the eyedropper over any of the selected
tools. You can also select all the tools in the current category by
right-clicking and clicking Select All.
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4 Drag the eyedropper according to the desired action:

Then…If you want to…

click the eyedropper and drag it in-
to the drawing area.

use the tool immediately

click the eyedropper and drag it to
a tool palette in the tool palette set.

NOTE A linked copy will only
be created when the tool cata-
log has been set to linked. If the
catalog has been set to non-
linked, any tool from that cata-
log will be inserted as non-
linked tool onto the AutoCAD
Architecture tool palettes set.
For more information about
linking tool catalogs see Editing
Tool Catalog Properties on page
150.

store a linked copy of the tool on a
tool palette in the tool palette set

press and hold alt. Then click the
eyedropper, and drag it to a tool
palette in the tool palette set.

NOTE If the tool catalog con-
taining the tool has been set to
unlinked, you do not need to
hold down alt while dragging
the tool. It will be inserted as
unlinked in any case.

create an unlinked copy of the tool
on a tool palette in the tool palette
set

NOTE If a tool palette does not accept a tool, it might be because
the palette is set to allow updates only from a linked tool palette in
a tool catalog. To check this, right-click on the palette, click Properties,
and look at the Refresh from setting. If Refresh from is selected, the
palette is linked to a palette in a tool catalog. To break the link, clear
Refresh from.
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Copying a Tool Palette to the AutoCAD Architecture Workspace
Use this procedure to store a copy of a tool palette in the tool palette set.

You can create a linked or unlinked copy of the tool palette. A linked copy
remains connected to the original in the tool catalog, so that you can easily
update the copy with any changes made to the original. An unlinked copy is
treated as a new tool palette, with no relationship to the original. For more
information about linked and unlinked tool palettes, see Using the Items in
a Tool Catalog on page 135.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Open the tool catalog containing the tool palette to copy to the
tool palette set. If the palette is located in a specific category of
the catalog, open that category.

3 Move the pointer over the i-drop® icon next to the tool palette,

so that the pointer image changes to an eyedropper (  ).

To copy multiple tool palettes, press and hold CTRL while clicking
each palette; then position the eyedropper over any of the selected
palettes.

4 Drag the eyedropper according to the desired action:

Then…If you want to…

click the eyedropper and drag it to
a tool palette in the tool palette set.

NOTE A linked palette will only
be created when the tool cata-
log has been set to linked. If the
catalog has been set to non-
linked, any palette from that
catalog will be inserted as non-
linked tool palette onto the
AutoCAD Architecture tool
palettes set. For more informa-
tion about linking tool catalogs
see Editing Tool Catalog Proper-
ties on page 150.

store a linked copy of the tool
palette in the tool palette set
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Then…If you want to…

press and hold alt. Then click the
eyedropper, and drag it to a tool
palette in the tool palette set.

NOTE If the tool catalog con-
taining the palette has been set
to unlinked, you do not need
to hold down alt while drag-
ging the palette. It will be inser-
ted as unlinked in any case.

create an unlinked copy of the tool
palette in the tool palette set

Copying a Tool Package to the AutoCAD Architecture Workspace
Use this procedure to copy a tool package to a palette in the tool palette set.

You can create linked or unlinked copies of the tools in the package. A linked
copy remains connected to the original in the tool catalog, so that you can
easily update the copy with any changes made to the original. An unlinked
copy is treated as a new tool, with no relationship to the original. For more
information about linked and unlinked tools, see Using the Items in a Tool
Catalog on page 135.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Open the tool catalog containing the tool package to copy into
the tool palette set. If the package is located in a specific category
of the catalog, open that category.

3 Move the pointer over the i-drop® icon next to the tool package,

so that the pointer image changes to an eyedropper (  ).

To copy multiple tool packages, press and hold CTRL while clicking
each package; then position the eyedropper over any of the
selected packages.
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4 Drag the eyedropper according to the desired action:

Then…If you want to…

click the eyedropper and drag it to
a tool palette in the tool palette set.

NOTE Linked tools will only be
created when the tool catalog
has been set to linked. If the
catalog has been set to non-
linked, any tool in that package
will be inserted as non-linked
tool package onto the AutoCAD
Architecture tool palettes set.
For more information about
linking tool catalogs see Editing
Tool Catalog Properties on page
150.

store linked copies of the package’s
tools in the tool palette set

press and hold alt. Then click the
eyedropper, and drag it to a tool
palette in the tool palette set.

NOTE If the tool catalog con-
taining the package has been
set to unlinked, you do not
need to hold down alt while
dragging the tool. It will be in-
serted as unlinked in any case.

create unlinked copies of the pack-
age’s tools in the tool palette set

Refreshing Linked Tools
Use this procedure to update a linked tool with the contents of its source copy
in a tool catalog.

■ In the tool palette set, right-click the tool you want to refresh, and click
Refresh Tool.
If Refresh Tool is not listed on the shortcut menu, click Properties. Then,
in the Tool Properties worksheet, select Refresh from.
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Refreshing Linked Tool Palettes
Use this procedure to update a linked tool palette with the contents of its
source copy in a tool catalog.

■ In the tool palette set, right-click the tool palette you want to refresh, and
click Refresh Palette.
If Refresh Palette is not listed on the shortcut menu, click Properties. Then,
in the Tool Palette Properties worksheet, select Refresh from.

Specifying Refresh Options for Linked Tool Palettes
Use this procedure to determine whether a linked tool palette and its tools
are refreshed from the tool catalog when you start AutoCAD Architecture
2012.

1 In the tool palette set, right-click the desired tool palette, and
click Properties.

2 Select an Auto-refresh option:

Then…If you want…

select Enable Auto-refresh.

NOTE Refresh from must also
be selected in order to enable
Auto-refresh.

the tool palette and all its tools to
automatically refresh when you start
AutoCAD Architecture 2012

clear Enable Auto-refresh.no automatic refreshing of the tool
palette

3 Click OK.

Working with Multiple Content Browser Windows
You can open more than one copy of the Content Browser and you can move
or copy items by dragging them between the windows. You can copy tool
palettes, tool packages, and tools; you cannot copy tool catalogs between
Content Browser windows. Only one catalog library can be open at any time.
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When you drag tool catalog items between Content Browser windows, the
following rules apply:

■ If a different catalog is open in each Content Browser window, dragging
an item copies it to the new location and leaves the original item in place.

■ If the same catalog is open in both Content Browser windows, dragging
items from one window to the other moves the item (for example, from
one category to another), removing the original item.

If you have the same tool catalog open in multiple windows, and you add an
item to the catalog, the tool catalog display is updated in all open Content
Browser windows.

Opening Additional Content Browser Windows

You can open a new instance of the Content Browser by pressing CTRL+N in
the Content Browser. You can also open a specific tool catalog, tool palette,
or tool package in a new Content Browser window.

Closing Content Browser Windows

Closing one Content Browser window has no effect on other Content Browser
windows. You can close all open Content Browser windows at once by
right-clicking in the title bar of any window and selecting Close All Windows.

Opening a Tool Catalog in a New Content Browser Window
Use one of the following procedures to open a tool catalog in a new Content
Browser window or display an open catalog in a new Content Browser window.

■ With the catalog library displayed in the right pane of the Content Browser
window, right-click the catalog to open, and click Open in New Window.

■ If a tool catalog is already open in the right pane of the Content Browser
window, right-click in a blank area of the catalog, and click New Window.
You can open a specific category of the tool catalog in a new Content
Browser window by opening the category.

Opening Catalog Items in a New Content Browser Window
Use this procedure to open a tool palette or tool package in a new Content
Browser window.
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1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Open the catalog containing the desired tool palette or tool
package. If the item is located in a specific category of the catalog,
open that category.

3 Right-click the tool palette or tool package, and click Open in
New Window.

Dragging Catalog Items Between Content Browser Windows
Use this procedure to send tools, tool palettes, or tool packages from one
catalog location to another by dragging them between two Content Browser
windows. Moving an item removes it from its original location, while copying
an item retains the original.

NOTE You must have write access to the original catalog before you can move
it.

1 Open two Content Browser windows.

2 In the first Content Browser window, display the catalog item
that you want to move or copy.

3 In the second Content Browser window, open the catalog,
category, tool palette, or tool package to send the item to (only
tools can be sent to palettes and packages).

4 In the first Content Browser window, move the pointer over the
i-drop icon associated with the item to be moved, so that the

pointer image changes to an eyedropper (  ).

Then…If you want to…

right-click  and drag the item to
its destination catalog or category

move an item to another location
in the same catalog

in the second Content Browser
window, and click Copy Here.

press CTRL; then  and drag the
item to its destination catalog or

copy an item to another location in
the same catalog

category in the second Content
Browser window.
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Then…If you want to…

press CTRL; then click  and drag
the item to its destination catalog

move an item to a different catalog

or category in the second Content
Browser window.

click  and drag the item to its
destination catalog or category in

copy an item to a different catalog

the second Content Browser win-
dow.

click  and drag the item to its
destination palette or package in

move a tool to a tool palette or tool
package in the same catalog

the second Content Browser win-
dow.

press CTRL; then click  and drag
the item to its destination palette

copy a tool to a tool palette or tool
package in the same catalog

or package in the second Content
Browser window.

press CTRL; then click  and drag
the item to its destination palette

move a tool to a tool palette or tool
package in a different catalog

or package in the second Content
Browser window.

click  and drag the item to its
destination palette or package in

copy a tool to a tool palette or tool
package in a different catalog

the second Content Browser win-
dow.
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Starting the Content Browser from a Windows Command
Prompt

Use this procedure to open the Content Browser from a Windows command
prompt, even if AutoCAD Architecture 2012 is not currently open.

1 Click Start (Windows) menu ➤ Command Prompt.

The location of the Command Prompt application varies from
one version of Windows to another. It is most likely to be found
either in Programs or on the Accessories menu within Programs.

2 At the command prompt, specify the AutoCAD Architecture
program folder as the current directory.

3 Enter the command aeccb, followed optionally by the path to the
tool catalog you want the Content Browser to open. For example:

aeccb "c:\my documents\autodesk\my content browser
library\mycatalog\mycatalog.atc”
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Creating and Saving
Drawings

Drawings have common properties that you can specify when you create a new drawing. You
can specify:

■ the template on which to base the drawing, or create a drawing that is not based on any
template.

■ units, scale, layer standard, layer key style, and default display properties.

■ options that control drawing performance and behavior.

You also have a number of options for saving files to use with other applications. These
options are useful if you work with vendors and consultants who do not use AutoCAD
Architecture.

About Templates
The templates included in the software are drawing files with predefined settings.
Predefined settings include drawing units, drawing scales, and annotation plot
sizes. You can use these templates to create new drawings without going through
any additional setup.

Templates are installed in C:\ProgramData\Autodesk\ACA 2012\enu\Template.

NOTE The Template folder is marked as hidden in Windows by default. To display
hidden folders, enable that option on the View tab of the Folder Options command
in Windows Explorer.

Templates also contain predefined display configurations. Display configurations
allow you to produce different architectural displays, such as floor plans, reflected
plans, elevations, 3D models, or schematic displays. For more information, see
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Display System on page 791. If you are working with a project, as described in
Drawing Management on page 303, you can assign display configurations
directly to the project as a project standard. For more information, see
Configuring Project Standards on page 609.

If you are a new user of the software, it is recommended that you use a template
to create your drawings. You always have the option to modify a template or
create your own template after you become more familiar with the software.

You can modify a template to conform to your office standards by changing
the settings and then saving it as a new template, or you can import settings
from another template into the current drawing, and then saving the current
drawing as a template. For more information about creating your own template,
see “Use a Template File to Start a Drawing” in AutoCAD Help. For more
information about importing display settings to a custom template, see Using
Display Settings in Multiple Drawings on page 846 and Creating and Editing
Display Configurations on page 824.

Creating a Drawing from a Template
Use this procedure to create a drawing from a template. The drawing templates
provided with the software are located in C:\ProgramData\Autodesk\ACA
2012\enu\Template. Template files have the extension dwt.

NOTE To create a drawing that you want to include in a project, see Workflow
for a Project Environment on page 303.

1 Click  ➤ New ➤ Drawing.

NOTE Be sure to choose the New command from the application

menu to select a template. The  icon on the Quick Access toolbar
is a shortcut to the “QNew” command which creates a new drawing
based upon a default template file. You can configure the default
template file used for QNew in the Options dialog. For more
information, see “QNEW Command” in AutoCAD Help.
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2 Select the template you want to use, or click Tools ➤ Find, and
navigate to the template you want to use.

3 Click Open.

To view or change the default drawing settings for units, scale,
layers, and display, see Setting Up a Drawing on page 183.

Creating a Drawing Without a Template
Use this procedure to create a drawing that is not based on a template.
Drawings that are not based on templates contain no customized or predefined
settings, such as display configurations or architectural units. Drawings without
a template use the settings specified in the Drawing Setup dialog box.

If you are a new user use one of the templates provided to create drawings
until you are comfortable working with display configurations and other
settings. After you are more familiar with the program, you can create your
own templates and customize your drawing settings. For more information,
see Creating a Drawing from a Template on page 180.

NOTE To create a drawing to include in a project, see Workflow for a Project
Environment on page 303.

1 Click  ➤ New ➤ Drawing.
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2 Click the arrow next to Open.

3 Select Open with no Template - Imperial to begin a drawing in
imperial units, or select Open with no Template - Metric to begin
a drawing in metric units.

For more information, see Setting Up a Drawing on page 183.

Opening Legacy Drawings
Keep the following points in mind when you open drawings from earlier
releases:

■ To upgrade a drawing from an earlier release to the current release, open
the legacy drawing and then save the drawing. When you open a drawing
from a previous release in a newer one, a task dialog appears prompting
you to do so. If the drawing references other legacy drawings, open and
save those externally referenced (xref) drawings to upgrade them to the
current release.

■ If you try to edit an external reference drawing within a legacy drawing,
you are prompted to update the external reference drawing to the current
release. It is recommended that you use the same version for your external
references and host drawings.

■ If you open a legacy drawing in the Style Manager, the drawing is marked
as read-only; you can copy styles from that drawing to drawings in newer
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current versions. If you copy styles from the current version to legacy
drawing, you have to save the legacy drawing under a new name and in
the current release file format.

■ Open and save a legacy drawing in the current version if you want to be
able to edit it in DesignCenter®.

IMPORTANT Any time you combine a drawing from a previous version with a
drawing from the current version, you should first open the previous version
drawing and save it. For example, before inserting a drawing as a block or attaching
it as an xref, open the drawing and save it to promote all the objects to the current
version.

Saving a Drawing to a Previous Release File Format
When you save a drawing to a previous release file format, not all objects and
properties will be supported. You can do one of the following:

■ Save the drawing to the current release format: All objects and properties
will be saved correctly, but the drawing may become incompatible with
earlier releases.

■ Save the drawing as AutoCAD-only objects. For more information, see
Exporting a Drawing to AutoCAD on page 208.
To view AutoCAD objects in a previous release, verify that the latest Object
Enabler is installed, as available on http://www.autodesk.com\enablers.

■ Save the drawing to a previous version with Proxy Graphics. If you open
the drawing in the previous version, you can view AEC objects as Proxy
Graphics, but cannot edit them. For more information, see Generating
Proxy Graphics on page 207.

Setting Up a Drawing
When you create a drawing from a template, the drawing setup options are
predefined. You can use these settings or customize them as needed. For
example, you may want to use different drawing scales for different drawings.

When you create a drawing without a template, settings such as layer standards
and layer key styles are imported into the drawing. For more information, see
Creating a Drawing Without a Template on page 181.
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You can specify the drawing units, drawing scale, and layer options as the
default settings for any drawing that you start, with or without a template. If
you save the settings specified as the default, they override settings in the
template.

If you are unfamiliar with the display system or layer management, you may
want to read more in Display System on page 791 and Managing Drawing
Layers on page 720 before specifying the layering and display options.

Specifying the Drawing Units
Use this procedure to specify the drawing units in a new or existing drawing.
If you change the drawing units, you can specify whether existing objects in
the drawing are scaled to the new units or retain their original size. You can
also specify whether objects inserted from a drawing that uses different units
are scaled to the units in the current drawing, or retain their original size.

You can specify the unit type and precision for linear, angular, area, and
volume units. The precision values specify only the number of decimal places
displayed in the interface. They do not determine the number of decimal
places used in the software to make calculations.

When you change the drawing units, the default options under Area and
Volume change to reflect the new drawing units. The drawing scale options
on the Scale tab also change to reflect the new drawing units.

1 Click  ➤ Utilities ➤ Drawing Setup.

2 Click the Units tab.
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Specifying default units options for the current drawing

3 Under Drawing Units, select the desired units.

Various imperial and metric units are available. The units that
you select determine the unit of measurement that each unit in
your drawing represents. For example, if you select Inches, each
drawing unit equals one inch.

4 To scale objects that you insert into the current drawing from
drawings with different drawing units, select Scale Objects Inserted
from Other Drawings.

Clear this option to insert objects at their original size without
scaling. For example, if an item that is one inch long were inserted
into a drawing set to millimeters, this setting would scale the item
to 25.4 mm in length when enabled. With this setting disabled,
it would remain one unit long, (which would now be only one
millimeter rather than one inch).

5 Under Length, select a unit type and desired precision.

6 Under Angle, select an angle type and desired precision.

If you want to measure angles clockwise instead of
counterclockwise, select Clockwise.
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7 Under Base Angle, enter a value for the default 0 angle direction.
The default is 0 degrees (East) and a counter-clockwise direction.

Imported survey drawings may include drafting instructions where
changing the base angle might be desirable to properly orient the
data.

The following values match these directions:

DirectionValue

East0

North90

West180

South270

8 Under Area, select an area type and precision.

If you do not want to use the default suffix that is displayed for
the drawing units that you specify, enter a new suffix.

9 Under Volume, select a volume type and precision.

If you do not want to use the default suffix that is displayed for
the drawing units that you specify, enter a new suffix.

10 Under Lighting Units, select a lighting unit type.

11 Save the units settings:

Then…If you want to…

select Save as Default. Settings on
the Scale and Layering tabs are also
saved as default settings.

save the units settings as default
settings for new drawings that you
start from scratch or from templates
that do not contain drawing setup
information

clear Save as Default, and then click
Apply.

save the units settings only for the
current drawing
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NOTE You can save one default drawing units set per unit type with
the Save as Default option. Define a set of imperial drawing units
defaults, and click Save as Default. Then, define a set of metric default
units, and click Save as Default again. When you start a drawing
without a template with imperial units, the imperial default settings
will be used. When you start a drawing without a template with metric
units, the metric default settings will be used. If you start a new
drawing with a template, the settings saved within that template file
will be used regardless of the saved default settings.

12 Click OK.

You are prompted to specify whether existing objects in the
current drawing should be scaled for the new units.

13 Specify scaling of existing Model Space and Paper Space objects:

Then…If you want to…

select Rescale modelspace and pa-
perspace objects.

scale all existing objects in the
drawing to reflect the new units

select Rescale only modelspace ob-
jects.

scale objects in Model Space to re-
flect the new units

select Don’t rescale any existing
objects.

leave all objects at their current
scale

Creating Annotation Scales and Assigning them to Display
Configurations

In the Scale tab, you can do the following things:

■ Display the available annotation scales

■ Create new annotation scales

■ Assign an annotation scale to a display configuration.

NOTE You cannot set the annotation scale used for this drawing here. For
information on setting the scale, see Specifying Annotation Scale on page 3678.
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The annotation scale determines how many drawing units in the drawing
represent one inch (for imperial drawings) or one millimeter (for metric
drawings) in the plotted drawing. A drawing scale of 1/8”=1’-0” (or 1:96 - eight
eighths per inch times 12 inches per foot) in a drawing that has inches as
default drawing units means that 8 feet in the drawing are represented by 1
inch on the plotted out plan. Likewise, if a drawing has a scale of 1:200 and
a drawing unit of millimeters, then 200 millimeters in the drawing will be
represented by one millimeter on the plotted out plan.

Annotation plot size, multiplied by the scale factor, determines the height of
plotted annotation text. Scale-dependent objects in a drawing are scaled
automatically upon insertion to reflect the units that are specified in a drawing.
Any content that you create can be built to take advantage of these settings
and is thus scaled appropriately.

1 Click  ➤ Utilities ➤ Drawing Setup.

2 Click the Scale tab.

Specifying default scale options for the current drawing

3 Under Scale, the available annotation scales are displayed.
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NOTE The scale values in the list reflect the current drawing units.
To change the drawing units, see Specifying the Drawing Units on
page 184.

4 To assign an annotation scale to a specific display configuration,
first select the desired annotation scale from the Scale list, and
then select the display configuration to associate it with from the
Display Configurations list.

Under Scale value, the currently used annotation scale for this
display configuration is displayed.

5 To edit an existing scale or add a new scale, click Edit Scale List.

■ To edit an existing scale, select it, and click Edit.

■ To add a new scale, click Add, and enter a display name and
scale values.

■ To rearrange the order of the scale entries, use the Move up
and Move down buttons.

6 Click OK.

7 Select Automatically Create Dimscale Override, if you want to
make the dimension scale match your drawing scale.

The override applies a scale factor to the dimension style
properties.

NOTE AEC dimensions added with tools are not affected by the
dimension scale override because an AEC dimension style depends
on which display representation is active. For more, see AEC
Dimensions on page 3387.

If you clear Automatically Create Dimscale Override, the software
is prevented from automatically applying an override to the
current dimension scale style in the drawing.

8 Enter a value for Annotation Plot Size.

The annotation plot size is always measured in millimeters for
metric drawings and in inches for imperial drawings. Annotation
plot size, multiplied by the drawing scale factor, determines the
height of plotted annotation text.
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9 Save the scale settings:

Then…If you want to…

select Save as Default. Settings on
the Units and Layering tabs are also
saved as default settings.

save the scale settings as default
settings for new drawings that you
start from scratch or from templates
that do not contain drawing setup
information

clear Save as Default, and then click
Apply.

save the scale settings only for the
current drawing

NOTE You can save one default drawing scale set per unit type with
the Save as Default option. Define a set of imperial drawing scale
defaults, and click Save as Default. Next, define a set of metric scale
defaults, and click Save as Default again. When you start a drawing
without a template with imperial units, the imperial default scale will
be used. When you start a drawing without a template with metric
units, the metric default scale will be used. If you start a new drawing
with a template, the settings saved within that template file will be
used regardless of the saved default settings.

10 Click OK.

If you also changed the drawing units, you are prompted to specify
whether existing objects in the current drawing should be scaled
for the new units. For more information, see Specifying the
Drawing Units on page 184.

Specifying a Layer Standard and a Layer Key Style
Use this procedure to specify the layer standard and layer key style to determine
the layers on which objects are placed in a drawing. You can specify the layer
key style to use in the current drawing. You can also specify a layer standard
and a layer key style to be imported when you set up a new drawing.

There are a number of layer standards and layer key styles in AecLayerStd.dwg,
located in C:\ProgramData\Autodesk\ACA 2012\enu\Layers.

By default, AecLayerStd.dwg (located in the Layers folder mentioned above)
is loaded automatically. This file contains layer standards and layer key styles.
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NOTE If you are unfamiliar with layer keying, you may want to read the overview
of layer keying before specifying layering options. For more information, see
Working with Layer Keys on page 759.

1 Do any of the following:

■ Click Home tab ➤ Layers panel ➤  ➤ Select Layer Standard

 .

■ Click  ➤ Utilities ➤ Drawing Setup, and click the
Layering tab.

2 Specifying default layering options for the current drawing

3 Under Layer Standards/Key File to Auto-Import, enter the name
of the layer standards drawing (DWG or DWT) you want to use.

You can click  to navigate to a file.

4 Under Default Layer Standard, select the layer key style that you
want to use in your drawing.
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5 To re-import the layer key style from the layer standard you
specified at the start of each drawing session, select Always import
Layer Key Style when first used in drawing.

Selecting this option has the effect of checking the current drawing
to see if the selected layer key style exists. If it does exist, the date
and time stored on it are compared with the external file. If the
external layer key style drawing is newer, then it re-imports the
layer key style and standard. This action occurs each time the
drawing file is opened; therefore, to force a re-import of the layer
key style, you must close and reopen the drawing.

6 Define the on/off behavior of secondary components within an
object.

You can place different components of an AEC object on different
layers. This is accomplished with the object’s display properties.
For example, the current layer key style might place a wall on the
layer named A-Wall, while the wall’s material definitions place
its internal boundaries on the layer named A-Wall-Comp. Turning
off the layer A-Wall would typically make the entire wall
(including its internal boundaries) invisible, even though those
components were assigned to a different layer. Selecting Immediate
and independent layer on/off control of display components
allows the internal boundary components on A-Wall-Comp to
remain visible, even though the primary object’s layer (A-Wall in
this case) is off. This behavior can be desirable in some plan
representations.

NOTE Freezing the primary object’s layer (A-Wall in this case) makes
the entire wall, including its internal boundaries, invisible regardless
of the value of this setting. This setting applies only to the Off layer
state.

Then…If you want to…

clear Immediate and independent
layer on/off control of display com-
ponents.

turn off secondary object compon-
ents on different layers when the
main component layer is turned
off

select Immediate and independent
layer on/off control of display com-
ponents.

turn on and off secondary object
components independently of the
main object component layer set-
tings
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7 IMPORTANT If you select Save as Default, the layer key style you
select is the default layer key style for all new drawings created without
a template or from templates that do not have different default layer
key standards assigned.

Save the layer settings:

Then…If you want to…

select Save as Default, and click OK.
Settings on the Units and Scale tabs
are also saved as default settings.

save the layers settings as default
settings for all new drawings that
you start without a template or
from templates that do not contain
drawing setup information

clear Save as Default, click Apply,
and then click OK.

save the layer settings only for the
current drawing

If you also changed the drawing units, you are prompted to specify
whether existing objects in the current drawing should be scaled
for the new units. For more information, see Specifying the
Drawing Units on page 184.

Specifying the Default Display Representations
Use this procedure to specify the default display representations of AEC objects.
You can also specify the default display configuration for the Model tab and
new viewports. In addition, you can specify whether the drawing uses its own
display configurations or those of a host drawing when the drawing is
referenced as an overlay xref.

You may find it easier to select and modify display representations using the
Display Manager. For more information about the display system, see Display
System on page 791. For more information about using the Display Manager,
see The Display Manager on page 814.

NOTE Changes you make on the Display tab apply only to the current drawing.
New drawings are not affected. Save as Default has no effect on this tab.

1 Click  ➤ Utilities ➤ Drawing Setup.

2 Click the Display tab.
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Specifying default display options for the current drawing

3 To make changes to a display representation for an object type,
select it, and click Edit.

For general information about display representations, see Display
Representations on page 803. For information about the display
properties of an object type, see the chapter about the relevant
object. For example, for information about wall display properties,
see Specifying the Display Properties of a Wall Style on page 1316.

4 Select a display configuration for Default Display Configuration.

The display configuration is applied to the Model tab and new
viewports in paper space layouts.

5 To use the display configurations in the current drawing when
the drawing is referenced as an overlay xref in a host drawing,
select When used as an Xref Overlay, use this drawing’s default
display configuration initially.

Clear this option if you want objects in the current drawing to
use the display configurations of the host drawing when the
current drawing is an overlay xref.

For information about overlaying xrefs in drawings, see “Reference
Other Drawing Files (Xrefs)” in AutoCAD Help.
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6 Click OK.

If you also changed the drawing units, you are prompted to specify
whether existing objects in the current drawing should be scaled
for the new units. For more information, see Specifying the
Drawing Units on page 184.

Specifying the Units for HVAC Components

TIP This tab is only available in AutoCAD MEP.

In the HVAC tab, you can choose from a list of the measurement units for the
following HVAC components:

■ Air flow

■ Friction

■ Velocity

Use this procedure to choose the measurement units for the HVAC
components: air flow, friction, and velocity. Depending on the drawing units
selected in the Units tab, you can choose from multiple units display options
in this tab. For example, when the drawing units is set to Meters, the air flow
units allows you to choose from the following display options: liters per second,
liters per minute, cubic meters per second, or cubic meters per hour.

The HVAC component units are used in all dialogs and palettes that display
these components, such as the Duct Properties palette, Duct System Size
Calculator, and so on.

NOTE Save as Default displays the selected settings for all drawings.

1 Click  ➤ Drawing Utilities  ➤ Drawing Setup.

2 Click the HVAC tab.
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Specifying units set for air flow, friction and velocity for the current
drawing

3 From the drop-down select the measurement units for air flow,
friction and velocity.

Changing the drawing units on page 184 changes the display
options appropriately.

Specifying AEC Options
There are several tabs in the AutoCAD Options dialog box where you can
select specific AEC options. You can use these settings to specify default values
for some architectural objects, to specify the location and type of content files,
and to control performance while you are working in architectural drawings.
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Changing the AEC Editor Settings
Use this procedure to specify settings to control the following aspects of the
software:

■ the display of diagnostic messages and solution tips

■ the placement of dialog boxes and viewers on the screen

■ whether objects retain their layer, color, and linetype when you export
them to an AutoCAD or DXF file

To improve drawing performance, you can limit the snap points provided by
certain display representations, and decrease the layer loading time of the
Layer Manager.

You can also specify settings for grip colors, and specify whether dynamic
dimensions appear when you select and move grips to change the geometry
of an object.

The AEC Editor settings that you specify are saved in the Windows® registry.

1 Click  ➤ Options.

You can also display the Options dialog box by right-clicking in
the command line area, and clicking Options.

2 Click the AEC Editor tab.
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Specifying default AEC Editor options for the current drawing

3 Under Diagnostic Messages, select options for displaying diagnostic
messages on the command line:

Then…If you want to…

select Object Relationship Graph.display data about the relationship
between objects in the drawing

select Display Management System.display Display System errors

select Geometry.display object geometry-specific
data

All diagnostic messages are off by default.

4 Under Similar-Purpose Dialogs, select options for the default
position of dialog boxes and viewers:

Then…If you want to…

select Use Common Position. Some
dialog boxes, such as those contain-

use a common position on the
screen for similar dialog boxes

ing style properties, are always dis-
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Then…If you want to…

played in the center of the screen,
regardless of this setting.

select Use Common Viewer Position
and Size. Some viewers are not
controlled by this setting.

use a common position for similar-
purpose viewers

5 Under Optimize for Speed, select Object Snap to limit certain
display representations to respond only to the Node and Insert
object snaps.

This setting affects stair, railing, space boundary, multi-view block,
masking block, slice, and clip volume result (building section)
objects.

6 Under Object Conversions, choose Apply Common Property Sets
to New Objects if you wish to have common property sets
automatically applied to new objects when applying tool
properties.

When you apply the properties of a tool to an object in the
drawing, the result can often be a new object. For instance, when
you apply the tool properties of a door to an existing window, a
new door object is created in place of the existing window. With
this setting enabled, any property sets that were assigned to the
existing window will automatically be preserved and applied to
the new door provided that the property set definitions in
question applies to both types of objects (in this case, both doors
and windows are selected on the property set’s applies to tab).

7 Under Solution Tips, specify whether you want solution tips to
be displayed during the listed activities. Drafting is selected by
default. Plotting/Publishing is cleared by default. For more
information, see Solution Tips on page 59.

8 Under Dynamic Dimensions Linetype, select either Continuous
or Dot.

The dimensions identify the current value of the dimension being
edited, such as the length of a wall, the difference between the
current value and the new dimension based on the position of
the grip, and the total value. For example, when you select and
move a Lengthen grip on a wall, the dimensions shown are the
current length, the difference between the current length and the
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length based on where you moved the grip, and the total new
length of the wall.

The dynamic dimensions will display in either continuous or dot
linetype based on your selection.

9 Under Export to AutoCAD, select Use Insert Method when Binding
xrefs if you want all objects from an xref drawing referenced in
the file you export to be incorporated into the host drawing.

If you select this option, the names of the xref drawings are
discarded when the exported drawing is created. In addition, their
layers and styles are incorporated into the host drawing. For
example, all exploded walls, regardless of their source (host or
xref) are located on the same layer.

Clear Use Insert Method when Binding xrefs if you want to retain
the xref identities, such as layer names, when you export a file to
AutoCAD or to a DXF file. For example, the blocks that define
walls in the host drawing are located on A-Wall in the exploded
drawing. Walls in an attached xref drawing are located on a layer
whose name is created from the drawing name and the layer
name, such as Drawing1$0$A-Wall.

10 Enter a prefix or a suffix to be added to the drawing file name
when the drawing is exported to an AutoCAD drawing or to a
DXF file.

11 Under Block Properties of Exploded Objects, select Maintain
Resolved Layer, Color, Linetype to maintain the layer, color, and
linetype of AEC objects when you explode them.

When you explode an AEC object, you create several primitive
objects grouped in a block definition. If this option is selected,
any objects whose component layer, color, and linetype properties
are set to ByBlock take the layer, color, and linetype of the parent
object. If this option is cleared, when you explode an object,
properties that are ByBlock remain ByBlock. Clear this option if
you want to explode the block definition even further.

12 Under Unselected Grip Colors, select the colors you want to use
for each type of grip.

13 To specify the units of measure for AutoCAD drawings when they
are opened in the software, select Metric or Imperial for Units for
Legacy Drawings.

This option enables the software to ignore the value for the
AutoCAD MEASUREMENT variable to ensure that the software
respects the correct units when an AutoCAD drawing is opened
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in the software. Select Automatic if you want AutoCAD drawings
to use the units that are current in the software.

14 Click OK.

Changing the AEC Content Settings
Use this procedure to specify the location of the content files accessed by the
Custom View in AutoCAD DesignCenter, to choose between imperial and
metric content, and to specify whether the Edit Property Data dialog box is
displayed when you insert schedule tags. You can also specify the location of
dependent files, such as styles for tools.

The AEC Content settings that you specify are saved in the Windows® registry.

1 Click  ➤ Options.

You can also display the Options dialog box by right-clicking in
the command line area, and clicking Options.

2 Click the AEC Content tab.

Specifying default AEC Content options for the current drawing
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3 Under AEC DesignCenter Content Path, edit the path and location
of your content files, or click Browse to locate content files.

4 To display the Edit Property Data dialog box when you insert a
schedule tag in the drawing, select Display Edit Property Data
Dialog During Tag Insertion.

When this option is chosen, a worksheet will display after each
tag is placed, allowing you to edit property set values. If you clear
this option, no worksheet will appear during tagging.

5 Under Tool Catalog Content Root Path, edit the path and location
of your style drawings, or click Browse to locate files.

The variable, %AECCONTENT_DIR%, used for tool-dependent
file references, is updated to use the path you specify. For example,
<Style href=“%AECCONTENT_DIR%\Door Styles\DoorStyles.dwg”/>.

6 Click Add/Remove next to Detail Component Databases to add
or remove additional Detail Component Databases.

7 Click Add/Remove next to Keynote Databases to add or remove
additional Keynote Databases.

8 Click OK.

Specifying AEC Object Settings
Refer to the following topics to specify AEC options for walls, stairs, spaces,
and the display of curved objects:

■ Wall Parameters on page 1247

■ Specifying AEC Options for Stairs on page 2106

■ Setting Up Adjacency Relations between Space Surfaces on page 3091

■ Specifying the Display Resolution of Objects with Facets on page 202

Specifying the Display Resolution of Objects with Facets
Use this procedure to specify the facet deviation and the maximum number
of facets that can be used to display a curved object, such as a Cylinder mass
element or a curved wall. The values you specify apply to the current drawing.

The number you specify for facet deviation defines the maximum distance
from the chord to the arc, the chord being an edge that is created from faceting
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the curve to the true mathematical arc. The facet deviation must be greater
than zero (0). It has no upper limit.

1 Click  ➤ Options.

You can also display the Options dialog box by right-clicking in
the command line area, and clicking Options.

2 Click the AEC Object Settings tab.

Specifying default AEC Object Settings options for the current drawing

3 Under AEC Display Resolution, enter a value for Facet Deviation.

The default value is 1/2'' for drawings created from imperial
templates and 12.7 mm for drawings created from metric
templates. The value you enter is stored in the AecFacetDev
variable.

4 Enter the maximum number of facets that can be used to draw
curved objects.

You can enter a value between 100 and 10,000. The value you
enter is stored in the AecFacetMax variable.

The default value is 128 for new drawings.
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5 Click OK.

Changing the AEC Project Defaults
Use this procedure to specify the default folders in which the software searches
for projects, palettes, templates, and other project files. These settings are used
to create new projects without using a template. If a new project is created
from a template project, the settings of the template project are used instead.

1 Click  ➤ Options.

You can also display the Options dialog box by right-clicking in
the command line area, and clicking Options.

2 Click the AEC Project Defaults tab.

Specifying default AEC Project Defaults options for the current drawing

3 Expand a category, and select a path.
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4 Change, add, or remove a path:

Then…If you want to…

select the path, and click Browse.
Navigate to the new path, and click
OK.

change the current path

select the category, and click Add.
Specify the new path, and click OK.

add a path to the list of paths

If Add is unavailable, you can spe-
cify only one path for this category.

select the path, and click Remove.
If Remove is unavailable, you can

remove a path

edit the path but you cannot delete
it.

5 Select Show Project Browser at startup if you want the Project
Browser to open when you open the software.

6 To launch the Create Sheet Set wizard, click the Create Sheet Set
Template.

This will launch a wizard to assist you in creating your own Sheet
Set Template to use for your projects.

7 Click OK.

Sharing Drawings with AutoCAD Users
There are 2 methods for making drawings available to users who are working
with AutoCAD:

■ Working with Proxy Graphics

■ Exporting drawings to AutoCAD DWG or DXF

The method you choose depends on the software the others are using, on how
exactly the drawing must match the original drawing, and on the particular
views the other users require.
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Turning on Proxy Graphics

When you turn on proxy graphics in a drawing, users who do not have
AutoCAD Architecture but do have another AutoCAD-based product (AutoCAD
2000 or newer), can view and plot AEC objects and design data.

Exporting to AutoCAD Drawings and DXF Files

You can export drawings created with the software to AutoCAD drawings for
the following versions:

■ AutoCAD 2007

■ AutoCAD 2004 (including 2005 and 2006)

■ AutoCAD 2000 (including 2000i and 2002)

■ AutoCAD R14

You can also export a drawing to a drawing interchange format (DXF) file. A
DXF file is a text or binary file that contains drawing information that can be
read by other CAD systems. For more information about DXF files, see “DXF
Files” in AutoCAD Help.

TIP The quickest way to locate and view an AutoCAD topic is to click the Search
tab in the Help window, select the Search titles only option, and then copy and
paste or type in the AutoCAD topic name, and click List Topics.

You can export drawings to the following DXF formats:

■ AutoCAD 2007 DXF

■ AutoCAD 2004 DXF (including 2005 and 2006)

■ AutoCAD 2000 DXF (including 2000i and 2002)

■ AutoCAD Release 12 DXF

Exporting a drawing to an AutoCAD drawing or to a DXF file creates a separate
drawing in which all AEC objects, such as walls, doors, windows, and roofs,
are exploded to AutoCAD primitive objects, such as lines, arcs, and 3D faces.
The resulting AutoCAD objects cannot be restored to AutoCAD Architecture
objects. Export AutoCAD Architecture drawings to DXF instead of saving them
as DXF files.
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NOTE You can open DXF files generated in earlier versions of the software if the
files do not contain any AEC objects. DXF files that contain AEC objects cannot
be imported into the software.

Comparing Methods of Sharing Drawings
The following table lists the features of the various methods of sharing
drawings with AutoCAD users:

Export to Auto-
CAD (DWG or
DXF)

Object EnablerProxy GraphicsUse Case

View, plot, ma-
nipulate ex-

View, plot, copy,
manipulate AEC

View, plot AEC
objects and

Use of AEC objects in other
AutoCAD-based applications

ploded AEC ob-
jects

objects and
design data

design data; no
manipulation of
objects

No AEC objectsAEC objects are
maintained as in-
telligent objects

AEC objects are
displayed as
proxy graphics

Status of AEC objects in
other applications

with no intelli-
gence

Separate ex-
ploded copies
are generated

YesNoMultiple representations of
objects in different view-
ports

NoYesYesAEC objects still exist when
reopened in the software

YesNoYesDrawings used in a previous
version

Generating Proxy Graphics
Use this procedure to create proxy graphics in a drawing to be made available
to users who do not have the software.
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Proxy graphics store the last-viewed image of AEC objects, which lets users
view your drawing without modifying the original objects. Proxy graphics
store only the display representation for the currently active viewport.

NOTE Depending on its complexity and density, a drawing saved with proxy
graphics turned on can become extremely large and can slow drawing
performance. It is recommended that you make a copy of the drawing before
turning proxy graphics on if you want to share the drawing with other users.

1 Arrange the view for which you want to create proxy graphics.

2 At the command line, enter proxygraphics.

3 Enter 1.

4 Save the drawing.

5 To turn off proxy graphics, enter proxygraphics, and then enter
0.

Exporting a Drawing to AutoCAD
Use this procedure to export a drawing created in the software to AutoCAD.
This process creates a new AutoCAD drawing with all AEC objects exploded.
The original drawing is not affected.

Depending on the size and complexity of the original drawing, the resulting
AutoCAD drawing may contain a large number of primitive objects, which
can affect drawing performance.

NOTE When you export a drawing to an AutoCAD drawing, all AEC objects are
exploded to AutoCAD primitive objects. Reopening the file in the software does
not restore these primitive objects to AEC objects.

WARNING If you export a drawing that has Mviews to AutoCAD R14, only the
layout active at the time of exporting will be preserved in AutoCAD R14. Any
non-rectangular (polygonal or object) Mviews are converted to rectangular Mviews.

1 Choose whether to export a single representation of the AEC
objects or all visible representations.

Then…If you want to…

activate the Model tab. Only those
representations in the currently
active view will be generated.

export the currently active repres-
entation of the AEC objects in the
drawing
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Then…If you want to…

activate any layout tab. The repres-
entations for all layouts will be
generated.

TIP  This will usually result in
duplicate graphics on the
Model tab, which makes the
drawing less useful.

export all representations of the
AEC objects in the drawing

For example, when creating a drawing for a consultant to use as
an xref-attached background, you should display a top view in
the active Model tab viewport. When creating a drawing to be
used to produce a rendering, you should display an isometric view
in the active Model tab viewport.

To create a drawing that includes the exact graphics used in all
layout tab viewports, activate any layout tab. These drawings can
be sent to a printing service, for example, to make plots without
the need for AutoCAD Architecture or the Object Enabler.

2 Press F2 to display the command window.

3 On the command line, enter -ExportToAutocad.

A list with the currently active export settings from the AEC Editor
options page is displayed:

■ File Format

■ Bind Xrefs

■ Bind Type

■ Filename prefix

■ Filename suffix

4 Alternatively, enter AecToAcad on the command line.

For more information, see “ExportToAutoCAD” in AutoCAD Help.

5 To change the AutoCAD file format to which the drawing should
be exported, enter F (Format) and press ENTER.

The following AutoCAD file format versions are available:

■ AutoCAD 2007

Exporting a Drawing to AutoCAD | 209



■ AutoCAD 2004 (including 2005 and 2006)

■ AutoCAD 2000 (including 2000i and 2002)

■ AutoCAD R14

6 To specify whether to bind xrefs when exporting a drawing, enter
B (Bind Xrefs), press ENTER, and select Y (Yes) or N (No).

NOTE If you want to retain visual fidelity in the exported drawing,
selecting Yes is recommended. Visual fidelity can be affected by
exporting individual drawings and binding them later, because when
opened individually the xref may appear differently than it does in
the host drawing.

7 To select the desired bind type for xrefs when exporting the
drawing, enter T (bind Type), and choose one of the following:

Then…If you want to…

enter I (Insert).
In this case, for example, all ex-
ploded walls, regardless of their

discard the names of the xref
drawings and incorporate their lay-
ers and styles into the host drawing

source (host or xref) are located on
the same layer.

when the exported drawing is cre-
ated

enter B (Bind).
In this case, for example, the blocks
that define walls in the host draw-

retain the xref identities when
binding xrefs, such as layer names,
when exporting the drawings

ing are located on A-Wall in the ex-
ploded drawing. Walls in an at-
tached xref drawing are located on
a layer whose name is created from
the drawing name and the layer
name, such as Drawing1$0$A-Wall.

IMPORTANT If you want to export drawings with multiple xrefs in
them, the bind option is recommended. If xref layers have the same
name, but different visibility settings, then the layers will be merged
when using the insert option, and use the settings of the first layer
found. This can lead to unexpected results in the exported drawings,
for example with objects disappearing from the drawing. The bind
option will retain the layers and their settings and thereby ensure
that visibility settings stay identical to the source drawing.
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8 To specify whether the object properties in the exported AutoCAD
drawing should be maintained, enter M (Maintain) and press
ENTER:

■ If you want the object properties to be resolved and be directly
assigned to the exploded objects, enter Y (Yes).

■ If you want objects to remain in blocks and have their
properties set ByLayer and ByBlock, enter N (No).

9 To select a prefix or suffix for the drawing name, enter P (Prefix)
or S (Suffix), press ENTER, and type in the desired prefix or suffix.

10 To enter a name for the exported AutoCAD drawing and start the
export, press ENTER, and type in a file name.

TIP You can also start an export to AutoCAD by clicking 
 ➤ Export ➤  AutoCAD, and then selecting the desired export format.
In that case, the export settings defined on the AEC Editor tab of the
Options dialog are used for exporting. For more information, see
Changing the AEC Editor Settings on page 197.

IMPORTANT The -AecExportToAutoCAD command has been added
to the Object Enabler in the software, enabling you to export a
drawing to an AutoCAD format from within AutoCAD or other
AutoCAD based vertical applications.

Exporting a Drawing to a DXF File
Use this procedure to export a drawing created in AutoCAD Architecture to a
drawing interchange format (DXF) file. A DXF file is a text file that contains
drawing information that can be read by other CAD systems. For more
information about DXF files, see “DXF Files” in AutoCAD Help.

You can export drawings to the following DXF formats:

■ AutoCAD 2007

■ AutoCAD 2004 DXF (including 2005 and 2006)

■ AutoCAD 2000 DXF (including 2000i and 2002)

■ AutoCAD Release 12 DXF
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Exporting AutoCAD Architecture drawings to a DXF format provides more
consistent results than saving drawings as DXF files. Exporting creates a new
DXF file with all AEC objects exploded. The original drawing is not affected.

Depending on the size and complexity of the original drawing, the resulting
AutoCAD drawing may contain a large number of primitive objects, which
can affect drawing performance.

NOTE When you export a drawing to a DXF file, all AEC objects are exploded to
AutoCAD primitive objects. Reopening the file in the software does not restore
these primitive objects to AEC objects.

1 Click  ➤ Export ➤ AutoCAD.

2 Select the DXF format you want to use.

3 Enter a file name, and specify a path, if necessary.

The default file name includes any prefix or suffix that you
specified on the AEC Editor tab of the Options dialog box. For
more information, see Changing the AEC Editor Settings on page
197.

4 Click Save.
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Interoperability with Other
Applications

AutoCAD Architecture 2012 is compatible with other Autodesk software applications (such
as Autodesk® Land Desktop and Autodesk® DWF™ Viewer) as well as applications that are
IFC certified. Interoperability features expand the usability of AutoCAD Architecture. For
example, you can import LandXML data and use the topographical information to site your
building appropriately.

Importing and Exporting IFC Files
Based on established, international standards for common objects in the building
industry, the Industry Foundation Classes (IFC) file format provides an
interoperability solution between different software applications. Using IFC
reduces the loss of information when files are transmitted.

AutoCAD Architecture is IFC-certified for importing and exporting version 2x3
IFC files. IFC files from versions 2x2 and 2x can also be imported if the data is
compatible with 2x3 and is consistent with implementation agreements as
defined for the IFC 2x3 coordination view. For more detailed information, go
to http://www.buildingsmart.com/ and search for IfcWiki Web resource.

IFC certification enhances your ability to share project information across
disciplines and technical applications over the life of the project. Using the IFC
format, you can export these drawings to other IFC-certified applications that
could not otherwise open a DWG file. For example, building models drawn in
AutoCAD Architecture are saved to a DWG file format. You can export the
drawing using the IFC format. Likewise, you can import an IFC file to create
and work in a DWG that was originally created in a format other than DWG.

Visual fidelity for three-dimensional (3D) objects is maintained in model views.
This means that dimensions are maintained for 3D objects exported to IFC.

6
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Objects must be dimensionally accurate in the single IFC model because it is
shared by diverse applications.

For information about other methods of sharing drawings with external users,
see Sharing Drawings with AutoCAD Users on page 205.

For more information about importing and exporting IFC files, see Modeling
For IFC with AutoCAD Architecture.

General Information for Exporting Drawing Files to IFC
Only a currently active drawing can be exported to IFC. The export process
generates 2 files:

■ An IFC file that contains information specified for project number and
name, file path, and external references (xrefs).

■ A LOG file that contains data about information (objects and geographic
location) in the drawing. This file is stored in the same location as the IFC
file.

The current display configuration for the drawing being exported is what
defines the graphical information and geometry for the IFC file. Objects that
would typically display in the current display configuration are exported
regardless of whether their layers are frozen or turned off. For more
information, see Display Representations on page 803.

You can export a property set as an IfcElementQuantity if an object with a
property set definition has a suffix of IfcElementQuantity. The property set
definition must also include at least one property name with a value, such as
IfcQuantityArea, IfcQuantityCount, or IfcQuantityLength. This information
displays on the Extended Data tab of the Properties palette. For more
information, see Property Sets and Property Set Definitions on page 3743. The
IFC Quantity Information is only exported from AutoCAD Architecture to the
IFC file when the Quantity Add On option is selected in the Export Options
dialog.

You can use the property set definition template (IFC_Object_Attribute_Pset
definition.dwg) to assign various sample IFC object attributes to objects.
Attributes that are set directly by the IFC export process are not part of the
definition. This template can be found in the following location:
C:\ProgramData\Autodesk\ACA 2012\enu\Styles.

NOTE Ensure that the IFC_Object_Attribute_Pset_definition.dwg is under the IFC
content root path. You can configure this in the Options dialog > AEC tab.
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Spaces and their boundaries must be set to Associative if you want to export
space boundary information. For best results, use Associative Freeform Space
to achieve air tightness in a model. When there is a virtual boundary—a
boundary between spaces or a space with nothing in it—draw a line along the
expected boundary, and set Bound spaces as Yes. This space will be exported
as a Virtual space boundary in IFC. For more information, see Making a Space
Associative or Non-Associative on page 2972.

You can specify the geographic location of the project and the True North
direction using the AutoCAD geographic location. For more information, see
View the Geographic Location Information in the AutoCAD Help.

For AutoCAD MEP, IFC Type Classifications are mapped to MvPart Objects
(such as equipment, panels, and devices) automatically. This classification is
added in the Autodesk Catalog Editor by default. You can modify this
classification or add more classifications to the content library in the Autodesk
Catalog Editor.

AutoCAD Architecture Project Drawings
When you export a drawing file from an AutoCAD Architecture project folder,
the drawing file is mapped to (Ifc)Site by default if the drawing includes at
least one xref. The (Ifc)Site drawing may contain building objects and site
geometry as well as xrefs.

Identifying information displays by default in the project, including project
number, project name, and level assignments of xrefs, when you select a
project drawing for export.

You control which xrefs in the project file are exported and how they display
in the IFC file by either accepting the default level assignments or by specifying
a different label. All drawings that are assigned to the same IFC Structure are
exported into an IfcBuildingStorey in the IFC file. For more information about
working with AutoCAD Architecture projects, see Concepts of Drawing
Management on page 305.
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Exporting a Drawing from an AutoCAD Architecture Project
Use this procedure to export a project drawing as an IFC file. Select the drawing
from the Constructs, Views, or Sheets tab of Project Navigator.

Xrefs contained in the drawing being exported are listed in the tree view below
the drawing name. If they were unloaded in the drawing, they are shaded in
the Export to IFC dialog. For more information, see Before You Begin: External
References on page 314.

If the drawings were assigned to levels as part of the AutoCAD Architecture
project, a corresponding label is displayed by default under IFC Structure.
Otherwise, they are mapped to Level 1 by default.

If there are objects you want to classify as a different type of object for export,
the drawing with the classified objects must have been previously saved. For
more information, see Classifying AEC Objects for Export on page 232.

1 On the Constructs, Views, or Sheets tab in Project Navigator, open
the drawing that you want to export as an IFC file.

2 Click  ➤ Export ➤ IFC (Industry Foundation Classes).
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Alternatively, on the command line, enter -IfcExport, and select
export options.

3 In the Export to IFC dialog, the project number and project name
display by default. Modify these if necessary.

4 If you want to change the default value for Create IFC File Named,
enter a new name; or click Browse, navigate to the file, and select
it.

5 Under Drawing Files, select the drawing files to be exported.

If you select an xref at the top level, all xrefs nested within this
drawing are selected as well. Expand the top level, and select xrefs
individually if necessary.

6 If you want to change the labels for the drawing files selected,
click the label in the IFC Structure column, and select a different
level from the drop-down list, or enter text in the field.
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If you want xrefs to display as a distinct level within the IFC file,
specify different identifying labels under IFC Structure. You can
specify the same identifier, such as Level (1), for multiple xrefs to
combine the objects within those xrefs into one IfcBuildingStorey.

7 Enter a description of the file for export.

You can select multiple drawing files and change all labels or
descriptions at the same time.

Specify Export Options

8 Click Options, and click the Header tab.

The name of the drawing active on your screen displays on the Header tab of
the IFC Export Options dialog. You can add information about the drawing
file to be exported, such as a description of the drawing, the author and
company name, authorization data, and the geographic location of the
building. For example, you could enter the description of a structural drawing
as Structure for Commercial Building 152 on the Header tab. This information
displays in the header of the IFC file when the file is viewed.

Other data is exported with the drawing by default and includes the name of
the source drawing file and the name and version of the application in which
it was created.

9 Enter information to include, then click the Objects tab.
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You can select or exclude objects for export with the drawing file.
When the IFC file is viewed, the only objects included will be
those that you selected. For example, you could select Slab and
Structural Member and exclude all other objects from exporting.

When you specify export options for your objects, the following
constraints apply:

■ The classification of an object takes precedence over the object
type. For example, if you classify a mass element as a ramp
and then export the drawing without Mass Element selected
on the Objects tab, the newly-classified mass element is not
included in the export process.

■ Any changes you make to either tab in the IFC Export Options
dialog, become the new default settings.

■ For selected objects to be exported, their display
representations must be active in the current display
configuration.

10 Select objects to include, and click OK.

11 Click the Address tab.
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Edit the IFC site address data to be exported and imported.

Specify the IFC address and the properties for IFC buildings.

IFC export process collects the data in the Address tab on the
model space block and includes it in the IFC file. This data is
attached to the IFC file when imported.

12 Click the View tab.
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13 Click Quantity Add On to export quantity property sets (including
the names and their values) as IfcQuantity.

14 Click Space Boundary Add On to export space boundary
information (including the boundary geometry) to IFC.

15 Under Space Boundary Add On, click one of the following:

■ Level 1: Calculates and defines the external boundary of a
space.

■ Level 2: Identifies and calculates internal and external space
boundaries between two or more space boundaries.

To determine the correct space boundary:

■ The space must be fully enclosed.

■ The surface must always point outward from the space (into
the material).

■ The space Boundary can only be created on associative spaces.

16 Click OK.

Exporting Standalone Drawings
Drawings created outside of an AutoCAD Architecture project can be exported
to an IFC file with or without xrefs.

■ If you are exporting a drawing file that contains xrefs, the host drawing
file is mapped to (Ifc)Site by default. The (Ifc)Site file may contain building
objects and site geometry as well as xrefs.

■ If you are exporting a drawing that does not contain any xrefs, all of the
objects in the drawing are contained in (Ifc)Building. The IFC file will not
contain an IfcSite or an IfcBuildingStorey. Without IfcSite, geographic
location information, such as longitude and latitude, cannot be exported.
This information is tracked in the LOG file. For more information, see
General Information for Exporting Drawing Files to IFC on page 214.

Exporting a Drawing with External References
Use this procedure to export a drawing as an IFC file and include selected
xrefs. The drawing for export must be active on your drawing screen. It is
mapped to (Ifc)Site by default.
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If there are objects you want to classify as a different type of object for export,
the drawing with the classified objects must have been previously saved. For
more information, see Classifying AEC Objects for Export on page 232.

Xrefs contained in this drawing are listed in the tree view below the drawing
name, and are mapped to Level (1) by default. If the xrefs are missing in the
drawing, they are unavailable in the Export to IFC dialog. The icon next to
the file name indicates if the xref is unloaded in the host drawing.

1 Open the drawing that you want to export as an IFC file.

2 Click  ➤ Export ➤ IFC (Industry Foundation Classes).

Alternatively, on the command line, enter -IfcExport, and select
export options.

3 In the Export to IFC dialog, for Project Number, enter a project
number for the drawing.

4 The name of the drawing being exported displays for Project Name
by default. Modify this, if necessary.

5 To change the default value for Create IFC File Named, click
Browse, navigate to the desired file, and select it.
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6 Under Drawing Files, select the drawing files to be exported.

If you select an xref at the top level, all xrefs nested within this
drawing are selected as well. Expand the top level, and select xrefs
individually if necessary.

7 To change the label in the IFC Structure column, select or add a
different level from the drop-down list, or enter text in the field.

If you want xrefs to display as a distinct level within the IFC file,
specify different identifying labels. You can specify the same
identifier, such as Level (1), for multiple xrefs to combine the
objects within those xrefs into one IfcBuildingStorey.

8 Enter a description of the file for export.

You can select multiple drawing files and change all labels or
descriptions at the same time.

Specify Export Options

9 Click Options, and click the Header tab.

General Information for Exporting Drawing Files to IFC | 223



The name of the drawing active on your screen displays on the Header tab of
the IFC Export Options dialog. You can add information about the drawing
file to be exported, such as a description of the drawing, the author and
company name, authorization data, and the geographic location of the
building. For example, you could enter the description of a structural drawing
as Structure for Commercial Building 152 on the Header tab. This information
displays in the header of the IFC file when the file is viewed.

Other data is exported with the drawing by default and includes the name of
the source drawing file and the name and version of the application in which
it was created.

10 Enter information, then click the Objects tab.
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You can select or exclude objects for export with the drawing file.
When the IFC file is viewed, the only objects included will be
those that you selected. For example, you could select Slab and
Structural Member and exclude all other objects from exporting.

When you specify export options for your objects, the following
constraints apply:

■ The classification of an object takes precedence over the object
type. For example, if you classify a mass element as a ramp
and then export the drawing without Mass Element selected
on the Objects tab, the newly-classified mass element is not
included in the export process.

■ Any change you make to either tab in the IFC Export Options
dialog, become the new default settings.

■ For selected objects to be exported, their display
representations must be active in the current display
configuration.

11 Select the objects for export, and click OK.

12 Click the Address tab.
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Edit the IFC site address data to be exported and imported.

Specify the IFC address and the properties for IFC buildings.

IFC export process collects the data in the Address tab on the
model space block and includes it in the IFC file. This data is
attached to the IFC file when imported.

13 Click the View tab.

226 | Chapter 6   Interoperability with Other Applications



14 Click Quantity Add On to export quantity property sets (including
the names and their values) as IfcQuantity.

15 Click Space Boundary Add On to export space boundary
information (including the boundary geometry) to IFC.

16 Under Space Boundary Add On, click one of the following:

■ Level 1: Calculates and defines the external boundary of a
space.

■ Level 2: Identifies and calculates internal and external space
boundaries between two or more space boundaries.

To determine the correct space boundary:

■ The space must be fully enclosed.

■ The surface must always point outward from the space (into
the material).

■ The space Boundary can only be created on associative spaces.

17 Click OK.

Exporting a Drawing Without External References
Use this procedure to export a drawing as an IFC file when the drawing does
not contain xrefs. The drawing for export must be active on your drawing
screen. It is mapped to (Ifc)Building by default.

If there are objects you want to classify as a different type of object for export,
the drawing with the classified objects must have been previously saved. For
more information, see Classifying AEC Objects for Export on page 232.

1 Open the drawing that you want to export as an IFC file.

2 Click  ➤ Export ➤ IFC (Industry Foundation Classes).

Alternatively, on the command line, enter -IfcExport, and select
export options.

3 In the Export to IFC dialog, for Project Number, enter a project
number for the drawing.

4 The name of the drawing being exported displays for Project Name
by default. Modify this, if necessary.
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5 If you want to change the default value of where the IFC file is
exported, click Browse, navigate to the desired file, and select it.

6 Enter a description of the file for export.

You can select multiple drawing files and change all labels or
descriptions at the same time.

Specify Export Options

7 Click Options, and click the Header tab.
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The name of the drawing active on your screen displays on the Header tab of
the IFC Export Options dialog. You can add information about the drawing
file to be exported, such as a description of the drawing, the author and
company name, authorization data, and the geographic location of the
building. For example, you could enter the description of a structural drawing
as Structure for Commercial Building 152 on the Header tab. This information
displays in the header of the IFC file when the file is viewed.

Other data is exported with the drawing by default and includes the name of
the source drawing file and the name and version of the application in which
it was created.

8 Enter information, and click the Objects tab.
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You can select or exclude objects for export with the drawing file.
When the IFC file is viewed, the only objects included will be
those that you selected. For example, you could select Slab and
Structural Member and exclude all other objects from exporting.

When you specify export options for your objects, the following
constraints apply:

■ The classification of an object takes precedence over the object
type. For example, if you classify a mass element as a ramp
and then export the drawing without Mass Element selected
on the Objects tab, the newly-classified mass element is not
included in the export process.

■ Any changes you make to either tab in the IFC Export Options
dialog, become the new default settings.

■ For selected objects to be exported, their display
representations must be active in the current display
configuration.

9 Select the objects for export, and click OK.

10 Click the Address tab.

230 | Chapter 6   Interoperability with Other Applications



Edit the IFC site address data to be exported and imported.

Specify the IFC address and the properties for IFC buildings.

IFC export process collects the data in the Address tab on the
model space block and includes it in the IFC file. This data is
attached to the IFC file when imported.

11 Click the View tab.
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12 Click Quantity Add On to export quantity property sets (including
the names and their values) as IfcQuantity.

13 Click Space Boundary Add On to export space boundary
information (including the boundary geometry) to IFC.

14 Under Space Boundary Add On, click one of the following:

■ Level 1: Calculates and defines the external boundary of a
space.

■ Level 2: Identifies and calculates internal and external space
boundaries between two or more space boundaries.

To determine the correct space boundary:

■ The space must be fully enclosed.

■ The surface must always point outward from the space (into
the material).

■ The space Boundary can only be created on associative spaces.

15 Click OK.

Classifying AEC Objects for Export
Using classification definitions allows you to assign three-dimensional AEC
objects as different object types. This is helpful if you want to export the object
in your drawing as something different for the IFC file. For example, you can
draw a mass element, and classify it as a specific object type. For more
information about assigning classifications to objects, see Classification
Definitions on page 3872.

When you work in AutoCAD MEP environment, any classification applied to
MEP objects are ignored during export as they are exported intelligently to
their associated IFC entities.

A drawing file of classifications (that can be used for objects at export) is
available in the software and can be found in ProgramData\Autodesk\ACA
2012\enu\Styles\IfcPropertySet_Definition.dwg.

IMPORTANT IfcSiteGeometry is a unique classification. This classification can be
applied to any object, but the object must be in an IfcSite drawing for the
classification to be retained when exported. If it is not an IfcSite drawing (the IFC
structure for drawings with xrefs attached), the IfcSiteGeometry classification is
not preserved when exported to IFC.

232 | Chapter 6   Interoperability with Other Applications



Use this procedure to classify an AutoCAD Architecture 3D object to display
as something different in the IFC file.

1 Open the drawing that contains the objects you want to classify
for export.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 In Style Manager, click  (open drawing).

4 In the Open drawing dialog, navigate to
C:\ProgramData\Autodesk\ACA
2012\enu\Styles\IfcPropertySet_Definition.dwg, and click Open.

5 In the Style Manager, expand the IFC drawing file, expand
Multi-Purpose Objects, and expand Classification Definitions.

6 Right-click Classification Definitions, and click Copy.

7 Select the drawing into which to add the IFC classifications (the
drawing opened in step 1), right-click, and click Paste.

8 Click OK.

9 Click the Applies To tab.

10 Select the objects you want the classification definition to apply.

11 Click OK to close Style Manager.

12 In the drawing area, select the objects to classify.

13 Open the Properties palette, and click the Extended Data tab.
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14 On the Classification panel, click IFCObjectClassification and
select the classification.

15 Click OK.

16 Save your drawing before exporting it to an IFC file.
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For more information, see General Information for Exporting
Drawing Files to IFC on page 214.

IMPORTANT Save this drawing file with the classifications before
exporting the file as either the host drawing or an xref.

Exporting this drawing in IFC file format also exports the classification
definitions. The classification definition is attached to the object type when
you import the drawing.

Importing and Exporting IFC Classifications
AutoCAD Architecture supports classification definitions that allow styles and
objects to be classified. The IFC import and export processes support these
classifications assigned to style and objects.

To support the export and import of IFC Classifications

1 Open a new drawing and draw a wall.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Expand your drawing  ➤  Multi-Purpose Objects  ➤  Classification
Definitions.
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4 Right-click Classification Definitions and select New.

5 Rename New Style to Wall.

6 In the Applies To tab, click Wall.

7 In the Classification tab, click Add.
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8 Expand Wall and select New Classification.

9 Under Item, enter brick; under Description enter brown and red.

10 Click Apply.

11 Click OK.

12 In the drawing, select the wall.

13 Right-click and select Properties.
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14 In the Properties palette, Extended Data tab, under Classification, select
the button near Wall.

15 In the Select Classification dialog, select Brick - Brown and Red.

16 Click OK.
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Exporting and Importing IFC ZIP Files
AutoCAD Architecture now supports ZIP files when both exporting and
importing IFC files.

To export IFC ZIP files

1 Click Application menu  ➤  Export  ➤  IFC (Industry Foundation Classes).

2 In the Export to IFC dialog, click Browse.

3 In the Export IFC File dialog, select IFCZIP file (*ifczip) from the Files of
Type drop-down list.

4 Click Save.

5 In the Export to IFC dialog, specify the Project Number, and click Export.

To import IFC ZIP files

1 Click Application menu  ➤  Open  ➤  IFC (Industry Foundation Classes).

2 Under IFC File to Import, click Browse.

3 In the Select File dialog, select IFCZIP file (*ifczip) from the Files of Type
drop-down list.
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4 Navigate to the IFC ZIP file.

5 Click Open.

6 In the Import IFC File and Create Drawings dialog, click Create.

7 The IFC ZIP file is extracted and imported.

Using a Property Set Definition Samples
When exporting an AutoCAD Architecture model as an IFC file or importing
an IFC file into AutoCAD Architecture, some of the object attributes in IFC
entities cannot be mapped directly to AutoCAD Architecture object properties.

The Property Set definition sample has a set of IFC object attributes (style and
object type) applied to AutoCAD Architecture objects. This allows you to set
the required values in the property sets used for exporting IFC files. These
values are exported without any extra processing or interpretation.

During import, the same property set definition is used to capture and preserve
IFC object attributes that cannot be mapped directly in the AutoCAD
Architecture properties.

This template can be found in the following location:

C:\ProgramData\Autodesk\ACA\enu\Styles\IFC_Object_Attribute_Pset_definition.dwg

In the Property Set Definition template:

■ Only simple attributes are listed.

■ IFC object attributes that can be mapped directly to AutoCAD Architecture
object properties during the IFC export process are not defined in the
template.

To map IFC object attributes to AutoCAD Architecture Property Set (entity
and object type)

1 Open a drawing and draw a beam.
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2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 In the Style Manager, click File  ➤  Open.

4 Navigate to the following:

C:\ProgramData\Autodesk\ACA\enu\Styles\IFC_Object_Attribute_Pset_definition.dwg

5 Expand IFC_Object_Attribute_Pset_definition.dwg and navigate
to Documentation Objects  ➤  Property Set Definitions.

6 From the object attribute list displayed, select IfcObjectAttribute
[IfcBeam].

7 Right-click and select Copy.

8 Select the drawing (the drawing opened in step 1) to add the
property set definitions.

9 Click Paste.

10 Select the beam.

11 Right-click and select Properties.
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12

13 In the Extended Data tab, click the Add Property Set button.

14 Select IfcObjectAttribute [IfcBeam] and click OK.
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You can now assign specific IFC attributes for IfcBeam using the
property set IfcObjectAttributes [IfcBeam].

Supporting Space Containment when Exporting and Importing
IFC Files

Space containment is achieved using a location property in the property set
definition. Ensure that you have the correct containment information before
defining it in the IFC file.

You can use the following property set definition sample to define space
containment: C:\ProgramData\Autodesk\ACA
2012\enu\Styles\IfcPropertySet_Definition.dwg

Ensure that the property set is included in all drawings that contain the object
and space.

To support space containment when exporting and importing IFC files
1 Open a new drawing and draw an object (such as MV Block -

conference table) contained in a space.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 In the Style Manager, click File  ➤  Open.

4 Navigate to the following:

C:\ProgramData\Autodesk\ACA\enu\Styles\IfcPropertySet_Definitions.dwg

5 Expand IfcPropertySet_Definitions.dwg and navigate to
Documentation Objects  ➤  Property Set Definitions.
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6 From the property set definition list displayed, select
IfcSpaceContainment

7 Right-click and select Copy.

8 Select the drawing (the drawing opened in step 1) to add the
Property Set Definitions.

9 Click Paste.

10 From the property set definition list, select IfcSpaceContainment.

11 In the Applies To tab, select the Multi-View Block Reference and
click Apply.
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12 Expand IfcPropertySet_Definitions.dwg and navigate to
Documentation Objects  ➤  Property Set Definitions.

13 From the property set definition list, select SpaceObjects.

14 Right-click and select Copy.

15 Select the drawing (the drawing opened in step 1) to add the
Property Set Definitions.

16 Click Paste.

17 In the drawing, select the space.

18 Right-click and select Properties.
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19 In the Properties palette, click Add Properties Set.

20 In the Add Properties Set dialog, select SpaceObjects and click OK.
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21 Select the conference table.

22 In the Properties set, click Add Properties Set.

23 In the Add Properties Set dialog, select IfcSpaceContainment and
click OK.
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24 A Property Data Location point is displayed on the conference
table.

Click the image to start the animation.

25 Select the Property Data Location point displayed on the
conference table and drag it to reference the correct space.

26 Save your drawing before exporting it to an IFC file. For more
information, see General Information for Exporting Drawing Files
to IFC on page 214.

IMPORTANT Save this drawing file with the classifications before
exporting the file as either the host drawing or an xref.

When you export this drawing as an IFC file, the classification definitions are
exported. When you import the drawing, the classification definitions are
attached to the object type.

How IFC Files Are Imported
When you import an IFC file, drawing files are created that correspond to
each part of the IFC project structure. The files are xrefed together into a main
host file that represents the entire IFC file. The import process also creates a
LOG file which contains object and geographic location information. This
file is stored in the same location as the imported IFC file. IFC files can be
imported into an AutoCAD Architecture project or as standalone drawings.
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You may need to turn on some display components of objects (such as surfaces
of spaces) for them to display after you import an IFC file. For more
information, see Display Representations on page 803.

When you import an IFC file, you specify a name for the drawing that is being
created from the IFC file. This drawing contains xrefs only. For example,
importing an IFC file and naming it Small Office Building, creates a DWG file
called Small Office Building.dwg, which contains all of the xrefs that
correspond to each part of the project structure contained in the IFC file.
During the import process, the following occurs:

■ A site drawing is created with field information if it existed in the IFC file.
If the IfcSite file does not have a name assigned, a site drawing file is created
with –Site appended. If there is an IfcSite name specified in the IFC file, a
default drawing is created with the name of Site.dwg. The geographic
location is imported by default if the IfcSite file contained the latitude and
longitude of the site. (The geographic information for a drawing with
multiple xrefs is determined by the host drawing.) You can see this
information in the Geographic Location dialog. For more information, see
View the Geographic Location Information in the AutoCAD Help.

■ The import process applies a name to the project or drawing file:

Then…If the IFC file is imported
as…

the IfcBuilding name is used with the name of the
project. (Note that AutoCAD Architecture uses the

an AutoCAD Architecture pro-
ject

project name (that you specified in the Export to
IFC dialog) as the IfcBuilding name. This is notice-
able if you are importing an IFC file that originated
in AutoCAD Architecture.)

the drawing is created with the original project
name appended. Using the Small Office Building

standalone drawings
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Then…If the IFC file is imported
as…

example, the drawing name would be Small Office
Building-Commercial Project.dwg because Commer-
cial Project was the IfcBuilding name in the IFC file.

■ A drawing is created for each IfcBuildingStorey contained in the IFC file.
The files are created using the drawing name with the name of the IfcStorey
appended. These files are referenced into the project file.

■ Objects in files with colors specified as 0, 0, 0 or 255, 255, 255 display with
the AutoCAD Color Index (ACI) 7 assigned by default.

Architectural Objects and IFC
As shown in the following table, most common building objects imported
from an IFC file are created as the corresponding AutoCAD Architecture objects
in the resulting drawing file. However, in the case of an IFC object with
complex geometry that does not directly correspond to the components of
its AutoCAD Architecture counterpart, a custom display block is created in
the model display representation. Therefore, 3D geometry in the Model display
representation may not always correspond exactly to the Plan display
representation. For more information, see Display Representations on page
803.

AutoCAD Architecture creates a…When you import an…

BeamIfcBeam

ColumnIfcColumn

Curtain wallIfcCurtainWall

DoorIfcDoor

Multi-view blockIfcElementAssembly

OpeningIfcOpening

BraceIfcMember

Multi-view blockIfcRailing
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AutoCAD Architecture creates a…When you import an…

Multi-view blockIfcRamp

Multi-view blockIfcRoof (object with geometry)

SlabIfcSlab

Roof slabIfcSlab (object with predefined type of
Roof or an aggregate of slabs such as a
gabled roof)

SpaceIfcSpace

Multi-view blockIfcStair

WallIfcWall

WallIfcWallStandardCase (an upright wall
with uniform thickness)

WindowIfcWindow

Multi-view blockIfcBuildingElementProxy (for example,
IFC objects that represent furniture)

When you import all other IFC objects with a 3D geometric representation
(for example, IFC objects that represent pipes or ducts), AutoCAD Architecture
creates a multi-view block.

Options for Importing AEC Objects
When you import an IFC file, you can specify objects to import. For example,
if you want to create a drawing file that displays only the curtain walls from
the IFC file, you can clear all other objects listed in the IFC Import Options
dialog. When the drawing is viewed, the only objects included will be those
that you selected.
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Style names stored in the IFC file display on the Properties palette and in Style
Manager. If there are no specific style names in the IFC file, style names are
created incrementally, such as IFCSTYLE(0).

You can specify how and when styles are created if there are multiple styles
with the same name in the IFC file. They can either display incrementally
with a number suffix or display with the name first encountered, regardless
of whether the styles are the same, during the import.

Importing an IFC File
Use this procedure to import an IFC file. When you select an IFC file to import,
you specify whether to create the drawings in an AutoCAD Architecture project
or as a set of standalone drawings.

1 Click  ➤ Open ➤ IFC (Industry Foundation Classes).
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2 In the Import IFC File and Create Drawings dialog, click Browse
for IFC file to import, navigate to the desired IFC file, and select
it.

3 Specify if the imported file is to be part of a project:

Then…If you want to…

select Create a project, and enter a folder
name for Create project under folder; or click

import the file and create
a project and project
drawings Browse, navigate to the desired folder, and

select it.
The drawings are imported with the structure
of an AutoCAD Architecture project. For more
information, see Concepts of Drawing Man-
agement on page 305.

enter a drawing name for Create drawings
named; or click Browse, navigate to the de-
sired file, and select it.
Unless you specify otherwise, the drawing is
created at the same location as the IFC file.

import the file as stan-
dalone drawings

4 If you want to change the default value for Create Drawings from
Template, click Browse, navigate to the desired DWT file, and
select it.

If the template (DWT file) you select does not have the same units
as the IFC file being imported, you are given the choice to
continue with that template or select a different template. If you
choose to continue with the selected template, the units in the
IFC file will override the units in the template file.
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NOTE The template you select becomes the new default template.

5 Click Options to specify import options, then click OK:

Then…If you want to…

under Select objects to import from IFC file,
check the objects to import or clear objects

change the default value
of importing all objects to

to omit. Click Select All and Clear All to assistselecting specific objects
to import with the selection. For more information, see

Options for Importing AEC Objects on page
251.

select Create new style with unique name.
For more information, see Options for Import-
ing AEC Objects on page 251.
If multiple occurrences of the same style
name exist, a number displays incrementally
at the end of the name.

have a new style name
created to correspond
with each instance of the
style name in the IFC file

select Use the first style encountered with
the same name. For more information, see

use the first instance of
the style name for all ob-
jects Options for Importing AEC Objects on page

251.
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6 Click Create:

Then…If you…

the Project Navigator opens on your drawing
screen. Use Project Navigator to browse the

specified Create project
drawings when you im-
ported the IFC file project drawings created at import. For more

information, see Workflow for a Project Envir-
onment on page 303.

click Yes.created standalone draw-
ings and want to view
the top-level drawing

click No.created drawings outside
of an AutoCAD Architec-
ture project and want to
view a different drawing

If there is a component of an object that does not display after
you import an IFC file, open the display representation for the
object, and on the Layer/Color/Linetype tab, turn on the display
component by selecting the light bulb icon under Visible. For
more information, see Display Representations on page 803.

IMPORTANT If AutoCAD Architecture runs out of memory during
import, a message displays on the command line, and the import
process fails. Continuing to use AutoCAD Architecture under these
conditions may affect subsequent work. The correct procedure is to
close and then restart the application. You can then retry the import
after:

■ Closing all other applications.

■ Limiting the objects for import in the IFC Import Options
dialog.

■ Switching to a 64-bit system.

Importing Building Components from Autodesk Inventor
AutoCAD Architecture 2012 can import data from Autodesk Inventor. This
capability allows designers of manufactured mechanical building system
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components and architectural elements to export digital design geometry
without the loss of data. This data can then be imported by architects designing
buildings and mechanical systems with AutoCAD Architecture.

Previously, exporting a building component from Inventor incurred some loss
of information when the data was imported into AutoCAD Architecture. Such
information loss may be necessary to protect the intellectual property of the
designer of the manufactured item, or to reduce the complexity and size of
the data being passed to the architectural or engineering model. To achieve
the desired level of information in the exported data, Inventor now employs
a custom data reduction of the architectural or engineering model.

Export Requirements in Autodesk Inventor

In order for a building component to be correctly imported into AutoCAD
Architecture, it must be prepared for export in Autodesk Inventor, and be
saved as a Building Component Autodesk Exchange file (*.adsk). For more
information, consult the Inventor User Guide.

Import Format

When you import an Inventor building component into AutoCAD
Architecture, you can choose whether the component is imported as a
multi-view block or a block.

Changing the UCS During Import

When importing building components from Inventor into AutoCAD
Architecture, you can change the original UCS. For example, a building
component could have been designed in Inventor using a coordinate system
with the X and Z axes as the horizontal ground plane axes and the Y axis as
the vertical axis. When importing into AutoCAD Architecture however, a
different coordinate system with the X and Y axes as the horizontal ground
plane axes and the Z axis as the vertical axis is needed, in order to avoid
importing the component lying on its back. In this case, the UCS can be
changed during the import of the part.

Re-Importing Components

If a building component has been imported into AutoCAD Architecture, and
then a change is made to the original file, then on re-import you can choose
whether the existing multi-view block or block is overwritten with the updated
component, or whether the new version should be imported as a new block
or multi-view block.
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Importing a Building Component into AutoCAD Architecture
Use this procedure to import an Inventor building component into AutoCAD
Architecture.

1 Click Insert tab ➤ Content panel ➤ Content Browser

drop-down ➤ Building Component  .

Inserting an Inventor component as a multi-view block

2 In the Import Building Component dialog, select the Autodesk
Exchange Format file (*.adsk) that you want to import.

3 Select if you want to import the component as a block or a
multi-view block.

This opens the Import dialog where you can specify a name,
description, and change the orientation of the block or multi-view
block during insertion.
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4 When inserting a single block, the image in the viewer will be the
block that is inserted, i.e front, top, etc. Any axonometric view
will insert the 3D block.

If necessary, use the ViewCube in the preview window to display
the component in the desired view.

5 Use the Rotate buttons to rotate the model around its X, Y, or Z
axis when inserted into the drawing.

6 Do one of the following:

■ If you are inserting a multi-view block, click Add. Then specify
the insertion point in the drawing.

■ If you are inserting a block, click either Insert (to insert the
block reference), or Insert All (to insert the block reference
plus separate graphical representations of all the view
directions). This is recommended if you want to build a block
library and add the block to that. Then, specify the insertion
point, the X and Y scale, and the rotation.

Depending on whether the component was inserted as a block or
multi-view block, you have different options for editing it in
AutoCAD Architecture. For information on multi-view blocks, see
Multi-View Blocks on page 2891. For information on blocks, see
“Create and Use Blocks (Symbols)” in the AutoCAD Online help.

Importing LandXML
LandXML data can be imported and converted to objects. LandXML is the
standard XML data format for civil engineering and survey data used in the
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land development and transportation industries. LandXML provides a data
format suitable for long-term data archiving and offers a standard format for
electronic design submission.

With LandXML, building professionals can extend the downstream value of
their data from design to construction, and for scheduling and maintenance
by using a format that can be read by many applications.

LandXML files are based on the LandXML schema, an XML schema definition
for civil and survey data.

Residential area layout from Autodesk® Land Desktop

NOTE For more information about LandXML, visit http://www.landxml.org.

You cannot convert AutoCAD Architecture objects to LandXML data or export
DWG files to the LandXML format.

Schema Version
To import LandXML files, create them with the LandXML schema version
1.1. Note that LandXML files created with earlier versions of LandXML (for
example version 0.88) cannot be imported. You can download the latest
version of the LandXML schema from http://www.landxml.org.
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Supported Data Types
AutoCAD Architecture can read and convert the following LandXML data
types:

■ Parcels

■ COGO points

■ Surfaces

Parcels

Parcels are two-dimensional shapes created from closed lines, arcs, and
polylines. When a parcel is imported, the parcel name and the lines (segments)
and curves (arcs) that make up the parcel boundary are used for the conversion.

Parcels in a street layout from Autodesk® Land Desktop

You can convert parcels to spaces or polylines. When you convert parcels to
spaces, you can define a space style that is applied to the spaces generated
from the parcels, and the parcel name is used as the space name. When the
parcel is converted to a polyline, the parcel name is lost.

Parcel data in LandXML
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COGO (Coordinate Geometry) Points

You can import LandXML COGO (Coordinate Geometry) points and convert
them to AutoCAD points.

Civil engineers create COGO points to locate crucial surveying locations. A
COGO point can be a project benchmark point - a common datum that the
entire civil team works off and from which all critical dimensions are located.

NOTE A LandXML file usually contains a large number of COGO points. In most
cases, you need only a small set to work within the drawing. You do not need to
import all COGO points, only those that have a special meaning for the drawing.

COGO points are the foundation for any civil engineering or surveying project.
In Land Desktop, you can use description keys to place points in the drawing
with symbols on specific layers. When importing a LandXML file you can
map selected points to the appropriate layer.

When a COGO point is imported it is defined by its coordinates in the form
of “northing easting” or “northing easting elevation.”

For example, a COGO point could be represented as: <CgPOINT NAME="1"
DESC="MYPOINT">248.04605951 359.53997314 1.000000</CgPOINT>.

COGO points on a map

NOTE Autodesk Land Desktop uses two coordinate systems for locating points:
X,Y and northing/easting. When you start a new project, these values all default
to 0 so that the Y coordinate is the same as the northing, and the X coordinate is
the same as the easting. Unless you change that in Land Desktop before exporting
a drawing to LandXML, the exported northing value will be identical to Y and the
exported easting value will be identical to X.

Surfaces

In most surveying and civil engineering operations, you gather information
about elevations to generate surface contours that represent a model of the
ground surface. The surfaces in LandXML are made up of many faces which
are either TINs (Triangular Irregulated Networks) or quadrilaterals. Points or
contours are usually a primary part of the original surface information and
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are supplemented with break lines and boundaries. You can create a surface
in LandXML, and then import it. It is converted to a Free Form mass element.

In the following cases, importing surfaces can create errors or fail altogether:

■ Surfaces with vertical faces

■ Surfaces with tiny gaps between the individual faces

■ Surfaces with very narrow faces

If the import fails, an error message is displayed on the command line, such
as “Failed to create mass element from terrain.”

Surface model in Autodesk® Land Desktop

A surface model is usually a complex structure with many defining points and
faces. When you convert a surface model to a Free Form mass element, the
points and faces are merged into one composite mass element body.

Surface model detail
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A Free Form mass element contains a large number of grips. Displaying all
grips can slow down the performance and be unnecessary for using the mass
element. There are two ways to control the display of grips on mass elements:

■ By default, the grips on a Free Form mass element are only displayed if
their number does not exceed 2000 grips per element.

■ You can turn off the display of grips in the drawing altogether if you click

 ➤ Options, then click the Selection tab, and under Grips, clear
Enable Grips.

A surface in the LandXML Schema contains information about the surface
name, type, 2D and 3D area, and the maximum and minimum elevations. It
also contains information about each of the points and faces that comprise
the surface. The surface information is merged into one composite mass
element body, which can have thousands of faces. Applying a surface hatch
or texture map to a complex mass element can be quite time-consuming.

Surface data in LandXML

File Validation
When you import a LandXML file, the file is automatically validated before
it is imported and opened. The LandXML file has to conform to the LandXML
1.1 schema definition to be used.

Importing LandXML Data
Use this procedure to import LandXML data.
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When you import a LandXML file, you can select different object types to
import. For a complete list, see Supported Data Types on page 260. Depending
on the object type, you can define additional conversion parameters. For
example, if you want to import LandXML parcels, you can choose to convert
them to space objects or standard polylines.

NOTE A LandXML file contains information about the drawing units in which it
is measured. When you import a LandXML file into a drawing with different units,
the LandXML data is converted to the units in the current DWG. When a LandXML
file based on meter units is imported into a drawing based on millimeters, the
resulting coordinates may exceed the range in which accurate calculations can be
made.

1 Click Insert tab ➤ Import panel ➤ Land XML.

2 Select a LandXML file to import, and click Open.

NOTE If you have selected an invalid LandXML file, an XML file not
based on the LandXML Schema, or an XML file based on a LandXML
Schema version earlier than 1.1, you receive an error message and
cannot import the file. Select another file that conforms to the
LandXML 1.1 schema, or update the existing file accordingly.

3 Select the import options.
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Then…If you want to…

select Surfaces. This selects all surfaces from the
imported file. To import only individual surfaces,

import surfaces from
the LandXML file

expand Surfaces, expand Collection, and then
select the surfaces you want to import.

select Parcels. This selects all parcels from the
imported file. To import only individual parcels,

import parcels from
the LandXML file

expand Parcels, expand Collection, and then
select the parcels you want to import.

select CgPoints. This selects all COGO from the
imported file. To import only individual points,

import COGO points
from the LandXML file

expand CgPoints, expand Collection, and then
select the points you want to import.

4 If you are importing parcels, indicate the form to which you want
them converted by selecting either Space Objects or Polylines.
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Parcels converted to spaces (left) and polylines (right)

5 If you want to clip the surface model using the boolean union of
all parcels as the model boundary, select Clip Surface Model at
Combined Parcel Boundary.

If this check box is selected, you can also enter an offset from the
boundary.

6 Enter a value for Model Base.

This creates an extrusion of the surface outer boundary from the
value you enter starting at the lowest surface point.

7 If you want to generate contours from the surface data you are
importing, select Generate Contours from Surfaces.

NOTE If you want to see the actual surfaces of the converted mass
element, such as a TIN model, you can display the mass element
without Gouraud shading.

8 Indicate how you want the contours to be created by selecting
either Polylines or Slice Objects.

9 Enter an interval value for the vertical spacing of the contours.

NOTE Because slice objects shade their entire area, they can interfere
with the appearance of the surface itself in shaded or hidden line
views.

10 Click Import.
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Selecting Layer Keys for LandXML Data
Use this procedure to set a default layer key for the different types of LandXML
data being imported. You can set layer keys individually for COGO points,
parcels, surfaces, and contour lines.

If you do not define specific layer keys for your LandXML data, the imported
data is placed on the default layer keys specified for LandXML data, TINN
(Surfaces), PRCL (Parcels), COGO (COGO Points), and TOPO (Contours).

You can also define a specific space style for parcels that are imported as spaces.

1 Click Insert tab ➤ Import panel ➤ Land XML.

2 Select a LandXML file to import, and click Open.

3 Click Defaults.

4 Select a layer key default for the imported objects.

Then…If you want to…

click Surfaces.select a layer key default for im-
ported surfaces

click Parcels.select a layer key default for im-
ported parcels

click COGO points.select a layer key default for im-
ported COGO points

click Contours.select a layer key default for im-
ported contours

5 Select a layer key, and click OK.
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6 If you want to import LandXML parcels as spaces, select a space
style and a style location if necessary.

7 Click OK.

8 Import your LandXML data as described in Importing LandXML
Data on page 263.

Publishing Drawing Files to Autodesk MapGuide
You can publish objects and property set data to the Autodesk MapGuide®

product suite.

The MapGuide product suite provides the tools to create, publish, and display
maps, drawings, designs, schematics, facilities management plans, and
associated attribute data over the Internet, an intranet, or an extranet with
the services of a web server and a web browser.

You can find a number of sample MapGuide projects under
http://enterprise.mapguide.com/landing/index.php.

Prerequisites
To publish graphic objects and property set data to MapGuide, the MapGuide
SDF Component Toolkit must be installed on your computer.

The MapGuide SDF Component Toolkit is a development library that allows
developers to read, write, and modify point, line, and polygon data within
SDF files. SDF files are the native Spatial Data File format of MapGuide, created
from stand-alone applications or CGI applications.

You can download the Autodesk MapGuide SDF Component Toolkit from
http://www.autodesk.com.

Published Data Types
You can publish the following data types from a drawing to MapGuide.

■ Graphic data: All graphic objects can be exported to MapGuide in an SDF
(Spatial Data File) file.
Areas and spaces are converted to polygons in the appropriate SDF files.
All other graphic objects are converted to polylines.
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■ Property set data: Property set data attached to an exported object is
exported to a Microsoft® Access Database consisting of a series of tables
representing the individual property sets. Each object record within a table
is assigned a unique object key matching the corresponding object key in
the SDF file in order to associate the record in the database with the
appropriate SDF geometry.

■ Blocks and MVBlocks: Blocks and MVBlocks are exported as SDF files and
point databases. Since the blocks and MVBlocks are exported in SDF format
as well, the point databases provide an option for users to use symbols
rather than the SDF geometry to represent Blocks and MVBlocks in
MapGuide. There is a point geometry SDF format, but since AutoCAD
Architecture does not work with geospatial coordinate systems, a table in
an external database presents a better data source for point-related data.
The Publish To MapGuide command does not create bitmap files (BMP)
or Windows Metafiles (WMF) representing the geometry of blocks or
MVBlocks. If you want to generate WMFs, you need to use either the
AutoCAD®WmfOut command or the MapGuide SDF Loader.

The SDF Loader is a utility used to create Spatial Data Files (SDF) and their
accompanying Spatial Index Files (SIF) from a variety of GIS data formats.

You can download the SDF Loader utility from http://www.autodesk.com.

■ External references: objects and property set data from external references
are exported as if they actually resided in the host drawing.

NOTE The external reference name prefix of the layer name is removed when
exporting data to MapGuide. This means that objects of the same type that
are on the same layer in separate externally referenced files are placed in the
same SDF files.

Generating a MWX File
The Publish To MapGuide feature creates, in addition to the data types listed
in Published Data Types on page 268, a default map file (MWX file) that
combines the exported data in a MapGuide® project. The map contains one
layer for each generated SDF file. Each layer is visible and selectable.
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An Overview of the Published Data Structure
When you publish data to MapGuide®, a data structure is created that facilitates
the incorporation of the data into an MWX project. The exported files are
placed in a series of folders representing the relevant portions of an MWX
project folder hierarchy. If the following folders do not already exist below
the folder you select for exporting your data, they are created and the
appropriate files placed in each folder.

Directory structure of exported data

The following files are contained in the individual folders:

■ Data Sources folder: In the Data Sources folder, you can find the data links
to the MDB database and the SDF directory. The Publish To MapGuide
options allow you to place the Data Sources in an alternate location.

Data link to exported database

■ DB: The DB folder contains the Microsoft® Access Database created on
export.
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Exported database file

■ MWX: the MWX folder contains the MapGuide project file combining the
exported spatial and non-spatial data. To view and edit the exported data
in MapGuide, you open the MWX file.

■ SDF: The SDF folder contains the exported SDF (Spatial Data File) and SIF
(Spatial Index File) files from the graphic objects.

An Overview of the Database Structure
When you publish data to MapGuide®, a Microsoft® Access Database (MDB)
is created that contains information about the exported graphic objects and
property set data.
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Exported database file

ContentTable Name

This table lists information about the drawing from which
the data is exported. Information includes file name, path,
date of last modification, and the units of the drawing.

ADT_Drawings

This table provides a listing of the object types and object
styles contained in the exported data. Each type and style is

ADT_Object Types

assigned an ID, which is later used to identify individual ob-
jects in the ADT_Objects table.

This table lists all individual objects contained in the exported
data.

ADT_Objects

This table provides a listing of the property set definitions
contained in the exported data. Each property set definition

ADT_Property Set Defini-
tions

is assigned an ID, which is later used to identify individual
properties.

This table lists all properties contained in the exported data.
To identify individual properties, use the PropertySetId from
the ADT_Property Set Definitions table.

ADT_Property Definitions

For each object type that has property data attached directly
to one or more of its objects, a table is created that contains

<Objects>
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ContentTable Name

the objects and their associated property data. For example,
if an exported drawing contains a number of doors with at-
tached properties for frame depth and frame width, a
DoorObjects table is created that lists all of these doors and
their frame depths and frame widths.

For each object type that has property data attached via an
object style, a table is created that contains the objects and

<Object>Styles

the property data derived from their styles. For example, if
an exported drawing contains a number of doors with a style
controlling the louver height and louver width, a DoorStyles
table is created that lists all doors of that style with their
louver heights and louver widths.

NOTE For a detailed view and description of the individual tables, select a table
in Microsoft® Access, right-click, and click Design View.

When you export data to an MDB, make sure that your property set definitions
names, property definition names, and layer names meet the following naming
criteria.

■ Names must not exceed 64 characters. Longer names will be truncated
after 64 characters.

■ Names must not contain the following special characters: period (.),
exclamation mark (!), accent ague (`), and brackets ([]).

Publishing Data to Autodesk MapGuide
Use this procedure to publish data to MapGuide®.

1 Click  ➤ Publish ➤ To Map Guide.
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If the drawing from which you want to publish objects is part of
a building project, the project name and level assignment of the
drawing display in the Publish to MapGuide dialog.

If the drawing is not part of a building project, the name of the
drawing and “Level 1” display by default. You can change these
entries.

NOTE The project name that you enter here is not used as the name
of the source MapGuide project folder and project files. The name
of the project source folder and project files is created from the name
of the drawing.

2 Under Objects, click  .

3 Select the objects you want to publish, and press ENTER.

4 Under Folder, select the location for the project files.

For a detailed description of the files and folders generated on
export, see An Overview of the Published Data Structure on page
270.

5 Click Options.
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6 Specify additional export options:

Then...If you want to...

select Preserve Existing Map Window XML
file. This option will prevent an existing

preserve the existing Map
Window XML file

MWX file in this location from being over-
written. This will allow users to preserve
any changes they made to the MWX file
(secondary data source table selections,
layer properties, or themes) when updating
or re-publishing the underlying data or
geometry.

select Include a Map Server URL, and enter
a server address.

include an URL to a Map
Server

select Publish to Map Server Data Source
Location, and browse for a location.

publish your data to a Map
Server data location

For more information about Map Server data locations, see the
online Autodesk MapGuide® User’s Guide.

7 Click OK twice.

Depending on your selection set, the export may take extra time.
A progress bar shows you the state of the export.
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Exporting Property Set Data to an MDB
Use this procedure to export property set data in a drawing to a Microsoft®

Access Database (MDB).

1 Click  ➤ Export ➤ Property Data.

2 Select the objects that contain the property data that you want
to export.

3 Press ENTER.

4 In the Export Property Data dialog, enter a path and a name for
the exported MDB.

5 Click Save.

The property set data of the objects you selected is exported to a
Microsoft® Access database.

Publishing Drawings to DWF and DWFx
The Design Web Format™ (DWF™) is an Autodesk® method of publishing
design data to a file that can be posted on the Internet or on an intranet. You
can view DWF files with a web browser, like Microsoft® Internet Explorer, or
with the free downloadable Autodesk® Design Review, from where you can
also plot the file. You can send a published DWF file as an e-mail attachment,
share it using a project collaboration site such as Autodesk® Buzzsaw®, or you
can post it to a company website.

DWFx is the next version of the DWF file format. The DWFx file format is a
blend of DWF and the Microsoft XPS (XML Paper Specification) format.

You can publish your DWG files as 2D or 3D model with the included property
set data to DWF or DWFx. When these files are viewed with Autodesk® Design
Review, users can select components that represent objects and display the
object information on the Object Properties palette.

For more information about property set data, see Property Set Definitions on
page 3823.

TIP To view published DWF or DWFx files, you need to install Autodesk Design
Review. You can download the latest version of Autodesk Design Review from
http://www.autodesk.com.
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DWFx file published to Autodesk Design Review

Workflow for Publishing Drawings to DWF or DWFx
Review the stepsWatch the movie

Select a 2D or 3D view of the building with the
correct display.
If you are working in a structured AutoCAD
Architecture project, select a sheet on page 510
or a sheet set from the Project Navigator.

-----Prepare a drawing for publishing

Attach additional property set data if desired.-----
Include specific information about
objects in the drawing

Publish the 2D or 3D drawing.-----Publish the drawing
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Conditions and Limitations to Publishing Drawings to 3D DWF
or DWFx

When publishing a drawing to 3D DWF or DWFx, the following conditions
apply:

■ Most types of hatches (patterns, solid, graphics) are published.

■ The 3D DWF or 3D DWFx file uses the display configuration that is active
in the DWG file during publishing.

NOTE When you publish 3D objects to DWF or DWFx, only the display set
used for 3D views of the drawing is published. For 3D views, this is usually a
Model display set, for example Model Medium Detail, Model High Detail, or
Model Low Detail. You can view the objects in Top view in Design Review;
however, this is only a Top view of the Model display, and not a Plan view.
Objects with no display representation in the Model display set are not
displayed in the published DWF or DWFx. Objects that typically are not
displayed in Model views are tags, annotations, dimensions, and 2D Plan
symbols. If you want these to display in the DWF or DWFx, you can either
activate them for the Model display set, or generate a 2D DWF or 2D DWFx
file. For more information about the display system, see Display System on
page 791.

■ If Render materials are enabled, the transparency is translated to the DWF
or DWFx file. For more information, see Materials on page 885.

■ Live Section objects are published.

■ Property set data attached to objects or styles is published to DWF or DWFx.

The following limitations apply:

■ Infinite lines, like construction lines (xlines) and rays, are not published.

■ Text fonts in the DWG file are all converted to Arial. Text formatting like
Bold, Italic, and Underline are not currently supported.

■ Clip Planes and Xref Clipping are not supported.

■ OLE objects as well as inserted images are not supported.

■ Linetypes and lineweights are currently not supported.

■ Hyperlinks are not published (but are visible for non-AEC objects.)
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Exporting Property Set Data to a DWF or DWFx File
You can export different types of property set data to a DWF or DWFx file.

Automatic Property Set Data

Each object in AutoCAD Architecture has a set of automatic properties attached
to it. For example, every wall has a width, length, and height. Automatic
properties are a subgroup of all property set data that can be attached to an
object (or object style) with a property set definition.

You can automatically export all automatic properties of an object to a DWF
or DWFx file. Automatically exporting all automatic properties has the
advantage that you do not need to set up property set definitions for individual
objects; it does not allow you however to select which properties to export
and which to ignore.

For information on how to export automatic property set data, see Publishing
Automatic Property Set Data to DWF/DWFx.

User-Defined Property Set Data

User-defined property set data is data from a property set definition that you
have created and attached to an object or object style. Property set data can
include automatic object properties, like height and width of a wall, but also
manually defined data such as fire ratings or manufacturing information,
project information, and more.

When publishing user-defined property set data, you specify which property
set definitions to include and which to exclude. For example, some property
sets in your drawing can contain confidential information, which you do not
want to expose to others. In other cases, the recipient of a published file might
need only very specific property set information about one aspect of the
drawing, and does not want to search for that information among a large
amount of unrelated information.

When publishing user-defined property set data, you must attach property
set definitions to the objects in your drawing, and select a PPL (Published
Properties List) file that contains these property sets. For example, you attach
the property set definition DoorObjects to a number of doors in your drawing.
Then, you add the DoorObjects property set definition to your PPL file. When
you publish the drawing to DWF or DWFx, the property set data from these
doors is published. In the same PPL file, you add the WindowObjects property
set definition. However, you do not attach the WindowObjects property set
definition to any windows in your drawing. When you publish the drawing
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to DWF or DWFx, no property set data from the WindowObjects property set
definition is published.

In order to publish user-defined property set data to a DWF or DWFx file, you
need to perform the following high-level steps:

1 Create property set definitions for objects and apply them to an object
or an object style.

For more information, see Property Set Definitions on page 3823.

2 Define in the PPL file (Published Properties List) which property set
definitions from your drawing should be exported.

For more information, see Creating a New Published Property List (PPL).

3 Publish the drawing to DWF or DWFx, as described in Publishing
User-Defined Property Set Data to DWF and Publishing a 2D or 3D DWF
or DWFx file with Property Set Data.

Publishing Property Set Data from External References
Property set data works across external references, and you can publish data
from an external reference to a DWF or DWFx file. To make sure that data
from the external reference is published correctly, make sure that the following
conditions are met:

■ The data structure of property sets coming from an external reference must
be identical to the structure of any corresponding property sets in the host
drawing. For example, if an external reference has a property set definition
called Doors that reports Height, Width, and Door Number, the host
drawing cannot have a property set definition called Doors that reports
Fire Rating, Leaf Width, and Glass thickness.

■ The same property data format must be applied to property set definitions
from external references and corresponding property set definitions in the
host drawing. For example, if an external reference property set definition
called Doors specifies architectural units with 1/4 inch precision, the host
drawing cannot have a property set definition called Doors that specifies
architectural units with 1/16 inch precision. If the property data formats
differ, the format of the host drawing is used for the external reference.
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Property Set Data Structure
As shown in the following examples, you can specify how property data is
organized when exporting property set data from a DWG file to a DWF, DWFx,
or PDF file. This capability can be helpful when exporting large drawings with
many object properties.

■ Grouping property set data by external reference first, and then by object
type and object style:

■ Grouping property set data by external reference first, and then by layer:
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■ Grouping property set data by object type first, and then object style:

■ Grouping property set data by object layer:
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For information on setting the data structure, see Publishing Automatic
Property Set Data to DWF/DWFx and Publishing User-Defined Property Set
Data to DWF.

Publishing a 3D DWF or 3D DWFx File with Automatic Property
Set Data

NOTE This instruction lets you create a single 3D DWF or 3D DWFx file of the
model you are working on with automatic property set data. If you want to create
multiple DWF or DWFx files for different sheets with automatic property set data,
see Publishing Sheets to Multiple DWF/DWFx files.

1 Do one of the following:

■ Click  Export ➤ 3D DWF.

■ Enter 3ddwf on the command line.

2 In the Export 3D DWF dialog, select 3D DWF or 3D DWFx for
Files of type. (By default 3D DWFx is selected.)

3 Click Tools menu  ➤ Options.
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4 Under Objects to Publish, select either the whole model or click
Selected Model space objects, and pick objects in the drawing to
include in the exported DWF or DWFx file.

5 Under 3D DWF Organization select in which order xrefs and
objects will be displayed in the exported file.

Then…If you want to…

check Group by Xref Hierarchy. Un-
der Group individual objects by, se-
lect Object Type and Style.

group the objects by their external
reference, and then by their object
type and style

check Group by Xref Hierarchy. Un-
der Group individual objects by, se-
lect Layer.

group the objects by their external
reference, and then by their layer

uncheck Group by Xref Hierarchy.
Under Group individual objects by,
select Object Type and Style.

group the objects by their type and
style

uncheck Group by Xref Hierarchy.
Under Group individual objects by,
select Layer.

group the objects by their layer
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For example illustrations, see Property Set Data Structure.

6 Select Publish with materials in order to include the material
definitions from the DWG file in the DWF or DWFx file.

7 Click Edit AEC DWF Options.

8 In the AEC DWF Publishing Options dialog, click Publish All
Automatic Properties.

This will publish all automatic properties associated with the
objects you have selected for exporting to the DWF or DWFx file.

9 If you want to publish user-defined property set data, see
Publishing User-Defined Property Set Data to DWF.

10 Click OK, and then Save.

By default, the automatic property data exported will be listed
under a property group called Aec+<object type>. For example, if
you export the automatic properties of a door, they will be listed
under AecDoor. If you are exporting additional user-defined
property set definitions and one of them already uses the name
Aec+<object type>, the automatic properties will be listed in a
property group called Aec+<object type> (2). In the door example
that would mean that if you are exporting a user-defined property
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set definition named AecDoor, then the automatic door properties
will be listed under AecDoor (2).

If an object property is both an automatic property and is also
included in a property set definition, it will be listed both under
the automatic properties and under the property set definition it
is part of in the DWF or DWFx file.

Publishing a 3D DWF or 3D DWFx file with User-Defined Property
Set Data

NOTE This instruction lets you create a single DWF or DWFx file of the model you
are working on with user-defined property set data. If you want to create multiple
DWF or DWFx files for different sheets with user-defined property set data, see
Publishing Sheets to Multiple DWF/DWFx files.

1 Do one of the following:

■ Click  Export ➤ 3D DWF.

■ Enter 3ddwf on the command line.

2 In the Export 3D DWG dialog, select 3D DWF or 3D DWFx for
file format. (By default, 3D DWFx is selected.)

3 Click Tools menu  ➤ Options.
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4 Under Objects to Publish, select either to publish the whole model
or click Selected Model space objects, and pick objects in the
drawing to include in the exported DWF or DWFx file.

5 Under 3D DWF Organization select in which order xrefs and
objects will be displayed in the exported file.

Then…If you want to…

check Group by Xref Hierarchy. Un-
der Group individual objects by, se-
lect Object Type and Style.

group the objects by their external
reference, and then by their object
type and style

check Group by Xref Hierarchy. Un-
der Group individual objects by, se-
lect Layer.

group the objects by their external
reference, and then by their layer

uncheck Group by Xref Hierarchy.
Under Group individual objects by,
select Object Type and Style.

group the objects by their type and
style

uncheck Group by Xref Hierarchy.
Under Group individual objects by,
select Layer.

group the objects by their layer
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For example illustrations, see Property Set Data Structure.

6 Select Publish with materials in order to include the material
definitions from the DWG file in the DWF or DWFx file.

7 Click Edit AEC DWF Options.

8 Verify that Publish Property Set Data is selected.

9 To add a property set definition to the exported DWF or DWFx
file, click Add.

In the Add Property Sets dialog, by default the currently active
drawing and the property set definitions in it are displayed.

10 To select one of the listed property set definitions, check its mark
and click OK.

11 To select property set definitions from another drawing file, click
Browse, and navigate to the desired drawing. Then, proceed to
add property set definitions as described above.

12 Click OK.

13 To remove a property set definition from the exported DWF or
DWFx file, select it, and click Remove.
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14 To create a new PPL file, click New, and follow the instructions
in Creating a New Published Property List (PPL).

15 To select a different PPL file, click Browse and select a new file.

16 Click OK twice, and then click Save.

When the export is finished, you are asked whether you want to
view the DWF or DWFx file. Click Yes to open the exported file
in Autodesk Design Review.

Publishing a 2D or 3D DWF or DWFx File with Property Set Data
When you create a DWF or DWFx file with the Publish dialog, you can create
both 2D and 3D DWF or DWFx files. You can also create multiple DWF or
DWFx files for individual sheets in your drawing. If you export property set
data, the property set data will be displayed in each DWF or DWFx file.

DWG file with property set data
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DWFx file with property set data

1 Click  Publish.

NOTE If you want to publish sheets from a project, see Publishing
Sheet Sets on page 510.

2 Under Page Setup, select if you want to publish a 2D or 3D DWF
or DWFx file:

■ To publish a 2D DWF or DWFx file, select a 2D page setup, or
select <Default: None>.

■ To publish a 3D DWF or 3D DWFx file, select <3D DWF>.
If the <3D DWF> option is not available, no valid 3D display
configuration has been set for the drawing.

3 Under Publish to, select DWF format.

4 Depending on whether you want to create DWF or DWFx, select
the appropriate option below DWF Format.
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5 Click Publish Options.

6 Specify the general DWF options as described in Publish Options
Dialog Box in the AutoCAD Help.

7 If you want to publish user-defined property set data, select
Include for AEC property set data.

8 If you want to publish all automatic properties of the objects in
the drawing, select Include for AEC automatic properties.

NOTE Automatic properties can be published instead of or in addition
to user-defined property set data.

9 In order to add or remove user-defined property sets for the
exported DWF or DWFx file, click the Browse button under AEC
DWF Options.
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10 If you are creating a 3D DWF or 3D DWFx file, define the
organization of published AEC objects in Autodesk Design Review:

Then…If you want to…

select Object Type and Style for AEC
Group Individual Objects by. Then,

group the objects by their external
reference, and then by their object
type and style select Yes for Group by Xref Hier-

archy.

select Layer for AEC Group Individual
Objects by. Then, select Yes for
Group by Xref Hierarchy.

group the objects by their external
reference, and then by their layer

select Object Type and Style for AEC
Group Individual Objects by. Then,

group the objects by their type and
style

select No for Group by Xref Hier-
archy.

select Layer for AEC Group Individual
Objects by. Then, select No for
Group by Xref Hierarchy.

group the objects by their layer

For example illustrations, see Property Set Data Structure.

11 If you are creating a 2D DWF or 2D DWFx file, select a sorting
option under AEC Group Individual objects by.

12 Click OK.

13 Click Publish.

The publishing process is initiated and notifies you when it is
finished.

Creating a New Published Property List (PPL)
Use this procedure to create a new, Published Property List (PPL). The Published
Property List specifies which property set definitions in a DWG file will be
exported to DWF or DWFx, provided the property set definition has been
added to objects or styles in the drawing.

1 Click  ➤ Publish ➤ AEC DWF Publishing Options.

2 Click New.
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3 Browse for the folder in which you want to save the new PPL file,
and enter a name for the new PPL file.

4 Click Save.

The new PPL file is opened in the AEC DWF Publishing Options
dialog. By default it does not contain any property set definitions.

5 Click Add.

By default the currently active drawing and all property set
definitions in it are displayed.

6 If you want to add property set definitions from another drawing,
click Browse to navigate to the desired file.

7 Select all property set definitions that should be included in the
new PPL either by selecting their check marks or by using the
Select All button.

8 If the PPL is complete, click OK.

9 If you want to add more property set definitions to it, click Add
again, and repeat step 6 - 7.

10 Click OK twice.
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Publishing Drawings to PDF
The Adobe® Portable Document Format (PDF) facilitates exchanging drawing
sets electronically. An electronic drawing set is the digital equivalent of a set
of plotted drawings.

PDF files can be easily distributed for viewing and plotting using the free,
downloadable Adobe® Acrobat software. You can send a published PDF file
as an e-mail attachment, share it using a project collaboration site such as
Autodesk® Buzzsaw®, or post it to a company website.

Like DWF files, PDF files are generated in a vector-based format conducive to
maintaining precision. Drawings that are converted to PDF can be easily
distributed for viewing and printing in Adobe Reader, versions 7 or later,
available from the Adobe website.

Unlike DWF or DGN files, multi-page PDF files are attached one page at a time
(as opposed to one sheet at a time for DWF files or one model at a time for
DGN files). Also, hypertext links from PDF files are converted to straight text,
and digital signatures are not supported. For information about publishing a
PDF file, see Publish Drawings in the AutoCAD Help.

Publishing to PDF
You can specify that drawings are automatically published to PDF format (or
DWF or DWFx) whenever they are saved or closed. The auto-publish settings
also let you specify whether to include models, layouts, or both and whether
to publish a multi-sheet or single-sheet file. (For more information, see Auto
Publish Options Dialog Box in the AutoCAD Help.) The following topics
explain how to publish or export to PDF on demand using settings you specify
at the time.

Publish to PDF

Use this procedure to publish PDF files based on options you select.

1 Click  ➤ Publish.
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2 For Publish to, in the Publish dialog, select PDF.

3 Specify other information for the PDF file as desired. For more
information, see Publish Dialog Box in AutoCAD Help.

4 Click Publish Options if you want to change your settings, make
the changes, and click OK.
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5 In the Publish dialog, click Publish.

Export to PDF

Use this procedure to create a PDF file.

6 Click  ➤ Export ➤ PDF.
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7 Specify information for the PDF file as desired. For more
information, see Save as PDF Dialog Box in AutoCAD Help.

8 Click Options if you want to change your settings, make the
changes, and click OK. For more information, see Export to
DWF/PDF Options Palette in AutoCAD Help.
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9 In the Save As PDF dialog, click Save.

Exporting Property Set Data to a PDF File
You can export both automatic and user-specified property set data to a PDF
file.

Automatic Property Set Data

Each object in AutoCAD Architecture has a set of automatic properties attached
to it. For example, every wall has width, length, and height properties.
Automatic properties are a subgroup of property set data that can be attached
to an object (or object style) with a property set definition.

If you automatically export all automatic properties of an object to a PDF file,
you do not have to set up property set definitions for individual objects; but
you cannot select which properties to export and which to ignore.

For information on how to export automatic property set data, see Publishing
a PDF File with Automatic Property Set Data.
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User-Defined Property Set Data

User-defined property set data is data from a property set definition that you
have created and attached to an object or object style. Property set data can
include automatic object properties, like height and width of a wall, but also
manually defined data such as fire ratings or manufacturing information,
project information, and more.

When publishing user-defined property set data, you specify which property
set definitions to include and which to exclude. For example, some property
sets in your drawing might contain information you want to keep confidential.
In other cases, the recipient of a published file might need only specific
property set information about one aspect of the drawing, and does not want
to search for that information among a large amount of unrelated information.

When publishing user-defined property set data, you must attach property
set definitions to the objects in your drawing, and select a PPL (Published
Properties List) file that contains these property sets. For example, you attach
the property set definition DoorObjects to a number of doors in your drawing.
Then, you add the DoorObjects property set definition to your PPL file. When
you publish the drawing to PDF, the property set data from these doors is
published. In the same PPL file, you add the WindowObjects property set
definition. However, you do not attach the WindowObjects property set
definition to any windows in your drawing. When you publish the drawing
to PDF, no property set data from the WindowObjects property set definition
is published.

To publish user-defined property set data to a PDF file, you need to perform
the following high-level steps:

1 Create property set definitions for objects and apply them to an object
or an object style.

For more information, see Property Set Definitions on page 3823.

2 Specify in the PPL file (Published Properties List) which property set
definitions from your drawing should be exported.

For more information, see Creating a New Published Property List (PPL).

3 Publish the drawing to PDF, as described in Publishing to PDF.

Publishing Property Set Data from External References
Property set data works across external references, and you can publish data
from an external reference to a PDF file. To make sure that data from the
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external reference is published correctly, make sure that the following
conditions are met:

■ The data structure of property sets coming from an external reference must
be identical to the structure of any corresponding property sets in the host
drawing. For example, if an external reference has a property set definition
called Doors that reports Height, Width, and Door Number, the host
drawing cannot have a property set definition called Doors that reports
Fire Rating, Leaf Width, and Glass thickness. For more information, see
Property Set Data Structure.

■ The same property data format must be applied to property set definitions
from external references and corresponding property set definitions in the
host drawing. For example, if an external reference property set definition
called Doors specifies architectural units with 1/4 inch precision, the host
drawing cannot have a property set definition called Doors that specifies
architectural units with 1/16 inch precision. If the property data formats
differ, the format of the host drawing is used for the external reference.

Publishing a PDF File with Automatic Property Set Data
Use this procedure to include automatic property data in your PDF. If you
want to publish sheets from a project, see Publishing Sheet Sets on page 510.

1 Do either of the following:

■ Click  Export ➤ DWF/PDF Options.

■ Enter exportsettings and select Options on the command line.

2 In the Export to DWF/PDF Options dialog, under DWF data
options for AEC automatic properties, select Include, and click
OK.
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All automatic properties associated with the objects you have
selected for exporting are published to the PDF file. For more
information, see Export to DWF/PDF Options Palette in AutoCAD
Help.

By default, the automatic property data exported will be listed
under a property group called Aec+<object type>. For example, if
you export the automatic properties of a door, they will be listed
under AecDoor. If you are exporting additional user-defined
property set definitions and one of them already uses the name
Aec+<object type>, the automatic properties will be listed in a
property group called Aec+<object type> (2). In the door example
that would mean that if you are exporting a user-defined property
set definition named AecDoor, then the automatic door properties
will be listed under AecDoor (2).

If an object property is both an automatic property and is also
included in a property set definition, it will be listed both under
the automatic properties and under the property set definition it
is part of in the PDF file.
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Publishing a PDF with All Property Set Data
Use this procedure to include automatic and user-defined property set data
in your PDF. If you want to publish sheets from a project, see Publishing Sheet
Sets on page 510.

1 Do either of the following:

■ Click  port ➤ DWF/PDF Options.

■ Enter exportsettings and select Options on the command line.

2 In the Export to DWF/PDF Options dialog, under DWF data
options for AEC property set data, select Include, and click OK.
For more information, see Export to DWF/PDF Options Palette in
AutoCAD Help.
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Drawing Management

The Drawing Management feature formalizes and automates the processes relating to building
model design and documentation. The feature provides automated tools that aid you in the
management, viewing, and construction of your building.

When you manage your project files with this feature, you have consistency throughout all
aspects of the project. Everyone on your design team has a centralized project environment
for accessing the most current documents, from project templates to sections and elevations.

Workflow for a Project Environment
Creating a set of construction documents with the Drawing Management feature
in AutoCAD Architecture is more efficient than creating standalone drawings
and compiling them afterwards.

Open the Project Browser on page 321 and create
the project framework from scratch on page 331,-----Create a new project
a template on page 328, or an existing project on
page 330.

Define vertical levels on page 380 for the project.-----Define floor elevations

7
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Define the project properties on page 333 and
details on page 337.

-----Enter your project information

Organize your drawings in categories on page
390.

-----Add categories to the project

Create constructs on page 404 and assign them
horizontal locations in the building with divisions
on page 387.

-----Design your building

Create views on page 453.-----Create views of your building

Create a sheet on page 484 for the project
drawing.

-----Make a sheet

Add views on page 465 to a sheet.-----Add drawings to a sheet
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Publish on page 510 your sheets.-----Plot your sheets

Concepts of Drawing Management
The Drawing Management feature of AutoCAD Architecture lets you create
large building projects distributed among many drawing files. The following
sections describe the key concepts of this feature.

Project

At the highest level, building models are organized conceptually into projects.
A project is composed of 2 parts: the building model and the reports generated
from the model. The building model is composed of constructs and elements,
while reports consist of views and sheets. Within a project, constructs are
referenced into views, and views are referenced into sheets.

Constructs

A construct describes one unique portion of a building and is assigned to a
specific level and division within the project. Spanning constructs, like curtain
walls, can be assigned to multiple levels and divisions.

For example, the first level of your building project may consist of an exterior
shell construct, a first-level core construct, and a first-level interior partitions
construct.

A construct can contain drawing objects like walls and doors, external
references to elements, or a combination of both. For example, a first-level
core construct can contain the core walls directly drawn into the construct
and an elevator element inserted as an external reference.
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You can create and modify constructs within the current project. You can also
import drawings and convert them or add them to constructs. You can import
constructs into the project physically or by creating a link.

Constructs are referenced into views. For more information, see Constructs
on page 400.

Views

After the structure of the building is defined, and constructs are assigned to
levels and divisions, you can generate reports (views and sheets) from the
building model. A view automatically references a number of constructs to
present a specific view of the building project. To create a view drawing, you
first decide what portion of the building you wish to look at and the type of
view to generate. You could, for example, create a first-floor reflected ceiling
plan or a second-floor framing plan.

You could also create a composite view of all floors in the building as shown:

3D view of entire building view

View drawings automatically reference the appropriate constructs according
to their location within the building. For example, to create a floor plan of
the west wing of the second floor, you would create a view that references all
constructs assigned to the second floor and the west wing. This would also
include a curtain wall spanning the first through fifth floors. You can reference
additional constructs that you want to see in the view even though they do
not lie on that floor, such as a building outline.

In a view drawing you can also add data like annotation, dimensions, and
schedules. Whether to create the annotation in a view drawing or on a sheet
is a decision you make based on your workflow and individual needs.
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Three different types of view drawings, each with its own template and
identified by a different icon, can be used as organizational tools.

■ General view drawing

■ Detail view drawing

■ Section/Elevation view drawing

Views are referenced into sheets. For more information on the view system
in AutoCAD Architecture, see Views on page 446.

Sheets

Sheets are used to plot drawings of your building project.

The sheet system in AutoCAD Architecture consists of the following
components:

■ Sheet: A sheet is a paper space layout that has been registered as a sheet.
A sheet can contain one or more sheet views. For more information, see
“Work with Model Space and Paper Space” in AutoCAD Help.

Sheet with building plan sheet view

■ Sheet views: A sheet view is a paper space viewport created by dragging a
model space view from a view drawing in the Drawing Explorer onto a
sheet.
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Sheet view created from model space view

■ Sheet set: A sheet set is a named and ordered collection of sheets. Sheet
sets are similar to the physical set of bound sheets that are the primary
communication medium for a typical building project. Sheet sets are
tailored for efficient output of printed or electronic documents through
the Publish command.
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Sheet set for AutoCAD Architecture project

Each project in AutoCAD Architecture has a simple project sheet set, which
contains all sheets for the project.

■ Sheet drawing: A sheet drawing is a DWG file containing one or more
sheets.

Sheet set, sheets, sheet views, sheet drawings, and model space views are listed
on the Sheets and Views tabs of the Project Navigator.

Although it is recommended to place annotation in a view, you can add
annotation like tags, dimensions, and schedule tables to a sheet. For more
information, see Sheets on page 481.

Project Standards

There is a Project Standards feature in AutoCAD Architecture. Project standards
provide a mechanism to establish, maintain, and synchronize styles and
display settings across an AutoCAD Architecture project. Within a project,
you can specify standard styles, display settings, and AutoCAD standards that
are used across all project drawings. Standard styles and display settings are
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defined in standards drawings associated with the project. The project is
synchronized with these standards throughout the project life cycle. For more
information, see Project Standards on page 599.

Project Tool Palettes and Content Browser Library

In addition to standards drawings, you can also set up project-specific tool
palettes and a Content Browser library for a project. A user-definable root path
for tool content ensures that the tools always reference the correct content
drawing for their definition.

External Reference Management

External references allow your source files to be distributed over many different
locations on your computer or on a network. You can assign schedule tables,
annotation tags, and dimensions to external references easily. Different people
can work simultaneously on the same project.

You specify whether reference paths are full external or relative external paths.

For more information on external references, see “Reference Other Drawing
Files (Xrefs)” in AutoCAD Help.

For more information on annotating external references in a project, see
Workflow for Annotating a Project on page 529.

Mapped Drives

AutoCAD Architecture supports mapped drives within a project environment.
You can map the same identifying drive letter on different servers with the
same project structure. If you use mapped drives within an AutoCAD
Architecture project, you are not prompted to repath each time you open the
project drawing files from different servers. For more information, see Working
with Design Teams Located Remotely on page 321.

XML Structure

A AutoCAD Architecture project has an underlying XML structure. For each
drawing file you create—for example, a floor drawing or a structural
drawing—an accompanying XML file is created. The XML file contains
project-relevant information, such as level and division information. You can
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reuse any drawing file created within a project outside the project as well,
because the drawing file itself does not contain project-relevant information.

Levels and Divisions

The project provides a framework of levels (floors) and divisions (wings) that
specify where in the building project constructs are located. By default, a new
project consists of one level and one division. You can add levels and divisions
throughout the lifetime of a project. The matrix of levels and divisions provide
the framework to help uniquely identify the building components. For
example, you could have a construct in your building assigned to First
Floor—West Wing.

Levels and divisions schematic

Building objects, such as curtain walls and elevator shafts, can span multiple
levels and divisions. You can use a spanning construct for these types of
building objects.

For more information, see Levels on page 379 and Divisions on page 387.
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Categories

To help organize the building, components of the building project—constructs,
views, and sheets—can be categorized. You can use categories like shell, core,
and interior partitions. Categorizing a construct lets you filter that construct
when generating views.

Construct categories in the Project Navigator

For more information, see Categories on page 390.

The Project Structure
When you create a new project, AutoCAD Architecture automatically creates
a project environment to connect the individual files into one project. This
environment has 3 main components:
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The Project (APJ) File
The project (APJ) file contains:

■ the project name and number

■ information about levels and divisions

■ settings for drawing templates, project details, project standards, project
palettes, and the method of linking xrefs

You also configure standards styles, display settings, and AutoCAD standards
here. For more information, see Working with Project Properties on page 333.
An existing APJ file can serve as the template for a new project. For more
information, see Creating a New Project Based on a Template (Copying a
Project) on page 328.

NOTE The APJ file is a well-formed XML document. You can open and modify it
using an XML editor.

The Default Category Structure
When you create a new project, the following default category structure is
created:

These categories are empty unless you created the new project from an existing
project with drawing files.

These top-level categories can be redirected to point to other folders. Each top
folder must use a unique folder, and they cannot be an ascendant or
descendant of each other in the tree structure. You can create subcategories
in each of them. For more information, see Categories on page 390.

The Project Sheet Set
In AutoCAD Architecture, project sheets are collected in sheet sets or a project.
A sheet set allows you to have common publishing setups across a number of
sheets.
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When you create a new project, a unique sheet set is created for this project.
The project sheet set is displayed on the Sheets tab of the Project Navigator.

Project sheet set in AutoCAD Architecture Project Navigator

Only one sheet set can be associated with a project. You cannot change the
sheet set for an existing project, but you can change its properties. For more
information, see Setting the Properties of the Project Sheet Set on page 487.

Before You Begin: External References
The Drawing Management feature uses external references (xrefs) as a means
to create a project and maintain it. Elements are referenced into constructs,
constructs are referenced into views, and views are referenced into sheets. The
mechanism of referencing is identical to the regular AutoCAD External
References Management feature. However, the background methods employed
have additional features.

Xrefs that are created in drawing management can automatically make use
of project data, while those that are created manually through the xref palette
or command line cannot. For example, a construct that is placed on a specific
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level will use that level's elevation data (as defined by the project) to control
the Z-axis insertion point when being xrefed into a view.

If you are working in a project environment, the best practice for referencing
project drawings into other project drawings is to use the Project Navigator
rather than the standard AutoCAD Xref Manager. The AutoCAD Xref Manager
cannot differentiate between project drawings and non-project drawings. If
you reference a non-project file into a project file by mistake, you cannot use
the full Drawing Management functionality on that file.

Whenever you define a project drawing on the Project Navigator, an
accompanying XML file is created. The XML file is vital for the project. Under
no circumstances should you delete it (unless you are deleting the entire
project). That XML file contains:

■ information about level and division assignments

■ viewport and content information appropriate for the type of drawing

Keep these considerations in mind when working with a project:

■ Do not delete any XML files generated by the Drawing Management feature.
They are vital for the project.

■ Use the Project Navigator to create, modify and reference project files
within the project. If you want to use existing non-project files in a project,
convert them to project files first. For more information, see Converting
a Drawing to an Element on page 431 and Converting a Drawing to a
Construct on page 408.

■ Drawing Management supports the use of relative paths for external
references. In the project setup, you can decide whether to use full paths
or relative paths. Working with relative xref paths makes moving the
project and transmitting it easier and reduces the need to repath the project.
For more information on relative and full paths, see “Set Paths to
Referenced Drawings” in AutoCAD Help.

NOTE Changing full xref paths to relative xref paths or relative paths to full
paths in an existing project will change existing paths. An exception is if the
xref path points to a location that is outside the project folders or is otherwise
not supported by relative paths. For information on adding project location
search paths, see Specifying the Default Project Options on page 318.

Before You Begin: External References | 315



Before You Begin: Working in a Network Environment
When you are working on a large project, the project may be hosted on a
network server and accessed by multiple users simultaneously. For a seamless
workflow, keep these points in mind:

■ Keep the project tree current: When multiple users are working on a
project simultaneously, it is possible that one user’s view of the project
will not reflect changes made by another user.
For example, user 1 might be adding/moving/deleting constructs in a
project at the same time that user 2 is annotating sheets. User 2 is not
notified that the coworker has removed some constructs from the project.
If user 2 tries to open a removed construct from the Project Navigator on
his machine, an error message results.

To prevent this situation, refresh the Project Navigator by clicking 
(Refresh Project) so that all items are updated to reflect the current project
status. For more information, see Refreshing the Project Navigator on page
527.

■ Icons reflect the status of drawings: A lock symbol is automatically
appended to the drawing icon if the drawing is in use. When you hold the
cursor over the drawing name, a tooltip displays information about the
drawing file.

■ Access restrictions on the network server: You can limit other users’ ability
to edit and delete project files by using network permissions. You can limit
the Delete rights for the entire project, so that users cannot delete files
from the project or move files around within the project. You might
consider limiting Delete rights to the top project folder (containing the
APJ file) while allowing deletions in the subfolders.

■ Mapped drives: The Drawing Management feature supports working with
mapped drives. You can place the project APJ file or project drawings on
a mapped drive and mirror the server information for users in multiple
locations. For more information, see Working with Design Teams Located
Remotely on page 321.

Project Support Files
A project can be associated with multiple support files. Normally these files
are used to provide standards that ensure consistency across the project, or
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across multiple projects. Some support files are mandatory, while others are
optional.

NOTE You can find all project-related templates under
C:\ProgramData\Autodesk\ACA 2012\enu\Template.

The following support files can be used in an AutoCAD Architecture project:

■ Project template (optional)

■ Drawing templates (mandatory)

■ Sheet set template (mandatory)

■ Project standards drawings (optional)

■ Project tool palette group (optional)

■ Project Content Browser library (optional)

■ Project structure templates (optional)

These support files are described below.

Project Template

A project template is an existing project that can be used as a template when
creating a new project. When you create a project based on a template project,
all drawing files, settings, and support files of the new project are taken from
the template project. Alternatively, you can use only the structure and the
support files of a project as the basis for the new project. For more information,
see Creating a New Project Based on a Template (Copying a Project) on page
328 and Creating a New Project with the Structure of an Existing Project on
page 330.

Drawing Templates

When you create a new project, you can define default templates for new
elements, constructs, and model views created in the project. For more
information, see Creating and Saving Drawings on page 179. Sheet templates
are defined in the project sheet set template.

The Project Sheet Set Template

Each project has a unique sheet set that collects and organizes the sheets in
a project when the project is created. The sheet set is created from a template
in which the user defines the sheet set structure, the default sheet template,
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and page setup overrides. When you create a project based on a template
project, the sheet set of that project is used as a sheet set template. When you
create a new project without using a template, the default sheet set template
defined in Specifying the Default Project Options on page 318 is used.

You cannot change the sheet set template after creating a project. You can,
however, change the properties of the sheet set in the project.

By default, following sheet set templates are shipped with the software:

■ Aec Sheet Set (Imperial ctb).dst

■ Aec Sheet Set (Imperial stb).dst

■ Aec Sheet Set (Metric ctb).dst

■ Aec Sheet Set (Metric stb).dst

Project Standards Drawings

You can define project-specific drawings that contain standard styles and
display settings, as well as AutoCAD standards for a project. For more
information, see Specifying Project Standards on page 339.

Project Tool Palette Group

You can define a tool palette group to be used in the project. If your project
is not based on a template that includes a project-specific tool palette group,
you can define one as described under Setting up Standard Tools in a Project
on page 622.

Project Content Browser Library

You can define a project-specific Content Browser library that opens by default
when you start Content Browser from within Project Navigator. The project
library contains standard tools and palettes for the project. For more
information, see Setting up Standard Tools in a Project on page 622.

Specifying the Default Project Options
Use this procedure to set the default options for your AutoCAD Architecture
projects. The following options can be specified for projects:

■ Location search paths

■ Template files for constructs, elements, views and sheet sets
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■ Project bulletin board

■ Project image

NOTE When you create a new project based on a template project, the default
templates, bulletin board, and project image of the template project are used in
the new project. If the new project is not based on a template project, the settings
defined in the project defaults are used.

In addition, you can specify settings that affect your workspace when:

■ Starting the application

■ Switching between projects

■ Dragging and dropping a view onto a sheet

To specify project defaults:

1 Click  ➤ Options.

2 Click the AEC Project Defaults tab.

3 Expand AEC Project Location Search Path:
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The paths also display in the Project Browser drop-down list (above
the list of projects), providing shortcuts to folders containing
projects.

Then…If you want to…

click the path you want to change, and click
Browse. In the Browse for Folder dialog, se-
lect the new search path, and click OK.

change an existing project
location search path

click Add. In the Browse for Folder dialog,
select the additional search path, and click
OK.

add a search path

click Remove.remove a search path

4 Expand Default Project Template Files.

5 To change any of the default templates, the bulletin board, or the
image, expand the category, select the existing file, and click
Browse. Then in the Select File dialog, select the new file, and
click Open.

6 Specify how your workspace displays:

Then…If you want to…

select Close project drawings when
switching projects.
This setting is only in effect if the option
of Always perform selected action in the

close all drawing files that are
open in your current project
when you change to a differ-
ent project

Project Browser-Close Project Files dialog
is also selected. For more information, see
Closing All Project Files on page 350.

clear Show detailed drawing preview
when dropping view on sheet.

improve performance by dis-
playing only the model space
view name within the frame
of the view when dropping
it on a sheet

select Show Project Browser at startup.specify that the Project
Browser opens every time
you open AutoCAD Architec-
ture

320 | Chapter 7   Drawing Management



7 To create a new sheet set template, click Create Sheet Set Template,
and see Creating a Sheet Set Template on page 511.

8 Click OK.

Working with Design Teams Located Remotely
The best practice for working with members of a remote team is to set up the
structure for a project on a dedicated drive of a central network server. If you
must mirror a server drive, communicate the location to remote teams so they
can assign the same drive letter. When remote locations use the same mapped
drive, the extended team can work on the project without being prompted to
repath the project when it is set current.

If you want to specify mapped drives for an existing project, organize the full
project on the specific drive first. Then use Project Browser to browse for the
project using the mapped drive letter.

Opening a Project From a Mapped Drive
Use this procedure to open a project located on a mapped drive. You must
already have the project structure defined on that drive.

1 On the Quick Access toolbar, click Project Browser  .

2 In the Project Files dialog, browse to the mapped drive (indicated
by letter) on which your project is located, and click Open.

3 To set this project current, select the APJ file, and click Open.

4 Click Close on the Project Browser.

The Project Browser
The Project Browser is where you perform high-level project-related tasks,
such as creating a new project, selecting the currently active project, and
setting project properties.
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Opening the Project Browser
Use this procedure to open the Project Browser.

■ Click  ➤ Open ➤ Project.

■ On the Quick Access toolbar, click Project Browser  .

■ On the command line, enter AecProjectBrowser.

Using the Project Browser
In the Project Browser, you create new projects, configure the project settings
and project standards, add detail information, and select the current project.
When you set a project current, either from the context menu or by
double-clicking the file name, the project is migrated to a format compatible
with the current version of AutoCAD Architecture. If you also repath the
project, all project drawings are migrated as well, and you will be unable to
open the project in any older version of the software. For more information,
see Repath the Project on page 525.
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Project Browser

On the left side of the Project Browser, you select the current project, create
new projects, browse existing projects, and view the project history. On the
context menu, you can also edit project properties, close a project, copy the
project structure, eTransmit a project, and archive a project. All information
you enter here pertains to the project as a whole. On the right side of the
Project Browser, an embedded Internet Explorer allows you to browse your
project home page.

NOTE The projects you create in the Project Browser display as files and folders
in Windows Explorer. As a general rule, you should not perform any file operations
on a project file there, except in those cases where a procedure explicitly states
that you should. Changes in Windows Explorer are not always updated correctly
in the Project Browser or Project Navigator, and you could get an inconsistent
view of your project data. Any changes you make to the project within the Project
Browser are managed and coordinated by AutoCAD Architecture. Changes made
outside the software might not be correctly coordinated and processed.
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The Project Header
The currently selected project is displayed in the upper-left area of the Project
Browser. The header contains the project name, project number, a user-selected
bitmap representing the project, and an optional short project description.
You enter this information when you create a new project or edit properties
of an existing project.

Project header

The Project Navigation Bar
Below the project header, toolbar buttons help you to navigate in your folder
structure.

DescriptionButton

Returns you to the previously displayed
folder.

Displays the folder one level above the
currently displayed folder.

Takes you to the Project File Navigator,
where you can browse for project (APJ)
files.

Lets you create a new folder in the specified
location.

Displays the projects in the folder selected
in the list below. For detailed information,
see The Project Selector on page 325.

Displays a historic list of projects sorted by
various criteria. For detailed information,
see The Project Selector on page 325.
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The Project Selector
The project selector on the left side of the Project Browser displays the projects
you have created in AutoCAD Architecture.

Project selector

You have 2 main options for displaying projects:

Displaying Projects by Folder Structure

You can display the projects on your computer or network based on the
Windows Explorer folder structure. When you navigate to a folder, all projects
and subfolders contained in that folder are displayed.

1 On the Quick Access toolbar, click Project Browser  .

2 In the project navigation bar, click  .

The project selector displays the folder structure of your computer. The
contents of the currently selected folder are displayed in the project

selector. Project files are displayed with the project icon  . The current
project is displayed in bold letters.

3 To switch to another folder, select it in the drop-down list.

WARNING When you repath a project that was saved in a version of AutoCAD
Architecture prior to 2010, the drawings are saved in the new file format.
You will no longer be able to open these drawings in a version of AutoCAD
Architecture prior to 2010. Synchronizing a project with the project standards
will also save the project drawings in the new file format. For more
information, see Repath the Project on page 525.

4 To navigate to the parent folder of the current folder, click  .
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Displaying Projects by History

In the project selector, you can display projects based on their history.

1 On the Quick Access toolbar, click Project Browser  .

2 In the project navigation bar, click  .

3 Select the option by which you want to sort projects.

■ If you select Most Recently Used, the last eight projects you have made
current are displayed in descending order in the project selector.

■ If you select By Date, a list of project dates is displayed, sorted by
current day, current week, and previous weeks.

■ If you select By Project, a list of project names is displayed, sorted
alphabetically.

■ If you select By Location, a list of folders containing project files is
displayed, in alphabetical order. If you double-click a folder, the
projects contained in it are displayed.

Project files are displayed with the project icon  . The current project
is displayed in bold letters.

4 If you want to remove a project from the history, select the project,
right-click, and click Remove from History List. Click Yes in the
subsequent message box.

NOTE You cannot remove the current project from the history list.

5 If you want to remove the complete history list except for the current
project, select a project, right-click, and click Reset History list. Click Yes
in the subsequent message box.

The Embedded Internet Explorer View
A project can connect to a bulletin board HTML page. You could do this, for
example, to provide a link to your company’s home page or a project web
site. The HTML page is displayed in the right pane of the Project Browser. At
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the bottom of the page, there is a standard Internet Explorer navigation bar
with buttons for Back, Forward, Stop, Refresh and Project Home.

Setting a Project Current
Use this procedure to set a project to be the current project.

To work within the project environment, you must define the current project.
Only one project can be current at a time, and all project operations you
perform, such as adding constructs and elements or changing levels and
divisions, are done within the current project.

When you select a project as the current one, its project header and default
HTML bulletin board are displayed in the Project Browser, and the name
appears on the Project Navigator palette.

NOTE If your Project Browser does not yet contain any projects, see Creating a
New Project on page 328.

1 On the Quick Access toolbar, click Project Browser  .

2 In the project selector, select a project.

Projects are displayed with a project icon  .

3 Right-click, and click Set Project Current.

NOTE Alternatively, you can double-click the project.

The selected project is loaded in AutoCAD Architecture, and you
can work with it until you close it or select another one.

4 In the Project Browser, click Close to begin working on the Project
Navigator palette.

If you working on the same project in more than one session of the same
version of AutoCAD Architecture, and you make changes in one session, you
can automatically refresh the project in the other session(s) by opening the
Project Browser there.
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Creating a New Project
There are 3 options for creating a new project. You can copy an existing project
and all its settings; you can create a project with the folder structure and
support files of an existing project; or you can create a new project from
scratch, with no predefined files and settings.

Creating a New Project Based on a Template (Copying a Project)
Use this procedure to create a project using an existing project as a template.

This is the quickest and easiest way to create a project with predefined settings
and support files. When you use this method, the following files and structures
are copied to the new project:

■ All project DWG files and XML files

■ Project standards files

■ AutoCAD standards files

■ Project standards synchronization settings

■ Sheet set template

■ Project details

■ Drawing templates

■ Keynote and detail component databases

■ Project tool palette group

■ Tool content root path

■ Project Content Browser library

NOTE Project standards files, the project tool palette group, and the project
Content Browser library are copied to the new project only if they are located
within the original project folder. Standard components located outside the project
folder will be referenced by the new project, but not copied to it.

Creating a new project based on a template will copy all files that are in the
project folder. If you want only the support files and structure of the project
to be copied, but not its drawing files, see Creating a New Project with the
Structure of an Existing Project on page 330.
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If you redirected a project folder (elements, constructs, views, or sheets) to a
folder that is not beneath the root project folder (location of the APJ file), the
project cannot be used as a template project. For more information, see
Specifying the Location of Top-Level Categories on page 396.

1 On the Quick Access toolbar, click Project Browser  .

2 Right-click on an existing project or folder in the project selector,
and click New Project.

Alternatively, you can click  in the toolbar below the project
selector.

3 In the Add Project dialog, enter a number for the new project.

Each project needs a unique identification number. You can use
numerals, alphabetic characters, or a combination, such as 100A.
The project number appears in the project header.

The number you assign here can be used as a prefix for all
drawings you create in the project. You can also use the number
as a property for a title block. For more information, see Project
Schedule Properties on page 535.

4 Enter a name for the new project.

5 Under Project Description, if desired, enter a description brief
enough to be displayed in the project header.

Details about the project can be entered on a separate worksheet.
For information, see Adding Detailed Information to Project
Properties on page 337.

6 Select Create from template project.

7 Enter the path and name of an existing APJ file, or click  to
navigate to an APJ file.

8 Click OK.
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NOTE You cannot specify all support files and paths directly when
creating a new project; you can only define name, number,
description, and project template. The remaining settings can only
be defined after the project has been created. If you create the project
based on a template, the settings of the template are used for the
initial setting. To define the project settings, see Working with Project
Properties on page 333.

Creating a New Project with the Structure of an Existing Project
Use this procedure to create a new project that is based on the structure and
support files of an existing project. However, if you redirected any categories
in the project on which you want to base your new project, it cannot be used
as a template. For more information, see Specifying the Location of Top-Level
Categories on page 396.

When you use this method, the following files and settings are copied to the
new project:

■ Project standards files

■ AutoCAD standards files

■ Project standards synchronization settings

■ Sheet set template

■ Project details

■ Drawing templates

■ Keynote and detail component databases

■ Project tool palette group

■ Tool content root path

■ Project Content Browser library

1 On the Quick Access toolbar, click Project Browser  .

2 In the project selector, locate the folder in which the project of
which you want to copy the structure and support files is located.

3 Select the project, right-click, and click Copy Project Structure.
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4 In the Duplicate Project dialog, enter a number for the new
project.

Each project needs a unique identification number. You can use
numerals, alphabetic characters, or a combination, such as 100A.
The project number appears in the project header.

The number you assign here can be used as a prefix for all
drawings you create in the project. You can also use the number
as a property for a title block. For more information, see Project
Schedule Properties on page 535.

5 Enter a name for the new project.

6 Under Description, if desired, enter a description brief enough to
be displayed in the project header.

Details about the project can be entered on a separate worksheet.
For information, see Adding Detailed Information to Project
Properties on page 337.

7 Under Copy to, select a folder in which you want to save the
copied project.

8 Click OK.

Creating a New Project Without Using a Template
Use this procedure to create a new project that is not based on a template but
uses the drawing templates, sheet set template, and project bulletin board
specified in the AEC Project Defaults, as described in Specifying the Default
Project Options on page 318. Note that you still need to define project details
and project standards.

1 On the Quick Access toolbar, click Project Browser  .

2 Right-click on an existing project or folder in the project selector,
and click New Project.
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Alternatively, you can click  in the toolbar below the project
selector.

3 In the Add Project dialog, enter a number for the new project.

Each project needs a unique identification number. You can use
numerals, alphabetic characters, or a combination, such as 100A.
The project number appears in the project header.

The number you assign here can be used as a prefix for all
drawings you create in the project. You can also use the number
as a property for a title block. For more information, see Project
Schedule Properties on page 535.

4 Enter a name for the new project.

5 Under Project Description, if desired, enter a description brief
enough to be displayed in the project header.

Details about the project can be entered on a separate worksheet.
For information, see Adding Detailed Information to Project
Properties on page 337.

6 Verify that Create from template project is not selected.

7 Click OK.
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NOTE You cannot specify all support files and paths directly when
creating a new project; you can only define name, number,
description, and project template. The remaining properties are
defined after the project has been created. If you create the project
based on a template, the properties of the template are used for the
initial setting. If you create a project without using a template, the
properties will initially be empty or are defined by the AEC default
project options. To define the project properties, see Working with
Project Properties on page 333.

Working with Project Properties
When you have created a new project, the following properties may be defined
or can be changed:

■ Project bulletin board

■ Project image

■ Relative or full paths for external references

■ Synchronization of view drawing layer settings with sheet views

■ Project tool palette file location

■ Project tool palette storage type

■ Project tool content root path

■ Project Content Browser library

■ Drawing templates for elements, constructs and views

■ Project details

■ Project detail component databases and keynote databases

■ Project standards settings

When you have created a project based on a template project, these settings
are initially taken from that project. You can change them, if necessary.
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NOTE The project sheet set template is defined during the creation of the project;
either it is the sheet set used in the template project, or, if you have chosen to
create a new project without using a template, it is the default project sheet set
template defined in Specifying the Default Project Options on page 318.

Specifying Basic Project Properties
Use this procedure to define or change basic properties for a project. Basic
properties are divided into 3 categories:

■ General

■ Drawing Settings

■ Templates

1 On the Quick Access toolbar, click Project Browser  .

2 In the project selector, select the project for which to define the
settings, right-click, and click Project Properties.

The Project Properties dialog is displayed.

3 Under General define or change the following properties as
needed.

DescriptionProperty

The project name is defined when you create
the project. If you change the name here, only

Name

the name displayed in Project Browser and
Project Navigator is changed; the APJ file and
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DescriptionProperty

the project folder in Windows Explorer retain
the original name. The recommended proced-
ure for renaming project is described in Re-
naming a Project on page 349.

The project number is defined when you cre-
ate the project. You can enter a new number
here.

NOTE Under Drawing Settings, you can
specify that the project number is added
as a prefix to each project drawing cre-
ated in the project. If you change the
project number during the project life
cycle, the existing file names will be
changed and repathed.

Number

To add a description or change the current

one, click  , enter the desired text, and
click OK.

Description

To attach user-defined information to a pro-
ject, such as project data and site description,

Detailed Information

click  . For more information see, Adding
Detailed Information to Project Properties on
page 337.

This path is read only and identifies where the
project is located.

Folder

4 Under Basic, expand Drawing Settings, and define or change the
following properties as needed:

DescriptionProperty

Select Yes to have external references within
the project attached using relative paths

Use Relative Xref Paths

whenever possible. This makes it easier to
move or electronically transmit a project.
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DescriptionProperty

After the progress bar indicates the project
files have been renamed, you are given the
option to repath the project now or repath
the project later.
Changing full xref paths to relative xref paths
or relative paths to full paths for existing xref
paths will change existing paths accordingly.
An exception to this behavior is if the xref
path points to a location outside the project
folders or otherwise not supported by relative
paths.

Select Yes to use the view drawing layer set-
tings in any sheet views generated from the

Match Sheet View Layers
to View

view drawing or one of its model space views.
The settings are updated in the sheet view
when they change in the view drawing. For
more information, see Synchronizing View
Drawing Layers with Sheet View Layers on
page 475.

Select Yes to have the project number pre-
fixed to the file names of drawing files created

Prefix Filenames with
Project Number

within this project. If you select No, no prefix
is added to drawing files created within this
project.

NOTE When you add or change the
prefix setting in an existing project, ex-
tended file names are changed and re-
pathed. Filename prefixes do not display
in the Drawing Explorer.

5 Under Basic, expand Templates, and define or change the
following properties as needed:

DescriptionProperty

Specify whether you want to base your ele-
ments, constructs, and view drawings on a

Use Common Mod-
el/View Templates

single common template or define separate
DWT files as templates for each drawing type.
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DescriptionProperty

For an overview of the drawing types, see
Concepts of Drawing Management on page
305.
If the value of Use Common Model/View
Templates is Yes, the Common Model/View
Template property specifies the location of
the common template for elements con-
structs, and view drawings. To change this

value, click  , select a different drawing
template, and click Open.

If the value of Use Common Model/View
Templates is No, these properties specify the

Element Template

Construct Template
location of the default template file. To

General View Tem-
plate change any of these values, click  , select

a different drawing template, and click Open.Section/Elevation
View Templates

Detail View Template

Specifies the location of the default template
file for creating new sheets. To change this

Sheet Template

value, click  , select a different drawing
template, and click Open.
If the sheet set is locked for the project, this
property is read only.

6 Click OK to return to the Project Browser.

Adding Detailed Information to Project Properties
Use this procedure to add detail information to a project.

Project details are user-defined information items that can be attached to a
project. Details might include contact information about contractors, legal
representatives, or others. You can also use project details to track changes
and improvements to the project.
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You can create detail categories such as Financial Data which might contain
detail items such as Loan Amount or Grant Amount. The details worksheet
lets you create an information model that meets your needs.

If you create a project based on a project template, you can use the project
detail categories and items from an existing project, For more information,
see Creating a New Project on page 328. If you create a new project without a
template, no project details exist.

NOTE Detailed information is saved in the project APJ file in XML format. You can
open the project APJ file in an XML editor in order to edit the detail information.

Project details are not only used in the project APJ file, but are also displayed
as manual properties in the schedule data of a project. You can use the details
to create schedule tables for your project or build title blocks for sheets. For
more information, see Project Schedule Properties on page 535.

1 On the Quick Access toolbar, click Project Browser  .

2 Select the project to which you want to add details, right-click,
and click Project Properties.

3 If necessary, expand Basic ➤ General and for Detailed Information

click  .

4 Add or modify project details as needed:

Then…If you want to…

enter the information in the right
column of the appropriate detail
row.

add or edit the value of the detail
item

click  , enter a name for the new
detail category, and click OK.

add a detail category

select the category, click  , enter
a name for the new detail, and
press ENTER.

add a detail item within a detail
category

select the detail item, and click 
.

remove a detail item
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Then…If you want to…

first delete all detail items in the
detail category; then select the cat-

egory, and click  .

remove a detail category

5 When you are finished editing, click OK twice.

Advanced Project Properties
You can define or modify advanced project properties such as standards,
images, keynotes, detail components, and tool palettes.

Specifying Project Standards
Use this procedure to configure project standards. The Project Standards feature
is disabled by default and lets you establish, maintain and synchronize
standards across all drawings in an AutoCAD Architecture project. Project
standards include standard styles, display settings, and AutoCAD standards
that are used across all project drawings. Standard styles and display settings
are specified in one or more standards drawings associated with the project.
Project drawings can then be synchronized with these standards throughout
the project life cycle, either automatically, or on demand.
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The AutoCAD Architecture Project Standards feature integrates the AutoCAD
Standards checker, allowing you to set up one or more DWS files for AutoCAD
components. AutoCAD components that can be included in a standards check
are:

■ AutoCAD dimension styles

■ AutoCAD layers

■ Text styles

■ Linetypes

In the Configure AEC Project Standards dialog, you define which drawings to
use as the source for standard styles and display settings, which drawings to
use as the source for AutoCAD layers, dimension styles, text styles, and layers,
and how to synchronize the standards in the project. For detailed information
about configuring project standards, see Project Standards on page 599.

Specifying Project Browser and Bulletin Board Images
Use this procedure to specify a BMP image for the project header and an HTML
file for the project bulletin board. You can specify that the HTML file points
to your company home page or a project web site. The current project header
and default HTML bulletin board display in the Project Browser.

1 On the Quick Access toolbar, click Project Browser  .

2 In the project selector, select the project for which to define the
settings, right-click, and click Project Properties.

3 Under Advanced, define or change the Project Browser project
properties as needed.

4 For Bulletin Board, click  , select the HTML page to display in
the Project Browser, and click Open.

The page selected is displayed in the right side of the Project
Browser in an embedded Internet Explorer.

340 | Chapter 7   Drawing Management



5 For Project Image, click  , select the bitmap file to display in
the project header, and click Open.

TIP Due to the relatively small size of the header (64x64 pixels), a
simple image with clear contrasts creates the best effect.

6 Click OK to return to the Project Browser.

Specifying Locations for the Project Folders
Use this procedure to change the location of the project folders. Ideally, the
project folders will not be redirected and will be located under your project
folder as Elements, Constructs, Views, and Sheets. If you change the location
of the project folders, you will need to repath. For more information, see
Specifying the Location of Top-Level Categories on page 396.

1 On the Quick Access toolbar, click Project Browser  .

2 In the project selector, select the project for which to define the
settings, right-click, and click Project Properties.

3 Under Advanced, define or change the Folders project properties
as needed.

DescriptionProperty

Specify whether you want to redir-
ect your elements, constructs,

Redirect Project Folders

views, and sheets folders to a differ-
ent location.
If the value of Redirect Project
Folders is No, the default folder
location for the project is used. For
more information, see Specifying
the Default Project Options on page
318.

If the value of Redirect Project
Folders is Yes, these properties spe-

Elements Folder

Constructs Folder
cify the location of the project

Views Folder
folders. To change any of these
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DescriptionProperty

values, click the value, click Browse,
select a different folder location,
and click OK.

Sheets Folder

4 Click OK to return to the Project Browser.

NOTE Folders must be unique and not ancestors or descendants of
the project folder.

Specifying the Keynote Databases for a Project
To ensure the compliance with a specific keynoting standard, for example the
CSI standard, you can use the following procedure to specify the relevant
keynote databases for a project. For more information, see Annotation and
Keynoting Tools on page 3587.

1 On the Quick Access toolbar, click Project Browser  .

2 In the project selector, select the project for which to define the
settings, right-click, and click Project Properties.

3 Under Advanced, define or change the Keynotes project properties
as needed.

4 For Project Keynote Database, click  . (The number of databases
associated with the current project is noted.)

5 In the Add/Remove Keynote Databases dialog, click Add to add a
keynote database to the project.

6 To remove a database from the list of databases available in the
project, select the database, and click Remove.

7 Click OK.

8 For Display Non-Project Keynote Databases, specify whether all
keynote databases included on the AEC Content tab in the
Options dialog display in addition to keynote databases specified
for the project.

9 Click OK to return to the Project Browser.
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Specifying the Project Detail Component Databases for a Project
Use this procedure to specify the relevant detail component databases for the
project. For more information, see Detail Components on page 3527.

1 On the Quick Access toolbar, click Project Browser  .

2 In the project selector, select the project for which to define the
settings, right-click, and click Project Properties.

3 Under Advanced, define or change the Detail Components project
properties as needed.

4 For Project Detail Component Database, click  . (The number
of databases associated with the current project is noted.)

5 In the Configure Detail Component Databases dialog, click Add
to add a detail component database to the project.

NOTE Only correctly structured detail component databases can be
added here; if you try to add a database with a different structure,
you receive an error message.

6 To remove a database from the list of databases available in the
project, select the database and click Remove.

7 Click OK.

8 For Display Non-Project Detail Component Databases, specify
whether all detail component databases included on the AEC
Content tab in the Options dialog display in addition to detail
component databases specified for the project.
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9 Click OK to return to the Project Browser.

Adding a Project Content Browser Library and Tool Palette
Group

You can define a project tool palette group and specify a Content Browser
library to be associated with the project. Then, each time the Content Browser
opens from the Project Navigator palette, the project library is displayed.

Project Tool Palette Group

Each project may have a specific tool palette group (ATC files) associated with
it. Depending on how you created the project, the tool palette group can be
created and displayed in different ways.

For a new project, the project tool palette group is empty by default, unless
the project settings point to an existing palette group.

Tool Content Root Path

Setting a tool content root path can help you keep your tools consistent if the
project or the standards drawings are moved during the project life cycle.

When tools on the project tool palettes point to the tool content root path
specified in the project settings, the content root path is created as a variable
(%AECPROJECT_DIR%) in the XML definition of the tool. When the tool
content root path in the project settings is changed, the path of the tools is
changed accordingly.

For example, if all project tools point to content stored under <Project Root
Folder>\Standards\Content\Content 1\, you can move the content to <Project
Root Folder>\Standards\Content\Content 2\, adjust the tool content root path
in the project setup accordingly, and all tools will now point correctly to
<Project Root Folder>\Standards\Content\Content 2.

Another example is if a user creates an eTransmit package of the project and
its tool content files in order to work offline. When the eTransmit package is
unpacked on the local computer, the tool content root path can be redirected
to a different drive, and all content remains valid.

Later, when the drawings the user modified offline are copied back to the
main project on the P server, the content root path will automatically change
back to P:\ <Project Root Folder>\Standards\Content\Content, because this is the
path of the original APJ file.
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Project Content Browser Library

For a large project, the CAD manager may want to set up a Content Browser
library on a shared network volume, so that all project users have quick access
to standard tools. When the Content Browser opens from the Project Navigator
palette, the library associated with the project will automatically open.

1 On the Quick Access toolbar, click Project Browser  .

2 In the project selector, select the project for which to define the
settings, right-click, and click Project Properties.

The Project Properties dialog is displayed.

3 Under Tool Palettes, specify the location for the project tool palette
group. You can select a local folder or a network folder.

If you do not specify a location, the following default behavior is
automatically selected based on how you created your project:

Project Tool Palette
Group

Tool Palette Group File
Location

Project Type

Created, but not dis-
played. To display the tool

pointing to new empty
ATC file under \<Project-

Legacy project
from Architec-

palette group in the toolName>\Standards\ Work-tural Desktop
2005/2006 palettes set and add toolsspaceToolPalettes\ <Project-

Name>.atc to it, see Displaying the
Project Tool Palette Group
on page 637 and Building
the Tool Palette Group on
page 639.

Created, but not dis-
played. To display the tool

pointing to new empty
ATC file under \<Project-

New project
not based on a
template palette group in the toolName>\Standards\ Work-

palettes set and add toolsspaceToolPalettes\ <Project-
Name>.atc to it, see Displaying the

Project Tool Palette Group
on page 637 and Building
the Tool Palette Group on
page 639.
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Project Tool Palette
Group

Tool Palette Group File
Location

Project Type

Created and displayed
with empty default tool

pointing to new ATC file
under \<Project-

New project
based on de-

palette. To add tools andName>\Standards\ Work-fault AutoCAD
palettes, see Building thespaceToolPalettes\ <Project-Architecture
Tool Palette Group on
page 639.

Name>.atc. By default,
one empty tool palette is
already inserted.

template pro-
ject

Displayed as either copied
tool palette group or refer-
enced tool palette group

If the tool palette group
of the template project is
located within the tem-

New project
based on user-
defined exist-

plate project folder, it willing template
project be copied with all con-

tained palettes to the cor-
responding folder of the
new project. The tool
palette file location of the
new project will point to
the copied tool palette
group.
If the tool palette group
of the template project is
located outside the tem-
plate project folder, the
tool palette file location of
the new project will point
to the same location,
sharing the tool palette
group with the template
project.

4 For Project Tool Palette Group, select Shared Workspace Catalog,
Per User Workspace Catalog, or None.

If you select Shared Workspace Catalog, the path selected for Tool
Palette Group is added to your project profile (AWS), and the tool
catalog is accessed from the specified location. If you select Per
User Workspace Catalog, a folder is created under C:\My
Documents\Autodesk\My Projects\<project name> and the tool palettes
are copied to that folder. If you select None, the project tool
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palette group is disabled for this project, and the other properties
under Tool Palettes do not display.

5 For Tool Content Root Path, you can specify a root path for the
tools used in the project tool palette group. When tools on project
palettes are created with the tool content root path specified in
the project setup, the content root path is created as a variable
(%AECPROJECT_DIR%). When the tool content root path in the
project setup is changed, and the referenced style drawings are
moved to the new location, the path of the project tools is
changed accordingly.

NOTE When a project is repathed, and the content root path is within
the project folder, it will be repathed accordingly.

WARNING When you repath a project that was saved in a version
of AutoCAD Architecture prior to 2010, the drawings are saved in
the new file format. You will no longer be able to open these drawings
in a version of AutoCAD Architecture prior to 2010. Synchronizing a
project with the project standards will also save the project drawings
in the new file format. For more information, see Repath the Project
on page 525.

6 For Content Browser Library, select the default Content Browser
Library (CBL) to be displayed when the Content Browser is opened
from the Project Navigator.

7 Click OK to return to the Project Browser.

Consolidating Inconsistent Project and Sheet Set Information
If the project name and project number you have entered in the sheet set
properties (Creating a Sheet Set Template on page 511) differ from the project
name and number when you created the project (Creating a New Project on
page 328), then the project information is inconsistent and needs to be
consolidated. When you edit the properties of an inconsistent project, you
are prompted to consolidate the project information.

1 On the Quick Access toolbar, click Project Browser  .

2 In the project selector, select the project for which to define the
settings, right-click, and click Project Properties.

If the project name and number of the project and the sheet set
template do not match, a message is displayed:
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Under Use the Project Properties, the name and number from the
project properties are displayed. Under Use the Project Sheet Set
Properties, the different project name and number from the sheet
set is displayed.

Then…If you want to…

select Use the Project Properties. The
name and number of the sheet set are

consolidate the project informa-
tion under the project name and
number overwritten with the project name and

number.

select Use the Project Sheet Set Proper-
ties. The project name and number are

consolidate the project informa-
tion under the project sheet set
name and number overwritten with the project sheet set

name and number.

select Accept properties mismatch.continue to use different names
for the project and the project
sheet set

Moving a Project
Use this procedure to move a project with all its associated files to a different
file location.

When you move a project, all internal paths between the project files are
automatically updated, so that all relationships between drawings are kept
current.
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WARNING When you repath a project that was saved in a version of AutoCAD
Architecture prior to 2010, the drawings are saved in the new file format. You will
no longer be able to open these drawings in a version of AutoCAD Architecture
prior to 2010. Synchronizing a project with the project standards will also save
the project drawings in the new file format. For more information, see Repath the
Project on page 525.

NOTE Do not use Windows Explorer to move a project file to a different location.
This might result in inconsistent project data.

1 Verify that the project is closed. For more information, see Closing
All Project Files on page 350.

2 On the Quick Access toolbar, click Project Browser  .

3 Select the project you want to move, right-click, and click Move
Project.

4 Select the location to which you want to move the project.

5 Click OK.

The project and all its files and folders are moved to the new
location.

Renaming a Project
Use this procedure to rename an existing project.

Renaming the project renames the following project files:

■ Rename the project display name in Project Browser and Project Navigator

■ Rename the APJ file

■ Rename the top project folder

When you rename a project, all internal paths between the project files are
automatically updated, so that all relationships between drawings are kept
current.
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WARNING When you repath a project that was saved in a version of AutoCAD
Architecture prior to 2010, the drawings are saved in the new file format. You will
no longer be able to open these drawings in a version of AutoCAD Architecture
prior to 2010. Synchronizing a project with the project standards will also save
the project drawings in the new file format. For more information, see Repath the
Project on page 525.

NOTE Do not use Windows Explorer to rename a project file. This might result in
inconsistent project data.

1 Verify that the project is closed. For more information, see Closing
All Project Files on page 350.

2 On the Quick Access toolbar, click Project Browser  .

3 In the project selector, select the project you want to rename,
right-click, and click Rename Project.

4 Enter the new name, and click OK.

Closing All Project Files
Use one of the following methods to close all drawing files in the current
project.

■ Click  ➤ Close ➤ All Project Drawings.
This option closes all of the project drawings but leaves the project current
and the Project Navigator displayed.

■ On the Project Navigator palette, right-click below the file tree, and click
Close All Project Files.
This option closes all of the project drawings but leaves the project current
and the Project Navigator displayed.

■ On the Project tab of the Project Navigator palette, click  , then specify
your preferences in the Project Browser - Close Project Files dialog.
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Then…If you want to…

select Always perform selected action,
and then click Close all project files.

always close all project files, close the Project
Navigator, and exit the project environment

when you click 

select Always perform selected action,
and then click Do not close project
files.
This option lets you work on the files
outside the project environment so

always close the Project Navigator and exit the
project environment but leave all project files

open, when you click 

that you do not accidentally make
changes to the project.

click Close all project files.close all project files, close the Project Navigator,
and exit the project environment for this instance

click Do not close project files.
This option lets you work on the files
outside the project environment so

close the Project Navigator and exit the project
environment but leave all project files open for
this instance

that you do not accidentally make
changes to the project.

NOTE When you select Always perform selected action, the Close project drawings
when switching projects option on the AEC Project Defaults tab of the Options
dialog is also selected. See Specifying the Default Project Options on page 318.
Note also that the Project Browser - Close Project Files dialog becomes a hidden

message. It will not display when you click  until you turn it back on as explained
under Hidden Message Settings Dialog Box in AutoCAD Help.

Closing All Project Files | 351



Electronically Transmitting a Project
Use this procedure to create an electronic file set package for a project or to
package files so they can be archived.

The electronic package can include the following:

■ All project drawing (DWG) files, including external references

■ All project XML files

■ The project (APJ) file

■ All project templates

■ The project sheet set (DST) file

■ AutoCAD font map

■ AutoCAD plot style tables

If you want to eTransmit a project, it is recommended that it uses relative xref
paths. You can determine whether a project uses full xref paths or relative
xref paths in the project setup. For more information, see Creating a New
Project on page 328 and Before You Begin: External References on page 314.

For more information about creating packages for electronic transmissions,
see Package a Set of Files for Internet Transmission in AutoCAD Help.

1 On the Quick Access toolbar, click Project Browser  .

2 In the project selector, select the project from which you want to
create an electronic package.

3 Right-click, and click eTransmit.
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The Create Transmittal dialog is displayed. For more information,
see Package a Set of Files for Internet Transmission in AutoCAD
Help.

4 Select the components to include in the electronic package.

5 Select the transmittal setup for the package, and click Transmittal
Setups.

6 In the Transmittal Setups dialog, click Modify.
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The Modify Transmittal Setup dialog is displayed.

7 Under Transmittal package type, select the package type in which
to export your project.

For more information, see Modify Transmittal Setup Dialog Box
in AutoCAD Help.

8 Under File Format, select the format in which to export the
drawing files. If you want to export the project drawings with
their AEC objects:

■ intact (such as walls and doors), select the AutoCAD <version>
Drawing Format.

■ exploded (such as 3D faces and hatches), select the AutoCAD
<version> Drawing Format with Exploded AEC Objects.

9 Under Transmittal file folder, select the folder in which to place
the package.

For example, if you selected ZIP as the transmittal package type
and C:\MyTransfer as the transmittal folder, the ZIP file
containing your project will be placed under
C:\MyTransfer\MyProject.zip.
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10 Under Transmittal file name, specify the method for naming the
transmittal package:

Then…If you want to…

select Prompt for a file name.display a standard file selection dialog
where you can enter the name of the
transmittal package

select Overwrite if necessary.use a logical default file name and, if the
file name already exists, overwrite the
existing file name

select Increment file name if
necessary.

use a logical default file name and, if the
file name already exists, add a number
to the end of the file name

11 Select the transmittal options:

Then…If you want to…

select Use organized folder structure. For
more information, see Modify Transmit-
tal Setup Dialog Box in AutoCAD Help.

NOTE This option is not available
if you are saving a transmittal pack-
age to an Internet location.

duplicate the folder structure
for the files being transmitted
and make the root folder the
top-level folder within the
hierarchical folder tree

select Place all files in one folder.

WARNING Do not select this op-
tion when electronically transmit-
ting project information. When you
place all files in one folder the pro-
ject structure will be flattened.

unpack all files to a single,
specified target folder when
the transmittal package is in-
stalled

select Keep files and folders as is.

NOTE This option is not available
if you are saving a transmittal pack-
age to an Internet location.

preserve the folder structure of
all files in the transmittal pack-
age
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If you are transmitting a project, the following project-related
information is always included in the transmittal package:

■ Project (APJ) file

■ XML files

■ Project template files

12 Specify actions for the transmittal. For more information, see
Modify Transmittal Setup Dialog Box in AutoCAD Help.

13 Identify options to include with the transmittal:

Then…If you want to include…

select Include fonts.

NOTE Because TrueType
fonts are proprietary, they
are not included with the
transmittal package. If any
required TrueType fonts are
not present on the com-
puter to which the transmit-
tal package is copied, the
font specified by the
FONTALT system variable
is substituted.

the associated font files (TXT and SHX)
with the transmittal package

select Include textures from
materials that are attached to
objects or faces.

textures of materials with the transmittal
package

select include files from data
links.

external files referenced by a data link
to the transmittal package

select Include photometric web
files.

photometric web files that are associated
with web lights in the drawing

select Include sheet set data
and files.

the sheet set data and files (DST) in the
transmittal package

14 Enter a description for the transmittal setup, and click OK.
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This description is displayed in the Create Transmittal dialog box
below the list of transmittal file setups. You can select any
transmittal setup in the list to display its description.

15 Click Close, and then click OK to start the electronic transmittal.

Deleting a Project
Deleting a project is a system administrator task. Therefore, you do not perform
it from within the Project Browser but from Windows Explorer.

Deleting the project folder deletes all DWG files, XML files, and the APJ file.
Before you do this, make sure that you really do not need any of these files
anymore. If you do not work on a project any longer but still want to save
the DWG files in it, it is often sufficient to just remove the project context,
as described in Removing the Project Context on page 358.

NOTE Before you delete a project, make sure that is not the current project in
AutoCAD Architecture.

1 In Windows Explorer, navigate to the folder of the project you
want to delete.

2 Delete the project folder.

Closing the Project Browser
Closing the Project Browser leads you to the next phase, where you are working
on the actual building project, creating and editing elements, constructs,
building views, and sheets. In this phase, you work mainly with the Project
Navigator. For more information, see The Project Navigator on page 360.

Close the Project Browser with one of these buttons:

DescriptionButton

Right-click in the AutoCAD Architecture
dialog header, and click Close.

Click the Close button in the lower-right
corner of the Project Browser.

Click the Windows Close button in the up-
per-right corner of the Project Browser.
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Removing the Project Context
Use this procedure to remove all project-related information from the drawing
files of a project. This may be desirable if you want to hand over the files to
a contractor who does not work with the latest version of AutoCAD
Architecture, or if the project no longer exists but you do not want to delete
the drawing files.

Much of the project-related information associated with a drawing file does
not reside in the drawing file itself, but in the accompanying XML file. This
means that you can use all your project files at any time in a
non-project-related drawing context. However, if you want to work
permanently without the project context, it is recommended that you clean
your file set of the unused project files.

Project-related information resides in the following files:

■ The APJ file, which contains the general, high-level project data like name,
number, project details, and project standards.

■ The XML files, each of which stores the project information for an
individual drawing file.

If you delete the APJ file and the XML files, the remaining drawing files no
longer have connections to a project. They are regular AutoCAD Architecture
drawing files and can be copied, edited, and deleted like any other drawing
file.

The drawing files can contain standard styles and display settings, if standards
have been set up for the project. When the XML and APJ files are deleted, any
standard styles and display settings are no longer synchronized in the now
standalone drawings.

NOTE Once the project context has been removed, there is no simple way to
recreate it. if you have removed the project, and want to re-build a project around
the remaining drawing files, build the project from scratch, and import the drawing
files into it.

To remove project-related information

1 In Windows Explorer, navigate to the folder containing the
project.

2 In the project folder, delete the APJ file. For example, if you have
a project named Office Building, delete the file named Office
Building.apj.
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3 Open the Elements, Constructs, Sheets, and Views folders, and
delete the XML files associated with your drawing files.

For example, if your Constructs folder contains First Floor
Construct.dwg, select and delete the file named First Floor
Construct.xml.

4 Repeat the previous step for each drawing file.

NOTE If you reorganize files into a different file structure, you may
have to manually reset broken external reference paths in the
drawings.

Opening a Project from Windows Explorer
You can open AutoCAD Architecture with a specific project set current by
double-clicking the project APJ file in Windows® Explorer. If there is an
AutoCAD Architecture session already open, the new project will become the
active project within the same session. Based on the setting you specify, you
are given the option to close all open drawing files from the previous project.
For more information, see Closing All Project Files on page 350.

When you install AutoCAD Architecture 2012, and the APJ files extension has
not previously been associated with another application, such as an XML
editor, the file association between the APJ file extension and AutoCAD
Architecture is automatically created. If you had previously associated the APJ
file extension with another application, and want to change that association
to AutoCAD Architecture, use the following steps:

1 On the Windows Start menu, click Settings ➤ Control Panel.

2 Double-click Folder Options.

3 Click the File Types tab.

4 Under Registered File Types, scroll to the APJ extension, and select
it.

In the Details section, the default application for opening APJ
files is listed. If the value of Opens with is
AECLAUNCHCURRENTPROJECT.EXE, click OK. If not, click
Restore, or click Change, select AutoCAD Architecture in the Open
With dialog, and click OK.
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To open AutoCAD Architecture from an APJ file, use the following steps:

1 In Windows Explorer, navigate to the project APJ file you want
to open.

APJ files have a specific icon  in Windows Explorer.

2 Double-click the APJ file.

AutoCAD Architecture will be opened with the double-clicked
project set as the current project.

The Project Navigator
After you have selected a project in the Project Browser, you open the Project
Navigator to create and edit the actual building and documentation data. Here
you create elements, constructs, model views, detail views, section views, and
sheets, connecting them with one another.

NOTE Although project files and categories you create on the Project Navigator
palette are shown as files and folders in Windows Explorer, you should not move,
copy, delete, or rename project files from there. Such changes are not updated
on the Project Navigator palette, and you could get an inconsistent view of your
project data. Any changes you make to the project on the Project Navigator palette
are managed and coordinated by the software. Also note that any changes you
make on the Project Navigator palette (such as renaming, deleting, or changing
the file’s properties) cannot be undone using the AutoCAD Undo command.

Opening the Project Navigator
The Project Navigator is opened by default after closing the Project Browser.
If you have manually closed it and want to redisplay it, use any of the following
methods:

■ On the Quick Access toolbar, click Project Navigator  .

■ On the command line, enter AecProjectNavigator.
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The Tabs of the Project Navigator
The Project Navigator has 4 tabs on which you can enter project data. The
tabs correspond to the main phases of project creation: general project
information (levels and divisions), creating building data (constructs and
elements), and creating building documentation (views and sheets).

The Project Tab
The Project tab of the Project Navigator palette is where you enter information
pertaining to the entire project.

On the Project tab, you can do the following:

■ Change project properties. For more information, see Working with Project
Properties on page 333.

■ Add, modify, and delete levels. For more information, see Levels on page
379.

■ Add, modify, and delete divisions. For more information, see Divisions on
page 387.

■ Launch the Project Browser. For more information, see Opening the Project
Browser on page 322.
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■ Launch the Content Browser to access the project library. For more
information, see Displaying the Project Content Browser Library on page
378.

■ Close the current project. For more information, see Closing All Project
Files on page 350.

■ Refresh the project. For more information, see Refreshing the Project
Navigator on page 527.

■ Synchronize the project with project standard styles and display setting.
For more information, see Synchronizing a Project with AEC Standards on
page 654.

■ Enable and configure project standards. For more information, see
Configuring Project Standards on page 609.

The Constructs Tab
The Constructs tab of the Project Navigator palette is where you add the basic
building objects for your project. For information about commands available
on the context menu, see The Drawing Explorer Context Menu on page 369.

On the Constructs tab, you can do the following:

■ Add, modify, and delete constructs and elements within the project. For
more information, see Constructs on page 400 and Elements in the Building
Project on page 426.
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■ Open and close existing element and construct drawings. For more
information, see Opening and Closing a Construct on page 411 and Opening
and Closing an Element on page 435.

■ Create categories for constructs and elements. For more information, see
Categories on page 390.

■ Reference elements into constructs. For more information, see Attaching
an Element as an External Reference to a Construct on page 414 and
Overlaying an Element as an External Reference to a Construct on page
414.

■ Launch the Content Browser to access the project library. For more
information, see Displaying the Project Content Browser Library on page
378.

The Views Tab
The Views tab of the Project Navigator palette is where you create individual
views of your building data. Views contain constructs and are the primary
location for adding annotation like notes, tags, and dimensions within the
project. After you have created a view drawing, you can create model space
views in it. For information about commands available on the context menu,
see The Drawing Explorer Context Menu on page 369.

On the Views tab, you can do the following:

■ Add, modify, and delete general views, detail views, and section/elevation
views. For more information, see Creating a Model Space View Drawing
from a Callout on page 462.
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■ Add, modify, and delete model space views. For more information, see
Creating a Model Space View on page 468.

■ Open and close view drawings. For more information, see Opening and
Closing a View Drawing on page 461.

■ Change the contents of view drawings. For more information, see Changing
the Properties of a View Drawing on page 463.

■ Create categories for view drawings. For more information, see Categories
on page 390.

■ Launch the Content Browser to access the project library. For more
information, see Displaying the Project Content Browser Library on page
378.

The Sheets Tab
The Sheets tab of the Project Navigator palette is where you create and organize
sheets for your project. Sheets reference views and are used for plotting
drawings.

The Sheets tab is also where you manage the project sheet set, performing
tasks such as creating a table of contents, managing page setups, or publishing
to a plotter, a PDF, a DWF, or a DWFx file. For information about commands
available on the context menu, see The Drawing Explorer Context Menu on
page 369.

The buttons at the top of the Sheets tab let you view sheet information in
either of the following ways: Click the Sheet Set View button to see the sheet
set view.

■  Sheet Set View

■  Explorer View
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Sheet Set View

The Sheet Set View is a tree view of the project sheet set in which you have
access to all publishing capabilities.

In the Sheet Set view, you can do the following:

■ Add, modify, and delete sheets in the project. For more information, see
Creating a Sheet on page 484.

■ Create sheet subsets that define the logical structure of the sheet set. For
more information, see Creating a Sheet Subset on page 490.

■ Open and close sheet views. For more information, see Opening a Sheet
View on page 498.

■ Assign numbers to sheet views. For more information, see Numbering
Sheet Views on page 498.

■ Insert a table of contents. For more information, see Inserting a Sheet List
on page 502.

■ Electronically transmit the sheet set or a sheet subset. For more information,
see Electronically Transmitting Sheets and Sheet Sets on page 508.

■ Archive the sheet set or a sheet subset. For more information, see Publishing
Sheet Sets on page 510.
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■ Publish the sheet set or a sheet subset to a plotter, a PDF, a DWF file, a
DWFx file, or to an alternate page setup. For more information, see
Publishing Sheet Sets on page 510.

■ Create sheet selections for specific tasks. For more information, see Creating
a Sheet Selection on page 506.

■ Manage page and publishing options. For more information, see Publishing
Sheet Sets on page 510.

■ Launch the Content Browser to access the project library. For more
information, see Displaying the Project Content Browser Library on page
378.

Explorer View

The Explorer View is a view of the folder structure and sheet drawings in the
project.

In the Explorer View, you can do the following:

■ Open, close, and delete sheet drawings. For more information, see Deleting
a Sheet Drawing on page 497.

■ Create categories for sheet drawings. For more information, see Categories
on page 390.
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■ Launch the Content Browser to access the project library. For more
information, see Displaying the Project Content Browser Library on page
378.

Using the Project Navigator
The Project Navigator is the main point from which you work with the project.

The Drawing Explorer
The Drawing Explorer is a tree view common to the Constructs, View, and
Sheets tabs of the Project Navigator. This is where the drawing files are
organized. Each tab of the Project Navigator except the Project tab has a
Drawing Explorer tree where the associated project drawing files—elements,
constructs, views, and sheets—are displayed.

■ The Constructs tab organizes constructs and elements in the project.

■ The View tab organizes view drawings, as well as their associated model
space views.

■ The Sheets tab organizes sheet drawings, sheets, sheet views and the sheet
set.

Drawing Explorer

Drawing files belonging to a project are displayed on their respective tabs in
the Drawing Explorer tree view, which lists the drawings in their category
(folder). You can drag and drop, or copy and paste drawing files in the Drawing
Explorer.
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Drawing Explorer of Constructs tab fully expanded

The Preview and Detail Panes
Below the Drawing Explorer on the Project Navigator palette is the Preview
or Detail pane. You display this pane by right-clicking at the bottom of the
Project Navigator palette and selecting Preview/Details Pane from the Tooltip
Style menu. For more information, see Drawing Explorer Tooltips on page 374.

With Preview/Details Pane selected, you can switch modes by clicking 

(Preview) to display a preview or by clicking  (Detail) to display a description
of the drawing file selected.
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The Drawing Explorer Context Menu
When you right-click a drawing file in the Drawing Explorer of the Project
Navigator palette, a context menu displays. The commands on the context
menu can vary slightly based on the type and status of the file selected:

DescriptionCommand

Opens the selected drawing file within
AutoCAD Architecture. Unavailable if the

Open

drawing file is in use or has a read-only at-
tribute.

Returns focus to the selected file if it is
already open in the current drawing ses-
sion.

Bring to Front

Opens the selected file in read-only mode
and displays it in the drawing area. If the

Open read-only

drawing file is already open for write in the
current session, clicking Open read-only
opens a copy and brings that drawing file
to the front.

Closes the selected drawing file. For more
information, see Closing All Project Files on
page 350.

Close

Opens the External References dialog that
lists all external references in the selected

External References

file and lets you unload, reload, and detach
them from a context menu. For more in-
formation, see Displaying External Refer-
ences of a Construct on page 417, Display-
ing External References of a View Drawing
on page 458, or Displaying External Refer-
ences of a Sheet Drawing on page 500.

Creates a new category for the file type
selected: for example, an element category

New ➤ Category

or a construct category. For more informa-
tion, see Categories on page 390.
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DescriptionCommand

Creates a new project file of the specified
type. For a description of these file types,

New ➤ 

Element
see Concepts of Drawing Management on
page 305.

Construct

View Dwg (General, Section/Elevation,
Detail)

Model Space View

Sheet

Converts pre-existing and non-project
drawings into project file drawings.

NOTE The legacy file must be open to run
this command.

Save Current Dwg as
Element

Construct

View (General, Section/Elevation, De-
tail)

Attaches the selected drawing as an extern-
al reference (xref) to the currently active
drawing.

NOTE The xref must be closed when you
attach it.

Xref Attach

Overlays the selected drawing as an extern-
al reference to the currently active drawing.

NOTE The xref must be closed when you
overlay it.

Xref Overlay

Inserts the selected drawing as a block into
the active drawing.

NOTE The drawing being inserted as a
block must be closed when you insert it.

Insert as Block

Cuts the selected file from the Drawing
Explorer. Use this command together with

Cut

Paste to relocate drawing files within the
Drawing Explorer.

NOTE You cannot cut a file that is open.
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DescriptionCommand

Copies the selected file. Use this command
together with Paste to copy a file to a dif-
ferent location.

Copy

Creates a new copy of the construct draw-
ing for each level you specify.

Copy Construct to Levels

References the selected element into one
or multiple constructs you specify.

Attach Element to Constructs

Pastes a cut or copied file to a new file loc-
ation that you specify with the Drawing

Paste

Explorer. After pasting a file in a different
location, you are prompted to repath the
project to update the file information.

Deletes the selected file.

NOTE You cannot delete a file that is cur-
rently open.

Delete

Renames the selected file.

NOTE You cannot rename a file that is
open. After you rename a file, you are
prompted to repath the project to update
the file information.

Rename

Opens the Project Repath Queue dialog in
which you can view the repath queue and

Repath File

repath or delete pending file paths. Unavail-
able if there are no files in the queue.
For more information, see Working with
Design Teams Located Remotely on page
321.

WARNING Selecting Repath migrates your
drawings to the current version format.
This means that you will be unable to open
these drawings in any older version. For
more information, see Repath the Project
on page 525.
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DescriptionCommand

Creates an eTransmit package from the
selected file, including all external refer-
ences.

eTransmit

Opens the properties of the selected pro-
ject drawing file. Depending on the file

Properties

type, the properties can differ. A construct,
for example, has settings for level and divi-
sion assignment; a view has a list of con-
structs assigned to it. For detailed informa-
tion on file properties, see the appropriate
sections for the individual file types.

The Project Navigator Toolbar
As the following table shows, the buttons on the toolbar at the bottom of the
Project Navigator vary according to which tab is active. Some of the same
functions are also available on the context menu for the tab:

Tab LocationDescriptionButton

AllLaunches the Project Browser
 Project Browser

ProjectCloses all project files of the current
project. For more information, see
Closing All Project Files on page 350

 Close Current Project

AllLaunches the Content Browser. If a
project library has been set for the Content Browser

project, it is displayed in the Content
Browser.

AllRefreshes the project information in
the Drawing Explorer to reflect any
changes made.

NOTE Refreshing the project fre-
quently is especially important when
you are working with a project on a
network server.

 Refresh Project
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Tab LocationDescriptionButton

ProjectSynchronizes a project with its project
standards, if they have been estab- Synchronize Projects

lished. For more information, see Syn-
chronizing a Project with the Standards
on page 647.

ProjectOpens the Configure AEC Project
Standards dialog in which you can set Configure Project

Standards up or modify standards for the current
project. For more information, see
Configuring Project Standards on page
609.

Constructs,
Views, Sheets

Adds a new category for elements,
constructs, views, or sheets. You can Add Category

nest categories and create an organiz-
ational tree.

ConstructsCreates a new element.
 Add Element

ConstructsCreates a new construct.
 Add Construct

Constructs,
Views, Sheets

Opens the External References dialog
that lists all external references in the Show External Refer-

ences selected file and lets you unload, re-
load, and detach them from a context
menu.For more information, see Dis-
playing External References of a Con-
struct on page 417, Displaying External
References of a View Drawing on page
458, or Displaying External References
of a Sheet Drawing on page 500.

Constructs,
Views, Sheets

Opens the Project Repath Queue dialog
in which you can view the repath Repath Xref

queue and then update the modified
xref paths. Unavailable if there are no
files in the queue.
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Tab LocationDescriptionButton

WARNING Selecting Repath migrates
your drawings to the current version
format. This means that you will be
unable to open these drawings in any
older version. For more information,
see Repath the Project on page 525.

ViewsCreates a new view.
 Add View

ViewsReloads all of the xrefs needed to gen-
erate the selected view after you have Regenerate View

edited xrefs in the view, added new
references, or changed the view prop-
erties.

SheetsCreates a new sheet drawing.
 Add Sheet

SheetsPublishes the sheet set to the plotter,
DWF, DWFx, or PDF that you specify. Publish

Drawing Explorer Tooltips
To specify the content of the tooltip that displays when you move the cursor
over an item in the Drawing Explorer, right-click an open area on the toolbar
and select one of the following options:

Then…If you want to…

select Preview/Details Pane.display the Preview or Detail pane at the
bottom of the Project Navigator palette

select Close.close the Project Navigator palette

select Tooltip Style, and then click Name.display only the file name

select Tooltip Style, click Preview, and then
click Small, Medium, or Large.

display the name and an image of the
content
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Then…If you want to…

select Tooltip Style, and then click Details.display details, such as the status, location,
and who currently has the file open (if ap-
plicable)

select Tooltip Style, click Preview & Details,
and then click Small, Medium, or Large.

display an image and details

Drag and Drop on the Project Navigator Palette
You can drag and drop files on a Project Navigator tab, from the tab to the
drawing area, or to and from Windows Explorer. Afterwards, you are prompted
to repath the project to update the file information.

The following drag and drop operations are supported:

■ Dragging elements, constructs, views, and sheets from one category in the
Drawing Explorer to another.
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■ Dragging elements, constructs, views, and sheets from the Drawing Explorer
into the AutoCAD Architecture drawing area.

■ Dragging and dropping objects from an open drawing in the drawing area
onto an element or construct in the Drawing Explorer.

■ Dragging drawing files from Windows Explorer to the Project Navigator;
the drop location determines the file type. For example, a file dragged to
a construct category becomes a construct.

The Drawing Status Bar
When you are working with a drawing in a project, the drawing status bar
displays the name of the current project, the name of the project file, and the
project file type. When you open a drawing that does not belong to a project,
no project information is displayed.

Drawing status bar

Displaying the Project Tool Palette Group
Use this procedure to display the project tool palette group in the tool palettes
set.

Depending on the setting of the tool palette file location (as described in
Adding a Project Content Browser Library and Tool Palette Group on page
344), the project tool palette group can be displayed automatically after you
set a project current and close Project Browser, or it can be empty and not be
displayed on the tool palettes set. The project tool palette group is displayed
automatically when it contains at least one palette.

Project tool palette groups that are not automatically displayed will not display
in the following cases:

■ A new project that is not based on a template, and does not point to an
existing tool palette group

■ A legacy project that is not manually redirected to an existing tool palette
group

■ A project that is based on a template project where the Project Tool Palette
Group storage type is set to None.
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■ A project that is based on a template project without project tool palettes

If an empty tool palette group is created for a project, it is not displayed in
the tool palettes set after the project is set current. To display it, add at least
one tool palette.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Design Tools

 .

2 In the title bar of the tool palettes set, click  .

■ If the project tool palette group contains at least one palette,
it is displayed in the list of available tool palette groups and
can be selected.

Selecting the project tool palette group

■ If the tool palette group of the current project is empty, it is
not displayed.
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3 To add a new palette to the empty tool palette group so it will

display the project tool palette group, click  , and click
Customize Palettes.

On the left, all available palettes are listed. On the right, all palette
groups are listed. The empty project tool palette group is listed
there.

4 Right-click in the palettes list on the left, and click New Palette.

5 Enter a name for the new palette.

6 Select the palette, and drag it on the project palette group on the
right.

7 Click Close, and click  again.

The project tool palette group is listed under the available palette
groups and can be selected and displayed.

Displaying the Project Content Browser Library
You can start the Content Browser directly from the Project Navigator, and
display a project-specific Content Browser Library.

If you are working with project standards, the project library should contain
tools referencing project standard styles. If you are not using project standards,
the project library should contain the tools you need in this project.

For information on building a Content Browser library for a project, see Setting
up Standard Tools in a Project on page 622.
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1 Set the project current, as described in Setting a Project Current
on page 327, and close the Project Browser.

2 On the Quick Access toolbar, click Project Navigator  .

3 On the Project Navigator palette toolbar, click  .

The Content Browser is opened with the project library displayed.

Levels
Buildings are segmented into levels (or floors) in the vertical plane. When you
create a project, you determine the number of levels, their floor-to-floor height,
and their floor elevation. When you add or remove levels, the project is
updated with the new level information.

Plan view of identical building core levels

Level Defaults

By default, the first level is present in each new project. It has a floor elevation
of zero and represents the ground floor. You can change the elevation value
for the first level, which is then used as the default elevation for each new
level you insert.

NOTE The unit in which the level height is displayed is dependent on the drawing
defaults of the active drawing.

Levels | 379



Copying Levels with Constructs

You can quickly and easily duplicate floors with identical plans. After creating
one level and assigning the floor plan constructs to it—for example, a layout
of apartments on the first floor—you can easily create new levels, which have
copies of the first level’s constructs assigned to them. You can edit and rename
these constructs later on the Constructs tab.

TIP If you duplicate floor plans in this way, a construct is created for each new
level. If you edit the floor plan later, for example, to add an extra door, edit each
level and construct individually. If your floor plans are going to be absolutely
identical, you can avoid this task. Create an element containing the floor plan,
and reference it into the first construct. Then copy the constructs to the levels.
Each of the copied constructs have the same reference, and you can change them
quickly by changing the referenced element once.

For information on creating constructs and assigning them to levels, see
Creating a New Construct on page 404.

For information on creating elements and referencing them into constructs,
see Creating an Element on page 429, and Attaching an Element as an External
Reference to a Construct on page 414.

Creating a New Level
Use this procedure to add levels to a building.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Project tab, and under Levels, click  .

3 If you want each new level to take its floor elevation from the
height of the level below, click Auto-Adjust Elevation.

4 Add a level using one of the following methods:

Then…If you want to…

click  . The default floor-to-floor
height of the new level is identical

add a level above the current level

to the level below. If you have selec-
ted Auto-Adjust Elevation, the
level’s floor elevation starts on top
of the previous level.

380 | Chapter 7   Drawing Management



Then…If you want to…

NOTE Alternatively, you can
select the level above which
you want to add a level, right-
click, and click Add Level
Above.

select the level below which you
want to add a level, right-click, and
click Add Level Below.

NOTE If you add a level below
the ground floor and you have
selected Auto-Adjust Elevation,
the elevation of the new level
is a negative height.

add a level below the current level

NOTE If you add a level between existing levels and you have selected
Auto-Adjust Elevation, the elevations of all levels above or below the
new level are automatically adjusted.

5 If necessary, edit the properties of the new level:

Then…If you want to…

click the name, and enter a new
one. Note that you cannot give the

change the name of the level

same name to 2 different
levels—the name is the unique
identifier of the level when assign-
ing constructs.

enter a new value. If you have selec-
ted Auto-Adjust Elevation, the base

change the base elevation of the
level

elevation fits with the elevation and
floor height of the level below, and
you won’t need to make changes
here.
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Then…If you want to…

NOTE The base elevation of a
level determines where the level
starts on the horizontal plane.
Usually, the base elevation of a
level is determined by the floor-
to-floor height of the level be-
low.

enter a new value. If you add levels
above this level and you selected

change the floor-to-floor height of
the level

Auto-Adjust Elevation, they use the
floor height of this level as the base
elevation.

enter a new ID. The ID can be used
in schedule tables. For more inform-

change the ID of the level

ation on scheduling a project, see
Workflow for Annotating a Project
on page 529.

enter a description for the level.add a description to the level

6 When you are finished adding levels to the project, click OK.

7 Click Yes in the subsequent dialog to update the changed level
information throughout the project.

Copying a Level with Assigned Constructs
Use this procedure to copy an existing level and all its assigned constructs
within the building.
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3D view of copied levels with assigned constructs

When you create a new level, it is empty and has no constructs assigned. After
you have assigned constructs to the level, as described in Creating a New
Construct on page 404, you can copy that level and its constructs within the
building. For example, perhaps you have created a first-floor level and assigned
3 apartment constructs to it. To create a second-floor level with exactly the
same layout, you can copy and paste the first level with its apartment
constructs and rename it “Second Floor.”

1 Create a level and assign constructs to it.

For more information, see Creating a New Construct on page 404.

2 On the Quick Access toolbar, click Project Navigator  .

3 Click the Project tab, and under Levels, click  .

4 Select the name of the level you want to copy, right-click, and
click Copy Level and Contents.

5 Click the level above or below the one on which you want to
place the copied level, right-click, and click Paste Level Above or
Paste Level Below.

6 Rename the pasted level accordingly: for example, Second Level.

7 If necessary, edit the description and the ID.

8 Click OK.

9 Click Yes in the subsequent dialog to update the changed level
information throughout the project.

10 Click the Constructs tab.
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11 Locate the Constructs category.

The constructs that were created by copying the level and
constructs are below the original construct. For example, if you
copied the first-floor-level with a construct named First Floor—Left
Apartment, you now have 2 constructs: First Floor—Left
Apartment and First Floor—Left Apartment (2).

12 If necessary, rename the copied construct with an appropriate
name: for example, Second Floor—Left Apartment.

13 To update the Drawing Explorer, click  .

Changing the Properties of a Level
Use this procedure to change the properties of a level.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Project tab, and under Levels, click  .

3 Change the level information as needed:

Then…If you want to…

click the name, and enter a new
one. Alternatively, you can select

change the name of the level

the name, right-click, and click Re-
name Level.

click the floor elevation, and change
it.

NOTE If you have selected
Auto-Adjust Elevation, the levels
above and below the level are
changed accordingly. To pre-
vent this, clear Auto-Adjust Elev-
ation before making changes to
the elevation.

change the elevation of a level
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Then…If you want to…

click the floor-to-floor height, and
change it.

NOTE If you have selected
Auto-Adjust Elevation, the levels
above and below the level are
changed accordingly. To pre-
vent this, clear Auto-Adjust Elev-
ation before making changes to
the elevation.

change the floor-to-floor height of
a level

click the ID, and change it.change the ID of a level

click the description, and change
it.

change the description of a level

4 Click OK.

5 Click Yes in the subsequent dialog to update the changed level
information throughout the project.

Deleting a Level
Use this procedure to delete a level from a building.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Project tab, and under Levels, click  .

3 Click the name of the level to delete.

4 Delete the level using either of the following methods:

■ Right-click, and click Delete Level.

■ In the Levels dialog, click  .

5 Click OK.

6 Click Yes in the subsequent dialog to update the changed level
information throughout the project.

NOTE Constructs assigned to the deleted level are not deleted.
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Changing Levels: Interactions with the Project
Changes made to one part of a project frequently influence other parts of the
project. The following information describes the changes you can make to a
level and the effects of the changes on other parts of the building project:

■ Adding new levels: When you add a new level to a project, you must assign
constructs. You also need views and sheets to represent that level.
For more information, see Constructs on page 400, Views on page 446, and
Sheets on page 481.

■ Changing the level name: When you change the name of a level, the
constructs assigned to it are automatically updated to reference the new
name. For example, if you change the name of a level from 1 to First Floor,
the constructs assigned to that level are automatically updated to be
assigned to First Floor.

■ Changing the level ID: Level IDs can be used in schedule tables. If you
change the information here, the information in your schedule table
changes.

■ Changing the floor-to-floor height of a level: When you change the
floor-to-floor height of a level and you have selected Auto-Adjust Elevation,
the floor-to-floor height of all the levels are adjusted. The multi-level view
regenerates to adjust for the change in height. For example, if you change
the height of the first floor from 3 meters to 4 meters, the elevation of the
second level changes from 3 meters to 4 meters. If you have chosen not
to auto-adjust levels, you need to update all other levels manually to avoid
gaps or overlapping levels. In any case, make sure that the objects in the
assigned constructs retain the correct height for the level after changing
it. That way, you avoid displaying 4 meter walls in a 3 meter level.

■ Changing the floor elevation of a level: If you are changing the elevation
of a level and you have selected Auto-Adjust Elevation, the elevation of
all the levels are adjusted. The multi-level view regenerates to adjust for
the changes in elevation.

■ Deleting a level: When you delete a level, constructs assigned to that level
are not deleted with it. They remain in the project, but they are “orphaned,”
that is, they have lost their level. You can choose what to do with them:

■ Delete them, because the level on which they are placed no longer
exists.

■ Assign them to a different level within the project.
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■ When you delete a level that has been used for a view, the view is not
deleted from the project. If you update the view, however, it is missing
this level. You can choose among these actions:

■ Delete the view, because the level it was displaying no longer exists.

■ Create a new selection set for the view.
For more information, see Views on page 446.

Divisions
Divisions segment the building in the horizontal plane. A division might be
a wing of a building. By default, each new project in AutoCAD Architecture
has one division. You can add divisions, change their properties, and delete
them.

Building and wing schematic

In most projects, you work with only one horizontal division.

Creating a New Division
Use this procedure to add divisions to a project.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Project tab, and under Divisions, click  .

3 Add a division using either of the following methods:

■ Right-click in the list, and click Add Division.

■ In the Divisions dialog, click  .
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4 If necessary, edit the division settings:

Then…If you want to…

click the name, and enter a new
one. Alternatively, you can select

change the name of the division

the name, right-click, and click Re-
name Division.

NOTE You cannot give the
same name to 2 divisions; the
name is the unique identifier of
the division when assigning
constructs to it.

enter a new ID. The ID can be used
for schedule tables. For more inform-

change the ID of the division

ation on scheduling a project, see
Workflow for Annotating a Project
on page 529.

enter a description, and press
ENTER.

add a description to the division

NOTE The division names are displayed in the order of their creation.

5 When you have finished adding new divisions to the project, click
OK.

Changing a Division
Use this procedure to change the properties of a division.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Project tab, and under Divisions, click  .

3 Change the division information as needed:

Then…If you want to…

click the name, and change it.change the name of the division
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Then…If you want to…

click the ID, and change it. The ID
can be used in schedule tables.

change the ID of the division

click the description, and change
it.

change the description of the divi-
sion

4 Click OK.

Deleting a Division
Use this procedure to delete a division from the building project.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Project tab, and under Divisions, click  .

3 Click the name of the division to delete.

4 Delete the division using either of the following methods:

■ Right-click, and click Delete Division.

■ Click  .

5 Click OK.

6 Click Yes in the subsequent dialog to update the changed division
information throughout the project.

Changing Divisions: Interactions with the Project
Changes made to one part of a project frequently influence other parts of the
project. The following information describes the changes you can make to a
division, and the effects of the changes on other parts of the building project:

■ Adding new divisions: When you add divisions to a project, you must
assign constructs. You also need views and sheets to represent that division.
For example, you might create a view named South Wing and a sheet
Plan—South Wing.
For more information, see Creating a New View Drawing on page 453.

■ Changing the division name: When you change the name of a division,
the constructs assigned to it are updated with the new name. For example,

Deleting a Division | 389



if you change the name of a division from SW to South Wing, the
constructs assigned to that division are updated to be assigned to South
Wing.

■ Changing the division ID: Division IDs can be used in schedule tables. If
you change the information here, the information in your schedule table
changes.

■ Deleting a division: When you delete a division, constructs assigned to
that division are not deleted with it. They are considered orphaned and
have lost their division. You can choose among the following actions:

■ Delete the constructs because the division in which they were placed
no longer exists.

■ Assign them to a different division within the project.

When you delete a division that has been used for a view, the view is not
deleted from the project. If you update the view, however, the deleted
division is missing. You can choose among the following actions:

■ Delete the view because the division it was displaying no longer exists.

■ Create a new selection set for the view.

Categories
The basic categories are represented by folders in the Drawing Explorer within
the project structure that help you organize your project files according to
disciplines, drawing types, or aspects of your workflows.

The Basic Project Categories

For every building project in AutoCAD Architecture, the following basic
category structure is displayed on the Project tab of the Project Navigator
palette:

■ <ProjectName>: This is the top node in the project, represented by a folder
with the project name.
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■ Constructs: This is the default category for constructs in the project. When
you create a construct, it is saved into the Constructs category or one of
its subcategories. For more information, see Constructs on page 400.

■ Elements: This is the default category for elements in the project. When
you create an element, it is saved into the Elements category or one of its
subcategories. For more information, see Elements in the Building Project
on page 426.

■ Views: This is the default category for view drawings in the project. When
you create a view drawing, it is saved into the Views category or one of its
subcategories. For more information, see Views on page 446.
If you create model space views within a view drawing, they are placed
under the view drawing in the same category as the view drawing itself.

■ Sheets: Sheets in the project can be viewed in 2 ways: the Sheet Set View
and the Explorer View. The following image is a Sheet Set View.

The following image is an Explorer View.
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Sheets are organized in sheet subsets in the Sheet Set View. Sheet subsets
are a logical structure rather than a physical one. The sheet folder category
does not need to be identical to the sheet subset in which the sheet is
placed, however, to avoid confusion, it is recommended that you have
parallel structures in the sheet set and the sheet categories.

You can rearrange sheets into different subsets within the Sheet Set View,
but that will not change their physical location in the category or folder.
Likewise, when you remove a sheet from a sheet subset in the Sheet Set
View, only the reference of the sheet to the subset is removed; the layout
itself and its containing sheet drawing are not deleted from the Sheets
folder or subfolder. For more information, see Sheets on page 481.

In the Explorer View, sheet drawings are placed in folder categories. When
you create sheets or sheet views within a sheet drawing, they are placed
in the sheet drawing.

User-Defined Categories

Within the main category structure which is fixed, you can create subcategories
and subcategory trees. Subcategories usually represent aspects of your workflow.
You might set up subcategories by discipline, by view type (such as working,
presentation, section, and rendering), by sheet type (such as floor plan, ceiling
plan, elevation), or by any other system that you find helpful.
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NOTE You cannot mix basic category types. For example, you cannot create a
construct subcategory within the Views category or an element subcategory within
the Sheets category.

Your Constructs tab might look like this:

The Benefits of Categories

Categories offer optimal organization and transparency. Even small building
projects contain a large number of individual drawings that are difficult to
track. Putting them into descriptive categories helps you quickly find the
correct files.

Categories help you to assemble views. When you create views of your building
data, you can use categories as selection or filter criteria. For example, for a
complete view of framing constructs in your building, you could set up a view
that references a Framing subcategory, thereby referencing all drawing files
from that category. If you add more framing construction to the Framing
category later, the view is updated to include the appropriate constructs. For
more information, see Creating a View Drawing: Selecting the Constructs on
page 456.

Methods of Creating Categories

You can create categories on the Project Navigator palette or in Windows
Explorer as described in the topics that follow.

Creating a Category in the Drawing Explorer
Use this procedure to create a new category in the Drawing Explorer.

Creating a Category in the Drawing Explorer | 393



1 On the Quick Access toolbar, click Project Navigator  .

2 Navigate to the tab for the category type you want to create.

3 If you want to create a sheet category, click the Sheets tab, and

click  (Explorer View).

4 To create a category under an existing category, click the existing
category in the tree, and create a new subcategory using either of
the following methods:

■ Right-click, and click New ➤ Category.

■ Click  on the toolbar at the bottom of the tab.

5 Enter a name for the category, and press ENTER.

You can now add project files to the new category.

Creating a Category from Windows Explorer
Use this procedure to create a new category in your project by dragging a
folder from Windows Explorer into the Drawing Explorer of the Project
Navigator palette. This adds a folder and its contents to your project.

1 On the Quick Access toolbar, click Project Navigator  .

2 Navigate to the tab for the category type you want to create.

3 If you want to create a sheet category, click the Sheets tab, and

click  (Explorer View).

4 Start Windows Explorer and position it next to the Project
Navigator.

5 Select the folder in Windows Explorer from which you want to
create a category.

6 Place the folder in the Drawing Explorer of the selected tab of the
Project Navigator:

Then…If you want to…

drag the folder to the desired loca-
tion.

move the folder out of its current
location

CTRL-drag the folder to the desired
location

copy the folder from its current
location
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Dragging a folder from Windows Explorer to Project Navigator

NOTE If the folder you are dragging onto the Project Navigator
palette contains drawing (DWG) files, you are prompted to add each
one as a project file. For example, if you drag a folder into the
Elements category in the Drawing Explorer, the Add Element dialog
displays prompting you to add each DWG file within that folder as
an element. For detailed information on converting existing drawing
files into project files, see, Converting a Drawing to a Construct on
page 408 and Converting a Drawing to an Element on page 431.
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For more information on updating files, see Repath the Project
on page 525.

Specifying the Location of Top-Level Categories
When you want to specify an alternate location for the top-level category
folders (Constructs, Elements, Views, and Sheets), the best practice is to start
with a new project. Organize the project structure in Windows Explorer first,
with the categories located in the same root folder as the APJ file. For example,
you could structure your project with Constructs, Elements, Views, and Sheets
under a category called Drawings. For more information, see Creating a New
Project on page 328.

Top-level categories within project structure

These top categories can be directed to point to unique folders, but they cannot
be an ascendant or descendant of each other in the tree structure. When you
want to change the location of a category in an existing project, create the
new category in Windows Explorer, and move the files from the old category
into the new category in Windows Explorer first before you redirect the
category.

NOTE If you locate top-level category folders outside the project folder, the project
cannot be used as a template for new projects.
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Top-level category located outside the project folder

Redirecting Top-Level Categories
Use this procedure when you want to change the location of the top-level
categories in your project after you have created new category folders in
Windows Explorer. You can redirect the path of Constructs, Elements, Views,
and Sheets.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Project tab, and under Current Project, click  .

3 In the Project Properties dialog, expand Advanced, and under
Folders for Redirect Project Folders, select Yes.

4 Click  for the category you wish to redirect, and browse to the
location for the new folder.

5 Select the new folder, and click OK.

Paths for files within the category are redirected to the new
location.

Changing the Subcategory of a Project File
By default each drawing file you create within a project is assigned to one of
the top-level, predefined categories—Elements, Constructs, Views, or Sheets.
After you have created a more detailed category system for your project, you
can move drawing files into the subcategories.
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Creating a File in a Subcategory
Use this procedure to create a project file within a subcategory.

1 On the Quick Access toolbar, click Project Navigator  .

2 Navigate to the tab for the file type you want to create.

3 If you want to create a file in a sheet category, click the Sheets

tab, and click  (Explorer View).

4 Locate the subcategory in which you want to create a project file.

5 Select the subcategory, right-click, and click
New ➤ Element/Construct/ General View
Dwg/Section/Elevation/Detail/Sheet.

NOTE Alternatively, you can use the Add button at the bottom of
the tab.

6 Specify the properties of the new file.

For more information on specifying new project files, see the
appropriate sections for the individual file types.

Changing the Category of an Existing File
Use this procedure to change the category of an existing file.

1 On the Quick Access toolbar, click Project Navigator  .

2 Navigate to the tab for the category type you want to change.

3 If you want to change a sheet category, click the Sheets tab, and

click  (Explorer View).

4 Locate the project file you want to move to another category.

5 Change the file category using any of the following methods:

■ Select the file, right-click, and click Properties. In the Modify
dialog, change the file category, and click OK.

■ Select the file, and drag it into another subcategory.

■ Select the file, right-click, and click Cut. Select the destination
category, right-click, and click Paste.
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The Project Navigator - Repath Project dialog displays.

6 Update your files to display the changes to your project:

Then…If you want to…

click Repath project now.update all project files at this time

click Repath project later. If you
close the project before repathing,

update all project files at another
time

the drawing files remain in a queue
for update and display in the Project
Repath Queue dialog the next time
you open it.

7 Alternatively, click  to repath all files in the project at any
time.

WARNING When you repath a project that was saved in a version
of AutoCAD Architecture prior to 2010, the drawings are saved in
the new file format. You will no longer be able to open these drawings
in a version of AutoCAD Architecture prior to 2010. Synchronizing a
project with the project standards will also save the project drawings
in the new file format. For more information, see Repath the Project
on page 525.

Deleting a Category
Use this procedure to delete unneeded categories from a project.

Deleting a Category | 399



If you delete a category that contains drawings, the drawings are deleted with
the category.

NOTE Deleting a category from Windows Explorer may result in inconsistent
project data.

1 On the Quick Access toolbar, click Project Navigator  .

2 Navigate to the tab for the category type you want to delete.

3 If you want to delete a sheet category, click the Sheets tab, and

click  (Explorer View).

4 Select the category you want to delete, right-click, and click Delete.

5 Click Yes in the subsequent dialog.

Constructs
Constructs are the main building blocks (or base drawing files) of the building
model. A construct represents one unique portion of a building, such as a
building core, an apartment, or an entire floor.

You assign a construct to a level and a division within the project. For example,
you could assign an architectural construct named Interior Partitions—First
Floor/South Wing to the first level and the south wing division of the building.
You could also assign the structural construct Framing—First Floor/South
Wing to the first level and south wing division, but it has a different purpose.
Constructs can span more than one level, a requirement for objects such as
curtain walls.

3D view of spanning curtain wall construct
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Construct Files

A construct is a drawing (DWG) file. As opposed to non-project related drawing
files, an additional XML file with the same name is created. The accompanying
XML file contains information to connect the construct to the project.

NOTE The XML file is created and updated automatically. You do not need to
edit it, but be careful not to accidentally delete it in Windows Explorer.

Copying Constructs to Levels

In multi-story buildings, levels may have identical floor plans. You can create
the constructs for one level and copy them to the other levels in one quick
step. For detailed information, see Copying Constructs to Levels on page 407.

Converting Legacy Drawings to Constructs

You can convert an existing drawing file into a construct within a project.
You specify the subcategory into which to move or copy the source drawing.

When you convert a legacy drawing file into a construct:

■ The drawing file is either moved, copied, or connected through a link to
the project category you specify.

■ You assign a level and a division to the construct.

■ If necessary, you give the construct a different name, and add a description
to it.

For detailed information, see Converting a Drawing to a Construct on page
408.

Constructs and Views

You use constructs to create views of a project. You could create a view named
First Floor, which displays the following constructs:

■ Interior Partitions—First Floor/South Wing

■ Framing—First Floor/South Wing

■ Ceiling—First Floor/South Wing

■ Spanning Front Curtain Wall
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This view would contain all objects in the South wing of the first floor. You
select the constructs to include in the view when you identify view properties.
You can add or remove constructs from views.

3D view of building first floor

When To Start with Constructs
You start creating constructs when you want to assemble the basic objects of
your building project into base files.

Typically, you begin a project by creating constructs. Adding optional elements
often comes later in the process. For example, perhaps you know how many
offices you need on a floor before you know the exact furniture layout of the
offices. Therefore, you would first create the construct for the office walls and
doors, First Floor—Office Space. Later, you could create elements for desk/chair
combinations or generic printer/copier layouts and reference them into the
construct with the office walls and doors.

Plan view of construct with highlighted furniture elements

The Role of Constructs in the Building Project
Constructs are the main building blocks or base files of the building model.
A construct can contain referenced elements and building objects, such as
walls, roofs, and doors. It can also contain more abstract information, like
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structural grids, building outlines, and footpaths. After creating constructs,
you can create different views of your building data. A view might contain
the framing constructs for floors 1–4, the foundation construct, and the column
grid construct. Or, a view of the first floor might include the partition walls
of the first floor, the framing of the first floor, and the shell components of
the building.

The Content of Constructs
There are 3 different types of content you can place in a construct:

■ Drawing objects: You can draw an entire floor, apartment layout, a frame
drawing, or a ceiling grid as a construct. Also, spanning objects like curtain
walls or elevator shafts are usually created directly as constructs.

■ Element references: You can display repeating components within the
construct, such as desk/chair combinations, bathroom layouts, or stairs.
For more information, see Referencing Elements into Constructs on page
413, and Referencing an Element into Multiple Constructs on page 415.

■ A combination of drawing objects and element references: If you have a
floor with different office types, but repeating furniture elements, you
could draw the office walls directly in the construct but reference the
furniture as elements.

You should not, as a general rule, reference constructs into constructs. A
construct has a defined level and division assignment. If a construct were to
be referenced into another construct, it may have 2 contradicting level and
division assignments. However, there are situations where the necessity to do
this can occur. For example, when you are checking the correct vertical
alignment of a ceiling in the building, you could view a ceiling construct with
an overlaid floor plan construct in it. Or, you might want to display alternating
versions of a 2 car garage and a 3 car garage within a plan construct. If you
encounter a situation where you would need to do this, there are several
options that can serve as a work-around:

■ Overlay the construct onto the other construct.
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■ Convert the first construct to an element, as described in Converting a
Construct to an Element on page 423, and then reference it into the other
construct.

WARNING Do not attach property set data to an overlaid construct from
within the host construct. This data is not carried forward into views. Attach
the property data locally in the overlaid construct.

■ Create a view into which you reference both constructs. For more
information, see Creating a New View Drawing on page 453.

Which of these options is best for you largely depends on your workflow and
the results you want to achieve.

Creating a New Construct
Use this procedure to create a new construct within a project.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the Constructs category or
subcategory where you want to add the new construct.

3 Open the Add Construct dialog using one of the following
methods:

■ Right-click the category in which to place the new construct,
and click New ➤ Construct.
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■ On the toolbar at the bottom of the Constructs tab, click 
. (You then specify the category in the dialog.)

4 Define the construct properties:

Then…If you want to…

enter a name. If the project number
is used as a prefix for project file

name the new construct

names, you do not need to enter
the prefix here. The complete name
with prefix is displayed under File
Name. For more information on
prefixes, see Specifying Basic Project
Properties on page 334.

click the setting for Description,
enter a description of the construct,
and click OK.

enter a description for the construct

select a category from the Category
list. By default, the category you
chose in step 3 is suggested.

change the category of the con-
struct
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Then…If you want to…

click  , and browse for a new
template. The software uses the

select a different template file

default template set for constructs
in the project.

select the correct level and division
in the assignments table. Select the

assign the construct to a level and
a division

desired level row and the division
column, and check the appropriate
box.

NOTE You should check only
one level and division. Multiple
levels and divisions create
spanning constructs.

5 If you want to work in this construct immediately, select Open
in drawing editor.

For information about other methods of opening constructs, see
Opening and Closing a Construct on page 411.

6 Click OK.

7 Edit the construct as necessary:

■ Add objects to the construct.

■ Reference elements into the construct.
For information on adding content to constructs, see The
Content of Constructs on page 403.

8 Close the construct using either of the following methods:

■ Right-click the construct in the Drawing Explorer, and click
Close.

■ Click  ➤ Close ➤ Current Drawing.

9 Click Yes to save the changes in the drawing, if necessary.

10 To update the tree view in the Drawing Explorer, click  .
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Copying Constructs to Levels
Use this procedure to copy a construct to multiple levels.

Copying constructs to levels is an easy way to fill multi-story buildings with
content. You draw the construct for the first level, and then create a copy of
that construct for each level you select.

Copying constructs to all levels schematic

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, select the construct to copy to multiple
levels, right-click, and click Copy Construct to Levels.

3 Select the levels on which to create a copy of the construct.

NOTE The level on which the original construct is situated is selected
by default. You cannot clear the selection here.

4 Click OK.

A new construct is created for each level selected. The level number
is appended in brackets after the construct name.

NOTE To rename a copied construct, select it in the Drawing Explorer, right-click,
and click Rename.
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Converting a Drawing to a Construct
You may have drawing files in AutoCAD Architecture that you want to convert
into constructs. When you convert a drawing into a construct:

■ The drawing file is either moved, copied, or connected via a link to the
project category you specify.

■ You assign a level and a division to the construct.

■ If necessary, you give the construct a different name, and add a description
to it.

There are 2 ways to convert a drawing file into a construct: you can open the
drawing file in AutoCAD Architecture and save it as a construct, or you can
drag a drawing file from Windows Explorer to the Project Navigator.

Converting Drawing Files by Saving as a Construct
Use this procedure to convert a drawing file to a construct by opening the file
in AutoCAD Architecture and then saving it as a construct.

1 Click  ➤ Open ➤ Drawing.

2 In the Select File dialog, select the file, and click Open.

3 On the Quick Access toolbar, click Project Navigator  .

4 On the Constructs tab, locate the Constructs category or any of
its subcategories.

5 Right-click, and click Save Current Dwg as Construct.

6 Define the construct properties:

Then…If you want to…

enter a new name. If the project
number is used as a prefix for pro-

change the name of the drawing
file

ject file names, you do not need to
enter the prefix here. The complete
name with prefix is displayed under
File Name. For more information
on prefixes, see Specifying Basic
Project Properties on page 334.
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Then…If you want to…

click the setting for Description,
enter a description of the construct,
and click OK.

enter a description for the construct

select one from the Category list.
By default, the category you chose
in step 4 is suggested.

change the category of the con-
struct

select the correct level and division
in the assignments table. Select the

assign the construct to a level and
a division

desired level row and the division
column, and check the appropriate
box.

NOTE You should check only
one level and division. Multiple
levels and divisions create
spanning constructs.

7 Click OK.

Converting Drawing Files Using Windows Explorer
Use this procedure to convert drawing files to constructs by dragging and
dropping them from Windows Explorer.

Windows Explorer offers 3 different modes of conversion:

■ Converting a file to a construct and moving it into a project folder

■ Copying a file, and converting the copy to a construct in a project folder

■ Converting a file to a construct and creating a link to its original location

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Constructs tab.

3 Start Windows Explorer, and position it next to the Project
Navigator.

Converting a Drawing to a Construct | 409



4 In Windows Explorer, open the folder that contains the drawing
file.

5 Place the drawing in the Constructs category or one of its
subcategories:

Then…If you want to…

drag the drawing into the desired
location in the Drawing Explorer.

move the drawing into the selected
category, and convert it to a con-
struct

CTRL-drag the drawing into the
desired location in the Drawing Ex-
plorer.

move a copy of the drawing into
the selected category, and convert
it to a construct

ALT-drag the drawing into the de-
sired location in the Drawing Ex-
plorer.

create a link to the drawing in its
original location, and convert it to
a construct

NOTE You can also drag an entire folder into the project. The folder
is converted into a category, and all drawings within it are converted
to constructs. For instructions on converting legacy folders to
categories, see Creating a Category from Windows Explorer on page
394.

6 Define the construct properties:

Then…If you want to…

enter a new name. If the project
number is used as a prefix for pro-

change the name of the drawing
file

ject file names, you do not need to
enter the prefix here. The complete
name with prefix is displayed under
File Name. For more information
on prefixes, see Specifying Basic
Project Properties on page 334.

click the setting for Description,
enter a description of the construct,
and click OK.

enter a description for the construct
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Then…If you want to…

select from the Category list. By
default, the category you chose in
step 5 is suggested.

change the category of the con-
struct

select the correct level and division
in the assignments table. Select the

assign the construct to a level and
a division

desired level row and the division
column, and check the appropriate
box.

NOTE Unless you are defining
a spanning construct, you
should check only one level and
division. Multiple levels and di-
visions create spanning con-
structs.

7 Click OK.

Opening and Closing a Construct
Use this procedure to open and close a construct. For information about
additional commands available on the context menu, see The Drawing Explorer
Context Menu on page 369.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the Constructs category or the
subcategory that contains the construct to open.

3 Open the construct using either of the following methods:

■ Select the construct, right-click, and click Open.

■ Double-click the construct.

The construct is opened in the drawing area of AutoCAD
Architecture.
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When you open a construct, the status line in the AutoCAD
Architecture drawing area displays the name of the associated
project.

4 Close the construct using either of the following methods:

■ Right-click the construct in the Drawing Explorer, and click
Close.

■ Click  ➤ Close ➤ Current Drawing.

5 Click Yes to save the changes in the drawing, if necessary.

Dragging Objects into a Construct
Use this procedure to drag and drop objects from the drawing screen into a
construct.

When you create a new construct, you have several choices for adding content
to it. You can draw objects within the construct, you can reference elements
into a construct, or you can drag and drop objects from other drawing files
into a construct.

1 Open the drawing that contains the objects you want to drag and
drop into the construct.

The drawing containing the objects is not required to be a part
of a project.

2 On the Quick Access toolbar, click Project Navigator  .

3 On the Constructs tab, locate the Construct to which you want
to add objects from another drawing file.

4 In the open drawing file, select the objects you want to drag and
drop into the construct.

5 Move or copy the objects into the construct.

Then…If you want to…

drag them from the drawing onto
the desired construct in the Draw-
ing Explorer.

move the objects from the open
drawing to the construct
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Then…If you want to…

CTRL-drag them from the drawing
onto the desired construct in the
Drawing Explorer.

copy the objects from the open
drawing to the construct

NOTE You can also drop objects on the category to create a new
construct containing the objects.

Referencing Elements into Constructs
There are several ways to reference an element into a construct:

Then…If you want to…

attach an element as an external reference.
Any changes to the referenced element are

create a link from the element to the con-
struct

displayed in the construct when it is
opened or refreshed. For more information,
see Attaching an Element as an External
Reference to a Construct on page 414.

overlay an element as an external refer-
ence. An overlaid reference is not included

create a link from the element to the con-
struct

when the construct is attached or overlaid
as a reference to a view. For more informa-
tion, see Overlaying an Element as an Ex-
ternal Reference to a Construct on page
414.

insert an element as a block reference. The
inserted element is converted to a block

cut off the link between the element and
the construct

and is not updated when the reference
element is changed. You can, however,
edit the block in the construct. For more
information, see Inserting an Element as a
Block into a Construct on page 415.
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3D view of cubicle element referenced 4 times into office space construct

Attaching an Element as an External Reference to a Construct
Use this procedure to attach an element as an external reference to a construct.

For detailed information on attaching external references to drawings, see
“Reference Other Drawing Files (Xrefs)” in AutoCAD Help.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, select the element to reference.

3 Reference the element into a construct using one of the following
methods:

■ With a construct open in your drawing area, drag the element
into the open construct drawing.

■ With a construct open in your drawing area, right-click the
element, and click Xref Attach.

■ Right-click, click Attach Element To Constructs, and in the
Attach Element to Construct dialog, select the constructs into
which to reference the element, and click OK.

The element is attached as an external reference to the construct
at 0, 0, 0.

NOTE If you cannot see the element, it may be inserted at 0, 0, 0.
Use the AutoCAD Zoom Extents command to display it.

Overlaying an Element as an External Reference to a Construct
Use this procedure to overlay an element as an external reference to a construct.
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For detailed information on overlaying external references to drawings, see
“Reference Other Drawing Files (Xrefs)” in AutoCAD Help.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the construct into which to reference
an element, right-click, and click Open.

3 On the Project Navigator palette, locate the element to overlay.

4 Select the element, right-click, and click Xref Overlay.

The element is inserted as an external reference into the construct.

NOTE If you cannot see the element, it may be inserted at 0, 0, 0.
Use the AutoCAD Zoom Extents command to display it.

Inserting an Element as a Block into a Construct
Use this procedure to insert an element as a block into a construct.

For detailed information on blocks, see “Create and Use Blocks (Symbols)” in
AutoCAD Help.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the construct into which to reference
an element as a block, right-click, and click Open.

3 On the Project Navigator palette, locate the element to insert as
a block.

4 Select the element, right-click, and click Insert as Block.

5 Specify the Insert options—such as insertion point, scale and
rotation angle—and click OK.

Referencing an Element into Multiple Constructs
Use this procedure to reference an element into multiple constructs.

This procedure is useful for updating a number of similar floor constructs in
a building.
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Referencing an element into a construct

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the element to reference into
multiple constructs, right-click, and click Attach Element to
Constructs.

3 Check the boxes of the constructs into which to reference the
element.

NOTE As a shortcut, you can select an entire category for referencing.

4 Define the referencing method:

Then…If you want to…

select the construct, right-click, and
click Set to Attach.

NOTE If the Set to Attach
command is unavailable, the
element is already set to attach.

attach the element as an external
reference

select the construct, right-click, and
click Set to Overlay.

NOTE If the Set to Overlay
command is unavailable, the
element is already set to over-
lay.

overlay the element as an external
reference

5 Repeat steps 5-6 for each construct the element should be attached
to.
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6 Click OK.

Elements are attached at 0, 0, 0.

Displaying External References of a Construct
Use this procedure to display a list of xrefs attached to a construct and to
access the functions available for each xref.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Constructs tab.

3 In the Drawing Explorer, locate the construct for which to display
external references, and select it.

4 Display the external references using either of the following
methods:

■ Right-click, and click External References.

■ On the toolbar at the bottom of the Constructs tab, click 
.

The External References dialog displays a list of xrefs in the
construct.

5 Expand or collapse the list by clicking individual items, and
right-click to change the status of the xref, if necessary.
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From the context menu you can unload, reload, or detach the
attached xref. For more information, see Reference Other Drawing
Files in AutoCAD Help.

6 View the details of the external reference:

■ The Reference Name displays the name of the drawing.

■ Status displays whether the xref is loaded or unloaded in the
host drawing, and it displays the host drawing as Open if it is
open in the drawing window. If the host drawing is not open
in the drawing window, status is left blank.

■ Size displays the file size of the selected drawing.

■ Type displays whether the drawing is an attachment, an
overlay, or the host drawing.

■ Date displays the last date the selected drawing was modified.

■ Saved Path displays the saved path, if any, that is used to locate
the xref. This path can be a full (absolute) path or a relative
(partially specified) path.
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■ Found At displays the path where the xref was found. If no
path was saved for the xref, or if the xref is no longer located
at the specified path, the program searches for the xref and
displays the location here.

7 Click OK to close the dialog.

NOTE You can also display external references by opening the construct in the
AutoCAD Architecture drawing area, and using the AutoCAD Xref Manager. For
more information, see “Reference Other Drawing Files (Xrefs)” in AutoCAD Help.

Changing the Properties of a Construct
Use this procedure to change the properties of a construct.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the Constructs category or the
subcategory that contains the construct you want to change,
right-click, and click Properties.

3 Change the construct properties:

Then…If you want to…

enter a name. If the project number
is used as a prefix for project file

change the name of the drawing
file

names, you do not need to enter
the prefix here. The complete name
with prefix is displayed under File
Name. For more information on
prefixes, see Specifying Basic Project
Properties on page 334.

click the setting for Description,
enter a description of the construct,
and click OK.

enter a description for the construct

select one from the Category list.
By default, the category you chose
in step 3 is suggested.

change the category of the con-
struct

select the correct combination of
both in the assignments table. Se-

assign the construct to a different
level and a division

lect the desired level row and divi-

Changing the Properties of a Construct | 419



Then…If you want to…

sion column, and check the appro-
priate box.

NOTE Unless you are defining
a spanning construct, you
should check only one level and
division. Multiple levels and di-
visions create spanning con-
structs.

4 Click OK.

The Project Navigator - Repath Project dialog displays if you
changed the name or category of the construct.

5 Update your files to display the changes to your project:

Then…If you want to…

click Repath project now.update all project files at this time

click Repath project later. If you
close the project before repathing,

update all project files at another
time

the drawing files remain in a queue
for update and display in the Project
Repath Queue dialog the next time
you open it.

420 | Chapter 7   Drawing Management



WARNING When you repath a project that was saved in a version
of AutoCAD Architecture prior to 2010, the drawings are saved in
the new file format. You will no longer be able to open these drawings
in a version of AutoCAD Architecture prior to 2010. Synchronizing a
project with the project standards will also save the project drawings
in the new file format. For more information, see Repath the Project
on page 525.

For more information on updating files, see Repath the Project
on page 525.

Electronically Transmitting a Construct
Use this procedure to electronically transmit a construct drawing.

Electronically transmitting a drawing means that you package the drawing
for delivery in electronic form. Drawing files in the transmittal package include
all related dependent files such as external references and font files.

For more information about electronic transmittal, see “Package a Set of Files
for Internet Transmission” in AutoCAD Help.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the Constructs category or the
subcategory that contains the construct to transmit, right-click,
and click eTransmit.
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The Create Transmittal dialog is displayed.

3 In either the Files tree tab or the File Table tab, select the
components to be included in the electronic package.

The Files Tree tab displays the included files sorted by type. The
Files Table tab displays all files in a list view. You can sort the list
by name, path, type, version, size, and date.

4 To include project information, double-click the setup under
Select a transmittal setup, and in the Modify Transmittal Setup
dialog, select Include project information under Include options.

For detailed information about packaging project information for
an electronic transmittal, see Electronically Transmitting a Project
on page 352

5 Click OK to start the electronic transmittal.

Deleting a Construct
Use this procedure to delete a construct.

For information on the consequences of deleting constructs, see Changing
Constructs: Interactions with the Project on page 425.
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The construct must be closed in order to delete it.

NOTE Do not delete a construct from Windows Explorer. This might result in
inconsistent project data.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the construct to delete, right-click,
and click Delete.

3 Click Yes in the subsequent message box.

Converting a Construct to an Element
Use this procedure to convert a construct to an element.

You may create a construct, and then realize that this is actually a repeating
element. For example, you might create a column grid and then decide to use
it on another floor. You can easily convert the construct to an element and
reference it into multiple constructs.
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NOTE When you convert a construct to an element, the level and division
information is lost. Should you later convert the element back to a construct, you
must reassign to a level and division.

NOTE Do not drag a construct into the Elements folder within Windows Explorer.
This will result in inconsistent project data.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the construct to convert to an
element, and drag it into the Elements category or one of its
subcategories.

NOTE If you want to convert the element back to a construct, drag
the element to the Constructs category.

3 Specify the element properties, as described in Creating an Element
on page 429.

The Project Navigator - Repath Project dialog displays.

4 Update your project files:

Then…If you want to…

click Repath project now.update all project files now

click Repath project later. If you
close the project before repathing,

update all project files later

the drawing files remain in a queue
for update and display in the Project
Repath Queue dialog the next time
you open it.
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WARNING When you repath a project that was saved in a version
of AutoCAD Architecture prior to 2010, the drawings are saved in
the new file format. You will no longer be able to open these drawings
in a version of AutoCAD Architecture prior to 2010. Synchronizing a
project with the project standards will also save the project drawings
in the new file format. For more information, see Repath the Project
on page 525.

For more information on updating files, see Repath the Project
on page 525.

Changing Constructs: Interactions with the Project
Changes made to one part of a project frequently influence other parts of the
project. The following information describes the changes you can make to a
construct and the effects of the changes on other parts of the building project:

■ Adding a new construct: When you add new constructs to a project, you
must fill them with drawing objects or referenced elements. Also, you must
create views in which to display them. For more information, see Creating
a New View Drawing on page 453.

■ Changing the construct name and category (location): Constructs are
referenced into views. Therefore, any name and location changes to a
construct need to be updated throughout the project. To update any xref
paths to the construct, repath the project, as described in Repath the Project
on page 525.

WARNING When you repath a project that was saved in a version of AutoCAD
Architecture prior to 2010, the drawings are saved in the new file format. You
will no longer be able to open these drawings in a version of AutoCAD
Architecture prior to 2010. Synchronizing a project with the project standards
will also save the project drawings in the new file format. For more information,
see Repath the Project on page 525.

■ Changing the level and division of a construct: If you change the level and
division you may need to regenerate views. For more information, see
Regenerating the View Drawings in a Project on page 465.

■ Deleting a construct: If you delete a construct you may need to regenerate
views. For detailed information on deleting constructs, see Deleting a
Construct on page 422. For detailed information on views, see Views on
page 446.
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Elements in the Building Project
An element is a generic building block for multiple use. For example, you can
create an element for a repeating design object like a desk/chair combination
to place in a number of cubicles. You can also create an element for a typical
bathroom layout and reference it multiple times into one or more constructs.
Because you can annotate individual instances of an external reference, you
can use the same element and annotate it differently in different locations.

Elements

3D view of cubicle element

You can place the same element in different levels and divisions. If you create
a bathroom layout as an element, you can use it on the second floor of the
west wing as well as on the first floor of the east wing. To place the element
on a specific floor and wing, you reference it into a construct. For example,
you could create an element named Generic Bathroom Layout and reference
it into constructs named First Floor—Left Apartment, First Floor—Middle
Apartment, First Floor—Right Apartment, and so on.

For more information, see Elements in the Building Project on page 426.

Element repeated in construct
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For information on scheduling repeating elements, see Attaching Property
Sets to Objects from External References on page 537.

Element Files

An element is a drawing (DWG) file. As opposed to non-project drawing files,
an additional XML file with the same name is created. The accompanying
XML file contains information to connect the drawing file to the project.

NOTE The XML file is created and updated automatically. You do not need to
edit it, but be careful not to accidentally delete it in Windows Explorer.

Converting Drawings to Elements

You can convert a drawing file into an element within a project. You specify
the subcategory into which to move or copy the source drawing.

When you convert a legacy drawing file into an element:

■ The drawing file is moved, copied, or linked to the project category you
specify.

■ You can assign a different name and add a description to the file.

Element Templates

When you create a project, you specify a default template for new elements.
For more information about project templates, see Project Support Files on
page 316.

Constructs and Elements

An element is a generic building block for multiple use. If you create a
bathroom layout as an element, you can use it on the second floor of the west
wing just as well as on the first floor of the east wing. To place the element
on a specific floor and wing, reference it into a construct. For example, you
could create an element named Generic Bathroom Layout and reference it
into constructs named First Floor, Second Floor, and Third Floor.
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Referencing an element into a construct

Referencing Elements to Multiple Constructs

In multi-story buildings, levels may have identical elements. You can create
an element once, and then reference it into multiple constructs in one single,
convenient step. For detailed information, see Referencing an Element into
Multiple Constructs on page 415.

When to Start with Elements
You would start creating elements when you can identify generic building
blocks in your project.

Elements can be small units like a desk/chair combination or large units like
an entire apartment layout or a generic furniture layout. You can also define
an element that uses other elements as external references in its content. A
generic building core element, for example, could contain references for
bathroom elements or staircase elements. You can nest elements that are
external references multiple levels deep.

Keep in mind these points when creating elements:

■ An element must be referenced into a construct before it can be used for
views.

■ An element can be referenced directly into a sheet. This might be done for
title blocks or the documentation of a detail on the sheet.

■ An element can be uniquely scheduled.
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■ An element is re-usable.

Processing Elements in the Building Project
After you have created and modified some elements in your project, decide
how to use them in the project. The following list describes typical uses for
elements and where to find additional information:

Further InformationUse

This is the most frequent use case for an
element. A generic element, like a bath-

reference an element into a construct

room layout, is referenced into a specific
construct, like a floor plan. For more inform-
ation, see Referencing Elements into Con-
structs on page 413 and Referencing an
Element into Multiple Constructs on page
415.

For example, if you want to have different
elements for single cubicles—a 4-cubicle

reference an element into another element

group, you could create an element for one
cubicle, and reference that 4 times into the
4-cubicle group element. For more inform-
ation, see Referencing an Element into An-
other Element on page 440.

You can directly reference an element into
a sheet. This can be useful for title block
elements.

reference an element into a sheet

Creating an Element
Use this procedure to create an element.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the Elements category or subcategory
where you want to add the new element.

Processing Elements in the Building Project | 429



3 Open the Add Element dialog using one of the following methods:

■ Right-click the category in which to place the new element,
and click New ➤ Element.

■ In the toolbar at the bottom of the Constructs tab, click  .
(You then specify the category in the dialog.)

4 Define the element properties:

Then…If you want to…

enter a name. If the project number
is used as a prefix for project file

name the new element

names, you do not need to enter
the prefix here. The complete name
with prefix is displayed under File
Name. For more information on
prefixes, see Specifying Basic Project
Properties on page 334.

click the setting for Description,
enter a description of the element,
and click OK.

add a description for the element

select a category from the Category
list. By default, the category you
chose in step 3 is suggested.

change the category of the element

click  , and browse for a new
template. By default, the default

select a different template file

template for elements set in the
project is used.
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5 If you want to work in this element immediately, select Open in
drawing editor.

For information about other methods of opening elements if you
do not select this option, see Opening and Closing an Element
on page 435.

6 Click OK.

7 Edit the element as necessary:

■ Add objects to the element.

■ Reference other elements into the element.
For more information, see Referencing an Element into
Another Element on page 440.

8 Close the element using either of the following methods:

■ Right-click the element in the Drawing Explorer, and click
Close.

■ Click  ➤ Close ➤ Current Drawing.

9 Click Yes to save the changes in the drawing if necessary.

Converting a Drawing to an Element
You may have drawing files in AutoCAD Architecture that you want to convert
into elements. When you convert a drawing file into an element:

■ The drawing file is either moved, copied, or connected via a link to the
element category you specify.

■ If necessary, a different name is given to the file and a description is added
to it.

There are 2 ways to convert a drawing file into an element: you can open the
drawing file in AutoCAD Architecture and save it as an element, or you can
drag a drawing file from Windows Explorer to the Project Navigator.
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Converting Drawing Files by Opening and Saving as an Element
Use this procedure to convert a drawing file to an element by opening it in
AutoCAD Architecture and then saving it as an element.

1 Click  ➤ Open ➤ Drawing.

2 On the Quick Access toolbar, click Project Navigator  .

3 On the Constructs tab, locate the Elements category, right-click,
and click Save Current Dwg as Element.

4 Define the element properties:

Then…If you want to…

enter a new name. If the project
number is used as a prefix for pro-

change the name of the drawing
file

ject file names, you do not need to
enter the prefix here. The complete
name with prefix is displayed under
File Name. For more information
on prefixes, see Specifying Basic
Project Properties on page 334.

click the setting for Description,
enter a description of the element,
and click OK.

enter a description for the element

select one from the Category list.
By default, the category you chose
in step 4 is suggested.

change the category of the element

5 Click OK.

6 Close the element using either of the following methods:

■ Right-click the element in the Drawing Explorer, and click
Close.

■ Click  ➤ Close ➤ Current Drawing.

7 Click Yes to save the changes in the drawing, if necessary.
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Converting Drawing Files from Windows Explorer
Use this procedure to convert drawing files to elements by dragging and
dropping them from Windows Explorer.

Windows Explorer offers 3 different modes of conversion:

■ Converting a file to an element and moving it into a project folder

■ Copying a file, and converting the copy to the element in a project folder

■ Converting a file to an element and creating a link to its original location

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Constructs tab.

3 Start Windows Explorer, and position it next to the Project
Navigator.

4 In Windows Explorer, open the folder that contains the drawing.

5 Drag and drop the drawing in the Elements category or one of its
subcategories:

Then…If you want to…

drag the drawing into the desired
location in the Drawing Explorer.

move the drawing into the selected
category, and convert it to an ele-
ment

CTRL-drag the drawing into the
desired location in the Drawing Ex-
plorer.

move a copy of the drawing into
the selected category, and convert
it to an element

ALT-drag the drawing into the de-
sired location in the Drawing Ex-
plorer.

create a link to the drawing in its
original location, and convert it to
an element

NOTE You can also drag an entire folder into the project. The folder
is converted into a category, and all drawings within are converted
to elements. For instructions on converting folders to categories, see
Creating a Category from Windows Explorer on page 394.
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6 Define the element properties:

Then…If you want to…

enter a new name. If the project
number is used as a prefix for pro-

change the name of the drawing
file

ject file names, you do not need to
enter the prefix here. The complete
name with prefix is displayed under
File Name. For more information
on prefixes, see Specifying Basic
Project Properties on page 334.

click the setting for Description,
enter a description of the element,
and click OK.

enter a description for the element

select one from the Category list.
By default, the category you chose
in step 5 is suggested.

change the category of the element

7 Click OK.
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Opening and Closing an Element
Use this procedure to open and close an element. For information about
additional commands available on the context menu, see The Drawing Explorer
Context Menu on page 369.

When you open an element, the status line in the AutoCAD Architecture
drawing area displays the name of the associated project.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the element you want to open.

3 Open the element using either of the following methods:

■ Select the element, right-click, and click Open.

■ Double-click the element.
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The element is opened in the drawing area of AutoCAD
Architecture. You can now edit it.

4 Close the element using either of the following methods:

■ Right-click the element in the Drawing Explorer, and click
Close.

■ Click  ➤ Close ➤ Current Drawing.

5 Click Yes to save the changes in the drawing, if necessary.

6 To update the preview of the element in the Drawing Explorer,

click  .

Dragging Objects into an Element
Use this procedure to drag and drop objects into an element.

When you create a new element, you may choose to add content to it in
several ways. You can draw objects within the element, you can reference one
element into another, or you can drag and drop objects from other drawing
files into an element.

1 Open the drawing that contains the objects you want to drag and
drop into an element.

NOTE The drawing containing the objects is not required to be a
part of a project.

2 On the Quick Access toolbar, click Project Navigator  .

3 On the Constructs tab, locate the element to which you want to
add objects from another drawing file.

4 In the open drawing file, select the objects you want to drag and
drop into the element.

5 Move or copy the objects into the element:

Then…If you want to…

drag the objects from the drawing
onto the desired element in the
Drawing Explorer.

move the objects from the open
drawing to the element
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Then…If you want to…

CTRL-drag the objects from the
drawing onto the desired element
in the Drawing Explorer.

copy the objects from the open
drawing to the element

NOTE You can also drag the objects from the drawing onto a
category in the Drawing Explorer to create an element.

Changing the Properties of an Element
Use this procedure to change the properties of an element.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the element you want to change,
right-click, and click Properties.

3 Change the element properties:

Then…If you want to…

enter a new name. If the project
number is used as a prefix for pro-

change the name of the element

ject file names, you do not need to
enter the prefix here. The complete
name with prefix is displayed under
File Name. For more information
on prefixes, see Specifying Basic
Project Properties on page 334.

click the setting for Description,
change the description of the ele-
ment, and click OK.

change the description of the ele-
ment

select one from the Category list.
Changing the category of an ele-

change the category of the element

ment means changing its location
in the project.

4 Click OK.

The Project Navigator - Repath Project dialog displays.
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5 Update your project files:

Then…If you want to…

click Repath project now.update all project files now

click Repath project later. If you
close the project before repathing,

update all project files later

the drawing files remain in a queue
for update and display in the Project
Repath Queue dialog the next time
you open it.

WARNING When you repath a project that was saved in a version
of AutoCAD Architecture prior to 2010, the drawings are saved in
the new file format. You will no longer be able to open these drawings
in a version of AutoCAD Architecture prior to 2010. Synchronizing a
project with the project standards will also save the project drawings
in the new file format. For more information, see Repath the Project
on page 525.

Electronically Transmitting an Element
Use this procedure to electronically transmit an element drawing.

Electronically transmitting a drawing means that you package the drawing
for delivery in electronic form. Drawing files in the transmittal package include
all related dependent files such as external references and font files.

For more information about electronic transmittal, see “Package a Set of Files
for Internet Transmission” in AutoCAD Help.
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1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the element to transmit.

3 Select the element, right-click, and click eTransmit.

The Create Transmittal dialog is displayed.

4 On either the Files tree tab or the File Table tab, select the
components to be included in the electronic package.

The Files Tree tab displays the included files sorted by type. The
Files Table tab displays all files in a list view. You can sort the list
by name, path, type, version, size, and date.

For detailed information about packaging project information for
an electronic transmittal, see Electronically Transmitting a Project
on page 352.

5 Click OK to start the electronic transmittal.

Deleting an Element
Use this procedure to delete an element.

The element must be closed in order to delete it.
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NOTE Do not delete an element from Windows Explorer. This might result in
inconsistent project data.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Constructs tab, locate the element to delete.

3 Select the element, right-click, and click Delete.

4 Click Yes in the subsequent message box.

Referencing an Element into Another Element
Use this procedure to reference an element into another element.

NOTE When you are working in a project environment, make sure that all files
you are using belong to this project. Drawing files that do not belong to a project
do not give access to the full functionality of Drawing Management. To reference
a non-project drawing file into the project, convert the file into an element, and
then reference it.

Cubicle element referenced 4 times into cubicle group

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Constructs tab.
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3 In the Drawing Explorer, locate and open the element into which
you want to reference another element.

4 On the Project Navigator palette, locate the element to reference
into the open element.

5 Reference the element into the open element using one of the
following methods:

Then…If you want to…

select the element in the Drawing
Explorer, right-click, and click Xref

attach the element as an external
reference to the open element

Attach, or select the element in the
Drawing Explorer, and drag it into
the open element in the AutoCAD
Architecture drawing area.
When you attach an element as an
external reference, you create a link
from the referenced element to the
current element; any changes to
the referenced element are dis-
played in the current element when
it is opened or refreshed.

select the element in the Drawing
Explorer, right-click, and click Xref
Overlay.
When you overlay an external refer-
ence, you also create a link from the

overlay the element as an external
reference on the open element

referenced element to the current
element. Unlike an attached refer-
ence, an overlaid reference is not
included when the element is itself
attached or overlaid as a reference
to another element or construct.

select the element in the Drawing
Explorer, right-click, and click Insert
as Block.
When you insert an element as a
block reference into another ele-

insert the element as a block into
the open element

ment, the link between the refer-
enced element and the current ele-
ment is cut off. The inserted ele-
ment is converted to a block and
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Then…If you want to…

does not update when the refer-
ence element is changed. You can,
however, edit the block in the cur-
rent element.

6 If necessary, edit the external reference in the open element.

For more information on external references, see “Attach External
References” in AutoCAD Help.

For more information on blocks, see “Create and Insert Symbols
(Blocks)” in AutoCAD Help.

Displaying External References Attached to an Element
Use this procedure to display a list of xrefs attached to an element and to
access the functions available for each xref.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Constructs tab.

3 In the Drawing Explorer, locate the element for which to display
xrefs.

4 Select the element.

5 Display the xrefs using either of the following methods:

■ Right-click, and click External References.

■ On the toolbar at the bottom of the Constructs tab, click 
.

The External References dialog displays a list of xrefs in the
element.

6 Expand or collapse the list by clicking individual items, and
right-click to change the status of the xref, if necessary.

From the context menu, you can unload, reload, or detach the
attached xref. For more information, see Reference Other Drawing
Files in AutoCAD Help.

7 View the details of the xref:
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■ The Reference Name displays the name of the drawing.

■ Status displays whether the xref is loaded or unloaded in the
host drawing, and it displays the host drawing as Open if it is
open in the drawing window. If the host drawing is not open
in the drawing window, status is left blank.

■ Size displays the file size of the selected drawing.

■ Type displays whether the drawing is an attachment, an
overlay, or the host drawing.

■ Date displays the last date the selected drawing was modified.

■ Saved Path displays the saved path, if any, that is used to locate
the xref. This path can be a full (absolute) path or a relative
(partially specified) path.

■ Found At displays the path where the xref was found. If no
path was saved for the xref, or if the xref is no longer located
at the specified path, the program searches for the xref and
displays the location here.

8 Click OK to close the dialog.

NOTE You can also display external references by opening the element in the
AutoCAD Architecture drawing area and using the AutoCAD Xref Manager. For
more information, see Reference Other Drawing Files in AutoCAD Help.

Converting an Element to a Construct
Use this procedure to convert an element to a construct.

If you create an element and realize later that you do not need this drawing
as a repeating element, you can convert it into a construct.

NOTE Do not drag an element to the Constructs folder within Windows Explorer.
This will result in inconsistent project data.

1 On the Quick Access toolbar, click Project Navigator  .

Converting an Element to a Construct | 443



2 Click the Constructs tab.

3 In the Drawing Explorer, locate the element to convert into a
construct.

4 Select the element, and drag it into the Constructs category or
one of its subcategories.

5 Specify the construct properties, as described in Creating a New
Construct on page 404.

6 Click OK.

The Project Navigator - Repath Project dialog displays.

7 Update your project files:

Then…If you want to…

click Repath project now.update all project files now

click Repath project later. If you
close the project before repathing,

update all project files later

the drawing files remain in a queue
for update and display in the Project
Repath Queue dialog the next time
you open it.

NOTE If you want to convert the construct back to an element, drag
it back to the Elements category.
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WARNING When you repath a project that was saved in a version
of AutoCAD Architecture prior to 2010, the drawings are saved in
the new file format. You will no longer be able to open these drawings
in a version of AutoCAD Architecture prior to 2010. Synchronizing a
project with the project standards will also save the project drawings
in the new file format. For more information, see Repath the Project
on page 525.

Changing Elements: Interactions with the Project
Changes made to one part of a project frequently influence other parts of the
project. The following information describes the changes you can make to an
element, and the effects of the changes on other parts of the building project.

■ Adding new elements: When you add new elements to a project, you may
reference them into other elements, constructs, or sheets.

■ Changing the element name and category (location): Elements are used
as external references in other files. When you change the name and the
location of an element, external reference paths to it no longer correct. To
update the project, repath it, as described in Repath the Project on page
525.

WARNING When you repath a project that was saved in a version of AutoCAD
Architecture prior to 2010, the drawings are saved in the new file format. You
will no longer be able to open these drawings in a version of AutoCAD
Architecture prior to 2010. Synchronizing a project with the project standards
will also save the project drawings in the new file format. For more information,
see Repath the Project on page 525.

■ Deleting an element: When you delete an element that has been referenced
into another element or into a construct or a sheet, that drawing now has
missing references. If a construct with deleted elements has been referenced
into a view, and the view is updated, it also has missing references.
Therefore, before deleting an element, check to see if it is still used
elsewhere.
For detailed information on deleting elements, see Deleting an Element
on page 439.
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Views
After the structure of the building project is defined, and constructs are assigned
to levels and divisions, you can start to create view drawings. A view drawing
references a number of constructs to present a specific view of the building
project. To create a view drawing, you first decide which portion of the building
you wish to look at and which type of view to generate. You could, for
example, create a first-floor reflected ceiling plan or a second-floor framing
plan, or create a composite view of all floors in the building. View drawings
automatically reference the appropriate constructs according to their
level/division assignments within the building. For example, to create a floor
plan of the west wing of the second floor, you would create a view that
references all constructs assigned to the second floor and the west wing. This
would also include a curtain wall spanning the first through fifth floors.

3D view of entire building view

In a view drawing you also add data like annotation, dimensions, and schedule
tables.

Types of View Drawings

There are 3 different types of view drawings in the Drawing Management
feature:

■ General view drawing: A general view drawing contains referenced
constructs from the project, representing a specific view on the building
model. General view drawings are based on the general view template
defined in the project settings.
You can reference a view drawing in a sheet. When you reference the view
drawing into a sheet, a sheet view is created that contains the view drawing
reference.
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Perspective view of building

■ Detail view drawing: A detail view drawing contains one or more model
space views that show a defined portion of the detail drawing in the level
of detail you specify. A model space view containing a detail can be
associated with a callout. Detail view drawings are based on the detail view
template defined in the project settings.

Detail view in callout

■ Section/Elevation view drawing: A section/elevation view drawing contains
one or more model space views, each showing a defined portion of the
section/elevation view drawing. A model space view containing a section
or elevation can be associated with a callout. Section/Elevation view
drawings are based on the section/elevation view template defined in the
project settings.
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Elevation view drawing with 4 model space views

When you reference a view drawing into a sheet, a sheet view is created
that contains the view drawing reference.

Model Space Views

A model space view is a portion of a view drawing that may be displayed in
its own paper space viewport on a sheet. Model space views are an evolution
of the Named Views concept of AutoCAD. Unlike Named Views, a model space
view has a defined boundary. When a model space view is placed onto a sheet,
a sheet view is created. A view drawing can contain any number of model
space views.

Sheet Views

A sheet view is a paper space viewport on the sheet that is created when you
drag a view drawing or model space view from the Project Navigator palette
onto a sheet.
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Model space view of plan area
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Sheet view placed on sheet

Sheet views can have viewport-specific layer overrides. When a view drawing
or a model space view is referenced into a sheet view, these overrides will be
retained, unless the project has been set up to synchronize views with sheets.
In that case the layer settings of the view drawing will be reset in the sheet
view when the sheet is opened, plotted, or published. For more information,
see Synchronizing View Drawing Layers with Sheet View Layers on page 475.

For more information on viewport-specific layer overrides, see “Override Layer
Properties in Viewports” in the AutoCAD help.

Views and Constructs

You create a view drawing by selecting constructs from the Project Navigator
palette and referencing them into the view drawing. When you are creating
multi-level views, each construct is referenced at its relative level height, with
the lowest level inserted at Z = 0. For more information, see Creating a New
View Drawing on page 453.
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3D view of copied building core constructs at each building level

Views and Annotation

You can add annotation, dimensions, and schedule tables in a view drawing
or on a sheet, depending on your specific workflow and needs. For more
information on annotating a project, see Workflow for Annotating a Project
on page 529.

View drawing with annotation tags

Updating View Drawings

A view drawing can include either individual constructs or entire construct
categories. For example, if you select the Architectural—First Floor construct
category, all constructs within this category at the appropriate level or division
are included in the view drawing. If you add constructs to that category later,
the view drawing is automatically regenerated to include the new constructs
as applicable. Using categories helps you keep your view drawings current
throughout the project.
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View Templates

When you create a project, you set a default template for new view drawings.
There are separate templates for general view drawings, detail view drawings,
and section/elevation view drawings.

The default view template should be saved so that it will create a drawing that
opens to the Model tab. When you create a new view drawing, all constructs
that you assign to it will be referenced into the view drawing. If the template
does not open with model space active, the building will be referenced into
paper space.

For more information about project templates, see Project Support Files on
page 316.

When to Start with Views
Typically, you create view drawings and model space views after you have
defined levels, divisions, and the basic constructs. For example, you could
create the following series of views for individual floors: First Floor Plan, Second
Floor Plan, Basement Plan, Roof Plan. You could also create a series of views
based on plan type, such as: Plan View, Model View, Reflected View. Another
approach could be by function; for example: Walls, Framing, Furniture. Only
constructs can be referenced into a view drawing. To see elements in a view,
they must be referenced by a construct.

First floor plan (top) and framing plan (bottom)

Working in a view, you add tags, dimension the building objects, and create
a schedule table. Tags and schedule tables may contain a number of project
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properties, such as level and division assignments. For detailed information
on annotating a project, see Workflow for Annotating a Project on page 529.

After you have assembled a view drawing, you can create model space views
in it. These model space views are later placed on sheets, creating sheet views.

Workflow to Create View Drawings
A view is a composite of constructs from your project.

Add a view drawing  on page 453 to the project.-----Create a 3D view of your building

Add tags and dimensions or create schedule
tables on page 529.

-----Annotate the drawing

Drag the view on page 465 onto the sheet or
create on page 468 and place a model space view
on page 471 on a sheet.

-----Add the drawing to a sheet

Creating a New View Drawing
A wizard leads you through the steps for creating a view drawing as described
in the topics that follow.

NOTE View drawings are containers for constructs. Typically, you create a view
drawing after you add the necessary constructs to the project. However, you can
also create an empty view drawing first, and reference constructs into it later.
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Creating a View Drawing: Defining General Properties
Use this procedure to specify the name, description, category, and template
file for a new view drawing.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab, and locate the Views category or subcategory
where you want to add the new view drawing.

3 Add a new view drawing to the project using either of the
following methods:

■ Right-click the category in which to place the new view
drawing, click New View Dwg, and click the view type
(General, Section/Elevation, or Detail).

■ On the toolbar at the bottom of the Views tab, click  , and
in the Add View dialog, click the view type (General,
Section/Elevation, or Detail).

4 In the Add <View Type> View dialog, define the General properties
for the view:

Then…If you want to…

enter a name. If the project number
is used as a prefix for project file

name the new view drawing

454 | Chapter 7   Drawing Management



Then…If you want to…

names, you do not need to enter
the prefix here. The complete name
with prefix is displayed under File
Name. For more information on
prefixes, see Specifying Basic Project
Properties on page 334.

click the value for Description, enter
a description of the view, and click
OK.

enter a description for the view
drawing

click the value for Category, and
select a category from the list. The

change the category of the view
drawing

category you chose in step 3 is re-
commended.

click  , and browse for a new
template. The default template for

select a different template file

view drawings set in the project is
recommended.

5 Click Next, and continue with assigning levels and divisions. For
more information, see Creating a View Drawing: Assigning Levels
and Divisions on page 455.

Creating a View Drawing: Assigning Levels and Divisions
Use this procedure to select portions of the building to include in the view by
assigning levels and divisions. You can choose multiple levels and divisions
for a view drawing; for example, to create a view of the entire building. This
provides the context for the view drawing.

When you select one or more levels as a view context, all constructs that
belong to the selected levels are referenced into the view drawing. The lowest
level in the view is inserted at an elevation of 0' - 0''. A spanning element
would be referenced at the elevation of the lowest level to which it is assigned.

The levels and divisions you choose for the context serve as a preselection for
selecting the constructs. For example, if you choose the first level and the
south wing as the view context, all constructs belonging to that level and
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wing are selected as content in the next step by default. You can exclude
constructs if you wish, but preselection saves time and effort.

1 Define the general properties of the view drawing, as described
in Creating a View Drawing: Defining General Properties on page
454.

2 In the Add <View Type> View dialog, select the levels and divisions
to include in the view drawing.

3 When you finish defining levels and divisions, click Next, and
proceed to defining the view content. For more information, see
Creating a View Drawing: Selecting the Constructs on page 456.

Creating a View Drawing: Selecting the Constructs
Use this procedure to select constructs to be referenced in the view
drawing—the content. By default, each construct is attached as an external
reference. For detailed information on attaching and overlaying external
references, see “Reference Other Drawing Files” in AutoCAD Help.

Selecting constructs is the key to creating a view drawing. The view drawing
consists mainly of referenced constructs.

There are several ways to make the selection of constructs easier:

■ Preselect levels and divisions: Depending on the level and division you
selected previously as the context, all constructs at that level and division
are already checked.
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■ Work with categories: When you select a category, all constructs within
that category are selected. When you add constructs to the category later,
they are included in the view drawing.

1 Define the general properties and the context of the view drawing,
as described in Creating a View Drawing: Defining General
Properties on page 454 and Creating a View Drawing: Assigning
Levels and Divisions on page 455.

2 Create the selection set of constructs for the view drawing:

Then…If you want to…

select the category. All constructs
in the category are selected auto-

select an entire category to include
in the view drawing

matically. When you add constructs
to the category later, they are in-
cluded in the view drawing.

expand the categories as needed,
and select the construct.

select a construct to include in the
view drawing

clear the category’s box. All con-
structs in the category are cleared
automatically.

exclude a category from the view
drawing

clear the construct.exclude a construct from the view
drawing
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3 Determine the referencing mode of the constructs in the view
drawing:

Then…If you want to…

select the construct, right-click, and
click Set All to Attach.

NOTE Attaching an external
reference is the default insertion
method for views. When the Set
All to Attach command is un-
available, the construct has
already been attached.

attach the construct to the view
drawing

select the construct, right-click, and
click Set All to Overlay.

NOTE  When the Set All to
Overlay command is unavail-
able, the construct has already
been overlaid.

overlay the construct on the view
drawing

4 If you want to work in this view drawing immediately, select Open
in drawing editor.

For information about other methods of opening views, see
Opening and Closing a View Drawing on page 461.

5 Click Finish.

Displaying External References of a View Drawing
Use this procedure to display a list of xrefs attached to a view drawing and to
access the functions available for each xref.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 In the Drawing Explorer, locate the view drawing for which to
display external references.

4 Select the view drawing.
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5 Display the xrefs using either of the following methods:

■ Right-click, and click External References.

■ On the toolbar at the bottom of the Views tab, click  .

The External References dialog displays a list of xrefs in the view.
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6 Expand or collapse the list by clicking individual items, and
right-click to change the status of the xref, if necessary.

You can unload, reload, or detach the attached xref. For more
information, see Reference Other Drawing Files in AutoCAD Help.

7 In the External References dialog, view the details of the xref:

■ The Reference Name displays the name of the drawing.

■ Status displays whether the xref is loaded or unloaded in the
host drawing, and it displays the host drawing as Open if it is
open in the drawing window. If the host drawing is not open
in the drawing window, status is left blank.

■ Size displays the file size of the selected drawing.

■ Type displays whether the drawing is an attachment, an
overlay, or the host drawing.

■ Date displays the last date the selected drawing was modified.
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■ Saved Path displays the saved path, if any, that is used to locate
the xref. This path can be a full (absolute) path or a relative
(partially specified) path.

■ Found At displays the path where the xref was found. If no
path was saved for the xref, or if the xref is no longer located
at the specified path, the program searches for the xref and
displays the location here.

8 Click OK to close the dialog.

NOTE You can also display external references by opening the view drawing and
using the AutoCAD Xref Manager. For more information, see “Overview of
Referenced Drawings (Xrefs)” in AutoCAD Help.

Opening and Closing a View Drawing
Use this procedure to open and close a view drawing.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 In the Drawing Explorer, locate the view drawing you want to
open.

4 Open the view drawing using one of the following methods:

■ Select the view drawing, right-click, and click Open. (For
information about additional commands available on the
context menu, see The Drawing Explorer Context Menu on
page 369.)
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■ Double-click the view drawing.

The view drawing opens in the drawing area of AutoCAD
Architecture.

5 Close the view drawing using one of the following methods:

■ Right-click the view drawing in the Drawing Explorer on the
Project Navigator, and click Close.

■ Click  ➤ Close ➤ Current Drawing.

6 Click Yes to save the changes in the drawing, if desired.

Creating a Model Space View Drawing from a Callout
In most cases, when you need a model space view containing a detail or a
section/elevation, you will create it by using a callout tool. This method lets
you specify whether the resulting model space view is placed in the view
drawing you have created it from, in a different drawing, or in a new view
drawing. For more information, see Callouts on page 3687.

NOTE You can still associate a callout symbol with the view later if you do not
use a callout tool to create the model space view. For more information, see
Working with Callouts on page 3687.

On the Views tab of the Project Navigator palette, general, detail, and
section/elevation view drawings are distinguished by different symbols:

SymbolView Drawing Type

General view drawing

Detail view drawing

Section/Elevation view drawing

For more information, see Creating a New View Drawing on page 453.
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Changing the Properties of a View Drawing
Use this procedure to change the general, context, or content properties of a
view drawing.

If you change the name or the location (general properties) of constructs
included in the view drawing, repath the project.

If you change the level or division assignment (context properties) of constructs
included in the view drawing, reload the external references in the drawing.
For information, see Regenerating the View Drawings in a Project on page 465.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 In the Drawing Explorer, select the view drawing, right-click, and
click Properties.

4 In the left pane of the Modify <View Type> View dialog, click the
General category, and change the general view properties as
needed:

Then…If you want to…

enter a new name. If the project
number is used as a prefix for pro-

change the name of the view
drawing

ject file names, you do not need to
enter the prefix here. The complete
name with prefix is displayed under
File Name. For more information
on prefixes, see Specifying Basic
Project Properties on page 334.
Changing the name prompts you
to repath the project. For more in-
formation, see Repath the Project
on page 525.

click the setting for Description,
change the description of the view
drawing, and click OK.

change the description of the view
drawing

select one from the Category list.
Changing the category prompts
you to repath the project. For more

change the category of the view
drawing

information, see Repath the Project
on page 525
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WARNING When you repath a project that was saved in a version
of AutoCAD Architecture prior to 2010, the drawings are saved in
the new file format. You will no longer be able to open these drawings
in a version of AutoCAD Architecture prior to 2010. Synchronizing a
project with the project standards will also save the project drawings
in the new file format. For more information, see Repath the Project
on page 525.

5 In the left pane of the Modify <View Type> View dialog, click the
Context category, and change the levels and divisions to include
in the view drawing as needed.

6 In the left pane of the Modify <View Type> View dialog, click the
Content category, and change the selected constructs for the view
drawing as needed:

Then…If you want to…

select the construct or category.add a construct or category to the
view drawing

select the construct or category.remove a construct or category
from the view drawing

right-click the construct, and select
one of the following commands:

change the referencing mode of a
construct

■ To attach a previously overlaid
construct to a view, click Set All
to Attach.

■ To overlay a previously at-
tached construct to a view, click
Set All to Overlay.

NOTE If one of these com-
mands is unavailable, its mode
is already selected.

7 Click OK.
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Regenerating the View Drawings in a Project
Use this procedure to regenerate view drawings in the project when the
content, levels, or divisions have changed. When you regenerate a view
drawing, the external references used to generate it are attached, detached, or
reloaded as needed.

1 On the Project Navigator palette, click the Views tab.

2 On the toolbar at the bottom of the tab, click the  button.

All view drawings in the project are updated with the changed
constructs.

Placing a View Drawing onto a Sheet
When a view drawing is dragged onto a sheet to create a sheet view, the model
space settings (the viewport scale, layer settings, and display configuration)
of the view drawing are used in the sheet view.

NOTE For information about placing a model space view, instead of a whole view
drawing, onto a sheet, see Placing a Model Space View onto a Sheet on page 471.

When generating a model space view or a new view drawing from a callout
tool, you define the drawing scale to be used. This scale is also used in any
sheet views generated from the view.

Layer changes (including xref dependent layer changes) from the view drawing
can be displayed and updated in the sheet view, if the project has been set up
to synchronize sheets with views, as described in Synchronizing View Drawing
Layers with Sheet View Layers on page 475.

If a project has been set up to synchronize view drawing layers with sheet
view layers, viewport layer overrides in sheet views will be overwritten by the
layer configuration of the view drawing when the external references are
loaded or reloaded. If not, layers and xrefed layers in the sheet view will behave
as normal.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Sheets tab, click  (Sheet Set View) on the title bar.

3 In the Sheet Set view, locate the sheet into which you want to
reference the view drawing.
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4 Open the sheet using one of the following methods:

■ Select the sheet, right-click, and click Open.

■ Double-click the sheet.

The drawing containing the sheet opens in the drawing area. The
sheet you selected is the active layout.

5 On the Project Navigator palette, click the Views tab.

6 Select the view drawing you want to place on the sheet, and drag
it from the Drawing Explorer to the drawing area of the sheet.

TIP While inserting the view drawing on a sheet, you can change
the scale of the resulting sheet view by right-clicking and selecting a
different scale before defining the insertion point. After creating the
sheet view, you can change its scale on the Properties palette.

NOTE Sheet views are inserted with their own layer key. By default,
the sheet view layer is G-Anno-Nplt.

Electronically Transmitting a View Drawing
Use this procedure to electronically transmit a view drawing.

Electronically transmitting a drawing means that you package the drawing
for delivery in electronic form. Drawing files in the transmittal package
automatically include all related dependent files, such as external references
and font files.

NOTE If the view contains multiple model space views, you are prompted to drop
each in succession.

For more information about electronic transmittal, see “Package a Set of Files
for Internet Transmission” in AutoCAD Help.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 Select the view drawing you want to transmit, right-click, and
click eTransmit.
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4 In either the Files tree tab or the File Table tab, select the
components to be included in the electronic package.

The Files Tree tab displays the included files sorted by type. The
Files Table tab displays all files in a list view. You can sort the list
by name, path, type, version, size, and date.

5 To include project information, double-click the setup under
Select a transmittal setup, and in the Modify Transmittal Setup
dialog, select Include project information under Include options.

For detailed information about packaging project information for
an electronic transmittal, see Electronically Transmitting a Project
on page 352.

6 Click OK to start the electronic transmittal.

Deleting a View Drawing
Use this procedure to delete a view drawing.
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For information on the consequences of deleting view drawings, see Changing
Views: Interactions with the Project on page 480.

The view drawing must be closed in order to delete it.

NOTE Do not delete a view drawing from Windows Explorer. This might result
in inconsistent project data.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 In the Drawing Explorer, select the view drawing, right-click, and
click Delete.

4 Click Yes in the subsequent message box.

Creating a Model Space View
A model space view is a named view that represents a view definition in model
space. You can create multiple model space views in a view drawing, each
with its own name, description, layer settings, and drawing scale.

When a model space view is placed onto a sheet, its own viewport scale, layer
settings, and the display configuration of the view drawing are used in the
sheet view created. The view direction, however, defaults to plan.

You can associate an AutoCAD layer snapshot with a model space view. If you
then place the model space view on a sheet, the AutoCAD layer snapshot
determines the On/Off and Freeze/Thaw settings of the model space layers.
The layer settings from the layer snapshot will only be used if the project has
not been set up to synchronize view drawing layers with sheet view layers. If
that synchronization has been set up, the layer settings from the view drawing’s
model space are used, and any attached layer snapshots on the model space
view are ignored.
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Defining a model space view

Displaying a model space view

To create a model space view within a view drawing

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Views tab, select the view drawing in which you want to
create a model space view, right-click, and click Open.
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3 Select the view drawing again, right-click, and click New Model
Space View.

4 In the Add Model Space View dialog, enter a name for the new
model space view.

5 Define the settings for the new model space view:

Then…If you want to…

click the setting for Description and add a de-
scription of the model space view.

enter a description for
the model space view

select a scale from the list of those used in the
current view drawing.

change the scale of the
model space view

6 Click  to define the boundaries of the new model space view.

7 Specify the first boundary point of the desired view area.

8 Specify the second boundary point of the desired view area.

9 Click OK.

The new model space view is listed under the view drawing from
which it was created.

10 To associate an AutoCAD layer snapshot with the new model
space view, select the model space view in the Drawing Explorer,
right-click, and click Save Layer State.

11 Open the model space view using either of the following methods:

■ double-click it in the Drawing Explorer.
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■ select the model space view in the Drawing Explorer,
right-click, and click Open.

Placing a Model Space View onto a Sheet
Use this procedure to place a model space view onto a sheet, creating a sheet
view. A sheet can contain any number of sheet views.

When a model space view is placed on a sheet, it retains its own drawing scale
and layer settings but uses the display configuration of the view drawing. The
view direction of the sheet view is determined by the sheet.

Model space view of plan detail
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Sheet view placed on sheet

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Sheets tab, click  (Sheet Set View) on the title bar.

3 In the Sheet Set view, locate the sheet into which you want to
reference the model space view, and open it using one of the
following methods:

■ Select the sheet, right-click, and click Open.

■ Double-click the sheet.

The drawing containing the sheet opens in the drawing area with
the selected sheet as the active layout.

4 On the Project Navigator palette, click the Views tab.

5 Use one of the following methods to place the desired model
space view on the sheet:

■ Select the model space view, right-click, and click Place on
Sheet. Then, specify an insertion point on the sheet.

■ Select the model space view, and drag it from the Project
Navigator to the drawing area of the sheet.

You can disable image previews to improve performance while
dragging a view from the Project Navigator palette. For more
information, see Drawing Explorer Tooltips on page 374.
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You can change the scale of the resulting sheet view by
right-clicking and selecting a different scale before defining the
insertion point. After creating the sheet view, you can change its
scale on the Properties palette.

NOTE Sheet views are inserted with their own layer key. By default,
the sheet view layer is G-Anno-Nplt.

Changing the Properties of a Model Space View
Use this procedure to change the properties of a model space view.

NOTE If you change the properties of a model space view, instances of that view
that have been placed as sheet views on a sheet are not updated. Only new
instances of the model space view will have the new settings. For example, if a
model space view named West Stairs is defined with a scale of 1/8” = 1’-0”, it is
placed with that scale on a sheet. If the scale is later changed to 1/4” = 1’-0”, the
new scale is not updated on existing sheet views, but will be used for new sheet
views.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 In the Drawing Explorer, select the view drawing that contains
the model space view you want to change, and expand it.
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NOTE To change the name, description, or scale of a model space
view, the associated view drawing does not need to be open. To
change the model space boundaries, the associated view drawing
must be open.

4 Right-click, click Properties, and change the properties of the
model space view as needed:

Then…If you want to…

enter a new name.change the name of the
model space view

click the setting for Description and change it.change the description
for the model space
view

select a new scale from the list.change the scale of the
model space view

5 To change the model space boundary, click  , and redefine
the boundaries on screen.

6 Click OK.

Deleting Model Space Views
Use this procedure to delete a model space view.
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When you delete a model space view, it is only deleted from the view drawing;
existing sheet views based on a deleted model space view remain in their
respective sheets.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 Select the view drawing that contains the model space view you
want to delete, and expand it.

4 Select the model space view to delete, right-click, and click Delete.

NOTE You can also delete model space views by the click View tab ➤ Appearance
panel ➤ Views drop-down ➤  View Manager, and deleting the model space view.

Synchronizing View Drawing Layers with Sheet View Layers
You can set up your project so that the sheet view layer settings are updated
from the layer settings in the model space of the view drawing.

The synchronized layer settings include:

■ the layer states (on/off, thawed/frozen).

■ the layer properties (layer, color, linetype, plotstyle) of layers native to the
view drawing.

■ the layers in external references attached to the view drawing through
constructs and elements.

View drawing with xref dependent layer changes
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Sheet view with layer settings from view

Before you can use the layer settings of the view drawing in a sheet view, the
following conditions must be met:

■ In the Project Properties dialog, the setting for synchronizing view drawing
layers with sheet view layers must be activated. For more information, see
Configuring an Existing Project to Synchronize View Drawing Layers with
Sheet View Layers on page 480.

■ In both the view drawing and the sheet drawing, the VISRETAIN variable
should be set to 1.

■ The VPLAYEROVERRIDESMODE variable for the AutoCAD session must
be set to 1.

■ The project in which the view drawing and the sheet drawing reside must
be the currently active project. If you open the sheet drawing outside of
Project Navigator while its project is not current, the synchronization will
not take place. The layer settings from the last successful synchronization
will remain in effect.

■ The layer synchronization takes place only if the view drawing and sheet
drawing are located within the project context. If either the view drawing
or the sheet drawing have been disconnected from the project, the standard
AutoCAD VISRETAIN behavior controls how the externally referenced
layer settings resolve. If you register both files back into the project, you
can synchronize the view and sheet layers again.

■ If you have set the project to synchronize view drawing layers with sheet
view layers after you created sheet views, close and reopen the existing
sheet views, or reload their xrefs to perform the synchronization.

■ If you have set a legacy project from a previous version of the software to
synchronize view drawing layers with sheet view layers, you may need to
manually link the sheet views to the view drawing. If the sheet views need
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to be linked, they will display a warning icon  in the Drawing Explorer.
In that case, follow the instruction in Linking a Legacy View Drawing to
a Sheet View on page 479 to link the sheet view to the view drawing.

Synchronization of view drawing layers with sheet view layers occurs in the
following instances:

■ Loading or reloading external references

■ Background plotting and publishing of the sheet

When a project is set to synchronize view drawing layers with sheet view
layers, the following behaviors will differ from standard AutoCAD behavior:

■ If a layer is off or frozen in the model space of the view drawing, it will be
frozen in synchronized sheet views.

■ Plotting or publishing output will include synchronized sheet views except
when you are foreground plotting the active sheet; in this case, the current
display settings in the sheet view will be used. In all other cases, the output
may display the updated, synchronized layer settings, even though the
open sheet view remains out of synch.

■ Synchronization of layer settings will never occur during electronic
transmission of a sheet.

If you copy or cut and paste a sheet view, the new copies will not be linked
to the original source view. To create multiple sheet views of a model space
view, drag the model space view to the sheet again. This creates a new sheet
view with the same model space view content.

When you drag a view drawing with multiple model space views onto a sheet,
the sheet view layers will be synchronized with the view drawing after all
sheet views are created.

When the project is set to synchronize view drawing layers with sheet view
layers, any AutoCAD layer snapshots that are attached to model space views
will be ignored. If the project is not set to synchronize view drawing layers
with sheet view layers, then the layer snapshot settings will be retained.
However, any layer that did not exist when the AutoCAD layer snapshot was
created will be frozen in the sheet view, regardless of whether it is frozen or
thawed in the view drawing. The new layer will also be listed as an
unreconciled layer in Layer Manager. For more information, see New Layer
Notification on page 745.
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Display Configurations in Sheet Views

When a project is set to synchronize view drawing layers with sheet view
layers, changes to the display configuration of the view drawing will not be
updated in the sheet view. The display configuration initially used in the sheet
view will be the same configuration that was active when the view drawing
or model space view was first referenced into the sheet drawing, unless changed
in the sheet view. Use one of the following methods to update the display
configuration of the view drawing in a sheet view:

■ Edit the sheet view directly by double-clicking it and changing the display
configuration in the sheet view.

■ Create a new sheet drawing, and reference the view drawing that has the
desired display configuration.

Viewport Layer Overrides in Sheet Views

Sheet views created in AutoCAD Architecture allow for layer overrides in paper
space viewports. (For more information, see Overriding Layer Properties in
Layout Viewports on page 729.) If the project has been set to synchronize view
drawing layers with sheet view layers, any viewport-specific overrides in the
sheet view will be overwritten when the view drawing xrefs are reloaded in
the sheet view. Otherwise, sheet view specific overrides behave as normal
viewport layer overrides. In this case, the xref-dependent layer changes from
the view will be marked as viewport overrides in the sheet.

Workflow to Synchronize View and Sheet Layers
After you set up your project so that the sheet view layer settings are updated
from the layer settings in the model space of the view drawing, these settings
do not have to be synchronized again.

Specify project properties on page 480 once per
project to synchronize layers between views and
sheets.

-----Specify settings for the project

478 | Chapter 7   Drawing Management



Type VISRETAIN at the command line, and verify
that this variable is set to 1 before saving and

-----Specify settings for the view closing the view drawing. The setting is saved in
the drawing template on page 179 and should be
verified before you create a sheet.

Type VPLAYEROVERRIDESMODE at the command
line, and verify that this variable on page 729 for
AutoCAD Architecture is set to 1.

-----
Specify settings for AutoCAD
Architecture

Create on page 484 a sheet, and drag the view on
page 465 onto the sheet or create on page 468 and-----Add the view to a sheet
place a model space view on page 471 on the
sheet.

Linking a Legacy View Drawing to a Sheet View
In order to synchronize the view drawing layers with the sheet view layers,
the sheet view and view drawing must be linked. In legacy projects created
with a previous version of the software, where a view drawing without model
space views was placed on a sheet, this information does not exist and must
be added by linking the sheet view to the view drawing.

When this happens, the sheet view icon on the sheet set tree displays a warning

icon (  ). The sheet view must be linked to the view drawing to establish
the link and allow synchronization.

NOTE In other cases where the link between a sheet view and its associated view
drawing is broken, no warning icon will be displayed. In these cases, the sheet
view must be recreated in the sheet by dragging the model space view or view
drawing onto the sheet again. This creates a new sheet view with the correct
connection. The connection between sheet view and view drawing or model space
view can be broken by: renaming of the view drawing, renaming of the model
space view, copying and pasting a sheet viewport, or creating a viewport by using
the MVIEW command.
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1 On the Quick Access toolbar, click Project Navigator  .

2 On the Sheets tab, open the sheet containing the sheet view to
be linked.

3 Select the desired sheet view, and drag it onto a view drawing on
the Views tab.

The sheet view node will be updated when you expand the

containing sheet node, when you click Refresh  on the Project
Navigator palette, or when the linking is complete.

Configuring an Existing Project to Synchronize View Drawing
Layers with Sheet View Layers

At any time during a project, you can activate synchronization of view drawing
layers with sheet view layers. Selecting this option does not update existing
sheet views instantly; the update occurs the next time they are opened or their
external references are reloaded.

1 At the bottom of the Project Navigator palette, click  .

2 In the Project Browser, select the currently active project,
right-click, and click Project Properties.

3 Under the Basic category, expand Drawing Settings.

4 For Match Sheet View Layers to View, select Yes.

5 Click OK to close the Project Properties dialog, and click Close to
close Project Browser.

New sheet views you create will use the layer settings of the
associated view drawing. Existing sheet views will be synchronized
the next time they are opened or have their xrefs are reloaded.

Changing Views: Interactions with the Project
Changes made to one part of a project frequently influence other parts of the
project. Listed below are the effects of some of the common changes you can
make to a view.

■ Adding a new view drawing: When you create a new view drawing, all or
most of the referenced constructs should be present. For easy selection of
constructs, place them in categories.
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■ Changing the view name and category (location): A view drawing has a
number of constructs referenced into it, and the view drawing itself can
be referenced into a sheet. Therefore, any name and location changes to
a view drawing need to be updated throughout the project. To update the
path, repath the project as described in Repath the Project on page 525.

■ Changing the content of a view drawing: Any changes made to the content
of a view are also made to the sheets that reference that view. If you have
created model space views and sheet views from the view drawings, they
will be updated to reflect the changed content of the view drawing.

■ Deleting a view drawing: If you delete a view drawing that has been
referenced into a sheet, that sheet now has missing references. Check to
see if the view is still used in a sheet before deleting it. If you delete a view
drawing, all model space views associated with that view are deleted also.
Any sheet views that reference these views will have missing references.

■ Changing a model space view: Changes made to the boundaries or scale
of an existing model space view are not updated in existing sheet views
derived from this view. To change the sheet view, delete it and re-create
it from the updated model space view. If the content of a model space view
changes due to changes in the view drawing, these changes will be updated
in the sheet view.

■ Deleting a model space view: When you delete a model space view, all
sheet views created from it remain intact. For definition, sheet views need
only the building model in the view drawing.

Sheets
Sheets are used to plot view drawings of your building project. The sheet
system in AutoCAD Architecture consists of these components:

■ Sheet: A sheet is a paper space layout that has been registered as a sheet.
A sheet can contain one or more views.

■ Sheet views: A sheet view is a paper space viewport created by dragging
and dropping a model space view from the Project Navigator onto a sheet.

■ Sheet sets: A sheet set is a collection of sheets. Within the sheet set, sheets
are organized in sheet subsets.

■ Sheet drawing: A sheet drawing is a drawing file containing one or more
sheets.
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Sheets, sheet subsets, sheet views, and sheet drawings are listed on the Sheets
tabs of the Project Navigator.

Sheets and Sheet Drawings

The National CAD Standard (NCS) mandates that sheets should be stored in
individual drawings, each with one sheet layout. The drawing name should
be the sheet number in its sheet set. The AutoCAD Architecture Project
Navigator follows this standard, so that each new sheet is placed in a new
sheet drawing. You can, however, create multiple sheets in one sheet drawing,
if necessary. For more information, see Importing the Current Layout as a
Sheet on page 494.

Sheets and Annotation

Although it is recommended that annotation be placed in a view, you can
add annotation, dimensions, and schedule tables in a view or a sheet,
depending on your specific workflow and needs. Scheduling in AutoCAD
Architecture makes it easy to add annotation in both views and sheets. For
more information on annotating a project, see Workflow for Annotating a
Project on page 529.

Sheet Drawing Files

A sheet drawing is a DWG file. As opposed to other non-project drawing files,
an XML file with the same name is created when you create a sheet drawing.
The accompanying XML file contains information to connect the drawing
file with the project.

NOTE The XML file is created and updated automatically. You do not need to
edit it but be careful not to accidentally delete it in Windows Explorer.

Sheets and sheet views are contained within sheet drawings. There are no
corresponding XML files for individual sheets or sheet views.

Sheet Categories and Subsets

Sheets are organized in 2 different methods. In the Explorer View, sheet
drawings are placed in category folders. When you create sheets or sheet views
within a sheet drawing, they are placed in the host sheet drawing.
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Sheet tab with Sheet Set View of project (left) and Explorer View (right)

In the Sheet Set view, sheets are organized in sheet subsets. Sheet subsets are
a logical structure rather than a physical one. This means that the sheet and
subset organization may not reflect the drawing file organization on disk. You
can logically rearrange sheets into a different subset within the Sheet Set View,
but that will not change their physical location in the category or folder. The
sheet category folder does not need to be identical to the sheet subset in which
the sheet is placed. However, to avoid confusion, it is recommended to have
parallel structures in the sheet set and the sheet categories. When you remove
a sheet from a sheet subset in the Sheet Set view, only the reference to the
sheet in the subset is removed; the layout itself and its containing sheet
drawing are not deleted from the Sheets folder or subfolder. For more
information, see Sheets on page 481.

When to Start with Sheets
Sheets are the final output of a building design. You create sheets after you
have created constructs for all parts of the building model, along with the
necessary model views, detail views, and section/elevation views. You then
drag the views onto the sheets to create sheet views.

Designing a building is an iterative process. You will revisit planning stages
and make changes to constructs, elements, and views. These changes are
reflected in sheets.
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Sheet with building plan

Keep these points in mind when creating sheets:

■ The content of a sheet depends on the views that are referenced into it
and the constructs referenced into the views.

■ The viewport settings of a sheet view are defined in the model space view
placed on the sheet from a view drawing. For more information, see
Creating a Model Space View on page 468.

■ A sheet contains all plotting-specific settings and title blocks.

Creating a Sheet
Use this procedure to create a new sheet. Each new sheet is created in a new
sheet drawing.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Add a new sheet to the project using one of the following
methods:

■ Right-click the subset in which to place the new sheet, and
click New ➤ Sheet.

■ In the toolbar at the bottom of the Sheets tab, click  .
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4 If you selected to be prompted for a template each time you create
a new sheet, you are prompted now for a sheet template. Select
a drawing template and a layout from a DWT, DWG or DWS file
as a sheet template, and click OK.

If you selected not to be prompted for a sheet template when
creating new sheets, the default template defined in the project
sheet set or the sheet subset is used.

5 Define the sheet properties:

Then…If you want to…

enter a number. If you selected a project
prefix in the project settings, the prefix is

number the new sheet

placed in front of the sheet number in the
file name. For more information, see Specify-
ing Basic Project Properties on page 334.

enter text under Sheet title. Commas, am-
persands, and semicolons are allowed in

enter a title for the sheet

sheet titles. The sheet title is used in these
locations:

■ As the display name of the sheet in the
Drawing Explorer.

■ As the display name of the sheet in a
sheet list.

■ As the sheet layout name in the sheet
drawing.

enter one under File name.enter a file name for the
sheet

The folder path defined in Project Properties
is displayed. This field is read only. For inform-

change the folder in
which the sheet is saved

ation about changing the Folder path, see
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Then…If you want to…

Specifying Basic Project Properties on page
334.

enter a template path.select a new sheet tem-
plate

NOTE If the settings for the storage folder and the sheet set template
are read only, these settings are defined in the sheet subset. To change
them, you must change the properties of the sheet subset.

6 Click OK.

You can access the new sheet from 2 locations:

■ In the Sheet Set view, the new sheet is displayed under the sheet subset in
which you created it.

■ In the Explorer View, the sheet drawing and the sheet are displayed under
the folder category in which you saved the sheet.

Sheet Set View on project (left) and Explorer View (right)

By default, these have the same organization, but depending on your project
setup, these 2 locations can have different names and structures.
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Setting the Properties of the Project Sheet Set
Use this procedure to set the properties of the project sheet set.

The properties of the project sheet set are initially defined by the sheet set
template you assigned in Creating a New Project on page 328. However, you
can change the settings for an individual project.

NOTE A number of settings apply only to sheet sets referenced in the AutoCAD
Sheet Set Manager. For a sheet set that will be used in an AutoCAD Architecture
project, most settings come from the project, and not from the sheet set template.

The following settings are ignored when you use a sheet set template in an
AutoCAD Architecture project:

■ Sheet set data file: The DST file is always stored in the root folder of the
project.

■ Model view: Model view drawing locations are not tracked in AutoCAD
Architecture sheet sets. They are automatically taken from the project
views.

■ Label block for views: Label blocks are not recommended in an AutoCAD
Architecture project. Use callout tools instead. For more information, see
Callout Tools on page 3690.

■ Callout blocks: Callout blocks are not recommended in an AutoCAD
Architecture project. Use callout tools instead. For more information, see
Callout Tools on page 3690.

■ Sheet storage location: The sheets in a project are always stored in the
Sheets folder of the project, or in one of its subfolders.

NOTE If you enter a project name and project number under Project Control
that differs from the project name and number you have entered in Creating
a New Project on page 328, you will get a message when editing the sheet set
properties, and be prompted to consolidate the information.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Select the root node of the sheet set, right-click, and click
Properties.
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4 Expand Sheet Set.

5 To define page setup overrides in the project, click the setting for
Page setup override files.

6 In the Select Template dialog, select a drawing template (DWT)
file.

NOTE Select a template that contains named paper space layouts,
and make sure that their plot areas have been set to Layout.
Otherwise, you cannot use them as page setup overrides.

7 Expand Sheet Creation.

In this category, you define settings for the sheets you create
within the sheet set.
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8 To define a default template for new sheets, click the setting for
Sheet creation template.

9 Click  to browse for a drawing (DWG) or template (DWT)
file, and click Open.

10 Select the default layout you want to use to create new sheets.
Then, click OK.

11 Specify if you want to be prompted for the sheet template each
time you create a new sheet:

Then…If you want to…

select Yes.be prompted for a sheet
template each time you
create a new sheet

select No.always use the default
sheet template

12 To add, edit, or delete custom properties, click Edit Custom
properties.

For information about Custom Properties, see “Include
Information with Sheets and Sheet Sets” in AutoCAD Help.

NOTE When working in an AutoCAD Architecture project, you can
also use the project properties. For more information, see Adding
Detailed Information to Project Properties on page 337.

13 Click OK.
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If you have entered a project name and project number in the
sheet set properties that differs from the project number and name
defined in Creating a New Project on page 328, a message appears
informing you of the mismatch. For information about
consolidating the inconsistent name and number, see
Consolidating Inconsistent Project and Sheet Set Information on
page 347.

Creating a Sheet Subset
Use this procedure to create a new sheet subset. You create sheet subsets in
the Sheet Set view of the Sheets tab.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Select the sheet subset under which you want to create a new
subset, right-click, and click New  ➤ Subset.

4 Define the properties of the new subset:

Then…If you want to…

enter a new name.change the name of the
sheet subset

under Store new sheet DWG files in, click 
. Then, select a folder into which new sheets
should be placed, and click Open.

set a different default dir-
ectory for new sheets
created in this subset

under Sheet creation template for subset, click

 . Then, use the default or select a DWG
or DWT file, and select a layout of the file.

set a different default
template for new sheets
created in this subset

select Prompt for template.be prompted for a tem-
plate each time you cre-
ate a new sheet in this
subset

5 Click OK.
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Setting the Properties of a Sheet Subset
Use this procedure to set the properties of a sheet subset.

A sheet subset is a logical grouping of sheets and subsets. Subsets help you
organize your sheet by allowing you to create sheet subsets for plan sheets,
detail sheets, elevation sheets, or other grouping criteria.

You can set the following parameters for a sheet subset:

■ The default template for new sheets created in this subset

■ Whether to be prompted for a sheet template each time you create a new
sheet

These parameters are set in sheet set properties., but you can override them
for individual subsets. This would be useful if you want to use different sheet
templates for plan sheets and detail sheets.

If you have no sheet subsets in your sheet set yet, see Creating a Sheet Subset
on page 490.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Select the sheet subset for which to change properties, right-click,
and click Properties.
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4 Change the properties of the sheet subset:

Then…If you want to…

enter a new name.change the name of the
sheet subset

under Store new sheet DWG files in, click 
. Then, select a folder into which new sheets
should be placed, and click Open.

set a different default dir-
ectory for new sheets
created in this subset

under Sheet creation template for subset, click

 . Then, select a DWG or DWT file, and

set a different default
template for new sheets
created in this subset

select a layout of the file as the default sheet
template.

select Prompt for template.be prompted for a tem-
plate each time you cre-
ate a new sheet in this
subset

5 Click OK.

492 | Chapter 7   Drawing Management



Removing a Sheet Subset
Use this procedure to remove a sheet subset from the project sheet set. When
you delete a sheet subset, no sheets or sheet drawings are deleted.

You can remove a sheet subset only if it contains no sheets.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Select the sheet subset you want to delete, right-click, and click
Delete.

Importing Sheets into the Sheet Set
Use this procedure to import a sheet into the project sheet set.

When you import a layout as a sheet, the layout and its associated sheet
drawing are physically not moved from their original location. For example,
if you import a layout from the drawing C:\Additional Drawings\Example.dwg
into the project sheet subset Architectural, the selected sheet is displayed
under the Architectural subset; the Example.dwg file, however, is not moved
into the Sheets folder of the project. This drawing remains in its original
location under C:\Additional Drawings\Example.dwg.

If you switch to the Explorer View, the imported sheet drawing is listed if the

drawing is located outside the folder. It is marked with a special icon  .

A sheet can belong to only one sheet set. You cannot import a sheet that is
already part of another sheet set.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Select the sheet subset into which to import the sheet, right-click,
and click Import Layout as Sheet.
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4 Click Browse for Drawings.

5 Browse for the drawing file containing the sheet you want to
import, and click Open.

6 Select the sheet layout to import.

NOTE You can select multiple layouts here.

7 If you want the sheet name to be prefixed with the sheet drawing’s
file name, select Prefix sheet titles with file name.

8 Click OK.

NOTE To import a layout that is currently open and displayed on the drawing
screen, select the subset in which it should be displayed, right-click, and click
Import Current Layout as Sheet.

Importing the Current Layout as a Sheet
Use this procedure to import the current layout as a sheet in the sheet set.

In some cases, you might have sheet drawings that do not conform to the
NCS standard, and contain more than one sheet. When you create a sheet in
the Drawing Explorer of AutoCAD Architecture, only the first sheet in the
sheet drawing is registered. To register other sheets as well, you may import
them while the sheet drawing is open and the layout is displayed.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Explorer View) in the title bar.
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3 Locate the sheet drawing that has additional layouts you want to
register as a set.

4 Double-click the sheet drawing.

5 On the drawing screen, click the layout you want to import to
make it current.

6 On the Project Navigator palette, click  .

7 Navigate to the sheet subset in which the additional sheet should
be placed, right-click, and click Import Current Layout as Sheet.

The sheet is added to the sheet subset. When you change to the Sheet Set
view, and expand the sheet drawing containing the sheet, you can see that
the additional sheet is now listed under the sheet drawing.

Opening and Closing a Sheet
Use this procedure to open and close a sheet. For information about additional
commands available on the context menu, see The Drawing Explorer Context
Menu on page 369.

When you open a sheet, the sheet drawing containing the sheet opens with
the correct sheet (layout) displayed.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Sheets tab, click  (Sheet Set View) in the title bar.

NOTE You can also open a sheet from the Explorer View of the Sheets
tab.

3 Locate the sheet you want to open.

4 Open the sheet using one of the following methods:

■ Select the sheet, right-click, and click Open.

■ Double-click the sheet.

The drawing containing the sheet opens in the drawing area of
AutoCAD Architecture. You can now edit it. To close the sheet,
you must close the sheet drawing.

5 Close the sheet drawing using one of the following methods:

■ Right-click it in the Drawing Explorer, and click Close.
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■ Click  ➤ Close ➤ Current Drawing.

6 Click Yes to save the changes in the drawing, if necessary.

7 To update the preview of the sheet in the Drawing Explorer, click

 (Refresh Project).

Changing the Properties of a Sheet
Use this procedure to change the properties of a sheet.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Select the sheet for which you want to change properties,
right-click, and click Properties.

4 Change the sheet properties as necessary.

For more information, see “Include Information with Sheets and
Sheet Sets” in AutoCAD Help.

5 Click OK.

Removing a Sheet
When you remove a sheet from the sheet set, the sheet drawing and its
companion XML file are deleted unless other sheets exist in the sheet drawing.
If other sheets exist in the sheet drawing, or the sheet drawing is located
outside of the sheet folder, then only the reference to the sheet is removed.
When only the reference is removed, the sheet drawing is still physically saved
on disc.

You must be in the Sheet Set view on the Sheets tab of the Project Navigator
to remove sheets.

Removing a sheet from the sheet set has the following consequences:

■ The sheet cannot be selected for a sheet selection.

■ The sheet will not be included in new sheet lists.
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■ The sheet will not be included in electronic packages of the sheet set.

■ The sheet will not be included in archive packages of the sheet set.

■ The sheet will not be included when you publish the sheet set to a plotter,
PDF, DWF, or a DWFx file.

To remove a sheet from the sheet set:

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Select the sheet you want to remove from the sheet set, right-click,
and click Delete.

4 In the Confirm Sheet Delete dialog, click Yes.

Deleting a Sheet Drawing
You must delete sheet drawings from the project using the Explorer View on
the Sheets tab of the Project Navigator. When you delete a sheet drawing, all
sheet layouts in the sheet drawing are deleted from this project.

To delete a sheet drawing from the project:

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Explorer View) in the title bar.

3 Select the sheet drawing you want to delete, right-click, and click
Delete.

4 In the Confirm Sheet Delete dialog, click Yes.

Creating a Sheet View
Use this procedure to create a sheet view on a sheet.

A sheet view is a paper space viewport on a sheet that is created when a model
space view or view drawing from the Project Navigator is dragged and dropped
onto a sheet. For information on model space views, see Creating a Model
Space View on page 468.
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1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 In the Sheet Set view, locate the sheet on which you want to place
a new sheet view.

4 Open the sheet using one of the following methods:

■ Select the sheet, right-click, and click Open.

■ Double-click the sheet.

The sheet opens in the drawing area of AutoCAD Architecture.
The sheet you have selected is the active layout.

5 On the Project Navigator palette, click the Views tab.

6 Select the model space view, right-click, and click Place on Sheet.
Then, select an insertion point on the sheet.

Alternatively, drag the model space view from the Project
Navigator and drop it onto a sheet.

NOTE Sheet views are inserted with their own layer key. The layer
key used for sheet views is G-Anno-Nplt.

Opening a Sheet View
Use this procedure to open a sheet view.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Select the sheet containing the sheet view you want to open, and
expand it.

4 Select the sheet view, right-click, and click Open.

Numbering Sheet Views
Use this procedure to number sheet views in a sheet set.

498 | Chapter 7   Drawing Management



The number assigned to a sheet view is displayed as a prefix to the sheet set
view name on the Project Navigator.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Select the sheet that contains the sheet view you want to number,
and expand it.

4 Select the sheet view, right-click, and click Rename and Renumber.

5 Enter a number for the sheet view.

6 If necessary, rename the sheet view.

7 Click Next to display the information for the next sheet view in
the sheet.

8 When you finish changing the numbering of sheet views, click
OK.

Deleting a Sheet View
Use this procedure to delete a sheet view from a sheet.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Select the sheet containing the sheet view you want to delete,
and expand it.

4 Select the sheet view, right-click, and click Open.

The sheet view opens in the drawing area.

5 Select the sheet view in the drawing area, and press DELETE.
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NOTE The view xref is still attached in model space. To also detach
the view from the sheet, right-click the sheet in the Drawing Explorer,
and click External References. In the External References dialog, select
the view, right-click, and click Detach.

Displaying External References of a Sheet Drawing
Use this procedure to display the external references of a sheet drawing.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Explorer View) in the title bar.

3 In the Drawing Explorer, locate the sheet drawing for which to
display external references.

4 Select the sheet drawing.

5 Display the xrefs using either of the following methods:

■ Right-click, and click External References.

■ On the toolbar at the bottom of the Sheets tab, click  .

The External References dialog displays a list of xrefs in the sheet.
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6 Expand or collapse the list by clicking individual items, and
right-click to change the status of the xref, if necessary.

From the context menu, you can unload, reload, or detach the
attached xref. For more information, see Reference Other Drawing
Files in AutoCAD Help.

7 On the External References dialog, view the details of the xref.

■ The Reference Name displays the name of the drawing.

■ Status displays whether the xref is loaded or unloaded in the
host drawing, and it displays the host drawing as Open if it is
open in the drawing window. If the host drawing is not open
in the drawing window, status is left blank.

■ Size displays the file size of the selected drawing.
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■ Type displays whether the drawing is an attachment, an
overlay, or the host drawing.

■ Date displays the last date the selected drawing was modified.

■ Saved Path displays the saved path, if any, that is used to locate
the xref. This path can be a full (absolute) path or a relative
(partially specified) path.

■ Found At displays the path where the xref was found. If no
path was saved for the xref, or if the xref is no longer located
at the specified path, the program searches for the xref and
displays the location here.

8 Click OK to close the dialog.

NOTE You can also display external references by opening the sheet drawing and
using the AutoCAD Xref Manager. For more information, see “Reference Other
Drawing Files (Xrefs)” in AutoCAD Help.

Inserting a Sheet List
Use this procedure to insert a sheet list on a sheet.

A sheet list is a table of contents for the sheets in a project. Normally, you
place it on the cover sheet of your sheet set; however, you can place it on any
sheet.

The sheet list is inserted as a table.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Open the sheet on which you want to place the sheet list.

4 Select the sheet set, sheet, or subset, right-click, and click Insert
Sheet List Table.
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5 On the Table Data tab, select the table style for the sheet list under
Table Style name.

To create a new table style, click  . For information on creating
table styles, see “Work with Table Styles” in AutoCAD Help.

6 Enter the title of the sheet set under Title Text.

7 Under Column Settings, define the information to include in the
sheet list.

Columns for sheet number and sheet title have already been
defined; however, you can delete them.

Then…If you want to…

click Add. Then, click the Data Type entry, and se-
lect the data you want to display in the list. You

add a column to
the sheet list

can choose subject, author, keywords, and more.
To change the heading text for the entry, click the
heading text and enter new text.

select the column in the list, and click Remove.remove a column
from the sheet list

select the column in the list, and click Move Up or
Move Down. The top entry in the list will be placed

rearrange a column
in the sheet list

as the far left column in the sheet list. The next-
lower entry will be placed next to the left column,
and so on.
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Then…If you want to…

NOTE You can see a preview of the sheet list
in the viewer on the left.

8 Click the Subsets and Sheets tab, and select the sheets to include
or select the subset if you want each sheet in that subset to be
included in the table.

When a subset is selected, any sheets added to that subset in the
future are also added to the sheet list table.

9 Click OK.

NOTE The sheet list is generated from the sheets contained in the
sheet set. If you make manual changes to the sheet list after placing
it on a sheet, these changes will be overwritten when you update the
sheet list, as described in Updating the Sheet List on page 505.

10 Specify an insertion point for the sheet list on the current sheet.

The sheet list is placed on the sheet.

The sheet title and sheet number entries are hyperlinked to the
files containing these sheets. If you CTRL-click the sheet title or
sheet number, it will open the associated drawing file.

Sheet list table on cover sheet
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Changing the Sheet List Properties
Use this procedure to change the properties of a sheet list.

NOTE Changing the properties of a sheet list includes changing the table style,
the number and arrangement of columns displayed, and the sheet list title. If you
change the actual sheets in your list (for example if you rename sheets, add, or
delete sheets), update the sheet list, as described in Updating the Sheet List on
page 505.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Open the sheet that contains the sheet list.

4 Select the sheet list in the drawing, right-click, and click Edit Sheet
List Table Settings.

5 Change the properties of the sheet list, as described in Inserting
a Sheet List on page 502.

Updating the Sheet List
Use this procedure to update a sheet list.

If you add, remove, or rename sheets, update the sheet list when you change
the sheet set; for example, if you add, remove, or rename sheets.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Open the sheet that contains the sheet list.

4 Select the sheet list in the drawing, right-click, and click Update
Sheet List Table.

Refreshing the Sheet Set
Use this procedure to refresh the sheet set.
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Refreshing a sheet set includes opening all sheets in the set, updating them
with any changes that have occurred (for example, changed external
references), saving them, and closing them. You cannot refresh sheets, if any
of the following conditions are true:

■ The associated sheet drawing is already open.

■ The sheet drawing or its folder are set to read-only.

■ The associated sheet drawing has been deleted.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Select the sheet set root node, right-click, and click Resave All
Sheets.

Resaving the sheet set can take a moment or two. A progress bar
displays how long it will take. When the sheet set has been saved,
you are notified by a message. If there were problems saving one
or more sheets, they are listed. You can also view details in a log
file located in the root directory of the project folder.

Creating a Sheet Selection
Use this procedure to create a sheet selection.

If you regularly work with a specific group of sheets in the project sheet set,
you can create a named selection of those sheets. You define the sheet selection
by choosing its name in the Sheet Set view of the Project Navigator.

You could use a sheet selection as a selection set for electronic transmissions
or publishing.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 SHIFT-click or CTRL-click to select the sheets to include in the
sheet selection.

4 When you finish selecting sheets, right-click, and click Save Sheet
Selection.
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5 Enter a name for the sheet selection, and click OK.

Activating a Sheet Selection
Use this procedure to activate a sheet selection.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Select the project sheet set root node, right-click, and click Sheet
Selections.

4 Make your selection from the Sheet Selections submenu.

Removing a Sheet Selection
Use this procedure to delete a sheet selection.

NOTE Deleting a sheet selection does not delete any sheets included in that
selection.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Sheets tab, and click  (Sheet Set View) in the title
bar.

3 Select the project sheet set root node, right-click, and click Sheet
Selections ➤ Manage.

4 Select the sheet selection you want to delete, and click Delete.

5 Click OK.
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Electronically Transmitting Sheets and Sheet Sets
Use this procedure to electronically transmit a sheet, a sheet subset or the
project sheet set.

Electronically transmitting a file set means that you package the file set for
delivering in electronic form. Drawing files in the transmittal package include
all related dependent files, such as external references and font files.

You can select different components of the project sheet set for electronic
transmittal:

■ The complete project sheet set: This includes all sheets in the project sheet
set.

■ A sheet subset: This includes all sheets from a specified sheet subset.

■ A sheet: This includes the sheet.

For more information about electronic transmittal, see “Package a Set of Files
for Internet Transmission” in AutoCAD Help.

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Sheets tab, click  (Sheet Set View) on the title bar.

3 Select the component you want to transmit electronically:

Then…If you want to…

select the project sheet set.transmit the complete pro-
ject sheet set

select the desired subset.transmit a sheet subset

select the desired sheet.transmit a sheet

4 Right-click, and click eTransmit.

The Create Transmittal dialog is displayed.
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5 In either the Files tree tab or the File Table tab, select the
components to be included in the electronic package.

The Files Tree tab displays the included files sorted by type. The
Files Table tab displays all files in a list view. You can sort the list
by name, path, type, version, size, and date.

6 To include project information, double-click the setup under
Select a transmittal setup, and in the Modify Transmittal Setup
dialog, select Include project information under Include options.

For detailed information about packaging project information for
an electronic transmittal, see Electronically Transmitting a Project
on page 352.

7 Click OK to start the electronic transmittal.
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Publishing Sheet Sets
In the Sheet Set view, you can publish sheets to a plotter, a PDF, a DWF file,
or a DWFx file. You can assign plot stamps to the sheet set, publish sheets to
an alternate page setup, and specify PDF, DWF, and DWFx publishing settings.

You publish from the following components:

■ An individual sheet.

■ A sheet subset. For information about creating sheet subsets, see Creating
a Sheet Subset on page 490.

■ A sheet selection. For information about creating sheet subsets, see Creating
a Sheet Selection on page 506.

■ The project sheet set.

For detailed information about plotting and publishing, see the following
topics in AutoCAD Help:

■ Publish Drawings

■ Publish, Transmit, and Archive Sheet Sets

■ Overview of Page Setup Settings
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■ Set Options for Plotted Objects and Plot Stamp Dialog Box

Changing Sheets: Interactions with the Project
Changes made to one part of a project frequently influence other parts of the
project. The following information describes the changes you can make to a
sheet and the effects of the changes on other parts of the building project:

NOTE Because the sheet is the last stage of the project, it has fewer interactions
with the project than the other components do. For example, deleting a sheet
has no influence on other drawings, like views or constructs.

■ Adding a new sheet: Normally, a sheet is created to reference a specific
view. For example, if you create a view called First Floor Plan, create a sheet
that contains this view.

■ Changing the sheet name and subset: A sheet has one or more views
referenced into it. Therefore, any name and location changes to a sheet
need to be updated throughout the project. To update the path, repath
the project as described in Repath the Project on page 525.

WARNING When you repath a project that was saved in a version of AutoCAD
Architecture prior to 2010, the drawings are saved in the new file format. You
will no longer be able to open these drawings in a version of AutoCAD
Architecture prior to 2010. Synchronizing a project with the project standards
will also save the project drawings in the new file format. For more information,
see Repath the Project on page 525.

■ For detailed information on deleting views, see Deleting a View Drawing
on page 467.

Creating a Sheet Set Template
When you create a new project, a project sheet set is automatically created.
The project sheet set controls the settings relevant to sheets and the sheet set,
such as page setups, the sheet template, and sheet subsets. The sheet set is
based either on the sheet set template that you define in the project default
options, or, if you base a new project on a project template, on the sheet set
of this project template.
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The easiest way to create a new sheet set template is to base it on an existing
sheet set. You can also base your new sheet set template on existing drawing
files, allowing you to add existing sheet layouts to the template.

NOTE A number of settings apply only to sheet sets referenced in the AutoCAD
Sheet Set Manager. For a sheet set that will be used in an AutoCAD Architecture
project, most settings come from the project, and not from the sheet set template.
For more information, see Adding Detailed Information to Project Properties on
page 337 and Working with Project Properties on page 333.

These fields on the Sheet Set Properties dialog are ignored when you use a
sheet set template in an AutoCAD Architecture project for the following
reasons:

■ Sheet set data file: The sheet set file (DST) is always stored in the root folder
of the project.

■ Model view: Model view drawing locations are not tracked in AutoCAD
Architecture sheet sets. They are automatically taken from the project
views.

■ Label block for views: Label blocks are not recommended in AutoCAD
Architecture projects. Use callout tools instead. For more information, see
Working with Callouts on page 3687.

■ Callout blocks: Callout blocks are not recommended in AutoCAD
Architecture projects. Use callout tools instead. For more information, see
Callout Tools on page 3690.

■ Sheet storage location: The sheets in a project are always stored in the
Sheets folder of the project, or in one of its subfolders.

Creating a Sheet Set Template
Use this procedure to create a sheet set template based on a sheet set in an
existing project. Settings applied here are overridden if you redirect top-level
categories on the Project Property dialog in the project in which the sheet set
is located. For more information, see Specifying the Location of Top-Level
Categories on page 396.

1 Click  ➤ Options.
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2 Click the AEC Project Defaults tab, and click Create Sheet Set
Template.

The Create Sheet Set wizard is displayed. It will help you create a
new sheet set template.
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3 In the Create Sheet Set - Begin dialog, under Create a sheet set
using, select An example sheet set, and click Next.

4 In the Create Sheet Set - Sheet Set Example dialog, select a sheet
set to use as an example:

Then…If you want to…

click Select a sheet set to use as an ex-
ample, select a sheet set from the list, and
then click Next.

use a sample sheet set from
the list

click Browse to another sheet set to use

as an example, and click  . In the

use a sheet set not listed

Browse for Sheet Set dialog, select a sheet
set (DST) file, click Open, and then click
Next.

5 In the Create Sheet Set - Sheet Set Details dialog, enter a name for
the new sheet set template.

6 Enter a description for the new sheet set template.

7 Select the folder location in which to save the new sheet set
template.
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NOTE The location of a sheet set template (DST file) does not define
the location of project sheet sets created from that template. A project
sheet set is always stored in the root folder of the associated project.

If you are creating a sheet set template for an AutoCAD
Architecture project, selecting Create a folder hierarchy based on
subsets will have no impact because sheet subsets in the Drawing
Explorer will have corresponding folders associated to them
automatically. If you are creating a sheet set template for an
AutoCAD sheet set, you can select this option. This will create a
new subfolder in the sheet set every time you create a new sheet
subset in the Sheet Set Manager.

8 To define the properties of the new sheet set template, click Sheet
Set Properties.

The Sheet Set Properties dialog is displayed.
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It is not necessary to complete the following fields when you use
the sheet set template for an AutoCAD Architecture project:

ReasonField

The DST file is always stored in the
root folder of the project.

Sheet set data file

Model view drawing locations are
not tracked in AutoCAD Architec-

Model view

ture sheet sets. They are automatic-
ally taken from the project views.
In an AutoCAD sheet set, this field
displays the paths and names of
folders that contain drawings used
by the sheet set.

These are stored in the view tem-
plates.

Label block for views

These are located on the Tools
palette.

Callout blocks

You associate project information
with the project file (APJ), instead

Name, Number, Phase, Milestone
under Project Control

of the project sheet set, when you
are working in an AutoCAD Archi-
tecture project. For information on
associating information with a pro-
ject, see Creating a New Project on
page 328 and Working with Project
Properties on page 333.
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ReasonField

NOTE If you enter a project
name and project number un-
der Project Control in the Sheet
Sets Properties dialog that dif-
fers from the project name and
number you enter in Creating
a New Project on page 328, you
will get an error message when
editing the project, and be
prompted to consolidate the
information. Therefore, it is
strongly recommended to leave
the Project Control fields in the
sheet set template empty.

The sheets in a project are always
stored in the Sheets folder of the
project, or in one of its subfolders.

Sheet storage location

9 In the Sheet Set Properties dialog, under Sheet Set, click the setting
for Page setup overrides file to define overrides for the project.

10 In the Select Template dialog, select a drawing template (DWT)
file, and click Open.

NOTE Select a template that contains named paper space layouts,
and make sure that their plot areas have been set to Layout.
Otherwise, you cannot use them as page setup overrides.

None of the other settings under Sheet Set are applied when using
the sheet set template for an AutoCAD Architecture project.

11 Under Sheet Creation, you define settings for the sheets you create
within the sheet set.

12 To define a default layout for new sheets, click the setting for
Sheet creation template.

13 In the Select Layout as Sheet Template, click  to browse for a
drawing (DWG) or template (DWT) file, and click Open.

14 In the Select Drawing dialog, select the default layout to use to
create new sheets, and click OK.
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15 Specify if you want to be prompted for the sheet template each
time you create a new sheet:

Then…If you want to…

select Yes for Prompt for Template.be prompted for a sheet
template each time you
create a new sheet

select No for Prompt for Template.always use the specified
template

16 To add, edit, or delete custom properties, click Edit Custom
properties.

For information about Custom Properties, see “Include
Information with Sheets and Sheet Sets” in AutoCAD Help.

NOTE When working in an AutoCAD Architecture project, normally
you do not use custom properties. In most cases, you use the project
details in the Project Browser. For more information, see Adding
Detailed Information to Project Properties on page 337.

17 Click OK to close the Sheet Set Properties dialog. Then, click Next.

The Create Sheet Set - Confirm dialog displays.
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18 Verify that all settings for the new sheet set are correct:

Then…If you want to…

click Back.make changes to one or
more settings

click Finish.finish creating the sheet
set template

NOTE You can edit a project sheet set in the Sheet Set view of the Project
Navigator, as described in Setting the Properties of the Project Sheet Set on page
487. You can edit a project sheet set template in the Sheet Set Manager of AutoCAD,
as described in “Create and Manage a Sheet Set” in AutoCAD Help.

Creating a Template from Existing Drawings
Use this procedure to create a sheet set template that contains layouts from
one or more existing drawings. You can also select options to prefix the sheet
titles with the file name and create subsets based on the folder structure.
Settings applied here are overridden if you redirect top-level categories in the
Project Properties dialog in the project in which the sheet set is located. For
more information, see Specifying the Location of Top-Level Categories on
page 396.

1 Click  ➤ Options.

2 Click the AEC Project Defaults tab, and click Create Sheet Set
Template.

The Create Sheet Set wizard is displayed. It will help you create a
new sheet set template.

3 Under Sheet Set Template, click Create.

The sheet set wizard is displayed. It will help you to create a new
sheet set template.
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4 Under Create a sheet set using, select Existing drawings, and then
click Next.

5 In the Create Sheet Set - Sheet Set Details, enter a name for the
new sheet set.

6 Enter a description for the new sheet set.

7 Select the folder location where the new sheet set template should
be saved.
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NOTE The location of a sheet set template (DST file) does not define
the location of project sheet sets created from that template. A project
sheet set is always stored in the root folder of the associated project.

8 To define the properties of the new sheet set template, click Sheet
Set Properties.

The Sheet Set Properties dialog is displayed.

It is not necessary to complete the following fields when you use
the sheet set template for an AutoCAD Architecture project:

ReasonField

The DST file is always stored in the
root folder of the project.

Sheet set data file

Model view drawing locations are
not tracked in AutoCAD Architec-

Model view

ture sheet sets. They are automatic-
ally taken from the project views.
In an AutoCAD sheet set, this field
displays the paths and names of
folders that contain drawings used
by the sheet set.

These are stored in the view tem-
plates.

Label block for views

These are located on the Tools
palette.

Callout blocks
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ReasonField

You associate project information
with the project file (APJ), instead

Name, Number, Phase, Milestone
under Project Control

of the project sheet set, when you
are working in an AutoCAD Archi-
tecture project. For information on
associating information with a pro-
ject, see Creating a New Project on
page 328 and Working with Project
Properties on page 333.

NOTE If you enter a project
name and project number un-
der Project Control in the Sheet
Sets Properties dialog that dif-
fers from the project name and
number you enter in Creating
a New Project on page 328, you
will get an error message when
editing the project, and be
prompted to consolidate the
information. Therefore, it is
strongly recommended to leave
the Project Control fields in the
sheet set template empty.

The sheets in a project are always
stored in the Sheets folder of the
project, or in one of its subfolders.

Sheet storage location

9 In the Sheet Set Properties dialog, under Sheet Set, click the setting
for Page setup overrides file to define overrides for the project.

10 In the Select Template dialog, select a drawing template (DWT)
file, and click Open.

NOTE Select a template that contains named paper space layouts,
and make sure that their plot areas have been set to Layout.
Otherwise, you cannot use them as page setup overrides.

None of the other settings under Sheet Set are applied when using
the sheet set template for an AutoCAD Architecture project.
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11 Under Sheet Creation, you define settings for the sheets you create
within the sheet set.

12 To define a default layout for new sheets, click the setting for
Sheet creation template.

13 In the Select Layout as Sheet Template, click  to browse for a
drawing (DWG) or template (DWT) file, and click Open.

14 In the Select Drawing dialog, select the default layout to use to
create new sheets, and click OK.

15 Select the default layout you want to use to create new sheets.
Then, click OK.

16 Specify if you want to be prompted for the sheet template each
time you create a new sheet:

Then…If you want to…

select Yes for Prompt for Template.be prompted for a sheet
template each time you
create a new sheet

select No for Prompt for Template.always use the specified
template

17 To add, edit, or delete custom properties, click Edit Custom
properties.

For information about Custom Properties, see “Include
Information with Sheets and Sheet Sets” in AutoCAD Help.

NOTE When working in an AutoCAD Architecture project, normally
you do not use custom properties. In most cases, you use the project
details in the Project Browser. For more information, see Adding
Detailed Information to Project Properties on page 337.

18 Click OK to close the Sheet Set Properties dialog. Then, click Next.

The Create Sheet Set - Choose Layouts dialog is displayed.
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In the Create Sheet Set - Choose Layouts dialog, you can select
layouts from existing drawings and add them to the sheet set
template as sheets. For example, you could do this to convert
legacy sheets to project sheets.

19 To select one or more drawings from which to copy layouts to
the sheet set template, click Browse.

20 In the Browse for Folder dialog, select the folder containing the
drawings, and click OK.

21 Expand the folder and drawing name, and select the layouts to
be included in the sheet set template.

22 To remove a drawing or folder, select it, right-click, and click
Remove.

23 Repeat this step for drawings in other folders, if necessary.

24 To prefix sheet titles with the file name or create subsets of sheet
sets based on the folder structure, click Import Options, select the
options, and click OK.
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25 Click Next.

26 Verify that all settings for the new sheet set are correct:

Then…If you want to…

click Back.make changes to one or
more settings

click Finish.finish creating the sheet
set template

NOTE You can edit a project sheet set in the Sheet Set Explorer of
the Project Navigator, as described in Setting the Properties of the
Project Sheet Set on page 487. You can edit a project sheet set in the
Sheet Set Manager of AutoCAD, as described in “Create and Manage
a Sheet Set ” in AutoCAD Help.

Repath the Project
Use this procedure to update the external reference paths within the project
after making changes to the names or locations of elements, constructs, or
views. For example, if you move a project file into another category, or rename
it, you must update the file that references the changed drawing to reflect that
change on the Project Navigator palette.

WARNING When you repath a project that was saved in a version of AutoCAD
Architecture prior to 2010, the drawings are saved in the new file format. You will
no longer be able to open these drawings in a version of AutoCAD Architecture
prior to 2010. Synchronizing a project with the project standards will also save
the project drawings in the new file format.
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A repath is necessary after you make any of the following changes in the
project:

■ Move the project to a different location

■ Move a project file to a different category

■ Rename a project file

■ Move a subcategory from one category to another

In addition to updating the project files, repathing will also update the paths
of the following files:

■ Paths to support files, folders, and templates stored within the project
setup, such as drawing templates, tool content root path, or project
standards drawings.

■ Paths to images referenced in project drawings

■ Paths for schedules referencing external drawings within project drawings

When you zip a project and send it to another user who unpacks the project
to a different location on another computer, the project will be updated in
its new location when it is set current for the first time on the new computer.
For example, if your project resides in C:\Project1\, and the user you are
sending it to unpacks it to D:\Project1, the path information is updated when
the new user sets the project current in AutoCAD Architecture. However, this
will update only if all project paths were correct and current when you zipped
them. If, for example, you have moved the project to another location on
your computer before zipping it, and not repathed it before zipping, the
repathing on the new user’s machine will not work correctly. Before you zip
and send a project, you must make sure that all external reference paths in
the project are valid.

You have the choice of repathing:

■ A single project file

■ All files in a category

■ All files in the project

1 On the Quick Access toolbar, click Project Navigator  .

2 Change the name or the location of a project file or project folder
in the Drawing Explorer.
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The Project Navigator - Repath Project dialog displays.

3 Specify when you want the repathing to be done:

Then…If you want to…

click Repath project now.update all project files now

click Repath project later. If you
close the project before repathing,

update all project files later

the drawing files remain in a queue
for update and will display in the
Project Repath Queue dialog the
next time you open it.
The repath queue is shared by all
users working on a project and it is
saved from session to session.

4 Alternatively, click  to update all files in the project at any
time.

Refreshing the Project Navigator
Use this procedure to refresh the project view on the Project Navigator palette.

When multiple people are working on the same project simultaneously, the
situation can occur that one person’s Drawing Explorer view on the Project
Navigator palette becomes out of sync with the changes of another.
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For example, user 1 is adding/moving/deleting constructs of a project. At the
same time, user 2 is annotating sheets. User 2 is not automatically notified
that user 1 has removed some constructs from the project. If user 2 tries to
open a removed construct from the Project Navigator on their machine, an
error message results.

To prevent this situation, refresh the Project Navigator by clicking  (Refresh
Project) so that all items are updated to reflect the current project status.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the tab for which you want to refresh the file tree.

3 Click  .

NOTE It is recommended that you do this frequently during a project
session when multiple people are working on the same project.

Object Display in External References
When you reference a project drawing into another project drawing—a
construct into a view or a view into a sheet—the referenced drawing uses the
display settings of the host drawing (the drawing into which it is referenced).

In some cases, however, you might want to change the display of an external
reference for a specific view. For example, you may want to display a new
walls construct with its regular display configuration, and an existing wall
construct as a light gray background image, as displayed in a different display
configuration.

To do this, you could define in a construct a display configuration called
Existing Walls and assign a light gray color to it. When you reference the
construct into a view during the first phase of the project, you use the regular
display configuration for new walls. When you reference that construct into
a view in a later phase, you can assign the Existing Walls display configuration.
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For more information, see Specifying the Display Configurations Used in Xref
Overlays on page 837.

Workflow for Annotating a Project
The most appropriate place to add annotation is in a view drawing.

Open a view on page 461 from the Project
Navigator.

-----Open a drawing

Add project-based tags on page 530 to objects in
the view.

-----
Link construction information in
the project to objects

Adjust the annotation to collect information from
the correct space on page 530 if necessary.

-----Connect tags to spaces

Creating property set definitions on page 536
allows you to collect specific property data from
objects for a schedule on page 532.

-----
Add customized information to
objects

Edit the fields on page 3810 on the tag.-----Change information on the tag
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Creating a schedule table on page 540 collects the
construction data from objects in your drawing.

-----Add a schedule table

Create a title block  on page 541 for your project.-----Create a title block

Add fields on page 542 to the title block.-----Customize the title block

Add on page 546 the title block to sheets.-----Add the title block to your drawing

Generating Spaces
Before you start creating annotation for the building objects, you might need
to create spaces and space property information from your project. Spaces and
space schedule properties help you report information on the rooms of a
building, such as room numbers, room finishes, or physical information like
net and gross areas, perimeters, and calculation modifiers. You can easily
create spaces from walls and other building objects. For more information,
see Generating Associative Spaces on page 2940, Converting Objects, Profiles,
and Polylines to Non-Associative Spaces on page 2987, and Basic Schedules on
page 3747.

Tagging in a Project
Use this procedure to tag objects in a project drawing.
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One of the most frequent uses of annotation in a project is tagging the
individual objects. It is recommended that you tag objects in view drawings.
You can create project-specific tags that display project information or use
the default project-based schedule tags that are in the Document tool palettes.
The difference between a standard schedule tag and a project-based schedule
tag is that a project-based schedule tag recognizes the level in the project in
which the object is located. When you want this additional information
captured, use a project-based schedule tag. For more information, see Adding
Tags Using Schedule Tag Tools on page 3756.

For more information, see Project Schedule Properties on page 535, Creating a
Property Set Definition with Project Property Definitions on page 536, and
Workflow for Creating Title Blocks on page 541.

1 Open the view drawing in which to add your tags.

2 Open the tool palette that contains the tag you want to use, and
select the tool.

Predefined project tag tools are located in the Documentation
Catalog in the Content Browser. You can add these tools to any
tool palette.

3 Select the object to which to attach the tag.

NOTE You can select an object within an external reference.

4 Specify the location of the tag.

5 If prompted, enter property set data for the object in the Edit
Property Set Data dialog, and click OK.

For information about preventing the worksheet from displaying
each time you add a tag, see Turning Off the Edit Property Set
Data Worksheet on page 3757.

If property set data is not yet attached to the object, you can attach
an appropriate property set from the current drawing or the
Schedule Tables.dwg file in C:\ProgramData\Autodesk\ACA
2012\enu\Styles\<Imperial or Metric>. For more information about
property sets, see Property Set Definitions on page 3823.

6 Enter m, press ENTER, and select multiple objects to tag.

7 Alternatively, press ENTER, and add schedule tags one at a time.
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Property Set Data and Schedule Tables in Projects
Schedules are tables that list specific information about selected objects in
your building model. You can create different types of schedules by attaching
property set data to objects and object styles, and then extracting and
displaying the data in a schedule table.

For detailed information on property sets and schedule tables, see Schedules
and Display Themes on page 3739.

You can schedule each instance of each external reference individually. For
example, if you have an element that contains a typical door, you can reference
that door element five times into a construct. When you create a door schedule
in the construct, all five instances of the door element are scheduled
independently and can have unique data.

When you work in a non-project environment, you typically attach property
data to objects directly in the drawing. When you use the Drawing
Management feature, you work extensively with external references and often
tag objects in xrefs.

■ Attach property set data to objects in external references: You can, for
example, reference a construct into a view, and attach property sets in the
view to the objects from the referenced construct. Attaching property sets
to external references works for any nested levels, but it is recommended
that you attach data while in a view drawing.

■ Attach different property sets to individual instances of an external
reference within a host drawing: You can reference the same door multiple
times into the same host drawing and attach different property sets to each
instance of the door. That way, you can reference the same typical element
multiple times in a building and schedule each one differently.

■ Access property sets from the source element or construct drawing as well
as property sets from views or sheets: You can create a property set with
properties in the element drawing and another property set in the sheet
and schedule both in the sheet.

Example: Numbering a Door in a Project
The following example shows how you can define property data that combines
object properties with project properties. The example uses space information
to show how you could use project and formula property definitions. The
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following diagram shows how a space number can be built up from
information on the space and in the project.

DescriptionProperty Defini-
tion

Property Set
Definition

Value

A project property definition, get-
ting the Level ID for the object for
the current project

LevelNumberSpace2

A manual auto-incrementing prop-
erty definition

BaseNumberSpace01

A formula property definition, with
the formula [LevelNum-
ber][BaseNumber]

RoomNumberSpace201

Creating Property Sets and Schedule Tables in a Project
Work with property set data and schedules as follows:

1 Create property set definitions and schedule table styles that contain the
necessary project information.

For more information, see Project Schedule Properties on page 535 and
Creating a Property Set Definition with Project Property Definitions on
page 536.

You can create property set definitions and schedule table styles at
different locations in the project environment:

■ In the AutoCAD Architecture Schedule Tables.dwg file

■ In your own, user-defined property set definitions drawing

■ In the drawing template

■ In the drawing

NOTE To attach a property set definition to an external reference, import it
into the object drawing. This is done automatically when you drag a tag from
DesignCenter into the drawing.
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NOTE The drawing that contains your property set definitions does not need
to be a part of your project. You can import and use property set definitions
from any drawing file accessible to you.

There are a number of guidelines that can help you decide in which
property set definition to put property definitions:

■ Non-manual property definitions—that is, Automatic, Formula,
Classification, Material, and Project Property Definitions—can in
many cases be defined in property set definitions that are applied to
styles. If a property set definition is to be applied to objects that do
not have styles, it does not matter where the property definition is
defined.

■ Manual property definitions containing data that does not change
for each instance of a style should be defined in property set
definitions that are applied to styles.

■ Manual property definitions containing data that does change for
each instance of a style should be defined in property set definitions
that are applied to objects.

2 Attach the property set definition to an object or style in a project
drawing.

You can attach a property set to an object at various stages of the project.
You can attach property set data to an external reference and also override
existing property sets from the external reference in the host drawing.
For example, you can attach a property set definition to a door in an
element and then override that property set with an extended one when
referencing that door into a construct. You could also create an element
without property sets, reference it into a construct and a view, and attach
a property set there.

NOTE Overriding property set definitions works only for those property sets
attached to objects. Property sets attached to styles cannot be overridden
when referenced into another drawing.

For more information, see Attaching Property Set Data to Objects on page
3811 and Attaching Property Sets to Objects from External References on
page 537.
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The following guidelines help you to select the correct location for
attaching property sets to objects within a project:

■ Property set definitions that are applied to styles must be attached to
styles in the drawing containing the style.

■ Property set definitions that are applied to objects and that contain
data that does not change for each instance of the object that is
externally referenced should be attached to the object itself in the
externally referenced drawing.

■ Property Set Definitions that are applied to objects and that contain
data that does change for each instance of the object that is externally
referenced should be overridden at the external reference, typically
at the project construct level.

These guidelines are recommendations. The location of property data
also depends on the processes and workflow you have established in your
work environment.

3 Open the project drawing in which to place the schedule table.

4 If necessary, attach property sets to objects to be scheduled from external
references, or override property sets for those objects on the external
references that contain them.

For more information, see Attaching Property Sets to Objects from
External References on page 537.

5 Create schedule tables in the drawing.

For more information, see Creating a Schedule Table in a Project on page
540.

Project Schedule Properties
A project property definition can be defined in a property set definition so
that an object has access to information about the project in which it is
currently located.

These project properties are available:

DescriptionProperty

Name of the projectName

Description of the projectDescription
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DescriptionProperty

Number of the projectNumber

File location of the project on the hard disk
or network drive

Location

Total number of levels in your projectNumber of Levels

ID of the level the object is onLevel ID

Elevation of the level the object is onLevel Elevation

Height of the level the object is onLevel Height

Total number of divisions in your projectNumber of Divisions

ID of the division the object is inDivision ID

Name of the sheet drawing that contains
the object

Sheet Name

Description of the sheet drawing that con-
tains the object

Sheet Description

Properties for all project details created in
Adding Detailed Information to Project
Properties on page 337.

Details of the project: Project Data, Pro-
posed Improvements, Site Legal Descrip-
tion, Owner’s Data, Site Information
Sources, Public Services, Financial Data,
and Method of Handling

For general information on creating property set definitions, see Creating a
Property Set Definition on page 3841.

Creating a Property Set Definition with Project Property
Definitions

Use this procedure to create a property set definition containing project
property definitions.

For a list of available project properties, see Project Schedule Properties on
page 535.
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For general information on creating property set definitions, see Creating a
Property Set Definition on page 3841.

NOTE A property set definition can contain different types of property definitions
such as automatic properties, project properties, formulas, and classifications.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and click Property Set
Definitions.

3 Right-click, and click New.

4 Enter a name for the new property set definition press ENTER.

5 Click the Applies to tab, and define if the property set definition
should be applied to objects or to object styles.

6 Select the entities or styles to which the property set definition
should apply.

Typically, you would attach project information to objects such
as spaces, walls, doors, windows, and curtain walls.

7 Click the Definition tab.

8 Click  .

The general project properties are listed. If you have created project
details, as described in Project Schedule Properties on page 535,
they are listed too and can be selected for the property set
definition.

9 Select a project property.

10 Enter a name, and click OK.

11 Repeat steps 8-10 for each project property you want to add to
the property set definition.

12 If necessary, add other properties to the definition.

13 Click OK twice.

Attaching Property Sets to Objects from External References
Use this procedure to attach property sets to objects in external references.

This topic explains the following procedures:

■ Attaching property sets to objects from external references.
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■ Attaching different property sets to different instances of the same external
reference. For example, you can reference the same floor plans onto
multiple levels and schedule each level differently.

1 Reference a project drawing, such as an element or a construct,
into another project drawing, such as a view or a plotting sheet.

2 Open the Scheduling tool palette, and select the Browse Property
Data tool.

3 Under Property Set Definitions, select the property set definition
from the host drawing with which you want to work.

4 Expand the desired external reference in the tree, until you can
see the desired object.

5 Attach property set data to objects:

Then…If you want to…

If no property set definition with
the same name has been attached

attach a property set from the host
drawing to an object in an external
reference to the object, the row of boxes im-

mediately next to it is empty. Select
the box to check it. A property set
is attached directly to the object. It
is displayed on the right side, and
can be edited.

If a property set with the same
name has been attached at a lower

override a property set from an ex-
ternal reference with a property set
from the host drawing level to the external reference, a

read-only box is displayed at the
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Then…If you want to…

appropriate level. Select the box at
that level next to the object. The
property set is attached to the ex-
ternal reference at the selected level
as an override for the object. If a
property set definition with the
same name as that selected above
exists in the external reference, it
uses it, otherwise the property set
definition in the host drawing is
copied to the external reference.
The property set is displayed on the
right and is editable.

Expand the desired instance of the
external reference in the tree. Select

attach different property sets to
different instances of an external
reference the box next to the object instance.

To attach a different property set
to another instance, select a differ-
ent property set definition, expand
a different instance of the external
reference, and attach the property
set to it.

clear the box at the appropriate
level next to the desired object.

remove a property set from the host
drawing for an external reference

6 If necessary, decrease the number of objects displayed in the tree:

Then…If you want to…

select the appropriate object under
Object Filter.

show only one type of object in the
tree

clear Hide Objects without Property
Set Definitions.

show only those objects that
already have the selected property
set attached on some level

7 If you are not sure whether you selected the correct object from
the external reference, click Highlight to mark the object in the
drawing area.

8 To display the correct object in the drawing area, click Zoom to.
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9 If necessary, edit the property set data on the right.

10 To display properties with the correct data format style from the
property set definition, select Format Data.

11 Click OK.

Creating a Schedule Table in a Project
Use this procedure to create a schedule table that contains property data from
an external drawing such as a project drawing.

Schedule tables can contain information from external references and block
references, which typically must exist in the same drawing as the schedule
table. Schedule tables now optionally specify an external drawing, which is
scheduled as if it were an external reference in the same drawing as the table.
The advantage to this is that the graphics of the external drawing do not need
to be generated in order to fill out the data in the table.

For general information on adding schedule tables, see Schedules on page 3739.

TIP To ensure that the Properties palette is displayed before you select a tool,
right-click in the drawing area, and click Properties.

1 Open the sheet to contain the schedule table.

2 Open the tool palette that you want to use, and select a Schedule
Table tool.

If necessary, scroll to display the tool that you want to use.

3 On the Properties palette, expand Basic, and expand General.

4 Select a style.

5 Instead of selecting objects in the drawing, press ENTER.

6 Specify the insertion point of the schedule table.

7 Specify the size of the schedule table.

A schedule table with no rows is inserted into the drawing.

8 Select the empty table, right-click, and click Properties.

9 On the Properties palette, expand Advanced, and expand External
Source.

10 For Schedule External Drawing, select Yes.

The External Drawing settings are displayed, with a list containing
all drawings in the Views directory of the current project. Each
drawing should correspond to a view defined in the project. If no
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project is active, the list contains all drawings in the last directory
browsed.

11 Select the view you want to schedule.

NOTE The setting for External Drawing Name is displayed only if you
have selected Yes for Schedule External Drawing.

If the desired external view drawing is not displayed in the list,
select Browse and find it.

Workflow for Creating Title Blocks
You can create title blocks that display information specific to the sheet set
or the project. When the information changes, it is updated in the title block.
A title block can be a multi-view block or a block with fields that include
project information from project attributes.

Open a sheet on page 495 from the Project
Navigator.

-----Open a sheet

Create a title block  on page 545 for your project.-----Create a title block

Add fields on page 542 to the title block.-----Customize the title block

Create a block on page 544 from the fields.-----Create a block
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Create a multi-view block definition on page 2895
from the block.

-----Create a multi-view block

Insert the multi-view block on page 2905 as a title
block  on page 546 to the sheet.

-----
Add the multi-view block to the
sheet

A title block would typically be placed in a sheet template or a sheet drawing.
If it is in a sheet template, you can use it for all sheet drawings based on that
template.

Adding Project Attributes
Use this procedure to create project attributes for a title block in the drawing.

1 Click Insert tab ➤ Attributes panel ➤ Define Attributes  .

2 In the Attribute Definition dialog, enter a name for Tag.
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3 Click  for Default.

The Field dialog is displayed.

4 In the Field dialog, select the field category you want to display
in the title block.

For example, if you want to display details of the project, select
AEC Project for Field category, and then select Project Details for
Field names.

5 Select the text format for Format, and click OK.

6 Click OK to add the attribute.

For more information, see Attach Data to Blocks (Block Attributes)
in AutoCAD Help.

7 Repeat steps 1–5 to add additional attributes to the project title
block.

8 Complete the attribute block with lines and borders.

The result is a number of attributes and graphic elements in your drawing.
Your attribute block might look like this:
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Creating a Project Block
Use this procedure to create a block that contains the project attributes you
want to display in a project title block. For information about adding attributes,
see Adding Project Attributes on page 542.

1 Click Insert tab ➤ Block panel ➤ Create Block  .

2 In the Block Definition dialog, enter a name for the block.

3 Click Select Objects, and select the attributes and additional
graphics to include in the title block.

4 For Block unit, select Unitless.

5 Continue creating the block as described in Create Blocks Within
a Drawing in AutoCAD Help.
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Creating a Multi-View Block for a Title Block
Use this procedure to create a multi-view block that contains the blocks you
want to display in the project title block. For information about creating
blocks, see Create Blocks Within a Drawing in AutoCAD Help.

For detailed information about multi-view blocks, see Creating Multi-View
Block Definitions on page 2892.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects.

3 Right-click Multi-View Block Definitions, and click New.

4 Enter a name for the new multi-view block definition, and press
ENTER.

5 Select the new multi-view block definition, right-click, and select
Edit.

6 Click the View Blocks tab.

7 Select a display representation for the title block.

Typically, you would display a title block in plan views and
reflected views.

8 Click Add.

9 Select the block you defined in Creating a Project Block on page
544, and click OK.

10 Select the view directions for the block.

11 Repeat steps 6–10 for each display representation in which you
want the title block to display.

12 Click OK twice.

Creating a Tool for a Title Block
Use this procedure to create a tool for inserting the title block in a drawing.
It is assumed you have already defined the multi-view block, as described
under Creating a Multi-View Block for a Title Block on page 545.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Multi-View Block
Definitions.

3 Locate the multi-view block definition you want to make into a
tool, and drag it to the tool palette.
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4 Click OK to close the Style Manager.

Inserting the Title Block in a Sheet
Use this procedure to insert a title block into a drawing using a tool you have
created. See Creating a Tool for a Title Block on page 545.

Viewing title block attributes and data

1 On the Quick Access toolbar, click Project Navigator  .

2 On the Sheets tab, open the sheet on which you want to place
the title block.

3 Open the tool palette that contains the title block tool you want
to use.

4 Specify the insertion point for the title block.

5 If necessary, specify the scale and rotation of the title block.

6 Press ENTER.
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Dimensioning a Project
Use this procedure to dimension objects in a project drawing.

In the documentation phase of a project, you create detailed dimensions of
objects. AEC dimensions can be attached to objects in a drawing or to objects
in an external reference. You can dimension objects in source drawings like
elements or constructs, or you can dimension them in higher-level drawings
like views or sheets.

For detailed information, see AEC Dimensions on page 3387.

1 Open the project drawing in which to add a dimension.

This may not be the drawing in which the object to be
dimensioned is located. It may be a drawing that references the
object. For more information, see Associative Dimensions in
External References on page 3401.

2 Open the tool palette that you want to use, and select an AEC
dimension tool.

If necessary, scroll to display the tool that you want to use.

3 On the Properties palette, expand Basic, and expand General.

4 Select a style.

5 In the drawing area, select the objects to dimension.

6 Press ENTER.

7 Specify the position of the new dimension:

Then…If you want to…

drag the cursor in the desired direc-
tion, and click in the drawing at the
desired insertion point.

NOTE If your selection set con-
tains objects with different dir-
ections, the direction of the first
selected object defines the par-
allel and perpendicular direc-
tions.

insert the dimension group parallel
to or perpendicular to the dimen-
sioned object

enter r (Rotation) on the command
line, and press ENTER. Then, enter

insert the dimension group at a
specified rotation

a rotation angle either by clicking
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Then…If you want to…

in the drawing or by entering one
on the command line. Press ENTER,
and click in the drawing at the de-
sired insertion point.

NOTE If your selection set con-
tains objects with different dir-
ections, the rotation is calcu-
lated with reference to the first
selected object.

enter a (Align) on the command
line, and press ENTER. Then, select

insert the dimension group aligned
parallel to an object other than the
dimensioned object the object to which to align the di-

mension group. Press ENTER, and
click in the drawing at the desired
insertion point.

NOTE The direction of the di-
mension group is dependent
on the rotation of the chosen
object. The drawing direction
of the object has no influence
on the dimension group direc-
tion.

Working with Cut Planes in a Project
You can set a global cut plane for each display configuration in a drawing,
and individual cut planes for objects like walls, curtain walls, and wall
openings. For more information, see Viewing Display Configurations on page
816.

The Global Cut Plane

You can set a cut plane for a display configuration in a drawing. All objects
included in that display configuration are cut at the height defined in the
display configuration, unless they have an object-specific cut plane override.
Each display configuration can have a different cut plane. For more
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information, see Object-Specific Cut Planes on page 559 and Global Cut Planes
on page 550.

The Object-Specific Cut Plane

A number of objects can override the cut plane settings in the display
configuration and use their own cut planes: for example, walls, curtain walls,
and stairs. For more information, see Object-Specific Cut Planes on page 559.

Cut Plane Display Range

A cut plane is set to a specific height, for example, 1.4 meters. Objects above
or below that level are by default not displayed in a plan view. You can,
however, define a display range above and below the cut plane. Object
components inside that range are displayed too. This would be useful if you
want to display a window that lies above or below the cut plane but that
should be included in the display.

Viewing plan view window cut plane options

You also use a display range to define clipped views, such as the model view
of a second floor. In that case, the display range defines which levels to display
and which levels to hide.

Clipped 3D view of second floor

For more information, see Creating a Clipped Model View on page 556.
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Cut Planes and Levels

Levels are represented separately by one or more files and are assembled in a
view or sheet to represent the entire building.

You set the cut plane individually for each level of a building. You create a
drawing file—a construct or a view—that represents the level, and assign a
cut plane to a display configuration within the drawing.

The following images illustrate a curtain wall that spans 3 levels. The images
on the left indicate the cut plane for the associated level drawing. The plans
to the right show how the curtain wall would be displayed in plan view at
each level. Notice the different appearance of the doors and mullions on the
various floor plans.

Specifying 3 cut plane levels

Global Cut Planes
The global cut plane cuts all objects in a drawing at the same height. It is
defined separately for each of the display configurations that can be applied
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to a drawing, so you can have, for example, one cut plane height for a regular
plan view and another cut plane height for a Reflected view.

The global cut plane is used on all objects that do not have an object-specific
cut plane override. For more information, see Object-Specific Cut Planes on
page 559.

Global Cut Plane Display Range
When you set a cut plane for a display configuration, you also set a display
range above and below the cut plane. This is the range in which objects, even
when they do not intersect the cut plane, are displayed. For example, if you
set the cut plane to 1.4 meters and define the visible range above the cut plane
at 2 meters and the visible range below the cut plane at 1 meter, then your
objects are cut at 1.4 meters. Objects that lie between 1.4 meters and 2 meters
as well as objects that lie between 1.4 meters and 1 meter are also displayed,
but with different display for above and below the cut plane. Objects that lie
outside the range—for example, a window that is inserted at 0.8 meter—are
not displayed at all.

NOTE The values for the display range are calculated relative to the WCS, not
relative to the global cut plane height.

Plan view of window cut planes

You also use a display range to define clipped views, such as the model view
of a second floor. In that case, the display range defines which levels to display
and which levels to hide.
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Clipped 3D view of second level

For more information, see Creating a Clipped Model View on page 556.

Display Properties for the Cut Plane Display Range
Many objects have display components that you can set for display above and
below the cut plane. For example, an object below the cut plane can be
displayed with dashed lines and a different color. If you want to work with
the display range, set the appropriate display components accordingly.

NOTE The Above and Below Cut Plane display components display in some
plan-type display representations, such as Plan, Plan High Detail, Plan Low Detail,
Plan Screened, Reflected, and Reflected Screened, as well as in user-defined display
representations that are based on any of these display representations.

The following objects have display components for above and below the cut
plane:

Components that can be set for
above and below cut plane

Object

Curtain Wall/Curtain Wall Unit bodyCurtain Walls/Curtain Wall Units

Frame/Panel/Stop/Swing/ThresholdDoors

Door/Window Assembly bodyDoor/Window Assemblies

Mass Element bodyMass Elements

Guard Rail/Hand Rail/Bottom Rail/PostRailings

Slab Body/Slab OutlineSlabs/Roof Slabs
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Components that can be set for
above and below cut plane

Object

Stringer/Stringer Facets/Riser/Riser Num-
bers/ Nosing/Path Outline

Stairs

Beam/Brace/Column bodyStructural Members

Wall BodyWalls

Glass/Frame/Sash/SillWindows

For more information on setting display properties for individual objects, see
the appropriate procedures for the objects.

Setting the Global Cut Plane and the Display Range
Use this procedure to set the cut plane and the visible display range for a
display configuration. For information on the display system, see Display
Configurations on page 810.

NOTE The values you enter for the Above and Below ranges are the absolute
height values calculated from the WCS origin. They are not relative to the cut
plane. For example, if you have set the global cut plane to 1.4 meters, set the
visible range above the cut plane to a value higher than 1.4 meters; otherwise,
you get an invalid display range.

1 Access the global cut plane controls using one of the following
methods.

Then…If you want to…

click the value for Cut Plane on the
drawing window status bar.

NOTE Specify a cut plane that
falls within the display range,
or change the value of the dis-
play range to include the cut
plane height.

define the global cut plane height
for the current display configuration
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Then…If you want to…

click Manage tab ➤ Style & Display

panel ➤ Display Manager

define the global cut plane height
for any display configuration

.Then, select a display configuration
in the left pane, and click the Cut
Plane tab.

2 Define the cut plane and the visible ranges above and below the
cut plane:

Then…If you want to…

enter the appropriate value for Cut
Height.

define the global cut plane height
for the display configuration

enter the appropriate value for Dis-
play Above Range.

NOTE The value you enter here
is calculated from the WCS ori-
gin and is not relative to the cut
height.

define the visible range above the
cut plane

enter the appropriate value for Dis-
play Below Range.

NOTE The value you enter here
is calculated from the WCS ori-
gin, and is not relative to the
cut height.

define the visible range below the
cut plane

You must specify a cut plane that falls within the display range,
or adjust the value of the display range to include the cut plane
height.

3 Click OK.

Displaying the Cut Plane for a Specific Level
Use this procedure to display the cut plane for a specific level in a project.
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Usually, you want to display the cut plane of the current level. However, in
some cases, you might want to display a different level. For example, you may
want to see how a curtain wall that spans several levels in a project will display
at each level.

Specifying different cut planes results

1 On the Project Navigator, open a construct with a curtain wall.

2 If necessary, switch to a plan view.

3 Access the cut plane controls using one of the following methods.

Then…If you want to…

click the value for Cut Plane on the
drawing window status bar.

define the cut plane height for the
current display configuration

click Manage tab ➤ Style & Display

panel ➤ Display Manager  .

define the cut plane height for any
display configuration

Then, select a display configuration
in the left pane, and click the Cut
Plane tab.

4 Click Calculate.

This button is only available when the drawing is part of a project.
It uses the level information you entered in Creating a New Level
on page 380.

5 In the Cut Plane Worksheet, select the level whose plan view you
want to display in the current drawing.
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For example, if you have created a view of the first floor but want
to display the plan view of the second floor, select 2.

6 Select the cut plane height of the selected level.

For example, to display the second level at a cut height of 1.4
meters, enter 1.4 here.

7 Click OK.

The display range is adapted to display the height of the selected
level.

For example, perhaps you have a 3-story building with a floor
height of 2.75 meters for each floor. You have created a view of
the first floor but want to display the second floor in it at a cut
height of 1.4 meters. In the Cut Plane dialog, you enter 2 for level,
and 1.4 for Cut Plane Height Above Level. When you click OK,
the display range of the view now spans the second level. The
following values are entered into the Cut Plane Tab of the display
configuration:

CommentValueField Name

This is where the
second level starts.

2.75 metersDisplay Below Range

To display a cut height
of 1.4 meters, add 1.4

4.15 meters (2.75
meters + 1.4 meters)

Cut Height

meters to the start of
the second level at
2.75 meters.

The second level starts
at 2.75 meters, and

5.5 metersDisplay Above Range

has a base height of
2.75 meters. This res-
ults in an overall
height of 5.5 meters.

8 Click OK.

Creating a Clipped Model View
Use this procedure to create a clipped Model view of a building level.
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If a level is crossed by a spanning element like a curtain wall or an elevator
shaft, you want to display only those parts of the spanning element that
actually lie on that level. You can create a clipped Model view that displays
only those objects and object ranges within the user-defined display range.

Clipped Model view

Some display settings for a clipped Model view are influenced by the materials
assigned to the clipped objects:

■ Display of object ranges outside the display range: You can display the
parts of a spanning element that are outside the display range of the level.
In some cases, you might want to display those parts of the object in a
lighter color and thinner lineweight to imply the complete shape of the
object.

3D view of spanning element in and out of display range
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How those parts are displayed is set in the Sectioned Body component of
the object’s materials. For information on setting the display of the
Sectioned Body component, see Sectioned Body and Sectioned Boundary
on page 902 and Defining the Layer, Color and Linetype of a Material
Definition on page 920.

■ Display of a section hatch and a section boundary where the display range
cuts the spanning object: You might choose such a display to highlight
the cut line.
How the section hatch and boundary are displayed is defined in the Section
Hatch component of the materials for the object. For information on
setting the display of these components, see Section Hatch Material
Component on page 902, Sectioned Body and Sectioned Boundary on page
902, and Defining the Layer, Color and Linetype of a Material Definition
on page 920.

1 Create a view containing the desired level.

For more information, see Creating a New View Drawing on page
453.

2 If necessary, switch to a Model view: for example, SW Isometric.

3 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

4 Expand Configurations.

5 Select the current display configuration.

It is displayed in bold text.

6 Click the Cut Plane tab.

7 Set the Above and Below display ranges to be identical to the level
height.

For example, if your level is 2.75 meters high, set Display Below
Range to 0.0 meters and Display Above Range to 2.75 meters.

NOTE For a clipped model view, it is not important how you set the
cut plane, as the cut plane is displayed only in plan views. Either keep
the original value, or enter any value within the display range: for
example, 1.4 meters.

8 Expand Sets.

9 Select the current display set (displayed in bold text).

10 Click the Display Options tab.
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11 Define the display of the clipped model view:

Then…If you want to…

select Section AEC Objects by Dis-
play Range defined in Display Con-
figuration.

display the objects in the display
range defined in step 7 with their
regular display settings, and the
objects outside of the display range
as Sectioned Body

select Show Materials where Display
Range Intersects AEC Objects.

show a section hatch and a section
boundary where spanning objects
are cut by the display range

select Hide Sectioned Body Com-
ponent.

hide all parts of spanning objects
outside of the display range

select Hide Surface Hatching.suppress the surface hatch of ob-
jects within the display range

12 Click OK.

Object-Specific Cut Planes
Many objects in AutoCAD Architecture have individual settings for cut planes
that can override the cut plane setting of the display configuration.
Object-specific cut planes are useful when you have objects of different heights
in your plan view. This happens frequently when you are working with a
window high in a wall.

NOTE The cut plane you specify must fall within the display range, or you can
adjust the value of the display range to include the cut plane height.

An object-specific cut plane takes precedence over the global cut plane in the
display configuration. For more information on the global cut plane, see
Global Cut Planes on page 550.

Example: Overriding the Cut Plane for a Wall

The object-specific cut plane is a part of the display properties of an object.
You can set it for an individual object, an object style, or as the system default.

For detailed information on display properties, see Display Representations
on page 803 and Creating a Display Representation for an Object on page 828.
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TIP If you want to create a clipped model view, as described in Creating a Clipped
Model View on page 556, or want to display the cut plane of a different level, as
described in Displaying the Cut Plane for a Specific Level on page 554, make sure
to turn off the object specific-cut plane of the included objects. The object-specific
cut plane overrides the global cut plane, and so you might get unexpected display
results.

The following is an example of how to set a cut plane for a wall style. The
detailed steps for other objects may vary slightly. For more information, see
the individual object chapters.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and then expand Wall Styles.

3 Select the wall style for which you want to set an individual cut
plane, and click the Display Properties tab.

4 Select a Plan or Reflected display representation.

5 Click the Edit button.

6 Click the Cut Plane tab.

7 Select Override Display Configuration Cut Plane.

8 For Cut Plane Height, enter the desired cut plane.

9 Click OK 3 times.

Example: Using the Cut Plane of the Anchoring Object

Whether an anchored object uses the cut plane of its host object or the cut
plane of the display configuration is set in the display properties of the object.
You can define this for an individual object, an object style, or as the system
default.

For detailed information about display properties, see Display Representations
on page 803 and Creating a Display Representation for an Object on page 828.

The following example demonstrates how to set an anchored window to use
the cut plane of the wall to which it is anchored. The detailed steps for other
objects may vary slightly. For more information, see the individual object
chapters.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and then expand Window Styles.

3 Select the window style for which you want to set the cut plane
when anchored, and click the Display Properties tab.

4 Select a Plan or Reflected display representation.
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5 Click the Edit button.

6 Click the Other tab.

7 Select Respect Cut Plane of Container Object When Anchored.

NOTE You should use this setting as the default. Even when the cut
plane of the anchoring object does not differ from the global cut
plane, this setting ensures a correct display of the anchored object
in plan views.

8 Click OK 3 times.

Object-Specific Cut Plane Overrides
The following objects can have an object-specific cut plane:

■ Curtain Walls

■ Curtain Wall Units

■ Door/Window Assembly

■ Mass Elements

■ Roof Slabs

■ Slabs

■ Stairs

■ Walls

Cut Planes from the Anchoring Object
Objects like windows or doors usually are anchored into walls, curtain walls,
and window assemblies. Normally, you want those anchored objects to have
the same cut plane height as the object into which they are anchored. However,
because the cut plane of the anchoring object can be set by either the display
configuration or by the object itself, specify in the anchored object whether
it should use the cut plane of the display configuration or of the object to
which it is anchored.
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The following objects can derive their own cut plane from the cut plane of
the object to which they are anchored:

■ Curtain Wall Units

■ Doors

■ Door/Window Assemblies

■ Windows

Manual Cut Planes
You can define any number of manual cut planes for a wall or a curtain wall.
Manual cut planes are only displayed when they are inside the display range.

For information on setting the manual cut plane, see:

■ Specifying the Cut Plane Display of a Curtain Wall on page 1553

■ Specifying the Cut Plane Display of a Wall Style on page 1319

■ Specifying the Cut Plane Display of a Curtain Wall on page 1553

■ Specifying the Cut Plane Display of a Curtain Wall Unit on page 1680

■ Specifying the Cut Plane Display of a Door and Window Assembly on page
1818

Drawing Management Commands
You can run certain Drawing Management commands from the command
line. These commands are also available as toolbar buttons or context menu
commands. In some cases, for example when creating LISP routines, you might
want to initiate them via the command line.

Command Line: Opening the Project Browser
Use this procedure to open the Project Browser from the command line.

■ On the command line, enter AecProjectBrowser.
The Project Browser is displayed.
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NOTE Alternatively, you can click the  button on the Projects tab of the Project
Navigator.

Command Line: Opening the Project Navigator
Use this procedure to open the Project Navigator palette from the command
line.

■ On the command line, enter AecProjectNavigator.
The Project Navigator palette is displayed.

NOTE Alternatively, you can click  on the Quick Access toolbar.

Command Line: Refreshing the Project
Use this procedure to refresh the project on the Project Navigator palette from
the command line.

■ On the command line, enter AecRefreshProject.
The Project Navigator Palette is displayed, and all tabs are refreshed to
display the current project state.

NOTE Alternatively, you can click the  button on each of the Project Navigator
tabs.

Command Line: Regenerating Views
Use this procedure to regenerate all views in the current project from the
command line. When you regenerate a view, you reload all of the external
references used to generate the view.

■ On the command line, enter AecRegenerateProjectViews.
All views in the current project are regenerated.

NOTE Alternatively, you can click the  button on the Views tab of the Project
Navigator.
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Command Line: Selecting a New Project Environment
Use this procedure to select a new project environment from the command
line.

NOTE You can select only existing projects from the command line. To create a
new project environment, go to the Project Browser and create a new project as
described in Setting a Project Current on page 327.

1 On the command line, enter AecSetCurrentProject, and press
ENTER.

2 Enter the project you want to set current on the command line.

NOTE Alternatively, you can click  on the Projects tab of the Project Navigator,
and set the new project current in the Project Browser.

Command Line: Closing the Project Navigator
Use this procedure to close the Project Navigator from the command line.

■ On the command line, enter AecCloseProjectNavigator.
The Project Navigator Palette is closed.

Frequently Asked Questions about Drawing
Management

This topic contains questions and answers that can help you to achieve the
results you need when working with Drawing Management.

What do I have to consider when working with the XML files in the project?

The project data of a building model is contained in the APJ file, which
contains information about the overall project, and in the XML files
accompanying each DWG file. Both file types are well-formed XML. In most
cases, you should not try to edit these files manually in an XML editor, as you
might inadvertently corrupt the file. To make changes to your project, use
the Project Browser and Project Navigator commands instead.

NOTE Do not delete any XML files generated by the Drawing Management feature.
They are vital to the project.
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I have added a lot of project details in the Project Browser. Can I export
these to another application?

Yes. The project details you enter in the Project Browser are stored in the
project’s APJ file, which is a well-formed XML file. If you want to export these
details, create a copy of the APJ file, and export it to any XML application or
database. If you want to use the project detail categories and items in another
project, use the existing APJ file as the template for the new project.

What should I do if my APJ file has been accidentally deleted or corrupted?

Deleting or corrupting the project’s APJ files has no influence on the DWG
files and XML files contained in the project. In the Project Browser, the project
will not display anymore. To recreate the project with a new APJ file, go to
the Project Browser, and create a new project of the same name in the same
folder location as the previous APJ file. For instructions, see Creating a New
Project on page 328. Then, go to the Project Navigator, and drag-and-drop the
Elements, Constructs, Views, and Sheets folders of the project from Windows
Explorer into the corresponding tabs of the Project Navigator. This re-inserts
the files into the project.

What should I do if an XML file has been accidentally deleted or corrupted?

Each DWG file within a project has an accompanying XML file that contains
the project-specific information. If the accompanying XML file is accidentally
deleted or corrupted, the DWG file is no longer recognized as part of the
project and will not display in the Drawing Explorer. To insert it into the
project again, convert the DWG file into a project file. For instructions, see
Converting a Drawing to a Construct on page 408 and Converting a Drawing
to an Element on page 431.

Can I limit other users access to the project files?

You can limit other users ability to edit and delete project files by using the
network permissions. You can limit the Delete rights for the entire project, so
that users are not able to delete files from the project or move files around
within the project. You might also consider just limiting the delete rights to
the top project folder (containing the APJ file) and allow deleting in the
subfolders.

How much additional file space will the project files need?

Working with a project does not require large additional amounts of file space
on your computer or network folder. The XML files are less than 10K, most
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of them around 1-3K. The APJ file is slightly bigger, but in most cases will not
exceed 10K either.

How can I best archive a project?

With AutoCAD Architecture, you can electronically transmit and archive a
project. For more information, see Electronically Transmitting a Project on
page 352.

Alternatively, you can copy and paste a project in Windows Explorer. All of
the project files are contained in a folder structure within the top project
folder, which also contains the APJ file. Just take the top project folder and
move or copy it to the desired archive location on a folder, a CD, or streamer
tape.

How would I best place Addenda, Alternates, or As-Builts within the project?

How you organize these items would largely depend on your internal processes
and workflow. One solution would be to draw the alternates as regular
constructs and then create special views for them.

If you want to present completely different plans/elevations to represent
Alternates, you could use divisions to represent them; when generating the
view, you just need to include the appropriate division into the view.

In some cases you might also consider copying the project and putting the
Alternates into the copied project. For instructions, see Creating a New Project
Based on a Template (Copying a Project) on page 328. If you copy a project,
however, you have 2 different file sets to maintain; the copied project does
not retain any links to the original one.

How do I define the physical locations of constructs and elements in the
building?

The location of the objects in a project file when referenced into another
project file depends on the location in the original file. By default, project
files are referenced at 0,0,0. When generating a view, the lowest level included
in this view is placed at a Z axis of 0.

When referencing a project file into another project file, are basepoints
other than 0,0,0 respected?

Yes. When referencing elements into constructs, and constructs into views,
they are inserted at 0,0,0. A base point (INSBASE) other than 0,0,0 within the
constructs and elements is respected.
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Can I override the basepoints of project files when referencing them in other
project files?

No. This is standard AutoCAD behavior.

Can I lock constructs and elements in their position to avoid accidentally
moving them?

Yes. If you want to lock an element or construct within the building model,
lock the layer the element or construct has been inserted on.

Is there an easy way to copy an element to multiple constructs at once?

Yes. Select the element in the Drawing Explorer, right-click, and click Attach
Element to Constructs. For detailed instructions, see Referencing an Element
into Multiple Constructs on page 415.

Is there an easy way to copy a construct to multiple levels at once?

Yes. There are 2 methods of achieving this, which are described in Copying
a Level with Assigned Constructs on page 382 and Copying Constructs to Levels
on page 407.

How do I move constructs from one level to another?

To move a construct to a different level, change its level assignment. Select
the construct, right-click, and click Properties in the context menu. Then,
choose a different level in the Assignments matrix. For detailed instructions,
see Changing the Properties of a Construct on page 419.

Will wall cleanups work across walls from different divisions?

Yes. Walls do cleanup across external references, such as divisions. You just
need to make sure that the wall baselines are at the same elevation.

Will AEC dimensions work with objects from external references?

Yes. AEC dimensions are capable of dimensioning objects from external
references, even when they are nested. For detailed information, see
Dimensioning a Project on page 547.

Will schedule tags and property sets work with objects from external
references?

Yes. Schedule tags and property set definitions are capable of annotating
objects from external references, even when they are nested. For detailed
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information, see Tagging in a Project on page 530 and Property Set Data and
Schedule Tables in Projects on page 532.

Is the Project Navigator MDI compliant?

No. During a session of AutoCAD Architecture, only one project can be opened
at a time. You can open files from different projects with the regular Open
file command in the Application menu. You do not, however, see the
associated project on the Project Navigator palette.

Appendix 1: Template Projects
A template project is an AutoCAD Architecture project that is used as the
starting point for a new project. The files and folder structure of the existing
project are used for the new project and are copied to the location you specify.
You can access template projects when creating a new project in Project
Browser.

Once chosen, the template project is copied to the new location (selected in
the Project Browser window before clicking the New Project icon) and then
automatically repathed. A template project provides the equivalent benefits
that DWT files provide for individual drawing files. Template projects help to
speed project setup and ensure office standards and consistency.

Using the Commercial Template Project as template for a new project

1 On the Quick Access toolbar, click Project Browser  .

2 In the Project Browser window, navigate to the location where

you want to create the new project, and click  .

3 Enter the project name and number, and then click Create from
template project.

4 Navigate to the following project: C:\ProgramData\Autodesk\ACA
2012\enu\Template\Commercial Template Project (Imperial)\Commercial
Template Project (Imperial).apj. This includes United States-based
constructs.

Alternatively, you can select the metric version.

5 Click OK and wait until the project has finished repathing.
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Levels and Divisions
The Commercial Template Project includes 5 basic levels to get you started.
For detailed information, see Creating a New Level on page 380.

If you are using divisions to divide the project laterally, set those up right
away.

Project File Naming
Below is a summary of potential file names based on the recommendations
of the US National CAD Standard as adapted to the Project Navigator and
suggestions made here. For complete information and to purchase a copy of
NCS visit: http://www.nationalcadstandard.org/.

An NCS Model file name is composed of a Discipline, plus a drawing type
Code, followed by an enumeration (which typically corresponds to the floor
number), though not always. (Elevations, for instance, would just be numbered
sequentially in any logical order.)

For example:

■ A-FP01 = Architectural First Floor Plan

■ A-EL01 = Architectural Elevations (first group of elevations; there could be
others named 02, 03, etc.)
The hyphen is used between discipline and code, but not between code
and number.
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NCS Recommends the following codes for Model files. Use these designations
for View file names:

■ FP = Floor Plan

■ SP = Site Plan

■ DP = Demolition Plan

■ QP = eQuipment Plan

■ XP = eXisting Plan

■ EL = ELevation

■ SC = SeCtion

■ DT = DeTail

■ SH = ScHedules

■ 3D = isometrics/3D

■ DG = DiaGrams

Technically, FP would be used for any type of plan and each would simply be
enumerated. So, the first floor plan might be: A-FP01, while the first floor
ceiling plan might be: A-FP02. However, A-FP02 for a ceiling plan on the first
floor is confusing to most people and it is highly likely you would run out of
codes with only 2 digits. Therefore, the following abbreviations are used almost
universally by most firms:

■ CP = reflected Ceiling Plan

■ RP = fuRniture Plan

■ EP = Enlarged Plan

While A-3D01 would technically be correct for the name of a composite model,
the following is recommended:

■ CM = Composite Model

So the file would be named A-CM01. (You could also use A-CM00 for the first
composite model in a set. It is not that critical with which number you start.)

570 | Chapter 7   Drawing Management



NCS knows nothing about constructs. Since their names indicate drawing
type and function, they are best suited to use as View file names. Consider
descriptive names for Constructs such as:

■ 01 Walls

■ 01 Shell and Core

■ 01 Floor

■ 01 Floor Plate (not Plan)

■ Stair (for spanning Stairs)

■ 00 Stair (alternative for stairs)

■ Roof

■ 01 Slab

For sheets, the NCS system is fine. They recommend the number of the sheet,
which typically includes the discipline code as well. The number is in 2 parts:
the first digit is a code indicating drawing type, and the remaining 2 are an
enumeration.

■ 1 = Plans (Horizontal Views)

■ 2 = Elevations (Vertical Views)

■ 3 = Sections (Sectional Views)

■ 4 = Large Scale Views (Plans, Sections & Elevations that are not Details)

■ 5 = Details

■ 6 = Schedules and Diagrams

■ 7 = User Defined

■ 8 = User Defined

■ 9 = 3D Representations (Isometrics, Perspectives and Photographs)

Examples:

■ A-101 - (Architectural First Floor Plan)

■ A-102 - (Architectural Second Floor Plan)

■ A-103 - (Architectural First Floor Reflected Ceiling Plan)
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■ A-201 - (Architectural Building Elevations)

■ A-301 - (Architectural Building Sections)

Constructs Included in the Commercial Template Project
All constructs included in the Commercial Template Project are suggestions
of typical commercial project organization. Feel free to modify the arrangement
to suit your specific project needs and add or delete files as needed. Some files
may contain geometry; these are placeholders that are meant to be erased by
project team members prior to beginning work. Simply erase the geometry,
and draw actual project geometry in its place. For example, the Typical Toilet
Room element file contains a rectangle, and many files include a Live Area
Guide block insertion.

General Considerations for all Constructs
Typically there will be at least one construct for each level and/or division (if
used). However, there will often be many more than that. Project and team
member requirements will be a determining factor in shaping the exact
quantity and makeup of the constructs on a per-project basis. Some projects
will have many constructs per floor, while others might have only one per
floor. Below is a brief description of each construct included in this Commercial
Template Project. Feel free to add or delete them as required to meet your
specific project and team needs. You can also make modifications to the
Commercial Template Project and save it as a custom template project for use
in later projects.

Terrain Construct
This construct is intended for a simple terrain model of the project’s site
conditions. The Terrain construct is referenced in the Site Plan, Composite
Model, Section and Elevation View files.

Shell Construct
Several shell constructs have been included into the Commercial Template
Project: one for each floor of the building. These constructs are intended for
the exterior enclosure of the building. The various shell constructs are
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referenced in the Floor Plans, Composite Model, Section and Elevation View
files.

Core Construct
This construct is intended for objects that are part of the building core (like
walls, doors, etc.), excluding the stairs and possibly the toilet rooms. The stairs
should be drawn in the separate stairs construct. Toilet rooms, if the layout
is the same on all levels, can be drawn here and copied to each level. Otherwise,
they can be created as an element file like the Typical Toilet Room element
file (included in this Commercial Template Project), and then dragged into
the Core construct file.

If you do not wish to have a separate core construct, core geometry can be
drawn in either the Shell or Interior construct files instead. If you do this,
delete the core construct(s) from the project.

The various Core constructs are referenced in the Floor Plans, Composite
Model and Section View files.

Slab Construct
This construct is intended for slab objects and other objects that should display
in sections and models but should not display in plans. The various slab
constructs are referenced in the Composite Model and Section View files.

Interior Construct
This construct is intended for all geometry that is placed within the exterior
shell of the building. This includes all partitions, doors, etc. on the interior
of each floor. You can include space objects, ceiling grids, furniture and
equipment in this construct as well. Or, if you wish, you can separate these
other objects into their own spaces and grids and furniture constructs.

The various Interior constructs are referenced in the Floor Plans, Composite
Model and Section View files.

Stairs Construct
This spanning construct is intended to contain the complete flight of stairs
from the lowest level to the roof (if applicable). You can create separate
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constructs for each stair tower, or a single Stairs construct that contains all
stairs for the entire project. If you view the properties of the construct on the
Project Navigator palette, you will note that all levels are checked. This makes
it spanning. To work with this construct, draw a single run of stairs at the
lowest level, and add railings and any slabs needed for landings. Then use the
Stair Tower Generate tool (on the Design Palette - Design Tool Palette Group)
to copy the stairs, railings and slabs (if desired) to the upper levels. For more
information, see Stair Tower Generator on page 2301.

To make the multi-story stair display correctly in view files, use the Medium
Detail Intermediate Level display configuration as an external reference (xref)
display override when referencing the stair into a view. Select the Medium
Detail Intermediate Level display configuration for the intermediate levels,
and the Medium Detail Top Level display configuration for the top level stair
reference. For more information, see Object Display in External References on
page 528

The Stairs construct is referenced in the Floor Plans, Composite Model and
Section View files.

Roof Construct
This construct is intended for the roof of the building. You can create a separate
roof construct for each discrete portion of the roof (lower roofs, wings, towers,
etc.) or you can create all roofs in this file at their appropriate Z-heights relative
to the roof level elevation. Parapets and other roof features can be included
here or in other constructs as appropriate.

The roof construct is referenced in the Roof Plan, Composite Model, Elevation
and Section View files.

Column Grid Construct
This construct is intended for structural column grids and their columns.
Include column grids, columns, column grid bubbles and dimensions in this
file. This file has been included in a Structural folder.

The various column grid constructs are referenced in the Floor Plans,
Composite Model and Section View files.

574 | Chapter 7   Drawing Management



The Element File Included in the Commercial Template Project
Elements are meant for typical conditions in the project and also are useful
for miscellaneous project resources whose external referencing (xref) behavior
you wish to control manually (not appearing automatically in views or sheets).

Typical Toilet Room Element
This element is intended for creating toilet room layouts that will occur more
than once in the project. Rather than draw the same layout several times, or
copy and paste it, only to have to redraw when changes occur, use an element
to centralize edits to a single source file.

This element file contains a simple rectangle on a non-plotting layer as a way
to alert you to its presence in the preconfigured files. Open this element and
delete this rectangle and replace it with your actual toilet room geometry at
the start of a project. The Typical Toilet Room Element is referenced into the
various core constructs.

Views Included in the Template Project
A collection of starter views is included in this Template Project.

Consultant Backgrounds
This folder contains floor plan views that have been saved with the Screened
display configuration active. For consultants that use AutoCAD Architecture
or AutoCAD MEP, simply save and send these files. For consultants using
AutoCAD, change the display configuration to Plan Only and then use the
Save as AutoCAD command on the Application menu to save a non-AutoCAD
Architecture version of the file. For more information, see Exporting a Drawing
to AutoCAD on page 208.

Detail Views
The only view in this folder simply provides a layout grid divided into a detail
grid module. Draw details in this file on the detail grid. Create a new view for
details at a different scale.
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Enlarged Views
This folder is for interior elevations and enlarged plan views. Use the callout
tools on the Callouts tab of the Tool Palettes to create such views. For more
information see Callout Tools in AutoCAD Architecture on page 3690.

Floor Plan Views
Floor plan views are included here. Basic titlemarks, elevation, and section
markers are included in these files. You can use these, modify them, or erase
and add them again as required.

3D Model Views
Composite Model views gather all the constructs together for visualization
and/or coordination. Two are provided here, one of the entire model and
another of just the shell constructs.

Reflected Ceiling Plan Views
Reflected ceiling plan views are included here. Basic titlemarks and elevation
and section markers are included in these files.

Schedule Views
A composite Model is included in the Commercial Template Project for use
in generating schedule tables. This view file is referenced directly by the
schedule objects in the schedule sheet file included in the project (Sheet
A601–Schedules). Reload external references and then update the schedule
table periodically throughout the project to see the latest data. For more
information, see Updating a Schedule Manually on page 3753.

Elevation and Section Views
These files are generated using the callout tools. They include 2D
section/elevation objects of the overall building. Four elevations and 2 sections
are included. As you add geometry to your constructs, you can move and
resize the section and elevation lines as appropriate to capture the complete
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design and then refresh the sections and elevations. The constructs listed in
this document are already included in the section and elevation objects’
selection set. If you add new files, you will need to regenerate the section or
elevation. For more information, see Updating a 2D or 3D Section on page
3295 and Updating a 2D or 3D Elevation on page 3364.

Sheets Included in the Template Project
Several basic sheets have been included in this Template Project. Some of the
sheets already include viewports, such as the floor plans. Others are empty
sheets ready to place views on. Drag a view file or named model space view
within a View file from Project Navigator and drop it on the sheet. For more
information, see Placing a Model Space View onto a Sheet on page 471 and
Creating a Sheet View on page 497.

Sheets are organized in a sheet set and subsets. The list of sheets includes the
following:

G-100, Cover SheetGeneral

A-100, Site PlanArchitectural: General

A-101, Floor Plans A-102, Floor Plans A-
103,Floor Plans A-104, Floor Plans

Architectural: Plans

A-201, Building Elevations A-202, Building
Elevations

Architectural: Elevations

A-301, Building SectionsArchitectural: Sections

A-401, Enlarged Plans A-402, Interior Elev-
ations

Architectural: Large Scale Views

A-501, DetailsArchitectural: Details

A-601, SchedulesArchitectural: Schedules and Diagrams

A-901, 3D DiagramsArchitectural: 3D Representations

Sheets Included in the Template Project | 577



Project Standards
Project Standards are a tool that allows project files to have their object styles
and display settings synchronized to one or more Standards drawing files. The
Template Project has been set up to only be synchronized with the standards
when the user manually starts a synchronization. For more information, see
Setting up Synchronization of AEC Standards on page 616.

In the project’s Standards\Content folder, a file named Project Styles.dwg is
included. Some sample styles have been included in this file. Tools in the
Project’s Tool Palette reference the styles in this file. The project is set to
synchronize all types of styles to this drawing except layer key styles. The
default AECLayerStd.dwg file has been set as a second Standards drawing to
synchronize layer key styles.

In the Standards\Template folder, 2 additional drawing template files (DWT)
have also been provided: one for constructs, elements and views and the other
for sheets. The project is configured to synchronize display settings from the
Model DWT file in this folder. All styles in the project have been versioned
and synchronized to these files.
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Renovation

An efficient method of easily identifying objects and associating them with different phases
of a renovation project is key to producing clear construction drawings. The Renovation
feature provides this method and a framework for designing, developing, and creating the
drawings needed for renovation projects.

Overview of Renovation
In one drawing, there is the ability to display existing, demolished, and new
construction. By working within the single drawing and switching between
renovation plan types, you avoid errors typically caused by editing multiple
drawings. This feature is available for AutoCAD Architecture 2010 and newer.

Renovation Plans
Existing, demolished, and new objects display on a renovation plan. When you
work in this plan, objects are represented by the Renovation display
representation. This plan is your base plan from which you create demolition
and revision plans. This is the ideal mode for your work that is in progress.

Demolition Plans
Existing construction and those objects categorized as demolished (Demo)
display on a demolition plan. All new objects are hidden.

By switching between renovation plan types, you can work in different “views”
of the drawing, and avoid errors often incurred when editing multiple drawings.
Display settings for the demolition plan type are located in the Renovation
Options dialog. By default, yellow is assigned to demolished objects. For more
information, see Customizing Renovation Design Rules on page 592.

8
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You must first activate Renovation mode before you can work with drawings
using Renovation features. For more information, see Activating Renovation
Mode for the First Time on page 582.

■ With the Renovation drawing open in an active Renovation mode, click

 (Demolition Plan) on the Renovation panel.
The Activation of a Demolition Plan dialog displays. For more information
about act

New objects are turned off by default. To display the plan with new objects,

click  (New Show/Hide).

Revision Plans
New and existing construction objects display on a revision plan, and all
demolition objects are hidden. By switching between renovation plan types,
you can work in different “views” of the drawing, avoiding errors by editing
multiple drawings. Display settings for the revision plan type are located in
the Renovation Options dialog.

You must first activate Renovation mode before you can work with drawings
using Renovation features. For more information, see Activating Renovation
Mode for the First Time on page 582.

■ With the Renovation drawing open in an active Renovation mode, click

 (Revision Plan) on the Renovation panel.
The Activation of a Revision Plan dialog displays.
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Demolished objects are turned off by default. To display the plan with

demolished objects, click  (Demo Show/Hide).

Renovation Mode
When you initiate the Renovation mode, a renovation display configuration
is created. This is a copy of the current display configuration that exists in the
drawing. All objects display according to Renovation settings.

When Renovation mode is initiated, objects that are not already categorized
are assigned to the Renovation category titled “Existing.” Objects added to
the drawing while Renovation mode is active are automatically categorized
as new. When you use commands such as Delete while working in renovation
mode, the objects are assigned to the demo category; they are not deleted.
Moving a door creates both a new and a demo door and the corresponding
wall openings. Settings for the Renovation display configuration are located
on the Display tab in the Renovation Options dialog.

Working in Renovation Mode
When working in Renovation mode and following the recommended workflow,
objects are automatically assigned to existing, demolition, or new categories.
You can assign two-dimensional (2D) and three-dimensional (3D) objects to
different categories, easily view the drawing as a renovation plan, demolition
plan, or revision plan, and view objects by category.

In plan, section, and elevation views, 2D and 3D objects display according to
the categories to which they are assigned. The display configurations are
controlled by Renovation styles, and these can be customized in the
Renovation Options dialog.
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With tools on the ribbon you can end Renovation mode, add objects to
categories, and freeze and reset walls to make manual corrections to the edges.
This Renovation ribbon panel is visible and available only while you are
working in an active Renovation session.

Two-dimensional objects, blocks, and multi-view blocks keep their own display
representation when Renovation mode is started and are categorized as existing
objects. When you delete, modify, or create new 2D objects, they display
according to the applicable Renovation category. You can explicitly assign
them to a category and change their display. Objects that were already
categorized in an earlier Renovation phase keep their category and
representation. Objects that are created new in active Renovation mode, are
automatically marked as New.

When an object is selected and a command such as Delete, Move, Rotate, and
Copy is initiated, objects are assigned to categories and displayed based on
the command. For example, pressing Delete identifies objects as Demolition,
and moving a door creates both a new and a demolition door and the
corresponding wall openings. Existing and new walls automatically clean up
with each other; however, demolition and new objects do not interact.

Activating Renovation Mode for the First Time
The first time you activate Renovation mode, a specific Renovation display
configuration is created. This configuration is a copy of the current, existing
display configuration with the word Renovation added as a prefix.

1 Open an existing drawing in which you want to begin renovation

planning, and click Manage tab ➤ Style & Display panel ➤ 

(Renovation Mode).

The First Activation of Renovation Mode dialog displays, and by
default, a name for the new display configuration is provided with
the Renovation prefix.
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2 Enter a new name for the display configuration if necessary.

It is recommended that you maintain the default prefixes for
display configurations.

3 Click Options to change settings for the Renovation display, layer,
and styles, blocks and materials, or click OK to begin working in
Renovation mode.

Renovation styles can be saved, modified, or deleted. Display
styles can also be imported from, or exported to, external catalogs.
For more information, see Renovation Settings for Objects on
page 585.

Subsequent Work Using Renovation Mode
When you reactivate Renovation mode in a previously-activated drawing, you
can continue using the existing Renovation display configuration or create a
new one.

Objects that were categorized in an earlier Renovation phase retain their
category and representation. Any objects without a Renovation category (for
example, objects that were added when Renovation mode was not active) are
automatically categorized and displayed as Existing objects.

By default, the Show existing, demolished, and new objects option is selected.
Because this option ensures that categorized objects in a Renovation plan
remain visible if you switch between displaying the drawing as a Renovation,
Demolition, or Revision plan, it is recommended that you leave this option
selected.
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1 Open a Renovation drawing in which you want to continue

working, and click Manage tab ➤ Style & Display panel ➤ 

(Renovation Mode).

The Repeated Activation of Renovation Mode dialog displays.

2 Specify settings in the dialog.

Then…If you want to…

click the drop-down arrow for Activate an
Existing Renovation Display Configuration,
select a display configuration, and click OK.

begin the renovation ses-
sion with an existing
Renovation display config-
uration

select Create a new Renovation Display
Configuration named, enter a name for the
configuration, and click OK.

begin the renovation ses-
sion using a new display
configuration

leave the Show existing, demolished, and
new objects option selected.
This option ensures that objects categorized
in the drawing remain visible if you switch

show all objects in all
Renovation categories of
the drawing

between renovation, demolition, and revision
plan types. For best results, leave this option
selected.
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Then…If you want to…

click Options, make your changes, and click
OK. For more information, see Renovation
Settings for Objects on page 585.

change the display style
or design rules of objects

3 Click OK.

For more information, see Working on Your Drawings with
Renovation Mode Active on page 589.

Ending a Renovation Session
You complete a Renovation session by clicking the Close Renovation Mode
tool on the Renovation panel. You can reactivate Renovation mode at any
time. For more information, see Subsequent Work Using Renovation Mode
on page 583.

■ Click  to end the Renovation session. If you make changes to the
drawing after you end the Renovation session, the uncategorized objects
are assigned to the Existing category the next time you reactivate
Renovation mode.

Working with Dimensions
When you use AEC dimensions, you cannot automatically ignore objects by
Renovation category; all existing, demolished, and new objects are
dimensioned. You must manually remove any undesirable dimensions.

Renovation Settings for Objects
Renovation styles control design rules for Existing, Demolished, and New
categories by object type. In the Renovation Options dialog, Renovation styles
can be imported from external catalogs, exported to external catalogs, modified,
saved, or deleted. Renovation styles for display and layer assignment can be
specified independently from each other for maximum flexibility. These
settings are saved to the current drawing.
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The design rules control how objects display, how layer assignments are made,
how Renovation styles and blocks are named, and whether the same material
definitions display regardless of whether objects are viewed in a plan view or
in a 2D section or elevation view. For information, see Customizing Renovation
Design Rules on page 592.

Display Style and Design Rules
Objects display according to their display representation in the Renovation
display configuration. The Existing, Demolished, and New object categories
are specified within this display configuration and can be viewed in plan,
section, and elevation displays.

Layer Assignment Style and Design Rules
Design rules for layer assignments can be modified by object type and category.
You can specify that a prefix or suffix be appended to the layer name instead
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of changing the layer name. These settings can be saved to the Layer
Assignment Style selected in the Renovation Options dialog.

Style, Blocks, and Materials Design Rules
Design rules for the names of existing, demolished, or new objects can be
appended with a prefix or suffix to the Renovation style name. This identifies
the Renovation style specifically by category. With a prefix or suffix defined,
naming conflicts are avoided between objects in different Renovation
categories.

For example, if an existing wall with style name Brick is moved to another
position in Renovation mode, the original wall displays as demolished, and
a new one is created. Therefore, the existing wall is renamed in the Existing
category, the demolished wall is renamed in the Demolition category, and
the new wall is renamed in the New category. Specifying a design rule allows
automatic renaming for the wall and any objects in the wall instead of
manually renaming each object.
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The new Renovation styles with the specified prefix or suffix display in Style
Manager. For more information, see Style Manager Overview on page 870.

When you specify that material definitions are duplicated, a copy of the
material is generated and assigned to the building object (like Masonry.Unit
Masonry.Brick.Modular.Flemish_New) and the corresponding color settings
displays. Objects can be viewed correctly by category in 2D sections and
elevations, and associative 2D sections and elevations display building objects
according to their renovation category.

Interactions Between Building Objects
In Renovation mode, building objects are automatically categorized as Existing,
Demolition, or New. Objects interact based on their Renovation category. For
example, objects categorized as Existing and New interact with each other,
but objects categorized as Demolition and New objects do not. Therefore, if
you have walls that are categorized as Demolition and walls that are categorized
as New, and you want to have them intersect, you can modify them manually.
For more information, see Making Manual Modifications on page 589.
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NOTE If an opening endcap is changed for a door, window, opening, or
door/window assembly object while in Renovation mode, a new object is created.
If the object is to be kept, the opening endcap must be changed outside of
Renovation mode.

Working on Your Drawings with Renovation Mode Active

Making Manual Modifications
You can make modifications to your wall objects by temporarily suspending
Renovation mode. This may be necessary if walls of different renovation
categories do not intersect correctly.

For example, you may have a plan that includes walls categorized as existing
and walls categorized as demolition with wall edges that need to be corrected.
While working in an active Renovation mode, objects categorized as New do
not interact with objects categorized as Demolition. When you make a manual
correction, you temporarily interrupt Renovation mode by freezing the walls
you want to modify and then correcting the edges. The changes are not
considered Renovation. The option to freeze or thaw walls is only available
when Renovation mode is active.

1 With the Renovation drawing open in an active Renovation mode,

click  (Freeze Walls) on the Renovation panel.

2 Select the walls, and press Enter.

Renovation mode is temporarily suspended.

3 Correct the wall edges, and click  (Thaw Walls).

Renovation mode resumes.

Working with Renovation Categories
Renovation categories include Existing, Demolition, and New. In Renovation
mode, objects are automatically assigned to these categories. Categories of
building objects display according to the display settings specified in the
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Renovation Options dialog. You can manually assign objects to categories,
and select or display objects by category.

Assigning Objects to Renovation Categories
In Renovation mode, you can manually assign an object’s Renovation category
to Existing, Demolished, or New. The display properties change according to
the category. Manually categorizing objects may be necessary for 2D,
multi-view block, or block objects because these objects are automatically
assigned to the Existing category when you begin a Renovation session. For
more information, see Working in Renovation Mode on page 581.

1 With the Renovation drawing open in an active Renovation mode,
click the Assign (Existing, Demo, or New) tool on the Renovation
panel.

Then…If you want to…

click  .

add objects to the Demoli-
tion category

click  .

add objects to the New
category

click  .

add objects to the Existing
category

2 Select the objects in the drawing to be assigned, and press ENTER.

The selected objects are now assigned to the category specified, and they
display as the category is defined on the Display tab in the Renovation Options
dialog.

Selecting Objects by Renovation Category
In Renovation mode, you can select all objects assigned to a specific Renovation
category.
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1 With the renovation drawing open in an active Renovation mode,
click the Select (Existing, Demo, or New) tool on the Renovation
panel.

Then…If you want to…

click  .

select all objects in the
Existing category

click  .

select all objects in the
Demolition category

click  .

select all objects in the
New category

2 With the objects selected, you can complete a command such as
Delete.

Displaying Objects by Renovation Category
In Renovation mode, you can use the Show/Hide tool to display or hide all
objects by category. Depending on the current state of the objects, this tool
turns the category on or off.

The show/hide status of objects is saved in the drawing and should be
considered when closing and reopening a drawing. If you are not sure if objects
are hidden, select the tool and watch what happens.

 ➤ With the Renovation drawing open in an active Renovation mode,
click a Show/Hide tool.

Then…If you want to…

click 
show or hide all objects in
the Demolition category

click 
show or hide all objects in
the New category

Working on Your Drawings with Renovation Mode Active | 591



Making Minor Adjustments
You can freeze and thaw walls to manually edit wall edges. Selecting the Freeze
Walls tool temporarily interrupts the active Renovation mode and allows you
to manually edit wall edges. For more information, see Making Manual
Modifications on page 589.

1 With the Renovation drawing open in an active Renovation mode,

click  (Freeze Walls) on the Renovation panel.

2 Select the walls, and press Enter.

3 Correct the edges of the wall, and then click  (Thaw Walls).

Renovation mode resumes.

Customizing Renovation Design Rules
Design rules control how objects display in the drawing, the layer to which
they are assigned, whether a prefix or suffix is added to the layer or style name,
and whether material definitions are duplicated for viewing objects in 2D
sections and elevations. These settings are saved in the drawing. For more
information, see Renovation Settings for Objects on page 585.

Modifying the Renovation Display
You can change how properties of objects within specific categories are
displayed in the drawing by unlocking them, changing them individually per
object type, and saving them as the Renovation display style. Modifications
made are saved to the current drawing.

The lock icon to the left of the property signals whether this property can be
changed. For example, in the locked position, the property retains the original
display and is not changed. If the property is unlocked, any changes made to
the display is reflected in the drawing.

1 With the Renovation drawing open in an active Renovation mode,

click  (Options) on the Renovation panel.

The Renovation Options dialog displays.

592 | Chapter 8   Renovation



2 On the Display tab, select the display style to apply to the current
drawing, and enter a description.

Renovation styles can be modified and saved, deleted, and
imported from and exported to an external catalog.

3 Select the object type for the design rules.

4 Select the checkbox to the left of each property value for the
category you want to change.

TIP Press Shift or Ctrl to change multiple properties of different design
rules at the same time.

5 Modify the properties as desired.

6 Select Prompt for objects to update.

7 Select the objects to modify, or press Enter to select all objects.

Changes to the selected properties for the specified object type
are applied in the current drawing.
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Modifying the Renovation Layer Assignments
Modify Renovation design rules to rename or reassign layers for objects based
on their object type and Renovation category. These changes are saved in the
current drawing. For more information, see Renovation Settings for Objects
on page 585.

1 With the Renovation drawing open in an active Renovation mode,

click  (Options) on the Renovation panel.

The Renovation Options dialog displays.

2 Click the Layer tab, select the Layer Assignment Style to apply to
the current drawing, and enter a description.

Renovation styles can be modified and saved, deleted, and
imported from and exported to an external catalog.
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3 Select the object type for the design rules.

4 Select the desired Renovation categories and modify the layer
assignments.

Then…If you want to…

select Add Prefix to layer name, and specify
the prefix.

append a prefix to the
layer name

select Add Suffix to layer name, and specify
the suffix.

append a suffix to the lay-
er name

select Use layer named, and select the name.apply a different, existing
layer to the objects

5 Click OK.
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Renaming Style and Block Names by Renovation Category
Modify Renovation design rules to automatically append a prefix or suffix to
style and block names based on their object’s Renovation category. If you do
not predefine a prefix or suffix, and the same style or block name exists in
another category in the drawing, an alert displays, and you can manually
enter a new name. For more information, see Style, Blocks, and Materials
Design Rules on page 587.

1 With the Renovation drawing open in an active Renovation mode,

click  (Options) on the Renovation panel.

The Renovation Options dialog displays.

2 Click the Styles, Blocks and Materials tab.

3 Select the desired Renovation categories, and specify a prefix or
suffix to append to the style/block name in the current drawing.
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4 Select or clear Duplicate material definitions to specify whether
to duplicate material definitions in 2D sections and elevations.

5 Click OK.

Renovation Styles Catalog
The Renovation styles catalog contains display and layer assignment styles.
AutoCAD Architecture-based styles for objects, such as walls and windows,
are managed with Style Manager.

By default, the Renovation styles catalog (AecRenovation.dwg) is installed in
ProgramData\Autodesk\ACA 2012\enu\Styles. If the Renovation styles catalog
is renamed or moved, the styles are disabled and cannot be accessed. Use the
Renovation Styles Catalog Settings dialog to specify a valid catalog.

1 With the Renovation drawing open in an active Renovation mode,

click  (Styles Catalog) from the Options drop-down menu
on the Renovation panel.

The Renovation Styles Catalog Settings dialog displays.

2 Select the Import renovation styles from catalog checkbox for
drawings to be populated with all Renovation styles in the
specified catalog.

Clear the Import renovation styles from catalog checkbox for new
drawings to include standard styles only.

3 Browse to the location of the Renovation styles catalog you want
to use.

4 Click OK.
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Project Standards

The Project Standards feature lets you establish, maintain and synchronize standards across
all drawings in an AutoCAD Architecture project. Project standards include standard styles,
display settings, and AutoCAD standards that are used across all project drawings. Standard
styles and display settings are specified in one or more standards drawings associated with
the project. Project drawings can then be synchronized with these standards throughout the
project lifecycle, either automatically, or on demand. In addition, you can designate tool
palettes and a Content Browser library that are associated with the project.

Project Standards Terminology
project drawing A drawing file belonging to an AutoCAD Architecture project.
A drawing must be part of a project to access and be synchronized with project
standards.

standards drawing A file (DWG, DWT, DWS) that contains standard styles and
display settings associated with the project. Standards drawings can be placed
in a folder within the project folder, if they contain project-specific standards,
or outside the project folder if they contain department-specific or company-wide
standards.

Standards drawings can be included in e-transmit and archiving packages.

standard style or display setting A style or display setting that has been defined
as a standard for a certain project. To be defined as a standard style or display
setting, it needs to be contained in a standards drawing. Standard style types
and display settings include the following:

■ object styles (for example, wall styles, door styles, and so on)

■ property set definitions

■ property data formats

■ schedule table styles
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■ classification definitions

■ display theme styles

■ layer key styles

■ mask block definitions

■ material definitions

■ multi-view block definitions

■ profile definitions

■ display properties

■ display sets

■ display configurations

Not standardized style or display setting A style or display setting in a project
drawing for which no corresponding object can be found in the project
standards drawings.

version The process of recording changes to project standard styles and display
settings. Standard styles and display settings should be versioned when they
are changed in a standards drawing. When a new version is created, the next
synchronization recognizes the style or display setting as changed and lets
you update the project drawing accordingly.

Nonstandard version of a standard style or display setting Standard styles
and display settings in a project are versioned when they are changed either
in a project drawing or a project standards drawing. A version of a standard
style could for example have the date of July 14, 2006. The previous version
could be a week earlier from July 7, 2006.

When the synchronization detects a version of the style or display setting in
a project drawing that has a version date not found in the project standards
drawing (for example, a version dated July 12, 2006), this version is labeled a
“nonstandard version” of a project standard style or display setting.

older version of a standard style or display setting When the
synchronization in the above example detects a version of the style or display
setting dated July 7, 2006 in the project drawing, this is labeled as an “older
version”, because the version exists in the project standards drawing, but has
been updated by a newer one from July 14, 2006.

synchronization The process of checking a drawing or project against its
associated standards to identify and remove version discrepancies between
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the standards and the project. Synchronization can be set up to run invisibly
in the background, run automatically with user prompting, or can be manually
initiated by the user.

project tool palette group A project tool palette group is associated
automatically with the project. It can be referenced from a shared location or
be copied to each user’s computer.

project tools Project tools are tools in the project tool palettes set for the
project. In order to ensure that the current style definition is always used,
project-specific tools should point directly to the styles within a standards
drawing.

standards drawing location When standards drawings, catalogs, and libraries
are located within the project folder, they are treated as project-specific. For
example, if the project is used as a template for a new project, all files from
the standards folder are copied to the new project, to enable changing and
overwriting them in the new project. Standards files that are located outside
the project folder are not copied when creating a new project; they are only
referenced from their original location in both the existing and the new project.
This would be appropriate for files containing company standards that should
not be changed from project to project.

Project Standards Overview
Standard styles and display settings for a project are specified and stored in
one or more standards drawings that are associated with the project. This
allows you to organize your standards drawings in various ways. For example,
you could have one standards drawing for styles, another for display settings,
and a third for AutoCAD components such as layers, dimension styles, text
styles, and linetypes. Or you could place all your wall styles in one standards
drawing and all of your property set definitions and data format styles into
another.

Project standards can be accessed from a variety of AutoCAD file formats. They
can be saved in one or more drawing files (DWG), drawing templates (DWT),
or AutoCAD standards drawings (DWS). Each of these file types can be
associated with a project as standards drawings.

The project can be compared to the project standards at any time during the
project lifecycle, and if version discrepancies between the standards and the
project drawings are detected, be synchronized with the standards. In addition,
the standards can be updated from the project drawings if necessary.
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AEC Standards
AEC standards for a project include all items from Style Manager and Display
Manager. AEC standard objects are included in the synchronization and can
be updated from a project drawing.

They include these items:

■ object styles (for example, wall styles, door styles, and so on)

■ property set definitions

■ property data formats

■ schedule table styles

■ classification definitions

■ display theme styles

■ layer key styles

■ mask block definitions

■ material definitions

■ multi-view block definitions

■ profile definitions

■ display properties

■ display sets

■ display configurations
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Standard Scheduling Information

Project standards enable you to define and distribute a set of property set
definitions, property data formats, schedule table styles, and object tags across
a project. Property set definitions, property data formats, and schedule table
styles are created and accessed through Style Manager. Schedule tags are
accessed through the project tool palettes.

Standard Material Definitions

Material definitions can be defined and distributed across the project. Materials
are an integral part of object styles, and should be contained in the same
standards drawing as the object styles that reference them.

Layer Key Styles

Layer key styles can be defined in a project standards drawing, and distributed
across the project. Layer standards, however, are not set in the project
standards. If you want to associate a layer standard with a project, you need
to associate it with the drawing templates used for elements, constructs, views,
and sheets.

Profiles

Profile definitions for a project are specified in one or more project standards
drawings. Profiles can be used by many objects, for example mass element
shapes or window styles.

Classification Definitions

A project may have a set of classification definitions in one or more standards
drawings. Classifications are used as a reporting and display tool for building
objects. Classifications are attached to object styles. If you want to use a
classification in a project standard style, the classification needs to be stored
in the same standards drawing as the object style to which it is referenced.

Display Settings

You can define standard display representations, display sets, and display
configurations for a project. This will ensure consistent display of drawing
objects in the project. Only one display standards drawing can be set for a
project.
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AutoCAD Standards
The Project Standards feature integrates the AutoCAD Standards checker,
allowing the user to set up one or more DWS files for AutoCAD components.
AutoCAD components that can be included in a standards check are:

■ AutoCAD dimension styles

■ AutoCAD layers

■ Text styles

■ Linetypes

When you set up AutoCAD standards, a CHX batch checker file is created for
the project. The CHX file contains all project drawings as drawings to be
checked, and all specified DWS files as drawings to check against. You can
run this batch file for checking the whole project, or check individual project
drawings manually. For more information, see Synchronizing a Project with
AutoCAD Standards on page 666 and Synchronizing a Project Drawing with
AutoCAD Standards on page 667.

Standard Tools
Standard styles can be organized and accessed through tools. You can define
project tool palettes and a project library in Content Browser for quick and
easy access. For detailed information, see Setting up Standard Tools in a Project
on page 622.

Project Tool Palette Group

You can define a project tool palette group containing standard project styles.
You can choose between defining a shared tool palette group on a network
location, or a copy of the project tool palette group on the local users’
machines.

Standard Content Browser Library

An icon now appears on the Project Navigator Palette to launch the Content
Browser. You can set a custom Content Browser library that is opened by
default when Content Browser is started from the Project Navigator. With the
possibility of creating tool catalogs from existing drawings, as described in
Creating a Project Standards Tool Catalog on page 626, it is now easy to create
standard tools and catalogs for a project.
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Synchronizing the Project
During the lifecycle of a project, project standards can change. For example,
the hatching associated with a wall component can change its pattern, or a
property set definition can have added properties. In cases such as these, the
project must be synchronized with the modified standards. You can configure
the project standards so that project drawings are automatically checked
against the standards when opened, and automatically updated with the new
edits. You can also manually start a synchronization for a project drawing or
on the complete project at any time or you can configure standards for manual
synchronization regardless of the overall project synchronization settings.

Process Overview: Using Standards in a Project
Setting up and using standards in a project entails the following actions:

1 Create standard styles, display settings, and AutoCAD components
in one or more standards drawings.

Standards drawings can be drawing files (DWG), drawing templates
(DWT), or AutoCAD standard files (DWS).

Optionally, you can create different project standards files for
different styles, display settings, and AutoCAD components.

2 If desired, create a tool catalog that uses the styles from the
standards drawings for their tool definitions.

3 Optionally, you can create a Content Browser library that should
be used throughout the project.

4 Associate the standards drawings with the project.

5 If there are multiple standards drawings for styles, define which
style type should be controlled by which standards drawing.

6 Set up the desired synchronization behavior of the project.

You can choose between different synchronization modes,
depending on your project workflows. For example, you can
specify that a project drawing is synchronized with the standards
when it is opened, or you can specify that synchronization
happens only manually.

7 Add standard styles and display settings to your project drawings
by one of these methods:

■ Use tools from the standard palettes.
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■ Use tools from the standard Content Browser library.

■ Copy styles and display settings from the standards drawings
through Style Manager and Display Manager.

8 Synchronize project drawings with the project standards. Project
drawings can be synchronized automatically on opening, or
manually by the user.

9 Update any inconsistent objects.

Using Project Standards
Project standards help ensure consistency across a project.

The following workflows demonstrate how to use standards in a project:

■ The user opens a project drawing, and the styles and display settings are
synchronized with the associated project standards. Depending on the
standard settings, the user can either be prompted to update out-of-synch
objects, or they can be automatically updated by the software.

■ The CAD manager makes changes to a style in a standards drawing, applies
a version to the change, and saves and closes the standards drawing. The
next time a project drawing is opened it can be synchronized with the
changed style, making it match the version in the standards file.

■ A user receives a project drawing from another user or a subcontractor,
and performs a standards audit on it to determine if there are any not
standardized styles or display settings, or if any of them are out-of-date.
The user can decide whether to update out-of-date styles and display
settings, or ignore them.

■ The CAD manager sets up a default Content Browser library for the project.
When a user starts Content Browser from the current project in Project
Navigator, the project library is displayed. The user can then drag standard
tools into a project drawing.

■ To create a standard tool catalog based on an existing project, the CAD
manager opens the AEC Tool Catalog Generator, browses to the project,
and creates a tool catalog from the project drawings. He adds the new
catalog to a Content Browser library and connects that library to a project.
From there, the tools can be used either directly in the project or be used
to build up a project-specific tool palette group.
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■ To transmit the project to an external subcontractor, the CAD manager
creates an e-transmit package containing all project drawing files, standards
drawings, and standard catalogs, as well as the standard Content Browser
library. The subcontractor unzips the package to access these standard
objects for use on the subcontracted design work.

■ The CAD manager wants to create a hierarchical structure for standards.
Some standards are specific to the project, whereas others are specific to a
customer or general company standards. By placing different standards
drawings in different locations, some can be copied and overwritten for a
specific project, whereas others are referenced from a central location and
are read-only.

Prerequisites for Working with Project Standards
The following points need to be taken into consideration to work efficiently
with the project standards feature:

■ Project standards can be used only with projects. A drawing must be part
of a project to be synchronized with project standards. Project standards
cannot be applied to standalone drawings. You can copy standard styles
and display settings into standalone drawings, but they will not be
synchronized when the standards change.

■ Project standards can be distributed among multiple standards drawings,
if desired. However, there can be only one drawing that is designated for
the display settings in a project.

■ Project standards can be stored in DWG, DWT, and DWS files.

■ AutoCAD standards for layers, text styles, linetypes, and AutoCAD
dimension styles must be placed in DWS files.

■ Demand loading needs to be enabled for working with project standards.
The XLOADCTL system variable must be set to 2 (default value).

Setting up Standards in a Project
You can define one or more files to use as the source for standard styles and
display settings. You can also specify options for synchronizing the styles and
display settings with the standards. Additionally, you can set up DWS files for
AutoCAD layers, dimension styles, text styles, and linetypes.
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Creating a New Project with Predefined Standards
The quickest and easiest way to create a new project that already has standards
associated with it, is to use an existing project with standards as a template.
When you use an existing project as a template, the following files and
structures are copied to the new project:

■ All project DWG files and XML files

■ AEC standards files

■ AutoCAD standards files

■ Project standards synchronization settings

■ Sheet set template

■ Project details

■ Drawing template paths

■ Keynote and detail component database paths

■ Project tool palette group

■ Tool content root path

■ Project Content Browser library

NOTE Project standards files, tool palettes, and the project Content Browser library
are copied to the new project only if they are located within the original project
folder. Standard components located outside the project folder will be referenced
by the new project, but not copied to it.

For information about creating a project with predefined standards, see
Creating a New Project Based on a Template (Copying a Project) on page 328.

When you create a new project based on a template, all files that are in the
project folder, will be copied, including the project drawings (DWG) and their
associated XML files. If you want to copy only the standards files and support
files, as well as the structure of the project, you need to create a project with
a copied structure, as described in Creating a New Project with the Structure
of an Existing Project on page 330.
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Configuring Project Standards
After setting up a project, you can configure the project standards. If you have
created a project based on a template, the initial project standard settings
come from the template. If you have not used a template, the settings are
undefined or default settings.

Project standard settings include the following:

■ Standard styles

■ Standard display settings

■ Synchronization settings

■ AutoCAD standards (layers, dimension styles, text styles and linetypes)

NOTE To set up project standards, you must have one or more project standards
drawings available. If you have created a new project based on a project with
standards, the standards drawings of the original project are copied to the new
project and are automatically associated with the new project. If you have created
a new project not based on a template, or based on a project without standards,
you first need to define one or more standards drawings. For more information,
see Creating a New Project Standards Drawing on page 671.

Setting up Standard Styles and Display Settings
Use this procedure to set up standard styles and display settings for a project.

NOTE Standard styles include object styles, definitions, profiles, materials, property
set definitions, and classifications.

To set up standard styles and display settings, you define one or more project
standards drawings that contain the standards for styles and display settings.
These drawings can be DWG, DWT, or DWS files and are added in the
configuration dialog.

Standard files are marked by icons next to their name in the configuration
setup.

DescriptionIcon

Standards drawing (DWG)
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DescriptionIcon

Standards template (DWT)

AutoCAD Standards file (DWS)

Missing standards file

Synchronization Order

If you have multiple standards drawings associated with a specific style type,
then during synchronization the occurrence of the style in the first standards
drawing is used as the style with which the style in the project drawing is
synchronized. Further drawings containing the same standard style are ignored.

Order of standards drawings
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1 Click  ➤ Open ➤ Project.

NOTE To access the standards configuration of the current project

only, click Manage tab ➤ Project Standards panel ➤ Configure  .

2 Select the project for which you want to configure standards,
right-click, and click Project Properties.

3 Expand Advanced and click Project Standards  .

4 To add a new standards drawing for styles, click  .

5 In the Select Standards Drawing dialog box, select a DWG, DWT,
or DWS file that contains standard styles, and click Open.

If you do not yet have standards drawings, see Creating a New
Project Standards Drawing on page 671.

The new styles drawing is appended to the Standards Drawings
list. The order of the columns, from left to right, defines the search
order and precedence during synchronization. To change the
order of the drawings, select the drawing name in the column

header, and click  to move the drawing up in the drawing
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order, and click  to move the drawing down in the drawing
order.

After you have added styles drawings to the project standards
setup, you need to define for which style types each drawing
should be the standard. To do this, you associate each style type
with a standards drawing. The style types are listed under Objects
in the Standard Styles tab. You can find all style types from Style
Manager here.

6 To display only style types of one style category, select the category
under Select which objects to display in the list below. If you want
to see all style categories, select All Objects.

7 To define that a specific style type should be controlled by a
specific standards drawing, click the style type’s check box in the
appropriate drawing column.

TIP If you want to select one drawing for all style types, right-click
in the header, and click Select Column.

If a style type has not been associated with a standards drawing,
these styles are not controlled by the standards. For example, if
the standards drawing “Standard Styles 1.dwg” has not been
associated with the Wall Styles type, then even if wall styles from
this standards drawing exist in a project drawing, they will be
interpreted as “not standardized” by the synchronization.

If you select multiple standards drawings for one style type, then
during synchronization, each drawing is searched for that style
type in the order of the drawings. This means that you can
distribute standard styles for a style type among different drawings.
For example, you could store your concrete wall styles in the
standards drawing “Wall Styles - Concrete (Imperial)”, and your
brick wall styles in the drawing “Wall Styles - Brick (Imperial)”.
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NOTE If two standards drawings contain a style of the same name
and type, the style in the first standards drawing will be used for
synchronization. Further instances of that style will be ignored. The
order of standards drawings is determined by their position from left

to right in the table. To re-order the drawings, use the Up  and

Down  buttons.

8 To remove a standard styles drawing from the project, click on

its name in the Standards Drawings list, and click  .

Removing a standards drawing from the list only removes the
reference of this drawing to the project. The drawing is not deleted
from the file system.

Next, you need to define a standards drawings for the display
settings in the project. You can assign only one standards drawing
for display settings. The standard display settings drawing can be
one already assigned as a styles standards drawing.

9 Under Select drawing to use for standard display settings, select
a file. If necessary, select Browse to browse for a file.

NOTE If you are using a display standards drawing that is different
from the styles standards drawing, or if you have multiple styles
standards drawings, you need to make sure that the styles standard
drawings are in synch with the display standards drawing. For more
information, see Synchronizing Project Standards with Each Other
on page 690.

10 Click the Synchronization tab.

If you have added a standards drawing to the project, and the
drawing is located in the project folder, the drawing will
automatically have initial version information added to all styles
and display settings. If the new standards drawing is located
outside the project folder, and has not yet been versioned, you
need to version it as described in Versioning a Project Standards
Drawing on page 687. For more information about versioning, see
Versioning Standards on page 675.

11 If necessary, enter a universal comment to all versioned styles and
display settings.

For instance, you might want to add a comment to indicate what
has changed in the style as of this version.
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12 Click OK.

NOTE If some of the standards drawings have been set to read-only,
they cannot be automatically versioned. In this case, they need to be
versioned manually by a user with read-write access.

Synchronization Options
When a project uses standards, it needs to be synchronized with the standards
in regular intervals to make sure the standards are observed. During
synchronization with its standards, the styles and display settings in the project
or project drawing are compared with the project standards, to find version
discrepancies between them, and fix them.

You can set different synchronization options. Before deciding on settings,
you should review your desired workflow to find the optimal choice. Keep in
mind that the option you select will be in effect for all users of the project.

Automatic Synchronization

If you select automatic synchronization, the following behavior is defined for
the synchronization:

■ Project drawings are compared with the project standards when they are
opened.

■ In case of version discrepancies between a project drawing and the project
standards, the styles and display settings in the project drawing are
overwritten by the styles and display settings from the project standards
without prompting. The user cannot prevent the update.

■ No notification of not standardized styles and display settings in the project
drawing is displayed during the automatic synchronization. If not
standardized styles and display settings exist, they are ignored.
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TIP To display not standardized styles and display settings, you can audit the
drawing, as described in Auditing a Project or a Drawing on page 668.

■ When users make changes to a standard style or display setting in a project
drawing, they will not be prompted to upload the styles or display settings
to the projects standards drawings accordingly. Unless a user uploads the
changed objects to the standards drawing manually, they will not be copied
into the standards drawing.

Semi-Automatic Synchronization

If you select semi-automatic synchronization, the following behavior is defined
for the synchronization:

■ Project drawings are compared with the project standards when they are
opened.

■ In case of version discrepancies between a project drawing and the project
standards, a notification dialog is displayed where the user can decide
whether the styles and display settings in the project drawings should be
overwritten with the standards. The user has the option to ignore
inconsistent styles and display settings.

■ Not standardized styles and display settings in the project drawing are
displayed in a list.

■ When users make changes to a standard style or display setting in a project
drawing, they will be prompted to upload the styles or display settings to
the projects standards drawings.

Manual Synchronization

If you select manual synchronization, the following behavior is defined for
the synchronization:

■ Project drawings are not compared and synchronized with the project
standards when opening the project drawing. To perform a
synchronization, the user needs to manually initiate it. For more
information, see Synchronizing a Project with the Standards on page 647.

■ In case of version discrepancies between a project drawing and the project
standards, a notification dialog is displayed where the user can decide
whether the styles and display settings in the project drawings should be
overwritten with the project standards. The user has the option to ignore
inconsistent standard styles or display settings.
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■ Not standardized styles and display settings in the project drawing are
displayed in a list.

■ When users make changes to a standard style or display setting in a project
drawing, they will not be prompted to upload the changes to the projects
standards. Unless a user uploads the changed standards in the standards
drawing manually, they will not be copied into the standards drawing.

The synchronization settings are valid for all users of the project. So the
synchronization method selected should reflect the workflow needs of the
majority of users. For example, if you want all users to be in synch with all
project standards at all times, you should choose automatic synchronization.
If you want greater transparency and user control, you could choose
semi-automatic or manual synchronization.

If you have selected automatic synchronization, the synchronization of project
drawings will run “invisible” in the background. On opening, each drawing
will automatically be synchronized with the standards without notification
to the user. If you have selected semi-automatic or manual synchronization,
you have more control and information about the synchronization process;
you can display lists of not standardized styles and display settings,
nonstandard versions, or older versions, and individually decide if you want
to update or ignore them.

Setting up Synchronization of AEC Standards
Use this procedure to set up the synchronization options for the AEC standards
in a project.

NOTE The synchronization settings you define are relevant only for the
synchronization of the AEC standard styles and display settings in a project, as
specified in Setting up Standard Styles and Display Settings on page 609. They do
not affect the synchronization of AutoCAD standards in a project, as defined in
Setting up AutoCAD Standards on page 618. For more information about
synchronization, see Synchronizing a Project with the Standards on page 647.

NOTE The settings in this dialog box control only how project drawings are
synchronized with project standards drawings. They do not specify how project
standards drawings are synchronized with each other. For information on
synchronizing project standards drawings, see Synchronizing Project Standards
with Each Other on page 690.

616 | Chapter 9   Project Standards



1 Click  ➤ Open ➤ Project.

NOTE To access the standards configuration of the current project

only, click Manage tab ➤ Project Standards panel ➤ Configure  .

2 Select the project for which you want to configure standards,
right-click, and click Project Properties.

3 Expand Advanced and click Project Standards  .

4 Click the Synchronization tab.

5 Select the synchronization method for your project.

For information about the available methods, see Synchronization
Options on page 614.

6 To create a log file of the synchronization, select Create log file.

When the log file is created, you can choose between a report in
XML or HTML format. The log file contains information about
the drawings synchronized, the standards drawings used, and the
changes made to standard styles and display settings in the course
of synchronization.

7 Click OK or click the AutoCAD Standards tab.
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Setting up AutoCAD Standards
Use this procedure to set up AutoCAD standards for the project.

AutoCAD standards include AutoCAD layers, AutoCAD dimension styles, text
styles, and linetypes, and are contained in DWS files. You cannot define
different DWS files for different components; for example, you cannot define
one DWS file for dimension styles, and another one for linetypes. Each setting
from each DWS file is processed. If there is conflicting information in different
DWS files, then the first one in the list is used. If necessary, you can change
the order of the DWS files to change the precedence. For more information,
see “Define Standards” in AutoCAD Help.

When you set up AutoCAD standards, a CHX batch checker file with the same
name as the project file is created in the project folder. The CHX file contains
all project drawings as drawings to be checked, and all specified DWS files as
drawings to check against. You can run this batch file for checking the whole
project, or check individual project drawings manually. For more information,
see Synchronizing a Project with AutoCAD Standards on page 666 and
Synchronizing a Project Drawing with AutoCAD Standards on page 667.

1 Click  ➤ Open ➤ Project.

2 Select the project for which you want to set up AutoCAD
standards, right-click, and click Project Properties.

3 Expand Advanced and click Project Standards  .

4 Click the AutoCAD Standards tab.
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5 To add a new DWS file, click  .

By default, the new DWS file is appended to the end of the list.
That means that will be processed last, and settings from higher
listed DWS files will take precedence.

6 To change the order of the DWS files in the list, use the Up 

and Down  buttons.

7 To remove a DWS file from the list, click on its name in the list,

and click  .

Removing a DWS file from the list only removes the reference of
this file to the project. The file is not deleted from the file system.

8 If you have set up DWS files as AEC standards drawings in Setting
up Standard Styles and Display Settings on page 609, you can re-use
them for the AutoCAD standards by clicking Add .dws files from
Standard Styles. This will copy the AEC standards files to the
AutoCAD Standards tab, and use them as AutoCAD standard files
in the project.

Copying Project Standards from Another Project
Use this procedure to copy the project standard settings from an existing
project.
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Copying the project standards copies the following standards settings:

■ Copy or reference the style and display standards drawings to the new
project

■ Copy or reference AutoCAD standards drawings to the new project

■ Duplicate the association of standards drawings to style types in the new
project

■ Duplicate the synchronization settings in the new project

When you copy the standards of an existing project to a new project, standards
drawings can be either referenced from their original location in the new
project, or be copied to the new project.

■ If the project standards drawings of the copied project are located within
the original project folder, then the drawings are copied to the new project.
You would do this if you wanted to have a separate set of project standards
drawings for each project you create. That way, you can make
project-specific changes for each set of project standards.

■ If the standards drawings of the copied project are outside the original
project folder, they will not be copied to the new project, but will be
referenced from their original location. You could do this if your project
standards are not specific to one project, but are rather department-specific
or company-wide standards. If you make changes to a project standards
drawing referenced by several projects, all projects will be able to be
synchronized with the changes.

1 Click  ➤ Open ➤ Project.

2 Select the project for which you want to set up AutoCAD
standards, right-click, and click Project Properties.

3 Expand Advanced and click Project Standards  .

4 Click the Standard Styles tab.

5 Click  .

6 In the Select Project dialog box, select the project file (APJ) from
which you want to copy project standards, and then click Open.
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7 Select the copy settings.

Then…If you want to…

click Remove existing settings.overwrite the existing project
standards with the copied
project standards

click Append copied settings to existing
settings.
Existing settings that are inconsistent
with the copied settings will be replaced
with the copied settings.

add the project standards
from the selected project to
any existing project standards

8 Click OK twice.

Enabling Project Standards for a Project
After defining the standards for a project, you need to enable them to make
them active within the project.

While you are still working on setting up the standards for a project, you
might not want the standards to be activated in the project right away, as
standards styles might still be added, removed, or changed. Once the setup is
complete, however, you must enable the standards for the project.

1 Click  ➤ Open ➤ Project.

2 Select the project for which you want to enable AutoCAD
standards, right-click, and click Project Properties.

3 Expand Advanced and click Project Standards  .

4 Select Enable project standards for project <Project Name>.

5 Click OK twice.

The selected synchronization behavior (automatic, semi-automatic,
or manual) is now activated.
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NOTE Enabling the standards in a project does not mean that
standard styles and display settings are copied to project drawings.
To add standard styles and display settings to project drawings, see
Adding Standards to a Project Drawing on page 642.

Generating a Project Standards Setup Report
Use this procedure to create an HTML or XML report that lists the project’s
standard drawings, and standard styles and display settings, along with their
version history.

1 Verify that the project for which you want to create a standards
setup report is set as the current project.

For information on setting a project current, see Setting a Project
Current on page 327.

2 Click Manage tab ➤ Project Standards panel ➤  ➤ Setup

Report  .

3 In the Save Setup Report dialog box, select a file name, location,
and format for the generated report.

4 Click Save.

The report is saved in the specified location and can be displayed
with a Web Browser or XML editor.

Setting up Standard Tools in a Project
Every project has a project tool palette group associated with it. If you are
using project standards, the tools should point to standard styles from a project
standards drawing. To make working with project tools easier, a project-specific
library can be created in Content Browser.

Setting up standard tool palettes is usually a task for a CAD manager or project
owner. Depending on the requirements of the project, different steps can be
taken to achieve the desired results. The main considerations for creating the
project tool palettes are the following:
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Per User Workspace Catalog and Shared Workspace Catalog

The CAD manager can decide whether to create a group of tools and palettes
that are shared by all users of a project and accessed from a single location,
or to define a project catalog and Content Browser library, and maybe create
a starter set of palettes for copying to individual users’ computers. For more
information, see Before You Begin: Working in a Network Environment on
page 316.

AutoCAD Architecture loads the tool palettes found in the paths specified in
the Files tab of the Options dialog box. Projects allow you to specify an
additional location path for a tool palettes file that contains project-specific
tool palettes. This path is appended to the current profile when the project is
made current, and removed when the project is closed or when another project
is set current.

Projects support two workflows for working with project palettes:

Per user workspace catalog: This the recommended option. Use the Per user
workspace catalog option in conjunction with project tool catalogs in Content
Browser. In this mode, users can access the tools and tool palettes they need
for the job from tool catalogs in Content Browser on a per-user basis. By
utilizing the refresh/linking behavior of Content Browser, you can make
changes to the original tools and tool palettes in project catalogs, and your
team can refresh their tools and palettes to get the latest versions. Thus, each
user’s workspace is maintained by the application uniquely, but linked palettes
allow for global updates.

You can optionally provide your project team with a starter set of tool palettes,
including the initial layout and tool ordering. To do this, you would create
the project palettes in your own workspace, and then use Windows Explorer
to copy the files to the location specified for the tool palette file location in
the project properties. For detailed instructions, see the workflow examples
below.

Shared workspace catalog: This option is recommended if you wish to mandate
a set collection of project tool palettes for everyone on the project. In this case
you do not want users going to Content Browser to customize project tools
or tool palettes. To create a shared workspace, you specify a shared network
location and assign it to the tool palette file location of the project. As this
path will be appended to every project team member’s profile when the project
is set current, the path should be read-only. Otherwise changes made by one
user would affect every user, and the last change would be the final form of
the tool.
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NOTE If you make changes to the shared tool palettes, they are not copied to
disk until you close the project to close AutoCAD Architecture. Similarly, other
users will not see your updates until the next time the project is set current or
AutoCAD Architecture is closed and re-opened with the project still current.

Using Content Browser or Style Manager

You can create standard catalogs in Content Browser and define a standard
Content Browser library for a project. You can use the catalog and library to
drag tools and palettes to the workspace or to the project tool palettes. This
would likely be the case if you set up the project using the Per user workspace
catalog option. If you do not want to give users access to a Content Browser
library with standard tools, do not set a library for the project. In that case,
you need to build the project tool palettes from standard styles in Style
Manager. You would typically do this if you are using the Shared workspace
catalog option.

Using Linked or Unlinked Tools

When you build your project palettes from a project catalog in Content
Browser, you can either link the palettes and tools from Content Browser, or
create an unlinked copy in the project palettes. If you want to be able to make
frequent updates in Content Browser, linking tools and palettes is
recommended.

Following are two suggested workflows for setting up standard tools. The first
one is based on a per user workspace catalog, giving more freedom to the
individual users of the project. The second one is based on a shared workspace
catalog, and puts greater emphasis on adhering to a given structure.

Workflow 1: Using a Per User Workspace Catalog

1 Create standard styles in standards drawings and associate them with the
project. For more information, see Creating a New Project Standards
Drawing on page 671 and Setting up Standard Styles and Display Settings
on page 609.

2 Create one or more tool catalogs from the standards drawings. For more
information, see Creating a Tool Catalog for a Project on page 626.

3 Create a project library in Content Browser, and add the standard catalogs.
For more information, see Adding a Project Catalog to a Content Browser
Library on page 631.
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TIP By default, tool catalogs are set to be linking. This makes it easier to
update them once they have been copied to the workspace tool palettes.

4 Define the tool palette file location for the project. For more information,
see Adding a Project Library and Tool Palette Group on page 632.

TIP If you are using one of the project templates provide with the software,
the tool palette file location is by default set to \<Project
Folder>\WorkspaceToolPalettes.

5 For Tool palette storage type, select Per user workspace catalog.

6 Associate the Content Browser library you have created with the project.
For more information, see Adding a Project Library and Tool Palette Group
on page 632.

7 Build up the project tool palette group. For more information, see Building
the Tool Palette Group on page 639.

8 If you want your project users to start out with the same tools you have
in your workspace, copy the palettes to the location specified in the tool
palette file location path. For more information, see Copying the Project
Tool Palettes to the Tool Palette File Location on page 641.

9 If you want your project users to have the same palette groupings, icon
size, and ordering as you have, copy the project profile (AWS) to the
location specified in the tool palette file location path. That way, new
project users will have the profile installed in their Documents and
Settings folder. For more information, see Adding the Project Profile to
the Tool Palette File Location on page 641.

Workflow 2: Using a Shared Workspace Catalog

1 Create standard styles in standards drawings and associate them with the
project. For more information, see Creating a New Project Standards
Drawing on page 671 and Setting up Standard Styles and Display Settings
on page 609.

2 Define the tool palette file location for the project. For more information,
see Adding a Project Library and Tool Palette Group on page 632.

TIP If you are working with a shared workspace catalog, it is highly
recommended that you point the tool palette file location to a read-only
folder.
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3 For Tool palette storage type, select Shared workspace catalog.

4 Build up the project tool palette group. For more information, see Building
the Tool Palette Group on page 639.

5 If you want your project users to have the same palette groupings, icon
size, and ordering as you have, copy the project profile (AWS) to the
location specified in the tool palette file location path. That way, new
project users will have the profile installed in their Documents and
Settings folder. For more information, see Adding the Project Profile to
the Tool Palette File Location on page 641.

Creating a Tool Catalog for a Project
A tool catalog for a project should contain tools from project standards
drawings. The easiest way to generate a tool catalog from standards drawings
is to either create a new tool catalog based on one or more project standards
drawings, or to add tools from a project standards drawing to an existing tool
catalog.

The tool catalog can then be added to the Content Browser library that is
associated with the project. This makes it easy to use the tools either in the
drawing or add them to the project tool palettes.

Creating a Project Standards Tool Catalog
Use this procedure to create a new tool catalog based on existing standards
drawings. You specify the styles from which tools will be created and whether
the new tools are organized in categories or palettes.

1 Click Manage tab ➤ Customization panel ➤  ➤ Generate Tool

Catalog  .
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2 Under Catalog, select Create a new catalog.

3 Enter a name for the new catalog.

4 Click Browse to define the location of the catalog.

5 Under Content Source, specify whether you want the new catalog
to be created from multiple drawings in a folder or from a single
drawing. Then, enter the path for the folder or drawing.

NOTE When you specify a folder as the catalog source, any nested
folders are included in the new tool catalog.

6 Specify how you want the tools organized in the new catalog:

■ To organize the new tools by their source drawing, select Group
tools by source drawing.
This option is well suited for a tool catalog that is generated
from a number of styles drawings. The resulting tools could
be placed in categories or palettes named “Wall Styles -
Concrete (Imperial)”, “Wall Styles - Brick (Imperial),” and so
on.

■ To organize the new tools by their object type, select Group
tools by object type.
This option is well suited if you want to merge styles from
various drawings into palettes or categories. The resulting tools
will be placed in categories or palettes named “Walls”, “Doors,”
and so on.
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NOTE If both options are enabled, the catalog is first grouped
by the drawings and then by the object type, generating
categories from the drawings, and palettes from the object types.
This is implemented because palettes cannot be nested. In this
case the radio buttons for categories and palettes are disabled,
and the Create tools in palettes option is selected for the catalog.

NOTE If neither of the two options is enabled, all new tools will
be generated in the top category of the catalog.

■ To organize the new tools in categories, select Create Tools in
Categories.
If you selected Group tools by source drawing, a category will
be created for each source drawing. If you selected Group tools
by object type, a category will be created for each object type.

■ To organize the new tools in palettes, select Create Tools in
Palettes.
If you selected Group tools by source drawing, a palette will
be created for each source drawing. If you selected Group tools
by object type, a palette will be created for each object type.

7 Under Create tools for the following objects, select the object
styles you want to appear as tools in the new catalog.

By default, all available style types are selected. Use the Select All
and Clear All buttons as necessary.

8 Click OK.

A progress bar in the application status bar informs you of the
progress of the catalog generation. This can take a few moments
for a large catalog.

NOTE Each category and each palette is created in its own ATC file.
The category and palette ATC files are stored in the Palettes or
Categories subfolders within the folder where the new catalog is
created.

For information about associating a tool catalog to a project
library, see Adding a Project Catalog to a Content Browser Library
on page 631.
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Adding Standard Tools to a Tool Catalog
Use this procedure to add project standard tools to an existing tool catalog.

1 Click Manage tab ➤ Customization panel ➤  ➤ Generate Tool

Catalog  .

2 Under Catalog, select Add to an existing catalog.

3 Enter the name and the path of the catalog.

4 Click Append to Catalog and select Ignore Duplicate Styles if you
want to prevent existing styles from being overwritten by styles
with the same name and file path from the appended drawing.

If you clear Ignore Duplicate Styles, existing styles are overwritten
with styles from the appended drawing if they have the same
name and file path.

5 If you want to overwrite the existing catalog, click Overwrite
Catalog.

This deletes the whole catalog and replaces it with the palettes,
categories, and tools from the source drawing(s).
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WARNING You should use that option with great caution, as it will
delete the complete existing catalog. If you just want to overwrite
tools with their up-to-date versions from a content drawing, select
Append to Catalog instead, and verify that Ignore Duplicate Styles is
cleared.

6 Under Content Source, select a project standards drawing or
standards folder to use as source for the new tools.

Then…If you want to…

select Create from drawings in folder, and
then enter the path and folder name under
Type the source folder location.

add tools from multiple
drawings in a folder

select Create from drawing, and then enter
the path and drawing name under Type the
source drawing.

add tools from a single
drawing

7 Specify how the tools should be ordered in the catalog.

■ To order the resulting tools by their source drawing, select
Group tools by source drawing.
This option is well suited for a tool catalog that is generated
from a number of styles drawings. The resulting tools could
be placed in categories or palettes named “Wall Styles -
Concrete (Imperial)”, “Wall Styles - CMU (Imperial)” and so
on.

■ To order the resulting tools by their object type, select Group
tools by object type.
This option is well suited if you want to merge styles from
various drawings into the catalog. The resulting tools will be
placed in categories or palettes named after the style type, for
example “Walls”, “Doors,” and so on.

NOTE If both options are enabled, then the tools are first grouped
by the drawings and then by the object type, generating
categories from the drawings, and palettes from the object types.
This is implemented because palettes cannot be nested. In this
case the radio buttons below are disabled and the Create tools
in palettes option is selected for the tools.
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NOTE If neither of the two options are enabled, all new tools will
be generated in the top category of the catalog.

■ To place the new tools in categories, select Create Tools in
Categories.
If you selected to group tools by their source drawing, then
for each source drawing a category will be created. If you
selected to group tools by their object type, then for each
object type a category will be created.

■ To place the new tools in palettes, select Create Tools in
Palettes.
If you selected to group tools by their source drawing, then
for each source drawing a palette will be created. If you selected
to group tools by their object type, then for each object type
a palette will be created.

8 Under Create tools for the following objects, select which object
styles should appear as tools in the catalog.

By default, all available style types are selected. Use the Select All
and Clear All buttons as needed to make your selections.

9 Click OK.

A progress bar in the application status bar indicates the progress
of the tool generation. When a large number of tools are being
added, the process can take a few moments.

NOTE Each category and each palette is created in its own ATC file.
The category and palette ATC files are stored in the Palettes or
Categories subfolders in the folder in which the new catalog is created.

For information about associating a tool catalog to a project
library, see Adding a Project Catalog to a Content Browser Library
on page 631.

Adding a Project Catalog to a Content Browser Library
Tool catalogs are placed in catalog libraries. If you have created a tool catalog
with standard tools, you need to add it to a catalog library. A Content Browser
library can be set up on a shared network volume to be accessed by all project
users. The CAD manager or project owner can point the project to that Content
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Browser library to have quick access to standard tools. For more information,
see Adding a Project Library and Tool Palette Group on page 632.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Click  to display the catalog library.

3 Click  to create a catalog.

4 In the Add Catalog dialog box, select Add an existing catalog or
website.

5 Enter the location of the standards tool catalog created in Creating
a Project Standards Tool Catalog on page 626, or click Browse a to
navigate to the catalog.

6 Click OK.

NOTE Alternatively, you can drag and drop an ATC file from Windows
Explorer to the Content Browser library pane.

Adding a Project Library and Tool Palette Group
If you have created a project library in Content Browser, you can associate it
to a project. When you open the Content Browser from Project Navigator,
the project library is automatically displayed.

The project library can be used to drag tools in project drawings, or to fill the
project tool palettes with standard tools.

Project Tool Palette Group

Each project has a specific tool palette group (ATC) associated with it.
Depending on how you created the project, the tool palette group can be
created and displayed in different ways.

For a new project, the project tool palette group is by default empty, unless
the project settings are pointing to an existing palette group.
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Selecting the project tool palette group

Tool Content Root Path

Setting a tool content root path can help you keep your tools consistent with
standards if the project or the standards drawings are moved during the project
lifecycle.

When tools on the project tool palettes point to the tool content root path
specified in the project settings, the content root path is created as a variable
(%AECPROJECT_DIR%) in the XML definition of the tool. When the tool
content root path in the project settings is changed, the path of the tools is
changed accordingly.

For example, if all project tools point to content stored under <Project Root
Folder>\Standards\Content\Content 1\, you can move the content to <Project
Root Folder>\Standards\Content\Content 2\, adjust the tool content root path
in the project setup accordingly, and all tools will now point correctly to
<Project Root Folder>\Standards\Content\Content 2.

Another use case for changing the tool content root path would be if a user
wants to work offline, and for that purpose creates an e-transmit package of
the project and its tool content files. When the e-transmit package is unpacked
on the local computer, the path to the content files will have changes. If it
was P:\ <Project Root Folder>\Standards\Content\Content, it could now be C:\
<Project Root Folder>\Standards\Content\Content. If the tool content root path
is redirected to the user’s C drive, and all content will remain valid.
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Later, when the drawings the user modified offline are copied back to the
main project on the P server, the content root path will automatically change
back to P:\ <Project Root Folder>\Standards\Content\Content, as this is the path
in the main APJ file.

Project Library

A Content Browser library can be set up on a shared network volume to be
accessed by all project users. The CAD manager or project owner can associate
the library with the project to have quick access to standard tools. This can
be especially useful on a large project. For more information, see Before You
Begin: Working in a Network Environment on page 316.

When Content Browser is opened from the Project Navigator, it will
automatically open the library associated with the project.

1 Click  ➤ Open ➤ Project.

2 Select the project for which you want to specify the tool palette
group and the Content Browser library, right-click, and click
Project Properties.
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3 Under Tool Palette Group, specify the location of the project tool
palette group. You can select a local folder or a network folder
here.

If you do not explicitly set a location here, the following default
behavior is selected depending on how you created your project:

Project Tool Palette
Group

Tool Palette File Loca-
tion

Project Type

Created, but not dis-
played. To display the tool

pointing to new empty
ATC file under \<Project-

Legacy project
from Autodesk

palette group in the toolName>\Standards\ Work-Architectural
Desktop 2005 palettes set and add toolsspaceToolPalettes\ <Project-

Name>.atc to it, see Displaying the
Project Tool Palette Group
on page 637 and Building
the Tool Palette Group on
page 639.

Adding a Project Library and Tool Palette Group | 635



Project Tool Palette
Group

Tool Palette File Loca-
tion

Project Type

Created, but not dis-
played. To display the tool

pointing to new empty
ATC file under \<Project-

New project
not based on
a template palette group in the toolName>\Standards\ Work-

palettes set and add toolsspaceToolPalettes\ <Project-
Name>.atc to it, see Displaying the

Project Tool Palette Group
on page 637 and Building
the Tool Palette Group on
page 639.

Created and displayed
with empty default tool

pointing to new ATC file
under \<Project-

New project
based on de-

palette. To add tools andName>\Standards\ Work-fault AutoCAD
palettes, see Building thespaceToolPalettes\ <Project-

Name>.atc.
By default, one empty tool
palette is already inserted
in ATC.

Architecture
template pro-
ject

Tool Palette Group on
page 639.

Displayed as either copied
tool palette group or refer-
enced tool palette group

If the tool palette group of
the template project is loc-
ated within the template

New project
based on user-
defined exist-

project folder, it will being template
project copied with all contained

palettes to the correspond-
ing folder of the new pro-
ject. The tool palette file
location of the new project
will point to the copied
tool palette group.
If the tool palette group of
the template project is loc-
ated outside the template
project folder, the tool
palette file location of the
new project will point to
the same location, sharing
the tool palette group with
the template project.
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4 For Project Tool Palette Group, select Shared Workspace Catalog
or Per User Workspace Catalog.

If you select Shared Workspace Catalog, the path selected under
Tool Palette File Location is added to the user’s project profile
(AWS), and the tool catalog is used from the specified location.
If you select Per User Workspace Catalog, a folder is created under
\\Documents and Settings\<User Name>\ and the tool palettes are
copied to that folder.

5 Under Tool Content Root Path, you can set a root path for the
tools used in the project tool palette group. When tools on project
palettes are created with the tool content root path specified in
the project setup, the content root path is created as a variable
(%AECPROJECT_DIR%). When the tool content root path in the
project setup is changed, and the referenced style drawings are
moved to the new location, the path of the project tools is
changed accordingly.

NOTE When a project is re-pathed, and the content root path is
within the project folder, then it will be re-pathed accordingly.

6 Under Content Browser Library, select the default Content Browser
library (CBL) to be displayed when opening Content Browser from
the Project Navigator.

7 Click OK.

Displaying the Project Tool Palette Group
Use this procedure to display the project tool palette group in the tool palettes
set.

Depending on the setting of the tool palette file location in Adding a Project
Content Browser Library and Tool Palette Group on page 344, the project tool
palette group can be displayed automatically after setting a project current
and closing Project Browser, or it can be empty and not be displayed on the
tool palettes set. The project tool palette group is displayed automatically
when it contains at least one palette.

Tool palette groups that are not automatically displayed can appear in the
following cases:

■ A new project that is not based on a template, and does not point to an
existing tool palette group
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■ A legacy project from Autodesk Architectural Desktop 2005 that is not
manually re-pointed to an existing tool palette group

■ A project that is based on a template project without project tool palettes

If an empty tool palette group is created for a project, it is not displayed in
the tool palettes set after the project is set current. To display it, you need to
add at least one tool palette to it.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Design Tools.

2 In the title bar of the tool palettes set, click  .

■ If the project tool palette group contains at least one palette,
it is displayed in the list of available tool palette groups, and
can be selected.

Selecting the project tool palette group

■ If the tool palette group of the current project is empty, it is
not displayed.

3 To display the project tool palette group, click  , and click
Customize.

On the left, all available palettes are listed. On the right, all palette
groups are listed. The empty project tool palette group is listed
there.
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4 Right-click in the palettes list on the left, and click New Palette.

5 Enter a name for the new palette.

6 Select the palette, and drag it on the project palette group on the
right.

7 Click Close, and click  again.

The project tool palette group is listed under the available palette
groups and can be selected.

Building the Tool Palette Group
When a new project is created, its associated tool palette group is empty,
unless the new project is explicitly pointing to an existing tool palette group.
You can add and remove palettes, add, remove, and rearrange tools to suit
the needs of the current project.

TIP To make sure that the changes you make here are distributed to all project
collaborators, you should define the tool palette storage type as a shared workspace
catalog.

IMPORTANT All new palettes you add to the tool palettes set while a project is
current are added to the current project’s tool palette group. This happens
regardless of whether the project tool palette group is active or not. In order to
add new palettes to the global tool palettes associated with your user profile, you
must first close any project that is current.

You can add standard tools to the project palette group in these ways:

■ Add standard tools from the project library

■ Add standard tools from the from standards drawings in Style Manager

1 Set the desired project current.

2 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Design Tools.

3 In the title bar of the tool palettes set, click  , and then select
the project tool palette group.
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Selecting the project palette group

4 Add and rename palettes as necessary.

For detailed information, see Creating a New Tool Palette on page
78.

5 To add standard tools from the project library, click  in the
Project Navigator toolbar.

The Content Browser is opened with the project library displayed.

6 Drag tools or palettes from the project library to the project palette
group.

7 To add standard tools from the standards drawings, open a project
drawing, and click Manage tab ➤ Style & Display panel ➤ Style

Manager  .

The project standards drawings are displayed under the project
node. You can drag-and-drop styles from the Style Manager to
the project palettes.

The next time you open the project, the new palettes and tools
will be present in the project tool palettes.
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Copying the Project Tool Palettes to the Tool Palette File
Location

If you are working with a per user workspace catalog, you can create a starter
set of palettes and tools for the project users by copying your palettes to the
project tool palette file location. The first time a user opens the project, the
tool palettes from the tool palette file location will be copied to the local users’
machines.

1 Set up project standards tools as described in Adding a Project
Library and Tool Palette Group on page 632 and Building the Tool
Palette Group on page 639.

2 Close AutoCAD Architecture.

3 In Windows Explorer, navigate to C:\Documents and
Settings\<username>\Application Data\Autodesk\ACA
2012\enu\Support\Profiles\ProjectCatalogs\.

4 Select the project catalog folder.

If you have just closed AutoCAD Architecture, the current project
folder is the one with the latest date. In addition, the folder is
named with the project GUID, which you can also find in the
project APJ file.

5 Copy the project catalog folder and paste it to the folder specified
as the tool palette file location for the project.

Adding the Project Profile to the Tool Palette File Location
After setting up the project tool palette group, the CAD manager or project
owner needs to ensure that new users of the project will all have an identical
set of tools and palettes when they are working with the project. To do this,
the project profile needs to be copied to the folder specified as the tool palette
file location.

1 Set up project standards tools as described in Adding a Project
Library and Tool Palette Group on page 632 and Building the Tool
Palette Group on page 639.

2 Close AutoCAD Architecture.

3 In Windows Explorer, navigate to C:\Documents and
Settings\<username>\Application Data\Autodesk\ACA
2012\enu\Support\Profiles\ProjectProfiles\.

4 Select the project AWS file.
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If you have just closed AutoCAD Architecture, the current project
profile is the one with the latest date. In addition, the AWS
contains the project GUID which you can also find in the project
APJ file.

5 Copy the project AWS file and paste it to the folder specified as
the tool palette file location of the project.

Adding Standards to a Project Drawing
If you set up standards for a new project, or add new drawings to an existing
project, standard styles and display settings do not yet exist in these drawings
and need to copied there.

If you have configured project standard tools as described in Setting up
Standard Tools in a Project on page 622, you can drag-and-drop them from the
project library or the project standards palettes to project drawings.

If you want to use standard styles and display settings in a project drawing
without using tools, you need to copy them through Style Manager and Display
Manager.

WARNING Project standard styles and display settings can be used only in project
drawings. You can copy standard styles and display settings into standalone
drawings as well; however, they will not be synchronized or versioned and maintain
no link to the project standards.

There are different methods of copying standard styles and display settings
to a drawing:

■ Project tool palettes can be defined, as described in Building the Tool
Palette Group on page 639. If the tools reference styles from standards
drawings, the associated standard style is copied to the project drawing
when the tool is executed.

■ A Content Browser library for the project can be defined, as described in
Adding a Project Library and Tool Palette Group on page 632. You can
drag-and-drop tools from Content Browser to a project drawing.

■ Standards drawings are displayed in the Style Manager and Display Manager
under the project node. You can drag-and-drop styles and display settings
into a project drawing from a project standards drawing.
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Project Tool Palette Group
When you create a project, a project palette group is associated with it. The
project palette group is displayed in the tool palettes set when the project is
set current. For information about creating a project tool palette group, see
Setting up Standard Tools in a Project on page 622.

Adding Standard Styles from the Project Tool Palettes
If you want to copy a standard style from a project palette into the current
drawing, you can either insert the tool into the drawing, or import the
associated style from the tool palette into the drawing.

1 Right-click the tool, and click Properties.

Verifying the style location

Under Style location, the associated style drawing is listed.

2 Verify that the tool points to a project standards drawing.

3 Click OK.

4 To add the standard style into the drawing, do one of the
following:

■ Select the tool, right-click, and click Import <Style Name>
<Object> Style. For example, if you want to add the wall style
CMU-190 into the drawing, click Import CMU-190 Wall Style.

■ Click the tool to execute its function which will automatically
use the referenced style.
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Both of these options add the style to the drawing.

Adding Standard Styles from Content Browser
The CAD manager can set up a library in Content Browser that contains
standard tools. Standard tools can be dragged from Content Browser directly
to a drawing or to a tool palette.

For information about associating a library for a project, see Adding a Project
Library and Tool Palette Group on page 632.

1 Set the project current, as described in Setting a Project Current
on page 327, and close the Project Browser.

2 Click View tab ➤ Palettes panel ➤ Project Navigator  .

3 In the Project Navigator toolbar, click  .

The Content Browser is opened with the project library displayed.

4 Select a standard tool by its eyedropper tool, and drag it either to
the drawing area of AutoCAD Architecture, or to one of the tool
palettes.

NOTE Be sure to hold down the mouse button until the eyedropper
appears to “fill up” before dragging it to the drawing or tool palette.

Adding Standard Styles from Style Manager
You can add standard styles to project drawings in Style Manager. When
standards drawings are specified in the project standards configuration, they
are displayed in Style Manager when you open a project drawing. Styles can
be dragged from the project node to the project drawing node here.
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Standard styles in Style Manager

1 Open the project drawing to which you want to add standard
styles.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The standards drawings specified in the standards configuration
are listed under the project node.

3 Expand the node for the project standards drawing containing
the style you want to add, and expand subnodes as necessary to
locate the style.

4 Drag the style from the project standards drawing node to the
project drawing node in the tree view.

The standard style is copied to the project drawing node.
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NOTE For the synchronization of the standard style to work, the style
needs to come from a standards drawing that has been selected as
a standards drawing for this style type in the configuration setup. For
example, if the standards drawing “Wall Styles.dwg” has been
configured as the standard for wall styles, and the standards drawing
“Door Styles.dwg” has been configured as the standards drawing for
door styles, you should not copy any wall styles from the “Door
Styles.dwg” to the project drawing. Because that drawing has not
been defined as the standards drawing for wall styles, the copied
styles will display as not standardized in the synchronization. For
information on configuring standards drawings, see Setting up
Standard Styles and Display Settings on page 609.

5 Click OK.

You can also drag styles from a project standards drawing into a drawing that
is not part of the current project. If the drawing is not part of any project, no
synchronization will happen to that style in the future. If the drawing is part
of a different project, the style will display as not standardized in future
synchronizations of that project, unless that project references the same
standards drawing from which the style was dragged.

Adding Standard Display Settings from Display Manager
You can add standard display settings to project drawings in the Display
Manager. When a standard display drawing is specified in the project standards
configuration, it is displayed in Display Manager under the project node. From
there, display configurations, display sets, and display representations can be
dragged to the project drawing nodes.
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Adding standard display settings from Display Manager

1 Open the project drawing to which you want to add standard
display settings.

2 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

The drawing that has been defined as display standards drawings
in the project standards configuration is listed under the project
node.

3 Expand the standards drawing node and navigate to the desired
type nodes for Configurations, Sets, and Representations by object.

4 Drag the component to the project drawing node in the tree view.

5 Click OK.

Synchronizing a Project with the Standards
When a project or project drawing is synchronized with its standards, the
styles and display settings in it are compared with the project standards to
find version discrepancies between them, and fix them.
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Synchronization can become necessary in these cases:

■ A style or display setting in a project drawing has changed and needs to
be updated with the correct version from the project standards.

■ A style or display setting in the project standards has changed and needs
to be updated in the project drawings.

■ Not standardized styles and display settings have been introduced in a
project drawing.

Depending on the synchronization settings specified in Setting up
Synchronization of AEC Standards on page 616, outdated standards in the
project drawings are either automatically updated with the latest version from
the project standards drawings, or you are presented with a list of objects that
need to be updated. You can select individual objects to update, while ignoring
others. If you select to update a style with the associated standard, the selected
style is copied from the project standards drawing into the project drawing,
overwriting the existing style definition.

NOTE Automatic synchronization of standard styles and display settings does not
happen during background plot/publish.

WARNING You should always synchronize the display settings in your project.
Version discrepancies between the display settings in the project drawings can
result in objects in project drawings not being displayed consistently. You also
need to make sure to synchronize all project standards drawings with the current
standard display settings, as described in Synchronizing Project Standards with
Each Other on page 690, to ensure consistent display in the standards drawings.

Synchronizing a project with standards
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Versioning Styles and Display Settings

To determine whether a standard style or display setting in a project drawing
is identical to the corresponding object in the project standards drawing, styles
and display settings in a project are versioned. The version information
includes a unique GUID (Global Unique Identifier), the date and time of the
last modification, the windows login name of who last modified the object,
and an optional comment.

A new version of a standard style or display setting in a project drawing is
created each time the style or display setting is changed in Style Manager or
Display Manager, and saved.

In a project standards drawing, a new version of a standard style or display
setting must be manually created after the style or display setting has been
changed in Style Manager or Display Manager. For information about
versioning standard styles and display settings, see Versioning Standards on
page 675. In project standards drawings, a version history is also stored. The
version history will be used to determine if styles or display settings in project
drawings are identical to the version in the project standards drawing, or
newer or older versions.

An older version of a style or display setting in a project drawing is a version
that exists in the project standards drawing, but is not the latest version. A
newer version of a style or display setting in a project drawing is a style or
display setting that exists in the project standards drawing, but has no
corresponding version in its version history.

A special case occurs if a standard style or display setting in a standards drawing
has no version information. This can happen if the version information has
been purged, as described in Purging the Version Information from a Project
Standards Drawing on page 689. In this case, the standard style or display
setting still participates in the synchronization and is considered the “latest
version” when comparing with versions of the object in project drawings. No
attempt is made during synchronization to automatically create a version
GUID or history list. If you want to add version information to the standard
style or display setting, you need to manually version the object as described
in Updating Standard Objects in a Project Standards Drawing on page 679.

Synchronization Conditions

Two styles or display settings are considered identical if the following are
identical:

■ Object type (e.g. wall style, display set)

■ Name
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■ Version GUID

If the synchronization process finds a style or display setting in a project
drawing that has the same type, name, and version GUID as the corresponding
style or display setting in the project standards, it concludes that the style or
display setting is up-to-date with the project standards. In that case, no change
is necessary.

NOTE A synchronization does not perform a property-by-property comparison
between the versions. The reason for this is that such a comparison would slow
down the software considerably, and that the GUID, date and time stamp in the
version information provides sufficient information to identify changes.

Synchronization Order

If you have multiple standards drawings containing the same standard styles
associated with a specific style type, then the instance of the style in the first
standards drawing is used as the style to which the style in the project drawing
is synchronized. The first standards drawing is the one listed on the left in
the standards configuration table. Further drawings containing the same
standard style are ignored.

650 | Chapter 9   Project Standards



Order of standards drawings

NOTE The order of the synchronization is observed in all cases, even if a later
project standards drawing contains a newer version of a standard style than the
one contained in the preceding standards drawing.

Dependent Styles

Some styles have dependent styles or definitions used to create them. This
could be, for example, door and window styles that are used within window
assembly or curtain wall styles. In a case like that, it is recommended that all
dependent styles and definitions are placed in the same standards drawing.

Synchronization Granularity

You can synchronize different parts of a project. You can synchronize a
complete project, an individual project drawing, or an individual style or
display setting.

Synchronizing only one drawing or style will take considerably less time, and
may often be sufficient.
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Synchronizing AutoCAD Standards

Synchronizing the AutoCAD standards (DWS) of a project is a separate process
from synchronizing the AEC standards of a project. While you can set the
AEC standards in a project to be automatically synchronized every time a
drawing is opened, synchronization of the AutoCAD standards has to be
initiated manually by the user. When AutoCAD standards are set up in a
project, a CHX file is automatically created containing the project drawings
and the associated AutoCAD project standards drawings. The batch standards
checker can be used to open the project’s CHX file and batch check the entire
project.

Synchronization Status
When you synchronize a project or a drawing with its AEC project standards,
the styles and display settings in the project drawings are compared with the
versions in the standards drawings. If the version of the style or display setting
in the project drawing is not identical to the version in the standards drawing,
you can choose from several possible actions regarding the style or display
setting.

Synchronization dialog

ActionDescriptionStatus

No action required. The object is in
synch with the standard.

The style or display set-
ting in the project draw-

Current standard
version

ing is identical to the
version in the project
standards drawing.
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ActionDescriptionStatus

You can choose from these actions:The style or display set-
ting in a project drawing

Older version of
standard style or dis-
play setting

■ Update from Standard: this
copies the version from the pro-is an older version than

ject standards drawing to thethe style in the project
standards drawing.

NOTE The version GUID
is used to determine
which version is more
current.

project drawing. The object in
the project drawing is overwrit-
ten.

■ Do not Update: The style or dis-
play setting is skipped for this
synchronization. The next time
the drawing is synchronized, it
will display as inconsistent with
the standards again.

■ Ignore: The style or display set-
tings is skipped now and for fu-
ture synchronizations.

NOTE If you choose this option, you
may choose to display ignored ob-
jects during each synchronization.

The style or display set-
ting in the project draw-

Nonstandard (New-
er) Version of stand-

ing is a version not foundard style or display
setting in the project standards

drawing’s version history.

The style or display set-
ting in the project draw-

Not standardized
style or display set-
ting

■ Skip: The not standardized ob-
ject is skipped for this synchron-
ization. The next time the pro-ing is not present in the

ject is synchronized, it will dis-
play as not standardized again.

project standards draw-
ings.

■ Ignore: The not standardized
object is skipped now and for
future synchronizations.

NOTE If you choose this option, you
may choose to display ignored ob-
jects during each synchronization.
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Synchronizing a Project with AEC Standards
When you have set up AEC project standards and enabled them, you can
synchronize the project with the standards.

For information about setting up AEC standards, see Setting up Standard Styles
and Display Settings on page 609.

Synchronizing a project will synchronize all drawings contained within.
Depending on your system setup and project size, this might take some time.
Also, project drawings that are open during the synchronization might not
be correctly synchronized because they will not be able to be saved after the
synchronization. In that case, the drawings need to be closed, and the
synchronization repeated.

NOTE Synchronizing a project will not synchronize the project standards drawings
with each other, even if they are located within the project folder. To synchronize
project standards drawings with each other, see Synchronizing Project Standards
with Each Other on page 690.

1 Verify that the project you want to synchronize is the current
project.

For information about setting a project current, see Setting a
Project Current on page 327.

2 Click Manage tab ➤ Project Standards panel ➤ Synchronize Project

 .

Synchronizing a project with AEC standards
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The synchronization dialog is displayed with two lists. The top
list shows styles and display settings that are either older versions
of standard styles or display settings, or nonstandard (newer)
versions. The bottom list shows a list of not standardized styles
and display settings. For a definition of terms, see Project
Standards Terminology on page 599.

3 To synchronize a style or display setting that is either an older
version or a nonstandard (newer) version, select Update from
Standards from the Action drop-down list.

4 To skip over a style or display setting that is either an older version
or a nonstandard (newer) version, select Do not Update from the
Action drop-down list.

In this case, the nonstandard version remains in the project
drawing for now, and is not updated with the standard. The next
time the drawing is synchronized, the style or display setting will
be listed again as inconsistent with the standard.

5 To ignore a style or display setting that is inconsistent with the
standard, select Ignore from the Action drop-down list.

In this case, the inconsistent object will not be listed again in
future synchronizations, except if you select Show objects set to
ignore during project standards synchronization, or remove the
Ignore flag from the style or display setting in Style Manager or
Display Manager, as described in Excluding Styles and Display
Settings from Synchronization on page 665.

WARNING You should use the Ignore option only in clearly defined
exception cases where you are sure that a style or display setting does
not need to conform to the project standards.

6 To skip over a not standardized style or display setting, select Skip
from the Action drop-down list.

The next time the drawing is synchronized, the style or display
setting will be listed again as not standardized.

NOTE You cannot promote not standardized styles and display
settings to standard ones here. To do this, you need to add the not
standardized style to the project standards, as described in Adding
Standard Objects from a Project Drawing to a Project Standards
Drawing on page 684.
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7 To ignore a not standardized style or display setting, select Ignore
from the Action drop-down list.

In this case, the not standardized object will not be listed again
in future synchronizations, except if you select Show objects set
to ignore during project standards synchronization, or remove
the Ignore flag from the style or display setting in Style Manager
or Display Manager, as described in Excluding Styles and Display
Settings from Synchronization on page 665.

8 Click OK.

Synchronization Exceptions
When you synchronize a complete project, drawings that are currently opened
by another user or are read-only will be excluded from the synchronization.
Before the synchronization of the project is started, the program runs an
internal check to see if there are drawings that cannot be synchronized at the
time. If such drawings are found, the Synchronization Warning worksheet is
displayed.

NOTE If a project drawing is opened by the same user who is trying to synchronize
the project, no error warning is displayed. The program will detect that the drawing
is open and will be able to make the synchronization changes to the open drawing.

If you get a warning message like this, you can either wait until all project
drawings are available to you, or you can synchronize the project now,
accepting that there are drawings that cannot be included.

1 Verify that the project you want to synchronize is the current
project.

For information on setting a project current, see Setting a Project
Current on page 327.

2 Click Manage tab ➤ Project Standards panel ➤ Synchronize Project

 .

If there are project drawings that are currently unavailable for
synchronization, you will receive the following warning message:

656 | Chapter 9   Project Standards



3 Click Synchronize to synchronize all project drawings not listed
in the warning worksheet.

4 When the Synchronization dialog is opened, follow the
instructions in Synchronizing a Project with AEC Standards on
page 654.

Synchronizing a Project Drawing with AEC Standards
Use this procedure to synchronize a project drawing with the AEC project
standards.

NOTE If you have selected automatic or semi-automatic synchronization in your
standards configuration, the synchronization is automatically started every time
you open the project drawing. For information on setting the synchronization
mode, see Synchronization Options on page 614.

1 Open the project drawing you want to synchronize.

2 Click Manage tab ➤ Project Standards panel ➤ Synchronize DWG

 .
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Synchronizing a project drawing with AEC standards

Two lists are displayed. The top list shows styles and display
settings that have corresponding styles or display settings in the
project standards, but are either an older version of a standard
style or display setting, or a nonstandard (newer) version. The
bottom list shows a list of styles and display settings that do not
have corresponding styles or display settings in the standards (not
standardized styles and display settings). For a definition of the
terms, see Project Standards Terminology on page 599.

3 To synchronize a style or display setting that is either an older
version or a nonstandard (newer) version, select Update from
Standards from the Action drop-down list.

4 To skip over a style or display setting that is either an older version
or a nonstandard (newer) version, select Do not Update from the
Action drop-down list.

In this case, the nonstandard version remains in the project
drawing for now, and is not updated with the standard version.
The next time the drawing is synchronized, the style or display
settings will be listed again as older version or nonstandard
version.

5 To ignore a style or display setting that is either an older version
or a nonstandard version, select Ignore from the Action drop-down
list.

In this case, the nonstandard version will not be listed again in
future synchronizations, except if you select Show objects set to
ignore during project standards synchronization, or remove the
Ignore flag from the style or display setting in Style Manager or
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Display Manager, as described in Excluding Styles and Display
Settings from Synchronization on page 665.

You should use the Ignore option only in clearly defined exception
cases where you are sure that a style or display setting does not
need to conform to the project standards.

6 To skip over a not standardized style or display setting, select Skip
from the Action drop-down list.

The next time the drawing is synchronized, the style or display
setting will be listed again as not standardized.

NOTE You cannot promote not standardized styles and display
settings to standard ones here. To do this, you need to add the not
standardized style to the project standards, as described in Adding
Standard Objects from a Project Drawing to a Project Standards
Drawing on page 684.

7 To ignore a not standardized style or display setting, select Ignore
from the Action drop-down list.

In this case, the not standardized object will not be listed again
in future synchronizations, except if you select Show objects set
to ignore during project standards synchronization, or remove
the Ignore flag from the style or display setting in Style Manager
or Display Manager, as described in Excluding Styles and Display
Settings from Synchronization on page 665.

8 Click OK.

Synchronizing Selected Styles and Display Settings with AEC
Standards

You can synchronize individual styles and display settings in Style Manager
and Display Manager. You could do this if you have accidentally changed a
style in the project drawing, and want to restore the correct version from the
project standards. Synchronizing an individual style or display setting will
take less time than synchronizing a drawing or the project.
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Standard styles in Style Manager

This process only synchronizes styles and display settings in a project drawing
with the standards. It does not synchronize styles and display settings in
different standards drawings with each other. For information on
synchronizing standards drawings among themselves, see Synchronizing
Project Standards with Each Other on page 690.

Standard Icons
Standard styles and display settings are displayed in Style Manager and Display
Manager. Depending on their status with regards to the project standards,
there are a number of different icons to differentiate them.

DescriptionIcon

Standard style or display setting
When a blue icon appears on a style or display setting in a project
drawing or project standards drawing, the style or display setting is a
standard one and is in synch with the standard. No update or synchron-
ization is necessary.

Standard style or display setting that is outdated
When this icon appears on a style or display setting in a project draw-
ing, the style or display setting is a standard one, but is out of date.
This means that the corresponding style or display setting in the project
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DescriptionIcon

standards drawing has a newer GUID than the one in the project
drawing. To update the style or display setting in the project drawing,
see Synchronizing Individual Styles with AEC Standards on page 664
and Synchronizing Individual Display Settings with AEC Standards on
page 664.

Standard style or display setting that has a non-standard (newer) ver-
sion
When this icon appears on a style or display setting in a project draw-
ing, the object is a standard object, but has a version GUID that cannot
be found in the project standards. If you encounter this icon, you can
either overwrite the non-standard version with the current version from
the standards drawing, as described in Synchronizing Individual Styles
with AEC Standards on page 664 and Synchronizing Individual Display
Settings with AEC Standards on page 664, or you can update the
standards with the version from the project drawing, as described in
Updating Standard Objects in a Project Standards Drawing from a
Project Drawing on page 682.

Standard style or display setting that is excluded from synchronization
When this icon appears on a style or display setting, the object is ex-
cluded from synchronization. For more information, see Excluding
Styles and Display Settings from Synchronization on page 665.

Standard style or display setting that has no version information
When this icon appears on a style or display setting in a project
standards drawing, the style or display setting has no version informa-
tion. Version information can be deleted, as described in Purging the
Version Information from a Project Standards Drawing on page 689.
To add version information to a style or display setting, see Updating
Standard Objects in a Project Standards Drawing on page 679.

Standard style or display setting that has been changed, but not ver-
sioned
When this icon appears on a style or display setting in a project
standards drawing, the object has been modified, but not versioned
yet. In order for the changes to be included in the synchronization,
the object must be versioned, as described in Updating Standard Ob-
jects in a Project Standards Drawing on page 679.
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DescriptionIcon

This icon appears only in project standards drawings. Changes in pro-
ject drawings are versioned automatically when you click Apply or OK
in Style Manager or Display Manager.

Not standardized style or display setting
When a gray icon appears on a style or display setting in a project
drawing, this object has no equivalent in the project standards, or (in
the case of styles) the equivalent style in the project standards has not
been associated with that style type in the project standards configur-
ation.
When this icon appears on a style in a project standards drawing, the
style type it belongs to has not been associated with the corresponding
standard style type in the project configuration setup. For example, if
the Wall style type in the standards configuration has been associated
with the Standards Drawing “Wall Styles 1.dwg” then the wall styles
in “Wall Styles 1.dwg” will be displayed as standard styles in the Style
Manager. The wall styles in “Wall Styles 2.dwg” will be displayed as
not standardized styles.

Overview: Styles in Project Drawings

You can synchronize individual styles in a project drawing.

■ All styles in a project drawing

■ Style Categories: You can synchronize all styles contained in a style
category. For example, you can synchronize all styles contained in
Documentation Objects, if you have made changes to property set
definitions, table styles, and data formats.

■ Style types: You can synchronize all styles belonging to a style type. For
example, you can synchronize all wall styles or all door styles.

■ Styles: You can synchronize individual styles. You could do this if you
have made a single change to a standard style, and do not want to start a
complete synchronization of the drawing.

Overview: Display Settings in Project Drawings

You can synchronize individual components of the display system in a project
drawing.
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Display Manager tree

■ All display settings in a project drawing: You can synchronize all display
settings in a project drawing. This includes display configurations, display
sets, and display representations.

■ Display configurations: You can synchronize either an individual display
configuration or all display configurations in the drawing.

NOTE A change to the cut plane is not a versionable change. If you change
the cut plane, and synchronize the display configuration with the project
standards, the changed cut plane will not be overwritten with the project
standard.

■ Display Sets: You can either synchronize an individual display set or all
display sets in the drawing,

NOTE Changes to the Live Section settings are not a versionable change. If
you change the Live Section settings, and synchronize the display set with the
project standards, the changed Live Section settings will not be overwritten
with the project standard.

■ Display representations: You can either synchronize an individual display
representation, all display representations of an object type, or all display
representations in the drawing.
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Synchronizing Individual Styles with AEC Standards
Use this procedure to synchronize styles in a project drawing.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 In the Style Manager tree, navigate to the style, style type, or style
category you want to synchronize.

3 Select the object in the tree, right-click, and click Synchronize
with Project Standards.

4 In the Synchronize Drawing with Project Standards dialog box,
select Update from Standard from the Action drop-down list for
each object that should be synchronized.

5 Click OK.

Synchronizing Individual Display Settings with AEC Standards
Use this procedure to synchronize display settings in a project drawing.

NOTE Display settings should always be synchronized with the latest standard
settings. Out-of-synch display settings in a project can cause objects to be displayed
inconsistently.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 In the Display Manager tree, navigate to the object you want to
synchronize.

You can synchronize the following objects:

■ All display settings in a drawing

■ all display configurations

■ single display configuration

■ all display sets

■ single display set

■ all display representations

■ all display representations of an object type

■ a single display representation on an object type
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3 Select the object in the tree, right-click, and click Synchronize
with Project Standards.

4 In the Synchronize Drawing with Project Standards dialog box,
select Update from Standard from the Action drop-down list for
each object that should be synchronized.

5 Click OK.

Excluding Styles and Display Settings from Synchronization
Use this procedure to specify individual styles and display settings that you
want to be ignored during synchronization.

Specified styles and display settings will not be overwritten with standards
during automatic synchronization and will not be displayed as version
mismatches during semi-automatic or manual synchronization, unless you
select the Show objects set to ignore during project standards synchronization
check box in the Synchronization dialog box.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager

or Display Manager  .

2 Navigate to the style or display setting to be excluded, right-click,
and click Ignore During Synchronization.

Note that the Ignore During Synchronization option now has a
check mark next to it. If you click the option again, the check
mark disappears and the selected style or display setting is removed
from the list of components to be ignored.

Generating a Synchronization Report
When you synchronize a project or a project drawing, you can save a
synchronization report in HTML or XML format.

You can define in the project setup whether a synchronization report should
be generated when synchronizing a project.

1 Verify that the creation of synchronization log files has been
activated in the project configuration, as described in Setting up
Synchronization of AEC Standards on page 616.

2 Synchronize a project or a drawing with its standards, as described
in Synchronizing a Project with AEC Standards on page 654 or
Synchronizing a Project Drawing with AEC Standards on page 657.
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When the synchronization is finished, the Save Project Standards
Report dialog box is displayed.

3 Select a file location and enter a name for the synchronization
report.

4 Click Save.

The report is saved as an HTML or XML document in the specified location.
You can open it with a Web Browser or an XML editor.

The report offers you various ways to display synchronization results; for
example, you can view the synchronization results by drawing, by standard
objects, or by problems encountered.

Synchronizing a Project with AutoCAD Standards
Use this procedure to synchronize a project with its AutoCAD standards. For
information on defining AutoCAD standards for a project, see Setting up
AutoCAD Standards on page 618.

When you set up AutoCAD standards for a project, a CHX batch checker file
with the project name is created in the project folder. The CHX file contains
a list of all project drawings as drawings to be checked, and a list of all specified
AutoCAD standards files (DWS) as files to check against. If you want to
synchronize a whole project against the AutoCAD standards, you need to run
this batch file using the AutoCAD Batch Standards Checker.

The AutoCAD Batch Standards Checker runs independently from AutoCAD
Architecture.
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Before you start the AutoCAD Batch Standards Checker, you should update
the project CHX file to make sure the CHX contains the current list of
AutoCAD standard files and project files.

1 Verify that the project you want to check is the current project.

For information on setting a project current, see Setting a Project
Current on page 327.

2 Click Manage tab ➤ CAD Standards panel ➤ Batch Checker.

A progress bar indicates the progress of the CHX update.

3 Click Start (Windows) menu ➤ All Programs (or
Programs) ➤ Autodesk ➤ AutoCAD Architecture 2012 ➤ Batch
Standards Checker.

4 Click File menu ➤ Open Check File.

5 In the File Open dialog box, select the project CHX file.

Batch Standards Checker

6 Click Check menu ➤ Start Check.

For more information about AutoCAD standards, see “Maintain
Standards in Drawings” in AutoCAD help.

Synchronizing a Project Drawing with AutoCAD Standards
Use this procedure to synchronize a project drawing with its associated
AutoCAD standards. AutoCAD standards include AutoCAD layer settings,
AutoCAD dimension styles, linetypes, and text styles.
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1 Open the drawing you want to synchronize with AutoCAD
standards.

2 Click Manage tab ➤ Project Standards panel ➤ Update  .

A progress bar indicates the progress of the CHX update.

3 Click Manage tab ➤ CAD Standards panel ➤ Check.

Under Problem, the first AutoCAD dimension style, text style,
layer, or linetype style that is inconsistent with the AutoCAD
standards of the project is listed.

4 To synchronize the component with the project standards, select
one of the styles listed under Replace with, and click Fix.

5 To retain the not standardized component in the drawing, click
Mark this Problem as ignored.

6 Click Next to display the next not standardized component.

When all problem components have been processed, a message
displays with a summary of the problems.

7 Click OK, and then click Close.

Auditing a Project or a Drawing
When a project or a drawing is audited, the styles and display settings in the
project drawing are compared with those of the project standards, and any
out-of-synch standards will be reported.
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Out-of-synch standards can appear in these cases:

■ A style or display setting in a project drawing has changed and needs to
be updated with the correct version from the project standards.

■ A style or display setting in the project standards has changed and needs
to be updated in the project drawings.

■ Not standardized styles and display settings have been introduced in a
project drawing.

You could for example run an audit on drawings that come from contractors,
or from other outside sources. Before you synchronize the drawings with the
project standards, you first want to look at what actually is different between
the drawings and the standards. For information on synchronizing standards,
see Synchronizing a Project Drawing with AEC Standards on page 657.

NOTE A drawing needs to be part of a project to be audited against project
standards. You cannot audit standalone drawings. If a drawing had been
outsourced, it needs to be copied back into the project before it can be audited.
For more information, see Converting a Drawing to a Construct on page 408.

The result of the audit is placed in an HTML or XML audit report.

1 To create an audit report for the project click Manage tab ➤ Project

Standards panel ➤ Audit Report  .

2 To create an audit report for the project drawing click Manage

tab ➤ Project Standards panel ➤ Audit Project Drawing  .

When the audit is finished, the Save Project Standards Report
dialog box is displayed.
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3 Select a file location and enter a name for the synchronization
report.

4 Click Save.

The report is saved as an HTML or XML document in the specified location.
You can open it with a Web Browser or an XML editor.

The report offers you various ways to display audit results; for example, you
can view the audit results by drawing, by standard objects, or by problems
encountered.

Showing Display Overrides in Project Drawings
To keep project drawings synchronized, it is important to control the properties
and display properties of building objects by style, to be able to update the
objects when the project standards change. Introducing object-level overrides
makes it impossible for the overridden objects to be updated through the
synchronization process when project standards change.

Use this procedure to detect object-level overrides on style-based objects in
the current drawing.

1 Click Manage tab ➤ Style & Display panel ➤ Show Display
Overrides.

NOTE Alternatively, enter AecShowDisplayOverrides on the
command line.

2 On the command line, enter a display option:

Then…If you want to…

enter O (byObject).highlight the overridden
objects in the drawing area.

enter S (byStyle)display a list of overridden
objects in the AutoCAD
command window

enter B (Both).highlight the objects and
display a list in the Auto-
CAD command window

3 Remove any object-level overrides.
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Editing Project Drawings Outside the Project
You need to work on a project drawing outside of a project in any of the
following cases:

■ A drawing is edited by an outside contractor.

■ A user wants to work on a drawing offline without access to the project.

■ A drawing has been created outside the project and is integrated into the
project later.

When you are working with a project drawing outside of a project, you can
use the drawing’s standard styles and display settings, but they cannot be
updated with changes that are made to the project standards during that time.
So it is important to synchronize the drawing after it has been re-integrated
into the project.

If you have made changes to standard styles and display settings in the project
drawing during working outside the project, a new version of the styles and
display settings is created automatically to track the changes when
synchronizing the drawing with the project standards. You can select to either
overwrite the new version with the current version from the project standards,
or you can update the project standards with the version from the project
drawing. For more information, see Synchronizing a Project Drawing with
AEC Standards on page 657 and Updating Standard Objects in a Project
Standards Drawing from a Project Drawing on page 682.

Creating a New Project Standards Drawing
Project standards drawings are assigned to a project, but are not project
drawings like elements, constructs, views, and sheets. The styles and display
settings in project drawings are compared with the standards and updated as
necessary during the synchronization process.

To create a project standards drawing, you need to create a drawing file or a
drawing template containing styles and display settings that should be used
in the project.

For example, you can create one drawing that contains the standard wall
styles, and another one that contains the standard door styles, or mask block
definitions.
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Project standard files can be of the file format DWG, DWT, or DWS. If you
select the DWS format for your standards drawings, you can simultaneously
use them as your AutoCAD standards drawings.

A project standards drawing is a regular drawing file. The definition of the
drawing as a project standards drawing is created when the drawing is added
as a project standards drawing to the standards configuration of a project, as
described in Setting up Standard Styles and Display Settings on page 609.

Styles vs. Display Settings

You can assign multiple standards drawings for project styles. During
synchronization, project drawings are compared against the project standards
drawings in the order you establish in the project standards configuration. If
a style is located in multiple standards drawings, the first instance in the search
order is used as the standard.

For display settings, you can assign only a single standards drawing. It must
contain all standard display settings for the project. Note, however, that the
same standards drawing can be used for both styles and display settings.

File Location of Project Standards Drawings

You can choose two different options for storing project standards drawings:

Project Folder

If the project standards drawings are located within the project, they are treated
as project specific. Typically, drawings containing project-specific standards
are stored inside the project folder. For example, if you create styles for only
one building project, you would place them in a project-specific standards
drawing within the project folder. Placing standards drawings under the project
folder has the following implications:

■ When you use the project as a template for a new project, the project
standards drawings are copied to the new project, and repathed to their
new location.

■ If you copy the standards of the project to another project, the project
standards drawings are copied to that project.

■ If you synchronize project standards drawings with each other, only
standards drawings within the project will be included in the
synchronization. For more information, see Synchronizing Project
Standards with Each Other on page 690.
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■ The standards drawings are included in e-transmit and archiving packages
created of the project.

You would place your standards drawings within the project if you want to
keep the standards drawings specific to that project. You can copy the standards
drawings to a new project, but any changes you make to one set of the
standards drawings will not be propagated to the other one.

A Folder Outside the Project

If project standards drawings are located outside the project, they are referenced
from that location. You would do this typically for standards that are not
specific to a project, but rather to the department or the company. In that
case, copying the standards to individual projects would create a risk of version
discrepancies being introduced in the multiple copies. Also, a change made
to a company-wide standards file would not be automatically propagated to
all projects using that standards file. Placing a standards drawing outside the
project has the following implications:

■ When you use the project as a template for a new project, the project
standards drawings are not copied to the new project. They are referenced
from their original location.

■ If you copy the standards of the project to another project, the project
standards drawings are referenced from their original location in the other
project.

■ If you synchronize project standards drawings with each other, standards
drawings outside the project will not be included in the synchronization.
For more information, see Synchronizing Project Standards with Each
Other on page 690.

■ The standards drawings outside the project folder are not included in
e-transmit and archiving packages created of the project. For more
information, see Electronically Transmitting a Project on page 352.

1 Open a new drawing file.

2 Add the standard styles and display settings you need in this
project.

For more information, see Style Manager on page 869, Display
System on page 791, and the relevant object chapters.
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3 Save the drawing as DWG, DWT, or DWS format.

Then…If you want to…

save it within the project folder.

NOTE You can create subfolders
for standards drawings.

make the standards drawing
specific to a project

save it outside the project folder.make the standards drawing
available for general use within
the company or team

4 Associate the standards drawing with a project, as described in
Setting up Standard Styles and Display Settings on page 609.

Updating Project Standards Drawings
When a standard style or display setting changes during the lifecycle of a
project, it needs to be versioned, saved, and then updated in the project
drawings and the other project standards drawings.

A standard component can be either changed directly in the standards drawing,
or be updated from a project drawing. For more information, see Updating
Standard Objects in a Project Standards Drawing on page 679 and Updating
Standard Objects in a Project Standards Drawing from a Project Drawing on
page 682.

Updating AEC project standards drawings
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Process Overview: Updating AEC Standards in a Project
When a change is made to an AEC project standard, the following high-level
steps need to be performed throughout the project:

1 Make a change to a standard style or display setting in a project
standards drawing.

2 Version the changed style or display setting in Style Manager or
Display Manager, and save or close the standards drawing. For
more information, see Versioning Standards on page 675.

3 Synchronize the project, individual project drawings, or individual
styles or display settings with the changed standard. For more
information, see Synchronizing a Project with the Standards on
page 647.

4 It is recommended that you synchronize all other project standards
drawings with the change. For more information, see
Synchronizing Project Standards with Each Other on page 690.

Versioning Standards
Styles and display settings in project standards drawings and project drawings
have a version. The version is used to determine whether a style or display
setting needs to be synchronized. The version information includes a unique
GUID (Global Unique Identifier), the date and time of the last modification,
the Windows login name of the user who last modified the object, and an
optional comment.

Version Comparison

When a project is audited or synchronized with its standards, the comparison
of the versions determines whether styles and display settings in the project
are identical, older, or newer than the project standard.

Styles or display settings are considered identical to the project standards if
the following are identical:

■ Object type (such as Wall style or display set)

■ Name

■ Version GUID
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For determining whether a style in a project drawing is identical to a project
standard style, the GUIDs of both are compared. The GUID is a unique string
that is newly created for each version of a standard object. In the project
standards drawing, a list of previous GUIDs is kept as a version history to
enable comparison with objects in a project drawing.

If the synchronization process finds a style or display setting in a project
drawing that has the same type, name, and version GUID as the corresponding
style or display setting in the project standards drawing, it concludes that the
style or display setting is a standard one, and in synch with the object in the
project standards drawing. In that case, no change is necessary.

If the comparison finds that the GUID in the project drawing does not match
the GUID of the style in the project standards drawing, but matches a previous
GUID from the standard style version list, it labels the style in the project
drawing an “older version of a standard style.”

If the comparison finds a style or display setting that matches a standard object
in name and object type, but has a GUID not appearing in the version history
of the standard style or display setting, the style or display setting in the project
drawing is labeled “nonstandard (newer) version of standard object.”

NOTE Synchronization does not perform a property-by-property comparison
between the versions. The reason for this is that such a comparison would slow
down the software considerably, and that the GUID, date and time stamp in the
version information provides sufficient information to identify changes.

Creating Versions

A new version of a standard style or display setting in a project drawing is
created automatically each time the style or display setting is changed in Style
Manager or Display Manager.

A new version of a standard style or display setting in a project standards
drawing must be created manually when the style or display setting is changed
in Style Manager or Display Manager. In project standards drawings, a version
history for each standard style and display setting is also stored. The version
history is used during synchronization to determine if styles or display settings
in project drawings match the versions in the project standards drawing, or
are newer or older versions.

Versioning Exceptions for Display Settings in Project Standards Drawings

There are a few cases where modifications to the display settings will not be
automatically versioned, as this will in most use cases not be a desirable effect.
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Some settings will routinely vary from the standards drawing, so these settings
will not be included in the automatic versioning process.

■ Display Configuration: Cut Plane

■ Display Set: Surface Hatch on/off

■ Display Set: Live Section on/off

■ Wall display: wall graph toggle on/off

Version History

Standard styles and display settings in project standards drawings contain a
version history for changes made to them during the project. You cannot roll
back to a previous version of a standard object. The version history is only
used to determine the current state of standard styles and display settings.

Change Types in Project Standards Drawings
Different types of changes you can make to project standards require different
actions to be applied throughout the project.

Actions requiredChange Type

Modifying a standard style or display
setting

■ Version style or display setting

■ Save project standards drawing

■ Synchronize project drawings

■ Synchronize other project standards drawings
(optional)

Renaming a standard style or display
setting

■ Rename style or display setting

■ Save project standards drawing

■ Copy style or display setting to project
drawings

■ Assign style or display settings in project
drawing

■ Remove older name version from project
drawings
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Actions requiredChange Type

NOTE Renaming a style is not considered a
modification to the style and cannot be synchron-
ized.

Adding a new standard style or dis-
play setting

■ Create new style or display setting

■ Save project standards drawing

■ Copy style or display setting to project
drawings

■ Copy style or display setting to other project
standards drawings (optional)

Deleting a standard style or display
setting

■ Verify that the style or display setting is not
needed anymore in the project

■ Delete style or display setting

■ Save project standards drawing

■ Remove style or display setting from project
drawings

Modifying a standard style or display setting: When you make a modification
to a standard style or display setting (except for renaming), you need to
synchronize the project drawings that use the style or display setting. If the
standard style or display setting is used in other project standards drawings,
they need to be synchronized, too.

Renaming a standard style or display setting: Renaming a style or display
setting is similar to creating a new style. The previous version history of the
renamed style remains. If you want to use the renamed object in a project
drawing or in another project standards drawing, you need to copy it there.
Any instances of the older name in a project drawing or a project standards
drawing should be deleted.

Adding a new standard style or display setting: If you have added a new
standard style or display setting to a standards drawing and want to use the
style in a project drawing or in another project standards drawing, you need
to copy it through Style Manager and Display Manager or through tool palettes
to these drawings. For information on copying styles and display settings to
project drawings, see Adding Standards to a Project Drawing on page 642. Once
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it has been copied, the new style or display setting will be included in future
synchronizations.

Deleting a standard style or display setting: When you remove a standard
style or display setting from a standards drawing, instances of that style in
project drawings will be identified as not standardized in subsequent
synchronizations. The not standardized instances should be removed from
these drawings, as well.

NOTE Standard styles and display settings can only be deleted in their standards
drawings. The synchronization does not delete unused standard styles or display
settings.

Updating Standard Objects in a Project Standards Drawing
You can change a standard style or display setting in a project standards
drawing. When a change has been made, you must version it and then
synchronize the project with the change.

When you change a standard style or display setting directly in the standards
drawing, you do not need to version every single change. Many changes may
be necessary to create a standard style or display setting in its final form; to
create a version for every intermediate stage would slow down the process.
unnecessarily.

You can make multiple changes, save and close the drawing, reopen it, and
then version the style or display setting when it is ready for propagating in
the project. As long as the changes are saved to the project standards drawing,
no edits will be lost, even without versioning in between.

WARNING As long as your changes are saved, but not versioned, any
synchronizations taking place during that time will not recognize the styles and
display settings as changed, since the object comparison is performed on the
version GUID, and not the actual object properties. As a consequence, changed
but unversioned styles and display settings in the project standards will not be
updated in the project drawings. To have the changes synchronized with the
project, you need to version the styles or display settings first.

To make changes to a project standards drawing, you must have write access
to the drawing. If a standards drawing is read-only, it is marked with a Lock

icon (  ) in Style Manager or Display Manager. You can make changes to
that drawing, but you cannot save them. If you need to make changes to a
locked drawing, contact the drawing owner or CAD manager.
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Standards drawings and standard styles under the project node

Changing a standard style or display setting

1 Open a project standards drawing.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager

or Display Manager  .

TIP All standards drawings are listed under the project node in Style
Manager and Display Manager.

3 Select the style or display setting you want to edit, and make your
changes.

Versioning changed styles and display settings

4 Click the Version History tab of the changed style or display
setting.
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5 Click Version.

6 If necessary, enter a comment for the new version.

7 Click OK.

The new version is appended to the Version History tab.

8 To version multiple styles or display settings in a project standards
drawing, select a group of objects and version them:

Updating Standard Objects in a Project Standards Drawing | 681



9 Select the styles or display settings that should be versioned.

10 If desired, enter a comment.

The comment will be applied to all objects selected for versioning.

11 Click OK.

NOTE To version all styles and display settings in a drawing, click

Manage tab ➤ Project Standards panel ➤  ➤ Apply Versioning
To Current Drawing.

Updating Standard Objects in a Project Standards Drawing from
a Project Drawing

You can change a standard style or display setting in a project standards
drawing by overwriting it with the corresponding style or display setting from
a project drawing. When you have updated the project standard from a project
drawing, the project needs to be synchronized to use the updated styles and
display settings. For information, see Synchronizing a Project with the
Standards on page 647.

NOTE Before you change a project standard from a project drawing, you should
verify that this is the correct procedure. Once the project standard has been
changed, the style or display setting will be updated in all project drawings during
the next project synchronization, if automatic synchronization is selected.
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To make changes to a standards drawing, you must have write access to the
drawing. If a standards drawing is read-only, it is marked with a Lock icon (

 ) in Style Manager or Display Manager. You can make changes to that
drawing, but you cannot save them. If you need to make changes to a locked
drawing, contact the drawing owner or CAD manager.

1 Open a project drawing from Project Navigator.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager

or Display Manager  .

3 Expand the node of the project drawing, and select the standard
style or display setting with which you want to update the project
standards.

NOTE A standard style or display setting in a project drawing is
marked with a blue icon. If a style or display setting is displayed with
a gray icon, it is not a standard style or display setting. In that case,
you can add it to the project standards, as described in Adding
Standard Objects from a Project Drawing to a Project Standards
Drawing on page 684.

4 Right-click, and click Update Standards from Drawing.

NOTE You can select multiple objects here.

The selected style or display setting is listed in the top panel.
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5 To update the project standards from a style or display setting in
the project drawing, select Update Project Standards from the
Action drop-down list of the style or display setting.

6 To not update the project standards from a style or display setting
in the project drawing, select Do not Update Project Standards
from the Action drop-down list of the style or display setting.

In this case, the version in the project standards is not overwritten
with the version in the project drawing. During the next
synchronization of the project drawing, the style or display setting
will be displayed as out of synch with the project standards.

7 To ignore the out of synch version of the style or display setting,
select Ignore from the Action drop-down list.

In this case, the style or display setting will not be displayed in
future updates, except when you select Show objects set to ignore
during project standards synchronization or remove the Ignore
flag from the style or display setting in Style Manager or Display
Manager, as described in Excluding Styles and Display Settings
from Synchronization on page 665.

8 Click OK.

9 In Style Manager or Display Manager, click OK or Apply.

10 Click Yes to save the updated project standards drawing.

Adding Standard Objects from a Project Drawing to a Project
Standards Drawing

You can add not standardized styles or display settings from the current project
drawing to the project standards. You can do this, for example, if you have
created a complex style in a project drawing and want to include that in your
standards.

If you want to add a style to the project standards in this way, in addition to
copying the style to the standards drawing you need to verify that the style
type in question has been selected for that standards drawing in the project
configuration. Otherwise, it will not be used as a standard. For example, if
you copy a wall style from a project drawing to the standards drawing
“Standards 1.dwg,” you need to make sure that in the project configuration
the Wall Style type has been checked for “Standards 1.dwg.” For more
information, see Setting up Standard Styles and Display Settings on page 609.
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After copying a style or display setting to the project standards, you need to
synchronize the project to use the new standard object.

1 Open a project drawing from Project Navigator.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager

or Display Manager  .

3 Add a new style or display setting to the current project drawing.

4 Select the new style or display setting, right-click, and click Update
Standards from Drawing.

NOTE You can select multiple items here.

The new style or display setting is listed in the lower panel, which
displays styles and display settings in the project drawing that do
not exist in the project standards.

5 To add the style or display setting to a project standards drawing,
and thereby make it a standard style or display setting, select Add
to Project Standards in the Action drop-down list.

NOTE If you are adding a display setting to the project standards, it
is added to the display standards drawing. If you are adding a style
to the project standards, it is added to the first project standards
drawing in the search order that has been associated with that style
type in the project standards configuration, as described in Setting
up Standard Styles and Display Settings on page 609.
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6 To skip over the not standardized style or display setting select
Skip from the Action drop-down list.

In this case, the not standardized object remains in the project
drawing, and is not entered in the standards.

7 To ignore the style or display setting, select Ignore from the Action
drop-down list.

In this case, the not standardized object will not be listed again
in future updates, except if you select Show objects set to ignore
during project standards synchronization or remove the Ignore
flag from the style or display setting in Style Manager or Display
Manager, as described in Excluding Styles and Display Settings
from Synchronization on page 665.

8 Click OK.

9 In Style Manager or Display Manager, click OK or Apply.

10 Click Yes to save the updated project standards drawing.

Editing the Version History of a Standard Object
Each style and display setting in a project standards drawing has a version
history. The version history displays the unique version identifier (GUID),
date and time of the modification, user name and any additional comments
entered by the user.

You can edit the history by selectively removing individual versions, or
removing all versions.

1 Open a project standards drawing.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager

or Display Manager  .

3 Select the standard style from the project standards node of the
tree.

4 Click the Version History tab.
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5 To add a new version, click Version, and enter the versioning
information.

6 To remove an existing version, select the version from the Version
History list, and click Remove.

To remove all versions in one step, click Remove All.

7 If you want the style or display setting to be ignored during
synchronization of standards, select Ignore during project
standards synchronization.

8 Click OK.

Versioning a Project Standards Drawing
You can version all styles and display settings in a project standards drawing
in a one step.

1 Open a project standards drawing.

2 Click Manage tab ➤ Project Standards panel ➤  ➤ Apply
Versioning To Current Drawing.
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3 Select the styles or display settings that should be versioned.

4 If desired, enter a comment.

The comment will be applied to all objects selected for versioning.

5 Click OK.

Purging the Version History from a Project Standards Drawing
You can remove the version history from all standard styles and display settings
in a project standards drawing with one command. Purging the version history
will remove all versions except the current one from the standard styles and
display settings. You can do that to avoid cluttering your styles and display
settings.

When you purge the version history, no version GUID except for the current
one remains. That means that the synchronization can no longer distinguish
between an older version of a standard style and a non standard version of a
style. Each style in a project drawing that does not have the current GUID of
the corresponding standard style, will be labeled a “non-standard,” or newer
version.

1 Verify that the project with which the project standards drawing
is associated is the current project.

2 Open the Project Standards drawing from which you want to
purge the version history.
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NOTE Project standards drawings do not appear on the Project

Navigator. You need to open them by clicking 
 ➤ Open ➤ Drawing.

3 On the command line, enter AecClearVersionHistory.

The version history is removed from all standard styles and display
settings in the drawing.

Purging the Version Information from a Project Standards
Drawing

You can remove the version information from all standard styles and display
settings in a project standards drawing. When you remove the version
information, the version history and the current version information is deleted.

When you run a synchronization, the standard style or display setting still
participates in the synchronization and is considered the latest version when
comparing with versions of the object in project drawings. No attempt is made
during synchronization to automatically create a version GUID or history list.
If you want to add version information to the standard style or display setting,
you need to manually version the object as described in Updating Standard
Objects in a Project Standards Drawing on page 679.

1 Verify that the project with which the project standards drawing
is associated is set current.

2 Open the project standards drawing from which you want to
remove the version information.

NOTE Project standards drawings do not appear on the Project

Navigator. You need to open them by clicking 
 ➤ Open ➤ Drawing.

3 On the command line, enter AecPurgeVersion.

The version information is removed from all standard styles and
display settings in the drawing.
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NOTE To re-add a version to all styles or display settings in the
drawing, open Style Manager or Display Manager, select the drawing
in the tree, right-click, and click Version Drawing.

Synchronizing Project Standards with Each Other
Project standard styles and display settings can be distributed among multiple
standards drawings, and depend on each other. For example, the styles in a
styles drawing should use the display settings from the standard display
drawing. If display changes are introduced in a standard styles drawing, and
not synchronized with the standard display drawing, styles can display
inconsistently across the project. Therefore, you should synchronize project
standards drawings with each other when changes have been made to
individual standards drawings.

You can synchronize project standards drawings among themselves either
from the project standards node in Style Manager and Display Manager, or
from the CAD Manager menu.

When project standards drawings are synchronized among themselves, the
following criteria are used to determine how the objects are updated:

■ Standards drawing type: The display settings in the Standards display
drawing update the display settings in all standard styles drawings.

■ Assigned style types: When a drawing has been associated with a style type
in the standards configuration setup, the styles in this drawing will update
all other standards drawings that may contain standard styles of that type.
For example, if the standards drawing “Door Styles.dwg” has been
associated with the Door style type, the styles in that drawing will overwrite
any existing door standard styles in all of the other standards drawings.
Note that in most cases, you will not place standard styles anywhere but
in the designated standards drawing for that style type.

■ Search order: When more than one standards drawings in the standards
configuration setup have been associated with a style type, the first
standards drawing in the search order will update all other drawings
associated with that style type.

Synchronizing project standards drawings among themselves is an automatic
synchronization process, where no user interaction is possible. That means
that no styles or display settings can be excluded from the synchronization
process.
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1 Verify that the project of which you want to synchronize the
standards is the current project.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager

or Display Manager  .

3 Select the project node in the tree view, right-click, and click
Synchronize Project Standards Drawings.

4 When the synchronization is finished, click OK to exit Style
Manager or Display Manager.

NOTE Alternatively, you can click Manage tab ➤ Project Standards

panel ➤  ➤ Synchronize Project Standards  .

Editing Project Standards Drawings Outside the Project
You can edit project standards drawings outside the current project. This could
happen, if you need to work offline, without access to the project, or if you
want to work on a project standards drawing that is not part of the current
project.

The following high-level steps are necessary to edit a project standards drawing
outside of a project:

1 If necessary, copy the project standards drawing to an offline
location outside the project.

2 Open the project standards drawing, and open Style Manager or
Display Manager.

3 Edit the styles or display settings as necessary.

NOTE If the style or display setting you are editing already has a
version history within the project, the version history is displayed in
Style Manager or Display Manager.

4 Upon closing Style Manager or Display Manager, you are prompted
to version changed styles or display settings. Version them just
like you would within the project.

5 Save and close the project standards drawing.

6 If necessary, copy the project standards drawing back to the
project.
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7 Set the project current, and start a synchronization to propagate
the changed styles and display settings to the project.

Scripting Project Standards Commands
Commands can help you automate the standards in your project by scripting
your workflows and processes. The following commands are available for the
project standards feature:

DescriptionCommand

Launches the Configure AEC Project Standards dialog
box for the current project. For more information,
see Configuring Project Standards on page 609.

AecProjectStandards

Synchronizes the current drawing with the project
standards.

TIP To run this command without user interaction,
make sure the automatic synchronization option is
selected, as described in Setting up Synchronization
of AEC Standards on page 616.

AecSynchronizeProjectDrawing

Synchronizes the current project with the project
standards.

TIP To run this command without user interaction,
make sure the automatic synchronization option is
selected, as described in Setting up Synchronization
of AEC Standards on page 616.

AecSynchronizeProject

Audits the current drawing against the project
standards. For more information, see Auditing a
Project or a Drawing on page 668

AecAuditProjectDrawing

Audits the current project against the project
standards. For more information, see Auditing a
Project or a Drawing on page 668

AecAuditProject

Identifies objects in the current drawing that have
their display properties overridden at the object level.

AecShowObjectDisplayOverrides

For more information, see Showing Display Overrides
in Project Drawings on page 670.
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DescriptionCommand

Versions all modified styles and display settings in
the current drawing. For more information, see Up-

AecVersionModifiedObjects

dating Standard Objects in a Project Standards
Drawing on page 679.

NOTE This command works only with project
standards drawings.

Generates a tracking report for the project standards
setup. For more information, see Generating a Pro-
ject Standards Setup Report on page 622.

AecProjectStandardsSetupReport

Updates the project standards with the styles and
display settings from the current drawing. For more

AecUpdateStandards

information, see Updating Standard Objects in a
Project Standards Drawing from a Project Drawing
on page 682.

Purges the version information from all styles and
display settings in the current drawing. For more

AecPurgeVersion

information, see Purging the Version Information
from a Project Standards Drawing on page 689.

NOTE This command works only with project
standards drawings.

Purges the version history from all styles and display
settings in the current drawing, except for the cur-

AecClearVersionHistory

rent version. For more information, see Purging the
Version History from a Project Standards Drawing
on page 688.

NOTE This command works only with project
standards drawings.

Synchronizes the project standards drawings of the
current project among themselves. For more inform-

AecSynchronizeStandards

ation, see Synchronizing Project Standards with Each
Other on page 690.

Updates the project's CAD Standards Batch Stand-
ards Checker CHX file. It also updates the CAD

AecUpdateProjectCADStandards
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DescriptionCommand

Standards file associations with each drawing in the
current project.

NOTE  The commands for the Drawing Management feature can also be useful
for creating scripts for project standards. For more information, see Drawing
Management Commands on page 562.
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Drawing Compare

An efficient review of drawings and revisions is key as you move through the design,
development, and construction phases of a project. The Drawing Compare feature makes it
easier and faster to compare versions of drawings visually and review proposed changes. In
addition to AutoCAD Architecture, Drawing Compare also allows you to compare drawings
from AutoCAD®, Revit MEP, Revit Architecture, and Revit Structure.

Overview of Drawing Compare
A typical project requires multiple reviews as you produce drawings and add
supplemental information. Drawing Compare compares review drawings to
project drawings. The original drawings are the project drawings. The drawings
that are revised and ready for evaluation are the review drawings.

The comparison process is like how drawings were compared when they were
received on tracing paper or Mylar sheets and then overlaid on the original
project drawings. Drawing Compare displays informational data about the
objects in your drawing as well as displaying the graphical changes on the
drawing screen.

You select the review drawings and compare each to its corresponding project
drawing on the Setup tab of the Drawing Compare palette. After the comparison,
you view the results on the Review tab of the Drawing Compare palette and in
the drawing area.

Drawing Compare identifies objects that have been modified, added, or removed
in the review drawings. Based on the status of the objects (modified, new, or
missing), colors are assigned, and a list of the changes is generated.

10
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Drawing Compare palette

In the following example, a simple floor plan was modified to show what
information Drawing Compare displays during a comparison session. The
review drawing shows that changes to the project drawing include moving
the lower vertical interior wall segment to the left (resulting in a shorter
horizontal interior wall segment), adding an exterior door to the right exterior
wall segment, and removing a window from the upper exterior wall segment.
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When the drawings are compared, color-coded changes are displayed, based
on the type of change.

Information about changes is also displayed in the Object Report List on the
Review tab.

File Organization for Drawing Compare

AutoCAD Architecture projects (the drawing management feature) provide
automated tools to aid in the management, viewing, and construction of a
building. Although it is not necessary for your drawings to be in a structured
project, Drawing Compare works best when they are. When you are working
in a project environment, Drawing Compare recognizes the Autodesk Project
Information (APJ) file that identifies the collection of drawing files as being
organized in a project. For more information about managing drawings in
projects, see Workflow for a Project Environment on page 303. Different people
on the team can access, share, and redirect project and review drawings in
top-level folders in a project setting. For more information, see Working with
Design Teams Located Remotely on page 321.

If you are not working with a structured project in AutoCAD Architecture,
organize original drawings in project folders, and organize the revised drawings
for review in review folders. The project drawings must all be contained within
the same top-level folder to provide the correct context to perform the
comparison. You specify these source folders for both Project and Review
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folders when you start Drawing Compare. Your drawings may be loosely
organized as plans, elevations, and sections and look like this:

General Guidelines for Comparing Drawings

Drawing Compare only works in model space. If a drawing selected for
comparison was saved in paper space, Drawing Compare automatically switches
to the model tab. Because the content of sheets is exclusive to paper space,
Drawing Compare does not display sheets in the list of project drawings in
the Select Project Drawing pane.

Drawing Compare creates a snapshot of current drawing conditions. If you
make changes, such as modifying project entities or changing the annotation
scale while the review process is active, the results of the changes do not
display until you run a new comparison.

During a Drawing Compare session, the drawing open on your screen is the
project drawing with a screened image of the review drawing overlaid. Any
changes you make are made in the project drawing. You can save changes
you make to this project drawing, but you cannot merge review drawings with
project drawings or modify review drawings.

Drawing Compare is not an integration tool. After the Drawing Compare
process is complete and differences between the drawings are compiled, review
drawings are not automatically integrated into your project. You are responsible
for manually integrating and copying review drawings and all of their
associated files (xref and image files, for example) to their appropriate locations.

IMPORTANT The data collected from the comparison is not saved. When you
exit Drawing Compare, the results of the comparison are discarded.

Starting a Drawing Compare Session
The Setup tab of the Drawing Compare palette is where you specify the context
in which drawings are matched and analyzed. Under Select Folders, the review
folder contains updated or revised drawings, and the project folder contains
the original version of the drawing files. All the project drawings must be
contained within the same top-level folder to provide the correct context. For
more information, see File Organization for Drawing Compare on page 697.
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The matching and analyzing process looks at each review drawing to verify
whether it is a modified version of a project drawing. If so, the 2 drawing files
are matched. For more information, see General Guidelines for Comparing
Drawings on page 698.

1 Click  ➤ Utilities ➤ Drawing Compare.

2 On the Setup tab, for Review Folder, click Browse  , navigate
to the folder containing project drawings, and select it.

Drawing files in this folder are displayed alphabetically in the
Select Review Drawing pane. These files include host drawings
and any drawings nested within them as external references
(xrefs).

3 For Project Folder, click Browse  , navigate to the folder
containing project drawings, and select it.

The Confirm Automatic Matching and Analyzing dialog displays.
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NOTE The automatic matching and analyzing option is strongly
recommended for most use cases. Match drawings manually only
when a review drawing has been renamed, or if you want to compare
a smaller set of drawings.

4 Match review drawings to project drawings.

Then…If you want to…

click Yes.
The Automatically Matching and Analyzing
Drawings progress bar displays. The software
matches drawings by file name.

let Drawing Compare
automatically match all
the review drawings
against all of the project
drawings in these folders

click No, and under Select Folders, browse
to the folder that contains project drawings

select a different project
folder for Project Folder

for Project Folder. Click Yes when the Con-before automatically
matching firm Automatic Matching and Analyzing dia-

log displays.
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You can also selectively match drawings:

Then…If you want to…

click No, and in the Select Review Drawing
pane, right-click the drawings or drawing

select specific draw-
ings/folder for automatic
matching folder to be matched, and select Automatic-

ally Match.

click No, and in the Select Review Drawing
pane, select a drawing, and drag it onto a
drawing in the Select Project Drawing pane.
When you manually match drawings with
different names, a relationship is established

match drawings manually

between the drawings. This affects what dis-
plays when you use the filter mode for the
Project folder.

click No. In the Select Review Drawing pane,
right-click the drawings or drawing folder to

exclude specific drawings
from matching

be excluded, and clear Include in Comparis-
on.

NOTE If you choose to exclude draw-
ings from a comparison, objects in ex-
cluded drawings will appear as unmod-
ified after the comparison. This allows
you to focus on a smaller, more manage-
able set of modifications.

A file excluded from a comparison will act as
if it, and all its xrefs, are exact copies of the
originals. Objects in excluded files (or xrefed
by excluded files) will appear as unmodified.
You should exclude files that you do not want
to include in a comparison.

NOTE Architectural Desktop R14 drawings or earlier versions may
not match automatically, but they can still be compared. You can
either update the older drawings by saving them in the 2007 format,
or you can match them manually.
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After project and review drawings have been matched, icons next
to the drawing name indicate status of the drawings as follows:

DescriptionIcon

No match attempted yet. This is the initial state of all
review drawings.

A review drawing is matched but is not selected.

A review drawing that is matched and selected.

A project drawing for which a matched review drawing
is selected.

No match for a review drawing is found.

A review drawing that was specifically excluded from
comparison by the user.

The date the selected drawing file was modified and the name of
the person who made the modifications displays when you select
a drawing from the review or project folder.

5 If desired, the drawings in the Review folder can be reset from
matched to unmatched. This undoes an incorrect or inadvertent
match, removing the match relationship.

702 | Chapter 10   Drawing Compare



■ You can un-match all review drawings at once by selecting
the top-level folder in the Select Review Drawing pane,
right-clicking, and clicking Un-Match All.

■ You can un-match a single review drawing by selecting the
drawing, right-clicking, and clicking Un-Match.

6 If you want to set up a filter for results, select any drawing in the

Select Review Drawing pane, and click  on the Select Project
Drawing title bar.

With the filter on, drawings in the project folder are filtered to
display only those drawings that were matched to the drawing
selected in the review folder and any project drawings into which
the selected review drawing is xrefed. When you turn the filter
mode off, all of the drawings in the project folder are listed.

7 Begin a comparison using one of the following methods.

■ Select a review drawing from the Select Review Drawing pane,
select a project drawing from the Select Project Drawing pane,
right-click, and click Begin comparison from this drawing.

■ Select a review drawing from the Select Review Drawing pane,
select a project drawing from the Select Project Drawing pane,
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then click  (Start Drawing Comparison) at the bottom of
the tab.

■ Select a review drawing from the Select Review Drawing pane,
double-click the project drawing from the Select Project
Drawing pane.

The Object Comparison progress bar displays the number of
objects being compared as they are processed. For results to be
generated, always allow the Drawing Compare process to finish.
For more information, see Reviewing the Results of a Drawing
Compare Session on page 704.

IMPORTANT Although you can use the AutoCAD Undo command
while working in a drawing, you cannot use it to undo any actions
specific to Drawing Compare.

After the comparison is complete, the Review tab of the Drawing
Compare palette displays along with a separate Drawing Compare
panel. For more information, see Reviewing the Results of a
Drawing Compare Session on page 704.

Reviewing the Results of a Drawing Compare Session
After you begin a comparison between a review drawing and a project drawing
(see Starting a Drawing Compare Session on page 698), the Object Comparison
progress indicator displays as shown.
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When all objects in the drawings have been compared, the following events
occur:

■ The Review tab of the Drawing Compare palette becomes active. This tab
has a legend for the colors used in the drawing area and lists all objects
for which differences were found. Select an object in the list to view a
comparative list of its properties in both drawings (and optionally zoom
in on the object in the drawing area).

■ Comparison results are shown graphically in the drawing area, with review
drawing geometry overlaid on the project drawing. Objects for which
differences were found display in color according to the Visual Filter Legend
on the Review tab. For more information, see Creating a Visual Filter on
page 710.

■ The Drawing Compare panel displays on the Home tab, providing a set of
tools for reviewing comparison results.

DescriptionIcon

Ends a Drawing Compare session. There is no Undo option
for exiting Drawing Compare, and the compiled data is not
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DescriptionIcon

saved. There is no way to recapture the information you
were reviewing without beginning a new comparison.

Plots a Drawing Compare session.
You can publish the current comparison results (based on
the current display system, layers, and filter settings) of the
review drawing to 2D DWF or plot with foreground plotting.
For more information, see Publishing Drawings to DWF and
DWFx on page 276 and “Plot and Publish Drawings” in
AutoCAD Help.

NOTE Foreground plotting is used by default; back-
ground plotting is disabled when the plot button is
selected. If you choose to plot or publish using back-
ground plotting, your comparison results will not be
plotted, and you will lose the themed results.

Selects the previous or next object in the Object Report List,
and zooms in on the object in the drawing area if the Zoom
to option is activated.

Selects an object in the drawing area and highlights it in the
Object Report List.

Activates/deactivates the Zoom to option. Activate this op-
tion to move forward and back through objects in the Object
Report List.

Hides/displays the Drawing Compare palette.
You can minimize the Drawing Compare palette and use
the Drawing Compare panel on the Home tab of the ribbon
to navigate when viewing objects. Expand the palette when
necessary to review information about objects and properties.

Using the Review Tab

The Review tab of the Drawing Compare palette lets you review the results of
a Drawing Compare session on an object-by-object basis. It also provides a
mechanism for filtering the display in the drawing area to show/hide certain
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categories of objects or an entire drawing. The tab includes the following
sections.

■ Setup: This section displays the full paths for the review and project
drawings that are being compared. If multiple comparisons are active, this
information updates as you switch between drawings.

■ Visual Filter Legend: The Visual Filter Legend identifies the colors used to
indicate different categories of drawings and objects. You can switch the
Hide/Show settings to control what will be visible in the drawing area. The
icons for new, missing, and modified objects show 2 colors: the color in
the upper-left corner of the icon is used for objects that have not been
viewed; the color at the lower right is used for objects that have been
viewed.
When you start a Drawing Compare session, the last used filter from the
previous session is still in effect. To change the colors or plot styles for any

of the categories in the legend, click the Edit Visual Filter icon (  ) on
the Visual Filter Legend title bar to open the Visual Filter dialog. For more
information, see Creating a Visual Filter on page 710.

■ Visual Filter: The Visual Filter dialog displays after you click the Edit Visual

Filter icon (  ) on the Visual Filter Legend title bar. It allows you to
specify filters that affect how objects display during your Drawing Compare
session.
Select which objects will be compared under Included Objects. For example,
you can set up a visual filter to include only modified windows to be
included in the comparison. All other objects would display as unchanged.
Under Visual Filtering Color Theme, you can adjust the color schemes and
assign plot styles to different groups of objects, such as all modified
windows. The Color column lists the colors for pending objects before
they are selected. The Viewed Color column lists the colors for objects after
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they are selected. For more information, see Creating a Visual Filter on
page 710.

■ Object Report List: Objects that changed in the selected review drawing
are listed alphabetically by categories, such as Circle, Door, Multi-View
Block, and Polyline. All the information is in bold text initially, indicating
objects as pending (not yet viewed). After an object is viewed, the associated
information displays as normal text.

Select objects from the list to reset their status to pending or to viewed.
Use the SHIFT key to select multiple objects and the CTRL key to select
objects one at a time, right-clicking, and clicking Reset to pending or Mark
as viewed. Resetting the objects changes the text style on the Object Report
List and updates values in the Object List Summary.

The option to zoom in on an object turns on and off when you click the

Activate/Deactivate Zoom to icon (  ) on the Object Report List title bar
or on the Drawing Compare panel. The software zooms into an object
automatically after you select it in the Object Report List when this option
is turned on.

When you select changed objects in the drawing area, the object is
highlighted in the Object Report List. When you hold the cursor over new
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or modified objects in the drawing, a lock icon indicates that these objects
cannot be changed.

The Object Report List works hand-in-hand with the Object List Summary
and the Object Properties. When you select an object from the Report List,
the number of Pending objects changes, and the properties of the object
display under Object Properties.

■ Object List Summary: This summary displays the total number of objects
changed and the total number of objects waiting to be viewed. In the
following example, a total of 209 objects changed in the review drawing
in some way, and 7 of these were reviewed, leaving 202 objects still
pending; that is, not yet selected in the Object Report List. As you change
the status of objects in the Object Report List, the number of Pending
objects decreases or increases accordingly.
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■ Object Properties: This option is on by default and displays properties that
have changed for the object that is selected in the Object Report List. If
you want to view all properties of the selected object, click the Display

properties for reviewed objects icon (  ) on the Object Properties title
bar to turn it off.
If the object is missing, data is listed in the Project Object column only. If
the object is new, data is listed in the Review Object column only. For
modified objects, both project and review properties display.

Creating a Visual Filter
Use this procedure when you want to create a filter that controls which objects
display and how they display during a review session. The changes you make
on the worksheet are applied to the drawing and the Visual Filter Legend after
you click OK.

1 On the Review tab, click the Edit Visual Filter button (  ).

2 On the Visual Filter dialog, in the Included Objects pane, select
or clear the objects as needed to specify which ones will display.

TIP The context menu includes options to Clear All or Select All
objects.

3 Specify settings for the visual filtering color theme:

Then click the 
If you want to…

under Color to display the Select Color dialog
box, select the primary color to appear on
the icon, and click OK.

change the primary color
of object groups pending
review
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Then click the 
If you want to…

under Viewed Color to display the Select
Color dialog box, select the secondary color
to appear on the icon, and click OK.

change the secondary
color of object groups
after they are selected and
viewed

under Plot Style to display the Select Plot
Style dialog box, select the plot style for the
object group, and click OK.

NOTE No options are listed for draw-
ings that use the CTB plot style. If the
STB style is used, you can change the
color and pen thickness for this group
of objects. For more information about
plot styles, see “Change Plot Style Set-
tings” in AutoCAD Help.

select a plot style

4 Click OK.

Drawing Compare Commands
You can run certain Drawing Compare commands from the command line.

■ To open the Drawing Compare palette, enter DwgCompare at the command
line.

■ To open the Visual Filter dialog (when the Review tab is current), enter
VisualFilter.

Frequently Asked Questions about Drawing Compare
Question: When I copy an object from a project drawing to a review drawing
and then start a Drawing Compare session, I would expect that the copied
object would be identified as unchanged. However, the copied object is
identified as new and missing. Why is this?

Answer: Drawing Compare uses object handles to match objects in review
drawings to objects in the project drawings. When an object is copied from
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one drawing to another, it is assigned a new object handle and is identified
as a new version of the object. This results in the object being identified as
missing in the project drawing and new in the review drawing.

Question: When I run a Drawing Compare session, objects that I know have
been altered are not identified as modified. What causes this situation?

Answer: Check the Visual Filter worksheet and verify that the objects in
question are not excluded from the Drawing Compare review. In the Included
Objects section, expand each list of objects and select the appropriate objects
for inclusion in the Drawing Compare review if necessary. If the properties
that have been modified are annotation scale-dependent, they may not have
been modified at the current annotation scale.

Drawing Compare uses the current model space annotation scale from the
project drawing when comparing drawings. Annotative entities that do not
support the current scale are still compared, but properties that can vary by
scale representation will be identified as ''Missing scale representation.''
Properties that never vary by scale representation are always identified with
their actual values. For any specific annotative entity, Drawing Compare will
compare all its non-annotative properties as well as those scale-specific
properties that are associated with the current annotation scale.

Non-annotative entities will always appear at the same size and rotation and
will have the same property values regardless of the current annotation scale.

Question: I expect the Drawing Compare feature to zoom to each object that
I select in the Object Report List, but this is not happening. Why?

Answer: The following reasons may apply:

■ You may have clicked the Zoom to button and toggled off the option.

■ You may be in the middle of a command. Click the Zoom to button again
to toggle the option on, or end the command that you started to return
to your Drawing Compare session.

■ The selected object is not currently visible because of layer or display system
settings. A message displays on the command line when a non-visible
object is selected from the Object Report List.

Question: My Drawing Comparison results identify xrefs that are new and
missing, but I expect these xrefs to be identified as unchanged or modified.
Why is this?

Answer: Drawing Compare uses object handles to match objects in review
drawings to objects in the project drawings. If the xref has been detached,
then reattached, the xref is assigned a different object handle and is identified

712 | Chapter 10   Drawing Compare



as a new version of the xref. This results in the xref being identified as new
in the review drawing and missing in the project drawing.

Question: After drawings from review and project folders are matched
automatically, some of the drawings are still identified as unmatched even
though these drawings in question share the same name. How can this be?

Answer: The drawing names may be the same, but the individual drawing
internal IDs are different. This can occur, for example, when a drawing is
W-blocked into a new drawing. Different drawing internal IDs are also assigned
to AutoCAD Architecture or Revit Architecture drawings when they are
exported to AutoCAD.

NOTE Using the Save or Save As commands does not alter a drawing’s internal
ID.

Question: Why is my Select Project Drawing list empty after I select a project
folder?

Answer: This occurs when the Project Drawing filter is toggled on and either
no review drawing has been selected or the selected review drawing is not
matched with a project drawing.

Question: Why do I not see the drawings that have been recently added to
the project or review folder?

Answer: Folder contents are not automatically updated when drawings are
added or removed. To update folder contents after they have been changed,
reselect the appropriate folder.

Question: I see an external block reference identified in the Object Report List
as new, modified, or missing, yet this external block reference does not appear
graphically with any color assigned by the Visual Filter settings. What causes
this problem?

Answer: External block references cannot have Visual Filter settings assigned
to them. This is to ensure that the modifications to underlying objects within
the external block reference are assigned colors according to the Visual Filter
settings.

Question: Objects that have had their display settings modified are not
identified in the Object Report List as modified. Why is this?

Answer: The Drawing Compare process does not review display settings for
objects. Only the property and style settings of objects are reviewed.
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Question: When comparing drawings exported from Revit Architecture or
Revit Structure, I notice that a simple modification that I made to an object
in these drawings results in numerous differences in associated objects. Why?

Answer: Each Revit object may be exported as separate objects, each of which
may show up as a separate modification.

Question: Why do I have to always manually match drawings exported from
Revit Architecture?

Answer: A new internal drawing ID is automatically assigned to each drawing
file exported from Revit Architecture.
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Layer Management

Enhanced layer management helps you to create, view, and modify the numerous and diverse
elements of architectural plans. Use the Layer Properties Manager in AutoCAD Architecture
to effectively organize and manage conceptual groupings in a drawing.

Layer Management

Layer Properties Manager

The Layer Properties Manager helps you organize, sort, and group layers, and
allows you to work with layer standards, layer key styles, layer filters, layer
overrides, and saved layer states.

In the Layer Properties Manager you can perform all activities related to layers:

■ Create, rename, and delete layers

■ Set and change layer properties

■ Make a layer current

■ Work with layer standards and layer key styles

■ Create layer groups and layer filters

■ Create layer overrides for layout viewports

■ Get notified about new layers in the drawing and its xrefs

■ Save and restore layer states

When you display the Layer Properties Manager, all the layers in the current
drawing are displayed in the All layer group. If there are any external reference
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files linked to the drawing, the layers are listed in a separate layer group, listed
by referenced drawing.

Layer Filters

You can create layer filters to manage large sets of layers. The Layer Properties
Manager allows you to create three types of layer filters: group filters, property
filters, and layer standards filters. Property filters group layers based on layer
properties and states, like for example visibility or color. Group filters contain
any layers that you put in them. Standards filters contain layers associated
with a specified layer standards category.

Creating a layer properties filter

Layer States

You can save the current layer settings in a drawing as a layer state and restore
this layer configuration later. Saving layer states is convenient if you need to
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return to particular settings for all layers during different stages in completing
a drawing or for plotting.

Layer settings include layer states, such as on or locked, and layer properties,
such as color or linetype. In a saved layer state, you can choose which layer
states and layer properties you want to restore later. For example, you can
choose to restore only the Frozen/Thawed setting of the layers in a drawing,
ignoring all other settings. When you restore that named layer state, all settings
remain as they are currently set except whether each layer is frozen or thawed.

Restoring a saved layer state

Viewport Layer Overrides

You can now apply overrides for color, linetype, lineweight, and plot style to
layers in individual layout viewports. This is an efficient way to display objects
with different property settings in individual viewports without changing
their ByLayer or ByBlock properties. Because layer property overrides do not
change the layer’s global properties, you can have objects display differently
in various viewports without having to create duplicate geometry or use xrefs
that have different layer settings. When the Layer Properties Manager is
accessed from a layout tab, 4 additional columns for viewport-specific layer
property overrides are displayed for VP Color, VP Lineweight, VP Linetype,
and VP Plot Style.
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Overriding layer properties for a viewport

New Layer Notification

You can be notified when new layers are added to the current drawing or one
of its attached xrefs before certain tasks, such as plotting, saving, or restoring
a layer state. This way you can avoid potential problems such as plotting
objects that were added to the drawing by the addition of a new layer. You
can control when a drawing is evaluated for new layers, if at all. You can
specify which commands, such as SAVE or PLOT, trigger the software to check
the layer list and alert you of new layers. This can be limited to new layers
that have been added to attached xrefs or include layers in the current drawing
and attached xrefs.

Layer Standards

Layer standards establish naming conventions for layers in your drawings. A
layer standard contains a set of rules that determines the structure of the layer
names in a drawing. When you install the software, you can select from a
number of layer standards that you can use. You can change or edit each of
the layer standards later, if needed.
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Defining a layer standard

Layer Keys and Layer Key Styles

Each layer standard has a corresponding layer key style. The layer keys in the
layer key style assign objects to predefined layers with names that conform
to the layer standard. When you add an object, the object is automatically
drawn on the layer assigned to it in the current layer key style. This process
is called layer keying.

Viewing a layer key style

You can change any part of the layer name structure using layer key overrides
within the layer key style. You can override the layer names for all the layer
keys in a layer key style, or you can override individual layer key styles.
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Managing Drawing Layers
The Layer Properties Manager helps you organize, sort, and group layers, as
well as save and coordinate layer states. You can also use layer standards with
the Layer Properties Manager to better name the layers in multiple drawings.

When you open the Layer Properties Manager, all the layers in the current
drawing are displayed in the right pane. You can work with individual layers
to:

■ Create, rename, and delete layers

■ Change layer properties

■ Make a layer current

■ Add and remove viewport layer overrides

■ Get notified of new layers and reconcile them in the drawing

■ Filter and group layers

NOTE Additional AutoCAD layer functionalities are available on the Home
tab ➤ Layers panel. For more information about AutoCAD layer functionalities,
see “Work with Layers” in the AutoCAD help.

Opening the Layer Properties Manager
Use this procedure to open the Layer Properties Manager. When you open the
Layer Properties Manager, all the layers in the current drawing are displayed
in the right pane while the layer groups are displayed in the left pane.

 ➤ Click Home tab ➤ Layers panel ➤ Layer Properties  .
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Making a Layer Current
Use this procedure to make a specific layer the current layer in the drawing.
You must select an individual layer to make current. You cannot make multiple
layers or layer groups current.

When you make a layer current, new objects you create are drawn on that
layer, unless they have their own layer assignment. For example, if you make
A-Wall the current layer, any lines, polylines, and other linework objects
without layer assignment will be drawn on that layer until you select another
layer to be current.

NOTE AutoCAD Architecture objects have their own layer assignment through
layer key styles and layer standard, so they are not affected by the current layer
setting.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 In the right pane, double-click the layer that you want to make
current.

You can also select the layer that you want to make current and

click  .

The selected layer is now the current layer and is marked with a
green check in the Layer Properties Manager. The layer name is
displayed next to Current Layer: at the top of the Layer Properties
Manager.
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Creating a Layer with a Layer Standard
Use this procedure to create a layer that conforms to the layer standard selected
for the drawing. Layer standards define the naming of new layers according
to the structure defined in the standard. AutoCAD Architecture creates layers
as needed according to the current layer standard. For example, when you
add a wall to a drawing, the software creates the necessary wall layers if they
do not yet exist.

Layer standards can be based on architectural standards like AIA or BS1192,
or they can be user-defined and represent a company or other standard.
AutoCAD Architecture ships with a number of predefined layer standards and
matching layer key styles.

For information on selecting a layer standard and layer key style for a drawing,
see Specifying a Layer Standard and a Layer Key Style on page 190. For
information about creating your own layer standard, see Creating a Layer
Standard on page 783.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  .

3 Select the layer standard that you want to use for Layer Standard.

4 Specify the layer standard information.

Depending on the layer standard you are using, different fields
are available here.
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To select a value for one of the available fields, click the [...]
button, and select one of the values.

You can also enter a new value, provided you follow the
parameters specified for the layer standard components.

When you are finished, the Layer Name and Description fields
display the combination of values you have selected. If you have,
for example, created a new layer for storage shelves according to
the BS1192 layer standard, it is named A746G.

NOTE If the name of the new layer is the same as an existing layer
in the current layer key style, the properties of the new layer are
automatically updated with the properties of the existing layer.

5 Select Make Current if you want to make the new layer the current
immediately.

6 Select a color for the layer from the list.

If the desired color is not available on the list, select Select Color,
and select a color from the Color Picker.

7 Select a linetype.

If the desired linetype is not available on the list, select Other,
and select a linetype from the Select Linetype dialog box.

8 Select a lineweight.

9 Select a Plot Style.

Clear Plot if you do not want the new layer to be plotted.

10 Click OK.

Creating a Nonstandard Layer
Use this procedure to create a nonstandard layer. A nonstandard layer is a
layer that does not need to conform to the layer standard. You might want
to use nonstandard layers for elements like architect’s comments or
construction lines, blocks you do not want to insert on their original layer,
or walls that you want to display partially.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  .
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3 Select Non Standard for Layer Standard.

4 Enter a name for the new layer.

5 Select Make Current if you want to make the layer the current
layer.

6 Enter a description for the new layer.

7 Select a color for the layer from the list.

If the desired color is not available on the list, select Select Color,
and select a color from the Color Picker.

8 Select a linetype.

If the desired linetype is not available on the list, select Other,
and select a linetype from the Select Linetype dialog box.

9 Select a lineweight.

10 Select a Plot Style.

Clear Plot if you do not want the new layer to be plotted.

11 When you finish specifying the properties of the layer, click OK.

Renaming a Layer
Use this procedure to specify a new name for a layer.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Select the layer that you want to rename, and click the layer name.

3 Enter a new name for the layer, and press ENTER.

Deleting a Layer
Use this procedure to delete a layer from a drawing.

Keep the following points in mind when you delete layers:

■ If you try to delete a layer that still has objects on it, you receive an error
message. To delete this layer, you must first erase all objects on it in the
drawing.

■ If the layer you try to delete is the current layer, you receive an error
message. To delete this layer, make another layer current and then delete
the layer.

724 | Chapter 11   Layer Management



■ Some layers may be assigned to the components of another object, or even
to other object styles. These layers cannot be deleted.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Right-click the layer that you want to delete, and click Delete
Layer.

Alternatively, you can select the layer that you want to delete and

click  .

Changing the Layer Standard of a Layer
Use this procedure to assign a specific layer to a different layer standard.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Right-click the layer that you want to change, and click Change
Layer Standard.

3 Select the layer standard that you want to use for Layer Standard.

The layer you selected is now assigned to the specified layer
standard.

NOTE If a layer standard is unavailable on the shortcut menu, the
layer that you selected is not valid for that standard.

Defining the Properties of a Layer
A layer has a number of states and properties that define its display and
behavior in the drawing.
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A state is a condition of a layer that can have one of two values, like On/Off
or Freeze/Thaw. The following layer states can be set in the Layer Properties
Manager:

DescriptionLayer state
value

Icon

Objects on the layer are displayed, plotted, and
regenerated and hide other objects when you use
HIDE.

On

Objects on the layer are not displayed and not
plotted but do hide other objects when you use

Off

HIDE. The drawing is not regenerated when you
turn the layer on.

Objects on the layer are displayed and plotted and
hide other objects when you use HIDE.

Thawed

Objects on the layer are not displayed and not
plotted but do hide other objects when you use

Frozen

HIDE. The drawing is regenerated when you thaw
the layer.

Objects on the layer can be modified.Unlocked

Objects on the layer cannot be modified. You can
still apply object snaps to objects on a locked layer

Locked

and perform other operations that do not modify
those objects.

The selected layer is plotted.Plot

The selected layer is not plotted. If you turn off
plotting for a layer, the objects on that layer are

Non Plot

still displayed. Layers that are off or frozen are not
plotted, regardless of the Plot/Non Plot setting.

Thaws the selected layer in new layout viewports.New Viewport
Thawed
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DescriptionLayer state
value

Icon

Freezes selected layers in new layout viewports.
For example, freezing the DIMENSIONS layer in

New Viewport
Freeze (New
VP Freeze) all new viewports restricts the display of dimen-

sions on that layer in any newly created layout
viewports but does not affect the DIMENSIONS
layer in existing viewports. If you later create a
viewport that requires dimensions, you can over-
ride the default setting by changing the Current
Viewport Freeze/Thaw setting.

Thaws the selected layer in the current layout
viewport.

Current View-
port Thawed

Freezes selected layers in the current layout view-
port. You can freeze or thaw layers in the current

Current View-
port Freeze
(VP Freeze) viewport without affecting layer visibility in other

viewports. Current Viewport Freeze is an override
to the Thaw setting in the overall drawing. You
can freeze a layer in the current viewport if it is
thawed in the drawing, but you cannot thaw a
layer in the current viewport if it is frozen or off in
the drawing. A layer is not visible when it is set to
Off or Frozen in the drawing.

Layer properties are settings that can have a list of different values for a display
characteristic. The following properties can be set for a layer in the Layer
Properties Manager:

■ Color: Changes the color of objects on the layer. Clicking the color name
displays the Select Color dialog box.

■ Linetype: Changes the linetype of objects on the layer. Clicking the linetype
name displays the Select Linetype dialog box.

■ Lineweight: Changes the lineweight of objects on the layer. Clicking the
lineweight name displays the Lineweight dialog box.

■ Plot style: If you are working with color-dependent plot styles
(PSTYLEPOLICY = 1), you cannot change the plot style associated with a
layer. Clicking the plot style displays the Select Plot Style dialog box.

Defining the Properties of a Layer | 727



■ Description: You can add a description to the layer. if your layers are created
with a layer standard, the description is filled in automatically. In that
case, it is recommended to not overwrite it.

NOTE You can override layer properties for individual viewports. For more
information, see Overriding Layer Properties in Layout Viewports on page 729.

Changing the Visibility of Object Subcomponents

You can place different components of an AEC object on different layers. This
is accomplished via the object’s display properties. For example, the current
layer key style might place a wall on the layer named A-Wall, while the wall’s
material definitions might place its internal boundaries on the layer named
A-Wall-Comp. Turning off the layer A-Wall would typically make the entire wall
(including its internal boundaries) invisible, even though those components
were assigned to a different layer. You can define that the subcomponents of
an object remain visible, even though the primary object’s layer (A-Wall in
this case) is turned off. For information on setting this option, see Specifying
a Layer Standard and a Layer Key Style on page 190.

NOTE  Freezing the primary object’s layer would make the entire object including
its internal subcomponents invisible regardless of the value of this setting. You
must turn the layer off if you want subcomponents to be visible without the main
component.

You must keep layer 0 (zero) on and thawed in order to work with AEC object
OSNAPs. When layer 0 is off, AEC object OSNAP points are not visible or
active.

To change the properties of a layer

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 To change one of the layer states On/Off, Freeze/Thaw,
Lock/Unlock, Plot/Non Plot, Current Viewport Freeze/Thaw, or
New Viewport Freeze/Thaw, click the layer state icon for the state
to switch its value.

3 To change one of the layer properties Color, Linetype, Lineweight,
Plot Style, or Description, click the current setting for the property.
Then, use the subsequent dialog box to select a different value.
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NOTE You can also access these many of these settings directly from
the Layer drop-down on Home tab ➤ Layers panel.

Overriding Layer Properties in Layout Viewports
You can now apply overrides for color, linetype, lineweight, and plot style to
layers in individual layout viewports. This is an efficient way to display objects
with different property settings in individual viewports without changing
their ByLayer or ByBlock properties. Because layer property overrides do not
change the layer’s global properties, you can have objects display differently
in various viewports without having to create duplicate geometry or use xrefs
that have different layer settings. When the Layer Properties Manager is
accessed from a layout tab, 4 additional columns for viewport-specific layer
property overrides are displayed for VP Color, VP Lineweight, VP Linetype,
and VP Plot Style (available only in named-plot style drawings;
PSTYLEMODE=1.)

Viewport layer overrides in Layer Properties Manager

If you want to temporarily not display or plot property overrides, set
VPLAYEROVERRIDESMODE to 0. Objects will display and plot with their
global layer properties. Property overrides can still be set even when
VPLAYEROVERRIDESMODE is set to 0.

NOTE Property overrides that are on xref layers are not retained when VISRETAIN
system variable is set to 0.

Layer Property Overrides in Previous Releases

When a drawing containing layer overrides is opened in a previous release of
the software, overrides are not visible and the layer displays its global
properties. The override settings are retained however when the drawing is
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saved in a previous release, and are visible again when the drawing is re-opened
in the current release.

If a viewport containing layer overrides is deleted when the drawing is opened
in a previous release, the override settings are not retained and are not available
when the drawing is re-opened in the current release.

When VISRETAIN is set to 0 when the drawing is opened in a previous release,
viewport overrides in xref layers are not retained.

To override layer properties in a layout viewport

1 Make the layout viewport active for which you want to create
viewport layer overrides.

2 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

3 Scroll until you have the viewport overrides columns visible in
the Layer Properties Manager.

The following viewport overrides are available for layout viewports:

■ VP Color

■ VP Linetype

■ VP Lineweight

■ VP Plot Style

4 Click the desired setting to change the property value.

A layer value that is overridden in the viewport is marked by a
different background color (light blue by default) on the override
property, the global property, and the layer name.

Identifying Viewport Layer Overrides
There are a number of ways to identify layers containing overrides.

In the Layer Properties Manager:

■ A background color displays for each override and for each corresponding
global property setting. By default, it is set to light blue, but you can change
that to another color. For information on changing the background color,
see “Override Layer Properties in Viewports” in the AutoCAD help.
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■ A different icon (  ) displays in the Status column of the layer.

■ A tooltip displays property override information when the cursor is placed
over the Status icon for the layer containing overrides.

■ A predefined filter named Viewport Overrides is displayed in the tree view
where all layers with viewport overrides are listed.

In the drawing workspace:

■ On the command line, enter VPLAYEROVERRIDES to check if the current
viewport contains layer property overrides. When VPLAYEROVERRIDES
is equal to 1, the viewport contains overrides.

Removing Viewport Layer Overrides
You can remove layer overrides from layout viewports.

There are different options to make removing viewport overrides efficient and
intuitive:

■ You can remove overrides in the active viewport only, or for all viewports.

■ You can remove overrides for selected layers only, or for all layers.

■ You can remove individual overrides from a selected layer.
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To remove a single override from a selected layer

1 Make the layout viewport active that has viewport layer override
you want to remove.

2 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

3 In the list of layers, right-click the overridden setting you want
to remove (for information about identifying overrides, see
Identifying Viewport Layer Overrides on page 730), and click
Remove Viewport Overrides for.

Depending on the setting you have right-clicked, a submenu
displays for the setting:

■ Color

■ Linetype

■ Lineweight

■ Plot Style

4 Click the desired submenu, and click one of these commands:

■ In Current Viewport only: This will remove the override from
the selected layer in the current viewport only. For example
if you have clicked Remove Viewport Overrides for
 ➤ Color ➤ In Current Viewport only, then only the
overridden color in the currently active viewport for the
selected layer will be reset to the global color.

■ In All Viewports: This will remove the selected override from
the selected layer in all layout viewports. For example if you
have clicked Remove Viewport Overrides for  ➤ Color ➤ In
All Viewports, then any color overrides for the selected layer
in any layout viewport in the drawing will be reset to the global
color.

To remove all overrides from a selected layer

5 Make the layout viewport active in which you want to remove
all viewport overrides from a layer.

6 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .
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7 In the list of layers, right-click the layer name or status icon from
which you want to remove all overrides, and click Remove
Viewport Overrides for  ➤ Selected Layers.

8 Click one of these two commands:

■ In Current Viewport only: This will remove all overrides from
the selected layer in the current viewport only.

■ In All Viewports: This will remove all overrides from the
selected layer in all layout viewports, and reset them to their
global properties.

To remove all overrides from all overridden layers

9 Make the layout viewport active in which you want to remove
all viewport layer overrides.

10 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

11 In the list of layers, right-click any layer name or status icon, and
click Remove Viewport Overrides for  ➤ All Layers.

12 Click one of these two commands:

■ In Current Viewport only: This will remove all overrides from
all layers in the current viewport only.

■ In All Viewports: This will remove all overrides from all layers
in all layout viewports, and reset them to their global
properties.

Working with Layer Groups
With the Layer Properties Manager, you can create different layer groups to
produce working views and backgrounds from large building data sets. Layer
groups help you work more efficiently in drawings that have many layers.
You can change the settings of a layer group to apply the changes to all layers
in the group at one time. For example, you can lock a layer group to lock all
the layers in the filter.
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Types of Layer Groups
There are five types of layer groups:

DescriptionType

Is always present and lists all the layers and
other layer groups in the drawing.

All

Lists any layers in external reference files
linked with the current drawing. This group

Xref

is automatically created when you xref a
drawing into the current drawing.

Contain layers that you have assigned to
them.

group filters

Contain layers based on a filter that you
specify. You can base filters on layer names
and other layer properties.

property filters

Contain layers associated with a specified
standards category.

layer standards filters

Rules for Layer Groups

The following group rules apply when you are creating and working with layer
groups:

■ You can list a layer in more than one layer group.

■ Multiple listings of the same layer must always have identical property
settings. For example, a layer that is a member of two groups cannot be a
different color in each group.

■ You cannot list a layer twice in a group.

■ You can delete layer groups without affecting the layers in the group.

■ Changing one of the properties of a layer group changes that property for
all the layers in that group, except where the change would be invalid. For
example, it is not possible to freeze the current layer.

■ Layer group names need not be unique.
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■ There is no naming convention for layer groups. Group names can include
spaces, non-alphanumeric characters, and both uppercase and lowercase
letters.

■ Xref layer groups cannot contain other filter groups.

Managing Layer Groups

You can add and subtract layers from layer groups. You can change the
standard AutoCAD properties for the layers in groups, rename layer groups,
delete layer groups, and change the filters in filter groups.

Types of Layer Filters
With the Layer Properties Manager, you can create three types of layer filters:
group filters, property filters, and layer standards filters.

Group filters can contain any layers in the current drawing. You can manually
add layers to, and remove layers from, group filters by dragging layers within
the Layer Properties Manager into the group filter or by selecting an object in
the drawing on the layer that you want to add to the group filter.

Group filters are considered static because they are not automatically updated.
They include only the layers that were assigned when the group was created.
You can manually add layers to, and remove layers from, group filters.

Property filters contain layers that meet filter criteria that you specify for the
group. Filter criteria can select layers according to layer states (on/off,
frozen/thawed, locked/unlocked), properties, or names. For example, you can
create a property filter that includes all of the red layers in the current drawing.

Property groups are considered dynamic because they are automatically
updated when you change the properties of layers that are part of the group.
Property filters are also updated when you add or modify layers that meet the
criteria specified in the filter. You cannot manually add layers to, or remove
layers from property filters.

The layer groups named Xrefs and All are created automatically.

Creating a Group Filter
Use this procedure to create a group filter. Group filters can contain any layers
currently listed in the Layer Properties Manager. You can manually add layers
to, and remove layers from, group filters by dragging layers within the Layer

Types of Layer Filters | 735



Properties Manager into the group filter or by selecting an object in the drawing
on the layer that you want to add to the group filter.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 In the left pane of the Layer Properties Manager, select a layer
group that you want to create the new group under, right-click,

and select New Group Filter, or click  in the Layer Properties
Manager.

3 Enter a name for the new group filter, and press ENTER.

4 Edit the new group filter:

Then…If you want to…

see Adding Layers to Layer Groups
on page 742.

add layers to the group filter

see Changing the Properties of a
Layer Group on page 743.

specify properties for the group fil-
ter

Creating a Property Filter
A property filter contains layers that meet filter criteria that you specify for
the group. Filter criteria can include layers according to layer states (on/off,
frozen/thawed, locked/unlocked), properties, or names. For example, you can
create a property filter that includes all of the red layers in the current drawing.

Creating Property Filters
Use this procedure to create property filters. You can specify more than one
filter for a group. For example, you can filter by both layer name and status
in order to group all frozen walls layers.

You can also specify more than one set of criteria for a property filter. For
example, you can create a filter that will include all frozen red layers and all
frozen blue layers. Boolean AND/OR logic is applied to the filter definitions
to determine which layers to include. A layer must meet all the criteria in a
single row in order to be included in the filter. Continuing with the example,
a layer must be frozen and red to be in the filter. Multiple rows offer alternative
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criteria. In the example below, a layer must be overridden with the color 30
or it must be overridden with the color 31.

Example of a property filter with multiple criteria

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 In the left pane of the Layer Properties Manager, select a layer
group that you want to create the new group under, right-click,

and select New Property Filter, or click  in the Layer Properties
Manager.

3 Enter a name for Filter Name.

4 Specify the filter criteria:

Then…If you want to…

see Specifying a Filter for Layer
State on page 738.

filter layers by visibility state

see Specifying a Filter for Layer
Color on page 739.

filter layers by layer color

see Specifying a Filter for Layer
Linetype or Lineweight on page 740.

filter layers by layer linetype

see Specifying a Filter for Layer
Name on page 740.

filter layers by wildcard characters
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5 Once a row of criteria is configured, you can copy or delete the
row:

Then…If you want to…

right-click in the row you want to copy, and
select Duplicate Row.

copy a row of criteria

right-click in the row, and select Delete Row.delete a row

6 Click OK.

Specifying a Filter for Layer State
Use this procedure to specify a filter that includes layers based on the following
layer states:

■ In use/not in use

■ On/off

■ Frozen/thawed

■ Locked/unlocked

A layer must meet all the specified filter criteria to be included. For example,
if you select Off and Frozen for the filter, a layer that is turned off but is not
frozen will not be included.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 In the left pane of the Layer Properties Manager, select a layer
group that you want to create the new group under, right-click,
and select New Property Filter.

3 Enter a name for Filter Name.

4 Specify the In use/not in use layer criteria for the filter:

Then…If you want to…

click in the Status field, and select
 .

include all the layers in the drawing
that are in use

click in the Status field, and select

 .

include all the layers in the drawing
that are not in use
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5 Specify the On/Off layer state criteria for the filter:

Then…If you want to…

click in the On field, and select 
.

include all the layers in the drawing
that are turned on

click in the On field, and select 
.

include all the layers in the drawing
that are turned off

6 Specify the Freeze/Thaw layer state criteria for the filter:

Then…If you want to…

click in the Freeze field, and select

 .

include all the layers in the drawing
that are thawed

click in the Freeze field, and select

 .

include all the layers in the drawing
that are frozen

7 Specify the Locked/Unlocked layer state criteria for the filter:

Then…If you want to…

click in the Lock field, and select

 .

include all the layers in the drawing
that are unlocked

select Locked.  .
include all the layers in the drawing
that are locked

8 Click OK.

Specifying a Filter for Layer Color
Use this procedure to specify a filter that includes layers based on layer colors.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .
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2 In the left pane of the Layer Properties Manager, select a layer
group that you want to create the new group under, right-click,
and click New Property Filter.

3 Enter a name for Filter Name.

4 Under Filter definition, click the Color field.

5 Click the [...] button.

6 Select a color from the Select Color dialog box.

7 Click OK.

Specifying a Filter for Layer Linetype or Lineweight
Use this procedure to specify a filter that includes layers based on linetype or
lineweight.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 In the left pane of the Layer Properties Manager, select a layer
group that you want to create the new group under, right-click,
and click New Property Filter.

3 Enter a name for Filter Name.

4 Specify the filter criteria for linetypes or lineweights:

then…If you want to…

click in the Linetype field, and click the
[...] button. Select a linetype from the
Select Linetype dialog box.

specify a linetype to include in
the filter

click in the Lineweight field, and click
the [...] button. Select a lineweight from
the Lineweight dialog box.

specify a lineweight to include
in the filter

5 Click OK.

Specifying a Filter for Layer Name
Use this procedure to specify a filter that includes layers based on wildcard
strings in a layer name. The wildcard string is not case sensitive.
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1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 In the left pane of the Layer Properties Manager, select a layer
group, right-click, and click New Property Filter.

3 Enter a name for Filter Name.

4 Under Filter definitions, click the Name field.

5 Specify the wildcard filter criteria:

Then…If you want to…

enter a wildcard string and an aster-
isk (*) for Name. Example: wall*

include all layers that start with a
particular string

enter an asterisk (*) and the wild-
card string for Name. Example:
*view

include all layers that end with a
particular string

enter an asterisk (*), the wildcard
string, then another (*) for Name.
Example: *anno*

include all layers where a particular
string can occur anywhere within
the layer name

For more information about working with wildcards, see “Filter
Selection Sets” in AutoCAD help.

6 Click OK.

Creating a Layer Standards Filter
A layer standards filter contains layers that are associated with a particular
category of a standard. For example, if you create a layer standards filter for
the AIA 2nd Edition standard, and you specify the Major category as the one
to include in the filter, you create a filter that contains all of the drawing
annotation layers.

Creating Layer Standards Filters
Use this procedure to create standards filters. You can specify more than one
standard category for a filter.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .
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2 In the left pane of the Layer Properties Manager, select a layer
group that you want to create the new group under, right-click,

and select New Standards Filter, or click  in the Layer Properties
Manager.

3 Enter a name for Filter Names.

4 Select a standard for Layering Standard.

5 The categories in the Available Category(s) column will differ
depending on the standard being used. Select a category to include
in the filter, and click the Add >> button to move it to the Selected
Category(s) column.

You can include multiple categories in one standards filter. All
layers associated with the Selected Category(s) will be included
in the filter.

6 Click OK.

Adding Layers to Layer Groups
Use this procedure to add layers to a layer group. You can manually add layers
to a group filter. You can either drag them from the list of layers in the right
pane of the Layer Properties Manager to the group in the left pane or add the
layer to the group by selecting an object in the current drawing that is on the
layer that you want to add.

You can also replace all layers in an existing group by selecting objects in the
current drawing that are on the layers that you want to use as replacements
for the existing layers.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Add layers to a layer group:

Then…If you want to…

in the left pane of the Layer Proper-
ties Manager, select the All layer

add layers to a layer group by
dragging

group. In the right pane of the
Layer Properties Manager, drag a
layer to the user layer group or
static filter group in the left pane.
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Then…If you want to…

select the layer group, right-click,

and click Select Layers ➤ Add. In

add layers to a layer group by select-
ing drawing objects

the current drawing, select an ob-
ject on each layer that you want to
add to the group. Press ENTER to
return to the Layer Properties Man-
ager.

select the layer group whose layers
you want to replace, right-click, and

replace layers from groups by select-
ing drawing objects

click Select Layers ➤ Replace. Select
an object on each layer that you
want to replace the layers in the
group. Press ENTER to return to the
Layer Properties Manager.

3 Click OK.

Changing the Properties of a Layer Group
Use this procedure to change the properties of all layers in a layer group. If a
layer is in more than one group, the changes apply to that layer in all groups
in which it is included. For example, if you freeze a group that includes the
layer A-Wall, that layer is frozen in any other group in which A-Wall appears.

NOTE Because you cannot freeze the current layer, you do not have the option
to freeze a group in the active viewport if the current layer is included in the group.
You also cannot freeze the active viewport on the Model layout tab.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click the layer group whose properties you want to change, and
specify properties:

Then…If you want to…

right-click, select Lock, and select
Lock or Unlock Off.

specify whether the group is locked
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Then…If you want to…

right-click, select Visibility, and se-
lect Thawed or Frozen.

specify whether the group is frozen

right-click, select Visibility, and se-
lect On or Off.

specify the visibility of the group

right-click, select Isolate Group, and
select All Viewports or Active View-
port Only.

freeze all layers in the drawing ex-
cept those in the selected layer
group

Renaming and Deleting Layer Groups
Use this procedure to rename or delete layer groups. The layer group is deleted
from the Layer Properties Manager, but the layers listed in the group are not
deleted.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Rename or delete a layer group:

Then…If you want to…

right-click the layer group, and click
Rename. Enter a new name, and
press ENTER.

rename the layer group

right-click the layer group, and click
Delete.

delete the layer group

Converting a Property Filter to a Group Filter
Use this procedure to convert property filters to group filters. Note that
dynamic property filters are converted to static group filters. You manually
add, replace, and delete layers from group filters.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .
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2 On the left pane, select the property filter you want to convert.

3 Right-click, and select Convert to Group Filter.

New Layer Notification
You can be notified when new layers are added to the drawing before certain
tasks, such as plotting, saving, or restoring a layer state. It is important to be
aware of new layers that have been added to a drawing or to an attached xref
without your knowledge. You can avoid potential problems such as plotting
objects that were added to the drawing by the addition of a new layer.

You can control when a drawing is evaluated for new layers, if at all. You can
specify which commands, such as SAVE or PLOT, trigger the program to check
the layer list and alert you of new layers. This can include new layers that
have been added to attached xrefs.

Setting up the Notification for New Layers
Use this procedure to be notified when new layers are introduced into the
drawing or any xrefs referenced to it.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  (Settings).
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3 To set up the new layers notification in the drawing, select
Evaluate new layers added to the drawing.

4 Determine if you want to be notified only of new layers added to
xrefed drawings, or of new layers in xrefed drawings and in the
current drawing:

To be notified only of new layers in xref drawings, click Evaluate
new xref layers only.

To be notified of new layers in xref drawings and in the current
drawing, click Evaluate all new layers.

5 Click Notify when new layers are present to define the actions
that should trigger an evaluation for new layers. Each time one
of the specified actions is performed in the drawing, a comparison
is made between the last time a specified action was performed
(the layer baseline) and the present time. If new layers have been
added in the meantime, the new layers notification is displayed.
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In new drawings, the layer baseline is created when the drawing
is saved or plotted for the first time. For example, when layers are
added to a new drawing, and then it is saved, the layer baseline
is created. Layers that have been added since the drawing was
saved are considered new unreconciled layers.

■ Open: Checks for new layers on opening the drawing.

■ Attach/Reload Xrefs: Checks for new layers when an xref is
attached or reloaded.

■ Restore Layer state: Checks for new layers when you restore a
saved layer state. For more information, see Working with
Layer States on page 749.

■ Save: Checks for new layers when the drawing is saved.

■ Insert: Checks for new layers when a block is inserted.

6 Click Display alert for plot when new layers are present to check
for new layers when plotting a drawing.

Identifying New Layers in the Drawing
When notification is turned on, a New Layer Notification bubble displays on
the status bar every time one of the specified actions is performed, and new
layers are detected in the process. You can choose to view the new layers by
clicking the View Unreconciled New Layers link.

When you click the link, the Layer Properties Manager opens, and the
Unreconciled New Layers filter is automatically selected. All new layers that
have been added to the drawing or attached xrefs are displayed in the list
view.
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You can turn off layer notification but still have the layer list evaluated for
new layers. Although the notification bubble does not display, you can still

check for new layers by right-clicking the alert icon (  ) on the status bar.

Reconciling New Layers in the Drawing
Unreconciled layers are layers that have been added to the drawing or to
attached xrefs since the layer list was last evaluated. The layer list is checked
for new layers when one of the commands selected in Setting up the
Notification for New Layers on page 745 is used.

To reconcile a layer in the drawing you have to manually select it and mark
it as reconciled.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 In the tree view on the left, select the Unreconciled Layers group.

All layers that have been added to the drawing or its xrefs since
the last user-specified action (for example reloading an xref), are
listed.

3 To reconcile a new layer, select the layer name or status,
right-click, and click Reconcile Layer.

This will add the layer to the layer baseline and not display it as
new anymore in the drawing.
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Working with Layer States

NOTE In AutoCAD Architecture 2012 the Layer Snapshot functionality is
discontinued in favor of the Layer State functionality. Existing layer snapshots (LAY)
files are automatically converted to layer states (LAS) when the Layer States
Manager is invoked in a legacy drawing with layer snapshots. The layer snapshot
is deleted after the conversion.

You can save the current layer settings in a drawing as a saved layer state and
restore them later. Saving layer states is convenient if you need to return to
particular settings for all layers during different stages in completing a drawing
or for plotting.

For example, a facilities manager might save a layer state of individual floor
plans and furniture, cable, and HVAC layouts to separate this information
from a complete building layout.

Layer settings you can save and restore include layer states, such as on or
locked, and layer properties, such as color or linetype. You can choose which
layer states and layer properties you want to restore later.

You can modify the properties of a saved layer state. All layer properties other
than the layer name can be edited. You can also add new layers to a layer state
if new layers were added since the later state was saved.

NOTE To be notified when new layers are added to the drawing, see Setting up
the Notification for New Layers on page 745.

Layer States in Xrefs

When an xref containing saved layer states is inserted in the host drawing,
the xref layer states are listed by name and can be viewed in the Layer States
Manager. Although they can be restored, they cannot be edited. Xref layer
states are identifiable because the layer state name is preceded by the xref
drawing’s name and separated by a double underscore symbol. (Example: Xref
Name__Layer State Name.) When the xref is bound to the host drawing, layer
states are identifiable by $0$ that displays between the xref name and layer
state name. (Example: Xref Name$0$Layer State Name.)

Layer states from nested xrefs are also included. Layer states from xrefs are
removed from the host drawing when the xref is detached or unloaded.
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Creating a Saved Layer State
You can save any set of currently existing layers and their properties as a layer
state, with the purpose of either restoring that layer state later in the current
drawing or exporting it to another drawing and restore it there.

The following lists the layer states and properties that are saved in a layer
state:

Saving a Layer State in Model Space:

■ Layer name

■ On/Off

■ Freeze/Thaw

■ Lock/Unlock

■ Color

■ Linetype

■ Lineweight

■ Plot style

IMPORTANT When a layer state is saved from the model space, the global
layer properties for color, linetype, lineweight, and plot style are saved in the
layer state. When the layer state is restored to the model space, the global
layer properties will be restored as the global layer properties of the drawing.
If the layer state is restored to a layout viewport, you can choose if the settings
from the saved layer state are restored either as the global layer properties for
the drawing, or as viewport overrides for that specific viewport.

■ Plot/Non Plot

■ New VP Freeze

Saving a Layer State in a Layout Viewport:

■ Layer name

■ On/Off

■ Freeze/Thaw

■ Lock
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■ Color

■ Linetype

■ Lineweight

■ Plot style

IMPORTANT When a layer state is saved from a layout viewport, and the
viewport has overrides for color, linetype, lineweight, or plot style, the override
settings are saved as the viewport properties. When the layer state is restored
to a layout viewport, you can choose if the settings from the saved layer state
are restored either as the global layer properties for the drawing, or as viewport
overrides for that specific viewport. When the layer state is restored to the
model space of a drawing, the saved layer settings will be restored as global
layer properties to the model space.

■ Plot/Non Plot

■ New VP Freeze

1 Verify that you are in the viewport - either model space or a layout
- which you want to save as a layer state.

2 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

3 Verify that all layers have the desired states and properties you
want to save in a layer state. If necessary, make adjustments.

4 Click  to open the Layer States Manager.

NOTE Alternatively, you can click Home tab ➤ Layers panel ➤ Layer
States drop-down ➤ New Layer State.
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Saving a layer state

5 Click New, and enter a name and description for the layer state.
Then, click OK.

The current settings in Layer Properties Manager are saved in the
layer state.

When a layer state has been created, the following information
about the layer state is displayed in the Layer States Manager:

■ Name: name of the layer state.

■ Space: displays whether the layer state has been saved from
the model space or from a layout viewport.

■ Same as DWG: If the layer configuration in the drawing is
identical to the one saved in the layer state, it is listed as Yes.
Otherwise, it is No. Typically, the layer state should be identical
to the drawing layer configuration when it is created and when
it just has been restored.

NOTE The layer state will also be reported to be Same as
DWG=Yes if the drawing contains new layers not in the layer state,
but these layers are turned off in the drawing.

■ Description: optional description of the layer state.

TIP To view the saved layer state settings, click Edit.
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6 To define which layer settings should be restored when later

restoring the layer state, click  , and select the appropriate
properties under Layer properties to restore.

NOTE Selecting settings to restore has no influence over which
settings are saved. All settings listed in the Edit window are saved;
but you can control which of these settings to restore.

You cannot change the settings for On/Off and Freeze/Thaw if
you are restoring a layer state to a layout viewport. When a layer
state is restored to a layout viewport, the layers in it will be On
and Thawed.

You cannot change the setting for Visibility in Current VP if you
are restoring a layer state to the model space. In model space, you
can only control the global visibility of the layer.

7 Click Save.

8 If new layers have been added to the drawing since the layer state
was saved, and you have not added these layers to the layer state
you can turn them off in the drawing when restoring the layer
state. To do so, click Turn off layers not found in layer state.

9 If you want to restore the saved layer state to a layout viewport,
determine if the saved layer properties for color, linetype,
lineweight, and plot style should be restored to the viewport as
global layer properties or as viewport overrides:

Select Apply properties as viewport overrides if you want to restore
the saved layer state properties as viewport overrides.

Clear Apply properties as viewport overrides if you want to restore
the saved layer state properties as global layer properties.

NOTE If you restore a saved layer state to the model space, the saved
properties are always restored as global layer properties.

Editing a Saved Layer State
When a layer state is saved, it uses the current viewport layer settings. You
can make changes to the saved layer state.
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Changes to a saved layer state can be these 3 change types:

■ adding layers that have been added to the drawing since the layer state
was saved

■ removing layers from the layer state

■ modifying layer settings

1 Do any of the following to open Layer States Manager:

■ Click Home tab ➤ Layers panel ➤ Layer States
drop-down ➤ Manage Layer State.

■ Open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  , and then click

 .

2 Select the layer state that you want to edit, and click Edit.

3 Edit the selected layer state:

Then…If you want to…

click  , select the layer that you
want to add, and click OK.

add layers from the drawing to the
layer state

select the layer that you want to

delete, and click  .

delete a layer from the layer state

click the appropriate state or prop-
erty icon and make the desired

edit the settings of the individual
layers in the layer state

change. This affects only the layer
state. The layers in the drawing are
not affected until you restore the
layer state.

4 Click OK, and then click Close to close the Layer States Manager.
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Restoring a Layer State
You can restore a saved layer state in a drawing. When you restore a layer
state, you can specify which of the saved settings you want to restore. The
layer settings you have not selected remain unchanged in the drawing. For
example, if you select only the Color property to be restored from the layer
state, then the linetype, lineweight, and plot style of the drawing remain
unchanged, even if they are different in the layer state than in the drawing.
If the drawing contains layers that were added since the layer state was saved,
those layers are not deleted when restoring the layer state. You can, however,
select to turn them off when restoring a layer state that does not have these
layers. For more information, see Creating a Saved Layer State on page 750.

When restoring a layer state, the layer that was current when the layer state
was saved is made current. If that layer no longer exists, the current layer does
not change.

IMPORTANT When you save a layer state in the current drawing and then delete
any layers in the drawing that are in the layer state, these layers are deleted from
the layer state without notification. To retain layers in a layer state that are deleted
in the drawing, you must export the layer state before deleting the layers in the
drawing. Later, you can re-import the exported LAS file and restore the deleted
layers.

Restore Options for Different Viewports

In most cases it is recommended to restore layer states that have been saved
from a layout viewport to a layout viewport and layer states that have been
saved from the model space to the model space of the drawing. If you want
to restore layer states between different workspaces, note the following
behaviors:

When a layer state is saved from the model space, the global layer properties
for color, linetype, lineweight, and plot style are saved to the state. When the
layer state is later restored to the model space, the global layer properties will
be restored as the global layer properties of the drawing. If the layer state is
restored to a layout viewport, you can choose if the settings from the saved
layer state are restored either as the global layer properties for the drawing, or
as viewport overrides for that specific viewport.

NOTE Layers that were turned off or frozen in model space are set to VP Freeze
in the Layer Properties Manager if they are restored to a layout viewport.
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When a layer state is saved from a layout viewport, and the viewport has
overrides for color, linetype, lineweight, or plot style, the override settings are
saved as the viewport properties. When the layer state is later restored to the
model space of a drawing, the saved layer settings will be restored as global
layer properties to the model space. If the layer state is later restored to a layout
viewport, you can choose if the settings from the saved layer state are restored
either as the global layer properties for the drawing, or as viewport overrides
for that specific viewport.

1 Verify that the viewport in which you want to restore a saved
layer state is active.

2 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

3 Click  to open the Layer States Manager.

4 Select the saved layer state to restore.

If the setting for Same as DWG is set to Yes, the layer configuration
in the drawing is already identical to the one saved in the layer
state, or the drawing contains new layers not in the layer state,
but these layers are turned off in the drawing. In this case, the
layer state will also be reported to be Same as DWG.

5 Expand the Layer States Manager by clicking  .

6 To define which layer settings should be restored, select the
appropriate properties under Layer properties to restore.

You cannot change the settings for On/Off and Freeze/Thaw if
you are restoring a layer state to a layout viewport. When a layer
state is restored to a layout viewport, the layers in it will be On
and Thawed.

You cannot change the setting for Visibility in Current VP if you
are restoring a layer state to the model space. In model space, you
can only control the global visibility of the layer.

7 Click Save.

8 If new layers have been added to the drawing since the layer state
was saved, and you have not added these layers to the layer state,
you can turn them off in the drawing when restoring the layer
state. To do so, click Turn off layers not found in layer state.

9 If you want to restore the saved layer state to a layout viewport,
determine if the saved layer properties for color, linetype,
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lineweight, and plot style should be restored to the viewport as
global layer properties or as viewport overrides:

Select Apply properties as viewport overrides if you want to restore
the saved layer state properties as viewport overrides.

Clear Apply properties as viewport overrides if you want to restore
the saved layer state properties as global layer properties.

NOTE If you restore a saved layer state to the model space, the saved
properties are always restored as global layer properties.

10 Click Restore.

Deleting a Layer State
When you delete a saved layer state, you do not delete the layers from the
drawing. You delete only the layer state.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  to open the Layer States Manager.

3 Select the saved layer state to delete.

4 Click Delete, and click Yes in the subsequent dialog.

5 Click Close.

Importing Layer States to the Current Drawing
You can import layer states that are saved in drawing files (DWG, DWS, and
DWT) or directly in a layer state (LAS) file.

If the layer state is imported from a drawing that contains layers not present
in the current drawing, these layers are imported into the current drawing.

If the layer state is imported from a drawing and it contains a layer property,
such as a linetype or plot style that is not loaded or available in the current
drawing, that property is automatically imported from the source drawing.

If the layer state is imported from a LAS file, and it contains linetype or plot
style properties that do not exist in the current drawing, that property cannot
be restored.
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When importing a layer state that is a duplicate of a layer state in the current
drawing, you can choose to overwrite the existing layer state or not import
it.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  to open the Layer States Manager.

3 Click Import.

4 In the Import layer state dialog box, select the file format of the
file from which you want to import a layer state:

■ DWG: Imports layer states from a drawing file

■ DWS: Imports layer states from a drawing standards file

■ DWT: imports layer states from a drawing template

■ LAS: Imports a saved and exported layer state directly

5 Select the desired file, and click Open.

6 If you have selected a DWG, DWS, or DWT file with multiple
saved layer states, select the desired state in the Select Layer States
dialog, and click OK.

7 If you have selected a LAS file, you are prompted upon successful
import whether you want to immediately restore the layer state
in the current drawing. Click Yes to restore or No to import
without restoring.
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Exporting a Layer State from the Current Drawing
You can export a saved layer state from the current drawing. Saved layer states
are saved as LAS files and can be imported into drawing files.

When you export a layer state, all layers and their settings are saved in an
external file and can be re-imported into a drawing. Exporting a layer state is
useful for saving layer configurations you need across multiple drawings.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  to open the Layer States Manager.

3 Select the layer state you want to export, and click Export.

4 In the Export Layer State dialog, select a name and location for
the LAS file, and click Save.

5 Click Close.

Working with Layer Keys
A layer key maps an object that you draw to a defined layer. Layer keys also
specify the default properties of each layer.

Layer Keys and Layer Keying

When you create an object, the layer key that is associated with the object
automatically places that object on the layer to which it is mapped. Using
layer keys to automatically place objects on predefined layers is called layer
keying. Usually, you key objects to layers that conform to a layer standard.
Each layer standard names layers according to a set of rules that you can
modify. For more information, see Creating and Editing Layer Standards on
page 774.

Layer Key Styles

You can create different sets of layer keys, called layer key styles, that you can
use to place objects on defined layers in your drawings. Each layer key style
contains a set of layer keys. Both the AIA and BS1192 layer key styles contain
layer keys and layer properties, including layer name, description, color,
linetype, lineweight, plot style, and plot settings for all of the AEC objects.
You can import the AIA and BS1192 layer standards and layer key styles that
are provided with AutoCAD Architecture 2012 from the AecLayerStd.dwg in
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the C:\ProgramData\Autodesk\ACA 2012\enu\Layers folder. You can modify these
styles, if needed, or create new layer key styles. You can also create layer key
styles from LY files.

Properties of Layer Key Styles

You can add and remove layer keys from layer key styles. Default layer keys
cannot be removed. The properties of any layer in an existing layer key style
can also be edited. You can change the layer name, description, color, linetype,
lineweight, plot style, and plot settings for the layer that each layer key maps
to. If the layer key style is based on a layer standard, you can use overrides on
all or some of the layer keys within the layer key style. For more information
about overrides, see Layer Key Overrides on page 771.

NOTE The default Standard layer key style is not based on a layer standard. It
contains the default set of layer keys.

LY Files and Layer Key Styles

If you have LY files from S8 or Release 1 of Architectural Desktop that you
want to use, you can create a new layer key style from an LY file. For more
information see Creating a Layer Key Style from an LY File on page 767.

Overrides to Layer Key Styles

Whether you create an original layer key style or one from an existing LY file,
if you want to use overrides, you must base the layer key style on a layer
standard in the current drawing. If you create a nonstandard layer key style,
the Overrides On/Off command is unavailable. If you copy a layer key style,
you can use layer key overrides only if the layer key style that you copied is
based on a layer standard. For more information about using layer key
overrides, see Layer Key Overrides on page 771.

Managing Layer Key Styles

To create, edit, copy, or purge layer key styles, you access the Style Manager.
The Style Manager provides a central location in AutoCAD Architecture, where
you can work with styles from multiple drawings and templates. For more
information about using the Style Manager, see Style Manager on page 869.
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Default Layer Keys
AutoCAD Architecture uses the following default layer keys when you create
AEC objects.

Default layer keys for creating AEC
objects

DescriptionLayer Key

Detail marksANNDTOBJ

Elevation marksANNELKEY

Elevation objectsANNELOBJ

AutoCAD Architecture masking objectsANNMASK

Match linesANNMATCH

Notes, leaders, etc.ANNOBJ

RevisionsANNREV

Section marksANNSXKEY

Section linesANNSXOBJ

Annotation marksANNSYMOBJ

AppliancesAPPL

CamerasCAMERA

CaseworkCASE

Casework tagsCASENO

Ceiling gridsCEILGRID

Ceiling objectsCEILOBJ

ChasesCHASE
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Default layer keys for creating AEC
objects

Control pointsCOGO

ColumnsCOLUMN

CommunicationCOMMUN

Control systemsCONTROL

Curtain wallsCWLAYOUT

Curtain wall unitsCWUNIT

DimensionsDIMLINE

Dimensions (AutoCAD points)DIMMAN

DoorsDOOR

Door tagsDOORNO

DrainageDRAINAGE

ElectricELEC

Electrical tagsELECNO

ElevationsELEV

ElevatorsELEVAT

Elevations (2D)ELEVHIDE

EquipmentEQUIP

Equipment tagsEQUIPNO

Ceiling tagsFINCEIL

Details - fine linesFINE
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Default layer keys for creating AEC
objects

Finish tagsFINFLOOR

Fire system equipmentFIRE

FurnitureFURN

Furniture tagsFURNNO

Plan grid bubblesGRIDBUB

Column gridsGRIDLINE

Details - hatchingHATCH

Hidden linesHIDDEN

Layout gridsLAYGRID

Ceiling lightingLIGHTCLG

Wall lightingLIGHTW

Massing elementsMASSELEM

Massing groupsMASSGRPS

Massing slicesMASSSLCE

Details - medium linesMED

Wall openingsOPENING

PeoplePEOPLE

Plumbing fixturesPFIXT

Plants - outdoorPLANTS

Plants - indoorPLANTSI
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Default layer keys for creating AEC
objects

AEC PolygonsPOLYGON

Electrical powerPOWER

PropertyPRCL

Parking symbolsPRK-SYM

RooflinesROOF

Roof slabsROOFSLAB

Room tagsROOMNO

Schedule tablesSCHEDOBJ

Seating tagsSEATNO

Miscellaneous sectionsSECT

Sections (2D)SECTHIDE

SiteSITE

SlabsSLAB

Space tagsSPACENO

Space objectsSPACEOBJ

StairsSTAIR

Stair handrailsSTAIRH

Structural beamsSTRUCTBEAM

Structural beam tagsSTRUCTBEAMIDEN

Structural bracesSTRUCTBRACE
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Default layer keys for creating AEC
objects

Structural brace tagsSTRUCTBRACEIDEN

Structural columnsSTRUCTCOLS

Structural column tagsSTRUCTCOLSIDEN

Electrical switchesSWITCH

Details - thin linesTHIN

Triangulated irregular networkTINN

Graphical ScalesTITSCALE

Border and title blockTITTEXT

Drawing title textTITTEXT-DWG

Architectural specialtiesTOILACC

Toilet tagsTOILNO

TopographyTOPO

Site utilitiesUTIL

VehiclesVEHICLES

Sheet View viewportsVIEWPORT

WallsWALL

Fire wall patterningWALLFIRE

Wall tagsWALLNO

Details - wide linesWIDE

WindowsWIND
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Default layer keys for creating AEC
objects

Window assembliesWINDASSEM

Window tagsWINDNO

Construction lineXLINE

ZonesZONE

Zone tagsZONENO

Default Layer Key Values
The following default values are assigned to new layer keys.

Default values for layer keys

Same as layer key name. Assigned to appro-
priate layer root name.

Layer name

BlankDescription

7 (white/black)Color

ContinuousLinetype

DefaultLineweight

NormalPlot style

YesPlot

Creating a Layer Key Style
Use this procedure to create a layer key style. You can create a layer key style
by using default style properties or by copying an existing style. After you
create the style, you edit the style properties to customize the characteristics
of the style.
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If you want to use layer key overrides, you must base the layer key style you
create on a layer standard in the current drawing. If you create a nonstandard
layer key style, you cannot attach layer key overrides to that layer key style.

1 Click Home tab ➤ Layers panel ➤  ➤ Layer Key Styles  .

Alternatively, in the Layer Properties Manager palette, click  .

The Style Manager is displayed with the current drawing expanded in the tree
view.

2 Create a new layer key style:

Then…If you want to…

right-click Layer Key Styles, and
click New.

create a style with default properties

right-click the layer key style you
want to copy, and click Copy.

create a style from an existing style

Right-click Layer Key Styles, and
click Paste.

3 Right-click the new layer key style and click Rename.

4 Enter a name for the new layer key style, and press ENTER.

5 Edit the new layer key style:

Then…If you want to…

see Editing Layer Key Styles on page
768.

specify properties for layer keys

see Attaching Notes and Files to a
Layer Key Style on page 770.

add notes and files to the style

6 When you finish specifying the properties of the layer key style,
click OK.

Creating a Layer Key Style from an LY File
Use this procedure to create a new layer key style from an existing LY file from
S8 or Release 1 of Architectural Desktop. If the LY file that you are using does
not contain the default layer keys required by the software, they are added to
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the new layer key style by default and mapped to default layers based on the
key name. For example, the layer key ANNOBJ maps to the layer ANNOBJ.

If you want to use layer key overrides, you must base the new layer key style
on a layer standard. If you create a nonstandard layer key style, you cannot
attach layer key overrides to that layer key style. When you create an original
layer key style from an existing LY file, you can choose which sections of the
LY file you want to include in your layer key style.

You must first import an existing LY file.

1 On the command line, enter -AECLYImport.

2 Enter the file name to import, or enter ? and browse for a file.

3 Select a file, and click Open.

4 Enter the name for the new layer key style.

5 Select the sections of the LY file you want to include in the new
layer key style.

6 Click OK.

A new layer key style is created. It is not associated with a layer standard until
you assign the new layer key style to a layer standard. For more information
about changing style properties, see Editing Layer Key Styles on page 768.

Editing Layer Key Styles
Use this procedure to edit a layer key style.

■ You can change the layer standard that a layer key style is based on, or
you can specify a layer standard for a nonstandard layer key style.

■ You can add layer keys to the layer key style.

■ You can remove any layer keys except the default layer keys.

■ You can edit the layer properties of the layers to which the layer keys map.

■ You can specify whether layer key overrides can be used with the layer key
style.

1 Click Home tab ➤ Layers panel ➤  ➤ Layer Key Styles  .

Alternatively, you can click  in the Layer Properties Manager.

The Style Manager is displayed with the current drawing expanded
in the tree view.
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2 Select the layer key style that you want to change.

3 Click the Keys tab.

4 Specify the layer standard:

Then…If you want to…

select a new layer standard for
Standard.

specify a different layer standard on
which to base the layer key style

select Non Standard for Standard.specify that the layer key style is not
based on a layer standard

NOTE You can base more than one layer key style on the same layer
standard so that each layer key style can be used with different color,
linetype, and override settings.

5 To add a new layer key, click Add.

New keys are added with default values.

6 To delete a layer key, select a layer key, and click Remove.

You cannot delete the default layer keys.

TIP To change the properties of more than one layer key at a time,
hold down CTRL and select the additional layer keys.

7 Select a layer key, and specify the layer key properties:

Then…If you want to…

double-click the text that you want
to change for Description, and
enter new text.

modify the description for a layer
key

under Layer, click the [...] button.
Specify the appropriate values for
layer fields, and click OK.

modify the layer name

under Color, click the current value.
Select a new color, and click OK.

modify the color for a layer key

under Linetype, click the current
value. Select a new linetype, and
click OK.

modify the linetype for a layer key
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Then…If you want to…

under Lineweight, click the current
value. Select a new lineweight, and
click OK.

modify the lineweight for a layer
key

under Plot, click the printer icon to
turn plotting on or off.

specify whether a layer key will plot

under Allow Overrides, clear the
options for which overrides are not
allowed.

TIP When you first add a new
layer key by default the name
generated for the layer is not
yet based on the layer standard
used. This is why the layer
overrides are inactive. Modify
first the layer name associated
to the key by clicking the [...]
button. Once the name is based
on the layer standard, you can
allow overrides to the standard.

specify whether to allow layer field
overrides

8 Click OK.

Attaching Notes and Files to a Layer Key Style
Use this procedure to enter notes and attach reference files to a layer key style.
You can also edit notes and edit or detach reference files from a layer key style.

1 Click Home tab ➤ Layers panel ➤  ➤ Layer Key Styles  .

Alternatively, you can click  in the Layer Properties Manager.

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Select the layer key style that you want to change.

3 Click the General tab.

4 To add a description to the layer key style, enter it for Description.
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5 Click Notes.

6 To add a note, click the Notes tab, and enter the note.

7 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

8 Click OK two times.

Layer Key Overrides
A layer key override enables you to change the default layer names specified
by one or more layer keys. The structure of layer names is determined by the
descriptive fields in the layer standard definition. You can allow overrides on
all the layer keys within a layer key style, or you can select individual layer
keys that you want to override. You can override all descriptive fields that
make up the layer name, or you can specify which descriptive fields to override.
You can apply overrides to any layer keys in a layer key style that is based on
a layer standard.

For example, in the AIA 2nd Edition layer standard definition, the Discipline
Designator field assigns a description and the Major field assigns a name by
default. By using layer key overrides, you can change the values specified in
these fields and add values in the unused fields, Minor Code and Status.

The information that you enter to create layer key overrides must conform to
the field width and value types specified by the layer standard definition. For
example, you cannot specify a four-letter override in the Discipline Designator
field in the AIA 2nd Edition Layer Standard, because the maximum width for
the Discipline Designator field as specified in the AIA layer standard definition
is 1. To modify the descriptive fields, you must edit the layer standard
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definition. For more information, see Creating and Editing Layer Standards
on page 774.

After you add overrides to a layer key style, you can turn the overrides on and
off in your current drawing. When the layer key overrides are on, objects that
you create are placed on layers defined by the layer standard definitions and
overridden with the values that you specify. When the layer key overrides are
off, objects that you create are placed on the layers defined only by the layer
keys. You can start using the layer key overrides immediately after you specify
them, or you can use the Overrides On/Off command to switch them on later.

Layer key overrides do not change the layer assignments of existing objects.
Only objects added after an override is enabled are affected by the override.

Specifying Layer Key Overrides
Use this procedure to specify layer key overrides. The layer key overrides that
you specify apply only to the layer keys that have any or all descriptive field
overrides selected in the Layer Key Properties dialog box. For more information,
see Editing Layer Key Styles on page 768.

To specify layer key overrides, you must have a layer key style that is based
on a layer standard. If you base your layer key standard on a nonstandard
style, you cannot specify layer key overrides.

If you do not have all overrides enabled in the Layer Key Overrides dialog box,
objects that you draw after you exit the dialog box are placed on the layer
defined by the layer standard. You can use the Overrides On/Off command
to turn on the layer overrides later.

NOTE Individual layer keys that do not allow overrides as specified in the Layer
Key Properties dialog box are not overridden when you select Enable All Overrides.

1 Click Home tab ➤ Layers panel ➤  ➤ Layer Key Overrides

. Alternatively, in the Layer Properties Manager palette, click 

.

2 Under Current Layer Key Style, select the layer key style that you
want to override.

The layer standard that the layer key style is based on is displayed
under Based on Standard and is not editable.

3 Enter values for Override or click the [...] button to specify values
to override the information in the descriptive fields.
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The fields in this dialog box depend on the layer standard your
layer key style is based on. For example, if you are using the AIA
2nd Edition layer standard, you can enter override values for the
Discipline Designator, Major, Minor 1, Minor 2, and Status
descriptive fields.

4 To begin using the layer overrides immediately, select Enable All
Overrides.

5 Click OK.

If you turned on the layer key overrides, any objects that you
create now use the layer key overrides according to the override
values that you have specified and whether you allowed overrides
for the layer keys in the layer key style. If you did not turn on the
layer key overrides, objects that you create are placed on layers
defined by the layer standard.

Turning Layer Key Overrides On and Off
You can use the Overrides On/Off command to turn layer key overrides on
and off for the current layer key style in your drawing. This command is
available only if your current layer key style is based on a layer standard and
if you have specified layer key overrides. If the layer key overrides are on in
the current drawing, a check mark is displayed next to the command name
on the menu.

■ At the command prompt, enter AecToggleLKeyOverridesMnu.

If you turned the layer key overrides on, objects that you create are placed on
layers defined by the layer standard definitions and are overridden with the
values that you specified. If you turned the layer key overrides off, objects that
you create are placed on layers defined by the layer standard.

Remapping Objects to Different Layers
Use this procedure to change the layer an object is drawn on by remapping
it from the current layer key to a different layer key.

1 Click Home tab ➤ Layers panel ➤  ➤ Remap Object Layers

 .

Layer Key Overrides | 773



2 Select the object or objects that you want to change, and press
ENTER.

3 To view the list of available layer keys, enter ?.

4 Press F2 to view the list of layer keys.

5 Select the layer key that you want to map the object to, right-click,
and click Paste To CmdLine.

6 Press F2 to close the text window, and press ENTER.

The object is mapped to a different layer in your drawing, respecting any
current layer key overrides.

Restoring Objects to Default Layer Key Layers
Use this procedure to restore the default layer key assignment to an object
after you remap the object to a different layer by assigning it to a different
layer key.

1 Click Home tab ➤ Layers panel ➤  ➤ Remap Object Layers

 .

2 Select the object or objects that you want to change, and press
ENTER.

3 Enter o (byObject).

This applies the layer assigned to the default layer key of each
object in the selection set, respecting any current layer key
overrides.

4 Press ENTER.

Creating and Editing Layer Standards
A layer standard contains predefined layer names and a set of rules that
determines the names of new layers that you create using that layer standard.
You can use layer standards to establish individual, project, or office layering
conventions that provide consistent and informative layer names. AutoCAD
Architecture provides a number of layer standards that you can use in drawings.
You can also create your own layer standards by customizing an existing layer
standard.
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How Layer Standards Determine Layer Name

When you create a new layer using a layer standard, the layer name has a
number of parts separated by delimiters (for example, hyphens). Each part of
the layer name is determined by rules specified in a corresponding field of the
layer standard.

For example, the AIA 2nd Edition layer standard includes five fields that form
each new layer name: Discipline Designator, Major, Minor 1, Minor 2, and
Status. Each field is separated by a hyphen (?) delimiter, as in the following
example:

(Discipline Designator) - (Major) - (Minor 1) - (Minor 2) - (Status)

A layer in your drawing with a Discipline value of “A,” a Major value of “Wall,”
a Minor 1 value of “Full,” a Minor 2 value of “Abov” and a Status value of
“D,” to denote a demolition layer, would be named A-WALL-FULL-ABOV-D.

You can edit the layer standard definition to change these rules. For more
information, see Editing Component Fields on page 784.

You can override the information in each field to change the way a layer
standard creates a layer name by specifying layer key overrides. For more
information, see Layer Key Overrides on page 771.

Layer Standards Included with the Layer Properties Manager

AutoCAD Architecture provides industry-standard layering conventions
including: AIA 2nd Edition, BS1192 Descriptive, and BS1192 - AUG Version 2.
Additional international layer conventions are also provided including: DIN
276, ISYBAU Long Format, ISYBAU Short Format, and STLB. Each layer standard
contains specific information organized in fields. You can specify how the
information appears in each field by changing the values in the layer standard
fields. For more information, see Editing Component Fields on page 784.

Component Fields in Layer Standards
Each layer standard defines the number of component fields that make up a
layer name and specifies the rules for the content allowed in each field. If you
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create or edit a layer standard, you access the layer standard properties to edit
the component fields.

Component Field Descriptions
Each layer standard contains the following component fields.

DescriptionValue

Identifies the field. Field names should be
as consistent as possible across layering
systems to aid in translation.

Field Name

When Yes, allows the field to be omitted
from the end of the layer name. Optional

Optional

layer fields cannot precede a required layer
field unless the match option is Yes so that
the fields can be identified according to a
match against specific descriptions.

Represents the maximum width in charac-
ters that can be used.

Max Width

When Yes, prevents a field from being
shortened from the max width setting.

Fixed Width
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DescriptionValue

An AutoCAD wildcard pattern that the field
must match.

Wildcard

When Yes, recognizes the field only if it
exactly matches a description. You can

Match Description

omit fields from the middle of layer names.
For example, an AIA layer may be made up
of <discipline> <major> <minor>, or <dis-
cipline> <major> <status>, or <discipline>
<major> <minor> <status>, as the <minor>
field may not precede the <status> field
and can be determined only by matching
the field value against valid <minor> field
descriptions.

NOTE When omitting fields from layer
names, verify that the omitted field Match
Description property is No. This ensures
that the layer name specified can be cre-
ated.

Specifies the character used to separate
fields with no fixed width. Delimiters are

Delimiter

often also used in fixed-width fields for
clarity.

A predefined value for those field names
that are not optional within the layer.

Default

For more information about the content of specific layer standards, see AIA
Long Format Layer Standard on page 778 and Editing Component Fields on
page 784.
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AIA Long Format Layer Standard
The AIA Long Format Standard contains the following fields:

DescriptionField Name

Shows divisions of manageable sections.
For example, A for architectural, M for
mechanical. This field is required.

Discipline Designator

Designates assemblies or construction sys-
tems such as walls and doors. This field is
required.

Major

Further differentiates major groups into
minor groups such as full-height walls and

Minor 1

partial-height walls. This field is optional
and user-defined.

Additional information, like title or unit in-
formation.

Minor 2

Differentiates phases of work. For example,
New indicates new, Demo indicates to be
demolished. This field is optional.

Status

The following table lists the rules for the AIA Long Format Layer Standard:

AIA Long
Format 

DefaultDelimiterMatchWild-
card

FixedWidthOption-
al

Field

ANoneNo“@”Yes1NoDiscipline
Designat-
or

Wall“-“No“@@@@”Yes4NoMajor

“-“No“*”No4YesMinor

“-“No“*”No4YesStatus
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BS1192 - AUG Version  2 Layer Standard
The BS1192 - AUG Version 2 layer standard contains the following fields:

DescriptionField

Identifies the author of the layer by using
a single character. For example, A for archi-

Discipline

tect, S for structural engineer. This field is
required.

Identifies the building element by using
three digits and uses CISfB as a common

Category

referencing system. For example, 210 for
wall, 315 for door. This field is required.

Indicates information that is associated with
the category by using a single character.

Graphics

For example, D for dimension, G for
graphics, T for text. This field is required.

Expresses as a single digit the recommen-
ded line thickness, where 1 is the thinnest

Grade

and 9 is the thickest. This field applies
mostly when using text where ISO standard
pen thicknesses correlate with ISO standard
text heights. For example, text that is
2.5mm high that is drawn with a 0.25mm
pen is given a pen grade of 2. This field is
required.

Differentiates viewing planes in plan, sec-
tion, or elevation view by using a two-digit

Level

alphanumeric character. For example, 01
would be Level/Floor 1, EA the elevation,
and SA Section A. This field is optional.

Indicates the state of work by using a single
character. For example, N indicates new,

Status

R indicates to be removed. This field is op-
tional.

Indicates the level of detail to be shown by
using a single character. For example, P

Scale
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DescriptionField

indicates a planning level, D indicates a
detail. This field is optional.

Indicates phasing or alternatives by using
a single character.

Phase/Time

Specifies the user. It is not a fixed width
field but is separated from the rest of the

User

layer name with an underscore. For ex-
ample, A210G701_WALL_L1. This field is
optional.

The following table lists the rules for the BS1192 - AUG Version 2 Layer
Standard:

BS1192
-
AUG
Ver-
sion
2

De-
fault

Delim-
iter

MatchWild-
card

FixedWidthOption-
al

Field

ANoneNo[0A-Z]Yes1NoDis-
cip-
line

1NoneNo#Yes1NoCISfB-
A

CSIfB

0NoneNo#Yes1NoCISfB-
B

0NoneNo#Yes1NoCISfB-
C

GNoneNo[0ACDGHTZ]Yes1NoGraph-
ics

7NoneNo#Yes1NoGrade
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BS1192
-
AUG
Ver-
sion
2

De-
fault

Delim-
iter

MatchWild-
card

FixedWidthOption-
al

Field

00NoneNo[0-9A-
Z][0-9A-
Z]

Yes2YesLevel

0NoneNo[0NXR]Yes1YesStatus

0NoneNo[0ASPD]Yes1YesScale

0NoneNo[0-9A-Z]Yes1YesPhase

BS1192 - Descriptive Layer Standard
The BS1192 - Descriptive layer standard contains the following fields:

DescriptionField Name

Identifies the author of the layer by using
a single character. For example, A for archi-

Discipline

tect, S for structural engineer. This field is
required.

Identifies the building element by using a
descriptive name for it. For example, pos-

Element

sible choices for this field are “Equipment”
or “Room.” This field is required.

Indicates information that is associated with
the category by using a single character.

Graphics

For example, D for dimension, G for
graphics, T for text. This field is required.

Differentiates viewing planes in plan, sec-
tion, or elevation view by using a two-digit

Level

alphanumeric character. For example, 01
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DescriptionField Name

would be Level/Floor 1, EA the elevation,
and SA Section A. This field is optional.

Indicates the state of work by using a single
character. For example, N indicates new,

Status

R indicates to be removed. This field is op-
tional.

Indicates the level of detail to be shown by
using a single character. For example, P

Scale

indicates a planning level, D indicates a
detail. This field is optional.

Indicates phasing or alternatives by using
a single character.

Phase

Specifies the user. It is not a fixed width
field but is separated from the rest of the

User

layer name with an underscore. For ex-
ample, A210G701_WALL_L1. This field is
optional.

The following table lists the rules for the BS1192 - Descriptive Layer Standard:

BS1192 -
Descript-
ive

DefaultDelim-
iter

MatchWildcardFixedWidthOptionalField

ANoneNo[0A-Z]Yes1NoDiscip-
line

Wall-No*No15NoElement

G-No[0ACDGHTZ]Yes1NoGraphics

00NoneNo[0-9A-
Z][0-9A-
Z]

Yes2YesLevel

0NoneNo[0NXR]Yes1YesStatus
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BS1192 -
Descript-
ive

DefaultDelim-
iter

MatchWildcardFixedWidthOptionalField

0NoneNo[0ASPD]Yes1YesScale

0NoneNo[0-9A-Z]Yes1YesPhase

Creating a Layer Standard
Use this procedure to create a layer standard, with default settings or based
on an existing standard, that specifies naming conventions for layers in
drawings.

If your drawing does not contain a layer standard, you can import a layer
standard from another drawing or an AutoCAD Architecture template. For
more information, see Importing Layer Standards on page 788.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  .

3 Click New.

4 To base the new layer standard on an existing standard, select
Based On, and select a standard.

5 Enter a name for the new layer standard, and click OK.

6 Edit the new layer standard:

Then…If you want to…

see Editing Component Fields on
page 784.

specify component fields of the
layer standard

see Editing Descriptive Fields on
page 785.

specify descriptive fields of the layer
standard

see Editing Descriptions on page
786.

specify the descriptions for the layer
standard
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Then…If you want to…

see Editing Description Specifica-
tions on page 787.

specify the descriptive specifications
of the layer standard

7 Click OK.

Editing Component Fields
Use this procedure to specify how you want to set up the fields within the
layer standard that determine the different parts of the layer names created
with that standard. You can add and delete fields here.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  .

3 Select the layer standard that you want to edit, and click Edit.

4 Click the Component Fields tab.

5 Modify the component fields:

Then…If you want to…

select the field, and click  .
delete a component field

select the field, click   , and
enter a name for the new compon-
ent field.

add a component field above an
existing field

select the field, click   , and
enter a name for the new compon-
ent field.

add a component field below an
existing field

double-click the name of the field,
and enter a new name over the ex-
isting name.

edit a field name
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Then…If you want to…

select the values that you want to
change, and select a new value. For

change the values of individual
components of the fields

more information, see Component
Field Descriptions on page 776.

6 Click OK two times.

Editing Descriptive Fields
Use this procedure to add a description that is applied to each component
field in the layer name. You can add a single description to a group of layer
name component fields.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  .

3 Select the layer standard that you want to edit, and click Edit.

4 Click the Edit Descriptive Fields tab.

5 Modify the descriptive fields:

Then…If you want to…

select the field, and click  .
delete a descriptive field

select the field, click   , and
enter a name for the new descript-
ive field.

add a descriptive field above an ex-
isting field

select the field, click   , and
enter a name for the new descript-
ive field.

add a descriptive field below an
existing field

double-click the name of the field,
and enter a new name over the ex-
isting name.

edit a field name
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Then…If you want to…

select the component, and click
Delete.

delete a component from a descript-
ive field

6 Click OK two times.

Editing Descriptions
Use this procedure to map longer or different descriptions to the component
fields of the layer name.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  .

3 Select the layer standard that you want to edit, and click Edit.

4 Click the Edit Descriptions tab.

5 Modify the descriptions:

Then…If you want to…

select the field description, and click

 .

delete a description

select the field description, click

 . Make changes to the descrip-
tion, and click OK.

edit a description

click  . Enter a value and a
description for the field, and click

add a field with a value and a de-
scription

OK. To add multiple fields, click
Apply after each individual field,
and click OK to finish.

6 Click OK two times.
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Editing Description Specifications
Use this procedure to specify how all the fields in the layer standard determine
the layer description that is displayed in the Layer Properties Manager. You
can change the field that is used in the description and the order of the fields,
and you can add text to the beginning of the layer description.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  .

3 Select the layer standard that you want to edit, and click Edit.

4 Click the Description Specification tab.

5 Specify how the fields determine the layer description:

Then…If you want to…

select the field, and click  .
delete a layer standard field

select the field, click   , and
enter a name for the new field.

add a field above an existing field

select the field, click   , and
enter a name for the new field.

add a field below an existing field

double-click the text for Prior Text,
and enter a new name.

edit text

select the current value for Field,
and click a new value.

change a field value

6 Click OK two times.

Purging Layer Standards
Use this procedure to remove standards that are not in use.
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1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  .

3 Select the layer standards that you want to purge, and click Purge.

4 Click OK.

NOTE To purge all layer standards and layer key styles in a drawing, enter
AecPurgeLayerStyles. This is beneficial to use when creating custom templates
or when importing new layer standards and layer key styles.

Importing Layer Standards
Use this procedure to import layer standards from other drawings or from the
AecLayerStd.dwg drawing in C:\ProgramData\Autodesk\ACA 2012\enu\Layers
folder.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  .

3 Click Import/Export.

4 Click Open.

5 Select the drawing with the layer standards that you want to
import, and click Open.

All the layer standards in the drawing are displayed in the External
File list.

6 Under External File, select the layer standard that you want to
import, and click Import.

You can select more than one layer standard in a list by holding
down CTRL while you select the additional layer standards.

If you import a layer standard that already exists in the target
drawing, a message is displayed asking if you wish to overwrite
the existing layer standard. Click Yes to overwrite the existing
layer standard, or click No to cancel.

7 Click OK.

The layer standards that you imported are displayed in the Layer Standards
dialog box.
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Exporting Layer Standards
Use this procedure to export layer standards from the current drawing to a
new drawing or to an existing drawing.

1 If necessary, open the Layer Properties Manager by clicking Home

tab ➤ Layers panel ➤ Layer Properties  .

2 Click  .

3 Click Import/Export.

4 Export the layer standards:

Then…If you want to…

click New, enter a name for the
new drawing, and click Save.

export layer standards to a new
drawing

click Open, select a drawing, and
click Open.

export layer standards to an exist-
ing drawing

5 Select the layer standards that you want to export, and click
Export.

You can select more than one item in a list by holding down CTRL
while you select the additional items. If you export a layer
standard that already exists in the target drawing, a message is
displayed asking if you wish to overwrite the existing layer
standard. Click Yes to overwrite the existing layer standard, or
click No to cancel.

6 Click OK two times.

Appendix: LISP Changes for Layer Snapshots and Layer
States

NOTE In AutoCAD Architecture 2012 the Layer Snapshot functionality is
discontinued in favor of the Layer State functionality. Existing layer snapshots (LAY)
files are automatically converted to layer states (LAS) when the Layer States
Manager is invoked in a legacy drawing with layer snapshots. The layer snapshot
is deleted after the conversion.
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If you have accessed layer snapshots via LISP routines in the past, these LISP
functions are the equivalents of the discontinued layer snapshot functions
and must be exchanged in your scripts:

New Layer States FunctionDefunct Layer Snapshot Function

layerstate-addlayersAecLayerAddToSnapshot

layerstate-exportAecLayerExportSnapshot

layerstate-getlayersAecLayerGetSnapshot

layerstate-importAecLayerImportSnapshot

layerstate-retoreAecLayerRestoreSnapshot

For more information about these functions, see the AutoLISP Reference in
the AutoCAD Help.
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Display System

The display system in AutoCAD Architecture controls how AEC objects are presented in a
designated viewport. By specifying the display configuration in a viewport and the direction
from which to view the objects, you can produce different architectural representations. The
display system lets you produce floor plans, reflected plans, elevations, 3D models, or schematic
displays without redrawing objects.

Introduction to the Display System
The display system in AutoCAD Architecture is designed so that you only have
to draw an architectural object once. The appearance of that object then changes
automatically to meet the display requirements of different types of drawings,
view directions, or levels of detail.

Display Properties and Display Components

The view-dependent display of objects in AutoCAD Architecture is made possible
by a hierarchical system of display settings that specify display properties
(visibility, layer, color, linetype, and so on) for individual display components
of all the different types of architectural objects under all the different viewing
scenarios.

For example, a door object has 5 display components by default: Door Panel,
Frame, Stop, Swing, and Glass. (Many display components correspond directly
to the physical components of the object, but some, like Swing, do not.) For
each of these display components, the drawing default settings specify the
relevant display properties as appropriate for the drawing type. In the case of
doors, the default settings specify that the Swing component is visible in plan
and elevation views, but not in 3D views.

12
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Overrides

The drawing default settings for a particular type of object apply to all such
objects in the drawing, except those for which an override is in effect. For
example, you can change a setting for all doors of a particular style (a style
override) or for an individual door (an object override).

Establishing and Modifying Default Display Settings

If you are a CAD manager, you will want to fully understand the Display
System Structure on page 801 and The Display Manager on page 814 topics so
that you can modify and organize default settings as necessary to implement
your own display standards. But any user can quickly change the appearance
of an object in a particular view by modifying values on the Display tab of
the Properties palette.

NOTE To hide the Display Tab (or show it if it is currently hidden), enter the
following command at the command line: AecChangeDisplayTabStatus.

Display tab when display component is selected

To change the display using this tab, click  (Select Components), select an
object display component (like a hatch or a boundary), and then select or
enter a new value for the display property you want to change (such as color,
visibility, or lineweight).

The results are immediately visible in the drawing area for the current display
representation and can be applied to other display representations that use
the same component. You can also apply style or object overrides by changing
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the value of Display controlled by. For detailed instructions, see Using the
Properties Palette to Change Display Properties on page 793.

Using the Properties Palette to Change Display
Properties

You can use the Display tab of the Properties palette to change the display
property settings for a selected object in the current display representation.
You can change settings for properties that apply to the object as a whole
(such as Cut plane height), as well as settings for the object’s individual display
components (such as Color, Layer, and Linetype for a hatch component).

You can also specify whether your changes will apply to:

■ all objects of the selected type (drawing default)

■ all objects of the same style as the one to which the component belongs
(a style override)

■ only the selected object (an object override)

You can also apply your changes to other display representations that use the
same display component to draw the selected object.

NOTE To hide the Display Tab (or show it if it is currently hidden), enter the
following command at the command line: AecChangeDisplayTabStatus.

1 If necessary, open the Properties palette using any of the following
methods:

■ Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties

 .

■ Press CTRL+1.

■ Select an object in the drawing, right-click, and click Properties.

■ Double-click an object in the drawing.

2 On the Properties palette, click the Display tab.
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Display tab with no object selected

3 Select an object in the drawing area. Note that the current display
representation is identified under the General category on the
Display tab

Display tab with one object selected
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4 Under the General category, for Display controlled by, select the
level at which you want your changes applied, as described in the
following table

Then your changes will apply to …If the value of Display
controlled by is …

all objects of the same type for which no
overrides are in effect (for example, all doors
in the drawing).

Drawing default setting

all objects with the specified style for which
no object overrides are in effect. This is called

<object type>Style:<style
name> (for example: Door
Style: Hinged - Single) a style override; it takes precedence over the

drawing default setting.

the selected object only. This is called an
object override; it takes precedence over
either the drawing default setting or the style.

This object

5 Do one of the following:

Then …If you want to …

proceed to step 6.change one or more dis-
play property settings for
a particular object display
component (or change
the visibility setting for
multiple components)

for Display component, select *NONE*, then
under the Object Display Properties category,

view or modify display
properties that apply to

change the value or click the worksheet but-the entire object at the

ton  for whichever property or set of
level currently specified by
the value of Display con-
trolled by properties you want to modify. The proper-

ties shown under this category depend on
the type of object selected. For detailed in-
formation about modifying display properties
for a specific object type, see the relevant
Help topic, such as Walls or Doors. Each of
these object topics contains subtopics for
each category of display property. For ex-
ample, for instructions on changing settings
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Then …If you want to …

on the Other tab for a wall object, see Spe-
cifying the Display of Other Characteristics
of a Wall on page 1244.

6 To change one or more display property settings for a particular
object display component, first use one of the following methods
to select it:

■ If an object is already selected, under the General category on
the Display tab, select a component from the Display
component drop-down list.

The color of the light bulb icon preceding each component
name indicates whether the component is visible (yellow) or
not (blue) in the current display representation. When the list
is open, you can click one or more of these icons to change
the visibility setting for the associated component(s). Your
changes take effect in the drawing when you close the
drop-down list by clicking a component name, pressing Enter,
or clicking anywhere outside the list. Pressing Esc closes the
list and cancels any visibility setting changes you have made
while the list was open.
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TIP  A hatch may obscure other components, which can be
selected inadvertently when you click on the hatch in the drawing
area.Therefore, the drop-down list is the preferred method for
selecting solid hatch components. Note also that the drop-down
list contains only components whose appearance is controlled by
the display system. Clicking in the drawing area may result in the
selection of an object or component whose display cannot be
modified through the Display tab (such as MV blocks, custom
blocks, AutoCAD objects, and other entities). In such cases, an
error message will identify why the selection is invalid.

■ If no object is selected, at the bottom of the Display tab, click

 , and then click the display component in the drawing
area.

■ Regardless of whether an object is selected, you can right-click
in the drawing area, click Select Component, and then click
the display component you want to modify.

Display tab with object display component selected

NOTE The property settings shown on the Display tab for a selected
component are specific to the display system. In most cases these
settings will not be the same as the settings (either default or override)
for associated layers in the Layer Properties Manager.
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7 Enter or select a new value for any display properties you want
to change. The results of your changes are immediately visible in
the drawing area. Note that the properties shown on the Display
tab vary depending on the object and component selected. Most
are self-explanatory. For detailed information about modifying
display properties for a specific object type, see the relevant Help
topic, such as Walls or Doors. Each of these object topics contains
subtopics for the applicable categories of display properties. For
example, the Walls topic includes separate subtopics for Specifying
the Layer, Color, and Linetype of a Wall on page 1239 and Specifying
the Hatching for Components of a Wall on page 1240.
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NOTE If the value of By Material is Yes, then your changes will apply
to all objects with display components controlled by the material
definition identified by the Name property, regardless of the value
of Display controlled by. This is called a material definition override.
When By material is Yes, you can access the drop-down list of material
display components and change their visibility settings using the
same technique described for display components in the previous
step.

In this case, the Display tab also includes an Advanced category under

which the Additional Properties worksheet button  accesses a
dialog where you can view and modify display properties associated
with the material definition, such as surface hatch placement and
surface rendering, as shown below. For detailed instructions, see
Creating and Editing Material Definitions on page 919.

Other tab for material definition override
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8 If you want to apply your changes to other display representations
at the same level indicated by the Display controlled by value,

click the worksheet button  on the title bar of the General
category. (Note that the worksheet button is available only when
a display component is selected, and the worksheet lists only
those display representations that can be applied to that
component.)

Worksheet for applying changes to other display representations

9 On the worksheet, select the display representations to which you
want your changes to apply, and click OK.
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NOTE If the value of By material is Yes, only that setting and the
Component visible setting will be applied to the selected display
representations. If the value of By material is No, all of the display
property settings for the component will be applied to the selected
display representations.

Display System Structure
You use the display system to manage display properties and view assignments
for objects in your project. You can also create new groupings for display
purposes.

Elements of the Display System

The display system has 3 major elements:

■ A display representation, which controls how an individual object, such
as a door or a wall, is displayed

■ A display set, which is a group of display representations of objects

■ A display configuration, which is a collection of display sets assigned to
particular view directions

These 3 elements are hierarchical: each display configuration contains a
number of display sets, and each display set contains a number of display
representations. To use a display configuration, you assign it to a viewport.
The objects in the viewport then use the display properties specified in the
display configuration.

Predefined Display Configurations in Templates

You use different display configurations for different tasks, such as sketching
and plotting. You also use different display configurations for different types
of drawings, such as floor plans, 3D models, and elevations.

AutoCAD Architecture includes templates with predefined display
configurations applied to viewports. These configurations are created for
typical architectural tasks and drawing types. You can use the configurations
and viewports supplied by the templates, or you can modify the display system
settings to suit your office standards. If you want to create your own display
configurations, you can start a drawing from scratch or from a template that
does not contain predefined display configurations.
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Materials and the Display System

A material definition is a group of settings for the display properties of a
real-world material, such as glass, brick, or wood. The settings define how the
components assigned to the material appear in every view.

The materials feature works with the display system to simplify the process
of customizing the display of drawings. Rather than specifying individual
properties, you can control the display of objects according to the materials
assigned to the physical components of the objects.

For example, you can assign brick as the material for all walls whose
components consist of this material. The display properties of the bricks are
customized to look like a typical brick wall. By assigning the material to walls,
you avoid the need to customize the display properties for each wall that uses
brick material. In addition, if the materials change during the project, you
can reassign components to the new material.

Wall components with assigned brick and concrete materials

Sample styles in AutoCAD Architecture catalogs contain predefined materials
assigned to their components. Use these materials in your drawings, customize
them, or create your own materials. For more information, see Creating and
Editing Material Definitions on page 919.

Display Settings in External References

You cannot change a display setting in an external reference while refediting
it from its host drawing. You can open Display Manager and make changes,
but they will not be saved when the external reference is saved and closed in
the host drawing. To make changes to display settings in external references,
you need to open the external reference drawing directly, make the changes
there, and save it. The external reference should then be reloaded to update
the changes
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Display Representations
A display representation defines how the components that make up an object
are drawn. In traditional CAD and manual drafting, a single object, such as a
door, is typically drawn multiple times in different drawings. In these drawings,
each instance of a door is a separate collection of linework. In AutoCAD
Architecture, you can create an object that changes the way it draws itself
depending on the display representation used to represent that object.

Display Components of AEC Objects

Most AEC objects are made up of individual components. For example, a door
has the following components: door panel, frame, stop, swing, glass, and
threshold. A door may also have muntins.

Each component of an object has both physical and graphical properties that
help to determine the display representation of that object.

■ The physical properties of an object control width, height, shape, and
location of the object in the drawing.

■ The graphical properties control visibility (on/off), layer, color, and linetype.

You typically decide the physical properties of an object when you create it.
For example, you specify the size of a door and its location in a wall. You
control the graphical properties of an object in its display representation. You
can define multiple display representations for the same object.

Display Representations and View Directions

A display representation is not dependent on view direction, although it
usually is designed with a specific view in mind.
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Objects displayed from different view directions that use different display
representations

Why Most Objects Have Multiple Display Representations

All objects have predefined display representations. Most objects have Plan,
Model, and Reflected display representations, because these are the most
common design situations. Some objects, such as cameras and reference AEC
objects, have only a General representation, because the display of these
objects does not change in different views.

A single object can be drawn in various ways, depending on the needs of
different drawing types. For example, the Plan display representation draws
the door panel, frame, stop, and swing components. The Nominal display
representation draws the door panel, frame, and swing components. Although
both representations draw the door panel, each draws it differently. The Plan
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representation draws a door panel as a rectangle, while the Nominal
representation draws it as a single line.

Door shown in the Plan and Nominal display
representations

The Plan display representation is appropriate for two-dimensional (2D) views
when components are to be displayed from a plan (Top) view. The Nominal
display representation is appropriate for 2D views when a limited amount of
detail is needed in plan view. For example, display configurations intended
for plotting at small scales, where details of objects might be obscured, often
use the Nominal display representation.

Default Display Representations

The display representations available for an object and the names of those
representations are based on the ways that you might need to view the object.
Display representations can include different components of an object or
additional display options.

For example, the display properties of stairs in the Plan display representation
include settings for break marks and other stair symbols. Break marks appear
only in 2D Top view drawings, so other display representations, such as Model
and Elevation, do not contain settings for break marks. Similarly, objects that
never display break marks do not have settings for them in their Plan display
representations.
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Plan display representation for stairs includes options
for break marks

Customizing the Display of an Object

If you do not use materials to control display, you customize the appearance
of an object by changing its display properties for the display representation.
For example, you can turn off the door swing in the Plan display
representation; specify whether the swing is straight or an arc; specify the
percent open; or change the layer, color, and linetype of the swing.

To change the display of an object, you specify how changes are applied to
the instances of the object in the drawing. You do this by specifying the source
of the display properties for the selected display representation.

■ To apply the changes to the default display properties of the object, you
customize the drawing default settings. The changes affect all instances of
the object in the drawing.
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Drawing default display properties affect all instances of an object

■ To apply the changes to all instances of the object that have the same style,
you override the drawing default settings with the display properties of
the object style.

Changes to the display properties of a style affect all objects of that style
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■ To apply the changes only to the selected object, you override the drawing
default settings or style display properties with the display properties of
the object.

Display properties of an object apply only to that object

Objects use the default display properties unless the properties are overridden
by the display properties of an object style or an individual object. Generally,
you customize the display properties of object styles so that the appearance
of different types of the same object is consistent throughout a drawing. You
may need to override the display properties of the style for an individual object
in order to achieve certain results.

Display Sets
Display sets are collections of object display representations. A display set
determines which objects are visible, and how the objects, such as wall
assemblies that include doors and windows, are displayed in different views.

Display Representations Included in a Display Set

A display set usually contains display representations that are appropriate for
specific tasks or drawing types. For example, the Reflected display set contains
display representations for objects typically included in a reflected ceiling
plan. This display set uses the Reflected display representation for most of
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these objects, but uses the Plan display representation for other objects, such
as structural members, that appear the same in plan and reflected views.

A display set can contain more than one display representation for an object.
For example, a display set for plotting a floor plan might include the Plan and
Threshold Plan display representations for doors.

■ The Plan display representation contains components for the door panel,
frame, stop, and swing.

■ The Threshold Plan display representation contains components for the
inner and outer thresholds of the door.

Plan and Threshold Plan display representations used alone and together to display a
door

If a display set contains no display representations for an object, the object is
not displayed when that display set is used. For example, a display set for a
reflected ceiling plan does not need representations for railings, which typically
are not shown in these drawings.

Display Sets and View Direction

A display set is not dependent on view direction, although it usually is designed
with a specific view in mind. For example, a Reflected display set is intended
to be used to display objects from the Top view direction in a reflected ceiling
plan.

Similarly, a Plan display set might contain Plan display representations for a
number of objects intended for two-dimensional (2D) top views. A
three-dimensional (3D) model display set might contain the Model display
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representation for a number of objects. The display representations included
in a display set depend on what representations are available for each object,
and whether objects need to be drawn differently from different view
directions.

Default Display Sets

Drawings based on templates provided with AutoCAD Architecture contain
display sets for many purposes. All drawings, even those that are not created
from templates, contain the following default display sets: Elevation, Model,
Model High Detail, Model Low Detail, Plan, Plan High Detail, Plan Low Detail,
and Reflected. These display sets contain display representations for each
object based on the most common design situations.

Display Configurations
A display configuration is a collection of display sets assigned to view
directions.

Display Configurations, Viewports, and Templates

A display configuration typically is created for a specific design task or drawing
type. To use a display configuration, you assign it to a viewport. Drawings
based on templates provided with AutoCAD Architecture contain layout tabs
with viewports to which appropriate display configurations are assigned. You
can use the configuration assigned to a viewport, assign a different one, or
customize the configuration.

Display Sets Assigned to View Directions

You can identify the display set assigned to each view direction using the
Display Manager. The Display Manager is a utility for managing elements of
the display system. The following illustration shows a drawing with two display
configurations, Medium Detail and Standard.
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Sample display configurations in the Display Manager

In the Display Manager, the active viewport in the drawing (in bold type) is
assigned the Medium Detail display configuration. In the left pane, the display
sets used are listed below the configuration name. An icon next to each display
set indicates the view direction to which the display set is applied. The
Configuration tab in the right pane shows the view direction to which each
display set is mapped. In this example, the current view direction in the
drawing is Top, which uses the Plan display set. Objects in the active viewport
are shown using the display representations in the Plan display set.

If the view direction in the active viewport is changed to Front, the objects
are shown using the display representations in the Section_Elev display set.
This is also true when the view direction in the active viewport is changed to
Right, Left, or Back.

The display set assigned to the Default view direction is used when any view
direction other than the six orthogonal views is selected, or when a view
direction is not assigned a display set. If the view direction of the active
viewport is changed to Bottom, objects are shown using the display set assigned
to the Default view direction—the Model display set.

For more information about the Display Manager, see The Display Manager
on page 814.
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Displaying Objects in a Viewport

The display configuration, the current viewport, and the object interact in
the following manner to determine what is shown in a viewport:

■ The active viewport has a current view direction and a current display
configuration. For example, the view direction is Top, and the display
configuration is Medium Detail.

■ The display configuration has one or more display sets and uses the display
set that is assigned to the current view direction. For example, in the
Medium Detail display configuration, the Plan display set is assigned to
the Top view.

■ The display set has associated display representations and it selects the
representation(s) associated with the object that needs to be shown. For
example, in the Plan display set, doors, windows, and walls use their Plan
display representations.

■ The object is shown in the active viewport using the appropriate display
representation(s) and display properties.

Examples of View Directions That Use Different Display Sets

A display configuration assigns display sets to specific view directions. When
a view direction is selected, the display representations in the display set
determine how each object is displayed in the viewport.

For example, the following illustration shows a viewport assigned the Plot
display configuration and the Top view direction. In this illustration, the
objects are shown with a Plan display representation.
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Objects from Top view using a display set for plan views

If the Front view direction is selected in this viewport, the same objects are
displayed with an Elevation display representation.

Objects from Front view using a display set for elevation views

If the SW Isometric view direction is selected, the same objects are displayed
with a three-dimensional (3D) representation.
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Objects from SW isometric view using a display set for model views

Default Display Configuration

The display configurations in a drawing depend on the template used to create
the drawing. A drawing that is not created from a template contains the
Standard display configuration, which includes the Plan and Model display
sets.

The Display Manager
The Display Manager is the central location of display system information for
your drawing in AutoCAD Architecture. You use the Display Manager to create
and modify display configurations, display sets, and display representations.
You can also assign a display configuration to a viewport and view how objects
are displayed in different representations. You can resize the Display Manager
window and the left and right panes as needed to view display information.

Left Pane of the Display Manager

The left pane of the Display Manager organizes the display information for
your drawings in a hierarchical tree view. You can add, purge, rename, copy,
and send display system components in the tree view. As you select items in
the left pane, the right pane is updated appropriately.
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Left pane showing a tree view of display configurations and their components

Right Pane of the Display Manager

The information displayed in the right pane of the Display Manager depends
on what you select in the left pane. You can view the display sets and mapped
view directions associated with each display configuration. You can view the
display representations of different objects and access the default graphical
display properties of objects in your drawings. You can also preview how an
object is displayed.

Right pane showing details of a selected display configuration

View Direction Icons in the Display Manager

The icons used with display sets and view directions identify how a display
set is used in a configuration. When you expand a display configuration, the
display sets used in it are shown. The icon next to each display set indicates
the view direction to which it is applied in the display configuration.

In the following example, the Model display set is applied to the default view
direction. The right pane shows that the Section_Elev display set is applied to
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the front, back, left, and right view directions. The Plan display set is applied
to the top view direction. In the right pane, icons correspond to the six
orthogonal view directions and the default view direction.

Using icons to identify view directions to which display sets are applied

Opening the Display Manager
Use this procedure to open the Display Manager.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Move and resize the Display Manager or resize the left and right
panes as needed to view display information.

Viewing Display Configurations
Use this procedure to view the display configurations available in the current
drawing. The display configurations depend on the template used to create
the drawing. A drawing not created from a template contains the Standard
display configuration, which includes the Model and Plan display sets.
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The following icons can be assigned to a display configuration:

DescriptionIcon

Multiple view display configuration

Fixed view display configuration

Multiple view display configuration (drawing default)

Fixed view display configuration (drawing default)

Default display set used in the display configuration. This set
is used for all views that are not otherwise connected to a
display set.

Display set used for the top view of the display configuration.

Display set used for the bottom view of the display configur-
ation.

Display set used for the left side view of the display configur-
ation.

Display set used for the right side view of the display config-
uration.

Display set used for the front view of the display configuration.

Display set used for the back view of the display configuration.

Display set used for the multiple views of the display config-
uration, but not as the default display set.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Configurations, and select a configuration.
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3 Click the Configuration tab.

The left pane lists the display sets included in the configuration.
The right pane lists the display sets assigned to each view
direction. If a display set is not listed next to a view direction, the
display set for the Default view direction is used when that view
direction is selected. The Default view direction is also used for
any view directions other than the six orthogonal views.

4 Click the Cut Plane tab.

The Cut Plane tab contains settings for the height of the cut plane
and the height above and below the cut plane that are included
in views when you assign this display configuration.

If you are working with a project, you can also calculate the cut
plane based on the level heights from the project. For more
information, see Global Cut Planes on page 550.

5 If you are working with a project and use project standards, you
can use the Version History tab to modify the version history of
the display configuration.

For more information, see Project Standards on page 599.

6 Click OK.

Viewing Display Sets
Use this procedure to view the display sets in the current drawing.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Sets, and select a display set.

The icons next to the display set names in the left pane indicate
whether a display set is used in a display configuration within
the current drawing. The icon with a green check mark indicates
that a display set is assigned. The icon with a green dot indicates
that a display set is a standard set. Although standard sets can be
renamed, they cannot be deleted.

3 Click the Display Representation Control tab.

The right pane contains a matrix that lists each object and display
representation. A check mark under a display representation
indicates that the display set uses this representation to show the
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corresponding object. For example, in the Model display set, most
objects use the Model display representations.

Display representations selected for each object in the Model display set

Display sets can have different icons depending on their function
in the drawing:

DescriptionIcon

The display set is a standard display set and
cannot be deleted.

The display set is currently used in a display
configuration in the drawing.

The display set is a standard display set and is
currently used in a display configuration in the
drawing.

The display set is neither a standard display set
nor is it used in a display configuration in the
drawing.
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4 Click the Display Options tab.

Settings on this tab enable you to filter objects by their
classification. In addition, you can specify settings that affect how
materials are displayed when you generate a live section view of
a building model.

Display options specified for a selected display set

5 If you are working with a project and use project standards, you
can use the Version History tab to modify the version history of
the display set.

For more information, see Project Standards on page 599.

6 Click OK.

Viewing Display Representations
Use this procedure to view the display representations in the current drawing.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Representations by Object, and select an object.
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Display representations can have different icons depending on
their function in the drawing:

DescriptionIcon

Standard display representation with properties
that the user can set.

User-defined display representation with proper-
ties the user can set.

Display representation without user-definable
properties.

In the right pane, rows list the display representations that exist
for that object, and columns list display sets. A check mark under
a display set indicates that the display representation is used in
that display set. A display representation can be used in multiple
display sets.

Curtain wall display representations used in display sets

The icon next to the display representation name indicates

whether it is a predefined display representation (  ) or custom

display representation (  ).

Viewing Display Representations | 821



3 Click OK.

Viewing an Object in a Display Representation
Use this procedure to see how an object appears in different display
representations and view directions.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Click  .

3 Reposition the Floating Viewer and the Display Manager so that
both are visible.

4 Expand Representations by Object, and select an object.

5 In the right pane, select a display representation.

NOTE  Overrides to the default display representation, made in the
display properties of an object style or an individual object, do not
show in the Display Manager.

The Floating Viewer displays the object in the display
representation.

Floating Viewer displaying a curtain wall
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6 Use the controls in the Floating Viewer to view the object from
different view directions and with hidden lines removed or with
shading.

7 Repeat steps 4 and 5 to view objects in various display
representations.

8 Click  to close the viewer.

Viewing the Display Representation of an Object in a Display
Set

Use this procedure to see how an object appears in the display representation
used object in a selected display set.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Click  .

3 Reposition the Floating Viewer and the Display Manager so that
both are visible.

4 Expand Sets, and select a display set.

5 Click the Display Representation Control tab.

6 Select an object.

NOTE  Overrides to the default display representation, made in the
display properties of an object style or an individual object, do not
show in the Display Manager.

The Floating Viewer displays the object in the display
representation selected for it in the display set.

7 Use the controls in the Floating Viewer to view the object from
different view directions and with hidden lines and shading.

8 Repeat steps 6 and 7 to view other objects in the display
representation used in the display set.

9 Select another display set, and repeat steps 6 and 7 to view objects
as they appear in that display set.

10 Click  to close the viewer.

11 Click OK.
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Accessing the Default Display Properties of an Object
Use this procedure to access and view the default display properties of a display
representation of an object. Default display properties apply to all instances
of the object in the drawing unless the properties are overridden by the object
style or an individual object.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Representations by Object.

3 Expand an object, and select a display representation.

The right pane of the Display Manager shows the default display
properties of the object for the selected display representation.

NOTE  Overrides to the default display representation, made in the
display properties of an object style or an individual object, do not
appear in the default display properties in the Display Manager.

4 Click OK.

Creating and Editing Display Configurations
A display configuration is a collection of display sets that controls the
representation of objects viewed from different directions in a drawing. You
apply a display configuration to the viewport in which you want the objects
to appear. You can also select a display configuration to use as the default for
model space and new viewports.

Drawings based on templates provided with AutoCAD Architecture contain
display configurations for common tasks and drawing types. You can modify
them and their display sets and display representations to meet your needs.
You can also copy these elements of the display system to use as the basis for
custom display configurations.

Process Overview: Creating a Display Configuration
AutoCAD Architecture templates provide display configurations for common
design, drafting, and production tasks. You can also create custom display
configurations.

The process of creating a display configuration has the following steps:
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1 Create a display configuration with default properties.

2 Create display sets to associate with different view directions.

Although you can assign display sets to any view direction, you usually
create them with specific view directions in mind. For example, you may
want to create display sets for plan, elevation, and model views of a
building model. You can add more display representations to the display
sets later.

3 Create or modify display representations for each object you want to
display.

You create a new display representation by duplicating an existing display
representation for an object. Use a display representation that is similar
to the one you want to create so that you have fewer settings to modify.
Although you can use display representations in any view direction, you
usually create them with specific view directions in mind.

4 Assign new, modified, or existing display representations to display sets.

A display set can include any display representation that you specify.
Objects can use more than one representation in a display set. Remember
that you need to include at least one display representation for every
object that is to appear in a viewport.

5 Assign display sets to view directions in the display configuration.

You add display sets to a display configuration by assigning them to any
of the six orthogonal view directions or to the Default view direction.
The display set assigned to the Default view direction is used if no display
set is assigned to a view direction.

6 Assign the display configuration to a viewport.

The display configuration becomes active when you assign it to a
viewport. You can assign a display configuration to multiple viewports.
You can also export display configurations to other drawings.

Tips for Working with Display Configurations, Sets, and
Representations

This topic provides suggestions for working effectively with display
configurations and their elements.

■ Templates provided with AutoCAD Architecture and the drawings based
on those templates contain display configurations for common design,
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drafting, and production tasks and various drawing types. If your drawing
does not contain these display configurations, you can import them. For
more information, see Display Configurations on page 810.
Templates and the drawings based on them contain layout tabs with display
configurations assigned to viewports for specific tasks. Examine your
building model in these different layouts to see if objects are displayed as
you want them to appear.

■ Before creating or modifying display configurations, review the predefined
configurations to see if they meet your needs or if you can readily adapt
them for your project.

■ When possible, use a predefined display configuration as the basis for
configurations you create. Starting with a display configuration that is
similar to what you need helps you to work efficiently. You can modify
only the settings that need to change, rather than creating everything from
scratch.

■ When you modify a display representation, the changes affect every display
set and display configuration that use that representation. To apply changes
more selectively, create a new display representation for the object and
assign it to the display sets in which the changes are to appear.

■ Similarly, when you modify a display set, the changes appear in every
display configuration that uses the display set. And if you modify a display
configuration, the changes appear in every viewport to which the
configuration is assigned. To apply the changes more selectively, create
custom display sets and configurations.

■ Remember that changes made to display representations through the
Display Manager apply only to the default display properties of objects.
Changes to the display properties of object styles and individual objects
override the default display properties. In addition, if the default display
properties assign a material to object components, the display properties
of the material determine the appearance of the object.

Creating a Display Configuration
Use this procedure to create a display configuration. You can create a display
configuration using standard default properties or by creating a duplicate of
an existing configuration.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.
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2 Expand Configurations.

3 Create a display configuration:

Then …If you want to …

click Configurations, and click New  .
create a display configura-
tion with default proper-
ties (containing no display
sets)

click the display configuration you want to

copy, and click New  .

create a display configura-
tion from an existing dis-
play configuration

4 Enter a name for the new display configuration, and press ENTER.

5 Specify the display sets and display representations to use in this
display configuration:

Then …If you want to …

see Creating a Display Set on page 827.create a display set for this
configuration

see Creating a Display Representation for an
Object on page 828 and Assigning a Display
Representation to a Display Set on page 831.

create display representa-
tions to use in this display
configuration

see Assigning a Display Set to a View Direc-
tion on page 834.

assign display sets to view
directions

6 Click OK.

Creating a Display Set
Use this procedure to create a display set. You can create a display set using
standard default properties or by creating a duplicate of an existing display
set.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Sets.
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3 Create a display set:

Then …If you want to …

click Sets, and click New  .
create a display set with
default properties (contain-
ing no display representa-
tions)

click the display set you want to copy, and

click New  .

create a display set from
an existing display set

4 Enter the name for the new display set, and press ENTER.

5 Specify the display representations to use in this display set:

Then …If you want to …

see Creating a Display Representation for an
Object on page 828.

create display representa-
tions to use in this display
set

see Assigning a Display Representation to a
Display Set on page 831.

assign display representa-
tions to this display set

see Assigning a Display Set to a View Direc-
tion on page 834.

add this display set to a
display configuration

see Specifying a Display Set as a Default Dis-
play Set on page 836.

use this display set as one
of the default display sets

6 Click OK.

Creating a Display Representation for an Object
Use this procedure to create a display representation for a selected object. You
create a display representation by duplicating an existing one for the object.

Each object has one or more display representations, depending on whether
the object needs to change in different views. Select an existing representation
that is similar to the one you want to create. That way, the display properties
are available for you to customize in the new representation.
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For example, to create a display representation for stairs and use a custom
break mark, duplicate a plan display representation for stairs that contains
settings for the break mark.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Representations by Object.

3 In the left pane of the Display Manager, select the object for which
to create the new display representation.

4 In the right pane, right-click the display representation to
duplicate, and click Duplicate.

5 Enter a name for the new display representation, and press ENTER.

The new display representation has the display properties of the
representation you duplicated.

The display representation created in the right pane is not listed
in the Representations by Object directory in the left pane until
you close and reopen the Display Manager.

6 Double-click the new display representation to edit its properties.

For more information about editing display properties, see Editing
a Display Representation on page 829.

7 Assign the display representation to the display sets in which they
will be used.

For more information, see Assigning a Display Representation to
a Display Set on page 831.

8 Click OK.

You can click Apply instead of OK to save the changes and
continue working in the Display Manager.

Editing a Display Representation
Use this procedure to change the following default display properties of a
display representation:

■ Visibility (on or off), and whether the display of a component is controlled
by its material assignment

■ Layer, color, linetype, and lineweight
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■ Display properties that are specific to the object and the display
representation, such as the stair line and break mark in plan display
representations of stairs

By default, the layer of object components is layer 0. The default color and
linetype are ByBlock. With these defaults, the object components inherit the
color and linetype properties of the “parent” object. For example, when the
color and linetype of the door frame component are ByBlock, the door frame
has the color and linetype of the door object. Object components cannot exist
outside their parent object as can typical AutoCAD block objects.

Changes made to a display representation apply to every display set and display
configuration that use the display representation. To apply changes more
selectively, create a display representation based on the representation you
want to modify. You can then change the display properties of the new
representation and assign it to specific display sets. For more information
about creating display representations, see Creating a Display Representation
for an Object on page 828.

NOTE Changes you made to a display representation using this procedure apply
only to the default display properties for the object. Changes to the display
properties of object styles or of individual objects override the default display
properties.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Representations by Object.

3 Expand the object that contains the display representation you
want to edit.

4 Select the display representation to edit.

The display properties you can edit depend on the object and the
display representation that you select. For example, a wall in a
model representation displays only the Layer/Color/Linetype tab;
a wall in a plan representation displays two additional tabs to
specify display properties for hatching and cut plane components.

5 Click the Layer/Color/Linetype tab to change the AutoCAD
properties, including visibility of the object components and
whether their display is controlled by the material assignment.

6 If applicable, click tabs such as Hatching or Other to change
object-specific display properties.
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For more information about object-specific display properties, see
the procedures for specifying display properties of an object style
in the Help topic for each object. For example, to specify the
display properties of wall styles, see Specifying the Display
Properties of a Wall Style on page 1316.

7 When you finish editing display properties, click OK.

Assigning a Display Representation to a Display Set
Use this procedure to add or remove display representations in a display set.
Changes made to a display set affect every display configuration that uses the
display set.

Keep the following points in mind when you add or remove display
representations in a display set:

■ A display set can use more than one display representation for an object.
For example, some display sets for plan views include both Plan and
Threshold Plan display representations for doors.

■ To use a display representation for an object other than the current one,
be sure to clear the current display representation after selecting the new
one. Otherwise, the display set uses the display properties of both display
representations.

■ If no display representation is selected for an object, the object does not
appear when the display set is active in a viewport.

■ If no check box appears under a display representation for an object, the
object does not have the display representation. For example, objects such
as layout curves and layout grids have only one display representation.

■ You can compare two display sets to view the differences in display
representation assignments. For more information, see Comparing Display
Representations Between Display Sets on page 833.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Sets.

3 Select the display set you want to edit.

4 Click the Display Representation Control tab.
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Editing a display set

5 In the right pane, add or remove display representations:

Then …If you want to …

scroll through the list to find the object. Se-
lect a display representation to use. If no

add a display representa-
tion for an object to the
display set check box appears under a display represent-

ation, the object does not have the display
representation.

scroll through the list to find the object. Clear
the display representation you want to re-
move.

remove a display repres-
entation for an object in
the display set

right-click the name of the display represent-
ation, and click Select All. Be sure to clear

use the same display rep-
resentation for all objects
in the display set any other display representations for the ob-

jects in this display set.

scroll through the list to find the object.
Right-click the object name, and click Clear
All.

remove an object from a
display set
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Then …If you want to …

right-click in the Objects heading area, and
click Select All Display Representations.

add all display representa-
tions to all objects in the
display set

right-click in the Objects heading area, and
click Clear All Display Representations.

clear all display represent-
ations from all objects in
the display set

NOTE You can use these steps to assign display representations from
the Representation by Objects directory. Expand Representations by
Object in the left pane, select an object, and add or remove display
representation assignments.

6 Click OK.

Comparing Display Representations Between Display Sets
Use this procedure to view the differences in display representation assignments
between two display sets.

The Compare Sets dialog box displays two lists. Each list contains display
representations that are assigned to that particular display set, but are not
assigned to the display set in the adjacent column.

Comparing display sets to view different display representation assignments
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You can use the Compare Sets dialog box to assign one or more display
representations to either display set.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Click Sets.

3 In the right pane, hold down the CTRL key and select the two
display sets you want to compare.

4 Right-click one of the selected display set names, and click
Compare Sets.

NOTE The Compare Sets command is available only when two display
set names are selected. You cannot compare more than two display
sets at a time.

5 Each list shows the display representation assignments that are
different from the other display set.

6 To assign display representations:

Then …If you want to …

select the display representation name under

the display set on the left side, and click 
.

assign a display represent-
ation on the left side to
the display set on the
right side

select the display representation name under
the display set on the right side, and click

 .

assign a display represent-
ation on the right side to
the display set on the left
side

Click  .
assign all display represent-
ations to the other display
set so both sets have
identical assignments

7 Click OK twice.

Assigning a Display Set to a View Direction
Use this procedure to specify the display set assigned to each view direction
in a display configuration.
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1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Configurations.

3 Select the display configuration you want to edit.

4 Click the Configuration tab.

5 Under Display Representation Set, select the appropriate display
set for each view direction.

The display set becomes active when the view direction is selected
in the viewport in which the display configuration is assigned.
The display set assigned to Default is used for view directions to
which you do not assign a display set and for the four isometric
views.

6 Click OK.

To see the results of your changes, you must assign the display
configuration to a viewport. For more information, see Assigning
a Display Configuration to a Viewport on page 835.

Assigning a Display Configuration to a Viewport
Use this procedure to assign a display configuration to a viewport. You can
specify a display configuration for a viewport, model space, or tiled viewport
at any time during the design process.

NOTE You can also assign a display configuration to the current viewport in the
Display Manager. Right-click the display configuration, and click Set To Current
Viewport.

1 Select the viewport for which you want to assign a display
configuration.

2 In the drawing status area, select the setting for Display
Configuration.

Displaying the configurations you can assign to the current viewport
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3 Select the display configuration that you want to use.

4 If necessary, click View tab ➤ Appearance panel ➤ Regenerate
drop-down ➤ Regenerate Drawing And Viewports to update the
display to show the new display configuration.

NOTE Alternatively, you can enter rea (Regenerate All) at the
command prompt.

Specifying a Display Set as a Default Display Set
Use this procedure to change the display sets defined as default display sets.
For more information about default display sets, also known as standard sets,
see Display Sets on page 808.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Right-click Sets, and click Standard Sets Adjustment.

The Standard Sets Types column lists the default display sets for
the drawing. The Sets column lists the display set specified for
each default display set.

3 Locate the standard set you want to change, and click its display
set name in the Sets column.

4 Select the display set name to use for the standard set type.

Specifying a display set for the Model standard set type

5 Click OK twice.
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Specifying the Default Display Configuration
Use this procedure to specify the default display configuration applied to new
viewports, model space, or tiled viewports in the current drawing. Existing
viewports with assigned display configurations are not affected.

NOTE You can also assign the default display configuration in the Display Manager.
Right-click the display configuration, and click Set as Drawing Default.

1 Click  ➤ Utilities ➤ Drawing Setup.

2 Click the Display tab.

3 Under Drawing Default Display Configuration, select the display
configuration to apply to new viewports, or when the TILEMODE
system variable is set to 1.

4 Click OK.

5 If necessary, click View tab ➤ Appearance panel ➤ Regenerate
drop-down ➤ Regenerate Drawing And Viewports to update the
display to show the new display configuration.

NOTE Alternatively, you can enter rea (Regenerate All) at the
command prompt.

Specifying the Display Configurations Used in Xref Overlays
Use this procedure to specify whether the objects in an xref drawing are to
use the display configurations in the xref when the drawing is referenced as
an overlay by the host drawing.

By default, objects in both overlay and attached xref drawings use the display
configurations assigned in the host drawing. This procedure describes how to
specify that an xref overlay use only its own display configurations and not
those in the host drawing. If you do not turn on this option, objects in the
xref drawing can use their own display configurations or those of the host
drawing. Xref drawings that are referenced as attachments can use either group
of display configurations. For more information, see Changing the Display
Configuration Used in Xref Drawings on page 839.

In the following example, the objects in the xref drawing inserted as an overlay
use the Screened display configuration (north and east walls, doors, and
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windows). The host drawing uses the Medium Detail display configuration
(south and west walls, doors, and windows).

An xref overlay that does not use the active display configuration in the host drawing

1 Open the drawing that you want to reference in another drawing.

2 Click  ➤ Utilities ➤ Drawing Setup.

3 Click the Display tab.

4 Under Drawing Default Display Configuration, select When used
as an Xref Overlay, use this drawing’s default display configuration
initially.

Clear this option if you want the xref drawing to use either its
own display configurations or the display configurations in the
host drawing.

Specifying that objects use display configurations only from the current drawing
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5 Click OK.

Changing the Display Configuration Used in Xref Drawings
Use this procedure to change the display configuration of an xref drawing
that is referenced as either an attachment or an overlay in a host drawing.

NOTE If you specified that the drawing should always use its own display
configurations when inserted as an xref overlay, you cannot change the display
configuration used to display the xref objects in the host drawing. For more
information, see Specifying the Display Configurations Used in Xref Overlays on
page 837.

1 Open the host drawing that contains the xref drawing for which
to specify a different display configuration.

2 Select the xref drawing you want to change, right-click, and click
Edit Object Display.

3 Click the Xref Display tab.

If the settings on the tab are unavailable, you cannot change the
display configuration used for this xref overlay.

4 Select Override the display configuration set in the host drawing.

5 Select the display configuration that you want to use.

Selecting a display configuration from those in the xref drawing

The list of display configurations are those available in the xref
drawing. Select Drawing Default if you want to use the default
display configuration specified in the host drawing.
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6 Click OK.

7 If necessary, click View tab ➤ Appearance panel ➤ Regenerate
drop-down ➤ Regenerate Drawing And Viewports to update the
display to show the new display configuration.

NOTE Alternatively, you can enter rea (Regenerate All) at the
command prompt.

Displaying Objects by Classification
Use this procedure to hide or show objects in a display set based on the
classification of the objects. For example, if you classify objects by construction
status (new, existing, or demo), you can exclude objects with the demo
classification from the display. When the display is used in the drawing, those
objects do not appear.

Objects filtered from the display are not removed from the drawing. Their
display is turned off only in viewports using the display set in which they are
filtered. You can change the filter to display them again. Because the objects
still exist in the drawing, the display of other objects does not change. For
example, if you filter doors from a floor plan, the walls in which they are
placed are still cut in the space occupied by the doors.

For more information about defining classifications and assigning them to
object styles, see Classification Definitions on page 3872.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Sets.

3 Select the display set you want to edit.

4 Click the Display Options tab.

The classification filter lists all classifications in the current
drawing. All classifications are selected by default.

5 To hide objects of a specified classification, clear the check box
under Classification Filter.

For example, to hide all doors and walls classified as A1010 and
A1020, clear the check boxes for A1010 and A1020 under
Uniformat II.
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Hiding objects based on their classification

To redisplay objects in a classification that were hidden, select
the classification.

6 Click OK.

Specifying Settings for Live Sections and Materials
Use this procedure to specify how live sections and materials are displayed
when the selected display set is active in a viewport and a live section view of
the building model is enabled. These settings let you refine the appearance of
a section. For example, you can remove surface hatching that may obscure
details in the section.

For more information about materials, see Materials on page 885. For more
information about live sections, see Creating and Editing a Live Section View
on page 3275.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Sets.

3 Select the display set you want to change, and click the Display
Options tab.
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Specifying display options for live sections and materials

4 Under Live Sections and Materials, specify display settings:

Then …If you want to …

select Section AEC Objects by Display Range
defined in Display Configuration. If you want

use the display range of
the display configuration

to graphically indicate where objects in theto determine the vertical
model extend below the display range, selectextents of a live section

view Show Materials where Display Range Inter-
sects AEC Objects.

WARNING You should clear this setting
for Plan display sets. If this setting is se-
lected, any 2D sections inserted in Plan
view will not be displayed.

select Hide Sectioned Body Component.remove the display of the
portion of sectioned ob-
jects beyond the bound-
ing box of the live section

select Hide Surface Hatching.remove surface hatching
on sectioned objects

5 Click OK.
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Managing Display Configurations
The Display Manager is a utility for managing display configurations, display
sets, and display representations: renaming them or deleting them, copying
them between drawings, emailing them to other users, and purging unused
elements from drawings.

Renaming a Display Configuration or a Display Set
Use this procedure to rename a display configuration or a display set. You
cannot rename the Standard display configuration.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Select a display configuration or a display set:

Then …If you want to …

expand Configurations, right-click the display
configuration, and click Rename.

rename a display configur-
ation

expand Sets, right-click the display set, and
click Rename.

rename a display set

3 Enter the new name, and press ENTER.

4 Click OK.

Renaming a Display Representation
Use this procedure to rename a display representation. You can rename any
display representation that you create as well as some that are provided in
AutoCAD Architecture templates. You cannot rename predefined display
representations.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Representations by Object.

3 Select the object for which to rename a display representation.

4 In the right pane, right-click the display representation to rename,
and click Rename.
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If Rename is unavailable on the context menu, the display
representation is predefined. Predefined display representations

have this icon  next to their names.

5 Enter the new name, and press ENTER.

6 Click OK.

Deleting a Display Configuration or a Display Set
Use this procedure to delete a display configuration or a display set.

Keep the following points in mind when you delete display configurations or
display sets:

■ You cannot delete the display configuration assigned to the current
viewport.

■ You cannot delete predefined display configurations, indicated by a red
check mark to the left of the configuration name.

■ You cannot delete a display set used in a display configuration, nor can
you delete the Standard display configuration.

NOTE Deleting a display configuration does not delete the display sets and display
representations used in it. Deleting a display set does not delete the display
representations used in it. For more information, see Deleting a Display
Representation on page 845.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Select a display configuration or a display set:

Then …If you want to …

expand Configurations, click the display

configuration, and click Delete  .

delete a display configura-
tion

expand Sets, click the display set, and click

Delete  .

delete a display set

3 Click OK.
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Deleting a Display Representation
Use this procedure to delete a display representation that is not assigned to a
display set. You can delete display representations that you create as well as
some that are provided in AutoCAD Architecture templates. User-defined

display representations have this icon  next to their names. You cannot
delete predefined display representations. Predefined display representations

have this icon  next to their names.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Representations by Object.

3 Select the object for which to delete a display representation.

4 To remove the display representation from all display sets,
right-click the display representation, and click Clear All.

5 Right-click the display representation to delete, and click Delete.

You will receive an error message if you try to delete a predefined
display representation or one that is assigned to a display set.

The name of the display representation deleted in the right pane
is listed in the Representations by Object directory in the left pane
until you close and reopen the Display Manager.

6 Click OK.

Adding Notes and Reference Files to a Display Configuration or
a Display Set

Use this procedure to enter notes and attach reference files to a display
configuration or a display set. You can also edit notes and edit or detach
reference files.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Select a display configuration or a display set:

Then …If you want to …

expand Configurations, and select the display
configuration.

add notes or files to a dis-
play configuration
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Then …If you want to …

expand Sets, and select the display set.add notes or files to a dis-
play set

3 Click the General tab.

4 To add a description to the display configuration, enter it for
Description.

5 Click Notes.

6 To add a note, click the Notes tab, and enter the note.

7 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then …If you want to …

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter the descrip-
tion, and click OK.

edit the description of a
reference file

double-click the reference file name to start
its application.

edit a reference file

select the file name, and click Delete.detach a reference file

8 Click OK twice.

Using Display Settings in Multiple Drawings
You can use your display configurations, display sets, and display
representations in multiple drawings.

You can copy display configurations, display sets, and display representations
between drawings. When you copy a display configuration, the display system
also copies any display sets and display representations included in the selected
configuration that do not exist in the destination drawing. Similarly, if you
copy a display set, the display system copies any display representations that
do not exist in the destination drawing.

If a display set or a display representation with the same name exists in the
destination drawing, it is not overwritten with the new display information.
To transfer the new information, rename the existing display set or
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representation in the destination drawing before copying display configurations
or display sets.

For example, you might want to copy a display set named New Reflected,
which contains a display representation for doors named Reflected Screened.
The current drawing also contains a display representation for doors named
Reflected Screened. You must rename the Reflected Screened display
representation in the current drawing before copying the new display set and
its display representations.

Emailing Display Configurations

If your system has email, you can email display configurations to other users
from the Display Manager. You can send the entire display system in your
drawing to another user of AutoCAD Architecture. The Display Manager copies
the display system information to a new drawing, and attaches the drawing
to a new email message created using your email program. Users of AutoCAD
Architecture who receive your display system by email can import it into their
drawings, open the attached drawing file, and export your display system to
their drawings; or they can use the attached drawing file as a template for new
drawings. For further information about importing and exporting display
systems, see Sending Display Configurations to Other Users on page 849.

Copying Display Settings Between Drawings
Use this procedure to copy display configurations, display sets, and display
representations from the current drawing to another drawing. You can copy
display settings between existing drawings. You can also copy them from an
existing drawing to a new drawing.

NOTE You can also drag and drop display configurations, display sets, and display
representations between drawings.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.
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2 In the Display Manager, open the drawing into which you want
to copy the display representation, display set, or display
configuration, if necessary:

Then…If you want to…

in the Display Manager, click

File ➤ Open, select the drawing you
want, and click Open.

copy the display configuration, dis-
play set, or display representation
to a drawing that is not open in the
Display Manager

in the Display Manager, click

File ➤ New drawing, enter a name
for the drawing, and click Save.

copy the display configuration, dis-
play set, or display representation
to a new drawing

3 Expand the Configurations, Sets, or Representations by Object
folder.

4 Select the display configurations, display sets, or display
representations that you want to copy:

Then…If you want to…

right-click the display configuration,
display set, or display representa-
tion, and click Copy.

copy an individual display configur-
ation, display set, or display repres-
entation

right-click the Configurations, Sets,
or Display Representations folder,
and click Copy.

copy all display configurations, dis-
play sets, or display representations

5 In Display Manager, right-click the drawing into which you want
to paste the display settings, and click Paste.

The display configurations, display sets, or display representations
are pasted into the selected drawing. If the drawing already
contains a setting with the same name, the duplicate name is
displayed in the Import/Export - Duplicate Names Found dialog
box.

6 Resolve duplicate names, if prompted:

Then…If you want to…

select Leave Existing, and click OK.prevent the Display Manager from
overwriting the existing display
configuration, display set, or display
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Then…If you want to…

representation with the new item
of the same name

select Overwrite Existing, and click
OK.

replace the existing display config-
uration, display set, or display rep-
resentation with the new item

select Rename to Unique, and click
OK. The Display Manager appends

keep the existing display configura-
tion, display set, or display repres-

a number to the name of the newentation and add the new item with
a different name setting. Right-click a setting, and

click Rename to change the name.

7 Click OK.

Sending Display Configurations to Other Users
Use this procedure to email all the display configurations and their elements
in a drawing to other users of AutoCAD Architecture. The software creates a
new drawing that contains only the display information from the current
drawing and attaches the drawing to an email message. Objects, layers, and
other drawing content and settings are not included in the new drawing.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Right-click the drawing name, and click Send.

An email message with the subject “AutoCAD Architecture Display
System,” is created using your email program. A drawing file
containing the display information is attached to the message.

If email is not available on your system, the Send option is not
available.

3 Complete and send the message in your email program.

4 Click OK.

Purging a Display Configuration
Use this procedure to purge unused display configurations from a drawing.
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You cannot purge a display configuration assigned to a viewport or model
space, or predefined display configurations such as Standard.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Click Configurations, and click Purge  .

All display configurations that you can purge are selected in the
Purge Display Configurations dialog box.

3 Clear any display configurations that you do not want to purge,
and click OK twice.

Purging a Display Set
Use this procedure to purge unused display sets from a drawing.

You cannot purge a display set assigned to a display configuration, or
predefined display sets such as Standard, Model, or Plan.

TIP To find out if a display set is assigned to any display configurations, select
Configurations in the left pane. The right pane lists each display configuration and
the display sets it uses.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Click Sets, and click Purge  .

All display sets that you can purge are selected in the Purge Display
Sets dialog box.

3 Clear any display sets that you do not want to purge, and click
OK twice.

Purging a Display Representation
Use this procedure to purge unused display representations from a drawing.
You cannot purge a display representation assigned to a display set, or
predefined display representations such as Model or General.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.
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2 Expand Representations by Object.

3 Select the display representations to purge:

Then …If you want to …

click the object name, and click Purge  .
purge unused display rep-
resentations for a specific
object

click Representations by Object, and click

Purge  .

purge all unused display
representations in the
drawing

All display representations that you can purge are selected in the
Purge Display Representations dialog box.

4 Clear any display representations that you do not want to purge,
and click OK twice.

Working with Standard Display Settings
The Project Standards feature provides a mechanism for users to establish,
maintain and synchronize display settings across an AutoCAD Architecture
project. Within a project, you can define standard display settings that are
used across all project drawings.

For more information about projects and project standards, see Drawing
Management on page 303 and Project Standards on page 599.

Standard display settings are organized in a standards drawing that is assigned
to the project. Once a group of display settings have been defined as project
standard settings, and introduced in the project drawings, they have a link to
the standards and can be synchronized with them. With the same link, display
settings from a project drawing can update the standard display settings, too.

Standard display settings can be accessed, edited, synchronized, copied, and
updated in Display Manager.
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Standard settings in Display Manager

Standard Icons
Standard display settings are displayed in Display Manager. Depending on
their status with regards to the project standards, there are a number of
different icons to differentiate them.

DescriptionIcon

Standard display setting
When a light blue icon appears on a display setting in a project drawing
or project standards drawing, the display setting is a standard setting
and is in synch with the standard. No update or synchronization is
necessary.

Standard display setting that is outdated
When this icon appears on a display setting in a project drawing, the
display setting is a standard setting, but is out of date. This means that
the corresponding display setting in the project standards drawing has
a newer GUID than the one in the project drawing. To update the
display setting in the project drawing, see Synchronizing Individual
Display Settings with AEC Standards on page 664.

Standard display setting that has a non-standard (newer) version
When this icon appears on a display setting in a project drawing, the
setting is a standard setting, but has a version GUID that cannot be
found in the project standards. If you encounter this icon, you can
either overwrite the non-standard version with the current version from
the standards drawing, as described in Synchronizing Individual Display
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DescriptionIcon

Settings with AEC Standards on page 664, or you can update the
standards with the version from the project drawing, as described in
Updating Standard Display Settings in the Project Standards Drawing
from a Project Drawing on page 858.

Standard display setting that is excluded from synchronization
When this icon appears on a display setting, the setting is excluded
from synchronization. For more information, see Excluding Display
Settings from Synchronization on page 854.

Standard display setting that has no version information
When this icon appears on a display setting in a project standards
drawing, the display setting has no version information. Version inform-
ation can be deleted, as described in Purging the Version Information
from a Project Standards Drawing on page 689.
To add version information to a display setting, see Updating Standard
Display Settings in a Project Standards Drawing on page 855.

Standard display setting that has been changed, but not versioned
When this icon appears on a display setting in a project standards
drawing, the setting has been modified, but not versioned yet. In order
for the changes to be included in the synchronization, the setting must
be versioned, as described in Updating Standard Display Settings in a
Project Standards Drawing on page 855.
This icon appears only in project standards drawings. Changes in pro-
ject drawings are versioned automatically when you click Apply or OK
in Display Manager.

Non-standardized display setting
When a dark blue icon appears on a display setting in a project drawing,
this setting has no equivalent in the project standards.

Synchronizing Individual Display Settings with AEC Standards
Use this procedure to synchronize display settings in a project drawing with
the project standards.

1 Open a project drawing.
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For more information about projects and project standards, see
Drawing Management on page 303 and Project Standards on page
599.

2 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

3 In the Display Manager tree, navigate to the display setting you
want to synchronize.

You can synchronize the following items:

■ display configurations

■ display sets

■ display representations

4 Select the item in the tree, right-click, and select Synchronize with
Project Standards.

5 In the Synchronize Drawing with Project Standards dialog box,
select the items to synchronize, as described in Synchronizing a
Project Drawing with AEC Standards on page 657.

6 Click OK to start the synchronization process.

Excluding Display Settings from Synchronization
Use this procedure to specify individual display settings that you want to be
ignored during synchronization.

Specified display settings will not be overwritten with standards during
automatic synchronization and will not be displayed as version mismatches
during semi-automatic or manual synchronization, unless you select the Show
objects set to ignore during project standards synchronization check box in
the Synchronization dialog box.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Navigate to the display configuration, display set, or display
representation to be excluded, right-click, and click Ignore During
Synchronization.

Note that the Ignore During Synchronization option now has a
check mark next to it. If you click the option again, the check
mark disappears and the selected display setting is removed from
the list of components to be ignored.
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Updating Standard Display Settings in a Project Standards
Drawing

Use this procedure to change and version a standard display setting in the
project standards display drawing.

Display settings in the project standards display drawing and in the project
drawings are versioned. The version is used to determine whether a display
setting needs to be updated during synchronization. The version information
includes the GUID (Global Unique Identifier), the date and time of the last
modification, the windows login name of who last modified the item, and an
optional comment.

When you change a standard display setting in the open standards drawing,
you are not automatically prompted to version the change.You can make
multiple changes, save and close the drawing, reopen it, and then version the
display setting when its is ready for propagating in the project. As long as the
changes are saved to the project standards drawing, no edits will be lost, even
without versioning in between.

NOTE When you make changes to the display standards drawing, you need to
update the standard styles drawings with the new setting as described in
Synchronizing Project Standards with Each Other on page 864. Otherwise,
inconsistent display of objects might occur.

As long as your changes are saved, but not versioned, any synchronizations
taking place during that time will not recognize the display settings as changed,
since the object comparison is performed on the version GUID, and not the
actual object properties. As a consequence, changed but unversioned display
settings in the project standards will not be updated in the project drawings.
To have the changes synchronized with the project, you need to version the
display settings first.
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Project standards in Display Manager

Updating a standard display setting

1 Open the standards display drawing of the current project.

2 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

TIP The standard display drawings in Display Manager are listed

under the project node (  ). If no project node is displayed, the
current drawing is not part of a project.

3 Select the display setting you want to edit, and make your changes.

4 Click the Version History tab of the changed display setting.
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5 Click Version.

6 If necessary, enter a comment for the new version.

7 Click OK.

The new version is appended to the Version History tab.

8 To version multiple display settings in a project standards drawing,
select a group of settings and version them:

9 Select the display settings that should be versioned.

10 If desired, enter a comment.

The comment will be applied to all objects selected for versioning.

11 Click OK.
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Updating Standard Display Settings in the Project Standards
Drawing from a Project Drawing

You can change a standard display setting in the project standards display
drawing by overwriting it with the corresponding display setting from a project
drawing. When you have updated a project standard display setting from a
project drawing, the project needs to be synchronized to use the updated
display setting. For information, see Synchronizing a Project with the Standards
on page 647.

NOTE When you make changes to the display standards drawing, you need to
update the standard style drawings with the new setting as described in
Synchronizing Project Standards with Each Other on page 864. Otherwise,
inconsistent display of objects might occur.

1 Open a project drawing.

2 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

3 Expand the node of the project drawing, and select the standard
display setting with which you want to update the project
standards.

NOTE A standard display setting in a project drawing can be
recognized by a blue icon.

4 Right-click, and click Update Standards from Drawing.

NOTE Alternatively, click Manage tab ➤ Project Standards panel ➤ 

 ➤ Update Standards From Drawing  .
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NOTE You can also select to update multiple display settings here.

The selected display setting is listed in the top panel.

5 To update the project standards from the project drawing, select
Update Project Standards from the Action drop-down list of the
display settings.

6 To not update the project standards from the display setting in
the project drawing, select Do not Update Project Standards from
the Action drop-down list of the display settings.

In this case, the version in the project standards drawing is not
overwritten with the version in the project drawing. During the
next synchronization of the project drawing, the display setting
will be displayed as out of synch with the project standards.

7 To ignore the out of synch version of the display setting, select
Ignore from the Action drop-down list.

In this case, the item will not be displayed in future updates,
except when you select Show objects set to ignore during project
standards synchronization or remove the Ignore flag from the
display setting in Display Manager, as described in Excluding
Display Settings from Synchronization on page 854.

8 Click OK.

9 In Display Manager, click OK or Apply.
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10 Click Yes to save the updated project standards drawing.

Adding Standard Display Settings from a Project Drawing to a
Project Standards Drawing

You can add non-standardized display settings from the current project drawing
to the project standards. You can do this, for example, if you have created a
complex display configuration in a project drawing and want to include that
into your standards.

After copying a display setting to the project standards, you need to
synchronize the project to use the new standard setting.

1 Open a project drawing from Project Navigator.

2 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

3 Add a new display setting to the current project drawing.

4 Select the new setting, right-click, and click Update Standards
from Drawing.

NOTE Alternatively, click Manage tab ➤ Project Standards panel ➤ 

 ➤ Update Standards From Drawing  .
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NOTE You can select multiple display settings here.

The new setting is listed in the lower panel, which lists styles and
display settings in the project drawing that do not exist in the
project standards.

5 To add the display setting to a project standards drawing, and
thereby make it a standard setting, select Add to Project Standards
in the Action drop-down list.

6 To skip over the non-standardized display setting, select Skip from
the Action drop-down list.

In this case, the non-standardized display setting remains in the
project drawing, and is not entered in the standards.

7 To ignore the display setting, select Ignore from the Action
drop-down list.

In this case, the non-standardized display setting will not be listed
again in future updates, except if you select Show objects set to
ignore during project standards synchronization or remove the
Ignore flag from the display setting in Display Manager, as
described in Excluding Display Settings from Synchronization on
page 854.

8 Click OK.

9 In Display Manager, click OK or Apply.
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10 Click Yes to save the updated project standards drawing.

Editing the Version History of a Standard Display Setting
Each display setting in a project standards drawing has a version history. The
version history displays the unique version identifier, date and time of the
modification, user name and any additional comments entered by the user.

You can edit the history by selectively removing individual versions, or
removing all versions. You cannot remove the current version.

1 Open a project standards drawing.

2 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

3 Select a standard display setting from the project node.

4 Click the Version History tab.

5 To add a new version, click Version, and enter the versioning
information.

6 To remove an existing version, select the version from the Version
History list, and click Remove.

To remove all versions in one step, click Remove All.

7 If you want the display setting to be ignored during
synchronization of standards, select Ignore during project
standards synchronization.
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8 Click OK.

Purging the Version History from a Project Standards Drawing
You can remove the version history from all standard styles and display settings
in a project standards drawing with one command. Purging the version history
will remove all versions except the current one from the standard styles and
display settings. You can do that to avoid cluttering your styles and display
settings.

When you purge the version history, no version GUID except for the current
one remains. That means that the synchronization can no longer separate
between an older version of a standard display setting and a non standard
version of a standard display setting. Each display setting in a project drawing
that does not have the current GUID of the corresponding standard display
setting, will be labeled a “non-standard”, or newer version.

1 Open the project standards drawing.

2 On the command line, enter AecClearVersionHistory.

The version history is removed from all standard styles and display
settings in the drawing.

Purging the Version Information from a Project Standards
Drawing

You can remove the version information from all standard styles and display
settings in a project standards drawing. When you remove the version
information, the version history and the current version information is deleted.

When you run a synchronization, the standard style or display setting still
participates in the synchronization and is considered the “latest version” when
comparing with versions of the object in project drawings. No attempt is made
during synchronization to automatically create a version GUID or history list.
If you want to add version information to the standard style or display setting,
you need to manually version the object as described in Updating Standard
Objects in a Project Standards Drawing on page 679.

1 Open the project standards drawing from which you want to
remove the version information.

2 On the command line, enter AecPurgeVersion.
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The version information is removed from all standard styles and
display settings in the drawing.

Synchronizing Project Standards with Each Other
Project standard styles and display settings can be distributed among multiple
standards drawings, and depend on each other. For example, the styles in a
styles drawing should use the display settings from the standard display
drawing. If display changes are introduced in a standard styles drawing, and
not synchronized with the standard display drawing, styles can display
inconsistently across the project. Therefore, you should synchronize project
standards drawings with each other when changes have been made to
individual standards drawings.

You can synchronize project standards drawings with each other either from
the project node in Display Manager or from the Manage tab on the ribbon.

When project standards drawings are synchronized with each other, the
following criteria are used to determine how the components are updated:

■ Standards drawing type: The display settings in the standard display
drawing update the display settings in all standard styles drawings.

■ Assigned style types: When a drawing has in the standards configuration
setup been associated to a style type, the styles in this drawing will update
all other standards drawings that may contain standard styles of that type.
For example, if the standards drawing “Door Styles.dwg” has been
associated with the Door style type, the styles in that drawing will overwrite
any existing door standard styles in all of the other standards drawings.
Note that in most cases, you will not place standard styles anywhere but
in the designated standards drawing for that style type.

■ Search order: When more than one standards drawings in the standards
configuration setup have been associated to a style type, the first standards
drawing in the search order will update all other drawings associated to
that style type.

Synchronizing project standards drawings with each other is an automatic
synchronization process, where no user interaction is possible. That means
that no styles or display settings can be excluded from the synchronization
process.

1 Verify that the project of which you want to synchronize the
standards is the current project.
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2 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

3 Select the Project Standards node in the tree view, right-click, and
click Synchronize Project Standards Drawings.

4 When the synchronization is finished, click OK to exit Display
Manager.

NOTE Alternatively, you can click Manage tab ➤ Project Standards

panel ➤  ➤ Synchronize Project Standards  .

Troubleshooting the Display System
If you have problems displaying objects in your drawing, use the following
troubleshooting suggestions.

Object Not Displayed in a Viewport
Why isn’t my object displayed?
When AEC objects in your model do not display correctly in a viewport, the
following actions might help to solve the problem.

■ In the drawing status area, verify the name of the selected display
configuration. Select a different display configuration, and see if the
problem is resolved.

■ In the Display Manager, find out what display set is being used in the
display configuration assigned to the viewport in question. The name of
the current display configuration is highlighted. The name of the current
display set is also highlighted.

■ In the detailed view of the display sets in the Display Manager, make sure
that a display representation for the object is selected in that display set.

■ Is the object hidden because objects of its classification are filtered in the
current display set? On the Display Options tab, verify that objects are not
hidden.

■ If a display representation is selected in the current display set, look at the
display properties of the display representation. Are the display components
turned off? Are components on layers turned off?
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■ Is the display of components controlled by the material assigned (is
ByMaterial selected in the display properties)? If so, look at the display
properties of the material assigned to object components to determine the
settings.

■ Is the object drawn on a layer that is turned off?

Viewport Not Updating Properly
Why isn’t my viewport updating?
Under certain circumstances, such as when you switch view directions in
shade modes other than 2D wireframe, the display is not restored correctly.

In such cases, click View tab ➤ Appearance panel ➤ Regenerate
drop-down ➤ Regenerate Model, and either select the problem AEC object or
press ENTER to select all the AEC objects. This forces the display system to
regenerate all the current display representations.

NOTE Alternatively, enter objrelupdate on the command line.

Objects Copied from Another Drawing Display Differently
I dragged objects to another drawing. Why do they look different now?
Objects dragged or copied from one drawing to another use the display
properties of the display configuration assigned to the viewport in the
destination drawing. The display configuration in the original drawing is not
copied with the objects.

Verifying the Existence of Objects Not Displayed in a Drawing
Is there a quick way to verify that an object exists in a drawing but is not
displayed?
Enter DisplayDxfName on the command line to label each object in the
drawing with its name. Labels appear even for objects that are not displayed.
For example, if you created a display set that did not include a display
representation for doors, and you then assigned the display set to a display
configuration used in the current viewport, doors would not be displayed in
that viewport. An object can also exist in a drawing and not be displayed if
the object was filtered by its classification in the current display set.

DisplayDxfName can help you determine whether the objects are simply not
displayed or if they are not present.
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1 At the command line, enter displaydxfname.

2 Enter y (Yes).

3 Click View tab ➤ Appearance panel ➤ Regenerate
drop-down ➤ Regenerate Drawing And Viewports.

NOTE Alternatively, enter rea on the command prompt.

Displaying the names of objects, including those that are not shown

4 To turn off object names, enter displaydxfname.

5 Enter n (No).

Object Linetype Displayed Incorrectly
Why doesn’t the linetype for my object display the way I expect?
The linetype scale for components of AEC objects works with the AutoCAD
linetype scale specified in the LTSCALE variable to control the linetype of AEC
objects. The default value for linetype scale of all components of AEC objects
is 1.0. This value is multiplied by the current value for LTSCALE to produce
the linetype scale of object components.

For example, if the LTSCALE value is 48.0, and the linetype scale in the display
properties of an object is 1.0 for an object component, then the linetype scale
of the component is 48.0. If you change the linetype scale in the display
properties to 2.0, the linetype scale of the component is effectively 96, or
2.0 x 48.
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Style Manager

The Style Manager is an AutoCAD Architecture utility that provides a central location for
working with the styles that determine the function and appearance of objects in your drawing.

What Are Styles?
Styles are sets of parameters that determine the function and appearance of
objects in AutoCAD Architecture drawings. For example, a door style specifies
a door’s type (single or double, bi-fold or hinged) and shape (rectangular or
arched), as well as its default frame dimensions, standard sizes, materials, and
display properties.

Each object in a drawing is an instance of a particular style. You use the same
style for all objects that are to have the same characteristics. For example, you
might use one door style for all office doors in a building and another for all
fire doors.

Generally a style is applied to an object through the tool you use to create the
object. After the object is created, you can apply a different style to it or edit
the style, either in the Style Manager or in a dialog accessed from the object’s
context menu. When you edit a style, the changes apply to all instances of that
style in your drawing, making this an efficient way of modifying a large number
of objects at once.

AutoCAD Architecture uses styles to define objects in 3 different categories:

■ Architectural objects, such as walls, doors, and windows

■ Documentation objects, such as 2D sections/elevations, dimensions, and
schedule tables

■ Multi-purpose objects, such as layer keys, mass elements, and material
definitions

13
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Where Are Styles Located?

For most architectural, documentation, or multi-purpose objects, there is a
default standard style, which you can access and customize through the Style
Manager. The default tool palettes also provide tools representing many specific
styles. For example, the Doors tool palette includes tools for creating door
objects of the Bifold - Double style, the Bifold - Single style, the Cased Opening
style, and so on. As soon as you use one of these tools to add an object to your
drawing, the associated style is added to the list of styles for that drawing in
the Style Manager, where you can view and edit the properties that define the
style.

Additional predefined styles are provided in the Stock Tools catalogs accessible
through the Content Browser. All styles are defined in Styles drawings located
in the C:\ProgramData\Autodesk\ACA 2012\enu\Styles\Imperial or Metric folder.

For more information about specifying the location of files at installation, see
“Install AutoCAD Architecture 2012” in the AutoCAD Architecture 2012 Installation
Guide.

Styles in External References

You cannot change an object style in an external reference while refediting
it from its host drawing. You can open Style Manager and make changes, but
they will not be saved when the external reference is saved and closed in the
host drawing. To make changes to styles in external references, you need to
open the external reference drawing directly, make the changes there, and
save it. The external reference should then be reloaded to update the changes.

Style Manager Overview
The Style Manager is an AutoCAD Architecture utility that provides a central
location where you can view and work with the styles that determine the
appearance and function of objects in drawings.

You can also manage layer key styles, schedule data formats, and definitions
for cleanup groups, mask blocks, multi-view blocks, profiles, and property
sets.

The Style Manager allows you to readily create or customize styles and share
them with other users. In the Style Manager, you can perform the following
tasks:

■ Access styles from open drawings and intranet sites

■ Drag styles onto a palette to create tools
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■ Set up new drawings and templates by copying styles from other drawings
or templates

■ Sort and view the styles in your drawings and templates by drawing or by
style type

■ Preview an object with a selected style

■ Create and edit styles

■ Delete unused styles from drawings and templates

■ Send styles to other AutoCAD Architecture users by email

Opening the Style Manager

To open the Style Manager, click Manage tab ➤ Style & Display panel ➤ Style

Manager  .

You can also access the Style Manager by right-clicking any style-based object
tool on a tool palette and clicking <object type> Styles.

The Style Manager

The Style Manager is split into 2 resizable panes and has a menu bar, a toolbar,
and a status bar. When you open the Style Manager, all drawings and templates
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that are open in the current session are displayed in the tree view in the left
pane.

Left Pane of the Style Manager

The left pane of the Style Manager displays the styles in all open drawings
and templates in a hierarchical tree view that you can navigate by expanding
and collapsing the different levels in the tree. By default, styles in the tree
view are sorted by the drawing that contains them, but you can also sort them
by style type. The tree view is always displayed in the left pane, regardless of
how you sort the styles.

Styles are organized into 3 categories: Architectural Objects, such as Door
Styles; Documentation Objects, such as Schedule Table Styles; and
Multi-Purpose Objects, such as Layer Key Styles. Within each category, styles
are listed alphabetically. To filter the tree view so that only styles of one style
type are displayed, select a style type, and on the Style Manager toolbar, click

 . To redisplay all styles, click  again.

NOTE If drawings or templates are read-only, their read-only status is indicated
by a lock on the folder next to the drawing in the tree view and also by a lock icon
on the status bar.

Right Pane of the Style Manager

The style information displayed in the right pane depends on what you select
in the tree view in the left pane. For example, when the tree view is sorted by
drawing, and a style category is selected, the right pane lists the style types in
the category. If a style type is selected, the right pane lists the styles within
the type. If an individual style is selected, the right pane displays a series of
tabs on which you can edit the properties of the style and preview how an
object will display using that style. When the tree view is sorted by style, you
can select a style type to view the distribution of the styles within that type
across all drawings and templates that are open in the Style Manager.

Style Manager Menu Bar and Toolbar

The top of the Style Manager includes a menu bar and a toolbar for quick
access the menu commands. Pause the mouse over a toolbar icon to display
a tooltip describing the associated command.
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Status Bar

The status bar at the bottom of the Style Manager indicates how styles are
sorted in the tree view (by drawing or by style), the name of the drawing, and
the currently selected style type and style.

Sorting Styles in the Style Manager
Use this procedure to change the way styles are sorted in the Style Manager.
By default, the names of open drawings and templates are displayed in the
tree view in the left pane. When you expand a drawing in the tree view, the
individual styles within the drawing are grouped into 3 categories: Architectural
Objects, Documentation Objects, and Multi-Purpose Objects. If you expand
a category, the individual styles are listed alphabetically by style type.

Styles sorted by drawing

To see the styles available in each drawing for a particular style type, such as
door styles, you can sort by style. Styles are then grouped by category, and
organized by type and then by drawing.
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Styles sorted by style type

The status bar at the bottom of the Style Manager indicates whether the styles
are sorted by drawing or by style type.

To switch how styles are sorted in the Style Manager

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

By default, styles are sorted by drawing.

2 On the toolbar of the Style Manager, click  to sort styles by
style type.

Alternatively, on the menu bar of the Style Manager, click View
menu ➤  Explore ➤ By Style.

3 If you want to view the styles available in a drawing, expand a
category, a style type, and then the drawing.

4 To restore the by-drawing sort order, click  again.

Creating a Style from the Style Manager
If you want to create a new style or definition for a particular type of object,
you can start with the default style properties for that object type, or you can
copy an existing style that has most of the properties you want. In either case
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you then edit the style properties as needed to specify the desired object
characteristics.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager displays with all open drawings listed in the
tree view and the current drawing expanded.

2 Expand the object category (Architectural, Documentation, or
Multi-Purpose) and object type for which you want to create a
style.

3 Choose a method:

Then…If you want to…

right-click the style type, and click
New.

create a style with default properties

expand the style type, right-click
the style you want to copy, and

create a style from an existing style

click Copy. Right-click, and click
Paste.

4 On the General tab, enter a name and description for the new
style.

5 Click other tabs as needed to view and edit the properties.

For detailed information about specifying the properties of a style
for a particular object, see the Help topics associated with that
object type.

6 When you finish specifying the properties of the style, click OK.

The new style will be listed if you open the Style Manager again
while the drawing remains open, but it is not saved until you save
the drawing.

After you have created a style, you can drag it from the Style Manager onto a
tool palette to create a tool. For more information, see Creating a Tool from
a Style on page 876.

Creating a Style from an Object
Use this procedure to create a new style for an object by copying and modifying
its current style. This method lets you change style properties for the selected
object without affecting other objects that use the same style. The new style
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can then be assigned to other objects as needed. This functionality can save
you time if you need to create many styles, or if you need to create templates
or styles draw

1 In the drawing area, select an object with the style you want to
copy.

2 Click <Object> tab ➤ General panel ➤ Copy Style  .

3 On the General tab of the <object type> Style Properties dialog,
enter a name for the new style, or accept the default, which is the
original style name suffixed with an incremental number in
parentheses.

4 Change other properties of the new style as desired.

For more information about changing the properties of an object
style, refer to the appropriate section in the Help. For example,
for information about wall styles, see Wall Styles on page 1296.

5 Click OK.

The new style has been assigned to the object. You can access the
new style in the Style Manager under the appropriate object style
type.

Creating a Tool from a Style
Use this procedure to create a tool from a style. You can create tools from the
following styles and definitions: AEC polygon, curtain wall, curtain wall unit,
door, door/window assembly, mask block, mass elements, multi-view block,
railing, roof slab, schedule table, slab, space, stair, structural member, wall,
window, zone template, and zone.

You can create object tools by dragging a style from the Style Manager to a
tool palette. When you drag a style onto a tool palette, a reference is created
that associates the tool to the style. The reference location can be the current
drawing, another drawing, or a remote location. If you edit the style in the
Style Manager, the tool automatically uses the updated style.

If an existing tool references a style from another drawing, the style is not
added to the current drawing until you add an object of that style to the
drawing. The reference location is used only if the current drawing has been
saved.

For detailed information about creating and customizing tools, see Tools on
page 85.
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1 Open the tool palette on which you want to create a tool.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Locate the style you want to copy, and drag it to the tool palette.

The default tool name is the name of the referenced style.

The image that identifies the new tool uses the view direction last
used in the Properties palette for the selected object type.

4 Click OK.

Renaming a Style
Use this procedure to change the name of a style in an open drawing.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 In the tree view of the Style Manager, right-click the style you
want to rename, and click Rename.

3 On the General tab, enter a new name for the style.

4 Click OK.

The new name will display if you open the Style Manager again
while the drawing remains open, but it is not saved until you save
the drawing.

Copying Styles Between Drawings
Use this procedure to copy styles or definitions from the current drawing to
another drawing. You can copy styles and definitions between existing
drawings. You can also copy them from an existing drawing to a new drawing.

If a style references other styles, those styles are also copied to the other
drawing. For example, if you copy a wall style into a new drawing, the wall
endcap style used in the wall style is also copied to the new drawing.

NOTE You can also drag and drop styles and style types between drawings.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager displays with all open drawings listed in the
tree view and the current drawing expanded.
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2 If the drawing to which you want to copy the style is not listed,
open it or create a new drawing:

Then…If you want to…

in the Style Manager, click

File ➤ Open Drawing, select the
drawing you want, and click Open.

copy the style to a drawing that is
not open in the Style Manager

in the Style Manager, click

File ➤ New drawing, enter a name
for the drawing, and click Save.

copy the style to a new drawing

3 Expand a category, and expand a style type.

4 Select the styles or definitions that you want to copy:

Then…If you want to…

right-click the style or definition,
and click Copy.

copy an individual style or definition

right-click the style or definition
type, and click Copy. If your styles

copy all styles or definitions of a se-
lected type, such as all wall styles

are sorted by style type, right-click
the drawing name under the selec-
ted style or definition type, and
click Copy.

5 Right-click the drawing into which you want to copy the style(s),
and click Paste.

The styles or definitions are pasted into the selected drawing. If
the drawing already contains a style with the same name, the
duplicate name is displayed in the Import/Export - Duplicate
Names Found dialog.

6 Resolve duplicate style names, if prompted:

Then…If you want to…

select Leave Existing, and click OK.prevent the Style Manager from
overwriting the existing style with
the new style of the same name

select Overwrite Existing, and click
OK.

replace the existing style with the
new style
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Then…If you want to…

select Rename to Unique, and click
OK. The Style Manager appends a

keep the existing style and add the
new style with a different name

number to the name of the new
style. Right-click a style, and click
Rename to change a style name.

7 Click OK.

Sending Styles to Other Users
Use this procedure to email styles or definitions to other users of AutoCAD
Architecture. The software creates a new drawing that contains only the style
information from the current drawing and attaches the drawing to an email
message. If email is not available on your system, the Send option is not
available.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand a category.

3 Select the styles or definitions you want to send:

Then…If you want to…

right-click the style or definition,
and click Send.

send an individual style or definition

right-click the style or definition
type, and click Send. If your styles

send all styles or definitions of a se-
lected type, such as all wall styles

are sorted by style type, right-click
the drawing name under the selec-
ted style or definition type, and
click Send.

right-click the drawing name, and
click Send.

send all styles or definitions in the
drawing (styles must be sorted by
drawing)

A new email message with the subject AutoCAD Architecture
Styles is created using your email program. A drawing file
containing the styles and definitions you selected is added to the
message as a file attachment.
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4 Complete and send the message in your email program.

5 Click OK.

Purging Styles
Use this procedure to remove unused styles and definitions from a drawing.
You can purge any styles that are not applied to an object in the drawing and
not used in another style. You can purge either a single unused style or
definition or all those within a selected type. For example, you can purge all
unused wall styles.

Referenced styles or definitions are not purged when you purge the style that
uses them. For example, if you purge a wall style, the wall endcap style and
cleanup group definition used in the wall style are not purged.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed, with the current drawing
expanded in the tree view.

NOTE You can also purge a selected style or style type by pressing
DELETE.

2 Expand a category, and expand a style type.

3 Purge styles or definitions:

Then…If you want to…

right-click the style or definition you
want to remove, and click Purge.

purge one unused style or definition

right-click the style or definition
type, and click Purge. When

purge all unused styles or defini-
tions of a selected type

prompted, verify that the styles you
want to purge are selected, and
click OK.

If a style or definition you selected to purge remains in the list
after purging, the style or definition is currently applied to an
object or is used in another style. For example, you cannot purge
a wall endcap style that is used in a wall style or that is applied
to an individual wall.

4 Click OK.
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Working with Drawings and Templates in the Style
Manager

When you first open the Style Manager, any drawings or templates that are
open in AutoCAD Architecture are displayed in the tree view. You can also
open other drawings or templates and create new drawings or templates within
the Style Manager.

Opening Drawings in the Style Manager

When you create a new drawing or template in the Style Manager, or open
an existing one, that drawing or template is open for use only within the Style
Manager, and not in your drawing session. You need to exit the Style Manager
before you can open the drawing or template in the drawing session.

Determining the Status of a Drawing
To determine whether a drawing or template is open in the software or only
within the Style Manager, look at the icon next to the drawing or template
in the tree view.

Drawing statusDrawing icon

Drawing is open in the software and in the
Style Manager.

Drawing is open only in the Style Manager.

Drawing is locked.

A drawing may be locked in the Style Manager for any of the following reasons:

■ The drawing is read-only.

■ The drawing was created in a previous version of the software.

■ The drawing is referenced into a drawing that is currently open.

■ The drawing is open in another application.

■ The drawing file is locked on a network.
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To view a tooltip stating the reason for the lock, select the drawing in the tree
view, and pause the cursor over the lock icon on the Style Manager status bar
.

TIP You can save your styles in a read-only source drawing and copy them to
other drawings as necessary.

Closing Drawings in the Style Manager

Any drawings and templates that you create or open in the Style Manager are
listed in the tree view every time you open the Style Manager until you close
them from within the Style Manager.

Starting a New Drawing or Template in the Style Manager
Use this procedure to start a new drawing or template in the Style Manager.
The new drawing or template does not contain any styles and is open for use
in the Style Manager only. It is not open in the AutoCAD Architecture session.
You can open the new drawing or template in the software after you exit the
Style Manager.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 On the Style Manager menu bar, click File ➤ New Drawing, or on

the Style Manager toolbar, click  .

3 In the New Drawing dialog, for File Name, enter the new drawing
name.

4 For Files of Type, select Drawing (*.dwg) to create a drawing, or
select Drawing Template (*.dwt) to create a template.

5 Click Save.

6 Click OK.

Opening a Drawing or Template in the Style Manager
Use this procedure to open a drawing or template in the Style Manager. The
drawing or template will be open only within the Style Manager; that is, it
will not be open in the AutoCAD Architecture drawing session. You can open
the drawing in the software after you exit the Style Manager.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .
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2 In the Style Manager, click File ➤ Open Drawing, or on the Style

Manager toolbar, click  .

3 Select one or more files, and click Open.

4 Click OK.

Dragging a Drawing into the Style Manager
Use this procedure to open a drawing or template in the Style Manager by
dragging it from Microsoft® Windows® Explorer. The drawing or template
will be open only within the Style Manager; that is, it will not be open in the
AutoCAD Architecture session. You can open the drawing in the software after
you exit the Style Manager.

1 In the Style Manager, sort the styles by drawing.

2 Start Microsoft Windows Explorer.

3 In Windows Explorer, select the drawing or template that you
want to open in the Style Manager.

4 Drag the drawing into the tree view in the Style Manager.

5 Click OK.

Closing Drawings and Templates in the Style Manager
Use this procedure to close a drawing or template that is open only in the
Style Manager. If a drawing is open in the AutoCAD Architecture session, you
cannot close it in the Style Manager.

1 In the Style Manager, sort the styles by drawing.

2 Select the drawing or template that you want to close.

3 In the Style Manager, click File ➤ Close.

4 Click OK.
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Materials

A material in AutoCAD Architecture corresponds to a specific finish material in a building
model, such as brick, concrete, or glass. Materials are useful for illustrating plans, sections,
elevations, and renderings in the design process. Materials also provide a way to manage the
display properties of object styles.

Materials
A material in AutoCAD Architecture corresponds to a specific finish material in
a building model, such as brick, concrete, or glass. Materials are useful for
illustrating plans, sections, elevations, and renderings in the design process.
Materials also provide a way to manage the display properties of object styles.

Viewing a building model corner showing materials

Simplifying the Design Process

Using materials makes displaying objects more realistic. You define the display
of a material, such as brick or glass, only once in the drawing or the drawing
template, and then assign it to the component of an object where you want the
material to display. For example, you can define a material “Glass” and then

14
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assign it to any number of windows, glass door insets or cubicle walls. You
typically assign materials to components in the style of an object, such as the
brick in a wall style. Then, whenever you add a wall of that style to your
drawing, the brick of that wall displays consistently.

Defining materials in an object style can provide control for the display of
objects across the whole project. When the characteristics of a material change,
you change them just once in the material definition and all objects that use
that material are updated. With the material tool you can apply a material to
a single instance of the object.

Visual Styles and Render Materials

You can take advantage of Visual Styles, Rendering Materials, Lights, and
Cameras in AutoCAD Architecture. In Content Browser, a Visualization catalog
lets you access a number of predefined tools for lights, rendering materials,
cameras, and visual styles. For more information about these visualization
features, see “Create Realistic Images and Graphics” in the AutoCAD help.

Predefined Materials

AutoCAD Architecture provides a number of predefined material definitions
for common design purposes, making it easy for you to start with new
drawings. You can use these predefined material definitions “as is” or modify
them to fit your designs. You can also create your own material definitions.
Object styles provided with the software already have material definitions
assigned to them.

Surface Hatching

Materials provide the ability to assign surface hatches to objects. Surface
hatches can be displayed in model, section and elevation views. You can
control the placement and orientation of the hatch for each object face.

Section Hatching

Materials are helpful to clearly illustrate sections and elevations. The section
hatch is specified independently of the surface hatch. Special material
components allow a realistic or schematic display of rendered live section
views, section cuts, and section bodies.

For more information about live section views, see Creating and Editing a Live
Section View on page 3275.
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Rendered live section view with transparent outside material

Material Tool

You create a material tool from a material definition. You can then use this
tool in the same way that you would use any other tool in your project. For
more information about working with tools, see Tools on page 85. This is the
most efficient method of applying a material definition to an object or the
component of an object. For more information, see Creating a Material Tool
from a Material Definition in Style Manager on page 893.

Objects That Support Materials
Objects to which you assign materials are typically three-dimensional (3D)
objects. Two-dimensional (2D) objects, such as areas, grids, or AEC polygons,
are more like symbolic representations and drawing aids than actual building
objects.

Not all components of an object can take on a material definition. For example,
a door swing is a symbolic graphic, therefore, it does not support a material
assignment. The appearance of a door swing is specified in the display
properties of a door style. The door frame, however, is a physical part of the
door, and a material definition can be assigned to it.

Components that support materialsObject

infills, frames, mullionsCurtain Walls/Curtain Wall Units
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Components that support materialsObject

frames, panels, stops, insets, muntinsDoors

infills, frames, mullionsDoor/Window Assemblies

mass element bodyMass Elements

mass group bodyMass Groups

guardrails, handrails, bottom rails, posts, bal-
usters

Railings

roof bodyRoof

slab body, slab edge, fascias slab, edge soffitsSlabs/Roof Slabs

interior boundary, exterior boundarySpace Boundaries

floor, ceilingSpaces

tread, riser, landingStairs

beam, brace, column bodyStructural Members

wall body, wall shrinkwrap, wall componentsWalls

glass, frames, sashes, muntinsWindows

Assigning Materials to Objects and Object Styles

The most efficient way to use materials is to apply them to a style. Any object
of that style inherits those definitions or the relevant properties. As you add
new objects of a style to your project, each will have the same materials
assigned to them.

You can also assign materials directly to an object. You may want to do so in
these cases:

■ You want to override the existing material for a specific object.

■ The object in question does not support styles, but does support materials.
(This is the case for AEC polygons.)
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Examples of Material Assignments

Assigning a material to components of an object will change how the object
displays in plan, isometric, section, and elevation views.

For example, if you want to draw a brick exterior wall, you can assign a material
that displays a brick surface hatch in model view and a realistic brick display
for a rendered view.

Brick wall in hidden line and rendered views

If there are special insulation components in a wall, you can assign a light,
half-transparent material to them. For sectioning the wall, you can assign a
specific section hatch pattern or fill that differs from the regular brick surface
hatch.
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Section fill material in a rendering

In another example, you can assign materials to the floor and ceiling
components of a space such as a carpet material to the floor and tile to the
ceiling.

Working with Material Tools
You can apply materials to objects in 2 different ways:

■ Assign material definitions to individual components of an object through
the display properties of its style. For more information, see Process
Overview: Creating and Assigning Materials on page 917.

■ Use a material tool to apply a material definition directly to an object
component in the drawing. For more information, see Using the Material
Tool to Add Materials to Objects on page 891.

■ Apply a render material from an AEC material definition to an AutoCAD
object. For more information, see Creating a Material Tool from a Render
Material in the Content Browser on page 895.
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The Design tool palette includes the default Material tool, which references
the Material Definitions file and allows you to apply any of those material
definitions. Many of these material definitions can also be applied through
material-specific tools located on the Materials tool palette in the Visualization
palette group.

You can also create custom material tools from other existing tools, from
material definitions in Style Manager, or from render materials in the Content
Browser. For more information, see Creating Custom Material Tools on page
893.

Using the Material Tool to Add Materials to Objects
Use this procedure to configure the default Material tool and use it to apply
an existing material definition to a component of an AEC object in a drawing.
By default, the tool applies the Standard material definition, but you can
modify the tool properties to specify any of the materials defined in the
Material Definitions (Imperial).dwg or Material Definitions (Metric).dwg files.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Design Tools

 .

2 On the Design palette, do one of the following:

Then…If you want to…

click the Material tool.apply the Standard material defini-
tion

right-click the Material tool, and
click Properties. Expand Ba-

select a different material definition

sic ➤ General, click the value for
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Then…If you want to…

Definition name, and select the de-
sired definition. Then click OK, and
click the Material tool.

TIP A number of prefabricated material tools are available on the
Materials palette in the Visualization palette group.

The cursor symbol changes to a small square. As you move it over
an object component, the component highlights and a tooltip
identifies the component and the material to be applied to it.

If a component does not support materials in the current view
direction, does not support materials at all, or is in an xref, the
tooltip informs you the material cannot be applied, and the cursor
changes to a slashed red circle until you move it off that
component.

NOTE For information about which objects can have materials
assigned, see Objects That Support Materials on page 887.

3 Move the cursor over the object in the drawing until the desired
component is identified in the tool tip, and then click to apply
the material.

4 If you want the material to be applied to this component in all
objects of this style, press ENTER. If you want it applied only to
this component in the current object, enter O, and press ENTER.
(Applying the material to the style is the default option for the
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first use of the tool on any component; if you choose to apply
the material only to the current object, that becomes the default
option, and you would need to enter S to apply the material to
the style the next time you use the tool on that component. In
other words, whichever option you choose becomes the default
for the next use of the tool.)

NOTE For non-style based objects, such as a roof, the material
definition (or the render material part of it in the case of an AutoCAD
object) is applied to the object as soon as you click. You are not
prompted about applying the material to the style, and you do not
have to press ENTER.

Creating Custom Material Tools
In addition to using the standard Material tool on the Design tools palette,
or the material-specific tools on the Materials tools palette in the Visualization
tool palette group, you can create your own material tools in a number of
ways, as explained in the following topics.

Creating a Material Tool from a Material Definition in Style
Manager

You can create a new material tool from a material definition in Style Manager.

NOTE You can create a material tool from Style Manager only if the drawing
containing the material definition has been previously saved.

1 Create a material definition as described in Creating and Editing
Material Definitions on page 919

2 Make the tool palette active on which you want to place the new
material tool.

3 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

4 Expand Multi-Purpose Objects, and expand Material Definitions.

5 Select the material definition that you have created, and drag it
from Style Manager to the active tool palette.

6 Close Style Manager.
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The material definition has been added as a material tool to the
tool palette. You can use it to apply the material to objects, as
described in Using the Material Tool to Add Materials to Objects
on page 891.

NOTE The material tool uses the material definition you selected in
Style Manager. The style location of the material tool is the drawing
containing the definition. This means that when using this material
tool you have access to all material definitions contained in the
drawing.

Copying a Material Tool on a Tool Palette
You can create a new material tool by copying and pasting an existing tool
on a tool palette.

1 Select a material tool from one of these locations on the tool
palettes set:

■ the Design tool palette (contains the default material tool)

■ the Materials tool palette (in the Visualization tool palette
group)

■ user-defined palettes and tools

2 Select the material tool, right-click, and click Copy.

3 If you want to paste it onto a different palette, make the palette
active.

4 On the palette, right-click, and click Paste.

5 Select the tool, right-click, and click Properties.

6 To change the associated material definition, select a different
definition under Definition Name.

7 To select a different source drawing, click Browse under Style
Location.

8 In the Select a location File dialog box, select a source drawing,
and click Open.

9 Select a material definition from the selected source file.

10 To update the material tool icon with the new material, select the
icon under Image in the top left corner, right-click, and click
Refresh Image.
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11 Click OK.

Creating a Material Tool from a Render Material in the Content
Browser

You can create a material tool by dragging a render material from Content
Browser to AutoCAD Architecture.

Creating a new material tool in a drawing entails the creation of a new material
definition in Style Manager. The material definition is used to create the
material tool, but can also be used for different purposes in the drawing, like
using the material definition to create object styles.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Open the Visualization catalog and navigate to the Render Material
category. Then, select the material you require.

3 Move the pointer over the i-drop® icon next to the tool so that

the pointer image changes to an eyedropper (  ).

4 Click and hold the i-drop® icon until it is full.

5 Use one of the following options to copy the render material to
AutoCAD Architecture:

■ Drag the material from Content Browser into an AutoCAD
Architecture drawing.
If you drag a render material from Content Browser directly
into an AutoCAD Architecture drawing, an AutoCAD
Architecture material definition is created from it. You cannot
directly create an AutoCAD Architecture material tool this
way. The new material definition is listed in Style Manager,
where you can create a material tool from it, as described in
Creating a Material Tool from a Material Definition in Style
Manager on page 893.

■ Drag the material from Content Browser onto an AutoCAD
Architecture palette.
If you drag a render material to an AutoCAD Architecture
palette, a “temporary” material tool is created.
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6 If you have dragged the render material directly into an drawing,
the Create AEC Material worksheet is displayed.

■ For AEC Material to use as a Template, select an existing
material definition that contains the parameters you want to
use.

NOTE The material definition you select as template will define
all initial material settings except for the rendering material. These
include the layer, color, and linetype settings, hatching, surface
hatch assignments, and the behavior of the material when used
in a section.

■ Enter a name for the new material definition.

■ Click OK.

The option to automatically create a material tool from the new
material definition is grayed out. To create a material tool, see
Creating a Material Tool from a Material Definition in Style
Manager on page 893.
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7 If you have dragged the render material onto an AutoCAD
Architecture palette, finish the creation of the AEC Material tool.

■ Select the temporary icon on the tool palette.

■ In the Create AEC Material Worksheet, select an existing
material definition for AEC Material to use as a Template.

NOTE The material definition you select as template will define
all initial material settings except for the rending material. These
include the layer, color, and linetype settings, hatching, surface
hatch assignments, and the behavior of the material when used
in a section.

■ Enter a name for the new material definition.

■ Verify that Convert to AEC Material tool is selected.

■ Click OK.
A notification message appears, reminding you to save the
drawing after dismissing the notification so that the material
tool is saved with the current drawing.

8 If you have created a material tool by dragging a render material
to a tool palette, update the tool image to display the AutoCAD
Architecture material tool icon.

9 Select the material tool on the palette, right-click, and click
Properties.

You can see that the icon preview is different from the Viewer
preview.
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10 Select the icon preview under Image, right-click, and click Refresh
Image. Then, click OK.

The material tool is now represented on the palette by the
AutoCAD Architecture cube icon with correct material display.

Material Components and Display Properties
Each material definition has the following display components that determine
the appearance of object components to which a material has been assigned:

■ Linework

■ Plan Hatch 3D Body

■ Surface Hatch

■ Section Hatch

■ Sectioned Body and Boundary

After you have specified display components of an object to be By Material,
then you can no longer change the display component properties of that
object.

The material components correspond to groups of object display properties
or to display property types. For example, the material Linework component
determines the appearance of linework components in 2D plan views, such
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as wall shrinkwraps, mass element boundaries or door frames. Surface Hatch
determines the appearance of all surface hatching on objects in model and
elevation views.

When you specify that the component of an object is displayed by material,
the component uses the display properties of the associated material, instead
of the display properties of the object. Only object components that correspond
to a physical component of the object can be assigned material definitions.
For more information, see Objects That Support Materials on page 887.

Material definitions cannot be assigned to a custom display block, but objects
that are within custom display blocks may have material definitions assigned.

For a detailed list of object components mapped to material components, see
the Help topics for the objects.

Linework Material Component
The Linework component is used for object components representing linework
in 2D plan and elevation views, such as wall boundaries, door frames, or mass
element boundaries.

Viewing wall plan view linework material components

Plan Hatch Material Component
The Plan Hatch component is used for hatching display components in plan
views, such as wall component hatches, mass element hatches, and slab
hatches.
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Viewing wall plan view hatching material components

3D Body Material Component
The Body component is used for object components representing linework
in 3D model views, such as wall bodies, mass element boundaries, door frames,
and window frames.

Viewing 3D body material components

Surface Hatch Material Component
The Surface Hatch component is used for hatching display components in 3D
model views, sections, and elevations. Section hatching is used on the cut
face of a sectioned object or component.

900 | Chapter 14   Materials



Viewing surface hatching material on a wall elevation

You can specify the faces of an object that display the surface hatch within
the material definition. For example, you can specify that the hatch be on
only the front and left side of the object.

Specifying wall face surface hatching assignments

For more information about surface hatch faces, see Specifying the Surface
Hatch Pattern of a Material Definition on page 923.

2D Section/Elevation Linework
The 2D Section/Elevation Linework component is used specifically for 2D
building sections or building elevations. All linework in a 2D section/elevation
can be controlled by this component. For more information about using
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material definitions in elevations, see Surface Hatch Linework in Elevations
on page 3376.

Viewing 2D elevation linework on a wall

Section Hatch Material Component
The Section Hatch component is used specifically for building sections. It is
used for hatches on object faces cut by a section line. Section hatches can be
applied to 2D sections, 3D sections, and live section views. For more
information about using material definitions with sections, see Section Hatch
Linework on page 3311.

Viewing a 2D wall section with section hatch

Sectioned Body and Sectioned Boundary
The Sectioned Body and Sectioned Boundary components display only in live
section views. Live section views are special section views of a 3D building
model. The building objects are not converted into a section object but are
retained as individual objects in the section. They keep their properties and
display components and may be edited in the section. The display of the views
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exterior to the live section is changed to be Sectioned Body. This display can
be semi-transparent or hidden.

DescriptionMaterial Component

the objects or object parts outside the sec-
tion

Sectioned Body

the outline of the cut line created by the
section

Sectioned Boundary

For detailed information about live section views, see Creating and Editing a
Live Section View on page 3275.

Live section view with sectioned body (gray) and sectioned boundary (red)

Displaying Materials in a Drawing
Use this procedure to turn on material definitions in a display representation
if they are assigned to objects but are not displayed in the drawing. For more
information, see Display System Structure on page 801.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Configurations.

The current display configuration is marked in bold.

3 Expand the current display configuration.
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4 Select a display set in the current display configuration.

5 Click the Display Representation Control tab.

6 Scroll to Material Definition and select a display representation.

By default, material definitions have only a General display
representation. If this is the only available display representation
listed, select it. If you created another display representation for
material definitions, you can select that representation instead.

NOTE Make sure that you select only one display representation for
material definitions in each display set. You should also verify that
the component’s object layer is turned on.

7 Repeat steps 4–6 to select a display representation for material
definitions in the other display sets in the current configuration.

8 Click OK.

The material assignments you made now display in the drawing.

Working with Surface Hatches
Surface hatches are hatch patterns on three-dimensional (3D) objects that
display in 3D model views and elevation views.

Each 3D object has a number of faces: Top, Bottom, Left, Right, Front, and
Back. You can decide whether an object should carry a surface hatch. For
example, if you view a wall in 3D view, you might want to hatch only the
side facing you to avoid cluttering the drawing.

The faces of an object that carry the surface hatch are specified in the material
definition. All objects with that material definition assigned show the same
surface hatch assignment, unless you create an individual surface hatch
override.

Defining the faces on a regular object, such as a wall, slab, or box-shaped mass
element, is intuitive. Front, Back, Left, Right, Top and Bottom are clearly
defined faces that can easily be assigned material definitions. However, defining
the direction in which each face lies can be more complex for different,
irregularly shaped objects, such as curved objects, extrusion objects, or Free
Form objects resulting from Boolean operations.

For information about changing the surface hatch assignments of a material
definition, see Specifying the Surface Hatch Pattern of a Material Definition
on page 923.
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For information about surface hatch overrides, see Overriding the Surface
Hatch on Individual Objects on page 909.

Specifying object face material assignments

Surface Hatches on Curved Surfaces
Curved surfaces do not have all the view directions you can specify in the
material definition. It is important to know that the faces are designated on
curved surfaces to understand how surface hatching is applied when these
objects are assigned material definitions.

An object with a vertically curved surface, such as a Barrel Vault mass element,
has no front and back faces, as nothing could delineate them. The curved
surface of the Barrel Vault mass element is considered to be the top face of
the object.

Barrel vault mass element with material assigned to top face
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An object with a horizontally curved surface, such as a Cylinder mass element,
has no left and right sides, as nothing can delineate them. The curved surface
is considered to be the front face.

Cylinder mass element with material assigned to front face

An object that has only one curved surface, such as a Sphere mass element,
has only a front face.

Sphere mass element with material assigned to front face

Surface Hatches on Multiple Faces
Irregular and complex objects can have multiple faces in one view direction.
If necessary, you can override the surface hatch on all faces with the same
view direction, or on individual faces. For information about overriding
individual faces, see Overriding the Surface Hatch on Individual Objects on
page 909.

Stair with material assigned to treads

906 | Chapter 14   Materials



Surface Hatches on Extrusions
The surface hatch placement on objects created from an extruded profile
depends on two factors:

■ the view directions assigned to the individual edges of the profile

■ the direction of the extrusion
The desired extrusion direction depends on the object you want to extrude
from the profile. A rail, for example, is extruded in the X direction. A railing
post is extruded in the Z direction. Custom door and window shapes are
extruded in the Y direction.

Face assignments from edges extruded in the X direction

Face assignments from edges extruded in the Y direction
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Face assignments from edges extruded in the Z direction

Specifying Faces on Extrusions
Use this procedure to specify the faces on object components created from
extruding a profile. These objects and components include extruded mass
elements, wall body modifiers, custom railing components, and other
components extruded from a profile.

When you create a profile, all the edges are marked for extrusion in the Z
direction. These edge positions are calculated based upon the quadrant in
which the midpoint of the edge lies. You can change the view direction of
edges and the extrusion direction in the profile definition.

Determine the direction of the profile edges before creating objects from the
profile. For example, if you created a profile for a custom railing baluster and
specified the direction of the individual edges, any baluster added to the railing
based on that profile has those assignments. If you later change the edge view
direction in the profile, existing balusters do not change accordingly.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Profiles.

3 Select the profile for the extrusion.

4 Click the Profile Edges tab.
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5 Select an extrusion direction.

6 For each edge, select a position that corresponds to the view
direction you want to assign to the face created from that edge.

The edge positions that are available depend on the extrusion
direction you selected.

7 Click OK.

Surface Hatches on Free Form Mass Elements
Free Form mass elements are created when you perform a Boolean operation
on a standard mass element by adding, subtracting or intersecting another
mass element. The resulting mass element can be irregularly shaped. For more
information, see Mass Elements and Mass Groups on page 1003.

When a mass element is converted into a Free Form mass element, all previous
material assignments of the source mass elements are lost. The new mass
element reverts to the Standard material definition. You can assign another
definition to the new mass element.

Overriding the Surface Hatch on Individual Objects
The surface hatch specified for a material determines the display of objects
that are assigned the material in elevation and model views, as well as the
appearance in rendered views. The material definition specifies which faces
of objects—Top, Bottom, Left, Right, Front, Back—display a surface hatch.
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However, in some instances, you may want to override the surface hatch for
a selected face of an object. For example, you may want to turn off the surface
hatch where it could obscure small details of an object when the drawing is
plotted.

Override Operations

You can change the surface hatches for faces of individual objects in the
following ways:

■ hide the surface hatch

■ change the rotation of the surface hatch

■ change the vertical and horizontal offsets of the surface hatch

You can also specify whether the changes are applied only to the selected face
or to all faces of the object with the same direction—for example, to all front
faces.

Multiple Surface Hatch Overrides

You don’t need to create separate overrides for individual changes; you can
create one surface hatch override that is both rotated and offset. In most cases,
this is the preferred method of working. However, in some cases, you need to
assign more than one override. For example, suppose you want to rotate the
surface hatch of all front faces of a column, and you want to offset one
individual front face. You first add an override for the rotation and select All
Front Faces. Then you add an override for the offset in which you select Only
Selected Front Face.

Hiding a Surface Hatch
Use this procedure to hide the surface hatch on an object face.

To add an override to a surface hatch, an object needs to have a surface hatch
material assigned to it. A surface hatch on an object can come from an assigned
material or from the display properties of the object or object style.

If a surface hatch comes from the display properties of the object instead of
from the material assignment, you cannot override it on individual faces. You
receive an error message upon selecting the object face.
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1 Select the object for which you want to hide an individual surface
hatch, then click <Object> tab ➤ Surface Hatch panel ➤ Add

Override  .

2 Select the object face where you want to hide the surface hatch.

A profile surrounds the selected face.

Profile defining a face of a wall

3 Specify where the override applies:

Then…If you want to…

select Only Selected <Direction>
Face for Faces. For example, to ap-

override only the selected face of
the object

ply a surface hatch override only to
the selected Front face of a wall,
select Only Selected Front Face.

select All <Direction> Faces for
Faces. For example, to apply a sur-

override all faces of the object in
the same view direction

face hatch override to all Top faces
of a selected column, select All Top
Faces.

4 Select Hide Surface Hatching.
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Surface hatch hidden on the front face of a wall

5 Click OK.

Displaying a Hidden Surface Hatch
Use this procedure to display a previously hidden surface hatch.

An object must have a surface hatch material assigned to it in order to add an
override to a surface hatch. A surface hatch on an object can come from an
assigned material or from the display properties of the object or object style.

If a surface hatch comes from the display properties of the object instead of
from the material assignment, you cannot override it on individual faces. You
receive an error message upon selecting the object face.

1 Select the object for which you want to redisplay a hidden
individual surface hatch, and click <Object> tab ➤ Surface Hatch

panel ➤ Edit Override  .

2 Select the profile around the hidden surface hatch.

3 Click Edit In Place tab ➤ Profile panel ➤  Edit Hatch Override
.

4 Under Overrides, clear Hide Surface Hatching.

5 Click OK.
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6 Click  (Finish) on the Edits panel to save the changes.

Specifying the Rotation of a Surface Hatch
Use this procedure to specify the rotation of a surface hatch.

1 Select the object for which you want to rotate an individual surface
hatch, and click <Object> tab ➤ Surface Hatch panel ➤ Add

Override  .

2 Select the object face where you want to change the rotation.

A profile surrounds the selected face.

3 Specify where the override applies:

Then…If you want to…

select Only Selected <Direction>
Face for Faces. For example, to ap-

override only the selected face of
the object

ply a surface hatch override only to
the selected Front face of a wall,
select Only Selected Front Face.

select All <Direction> Faces for
Faces. For example, to apply a sur-

override all faces of the object in
the same view direction

face hatch override to all Top faces
of a selected column, select All Top
Faces.

4 Specify the rotation of the surface hatch.
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Specifying surface hatch rotation angles

5 Click OK.

Specifying the Horizontal and Vertical Offset of a Surface Hatch
Use this procedure to specify the horizontal and vertical offset of a surface
hatch.

An object must have a surface hatch material assigned to it in order to add an
override to a surface hatch. A surface hatch on an object can come from an
assigned material or from the display properties of the object or object style.

If a surface hatch comes from the display properties of the object instead of
from the material assignment, you cannot override it on individual faces. You
receive an error message upon selecting the object face.

Changing the offsets of a surface hatch lets you adjust the hatch pattern on
individual faces to align with the face edges or to improve the appearance of
the hatch.
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Specifying surface hatching offset and alignment

1 Select the object for which you want to change the hatch pattern
offset, and click <Object> tab ➤ Surface Hatch panel ➤ Add

Override  .

2 Select the object face where you want to change the hatch pattern
offset.

A profile surrounds the selected face.

3 Specify where the overrides applies:

Then…If you want to…

select Only Selected <Direction>
Face for Faces. For example, to ap-

override only the selected face of
the object

ply a surface hatch override only to
the selected Front face of a wall,
select Only Selected Front Face.

select All <Direction> Faces for
Faces. For example, to apply a sur-

override all faces of the object in
the same view direction

face hatch override to all Top faces
of a selected column, select All Top
Faces.

4 Specify the horizontal and vertical offsets of the surface hatch.

5 Click OK.
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Editing Surface Hatch Overrides
Use this procedure to edit a surface hatch override that you applied to an
object.

1 Select the object that has a surface override you want to change,
and click the <Object> tab ➤ Surface Hatch panel ➤  Edit Override

 .

2 Select the profile of the face you want to edit.

If you have multiple surface hatch overrides on one object face,
be sure to select the override you want to change.

3 Click Edit In Place tab ➤ Profile panel ➤  Edit Hatch Override
.

4 Edit the surface hatch override:

Then…If you want to…

select Hide Surface Hatching.hide a surface hatch

clear Hide Surface Hatching.re-display a hidden surface hatch

enter a value for Rotation, or click

 and specify the rotation on
screen.

change the rotation of the surface
hatch

enter a value for X Offset or Y Off-

set, or click  and specify the
offset on screen.

change the offset of the surface
hatch

5 Click OK.

6 Click  (Finish) on the Edits panel to save the changes.

Displaying a List of Materials
Use this procedure to create a list of material definitions and corresponding
volumes for the objects that you select. The list includes all material definitions
used in the selected objects as well as the total volume of each material
definition. You can use the information for preliminary cost estimates.
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1 On the command line, enter materiallist.

2 Select the objects you want to include in the list, and press ENTER.

3 Press F2.

The material definitions list is displayed in the AutoCAD® text
window.

NOTE You can also select the list of material definitions, and then press CTRL+C
to copy it, and CTRL+V to paste it into Microsoft® Word.

Displaying a Material Query
Use this procedure to obtain volume information for a selected material
definition. The results of the query include the total volume for all objects
with a selected material definition. For example, if you have two brick walls
within your selection set, and each has a volume of 8.85 m3, the overall
volume of brick objects is listed as 17.7 m3. You can use that information for
preliminary cost estimates.

1 On the command line, enter materialquery.

2 Select the objects you want to include in the query, and press
ENTER.

3 Select the material definition you want to query.

For example, if you want to query for bricks, select Brick from the
list.

4 Click OK.

All objects assigned the selected material definition are highlighted
in the drawing.

5 Press F2.

The volume for the selected material definition is displayed in
the AutoCAD® text window.

Process Overview: Creating and Assigning Materials
AutoCAD Architecture offers a number of predefined building material
definitions in the drawing templates. You can also create your own custom
material definitions. All material definitions used in a project are listed under
Material Definitions in the Style Manager.
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The material definitions are listed in alphabetical order. Devising a naming
convention for your material definitions allows you to locate them quickly.
For example, you might create glazing definitions named
“glass.interior.clear,”“glass.exterior.tinted,” and “glass.exterior.clear.” These
would appear in the following order under Material Definitions:

■ glass.exterior.clear

■ glass.exterior.tinted

■ glass.interior.clear

The following steps describe the process of creating a material definition and
assigning it to an object or object style:

1 Create a material definition for each material needed and specify the
display properties of these definitions.

For example, create a brick material definition that shows a dark red
surface hatch, matching dark red linework components, an appropriate
section hatch, and a brick rendering material. Or, create a glass material
definition that has light blue linework, a transparent surface, and a light
blue rendering material.

For more information, see Creating and Editing Material Definitions on
page 919.

2 In object styles, assign a material definition to represent each component.

For example, in a window style, assign a wood material definition to the
frame and the muntins and a glass material definition to the window
glass. Or, if you are working with a wall style, assign a brick material
definition to the wall body and an insulation material to insulation
components.

3 Make sure that the corresponding display properties of the object or
object style are in all display representations specified as By Material.

4 For object components that do not use material definitions, specify the
display properties in each display representation.

For example, if you want the graphic representation of a door swing to
match the dark brown door frame, open the display properties of the
door style, and change the color of the door swing to a dark brown.
Perform this step for each display representation in which the door swing
appears.
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When you create objects from these styles, their components are displayed
as follows:

■ If you have selected By Material in the Display Properties, then the
object components that have material definitions assigned show the
display properties you specified in the material definition.

■ Object components that have no material definitions assigned show
the display properties you specified in the object style.

Creating and Editing Material Definitions
Material definitions are created, edited, copied, or purged in Style Manager.
The Style Manager provides a central location in AutoCAD Architecture where
you can work with styles from multiple drawings and templates. Material
definitions contain settings for the hatching, scale, and color of materials,
plus rendering materials. You can find predefined material definitions in
C:\ProgramData\Autodesk\ACA 2012\enu\Styles\<Imperial or Metric>\Material
Definitions.dwg. For more information about using the Style Manager, see Style
Manager Overview on page 870.

Creating a Material Definition
Use this procedure to create a definition for the material you wish to use.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Multi-Purpose Objects, and expand Material Definitions.

3 Create a material definition:

Then…If you want to…

right-click Material Definitions, and
click New.

create a new definition with default
properties

right-click the material definition
you want to copy, and click Copy.
Right-click, and click Paste.

create a new definition from an ex-
isting definition

4 Enter a name for the new material definition, and press ENTER.
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5 Edit the properties of your new definition:

Then…If you want to…

click General. Enter a description of
the material definition.

enter a description of the material
definition

see Defining the Layer, Color and
Linetype of a Material Definition on
page 920.

change the layer/color/linetype
properties

see Specifying the Plan and Section
Hatch Patterns of a Material Defini-
tion on page 921.

change the hatching patterns

see Specifying the Surface Hatch
Pattern of a Material Definition on
page 923.

assign surface hatching to individual
object faces

see Assigning Render Materials on
page 925.

assign surface and live section ren-
dering materials

see Excluding a Material Definition
from 2D Section Shrinkwrap on
page 928.

exclude components from 2D
shrinkwrap

see Attaching Notes and Files to a
Material Definition on page 932.

add notes, files, or documents to
the definition

6 When you finish changing the material definition properties,
click OK.

Defining the Layer, Color and Linetype of a Material Definition
Use this procedure to define the layer, color, and linetype of the material
components. For detailed descriptions of the individual material components,
see Material Components and Display Properties on page 898.

NOTE If you turn off a display component in the material definition, object
components assigned that material definition do not display in the drawing. For
example, if you turn off the Linework component in a material definition, and
assign that definition to a door frame component, the door frame does not display
in plan views.
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1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Multi-Purpose Objects, and expand Material Definitions.

3 Select the material definition you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and verify that Style Override is checked.

The display representation in bold is the current display
representation.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select the component to change, and select a different setting for
the property.

9 Click OK.

Specifying the Plan and Section Hatch Patterns of a Material
Definition

Use this procedure to change the patterns for the Plan, Hatch, and Section
Hatch components of a material definition. For detailed descriptions of
individual hatch components, see Material Components and Display Properties
on page 898.

For more information about specifying surface hatch patterns, see Specifying
the Surface Hatch Pattern of a Material Definition on page 923.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Multi-Purpose Objects, and expand Material Definitions.

3 Select the material definition you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and verify that Style Override is checked.
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The display representation in bold is the current display
representation.

6 If necessary, click  .

7 Click the Hatching tab.

8 Select Plan Hatch or Section Hatch, and click the setting for
Pattern.

9 Select the hatching for the component:

Then…If you want to…

select Predefined for Type, and then
select a pattern.

select a hatching pattern that is
available in the software

select Custom for Type, and then
enter the name of the custom pat-

select a custom pattern

tern. If necessary, click Browse, and
navigate to the location where the
custom pattern file is located.

select User-defined for Type, and
clear Double Hatch.

select single hatching

select User-defined for Type, and
select Double Hatch.

select double hatching

select Solid Fill for Type.select solid fill

10 Click OK.

11 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

12 Click Angle, and enter the angle for the selected pattern.

13 Click Orientation, and specify how the hatching is oriented:

Then…If you want to…

select Object.orient the hatching to the object,
regardless of the object rotation

select Global.orient the hatching to the World
Coordinate System
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Specifying surface hatching orientation

14 Click OK.

Specifying the Surface Hatch Pattern of a Material Definition
Use this procedure to specify the pattern used for the surface hatch.

Specifying material assignment by object face
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NOTE After you assign a material definition to an object, you can edit the surface
hatches for the individual faces of the object. For more information about editing
surface hatches, see Overriding the Surface Hatch on Individual Objects on page
909.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Multi-Purpose Objects, and expand Material Definitions.

3 Select the material definition you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and verify that Style Override is checked.

The display representation in bold is the current display
representation.

6 If necessary, click  .

7 Click the Hatching tab.

8 Select Surface Hatch, and click the setting for Pattern.

9 Select the hatching for the component:

Then…If you want to…

select Predefined for Type, and then
select a pattern.

select a hatching pattern that is
available in the software

select Custom for Type, and then
enter the name of the custom pat-

select a custom pattern

tern. If necessary, click Browse, and
navigate to the location where the
custom pattern file is located.

select User-defined for Type, and
clear Double Hatch.

select single hatching

select User-defined for Type, and
select Double Hatch.

select double hatching

select Solid Fill for Type.select solid fill
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10 Click OK.

11 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

12 Click Angle, and enter the angle for the selected pattern.

13 Click Orientation, and specify how the hatching is oriented:

Then…If you want to…

select Object.orient the hatching to the object,
regardless of the object rotation

select Global.orient the hatching to the World
Coordinate System

Specifying surface hatch orientation

14 Click the Other tab.

15 For Surface Hatch Placement, select the object faces on which the
surface hatching is displayed.

16 Click OK.

Assigning Render Materials
Use this procedure to assign materials for rendering object surfaces.
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In shaded view and rendered views, objects may display rendering materials
instead of the hatch patterns that are displayed in 2D wireframe and hidden
line views. The following types of rendering materials are available:

DescriptionRender Material Type

Any object face that has surface hatching
applied displays the hatching in the Auto-
CAD renderer

Surface Rendering Material

All faces cut by a live section line display
the live section rendering material when
rendered with the AutoCAD renderer

Live Section Rendering Material

All objects and object parts outside the live
section line display the sectioned boundary

Live Section Sectioned Boundary Rendering
Material

material when rendered with the Auto-
CAD® renderer

You can assign rendering materials to two different types of component:

■ Object surfaces: All object surfaces that have a surface hatch applied to
them can also have a rendering material assigned. If you want to assign a
rendering material to an object surface, make sure that the Surface Hatch
component in the material definition is turned on.

■ Live section views: The Sectioned Body component of a live section view
as well as the live section cut plane can have special rendering materials
assigned. If you want to assign rendering materials to a live section view,
make sure that the Sectioned Body component in the material definition
is turned on.

926 | Chapter 14   Materials



Rendered live section view with transparent outside component

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Multi-Purpose Objects, and expand Material Definitions.

3 Select the material definition you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and verify that Style Override is checked.

The display representation in bold is the current display
representation.

6 If necessary, click  .

7 Click the Other tab.

8 Select rendering materials for the individual material components:

Then…If you want to…

select a material for Render Materi-
al. Then select a mapping type for
Mapping:

assign a rendering material to ob-
ject surfaces

■ If you select Same as Surface
Hatch, only those surfaces selec-
ted under Surface Hatch Place-
ment are rendered.
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Then…If you want to…

■ If you select Face Mapping, all
surfaces are rendered and any
hatch alignment overrides are
ignored.

select a material for Cut Surface
Render Material.

assign a rendering material to the
cut plane of a live section view

select a material for Sectioned Body
Render Material.

assign a rendering material to the
body component outside the live
section line

If you don’t find the correct rendering material or if you want to
see a preview of the material, click the Browse button and browse
for the desired material.

9 Select a new rendering material, if necessary.

10 Click OK.

Excluding a Material Definition from 2D Section Shrinkwrap
Use this procedure to exclude components with a specific material definition
assigned to them from the shrinkwrap of a 2D section.

When you create a 2D section, you can display a section component named
Shrinkwrap. The shrinkwrap is the union of all object faces cut by the section
line, merged into one component with one hatch pattern. This is a view
frequently used for a 2D section.

By default, all components that are assigned material definitions are included
in the shrinkwrap. However, you may want to exclude certain material
definitions, such as glass, from the shrinkwrap.
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2D section shrinkwrap with glass excluded (left)

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Multi-Purpose Objects, and expand Material Definitions.

3 Select the material definition you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

The display representation in bold is the current display
representation.

6 If necessary, click  .

7 Click the Other tab.

8 Select Exclude from 2D Section Shrinkwrap.

9 Click OK.

Controlling the Display of Hidden Lines by Material
Use this procedure to control whether hidden lines of a material should be
displayed in a section or elevation.

You could do this, for example, if you want to display concrete walls and
footings that are hidden by the ground and by other walls. Another frequent
use could be to display structural members that are located behind walls.
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Displaying hidden foundation walls

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Multi-Purpose Objects, and expand Material Definitions.

3 Select the material definition you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

The display representation in bold is the current display
representation.

6 If necessary, click  .

7 Click the Other tab.

8 Under 2D Section/Elevation Rules, select Display Hidden Edges
for this Material.

9 Click OK.
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Merging Material Definitions in a 2D Section/Elevation
Use this procedure to merge material definitions when creating a 2D
section/elevation.

Sometimes a single object in real-life is modeled with different objects in
AutoCAD Architecture. An example is concrete foundations, which are modeled
from slabs and walls. These objects should appear as one foundation object
in sections and elevations. The new option to merge common material
definitions facilitates this result. When a 2D section/elevation is created, all
objects of that material definition are combined into a single object. Edges
between coplanar faces are removed.

Walls and slabs merged (right)

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Multi-Purpose Objects, and expand Material Definitions.

3 Select the material definition you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

The display representation in bold is the current display
representation.

6 If necessary, click  .

7 Click the Other tab.

8 Under 2D Section/Elevation Rules, select Merge Common
Materials.

9 Click OK.
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Attaching Notes and Files to a Material Definition
Use this procedure to enter notes and attach reference files to a material
definition. You can also edit notes and edit or detach reference files from a
material definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Multi-Purpose Objects, and expand Material Definitions.

3 Select the material definition you want to change.

4 Click the General tab.

5 To add a description to the material definition, enter it for
Description.

6 Click Notes.

7 To add a note, click the Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

9 Click OK.
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Content Creation
Guidelines

In this guide the term content refers generically to various types of elements that you can
create to customize your installation of AutoCAD Architecture. These elements can be
style-based or symbol-based and include items such as plot style tables, layers, layer key styles,
layer standards, and drawing template files. While there are many ways in which you can
create and structure your custom content, there are several standards and conventions (both
documented and de-facto) that you can follow to make your custom tools more efficient and
more portable between different environments and organizations. This document is not
step-by-step guide for creating custom content; instead it focuses on identifying the relevant
standards, conventions and best practices.

General Content Standards and Conventions
It is important to understand the various types of content, where they are stored
and how they are made accessible to users. AutoCAD Architecture includes
support for various CAD standards. Understanding how these are applied will
assist you in creating your own customized content that works with the existing
standards and conventions.

Content Types
AutoCAD Architecture content takes several forms and can be stored in a variety
of locations.

■ Drawing templates: The drawing template file is perhaps the most critical
of content items in AutoCAD Architecture. In addition to standard AutoCAD
items such as layers and dimension styles, the templates contain critical
drawing and display settings. All AutoCAD Architecture model and sheet
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drawings should start with a template. Drawing templates are usually stored
in the folder established in the AutoCAD Options dialog for template file
storage. Additionally you can specify a default template to be used
whenever the QNEW command is invoked. Finally, a default plot sheet
template is usually specified as one of the sheet set properties for an
AutoCAD Architecture project.

■ Styles: Most AutoCAD Architecture objects, whether they are geometric
objects or documentation objects, are based on styles. Any successful
AutoCAD Architecture implementation will most likely consist of several
custom styles and definitions. Most styles should be stored in one or more
style library drawings, in a location that is accessible by all users. Usually,
styles can be easily accessed by users from a tool on a palette or in a tool
catalog.

NOTE Although some styles may be stored in the drawing template, this
should be kept to a minimum and limited to those styles and definitions that
are required for other content in the template.

■ Design and General Documentation Symbols: These are best stored as AEC
Content, which is created using the Create AEC Content wizard.
Palette-based tools can also access these symbols.

NOTE Some symbol-based content, such as multi-view blocks used for column
grid bubbles, can be stored in the drawing template. As with styles, however,
this should be kept to a minimum. Once a symbol is stored as AEC Content,
you can access it through Design Center™.

■ Callout Symbols: These are special symbols that use attributes with field
values to automate drawing coordination when you are placing keys for
elevations, sections and details. The blocks that define callouts are stored
in a library drawing and are accessed through palette-based tools.

■ Schedule Tags: Based on multi-view block definitions, schedule tags capture
and display property set data for objects in a drawing. Like callout symbols,
schedule tags are stored in a library drawing and accessed from a
palette-based tool.

■ Layer Key Styles: While they can be stored in the drawing template, it is
better to keep layer key styles in a central library drawing. When setting
up a drawing, you can specify that a particular layer key style automatically
loads each time a drawing is opened. This way if a layer key style is updated,
a drawing that is already in progress will always be using the latest version.
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■ Layer Standards: Defined in the Layer Manager, layer standards are stored
in the same library drawing as the layer key style with which they are
associated. When the layer key style is imported into a drawing, the layer
standard on which it is based will import also.

■ Display Configurations: Default display configurations are stored in the
drawing template.

TIP Most content types have associated naming conventions that are documented
in this guide. As a global convention, it is acceptable to prefix any name with a
company or organization name to differentiate your custom content from the
default content supplied with AutoCAD Architecture.

National CAD Standard Compliance
The National CAD Standard version 3.1 is a consensus standard compiled
from three existing standards and guidelines by NIBS (The National Institute
of Building Sciences). These consist of the AIA Layer Guidelines version 3.0,
the CSI Uniform Drawing System (UDS) and the Tri-Services Plotting
Guidelines. The National CAD Standard v. 3.1 is supported where possible in
AutoCAD Architecture through the use of pre-configured Layer Standards,
Layer Key Styles, plot style tables and annotation tools. While it is not required
that custom content be compliant, when creating new content for use in the
United States you should take this support into account.

The Imperial templates provided with AutoCAD Architecture are pre-configured
to load the AIA Version 3 Layer Key Style by default. This is based on the AIA
Version 3 Layer Standard, which is in turn compliant with the AIA Layer
Guidelines version 3.0.

The AIA v3 Layer Key Style includes line weights and linetypes that are in
accordance with the Uniform Drawing System, and the colors that it specifies
are compliant with the Tri-Services plotting guidelines. Additionally, the
drawing default display representations for all objects in the template files
have been configured to adhere to the Tri-Services Guidelines and Uniform
Drawing System recommendations by assigning appropriate colors, linetypes,
line weights and plot styles to all display components.
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There are twelve templates that are provided with the AutoCAD Architecture
sold in the United States, and each one is pre-configured to use a specific plot
style table:

Default Plot Style TableDescriptionTemplate File Name

AIA Standard.ctbUsed for model drawings
with imperial (architectural)

AEC Model (Imperial
Ctb).dwt

units and set up for color-
based plotting.

AEC Standard.stbUsed for model drawings
with imperial (architectural)

AEC Model (Imperial
Stb).dwt

units and set up for named
plot styles.

AIA Standard.ctbUsed for plot sheet draw-
ings with imperial (architec-

AEC Sheet (Imperial
Ctb).dwt

tural) units and set up for
color-based plotting.

AEC Standard.stbUsed for plot sheet draw-
ings with imperial (architec-

AEC Sheet (Imperial
Stb).dwt

tural) units and set up for
named plot styles.

AIA Standard.ctbUsed for model drawings
with metric (decimal) units

AEC Model (Metric
Ctb).dwt

and set up for color-based
plotting.

AEC Standard.stbUsed for model drawings
with metric (decimal) units

AEC Model (Metric
Stb).dwt

and set up for named plot
styles

AIA Standard.ctbUsed for plot sheet draw-
ings with metric (decimal)

AEC Sheet (Metric Ctb).dwt

units and set up for color-
based plotting.

AEC Standard.stbUsed for plot sheet draw-
ings with metric (decimal)

AEC Sheet (Metric Stb).dwt
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Default Plot Style TableDescriptionTemplate File Name

units and set up for named
plot styles.

AIA Standard.ctbUsed for structural model
drawings with imperial (ar-

Structural (Imperial
Ctb).dwt

chitectural) units and set up
for color-based plotting.

AEC Standard.stbUsed for structural model
drawings with imperial (ar-

Structural (Imperial
Stb).dwt

chitectural) units and set up
for color-based plotting.

AIA Standard.ctbUsed for structural model
drawings with metric

Structural (Metric Ctb).dwt

(decimal) units and set up
for color-based plotting.

AEC Standard.stbUsed for structural model
drawings with metric

Structural (Metric Stb).dwt

(decimal) units and set up
for named plot styles.

NOTE By default the software is configured to use the AEC Model (Imperial Stb).dwt
for model drawings and the AEC Sheet (Imperial Stb).dwt for plot sheet drawings.

In addition to the default plot style tables assigned to the imperial and metric
templates, there are several additional optional tables provided. Many of these
are for use with older legacy templates and drawing files:

DescriptionPlot Style Table

Default plot style for templates using
named plot styles. This table uses generic

AEC Standard.stb

names for plot styles and passes line weight
control to the layer and object properties.
All objects plot black.

Default plot style for templates set up for
color-based plotting. This table maps each

AIA Standard.ctb

color to an explicit line weight according
to the Tri-Services guidelines.
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DescriptionPlot Style Table

Optional plot style for templates using
color-based plotting. All colors are mapped

AIA Standard Color.ctb

to explicit line weights according to the
Tri-Services guidelines. Colors are con-
trolled by the objects and layers.

Optional plot style for templates using
named plot styles. This table uses the same

AEC Standard Color.stb

names for plot styles as the AEC Stand-
ard.stb plot style table, but objects will plot
according to their AutoCAD color.

Legacy plot style for older templates using
named plot styles. This table includes plot

AIA Standard.stb

styles named according to line weight
definitions specified in the Uniform Draw-
ing System.

Legacy plot style for older templates using
color-based plotting. All colors are mapped

AIA LWT by Object.ctb

to black and line weight control is by layer
and object properties.

Legacy plot style for older templates using
named plot styles. All line weight control
is by layer and object properties.

AIA LWT by Object.stb

Legacy plot style for older templates using
named plot styles. Plot styles assign line

AIA Standard Color.stb

weight explicitly. Colors are controlled by
objects and layers.

Legacy plot style for older templates using
color-based plotting. Color and line weight
control is by layer and object properties.

AIA Color LWT by Object.ctb

Legacy plot style for older templates using
named plot styles. All plot styles assign

AIA Color LWT by Object.stb

color and line weight according to object
and layer assignments.
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Legacy named plot style tables have seemingly redundant plot style names
that correspond to UDS line weight names. Many of these tables use the same
plot settings for multiple plot styles. This was done to allow for consistency
in naming when switching between plot styles. With the newer AEC Standard.stb
plot style tables, this complex plot style naming has been abandoned in favor
of a much more simplified system. Both the AEC Standard.stb and the AEC
Standard Color.stb plot style tables use the same plot style names, however the
former will plot all objects black while the latter will plot all objects according
to their AutoCAD color. Aside from color vs. monochrome, the plot styles
determine saturation:

■ Normal: Default plot style. Because this plot style is not editable, it is
typically not used in the AutoCAD Architecture layer key styles or display
settings.

■ Full Saturation: Objects assigned this plot style will plot either 100 percent
black or 100 percent color, depending upon which plot style table is used.

■ 50 Percent: Objects assigned this plot style will plot with a 50 percent
screen.

■ 25 Percent: Objects assigned this plot style will plot with a 25 percent
screen.

■ Invisible Ink: This is a unique plot style. Regardless of whether the AEC
Standard.stb or AEC Standard Color.stb plot style table is being used, objects
on this plot style will plot cyan, to simulate the effect of a blue lead pencil
from manual drafting days, which will not typically come through when
reproduced on a monochrome copy machine or standard blueline machine.

The Uniform Drawing System also specifies formatting for symbology and
annotation. This is supported in AutoCAD Architecture through the content
provided in the Documentation Tool Catalogs and in the drawing templates
themselves.

NOTE For more information on NIBS or to purchase a copy of the National CAD
Standard documentation you can visit their web site at http://www.nibs.org/

Content Resources
To create and distribute content effectively, it is important to have an
understanding of where different types of content are best stored, and the
possibilities each one of them provide towards a cohesive, well-managed
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system of templates, styles, symbols and tools. Careful attention should be
paid to ease of user access, centralized storage and automation.

Template Drawings
There are a variety of things that should be kept in the template, however
care should be taken to keeping it as “lean” as possible. Before storing content
in a template you should consider other options, choosing to store it in the
template only after confirming that it is the best possible location. Normally,
the template itself should be stored in the location that is specified in the
Options dialog under Template Settings.

Setting the template file location in the “Options” dialog box.

Items that should be included in the template file:

■ Layer definitions: Pre-defined layers should be kept to a minimum. Most
layers are created when needed by the layer key style that is loaded into a
drawing. Only include pre-defined layers for those other objects and settings
that must be in the template before a Layer Key Style is loaded or any
objects created.

■ Text styles: Include text style definitions to be used for standard notes and
dimensions.
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■ Title blocks, layouts and page setups: These should be created in templates
intended for use as plot sheet templates. Templates that are intended to
be used for sheet sets, especially, should have page setups saved within
them to serve as overrides when publishing a sheet set.

■ Multi-view blocks: Normally these should be stored as AEC Content or
tags, however if you want to use a custom column grid bubble block instead
of the default grid bubble, you should store it in the template.

NOTE Custom blocks do not scale correctly if you copy objects to which they
are attached (such as doors with door hardware) and paste them in a drawing
that has drawing units specified differently.

■ Classification definitions: Those classification definitions that you use
frequently are best stored in your drawing template, so that they are readily
available when you need to classify either a style or an individual object.

Items that should not be included in the template file:

■ Most styles: These should be kept in a style library drawing, with an
associated palette-based tool that allows users to import the styles into the
current quickly and easily on demand. Storing the styles in a style library
and providing tool access to them keeps your drawings from becoming
unnecessarily bloated due to unused styles in the drawing database.

■ Symbol-based content: These items are typically more effectively stored
as AEC content or in the case of callouts and schedule tags, a library
drawing. Again, palette-based tools provide quick and easy access to them
on an as-needed basis.

■ Dimension styles: AEC dimensions and the standard AutoCAD dimension
styles upon which they depend for their display do not need to be stored
in the template. Instead, you can store these in the same way as other
style-based content; in a style library drawing, and provide access to them
through palette-based tools.

■ Layer key styles and layer standards: While these can be stored in the
template, it is better to keep them in a library drawing and use the Drawing
Setup dialog to make sure that the most current layer key style is
automatically imported into a new drawing and any drawings that are
already in progress upon opening. This ensures that you are always working
with the most up-to-date version.

The layer settings in the Drawing Setup dialog. Note that a layer key style is set to
auto-import and that Save as Default is checked. This will ensure that even if you start
a drawing without a template, the correct layer key style will be loaded. Note also that
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Always import Layer Key Style when first used in drawing is checked. This is a
drawing-based setting and should be set in the template. This will ensure that the
most current layer key style will also be used in drawings that are already in progress.

Style Library Drawings
Most style-based content should be kept in a centrally located library drawing,
accessible to all users. In most cases, the styles contained in this file can be
imported by selecting a tool on a palette. If you anticipate a large quantity of
custom styles, you may wish to break your library drawings up by type to keep
them more manageable.

General Guidelines for Style Library Drawings:

■ Start with a valid template drawing that includes all of your display
configurations and correct units. This will allow you to edit or review styles
in the library in the context in which they will be used.

■ If you are storing your style library on a mapped drive make sure that the
drive is mapped identically on every user’s computer. AutoCAD Architecture
supports UNC (Universal Naming Convention) pathing. If you are confident
that your server names will not be changing you may want to consider
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using this method of pathing to your style libraries to avoid drive mapping
problems.

■ If you need to restrict users’ ability to make changes to the style library,
you can store it in a read-only folder. They will still be able to use the styles
that it contains without any problems.

Template Projects
A well-planned template project can help you automate office standards and
simplify the process of beginning and setting up a new project. Depending
upon the type of work you do, your template project may be very complete
or it may just form the basic framework for a project. If your work consists of
unique designs and your building types vary, you may find that the most
efficient template project is minimal in structure. On the other hand, if you
work with a typical building type, or if you work with prototypical buildings
you might find that a more complete template project that includes more
information concerning specific project structure is more effective.

Creating a template project is not the same as simply copying and renaming
an existing project. In order to properly call for a template, you must specify
it at the time that you create your new project.

Specifying the template project from the Add Project dialog. This is the only time this
can be done. When the new project is created, settings and files from the specified
template project will be copied to the new project.

Template Drawings

AutoCAD Architecture projects have, as a project property, template file
specifications that determine the drawing templates to use for constructs,
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elements and views. These template settings are independent from the template
settings established in the Options dialog. These templates should be in a
location accessible to all users.

Project Details

Accessible from the Project Properties dialog, the detailed information
worksheet contains information that can be linked to title blocks via fields or
embedded in MTEXT or block attributes. This data is completely user-defined.
Include data that is common to all of your projects in the project details of
the template project.

Sheet Sets

All AutoCAD Architecture projects include an AutoCAD sheet set (.dst) file.
When you use a project as a template, its sheet set file gets copied over to your
new project along with all of the other project files and folders, and it is
renamed to match your new project. The sheet set file contains a variety of
critical information that can be pre-configured as part of your overall project
template.

Items that can be modified in the sheet set file as part of the template project:

■ Default sheet template file: This should be a sheet that has layouts defined
in it to represent all of your standard plot configurations. It should also
contain each layout saved as a page setup for use as overrides when
publishing.

■ Subset structure: You can add and delete subsets to conform to your office’s
standard sheet set layout and structure.

■ Sheets: You can create sheets in advance to further automate the sheet set
structure.

■ Sheet set custom properties: You can define standard properties (data
fields) that can be linked to your title block MTEXT or attribute fields.

NOTE If you define custom properties that are to be linked to a title block,
you may want to consider providing a default value of “----” so that it will be
obvious later on (if you have fields without values), and it will be easy to edit
them.
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Items that you should NOT include in a sheet set file for AutoCAD Architecture

■ Resource drawing locations: In AutoCAD Architecture your view drawings
automatically become your resource drawings. This setting should remain
blank in the sheet set properties for an AutoCAD Architecture project.

■ Label block for views: This is taken care of by the Title Mark tool on the
AutoCAD Architecture tool palettes. These can also be customized to suit
office standards. Leave this setting blank.

■ Callout blocks: As with title marks, these are taken care of by the various
callout tools on the AutoCAD Architecture tool palettes and can be
customized to suit office standards. This setting should remain blank.

Project Standards

All settings established in the Configure AEC Project Standards dialog will
copy with the template project to become part of the new project. Standards
files that are unique to the project, in other words, standards files that reflect
project standards that may be supplemental to or override office standards,
should be placed in the Standards folder of the template project. These files
will be copied and their paths updated in the new project.

As with style library drawings, if you are including a non-project based file in
your standards files, you need to decide whether to use mapped drives or UNC
file pathing. If you are using mapped drive letters, they must be mapped
identically on all users’ workstations. If you choose UNC, you need to be sure
that the server path will be remaining the same for the foreseeable future.

Project Tool Catalogs and Palettes

In addition to office standard custom tool catalogs, each project has its own
Content Browser library, with its own associated project tool catalogs. These
can be configured in the template project as well. There are a few simple
guidelines that you should follow when creating project tool catalogs.

■ Create your new catalog from the project library view in the Content
Browser. The project library can be accessed from the Content Browser
button at the bottom of Project Navigator.

■ If you create new catalogs in the project library, you should place them in
the Standards/Tool Catalogs folder of your template project.
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IMPORTANT In order for project catalogs to properly copy when the template
project is selected, you must start your template project from one of the templates
provided with AutoCAD Architecture. Remember also that even though the project
catalog is copied from the template project, the tools within the catalog are
unchanged; their paths remain the same as they are in the template.

Project Structure

If you work with a building type that is fairly consistent from one project to
another, or a prototypical building type, you may find it advantageous to
pre-define some aspects of the project structure itself. None of this is absolutely
necessary, and the level to which you choose to pre-define these items is
completely optional.

Project Structure Items That Can be Established in the Template Project

■ Levels and Divisions

■ Constructs and Elements: In addition to defining categories and
sub-categories, any actual construct or element drawings will be copied to
the new project from the template project.

■ Views: If you’ve created constructs and elements as part of your template
project structure, you can also create view drawings that reference the
constructs.

NOTE AutoCAD Architecture provides you with the choice to use relative xref
paths, which are on by default in the project properties. If you choose not to use
relative paths and you create constructs, elements, and views as part of your
template project, when a new project is created, the these items will be repathed
automatically according to the new project’s path.

Tool Catalogs
The tool catalog is one of the most critical components of any office’s custom
content collection. It is the central repository for all tool-based content, which
can and should include tools that provide access to styles, AEC content,
callouts, schedule tags, and other miscellaneous annotation items. Because it
is central to an effective content distribution and management system, you
should spend time planning its location, organization, and structure. You
should also take steps to protect the contents of the tool catalog from
unauthorized or inadvertent modifications.
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If users are going to manually load the catalog into their content browser
library, pathing is not critical; it simply needs to be placed in a location that
all users can browse to. If you choose to automate the loading of the palette
by creating a catalog install file, you need to ensure that the network location
of the catalog file is accessed in the same way by all users. As with other types
of network-based content, carefully consider the advantages and disadvantages
of both mapped network drives and UNC pathing.

If you need to control the ability of users to make modifications to the tool
catalog, you can store it in a read-only folder. Users will still be able to access
the catalog to use the tools, however only those people with permission to
write to that location will actually be able to make changes to it.

Display Control
The AutoCAD Architecture display control system is flexible and powerful
and is drawing-based. Therefore, your default display settings should be
established in your template drawing. The templates that come with AutoCAD
Architecture already have much of the work involved in setting up a display
system done for you. While they may require some adjustments to conform
to your office or project standards, you should, in most cases, start with the
default templates and make modifications to the existing settings rather than
try to create a display system from scratch.

Display Hierarchy and By Material Display Control

Display control of individual objects can occur at three levels: drawing default,
style overrides, and object overrides. When you define an object style you
should only apply style overrides when absolutely necessary. Frequently, you
can use material assignments to control the display of linework and hatching
components of objects. For this reason, many objects have By Material set as
a drawing default for their display representations.

Display Control Customization

Like most aspects of AutoCAD Architecture, the display system can be
customized. There are a few things that you should keep in mind before doing
so, however.

Best Practices for Customizing the Display System

■ Start with one of the default templates. Creating a display system from
scratch can be laborious and time-consuming. It is better to start with a
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template that is relatively close to what you need and make modifications
to it.

■ Modify existing display configurations and display sets before creating
new ones.

■ Do not create new display representations for objects unless you absolutely
have to. Many times you can find an existing display representation that
you are not using that you can modify to suite your needs. Remember that
every display representation that you create is one that you have to manage.

NOTE Remember that display control is drawing-specific. Changes that you intend
to be part of your office standard should be made in the drawing template. You
can use the Display Manager to copy display configurations, display sets, and
display representations between drawings.

IMPORTANT If you create a new display configuration that uses an existing display
representation that has been modified, you must remember to copy both the
display configuration and the modified display representation to your template.
When you copy the display configuration to the template the associated display
representations and display sets will only be copied with it if they do not already
exist in the template. When you manually copy a display set or a display
representation into a template that already contains display sets and representations
with the same name, you will be prompted to overwrite the existing definitions.

Level of Detail
Level of detail should always be a consideration when creating new content
objects and new display representations. By default there are three display
configurations that address level of detail provided in the AutoCAD
Architecture template drawings.

Design Scale [Metric Units in Brack-
ets]

Display Configuration

1/4”=1’-0” [1:50]or greaterHigh Detail

1/8”=1’-0” [1:100]Medium Detail

1/16”=1’-0” [1:200] or smallerLow Detail

NOTE You may decide that the default display configurations are not appropriate
for your preferred graphic standards. You can create additional display
configurations and modify the existing ones to accommodate your own standards.
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Architectural objects frequently include hatch pattern parameters as part of
their display control. You should make sure that the hatch pattern scale and
type is appropriate for the level of detail a given display representation is
meant to address. Also remember to address hatch pattern scale and type in
your material definitions, as it is a best practice to assign material definitions
to style-based components. Hatch patterns that represent annotation standards
(diagonal lines that represent brick in plan, for example), should be scaled
appropriately for your level of detail. Hatch patterns that represent geometry
(bricks in elevation, for example), should be given a scale of 1 unit.

Style-Based Content
Style-based content in AutoCAD Architecture is classified under one of three
general groups.

■ Architectural Objects: Traditional architectural object geometry.

■ Documentation Objects: Any style-based object that is specifically and
uniquely used for annotation and documentation purposes.

■ Multi-Purpose Objects: Any style-based object that could be used to help
define either a documentation object style or an architectural object style.

Many styles can be used to create style-based tools on a palette. Others are
used as nested styles or substyles. All styles and definitions can be edited in
the Style Manager and stored in a central style library drawing.

TIP You can assign a pre-defined keynote from your keynote database to any style
that you create on the General tab of the style definition.

Architectural Objects
When referring to styles, the term architectural object refers to any object
style that will result in the creation of a specific type of architectural geometry,
such as a wall, door, stair, roof slab, etc. It also refers to sub-styles that are
related to those object types, such as wall endcaps and slab edge styles.
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Walls
Walls are more complex objects and affected by a variety of styles and substyles.
When a wall style that references a specific substyle is imported into a drawing,
it will import all necessary substyles with it.

Wall Styles

Naming Conventions

You should provide as much information about the wall structure in the name
itself as practical. This makes it easier to discriminate between wall styles in
a long list without having to refer to the wall style description. The first
component listed is the major structural component. The last component
listed is usually a finish component.

<Component name>-<Size in decimal units> <Component name>-<Size in decimal
units>...

Example Wall Style Names:

Example NameWall Style Description

Stud-3.5 Brick-3.625 Sheathing-0.5 Air-1
GWB-0.625

Wall structure: 5/8” gypboard interior fin-
ish, 3 1/2” wood stud, 1/2” sheathing, 1”
air gap and 3 5/8” brick veneer.

Stud-3.5 GWB-0.625 Both SidesWall structure: 5/8” Gypboard interior fin-
ish on both sides of a 3 1/2” wood stud.

Stud-X GWB-0.625 Both SidesWall structure: 5/8” Gypboard interior fin-
ish on both sides of a variable width wood
stud.

Best practices for wall styles

■ Walls are directional and should be considered as having an exterior and
interior side. The exterior, or positive side of the wall, is at the top of a
wall running left to right. Wall components should be defined so that the
index order is from exterior to interior. The component furthest to the
exterior side of the wall should have an index assignment of 1, while the
most interior component will have the highest index assignment.
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■ When specifying the edge offset of a component, the value should always
be to the most interior edge of the component.

■ The width of components is always a positive value.

■ Wall priorities should be standardized and based on the existing AutoCAD
Architecture convention, which is documented in the AutoCAD
Architecture User Guide.

■ Materials should be assigned to all wall components.

■ Plan display of wall components should normally be set to observe the
drawing default settings. Best practice is to assign materials to wall
components and set their linework and hatch pattern parameters to By
Material in the plan display settings.

NOTE Prior to the introduction of material definitions in Architectural Desktop
2004 it was common and recommended practice to assign wall style
components to nested layers and set their color, line type, line weight, and
plot style settings to BYLAYER. While this is still technically valid in AutoCAD
Architecture 2012, it is not recommended except for a very few exceptions
(such as the Plan Screened display representation, which is frequently used to
export plan displays to consultants using AutoCAD, who desire the items to
be on a prescribed layer and assigned colors appropriate for background
drawings).

■ Model display of wall components should be set to the drawing defaults
to allow for material assignments to control the color and hatching of
walls when viewed in non-orthogonal views.
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■ Wall styles should be classified. This allows for more flexible scheduling
and tagging in the future, as well as more display control options.

NOTE The Uniformat II classification definition is supplied in the Uniformat II
Classifications (1997 ed).dwg file located in the AEC Content\Styles path. This
classification definition is fairly comprehensive and in many cases serves well
in classifying all types of AutoCAD Architecture object styles according to a
uniform standard.

■ Walls that have one or more obvious internal dimension points (such as
the outside of a structural component) should have those specified in the
wall style Components tab under the Dimensions column. This allows for
more accurate application of AEC dimensions.

■ Wall components should be assigned a “Structural” or “Non-Structural”
designation under the “Type” column in the “Components” tab, again to
allow for more effective use of AEC dimensions.

■ Walls should have an interior and exterior side specified as part of the wall
style definition to ensure more accurate AEC Dimensioning.

To ensure accurate dimensioning with AEC dimensions, the wall in the following image
has had its components assigned to either “Structural” or “Non-Structural” types.
Dimension points and the exterior/interior sides of the wall are also specified.
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Wall Endcap Styles

Wall endcap styles are intended to be used with specific wall styles. They can
be used to define actual end conditions as well as opening conditions as part
of a Wall Opening Endcap Style.

Naming Conventions:

Wall endcap styles should be named according to the wall style to which they
apply, with an indication of the condition they are meant to address:

<Associated wall styles> (<End condition><Index>)

Example Wall Endcap Style Names:

Example NameWall Endcap Style Description

Stud-3.5 Brick-3.625 Sheathing-0.5 Air-1
GWB-0.625 (End1)

For wall style Stud-3.5 Brick-3.625 Sheath-
ing-0.5 Air-1 GWB-0.625 to define the first
end condition.

Stud-3.5 Brick-3.625 Sheathing-0.5 Air-1
GWB-0.625 (End2)

For wall style Stud-3.5 Brick-3.625 Sheath-
ing-0.5 Air-1 GWB-0.625 to define a pos-
sible second end condition.

Stud-3.5 Brick-3.625 Sheathing-0.5 Air-1
GWB-0.625 (Jamb1)

or wall style Stud-3.5 Brick-3.625 Sheathing-
0.5 Air-1 GWB-0.625 to define a jamb con-
dition.

Best Practices for Wall Endcaps:

■ Endcaps are drawn for each component. Components for which there is
no endcap defined will terminate as soon as another component’s endcap
is encountered. For that reason, you need to draw a complete endcap for
each component except for those that are intended to terminate at the
location on the wall where the endcap is applied.

■ Endcaps are applied perpendicular to the direction of the wall. The
endpoints of each endcap are normally drawn so that an imaginary line
connecting them would be perpendicular to the wall edges, except in the
case where an endcap is intentionally skewed.

■ It is typically not recommended to define endcaps for walls with variable
width components. As a component’s width is changed, its associated
endcap will adjust to accommodate the change in width, however the
endcap will maintain its proportions, causing distortions to occur to the
end effect.
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Wall Opening Endcap Styles

Wall Opening Endcap Styles apply to door, window, opening and door/window
assemblies that are inserted into a wall. They consist of a collection of wall
endcap styles that are applied to the head, jamb and sill conditions of the
opening.

Wall Opening Endcap Style Naming Conventions:

The naming convention for a wall opening endcap style is similar to that for
a wall endcap style:

<Associated wall style> (Opening<Index>)

Example Wall Opening Endcap Style Names:

Example NameWall Opening Endcap Style Descrip-
tion

Stud-3.5 Brick-3.625 Sheathing-0.5 Air-1
GWB-0.625 (Opening1)

Wall opening endcap style for a wall style
named Stud-3.5 Brick-3.625 Sheathing-0.5
Air-1 GWB-0.625.

Wall Cleanup Group Definitions

Wall Cleanup Group definitions should allow objects anchored to walls in
other cleanup groups to be moved or copied to walls of the current cleanup
group unless there is a compelling reason to not allow it. Cleanup between
host and xref drawings should be turned on by default unless performance
issues arise. There are no naming conventions for wall cleanup group
definitions.

Wall Modifier Styles

Wall modifiers are typically best created “on the fly” by first creating a 2D
polyline and converting it to a wall modifier. During the process you are
prompted for a name to assign to a new modifier style, which is created from
your geometry. Modifier styles define minimal information about the shape
of the modifier itself. There are no current conventions for naming or
application of wall modifier styles.
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NOTE Wall modifiers can vary widely in shape and size from one instance to the
next, even if they belong to the same style. To ensure that the modifier you wish
to apply to a wall represents the shape that you want, first draw a 2D polyline and
then convert the polyline to a wall modifier. You will be prompted for a new wall
modifier style name during the process; each converted polyline must define a
different modifier style. For these reasons, you may find it more effective in many
cases to use body modifiers instead, which are not style-based.

Palette-Based Wall Tools

The only wall-based style that can be assigned to a palette-based tool is the
wall style itself. However when the wall style is used, any substyles that it uses,
such as wall endcap styles and wall opening endcap styles, will be imported
with it automatically. Additionally there are some tool properties that you
may want to consider setting as defaults before saving the tool to a catalog:

■ Justification: In the case of exterior walls, the baseline is usually defined
at a critical dimensional location within the wall structure. In these cases
it is a good idea to pre-set the justification property of the tool to “Baseline”.

■ Cleanup Group Definition: If you have defined a wall that should not clean
up with other walls that are not of the same type, you can pre-set the
cleanup group definition that it is inserted with.

IMPORTANT To pre-set the wall cleanup group definition, you must first
specify the library drawing in which the cleanup group definition exists, then
define the cleanup group to use. Even if the cleanup group already exists in
the current drawing, it will not be used unless you specify the definition
location.
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Wall tool pre-sets to establish the default cleanup group definition and the justification.

Doors and Windows
Doors and windows comprise three primary AutoCAD Architecture object
styles: doors, windows and door/window assemblies.

Door Styles

Naming Conventions:

As with wall styles, the name for a door style should provide as much
information about the door as possible. The format is:

<Door Operation> - <Door Type> - <Optional Door Shape> <Optional Case Type>...

NOTE Doors with no shape specified are assumed to be rectangular.
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Example Door Style Names:

Example NameDoor Style Description

Hinged - SingleA single hinge, flush rectangular door.

Hinged - Single - ExteriorA single hinge, flush rectangular door, ex-
plicitly for exterior use.

Hinged - Double -Arched - PaneledA double hinge, paneled arched door.

Overhead - Single - Paneled - ExteriorA single overhead door, paneled, for exter-
ior use.

Hinged - Single - Full Glazed - AssyA single hinge, full glazed door, for use in
a door/window assembly.

IMPORTANT It is important to indicate those doors that are intended explicitly
for assemblies. They will frequently have conditions defined that will not look
correct when inserted into a wall independently from the assembly for which they
were defined.

Best Practices for Door Styles:

■ All door components should have materials assigned to them.

■ Door styles should be classified for more control with scheduling and
display control. As with walls, the Uniformat II Classification definition
contains a ready-made list of classifications, including basic door
classifications.

■ In the “Model display representations of doors components should follow
“By Material” settings.

■ In the “Elevation” display representations components should be assigned
colors with the display rules of your 2D Section/Elevation styles in mind.
Using colors that are coordinated with those styles can be used to automate
linework properties in section and elevation objects.

Window Styles

Naming Conventions:

The naming convention for window styles is similar to that for doors, however
is a bit more relaxed with more items becoming optional:
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<Optional Window Operation> - <Window Type> - <Optional Window Shape>
<Optional Case Type>...

NOTE Windows with no window shape specified are assumed to be rectangular.
Windows with no operation specified are assumed to be fixed.

Example Window Style Names:

Example NameWindow Style Description

PictureA rectangular Picture Window.

Casement - Double - ArchtopAn arched double casement window.

Awning - AssyAn awning window, to be used explicitly
in a door/window assembly.

IMPORTANT It is important to indicate those windows that are intended explicitly
for assemblies. They will frequently have conditions defined that will not look
correct when inserted into a wall independently from the assembly for which they
were defined.

Best Practices for Window Styles:

■ All window components should have materials assigned to them.

■ Window styles should be classified for more control with scheduling and
display control. As with walls, the Uniformat II Classification definition
contains a ready-made list of classifications, including basic window
classifications.

■ In the Model display representations of window components should follow
“By Material” settings.

■ In the “Elevation” display representations components should be assigned
colors with the display rules of your 2D Section/Elevation styles in mind.
Using colors that are coordinated with those styles can be used to automate
linework properties in section and elevation objects.

Door/Window Assembly Styles

Naming Conventions:

The naming convention for door/window assemblies should reflect as much
as possible the infill elements that they include, any cell adjustment parameters
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and where appropriate, the general position of infills in the assembly. In
addition, if certain infills have a fixed size, it is helpful to indicate these as
well. Different infill types are separated with a “+” symbol. These are loose
guidelines at best; the very flexibility of door/window assembly styles and
virtually unlimited combination of infills and grids makes it impossible to
develop a fixed naming convention that will apply to all conditions:

<Infill Type> <Optional Infill Size> <Optional Infill Position> <Optional Cell Adjustment
Parameter> + <Next Infill Type>....<Optional Door/Window Assembly Shape>

NOTE Door/Window Assemblies with no shape specified are assumed to be
rectangular. In the case of a very complex door/window assembly, you may choose
to omit some of the less prominent infill types and parameters, choosing instead
to include them in a more complete style description.

Example Door/Window Assembly Style Names:

Example NameDoor/Window Assembly Style Descrip-
tion

Windows4-0 Ctr Grow + Transom 2-0 Ctr
Arched

An arched assembly with 4’ windows and
a two foot tall arched transoms, centered,
with both side cells configured to grow as
the assembly width is changed until the 4’
size can be accommodated

Hinged Double 6-0x6-8 + Sidelights +
Transom

Hinged double door with variable width
sidelights on each side and a transom.

Hinged Single 3-9x6-8 Right + Sidelight
+ Transom

A hinged single door on the right side with
a single sidelight and a transom.

Best Practices for Door/Window Assembly Styles:

■ All assembly components should have materials assigned to them.

■ Door/Window Assembly styles should be classified for more control with
scheduling and display control. This is especially important with assemblies
that are explicitly intended to be included in a window or door schedule
as a mulled unit.
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NOTE In cases where an assembly includes a door or window infill and the
assembly is to be included in a door or window schedule, you can choose not
to classify the door or window infill. This will help you to make sure that the
infill is not included in the schedule as a separate item from the assembly of
which is a part.

■ The Model display representations of assembly components should follow
“By Material” settings.

■ The “Elevation” display representations components should be assigned
colors with the display rules of your 2D Section/Elevation styles in mind.
Using colors that are coordinated with those styles can be used to automate
linework properties in section and elevation objects.

■ Naming of assembly components: In order to minimize confusion when
editing door/window assembly styles, you should be descriptive and
consistent when naming the components of the style. In general, each
name should end with the type of assembly element it refers to. For
example, an infill name might be “Entry Door Infill.” In particular, care
should be taken to name grids and the divisions they are based on. A grid
using a division named “Sidelight Vertical Division” should be named
“Sidelight Vertical Grid.”

Curtain Walls
Curtain walls comprise two primary AutoCAD Architecture objects: Curtain
wall styles and curtain wall unit styles. Curtain walls can also use door, window
and door/window assembly styles as infills.

Curtain Wall Styles

Naming Conventions:

As with other style types, the naming for curtain walls should be as descriptive
as possible, but because curtain walls can be even more varied and complex
in their structure than door/window assemblies, you should not expect to
fully describe the details of the style in the name:

<Major Element (Descriptive) + <Major Element (Descriptive)>...
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Example Curtain Wall Style Names:

Example NameCurtain Wall Style
Definition

Mass Base + 4x4 Grid
Above

A curtain wall whose first
floor cell assignment
consists of wide mullions
meant to simulate wall
panels, with a 4’ x 4’ pat-
tern of standard window
mullions and glazing
panels above.

Stone Base + Revolving
Doors + Variable Grid
Above

First floor with stone
panels, revolving doors
and glazing above in
variable pattern (perhaps
with nested assemblies or
curtain wall unit styles as
infills).

Best Practices for Curtain Wall Styles:

■ All curtain wall components should have materials assigned to them.

■ The “Model display representations of curtain wall components should
follow “By Material” settings.

■ The “Elevation” display representations components should be assigned
colors with the display rules of your 2D Section/Elevation styles in mind.
Using colors that are coordinated with those styles can be used to automate
linework properties in section and elevation objects.

■ Naming of curtain wall components: In order to minimize confusion when
editing curtain wall styles, you should be descriptive and consistent when
naming the components of the style. In general, each name should end
with the type of curtain wall element it refers to. For example, an infill
name might be “Stone Panel Infill.” In particular, care should be taken to
name grids and the divisions they are based on. A grid using a division
named “First Floor Vertical Division” should be named “First Floor Vertical
Grid.”
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Curtain Wall Unit Styles

Naming Conventions:

Curtain wall units, while similar in many respects to door/window assemblies
and curtain walls, are limited to simple panel infill definitions. The naming
conventions are similar to those for curtain walls, but you can also include
indicators of cell adjustment parameters as well:

<Major Element (Descriptive) + <Major Element (Descriptive)>...<Optional Cell
Adjustment Parameter)

Example Curtain Wall Unit Style Names:

Example NameCurtain Wall Unit Style Definition

2 x 2 GlazingA curtain wall unit with 2 x 2 glazing pan-
els:

Glazing 4-0 Grow + Pointed MullionsA curtain wall unit with 4’ wide glazing
panels, mullions coming to a point at the
top, with the side cells set to grow until a
new 4’ panel can be added:

Best Practices for Curtain Wall Unit Styles:

■ All curtain wall Unit components should have materials assigned to them.

■ Unless a curtain wall unit is to be scheduled as a separate item, you should
not classify curtain wall unit styles.

■ The Model display representations of curtain wall unit components should
follow “By Material” settings.

■ The “Elevation” display representations components should be assigned
colors with the display rules of your 2D Section/Elevation styles in mind.
Using colors that are coordinated with those styles can be used to automate
linework properties in section and elevation objects.

■ Naming of curtain wall unit components: In order to minimize confusion
when editing curtain wall styles, you should be descriptive and consistent
when naming the components of the style. In general, each name should
end with the type of curtain wall element it refers to. For example, an infill
name might be “Stone Panel Infill.” In particular, care should be taken to
name grids and the divisions they are based on. A grid using a division
named “First Floor Vertical Division” should be named “First Floor Vertical
Grid.”
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Roofs and Slabs
Roof slab styles can contain more than one component, similar to wall styles;
many of the conventions are therefore the same or similar. Roof slabs can also
use roof slab edge styles.

Roof Slab Styles

Naming Convention:

Roof slab styles, like wall styles, include multiple components. The name
should indicate the structure of the roof and the dimensions of the major
components (minor components such as roofing felt can have the dimension
omitted). The first component listed should be the major structural component.
The last component should be the finish component (if any):

<Component name>-<Size in decimal units> + <Component name>-<Size in decimal
units>...

Example Roof Slab Style Names:

Example NameRoof Slab Style Definition

Rafter-7.25 + ShinglesRoof Structure: 2x8 Rafter, roofing felt, as-
phalt shingles.

Best Practices for Roof Slab Styles:

■ Materials should be assigned to all roof slab components.

■ Roof slabs should be defined with the baseline at the bottom of the major
structural component.

■ The index order of roof slab components should be indexed from top to
bottom, with the top component having index 1.

■ Thicknesses of components should always be positive. The thickness offset
from the baseline should always be to the bottom edge of the component.

■ You should consider classifying all roof slab styles to allow for more display
control options.

Roof Slab Edge Styles

Roof slab edge styles are fairly simple and can contain a maximum of only
two components: the fascia and the soffit. Unlike wall endcaps, roof slab edge
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styles are not applied to individual roof slab components, but to the roof slab
as a whole.

Naming Conventions:

Roof slab edge styles should be named according to the fascia and/or soffit
condition they define:

<Optional nominal fascia size> <Optional fascia> + <Optional nominal soffit size>
<Optional soffit> - <Optional default edge cut condition> - <Optional edge overhang>

Example Roof Slab Edge Style Names:

Example NameRoof Slab Edge Style Description

1x4 Fascia - Plumb1x4 Fascia, no soffit, plumb cut, no over-
hang.

1x8 Fascia + 5-8 Soffit - Plumb - Over-
hang 12

1x8 Fascia, 5/8” soffit, plumb cut, 1’ over-
hang.

4x4 Cant4x4 Cant strip edge style (for built-up roof).

Best Practices for Roof Slab Edge Styles:

■ When creating the profiles for the edge, draw them for the right side of
the roof when drawn in section.

■ Exercise discretion when turning on “Auto-Adjust to Edge Height”. While
this will cause the fascia to adjust to a variable width component in a roof
slab as it changes thickness, the adjustment is proportional. The fascia will
adjust both vertically and horizontally. The same consideration should be
taken into account when turning on the option to adjust the soffit to the
overhang depth.

NOTE Roof slab edge styles can not be applied as a part of the roof slab style
definition; instead you can apply them as a palette-based tool property. Many of
the roof slab styles included in the sample content files that ship with AutoCAD
Architecture indicate in their names a specific roof slab edge style and when a tool
is created from those styles, the slab style is already assigned to the tool properties.
These styles originated in an earlier version of the software in which default roof
slab edge styles could be assigned to a roof slab style. This capability was removed
from the User Interface of the roof slab style editor, however the style properties
were left in those sample styles.
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Slab Styles

Naming Convention:

Slab styles, like wall styles, include multiple components. The name should
indicate the structure of the slab and the dimensions of the major components
(minor components such as vapor barriers, linoleum floor finishes, etc., can
have the dimension omitted). The first component listed should be the major
structural component. The last component should be the finish component
(if any):

<Component name>-<Size in decimal units> + <Component name>-<Size in decimal
units>...

Example Slab Style Names:

Example NameSlab Style Description

Concrete-6 + Tile-CeramicSlab Structure: 6” Concrete, ceramic tile
flooring.

Best Practices for Slab Styles:

■ Materials should be assigned to all slab components.

■ Slabs should be defined with the baseline at the bottom of the major
structural component.

■ The index order of slab components should be indexed from top to bottom,
with the top component having index 1.

■ Thicknesses of components should always be positive. The thickness offset
from the baseline should always be to the bottom edge of the component.

■ You should consider classifying all slab styles to allow for more display
control options.

Slab Edge Styles

Slab edge styles are fairly simple and can contain a maximum of only two
components: termed “fascia” and “soffit”. As with roof slab edge styles, slab
edge styles are not applied to individual slab components, but to the slab as
a whole.

Naming Conventions:

Slab edge styles should be named according to the fascia and/or soffit condition
they define:
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<Optional fascia size> <Optional fascia> + <Optional nominal soffit size> <Optional
soffit> - <Optional default edge cut condition> - <Optional edge overhang>

Example Slab Edge Style Names:

Example NameSlab Edge Style Description

Curb6” Curb.

36x18 Grade Beam + Brick Lug36” x 18” grade beam with brick lug.

Best Practices for Slab Edge Styles:

■ When creating the profiles for the edge, draw them for the right side of
the slab when drawn in section.

■ Exercise discretion when turning on “Auto-Adjust to Edge Height”. While
this will cause the fascia to adjust to a variable width component in a slab
as it changes thickness, the adjustment is proportional. The fascia will
adjust both vertically and horizontally. The same consideration should be
taken into account when turning on the option to adjust the soffit to the
overhang depth.

NOTE Slab edge styles can not be applied as a part of the slab style definition;
instead you can apply them as a palette-based tool property. Many of the slab
styles included in the sample content files that ship with AutoCAD Architecture
indicate in their names a specific slab edge style and when a tool is created from
those styles, the slab style is already assigned to the tool properties. These styles
originated in an earlier version of the software in which default slab edge styles
could be assigned to a slab style. This capability was removed from the User
Interface of the slab style editor, however the style properties were left in those
sample styles.

Palette-Based Roof Slab and Slab Tools

To apply a slab edge or roof slab edge style at the time of creation, you can
specify them as default properties of a palette-based tool along with other
properties:

■ You may want to consider “Top”, “Bottom” or “Baseline” justification,
depending upon the type of slab and its intended purpose.

■ The Vertical Offset can be set to pre-determine an elevation for the slab.

■ You can establish an edge style as a default.
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IMPORTANT To pre-set the edge style, you must first specify the library
drawing in which the edge style exists, then define the edge style to use. Even
if the edge style already exists in the current drawing, it will not be used unless
you specify the style location.

Slab tool properties, with a slab edge style set as the default.

Stairs and Railings
Stairs can be created using a parametric object or from a 2D sketch. In both
cases, the resulting object will be based on a stair style definition.
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Stair Styles

There are no naming conventions for stair styles. In general the name should
simply indicate the overall purpose or stair type and possibly include the
primary structure, material or construction of the stair.

Example Stair Style Names:

Example NameStair Style Description

Steel - HousedSteel stairs with a housed stringer.

Ramp - Concrete + CurbStair style configured to act as a concrete
ramp with stringers configured to act as
curbs.

Best Practices for Stair Styles:

■ Consider carefully the ramifications, pro and con, of allowing the landing
extension settings and stair component settings to vary amongst stairs of
the same style. Turning these options off makes them “hard coded” to the
style. Turning them on makes them merely defaults to be applied during
the creation of a stair, but able to be overridden.

■ When a style is assigned to a custom stair created from linework, the
stringer offsets specified in the style definition will be calculated from the
lines that you select for the stringer locations.

■ Landing extensions that are defined in the stair style will be ignored when
creating a custom stair from linework.

Stair Winder Styles

Winder styles can be applied to stairs with the “Turn type” set to either “1/4
Turn” or 1/2 Turn.

Stair Winder Styles Naming Conventions:

The stair style name should indicate the Winder type, followed by specifics
as to any tread or riser controls:

<Winder type> - <Optional control parameter>...
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Example Stair Winder Style Names:

Example NameStair Winder Style Description

Manual - RiserManual winder type, “Use Riser Line”
toggled on under “Settings”.

Single Point - 2 TreadSingle Point winder type, “Adjust Winder
Turn” checked on under “Tread Settings
in Turn Area”, with 2 treads per turn.

Best Practices for Stair Winder Styles:

■ Before defining a new stair winder style, check the existing style content
library files. Most of the typical winder conditions have already been
defined.

■ When using the single point type, it is important to clear “Use Riser Line”
if the turn point will be on the edge or corner of the stair. Otherwise, the
treads will overlap and the stair will be defective.

Palette-Based Stair Tools

When creating a tool for a stair style you may want to consider the following
optional pre-sets:

■ Stair shape: although many properties of a stair can be changed after the
stair has been placed, the stair shape can only be set at the time of creation.
You may want to consider having the stair shape (multi-landing, U-shaped,
spiral or straight) be a default setting for your stair tools.

■ Turn type: you can specify either landings or turns. This is also a setting
that cannot be changed after the stair has been placed.

■ Winder style and winder style location: If you specify a turn as the turn
type, you can set the winder style to use on the turn. If you specify the
winder style, you can also specify a different drawing from which to import
the winder style.

■ Stair termination: You can pre-determine whether the stair should end
with a riser, tread or landing. This setting can be changed after the stair
has been placed as well.
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The stair tool properties

Railing Styles

Railing style names should be as descriptive as possible, listing the major
components of the railing.

Railing Styles Naming Conventions:

<Rail type> - <Rail Shape> + <Additional component> + <Additional component>...

Example Railing Style Names:

Example NameRailing Style Description

Guardrail - Pipe + Handrail + Rod Bal-
usters

Guardrail, circular with a handrail and rod
balusters.
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Example NameRailing Style Description

Guardrail - Pipe _+ Handrail + ReturnGuardrail, circular with a handrail and re-
turns:

NOTE If a custom display block applied as a style-level display override defines a
component, such as a return, it should be listed as an additional component in
the railing style name.

Spaces
Spaces have a multitude of uses, spanning the conceptual design through
construction documents phases of a project. Among other things, spaces can
begin to define the layout of a building’s internal rooms and areas. They can
also define rooms and areas for scheduling purposes and for area calculations
and evaluations. They can also contain information valuable to users of
AutoCAD MEP who need to process the geometry for analysis.

Space Styles

Space style names should be indicative of the type of room or area that the
space style is meant to address.

Space Style Naming Conventions:

<Room/Area use> - <Optional relative size> - <Optional building type>

Example Space Style Names:

Example NameSpace Style Descrip-
tion

Kitchen - Large - Com-
mercial

Large commercial kit-
chen.

Dining_Room - Restaur-
ant

Dining room for a restaur-
ant.

BedroomResidential Bedroom.

Bedroom - HotelBedroom for a hotel suite.
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Best Practices for Space Styles:

■ Spaces can have a “Name” property assigned. These are derived from a List
Definition. The List Definition should be assigned to the style so that you
have a valid list of names to select from when establishing the space object’s
properties.

■ Space styles should have materials assigned to their “Floor” and “Ceiling”
components.

■ Because space styles can work in conjunction with Zone Definitions you may
want to store them in the same library file to make it easier to make changes
later.

Structural Members

Structural Member Shape Definitions

Structural Member Shape Definitions should be named according to the
structural member style(s) for which they are intended to be a part of. For
example, if you are defining a steel bar joist member style and you’ve defined
a structural member shape definition on which you plan to base the bottom
chord component of the joist, you would name it simply “Steel Joist Bottom
Chord”.

Structural Member Styles

Structural members should be named according to the specific structural object
type that they are to represent, including dimensional information.

Structural Member Style Naming Conventions:

<Structural member type> <Size>

NOTE Frequently standard structural shape designations include the size of the
member. In these cases, the structural name can simply be the structural
designation.

Example Structural Member Style Names:

Example NameStructural Member Style Description

W8x40Wide flange steel shape (W8x40).

Bar Joist 10K110” K Series Bar Joist.
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Example NameStructural Member Style Description

Decorative Square Column - Tapered
12”-8”

Decorative square tapered square column
(specific use).

Plywood Web Joist - 1010” Plywood Web Wood Joist.

NOTE Naming conventions for structural member styles are not fixed. In the case
of structural member styles defined as a result of the Structural Member Catalog,
it is acceptable and more efficient in many cases to use the default name that is
provided by the catalog. As an example the “Plywood Web Joist - 10” style name
listed above would be “10in Plywood Web Wood Joist”.

Best Practices for Structural Member Styles:

■ When naming a structural member style, consider whether it can be used
for more than one purpose. For example, wide flange shapes can be used
for either columns, bracing or beams. In the case of such an element, you
should not indicate a specific use in the member style name.

■ When defining custom display blocks for the Model display of structural
member styles, you should use other structural members to define the
blocks where possible, in lieu of mass elements. An example of this is seen
in the example Bar Joist styles that are provided with AutoCAD
Architecture. The custom display blocks that define the webbing are made
from a structural member style called “Steel Joist Webbing”.

■ Materials should be assigned to structural member style components.

Documentation Objects
AutoCAD Architecture documentation objects are object types that are
explicitly for use as annotation tools. Rather than define 3D geometry, they
define data structures and 2D annotation graphics.

NOTE Since documentation objects do not define geometry, it is not necessary
to classify their styles for scheduling purposes, however you may want to consider
it if you need more display control than that provided by the normal display set
controls.

Documentation Objects | 973



Sections and Elevations
2D sections and elevations define the 2D representation of orthogonal views
of a 3D building model. They are not geometric objects in and of themselves,
but are more of a “report” of the model.

2D Section/Elevation Styles

The purpose of a 2D Section/Elevation style is to automate the display
characteristics of linework in the section/elevation object.

IMPORTANT It is important to have a standardized display system established
before creating custom 2D Section/Elevation styles. The Design Rules of a
Section/Elevation style are wholly dependent upon the colors assigned to objects
in the display representation used by the section/elevation object. By default, this
is usually an object’s “Model” or “Elevation” display representation. To find out
which specific display representation is used by section/elevations for each object
type, you can refer to Display Manager and review the Display Representation
Control for the “Section_Elev” display set, or whatever other display set is specified
as part of the section/elevation’s properties.

2D Section/Elevation Style Naming Conventions:

<2D Section purpose or use> - <Optional scale>

Example 2D Section/Elevation Style Names:

Example Name2D Section/Elevation
Style Description

Bldg Section-Elevation -
48

A section/elevation style
to be used for elevations
and sections plotted at
1/4”=1’-0”.

Detail BackgroundA section/elevation style
for use as a background
for a detail view.

Best Practices for 2D Section/Elevation Styles

■ If you define custom components and design rules in your section/elevation
style, you should always include a description. The description for the
design rules should explain what action each rule takes in the display
properties of the style. For example, you might have a display component
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named “Swing Lines”. The component description would be simply “Door
and Window swing lines”. The design rule accompanying the component
might have a description of “Make window and door swings a fine line
weight and dashed”.

■ For a section/elevation style intended to be used as a detail background,
you should place all display components on a no-plot layer.

■ Section/elevation styles cannot, by themselves, be made into a palette-based
tool. Instead you refer to them in a callout tool’s properties. You can specify
the library file containing the section/elevation style, and the specific
section/elevation style to be used with the callout.

Callout tool properties including the 2D Section/Elevation Style to use, the style library
from which to import the style, the default scale and display set to use.
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Dimensions
In addition to traditional AutoCAD dimensioning, AutoCAD Architecture
provides more intelligent and automated AEC Dimension objects. Thoughtful
creation of AEC Dimension Styles can greatly improve productivity during
the construction documents phase of a project. Another benefit of AEC
Dimension styles is that as AEC objects, they can be controlled with the
AutoCAD Architecture Display System, and can be scale-dependent; the same
AEC Dimension can be used for any number of scales in the drawing.

AEC Dimension Styles

AEC Dimension Style Naming Conventions:

<Maximum number of chains> - <Optional unique purpose>

Example AEC Dimension Style Names:

Example NameAEC Dimension Style Description

3 ChainDimension style with maximum 3 chains,
for use in normal construction documents
dimensioning.

2 Chain - Alternate MetricDimension style with maximum 2 chains,
to display metric units in a drawing con-
figured for imperial units.

Best Practices for AEC Dimension Styles:

■ Make your dimension styles scale dependent where possible, by using
different AutoCAD dimension styles with different settings for “Overall
Scale”. By changing display configurations, you can use a different display
representation for dimension styles that adjusts to different scales and
detail levels.

■ It is not necessary to store AEC Dimension styles, or the AutoCAD
dimension styles on which they are dependent upon for display in the
template drawing. Instead you can use the tool properties to import them
as needed from a style library. Necessary AutoCAD dimension styles will
also be imported.

■ If you have configured the “Dimension” and “Type” parameters of your
wall style components, you can and should take advantage of this in the
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AEC Dimension’s “Content” settings for the “Wall Width” dimension
parameters by specifying “From Style” or “Structural from Style”.

Schedules and Property Sets
Schedules, property set definitions, property data format styles and display
themes are all tightly interrelated. Because of that, you should take the time
to plan out carefully your system of property data usage.

Property Set Definitions

In addition to defining data fields for schedules, property set definitions can
also be used to create “smart” object tags and can be used to override display
settings for objects. Because of their myriad uses, you should plan them
carefully. Of utmost importance, you need to carefully consider what specific
object type(s) your property set definition will apply to and whether or not
it will be style-based or object-based.

NOTE Because Property Set Definitions, Property Data Format Styles, Schedule
Table Styles and Display Theme Styles are so inter-dependent you may want to
consider storing them in the same style library to make it easier to make
modifications later on.

Property Set Definition Naming Conventions:

<Object type><Optional additional description><Attachment (style or object>

Example Property Set Definition Names:

Example NameProperty Set Definition Description

DoorObjectsProperty set definition for doors, object-
based.

WindowFrameStylesProperty set definition for window frame
information, attached to window styles.

Best Practices for Property Set Definitions:

■ Do not include spaces in property set definition names or property names.
In the event that you want to have a property displayed in an object tag,
it will need to be referenced by an AutoCAD attribute definition by name
when the “Define Schedule Tag” tool is used. Attribute definition tags
cannot include spaces.
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■ When a property is selected for use in a schedule table column, the
property’s description is the default column header. While this can easily
be overridden at any time, if you keep it in mind when you are defining
your properties you can streamline the task of creating schedule tables
somewhat.

■ If you have legacy property set definitions for anchored objects that include
formula-based properties that extract information based on the host object’s
properties, you should consider replacing them with the “Anchor Property”
in AutoCAD Architecture. An example of this would be a door’s fire-rating
property where you want to make sure it is set to match the fire-rating of
the wall it is anchored to.

■ Take advantage of AutoCAD Architecture’s new ability to hide properties.
This is useful if you have a property that is not actually directly edited by
a user. By disabling its visibility you can minimize confusion when viewing
and editing properties in the “Extended Data” tab of the object properties
palette.

■ If you have classified your object styles, consider strongly using
classifications to further filter the object and style types that your property
sets apply to. This is much more reliable than using layer filters.

Property Data Formats

Property Data Formats control the appearance and character/numeric
formatting of property set values when they appear in a schedule table.

Property Data Format Naming Conventions:

Naming conventions for property data formats is fairly relaxed and descriptive:

<Data type/purpose> - <Optional description>

Example Property Data Format Names:

Example NameProperty Data Format Description

AreaProperty data format to display the area of
an object.

Length - Short 1-16Property data format to display a numerical
value as a length to 1/16” precision.
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NOTE In cases of numerical values formatted for a specific precision, you can
choose to leave the actual precision value out of the data format style name,
however you should indicate it in the description.

Best Practices for Data Format Styles:

■ Before creating a new data format style, check to make sure there isn’t
already an existing one that you can re-use. There are a large number of
pre-configured data format styles in the existing “Schedule Tables
(Imperial).dwg” or “Schedule Tables (Metric).dwg” files in your AutoCAD
Architecture content folder.

Schedule Table Styles

Schedule Table Style Naming Conventions:

<Object type> Schedule <Optional additional qualifier>

Example Schedule Table Style Names:

Example NameSchedule Table Style Description

Door ScheduleDoor schedule, using standard door num-
ber property (not project-based).

Door Schedule Project BasedDoor schedule, using project-based door
number.

Best Practices for Schedule Table Styles:

■ If you have classified your object styles, consider strongly using
classifications to further filter the object and style types that your schedule
applies to. This is much more reliable than using layer filters.

■ Pay special attention to the “Applies to” property of your schedule table
style. It must match exactly the “Applies to” property of any property set
definitions whose properties you intend to use for schedule table columns.

Display Theme Styles

Aside from making sure that your style names are descriptive, there are no
conventions or standards for Display Theme Styles.
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Zones
Zones allow you to group your spaces together for use in area calculation
schemas and presentations (showing spaces color-coded by department, for
example). Additionally, engineers who are using AutoCAD MEP can use zones
to perform complex analysis calculations and reporting.

Zone Styles

Beyond being as descriptive as possible there are no naming conventions for
Zone Styles.

Best Practices for Zone Styles:

■ If you are using Zone Templates to automate the organization of your
zones, then you must store the zone styles in the same drawing as the zone
template styles.

■ You may want to use a style-level display override for your zone styles for
presentation displays to control hatching and color.

NOTE In addition to using style display overrides to control the display of
zones, you might also consider using a Display Theme Style configured to
display Spaces based on a property value.

Calculation Modifier Styles

Calculation Modifier Style Naming Conventions:

<Calculation description> <Purpose>

Example Calculation Modifier Style Names:

Example NameCalculation Modifier Style Description

10 Percent Commons FactorModifier to add ten percent to a calculated
area to account for a commons factor add
on in a commercial office building.

Zone Template Styles

Zone Templates allow you to automate the organization of your zones into a
tree structure. Aside from being as descriptive as reasonably possible there are
no naming conventions.
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Best Practices for Zone Template Styles:

■ When it is appropriate to do so, don’t forget to attach a calculation modifier
style to the styles that you include in your zone template. This can further
automate the process of zone organization.

■ Zone template styles must be stored in the same drawing as the zone styles
that they include. They also must be stored in the same drawing as any
calculation modifiers that they use.

IMPORTANT Related zone styles, zone template styles and calculation modifier
styles must exist in the same drawing. For this reason, you should consider storing
all zone styles, zone template styles and calculation modifier styles in the same
library drawing. In addition, you should store list definitions in the library drawings
containing the zone styles, space styles and property set definitions that they are
intended to be used with.

Multi-Purpose Objects
Object styles found under the “Multi-Purpose Objects” category are usually
“helper” objects that are used to help define or enhance other object styles,
or symbol objects, such as masking blocks or multi-view blocks.

AEC Polygons

AEC Polygons are useful in defining infills for curtain walls and curtain wall
units, defining 2-dimensional areas and other annotation tasks. For example,
they are also used on the “Cut Line” tool found on the “Annotation” tool
palette.

AEC Polygon Naming Conventions:

AEC Polygon naming format will depend upon what their purpose is. An AEC
Polygon style meant to define a curtain wall infill, for example, will have a
much more rigid naming convention than one meant to merely define an
area:

<AEC Polygon purpose> - <Optional description>
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Example AEC Polygon Style Names:

Example NameAEC Polygon Style Description

Stone Infill + Revolving Doors - Stone
Infill Dark Band

AEC Polygon style to serve as banding in a
stone infill with a revolving door in a cur-
tain wall.

Classification Definitions

Classifications are a way of further defining a more generic object type. For
example, wall styles can be used to define objects that aren’t walls, such as
cabinetry, countertops, soffits, etc. By classifying objects, you can control
whether or not they are scheduled or displayed with other similar object types.

Classification Definition Naming Conventions:

Classification definitions are merely a list. Frequently this list is based on some
other documented list or data structure. In other cases they may pertain to a
specific object type and qualities about that object type. The naming format
can vary depending upon these conditions.

Naming ConventionClassification Definition Purpose

<Data structure name or description>Classification definitions based on an exist-
ing list or data structure.

<Object type> <Purpose>Classification definitions for a specific object
type and purpose.

Example Classification Definition Names:

Example NameClassification Defini-
tion Description

Uniformat IIClassification definition,
applying to all object
types, based on the Uni-
format II structure.

Doors-Windows PhaseClassification definition
for doors, windows and
assemblies, to classify
based on construction
phase.
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NOTE The second example above is exactly that, an example. In reality, a
classification definition to classify objects based on phasing might better be defined
to apply to all object types.

Best Practices for Classification Definitions:

■ While it is possible to classify objects on a “per instance” basis, it is better
in most cases to classify object styles. All object styles that define geometry
(anything that would be considered an “Architectural Object” rather than
a “Documentation Object”) should be classified.

■ Be careful not to be too restrictive when specifying the “Applies to:”
parameter for a classification definition. In many cases you may find that
your classification definition, depending upon what is actually included
in its list of classifications, might apply best for several different object
types, if not all of them.

■ If you have a long classification definition you may want to consider
arranging the classifications in a hierarchical manner. For example, if you
were developing a classification definition to encompass the MasterSpec
II format, you might have at the top level the major division numbers,
then have the sections within those divisions defined within each one at
a lower level.

■ Store commonly used classifications in your template drawings, especially
those that might be used to classify individual objects.

Layer Key Styles

Layer Key Styles are the heart of an automated layer standard. There are several
pre-defined Layer Key Styles provided with AutoCAD Architecture that are
based on existing widely accepted industry standards. You can also define
your own Layer Key Style.

Layer Key Style Naming Conventions:

<Optional company name or other unique identifier> <Optional standard name>
<Optional descriptive element>

Example Layer Key Style Names:

Example NameLayer Key Style Description

BS1192Layer Key Style based on the British BS1192
standard.
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Example NameLayer Key Style Description

AIA v3Layer Key Style based on the AIA Layer
Guidelines version 3, with provisions for
deviation from Tri-Services plotting
guidelines (using named plot styles).

Company X Health CareLayer Key Style created by “Company X”
for use with their internal layer standard,
which is specifically used on medical pro-
jects.

Best Practices for Layer Key Styles:

■ Base your Layer Key Style on a structured AutoCAD ArchitectureLayer
Standard, which defines the actual layer naming format for your layers.
Layer keys that are not based on a Layer Standard cannot take advantage
of layer key overrides.

■ Since Layer Key Styles define the color, line weight, line type and plot style
for each layer they define, they should work in conjunction with your
display system. Before defining your own Layer Key Style, you should have
a display system in effect that has been tested and you should be very
familiar with it.

■ Remember that several existing Layer Key Styles are already provided with
AutoCAD Architecture. You may want to start with these instead of creating
a new one from scratch, modifying and adding layer keys as necessary to
suit your needs.

■ Don’t forget to specify, as part of your drawing settings the Layer Standard
and Layer Key Style to automatically load in any new drawing. Additionally
you should specify that the Layer Key Style be reloaded in any existing
drawings if the “master” Layer Key Style in the library drawing has been
edited recently. (Refer to “Template Drawings” under the “Content
Resources” section of this chapter).

List Definitions

There are no naming or “Best Practices” tips for List Definitions.

NOTE Store list definitions in the library drawings containing the zone styles,
space styles and property set definitions that they are intended to be used with.
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Mask Block Definitions

Mask blocks are symbol-based style definitions that consist of a shape definition
to serve as a masking object along with optional additional graphics.

NOTE Mask blocks only affect AEC Objects and cannot mask generic AutoCAD
objects such as lines, arcs, circles, etc.

Mask Block Definition Naming Conventions:

Because Mask Block Definitions are symbolic objects, naming conventions
are similar to those used for standard block definitions. Since mask block
definitions are best stored as AEC Content, you may also want the name to
indicate the category of AEC Content in which the mask block definition
belongs:

Descriptive field>_<Optional descriptive field>_...<Optional size indication>

Example Mask Block Definition Names:

Example NameMask Block Definition Description

I_Elec_Lighting_Fluor_2x22’x2’ fluorescent lighting fixture for use in
an imperial Architectural project.

Company X_I_Furn_Table_ConfCustom conference table created by/for
“Company X” for use in imperial projects.

Best Practices for Mask Block Definitions:

■ When creating geometry to serve as additional graphics for the mask block
definition, create it on the layer “0” with color, line weight, line type and
plot style set to “BYBLOCK”, unless you have a specific reason to override
any of these values with an explicit value.

NOTE Only the objects selected as “Additional Graphics” can be assigned a
unique property for color, line weight, line type and plot style prior to being
defined as a mask block. The objects that make up the masking shape will
ignore any of those overrides once made part of a mask block definition,
following the assignments given to their display representations instead.

■ Store mask blocks as AEC Content. This way they can be easily accessed
through the Design Center. Additionally, a palette-based tool can be used
to allow users to find them without navigating the AEC Content folder
structure.
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Mass Element Styles

Unlike many other types of AutoCAD Architecture object types, mass elements
do not have to exist on a specific mass element style to be effectively used.
Many mass elements can be created on the style “Standard” with no adverse
effects whatsoever. However you can define mass element styles to predefine
material assignments, classification assignments and display representation
overrides.

Mass Element Style Naming Conventions:

Mass - <Optional classification assignment> - <Material assignment>

NOTE Classification and material assignments can be abbreviated in the mass
element style name.

Example Mass Element Style Names:

Example NameMass Element Style Description

Mass - Exterior Wall - Brown StuccoMass element for use as a decorative
column and classified as “B2010 - Exterior
Walls” from the “Uniformat II” classification
definition and assigned a material of “Fin-
ishes.Plaster and Gypsum
Board.Plaster.Stucco.Fine.Brown”.

Mass - Deep Green Marble TileUnclassified mass element for non-specific
use assigned a material of “Finishes.Floor-
ing.Tile.Marble.Deep Green”.

Best Practices for Mass Element Styles:

■ Use tools and tool palettes to provide access to your mass element styles.
You can accomplish several things with a tool referencing a mass element
style:

1 You can create a tool that pre-assigns a specific mass shape as well as
a mass style to a mass element.

2 You can create a tool that pre-assigns a mass style but leaves the shape
undefined. This is useful for assigning a mass style to an existing object
with the “Assign Tool Properties To...” right-click tool menu option
without changing its shape.

3 Mass elements by default are created on a generic “MASSELEM” layer
key, since they do not, by definition, define a specific type of
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architectural object. By using a tool, you can override this and place
them on a key that is more appropriate for the object type that they
are to represent.

Tool properties for a mass element style tool. Note that the name of the tool has been
changed to be more descriptive. Additionally, since the mass element that this tool
creates is meant to define a decorative column classified as an exterior wall, the tool’s
creator has decided to put the mass element on the layer defined by the “WALL” key
in the current layer key style. In the example the mass element shape has also been
pre-defined to be a cylinder, again, since it is meant to define a specific object type,
not just a particular material assignment.

Material Definitions

Material Definitions are integral to the display system in AutoCAD Architecture
and are a powerful tool to use with style and object definitions to automate
displays in plan, section and elevation. Additionally, you can use a “Material”
automatic property definition to tie material assignments (and the properties
of those materials) into a schedule table of objects that have the materials
assigned to them.

Material Definition Naming Conventions:

<General material category>.<Additional descriptive field>.<Optional additional
descriptive field>...<Optional color>
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Example Material Definition Names:

Example NameMaterial Definition Description

Concrete.Cast-in-Place.Exposed Aggreg-
ate.Medium

Cast in place concrete, exposed aggregate,
medium texture.

Finishes.Flooring.Tile.Marble.Deep GreenDark green marble flooring tile.

Best Practices for Material Definitions:

■ Take every step to standardize your materials. You may want to consider
storing your main material library drawing as a read-only file, accessible
to only a few authorized people in your office to ensure that standard
material definitions do not get inadvertently modified.

■ Take advantage of Project Standards to make sure your project drawings
are consistent with your office and project standard materials.

■ Avoid using the “Edit Material” or “New Material” buttons on the
“Materials” tab of your style editor. While these may seem like efficient
ways of editing and creating new materials “on the fly”, they can be
dangerous, as they make it easy to accidentally edit a material that has
been applied to a multitude of different object styles, having an unintended
and potentially drastic effect on the graphic quality of your drawing, as
well as creating a material that deviates from your standard material
definitions.

The “Edit Material” and “New Material” buttons available in the style editor. These
may seem like efficient and handy ways of creating materials on the fly, but their use
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should be discouraged as they make it easy to accidentally create non-standard
materials.

■ Assign commonly used standard materials to palette-based tools so that
users can access them quickly and easily without having to browse for your
material library file in Style Manager.

■ Material Definitions are essentially nothing more than a collection of
display representations. Therefore, every material definition you create should
have style overrides placed on every display representation.

■ When defining and editing materials, keep level of detail in mind, especially
when you are defining hatch patterns and hatch pattern scale. In the
default template drawings there are three display representations for
material definitions that are meant to address scale dependency. You can,
of course, create additional display configurations and associated display
representations for additional scale dependency. The existing display
representations for scale dependency are:

Material Display RepresentationDisplay Configuration

High DetailGeneral HIgh Detail

Medium DetailGeneral Medium Detail

Low DetailGeneral Low Detail
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■ When editing a material definition’s “General Screened” or “General
Reflected Screened” you should assign the components to a layer that has
a color or plot style assigned to it that will plot screened with color and
line type set to “BYLAYER”. These display representations are meant for
use with consultants who need a screened background drawing. You can
set one of the screened display configurations current and export your
AutoCAD Architecture drawing to an AutoCAD format. By assigning the
components to screened layers you provide your consultants and
collaborators the ability to control their display via traditional AutoCAD
layer control.

NOTE By default, the screened display representations in the Imperial and
Metric templates for use in the United States assign material display components
to the layer “A-Anno-Scrn” in accordance with the AIA layering guidelines.

IMPORTANT If you want to use material definitions to control the display of object
components in a 2D Section/Elevation object on the cut line you must first set the
“Defining Line” component in the 2D Section/Elevation’s “General” display
representation to “By Material”. Next, edit the material definitions being used in
the section and set the “2D Section/Elevation Linework” component to the color,
line type, line weight and plot style you would like to see in the Section/Elevation.
You will also need to make sure the setting “Maintain layer, color, linetype
properties form the Display Set used during generation” is toggled off.

Multi-View Block Definitions

Multi-View Block Definitions can be used for both geometric symbols and
annotation symbols (primarily chases and column grid bubbles).

Multi-View Block Naming Conventions

<Optional system of measure>_<General
object category>_<Specific object

Geometry-defining Multi-View Blocks.

type>_<Optional descriptive field>_<Optional
descriptive field>

<Optional system of measure>_<Annotation
purpose/type>_<Optional descriptive field>

Annotation-defining Multi-View Blocks.
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Example Multi-View Block Definition Names:

Example NameMulti-View Block Definition Descrip-
tion

I_Furn_Bed_QueenMulti-View Block Definition for a queen size
bed for use in an imperial project.

M_Plumb_WC_Flush - WallMulti-View Block Definition for a wall-
mounted flush WC for use in a metric pro-
ject.

ChaseMulti-View Block Definition for a Chase.

I_ColGrid_Bubble_SquareMulti-View Block Definition for a column
grid bubble, with a square bubble.

Block definitions for view block components of Multi-View blocks should also
be named consistently and appropriately.

View Block Naming Conventions:

<Optional system of measure>_<General
object category>_<Specific object

View Blocks for Geometry-defining
Multi-View Blocks.

type>_<Optional descriptive field>_<View
direction indicator>

<Optional system of measure>_<Annotation
purpose/type>_<Qualifier (“2D”, “Scale-De-
pendent”, etc.)>

View Blocks for Annotation-defining
Multi-View Blocks.

Example View Block Names:

Example NamesView Block Description

I_Furn_Bed_Queen_P2D plan view for a queen size bed multi-
view block.

I_Furn_Bed_Queen_F2D front view for a queen size bed multi-
view block.

I_Furn_Bed_Queen_M3D model for a queen size bed multi-view
block.
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Example NamesView Block Description

I_GridBubble_2D2D grid bubble block with attribute for grid
bubble multi-view block.

Best Practices for Multi-View Block Definitions:

■ Limit the use of multi-view blocks for annotation purposes to grid bubbles,
chases, and schedule tags. To define a multi-view block for use as a schedule
tag, use the Create Tag tool, accessed by clicking Annotate tab ➤ Scheduling

panel ➤  ➤ Create Tag  .

■ There are two possible display representations by default for multi-view
blocks. Typically, “General” is used for most plan views. If you need to
define a scale-dependent multi-view block, you can use “Plan” instead,
along with “Plan High Detail” and “Plan Low Detail,” and any other display
representations you might create for different scale plan views. In these
cases do not use the “General” display representation.

■ Use the Create AEC Content Wizard to store your multi-view block
definitions, rather than store them in the template. The only exception
to this is a custom column grid bubble multi-view block definition.

Profiles

Profiles are general purpose 2D definitions that assist in defining geometry
that is included in other styles. For example, a 2D shape can be converted to
a profile to define a handrail shape. The profile is then extruded the length
of the railing whose style the profile is used in to define the handrail.

Profile Definition Naming Conventions:

<Profile purpose>_<Descriptive field>_<Optional additional descriptive field>_<Optional
size indication>

Example Profile Definition Names:

Example NameProfile Definition Description

HR_GripProfile to define a handrail grip for a railing
style

Door (SingleHinge)_GlazedProfile to define a glazed door panel.
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Example NameProfile Definition Description

WallBase_1x4Profile to define a 1x4 base for a wall sweep
definition.

Fascia_2x10Profile to define a 2x10 fascia for a roof slab
edge style.

Symbol & Tool-Based Content
The terms “Symbols” and “Tools” in the context of this chapter refer mainly
to delivery mechanisms for the various types of content that is external to the
drawing template: styles, multi-view blocks, masking blocks, and
command-based content.

AEC Content
Any symbol-based content with the exception of leaders, callouts and title
marks should be created using the AEC Content Wizard and stored as AEC
Content so that it can be made accessible either through the “AEC Content”
tab in Design Center or through a palette-based tool.

NOTE Custom blocks do not scale correctly if you copy objects to which they are
attached (such as doors with door hardware) and paste them in a drawing that
has drawing units specified differently.

Best Practices for AEC Content:

■ Store your custom AEC Content files in a folder that is separate from the
default “Imperial” and “Metric” folders. The path to your AEC Content
can be accessed in the OPTIONS dialog box in the “AEC Content” tab. You
can create as many subfolders as you like in the location indicated as the
“AEC Design Center Content Path”. They will be accessible from the “AEC
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Content” tab in the AutoCAD Design Center, and will act like any other
type of AEC Content.

■ If you have existing 2D and 3D AutoCAD blocks, you can convert them
directly to AEC Content using the AEC Content Wizard and choosing
“Block” as the content type.
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■ When creating AEC Content, remember that the resulting file is a new
drawing that takes its content and other settings from the drawing in
which you are running the AEC Content Wizard. With this in mind, there
are some critical steps you should take before launching the Wizard:

1 Start in a clean drawing. Instead of using the QNEW command, which
loads a template, use the NEW command and choose “Open with No
Template - Imperial” from the “Open” drop down list.

IMPORTANT Make sure you have set your drawing setup parameters to
automatically load your layer key style into any new drawing. This is critical
in order to assign your content to a layer key.

2 Make sure your drawing window background color is set to white.
The resulting content file will have an associated icon with it. The
icon background color will be the same color as your AutoCAD
drawing window background.

3 Make sure you have all of the items necessary for your content in the
current drawing. In the case of a multi-view block that you may have
defined in another drawing, if you simply copy that block into the
current drawing, all necessary view blocks will import with it.

4 Create the graphics for your content file’s Design Center icon.
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IMPORTANT Remember that the Design Center icon is nothing more
than a thumbnail. Keep the graphics simple. The default Design Center
icon will be created from all geometry that exists in the drawing window
at the time you save the content file.

■ Always assign a layer key to your AEC Content file.

■ Always provide a description for the AEC Content file.

■ When saving the AEC Content file, make sure you save it to a folder
underneath the AEC Content path setting in your OPTIONS dialog box.
This is not done by default. You should select the “Browse” button next
to the file name field in the AEC Content Wizard to make sure your file is
being saved in the right location.

■ Most design content files, since they define actual architectural geometry,
should be made up of blocks, multi-view blocks and mask blocks.

■ Documentation content files, regardless of whether they are based on
blocks or multi-view blocks have the additional requirement that they be
inserted at a scale relative to your anticipated plot scale, and taking into
account the “Annotation Plot Size” setting in the drawing setup dialog
box. As a baseline, you can use one AutoCAD unit (either an inch or a
millimeter, depending upon whether your working in imperial or metric
units). Anything in the content file that is one unit in size will be the
annotation plot size when plotted at the drawing scale specified at the
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time it was inserted. Items that are not meant to be plotted at the
annotation plot size can be sized proportionally.

Palette-Based and Miscellaneous Annotation Tool Content
Palette-based tools, combined with tool catalogs, offer an effective means of
distributing and standardizing content, as well as automating insertion and
creation parameters.

General Best Practices for Palette-Based Tools

■ All annotation content should be created to take advantage of the
annotation plot size.

■ Tools should normally be saved in a catalog. That way, if the palette on
which they exist in the user’s workspace gets inadvertently deleted, the
tool can be restored from the original palette.

■ When creating palette based tools, make it a habit to look for automation
opportunities. With the exception of tools for AEC content, there are a
variety of properties that can be pre-configured to further automate and
standardize object creation.
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■ If you have a need for callouts that use different graphic qualities, you can
limit the number of actual tools that you create by taking advantage of
dynamic blocks. The disadvantage to doing this, however, is that you may
lose some standardization, as the same callout tool could have multiple
bubbles in the same drawing by simply changing the view state parameter
of the callouts after they’ve been inserted.

■ Store schedule tags in the same file as your schedules and property set
definitions. While this is not technically necessary in order for them to
work properly, it makes editing them easier.

■ Text and labels in schedule tags should be MTEXT objects. MTEXT that
links to a property definition will automatically be converted to a properly
formatted attribute definition.

■ Carefully consider the tool properties for leaders. There are several pre-sets
that can make creating a simple leader much less time consuming and
more standardized.
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■ If you create tools for standard AutoCAD dimensions, use the AEC Content
Wizard to do so. That way you can use the Custom Command option and
use layer keys to make sure that the dimensions go to the correct layer.

■ Break line tools should have supporting elements stored in the same
drawing as the break line symbol. As with other multi-component tools,
such as schedule tags, it makes them easier to modify in the future. All of
the properties for break marks are set in the tool properties, including
whether or not the break mark masks or trims objects.
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■ Title blocks should be stored in a sheet template drawing rather than as a
separate drawing.

■ Use MTEXT objects instead of attribute definitions in your title blocks.
When you include fields in an MTEXT object, it will word-wrap where
necessary.

TIP The title blocks that are provided in the AutoCAD Architecture sheet templates
are NCS compliant. You may want to consider beginning with them and making
modifications to suit if you are planning to comply with that standard.
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Conceptual Design
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Creating Conceptual
Models

A conceptual model, which represents the idea for a building design, comprises a variety of
building blocks. In AutoCAD Architecture, the building blocks include mass elements, mass
groups, spaces, and slices. Combined, they produce a three-dimensional (3D) model.

Mass Elements and Mass Groups
Mass elements are primitive parametric objects that have specific shapes, such
as arch, box, cylinder, and gable. They function as the building blocks of
conceptual design (also schematic design) in AutoCAD Architecture. You can
create preliminary studies, or mass models, by grouping mass elements together
in mass groups.

Mass Groups and Mass Models

When you create a mass group, you can combine the shapes of mass elements
in the mass group by adding, subtracting, and intersecting them in a specific
order. The resulting complex shape of the mass group forms your conceptual
building design, or mass model. The mass model defines the basic structure and
proportion of a building model.

Developing Mass Models

As you continue developing your mass model, you can combine mass elements
into mass groups and create complex building shapes by adding, subtracting,
and intersecting the mass elements.

You can change mass elements in the mass group as necessary to reflect the
building design. You can edit individual mass elements that are attached to a
mass group to further refine the building model. You can also nest mass groups
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within other mass groups. For more information, see Creating a Mass Group
on page 1066.

Using the Model Explorer

You can use the Model Explorer to create your entire mass model, or you can
create your mass model in the current drawing. You can also modify your
mass model or change the relationships of mass elements in the Model
Explorer. In addition to a graphics area that displays the mass model, the
Model Explorer has a tree view in which you can drag and drop mass elements
and mass groups to arrange and view the building blocks of your model in a
hierarchical structure. For more information, see Using the Model Explorer
to Create Mass Models on page 1087.

When creating massing studies, you can create mass groups with any AutoCAD
three-dimensional (3D) object, including AutoCAD ACIS solids. These can be
combined with mass elements in the Model Explorer to allow more complex
studies of potential designs. However, only objects that have volume affect
the appearance of the mass group. For example, a polyline, even with thickness,
does not contribute to the mass group.

Continuing Building Design from a Mass Model

The mass model that you create is a refinement of your original idea that you
carry into the next phase of the project, where you can slice floorplates from
the mass model. You can convert the floorplates to space boundaries to start
space planning, or you can convert them to polylines and then to walls to
begin your building design.

Display Configurations and Layouts for Mass Modeling

Drawings created from templates provided with AutoCAD Architecture contain
display configurations and layouts that enable you to work effectively with
mass elements and mass groups. For example, a layout has two viewports: one
is assigned a display configuration that displays only mass groups and the
other is assigned a display configuration that displays only mass elements.

Materials in Mass Elements

In AutoCAD Architecture, you can assign materials to a mass element. These
materials are displayed in wireframe and working shade views, or when
rendered. Materials have specific settings for individual components of a mass
element, such as linework or surface hatches.
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Mass elements with assigned materials in rendered view

AutoCAD Architecture provides predefined materials for all common design
purposes. These materials contain settings for roof slabs. You can use these
predefined materials, or modify them to your special designs. You can also
create your own materials from scratch.

For more information, see Using Materials for Mass Elements and Mass Groups
on page 1082.

Other Uses of Mass Elements and Mass Groups

You can use mass elements and mass groups to create 3D body pieces of the
building model. For example, you can apply them to walls as 3D body
modifiers.

Using Massing Tools to Create Mass Elements
Tools provided with AutoCAD Architecture let you quickly place mass elements
by selecting a massing tool with a specific style and other predefined properties.
You can use the tool with its default settings, or you can change any properties
that are not controlled by the style. You can also use massing tools to create
new mass elements by applying tool properties to existing 3D solids.
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Tool palette containing massing tools

The default tool palettes in the workspace contain massing tools that you can
use and customize as needed. In addition, the following catalogs provided
with the software contain massing tools that you can add to your tool palettes:

■ Stock Tool catalog

■ Sample Palette catalog

■ My Tool catalog

For more information on accessing tools in these catalogs, see Content Browser
on page 129.

Custom palettes created by your CAD manager or other users may also contain
massing tools with mass element styles and properties that are customized for
your projects or office standards.
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Creating a Mass Element
Use this procedure to add a new mass element that has the properties specified
in a selected massing tool. To specify settings when you add a mass element,
see Creating a Mass Element with User-Specified Settings on page 1008.

Shapes of Mass Elements

To create mass elements, you start with basic shapes and manipulate them
for the desired result. The twelve basic mass element shapes are Arch, Barrel
Vault, Box, Pyramid, Isosceles Triangle, Right Triangle, Cone, Cylinder, Dome,
Sphere, Gable, and Drape. You can also create custom mass elements by
extruding and revolving profiles and by creating free form mass elements.

You can modify a mass element based on its shape. For example, you can
specify the width, depth, and height of a Box mass element, and the radius
and height of a Cylinder mass element. For more information, see Editing
Mass Elements on page 1024.

Specifying the Size of Mass Elements

You can graphically specify size parameters of mass elements.

■ A rectangular mass element is any element that has four lines at its base,
such as an Arch, Barrel Vault, Box, Gable, Pyramid, Isosceles Triangle, or
Right Triangle. You can graphically specify the width, depth, and height
of rectangular mass elements.

■ When you create a circular mass element, you graphically specify all the
valid size parameters. Circular mass elements are Cone, Cylinder, Dome,
and Sphere.

Some parameters are fixed during input; for example, the radius of an arch is
one quarter of the width, and the rise of a gable is half the height. These
parameters can be edited after the mass elements are placed in the drawing.

1 Open the tool palette that you want to use, and select a massing
tool.

Alternatively, you can click Home tab ➤ Build panel, and select
a mass element there.

2 Specify the insertion point of the mass element.

You can move or hide the Properties palette to expose more of
the drawing area.
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3 Specify the next point.

This point can be the second corner (for a rectangular mass
element), or the radius (for a circular mass element).

4 Specify the height, if prompted.

5 Specify the rotation of the mass element.

6 Continue adding mass elements, and press ENTER.

Creating a Mass Element with User-Specified Settings
Use this procedure to add a mass element with settings that you specify.

1 Open the tool palette that you want to use, and select a massing
tool.

Alternatively, you can click Home tab ➤ Build panel, and select
a mass element there.

2 On the Properties palette, expand Basic, and expand General.

3 Select a style.

4 Under Bound Spaces, define if this mass element can be used as
a bounding object for associative spaces.

You can select three options here:

■ Yes: this mass element can be used as bounding object for
associative spaces.

■ No: this mass element cannot be used as bounding object for
associative spaces.

■ By style: this mass element will use the bounding settings from
the mass element style.

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

5 Select a shape.

6 Specify the mass group to which to attach the mass element.

7 Expand Dimensions.

The options that display under Dimensions depend on the shape
you selected for the mass element.
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8 Specify the dimensions of the mass element:

Then…If you want to…

enter a value for Width.specify the width of the mass ele-
ment in its relative X direction

enter a value for Depth.specify the depth of the mass ele-
ment in its relative Y direction

enter a value for Height.specify the height of the mass ele-
ment in its relative Z direction

enter a value for Radius.specify the radius of the mass ele-
ment

enter a value for Rise.specify the rise of the mass element

9 In the drawing area, specify the insertion point of the mass
element.

You can move or hide the Properties palette to expose more of
the drawing area.

10 Continue adding mass elements, and press ENTER.

Creating an Arch Mass Element
Use this procedure to dynamically create an Arch mass element. The insertion
point of an Arch mass element is at the centroid of its bottom face.

Arch mass element in 3D and plan views

1 On the Massing tool palette, select the Arch tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Box

drop-down ➤ Arch  .

2 Specify the first corner of the Arch.

3 Drag the cursor and specify the second corner of the Arch.
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4 Drag the cursor and specify the height of the Arch.

5 Enter a rotation angle, or press ENTER to accept the default angle
of 0.

6 Continue adding Arch mass elements, and press ENTER.

Creating a Barrel Vault Mass Element
Use this procedure to create a Barrel Vault mass element. The insertion point
of the Barrel Vault mass element is at the centroid of its bottom face.

Barrel Vault mass element in 3D and plan views

1 On the Massing tool palette, select the Barrel Vault tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Box

drop-down ➤ Barrel Vault  .

2 Specify the first corner of the Barrel Vault.

3 Drag the cursor and specify the second corner of the Barrel Vault.

4 Enter a rotation angle, or press ENTER to accept the default angle
of 0.

5 Continue adding Barrel Vault mass elements, and press ENTER.

Creating a Box Mass Element
Use this procedure to create a Box mass element. The insertion point of the
Box mass element is at the centroid of its bottom face.

Box mass element in 3D and plan views
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1 On the Massing tool palette, select the Box tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Box

drop-down ➤ Box  .

2 Specify the first corner of the Box.

3 Drag the cursor and specify the second corner of the Box.

4 Drag the cursor and specify the height of the Box.

5 Enter a rotation angle, or press ENTER to accept the default angle
of 0.

6 Continue adding Box mass elements, and press ENTER.

Creating a Pyramid Mass Element
Use this procedure to create a Pyramid mass element. The insertion point of
a Pyramid mass element is at the centroid of its bottom face.

Pyramid mass element in 3D and plan views

1 On the Massing tool palette, select the Pyramid tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Box

drop-down ➤ Pyramid  .

2 Specify the first corner of the Pyramid.

3 Drag the cursor and specify the second corner of the Pyramid.

4 Drag the cursor and specify the height of the Pyramid.

5 Enter a rotation angle, or press ENTER to accept the default angle
of 0.

6 Continue adding Pyramid mass elements, and press ENTER.
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Creating an Isosceles Triangle Mass Element
Use this procedure to create an Isosceles Triangle mass element. The insertion
point of an Isosceles Triangle mass element is at the centroid of its bottom
face.

Isosceles Triangle mass element in 3D and plan views

1 On the Massing tool palette, select the Isosceles Triangle tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Box

drop-down ➤ Isosceles Triangle  .

2 Specify the first corner of the Isosceles Triangle.

3 Drag the cursor and specify the second corner of the Isosceles
Triangle.

4 Drag the cursor and specify the height of the Isosceles Triangle.

5 Enter a rotation angle, or press ENTER to accept the default angle
of 0.

6 Continue adding Isosceles Triangle mass elements, and press
ENTER.

Creating a Right Triangle Mass Element
Use this procedure to create a Right Triangle mass element. The insertion
point of a Right Triangle mass element is at the centroid of its bottom face.

Right Triangle mass element in 3D and plan views

1 On the Massing tool palette, select the Right Triangle tool.
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Alternatively, you can click Home tab ➤ Build panel ➤ Box

drop-down ➤ Right Triangle  .

2 Specify the first corner of the Right Triangle.

3 Drag the cursor and specify the second corner of the Right
Triangle.

4 Drag the cursor and specify the height of the Right Triangle.

5 Enter a rotation angle, or press ENTER to accept the default angle
of 0.

6 Continue adding Right Triangle mass elements, and press ENTER.

Creating a Cone Mass Element
Use this procedure to create a Cone mass element. The insertion point of the
Cone mass element is at the centroid of its bottom face.

Cone mass element in 3D and plan views

1 On the Massing tool palette, select the Cone tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Box

drop-down ➤ Cone  .

2 Specify the insertion point of the Cone.

3 Drag the cursor and specify the radius of the Cone.

4 Drag the cursor and specify the height of the Cone.

5 Enter a rotation angle, or press ENTER to accept the default angle
of 0.

6 Continue adding Cone mass elements, and press ENTER.

Creating a Cylinder Mass Element
Use this procedure to create a Cylinder mass element. The insertion point of
the Cylinder mass element is at the centroid of its bottom face.
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Cylinder mass element in 3D and plan views

1 On the Massing tool palette, select the Cylinder tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Box

drop-down ➤ Cylinder  .

2 Specify the insertion point of the Cylinder.

3 Drag the cursor and specify the radius of the Cylinder.

4 Drag the cursor and specify the height of the Cylinder.

5 Enter a rotation angle, or press ENTER to accept the default angle
of 0.

6 Continue adding Cylinder mass elements, and press ENTER.

Creating a Dome Mass Element
Use this procedure to create a Dome mass element. The insertion point of the
Dome mass element is at the centroid of its bottom face.

Dome mass element in 3D and plan views

1 On the Massing tool palette, select the Dome tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Box

drop-down ➤ Dome  .

2 Specify the insertion point of the Dome.

3 Drag the cursor and specify the radius of the Dome.

4 Enter a rotation angle, or press ENTER to accept the default angle
of 0.
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5 Continue adding Dome mass elements, and press ENTER.

Creating a Sphere Mass Element
Use this procedure to create a Sphere mass element. The insertion point of a
Sphere mass element is at its centroid.

Sphere mass element in 3D and plan views

1 On the Massing tool palette, select the Sphere tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Box

drop-down ➤ Sphere  .

2 Specify the insertion point of the Sphere.

3 Drag the cursor and specify the radius of the Sphere.

4 Enter a rotation angle, or press ENTER to accept the default angle
of 0.

5 Continue adding Sphere mass elements, and press ENTER.

Creating a Gable Mass Element
Use this procedure to create a Gable mass element. The insertion point of a
Gable mass element is at the centroid of its bottom face.

Gable mass element in 3D and plan views

1 On the Massing tool palette, select the Gable tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Box

drop-down ➤ Gable  .
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2 Specify the first corner of the Gable.

3 Drag the cursor and specify the second corner of the Gable.

4 Drag the cursor and specify the height of the Gable.

5 Enter a rotation angle, or press ENTER to accept the default angle
of 0.

6 Continue adding Gable mass elements, and press ENTER.

Creating a Drape Mass Element
Use this procedure to create a Drape mass element. A drape is useful when
you are working with a conceptual model of a building site. You can create
polylines and AEC Polygons at different elevations to represent topographic
lines, and then drape a mass element over the polylines to show the contours
of the site.

For the generated terrain surface, you can choose between a regular mesh with
user-defined mesh density and mass element size, and a non-regular mesh
defined by the input contour curves and points (Delaunay triangulation).

For a non-regular mesh, you can select either a rectangular mesh of
user-specified size (the topography will be extrapolated from your input if the
selected rectangular region is larger than the area covered by the contour
curves and points), or a non-rectangular mesh whose surface size and shape
are determined by the area of the input contour curves and points.

NOTE AutoCAD Architecture uses the Autodesk Civil 3D technology to define the
terrain surface; however, the extrapolation of the terrain is used in AutoCAD
Architecture only.
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Creating a Drape mass element

1 On the Massing tool palette, select the Drape tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Box

drop-down ➤ Drape  .

2 Select the polylines or AEC Polygons to represent contours, and
press ENTER.

3 Specify whether the source contours should be deleted after
creating the drape mass element, and press ENTER.

4 Specify which mesh type you want to generate.

Then…If you want…

enter y (Yes) for Generate Regular Mesh
[Yes/No].

a surface with user-defined
mesh density and mass ele-
ment size (non-triangulated
surface)

enter n (No) for Generate Regular Mesh
[Yes/No].

a surface defined from the in-
put contours and points
(Delaunay triangulation)

5 If you are generating a regular mesh, complete the following steps:

■ Specify the first corner point of the mesh.
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■ Specify the opposite corner point of the mesh.

■ Specify the mesh subdivisions in the X-direction.

■ Specify the mesh subdivisions in the Y-direction.

■ Enter the base thickness of the resulting mass element.

6 If you are generating a non-regular mesh, specify whether you
want it to be rectangular or non-rectangular:

Then…If you want…

enter y (Yes) for Generate Rectangular Mesh
[Yes/No].

a rectangular mesh

enter n (No) for Generate Rectangular Mesh
[Yes/No].

a non-rectangular mesh

7 If you are generating a non-regular, rectangular mesh, complete
the following steps:

■ Specify the first corner point of the mesh.

■ Specify the opposite corner point of the mesh.

■ Enter the base thickness of the resulting mass element.

NOTE If the selected mesh area extends beyond the selected
contours, the topography of the resulting mass element is
extrapolated from the input values.

8 If you are generating a non-regular, non-rectangular mesh, enter
the base thickness for the resulting mass element, and press ENTER.

Creating Profiles for Extrusion and Revolution Mass Elements
Use this procedure to define a profile from a polyline to create either of the
following mass elements:

■ Extrusion, in which the shape of the two-dimensional (2D) profile is
projected to create a 3D mass element

■ Revolution, in which the 2D profile is revolved around its X axis to create
a 3D mass element
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You can draw more than one polyline within the outermost polyline to create
voids in the resulting mass element. Polylines cannot intersect or overlap.

1 Draw one or more closed polylines in the shape you want to
extrude or revolve.

2 Select the polyline, right-click, and click Convert To ➤ Profile
Definition.

3 Enter c (Centroid) for the insertion point of the profile.

The insertion point of the profile is aligned with the centroid of
the mass element.

4 Press ENTER to specify a new profile definition.

5 Enter a name for the profile, and click OK.

You can now use the profile as an Extrusion or Revolution mass
element. For more information, see Creating a Mass Element by
Extruding a Profile on page 1019 or Creating a Mass Element by
Revolving a Profile on page 1020.

Creating a Mass Element by Extruding a Profile
Use this procedure to create a custom-shaped mass element by using a profile
as the basis of its shape. The extrusion projects the shape of the profile to
create the mass element.

The width and depth of the Extrusion mass element are based on the original
width and depth of the profile. You can specify different width and depth
values, if necessary.

The insertion point is at the centroid of the bottom face of the Extrusion mass
element.

Creating an Extrusion mass element from a profile

1 Create the profile to use as the basis of the mass element.

For more information, see Creating Profiles for Extrusion and
Revolution Mass Elements on page 1018.
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2 On the Massing tool palette, select the Extrusion tool.

3 On the Properties palette, expand Basic and expand General.

4 Select the profile you created in step 1 for Profile.

5 Specify the insertion point in the drawing.

6 Specify the height of the Extrusion mass element.

7 Specify a rotation angle, or press ENTER for a rotation angle of zero
degrees.

8 Press ENTER.

Creating a Mass Element by Revolving a Profile
Use this procedure to create a mass element by defining a profile as the basis
of its shape, and then revolving the profile about an axis. The axis of revolution
is along the X axis of the profile as it is drawn. The insertion point is at the
centroid of the bottom face of the Revolution mass element.

Creating a Revolution mass element from a profile

1 Create a profile to use as the basis of the mass element.

For more information, see Creating Profiles for Extrusion and
Revolution Mass Elements on page 1018.

2 On the Massing tool palette, select the Revolution tool.

3 On the Properties palette, expand Basic and expand General.

4 Select the profile you created in step 1 for Profile.

5 Specify the insertion point in the drawing.

6 Specify a rotation angle, or press ENTER for a rotation angle of zero
degrees.

7 Press ENTER.
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Creating a Mass Element from a 3D Solid
Use this procedure to create a Free Form mass element from an AutoCAD ACIS
solid that has the properties of the mass element tool you select. You can edit
these properties after creating the mass element.

The resulting Free Form mass element is a faceted approximation of the 3D
solid. The smoothness of curved edges is controlled by the FACETDEV variable.
This variable specifies the number of facets to display on curved AEC objects.
For more information, see Specifying the Display Resolution of Objects with
Facets on page 202.

1 Open the tool palette that you want to use.

If necessary, scroll to display the tool that you want to use.

2 Right-click a mass element tool, and click Apply Tool Properties
to ➤ 3D Solid.

3 Select the 3D solids to convert.

4 When prompted to erase the original geometry, press ENTER to
keep the 3D solid, or enter y (Yes) to erase it.

5 Enter n (Name) to give a description to the mass element, and
press ENTER.

6 Enter a name, and press ENTER twice.

7 Edit the properties of the mass element in the Properties palette,
if needed.

NOTE Due to the topological structure of the free form mass element,
its facet deviation cannot be changed. The FACETDEV command will
have no effect on an existing free form mass element.

Creating a Mass Element Tool
Use this procedure to create a mass element tool and add it to a tool palette.
You may want to create your own tools if you frequently place multiple mass
elements of specific styles that have the same properties.

1 Open the tool palette on which you want to create a tool.
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2 Create the tool:

Then…If you want to…

select the object, and drag it to the
tool palette.

create a tool from a mass element
in the drawing

click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from a mass element
style in the Style Manager

the style you want to copy, and
drag it to the tool palette. Click OK
to close the Style Manager.

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

right-click the tool, and click Copy.
Open the other palette, and click
Paste.

copy a tool from another palette

click Home tab ➤ Build pan-

el ➤ Tools drop-down ➤ Content

copy a tool from a tool catalog

Browser , and locate the tool
you want to copy. Position the
cursor over the i-drop handle, and
drag the tool to the tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

6 On the Properties palette, expand Basic, and expand General.

7 Click the setting for Description, enter a description of the mass
element created from this tool, and click OK.

8 Specify a layer key and any layer overrides if you do not want to
use the layer assignments specified in the layer key style used in
the drawing.

9 Select a mass element style.

10 Select the drawing file containing the style used for this mass
element.
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11 Under Bound Spaces, define if this mass element tool can be used
as a bounding object for associative spaces.

You can select three options here:

■ Yes: this mass element tool can be used as bounding object
for associative spaces.

■ No: this mass element tool cannot be used as bounding object
for associative spaces.

■ By style: this mass element tool will use the bounding settings
from the mass element style.

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

12 Select a shape.

13 Expand Dimensions.

The options that display under Dimensions depend on the mass
element tool you copied to create the new tool.

14 Specify the dimensions of the mass element:

Then…If you want to…

enter a value for Width.specify the width of the mass ele-
ment in its relative X direction

enter a value for Depth.specify the depth of the mass ele-
ment in its relative Y direction

enter a value for Height.specify the height of the mass ele-
ment in its relative Z direction

enter a value for Radius.specify the radius of the mass ele-
ment

enter a value for Rise.specify the rise of the mass element

15 Click OK.
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Editing Mass Elements
After you create mass elements, you can edit and reposition them to generate
the form of your building mass model.

You can use grips to manipulate mass elements. The grip editing features
available depend upon the shape of the selected mass element. Because mass
elements are parametric, each shape has a specific behavior when you modify
it. For example, if you select and drag the corner grip point of a Box mass
element, the width and depth of the mass element are modified.

AutoCAD Architecture offers several methods for editing mass elements:

■ You can directly edit mass elements using grips for dimensions and other
physical characteristics.

■ You can change mass element settings on the Properties palette.

■ You can select editing commands from the shortcut menu for a selected
mass element.

■ For grip edit operations where you are changing a dimension or an angle,
the Dynamic Input feature lets you enter a precise value instead of moving
a grip. When this feature is active (click DYN on the application status
bar), selecting a grip displays a text box in which you can enter the desired
value for the associated dimension or angle. For more information, see
“Use Dynamic Input” in AutoCAD Help.

Using Grips to Edit Mass Elements
Use the following procedures to edit mass elements using grips.

Editing Mass Element Dimensions

1 Select the mass element.

2 Select the grip for the dimension you want to change.
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Viewing mass element grips and dimensions

3 Move the grip until the dimension value you want is displayed,
and click once; or enter a value.

Changing the Location or Position of a Mass Element

1 Select the mass element.

2 Select the Location grip.

In model view, the Location grip has three edit modes: Edit Along
Object’s XY Plane, Edit Along Object’s YZ Plane, and Edit Along
Object’s XZ Plane. Press CTRL to cycle among modes until you are
in the desired mode. The default edit mode is along the XY plane.
In plan view, the Location grip is restricted to movement in one
plane.

3 Move the mass element to the desired location, and click; or enter
a value, and press ENTER.

If you want to enter a specific value for the second direction in
any edit mode (for example, in the Y direction when editing along
the XY plane), press TAB to cycle to the second direction.

You can also lock the movement of the mass element along a
specific direction. If you enter a value for either dimension
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direction in the current edit mode, and then press TAB, the
movement of the mass element is constrained to the second
dimension direction. When editing along the XY plane, for
example, you can enter a value for X dimension, and then press
TAB. The X dimension is locked at that value, and movement of
the mass element is constrained to the Y dimension direction.

4 Right-click, and click Deselect All to turn off grips.

Changing the Area of a Rectangular Mass Element
Use this procedure to change the area of a rectangular mass element using
grips. A rectangular mass element is any element that has four lines at its base,
such as an Arch, Barrel Vault, Box, Gable, Pyramid, Isosceles Triangle, or Right
Triangle.

For more information about mass element grips, see Using Grips to Edit Mass
Elements on page 1024.

You can also change mass element area dimensions on the Properties palette.
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Editing a Box mass element with its corner grip

Using Corner grips to change area

1 Select the rectangular mass element to display its grips.

2 Click a corner (Width and Depth) grip, and move it to the new
location, or enter a value and press ENTER.

The location of the opposite corner remains fixed while you move
the mass element corner.

If you want to enter a specific value for the second direction in
the Width and Depth edit mode, press TAB to cycle to the second
direction value.

Changing the Edge of an Extrusion Mass Element
Use this procedure to change the area of an extrusion mass element using the
Edge grip.
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The Edge grip has three edit modes: Offset, Add Vertex, and Convert to Arc.
The default mode is Offset, which offsets the selected edge in a direction that
is perpendicular to the midpoint of the edge. Depending on the shape of the
mass element and the edge you choose to modify, neighboring lines are
extended or trimmed, and new lines are added as necessary.

Use the Add Vertex edit mode to add a vertex to the selected edge, and create
a new edge. If the selected edge is an arc, the new edge is an arc, as well.

Convert to Arc changes the selected edge to an arc and stretches the midpoint
of the edge. The edge grip for an arc also has a Stretch mode, so that you can
stretch the midpoint of the edge after it has been converted to an arc.

For more information about mass element grips, see Using Grips to Edit Mass
Elements on page 1024.

You can also change the mass element area dimensions on the Properties
palette.

1 Select the extrusion mass element.

2 Select an Edge grip.

3 Specify the new edge location:

Then…If you want to…

move the edge to the desired location and
click; or enter a value and press ENTER.

offset the edge

press CTRL to switch to the Add Vertex edit
mode. Move the edge to the desired location
and click; or enter a value and press ENTER.

add a vertex and create
an edge

press CTRL twice to switch to the Convert to
Arc edit mode. Stretch the midpoint to the

change the selected edge
to an arc

desired location and click; or enter a value
and press ENTER.

You can press CTRL to toggle among the edit modes.
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4 Right-click, and click Deselect All to turn off grips.

Changing the Height of a Mass Element
Use this procedure to change the height of a mass element using grips.

For more information about mass element grips, see Using Grips to Edit Mass
Elements on page 1024.

You can also change the mass element height on the Properties palette.

Editing a Pyramid mass element with its Height grip

1 Switch to a 3D view.

2 Select the mass element to display its grips.

3 Click the Height grip at the top of the mass element, and move
it to the new location.

The height of the mass element changes as you move the grip.

Changing the Arch Radius of an Arch Mass Element
Use this procedure to change the radius of the arch within an Arch mass
element using grips.
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For more information about mass element grips, see Using Grips to Edit Mass
Elements on page 1024.

You can also change the arch radius on the Properties palette.

Editing an Arch mass element with its Arch Radius grip

1 Select the Arch mass element to display its grips.

2 Click the Arch Radius grip, and move it to the new location.

The radius of the arch changes as you move the grip.

Changing the Roof Height of a Gable Mass Element
Use this procedure to change the roof height of a Gable mass element using
grips.

For more information about mass element grips, see Using Grips to Edit Mass
Elements on page 1024.

You can also change the Gable roof height on the Properties palette.
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Editing a Gable mass element with its Height grip

1 Switch to a 3D view.

2 Select the Gable mass element to display its grips.

3 Click the Height grip at the midpoint of the roof ridgeline.

4 Move the grip to change the height of the roof.

The height of the roof ridgeline and the walls change as you move
the grip, leaving the roof slope and gable configuration
unchanged.

Changing the Rise of a Gable Mass Element
Use this procedure to change the wall height of a Gable mass element using
grips.

For more information about mass element grips, see Using Grips to Edit Mass
Elements on page 1024.

Editing Mass Elements | 1031



You can also change the gable rise on the Properties palette.

Editing a Gable mass element with its Rise grip

1 Switch to a 3D view.

2 Select the Gable mass element to display its grips.

3 Click the Rise grip at the top of the wall.

4 Move the grip to change the height of the wall.

The height of the wall changes as you move the grip, while the
roof ridgeline position remains fixed. This changes the roof slope
and gable configuration.

Changing the Radius of a Circular Mass Element
Use this procedure to change the radius of a circular mass element using grips.
Circular mass elements include Cones, Cylinders, Domes, Doric Columns,
Spheres, and Revolutions.
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For more information about mass element grips, see Using Grips to Edit Mass
Elements on page 1024.

You can also change the mass element radius on the Properties palette.

Editing a Dome mass element with its Radius grip

1 Select the circular mass element to display its grips.

2 Click the Radius grip on the mass element.

You can select any one of the radius grips on the same circle to
change the size.

3 Move the grip in or out.

The mass element becomes larger or smaller depending on the
direction you move the grip.

Changing the Shape, Size, and Mass Group of a Mass Element
Use this procedure to change one mass element into another, add it to a mass
group, and change its size.

1 Double-click a mass element.

2 On the Properties palette, expand Basic, and expand General.

3 Select a new basic shape for Shape.
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4 To attach the mass element to a mass group, select a mass group
for Attached to.

5 Expand Dimensions.

6 Enter new dimension values for the mass element.

NOTE When you change the size of a mass element, the center point
remains constant and the change is applied to both sides of the
element.

Editing the Profile of a Mass Element
Use this procedure to edit the geometry of a mass element.

NOTE If you want to replace the geometry of the mass element with newly drawn
polylines, ellipses, or circles, draw them before you start this procedure.

1 Select the mass element that you want to change, right-click, and
click Edit Profile In Place.

2 If prompted that the profile is not drawn to size, click Yes.

A temporary profile is created for you to edit the geometry of the
mask block.

3 NOTE After you perform an editing task from the context menu, you
may need to select the profile again to perform another editing task.
If you do not see the editing commands that you expect on the
context menu, select the profile, and right-click to display the context
menu.

Edit the profile:

Then…If you want to…

select the profile, and use edge or
vertex grips to adjust the shape.

change the shape of the perimeter
of the profile or its rings

The Edge grip has two edit modes:
Stretch and Move. The default
mode is Stretch, and the direction
of the stretch depends on the orient-
ation of edges connected to the
selected edge. For example, if the
edges at both ends of the selected
edge are parallel, the grip edit
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Then…If you want to…

mode is Stretch (Parallel) and the
stretch direction is limited to the
direction of the parallel edges. If the
connected edges are not parallel,
the grip edit mode is Stretch (Off-
set) and the stretch direction is
perpendicular to the direction of
the selected edge. The Move edit
mode allows an unconstrained
move of the selected edge.

select the profile, right-click, and
click Add Vertex. Select a point for
each new vertex, and press ENTER.

add vertices to the profile

select the profile, right-click, and
click Remove Vertex. Select each
vertex to remove, and press ENTER.

remove vertices from the profile

select the profile, right-click, and
click Replace Ring. Select the ring

replace an existing ring of the pro-
file with new geometry

to replace, and select the new geo-
metry. Press ENTER to keep the
geometry, or enter n (No) to erase
it.

select the profile, right-click, and
click Add Ring. Select the geometry

add a ring to the profile

to define the ring. Press ENTER to
keep the geometry, or enter n (No)
to erase it.

select the profile, right-click, and
click Remove Ring. Select the ring
to remove, and press ENTER.

remove a ring from the profile

4 Save or discard the changes:

Then…If you want to…

right-click and click Discard All
Changes

restore the mass element to its ori-
ginal shape
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Then…If you want to…

right-click, and click Save Changes.
The mass element uses the edited

save the changes to the current
mass element

profile to define its geometry. Any
other objects or styles that use this
profile are also updated with the
edited geometry.

Combining Mass Elements Using Boolean Operations
Use this procedure to combine mass elements using Boolean operations.

1 Select the mass element to which you want to join another mass
element.

2 Selected the desired Boolean operation:

Then…If you want to…

click Mass Element tab ➤ Modify

panel ➤ Boolean drop-

down ➤ Union  .

combine the total volume of two
or more mass elements into a com-
posite object

click Mass Element tab ➤ Modify

panel ➤ Boolean drop-

down ➤ Subtract  .

remove the common area of one
mass element from another

click Mass Element tab ➤ Modify

panel ➤ Boolean drop-down ➤ In-

tersect  .

remove non-overlapping portions
and create a composite solid from
the common volume

3 Select the objects you want to combine, and press ENTER.

4 Enter y (Yes) to erase the original geometry, or enter n (No) to
keep the original geometry in the drawing.

NOTE A boolean operation creates a free form mass element. Due
to the topological structure of the free form mass element, its facet
deviation cannot be changed. The FACETDEV command will have
no effect on an existing free form mass element.
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Dividing a Mass Element
Use this procedure to divide a mass element. The divide plane you specify
splits the original mass element into two separate mass elements.

1 Select the mass element you want to divide.

2 Click Mass Element tab ➤ Modify panel ➤ Split By Plane  .

3 Specify the divide plane start point.

4 Specify the divide plane endpoint.

Dividing a mass element

The original mass element is split along the divide plane, creating
two mass elements.

NOTE Dividing a mass element creates free form mass elements. Due
to the topological structure of the free form mass element, its facet
deviation cannot be changed. The FACETDEV command will have
no effect on an existing free form mass element.

Trimming a Mass Element
Use this procedure to trim a mass element. The divide plane you specify acts
as the trim line, and you specify which side of the mass element to remove.
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1 Select the mass element you want to trim.

2 Click Mass Element tab ➤ Modify panel ➤ Trim By Plane  .

3 Specify the divide plane start point.

4 Specify the divide plane endpoint.

5 Select the side of the mass element to remove.

Trimming a mass element

NOTE Trimming a mass element creates a free form mass element.
Due to the topological structure of the free form mass element, its
facet deviation cannot be changed. The FACETDEV command will
have no effect on an existing free form mass element.

Converting a Mass Element to a Free Form Mass Element
Use this procedure to convert mass elements to Free Form mass elements.

1 Double-click the mass element to convert.

2 On the Properties palette, expand Basic, and expand General.

3 Select Freeform for Shape.
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4 Press ESC, or right-click and click Deselect All to exit the editing
session.

NOTE Due to the topological structure of the free form mass element,
its facet deviation cannot be changed. The FACETDEV command will
have no effect on an existing free form mass element.

Converting a Mass Element to a 3D Solid
Use this procedure to convert mass elements to 3D solids. Most objects create
2D geometry in plan view; therefore, select a 3D view first for best results.

1 Select the mass element to convert.

2 Click Mass Element tab ➤ Convert To panel ➤ Convert To 3D

Solid  .

3 When prompted to erase the original geometry, press ENTER to
keep the mass element, or enter y (Yes) to erase it.

Converting a Mass Element to a Wall
Use this procedure to convert mass elements to walls.

1 Select the mass element to convert.

2 Click Mass Element tab ➤ Convert To panel ➤ Wall  .

3 When prompted to erase the original geometry, press ENTER to
keep the mass element, or enter y (Yes) to erase it.

4 Specify a point to start the baseline.

5 Specify a point to end the baseline.

The Wall Styles worksheet displays the wall styles that exist in
your current drawing.

6 Select a wall style and click OK.

Converting a Mass Element to a Slab or Roof Slab
Use this procedure to convert mass elements to slabs or roof slabs.

1 Select the mass element to convert.
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2 Click Mass Element tab ➤ Convert To panel ➤ Roof Slab  .

3 When prompted to erase the original geometry, press ENTER to
keep the mass element, or enter y (Yes) to erase it.

The Slab Styles or Roof Slab Styles worksheet displays the slab or
roof slab styles that exist in your current drawing.

4 Select a style and click OK.

Converting a Mass Element to a Space
Use this procedure to convert mass elements to spaces. Depending on whether
the converted mass element shape is an extrusion- type shape (box, cylinder,
extrusion) or a non-extrusion-type shape (pyramid, gable, freeform, etc.),
either an extruded 3D space or a 3D freeform space is generated by the
conversion.

1 Select the mass element to convert.

2 Click Mass Element tab ➤ Convert To panel ➤ Space  .

3 When prompted to erase the original geometry, press ENTER to
keep the mass element, or enter y (Yes) to erase it.

Converting an Object to a Mass Element
Use this procedure to convert objects to Free Form mass elements. The resulting
Free Form mass element is a faceted approximation of the object. The
smoothness of curved edges is controlled by the FACETDEV variable.

This variable specifies the number of facets to display on curved AEC objects.
For more information, see Specifying the Display Resolution of Objects with
Facets on page 202.

1 Open a tool palette that has the Convert to Mass Element tool
and select the tool.

Alternatively, you can click Home tab ➤ Modify panel ➤ 

 ➤ Convert To Mass Element  .

2 Select the object(s) that you want to convert to a Free Form mass
element, and press ENTER.
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The Convert to Mass Element worksheet opens.

3 Enter text for Description.

4 To convert all of the selected objects into one mass element, select
Convert to single boolean mass element.

5 Alternatively, to convert the objects within your selection to
separate mass elements, select Convert to individual mass
elements.

6 To erase the original geometry of the objects, select Erase layout
geometry.

7 Click OK.

Dividing the Face of a Mass Element
Use this procedure to divide the face of a mass element. In order for the face
to split, the mass element is converted to a Free Form mass element.

1 Select the mass element whose face you want to divide.

2 Click Mass Element tab ➤ Modify panel ➤ Split Face  .

3 Select the first point on the face.

4 Select the second point on the same face, and press ENTER.

The original mass element is converted to a Free Form mass
element, and the selected face is divided along the line you
specified.

Joining the Faces of a Mass Element
Use this procedure to join previously split faces of a mass element. After the
faces are joined, the mass element is converted to its original shape.

1 Select the mass element whose faces you want to join.

2 Click Mass Element tab ➤ Modify panel ➤ Join Faces  .
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3 Select the edge of the coplanar faces, and press ENTER.

The mass element is converted to its original shape, and the
selected faces are joined into a single face.

Editing the Faces of a Free Form Mass Element
Use this procedure to edit individual faces of a Free Form mass element. You
must convert the mass element to a Free Form mass element in order to edit
its faces.

The following illustration shows how Initial and Free Form mass element grips
are displayed.

Initial and Free Form mass element grips

When you select a Free Form mass element Face grip, the following tooltip is
displayed.

Free Form mass element Face grip tool tip
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You have six choices while editing a face of a Free Form mass element. A
tooltip displays to indicate which option is current.

Tooltip DisplayedThen…If you want to…

Move face orthogonally,
stretch adjacent faces

click and drag the Face grip to
the new Face location.

move the face orthogon-
ally while stretching adja-
cent faces

Move face freely, stretch
adjacent faces

click and hold the Face grip,
press CTRL once, and specify
the new Face location.

move the face freely while
stretching adjacent faces

Move face plane, main-
tain plane of adjacent
faces

click and hold the Face grip,
press CTRL twice, and specify
the new Face location.

move the face orthogon-
ally while maintaining the
planes of adjacent faces

Pull face orthogonally,
add adjacent faces

click and hold the Face grip,
press CTRL three times, and
specify the new Face location.

pull the face orthogonally
while adding adjacent
faces

Pull face freely, add adja-
cent faces

click and hold the Face grip,
press CTRL four times, and
specify the new Face location.

pull the face freely while
adding adjacent faces

Push face orthogonally,
add adjacent faces, pos-
sibly create a hole

click and hold the Face grip,
press CTRL five times, and
specify the new Face location.

pull or push the face ortho-
gonally while either adding
adjacent faces or creating
a hole

As you cycle through the options by pressing CTRL, the tooltip advances
sequentially to indicate the current option. Pressing CTRL more than five times
returns you to the first option, allowing you to continue cycling through the
edit choices.

The cursor is constrained when you choose an orthogonal option and
unconstrained when you choose a free option.

Moving a Mass Element Face Orthogonally While Stretching Adjacent Faces

1 Select the mass element you want to edit.

2 On the Properties palette, expand Basic, and expand General.

3 Select Freeform for Shape.
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The mass element is in in-place edit mode. Each face of the Free
Form mass element is available to edit in this mode.

4 Select the Face grip for the face of the mass element to edit.

Depending on the original shape of the mass element, Edge and
Vertex grips are displayed.

5 Click and drag the Face grip to specify the new location.

6 Press ESC, or right-click and click Deselect All to exit the editing
session.

NOTE You cannot pull the mass element face at such an angle, either
horizontally or vertically, that the adjacent faces become non-planar.
If this distorted condition occurs, the mass element face automatically
returns to its original position and an error message is displayed on
the command line.

Moving a mass element orthogonally while stretching adjacent faces

The face of the Free Form mass element is moved orthogonally
and its geometry remains unchanged, while its adjacent faces are
stretched and tilted.

Moving a Mass Element Face Freely While Stretching Adjacent Faces

1 Select the mass element you want to edit.
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2 On the Properties palette, expand Basic, and expand General.

3 Select Freeform for Shape.

The mass element is in in-place edit mode. Each face of the Free
Form mass element is available to edit in this mode.

4 Select the Face grip for the face of the mass element to edit.

Depending on the original shape of the mass element, Edge and
Vertex grips are displayed.

5 Click and hold the Face grip, press CTRL once, and specify the new
location.

6 Press ESC; or right-click, and click Deselect All to exit the editing
session.

NOTE You cannot pull the mass element face at such an angle, either
horizontally or vertically, that the adjacent faces become non-planar.
If this distorted condition occurs, the mass element face automatically
returns to its original position and an error message is displayed on
the command line.

Moving a mass element freely while stretching adjacent faces

The face of the Free Form mass element is moved freely and its
geometry remains unchanged, while its adjacent faces are stretched
and tilted.
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NOTE The location of the current UCS is temporarily moved to
coincide with the original position of the Face grip that you select
when you are working with this option. Only the UCS origin is
changed, not its orientation.

Moving a Mass Element Face Orthogonally While Maintaining the Planes of
Adjacent Faces

1 Select the mass element you want to edit.

2 On the Properties palette, expand Basic, and expand General.

3 Select Freeform for Shape.

The mass element is in in-place edit mode. Each face of the Free
Form mass element is available to edit in this mode.

4 Select the Face grip for the face of the mass element to edit.

Depending on the original shape of the mass element, Edge and
Vertex grips are displayed.

5 Click and hold the Face grip, press CTRL twice, and specify the
new location.

6 Press ESC, or right-click and click Deselect All to exit the editing
session.

NOTE You cannot pull the mass element face at such an angle, either
horizontally or vertically, that the adjacent faces become non-planar.
If this distorted condition occurs, the mass element face automatically
returns to its original position and an error message is displayed on
the command line.
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Moving a mass element face orthogonally while maintaining the planes of adjacent
faces

The face of the Free Form mass element is moved orthogonally
and its geometry is changed, while the planes of its adjacent faces
are maintained.

Pulling a Mass Element Face Orthogonally While Adding Adjacent Faces

1 Select the mass element you want to edit.

2 On the Properties palette, expand Basic, and expand General.

3 Select Freeform for Shape.

The mass element is in in-place edit mode. Each face of the Free
Form mass element is available to edit in this mode.

4 Select the Face grip for the face of the mass element to edit.

Depending on the original shape of the mass element, Edge and
Vertex grips are displayed.

5 Click and hold the Face grip, press CTRL three times, and specify
the new location.

6 Press ESC, or right-click and click Deselect All to exit the editing
session.
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Pulling a mass element face orthogonally while adding adjacent faces

The face of the Free Form mass element is moved orthogonally
and its geometry remains unchanged, while adjacent faces between
the original geometry and the moved face are added.

Pulling a Mass Element Face Freely While Adding Adjacent Faces

1 Select the mass element you want to edit.

2 On the Properties palette, expand Basic, and expand General.

3 Select Freeform for Shape.

The mass element is in in-place edit mode. Each face of the Free
Form mass element is available to edit in this mode.

4 Select the Face grip for the face of the mass element to edit.

Depending on the original shape of the mass element, Edge and
Vertex grips are displayed.

5 Click and hold the Face grip, press CTRL four times, and specify
the new location.

6 Press ESC, or right-click and click Deselect All to exit the editing
session.
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NOTE You cannot pull the mass element face at such an angle, either
horizontally or vertically, that the adjacent faces become non-planar.
If this distorted condition occurs, the mass element face automatically
returns to its original position and an error message is displayed on
the command line.

Pulling a mass element face freely while adding adjacent faces

The face of the Free Form mass element is moved freely and its
geometry remains unchanged, while adjacent faces between the
original geometry and the moved face are added.

NOTE The location of the current UCS is temporarily moved to
coincide with the original position of the Face grip that you select
when you are working with this option. Only the UCS origin is
changed, not its orientation.

Pushing or Pulling a Mass Element Face Orthogonally While either Adding
Adjacent Faces or Creating a Hole

1 Select the mass element you want to edit.

2 On the Properties palette, expand Basic, and expand General.

3 Select Freeform for Shape.

The mass element is in in-place edit mode. Each face of the Free
Form mass element is available to edit in this mode.

Editing Mass Elements | 1049



4 Select the Face grip for the face of the mass element to edit.

Depending on the original shape of the mass element, Edge and
Vertex grips are displayed.

5 Click and hold the Face grip, press CTRL five times, and specify
the new location.

Push into the mass element to create a hole, or pull out of the
mass element to add adjacent faces.

6 Press ESC, or right-click and click Deselect All to exit the editing
session.

Pulling a mass element face orthogonally while adding adjacent faces

The face of the Free Form mass element is pulled orthogonally
and its geometry remains unchanged, while adding adjacent faces
between the original geometry and the moved face.
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Pushing a mass element face orthogonally to create a hole

The face of the Free Form mass element is pushed orthogonally
and its geometry remains unchanged, while creating a hole in the
mass element.

Assigning Materials to a Mass Element
Use this procedure to assign materials to the individual components of a mass
element.

1 Select the mass element to which you want to assign materials,
right-click, and click Edit Object Display.

2 To verify that the material assignment determines the display
properties of the component, click the Display Properties tab,
select the display representation where you want the changes to

appear, and click  .

3 Click the Layer/Color/Linetype tab, verify that By Material is
selected for the component, and click OK.

4 Click the Materials tab.

The Component column displays all components of the mass
element that can be assigned a material. Components that are
only symbolical graphics, like the bounding box, are not listed
because they cannot have a material assignment.

The Material Definition column displays the currently assigned
materials. If no previous material assignments were made, the
default material is Standard.
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5 Select the component you want to change, and select a different
material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Although you can edit a material definition from this
dialog box, any changes you make to the material definition apply
to all objects that are assigned the material.

6 Click OK twice.

Specifying the Display Properties of a Mass Element
Use this procedure to change the following display properties of the
components of a mass element:

■ Visibility (component is on or off)

■ By Material (material assigned to the component determines its display
properties)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

NOTE If a material assignment determines the properties of a mass element display
component, you can change the properties of the display component by clearing
By Material or by overriding the material assignment with a different material. For
more information, see Assigning Materials to a Mass Element on page 1051.

1 Select the mass element you want to change, right-click, and click
Edit Object Display.

2 Click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current one.
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4 If necessary, click  .

5 Click the Layer/Color/Linetype tab.

6 Select the component to change, and select a different setting for
the property.

7 Click OK twice.

Specifying the Hatching of a Mass Element
Use this procedure to specify the hatching of components of an individual
mass element. Hatching is displayed only in display representations, such as
Plan, that are used in the Top view (plan view) of a drawing.

NOTE If a material assignment determines the hatching properties of a mass
element display component, you can change the hatching by clearing By Material
or by overriding the material assignment with a different material. For more
information, see Assigning Materials to a Mass Element on page 1051.

1 Select the mass element you want to change, right-click, and click
Edit Object Display.

2 Click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current one.

4 If necessary, click  .

5 Click the Hatching tab.

6 Select a display component, and click the setting for Pattern.

7 Select the hatching for the display component:

Then…If you want to select…

select Predefined for Type, and then
select a pattern.

a hatching pattern that is available
in the software

select Custom for Type, and then
enter the name of the custom pat-

a custom pattern

tern. If necessary, click Browse, and
navigate to the folder where the
custom pattern file is located.
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Then…If you want to select…

select User-defined for Type, and
clear Double Hatch.

single hatching

select User-defined for Type, and
select Double Hatch.

double hatching

select Solid Fill for Type.solid fill

8 Click OK.

9 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

10 Click Angle, and enter the angle for the selected pattern.

11 Click Orientation, and specify how the hatching is oriented:

Then…If you want to orient…

select Object.the hatching to the object, regard-
less of the object rotation

select Global.the hatching to the World Coordin-
ate System

12 Click OK twice.

Changing the Location of a Mass Element
Use this procedure to relocate a mass element by changing the coordinate
values of its insertion point. The mass element also has an orientation with
respect to the world coordinate system (WCS) or the current user coordinate
system (UCS). For example, if the top and bottom of the mass element are
parallel to the XY plane, its normal is parallel to the Z axis. You can change
the orientation of the mass element by aligning its normal with another axis.
You can also rotate the mass element on its plane by changing the rotation
angle.

For more information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use Coordinates and Coordinate Systems” in
AutoCAD Help.

1 Select the mass element you want to change.
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2 On the Properties palette, expand Basic, and expand Location.

3 Select Additional information.

4 Specify the location of the mass element:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the mass element

make the normal of the mass ele-
ment parallel to the Z axis: under

locate the mass element on the XY
plane

Normal, enter 1 for Z, and enter 0
for X and Y.

make the normal of the mass ele-
ment parallel to the X axis: under

locate the mass element on the YZ
plane

Normal, enter 1 for X, and enter 0
for Y and Z.

make the normal of the mass ele-
ment parallel to the Y axis: under

locate the mass element on the XZ
plane

Normal, enter 1 for Y, and enter 0
for X and Z.

enter a new value for Rotation
Angle.

change the rotation of the mass
element

5 Click OK twice.

Specifying the Cut Plane Display of a Mass Element
Use this procedure to specify the properties of one or more cut planes for a
mass element. Cut plane display properties apply only to display
representations, such as Plan, that are used in the Top view (plan view) of a
drawing.

1 Double-click the mass element you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.
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NOTE To apply your changes to all mass elements in the drawing,
select Drawing default setting. To apply changes to all mass elements
of this style, select Mass Element Style:<style name>. For more
information on styles, see Mass Element Styles on page 1057.

5 If necessary, expand Object Display Properties ➤ Cut Plane.

6 For Override cut plane, specify whether you want to override the
global cut plane defined for the current display configuration.

7 If you selected Yes for Override cut plane, enter a value for Height
to define the cut plane for this object. (Alternatively, you can click

 and specify 2 points in the drawing area to set the new size.)

You can also access and modify these same cut plane settings through the
mass element’s context menu, as follows

1 Select the mass element, right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 In the Display Properties dialog, click the Other tab, and then
change the settings as needed.

6 Click OK twice.

Attaching Hyperlinks, Notes, or Files to a Mass Element
Use this procedure to attach hyperlinks, notes, or files to a mass element. You
can also edit hyperlinks and notes, and edit or detach reference files from a
mass element.

1 Select the mass element to which you want to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

4 Click OK.

5 To add a note, click the setting for Notes, and enter the note.
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6 Click OK.

7 To add a reference file, click the setting for Reference documents,
and attach, edit, or detach a reference file:

Then…If you want to…

click Add, and select a file. Click
open, and click OK.

attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

8 Click OK twice.

Mass Element Styles
A mass element style is a collection of settings for variables associated with a
mass element. Depending on the scope of the drawing, you could create
different mass element styles to represent different types of mass elements.

Properties Controlled by Mass Element Styles

The mass element style determines the properties of mass elements you create.
When you edit the display properties of a mass element style, those changes
are applied to existing mass elements of that style throughout the current
drawing.

Creating Mass Element Styles

Typically, you create mass element styles that represent the basic building
blocks of the drawing. When you name a mass element style, mass elements
are grouped and can generate reports based on the first part of the mass
element style name.
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Editing Mass Element Styles

The changes you make to a mass element style take effect the next time you
use that style. Mass elements already created with that style are not updated
unless you change the display properties of the mass element style.

Managing Mass Element Styles

When you create, import, export, or edit styles, you access the Style Manager.
The Style Manager provides a central location in AutoCAD Architecture where
you can work with styles from multiple drawings and templates. For more
information about using the Style Manager, see Style Manager Overview on
page 870.

Creating a Mass Element Style
Use this procedure to create a mass element style. You can create a style using
default style properties or by copying an existing style. After you create the
style, you edit the style properties to customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Mass Element Styles.

3 Create a mass element style:

Then…If you want to…

right-click Mass Element Styles, and
click New.

create a style with default properties

right-click the mass element style
you want to copy, and click Copy.
Right-click, and click Paste.

create a style from an existing style

4 Enter a name for the new mass element style, and press ENTER.

5 Edit the new mass element style:

Then…If you want to…

see Assigning Materials to a Mass
Element Style on page 1060.

specify materials for mass element
components

see Specifying the Display Proper-
ties of a Mass Element Style on
page 1061.

specify the display properties of the
style
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Then…If you want to…

see Specifying the Hatching for
Components of a Mass Element
Style on page 1062.

specify hatching for components of
the style

see Attaching Notes and Files to a
Mass Element Style on page 1064.

add notes and files to the style

6 When you finish specifying the properties of the mass element
style, click OK.

Specifying the Materials of a Mass Element Style
A mass element consists of a number of components whose display properties
can be determined by the materials assigned to each component.

You assign one material to each physical component of the mass element.
You assign materials to components in each display representation where you
want the materials to be used.

If you want to use the display properties of the mass element style, instead of
using material display properties, you can turn off the material assignments
in the display properties of the style.

Material definitions consist of display components that correspond to
component types of objects. For example, the Linework component of a
material is used for all linework in plan view. The Surface Hatch component
of a material is used to hatch all object surfaces in three-dimensional (3D)
model views and in elevations.

Mass Element Materials and Display Components
The following table lists mass element components and the material
components that determine them in specific views.

Material ComponentMass Element Component

Plan, Plan High Detail, Plan Low Detail, Plan
Presentation, Plan Screened

Plan LineworkAbove Cut Plane
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Material ComponentMass Element Component

Plan LineworkBelow Cut Plane

Plan HatchHatch

No MaterialCut Plane

Model

3D BodyEntity

No MaterialBounding Box

Reflected, Reflected Screened

3D BodyEntity

No MaterialBounding Box

Plan HatchHatch

Assigning Materials to a Mass Element Style
Use this procedure to assign materials to the individual components of a mass
element style. The component uses the display properties of the material
instead of the style display properties.

You can assign a material to any physical component of the mass element.
Custom components and components that are only symbolic graphics do not
use materials for their display properties. For example, the hatch is a physical
component. The cut plane is a symbolic component.

NOTE If a material assignment does not determine the display properties of a
mass element component, you can change the display properties of the mass
element style as described in Specifying the Display Properties of a Mass Element
Style on page 1061.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Mass Element Styles.

3 Select the style you want to edit.
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4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select By Material for any component to which you want to assign
a material, and click OK.

If the setting for By Material is not available, the display of this
component cannot be determined by a material.

9 Click the Materials tab.

10 Select the component you want to change, and select a different
material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Although you can edit a material definition from this
dialog box, any changes you make to the material definition apply
to all objects that are assigned the material.

11 Click OK.

Specifying the Display Properties of a Mass Element Style
Use this procedure to change the following display properties of the display
components of a mass element style:

■ Visibility (component is on or off)

■ By Material (material assigned to the component determines its display
properties)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

Mass Element Styles | 1061



To change these display properties for an individual mass element, see
Specifying the Display Properties of a Mass Element on page 1052.

NOTE If a material assignment determines the display properties of components
in the mass element style, you can change the properties of the display component
by clearing By Material. You can also override the material assignment with a
different material. For more information, see Assigning Materials to a Mass Element
Style on page 1060.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Mass Element Styles.

3 Select the mass element style you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 Click the Layer/Color/Linetype tab.

7 Select the component to change, and select a different setting for
the property.

8 Click OK.

Specifying the Hatching for Components of a Mass Element
Style

Use this procedure to specify the hatching of components of a mass element
style. Mass element hatching is displayed only in display representations, such
as Plan, that are used in the Top view (plan view) of a drawing.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Mass Element Styles.

3 Select the mass element style to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and click Style Override.

The display representation in bold is the current one.

6 Click the Hatching tab.

7 Select a display component, and click the setting for Pattern.
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8 Select the hatching for the display component:

Then…If you want to…

select Predefined for Type, and then
select a pattern.

select a hatching pattern that is
available in the software

select Custom for Type, and then
enter the name of the custom pat-

select a custom pattern

tern. If necessary, click Browse, and
navigate to the folder where the
custom pattern file is located.

select User-defined for Type, and
clear Double Hatch.

select single hatching

select User-defined for Type, and
select Double Hatch.

select double hatching

select Solid Fill for Type.select solid fill

9 Click OK.

10 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

11 Click Angle, and enter the angle for the selected pattern.

12 Click Orientation, and specify how the hatching is oriented:

Then…If you want to…

select Object.orient the hatching to the object,
regardless of the object rotation

select Global.orient the hatching to the World
Coordinate System

13 Click OK.

Defining a Mass Element Style as Bounding for Associative
Spaces

Use this procedure to define a mass element style that can bound associative
spaces.
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When a mass element style is set as bounding, by default all mass element
that have the style assigned will be used in the selection set for an associative
space. For more information about associative spaces see Generating Associative
Spaces on page 2940.

You can override the bounding settings from the mass element style in an
individual mass element, if necessary.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Mass Element Styles.

3 Select a mass element style.

4 Click the General tab.

5 Select the check box for Objects of this style may act as a boundary
for associative spaces.

6 Click OK.

Attaching Notes and Files to a Mass Element Style
Use this procedure to enter notes and attach reference files to a mass element
style. You can also edit notes and edit or detach reference files from a mass
element style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Mass Element Styles.

3 Select the mass element style you want to change.

4 Click the General tab.

5 To add a description to the mass element style, enter it for
Description.

6 Click Notes.

7 To add a note, click the Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file
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Then…If you want to…

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

9 Click OK twice.

Using Massing Tools to Create Mass Groups
Tools provided with AutoCAD Architecture let you quickly place mass groups
by selecting a tool from the Massing tool palette. The mass group tool has
predefined properties. You can use the default settings of the tool, or you can
change settings for the mass group properties.

Tool palette containing mass group tools
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The default tool palettes in the workspace contain sample mass group tools
that you can use and customize as needed. In addition, the following catalogs
provided with the software contain mass group tools that you can add to your
tool palettes:

■ Stock Tool catalog

■ Sample Palette catalog

For more information on accessing tools in these catalogs, see Content Browser
on page 129.

Custom palettes created by your CAD manager or other users may also contain
mass group tools with mass group properties that are customized for your
projects or office standards.

Creating a Mass Group
Use this procedure to add a new mass group that has the properties specified
in a selected mass group tool.

A mass group is a display object that allows you to visualize and manipulate
combinations of mass elements. After you create mass elements, you can
combine their shapes through Boolean operations (addition, subtraction, and
intersection) in a mass group. The resulting complex shape of the mass group
represents your mass model.

Mass Groups and Mass Group Markers

You use a mass group tool to attach mass elements, other AEC objects, or
AutoCAD objects to a mass group, which you place in a convenient area of
your drawing. The mass elements and other objects that you attach form the
body of the mass group. The mass group is created on a different layer than
the mass elements that form it.

A mass group marker is displayed in the drawing if you create a mass group
and then detach all mass elements from it, or if you release the anchor of
objects attached to the group. If you attach elements to the group, or if you
anchor attached objects to the group, the mass group marker is no longer
displayed.
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Using Boolean Operations to Create a Mass Group

You can combine the shapes of mass elements in the mass group—adding,
subtracting, and intersecting them in a specific order.

■ An additive operation combines the total volume of two or more solids or
two or more regions into a composite object.

■ A subtractive operation removes the common area of one set of solids from
another.

■ An intersection removes non-overlapping portions and creates a composite
solid from the common volume.

You can attach any closed, solid shape to a mass group. For example, a line
has no solid properties and cannot be added to the shape of the mass group.
However, an AutoCAD 3D solid does contribute to the final shape.

You can also create and work with mass groups in the Model Explorer. For
more information, see Using the Model Explorer to Create Mass Models on
page 1087.

To further refine the building model, you can edit individual mass elements
that are attached to a mass group.

Materials in Mass Groups

In AutoCAD Architecture, you can assign materials to a mass group. These
materials are displayed in wireframe or rendered views. Materials have specific
settings for individual components of a mass group.

Mass groups with assigned materials in rendered view
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AutoCAD Architecture provides predefined materials for common design
purposes, which contain settings for mass groups. You can use these predefined
materials, or modify them to your special designs. You can also create your
own materials.

For more information, see Using Materials for Mass Elements and Mass Groups
on page 1082.

1 Open the tool palette that you want to use, and select a mass
group tool.

If necessary, scroll to display the tool that you want to use.

2 Select the elements to attach to the group, and press ENTER.

3 Specify the insertion point of the mass group.

You can move or hide the Properties palette to expose more of
the drawing area.

Assigning Materials to a Mass Group
Use this procedure to assign materials to the individual components of a mass
group.

1 Select the mass group to which you want to assign materials,
right-click, and click Edit Object Display.

2 To verify that the material assignment determines the display
properties of the component, click the Display Properties tab,
select the display representation where you want the changes to

appear, and click 

3 Click the Layer/Color/Linetype tab, verify that By Material is
selected for the component, and click OK.

4 Click the Materials tab.

The Component column displays all components of the mass
group that can be assigned a material. Components that are only
symbolical graphics, like the bounding box, are not listed because
they cannot have a material assignment.

The Material Definition column displays the currently assigned
materials. If no previous material assignments have been made,
the default material is Standard.

5 Select the component you want to change, and select a different
material definition.
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You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Although you can edit a material definition from this
dialog box, any changes you make to the material definition apply
to all objects that are assigned the material.

6 Click OK twice.

Changing the Size of the Mass Group Marker
Use this procedure to change the size of the mass group marker by editing its
display properties.

1 Double-click the mass group you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all mass groups in the drawing,
select Drawing default setting.

5 If necessary, expand Object Display Properties ➤ Advanced.

6 Click the value for Marker size, and enter a new value.

(Alternatively, you can click  and specify 2 points in the
drawing area to set the new size.)

You can also access and modify the marker size property through the mass
group’s context menu, as follows

1 Select the mass group, right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .
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5 In the Display Properties dialog, click the Other tab, and then
change the size as needed.

6 Click OK twice.

Adding a New Mass Element to a Mass Group
Use this procedure to add a new mass element to a mass group after you have
placed a mass group in the drawing.

1 Select an existing mass group or mass group marker.

2 Click Mass Group tab ➤ Modify panel ➤ Add New Element.

3 On the Properties palette, select a shape for the mass element.

4 Select Add, Subtract, or Intersect for Operation.

5 Specify an insertion point in the drawing.

6 Specify additional parameters for the mass element.

Depending on the shape of the mass element, you need to specify
a second corner, the radius, or the height.

7 Specify a rotation angle, and press ENTER.

The newly created mass element is now part of the selected mass group.

Attaching an Existing Mass Element to a Group
Use this procedure to add existing mass elements to a mass group. When an
element is attached to a mass group, the element display is turned off and the
group display is turned on.

While it is possible to attach any number of objects to a single mass group,
performance improves if this group is subdivided into a series of nested groups.
Your design is also more manageable if a group is broken into logical divisions.
In addition, if one of the subgroups fails to display as expected, it is easier to
track down the problem. In most cases, you can adjust the order of the objects
in the group to get the correct appearance.

1 Select the mass group.

2 Select the Attach Elements grip.

Alternatively, you can click Mass Group tab ➤ Modify

panel ➤ Attach Elements  .
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3 Select one or more mass elements to attach to the mass group,
and press ENTER.

Detaching a Mass Element from a Group
Use this procedure to detach a mass element from a mass group. After you
have defined a mass group and added mass elements to it, you may decide
that one or more elements do not fit your model. You can detach these from
the mass group and use them elsewhere or delete them.

When an element is detached from a mass group, the element display is turned
on because it is an individual entity and is no longer part of the group.

1 Select the mass group.

2 Select the Detach Elements grip.

Alternatively, you can click Mass Group tab ➤ Modify

panel ➤ Detach Elements  .
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3 Select one or more mass elements to detach from the mass group.

If there is only one element attached to the mass group, you are
not prompted to select elements. The single element is detached
without further input.

4 Press ENTER.

Using Boolean Operations for Mass Groups
You can change a mass group by using boolean operations on the mass
elements contained within.

Making a Mass Element Additive
Use this procedure to change the operation of a mass element. All objects are
additive when they are created. When two mass elements are grouped together,
they form one mass containing both objects.

1 Select the mass group that contains the mass element you want
to change.

2 Select the Edit In Place grip.

Alternatively, you can click Mass Group tab ➤ Modify panel ➤ Edit

In Place  .

3 Select the mass element you want to make additive.

4 Click Edit in Place tab ➤ Modify panel ➤ Mass Group Operation

drop-down ➤ Additive  .
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5 Click Edit in Place tab ➤ Edits panel ➤ Finish  .

This saves the changes to the mass element and ends the in-place
edit session.

Making a Mass Element Subtractive
Use this procedure to change the operation of a mass element. When a mass
element in a group operates by subtraction, the mass element subtracts its
mass where it overlaps another object.

1 Select the mass group that contains the mass element you want
to change.

2 Select the Edit In Place grip.

Alternatively, you can click Mass Group tab ➤ Modify panel ➤ Edit

In Place  .

3 Select the mass element you want to make subtractive.

4 Click Edit in Place tab ➤ Modify panel ➤ Mass Group Operation

drop-down ➤ Subtractive  .

5 On the Properties palette, expand Basic, and expand General.

6 Select Subtract for Operation.

7 Click Edit in Place tab ➤ Edits panel ➤ Finish  .

This saves the changes to the mass element and ends the in-place
edit session.
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Creating an Intersection from Mass Elements
Use this procedure to create a new mass shape using the intersection of two
mass elements.

1 Select the mass group that contains the mass element you want
to change.

2 Select the Edit In Place grip.

Alternatively, you can click Mass Group tab ➤ Modify panel ➤ Edit

In Place  .

3 Select the mass element you want to make intersecting.

4 Click Edit in Place tab ➤ Modify panel ➤ Mass Group Operation

drop-down ➤ Intersect  .

5 On the Properties palette, expand Basic, and expand General.

6 Select Intersect for Operation.

7 Click Edit in Place tab ➤ Edits panel ➤ Finish  .

This saves the changes to the mass element and ends the in-place
edit session.

Creating a Nested Mass Group
Use this procedure to attach a mass group to another mass group. This action
nests the current mass group within the mass group that you select.
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You may find it easier to nest mass groups using the Model Explorer. For more
information, see Moving a Mass Element or Group from One Mass Group to
Another on page 1101.

1 Select the mass group that you want to nest within another mass
group.

2 On the Properties palette, expand Basic, and expand General.

3 Click the mass group where you want to nest the current mass
group for Attached to.

4 Specify Add, Subtract, or Intersect for Operation.

This option determines how the mass group is nested within the
mass group you selected.

Removing a Nested Mass Group from a Mass Group
Use this procedure to remove a mass group from a mass group in which the
first mass group is nested. The mass group you remove remains in the drawing.

1 Select the mass group you want to remove.

2 On the Properties palette, expand Basic, and expand General.

3 Select None for Group.

4 Right-click, and click Deselect All to turn off grips.

Changing the Location of a Mass Group Using Grips
Use this procedure to relocate a mass group using the Location grip. In Model
view, the Location grip has three edit modes: Edit Along XY Plane, Edit Along
YZ Plane, and Edit Along ZX Plane. The default edit mode is along the XY
plane. In Plan view, the Location grip is restricted to movement in one plane.

If the mass elements that are attached to the mass group are anchored, they
move when you move the Location grip. If the anchor of objects has been
released, only the mass group marker moves when you move the Location
grip. For more information, see Working with Mass Group Anchors on page
1077.

You can also change the location of a mass group using the Properties palette.

1 Select the mass group you want to change.

2 Select the Location grip.
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3 Move the mass group to the desired location, and click once; or
enter a value and press ENTER.

If you want to enter a specific value for the second direction in
any edit mode (for example, in the Y direction when editing along
the XY plane), press TAB to cycle to the second direction.

You can also lock the movement of the mass group along a specific
direction. If you enter a value for either dimension direction in
the current edit mode, and then press TAB, the movement of the
mass group is constrained to the second dimension direction.
When editing along the XY plane, for example, you can enter a
value for X dimension, and then press TAB. The X dimension is
locked at that value, and movement of the mass group is
constrained to the Y dimension direction.

4 Right-click, and click Deselect All to turn off grips.
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Working with Mass Group Anchors
Use these procedures to release anchors of objects attached to a mass group,
or anchor elements to a mass group.

Releasing object anchors from a mass group

1 Select the mass group with objects anchored to it.

2 Click Mass Group tab ➤ Modify panel ➤ Release Anchor  .

All anchors are released, and the mass group marker is displayed.
The display of attached elements is turned on.

Anchoring objects to a mass group

1 Select the mass group or the mass group marker that has no objects
anchored to it.

The mass group must have mass elements attached to it in order
to anchor them to the group.

2 Right-click, and click Anchor Attached Objects.

All objects are anchored to the mass group, and the mass group
marker is no longer displayed. The display of attached elements
is turned off.

Working with Mass Groups
Use these procedures to place an entity reference of a mass group in a drawing,
or to reposition the insertion point of a mass group.

You can place a mass group in the drawing multiple times for modeling. Using
an entity reference helps to simplify the modeling process.

Using Massing Tools to Create Mass Groups | 1077



You can adjust the insertion point of a mass group by selecting a new location
and a new rotation.

Placing an entity reference of a mass group

1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Place Reference  .

3 Move the cursor to the desired location for the entity reference,
and click once to place the reference in the drawing.

4 Specify the rotation angle, and press ENTER.

An entity reference of the selected mass group is placed in the
drawing, as specified. The entity reference is distinguished from
the mass group by its location marker.

Repositioning the insertion point of a mass group

1 Select a mass group.
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2 Click Mass Group tab ➤ Modify panel ➤ Reposition Insertion

Point  .

3 Specify the new insertion point.

4 Enter a rotation angle, and press ENTER; or move the cursor, and
click to specify the rotation.

If the mass group has an entity reference connected to it,
repositioning the insertion point of the mass group affects the
rotation of the entity reference.

Specifying the Cut Plane Display of a Mass Group
Use this procedure to specify the properties of one or more cut planes for a
mass group. Cut plane display properties apply only to display representations,
such as Plan, that are used in the Top view (plan view) of a drawing.

1 Double-click the mass group you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all mass groups in the drawing,
select Drawing default setting.

5 If necessary, expand Object Display Properties ➤ Cut Plane.

6 For Override cut plane, specify whether you want to override the
global cut plane defined for the current display configuration.
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7 If you selected Yes for Override cut plane, enter a value for Height
to define the cut plane for this object. (Alternatively, you can click

 and specify 2 points in the drawing area to set the new size.)

You can also access and modify these same cut plane settings through the
mass group’s context menu, as follows

1 Select the mass group, right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 In the Display Properties dialog, click the Other tab, and then
change the settings as needed.

6 Click OK twice.

Attaching Hyperlinks, Notes, or Files to a Mass Group
Use this procedure to attach hyperlinks, notes, or files to a mass group. You
can also edit hyperlinks and notes, and edit or detach reference files from a
mass group.

1 Double-click the mass group to which you want to attach
information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

4 To add a note, click  next to Notes, enter text, and click OK.

5 To attach, detach, or edit a reference file, click  next to
Reference documents, and then do any of the following:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

1080 | Chapter 16   Creating Conceptual Models



Then…If you want to…

enter text under Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

6 Click OK twice.

Creating a Mass Group Tool
Use this procedure to create a mass group tool and add it to a tool palette.
You may want to create your own mass group tools if you are placing multiple
mass groups with the same mass group properties.

1 Open the tool palette where you want to create a tool.

2 Create the tool:

Then…If you want to…

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

right-click the tool, and click Copy.
Open the other palette, and click
Paste.

copy a tool from another tool
palette

click Home tab ➤ Build pan-

el ➤ Tools drop-down ➤ Content

copy a tool from a tool catalog

Browser , and locate the tool
you want to copy. Position the
cursor over the i-drop handle, and
drag the tool to the tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.
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5 Click the setting for Description, enter a description of the tool,
and click OK.

6 To add keywords to the tool, click More Info.

7 Enter the keywords, and click OK twice.

Using Materials for Mass Elements and Mass Groups
Using materials simplifies defining the display of objects. You define the
display of a material, such as brick or glass, only once in the drawing or the
drawing template, and then assign it to any object component or object style.
For example, you can define a material “Glass” and assign it to any number
of windows, glass door insets, or cubicle walls.

Using a common set of materials provides centralized control across the display
of objects in a drawing or throughout the whole project. When the particulars
of a material change, you change them just once in the material definition,
and all objects are updated.

For more information, see Materials on page 885.

Rendered building with different materials

Predefined Materials

AutoCAD Architecture provides predefined materials for common design
purposes. You can use these predefined materials, or modify them to your
special designs. You can also create your own materials.
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Surface Hatching

Surface hatches can display in both model views and section/elevation views.
Placement and orientation of the hatch can be precisely controlled and
specified for each object face individually.

For detailed information about surface hatches, see Working with Surface
Hatches on page 904.

Mass Element and Mass Group Display Components and
Materials

A mass element or a mass group consists of a number of display components
that can be determined by materials.

Workflow

You assign one material to each display component of the mass element or
mass group. For example, you assign a dark wood material to the mass element
body and a light brown material to the mass element hatch. When you assign
a material to a mass group, the display properties of the attached mass elements
are overridden with the mass group settings.

If you want to use the display properties of the mass element instead of the
material display properties, you can deactivate the material assignments in
the display properties of the mass element.

Display Representations

The display properties of an object are specified for each display representation
individually. Mass elements and mass groups have display representations for
plan, model, reflected, and sketch views. You can create new display
representations for mass elements and mass groups by copying an existing
representation. For example, you can create a new display representation “Plan
1:25” to create a plan view optimized for display in a view scaled to 1:25. This
new display representation has the same display components as the one from
which it was copied. The copied components will be influenced by the same
material components as the original components.

Material Component Assignments

Material definitions consist of display components that correspond to
component types of objects. For example, the Linework component of a
material is used for all linework in Plan view. The Surface Hatch component
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of a material is used to hatch all object surfaces in 3D model views and
elevations.

For a complete list of material components and their descriptions, see Material
Components and Display Properties on page 898.

The following table lists mass element components and the material
components that determine them.

Material ComponentMass Element Component

Plan High Detail, Plan Low Detail, Plan
Presentation, Plan Screened

Plan HatchHatch

No MaterialCut Plane

Model

3D BodyEntity

No MaterialBounding Box

Reflected, Reflected Screened, Sketch

Plan LineworkEntity

No MaterialBounding Box

Plan HatchHatch

The following table lists mass group components and the material components
that determine them.

Material ComponentMass Group Component

Plan High Detail, Plan Low Detail

No MaterialMarker

No MaterialCut Plane

No MaterialHatch
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Material ComponentMass Group Component

Plan, Plan Presentation, Plan Screened

Plan LineworkEntity

No MaterialMarker

Model

3D BodyEntity

No MaterialMarker

Reflected, Reflected Screened

Plan LineworkEntity

No MaterialMarker

Process Overview: Creating and Applying a Material for a Mass
Element or Mass Group

If you create a material, you can apply it to all types of objects that support
materials. For example, a concrete material could be used for a wall and for a
structural element. Mass elements and mass groups are often used for columns,
elevator shafts, or chimneys. If you want to create a material to use only for
mass elements or mass groups, you should name it accordingly. For example,
if the materials have specific names, such as “Mass Element - Concrete
Column” or “Mass Group - Cable Shaft,” you can simplify the organization
of your material definitions.

1 Create a new material definition or edit an existing material definition.

For more information, see Creating and Editing Material Definitions on
page 919.
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2 In the material definition, define the settings that affect the display of
materials in mass elements and mass groups:

Then…If you want to…

turn on the Surface Hatch component,
and specify its display properties. For

display a surface hatch for a mass ele-
ment or a mass group in 3D model
views more information, see Defining the

Layer, Color and Linetype of a Material
Definition on page 920 and Specifying
the Surface Hatch Pattern of a Material
Definition on page 923.

turn on the Section Hatch component,
and specify its display properties. For

display a section hatch for a mass ele-
ment or mass group in a 2D section, 3D
section, or live section more information, see Defining the

Layer, Color and Linetype of a Material
Definition on page 920 and Specifying
the Plan and Section Hatch Patterns of
a Material Definition on page 921.

turn on the Sectioned Boundary and
Sectioned Body components, and spe-

display the sectioned boundary and
sectioned body of a mass element or
mass group in a live section cify their display properties. For more

information, see Defining the Layer,
Color and Linetype of a Material Defini-
tion on page 920.

select rendering materials. For more in-
formation, see Assigning Render Mater-
ials on page 925.

add special rendering materials for mass
elements or mass groups in live sections

specify this setting in the material
definition. For more information, see

exclude mass element or mass group
components from a 2D section shrink-
wrap hatch Excluding a Material Definition from 2D

Section Shrinkwrap on page 928.

3 Turn on the assigned materials in the individual display representations,
and then assign materials to the mass elements and mass groups in your
building model.

For more information about assigning materials to mass elements, see
Assigning Materials to a Mass Element on page 1051.
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For information about assigning materials to mass groups, see Assigning
Materials to a Mass Group on page 1068.

Using the Model Explorer to Create Mass Models
The Model Explorer is a window in which you create, view, and manipulate
mass elements and mass groups. You can create your entire conceptual model
by using the Model Explorer. The main window is similar to the 3D orbit view.
You can attach objects and mass elements to mass groups and view them in
the Model Explorer. You can simultaneously view the conceptual and the
hierarchical structure of mass groups and mass elements that make up the
model.

The Model Explorer is divided into three areas: the tree view in the left pane,
the graphics area in the right pane, and the menu bar and toolbar across the
top.

Viewing a mass group in the Model Explorer

Left Pane of the Model Explorer
The tree view lists all open drawings as Projects. Any mass groups are displayed
under their associated drawing in the tree view. If you expand a mass group,
the mass elements attached to it are displayed. One of the following icons is
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displayed next to each mass element in the mass group, indicating which
Boolean operation is used to combine mass elements:

Boolean Operation UsedIcon

If both circles are blue, the operation is
union.

If the left portion of the 2 circles is blue,
the operation is subtractive.

If the intersection of the 2 circles is blue,
the operation is intersection.

An additive operation in the Model Explorer combines the total volume of
two or more solids or two or more regions into a composite object. A
subtractive operation removes the common area of one set of solids from
another. An intersection removes non-overlapping portions and creates a
composite solid from the common volume.

The order of objects and mass elements in the tree view dictates the outcome
of the group when mass elements are combined. You can drag and drop the
mass elements within the mass group to change the order in which they are
combined.

You can also drag and drop mass groups to nest them within other mass
groups. For example, if you are modeling a building with multiple wings, each
wing can be a mass group containing multiple mass elements. You can then
add these groups to a mass group of the entire building.

Right Pane of the Model Explorer

The right pane of the Model Explorer displays a graphical view of the mass
elements or mass groups that you select in the left pane.

Model Explorer Menu Bar and Toolbar

The top of the Model Explorer includes a menu bar and toolbar that allow
you to access menu commands. If you position your pointing device over a
toolbar icon, a tooltip displays an explanation of the icon. For more
information, see Using Toolbar Commands in the Model Explorer on page
1094.

If you turn off the Model Explorer toolbars using commands on the View
menu, the tree view and viewer are blank the next time you display the Model
Explorer. Click any pull-down menu heading to restore the proper display.

1088 | Chapter 16   Creating Conceptual Models



Displaying the Model Explorer
Use this procedure to open the Model Explorer. Any mass groups in the current
drawing are displayed in the right pane. The tree view in the left pane lists
the mass groups in open drawings.

Viewing a mass group in the Model Explorer

1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Show Model Explorer

 .

3 You can move, resize, or close the Model Explorer:

Then…If you want to…

drag the Model Explorer title bar to
the desired location.

move the Model Explorer

click the edge of the Model Explorer
and drag to the desired size.

resize the Model Explorer

click the “X” in the upper right
corner of the Model Explorer.

close the Model Explorer
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Defining the View in the Model Explorer
The Model Explorer lets you display mass groups in different view directions,
display configurations, and visual styles. You can also define parallel or
perspective views.

1 Select a visual style from the drop-down menu on the top left:

■ 3D Hidden: Displays the objects using 3D wireframe
representation and hides lines representing back faces.

■ 3D Wireframe: Displays the objects using lines and curves to
represent the boundaries.

■ Conceptual: Shades the objects and smooths the edges between
polygon faces. Shading uses a transition between cool and
warm colors. The effect is less realistic, but it can make the
details of the model easier to see.

■ Realistic: Shades the objects and smooths the edges between
polygon faces. Materials that you have attached to the objects
are displayed.

Alternatively, right-click in the preview area, click Visual Style,
and select the desired style.

2 Click the  button to select a display configuration.

Display configurations are collections of object display
representations, determining which objects are visible, and how
the objects are displayed per view. For more information, see
Display Configurations on page 810.

3 Select a view direction from the drop-down menu on the top
right.

Alternatively, right-click in the preview area, click Preset Views,
and select the desired view direction.

4 Select the projection type of the mass groups in the preview:

■ To select a parallel projection, right-click in the preview area,
and click Projection  ➤ Parallel.

■ To select a perspective projection, right-click in the preview
area, and click Projection  ➤ Perspective.
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Navigating the View in the Model Explorer
In the Model Explorer, you have a number of options for navigating through
the model view.

1 Use these basic navigation tools as needed:

■ To move the view in the drawing area, click  (Pan Realtime.)
Alternatively, right-click in the preview area, and click Pan.

2 To zoom in and out of the drawing area, click  (Zoom
Realtime.)

Alternatively, right-click in the preview area, and click Zoom. For
further Zoom options, right-click in the drawing area, click More,
and select the desired Zoom option.

3 To orbit the model in 3D, click  (Constrained 3D Orbit.)

Alternatively, right-click in the preview drawing area, and click
Orbit.

4 To move closer to or farther away from the model, click 
(Adjust Distance.)

This command works only when you are in perspective projection.

Alternatively, right-click in the preview drawing area, and click
More  ➤ Adjust Distance.

Navigating the View with the ViewCube
The ViewCube is a 3D navigation tool that appears when the 3D graphics
system is enabled and allows you to switch between standard and isometric
views.

In Model Explorer the ViewCube is always visible. When you position the
cursor over the ViewCube, it becomes active. You can switch to one of the
available preset views, roll the current view, or change to the Home view of
the model.
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For detailed information about the ViewCube, see “ViewCube” in the AutoCAD
Help.

Navigating the View with SteeringWheels
SteeringWheels are tracking menus that are divided into different sections
known as wedges. Each wedge on a wheel represents a single navigation tool.
You can pan, zoom, or manipulate the current view of a model in different
ways.

SteeringWheels can save you time and clicks by combining many of the
common navigation tools into a single interface. Wheels are specific to the
context that a model is being viewed in.
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1 Click the  button.

Alternatively, you can right-click in the preview area, and click
Steering Wheel.

2 To close the SteeringWheel, right-click, and click Close Wheel, or

click the  button again.

For detailed information, see “SteeringWheels” in the AutoCAD
Help.

Viewing Objects on a Nonvisible Layer
Use this procedure to change the settings in the Model Explorer to view all
objects, regardless of the visibility of the layer on which they reside. Any object
on a layer that is frozen or turned off is not displayed initially.

1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Show Model Explorer

 .

3 On the Model Explorer View menu, click Show All Layers.

The check mark on the menu next to Show All Layers indicates that all objects
are displayed in the Model Explorer.
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Maintaining Zoom Percentage and Position of an Object
Use this procedure to select an object in the Model Explorer tree view. The
zoom percentage and location of the object are maintained. This is useful
when you want to examine how the object relates to the rest of the drawing.

In the Model Explorer, you can specify to display the selected object only,
and display it at maximum size.

1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Show Model Explorer

 .

3 On the Model Explorer View menu, click Auto Zoom Extents.

4 Select the object to view from the tree view.

The Model Explorer graphics window displays only the selected
object, zoomed to fit the window.

Using Toolbar Commands in the Model Explorer
The following toolbar commands allow you to work with mass elements and
mass groups in the Model Explorer:

Icon

New Grouping: Creates a new mass group in the drawing.

New Element: Creates a new mass element in the drawing.

Cut: Cuts the selected item in the tree view to the Clip-
board.

Copy: Copies the selected item from the tree view to the
Clipboard.

Paste: Pastes the item on the Clipboard into the tree view
at the selected location.

Delete Item: Deletes an item from the tree view and from
the drawing.
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Icon

Attach Items: Attaches existing mass elements or objects
to the selected mass group. Select one or more elements
or objects in the drawing. This option is available only when
a mass group is selected in the tree view.

Detach Items: Detaches the selected mass elements or
objects from the mass group. This option is available only
when a mass group is selected in the tree view.

Properties: Opens the properties dialog box for the selected
mass element, object, or mass group.

Display Configuration: Changes the display configuration
of the objects in the Model Explorer. You select a display
configuration from the list.

Creating a Mass Element with the Model Explorer
Use this procedure to create a mass element in the Model Explorer. For detailed
information about specifying the shape and dimensions of a mass element,
see Creating a Mass Element on page 1007.

1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Show Model Explorer

 .

3 In the left pane, select the level at which to create the mass
element.

If you select the drawing name, the new mass element is created
at the next hierarchical level. If you select a mass group name
with a drawing, the new mass element is attached to the selected
mass group.

4 On the Model Explorer File menu, click Create Element, or click

 .

5 On the command line, specify a shape.

6 Specify the insertion point for the mass element.

Depending on the shape you specified, you need to specify a
second corner, the radius, or the height.
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7 Specify the rotation angle.

8 Press ENTER.

Creating a Mass Group
Use this procedure to create a mass group in the Model Explorer.

1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Show Model Explorer

 .

3 In the left pane, select the level at which you want to create the
mass group.

If you select the drawing name, the new mass group is created at
the next hierarchical level. If you select a mass group name with
a drawing, the new mass group is nested within the existing mass
group.

4 On the Model Explorer File menu, click Create Group, or click

 .

5 Specify a location for the mass marker.

The location does not represent the location of mass elements
added to the marker. Therefore, you can locate the mass marker
in any convenient area.

6 Specify the rotation angle.

The new mass group is added to the project tree in the Model Explorer.

Attaching a Mass Element to a Mass Group
Use this procedure to attach existing mass elements to the group after a mass
group is created.

1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Show Model Explorer

 .

3 In the left pane, select a mass group, right-click, and click Attach
Elements.

4 Select the mass elements to add to the group, and press ENTER.
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Attaching Objects to a Mass Group
Use this procedure to attach objects such as doors, walls, and curtain walls to
the group after a mass group is created.

1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Show Model Explorer

 .

3 In the left pane, select a mass group, right-click, and click Attach
Elements.

4 Select the objects to add to the group, and press ENTER.

Changing a Mass Element Operation to Additive
Use this procedure to change a mass element operation to additive. Mass
elements are additive when you create them. After a mass element is added
to a mass group, its operation can be changed to produce different results.
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Adding a mass element to a mass group

1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Show Model Explorer

 .

3 In the left pane, select a mass element, right-click, and click
Operation ➤ Additive.

4 In the left pane, click Project to update the display.

The display changes to indicate the new operation property of the mass
element.

Changing a Mass Element Operation to Subtractive
Use this procedure to change a mass element operation to subtractive. Mass
elements are additive when you create them. After a mass element is added
to a mass group, its operation can be changed to produce different results. If
the mass element is subtractive, its shape is removed from the mass group.
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Subtracting a mass element from a mass group

1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Show Model Explorer

 .

3 In the left pane, select a mass element, right-click, and select
Operation ➤ Subtractive.

4 In the left pane, click Project to update the display.

The display changes to indicate the new subtractive operation of the mass
element.

Changing a Mass Element Operation to Intersection
Use this procedure to change a mass element operation to intersection. Mass
elements are additive when you create them. After a mass element is added
to a mass group, its operation can be changed to produce different results.
The intersect operation creates a shape that is defined by the overlap where
the mass element intersects with another mass element.
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Creating an intersection mass group from mass elements

1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Show Model Explorer

 .

3 In the left pane, select a mass element, right-click, and select
Operation ➤ Intersect.

4 In the left pane, click Project to update the display.

The display changes to indicate the new intersection operation of the mass
element.

Specifying the Order of Mass Elements
Use this procedure to specify the order of mass elements. The operation
(additive, subtractive, intersection) of each mass element in a mass group is
based on the hierarchy of mass elements in the project tree. You can drag and
drop mass elements within mass groups in the project tree. By default, mass
elements are listed in the left pane of the Model Explorer in the order they
are created in the Model Explorer or selected for the mass group.
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1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Show Model Explorer

 .

3 Select the mass element you want to move, and drag it to the
target location in the project tree.

Moving a Mass Element or Group from One Mass Group to
Another

Use this procedure to move a mass element or a mass group from one mass
group to another in the Model Explorer project tree.

1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Show Model Explorer

 .

3 In the left pane, select the mass element or mass group you want
to move, and drag it to another mass group.

When you move a mass group within another mass group, it is
known as a nested mass group.

Creating Slice Floorplates from a Conceptual Model
A slice can be thought of as a representation of a theoretical floor level. Slice
floorplates provide a way to translate the 3D geometry of a mass group into
something that can be used to generate the individual floors of a building.
Slices can be converted to space boundaries or polylines, and then to walls.

Slices and Mass Models

Like mass groups, slices are chosen and manipulated by an associated marker,
the slice marker. When you attach mass groups to the slice marker, the slice
marker creates the perimeter geometry of the building, known as a floorplate.
Anytime you change the mass groups attached to the slice marker, the
floorplate is updated.

If you attach mass elements instead of mass groups to the slice, the operational
aspects (additive, subtractive, and intersection) of the mass elements are not
recognized by the slice. To have these aspects recorded by the slice, attach the
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mass group. For more information about additive, subtractive, and intersection
operations, see Creating a Mass Group on page 1096.

From Slice Floorplate to Walls

After you create floorplates, you can convert slices to space boundaries or
polylines, and then generate walls. You cannot create walls directly from a
slice. The slice is simply a way to mark each floor level of the mass group.

Generating a Slice
Use this procedure to generate a slice. The slice object is defined by a small
crossed box. Like the mass group marker, the slice marker can be located in a
convenient place in your drawing. For more information about the mass group
marker, see Creating a Mass Group on page 1096.

You can create multiple slices at regular height intervals. A slice marker is
created for each slice.
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Generating slice objects

1 Open the tool palette that you want to use, and select a slice tool.

If necessary, scroll to display the tool that you want to use.

2 Specify the number of slices you want to create.

3 Specify the lower-left and upper-right corners for the slice marker.

TIP Keep the slice marker small so as not to clutter your drawing.

4 Specify a rotation for the slice marker.

5 Enter the starting height of the slice.

6 Enter the distance between slices, and press ENTER.

7 Press ENTER.
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Specifying the Slice Elevation
Use this procedure to change the elevation of a slice.

1 Select the slice marker.

2 Click Slice tab ➤ Modify panel ➤ Set Elevation  .

3 Enter a new slice elevation.

If multiple slices were created together, only the elevation of the
selected slice changes. The distance between slices remains
constant.

Attaching Objects to a Slice
Use this procedure to attach mass elements or mass groups to a slice to create
the building floorplate. You can freeze the layer(s) containing the mass
elements and mass groups to display only the slices.

Attaching a mass group to slice objects

1 Select the slice marker.

2 Click Slice tab ➤ Modify panel ➤ Attach Objects  .

3 Select the mass elements or mass groups you want to include in
the slice.

4 Press ENTER.

Detaching Objects from a Slice
Use this procedure to detach mass elements or mass groups from a slice to
change a floorplate.
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1 Select the slice marker.

2 Click Slice tab ➤ Modify panel ➤ Detach Objects  .

3 Select the mass elements or mass groups you want to remove from
the slice.

4 Press ENTER.

Converting a Slice to a Polyline
Use this procedure to convert a slice to a polyline after objects have been
attached to a slice marker. You can then convert polylines to spaces, walls, or
profiles.

■ Select the slice marker.

■ Click Slice tab ➤ Modify panel ➤ Convert To Polyline  .
The outlines of the objects attached to the slice marker are converted to
polylines.

Changing the Location of a Slice
Use this procedure to relocate a slice by changing the coordinate values of its
insertion point. The slice also has an orientation with respect to the world
coordinate system (WCS) or the current user coordinate system (UCS). For
example, if the top and bottom of the slice are parallel to the XY plane, its
normal is parallel to the Z axis. You can change the orientation of the slice
by aligning its normal with another axis. You can also rotate the slice on its
plane by changing the rotation angle.

For more information about the WCS and the UCS, see “Use Coordinates and
Coordinate Systems” in AutoCAD Help.

1 Double-click the slice you want to modify.

2 On the Properties palette, expand Basic, and expand Location.

3 Click Additional information.

4 Specify the location of the slice:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the slice

Converting a Slice to a Polyline | 1105



Then…If you want to…

make the normal of the slice parallel
to the Z axis: under Normal, enter
1 for Z, and enter 0 for X and Y.

locate the slice on the XY plane

make the normal of the slice parallel
to the X axis: under Normal, enter
1 for X, and enter 0 for Y and Z.

locate the slice on the YZ plane

make the normal of the slice parallel
to the Y axis: under Normal, enter
1 for Y, and enter 0 for X and Z.

locate the slice on the XZ plane

enter a new value for Rotation
Angle.

change the rotation of the slice

5 Click OK.

Attaching Hyperlinks, Notes, or Files to a Slice
Use this procedure to attach hyperlinks, notes, or files to a slice. You can also
edit hyperlinks and notes, and edit or detach reference files from a slice.

1 Double-click the slice to which you want to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

4 To add a note, click the setting for Notes, and enter the note.

5 Click OK.

6 To add a reference file, click the setting for Reference documents,
and attach, edit, or detach a reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file
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Then…If you want to…

select the file name, and click De-
lete.

detach a reference file

7 Click OK.
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Quick Slice

The Quick Slice tool lets you “slice” through one or more objects in a drawing and extract a
polyline outline that you can use to create profile shapes.

Quick Slice
The Quick Slice tool lets you “slice” through one or more three-dimensional
(3D) objects in a drawing (including mass groups, AutoCAD® blocks, and external
references) and extract a polyline outline that can be used to produce a profile
shape, such as a roof truss. If you have a 3D model of stairs in your drawing,
you can use the Quick Slice tool to create a polyline outline of the stair object
in a section view, instead of using a section tool. For more information about
section views, see Sections on page 3251.

Unlike the Horizontal Section, Vertical Section, and Slice tools, which produce
multiple polyline segments, the Quick Slice tool produces a single polyline.
When you slice through the selected object(s), any overlapping parts of the
outline are combined in a boolean operation and converted into a polyline that
is inserted on the current layer. The Quick Slice tool also differs from the Slice
tool in that it does not create a slice marker. For more information about the
Slice tool, see Generating a Slice on page 1102.

Creating a Quick Slice
Use this procedure to extract a polyline outline of a “slice” through one or more
3D objects.

1 Click Home tab ➤ Section & Elevation panel ➤  ➤ Quick Slice

 .
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NOTE The Quick Slice tool is also provided with the Helper Tools in
the Stock Tool Catalog. You can add this tool to any tool palette. For
more information, see Content Browser Overview on page 129.

2 Select the object(s) that you want to slice through, and press
ENTER.

3 Specify a starting point for the slice plane.

4 Specify a second point to complete a slice plane through the
object(s) and generate the polyline outline.

You can now select the polyline outline and view it using the
Object Viewer.
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Object Viewer

The Object Viewer lets you preview objects in your drawing with different visual styles, view
directions, and display configurations without changing the display of the drawing area.

Object Viewer
The Object Viewer lets you preview objects in your drawing with different visual
styles, view directions, and display configurations without changing the display
of the drawing area.

The Object Viewer can be started from different locations in the software.
Depending on where the Object viewer is located the viewing and navigation
options can vary. For example, if you use Object Viewer to preview an object
from the drawing area, a compass is displayed. If you use the object viewer to
preview a style in Style Manager, the compass is not displayed, since the style
is not an object located in WCS or UCS.

Previewing Objects from the Drawing Area

You can select one or more objects in the drawing area, and preview them in
the Object Viewer.

1 Select the objects in the drawing area for which you want to see a preview.

2 Click <Object> tab ➤ General panel ➤ Object Viewer  .
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Previewing Object Styles in the Style Manager

You can preview the effects of a style that you are creating in the Object Viewer
(Floating Viewer) provided with Style Manager.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .
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2 Select the style you want to preview.

3 Click the  (Floating Viewer) button at the bottom left of Style Manager.

Alternatively, you can click the  button (Inline Edit Toggle) to display
the Object Viewer embedded inside Style Manager.

Previewing Mass Models in Model Explorer

The Model Explorer is a window in which you create, view, and manipulate
mass elements and mass groups. The Model Explorer uses the Object Viewer
to let you preview the mass element and mass group operations you perform.

For more information about Model Explorer, see Using the Model Explorer to
Create Mass Models on page 1087.

1 Select a mass group.

2 Click Mass Group tab ➤ Modify panel ➤ Show Model Explorer  .

Embedded Object Viewers

A number of dialogs have embedded object viewers in order to let you preview
components of a style, a definition, or a tool. See below for a couple of
examples of embedded Object Viewers.

Object Viewer | 1113



Embedded Object Viewer in Roof Slab style tab
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Embedded Object Viewer in tool properties

Defining the View in the Object Viewer
The Object Viewer lets you display selected objects, styles, or tools in different
view directions, display configurations, and visual styles. You can also define
parallel or perspective views.

1 Open the Object Viewer from one of these locations:

■ Select an object in the drawing area, and click <Object>

tab ➤ General panel ➤ Object Viewer  .

■ Click Manage tab ➤ Style & Display panel ➤ Style Manager

 , and click the  button.

Alternatively, you can click the  button (Inline Edit Toggle)
to display the Object Viewer embedded inside Style Manager.
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■ Select a mass group, and click Mass Group tab ➤ Modify

panel ➤ Show Model Explorer  .

2 Select a visual style from the drop-down menu on the top left:

■ 3D Hidden: Displays the objects using 3D wireframe
representation and hides lines representing back faces.

■ 3D Wireframe: Displays the objects using lines and curves to
represent the boundaries.

■ Conceptual: Shades the objects and smooths the edges between
polygon faces. Shading uses a transition between cool and
warm colors. The effect is less realistic, but it can make the
details of the model easier to see.

■ Realistic: Shades the objects and smooths the edges between
polygon faces. Materials that you have attached to the objects
are displayed.

Alternatively, right-click in the preview area, click Visual Style,
and select the desired style.

3 Select a display configuration from the drop-down list below the
Visual Styles drop-down list.

Display configurations are collections of object display
representations, determining which objects are visible, and how
the objects are displayed per view. For more information, see
Display Configurations on page 810.

NOTE Display configurations are not available in some embedded
Object Viewers.

4 Select a view direction from the drop-down menu on the top
right.

Alternatively, right-click in the preview area, click Preset Views,
and select the desired view direction.

5 Select the projection type of the objects in the preview:

■ Click  to display the objects in a parallel projection.

■ Click  to display the objects in a perspective projection.
Perspective views require a distance between a theoretical
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camera and target point. in order to change the lens length

of the camera, click  and enter the desired value.

Alternatively, right-click in the preview area, click Projection, and
select the desired view projection.

NOTE In embedded Object Viewers, only the context menu options
of these commands are available.

Navigating the View in the Object Viewer
In the Object Viewer, you have a number of options for navigating through
the model view.

1 Open the Object Viewer from one of these locations:

■ Select an object in the drawing area, and click <Object>

tab ➤ General panel ➤ Object Viewer  .

■ Click Manage tab ➤ Style & Display panel ➤ Style Manager

 , and click the  button.

Alternatively, you can click the  button (Inline Edit Toggle)
to display the Object Viewer embedded inside Style Manager.

■ Select a mass group, and click Mass Group tab ➤ Modify

panel ➤ Show Model Explorer  .

2 Use these basic navigation tools as needed:

■ To move the view in the drawing area, click  (Pan Realtime.)
Alternatively, right-click in the preview area, and click Pan.

3 To zoom in and out of the drawing area, click  (Zoom
Realtime.)

Alternatively, right-click in the preview area, and click Zoom. For
further Zoom options, right-click in the drawing area, click More,
and select the desired Zoom option.

4 To orbit the objects in 3D, click  (Constrained 3D Orbit.)
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Alternatively, right-click in the preview drawing area, and click
Orbit.

5 To move closer to or farther away from the object, click  (Adjust
Distance.)

This command works only when you are in perspective projection.

Alternatively, right-click in the preview drawing area, and click
More  ➤ Adjust Distance.

NOTE In embedded Object Viewers, only the context menu option
is available for all commands.

Navigating the View with the ViewCube
The ViewCube is a 3D navigation tool that appears when the 3D graphics
system is enabled and allows you to switch between standard and isometric
views.

In Object Viewers, the ViewCube is always visible. When you position the
cursor over the ViewCube, it becomes active. You can switch to one of the
available preset views, roll the current view, or change to the Home view of
the model.
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NOTE When you access the ViewCube from Style Manager or from an embedded
Object Viewer, no UCS option and no compass are available.

For detailed information about the ViewCube, see “ViewCube” in the AutoCAD
Help.

Navigating the View with SteeringWheels
SteeringWheels are tracking menus that are divided into different sections
known as wedges. Each wedge on a wheel represents a single navigation tool.
You can pan, zoom, or manipulate the current view of a model in different
ways.

SteeringWheels can save you time and clicks by combining many of the
common navigation tools into a single interface. Wheels are specific to the
context that a model is being viewed in.

NOTE SteeringWheels are not available in embedded Object Viewers.

1 Open the Object Viewer from one of these locations:

■ Select an object in the drawing area, and click <Object>

tab ➤ General panel ➤ Object Viewer  .
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■ Click Manage tab ➤ Style & Display panel ➤ Style Manager

 , and click the  button.

Alternatively, you can click the  button (Inline Edit Toggle)
to display the Object Viewer embedded inside Style Manager.

■ Select a mass group, and click Mass Group tab ➤ Modify

panel ➤ Show Model Explorer  .

2 Click the  button.

Alternatively, you can right-click in the preview area, and click
Steering Wheel.

3 To close the SteeringWheel, right-click, and click Close Wheel, or

click the  button again.

For detailed information, see “SteeringWheels” in the AutoCAD
Help.

Setting the View Direction of the Object Viewer to the Drawing
Area

You can set the view direction you have specified in the Object Viewer back
to the drawing area.

NOTE This command is available only for the Object Viewer when it is started
from an object in the drawing area.

1 Select an object in the drawing area, and click <Object>

tab ➤ General panel ➤ Object Viewer  .

2 Change the view direction as desired.

3 Click  .

Alternatively, you can right-click in the preview area, and click
Set View.
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Saving a Preview Image from the Object Viewer
You can save the view in the Object Viewer to a graphic file. File formats
supported are PNG, JPEG, BMP, and TIFF.

1 Open the Object Viewer from one of these locations:

■ Select an object in the drawing area, and click <Object>

tab ➤ General panel ➤ Object Viewer  .

■ Click Manage tab ➤ Style & Display panel ➤ Style Manager

 , and click the  button.

Alternatively, you can click the  button (Inline Edit Toggle)
to display the Object Viewer embedded inside Style Manager.

■ Select a mass group, and click Mass Group tab ➤ Modify

panel ➤ Show Model Explorer  .

2 Click  .

Alternatively, you can right-click in the preview area, and click
Save Image.

NOTE In embedded Object Viewers, only the context menu option
is available.

3 In the Save Image File dialog, enter a file name and select a file
format. Then, click Save.
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Napkin Sketch

Use Napkin Sketch to create freehand sketch geometry from objects in a drawing. You can
create a napkin sketch to reflect ambiguity in a work-in-progress design or to present a more
artistically pleasing version of a drawing. You can also generate a napkin sketch of a portion
of a drawing and designate it as still in the design stage.

Napkin Sketch
Use Napkin Sketch to create freehand sketch geometry from objects in a drawing.
You can create a napkin sketch to reflect ambiguity in a work-in-progress design
or to present a more artistically pleasing version of a drawing. You can also
generate a napkin sketch of a portion of a drawing and designate it as still in
the design stage.

You can create a napkin sketch from an entire drawing or from a portion of a
drawing. You can select both AutoCAD® and AEC objects to include in your
napkin sketch.

How Objects Appear in a Napkin Sketch

When you generate a napkin sketch, random bumpy line segments are created
along objects that you select to include in your sketch. The bumpy lines are
short segments that emulate the freehand strokes of a traditional sketch. Lines
where segments cross each other are extended in the napkin sketch.
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Generating a napkin sketch

Line Formats for Napkin Sketches

When you generate the napkin sketch, you choose from three line formats
that control the appearance of the sketch:

■ Tight line format: Traces the selected geometry once to create the
appearance of a more accurate sketch.

■ Loose line format: Traces the selected geometry twice. (This is the default
setting.)

■ Messy line format: Traces the selected geometry three times.

Line format options

Each pass at tracing the geometry adds more artistic flare to the sketch.

Managing Napkin Sketches

When you create a napkin sketch, the geometry is packaged in a named block
and placed on top of the original objects in model space. This means that you
can move the original drawing and the sketch drawing independently of each
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other. You can also edit the napkin sketch as you do with other referenced
blocks. Each sketch segment retains the layer and color of the geometry from
which it is generated.

Depending on the line format you select for the napkin sketch, up to three
complex polylines are generated for each selected object in your drawing. This
can significantly increase the drawing size. To keep your drawing size as small
as possible, cut and paste your napkin sketches into new drawings.

When you are working with three-dimensional (3D) drawings or complex
models, first create a hidden line projection, two-dimensional (2D) section,
or 2D elevation object. Unless your drawing is very simple, generating the
napkin sketch from these 2D objects saves linework and time.

When you are working with external references, double-click on the napkin
sketch and edit it like any other block. For more information about editing
external references, see “Edit Referenced Drawings” in the AutoCAD Help.

Napkin Sketch and Intended Plot Scale

You can specify the intended plot scale to control the size of the sketch
segments and extensions. Select a larger scale to increase the size of the sketch
segments and extensions in the final sketch.

Specifying a plot scale

Creating a Napkin Sketch
Use this procedure to produce a napkin sketch in a plan, isometric, or elevation
view. When you are working with three-dimensional (3D) drawings, unless
your drawing is very simple, generate the napkin sketch from a
two-dimensional (2D) hidden line projection, section, or elevation. For more
information, see Creating a Hidden Line Projection on page 3385, Sections on
page 3251, and Working With Elevations on page 3321.

1 Open a tool palette that contains a napkin sketch tool.
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A napkin sketch tool is located with the Helper Tools in the Stock
Tool catalog. For more information, see Content Browser Overview
on page 129.

2 Select a napkin sketch tool.

3 Select the objects to include in the napkin sketch, and press ENTER.

4 Enter a name for the block created of the napkin sketch.

5 Specify a line format for generating the napkin sketch geometry:

Then…If you want to…

select Tight.trace over objects once to create
the appearance of a more accurate
sketch

select Loose.trace over objects twice to create a
looser sketch

select Messy.trace over objects three times to
create a very loose sketch

6 Clear Extend Sketch Lines At Corners if you do not want the
extended lines to appear on the napkin sketch.

Extending sketch lines at corners

7 Under Intended Plot Scale, select the scale at which you intend
to plot the sketch, or select Other and enter a custom scale.

8 Click OK.

The napkin sketch geometry is generated and placed as a block
reference over the drawing objects that you selected. Use the Move
command to relocate the sketch block reference in the drawing,
or cut and paste it into a new drawing.
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Editing a Napkin Sketch
Use this procedure to edit the block reference generated when you create a
napkin sketch. For more information about editing external references, see
“Edit Selected Objects in Referenced Drawings and Blocks” in AutoCAD Help.

TIP The quickest way to locate and view an AutoCAD topic is to click the Search
tab in the Help window, select the Search titles only option, and then copy and
paste or type in the AutoCAD topic name, and click List Topics.

1 Select the napkin sketch that you want to edit, right-click, and
click Edit Block in-place.

The Reference Edit dialog box opens. For more information, see
“Reference Edit Dialog Box” in AutoCAD Help.

2 Select the reference to edit, if necessary.

3 Specify how nested objects in the napkin sketch are selected:

Then…If you want to…

select Automatically select all nested
objects.

make changes to the sketch lines or
any component of the object from
which the sketch was drawn

select Prompt to select nested ob-
jects.

work with specific nested objects
within a napkin sketch, such as a
hatch pattern

4 Specify lock settings for the napkin sketch:

Then…If you want to…

select the Settings tab, and clear
Lock objects not in working set.

allow changes to be made to ob-
jects other than those selected as
your working set

select the Settings tab, and select
Lock objects not in working set.

prevent changes from being made
to objects other than those selected
as your working set

For information about the Settings tab, see “Reference Edit Dialog
Box” in AutoCAD Help.

5 Click OK.
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The block reference that represents the napkin sketch is
highlighted in your drawing.

6 Make changes to the block reference as you would to any drawing
object.

7 Click Insert tab ➤ Edit Reference panel ➤ Save.

8 Click OK.
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General Object Tools

The following topics describe commands that are common for most object types.

The General Panel
The General panel on each object’s contextual tabs contains commands that
are common for most object types.

Selecting Similar Objects
You can select all objects in a drawing that have the same object type, style,
and layer as one or more preselected objects. If the objects selected are of
different types, the selection is based on shared properties.

For example, you can select all walls in the drawing that use the CMU-Rigid
style and are placed on the A-Walls layer.

NOTE Block references are selected based on their layer and block definition.
Style-based objects are selected on their style.

1 Select the object on which to base the preselection criteria.

2 Click <Object> tab ➤ General panel ➤ Select Similar  .

All objects that match the type, style, and layer of the object are
added to the selection set. You can now make changes to the
selection set, for example on the Properties palette.
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The Object Viewer
The Object Viewer lets you preview objects in your drawing with different
visual styles, view directions, and display configurations without changing
the display of the drawing area.

1 Select the object you want to display in Object Viewer.

2 Click <Object> tab  ➤ General panel ➤ Object Viewer  .

For more information, see Object Viewer on page 1111.

Isolating and Hiding Objects
You can create a temporary drawing view where only selected (isolated) objects
appear. When you are finished, you can dismiss the view, or save the drawing
in that view.

There are 2 basic ways of creating a view with only selected objects:

■ Select the objects to display: you can select (isolate) objects and display
only those

Isolate chair and cabinet

■ Hide objects: you can hide those objects that you do not want included
in the current view
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Hiding chair and cabinet

Isolating Objects
You can select (isolate) objects and create a temporary view that includes only
these objects.

1 Select the objects that you want to display, for example a wall.

2 Click <Object> tab ➤ General panel ➤ Isolate Objects

drop-down ➤ Isolate Objects  .

3 TIP You can also use the  icon in the drawing window status to

isolate objects. A red icon (  ) means that there are already objects
isolated.

4 If you need to refine the selection set, select the desired objects,
and click <Object> tab ➤ General panel ➤ Isolate Objects

drop-down ➤ Isolate Objects  again.

When you end the object isolation, as described in Ending the Object Isolation
View in a Drawing on page 1134, all objects are redisplayed.

Hiding Objects
You can temporarily hide objects in the drawing.

1 Select the objects that you want to hide.
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2 Click <Object> tab ➤ General panel ➤ Isolate Objects

drop-down ➤ Hide Objects  .

3 TIP You can also use the  icon in the drawing window status to

hide objects. A red icon (  ) means that there are already objects
hidden.

4 If you need to refine the selection set, select the desired objects,
and click <Object> tab ➤ General panel ➤ Isolate Objects

drop-down ➤ Hide Objects  again.

Ending the Object Isolation View in a Drawing
To redisplay all objects in the drawing, the object isolation view must be
dismissed.

Restoring all objects in a drawing

1 Select any object in the current view.

2 Click <Object> tab ➤ General panel ➤ Isolate Objects

drop-down ➤ End Isolation  .

TIP You can also use the  icon in the drawing window status to
end the object isolation view.

Saving Isolated Objects
You can save a drawing in which object isolation is currently active. The next
time you open the drawing, it displays with the isolation settings you defined.
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For example, you could save a specific view setting to distribute the file to a
contractor who needs to see only a specific part of the drawing. You could
also save a specific view setting in a drawing that is used as an external
reference within another drawing.

1 Isolate and hide objects as needed. (See Isolating Objects on page
1133 and Hiding Objects on page 1133).

2 Save the drawing with the current isolation setting.

NOTE If you want to distribute a drawing with isolated objects, make sure that
you and the recipient of the drawing are working with the same version of AutoCAD
Architecture. A recipient who is working with an earlier version of the software,
plain AutoCAD, or Object Enabler is not able to display the hidden objects. In this
case, end the object isolation before saving and distributing the drawing.

Isolating Objects in External References
When working in drawings with external references, note the following points:

■ You can isolate an external reference within a host drawing as a whole by
selecting it and isolating at as described in Isolating Objects on page 1133.

■ You can isolate individual objects within an external reference by opening
the external reference, isolating and hiding objects as needed, saving the
external reference drawing, and then reloading the external reference.

■ You cannot isolate or hide objects in an external reference while editing
it with REFEDIT in the host drawing. You need to use XOPEN and save
the desired Hide/Isolate settings within the external reference.

■ You cannot redisplay hidden objects in an external reference while editing
it with REFEDIT in the host drawing. You need to use XOPEN and save
the desired Hide/Isolate settings within the external reference.

Editing Objects in Temporary Views
You can specify a selection of objects in a drawing and view and edit them in
a temporary section, elevation, or plan view. The UCS will be aligned to the
temporary view while you are editing it.

For example, if you are working in a design with an angled wall and want to
add a body modifier in an elevation view, you can switch to a temporary
elevation, add the detail, and exit the elevation. You are returned to your
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working view, and you must save any modifications at this point. You could
also use to look at the endcaps of a wall opening in a temporary section view
or add a section line through objects at an angle.

The following high-level steps are necessary to view and edit an object in a
temporary view:

■ Select objects

■ Generate temporary section, elevation, or plan view

■ (Optional) Edit objects in view

■ Dismiss temporary view

■ (Optional) Save changes to objects

Selecting objects for temporary view

Editing Objects in a Temporary Section View
You can select objects to view and edit in a temporary section view. The section
view is not persisted after the edits are finished.

1 Select the objects you want to view in a section view.
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2 Click <Object> tab ➤ General panel ➤ Edit In View

drop-down ➤ Edit In Section  .

3 Specify the first and second points for the section line or press
ENTER to change the UCS.

4 Specify the extent of the section.

5 Modify the objects in the section view.

6 Click  on the Edit in View toolbar to exit the temporary
section.

7 Save the changes to your drawing.

Editing Objects in a Temporary Elevation View
You can select objects to view and edit in a temporary elevation view. The
elevation view is not persisted after the edits are finished.

1 Select the objects you want to view in an elevation view.

2 Click <Object> tab ➤ General panel ➤ Edit In View

drop-down ➤ Edit In Elevation  .

3 Select linework, the face of an object, or a reference point for the
view direction.

4 Specify the extents of the elevation.

5 Modify the objects in the elevation view.

6 Click  on the Edit in View toolbar to exit the temporary
elevation.

7 Save the changes to your drawing.

Editing Objects in a Temporary Plan View
You can select objects to view and edit in a temporary plan view. The plan
view is not persisted after the edits are finished.

1 Select the objects you want to view in a temporary plan view.

2 Click <Object> tab ➤ General panel ➤ Edit In View

drop-down ➤ Edit In Plan  .
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3 Select linework, the face of an object, or a reference point for the
view direction.

4 Modify the objects in the plan view.

5 Click  on the Edit in View toolbar to exit the temporary
plan.

6 Save the changes to your drawing.

Adding Objects of the Same Type as the Selected Object
When you have an object in the drawing, you can select it and create new
objects of the same type based on the selection. This saves you the time needed
for navigating to the tools palette, and re-selecting the correct tool.

1 Select the object of which you want more instances.

2 Click <Object> tab ➤ General panel ➤ Add Selected  .

3 Proceed to create new objects of the same type.

Editing Object Styles
When you have selected an object the contextual tab gives you access to
editing the style of the object.

Editing the style of the selected object

1 Select the object.

2 Click <Object> tab ➤ General panel ➤ Edit Style.

The style properties of the selected object are displayed. You can edit
them as necessary.

The ribbon also lets you access other styles of the same type.

Editing other styles of the same type

1 Select the object.

2 Click <Object> tab ➤ General panel ➤ Edit Style drop-down ➤ <Object>
Styles.
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This opens Style Manager with only styles for that object type displayed,
for example, only wall styles or door styles. You can edit them as
necessary.

Depending on the object you have selected, you may be able to access not
only styles for that object, but also styles of objects that act as supporting
objects. For example, when you have selected a space, you can access space
styles, zone styles, zone templates, and display theme styles.

Accessing supporting style types from the ribbon

1 Select the object.

2 Click <Object> tab ➤ General panel ➤ Edit Style drop-down, and select
the desired style type.

Copying and Assigning an Object Style
The General panel of the contextual tab of an object lets you create a copy of
the currently used style and assign that to the object.

1 Select the object for which you want to create a new style.

2 Click <Object> tab  ➤ General panel ➤ Copy Style  .

For more information, see Creating a Style from an Object on page 875.

Dimensioning an Object
From the contextual tab of an object, you can add an AEC dimension to the
object.
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1 Select the object you want to dimension.

2 Click <Object> tab ➤ General panel ➤ Dimension  .

For more information, see AEC Dimensions on page 3387.

Tagging an Object
For some objects, you can add a tag from their contextual tab.

NOTE More tags are available under Annotate tab ➤ Scheduling panel, on the
Tags tool palette, and in Content Browser.

1 Select the object you want to tag.

2 Click <Object> tab ➤ General panel ➤ Tag  .

For more information about tagging objects, see Schedule Tags
on page 3754.

Editing Object Components In Place
Edit in place is a special editing mode where polyline- or profile based object
components can be edited directly on screen, while other editing capabilities
in the drawing are limited. For example when you are in edit-in place mode,
you can change a wall endcap, but you cannot save and close the drawing.
Upon exiting the edit-in-place mode you can choose if the changes should
be discarded, overwrite the existing component definition, or be saved as a
new definition.

When you enter the edit-in-place mode, a temporary profile is drawn around
the object or component being edited.

In-place edit profile of extruded mass element
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The edit-in-place mode is characterized by the following user interface changes:

■ On the ribbon, the contextual Edit in Place tab for the selected component
is displayed.

Edit in Place tab for Wall Endcaps

■ Right-clicking an editable object component displays a context menu that
has commands for editing the component, and for exiting the edit in place
mode.

■ Editable object components are displayed with a different color and
hatching. You can change the display of the components by changing the
color, lineweight, and hatching. For more information, see Changing the
Display of Object Components in Edit-in-Place Mode on page 1146.

■ A number of commands, like closing or saving the drawing are deactivated
while the edit-in-place mode is active. In order to access them, you must
exit the edit-in-place mode first.

Sometimes, multiple edit-in-place entities are created in a single session. This
is the case for walls that have multiple sweeps or modifiers, or for roof slabs
and slabs that have both a fascia and a soffit profile. You can make changes
to all of them during the session. When you exit the edit-in-place mode, all
of the changes are either saved or discarded.
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Editing Polyline-based Components in Place
The following objects in AutoCAD Architecture can have custom components
based on polylines:

■ Walls: wall endcaps and opening endcaps

■ Wall/curtain walls: roof and floor lines

■ Walls: plan modifiers

Polyline-based components of an object can be edited in place. During the
edit-in-place session, the selected polyline is isolated for editing so that you
can perform changes on its shape, such as grip-editing or adding and removing
vertex points.

Viewing Edit in Place wall endcap grips

You can modify the polyline-based components of a wall either in
two-dimensional (2D) plan views or in three-dimensional (3D) model views.

When you edit a component in a 3D view, the UCS is aligned to the
component, so that you can easily add or remove vertices and grip-edit the
component.

The commands for editing polyline-based objects vary, depending on the
component type. For example, a wall endcap has commands for adding and
removing vertices and hiding and replacing endcap components; a wall roof
line or floor line has commands for adding gables and steps and projecting
the roof and floor lines to a polyline. For instructions on how to assign and
edit a polyline-based object component in place, see the following locations:

■ Working with Wall Endcaps and Opening Endcaps on page 1373

■ Working with Wall Modifiers on page 1268
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■ Editing the Roof Line or the Floor Line of a Wall on page 1229

■ Editing the Roof Line or the Floor Line of a Curtain Wall on page 1560

Editing Profile-based Object Components in Place
You can edit profile-based objects and object components in place. You can
change the shape of the profile, add and remove rings and, for some profiles,
move the insertion point.

The following objects are either profile-based or can have profile-based
components that can be edited in place:

■ extruded mass elements

■ revolution mass elements

■ slab and roof slab edges (fascia and soffits)

■ door frames

■ window frames

■ opening frames

■ door/window muntins

■ railing guardrails, handrails, bottom rails, and posts

■ curtain wall/curtain wall unit frames and mullions

■ door/window assembly frames and mullions

■ wall sweeps

NOTE The edit-in-place feature for the objects in the list is available only if one
or more components of the object are based on profiles.

Example 1: profile based curtain wall frames
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Example 2: mass element extruded from a profile

Example 3: profile-based roof slab fascia and soffit

For instructions for editing profiles in place, see Editing a Profile In Place on
page 2860.

Editing in Place: Special Cases
There are a number of special cases where you can use the edit-in-place mode.

3D Wall Body Modifiers

You can add a 3D modifier to a wall body, and then edit it in place. Body
modifiers use the 3-dimensional (3D) geometry of an object, such as a mass
element or a mass group, to add to, subtract from, or completely replace one
component in a wall.

While you edit the body modifier in place, you can change the modifier shape
with grips and use Boolean commands to add or remove other objects from
the body modifier.
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Editing a body modifier in place

For instructions on adding and editing a body modifier, see Working with
Body Modifiers on page 1284.

Editing Material Hatches in Place

You can make changes to the surface hatch of an object with the edit-in-place
mode, if the surface hatch is coming from a material. Unlike the other
edit-in-place modes, you do not change the shape of an object but the display
of the hatch on a specific object face.
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Changing the hatch rotation with in-place editing

For detailed instructions, see Overriding the Surface Hatch on Individual
Objects on page 909.

Changing the Display of Object Components in Edit-in-Place
Mode

When you enter the edit-in-place session, a temporary profile is created that
allows you to edit a polyline or profile-based component of an object. That
profile has different sub-components of which you can change the display.
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Changing the edge and boundary properties

1 Enter an edit-in-place session, as described in Editing a Profile In
Place on page 2860, Working with Body Modifiers on page 1284 and
Overriding the Surface Hatch on Individual Objects on page 909.

2 Select the temporary profile, right-click, and click Edit Object
Display.

3 Depending on whether the display changes should be valid for
all edit-in-place profiles in the drawing, or only the selected
profile, choose one of these options:

■ To make display changes globally in the drawing for all
profiles, verify that Drawing Default is selected for Display
Property source, and that the Object override check box is not
selected.

■ To make changes only to the currently selected profile, select
the Object Override check box.

4 Click  .

5 On the Layer/Color/Linetype tab, change the properties of the
following components:

■ Entity: this component controls the display of the object on
which you edit a component in place. For example, if you edit
a wall endcap in place, this display component controls the
wall boundary.

■ Hatch: this display component controls the
layer/color/linetype properties of the hatch of the temporary
profile. This is independent on any hatches assigned to the
object itself, and will be displayed only in edit-in-place mode.
By default this component is turned off.

■ Modifiable edge: this display component controls the display
of the active edges of the profile that can be modified.

■ Hidden Edge: controls the display of object edges that are
hidden from view. When you hide an edge, and exit the
edit-in-place mode, it will not be displayed. When you are in
the edit-in-place mode it is displayed as a red line.
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Changing the color of edit in place grips

1 Click  ➤ Options.

2 Click the AEC Editor tab.

3 Under Unselected Grip Colors, change the color for Style to the
desired color.

AEC Object Constraints
In AutoCAD Architecture, dimensional and geometric constraints can be
applied to AEC objects when you are working in a 2D plan view. AEC object
constraints are enhanced versions of the AutoCAD constraints, providing you
with additional functionality in the interaction between AEC objects. In
general, AEC object constraints support initial object entity selection rather
than point selection.

The following AEC objects support constraints:

■ Walls

■ Column grids

■ Columns

■ Beams

■ Curtain walls

■ Mass elements

■ Multi-view blocks

Examples of the use of constraints for AEC objects include constraining exterior
walls to a column grid using Fix and Horizontal constraints, aligning the
centerline of a curtain wall with a column grid using the Aligned constraint,
and anchoring 2 column grids together with the Coincident constraint.

The following AEC object constraints can be applied to the appropriate AEC
objects:

Dimensional ConstraintsGeometric Constraints

AlignedCoincident
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Dimensional ConstraintsGeometric Constraints

AngularVertical

RadialCollinear

DistanceHorizontal

DiameterFix

Parallel

Perpendicular

Concentric

Symmetric

Tangent

Equal

Smooth

All of the AutoCAD constraints are supported by the appropriate AEC objects,
but the AUTOCONSTRAINT and Infer Constraints features are not.

With a grip selected or when you specify options during an editing command,
tap the Shift key to alternate between relaxing constraints and maintaining
constraints.

When you select one of the AEC objects that support constraints, the
Parametric panel on the contextual ribbon tab displays the constraints available
for the selected object.

Parametric panel

NOTE Constraints that have a limited application to the selected AEC object do
not display on the Parametric panel.
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Different AEC objects have different selection options when working with
AEC object constraints. The Coincident and Fix constraints are point
constraints only, but the other AEC object constraints allow you to select
various object entities to constrain.

For example, you can pick

■ either edge or the centerline of a wall segment to constrain.

■ the object edge, X or Y axis, or bounding box edge of a mass element to
constrain.

■ the object edge, centroid, or bounding box edge of a structural member
to constrain.

As you select the AEC object to constrain, press TAB to cycle through your
options. Valid selectable object entities are highlighted with a red line.

Working with the Coincident constraint

The Coincident constraint constrains 2 points to coincide. The constrained
points can lie directly on an AEC object, or the extension of an AEC object.
The Coincident constraint also works between appropriate AEC objects and
AutoCAD objects, such as a wall segment and a line.

Use a Coincident constraint to anchor 2 column grids together.

1 Select a column grid.

2 Click Column Grid tab ➤ Parametric panel ➤ Coincident  .

3 Select a corner point on the first column grid to constrain.

The selected point is shown with a red circle and X through its
center.
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4 Select a corresponding corner point on the second column grid
to constrain.

When you move one of the column grids, the other one moves
with it. You can also rotate one of the column grids about the
Coincident constraint point. To fully constrain both grids, add
another Coincident constraint to the other column grid corner.

Working with the Vertical Constraint

The Vertical constraint constrains lines or pairs of points on AEC objects to
lie parallel to the Y-axis of the current UCS. When you specify 2 points to
vertically constrain, the second point is made vertical to the first point.

Use a Vertical constraint to realign a curtain wall segment vertically.

1 Select the curtain wall segment.
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2 Click Curtain Wall tab ➤ Parametric panel ➤ Vertical  .

3 Specify a point on the curtain wall segment near the end that you
want to remain fixed.

The curtain wall segment end closest to the specified point
becomes the pivot point.

Working with the Collinear Constraint

The Collinear constraint aligns one AEC object with another. The second
selected AEC object is made collinear with the first selected AEC object. You
can align edges or centerlines of AEC objects as necessary. The Collinear
constraint also works between appropriate AEC objects and AutoCAD objects,
such as a column grid and a line.

Use a Collinear constraint to align the centerline of a wall with a column grid
line.

1 Select the column grid.

2 Click Column Grid tab ➤ Parametric panel ➤ Collinear  .

3 Hover your cursor over the column grid line.

The grid line is highlighted with a red line.

4 Select the red grid line.

5 Hover your cursor over the edge of the wall segment.

The wall segment edge is highlighted with a red line.
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6 Press TAB to highlight the wall centerline.

The wall segment centerline is highlighted with a red line.

7 Select the wall segment.

Use a Collinear constraint to align the edge of a mass element with the edge
of a wall segment.

1 Select the mass element.

2 Click Mass Element tab ➤ Parametric panel ➤ Collinear  .

3 Hover your cursor over the edge of the mass element.

The top edge of the mass element is highlighted with a red line.

4 Press TAB to highlight the mass element X and Y axes.

The X axis is highlighted with a red line.

5 Press TAB to highlight the mass element bounding box.

The right bounding box line is highlighted with a red line.
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6 Select the top bounding box line of the mass element.

7 Select the bottom edge of the wall segment.

Working with the Horizontal Constraint

The Horizontal constraint constrains lines or pairs of points on AEC objects
to lie parallel to the X-axis of the current UCS. When you specify 2 points to
horizontally constrain, the second point is made horizontal to the first point.

Use a Horizontal constraint to realign a wall segment horizontally.

1 Select the wall segment.

2 Click Wall tab ➤ Parametric panel ➤ Horizontal  .

3 Specify a point on the wall segment near the end that you want
to remain fixed.
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The wall segment end closest to the specified point becomes the
pivot point.

Working with the Fix Constraint

The Fix constraint is a point constraint that maintains the position of an AEC
object in your drawing.

Use a Fix constraint to maintain the position of a structural member.

1 Select the column.

2 Click Structural Member tab ➤ Parametric panel ➤ Fix  .

3 Select the column to constrain.

The column is fixed in place and cannot be moved or rotated.

Working with the Aligned Constraint

The Aligned constraint maintains the distance between 2 parallel elements
on 2 different AEC objects.

Use an Aligned constraint to maintain a specific distance between a wall
segment and a multi-view block.

1 Select the multi-view block.

2 Click Multi-View Block tab ➤ Parametric panel ➤ Aligned  .

3 Select the edge of the multi-view block.

4 Select the edge of the wall segment.

5 Specify the dimension location.
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6 Enter a new dimension value.

When you move either AEC object, the specified distance between
them is maintained.

Working with the Angular Constraint

The Angular constraint maintains a specific angle between 2 AEC objects. The
Angular constraint also works between appropriate AEC objects and AutoCAD
objects, such as a wall segment and a line.

Use an Angular constraint to maintain an angle between 2 attached wall
segments.
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1 Select the wall segment.

2 Click Wall tab ➤ Parametric panel ➤ Angular  .

3 Select the first wall segment edge as the angle baseline.

4 Select the second wall segment edge to constrain.

5 Specify an angle location.

6 Enter a new angle value.

When you move either AEC object, the specified angle between
them is maintained.
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Working with the Radial Constraint

The Radial constraint maintains a specific radius of an AEC object. The Radial
constraint also works between appropriate AEC objects and AutoCAD objects,
such as a wall segment and a line.

Use a Radial constraint to maintain the radius of an arc wall segment.

1 Select the arc wall segment.

2 Click Wall tab ➤ Parametric panel ➤ Radial  .

3 Select the arc wall segment edge.

4 Specify the radius location.

5 Enter a new radius value.
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Walls

A wall is an AEC object that represents the real-world features of an interior or exterior wall.
The wall object contains all the geometry needed to represent a wall in 2-dimensional (2D)
and 3-dimensional (3D) views.

Walls are the basic components of any building plan. You can create very simple wall types
that rely on standard settings, and add them on the fly. You can also create complex walls
with different components, materials, and 2D and 3D endcaps assigned, have detailed cleanup
information, and contain interferences with other objects like mass elements.
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A wall has one or more components, which are the materials used to construct the wall.
Some components include brick, CMU, concrete, studs, air gaps, and insulation. The
components of walls can also have modifiers, which change the shape of the component
or its surface.

Wall styles control the appearance of wall objects. Using wall styles, you can specify
components, endcaps, materials, and other characteristics to create new types of walls, such
as concrete walls, masonry walls, and brick cavity walls. Catalogs provided with AutoCAD
Architecture include sample wall styles for common wall types, such as concrete walls with
footings or furring, CMU and brick cavity walls, and various stud partition walls.

You can also work with casework wall styles that include counters, base units, and upper
units.

When you add a wall to a drawing, you select a wall tool and then specify the points that
define each wall segment. A wall can have both straight and curved segments.
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Wall direction is significant for some modifications to walls. Sample wall styles provided
with AutoCAD Architecture were created with the intent that you place perimeter walls in
clockwise fashion. After placing a wall, you can determine the wall direction by selecting
the wall. The wall direction grip indicates the wall direction. You can also reverse the
direction of a wall.

When you add doors, windows, door/window assemblies, and openings to a wall, the wall
automatically adjusts to accommodate the object and adds endcaps where needed. By default,
these objects are anchored to the wall and remain with the wall if you move it. If you remove
an object from a wall, the wall repairs itself in the space where the object was located.

Workflow for Adding Walls

Use a wall tool on page 87 to add a wall or to
convert linework on page 1173 (lines, arcs, circles,
or polylines) to walls.

-----Add walls to the drawing
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Fix wall intersections that did not clean up on
page 1323 properly.

-----
Identify any wall intersections that
do not join correctly

Toggle the wall justification line to display on
page 1333 the justification line graphics and the

-----Determine the wall justification cleanup radius circle when cleanup radius override
is present. Changing  on page 1207the justification
of an existing wall moves the wall and can affect
how the wall cleans up with other walls.

Select the wall to see the wall direction grip on
page 1191. Wall direction is significant for some
modifications on page 1222 to walls.

-----Verify the wall direction

Move a wall based on an offset on page 1209 or
add copies on page 1207 of a wall by offsetting
them a distance from an existing wall component.

-----Offset the wall

Add a special condition on page 1255, such as a
sweep, modifier, or interference to the wall.

-----Customize the wall

Specify how the wall displays on page 1316.-----Display the wall
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Drawing Walls
Draw straight or arc wall segments, change the orientation or justification of
a wall segment while you are drawing it, or reposition a wall segment based
on an offset from a wall component.

To Draw a Straight Wall Segment

1 Select a wall tool.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Wall

drop-down ➤ Wall  .

2 Specify the wall segment start point.

3 Specify the wall segment endpoint.

To Draw an Arc Wall Segment

1 Select a wall tool.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Wall

drop-down ➤ Wall  .

2 Specify the wall segment start point.

3 On the command line, enter A for Arc.

4 Specify the wall segment midpoint.
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NOTE If you have Dynamic Input activated on the application window
status bar (DYN), you can use dynamic dimensions to specify the wall
length and angle. After clicking the start point of the wall, dynamic
input fields for wall length and wall angle appear around the wall
preview. Enter values as desired, and use the TAB key to switch
between input fields.

5 Specify the wall segment endpoint.

To Change the Wall Orientation

1 Select a wall tool.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Wall

drop-down ➤ Wall  .

2 Specify the wall segment start point.

3 Press CTRL to flip the wall segment orientation.
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4 Specify the wall segment endpoint.

To Change the Wall Justification

You can either enter J on the command line to initiate switching the
justification, or you can press CTRL to cycle between the justification options.

1 Select a wall tool.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Wall

drop-down ➤ Wall  .

2 Specify the wall segment start point.

3 On the command line, enter J for Justification, then do the
following:

Then, on the command line...If you want to switch the justific-
ation to...

...enter J, then enter L.Left

...enter J, then enter CCenter

...enter J, then enter RRight

...enter J, then enter BBaseline
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4 Specify the wall segment endpoint.
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You can also press SHIFT to cycle between the justification options.

To Reposition a Wall Segment

Reposition a wall segment while you are drawing it by specifying an offset
based on a wall component’s face or center, or the overall center of the wall.
When you specify the offset option and move your cursor over the wall
segment, assistant lines with a tooltip display to indicate which part of the
particular wall component is selected. A solid line indicates a component face,
a dashed line indicates a component center, and a center line indicates the
overall center of the wall.

Reposition a wall segment as you are drawing it to align a particular wall
component with a specific point or guideline. For example, you may wish to
align the outside face of a wall’s brick veneer with a column grid line or align
the inside face of a wall’s structural CMU with a column.

You can also pick any point inside or outside of the wall to specify as an offset
point for repositioning the wall. You can enter a value in the dynamic
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dimension box, or on the Properties palette, under Dimensions, enter a value
for Offset, and the wall will move the offset distance entered in the direction
from your cursor location to the current justification line.

1 Select a wall tool.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Wall

drop-down ➤ Wall  .

2 Specify the wall segment start point.

NOTE You may need to switch the wall segment orientation or
justification at this point to properly position it before specifying an
offset distance.

3 On the command line, enter O for Offset, or right-click and click
Offset.

As you move your cursor, assistant lines are displayed with
tooltips.

4 Click to select the wall component to offset from or specify a
point outside the wall segment.

The justification line shifts to accommodate the specified offset
distance.
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5 Specify the wall segment endpoint.

To Specify Wall Properties

Use wall properties to specify whether the walls you draw will be bounding
objects for associative spaces, the cleanup parameters, and dimensions.

1 Select a wall tool.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Wall

drop-down ➤ Wall  .

2 Specify the wall segment start point.

3 On the Properties palette, expand Basic, and expand General.

4 Select a wall style.

5 Under Bound Spaces, define if this wall can be used as a bounding
object for associative spaces.

You can select 3 options here:

■ Yes: this wall can be used as bounding object for associative
spaces.

■ No: this wall cannot be used as bounding object for associative
spaces.
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■ By style: this wall will use the bounding settings from the wall
style.

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

6 Select Yes for Cleanup Automatically if you want the wall to clean
up with other walls, and select a cleanup group.

7 Expand Dimensions.

8 Specify wall dimensions:

Then …If you want to …

enter a value for Width. If Width is
not available, the wall style you se-

specify the thickness of the wall

lected determines the width of the
wall.

enter a value for Base height.specify the height of the wall from
the floor to the ceiling

enter a value for Length.specify the length of the wall from
the start and endpoints

9 Specify the wall justification, which places the wall in relation to
the points you specify and the direction in which you draw the
wall:

Then …If you want to …

select Left for Justify.specify points that define the left
side of the wall

select Right for Justify.specify points that define the right
side of the wall

select Center for Justify.specify points that define the center
line of the wall

select Baseline for Justify.select points that define the
baseline of the wall
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10 Specify offsets:

Then …If you want to …

enter a value for Baseline offset.offset the location of the wall from
the points you specify

enter a value for Roof line offset
from base height.

offset the roof line from the spe-
cified base height

enter a value for Floor line offset
from baseline.

offset the floor line from the
baseline

11 Continue adding wall segments.

You can enter u (Undo) to undo any point except the start point.

12 Specify the endpoint of the wall:

Then …If you want to …

enter or (Ortho Close), and then
specify a point in the direction you

close the wall by drawing 2 wall
segments that meet the start point
at a right angle want the wall to close. The wall

segment is extended until it meets
a wall segment perpendicular to the
first wall segment.

enter c (Close).close the wall by adding a wall
segment from the previous point
to the start point of the wall

specify the endpoint of the wall,
and press ENTER.

complete the wall segment at a
point that you specify

For more information about Ortho Close and Close, see Using
Ortho Close and Close with Walls on page 1409.

To Draw a Wall Segment From a Wall Justification Line

Use this procedure to draw a new wall segment using any of the Object Snap
modes on an existing wall segment justification line. Start by specifying which
Osnaps you want to be active. For example, you may want to start a new wall
segment from the midpoint of an existing wall segment.

Once you start to add the new wall segment, the justification line is
automatically displayed on the existing wall segment, whether or not its
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display was turned on. If you move your cursor off of the existing wall segment,
the justification line will disappear. Selecting a point near the middle of the
wall segment will display the Midpoint Osnap on the justification line. Click
to specify this point as the new wall segment start point, and then specify the
wall segment endpoint.

1 On the command line, enter dsettings, and then click the Object
Snap tab.

2 Under General, select the object snap modes that you want to be
active.

3 Under AutoCAD Architecture, select Allow general object snap
settings to act upon wall justification line.

4 Select a wall tool.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Wall

drop-down ➤ Wall  .

5 On the existing wall segment, click the object snap on the
justification line from which you want to start the new wall
segment.

6 Specify the new wall segment endpoint.
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Creating Walls from Linework and 3D Objects
Use this procedure to convert any of the following objects to walls:

■ Lines

■ Arcs

■ Circles

■ Polylines

For example, you can create line diagrams or sketches of walls using lines,
arcs, circles, and polylines to create the building exterior and rooms, and
convert these objects to walls. You can edit the wall properties after creating
the wall.

You can also convert 3D objects, such as mass elements into walls.

To Convert a Line into a Wall

1 Right-click a wall tool, and click Apply Tool Properties
to ➤ Linework.

2 Select the line to convert, and press ENTER.

3 When prompted to erase the original geometry, press ENTER to
retain the linework, or enter y (Yes) to erase it.

4 Edit the properties of the new walls in the Properties palette, if
necessary.
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To Convert an Arc into a Wall

1 Right-click a wall tool, and click Apply Tool Properties
to ➤ Linework.

2 Select the arc to convert, and press ENTER.

3 When prompted to erase the original geometry, press ENTER to
retain the linework, or enter y (Yes) to erase it.

4 Edit the properties of the new walls in the Properties palette, if
necessary.

To Convert a Circle into a Wall

1 Right-click a wall tool, and click Apply Tool Properties
to ➤ Linework.

2 Select the circle to convert, and press ENTER.

3 When prompted to erase the original geometry, press ENTER to
retain the linework, or enter y (Yes) to erase it.
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4 Edit the properties of the new walls in the Properties palette, if
necessary.

To Convert a Polyline into a Wall

1 Right-click a wall tool, and click Apply Tool Properties
to ➤ Linework.

2 Select the polyline to convert, and press ENTER.

3 When prompted to erase the original geometry, press ENTER to
retain the linework, or enter y (Yes) to erase it.

Creating Walls from Linework and 3D Objects | 1175



4 Edit the properties of the new walls in the Properties palette, if
necessary.

To Convert a 3D Object into a Wall

Convert a 3D object, such as a mass element or an AutoCAD ACIS solid, into
a single-component wall.

1 Select the object you want to convert to a wall.

2 Click Mass Element tab ➤ Convert To panel ➤ Wall  .

3 Enter y (Yes) to erase the original object, or enter n (No) to retain
the object.

4 Specify the baseline of the wall:

Then …If you want to …

specify the start point, and then
specify the endpoint when promp-
ted.

specify the baseline of the wall by
specifying the start point and the
endpoint of the wall

enter p (Pick), and select the line or
the arc you want to define for the
baseline.

specify the baseline of the wall from
an existing line or arc in the draw-
ing
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NOTE Specifying a baseline away from the object you are converting
to a wall affects the insertion of anchored objects, such as doors,
windows, and openings. Anchored objects are inserted in a wall
relative to the baseline of the wall.

5 Select a wall style.

The wall style you select must be a single-component style.

Adding Doors and Windows to Walls
When you add doors and windows to a wall, the wall automatically adjusts
to accommodate the object and adds endcaps where needed.

Doors and windows can be added to walls in different ways. You can choose
to add a door or window unconstrained, you can space windows and doors
evenly along a wall, or you can use the points of an overlying column grid to
define the position of the door or window.
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Adding Unconstrained Doors and Windows
You can add a door or window to a wall by placing it freely on any wall point.

Inserting a window in a wall

Inserting a door in a wall

1 Select a wall.

2 Click Wall tab ➤ General panel ➤ Window  or click Wall

tab ➤ General panel ➤ Door  .

3 Specify the settings for the window or door.

For more information about adding windows or doors, see
Creating a Window with User-Specified Settings on page 1965 or
Creating a Door on page 1873.

4 Specify an insertion point along the wall.

TIP In order to have unconstrained placement, verify that the Position
on wall setting on the Properties palette is set to Unconstrained, and
verify that the OSNAP setting in the status bar is turned off.

5 Continue to place doors or windows in the wall, and press ENTER.
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Adding Doors and Windows Relative to Walls
You can place doors and windows precisely in relation to walls.

Inserting Doors and Windows Evenly on a Wall
You can insert multiple doors and windows evenly on a wall. The following
options can be set during insertion:

Fixed Number of Openings or Fixed Distance between Openings

■ Inserting a fixed number of doors or windows on a selected wall

■ Inserting a variable number of doors or windows at a specified distance
on a selected wall

Insertion on a Wall Segment or the Whole Wall

You can select if doors or windows are inserted along a wall segment (between
intersecting walls) or along the whole wall.

Inserting multiple doors evenly on a wall segment

Inserting multiple doors evenly on the full wall
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Insertion Offset from Wall Edges

You can select the wall edge from which the doors or windows should be
offset. Specify either in the inside or outside wall edges from which to offset
the doors or windows.

Distributing doors evenly on the wall inside

Distributing doors evenly on the wall outside

To insert a fixed number of doors or windows evenly on a wall

1 Select the wall on which you want to insert doors or windows.

2 Click one of these commands:

■ Click Wall tab ➤ General Panel ➤ Door drop-down ➤ Evenly
between Walls.

■ Click Wall tab ➤ General Panel ➤ Window
drop-down ➤ Evenly between Walls.

3 Define whether you want to insert doors or windows on a selected
wall segment or the complete wall:

■ To insert multiple doors or windows on a selected wall
segment, press B (Between Walls).

■ To insert multiple doors or windows along the entire length
of the wall, press W (Whole Wall).

4 Select the desired wall edge for placing the doors or windows by
clicking the edge onscreen.The red line serves as a preview. You
can choose between outer and inner edge.
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5 Verify that the Multiple Insert option on the Properties palette is
set to Yes.

6 On the Properties palette, enter the desired number of doors or
windows under Number to Insert.

By default the command assumes that the user wants to insert
doors or windows at an evenly spaced distance, and suggests a
range of the minimum and maximum possible doors or windows
that can be fit on the selected wall segment.

7 Verify that the Position Multiple option is set to Evenly.

8 Click onscreen to place the doors or windows.

To insert a variable number of doors or windows with a fixed distance on a
wall

1 Select the wall on which you want to insert doors or windows.

2 Click one of these commands:

■ Click Wall tab ➤ General Panel ➤ Door drop-down ➤ Evenly
between Walls.

■ Click Wall tab ➤ General Panel ➤ Window
drop-down ➤ Evenly between Walls.

3 Define whether you want to insert doors or windows on a selected
wall segment or the complete wall:

■ To insert multiple doors or windows on a selected wall
segment, press B (Between Walls).

■ To insert multiple doors or windows along the entire length
of the wall, press W (Whole Wall).

4 Select the desired wall edge for placing the doors or windows by
clicking the edge onscreen.The red line serves as a preview. You
can choose between outer and inner edge.

5 Verify that the Multiple Insert option on the Properties palette is
set to Yes.

6 On the Properties palette, select Offset under Spacing.

On the command line, the minimum to maximum offset values
are displayed. The minimum offset is 0 (no offset), the maximum
offset is calculated by the maximum distance possible between 2
doors or windows on the wall segment.

7 Enter the desired Offset value under Offset Multiples.
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The program automatically calculates the maximum number of
doors or windows that can be fit on the wall segment while
observing the offset and displays that number on the command
line. Do one of the following:

■ To insert the maximum number of doors or windows, press
ENTER, and click onscreen to place the doors or windows.

■ To place a smaller number of doors or windows while still
observing the offset, enter the desired number on the
command line and press ENTER. then click onscreen to place
the doors or windows. The doors or windows are centered on
the wall segment while keeping their offset to each other.

Inserting a Door or Window across the Length of a Wall
You can insert a door or a window that spans the entire length of a wall.

1 Select the wall on which you want to insert a door or window
across the entire length.

2 Click one of these commands:

■ Click Wall tab ➤ General Panel ➤ Door drop-down ➤ Entire
Wall.

■ Click Wall tab ➤ General Panel ➤ Window
drop-down ➤ Entire Wall.

3 Place the door or window.

TIP By default, the door or window is inserted with the last-used
door or window style. If you want to change the door or window
style, enter ST (Style), and type in the desired style name, change
the style after insertion in the Properties palette.

Adding Doors and Windows relative to column grids
You can add doors and windows on a wall relative to the lines of an overlaying
column grid.
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Placing Doors and Windows in Relation to a Grid Line
You can add doors and windows to a wall with a specified distance to a grid
line.

Adding multiple doors at specified distance to grid lines

1 Select the wall on which you want to insert doors or windows
relative to a grid line.

2 Click one of these commands:

■ Click Wall tab ➤ General Panel ➤ Door drop-down ➤ Offset
from Grid Line.

■ Click Wall tab ➤ General Panel ➤ Window
drop-down ➤ Offset from Grid Line.

3 Verify that the Relative to Grid setting on the Properties palette
under Location is set to Yes.

4 Verify that the Position setting on the Properties palette is set to
Offset.

5 Enter the desired offset from grid line under Automatic offset.

6 Place the doors or windows onscreen. The command calculates
the requested distance to the nearest grid line.
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7 Place as many doors or windows as you need and then press
ENTER.

Inserting Doors and Windows Centered between Grid Lines
You can insert a door or window in a wall at the center between two grid lines.

Inserting windows at the center between two grid lines

1 Select the wall on which you want to insert doors or windows
centered on a grid line.

2 Click one of these commands:

■ Click Wall tab ➤ General Panel ➤ Door drop-down ➤ Center
between Grid Lines.

■ Click Wall tab ➤ General Panel ➤ Window
drop-down ➤ Center between Grid Lines.

3 Verify that on the Properties palette the Relative to Grid setting
is set to Yes.

4 Verify that on the Properties palette the Position setting is set to
Center.
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NOTE If you set the Position setting to Center and the Relative to
Grid setting to None, the insertion behavior will be equivalent to the
legacy Position along wall=Center setting. The first door or window
will be placed on the center of the wall, and the next door or window
will be centered between the first one and the end of the wall.

5 Use the onscreen preview to place the door or window centered
between two grid lines.

6 Place as many doors or windows as you need and then press
ENTER.

Inserting Doors and Windows Evenly Between Grid Lines
You can insert a fixed number of doors or windows at equal distances between
two grid lines.

Inserting doors evenly spaced between grid lines

To insert a fixed number of doors or windows evenly on a grid line segment

1 Select the wall on which you want to insert doors or windows.

2 Click one of these commands:

■ Click Wall tab ➤ General Panel ➤ Door drop-down ➤ Evenly
between Grid Lines.

■ Click Wall tab ➤ General Panel ➤ Window
drop-down ➤ Evenly between Grid Lines.

3 Select a wall segment between two grid lines by clicking the
segment onscreen. The red line serves as a preview.
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4 Verify that the Multiple Insert option on the Properties palette is
set to Yes.

5 Enter the desired number of doors or windows under Number to
Insert.

By default the command assumes that the user wants to insert
doors or windows at an evenly spaced distance, and suggests a
range of the minimum and maximum possible doors or windows
that can be fit on the selected wall segment.

6 Verify that the Position Multiple option is set to Evenly.

7 Click onscreen to place the doors or windows.

To insert a variable number of doors or windows with a fixed distance on a
grid line segment

1 Select the wall on which you want to insert doors or windows.

2 Click one of these commands:

■ Click Wall tab ➤ General Panel ➤ Door drop-down ➤ Evenly
between Grid Lines.

■ Click Wall tab ➤ General Panel ➤ Window
drop-down ➤ Evenly between Grid Lines.

3 Select a wall segment between two grid lines by clicking the
segment onscreen. The red line serves as a preview.

4 Verify that the Multiple Insert option on the Properties palette is
set to Yes.

5 On the Properties palette, select Offset under Spacing.

On the command line, the minimum to maximum offset values
for the wall segment are displayed. The minimum offset is 0 (no
offset), the maximum offset is calculated by the maximum
distance possible between 2 doors or windows between two grid
lines.

6 Enter the desired Offset value under Offset Multiples.

The program automatically calculates the maximum number of
doors or windows that can be fit on the segment between the two
grid lines while observing the offset and displays that number on
the command line. Do one of the following:

■ To insert the maximum number of doors or windows on the
segment, press ENTER, and click onscreen to place the doors
or windows.
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■ To place a smaller number of doors or windows while still
observing the offset, enter the desired number on the
command line and press ENTER. then click onscreen to place
the doors or windows. The doors or windows are centered on
the segment between the two grid lines while keeping their
offset to each other.

Adding an Opening to a Wall
Use this procedure to place one or more openings in a wall.

Inserting an opening in a wall

1 Select a wall.

2 Click Home tab ➤ Build panel ➤ Door drop-down ➤ Opening
.

3 Specify the settings for the opening.

For more information about adding openings, see Creating an
Opening with User-Specified Settings on page 2062.

4 Specify an insertion point along the wall.

5 Continue to place openings in the wall, and press ENTER.

Adding a Door/Window Assembly to a Wall
Use this procedure to place one or more door/window assemblies in a wall.
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Inserting a door/window assembly in a wall

1 Select a wall.

2 Click Home tab ➤ Build panel ➤ Door

drop-down ➤ Door/Window Assembly  .

3 Specify the settings for the door/window assembly.

4 Specify an insertion point along the wall.

5 Continue to place door/window assemblies in the wall, and press
ENTER.

Removing Windows, Openings, Doors, or Door/Window
Assemblies from a Wall

Select the objects you want remove from the wall, and press DELETE. The wall
repairs itself where the objects were located.

Anchoring an Object to a Wall
Use this procedure to move objects to a different wall by anchoring the objects.

An anchored object is constrained by the wall. You can move the object along
the wall, but the object does not move from the wall unless you detach the
object. Objects anchored to walls follow connected wall segments.

The center of the bottom face of the object is anchored to the insertion point
on the bottom face of the wall, which is midway in the wall width.

NOTE By default, doors, openings, windows, and window assemblies are anchored
to the walls these objects are added to.
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1 Select the object to attach to the wall, and do one of the following:

Then …If the selected object is …

click Window tab ➤ Anchor pan-

el ➤ Set

a window

click Opening tab ➤ Anchor pan-

el ➤ Set

an opening

click Door tab ➤ Anchor pan-

el ➤ Set

a door

click Door/Window Assembly

tab ➤ Anchor panel ➤ Set

a door/window assembly

2 Select the wall to attach the object to.

Detaching Objects from a Wall
Use this procedure to detach an object that is anchored to a wall. When you
detach an object, the object is no longer constrained by the wall and can be
moved off the wall.

1 Select the object to release from the wall.

2 Do one of the following:

Then …If the selected object is …

click Window tab ➤ Anchor pan-

el ➤ Release  .

a window

click Opening tab ➤ Anchor pan-

el ➤ Release  .

an opening

click Door tab ➤ Anchor panel ➤ Re-

lease  .

a door
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Then …If the selected object is …

click Door/Window Assembly

tab ➤ Anchor panel ➤ Release
.

a door/window assembly

The object remains in place but is no longer constrained to the wall. The wall
no longer cleans up around the object.

Editing Walls
After placing walls, you can change its style, location, size, shape, basic
geometry, and override the component priorities and the endcap styles of the
wall. You can also move a wall, merge or join walls, reverse the direction of
a wall and change the shape of the roof line and the floor line of a wall. In
addition, you can modify walls using other objects as interference conditions
or body modifiers.

Depending on the type of editing you want to perform, various methods may
be available:

■ After selecting a wall, you can click any non-grip point along the perimeter
and drag the entire object to a new location. You can also move the object
by clicking a grip, pressing the Space bar, and then moving the object to
the new location and clicking again.

■ You can drag the grips that are displayed on a selected wall to reorient it,
resize it, or change other physical characteristics.

■ For grip edits where you are changing a dimension or an angle, the
Dynamic Input feature lets you enter a precise value instead of moving a
grip. (This feature is activated by default; you can toggle it on and off by
clicking DYN on the application status bar. For more information, see
Dynamic Dimensions on page 120.)

■ You can apply the properties of a wall tool to an existing wall or the
properties of a curtain wall tool, slab tool, or roof slab tool to an existing
wall.

■ You can change settings on the Properties palette.

■ You can use editing commands from the object’s context menu.
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Using Grips to Edit Walls
Various types of editing grips are displayed for a selected wall object. You can
drag these grips as needed to reposition or resize the object, or you can enter
precise distance or angle values using the Dynamic Input feature. When you
select a grip that has multiple functions, you can cycle among them by pressing
CTRL. For more information, see Dynamic Dimensions on page 120.

DescriptionGrip

Lets you change the length of a
straight wall segment

(Lengthen)

Lets you change the base height of
a straight wall segment

(Base Height)

Lets you change the width while
maintaining the baseline of a
straight wall segment

(Width)

Lets you change the width while
maintaining the opposite face of a
straight wall segment

(Width)

Lets you change the base height of
an arc wall segment

(Base Height)

Lets you change the 2nd Point of
an arc wall segment.

(2nd Point)

Lets you change the curve radius of
an arc wall segment.

(Curve Radius)

Lets you change the end angle of
an arc wall segment.

(End Angle)

Lets you reverse the direction of an
arc wall segment.

(Reverse Direc-
tion)

Lets you reverse the direction while
maintaining the baseline of an arc
wall segment.

(Reverse Direc-
tion)
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Viewing Wall Grips

The types of editing grips available for a selected wall depend on the view
direction and the wall style. Lengthen, Start, Location, Reverse Direction,
Width, and End grips are displayed in both plan and 3D isometric views. Base
Height grips are available only in 3D isometric views. Curve 2nd Point, Width,
and Curve Radius grips are displayed in both 2D and 3D views for curved
walls. Wall styles that have a fixed width do not display Width grips, while
wall styles that have a variable width do.

The following illustration shows the Lengthen, Width, and Base Height grips
that appear for a straight wall segment in 3D and 2D views.
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The following illustration shows the Start Angle, End Angle, Width, Curve
Radius, and Base Height grips that appear for a curved wall segment in 3D
and 2D views.
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The following illustration shows the Start, End, Reverse Direction, and Location
grips that appear for a straight wall segment in 3D and 2D views.
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The following illustration shows the Start, End, Reverse Direction, Curve 2nd
Point, and Location grips that appear for a curved wall segment in 3D and 2D
views.

The following illustration shows the Roof Start Line and Roof End Line grips
that appear for a straight wall segment in 3D and 2D views.
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The following illustration shows the Roof Start Line and Roof End Line grips
that appear for a curved wall segment in 3D and 2D views.

Changing the Location of a Wall

Use this procedure to relocate a wall by using the Location grip. There are 2
cases to consider when working with the location grip: parallel wall segments
and non-parallel wall segments.

When you are working with connected walls that are parallel, the Location
grip has 2 edit modes: Stretch (Parallel) and Move. The default mode is Stretch
(Parallel), and the direction of the stretch depends on the orientation of walls
connected to the selected wall. For example, if the walls at both ends of the
selected wall are parallel to each other, with the Stretch (Parallel) mode, the
move direction is limited to the direction of the parallel walls.

When you are working with a stand-alone wall segment or connected walls
that are not parallel, the Location grip has 2 edit modes: Stretch (Offset) and
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Move. In this case, the default mode is Stretch (Offset) and the stretch direction
is perpendicular to the direction of the selected wall.

In both cases, the Move location mode allows an unconstrained move of the
selected wall without maintaining adjacent wall connections. You can also
move a wall by changing its coordinates on the Properties palette.

The following illustration shows how to use the Location grip in Stretch
(Parallel) mode to move a connected parallel wall segment and maintain
adjacent wall connections.
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The following illustration shows how to use the Location grip in Move mode
to move a parallel wall segment without maintaining adjacent wall
connections.

1 Select the wall you want to relocate.

2 Select the Location grip.

The Stretch (Parallel) location mode is the default, or you can
press CTRL to toggle to the Move location mode.

3 Move the wall to the desired location and click once, or enter a
distance value and press ENTER.

When you use the Stretch (Parallel) location mode, wall
connections are maintained if the connecting walls use a zero
cleanup circle radius. The connected walls are trimmed, extended,
and reversed as necessary to maintain connections and the cleanup
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circle radius. Using the Move location mode results in
disconnected walls.

4 Press ESC, or right-click, and click Deselect All to deselect the wall
and turn off all grips.

Changing the Shape of a Wall
Use this procedure to change a straight wall to a curved wall, or to change a
curved wall to a straight wall. When you change a straight wall to a curved
wall, the software adds a Curve 2nd Point grip at the midpoint of the of the
wall segment. You can then use the grip to change the shape of the arc. For
more information about curved walls, see About Curved Walls on page 1410.

When you change a curved wall to a straight wall, the software creates a
straight segment between the start and endpoints of the curve. You can use
grips to adjust the length and location of the wall.

1 Select the walls you want to change, and double-click one of them.

2 On the Properties palette, expand Basic, and expand General.

3 Select Arc or Line for Segment type.

4 Select the Curve 2nd Point grip, and move it to adjust the radius
for a curved wall.

Changing the Shape of a Wall | 1199



To Change the Wall Width with Grips while Maintaining the Wall Justification
Line

If the wall width is defined in the wall style applied to the wall, you cannot
change the thickness of an individual wall.

1 Select the wall.

2 Select a Width grip, move the grip until the width value you want
is displayed, and click once.
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After selecting a grip, you can also enter a precise value to increase
or decrease the width of the wall. For more information, see
Dynamic Dimensions on page 120.
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To Change the Wall Width with Grips while Maintaining the Opposite Face
of the Wall

You can also change the wall width on the Properties palette. If the wall width
is defined in the wall style applied to the wall, you cannot change the thickness
of an individual wall.

1 Select the wall.

2 Select a Width grip and press CTRL to maintain the position of
the opposite face of the wall when you change the wall width.

3 Move the grip until the width value you want is displayed, and
click once.
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After selecting a grip, you can also enter a precise value to increase
or decrease the width of the wall. For more information, see
Dynamic Dimensions on page 120.
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To Change the Wall Base Height with Grips

The base height is the height of the wall from floor to ceiling. You can also
change the base height on the Properties palette.

1 Select the wall.

2 Select the Base Height grip, move the grip until the height value
you want is displayed, and click once.

After selecting the grip, you can also enter a precise value to
increase or decrease the base height of the wall.
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To Change the Wall Length with Grips

You can also change the length on the Properties palette.

1 Select the wall.

2 Select a Lengthen grip, move the grip until the length value you
want is displayed, and click once.
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After selecting the grip, you can also enter a precise value to
increase or decrease the length of the wall.
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To Change Wall Justification with Grips

Justification determines the location of the wall in relation to the direction
in which the wall was drawn and the points used to draw the wall. Changing
the justification of an existing wall moves the wall and can affect how the
wall cleans up with other walls. You can also change the justification on the
Properties palette.

Changing the Wall Justification
1 Select the wall.

2 Click Wall tab ➤ Cleanup panel ➤  ➤ Edit Justification  .

Six grips appear, with four indicating the justification options:
Left Right, Center, and Baseline. The gray grip identifies the
current justification. Start and End grips for the wall segment are
also displayed.

3 Select the grip that corresponds to the justification you want.

In the following illustration, the Baseline justification is current,
as indicated by the gray grip.

Wall justification grips

Offsetting New Walls from Existing Walls
Use this procedure to add copies of an existing wall that are offset from a
component of the wall at a distance that you specify.

This offset command allows you to copy walls by offsetting them a clear
distance from the face or center of a specific wall component, such as the stud
or the wall finish.

1 Select the wall you want to copy.

2 Click Wall tab ➤ Modify panel ➤ Offset drop-down ➤ Copy
.
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3 Specify the location of the offset point:

Then …If you want to …

move the cursor over the wall until
the face of the component you

offset the wall from the face of a
wall component

want is highlighted with a red line,
and click once.

press CTRL, and move the cursor
over the wall until the center of the

offset the wall from the center of a
wall component

component you want is high-
lighted. Click once.

4 Specify the offset distance.

5 Continue adding walls, each new wall offset from the face or
center of the wall you added before it.

You can specify a different offset distance each time you add
another wall.

Offset copying a wall segment from an existing wall segment component

6 Press ENTER.

1208 | Chapter 21    Walls



Repositioning a Wall
Use this procedure to move a wall by offsetting the wall from the center or
face of a wall component to a point or distance that you specify.

1 Select the wall you want to move.

2 Click Wall tab ➤ Modify panel ➤ Offset drop-down ➤ Move
.

3 Specify the location of the offset point:

Then …If you want to …

move the cursor over the wall until
the face of the component you

offset the wall from the face of a
wall component

want is highlighted with a red line,
and click once.

press CTRL, and move the cursor
over the wall until the center of the

offset the wall from the center of a
wall component

component you want is high-
lighted. Click once.

4 Specify the distance from the component face or center to its new
position.
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Offset moving a wall segment from its existing wall segment component

Adjusting the Position of Wall
Use this procedure to adjust the position of a wall by aligning or offsetting
the center or face of a wall component from a reference point that you specify.
For example, you can adjust the placement of a stud partition wall by defining
the distance from stud to stud on center.

1 Select the wall you want to move.

2 Click Wall tab ➤ Modify panel ➤ Offset drop-down ➤ Set From

 .
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3 Specify the location of the offset point:

Then …If you want to …

move the cursor over the wall until
the face of the component you

offset the wall from the face of a
wall component

want is highlighted with a red line,
and click once.

press CTRL, and move the cursor
over the wall until the center of the

offset the wall from the center of a
wall component

component you want is high-
lighted. Click once.

4 Specify the reference point to which you want to measure.

For example, if you want to move a wall so that its exterior face
is aligned with the exterior face of another wall, specify a point
on the face of the other wall.

5 Specify the new distance from the wall component face or center
to the reference point.

Enter 0 (zero) to align the selected wall with the reference point.

Applying Tool Properties to an Existing Wall
Use this procedure to modify one or more walls by applying the properties of
a wall tool. The properties include the wall style and any other settings
specified in the tool you select.

1 Open the tool palette that contains the wall tool you want to use.

(You may have to scroll to display the desired tool.)

2 Right-click the tool, and click Apply Tool Properties to ➤ Wall.

3 Select the walls to be modified, and press ENTER.

4 Edit the properties of the modified walls in the Properties palette,
if necessary.
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Applying a different wall tool and new property to an existing wall segment

Changing the Style of a Wall
Use this procedure to select a different wall style for one or more walls.

1 Select the walls to change, and double-click one of them.

2 Expand Basic, and expand General.

3 Select a different style.

Changing the style of a wall segment
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Changing the Location of a Wall
Use this procedure to relocate a wall by changing the coordinate values of its
insertion point. The wall also has an orientation with respect to the WCS or
the current UCS. For example, if the top and bottom of the wall are parallel
to the XY plane, its normal is parallel to the Z axis. You can change the
orientation of the wall by aligning its normal with another axis. You can also
rotate the wall on its plane by changing the rotation angle.

For information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use Coordinates and Coordinate Systems” in
AutoCAD Help.

1 Double-click the wall you want to change.

2 In the Properties palette, expand Basic, and expand Location.

3 Select Additional information.

4 Specify the location of the wall:

Then …If you want to …

enter new coordinate values under
Insertion Point.

relocate the wall

make the normal of the wall parallel
to the Z axis: under Normal, enter
1 for Z, and enter 0 for X and Y.

locate the wall on the XY plane

make the normal of the wall parallel
to the X axis: under Normal, enter
1 for X and enter 0 for Y and Z.

locate the wall on the YZ plane

make the normal of the wall parallel
to the Y axis: under Normal, enter
1 for Y, and enter 0 for X and Z.

locate the wall on the XZ plane

enter a new value for Rotation
Angle.

change the rotation of the wall

5 Click OK.
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Merging Walls
Use this procedure to merge the profile of selected walls. This does not provide
automatic wall cleanup, but merging walls is useful in tight situations that
involve short wall segments.

Merging wall segments

1 Select a wall to merge.

2 Click Wall tab ➤ Cleanup panel ➤  ➤ Add Wall Merge

Condition  .

3 Select other walls to merge with the first wall, and press ENTER.

TIP To identify merged walls, turn on the Diagnostic display
representation. Select a wall and click Wall tab ➤ Cleanup

panel ➤ Justification Display  . Select the wall to which you added
merge conditions. An arc connects the original wall to each wall it is
merged with.

Removing Individual Merge Conditions
Use this procedure to selectively remove merge conditions from a wall.

1 Select a wall.

2 Click Wall tab ➤ Cleanup panel ➤ Justification Display  .
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3 Select the wall that was selected first when the walls were merged.

An arc connects the wall to each wall merged with it.

4 Select the Remove Wall Merge Condition grip for the wall you
want to remove from the original wall.

The arc and grip are removed to indicate that a merge condition
with the wall no longer exists.

Removing All Merged Walls
Use this procedure to remove all merged wall conditions from a group of
merged walls.

TIP To identify merged walls, turn on the Diagnostic display representation. Select

a wall and click Wall tab ➤ Cleanup panel ➤ Justification Display  . Select the
wall to which you added merge conditions. An arc connects the original wall to
each wall it is merged with.

1 Select the wall that was selected first when the walls were merged.

2 Click Wall tab ➤ Cleanup panel ➤  ➤ Remove All Wall Merge

Conditions  .

If a message at the command line indicates that no merge
conditions were removed, the wall you selected was not the first
wall when the merge condition was created. You can press ENTER
to repeat the command, and then select a different wall.

Joining Walls
Use this procedure to combine the baselines of 2 walls to create one wall
segment. Walls that you join must meet the following requirements:

■ Linear walls must have collinear baselines and be touching at one endpoint.

■ Arc walls must have the same center, radius, and be touching at one end.

■ Walls must have the same style and width.

■ Walls must belong the same cleanup group.
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Joining walls also transfers all sub-objects and anchored objects from one wall
to the other. Sub-objects include roofline, floorline, anchors, wall modifiers,
wall style overrides, and interference conditions. Anchored objects include
doors, windows, and openings anchored to the walls.

NOTE Certain Collinear wall segments may appear to be already joined. However,
if they were drawn as 2 segments, they are actually separate segments and can
be highlighted as separate segments.

The following illustration shows joining 2 straight wall segments after first
highlighting each separate segment.

Joining 2 straight wall segments

The following illustration shows joining 2 curved wall segments after first
highlighting each separate segment.
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Joining 2 curved wall segments

1 Select the first wall.

2 Click Wall tab ➤ Cleanup panel ➤  ➤ Join  .

3 Select the second wall.

Filleting Walls
Use this procedure to fillet 2 walls. Filleting walls creates a curved wall segment
with a specified radius that is tangent to the baselines of the selected walls.

If you specify zero for the fillet radius, the walls are trimmed or extended until
they intersect, but no curved wall segment is created. Using a radius of zero
allows you to force odd-angled walls to meet. If you select parallel wall
segments, the fillet radius is ignored, and a curved wall segment is created
that is tangent to the baselines of the selected walls.

The following illustration shows how to fillet two wall segments with a zero
radius.
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Filleting wall segments with a zero radius

The following illustration shows how to fillet two wall segments with a
specified radius.

Filleting wall segments with a specified radius

Trim mode options allow you to specify whether the walls are trimmed or
extended to the new segment (trim option) or whether their endpoints remain
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unchanged (no trim option). If you select no trim, the fillet radius must be
greater than zero.

Before filleting walls, ensure that the following conditions exist:

■ The walls have the same style and baseline justification.

■ The fillet radius is not a negative value.

Solution tip icons may display when you fillet the walls if these conditions
are not met.

1 Open a tool palette that contains the Fillet tool.

The Fillet tool is located with the Drafting Tools in the Stock Tool
Catalog in the Content Browser. You can add this tool to any tool
palette, and then use the tool to fillet walls and other objects.

2 Select the Fillet tool.

3 Verify trim mode and radius settings:

Then …If you want to …

enter t (Trim), and then enter t
(Trim).

trim or extend wall segments to
meet each other or to meet the en-
dpoints of the resulting curved wall
segment

enter t (Trim), and then enter n (No
trim).

keep the endpoints of the wall seg-
ments in their original locations and
fit the curved wall segment
between them

enter r (Radius), and then enter a
value for the radius. Enter 0 for the

specify a new fillet radius

radius if you want the wall seg-
ments to meet each other without
creating a curved wall segment.

enter m (Multiple).fillet multiple walls

4 Select the first wall.

5 Select the second wall.
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Chamfering Walls
Use this procedure to chamfer 2 walls. Chamfering walls creates a new wall
segment between 2 walls that are not parallel. Chamfering is useful when you
are working with unique wall angles or architectural details.

You can chamfer walls by specifying distance or angle:

■ Using the distance option, you specify the length that each wall should
be trimmed or extended until it meets the new wall segment or the other
wall. If both chamfer distances are zero, the walls are extended until they
intersect, but a new wall segment is not created.

Chamfering wall segments using the distance option

■ Using the angle option, you specify the length of the chamfer and the
angle it forms with the first wall.

Trim mode options allow you to specify whether the walls are trimmed or
extended to the new wall segment (trim option) or whether their endpoints
remain unchanged (no trim option). If you select no trim, chamfer distances
must be greater than zero.

Before chamfering walls, ensure that the walls have the same style and baseline
justification. Solution tip icons may display when you chamfer the walls if
these settings are not the same for each wall.

1220 | Chapter 21    Walls



1 Open a tool palette that contains the Chamfer tool.

The Chamfer tool is located with the Drafting Tools in the Stock
Tool Catalog in the Content Browser. You can add this tool to
any tool palette, and then use the tool to chamfer walls and other
objects.

2 Select the Chamfer tool.

3 Specify default settings for chamfering walls:

Then …If you want to …

enter t (Trim), and then enter t
(Trim).

trim or extend wall segments to
meet each other or to meet the en-
dpoints of the new wall segment

enter t (Trim), and then enter n (No
trim).

keep the endpoints of the wall seg-
ments in their original locations and
fit the new wall segment between
them

enter a (Angle). Enter the distance
from the endpoint to the point on

specify the default length and angle
values for the angle option

the wall where you want the
chamfer to begin. Enter the angle
of the chamfer.

enter d (Distance). Enter values for
Distance 1 and Distance 2. Enter 0

specify the default distances for the
distance option

for both distances if you want the
walls to meet without creating a
new wall segment.

enter e (Method), and then enter
d (Distance).

specify the distance option as the
default option for chamfering walls

enter e (Method), and then enter
a (Angle).

specify the angle option as the de-
fault option for chamfering walls

enter m (Multiple).chamfer multiple walls

4 Select the first wall.

5 Select the second wall.
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Reversing the Direction of a Wall
Use this procedure to change the direction in which a wall is drawn by
reversing the start point and the endpoint of the wall. Walls are drawn from
the first specified point to the last point. Some commands and properties are
affected by that order. For example, you can add wall modifiers to the left or
right side of a wall. Left and right sides are west and east, respectively, when
a wall is drawn from south to north, regardless of how the wall is displayed
in the current view.

There are 2 different ways to reverse the wall direction. When you reverse a
wall in place, the wall position in the drawing does not change; only the wall
direction changes, and the wall justification line is switched in the drawing
but not in relation to the wall components. This method of reversing walls is
common when you create walls from scratch and do not want to change their
physical position in the drawing.

When you reverse the wall justification line, the wall position in the drawing
changes, but the baseline position in the drawing remains the same. You
would use this method when creating walls from polylines or spaces; in this
case the baseline position can be important geometry that you do not want
to change.

To determine the direction in which a wall was drawn, select the wall. The
Reverse Direction grip shows the orientation of the wall. For more information
about wall grips, see Using Grips to Edit Walls on page 1191.

To reverse the wall direction in place:

1 Select the wall.

2 Click Wall tab ➤ Modify panel ➤ Reverse drop-down ➤ Wall

Reverse  .

The outside faces of the wall remain in place, and the baseline
shifts, if necessary.
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Reversing a wall segment in place

To reverse the wall justification line:

1 Select the wall.

2 Click Wall tab ➤ Modify panel ➤ Reverse

drop-down ➤ WallReverseBaseline  .

The baseline remains in place, and the wall shifts, if necessary.

Reversing a wall segment about its baseline

Using AutoCAD Commands to Edit Walls
You can use the following standard AutoCAD commands to edit walls:

■ BREAK

■ EXTEND

■ TRIM

For more information about these commands, see AutoCAD Help.
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Changing the Roof Line and the Floor Line of a Wall
You can modify the roof and floor lines of a wall to create a non-rectangular
wall.

■ You edit vertex locations on the roof line to create steps, gables, and other
roof conditions.

Modifying the roof line of a wall

■ You edit vertex locations on the floor lines to create steps and other floor
conditions.

Modifying the floor line of a wall

You can also create non-rectangular roof and floor conditions by projecting
to polylines.

AutoCAD Architecture offers multiple methods of editing roof lines and floor
lines. You may want to begin by graphically creating a custom roof line or
floor line condition. You can then fine-tune that condition by specifying
precise values in the Roof/Floor Line worksheet on the Properties palette.

Offsetting or Projecting the Roof Line of a Wall
Use this procedure to change the height or the shape of the roof line of a wall:

■ Offset the roof line from the current height of the wall.
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■ Project the roof line of the wall to a polyline.

■ Project the roof line of the wall to another object, such as a roof or stairs.

You can also create a polyline that represents the current roof line of the
selected walls. You can then use this polyline to change the roof line of other
walls.

NOTE To project the roof line to a polyline, draw the polyline first in elevation
view. For best results, the polyline should be parallel to the wall. The polyline does
not need to be in the same plane as the wall.

1 Select a wall,

2 Click Wall tab ➤ Modify panel ➤ Roof/Floor Line

drop-down ➤ Modify Roof Line  .

3 Change the roof line of the wall:

Then …If you want to …

enter o (Offset), and enter an offset
distance. Enter a negative value to

offset the roof line from the current
height of the wall

project the roof line below the cur-
rent wall height.

enter p (Project), and select the
polyline.

project the roof line to a polyline

enter a (Auto-project), and select
the object to project to. When pro-

project the roof line to another ob-
ject, such as a roof or stairs

jecting to stairs, make sure that the
bottom riser or the stringer does
not create a zero-height segment
of wall.

enter g (Generate), and select the
walls for the polyline to be created
from.

generate a polyline of the current
roof line

enter r (Reset), and select the walls
to change.

remove any changes to the roof line

4 Press ENTER.
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Offsetting or Projecting the Floor Line of the Wall
Use this procedure to change the height or the shape of the floor line of a wall:

■ Offset the floor line from the current baseline of the wall.

■ Project the floor line of the wall to a polyline.

■ Project the floor line of the wall to another object, such as a floor slab or
stairs.

You can also create a polyline that represents the current floor line of the
selected walls. You can then use this polyline to change the floor line of other
walls.

NOTE To project the floor line to a polyline, draw the polyline first in elevation
view. For best results, the polyline should be parallel to the wall. The polyline does
not need to be in the same plane as the wall.

1 Select a wall.

2 Click Wall tab ➤ Modify panel ➤ Roof/Floor Line

drop-down ➤ Modify Floor Line  .

3 Change the floor line of the wall:

Then …If you want to …

enter o (Offset), and enter an offset
distance. Enter a negative value to

offset the floor line from the current
base line of the wall

project the floor line below the
current wall base line.

enter p (Project), and select the
polyline.

project the floor line to a polyline

enter a (Auto-project), and select
the object to project to. When pro-

project the floor line to another
object, such as a slab or stairs

jecting to stairs, make sure that the
bottom riser or the stringer does
not create a zero-height segment
of wall.

enter g (Generate), and select the
walls for the polyline to be created
from.

generate a polyline of the current
floor line
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Then …If you want to …

enter r (Reset), and select the walls
to change.

remove any changes to the floor
line

4 Press ENTER.

Adding a Gable to the Roof Line of a Wall
Use this procedure to add a gable to the roof line of a wall. You can also add
a gable on the Roof/Floor Line worksheet on the Properties palette.

NOTE This option is available only if the roof line has not been edited. After the
roof line changes, you cannot add a gable using this option. To add a gable to a
roof line that has been edited, see Changing Vertices in the Roof Line or Floor Line
of a Wall on page 1234.

1 Select the wall.

2 Click Wall tab ➤ Modify panel ➤ Roof/Floor Line

drop-down ➤ Edit In Place  .

A temporary profile is created for you to edit the geometry of the
Roof line.

3 Click Edit In Place tab ➤ Profile panel ➤ Add Gable  .

If Add Gable is not available, the roof line was previously edited.

4 Select the roof line.

Modifying a wall roof line by adding a gable

A third vertex is added to the roof line halfway between the 2
ends of the roof line and 8'-0'' up from the roof line.

5 Continue editing the roof line or the floor line, if needed.
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For more information, see Editing the Roof Line or the Floor Line
of a Wall on page 1229.

6 Save or discard the changes:

Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the roof line to its previous
shape

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  .

save the changes to the roof line

Adding a Step to the Roof Line or Floor Line of a Wall
Use this procedure to add a step to the roof line or the floor line of a wall. You
can also add a step on the Roof/Floor Line worksheet on the Properties palette.

NOTE This option is available only when the roof line or the floor line has not
been edited. After the line has been changed, you cannot automatically add a
step using this option. To add a step to a roof line or a floor line that has been
edited, see Changing Vertices in the Roof Line or Floor Line of a Wall on page 1234.

1 Select the wall.

2 Click Wall tab ➤ Modify panel ➤ Roof/Floor Line

drop-down ➤ Edit In Place  .

A temporary profile is created for you to edit the geometry of the
roof line or the floor line.

3 Click Edit In Place tab ➤ Profile panel ➤ Add Step  .

If Add Step is not available, the roof line or the floor line was
previously edited.

4 Select the roof line or the floor line.
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Modifying a wall floor line by adding a step

A third vertex is added to the line halfway between the 2 ends of
the line and 4'-0'' from the line. A step is created from the selected
vertex to the second vertex.

5 Continue editing the roof line or the floor line, if needed.

For more information, see Editing the Roof Line or the Floor Line
of a Wall on page 1229.

6 Save or discard the changes:

Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the roof line or the floor line
to its previous shape

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  .

save the changes to the roof line or
the floor line

Editing the Roof Line or the Floor Line of a Wall
Use this procedure to edit the geometry of the roof line or the floor line of a
wall:

■ Add, modify, or remove gables.

■ Add, modify, or remove steps.

■ Project the roof line or the floor line to a polyline or to other objects, such
as roofs, roof slabs, slabs, and stairs.

■ Create custom roof line or floor line conditions by adding and adjusting
vertices and edges.
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■ Reverse the roof line or the floor line of the wall without reversing the wall
itself.

■ Remove all changes to the roof line or the floor line of a wall.

You can also edit the roof line and the floor line on the Roof/Floor Line
worksheet on the Properties palette. For more information, see Changing
Vertices in the Roof Line or Floor Line of a Wall on page 1234.

Viewing Edit In Place Wall Elevation Grips

NOTE If you want to project the roof line or the floor line to a polyline, draw the
polyline before you start this procedure.

1 Select the wall that has the roof line or floor line you want to
change.

2 Click Wall tab ➤ Modify panel ➤ Roof/Floor Line

drop-down ➤ Edit In Place  .

A temporary profile is created for you to edit the geometry of the
roof line and floor line.
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Wall Elevation Edit In Place Grips

3 NOTE After you perform an editing task, you may need to select the
profile again to perform another editing task.

Edit the profile:

Then …If you want to …

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Add

add a gable to the roof line or the
floor line

Gable  . Select the roof line or
the floor line.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Add

add a step to the roof line or the
floor line

Step  . Select the roof line or the
floor line.

select the profile, and use Move
Roof Line, Move Floor Line, Vertex,
and Edge grips to adjust the shape.

change the shape of the roof line
or the floor line

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Add

add vertices to the roof line or the
floor line

Vertex  . Select a point for each
new vertex, and press ENTER.
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Then …If you want to …

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Remove

remove vertices from the roof line
or the floor line

Vertex  . Select the vertices to
remove, and press ENTER.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Project

project the roof line or the floor line
to a polyline

To Polyline  . Select the roof line
or the floor line, and select the
polyline. Press ENTER to keep the
geometry, or enter y (Yes) to erase
it.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Auto

project the roof line or the floor line
to another object, such as a stair or
a roof

Project  . Select the roof line or
the floor line, and select the object.

select the profile, and click Edit in

Place tab ➤ Profile panel ➤ Reverse

reverse the roof line or the floor line

 . Select the roof line or the floor
line.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Remove

restore the roof line to the base
height of the wall, or restore the
floor line to the baseline of the wall

 . Select the roof line or the floor
line.

NOTE To add a gable or a step to a roof line or a floor line that has
been edited, first use the Remove tool to remove an existing roof line
or floor line condition.

4 Save or discard the changes:

Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the roof line and the floor
line to their shape before editing
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Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  . The wall uses the

save the changes

edited profile to define its geo-
metry.

Reversing the Roof Line or Floor Line of a Wall
Use this procedure to reverse the conditions applied to the roof line or the
floor line of a wall. Reversing the roof line or the floor line does not reverse
the start point and endpoint of the wall.

The following illustration shows reversing the roof line of a wall.

Reversing the roof line of a wall

The following illustration shows reversing the floor line of a wall.

Reversing the floor line of a wall

1 Select the wall that has the roof line or floor line you want to
change.

2 Click Wall tab ➤ Modify panel ➤ Roof/Floor Line

drop-down ➤ Edit In Place  .

A temporary profile is created for you to edit the geometry of the
roof line or the floor line.

3 Select the profile.

4 Click Edit in Place tab ➤ Profile panel ➤ Reverse  .
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5 Select the roof line or the floor line.

The selected line is reversed; the condition is applied to the
opposite end of the line.

6 Save or discard the changes:

Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the roof line and the floor
line to their shape before editing

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  . The wall uses the

save the changes

edited profile to define its geo-
metry.

Changing Vertices in the Roof Line or Floor Line of a Wall
Use this procedure to perform the following tasks on the Roof/Floor Line
worksheet on the Properties palette:

■ Add, move, or remove vertices in the roof line or the floor line of a wall.

■ Add gables or steps to a roof line or steps to a floor line that was previously
edited by adding vertices that define these conditions.

You can also edit the roof line and the floor line graphically. For more
information, see Editing the Roof Line or the Floor Line of a Wall on page 1229.

1 Double-click the wall you want to change.

2 Expand Advanced, and expand Worksheets.

3 Select Roof/Floor Line.

4 Select Edit Roof Line, or select Edit Floor Line.
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Changing the vertices of a roof line

The active vertex in the illustration changes when you select a
different line to edit. Any changes you make to the wall are
reflected in the illustration.

5 To add a vertex, click Insert Vertex. Specify the horizontal offset
and vertical offset for the new vertex and each offset distance,
and click OK.

For more information about specifying the location of a vertex,
see Specifying Offsets for Roof Line and Floor Line Vertices on
page 1411.

The following illustration shows modifying the roof line of a wall
by adding a vertex.

Modifying a roof line of a wall by adding a vertex

The following illustration shows modifying the floor line of a wall
by adding a vertex.
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Modifying a floor line of a wall by adding a vertex

6 To move a vertex, select the vertex from the table or the
illustration, and click Edit Vertex. Specify the horizontal offset
and vertical offset for the new vertex and each offset distance,
and click OK.

For more information about specifying the location of a vertex,
see Specifying Offsets for Roof Line and Floor Line Vertices on
page 1411.

7 To delete a vertex, select a vertex, and click Delete Vertex.

The selected vertex is deleted, and the line automatically connects
the 2 adjacent vertices.

8 To reverse the roof line or the floor line, click Reverse.

9 Click OK.

Specifying the Materials of Individual Walls
Use this procedure to select a different material for components of an
individual wall.

To change the materials assigned to all walls of the same wall style, see
Specifying the Materials of a Wall Style on page 1313.

NOTE If a material assignment does not determine the display properties of a wall
component, you can change the properties of the display component as described
in Changing the Display Properties of Individual Walls on page 1238.

1 Select the wall you want to change, right-click, and click Edit
Object Display.
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2 To verify that the material assignment determines the display
properties of the component, click the Display Properties tab,
select the display representation where you want the changes to

appear, and click  .

3 Click the Layer/Color/Linetype tab, verify that By Material is
selected for the component, and click OK.

4 Click the Materials tab.

5 Select the component you want to change, and select a different
material definition.

Wall segments with assigned materials in realistic visual style
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You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Although you can edit a material definition from this
dialog, any changes you make to the material definition apply to all
objects that are assigned the material.

6 Click OK.

Changing the Display Properties of Individual Walls
In most cases, you want the appearance of walls that belong to the same style
to be consistent throughout a drawing. To achieve this, you specify the material
assigned to each wall component, or you specify the display properties for
each wall style. However, in certain instances, you may need to override a
display property for an individual wall to achieve a specific result. All the
display properties that you can specify in wall styles are available for individual
walls:

■ Whether the display properties of wall components are determined by
material assignments

■ The layer, color, and linetype of the display components of the wall

■ The hatching used with each component

■ The cut plane height and the display of components relative to the cut
plane

■ Other specific wall display information, such as whether complex endcaps
are displayed and whether the wall is cut around door and window frames

When you change the display properties of an individual wall, the changes
apply only to that wall. Other walls of the same style are not affected. To
change the display properties of all walls of a specific wall style, see Wall Styles
on page 1296.
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Specifying the Layer, Color, and Linetype of a Wall
Use this procedure to change the following display properties of the
components of an individual wall:

■ Visibility (component is on or off)

■ By material (a material assigned to the display component determines its
display properties)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

To change these display properties for all walls of the same wall style, see
Specifying the Display Properties of a Wall Style on page 1316.

NOTE If a material assignment determines the properties of a wall display
component, you can change the properties of the display component by clearing
By Material or by overriding the material assignment with a different material. For
more information, see Specifying the Materials of Individual Walls on page 1236.

1 Select the wall you want to change, right-click, and click Edit
Object Display.

NOTE You can also use the Display tab of the Properties palette to
change the display property settings for a selected object display
component in the current display representation. For more
information, see Using the Properties Palette to Change Display
Properties on page 793.

2 Click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .
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5 Click the Layer/Color/Linetype tab.

6 Select the component to change, and select a different setting for
the property.

7 Click OK twice.

Specifying the Hatching for Components of a Wall
Use this procedure to specify the hatching of the components of an individual
wall. Wall hatching is displayed only in display representations, such as Plan,
that are used in the Top view (plan view) of a drawing.

To change the hatching for all walls of the same wall style, see Specifying the
Hatching for Components of a Wall Style on page 1317.

NOTE If a material assignment determines the hatching properties of a wall
component, you can change the hatching of the component by clearing By
Material or by overriding the material assignment with a different material. For
more information, see Specifying the Materials of Individual Walls on page 1236.

1 Select the wall you want to change, right-click, and click Edit
Object Display.

NOTE You can also use the Display tab of the Properties palette to
change the display property settings for a selected object display
component in the current display representation. For more
information, see Using the Properties Palette to Change Display
Properties on page 793.

2 Click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 Click the Hatching tab.

6 Select a component, and click the setting for Pattern.
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7 Select the hatching for the component:

Then …If you want to …

select Predefined for Type, and then
select a pattern.

select a hatching pattern that is
available in the software

select Custom for Type, and then
enter the name of the custom pat-

select a custom pattern

tern. If necessary, click Browse, and
navigate to the folder where the
custom pattern file is located.

select User-defined for Type, and
clear Double Hatch.

select single hatching

select User-defined for Type, and
select Double Hatch.

select double hatching

select Solid Fill for Type.select solid fill

8 Click OK.

9 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

10 Click Angle, and enter the angle for the selected pattern.

11 Click Orientation, and specify how the hatching is oriented:

Then …If you want to …

select Object.orient the hatching to the object,
regardless of the object rotation

select Global.orient the hatching to the World
Coordinate System

12 Click OK twice.

Specifying the Cut Plane Display of a Wall
Use this procedure to specify the properties of one or more cut planes for an
individual wall. Cut plane display properties apply only to display
representations, such as Plan, that are used in the Top view (plan view) of a
drawing.
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To better visualize the elements of a wall in plan view, you can create cut
planes. The main cut plane is where the shrinkwrap and hatching are applied.
The plan display shows the components and objects in the wall as they are
displayed at the height of each cut plane.

1 Double-click the wall you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all walls in the drawing, select
Drawing default setting. To apply changes to all walls of this style,
select Wall Style:<style name>. For more information on styles, see
Wall Styles on page 1296.

5 If necessary, expand Object Display Properties ➤ Cut Plane.

6 For Override cut plane, specify whether you want to override the
global cut plane defined for the current display configuration.

7 If you selected Yes for Override cut plane, enter a value for Height
to define the cut plane for this object.

8 To specify whether to display object components both above and
below the cut plane, or to define additional cut planes for the

wall, click  Manual cut planes.

9 On the Manual Cut Planes worksheet, do either or both of the
following:

■ To display object components above and below the cut plane,
verify that Automatically Choose Above and Below Cut Plane
Heights is selected.

■ To specifically define a cut plane, select Manual Above and
Below Cut Plane Heights, click Add, and enter the height of
the new cut plane.

Then …If you add a cut plane …

objects are displayed using the
Layer/Color/Linetype properties

at a height that is lower than the
value for Cut Plane Height

specified for the Below Cut Plane
component of the object.
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Then …If you add a cut plane …

objects are displayed using the
Layer/Color/Linetype properties

at a height that is higher than the
value for Cut Plane Height

specified for the Above Cut Plane
component of the object.

You can click Remove to delete a cut plane that you added.

You can also access and modify these same cut plane settings through the
wall’s context menu, as follows:

1 Select the wall you want to change, right-click, and click Edit
Object Display.

2 In the Object Display dialog, click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 In the Display Properties dialog, click the Cut Plane tab, and then
change the settings as needed.

6 Click OK twice.

Specifying the Display of Endcaps in Model Views
Use this procedure to specify whether to display endcaps of openings in a
selected wall in a display representation used for model views.

1 Double-click the wall.

2 Click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all walls in the drawing, select
Drawing default setting. To apply changes to all walls of this style,
select Wall Style:<style name>. For more information on styles, see
Wall Styles on page 1296.

Changing the Display Properties of Individual Walls | 1243



5 For Display representation, verify that the desired display
representation is selected.

6 If necessary, expand Object Display Properties ➤ Advanced.

7 For Display opening endcaps, select Yes or No.

Specifying the Display of Other Characteristics of a Wall
Use this procedure to specify display properties for an individual wall that
apply only in display representations such as Plan, that are used in the Top
view (plan view) of a drawing. These properties include whether to display
complex endcaps, to show door and window frames, or to show the miter of
specific wall components.

1 Double-click the wall you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all walls in the drawing, select
Drawing default setting. To apply changes to all walls of this style,
select Wall Style:<style name>. For more information on styles, see
Wall Styles on page 1296.

5 For Display representation, verify that the desired display
representation is selected.

6 If necessary, expand Object Display Properties ➤ Advanced.

7 Click  Additional properties.

8 Specify individual display property settings as needed:

Then …If you want to …

select Display Inner Lines Above.
Clear this option if you do not want
to display these lines.

display the component lines within
the wall above the cut plane (for
example, through a window or
door in the wall)

select Display Inner Lines Below.
Clear this option if you do not want
to display these lines.

display the component lines within
the wall below the cut plane (for
example, through a window or
door in the wall)
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Then …If you want to …

select Hide Lines Below Openings
Above Cut Plane. Clear this option
if you want to display the lines.

turn off lines above a window, door,
or opening at the cut plane

select Hide Lines Below Openings
at Cut Plane. Clear this option if you
want to display the lines.

turn off lines beneath a window or
an opening at the cut plane

select Display Endcaps. Clear this
option to display complex endcaps
as a single line.

display complex endcaps

select Cut Door Frames. Clear this
option if you want door openings

display door openings cutting the
wall at the outer edge of the door
frame to cut the wall at the inside of the

door frame.

select Cut Window Frames. Clear
this option if you want window

display window openings cutting
the wall at the outer edge of the
window frame openings to cut the wall at the in-

side of the window frame.

select Component Draw Order by
Priority. Clear this option if you

draw wall components by their pri-
ority number to control the display

want to draw the components in
the order that they were created.

of a component over another com-
ponent

select Do True Cut. Clear this op-
tion if the wall does not have

perform a slice of the actual 3-di-
mensional (3D) model at each cut

sweeps or body modifiers, or if theyplane to obtain more accurate views
do not change along the height of
the wall.

of walls with sweeps or body modi-
fiers

Under Draw Miter for Components,
select each component whose miter
lines you want to display.

display miter lines at wall corners
for selected wall components

9 Click OK.

You can also access and modify these same additional settings through the
wall’s context menu, as follows
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1 Select the wall you want to change, right-click, and click Edit
Object Display.

2 In the Object Display dialog, click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 In the Display Properties dialog, click the Other tab, and then
change the settings as needed.

6 Click OK twice.

Attaching Notes and Files to a Wall
Use this procedure to enter notes and attach reference files to a wall. You can
also edit notes and edit or detach reference files from a wall.

1 Double-click the wall.

2 On the Properties palette, click the Extended Data tab.

3 Click the setting for Notes.

4 Enter the note, and click OK.

5 Click the setting for Reference documents, and attach, edit, or
detach a reference file:

Then …If you want to …

click  , select a file, and click OK.
attach a reference file

select the file, and click the descrip-
tion. Edit the description.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

6 Click OK twice.
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Wall Parameters
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Wall Styles

Many characteristics of a wall are determined by the wall style used. You can
create simple wall styles that have a more symbolic display, or you can create
detailed walls styles with a representational display, containing many elements
the real wall will have. These settings are defined in the wall style:

■ Property Set data: If you want to tag a wall in a drawing, or include it in
a schedule table, you need to attach property set data to the wall or the
wall style. Property data attached to a wall style typically contains automatic
properties, like the wall height or the wall width, or manual properties
that are identical for all walls of that style, like for example the fire rating.
For more information, see Adding Property Set Data to a Wall Style on
page 1298.

■ Wall Components: In a wall style, you can define wall components.

For more information, see Specifying the Components of a Wall Style on
page 1299

■ Materials: In a wall style, you can define materials for the 2D and 3D
display of walls, as well as for the rendering display of the wall.

To use a material in a wall style, it needs to be defined first in Style
Manager. For information about assigning a material to a wall style, see
Specifying the Materials of a Wall Style on page 1313.
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For information about defining Materials, see Creating and Editing Material
Definitions on page 919.

■ Specifying Wall Display: the visual appearance of a wall is defined in the
wall style. Define the layer, color, linetype settings of the individual wall
components, hatching, and the cut plane display of the wall in plan views.
The display settings defined in the wall style can be overridden for an
individual wall. For more information, see Specifying the Display Properties
of a Wall Style on page 1316

■ Specifying Default Wall Settings: access the Options dialog and specify
the defaults for dimensioning walls and for wall cleanup. The cleanup
settings apply only to new walls.

■ Using Wall Tools: Tools provided with AutoCAD Architecture let you
quickly place walls by selecting a wall tool with a specific wall style and
other predefined properties. You can also use wall tools to convert linework
to walls and to apply the settings of a wall tool to existing walls.
You can also access Stock Tool, Sample palette, and Design Tool catalogs.
When you place walls using wall tools, you can use the default settings of
the tool, or you can change settings for any wall properties that are not
controlled by the style.

Wall Endcaps and Opening Endcaps

Work with wall and opening endcaps to create endcap conditions:

■ Modifying Wall Endcaps with Edit in Place Grips: You can use Edit in Place
grips to modify wall endcaps and create the wall endcap conditions that
you want. Vertex and Edge grips are displayed for all wall components at
the wall endcap that you specify. For more information, see Using Edit in
Place to Modify Wall Endcaps on page 1375.

■ Creating Wall Endcaps Using Calculate Automatically: You can use the
Calculate Automatically feature with appropriate polyline linework to
create wall endcaps. Calculate Automatically will add boundary segments
to complete an endcap configuration if the initial polyline is drawn with
regard to location and orientation of the particular wall component. For
more information, see Creating Wall Endcaps Using Calculate Automatically
on page 1396.

■ Creating Wall Endcaps Using AEC Modify Tools: You can use AEC Modify
Tools to manipulate wall components to create appropriate wall endcap
configurations. Use Trim, Extend, Subtract, and Merge tools as necessary
to do this. You can modify single wall components or you can modify all
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components at your wall endcap or opening at once. In each case, you
will be using the Edit in Place feature as you modify the wall components
to create your wall endcap condition. For more information, see Using
Edit in Place to Modify Wall Endcaps on page 1375.

■ Specifying Wall Endcaps by Style: In the wall style, you can define endcaps
for the wall start and end. The standard endcap style is a straight line. If
you need different endcaps, you need to create a wall endcap style, and
then assign it to the wall style. For more information, see Applying a Wall
Endcap Style to a Wall Style on page 1402 and Working with Wall Endcaps
and Opening Endcaps on page 1373.

NOTE You can override the wall endcap style on individual walls in the drawing.

■ Specifying Opening Endcaps by Style: In the wall style, you define the
endcaps for any doors, windows, and openings inserted in the wall. By
default the opening endcaps are 4 straight lines for the jamb start and end,
and the sill and head of the opening.

For more information, see Working with Wall Endcaps and Opening
Endcaps on page 1373.

Creating a Wall Tool
Use this procedure to create a wall tool and add it to a tool palette. You may
want to create your own tools if you are placing multiple walls of specific
styles that have the same properties.

For example, you are creating an office floor plan with partition walls for
cubicles. Although all partition walls use the same wall style in your floor
plan, the walls in administrative areas are lower than the walls in office areas.
To work efficiently, you can create a wall tool for each wall height, and select
the appropriate tool to place the walls with the correct height in each area of
the floor plan.

You can use any of the following methods to create a wall tool:

■ Drag a wall that has the properties you want to a tool palette.
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■ Drag a wall style from the Style Manager to a tool palette, and then
customize the properties of the new tool.

■ Copy an existing wall tool, and then customize the properties of the new
tool.

■ Drag a wall tool from a tool catalog in the Content Browser, and then
customize the properties of the tool.

1 Open the tool palette on which you want to create a tool.

2 Create the tool:

Then …If you want to …

select the wall, and drag it to the
tool palette.

TIP Drag the wall by a point on
its perimeter, not by one of its
grips.

create a tool from a wall in the
drawing

click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from a wall style in the
Style Manager

the style you want to copy, and
drag it to the tool palette. Click OK
to close the Style Manager.

right-click the tool, click Copy, and
click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another palette

open the palette where you want
to add the tool, right-click, and click
Paste.

open the tool catalog in the Con-
tent Browser, and locate the tool

copy a tool from a tool catalog in
the Content Browser

you want to copy. Position the
cursor over the i-drop handle, and
drag the tool to the tool palette.

3 Right-click the new tool, and click Properties.
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4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

This description is used as the tool’s tooltip on the tool palette,
and to describe the tool if it is stored in a tool catalog.

6 Expand Basic, and expand General.

7 Enter a description of the tool.

8 If you do not want to use the default layer key, select a layer key.

9 If you want to override the default layer names, select a layer
override.

10 Select a wall style.

11 For Style location, select the drawing file containing the style to
be used for this tool, or select Browse and use a standard file
selection dialog box to select the file.

12 Under Bound spaces, define if this wall tool can be used as a
bounding object for associative spaces.

You can select 3 options here:

■ Yes: this wall tool can be used as bounding object for
associative spaces.

■ No: this wall tool cannot be used as bounding object for
associative spaces.

■ By style: this wall tool will use the bounding settings from the
wall style.

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

13 Select Yes for Cleanup automatically if you want the wall to clean
up with other walls, and select a cleanup group.

14 For Definition location, select Browse, and use a standard file
selection dialog box to select the Cleanup group definition to be
used for this tool.

15 Expand Dimensions.
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16 Specify wall dimensions:

Then …If you want to …

enter a value for Width. If Width is
not available, the wall style you se-

specify the thickness of the wall

lected determines the width of the
wall.

enter a value for Base height.specify the height of the wall from
the floor to the ceiling

17 Specify the wall justification, which places the wall in relation to
the points you specify and the direction in which you draw the
wall:

Then …If you want to …

select Left for Justify.specify points that define the left
side of the wall

select Right for Justify.specify points that define the right
side of the wall

select Center for Justify.specify points that define the center
line of the wall

select Baseline for Justify.specify points that define the
baseline of the wall

18 Specify offsets:

Then …If you want to …

enter a value for Baseline offset, or
pick the offset point.

offset the location of the wall from
the points you specify

enter a value for Roof line offset
from base height.

offset the roof line from the spe-
cified base height

enter a value for Floor line offset
from baseline.

offset the floor line from the
baseline

19 On the Properties palette, expand Advanced.
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20 Expand Cleanups, and specify cleanup options:

Then …If you want to …

select Wall Justification Line, or se-
lect Wall Center Line.

specify the line that the Diagnostic
display representation uses for the
wall justification line

enter a value for Cleanup radius
override.

specify a radial distance from the
endpoint of a wall in which other
walls will be connected

21 Click OK.

Troubleshooting Walls
This section provides solutions for problems you may encounter when working
with walls.

Legacy Walls Do not Display in Isometric Views

In some cases walls in a drawing that come from a previous version of AutoCAD
Architecture do not display in isometric views. The reason for this can be
number of decimal places in the wall base height. If you encounter this
situation, try the following:

1 Click  ➤ Utilities ➤ Drawing Setup.

2 Click the Units tab.

3 Under Area, for Precision, select the maximum 8 decimals.

4 Close the Drawing Setup dialog.

5 Select the wall in the drawing, and edit its Base Height value in the
Properties palette to display the correct value.

The wall should now display in an isometric view.

Troubleshooting Wall Cleanups

Wall Cleanup can be complex, especially for multi-component walls. For a
list of issues that can come up and how to solve them, see Troubleshooting
Wall Cleanups on page 1343.
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Creating Special Conditions and Customized Wall
Surfaces

Wall sweeps, wall (plan) modifiers, body modifiers, and interference conditions
are features that you can use to create special conditions, such as chases, and
to customize wall surfaces.

Wall Sweeps Created from Profiles

A wall sweep is a wall or a wall component whose shape is extruded
horizontally from a profile that was created from a closed polyline. The profile
“sweeps” along the length of the wall to define the shape of the wall or the
wall component.

Profile and resulting wall sweep

Wall (Plan) Modifiers Created from Polylines

Wall modifiers use the 2-dimensional (2D) geometry of an open polyline to
customize the shape of a wall or a wall component. To use wall modifiers, you
draw a polyline in the shape you need and create a wall modifier style from
the polyline. You can then add wall modifiers of that style to any wall.

Polyline and resulting wall modifier

Body Modifiers Created from 3D Objects

Body modifiers use the 3-dimensional (3D) geometry of an object, such as a
mass element or a mass group, to add to, subtract from, or completely replace
one component in a wall. If the wall has only one component, the body
modifier applies to the entire wall. If the wall has multiple components, the
modifier applies only to the component that you specify.
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Barrel Vault mass element and resulting body modifier subtracted from a wall

Interference Conditions Created from 3D Objects

Interference conditions use the geometry of 3D objects to create custom
openings or cutouts in walls. You can specify how the interference condition
is applied to the wall: added to the wall, subtracted to the wall, or ignored.

Interference conditions apply to all wall components that the interfering
object touches. The wall stops at the interference condition. The way in which
you apply the interference condition to the wall determines how the
shrinkwrapping of the wall is affected by the condition in plan view. In model
views, the interference condition is always subtractive, regardless of the
shrinkwrapping option you selected.

When you edit the object that acts as the interference condition, the wall
changes to accommodate the changes to the geometry of the object. For
example, you can move the interfering object to change its location on the
wall.

A Cylinder mass element added as an additive interference condition

Working with Wall Sweeps
A wall sweep is a wall or a wall component whose shape is extruded
horizontally from a profile that was created from a closed polyline. The profile
“sweeps” along the length of the wall to define the shape of the wall.

The height and the width of the polyline you use to create the profile define
the height and the width of the wall component.The profile is not scaled
when swept on the wall. The insertion point of the profile becomes the
lower-left corner of the wall component.
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After you create wall sweeps, you can miter wall sweeps that meet at a corner.
You can also change how the sweep is applied to the wall:

■ You can edit the geometry that defines a sweep.

■ You can assign a sweep profile to a different wall component.

■ You can adjust the miter angles at each end of a wall that has a
sweep profile.

■ You can remove a sweep profile from a wall or a wall component.

Creating a Profile for a Wall Sweep
Use this procedure to create a profile from a closed polyline. You can then
sweep the profile along the length of a wall or a wall component to create a
wall with a custom shape.

The height and the width of the polyline you use to create the profile define
the height and the width of the wall component. The profile is not scaled
when swept on the wall. The insertion point of the profile becomes the
lower-left corner of the wall component.

You can also define the shape of a wall sweep as you add it to a wall, using
the Start from Scratch option. You may find that option easier to use because
you can define the shape in place on the wall. You may want to separately
create a profile as described in this procedure if the shape is highly complex
or contains many arcs.

1 Draw a closed polyline of the shape needed for the resulting wall
component.

2 Select the polyline, right-click, and click Convert to ➤ Profile
Definition.

3 Specify the insertion point of the profile.

The point you specify becomes the lower-left corner of the wall
component.

4 Press ENTER.

5 Enter a name for the profile, and click OK.

You can now use the profile as a wall sweep to replace a wall
component. For more information, see Adding a Sweep to a Wall
on page 1258.
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Adding a Sweep to a Wall
Use this procedure to create a custom wall or a wall component by defining
its shape from a profile.

You can create the profile as you add it to a wall. However, if the shape you
need is elaborate and has curved segments, you may find it easier to create
the profile from a polyline first. You can then add the profile to the wall. For
more information, see Creating a Profile for a Wall Sweep on page 1257.

Adding a sweep profile to a wall

1 Select the walls to sweep.

2 Click Wall tab ➤ Modify panel ➤ Sweep drop-down ➤ Add  .

3 Select the component to which to apply the sweep.

4 Select the profile to use for the sweep.

If you want to define the sweep after you apply it to the
component, select Start from scratch, and enter a name for the
profile.
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Specifying settings for a wall sweep

5 Specify how the sweep is applied to the wall:

Then …If you want to …

select Apply Roof/Floor Lines to
Sweeps.

apply existing roof line or floor line
conditions to the sweep

clear Apply Roof/Floor Lines to
Sweeps.

use the geometry of the sweep to
define the roof line and the floor
line

select Miter Selected Walls.miter the intersection of the wall
containing the sweep and other
walls

clear Miter Selected Walls. You can
miter the walls later, if needed. You
can also adjust the miter angles.

prevent mitering the intersection of
the wall containing the sweep and
other walls

select Continue Editing. For more
information about editing the pro-

change the geometry of the sweep
when it is applied to the wall

file, see Editing the Geometry of a
Wall Sweep on page 1260.

clear Continue Editing.use the existing geometry of the
profile to define the sweep

6 Click OK.
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TIP To create additional walls with the same sweep condition, select
the wall with the sweep, and click Wall tab ➤ General panel ➤ Add

Selected  .

Editing the Geometry of a Wall Sweep
Use this procedure to change the shape of a wall component that was defined
with a wall sweep. You can select a different profile to change the appearance
of the sweep, or you can edit the current profile.

If you want to remove a wall sweep, apply the sweep to a different wall
component, or change how the sweep cleans up with intersecting walls, see
Managing Wall Sweeps on page 1267.

Use this procedure to display wall sweep edit in-place grips

1 Select the wall that has the sweep you want to change.

2 Click Wall tab ➤ Modify panel ➤ Sweep drop-down ➤ Edit Profile

In Place  .

3 Select a location on the wall where the shape of the sweep will
be convenient to edit.

A temporary profile is created for you to edit the geometry of the
sweep.
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Viewing Wall Sweep Edit In Place Grips

Offsetting an edit in-place wall sweep profile edge

Use this procedure to offset an edit in-place wall sweep profile edge

1 Select the wall that has the sweep you want to change.
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2 Click Wall tab ➤ Modify panel ➤ Sweep drop-down ➤ Edit Profile

In Place  .

3 Select a location on the wall where the shape of the sweep will
be convenient to edit.

A temporary profile is created for you to edit the geometry of the
sweep.

4 Select the Edge grip and specify a new grip location.

The wall sweep profile now has a offset edge.

Adding a vertex to an edit in-place wall sweep profile edge

Use this procedure to add a vertex to an edit in-place wall sweep profile edge

1 Select the wall that has the sweep you want to change.

2 Click Wall tab ➤ Modify panel ➤ Sweep drop-down ➤ Edit Profile

In Place  .

3 Select a location on the wall where the shape of the sweep will
be convenient to edit.

A temporary profile is created for you to edit the geometry of the
sweep.

4 Select the Edge grip, press CTRL and specify a new grip location.
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The wall sweep profile now has a new edge vertex.

Converting an edit in-place wall sweep profile edge to an arc

Use this procedure to convert an edit in-place wall sweep profile edge to an
arc

1 Select the wall that has the sweep you want to change.

2 Click Wall tab ➤ Modify panel ➤ Sweep drop-down ➤ Edit Profile

In Place  .

3 Select a location on the wall where the shape of the sweep will
be convenient to edit.

A temporary profile is created for you to edit the geometry of the
sweep.

4 Select the Edge grip, press CTRL twice, and specify a new grip
location.

The wall sweep profile edge is now an arc.

1 NOTE After you perform an editing task, you may need to select the
profile again to perform another editing task.
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Moving an edit in-place wall sweep vertex

Edit the profile:

Then …If you want to …

select the Insertion Point grip, and
move it to the desired position.

change the location of the sweep
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Then …If you want to …

select the profile, and use grips to
adjust the shape.
The Edge grip has 3 edit modes:
Offset, Add Vertex, and Convert to

change the shape of the perimeter
of the profile or its rings

Arc. The default mode is Offset,
which offsets the selected edge in
a direction that is perpendicular to
the midpoint of the edge. Depend-
ing on the shape of the profile and
the edge you choose to modify,
neighboring lines are extended or
trimmed, and new lines are added,
as necessary.
Use the Add Vertex edit mode to
add a vertex to the selected edge,
and create a new edge. If the selec-
ted edge is an arc, the new edge is
an arc, as well.
Convert to Arc changes the selected
edge to an arc and stretches the
midpoint of the edge. The edge
grip for an arc also has a Stretch
mode, so that you can stretch the
midpoint of the edge after it has
been converted to an arc.

select an Edge grip, and press CTRL
to switch to the Add Vertex edit

add vertices to the profile

mode. Move the edge to the de-
sired location and click, or enter a
value and press ENTER.

select the Vertex grip for the vertex
you want to remove, and press

remove vertices from the profile

CTRL to switch to the Remove edit
mode. Move the cursor off the se-
lected vertex, and click.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Replace

replace an existing ring of the pro-
file with new geometry

Ring  . Select the ring to replace,
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Then …If you want to …

and select the new geometry. Press
ENTER to keep the geometry, or
enter n (No) to erase it.

draw the linework in place on the
temporary profile. Select the profile,

add a ring to the profile to subtract
an area from the profile

and click Edit In Place tab ➤ Profile

panel ➤ Add Ring  . Select the
geometry to define the ring. Press
ENTER to keep the geometry, or
enter y (Yes) to erase it.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Remove

remove a ring from the profile

Ring  . Select the ring to re-
move, and press ENTER. This option
does not appear if the profile has
only one ring.

2 Save or discard the changes:

Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the sweep to its original
shape

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  .The sweep uses the

save the changes to the current
profile

edited profile to define its geo-
metry. Any other objects or styles
that use this profile are also up-
dated with the edited geometry.

click Edit In Place tab ➤ Edits pan-

el ➤ Save As  . Enter a name for

save the changes to a new profile

the new profile, and click OK. The
sweep uses the new profile to
define its geometry. Other styles or
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Then …If you want to …

objects that use the original profile
are not affected.

Mitering Walls with Sweeps
Use this procedure to miter intersecting walls whose shape is defined by a wall
sweep.

NOTE If you miter the end of walls, no endcaps are drawn.

1 Select a wall with a sweep that you want to miter.

2 Click Wall tab ➤ Modify panel ➤ Sweep drop-down ➤ Miter
.

3 Select the second wall.

To adjust the angles of the mitered walls, see Managing Wall
Sweeps on page 1267.

Managing Wall Sweeps
Use this procedure to edit or remove a wall sweep from an individual wall.
You can change the component the sweep is applied to. You can also change
the miter angles at each end of the sweep and the offsets in the wall.

1 Double-click the wall you want to change.

2 On the Properties palette, expand Advanced, and expand
Worksheets.

3 Select the setting for Sweeps.

4 Select a wall sweep, and change its settings:

Then …If you want to …

select a different profile for Profile.change the profile used to define
the geometry of the sweep

select a different component for
Component.

apply the sweep to a different wall
component
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Then …If you want to …

enter different values for Start Miter
and End Miter.

change the miter angles at each
end of the wall

enter a value for Offset Within.offset the sweep within the wall

enter a value for Offset Vertical.vertically offset the sweep

click  .
delete the sweep from the wall
component

5 Click OK.

Working with Wall Modifiers
Wall modifiers (also called plan modifiers) use the 2-dimensional (2D) geometry
of an open polyline to customize the shape of a wall or a wall component. To
use wall modifiers, you draw a polyline in the shape you need and create a
wall modifier style from the polyline. You can then add wall modifiers of that
style to any wall. A wall can have more than one wall modifier attached to it.

Placing a Wall Modifier on a Wall

You specify the placement of a wall modifier, including its vertical and
horizontal position and its depth. The wall modifier can be added at the drawn
size of the polyline or scaled to a specific size. The wall modifier is then
extruded vertically along the wall surface.

You can add the wall modifier to one or both sides of the wall. When you
select the face, you can also offset the wall modifier from the opposite face to
create a bump-out, such as for pipe chases or interior columns.
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Applying wall modifiers to a wall

Editing a Wall Modifier

After placing a wall modifier, you can adjust its placement, or assign the
modifier to a different wall component. You can also edit the geometry of the
wall modifier, and save the changes to the current wall modifier style or to a
new style.

Display Properties and Materials for Wall Modifiers

Wall modifiers take on the material assignment and the display properties of
the wall component they are assigned to. This allows you to use the same wall
modifier on different types of walls.

Wall Modifier Styles

You save the geometry of a wall modifier as a wall modifier style. You can
create the style when you add the wall modifier to a wall. You can also create
a wall modifier first and then apply it to walls as needed.

To create, edit, copy, or purge wall modifier styles, you access the Style
Manager. The Style Manager provides a central location in AutoCAD
Architecture to work with styles from multiple drawings and templates. For
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more information about using the Style Manager, see Style Manager Overview
on page 870.

Converting a Polyline to a Wall Modifier
Use this procedure to create a wall modifier from an open polyline. You can
draw the polyline in the location for the wall modifier, or you can project the
modifier you create to the wall. The polyline cannot be closed.

Converting a polyline to a wall plan modifier

The wall modifier you create is added to the selected wall and is also saved as
a wall modifier style that you can apply to other walls.
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Wall plan modifier in plan and 3D views

1 Draw the polyline in the shape of the wall modifier.

2 Select a wall to which you want to apply a wall modifier.

3 Click Wall tab ➤ Modify panel ➤ Plan Modifiers

drop-down ➤ Convert Polyline To Wall Modifiers  .

4 Select the polyline.

5 Enter y (Yes) to erase the selected polyline, or enter n (No) to keep
the polyline in the drawing.

6 Enter a name for the wall modifier style created from the polyline,
and click OK.

7 Select the wall component to which the wall modifier applies.

8 To offset the opposite face of the selected component in the shape
of the wall modifier, select Offset Opposite Face.
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Applying a wall plan modifier and offsetting the opposite component face

9 Specify the vertical position of the modifier on the wall
component:

Then …If you want to …

enter a value for Start Elevation
Offset, and specify whether the off-

specify the beginning height of the
wall modifier

set occurs from the wall top, the
wall base height, the wall justifica-
tion line, or the wall bottom.

enter a value for End Elevation Off-
set, and specify whether the offset

specifying the ending height of the
wall modifier

occurs from the wall top, the wall
base height, the wall justification
line, or the wall bottom.

Enter a negative offset value to specify a location toward the
ground.
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Wall plan modifier location parameters

10 Click OK.

Adding an Existing Wall Modifier to a Wall
Use this procedure to add a wall modifier of an existing wall modifier style to
a wall. You can apply the modifier to one or both sides of the wall or the
component. The left and right sides of the wall are determined from the start
and endpoints of the wall.

1 Select the wall to which you want to apply a wall modifier

2 Click Wall tab ➤ Modify panel ➤ Plan Modifiers drop-down ➤ Add

 .

3 Select the start point for the wall modifier.

After you select the first point, a temporary line is displayed to
show you the length of the modifier.

4 Select the endpoint for the modifier.

5 Select the side of the wall to draw the modifier.

6 Enter the depth for the wall modifier.

7 Select the wall modifier style.

8 Select the name of the component to apply the modifier to.

9 To offset the opposite face of the selected component in the shape
of the wall modifier, select Offset Opposite Face.
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Adding a wall plan modifier

10 Specify the vertical position of the modifier on the wall
component:

Then …If you want to …

enter a value for Start Elevation
Offset, and specify whether the off-

specify the beginning height of the
wall modifier

set occurs from the wall top, the
wall base height, the wall justifica-
tion line, or the wall bottom.

enter a value for End Elevation Off-
set, and specify whether the offset

specifying the ending height of the
wall modifier

occurs from the wall top, the wall
base height, the wall justification
line, or the wall bottom.

Enter a negative offset value to specify a location toward the
ground.
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Wall plan modifier location parameters

11 Click OK.

After you add a wall modifier, you can edit its geometry or adjust
its placement.

Editing the Geometry of a Wall Modifier
Use this procedure to edit the geometry of a wall modifier that is applied to
a wall. You can edit the vertices and edges of the wall modifier or replace the
geometry with that of another polyline. You can save the changes to the
current wall modifier style or to a new style.

To move a wall modifier horizontally or change the vertical offsets of a wall
modifier, see Changing the Horizontal and Vertical Offsets of a Wall Modifier
on page 1278.

1 Select the wall that has the wall modifier you want to change.

2 Click Wall tab ➤ Modify panel ➤ Plan Modifiers drop-down ➤ Edit

Profile In Place  .
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3 If prompted that the modifier is not drawn to size, click Yes.

A temporary profile is created for you to edit the geometry of the
wall modifier. If the wall contains multiple wall modifiers, a profile
is created for each wall modifier.

4 NOTE After you perform an editing task, you may need to select a
profile again to perform another editing task.

Edit the profile:

Then …If you want to …

select the profile, and use grips to
adjust the shape.

change the shape of the perimeter
of the profile

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Hide

hide one or more edges of the pro-
file (plan view only)

Edge  . Select the edges you
want to hide, and press ENTER.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Show

display an edge that you hid

Edge  . Select the edges you
want to show, and press ENTER.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Add

add vertices to the profile

Vertex  . Select a point for each
new vertex, and press ENTER.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Remove

remove vertices from the profile
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Then …If you want to …

Vertex  . Select each vertex to
remove, and press ENTER.

select the profile, and click Click

Edit In Place tab ➤ Profile pan-

replace a profile with new geometry

el ➤ Replace Modifier  . Select
the modifier to replace, and select
a polyline to define the new geo-
metry. Press ENTER to keep the
polyline in the drawing, or enter y
(Yes) to erase it. The start and end-
points of the new polyline must be
the same as those for the original
wall modifier.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Remove

remove a wall modifier

Modifier  . If the wall has mul-
tiple wall modifiers, select the wall
modifier to remove, and press
ENTER.

5 Save or discard the changes:

Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the wall modifier to its ori-
ginal shape

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  .The wall modifier

save the changes to the current wall
modifier style

and the wall modifier style use the
edited profile to define its geo-
metry. Any other walls that use this
wall modifier style are also updated
with the edited geometry.

click Edit In Place tab ➤ Edits pan-

el ➤ Save As  . Enter a name for

save the changes to a new wall
modifier style
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Then …If you want to …

the new wall modifier, and click OK.
The wall modifier uses the new style
to define its geometry. Other walls
that use the original style are not
affected.

Changing the Horizontal and Vertical Offsets of a Wall Modifier
Use this procedure to change the horizontal position of a wall modifier applied
to a wall, or to change its vertical position on a wall.

1 Select the wall that has the wall modifier you want to change.

2 Click Wall tab ➤ Modify panel ➤ Plan Modifiers drop-down ➤ Edit

Profile In Place  .

3 If prompted that the modifier is not drawn to size, click Yes.

A temporary profile is created for you to edit the geometry of the
wall modifier. If the wall contains multiple wall modifiers, a profile
is created for each wall modifier.

NOTE After you perform an editing task, you may need to select a
profile again to perform another editing task.

4 Change the placement of the wall modifier:

Then …If you want to …

select the Move grip, and move the
grip to reposition the wall modifier.

move the wall modifier horizontally
along the wall

After you select the grip, you can
also enter a value to move the wall
modifier a specified distance.

select an isometric view. Select the
Offset from top of wall grip, and

position the wall modifier relative
to the top of the wall

move the grip to reposition the wall
modifier. After you select the grip,
you can also enter a value to move
the wall modifier a specified dis-
tance from the top of the wall.
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Then …If you want to …

select an isometric view. Select the
Offset from bottom of wall grip,

position the wall modifier relative
to the bottom of the wall

and move the grip to reposition the
wall modifier. After you select the
grip, you can also enter a value to
move the wall modifier a specified
distance from the bottom of the
wall.

5 If necessary, continue editing the wall modifier as described in
Editing the Geometry of a Wall Modifier on page 1275.

6 Save or discard the changes:

Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the wall modifier to its ori-
ginal position

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  The wall modifier

save the changes to the current wall
modifier style

and the wall modifier style use the
edited profile to define its geo-
metry. Any other walls that use this
wall modifier style are also updated
with the edited geometry.

click Edit In Place tab ➤ Edits pan-

el ➤ Save As  . Enter a name for

save the changes to a new wall
modifier style

the new wall modifier style, and
click OK. The wall modifier uses the
new style to define its geometry.
Other walls that use the original
style are not affected.

Adjusting the Placement of a Wall Modifier
Use this procedure to adjust the placement of a wall modifier that you added
to a wall. You can also add or remove wall modifiers using this procedure.
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You can also graphically adjust the placement of a wall modifier. For more
information, see Changing the Horizontal and Vertical Offsets of a Wall
Modifier on page 1278.

To edit the shape of a wall modifier, see Editing the Geometry of a Wall
Modifier on page 1275.

1 Double-click the wall that has the modifier you want to change.

2 On the Properties palette, expand Advanced, and expand
Worksheets.

3 Select the setting for Plan Modifiers.

4 Under Style, select the wall modifier you want to change.

5 If needed, select a different modifier style or component name,
and specify which sides to apply the modifier to.

6 Enter a value for Start Position Offset and specify whether the
offset occurs from the wall start point, the wall endpoint, or the
midpoint of the wall.

These settings specify the start point of the modifier along the
length of the wall. You can enter a negative value to specify an
offset in the reverse wall direction.

Wall plan modifier location parameters

7 Edit the vertical position of the modifier on the wall component:

Then …If you want to …

enter a value for Start Elevation
Offset, and specify whether the off-

specify the beginning height of the
wall modifier

set occurs from the wall top, the
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Then …If you want to …

wall base height, the wall justifica-
tion line, or the wall bottom.

enter a value for End Elevation Off-
set, and specify whether the offset

specifying the ending height of the
wall modifier

occurs from the wall top, the wall
base height, the wall justification
line, or the wall bottom.

Enter a negative offset value to specify a location toward the
ground.

8 Edit settings to control the size and placement of the modifier:

Then …If you want to …

select Use Drawn Size.place the modifier at the size it was
defined in the modifier style

clear Use Drawn Size, and enter
values for Length and Depth.

specify the length and the depth of
the modifier on the wall

select Mirror X.mirror the modifier in the X direc-
tion

select Mirror Y.mirror the modifier in the Y direc-
tion

select Measure to Center.measure the modifier to the center
of the wall

9 To mirror the modifier in the X direction, select Mirror X.
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Wall plan modifier mirrored in the X direction

10 To mirror the modifier in the Y direction, select Mirror Y.

Wall plan modifier mirrored in the Y direction

11 To remove a modifier, select the modifier, and click  .

12 Click OK.

Removing Wall Modifiers
Use this procedure to remove a wall modifier from an individual wall or a wall
component.

NOTE If you offset the modifier to the opposite face of the wall or the wall
component when you applied the modifier, you must remove the wall modifier
from each face.

1 Select the wall that has the wall modifier you want to remove.
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2 Click Wall tab ➤ Modify panel ➤ Plan Modifiers

drop-down ➤ Remove  .

3 Select the modifier.

Removing a wall plan modifier

4 Enter y (Yes) to create a polyline in the shape of the modifier, or
enter n if you do not want to create a polyline.

Creating a Wall Modifier Style
Use this procedure to create a wall modifier style from a polyline. The shape
of the polyline defines the shape of the wall modifier. After you create the
style, you can add it to a wall or a component of a wall. To create a wall
modifier style and apply it to a wall at the same time, see Converting a Polyline
to a Wall Modifier on page 1270.

To edit a wall modifier style, add the wall modifier to a wall, and then edit
the geometry of the wall modifier. For more information, see Adding an
Existing Wall Modifier to a Wall on page 1273 and Editing the Geometry of a
Wall Modifier on page 1275.

1 Draw an open polyline in the shape you want to use for the wall
modifier.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Expand Architectural Objects.

4 Right-click Wall Modifier Styles, and click New.

5 Enter a name for the new style.

6 Right-click the new style, and click Set From.

7 Select the polyline.
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8 Click OK.

Attaching Notes or Files to a Wall Modifier Style
Use this procedure to enter notes and attach reference files to a wall modifier
style. You can also edit notes and edit or detach reference files attached to the
style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Modifier Styles.

3 Select the wall modifier style that you want to change.

4 Click the General tab.

5 To add a description to the style, enter it for Description.

6 Click Notes.

7 To add a note, click the Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then …If you want to …

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

9 Click OK twice.

Working with Body Modifiers
Body modifiers use the 3-dimensional (3D) geometry of an object, such as a
mass element or a mass group, to add to, subtract from, or completely replace
one component in a wall. If the wall has only one component, the body
modifier applies to the entire wall. If the wall has multiple components, the
modifier applies only to the component that you specify.
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If you add the body modifier to a wall component, or use a body modifier to
replace the component, the body modifier uses the material assignment and
display properties of the wall component.

After you create a body modifier from an object, you can delete the original
object. However, if you have created a complex object, such as a mass group
comprising many mass elements, you may want to retain the object in the
drawing until you are sure you have the results you want for the wall.

Adding a Body Modifier to a Wall
Use this procedure to create a body modifier and add it to a wall. You can
apply the modifier to a single-component wall, or to a component in a
multi-component wall.

You can create a 3-dimensional (3D) body modifier from a mass element, a
mass group, or any other AEC object with mass. You can also create body
modifiers from ACIS solids or blocks that form 3D bodies. You must place the
object in the location you want in the drawing before defining the object as
a body modifier.

Adding a body modifier to a wall component

1 Place the object in the location where you want to add the body
modifier to the wall.

2 Select the wall to which you want to add the body modifier.
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3 Click Wall tab ➤ Modify panel ➤ Body Modifiers

drop-down ➤ Add  .

4 Select the object to add to the wall.

5 Select the wall component to add the object to.

6 Select Additive or Additive Cut Openings for Operation.

7 Enter a description for the body modifier.

8 Select Erase Selected Object(s) if you do not want to keep the
original object, or clear this option to keep the object in the
drawing.

9 Click OK.

Subtracting a Body Modifier from a Wall
Use this procedure to create a 3-dimensional (3D) body modifier and subtract
it from a wall. You can apply the modifier to a single-component wall, or to
a component in a multi-component wall.

You can create a body modifier from a mass element, a mass group, or any
other AEC object with mass. You must place the object in the location you
want in the drawing before defining the object as a body modifier.

Subtracting a body modifier from a wall component

1 Place the object in the location where you want to subtract the
body modifier from the wall.
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2 Select the wall from which you want to subtract the body modifier.

3 Click Wall tab ➤ Modify panel ➤ Body Modifiers

drop-down ➤ Add  .

4 Select the object to subtract from the wall.

5 Select the wall component to subtract the object from.

6 Select Subtractive for Operation.

7 Enter a description for the body modifier.

8 Select Erase Selected Object(s) if you do not want to keep the
original object, or clear this option to keep the object in the
drawing.

9 Click OK.

Replacing a Wall with a Body Modifier
Use this procedure to create a 3-dimensional (3D) body modifier and replace
a wall or a wall component with the modifier. You can apply the modifier to
a single-component wall, or to a selected component in a multi-component
wall.

You can create a 3D body modifier from a mass element, a mass group, or any
other AEC object with mass. You must place the object in the location you
want in the drawing before defining the object as a body modifier.

Replacing a wall component with a body modifier
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1 Place the object in the location where you want to replace the
wall with the body modifier.

2 Select the wall that you want to replace with the body modifier.

3 Click Wall tab ➤ Modify panel ➤ Body Modifiers

drop-down ➤ Add  .

4 Select the object to replace the wall or wall component.

5 Select the wall component you want the object to replace.

6 Select Replace for Operation.

7 Enter a description for the body modifier.

8 Select Erase Selected Object(s) if you do not want to keep the
original object, or clear this option to keep the object in the
drawing.

9 Click OK.

Editing the Geometry of a Body Modifier
Use this procedure to edit the shape of a body modifier that is attached to a
wall. You can edit the body using grips to edit faces, using Boolean commands
to add or remove other objects from the body modifier, and other editing
commands to change its shape.

1 Select the wall that has the body modifier you want to change.

2 Click Wall tab ➤ Modify panel ➤ Body Modifiers

drop-down ➤ Edit In Place  .

A temporary mass element is created for you to edit the geometry
of the body modifier. If the wall contains multiple body modifiers,
a mass element is created for each body modifier. If object was
not originally a mass element (for example, if you used a slab as
a body modifier), the object becomes a temporary Free Form mass
element with faces that you can edit.

NOTE After you perform an editing task, you may need to select a
profile again to perform another editing task.

3 Edit the body modifier:

Then …If you want to …

select the body modifier. Select a
Face grip to activate edge grips for

change the shape of a body modifi-
er that is a Free Form mass element

1288 | Chapter 21    Walls



Then …If you want to …

the face. Move the grips to the de-
sired locations. Continue editing
other faces in the same manner.

select the body modifier. Select
grips and move them to change the

change the shape of a body modifi-
er that is a conventional mass ele-
ment shape of the body modifier. The

grips that are available depend on
the type of mass element used as a
body modifier and the current view
direction.

place the object in the location
where it is needed. Select the body

add an object to a body modifier

modifier, and click Edit In Place

tab ➤ Modify panel ➤ Boolean

drop-down ➤ Union  . Select
the object, and press ENTER. Enter
y (Yes) to keep the object in the
drawing, or press ENTER to erase it.

place the object in the location
where it is needed. Select the body

subtract an object from a body
modifier

modifier, and click Edit In Place

tab ➤ Modify panel ➤ Boolean

drop-down ➤ Subtract  . Select
the object, and press ENTER. Enter
y (Yes) to keep the object in the
drawing, or press ENTER to erase it.

place the object in the location
where it is needed. Select the body

create a body modifier that is the
intersection of the original body
modifier with another object modifier, and click Edit In Place

tab ➤ Modify panel ➤ Boolean

drop-down ➤ Intersect  . Select
the object, and press ENTER. Enter
y (Yes) to keep the object in the
drawing, or press ENTER to erase it.
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Then …If you want to …

select the body modifier, and click

Edit In Place tab ➤ Modify pan-

trim a body modifier

el ➤ Trim By Plane  . Specify the
points that define the trim plane,
and select the side of the body
modifier to be trimmed. The
trimmed body modifier is converted
to a Free Form mass element.

select the body modifier, and click

Edit In Place tab ➤ Modify pan-

divide the face of a body modifier
into 2 faces

el ➤ Split Face  . Specify the
points that define the edge created
by splitting the faces.

select the body modifier, and click

Edit In Place tab ➤ Modify pan-

join 2 faces that are on the same
plane into a single face

el ➤ Join Faces  . Select the edge
that separates the coplanar faces.

select the object that forms the
body modifier, and press DELETE.

remove a body modifier

4 Save or discard the changes:

Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the body modifier to its ori-
ginal shape

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  . The body modifier

save the changes to the body
modifier

uses the edited mass element to
define its geometry.
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Managing Body Modifiers
Use this procedure to edit or remove 3-dimensional (3D) body modifiers from
an individual wall. You can change the component the body modifier is added
to and select a different operation. You can also enter or edit the descriptions
of body modifiers.

NOTE To remove a body modifier from a wall component and restore the modifier
as a mass element that you can edit or apply to other walls, see Restoring a Body
Modifier to a Mass Element on page 1292.

1 Double-click the wall you want to change.

2 Expand Advanced, and expand Worksheets.

3 Click the setting for Body modifiers.

4 Select a body modifier, and change its settings:

Then …If you want to …

select a different component for
Component.

apply the body modifier to a differ-
ent wall component

select a different operation for Op-
eration:

change the operation used to apply
the body modifier to the wall

■ Select Additive or Additive Cut
Openings to add the body
modifier to the wall compon-
ent.

■ Select Subtract to subtract the
shape of the body modifier
from the wall component.

■ Select Replace to replace the
wall component with the body
modifier.

select the body modifier, and click

 .

delete the body modifier from the
wall component

click Description, enter text, and
press ENTER.

enter a description of the body
modifier

5 Click OK.
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Restoring a Body Modifier to a Mass Element
Use this procedure to remove a body modifier from a wall and add it to the
drawing as a mass element. Restoring a body modifier to a mass element allows
you to modify the shape as a mass element and then add it to the wall again
as a body modifier. You can also restore the body modifier to a mass element
while leaving the body modifier still applied to the wall. This is useful if you
want to create other walls with the same shape.

If the object used to create the body modifier was a conventional mass element,
it is restored to that mass element. For example, a Gable mass element is
restored as a Gable mass element. However, if the body modifier was created
from another object, such as a slab, or was edited using Boolean operations
or face editing commands, the body modifier is restored as a Free Form mass
element.

1 Select the walls you want to change.

2 Click Wall tab ➤ Modify panel ➤ Body Modifiers

drop-down ➤ Restore  .

3 NOTE This procedure restores all body modifiers attached to a wall.

Create mass elements from the body modifiers:

Then …If you want to …

press ENTER.create mass elements from the body
modifiers while keeping the body
modifiers attached to the wall

enter y (Yes), and press ENTER.remove all body modifiers from the
wall, and create mass elements
from their shapes

Working with Interference Conditions
Interference conditions use the geometry of 3-dimensional (3D) objects to
create custom openings or cutouts in walls. You can specify how the
interference condition is applied to the shrinkwrapping of a wall: added to
the wall, subtracted to the wall, or ignored.
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How Interference Conditions Affect the Display of Walls

Unlike wall modifiers and body modifiers, which apply to a selected wall
component, interference conditions apply to all wall components that the
interfering object touches. The wall stops at the interference condition. The
way in which you apply the interference condition to the wall determines
how the shrinkwrapping of the wall is affected by the condition in plan view:

■ Add the interference condition to include the condition in the
shrinkwrapping.

■ Subtract the interference condition to exclude the object from the
shrinkwrapping.

■ Ignore the interference condition to draw the shrinkwrapping as if the
object were not there. You also use the ignore option to add interference
conditions applied to one wall to subsequent walls.

In model views, the interference condition is always subtractive, regardless of
the shrinkwrapping option you selected.

Editing Interference Conditions

When you edit the object that acts as the interference condition, the wall
changes to accommodate the changes to the geometry of the object. For
example, you can move the interfering object to change its location on the
wall. Moving the object off the wall does not remove the interference condition
for the object.
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You can also change how interference conditions are applied to a wall, and
you can delete interference conditions.

Adding an Interference Condition
Use this procedure to place objects, such as mass elements, in walls to create
custom openings or cutouts in the wall. An example is a column grid structure
where columns are connected by walls.

When you define the interference condition, you specify how the wall
shrinkwrapping in plan views is affected by the interfering object. You can
specify that the object be added to the wall, subtracted from it, or ignored.
The option you select affects the wall only in plan views. In model display
representations, interference is always subtracted from a wall, regardless of
the option you select in this procedure.

NOTE If you want to apply the same object as the interference condition for
multiple walls, such as walls that meet at a corner, use the ignore option for
subsequent walls after the first wall. In plan views, the effect is additive for all the
walls to which you apply the interference condition.

The shrinkwrap display component must be turned on in the display properties
of the wall or the wall style for interference to be visible. In most sample wall
styles provided with AutoCAD Architecture, shrinkwrap is turned on in plan
display representations. For more information about specifying shrinkwrapping
for a wall style, see Specifying the Display Properties of a Wall Style on page
1316.

1 Place the object in the location where you want to specify the
interference condition.

2 Select the wall to which you want to add an interference.

3 Click Wall tab ➤ Modify panel ➤ Interference drop-down ➤ Add

 .

4 Select the object intersecting the wall, and press ENTER.

5 Specify how shrinkwrapping in plan view is applied to the
interference condition:

Then …If you want to …

enter a (Additive).add the interference condition to
the shrinkwrapping
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Then …If you want to …

enter s (Subtractive).take the object shape out of the
shrinkwrapping

enter i (Ignore).ignore the object when shrinkwrap-
ping is applied

Removing an Interference Condition
Use this procedure to remove an object that was added to a wall as an
interference condition.

1 Select the walls you want to change.

2 Click Wall tab ➤ Modify panel ➤ Interference

drop-down ➤ Remove  .

3 Select one or more objects to remove, and press ENTER.

4 Enter r (Remove) to continue removing interference conditions
from other walls, or press ENTER to end the command.

Managing Wall Interference Conditions
Use this procedure to change the shrinkwrap effect for an interference
condition, or to remove an interference condition from a wall.

1 Double-click a wall with interference conditions.

2 On the Properties palette, expand Advanced, and expand
Worksheets.

3 Click the setting for Interference conditions.

4 Select an interference condition.

5 In the Shrinkwrap Effect column, specify the way shrinkwrap is
applied to the interference object:

Then …If you want to …

select Add.add the interference condition to
the shrinkwrapping

select Subtract.take the object shape out of the
shrinkwrapping
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Then …If you want to …

select Ignore.ignore the object when shrinkwrap-
ping is applied

6 To delete the interference condition, select the condition, and

click  .

7 Click OK.

Wall Styles
Wall styles control the appearance of wall objects. Using wall styles, you can
specify dimensions, components, endcaps, materials, and other characteristics
to create new types of walls, such as concrete walls, masonry walls, and brick
cavity walls. Catalogs provided with AutoCAD Architecture include sample
wall styles for common wall types, such as concrete walls with footings or
furring, CMU and brick cavity walls, and various stud partition walls.

Wall styles that use various components

Using Materials in Wall Styles

You can use materials to control how walls of each style are displayed in a
drawing. You assign materials to the wall components in the style. The
components are then displayed using the display properties of the assigned
materials.

AutoCAD Architecture provides a large number of predefined materials for
common design purposes. You can use these materials, modify them for your
project requirements, and define new materials. For more information about
materials and how to define them, see Materials on page 885.

Creating Tools from Wall Styles

You can create a wall tool from any wall style. You can drag the style from
the Style Manager onto a tool palette. You can then specify default settings
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for any walls created from the tool. For more information, see Creating a Wall
Tool on page 1250.

Managing Wall Styles

To create, edit, copy, or purge styles, you access the Style Manager. The Style
Manager provides a central location in AutoCAD Architecture where you can
work with styles from multiple drawings and templates. For more information
about using the Style Manager, see Style Manager Overview on page 870.

Creating a Wall Style
Use this procedure to create a wall style. By copying an existing style, you can
create a style using default style properties. After you create the style, you edit
the style properties to customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Architectural Objects, and expand Wall Styles.

3 Create a wall style:

Then …If you want to …

right-click Wall Styles, and click
New.

create a style with default properties

right-click the wall style you want
to copy, and click Copy. Right-click,
and click Paste.

create a style from an existing style

4 Enter a name for the new wall style, and press ENTER.

5 Edit the new wall style:

Then …If you want to …

click the General tab, and enter a
description.

enter a description of the style

see Applying a Wall Endcap Style to
a Wall Style on page 1402.

specify the endcap styles used for
wall openings and the ends of walls
of the style
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Then …If you want to …

see Specifying the Components of
a Wall Style on page 1299.

specify the structural components
of the style

see Specifying the Materials of a
Wall Style on page 1313.

specify materials for the compon-
ents of the style

see Specifying the Display Proper-
ties of a Wall Style on page 1316.

specify wall hatching, cut plane
properties, and other display prop-
erties of the style

see Adding Classifications to a Wall
Style on page 1322.

add classifications to a wall style

see Attaching Notes and Files to a
Wall Style on page 1323.

add notes and files to the style

6 When you finish specifying the properties of the wall style, click
OK.

7 If you want to assign the style to a wall tool, drag the style from
the Style Manager to a tool palette.

You can later rename the tool and specify other properties for it
as described in Creating a Wall Tool on page 1250.

8 Click OK.

Adding Property Set Data to a Wall Style
You can add property set data to a wall style. Property set data is necessary if
you want to tag a wall in a drawing later or include it in a schedule table.
Property set data typically attached to a wall style are automatic properties,
like wall height and wall width, or manual properties that are identical for all
walls of that style, like the fire rating. For detailed information about property
set data, see Property Set Definitions on page 3823.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Styles.

3 Select the wall style you want to change.

4 Click the General tab.

5 Click Property Sets.
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6 Click  .

If the Add Property Set button is deactivated, no property sets for
wall styles have been defined.

7 Select the property set you want to add to the style, and click OK.

The properties in the set are listed in the Edit Property Set Data
worksheet.

8 To remove a property set from a style, click  , clear the property
set from the list, and click OK.

9 Click OK.

Specifying the Components of a Wall Style
Wall components are the physical structures of the components of a wall,
such as concrete, CMU, studs, GWB, insulation, and air gaps.

Wall Components and Their Properties

Each component in a wall style corresponds to a structural component of a
wall or a wall material, including air gaps in cavity walls. When you create a
wall component, you specify the following characteristics of the component:

■ The component name, which usually identifies the material used, such as
brick, concrete, CMU, or insulation

■ The component cleanup priority, which determines how the component
cleans up with the components of intersecting walls

■ The width (thickness) of the component

■ The vertical offset of the component at the bottom and the top of the wall

■ The position of the component within the wall, relative to the baseline of
the wall and adjacent wall components

■ The function of the component within the wall. Possible functions are
structural and non-structural components.

■ The position of dimension points on the component. Wall components
can be dimensioned to the left and right edges and to the component
center.
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Using Components from Other Wall Styles

In addition to creating a wall component by specifying its individual properties,
you can also copy components from other wall styles into a wall style. The
Wall Component Browser is a utility that lets you view the components of
other wall styles and copy components into the wall style you are editing.

Dimensioning Wall Components

Each wall component can be dimensioned separately. In the wall style, you
define the settings for the dimensioning of the components. A wall component
can be dimensioned to its left and right edges, or to its center.

Wall components can be assigned a structural or non-structural function.
When the wall is dimensioned, you can choose to dimension all components,
or only structural components.

NOTE Additional settings for dimensioning wall components can be set in the
AEC dimension style. Here, you can dimension a multi-component wall to its entire
width and to the overall wall center. For more information, see Dimension Points
for Walls on page 3393 and Specifying Object Dimension Points in AEC Dimension
Styles on page 3460.

Components Tab

The Components tab of the Wall Styles dialog lets you view wall components
as you specify them.

Specifying the properties of wall components
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Use the features of the Components tab for the following tasks:

■ Add, remove, and edit the properties of wall components for wall style.

■ View the components as you specify them.

■ Change the order of components relative to other components in the wall
style.

■ Access the Wall Style Components Browser, which lets you view and copy
components from other wall styles in the current drawing and in other
drawings.

Wall Style Components Browser

The Wall Style Components Browser is a utility that lets you view and copy
wall components from wall styles in the current drawing and in other drawings.
You can copy components from these styles to the current wall style. After
you add them to the wall style, you can change their properties as needed for
the style you are editing.

Viewing wall components from multiple styles and drawings

The Wall Style Components Browser has the following features:

To …Use this feature …

open other drawings, copy wall compon-
ents, and change the view options for the
right pane of the browser.

icons
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To …Use this feature …

expand wall styles to view the list of com-
ponents in the style. Select a wall style in

tree structure in the left pane of the
browser

the left pane to view the properties of its
components and see the wall style in the
right pane. You can use the context menu
to copy an individual component or all
components of a selected style. You can
then paste the component(s) in the style
you are editing.

view the component properties of a selec-
ted style, and preview the style in the
viewer area of the pane.

right pane of the browser

Default Cleanup Priorities of Wall Components
The component priority determines how each wall component cleans up with
the components of an intersecting wall. The lower the component index
number, the higher the priority of the component when it intersects other
walls.
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Wall cleanup priorities

The following table lists the default cleanup priority for components used in
sample wall styles provided in AutoCAD Architecture catalogs. You can assign
different priorities to wall components in wall styles and individual walls to
control cleanup with other walls.

IndexComponent

700Air Gap

805Air Gap (Brick/Brick)

305Air Gap (CMU/CMU)

505Air Gap (Stud/Stud)

800Brick

810Brick Veneer

1800Bulkhead

Specifying the Components of a Wall Style | 1303



IndexComponent

2030Casework - Backsplash

2010Casework - Base

2020Casework - Counter

2000Casework - Upper

300CMU

350CMU Veneer

200Concrete

200Concrete (Footing)

1200Glass

1200GWB

1200,1210,1220,1230GWB (X)

600Insulation (CMU/Brick, Stud/Brick)

1000Metal Panel

400Precast Panel

404Rigid Insulation (Brick)

900Siding

1100Stucco

500Stud

3000Toilet Partition
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Creating or Editing a Component in a Wall Style
Use this procedure to create a wall component, or to edit existing wall
components in a wall style.

You can also add components to a wall style by copying them from other wall
styles. For more information, see Adding a Component from Another Wall
Style on page 1307.

NOTE Only the first 20 components of a wall style are controlled by the display
system. Although you can specify more than 20 components in a wall style, it is
suggested that you limit the number of components to 20. Components 21 and
higher are controlled by material assignment only.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Styles.

3 Select the wall style that you want to change.

4 Click the Components tab.

5 Click  .

6 Enter a name for the new component.

7 Enter the cleanup priority for the component when walls intersect.

The lower the priority number, the higher the priority of the
component when it intersects with the components of other walls.
For more information, see Default Cleanup Priorities of Wall
Components on page 1302.

8 Specify the width of the component:

Then …If you want to …

enter a value for Width.specify a fixed width that cannot
be edited when you add or edit
walls of this style

select the setting for Width. Enter
a formula that defines how the

specify a variable width that can be
edited when you add or edit walls
of this style component width is calculated. For

more information, see Specifying
the Width and Edge Offset of a Wall
Component on page 1412.
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Adding the first wall component

9 Specify the edge offset, which is the offset of the exterior edge of
the component from the baseline:

Then …If you want to …

select the component, select 

or  to offset the component by

graphically specify the offset

an increment that you specify. The
viewer shows the position of the
wall component as you click the
icons. The selected component is
highlighted in green.

select Auto Calculate Edge Offset.let the software calculate the offset

enter a value for Edge Offset.specify a fixed offset

select the setting for Edge Offset.
Enter a formula that defines how

specify a variable offset that is calcu-
lated from values that you specify

the edge offset is calculated for this
component. For more information,
see Specifying the Width and Edge
Offset of a Wall Component on
page 1412.

10 To specify the top elevation offset or bottom elevation offset,
enter a new value, and select from where the distance is to be
measured: Wall Top, Base Height, Baseline, or Wall Bottom.

NOTE Do not define wall components with elevation offsets that are
above Wall Top or below Wall Bottom. Walls that have components
that are defined this way do not clean up correctly and may not be
displayed correctly if you edit their roof line or floor line. To avoid
cleanup and display problems, you can define wall components with
elevation offsets that are above Base Height or below Baseline.
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11 Repeat steps 5 through 10 to add more components to the wall
style.

Adding the second wall component

12 To change the order of components in the wall style, select a wall

component, and click  or  to move the component to the
desired position relative to the other wall components.

13 Click OK.

Adding a Component from Another Wall Style
Use this procedure to copy one or more wall components from another wall
style into the wall style you are editing.

NOTE Only the first 20 components of a wall style are controlled by the display
system. Although you can specify more than 20 components in a wall style, it is
suggested that you limit the number of components to 20. Components 21 and
higher are controlled by material assignment only.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Styles.

3 Select the wall style that you want to change.

4 Click the Components tab.

5 Click  .

The Wall Style Components Browser lists the wall styles and their
components in the current drawing.

6 Locate the wall components you want to copy:

Then …If you want to …

in the left pane, select a wall style.
The right pane lists the components

view the wall components for wall
styles in the current drawing
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Then …If you want to …

and their properties and displays
the style in the viewer.

click  . Navigate to the drawing
you want, and click Open. In the
left pane, select a wall style.

view the wall components in wall
styles in other drawings

select the drawing name, right-
click, and click Close. You cannot
close the current drawing.

close a drawing that you opened in
the browser

For more information about the information shown in the Wall
Styles Component Browser, see Specifying the Components of a
Wall Style on page 1299.

7 Copy wall components, and add them to the wall style you are
editing:

Then …If you want to …

select the wall style, and drag the
style to the list of components in

copy all components in a wall style

the Style Manager. All the compon-
ents are added to the wall style.

select the wall component, and
drag the component to the list of

copy an individual wall component

components in the Style Manager.
The component you selected is ad-
ded to the wall style.

8 Click  to close the Wall Style Components Browser.

9 After you copy wall components to the current wall style, you
can edit or delete the new components as needed.

For more information, see Creating or Editing a Component in a
Wall Style on page 1305.

10 Click OK.
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Defining the Dimension Settings for Wall Components
You have various options for dimensioning individual wall components. In
the wall style, you can define the dimension settings for each individual wall
component. Each component can be dimensioned to one or both of its edges,
as well as to the component center. You also can select to not dimension a
specific component at all.

■ Component side to dimension: In the wall style, you can define for each
wall component whether it should be dimensioned to its positive or
negative side, or to the center of the component. The positive and negative
sides of a wall are determined by the direction in which the wall is drawn:
if you draw a wall from left to right, the positive side is the left (top). If
you draw a wall from the right side to the left, then the positive side is the
right (bottom). If you determine that a wall component is only
dimensioned to one side, you can select either the positive or negative side
of the wall

.

■ Structural Function: You can define a wall component as structural or
non-structural. When you set up the AEC dimension style you can define
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that only structural wall components, or all wall components should be
dimensioned.

Alternatively, you can select to dimension a multi-component wall not to
each individual component, but to the overall wall width or the overall wall
center. You set these points in the AEC dimension style, as described in
Specifying Object Dimension Points in AEC Dimension Styles on page 3460.

In the AEC dimension style you can define the following additional or
overriding settings for dimensioning wall components:

■ By Style: the dimension points selected in the wall style are used to
dimension the wall components width.

■ Structural by Style: the dimension points specified for the structural
components of the wall style are used.

■ Overall: the overall width of the wall is dimensioned.
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■ Center: the center of the wall is dimensioned.

Defining the dimensioning of components

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Styles.

3 Select the wall style that you want to change.

4 Click the Components tab.
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5 Define if the positive and negative sides of the wall should be an
interior or exterior wall side by selecting Interior or Exterior for
(+) and (-).

6 To define an offset for a wall component, select the component
in the list view, and enter a value for Offset Increment.

Alternatively, you can use the arrow keys.

7 Under Function, select if the component is a structural component
or a non-structural one.

This distinction is important when creating a dimension style for
a multi-component wall, as you can define in the dimension style
that it only dimensions structural components.

You can also leave the component function as unspecified.

8 To specify the dimension settings for a wall component, verify
that the component is selected in the list view.

NOTE The component selected is highlighted in the graphic on the
left.

9 Under Dimension, select if the component should be dimensioned
to one side, to both sides, or to the center of the component.

■ To dimension the component only to one side check the mark

under  or  depending on whether you want to
dimension the component to the left or right side.

■ If you want to dimension the component to both sides, check

both marks for  and  .

■ If you want to dimension the component to its center, check

the mark for  .

10 Click OK to finish setting up component dimensioning in the
wall style.

For information on creating a dimension style for wall
components, see Specifying Object Dimension Points in AEC
Dimension Styles on page 3460.
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Removing a Component from a Wall Style
Use this procedure to delete a component from a wall style. When you remove
a component from a wall style, the component is also removed from all existing
walls that use this style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Styles.

3 Select the wall style that you want to change.

4 Click the Components tab.

5 Select the wall component you want to remove, and click  .

6 Click OK.

Specifying the Materials of a Wall Style
A wall consists of a number of components whose display properties can be
determined by the materials assigned to each component. When you assign
materials to a wall style, you assign one material to each physical component
of the wall. For example, you assign a wood or metal material to studs, concrete
to a concrete component, and so on. You assign materials to components in
each display representation where you want the materials to be used.

If you want to use the display properties of the wall style, instead of using
material display properties, you can turn off the material assignments in the
display properties of the wall style.

Material definitions consist of display components that correspond to
component types of objects. For example, the Linework component of a
material is used for all linework in plan view. The Surface Hatch component
of a material is used to hatch all object surfaces in 3-dimensional (3D) model
views and in elevations.

Wall Materials and Display Components
The following table identifies the material component that corresponds to
each wall component.

Material ComponentWall Component

Plan, Plan Low Detail, Plan High Detail, Plan
Presentation, Plan Screened
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Material ComponentWall Component

No MaterialBelow Cut Plane

No MaterialAbove Cut Plane

2D LineworkShrink Wrap

Plan HatchShrink Wrap Hatch

Plan LineworkBoundary 1 - 20

Plan HatchHatch 1 - 20

Reflected, Reflected Screened

No MaterialBelow Cut Plane

No MaterialAbove Cut Plane

2D LineworkShrink Wrap

Plan HatchShrink Wrap Hatch

Plan LineworkBoundary 1 - 20

Plan HatchHatch 1 - 20

Model, Model High Detail, Model Low
Detail

3D BodyShrinkwrap Body

3D BodyBoundary 1 - 20

Sketch

No MaterialBaseline

No MaterialMarker

No MaterialCenter Line
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Material ComponentWall Component

Graph

No MaterialRadius

No MaterialEdge

Assigning Materials to a Wall Style
Use this procedure to assign materials to the individual components of a wall
style. When you assign a material to a wall component, the component uses
the display properties of the material instead of the style display properties.

You can assign a material to any physical component of the wall. Custom
components and components that are only symbolic graphics do not use
materials for their display properties. For example, all structural components,
such as brick and other masonry, studs, insulation, and air gaps, are physical
components that you can assign materials.

NOTE If a material assignment does not determine the display properties of a wall
component, you can change the display properties of the wall style as described
in Specifying the Display Properties of a Wall Style on page 1316.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select By Material for any component to which you want to assign
a material, and click OK.

If the setting for By Material is not available, the display of this
component cannot be determined by a material.

9 Click the Materials tab.
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10 Select the component you want to change, and select a different
material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Although you can edit a material definition from this
dialog, any changes you make to the material definition apply to all
objects that are assigned the material.

11 Click OK.

Specifying the Display Properties of a Wall Style
In most cases, you can assign materials to wall components so that the
appearance of walls that belong to the same style is consistent throughout a
drawing and with other walls and objects that use the same materials.

If a component cannot be assigned a material, or if you do not want to use
materials but still want consistency among walls of the same style, you can
specify the display properties of the wall components in the wall style:

■ The layer, color, and linetype of wall components

■ The hatching used with each component

■ The cut plane height and the display of components relative to the cut
plane

■ Other specific wall display information, such as whether complex endcaps
are displayed and whether the wall is cut around door and window frames

Specifying the Layer, Color, and Linetype of a Wall Style
Use this procedure to change the following display properties of the
components of a wall style:

■ Visibility (component is on or off)

■ By material (material assigned to the display component determines its
display properties)

■ Layer
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■ Color

■ Linetype

■ Lineweight

■ Linetype scale

To change these display properties for an individual wall, see Changing the
Display Properties of Individual Walls on page 1238.

NOTE If a material assignment determines the display properties of components
in the wall style, you can change the properties of the display component by
clearing By Material. You can also override the material assignment with a different
material. For more information, see Assigning Materials to a Wall Style on page
1315.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Styles.

3 Select the wall style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select the component to change, and select a different setting for
the property.

9 Click OK.

Specifying the Hatching for Components of a Wall Style
Use this procedure to specify the hatching of the components of a wall style.
Wall hatching is displayed only in display representations, such as Plan, that
are used in the Top view (plan view) of a drawing.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Styles.

3 Select the wall style that you want to change.

4 Click the Display Properties tab.
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5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Hatching tab.

8 Select a component, and click the setting for Pattern.

9 Select the hatching for the component:

Then …If you want to …

select Predefined for Type, and then
select a pattern.

select a hatching pattern that is
available in the software

select Custom for Type, and then
enter the name of the custom pat-

select a custom pattern

tern. If necessary, click Browse, and
navigate to the folder where the
custom pattern file is located.

select User-defined for Type, and
clear Double Hatch.

select single hatching

select User-defined for Type, and
select Double Hatch.

select double hatching

select Solid Fill for Type.select solid fill

10 Click OK.

11 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

12 Click Angle, and enter the angle for the selected pattern.

13 Click Orientation, and specify how the hatching is oriented:

Then …If you want to …

select Object.orient the hatching to the object,
regardless of the object rotation

select Global.orient the hatching to the World
Coordinate System

14 Click OK.
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Specifying the Cut Plane Display of a Wall Style
Use this procedure to specify the properties of one or more cut planes for a
wall style. Cut plane display properties apply only to display representations,
such as Plan, that are used in the Top view (plan view) of a drawing.

To better visualize the elements of a wall in plan view, you can create cut
planes. The main cut plane is where the shrinkwrap and hatching are applied.
The plan display shows the components and objects in the wall as they are
displayed at the height of each cut plane.

The cut plane settings you specify in the wall style override the cut plane
settings in any display configuration applied to a viewport. When you add
doors, windows, openings, or door/window assemblies to a wall, you can
specify in the display properties of those objects or their styles whether they
respect the cut plane of the wall or of the display configuration.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Styles.

3 Select the wall style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Cut Plane tab.

8 Select Override Display Configuration Cut Plane.

9 To specify the cut plane where shrinkwrap, component
boundaries, and hatching take effect, enter a value for Cut Plane
Height.

10 Select Automatically Choose Above and Below Cut Plane Heights
to show the components above and below the cut plane height.

11 To specifically define a cut plane, select Manual Above and Below
Cut Plane Heights, click Add, and enter the height of the new cut
plane.

Then …If you add a cut plane …

objects are displayed using the
properties specified for the Below

at a height that is lower than the
value for Cut Plane Height

Cut Plane component on the Lay-
er/Color/Linetype tab.
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Then …If you add a cut plane …

objects are displayed using the
properties specified for the Above

at a height that is higher than the
value for Cut Plane Height

Cut Plane component on the Lay-
er/Color/Linetype tab.

You can click Remove to delete a cut plane that you added.

12 Click OK.

Specifying the Display of Other Characteristics of a Wall Style
Use this procedure to specify other display properties for the wall style, such
as whether to display complex endcaps, to show door and window frames, or
whether to show the miter of specific wall components. These display
properties apply only to display representations, such as Plan, that are used
in the Top view (plan view) of a drawing.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Styles.

3 Select the wall style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 Select the display properties for the wall style:

Then …If you want to …

select Display Inner Lines Above.
Clear this option if you do not want
to display these lines.

display the component lines within
the wall above the cut plane (for
example, through a window or
door in the wall)

select Display Inner Lines Below.
Clear this option if you do not want
to display these lines.

display the component lines within
the wall below the cut plane (for
example, through a window or
door in the wall)
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Then …If you want to …

select Hide Lines Below Openings
at Cut Plane. Clear this option if you
want to display the lines.

turn off lines below a window, door
or opening at the cut plane

select Hide Lines Below Openings
Above Cut Plane. Clear this option
if you want to display the lines.

turn off lines below a window, door
or opening above the cut plane

select Display Endcaps. Clear this
option to display complex endcaps
as a single line.

display complex wall and opening
endcaps

select Cut Door Frames. Clear this
option if you want door openings

display door openings cutting the
wall at the outer edge of the door
frame to cut the wall at the inside of the

door frame.

select Cut Window Frames. Clear
this option if you want window

display window openings cutting
the wall at the outer edge of the
window frame openings to cut the wall at the in-

side of the window frame.

select Component Draw Order by
Priority. Clear this option if you

draw wall components by their pri-
ority number to control the display

want to draw the components in
the order that they were created.

of a component over another com-
ponent

select Do True Cut. Clear this op-
tion if the wall does not have

perform a slice of the actual 3-di-
mensional (3D) model at each cut

sweeps or body modifiers, or if theyplane to obtain more accurate views
do not change along the height of
the wall.

of walls with sweeps or body modi-
fiers

under Draw Miter for Components,
select each component whose miter
lines you want to display.

display miter lines at wall corners
for selected wall components

9 Click OK.

Specifying the Display Properties of a Wall Style | 1321



Adding Classifications to a Wall Style
Use this procedure to specify classifications for any classification definition
applied to a wall style.

For more information about creating and applying classification definitions,
see Classification Definitions on page 3872.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Styles.

3 Select the style that you want to change.

4 Click the Classifications tab.

By default, the classification for all classification definitions is
Unspecified. If no classification definitions are listed, none are
applied to wall styles.

5 For each classification definition, select the classification you want
to apply to the current wall style.

6 Click OK.

Defining a Wall Style as Bounding for Associative Spaces
Use this procedure to define a wall style that can bound associative spaces.

When a wall style is set as bounding, by default all walls that have the style
assigned will be used in the selection set for an associative space. For more
information about associative spaces see Generating Associative Spaces on
page 2940.

You can override the bounding settings from the wall style in an individual
wall, if necessary.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Styles.

3 Select a wall style.

4 Click the General tab.

5 Select the check box for Objects of this style may act as a boundary
for associative spaces.

6 Click OK.
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Attaching Notes and Files to a Wall Style
Use this procedure to enter notes and attach reference files to a wall style. You
can also edit notes and edit or detach reference files from a wall style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Wall Styles.

3 Select the wall style you want to change.

4 Click the General tab.

5 To add a description to the wall style, enter it for Description.

6 Click Notes.

7 To add a note, click the Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then …If you want to …

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

9 Click OK.

Workflow for Cleaning Up Wall Intersections
Use intelligent cleanup to manage wall intersections.You can assign walls to
a cleanup group when you create the walls or after you create the walls.

Hold the cursor over the solution tip icon on page
59, review the suggestions provided, and try the
tips on page 1343.

-----Read the solution tips
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Toggle on the Wall Justification Lines and Cleanup
Circles on page 1333 and verify that the wall
justification lines of both wall segments intersect.

-----Turn on the wall justification line

Use the Working with Intelligent Cleanup on page
1324 feature to evaluate and correct your wall
intersection issues.

-----
Use Intelligent Cleanup for
intersections

Use the Cleanup Edit in Place  on page 1354 feature
to correct a single instance of a wall intersection
issue, including intersection wall components.

-----
Use Edit in Place to edit specific
wall conditions

Working with Intelligent Cleanup
Use the intelligent cleanup feature to clean up wall intersections. Non-collinear
wall segments are trimmed or extended to result in clean corners. Select the
wall segments and specify a cleanup method. In general, when you select a
boundary, a T-cleanup results. If no boundary is selected, an L-cleanup results.

Cleanup conditions are determined by the justification lines for the wall
segments, and the size of the cleanup circles located at the start and endpoints
of each justification line. For information about wall justification lines and
cleanup circles, see Wall Justification Lines and Cleanup Circles on page 1333.
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Use intelligent cleanup to create an L joint with 2 wall segments.

Use intelligent cleanup to create a T joint with 2 wall segments.

Using Intelligent Cleanup for L Intersections
When working with intelligent cleanup for L intersections, the following rules
apply:

■ L-cleanup works with 2 non-collinear wall segments at a time.

■ The wall segments can be any distance apart, as long as they have a possible
intersection.

■ When an improper cleanup condition occurs, a tip displays to suggest
possible solutions.
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■ Wall segments clean up when their respective wall justification lines
intersect cleanly with each other.

■ Wall segments that do not intersect are extended to meet in a clean corner
condition with intersecting wall justification lines.

■ Wall segments that intersect are trimmed to meet in a clean corner
condition with intersecting wall justification lines.

1 Use the following procedure to clean up an L intersection.

Select the wall segments to include in the wall cleanup.

2 Click Wall panel ➤ Cleanup tab ➤ Intelligent Cleanup  .

1326 | Chapter 21    Walls



3 Press ENTER for L-cleanup.
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L-cleanup works the same way for arc wall segments.

Using Intelligent Cleanup for T Intersections
When working with intelligent cleanup for T intersections, the following rules
apply:

■ T-cleanup works by specifying a boundary wall segment for selected wall
segments.

■ The wall segments can be any distance apart, as long as they have a possible
intersection.

■ When an improper cleanup condition occurs, a tip displays to suggest
possible solutions.

■ Wall segments clean up when their respective wall justification lines
intersect cleanly with each other.

■ T-cleanup works for multiple wall intersections, but only one wall segment
may be specified for the boundary.
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Use the following procedure to clean up a T intersection.

1 Select the wall segments to include in the wall cleanup.

2 Click Walls panel ➤ Cleanup tab ➤ Intelligent Cleanup  .

3 Select a boundary for T-cleanup.
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T-cleanup works the same way for arc wall segments.

Using Intelligent Cleanup for Multiple Wall Intersections
When cleaning up multiple wall intersections, projected walls are trimmed
or extended to adjacent walls that can act as boundary walls. Only selected
wall segments participate in cleanup.
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When a projected wall segment intersects a boundary wall, the shorter wall
segment is trimmed. Since the projected wall distance 1 is shorter than the
projected wall distance 2, the projected wall 1 segment is trimmed.

If the projected wall distance is less than half of the total distance between
boundary walls, the wall is trimmed to the first boundary wall. If the projected
wall distance is equal to or more than half of the total distance between
boundary walls, the wall is extended to the second boundary wall.
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Clean up multiple wall intersections by selecting all of the wall segments.
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Wall Justification Lines and Cleanup Circles
Wall justification lines and cleanup circles are features of wall objects that are
used to determine the cleanup conditions. Cleanup circles display for walls
only in the Diagnostic display representation, or when you turn on the display
of wall justification lines.

Displaying Wall Justification Lines and Cleanup Circles

The Diagnostic display representation displays the wall segment’s justification
line, cleanup circle radius, and direction glyph to help you troubleshoot wall
cleanup issues. On the drawing status bar, click Display Representation  ➤ 

Diagnostic.

A cleanup circle is located at the start point and the endpoint of each wall
segment. The center point of each cleanup circle is the start point or endpoint
of the wall justification line.

The cleanup circle radius determines the size of the cleanup circle. You can
specify a cleanup circle radius in the wall tools you use to add walls to a
drawing. If needed, you can override the default cleanup circle radius at each
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end of a wall segment. This allows you to adjust the cleanup circle radius for
particular wall styles and for individual situations.

You can also turn on the display of justification lines without switching to
the Diagnostic display representation. Select a wall segment and click Wall
panel ➤ Cleanup tab ➤ Justification Display.

Justification lines and cleanup circles display on all walls in the drawing. In
addition, when you select a wall, Cleanup Radius grips are displayed at each
cleanup circle. Move the grip to increase or decrease the cleanup circle radius.

NOTE Zero-radius cleanup circles do not display.
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Cleaning Up Wall Intersections with Dynamic Cleanup Radius

You can preview the wall intersection cleanup condition between 2 or more
unconnected wall segments by adjusting the radius of the cleanup circle that
is closest to the intended intersection.

1 Enable hardware acceleration. See Manual Performance Tuning
Dialog Box for more information.

2 At the command prompt, enter AecDynamicCleanupRadius.

3 Enter ON.

4 Select a wall segment and turn on wall justification lines. See Wall
Justification Lines and Cleanup Circles on page 1333 for more
information.

5 Select the cleanup radius grip and drag it until the cleanup circle
encompasses both wall segments.

A preview of the cleaned up intersection displays in cyan inside
of the cleanup circle.

6 Click to set the size of the new cleanup circle radius and accept
the previewed cleanup condition.
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Wall Cleanup Conditions

Walls in the same cleanup group clean up when one of the following
conditions applies:

■ The cleanup circle of one wall overlaps the center point of the cleanup
circle of another wall.

■ The cleanup circle of one wall overlaps the wall justification line of another
wall.

Wall cleanup with justification line intersecting cleanup circle

■ The wall justification line of one wall intersects the wall justification line
of another wall.

Wall cleanup with intersecting justification lines

TIP The best practice for successful wall intersection cleanup is to ensure that the
wall segment justification lines intersect and that you specify a zero (0) radius for
the wall segment cleanup circles.

When walls intersect and clean up properly, a new wall joint is created at the
intersection of the wall justification lines. The exact location of the wall joint
depends on the location of the new wall segment endpoint. In many cases,
the wall joint location does not coincide with the existing wall segment center
line. The location of the wall joint is based on a weighted average distance
between wall segment endpoints, as well as the thickness of the wall segments.
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Wall justification lines and wall joint at wall intersections

Wall Cleanups and Priorities
Walls with multiple components clean up based on the priority assigned to
each component and the location of each component within the wall.
Matching component edges with the same priority are extended or trimmed
to their intersection points. Components with a higher priority (a low priority
number) cut through components with a lower priority (a high priority
number).
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Wall cleanup priorities

To identify the default cleanup priorities for the components used in the
sample wall styles provided with AutoCAD Architecture, see Default Cleanup
Priorities of Wall Components on page 1302.

The software calculates and performs wall cleanups in the following sequence:

1 Component information is gathered from the wall graph:

■ Endcaps are calculated. If an endcap does not fit in the section,
a solution tip icon displays. For more information, see
Troubleshooting Wall Cleanups on page 1343.

■ Sides of components are combined with endcaps to produce
a component profile (like a 2-dimensional region).

■ If this profile is self-intersecting, a solution tip icon displays.

2 Adjacent higher priority components are gathered from the wall
graph from neighboring wall segments.

3 Higher-priority component profiles are subtracted from the
lower-priority component profiles.
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4 Doors, windows, openings, and interferences are cut and/or
applied.

5 Shrinkwrap may be calculated and hatching applied.

A failed shrinkwrap calculation may also result in the display of
a solution tip icon.

6 Graphics are drawn to an output device (for example, the
AutoCAD screen, Object Viewer, Osnap stream, explode stream,
and a plotter).

7 Solutions are cached for subsequent draw requests until the wall
is modified again.

Guidelines for Successful Wall Cleanup
When cleanup settings or the placement of a wall segment are preventing
correct wall cleanup, a solution tip icon displays to indicate the location of
the problem and provide possible solutions.

Here are some recommendations for actions you can take to achieve successful
wall cleanup:

■ Wall justification lines should intersect.

■ Use a smaller cleanup circle radius. A small cleanup circle radius also makes
the graph display more readable. The cleanup circle radius should be a
value that is between one-half the wall width and the overall wall width.

NOTE A wall segment must be longer than its cleanup circle radius.

■ Look for very short wall segments. You can find these short segments by
turning on the Diagnostic display representation. You can fix them by
adjusting the baselines or by increasing the cleanup circle radii.

■ Draw walls with center justification on and use an offset to simulate right
or left justification. Using this method, you can draw very short segments
and tight wall jogs, provided the appropriate cleanup circle radius is used.
For more information about wall justification, see Changing the Wall
Justification on page 1207.

■ In order to ensure that exterior walls clean up properly with interior walls,
switch the justification lines in the exterior wall segments to the inside so
that the interior wall segment justification lines intersect.
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Assigning a Different Wall Cleanup Group Definition to Existing
Walls

Use this procedure to change the wall cleanup group assigned to existing walls.
Assigning different cleanup groups is useful when you want to prevent 2 walls
from cleaning up with each other. To create a new cleanup group, see Cleanup
Group Definitions on page 1351.

1 Select the walls to change, and double-click one of them.

2 On the Properties palette, expand Basic, and then expand General.

3 Select a cleanup group for Cleanup group definition.

Specifying Cleanup for Individual Walls
Use this procedure to specify the following cleanup settings for one or more
walls:

■ Whether the wall cleans up with other walls.

■ The cleanup group for the wall.

■ Whether the justification line position corresponds to the center line of
the wall or to the wall justification.

■ The cleanup circle radius for both ends of the wall, or separate values for
the start and endpoints of the wall.

1 Select the walls you want to change, and double-click one of them.

2 On the Properties palette, expand Basic, and then expand General.

3 Turn wall cleanup on or off:

Then …If you want to …

select No for Cleanup automatically.
If you select this option, you do not
need to specify other settings.

turn off wall cleanup so that the
walls do not clean up with any
other walls

select Yes for Cleanup automatic-
ally, and proceed to step 4.

turn on wall cleanup and specify
cleanup settings

4 Select a cleanup group definition.
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The walls will clean up with other walls that also belong to the
cleanup group definition that you select.

5 Expand Advanced, expand Cleanups, and expand Cleanup Radius
Overrides.

6 Specify the cleanup circle radius for the walls:

Then …If you want to …

enter a value for Cleanup radius,
and verify that No is selected for

specify the same cleanup circle radi-
us for the start and endpoints of the
walls Override start cleanup radius and

Override end cleanup radius.

select Yes for Override start cleanup
radius, and enter a value for Start
cleanup radius.

specify a cleanup circle radius for
the start point of the walls

select Yes for Override end cleanup
radius, and enter a value for End
cleanup radius.

specify a cleanup circle radius for
the endpoint of the walls

Start and End are based on the direction the wall was drawn. If
you enter zero for any cleanup circle radius, the wall justification
lines need to touch for the walls to clean up with other walls.

Overriding the Wall Cleanup Circle Radius
Use this procedure to override the default wall cleanup circle radius at one
end of a wall. You can also override the cleanup circle radius on the Properties
palette and using the context menu for the selected wall.

1 If the wall justification line is not displayed, select a wall, and

click Wall tab ➤ Cleanup panel ➤ Justification Display  .

2 Select a Cleanup Radius grip, and move the grip until you have
properly resized the cleanup circle.

If Dynamic Input is active, move the grip until the dimension
you want is displayed.
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Changing the cleanup circle radius at one end of a wall

Overriding Component Priorities
Use this procedure to change the priority of a wall component so that when
it intersects with another wall, it has higher or lower priority than its
counterpart on the other wall. The lower the priority number you enter, the
higher the priority of the component when the wall intersects with another
wall.

For the list of default priorities of the wall components used in sample wall
styles provided with AutoCAD Architecture, see Default Cleanup Priorities of
Wall Components on page 1302.

1 Double-click the wall you want to change.
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2 On the Properties palette, expand Advanced, and then expand
Style Overrides.

3 Click the setting for Priority overrides.

4 Add or edit a priority override for a wall component:

Then …If you want to …

click  , and proceed to step 5.
add a new priority override

proceed to step 5.edit a priority override

select the priority override you want

to delete, and click  .

delete a priority override

5 Specify the override settings:

Then …If you want to …

select a different component.change the component to which
you assigned the override

select the component, select At
start of wall, and enter a value for
Priority.

specify a priority override at the
start of the wall

select the component, select At end
of wall, and enter a value for Prior-
ity.

specify a priority override at the end
of the wall

select the value for Priority, and
enter a new value.

change the priority of an existing
override

6 Click OK.

Troubleshooting Wall Cleanups
This topic provides more details about the solution tips displayed when
problems are detected with wall cleanup or display. Answers are also provided
for common questions associated with wall cleanups.
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Solution Tips for Walls
When you move the cursor over a solution tip icons on a wall, any of the
following problem statements may display:

NOTE Not all problems that generate solution tips have an easily identifiable cause
or a specific solution. This is often true in the case of Boolean operations where
an entity such as a body modifier is added to or subtracted from an object. In
these cases the solution tip identifies the kind of object or component involved
and suggests corrective action. You may be advised to modify the location or the
geometry of the object, but it is essentially a trial-and-error approach. The messages
are tips rather than guaranteed solutions.

The walls are not cleaning up correctly

As described under Guidelines for Successful Wall Cleanup on page 1339, there
are various conditions that can prevent cleanup. The first step in determining
the cause of this problem is to examine the condition of the wall justification
lines at the intersection. To display the justification line for a wall, select the

wall, and click Wall tab ➤ Cleanup panel ➤ Justification Display  . (For
more information, see Wall Justification Lines and Cleanup Circles on page
1333.)

After looking at the justification lines, try one of the following possible
solutions, as applicable:

■ Extend or trim the walls using the AutoCAD Extend or Trim commands.

■ With the wall selected, on the Wall tab ➤ Cleanup panel, click L Cleanup

 or T Cleanup  . For more information, see Using Intelligent Cleanup
for L Intersections on page 1325 or Using Intelligent Cleanup for T
Intersections on page 1328.

■ Increase the wall cleanup radius by grip-editing (see Working with
Intersections and Small Cleanup Circle Radii on page 1348) or by changing
the value of Cleanup radius on the Properties palette (see Specifying
Cleanup for Individual Walls on page 1340).

■ With the wall selected, click Wall tab ➤ Cleanup panel ➤  ➤ Add Wall

Merge Condition  . For more information, see Merging Walls on page
1214.
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The wall’s endcaps or opening endcaps cannot be displayed due to space
limitations

If there is insufficient space to display an endcap, you can either modify the
wall to provide more space, or you can modify the endcaps to reduce the
amount of space required. Note that some endcap problems are evident only
in 3D (isometric) views, so you may need to switch to model space in order
to see and resolve the problem. Then, depending on your design requirements,
do any of the following:

■ Lengthen the wall (see Changing the Shape of a Wall on page 1199).

■ Remove one or more endcaps (see Modifying the Geometry of a Wall
Endcap Style on page 1403).

■ Modify the wall endcap style or opening endcap style to require less space
(see Modifying the Geometry of a Wall Endcap Style on page 1403).

The wall cannot be displayed because it does not extend beyond its own
cleanup radius or that of an adjacent wall.

In this case, you need to reduce the cleanup radius of the wall, and then
regenerate the model.

To reduce the cleanup radius, do either of the following:

■ On the Properties palette, enter a smaller value for Cleanup radius.

■ Grip-edit the relevant cleanup radius so that it no longer encloses the
defective wall.

To regenerate the model, do either of the following:

■ Click View tab ➤ Appearance panel ➤  ➤ Regenerate

drop-down ➤ Regenerate Model  .

■ On the command line, enter ObjRelUpdate.

A wall’s cleanup radius intersects the justification line of another,
non-connected wall.

Just as in the case of a wall that does not extend beyond its cleanup radius or
that of another, you need to reduce the cleanup radius of the wall, and then
regenerate the model.
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To reduce the cleanup radius, do either of the following:

■ On the Properties palette, enter a smaller value for Cleanup radius.

■ Grip-edit the relevant cleanup radius so that it no longer encloses the
defective wall.

To regenerate the model, do either of the following:

■ Click View tab ➤ Appearance panel ➤  ➤ Regenerate

drop-down ➤ Regenerate Model  .

■ On the command line, enter ObjRelUpdate.

Invalid roofline or floorline is causing the wall’s 3D body to display
incorrectly.

You can edit the roofline or floorline and correct the display using a worksheet
accessed from the Properties palette. Expand Advanced ➤ Worksheets, and
then click Roof/floor line. For more information, see Editing the Roof Line or
the Floor Line of a Wall on page 1229.

Working with Solution Tip Icons and Short Walls
Why do some short walls display a solution tip icon?
The cleanup circle radius is too large. Reduce the cleanup circle radii of all
walls at the wall joint, or adjust the baselines so that the ends of all justification
lines fall within the wall joint cleanup circle radii.

Solution tip icon displayed in a wall with a short wall segment

This situation can also occur if a door, window, opening, or door/window
assembly is placed too close to the end of the wall and the wall or the objects
in it use elaborate endcaps. In such cases, there may not be enough room for
these conditions to be drawn correctly.
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Solution tip icon displayed in a wall with a window near its end

Working with Intersections and Adjacent Wall Segments
Why do some wall segments that have ends that are close together not clean
up properly?
The wall segment justification lines do not intersect each other, or one
justification line does not fall within an adjacent cleanup circle. Adjust one
wall segment length so that the end of its justification line falls within the
adjacent wall segment’s cleanup circle.

Adjusting wall segment length for correct clean up
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Working with Intersections and Small Cleanup Circle Radii
While using small cleanup circle radii, wall intersections clean up incorrectly
or not at all. How can I fix this?
Turn on the Diagnostic display representation or toggle on justification lines
and adjust the justification lines or increase the cleanup circle radii until the
problem is fixed.

Adjusting wall cleanup circle radius for correct clean up

Also, make sure that there are no short wall segments in the wall. These can
occur where center lines intersect, or when a segment is too short to produce
a full profile. Delete the short wall segment to fix the cleanup problem.

Incorrect Cleanup Group Assignments When Copying or Moving
Doors, Windows, and Openings

When I try to copy or move doors, windows, and openings from one wall to
another, the command does not always work. Why?
This situation can occur if the cleanup group for the destination wall does
not allow objects from walls assigned to other cleanup groups to be copied to
this wall. This design rule is intended to prevent placing objects in walls, such
as cubicle partitions, that should not have objects added to them.
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You can address this situation in 2 ways:

■ Turn off this design rule in the cleanup group definition. For more
information, see Creating a Wall Cleanup Group Definition on page 1352.

■ Temporarily assign the walls to the same cleanup group, copy or move the
objects, and then reassign the walls to their correct cleanup groups.

Opening a Drawing that Displays New Solution Tip Icons
When I closed my drawing, all the wall cleanups looked fine. Now when I
open the drawing, there are solution tip icons in the drawing. What causes
this, and how can I fix it?
Under some circumstances, the order in which walls are cleaned up affects
the display.

When troubleshooting this condition, select the walls in question, and
double-click one of them. On the Properties palette, select No for Cleanup
automatically, and then select Yes. Try this on different walls to see whether
you can locate the unstable wall. Usually, adjusting the justification line of
the unstable wall fixes this problem. For more information about verifying
justification line, see Wall Justification Lines and Cleanup Circles on page 1333.

Working with Wall Cleanups and Xref Drawings
How can I get walls to clean up with walls in xref drawings?
There are several actions you can take to improve wall cleanup when you work
with xref drawings that contain walls:

■ Verify the design rules of the cleanup groups used in the xref drawings. If
the cleanup group in the xref drawing does not allow cleanup with the
walls in the host drawing, walls in the 2 drawings do not clean up, even
when their cleanup groups have the same name. For more information
about the design rules of cleanup groups, see Creating a Wall Cleanup
Group Definition on page 1352.

■ When adding new walls during a Refedit session, add the existing walls to
the current working set. Select the Xref cleanup group of the existing walls
for the walls you are adding. Otherwise, the new walls do not clean up
with the existing walls until you save changes to the drawings.

■ Use the Regenall (Regenerate All) and ObjRelUpdate (Object Relationship
Update) commands to update the relationships among walls in the drawing,
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especially if you move or transform walls involving xref drawings, or if
you undo edits to walls in an xref drawing.

■ For more information about xref drawings and wall cleanup, see additional
troubleshooting topics in Troubleshooting Wall Cleanups on page 1343.

Occurrence of Copied Walls in Xref Drawings
My xref drawing contains copies of walls that are in my host drawing. How
did this happen?
If you added objects, such as doors or windows, to a wall in the host drawing
while you had a Refedit session open for an xref drawing, a copy of the selected
wall is added to the xref drawing. This occurs because any objects added during
a Refedit session are always added to the xref drawing and not to the host
drawing. Because the object you added was anchored to a wall, the wall is also
added to the xref drawing.

To correct the drawings, review both the host drawing and the xref drawing
for duplicate objects. Remove the duplicates from the incorrect drawing files.
Allowing the duplicates to remain can create problems with the cutting of
walls around doors, windows, door/window assemblies, and openings. Hidden
line and shaded views are also affected.

To avoid creating duplicate objects in xref drawings, do not add or edit objects
in the host drawing when a Refedit session is open for an xref drawing. Also,
instead of opening a Refedit session, you can open the xref itself, and make
edits directly. You can then save the xref drawing, and reload the updated
drawing in the host drawing.

Adding a Door to a Wall in an Xref Drawing
I added a wall in an xref drawing and then added a door to the wall. The door
does not center correctly. What causes this, and how I can correct it?
Some changes that you make during Refedit sessions of xref drawings do not
take effect until you save the changes to the xref drawing. When you add
doors, windows, door/window assemblies, and openings to a new wall in an
xref drawing, their placement is affected by whether the new wall cleans up
with other walls in the drawing. Clean up does not occur between walls in
xref and host drawings until you save the changes in the Refedit session.

For best results, if you add walls during a Refedit session, save and close the
session before adding objects to those walls. Open a new Refedit session (or
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open the xref drawing directly, outside of the host drawing), verify that the
walls clean up as you intend them to, and then add objects to the walls.

Cleanup Group Definitions
A wall cleanup group definition is a designation that you can assign to
individual walls to control how intersecting walls clean up. Walls that belong
to the same cleanup group clean up where they intersect according to the
priority assigned to each component in each wall. Walls that belong to different
cleanup groups do not clean up when they meet at corners or intersections.

Walls that do and do not clean up

Controlling Wall Cleanup through Design Rules

You use the design rules of a cleanup group definition to determine how walls
assigned that cleanup group cleanup when you Xref them in other drawings.
The setting for this design rule in the cleanup group definition in the xref
drawing controls whether those walls clean up with walls in the host drawing.

Design rules also determine whether you can move or copy objects from walls
assigned to other groups to walls assigned to the current cleanup group.
Preventing copying or moving objects to walls in a certain cleanup group
helps you avoid inadvertently placing objects in walls that should not contain
them.

Managing Cleanup Group Definitions

To create, edit, copy, or purge cleanup group definitions, you access the Style
Manager. The Style Manager provides a central location in AutoCAD
Architecture where you can work with definitions and styles from multiple
drawings and templates. For more information about using the Style Manager,
see Style Manager Overview on page 870.
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Creating a Wall Cleanup Group Definition
Use this procedure to create a wall cleanup group definition. A cleanup group
definition must exist in the drawing before you can assign walls and wall
styles to the cleanup group.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Architectural Objects, and expand Wall Cleanup Group
Definitions.

3 Create a cleanup group definition:

Then …If you want to …

right-click Wall Cleanup Group
Definitions, and click New.

create a cleanup group definition
with default properties

right-click the cleanup group
definition you want to copy, and

create a cleanup group definition
from an existing definition

click Copy. Right-click, and click
Paste.

4 Enter a name for the new cleanup group definition, and press
ENTER.

5 Select the new cleanup group definition.

6 Click the General tab, and enter a description of the cleanup
group.

7 Click the Design Rules tab.

8 Specify the design rules:

Then …If you want to …

Select Allow wall cleanup between
host and xref drawings. Clear this

allow walls assigned to this cleanup
group to clean up with walls in a

option if you do not want the wallshost drawing when the current
drawing is inserted as an Xref to cleanup with walls in the host

drawing.
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Then …If you want to …

NOTE The cleanup group
definition in the xref drawing
controls cleanup with walls in
the host drawing.

Select Allow objects anchored to
walls in other cleanup groups to be

allow objects anchored to walls as-
signed to other cleanup groups to

moved or copied to walls in thisbe moved or copied to walls as-
signed to this cleanup group cleanup group. Clear this option if

you do not want objects anchored
to walls in other cleanup groups to
be moved or copied to walls as-
signed to this cleanup group.

9 Click OK.

If you want to add notes, files, or documents to a cleanup group
definition, see Attaching Notes and Files to a Wall Cleanup Group
Definition on page 1353.

Attaching Notes and Files to a Wall Cleanup Group Definition
Use this procedure to enter notes and attach reference files to a cleanup group
definition. You can also edit notes and edit or detach reference files attached
to the definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Architectural Objects, and expand Wall Cleanup Group
Definitions.

3 Select the cleanup group definition that you want to change.

4 Click the General tab.

5 To add a description to the cleanup group definition, enter it for
Description.

6 Click Notes.

7 To add a note, click the Notes tab, and enter the note.
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8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then …If you want to …

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Edit
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

9 Click OK.

Using Edit in Place to Clean Up Wall Intersections
In cases where intelligent wall cleanup does not produce the desired results,
you can use the Cleanup Edit in Place feature to change the shape, width,
length, or depth of individual wall components at an intersection.

When you edit a wall intersection in place, a temporary profile is created for
each component in the intersecting wall segments. The profiles for the
component with the lowest index number in the wall style are displayed first.
When you select a profile, it displays Vertex and Edge grips you can manipulate
to edit its geometry. You can press ESC to clear selected components.

The Vertex grips allow you to manipulate component corners. When you
move a Vertex grip that occurs at the end of an component polyline, additional
Edge grips are added at the midpoints of the new edges that are created. Also,
a new Vertex grip is automatically created at the location of the original Vertex
that you moved.

The Edge grips allow you to offset a component edge, add a vertex to the
component edge, or convert a straight component edge to an arc edge. When
you offset a component edge or add a vertex to the component edge, additional
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Edge grips are added at the midpoints of the new edges that are created. In
addition, when you offset a component edge, new component corner Vertex
grips are created.

You can edit this profile in plan or model views. In a model view, you are
prompted to select a point at the intersection you want to cleanup. This pick
point determines the elevation of the profile.

IMPORTANT A wall style that has vertically stacked components may require
unique intersection cleanup conditions at different elevations of the wall endcap.
Change your cutplane height to specify these different wall intersection cleanup
conditions at the appropriate elevation.

When working with intersecting walls in a plan view, the profile is located
on the normal plane of the middle point of the wall segment nearest to your
pick point. Components that don’t intersect the cutplane of the wall will not
be displayed.

You can use the Trim and Extend tools with defined boundaries and the
Subtract and Merge tools with closed polyline areas or defined profiles to
modify wall components to create the configuration that you want. You can
also fillet or chamfer individual component corners.

To Edit Cleanup Conditions in Place

1 Select the wall segment that has the intersection clean up
condition that you want to change.

2 Click Wall tab ➤ Cleanup panel ➤ Cleanup Edit In Place  .

Temporary profiles are created for you to edit the geometry of the
wall intersection for each wall component.

3 Select the profile and edit it as desired:

Then …If you want to …

use grips to adjust the shape.change the shape of the perimeter
of the profile
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Then …If you want to …

click Edit In Place tab ➤ Profile

panel ➤ Hide Edge  .

hide an edge of the profile for a
single wall component (plan view
only)

click Edit In Place tab ➤ Profile

panel ➤ Show Edge  .

display a hidden edge of the profile
for a single wall component (plan
view only)

click Edit In Place tab ➤ Profile

panel ➤ Add Vertex  .

add vertices to the profile of a
single wall component

click Edit In Place tab ➤ Profile

panel ➤ Remove Vertex  .

remove vertices from the profile of
a single wall component

click Edit In Place tab ➤ Modify

panel ➤ Fillet  .

fillet wall component corners

click Edit In Place tab ➤ Modify

panel ➤ Chamfer  .

chamfer wall component corners

click Edit In Place tab ➤ Modify

panel ➤ Subtract  .

subtract profiles from wall compon-
ents

click Edit In Place tab ➤ Modify

panel ➤ Merge  .

merge profiles with wall compon-
ents

click Edit In Place tab ➤ Modify

panel ➤ Trim  .

trim wall components to a bound-
ary

click Edit In Place tab ➤ Modify

panel ➤ Extend  .

extend wall components to a
boundary
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4 Save or discard the changes:

Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

Discard any changes you made
during the edit-in-place session

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  .

Save any changes you made during
the edit-in-place session

NOTE When the cut plane specified by the display configuration is overridden
and you attempt a edit in-place wall cleanup, wall editing takes place at a different
elevation than what is displayed at the cut plane override. A dialog is displayed
where you can choose to edit or cancel wall cleanup in-place edit.

Specifying a Component Cleanup Override
When you are editing wall components to achieve the desired wall intersection
condition, you may encounter a situation in which edited components overlap
other components that have a higher priority. For example, if you drag a
sheathing component with a lower priority over a structural component with
a higher priority, you are specifying a component cleanup override condition.
A dialog displays to allow you to specify whether to accept or discard the
overlapping component condition.

NOTE Specifying a component cleanup override does not affect the wall style
component priority or the display parameters on the Properties palette.

The following sections outline the various features that you can use to cleanup
wall intersections.

Hiding the Edge of a Wall Intersection Component
Use this procedure to modify a wall intersection by hiding a wall component
edge. This is useful if you have an intersection condition that has a component
edge this is displayed incorrectly.

1 Select the wall segment with the wall intersection to modify.

2 Click Wall tab ➤ Cleanup panel ➤ Cleanup Edit In Place  .
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Vertex and Edge grips display for the first wall component, based
upon the wall style index.

3 Select the component that has the edge you want to hide.

You can only hide the edge of one component at a time. Press
ESC to clear component selection.

4 Click Edit In Place tab ➤ Profile panel ➤ Hide Edge  .

5 Select the component edge to hide.

6 Exit the edit-in-place session:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session
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In the following example, wallboard component edges are hidden
to create an interior corner condition.

Showing the Edge of a Wall Intersection Component
Use this procedure to modify a wall intersection by showing a previously
hidden wall component edge.

1 Select the wall segment with the wall intersection to modify.
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2 Click Wall tab ➤ Cleanup panel ➤ Cleanup Edit In Place .

Vertex and Edge grips display for the first wall component, based
upon the wall style index.

3 Select the component that has the edge you want to show.

You can only show the edge of one component at a time. Press
ESC to clear component selection.

4 Click Edit In Place tab ➤ Profile panel ➤ Show Edge  .

5 Select the component edge to show.

6 Exit the edit-in-place session:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session
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In the following example, previously hidden wallboard component
edges are shown to create an interior corner condition.

Filleting a Wall Intersection Component
Use this procedure to modify a wall intersection by filleting a wall component.

1 Select the wall segment with the wall intersection to modify.
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2 Click Wall tab ➤ Endcap panel ➤ Cleanup Edit In Place  .

3 Select the component that has the corner you want to fillet.

You may only fillet the corner of one component at a time. Press
ESC to clear component selection.

4 Click Edit In Place tab ➤ Modify panel ➤ Fillet  .

5 Specify the fillet radius.

6 Select the first component edge to fillet.

7 Select the second component edge to fillet.

8 Save or discard your changes:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session

Chamfering a Wall Intersection Component
Use this procedure to modify a wall intersection by chamfering a wall
component corner.

1 Select the wall segment with the wall intersection to modify.

2 Click Wall tab ➤ Cleanup panel ➤  Cleanup Edit In Place  .

3 Select the component that has the corner you want to chamfer.

You may only chamfer the corner of one component at a time.
Press ESC to clear component selection.

4 Click Edit In Place tab ➤ Modify panel ➤ Chamfer  .

5 Specify the chamfer distances.

6 Select the first component edge to chamfer.
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7 Select the second component edge to chamfer.

8 Exit the edit-in-place session:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session

Adding a Vertex to a Wall Intersection Component
Use this procedure to modify a wall intersection by adding a vertex on or near
to a component edge. By adding vertices to a component edge, you have more
options for editing its shape.

1 Select the wall segment with the wall intersection to modify.

2 Click Wall tab ➤ Cleanup panel ➤ Cleanup Edit In Place  .

Vertex and Edge grips display for the first wall component, based
upon the wall style index.

3 Select the component to which you want to add a vertex.

You can only add vertices to one component at a time. Press ESC
to clear component selection.

4 Click Edit In Place tab ➤ Profile panel ➤ Add Vertex  .

5 Specify a location on or near the selected component edge for the
new vertex.

6 Exit the edit-in-place session:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session
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Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session
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In the following example, new vertices are added to components,
then Edge grips are used to modify a brick veneer corner condition.
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Removing a Vertex from a Wall Intersection Component
Use this procedure to modify a wall intersection by removing a vertex from
a component.

1 Select the wall segment with the wall intersection to modify.

2 Click Wall tab ➤ Cleanup panel ➤ Cleanup Edit In Place  .

Vertex and Edge grips display for the first wall component, based
upon the wall style index.

3 Select the component from which you want to remove a vertex.

You can only remove vertices from one component at a time.
Press ESC to clear component selection.

4 Click Edit In Place tab ➤ Profile panel ➤ Remove Vertex  .

5 Select a vertex to remove.

6 Exit the edit-in-place session:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session
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In the following example, a vertex is removed from a foundation
wall corner to create a chamfered condition.

Subtracting a Profile from a Wall Intersection Component
Use this procedure to modify a wall intersection by subtracting a profile from
a component. The profile can be any polyline-enclosed area that overlaps the
component.

1 Select the wall segment with the wall intersection to modify.

2 Click Wall tab ➤ Cleanup panel ➤ Cleanup Edit In Place  .

Vertex and Edge grips display for the first wall component, based
upon the wall style index.

3 Select the component from which you want to subtract the profile.

You can subtract profiles from more than one component at a
time. Press ESC to clear component selection.

4 Click Edit In Place tab ➤ Modify panel ➤ Subtract  .

5 Select a profile to remove.

6 Enter Y to erase selected linework, or N to keep it.

Subtracting a Profile from a Wall Intersection Component | 1367



7 Exit the edit-in-place session:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session

In the following example, profiles are subtracted from facing
components to create cutout reveal conditions.

Merging a Profile with a Wall Intersection Component
Use this procedure to modify a wall intersection by merging a profile with a
component. The profile may be any polyline-enclosed area that overlaps or
is coincident with the component.
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1 Select the wall segment with the wall intersection to modify.

2 Click Wall tab ➤ Cleanup panel ➤ Cleanup Edit In Place  .

Vertex and Edge grips display for the first wall component, based
upon the wall style index.

3 Select the component to which you want to merge the profile.

Merge profiles with one component at a time. Press ESC to clear
component selection.

4 Click Edit In Place tab ➤ Modify panel ➤ Merge  .

5 Select a profile to merge.

6 Enter Y to erase selected linework, or N to keep it.

7 If the merged profile overlaps another component that has a
higher priority, the Wall Cleanup Edit in Place - Component
Cleanup Override dialog displays. Click Yes to have the merged
profile override the overlapped component, click No have the
overlapped component override the merged profile, or click Cancel
to end without merging the profile with the component.

8 Exit the edit-in-place session:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session

In the following example, a profile is merged with a brick veneer
component to create a corner condition. The modified brick
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component (lower priority) overrides the concrete block
component (higher priority).

Trimming a Wall Intersection Component
Use this procedure to modify a wall intersection by trimming a component.
The trim boundary can be a line, arc, circle, polyline, or wall component edge.

1 Select the wall segment with the wall intersection to modify.

2 Click Wall tab ➤ Cleanup panel ➤ Cleanup Edit In Place  .

Vertex and Edge grips display for the first wall component, based
upon the wall style index.

3 Select the component that you want to trim.

You can trim multiple components at a time to a trim boundary.
Press ESC to clear component selection.

4 Click Edit In Place tab ➤ Modify panel ➤ Trim  .

5 Either specify points to delineate a trim boundary, or press ENTER
to select a trim boundary.

6 Specify the side to trim.
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7 Exit the edit-in-place session:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session

In the following example, a concrete wall corner is trimmed to a
line trim boundary.
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Extending a Wall Intersection Component
Use this procedure to modify a wall intersection by extending a component.
The extension boundary can be a line, arc, circle, polyline, or wall component
edge.

1 Select the wall segment with the wall intersection to modify.

2 Click Wall tab ➤ Cleanup panel ➤ Cleanup Edit In Place  .

Vertex and Edge grips display for the first wall component, based
upon the wall style index.

3 Select the component that you want to extend.

You can extend multiple components at a time to a extension
boundary. Press ESC to clear component selection.

4 Click Edit In Place tab ➤ Modify panel ➤ Extend  .

5 Select an extension boundary.

6 Exit the edit-in-place session:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session
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In the following example, wallboard components are extended
to a concrete block component as the extension boundary to
create a fire break.

Working with Wall Endcaps and Opening Endcaps
You can define different kinds of wall endcaps and wall opening endcaps
conditions. When you encounter an unsuitable wall endcap configuration,
you can modify the shape, width, and depth of individual wall components
to achieve the desired result. Generally, you create a specific wall or opening
endcap condition to use with a specific wall style.

To modify endcaps, you can use the Edit in Place mode and manipulate wall
components with Vertex and Edge grips. You can hide or show component
edges. You can also use Fillet, Chamfer, Trim, Extend, Subtract, and Merge
tools to modify wall components to create the configuration that you want.
The Calculate Automatically feature can also assist you in adding boundary
segments to complete your partial endcap designs.

When necessary, you can override the wall endcap style assigned in a wall
style. When you override the assigned endcap style, you can select a different
endcap style for one or both ends of a wall segment.
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Opening Endcap Styles

Wall endcap styles are also used as a basis to define endcap styles for wall
openings. When a wall has an opening, such as a window or a door, the shape
of the wall endcap at each edge of the opening can be defined. You use opening
endcap styles to specify the wall endcap style applied to each edge of the wall
adjacent to an opening. When you change a wall endcap style, all opening
endcap styles based on that style are also modified. For more information
about opening endcap styles, see Creating a Wall Opening Endcap Style on
page 1407.

NOTE If you use a custom profile to create an opening in a curved wall, opening
endcaps will not be applied to the opening.

Workflow for Creating Wall and Opening Endcaps

Display the edit in place edge and vertex grips
on page 1375on the wall or opening.

-----
Customize the end of the wall or
the wall around an opening

Use edit in place edge and vertex grips on page
1375 to create and modify wall and opening
endcaps.

-----
Modify endcap geometry using
grips

Use the AEC Modify tools on page 1375 such as
trim, extend, subtract and merge to create and
modify wall endcaps and opening endcaps.

-----
Modify endcap geometry using
trim, extend, and subtract

Save the endcap you created with a new style on
page 1407 name.

-----Save your changes
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Apply on page 1401 the new endcap to walls or
openings in the drawing.

-----Add the new endcap

Using Edit in Place to Modify Wall Endcaps
You can use Edit in Place grips to modify wall endcaps and create the wall
endcap conditions that you want. Vertex and Edge grips are displayed for all
wall components at the wall endcap that you specify.

When you edit a wall endcap in place, a temporary profile is created for each
component in the endcap. The profiles for the component with the lowest
index number in the wall style are displayed first. When you select a profile,
it displays Vertex and Edge grips you can manipulate to edit its geometry. You
can press ESC to clear selected components.

The Vertex grips allow you to manipulate component corners. When you
move a Vertex grip that occurs at the end of an component polyline, additional
Edge grips are added at the midpoints of the new edges that are created. Also,
a new Vertex grip is automatically created at the location of the original Vertex
that you moved.

The Edge grips allow you to offset a component edge, add a vertex to the
component edge, or convert a straight component edge to an arc edge. When
you offset a component edge or add a vertex to the component edge, additional
Edge grips are added at the midpoints of the new edges that are created. In
addition, when you offset a component edge, new component corner Vertex
grips are created.

Using Edit in Place to Modify Wall Endcaps | 1375



You can edit this profile in plan or model views. In a model view, you are
prompted to select a point at the endcap you want to modify. This pick point
determines the elevation of the profile.

IMPORTANT A wall style that has vertically stacked components may require
unique endcap conditions at different elevations of the wall endcap. Change your
cutplane height to specify these different wall intersection cleanup conditions at
the appropriate elevation.

When working with intersecting walls in a plan view, the profile is located
on the normal plane of the middle point of the wall segment nearest to your
pick point. Components that don’t intersect the cutplane of the wall will not
be displayed.

To Edit Endcap Conditions in Place

1 Select the wall that has the wall or opening endcaps that you want
to change.

2 Click Wall tab ➤ Endcap panel ➤ Endcap Edit In Place .

3 Specify a point near the endcap.

Temporary profiles are created for you to edit the geometry of the
wall endcap for each wall component.

4 Select the profile and edit it as desired:

Then …If you want to …

use grips to adjust the shape.change the shape of the perimeter
of the profile

click Edit In Place tab ➤ Profile

panel ➤ Show Edge  .

show an edge of the profile for a
single component (plan view only)
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Then …If you want to …

click Edit In Place tab ➤ Profile

panel ➤ Hide Edge  .

hide an edge of the profile for a
single wall component (plan view
only)

click Edit In Place tab ➤ Profile

panel ➤ Replace Endcap  .

replace the geometry of an endcap
component with a new polyline
that lies on the end of the wall ex-
clusive of existing endcaps

click Edit In Place tab ➤ Profile

panel ➤ Remove Endcap  .

remove an endcap component

click Edit In Place tab ➤ Modify

panel ➤ Fillet  .

fillet an edge of the profile for a
single wall component

click Edit In Place tab ➤ Modify

panel ➤ Chamfer  .

chamfer an edge of the profile for
a single wall component

click Edit In Place tab ➤ Modify

panel ➤ Merge  .

merge an enclosed polyline area
with a wall component

click Edit In Place tab ➤ Modify

panel ➤ Subtract  .

subtract an enclosed polyline area
from a wall component

click Edit In Place tab ➤ Modify

panel ➤ Trim  .

trim wall components to a trim
boundary

click Edit In Place tab ➤ Modify

panel ➤ Extend  .

extend wall components to an ex-
tension boundary

5 Save or discard the changes:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style
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Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session

The Vertex grips allow you to manipulate component corners. When you
move a Vertex grip that occurs at the end of an endcap polyline, additional
edge grips are added at the midpoints of the new edges that are created.

The Edge grips allow you to offset a component edge, add a vertex to the
component edge, or convert a straight component edge to an arc edge. When
you offset a component edge or add a vertex to the component edge, additional
edge grips are added at the midpoints of the new edges that are created. In
addition, when you offset a component edge, new component corner Vertex
grips are added.

Often you will work with wall styles that have one or more components that
wrap at the wall endcap or opening. For example, a brick wall component in
some wall styles wraps at the wall endcap. With this condition, a control line
parallel to the Y axis delineates the innermost component face. Remaining
components in the wall style will start at this control line, and the initial grips
display along the control line.

In the following illustration you can see the component overlap distance and
the grips that occur along the control line.

The following sections cover using Edit in Place to modify wall endcaps.
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Using Vertex Grips to Modify a Wall Endcap
Use this procedure to modify a wall component with Vertex grips.

1 Select the wall segment with the wall endcap to modify.

2 Click Wall tab ➤ Endcap panel ➤ Endcap Edit In Place .

3 Specify a point near the wall endcap.

The Edit in Place grips for the wall component are displayed.

4 Select the Vertex grip.

5 Specify a new location for the Vertex grip.

6 Save or discard your changes:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session
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7 In the following example, a wall endcap is modified with a Vertex
grip.

Using Edge Grips to Offset a Wall Endcap Edge
Use this procedure to offset a wall component edge with Edge grips.

1 Select the wall segment with the wall endcap to modify.

2 Click Wall tab ➤ Endcap panel ➤ Endcap Edit In Place .

3 Specify a point at the wall endcap.

4 Move your cursor over the Edge grip to display the available
modes.

5 Select the Edge grip.

6 Specify a new location for the Edge grip.
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7 Save or discard your changes:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session

In the following example, a wall component edge is offset with
an Edge grip.
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Using Edge Grips to Add a Vertex to a Wall Endcap Edge
Use this procedure to add a vertex to a wall component edge with Edge grips.

1 Select the wall segment with the wall endcap to modify.

2 Click Wall tab ➤ Endcap panel ➤ Endcap Edit In Place .

3 Specify a point at the wall endcap.

4 Move your cursor over the Edge grip to display the available
modes.

5 Select the Edge grip, and then press CTRL once.

6 Specify a new location for the Edge grip.

7 Save or discard your changes:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session
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In the following example, a vertex is added to a wall component
edge with an Edge grip.

Using Edge Grips to Convert a Wall Endcap Edge to an Arc
Use this procedure to convert a wall component edge to an arc with Edge
grips.

1 Select the wall segment with the wall endcap to modify.

2 Click Wall tab ➤ Endcap panel ➤ Endcap Edit In Place .

3 Specify a point at the wall endcap.

4 Move your cursor over the Edge grip to display the available
modes.
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5 Select the Edge grip, and then press CTRL twice.

6 Specify a new location for the Edge grip.

7 Save or discard your changes:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session
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In the following example, a wall endcap edge is converted to an
arc with an Edge grip.

Filleting a Wall Endcap Component
Use this procedure to modify a wall endcap by filleting a wall component.

1 Select the wall segment with the wall endcap to modify.

2 Click Wall tab ➤ Endcap panel ➤ Endcap Edit In Place  .

3 Select the component that has the corner you want to fillet.

You may only fillet the corner of one component at a time. Press
ESC to clear component selection.
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4 Click Edit In Place tab ➤ Modify panel ➤ Fillet  .

5 Specify the fillet radius.

6 Select the first component edge to fillet.

7 Select the second component edge to fillet.

8 Save or discard your changes:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session
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In the following example, a brick veneer corner is filleted.

Chamfering a Wall Endcap Component
Use this procedure to modify a wall endcap by chamfering a wall component
corner.

1 Select the wall segment with the wall endcap to modify.

2 Click Wall tab ➤ Endcap panel ➤ Endcap Edit In Place  .

3 Select the component that has the corner you want to chamfer.

You may only chamfer the corner of one component at a time.
Press ESC to clear component selection.

4 Click Edit In Place tab ➤ Modify panel ➤ Chamfer  .

5 Specify the chamfer distances.
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6 Select the first component edge to chamfer.

7 Select the second component edge to chamfer.

8 Exit the edit-in-place session:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session

In the following example, a CMU component corner is chamfered.

Showing the Edge of a Wall Endcap Component
Use this procedure to modify a wall endcap by showing a previously hidden
wall component edge.
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1 Select the wall segment with the wall endcap to modify.

2 Click Wall tab ➤ Endcap panel ➤ Endcap Edit In Place  .

3 Select the component that has the edge you want to show.

You may only show the edge of one component at a time. Press
ESC to clear component selection.

4 Click Edit In Place tab ➤ Profile panel ➤ Show Edge  .

5 Select the component edge to show.

6 Save or discard your changes:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session

Hiding the Edge of a Wall Endcap Component
Use this procedure to modify a wall endcap by hiding a wall component edge.

1 Select the wall segment with the wall endcap to modify.

2 Click Wall tab ➤ Endcap panel ➤ Endcap Edit In Place  .

3 Select the component that has the edge you want to hide.

You may only hide the edge of one component at a time. Press
ESC to clear component selection.

4 Click Edit In Place tab ➤ Profile panel ➤ Hide Edge  .

5 Select the component edge to hide.
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6 Save or discard your changes:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session

Trimming a Wall Endcap Component
Use this procedure to modify a wall endcap by trimming a component. A trim
boundary may be a line, arc, circle, polyline, or wall component edge.

1 Select the wall segment with the wall endcap to modify.

2 Click Wall tab ➤ Endcap panel ➤ Endcap Edit In Place  .

3 Select the component that you want to trim.

You may trim multiple components at a time to a trim boundary.
Press ESC to clear component selection.

4 Click Edit In Place tab ➤ Modify panel ➤ Trim  .

5 Either specify points to delineate a trim boundary, or press ENTER
to select a trim boundary.

6 Specify the side to trim.

7 Save or discard your changes:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session
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Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session

In the following example, components are trimmed to a boundary
line.

Extending a Wall Endcap Component
Use this procedure to modify a wall endcap by extending a component. An
extension boundary may be a line, arc, circle, polyline, or wall component
edge.

1 Select the wall segment with the wall endcap to modify.
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2 Click Wall tab ➤ Endcap panel ➤ Endcap Edit In Place  .

3 Select the component that you want to extend.

You may extend multiple components at a time to a extension
boundary. Press ESC to clear component selection.

4 Click Edit In Place tab ➤ Modify panel ➤ Extend  .

5 Select an extension boundary.

6 Save or discard your changes:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session
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In the following example, components are extended to another
wall segment as an extension boundary.

Subtracting a Profile from a Wall Endcap Component
Use this procedure to modify a wall endcap by subtracting a profile from a
component. A profile may be any polyline-enclosed area that overlaps a specific
component.

1 Select the wall segment with the wall endcap to modify.

2 Click Wall tab ➤ Endcap panel ➤ Endcap Edit In Place  .

3 Select the component from which you want to subtract the profile.

You may subtract profiles from more than one component at a
time. Press ESC to clear component selection.

Subtracting a Profile from a Wall Endcap Component | 1393



4 Click Edit In Place tab ➤ Modify panel ➤ Subtract  .

5 Select a profile to remove.

6 Enter Y to erase selected linework, or N to keep it.

7 Save or discard your changes:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session

In the following example, a profile is subtracted from a wall
component.
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Merging a Profile with a Wall Endcap Component
Use this procedure to modify a wall endcap by merging a profile with a
component. A profile may be any polyline-enclosed area that overlaps or is
coincident with a specific component.

1 Select the wall segment with the wall endcap to modify.

2 Click Wall tab ➤ Endcap panel ➤ Endcap Edit In Place  .

3 Select the component to which you want to merge the profile.

You can only merge profiles with one component at a time. Press
ESC to clear component selection.

4 Click Edit In Place tab ➤ Modify panel ➤ Merge  .

5 Select a profile to merge.

6 Enter Y to erase selected linework, or N to keep it.

7 If the merged profile overlaps another component that has a
higher priority, the Wall Cleanup Edit in Place - Component
Cleanup Override dialog is displayed. Click Yes to have the merged
profile override the overlapped component, click No have the
overlapped component override the merged profile, or click Cancel
to end without merging the profile with the component.

8 Save or discard your changes:

Then...If you want to...

click Edit In Place tab ➤ Edits panel ➤ Save

As  .

Save any changes you made during
the edit-in-place session as a new style

click Edit In Place tab ➤ Edits panel ➤ Can-

cel  .

Discard any changes you made during
the edit-in-place session

click Edit In Place tab ➤ Edits panel ➤ Fin-

ish  .

Save any changes you made during
the edit-in-place session
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In the following example, a profile is merged with a wall
component.

Creating Wall Endcaps Using Calculate Automatically
You can use the Calculate Automatically feature with appropriate polyline
linework to create wall endcaps. Calculate Automatically will add boundary
segments to complete an endcap configuration if the initial polyline is drawn
with regard to location and orientation of the particular wall component.

Here are some guidelines for drawing polylines to use in endcap styles:

■ Use only 2-dimensional (2D), open, lightweight polylines.

■ To help you visualize how the endcap should appear for each component
of the wall, draw the polylines in plan view, adjacent to the wall
components that you want to change.

■ When you draw polylines for an endcap style used in a multi-component
wall, draw one polyline for each component, so that each polyline
corresponds to the shape of the endcap for one wall component.
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Working with Wall Endcap Polylines and Wall Components
Valid wall endcap polylines start at the wall component corner on the Y axis.
Ideally, the polyline ends at the other wall component corner on the Y axis,
so that both the polyline start point and endpoint are coincident with the Y
axis and both have the same X value as shown.

Often you will work with wall styles that have one or more components that
wrap at the wall endcap or opening. For example, a brick wall component in
some wall styles wraps at the wall endcap. With this condition, a control line
parallel to the Y axis delineates the innermost component face, and the
remaining components in the wall style will start at this control line. When
you select a wall segment in order to apply a new wall endcap condition for
the first wall component, the Edit in Place grips display along the control line
as shown.

Adding a Wall Endcap Polyline to a Single-Component Wall Segment

Use this procedure to associate a wall endcap polyline with the component
of a single-component wall segment.
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1 At the end of an existing single-component wall segment in plan
view, draw a polyline to define the wall endcap condition.

2 Select the wall segment.

3 Click Wall tab ➤ Endcap panel ➤ Calculate Automatically  .

4 Select the wall endcap polyline.

5 Press ENTER to accept the wall component that you want.

The Wall Endcap Style dialog displays, in which you can do the
following:

■ Save the new wall endcap as a new wall endcap style.

■ Apply the wall endcap style as a default endcap for this wall
style. All existing and new instances of this wall style will
display the new wall endcap condition.

■ Apply the wall endcap style as an override to the selected end
of this wall style. Only this single instance of this wall style
will display the new wall endcap condition.

■ You can choose to erase or retain the original polyline layout
geometry of the wall endcap.

Click OK, and the specified wall component is merged with the
wall endcap polyline. Click Cancel to discard your changes.
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In the following example, a wall endcap polyline is associated
with a wall component.

Adding a Wall Endcap Polyline to a Multiple-Component Wall Segment

Use this procedure to associate a wall endcap polyline with a specific
component in a multiple-component wall segment.

1 On an existing multi-component wall segment in plan view, draw
a polyline to define the wall endcap condition.

2 Select the wall segment to edit.

3 Click Wall tab ➤ Endcap panel ➤ Calculate Automatically  .

4 Select the wall endcap polyline.

The first wall component to which you could associate the
polyline is highlighted with a red line inside the perimeter of the
wall component.

5 Press ENTER to accept this wall component, or press TAB to advance
to the next wall component.

Continue to press TAB until the component that you want is
highlighted.

6 Press ENTER to accept the wall component that you want.
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The Wall Endcap Style dialog displays, in which you can do the
following:

■ Save the new wall endcap as a new wall endcap style.

■ Apply the wall endcap style as a default endcap for this wall
style. All existing and new instances of this wall style will
display the new wall endcap condition.

■ Apply the wall endcap style as an override to the selected end
of this wall style. Only this single instance of this wall style
will display the new wall endcap condition.

■ You can choose to erase or retain the original polyline layout
geometry of the wall endcap.

Click OK, and the specified wall component is merged with the
wall endcap polyline. Click Cancel to discard your changes.

In the following example, a wall endcap polyline is applied to the
second of two wall components in a multi-component wall
segment.
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Applying Wall Endcap Styles from the Style Manager
Although you can create a new wall endcap style from the Style Manager using
the procedure described below, the new style is not automatically applied to
any wall style or wall; you must apply it to wall styles or walls in a separate
task. For more information, see Applying a Wall Endcap Style to a Wall Style
on page 1402 and Overriding a Wall Endcap Style on a Wall on page 1402.

Creating a Wall Endcap Style in the Style Manager
1 Draw polyline(s) in the shape of the wall endcap you want to

create.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Expand Architectural Objects.

4 Right-click Wall Endcap Styles, and click New.

5 Enter a name for the new wall endcap style, and press ENTER.

6 Right-click the new style name, and click Set From.

7 Select a polyline, and enter the index number for the wall
component to which the polyline applies.

When you select polylines to use in wall endcap styles, each
polyline corresponds to the shape of the endcap for one wall
component. Each polyline is scaled to fit its assigned component.

Wall components are numbered from exterior to interior.
Component index 1 corresponds to the outermost exterior
component.

8 When prompted, enter y (Yes) to assign a polyline to another
component, or enter n (No) if there are no more components.

NOTE  You can assign the same polyline to multiple wall components
that you want to have the same endcap condition.

9 When you finish specifying endcap conditions for wall
components, enter the return offset for the endcap.

A positive value offsets the endcap from the wall start point in
the positive X direction.

10 Click OK.

You can apply the wall endcap style to a wall style (Applying a
Wall Endcap Style to a Wall Style on page 1402, an opening endcap
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style (Creating a Wall Opening Endcap Style on page 1407,) or to
individual walls (Overriding a Wall Endcap Style on a Wall on
page 1402.)

Applying a Wall Endcap Style to a Wall Style
Use this procedure to apply a wall endcap style to a wall style. When a wall
endcap style is applied to a wall style, all walls of that style will have the
specified at both ends. You can override the style-defined endcap style by
assigning a different endcap to one wall end.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects.

3 Expand Wall Styles, and select the wall style to which you want
to apply the wall endcap style.

4 Click the Endcaps/Opening Endcaps tab.

5 For Wall Endcap Style, select the style you want to apply.

The endcap style is applied to all existing walls of that style, as
well as all new walls of that style.

TIP The endcap style defined in the wall style is always applied to
both ends of the wall. If you want a different endcap for each end of
the wall, you can override the style-defined endcap. For more
information, see Overriding a Wall Endcap Style on a Wall on page
1402.

6 Click OK.

Overriding a Wall Endcap Style on a Wall
Use this procedure to override the style-defined wall endcap style for one end
of an individual wall.

NOTE A wall endcap style is generally created for use with a specific wall style.
Overriding the endcap style for an individual wall may display solution tip icons
in the wall.

1 Select a wall.
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2 Click Wall tab ➤ Endcap panel ➤  ➤ Override Endcap Style

 .

3 Select a point close to the wall end where you want assign a
different endcap.

4 In the Select an Endcap Style dialog, select an endcap style to use
on the wall end, and click OK.

TIP Alternatively, you can double-click the wall to display the
Properties palette, and scroll to the Style Overrides category. Under
Starting endcap and Ending Endcap, you can select a different endcap
style to override the style assignment.

Modifying the Geometry of a Wall Endcap Style
You can modify the geometry of an existing wall endcap style using either of
the following methods:

■ Enter an Edit in Place session to change the endcap profile and save the
change back to the style. This is best suited to making small, detailed
changes.

■ Exchange the endcap definition with a newly created polyline. This is best
suited for changing the endcap shape completely without having to reassign
a new endcap style to all wall styles that use it.

Editing the Standard Wall Endcap Style

The Standard wall endcap style is a special case. While you can use the Standard
style as a starting point for creating a new wall endcap style, the Standard
style itself cannot be changed. The Standard style is used when no other
endcap style is specified for a wall. It is also used when you remove all
components from a wall endcap style.

The Wall Endcap Profile

When you edit a wall endcap in place, a temporary profile with grips for
vertices and edges is created for each component of the endcap. You can edit
this profile in both plan and model views. In model views, the profile is
inserted at the mid-height of the wall. If the wall has components that do not
extend to that height, such as a footing, additional profiles are created at the
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vertical midpoint of these components. Use model views to edit wall endcaps
that lie in different planes.

If the profile is very complex or is obscured by the linework of other objects,
use the location grip on the temporary profile to move the profile away from
the wall. Changes to the profile are saved at its original location.

Changing a wall endcap style using Edit in Place

1 Select the wall that has the wall endcap style you want to change.

2 Click Wall tab ➤ Endcap panel ➤ Edit In Place  .

3 Select a point near the endcap.

Temporary profiles are created for you to edit the geometry of the
wall endcap for each wall component.

NOTE After performing an editing task, you may need to select a
profile again to perform another editing task.

4 Select the profile and edit it as desired:

Then …If you want to …

use grips to adjust the shape. If the
profile has no grips, the Standard

change the shape of the perimeter
of the profile

style, which you cannot edit, is the
current endcap style.

click Edit In Place tab ➤ Profile

panel ➤ Hide Edge  .Select the

hide one or more edges of the pro-
file (plan view only)

edges you want to hide, and press
ENTER.

click Edit In Place tab ➤ Profile

panel ➤ Show Edge  . Select the

display an edge that you hid

edges you want to show, and press
ENTER.

Edit In Place tab ➤ Profile pan-

el ➤ Add Vertex  . Select a point

add vertices to the profile

for each new vertex, and press
ENTER.
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Then …If you want to …

Edit In Place tab ➤ Profile pan-

el ➤ Remove Vertex  . Select

remove vertices from the profile

each vertex to remove, and press
ENTER.

click Edit In Place tab ➤ Profile

panel ➤ Replace Endcap  . Se-

replace the geometry of an endcap
component with new polyline that
lies on the end of the wall exclusive
of existing endcaps lect the endcap component to re-

place, and select a polyline to
define the new geometry. Press
ENTER to keep the polyline in the
drawing, or enter y (Yes) to erase
it.

click Edit In Place tab ➤ Profile

panel ➤ Remove Endcap  .

remove an endcap component

5 Save or discard the changes:

Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the wall endcap to its origin-
al shape

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  .The wall endcap

save the changes to the current wall
endcap style

and the wall endcap style use the
edited profile(s) to define its geo-
metry. Any other walls or opening
endcap styles that use this wall end-
cap style are also updated with the
edited geometry.

click Edit In Place tab ➤ Edits pan-

el ➤ Save As  . Enter a name for

save the changes to a new wall en-
dcap style

the new wall endcap style, and click
OK. The wall endcap uses the new
style to define its geometry. Other
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Then …If you want to …

walls, wall styles, or opening end-
cap styles that use the original style
are not affected.

Changing the wall endcap style by substituting its profile with a new polyline

1 Draw the polyline you want to exchange for an existing wall
endcap style.

2 Select a wall in the drawing that has the wall endcap style you
want to change.

3 Click Wall tab ➤ Endcap panel ➤ Calculate Automatically .

4 Select the polyline you have drawn, and press ENTER.

5 Enter y (Yes) to erase the polyline(s), or enter n (No) to keep the
polyline(s).

If the current wall endcap style is not the Standard style, you are
prompted to modify the current style.

6 Enter y (Yes) to modify the currently active endcap style.

7 Enter w (Wallstyledefault) to use the modified wall endcap style
as the default endcap style for that wall style. Otherwise, enter o
(Override).

Changing the Return Offset of a Wall Endcap Style
Use this procedure to change the return offset of an existing wall endcap style.

A positive value offsets the endcap from the wall start point in the positive X
direction.

Specifying the return offset for an endcap

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects.
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3 Expand Wall Endcap Styles, and select the endcap style for which
you want to change the return offset.

4 Click the Dimensions tab.

5 Enter a new offset value, and click OK.

Attaching Notes and Files to a Wall Endcap Style
Use this procedure to enter notes and attach reference files to a wall endcap
style. You can also edit notes and edit or detach reference files that are attached
to a wall endcap style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects.

3 Select the wall style you want to access.

4 Click the General tab.

5 Under Description, add a description of the endcap style.

6 Click Notes.

7 To add a note, click the Notes tab, and enter the note.

8 Click the Reference Docs tab, and perform the following
operations as needed:

Then …If you want to …

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

9 Click OK.

Creating a Wall Opening Endcap Style
Wall opening endcap styles are endcap conditions assigned to a wall end
adjacent to a door, window, or door and window assembly. An opening endcap
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style has no independent geometry, but must use a wall endcap style as its
geometry definition. For information on creating wall endcap styles, see
Creating Wall Endcaps Using Calculate Automatically on page 1396 and Creating
a Wall Endcap Style in the Style Manager on page 1401.

NOTE When you change a wall endcap style, all opening endcap styles based on
the wall endcap style are modified, too.

Like a wall endcap style, an opening endcap style must be assigned to a wall
style. For more information, see Applying a Wall Opening Endcap Style to a
Wall Style on page 1408.

1 Verify that the wall endcap style you want to base your opening
endcap style on is present in your drawing, and has the correct
geometry.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Expand Architectural Objects.

4 Expand Opening Endcap Styles, right-click, and click New.

5 Click the Design Rules tab.

In an opening endcap style, you have to define the endcap
condition between the wall and the opening separately for each
direction: jamb start, jamb end, sill, and head.

6 Under Endcap Style, select the wall endcap style for each opening
direction.

7 Click OK.

For information on how to apply the opening endcap style to a
wall style or a wall opening, see Applying a Wall Opening Endcap
Style to a Wall Style on page 1408 and Overriding a Wall Opening
Endcap Style on a Wall on page 1409.

Applying a Wall Opening Endcap Style to a Wall Style
After you create a wall opening endcap style, you need to assign it to the wall
style where you want to use it when adding the following objects to the wall:
doors, windows, openings, and door and window assemblies.

When necessary, you can override the wall opening endcap style assigned in
a wall style on an individual wall.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .
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2 Expand Architectural Objects.

3 Expand Wall Styles, and select the wall style to which you want
to apply the opening endcap style to.

4 Click the Endcaps/Opening Endcaps tab.

5 For Opening Endcaps, select an opening endcap style to use for
each of the opening objects that can interact with the wall.

6 You can also edit an existing opening endcap style here, or create
a new one from wall endcap styles, if necessary.

7 Click OK.

Overriding a Wall Opening Endcap Style on a Wall
Use this procedure to override the style-defined wall opening style for one
intersection of a wall with an opening.

NOTE Each wall opening endcap style is generally created for use with a specific
wall style. Overriding the endcap style for an individual wall and opening may
display solution tip icons in the wall.

1 Select a wall with an opening.

2 Click Wall tab ➤ Endcap panel ➤  ➤ Override Endcap Style

 .

3 Select a point close to the wall opening where you want assign a
different opening endcap.

4 In the Select an Endcap Style dialog, select an endcap style, and
click OK.

Using Ortho Close and Close with Walls
Ortho Close and Close are command-line options that let you efficiently create
a closed space when you add walls.

Ortho Close

This option closes the space by drawing 2 walls based on the direction you
specify. The direction is extended until it meets a line perpendicular to the
initial edge of either the wall. You enter or (Ortho) at the command line to
use this option when placing walls.
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Closing walls with Ortho Close

Close

This option closes the wall by creating a wall segment from the last point
specified for the walls to the first point specified in this group of walls. You
enter c (Close) at the command line to use this option when placing walls.

About Wall Lengths
When you draw a wall, the “true” length of the wall is the distance between
the 2 end grips. The wall can appear to have a different length when it cleans
up with other walls; the difference can be twice the cleanup circle radius longer
or shorter than the “true” length. The “true” length is the length reported by
properties and schedules. To get the most accurate information about wall
length in schedules, always make sure that walls that clean up with each other
have end grips that coincide.

About Curved Walls
The smoothness (tesselation) of curved edges is controlled by the FACETDEV
variable. This variable sets the number of facets to display on curved AEC
objects. The default value is 1/2'' for drawings created from imperial templates
and is 12.7 mm for drawings created from metric templates.
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The number you specify for facet deviation defines the maximum distance
from the chord to the arc, the chord being an edge that is created from faceting
the curve, to the true mathematical arc. The facet deviation has a range of
greater than zero (0) and no upper limit.

Curved wall segments with facet deviation examples

The minimum number of facets is 8. For example, if you create a cylinder
mass element to have a 1'-0'' radius, and specify 1 for FACETDEV, the cylinder
has 8 faces.

To specify the facet deviation values for the current drawing, see Specifying
the Display Resolution of Objects with Facets on page 202. The settings apply
to all curved objects in the drawing, including curved walls.

Specifying Offsets for Roof Line and Floor Line Vertices
When you add or move a vertex on the roof line or the floor line of a wall,
you specify the horizontal and vertical offset of the vertex. You can specify
the offset relative to other vertices or to the base height or the baseline of the
wall. The following table identifies the locations you can specify for the
horizontal offset of a vertex. The offset distance is measured in the direction
the wall was drawn.

Defines the horizontal offset from …This setting …

the wall start point.From Wall Start
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Defines the horizontal offset from …This setting …

the wall endpoint.From Wall End

the midpoint of the wall.From Wall Midpoint

the vertex that is one position closer to the
wall start point than the vertex you are
adding or moving.

From Previous Point

the vertex that is one position closer to the
wall endpoint than the vertex you are
adding or moving.

From Next Point

the midpoint of the distance between the
current vertex and the vertex that is one
position closer to the wall endpoint.

From Midpoint of Neighbors

The following table identifies the locations you can specify for the vertical
offset of a vertex. You can enter a negative distance for the vertical offset to
position a vertex toward the ground.

Defines the vertical offset from …This setting …

the base height of the wall.From Wall Base Height

the vertex that is one position closer to the
wall endpoint than the vertex you are
adding or moving.

From Next Point.

the vertex that is one position closer to the
wall start point than the vertex you are
adding or moving.

From Previous Point

the baseline of the wall.From Baseline

Specifying the Width and Edge Offset of a Wall
Component

You can specify the width and edge offset of a wall component by entering
values, creating a component with a fixed width and offset. You can also
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specify a formula for determining these values. The formula can include a
value for Base Width. By including the Base Width variable in the formula,
you can specify the width of the wall when you add or edit walls of this style
to a drawing.

Specifying a formula to determine component width or edge offset

To calculate the edge offset or the width based on the base width, select Base
Width and select an operator and an operand:

■ If you select Base Width for any component, you can enter a width for
walls of this style when you add or modify them in a drawing.

■ If all components in the wall style use absolute values, you cannot change
the width of individual walls of this style when you add or modify them.

Wall component baseline offset parameters
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Curtain Walls

Curtain walls provide a grid or framework for inserting objects such as windows and doors.
Curtain walls have many similarities to standard walls, such as baseline, roof line, and floor
line, and they allow for interferences. You can insert doors, windows, and door/window
assemblies into a curtain wall, just like standard walls, but the insertion process is different.

Curtain Walls
Curtain walls provide a grid or framework for inserting objects such as windows
and doors. Curtain walls have many similarities to standard walls, such as
baseline, roof line, and floor line, and they allow for interferences. You can
insert doors, windows, and door/window assemblies into a curtain wall, just
like standard walls, but the insertion process is different.

Curtain Wall Grids

Curtain walls are made up of one or more grids. Each grid in a curtain wall has
either a horizontal division or a vertical division, but you can nest the grids to
create a variety of patterns from simple to complex.

Curtain wall nested grid example

22
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Each cell in a grid can contain either a panel infill, to represent basic cladding
materials such as a stone wall panel or glazing, or an object such as a window
or a door.

Assigned curtain wall infill types

Curtain Wall Units and Door/Window Assemblies

Other objects you can insert in a grid include curtain wall units and
door/window assemblies. Curtain wall units are designed to represent complex
elements that are repeated within your main curtain wall.

Assigned curtain wall unit infill

Window assemblies serve a similar function as curtain wall units but can
contain panel infills or objects such as doors or windows. Door/window
assemblies can be inserted into curtain walls and standard walls.
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Assigned door/window assembly infill

Both curtain wall units and door/window assemblies can reduce the need for
nested grids, making edits to the curtain wall easier.

Elements of Grids

Grids are the foundation of curtain walls, curtain wall units, and door/window
assemblies. Every grid has four element types:

■ Divisions: Define the direction of the grid (horizontal or vertical) and the
number of cells

■ Cell Infills: Contain another grid, a panel infill, or an object such as a
window or a door

■ Frames: Define the edge around the outside of the primary grid and nested
grids

■ Mullions: Define the edges between the cells

NOTE  Division is an abstract element, in contrast to the other three element types
that represent physical elements of the curtain wall.

Each element type is assigned a default definition that describes what elements
of that type look like.

Default definitionsElement type

Primary horizontal grid with a fixed cell di-
mension of 13' and secondary vertical grid
with a fixed cell dimension of 3'

Divisions

Cells containing simple panels 2" thickCell Infills
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Default definitionsElement type

Left, right, top, and bottom outer edges
of grid 3" wide and 3" deep

Frames

Edges between cells 1" wide and 3" deepMullions

Specifying grid element types

You can create new element definitions and assign those definitions within
the curtain wall. For example, you can create multiple infill definitions, and
then assign different infills to specific cells in the grid.

Assigning different infills to curtain wall cells

Likewise, you can create multiple frame definitions and then assign a different
definition to each frame edge (top, bottom, left, or right). You can also create
multiple mullion definitions.
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Specifying different frame definitions for each edge of a frame

Experimenting with Curtain Wall Designs

The templates provided with AutoCAD Architecture offer curtain wall styles
as well as curtain wall unit styles and door/window assembly styles. To
familiarize yourself with the curtain wall feature, you can look at those existing
styles and experiment with them. That will make it easier to understand curtain
wall behavior and create your own curtain wall designs. You can find curtain
wall styles and curtain wall unit styles under C:\ProgramData\Autodesk\ACA
2012\enu\Styles\Imperial or C:\ProgramData\Autodesk\ACA 2012\enu\Styles\Metric.

Using Curtain Wall Tools To Create Curtain Walls
Curtain walls are created in much the same way as standard walls. You can
specify a style, a height, and start and endpoints. Curtain walls can be straight,
curved, or a combination of the two.

Tools provided with AutoCAD Architecture let you quickly place curtain walls
by selecting a curtain wall tool with a specific curtain wall style and other
predefined properties. You can use the tool with all of its default settings, or
you can change any properties that are not controlled by the style. You can
also use curtain wall tools to create new curtain walls by applying tool
properties to existing walls, elevation sketches, 2D layout grids, or custom
grids from two dimensional (2D) lines, arcs, and circles.
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Tool palette containing a curtain wall tool

The following palettes contain one or more curtain wall tools:

Curtain Wall ToolsTool Palette

a tool for the Standard curtain wall style
and default settings for other curtain wall
properties

Design palette in the Design palette group

a package of curtain wall and curtain wall
unit tools. For information about accessing

Design Tool Catalog in Content Browser

tools in Content Browser, see Using Tool
Catalog Items in AutoCAD Architecture on
page 167 .

tools with curtain wall styles and properties
that your CAD manager customized for
your projects or office standards.

custom tool palettes created by your CAD
manager

When you place curtain walls using curtain wall tools, you can use the default
settings of the tool, or you can change settings for any curtain wall properties
that are not controlled by the style.

Creating a Straight Curtain Wall
Use this procedure to create a straight curtain wall that has the properties
specified in the curtain wall tool that you select. To specify settings when you
add a curtain wall, see Creating a Curtain Wall with User-Specified Settings
on page 1421 .
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Drawing a straight curtain wall segment

1 Open the tool palette that you want to use, and select a curtain
wall tool.

NOTE  Alternatively, you can  click  Home tab  ➤ Build panel ➤  Wall

drop-down  ➤ Curtain Wall  .

2 Specify a start point for the curtain wall.

You can move or hide the Properties palette to expose more of
the drawing area.

3 Specify an end point.

4 Press ENTER.

Creating a Curtain Wall with User-Specified Settings
Use this procedure to add a curtain wall with settings that you specify.

TIP  To ensure that the Properties palette is displayed before you select a tool,
right-click in the drawing area, and click Properties.
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1 Open the tool palette that you want to use, and select a curtain
wall tool.

NOTE  Alternatively, you can  click  Home tab  ➤ Build panel ➤  Wall

drop-down  ➤ Curtain Wall  .

2 On the Properties palette, expand Basic, and expand General.

3 If desired, you can enter a description for the curtain wall by
clicking the Description setting.

4 Select a style.

The curtain wall style determines many settings of the curtain
wall, like the grid, the frames and mullions used, as well as cell
infills and display settings. For information about curtain wall
styles, see Curtain Wall Styles on page 1436 .

5 Under Bound Spaces, define if this curtain wall can be used as a
bounding object for associative spaces.

You can select three options here:

■ Yes: this curtain wall can be used as bounding object for
associative spaces.

■ No: this curtain wall cannot be used as bounding object for
associative spaces.

■ By style: this curtain wall will use the bounding settings from
the curtain wall style.

For more information on associative spaces, see Generating
Associative Spaces on page 2940 .

6 Expand Dimensions.

7 Modify the dimensions of the curtain wall:

Then …If you want to specify …

enter a value for Base Height.the base height of the curtain wall

enter miter values for Start Miter
and End Miter.

start and end miters

enter the appropriate value for roof
line offset from base height. This

define an offset of the roof line from
the curtain wall base height

offset can be set only during the
insertion of the curtain wall.
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Then …If you want to specify …

enter the appropriate value for floor
line offset from base line. This offset

define an offset of the floor line
from the curtain wall base line

can be set only during the insertion
of the curtain wall.

TIP  The length of the curtain wall is defined on screen. You can
however, edit it in the Properties palette later.

8 To make further edits to the roof line and floor line, expand
Advanced, and click the Roof/floor line worksheet.

For more information, see Changing the Roof Line and the Floor
Line of a Curtain Wall on page 1557 .

9 In the drawing area, specify the insertion point of the curtain
wall.

You can move or hide the Properties palette to expose more of
the drawing area.

NOTE  If you have Dynamic Input activated on the application
window status bar (DYN), you can use dynamic dimensions to specify
the curtain wall length and angle. After clicking the start point of the
curtain wall, dynamic input fields for length and angle appear around
the curtain wall preview. Enter values as desired, and use the TAB key
to switch between input fields.

10 Specify the endpoint of the curtain wall, and press ENTER.

Creating a Curved Curtain Wall
Use this procedure to create a curved curtain wall in a drawing.

The display of curved objects is dependent on the facet deviation set in the
application. For information see Facet Deviation on page 1685 .
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Drawing a curved curtain wall segment

1 Open the tool palette that you want to use, and select a curtain
wall tool.

NOTE  Alternatively, you can  click  Home tab  ➤ Build panel ➤  Wall

drop-down  ➤ Curtain Wall  .

2 On the Properties palette, expand Basic, and expand General.

3 If desired, you can enter a description for the curtain wall by
clicking the Description setting.

4 Select a style.

The curtain wall style determines many settings of the curtain
wall, like the grid, the frames and mullions used, as well as cell
infills and display settings. For information about curtain wall
styles, see Curtain Wall Styles on page 1436 .

5 Under Bound Spaces, define if this curtain wall can be used as a
bounding object for associative spaces.

You can select three options here:

■ Yes: this curtain wall can be used as bounding object for
associative spaces.
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■ No: this curtain wall cannot be used as bounding object for
associative spaces.

■ By style: this curtain wall will use the bounding settings from
the curtain wall style.

For more information on associative spaces, see Generating
Associative Spaces on page 2940 .

6 Select Arc for Segment type.

7 Expand Dimensions.

8 Modify the dimensions of the curtain wall:

Then …If you want to specify …

enter a value for Base Height.the base height of the curtain wall

enter miter values for Start Miter
and End Miter.

start and end miters

enter the appropriate value for roof
line offset from base height. This

define an offset of the roof line from
the curtain wall base height

offset can be set only during the
insertion of the curtain wall.

enter the appropriate value for floor
line offset from base line. This offset

define an offset of the floor line
from the curtain wall base line

can be set only during the insertion
of the curtain wall.

TIP  The length and the radius of the curtain wall are defined on
screen. You can however, edit them in the Properties palette later.

9 To make further edits to the roof line and floor line, expand
Advanced, and click the Roof/floor line worksheet.

For more information, see Changing the Roof Line and the Floor
Line of a Curtain Wall on page 1557 .

10 Specify a start point for the curved curtain wall segment.

You can move or hide the Properties palette to expose more of
the drawing area.
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NOTE  If you have Dynamic Input activated on the application
window status bar (DYN), you can use dynamic dimensions to specify
the curtain wall length and angle. After clicking the start point of the
curtain wall, dynamic input fields for length and angle appear around
the curtain wall preview. Enter values as desired, and use the TAB key
to switch between input fields.

11 Specify the midpoint of the curved curtain wall segment.

12 Specify the endpoint of the curved curtain wall segment.

13 Continue placing curtain walls to create, for example, a building
exterior or a room.

14 Press ENTER.

Creating a Curtain Wall that References a Curve
Use this procedure to create a curtain wall from linework such as lines,
polylines, arcs, and circles.

If you want to create a curtain wall with a mixture of straight and curved
segments, you can use the Add Curtain Wall command. However, for
complicated designs, you might find it easier to draw the segments using lines,
arcs, and circles, and then reference that curve as the baseline for the curtain
wall. This method has an added advantage in that the curve remains in control
of the length and baseline of the curtain wall. Any changes you make to the
curve are reflected in changes to the curtain wall.

Creating a curtain wall that references a curve

Use any of the following objects to create the reference curve:

■ Line

1426 | Chapter 22   Curtain Walls



■ Arc

■ Circle

■ Polyline

■ Spline

■ AEC objects (excluding stairs, columns, roof slabs, grids, and multi-view
blocks. These objects might give you unexpected results when trying to
generate a curtain wall from their base curve.)

1 Open the tool palette that you want to use.

2 Right-click a curtain wall tool, and click Apply Tool Properties
to ➤ Referenced Base Curve.

3 Select the geometry to reference.

If the geometry you want to reference consists of multiple
segments, you must repeat this procedure for each segment.

4 Edit the properties of the curtain walls in the Properties palette,
if needed.

Converting a Layout Grid to a Curtain Wall
Use this procedure to create a curtain wall that is based on a 2D layout grid.
If you already have 2D layout grids in a drawing, you can easily convert them
to curtain walls. Or if you are already familiar with layout grids, it is an efficient
way to create a curtain wall, and then experiment with the curtain wall
commands to learn more about them.

Converting a 2D layout grid to a curtain wall

When you create a curtain wall from a 2D layout grid, you also create a new
curtain wall style. The divisions in the new curtain wall style are taken from
the divisions in the layout grid.
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Curtain wall grids are one dimensional—divided either horizontally or
vertically. To create the horizontal and vertical patterns in the 2D layout grid,
the curtain wall uses a primary grid with a secondary grid nested inside it. For
more information about nested grids, see Working with Nested Grids in
Curtain Walls on page 1478 .

When you create a curtain wall grid from a 2D layout grid, you need to decide
the direction of the primary grid in the curtain wall. If you select horizontal,
the primary grid has horizontal divisions that cross over the vertical divisions
of the secondary grid. If you select vertical, the primary grid has vertical
divisions that cross over the horizontal divisions of the secondary grid.

Specifying primary division directions

The horizontal and vertical lines of the 2D layout grid define the divisions for
the curtain wall grids. The grid cells, frame, and mullions are assigned default
definitions. For more information, see Assigning Definitions to Curtain Wall
Elements on page 1475 .

1 Open the tool palette that you want to use.

2 Right-click a curtain wall tool, and click Apply Tool Properties
to ➤ Layout Grid.

3 Select the layout grid to convert.

4 When prompted to erase the original geometry, press ENTER to
keep the layout grid, or enter y (Yes) to erase it.

5 Press ENTER to specify horizontal as the orientation for the primary
division, or enter v to specify vertical.

6 Enter a name for the curtain wall style generated from the grid
layout, and click OK.

7 Edit the properties of the curtain wall in the Properties palette, if
needed.
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Creating a Curtain Wall from an Elevation Sketch
You can create a sketch of a custom grid with lines, arcs, and circles, and then
convert that linework into a curtain wall.

NOTE  Curtain wall grids are either horizontal or vertical. To create a grid pattern
with horizontal and vertical cells, nested grids are used. For more information
about nested grids, see Working with Nested Grids in Curtain Walls on page 1478
.

The resulting curtain wall is assigned a custom grid division definition, which
you cannot modify. You can, however, assign a different division definition
to it. For more information, see Assigning a Division to a Curtain Wall Grid
on page 1476 .

1 Verify that you are drawing in world coordinate system (WCS).

2 Use lines, arcs, and circles to create an elevation sketch.

3 Right-click a curtain wall tool, and click Apply Properties
to ➤ Elevation Sketch.

4 Select the linework of the sketch.

5 Press ENTER.

6 Select one of the grid lines as the baseline for the curtain wall or
press ENTER to use the line along the X axis as the default baseline.

Converting linework to curtain walls using the default baseline option

If you draw your linework in the XY plane (in Plan view) and
accept the default baseline, the resulting curtain wall is displayed
as it is projected in the Z direction.
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Converting linework to curtain walls using the specified baseline option

7 To erase the lines, enter y (Yes). To have the lines remain after
the curtain wall is created, enter n (No).

When you create a curtain wall from an elevation sketch, the
properties and design rules of the curtain wall style are applied
to the generated curtain wall. The grid of the generated curtain
wall will however differ from the curtain wall style, and is defined
as a custom grid.

The custom grid is not automatically saved back to the curtain
wall style, but is treated as an object override on the generated
curtain wall. You can proceed in these ways:

■ You can leave the custom grid as an override on the curtain
wall object. This is recommended if the curtain wall generated
from the elevation sketch has a unique grid that does not need
to be reused.

■ You can save the custom grid of the elevation sketch back to
the existing curtain wall style, changing the curtain wall style
to reflect the grid of the elevation sketch.

■ You can save the custom grid of the elevation sketch to a new
curtain wall style and use that for other, similar curtain walls.

8 Proceed in one of the following ways:

Then…If you want to…

no further action is required.leave the custom grid on
the curtain wall object as
an override
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Then…If you want to…

select the curtain wall, and  click  Curtain Wall

tab  ➤ Modify panel ➤  Design Rules drop-

save the custom grid of
the elevation sketch back
to the existing curtain
wall style

down  ➤ Save To Style.  Verify that under
Save Changes to Style the correct style is se-
lected, and click OK.

select the curtain wall, and  click  Curtain Wall

tab  ➤ Modify panel ➤  Design Rules drop-

save the custom grid of
the elevation sketch to a
new curtain wall style down  ➤ Save To Style.  Click New, and enter

a name for the new curtain wall style. Then,
click OK.

Converting a Wall to a Curtain Wall
Use this procedure to create curtain walls based on existing standard walls.
For each wall segment, a separate curtain wall is created. During the conversion
process, you are prompted to select a curtain wall style that determines the
number and size of cells in the curtain wall grid as well as the appearance of
the cells, frame, and mullions. For more information, see Curtain Wall Styles
on page 1436 .

Converting a wall to a curtain wall

1 Open the tool palette that you want to use.

If necessary, scroll to display the tool that you want to use.

2 Right-click a curtain wall tool, and click Apply Tool Properties
to ➤ Walls.

3 Select the wall, and press ENTER.
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4 Specify if the curtain wall should be aligned to the left side, the
right side, the center line, or the baseline of the wall it is created
from.

Specifying the alignment of the curtain wall

5 To erase the wall, enter y (Yes). To have the wall remain after the
curtain wall is created, enter n (No).

6 Press ENTER.

Converting a 3D Face to a Curtain Wall
Use this procedure to create curtain walls based on faces of existing mass
elements, mass groups, or AutoCAD® entities, such as a mesh, ruled surface,
or solid. This might be helpful after you have developed a building model.
For more information, see Using the Model Explorer to Create Mass Models
on page 1087 . For each face, a separate curtain wall is created. During the
conversion process, you are prompted to select a curtain wall style that
determines the number and size of cells in the curtain wall grid as well as the
appearance of the cells, frame, and mullions. For more information, see Tips
for Working Efficiently with Curtain Wall Styles on page 1438 .

Use this procedure to generate a curtain wall of the face of a 3D object. Objects
that have faces that can be used to generate curtain walls are the following:

■ mass elements
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■ mass groups

■ 3D spaces

■ slabs

■ roof slabs

■ roofs

■ AutoCAD 3D meshes

■ AutoCAD 3D solids

1 Open the tool palette that you want to use.

If necessary, scroll to display the tool that you want to use.

2 Right-click a curtain wall tool, and click Apply Tool Properties
to ➤ Faces.

3 Select a face to convert, or press CTRL and select multiple faces.

You can press TAB to cycle through the faces.

The Convert to Curtain Walls worksheet opens.

4 Select the curtain wall style.

5 To erase the object the face belongs to, select Erase Layout
Geometry.

6 Click OK.

Creating a Curtain Wall Tool
Use this procedure to create a curtain wall tool and add it to a tool palette.
You may want to create your own curtain wall tools if you are placing multiple
curtain walls of specific styles with additional properties that you want to be
the same each time you add a curtain wall of each type.

1 Open the tool palette where you want to create a tool.
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2 Create the tool:

Then …If you want to …

select the object, and drag it to the
tool palette.

create a tool from a curtain wall in
the drawing

click  Manage tab  ➤ Style & Dis-

play panel ➤ Style Manager  .

create a tool from a curtain wall
style in the Style Manager

Locate the style you want to copy,
and drag it to the tool palette. Click
OK.

NOTE  You can only drag a
style to a tool palette if the style
has previously been saved with
the drawing. Otherwise you are
prompted to save the drawing
first, and then create a tool
from the style.

right-click the tool, and click Copy.
Deselect the tool, right-click any-

copy a tool in the current tool
palette

where in the palette, and click
Paste.

open the tool palette containing
the tool you want to copy, right-

copy a tool from another tool
palette

click the tool, and click Copy. Open
the palette where you want to add
the tool, right-click, and click Paste.

click  Home tab  ➤ Build panel ➤ 

Tools drop-down  ➤ Content

copy a tool from the Content
Browser

Browser  and locate the tool
you want to copy. Position the
cursor over the i-drop handle, and
drag the tool to the tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.
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5 Click the setting for Description, enter a description of the tool,
and click OK.

6 Expand Basic, and expand General.

7 Click the setting for Description, enter a description of the curtain
wall created from this tool, and click OK.

8 Specify a layer key and any layer key overrides if you do not want
to use the layer assignments specified in the layer key style used
in the drawing.

9 Specify the location of the curtain wall style used in this tool.

By default, the style location is set to Undefined (--) and the styles
from the current drawing are displayed in the list of available
styles. You can however navigate to one of the curtain wall styles
drawings shipped with the product under
C:\ProgramData\Autodesk\ACA 2012\enu\Styles , or to a user-defined
styles drawing.

10 Select a style for the curtain wall tool.

11 Under Bound Spaces, define if this curtain wall tool can be used
as a bounding object for associative spaces.

You can select four options here:

■ Yes: this curtain wall tool can be used as bounding object for
associative spaces.

■ No: this curtain wall tool cannot be used as bounding object
for associative spaces.

■ By style: this curtain wall tool will use the bounding settings
from the curtain wall style.

■ Undefined (--): If you create a new curtain wall with this tool,
it will use the default bounding setting (by style). If you apply
the properties of this curtain wall tool to an existing curtain
wall, the bounding settings of that curtain wall will be used.

NOTE  For more information on associative spaces, see Generating
Associative Spaces on page 2940 .

12 Modify the dimensions of the curtain wall:

Then …If you want to specify …

enter a value for Base height.the base height of the curtain wall
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Then …If you want to specify …

enter miter values for Start Miter
and End Miter.

start and end miter angles

enter a value for Roof line offset
from base height.

the roof line offset from the base
height of the curtain wall

enter a value for Floor line offset
from baseline.

the floor line offset from the
baseline of the curtain wall

13 Click OK.

Curtain Wall Styles
Curtain walls are style-based, which means there are preset characteristics
assigned to each curtain wall that determine its appearance and function. By
changing from one style of curtain wall to another, you can quickly study
several different design options. Any changes you make to the style updates
all curtain walls of that particular style. You can also apply overrides to a single
curtain wall, without changing other curtain walls of the same style.

A curtain wall style controls the following properties of a curtain wall:

■ Division definitions/Grids

■ Infill definitions

■ Frame definitions

■ Mullion definitions

■ Assignments of grids, infills, frames, and mullions to curtain wall cells

■ Materials for each element

■ Display properties for each element

■ Notes about the style and any associated reference files

Using Materials in Curtain Wall Styles

You can use materials to control how curtain walls of each style are displayed
in a drawing. You assign materials to the curtain wall elements in the style.
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The elements are then displayed using the display properties of the assigned
materials.

AutoCAD Architecture provides a large number of predefined materials for
common design purposes. You can use these materials, modify them for your
project requirements, and define new materials. For more information about
materials and how to define them, see Materials on page 885 .

Creating Tools from Curtain Wall Styles

You can create a curtain wall tool from any curtain wall style. You can drag
the style from the Style Manager onto a tool palette. You can then specify
settings for any curtain wall properties for the tool. For more information, see
Creating a Curtain Wall Tool on page 1433 .

To create, edit, copy, or purge styles, you access the Style Manager. The Style
Manager provides a central location in AutoCAD Architecture to work with
styles from multiple drawings and templates. For more information about
using the Style Manager, see Style Manager Overview on page 870 .

Process Overview: Creating a Curtain Wall Style
When you create a curtain wall style, you assign characteristics to any or all
elements of a curtain wall and save them as a named style. In this way, you
standardize the appearance of all curtain walls that use the style. When you
modify a style, all curtain walls in your drawing that use the style are updated
to reflect the changes.

1 Define divisions for the curtain wall grid.

For information on defining curtain wall grid definitions, see Defining
Divisions for Curtain Wall Grids on page 1442 .

2 Define the infill for the cells of the curtain wall.

For information on creating infills, see Defining Infills for Curtain Wall
Cells on page 1455 .

3 Define the curtain wall frame, including using profiles and specifying
offsets.

For information on defining a frame for a curtain wall, see Defining
Curtain Wall Frames on page 1461 .

4 Define the mullions for the curtain wall, including using profiles and
specifying offsets.
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For information on ways to define mullions, see Defining Curtain Wall
Mullions on page 1468 .

5 Assign the element definitions you created:

Then …If you want to assign …

see Assigning a Division to a Curtain
Wall Grid on page 1476 .

a division to a curtain wall grid

see Assigning Infills to Curtain Wall Cells
on page 1477 .

infills to curtain wall cells

see Assigning Definitions to Curtain
Wall Frames on page 1489 .

definitions to curtain wall frames

see Assigning Definitions to Curtain
Wall Mullions on page 1493 .

definitions to curtain wall mullions

6 Specify the materials of the curtain wall style.

For information on specifying materials, see Specifying the Materials of
a Curtain Wall Style on page 1496 .

7 Specify the display properties of the curtain wall, including layer, color,
linetype, and hatching.

For information on specifying the display properties of a curtain wall,
see Specifying the Display of Curtain Walls on page 1499 .

8 Attach notes and reference documents to the curtain wall style.

For information on attaching notes and files, see Attaching Notes and
Files to a Curtain Wall Style on page 1506 .

Tips for Working Efficiently with Curtain Wall Styles
Use these suggestions to work efficiently and productively with curtain wall
styles:

■ Name grids and elements very clearly to identify where they are used and
what they are. For example, use the name L3-FL1-H to represent a
third-level grid used on the first floor and which has a horizontal division.

■ Use the element definition that is applied most often as the default element
definition. For example, if most cells are stone panels, define the default
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infill as the stone panel. This panel is then used in every cell that is not
specifically assigned to another infill. Apply this rule to the default frame,
mullion, and division.

■ Use curtain wall units and door and window assemblies to simplify the
complexity of a curtain wall style.

■ Name the styles for doors, windows, curtain wall units, AEC polygons, and
curtain walls to indicate where they are used and what they are.

■ Use cell and edge overrides to define special conditions not accounted for
in the curtain wall style.

Creating Element Definitions for a Curtain Wall Style
Element definitions determine the appearance of the four basic curtain wall
elements. There is a different definition type for each element.

Curtain wall grid element types

Each type of element can have multiple definitions. For example, you can
define a division to create a horizontal grid or a vertical grid, and you can
define the cells to contain a nested grid or a door/window assembly. To make
reuse easier, you can save the element definitions, and then assign them to
grids, cells, frames, or mullions as needed.

Element definitions are style-specific. When you create element definitions
for a specific curtain wall style, those definitions are available only for curtain
walls of that style. For example, if you define a door and window assembly
infill for one curtain wall style, that infill is not available as an option when
you edit a curtain wall of a different style.
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When you create a new element definition, like a new grid division, a new
frame, cell infill, or mullion, you need to define a display component for this
element in order to control the visual appearance (layer, color, and linetype
properties) of this element separately from the other elements. For example,
if you have defined a new panel infill, and want to assign a concrete gray color
to that, you need to define a display component for the new infill, and assign
it a grey color. For information on defining display components for elements,
see Adding Curtain Wall Element Definitions as Display Components on
page 1500 . If you do not define a display component for a new element, its
display will be controlled by the display component of the default element
of that type. For example, if you have a new panel infill, but do not define a
display component for it, then its display is controlled by the default infill
display component.

Creating a Curtain Wall Style
Use this procedure to create a curtain wall style. You can create a style using
default style properties or by copying an existing style. After you create the
style, you edit the style properties to customize the characteristics of the style.
You can also create a curtain wall tool based on the newly created curtain wall
style. When you use the tool to add curtain walls, each curtain wall has the
style specific to the tool.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Create a new curtain wall style:

Then …If you want to create a style …

right-click Curtain Wall Styles, and
click New.

with default properties

right-click the curtain wall style you
want to copy, and click Copy.
Right-click, and click Paste.

from an existing style

right-click Curtain Wall Styles, and
click New. Right-click the new style,

from a curtain wall, curtain wall
unit, or door and window assembly
in the drawing click Set From, and then select a

curtain wall, a curtain wall unit, or
a door and window assembly in the
drawing.

1440 | Chapter 22   Curtain Walls



4 If necessary, right-click the style again, and click Rename to enter
a descriptive name for the new curtain wall style.

5 Edit the new curtain wall style:

Then …If you want to …

see Defining Divisions for Curtain
Wall Grids on page 1442 , Defining

define the elements of a curtain wall
style

Infills for Curtain Wall Cells on page
1455 , Defining Curtain Wall Frames
on page 1461 , and Defining Curtain
Wall Mullions on page 1468 .

see Assigning Definitions to Curtain
Wall Elements on page 1475 , Assign-

assign element definitions to the
curtain wall style

ing a Division to a Curtain Wall Grid
on page 1476 , Assigning Infills to
Curtain Wall Cells on page 1477 ,
Assigning Definitions to Curtain
Wall Frames on page 1489 , and As-
signing Definitions to Curtain Wall
Mullions on page 1493 .

see Adding Curtain Wall Element
Definitions as Display Components
on page 1500 .

add curtain wall element definitions
as display components

see Specifying the Layer, Color,
and Linetype of a Curtain Wall Style
on page 1501 .

specify layer, color and linetype
settings for the display components
of a curtain wall

see Specifying the Hatching for
Components of a Curtain Wall Style
on page 1501 .

specify curtain wall hatching

see Adding Custom Graphics as a
Display Component of a Curtain
Wall on page 1503 .

add custom graphics as display
components of a curtain wall style

see Creating Cut Planes for a Cur-
tain Wall on page 1504 .

create individual cut planes for cur-
tain wall styles

see Specifying the Materials of a
Curtain Wall Style on page 1496 .

specify the materials of the curtain
wall style
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Then …If you want to …

see Attaching Notes and Files to a
Curtain Wall Style on page 1506 .

add notes and files to the style

6 When you finish specifying the properties of the curtain wall
style, click OK.

7 If you want to assign the style to a curtain wall tool, drag the style
from the Style Manager to a tool palette.

You can later rename the tool and specify other properties for it
as described in Creating a Curtain Wall Tool on page 1433 .

8 Click OK.

Defining Divisions for Curtain Wall Grids
The divisions of a grid define the orientation that determines the direction
of the grid cells and mullions, and they define a division type that determines
the number and size of cells.

NOTE  Creating a nested grid is not a division rule. To create a nested grid, add
a cell assignment. For more information, see Creating a Nested Grid in a Curtain
Wall on page 1480  and Working with Nested Grids in Curtain Walls on page 1478 .

You can create a variety of division definitions under different names, and
then assign different divisions to each grid in your curtain wall. Although you
can create multiple definitions, there can be only one division assignment
per grid. You create division definitions for a specific curtain wall style and
those definitions can be assigned only to grids in curtain walls of that style.

For more information about assigning divisions to a particular grid, see
Assigning a Division to a Curtain Wall Grid on page 1476 .

Division of Curtain Wall Grids
A curtain wall consists of one or more grids, which are the framework for
placing design elements in the curtain wall. The highest-level grid is the
primary grid, which is also the outside edge of the curtain wall.

Each grid in a curtain wall has one division assignment that determines
whether the grid is divided horizontally or vertically. The division also
determines the number of cells, their size, and their placement.

1442 | Chapter 22   Curtain Walls



Within the primary grid, you can define multiple levels of grids. These grids
within the primary grid are called nested grids. Each subdivision of a grid is
called a cell.

Creating a Division Definition for a Curtain Wall
Use this procedure to create divisions for a curtain wall grid.

Because curtain walls can contain multiple nested grids, it is helpful to use a
naming convention for grids that indicates the level of each grid and the grid
location or the purpose within the curtain wall. For example, L2-FL1-Stone
Panels can identify a secondary grid that provides a row of stone panels on
Floor 1.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Click New Division (  ).

7 Enter a name for this division definition.
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8 Select either Vertical orientation  or Horizontal orientation

 .

9 Select one of the following division types and specify offsets if
needed.

DescriptionDivision Type

Creates a grid where the size of the
individual cells is fixed at a user-

Fixed Cell Dimension

defined size. For more information,
see Specifying a Division with a
Fixed Cell Size on page 1445 .

Creates a grid where the number
of grid cells is fixed at a user-

Fixed Number of Cells

defined cell number. For more in-
formation, see Specifying a Division
with a Fixed Cell Number on page
1448 .

Creates a grid where the size and
number of individual cells is manu-

Manual

ally determined by the user. For
more information, see Specifying
a Division with Manually Defined
Cells on page 1449 .

Creates a horizontal grid that does
not extend to gables or steps in a

Baseline/ Base Height (horizontal
grids only)

curtain wall. For more information,
see Excluding Gables and Steps
from a Curtain Wall Grid on page
1450 .

Creates a vertical grid from a poly-
line that adds a grid line for each

Polyline (vertical grids only)

vertex of the polyline. For more in-
formation, see Dividing a Vertical
Curtain Wall Grid at Each Vertex
Along a Polyline on page 1452 .
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After you create a division definition, you can assign the definition
to a specific grid in a curtain wall. For more information, see
Assigning a Division to a Curtain Wall Grid on page 1476 .

10 When you are finished creating division definitions, click OK.

Specifying a Division with a Fixed Cell Size
Use this procedure to define a division that has a fixed size for the cells
contained in it. In this case, the number of cells is determined by the length
or height of the grid, depending on the grid orientation.

When you specify a fixed cell size in a grid division, you can control how the
cells of the grid adjust to accommodate any leftover space. This space occurs
if the length (or the height) of the curtain wall cannot be evenly divided by
the fixed size of the cell.

Specifying a fixed size for cells

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Divisions definition or create a new one.
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7 Under Division Type, select Fixed Cell Dimension.

8 Under Cell Dimension, specify a size for the cells.

If you are defining a vertical division, the cell dimension is the
length of the cell from mullion to mullion. If you are defining a
horizontal division, the cell dimension is the height of the cell.

9 To specify an offset for the grid, enter an offset distance in Start
Offset/Top Offset or End Offset/Bottom Offset. For more
information, see Specifying an Offset for a Curtain Wall Grid on
page 1453 .

TIP  The frame width is calculated as part of the cell size. Therefore,
cells adjacent to the frame can appear to be a different size than the
other cells. If you do not want the frame width included in the cell
size, specify an offset for the grid that is equal to the frame width.

When you draw a curtain wall using a fixed cell dimension, there
is often extra space between the last full-size cell and the end of
the curtain wall.

10 Adjust the cells to accommodate this extra space:

Then …If you want to …

select Auto-Adjust Cells, select Grow
for Cell Adjustment, and select the

add the space to grid cells

specific cells where the space is to
be added. You can select any com-
bination of Specific Cells.

select Auto-Adjust Cells, select
Shrink for Cell Adjustment, and se-

remove the space from grid cells

lect the specific cells where the
space is to be removed. You can
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Then …If you want to …

select any combination of Specific
Cells.

11 Under Specific Cells, select the cells where the space is to be added
or removed.

You have the following options:

■ Start of curtain wall (  ): For a vertical division, you can add
or remove extraneous space from the start cell of the curtain
wall. The start cell is determined by the drawing direction of
the curtain wall.

■ Vertical middle of curtain wall (  ): If the curtain wall has
an uneven number of vertical cells, the middle cell is grown
or shrunk. If the curtain wall has a an even number of vertical
cells, the two middle cells are grown or shrunk.

■ End of curtain wall (  ): For a vertical division, you can add
or remove extraneous space from the end cell of the curtain
wall. The end cell is determined by the drawing direction of
the curtain wall.

■ Top of curtain wall (  ): For a horizontal division, you can
add or remove extraneous space from the top cell of the curtain
wall.

■ Horizontal middle of curtain wall (  ): If the curtain wall
has an uneven number of horizontal cells, the middle cell is
grown or shrunk. If the curtain wall has a an even number of
horizontal cells, the two middle cells are grown or shrunk.

■ Bottom of curtain wall (  ): For a horizontal division, you
can add or remove extraneous space from the bottom cell of
the curtain wall.

You can select multiple options here; for example, you can select
to add additional space to the start and end cells, or to the start,
middle, and end cells.

12 Click OK.
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As the next step, you will assign the division definition to a grid in a curtain
wall style. For more information, see Assigning a Division to a Curtain Wall
Grid on page 1476 .

Specifying a Division with a Fixed Cell Number
Use this procedure to define a specific number of cells in a grid. In this case,
the size of the cells is determined by the length or height of the grid, depending
on how the grid is divided.

In some cases, when you create a complex curtain wall grid, you might want
to start with a standard grid with a fixed number of cells, and then later
fine-tune that manually. You can first create a grid with fixed cell numbers
and then convert that to a manual grid. For information on manual grids, see
Specifying a Division with Manually Defined Cells on page 1449 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Division definition or create a new one.

7 Under Division Type, select Fixed Number of Cells.

8 Specify the number of cells.

9 To specify an offset for the grid, enter an offset distance for Start
Offset or End Offset.

For more information, see Specifying an Offset for a Curtain Wall
Grid on page 1453 .
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NOTE  If you want to fine-tune the initial layout with a fixed number
of cells, click Convert To Manual Division and edit the grid as
described in Specifying a Division with Manually Defined Cells on
page 1449 .

10 Click OK.

For information about assigning the division definition to a specific grid in
your curtain wall, see Assigning a Division to a Curtain Wall Grid on page
1476 .

Specifying a Division with Manually Defined Cells
Use this procedure to manually add gridlines and specify an offset for each
one when you need to create a unique grid that does not fit into any of the
other division types. You can also start with a fixed cell dimension grid or a
fixed number of cells grid, and then manually adjust the grid lines to suit your
needs.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Division definition or create a new one.

7 Select Manual for Division Type.

8 Click Add Gridline to insert a grid line. Insert as many grid lines
as you need. If you need to remove a grid line, select it from the
table and click Remove Gridline.

9 Under Offset in the gridline table, specify an offset distance for
each grid line.

Gridline offset
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10 Under From in the grid line table, select the grid location from
which the grid line is offset.

Offset grid line from option

11 To specify an offset for the grid, enter an offset distance for Start
Offset or End Offset.

For more information, see Specifying an Offset for a Curtain Wall
Grid on page 1453 .

12 Click OK.

For information about assigning the division definition to a
specific grid in your curtain wall, see Assigning a Division to a
Curtain Wall Grid on page 1476 .

Excluding Gables and Steps from a Curtain Wall Grid
If you are designing a curtain wall that has gables in the roof line or steps in
the floor line, there may be occasions when you do not want the grid to extend
into those areas. To define your curtain wall in this case, you can define a
single-cell horizontal grid that excludes those areas, and then use that grid as
a starting point for nested grids. For information about nested grids, see
Working with Nested Grids in Curtain Walls on page 1478 .

NOTE  For information about adding steps or gables to your curtain wall, see
Changing the Roof Line and the Floor Line of a Curtain Wall on page 1557 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Division definition or create a new one.

7 Select Horizontal for Orientation.

8 Select Baseline/Base Height for Division Type.
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9 Select Divide at Baseline or Divide at Base Height.

■ Divide at Baseline: Forces a division at the baseline to exclude
steps from the grid.

■ Divide at Base Height: Forces a division at the base height to
exclude gables from the grid.

10 To offset the division from the baseline, enter a positive number
for Baseline Offset.

11 To offset the division from the base height, enter a positive
number for Base Height Offset.

12 Click OK.

The resulting grid contains a single, horizontal cell. To add additional divisions,
use nested grids. For more information, see Creating a Nested Grid in a Curtain
Wall on page 1480 .

For information about assigning the division definition to a specific grid in
your curtain wall, see Assigning a Division to a Curtain Wall Grid on page
1476 .
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Dividing a Vertical Curtain Wall Grid at Each Vertex Along a
Polyline

If you create a curtain wall by referencing a polyline, you can define a vertical
grid for your curtain wall by placing grid lines at each vertex along the polyline.

1 Draw a polyline and use it as a reference curve to create a curtain
wall.

For more information, see Creating a Curtain Wall that References
a Curve on page 1426 .

2 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

3 Expand Architectural Objects, and expand Curtain Wall Styles.

4 Select a curtain wall style.

5 Click the Design Rules tab.

6 In the left pane, select Divisions under Element Definitions.

7 Select a Division definition or create a new one.

8 Select Vertical for Orientation.

9 Select Polyline for Division Type.

10 Click OK.

For information about assigning the division definition to a specific grid in
your curtain wall, see Assigning a Division to a Curtain Wall Grid on page
1476 .
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Specifying an Offset for a Curtain Wall Grid
By default, grids cells are measured from the start and end points of the curtain
wall baseline (for horizontal divisions) or from the floor line to the roof line
(for vertical divisions). The width of the grid frame is not considered in
calculating the size of the cell. For example, if you draw a curtain wall with a
14' baseline and a 1' frame on the left and right, and you specify a fixed number
of vertical cells, the cells do not appear equal in size. The first and last cells
appear smaller because they include the frame. To make the cells equal in size,
offset the start and end of the grid by the width of the frame.

Specifying grid offset directions

NOTE  You can offset the grid only when the division type is Fixed Cell Dimension,
Fixed Number of Cells, or Manual.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Division definition or create a new one.

7 Select Fixed Cell Dimension, Fixed Number of Cells, or Manual
for Division Type.
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8 Specify an offset for the grid.

Then …If you want to specify the dis-
tance between …

enter a value for Start Offset.the start point of the curtain wall
baseline and the start of the first cell
in a horizontal grid

enter a value for End Offset.the end point of the curtain wall
baseline and the end of the last cell
in a horizontal grid

enter a value for Bottom Offset.the floor line of the curtain wall and
the start of the bottom cell in a
vertical grid

enter a value for Top Offset.the roof line of the curtain wall and
the end of the top cell in a vertical
grid

9 Click OK.

Removing a Division Definition from a Curtain Wall Style
Use this procedure to remove a division definition that you no longer need.
You cannot remove a division definition when it is currently assigned to a
grid. In addition, you cannot remove the default division definition, but you
can modify it.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Division definition that you want to remove.
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7 Click Remove.

8 Click OK.

Defining Infills for Curtain Wall Cells
An infill defines the contents of a curtain wall cell. A curtain wall cell can
have the default simple panel or contain a nested grid, an AEC Polygon, curtain
wall unit, door, window, or door/window assembly style. The object styles
you use in infills must exist in the current drawing to be added to an infill
definition. Panels typically represent glazing or other plain cladding, such as
stone or concrete. For more information, see Assigning Infills to Curtain Wall
Cells on page 1477 .

Specifying different infills

NOTE  Nested grids and no infill are options you select when assigning an infill
to a cell. These options do not require infill definitions. For more information, see
Creating a Nested Grid in a Curtain Wall on page 1480  and Removing an Infill from
a Curtain Wall Cell on page 1486 .

You can define as many infills as you need, and then use cell assignments to
specify the cells that use each infill. You can modify, as needed, a default infill
that is used for all unassigned cells. For more information about cell
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assignments, see Assigning Definitions to Curtain Wall Elements on page 1475
.

NOTE  Create infill definitions for a specific curtain wall style. Those definitions
can be assigned only to grid cells in curtain walls of that style.

Materials

Styles use the materials of the object style assigned to each panel. For example,
if you specify an infill to use the Standard door style, the materials of that
infill are those designated in the door style. Simple Panels need material
assigned in the curtain wall style.

If you do not use materials to control the display properties of infills, you can
specify their display properties in the curtain wall style. The layer, color,
linetype, and other display properties of the default infill are applied to all
infills unless you create a custom display component for each infill definition.
You can then control the display of each infill definition independently. For
more information, see Specifying the Display of Curtain Walls on page 1499 .

Creating a Panel Infill for a Curtain Wall
Use this procedure to create a simple panel infill to represent basic cladding
materials in the curtain wall, such as a stone wall panel, concrete panel, metal
panel, or glazing infill.

Because curtain walls can contain multiple infills, it is helpful to use a naming
convention for panel infills that indicates the infill location or purpose within
the curtain wall. For example, L3-FL1- Stone Panel can identify a stone panel
in a third-level grid on Floor 1.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.

6 Click New Infill.

7 Enter a descriptive name for the infill.

8 Select Simple Panel as the infill type.

9 Specify an alignment for the infill.
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For more information, see Specifying an Alignment for a Curtain
Wall Infill on page 1458 .

10 Specify an offset for the infill.

For more information, see Specifying an Offset for a Curtain Wall
Infill on page 1459 .

11 Specify a thickness for the panel.

Specifying infill panel thickness

12 Click OK.

After you create an infill definition, you can assign it to any cell in a curtain
wall grid. For more information, see Assigning Infills to Curtain Wall Cells
on page 1477 .

Creating a Style Infill for a Curtain Wall
Use this procedure to create a style infill to insert objects into a curtain wall.
You can insert doors, windows, door/window assemblies, curtain wall units,
and AEC Polygons by defining a specific style of that object as an infill.

TIP  After you insert an object in a cell, you can select that object independent of
the grid and access editing options for the object.

Because curtain walls can contain multiple object styles, it is helpful to use a
naming convention for style infills that indicates the infill location or purpose
within the curtain wall. For example, L3-FL1-Octagonal Window can identify
an octagonal window in a third-level grid on Floor 1.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.
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3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.

6 Click New Infill.

7 Enter a descriptive name for the infill.

8 Select Style as the infill type.

The bottom right pane changes to display a tree view of the object
styles available for insertion into a curtain wall.

9 Select an object style.

There is a unique icon for each type of style, for example the door

style icon  and the curtain wall unit icon  . These icons are
also displayed next to the infill name at the top of the dialog box
to help you identify the type of infill.

10 Specify an alignment for the infill. For more information, see the
next section Specifying an Alignment for a Curtain Wall Infill
on page 1458 .

11 Specify an offset for the infill. For more information, see
Specifying an Offset for a Curtain Wall Infill on page 1459 .

12 Click OK.

After you create an infill definition, you can assign it to any cell in a curtain
wall grid. For more information, see Assigning Infills to Curtain Wall Cells
on page 1477 .

Specifying an Alignment for a Curtain Wall Infill
Use this procedure to align an infill so that it is centered with the baseline of
the curtain wall, in front of the baseline, or behind the baseline. In Plan view,
the front of a curtain wall (drawn from left to right) is below the baseline and
the back is above the baseline.

NOTE  To move the infill away from the baseline, see Specifying an Offset for a
Curtain Wall Infill on page 1459 .
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Specifying infill alignments

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.

6 Select an infill, or create a new one.

7 Select an alignment: front, center, or back.

8 Click OK.

Specifying an Offset for a Curtain Wall Infill
Use this procedure to specify an offset for a curtain wall infill. By default,
infills are centered on the curtain wall baseline. If your design requires that
the infill be aligned with frame edges or some other part of the curtain wall,
you can specify an offset for the infill.

You can also edit individual style-based infills directly in the drawing. The
selected infill has Flip grips in both the X and Y directions so that you can
change the orientation of the infill.
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Specifying panel infill offsets

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.

6 Select an infill, or create a new one.

7 Enter an offset distance.

In Plan view, positive numbers offset the infill above the baseline
and negative numbers offset the infill below the baseline. The
offset is also affected by the selected alignment for the infill.

8 Click OK.
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Removing an Infill Definition from a Curtain Wall Style
Use this procedure to delete an infill definition that you no longer need from
the Infills definitions list. You cannot remove an infill definition when it is
currently assigned to a cell. In addition, you cannot remove the default infill
definition, but you can modify it as needed.

NOTE  For information about removing an infill from a cell, see Removing an
Infill from a Curtain Wall Cell on page 1486 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.

6 Select the unneeded infill definition, and click Remove.

7 Click OK.

Defining Curtain Wall Frames
All curtain wall grids, including the primary grid, can have frame definitions.
The frame of the primary grid defines the outer edges of the curtain wall. The
overall frame size is determined by the length and height of the primary
curtain wall grid or a nested curtain wall grid. You can define a frame by
specifying a width and depth or by selecting a profile.
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Specifying default and profile-based frames

You create frame definitions for a specific curtain wall style. Those definitions
can be assigned only to frames in curtain walls of that style. You can create
as many frame definitions as you want, and then assign the definitions to the
frames as needed. If you have nested grids, each grid has its own frame. There
is a default frame definition that you can modify and assign as needed.
Unassigned frames are not displayed. For more information, see Assigning
Definitions to Curtain Wall Frames on page 1489 .

TIP  Using Style Manager, you can copy a mullion definition and use it as a frame
definition. Select the mullion definition and drag it to Frames in the left pane of
the Design Rules tab.

Materials and Display Properties for Frames

If you do not use materials to control the display properties of frames, you
can specify their display properties in the curtain wall style. The layer, color,
linetype, and other display properties of the default frame are applied to all
frames unless you create a custom display component for each definition. You
can then control the display of each frame definition independently. For more
information, see Specifying the Display of Curtain Walls on page 1499 .
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Defining a Curtain Wall Frame by Width and Depth
You can define a frame by specifying its width and depth. The overall frame
size is determined by the length and height of the curtain wall grid.

Specifying frame width and depth

Because curtain walls can contain multiple object styles with different frames,
it is helpful to use a naming convention for grid frames that indicates the grid
location or purpose within the curtain wall. For example, L3-FL1- Metal Frame
can identify a metal frame for a third-level grid on Floor 1.

TIP  To remove the frame edge and have the infill adjust to fill the space occupied
by the frame, create a frame definition with both width and depth set to zero.
Then, assign that definition to the frame edge that you want to remove. This is
necessary for the infill to be mitered as it would be for a butt-glazed condition.
For more information, see Removing a Frame Edge from a Curtain Wall on page
1491 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Frames under Element Definitions.

6 Click  to create a new frame definition.

7 Enter a descriptive name for the frame.

8 Specify a width and depth for the frame.

9 Specify any offsets.

For more information, see Specifying Offsets for a Curtain Wall
Frame on page 1466 .
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10 Click OK.

After you create a frame definition, you can assign it to any frame in a curtain
wall. For more information, see Assigning Definitions to Curtain Wall Frames
on page 1489 .

Creating a Profile for a Curtain Wall Frame
Use this procedure to create a profile that you can use to define the shape of
a curtain wall frame. You can then extrude the profile to create a curtain wall
frame.

The height and the width of the polyline you use to create the profile define
the default height and width of the curtain wall frame. The insertion point
of the profile is aligned with the centroid of the frame.

1 Draw a closed polyline of the height and the depth needed for
the resulting curtain wall frame.

2 Select the polyline, right-click, and click Convert to ➤ Profile
Definition.

3 Enter c (Centroid) for the insertion point of the profile.

The insertion point of the profile is aligned with the centroid of
the frame.

4 Enter a name for the profile, and click OK.

You can now use the profile as a curtain wall frame. For more
information, see Defining a Curtain Wall Frame Using a Profile
on page 1464 .

Defining a Curtain Wall Frame Using a Profile
Use this procedure to create a frame element definition from a profile. If you
do not want a straight edge to your frame, you can use a profile to define
edges with curves, jags, or any other shape you require.

You can also use an edit in-place routine to create a frame from a profile. For
more information, see Creating a Frame or Mullion Edge from a Polyline or
Profile Using In-Place Editing on page 1521 .
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Two profile-based frame examples

NOTE  The insertion point of the profile is aligned with the centroid of the frame.

1 Create the profile for the frame.

For information on creating profiles for curtain wall frames, see
Creating a Profile for a Curtain Wall Frame on page 1464 .

2 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

3 Expand Architectural Objects, and expand Curtain Wall Styles.

4 Select a curtain wall style.

5 Click the Design Rules tab.

6 In the left pane, select Frames under Element Definitions.

7 Click New Frame.

8 Enter a descriptive name for the frame.

9 Specify a width and depth for the frame edge.

These dimensions are used to calculate the center point of the
edge for aligning the profile and also to specify a boundary for
the adjacent infill.

10 Select Use Profile.

NOTE  The Profile options are available only if you have profiles in
the current drawing.

11 Select a profile from the list.

By default, the profile is inserted using the same width and depth
with which it was created.

12 To adjust the size of the profile to fit within the width or depth
dimension of the frame edge, select Auto-Adjust Profile Width or
Depth.

13 To mirror the profile, select to mirror along the X or Y axis.

14 To rotate the profile, specify an angle for Rotation.
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15 Specify any offsets.

For more information, see Specifying Offsets for a Curtain Wall
Frame on page 1466 .

16 Click OK.

After you create a frame definition, you can assign it to any frame in a curtain
wall. For more information, see Assigning Definitions to Curtain Wall Frames
on page 1489 .

Specifying Offsets for a Curtain Wall Frame
Use this procedure to define the distance that a curtain wall frame is from the
floor line, roof line, or baseline. By default, the outside edges of the frame
align with the start and end of the floor line and the start and end of the roof
line. When you adjust the width of the frame, the frame expands inward.
However, you can use offsets to expand or contract the frame away from these
default limits or to shift the frame away from the baseline in either the X or
Y direction.

DescriptionOffset

Positive X offset moves the frame edge
outward beyond the end of the curtain

X

wall, while a negative X offset moves the
frame edge inward toward the center of
the curtain wall.

In Plan view, a positive Y offset moves the
frame edge above the baseline, while a

Y

negative Y offset moves the frame below
the baseline.

Negative Start offset lengthens the frame
beyond the start point, while a positive

Start

Start offset shortens the frame. The start
point for vertical edges is the baseline, and
the start point for horizontal edges (drawn
left to right) is the left side.

Negative End offset lengthens the frame
beyond the end point, while a positive End

End

offset shortens the frame. The end point
for vertical edges is the base height, and
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DescriptionOffset

the end point for horizontal edges (drawn
left to right) is the right side.

Specifying frame offsets in the x and y directions

TIP  To quickly identify the start and end of a curtain wall, select the curtain wall.
The Reverse Direction grip is displayed near the center of the curtain wall and
points toward the end of the curtain wall.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Frames under Element Definitions.

6 Select a frame definition from the list.

7 Specify an offset distance for the frame edge.

8 Click OK.

Removing a Frame Definition from a Curtain Wall Style
Use this procedure to remove a frame definition from the Frame definitions
list. You cannot remove a frame definition if it is currently assigned to a frame
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edge, but you can remove it if it is assigned as an override to a frame edge. In
addition, you cannot remove the default frame definition, but you can modify
it as needed.

NOTE  For information about removing a frame edge, see Removing a Frame
Edge from a Curtain Wall on page 1491 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Frames under Element Definitions.

6 Select the unneeded frame definition.

7 Click Remove Frame.

8 Click OK.

Defining Curtain Wall Mullions
All curtain wall grids, including the primary grid, can have mullion definitions.
The mullion of the primary grid defines the outer edges of the curtain wall.
You can define the mullions by specifying a width and depth or by selecting
a profile from which the mullion is extruded.

Because curtain walls can contain multiple nested grids with different mullions,
it is helpful to use a naming convention for grid mullions that indicates the
level of each grid and the grid location or purpose within the curtain wall.
For example, L3-FL1-Window Mullion can identify a mullion for a window
in a third-level grid on Floor 1.
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Specifying default and profile-based mullions

You create mullion definitions for a specific curtain wall style and those
definitions can be assigned only to mullions in curtain walls of that style. You
can create as many mullion definitions as you want, and then assign the
definitions to mullions as needed. If you have nested grids, each grid has its
own mullions. There is a default mullion definition that you can modify as
needed that is used for any unassigned mullions. For more information, see
Assigning Definitions to Curtain Wall Mullions on page 1493 .

TIP  Using Style Manager, you can copy a frame definition and use it as a mullion
definition. Select the frame definition and drag it to Mullions in the left pane of
the Design Rules tab.

Materials and Display Properties for Mullions

If you do not use materials to control the display properties of mullions, you
can specify their display properties in the curtain wall style. The layer, color,
linetype, and other display properties of the default mullion are applied to all
mullions unless you create a custom display component for each definition.
You can then control the display of each mullion definition independently.
For more information, see Specifying the Display of Curtain Walls on page
1499 .
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Defining Curtain Wall Mullions by Width and Depth
You can define mullions by specifying a width and a depth.

Specifying mullion width and depth

TIP  To remove mullions for butt glazing, create a definition with both width and
depth set to zero. Then, assign that definition to the mullions that you want to
remove. For more information, see Removing Mullions from a Curtain Wall Grid
on page 1496 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Mullions under Element Definitions.

6 Click New Mullion.

7 Enter a descriptive name for the mullion.

8 Specify a width and depth for the mullion.

9 Specify the offsets you want.

For more information, see Specifying Offsets for the Mullions of
a Curtain Wall on page 1473 .

10 Click OK.

After you create a mullion definition, you can assign it to any mullion in a
curtain wall. For more information, see Assigning Definitions to Curtain Wall
Mullions on page 1493 .
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Creating a Profile for Curtain Wall Mullions
Use this procedure to create a profile that you can use to define the shape of
a curtain wall mullion definition. You can then extrude the profile to create
mullions from it.

The height and the width of the polyline you use to create the profile define
the default height and width of the curtain wall mullion. The insertion point
of the profile is aligned with the centroid of the mullion.

1 Draw a closed polyline of the height and the depth needed for
the resulting curtain wall mullion.

2 Select the polyline, right-click, and click Convert to ➤ Profile
Definition.

3 Enter c (Centroid) for the insertion point of the profile.

The insertion point of the profile is aligned with the centroid of
the mullion.

4 Enter a name for the profile, and click OK.

You can now use the profile as a curtain wall mullion. For more
information, see Defining the Mullions of a Curtain Wall Using
a Profile on page 1471 .

Defining the Mullions of a Curtain Wall Using a Profile
Use this procedure to create a mullion element definition from a profile. If
you do not want a straight edge to your mullions, you can use a profile to
define mullions with curves, jags, or any other shape.

You can also use an edit in-place routine to create a mullion from a profile.
For more information, see Creating a Frame or Mullion Edge from a Polyline
or Profile Using In-Place Editing on page 1521 .

NOTE  The insertion point of the profile is aligned with the centroid of the mullion.
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Infill alignments with default and profile-based mullions

1 Create the profile to use for the mullion.

For information, see Creating a Profile for Curtain Wall Mullions
on page 1471 .

2 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

3 Expand Architectural Objects, and expand Curtain Wall Styles.

4 Select a curtain wall style.

5 Click the Design Rules tab.

6 In the left pane, select Mullions under Element Definitions.

7 Click New Mullion.

8 Enter a descriptive name for the mullion.

9 Specify a width and depth for the mullion.

These dimensions are used to calculate the center point of the
mullion for aligning the profile, and also to specify a boundary
for the adjacent infill.

10 Select Use Profile.

NOTE  The Profile options are available only if you have profiles in
the current drawing.

11 Select a profile from the list.

1472 | Chapter 22   Curtain Walls



By default, the profile is inserted using the same width and depth
with which it was created.

12 To adjust the size of the profile to fit within the width or depth
dimension of the mullion, select Auto-Adjust Profile Width or
Depth.

13 To mirror the profile, select X or Y for Mirror In.

14 To rotate the profile, specify a rotation angle for Rotation.

15 Specify any offsets.

For more information, see Specifying Offsets for the Mullions of
a Curtain Wall on page 1473 .

16 Click OK.

After you create a mullion definition, you can assign it to any mullion in a
curtain wall. For more information, see Assigning Definitions to Curtain Wall
Mullions on page 1493 .

Specifying Offsets for the Mullions of a Curtain Wall
Use this procedure to define mullions that are offset from the start or end of
the curtain wall to lengthen or shorten the edge or offset in the X or Y direction
to shift the edge. For example, you might want to represent butt glazing by
offsetting the mullions to be behind glass panel infills.

DescriptionOffset

For vertical mullions, a positive X offset
moves the mullions toward the end of the

X

curtain wall, while a negative X offset
moves the mullions toward the start of the
curtain wall. For horizontal mullions, a
positive X offset moves the mullions toward
the top of the curtain wall, while a negative
X offset moves the mullions toward the
bottom of the curtain wall.

In Plan view, a positive Y offset moves the
mullions above the baseline, while a negat-

Y

ive Y offset moves the mullions below the
baseline.

Defining Curtain Wall Mullions | 1473



DescriptionOffset

Negative Start offset lengthens the mullions
beyond the start point, while a positive
Start offset shortens the mullions.

Start

Negative End offset lengthens the mullions
beyond the end point, while a positive End
offset shortens the mullions.

End

Specifying mullion offsets in x and y directions

TIP  To quickly identify the start and end of a curtain wall, select the curtain wall.
The Reverse Direction grip is displayed near the center of the curtain wall and
points toward the end of the curtain wall.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Mullions under Element Definitions.

6 Select a mullion definition from the list.

7 Specify an offset distance for the X, Y, Start, or End.

8 Click OK.
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Removing a Mullion Definition from a Curtain Wall Style
Use this procedure to remove a mullion definition from the Mullions
definitions list. You cannot remove a mullion definition if it is assigned to a
mullion, but you can remove it if it is assigned as an override to a mullion.
In addition, you cannot remove the default mullion definition, but you can
modify it as needed.

NOTE  For information about removing mullions from between cells, see Removing
Mullions from a Curtain Wall Grid on page 1496 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select Mullions under Element Definitions.

6 Select the unneeded mullion definition from the list.

7 Click Remove Mullion.

8 Click OK.

Assigning Definitions to Curtain Wall Elements
After you’ve created element definitions for a curtain wall style, you can assign
those definitions to each of the curtain wall element types: divisions, cell
infills, frames, and mullions.

By default, one definition is assigned to all elements of a particular type.
However, you can assign definitions to individual elements as well. For
example, all cells in the grid are assigned the default infill. You can, however,
create a new cell assignment, select a different infill, and then specify the cells
to use that infill.
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Assignment list

For more information about element definitions, see Creating Element
Definitions for a Curtain Wall Style on page 1439 .

Assigning a Division to a Curtain Wall Grid
Use this procedure to assign a division to a curtain wall grid. A division defines
the grid orientation (whether the direction of the grid cells and mullions is
horizontal or vertical) and the division type (number and size of cells).

After you define a division, you can assign it to the primary grid or to nested
grids. Nested grids are created by selecting Nested Grid as the cell assignment.
For more information, see Working with Nested Grids in Curtain Walls on
page 1478 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select the grid you want to assign a division to.

The name of the grid you select is displayed in the table under
the Division Assignment row.
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TIP  To rename a grid, select it, and click Rename and enter a new
name.

6 Click the Element column for that grid and select a division
definition from the list.

7 Click OK.

Assigning Infills to Curtain Wall Cells
An infill defines the contents of a curtain wall cell. A curtain wall cell can
have the default simple panel or contain a nested grid, an AEC Polygon, curtain
wall unit, door, window, or door/window assembly style. The object styles
you use in infills must exist in the current drawing to be added to an infill
definition. Panels typically represent glazing or other plain cladding, such as
stone or concrete. For more information, see Defining Infills for Curtain Wall
Cells on page 1455 .

Cell Assignments

A cell assignment defines the infill definition used for the cells. You can use
one cell assignment to assign the same infill to all cells, or you can create
multiple cell assignments to assign different infills to different cells.

Cell assignments

Do not assign multiple definitions to the same cell because only the last
assigned definition to the cell is used.

Default Cell Assignment

The default cell assignment is used by all unassigned cells. You can modify
the default assignment to be any type of infill, but you cannot delete the
default cell assignment.

You may want to modify the default cell assignment to use the infill definition
that occurs most frequently in your design. Any cells not assigned to other
infills then use this infill definition.
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Materials and Display Properties of Infills

The layer, color, linetype, and other display properties of the default infill are
applied to all infills unless you assign materials to the infills you created or
you create a custom display component for each definition. You can then
control the display of each infill definition independently. For more
information, see Specifying the Display of Curtain Walls on page 1499 .

Working with Nested Grids in Curtain Walls
Each curtain wall grid is one-dimensional with either a horizontal or vertical
division. By nesting grids in the curtain wall style, you can create a variety of
patterns from simple to complex.

Example of nested grids

Simple Primary Grids

When you nest grids, you start with one primary grid. Each cell in the primary
grid can then be filled with another grid. For example, if your primary grid is
horizontal and has three cells, you can nest a vertical grid in each horizontal
cell to create a simple two-dimensional (2D) grid. This is the nesting
configuration for the Standard curtain wall style.

Specifying cell division definitions 1
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The previous illustration shows all cells in the grid with the same cell
assignment—a vertical division. However, each cell in a grid is independent
and can have a separate assignment. For example, the following illustration
shows a three cell horizontal grid with different assignments in each cell. The
bottom cell contains another horizontal division, the middle cell contains
vertical divisions of varying width, and the top cell contains a vertical divisions
of a fixed width.

Specifying cell division definitions 2

Multiple Nested Grids

You can continue to nest grids to create multiple levels. For example, the
following illustrations show the Standard curtain wall style, which is a simple
two-dimensional (2D) grid, with one horizontal cell and three vertical cells.
Another grid is nested in the first cell of the secondary grid. This creates a
tertiary grid. The final illustration shows the nested grids assigned to all cells.

Specifying a sequence of nested grids

Defining Nested Grids

You can define nested grids by using the Design Rules tab of the Curtain Wall
Style Properties dialog box. The tree in the left pane lists the grids. There is
always one primary grid. The primary grid can have one or more secondary
grids. Each secondary grid can have one or more tertiary grids, and so on.
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TIP  To quickly create nested grids in all cells, change the default cell assignment
to Nested Grid. If you want multiple levels of nesting, be sure to change the default
cell assignment for each grid. For more information, see Creating a Nested Grid
in a Curtain Wall on page 1480 .

Each grid has its own cell assignments. You assign cells to contain another
grid, a panel infill, or an object such as a door or window. For more
information, see Assigning Infills to Curtain Wall Cells on page 1477 .

Primary grid and cell assignments

Secondary grid and cell assignments

Creating a Nested Grid in a Curtain Wall
Use this procedure to create a nested grid in a curtain wall. A nested grid is a
grid within a grid. Each nested grid has its own division, cell assignments,
frame, and mullions. By default, the frame is turned off for nested grids.

For more information, see Working with Nested Grids in Curtain Walls on
page 1478 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to create a
nested grid.

6 Click New Cell Assignment.

A new cell assignment is displayed in the list of cell assignments.
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7 Select the cell assignment in the top right frame, right-click and
click Rename, and then enter a descriptive name.

8 Select Nested Grid in the Element column.

A new grid is added to the list of grids in the left pane. If you are
editing the primary grid, the new grid is added at the secondary
level. If you are editing a grid at the secondary level, the additional
grid is placed at the tertiary level, and so on.

Creating a nested grid

New nested grid in tree

NOTE  To rename a grid, select it in the right pane, right-click and
click Rename, and enter a new name.

9 Specify the cells to contain this nested grid.

For more information, see Specifying Which Curtain Wall Cells
Use a Cell Assignment on page 1487 .

10 Click OK.
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Inserting a Door, Window or Door/Window Assembly into a
Curtain Wall Cell

Use this procedure to add doors, windows and door/window assemblies to a
curtain wall. For more information, see Defining Infills for Curtain Wall Cells
on page 1455 .

1 Open the tool palette that you want to use, and select a door,
window or door/window assembly.

2 Select the curtain wall in which to insert the door, window or
door/window assembly.

3 Select the curtain wall cell marker for the cell in which to insert
the door, window or door/window assembly.

The Add Infill worksheet opens.

4 Select the insertion method for the door, window or door/window
assembly:

Then…If you want to…

select Add as Cell Assignment.add the door, window or
door/window assembly
as a cell assignment and
have all curtain walls us-
ing the same style display
the same object added in
a corresponding cell

select Add as Cell Override.add the door, window or
door/window assembly
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Then…If you want to…

exclusively to the selected
curtain wall

If a door, window or door/window assembly of the style you
selected already exists in your drawing, Existing Infill is selected
by default.

5 Select the type of infill for the door, window or door/window
assembly:

Then…If you selected…

Click OK.Add as Cell Assignment
and you want to insert a
door, window or
door/window assembly
of the existing style, Exist-
ing Infill is selected by
default.

select New Infill, enter a name for the object
and click OK.

Add as Cell Assignment
and you want to insert a
door, window or
door/window assembly
of a different style than
exists in your drawing

Click OK.Add as Cell Override and
you want to insert a
door, window or
door/window assembly
of the existing style and
not modify the edge of
the frame surrounding
the object

select New Infill, enter a name for the object
and click OK.

Add as Cell Override and
you want to insert a
door, window or
door/window assembly
of a different style than
exists in your drawing
and not remove an edge

Assigning Infills to Curtain Wall Cells  | 1483



Then…If you selected…

of the frame surrounding
the object

select Top, Bottom, Left, or Right for Override
Frame Removal and click OK.

Add as Cell Override and
you want to insert a
door, window or
door/window assembly
of the existing style and
remove an edge of the
frame surrounding the
object

select New Infill and enter a name for the
object. Then select Top, Bottom, Left, or Right
for Override Frame Removal and click OK.

Add as Cell Override and
you want to insert a
door, window or
door/window assembly
of a different style than
exists in your drawing
and remove an edge of
the frame surrounding
the object

6 Press ENTER.

Filling a Curtain Wall Cell with a Simple Panel
Use this procedure to fill a curtain wall cell with a simple panel. Simple panels
are generally used to represent basic cladding materials in the curtain wall,
such as a stone wall panel or a concrete panel.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to put a simple
panel infill.
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6 Click New Cell Assignment.

A new cell assignment is displayed in the list of cell assignments.

7 Select the cell assignment in the top right pane, right-click and
click Rename, and then enter a descriptive name.

8 Under Element, select an infill that defines a simple panel.

If you do not have a simple panel infill defined, then select New
Infill and define one. For more information, see Creating a Panel
Infill for a Curtain Wall on page 1456 .

9 Specify the cells to contain this simple panel.

For more information, see Specifying Which Curtain Wall Cells
Use a Cell Assignment on page 1487 .

10 Click OK.

Inserting an Object into a Curtain Wall Cell
Use this procedure to insert objects, such as curtain wall units and AEC
Polygons, into a curtain wall cell. Curtain wall cells can contain these objects
when you create infill definitions that use them. For more information, see
Creating a Style Infill for a Curtain Wall on page 1457 .

TIP  After you insert an object in a cell, you can select that object independent of
the grid, right-click, and access editing options for the object.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.
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4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to insert objects.

6 Click New Cell Assignment.

A new cell assignment is displayed in the list of cell assignments.

7 Select the cell assignment in the top right frame, right-click and
click Rename, and then enter a descriptive name.

8 Select an infill that uses an object style.

9 Specify the cells to contain this object.

For more information, see Specifying Which Curtain Wall Cells
Use a Cell Assignment on page 1487 .

10 Click OK.

Removing an Infill from a Curtain Wall Cell
Use this procedure to remove the infill of a cell and leave the cell empty. To
do this, use None as the element definition. Using None also removes any
frame edges that border the cell, but it does not affect the mullions.

Removing an infill assignment from a cell

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select the grid that contains the cells you want
to assign to None.

6 Create a new cell assignment or select an existing cell assignment.

7 Select NONE under the Element column.

8 Specify the cells to contain the None infill.
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For more information, see Specifying Which Curtain Wall Cells
Use a Cell Assignment on page 1487 .

9 Click OK.

Specifying Which Curtain Wall Cells Use a Cell Assignment
When you create a cell assignment you need to specify the cells in the grid to
use that assignment. There are two options for selecting cells:

■ Use Location to insert the infill into the start, middle, or end cells of a
vertical grid or into the bottom, middle, or top cells of a horizontal grid.
If there is an even number of cells (four or more), Middle refers to the two
cells in the middle of the grid. If there is an odd number of cells (three or
more), Middle refers to one cell in the middle of the grid.

Specifying cell assignments by location

■ Use Index to insert the infill into specific cells based on cell numbers. Cells
are numbered from start to end or bottom to top. For example, typing 1,
3, 5 would place the infill in the first, third, and fifth cells.

Specifying cell assignment by index
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TIP  When you are trying to determine cell assignments in a grid that has both
vertical and horizontal cells it is helpful to remember that each of these directions
is actually in a separate grid. You can have a vertical grid with a nested horizontal
grid, or the other way around. Select each grid separately to make cell assignments.

Any cells that are not assigned a specific cell assignment use the default infill.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select a grid.

6 In the right pane, select Location or Index for Type.

7 Select a cell assignment:

Then …If you select …

click the Used In column, and click
the button at the far right of the

Location

row. Select the cells you want to
use this assignment, and click OK.

enter the cell numbers separated
by commas in the Used In column.

Index

For vertical grids, cells are
numbered from start to end and for
horizontal grids, cells are numbered
from bottom to top.

NOTE  Do not assign multiple definitions to a cell because the last
definition assigned to the cell is used.

8 Click OK.

Removing an Assignment from a Curtain Wall Style
Use this procedure to remove cell assignments, frame assignments, and mullion
assignments from a curtain wall style. You cannot remove default assignments,
but you can modify them to suit your needs.
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NOTE  Each grid requires one division assignment. Therefore, you cannot remove
the division assignment, although you can change the division element used for
the division assignment.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select the grid from which you want to remove
an assignment.

6 Select a cell assignment, frame assignment, or a mullion
assignment.

7 Click Remove Assignment.

8 Click OK.

Assigning Definitions to Curtain Wall Frames
The curtain wall frame is represented by the outer edges of the primary grid.
Each nested grid has its own frame that is defined separately from the primary
grid frame. By default, the frames of nested grids are turned off. For more
information about nested grids, see Working with Nested Grids in Curtain
Walls on page 1478 .

Frame Assignments

A frame assignment defines the frame definition that is used by each frame
edge. You can use one frame assignment to assign the same definition to all
four edges of the frame, or you can create multiple frame assignments to assign
different definitions to different edges of the frame. Unassigned edges are not
displayed.

Do not assign multiple definitions to the frame edge because only the last
definition assigned to the edge is used.

Default Frame Assignment

There is a default frame assignment and you can select the frame edges it
applies to. You can modify the default assignment to use any frame definition,
but you cannot delete the default frame assignment.
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Materials and Display Properties of Frames

The layer, color, linetype, and other display properties of the default frame
are applied to all frame edges unless you assign materials to the frame
definition or you create a custom display component for each definition. You
can then control the display of each frame definition independently. For more
information, see Specifying the Display of Curtain Walls on page 1499 .

Adding a New Frame Assignment to a Curtain Wall
Use this procedure to add a frame assignment to a curtain wall. To assign
different definitions to different frame edges, you need multiple frame
assignments.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to create a new
frame assignment.

6 Click New Frame Assignment.

A new frame assignment is displayed in the list of frame
assignments.

New frame assignment

7 Select the frame assignment in the right pane, right-click and click
Rename, and then enter a descriptive name.

8 Select a frame definition from the Element column.

9 Specify the sides of the frame to use this frame assignment.

For more information, see Specifying Which Curtain Wall Edges
Use a Frame Assignment on page 1492 .

10 Click OK.
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Removing a Frame Edge from a Curtain Wall
Use this procedure to remove a frame edge from a curtain wall. There are three
ways to remove a frame edge:

■ Set the width and depth of the edge to zero

■ Leave the edge unassigned

■ Specify None as an override to the edge assignment

The first two methods remove the frame edge and expand the adjacent infills
into the space occupied by the edge.

Specifying a frame width and depth of zero

By specifying None as an override, the frame edge is not displayed, but the
adjacent infill is not expanded into the space the edge occupied.

Overriding a frame edge definition

For information about setting the width and depth to zero, see Defining a
Curtain Wall Frame by Width and Depth on page 1463 .

For information about leaving the edge unassigned, see Specifying Which
Curtain Wall Edges Use a Frame Assignment on page 1492 .

For information about overriding the edge, see Overriding Curtain Wall
Frames and Mullions on page 1518 .
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Specifying Which Curtain Wall Edges Use a Frame Assignment
Use this procedure to specify edges that use a frame assignment. When you
create a frame assignment, you need to specify the edges of the frame to use
that assignment.

Frame edges that are not assigned a frame definition are not displayed.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select a grid.

6 Select a frame assignment.

Location is the only way to specify the frame edges.

7 Click the Used In column, and then click the [...] button at the
far right of the row.

Specifying frame location

8 Select the edges that you want to use this assignment - Left, Right,
Top, or Bottom - and click OK.

Assigning frames to nested grids
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Do not assign multiple definitions to the same frame edge because
only the last definition assigned to the edge is used.

9 Click OK.

Assigning Definitions to Curtain Wall Mullions
The mullions of a curtain wall are the edges between the grid cells. The primary
grid and each nested grid have mullions that are defined separately from the
other grids. For more information about nested grids, see Working with Nested
Grids in Curtain Walls on page 1478 .

Assign mullions to a nested grid

Mullion Assignments

A mullion assignment defines the definition used by each mullion. You can
use one assignment to define all mullions, or you can create multiple
assignments and assign different definitions to different mullions in any grid.

Do not assign multiple definitions to the same mullion because only the last
definition assigned to the mullion is used.

Default Mullion Assignment

There is a default mullion assignment used by all unassigned mullions. You
can modify the default assignment to be any mullion definition, but you
cannot delete the default mullion assignment.

Adding a New Mullion Assignment to a Curtain Wall Style
Use this procedure to add a new mullion assignment to a curtain wall style.
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1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to create a new
mullion assignment.

6 Click New Mullion Assignment.

A new mullion assignment is displayed in the list of mullion
assignments.

New mullion assignment

7 Select the mullion assignment, right-click and click Rename, and
then enter a descriptive name.

8 Select a mullion definition from the Element column.

9 Specify the mullions to use this assignment.

For more information, see Specifying Which Curtain Wall
Mullions Use an Assignment on page 1494 .

10 Click OK.

Specifying Which Curtain Wall Mullions Use an Assignment
When you create a mullion assignment you need to specify the mullions in
the grid to use that assignment. There are two options for selecting mullions: 

■ Use Location to assign a definition to the start, middle, or end mullions
of a vertical grid or the bottom, middle, or top mullions of a horizontal
grid. If there is an even number of mullions (four or more), Middle refers
to the two mullions in the middle of the grid. If there is an odd number
of mullions (three or more), Middle refers to the one mullion in the middle
of the grid.
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■ Use Index to assign a definition to specific mullions based on mullion
numbers. Mullions are numbered from start to end or bottom to top. For
example, typing 1, 2, 3 would assign the definition to the first, second,
and third mullions.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select a grid.

6 Create a new mullion assignment or select an existing assignment.

7 Select Location or Index for Type.

8 Select a cell assignment.

Then …If you selected …

click the Used In column, and click
the button at the far right of the

Location

row. Select the cells you want to
use this cell assignment, and click
OK.

enter the mullion numbers separ-
ated by commas in the Used In

Index

column. For vertical grids, mullions
are numbered from start to end
and, for horizontal grids, mullions
are numbered from bottom to top.

NOTE  Do not assign multiple definitions to the same mullion because
only the last definition assigned to the mullion is used.

9 Click OK.

Any mullions that are not assigned a specific mullion assignment
use the default mullion definition.
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Removing Mullions from a Curtain Wall Grid
Use this procedure to remove a mullion from the curtain wall. You can create
a mullion definition whose edge width and depth are zero. Adjacent infills
expand to fill in the space that was occupied by the mullion. This is an effective
way to represent butt glazing.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to remove a
mullion.

6 Create a new mullion assignment and enter 0 (zero) for the width
and depth.

For more information, see Defining Curtain Wall Mullions by
Width and Depth on page 1470 .

7 Under Mullion Assignments, select the mullion definition you
created for any cell edges of any mullion assignment, where you
want to remove the mullions.

For more information, see Specifying Which Curtain Wall
Mullions Use an Assignment on page 1494 .

8 Click OK.

Specifying the Materials of a Curtain Wall Style
A curtain wall consists of a number of components whose display properties
can be determined by the materials assigned to each component.
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When you assign materials to a curtain wall style, you assign one material to
each display component of the curtain wall. For example, you assign a wood
material to the frame and a glass material to the glass inset. You assign
materials to components in each display representation where you want the
materials to be used.

If you want to use the display properties of the curtain wall style, instead of
using material display properties, you can turn off the material assignments
in the display properties of the curtain wall style.

Material definitions consist of display components that correspond to
component types of objects. For example, the Linework component of a
material is used for all linework in plan view. The Surface Hatch component
of a material is used to hatch all object surfaces in three dimensional (3D)
model views and in elevations.

Curtain Wall Materials and Display Components
The following table identifies the material component that corresponds to
each curtain wall component in the specified views.

Material ComponentCurtain Wall Component

Plan, Plan High Detail, Plan Low Detail,
Screened, Reflected Plan

LineworkFrame Definitions

LineworkMullion Definitions

LineworkInfill Definitions

LineworkFrame Definitions Hatch

LineworkMullion Definitions Hatch

LineworkInfill Definitions Hatch

Model

3D BodyFrame

3D BodyMullion
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Material ComponentCurtain Wall Component

3D BodyInfill

Assigning Materials to a Curtain Wall Style
Use this procedure to assign materials to the individual components of a
curtain wall style. When you assign a material to a curtain wall component,
the component uses the display properties of the material instead of the style
display properties.

You can assign a material to any physical component of the curtain wall.
Custom components and components that are only symbolic graphics do not
use materials for their display properties. For example, the frame, mullion,
and infill are physical components of a curtain wall. The cell marker is a
symbolic component.

NOTE  If a material assignment does not determine the display properties of a
curtain wall component, you can change the display properties of the curtain wall
style as described in Specifying the Display of Curtain Walls on page 1499 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select By Material for any component to which you want to assign
a material, and click OK.

If the setting for By Material is not available, the display of this
component cannot be determined by a material.

9 Click the Materials tab.

10 Select the component you want to change, select the value for
Material Definition, and select a different material definition.
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You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING  Although you can edit a material definition from this
dialog box, any changes you make to the material definition apply
to all objects that are assigned the material.

11 Click OK.

Specifying the Display of Curtain Walls
The display of a curtain wall depends on the direction from which you view
the curtain wall. In Plan view, the curtain wall object is displayed as parallel
lines with vertices marking the grid lines, as an architect would typically draw
a curtain wall. In 3D isometric views, the curtain wall object is displayed as it
would appear in the real world, with surfaces showing length, thickness, and
height. You control what you want to display in each particular view.

Element Definitions and Custom Display Components

By default, the display of all infills, frames, and mullions is controlled by the
display properties of the default infill, default frame, and default mullions.
However, you can add individual element definitions as components with
separate display properties. For example, if you define two infills called stone
panel and glass panel, by default they are both controlled by the default infill
display properties. However, you can add each definition as a new display
component, and then control the display properties separately.

NOTE  The component name in the Custom Display Component dialog box must
match the name of element definition in the Design Rules tab. Otherwise the
element definition does not display properly.

For more information about the display system, see Display System on page
791 .

Materials and Display Properties

You can use materials to control the display of both default and custom infills,
frames, and mullions. When you assign materials to the element definitions
you create, you do not need to define these definitions as custom display
components. For more information, see Specifying the Materials of a Curtain
Wall Style on page 1496 .
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Adding Curtain Wall Element Definitions as Display Components
Use this procedure to add curtain wall element definitions. Before you can
control the display properties of curtain wall elements according to the
definition assigned to the element, you must create display components for
each element definition.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select the curtain wall style that you want to change.

4 Click the Display Properties tab.

5 Select Model as the display representation.

6 Click  .

The default list of components includes only the three basic
elements and cell markers.

Default Model display components for curtain walls

7 Click the Other tab, and then click Add.

8 Select Infill, Frame, or Mullion for Component Type.

9 Enter a name for Component Name, or click Select Element and
select an element from the list.

10 Click OK.

11 Click the Layer/Color/Linetype tab.

The element definition that you added is displayed in the list of
components.

12 Click the Other tab to continue adding element definitions, or
click OK twice.
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Specifying the Layer, Color, and Linetype of a Curtain Wall Style
Use this procedure to change the following display properties of the
components of a curtain wall style:

■ Visibility (component is on or off)

■ By Material

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select the curtain wall style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear.

6 Click Style Override.

7 Click the Layer/Color/Linetype tab.

8 Select the component to change, and select a different setting for
the property.

9 Click OK twice.

Specifying the Hatching for Components of a Curtain Wall Style
Use this procedure to specify the hatching of the components of a curtain
wall style. Curtain wall hatching is displayed only in display representations,
such as Plan, that are used in Top view (Plan view) of a drawing.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.
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3 Select the curtain wall style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and click Style Override.

6 Click the Hatching tab.

7 Select a component, and click the setting for Pattern.

8 Specify the hatching for the component:

Then …If you want to specify …

select Predefined for Type, and then
select a pattern.

a hatching pattern that is available
in the software

select Custom for Type, and then
enter the name of the custom pat-

a custom pattern

tern. If necessary, click Browse, and
navigate to the folder where the
custom pattern file is located.

select User-defined for Type, and
clear Double Hatch.

single hatching

select User-defined for Type, and
select Double Hatch.

double hatching

select Solid Fill for Type.solid fill

9 Click OK.

10 Click the setting for Scale/Spacing, and enter a value that
determines how the selected pattern is repeated.

11 Click the setting for Angle, and enter the angle for the selected
pattern.

12 Click the setting for Orientation, and specify how the hatching
is oriented:

Then …If you want to orient the
hatching …

select Object.to the object, regardless of the ob-
ject rotation

select Global.to the World Coordinate System
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13 Click OK twice.

Adding Custom Graphics as a Display Component of a Curtain
Wall

There may be instances where an infill, frame, or mullion requires a custom
two-dimensional (2D) or three-dimensional (3D) graphic. For example, you
might need a highly detailed 3D truss as the mullions or a decorative light
fixture applied to an infill. In cases like these, you can create a custom block,
add a display component with the block attached, and associate that
component with an element definition. When you assign that definition to
an element, the block is also displayed.

1 Draw your custom component, and save it as a block.

2 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

3 Expand Architectural Objects, and expand Curtain Wall Styles.

4 Select the curtain wall style that you want to change.

5 Click the Display Properties tab.

6 Click  .

7 Click the Other tab.

8 Click Add.

9 Select Infill, Frame, or Mullion as the element type.

10 Select the specific element from the list.

11 Select Draw Custom Graphics.

12 Specify the display of the element:

Then …If you want to …

select Replace Graphics.display the block instead of the as-
sociated curtain wall element

clear Replace Graphics.superimpose the block over the
curtain wall element so that both
are displayed

13 Click Select Block, and select the custom block that you created.

14 Click OK.
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15 Specify further settings for the custom display block:

Then …If you want to …

select Width, Height, or Depth. To
prevent the block from losing its
proportions, select Lock XY Ratio.

scale the block to fit a particular di-
mension

specify an insertion point on the X,
Y, and Z planes.

specify how the block is inserted
into the grid in the X, Y, and Z dir-
ections

determine if it should mirror in the
X, Y, or Z direction.

mirror the block

specify the offset in the X, Y, or Z
direction.

offset the block from the grid

16 Click OK three times.

Creating Cut Planes for a Curtain Wall
Use this procedure to specify the properties of one or more cut planes for a
curtain wall style. Cut plane display properties apply only to display
representations, such as Plan, that are used in Top view (Plan view) of a
drawing.

To better visualize the elements of a curtain wall in Plan view, you can create
cut planes. The main cut plane is where the shrinkwrap and hatching are
applied. The plan display shows the components and objects in the wall as
they are displayed at the height of each cut plane.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select the curtain wall style that you want to change.

4 Click the Display Properties tab.

5 Select Plan, and click  .

NOTE  The Cut Plane tab is displayed only in some display
representations, such as Plan.
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6 Click the Cut Plane tab to set the cut plane to be displayed in
each display representation for the curtain wall style.

7 Enter a value for Cut Plane Height to specify the cut plane at
which hatching takes effect.

8 To specifically define a cut plane, click Add, and enter the height
of the new cut plane.

Then …If you add a cut plane …

objects are displayed using the
properties specified for the Below

at a height that is lower than the
value for Cut Plane Height

Cut Plane component on the Lay-
er/Color/Linetype tab.

objects are displayed using the
properties specified for the Above

at a height that is higher than the
value for Cut Plane Height

Cut Plane component on the Lay-
er/Color/Linetype tab.

Below and Above components

You can click Remove to delete a cut plane that you added.

9 Click OK twice.

Defining a Curtain Wall Style as Bounding for Associative Spaces
Use this procedure to define a curtain wall style that can bound associative
spaces.

When a curtain wall style is set as bounding, by default all curtain walls that
have the style assigned will be used in the selection set for an associative space.
For more information about associative spaces see Generating Associative
Spaces on page 2940 .

You can override the bounding settings from the curtain wall style in an
individual curtain wall, if necessary.
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1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall style.

4 Click the General tab.

5 Select the checkbox for Objects of this style may act as a boundary
for associative spaces.

6 Click OK.

Attaching Notes and Files to a Curtain Wall Style
Use this procedure to enter notes and attach reference files to a curtain wall
style. You can also edit notes and edit or detach reference files from a curtain
wall style.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select the curtain wall style you want to change.

4 Click the General tab.

5 To add a description to the curtain wall style, enter it for
Description.

6 Click Notes.

7 To add a note, click the Text Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then …If you want to …

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file
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9 Click OK.

Using Overrides in Curtain Walls
Curtain walls are geometrically complex objects that often have a large number
of different elements, such as frames, panels, and window infills. The settings
for these elements are defined in the curtain wall style and can be modified
using Style Manager. However, there are cases when modifying a curtain wall
directly on screen is more suitable:

■ You want to add custom frame or mullion edges to a curtain wall and need
direct visual feedback.

■ You want to create an override, like a merged infill or an irregular panel
shape in only one specific place in the curtain wall.

■ You want to experiment with different visuals without having to change
the curtain wall style for each idea immediately.

When you have finished your onscreen edits, you have three choices:

■ apply the overrides to the curtain wall you have edited.

■ save the overrides to the current curtain wall style.

■ create a new style for the overrides.

Overrides you can set include assigning a different definition to a selected
cell, frame, or mullion, and assigning a profile to a frame or mullion edge.
Note that the definition or profile must already exist in the current drawing
before you can use it as an override. For example, if you want to override a
cell that has a simple panel infill with an octagonal window infill, you must
first define the window (octagonal) style as a valid infill in the curtain wall
style. Similarly, if you want to override a frame or mullion edge assignment
in the curtain wall, the curtain wall style must contain the edge profile as a
frame or mullion definition.

NOTE  You cannot modify a definition using the Override method. For information
about modifying definitions, see Modifying Element Definitions for Curtain Wall
Styles on page 1535 .

Overrides do not affect the Design Rules for the curtain wall style. However,
you can transfer overrides to a curtain wall style if you want all curtain walls
of that style to have the same overrides.

Using Overrides in Curtain Walls  | 1507



You can view a list of overrides that are currently assigned to a curtain wall
from the Overrides tab of the Curtain Wall Properties dialog box. For more
information, see Removing Curtain Wall Overrides on page 1535 .

NOTE  Overrides are also listed on the Overrides tab in the Curtain Wall Style
Properties dialog box.

Overriding Curtain Wall Infills
The cell infills of a curtain wall are set in the curtain wall style. You can,
however, create overrides for these infills in cells. For example, you might
want a row of glider windows for a first floor facade. In one specific position,
however, you want a frosted glass window. In this case, you would set the row
of glider windows in the curtain wall style, and then override the infill style
in one specific cell with a frosted glass window.

Curtain wall infills can consist of simple panels, objects like windows or doors,
or nested grids. You can change one infill for another, merge cells, or remove
the frame from an infill altogether. This would be useful if you add a door
into a grid cell and want to remove the bottom frame from that cell.

Turning on Cell Markers
Use this procedure to turn on the cell markers for each grid cell in a curtain
wall. The cell markers must be on in order to select individual cells and make
changes to them.

Viewing Cell Markers

1 Select the curtain wall for which you want to create an infill
override.
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2 Click Curtain Wall tab ➤  Modify panel  ➤  Show Infill Markers

 .

Merging Curtain Wall Cells
Use this procedure to merge two curtain wall cells.

NOTE  To merge curtain wall cells, the cell markers need to be visible. For
information on turning on cell markers, see Turning on Cell Markers on page 1508
.

You can only merge cells which are adjacent to each other.

In most cases you merge cells with the same infill type. The merged cell is
then the same type as the original cells. For example, if you merge two solid
panel infills, the resulting merged cell also has a solid panel infill. In some
cases however, you might want to merge two cells that have different infill
types. In that case, the infill type of the first selected cell is used for the merged
cell. For example, if you want to merge a cell with a simple panel infill and a
cell with a window infill, and you select the cell with the simple panel first
during the merge command, the merged cell contains a simple panel infill,
not a window. If you select the two cells in the opposite order, the merged
cell contains a window and no simple panel infill.

Merging two cells
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1 Select the curtain wall on which you want to merge two cells.

2 Click  Curtain Wall tab  ➤ Modify panel ➤  Infill drop-down
 ➤ Merge.

3 Select the first cell to be merged.

4 Select the second cell to be merged.

The cells are merged into one.

5 Specify where you want to save the curtain wall override:

Then …If you want to save the over-
ride …

no further steps are necessary. The
override is saved to the curtain wall.

only on this specific curtain wall

For information about how to re-
move an override from a curtain
wall, see Removing Curtain Wall
Overrides on page 1535 .

select the curtain wall, and  click

Curtain Wall tab  ➤ Modify pan-

to a curtain wall style

el ➤  Design Rules drop-down

 ➤ Transfer To Object.

6 If you have chosen to save the override to a curtain wall style,
click  Curtain Wall tab  ➤ Modify panel ➤  Design Rules
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drop-down  ➤ Save To Style. Then, decide to which curtain wall
style you want to save the override.

Then …If you want to save the over-
ride …

select Transfer Merge Operations
to Style, and click OK.

NOTE  If you have created only
a cell merge, only the Transfer
Merge Operations to Style
checkbox is active. If you have
also created other overrides,
such as a new cell assignment
or a frame or mullion edge
override, these checkboxes are
available as well. If you also
want to save these overrides to
the style, select their check-
boxes, too.

to the current curtain wall style

select Transfer Merge Operations
to Style, and click New. Then, enter

to a new curtain wall style

a name for the new curtain wall
style, and click OK.

NOTE  If you have created only
a cell merge, only the Transfer
Merge Operations to Style
checkbox is active. If you have
also created other overrides,
such as a new cell assignment
or a frame or mullion edge
override, these checkboxes are
available as well. If you also
want to save these overrides to
the style, select their check-
boxes, too.
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NOTE  If you do not want to save the override back to a style at all,
click  Curtain Wall tab  ➤ Modify panel ➤  Design Rules drop-down
 ➤  Revert To Style Design Rules .  The overrides still remain on the
curtain wall, where they can be removed as described in Removing
Curtain Wall Overrides on page 1535 , but they are not saved back to
a curtain wall style.

In-Place Editing of Curtain Wall Cells
Use this procedure to edit curtain wall cells using in-place editing with the
Edit Grid grip. With in-place editing, you can edit individual cells, bays,
columns, or nested grids of the curtain wall directly and interactively in the
drawing area, and later save the changes to the curtain wall or curtain wall
style.

1 Select a curtain wall on which you want to edit cells with in-place
editing.

2 Specify the mode in which to edit the curtain wall:

Then …If you want to edit …

click  Curtain Wall tab  ➤ Modify

panel ➤  Design Rules drop-down

 ➤ Transfer To Object.

this instance of the curtain wall

click  Curtain Wall tab  ➤ Modify

panel ➤  Design Rules drop-down

the curtain wall style

 ➤  Revert To Style Design Rules .
If this option is not available, the
design rules are already style-based
for the curtain wall.

3 Click the Edit Grid grip.

4 Enter c (Cell) and press ENTER.

NOTE  You have entered the in-place editing session now. You can
see this from the faded color of all objects in the drawing, as well as
from the different grips at your disposal. Note that while you are in
the in-place editing session, you have only limited editing access to
other commands in the drawing. Before working on other objects,
you should first end the in-place editing session.
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5 Select the individual cells, bay, column, or nested grid to modify
the cell assignment by hovering over a cell or pressing TAB, and
press ENTER.

Press CTRL to select multiple cells, bays, columns or nested grids.

The Edit Cells worksheet displays.

6 Edit the cell for the selected grid:

Then…If you want to…

select Assign Infill and select an infill defini-
tion. Clear Replace Cell and click OK.

assign an infill to selected
cells

select Assign Infill and select an infill defini-
tion. Select Replace Cell and click OK.

replace the selected cells
with a new infill

click  and specify values on the Design
Rules worksheet.
For more information, see Assigning Infills to
Curtain Wall Cells on page 1477 .

create and assign a new
infill to the selected cells

select Subdivision.divide the selected cells
with divisions, infills or
frames

select a division definition.select a division for the
subdivided cells
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Then…If you want to…

click  and specify values on the Design
Rules worksheet.
For more information, see Assigning a Divi-
sion to a Curtain Wall Grid on page 1476 .

create and assign a new
division to the selected
cells

select an infill definition.select an infill for the
subdivided cells

click  and specify values on the Design
Rules worksheet.
For more information, see Assigning Infills to
Curtain Wall Cells on page 1477 .

create and assign a new
infill to the subdivided
cells

select the frame definition and click OK.select a frame definition
for the grid created after
the cell is subdivided

select Top, Bottom, Left, Right for Frame
Location and click OK.

specify the location of
frames on the grid cre-
ated after the cell is sub-
divided

click  and specify values on the Design
Rules worksheet.
For more information, see Adding a New
Frame Assignment to a Curtain Wall on page
1490 .

create and assign a new
frame definition for the
new grid created after
the cell is subdivided

select the mullion definition.select a mullion definition
for the grid created after
the cell is subdivided

click  and specify values on the Design
Rules worksheet.
For more information, see Adding a New
Mullion Assignment to a Curtain Wall Style
on page 1493 .

create and assign a new
mullion definition to the
selected grid
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Then…If you want to…

select Replace Cell.replace the existing cell
infill with the options se-
lected on this worksheet

select Continue Grid Editing.continue in-place editing
the grid after the cell is
subdivided

7 Click OK.

8 Press ENTER.

Creating a Curtain Wall Infill Override
Use this procedure to override the infill of a curtain wall cell.

For example, you might have a row of simple concrete panels in your curtain
wall, but want in one location a round window instead of the concrete panel.
In that case, it might be simpler to use an infill override, instead of creating
complex curtain wall unit definitions.

NOTE  To override an infill assignment, the cell markers must be visible. For
information on turning on cell markers, see Turning on Cell Markers on page 1508
.

To exchange an infill definition, the new infill definition must already be
defined in the curtain wall style. For information on creating infill definitions,
see Defining Infills for Curtain Wall Cells on page 1455 .

1 Select the curtain wall on which you want to override an infill.

2 Click  Curtain Wall tab  ➤ Modify panel ➤  Infill drop-down
 ➤ Override Assignment.
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3 Select the marker of the cell where you want to create an override,
and press ENTER.

4 Create the override.

Then …If you want to …

select a new infill definition from
the list.

exchange the existing infill for an-
other

select the frame component to be
removed. You could, for example,

remove one or more of the frames
around the infill

override a cell to contain a door in-
fill instead of a panel infill; in this
case, you would want to remove
the bottom frame of the cell.

select Remove Infill and Frames.

NOTE  This works only for infills
that border the exterior of the
curtain wall.

remove the complete infill and its
frame

5 Click OK.

6 Specify where you want to save the curtain wall override.

Then …If you want to save the over-
ride …

no further steps are necessary. The
override is saved to the curtain wall.

only on this specific curtain wall

For information about how to re-
move an override from a curtain
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Then …If you want to save the over-
ride …

wall, see Removing Curtain Wall
Overrides on page 1535 .

select the curtain wall, and  click

Curtain Wall tab  ➤ Modify pan-

to a curtain wall style

el ➤  Design Rules drop-down

 ➤ Transfer To Object.

7 If you have chosen to save the override to a curtain wall style,
click  Curtain Wall tab  ➤ Modify panel ➤  Design Rules
drop-down  ➤ Save To Style. Then, decide to which curtain wall
style you want to save the override.

Then …If you want to save the over-
ride …

select Transfer Cell Overrides to
Style, and click OK.

NOTE  If you have created only
an infill override, only the
Transfer Cell Overrides to Style
checkbox is active. If you have
also created other overrides,
such as a cell merge or a frame
or mullion edge override, these
checkboxes are available as
well. If you also want to save
these overrides to the style, se-
lect their checkboxes, too.

to the current curtain wall style

select Transfer Cell Overrides to
Style, and click New. Then, enter a

to a new curtain wall style

name for the new curtain wall style,
and click OK.
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Then …If you want to save the over-
ride …

NOTE  If you have created only
an infill override, only the
Transfer Cell Overrides to Style
checkbox is active. If you have
also created other overrides,
such as a cell merge or a frame
or mullion edge override, these
checkboxes are available as
well. If you also want to save
these overrides to the style, se-
lect their checkboxes, too.

NOTE  If you do not want to save the override back to a style at all,
click  Curtain Wall tab  ➤ Modify panel ➤  Design Rules drop-down
 ➤  Revert To Style Design Rules .  The overrides remain on the curtain
wall, where they can be removed as described in Removing Curtain
Wall Overrides on page 1535 , but they are not saved back to a curtain
wall style.

Overriding Curtain Wall Frames and Mullions
You can change a selected frame edge or mullion edge by using an edge
assignment override.

NOTE  To exchange a frame edge or mullion edge, the new edge definition must
already be defined in the curtain wall style.

Removing the edge does not affect the width of the cell. To remove the edge
and have the adjacent cell resize, create an edge definition with a width and
depth of zero. For more information, see Defining a Curtain Wall Frame by
Width and Depth on page 1463 or Defining Curtain Wall Mullions by Width
and Depth on page 1470 .

You can also create a new edge profile by drawing a polyline or using an
existing profile in the drawing. This edge profile can be interactively edited
onscreen by in-place editing.
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Creating a Frame or Mullion Override
Use this procedure to override an individual frame or mullion.

To exchange a frame or mullion, the new definition must already be defined
in the curtain wall style. For information on creating frames and mullions,
see Defining Curtain Wall Frames on page 1461  and Defining Curtain Wall
Mullions on page 1468 .

1 Select the curtain wall on which you want to override an edge.

2 Click  Curtain Wall tab  ➤ Modify panel ➤  Frame/Mullion
drop-down  ➤ Override Assignment.

3 Select the frame or mullion edge you want to override.

If you selected a frame edge, the Frame Assignment Override dialog
box is displayed.

If you selected a mullion, the Mullion Assignment Override dialog
box is displayed.

4 Create the override.

Then …If you want to …

select a new edge definition from
the list.

exchange the existing edge for an-
other

select Remove Edge.remove the frame or mullion edge

5 Click OK.

6 Specify where you want to save the curtain wall override.

Then …If you want to save the over-
ride …

no further steps are necessary. The
override is saved to the curtain wall.

only on this specific curtain wall

For information about how to re-
move an override from a curtain
wall, see Removing Curtain Wall
Overrides on page 1535 .

select the curtain wall, and  click

Curtain Wall tab  ➤ Modify pan-

to a curtain wall style

el ➤  Design Rules drop-down

 ➤ Transfer To Object.

Overriding Curtain Wall Frames and Mullions  | 1519



7 If you have chosen to save the override to a curtain wall style,
click  Curtain Wall tab  ➤ Modify panel ➤  Design Rules
drop-down  ➤ Save To Style.  Then, decide to which curtain wall
style you want to save the override.

Then …If you want to save the over-
ride …

select Transfer Edge Overrides to
Style, and click OK.

NOTE  If you have created only
a frame or mullion edge over-
ride, only the Transfer Edge
Overrides to Style checkbox is
active. If you have also created
other overrides, such as a cell
merge or a division override,
these checkboxes are available
as well. If you also want to save
these overrides to the style, se-
lect their checkboxes, too.

to the current curtain wall style

select Transfer Edge Overrides to
Style, and click New. Then, enter a

to a new curtain wall style

name for the new curtain wall style,
and click OK.

NOTE  If you have created only
a frame or mullion edge over-
ride, only the Transfer Edge
Overrides to Style checkbox is
active. If you have also created
other overrides, such as a cell
merge or a division override,
these checkboxes are available
as well. If you also want to save
these overrides to the style, se-
lect their checkboxes, too.
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NOTE  If you do not want to save the override back to a style at all,
click  Curtain Wall tab  ➤ Modify panel ➤  Design Rules drop-down
 ➤  Revert To Style Design Rules .  The overrides remain on the curtain
wall, where they can be removed as described in Removing Curtain
Wall Overrides on page 1535 , but they are not saved back to a curtain
wall style.

Creating a Frame or Mullion Edge from a Polyline or Profile Using
In-Place Editing

Use this procedure to assign a profile to a vertical edge of a frame or mullion.
The curtain wall edge profile can be any profile or any closed polyline that
you specify. You can use a profile edge to create a unique corner in situations
where a simple miter is not sufficient.

NOTE  Adjacent infills are not trimmed or expanded to accommodate the new
edge. To adjust the infill, change the width of the frame edge. For more
information, see Defining a Curtain Wall Frame by Width and Depth on page 1463
.

Overriding edge profile

1 Draw a closed polyline in the location where you want it to display
in the curtain wall.

NOTE  For best results, it is recommended to draw the polyline in
Plan view.

2 Select the curtain wall for which you want to create a frame or
mullion edge profile override.
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3 Specify the mode in which to edit the curtain wall:

Then …If you want to edit …

click  Curtain Wall tab  ➤ Modify

panel ➤  Design Rules drop-down

 ➤ Transfer To Object.

this instance of the curtain wall

click  Curtain Wall tab  ➤ Modify

panel ➤  Design Rules drop-down

the curtain wall style

 ➤  Revert To Style Design Rules .
If this option is not available, the
design rules are already style-based
for the curtain wall.

4 Click  Curtain Wall tab  ➤ Modify panel ➤  Frame/Mullion
drop-down  ➤ Add Profile.

5 Select a vertical frame or mullion edge.

6 Select a profile for the override.

Then …If you want to create the edge
profile …

select Start from scratch for Profile
Definition, and enter a name for
New Profile Name.

from the polyline drawn in step 1

select the existing profile for Profile
Definition, and click Continue Edit-
ing.

from an existing profile in the
drawing

7 Select whether to apply the profile to the shared edge element
definition or as an edge profile override.
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8 Click OK.

You are now in in-place edit mode, and can edit the profile.

9 Click Edit In Place tab  ➤  Profile panel  ➤ Zoom To  .

10 Select the profile and edit it using Edge and Vertex grips, by using
the commands on the contextual Edit in Place tab, or by
right-clicking the context menu.

The Edge grip has three edit modes: Offset, Add Vertex, and
Convert to Arc. The default mode is Offset, which offsets the
selected edge in a direction that is perpendicular to the midpoint
of the edge. Depending on the shape of the profile and the edge
you choose to modify, neighboring lines are extended or trimmed,
and new lines are added, as necessary.

Use the Add Vertex edit mode to add a vertex to the selected edge,
and create a new edge. If the selected edge is an arc, the new edge
is an arc, as well.

Convert to Arc changes the selected edge to an arc and stretches
the midpoint of the edge. The edge grip for an arc also has a
Stretch mode, so that you can stretch the midpoint of the edge
after it has been converted to an arc.

11 Save or discard changes to the curtain wall grid:

Then …If you want to exit the in-place
editing session …

click Edit in Place tab ➤ Edits pan-

el ➤ Cancel  .

without saving your changes

click Edit in Place tab ➤ Edits pan-

el ➤ Finish  .

after saving your changes
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In-Place Editing of Edge Profiles for Curtain Walls
Use this procedure to edit profile edges using in-place editing. With in-place
editing, you can edit the curtain wall directly and interactively in the drawing
area and later save the changes to the profile definition.

1 Select a curtain wall that has the edge profile you want to edit
with in-place editing.

2 Click  Curtain Wall tab  ➤ Modify panel ➤  Frame/Mullion
drop-down  ➤ Edit Profile.

This command is only available if you have profile-based edges
in the curtain wall.

NOTE  If the profile is not drawn to size, it must be converted in
order for you to begin the in-place editing session. Click Yes if
prompted to convert the profile to its actual size.

3 Select the edge you want to edit.

NOTE  You have entered the in-place editing session now. You can
see this from the magenta-colored grips and light blue hatch of the
temporary in-place editing profile, as well as the faded color of all
other objects in the drawing. Note that while you are in the in-place
editing session, you have only limited editing access to other
commands in the drawing. Before working on other objects, you
should first end the in-place editing session.

4 Edit the profile:

Then …If you want to …

move the grips as needed.
The Edge grip has three edit modes:
Offset, Add Vertex, and Convert to

use grips to edit the profile

Arc. The default mode is Offset,
which offsets the selected edge in
a direction that is perpendicular to
the midpoint of the edge. Depend-
ing on the shape of the profile and
the edge you choose to modify,
neighboring lines are extended or
trimmed, and new lines are added,
as necessary.
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Then …If you want to …

Use the Add Vertex edit mode to
add a vertex to the selected edge,
and create a new edge. If the selec-
ted edge is an arc, the new edge is
an arc, as well.
Convert to Arc changes the selected
edge to an arc and stretches the
midpoint of the edge. The edge
grip for an arc also has a Stretch
mode, so that you can stretch the
midpoint of the edge after it has
been converted to an arc.

select an Edge grip, and press CTRL
to switch to the Add Vertex edit
mode.
Alternatively, you can click Edit In

Place tab ➤ Profile panel ➤  Add

Vertex  .

add a vertex to the profile

Move the edge to the desired loca-
tion and click, or enter a value and
press ENTER.

select the Vertex grip for the vertex
you want to remove, and press

remove a vertex from the profile

CTRL to switch to the Remove edit
mode.
Alternatively, you can click Edit In

Place tab ➤ Profile panel ➤  Re-

move Vertex  .
Move the cursor off the selected
vertex, and click.

select the profile, right-click and
click Add Ring.
Alternatively, you can click Edit In

Place tab ➤ Profile panel ➤  Add

Ring  .

add a ring to the profile

Then, select a closed polyline,
spline, ellipse, or circle for an addi-
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Then …If you want to …

tional ring. Specify if you want to
erase the source linework, and press
Enter.

select the profile, right-click and
click Remove Ring.
Alternatively you can click Edit In

Place tab ➤ Profile panel ➤  Re-

move Ring  .

remove a ring from a profile

Then select the ring you want to
remove.

NOTE  You cannot remove the
last ring from a profile.

select the profile, right-click and
click Replace Ring.
Alternatively you can click Edit In

Place tab ➤ Profile panel ➤  Replace

Ring  .

replace a ring on a profile

Then, select a closed polyline,
spline, ellipse, or circle for the re-
placed ring. Specify if you want to
erase the source linework, and press
Enter.

5 Save the changes to the profile.:

Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  .

change the existing profile defini-
tion to reflect the new shape

click Edit In Place tab ➤ Edits pan-

el ➤  Save As  . Then, enter a

create a new profile definition with
the shape you have created

name for the new profile and click
OK. The in-place edit session is ex-
ited and the new profile definition
is available in the Style Manager.
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Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

discard all changes on the profile
and revert back to the previous
shape

In-Place Editing of Curtain Wall Frames and Mullions
Use this procedure to edit frames and mullions using in-place editing with
the Edit Grid grip. With in-place editing, you can edit bays, columns or nested
grids of the curtain wall directly and interactively in the drawing area, and
later save the changes to the curtain wall or curtain wall style.

1 Select a curtain wall on which you want to edit frames or mullions
with in-place editing.

2 Specify the mode in which to edit the curtain wall:

Then …If you want to edit …

click  Curtain Wall tab  ➤ Modify

panel ➤  Design Rules drop-down

 ➤ Transfer To Object.

this instance of the curtain wall

click  Curtain Wall tab  ➤ Modify

panel ➤  Design Rules drop-down

 ➤  Revert To Style Design Rules .

the curtain wall style

3 Click the Edit Grid grip.

4 Enter f (Frame and mullion assignment) and press ENTER.

NOTE  You have entered the in-place editing session now. You can
see this from the faded color of all objects in the drawing, as well as
from the different grips at your disposal. Note that while you are in
the in-place editing session, you have only limited editing access to
other commands in the drawing. Before working on other objects,
you should first end the in-place editing session.

5 Select the bay, column or nested grid to modify the frame and
mullion assignment and press ENTER.

Press CTRL to select multiple bays, columns or nested grids.
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The Modify Frame/Mullion Assignment worksheet displays.

6 Select a frame definition for the selected grid:

Then…If you want to…

select a frame definition and click OK.modify the frame of the
selected grid

select Top, Bottom, Left, Right for Frame
Location and click OK.

specify the location of the
frame on the selected
grid

click  .
For more information, see Adding a New
Frame Assignment to a Curtain Wall on page
1490 .

create and assign a new
frame definition to the
selected grid

7 Select the mullion definition for the selected grid:

Then…If you want to…

select the mullion definition and click OK.modify the mullion of the
selected grid

click  and complete the Design Rules
worksheet.
For more information, see Adding a New
Mullion Assignment to a Curtain Wall Style
on page 1493 .

create and assign a new
mullion definition to the
selected grid

8 Press ENTER.
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Overriding Curtain Wall Divisions
The grid of a curtain wall is made up of one or more divisions that define how
the curtain wall is partitioned. Divisions can be horizontal or vertical, and
can be nested in each other. For detailed information on curtain wall divisions,
see Defining Divisions for Curtain Wall Grids on page 1442 .

You can override a division in a curtain wall, thereby changing the grid of the
curtain wall.

Creating a Division Override
Use this procedure to create a division override on a curtain wall.

NOTE  To exchange a curtain wall division, the new division definition must
already be defined in the curtain wall style. For information on curtain wall divisions,
see Defining Divisions for Curtain Wall Grids on page 1442 .

1 Select the curtain wall for which you want to create a division
override.

2 Click  Curtain Wall tab  ➤ Modify panel ➤  Division drop-down
 ➤ Override Assignment.

3 Select an edge of the curtain wall to determine if a horizontal or
vertical division is overridden.

For example, if you want to override the primary horizontal
division, you could select the bottom horizontal frame of the
curtain wall.
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TIP  The Division Assignment Override dialog box shows you which
grid type and which grid division you have selected, e.g. Selected
Nested Grid: Secondary Grid, Division Element Definition: Vertical 3
Cells. If you have accidentally selected the wrong division, click Cancel
and reselect the correct grid.

4 Select the appropriate division override, and click OK.

5 Specify where you want to save the curtain wall override:

Then …If you want to save the over-
ride …

no further steps are necessary. The
override is saved to the curtain wall.

only on this specific curtain wall

For information about how to re-
move an override from a curtain
wall, see Removing Curtain Wall
Overrides on page 1535 .

click  Curtain Wall tab  ➤ Modify

panel ➤  Design Rules drop-down

 ➤ Transfer To Object.

to a curtain wall style

6 If you have chosen to save the override to a curtain wall style,
select the curtain wall again, and  click  Curtain Wall tab
 ➤ Modify panel ➤  Design Rules drop-down  ➤ Save To Style.
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Then, decide to which curtain wall style you want to save the
override.

Then …If you want to save the over-
ride …

select Transfer Division Overrides to
Style, and click OK.

NOTE  If you have created only
a profile edge override, only the
Transfer Division Overrides to
Style checkbox is active. If you
have also created other over-
rides, such as a cell merge or a
edge override, these check-
boxes are available as well. If
you also want to save these
overrides to the style, select
their checkboxes, too.

to the current curtain wall style

select Transfer Division Overrides to
Style, and click New. Then, enter a

to a new curtain wall style

name for the new curtain wall style,
and click OK.

NOTE  If you have created only
a profile edge override, only the
Transfer Division Overrides to
Style checkbox is active. If you
have also created other over-
rides, such as a cell merge or a
edge override, these check-
boxes are available as well. If
you also want to save these
overrides to the style, select
their checkboxes, too.
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NOTE  If you do not want to save the override back to a style at all,
click  Curtain Wall tab  ➤ Modify panel ➤  Design Rules drop-down
 ➤  Revert To Style Design Rules .  The overrides remain on the curtain
wall, where they can be removed as described in Removing Curtain
Wall Overrides on page 1535 , but they are not saved back to a curtain
wall style.

In-Place Editing of Curtain Wall Divisions
Use this procedure to edit divisions using in-place editing with the Edit Grid
grip. With in-place editing, you can edit the curtain wall directly and
interactively in the drawing area, and later save the changes to the curtain
wall or curtain wall style. For more information, see Division of Curtain Wall
Grids on page 1442 .

1 Select a curtain wall on which you want to edit divisions with
in-place editing.

2 Specify the mode in which to edit the curtain wall:

Then …If you want to edit …

click  Curtain Wall tab  ➤ Modify

panel ➤  Design Rules drop-down

 ➤ Transfer To Object.

this instance of the curtain wall

click  Curtain Wall tab  ➤ Modify

panel ➤  Design Rules drop-down

 ➤  Revert To Style Design Rules .

the curtain wall style

3 Click the Edit Grid grip.

4 Enter d (Division in place) and press ENTER.

1532 | Chapter 22   Curtain Walls



Viewing edit in-place grips for a primary division

NOTE  You have entered the in-place editing session now. You can
see this from the faded color of all objects in the drawing, as well as
from the different grips at your disposal. Note that while you are in
the in-place editing session, you have only limited editing access to
other commands in the drawing. Before working on other objects,
you should first end the in-place editing session.

Viewing edit in-place grips for adding and removing bays

5 Edit the division:

Then …If you want to …

click the Add Bay grip.add a bay to the grid

click the Remove Bay grip.remove a bay from the grid

select the Start Offset grip and
move it to the appropriate position.

change the start offset of the grid
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Then …If you want to …

select the End Offset grip and move
it to the appropriate position.

change the end offset of the grid

click the Auto Grid Bay Spacing grip
and move it to the appropriate po-
sition.

change the spacing of bays

click  Edit In Place tab  ➤ Division

panel ➤  Convert To Manual  .

manually edit the grid

You can manually add and remove
gridlines, change the offsets, and
change the position of individual
gridlines.

click the Fixed Cell Dimension Rules
grip, and edit the values in the
worksheet.

use a worksheet to edit the cell di-
mensions

6 Save or discard changes to the curtain wall grid:

Then …If you want to …

click Edit in Place tab ➤ Edits pan-

el ➤ Finish  .

save the changes

click Edit in Place tab ➤ Edits pan-

el ➤ Cancel  .

discard all changes

7 In the Save Changes dialog box, specify to which division to save
the changes:

Then …If you want to …

verify the current division is selected
for Save Changes to Existing Divi-

save the changes to the style in the
current curtain wall division

sion, and click Save. The changes
are made in the style and affect all
curtain walls of that style in the
drawing.
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Then …If you want to …

click New, enter a name for the
new division override, and click OK.

create an override to the style by
saving the changes in a new curtain
wall division Click Save. The changes are saved

as an override to the style, and af-
fect only the curtain walls to which
the override is applied.

Removing Curtain Wall Overrides
Use this procedure to remove curtain wall overrides either from the curtain
wall or the curtain wall style.

1 Select the curtain wall.

Then …If you want to remove an
override …

expand Advanced in the Properties
palette, and click Overrides.

from a curtain wall

click  Curtain Wall tab  ➤ General

panel ➤  Edit Style drop-down

from the curtain wall style

 ➤ Edit Style. Then, click the Over-
rides tab.

2 Select an override from the list and click Remove.

3 Click OK.

Modifying Element Definitions for Curtain Wall Styles
Use this procedure to modify existing elements in a curtain wall style. A curtain
wall consists of division, infill, frame and mullion elements, all of which are
defined in the design rules of the curtain wall style.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select the curtain wall style that you want to change.
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4 Click the Design Rules tab.

5 In the left pane, click Element Definitions.

The list of element types is displayed.

Element definitions list

6 Decide the type of elements you want to edit:

Then …If you want to modify …

click Divisions under Element
Definitions. In the right pane, select

a division definition

the division definition you want to
modify and edit it as described in
Defining Divisions for Curtain Wall
Grids on page 1442 .

click Infills under Element Defini-
tions. In the right pane, select the

an infill definition

infill definition you want to modify
and edit it as described in Defining
Infills for Curtain Wall Cells on page
1455 .

click Frames under Element Defini-
tions. In the right pane, select the

a frame definition

frame definition you want to modify
and edit it as described in Defining
Curtain Wall Frames on page 1461 .
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Then …If you want to modify …

click Mullions under Element
Definitions. In the right pane, select

a mullion definition

the mullion definition you want to
modify and edit it as described in
Defining Curtain Wall Mullions on
page 1468 .

7 Click OK twice.

Editing Curtain Walls
Most relevant settings for a curtain wall are defined in the curtain wall style.
These include divisions, infills, frames, and mullions. For information on
modifying a curtain wall style, see Curtain Wall Styles on page 1436 .

You can make other changes directly to individual curtain walls. These changes
affect only the curtain wall you select:

■ Dimensions of a curtain wall

■ Roof and floor line settings

■ Interference conditions

■ Cleanup settings

Methods of Editing Curtain Walls

AutoCAD Architecture offers several methods for editing curtain walls:

■ You can directly edit curtain walls using grips for dimensions, base height,
location, and other physical characteristics.

■ You can directly edit curtain walls using the Edit Grid grip for grid divisions,
cells, frames, and mullions. For more information, see In-Place Editing of
Curtain Wall Divisions on page 1532 , In-Place Editing of Edge Profiles for
Curtain Walls on page 1524  and Overriding Curtain Wall Infills on page
1508 .

■ You can change curtain wall settings on the Properties palette. You can
also use the Display tab of the Properties palette to change the display
property settings for a selected object display component in the current
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display representation. For more information, see Using the Properties
Palette to Change Display Properties on page 793 .

■ You can select editing commands from the context menu for a selected
curtain wall.

■ For grip edit operations where you are changing a dimension or an angle,
the Dynamic Input feature lets you enter a precise value instead of moving
a grip. When this feature is active (click DYN on the application status
bar), selecting a grip displays a text box in which you can enter the desired
value for the associated dimension or angle. For more information, see
“Use Dynamic Input” in AutoCAD Help.

Using Grips to Edit Curtain Walls
There are many different curtain wall grips. The grips that appear in your
drawing when you select a curtain wall are dependent upon the design rules
of the curtain wall. For more information, see Curtain Wall Styles on page
1436 .

Editing Curtain Wall Dimensions
Use this procedure to change the dimensions of a curtain wall.

1 Select the curtain wall.

2 Select the grip for the dimension you want to change.

You can modify the dimensions of the length, roof line, floor
line, and base height for a curtain wall.
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Viewing Curtain Wall Lengthen and Base Height grips

3 Enter a value for the dimension and press ENTER, or drag the grip
until the dimension value you want is displayed.

Changing the Location or Position of a Curtain Wall
Use this procedure to change the location or the position of a curtain wall
with grips.

1 Select the curtain wall.

2 Select the appropriate grip to change the location of the curtain
wall, its start point, or its endpoint.
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Viewing Curtain Wall Start, End, Location, and Reverse Direction Grips

In Model view, the Location grip has three possible edit modes:
Edit Along Object’s XY Plane, Edit Along Object’s YZ Plane, and
Edit Along Object’s XZ Plane. Press CTRL to cycle between modes
until you are in the desired mode. The default edit mode is along
the XY plane. In Plan view, the Location grip is restricted to
movement in one plane.

3 Move the curtain wall to the desired location and click once, or
enter a value and press ENTER.

If you want to enter a specific value for the second direction in
any edit mode (for example, in the Y direction when editing along
the XY plane), press TAB to cycle to the second direction.

You can also lock the movement of the curtain wall along a
specific direction. If you enter a value for either of the dimension
directions in the current edit mode and then press TAB, the
movement of the curtain wall is constrained to the second
dimension direction. When editing along the XY plane, for
example, you can enter a value for X dimension, and then press
TAB. The X dimension is locked at that value, and movement of
the curtain wall is constrained to the Y dimension direction.
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Viewing Curtain Wall Location Grip

4 Right-click, and click Deselect All to turn off grips.

Changing the Base Height of a Curtain Wall
Use this procedure to change the base height of a curtain wall with grips.

1 Select the curtain wall.

2 Select the Base Height grip, move the grip until the height value
you want is displayed, and click once.
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NOTE  As you move the grip, the original base height value is
displayed in addition to the new base height and the difference
between the two values.

After selecting the grip, you can also enter a new value for the
base height of the curtain wall.
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Changing the Length of a Curtain Wall
Use this procedure to change the length of a curtain wall with grips.

1 Select the curtain wall.

2 Select the Lengthen grip, move the grip until the length value
you want is displayed, and click once.
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NOTE  As you move the grip, the original length value is displayed
in addition to the new length and the difference between the two
values.
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After selecting the grip, you can also enter a new value for the
length of the curtain wall.

Changing the Radius of a Curtain Wall
Use this procedure to change the radius of a curved curtain wall with grips.

1 Select the curtain wall.

2 Select the Curve Radius grip, move the grip until the radius value
you want is displayed, and click once.

NOTE  As you move the grip, the original radius value is displayed
in addition to the new radius and the difference between the two
values.

After selecting the grip, you can also enter a new value for the
radius of the curtain wall.

Reversing the Direction of a Curtain Wall
Use this procedure to change the direction in which a curtain wall is drawn
by reversing the start point and the end point of the curtain wall with grips.

Curtain walls are drawn from the first specified point to the last point. Some
commands and properties are affected by that order.

To determine the direction in which a curtain wall was drawn, select the
curtain wall. The Reverse Direction grip is shaped like an arrow and points in
the direction in which the curtain wall has been drawn.

1 Select the curtain wall for which you want to reverse the direction.
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2 Click on the Reverse Direction grip.

The direction of the wall is reversed, which switches the Start and
End grips.

Selecting a Different Curtain Wall Style
Use this procedure to select a different style for the curtain wall on the
Properties palette.

1 Double-click the curtain wall for which you want to change the
style.

You can select multiple curtain walls and change the style for all
at the same time.

2 On the Properties palette, scroll to the General subcategory.

3 Select a different style.
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Applying the Properties of an Existing Curtain Wall
Use this procedure to apply the properties of a curtain wall tool to one or more
existing curtain walls. The properties include the curtain wall style and any
other settings specified in the tool you select.

1 Open the tool palette that you want to use.

If necessary, scroll to display the tool that you want to use.

2 Right-click a curtain wall tool, and click Apply Tool Properties
to ➤ Curtain Wall.

3 Select the curtain wall(s), and press ENTER.

The properties of the selected curtain wall(s) match the properties
of the curtain wall tool.

Changing the Dimensions of a Curtain Wall
Use this procedure to change the dimensions of a curtain wall on the Properties
palette.

1 Double-click a curtain wall.

2 On the Properties palette, expand Dimensions.

3 Change the dimension:

DescriptionDimension

Height of the curtain wall from the
baseline

Base Height

Length of a straight curtain wall
from the start grip on the baseline
to the end grip

Length

Radius of a curved curtain wall from
the start grip on the baseline to the
end grip

Radius (curved curtain walls only)

Angle of all infills and horizontal
edges (frame or mullion) at the start

Start Miter

of the curtain wall: for more inform-
ation about miter angles, see
Mitering Curtain Walls on page 1551
.
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DescriptionDimension

Angle of all infills and horizontal
edges (frame or mullion) at the end
of the curtain wall

End Miter

Changing the Curtain Wall Location Properties
Use this procedure to relocate a curtain wall by changing the coordinate values
of its insertion point. The curtain wall also has an orientation with respect to
the WCS or the current UCS. For example, if the top and bottom of the curtain
wall are parallel to the XY plane, its normal is parallel to the Z axis. You can
change the orientation of the curtain wall by aligning its normal with another
axis. You can also rotate the curtain wall on its plane by changing the rotation
angle.

For information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use Coordinates and Coordinate Systems” in
AutoCAD Help.

1 Double-click the curtain wall you want to change.

2 Expand Location.

3 Click Additional information.

4 Specify the location of the curtain wall:

Then …If you want to …

enter new coordinate values under
Insertion Point.

relocate the curtain wall

make the normal of the wall parallel
to the Z axis: under Normal, enter
1 for Z, and enter 0 for X and Y.

locate the curtain wall on the XY
plane

make the normal of the curtain wall
parallel to the X axis: under Normal,

locate the curtain wall on the YZ
plane

enter 1 for X and enter 0 for Y
and Z.

make the normal of the curtain wall
parallel to the Y axis: under Normal,

locate the curtain wall on the XZ
plane
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Then …If you want to …

enter 1 for Y, and enter0 for X
and Z.

enter a new value for Rotation
Angle.

change the rotation of the curtain
wall

5 Click OK.

Adding an Interference Condition to a Curtain Wall
Use this procedure to add an interference condition to a curtain wall.
Interference conditions use the geometry of 3D objects to create custom
openings or cutouts in curtain walls. You can specify how the interference
condition is applied to the curtain wall: added to the curtain wall, subtracted
from the curtain wall, or ignored.

You can specify whether the interference condition applies to an infill, frame,
or mullions of a curtain wall.

1 Place the object in the location where you want to specify the
interference condition.

2 Select the curtain wall to which you want to add an interference
condition.

3 Click  Curtain Wall tab  ➤ Modify panel ➤  Interference

drop-down  ➤ Add  .

4 Select the object intersecting the curtain wall, and press ENTER.

5 Specify to which curtain wall component the interference should
be added:

Then …If you want to add the interfer-
ence condition …

enter y (Yes) when prompted for
the infill component.

to the infill

enter y (Yes) when prompted for
the frame component.

to the frame

enter y (Yes) when prompted for
the mullion component.

to the mullion
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6 Press ENTER.

Removing an Interference Condition from a Curtain Wall
Use this procedure to remove an object, such as a mass element, from a curtain
wall that the object was added to as an interference condition.

1 Select the curtain wall from which you want to remove an
interference object.

2 Click  Curtain Wall tab  ➤ Modify panel ➤  Interference

drop-down  ➤ Remove  .

3 Select the object intersecting the curtain wall, and press ENTER.

Mitering Curtain Walls
Use this procedure to miter the corners where curtain walls meet. The corner
where adjacent curtain walls meet is not mitered by default. However, you
can determine the necessary angles automatically.

The miter angle applies to all infills and horizontal edges (frame or mullion)
that are adjacent to the corner. Vertical edges are not affected.

TIP  If you want to create a custom corner condition between two curtain walls,
you can replace the edge of one curtain wall with an AEC profile and remove the
edge of the other curtain wall by using the frame override Remove Edge option.
For more information, see Overriding Curtain Wall Frames and Mullions on page
1518  and Defining Curtain Wall Frames on page 1461 .

1 Select one of the curtain walls.

2 Click  Curtain Wall tab  ➤ Modify panel ➤  Set Miter Angles 
.

3 Select the other curtain wall.

If you change the angle of either curtain wall, use Set Miter Angles
again to recalculate the angles.
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Specifying a Miter Angle for a Curtain Wall Adjacent to Another
Object

Use this procedure to manually create a mitered corner between a curtain wall
and another object, such as a standard wall or a mass element. For example,
if your curtain wall connects with a standard wall that is at a 60-degree angle
from the curtain wall, you would set the miter angle to 30.

The miter angle applies to all infills and horizontal edges that are adjacent to
the corner. Vertical edges are not affected.

TIP  To quickly identify the start and end of a curtain wall, select the curtain wall.
The Reverse Direction grip points toward the end of the curtain wall.

Frame miter angles for a curtain wall

1 Double-click the curtain wall.

2 Expand Dimensions.

3 Miter the curtain wall on the start or the end point:

Then …If you want to miter the curtain
wall …

enter an angle for Start Miter, and
press ENTER.

at its start point

enter an angle for End Miter, and
press ENTER.

at its end point
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Specifying the Cut Plane Display of a Curtain Wall
Use this procedure to specify the properties of one or more cut planes for an
individual curtain wall. Cut plane display properties apply only to display
representations, such as Plan, that are used in the Top view (plan view) of a
drawing.

1 Double-click the curtain wall.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE  To apply your changes to all curtain walls in the drawing,
select Drawing default setting. To apply changes to all curtain walls
of this style, select Curtain Wall Style:<style name>. For more
information on styles, see Curtain Wall Styles on page 1436 .

5 If necessary, expand Object Display Properties ➤ Cut Plane.

6 For Override cut plane, specify whether you want to override the
global cut plane defined for the current display configuration.

7 If you selected Yes for Override cut plane, enter a value for Height
to define the cut plane for this object.

8 For Use cut plane of containing object when anchored, specify
whether you want the containing object’s cut plane to be used
when the curtain wall is anchored to that object.

9 To define additional cut planes for the curtain wall, click 
Manual cut planes.

10 On the Manual Above and Below Cut Plane Heights worksheet,
click Add, and under Cut Plane, enter the height of the new cut
plane.

Then …If you add a cut plane …

objects are displayed using the
Layer/Color/Linetype properties

at a height that is lower than the
current cut plane

specified for the Below Cut Plane
component of the object.

objects are displayed using the
Layer/Color/Linetype properties

at a height that is higher than the
current cut plane
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Then …If you add a cut plane …

specified for the Above Cut Plane
component of the object.

You can click Remove to delete a cut plane that you added.

You can also access and modify these same cut plane settings through the
curtain wall’s context menu, as follows

1 Select the curtain wall you want to change, right-click, and click
Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 In the Display Properties dialog, click the Cut Plane tab, and then
change the settings as needed.

5 Click OK twice.

Specifying the Display of Other Characteristics of a Curtain Wall
Use this procedure to specify other display properties for a curtain wall,
including cell marker size, the display of miters at frame corners, and the
display of custom components. If you are going to use custom graphics for a
component, draw the component and save it as a block before you start this
procedure.

1 Double-click the curtain wall.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE  To apply your changes to all curtain walls in the drawing,
select Drawing default setting. To apply changes to all curtain walls
of this style, select Curtain Wall Style:<style name>. For more
information on styles, see Curtain Wall Styles on page 1436 .
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5 If necessary, expand Object Display Properties ➤ Advanced.

6 If you want to change the size of the markers used for cells in the
curtain wall grid, click Cell marker size, and enter a new value.

(Alternatively, you can click  and specify 2 points in the
drawing area to set the new size.)

7 Optionally, for Show mitres at frame corners, select Yes/No.

8 If you want to add or edit a custom component, for Custom model
components (or for Custom plan components, if in a plan view),

click  .

9 On the Custom Model (or Plan) Components worksheet, click
Add, or select one of the components in the list, and click Edit.

10 On the Custom Display Component worksheet, for Component
Type, select Infill, Frame, or Mullion.

11 Enter a name for Component Name, or click Select Component,
and in the Select <component type> Definition dialog, select a
definition and click OK.

12 Select Draw Custom Graphics.

13 Specify the display of the element:

Then …If you want to …

select Replace Graphics.display the block instead of the as-
sociated curtain wall element

clear Replace Graphics.superimpose the block over the
curtain wall element so that both
are displayed

14 Click Select Block, select the custom block that you created, and
click OK.

15 Specify further settings for the custom display block:

Then …If you want to …

select Width, Height, or Depth. To
prevent the block from losing its
proportions, select Lock XY Ratio.

scale the block to fit a particular di-
mension

specify an insertion point on the X,
Y, and Z planes.

specify how the block is inserted
into the grid in the X, Y, and Z dir-
ections
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Then …If you want to …

determine whether it should mirror
in the X, Y, or Z direction.

mirror the block

specify the offset in the X, Y, or Z
direction.

offset the block from the grid

16 Click OK twice.

Attaching Hyperlinks, Notes, or Files to a Curtain Wall
Use this procedure to enter notes and attach reference files to a curtain wall.
You can also edit notes and edit or detach reference files from a curtain wall.

1 Double-click the curtain wall.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

4 To add a note, click the setting for Notes, and enter the text.

5 Click OK.

6 To attach a reference file, click under Reference documents, and
attach, edit, or detach a reference file:

Then …If you want to …

click Add, select a file, and click
Open.

attach a reference file

select the file, and click the descrip-
tion. Enter the new text, and press
ENTER.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

7 Click OK twice.
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Changing the Roof Line and the Floor Line of a Curtain
Wall

You can modify the roof and floor lines of a curtain wall to create a
non-rectangular curtain wall:

■ You edit vertex locations on the roof line to create steps, gables, and other
roof conditions.

Modifying the roof line of a curtain wall

■ You edit vertex locations on the floor lines to create steps and other floor
conditions.

Modifying the floor line of a curtain wall

You can also create non-rectangular roof and floor conditions by projecting
to polylines.

AutoCAD Architecture offers multiple methods of editing roof lines and floor
lines. You may want to begin by graphically creating a custom roof line or
floor line condition. You can then fine-tune that condition by specifying
precise values in the Roof/Floor Line worksheet on the Properties palette.

Offsetting or Projecting the Roof Line of a Curtain Wall
Use this procedure to change the height or the shape of the roof line of a
curtain wall:

■ Offset the roof line from the current height of the curtain wall.
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■ Project the roof line of the curtain wall to a polyline.

■ Project the roof line of the curtain wall to another object, such as a roof
or stairs.

You can also create a polyline that represents the current roof line of the
selected curtain wall. You can then use this polyline to change the roof line
of other curtain walls.

NOTE  To project the roof line to a polyline, draw the polyline first in Elevation
view. For best results, the polyline should be parallel to the curtain wall. The
polyline does not need to be in the same plane as the curtain wall.

1 Select a curtain wall, and  click  Curtain Wall tab  ➤ Modify

panel ➤  Roof/Floor Line drop-down  ➤ Modify Roof Line  .

The current roof line is the default value in the curtain wall style.

2 Change the roof line of the wall:

Then …If you want to …

enter o (Offset), select the curtain
walls to change, and enter an offset

offset the roof line from the current
height of the curtain wall

distance. Enter a negative value to
project the roof line below the cur-
rent curtain wall height.

enter p (Project), select the curtain
walls to change, and select the
polyline.

project the roof line to a polyline

enter g (Generate), and select the
curtain walls for the polyline to be
created from.

generate a polyline of the current
roof line

enter a (Auto-project), select the
curtain walls to change, and select

project the roof line to another ob-
ject, such as a roof or stairs

the object to project to. When pro-
jecting to stairs, make sure that the
bottom riser or the stringer does
not create a zero-height segment
of curtain wall.
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Then …If you want to …

enter r (Reset), and select the cur-
tain walls to change.

remove any changes to the roof line

3 Press ENTER.

The new roof line value is used only on the selected curtain walls.
The curtain wall style is unchanged.

Offsetting or Projecting the Floor Line of a Curtain Wall
Use this procedure to change the height or the shape of the floor line of a 
curtain wall:

■ Offset the floor line from the current baseline of the curtain wall.

■ Project the floor line of the curtain wall to a polyline.

■ Project the floor line of the curtain wall to another object, such as a floor
slab or stairs.

You can also create a polyline that represents the current floor line of the
selected curtain walls. You can then use this polyline to change the floor line
of other curtain walls.

NOTE  To project the floor line to a polyline, draw the polyline first in Elevation
view. For best results, the polyline should be parallel to the curtain wall. The
polyline does not need to be in the same plane as the curtain wall.

1 Select a curtain wall, and click  click  Curtain Wall tab  ➤ Modify

panel ➤  Roof/Floor Line drop-down  ➤ Modify Floor Line  .

The current floor line is the default value in the curtain wall style.

2 Change the floor line of the curtain wall:

Then …If you want to …

enter o (Offset), select the curtain
walls to change, and enter an offset

offset the floor line from the current
baseline of the curtain wall

distance. Enter a negative value to
offset the floor line below the cur-
rent baseline.
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Then …If you want to …

enter p (Project), select the curtain
walls to change, and select the
polyline.

project the floor line to a polyline

enter g (Generate), and select the
curtain walls for the polyline to be
created from.

generate a polyline of the current
floor line

enter a (Auto-project), select the
curtain walls to change, and select
the object to project to.

project the floor line to another
object, such as a floor slab or stairs

enter r (Reset), and select the cur-
tain walls to change.

remove any changes to the floor
line

3 Press ENTER.

The new floor line value is used only in the selected curtain wall.
The curtain wall style is unchanged.

Editing the Roof Line or the Floor Line of a Curtain Wall
Use this procedure to edit the geometry of the roof line or the floor line of a
curtain wall:

■ Add, modify, or remove gables.

■ Add, modify, or remove steps.

■ Project the roof line or the floor line to a polyline or to other objects, such
as roofs, roof slabs, slabs, and stairs.

■ Create custom roof line or floor line conditions by adding and adjusting
vertices and edges.

■ Reverse the roof line or the floor line of the curtain wall without reversing
the curtain wall itself.

■ Remove all changes to the roof line or the floor line of a curtain wall.
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You can also edit the roof line and the floor line on the Roof/Floor Line
worksheet on the Properties palette. For more information, see Changing
Vertices in the Roof Line or Floor Line of a Curtain Wall on page 1567.

NOTE If you want to project the roof line or the floor line to a polyline, draw the
polyline before you start this procedure.

1 Select the curtain wall that you want to change, and  click  Curtain
Wall tab  ➤ Modify panel ➤  Roof/Floor Line drop-down  ➤ Edit

In Place  .

A temporary profile is created for you to edit the geometry of the
roof line or the floor line.

2 Edit the profile:

Then …If you want to …

click Edit In Place tab ➤ Profile

panel ➤  Add Gable  . Then,
select the roof line or the floor line.

add a gable to the roof line or the
floor line

click Edit In Place tab ➤ Profile

panel ➤  Add Step  . Then, se-
lect the roof line or the floor line.

add a step to the roof line or the
floor line

select the profile, and use Vertex
and Edge grips to adjust the shape.

change the shape of the roof line
or the floor line

select the profile, right-click and
click Add Vertex. Select a point for
each new vertex, and press ENTER.

add vertices to the roof line or the
floor line

select the profile, right-click and
click Remove Vertex. Select each
vertex to remove, and press ENTER.

remove vertices from the roof line
or the floor line

click Edit In Place tab ➤ Profile

panel ➤  Project To Polyline  .

project the roof line or the floor line
to a polyline

Select the roof line or the floor line,
and select the polyline. Press ENTER
to keep the geometry, or enter n
(No) to erase it.
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Then …If you want to …

click Edit In Place tab ➤ Profile

panel ➤  Auto Project  . Select

project the roof line or the floor line
to another object, such as a stair or
a roof

the roof line or the floor line, and
select the object.

click Edit In Place tab  ➤ Profile

panel ➤ Reverse  . Select the
roof line or the floor line.

reverse the roof line or the floor line

click Edit In Place tab ➤ Profile

panel ➤ Remove  . Select the
roof line or the floor line.

restore the roof line to the base
height of the curtain wall, or restore
the floor line to the baseline of the
curtain wall

NOTE  To add a gable or a step to a roof line or a floor line that has
been edited, first use the Remove command on the contextual ribbon
tab to remove an existing roof line or floor line condition.

3 Save or discard the changes:

Then …If you want to …

click Edit in Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the roof line and the floor
line to their shape before editing

click Edit in Place tab ➤ Edits pan-

el ➤ Finish  .

save the changes

Changing the Roof Line and the Floor Line
Use this procedure to change the height or the shape of the roof line and the
floor line using grips.

1 Select a curtain wall.
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2 Select a Roof Line End or Floor Line End grip, move the grip to
the appropriate position, and click once.
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Adding a Gable to the Roof Line of a Curtain Wall
Use this procedure to add a gable to the roof line of a curtain wall. You can
also add a gable on the Roof/Floor Line worksheet on the Properties palette.
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For more information, see Specifying Gable Settings for a Roof Line on page
1569 .

NOTE  This option is available only if the roof line has not been edited. After the
roof line changes, you cannot add a gable using this option. To add a gable to a
roof line that has been edited, see Changing Vertices in the Roof Line or Floor
Line of a Curtain Wall on page 1567 .

1 Select the curtain wall, and  click  Curtain Wall tab  ➤ Modify

panel ➤  Roof/Floor Line drop-down  ➤ Edit In Place  .

A temporary profile is created for you to edit the geometry of the
Roof line.

2 Click  Edit In Place tab  ➤ Profile panel ➤  Add Gable  .

If Add Gable cannot be selected, the roof line was previously
edited.

3 Select the roof line.

Modifying a curtain wall roof line by adding a gable

A third vertex is added to the roof line halfway between the two
ends of the roof line.

4 Continue editing the roof line or the floor line, if needed.

For more information, see Changing the Roof Line and the Floor
Line on page 1562 .
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5 Save or discard the changes:

Then …If you want to …

click Edit in Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the roof line and the floor
line to their shape before editing

click Edit in Place tab ➤ Edits pan-

el ➤ Finish  .

save the changes

Adding a Step to the Roof Line or Floor Line of a Curtain Wall
Use this procedure to add a step to the roof line or the floor line of a curtain
wall. You can also add a step on the Roof/Floor Line worksheet on the
Properties palette. For more information, see Specifying Step Settings for a
Roof Line or Floor Line on page 1570 .

NOTE  This option is available only when the roof line or the floor line has not
been edited. After the line has been changed, you cannot automatically add a
step using this option. To add a step to a roof line or a floor line that has been
edited, see Changing Vertices in the Roof Line or Floor Line of a Curtain Wall on
page 1567 .

1 Select the curtain wall, and  click  Curtain Wall tab  ➤ Modify

panel ➤  Roof/Floor Line drop-down  ➤ Edit In Place  .

A temporary profile is created for you to edit the geometry of the
Roof line.

2 Click  Edit In Place tab  ➤ Profile panel ➤  Add Step  .

If Add Step cannot be selected, the roof line or the floor line was
previously edited.

3 Select the roof line or the floor line.
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Modifying a curtain wall floor line by adding a step

A third vertex is added to the line halfway between the two ends
of the line and four feet from the line. A step is created from the
selected vertex to the second vertex.

4 Continue editing the roof line or the floor line, if needed.

For more information, see Changing the Roof Line and the Floor
Line on page 1562 .

5 Save or discard the changes:

Then …If you want to …

click Edit in Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the roof line and the floor
line to their shape before editing

click Edit in Place tab ➤ Edits pan-

el ➤ Finish  .

save the changes

Changing Vertices in the Roof Line or Floor Line of a Curtain
Wall

Use this procedure to perform the following tasks:

■ Add, move, or remove vertices and edges in the roof line or the floor line
of a curtain wall.
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■ Add gables or steps to a roof line or steps to a floor line that was previously
edited by adding vertices that define these conditions.

■ Remove all changes to the roof line or the floor line, restoring the original
base height or baseline of a curtain wall.

NOTE  You can also edit vertices in a curtain wall with the curtain wall worksheets.
For information, see Specifying Vertex Settings for a Roof Line or Floor Line on
page 1571 .

1 Select the curtain wall, and  click  Curtain Wall tab  ➤ Modify

panel ➤  Roof/Floor Line drop-down  ➤ Edit In Place  .

A temporary profile is created for you to edit the geometry of the
Roof line.

2 Edit the vertices:

Then …If you want to …

select its grip and move it to the
appropriate position.

change the position of a vertex or
an edge

select the profile, right-click and
click Add Vertex. Select a point for
each new vertex, and press ENTER.

add a vertex

select the profile, right-click and
click Remove Vertex. Select each
vertex to remove, and press ENTER.

remove a vertex

click Edit In Place tab ➤ Profile

panel ➤ Remove  . Select the
roof line or the floor line.

restore the original roof line or floor
line

3 Save the changes to the curtain wall:

Then …If you want to …

click Edit in Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the roof line and the floor
line to their shape before editing
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Then …If you want to …

click Edit in Place tab ➤ Edits pan-

el ➤ Finish  .

save the changes

Specifying Gable Settings for a Roof Line
Use this procedure to add a gable to the roof line of a curtain wall by adding
a vertex to the roofline.

Modifying a curtain wall roof line by adding a gable

NOTE  This option is available only if the roof line has not been edited. After the
roof line changes, you cannot add a gable using this option. To add a gable to a
roof line that has been edited, see Changing Vertices in the Roof Line or Floor
Line of a Curtain Wall on page 1567 .

1 Select the curtain wall, and  click  Curtain Wall tab  ➤ Modify
panel ➤  Roof/Floor Line drop-down  ➤ Roof/Floor Line Settings

 .

2 Select Edit Roof Line or Edit Floor Line.

3 Click Add Gable.

A third vertex is added to the roof line halfway between the two
ends of the roof line.
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The table at the top of the dialog box displays information about
each vertex in the curtain wall. You can also select the vertex to
edit from the list.

4 Click OK.

Specifying Step Settings for a Roof Line or Floor Line
Use this procedure to add a step to the roof line or the floor line of a curtain
wall.

Modifying a curtain wall roof line by adding a gable

1570 | Chapter 22   Curtain Walls



NOTE  This option is available only when the roof line or the floor line has not
been edited. After the line has been changed, you cannot automatically add a
step using this option. To add a step to a roof line or a floor line that has been
edited, see Changing Vertices in the Roof Line or Floor Line of a Curtain Wall on
page 1567 .

1 Select the curtain wall, and  click  Curtain Wall tab  ➤ Modify
panel ➤  Roof/Floor Line drop-down  ➤ Roof/Floor Line Settings

 .

2 Select Edit Roof Line or Edit Floor Line.

3 Click Add Step.

A third vertex is added to the line halfway between the two ends
of the line. A step is created from the selected vertex to the second
vertex.

The table at the top displays information about each vertex in
the curtain wall. You can select a vertex to edit from the list.

4 Click OK.

Specifying Vertex Settings for a Roof Line or Floor Line
Use this procedure to perform the following tasks:

■ Add, move, or remove vertices in the roof line or the floor line of a curtain
wall.

■ Add gables or steps to a roof line or steps to a floor line that was previously
edited by adding vertices that define these conditions.
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1 Select the curtain wall, and  click  Curtain Wall tab  ➤ Modify
panel ➤  Roof/Floor Line drop-down  ➤ Roof/Floor Line Settings

 .

2 Select Edit Roof Line or Edit Floor Line.

The active vertex in the illustration changes when you select a
different line to edit. Any changes you make to the wall are
reflected in the illustration.

3 Specify vertex settings:

Then …If you want to …

click Insert Vertex. In the Wall
Roof/Floor Line Vertex dialog box,

add a vertex

specify the horizontal offset and
vertical offset for the new vertex,
specify a distance, and click OK.

select a vertex from the list, and
then click Edit Vertex.

move a vertex

select a vertex from the list, and
then click Delete Vertex. The selec-

delete a vertex

ted vertex is deleted, and the line
automatically connects the two ad-
jacent vertices.

4 Specify the horizontal offset.

The horizontal offset specifies the existing vertex from which to
measure the placement of the next vertex and how far away from
the existing vertex to place the new one. Distance is measured in
the direction the curtain wall is drawn. You can enter a negative
number to offset the vertex in the reverse direction.

5 Specify the vertical offset.

The vertical offset specifies the location from which to measure
the height of the next vertex and how far away from the existing
location to place the new vertex. You can enter a negative number
to offset the vertex toward the ground.

6 Click OK twice.
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Editing Objects Anchored in Curtain Walls
When you fill a curtain wall cell with an infill that contains an object, such
as a door or window, you can edit that object independently from the curtain
wall. For example, you can select a door from a curtain wall and edit its
properties. You can edit the anchor settings for the door to change the
orientation of the door and the alignment or offset of the door in relation to
the curtain wall.

You can also move objects from one cell to another or release the object anchor
so that the object moves independently of the curtain wall.

When you move or release an object or edit its properties, you are creating a
variation from the infill cell assignment for the curtain wall style. By default,
these variations (except release) are allowed to persist in the drawing when
you reapply the style to a curtain wall. However, if you want these variations
to be overridden when you reapply a curtain wall style, turn off the Allow
Variation from Infill Element Definition option on the Anchor worksheet of
the Properties palette of the object. This option is set on a per object basis.

Changing the Orientation of an Object Anchored in a Curtain
Wall

Use this procedure to change the orientation of an object anchored in a curtain
wall using grips.

1 Click the object in the curtain wall for which you want to change
the orientation.

2 Click the appropriate Flip grip to change the X or Y direction of
the object.

You can also change the orientation of an object, including the
Z direction, using the Anchor worksheet found on the object’s
Properties palette.

Changing the Alignment of an Object Anchored in a Curtain Wall
Use this procedure to modify the alignment of an object that is anchored in
a curtain wall.

1 Double-click the object in the curtain wall.

2 Expand Location, and click Anchor.
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3 Click Allow Variation from Infill Element Definition.

4 Select a new alignment for the object.

For more information, see Specifying an Alignment for a Curtain
Wall Infill on page 1458 .

5 Click OK.

Changing the Offset of an Object Anchored in a Curtain Wall
Use this procedure to change the offset of an object anchored in a curtain
wall.

1 Double-click the object in the curtain wall.

2 Expand Location, and click Anchor.

3 Click Allow Variation from Infill Element Definition.

4 Specify a new offset for the object.

For more information, see Specifying an Offset for a Curtain Wall
Infill on page 1459 .

5 Click OK.

Swapping Two Objects Anchored in a Curtain Wall
When you fill a curtain wall cell with an object, such as a door or window,
you can swap that object with another object in the curtain wall.

1 Select one of the objects from the curtain wall, right-click, and
click Infill Anchor ➤ Swap Objects.

2 Select the object you want to swap with.

Releasing an Object Anchored in a Curtain Wall
When you fill a curtain wall cell with an object, such as a door or window,
that object is anchored to the curtain wall. While the anchor is in place, the
object moves when you move the curtain wall and is removed when you erase
the curtain wall. If you want to move or erase an object independently from
the curtain wall, you can release the anchor of the object.

1574 | Chapter 22   Curtain Walls



NOTE  You can also move or erase the object by changing the element definition
for the cell that contains the object. For more information, see Defining Infills for
Curtain Wall Cells on page 1455 .

■ Select one of the objects from the curtain wall, right-click, and click Infill
Anchor ➤ Release.

Curtain Wall Units
Curtain wall units are an important building block of curtain walls.

The Concept of Curtain Wall Units

Curtain wall units can significantly reduce the complexity of the curtain wall
design and, thereby, the necessary design time.

You can think of a curtain wall unit as a “mini” curtain wall itself, which can
have frames, mullions and divisions, but is normally not a standalone building
object. A curtain wall unit is used in the larger context of a curtain wall. You
usually assign curtain wall units to specific cells within a curtain wall grid.
For more information, see Inserting an Object into a Curtain Wall Cell on
page 1485 .

Curtain Wall Unit Styles

Curtain wall units are style-based, permitting maximum efficiency and
flexibility. Curtain wall unit styles are created and edited independently from
the curtain wall style. You can use a curtain wall unit style in different curtain
wall styles. For example, you can create a decorative three-tiled panel as a
curtain wall unit and use that for several curtain wall styles.

Curtain Wall Units and Door/Window Assemblies

Curtain wall units and door/window assemblies are very similar in their
functionality. Both can contain nested grids and be anchored as building
blocks in curtain walls. A curtain wall unit usually is not used as a standalone
object, whereas a door/window assembly could be.

Curtain Wall Unit Grids

Like curtain walls, curtain wall units are made up of one or more grids. Each
grid has either a horizontal division or a vertical division, but you can nest
the grids to create a variety of patterns.
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Using curtain wall units in a curtain wall can Help you limit the complexity
in the curtain wall design.

Elements of Grids

Grids are the foundation of curtain walls and curtain wall units. Every grid
has four element types:

■ Divisions: Define the direction of the grid (horizontal or vertical) and the
number of cells

■ Cell Infills: Contain another grid, a panel infill, or an object such as a
window or a door

■ Frames: Define the edge around the outside of the primary grid and nested
grids

■ Mullions: Define the edges between the cells

NOTE  Division is an abstract element, in contrast to the other three element types
that represent physical elements of the curtain wall unit.

Each element type is assigned a default definition that describes what elements
of that type look like.

Default definitionsElement type

Horizontal grid with two manual divisions
offset from the top and bottom of the grid

Divisions

Cells containing simple panelsCell Infills

Outer edges of grid 3" wide and 3" deepFrames

Edges between cells 1" wide and 3" deepMullions
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Curtain wall units default element definitions

Getting Started with Curtain Wall Units

To get started with curtain wall units, draw a curtain wall unit using one of
the methods described in Creating Curtain Wall Units on page 1577 . Try a
variety of the existing curtain wall unit styles, find a style you like and make
a copy of it. Then, modify the element definitions and assignments to suit
your own needs. For more information, see Creating Element Definitions for
a Curtain Wall Unit Style on page 1582 .

For more information about element definitions and assignments, see Creating
Element Definitions for a Curtain Wall Unit Style on page 1582  and Assigning
Infills to Curtain Wall Unit Cells on page 1614 .

Creating Curtain Wall Units
Creating curtain wall units is similar to creating curtain walls. You specify a
style, a height, and start and end points. You can also create curtain wall units
by converting a 2D layout grid to a curtain wall or converting two-dimensional
(2D) lines, arcs, and circles. Unlike curtain walls, you cannot create a curtain
wall unit based on a curve. Curtain wall units can only be planar.

Creating a Curtain Wall Unit
Use this procedure to create a curtain wall unit.
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Drawing a curtain wall unit

1 Click  Home tab  ➤ Build panel ➤  Wall drop-down  ➤ Curtain

Wall Unit  .

2 Select a start point and an end point.

3 Specify a height for the curtain wall unit.

4 Select a style, and click OK.

For information about curtain wall unit styles, see Curtain Wall Unit Styles
on page 1582 .

Converting a Layout Grid to a Curtain Wall Unit
You can create a curtain wall unit grid that is based on a 2D layout grid. If
you already have 2D layout grids in a drawing, you can easily convert them
to curtain wall units. Or if you are already familiar with layout grids, it is an
efficient way to create a curtain wall unit, and then experiment with the
curtain wall commands to learn more about them.

1578 | Chapter 22   Curtain Walls



Converting a 2D layout grid to a curtain wall unit

When you create a curtain wall unit from a 2D layout grid, you also create a
new curtain wall unit style. The divisions in the new curtain wall unit style
are taken from the divisions in the layout grid.

Curtain wall unit grids are one-dimensional, divided either horizontally or
vertically. To create the horizontal and vertical patterns in the 2D layout grid,
the curtain wall unit uses a primary grid with a secondary grid nested inside
it. For more information about nested grids, see Working with Nested Grids
in Curtain Walls on page 1478 .

When you create a curtain wall unit grid from a 2D layout grid, you need to
decide the direction of the primary grid in the curtain wall unit. If you select
horizontal, the primary grid has horizontal divisions that cross over the vertical
divisions of the secondary grid. If you select vertical, the primary grid has
vertical divisions that cross over the horizontal divisions of the secondary
grid.

Specifying primary division directions

The horizontal and vertical lines of the 2D layout grid define the divisions for
the curtain wall unit grids. The grid cells, frame, and mullions are assigned
default definitions.
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1 Create a layout grid.

For more information, see Using Layout Grids on page 2719 .

2 At the command line, enter cwunit.

3 Enter c (Convert).

4 Enter LA (LayoutGrid).

5 Select the layout grid.

6 To erase the layout grid, enter y (Yes). To have the layout grid
remain after the curtain wall unit is created, enter n (No).

7 When prompted for the primary division, enter v (Vertical) or h
(Horizontal) as the orientation.

8 Enter a name for this new curtain wall unit style.

9 Click OK, and press ENTER to end the command.

Creating a Curtain Wall Unit with a Custom Grid
Curtain wall units contain one or more grids. You can define a custom grid
with lines, arcs, and circles, and then convert that linework into a curtain wall
unit.

NOTE  Curtain wall unit grids are either horizontal or vertical. To create a grid
pattern with horizontal and vertical cells, nested grids are used. For more
information about nested grids, see Working with Nested Grids in Curtain Walls
on page 1478 .

You cannot modify the division definition of a custom grid created from lines,
arcs, and circles. You can, however, assign a different division definition to
it. For more information, see Assigning a Division to a Curtain Wall Unit
Grid on page 1613 .

1 Use lines, arcs, and circles to draw a grid in the current world
coordinate system (WCS).

2 At the command line, enter cwunit.

3 Enter c (Convert).

4 Enter LI (LInework).

5 Select the lines, arcs, or circles that define your grid.

6 Press ENTER.

7 Select one of the grid lines as the baseline for the curtain wall or
press ENTER to use the line along the X axis as the baseline.

1580 | Chapter 22   Curtain Walls



Converting linework to curtain walls units using the default baseline option

TIP  If you draw your linework in the XY plane (in Plan view) and
accept the default baseline, the resulting curtain wall unit is displayed
as it is projected in the Z direction.

Converting linework to curtain walls using the specified baseline option

8 To erase the lines, enter y (Yes). To have the lines remain after
the curtain wall unit is created, enter n (No).

Each enclosed area is assigned the default cell infill. The lines
between the cells are assigned the default mullion definition, and
the boundary around the grid is assigned the default frame
definition. For more information, see Assigning Definitions to
Curtain Wall Elements on page 1475 .

9 Select the resulting custom curtain wall unit.

10 Click Curtain Wall Unit tab ➤  Modify panel  ➤ Design Rules
drop-down ➤  Save To Style .

11 Click New to create a new curtain wall unit style.

12 Enter a name for the new curtain wall unit style.

13 Click OK twice.
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Curtain Wall Unit Styles
Curtain wall units are style-based, meaning there are preset characteristics
assigned to each curtain wall unit that determine its appearance and function.
By changing from one style of curtain wall unit to another, you can quickly
study several different design options. Any changes you make to the style are
reflected throughout your building, updating all curtain walls that use that
particular curtain wall unit style. You can also apply overrides to a single
curtain wall unit, without changing other curtain walls of the same style.

A curtain wall unit style controls the following properties of a curtain wall:

■ Element definitions

■ Definition assignments for each element

■ Materials for each element

■ Display properties for each element

■ Notes about the style and any associated reference files

To create, edit, copy, or purge styles, you access the Style Manager. The Style
Manager provides a central location in AutoCAD Architecture where you can
work with styles from multiple drawings and templates. For more information
about using the Style Manager, see Style Manager Overview on page 870 .

Creating Element Definitions for a Curtain Wall Unit Style
Element definitions determine the appearance of the four basic curtain wall
unit elements. There is a different definition type for each element.

Default definitionsElement type

Horizontal grid with two manual divisions
offset from the top and the bottom of the
grid

Divisions

Cells containing simple panelsCell Infills

Left, right, top, and bottom outer edges
of grid 3" wide and 3" deep

Frames

Edges between cells 1" wide and 3" deepMullions
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Each type of element can have multiple definitions. For example, you can
define a division to create a horizontal grid or a vertical grid, and you can
define the cells to contain a nested grid or a panel infill. To make reuse easier,
you can save the element definitions, and then assign them to grids, cells,
frames, or mullions as needed.

Element definitions are style-specific. When you create element definitions
for a specific curtain wall unit style, those definitions are available only for
curtain wall units of that style. For example, if you define a panel infill for
one curtain wall unit style, that infill is not available as an option when you
edit a curtain wall unit of a different style.

For information about defining the color, linetype, or layer of curtain wall
elements, see Specifying the Display of Curtain Wall Units on page 1633 .

Creating a Curtain Wall Unit Style
Use this procedure to create a curtain wall unit style. You can create a style
using default style properties or by copying an existing style. After you create
the style, you edit the style properties to customize the characteristics of the
style.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Create a new curtain wall style:

Then …If you want to create a style …

right-click Curtain Wall Unit Styles,
and click New.

with default properties

right-click the curtain wall unit style
you want to copy, and click Copy.
Right-click, and click Paste.

from an existing style

right-click Curtain Wall Unit Styles,
and click New. Right-click the new

from a curtain wall, curtain wall
unit, or door/window assembly in
the drawing style, click Set From, and then pick

a curtain wall, a curtain wall unit,
or a door/window assembly.
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4 Enter a name for the new curtain wall unit style, and press Enter.

5 Edit the new curtain wall unit style:

Then …If you want to …

see Defining Divisions for Curtain
Wall Unit Grids on page 1585 , Defin-

define the elements of a curtain wall
unit style

ing Infills for Curtain Wall Unit Cells
on page 1594 , Defining Curtain Wall
Unit Frames on page 1599 , and De-
fining Curtain Wall Unit Mullions
on page 1606 .

see Assigning a Division to a Cur-
tain Wall Unit Grid on page 1613 ,

assign element definitions to the
curtain wall unit style

Assigning Infills to Curtain Wall Unit
Cells on page 1614 , Assigning
Definitions to Curtain Wall Unit
Frames on page 1623 , and Assigning
Definitions to the Mullions of a
Curtain Wall Unit on page 1627 .

see Adding Curtain Wall Unit Ele-
ment Definitions as Display Com-
ponents on page 1634 .

add curtain wall element definitions
as display components

see Specifying the Layer, Color,
and Linetype of a Curtain Wall Unit
Style on page 1635 .

specify layer, color and linetype
settings for the display components
of a curtain wall

see Specifying the Hatching for
Components of a Curtain Wall Unit
Style on page 1635 .

specify curtain wall unit hatching

see Adding Custom Graphics as a
Display Component of a Curtain
Wall Unit on page 1637 .

add custom graphics as display
components of a curtain wall unit
style

see Creating Cut Planes for a Cur-
tain Wall Unit on page 1638 .

create individual cut planes for cur-
tain wall unit styles

see Attaching Notes and Files to a
Curtain Wall Unit Style on page 1640
.

add notes and files to the style
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6 Click OK.

Defining Divisions for Curtain Wall Unit Grids
The divisions of a grid define the orientation that determines the direction
of the grid cells and mullions, and they define a division type that determines
the number and size of cells.

NOTE  Creating a nested grid is not a division rule. To create a nested grid, add
a cell assignment. For more information, see Creating a Nested Grid in a Curtain
Wall Unit on page 1615  and Working with Nested Grids in Curtain Walls on page
1478 .

You can create a variety of division definitions under different names, and
then assign different divisions to each grid in your curtain wall unit. Although
you can create multiple definitions, there can be only one division assignment
per grid. You create division definitions for a specific curtain wall unit style
and those definitions can be assigned only to grids in curtain wall units of
that style.

For more information about assigning divisions to a particular grid, see
Assigning a Division to a Curtain Wall Unit Grid on page 1613 .

Division of Curtain Wall Unit Grids
A curtain wall unit consists of one or more grids, which are the framework
for placing design elements in the curtain wall unit. The highest-level grid is
the primary grid, which is also the outside edge of the curtain wall unit.

Each grid in a curtain wall unit has one division assignment that determines
whether the grid is divided horizontally or vertically. The division also
determines the number of cells, their size and their placement.

Within the primary grid, you can define multiple levels of grids. These grids
within are called nested grids. Each subdivision of a grid is called a cell.

Creating a Division Definition for a Curtain Wall Unit
Use this procedure to create divisions for a curtain wall unit grid.

Because curtain wall units can contain multiple nested grids, it is helpful to
use a naming convention for grids that indicates the level of each grid and
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the grid location or the purpose within the curtain wall unit. For example,
L3-FL1-Stone Panels can identify a third level grid that provides a row of stone
panels on Floor 1.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Click New Division.

7 Enter a name for this division definition.

8 Click either Horizontal or Vertical for Orientation.

9 Select one of the following division types and specify offsets if
needed.

DescriptionDivision Type

Creates a grid where the size of the
individual cells is predetermined.

Fixed Cell Dimension

For more information, see Specify-
ing a Fixed Size for Cells in a Cur-
tain Wall Unit Grid on page 1587 .

Creates a grid where the number
of grid cells is predetermined. For

Fixed Number of Cells

more information, see Specifying
a Fixed Number of Cells for a Cur-
tain Wall Unit Grid on page 1590 .

Creates a grid where the size and
number of individual cells is manu-

Manual

ally determined by the user. For
more information, see Manually
Defining the Number and Size of
Cells in a Curtain Wall Unit Grid on
page 1591 .

After you create a division definition, you can assign the definition
to a specific grid in a curtain wall unit. For more information, see
Assigning a Division to a Curtain Wall Unit Grid on page 1613 .
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10 When you are finished creating division definitions, click OK.

Specifying a Fixed Size for Cells in a Curtain Wall Unit Grid
Use this procedure to define a specific size for the cells in a grid. In this case,
the number of cells is determined by the length or height of the grid,
depending on how the grid is divided.

When you specify a fixed cell size in a grid, you can control how the cells of
the grid adjust to accommodate any leftover space. This space occurs if the
length (or the height) of the curtain wall unit cannot be evenly divided by
the fixed size of the cell. For more information, see Using the Auto-Adjust
Cells Option to Resize Cells in a Curtain Wall Unit Grid on page 1589 .

Specifying a fixed size for cells

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Division definition or create a new one.
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7 Select Fixed Cell Dimension for Division Type.

8 Specify a size for the cells in Cell Dimension.

If you are defining a vertical division, the cell dimension is the
length of the cell from mullion to mullion. If you are defining a
horizontal division, the cell dimension is the height of the cell.

9 To specify an offset for the grid, enter an offset distance in Start
Offset or End Offset. For more information, see Specifying an
Offset for a Curtain Wall Unit Grid on page 1592 .

TIP  The frame width is calculated as part of the cell size. Therefore,
cells adjacent to the frame can appear to be a different size than the
other cells. If you do not want the frame width included in the cell
size, specify an offset for the grid that is equal to the frame width.

When you draw a curtain wall unit using a fixed cell dimension,
there is often extra space between the last full-size cell and the
end of the curtain wall unit.

10 To adjust the cells and accommodate this extra space automatically
as you draw curtain wall units, select the Auto-Adjust Cells option.

11 Adjust the cells to accommodate this extra space:

Then …If you want to …

select Auto-Adjust Cells, select Grow
for Cell Adjustment, and select the

add the space to grid cells

specific cells where the space is ad-
ded. You can select any combina-
tion of specific cells.

select Auto-Adjust Cells, select
Shrink for Cell Adjustment, and se-

remove the space from grid cells

lect the specific cells where the
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Then …If you want to …

space is removed. You can select
any combination of specific cells.

For information about offsets, see Specifying an Offset for a
Curtain Wall Unit Grid on page 1592 .

12 Click OK.

For information about assigning the division definition to a specific grid in
your curtain wall unit, see Assigning a Division to a Curtain Wall Unit Grid
on page 1613 .

Using the Auto-Adjust Cells Option to Resize Cells in a Curtain
Wall Unit Grid

Use this procedure to automatically resize cells in a grid when the result of
dividing the grid by the specified cell dimension is not a whole number.

For example, if a vertical primary grid in a curtain wall unit style is 17 feet in
length and you specify a fixed cell dimension of 3 feet, the grid has five cells
of 3 feet each with 2 feet remaining. Using the Auto-Adjust Cells option, you
can specify how the grid distributes the remaining quantity.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Divisions definition or create a new one.

7 Select Fixed Cell Dimension as the division type.

8 Select Auto-Adjust Cells, and specify the cell adjustment:

Then …If you want to …

select Grow, and select the specific
cells to which you want the space
added.

add the remaining space to grid
cells
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Then …If you want to …

select Shrink, and select the specific
cells from which you want the

remove the remaining space from
grid cells

space removed. You can then select
Maintain at least half of cell dimen-
sion in order to control the cell
shrinkage.

The cells that you do not select maintain the fixed value you
specified for Cell Dimension.

Specifying a Fixed Number of Cells for a Curtain Wall Unit Grid
Use this procedure to define a specific number of cells in a grid. In this case,
the size of the cells is determined by the length or height of the grid, depending
on how the grid is divided.

In some cases, when you create a complex curtain wall unit grid, you might
want to start with a standard grid with a fixed number of cells, and then later
fine-tune that manually. You can first create a grid with fixed cell numbers
and then convert that to a manual grid. For information on manual grids, see
Manually Defining the Number and Size of Cells in a Curtain Wall Unit Grid
on page 1591 .

Specifying a fixed number of cells

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.
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5 In the left pane, select Divisions under Element Definitions.

6 Select a Division definition or create a new one.

7 Select Fixed Number of Cells for Division Type.

8 Specify the number of cells.

9 To specify an offset for the grid, enter an offset distance for Start
Offset or End Offset. For more information, see Specifying an
Offset for a Curtain Wall Unit Grid on page 1592 .

NOTE  If you want to fine-tune the initial layout with a fixed number
of cells, click Convert To Manual Division and edit the grid as
described in Manually Defining the Number and Size of Cells in a
Curtain Wall Unit Grid on page 1591 .

10 Click OK.

For information about assigning the division definition to a specific grid in
your curtain wall unit, see Assigning a Division to a Curtain Wall Unit Grid
on page 1613 .

Manually Defining the Number and Size of Cells in a Curtain
Wall Unit Grid

Use this procedure to manually add gridlines and specify an offset for each
one when you need to create a unique grid that does not fit into any of the
other division types. You can also start with a fixed cell dimension grid or a
fixed number of cells grid, and then manually adjust the grid lines to suit your
needs.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Division definition or create a new one.

7 Select Manual for Division Type.
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8 Click the Add Gridline icon to insert a grid line. Insert as many
grid lines as you need. If you need to remove a grid line, select it
from the table and click the Remove Gridline icon.

9 Under Offset in the gridline table, specify an offset distance for
each grid line.

Gridline offset

10 Under From in the grid line table, select the grid location from
which the grid line is offset.

Offset grid line from option

11 To specify an offset for the grid, enter an offset distance for Start
Offset or End Offset.

For more information, see Specifying an Offset for a Curtain Wall
Unit Grid on page 1592 .

12 Click OK.

For information about assigning the division definition to a
specific grid in your curtain wall, see Assigning a Division to a
Curtain Wall Unit Grid on page 1613 .

Specifying an Offset for a Curtain Wall Unit Grid
By default, grids cells are measured from the start and end points of the curtain
wall unit baseline. The width of the grid frame is not considered in calculating
the size of the cell. For example, if you draw a curtain wall unit with a 14'
baseline and a 1' frame on the left and right, and you specify a fixed number
of vertical cells, the cells do not appear equal in size. The first and last cells
appear smaller because they include the frame. To make the cells equal in size,
offset the start and end of the grid by the width of the frame.
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Specifying grid offset directions

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Division definition or create a new one.

7 Specify an offset for the grid:

Then …If you want to specify the dis-
tance between …

enter a value for Start Offset.the start point of the curtain wall
baseline and the start of the first cell
in a horizontal grid

enter a value for End Offset.the end point of the curtain wall
baseline and the end of the last cell
in a horizontal grid

enter a value for Bottom Offset.the floor line of the curtain wall and
the start of the first cell in a vertical
grid
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Then …If you want to specify the dis-
tance between …

enter a value for Top Offset.the roof line of the curtain wall and
the end of the top cell in a vertical
grid

8 Click OK.

Removing a Division Definition from a Curtain Wall Unit Style
Use this procedure to remove a division definition that you no longer need.
You cannot remove a division definition when it is currently assigned to a
grid. In addition, you cannot remove the default division definition, but you
can modify it.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Division definition that you want to remove.

7 Click Remove Division.

8 Click OK.

Defining Infills for Curtain Wall Unit Cells
An infill defines the contents of a curtain wall unit cell. A curtain wall unit
cell can have the default simple panel or contain a nested grid, an AEC
Polygon, door, window, or door/window assembly style. The object styles you
use in infills must exist in the current drawing to be added to an infill
definition. Panels typically represent glazing or other plain cladding, such as
stone or concrete. For more information, see Assigning Infills to Curtain Wall
Unit Cells on page 1614 .
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NOTE  Nested grids and no infill are options you select when assigning an infill
to cell. These options do not require infill definitions. For information, see Creating
a Nested Grid in a Curtain Wall Unit on page 1615  and Removing an Infill Definition
from a Curtain Wall Unit Style on page 1599 .

You can define as many infills as you need, and then use cell assignments to
specify the cells that use each infill. You can modify, a default infill that is
used for all unassigned cells.

NOTE  Create infill definitions for a specific curtain wall unit style. Those definitions
can be assigned only to grid cells in curtain wall units of that style.

Materials

Styles use the materials of the object style assigned to each panel. For example,
if you specify an infill to use the Standard door/window assembly style, the
materials of that infill are those designated in the door/window assembly
style. Simple panels need material assigned in the curtain wall style.

If you do not use materials to control the display properties of infills, you can
specify their display properties in the curtain wall unit style. The layer, color,
linetype, and other display properties of the default infill are applied to all
infills unless you create a custom display component for each infill definition.
You can then control the display of each infill definition independently. For
more information, see Specifying the Display of Curtain Wall Units on page
1633 .

Creating a Panel Infill for a Curtain Wall Unit
Use this procedure to create a simple panel infill to represent basic cladding
materials in the curtain wall, such as a stone wall panel, concrete panel, metal
panel, or glazing infill.

Because curtain wall units can contain multiple infills, it is helpful to use a
naming convention for panel infills that indicates the infill location or purpose
within the curtain wall unit. For example, L3-FL1- Stone Panel can identify a
stone panel in a third-level grid on Floor 1.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.
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4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.

6 Click New Infill.

7 Enter a descriptive name for the infill.

8 Specify an alignment for the infill.

For more information, see Specifying an Alignment for a Curtain
Wall Unit Infill on page 1596 .

9 Specify an offset for the infill.

For more information, see Specifying an Offset for a Curtain Wall
Unit Infill on page 1597 .

10 Specify a thickness for the panel.

Specifying infill panel thickness

11 Click OK.

After you create an infill definition, you can assign it to any cell in a curtain
wall unit grid. For more information, see Assigning Infills to Curtain Wall
Unit Cells on page 1614 .

Specifying an Alignment for a Curtain Wall Unit Infill
Use this procedure to align an infill so that it is centered with the baseline of
the curtain wall unit, in front of the baseline, or behind the baseline. In Plan
view, the front of a curtain wall unit (drawn from left to right) is below the
baseline and the back is above the baseline.

NOTE  To move the infill away from the baseline, see Specifying an Offset for a
Curtain Wall Unit Infill on page 1597 .
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Specifying infill alignments

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.

6 Select an infill, or create a new one.

7 Select an alignment: front, center, or back.

8 Click OK.

Specifying an Offset for a Curtain Wall Unit Infill
Use this procedure to specify an offset for a curtain wall unit infill. By default,
infills are centered on the curtain wall unit baseline. If your design requires
that the infill be aligned with frame edges or some other part of the curtain
wall unit, you can specify an offset for the infill.
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Specifying panel infill offsets

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.

6 Select an infill, or create a new one.

7 Enter an offset distance.

In Plan view, positive numbers offset the infill above the baseline
and negative numbers offset the infill below the baseline. The
offset is also affected by the selected alignment for the infill.

8 Click OK.
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Removing an Infill Definition from a Curtain Wall Unit Style
Use this procedure to delete an infill definition that you no longer need from
the Infills definitions list. You cannot remove an infill definition when it is
currently assigned to a cell. In addition, you cannot remove the default infill
definition, but you can modify it.

NOTE  For information about removing an infill from a cell, see Removing an
Infill from a Curtain Wall Unit Cell on page 1620 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.

6 Select the unneeded infill definition from the list.

7 Click Remove Infill.

8 Click OK.

Defining Curtain Wall Unit Frames
All curtain wall unit grids, including the primary grid, can have frame
definitions. The frame of the primary grid defines the outer edges of the curtain
wall unit. The overall frame size is determined by the length and height of
the primary curtain wall unit grid or a nested curtain wall unit grid. You can
define a frame by specifying a width and depth or by selecting a profile.
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Specifying default and profile-based frames

You create frame definitions for a specific curtain wall unit style. Those
definitions can be assigned only to frames in curtain wall units of that style.
You can create as many frame definitions as you want, and then assign the
definitions to the frames. If you have nested grids, each grid has its own frame.
There is a default frame definition that you can modify and assign as needed.
Unassigned frames are not displayed. For more information, see Assigning
Definitions to Curtain Wall Unit Frames on page 1623 .

TIP  You can copy a mullion definition and use it as a frame definition. Select the
mullion definition and drag it to Frames in the tree on the left side of the dialog
box.

Materials and Display Properties for Frames

If you do not use materials to control the display properties of frames, you
can specify their display properties in the curtain wall style. The layer, color,
linetype, and other display properties of the default frame are applied to all
frames unless you create a custom display component for each definition. You
can then control the display of each frame definition independently. For more
information, see Specifying the Display of Curtain Wall Units on page 1633 .
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Defining a Curtain Wall Unit Frame by Width and Depth
You can define a frame by specifying its width and depth. The overall frame
size is determined by the length and height of the curtain wall unit grid.

Specifying frame width and depth

Because curtain wall units can contain multiple nested grids with different
frames, it is helpful to use a naming convention for grid frames that indicates
the grid location or purpose within the curtain wall unit. For example, L3-FL1-
Metal Frame can identify a metal frame for a third-level grid on Floor 1.

TIP  To remove the frame edge and have the infill adjust to fill the space occupied
by the frame, create a frame definition with both width and depth set to zero.
Then, assign that definition to the frame edge that you want to remove. This is
necessary for the infill to be mitered as it would be for a butt-glazed condition.
For more information, see Removing a Frame Edge from a Curtain Wall Unit on
page 1624 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Frames under Element Definitions.

6 Click the New Frame icon to create a new frame definition.

7 Enter a descriptive name for the frame.

8 Specify a width and depth for the frame.

9 Specify any offsets.

For more information, see Specifying Offsets for a Curtain Wall
Unit Frame on page 1604 .
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10 Click OK.

After you create a frame definition, you can assign it to any frame in a curtain
wall unit. For more information, see Assigning Definitions to Curtain Wall
Unit Frames on page 1623 .

Creating a Profile for a Curtain Wall Unit Frame
Use this procedure to create a profile that you can use to define the shape of
a curtain wall unit frame. You can then extrude the profile to create a curtain
wall unit frame.

The height and the width of the polyline you use to create the profile define
the default height and width of the curtain wall unit frame. The insertion
point of the profile is aligned with the centroid of the frame.

1 Draw a closed polyline of the height and the depth needed for
the resulting curtain wall unit frame.

2 Select the polyline, right-click, and click Convert to ➤ Profile
Definition.

3 Enter c (Centroid) for the insertion point of the profile.

The insertion point of the profile is aligned with the centroid of
the frame.

4 Enter a name for the profile, and click OK.

You can now use the profile as a curtain wall frame. For more
information, see Defining a Curtain Wall Unit Frame Using a
Profile on page 1602 .

Defining a Curtain Wall Unit Frame Using a Profile
Use this procedure to create a frame element definition from a profile. If you
do not want a straight edge to your frame, you can use a profile to define
edges with curves, jags, or any other shape.
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Two profile-based frame examples

NOTE  The insertion point of the profile is aligned with the centroid of the frame.

1 Create the profile for the frame.

For information on creating profiles for curtain wall unit frames,
see Creating a Profile for a Curtain Wall Unit Frame on page 1602
.

2 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

3 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

4 Select a curtain wall unit style.

5 Click the Design Rules tab.

6 In the left pane, select Frames under Element Definitions.

7 Click New Frame.

8 Enter a descriptive name for the frame.

9 Specify a width and depth for the frame edge.

These dimensions are used to calculate the center point of the
edge for aligning the profile and also to specify a boundary for
the adjacent infill.

10 Select Use Profile.

NOTE  The Profile options are available only if you have profiles in
the current drawing.

11 Select a profile from the list.

By default, the profile is inserted using the same width and depth
with which it was created.
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12 To adjust the size of the profile to fit within the width or depth
dimension of the frame edge, select Auto-Adjust Profile Width or
Depth.

13 To mirror the profile, select X or Y for Mirror In.

14 To rotate the profile, specify an angle for Rotation.

15 Specify any offsets.

For more information, see Specifying Offsets for a Curtain Wall
Unit Frame on page 1604 .

16 Click OK.

After you create a frame definition, you can assign it to any frame in a curtain
wall unit. For more information, see Assigning Definitions to Curtain Wall
Unit Frames on page 1623 .

Specifying Offsets for a Curtain Wall Unit Frame
Use this procedure to define the distance that a curtain wall unit frame is from
the floor line, roof line, or baseline. By default, the outside edges of the frame
align with start and end of the floor line and the start and end of the roof
line. When you adjust the width of the frame, the frame expands inward.
However, you can use offsets to expand or contract the frame away from these
default limits or to shift the frame away from the baseline in either the X or
Y direction.

DescriptionOffset

Positive X offset moves the frame edge
outward beyond the end of the curtain wall

X

unit, while a negative X offset moves the
frame edge inward toward the center of
the curtain wall unit.

In Plan view, a positive Y offset moves the
frame edge above the baseline, while a

Y

negative Y offset moves the frame below
the baseline.

Negative Start offset lengthens the frame
beyond the start point, while a positive

Start

Start offset shortens the frame. The start
point for vertical edges is the baseline and,
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DescriptionOffset

for horizontal edges (drawn left to right),
it is the left side.

Negative End offset lengthens the frame
beyond the end point, while a positive End

End

offset shortens the frame. The end point
for vertical edges is the base height and,
for horizontal edges (drawn left to right),
it is the right side.

Specifying frame offsets

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Frames under Element Definitions.

6 Select a frame definition from the list.

7 Specify an offset distance for the frame edge X, Y, Start, or End.

8 Click OK.
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Removing a Frame Definition from a Curtain Wall Unit Style
Use this procedure to remove a frame definition from the Frame definitions
list. You cannot remove a frame definition if it is currently assigned to a frame
edge, but you can remove it if it is assigned as an override to a frame edge. In
addition, you cannot remove the default frame definition, but you can modify
it.

NOTE  For information about removing a frame edge, see Removing a Frame
Edge from a Curtain Wall Unit on page 1624 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Frames under Element Definitions.

6 Select the unneeded frame definition from the list.

7 Click the Remove Frame icon.

8 Click OK.

Defining Curtain Wall Unit Mullions
The mullions of a curtain wall unit are the edges between the grid cells. You
can define the mullions by specifying a width and depth or by selecting a
profile from which the mullion is extruded.

Because curtain wall units can contain multiple nested grids with different
mullions, it is helpful to use a naming convention for grid mullions that
indicates the grid location or purpose within the curtain wall unit. For example,
L3-FL1- Panel Decorative Mullion can identify a mullion for a panel in a
third-level grid on Floor 1.
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Specifying default and profile-based mullions

You create mullion definitions for a specific curtain wall unit style and those
definitions can be assigned only to mullions in curtain wall units of that style.
You can create as many mullion definitions as you want, and then assign the
definitions to mullions as needed. If you have nested grids, each grid has its
own mullions. There is a default mullion definition that you can modify as
needed that is used for any unassigned mullions. For more information, see
Assigning Definitions to the Mullions of a Curtain Wall Unit on page 1627 .

TIP  You can copy a frame definition and use it as a mullion definition. Select the
frame definition and drag it to Mullions in the left pane of the dialog box.

Materials and Display Properties for Mullions

If you do not use materials to control the display properties of mullions, you
can specify their display properties in the curtain wall unit style. The layer,
color, linetype, and other display properties of the default mullion are applied
to all mullions unless you create a custom display component for each
definition. You can then control the display of each mullion definition
independently. For more information, see Specifying the Display of Curtain
Wall Units on page 1633 .

Defining Curtain Wall Unit Mullions by Width and Depth
You can define mullions by specifying a width and a depth.
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Specifying mullion width and depth

TIP  To remove mullions for butt glazing, create a definition with both width and
depth set to zero. Then, assign that definition to the mullions that you want to
remove. For more information, see Removing Mullions from a Curtain Wall Unit
Grid on page 1629 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Mullions under Element Definitions.

6 Click New Mullion.

7 Enter a descriptive name for the mullion.

8 Specify a width and depth for the mullion.

9 Specify the offsets you want.

For more information, see Specifying Offsets for the Mullions of
a Curtain Wall Unit on page 1611 .

10 Click OK.

After you create a mullion definition, you can assign it to any mullion in a
curtain wall unit. For more information, see Assigning Definitions to the
Mullions of a Curtain Wall Unit on page 1627 .

Creating a Profile for Curtain Wall Unit Mullions
Use this procedure to create a profile that you can use to define the shape of
a curtain wall unit mullion definition. You can then extrude the profile to
create mullions from it.
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The height and the width of the polyline you use to create the profile define
the default height and width of the curtain wall unit mullion. The insertion
point of the profile is aligned with the centroid of the mullion.

1 Draw a closed polyline of the height and the depth needed for
the resulting curtain wall unit mullion.

2 Select the polyline, right-click, and click Convert to ➤ Profile
Definition.

3 Enter c (Centroid) for the insertion point of the profile.

The insertion point of the profile is aligned with the centroid of
the mullion.

4 Enter a name for the profile, and click OK.

You can now use the profile as a curtain wall unit mullion. For
more information, see Defining the Mullions of a Curtain Wall
Unit Using a Profile on page 1609 .

Defining the Mullions of a Curtain Wall Unit Using a Profile
Use this procedure to create a mullion element definition from a profile. If
you do not want a straight edge to your mullions, you can use a profile to
define mullions with curves, jags, or any other shape.

NOTE  The insertion point of the profile is aligned with the centroid of the mullion.

Infill alignments with default and profile-based mullions

1 Create the profile to use for the mullion.

For information, see Creating a Profile for Curtain Wall Unit
Mullions on page 1608 .
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2 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

3 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

4 Select a curtain wall unit style.

5 Click the Design Rules tab.

6 In the left pane, select Mullions under Element Definitions.

7 Click the New Mullion icon to create a new mullion definition.

8 Enter a descriptive name for the mullion.

9 Specify a width and depth for the mullion.

These dimensions are used to calculate the center point of the
mullion for aligning the profile and also to specify a boundary
for the adjacent infill.

10 Select Use Profile.

NOTE  The Profile options are available only if you have profiles in
the current drawing.

11 Select a profile from the list.

By default, the profile is inserted using the same width and depth
with which it was created.

12 To adjust the size of the profile to fit within the width or depth
dimension of the mullion, select Auto-Adjust Profile Width or
Depth.

13 To mirror the profile, select X or Y for Mirror In.

14 To rotate the profile, specify a rotation angle for Rotation.

15 Specify any offsets.

For more information, see Specifying Offsets for the Mullions of
a Curtain Wall Unit on page 1611 .

16 Click OK.

After you create a mullion definition, you can assign it to any mullion in a
curtain wall unit. For more information, see Assigning Definitions to the
Mullions of a Curtain Wall Unit on page 1627 .
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Specifying Offsets for the Mullions of a Curtain Wall Unit
Use this procedure to define mullions that are offset from the start or end of
the curtain wall unit to lengthen or shorten the edge or offset in the X or Y
direction to shift the edge. For example, you might want to represent butt
glazing by offsetting the mullions to be behind glass panel infills.

DescriptionOffset

For vertical mullions, a positive X offset
moves the mullions toward the end of the

X

curtain wall unit, while a negative X offset
moves the mullions toward the start of the
curtain wall unit. For horizontal mullions,
a positive X offset moves the mullions to-
ward the top of the curtain wall unit, while
a negative X offset moves the mullions to-
ward the bottom of the curtain wall unit.

In Plan view, a positive Y offset moves the
mullions above the baseline, while a negat-

Y

ive Y offset moves the mullions below the
baseline.

Negative Start offset lengthens the mullions
beyond the start point, while a positive
Start offset shortens the mullions.

Start

Negative End offset lengthens the mullions
beyond the end point, while a positive End
offset shortens the mullions.

End
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Specifying mullion offsets

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Mullions under Element Definitions.

6 Select a mullion definition from the list.

7 Specify an offset distance for the X, Y, Start, or End.

8 Click OK.

Removing a Mullion Definition from a Curtain Wall Unit Style
Use this procedure to remove a mullion definition from the Mullions
definitions list. You cannot remove a mullion definition if it is assigned to a
mullion. In addition, you cannot remove the default mullion definition, but
you can modify it as needed.

NOTE  For information about removing mullions from between cells, see Removing
Mullions from a Curtain Wall Unit Grid on page 1629 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.
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2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select Mullions under Element Definitions.

6 Select the unneeded mullion definition from the list.

7 Click the Remove Mullion icon to remove the mullion definition.

8 Click OK.

Assigning a Division to a Curtain Wall Unit Grid
Use this procedure to assign a division to a curtain wall unit grid. A division
defines the grid orientation (whether the direction of the grid cells and
mullions is horizontal or vertical) and the division type (number and size of
cells).

After you define a division, you can assign it to the primary grid or to nested
grids. Nested grids are created by selecting Nested Grid as the cell assignment.
For more information, see Working with Nested Grids in Curtain Walls on
page 1478 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select the grid you want to assign a division to.
The name of the grid you select is displayed in the table under
the Division Assignment row.

TIP  To rename a grid, select it, and click Rename, and enter a new
name.
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6 Click the Element column for that grid and select a division
definition from the list.

7 Click OK.

Assigning Infills to Curtain Wall Unit Cells
An infill defines the contents of a curtain wall unit cell. A curtain wall unit
cell can have the default simple panel or contain a nested grid, an AEC
Polygon, door, window, or door/window assembly style. The object styles you
use in infills must exist in the current drawing to be added to an infill
definition. Panels typically represent glazing or other plain cladding, such as
stone or concrete. For more information, see Defining Infills for Curtain Wall
Unit Cells on page 1594 .

Cell Assignments

A cell assignment defines the infill definition used for the cells. You can use
one cell assignment to assign the same infill to all cells, or you can create
multiple cell assignments to assign different infills to different cells.

Cell assignments

Do not assign multiple definitions to the same cell because only the last
definition assigned to the cell is used.

Default Cell Assignment

The default cell assignment is used by all unassigned cells. You can modify
the default assignment to be any type of infill, but you cannot delete the
default cell assignment.

You may want to modify the default cell assignment to use the infill definition
that occurs most frequently in your design. Any cells not assigned to other
infills then use this infill definition.

Materials and Display Properties of Infills

The layer, color, linetype, and other display properties of the default infill are
applied to all infills unless you assign materials to the infills you created or
you create a custom display component for each definition. You can then
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control the display of each infill definition independently. For more
information, see Specifying the Display of Curtain Wall Units on page 1633 .

Creating a Nested Grid in a Curtain Wall Unit
Use this procedure to create a nested grid in a curtain wall unit. A nested grid
is a grid within a grid. Each nested grid has its own division, cell assignments,
frame, and mullions. By default, the frame is turned off for nested grids.

For more information, see Working with Nested Grids in Curtain Walls on
page 1478 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to create a
nested grid.

6 Click the New Cell Assignment icon.

A new cell assignment is displayed in the list of cell assignments.

7 Click New Cell Assignment, and enter a descriptive name for the
assignment.

8 Select Nested Grid in the Element column.

A new grid is added to the list of grids in the tree view to the left
of the dialog box. If you are editing the primary grid, the new
grid is added at the secondary level. If you are editing a grid at
the secondary level, the additional grid is placed at the tertiary
level, and so on.

Creating a nested grid
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New nested grid in tree

NOTE  To rename a grid, select it in the right pane, right-click and
click Rename, and enter a new name.

9 Specify the cells to contain this nested grid.

For more information, see Specifying Which Curtain Wall Unit
Cells Use a Cell Assignment on page 1621 .

10 Click OK.

Inserting a Door, Window or Door/Window Assembly into a
Curtain Wall Unit Cell

Use this procedure to add doors, windows and door/window assemblies to a
curtain wall unit. For more information, see Defining Infills for Curtain Wall
Unit Cells on page 1594

1 Open the tool palette that you want to use, and select a door,
window or door/window assembly.

2 Select the curtain wall unit in which to insert the door, window
or door/window assembly.

You can move or hide the Properties palette to expose more of
the drawing area.

3 Select the curtain wall unit cell marker for the cell in which to
insert the door, window or door/window assembly.
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The Add Infill worksheet displays.

4 Select the insertion method for the door, window or door/window
assembly:

Then…If you want to…

select Add as Cell Assignment.add the door, window or
door/window assembly
as a cell assignment and
have all curtain wall units
using the same style dis-
play the same object ad-
ded in a corresponding
cell

select Add as Cell Override.add the door, window or
door/window assembly
exclusively to the selected
curtain wall unit

If a door, window or door/window assembly of the style you
selected already exists in your drawing, Existing Infill is selected
by default.

5 Select the type of infill for the door, window or door/window
assembly:

Then…If you selected…

Click OK.Add as Cell Assignment
and you want to insert a
door, window or
door/window assembly
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Then…If you selected…

of the existing style, Exist-
ing Infill is selected by
default.

select New Infill, enter a name for the object
and click OK.

Add as Cell Assignment
and you want to insert a
door, window or
door/window assembly
of a different style than
exists in your drawing

Click OK.Add as Cell Override and
you want to insert a
door, window or
door/window assembly
of the existing style and
not modify the edge of
the frame surrounding
the object

select New Infill, enter a name for the object
and click OK.

Add as Cell Override and
you want to insert a
door, window or
door/window assembly
of a different style than
exists in your drawing
and not remove an edge
of the frame surrounding
the object

select Top, Bottom, Left, or Right for Override
Frame Removal and click OK.

Add as Cell Override and
you want to insert a
door, window or
door/window assembly
of the existing style and
remove an edge of the
frame surrounding the
object
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Then…If you selected…

select New Infill and enter a name for the
object. Then select Top, Bottom, Left, or Right
for Override Frame Removal and click OK.

Add as Cell Override and
you want to insert a
door, window or
door/window assembly
of a different style than
exists in your drawing
and remove an edge of
the frame surrounding
the object

6 Press ENTER.

Filling a Curtain Wall Unit Cell with a Simple Panel
Use this procedure to fill a curtain wall unit cell with a simple panel. Simple
panels are generally used to represent basic cladding materials in the curtain
wall, such as a stone wall panel or a concrete panel.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to put a simple
panel infill.

6 Click the New Cell Assignment icon.

A new cell assignment is displayed in the list of cell assignments.

7 Click New Cell Assignment, and enter a descriptive name for the
assignment.

8 Under Element, select an infill that defines a simple panel.

If you do not have a simple panel infill defined, select New Infill
and define one. For more information, see Creating a Panel Infill
for a Curtain Wall Unit on page 1595 .

9 Specify the cells to contain this simple panel.
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For more information, see Specifying Which Curtain Wall Unit
Cells Use a Cell Assignment on page 1621 .

10 Click OK.

Removing an Infill from a Curtain Wall Unit Cell
Use this procedure to remove the infill of a cell and leave the cell empty. To
do this, use None as the element definition. Using None also removes any
frame edges that border the cell, but it does not affect the mullions.

Removing an infill assignment from a cell

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select the grid that contains the cells you want
to assign to None.

6 Create a new cell assignment or select an existing cell assignment.

7 Select None under the Element column.

8 Specify the cells to contain the None infill.

For more information, see Specifying Which Curtain Wall Unit
Cells Use a Cell Assignment on page 1621 .

9 Click OK.
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Specifying Which Curtain Wall Unit Cells Use a Cell Assignment
When you create a cell assignment you need to specify the cells in the grid to
use that assignment. There are two options for selecting cells:

■ Use Location to insert the infill into the start, middle, or end cells of a
vertical grid or into the bottom, middle, or top cells of a horizontal grid.
If there is an even number of cells (four or more), Middle refers to the two
cells in the middle of the grid. If there is an odd number of cells (three or
more), Middle refers to one cell in the middle of the grid.

Specifying cell assignments by location

■ Use Index to insert the infill into specific cells based on cell numbers. Cells
are numbered from start to end or bottom to top. For example, typing 1,
3, 5 would place the infill in the first, third, and fifth cells.

Specifying cell assignment by index

Any cells that are not assigned a specific cell assignment use the default infill.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.
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2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select a grid.

6 Under the Type column, select Location or Index.

7 Select a cell assignment:

Then …If you selected …

click the Used In column, and click
the button at the far right of the

Location

row. Select the cells you want to
use this assignment, and click OK.

enter the cell numbers separated
by commas in the Used In column.

Index

For vertical grids, cells are
numbered from start to end and for
horizontal grids, cells are numbered
from bottom to top.

NOTE  Do not assign multiple definitions to a cell because the last
definition assigned to the cell is used.

8 Click OK

Removing an Assignment from a Curtain Wall Unit Style
Use this procedure to remove cell assignments, frame assignments, and mullion
assignments from a curtain wall unit style. You cannot remove default
assignments, but you can modify them to suit your needs.

NOTE  Each grid requires one division assignment. Therefore, you cannot remove
the division assignment, although you can change the division element used for
the division assignment.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.
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3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select the grid from which you want to remove
an assignment.

6 Select a cell assignment, frame assignment, or a mullion
assignment.

7 Click the Remove Assignment icon.

8 Click OK twice.

Assigning Definitions to Curtain Wall Unit Frames
The curtain wall unit frame is represented by the outer edges of the primary
grid. Each nested grid has its own frame that is defined separately from the
primary grid frame. By default, the frames of nested grids are turned off. For
more information about nested grids, see Working with Nested Grids in
Curtain Walls on page 1478 .

Frame Assignments

A frame assignment defines the frame definition that is used by each frame
edge. You can use one frame assignment to assign the same definition to all
four edges of the frame, or you can create multiple frame assignments to assign
different definitions to different edges of the frame. Unassigned edges are not
displayed.

Do not assign multiple definitions to the frame edge because the last definition
assigned to the edge is used.

Default Frame Assignment

There is a default frame assignment, and you can select the frame edges it
applies to. You can modify the default assignment to use any frame definition,
but you cannot delete the default frame assignment.

Materials and Display Properties of Frames

The layer, color, linetype, and other display properties of the default frame
are applied to all frame edges unless you assign materials to the frame
definition or you create a custom display component for each definition. You
can then control the display of each frame definition independently. For more
information, see Specifying the Display of Curtain Wall Units on page 1633 .
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Adding a New Frame Assignment to a Curtain Wall Unit
Use this procedure to add a frame assignment to a curtain wall unit. To assign
different definitions to different frame edges, you need multiple frame
assignments.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to create a new
frame assignment.

6 Click the New Frame Assignment icon.

A new frame assignment is displayed in the list of frame
assignments.

New frame definition

7 Click New Frame Assignment and enter a descriptive name for
the assignment.

8 Select a frame definition from the Element column.

9 Specify the sides of the frame to use this frame assignment.

For more information, see Specifying Which Curtain Wall Unit
Edges Use a Frame Assignment on page 1625 .

10 Click OK.

Removing a Frame Edge from a Curtain Wall Unit
Use this procedure to remove a frame edge from a curtain wall unit. There are
three ways to remove a frame edge:

■ Set the width and depth of the edge to zero

■ Leave the edge unassigned
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■ Specify None as an override to the edge assignment

The first two methods remove the frame edge and expand the adjacent infills
into the space occupied by the edge.

Specifying a frame width and depth of zero

By specifying None as an override, the frame edge is not displayed, but the
adjacent infill is not expanded into the space the edge occupied.

Overriding a frame edge definition

For information about setting the width and depth to zero, see Defining a
Curtain Wall Unit Frame by Width and Depth on page 1601 .

For information about leaving the edge unassigned, see Specifying Which
Curtain Wall Unit Edges Use a Frame Assignment on page 1625 .

Specifying Which Curtain Wall Unit Edges Use a Frame
Assignment

Use this procedure to specify edges that use a frame assignment. When you
create a frame assignment, you need to specify the edges of the frame to use
that assignment.

Frame edges that are not assigned a frame definition are not displayed.
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1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select a grid.

6 Select a frame assignment.

Location is the only way to specify the frame edges.

7 Click the Used In column, and then click the [...] button at the
far right of the row.

Specifying frame location

8 Select the edges that you want to use this assignment - Left, Right,
Top, or -Bottom - and click OK.

Assigning frames to nested grids

Do not assign multiple definitions to the same frame edge because
only the last definition assigned to the edge is used.

9 Click OK.
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Assigning Definitions to the Mullions of a Curtain Wall Unit
The mullions of a curtain wall unit are the edges between the grid cells. The
primary grid and each nested grid have mullions that are defined separately
from the other grids. For more information about nested grids, see Working
with Nested Grids in Curtain Walls on page 1478.

Assign mullions to a nested grid

Mullion Assignments

A mullion assignment defines the definition used by each mullion. You can
use one assignment to define all mullions, or you can create multiple
assignments and assign different definitions to different mullions in any grid.

Do not assign multiple definitions to the same mullion because only the last
definition assigned to the mullion is used.

Default Mullion Assignment

There is a default mullion assignment used by all unassigned mullions. You
can modify the default assignment to be any mullion definition, but you
cannot delete the default mullion assignment.

Adding a New Mullion Assignment to a Curtain Wall Unit Style
Use this procedure to add a new mullion assignment to a curtain wall unit
style.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.
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4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to create a new
mullion assignment.

6 Click New Mullion Assignment.

A new mullion assignment is displayed in the list of mullion
assignments.

New mullion assignment

7 Select the mullion assignment, right-click and click Rename, and
then enter a descriptive name.

8 Select a mullion definition from the Element column.

9 Specify the mullions to use this assignment.

For more information, see Specifying Which Curtain Wall Unit
Mullions Use an Assignment on page 1628 .

10 Click OK.

Specifying Which Curtain Wall Unit Mullions Use an Assignment
When you create a mullion assignment you need to specify the mullions in
the grid to use that assignment. There are two options for selecting mullions: 

■ Use Location to assign a definition to the start, middle, or end mullions
of a vertical grid or the bottom, middle, or top mullions of a horizontal
grid. If there is an even number of mullions (four or more), Middle refers
to the two mullions in the middle of the grid. If there is an odd number
of mullions (three or more), Middle refers to the one mullion in the middle
of the grid.

■ Use Index to assign a definition to specific mullions based on mullion
numbers. Mullions are numbered from start to end or bottom to top. For
example, entering  1, 2, 3  would assign the definition to the first, second,
and third mullions.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.
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2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select a grid.

6 Create a new mullion assignment or select an existing assignment.

7 Select Location or Index for Type.

8 Select a cell assignment.

Then …If you selected …

click the Used In column, and click
the button at the far right of the

Location

row. Select the cells you want to
use this assignment, and click OK.

enter the mullion numbers separ-
ated by commas in the Used In

Index

column. For vertical grids, mullions
are numbered start to end and for
horizontal grids, mullions are
numbered from bottom to top.

NOTE  Do not assign multiple definitions to the same mullion because
only the last definition assigned to the mullion is used.

9 Click OK.

Any mullions that are not assigned a specific mullion assignment
use the default mullion definition.

Removing Mullions from a Curtain Wall Unit Grid
Use this procedure to remove a mullion from the curtain wall unit. You can
create a mullion definition whose edge width and depth are zero. Adjacent
infills expand to fill in the space that was occupied by the mullion. This is an
effective way to represent butt glazing.
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Removing mullions from a curtain wall unit grid

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to remove a
mullion.

6 Create a new mullion assignment and enter 0 (zero) for the width
and depth.

For more information, see Defining Curtain Wall Unit Mullions
by Width and Depth on page 1607 .

7 Under Mullion Assignments, select the mullion definition you
created for any cell edges of any mullion assignment where you
want to remove the mullions.

For more information, see Specifying Which Curtain Wall Unit
Mullions Use an Assignment on page 1628 .

8 Click OK.

Specifying the Materials of a Curtain Wall Unit Style
A curtain wall unit consists of a number of components whose display
properties can be determined by the materials assigned to each component.

When you assign materials to a curtain wall unit style, you assign one material
to each display component of the curtain wall unit. For example, you assign
a wood material to the frame and a glass material to the glass inset. You assign
materials to components in each display representation where you want the
materials to be used.
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If you want to use the display properties of the curtain wall unit style, instead
of using material display properties, you can turn off the material assignments
in the display properties of the curtain wall unit style.

Material definitions consist of display components that correspond to
component types of objects. For example, the Linework component of a
material is used for all linework in plan view. The Surface Hatch component
of a material is used to hatch all object surfaces in three dimensional (3D)
model views and in elevations.

Curtain Wall Unit Materials and Display Components
The following table identifies the material component that corresponds to
each curtain wall unit component in the specified views.

Material ComponentCurtain Wall Unit Component

Plan, Plan High Detail, Plan Low Detail,
Screened, Reflected Plan

LineworkFrame Definitions

LineworkMullion Definitions

LineworkInfill Definitions

LineworkFrame Definitions Hatch

LineworkMullion Definitions Hatch

LineworkInfill Definitions Hatch

Model

3D BodyFrame

3D BodyMullion

3D BodyInfill
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Assigning Materials to a Curtain Wall Unit Style
Use this procedure to assign materials to the individual components of a
curtain wall unit style. When you assign a material to a curtain wall unit
component, the component uses the display properties of the material instead
of the style display properties.

You can assign a material to any physical component of the curtain wall unit.
Custom components and components that are only symbolic graphics do not
use materials for their display properties. For example, the frame, mullion,
and infill are physical components of a curtain wall unit. The cell marker is
a symbolic component.

NOTE  If a material assignment does not determine the display properties of a
curtain wall unit component, you can change the display properties of the curtain
wall unit style as described in Specifying the Display of Curtain Wall Units on page
1633 .

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select By Material for any component to which you want to assign
a material, and click OK.

If the setting for By Material is not available, the display of this
component cannot be determined by a material.

9 Click the Materials tab.

10 Select the component you want to change, select the value for
Material Definition, and select a different material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.
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WARNING  Although you can edit a material definition from this
dialog box, any changes you make to the material definition apply
to all objects that are assigned the material.

11 Click OK.

Specifying the Display of Curtain Wall Units
The display of a curtain wall unit depends on the direction from which you
view the curtain wall unit. In Plan view, the curtain wall unit is displayed as
parallel lines with vertices marking the grid lines, as an architect would
typically draw a curtain wall unit. In 3D isometric views, the curtain wall unit
is displayed as it would appear in the real world, with surfaces showing length,
thickness, and height. You control what you want to display in each particular
view.

Element Definitions and Custom Display Components

By default, the display of all infills, frames, and mullions are controlled by
the display properties of the default infill, default frame, and default mullions.
However, you can add individual element definitions as components with
separate display properties. For example, if you define two infills called stone
panel and acetylene panel, by default they are both controlled by the same
default infill display properties. However, you can add each definition as a
new display component and control the display properties separately.

NOTE  The component name in the Custom Display Component dialog box must
match the name of element definition in the Design Rules tab. Otherwise the
element definition does not display properly.

For more information about the display system, see Display System on page
791 .

Materials and Display Properties

You can use materials to control the display of both default and custom infills,
frames, and mullions. When you assign materials to the element definitions
you create, you do not need to define these definitions as custom display
components. For more information, see Specifying the Materials of a Curtain
Wall Unit Style on page 1630 .
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Adding Curtain Wall Unit Element Definitions as Display
Components

Use this procedure to add curtain wall unit element definitions. Before you
can control the display properties of curtain wall unit elements according to
the definition assigned to the element, you must create display components
for each element definition.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select the curtain wall unit style that you want to change.

4 Click the Display Properties tab.

5 Select Model as the display representation.

6 Click  .

The default list of components includes only the three basic
elements and cell markers.

Default Model display components for curtain wall units

7 Click the Other tab, and then click Add.

8 Select Infill, Frame, or Mullion for Component Type.

9 Enter a name for Component Name, or click Select Element and
select an element from the list.

10 Click OK.

11 Click the Layer/Color/Linetype tab.

The element definition that you added is displayed in the list of
components.

12 Click the Other tab to continue adding element definitions, or
click OK twice.
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Specifying the Layer, Color, and Linetype of a Curtain Wall Unit
Style

Use this procedure to change the following display properties of the
components of a curtain wall unit style:

■ Visibility (component is on or off)

■ By Material

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select the curtain wall unit style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear.

6 Click Style Override.

7 Click the Layer/Color/Linetype tab.

8 Select the component to change, and select a different setting for
the property.

9 Click OK twice.

Specifying the Hatching for Components of a Curtain Wall Unit
Style

Use this procedure to specify the hatching of the components of a curtain
wall unit style. Curtain wall hatching is displayed only in display

Specifying the Display of Curtain Wall Units  | 1635



representations, such as Plan, that are used in Top view (Plan view) of a
drawing.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select the curtain wall unit style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and click Style Override.

6 Click the Hatching tab.

7 Select a component, and click the setting for Pattern.

8 Specify the hatching for the component:

Then …If you want to select …

select Predefined for Type, and then
select a pattern.

a hatching pattern that is available
in the software

select Custom for Type, and then
enter the name of the custom pat-

a custom pattern

tern. If necessary, click Browse, and
navigate to the folder where the
custom pattern file is located.

select User-defined for Type, and
clear Double Hatch.

single hatching

select User-defined for Type, and
select Double Hatch.

double hatching

select Solid Fill for Type.solid fill

9 Click OK.

10 Click the setting for Scale/Spacing, and enter a value that
determines how the selected pattern is repeated.

11 Click the setting for Angle, and enter the angle for the selected
pattern.
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12 Click the setting for Orientation, and specify how the hatching
is oriented:

Then …If you want to orient the
hatching …

select Object.to the object, regardless of the ob-
ject rotation

select Global.to the World Coordinate System

13 Click OK twice.

Adding Custom Graphics as a Display Component of a Curtain
Wall Unit

There may be instances where an infill, frame, or mullion requires a custom
two-dimensional (2D) or three-dimensional (3D) graphic. For example, you
might need a highly detailed three-dimensional truss as the mullions or a
decorative light fixture applied to an infill. In cases like these, you can create
a custom block, add a display component with the block attached, and
associate that component with an element definition. When you assign that
definition to an element, the block is also displayed.

1 Draw your custom component and save it as a block.

2 Select a curtain wall unit, right-click, and click Edit Curtain Wall
Unit Style.

3 Click the Display Properties tab.

4 Click  .

5 Click the Custom Plan Components tab.

If Model is the current display representation, the tab is called
Other.

6 Click Add.

7 Select Infill, Frame, or Mullion for Component Type.

8 Select the specific element from the list.

9 Select Draw Custom Graphics.
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10 Specify the display of the component:

Then …If you want to …

select Replace Graphics.display the block instead of the as-
sociated curtain wall unit element

clear Replace Graphics.superimpose the block over the
curtain wall unit element so that
both are displayed

11 Click Select Block, and select the custom block that you created.

12 Click OK.

13 Specify further settings for the custom display block:

Then …If you want to …

select Width, Height, or Depth. To
prevent the block from losing its
proportions, select Lock XY Ratio.

scale the block to fit a particular di-
mension

specify an insertion point on the X,
Y, and Z planes.

specify how the block is inserted
into the grid in the X, Y, and Z dir-
ections

determine if it should mirror in the
X, Y, or Z direction.

mirror the block

specify the offset in the X, Y, or Z
direction.

offset the block from the grid

14 Click OK three times.

Creating Cut Planes for a Curtain Wall Unit
Use this procedure to specify the properties of one or more cut planes for a
curtain wall unit style. Cut plane display properties apply only to display
representations, such as Plan, that are used in Top view (Plan view) of a
drawing.

To better visualize the elements of a curtain wall unit in Plan view, you can
create cut planes. The main cut plane is where the shrinkwrap and hatching
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are applied. The plan display shows the components and objects in the wall
as they are displayed at the height of each cut plane.

1 Select a curtain wall unit.

2 Click  Curtain Wall Unit tab  ➤ General panel ➤  Edit Style

drop-down  ➤ Edit Style  .

3 Click the Display Properties tab.

4 Select Plan, and click  .

NOTE  The Cut Plane tab is displayed only in some display
representations, such as Plan.

5 Click the Cut Plane tab to set the cut plane to be displayed in
each display representation for the curtain wall unit style.

6 Enter a value for Cut Plane Height to specify the cut plane at
which hatching takes effect.

7 To specifically define a cut plane, click Add, and enter the height
of the new cut plane:

Then …If you add a cut plane …

objects are displayed using the
properties specified for the Below

at a height that is lower than the
value for Cut Plane Height

Cut Plane component on the Lay-
er/Color/Linetype tab.

objects are displayed using the
properties specified for the Above

at a height that is higher than the
value for Cut Plane Height

Cut Plane component on the Lay-
er/Color/Linetype tab.

Below and Above components

You can click Remove to delete a cut plane that you added.

8 Click OK to exit all dialog boxes.
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Defining a Curtain Wall Unit Style as Bounding for Associative
Spaces

Use this procedure to define a curtain wall unit style that can bound associative
spaces.

When a curtain wall unit style is set as bounding, by default all curtain wall
units that have the style assigned will be used in the selection set for an
associative space. For more information about associative spaces see Generating
Associative Spaces on page 2940 .

You can override the bounding settings from the curtain wall unit style in an
individual curtain wall unit, if necessary.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select a curtain wall unit style.

4 Click the General tab.

5 Select the checkbox for Objects of this style may act as a boundary
for associative spaces.

6 Click OK.

Attaching Notes and Files to a Curtain Wall Unit Style
Use this procedure to enter notes and attach reference files to a curtain wall
unit style. You can also edit notes and edit or detach reference files from a
curtain wall unit style.

1 Click  Manage tab  ➤ Style & Display panel ➤  Style Manager 
.

2 Expand Architectural Objects, and expand Curtain Wall Unit
Styles.

3 Select the curtain wall unit style you want to change.

4 Click the General tab.

5 To add a description to the curtain wall unit style, enter the
description for Description.

6 Click Notes.

1640 | Chapter 22   Curtain Walls



7 To add a note, click the Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then …If you want to …

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

9 Click OK twice.

Using Overrides in Curtain Wall Units
Curtain wall units are subunits of geometrically complex curtain walls, which
often have a large number of different elements, like frames, panels, and infills.
Most of these settings are defined in the style. However, there are cases when
modifying a curtain wall unit directly on screen is more suitable:

■ You want to add custom frame or mullion edges to a curtain wall unit and
need direct visual feedback.

■ You want to create an override, like a merged infill or nested grid, in only
one specific place in the curtain wall unit.

■ You want to experiment with different visuals without having to change
the curtain wall unit style for each idea immediately.

When you have finished your onscreen edits, you can decide if you want to

■ Apply the overrides to the curtain wall unit you have edited.

■ Save the overrides to the current curtain wall unit style.

■ Create a new style for the overrides.
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Overrides you can set include assigning a different definition to a selected
cell, frame, or mullion, and assigning a profile to a frame or mullion edge.
Note that the definition or profile must already exist in the current drawing
before you can use it as an override.

Overrides do not affect the Design Rules for the curtain wall unit style.
However, you can transfer overrides to a curtain wall unit style if you want
all curtain wall units of that style to have the same overrides.

You can view a list of overrides that are currently assigned to a curtain wall
unit from the Overrides tab of the Curtain Wall Unit Properties dialog box.
For more information, see Removing Curtain Wall Unit Overrides on page
1670 .

NOTE  Overrides are also listed on the Overrides tab in the Curtain Wall Unit Style
Properties dialog box.

Overriding Curtain Wall Unit Infills
The cell infills of a curtain wall unit are set in the curtain wall unit style. You
can however, create overrides for these infill overrides in cells. For example,
you might want a row of normal rectangular panel infills for a first floor facade.
In one specific position, however, you want a decorative nested grid. In this
case, you would set the row of concrete panels in the curtain wall unit style,
and then override the panel at one specific place with the nested grid.

Curtain wall unit infills can consist of simple panels or nested grids. You can
change one infill for another, merge cells, or remove frames from an infill
altogether.

Turning on Cell Markers for Curtain Wall Units
Use this procedure to turn on the cell markers for each grid cell in a curtain
wall unit. The cell markers must be on in order to select individual cells and
make changes to them.
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Viewing Cell Markers

1 Select the curtain wall unit for which you want to create an infill
override.

2 Click Curtain Unit Wall tab ➤  Modify panel  ➤  Show Infill

Markers  .

Merging Curtain Wall Unit Cells
Use this procedure to merge two curtain wall unit cells.

NOTE  To merge curtain wall unit cells, the cell markers need to be visible. For
information on turning on cell markers, see Turning on Cell Markers for Curtain
Wall Units on page 1642 .

You can only merge cells that are adjacent to each other.

In most cases, you merge cells with the same infill type. The merged cell is
then of the same type as the original cells. For example, if you merge two solid
panel infills, the resulting merged cell also has a solid panel infill. In some
cases, however, you might want to merge two cells that have different infill
types. In that case, the infill type of the first selected cell is used for the merged
cell. For example, if you want to merge a cell with a simple panel infill and a
cell with a nested grid, and you select the cell with the simple panel first during
the merge command, the merged cell contains a simple panel infill, and not
a nested grid. If you select the two cells in the opposite order, the merged cell
contains a nested grid and no simple panel infill.

Overriding Curtain Wall Unit Infills  | 1643



Merging two cells

1 Select the curtain wall unit on which you want to merge two cells.

2 Click Curtain Wall Unit tab ➤  Modify panel  ➤ Infill
drop-down ➤ Merge.

3 Select the first cell to be merged.

4 Select the second cell to be merged.

The cells are merged into one.

5 Specify where you want to save the curtain wall unit override.

Then …If you want to save the over-
ride …

no further steps are necessary. The
override is saved to the curtain wall

only on this specific curtain wall
unit

unit. For information about how to
remove an override from a curtain
wall unit, see Removing Curtain
Wall Unit Overrides on page 1670 .

click Curtain Wall Unit

tab ➤ Modify panel ➤  Design

to a curtain wall unit style

Rules drop-down  ➤ Transfer To
Object.

1644 | Chapter 22   Curtain Walls



6 If you have chosen to save the override to a curtain wall unit style,
click Curtain Wall Unit tab ➤  Modify panel  ➤ Design Rules
drop-down ➤  Save To Style , and decide to which curtain wall
unit style you want to save the override.

Then …If you want to save the over-
ride …

select Transfer Merge Operations
to Style, and click OK.

NOTE  If you have created only
a cell merge, only the Transfer
Merge Operations to Style
checkbox is active. If you have
also created other overrides,
such as a new cell assignment
or a frame or mullion edge
override, these checkboxes are
available as well. If you also
want to save these overrides to
the style, select their check-
boxes too.

to the current curtain wall unit style

select Transfer Merge Operations
to Style, and click New. Enter a

to a new curtain wall unit style

name for the new curtain wall unit
style, and click OK.

NOTE  If you have created only
a cell merge, only the Transfer
Merge Operations to Style
checkbox is active. If you have
also created other overrides,
such as a new cell assignment
or a frame or mullion edge
override, these checkboxes are
available as well. If you also
want to save these overrides to
the style, select their check-
boxes too.
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NOTE  If you do not want to save the override back to a style at all,
click  Curtain Wall Unit tab  ➤ Modify panel ➤  Design Rules
drop-down  ➤  Revert To Style Design Rules . The overrides still remain
on the curtain wall unit, where they can be removed as described in
Creating a Curtain Wall Unit Infill Override on page 1646 , but they are
not saved back to a curtain wall unit style.

Creating a Curtain Wall Unit Infill Override
Use this procedure to override the infill of a curtain wall unit cell.

For example, you might have a row of simple concrete panels in your curtain
wall unit, but want in one location a nested grid instead of the concrete panel.
In that case, it might be simpler to use an infill override, instead of creating
a complex curtain wall unit style setting.

NOTE  To override an infill assignment, the cell markers need to be visible. For
information on turning on cell markers, see Turning on Cell Markers for Curtain
Wall Units on page 1642 .

To exchange an infill definition, the new infill definition must already be
defined in the curtain wall unit style. For information on creating infill
definitions, see Defining Infills for Curtain Wall Unit Cells on page 1594 .

Overriding a curtain wall unit cell definition

1 Select the curtain wall unit on which you want to override an
infill.

2 Click Curtain Wall Unit tab ➤  Modify panel  ➤ Infill
drop-down ➤  Override Assignment .
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3 Select the marker of the cell where you want to create an override.

4 Create the override:

Then …If you want to …

select a new infill definition from
the list.

NOTE  To exchange an infill
definition, the new infill defini-
tion must already be defined in
the curtain wall unit style.

exchange the existing infill for an-
other

select the frame component to be
removed.

remove one or more of the frames
around the infill

select Remove Infill and Frames.

NOTE  This works only for infills
that are bordering the exterior
of the curtain wall unit.

remove the complete infill and its
frame

5 Click OK.

6 Specify where you want to save the curtain wall unit override.

Then …If you want to save the over-
ride …

no further steps are necessary. The
override is saved to the curtain wall

only on this specific curtain wall
unit

unit. For information about how to
remove an override from a curtain
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Then …If you want to save the over-
ride …

wall unit, see Removing Curtain
Wall Unit Overrides on page 1670 .

click Curtain Wall Unit

tab ➤ Modify panel ➤  Design

to a curtain wall unit style

Rules drop-down  ➤ Transfer To
Object.

7 If you have chosen to save the override to a curtain wall unit style,
click Curtain Wall Unit tab ➤  Modify panel  ➤ Design Rules
drop-down ➤  Save To Style , and decide to which curtain wall
unit style you want to save the override.

Then …If you want to save the over-
ride …

select Transfer Cell Overrides to
Style, and click OK.

NOTE  If you have created only
an infill override, only the
Transfer Cell Overrides to Style
checkbox is active. If you have
also created other overrides,
such as a cell merge or a frame
or mullion edge override, these
checkboxes are available as
well. If you also want to save
these overrides to the style, se-
lect their checkboxes too.

to the current curtain wall unit style

select Transfer Cell Overrides to
Style, and click New. Enter a name

to a new curtain wall unit style

for the new curtain wall unit style,
and click OK.
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Then …If you want to save the over-
ride …

NOTE  If you have created only
an infill override, only the
Transfer Cell Overrides to Style
checkbox is active. If you have
also created other overrides,
such as a cell merge or a frame
or mullion edge override, these
checkboxes are available as
well. If you also want to save
these overrides to the style, se-
lect their checkboxes too.

NOTE  If you do not want to save the override back to a style at all,
click  Curtain Wall Unit tab  ➤ Modify panel ➤  Design Rules
drop-down  ➤  Revert To Style Design Rules .The overrides still remain
on the curtain wall unit, where they can be removed as described in
Removing Curtain Wall Unit Overrides on page 1670 , but they are not
saved back to a curtain wall unit style.

In-Place Editing of Curtain Wall Unit Cells
Use this procedure to edit curtain wall unit cells using in-place editing with
the Edit Grid grip. With in-place editing, you can edit individual cells, bays,
columns, or nested grids of the curtain wall unit directly and interactively in
the drawing area, and later save the changes to the curtain wall unit or curtain
wall unit style.

1 Select a curtain wall unit on which you want to edit cells with
in-place editing.

2 Specify the mode in which to edit the curtain wall unit:

Then …If you want to edit …

click Curtain Wall Unit

tab ➤ Modify panel ➤  Design

this instance of the curtain wall unit

Rules drop-down  ➤ Transfer To
Object.
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Then …If you want to edit …

click Curtain Wall Unit

tab ➤ Modify panel ➤  Design

the curtain wall unit style

Rules drop-down  ➤  Revert To
Style Design Rules . If this option is
not available, the design rules are
already style-based for the curtain
wall unit.

3 Click the Edit Grid grip.

4 Enter c (Cell) and press ENTER.

NOTE  You have entered the in-place editing session now. You can
see this from the faded color of all objects in the drawing, as well as
from the different grips at your disposal. Note that while you are in
the in-place editing session, you have only limited editing access to
other commands in the drawing. Before working on other objects,
you should first end the in-place editing session.

5 Select the individual cells, bay, column, or nested grid to modify
the cell assignment by hovering over a cell or pressing TAB, and
press ENTER.

Press CTRL to select multiple cells, bays, columns or nested grids.

The Edit Cells worksheet displays.
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6 Edit the cell for the selected grid:

Then…If you want to…

select Assign Infill and select an infill defini-
tion. Clear Replace Cell and click OK.

assign an infill to selected
cells

select Assign Infill and select an infill defini-
tion. Select Replace Cell and click OK.

replace the selected cells
with a new infill

click  and specify values on the Design
Rules worksheet.
For more information, see Assigning Infills to
Curtain Wall Unit Cells on page 1614 .

create and assign a new
infill to the selected cells

select Subdivision.divide the selected cells
with divisions, infills or
frames

select a division definition.select a division for the
subdivided cells

click  and specify values on the Design
Rules worksheet.
For more information, see Assigning a Divi-
sion to a Curtain Wall Unit Grid on page 1613
.

create and assign a new
division to the selected
cells

select an infill definition.select an infill for the
subdivided cells

click  and specify values on the Design
Rules worksheet.
For more information, see Assigning Infills to
Curtain Wall Unit Cells on page 1614 .

create and assign a new
infill to the subdivided
cells

select the frame definition and click OK.select a frame definition
for the grid created after
the cell is subdivided

select Top, Bottom, Left, Right for Frame
Location and click OK.

specify the location of
frames on the grid cre-
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Then…If you want to…

ated after the cell is sub-
divided

click  and specify values on the Design
Rules worksheet.
For more information, see Adding a New
Frame Assignment to a Curtain Wall Unit on
page 1624 .

create and assign a new
frame definition for the
new grid created after
the cell is subdivided

select the mullion definition.select a mullion definition
for the grid created after
the cell is subdivided

click  and specify values on the Design
Rules worksheet.
For more information, see Adding a New
Mullion Assignment to a Curtain Wall Unit
Style on page 1627 .

create and assign a new
mullion definition to the
selected grid

select Replace Cell.replace the existing cell
infill with the options se-
lected on this worksheet

select Continue Grid Editing.continue in-place editing
the grid after the cell is
subdivided

7 Click OK.

8 Press ENTER.

Overriding Curtain Wall Unit Frames and Mullions
You can change a selected frame edge or mullion edge by using an edge
assignment override.

NOTE  To exchange a frame edge or mullion edge, the new edge definition must
already be defined in the curtain wall unit style.
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Removing the edge does not affect the width of the cell. To remove the edge
and have the adjacent cell resize, create an edge definition with a width and
depth of zero. For more information, see Defining a Curtain Wall Unit Frame
by Width and Depth on page 1601  or Defining Curtain Wall Unit Mullions by
Width and Depth on page 1607 .

You can also create a new edge profile by drawing a polyline or using an
existing profile in the drawing. This edge profile can be interactively edited
onscreen using in-place editing.

Creating a Curtain Wall Unit Frame or Mullion Override
Use this procedure to override an individual frame or mullion in a curtain
wall unit.

To exchange a frame or mullion, the new definition must already be defined
in the curtain wall unit style. For information on creating frames and mullions,
see Defining Curtain Wall Unit Frames on page 1599  and Defining Curtain
Wall Unit Mullions on page 1606 .

1 Select the curtain wall unit on which you want to override an
edge.

2 Click Curtain Wall Unit tab ➤  Modify panel  ➤ Frame/Mullion
drop-down ➤  Override Assignment .

3 Select the frame or mullion edge you want to override.
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4 Create the override:

Then …If you want to …

select a new edge definition from
the list.

NOTE  To exchange an edge
definition, the new edge defini-
tion must already be defined in
the curtain wall unit style.

exchange the existing edge for an-
other

select Remove Edge.remove the frame or mullion edge

5 Click OK.

6 Specify where you want to save the curtain wall unit override.

Then …If you want to save the over-
ride …

no further steps are necessary. The
override is saved to the curtain wall

only on this specific curtain wall
unit

unit. For information about how to
remove an override from a curtain
wall unit, see Removing Curtain
Wall Unit Overrides on page 1670 .

click Curtain Wall Unit

tab ➤ Modify panel ➤  Design

to a curtain wall unit style

Rules drop-down  ➤ Transfer To
Object.

7 If you have chosen to save the override to a curtain wall unit style,
click Curtain Wall Unit tab ➤  Modify panel  ➤ Design Rules
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drop-down ➤  Save To Style , and decide to which curtain wall
unit style you want to save the override.

Then …If you want to save the over-
ride …

select Transfer Edge Overrides to
Style, and click OK.

NOTE  If you have created only
a frame or mullion edge over-
ride, only the Transfer Edge
Overrides to Style checkbox is
active. If you have also created
other overrides, such as a cell
merge or a division override,
these checkboxes are available
as well. If you also want to save
these overrides to the style, se-
lect their checkboxes too.

to the current curtain wall unit style

select Transfer Edge Overrides to
Style, and click New. Then, enter a

to a new curtain wall unit style

name for the new curtain wall unit
style, and click OK.

NOTE  If you have created only
a frame or mullion edge over-
ride, only the Transfer Edge
Overrides to Style checkbox is
active. If you have also created
other overrides, such as a cell
merge or a division override,
these checkboxes are available
as well. If you also want to save
these overrides to the style, se-
lect their checkboxes too.
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NOTE  If you do not want to save the override back to a style at all,
click  Curtain Wall Unit tab  ➤ Modify panel ➤  Design Rules
drop-down  ➤  Revert To Style Design Rules . The overrides still remain
on the curtain wall unit, where they can be removed as described in
Removing Curtain Wall Unit Overrides on page 1670 , but they are not
saved back to a curtain wall unit style.

Creating a Curtain Wall Unit Frame or Mullion Edge from a
Polyline or Profile

You can assign a profile to any vertical edge of a frame or mullion. The profile
can be any profile or any closed polyline that you specify. You can use a profile
edge to create a unique corner in situations where a simple miter is not
sufficient.

NOTE  Adjacent infills are not trimmed or expanded to accommodate the new
edge. To adjust the infill, change the width of the frame edge. For more
information, see Defining a Curtain Wall Unit Frame by Width and Depth on page
1601 .

Overriding edge profile

1 Draw a closed polyline in the location where you want it to display
in the curtain wall unit.

NOTE  For best results, it is recommended that you draw the polyline
in Plan view.

2 Select the curtain wall unit for which you want to create a frame
or mullion edge profile override.

3 Click Curtain Wall Unit tab ➤  Modify panel  ➤ Frame/Mullion
drop-down ➤  Add Profile .

1656 | Chapter 22   Curtain Walls



4 Select a vertical frame or mullion edge.

5 Select a profile for the override:

Then …If you want to create the edge
profile …

select it in the drawing, and enter
a name for it. Click OK.

from the polyline drawn in step 1

press Enter, select the profile, and
click OK.

from an existing profile in the
drawing

6 Specify where you want to save the curtain wall unit override.

Then …If you want to save the over-
ride …

no further steps are necessary. The
override is saved to the curtain wall

only on this specific curtain wall
unit

unit. For information about how to
remove an override from a curtain
wall unit, see Removing Curtain
Wall Unit Overrides on page 1670 .

click Curtain Wall Unit

tab ➤ Modify panel ➤  Design

to a curtain wall unit style

Rules drop-down  ➤ Transfer To
Object.

7 If you have chosen to save the override to a curtain wall unit style,
click Curtain Wall Unit tab ➤  Modify panel  ➤ Design Rules
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drop-down ➤  Save To Style , and decide to which curtain wall
unit style you want to save the override.

Then …If you want to …

select Transfer Edge Profile Over-
rides to Style, and click OK.

NOTE  If you have created only
a profile edge override, only the
Transfer Edge Profile Overrides
to Style checkbox is active. If
you have also created other
overrides, such as a cell merge
or a division override, these
checkboxes are available as
well. If you also want to save
these overrides to the style, se-
lect their checkboxes too.

to the current curtain wall unit style

select Transfer Edge Overrides to
Style, and click New. Enter a name

to a new curtain wall unit style

for the new curtain wall unit style,
and click OK.

NOTE  If you have created only
a profile edge override, only the
Transfer Edge Profile Overrides
to Style checkbox is active. If
you have also created other
overrides, such as a cell merge
or a division override, these
checkboxes are available as
well. If you also want to save
these overrides to the style, se-
lect their checkboxes too.
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NOTE  If you do not want to save the override back to a style at all,
click  Curtain Wall tab  ➤ Modify panel ➤  Design Rules drop-down
 ➤  Revert To Style Design Rules .The overrides still remain on the
curtain wall unit, where they can be removed as described in
Removing Curtain Wall Unit Overrides on page 1670 , but they are not
saved back to a curtain wall unit style.

In-Place Editing of Edge Profiles for Curtain Wall Units
Use this procedure to edit profile edges with in-place editing. With in-place
editing, you can use edge grips to edit the profile directly and interactively
on screen, and later save the changes to the profile definition.

1 Select a curtain wall unit that has the edge profile you want to
edit onscreen with in-place editing.

2 Click Curtain Wall Unit tab ➤  Modify panel  ➤ Frame/Mullion
drop-down ➤  Edit Profile .

This command is only available if you have profile-based edges
in the curtain wall unit.

NOTE  If the profile is not drawn to size, it must be converted in
order for you to begin the in-place editing session. Click Yes if
prompted to convert the profile to its actual size.

3 Select the edge you want to edit.

NOTE  You have entered the in-place editing session now. You can
see this from the magenta colored grips and light blue hatch of the
temporary in-place editing profile, as well as the faded color of all
other objects in the drawing. Note that while you are in the in-place
editing session, you have only limited editing access to other
commands in the drawing. Before working on other objects, you
should first end the in-place editing session.

4 Edit the profile:

Then …If you want to …

move the grips as needed.
The Edge grip has three edit modes:
Offset, Add Vertex, and Convert to

use grips to edit the profile

Arc. The default mode is Offset,
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Then …If you want to …

which offsets the selected edge in
a direction that is perpendicular to
the midpoint of the edge. Depend-
ing on the shape of the profile and
the edge you choose to modify,
neighboring lines are extended or
trimmed, and new lines are added,
as necessary.
Use the Add Vertex edit mode to
add a vertex to the selected edge,
and create a new edge. If the selec-
ted edge is an arc, the new edge is
an arc, as well.
Convert to Arc changes the selected
edge to an arc and stretches the
midpoint of the edge. The edge
grip for an arc also has a Stretch
mode, so that you can stretch the
midpoint of the edge after it has
been converted to an arc.

select an Edge grip, and press CTRL
to switch to the Add Vertex edit

add a vertex to the profile

mode. Move the edge to the de-
sired location and click, or enter a
value and press ENTER.
Alternatively, you can click Edit In

Place tab ➤ Profile panel ➤  Add

Vertex  .

select the Vertex grip for the vertex
you want to remove, and press

remove a vertex from the profile

CTRL to switch to the Remove edit
mode. Move the cursor off the se-
lected vertex, and click.
Alternatively you can click Edit In

Place tab  ➤ Profile panel ➤  Re-

move Vertex  .
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Then …If you want to …

click Edit In Place tab ➤ Profile

panel ➤  Add Ring  . Select a

add a ring to the profile

closed polyline, spline, ellipse, or
circle for an additional ring. Specify
if you want to erase the source
linework, and press Enter.

click Edit In Place tab ➤ Profile

panel ➤  Remove Ring  . Select
the ring you want to remove.

NOTE  You cannot remove the
last ring from a profile.

remove a ring from a profile

click Edit In Place tab ➤ Profile

panel ➤  Replace Ring  . Select

replace a ring on a profile

a closed polyline, spline, ellipse, or
circle for the replaced ring. Specify
if you want to erase the source
linework, and press Enter.

5 Save the changes to the profile.

Then …If you want to …

click Edit in Place tab ➤ Edits pan-

el ➤ Finish  .

change the existing profile defini-
tion to reflect the new shape

click Edit in Place tab ➤ Edits pan-

el ➤  Save As  . Enter a name

create a new profile definition with
the shape you have created

for the new profile and click OK.
The in-place edit session is exited
and the new profile definition is
available in the Style Manager.

click Edit in Place tab ➤ Edits pan-

el ➤ Cancel  .

discard all changes on the profile
and revert back to the previous
shape
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In-Place Editing of Curtain Wall Unit Frames and Mullions
Use this procedure to edit frames and mullions using in-place editing with
the Edit Grid grip. With in-place editing, you can edit bays, columns or nested
grids of the curtain wall unit directly and interactively in the drawing area,
and later save the changes to the curtain wall unit or curtain wall unit style.

1 Select a curtain wall unit on which you want to edit frames or
mullions with in-place editing.

2 Specify the mode in which to edit the curtain wall unit:

Then …If you want to edit …

click Curtain Wall Unit

tab ➤ Modify panel ➤  Design

this instance of the curtain wall unit

Rules drop-down  ➤ Transfer To
Object.

click Curtain Wall Unit

tab ➤ Modify panel ➤  Design

the curtain wall unit style

Rules drop-down  ➤  Revert To
Style Design Rules . If this option is
not available, the design rules are
already style-based for the curtain
wall unit.

3 Click the Edit Grid grip.

4 Enter f (Frame and mullion assignment) and press ENTER.

NOTE  You have entered the in-place editing session now. You can
see this from the faded color of all objects in the drawing, as well as
from the different grips at your disposal. Note that while you are in
the in-place editing session, you have only limited editing access to
other commands in the drawing. Before working on other objects,
you should first end the in-place editing session.

5 Select the bay, column or nested grid to modify the frame and
mullion assignment and press ENTER.

Press CTRL to select multiple bays, columns or nested grids.
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The Modify Frame/Mullion Assignment worksheet displays.

6 Select a frame definition for the selected grid:

Then…If you want to…

select a frame definition and click OK.modify the frame of the
selected grid

select Top, Bottom, Left, Right for Frame
Location and click OK.

specify the location of the
frame on the selected
grid

click  .
For more information, see Adding a New
Frame Assignment to a Curtain Wall on page
1490 .

create and assign a new
frame definition to the
selected grid

7 Select the mullion definition for the selected grid:

Then…If you want to…

select the mullion definition and click OK.modify the mullion of the
selected grid

click  and complete the Design Rules
worksheet.
For more information, see Adding a New
Mullion Assignment to a Curtain Wall Style
on page 1493 .

create and assign a new
mullion definition to the
selected grid

8 Press ENTER.
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Overriding Curtain Wall Unit Divisions
The grid of a curtain wall unit is made up of one or more divisions that define
how the curtain wall unit is partitioned. Divisions can be horizontal or vertical
and can be nested in each other. For detailed information on curtain wall unit
divisions, see Defining Divisions for Curtain Wall Unit Grids on page 1585 .

You can override a division in a curtain wall unit, thereby changing the grid
of the curtain wall unit.

Overriding number of Curtain Wall Unit cells

Creating a Curtain Wall Unit Division Override
Use this procedure to create a division override on a curtain wall unit.

NOTE  To exchange a curtain wall unit division, the new division definition must
already be defined in the curtain wall unit style. For information on curtain wall
unit divisions, see Defining Divisions for Curtain Wall Unit Grids on page 1585 .

1 Select the curtain wall unit for which you want to create a division
override.

2 Click Curtain Wall Unit tab ➤  Modify panel  ➤ Division
drop-down ➤  Override Assignment .

3 Select an edge of the curtain wall unit to determine if a horizontal
or vertical division is overridden.

For example, if you want to override the primary horizontal
division, you could select the bottom horizontal frame of the
curtain wall unit.
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TIP  The Division Assignment Override dialog box shows you which
grid type and which grid division you have selected, e.g., Selected
Nested Grid: Secondary Grid, Division Element Definitions: Vertical
3 Cells. If you accidentally selected the wrong division, click Cancel
and reselect the correct grid.

4 Select the appropriate division override, and click OK.

5 Specify where you want to save the curtain wall unit override.

Then …If you want to save the over-
ride …

no further steps are necessary. The
override is saved to the curtain wall

only on this specific curtain wall
unit

unit. For information about how to
remove an override from a curtain
wall unit, see Removing Curtain
Wall Unit Overrides on page 1670 .

click Curtain Wall Unit

tab ➤ Modify panel ➤  Design

to a curtain wall unit style

Rules drop-down  ➤ Transfer To
Object.

6 If you have chosen to save the override to a curtain wall unit style,
click Curtain Wall Unit tab ➤  Modify panel  ➤ Design Rules
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drop-down ➤  Save To Style , and decide to which curtain wall
unit style you want to save the override.

Then …If you want to save the over-
ride …

select Transfer Division Overrides to
Style, and click OK.

NOTE  If you have created only
a profile edge override, only the
Transfer Division Overrides to
Style checkbox is active. If you
have also created other over-
rides, such as a cell merge or a
edge override, these check-
boxes are available as well. If
you also want to save these
overrides to the style, select
their checkboxes too.

to the current curtain wall unit style

select Transfer Division Overrides to
Style, and click New. Enter a name

to a new curtain wall unit style

for the new curtain wall unit style,
and click OK.

NOTE  If you have created only
a profile edge override, only the
Transfer Division Overrides to
Style checkbox is active. If you
have also created other over-
rides, such as a cell merge or a
edge override, these check-
boxes are available as well. If
you also want to save these
overrides to the style, select
their checkboxes too.
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NOTE  If you do not want to save the override back to a style at all,
click  Curtain Wall Unit tab  ➤ Modify panel ➤  Design Rules
drop-down  ➤  Revert To Style Design Rules . The overrides still remain
on the curtain wall unit, where they can be removed as described in
Removing Curtain Wall Unit Overrides on page 1670 , but they are not
saved back to a curtain wall unit style.

In-Place Editing of Curtain Wall Unit Divisions
Use this procedure to edit divisions using in-place editing with the Edit Grid
grip. With in-place editing, you can edit the curtain wall unit directly and
interactively in the drawing area and later save the changes to the curtain wall
unit or curtain wall unit style.

For more information, see Division of Curtain Wall Unit Grids on page 1585 .

1 Select a curtain wall unit on which you want to edit divisions
with in-place editing.

2 Specify the mode in which to edit the curtain wall unit:

Then …If you want to edit …

click Curtain Wall Unit

tab ➤ Modify panel ➤  Design

this instance of the curtain wall unit

Rules drop-down  ➤ Transfer To
Object.

click Curtain Wall Unit

tab ➤ Modify panel ➤  Design

the curtain wall unit style

Rules drop-down  ➤  Revert To
Style Design Rules . If this option is
not available, the design rules are
already style-based for the curtain
wall unit.

3 Click the Edit Grid grip.

4 Enter d (Division in place).
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Viewing edit in-place grips for a primary division

NOTE  You have entered the in-place editing session now. You can
see this from the faded color of all objects in the drawing, as well as
from the different grips at your disposal. Note that while you are in
the in-place editing session, you have only limited editing access to
other commands in the drawing. Before working on other objects,
you should first end the in-place editing session.

Viewing edit in-place grips for adding and removing bays

5 Edit the division:

Then …If you want to …

click the Add Bay grip.add a bay to the grid

click the Remove Bay grip.remove a bay from the grid

select the Start Offset grip and
move it to the position.

change the start offset of the grid
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Then …If you want to …

select the End Offset grip and move
it to the position.

change the end offset of the grid

click the Auto Grid Bay Spacing grip
and move it to the position.

change the spacing of bays

click Edit In Place tab ➤ Division

panel ➤  Convert To Manual 

manually edit the grid

.You can manually add and remove
gridlines, change the offsets, and
change the position of individual
gridlines.

click the Set Fixed Cell Dimension
Rules command grip, and edit the
values in the worksheet.

use a worksheet to edit the cell di-
mensions

6 Save or discard changes to the curtain wall unit grid:

Then …If you want to exit the in-place
editing session …

click Edit in Place tab ➤ Edits pan-

el ➤ Cancel  .

without saving your changes

click Edit in Place tab ➤ Edits pan-

el ➤ Finish  .

after saving your changes

7 In the Save Changes dialog box, specify to which division to save
the changes:

Then …If you want to …

verify the current division is selected
for Save Changes to Existing Divi-

save the changes to the style in the
current curtain wall unit division

sion, and click Save. The changes
are made in the style and affect all
curtain wall units of that style in the
drawing.
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Then …If you want to …

click New, enter a name for the
new division override, and click OK.

create an override to the style by
saving the changes in a new curtain
wall unit division Click Save. The changes are saved

as an override to the style, and af-
fect only the curtain wall units to
which the override is applied.

Removing Curtain Wall Unit Overrides
Use this procedure to remove curtain wall unit overrides either from the curtain
wall unit or the curtain wall unit style.

1 Select the curtain wall unit:

Then …If you want to remove an
override …

double-click the curtain wall unit.
In the Properties palette, expand

from a curtain wall unit

Advanced, and click the Overrides
worksheet.

click  Curtain Wall tab  ➤ General

panel ➤  Edit Style drop-down

from the curtain wall unit style

 ➤ Edit Style, then, click the Over-
rides tab.

2 Select an override from the list and click Remove.

3 Click OK.

Editing Curtain Wall Units
Most relevant settings for a curtain wall unit are defined in the curtain wall
unit style. These include divisions, infills, frames, and mullions. For
information on modifying a curtain wall unit style, see Curtain Wall Unit
Styles on page 1582 .
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You can make other changes directly to individual curtain wall units. These
changes affect only the curtain wall unit you select:

■ Dimensions of a curtain wall unit

■ Roof and floor line settings

■ Interference conditions

■ Cleanup settings

Methods of Editing Curtain Wall Units

AutoCAD Architecture offers several methods for editing curtain wall units:

■ You can directly edit curtain wall units using grips for dimensions, base
height, location, and other physical characteristics.

■ You can directly edit curtain wall units using the Edit Grid grip for grid
divisions, cells, frames, and mullions. For more information, see In-Place
Editing of Curtain Wall Unit Divisions on page 1667 , In-Place Editing of
Edge Profiles for Curtain Wall Units on page 1659  and Overriding Curtain
Wall Unit Infills on page 1642 .

■ You can change curtain wall unit settings on the Properties palette.

■ You can select editing commands from the context menu for a selected
curtain wall unit.

Using Grips to Edit Curtain Wall Units
There are many different curtain wall unit grips. The grips that appear in your
drawing when you select a curtain wall unit are dependent upon the design
rules of the curtain wall unit. For more information, see Curtain Wall Unit
Styles on page 1582 .

Editing Curtain Wall Unit Dimensions
Use this procedure to change the dimensions of a curtain wall unit.

1 Select the curtain wall unit.

2 Select the grip for the dimension you want to change.

You can modify the dimensions of the height and length for a
curtain wall unit.
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Viewing Curtain Wall Unit Lengthen and Base Height grips

3 Enter a value for the dimension and press ENTER, or drag the grip
until the dimension value you want is displayed.

Changing the Location or Position of a Curtain Wall Unit
Use this procedure to change the location or the position of a curtain wall
unit with grips.

1 Select the curtain wall unit.

2 Select the appropriate grip to change the location of the curtain
wall unit, its start point, or its end point.
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Viewing Curtain Wall Unit Start, End, Location, and Reverse Direction Grips

In Model view, the Location grip has three possible edit modes:
Edit Along XY Plane, Edit Along YZ Plane, and Edit Along ZX
Plane. Press CTRL to cycle between modes until you are in the
desired mode. The default edit mode is along the XY plane. In
Plan view, the Location grip is restricted to movement in one
plane.

3 Move the curtain wall unit to the desired location and click once,
or enter a value and press ENTER.

If you want to enter a specific value for the second direction in
any edit mode (for example, in the Y direction when editing along
the XY plane), press TAB to cycle to the second direction.

You can also lock the movement of the curtain wall unit along a
specific direction. If you enter a value for either of the dimension
directions in the current edit mode and then press TAB, the
movement of the curtain wall unit is constrained to the second
dimension direction. When editing along the XY plane, for
example, you can enter a value for X dimension, and then press
TAB. The X dimension is locked at that value, and movement of
the curtain wall unit is constrained to the Y dimension direction.

Using Grips to Edit Curtain Wall Units  | 1673



4 Right-click, and click Deselect All to turn off grips.

Changing the Base Height of a Curtain Wall Unit
Use this procedure to change the base height of a curtain wall unit. You can
also change the base height on the Properties palette.

1 Select the curtain wall unit.

2 Select the Base Height grip, move the grip until the height value
you want is displayed, and click once.

As you move the grip, the original base height value is displayed
in addition to the new base height and the difference between
the two values.

After selecting the grip, you can also enter a new value for the
base height of the curtain wall unit.

Changing the Length of a Curtain Wall Unit
Use this procedure to change the length of a curtain wall unit. You can also
change the length on the Properties palette. For more information, see
Changing the Dimensions of a Curtain Wall Unit on page 1677 .

1 Select the curtain wall unit.

2 Select the Lengthen grip, move the grip until the length value
you want is displayed, and click once.
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As you move the grip, the original length value is displayed in
addition to the new length and the difference between the two
values.

After selecting the grip, you can also enter a new value for the
length of the curtain wall unit.

Selecting a Different Curtain Wall Unit Style
Use this procedure to select a different style for the curtain wall unit.

1 Select the curtain wall unit for which you want to change the
style.

You can select multiple curtain wall units and change the style
for all at the same time.

2 On the Properties palette, scroll to the General subcategory.
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3 Select a different style.

Matching the Properties of an Existing Curtain Wall Unit
Use this procedure to apply the properties of a curtain wall unit tool to one
or more existing curtain wall units. The properties include the curtain wall
unit style and any other settings specified in the tool you select.

1 Open the tool palette that you want to use.

If necessary, scroll to display the tool that you want to use.

2 Right-click a curtain wall unit tool, and click Apply Tool Properties
to ➤ Curtain Wall Unit.

3 Select the curtain wall units, and press ENTER.

The properties of the selected curtain wall units match the
properties of the curtain wall unit tool.
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Changing the Dimensions of a Curtain Wall Unit
Use this procedure to change the dimensions of a curtain wall unit.

DescriptionDimension

Height of the curtain wall unit from the
baseline

Height

Length of a straight curtain wall unit from
the start grip on the baseline to the end
grip

Length

Angle of all infills and horizontal edges
(frame or mullion) at the start of the curtain

Start Miter

wall unit. For more information about miter
angles, see Mitering Curtain Walls on page
1551 .

Angle of all infills and horizontal edges
(frame or mullion) at the end of the curtain

End Miter

wall unit. For more information about miter
angles, see Mitering Curtain Walls on page
1551 .

1 Select a curtain wall unit.

2 Expand Dimensions.

3 Change the dimension.

Specifying a Miter Angle for a Curtain Wall Unit Adjacent to
Another Object

Use this procedure to manually create a mitered corner between a curtain wall
unit and another object, such as a standard wall or a mass element. For
example, if your curtain wall unit connects with a standard wall that is at
60-degree angle from the curtain wall unit, you would specify the miter angle
as 30.

The miter angle applies to all infills and horizontal edges that are adjacent to
the corner. Vertical edges are not affected.
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TIP  To quickly identify the start and end of a curtain wall unit, select the curtain
wall unit. The Reverse Direction grip points toward the end of the curtain wall
unit.

1 Select a curtain wall unit.

2 Expand Dimensions.

3 Miter the curtain wall unit on the start or the end point:

Then …If you want to miter the curtain
wall unit …

enter an angle for Start Miter Angle,
and press ENTER.

at its start point

enter an angle for End Miter Angle,
and press ENTER.

at its end point

Changing the Location of a Freestanding Curtain Wall Unit
Use this procedure to relocate a freestanding curtain wall unit by changing
the coordinate values of its insertion point. The curtain wall unit also has an
orientation with respect to the WCS or the current UCS. For example, if the
top and bottom of the curtain wall unit are parallel to the XY plane, its normal
is parallel to the Z axis. You can change the orientation of the curtain wall
unit by aligning its normal with another axis. You can also rotate the curtain
wall unit on its plane by changing the rotation angle.

For information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use Coordinates and Coordinate Systems” in
AutoCAD Help.

1 Double-click the curtain wall unit you want to change.

2 Expand Location.

3 Click Additional information.

4 Specify the location of the curtain wall unit:

Then …If you want to …

enter new coordinate values under
Insertion Point.

relocate the curtain wall unit
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Then …If you want to …

make the normal of the wall parallel
to the Z axis: under Normal, enter
1 for Z, and enter 0 for X and Y.

locate the curtain wall unit on the
XY plane

make the normal of the curtain wall
unit parallel to the X axis: under

locate the curtain wall unit on the
YZ plane

Normal, enter 1 for X and enter 0
for Y and Z.

make the normal of the curtain wall
unit parallel to the Y axis: under

locate the curtain wall unit on the
XZ plane

Normal, enter 1 for Y, and enter 0
for X and Z.

enter a new value for Rotation
Angle.

change the rotation of the curtain
wall unit

5 Click OK.

Modifying the Position of Anchored Curtain Wall Units
When you use a curtain wall unit as an infill for a curtain wall or a
door/window assembly, the curtain wall unit is anchored to the other object.
While anchored, the curtain wall unit moves when you move the curtain wall
and is erased when you erase the curtain wall.

You can change the orientation, alignment, or offset of the curtain wall unit
without affecting the anchor.

NOTE  For information about releasing the curtain wall unit anchor so that it
moves and erases independently from the curtain wall, see Releasing an Object
Anchored in a Curtain Wall on page 1574 .

Changing the Orientation of an Anchored Curtain Wall Unit
Use this procedure to change the orientation of an anchored curtain wall unit
using grips.

1 Select the anchored curtain wall unit.
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2 Click the appropriate Flip grip to change the X or Y direction of
the object.

You can also change the orientation of an object, including the
Z direction, using the Anchor worksheet found on the object’s
Properties palette.

Changing the Alignment of an Anchored Curtain Wall Unit
Use this procedure to change the alignment of a curtain wall unit anchored
into a curtain wall.

1 Double-click the anchored curtain wall unit.

2 Expand Location, and click Anchor.

3 Click Allow Variation from Infill Element Definition.

4 Select a new alignment for the curtain wall unit.

For more information, see Specifying an Alignment for a Curtain
Wall Unit Infill on page 1596 .

5 Click OK.

Changing the Offset of an Anchored Curtain Wall Unit
Use this procedure to change the offset of an anchored curtain wall unit.

1 Double-click the anchored curtain wall unit.

2 Expand Location, and click Anchor.

3 Click Allow Variation from Infill Element Definition.

4 Specify a new offset for the curtain wall unit.

For more information, see Specifying an Offset for a Curtain Wall
Unit Infill on page 1597 .

5 Click OK.

Specifying the Cut Plane Display of a Curtain Wall Unit
Use this procedure to specify the properties of one or more cut planes for an
individual curtain wall unit. Cut plane display properties apply only to display
representations, such as Plan, that are used in the Top view (plan view) of a
drawing.
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1 Double-click the curtain wall unit you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE  To apply your changes to all curtain wall units in the drawing,
select Drawing default setting. To apply changes to all curtain wall
units of this style, select Curtain Wall Unit Style:<style name>. For
more information on styles, see Curtain Wall Unit Styles on page 1582
.

5 If necessary, expand Object Display Properties ➤ Cut Plane.

6 For Override cut plane, specify whether you want to override the
global cut plane defined for the current display configuration.

7 If you selected Yes for Override cut plane, enter a value for Height
to define the cut plane for this object.

8 For Use cut plane of containing object when anchored, specify
whether you want the containing object’s cut plane to be used
when the curtain wall unit is anchored to that object.

9 To define additional cut planes for the curtain wall unit, click 
Manual cut planes.

10 On the Manual Above and Below Cut Plane Heights worksheet,
click Add, and under Cut Plane, enter the height of the new cut
plane.

Then …If you add a cut plane …

objects are displayed using the
Layer/Color/Linetype properties

at a height that is lower than the
current cut plane

specified for the Below Cut Plane
component of the object.

objects are displayed using the
Layer/Color/Linetype properties

at a height that is higher than the
current cut plane

specified for the Above Cut Plane
component of the object.

You can click Remove to delete a cut plane that you added.
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You can also access and modify these same cut plane settings through the
curtain wall unit’s context menu, as follows

1 Select the curtain wall unit you want to change, right-click, and
click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 In the Display Properties dialog, click the Cut Plane tab, and then
change the settings as needed.

5 Click OK twice.

Specifying the Display of Other Characteristics of a Curtain Wall
Unit

Use this procedure to specify other display properties for a curtain wall unit,
including cell marker size, the display of miters at frame corners, and the
display of custom components. If you are going to use custom graphics for a
component, draw the component and save it as a block before you start this
procedure.

1 Double-click the curtain wall unit.

2 Click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE  To apply your changes to all curtain wall units in the drawing,
select Drawing default setting. To apply changes to all curtain wall
units of this style, select Curtain Wall Unit Style:<style name>. For
more information on styles, see Curtain Wall Styles on page 1436 .

5 If necessary, expand Object Display Properties ➤ Advanced.

6 If you want to change the size of the markers used for cells in the
curtain wall grid, click Cell marker size, and enter a new value.
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(Alternatively, you can click  and specify 2 points in the
drawing area to set the new size.)

7 Optionally, for Show mitres at frame corners, select Yes/No.

8 If you want to add or edit a custom component, for Custom model
components (or Custom plan components, if in a plan view),

click  .

9 On the Custom Model (or Plan) Components worksheet, click
Add, or select one of the components in the list, and click Edit.

10 On the Custom Display Component worksheet, for Component
Type, select Infill, Frame, or Mullion.

11 Enter a name for Component Name, or click Select Component,
and in the Select <component type> Definition dialog, select a
definition, and click OK.

12 Select Draw Custom Graphics.

13 Specify the display of the element:

Then …If you want to …

select Replace Graphics.display the block instead of the as-
sociated curtain wall unit element

clear Replace Graphics.superimpose the block over the
curtain wall unit element so that
both are displayed

14 Click Select Block, select the custom block that you created, and
click OK.

15 Specify further settings for the custom display block:

Then …If you want to …

select Width, Height, or Depth. To
prevent the block from losing its
proportions, select Lock XY Ratio.

scale the block to fit a particular di-
mension

specify an insertion point on the X,
Y, and Z planes.

specify how the block is inserted
into the grid in the X, Y, and Z dir-
ections

determine if it should mirror in the
X, Y, or Z direction.

mirror the block
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Then …If you want to …

specify the offset in the X, Y, or Z
direction.

offset the block from the grid

16 Click OK twice.

Attaching Hyperlinks, Notes, or Files to a Curtain Wall Unit
Use this procedure to enter notes and attach reference files to a curtain wall
unit. You can also edit notes and edit or detach reference files from a curtain
wall unit.

1 Double-click the curtain wall unit.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

4 To add a note, click the setting for Notes, and enter the text.

5 Click OK.

6 Click under Reference documents, and attach, edit, or detach a
reference file:

Then …If you want to …

click Add, select a file, and click
Open.

attach a reference file

select the file, and click the descrip-
tion. Enter the new text, and press
ENTER.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

7 Click OK twice.
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Facet Deviation
The smoothness (tesselation) of curved curtain wall edges is controlled by the
FACETDEV variable. Specify the facet deviation to set the number of facets to
display on curved objects. This must be set before converting a polyline to a
curtain wall.

The facet deviation is available only on the command line by typing
-AecFacetDev.

The number you set as the facet deviation defines the maximum distance
from the chord to the arc, the chord being an edge that is created from faceting
the curve, to the true mathematical arc. The facet deviation has a range of
greater than zero (0) and no upper limit.

The minimum number of facets is 8. For example, when you create a cylinder
mass element with a 1' radius, and specify a FACETDEV value of 1', the cylinder
has 8 faces.
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Door and Window
Assemblies

Door and window assemblies provide a mechanism for creating door and window compounds
for inserting in walls and curtain walls.

Door and Window Assemblies
Door/window assemblies provide a grid or framework for inserting objects such
as windows and doors. With this framework, you can create complex window
and door assemblies, which can then be inserted in standard walls or used as
repeated elements in curtain walls.
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Door/Window Assembly Grids

Door/window assemblies are made up of 1 or more grids. Each grid has either
a horizontal division or a vertical division, but you can nest the grids to create
a variety of patterns from simple to complex.

TIP Using a door/window assembly in a curtain wall can help you avoid the
complexities of too many nested grids in the curtain wall.

Elements of Grids

Grids are the foundation of curtain walls, curtain wall units, and door/window
assemblies. Every grid has four element types:

■ Divisions: Define the direction of the grid (horizontal or vertical) and the
number of cells

■ Cell Infills: Contain another grid, a panel infill, or an object such as a
window or a door

■ Frames: Define the edge around the outside of the primary grid and nested
grids

■ Mullions: Define the edges between the cells

NOTE Division is an abstract element, in contrast to the other three element types
that represent physical elements of the door/window assembly.
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Each element type is assigned a default definition that describes what elements
of that type look like.

Default definitionsElement type

Vertical divisions with a fixed cell dimension
of 3'

Divisions

Cells containing simple panels with a 2"
thickness

Cell Infills

Outer edges of grid 3" wide and 3" deepFrames

Edges between cells 1" wide and 3" deepMullions

You can create new element definitions and assign those definitions within
the door/window assembly. For example, you can create multiple infill
definitions and then assign different infills to specific cells in the grid. Likewise,
you can create multiple frame definitions and then assign a different definition
to each frame edge (top, bottom, left, right). This is also true for mullion
definitions.
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Experimenting with Door/Window Assembly Designs

The templates provided with AutoCAD Architecture offer door/window
assembly styles. Looking at these styles and experimenting with them makes
it easier to understand door/window assembly behavior and create your own
door/window assembly designs.

For more information about element definitions and assignments, see Creating
Element Definitions for a Door and Window Assembly Style on page 1707 and
Assigning Definitions to Door and Window Assembly Elements on page 1745.

Door and Window Assembly Endcaps

Door and window assemblies that are anchored in a wall can have endcap
styles applied to them. The endcap shapes for wall openings are defined in
the wall style and are a property of the wall. For information on setting an
opening endcap style in a wall, see Working with Wall Endcaps and Opening
Endcaps on page 1373.
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Using Door and Window Assembly Tools to Create Door and
Window Assemblies

Door/window assemblies are planar and defined by an insertion point, as
opposed to curtain walls, which have a baseline that can be curved or straight.
You can create a door/window assembly based on a 2D layout grid or on a
combination of lines, arcs, and circles.

To create a door/window assembly for use in a standard wall, you draw the
wall first. You can then insert the door/window assembly and modify the
door/window assembly elements as needed.

To create a door/window assembly for use in a curtain wall, insert the
door/window assembly in space. Modify the element definitions and
assignments as needed. Save your changes as a new door/window assembly
style, and then assign that style to cells in your curtain wall grid. For more
information, see Inserting an Object into a Curtain Wall Cell on page 1485.

Tool palettes provided with AutoCAD Architecture let you quickly place
door/window assemblies by selecting a door/window assembly tool with a
specific door/window assembly style and other predefined properties. When
you place door/window assemblies using door/window assembly tools, you
can use the default settings of the tool, or you can change settings for the
door/window assembly properties. You can also use door/window assembly
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tools to convert linework to door/window assemblies and to apply the settings
of a door/window assembly tool to existing door/window assemblies.

The following palettes contain one or more door/window assembly tools:

Door/Window Assembly ToolsTool Palette

Standard door/window assembly style and
default settings for other door/window as-
sembly properties

Design palette in the Sample Palette cata-
log in the Content Browser

a large number of door and window as-
sembly styles for many design uses

Design Tool Catalog  ➤ Doors and Win-

dows  ➤ Door and Window Assemblies in
the Content Browser

door/window assembly styles and proper-
ties that your CAD manager customized
for your projects or office standards

custom tool palettes created by your CAD
manager

When you place door/window assemblies using door/window assembly tools,
you can use the default settings of the tool, or you can change settings for
any door/window assembly properties that are not controlled by the style.
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Creating a Door and Window Assembly
Use this procedure to add a new door/window assembly that has the properties
specified in the door/window assembly tool that you select. To specify settings
when you add a door/window assembly, see Creating a Door and Window
Assembly with User-Specified Settings on page 1694.

1 Open the tool palette that contains the door/window assembly
tool you want to use, and select the tool.

TIP You may have to scroll to display the desired tool. After you select
it, you can move or hide the Properties palette to expose more of the
drawing area.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Door

drop-down ➤ Door/Window Assembly  .

2 Select a wall, or press ENTER and then specify the insertion point
of the door/window assembly.

3 Continue adding door/window assemblies, and then press ENTER.
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Creating a Door and Window Assembly with User-Specified
Settings

Use this procedure to add a door/window assembly with settings that you
specify.

1 Open the tool palette that contains the door/window assembly
tool you want to use, and select it.

(You may have to scroll to display the desired tool.)

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Door

drop-down ➤ Door/Window Assembly  .

2 On the Properties palette, expand Basic, and expand General.

3 Select a style.

4 Under Bound Spaces, specify if this door and window assembly
can be used as a bounding object for associative spaces.

You can select three options here:

■ Yes: this door and window assembly can be used as bounding
object for associative spaces.

■ No: this door and window assembly cannot be used as
bounding object for associative spaces.

■ By style: this door and window assembly will use the bounding
settings from the door and window assembly style.

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

5 Expand Dimensions.

6 Modify the dimensions of the door/window assembly:

Then…If you want to specify…

enter a value for Length.the length of the door/window as-
sembly

enter a value for Height.the height of the door/window as-
sembly
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Then…If you want to specify…

enter a value for Rise.the rise of the door/window as-
sembly

enter miter values for Start miter
angle and End miter angle.

start and end miters

7 Expand Location.

8 Modify the location properties of the door/window assembly:

Then…If you want to specify…

select Unconstrained or Off-
set/Centered for Position along the
wall.

NOTE If you selected Off-
set/Centered, enter a value for
the Automatic offset.

the position of the door/window
assembly

select Head or Sill for Vertical
Alignment.

the vertical alignment of the
door/window assembly

enter a value for Head height.the head height of the door/win-
dow assembly

enter a values for Sill height.the sill height of the door/window
assembly

enter a value for Rotation.the rotation reference angle of the
door/window assembly

Vertical alignment controls how you place the door/window
assembly in the wall and how the door/window assembly responds
to modifications in height. The Sill height and Head height
options allow you to determine the working point on the
door/window assembly. You can place the working point at the
sill or at the head. The vertical alignment value determines the
location of the working point vertically in the wall.

Modifications to the door/window assembly height respect the
working point. For example, if you specify the working point of
the window as sill, the vertical alignment as 0'', and the
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door/window assembly height as 7'–0'', the height in the wall
where the top of the door/window assembly is placed is 7–0''. If
you modify the height of the window to 6'–8'', the window sill
remains at 0'', and the top of the door/window assembly becomes
6–8''. The sill working point is maintained.

If you specify the working point as the door/window assembly
head, the Vertical Alignment value as 7'–0'', and the door/window
assembly height as 7'–0'', the height in the wall where the top of
the door/window assembly is placed is 7–0''. If you modify the
height of this door/window assembly to 6'–8'', the door/window
assembly head remains at 7'–0'' and the window sill becomes 4''.
The head working point is maintained.

TIP You can move or hide the Properties palette to expose more of
the drawing area.

9 In the drawing area, select a wall, or press ENTER and then specify
the insertion point of the door/window assembly.

10 Continue adding door/window assemblies, and press ENTER.

Creating a Door and Window Assembly from a Layout Grid
Use this procedure to create a door/window assembly based on a 2D layout
grid. If you already have 2D layout grids in a drawing, you can easily convert
them to door/window assemblies. Or, if you are already familiar with layout
grids, it is an efficient way to create a door/window assembly and then
experiment with the door/window assembly commands to learn more about
them. For more information, see Using Layout Grids on page 2719.
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NOTE Only rectangular layout grids can be converted to a door/window
assemblies.

When you create a door/window assembly from a 2D layout grid, you also
create a new door/window assembly style. The divisions in the new
door/window assembly style are taken from the divisions in the layout grid.

1 Open the tool palette that contains the door/window assembly
tool you want to use.

(You may have to scroll to display the desired tool.)

2 Right-click a door/window assembly tool, and click Apply Tool
Properties to ➤ Layout Grid.

3 Select the layout grid to convert.

4 When prompted to erase the original geometry, press ENTER to
keep the layout grid, or enter y (Yes) to erase it.

5 Press ENTER to specify horizontal as the orientation for the primary
division, or enter v to specify vertical.

6 Enter a name for the door/window assembly style, and click OK.

7 If necessary, edit the properties of the door/window assembly in
the Properties palette.
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Creating a Door and Window Assembly from Doors, Windows
and Openings

Use this procedure to convert doors, windows, and openings to a door/window
assembly that has the properties of the door/window assembly tool you select.
You can edit the properties of the door/window assembly after you create it.

NOTE When you create a door/window assembly from a collection of doors,
windows and openings, you create a single assembly from each object selected.
For more information about how to create an assembly from a specific
configuration, see Creating a Door and Window Assembly from an Elevation Sketch
on page 1699.

1 Open the tool palette that contains the door/window assembly
tool you want to use.

(You may have to scroll to display the desired tool.)

2 Right-click a door/window assembly tool, and click Apply Tool
Properties to ➤ Door, Opening, Window.

3 Select the door, window or opening to convert.

4 Edit the properties of the door/window assembly in the Properties
palette, if necessary.
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Creating a Door and Window Assembly from an Elevation Sketch
Use this procedure to create a sketch of a custom grid with lines, arcs, and
circles, and then convert that linework into a door/window assembly.

NOTE You cannot modify the division definition of a custom grid created from
lines, arcs, and circles. You can, however, assign a different division definition to
it. For more information, see Assigning a Division to a Door and Window Assembly
Grid on page 1746.

NOTE Door/window assembly grids are either horizontal or vertical. To create a
grid pattern with horizontal and vertical cells, nested grids are used. For more
information about nested grids, see Working with Nested Grids in Door and
Window Assemblies on page 1748.

1 Use lines, arcs, and circles to draw a grid in the world coordinate
system (WCS).

2 Open the tool palette that contains the door/window assembly
tool you want to use.

(You may have to scroll to display the desired tool.)

3 Right-click a door/window assembly tool, and click Apply
Properties to ➤ Elevation Sketch.

4 Select the linework of your sketch, and press ENTER.

5 You have the option of either selecting a baseline for the
door/window assembly or accepting the default baseline. Select
one of the grid lines as the baseline for the door/window assembly.

Using Door and Window Assembly Tools to Create Door and Window Assemblies | 1699



Or press ENTER to use the line along the X axis as the default
baseline.

TIP If you draw your linework in the XY plane (in Plan view) and
accept the default baseline, the resulting door/window assembly is
displayed from the Z direction.

6 To erase the lines, enter y (Yes). To have the lines remain after
the door/window assembly is created, enter n (No).

If there is a style applied to the door/window assembly tool, the
new custom style is based on the existing style. The infill, mullion,
and frame definitions are those of the existing style. You can
modify the style without having to create a new one from scratch.
For more information, see Assigning Definitions to Door and
Window Assembly Elements on page 1745.

7 Select the resulting custom door/window assembly, click
Door/Window Assembly tab ➤ Modify panel ➤ Design Rules
drop-down ➤ Save to Style.

8 Click New to create a new door/window assembly style.

9 Enter a name for the new door/window assembly style.

10 Click OK twice.

Creating a Door and Window Assembly Tool
Use this procedure to create a door/window assembly tool and add it to a tool
palette. You may want to create your own door/window assembly tools if you
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are placing multiple door/window assemblies of specific styles that have the
same properties.

1 Open the tool palette on which you want to add a tool.

2 Create the tool:

Then…If you want to…

select the door/window assembly,
and drag it to the tool palette.

create a tool from a door/window
assembly in the drawing

click Manage tab ➤ Style & Display

panel ➤ Style Manager . Locate

create a tool from a door/window
assembly style in the Style Manager

the style you want to copy, and
drag it to the tool palette. Click OK
to close the Style Manager.

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the palette where you want
to add the tool, right-click, and click
Paste.

click Home tab ➤ Build pan-

el ➤ Tools drop-down ➤ Content

copy a tool from the Content
Browser

Browser  and locate the tool
you want to copy. Position the
cursor over the i-drop handle, and
drag the tool to the tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

This description is used as the tool’s tooltip on the tool palette,
and to describe the tool if it is stored in a tool catalog.

6 Expand Basic, and expand General.
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7 Click  next to Description, enter a description of the
door/window assembly created from this tool, and click OK.

8 Click  next to Layer key to specify a layer key.

9 Click  next to Layer overrides to specify any layer key overrides
if you do not want to use the layer assignments specified in the
layer key style used in the drawing.

10 Select a style.

11 Select the drawing file containing the style used for this
door/window assembly for Style location.

12 Under Bound Spaces, define if this door and window assembly
tool can be used as a bounding object for associative spaces.

You can select three options here:

■ Yes: this door and window assembly tool can be used as
bounding object for associative spaces.

■ No: this door and window assembly tool cannot be used as
bounding object for associative spaces.

■ By style: this door and window assembly tool will use the
bounding settings from the door and window assembly style.

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

13 Expand Dimensions.

14 Modify the dimensions of the door/window assembly

Then…If you want to specify…

enter a value for Length.the length of the door/window as-
sembly

enter a value for Height.the height of the door/window as-
sembly

enter a value for Rise.the rise of the door/window as-
sembly

enter miter values for Start miter
angle and End miter angle.

start and end miters
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15 Expand Location.

16 Modify the location properties of the door/window assembly:

Then…If you want to…

select Unconstrained or Offset/Cen-
ter for Position along the wall.

NOTE If you selected Off-
set/Center, enter a value for the
Automatic offset.

specify the position of the
door/window assembly

enter a value for Head height.specify the head height of the
door/window assembly

enter a value for Sill height.specify the sill height of the
door/window assembly

17 Click OK.

Door and Window Assembly Styles
Door/window assemblies are style-based, meaning there are preset
characteristics assigned to each door/window assembly that determine its
appearance and function. By changing from one style of door/window assembly
to another, you can quickly study several different design options. Any changes
you make to the style are reflected throughout your building, updating all
door/window assemblies of that particular style. You can also apply overrides
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to a single door/window assembly, without changing other door/window
assemblies of the same style.

A door/window assembly style controls the following properties of a
door/window assembly:

■ Element definitions

■ Definition assignments for each element

■ Materials for each element

■ Display properties for each element

■ Default dimensions

■ Notes about the style and any associated reference files

To create, edit, copy, or purge styles, you access the Style Manager. The Style
Manager provides a central location in AutoCAD Architecture where you can
work with styles from multiple drawings and templates. For more information
about using the Style Manager, see Style Manager Overview on page 870.
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Workflow to Create a Door and Window Assembly Style
When you create a door/window assembly style, you assign characteristics to
any or all of the components, and save them as a named style. In this way,
you standardize the appearance of all assemblies with that style. When you
modify a style, all door/window assemblies in your drawing that use the style
are updated to reflect the changes. For more information about working with
styles, see Style Manager Overview on page 870.

Open the drawing in which you want to add a
door and window assembly.
If you are working in a structured AutoCAD
Architecture project, open a construct on page
411 from the Project Navigator.

-----Open a drawing

Add the door style for the assembly to the
drawing.

-----
Prepare the drawing for the door
and window assembly

Although you can also use a predefined door and
window assembly tool, you can also create a

-----
Create the door and window
assembly style

custom style by modifying an existing style on
page 1694 or by converting a door, window,
opening on page 1698, 2D layout grid on page 1696,
or an elevation sketch on page 1699.

Define the infills on page 1722 for the cells of the
door/window assembly style before assigning
them to the style.

-----Define glazing or panels

Define the door/window assembly frame on page
1730 (using profiles and specifying offsets) and-----Define the frame and mullions
mullions on page 1737 before assigning them to
the door/window assembly style.
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Add the infills on page 1746 that you previously
defined by assigning the definitions to the
door/window assembly style.

-----Assign infills to the style

Add the frames on page 1759 and mullions on page
1763 that you previously defined by assigning the
definitions to the door/window assembly style.

-----
Assign the frame and mullions to
the style

Assign materials on page 1767 to the door/window
assembly style if desired.

-----Add material to infills and mullions

Create a tool on page 1700 to use when adding
other door/window assemblies of the same style
to your drawing.

-----
Add this door/window assembly
style to your library

Tips for Working Efficiently with Door and Window Assembly
Styles

Use these suggestions to work with door/window assembly styles efficiently.

■ Name grids and elements very clearly to identify where they are used and
what they are. For example, use the name L3-FL1-H to represent a
third-level grid used on the first floor and that is horizontally divided.
Incorporating this suggestion makes it easier to ensure that you are using
elements correctly.

■ Use the element definition that is applied most often as the default element
definition. For example, if most cells are stone panels, define the default
infill as the stone panel. This panel is then used in every cell that is not
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specifically assigned to another infill. Apply this rule to the default frame,
mullion, and division.

■ Name the styles for doors, windows, curtain wall units, AEC Polygons, and
curtain walls to indicate where they are used and what they are.

■ Remember that you can use cell and edge overrides to define special
conditions not accounted for in the door/window assembly style.

Creating Element Definitions for a Door and Window Assembly
Style

Element definitions determine the appearance of the four basic door/window
assembly elements. There is a different definition type for each element.

Sample definitionsDefinition

Horizontal grid with six cellsDivisions

Cells contain windowsCell Infills

Outer edge of grid is 6" wideFrames

Edges between cells are 4" wideMullions

Each type of element can have multiple definitions. For example, you can
define the divisions to create a horizontal grid or a vertical grid and you can
define the cells to contain a nested grid or a door/window assembly. To make
reuse easier, you can save the element definitions and then assign them to
grids, cells, frames, or mullions as needed.

Element definitions are style-specific. When you create element definitions
for a specific door/window assembly style, those definitions are available only
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for door/window assemblies of that style. For example, if you define a
door/window assembly infill for one door/window assembly style, that infill
is not available as an option when you edit a door/window assembly of a
different style.

Creating a Door and Window Assembly Style
Use this procedure to create a door/window assembly style. You can create a
style using default style properties or by copying an existing style. After you
create the style, you edit the style properties to customize the characteristics
of the style. You can also create a door/window assembly tool based on the
newly created door/window assembly style. When you use the tool to add
door/window assemblies, each door/window assembly has the style specific
to the tool.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

3 Create a new door/window assembly style:

Then…If you want to…

right-click Door/Window Assembly
Styles, and click New.

create a style with default properties

right-click the door/window as-
sembly style you want to copy, and

create a style from an existing style

click Copy. Right-click, and click
Paste.

right-click Door/Window Assembly
Styles, and click New. Right-click

create a style from a curtain wall,
curtain wall unit, or door/window
assembly in the drawing the new style, click Set From, and

then pick a curtain wall, a curtain
wall unit, or a door/window as-
sembly.

4 Enter a name for the new door/window assembly style, and press
ENTER.
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5 Edit the new door/window assembly style:

Then…If you want to…

see Creating a Division Definition
for a Door and Window Assembly

define the elements of a door/win-
dow assembly style

on page 1711, Defining Infills for Door
and Window Assembly Cells on
page 1722, Defining Door and Win-
dow Assembly Frames on page 1730,
and Defining Door and Window
Assembly Mullions on page 1737.

see Assigning Definitions to Door
and Window Assembly Elements on

assign element definitions to the
door/window assembly style

page 1745, Assigning a Division to a
Door and Window Assembly Grid
on page 1746, Assigning Infills to
Door and Window Assembly Cells
on page 1746, Assigning Definitions
to Door and Window Assembly
Frames on page 1759, and Assigning
Definitions to the Mullions of a
Door and Window Assembly on
page 1763.

see Adding Door and Window As-
sembly Element Definitions as Dis-
play Components on page 1771.

add door/window assembly ele-
ment definitions as display compon-
ents

see Specifying the Layer, Color, and
Linetype of a Door and Window
Assembly Style on page 1772.

specify layer, color and linetype
settings for the display components
of a door/window assembly

see Specifying the Hatching for
Components of a Door and Win-
dow Assembly Style on page 1773.

specify door/window assembly
hatching

see Adding Custom Graphics as a
Display Component of a Door and
Window Assembly on page 1774.

add custom graphics as display
components of a door/window as-
sembly style

see Creating Cut Planes for a Door
and Window Assembly on page 1776.

create individual cut planes for
door/window assembly styles
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Then…If you want to…

see Specifying the Materials of a
Door and Window Assembly Style
on page 1767.

specify the materials of the
door/window assembly style

see Attaching Notes and Files to a
Door and Window Assembly Style
on page 1778.

add notes and files to the style

6 When you finish specifying the properties of the door/window
assembly style, click OK.

7 If you want to assign the style to a door/window assembly tool,
drag the style from the Style Manager to a tool palette.

You can later rename the tool and specify other properties for it
as described in Creating a Door and Window Assembly Tool on
page 1700.

8 Click OK.

Division of Door and Window Assembly Grids
A door/window assembly consists of one or more grids, which are the
framework for placing design elements in the door/window assembly. The
highest-level grid is the primary grid, which is also the outside edge of the
door/window assembly.

Each grid in a door/window assembly has one division assignment that
determines whether the grid is divided horizontally or vertically. The division
also determines the number of cells, their size, and their placement.
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Within the primary grid, you can define multiple levels of grids. These grids
within the primary grid are called nested grids. Each subdivision of a grid is
called a cell.

You can create a variety of division definitions under different names and
then assign different divisions to each grid in your door/window assembly.
Although you can create multiple definitions, there can be only one division
assignment per grid. You create division definitions for a specific door/window
assembly style and those definitions can be assigned only to grids in
door/window assemblies of that style. For more information about assigning
divisions to a particular grid, see Assigning a Division to a Door and Window
Assembly Grid on page 1746.

Creating a Division Definition for a Door and Window Assembly
Use this procedure to create divisions for a door/window assembly grid.

Because door/window assemblies can contain multiple nested grids, it is helpful
to use a naming convention for grids that indicates the level of each grid and
the grid location or the purpose within the door/window assembly. For
example, L3-FL1-Stone Panels identifies a third level grid that provides a row
of stone panels on Floor 1.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Click  to create a new division definition.

7 Enter a name for this division definition.

8 For Orientation, select either Horizontal  , or Vertical  .
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9 Select one of the following division types and specify offsets if
needed:

DescriptionDivision Type

Creates a grid where the size of the
individual cells is predetermined.

Fixed Cell Dimension

For more information, see Specify-
ing a Fixed Size for Cells in a Door
and Window Assembly Grid on
page 1712.

Creates a grid where the number
of grid cells is predetermined. For

Fixed Number of Cells

more information, see Specifying a
Fixed Number of Cells for a Door
and Window Assembly Grid on
page 1717.

Creates a grid where the size and
number of individual cells is manu-

Manual

ally determined by the user. For
more information, see Manually
Defining the Number and Size of
Cells in a Door and Window As-
sembly Grid on page 1718.

After you create a division definition, you can assign the definition
to a specific grid in a door/window assembly. For more
information, see Assigning a Division to a Door and Window
Assembly Grid on page 1746.

10 When you are finished creating division definitions, click OK.

Specifying a Fixed Size for Cells in a Door and Window Assembly
Grid

Use this procedure to define a specific size for the cells in a grid. In this case,
the number of cells is determined by the length or height of the grid,
depending on how the grid is divided.

When you specify a fixed cell size in a grid, you can control how the cells of
the grid adjust to accommodate any leftover space. This space occurs if the
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length (or the height) of the door/window assembly cannot be evenly divided
by the fixed size of the cell. For more information, see Using the Auto-Adjust
Cells Option on page 1715.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Divisions definition or click  to create a new one.

7 Select Fixed Cell Dimension for Division Type.

8 Specify a size for the cells in Cell Dimension.

If you are defining a vertical grid, the cell dimension is the length
of the cell from mullion to mullion. If you are defining a
horizontal grid, the cell dimension is the height of the cell.
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9 To specify an offset for the grid,

then…if the orientation is…

specify an offset distance in Bottom
Offset or Top Offset.

horizontal

specify an offset distance in Start
Offset or End Offset.

vertical

TIP The frame width is calculated as part of the cell size. Therefore,
cells adjacent to the frame can appear to be a different size than the
other cells. If you do not want the frame width included in the cell
size, specify an offset for the grid that is equal to the frame width.

When you draw a door/window assembly using a fixed cell
dimension, there is often extra space between the last full-size
cell and the end of the door/window assembly.

For more information about grid offsets, see Specifying an Offset
for a Door and Window Assembly Grid on page 1719.

10 Adjust the cells to accommodate this extra space:

Then…If you want to…

select Auto-Adjust Cells, select Grow
for Cell Adjustment, and select the

add the space to grid cells

specific cells where the space is to
be added. You can select any com-
bination of Specific Cells.

select Auto-Adjust Cells, select
Shrink for Cell Adjustment, and se-

remove the space from grid cells

lect the specific cells where the
space is to be removed. You can
select any combination of Specific
Cells.

11 Click OK.

For information about assigning the division definition to a
specific grid in your door/window assembly, see Assigning a
Division to a Door and Window Assembly Grid on page 1746.
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Using the Auto-Adjust Cells Option
Use this procedure to automatically resize cells in a grid when the result of
dividing the grid by the specified cell dimension is not a whole number. You
can adjust the size of cells by specifying a cell or combination of cells to grow
or shrink according to your layout.

For example, if a vertical primary grid in a door/window assembly style is 17
feet in length and you specify a fixed cell dimension of 3 feet, the grid has
five cells of 3 feet each with 2 feet remaining. Using the Auto-Adjust Cells
option, you can specify how the grid distributes the remaining quantity.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.
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NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Divisions definition or click  to create a new one.

7 Select Fixed Cell Dimension as the division type.

Auto-Adjusting Cells by Growing

8 Select Auto-Adjust Cells, and specify the cell adjustment:

Then…If you want to…

select Grow, and select the specific
cells to which you want the space
added.

add the remaining space to grid
cells

select Shrink, and select the specific
cells from which you want the

remove the remaining space from
grid cells

space removed. You can then select
Maintain at least half of cell dimen-
sion in order to control the cell
shrinkage.

The cells that you do not select maintain the fixed value you
specified for Cell Dimension.

You can auto-adjust the grid divisions by specifying the start,
middle, or end cell, or any combination of those cells, to receive
the cell growth. The size of each cell depends on which
combination of cells you specify. In the following illustration, all
of the possible cell growth combinations for an example
door/window assembly are shown, with highlighted cells in green.
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Specifying a Fixed Number of Cells for a Door and Window
Assembly Grid

Use this procedure to define a specific number of cells in a grid. In this case,
the size of the cells is determined by the length or height of the grid, depending
on how the grid is divided.

Specifying a fixed number of cells for Door/Window Assembly grids

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Divisions definition or click  to create a new one.

7 Select Fixed Number of Cells for Division Type.

8 Enter the desired number of cells in Number of Cells.

9 Specify an offset distance:

Then…If the orientation is…

specify an offset distance in Bottom
Offset or Top Offset.

horizontal

specify an offset distance in Start
Offset or End Offset.

vertical
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For more information, see Specifying an Offset for a Door and
Window Assembly Grid on page 1719.

TIP The frame width is calculated as part of the cell size. Therefore,
cells adjacent to the frame can appear to be a different size than the
other cells. If you do not want the frame width included in the cell
size, specify an offset for the grid that is equal to the frame width.

For information about assigning the division definition to a specific grid in
your door/window assembly, see Assigning a Division to a Door and Window
Assembly Grid on page 1746.

Manually Defining the Number and Size of Cells in a Door and
Window Assembly Grid

Use this procedure to manually add gridlines and specify an offset for each
one when you need to create a unique grid that does not fit into any of the
other division types. You can also start with a fixed cell dimension grid or a
fixed number of cells grid and then manually adjust the gridlines to suit your
needs.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Divisions definition or click  to create a new one.

7 Select Manual for Division Type.

8 Click  to add a gridline.

Insert as many grid lines as you need. If you need to remove a

grid line, select it from the table, and then click  .

1718 | Chapter 23   Door and Window Assemblies



9 Under Offset in the grid line table, specify an offset distance for
each grid line.

10 Under From in the grid line table, select the grid location from
which the grid line is offset.

11 Specify an offset distance:

Then…If the orientation is…

specify an offset distance in Bottom
Offset or Top Offset.

horizontal

specify an offset distance in Start
Offset or End Offset.

vertical

For more information, see Specifying an Offset for a Door and
Window Assembly Grid on page 1719.

12 Click OK.

For information about assigning the division definition to a
specific grid in your door/window assembly, see Assigning a
Division to a Door and Window Assembly Grid on page 1746.

Specifying an Offset for a Door and Window Assembly Grid
By default, grids cells are measured from the start and end points of the
door/window assembly baseline (for horizontal divisions) or in the baseline
to the base height (for vertical divisions). The width of the grid frame is not
considered in calculating the size of the cell. For example, if you draw a
door/window assembly with a 14 ft. baseline and a 1 ft. frame on the left and
right, and you specify a fixed number of vertical cells, the cells do not appear
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equal in size. The first and last cells appear smaller because they include the
frame.

To make the cells equal in size, offset the start and end of the grid by the width
of the frame.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select a Divisions definition or click  to create a new one.
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7 Specify an offset for the grid.

Then…If you want to specify the dis-
tance between…

enter a value for Start Offset.the start point of the door/window
assembly baseline and the start of
the first cell in a horizontal grid

enter a value for End Offset.the end point of the door/window
assembly baseline and the end of
the last cell in a horizontal grid

enter a value for Bottom Offset.the baseline of the door/window
assembly and the start of the bot-
tom cell in a vertical grid

enter a value for Top Offset.the base height of the door/window
assembly and the end of the top
cell in a vertical grid

8 Click OK.

Removing a Division Definition from a Door and Window
Assembly Style

Use this procedure to remove a division definition that you no longer need.
You cannot remove a division definition that is currently assigned to a grid.
In addition, you cannot remove the default division definition, but you can
modify it.
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1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Divisions under Element Definitions.

6 Select the division definition that you want to remove.

7 Right-click and click Remove, or click  .

8 Click OK.

Defining Infills for Door and Window Assembly Cells
An infill defines the contents of a door/window assembly cell. A door/window
assembly cell can have the default simple panel or contain a nested grid, an
AEC Polygon, curtain wall unit, door or window style. The object styles you
use in infills must exist in the current drawing to be added to an infill
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definition. Panels typically represent glazing or other plain cladding, such as
stone or concrete.

NOTE Nested grids and no infill are options you select when assigning an infill to
a cell. They do not require infill definitions. For more information, see Creating a
Nested Grid for a Door and Window Assembly on page 1750 and Removing an Infill
from a Door and Window Assembly on page 1756.

You can define as many infills as you need and then use cell assignments to
specify the cells that use each infill. A default infill, which you can modify,
is used for all unassigned cells. For more information about cell assignments,
see Assigning Definitions to Door and Window Assembly Elements on page
1745.

NOTE Create infill definitions for a specific door/window assembly style. Those
definitions can be assigned only to grid cells in door/window assemblies of that
style.
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Materials

Styles use the materials of the object style assigned to each panel. For example,
if you specify an infill to use the Standard door style, the materials of that
infill are those designated in the door style.

Simple panels need materials assigned in the door/window assembly style.

If you do not use materials to control the display properties of infills, you can
specify their display properties in the door/window assembly style. The layer,
color, linetype, and other display properties of the Default Infill are applied
to all infills unless you create a custom display component for each infill
definition. Then you can control the display of each infill definition
independently. For more information, see Specifying the Display of Door and
Window Assemblies on page 1770.

Creating a Panel Infill for a Door and Window Assembly
Use this procedure to create a simple panel infill to represent basic cladding
materials in the door/window assembly, such as a stone wall panel, concrete
panel, metal panel, or glazing infill.

Because door/window assemblies can contain multiple infills, it is helpful to
use a naming convention for panel infills that indicates the infill location or
purpose within the door/window assembly. For example, L3-FL1- Stone Panel
identifies a stone panel in a third-level grid on Floor 1.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

1724 | Chapter 23   Door and Window Assemblies



NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.

6 Click  to create a new infill.

7 Enter a descriptive name for the infill.

8 Select Simple Panel for Infill Type.

9 Select an alignment for the infill.

For more information, see Specifying an Alignment for a Door
and Window Assembly Infill on page 1727.

10 Specify an offset value for the infill.

For more information, see Specifying an Offset for a Door and
Window Assembly Infill on page 1727.

11 Specify a thickness for the panel.

12 Click OK.

After you create an infill definition, you can assign it to any cell in a
door/window assembly grid. For more information, see Assigning Infills to
Door and Window Assembly Cells on page 1746.

Creating an Infill for Inserting an Object into a Door and Window
Assembly

Use this procedure to create a style infill to insert objects into a door/window
assembly. You can insert doors, windows, curtain wall units, and AEC Polygons
by defining a specific style of that object as an infill.

TIP After you insert an object in a cell, you can select that object independent of
the grid and access editing options for the object.

Because door/window assemblies can contain multiple infills, it is helpful to
use a naming convention for panel infills that indicates the infill location or
purpose within the door/window assembly. For example, L3-FL1-Stone Panel
identifies a stone panel in a third-level grid on Floor 1.
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NOTE The object styles you use in infills must exist in the current drawing to be
added to an infill definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.

6 Click  to create a new infill.

7 Enter a descriptive name for the infill.

8 Select Style for Infill Type.

The right side of the dialog box changes to display a tree view of
the object styles available for insertion into a door/window
assembly.

9 Select an object style.

There is a unique icon for each type of style, for example the door

style icon  and the curtain wall unit icon  . These icons also
are displayed next to the infill name at the top of the dialog box
to help you identify the type of infill.

10 Select an alignment for the infill.

For more information, see Specifying an Alignment for a Door
and Window Assembly Infill on page 1727.

11 Specify an offset value for the infill.

For more information, see Specifying an Offset for a Door and
Window Assembly Infill on page 1727.

12 Click OK.

After you create an infill definition, you can assign it to any cell in a
door/window assembly grid. For more information, see Assigning Infills to
Door and Window Assembly Cells on page 1746.
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Specifying an Alignment for a Door and Window Assembly Infill
Use this procedure to align an infill so that it is centered with the baseline of
the door/window assembly, in front of the baseline, or behind the baseline.
In Plan view, the front of a door/window assembly (drawn from left to right)
is below the baseline and the back is above the baseline.

Specifying Door/Window Assembly panel infill alignments

NOTE To move the infill away from the baseline, see Specifying an Offset for a
Door and Window Assembly Infill on page 1727.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.

6 Select an infill definition or click  to create a new one.

7 Select an alignment: front, center, or back.

8 Click OK.

Specifying an Offset for a Door and Window Assembly Infill
Use this procedure to specify an offset for a door/window assembly infill. By
default, infills are centered on the door/window assembly baseline. If your
design requires that the infill be aligned with frame edges or some other part
of the door/window assembly, you can specify an offset for the infill.
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You can also edit individual style-based infills directly in the drawing. The
selected infill has Flip grips in both the X and Y directions so that you can
change the orientation of the infill.

Specify Door/Window Assembly infill panel offsets

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.

6 Select an infill definition or click  to create a new one.
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7 Enter an offset distance.

In plan view, positive numbers offset the infill above the baseline
and negative numbers offset the infill below the baseline. The
offset is also affected by the selected alignment for the infill.

8 Click OK.

Removing an Infill Definition from a Door and Window Assembly
Style

Use this procedure to delete an infill definition that you no longer need.
However, you cannot remove an infill definition that is currently assigned to
a cell in the primary grid or any nested grid. Also, you cannot remove the
default infill definition, but you can modify it as needed.

NOTE For information about removing an infill from a cell, see Removing an Infill
from a Door and Window Assembly on page 1756.

Removing panel infill from a Door/Window Assembly

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Infills under Element Definitions.
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6 Select the unneeded infill definition, and click  (Remove).

7 Click OK.

Defining Door and Window Assembly Frames
All door/window assembly grids, including the primary grid, can have frame
definitions. The door/window assembly frame is represented by the outer
edges of a grid. The overall frame size is determined by the length and height
of the door/window assembly grid. You can define a frame by specifying a
width and depth or by selecting a profile.

Specifying Door/Window Assembly frame width and depth

You create frame definitions for a specific door/window assembly style. Those
definitions can be assigned only to frames in door/window assemblies of that
style. You can create as many frame definitions as you want and then assign
the definitions to the frame edges as needed. If you have nested grids, each
grid has its own frame. There is a default frame definition that you can modify
and assign as needed. Unassigned frame edges are not displayed. For more
information, see Assigning Definitions to Door and Window Assembly Frames
on page 1759.
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TIP Using Style Manager, you can copy a mullion definition and use it as a frame
definition. Select the mullion definition and drag it to Frames in the left pane.

Materials and Display Properties for Frames

If you do not use materials to control the display properties of frames, you
can specify their display properties in the door/window assembly style. The
layer, color, linetype, and other display properties of the default frame are
applied to all frames unless you create a custom display component for each
definition. You can then control the display of each frame definition
independently. For more information, see Specifying the Display of Door and
Window Assemblies on page 1770.

NOTE You create frame definitions for a specific door/window assembly style and
those definitions can be assigned only to frames in door/window assemblies of
that style.

Defining a Door and Window Assembly Frame by Width and
Depth

Use this procedure to define a frame by specifying its width and depth. The
overall frame size is determined by the length and height of the door/window
assembly grid.

Because door/window assemblies can contain multiple styles with different
frames, it is helpful to use a naming convention for grid frames that indicates
the grid location or purpose within the door/window assembly. For example,
L3-FL1- Metal Frame identifies a metal frame in a third-level grid on Floor 1.

TIP To remove the frame edge and have the infill adjust to fill the space occupied
by the frame, create a frame definition with both width and depth set to zero.
Then assign that definition to the frame edge that you want to remove. This is
necessary for the infill to be mitered as it would be for a butt-glazed condition.
For more information, see Removing a Frame Edge from a Door and Window
Assembly on page 1763.
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Specifying a Door/Window Assembly frame width and depth of zero

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Frames under Element Definitions.

6 Click  to create a new frame definition.

7 Enter a descriptive name for the frame.

8 Specify a width and depth for the frame.

9 Specify any offsets.

For more information, see Specifying Offsets for a Door and
Window Assembly Frame on page 1735.

10 Click OK.

After you create a frame definition, you can assign it to any frame in a
door/window assembly. For more information, see Assigning Definitions to
Door and Window Assembly Frames on page 1759.

Creating a Profile for a Door and Window Assembly Frame
Use this procedure to create a profile that you can use to define the shape of
a door/window assembly frame. You can then extrude the profile to create a
door/window assembly frame.
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The height and the width of the polyline you use to create the profile define
the default height and width of the door/window assembly frame. The insertion
point of the profile is aligned with the centroid of the frame.

1 Draw a closed polyline of the height and the depth needed for
the resulting door/window assembly frame.

2 Select the polyline, right-click, and click Convert to ➤ Profile
Definition.

3 Enter c (Centroid) for the insertion point of the profile.

The insertion point of the profile is aligned with the centroid of
the frame.

4 Enter a name for the profile, and click OK.

You can now use the profile as a door/window assembly frame.
For more information, see Defining a Door and Window Assembly
Frame Using a Profile on page 1733.

Defining a Door and Window Assembly Frame Using a Profile
Use this procedure to create a frame element definition from a profile. If you
do not want a straight edge to your frame, you can use a profile to define
edges with curves, jags, or any other shape you require.

You can also use an edit in-place routine to create a frame from a profile. For
more information, see Creating a Frame or Mullion Edge from a Polyline or
Profile Using In-Place Editing on page 1793.

It is helpful to use a naming convention for profiles that indicates the grid
location or purpose within the door/window assembly. For example, L3-FL1-
Metal Frame identifies a metal frame in a third-level grid on Floor 1.
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Specifying default and profile-based Door/Window Assembly frames

NOTE The insertion point of the profile is aligned with the centroid of the frame.

1 Create the profile to use for the frame.

For more information, see Creating a Profile for a Door and
Window Assembly Frame on page 1732.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

4 Select a door/window assembly style.

5 Click the Design Rules tab.

6 In the left pane, select Frames under Element Definitions.

7 Select a frame definition or click  to create a new one.

8 Enter a descriptive name for the frame.

9 Specify a width and depth for the frame edge.
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These dimensions are used to calculate the center point of the
edge for aligning the profile and also to specify a boundary for
the adjacent infill.

10 Select Use Profile.

NOTE The Profile options are available only when you have profiles
in the current drawing.

11 Select a profile from the list.

By default, the profile is inserted using the same width and depth
with which it was created.

12 To adjust the size of the profile to fit within the width or depth
dimension of the frame edge, select Auto-Adjust Profile Width or
Depth.

13 To mirror the profile along the X or Y axis, select X or Y for Mirror
In.

14 To rotate the profile, specify a rotation angle.

15 Specify any offsets.

For more information, see the next section Specifying Offsets for
a Door and Window Assembly Frame on page 1735.

16 Click OK.

After you create a frame definition, you can assign it to any frame in a
door/window assembly. For more information, see Assigning Definitions to
Door and Window Assembly Frames on page 1759.

Specifying Offsets for a Door and Window Assembly Frame
Use this procedure to define the distance that a door/window assembly frame
is from the floor line, roof line, or baseline. By default, the outside edges of
the frame align with start and end of the baseline and the start and end of
the base height. When you adjust the width of the frame, the frame expands
inward. However, you can use offsets to expand or contract the frame away
from these default limits or to shift the frame away from the baseline in either
the X or Y direction.

DescriptionOffset

Positive X offset moves the frame edge
outward beyond the end of the door/win-

X
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DescriptionOffset

dow assembly, while a negative X offset
moves the frame edge inward toward the
center of the door/window assembly.

In Plan view, a positive Y offset moves the
frame edge above the baseline, while a

Y

negative Y offset moves the frame below
the baseline.

Negative Start offset lengthens the frame
beyond the start point, while a positive

Start

Start offset shortens the frame. The start
point for vertical edges is the baseline, and
the start point for horizontal edges (drawn
left to right) is the left side.

Negative End offset lengthens the frame
beyond the end point, while a positive End

End

offset shortens the frame. The end point
for vertical edges is the base height, and
the end point for horizontal edges (drawn
left to right) is the right side.

TIP To quickly identify the start and end of a door/window assembly, select the
door/window assembly. The Reverse Direction grip is displayed near the center
of the door/window assembly and points toward the end of the door/window
assembly.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Frames under Element Definitions.
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6 Select a frame definition or click  to create a new one.

7 Specify an offset distance for the frame edge: X, Y, Start, or End.

8 Click OK.

Removing a Frame Definition from a Door and Window Assembly
Style

Use this procedure to remove a frame definition that you no longer need. You
cannot remove a frame definition if it is currently assigned to a frame edge,
but you can remove it if it is assigned as an override to a frame edge. Also,
you cannot remove the default frame definition, but you can modify it as
needed.

NOTE For information about removing a frame edge, see Removing a Frame Edge
from a Door and Window Assembly on page 1763.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Frames under Element Definitions.

6 Select the unneeded frame definition from the list, and click 
(remove frame).

7 Click OK.

Defining Door and Window Assembly Mullions
All door/window assembly grids, including the primary grid, can have mullion
definitions. The mullions of a door/window assembly are the edges between
the grid cells. You can define the mullions by specifying a width and depth
or by selecting a profile from which the mullion is extruded.
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Because door/window assemblies can contain multiple nested grids with
different mullions, it is helpful to use a naming convention for grid mullions
that indicates the grid location or purpose within the door/window assembly.
For example, L3-FL1- Window Mullion identifies a mullion for a window in
a third-level grid on Floor 1.

Specifying default and profile-based Door/Window Assembly mullions

You create mullion definitions for a specific door/window assembly style and
those definitions can be assigned only to mullions in door/window assemblies
of that style. You can create as many mullion definitions as you want and
then assign the definitions to mullions as needed. If you have nested grids,
each grid has its own mullions. A default mullion definition, which you can
modify and assign as needed, is used for any unassigned mullions. For more
information, see Assigning Definitions to the Mullions of a Door and Window
Assembly on page 1763.

TIP Using Style Manager, you can copy a frame definition and use it as a mullion
definition. Select the frame definition and drag it to Mullions in the left pane.

Materials and Display Properties for Mullions

If you do not use materials to control the display properties of mullions, you
can specify their display properties in the door/window assembly style. The
layer, color, linetype, and other display properties of the default mullion are
applied to all mullions unless you create a custom display component for each
definition. You can then control the display of each mullion definition
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independently. For more information, see Specifying the Display of Door and
Window Assemblies on page 1770.

Defining Door and Window Assembly Mullions by Width and
Depth

Use this procedure to define mullions by specifying a width and a depth.

Because door/window assemblies can contain multiple nested grids with
different mullions, it is helpful to use a naming convention for grid mullions
that indicates the grid location or purpose within the door/window assembly.
For example, L3-FL1- Window Mullion identifies a mullion for a window in
a third-level grid on Floor 1.

Specifying Door/Window Assembly mullion width and depth

TIP To remove mullions for butt glazing, create a definition with both width and
depth set to zero. Then assign that definition to the mullions that you want to
remove. For more information, see Removing Mullions from a Door and Window
Assembly Grid on page 1766.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Mullions under Element Definitions.
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6 Click  to create a new mullion definition.

7 Enter a descriptive name for the mullion definition.

8 Specify a width and depth for the mullion definition.

9 Specify any offsets.

For more information, see Specifying Offsets for the Mullions of
a Door and Window Assembly on page 1742.

10 Click OK.

After you create a mullion definition, you can assign it to any mullion in a
door/window assembly. For more information, see Assigning Definitions to
the Mullions of a Door and Window Assembly on page 1763.

Creating a Profile for Door and Window Assembly Mullions
Use this procedure to create a profile that you can use to define the shape of
a door/window assembly mullion definition. You can then extrude the profile
to create mullions from it.

The height and the width of the polyline you use to create the profile define
the default height and width of the door/window assembly mullion. The
insertion point of the profile is aligned with the centroid of the mullion.

1 Draw a closed polyline of the height and the depth needed for
the resulting door/window assembly mullion.

2 Select the polyline, right-click, and click Convert to ➤ Profile
Definition.

3 Enter c (Centroid) for the insertion point of the profile.

The insertion point of the profile is aligned with the centroid of
the mullion.

4 Enter a name for the profile, and click OK.
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You can now use the profile as a door/window assembly mullion.
For more information, see Defining the Mullions of a Door and
Window Assembly Using a Profile on page 1741.

Defining the Mullions of a Door and Window Assembly Using a
Profile

Use this procedure to create a mullion element definition from a profile. If
you do not want a straight edge to your mullions, you can use a profile to
define mullions with curves, jags, or any other shape.

You can also use an edit in-place routine to create a mullion from a profile.
For more information, see Creating a Frame or Mullion Edge from a Polyline
or Profile Using In-Place Editing on page 1793.

Because door/window assemblies can contain multiple nested grids with
different mullions, it is helpful to use a naming convention for grid mullions
that indicates the grid location or purpose within the door/window assembly.
For example, L3-FL1- Window Mullion identifies a mullion for a window in
a third-level grid on Floor 1.

NOTE The insertion point of the profile is aligned with the centroid of the mullion.

1 Create the profile to use for the mullion.

For more information, see Creating a Profile for Door and Window
Assembly Mullions on page 1740.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

4 Select a door/window assembly style.

5 Click the Design Rules tab.

6 In the left pane, select Mullions under Element Definitions.

7 Select a mullion definition or click  to create a new one.
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8 Enter a descriptive name for the mullion definition.

9 Specify a width and depth for the mullion definition.

These dimensions are used to calculate the center point of the
mullion for aligning the profile, and also to specify a boundary
for the adjacent infill.

10 Select Use Profile.

NOTE The Profile options are available only when you have profiles
in the current drawing.

11 Select a profile from the list.

By default, the profile is inserted using the same width and depth
with which it was created.

12 To adjust the size of the profile to fit within the width or depth
dimension of the mullion, select Auto-Adjust Profile Width or
Depth.

13 To mirror the profile along the X or Y axis, select X or Y for Mirror
In.

14 To rotate the profile, specify a rotation angle.

15 Specify any offsets.

For more information, see Specifying Offsets for the Mullions of
a Door and Window Assembly on page 1742.

16 Click OK.

After you create a mullion definition, you can assign it to any mullion in a
door/window assembly. For more information, see Assigning Definitions to
the Mullions of a Door and Window Assembly on page 1763.

Specifying Offsets for the Mullions of a Door and Window
Assembly

Use this procedure to define mullions that are offset from the start or end of
the door/window assembly to lengthen or shorten the edge or offset in the X
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or Y direction to shift the edge. For example, you might want to represent
butt glazing by offsetting the mullions to be behind glass panel infills.

DescriptionOffset

For vertical mullions, a positive X offset
moves the mullions toward the end of the

X

door/window assembly, while a negative
X offset moves the mullions toward the
start of the door/window assembly. For
horizontal mullions, a positive X offset
moves the mullions toward the top of the
door/window assembly, while a negative
X offset moves the mullions toward the
bottom of the door/window assembly.

In Plan view, a positive Y offset moves the
mullions above the baseline, while a negat-

Y

ive Y offset moves the mullions below the
baseline.

Negative Start offset lengthens the mullions
beyond the start point, while a positive
Start offset shortens the mullions.

Start

Negative End offset lengthens the mullions
beyond the end point, while a positive End
offset shortens the mullions.

End

TIP To quickly identify the start and end of a door/window assembly, select the
door/window assembly. The Reverse Direction grip is displayed near the center
of the door/window assembly and points toward the end of the door/window
assembly.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .
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3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Mullions under Element Definitions.

6 Select a mullion definition or click  to create a new one.

7 Specify an offset distance for the X, Y, Start, or End.

8 Click OK.

Removing a Mullion Definition from a Door and Window
Assembly Style

Use this procedure to remove a mullion definition that you no longer need.
You cannot remove a mullion definition if it is assigned to a mullion, but you
can remove it if it is assigned as an override to a mullion. Also, you cannot
remove the Default Mullion definition, but you can modify it as needed.

NOTE For information about removing mullions from between cells, see Removing
Mullions from a Door and Window Assembly Grid on page 1766.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select Mullions under Element Definitions.

1744 | Chapter 23   Door and Window Assemblies



6 Select the unneeded mullion definition from the list, and click

 (remove mullion).

7 Click OK.

Assigning Definitions to Door and Window Assembly Elements
After you’ve created element definitions for a door/window assembly style,
you can assign those definitions to each of the door/window assembly element
types: divisions, cell infills, frames, and mullions.

By default, one definition is assigned to all elements of a particular type.
However, you can assign definitions to individual elements as well. For
example, all cells in the grid are assigned the default infill. But you can create
a new cell assignment, select a different infill, and then specify the cells to
use that infill.

Assignment list

For more information about element definitions, see Creating Element
Definitions for a Door and Window Assembly Style on page 1707.
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Assigning a Division to a Door and Window Assembly Grid
Divisions define the grid orientation (whether the direction of the grid cells
and mullions is horizontal or vertical) and the division type (number and size
of cells).

After you define a division, you can assign it to the primary grid or to nested
grids. Nested grids are created by selecting Nested Grid as the cell assignment.
For more information, see Working with Nested Grids in Door and Window
Assemblies on page 1748.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select the grid you want to assign rules to.

The name of the grid you select is displayed in the table under
the Division Assignment row.

TIP To rename a grid, select it, click Rename, and enter a new name.

6 Click the Element column for that grid and select a division
definition from the list.

7 Click OK.

Assigning Infills to Door and Window Assembly Cells
An infill defines the contents of a door/window assembly cell. A door/window
assembly cell can have the default simple panel or contain a nested grid, an
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AEC Polygon, curtain wall unit, door or window style. The object styles you
use in infills must exist in the current drawing to be added to an infill
definition. Panels typically represent glazing or other plain cladding, such as
stone or concrete.

Specifying Door/Window Assembly infill definitions

Cell Assignments

A cell assignment defines the infill definition used for cells. You can use one
cell assignment to assign the same infill to all cells, or you can create multiple
cell assignments to assign different infills to different cells.

Do not assign multiple definitions to the same cell. If you do, the last definition
assigned to the cell is used.

Default Cell Assignment

The default cell assignment is used by all unassigned cells. You can modify
the default assignment to be any type of infill, but you cannot delete the
default cell assignment.
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You may want to modify the default cell assignment to use the infill definition
that occurs most frequently in your design. Any cells not assigned to other
infills then use this infill definition.

Materials and Display Properties of Infills

The layer, color, linetype, and other display properties of the default infill are
applied to all infills unless you assign materials to the infills you created or
you create a custom display component for each definition. Then you can
control the display of each infill definition independently. For more
information, see Specifying the Display of Door and Window Assemblies on
page 1770.

Working with Nested Grids in Door and Window Assemblies
Each door/window assembly grid is one dimensional with either a horizontal
or vertical division. By nesting grids in the door/window assembly style, you
can create a variety of patterns from simple to complex.

Specifying Door/Window Assembly nested grid locations

Simple Primary Grids

When you nest grids, you start with one primary grid. Then each cell in the
primary grid can be filled with another grid. For example, the following
illustration has a horizontal primary grid with four cells. You can nest a vertical
grid in each horizontal cell to create a simple 2D grid.

Specifying Door/Window Assembly cell divisions 1
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The previous illustration shows all cells in the grid with the same cell
assignment—a vertical division. But each cell in a grid is independent and
can have a separate assignment. For example, the following illustration shows
one cell in the primary grid that contains another horizontal grid, the next
cell contains a vertical grid with three divisions, and the next cell contains a
vertical grid with six divisions.

Specifying Door/Window Assembly cell divisions 2

Multiple Nested Grids

You can continue to nest grids to create multiple levels. For example, the
following illustrations show the Standard door/window assembly style grid,
the same grid with a nested grid in one cell of the secondary grid, and the
same grid again with nested grids in all cells of the secondary grid.

Specifying a nested grid in a door/window assembly
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Defining Nested Grids

You can define nested grids on the Design Rules tab of the Door/Window
Assembly Style Properties dialog box. The tree on the left side of the tab lists
the grids. There is always one primary grid. The primary grid can have one or
more secondary grids. Each secondary grid can have one or more tertiary grids
and so on.

TIP To quickly create nested grids in all cells, change the default cell assignment
to Nested Grid. If you want multiple levels of nesting, be sure to change the default
cell assignment for each grid. For more information, see Creating a Nested Grid
for a Door and Window Assembly on page 1750.

Each grid has its own cell assignments. You assign cells to contain another
grid, a panel infill, or an object such as a door or window. For more
information, see Assigning Infills to Door and Window Assembly Cells on
page 1746.

Creating a Nested Grid for a Door and Window Assembly
Use this procedure to create a nested grid, which is a grid within a grid. Each
nested grid has its own division rules, cell assignments, frame, and mullions.
By default, the frame is off for nested grids.

For more information, see Working with Nested Grids in Door and Window
Assemblies on page 1748.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .
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2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to create a
nested grid.

6 Click  (new cell assignment).

A new cell assignment is displayed in the list of cell assignments.

7 Right-click the default name, click Rename, and enter a descriptive
name for the assignment.

8 Select Nested Grid in the Element column.

A new grid is added to the list of grids in the left pane of the dialog
box. If you are editing the primary grid, the new grid is added at
the secondary level. If you are editing a grid at the secondary level,
the additional grid is placed at the tertiary level, and so on.

Creating a nested grid

New nested grid in tree
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NOTE To rename a grid, select it in the right pane, right-click, and
click Rename, and enter a new name.

9 Specify the cells to contain this nested grid.

For more information, see Specifying Which Door and Window
Assembly Cells Use a Cell Assignment on page 1757.

10 Click OK.

Filling a Door and Window Assembly Cell with a Simple Panel
Use this procedure to fill a door/window assembly cell with a simple panel.
Simple panels are generally used to represent basic cladding materials in the
door/window assembly, such as a stone wall panel or a concrete panel.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to assign a
simple panel.

6 Click  (new cell assignment).

A new cell assignment is displayed in the list of cell assignments.

7 Right-click the default name, click Rename, and enter a descriptive
name for the assignment.

8 Select an infill that defines a simple panel.

9 Specify the cells to contain this simple panel.

For more information, see Specifying Which Door and Window
Assembly Cells Use a Cell Assignment on page 1757.

10 Click OK.
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Inserting a Door or Window into a Door and Window Assembly
Use this procedure to add doors and windows to door/window assemblies.
For more information, see Defining Infills for Door and Window Assembly
Cells on page 1722.

1 Open the tool palette that you want to use, and select a door,
window or door/window assembly.

NOTE Alternatively, on the Home tab ➤ Build panel, click one of the

following: Window  , Door drop-down ➤ Door  , or Door

drop-down ➤ Door/Window Assembly  .

2 Select the door/window assembly in which to insert the door or
window.

You can move or hide the Properties palette to expose more of
the drawing area.

3 Select the door/window assembly cell marker for the cell in which
to insert the door or window.

The Add Infill worksheet displays.

4 Select the insertion method for the door or window:

Then…If you want to…

select Add as Cell Assignment.add the door or window
as a cell assignment and
have all door/window as-
semblies using the same
style display the same
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Then…If you want to…

object added to a corres-
ponding cell

select Add as Cell Override.add the door or window
exclusively to the selected
door/window assembly

If a door or window of the style you selected already exists in your
drawing, Existing Infill is selected by default.

5 Select the type of infill for the door or window:

Then…If you selected…

Click OK.Add as Cell Assignment
and you want to insert a
door or window of the
existing style, Existing In-
fill is selected by default.

select New Infill, enter a name for the object
and click OK.

Add as Cell Assignment
and you want to insert a
door or window of a dif-
ferent style than exists in
your drawing

Click OK.Add as Cell Override and
you want to insert a door
or window of the existing
style and not modify the
edge of the frame sur-
rounding the object

select New Infill, enter a name for the object
and click OK.

Add as Cell Override and
you want to insert a door
or window of a different
style than exists in your
drawing and not remove
an edge of the frame sur-
rounding the object

select Top, Bottom, Left, or Right for Override
Frame Removal and click OK.

Add as Cell Override and
you want to insert a door
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Then…If you selected…

or window of the existing
style and remove an edge
of the frame surrounding
the object

select New Infill and enter a name for the
object. Then select Top, Bottom, Left, or Right
for Override Frame Removal and click OK.

Add as Cell Override and
you want to insert a door
or window of a different
style than exists in your
drawing and remove an
edge of the frame sur-
rounding the object

6 Press ENTER.

Inserting an Object into a Door and Window Assembly Cell
Use this procedure to insert objects, such as doors, windows, curtain wall
units, and AEC Polygons, into a door/window assembly cell. Door/window
assembly cells can contain these objects when you create infill definitions
that use them. For more information, see Creating an Infill for Inserting an
Object into a Door and Window Assembly on page 1725.

TIP After you insert an object in a cell, you can select that object independent of
the grid, and access editing options for the object. For more information, see
Editing Objects Anchored in Door and Window Assemblies on page 1824.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to insert objects.
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6 Click  (new cell assignment).

A new cell assignment is displayed in the list of cell assignments.

7 Right-click the default name, click Rename, and then enter a
descriptive name for the assignment.

8 Select an infill that uses an object style.

9 Specify the cells to contain this object.

For more information, see Specifying Which Door and Window
Assembly Cells Use a Cell Assignment on page 1757.

10 Click OK.

Removing an Infill from a Door and Window Assembly
Use this procedure to remove the infill of a cell and leave the cell empty. To
do this, use None as the element definition. Using None also removes any
frame edges that border the cell, but it does not affect the mullions.

Removing infill from a Door/Window Assembly cell

To remove the infill of a cell

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.
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5 In the left pane, select the grid that contains the cells you want
to assign to None.

6 Select an existing cell assignment or create a new one.

7 Select None under the Element column.

8 Specify the cells to contain the None infill.

For more information, see Specifying Which Door and Window
Assembly Cells Use a Cell Assignment on page 1757.

9 Click OK.

Specifying Which Door and Window Assembly Cells Use a Cell
Assignment

When you create a cell assignment you need to specify the cells in the grid to
use that assignment. There are two options for selecting cells:

■ Use Location to insert the infill into the start, middle, or end cells of a
vertical grid or into the bottom, middle, or top cells of a horizontal grid.
If there is an even number of cells (four or more), Middle refers to the two
cells in the middle of the grid. If there is an odd number of cells (three or
more), Middle refers to one cell in the middle of the grid.

Specifying Door/Window Assembly infill by location

■ Use Index to insert the infill into specific cells based on cell numbers. Cells
are numbered from start to end or bottom to top. For example, typing 1,
2, 3 would place the infill in the first, second and third cells.
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Specifying Door/Window Assembly infill by index

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select a grid.

6 Select a cell assignment:

Then…If you selected…

click the Used In column, and click

 . Select the cells you want to
use this assignment, and click OK.

Location for Type

enter the cell numbers separated
by commas in the Used In column.

Index for Type

For vertical grids, cells are
numbered from start to end and for
horizontal grids, cells are numbered
from bottom to top.

NOTE Do not assign multiple definitions to a cell. If you do, the last
definition assigned to the cell is used.
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7 Click OK.

Any cells that are not assigned a specific cell assignment use the
default infill.

Removing an Assignment from a Door and Window Assembly
Style

Use this procedure to remove cell assignments, frame assignments, and mullion
assignments from a door/window assembly style. You cannot remove default
assignments, but you can modify them to suit your needs.

NOTE Each grid requires one division assignment, therefore you cannot remove
the division assignment. You can change the division element used for the division
assignment.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select the grid from which you want to remove
an assignment.

6 Select a cell assignment, frame assignment, or a mullion
assignment.

7 Click  (remove assignment).

8 Click OK.

Assigning Definitions to Door and Window Assembly Frames
The door/window assembly frame is represented by the outer edges of the
primary grid. Each nested grid has its own frame that is defined separately
from the primary grid frame. By default, the frames of nested grid are turned
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off. For more information about nested grids, see Working with Nested Grids
in Door and Window Assemblies on page 1748.

Frame Assignments

A frame assignment defines the frame definition used by each frame edge.
You can use one frame assignment to assign the same definition to all four
edges of the frame, or you can create multiple frame assignments to assign
different definitions to different edges of the frame. Unassigned edges are not
displayed.

Default Frame Assignment

Do not assign multiple definitions to the frame edge. If you do, the last
definition assigned to the edge is used.

There is a default frame assignment and you can select the frame edges it
applies to. You can modify the default assignment to use any frame definition,
but you cannot delete the default frame assignment.

Materials and Display Properties of Frames

The layer, color, linetype, and other display properties of the default frame
are applied to all frame edges unless you assign materials to the frame
definition or create a custom display component for each definition. Then
you can control the display of each frame definition independently. For more
information, see Specifying the Display of Door and Window Assemblies on
page 1770.

Adding a New Frame Assignment to a Door and Window
Assembly Grid

Use this procedure to add a frame assignment to a door/window assembly. To
assign different definitions to different frame edges, you need multiple frame
assignments.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.
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NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to create a new
frame assignment.

6 Click  (new frame assignment).

A new frame assignment is displayed in the list of frame
assignments.

7 Right-click the default name, click Rename, and then enter a
descriptive name.

8 Under Element, select a frame definition.

9 Specify the sides of the frame to use this frame assignment.

For more information, see Specifying Which Door and Window
Assembly Edges Use a Frame Assignment on page 1761.

10 Click OK.

Specifying Which Door and Window Assembly Edges Use a Frame
Assignment

When you create a frame assignment, you need to specify the edges of the
frame to use that assignment.

Frame edges that are not assigned a frame definition are not displayed.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.
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NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select a grid.

6 Select a frame assignment.

Location is the only way to specify the frame edges.

7 Click the Used In column, and then click the  .

8 Select the edges that you want to use this assignment - Left, Right,
Top, or Bottom - and click OK.

Specifying different Door/Window Assemblies frame definitions

NOTE Do not assign multiple definitions to the same frame edge
because only the last definition assigned to the edge is used.

9 Click OK.
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Removing a Frame Edge from a Door and Window Assembly
Use this procedure to remove a frame edge from a door/window assembly.
There are three ways to remove a frame edge:

■ Set the width and depth of the edge to zero.

■ Leave the edge unassigned.

■ Specify None as an override to the edge assignment.

The first two methods remove the frame edge and expand the adjacent infills
into the space occupied by the edge.

By specifying None as an override, the frame edge is not displayed, but the
adjacent infill is not expanded into the space the edge occupied.

For information about setting the width and depth to zero, see Defining a
Door and Window Assembly Frame by Width and Depth on page 1731.

For information about leaving the edge unassigned, see Specifying Which
Door and Window Assembly Edges Use a Frame Assignment on page 1761.

For information about overriding the edge, see Creating a Frame or Mullion
Override on page 1790.

Assigning Definitions to the Mullions of a Door and Window
Assembly

The mullions of a door/window assembly are the edges between the grid cells.
The primary grid and each nested grid have mullions that are defined separately
from the other grids. For more information about nested grids, see Working
with Nested Grids in Door and Window Assemblies on page 1748.

Specifying mullions for Door/Window Assembly nested grids
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Mullion Assignments

A mullion assignment defines the definition used by each mullion. You can
use one assignment to define all mullions, or you can create multiple
assignments and assign different definitions to different mullions in any grid.

Do not assign multiple definitions to the same mullion because only the last
definition assigned to the mullion is used.

Default Mullion Assignment

There is a default mullion assignment used by all unassigned mullions. You
can modify the default assignment to be any mullion definition, but you
cannot delete the default mullion assignment.

Adding a New Mullion Assignment to a Door and Window
Assembly Style

Use this procedure to add a new mullion assignment to a door/window
assembly style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to create a new
mullion assignment.

6 Click  (new mullion assignment).
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A new mullion assignment is displayed in the list of mullion
assignments.

7 Right-click the default name, click Rename, and then enter a
descriptive name.

8 Under Element, select a mullion definition.

9 Specify the mullions to use this assignment.

For more information, see Specifying Which Door and Window
Assembly Mullions Use an Assignment on page 1765.

10 Click OK.

Specifying Which Door and Window Assembly Mullions Use an
Assignment

When you create a mullion assignment you need to specify the mullions in
the grid to use that assignment. There are two options for selecting mullions:

■ Use Location to assign a definition to the start, middle, or end mullions
of a vertical grid or the bottom, middle, or top mullions of a horizontal
grid. If there is an even number of mullions (four or more), Middle refers
to the two mullions in the middle of the grid. If there is an odd number
of mullions (three or more), Middle refers to the one mullion in the middle
of the grid.

■ Use Index to assign a definition to specific mullions based on mullion
numbers. Mullions are numbered from left to right or bottom to top. For
example, typing 1, 2, 3 would assign the definition to the first, second,
and third mullions.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.
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NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select a grid.

6 Select an existing mullion assignment or click  to create a
new one.

7 Select a mullion assignment:

Then…If you selected…

click the Used In column, and click

 . Select the mullions you want

Location

to use this assignment, and click
OK.

enter the mullion numbers separ-
ated by commas in the Used In

Index

column. For vertical grids, mullions
are numbered from start to end
and, for horizontal grids, mullions
are numbered from bottom to top.

NOTE Do not assign multiple definitions to the same mullion because
only the last definition assigned to the mullion is used.

8 Click OK.

Any mullions that are not assigned a specific mullion assignment
use the default mullion definition.

Removing Mullions from a Door and Window Assembly Grid
Use this procedure to remove a mullion from the door/window assembly. You
can create a mullion definition whose edge width and depth are zero. Adjacent
infills expand to fill in the space that was occupied by the mullion. This is an
effective way to represent butt glazing.
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Removing a mullion from Door/Window Assembly grid

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the Design Rules tab.

5 In the left pane, select the grid in which you want to remove a
mullion.

6 Create a new mullion assignment, and enter 0 (zero) for the width
and depth.

For more information, see Defining Door and Window Assembly
Mullions by Width and Depth on page 1739.

7 Under Mullion Assignments, select the mullion definition you
created for mullion edges of any mullion assignment where you
want to remove the mullions.

For more information, see Specifying Which Door and Window
Assembly Mullions Use an Assignment on page 1765.

8 Click OK.

Specifying the Materials of a Door and Window Assembly Style
A door/window assembly consists of a number of components whose display
properties can be determined by the materials assigned to each component.
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When you assign materials to a door/window assembly style, you assign one
material to each display component of the door/window assembly. For
example, you assign a wood material to the frame and a glass material to the
glass inset. You assign materials to components in each display representation
where you want the materials to be used.

If you want to use the display properties of the door/window assembly style,
instead of using material display properties, you can turn off the material
assignments in the display properties of the door/window assembly style.

Material definitions consist of display components that correspond to
component types of objects. For example, the Linework component of a
material is used for all linework in plan view. The Surface Hatch component
of a material is used to hatch all object surfaces in three dimensional (3D)
model views and in elevations.

Door and Window Assembly Materials and Display Components
The following table identifies the material component that corresponds to
each door/window assembly component in the specified views.

Material ComponentDoor/Window Assembly Component

Plan, Plan High Detail, Plan Low Detail,
Screened, Reflected Plan

LineworkDefault Infill

LineworkDefault Frame

LineworkDefault Mullion

LineworkDefault Infill Hatch

LineworkDefault Frame Hatch

LineworkDefault Mullion Hatch

Model

3D BodyDefault Infill

3D BodyDefault Frame
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Material ComponentDoor/Window Assembly Component

3D BodyDefault Mullion

Assigning Materials to a Door and Window Assembly Style
Use this procedure to assign materials to the individual components of a
door/window assembly style. When you assign a material to a door/window
assembly component, the component uses the display properties of the
material instead of the style display properties.

You can assign a material to any physical component of the door/window
assembly. Custom components and components that are only symbolic
graphics do not use materials for their display properties. For example, the
frame, mullion, and infill are physical components of a door/window assembly.
The cell marker is a symbolic component.

NOTE If a material assignment does not determine the display properties of a
door/window assembly component, you can change the display properties of the
door/window assembly style as described in Specifying the Display of Door and
Window Assemblies on page 1770.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select By Material for any component to which you want to assign
a material, and click OK.
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If the setting for By Material is not available, the display of this
component cannot be determined by a material.

9 Click the Materials tab.

10 Select the component you want to change, select the value for
Material Definition, and select a different material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Although you can edit a material definition from this
dialog box, any changes you make to the material definition apply
to all objects that are assigned the material.

11 Click OK.

Specifying the Display of Door and Window Assemblies
The display of a door/window assembly depends on the direction from which
you view the door/window assembly. In plan view, the door/window assembly
object is displayed as parallel lines with vertices marking the grid lines, as an
architect would typically draw a door/window assembly. In 3D view, the
door/window assembly object is displayed as it would appear in the real world,
with surfaces showing length, thickness, and height. You control what you
want to display in each particular view.

Element Definitions and Custom Display Components

By default, the display of all infills, frames, and mullions is controlled by the
display properties of the default infill, default frame, and default mullion.
However, you can add individual element definitions as components with
separate display properties. For example, if you define two infills called stone
panel and glass panel, by default they are both controlled by the default infill
display properties. But you can add each definition as a new display component
and then control the display properties separately.

NOTE The component name in the Custom Display Component dialog box must
match the name of element definition in the Design Rules tab. Otherwise, the
element definition does not display properly.

For more information about the display system, see Display System on page
791.
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Materials and Display Properties

You can use materials to control the display of both default and custom infills,
frames, and mullions. When you assign materials to the element definitions
you create, you do not need to define these definitions as custom display
components. For more information, see Specifying the Materials of a Door
and Window Assembly Style on page 1767.

Adding Door and Window Assembly Element Definitions as
Display Components

Use this procedure to add door/window assembly element definitions. Before
you can control the display properties of door/window assembly elements
according to the definition assigned to the element, you must create display
components for each element definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select the door/window assembly style that you want to change.

4 In the Door/Window Assembly Style Properties dialog box, click
the Display Properties tab.

5 Click Edit Display Properties  .

6 Click the Other tab, and then click Add.

NOTE If you click the Custom Plan Components tab, the Custom
Display Component dialog box is similar, except that you do not
specify the Z insertion point and Z offset for the custom graphic.

7 Select Infill, Frame, or Mullion for Component Type.

8 Enter a name for Component Name, or click Select Element and
select an element from the list.

9 Click OK.

10 Click the Layer/Color/Linetype tab.
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The element definition that you added is displayed in the list of
components.

11 Click the Other tab to continue adding element definitions, or
click OK twice.

Specifying the Layer, Color, and Linetype of a Door and Window
Assembly Style

Use this procedure to change the following display properties of the
components of an individual door/window assembly:

■ Visibility (component is on or off)

■ By Material

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select the door/window assembly style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and click Style Override.

6 Click the Layer/Color/Linetype tab.

7 Select the component to change, and select a different setting for
the property.

8 Click OK twice.
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Specifying the Hatching for Components of a Door and Window
Assembly Style

Use this procedure to specify the hatching of the components of an individual
door/window assembly. Door/window assembly hatching is displayed only
in display representations, such as Plan, that are used in the Top view (Plan
view) of a drawing.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select the door/window assembly style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and click Style Override.

6 Click the Hatching tab.

7 Select a component, and click the setting for Pattern.

8 Select the hatching for the component:

Then…If you want to select…

select Predefined for Type, and then
select a pattern.

a hatching pattern that is available
in the software

select Custom for Type, and then
enter the name of the custom pat-

a custom pattern

tern. If necessary, click Browse, and
navigate to the folder where the
custom pattern file is located.

select User-defined for Type, and
clear Double Hatch.

single hatching

select User-defined for Type, and
select Double Hatch.

double hatching
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Then…If you want to select…

select Solid Fill for Type.solid fill

9 Click OK.

10 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

11 Click Angle, and enter the angle for the selected pattern.

12 Click Orientation, and specify how the hatching is oriented:

Then…If you want to orient the
hatching…

select Object.to the object, regardless of the ob-
ject rotation

select Global.to the World Coordinate System

13 Click OK twice.

Adding Custom Graphics as a Display Component of a Door and
Window Assembly

There may be instances where an infill, frame, or mullion requires a custom
2D or 3D graphic. For example, you might need a highly detailed
three-dimensional truss as the mullions or a decorative light fixture applied
to an infill. In cases like these, you can create a custom block, add a display
component with the block attached, and associate that component with an
element definition. When you assign that definition to an element, the block
is also displayed.

1 Draw your custom component, and save it as a block.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .
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4 Select the door/window assembly style that you want to change.

5 Click the Display Properties tab.

6 Click  .

7 Click the Custom Plan Components tab.

If Model, Sill Plan, or Sill Plan Screened is the current display
representation, the tab is called Other.

8 Click Add.

9 Select Infill, Frame, or Mullion as the element type.

10 Select the specific element from the list.

11 Select Draw Custom Graphics.

12 Specify the display of the element:

Then…If you want to…

select Replace Graphics.display the block instead of the as-
sociated door/window assembly
element

clear Replace Graphics.superimpose the block over the
door/window assembly element so
that both are displayed

13 Click Select Block and select the custom block that you created.

14 Click OK.

15 Specify further settings for the custom display block:

Then…If you want to…

select Width, Height, or Depth. To
prevent the block from losing its
proportions, select Lock XY Ratio.

scale the block to fit a particular di-
mension

determine if it should mirror in the
X, Y, or Z direction.

mirror the block

specify an insertion point on the X,
Y, and Z planes.

specify how the block is inserted
into the grid in the X, Y, and Z dir-
ections

specify the offset in the X, Y, or Z
direction.

offset the block from the grid
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16 Click OK three times.

Creating Cut Planes for a Door and Window Assembly
Use this procedure to specify the properties of one or more cut planes for a
door/window assembly style. Cut plane display properties apply only to display
representations, such as Plan, that are used in Top view (Plan view) of a
drawing.

To better visualize the elements of a door/window assembly in plan view, you
can create cut planes. The main cut plane is where the shrinkwrap and
hatching are applied. The plan display shows the components of the
door/window assembly as they are displayed at the height of each cut plane.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select the door/window assembly style that you want to change.

4 Click the Display Properties tab.

5 Select Plan, and click  .

NOTE The Cut Plane tab is displayed only in some display
representations, such as Plan.

6 Click the Cut Plane tab to set the cut plane to be displayed in
each display representation for the door/window assembly style.

7 Enter a value for Cut Plane Height to specify the cut plane at
which hatching takes effect.

8 To specifically define a cut plane, click Add, and enter the height
of the new cut plane:

Then…If you add a cut plane…

objects are displayed using the
properties specified for the Below

at a height that is lower than the
value for Cut Plane Height
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Then…If you add a cut plane…

Cut Plane component on the Lay-
er/Color/Linetype tab.

objects are displayed using the
properties specified for the Above

at a height that is higher than the
value for Cut Plane Height

Cut Plane component on the Lay-
er/Color/Linetype tab.

9 Click OK twice.

Defining a Door and Window Assembly Style as Bounding for
Associative Spaces

Use this procedure to define a door and window assembly style that can bound
associative spaces.

When a door and window assembly style is set as bounding, by default all
door and window assemblies that have the style assigned will be used in the
selection set for an associative space. For more information about associative
spaces see Generating Associative Spaces on page 2940.

You can override the bounding settings from the object style in the object
settings, if necessary.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.
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4 Click the General tab.

5 Select the check box for Objects of this style may act as a boundary
for associative spaces.

6 Click OK.

Attaching Notes and Files to a Door and Window Assembly Style
Use this procedure to enter notes and attach reference files to a door/window
assembly. You can also edit notes and edit or detach reference files from a
door/window assembly.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select a door/window assembly style.

4 Click the General tab.

5 To add a description to the door/window assembly, enter it for
Description.

6 Click Notes.

7 To add a note, click the Text Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file
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9 Click OK.

Using Overrides in Door and Window Assemblies
Door/window assemblies are geometrically complex objects that often have
a large number of different elements, such as frames, panels, and window
infills. The settings for these elements are defined in the door/window assembly
style and can be modified using Style Manager. However, there are cases when
modifying a door/window assembly directly on screen is more suitable:

■ You want to add custom frame or mullion edges to a door/window assembly
and need direct visual feedback.

■ You want to create an override, like a merged infill or an irregular panel
shape in only one specific place in the door/window assembly.

■ You want to experiment with different visuals without having to change
the door/window assembly style for each idea immediately.

When you have finished your on-screen edits, you can decide if you want to

■ apply the overrides to the door/window assembly you have edited.

■ save the overrides to the current door/window assembly style.

■ create a new style for the overrides.

NOTE You cannot modify a definition using the Override method. For information
about modifying definitions, see Modifying Element Definitions for Door and
Window Assembly Styles on page 1808.

Overrides do not affect the door/window assembly design rules. However, you
can transfer overrides to a door/window assembly style when you want all
door/window assemblies of that style to have the same overrides.

You can view a list of overrides that are currently assigned to a door/window
assembly from the Overrides tab of the Door/Window Assembly Properties
dialog box. For more information, see Creating a Division Override on page
1802.

NOTE Overrides are also listed on the Overrides tab in the Door/Window Assembly
Style Properties dialog box.
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Overriding Door and Window Assembly Infills
The cell infills of a door/window assembly are set in the door/window assembly
style. You can, however, create overrides for these infills in cells. For example,
you might want a row of glider windows for a first floor facade. In one specific
position, however, you want a frosted glass window. In this case, you would
set the row of glider windows in the door/window assembly style, and then
override the infill style in one specific cell with a frosted glass window.

Door/window assembly infills can consist of simple panels, objects like
windows or doors, or nested grids. You can change one infill for another,
merge cells, or remove the frame from an infill altogether. This would be useful
if you add a door into a grid cell and want to remove the bottom frame from
that cell.

Turning on Cell Markers
Use this procedure to turn on the cell markers for each grid cell in a
door/window assembly. The cell markers must be on in order to select
individual cells and make changes to them.

Viewing Door/Window Assembly cell markers

1 Select the door/window assembly for which you want to create
an infill override.

2 Click Door/Window Assembly tab ➤ Modify panel ➤ Show Infill

Markers  .

Merging Door and Window Assembly Cells
Use this procedure to merge two door/window assembly cells.
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NOTE To merge door/window assembly cells, the cell markers need to be visible.
For information on turning on cell markers, see Turning on Cell Markers on page
1780.

You can only merge cells that are adjacent to each other.

In most cases, you merge cells with the same infill type. The merged cell is
then of the same type as the original cells. For example, if you merge two solid
panel infills, the resulting merged cell also has a solid panel infill. In some
cases however, you might want to merge two cells that have different infill
types. In that case, the infill type of the first selected cell is used for the merged
cell. For example, if you want to merge a cell with a simple panel infill and a
cell with a window infill, and you select the cell with the simple panel first
during the merge command, the merged cell contains a simple panel infill,
not a window. If you select the two cells in the opposite order, the merged
cell contains a window and no simple panel infill.

Merging two Door/Window Assembly cells

1 Select the door/window assembly on which you want to merge
two cells.

2 Click Door/Window Assembly tab ➤ Modify panel ➤ Infill
drop-down ➤ Merge.

3 Select the first cell to be merged.

4 Select the second cell to be merged.

The cells are merged into one.
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5 Specify where you want to save the door/window assembly
override:

Then…If you want to save the over-
ride…

no further steps are necessary. The
override is saved to the door/win-

only on this specific door/window
assembly

dow assembly. For information
about how to remove an override
from a door/window assembly, see
Creating a Division Override on
page 1802.

select the door/window assembly,
click Door/Window Assembly

save the override to a door/window
assembly style

tab ➤ Modify panel ➤ Design Rules

drop-down ➤ Transfer To Object.

6 If you chose to save the override to a door/window assembly style,
select the door/window assembly again, click Door/Window
Assembly tab ➤ Modify panel ➤ Design Rules drop-down ➤ Save
to Style. Then choose the door/window assembly style in which
to save the override.

Then…If you want to…

select Transfer Merge Operations
to Style, and click OK.

NOTE If you have created only
a cell merge, only the Transfer
Merge Operations to Style
check box is active. If you have
also created other overrides,
such as a new cell assignment
or a frame or mullion edge
override, these check boxes are
available as well. If you also
want to save these overrides to
the style, select their check
boxes too.

save the override to the current
door/window assembly style
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Then…If you want to…

select Transfer Merge Operations
to Style, and click New. Then, enter

save the override to a new
door/window assembly style

a name for the new door/window
assembly style, and click OK.

NOTE If you have created only
a cell merge, only the Transfer
Merge Operations to Style
check box is active. If you have
also created other overrides,
such as a new cell assignment
or a frame or mullion edge
override, these check boxes are
available as well. If you also
want to save these overrides to
the style, select their check
boxes too.

NOTE If you do not want to save the override back to a style at all,
click Door/Window Assembly tab ➤ Modify panel ➤ Design Rules
drop-down ➤ Revert to Style Design Rules. The overrides still remain
on the door/window assembly, where they can be removed as
described in Creating a Division Override on page 1802, but they are
not saved back to a door/window assembly style.

Creating a Door and Window Assembly Infill Override
Use this procedure to override the infill of a door/window assembly cell.

For example, you might have a row of simple concrete panels in your
door/window assembly, but want in one location a round window instead of
the concrete panel. In that case, it might be simpler to use an infill override,
instead of creating complex door/window assembly definitions.

NOTE To override an infill assignment, the cell markers must be visible. For
information on turning on cell markers, see Turning on Cell Markers on page 1780.
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To exchange an infill definition, the new infill definition must already be
defined in the curtain wall style. For information on creating infill definitions,
see Defining Infills for Door and Window Assembly Cells on page 1722.

1 Select the door/window assembly on which you want to override
an infill.

2 Click Door/Window Assembly tab ➤ Modify panel ➤ Infill
drop-down ➤ Override Assignment.

3 Select the marker of the cell(s) where you want to create an
override, and press ENTER.

4 Create the override:

Then…If you want to…

select a new infill definition from
the list.

exchange the existing infill for an-
other

select the frame component to be
removed. You could, for example,

remove one or more of the frames
around the infill

override a cell to contain a door in-
fill instead of a panel infill; in this
case, you would want to remove
the bottom frame of the cell.

select Remove Infill and Frames.

NOTE This works only for infills
that border the exterior of the
door/window assembly.

remove the complete infill and its
frame

5 Click OK.
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6 Specify where you want to save the door/window assembly
override:

Then…If you want to…

no further steps are necessary. The
override is saved to the door/win-

save the override only on this specif-
ic door/window assembly

dow assembly. For information
about how to remove an override
from a door/window assembly, see
Creating a Division Override on
page 1802.

select the door/window assembly,
click Door/Window Assembly

save the override to a door/window
assembly style

tab ➤ Modify panel ➤ Design Rules

drop-down ➤ Transfer To Object.

7 If you have chosen to save the override to a door/window assembly
style, select the door/window assembly again, click Door/Window
Assembly tab ➤ Modify panel ➤ Design Rules drop-down ➤ Save
to Style and decide to which door/window assembly style you
want to save the override.

Then…If you want to…

select Transfer Cell Overrides to
Style, and click OK.

NOTE If you have created only
an infill override, only the
Transfer Cell Overrides to Style
check box is active. If you have
also created other overrides,
such as a cell merge or a frame
or mullion edge override, these
check boxes are available as
well. If you also want to save
these overrides to the style, se-
lect their check boxes too.

save the override to the current
door/window assembly style

select Transfer Cell Overrides to
Style, and click New. Then, enter a

save the override to a new
door/window assembly style
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Then…If you want to…

name for the new door/window
assembly style, and click OK.

NOTE If you have created only
an infill override, only the
Transfer Cell Overrides to Style
check box is active. If you have
also created other overrides,
such as a cell merge or a frame
or mullion edge override, these
check boxes are available as
well. If you also want to save
these overrides to the style, se-
lect their check boxes too.

NOTE If you do not want to save the override back to a style at all,
click Door/Window Assembly tab ➤ Modify panel ➤ Design Rules
drop-down ➤ Revert to Style Design Rules. The overrides remain on
the door/window assembly, where they can be removed as described
in Creating a Division Override on page 1802, but they are not saved
back to a door/window assembly style.

In-Place Editing of Door and Window Assembly Cells
Use this procedure to edit door/window assembly cells using in-place editing
with the Edit Grid grip. With in-place editing, you can edit individual cells,
bays, columns, or nested grids of the door/window assembly directly and
interactively in the drawing area, and later save the changes to the
door/window assembly or door/window assembly style.

1 Select a door/window assembly on which you want to edit cells
with in-place editing.

2 Specify the mode in which to edit the door/window assembly:

Then …If you want to edit …

click Door/Window Assembly

tab ➤ Modify panel ➤ Design Rules

drop-down ➤ Transfer To Object.

this instance of the door/window
assembly
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Then …If you want to edit …

click Door/Window Assembly

tab ➤ Modify panel ➤ Design Rules

the door/window assembly style

drop-down ➤ Revert to Style
Design Rules. If this option is not
available, the design rules are
already style-based for the
door/window assembly.

3 Click the Edit Grid grip.

4 Enter c (Cell) and press ENTER.

NOTE You have entered the in-place editing session now. You can
see this from the faded color of all objects in the drawing, as well as
from the different grips at your disposal. Note that while you are in
the in-place editing session, you have only limited editing access to
other commands in the drawing. Before working on other objects,
you should first end the in-place editing session.

5 Select the individual cells, bay, column, or nested grid to modify
the cell assignment by hovering over a cell or pressing TAB, and
press ENTER.

Press CTRL to select multiple cells, bays, columns or nested grids.

The Edit Cells worksheet displays.
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6 Edit the cell for the selected grid:

Then…If you want to…

select Assign Infill and select an infill defini-
tion. Clear Replace Cell and click OK.

assign an infill to selected
cells

select Assign Infill and select an infill defini-
tion. Select Replace Cell and click OK.

replace the selected cells
with a new infill

click  and specify values on the Design
Rules worksheet.
For more information, see Assigning Infills to
Door and Window Assembly Cells on page
1746.

create and assign a new
infill to the selected cells

select Subdivision.divide the selected cells
with divisions, infills or
frames

select a division definition.add a division to the sub-
divided cells

click  and specify values on the Design
Rules worksheet.
For more information, see Assigning a Division
to a Door and Window Assembly Grid on
page 1746.

create and assign a new
division to the selected
cells

select an infill definition.select an infill for the
subdivided cells

click  and specify values on the Design
Rules worksheet.
For more information, see Assigning Infills to
Door and Window Assembly Cells on page
1746.

create and assign a new
infill to the subdivided
cells

select the frame definition and click OK.select a frame definition
for the grid created after
the cell is subdivided
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Then…If you want to…

select Top, Bottom, Left, Right for Frame
Location and click OK.

specify the location of
frames on the grid cre-
ated after the cell is sub-
divided

click  and specify values on the Design
Rules worksheet.
For more information, see Adding a New
Frame Assignment to a Door and Window
Assembly Grid on page 1760.

create and assign a new
frame definition for the
new grid created after
the cell is subdivided

select the mullion definition.select a mullion definition
for the grid created after
the cell is subdivided

click  and specify values on the Design
Rules worksheet.
For more information, see Adding a New
Mullion Assignment to a Door and Window
Assembly Style on page 1764.

create and assign a new
mullion definition to the
selected grid

select Replace Cell.replace the existing cell
infill with the options se-
lected on this worksheet

select Continue Grid Editing.continue in-place editing
the grid after the cell is
subdivided

7 Click OK.

8 Press ENTER.

Overriding Door and Window Assembly Frames and Mullions
You can change a selected frame edge or mullion edge by using an edge
assignment override.
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NOTE To exchange a frame edge or mullion edge, the new edge definition must
already be defined in the door/window assembly style.

Removing the edge does not affect the width of the cell. To remove the edge
and have the adjacent cell resize, create an edge definition with a width and
depth of zero. For more information, see Defining a Door and Window
Assembly Frame by Width and Depth on page 1731 or Defining Door and
Window Assembly Mullions by Width and Depth on page 1739.

You can also create a new edge profile by drawing a polyline or using an
existing profile in the drawing. This edge profile can be interactively edited
on screen by in-place editing.

Creating a Frame or Mullion Override
Use this procedure to select a different element definition for a selected frame
edge or mullion by using an edge assignment override.

To exchange a frame or mullion, the new definition must already be defined
in the door/window assembly style. For information on creating frames and
mullions, see Defining Door and Window Assembly Frames on page 1730 and
Defining Door and Window Assembly Mullions on page 1737.

Overriding a Door/Window Assembly frame definition

1 Select the door/window assembly on which you want to override
an edge.

2 Click Door/Window Assembly tab ➤ Modify
panel ➤ Frame/Mullion drop-down ➤ Override Assignment.

3 Select the frame or mullion edge you want to override.
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4 Create the override:

Then…If you want to…

select a new edge definition from
the list.

exchange the existing edge for an-
other

select Remove.remove the frame or mullion edge

5 Click OK.

6 Specify where you want to save the door/window assembly
override:

Then…If you want to…

no further steps are necessary. The
override is saved to the door/win-

save the override only on this specif-
ic door/window assembly

dow assembly. For information
about how to remove an override
from a door/window assembly, see
Creating a Division Override on
page 1802.

select the door/window assembly,
and click Door/Window Assembly

save the override to a door/window
assembly style

tab ➤ Modify panel ➤ Design Rules

drop-down ➤ Transfer To Object.

7 If you have chosen to save the override to a door/window assembly
style, select the door/window assembly again, click Door/Window
Assembly tab ➤ Modify panel ➤ Design Rules drop-down ➤ Save

Using Overrides in Door and Window Assemblies | 1791



to Style and decide to which door/window assembly style you
want to save the override.

Then…If you want to…

select Transfer Edge Overrides to
Style, and click OK.

NOTE If you have created only
a frame or mullion edge over-
ride, only the Transfer Edge
Overrides to Style check box is
active. If you have also created
other overrides, such as a cell
merge or a division override,
these check boxes are available
as well. If you also want to save
these overrides to the style, se-
lect their check boxes too.

save the override to the current
door/window assembly style

select Transfer Edge Overrides to
Style, and click New. Then, enter a

save the override to a new
door/window assembly style

name for the new door/window
assembly style, and click OK.

NOTE If you have created only
a frame or mullion edge over-
ride, only the Transfer Edge
Overrides to Style check box is
active. If you have also created
other overrides, such as a cell
merge or a division override,
these check boxes are available
as well. If you also want to save
these overrides to the style, se-
lect their check boxes too.

NOTE If you do not want to save the override back to a style at all,
click Door/Window Assembly tab ➤ Modify panel ➤ Design Rules
drop-down ➤ Revert to Style Design Rules. The overrides remain on
the door/window assembly, where they can be removed as described
in Creating a Division Override on page 1802, but they are not saved
back to a door/window assembly style.
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Creating a Frame or Mullion Edge from a Polyline or Profile Using
In-Place Editing

Use this procedure to assign a profile to a vertical edge of a frame or mullion.
The profile can be any profile or any closed polyline that you specify. You can
use a profile edge to create a unique corner in situations where a simple miter
is not sufficient.

NOTE Adjacent infills are not trimmed or expanded to accommodate the new
edge. To adjust the infill, change the width of the frame edge. For more
information, see Defining a Door and Window Assembly Frame by Width and
Depth on page 1731.

1 Draw a closed polyline in the location where you want it to display
in the door/window assembly.

NOTE For best results, it is recommended to draw the polyline in
Plan view.

2 Select the door/window assembly for which you want to create a
frame or mullion edge profile override.

3 Specify the mode in which to edit the door/window assembly:

Then…If you want to edit…

click Door/Window Assembly

tab ➤ Modify panel ➤ Design Rules

drop-down ➤ Transfer To Object.

this instance of the door/window
assembly

click Door/Window Assembly

tab ➤ Modify panel ➤ Design Rules

the door/window assembly style

drop-down ➤ Revert to Style
Design Rules. If this option is not
available, the design rules are
already style-based for the
door/window assembly.

4 Click Door/Window Assembly tab ➤ Modify
panel ➤ Frame/Mullion drop-down ➤ Add Profile.

5 Select a vertical frame or a mullion edge.
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6 Select a profile for the override:

Then…If you want to create the edge
profile from…

select Start from scratch for Profile
Definition, and enter a name for
New Profile Name.

the polyline drawn in step 1

select the existing profile for Profile
Definition.

an existing profile in the drawing

7 Select whether to apply the profile to the shared edge element
definition or as an edge profile override.

8 Click OK.

You are now in in-place edit mode, and can edit the profile. For
more information, see In-Place Editing of Edge Profiles for
Door/Window Assemblies on page 1796.

9 Click Edit in Place tab ➤ Profile panel  ➤ Zoom To  to zoom
to the profile.

10 Use the grips, the ribbon, or the context menu in order to make
any of the following changes to the profile.

Then...If you want to...

Select the vertex grip, and move it.Move a Vertex

Add a Vertex ■ Grips: Select an Edge grip, and press CTRL to
switch to the Add Vertex edit mode. Move the
edge to the desired location and click, or enter
a value and press ENTER.

■ Ribbon: Click Edit In Place tab ➤ Profile pan-

el ➤ Add Vertex  . Then, specify the location
of the new vertex on screen.

■ Context menu: Click Add Vertex, and specify
the location of the new vertex on screen.

Remove a vertex ■ Grips: Select the Vertex grip for the vertex you
want to remove, and press CTRL to switch to
the Remove edit mode. Move the cursor off the
selected vertex, and click.
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Then...If you want to...

■ Ribbon: Click Edit In Place tab ➤ Profile pan-

el ➤ Remove Vertex  . Then, select the vertex
to remove on screen.

■ Context menu: Click Remove Vertex, and select
the vertex to remove.

Offset a vertex with its edges ■ Grips: Select the vertex grip which you want to
offset with its associated edges. Then, press Ctrl
twice and drag the vertex to the desired loca-
tion.

Offset a profile edge ■ Grips: Select the grip of the edge you want to
offset and drag it to the desired location.

Convert an edge to an arc ■ Grips: Select the grip of the edge you want to
convert, and press Ctrl twice. Then, drag the
grip until the desired arc shape is in place.

Offset all edges of the profile ■ Grips: Select any edge grip on the profile, and
press Ctrl three times. Then, drag the grip until
the overall profile shape is correct.

Add a ring to a profile ■ Ribbon: Click Edit In Place tab ➤ Profile pan-

el ➤ Add Ring  . Then, select a closed poly-
line, spline, ellipse or circle to convert.

■ Context menu: Select the profile, and click Add
ring. Then, select a closed polyline, spline, el-
lipse to convert.

Remove a ring from a profile ■ Ribbon: Click Edit In Place tab ➤ Profile pan-

el ➤ Remove Ring  . Then, select the ring
you want to remove from the profile, and press
Enter.

■ Context menu: Select the profile, and click Re-
move Ring. Then, select the ring you want to
remove from the profile, and press Enter.
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Then...If you want to...

Replacing a ring with another ■ Ribbon: Click Edit In Place tab ➤ Profile pan-

el ➤ Replace Ring  . Then, select the ring
you want to replace and the ring that should
be used instead.

■ Context menu: Select the profile, and click Re-
place Ring. Then, select the ring you want to
replace, and after that the ring that should be
used instead.

11 Save or discard changes to the door/window assembly grid:

Then…If you want to exit the in-place
editing session…

click Edit in Place tab ➤ Edits pan-

el ➤ Cancel  .

without saving your changes

click Edit in Place tab ➤ Edits pan-

el ➤ Finish  .

after saving your changes

click Edit in Place tab Edits pan-

el ➤ Save As  . Enter a name for

and save the changes to a new
profile definition

the new profile definition, and click
OK. The in-place edit session is ex-
ited and the new profile definition
is available in the Style Manager.

In-Place Editing of Edge Profiles for Door/Window Assemblies
Use this procedure to edit profile edges using in-place editing. With in-place
editing, you can edit the door/window assembly directly and interactively in
the drawing area and later save the changes to the profile definition.

1 Select the door/window assembly that has the edge profile you
want to edit on screen with in-place editing.

2 Click Door/Window Assembly tab ➤ Profile panel ➤ Edit In Place

 .
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This command is only available if you have profile-based edges
in the door/window assembly.

NOTE If the profile is not drawn to size, it must be converted in order
for you to begin the in-place editing session. Click Yes if prompted
to convert the profile to its actual size.

3 Select the edge you want to edit.

NOTE You have entered the in-place editing session now. You can
see this from the magenta-colored grips and light blue hatch of the
temporary in-place editing profile, as well as the faded color of all
other objects in the drawing. Note that while you are in the in-place
editing session, you have only limited editing access to other
commands in the drawing. Before working on other objects, you
should first end the in-place editing session.

4 Edit the profile:

Then…If you want to…

move the grips as needed.
The Edge grip has three edit modes:
Offset, Add Vertex, and Convert to

move or offset edges, or convert
edges to arcs

Arc. The default mode is Offset,
which offsets the selected edge in
a direction that is perpendicular to
the midpoint of the edge. Depend-
ing on the shape of the profile and
the edge you choose to modify,
neighboring lines are extended or
trimmed, and new lines are added,
as necessary.
Convert to Arc changes the selected
edge to an arc and stretches the
midpoint of the edge. The edge
grip for an arc also has a Stretch
mode, so that you can stretch the
midpoint of the edge after it has
been converted to an arc.

add a vertex ■ Grips: Select an Edge grip, and
press CTRL to switch to the Add
Vertex edit mode. Move the
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Then…If you want to…

edge to the desired location
and click, or enter a value and
press ENTER.

■ Ribbon: Click Edit In Place

tab ➤ Profile panel ➤ Add Ver-

tex  . Then, specify the loca-
tion of the new vertex on
screen.

■ Context menu: Click Add Ver-
tex, and specify the location of
the new vertex on screen.

remove a vertex ■ Grips: Select the Vertex grip for
the vertex you want to remove,
and press CTRL to switch to the
Remove edit mode. Move the
cursor off the selected vertex,
and click.

■ Ribbon: Click Edit In Place

tab ➤ Profile panel ➤ Remove

Vertex  . Then, select the
vertex to remove on screen.

■ Context menu: Click Remove
Vertex, and select the vertex to
remove.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Add

add a ring

Ring  . Then, select a closed
polyline, spline, ellipse, or circle for
an additional ring. Specify if you
want to erase the source linework,
and press Enter.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Remove

remove a ring
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Then…If you want to…

Ring  . Then select the ring you
want to remove.

NOTE You cannot remove the
last ring from a profile.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Replace

replace a ring

Ring  . Then, select a closed
polyline, spline, ellipse, or circle for
the replaced ring. Specify if you
want to erase the source linework,
and press Enter.

5 Save the changes to the profile:

Then…If you want to…

click Edit in Place tab ➤ Edits pan-

el ➤ Finish  .

change the existing profile defini-
tion to reflect the new shape

Click Edit in Place tab ➤ Edits pan-

el ➤ Save As  . Then, enter a

create a new profile definition with
the shape you have created

name for the new profile and click
OK. The in-place edit session is ex-
ited and the new profile definition
is available in the Style Manager.

click Edit in Place tab ➤ Edits pan-

el ➤ Cancel  .

discard all changes on the profile
and revert back to the previous
shape

In-Place Editing of Door and Window Assembly Frames and
Mullions

Use this procedure to edit frames and mullions using in-place editing with
the Edit Grid grip. With in-place editing, you can edit bays, columns or nested
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grids of the door/window assembly directly and interactively in the drawing
area, and later save the changes to the door/window assembly or door/window
assembly style.

1 Select a door/window assembly on which you want to edit frames
or mullions with in-place editing.

2 Specify the mode in which to edit the door/window assembly:

Then …If you want to edit …

click Door/Window Assembly

tab ➤ Modify panel ➤ Design Rules

drop-down ➤ Transfer To Object.

this instance of the door/window
assembly

click Door/Window Assembly

tab ➤ Modify panel ➤ Design Rules

the door/window assembly style

drop-down ➤ Revert to Style
Design Rules. If this option is not
available, the design rules are
already style-based for the
door/window assembly.

3 Click the Edit Grid grip.

4 Enter f (Frame and mullion assignment) and press ENTER.

NOTE You have entered the in-place editing session now. You can
see this from the faded color of all objects in the drawing, as well as
from the different grips at your disposal. Note that while you are in
the in-place editing session, you have only limited editing access to
other commands in the drawing. Before working on other objects,
you should first end the in-place editing session.

5 Select the bay, column or nested grid to modify the frame and
mullion assignment and press ENTER.

Press CTRL to select multiple bays, columns or nested grids.
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The Modify Frame/Mullion Assignment worksheet displays.

6 Select a frame definition for the selected grid:

Then…If you want to…

select a frame definition and click OK.modify the frame of the
selected grid

select Top, Bottom, Left, Right for Frame
Location and click OK.

specify the location of the
frame on the selected
grid

click  and complete the Design Rules
worksheet.
For more information, see Adding a New
Frame Assignment to a Door and Window
Assembly Grid on page 1760.

create and assign a new
frame definition to the
selected grid

7 Select the mullion definition for the selected grid:

Then…If you want to…

select the mullion definition and click OK.modify the mullion of the
selected grid

click  and complete the Design Rules
worksheet.
For more information, see Adding a New
Mullion Assignment to a Door and Window
Assembly Style on page 1764.

create and assign a new
mullion definition to the
selected grid

8 Press ENTER.
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Overriding Door and Window Assembly Divisions
The grid of a door/window assembly is made up of one or more divisions that
define how the door/window assembly is partitioned. Divisions can be
horizontal or vertical, and can be nested in each other. For detailed information
on door/window assembly divisions, see Creating a Division Definition for a
Door and Window Assembly on page 1711.

You can override a division in a door/window assembly, thereby changing
the grid of the door/window assembly.

Overriding a Door/Window Assembly cell division definition

Creating a Division Override
Use this procedure to create a division override on a door/window assembly.

NOTE To exchange a door/window assembly division, the new division definition
must already be defined in the door/window assembly style. For information on
door/window assembly divisions, see Division of Door and Window Assembly Grids
on page 1710.

1 Select the door/window assembly for which you want to create a
division override.

2 Click Door/Window Assembly tab ➤ Modify panel ➤ Division
drop-down ➤ Override Assignment.

3 Select an edge of the door/window assembly to determine if a
horizontal or vertical division is overridden.

For example, if you want to override the primary horizontal
division, you could select the bottom horizontal frame of the
door/window assembly.
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TIP The Division Assignment Override dialog box shows you which
grid type and which grid division you have selected, e.g. Selected
Nested Grid: Secondary Grid, Division Element Definition: Vertical 3
Cells. If you have accidentally selected the wrong division, click Cancel
and reselect the correct grid.

4 Select the division to override, and click OK.

5 Specify where you want to save the door/window assembly
override:

Then…If you want to save the over-
ride…

no further steps are necessary. The
override is saved to the door/win-

only on this specific door/window
assembly

dow assembly. For information
about how to remove an override
from a door/window assembly, see
Removing Door and Window As-
sembly Overrides on page 1807.

select the door/window assembly,
and click Door/Window Assembly

to a door/window assembly style

tab ➤ Modify panel ➤ Design Rules

drop-down ➤ Transfer To Object.

6 If you want to save the override to a door/window assembly style,
select the door/window assembly again, click Door/Window
Assembly tab ➤ Modify panel ➤ Design Rules drop-down ➤ Save

Using Overrides in Door and Window Assemblies | 1803



to Style and decide to which door/window assembly style you
want to save the override.

Then…If you want to…

select Transfer Division Overrides to
Style, and click OK.

NOTE If you have created only
a profile edge override, only the
Transfer Division Overrides to
Style check box is active. If you
have also created other over-
rides, such as a cell merge or a
edge override, these check
boxes are available as well. If
you also want to save these
overrides to the style, select
their check boxes too.

save the override to the current
door/window assembly style

select Transfer Division Overrides to
Style, and click New. Then, enter a

save the override to a new
door/window assembly style

name for the new door/window
assembly style, and click OK.

NOTE If you have created only
a profile edge override, only the
Transfer Division Overrides to
Style check box is active. If you
have also created other over-
rides, such as a cell merge or a
edge override, these check
boxes are available as well. If
you also want to save these
overrides to the style, select
their check boxes too.

NOTE If you do not want to save the override back to a style at all,
click Door/Window Assembly tab ➤ Modify panel ➤ Design Rules
drop-down ➤ Revert to Style Design Rules. The overrides remain on
the door/window assembly, where they can be removed as described
in Removing Door and Window Assembly Overrides on page 1807, but
they are not saved back to a door/window assembly style.
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In-Place Editing of Door and Window Assembly Divisions
Use this procedure to edit divisions using in-place editing with the Edit Grid
grip. With in-place editing, you can edit the door/window assembly directly
and interactively in the drawing area, and later save the changes to the
door/window assembly or door/window assembly style. For more information,
see Division of Door and Window Assembly Grids on page 1710.

1 Select a door/window assembly on which you want to edit
divisions on screen with in-place editing.

2 Specify the mode in which to edit the door/window assembly:

Then…If you want to…

click Door/Window Assembly

tab ➤ Modify panel ➤ Design Rules

drop-down ➤ Transfer To Object.

edit this instance of the door/win-
dow assembly

click Door/Window Assembly

tab ➤ Modify panel ➤ Design Rules

edit the door/window assembly
style

drop-down ➤ Revert to Style
Design Rules. If this option is not
available, the design rules are
already style-based for the
door/window assembly.

3 Click the Edit Grid grip.

NOTE Alternatively, you can click Door/Window Assembly
tab ➤ Modify panel ➤ Division drop-down ➤ Edit.

4 Enter d (Division in place) and press ENTER.

For example, if you want to edit the primary grid, select an edge
on the outer door/window assembly frame.

NOTE You have entered the in-place editing session now. You can
see this from the faded color of all objects in the drawing, as well as
from the different grips at your disposal. Note that while you are in
the in-place editing session, you have only limited editing access to
other commands in the drawing. Before working on other objects,
you should first end the in-place editing session.

Using Overrides in Door and Window Assemblies | 1805



Viewing Edit In Place grips

5 Edit the division:

Then…If you want to…

click the Add Bay grip.add a bay to the grid

click the Remove Bay grip.remove a bay from the grid

select the Start Offset grip and
move it to the appropriate position.

change the start offset of the grid

select the End Offset grip and move
it to the appropriate position.

change the end offset of the grid

click the Auto Grid Bay Spacing grip
and move it to the appropriate po-
sition.

change the spacing of bays

Click Edit In Place tab ➤ Division

panel ➤ Convert To Manual  .

manually edit the grid

You can manually add and remove
gridlines, change the offsets, and
change the position of individual
gridlines.

click the Set Fixed Cell Dimension
Rules command grip, and edit the
values in the worksheet.

use a worksheet to edit the cell di-
mensions
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6 Save or discard changes to the door/window assembly grid:

Then…If you want to…

click Edit in Place tab ➤ Edits pan-

el ➤ Cancel  .

exit the in-place editing session
without saving your changes

click Edit in Place tab ➤ Edits pan-

el ➤ Finish  . If you edited the

exit the in-place editing session
after saving your changes

grid by instance, the changes are
saved to the design rules for the in-
dividual grid. If you edited the
door/window assembly style, the
Save Changes dialog box is dis-
played.

7 In the Save Changes dialog box, specify to which division to save
the changes:

Then…If you want to…

verify the current division is selected
for Save Changes to Existing Divi-

save the changes to the style in the
current door/window assembly divi-
sion sion, and click Save. The changes

are made in the style and affect all
door/window assemblies of that
style in the drawing.

click New, enter a name for the
new division override, and click OK.

create an override to the style by
saving the changes in a new
door/window assembly division Click Save. The changes are saved

as an override to the style, and af-
fect only the door/window assem-
blies to which the override is ap-
plied.

Removing Door and Window Assembly Overrides
Use this procedure to remove door/window assembly overrides either from
the door/window assembly or the door/window assembly style.
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1 Select the door/window assembly:

Then…If you want to…

double-click the door/window as-
sembly, expand Advanced in the

remove an override from a
door/window assembly

Properties palette, and click 
next to Overrides.

select the door/window assembly,
click Door/Window Assembly

remove an override from the
door/window assembly style

tab ➤ General panel ➤ Edit Style

 , and then click the Overrides
tab.

2 Select an override from the list and click Remove.

3 Click OK.

Modifying Element Definitions for Door and Window Assembly
Styles

You can modify element definitions using the Design Rules tab of the
Door/Window Assembly Style Properties dialog box. You can access these
definitions from the assignments list and from the definitions list:

■ From the assignments list: Select a grid from the tree view to display the
assignments list. Then select an assignment that uses that definition. Make
your changes below the assignment list.
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■ From the definitions list: Select an element type from the tree view to
display all definitions for that element type. Select a definition and make
your changes below the definitions list.

Any changes you make, including changes to the definition name, overwrite
the existing definition. To create a new definition from the assignments list,
select New from the Element list. To create a new definition from the
definitions list, click the New Division icon, the New Infill icon, the New
Frame icon, or the New Mullion icon.

Editing Door and Window Assemblies
Most relevant settings for a door/window assembly are defined in the
door/window assembly style. These settings include divisions, infills, frames,
and mullions. For information on modifying a door/window assembly style,
see Door and Window Assembly Styles on page 1703.

You can make other changes directly to individual door/window assemblies,
which affect only the door/window assembly you select:

■ The dimensions of a door/window assembly

■ Interference conditions

■ Cleanup settings
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Methods of Editing Door and Window Assemblies

AutoCAD Architecture offers several methods for editing door/window
assemblies:

■ You can directly edit door/window assemblies using grips for dimensions
and other physical characteristics.

■ You can directly edit door/window assemblies using the Edit Grid grip for
grid divisions, cells, frames, and mullions. For more information, see
In-Place Editing of Door and Window Assembly Divisions on page 1805,
In-Place Editing of Edge Profiles for Door/Window Assemblies on page 1796,
and Overriding Door and Window Assembly Infills on page 1780.

■ You can change door/window assembly settings on the Properties palette.
You can also use the Display tab of the Properties palette to change the
display property settings for a selected object display component in the
current display representation. For more information, see Using the
Properties Palette to Change Display Properties on page 793.

■ You can select editing commands from the contextual ribbon and context
menu for a selected door/window assembly.

■ For grip edit operations where you are changing a dimension or an angle,
the Dynamic Input feature lets you enter a precise value instead of moving

a grip. When this feature is active (click  on the application status bar),
selecting a grip displays a text box in which you can enter the desired value
for the associated dimension or angle. For more information, see “Use
Dynamic Input” in AutoCAD Help.

NOTE For information about changing the elements within a door/window
assembly, see Using Overrides in Door and Window Assemblies on page 1779. For
information about changing the display of the door/window assemblies, see
Specifying the Display of Door and Window Assemblies on page 1770.

Using Grips to Edit Door and Window Assemblies
You can use the following grips to edit a door and window assembly:
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Viewing Door/Window Assembly Grips

DescriptionGrip

Lets you change the
overall width of a
door/window assembly

 (Width)

Lets you change the
height of the door and
window assembly

 (Height)

Lets you move a door
and window assembly. (Location)

If the assembly is
anchored to a wall, you
can use these three
methods:

■ Drag the cursor to
move the assembly
along the length of
the wall

■ Press CTRL and drag
to move the as-
sembly within the
width of the wall

■ Press CTRL twice
and drag to move
the assembly vertic-
ally within the wall
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Changing the Location Properties of a Door and Window
Assembly

Use this procedure to change the location properties of a door/window
assembly. Location properties include vertical alignment, head height, sill
height, and rotation.

DescriptionLocation Property

Specifies whether to measure the vertical
height of the window to the sill or head

Vertical alignment

The head height of the windowHead height

The sill height of the windowSill height

Reference angle for the objectRotation

1 Double-click the door/window assembly.

2 On the Properties palette, expand Location.

3 Change the location properties.

4 Select Additional information to display the Location worksheet,
where you can change additional location properties, such as
coordinate system, insertion point, and normal.

Selecting a Different Door and Window Assembly Style
Use this procedure to select a different style for a door/window assembly.

1 Double-click the door/window assembly for which you want to
change the styles.

You can select multiple door/window assemblies and change the
style for all at the same time.

2 On the Properties palette, expand General.

3 Select a different style.
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Matching the Properties of an Existing Door and Window
Assembly

Use this procedure to apply the properties of a door/window assembly tool to
one or more existing door/window assemblies. The properties include the
door/window assembly style and any other settings specified in the tool you
select.

1 Open the tool palette that you want to use.

If necessary, scroll to display the tool that you want to use.

2 Right-click a door/window assembly tool, and click Apply Tool
Properties to ➤ Door/Window Assembly.

3 Select the door/window assemblies, and press ENTER.

The properties of the selected door/window assemblies match the
properties of the door/window assembly tool.

Changing the Door and Window Assembly Dimensions
Use this procedure to change the dimensions of a door/window assembly.

1 Double-click a door/window assembly.

2 On the Properties palette, expand Dimensions.

3 Change the dimensions:

DescriptionDimension

The distance from the baseline to
the top of the door/window as-
sembly, including any rise.

Height

The distance from the base height
to the top of the door/window as-
sembly.

Rise

Angle of all infills and horizontal
edges (frame or mullion) at the start

Start Miter

of the door/window assembly. For
more information about miter
angles, see Mitering Door and
Window Assemblies on page 1817.
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DescriptionDimension

Angle of all infills and horizontal
edges (frame or mullion) at the end
of the door/window assembly.

End Miter

Changing the Shape of a Door and Window Assembly
Use this procedure to change the shape of a door/window assembly. There
are several predefined shapes for door/window assemblies. You can use any
of these shapes or use an AEC profile as the shape. For more information about
profiles, see Creating a Profile for a Door and Window Assembly Frame on
page 1732.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager .

2 Expand Architectural Objects, and expand Door/Window
Assembly Styles.

NOTE Alternatively, select a door/window assembly in the drawing,
and click Door/Window Assembly tab ➤ General panel ➤ Edit Style

drop-down ➤ Door/Window Assembly Styles  .

3 Select the door/window assembly style that you want to change.

4 Click the Shape tab.

5 Select a shape from the Predefined list or select Use Profile, and
select an existing AEC Profile as the shape.

6 Click OK.

Changing the Location of a Freestanding Door and Window
Assembly

You can relocate an existing door/window assembly by changing the
coordinate values of its insertion point. The door/window assembly also has
an orientation with respect to the world coordinate system (WCS) or the
current user coordinate system (UCS). For example, if the top and bottom of
the door/window assembly are parallel to the XY plane, its normal is parallel
to the Z axis. You can change the orientation of the door/window assembly
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by aligning its normal with another axis. You can also rotate the door/window
assembly on its plane by changing the rotation angle.

For more information about the world coordinate system, see “Use Coordinates
and Coordinate Systems” in AutoCAD Help.

1 Double-click the door/window assembly.

2 On the Properties palette, expand Location.

3 Click Additional information.

4 Specify the location of the door/window assembly:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the door/window assembly

make the normal of the door/win-
dow assembly parallel to the Z axis:

locate the door/window assembly
on the XY plane

under Normal, enter 1 for Z, and
enter 0 for X and Y.

make the normal of the door/win-
dow assembly parallel to the X axis:

locate the door/window assembly
on the YZ plane

under Normal, enter 1 for X, and
enter 0 for Y and Z.

make the normal of the door/win-
dow assembly parallel to the Y axis:

locate the door/window assembly
on the XZ plane

under Normal, enter 1 for Y, and
enter 0 for X and Z.

enter a new value for Rotation
Angle.

change the rotation of the
door/window assembly

5 Click OK.

Adding an Interference Condition to a Door and Window
Assembly

Use this procedure to add an interference condition to a door/window
assembly. Interference conditions use the geometry of 3D objects to create
custom openings or cutouts in door/window assemblies. You can specify how
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the interference condition is applied to the door/window assembly: added to
the door/window assembly, subtracted from the door/window assembly, or
ignored.

1 Place the object in the location where you want to specify the
interference condition.

2 Select the door/window assembly to which you want to add an
interference condition.

3 Click Door/Window Assembly tab ➤ Modify panel ➤ Interference

drop-down ➤ Add  .

4 Select the object intersecting the door/window assembly, and
press ENTER.

5 Specify to which door/window assembly component the
interference should be added:

Then…If you want to add the interfer-
ence condition…

enter y (Yes) when prompted for
the infill component.

to the infill

enter y (Yes) when prompted for
the frame component.

to the frame

enter y (Yes) when prompted for
the mullion component.

to the mullion

6 Press ENTER.

Removing an Interference Condition from a Door and Window
Assembly

Use this procedure to remove an object, such as a mass element, from a
door/window assembly that the object was added to as an interference
condition.

1 Select the door/window assembly from which you want to remove
an interference object.

2 Click Door/Window Assembly tab ➤ Modify panel ➤ Interference

drop-down ➤ Remove  .
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3 Select the object intersecting the door/window assembly, and
press ENTER.

Mitering Door and Window Assemblies
Use this procedure to miter the corners where door/window assemblies meet.
The corner where adjacent door/window assemblies meet is not mitered by
default. However, you can automatically determine the necessary angles.

The miter angle applies to all infills and horizontal edges (frame or mullion)
that are adjacent to the corner. Vertical edges are not affected.

TIP If you want to create a custom corner condition between two door/window
assemblies, you can replace the edge of one door/window assembly with an AEC
profile and remove the edge of the other door/window assembly by using the
frame override Remove Edge option. For more information, see Overriding Door
and Window Assembly Frames and Mullions on page 1789 and Defining Door and
Window Assembly Frames on page 1730.

1 Select one of the door/window assemblies.

2 Click Door/Window Assembly tab ➤ Modify panel ➤ Set Miter

Angles  .

3 Select the other door/window assembly.

If you change the angle of either door/window assembly, use Set
Miter Angles again to recalculate the angles.

Specifying a Miter Angle for a Door and Window Assembly
Adjacent to Another Object

Use this procedure to manually create a mitered corner between a door/window
assembly and another object, such as a standard wall or a mass element. For
example, if your door/window assembly connects with a standard wall that
is at a 60-degree angle from the door/window assembly, you would set the
miter angle to 30.

The miter angle is applied to all infills and horizontal edges that are adjacent
to the corner. Vertical edges are not affected.

1 Double-click the door/window assembly.

2 On the Properties palette, expand Dimensions.
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3 Miter the door/window assembly on the start or the end point:

Then…If you want to miter the
door/window assembly…

enter an angle for Start Miter, and
press ENTER.

at its start point

enter an angle for End Miter, and
press ENTER.

at its end point

Specifying the Cut Plane Display of a Door and Window Assembly
Use this procedure to specify the properties of one or more cut planes for an
individual door and window assembly. Cut plane display properties apply
only to display representations, such as Plan, that are used in the Top view
(plan view) of a drawing.

1 Double-click the door and window assembly you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all door and window assemblies in
the drawing, select Drawing default setting. To apply changes to all
assemblies of this style, select Door/Window Assembly Style:<style
name>. For more information on styles, see Door and Window
Assembly Styles on page 1703.

5 If necessary, expand Object Display Properties ➤ Cut Plane.

6 For Override cut plane, specify whether you want to override the
global cut plane defined for the current display configuration.

7 If you selected Yes for Override cut plane, enter a value for Height
to define the cut plane for this object. (Alternatively, you can click

 and specify 2 points in the drawing area to set the new size.)

8 For Use cut plane of containing object when anchored, specify
whether you want the containing object’s cut plane to be used
when the assembly is anchored to that object.
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9 To define additional cut planes for the assembly, click  Manual
cut planes.

10 On the Manual Above and Below Cut Plane Heights worksheet,
click Add, and under Cut Plane, enter the height of the new cut
plane.

Then …If you add a cut plane …

objects are displayed using the
Layer/Color/Linetype properties

at a height that is lower than the
current cut plane

specified for the Below Cut Plane
component of the object.

objects are displayed using the
Layer/Color/Linetype properties

at a height that is higher than the
current cut plane

specified for the Above Cut Plane
component of the object.

You can click Remove to delete a cut plane that you added.

You can also access and modify these same cut plane settings through the
assembly’s context menu, as follows:

1 Select the door and window assembly you want to change,
right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 In the Display Properties dialog, click the Cut Plane tab, and then
change the settings as needed.

6 Click OK twice.

Specifying the Display of Sills for a Door and Window Assembly
Use this procedure to change the sill dimensions for a door and window
assembly in the Sill Plan display representation.

1 Double-click the door and window assembly.
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2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all door and window assemblies in
the drawing, select Drawing default setting. To apply changes to all
assemblies of this style, select Door/Window Assembly Style:<style
name>. For more information on styles, see Door and Window
Assembly Styles on page 1703.

5 For Display representation, select Sill Plan.

6 If necessary, expand Object Display Properties ➤ Advanced, and

click  Sill dimensions.

7 On the Sill Dimensions worksheet, enter the sill extension and
depth dimensions.

Sill components A and B are for the outside of the door and
window assembly. Sill components C and D are for the interior
side.

8 Click OK.

9 On the Display component drop-down list, click the light bulb
icons for individual sill components to turn visibility on or off as
desired.

You can also access and modify sill dimensions and visibility settings through
the door and window assembly’s context menu, as follows:

1 Select the door and window assembly you want to change,
right-click, and click Edit Object Display.

2 Click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 Click the Other tab.
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Door and window assembly sill dimensions

6 Under Sill Dimensions, enter the sill extension and depth
dimensions.

7 On the Layer/Color/Linetype tab, under Visible, click the icons
to turn on visibility for individual sill display components as
necessary.

8 Click OK twice.

Specifying the Display of Other Characteristics of a Door and
Window Assembly

Use this procedure to specify other display properties for an individual door
and window assembly, including cell marker size, the display of miters at
frame corners, and the display of custom components. If you are going to use
custom graphics for a component, draw the component and save it as a block
before you start this procedure.

1 Double-click the door and window assembly.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all door and window assemblies in
the drawing, select Drawing default setting. To apply changes to all
assemblies of this style, select Door/Window Assembly Style:<style
name>. For more information on styles, see Door and Window
Assembly Styles on page 1703.

5 If necessary, expand Object Display Properties ➤ Advanced.
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6 If you want to change the size of the markers used for cells in the
door/window assembly, click Cell marker size, and enter a new

value. (Alternatively, you can click  and specify 2 points in the
drawing area to set the new size.)

7 Optionally, for Show mitres at frame corners, select Yes/No.

8 If you want to add or edit a custom component, for Custom model
components (or Custom plan components, if in a plan view),

click  .

9 On the Custom Model (or Plan) Components worksheet, click
Add, or select one of the components in the list, and click Edit.

10 On the Custom Display Component worksheet, for Component
Type, select Infill, Frame, or Mullion.

11 Enter a name for Component Name, or click Select Component,
and in the Select <component type> Definition dialog, select a
definition and click OK.

12 Select Draw Custom Graphics.

13 Specify the display of the element:

Then …If you want to …

select Replace Graphics.display the block instead of the as-
sociated door/window assembly
element

clear Replace Graphics.superimpose the block over the
door/window assembly element so
that both are displayed

14 Click Select Block, select the custom block that you created, and
click OK.

15 Specify further settings for the custom display block:

Then …If you want to …

select Width, Height, or Depth. To
prevent the block from losing its
proportions, select Lock XY Ratio.

scale the block to fit a particular di-
mension

specify an insertion point on the X,
Y, and Z planes.

specify how the block is inserted
into the grid in the X, Y, and Z dir-
ections
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Then …If you want to …

determine if it should mirror in the
X, Y, or Z direction.

mirror the block

specify the offset in the X, Y, or Z
direction.

offset the block from the grid

16 Click OK twice.

Attaching Hyperlinks, Notes, or Files to a Door and Window
Assembly

Use this procedure to enter notes and attach reference files to a door/window
assembly. You can also edit notes and edit or detach reference files from a
door/window assembly.

1 Double-click the door/window assembly.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click  next to Hyperlink, and specify the
link.

For more information about adding hyperlinks, “Add Hyperlinks
to a Drawing” in AutoCAD Help.

4 To add a note, click  next to Notes, and enter the text.

5 Click OK.

6 To attach a reference file, click  next to Reference documents,
and attach, edit, or detach a reference file:

Then…If you want to…

click Add, select a file, and click
Open.

attach a reference file

select the file, and click the descrip-
tion. Enter the new text, and press
ENTER.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file
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Then…If you want to…

select the file name, and click De-
lete.

detach a reference file

7 Click OK twice.

Editing Objects Anchored in Door and Window Assemblies
When you fill a door/window assembly cell with an infill that contains an
object, such as a door or window, you can edit that object independently from
the door/window assembly. For example, you can select a door from a
door/window assembly and edit its properties. You can edit the anchor settings
for the door to change the orientation of the door and the alignment or offset
of the door in relation to the door/window assembly.

You can also move objects from one cell to another or release the object anchor
so that the object moves independently of the door/window assembly.

When you move or release an object or edit its properties, you are creating a
variation from the infill cell assignment for the door/window assembly style.
By default, these variations (except release) are allowed to persist in the drawing
when you reapply the style to a door/window assembly. However, if you want
these variations to be overridden when you reapply a door/window assembly
style, turn off the Allow Variation from Infill Element Definition option on
the Anchor worksheet of the object’s Properties palette. This option is set on
a per object basis.

Changing the Orientation of an Object Anchored in a Door and
Window Assembly

Use this procedure to change the orientation of an object anchored in a
door/window assembly using grips.

1 Click the object in the door/window assembly for which you want
to change the orientation.

2 Click the appropriate Flip grip to change the X or Y direction of
the object.
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NOTE Alternatively, click Door/Window Assembly tab ➤ Modify

panel ➤ Flip X  or Door/Window Assembly tab ➤ Modify

panel ➤ Flip Y  .

You can also change the orientation of an object, including the
Z direction, using the Anchor worksheet found on the object’s
Properties palette.

Changing the Alignment of an Object Anchored in a Door and
Window Assembly

Use this procedure to modify the alignment of an object that is anchored in
a door/window assembly.

1 Double-click the object in the door/window assembly.

2 On the Properties palette, expand Location, and click Anchor.

3 Click Allow Variation from Infill Element Definition.

4 Select a new alignment for the object.

For more information, see Specifying an Alignment for a Door
and Window Assembly Infill on page 1727.

5 Click OK.

Changing the Offset of an Object Anchored in a Door and
Window Assembly

Use this procedure to change the offset of an object anchored in a door/window
assembly.

1 Double-click the object in the door/window assembly.

2 On the Properties palette, expand Location, and click Anchor.

3 Click Allow Variation from Infill Element Definition.

4 Specify a new offset for the object.

For more information, see Specifying an Offset for a Door and
Window Assembly Infill on page 1727.

5 Click OK.
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Swapping Two Objects Anchored in a Door and Window
Assembly

When you fill a door/window assembly cell with an object, such as a door or
window, you can swap that object with another object in the door/window
assembly.

1 Select one of the objects from the door/window assembly,
right-click, and click Infill Anchor ➤ Swap Objects.

2 Select the object you want to swap with.

Releasing an Object Anchored in a Door and Window Assembly
When you fill a door/window assembly cell with an object, such as a door or
window, that object is anchored to the door/window assembly. While the
anchor is in place, the object moves when you move the door/window
assembly and is removed when you erase the door/window assembly. If you
want to move or erase an object independently from the door/window
assembly, you can release the anchor.

NOTE You can also move or erase the object by changing the element definition
for the cell that contains the object. For more information, see Defining Infills for
Door and Window Assembly Cells on page 1722.

■ Select one of the objects from the door/window assembly, and click

Door/Window Assembly tab ➤ Anchor panel ➤ Release  .

1826 | Chapter 23   Door and Window Assemblies



AEC Polygons

An AEC Polygon is a two-dimensional (2D) area object that can be used as infill for structures
such as curtain walls and layout grids. You can use a True Color display representation to
assign a solid fill to the edges and interiors of AEC Polygons, making these objects useful for
conceptual rendering.

AEC Polygons
An AEC Polygon is a two-dimensional (2D) area object that can be used as infill
for structures such as curtain walls and layout grids. You can use a True Color
display representation to assign a solid fill to the edges and interiors of AEC
Polygons, making these objects useful for conceptual rendering.

AEC Polygons and Curtain Walls

Curtain walls provide a framework for inserting objects such as panels, windows,
and doors. You can use curtain walls to model structures such as the following:

■ Large scale curtain walls

■ Storefronts with components

■ Assemblies of custom-shaped doors and windows

In AutoCAD Architecture, a curtain wall object consists of one or more grids.
Each grid contains cells that can be filled by a panel, or by an object such as a
window or door. AEC Polygons are ideally suited to create panel infills for curtain
walls.

24
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Curtain wall with AEC Polygon infill assignment

A curtain wall can include curtain wall units. Curtain wall units are similar to
curtain walls except that their grid cells can contain only panel infills, and
not objects. Curtain wall units are designed to represent complex elements
that are repeated within the main curtain wall. You can use AEC Polygons to
fill the grids in a curtain wall unit.

Paving and Tiling Patterns

You can use AEC Polygons to create intricate paving and tiling patterns in a
drawing. Using the join, subtract, trim, and split functions of AEC Polygons,
and by creating AEC Polygons from profiles and polylines, you can create
complex and irregular polygon outlines. By adding edges and hatch patterns
to the AEC Polygons, you can display a realistic tiling and paving look.

AEC Polygon Style Components

You can use AEC Polygon styles to define the look and edge widths of a
polygon. You can use the edges to display framing components of infill panels,
or to represent a shadow. Framing components can have different dimensions,
casting shadows with different widths along the edges. When you render the
curtain wall, you can depict different sun angles with different edge widths.

AEC Polygon components
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Polylines and Profiles

Using straight line segments, you can create a freehand AEC Polygon by
drawing a closed contour of the object.

Creating an AEC Polygon

To define complex and curved shapes, either convert an existing polyline into
an AEC Polygon or use a profile definition as the source of the AEC Polygon.

Converting a polyline to an AEC Polygon
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Converting a complex polyline to an AEC Polygon

True Color Display

AEC Polygons have a True Color display representation. When you attach
AEC Polygons as infill panels to curtain walls, you can use the True Color
display representation to create a conceptual rendering of the curtain wall.

Using AEC Polygon Tools to Create AEC Polygons
Tools provided with AutoCAD Architecture let you quickly place AEC Polygons
by selecting an AEC Polygon tool with a specific AEC Polygon style and other
predefined properties. You can use the tool with all of its default settings, or
you can change any properties that are not controlled by the style. You can
also use AEC Polygon tools to create new AEC Polygons by applying tool
properties to existing closed polylines.

An AEC Polygon tool is included in the AutoCAD Architecture Stock Tool
catalog supplied with the Content Browser. For information about using the
Content Browser, see Content Browser Overview on page 129.

Custom palettes created by your CAD manager or other users may also contain
AEC Polygon tools with styles and properties customized for your projects or
office standards.

Creating an AEC Polygon
Use this procedure to create a new AEC Polygon.

You create an AEC Polygon from straight line segments. The AEC Polygon
must have a minimum of three sides and must not intersect itself. The style
that you select controls the width and the justification of the AEC Polygon
edges. The justification determines whether the edges are displayed inside,
outside, or centered on the AEC Polygon vertices.
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1 Click Home tab ➤ Draw panel ➤ Shapes drop-down ➤ AEC

Polygon  .

Alternatively, you can open a tool palette containing an AEC
Polygon tool, and select the tool.

To use the AEC Polygon tool supplied in the AutoCAD
Architecture Stock Tool catalog, open the Content Browser and
navigate to Helper Tools in the Stock Tool catalog; then drag the
AEC Polygon to the drawing area. For more information on using
a catalog tool, see Using a Tool in the AutoCAD Architecture 2012
Workspace on page 168.

2 Specify the start point of the AEC Polygon.

3 Specify further points to define the AEC Polygon.

NOTE You must specify enough points to create at least three sides
for the AEC Polygon.

4 Enter c (Close) to close the AEC Polygon.

Creating an AEC Polygon

Creating an AEC Polygon with User-Specified Settings
Use this procedure to create an AEC Polygon with settings that you specify.

1 Click Home tab ➤ Draw panel ➤ Shapes drop-down ➤ AEC

Polygon  .

Alternatively, you can open a tool palette containing an AEC
Polygon tool, and select the tool.

To use the AEC Polygon tool supplied in the AutoCAD
Architecture Stock Tool catalog, open the Content Browser and
navigate to Helper Tools in the Stock Tool catalog; then drag the
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AEC Polygon to the drawing area. For more information on using
a catalog tool, see Using a Tool in the AutoCAD Architecture 2012
Workspace on page 168.

2 On the Properties palette, expand Basic, and expand General.

3 Specify the start point of the AEC Polygon.

4 Specify further points to define the AEC Polygon.

NOTE You must specify enough points to create at least three sides
for the AEC Polygon.

5 Enter c (Close) to close the AEC Polygon.

Creating an AEC Polygon from a Polyline
Use this procedure to create an AEC Polygon from a closed polyline in a
drawing.

When you create an AEC Polygon by converting a closed polyline in your
drawing, the object that you convert can be created from a combination of
line and arc segments. The polyline must have a minimum of three sides and
must not intersect itself. After you convert the polyline to an AEC Polygon,
the width and justification of the AEC Polygon edges are set by the style that
you select for the AEC Polygon.

1 Draw a polyline in your drawing.

2 Open a palette containing an AEC Polygon tool, right-click the
tool, and click Apply Tool Properties to ➤ Closed Polyline.

3 Select the polyline that you created in step 1, and press ENTER.

4 Enter y (Yes) to erase the polyline after creating the AEC Polygon,
or n (No) to keep the polyline in the drawing.

5 Press ENTER.

Converting a polyline to an AEC Polygon
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Creating an AEC Polygon from a Profile
Use this procedure to create an AEC Polygon from a profile definition in a
drawing.

The profile definition that you convert can be created from a combination of
line and arc segments. The profile definition must have a minimum of three
sides and must not intersect itself. After you create an AEC Polygon from the
profile definition, the width and justification of the AEC Polygon edges are
set by the style that you select for the AEC Polygon. For additional information,
see Editing Profile-based Object Components in Place on page 1143.

1 On the command line, enter aecpolygon.

2 Enter c (Convert) and press ENTER.

3 Enter pr (Profile) and press ENTER.

4 Select the desired profile definition and click OK.

5 Select the insertion point for the new AEC Polygon.

6 Press ENTER.

Converting a profile to an AEC Polygon

Creating an AEC Polygon Tool
Use this procedure to create an AEC Polygon tool and add it to a tool palette.
You may want to create your own AEC Polygon tools if you are placing multiple
AEC Polygons of specific styles that have the same properties.

You can use any of the following methods to create an AEC Polygon tool:

■ Drag an AEC Polygon with the desired properties to a tool palette.

■ Drag an AEC Polygon style from the Style Manager to a tool palette, and
then customize the properties of the new tool.
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■ Copy an existing AEC Polygon tool, and then customize the properties of
the new tool.

■ Drag an AEC Polygon tool from a tool catalog in the Content Browser to
a tool palette, and then customize the properties of the tool.

1 Open the tool palette on which you want to create a tool.

2 Create the tool:

Then…If you want to…

select the AEC Polygon and drag it
to the tool palette.

create a tool from an AEC Polygon
in the drawing

click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from an AEC Polygon
style in the Style Manager

the style you want to copy under
Multi-Purpose Objects, and drag it
to the tool palette. Click OK to close
the Style Manager.

right-click the tool, click Copy, and
click Paste.

copy a tool in the current palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another palette

open the palette where you want
to add the tool, right-click, and click
Paste.

open the tool catalog in the Con-
tent Browser, and locate the tool

copy a tool from the Content
Browser

you want to copy. Position the
cursor over the i-drop handle, and
drag the tool to the tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

This description is used as the tool’s tooltip on the tool palette,
and to describe the tool if it is stored in a tool catalog.
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6 Expand Basic and expand General.

7 Enter a description of the AEC Polygon that you can create using
this AEC Polygon tool.

8 Specify a layer key and any layer key overrides, if you do not want
to use the layer assignments specified in the layer key style used
in the drawing.

9 Select an AEC Polygon style.

10 For Style location, select the drawing file containing the style used
for this AEC Polygon, or select Browse and use a standard file
selection dialog box to select the file.

11 Click OK.

Editing AEC Polygons
You can change the location of an AEC Polygon, adjust the width and
justification of its edges, and change how it is displayed in your drawing. You
can also redefine the geometry of an AEC Polygon or define how AEC Polygons
interact with each other. You can join two AEC Polygons, create a hole in an
AEC Polygon by subtracting the area of another one, create an AEC Polygon
from the intersection of two others, divide or trim an AEC Polygon, and add
or remove its vertices.

AutoCAD Architecture offers several methods for editing AEC Polygons:

■ You can directly edit AEC Polygons using grips for dimensions and other
physical characteristics.

■ For grip edit operations where you are changing a dimension or an angle,
the Dynamic Input feature lets you enter a precise value instead of moving
a grip. When this feature is active (click DYN on the application status
bar), selecting a grip displays a text box in which you can enter the desired
value for the associated dimension or angle. For more information, see
“Use Dynamic Input” in AutoCAD Help.

■ You can change AEC Polygon settings on the Properties palette.

■ You can select editing commands from the contextual ribbon tab and
context menu for a selected AEC Polygon.

Editing AEC Polygons | 1835



Using Grips to Edit AEC Polygons
Use this procedure to change the shape and size of an AEC Polygon in your
current drawing by using grips.

Changing the edge of an AEC Polygon

1 Select the AEC Polygon you want to change.

2 Select an Edge grip.

Viewing the AEC Polygon Edge grip tooltip

The Edge grip has four edit modes: Offset, Add Vertex, Convert
to Arc, and Offset All. The default mode is Offset, which offsets
the selected edge in a direction that is perpendicular to the
midpoint of the edge. Depending on the shape of the AEC Polygon
and the edge you choose to modify, neighboring lines are
extended or trimmed, and new lines are added, as necessary.
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Offsetting the edge of an AEC Polygon using its Edge grip

Use the Add Vertex edit mode to add a vertex to the selected edge,
and create a new edge. If the selected edge is an arc, the new edge
is an arc, as well.
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Adding a vertex to the edge of an AEC Polygon using its Edge grip

Convert to Arc changes the selected edge to an arc and stretches
the midpoint of the edge. The edge grip for an arc also has a
Stretch mode, so that you can stretch the midpoint of the edge
after it has been converted to an arc.
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Converting the edge of an AEC Polygon to an arc using its Edge grip

Offset All moves all edges of an AEC Polygon at an identical
distance. When you drag one edge, all other edges are repositioned
accordingly. This option is very useful for regular resizing
operations, like scaling an AEC Polygon.
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Offsetting all the edges of an AEC Polygon using its Edge grip

3 Specify the new edge location:

Then…If you want to…

move the edge to the desired loca-
tion and click, or enter a value and
press ENTER.

offset the edge

press CTRL to switch to the Add
Vertex edit mode. Move the edge

add a vertex and create an edge

to the desired location and click, or
enter a value and press ENTER.

press CTRL twice to switch to the
Convert to Arc edit mode. Stretch

change the selected edge to an arc

the midpoint to the desired location
and click, or enter a value and press
ENTER.
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Then…If you want to…

press CTRL three times to switch to
the Offset All edit mode. Move the

offset all edges at an identical dis-
tance

selected edge to the desired location
for all edges and click, or enter a
value and press ENTER.

You can press CTRL to toggle among the edit modes.

4 Right-click, and click Deselect All to turn off grips.

Changing the vertex of an AEC Polygon

1 Select an existing AEC Polygon.

2 Select the Vertex grip for the vertex you want to change.

Viewing the AEC Polygon Vertex grip tooltip

The Vertex grip has three edit modes:

■ Move: This is the default mode. Use this mode to move the
selected vertex in any direction. The neighboring segments
are stretched, as necessary.
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Moving the vertex of an AEC Polygon using its Vertex grip

■ Remove: Use this mode to remove a vertex. The neighboring
segments are replaced with a line.
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Removing the vertex of an AEC Polygon using its Vertex grip

■ Offset Edges: Use this edit mode to move a vertex and the
adjacent edges of the AEC Polygon with it.
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Offsetting the edges of an AEC Polygon using its Vertex grip

3 Edit the vertex as necessary:

Then…If you want to…

move the vertex to the desired loca-
tion and click; or enter a value, and
press ENTER.

move the vertex

press CTRL to switch to the Remove
Vertex edit mode, and click to con-
firm the removal.

remove the vertex

press CTRL twice to switch to the
Offset Edges edit mode. Move the

move the vertex and the adjacent
edges

vertex to the desired location, and
click; or enter a value, and press
ENTER.

4 Right-click, and click Deselect All to turn off grips.
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Changing the AEC Polygon Style
Use this procedure to change the style of one or more AEC Polygons. The style
controls the width and justification of the AEC Polygon edges. The justification
determines whether the edges are displayed inside, outside, or centered on
the vertices of the AEC Polygon. The style can also control the display
properties of the AEC Polygon. For more information about styles, see AEC
Polygon Styles on page 1858.

1 Double-click the AEC Polygon you want to change.

2 On the Properties palette, expand Basic, and expand General.

3 Select an AEC Polygon style.

Centering AEC Polygons
Use this procedure to center an AEC Polygon on a specified axis or between
any two specified points.

1 Select the AEC Polygon to center.

2 Click AEC Polygon tab ➤ Modify panel ➤ Center  .

3 Select an existing axis line on which to center the AEC Polygon,
or press ENTER and then specify two points between which to
center the AEC Polygon.

Subtracting AEC Polygons
Use this procedure to subtract AEC Polygons from one another in order to
create a hole in an AEC Polygon. This would be useful, for example, for creating
a complex pattern for a curtain wall infill.
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Subtracting an AEC Polygon from an AEC Polygon

To perform a subtraction operation, you need to select AEC Polygons that
intersect one another. You can choose whether to keep the subtracted AEC
Polygon in the drawing as a separate unit. For example, you may want to keep
the AEC Polygon if you need to subtract the same shape from other AEC
Polygons.

1 Create an AEC Polygon from which to subtract a hole. For more
information, see Creating an AEC Polygon on page 1830.

2 Create a second, smaller AEC Polygon to represent the area to be
subtracted from the larger AEC Polygon.

You can draw the second AEC Polygon within or overlapping the
area of the first AEC Polygon, or you can draw it in another
location and then move it onto the larger AEC Polygon.

3 Select the larger AEC Polygon.

4 Click AEC Polygon tab ➤ Modify panel ➤ Subtract  .

5 Select the smaller AEC Polygon to subtract from the larger AEC
Polygon.

6 Enter y (Yes) to erase the subtracted AEC Polygon, or n (No) to
leave the AEC Polygon in the drawing.

Merging AEC Polygons
Use this procedure to merge two or more AEC Polygons in a drawing. When
you merge two AEC Polygons that overlap each other, their common boundary
is combined to form the boundary of the merged AEC Polygon.
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NOTE When you merge one AEC Polygon with another, the properties of the
merged AEC Polygon are identical to the properties of the first selected AEC
Polygon.

1 Create two overlapping AEC Polygons. For more information, see
Creating an AEC Polygon on page 1830.

2 Select one of the AEC Polygons to be merged.

3 Click AEC Polygon tab ➤ Modify panel ➤ Merge  .

4 Select the AEC Polygon to merge with the first AEC Polygon.

NOTE You can merge only those AEC Polygons that lie on the same
Z-plane. Two AEC Polygons with different Z-positions in the same
coordinate system cannot be merged.

5 Enter y (Yes) to erase the second AEC Polygon, or n (No) to leave
the AEC Polygon in the drawing.

Merging two overlapping AEC Polygons

Arraying AEC Polygons
Use this procedure to create an array of identical AEC Polygons along an axis.

1 Select the AEC Polygon to array.

2 Click AEC Polygon tab ➤ Modify panel ➤ Array  .
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3 Select an edge from which to start the array that is perpendicular
to the array axis, then drag in the direction of the array. Do one
of the following:

■ Offset: start the AEC Polygon array a specified offset distance
from the edge.

■ Clear Distance: specify a clear distance between each arrayed
AEC Polygon.

■ Pick Array Distance: specify a distance between arrayed AEC
Polygons.

■ Enter Count: specify the number of AEC Polygons to appear
in the array.

Alternatively, you can press ENTER and then specify two points
between which to array the AEC Polygon.

Repositioning AEC Polygons
Use this procedure to reposition an AEC Polygon.

1 Select the AEC Polygon to reposition.

2 Click AEC Polygon tab ➤ Modify panel ➤ Reposition From  .

3 Select an existing boundary from which to reposition the AEC
Polygon, or specify two points to define a reference edge.

Evenly Spacing AEC Polygons
Use this procedure to space AEC Polygons evenly along an axis.

1 Select the AEC Polygon to space evenly.

2 Click AEC Polygon tab ➤ Modify panel ➤ Space Evenly  .

3 Select an edge as the axis along which to space all the AEC
Polygons evenly, and specify a start point and an endpoint along
the edge.

Alternatively, press ENTER and specify two points between which
the AEC Polygons will be spaced evenly from each other.
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Trimming AEC Polygons
Use this procedure to trim a side from an AEC Polygon by defining a trim line
through an existing AEC Polygon.

Trimming an AEC Polygon

1 Select the AEC Polygon to be trimmed.

2 Click AEC Polygon tab ➤ Modify panel ➤ Trim  .

3 Specify a start point for the trim line. This line cuts through the
AEC Polygon, creating the area to trim and the area to retain.

4 Specify an endpoint for the trim line.

5 Select the side of the AEC Polygon to be trimmed.

Dividing AEC Polygons
Use this procedure to divide an AEC Polygon into two separate AEC Polygons
by defining a division line through it.
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Dividing an AEC Polygon

1 Select the AEC Polygon to be divided.

2 Click AEC Polygon tab ➤ Modify panel ➤ Divide  .

3 Specify a start point for the division line.

NOTE You can specify only a start point and endpoint for your
division line. You cannot specify additional points.

4 Specify an endpoint for the division line.

The AEC Polygon is divided by the line that you defined.

Cropping AEC Polygons
Use this procedure to create a new AEC Polygon from the overlapping portion
of two intersecting AEC Polygons. You can choose whether to retain the
original geometry after creating the new intersection AEC Polygon.

Intersecting AEC Polygons with original geometry erased
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Intersecting AEC Polygons with original geometry retained

1 Create two overlapping AEC Polygons. For more information, see
Creating an AEC Polygon on page 1830.

2 Select the first overlapping AEC Polygon.

3 Click AEC Polygon tab ➤ Modify panel ➤ Crop  .

4 Select the second overlapping AEC Polygon.

5 Enter y (Yes) to erase the original AEC Polygons, or n (No) to leave
the AEC Polygons in the drawing.

Adding a Vertex to an AEC Polygon
You can add a vertex to an existing AEC Polygon to change its shape. A vertex
is the location where the edges of the AEC Polygon meet.

Adding a vertex to an AEC Polygon

1 Select the AEC Polygon for which to add a vertex.

2 Click AEC Polygon tab ➤ Profile panel ➤ Add Vertex  .
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3 Select the point in your drawing to add the new vertex.

Line segments are drawn from the two existing vertices of the
AEC Polygon closest to the point that you selected to form the
new vertex.

4 Press ENTER.

Removing a Vertex from an AEC Polygon
You can remove a vertex from an existing AEC Polygon to change its shape.

Removing a vertex from an AEC Polygon

1 Select the AEC Polygon from which to remove a vertex.

2 Click AEC Polygon tab ➤ Profile panel ➤ Remove Vertex  .

3 Select the vertex you want to remove.

4 Press ENTER.

Converting an AEC Polygon to a Polyline
Use this procedure to convert an existing AEC Polygon to a polyline. When
you create a polyline from an AEC Polygon that contains a hole, each ring of
the AEC Polygon is converted into an individual polyline.

1 Select the AEC Polygon from which to create a polyline.

2 Click AEC Polygon tab ➤ Convert To panel ➤ Polyline  .

3 When prompted to erase the original geometry, press ENTER to
keep the linework, or enter y (Yes) to erase it.
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Converting an AEC Polygon to a Profile
Use this procedure to convert an existing AEC Polygon to a profile definition.
You can create a new profile definition or overwrite an existing profile
definition. Then, use the profile definition you create with objects that are
profile based or have profile-based components, such as the soffit of a roof
slab. For detailed information, see the sections for the individual objects.

1 Select the AEC Polygon from which to create a profile definition.

2 Click AEC Polygon tab ➤ Convert To panel ➤ Profile  .

3 Specify the insertion point of the resulting profile, or press ENTER
to use the centroid as the insertion point.

4 Enter n (New) to create a new profile definition, or e (Existing) to
replace an existing profile.

5 Enter a name for the new profile definition, or select from the
existing profile definitions on the Profile Definitions worksheet
and click OK.

Profile Definitions worksheet

The existing profile definition you select is replaced by the one
you are creating from an AEC Polygon.

Changing the Rotation of an AEC Polygon
Use this procedure to change the rotation of an AEC Polygon.

1 Double-click the AEC Polygon whose rotation you want to change.

2 On the Properties palette, expand Basic, and expand Location.

3 Enter a value for Rotation.
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Changing the Elevation of an AEC Polygon
Use this procedure to change the elevation of an AEC Polygon.

1 Double-click the AEC Polygon for which to change the elevation.

2 On the Properties palette, expand Basic, and expand Location.

3 Enter a value for Elevation.

Changing the Location of an AEC Polygon
Use this procedure to relocate an AEC Polygon by changing the coordinate
values of its insertion point. You can also move an AEC Polygon by cutting
and pasting it.

AEC Polygons are oriented with respect to the WCS or the current UCS. For
example, if the top and bottom of an AEC Polygon are parallel to the XY plane,
its normal is parallel to the Z axis. You can change the orientation of the AEC
Polygon by aligning its normal with another axis. You can also rotate the AEC
Polygon on its plane by changing the rotation angle. For information about
the world coordinate system (WCS) and the user coordinate system (UCS),
see “Use Coordinates and Coordinate Systems” in AutoCAD help.

1 Double-click the AEC Polygon you want to move.

2 On the Properties palette, expand Location.

3 Click Additional information.

4 Specify the location of the AEC Polygon:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the AEC Polygon

make the normal of the AEC Poly-
gon parallel to the Z axis: under

locate the AEC Polygon on the XY
plane

Normal, enter 1 for Z, and enter 0
for X and Y.

make the normal of the AEC Poly-
gon parallel to the X axis: under

locate the AEC Polygon on the YZ
plane

Normal, enter 1 for X and enter 0
for Y and Z.
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Then…If you want to…

make the normal of the AEC Poly-
gon parallel to the Y axis: under

locate the AEC Polygon on the XZ
plane

Normal, enter 1 for Y and enter 0
for X and Z.

enter a new value for Rotation
Angle.

change the rotation of the AEC
Polygon

5 Click OK.

Specifying Fill Properties for the True Color Display
Representation of an AEC Polygon

Use this procedure to specify the fill properties for an AEC Polygon in the True
Color display representation, which is used for high-resolution renderings.

NOTE Make sure that you do not use the True Color display representation and
the Model display representation of an AEC Polygon simultaneously in one view.
The Interior Fill and Edge Fill components of the Model display representation
would be drawn on top of the Interior Fill and Edge Fill components of the True
Color display representation. It is recommended that you create separate views
for regular viewing and True Color renderings.

1 Double-click the AEC Polygon you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all AEC Polygons in the drawing,
select Drawing default setting. To apply changes to all AEC Polygons
of this style, select AEC Polygon Style:<style name>. For more
information on styles, see AEC Polygon Styles on page 1858.

5 For Display representation, select True Color.
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NOTE The True Color display representation is not turned on for any
display sets by default. If it is not included on the drop-down list,

click Manage tab ➤ Style & Display panel ➤ Display Manager  .
Expand Representations by Object ➤ AEC Polygon, and then select
the display set for the current display configuration and any others
for which you want this display representation turned on.

6 If necessary, expand Object Display Properties ➤ Advanced, and

click  next to Fill properties.

7 Specify the fill properties:

Then…If you want…

in the Exterior panel, select Edge
Fill, and then select a color for Edge

a True Color fill for the outer part
of the AEC Polygon

Color, or click Other to choose a
different color.

in the Interior panel, select Interior
Fill, and then select a color for Interi-

a True Color fill for the inner part
of the AEC Polygon

or Color, or click Other to choose
a different color.

NOTE If the edge dimensions of the AEC Polygon are set to 0, the
edge fill is not displayed.

8 Click OK.

You can also access and modify these same settings through the AEC Polygon’s
context menu, as follows:

1 Select the AEC Polygon, right-click, and click Edit Object Display.

2 Click the Display Properties tab.

3 Select the True Color display representation, and select Object
Override.

4 If necessary, click  .

5 On the Fill Properties tab, adjust the settings as needed.

6 Click OK twice.
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Attaching Hyperlinks, Notes, or Files to an AEC Polygon
Use this procedure to attach hyperlinks, enter notes, or attach reference files
to an AEC Polygon. You can also edit notes and edit or detach reference files
from an AEC Polygon.

1 Double-click the AEC Polygon to which to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click  next to Hyperlink, and specify the
link.

For more information about adding hyperlinks, see “Add
Hyperlinks in a Drawing” in AutoCAD help.

4 To add or edit a note, click  next to Notes, enter text, and click
OK.

5 To attach, detach, or edit a reference file, click  next to
Reference documents, and then do any of the following:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

6 Click OK.
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AEC Polygon Styles
An AEC Polygon style is a group of properties that determines the appearance
and other characteristics of AEC Polygons. AEC Polygon styles control the
following parameters:

■ default dimensions, including edge width and justification

■ default display properties for the interior and edges of the AEC Polygon
The display properties of an AEC Polygon allow you to hatch its interior
and edges, or fill its edges and interior with a solid color fill.

■ masking capability

Creating Tools from AEC Polygon Styles

You can create an AEC Polygon tool from any AEC Polygon style. You can
drag the style from the Style Manager onto a tool palette. You can then specify
default settings for any AEC Polygon created with that tool. For more
information, see Using AEC Polygon Tools to Create AEC Polygons on page
1830.

Managing AEC Polygon Styles

To create, copy, or edit styles, you access the Style Manager. The Style Manager
provides a central location in AutoCAD Architecture where you can work with
styles from multiple drawings and templates. For more information, see Style
Manager Overview on page 870.

Creating an AEC Polygon Style
Use this procedure to create an AEC Polygon style. You can create a new style
using default style properties, or by copying an existing style. After you create
a style, you edit its properties to customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand AEC Polygon Styles.

NOTE Alternatively, you can select an AEC Polygon in the drawing,
and click AEC Polygon tab ➤ General panel ➤ Edit Style

drop-down ➤ AEC Polygon Styles  .

1858 | Chapter 24    AEC Polygons



3 Create an AEC Polygon style:

Then…If you want to…

right-click AEC Polygon Styles, and
click New.

create a style with default properties

right-click the AEC Polygon style
you want to copy, and click Copy.
Right-click, and click Paste.

create a style from an existing style

4 To rename the new AEC Polygon style, right-click the style, and
click Rename.

5 Enter a name for the new AEC Polygon style, and press ENTER.

6 Edit the style properties of the new AEC Polygon style:

Then…If you want to…

see Changing the Width and Justi-
fication of the AEC Polygon Edges
on page 1860.

change the edge width and edge
alignment

see Masking Underlying Objects
with AEC Polygons on page 1861.

add an AEC Polygon as a back-
ground mask

see Specifying the Layer, Color, and
Linetype of an AEC Polygon Style
on page 1863.

change the Layer/Color/Linetype
properties

see Specifying the Hatching of an
AEC Polygon Style on page 1864.

change the AEC Polygon interior
and exterior hatching

see Setting the Colors of the True
Color Display Representation on
page 1866.

change the colors of the True Color
display representation

see Attaching Notes and Files to an
AEC Polygon Style on page 1867.

add notes and files to the style

see Adding Classifications to an AEC
Polygon Style on page 1868.

add classifications to an AEC Poly-
gon style

7 If you want to create an AEC Polygon tool from the new style,
drag the style from the Style Manager to a tool palette.
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You can later rename the tool and specify other properties for it
as described in Creating an AEC Polygon Tool on page 1833.

8 Click OK.

Changing the Width and Justification of the AEC Polygon Edges
Use this procedure to change the width and justification of the edges of an
AEC Polygon in the AEC Polygon style. The justification determines whether
the edges are displayed inside, outside, or centered on the vertices of the AEC
Polygon.

Justifying AEC Polygon edges

1 Select an AEC Polygon.

2 Click AEC Polygon tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

3 Click the Dimensions tab.

4 To change the width of the AEC Polygon edges, enter a new value
for Edge Width.

5 Change the justification of the AEC Polygon edges as desired:

Then …If you want to…

select In for Justify.display the edges inside the AEC
Polygon vertices

select Center for Justify.display the edges centered within
the vertices of the AEC Polygon
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Then …If you want to…

select Out for Justify.display the edges outside the AEC
Polygon vertices

6 Click OK.

Masking Underlying Objects with AEC Polygons
Use this procedure to change an AEC Polygon style to mask a background.
This style property also determines if masking break marks display correctly
in your drawings. For more information about working with break marks, see
The Basic Annotation Tool on page 3587.

1 Select an AEC Polygon.

2 Click AEC Polygon tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

3 Click the Other tab.

4 Select Use Background Mask.

5 Click OK.

All AEC Polygons of this style use a background mask in the
current drawing.

Specifying the Display Properties of an AEC Polygon Style
In most cases, you want the appearance of AEC Polygons that belong to the
same style to be consistent throughout a drawing. To achieve this, you specify
the display properties of the AEC Polygons in each AEC Polygon style:

■ The layer, color, and linetype of AEC Polygon components

■ The hatching used for the components of the AEC Polygon
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AEC Polygon components

Display components in Model view 

DescriptionComponent

Inner edge of the AEC Polygon.

NOTE When the edge dimensions are set
to 0, the interior edge is the only edge of
the AEC Polygon.

Interior Edge

Outer edge of the AEC Polygon.

NOTE When the edge dimensions are set
to 0, the exterior edge is not displayed in
the AEC Polygon.

Exterior Edge

Hatch component of the inner part of the
AEC Polygon.

NOTE When the edge dimensions are set
to 0, the interior hatch is the only hatch of
the AEC Polygon.

Interior Hatch

Hatch component of the outer part of the
AEC Polygon.

NOTE When the edge dimensions are set
to 0, the edge hatch is not displayed in the
AEC Polygon.

Edge Hatch

The fill component of the inner part of the
AEC Polygon. This component is displayed

Interior Fill

only in rendered views. Make sure that for
each rendered view you use either the In-
terior Fill and Edge Fill components of the
Model display representation or the Interior
Fill and Edge Fill components of the True
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Display components in Model view 

DescriptionComponent

Color display representation. If you use
both display representations simultan-
eously, the fills are drawn on top of each
other. For detailed information, see Setting
the Colors of the True Color Display Repres-
entation on page 1866.

The fill component of the outer part of the
AEC Polygon. This component is displayed

Edge fill

only in rendered views. Make sure that for
each rendered view you use either the In-
terior Fill and Edge Fill components of the
Model display representation or the Interior
Fill and Edge Fill components of the True
Color display representation. If you use
both display representations simultan-
eously, the fills are drawn on top of each
other. For detailed information, see Setting
the Colors of the True Color Display Repres-
entation on page 1866.

NOTE When the edge dimensions have
been set to 0, the edge fill is not displayed
in a rendered AEC Polygon.

Specifying the Layer, Color, and Linetype of an AEC Polygon
Style

Use this procedure to change the following display properties of an AEC
Polygon style:

■ Visibility (component is on or off)

■ Layer

■ Color

■ Linetype

■ Lineweight
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■ Linetype Scale

■ Plot Style

Materials cannot be assigned to AEC Polygons. Note that you can also use the
Display tab of the Properties palette to change the display property settings
for a selected object display component in the current display representation.
For more information, see Using the Properties Palette to Change Display
Properties on page 793.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand AEC Polygon Styles.

NOTE Alternatively, you can select an AEC Polygon in the drawing,
and click AEC Polygon tab ➤ General panel ➤ Edit Style

drop-down ➤ AEC Polygon Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the Model display representation, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select the component to change, and select a different setting for
the property.

9 Click OK twice.

Specifying the Hatching of an AEC Polygon Style
Use this procedure to specify the hatching of an AEC Polygon style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand AEC Polygon Styles.

NOTE Alternatively, you can select an AEC Polygon in the drawing,
and click AEC Polygon tab ➤ General panel ➤ Edit Style

drop-down ➤ AEC Polygon Styles  .

3 Select the style you want to edit.
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4 Click the Display Properties tab.

5 Select the display representation in which changes should appear,
and select Style Override.

6 If necessary, click  .

7 Click the Hatching tab.

8 Click the setting for Pattern.

9 Select the hatching pattern:

Then…If you want to…

select Predefined for Type, and then
select a pattern.

select a hatching pattern that is
available in the software

select Custom for Type, and then
enter the name of the custom pat-

select a custom pattern

tern. If necessary, click Browse, and
navigate to the folder where the
custom pattern file is located.

select User-defined for Type, and
clear Double Hatch.

select single hatching

select User-defined for Type, and
select Double Hatch.

select double hatching

select Solid Fill for Type.select solid fill

TIP Mask blocks do not hide the True Color representation of AEC
Polygons, but you can use hatching to work around this. Use the
Model representation of the AEC Polygon, set the hatch to Solid, and
select the appropriate True Color for the hatch.

10 Click OK.

11 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

12 Click Angle, and enter the angle for the selected pattern.
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13 Click Orientation, and specify how the hatching is oriented:

Then…If you want to…

select object.orient the hatching to the AEC
Polygon, regardless of the object’s
rotation

select global.orient the hatching to the World
Coordinate System

14 Click OK twice.

Setting the Colors of the True Color Display Representation
Use this procedure to set the colors of the AEC Polygon with True Color display
representations. Use True Color display representation for high-resolution
renderings.

NOTE Make sure that you do not use the True Color display representation and
the Model display representation of an AEC Polygon simultaneously in one view.
The Interior Fill and Edge Fill components of the Model display representation
would be drawn on top of the Interior Fill and Edge Fill components of the True
Color display representation. It is recommended that you create separate views
for regular viewing and True Color renderings.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand AEC Polygon Styles.

NOTE Alternatively, you can select an AEC Polygon in the drawing,
and click AEC Polygon tab ➤ General panel ➤ Edit Style

drop-down ➤ AEC Polygon Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the True Color display representation, and select Style
Override.

6 If necessary, click  .
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7 Specify the fill properties:

Then…If you want…

select Edge Fill, and select a color
for Edge Color, or click Other to
choose a different color.

a True Color fill for the outer part
of the AEC Polygon

select Interior Fill, and select a color
for Interior Color, or click Other to
choose a different color.

a True Color fill for the inner part
of the AEC Polygon

NOTE If the edge dimensions of the AEC Polygon are set to 0, the
edge fill is not displayed.

8 Click OK twice.

Attaching Notes and Files to an AEC Polygon Style
Use this procedure to enter notes and attach reference files to an AEC Polygon
style. You can also edit notes and edit or detach reference files from an AEC
Polygon style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand AEC Polygon Styles.

NOTE Alternatively, you can select an AEC Polygon in the drawing,
and click AEC Polygon tab ➤ General panel ➤ Edit Style

drop-down ➤ AEC Polygon Styles  .

3 Select the style you want to edit.

4 Click the General tab.

5 To add a description to the AEC Polygon, enter it under
Description.

6 Click Notes.

7 To add or edit a note, click the Notes tab, and enter the note.
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8 To attach, edit, or detach a reference file, click the Reference Docs
tab:

Then…If you want to…

click Add, select a file, and click
open. Click OK.

attach a reference file

select the file, and click Edit. Edit
the description, and click OK.

edit the description of a reference
file

double-click the reference file to
start its application. Close the applic-
ation when you are finished editing.

change the reference file

select the file name, and click De-
lete.

detach a reference file

9 Click OK twice.

Adding Classifications to an AEC Polygon Style
Use this procedure to specify classifications for any classification definition
applied to an AEC Polygon style.

For more information about creating and applying classification definitions,
see Classification Definitions on page 3872.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand AEC Polygon Styles.

NOTE Alternatively, you can select an AEC Polygon in the drawing,
and click AEC Polygon tab ➤ General panel ➤ Edit Style

drop-down ➤ AEC Polygon Styles  .

3 Select the style that you want to change.

4 Click the Classifications tab.

By default, the classification for all classification definitions is
Unspecified. If no classification definitions are listed, none are
applied to AEC Polygon styles.
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5 For each classification definition, select the classification you want
applied to the current AEC Polygon style.

6 Click OK.
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Doors

You can add many different types of doors in AutoCAD Architecture. Doors can be anchored
to walls or door/window assemblies.

Doors
You can create doors using different design parameters for style, standard size,
width and height, threshold height, and head height. You can choose styles
with glass shapes that receive standard muntins patterns, and create your own
custom glass shapes from profiles.

AutoCAD Architecture provides ready-to-use door styles. The door style
determines the default dimensions of doors and the door shape and type:

■ The door shape determines the geometry of the door panel, such as
rectangular, half-round, and arch. You can also create custom door shapes
from profiles.

■ The door type determines the number of panels and the method of opening
the door, such as single, double, bifold, pocket, revolving, and overhead.

You can define standard sizes in a door style and then select the size you want
to use when you place the door in a drawing.

Anchoring Doors

Doors can be anchored to specific locations in walls or door and window
assemblies, so that when the wall or door and window assembly moves or
changes size, the location of the door in that object remains constant.
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Door Dimensions

Some door dimensions depend on the shape and type specified in the door
style.

Rise is the height from the top of the rectangular portion of a door to the peak
of the door opening for Gothic, Arch, and Peak Pentagon door shapes.

Leaf specifies the door size for pairs of Uneven, Uneven-Dhung, and Uneven
Opposing door types. For more information about leaf, see Door Properties
on page 1876.

Door Endcaps

Doors that are anchored in a wall can have endcap styles applied to them.
The endcap shapes for wall openings are defined in the wall style and are a
property of the wall. For information on setting an opening endcap style in
a wall, see Working with Wall Endcaps and Opening Endcaps on page 1373.

Vertical Alignment of Doors

You use vertical alignment settings to control the placement of the door in
the wall, the location of the working point vertically in the wall, and how the
door responds to modifications in height. To determine the working point
on the door, use the threshold and head height settings. You can place the
working point at the sill or at the head. For example, if you specify the vertical
alignment as 0'' and the door height as 7'–0'', the door opening height is 7’–0''.
If you next specify the height of the door as 6'–8'', the door threshold remains
at 0'' and the door opening height becomes 6’–8''.

For the door head working point, if you specify the vertical alignment as 7'–0''
and the door height as 7'–0'', the door opening height is 7–0''. If you specify
the door height as 6'–8'', the door head remains at 7'–0'' and the door threshold
becomes 4''.

Materials in Doors

You can assign materials to a door. Materials are displayed in wireframe and
working shade views, or when rendered. Materials have specific settings for
individual components of a door, such as the panel, the stop, the frame, or a
glass inset.
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Doors in Wireframe, Hidden, Realistic, and Conceptual Visual Style representations

AutoCAD Architecture provides predefined materials for common design
purposes, which contain settings for doors. You can use the predefined
materials “as is,” or modify them for your special designs. You can also create
your own materials. Styles provided with the software have appropriate
materials already assigned to them. For more information, see About Door
Display Components and Materials on page 1910.

Creating a Door
Use this procedure to add a door to the drawing. For information on the
properties of doors, see Door Properties on page 1876.

Where can I find Door Tools?

In a standard US installation of AutoCAD Architecture, you can find door
tools in the following locations:

■ Tool Palettes: Design Tool Palettes group ➤ Design tab (standard door tool)

■ Tool Palettes: Design Tool Palettes group ➤ Doors tab

■ Content Browser ➤ Stock Tool Catalog ➤ Architectural Object Tools
(standard door tool)

■ Content Browser ➤ Sample Palette Catalog ➤ Design  ➤ Doors
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■ Content Browser ➤ Design Tool Catalog ➤ Doors and Windows ➤ Doors

For information about finding tools in Content Browser, see Searching for
Items in a Tool Catalog on page 155

How can I create Door Tools?

There are multiple ways to create door tools in AutoCAD Architecture:

■ Creating a Tool from an Object in the Drawing on page 92

■ Copying a Tool from a Tool Palette on page 93

■ Creating a Tool from the Style Manager on page 94

■ Creating a Tool from AEC Content in DesignCenter on page 95

Predefined door tools

1 Select a door tool on a tool palette.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Door

drop-down ➤ Door  .

2 In the drawing, select a wall or a door and window assembly in
which to insert the door, or press ENTER to add a freestanding
door.

3 Specify the insertion point for the door.
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In order to have full flexibility for defining the insertion point,
verify the following:

■ The Position along wall setting on the Properties palette is set
to Unconstrained.

■ The OSNAP setting in the status bar is turned off.

Otherwise the door insertion point will be aligned to the center
or end points of the wall, or to any of the active OSNAP points.

Command line options for easier insertion

■ Enter CY (cycle measure to) once or twice on the command
line in order to switch the insertion point of the door from
hinge (default) to center and latch.

■ Enter RE (Reference point on) in order to measure the insertion
point of a door in relation to a specified point in the drawing.

4 Continue adding doors, and press ENTER.

Creating a Door in a Door and Window Assembly
Inserting a Door or Window into a Door and Window Assembly on page 1753.

Converting Objects to a Door
Use this procedure to convert one of the following objects to a door:

■ Door and window assembly

■ Window

■ Opening

For information about the properties you can set, see Door Properties on page
1876.

1 Select a door tool on a tool palette.

2 Right-click the tool, and click Apply Tool Properties
to ➤ Door/Window Assembly, Opening, Window.

3 Select the door/window assembly, window, or opening to convert,
and press ENTER.

Creating a Door in a Door and Window Assembly | 1875



4 Edit the properties of the door in the Properties palette, if needed.

Door Properties
The following properties can be set for a door. Note that some properties are
available only during adding a door, or for door tools.

For information about using these properties for a door or door tool, see the
following:

■ Creating a Door on page 1873

■ Changing the Tool Properties on page 89

How to setDescriptionSpecial ConditionProperty

General Category

Click the description icon
and enter a description text.

User-defined description of the
door.

NOTE You can add a description
to a door object or to a door
tool.

Description

Click the icon for Layer key
or Layer override, and select

If you do not want to use the
door layer assignment specified

Door tools onlyLayer key/Lay-
er Overrides

a layer key or a layer over-in the layer key style of the
ride. Layer overrides are nowdrawing, you can specify a layer
available for all layer key
styles.

key and layer key overrides for
the door tool.

Click the drop-down list and
select a layer.

When you insert a door, the lay-
er assignment is defined either

Door object
only/not during
door insertion

Layer

by the layer key style used for
the drawing, or by the layer key
and layer overrides in the door
tool. You can change the layer
later with the Layer property.

Click the drop-down list and
select a style.

Specifies the door style. The style
defined in the door tool is the
default.

Style

1876 | Chapter 25   Doors



How to setDescriptionSpecial ConditionProperty

Click the drop-down list and
either select a file, or click

Specifies the drawing file contain-
ing the style used for this door
tool.

Door tools onlyStyle Location

Browse to navigate to the file
containing the style you want
to use for this tool.

Click the drop-down list and
select a setting.

Options

Defines if this door can be used
as a boundary when generating
associative spaces. This setting
is relevant only for standalone
doors.

NOTE If a door, window, or
opening is anchored in a wall,
the Bound Spaces setting of the
wall is used for the opening, too.

Bound Spaces

■ By style (default): The
Bound spaces setting
defined in the door style
is used.

■ Yes: this door can be
used as a boundary ob-For information on associative

spaces, see Generating Associat-
ive Spaces on page 2940.

ject for associative
spaces.

■ No: this door cannot be
used as a boundary ob-
ject for associative
spaces.

Dimensions Category

Click the drop-down list, and
select a standard size. If no

In the door style, you can define
a number of standard sizes.

Standard sizes

standard sizes are available,When you add a door, you can
see Specifying the Standardselect one of the predefined

sizes. Sizes of a Door Style on page
1904
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How to setDescriptionSpecial ConditionProperty

Enter a value for Rise, or click

 to pick points on the
screen to specify the rise.

Specifies the height of a pointed
or arched top of the door

Illustration

available only for
Gothic, Arch, and
Peak Pentagon door
shapes

Rise

Enter a value for Leaf width,

or click  to pick points on
the screen to specify the leaf.

Determines the width of the
door panel in an uneven door
type

Illustration

Uneven, Uneven-
Dhung, and Uneven
Opposing door
types only

Leaf width
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How to setDescriptionSpecial ConditionProperty

If no standard sizes have been
defined in the door style, or you

Width/Height

do want to use a different size,
you can edit the width and
height of the door.

Click the drop-down list and
select Inside of Frame or
Outside of Frame.

Specifies whether the width and
height of the door is measured
to the inside of the door frame

Measure to

or the outside. When a door is
measured to the outside of the
frame it is smaller by the amount
that is deducted for the frame.

Illustration
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How to setDescriptionSpecial ConditionProperty

Enter a value.Lets you determine at which
opening angle the door will be
displayed.

Swing angle and display
properties
The swing angle can also be
determined in the display

Swing Angle

properties of the door style.
The settings in the style
override properties setting.
For more information, see
Specifying the Opening
Percentage for Display Rep-
resentations in a Door on
page 1921.

Illustration

Location Category
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How to setDescriptionSpecial ConditionProperty

Click the drop-down list and
select Unconstrained or Off-
set/Center.

Specifies the insertion point of
the door relative to the wall or
door/window assembly. You
have the following options:

Only during adding
a door/anchored
walls

Position along
wall

■ Unconstrained: you can
place the door anywhere on
the wall.

NOTE This will work only
if the Osnap is turned off,
otherwise the door will
snap to wall points.

■ Offset/Center: allows you
either place the door in the
center of the wall, or at a
specified offset from the wall
end.

Enter a value for Automatic

Offset, or click  to pick

Specifies the offset from the wall
end during insertion if you have
chosen Offset/Center for Position
along wall

Only during adding
an anchored door

Automatic
Offset

points on the screen to spe-
cify the offset.

Click the drop-down list and
select Threshold or Head.

Lets you specify if the vertical
height of the door should be

anchored doors
only

Vertical Align-
ment

measured to the door threshold
or the door head.

Enter a value for Head Height
or Threshold height, or click

Depending on the vertical align-
ment you chose, you can modify

anchored doors
only

Head
Height/Threshold
Height

 to pick points on the
screen to specify the height.

either the head height or the
threshold height of the door. For
example, if you want to create
an elevated threshold, you select
Threshold for Vertical Alignment,
and then enter the elevation of
the threshold under Threshold
height.
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How to setDescriptionSpecial ConditionProperty

Click the Anchor worksheet,
and enter the desired values
there.

More information

The anchor worksheet lets you
change the position and rotation
of the door in relation to the wall
it is anchored to.

anchored doors
only/not available
for door tools

Anchor

■ Using Anchors to
Change the Horizontal
Position of a Door on
page 1887

■ Using Anchors to
Change the Vertical Posi-
tion of a Door on page
1889

■ Using Anchors to
Change the Position of a
Door Within a Wall on
page 1890

■ Changing the Orienta-
tion of a Door to a Wall
on page 1892

Click the Additional Informa-
tion worksheet, and enter the

The additional information
worksheet lets you change the

freestanding doors
only/not available
for door tools

Additional In-
formation

desired values there. Forposition of a a freestanding door
relative to the WCS or UCS. more information, see Chan-

ging the Location of a
Freestanding Door on page
1893.

Endcaps Category

Click the drop-down list, and
select an endcap style. If you

Lets you define an endcap style
for the door where it is connec-

anchored doors
only/not available
for door tools

Opening End-
cap

select By Wall Style, the wall
endcaps will be used.

ted to the wall. For more inform-
ation, see Working with Wall
Endcaps and Opening Endcaps
on page 1373.
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Editing Doors
You can edit doors in your drawing with different tools and methods.

Using Grips to Edit Doors
For grip edit operations where you are changing a dimension or an angle, the
Dynamic Input feature lets you enter a precise value instead of moving a grip.

When this feature is active (click  on the application status bar), selecting
a grip displays a text box in which you can enter the desired value for the
associated dimension or angle. For more information, see “Use Dynamic Input”
in AutoCAD Help.

You can use the following grips to modify doors:

DescriptionGrip

Lets you change the width of a door

NOTE Initially the grip is set to con-
strain the sizing to one of the standard
values on page 1904defined for the door’s
style.

 (Width)
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DescriptionGrip

The CTRL key acts as a toggle between
standard and custom sizing.

Additional information
A series of tick marks indicates
the standard sizes for the selected
dimension. As you move the grip,
it snaps to each tick mark and
displays the measurement at that
mark.
The size and color of the grip tick
marks indicate whether setting a
standard value for the dimension
will result in a standard door size.
For example, if the height of the
door is set to a non-standard
value, then even if you set the
door width to a standard value
for that door’s style, the door is
still not a standard size. Long grey
tick marks indicate that a stand-
ard size is possible; short red
marks indicate that another di-
mension is already set to a non-
standard value.

Lets you change the Height of a door
 (Height)

Lets you move a door within a wall

More options for moving a door
 (Location)

■ Moving a Door Along a Wall on
page 1885

■ Moving a Door Within a Wall on
page 1886

■ Moving a Door to a Different Wall
on page 1892

■ Releasing a Door from a Wall on
page 1892
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DescriptionGrip

Lets you change the hinge side of the
door (Flip Hinge)

Lets you change the swing direction of
the door (Flip Swing

Direction)

Rise
Rise applies to Peak Pentagon, Arch,
and Gothic door shapes. For more in-
formation, see Specifying the Design
Rules of a Door Style on page 1903.

Moving a Door Along a Wall
Use this procedure to change the location of one or more doors along a wall
by offsetting the doors from a reference location.

This feature is useful when you want to position a door at a specified distance
from another object. For example, you may want to specify an exact distance
between a series of doors along a wall.

1 Select the doors you want to move.

2 Click Door tab ➤ Anchor panel ➤ Reposition Along Wall  .

A marker indicates the current location within the opening: left
jamb, center of door, or right jamb.

3 Specify how to measure the offset:

Then…If you want to…

select a point near the
center of the door.

measure the offset from
the center of the door

select a point on the
jamb of the door you
want to measure from.

measure the offset from
the left or right jamb

4 Select a point to measure to (the reference point).
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5 Specify the distance between the points you selected:

Then…If you want to…

enter 0.move the door to the reference
point

enter a value for the offset distance.move the door a specified distance
from the reference point

select the two points measuring the
distance.

specify the distance as a measure-
ment between two points, such as
the distance between the centers
of two doors that are correctly posi-
tioned

Moving a Door Within a Wall
Use this procedure to move one or more doors within a wall by offsetting the
doors from a reference location.

This feature allows you to align doors within the thickness of a wall. You can
set an offset distance from any point within a wall, or center the doors between
the faces of a wall. You can select doors, windows, or openings, and reposition
them at the same time. If you select more than one object, you can select only
one side to offset.

1 Select the doors you want to move.

2 Click Door tab ➤ Anchor panel ➤ Reposition Within Wall  .

A marker indicates the current location within the opening. This
may be the center of the frame, the interior face of the frame, or
the exterior face of the frame.

3 Specify how to measure the offset:

Then…If you want to…

select a point near the center of the
door jamb.

center the doors between the faces
of the wall

select a point on the side of the face
you want to measure from.

offset the doors from the interior or
exterior face
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4 Select a point to measure to.

5 Specify the offset distance from the selected point:

Then…If you want to…

use the Midpoint osnap to select
the midpoint of the end of the wall.

center the doors between the faces
of the wall

enter 0.move the doors to the reference
point

enter a value for the offset distance.move the doors a specified distance

select the two points measuring the
distance.

specify the distance as a measure-
ment between two points

Using Anchors to Change Doors
You can use anchors to change the position and orientation of a door.

Using Anchors to Change the Horizontal Position of a Door
Use this procedure to change the horizontal position of doors along a wall to
which the doors are anchored.
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Door position along the X axis parameters

1 Select the door you want to change.

2 Click Door tab ➤ Anchor panel ➤ Settings  .

3 Select the reference point for the anchor along the X axis:

Then…If you want to…

under Position Along (X), select
Start of wall (curve) for From.

use the start of the wall as your ref-
erence point

under Position Along (X), select
Midpoint of wall (curve) for From.

use the midpoint of the wall as your
reference point

under Position Along (X), select End
of Wall (curve) for From.

use the end of the wall as your ref-
erence point

4 Enter the distance from the reference point at which to place the
doors.

Use a negative value to measure from endpoint to start point.

1888 | Chapter 25   Doors



5 Select the position of the doors to measure to:

Then…If you want to…

select Start Edge of object for To.measure to the start edge of the
doors

select Center of object for To.measure to the center of the doors

select End Edge of object for To.measure to the end edge of the
doors

6 Click OK.

Using Anchors to Change the Vertical Position of a Door
Use this procedure to change the vertical position of doors in a wall to which
the doors are anchored.

Door position along the Z axis parameters

1 Select the door you want to change.
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2 Click Door tab ➤ Anchor panel ➤ Settings  .

3 Select the reference point for the anchor along the Z axis:

Then…If you want to…

select Bottom of wall (curve) height
for From.

use the bottom of the wall height
as your reference point

select Center of wall (curve) height
for From.

use the center of the wall height as
your reference point

select Top of wall (curve) height for
From.

use the top of the wall height as
your reference point

4 Enter the distance from the reference point at which to place the
doors.

Use a negative value to measure from endpoint to start point.

5 Select the position of the doors to measure to:

Then…If you want to…

select Threshold (Bottom) of object
for To.

measure to the bottom of the doors

select Center of object for To.measure to the center of the doors

select Head (Top) of object for To.measure to the top of the doors

6 Click OK.

Using Anchors to Change the Position of a Door Within a Wall
Use this procedure to change the position of doors horizontally within a wall
to which the doors are anchored.
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Door position along the Y axis parameters

1 Select the door you want to change.

2 Click Door tab ➤ Anchor panel ➤ Settings  .

3 Select the reference point for the anchor along the Y axis:

Then…If you want to…

select Left edge of wall (curve)
width for From.

use the left edge of the wall as your
reference point

select Center of wall (curve) width
for From.

use the center of the wall as your
reference point

select Right edge of wall (curve)
width for From.

use the right edge of the wall as
your reference point

4 Enter the distance from the reference point at which to place the
doors.

Use a negative value to measure from endpoint to start point.

5 Select the position of the doors to measure to:

Then…If you want to…

select Front for To.measure to the front of the doors

select Center for To.measure to the center of the doors

select Back for To.measure to the back of the doors
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6 Click OK.

Changing the Orientation of a Door to a Wall
Use this procedure to change the vertical orientation of doors in a wall to
which the doors are anchored.

1 Select the doors you want to change.

2 Click Door tab ➤ Anchor panel ➤ Settings  .

3 Enter the X and Z rotation angles of the doors.

4 Indicate if you want to reverse the flip direction of the doors in
the X, Y, and Z axes:

Then…If you want to…

select Flip X.reverse the direction the doors open
to

select Flip Y.reverse the side of the wall the
doors open to

select Flip Z.reverse the top and bottom of the
doors

5 Click OK.

Moving a Door to a Different Wall
Use this procedure to move a door from one wall to another.

1 Select the door you want to move.

2 Click Door tab ➤ Anchor panel ➤ Set  .

3 Select the wall to move the door to.

Releasing a Door from a Wall
Use this procedure to release doors from the wall to which they are anchored.

■ Select the doors you want to release.
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■ Click Door tab ➤ Anchor panel ➤ Release  .

Changing the Location of a Freestanding Door
Use this procedure to relocate a freestanding door by changing the coordinate
values of its insertion point. The door also has an orientation with respect to
the WCS or the current UCS. For example, if the top and bottom of the door
are parallel to the XY plane, its normal is parallel to the Z axis. You can change
the orientation of the door by aligning its normal with another axis. You can
also rotate the door on its plane by changing the rotation angle.

For information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use World and User Coordinate Systems in 3D”
in AutoCAD Help.

1 Double-click the door you want to move.

2 On the Properties palette, expand Basic, then expand Location

and click  next to Additional Information.

3 In the Location dialog box, specify the door’s location:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the door

make the normal of the door paral-
lel to the Z axis: under Normal,

locate the door on the XY plane

enter 1 for Z, and enter 0 for X
and Y.

make the normal of the door paral-
lel to the X axis: under Normal,

locate the door on the YZ plane

enter 1 for X and enter 0 for Y
and Z.

make the normal of the door paral-
lel to the Y axis: under Normal,

locate the door on the XZ plane

enter 1 for Y, and enter 0 for X
and Z.

enter a new value for Rotation
Angle.

change the rotation of the door
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4 Click OK.

Center a Door Using Modify Tools
Use this procedure to center a door on a specified axis or between any two
specified points.

1 Select the door to center.

2 Click Door tab ➤ Modify panel ➤ Center  .

3 Select an existing axis line on which to center the door, or press
ENTER and then specify two points between which to center the
door.

Create a Door Array Using Modify Tools
Use this procedure to create an array of identical doors along a wall.

1 Select the door to array.

2 Click Door tab ➤ Modify panel ➤ Array  .

3 Select an edge from which to start the array that is perpendicular
to the array axis, then drag along your wall in the direction of
the array. Do one of the following:

■ Offset: start the door array a specified offset distance from the
edge.

■ Clear Distance: specify a clear distance between each arrayed
door.

■ Pick Array Distance: specify a distance between arrayed doors.

■ Enter Count: specify the number of doors to appear in the
array.

Alternatively, you can press ENTER and then specify two points
between which to array the door.

Repositioning a Door with Modify Tools
Use this procedure to reposition a door.

1 Select the door to reposition.
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2 Click Door tab ➤ Modify panel ➤ Reposition From  .

3 Select an existing wall edge from which to reposition the door,
or specify two points to define a reference edge.

Spacing Doors Evenly with Modify Tools
Use this procedure to space doors evenly along a wall.

1 Select the door to space evenly.

2 Click Door tab ➤ Modify panel ➤ Space Evenly  .

3 Select an edge as the axis along which to space all the doors
evenly, and specify a start point and an endpoint along the edge.

Alternatively, press ENTER and specify two points between which
the doors will be spaced evenly from each other.

Display Properties of Doors
The display properties of a door determine how the door appears the drawing.
They are different from door object properties (Door Properties on page 1876),
which describe real world characteristics of doors, like the direction of the
door swing, or the width of the door. Display properties describe how the
door objects are displayed in the drawing, like cut plane, and layer, color,
linetype settings.

Display properties are often dependent on a specific view; for example, the
door swing and the threshold symbol appear only in plan views.

The display properties of a door can be set on 3 different levels:

■ for an individual object

■ for the object style

■ globally for all objects of the type (drawing default settings)

What happens when I change the display source?

When you change the display source from the style or drawing default settings
to the object then any changes you make to the display are not propagated
to the style or drawing default settings anymore. The object will become
inconsistent with the other objects inserted with this tool.
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When you change the display settings from the object to the door style or the
drawing default, any overrides you have made will be overwritten by the style
or drawing defaults.

To change the display properties of a door

1 Double-click the door you want to change.

2 In the Properties palette, click the Display tab.

3 Change the display properties as needed:

How to SetDescriptionDisplay Property

Select *NONE* from the
drop-down list. This allows

Lets you select individual object components
for editing. If no component is selected, the
change applies to the whole door.

Display component

you to make a change to the
entire door.

Displays the currently selected display source.

Options

Display controlled by

■ This object: Display properties are used
for this object only.

■ Door Style: Display properties come from
the door style on page 1899

■ Drawing default settings: display proper-
ties come bfrom the global drawing set-
tings on page 193.

Select the display representa-
tion in which you want to

Shows you which display representations are
active in the current drawing view. Multiple

Display representa-
tion

change a display propertydisplay representations can be turned on. For
from the drop-down menu.example in Plan view, both plan and threshold
If the list is greyed out, thesymbol plan display representations are vis-

ible. view only has one associated
display representation.

Select Yes or No from the
drop-down menu.

Specifies whether a selected door will use the
cut plane of the wall or door/window as-
sembly it is anchored to

Use cut plane of con-
taining object when
anchored (Plan views
only)
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How to SetDescriptionDisplay Property

Select Yes or No from the
drop-down menu.

Specifies whether to display the swing of a
selected door as a straight line in the current
display representation.

Illustration

Straight swing (left) and curved (right)

Straight Swing (Plan
Views only)

For Override Swing angle,
select Yes. Then, enter a

Lets you define an override to the swing angle
that was defined in the Door Properties on
page 1876.

Override Swing
Angle/Swing Angle
(Plan and Elevation
views only)

door angle under Swing
Angle.

Click the Custom Block Dis-

play worksheet (  ), and

Custom blocks are AutoCAD blocks that you
can add to a specific display representation
of a door, like a door knob, or a custom panel.

Custom Block Display

add blocks to the door in theIn this worksheet, you can add on page 1917,
selected display representa-
tion.

edit on page 1916, disable on page 1919, or re-
move on page 1920 custom blocks from the
door.

Click the Threshold Dimen-

sions worksheet (  ), and

Lets you specify the depth and extension of
the threshold display.

Threshold Dimen-
sions (Threshold Plan
only)

add values for the depth and
extension.

Click the Symbol worksheet

(  ), and select one of the

Lets you define a Threshold symbol.Threshold Symbol
(Threshold Symbol
Plan Only)

available symbols - Heel,
Passthrough, Threshold, or
no - in the list.
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How to SetDescriptionDisplay Property

Click the Muntins worksheet

(  ), and add or remove

Door muntins are secondary framing mem-
bers that hold multiple lights in door glass.
AutoCAD Architecture provides an easy way

Muntins (Elevation
and Model view)

muntins. For detailed inform-to create muntins with different layout pat-
ation, see Creating Muntins
in a Door Style on page 1924.

terns.This worksheet lets you add, edit, dis-
able, or remove muntins from a door.

Click the drop-down list and
select Yes or No.

??Reverse Handing (El-
evation views only)

Click the drop-down list and
select Yes or No.

Lets you display the door panel as a single
line

Illustration

Single line door panel (right)

Single Line Panel
(Plan High Detail
view only)

Click the Frame Display
worksheet, and select the

Lets you display the door frame with different
representations in Plan High Detail

Illustration

Frame Display (Plan
High Detail Only)

desired Frame representation
there.
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Attaching Hyperlinks, Notes, and Files to a Door
Use this procedure to enter notes and attach reference files to a door. You can
also edit notes and edit or detach reference files from a door.

1 Double-click the door to which to attach notes or files.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click  next to Hyperlink, and specify the
link.

For more information, see “Add Hyperlinks to a Drawing” in
AutoCAD Help.

4 To add a note, click  next to Notes, enter text, and click OK.

5 To attach, detach, or edit a reference file, click  next to
Reference documents, and then do any of the following:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

6 Click OK.

Door Styles
A door style is a group of properties assigned to a door that determines the
appearance and characteristics of the door.

You can use door styles to represent standard door types for specific jobs and
drawings or for your office standards. When you create or modify a door style,
the doors using the style have the settings and characteristics of the style.
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Templates provided with AutoCAD Architecture contain door styles for many
typical doors. You can create a style using default style properties or by copying
an existing style. After you create the style, you edit the style properties to
customize the characteristics of the style.

Creating Tools from Door Styles

To create a door tool from any door style, you drag the style from the Style
Manager onto a tool palette. You can then specify default settings for doors
created with that tool. For more information, see Creating a Tool from the
Style Manager on page 94.

Managing Door Styles

To create, edit, copy, or purge door styles, you access the Style Manager. The
Style Manager provides a central location in AutoCAD Architecture in which
to work with styles from multiple drawings and templates. For more
information about using the Style Manager, see Style Manager Overview on
page 870.

Creating a Door Style
Use this procedure to create a door style.

You can create a style with default style properties, or you can create a style
by copying an existing one. After you create the style, you edit its properties
to customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

3 Create a door style:

Then…If you want to…

right-click Door Styles, and click
New.

create a style with default properties

right-click the door style you want
to copy, and click Copy. Right-click,
and click Paste.

create a style from an existing style

4 Enter a name for the new door style, and press ENTER.
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5 Edit the properties of your new door style:

Then…If you want to…

click the General tab, and enter a
description.

enter a description of the style

see Specifying the Dimensions of a
Door Style on page 1902.

change dimension properties of the
style

see Specifying the Design Rules of
a Door Style on page 1903.

change design rules of the style

see Specifying the Standard Sizes
of a Door Style on page 1904.

change the standard door sizes of
the style

see Assigning Materials to a Door
Style on page 1912 and Turning on

assign materials to the components
of the door style

Materials for a Door Style on page
1915.

see Adding Classifications to a Door
Style on page 1913.

add classifications to a door style

see Specifying the Display Proper-
ties of a Door Style on page 1914.

specify the display properties of the
style

see Changing the Layer, Color, and
Linetype of Door Components on
page 1914.

change the appearance of the dis-
play components of the style

see Adding Components to a Door
Style on page 1917.

add components to the style

see Removing Custom Components
from a Door Style on page 1920.

remove components from the style

see Turning Off Custom Compon-
ents in a Door Style on page 1919.

turn off components in the style

see Displaying a Straight Door
Swing on page 1920.

display a straight door swing from
the style
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Then…If you want to…

see Specifying the Opening Percent-
age for Display Representations in
a Door on page 1921.

override the opening percentage in
the style

see Changing the Door Threshold
in a Door Style on page 1921.

change the threshold in the style

see Creating Muntins in a Door
Style on page 1924.

add muntins to the style

see Attaching Notes and Files to a
Door Style on page 1923.

add notes, files, or documents to
the style

6 If you want to assign the style to a door tool, drag the style from
the Style Manager to a tool palette.

You can later rename the tool and specify other properties for it
as described in Creating a Tool from the Style Manager on page
94.

7 Click OK.

Specifying the Dimensions of a Door Style
Use this procedure to change the default dimensions of a door style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Dimensions tab.
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Changing door style dimensions

5 Change dimension values:

Then…If you want to…

under Frame, enter values for Width
and Depth.

change the frame width and depth

under Frame, select Auto-Adjust to
Width of Wall.

set the frame width to the wall
thickness

under Stop, enter values for Width
and Depth.

change the stop dimensions

enter a value for Door Thickness.change the door thickness

enter a value for Glass Thickness.change the glass thickness

6 Click OK.

Specifying the Design Rules of a Door Style
Use this procedure to specify the shape and the type of door for a door style.

Door shapes are named geometrical descriptions of a door. You can select
predefined and custom door shapes, or create your own shape from profiles.
For more information, see Creating a Custom Door Shape on page 1905.

The door type describes the type of opening for the door, such as bifold or
pocket.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.
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NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Design Rules tab.

5 Select a door shape:

Then…If you want to…

under Shape, click Predefined, and
select a shape.

use a predefined door shape

under Shape, click Use Profile, and
select a profile.

use a custom door shape

6 Select a door type.

7 Click OK.

Specifying the Standard Sizes of a Door Style
Use this procedure to create standard door sizes in a door style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Standard Sizes tab, and add, change, or remove door-size
values:

Then…If you want to…

click Add  . Under Standard
Sizes, enter values for Description,
Width, Height, Rise, and Leaf.

create standard sizes
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Then…If you want to…

select the size, and click Edit  .
Enter new values for Width, Height,
Rise, and Leaf.

change a size

select a size, and click Remove 
.

delete a size

The description can be used to identify standard door sizes in
door schedules. For example, you can specify a manufacturer’s
size or model code for Description.

Rise is available for Arch, Gothic, and Peak Pentagon door shapes.
Leaf controls the width of Uneven, Uneven-Dhung, and
Uneven-Opposing door types. For more information on door
types and shapes, see Specifying the Design Rules of a Door Style
on page 1903.

5 Click OK.

Creating a Custom Door Shape
Use this procedure to create a profile that you can use to define a custom door
shape in a door style. To create a custom door shape that includes glazing, see
Creating a Void for Door Muntins on page 1927.

1 Draw a closed polyline in the shape you want.

2 Select the polyline, right-click, and click Convert To ➤ Profile
Definition.

3 Specify the insertion point of the profile.

The insertion point is not used for doors.

4 Enter n (New).

5 Enter a name for the profile, and click OK.
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Replacing the Door Shape in a Door Style
Use this procedure to replace a predefined shape in a door style with a custom
shape created from a profile.

1 Select a door that uses the style you want to modify.

2 Click Door tab ➤ Profile panel ➤ Add Profile  .

3 Specify the profile to use for the custom shape:

Then…If you want to…

select a profile for Profile Definition,
and click OK. For information about

use a predefined door shape

creating a profile, see Creating a
Custom Door Shape on page 1905.

select a profile for Profile Definition,
select Continue Editing, and click

use a predefined door shape, but
modify it

OK. For information about modify-
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Then…If you want to…

ing the shape, see Editing the Geo-
metry of a Door Style on page 1907.

select Start from scratch for Profile
Definition, enter a name for the

create a custom shape

new profile, and click OK. For in-
formation about modifying the de-
fault shape, see Editing the Geo-
metry of a Door Style on page 1907.

Editing the Geometry of a Door Style
Use this procedure to edit the geometry of the profile used to define a door
style. You can also add a profile to a door style that does not currently use a
profile to define its shape.

1 Add a door that has the style you want to change.

2 Add or edit a profile:

Then…If you want to…

select the door, and click Door

tab ➤ Profile panel ➤ Add Profile

add an existing profile to the style

 . Select the name of the profile,
and click OK.

select the door, and click Door

tab ➤ Profile panel ➤ Add Profile

add and an existing profile to the
style and edit it immediately

 . Select the name of the profile,
click Continue Editing, then click
OK.

select the door, and click Door

tab ➤ Profile panel ➤ Add Profile

create a profile and add it to the
style

 . Select Start from scratch for
Profile Definition, enter a name for
the new profile, and click OK. A
rectangular profile is created for you
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Then…If you want to…

to edit to define the required geo-
metry.

select the door, and click Door

tab ➤ Profile panel ➤ Edit In Place

 .

edit the existing profile for the style

3 If you receive a message that the profile is not drawn to size, click
Yes.

The area of the door defined by the profile is selected in the
drawing.

4 NOTE After you perform an editing task, you may need to select the
profile again to perform another editing task. If the editing commands
that you want to use are not available, select the profile again.

Edit the profile as necessary:

Then…If you want to…

select the profile, and use edge or
vertex grips to adjust the shape.
The Edge grip has three edit modes:
Offset, Add Vertex, and Convert to

change the shape of the perimeter
of the profile or its rings

Arc. The default mode is Offset,
which offsets the selected edge in
a direction that is perpendicular to
the midpoint of the edge. Depend-
ing on the shape of the profile and
the edge you choose to modify,
neighboring lines are extended or
trimmed, and new lines are added,
as necessary.
Use the Add Vertex edit mode to
add a vertex to the selected edge,
and create a new edge. If the selec-
ted edge is an arc, the new edge is
an arc, as well.
Convert to Arc changes the selected
edge to an arc and stretches the
midpoint of the edge. The edge
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Then…If you want to…

grip for an arc also has a Stretch
mode, so that you can stretch the
midpoint of the edge after it has
been converted to an arc.

select an Edge grip, and press CTRL
to switch to the Add Vertex edit

add vertices to the profile

mode. Move the edge to the de-
sired location and click, or enter a
value and press ENTER.

select the Vertex grip for the vertex
you want to remove, and press

remove vertices from the profile

CTRL to switch to the Remove edit
mode. Move the cursor off the se-
lected vertex, and click.

click Edit In Place tab ➤ Profile

panel ➤ Replace Ring  . Select

replace an existing ring of the pro-
file with new geometry

the ring to replace, and select the
new geometry. Press ENTER to keep
the geometry, or enter n (No) to
erase it.

click Edit In Place tab ➤ Profile

panel ➤ Add Ring  . Select the

add a ring to the profile

geometry to define the ring. Press
ENTER to keep the geometry, or
enter n (No) to erase it.

click Edit In Place tab ➤ Profile

panel ➤ Remove Ring  . Select

remove a ring from the profile

the ring to remove, and press
ENTER.
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5 Save or discard the changes:

Then…If you want to…

click Edit in Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the profile to its original
shape

click Edit in Place tab ➤ Edits pan-

el ➤ Finish  . The door style uses

save the changes to the current
profile

the edited profile to define its geo-
metry. Any other objects or styles
that use this profile are also up-
dated with the edited geometry.

click Edit in Place tab ➤ Edits pan-

el ➤ Save As  . Enter a name for

save the changes to a new profile
definition

the new profile definition, and click
OK. The door uses the new profile
to define its geometry. Any doors
of this style are updated with the
new geometry. Other styles or ob-
jects that use the original profile are
not affected.

About Door Display Components and Materials
A door object consists of a number of components whose display properties
can be determined by the materials assigned to each component.

You assign one material to each display component of the door. For example,
you assign a wood material to the frame and a glass material to the glass inset.
You assign materials to door components in each display representation in
which the materials are to be used.

To use the display properties of the door object or the door style, instead of
using material display properties, you can turn off the material assignments
in the display properties of the door or the door style.

Material definitions consist of display components that correspond to
component types of objects. For example, the Linework component of a
material is used for all linework in plan view. The Surface Hatch component
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of a material is used to hatch all object surfaces in 3D model views and
elevations.

For a complete list of material components and their descriptions, see Material
Components and Display Properties on page 898.

The following table lists door components that can be displayed using materials
assigned to them, and identifies the material component of each.

Material ComponentDoor Component

Plan, Plan High Detail, Reflected

LineworkDoor Panel

LineworkFrame

LineworkStop

Plan Low Detail

LineworkPanel

Model

3D BodyDoor Panel

3D BodyFrame

3D BodyStop

3D BodyGlass

Elevation

2D Section/Elevation LineworkDoor Panel

2D Section/Elevation LineworkFrame

2D Section/Elevation LineworkStop

2D Section/Elevation LineworkGlass
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Assigning Materials to a Door Style
Use this procedure to assign materials to the individual components of a door
style. Components use the display properties of the material. For more
information, see About Door Display Components and Materials on page 1910.

You can specify the materials used to display the following components of a
door style:

■ Frame

■ Stop

■ Panel

■ Glass

■ Muntin

NOTE If a material assignment does not determine the display properties of a
door component, you can change the display properties of the door style as
described in Specifying the Display Properties of a Door Style on page 1914.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which to display the changes,
and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select By Material for any component to which you want to assign
a material, and click OK.

If the setting for By Material is not available, the display of this
component cannot be determined by a material.

9 Click the Materials tab.
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10 Click the component you want to change, and select a different
material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Although you can edit a material definition from this
dialog box, any changes you make apply to all objects that are
assigned the material.

11 Click OK.

Adding Classifications to a Door Style
Use this procedure to specify classifications for definitions applied to a door
style.

For more information about creating and applying classification definitions,
see Classification Definitions on page 3872.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style that you want to change.

4 Click the Classifications tab.

The default setting for classification definitions is Unspecified. If
no classification definitions are listed, none are applied to door
styles.

5 For each classification definition, select the classification you want
to apply to the current door style.

6 Click OK.
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Specifying the Display Properties of a Door Style
In most cases, you want the appearance of doors that belong to the same style
to be consistent throughout a drawing. To achieve this, you specify the
following display properties of the doors in each door style:

■ The layer, color, and linetype of door components

■ The hatching used with each component

■ The cut plane height and the display of components relative to the cut
plane

■ Other specific door display information, such as the shape of the door
swing

You can also use materials to control the display properties of the physical
components of a door. Symbolic components, such as the door swing, are not
controlled by materials. For more information about using materials in doors,
see About Door Display Components and Materials on page 1910.

Changing the Layer, Color, and Linetype of Door Components
Use this procedure to change the following properties of the display
components of a door style:

■ Visibility (display component is on or off)

■ By material (material assigned to the display component determines its
layer properties)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

1914 | Chapter 25   Doors



NOTE You can also use the Display tab of the Properties palette to change the
display property settings for a selected object display component in the current
display representation. For more information, see Using the Properties Palette to
Change Display Properties on page 793. Note also, that If a material assignment
determines the properties of components in the door style, you can change the
properties of the display component by clearing By Material or by overriding the
material assignment with a different material. For more information, see Assigning
Materials to a Door Style on page 1912.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which to display the changes,
and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select the component to change, and select a different setting for
the property.

9 Click OK.

Turning on Materials for a Door Style
Use this procedure to turn on material assignments for individual display
representations in a door style.

For more information about using materials to control the display of door
components, see About Door Display Components and Materials on page 1910.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .
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3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which to display the changes,
and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select By Material for each component to be controlled by the
material. The By Material check box is unavailable for components
that cannot be assigned a material.

When you select By Material for a display component, all other
settings in the dialog are unavailable. Since the display properties
are now taken from the material definition, you can no longer
set them directly in the display properties of the door style.

9 Click OK.

Using Custom Blocks to Create Door Components
You can add custom blocks for components, such as door hardware, to the
display components, or to replace the default display components. For
example, you can replace a simple door leaf with a custom six-panel door leaf
in which the custom component is to appear. You can have a different custom
block for each display representation.

When you add a custom block, you can specify rules for positioning and
scaling the new component. Each custom block also appears in the display
properties component list so that you can control its layer, color, and linetype.
For more information on adding custom blocks, see Adding Components to
a Door Style on page 1917.

If you create a custom block from mass elements, you can use the material
assignments of the mass elements to determine the display properties of the
custom block.

Be sure to set the properties of objects used to create your custom blocks to
ByBlock. Otherwise, you cannot control these objects through the display
properties. For more information about ByBlock, see “Use Layers to Manage
Complexity” in AutoCAD Help.
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Adding Components to a Door Style
Use this procedure to add or edit custom block components in the display
representation of door styles.

1 Create a block for the component to add to the door style.

Create the block in the same plane as the door that you use to
represent the style. For more information about custom blocks,
see Using Custom Blocks to Create Door Components on page
1916.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

4 Select the style you want to edit.

5 Click the Display Properties tab.

6 Select the display representation in which to display the changes,
and select Style Override.

7 If necessary, click  .

8 Click the Other tab.

9 Specify whether to add or edit a block component:

Then…If you want to…

click Add.add a new block component

select the component to edit, and
click Edit. Proceed to step 11.

edit an existing block component

10 Click Select Block.

11 Select the block to use, and click OK.

12 Specify whether to scale to fit the block component to the object
by width, depth, or height, or to lock the XY ratio:

Then…If you want to…

select Width.set the block scale to the width of
the object
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Then…If you want to…

select Depth.set the block scale to the depth of
the object

select Height.set the block scale to the height of
the object

select Lock XY Ratio.scale the whole block equally, so
that one direction is scaled to fit
another of the scale criteria

clear all options under Scale to Fit.scale the block to its original size

13 Specify whether to mirror the block in the X,Y, or Z direction:

Then…If you want to…

select Mirror X.create a mirror of the block in the
X direction

select Mirror Y.create a mirror of the block in the
Y direction

select Mirror Z.create a mirror of the block in the
Z direction

14 Specify the X, Y, and Z location of the insertion point.

15 Specify an insertion offset of the block in the X, Y, and Z directions.

16 Specify whether the component is for the door frame, leaf or glass:

Then…If you want to…

click Frame Component, and click
either Outside or Inside.

add the block to the inside or out-
side of the frame

click Leaf Component, and click
either All or Single. If you select

add the block to all leaf compon-
ents or to a single leaf component

Single, enter the component num-
ber.

click Glass Component, and click
either All or Single. If you select

add the block to all glass compon-
ents or to a single glass component
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Then…If you want to…

Single, enter the component num-
ber.

NOTE If you specified Depth
for Scale to Fit, the depth will
be scaled to the glass thickness.
You can scale to the door panel
thickness instead by selecting
Scale Depth to Panel Thickness.

17 Leaf and glass components are not available in some display
representations.

Click OK three times.

Turning Off Custom Components in a Door Style
Use this procedure to turn off custom blocks in a door style.

You can turn off the display of component blocks without removing them
from the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which to turn off the display
of the door component, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 Select Disable Custom Blocks.

9 Click OK.
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Removing Custom Components from a Door Style
Use this procedure to remove components from a door style.

Removing component blocks from a door style deletes them from the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation from which to remove the door
component, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 Select the component to remove, and click Remove.

9 Click OK.

Displaying a Straight Door Swing
Use this procedure to display the door swing as a straight line in a door style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which to display a straight
door swing, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.
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8 Select Straight Swing.

9 Click OK.

Specifying the Opening Percentage for Display Representations
in a Door

Use this procedure to override the opening percentage in the display
representation of a door style. For example, you can specify that a door is
displayed closed in model and elevation representations, but open in plan
representations.

NOTE This setting overrides other door opening percent settings. If the opening
percent is specified here, the opening percent entered on the Properties palette
when you add or modify doors is ignored.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which to override the opening
percent, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 Select Override Opening Percent.

9 Enter a value for the opening percent.

10 Click OK.

Changing the Door Threshold in a Door Style
Use this procedure to display a door threshold and change its dimensions in
threshold display representations.
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You can turn on threshold display representations in addition to door display
representations.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select Threshold Plan, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 Under Threshold Dimensions, enter the threshold extension and
depth dimensions.

Component A is the swing side of the door. Component B is the
other side.

9 Click the Layer/Color/Linetype tab.

10 Under Visible, click the icons to turn on visibility.

11 Click OK.

Changing the Door Threshold Symbol in a Door Style
Use this procedure to specify the symbol indicating a threshold that appears
in a door opening for the door style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select Threshold Symbol Plan, and select Style Override.
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6 If necessary, click  .

7 Click the Other tab.

8 Select the type of symbol you want to display in the door opening.

9 Click the Layer/Color/Linetype tab.

10 Under Visible, click the icon to turn on visibility.

11 Click OK.

Defining a Door Style as Bounding for Associative Spaces
Use this procedure to define a door style that can bound associative spaces.

When a door style is set as bounding, by default all doors that have the style
assigned will be used in the selection set for an associative space. For more
information about associative spaces see Generating Associative Spaces on
page 2940.

You can override the bounding settings from the door style in an individual
door, if necessary.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select a door style.

4 Click the General tab.

5 Select the checkbox for Objects of this style may act as a boundary
for associative spaces.

6 Click OK.

Attaching Notes and Files to a Door Style
Use this procedure to enter notes and attach reference files to a door style.
You can also edit reference files attached to the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.
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NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the General tab.

5 To add a description to the door, enter the description under
Description.

6 Click Notes.

7 To add or edit a note, click the Notes tab, and enter the note.

8 To attach, edit, or detach a reference file, click the Reference Docs
tab:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Edit
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application. Click OK
when you finish editing.

edit a reference file

select the file name, click Delete,
and click OK.

detach a reference file

9 Click OK.

Creating Muntins in a Door Style
Door muntins are secondary framing members that hold multiple lights in
door glass. AutoCAD Architecture provides an easy way to create muntins
with different layout patterns.

Door muntins are available in the following patterns that you can customize
into different styles:

■ Rectangular

■ Diamond

■ Prairie 9 Lights
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■ Prairie 12 Lights

■ Starburst

■ Sunburst

Starburst and Sunburst patterns are a combined-rectangular pattern with a
half-round or quarter-round spoked top. They can be used for half- and
quarter-round door glass as well as rectangular door glass. The other patterns
are primarily rectangular but fit into half-round glass. You can make up custom
glass shapes by creating profiles from polylines and adding them to a new
door style.

Door muntin components

Process Overview: Creating Door Muntins
You must have a void for the glass in the door in order to add muntins. Sample
content provided with the software includes several door styles that already
have glass and can receive muntins. The door style description indicates
whether the style has glass. You can create door styles with a glazing void to
receive muntins.

The process of creating a door style with door glass and muntins has three
steps:

1 Create a void for door glass and muntins.

You create a profile from two concentric polylines that define the door
shape and the door glass.
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Concentric closed polylines for a door profile

2 Add glass to a door style.

You apply the profile with a void to a door style so that the style has glass
for doors to receive muntins.

Door style created from a profile

3 Add muntins to the door style.

Door glass with muntins
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Creating a Void for Door Muntins
Use this procedure to create a profile of a door with a void for glass to receive
muntins. This is the first step for adding muntins to door styles that do not
have glass.

The profile is made up of concentric, closed polylines. The outer polyline, or
ring, becomes the door shape, and the inner polyline becomes the void for
the glass. You can create multiple voids by adding more inner polylines. Voids
for glazing must be entirely within the polyline representing the door shape.
The polylines are proportional in size and shape to each other and also to the
individual doors created from the door style.

You can draw these polylines anywhere in the drawing and use any convenient
scale relative to your final door and glass size. One method for sizing the
polylines relative to the door is to draw them by snapping to an existing door,
and then move them to the side.

Concentric closed polylines for a door profile

1 Draw concentric, closed polylines representing the door and the
glass that receives the muntin pattern.

2 Select the polylines, right-click, and click Convert To ➤ Profile
Definition.

3 Select the outermost polyline.

4 Enter a (Add ring).

5 Select an inner polyline.

6 Repeat steps 3 and 4 as needed to add more voids to the profile.

7 Specify the insertion point of the profile.

8 Enter n (New), enter a name for the profile, and click OK.

To add the profile to a door style, see Adding Glass to a Door Style on page
1928.
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Adding Glass to a Door Style
Use this procedure to create a door style with glass for doors to accept muntin
patterns.

The drawing must contain a profile that defines the door style and the void
for the door glass. For more information about creating such a profile, see
Creating a Void for Door Muntins on page 1927.

Door profile with a void for glass

Door style created from the profile

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

3 Create a door style:

Then…If you want to…

right-click Door Styles, and click
New.

create a style with default properties
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Then…If you want to…

right-click the Door style you want
to copy, and click Copy. Right-click,
and click Paste.

create a style from an existing style

4 Select the new door style, right-click, and click Rename.

5 Enter a name for the new door style, and press ENTER.

6 Select the new door style.

7 Click the Design Rules tab.

8 Under Shape, select Use Profile, and select a profile that defines
a door style containing a void for door glass.

9 Click the Standard Sizes tab.

10 Add new sizes to the style.

For more information about adding standard sizes to a door style,
see Specifying the Standard Sizes of a Door Style on page 1904.

11 Click OK.

The door style now contains glass. You can now add muntins to a door style.

Adding Rectangular or Diamond Muntins to a Door Style
Use this procedure to add rectangular or diamond muntins to a door style
that contains glass.

You add muntins by editing the display properties of the door style for a
display representation, such as Model or Elevation, where you want the
muntins to appear. You can add muntins to display representations
individually. You can also add muntins to a single display representation and
apply them to all display representations of that door style. You add the
muntins block to glass components of the door style in display properties.
Each muntins block becomes a display component of the door style.
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Rectangular door glass with rectangular muntins

Gothic door glass with diamond muntins

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

NOTE A door style must contain glass to receive muntins. For more
information about adding glass to a door style, see Adding Glass to
a Door Style on page 1928.

4 Click the Display Properties tab.

5 Select the display representation in which to display the changes,
and select Style Override.

6 If necessary, click  .

7 Click the Muntins tab.

8 Click Add.
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9 Enter a name for the muntins block.

10 If the door style contains multiple glass components, specify
whether you want to apply muntins to all glass components or
to one glass component in the door:

Then…If you want to…

under Glass Component, select All.attach muntins to all glass compon-
ents

under Glass Component, select
Single, and specify the index num-

apply muntins to an individual glass
component

ber. Lights are indexed counter-
clockwise, starting from the lower-
left corner.

Muntins applied to all or one glass component

11 Enter a value for the width of all muntins.

12 Enter a value for the depth of all muntins.
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Specifying muntin width and depth

13 Clean up the muntin intersections:

Then…If you want to…

under Muntin, select Clean Up
Joints.

convert the muntin intersections to
corners

under Muntin, select Convert to
Body.

convert all the muntins to one body
with the joints cleaned up

Specifying muntin cleanup joints
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Converting muntins to a body

14 Under Lights, select a pattern:

Then…If you want to…

select Rectangular for pattern.use a rectangular pattern

select Diamond for pattern.use a diamond pattern

15 Enter a value for Lights High to specify the number of light rows
in the vertical direction.

16 Enter a value for Lights Wide to specify the number of light
columns in the horizontal direction.

Values for lights high and lights wide
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17 Click OK.

18 Add other muntins:

Then…If you want to…

repeat this procedure from step 8.add muntins to another glass com-
ponent in the door style

click OK, and repeat this procedure
from step 5.

add muntins to another display
representation

select Automatically Apply to Other
Display Representations and Object
Overrides.

add muntins to all display represent-
ations of the selected door style

19 When you finish adding muntins to the door style, click OK three
times.

After you add a muntins block to a door style, you can assign a material, such
as wood sash, and specify the display properties, such as color and linetype.
For more information, see Assigning Materials to a Door Style on page 1912 and
Changing the Layer, Color, and Linetype of Door Components on page 1914.

Adding Prairie-Lights Muntins to a Door Style
Use this procedure to add prairie-9-lights or prairie-12-lights muntins to a
door style that contains glass.

You add muntins by editing the display properties of the door style for a
display representation, such as Model or Elevation, where you want the
muntins to appear. You can add muntins to display representations
individually. You can also add muntins to a single display representation and
apply them to all display representations of that door style. You add the
muntins block to glass components of the door style in display properties.
Each muntins block becomes a display component of the door style.
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Rectangular door glass with prairie-9-lights muntins

Rectangular door glass with prairie-12-lights muntins

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

NOTE A door style must contain glass to receive muntins. For more
information about adding glass to a door style, see Adding Glass to
a Door Style on page 1928.

4 Click the Display Properties tab.

5 Select the display representation in which to display the changes,
and select Style Override.

6 If necessary, click  .

7 Click the Muntins tab.

8 Click Add.
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9 Enter a name for the muntins block.

10 If the door style contains multiple glass components, specify
whether you want to apply muntins to all glass components or
to one glass component in the door:

Then…If you want to…

under Glass Component, select All.attach muntins to all glass compon-
ents

under Glass Component, select
Single, and specify the index num-

apply muntins to an individual glass
component

ber. Lights are indexed counter-
clockwise, starting from the lower-
left corner.

Muntins applied to all or one glass component

11 Enter a value for the width of all muntins.

12 Enter a value for the depth of all muntins.
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Specifying muntin width and depth

13 Clean up the muntin intersections:

Then…If you want to…

under Muntin, select Clean Up
Joints.

convert the muntin intersections to
corners

under Muntin, select Convert to
Body.

convert all the muntins to one body
with the joints cleaned up

Specifying muntin cleanup joints
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Converting muntins to a body

14 Under Lights, select a pattern:

Then…If you want to…

select Prairie-9 Lights for Pattern.use a nine-light prairie pattern

select Prairie-12 Lights for Pattern.use a twelve-light prairie pattern

15 Enter a value for Edge X Offset to specify the horizontal distance
of the muntins from the edges of the glass.

16 Enter a value for Edge Y Offset to specify the vertical distance of
the muntins from the edges of the glass.
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Specifying edge X and Y offsets

17 Click OK.

18 Add other muntins:

Then…If you want to…

repeat this procedure from step 8.add muntins to another glass com-
ponent in the door style

click OK, and repeat this procedure
from step 5.

add muntins to another display
representation

select Automatically Apply to Other
Display Representations and Object
Overrides.

add muntins to all display represent-
ations of the selected door style

19 When you finish adding muntins to the door style, click OK three
times.

After you add a muntins block to a door style, you can assign a material, such
as wood sash, and specify the display properties, such as color and linetype.
For more information, see Assigning Materials to a Door Style on page 1912 and
Changing the Layer, Color, and Linetype of Door Components on page 1914.

Adding Starburst Muntins to a Door Style
Use this procedure to add starburst muntins to a door style that contains glass.

You add muntins by editing the display properties of the door style for a
display representation, such as Model or Elevation, where you want the
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muntins to appear. You can add muntins to display representations
individually. You can also add muntins to a single display representation and
apply them to all display representations of that door style. You add the
muntins block to glass components of the door style in display properties.
Each muntins block becomes a display component of the door style.

Half-round door glass with starburst muntins

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

NOTE A door style must contain glass to receive muntins. For more
information about adding glass to a door style, see Adding Glass to
a Door Style on page 1928.

4 Click the Display Properties tab.

5 Select the display representation in which to display the changes,
and select Style Override.

6 If necessary, click  .

7 Click the Muntins tab.

8 Click Add.

9 Enter a name for the muntins block.
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10 If the door style contains multiple glass components, specify
whether you want to apply muntins to all glass components or
to one glass component in the door:

Then…If you want to…

under Glass Component, select All.attach muntins to all glass compon-
ents

under Glass Component, select
Single, and specify the index num-

apply muntins to an individual glass
component

ber. Lights are indexed counter-
clockwise, starting from the lower-
left corner.

Muntins applied to all or one glass component

11 Enter a value for the width of all muntins.

12 Enter a value for the depth of all muntins.
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Specifying muntin width and depth

13 Clean up the muntin intersections:

Then…If you want to…

under Muntin, select Clean Up
Joints.

convert the muntin intersections to
corners

under Muntin, select Convert to
Body.

convert all the muntins to one body
with the joints cleaned up

Specifying muntin cleanup joints
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Converting muntins to a body

14 Under Lights, select Starburst for pattern.

15 Under Shape, select Half Round or Quarter Round.

16 Enter a value for Lights High to specify the number of light rows
in the vertical direction, exclusive of the spoked lights.

17 Enter a value for Lights Wide to specify the number of light
columns in the horizontal direction.

Count the columns as though they continue around the hub. For
a half-round starburst, five apparent columns are counted as three.
For a quarter-round starburst, three apparent columns are also
counted as three.

18 Enter a value for Spokes to specify the number of radial muntin
spokes.

Specifying the number of radial muntin spokes
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19 Specify where to place the hub:

Then…If you want to…

under Hub, select Bottom Center.place the hub at the bottom of a
half-round shape

under Hub, select Top Center.place the hub at the top of a half-
round shape

under Hub, select Bottom Left.place the hub at the bottom left of
a quarter-round shape

under Hub, select Bottom Right.place the hub at the bottom right
of a quarter-round shape

under Hub, select Top Left.place the hub at the top left of a
quarter-round shape

under Hub, select Top Right.place the hub at the top right of a
quarter-round shape

Specifying hub placement of half-round shape
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Specifying hub placement of quarter-round shape

20 Click OK.

21 Add other muntins:

Then…If you want to…

repeat this procedure from step 8.add muntins to another glass com-
ponent in the door style

click OK, and repeat this procedure
from step 5.

add muntins to another display
representation

select Automatically Apply to Other
Display Representations and Object
Overrides.

add muntins to all display represent-
ations of the selected door style

22 When you finish adding muntins to the door style, click OK three
times.

After you add a muntins block to a door style, you can assign a material, such
as wood sash, and specify the display properties, such as color and linetype.
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For more information, see Assigning Materials to a Door Style on page 1912 and
Changing the Layer, Color, and Linetype of Door Components on page 1914.

Adding Sunburst Muntins to a Door Style
Use this procedure to add sunburst muntins to a door style that contains glass.

You add muntins by editing the display properties of the door style for a
display representation, such as Model or Elevation, where you want the
muntins to appear. You can add muntins to display representations
individually. You can also add muntins to a single display representation and
apply them to all display representations of that door style. You add the
muntins block to glass components of the door style in display properties.
Each muntins block becomes a display component of the door style.

Quarter-round door glass with sunburst muntins and closed hub

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

NOTE A door style must contain glass to receive muntins. For more
information about adding glass to a door style, see Adding Glass to
a Door Style on page 1928.

4 Click the Display Properties tab.

5 Select the display representation in which to display the changes,
and select Style Override.
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6 If necessary, click  .

7 Click the Muntins tab.

8 Click Add.

9 Enter a name for the muntins block.

10 If the door style contains multiple glass components, specify
whether you want to apply muntins to all glass components or
to one glass component in the door:

Then…If you want to…

under Glass Component, select All.attach muntins to all glass compon-
ents

under Glass Component, select
Single, and specify the index num-

apply muntins to an individual glass
component

ber. Lights are indexed counter-
clockwise, starting from the lower-
left corner.

Muntins applied to all or one glass component

11 Enter a value for the width of all muntins.

12 Enter a value for the depth of all muntins.
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Specifying muntin width and depth

13 Clean up the muntin intersections:

Then…If you want to…

under Muntin, select Clean Up
Joints.

convert the muntin intersections to
corners

under Muntin, select Convert to
Body.

convert all the muntins to one body
with the joints cleaned up

Specifying muntin cleanup joints
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Converting muntins to a body

14 Under Lights, select Sunburst for pattern.

15 Under Shape, select Half Round or Quarter Round.

16 Enter a value for Lights High to specify the number of light rows
in the vertical direction, exclusive of the spoked lights.

17 Enter a value for Lights Wide to specify the number of light
columns in the horizontal direction.

Count the columns as though they continue around the hub. For
a half-round sunburst, five apparent columns are counted as two.
For a quarter-round sunburst, three apparent columns are also
counted as two.

18 Enter a value for Spokes to specify the number of radial muntin
spokes.
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Specifying the number of radial muntin spokes

19 Under Hub Style, select Closed for no hub light, or select Open
for a hub light.

Specifying closed and open hubs

20 Enter a value for Radius to specify the radius for the hub.

Specifying hub radius

21 Specify where to place the hub:

Then…If you want to…

under Hub, select Bottom Center.place the hub at the bottom of a
half-round shape

under Hub, select Top Center.place the hub at the top of a half-
round shape
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Then…If you want to…

under Hub, select Bottom Left.place the hub at the bottom left of
a quarter-round shape

under Hub, select Bottom Right.place the hub at the bottom right
of a quarter-round shape

under Hub, select Top Left.place the hub at the top left of a
quarter-round shape

under Hub, select Top Right.place the hub at the top right of a
quarter-round shape

Specifying hub placement of quarter-round shape

22 Click OK.
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23 Add other muntins:

Then…If you want to…

repeat this procedure from step 8.add muntins to another glass com-
ponent in the door style

click OK, and repeat this procedure
from step 5.

add muntins to another display
representation

select Automatically Apply to Other
Display Representations and Object
Overrides.

add muntins to all display represent-
ations of the selected door style

24 When you finish adding muntins to the door style, click OK three
times.

After you add a muntins block to a door style, you can assign a material, such
as wood sash, and specify the display properties, such as color and linetype.
For more information, see Assigning Materials to a Door Style on page 1912 and
Changing the Layer, Color, and Linetype of Door Components on page 1914.

Editing a Door Muntins Block in a Door Style
Use this procedure to edit the muntins settings for a door style.

After you create a muntins block, you can change its settings by editing the
display properties of the door style for each display representation, such as
Model or Elevation. You can edit the muntins for display representations
individually. You can also edit the muntins for a single display representation
and apply the changes to all display representations of that door style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which to display the changes,

and click  .
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6 Click the Muntins tab.

7 Select the muntins block to edit.

8 Click Edit.

9 Edit any of the settings.

For more information on settings, refer to the door muntins type
in Creating Muntins in a Door Style on page 1924.

10 Select Automatically Apply to Other Display Representations and
Object Overrides to apply edits to all display representations of
the selected door style.

Clear this setting to apply edits to only the selected display
representation.

11 When you finish editing the door muntins block in the door style,
click OK three times.

You can edit the display properties, such as color and linetype, for the muntins
block. For more information, see Changing the Layer, Color, and Linetype of
Door Components on page 1914.

You can also edit the material applied to the muntins. For more information,
see Assigning Materials to a Door Style on page 1912.

Turning Off the Display of Muntins in a Door Style
Use this procedure to turn off the display of muntins in a door style. You can
turn off the display of door muntins without removing them from the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which to turn off the display

of door muntins, and click  .

6 Click the Muntins tab.

7 Select Disable Muntins Blocks.
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8 Select Automatically Apply to Other Display Representations and
Object Overrides to turn off muntins block(s) for all display
representations of the selected door style.

Clear this setting to turn off muntins block(s) for only the selected
display representation.

9 Click OK two times.

Removing a Door Muntins Block from a Door Style
Use this procedure to remove muntins from a door style.

When you remove muntins blocks from a door style, they are deleted. To turn
off muntins without deleting them, see Turning Off the Display of Muntins
in a Door Style on page 1953.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Door Styles.

NOTE Alternatively, you can select a door, and click Door

tab ➤ General panel ➤ Edit Style drop-down ➤ Door Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation for which to remove door

muntins, and click  .

6 Click the Muntins tab.

7 Select the muntins block to remove.

8 Click Remove.

9 Repeat steps 7 and 8 to remove multiple muntins blocks.

10 Select Automatically Apply to Other Display Representations and
Object Overrides to remove muntins block(s) from all display
representations of the selected door style.

Clear this setting to remove muntins block(s) from only the
selected display representation.

11 When you finish removing muntins blocks from the door style,
click OK two times.
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Windows

A window is an AEC object that interacts with walls and door and window assemblies. After
a window is placed in a wall or door and window assembly, the window is constrained to the
object and cannot move outside it. Windows can be anchored to specific locations in walls
or door and window assemblies; when the wall or door and window assembly moves or
changes size, the location of the window in that object stays constant. Windows can also be
freestanding objects.

NOTE A corner window does not support window assembly.

Overview of Windows
A window is an AEC object that interacts with walls and doors.

Types of Windows

There are two types of windows: regular and corner window

■ Regular window. A regular window is placed on a wall or door and window
assembly and is constrained to the object. They can be anchored to specific
location on walls, or door and window assemblies. When a wall, or door, or
a window assembly moves or changes size, the location of the regular window
in that object stays constant. Regular windows can also be freestanding
objects.

■ Corner window. A corner window is placed at a qualified corner junction
of two walls and extends from one wall to another after being inserted. For
more details on corner windows, see Overview of Corner Window on page
1958.

NOTE A corner window cannot be placed at a window assembly.
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Creating Windows

You can create windows using all of the typical design parameters for style,
standard size, width and height, threshold height, head height, and vertical
alignment. You can choose styles with glass shapes that receive standard
muntins patterns, and create your own custom glass shapes from profiles.

Working with Window Styles

Templates provided with AutoCAD Architecture contain ready-to-use window
styles. The design rules of a window style determine the default dimensions
of windows created from the style. The window style also determines the
window shape and the window type:

■ The window shape determines the geometry of the window frame, such
as rectangular, half round, and arch. You can also create custom window
shapes from profiles.

■ The window type determines the number of panels and the method of
opening the window, such as glider, pass-through, hopper, or picture.

You can also define standard sizes in a window style and then select the size
you want to use when you place the window in a drawing.

Anchoring Windows

After a window is placed in a wall or door and window assembly, the window
is constrained to the object and cannot move outside it.

Windows can also be anchored to specific locations in walls or door and
window assemblies that when the wall or door and window assembly moves
or changes size, the location of the window in that object stays constant.

Window Dimensions

Some window dimensions depend on the window shape and type specified
in the window style.

Rise is the height from the top of the rectangular portion of a window to the
peak of the window opening for Gothic, Arch, and Peak Pentagon window
shapes.

Vertical Alignment of Windows

To control how you place the window in the wall, the location of the working
point vertically in the wall, and how the window responds to modifications
in height, use the vertical alignment settings. To determine the working point
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on the window, use the threshold and head height settings. You can place
the working point at the sill or at the head.

The threshold height is maintained. For example, if you specify the vertical
alignment as 0'' and the window height as 7'–0'', the window opening height
is 7’–0''. If you next specify the height of the window as 6'–8'', the window
threshold remains at 0'' and the window opening height becomes 6’–8''.

The window head work point is maintained. For example, if you specify the
vertical alignment as 7'–0'' and the window height as 7'–0'', the window
opening height is 7–0''. If you specify the window height as 6'–8'', the window
head remains at 7'–0'' and the window threshold becomes 4''.

Materials in Windows

In AutoCAD Architecture, you can assign materials to a window. These
materials then are displayed in wireframe or rendered views. Materials have
specific settings for individual components of a window, such as the frame,
the sash, or the muntins. For more information, see Material Components
and Display Properties on page 898.

Window in 2D wireframe and rendered views

AutoCAD Architecture provides a large number of predefined materials for all
common design purposes, which contain settings for windows. You can use
these predefined materials, or modify them to your special designs. You can
also create your own materials. If you create a material that should specifically
be used only for windows, it is recommended that you name it accordingly;
for example, Window - Wood Frame or Window Sill - Marble. For more
information, see Creating and Editing Material Definitions on page 919.

Window Endcaps

Windows that are anchored in a wall can have endcap styles applied to them.
The endcap shapes for wall openings are defined in the wall style and are a
property of the wall. For information on setting an opening endcap style in
a wall, see Working with Wall Endcaps and Opening Endcaps on page 1373.
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Overview of Corner Window
A corner window extends from one wall to the other after being inserted at a
qualified corner junction of two walls. A qualified corner junction has:

■ L-shaped wall junction

■ Wall joints formed of linear walls only

■ Wall joint cleaned up correctly
Baselines of both the walls touch each other. If the baselines do not touch
each other, it is inside a cleanup radius of either wall segments. For more
details on wall cleanup, see Workflow for Cleaning Up Wall Intersections
on page 1323

A corner window has two opening widths.

■ Width 1: Width 1 is the opening width of the first wall you specify when
you insert a corner window. Width 1 is also anchored to the first wall you
specify.

■ Width 2: Width 2 is the opening width of the second wall you specify
when you insert a corner window. For more details, see Creating a Corner
Window on page 1964. 

NOTE Width 1 and 2 of the corner window is determined by the opening width
measure that you can change from the Properties palette. For more details on
opening width measure, see Measuring a Corner Window on page 1960.
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Create corner window that supports both corner window frames or butt
glazing. For more details on corner window frames, see Overview of Corner
Window Frames on page 1961. To create a corner window with butt glazing, see
Specifying the Dimensions of a Window Style on page 2006.

Inserting the corner window results in the following:

■ The window is automatically cleaned up with the qualified wall joint. For
more details on wall clean-up, see Workflow for Cleaning Up Wall
Intersections on page 1323.

■ The window panes are spread perpendicularly to each wall. The inner angle
of the corner window is automatically adjusted to the wall corner.

■ Changing the angle of the L-shaped wall corner junction automatically
adjusts the angle of the corner window. The opening width values of the
corner window are not changed. Only the angle of the corner window is
changed, corresponding to the angle of the wall corner.

■ Removing either walls of the L-shaped wall corner junction automatically
deletes the corner window.

Editing a Corner Window with Grips

■ You can edit the corner window size using grips, Properties palette, or
dynamic input.

■ Use the width grips or dynamic input to change the dimension of a corner
window in both plan and non-plan view.

■ Use the location grip to move the corner window within the wall to create
an offset from the wall or relocate the corner window vertically.
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■ Use the flip grip to flip the corner window. The values of width 1 and
width 2 are also flipped.

■ Use the swing grip to change the swing direction of the window panes.

NOTE For more details on editing windows with grips, see Using Grips to Edit
Windows on page 1975

Changing the Corner Window Style

Corner Window has most of the same properties and styles as a regular window.
To change the object properties of a corner window, see Window Styles on
page 2003.

Dimensioning a Corner Window

Corner windows support both AutoCAD dimensions and AEC dimension.

The following are applied when you use AEC dimensions:

■ Corner window is located on two walls. In AEC dimensioning, the direction
you specify to insert the dimension determines the side of the corner
window pane.

■ The side of the corner window dimension is determined by the wall
selection used for dimensioning.

■ The outermost edge of the corner frame is used for dimensioning when
the corner frame is in one selection set and is located at the boundary edge.

Measuring a Corner Window
When you insert a corner window, you can change the opening width measure
from the Properties palette to:

■ Inside of Opening. Measure the corner window from one wall end to the
inside (shorter side) of the wall corner.

■ Outside of Opening. Measure the corner window from one wall end to the
outside (longer side) of the wall corner.

■ Center of Opening. Measure the corner window from one wall end to the
intersection of both walls at the wall corner.
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Overview of Corner Window Frames
In a corner window, corner window frame is classified into:

■ Frame component

■ Sash component

■ Glass component

The frame component is divided into frame and corner frame.

In a corner window, frame depth and corner frame depth are equal. Frame
width and corner frame width may vary. The shorter side of the corner frame
is used to determine the corner frame width.
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You can specify the display of frames to be standard or offset. You can also
specify the frame extension value. For more details on changing the parameters
of a corner frame, see Specifying the Display Properties of Window Frames on
page 2024.

Inserting a corner window automatically adjusts the profile of the window
frame to the angle of the wall corner.

Using Window Tools to Create Windows
In the Tools Palette, select regular window tools from the Window tab and
corner window tools from the Corner Window tab. From the Tools provided
with AutoCAD Architecture, you can quickly place windows by selecting a
window tool with a specific window style and other predefined properties.
You can use the tool with all of its default settings, or you can change any
properties that are not controlled by the style. You can also use window tools
to create new windows by applying tool properties to existing door/window
assemblies, openings and doors.
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The following palettes contain one or more window tools:

Contains…Tool palette…

a window tool for the Standard window
style and default settings for other window
properties

Design

a window tool for sample window styles,
with default properties appropriate for each
window style

Windows

a window tool for sample corner window
styles, with default properties appropriate
for each corner window style

Corner Window

window tools with window styles and
properties that are customized for your
projects or office standards

Custom tool palettes created by your CAD
manager

When you place windows using windows or corner window tools, you can
use the default settings of the tool, or you can change settings for any windows
properties that are not controlled by the style.
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Creating a Regular Window
Use this procedure to add a new regular window that has the properties
specified in the window tool that you select. To specify settings when you
add a window, see Creating a Window with User-Specified Settings on page
1965.

1 Open the tool palette that you want to use, and select a window
tool.

If necessary, scroll the palette to display the tool that you want
to use.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Window

 .

2 Select a wall or door and window assembly in which to insert the
window, or press ENTER to add a freestanding window.

You can move or hide the Properties palette to expose more of
the drawing area.

3 Specify the insertion point of the window.

4 Continue adding windows, and press ENTER.h

Creating a Corner Window
Use this procedure to add a new corner window that has the properties
specified in the selected window tool. To specify settings when you add a
window, see Creating a Window with User-Specified Settings on page 1965.

To insert a corner window, ensure that you have a L-shaped wall junction
cleaned up correctly. For more details, see Overview of Corner Window on
page 1958. For more details on cleaning up wall segments, see Workflow for
Cleaning Up Wall Intersections on page 1323.

NOTE If the baselines of both walls does not touch each other, the joints must lie
within the inside cleanup radius of either wall segment.

1 Click Home tab  ➤  Build panel  ➤  Design Tools.

2 On the Tools palette, click Corner Window and select a corner
window tool to insert.
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NOTE Alternatively, click Home tab ➤ Build panel ➤  Corner Window.

3 Select a qualified L-shaped wall joint.

A preview of the corner window is displayed at the wall joint.

If the selected wall has walls joined at either ends, you can drag
your cursor from one end to the other. When you position your
cursor at the wall joint, a preview of the corner window is
displayed.

Press Tab to specify the Width 1 and Width 2 values.

Width 1 is the opening width of a corner window anchored to
the first wall you specify. Width 2 will be the opening width of
the corner window pane on the second wall that you will specify.
You can change the opening width of the corner window

4 Select the second wall to insert the corner window.

Creating a Window with User-Specified Settings
Use this procedure to create any of the following, with user-specified settings:

■ Freestanding regular windows

■ Regular windows in walls

■ Corner windows
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Adding a window to a wall
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Adding a corner window to a L-shape wall joint

TIP )To ensure that the Properties palette is displayed before you select a tool,
click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties.

1 Open the Tool palette, and select a Window tool or a Corner
Window tool.

If necessary, scroll the tool palette to display the tool you want
to use.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Window

 .

2 On the Properties palette, expand Basic, and expand General.

3 Select a window style.

4 Under Bound Spaces, define if this window can be used as a
bounding object for associative spaces.
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You can select three options here:

■ Yes: this window can be used as bounding object for associative
spaces.

■ No: this window cannot be used as bounding object for
associative spaces.

■ By style: this window will use the bounding settings from the
window style.

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

5 Expand Dimensions.

6 Specify a window size:

Then…If you want to…

click Standard Sizes, and then select
a window size.

use a standard window size

enter values for Width and Height.
For corner window, width is a sum
of Width 1 and Width 2.

use a custom window size

7 Enter a value for Rise, if applicable to the selected style and
window type.

8 Specify where the window width and height are measured to:

Then…If you want to measure to…

Select Outside of frame for Measure
to.

the outside of the window frame

Select Inside of frame for Measure
to.

the inside of the window frame

Select Center of frame for Measure
to.

the center of the window frame

9 Enter a value for Opening percent or Swing angle.

Zero indicates a closed window.

10 Expand Location.
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11 If you are placing the window in a wall, specify the position of
the window:

Then…If you want to…

select Offset/Center for Position
along wall, and enter a value for
Automatic offset.

position the window at a specific
distance between the edge of the
opening and the end of a wall seg-
ment

select Offset/Center for Position
along wall, and specify a point near
the center of the wall segment.

center the window on a wall seg-
ment

click Position along wall, and select
Unconstrained.

position the window anywhere
along the wall

12 Specify whether you want the window aligned vertically by sill
height or by head height:

Then…If you want to align the win-
dow…

select Sill for Vertical alignment, and
enter a value for Sill height.

by sill height

select Head for Vertical alignment,
and enter a value for Head height.

by head height

13 Specify the insertion point for a freestanding window, window,
or corner window in a wall:

Then…If you want to insert…

press ENTER, and specify an inser-
tion point and a rotation angle for
the window.

a freestanding window

select the wall and specify an inser-
tion point along the wall.

the window in a wall

select a qualified L-shaped wall
joint. Specify an insertion point
along the second wall.

a corner window in a wall
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TIP There are 2 command line options that make the insertion of a
window in a specific location easier: You can switch the insertion
point of the window from left (default) to center and right by entering
CY (cycle measure to) once or twice on the command line. For regular
window, you can also measure the insertion point of a window in
relation to a specified point in the drawing - for example the frame
of a door - by entering RE (Reference point on) and then selecting
the point from which the distance should be measured.

Creating a Regular Window in a Door and Window
Assembly

Use this procedure to insert a regular window into a door and window
assembly.

1 Open the tool palette that you want to use, and select a Window
tool.

If necessary, scroll the Tool palette to display the tool you want
to use.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Window

 .

2 Select a door and window assembly to insert the window into.

3 Select the grid cell on the door and window assembly into which
you want to insert the window.

4 Commence adding the window to the door and window assembly,
as described in Inserting a Door or Window into a Door and
Window Assembly on page 1753.

Creating a Regular Window from Doors, Door/Window
Assemblies and Openings

Use this procedure to convert a door, door/window assembly, or opening to
a regular window that has the properties of the window tool you select. You
can edit these properties after creating the window.

1 Open the tool palette that you want to use.
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If necessary, scroll to display the tool that you want to use.

2 Right-click a window tool, and click Apply Tool Properties
to ➤ Door, Door/Window Assembly, Opening.

3 Select the door or window assembly, opening, or door to convert,
and press ENTER.

4 Edit the properties of the window in the Properties palette, if
needed.

Creating a Window Tool
Use this procedure to create a window tool and add it to a tool palette. You
may want to create your own window tools if you are placing multiple windows
of specific styles with additional properties that you want to be the same each
time you add a window of each type.

For example, you are creating an office floor plan that contains two custom
window styles: fixed casement for conference rooms and operable casement
for offices. To work efficiently, you can create a window tool for each style.
You can then select the appropriate tool to place windows in offices and
conference rooms.

You can use any of the following methods to create a window tool:

■ Drag a window that has the properties you want to a tool palette.

■ Drag a window style from the Style Manager to a tool palette, and then
customize the properties of the new tool.

■ Copy an existing tool, and then customize the properties of the new tool.

■ Drag a tool from a tool catalog in the Content Browser, and then customize
the properties of the tool.
For information about using the Content Browser to create a tool, see Using
Tool Catalog Items on page 167.

1 Open the tool palette where you want to create a tool.

2 Create the tool:

Then…If you want to…

select the object, and drag it to the
tool palette.

create a tool from a window in the
drawing
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Then…If you want to…

click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from a window style
in the Style Manager.

the style you want to copy, and
drag it to the tool palette. Click OK.

right-click the tool, click Copy, and
click Paste.

copy a tool in the current palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another palette

open the palette where you want
to add the tool, right-click, and click
Paste.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

This description is used as the tool’s tooltip on the tool palette,
and to describe the tool if it is stored in a tool catalog.

6 Expand Basic, and expand General.

7 Enter a description of the tool.

8 If you do not want to use the default layer key for windows, select
a layer key.

9 If you want to override the default layer name for windows, select
a layer override.

10 Select a window style.

11 For Style location, select the drawing file containing the style used
for this window, or select Browse and use a standard file selection
dialog box to select the file.

12 Under Bound Spaces, define if this window tool can be used as a
bounding object for associative spaces.

You can select three options here:

■ Yes: this window tool can be used as bounding object for
associative spaces.
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■ No: this window tool cannot be used as bounding object for
associative spaces.

■ By style: this window tool will use the bounding settings from
the window style.

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

13 Expand Dimensions.

14 Specify a window size:

Then…If you want to…

click Standard Sizes, and then select
a window size.

use a standard window size

enter values for Width and Height.use a custom window size

15 Specify where the window width and height are measured to:

Then…If you want to measure to…

Select Outside of frame for Measure
to.

the outside of the window frame

Select Inside of frame for Measure
to.

the inside of the window frame

16 Enter a value for Rise, if applicable to the selected style and
window type.

17 Enter a value for the Opening percent or Swing angle.

Zero indicates a closed window.

NOTE Defining the opening percent in display properties overrides
this setting on the Tool Properties palette. For more information, see
Specifying the Display Properties of a Window Style on page 2017.

18 Expand Location.
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19 Specify the position of the window when it is placed in a wall:

Then…If you want to…

select Offset/Center for Position
along wall, and enter a value for
Automatic offset.

position the window at a specific
distance between the edge of the
opening and the end of a wall seg-
ment

select Offset/Center for Position
along wall, and specify a point near
the center of the wall segment

center the window on a wall seg-
ment

click Position along wall, and select
Unconstrained.

position the window anywhere
along the wall

20 Enter a value for the head height.

21 Enter a value for the sill height.

22 Click OK.

Editing Windows
After you create a window, you can change the size, height, width, rise, and
opening. You can also move the window within the wall, flip the hinge or
swing, and change the swing opening.

You can change the properties of existing windows in your drawing by
changing the window style, changing the dimensions of the window, moving
the anchor location of the window, and specifying the endcap conditions of
the window.

AutoCAD Architecture offers several methods for editing windows:

■ You can directly edit windows using grips for dimensions and other
physical characteristics.

■ For grip edit operations where you are changing a dimension or an angle,
the Dynamic Input feature lets you enter a precise value instead of moving
a grip. When this feature is active (click DYN on the application status
bar), selecting a grip displays a text box in which you can enter the desired
value for the associated dimension or angle. For more information, see
“Use Dynamic Input” in AutoCAD Help.
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■ You can change window settings on the Properties palette. You can also
use the Display tab of the Properties palette to change the display property
settings for a selected object display component in the current display
representation. For more information, see Using the Properties Palette to
Change Display Properties on page 793.

■ You can select editing commands from the context menu for a selected
window.

Using Grips to Edit Windows
You can use the following grips to modify windows:

DescriptionGrip

Lets you change the width of a window

NOTE Initially the grip is set to con-
strain the sizing to one of the standard
values on page 2007 defined for the win-
dow style.

 (Width)

The CTRL key acts as a toggle between
standard and custom sizing.
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DescriptionGrip

Additional information
A series of tick marks indicates
the standard sizes for the selected
dimension. As you move the grip,
it snaps to each tick mark and
displays the measurement at that
mark.
The size and color of the grip tick
marks indicate whether setting a
standard value for the dimension
will result in a standard window
size. For example, if the height of
the window is set to a non-
standard value, then even if you
set the window width to a stand-
ard value for that window’s style,
the window is still not a standard
size. Long grey tick marks indic-
ate that a standard size is pos-
sible; short red marks indicate
that another dimension is already
set to a non-standard value.

Lets you change the Height of a win-
dow. you can choose if you want to /  (Sill

Height/Head
Height)

change the sill height or the head
height.

Lets you move a window along a wall,
within a wall and along the vertical
height of the wall.
For corner window, you can only relo-
cate the corner window into another
qualified wall corner.

 (Location)

More options for moving a win-
dow

■ Moving a Window Along a Wall on
page 1981
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DescriptionGrip

■ Moving a Window Within a Wall on
page 1984

■ Moving a Window to a Different
Wall on page 1991

■ Using Location Grips to Relocate a
Corner Window on page 1985

■ Releasing a Window from a Wall on
page 1991

Lets you change the hinge side of the
window.
For corner window, values of width 1
and width 2 are flipped. The anchor of

 (Flip Hinge)

the window pane that was anchored to
the first wall selected is also flipped.

Lets you change the swing direction of
the window (Flip Swing

Direction)

Rise
Rise applies to Peak Pentagon, Arch,
and Gothic window shapes. For more
information, see Specifying the Design
Rules of a Window Style on page 2010.

Changing the Window Style
Use this procedure to change the style for a window or group of windows.

1 Select one or more windows, and double-click one of them.

2 On the Properties palette, expand Basic, and expand General.

3 Select a window style.
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Change the Window Width and Height
Use this procedure to change how the width of a window or windows is
measured.

1 Select the windows you want to change, and double-click one of
them.

2 On the Properties palette, expand Basic, and expand Dimensions.

3 Specify the location to which window width and height is
measured:

Then…If you want to size the win-
dows…

select Inside of frame for Measure
to.

to the inside frame

select Outside of frame for Measure
to.

to the outside frame

select Center of Frame for Measure
to.

to the center frame (in corner win-
dows only)
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Specifying window frame measurement

4 Specify the width of a window. For corner window, width is a
sum of width 1 and width 2.

Then…If you want to specify...

enter a value for Width 1 or use the
pick tool to pick two points to spe-
cify a distance.

the width of a corner window pane
anchored to a wall

enter a value for Width 2 or use the
pick tool to pick two points to spe-
cify a distance.

the width of a corner window pane
that is not anchored to a wall

NOTE When you add a corner window, the first wall you specify is
anchored to the wall. When you flip the wall, the second wall is
anchored.

5 To specify the height of the window, enter a value.

Changing the Window Swing Angle or Opening Percent
Use this procedure to change the swing angle or opening percent of a window
or group of windows.

A window with an opening percent of zero is closed.
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NOTE Defining the opening percent in display properties overrides this setting
on the Properties palette. For more information, see Specifying the Display
Properties of a Window Style on page 2017.

1 Select the windows you want to change, and double-click one of
them.

2 On the Properties palette, expand Basic, and expand Dimensions.

3 Enter a value for swing angle or Opening Percent.

Changing a window swing angle

Changing the Vertical Alignment of a Window
Use this procedure to change the vertical alignment of a window or group of
windows.

1 Select the windows you want to change, and double-click one of
them.

2 On the Properties palette, expand Basic, and expand Location.
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3 Specify whether you want the window aligned vertically by sill
height or by head height:

Then…If you want to align the win-
dows…

select Sill for Vertical alignment, and
enter a value for Sill height.

by sill height

select Head for Vertical alignment,
and enter a value for Head height.

by head height

Moving a Window Along a Wall
Use this procedure to change the location of one or more windows along a
wall by offsetting the windows from a reference location.

NOTE You can only relocate the corner window into another qualified wall corner.

This feature is useful when you want to position a window at a specified
distance from another object. For example, you may want to specify an exact
distance between a series of windows along a wall.

NOTE If the defect marker appears in the wall after you move a window, the
window is too close to other objects in the wall or to the end of the wall for the
endcaps to fit. Adjust the position of the window until the defect marker disappears.

1 Select the window you want to move.

2 Click Window tab ➤ Anchor panel ➤ Reposition Along Wall
.

A marker indicates the current location within the opening.

3 Specify where to measure the offset from:

Then…If you want to measure the
offset…

select a point near the center of the
window.

from the center of the window

select a point on the end of the
window you want to measure from.

from an end of the window
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4 Select a point to measure to (the reference point).

You can select a point along the wall.

5 Specify the distance between the points you selected:

Then…If you want to…

enter 0.move the window to the reference
point

enter a value for the offset distance.move the window a specified dis-
tance from the reference point

select the two points measuring the
distance.

specify the distance as a measure-
ment between two points, such as
the distance between the centers
of two windows that are correctly
positioned
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Repositioning a window along a wall
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Moving a Window Within a Wall
Use this procedure to move one or more windows within a wall by offsetting
the windows from a reference location.

This feature allows you to align windows within the thickness of a wall. You
can set an offset distance from any point within a wall, or center the windows
between the faces of a wall. You can select doors, windows, and openings and
reposition them at the same time. If you select more than one object, you can
select only one side to offset.

NOTE You can only relocate the corner window into another qualified wall corner.

1 Select the windows you want to move.

2 Click Window tab ➤ Anchor panel ➤ Reposition Within Wall
.

A marker indicates the current location within the opening. This
may be the center of the frame, the interior face of the frame, or
the exterior face of the frame.

3 Specify where to measure the offset from:

Then…If you want to…

select a point near the center of the
window.

center the windows between the
faces of the wall

select a point on the side of the face
you want to measure from.

offset the windows from the interior
or exterior face

4 Select a point to measure to.

5 Specify the offset distance from the selected point:

Then…If you want to…

use the Midpoint osnap to select
the midpoint of the end of the wall.

center the windows between the
faces of the wall

enter 0.move the windows to the reference
point

enter a value for the offset distance.move the windows a specified dis-
tance
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Then…If you want to…

select the two points measuring the
distance.

specify the distance as a measure-
ment between two points

Repositioning a window within a wall

Using Location Grips to Relocate a Corner Window
You can only relocate a corner window into another qualified L-shaped wall
joint. Right-click the location grip and press Ctrl to cycle through the following
options:

■ Specify Wall Corner. Drag the location grip to another qualified wall corner.

■ Move Within. Move within the wall by specifying an offset distance. The
same offset value is applied to both the window panes of the corner
window.

■ Move Vertically. Move the corner window vertically along the wall height.
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Using Anchors to Change the Horizontal Position of a Window
Use this procedure to change the horizontal position of windows along a wall
to which the windows are anchored.

When you insert a corner window, the first wall you specify is the anchored
wall.

Window position along the X axis parameters

1 Select the windows you want to change, and double-click one of
them.

2 On the Properties palette, expand Basic, and expand Location.

3 Click Anchor.

4 Select the reference point for the anchor along the X axis:

Then…If you want to…

under Position Along (X), select
Start of wall for From.

use the start of the wall as the refer-
ence point

under Position Along (X), select
Midpoint of wall for From.

use the midpoint of the wall as the
reference point
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Then…If you want to…

under Position Along (X), select End
of wall for From.

use the end of the wall as the refer-
ence point

5 Enter the distance from the reference point at which to place the
windows.

Use a negative value to measure from endpoint to start point.

6 Select the position of the windows to measure to:

Then…If you want to measure to…

select Start Edge of object for To.the start edge of the windows

select Center of object for To.the center of the windows

select End Edge of object for To.the end edge of the windows

7 Click OK.

Using Anchors to Change the Vertical Position of a Window
Use this procedure to change the vertical position of windows in a wall to
which the windows are anchored.
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Window position along the Z axis parameters

1 Select the windows you want to change, and double-click one of
them.

2 On the Properties palette, expand Basic, and expand Location.

3 Click Anchor.

4 Select the reference point for the anchor along the Z axis:

Then…If you want to…

under Position Along (Z), select
Bottom of wall height for From.

use the bottom of the wall height
as the reference point

under Position Along (Z), select
Center of wall height for From.

use the center of the wall height as
the reference point

under Position Along (Z), select Top
of wall height for From.

use the top of the wall height as the
reference point

5 Enter the distance from the reference point at which to place the
windows.

Use a negative value to measure from endpoint to start point.
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6 Select the position of the windows to measure to:

Then…If you want to measure to…

select Sill (Bottom) of object for To.the bottom of the windows

select Center of object for To.the center of the windows

select Head (Top) of object for To.the top of the windows

7 Click OK.

Using Anchors to Change the Position of a Window Within a
Wall

Use this procedure to change the position of windows horizontally within a
wall to which the windows are anchored.

Window position along the Y axis parameters

1 Select the windows you want to change, and double-click one of
them.

2 On the Properties palette, expand Basic, and expand Location.

3 Click Anchor.

4 Select the reference point for the anchor along the Y axis:

Then…If you want to…

select Left edge of wall width for
From.

use the left edge of the wall as your
reference point

select Center of wall width for
From.

use the center of the wall as your
reference point
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Then…If you want to…

select Right edge of wall width for
From.

use the right edge of the wall as
your reference point

5 Enter the distance from the reference point at which to place the
windows.

Use a negative value to measure from endpoint to start point.

6 Select the position of the windows to measure to:

Then…If you want to measure to…

select Front of object for To.the front of the windows

select Center of object for To.the center of the windows

select Back of object for To.the back of the windows

7 Click OK.

Changing the Orientation of a Window to a Wall
Use this procedure to change the vertical orientation of windows in a wall to
which the windows are anchored.

1 Select the windows you want to change, and double-click one of
them.

2 On the Properties palette, expand Basic, and expand Location.

3 Click Anchor.

4 Enter the X and Z rotation angles of the windows.

5 Indicate if you want to reverse the flip direction of the windows
in the X, Y, and Z axes:

Then…If you want to reverse…

select Flip X.the direction the windows open to

select Flip Y.the side of the wall the windows
open to

select Flip Z.the top and bottom of the windows
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6 Click OK.

Moving a Window to a Different Wall
Use this procedure to move a window from one wall to another.

1 Select the window you want to move.

2 Click Window tab ➤ Anchor panel ➤ Set  .

3 Select the wall to move the window to.

Releasing a Window from a Wall
Use this procedure to release windows from the wall to which they are
anchored.

1 Select the windows you want to release.

2 Click Window tab ➤ Anchor panel ➤ Release  .

Center a Window Using Modify Tools
Use this procedure to center a window on a specified axis or between any two
specified points.

1 Select the window to center.

2 Click Window tab ➤ Modify panel ➤ Center  .

3 Select an existing axis line on which to center the window, or
press ENTER and then specify two points between which to center
the window.

Create a Window Array Using Modify Tools
Use this procedure to create an array of identical windows along a wall.

1 Select the window to array.

2 Click Window tab ➤ Modify panel ➤ Array  .
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3 Select an edge from which to start the array that is perpendicular
to the array axis, then drag along your wall in the direction of
the array. Do one of the following:

■ Offset: start the window array a specified offset distance from
the edge.

■ Clear Distance: specify a clear distance between each arrayed
window.

■ Pick Array Distance: specify a distance between arrayed
windows.

■ Enter Count: specify the number of windows to appear in the
array.

Alternatively, you can press ENTER and then specify two points
between which to array the window.

Repositioning a Window with Modify Tools
Use this procedure to reposition a window.

1 Select the window to reposition.

2 Click Window tab ➤ Modify panel ➤ Reposition From  .

3 Select an existing wall edge from which to reposition the window,
or specify two points to define a reference edge.

Spacing Windows Evenly with Modify Tools
Use this procedure to space windows evenly along a wall.

1 Select the window to space evenly.

2 Click Window tab ➤ Modify panel ➤ Space Evenly  .

3 Select an edge as the axis along which to space all the windows
evenly, and specify a start point and an endpoint along the edge.

Alternatively, press ENTER and specify two points between which
the windows will be spaced evenly from each other.
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Changing the Opening Endcap Assigned to a Window
Use this procedure to change the opening endcap style assigned to windows.

NOTE Each opening endcap style is generally created for use with a specific wall
style. Changing the opening endcap style used for individual windows may cause
the wall to display a defect marker.

For more information, see Working with Wall Endcaps and Opening Endcaps
on page 1373.

1 Select the windows whose endcaps you want to change, and
double-click one of them.

2 On the Properties palette, expand Basic, and expand Location.

3 Select the Opening Endcap style drop-down.

4 Select By Wall Style or Standard.

NOTE When inserting a corner window, if the wall corner have
different endcap styles, a dialog is displayed to inform the user about
the error.

Changing the Location of a Freestanding Regular Window
Use this procedure to relocate a freestanding regular window by changing the
coordinate values of its insertion point. The window also has an orientation
with respect to the WCS or the current UCS. For example, if the top and
bottom of the window are parallel to the XY plane, its normal is parallel to
the Z axis. You can change the orientation of the regular window by aligning
its normal with another axis. You can also rotate the window on its plane by
changing the rotation angle.

For information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use Coordinates and Coordinate Systems” in
AutoCAD Help.

1 Double-click the window you want to move.

2 On the Properties palette, expand Basic, expand Location, and
click Additional Information.
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3 In the Location dialog box, specify the window location:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the window

make the normal of the window
parallel to the Z axis: under Normal,

locate the window on the XY plane

enter 1 for Z, and enter 0 for X
and Y.

make the normal of the window
parallel to the X axis: under Normal,

locate the window on the YZ plane

enter 1 for X and enter 0 for Y
and Z.

make the normal of the window
parallel to the Y axis: under Normal,

locate the window on the XZ plane

enter 1 for Y, and enter 0 for X
and Z.

enter a new value for Rotation
Angle.

change the rotation of the window

4 Click OK.

Changing the Cut Plane Setting for a Window
Use this procedure to specify whether a selected window will use the cut plane
of the containing object when anchored to that object in the current display
representation. Note that cut plane display properties apply only to display
representations, such as Plan, that are used in the Top view (plan view) of a
drawing.

1 Double-click the window.

2 Click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.
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NOTE To apply your changes to all windows in the drawing, select
Drawing default setting. To apply changes to all windows of this style,
select Window Style:<style name>. For more information on styles,
see Window Styles on page 2003.

5 For Display representation, verify that the desired display
representation is selected.

6 If necessary, expand Object Display Properties ➤ Cut Plane.

7 For Use cut plane of containing object when anchored, select Yes
or No.

Specifying the Display of Muntins Blocks for a Window
Use this procedure to specify the display of muntins for an individual window
in model and elevation views.

1 Double-click the window.

2 Click the Display tab in the Properties palette.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all windows in the drawing, select
Drawing default setting. To apply changes to all windows of this style,
select Window Style:<style name>. For more information on styles,
see Window Styles on page 2003.

5 For Display representation, verify that the desired display
representation is selected.

6 If necessary, expand Object Display Properties ➤ Advanced, and

for Muntins, click  (the number in parentheses indicates the
number of muntins blocks currently attached to the window).

7 If you want to turn off the display of muntins blocks for this
window without removing them, select Disable Muntins Blocks.

8 Specify whether to add, edit, or remove a block:

Then…If you want to…

click Add.add a new muntins block
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Then…If you want to…

select the block to edit, and click
Edit.

edit an existing muntins block

select the block, click Remove, and
click OK.

remove an existing muntins block

9 For Name, enter a name for the new block or edit the existing one
as applicable.

10 The rest of the parameters on the Muntins Block worksheet vary
according to the type of window and type of pattern selected for
the lights. For detailed instructions on specifying these parameters
for a particular pattern, refer to the pattern-specific topic as listed
under Creating Muntins in a Window Style on page 2028. When
the worksheet parameters are set as desired, click OK.

11 If you want your changes to apply only to the current display
representation, clear Automatically Apply to Other Display
Representations. (If this option is not selected, you will be
prompted to identify the other display representations to which
you want your changes applied.

12 Click OK.

Specifying the Display of Sills for a Window
Use this procedure to change the sill dimensions for a window in the Sill Plan
display representation.

1 Double-click the window.

2 Click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all windows in the drawing, select
Drawing default setting. To apply changes to all windows of this style,
select Window Style:<style name>. For more information on styles,
see Window Styles on page 2003.

5 For Display representation, select Sill Plan.
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6 If necessary, expand Object Display Properties ➤ Advanced, and

click  Sill dimensions.

7 On the Sill Dimensions worksheet, enter the sill extension and
depth dimensions.

Sill components A and B are for the outside of the opening. Sill
components C and D are for the interior side.

8 Click OK.

9 On the Display component drop-down list, click the light bulb
icons for individual sill components to turn visibility on or off as
desired.

You can also access and modify sill dimensions and visibility settings through
the window’s context menu, as follows:

1 Select the window you want to change, right-click, and click Edit
Object Display.

2 Click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 Click the Other tab.

Window sill dimensions

6 Under Sill Dimensions, enter the sill extension and depth
dimensions.

7 On the Layer/Color/Linetype tab, under Visible, click the icons
to turn on visibility for individual sill display components as
necessary.

8 Click OK twice.

Specifying the Display of Sills for a Window  | 1997



Reversing the Handing for a Window in an Elevation View
Use this procedure to specify whether to reverse the current handing of a
selected window in the Elevation display representation.

1 Double-click the window.

2 Click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all windows in the drawing, select
Drawing default setting. To apply changes to all windows of this style,
select Window Style:<style name>. For more information on styles,
see Window Styles on page 2003.

5 For Display representation, verify that the desired display
representation is selected.

6 If necessary, expand Object Display Properties ➤ Advanced.

7 For Reverse handing, select Yes or No.

Specifying the Display of Frames for a Window
Use this procedure to change the frame display for a window in the Plan High
Detail display representation.

1 Double-click the window.

2 Click the Display tab on the Properties palette.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all windows in the drawing, select
Drawing default setting. To apply changes to all windows of this style,
select Window Style:<style name>. For more information on styles,
see Window Styles on page 2003.

5 For Display representation, select Plan High Detail.

6 If necessary, expand Object Display Properties ➤ Advanced, and

click  Frame display.
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7 On the Frame Display worksheet, under Type, select either
Standard or Offset.

8 For A-Extension, enter a value to indicate the distance you want
the frame to extend.

9 Click OK.

You can also access and modify frame display settings through the window’s
context menu, as follows:

1 Select the window you want to change, right-click, and click Edit
Object Display.

2 Click the Display Properties tab.

3 Select the Plan High Detail display representation, and select
Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 Click the Frame Display tab.

6 Adjust the settings as desired, and click OK twice.

Specifying the Display of Custom Block Components of a Window
Use this procedure to specify the display of custom block components for an
individual window in a particular display representation. If you are going to
use custom graphics for a new component, draw the component and save it
as a block before you start this procedure.

1 Double-click the window.

2 Click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all windows in the drawing, select
Drawing default setting. To apply changes to all windows of this style,
select Window Style:<style name>. For more information on styles,
see Window Styles on page 2003.

5 For Display representation, verify that the desired display
representation is selected.
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6 If necessary, expand Object Display Properties ➤ Advanced, and

for Custom block display, click  (the number in parentheses
indicates the number of blocks currently attached to the window).

7 If you want to turn off the display of custom blocks for this
window without removing them, select Disable Custom Blocks.

8 Specify whether to add, edit, or remove a block component:

Then…If you want to…

click Add, and then click Select
Block, select the block, and click
OK.

add a new block component

select the component to edit, and
click Edit.

edit an existing block component

select the block, click Remove, and
click OK.

remove an existing block compon-
ent

9 Specify whether you want to scale to fit the block component to
the object by width, depth, and height, or to lock the XY ratio:

Then…If you want to…

select Width.set the block scale to the width of
the object

select Depth.set the block scale to the depth of
the object

select Height.set the block scale to the height of
the object

select Lock to XY Ratio.scale the whole block equally, so
that one direction is scaled to fit
another of the scale criteria

clear all options under Scale to Fit.scale the block to its original size
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10 Specify whether to mirror the block in the X,Y, or Z direction:

Then…If you want to create a mirror
of the block…

select Mirror X.in the X direction

select Mirror Y.in the Y direction

select Mirror Z.in the Z direction

11 Specify the X, Y, and Z location of the insertion point.

12 Specify an insertion offset of the block in the X, Y, and Z directions.

13 Specify whether the component is for the window frame or
window glass component:

NOTE Both frame and glass components are not available in all
display representations.

Then…If you want to add the block…

select Frame Component, and se-
lect either Outside or Inside.

to the inside or outside of the frame

click Window Component, and click
either All or Single. If you select

to all window glass components or
a single window glass component

Single, enter the component num-
ber.

NOTE If you specified Depth
for Scale to Fit, the depth is
scaled to the glass thickness.
You can scale to the window
panel thickness instead by select-
ing Scale Depth to Panel Thick-
ness.

14 Click OK twice.
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Attaching Hyperlinks, Notes, and Files to a Window
Use this procedure to enter notes and attach reference files to a window. You
can also edit notes and edit or detach reference files from a window.

1 Double-click the window you want to attach notes or files to.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

4 To add a note, click  next to Notes, enter text, and click OK.

5 Click  next to Reference documents, and then attach, detach,
or edit a reference file:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

6 Click OK.

Edit the Width of a Window
Use this procedure to enter notes and attach reference files to a window. You
can also edit notes and edit or detach reference files from a window.

1 Double-click the window you want to attach notes or files to.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.
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4 To add a note, click  next to Notes, enter text, and click OK.

5 Click  next to Reference documents, and then attach, detach,
or edit a reference file:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

6 Click OK.

Window Styles
A window style is a group of properties assigned to a window that determines
the appearance and other characteristics of the window.

You can use window styles to represent standard window types for specific
jobs and drawings or for office standards. When you create or modify a window
style, the windows using the style have the settings and characteristics of the
style. Templates provided with AutoCAD Architecture contain window styles
for many standard windows. You can create your own window styles and
window types for custom windows.

Each window you create has a window style associated with it. The window
style controls window properties such as dimensions, design rules, and standard
sizes for windows. Style control means that when you change a window style,
the windows in the current drawing that use that style change globally.

The design rules are window-style properties that determine the predefined
or custom shape and window type. Window shapes such as Arch, Gothic,
Rectangular, and Round are the geometric configurations of the window.
Custom shapes, such as Hinged-Single-Full Lite, are available for particular
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window types, for example a Single Casement window type. Window types,
such as Awning, Pass Through, or Casement, describe window opening
characteristics of closure, swing, and hinging.

You can create a style using default style properties or by copying an existing
style. After you create the style, you edit the style properties to customize the
characteristics of the style.

Creating Tools from Window Styles

You can create a window tool from any window style. You can drag the style
from the Style Manager onto a tool palette. You can then specify default
settings for any window created with that tool. For more information, see
Using Window Tools to Create Windows on page 1962.

Creating a Window Style
Use this procedure to create a window style.

You can create a new style with default style properties, or you can create a
new style by copying an existing style. After you create the style, you edit the
style properties to customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Create a window style:

Then…If you want to create a new
style…

right-click Window Styles, and click
New.

with default properties

right-click the window style you
want to copy, and click Copy.
Right-click, and click Paste.

from an existing style

4 Enter a name for the new window style, and press ENTER.

5 Edit the style properties of your new window style:

Then…If you want to…

click the General tab, and enter a
description.

enter a description of the style
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Then…If you want to…

see Specifying the Dimensions of a
Window Style on page 2006.

change dimension properties of the
style

see Specifying the Design Rules of
a Window Style on page 2010.

change the design rules of the style

see Specifying the Standard Sizes
of a Window Style on page 2007.

change the standard window sizes
of the style

see Assigning Materials to a Win-
dow Style on page 2016 and Turning

assign materials to the components
of the window style,

on Materials for a Window Style on
page 2018.

see Adding Classifications to a Win-
dow Style on page 2017.

add classifications to a window style

see Specifying the Display Proper-
ties of a Window Style on page 2017.

specify the display properties of the
style

see Changing the Layer, Color, and
Linetype of Window Components
on page 2018.

change the appearance of the dis-
play components in the style

see Adding Components to a Win-
dow Style on page 2020.

add custom block components to
the style

see Turning Off Components in a
Window Style on page 2022.

turn off components in the style

see Removing Components from a
Window Style on page 2022.

remove components from the style

see Specifying the Opening Percent-
age for a Window Style on page 2023.

override the opening percentage
from the style

see Specifying the Display of Win-
dow Sills in a Window Style on page
2025.

change the sill from the style
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Then…If you want to…

see Creating Muntins in a Window
Style on page 2028.

add muntins to the style

see Attaching Notes and Files to a
Window Style on page 2027.

add notes, files, or documents to
the style

6 If you want to assign the style to a window tool, drag the style
from the Style Manager to a tool palette.

You can later rename the tool and specify other properties for it
as described in Creating a Window Tool on page 1971.

7 Click OK.

Specifying the Dimensions of a Window Style
Use this procedure to change the default dimensions of a regular window or
corner window style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Dimensions tab.

5 Click the Window tab for a regular window or the Corner Window
tab for a corner window.
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6 Change dimension values:

Then…If you want to…

under Frame, enter values for Width
and Depth.

change the frame width and depth

under Frame, select Butt Glazing at
Corner.

set the window corners to butt
glazing

under Frame, unselect Butt Glazing
at Corner. Specify inside corner

set the window corners to frame
and adjust the value of the inside
corner frame width frame width value. Only positive

values are valid.

under Frame, select Auto-Adjust to
Width of Wall.

set the frame width to the wall
thickness

under Sash, enter values for Width
and Depth.

change the sash dimensions

enter a value for Glass Thickness.change the window thickness

7 Click OK.

NOTE For corner window with butt glazing on, only Picture, Glider,
and Pass Through window types are supported. If you select any
other window type, a picture window is created. If the corner window
with butt glazing does not support a shape you have selected, a
rectangular shape window is created by default.

Specifying the Standard Sizes of a Window Style
Use this procedure to create the standard window sizes in a window style.

Standard sizes ensure consistency by allowing designers to select sizes from a
predefined list specific to the window style. You can also enter custom sizes
when you add or modify individual windows.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the window style you want to edit.
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4 Click the Standard Sizes tab, and add, change, or remove
window-size values:

Then…If you want to…

click Add  . Under Standard
Sizes, enter values for Description,

create standard sizes

Width and Height; if applicable,
enter values for Rise and Bottom
Sash.

select the size, and click Edit  .
Enter new values as needed.

change a size

select a size, and click Remove 
.

delete a size

Description can be used to identify standard window sizes in
window schedules. For example, you can specify a manufacturer’s
size or model code for Description.

Rise applies to Arch, Gothic, and Peak Pentagon window shapes.
Bottom Sash applies to Uneven Single Hung and Uneven Double
Hung windows. For more information on window types and
shapes, see Specifying the Design Rules of a Window Style on page
2010.

5 Click OK.

Creating a Custom Window Shape
Use this procedure to create a profile for a custom window shape. You can
make custom shapes for windows and apply them to window styles.

The profile is made up of two concentric, closed polylines. The outer polyline,
or ring, becomes the window shape, and the inner polyline creates a void for
the inside shape of the window frame. You can create multiple voids by adding
more inner polylines. The inner polyline must be entirely within the polyline
representing the outer shape of the window frame. The polylines are
proportional in size and shape to each other and also to the windows created
from the window style.
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You can draw these polylines anywhere in the drawing and use any convenient
scale relative to your final window frame size. One method for sizing the
polylines relative to the window is to draw them by snapping to an existing
window, and then moving the completed polylines to the side.

Adding a profile-based window to a wall

1 Draw concentric, closed polylines representing the outer and inner
lines of the window frame.
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2 Select the outer polyline, right-click, and click Convert
To ➤ Profile Definition.

3 Enter a (Add ring).

4 Select the inner polyline.

5 Specify the insertion point of the profile.

The insertion point is typically the lower-left corner.

6 Enter a name for the profile, and click OK.

To add the profile to a window style, see Specifying the Design Rules of a
Window Style on page 2010.

Specifying the Design Rules of a Window Style
Use this procedure to specify the shape and the type of window for a window
style.

Window shapes are named geometrical descriptions of a window. You can
select predefined and custom window shapes, or create your own shape from
profiles. For more information, see Creating a Custom Window Shape on page
2008.

The window type describes the method for opening the window. For example,
you can use the Rectangular or Half Round predefined shapes for the Double
Casement or Single Hopper window types. Or, you can use a custom
Hinged-Single-Full Lite shape for a Single Casement with Muntins.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the window style you want to edit.

4 Click the Design Rules tab.

5 Select a window shape:

Then…If you want to…

under Shape, click Predefined, and
select a shape.

use a predefined window shape

under Shape, click Use Profile, and
select a profile.

use a custom window shape

6 Select a window type.
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7 Click OK.

Replacing the Window Shape in a Window Style
Use this procedure to replace a predefined shape in a window style with a
custom shape created from a profile.

1 Select a window that uses the style you want to modify.

2 Click Window tab ➤ Profile panel ➤ Add Profile  .

3 Specify the profile to use for the custom shape:

Then…If you want to…

select a profile for Profile Definition,
and click OK. For information about

use a predefined window shape

creating a profile, see Creating a
Custom Window Shape on page
2008.

select a profile for Profile Definition,
select Continue Editing, and click

use a predefined window shape,
but modify it

OK. For information about modify-
ing the shape, see Editing the Geo-
metry of a Window Style on page
2011.

select Start from scratch for Profile
Definition, enter a name for the

create a custom shape

new profile, and click OK. For in-
formation about modifying the de-
fault shape, see Editing the Geo-
metry of a Window Style on page
2011.

Editing the Geometry of a Window Style
Use this procedure to edit the geometry of the profile used to define a window
style. You can also add a profile to a window style that does not currently use
a profile to define its shape.

1 Add a window that has the style you want to change.
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2 Add or edit a profile:

Then…If you want to…

select the window, click Window

tab ➤ Profile panel ➤ Add Profile

add an existing profile to the style

 . Select the name of the profile,
and click OK.

select the window, click Window

tab ➤ Profile panel ➤ Add Profile

create a profile and add it to the
style

 . Select Start from scratch for
Profile Definition, enter a name for
new profile, and click OK. A rectan-
gular profile is created for you to
edit to define the required geo-
metry.

select the window, click Window

tab ➤ Profile panel ➤ Edit In Place

 .

edit the existing profile for the style

3 If prompted that the profile is not drawn to size, click Yes.

The area of the window defined by the profile is selected and
hatched in the drawing.

NOTE After you perform an editing task, you may need to select the
profile again to perform another editing task.

4 Edit the profile:

Then…If you want to…

select the profile, and use edge and
vertex grips to adjust the shape.
The Edge grip has three edit modes:
Offset, Add Vertex, and Convert to

change the shape of the perimeter
of the profile or its ring

Arc. The default mode is Offset,
which offsets the selected edge in
a direction that is perpendicular to
the midpoint of the edge. Depend-
ing on the shape of the profile and
the edge you choose to modify,
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Then…If you want to…

neighboring lines are extended or
trimmed, and new lines are added,
as necessary.
Use the Add Vertex edit mode to
add a vertex to the selected edge,
and create a new edge. If the selec-
ted edge is an arc, the new edge is
an arc, as well.
Convert to Arc changes the selected
edge to an arc and stretches the
midpoint of the edge. The edge
grip for an arc also has a Stretch
mode, so that you can stretch the
midpoint of the edge after it has
been converted to an arc.

select an Edge grip, and press CTRL
to switch to the Add Vertex edit

add vertices to the profile

mode. Move the edge to the de-
sired location and click, or enter a
value and press ENTER.

select the Vertex grip for the vertex
you want to remove, and press

remove vertices from the profile

CTRL to switch to the Remove edit
mode. Move the cursor off the se-
lected vertex, and click.

select the profile, click Edit In Place

tab ➤ Profile panel ➤ Replace Ring

replace an existing ring of the pro-
file with new geometry

 . Select the ring to replace, and
select the new geometry. Press
ENTER to keep the geometry, or
enter n (No) to erase it.
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5 Save or discard the changes:

Then…If you want to…

select the profile and click Edit In

Place tab ➤ Edits panel ➤ Cancel

 .

restore the profile to its original
shape

select the profile, and clickEdit In

Place tab ➤ Edits panel ➤ Finish

save the changes to the current
profile

. The window style uses the edited
profile to define its geometry. Any
other objects or styles that use this
profile are also updated with the
edited geometry.

select the profile, and click Edit In

Place tab ➤ Edits panel ➤ Save As

save the changes to a new profile
definition

 . Enter a name for the new
profile definition, and click OK. The
window uses the new profile to
define its geometry. Any windows
of this style are updated with the
new geometry. Other styles or ob-
jects that use the original profile are
not affected.

About Window Display Components and Materials
A window object consists of a number of components whose display properties
can be determined by a material assigned to each component.

When you assign materials to a window, you assign one material to each
display component of the window. For example, you assign a wood material
to the frame and a glass material to the window glass.

If you want to use the display properties of the window object or window
style instead of using material display properties, you can turn off the material
assignments in the display properties of the window or the window style.

Material definitions consist of display components that correspond to
component types of objects. For example, the Linework component of a
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material is used for all linework in Plan view. The Surface Hatch component
of a material is used to hatch all object surfaces in 3D model views and
elevations.

For a complete list of material components and their description, see Material
Components and Display Properties on page 898.

The following table lists all window components that can be displayed using
materials assigned to them, and identifies the material component of each
window component.

Material ComponentWindow Component

Plan, Plan High Detail, Reflected

LIneworkFrame

LIneworkSash

LineworkGlass

Plan Low Detail

LineworkWindow

Model

3D BodyFrame

3D BodySash

3D BodyGlass

Elevation

2D Section/Elevation LineworkFrame

2D Section/Elevation LineworkSash

2D Section/Elevation LineworkGlass
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Assigning Materials to a Window Style
Use this procedure to assign materials to the individual components of a
window style. When you assign materials to window components, the
components use the display properties of the material. For more information,
see About Window Display Components and Materials on page 2014.

You can specify the materials used to display the following components of a
window style:

■ Frame

■ Sash

■ Glass

■ Muntin

NOTE If a material assignment does not determine the display properties of a
window component, you can change the display properties of the window style
as described in Specifying the Display Properties of a Window Style on page 2017.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which you want changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select By Material for any component to which you want to assign
a material, and click OK.

If the setting for By Material is not available, the display of this
component cannot be determined by a material.

9 Click the Materials tab.

10 Click the component you want to change, and select a different
material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.
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WARNING Although you can edit a material definition from this
dialog box, any changes you make to the material definition apply
to all objects that are assigned the material.

11 Click OK.

Adding Classifications to a Window Style
Use this procedure to specify classifications for any classification definition
applied to a window style.

For more information about creating and applying classification definitions,
see Classification Definitions on page 3872.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style that you want to change.

4 Click the Classifications tab.

By default, the classification for all classification definitions is
Unspecified. If no classification definitions are listed, none are
applied to window styles.

5 For each classification definition, select the classification you want
to apply to the current window style.

6 Click OK.

Specifying the Display Properties of a Window Style
In most cases, you want the appearance of windows that belong to the same
style to be consistent throughout a drawing. To achieve this, you specify the
display properties of the windows in each window style:

■ The layer, color, and linetype of window components

■ The hatching used with each component

■ The cut plane height and the display of components relative to the cut
plane

■ Other specific window display information, such as window rise
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Changing the Layer, Color, and Linetype of Window Components
Use this procedure to change the display properties of the window style:

■ Visibility (display component is on or off)

■ By material (material assigned to the display component determines its
layer properties)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

NOTE If a material assignment determines the properties of components in the
window style, you can change the properties of the display component by clearing
By Material or by overriding the material assignment with a different material. For
more information, see Assigning Materials to a Window Style on page 2016.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which you want changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select the component to change, and select a different setting for
the property.

9 Click OK.

Turning on Materials for a Window Style
Use this procedure to turn on material assignments for individual display
representations in a window style.
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For information on creating and assigning materials, see About Window
Display Components and Materials on page 2014.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which you want changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select By Material for each component you want to be controlled
by the material. The ByMaterial checkbox is unavailable for
components that cannot be assigned a material.

When you select By Material for a display component, all other
settings in the dialog are greyed out. The display properties are
now taken from the material definition, so you can no longer set
them directly in the display properties of the window style.

9 Click OK.

Using Custom Blocks to Create Window Components
You can add custom blocks for components, such as window hardware, to
the display components or to replace the default display components. For
example, you can replace a simple window frame with a custom window frame
containing shutters in which you want the custom component to appear. You
can have a different custom block for each display representation.

When you add a custom block, you can specify several rules for positioning
and scaling the new component. Each custom block also appears in the display
properties component list so that you can control its layer, color, and linetype.
For more information on adding custom blocks, see Adding Components to
a Window Style on page 2020.

If you create a custom block from mass elements, you can use the material
assignments of the mass elements to determine the display properties of the
custom block.

Be sure to set the properties of the objects used to create your custom blocks
to ByBlock. Otherwise, you cannot control these objects through the display
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properties. For more information about ByBlock, see “Work with Layers” in
AutoCAD Help.

Adding Components to a Window Style
Use this procedure to add or edit custom block components in the display
representation of window styles.

1 Create a block for the component to add to the window style.

Create the block in the same plane as the window that you use
to represent the style. For more information about custom blocks,
see Using Custom Blocks to Create Window Components on page
2019.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Expand Architectural Objects, and expand Window Styles.

4 Select the style you want to edit.

5 Click the Display Properties tab.

6 Select the display representation in which you want changes to
appear, and select Style Override.

7 If necessary, click  .

8 Click the Other tab.

9 Specify whether to add or edit a block component:

Then…If you want to…

click Add, and then click Select
Block.

add a new block component

select the component to edit, and
click Edit.

edit an existing block component

10 Select the block to use, and click OK.

11 Specify whether you want to scale to fit the block component to
the object by width, depth, and height, or to lock the XY ratio:

Then…If you want to…

select Width.set the block scale to the width of
the object
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Then…If you want to…

select Depth.set the block scale to the depth of
the object

select Height.set the block scale to the height of
the object

select Lock to XY Ratio.scale the whole block equally, so
that one direction is scaled to fit
another of the scale criteria

clear all options under Scale to Fit.scale the block to its original size

12 Specify whether to mirror the block in the X,Y, or Z direction:

Then…If you want to create a mirror
of the block…

select Mirror X.in the X direction

select Mirror Y.in the Y direction

select Mirror Z.in the Z direction

13 Specify the X, Y, and Z location of the insertion point to be left,
right, or center.

14 Specify an insertion offset of the block in the X, Y, and Z directions.

15 Specify whether the component is for the window frame or
window glass component:

Then…If you want to add the block…

click Frame Component, and click
either Outside or Inside.

to the inside or outside of the frame

click Window Component, and click
either All or Single. If you select

to all window glass components or
a single window glass component

Single, enter the component num-
ber.
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Then…If you want to add the block…

NOTE If you specified Depth
for Scale to Fit, the depth is
scaled to the glass thickness.
You can scale to the window
panel thickness instead by select-
ing Scale Depth to Panel Thick-
ness.

16 Frame and Glass components are not available in some display
representations.

Click OK three times.

Turning Off Components in a Window Style
Use this procedure to turn off custom blocks in a window style.

You can turn off the display of component blocks without removing them
from the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which you want to turn off
the display of the window component, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 Select Disable Custom Blocks.

9 Click OK.

Removing Components from a Window Style
Use this procedure to remove components from a window style.

Removing component blocks from a window style deletes them from the style.
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1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which you want to remove
the window component, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 Select the component to remove, and click Remove.

9 Click OK.

Specifying the Opening Percentage for a Window Style
Use this procedure to override the opening percentage in the display
representation of a window style. For example, you can specify that a window
is displayed closed in model and elevation representations, but open in plan
representations.

NOTE This setting overrides other window opening percent settings. If the opening
percent is specified here, the opening percent entered on the Properties palette
when you add or modify windows is ignored.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which you want to override
the opening percent, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 Select Override Open Percent.

9 Enter a value for the opening percent.

10 Click OK.
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Specifying the Reverse Handling for a Window Style
Use this procedure to specify reverse handling in the display representation
of a window style. By reverse handling, you can change the direction of the
window opening. Instead of opening the window from the left, you can open
it from the right. Thus, the swing angle of the opening will also reverse.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation in which you want to override
the opening percent, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 Select Reverse Handling.

9 Click OK.

Specifying the Display Properties of Window Frames
Use this procedure to specify the display properties of window frames.

1 Create a regular window or a corner window.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Expand Architectural Objects, and expand Window Styles.

4 Select the style you want to edit.

5 Click the Display Properties tab.

6 Select Plan High Detail and select Style Override.

7 If necessary, click  .

8 Click the Frame Display tab.

9 Select Windows to specify the display properties of regular window
frames. Select Corner Window to specify the display properties
of corner window frames.

10 Under Frame, specify the frame type:

■ Standard. Displays the frame at a standard location.
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■ Offset. Sets the frame to offset from the original location.

11 Under extension, specify the A-extension value.

Extension is the distance between the window width edge and
the frame edge.

Specifying the Display of Window Sills in a Window Style
Use this procedure to change the regular window and corner window sill
dimensions in the Sill Plan display representation.

You must use a display representation for a window that has a sill. You can
turn on the Sill Plan display representation in addition to the Plan display
representation.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select Sill Plan for Display Representations, and select Style
Override.

6 If necessary, click  .
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7

8 Select the Window tab or the Corner Window tab.

9 Under Sill Dimensions, enter the sill extension and depth
dimensions.

Sill components A and B are for the swing or outside of the
window. Sill components C and D are for the interior side.

NOTE For corner windows, A-Extension and B-Depth are applied to
the anchored wall; C- extension and D- Depth are applied to the
non-anchored wall.

10 If you want to use the cut plane of the wall for anchored windows,
instead of using the cut plane of the window, select Use Cut Plane
of Containing Object when Anchored.

11 Click the Layer/Color/Linetype tab.

12 Under Visible, click the icons to turn on visibility.

13 Click OK twice.

Defining a Window Style as Bounding for Associative Spaces
Use this procedure to define a window style that can bound associative spaces.

When a window style is set as bounding, by default all windows that have
the style assigned will be used in the selection set for an associative space. For
more information about associative spaces see Generating Associative Spaces
on page 2940.

You can override the bounding settings from the window style in an individual
window, if necessary.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.
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3 Select a window style.

4 Click the General tab.

5 Select the checkbox for Objects of this style may act as a boundary
for associative spaces.

6 Click OK.

Attaching Notes and Files to a Window Style
Use this procedure to enter notes and attach reference files to a window style.
You can also edit reference files attached to the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the General tab.

5 To add a description to the window, enter the description under
Description.

6 Click Notes.

7 To add or edit a note, click the Notes tab, and enter the note.

8 To attach, edit, or detach a reference file, click the Reference Docs
tab:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Edit
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application. Click OK.

edit a reference file

select the file name, click Delete,
and click OK.

detach a reference file

9 Click OK.
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Creating Muntins in a Window Style
Window muntins are secondary framing members that hold multiple panes
of glass in a window sash. AutoCAD Architecture provides an easy way to
create muntins with different layout patterns.

Window muntins are available in several patterns that you can customize into
many different styles:

■ Rectangular

■ Diamond

■ Prairie 9 Lights

■ Prairie 12 Lights

■ Starburst

■ Sunburst

■ Gothic

Starburst and Sunburst patterns are a combined-rectangular pattern with a
half-round or quarter-round spoked top and can be used for half- and
quarter-round as well as rectangular muntins. Gothic is similar but has a gothic
muntin pattern. The other patterns are primarily rectangular but fit into
half-round window sash.

NOTE Corner window styles do not support diamond-patterned muntins. If you
continue to select diamond pattern muntins, rectangular-patterned muntins are
displayed.

You can make custom shapes for window muntins by creating profiles from
polylines and adding them to a new window style. For information about
creating profiles and adding them to a window style, see Creating a Custom
Window Shape on page 2008.
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Window muntin components

Adding Rectangular Muntins to a Window Style
Use this procedure to add rectangular muntins to a window style.

You add the muntins by editing the display properties of the window style
for a display representation, such as Model or Elevation, where you want the
muntins to appear. You can add muntins to display representations
individually. You can also add muntins to a single display representation and
automatically apply the muntins to all display representations of that window
style. You add the muntins block to the window style in the display properties.
Each muntins block becomes a display component of the window style.

You can apply the rectangular pattern to all window shapes and window types
except Pass Through.

Specifying rectangular pattern muntins

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.
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6 If necessary, click  .

7 Click the Muntins tab.

8 Click Add.

9 Enter a name for the muntins block.

10 If the window style contains multiple sash, specify whether you
want muntins applied to the Top, All, or a Single sash component
in the window:

Then…If you want to attach muntins
to…

under Window Pane, select Top.
Top also applies to single sash.

the top sash only

under Window Pane, select Other,
and select All.

all sash

under Window Pane, select Other.
Select Single, and specify the index

an individual sash component

number for window sash. Sash is
indexed counterclockwise, starting
from the lower left corner.

Specifying rectangular muntins for top sash
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Specifying rectangular muntins for an individual sash component

11 Enter a value for the width of all muntins.

12 Enter a value for the depth of all muntins.

13 Clean up the muntin intersections:

Then…If you want to convert…

under Muntin, select Clean Up
Joints.

the muntin intersections to corners

under Muntin, select Convert to
Body.

all the muntins to one body with
the joints cleaned up

Specifying rectangular muntin cleanup joints

14 Under Lights, select Rectangular for Pattern.

15 Enter a value for Lights High to specify the number of light rows
in the vertical direction.
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16 Enter a value for Lights Wide to specify the number of light
columns in the horizontal direction.

17 Click OK.

18 Add additional muntins:

Then…If you want to add muntins
to…

repeat this procedure from step 8.another window sash in the win-
dow style

click OK, and repeat this procedure
from step 5.

another display representation

select Automatically Apply to Other
Display Representations and Object
Overrides.

all display representations of the
selected window style

19 Click OK three times.

After you add a muntins block to a window style, you can assign a material,
such as wood, and specify display properties, such as color and linetype, for
the muntins. For more information, see About Window Display Components
and Materials on page 2014, Specifying the Display Properties of a Window Style
on page 2017, and Creating and Editing Material Definitions on page 919
respectively.

Adding Diamond Muntins to a Window Style
Use this procedure to add diamond muntins to a window style.

You add the muntins by editing the display properties of the window style
for a display representation, such as Model or Elevation, where you want the
muntins to appear. You can add muntins to display representations
individually. You can also add muntins to a single display representation and
automatically apply the muntins to all display representations of that window
style. You add the muntins block to the window style in the display properties.
Each muntins block becomes a display component of the window style.

You can apply the diamond pattern to all window shapes and window types
except Pass Through.
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Specifying diamond pattern muntins

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Muntins tab.

8 Click Add.

9 Enter a name for the muntins block.

10 If the window style contains multiple sash, specify whether you
want muntins applied to the Top, All, or a Single sash component
in the window:

Then…If you want to attach muntins
to…

under Window Pane, select Top.
Top also applies to single sash.

the top sash only

under Window Pane, select Other,
and select All.

all sash

under Window Pane, select Other.
Select Single, and specify the index

an individual sash component

number for window sash. Sash is
indexed counterclockwise, starting
from the lower left corner.
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Specifying diamond muntins for top sash

Specifying diamond muntins to an individual sash component

11 Enter a value for the width of all muntins.

12 Enter a value for the depth of all muntins.

13 Clean up the muntin intersections:

Then…If you want to…

under Muntin, select Clean Up
Joints.

convert the muntin intersections to
corners

under Muntin, select Convert to
Body.

convert all the muntins to one body
with the joints cleaned up
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Specifying diamond muntin cleanup joints

14 Under Lights, select Diamond for Pattern.

15 Enter a value for Lights High to specify the number of light rows
in the vertical direction.

16 Enter a value for Lights Wide to specify the number of light
columns in the horizontal direction.

17 Click OK.

18 Add additional muntins:

Then…If you want to add muntins to
…

repeat this procedure from step 8.another window sash in the win-
dow style

click OK, and repeat this procedure
from step 5.

another display representation

select Automatically Apply to Other
Display Representations and Object
Overrides.

all display representations of the
selected window style

19 Click OK three times.

After you add a muntins block to a window style, you can assign a material,
such as wood, and specify display properties, such as color and linetype, for
the muntins. For more information, see About Window Display Components
and Materials on page 2014, Specifying the Display Properties of a Window Style
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on page 2017, and Creating and Editing Material Definitions on page 919
respectively.

Adding Prairie-9 Lights Muntins to a Window Style
Use this procedure to add prairie-9 lights muntins to a window style.

You add the muntins by editing the display properties of the window style
for a display representation, such as Model or Elevation, where you want the
muntins to appear. You can add muntins to display representations
individually. You can also add muntins to a single display representation and
automatically apply the muntins to all display representations of that window
style. You add the muntins block to the window style in the display properties.
Each muntins block becomes a display component of the window style.

You can apply the prairie-9 lights pattern to all window shapes and window
types except Pass Through.

Specifying prairie-9 lights pattern muntins

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Muntins tab.

8 Click Add.

9 Enter a name for the muntins block.
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10 If the window style contains multiple sash, specify whether you
want muntins applied to the Top, All, or a Single sash component
in the window:

Then…If you want to attach muntins
to…

under Window Pane, select Top.
Top also applies to single sash.

the top sash only

under Window Pane, select Other,
and select All.

all sash

under Window Pane, select Other.
Select Single, and specify the index

an individual sash component

number for window sash. Sash is
indexed counterclockwise, starting
from the lower left corner.

Specifying prairie-9 lights muntins for top sash
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Specifying prairie-9 lights muntins to an individual sash component

11 Enter a value for the width of all muntins.

12 Enter a value for the depth of all muntins.

13 Clean up the muntin intersections:

Then…If you want to…

under Muntin, select Clean Up
Joints.

convert the muntin intersections to
corners

under Muntin, select Convert to
Body.

convert all the muntins to one body
with the joints cleaned up

Specifying prairie-9 lights muntin cleanup joints

14 Under Lights, select Prairie-9 Lights for Pattern.

15 Enter a value for Edge X Offset to specify the horizontal distance
of the muntins from the edges of the pane.
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16 Enter a value for Edge Y Offset to specify the vertical distance of
the muntins from the edges of the pane.

Specifying prairie-9 lights pattern muntin edge X and Y offsets

17 Click OK.

18 Add additional muntins:

Then…If you want to add muntins
to…

repeat this procedure from step 8.another window sash in the win-
dow style

click OK, and repeat this procedure
from step 5.

another display representation

select Automatically Apply to Other
Display Representations and Object
Overrides.

all display representations of the
selected window style

19 Click OK three times.

After you add a muntins block to a window style, you can assign a material,
such as wood, and specify display properties, such as color and linetype, for
the muntins. For more information, see About Window Display Components
and Materials on page 2014, Specifying the Display Properties of a Window Style
on page 2017, and Creating and Editing Material Definitions on page 919
respectively.

Adding Prairie-12 Lights Muntins to a Window Style
Use this procedure to add prairie-12 lights muntins to a window style.

You add the muntins by editing the display properties of the window style
for a display representation, such as Model or Elevation, where you want the
muntins to appear. You can add muntins to display representations
individually. You can also add muntins to a single display representation and
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automatically apply the muntins to all display representations of that window
style. You add the muntins block to the window style in the display properties.
Each muntins block becomes a display component of the window style.

You can apply the prairie-12 lights pattern to all window shapes and window
types except Pass Through.

Specifying prairie-12 lights pattern muntins

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Muntins tab.

8 Click Add.

9 Enter a name for the muntins block.

10 If the window style contains multiple sash, specify whether you
want muntins applied to the Top, All, or a Single sash component
in the window:

Then…If you want to attach muntins
to…

under Window Pane, select Top.
Top also applies to single sash.

the top sash only

under Window Pane, select Other,
and select All.

all sash

under Window Pane, select Other.
Select Single, and specify the index

an individual sash component
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Then…If you want to attach muntins
to…

number for window sash. Sash is
indexed counterclockwise, starting
from the lower left corner.

Specifying prairie-12 lights muntins for top sash

Specifying muntins to an individual sash component

11 Enter a value for the width of all muntins.

12 Enter a value for the depth of all muntins.
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13 Clean up the muntin intersections:

Then…If you want to…

under Muntin, select Clean Up
Joints.

convert the muntin intersections to
corners

under Muntin, select Convert to
Body.

convert all the muntins to one body
with the joints cleaned up

Specifying muntin cleanup joints

14 Under Lights, select Prairie-12 Lights for Pattern.

15 Enter a value for Edge X Offset to specify the horizontal distance
of the muntins from the edges of the pane.

16 Enter a value for Edge Y Offset to specify the vertical distance of
the muntins from the edges of the pane.

Specifying prairie-12 lights pattern muntin edge X and Y offsets

17 Click OK.
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18 Add additional muntins:

Then…If you want to add muntins
to…

repeat this procedure from step 8.another window sash in the win-
dow style

click OK, and repeat this procedure
from step 5.

another display representation

select Automatically Apply to Other
Display Representations and Object
Overrides.

all display representations of the
selected window style

19 Click OK three times.

After you add a muntins block to a window style, you can assign a material,
such as wood, and specify display properties, such as color and linetype, for
the muntins. For more information, see About Window Display Components
and Materials on page 2014, Specifying the Display Properties of a Window Style
on page 2017, and Creating and Editing Material Definitions on page 919
respectively.

Adding Starburst Muntins to a Window Style
Use this procedure to add starburst muntins to a window style.

You add the muntins by editing the display properties of the window style
for a display representation, such as Model or Elevation, where you want the
muntins to appear. You can add muntins to display representations
individually. You can also add muntins to a single display representation and
automatically apply the muntins to all display representations of that window
style. You add the muntins block to the window style in the display properties.
Each muntins block becomes a display component of the window style.

You can add the starburst pattern only to the top window sash. You can apply
the starburst pattern to window shapes with a round, half round, or quarter
round top.

You can apply the starburst pattern to the following window types: awning,
single hopper, single transom, vertical pivot, horizontal pivot, double hung,
glider, single hung, single casement, and picture.
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Specifying starburst pattern muntins

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Muntins tab.

8 Click Add.

9 Enter a name for the muntins block.

10 Under Window Pane, select Top.

NOTE The Starburst pattern is available only when Top is selected
for Window Pane.

11 Enter a value for the width of all muntins.

12 Enter a value for the depth of all muntins.

13 Clean up the muntin intersections:

Then…If you want to…

under Muntin, select Clean Up
Joints.

convert the muntin intersections to
corners

under Muntin, select Convert to
Body.

convert all the muntins to one body
with the joints cleaned up
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Specifying starburst muntin cleanup joints

14 Under Lights, select Starburst for pattern.

15 Enter a value for Lights High to specify the number of light rows
in a vertical direction.

16 Enter a value for Lights Wide to specify the number of panes in
the radial direction.

17 Enter a value for Spokes to specify the number of radial muntin
spokes.

Specifying number of spokes for starburst muntins

18 Click OK.

19 Add additional muntins:

Then…If you want to add muntins
to…

repeat this procedure from step 8.another window sash in the win-
dow style
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Then…If you want to add muntins
to…

click OK, and repeat this procedure
from step 5.

another display representation

select Automatically Apply to Other
Display Representations and Object
Overrides.

all display representations of the
selected window style

20 Click OK three times.

After you add a muntins block to a window style, you can assign a material,
such as wood, and specify display properties, such as color and linetype, for
the muntins. For more information, see About Window Display Components
and Materials on page 2014, Specifying the Display Properties of a Window Style
on page 2017, and Creating and Editing Material Definitions on page 919
respectively.

Adding Sunburst Pattern Muntins to a Window Style
Use this procedure to add sunburst muntins to a window style.

You add the muntins by editing the display properties of the window style
for a display representation, such as Model or Elevation, where you want the
muntins to appear. You can add muntins to display representations
individually. You can also add muntins to a single display representation and
automatically apply the muntins to all display representations of that window
style. You add the muntins block to the window style in the display properties.
Each muntins block becomes a display component of the window style.

You can add the sunburst pattern only to the top window sash. You can apply
the sunburst pattern to window shapes with a round, half round, or quarter
round top.

You can apply the sunburst pattern to the following window types: awning,
single hopper, single transom, vertical pivot, horizontal pivot, double hung,
glider, single hung, single casement, and picture.
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Specifying sunburst pattern muntins

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Muntins tab.

8 Click Add.

9 Enter a name for the muntins block.

10 Under Window Pane, select Top.

NOTE The Sunburst pattern is available only when Top is selected
for Window Pane.

11 Enter a value for the width of all muntins.

12 Enter a value for the depth of all muntins.

13 Clean up the muntin intersections:

Then…If you want to…

under Muntin, select Clean Up
Joints.

convert the muntin intersections to
corners

under Muntin, select Convert to
Body.

convert all the muntins to one body
with the joints cleaned up

Creating Muntins in a Window Style | 2047



Specifying sunburst muntin cleanup joints

14 Under Lights, select Sunburst for Pattern.

15 Enter a value for Lights High to specify the number of light rows
in a vertical direction.

16 Enter a value for Lights Wide to specify the number of panes in
the radial direction.

17 Enter a value for Spokes to specify the number of radial muntin
spokes.

Specifying number of spokes for sunburst muntins

18 Under Hub Style, select Closed for no hub pane, or select Open
for a hub pane.

Specifying sunburst muntin open and closed hubs
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19 Enter a value for Radius to specify the radius for the hub.

Specifying sunburst muntin hub radius

20 Click OK.

21 Add additional muntins:

Then…If you want to add muntins
to…

repeat this procedure from step 8.another window sash in the win-
dow style

click OK, and repeat this procedure
from step 5.

another display representation

select Automatically Apply to Other
Display Representations and Object
Overrides.

all display representations of the
selected window style

22 Click OK three times.

After you add a muntins block to a window style, you can assign a material,
such as wood, and specify display properties, such as color and linetype, for
the muntins. For more information, see About Window Display Components
and Materials on page 2014, Specifying the Display Properties of a Window Style
on page 2017, and Creating and Editing Material Definitions on page 919
respectively.

Adding Gothic Muntins to a Window Style
Use this procedure to add gothic muntins to a window style.

You add the muntins by editing the display properties of the window style
for a display representation, such as Model or Elevation, where you want the
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muntins to appear. You can add muntins to display representations
individually. You can also add muntins to a single display representation and
automatically apply the muntins to all display representations of that window
style. You add the muntins block to the window style in the display properties.
Each muntins block becomes a display component of the window style.

You can add the gothic pattern only to the top window sash. You can apply
the gothic pattern to the following window shapes: round, half round, gothic,
peak pentagon, or arch.

You can apply the gothic pattern to the following window types: awning,
single hopper, single transom, vertical pivot, horizontal pivot, double hung,
glider, single hung, single casement, and picture.

Specifying gothic pattern muntins

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Muntins tab.

8 Click Add.

9 Enter a name for the muntins block.

10 Under Window Pane, select Top.

NOTE The Gothic pattern is available only when Top is selected for
Window Pane.

11 Enter a value for the width of all muntins.

12 Enter a value for the depth of all muntins.
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13 Clean up the muntin intersections:

Then…If you want to…

under Muntin, select Clean Up
Joints.

convert the muntin intersections to
corners

under Muntin, select Convert to
Body.

convert all the muntins to one body
with the joints cleaned up

Specifying gothic muntin cleanup joints

14 Under Lights, select Gothic for Pattern.

15 Enter a value for Lights High to specify the number of light rows
in the vertical direction.

16 Enter a value for Lights Wide to specify the number of panes in
the horizontal direction.

Count the panes across the bottom row.

17 Click OK.

18 Add additional muntins:

Then…If you want to add muntins
to…

repeat this procedure from step 8.another window sash in the win-
dow style
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Then…If you want to add muntins
to…

click OK, and repeat this procedure
from step 5.

another display representation

select Automatically Apply to Other
Display Representations and Object
Overrides.

all display representations of the
selected window style

19 Click OK three times.

After you add a muntins block to a window style, you can assign a material,
such as wood, and specify display properties, such as color and linetype, for
the muntins. For more information, see About Window Display Components
and Materials on page 2014, Specifying the Display Properties of a Window Style
on page 2017, and Creating and Editing Material Definitions on page 919

Editing a Window Muntins Block in a Window Style
Use this procedure to edit the muntins settings for a window style.

After you create a muntins block, you can change any of its settings by editing
the display properties of the window style for each display representation,
such as Model or Elevation. You can edit the muntins for display
representations individually. You can also edit the muntins for a single display
representation and automatically apply the changes to all display
representations of that window style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to

appear, and click  .

6 Click the Muntins tab.

7 Select the muntins block to edit.

8 Click Edit.

9 Edit any of the settings.
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For more information on the settings, see the window muntins
type in Creating Muntins in a Window Style on page 2028.

10 Select Automatically Apply to Other Display Representations and
Object Overrides to apply the changes to all display
representations of the selected window style.

Clear this setting to apply the changes to only the selected display
representation.

11 When you finish editing the window muntins block in the
window style, click OK three times.

After you add a muntins block to a window style, you can assign a material,
such as wood, and specify display properties, such as color and linetype, for
the muntins. For more information, see About Window Display Components
and Materials on page 2014, Specifying the Display Properties of a Window Style
on page 2017, and Creating and Editing Material Definitions on page 919
respectively.

Turning Off the Display of Muntins in a Window Style
Use this procedure to turn off the display of muntins in a window style. You
can turn off the display of window muntins without removing them from the
window.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want to turn off the

display of window muntins, and click  .

6 Click the Muntins tab.

7 Select Disable Muntins Blocks.

8 Select Automatically Apply to Other Display Representations and
Object Overrides to apply the changes to all display
representations of the selected window style.

Clear this setting to apply the changes to only the selected display
representation.

9 Click OK twice.
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Removing a Window Muntins Block from a Window Style
Use this procedure to remove muntins from a window style. When you remove
existing muntins blocks from the window style, they are deleted.

To turn off muntins without deleting them, see Turning Off the Display of
Muntins in a Window Style on page 2053.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Window Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want to remove

window muntins, and click  .

6 Click the Muntins tab.

7 Select the muntins block to remove.

8 Click Remove.

9 Repeat steps 7 and 8 to remove multiple muntins blocks.

10 Select Automatically Apply to Other Display Representations and
Object Overrides to apply the changes to all display
representations of the selected window style.

Clear this setting to apply the changes to only the selected display
representation.

11 When you finish removing muntins blocks from the window
style, click OK twice.

Changing the Automatic Properties of a Corner Window
AutoCAD Architecture provides a default automatic property set for corner
window widths and frames. These automatic properties are reported in the
window schedule. You can use the Style Manager to customize the automatic
properties reported in the window schedule.

To change the automatic properties generated in the window schedule, do
the following:

1 Open a drawing with regular windows and corner windows.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Expand Property Set definition and select Window Styles.
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4 In the Definition tab, click Add Automatic Property Definition.

5 Under Window Styles select Corner Rough Opening Width –
CROW1 x CROW2.
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6 Expand Schedule Table and Style and select Window Schedule.

7 Click Columns tab  ➤ Add Column.

8 In the Add Column dialog, under Window Styles select Corner
Rough Opening Width – CROW1 x CROW2.
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9 Click OK.

10 In the Style Manager, click Apply, and then click OK.

11 Click Annotate tab  ➤ Scheduling panel  ➤ Window Tag.

12 Select window objects in the drawing to tag.

13 Click Annotate tab  ➤ Scheduling panel  ➤  Window Schedule.

14 Select regular and corner windows in the drawing.

15 Press Enter.
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16 Specify upper left corner of the table and upper right corner of
the table and press Enter.

17 Notice, in the generated schedule, automatic property Corner
Rough Opening Width – CROW1 x CROW2 is displayed.
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Openings

An opening is an AEC object that interacts with walls to represent an opening of any size at
any elevation. You can also add openings as freestanding objects.

Openings
An opening is an AEC object that interacts with walls to represent an opening
of any size at any elevation. You can also add openings as freestanding objects.

Opening Shapes

When you add an opening to a drawing, you can select from a number of
predefined shapes, such as rectangular, half-round, oval, or arch. You can also
create openings with custom shapes using profiles to define the geometry of
the opening.

Examples of predefined shapes for openings

27
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Anchoring Openings

After you place an opening in a wall, the opening is constrained to the object
and cannot move outside it.

Openings can also be anchored to specific locations in walls, so that when
the wall moves or changes size, the location of the opening in that object
remains constant.

Opening Endcaps

Openings that are anchored in a wall can have endcap styles applied to them.
The endcap shapes for wall openings are defined in the wall style and are a
property of the wall. For information on setting an opening endcap style in
a wall, see Working with Wall Endcaps and Opening Endcaps on page 1373.

Opening Dimensions

All openings have height and width. The rise dimension depends on the
opening shape. Rise is the height from the top of the rectangular portion of
an opening to the peak of the opening for gothic, arch, peak pentagon, and
trapezoid shapes.

Vertical Alignment of Openings

Use the vertical alignment settings to control how to place an opening in the
wall, the location of the working point vertically in the wall, and how the
opening responds to modifications in height. Use the sill and head height
settings to determine the working point on the opening. You can place the
working point at the sill or at the head. For example, if you specify the vertical
alignment as 0'' and the opening height as 7'–0'', the opening height is 7’–0''.
If you next specify the height of the opening as 6'–8'', the sill remains at 0''
and the opening height becomes 6’–8''.

For the opening head working point, if you specify the vertical alignment as
7'–0'' and the opening height as 7'–0'', the opening height is 7–0''. If you specify
the opening height as 6'–8'', the head remains at 7'–0'' and the sill becomes
4''.

Using Opening Tools to Create Openings
Tools provided with AutoCAD Architecture let you quickly place openings by
selecting an opening tool with a specific opening style and other predefined
properties. You can use the tool with all of its default settings, or you can
change any properties that are not controlled by the style. You can also use
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opening tools to create new openings by applying tool properties to existing
door/window assemblies, doors and windows.

Tool palette containing opening tool

The default tool palettes in the workspace contain a sample opening tool that
you can use and customize as needed. In addition, the following catalogs
provided with the software contain opening tools that you can add to your
tool palettes:

■ Stock Tool catalog

■ Sample Palette catalog

Custom palettes created by your CAD manager or other users may also contain
opening tools with properties that are customized for your projects or office
standards.

Creating an Opening
Use this procedure to add an opening that has the properties specified in the
opening tool that you select. To specify settings when you add an opening,
see Creating an Opening with User-Specified Settings on page 2062.
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Adding an opening to a wall

1 Open the tool palette that you want to use, and select an opening
tool.

If necessary, scroll to display the desired tool.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Door

drop-down ➤ Opening  .

2 Select a wall in which to insert the opening, or press ENTER to add
a freestanding opening.

You can move or hide the Properties palette to expose more of
the drawing area.

3 Specify the insertion point of the opening.

If you are adding a freestanding opening, specify the rotation of
the opening after you specify the insertion point.

4 Continue adding openings, and press ENTER.

Creating an Opening with User-Specified Settings
Use this procedure to create an opening with settings that you specify.
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Adding an opening to a wall

1 Open the tool palette that you want to use, and select an opening
tool.

If necessary, scroll to display the desired tool.

2 On the Properties palette, expand Basic, and expand General.

3 Select a shape for the opening.

To specify a custom shape, select Custom for Shape, and select
the profile that provides the geometry of the shape for Profile.

NOTE Alternatively, after creating an opening, you can later add a
profile to it by selecting the opening, and clicking Opening

tab ➤ Profile panel ➤ Add Profile  .

4 Expand Dimensions.

5 Enter values for Width, Height, and Rise.

Rise is available only for arch, gothic, peak pentagon, and
trapezoid shapes.

6 Expand Location.
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7 If you are placing the opening in a wall, specify the opening
position:

Then…If you want to…

select Offset/Center for Position
along wall, and enter a value for
Automatic offset.

position the edge of the opening at
a specific distance from the end of
a wall segment

select Offset/Center for Position
along wall, and specify a point near
the center of the wall segment.

center the opening on a wall seg-
ment

select Unconstrained for Position
along wall.

position the opening anywhere
along the wall

8 Specify whether you want the opening to be aligned vertically by
sill height or by head height:

Then…If you want to…

select Sill for Vertical alignment, and
enter a value for Sill height.

align the opening by sill height

select Head for Vertical alignment,
and enter a value for Head height.

align the opening by head height

9 Specify the insertion point for an opening in a wall or for a
freestanding opening:

Then…If you want to…

select the wall, and specify an inser-
tion point along the wall.

place an opening in a wall

press ENTER, and specify an inser-
tion point and rotation angle for
the opening.

place a freestanding opening

10 Continue to place openings, and press ENTER.
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Creating an Opening from Doors, Door/Window
Assemblies and Windows

Use this procedure to convert a door, door/window assembly, or window to
an opening that has the properties of the opening tool you select. You can
edit these properties after creating the opening.

1 Open the tool palette that you want to use.

If necessary, scroll to display the tool that you want to use.

2 Right-click an opening tool, and click Apply Tool Properties
to ➤ Door, Door/Window Assembly, Window.

3 Select the door, door/window assembly or window to convert,
and press ENTER.

4 Edit the properties of the opening in the Properties palette, if
needed.

Creating and Editing Custom Openings
In addition to using predefined shapes for openings, you can create openings
with custom shapes. You create a profile from a closed polyline to define the
two-dimensional (2D) geometry of the shape. The profile is then extruded
when it is applied to an opening. You can edit the profile to change the shape
of the opening. You can then save the changes to the current profile or to a
new profile. You can apply the profiles you create to any openings.

Creating a Profile for a Custom Opening
Use this procedure to create a profile that provides the geometry for an opening
with a custom shape.

You can create the profile as you add it to an opening. However, if the shape
you need is elaborate and has curved segments, you may find it easier to create
the profile from a polyline first. You can then add the profile to the opening.

1 Draw concentric, closed polylines representing the opening and
any insets.

2 Select the polylines, right-click, and click Convert to ➤ Profile
Definition.

3 Select the outermost polyline.
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4 Enter a (Add ring).

5 Select an inner polyline.

6 Repeat steps 4 and 5 as needed to add more rings to the profile.

7 Specify the insertion point of the profile.

8 Enter n (New), enter a name for the profile, and click OK.

Creating an Opening with a Custom Shape
Use this procedure to create an opening with a custom shape and other settings
that you specify.
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Adding an opening with a custom shape

1 Open the tool palette that you want to use, and select an opening
tool.

If necessary, scroll to display the desired tool.

2 On the Properties palette, expand Basic, and expand General.

3 Select Custom for Shape.
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4 Select the profile that provides the geometry of the shape for
Profile.

5 Expand Dimensions.

6 Enter values for Width and Height.

7 Expand Location.

8 If you are placing the opening in a wall, specify the opening
position:

Then…If you want to…

select Offset/Center for Position
along wall, and enter a value for
Automatic offset.

position the edge of the opening at
a specific distance from the end of
a wall segment

select Offset/Center for Position
along wall, and specify a point near
the center of the wall segment.

center the opening on a wall seg-
ment

select Unconstrained for Position
along wall.

position the opening anywhere
along the wall

9 Specify whether you want the opening to be aligned vertically by
sill height or by head height:

Then…If you want to…

select Sill for Vertical alignment, and
enter a value for Sill height.

align the opening by sill height

select Head for Vertical alignment,
and enter a value for Head height.

align the opening by head height

10 Specify the insertion point for an opening in a wall or for a
freestanding opening:

Then…If you want to…

select the wall, and specify an inser-
tion point along the wall.

place an opening in a wall

press ENTER, and specify an inser-
tion point and a rotation angle for
the opening.

place a freestanding opening
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11 Continue to place openings, and press ENTER.

Editing the Geometry of a Custom Opening
Use this procedure to edit the geometry of a profile that determines the shape
of a custom opening. You can save the changes to the existing profile or to a
new profile.

1 Select the opening that has the shape you want to change, and

click Opening tab ➤ Profile panel ➤ Edit In Place  .

A temporary profile is created for you to edit the geometry of the
custom opening.

A temporary profile for editing a custom opening

2 NOTE After you perform an editing task from the Edit in Place tab,
you may need to select the profile again to perform another editing
task. If you do not see the editing commands that you expect on the
ribbon, select the profile, and click Edit in Place once again.

Edit the profile:

Then…If you want to…

select the profile, and use edge and vertex
grips to adjust the shape.
The Edge grip has three edit modes: Off-
set, Add Vertex, and Convert to Arc. The

change the shape of the
perimeter of the profile or its
rings

default mode is Offset, which offsets the
selected edge in a direction that is perpen-
dicular to the midpoint of the edge. De-
pending on the shape of the profile and
the edge you choose to modify, neighbor-
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Then…If you want to…

ing lines are extended or trimmed, and
new lines are added, as necessary.
Use the Add Vertex edit mode to add a
vertex to the selected edge, and create a
new edge. If the selected edge is an arc,
the new edge is an arc, as well.
Convert to Arc changes the selected edge
to an arc and stretches the midpoint of
the edge. The edge grip for an arc also
has a Stretch mode, so that you can
stretch the midpoint of the edge after it
has been converted to an arc.

select an Edge grip, and press CTRL to
switch to the Add Vertex edit mode. Move

add vertices to the profile

the edge to the desired location and click,
or enter a value and press ENTER.

select the Vertex grip for the vertex you
want to remove, and press CTRL to switch

remove vertices from the
profile

to the Remove edit mode. Move the
cursor off the selected vertex, and click.

select the profile, and click Edit In Place

tab ➤ Profile panel ➤ Replace Ring  .

replace an existing ring of the
profile with new geometry

Select the ring to replace, and select the
new geometry. Press ENTER to keep the
geometry, or enter y (Yes) to erase it.

draw the linework in place on the tempor-
ary profile. Select the profile, and click Edit

add a ring to the profile

In Place tab ➤ Profile panel ➤ Add Ring

 . Select the geometry to define the
ring. Press ENTER to keep the geometry,
or enter y (Yes) to erase it.

select the profile, and click Edit In Place

tab ➤ Profile panel ➤ Remove Ring  .

remove a ring from the pro-
file

Select the ring to remove, and press
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Then…If you want to…

ENTER. This option does not appear if the
profile has only one ring.

Profile for custom opening after editing

3 Save or discard the changes:

Then…If you want to…

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the opening to its original
shape

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  . The opening uses

save the changes to the current
profile

the edited profile to define its geo-
metry. Any other objects or styles
that use this profile are also up-
dated with the edited geometry.

select the profile, and click Edit In

Place tab ➤ Edits panel ➤ Save As

save the changes to a new profile

 . Enter a name for the new
profile, and click OK. The opening
uses the new profile to define its
geometry. Other styles or objects
that use the original profile are not
affected.
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Creating an Opening Tool
Use this procedure to create an opening tool and add it to a tool palette. You
may want to create your own opening tools if you are placing multiple
openings that have the same properties.

For example, you are creating a restaurant floor plan that contains openings
of various sizes. To work efficiently, you can create an opening tool for each
size. You can then select the appropriate tool to place openings in the floor
plan.

1 Open the tool palette where you want to create a tool.

2 Create the tool:

Then…If you want to…

select the opening, and drag it to the
tool palette.

create a tool from an opening
in the drawing

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current
palette

open the other tool palette, right-click
the tool, and click Copy. Reopen the

copy a tool from another
palette

palette where you want to add the tool,
right-click, and click Paste.

open the tool catalog in the Content
Browser, and locate the tool you want

copy a tool from a tool catalog

to copy. Position the cursor over the i-
drop handle, and drag the tool to the
tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

This description is used as the tooltip on the tool palette, and to
describe the tool if it is stored in a tool catalog.

6 Expand Basic, and expand General.

7 Enter a description of the opening that you can create using this
opening tool.

2072 | Chapter 27   Openings



8 If you do not want to use the default layer key for openings, select
a layer key.

9 If you want to override the default layer name for openings, select
a layer override.

10 Select a shape for the opening.

To specify a custom shape, select Custom for Shape, and select
the profile that provides the geometry of the shape for Profile.

11 Expand Dimensions.

12 Enter values for Width, Height, and Rise.

Rise is available only for arch, gothic, peak pentagon, and
trapezoid shapes.

13 Expand Location.

14 If you are placing the opening in a wall, specify the opening
position:

Then…If you want to…

select Offset/Center for Position along
wall, and enter a value for Automatic
offset.

position the edge of the opening
at a specific distance from the
end of a wall segment

select Offset/Center for Position along
wall, and specify a point near the
center of the wall segment.

center the opening on a wall
segment

select Unconstrained for Position
along wall.

position the opening anywhere
along the wall

15 Specify whether you want the opening to be aligned vertically by
sill height or by head height:

Then…If you want to…

select Sill for Vertical alignment, and
enter a value for Sill height.

align the opening by sill height

select Head for Vertical alignment, and
enter a value for Head height.

align the opening by head
height

16 Click OK.
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Editing Openings
After you create an opening, you can change the height, width, and rise. You
can also change the endcap conditions applied to the opening. You can move
the opening within the wall.

AutoCAD Architecture offers several methods for editing openings:

■ Edit openings directly using grips for dimensions and other physical
characteristics.

■ For grip edit operations where you are changing a dimension or an angle,
the Dynamic Input feature lets you enter a precise value instead of moving
a grip. When this feature is active (click DYN on the application status
bar), selecting a grip displays a text box in which you can enter the desired
value for the associated dimension or angle. For more information, see
“Use Dynamic Input” in AutoCAD Help.

■ Change settings on the Design tab of the Properties palette. You can also
use the Display tab of the Properties palette to change the display property
settings for a selected object display component in the current display
representation. For more information, see Using the Properties Palette to
Change Display Properties on page 793.

■ Select editing commands from the Opening context tab for a selected
opening.

Using Grips to Edit Openings
You can use the following grips to edit openings:
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Opening dimension grips

AnimationDescriptionGrip

Lets you change the width of an open-
ing (Width)

Lets you change the Height of an
opening. You can choose if you want /  (Sill

Height/Head
Height)

to change the sill height or the head
height.

Lets you move an opening within a wall
 (Location) ■ Drag the cursor to move the open-

ing along the length of the wall

■ Press CTRL and drag to move the
opening within the width of the
wall

■ Press CTRL twice and drag to move
the opening vertically within the
wall

Rise
Rise applies to Peak Pentagon, Arch,
and Gothic opening shapes.
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Changing the Shape and Dimensions of an Opening
Use this procedure to change the shape and size of an opening.

1 Double-click the opening you want to change.

2 On the Properties palette, click the Design tab, expand Basic, and
expand General.

3 Select a shape.

To specify a custom shape, select Custom for Shape, and select
the profile that provides the geometry of the shape for Profile.

4 Expand Dimensions.

5 Change the width, height, or rise for the opening.

Flipping an Opening along the X or Y Axis
Use this procedure to reorient an opening along its X or Y axis.

TIP You can also flip an opening along its X axis using the Flip grip that is displayed
when you select an opening.

1 To flip an opening along the X axis, select the openings you want
to change, right-click, and click Wall Anchor ➤ Flip X.

Opening in original position, and flipped along its X axis

2 To flip an opening along the Y axis, select the openings, right-click,
and click Wall Anchor ➤ Flip Y.
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Opening in original position, and flipped along its Y axis

Changing Endcap Style for an Opening
Use this procedure to change the opening endcap style used at each side of
an opening. An endcap is a user-definable condition for the edges of an
opening. For more information about opening endcap styles, see Working
with Wall Endcaps and Opening Endcaps on page 1373.

1 Select the opening you want to change.

2 Click Opening tab ➤ Endcap panel ➤ Opening Endcap: drop-down
menu.

3 Select an opening endcap style.

Alternatively, you can change endcap styles on the Design tab of
the Properties palette.

Applying Tool Properties to an Existing Opening
Use this procedure to apply the properties of an opening tool to one or more
openings.

1 Open the tool palette that you want to use.

If necessary, scroll to display the desired tool.

2 Right-click an opening tool, and click Apply Tool Properties to
Opening.

3 Select the openings, and press ENTER.
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4 Edit the properties of the openings in the Properties palette, if
necessary.

Repositioning an Opening
Use this procedure to change the location of an opening along the wall by
offsetting the opening from a reference location.

This feature is useful when you want to position an opening at a specified
distance from another object. For example, you may want to specify an exact
distance between a series of openings along a wall.
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Repositioning an opening by offsetting points
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1 Select the opening you want to move, and click Opening

tab ➤ Anchor panel ➤ Reposition Along Wall  .

A marker indicates the current location within the opening: left
jamb, center of opening, or right jamb.

2 Specify how to measure the offset:

Then…If you want to…

select a point near the center of the
opening.

measure the offset from the center
of the opening

select a point on the jamb of the
opening from which you want to
measure.

measure the offset from the left or
right jamb

Selecting the center of the opening for measuring the offset

3 Select a point to measure to (the reference point).

You can select a point along the wall.

Specifying a reference point

4 Specify the distance between the points you selected:

Then…If you want to…

enter 0 (zero).move the opening to the reference
point

enter a value for the offset distance.move the opening a specified dis-
tance from the reference point
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Then…If you want to…

specify the two points measuring
the distance.

specify the distance as a measure-
ment between two points, such as
the distance between the centers
of two openings that are correctly
positioned

Opening repositioned along the wall

Using Anchors to Change the Position and Orientation of an
Opening

When an opening is anchored to a wall, you can use the anchor to change
position and orientation of the opening in relation to the wall.

Using Anchors to Change the Horizontal Position of an Opening
Use this procedure to change the horizontal position of openings along a wall
to which the openings are anchored.

You can also change the horizontal position of the opening using the Location
grip. For more information, see Using Grips to Edit Openings on page 2074.
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Positioning an opening horizontally

1 Select the openings you want to change, and click Opening

tab ➤ Anchor panel ➤ Settings  .

Alternatively, you can access anchor settings on the Properties
palette.

2 Select the reference point for the anchor along the X axis:

Then…If you want to…

under Position Along (X), select
Start of wall for From.

use the start of the wall as the refer-
ence point

under Position Along (X), select
Midpoint of wall for From.

use the midpoint of the wall as the
reference point

under Position Along (X), select End
of wall for From.

use the end of the wall as the refer-
ence point

3 Enter the distance from the reference point at which to place the
openings.

Use a negative value to measure from endpoint to start point.
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4 Select the position of the openings to measure to:

Then…If you want to measure…

select Start edge of object for To.to the start edge of the opening

select Center of object for To.to the center of the opening

select End edge of object for To.to the end edge of the opening

5 Click OK.

Using Anchors to Change the Vertical Position of an Opening
Use this procedure to change the vertical position of openings in a wall to
which the openings are anchored.

You can also change the vertical position of the opening using the Location
grip. For more information, see Using Grips to Edit Openings on page 2074.

Changing the vertical position of an opening

1 Select the openings you want to change, and click Opening

tab ➤ Anchor panel ➤ Settings  .
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Alternatively, you can access anchor settings on the Properties
palette.

2 Select the reference point for the anchor along the Z axis:

Then…If you want to…

under Position Vertical (Z), select
Bottom of wall height for From.

use the bottom of the wall height
as the reference point

under Position Vertical (Z), select
Center of wall height for From.

use the center of the wall height as
the reference point

under Position Vertical (Z), select
Top of wall height for From.

use the top of the wall height as the
reference point

3 Enter the distance from the reference point at which to place the
openings.

Use a negative value to measure from endpoint to start point.

4 Select the position of the openings to measure to:

Then…If you want to…

select Sill of object for To.measure to the bottom of the
openings in wall

select Center of object for To.measure to the center of the open-
ings in walls

select Head of object for To.measure to the top of the openings
in walls

5 Click OK.

Changing the Position of an Opening Within a Wall
Use this procedure to change the horizontal position of openings within a
wall to which the openings are anchored.

You can also change the position of the opening within a wall using the
Location grip. For more information, see Using Grips to Edit Openings on
page 2074.
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Changing the position of an opening within a wall

1 Select the openings you want to change, and click Opening

tab ➤ Anchor panel ➤ Settings  .

Alternatively, you can access anchor settings on the Properties
palette.

2 Select the reference point for the anchor along the Y axis:

Then…If you want to…

under Position Within (Y), select Left
edge of wall width for From.

use the left edge of the wall as your
reference point

under Position Within (Y), select
Center of wall width for From.

use the center of the wall as your
reference point

under Position Within (Y), select
Right edge of wall width for From.

use the right edge of the wall as
your reference point

3 Enter the distance from the reference point at which to place the
openings.

Use a negative value to measure from endpoint to start point.

4 Select the position of the openings to measure to:

Then…If you want to…

select Front of object for To.measure to the front of the opening

select Center of object for To.measure to the center of the open-
ing

select Back of object for To.measure to the back of the opening
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5 Click OK.

Changing the Orientation of an Opening to a Wall
Use this procedure to change the vertical orientation of an opening in a wall
to which the openings are anchored.

1 Select the opening you want to change, and click Opening

tab ➤ Anchor panel ➤ Settings  .

Alternatively, you can access anchor settings on the Properties
palette.

2 Enter the X and Z rotation angles of the openings.

3 Indicate if you want to reverse the flip direction of the opening
in the X, Y or Z axes:

Then…If you want to…

select Flip X.reverse the direction of the opening

select Flip Z.reverse the top and bottom of the
opening

select Flip Y.reverse the position of the opening
in the side of the wall

4 Click OK.

Changing the Location of an Opening
Use this procedure to relocate a freestanding opening by changing the
coordinate values of its insertion point. The opening also has an orientation
with respect to the world coordinate system (WCS) or the current user
coordinate system (UCS). For example, if the top and bottom of the opening
are parallel to the XY plane, its normal is parallel to the Z axis. You can change
the orientation of the opening by aligning its normal with another axis. You
can also rotate the opening on its plane by changing the rotation angle.

1 Double-click the opening, and on the Properties palette, expand
Basic, and expand Location.

2 Click Additional information.
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3 Specify a new location, orientation, or rotation angle:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the opening

make the normal of the opening
parallel to the Z axis: under Normal,

locate the opening on the XY plane

enter 1 for Z, and enter 0 for X
and Y.

make the normal of the opening
parallel to the X axis: under Normal,

locate the opening on the YZ plane

enter 1 for X and enter 0 for Y
and Z.

make the normal of the opening
parallel to the Y axis: under Normal,

locate the opening on the XZ plane

enter 1 for Y, and enter 0 for X
and Z.

enter a new value for Rotation
Angle.

change the rotation of the opening

4 Click OK.

Center an Opening Using Modify Tools
Use this procedure to center an opening on a specified axis or between any
two specified points.

1 Select the opening to center.

2 Click Opening tab ➤ Modify panel ➤ Center  .

3 Select an existing axis line on which to center the opening, or
press ENTER and then specify two points between which to center
the opening.

Create an Opening Array Using Modify Tools
Use this procedure to create an array of identical openings along a wall.
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1 Select the opening to array.

2 Click Opening tab ➤ Modify panel ➤ Array  .

3 Select an edge from which to start the array that is perpendicular
to the array axis, then drag along your wall in the direction of
the array. Do one of the following:

■ Offset: start the opening array a specified offset distance from
the edge.

■ Clear Distance: specify a clear distance between each arrayed
opening.

■ Pick Array Distance: specify a distance between arrayed
openings.

■ Enter Count: specify the number of openings to appear in the
array.

Alternatively, you can press ENTER and then specify two points
between which to array the opening.

Repositioning an Opening with Modify Tools
Use this procedure to reposition an opening.

1 Select the opening to reposition.

2 Click Opening tab ➤ Modify panel ➤ Reposition From  .

3 Select an existing wall edge from which to reposition the opening,
or specify two points to define a reference edge.

Spacing Openings Evenly with Modify Tools
Use this procedure to space openings evenly along a wall.

1 Select the opening to space evenly.

2 Click Opening tab ➤ Modify panel ➤ Space Evenly  .

3 Select an edge as the axis along which to space all the openings
evenly, and specify a start point and an endpoint along the edge.

Alternatively, press ENTER and specify two points between which
the openings will be spaced evenly from each other.
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Changing the Cut Plane Setting for an Opening
Use this procedure to specify whether a selected opening will use the cut plane
of the containing object when anchored to that object in the current display
representation. Note that cut plane display properties apply only to display
representations, such as Plan, that are used in the Top view (plan view) of a
drawing.

1 Double-click the opening.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display controlled by, select This
object.

NOTE To apply your changes to all openings in the drawing, select
Drawing default setting.

4 For Display representation, verify that the desired display
representation is selected.

5 If necessary, expand Object Display Properties ➤ Cut Plane.

6 For Use cut plane of containing object when anchored, select Yes
or No.

Specifying the Display of Sills for an Opening
Use this procedure to change the sill dimensions for an opening in the Sill
Plan display representation.

1 Double-click the opening.

2 Click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all openings in the drawing, select
Drawing default setting.

5 For Display representation, select Sill Plan.

6 If necessary, expand Object Display Properties ➤ Advanced, and

click  Sill dimensions.
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7 On the Sill Dimensions worksheet, enter the sill extension and
depth dimensions.

Sill components A and B are for the outside of the opening. Sill
components C and D are for the interior side.

8 Click OK.

9 In the Display component drop-down list, click the light bulb
icons next to individual sill components to turn their visibility
on or off as desired.

You can also access and modify sill dimensions and visibility settings through
the opening’s context menu, as follows:

1 Select the opening you want to change, right-click, and click Edit
Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 Click the Other tab.

Opening sill dimensions

5 Under Sill Dimensions, enter the sill extension and depth
dimensions.

6 On the Layer/Color/Linetype tab, under Visible, click the light
bulb icons to turn on visibility for individual sill display
components as necessary.

7 Click OK twice.
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Specifying the Display of Custom Block Components of an
Opening

Use this procedure to specify the display of custom block components for an
individual opening. If you are going to use custom graphics for a new
component, draw the component and save it as a block before you start this
procedure.

1 Double-click the opening.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all openings in the drawing, select
Drawing default setting.

5 For Display representation, verify that the desired display
representation is selected.

6 If necessary, expand Object Display Properties ➤ Advanced, and

for Custom block display, click  (The number in parentheses
indicates the number of blocks currently attached to the opening.)

7 If you want to turn off the display of custom blocks for this
opening without removing them, select Disable Custom Blocks.

8 Specify whether to add, edit, or remove a block component:

Then…If you want to…

click Add, and then click Select
Block, select the block, and click
OK.

add a new block component

select the component to edit, and
click Edit.

edit an existing block component

select the block, click Remove, and
click OK.

remove an existing block compon-
ent
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9 When adding or editing a block component, specify whether you
want to scale to fit the block component to the object by width,
depth, and height, or to lock the XY ratio:

Then…If you want to…

select Width.set the block scale to the width of
the object

select Depth.set the block scale to the depth of
the object

select Height.set the block scale to the height of
the object

select Lock to XY Ratio.scale the whole block equally, so
that one direction is scaled to fit
another of the scale criteria

clear all options under Scale to Fit.scale the block to its original size

10 Specify whether to mirror the block in the X,Y, or Z direction:

Then…If you want to create a mirror
of the block…

select Mirror X.in the X direction

select Mirror Y.in the Y direction

select Mirror Z.in the Z direction

11 Specify the X, Y, and Z locations of the insertion point.

12 Specify an insertion offset of the block in the X, Y, and Z directions.

13 Click OK twice.

Specifying the Display of Fill Type for an Opening
Use this procedure to specify the type of fill to display for an opening in display
representations used in the Top view (plan view) of a drawing.

1 Double-click the opening.

2 Click the Display tab.
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3 Under the General category, for Display component, verify that
*NONE* is selected.

4 Under the General category, for Display controlled by, select This
object.

NOTE To apply your changes to all openings in the drawing, select
Drawing default setting.

5 For Display representation, verify that the desired display
representation is selected.

6 If necessary, expand Object Display Properties ➤ Advanced, and

click  Fill type.

7 On the Fill type worksheet, select the desired fill type.

Opening fill types

8 Click OK.

You can also access and modify frame display settings through the opening’s
context menu, as follows:

1 Select the opening you want to change, right-click, and click Edit
Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 Click the Fill type tab.

5 Under Hatch Type, select the desired option.
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6 Click OK twice.

Attaching Hyperlinks, Notes, and Files to an Opening
Use this procedure to enter notes and attach hyperlinks or reference files to
an opening. You can also edit reference files attached to the style.

1 Double-click the opening to which you want to attach
information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, specify the
link, and click OK.

For more information, see “Add Hyperlinks to a Drawing” in
AutoCAD help.

4 To add a note, click the setting for Notes, enter the note, and click
OK.

5 Click the setting for Reference Docs.

6 Attach, edit, or detach a reference file:

Then…If you want to…

click  , select a file, and click
OPEN.

attach a reference file

select the description of the file, and
edit the description.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

7 Click OK.

Changing the Display Properties of Openings
You use the display properties of openings to control their appearance in a
drawing. In addition, you can create custom components for openings by
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adding custom blocks to any display representation where you want the
components to appear.

Specifying the Display Properties of an Opening
Use this procedure to change the properties of the following display
components of an individual opening:

■ Visibility (display component is on or off)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

NOTE Openings do not have material assignments.

1 Select the opening you want to change, right-click, and click Edit
Object Display.

NOTE You can also use the Display tab of the Properties palette to
change the display property settings for a selected object display
component in the current display representation. For more
information, see Using the Properties Palette to Change Display
Properties on page 793.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 Click the Layer/Color/Linetype tab.

5 Select the component to change, and select a different setting for
the property.

6 Click OK twice.
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Specifying the Hatching of an Opening
Use this procedure to specify the hatching of the components of an opening.
Hatching is displayed only in display representations used in the Top view
(plan view) of a drawing.

1 Select the opening you want to change, right-click, and click Edit
Object Display.

NOTE You can also use the Display tab of the Properties palette to
change the display property settings for a selected object display
component in the current display representation. For more
information, see Using the Properties Palette to Change Display
Properties on page 793.

2 Click the Display Properties tab.

3 Select the display representation in which to display the changes.

4 Specify whether changes apply to all openings, or only to the
selected opening:

Then…If you want to…

verify that Object Override is

cleared, and click  .

apply the hatching to all openings
in the drawing

select Object Override. If it is

already selected, click  .

apply the hatching only to the selec-
ted opening

The display representation in bold is the current one.

5 Click the Layer/Color/Linetype tab.

6 Verify that the Hatch display component is turned on.

7 Click the Hatching tab.

8 Click the setting for Pattern.

9 Select the hatching:

Then…If you want to…

select Predefined for Type, and then
select a pattern.

select a hatching pattern that is
available in the software

select Custom for Type, and then
enter the name of the custom pat-

select a custom pattern
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Then…If you want to…

tern. If necessary, click Browse, and
navigate to the folder where the
custom pattern file is located.

select User-Defined for Type, and
clear Double Hatch.

select single hatching

select User-Defined for Type, and
select Double Hatch.

select double hatching

select Solid Fill for Type.select solid fill

10 Click OK.

11 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

12 Click Angle, and enter the angle for the selected pattern.

13 Click Orientation, and specify how the hatching is oriented:

Then…If you want to…

select Object.orient the hatching to the object
regardless of the object rotation

select Global.orient the hatching to the World
Coordinate System

14 Click the Fill type tab.

15 Select a graphic representation to use for hatching the opening.

Specifying hatching graphics for openings

16 Click OK twice.
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Using Custom Blocks to Create Opening Components
You can add custom blocks for components, such as hardware, to the display
components or to replace the default display components. You can have a
different custom block for each display representation.

You can specify several rules for positioning and scaling the new component.
Each custom block also appears in the display properties component list so
that you can control its layer, color, and linetype.

If you create a custom block from mass elements, you can use the material
assignments of the mass elements to determine the display properties of the
custom block.

Be sure to set the properties of the objects used to create your custom blocks
to ByBlock. Otherwise, you cannot control these objects through the display
properties. For more information, see “Control the Color and Linetype
Properties in Blocks” in AutoCAD help

Adding Components to an Opening
Use this procedure to add or edit custom block components in the display
representation of openings.

1 Create a block for the component to add to the opening.

Create the block in the same plane as the opening.

2 Select the opening you want to change, right-click, and click Edit
Object Display.

3 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

4 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

5 Click the Other tab.

6 Specify whether to add or edit a block component:

Then…If you want to…

click Add.add a new block component

select the component to edit, and
click Edit. Proceed to step 10.

edit an existing block component
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7 Click Select Block.

8 Select the block to use, and click OK.

9 Specify whether you want to scale to fit the block component to
the object by width, depth, and height, or to lock the XY ratio:

Then…If you want to…

select Width.set the block scale to the width of
the object

select Depth.set the block scale to the depth of
the object

select Height.set the block scale to the height of
the object

select Lock XY Ratio.scale the whole block equally, so
that one direction is scaled to fit
another of the scale criteria

clear all options under Scale to Fit.scale the block to its original size

10 Specify whether to mirror the block in the X,Y, or Z direction:

Then…If you want to…

select Mirror X.create a mirror of the block in the
X direction

select Mirror Y.create a mirror of the block in the
Y direction

select Mirror Z.create a mirror of the block in the
Z direction

11 Specify the X, Y, and Z location of the insertion point.

12 Specify an insertion offset of the block in the X, Y, and Z directions.

13 Click OK three times.

Turning Off Custom Components in an Opening
Use this procedure to turn off custom blocks in an opening.
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You can turn off the display of component blocks without removing them
from the opening.

1 Select the opening you want to change, right-click, and click Edit
Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 Click the Other tab.

5 Select Disable Custom Blocks.

6 Click OK twice.

Removing Custom Components from an Opening
Use this procedure to remove components from an opening.

Removing custom blocks deletes them from the opening.

1 Select the opening you want to change, right-click, and click Edit
Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 Click the Other tab.

5 Select the component to remove, and click Remove.

6 Click OK twice.
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Stairs

Stairs are AEC objects that use flights of treads and risers to accommodate vertical circulation.
Stairs also interact with railing objects. You can control the style of the stair, the shape of the
landing, the type of treads, and the height and width of the stair run.

Stairs
Stairs are AEC objects that use flights of treads and risers to accommodate vertical
circulation. Stairs also interact with railing objects. You can control the style of
the stair, the shape of the landing, the type of treads, and the height and width
of the stair run.

Stair Shapes

While strictly rectangular stairs are predominant in modern buildings, in some
cases the edges of a flight are not parallel, or they might be curved. Landings
can also be non rectangular. Stairs allow the use of nearly arbitrary profiles for
the edges of flights and landings. In addition, railings and stringers can be
anchored to stairs and can follow the edges of flights and landings. You can
create custom stairs from linework or profiles to model different conditions as
well.

Landings and Turns

Stairs are created at a specified overall height that requires a total length based
on the tread length. Within that length, you can place landings or turns. When
you begin to create a stairway, a rectangular box is displayed that represents
the width and length of the stair as if it were a straight stairway. As you select
consecutive points, depending upon the shape of the stair, landings and turns
are created.

28
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Materials in Stairs

In AutoCAD Architecture, you can assign materials to a stair. These materials
are displayed in the Realistic visual style, or when rendered. Materials have
specific settings for the physical components of a stair, such as risers, nosing,
and treads.

Viewing a stair in different visual styles

AutoCAD Architecture provides a number of predefined materials for common
design purposes, which contain settings for stair components. You can use
predefined materials, or modify them for your designs. You can also create
your own materials. Object styles provided with the software have appropriate
materials already assigned to them. For more information, see Stair Materials
and Display Components on page 2288.

Solution Tips for Stairs
When AutoCAD Architecture detects a problem with the way a stair object is
drawn, it displays a solution tip icon on the stair in the drawing.
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Stair with solution tip icon

Move the cursor over the icon to display a message that describes the problem
and provides one or more possible solutions. Where more detailed instructions
are required, you can press F1 to access the relevant topic in Help.

Stair with solution tip

A number of the solution tips for stair objects identify an invalid configuration
for a particular type of stair. The F1 links for these tips bring you to this topic
and the following table, which shows and describes the different types of stairs
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you can draw in AutoCAD Architecture. Follow the associated links to specific
instructions for drawing each type of stair.

How to DrawTurn
Type

Stair
Shape

Stair 3D
View

Stair 2D
View

Specify flight start and endpoints. For
more information, see Creating a

NoneStraight

Straight Stair with User-Specified Set-
tings on page 2108.

Specify flight start and endpoints. For
more information, see Creating a U-

1/2
land-
ing

U-
shaped

Shaped Stair with User-Specified Set-
tings on page 2123.

Specify flight start and endpoints. For
more information, see Creating a U-

1/2
turn

U-
shaped

Shaped Stair with User-Specified Set-
tings on page 2123.

Specify first flight start and endpoints;
specify next flight start and endpoints.

1/2
land-
ing

Multi-
landing

For more information, see Creating a
Multi-Landing Stair with User-Specified
Settings on page 2113.

Specify first flight start and endpoints;
specify next flight start and endpoints.

1/2
land-
ing

Multi-
landing
(straight) For more information, see Creating a

Multi-Landing Stair with User-Specified
Settings on page 2113.
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How to DrawTurn
Type

Stair
Shape

Stair 3D
View

Stair 2D
View

Specify first flight start and endpoints;
specify next flight start and endpoints

1/2
turn

Multi-
landing

- draw in one direction only. For more
information, see Creating a Multi-
Landing Stair with User-Specified Set-
tings on page 2113.

Specify first flight start and endpoints;
specify next flight endpoint; specify

1/4
land-
ing

Multi-
landing

next flight endpoint. For more inform-
ation, see Creating a Multi-Landing
Stair with User-Specified Settings on
page 2113.

Specify first flight start and endpoints;
specify next flight endpoint; specify

1/4
turn

Multi-
landing

next flight endpoint. For more inform-
ation, see Creating a Multi-Landing
Stair with User-Specified Settings on
page 2113.

Specify center of spiral stair; specify
start point. For more information, see

NoneSpiral

Creating a Spiral Stair with User-Spe-
cified Settings on page 2130.

Draw custom stair linework; select left
and right sides; select stair path; select

NoneCustom
stair

left, right, and center stringer paths;
select first tread at current level; select
remaining treads. For more informa-
tion, see Creating a Custom Stair from
Linework on page 2137.

(from
line-
work)
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How to DrawTurn
Type

Stair
Shape

Stair 3D
View

Stair 2D
View

Draw custom tread profile; array tread
profile; select stair path; select left,

NoneCustom
stair

right, and center stringer paths; select
first tread profile at current level; select
remaining tread profiles. For more in-
formation, see Creating a Custom Stair
from Tread Profiles on page 2141.

(from
tread
profile)

Draw multi-landing stair; draw straight
stair; select multi-landing stair; anchor

NoneAnchor
Stair to
Landing straight stair to multi-landing stair

landing. For more information, see
Anchoring a Stair to a Landing on
page 2207.

Specifying AEC Options for Stairs
Use this procedure to specify parameters and options for stairs that are not
specified in the stair styles or display properties. These options are on the AEC
Object Settings tab of the Options dialog box:

■ Presentation format

■ Node Osnaps

■ Flight height measurement

■ Calculator limits

1 Click  ➤ Options.

2 Click the AEC Object Settings tab.

3 Specify the stair defaults:

Then…If you want to…

select Presentation Format (No Cut
Lines or Path).

display the stair with no cut lines or
path
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Then…If you want to…

select Flight & Landing Corners for
Node Osnap.

use Node Osnap to select the
corners of the stairs and landings

select Vertical Alignment for Node
Osnap.

specify the stair height distance
above the start of the stair and be-
low the end of the stair as the posi-
tion for the Node Osnap

select Finished Floor to Floor for
Measure Stair Height.

include top and bottom offsets in
the stair height measurement

select Rough Floor to Floor for
Measure Stair Height.

ignore top and bottom offsets in
the stair height measurement

select Strict for Calculator Limits.display the stair with a solution tip
icon when an edit causes it to viol-
ate the calculation limits set in the
Calculation Rules tab of the Stair
Style dialog box

select Relaxed for Calculator Limits.display the stair normally when an
edit causes it to violate the calcula-
tion limits set in the Calculation
Rules tab of the Stair Style dialog
box

NOTE The Calculator Limits setting is stored with the drawing. Some
earlier versions of the software have the Calculator limits set to Relaxed
by default. Any new drawing has it set to Strict by default.

4 Click OK.

Using Stair Tools to Create Stairs
Tools provided with AutoCAD Architecture let you quickly place stairs using
a stair tool with a specific stair style and other predefined properties. You can
use the default settings of the tool, or you can change the properties that are
not controlled by the style.
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The following catalogs provided with the software contain stair tools that you
can add to your tool palettes:

■ Stock Tool catalog

■ AutoCAD Architecture Sample Palette catalog

■ Design Tool catalog

Custom palettes created by your CAD manager or other users may also contain
stair tools with stair styles and properties that are customized for your projects
or office standards.

Creating a Stair
Use this procedure to add a new stair that has the properties specified in the
stair tool that you select. To specify settings when you add a stair, see Creating
a Straight Stair with User-Specified Settings on page 2108.

1 Open the tool palette that you want to use, and select a stair tool.

If necessary, scroll to display the tool that you want to use.

NOTE Alternatively, you can create stairs by clicking Home

tab ➤ Build panel ➤ Stair drop-down ➤ Stair  .

2 Specify the insertion point of the stair.

You can move or hide the Properties palette to expose more of
the drawing area.

3 Specify the direction point of the stair.

The stair is created at the length necessary to accommodate the
values specified.

4 Continue adding stairs, and press ENTER.

Creating a Straight Stair with User-Specified Settings
Use this procedure to add a straight stair with settings that you specify.

2108 | Chapter 28    Stairs



Creating a straight stair

TIP To ensure that the Properties palette is displayed before you select a tool, click
Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties.

1 Open the tool palette that you want to use, and select a stair tool.

If necessary, scroll to display the tool that you want to use.

NOTE Alternatively, click Home tab ➤ Build panel ➤ Stair

drop-down ➤ Stair  .

2 On the Properties palette, click the Design tab, expand Basic, and
expand General.

3 Select a style.

4 For Shape, select Straight.

5 Specify the vertical orientation of the stair:

Then…If you want to…

select Up for Vertical Orientation.draw the stair from this floor to the
floor above
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Then…If you want to…

select Down for Vertical Orienta-
tion.

draw the stair from this floor to the
floor below

6 Expand Dimensions.

7 Specify stair width, height, and justification:

Then…If you want to…

enter a value for Width.specify the width of the stair

enter a value for Height.specify the height of the stair

enter a value for Justify. The Justify
value controls the insertion point

specify the justification of the stair

when you place the stair (left, cen-
ter, or right) at the beginning of the
stair run.

8 Specify the stair termination:

Then…If you want to…

select Riser for Terminate with.end the stair run with a riser

NOTE Stairs that end with a
riser will have an overall height
that is one tread thickness less
than the floor-to-floor height
specified.
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Then…If you want to…

select Tread for Terminate with.end the stair run with a tread

select Landing for Terminate with.end the stair run with a landing

9 Click  next to Calculation rules, and

then…if you want to…

enter values for Straight Length,
and Riser Count, then click OK.

specify the overall linear length of
the stair

■ When Straight Length is set to

 (automatic), the value is
calculated based on the tread
size and riser count.

■ When Straight Length is 
(user-defined), the stair length
is equal to the dimension
entered, and the other three
values are adjusted within the
code limits.

■ When Riser Count is  (user-
defined), the tread depth is in-
creased or decreased to accom-
modate the stair.
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then…if you want to…

enter a value for Riser Count, then
click OK.

specify the total number of stair
risers

■ When Riser Count is set to 
(automatic), the number of
risers is based on the overall
length and overall height of the
stair and the code limits spe-
cified on the Design Rules tab.
The Straight Length value of
the stair is adjusted automatic-
ally.

■ When Riser Count is set to 
(user-defined), you can specify
a value that is used to calculate
the tread depth and riser
height. If these values fall out-
side the stair limits, an error
message is displayed.

set all fields to  (automatic),
click the icon to Riser to change it

specify the height of each riser in
the stair flight

to  (user-defined) and enter a
value for Riser. Click OK.

set all fields to  (automatic),
click the icon next to Tread to

specify the tread depth for each
tread in the stair flight

change it to  (user-defined),
and enter a tread depth value. You
can also specify the Riser Count
when you set the tread depth.

NOTE If a value is set to user-defined on the Calculation rules
worksheet, it can be modified directly in the Properties palette.
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NOTE If  is displayed next to a field in the Calculation Rules dialog
box, that field can’t be changed until another field is changed from

 (user-defined) to  (automatic).

10 In the drawing area, specify the insertion point of the stair.

You can move or hide the Properties palette to expose more of
the drawing area.

11 Specify the endpoint of the stair.

12 Continue adding stairs, or press ENTER.

Creating a Multi-Landing Stair with User-Specified
Settings

Use this procedure to create a multi-landing stair. You can use multi-landing
stair shapes to define both straight and angled stair runs. You can insert
quarter-landings, half-landings, and turns.

This type of stair is constrained by the design rules on the stair and the
floor-to-floor height. For more information about stair design rules, see
Specifying the Design Rules of a Stair Style on page 2277.

If you are drawing the risers or flights of a stair, lines for each tread are shown.
If you are drawing a flat landing, no tread lines are shown. If you are drawing
a turn-type landing, angled tread lines are shown through the turn. These
temporary lines do not necessarily represent the actual locations of tread lines
in the final stair. In addition, the number of risers currently added to the stair
is displayed (to the left of the stair), as a fraction of the total number of risers
required for the stair; for example, “10/18.”

NOTE To create a straight stair with user-specified landings, use the multi-landing
shape with half-landings. Select all the points in a straight line to define the flight
start points and flight endpoints.
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Creating a multi-landing stair with 1/4 landings

TIP To ensure that the Properties palette is displayed before you select a tool, click
Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties.

1 Open the tool palette that you want to use, and select a stair tool.

If necessary, scroll to display the tool that you want to use.

NOTE Alternatively, click Home tab ➤ Build panel ➤ Stair

drop-down ➤ Stair  .

2 On the Properties palette, click the Design tab, expand Basic, and
expand General.

3 Select a style.
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4 For Shape, select Multi-landing.

5 Specify the turn type:

Then…If you want to…

select 1/2 landing for Turn type.create a flat landing with a user-
defined length where the stair run
turns

select 1/2 turn for Turn type.

NOTE These stairs must have
at least three segments and
each corner must turn in the
same direction.

create stairs with a user-defined
length where the stair run turns
with treads through the turn

select 1/4 landing for Turn type.

NOTE These stairs typically
have two or more flights joined
by square landings.

create a flat landing where the stair
turns, with the length of the land-
ing equal to the width of the stair

select 1/4 turn for Turn type.

NOTE These stairs may have
two or more segments, and
corners may turn in either direc-
tion.

create stairs having treads along the
entire length, with one or more
turns in any direction

6 Specify the vertical orientation of the stair:

Then…If you want to…

select Up for Vertical Orientation.draw the stair from this floor to the
floor above

select Down for Vertical Orienta-
tion.

draw the stair from this floor to the
floor below

7 Expand Dimensions.

Creating a Multi-Landing Stair with User-Specified Settings | 2115



8 Specify stair width, height, and justification:

Then…If you want to…

enter a value for Width.specify the width of the stair

enter a value for Height.specify the height of the stair

enter a value for Justify. The Justify
value controls the insertion point

specify the justification of the stair

when you place the stair (left, cen-
ter, or right) at the beginning of the
stair run.

9 Specify the stair termination:

then…if you want to…

select Riser for Terminate with.end the stair run with a riser

NOTE Stairs that end with a
riser will have an overall height
that is one tread thickness less
than the floor-to-floor height
specified.

select Tread for Terminate with.end the stair run with a tread
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then…if you want to…

select Landing for Terminate with.end the stair run with a landing

10 Click  next to Calculation rules, and

then…if you want to…

enter values for Straight Length and
Riser Count, then click OK.

specify the overall linear length of
the stair

■ When Straight Length is set to

 (automatic), the value is
calculated based on the tread
size and riser count.

■ When Straight Length is set to

 (user-defined), the stair
length is equal to the dimen-
sion entered, and the other
three values are adjusted within
the code limits.

■ When Riser Count is set to 
(user-defined), the tread depth
is increased or decreased to ac-
commodate the stair.

enter a value for Riser Count, then
click OK.

specify the total number of stair
risers

■ When Riser Count is set to 
(automatic), the number of
risers is based on the overall
length and overall height of the
stair and the code limits spe-
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then…if you want to…

cified on the Design Rules tab.
The Straight Length value of
the stair is adjusted automatic-
ally.

■ When Riser Count is set to 
(user-defined), you can specify
a value that is used to calculate
the tread depth and riser
height. If these values fall out-
side the stair limits, an error
message is displayed.

set all fields to  (automatic),
click the icon for Riser to change it

specify the height of each riser in
the stair flight

to  (user-defined), and enter a
value for Riser. Click OK.

set all fields to  (automatic),
click the icon next to Tread to

specify the tread depth for each
tread in the stair flight

change it to  (user-defined),
and enter a value for Tread. You can
also specify the Riser count when
you set the tread depth. Click OK.

NOTE If a value is set to user-defined on the Calculation rules
worksheet, it can be modified directly in the Properties palette.

NOTE If  is displayed next to a field in the Calculation Rules dialog
box, that field can’t be changed until another field is changed from

 (user-defined) to  (automatic).

11 Expand Advanced.
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12 Specify the Floor Settings:

Then…If you want to…

enter a value for Top offset.change the thickness of the floor
finish material at the top of the stair

enter a value for Top depth.change the depth of the structure
at the top of the stair

enter a value for Bottom offset.change the thickness of the floor
finish material at the bottom of the
stair

enter a value for Bottom depth.change the depth of the structure
at the bottom of the stair

13 Set the minimum height or number of risers in a stair flight, or
specify *NONE*.

14 Set the maximum height or number of risers in a stair flight, or
specify *NONE*.

15 In the drawing area, specify the insertion point of the stair.

You can move or hide the Properties palette to expose more of
the drawing area.

16 Specify the point of the first turn or landing for the stair.

17 Continue specifying points for the stair.

NOTE If you specified Landing for Terminate with, the last point for
the stair beyond the final riser defines the end of the landing.
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Specifying terminal landing length for multi-landing stair

18 Continue adding stairs, or press ENTER.

Creating an L-Shaped Stair with 45-Degree Tread
Use this procedure to add an L-shaped stair with a 45-degree turn in the winder.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Architectural Objects, and expand Stair Winder Styles.

3 Right-click, select New, and enter Single Point – 2 Tread as the
style name.

4 On the Settings tab, confirm that Use Riser Line is not selected.

5 Specify Single Point for Winder Type.

6 Select Adjust Winder Turn and enter 2 for Number of Treads in
Turn.

7 Click OK.

8 Open the tool palette that you want to use, and select a stair tool.

If necessary, scroll to display the tool that you want to use.

NOTE Alternatively, click Home tab ➤ Build panel ➤ Stair

drop-down ➤ Stair  .

2120 | Chapter 28    Stairs



9 On the Properties palette, click the Design tab, expand Basic, and
expand General.

10 For Shape, select Multi-landing.

11 For Turn type, select 1/4 turn.

12 For Winder Style, select Single Point – 2 Tread.

13 Expand Dimensions.

14 For Flight length, select Tread length.

NOTE If the stair style has Extend Landings to Prevent Risers and
Treads Sitting under Landings turned on, the flight will not be pivoted
exactly around the end of the stair.

15 Draw a stair with one 90-degree turn, and press ENTER.
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Creating an L-shaped stair with a 45 degree
tread

16 Select the stair, enter winderturnadjust at the command line, and
press ENTER.
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NOTE The winderturnadjust command changes the number of treads
in a turn zone for a stair using a Single Point winder style. The default
number of treads is specified in the Settings tab of the Stair Winder
Styles. You can change the amount of treads on the command line
while running the winderturnadjust command.

When you change the number of treads in the turn zone, the construction
line changes location across the stair because the tread length must remain
constant along the stair. Changing the winder treads changes the width, so
the line moves. The construction line can be edited with grips. If you move
the construction line, the winder treads are affected.

Creating a U-Shaped Stair with User-Specified Settings
Use this procedure to add a U-shaped stair with settings that you specify.
U-shaped stairs have two equal-length runs joined by a half-landing. The
justification setting controls where the points that define the stair fall within
its width.

When drawing the stair, the flights are shown with lines for each tread. Flat
landings have no tread lines, while turn-type landings show tread lines through
the entire turn. For turn-type stairs, these temporary lines do not necessarily
represent the actual locations of tread lines in the final stair.
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Creating a U-shaped stair

TIP To ensure that the Properties palette is displayed before you select a tool, click
Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties.

1 Open the tool palette that you want to use, and select a stair tool.

If necessary, scroll to display the tool that you want to use.

NOTE Alternatively, click Home tab ➤ Build panel ➤ Stair

drop-down ➤ Stair  .

2 On the Properties palette, click the Design tab, expand Basic, and
expand General.

3 Select a style.

4 For Shape, select U-shaped.

5 Specify the turn type:

Then…If you want to…

select 1/2 landing for Turn type.create a flat landing where the stair
run turns back in the opposite direc-
tion

2124 | Chapter 28    Stairs



Then…If you want to…

select 1/2 turn for Turn type.create stairs where the stair run
turns back in the opposite direction
with treads throughout the run

6 Specify the horizontal orientation of the stair:

Then…If you want to…

select Counterclockwise for Hori-
zontal Orientation.

draw the U-shaped stair so that the
right is the outer edge of the stair
and left is the inner edge

select Clockwise for Horizontal Ori-
entation.

draw the U-shaped stair so that the
left is the outer edge of the stair
and right is the inner edge

Specifying the horizontal direction for U-shaped stairs
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7 Specify the vertical orientation of the stair:

Then…If you want to…

select Up for Vertical Orientation.draw the stair from this floor to the
floor above

select Down for Vertical Orienta-
tion.

draw the stair from this floor to the
floor below

8 Expand Dimensions.

9 Specify stair width, height, and justification:

Then…If you want to…

enter a value for Width.specify the width of the stair

enter a value for Height.specify the floor-to-floor height of
the stair

enter a value for Justify. The Justify
value you select controls the inser-

specify the justification of the stair

tion point when you place the stair
(inside, center, or outside) at the
beginning of the stair run.

10 Specify the stair termination:

Then…If you want to…

select Riser for Terminate with.end the stair run with a riser

NOTE Stairs that end with a
riser will have an overall height
that is one tread thickness less
than the floor-to-floor height
specified.
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Then…If you want to…

select Tread for Terminate with.end the stair run with a tread

select Landing for Terminate with.end the stair run with a landing

11 Click  next to Calculation rules, and

then…if you want to…

enter values for Straight Length and
Riser Count, then click OK.

specify the overall linear length of
the stair

■ When Straight Length is set to

 (automatic), the value is
calculated based on the tread
size and riser count.

■ When Straight Length is set to

 (user-defined), the stair
length is equal to the dimen-
sion entered, and the other
three values are adjusted within
the code limits.

■ When Riser Count is set to 
(user-defined), the tread depth
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then…if you want to…

is increased or decreased to ac-
commodate the stair.

enter a value for Riser Count, then
click OK.

specify the total number of stair
risers

■ When Riser Count is set to 
(automatic), the number of
risers is based on the overall
length and overall height of the
stair and the code limits spe-
cified on the Design Rules tab.
The Straight Length value of
the stair is adjusted automatic-
ally.

■ When Riser Count is set to 
(user-defined), you can specify
a value that is used to calculate
the tread depth and riser
height. If these values fall out-
side the stair limits, an error
message is displayed.

set all fields to  (automatic),
click the icon for Riser to change it

specify the height of each riser in
the stair flight

to  (user-defined), and enter a
value for Riser. Click OK.

set all fields to  (automatic),
click the icon next to Tread to

specify the tread depth for each
tread in the stair flight

change it to  (user-defined),
and enter a value for Tread. You can
also specify the Riser count when
you set the tread depth. Click OK.

NOTE If a value is set to user-defined on the Calculation rules
worksheet, it can be modified directly in the Properties palette.
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NOTE If  is displayed next to a field in the Calculation Rules dialog
box, that field can’t be changed until another field is changed from

 (user-defined) to  (automatic).

12 Expand Advanced.

13 Specify the Constraints:

Then…If you want to…

select Free for Alignment.place the treads and risers with the
minimum landing extension

select Tread to tread for Alignment.align the tread of the up flight to
the tread of the down flight

select Tread to riser for Alignment.align the tread of the up flight to
the riser of the down flight

select Riser to riser for Alignment.align the riser of the up flight to the
riser of the down flight

14 Specify a value for Alignment offset.

When you select Tread to tread, Tread to riser, or Riser to riser,
you can specify an offset value. A positive offset value means that
the down-flight tread location is closer to landing than the
up-flight tread location.

Specifying tread to riser alignment offsets

15 Specify a value for the Extend alignment (Lower flight or Upper
flight).

16 Specify a value for Uneven tread to determine which flight will
be longer if the total number of treads is uneven. Select Upper
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flight to place the Uneven tread on the upper flight. Select Lower
flight to place the uneven tread on the lower flight.

17 Specify floor settings:

Then…If you want to…

enter a value for Top offset.change the thickness of the floor
finish material at the top of the stair

enter a value for Top depth.change the depth of the structure
at the top of the stair

enter a value for Bottom offset.change the thickness of the floor
finish material at the bottom of the
stair

enter a value for Bottom depth.change the depth of the structure
at the bottom of the stair

18 Set the minimum height or number of risers in a stair flight, or
specify *NONE*.

19 Set the maximum height or number of risers in a stair flight, or
specify *NONE*.

20 In the drawing area, specify the insertion point of the stair.

You can move or hide the Properties palette to expose more of
the drawing area.

21 Specify the endpoint of the stair.

22 Continue adding stairs, or press ENTER.

Creating a Spiral Stair with User-Specified Settings
Use this procedure to create a circular sweeping and spiral stair. A spiral stair
revolves about a common center point from bottom to top.

You can specify a radius directly or on the screen only when the arc constraint
is free. Otherwise, the radius is determined from the specified tread length
and arc constraint. In that case, you need to adjust the tread length to achieve
the desired radius.
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Creating a spiral stair

To create a spiral stair with the specified tread depth (T) that occurs at a
specified distance from the inner edge, first construct the stair with a width
equal to twice the required distance (A). Next, use Customized Edges to offset
the outer edge to the desired total width B. The offset distance is equal to B -
2A.

Creating a spiral stair with a specified tread depth at a specified distance

TIP To ensure that the Properties palette is displayed before you select a tool, click
Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties.

1 Open the tool palette that you want to use, and select a stair tool.

If necessary, scroll to display the tool that you want to use.
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NOTE Alternatively, click Home tab ➤ Build panel ➤ Stair

drop-down ➤ Stair  .

2 On the Properties palette, click the Design tab, expand Basic, and
expand General.

3 Select a style.

4 For Shape, select Spiral.

5 Specify the horizontal orientation of the stair:

Then…If you want to…

select Counterclockwise for Hori-
zontal Orientation.

draw the spiral stair in a counter-
clockwise direction

select Clockwise for Horizontal Ori-
entation.

draw the spiral stair in a clockwise
direction

Specifying the horizontal orientation for a spiral stair

6 Specify the vertical orientation of the stair:

Then…If you want to…

select Up for Vertical Orientation.draw the stair from this floor to the
floor above
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Then…If you want to…

select Down for Vertical Orienta-
tion.

draw the stair from this floor to the
floor below

NOTE If Terminate with is set to Landing, the vertical orientation is
up and cannot be changed.

7 Expand Dimensions.

8 Specify stair width, height, and justification:

Then…If you want to…

enter a value for Width.specify the width of the stair

enter a value for Height.specify the floor-to-floor height of
the stair

enter a value for Justify. The Justify
value you select controls the inser-

specify the justification of the stair

tion point when you place the stair
(inside, center, or outside) at the
beginning of the stair run.

9 Specify the stair termination:

Then…If you want to…

select Riser for Terminate with.end the stair run with a riser

NOTE Stairs that end with a
riser will have an overall height
that is one tread thickness less
than the floor-to-floor height
specified.
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Then…If you want to…

select Tread for Terminate with.end the stair run with a tread

select Landing for Terminate with.end the stair run with a landing

NOTE If the vertical orientation is set to Down, Terminate with is set
to Riser and cannot be changed.

10 Specify the radius of the stair:

Then…If you want to…

select No for Specify On Screen and
enter a value for Radius.

specify the exact radius for the
spiral stair

select Yes for Specify On Screen.define the radius for the stair dynam-
ically

11 Select the type of arc constraint to use when creating the spiral
stair:

Then…If you want to…

select Free for Arc constraint.create a spiral stair run with no
constraints

select Total degrees for Arc con-
straint, and enter a value for Arc

create a spiral stair with a specific
number of degrees for the stair
flight
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Then…If you want to…

angle. This includes the terminal
landing or tread.

select Degrees per tread for Arc
constraint, and enter a value for Arc
angle.

create a spiral stair with a specific
degree for each tread in the stair

12 Click  next to Calculation rules, and

then…if you want to…

enter values for Straight Length and
Riser Count, then click OK.

specify the overall linear length of
the stair

■ When Straight Length is set to

 (automatic), the value is
calculated based on the tread
size and riser count.

■ When Straight Length is set to

 (user-defined), the stair
length is equal to the dimen-
sion entered, and the other
three values are adjusted within
the code limits.

■ When Riser Count is set to 
(user-defined), the tread depth
is increased or decreased to ac-
commodate the stair.

enter a value for Riser Count, then
click OK.

specify the total number of stair
risers

■ When Riser Count is set to 
(automatic), the number of
risers is based on the overall
length and overall height of the
stair and the code limits spe-
cified on the Design Rules tab.
The Straight Length value of
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then…if you want to…

the stair is adjusted automatic-
ally.

■ When Riser Count is set to 
(user-defined), you can specify
a value that is used to calculate
the tread depth and riser
height. If these values fall out-
side the stair limits, an error
message is displayed.

set all fields to  (automatic),
click the icon for Riser to change it

specify the height of each riser in
the stair flight

to  (user-defined), and enter a
value for Riser. Click OK.

set all fields to  (automatic),
click the icon next to Tread to

specify the tread depth for each
tread in the stair flight

change it to  (user-defined),
and enter a value for Tread. You can
also specify the Riser count when
you set the tread depth. Click OK.

NOTE If a value is set to user-defined on the Calculation rules
worksheet, it can be modified directly in the Properties palette.

NOTE If  is displayed next to a field in the Calculation Rules dialog
box, that field can’t be changed until another field is changed from

 (user-defined) to  (automatic).

13 Expand Advanced.

14 Specify the Floor Settings:

Then…If you want to…

enter a value for Top offset.change the thickness of the floor
finish material at the top of the stair
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Then…If you want to…

enter a value for Top depth.change the depth of the structure
at the top of the stair

enter a value for Bottom offset.change the thickness of the floor
finish material at the bottom of the
stair

15 Set the minimum height or amount of risers in a stair flight, or
specify *NONE*.

16 Set the maximum height or number of risers in a stair flight, or
specify *NONE*.

17 Specify the center point for the spiral stair.

18 Specify the location of the stair.

19 Continue adding stairs, or press ENTER.

Creating a Custom Stair from Linework
Use this procedure to create a custom stair from linework. You can model
irregularly shaped stairs and treads, and specify multiple flights at varying
angles with a custom stair. You can select or create linework defining stair
edges and tread edges. Create a custom stair to model complex existing stair
conditions for analysis and explore non-code compliant conditions, or generate
stair types that are not possible to create using regular AutoCAD Architecture
stair commands.

The stairs outline component of a custom stair is delineated by the left and
right stair sides, the nosing of the first tread, and the front of the last tread or
landing.

Stair stringers can be selected as linework, or they can be automatically
generated by AutoCAD Architecture. After you create a custom stair, you can
replace stringer paths. You can add or modify stringers by editing the stair
style. The stair style applied to the custom stair must have stringers defined
in that particular stair style. If the stair style does include stringers, the left
and right stringer path lines are converted to appropriate stringer geometry.
The current stair properties govern the appearance of stair components in
various representations.

IMPORTANT The overall outline of the stair must not overlap at any point, or a
Solution Tip will appear.
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Create the linework for your custom stair using lines, light-weight polylines,
or arc segments. All tread lines must intersect with the sides of the stair.
Graphics representing the stringer paths must be continuous throught the
path of the stair.

Linework for custom stairs can represent the following components:

■ left and right stair sides (required)

■ stair path (optional)

■ left, right, and center stair stringers (optional)

■ first tread at current level (required)

■ remaining treads (required)

NOTE A custom stair must have a minimum of 2 treads. At least 2 lines must
be selected for remaining treads when creating a custom stair.

Creating a Custom Stair from Linework

1 Open the tool palette that contains the stair tool that you want
to use, and select the tool.

You may have to scroll to display the desired tool.

TIP To ensure that the Properties palette is displayed before you
select a tool, click Home tab ➤ Build panel ➤ Tools
drop-down ➤ Properties.
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2 Verify that your current drawing includes a stair style with defined
stringers.

3 Right-click the stair tool and click Apply Tool Properties
to ➤ Linework.

4 Select the linework that represents the left and right sides of the
custom stair.

Only lines, light-weight polylines, or arc segments that intersect
all treads can be selected for the stair sides.

5 Select the linework that represents the stair path, or press ENTER
to have it generated automatically.

Only single or multi-segment light-weight polylines or arc
segments that intersect all treads can be selected for the stair path.
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6 Select the linework that represents the left, right, and center stair
stringers, or press ENTER to have the left, right, and center stair
stringers generated automatically.

7 Select the linework that represents the first tread at the current
level.

Only lines, light-weight polylines, or arc segments that intersect
the stair sides can be selected for the stair treads.

8 Select the remaining treads.

9 In the Convert to Stair dialog, verify or change the parameter
values for Style, Height, Vertical Orientation, and Terminate with.
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Specify a style with defined stringers. Specify whether to erase the
layout geometry, then click OK.

NOTE The Standard stair style does not have defined stringers.

IMPORTANT You cannot convert a custom stair to a ramp stair style.

The custom stair from linework is generated.

Once you create a custom stair, you can convert any part of it to a landing.
See Modifying Custom Stairs on page 2145 to do this.

Creating a Custom Stair from Tread Profiles
Use this procedure to create a custom stair from tread profiles. Use defined
profiles generated from closed polylines for custom stair treads. All tread
profiles in each stair run must either intersect or overlap.

The stairs outline component of a custom stair is delineated by the left and
right stair sides, the nosing of the first tread, and the front of the last tread or
landing.
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IMPORTANT The overall outline of the stair must not overlap at any point, or a
Solution Tip will appear.

Stair stringers can be selected as linework or they can be automatically
generated by AutoCAD Architecture. After you create a custom stair, you can
replace stringer paths. You can add or modify stringers by editing the stair
style. The current stair properties govern the appearance of stair components
in various representations.

Linework and profiles for custom stairs can represent the following
components:

■ stair path (required)

■ left and right stair stringers (optional)

■ first tread profile at current level (required)

■ remaining treads (required)

Creating a Custom Stair from Tread Profiles

1 Open the tool palette that contains the stair tool that you want
to use, and select the tool.

You may have to scroll to display the desired tool.

TIP To ensure that the Properties palette is displayed before you
select a tool, click Home tab ➤ Build panel ➤ Tools
drop-down ➤ Properties.
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2 Right-click the stair tool and click Apply Tool Properties
to ➤ Linework.

3 Enter T for Treadprofile.

4 Select the linework that represents the stair path.

Only single or multi-segment light-weight polylines or arc
segments that intersect all treads can be selected for the stair path.

5 Select the linework that represents the left, right, and center stair
stringers, or press ENTER to have the left, right, and center stair
stringers generated automatically.

6 Select the linework that represents the first tread profile at the
current level.

Only defined profiles can be selected for stair treads.
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7 Select the remaining treads.

IMPORTANT You cannot covert a custom stair to a ramp stair style.

8 In the Convert to Stair dialog, verify or change the parameter
values for Style, Height, Vertical Orientation, and Terminate with.
Specify whether to erase the layout geometry, then click OK.

IMPORTANT You cannot convert a custom stair to a ramp stair style.
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The custom stair from tread profiles is generated.

Once you create a custom stair, you can convert any part of it to a landing.
See Modifying Custom Stairs on page 2145 to do this.

Modifying Custom Stairs
Use these procedures to perform the following modifications for custom stairs:

■ Edit the faces of treads and risers

■ Match treads and risers to source components

■ Convert a tread to a landing and back again

■ Replace an existing stringer path with a new stringer path by selecting
linework

IMPORTANT When adding or changing the shape of treads, the overall outline
of the stair must not overlap at any point, or a Solution Tip will appear.

Edit a Custom Stair Tread

1 Use this procedure to convert the edge of a custom stair tread to
an arc.

Select the custom stair that you want to change and click Stair

tab ➤ Custom Stair panel ➤ Edit Tread/Riser  .
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A grip appears at the midpoint of each tread and riser.

2 Select the bottom Edit Tread grip.

You can select either edge or vertex grips to modify the face of
the tread. The following grips are displayed for editing the face
of a custom stair tread:

3 Move the cursor over the front Edge grip.

A tooltip with the following options is displayed:

■ Offset

■ Add Vertex

■ Convert to Arc

■ Offset All

4 Select the Edge grip, and press CTRL twice to cycle to the Convert
to Arc option.
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5 Specify a new location for the Edge grip.

Match Tread/Riser

1 Use this procedure to modify a custom stair tread by matching
an existing tread on another custom stair.

Create 2 custom stairs: one with a source tread to match, and one
as the destination custom stair.

2 Select the custom stair that you want to change, and click Stair

tab ➤ Custom Stair panel ➤ Match Tread/Riser  .

3 Specify tread to match.

You have the option of matching a tread, a riser, or both.

4 Select the tread to match on the source custom stair.
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5 Select the tread on the destination custom stair to replace.

Toggle Tread/Landing

1 Use this procedure to convert a custom stair tread to a landing,
or convert a custom stair landing to a tread.

Select the custom stair that you want to change, and click Stair

tab ➤ Custom Stair panel ➤ Set To Tread/Landing  .

2 Select the tread to convert to a landing.
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When you use a stair style that has defined stringers, you can see
that the stringer is parallel to the landing and sloping for the
duration of the tread.

NOTE This feature does not override the Terminate with option. If
Terminate with Landing is specified, you cannot use this feature to
convert the landing to a tread.

Replace Stringer Path

1 Use this procedure to replace an existing custom stair stringer
path with a new stringer path by selecting linework. The linework
must occur within the stair to be valid for selection as a
replacement stringer path, and must follow the entire length of
the stair.
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Select the custom stair that you want to change, and click Stair

tab ➤ Custom Stair panel ➤ Replace Stringer Path  .

2 Specify the left, right, or center stringer path (depending on the
custom stair configuration) to replace.

3 Select the linework to represent the new stringer path.

Creating a Ramp
Use this procedure to create a ramp using stairs. The Ramp-Concrete style (in
the Stair Styles drawing) includes the correct settings for creating a ramp.

TIP For a listing of the location of all styles and support drawings, see Styles and
Support Files on page 126.

The ramp stringer type should be used for creating ramps. The stringer facets
display component provides the landing lines for ramps, and an End with
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tread setting makes the connection to the next level work correctly, instead
of having one riser height between the ramp and the surface it should meet.

TIP To ensure that the Properties palette is displayed before you select a tool, click
Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties..

1 Import the ramp style from the Stair Styles drawing.

For information about copying styles into your drawing, see
Copying Styles Between Drawings on page 877.

2 Open the tool palette that you want to use, and select a stair tool.

If necessary, scroll to display the tool that you want to use.

NOTE Alternatively, click Home tab ➤ Build panel ➤ Stair

drop-down ➤ Stair  .

3 On the Properties palette, expand Basic, and expand General.

4 Select the Ramp-Concrete style.

5 Specify stair settings, such as shape, turn type, and so on.

6 Specify the location of the stair.

7 Continue adding stairs, or press ENTER.
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Creating a U-shaped concrete ramp

Creating a Stair Tool
Use this procedure to create a stair tool and add it to a tool palette. You may
want to create your own stair tools if you are placing multiple stairs of a specific
style and they all have the same property.

1 Open the tool palette on which you want to add a tool.

2 Create the tool:

Then…If you want to…

select the stair, and drag it to the
tool palette.

create a tool from a stair in the
drawing

Click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from a stair style in the
Style Manager

the style you want to copy, and
drag it to the tool palette. Click OK
to close the Style Manager.
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Then…If you want to…

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the palette where you want
to add the tool, right-click, and click
Paste.

open the catalog in the Content
Browser, and locate the tool you

copy a tool from a tool catalog

want to copy. Position the cursor
over the i-drop handle, and drag
the tool to the tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

This description is used as the tooltip on the tool palette, and to
describe the tool if it is stored in a tool catalog.

6 Expand Basic, and expand General.

7 Click  next to Description, enter a description of the stair
created from this tool, and click OK.

8 Specify a layer key and any layer key overrides if you do not want
to use the layer assignments specified in the layer key style used
in the drawing.

9 Select a stair style.

NOTE If a multi-landing or u-shaped stair is selected, the turn type
can be set. If the turn type is 1/2 or 1/4 turn, the winder style can be
set.

10 Select the drawing file containing the style used for this stair.

11 Click OK.
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Editing Stairs
You can edit stairs by changing the style of the stair, the width and height of
the stair, the size of the tread, and the justification. You can also change
constraints, components, landing extensions, and location, in addition to the
style and dimensions.

AutoCAD Architecture offers several methods for editing stairs:

■ You can directly edit stairs using grips for dimensions and other physical
characteristics.

■ For grip edit operations where you are changing a dimension or an angle,
the Dynamic Input feature lets you enter a precise value instead of moving
a grip. When this feature is active (click DYN on the application status
bar), selecting a grip displays a text box in which you can enter the desired
value for the associated dimension or angle. For more information, see
“Use Dynamic Input” in AutoCAD Help.

■ You can change stair settings on the Properties palette.

■ You can use editing commands from the contextual ribbon tab for a
selected stair.

Using Grips to Edit Stairs
When you use grips to edit stairs, the stairway continues to be constrained by
the design limits and length specified when the stair was created, if Automatic
Length is set to No. This is the case for all stairs in earlier- version drawings.
If you move beyond those limits, a solution tip icon is displayed.

Stair with solution tip icon
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You can use grips to create multi-landing stairs that have skewed landings
and angled stair runs. Changing the configuration of a landing may result in
changes to the stair run.

You can increase or decrease the overall width of the stair run for U-shaped
stairs.

The radius and start point can be changed for spiral stairs. You can use grips
to increase or decrease the overall width of the stair run for spiral stairs. If you
change the width of the stair after grip-editing a side, the changes are lost.

NOTE You cannot use any of the plan representation grips to alter the floor-to-floor
height. Select the stair in a view direction other than TOP to use a grip to change
the floor-to-floor height.

Each stair shape has different grips associated with it.

Using Grips to Edit Straight Stairs
Refer to the illustrations and steps in this topic to use straight stair grips to
edit stairs.

AnimationDescriptionGrip

Lets you change the length of a
straight stair run.

(Length)

Lets you change the height of a
straight stair run.

(Height)

Lets you change the fight taper of
a straight stair run.

(Flight Taper)

Lets you change the flight width of
a straight stair run by adding an
edge.

(Edge)

Lets you change the flight width of
a straight stair run by moving an
edge.

(Edge)

Lets you change the construction
line location of a straight stair run.

(Construction
Line Location)
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AnimationDescriptionGrip

Lets you change the graphics path
location of a straight stair run.

(Graphics Path
Location)

Editing Stair Dimensions

1 Select the straight stair.

2 Select the grip for the dimension you want to change.

Straight stair Flight Start and End, Location,
and Lengthen Stair grips

3 Move the grip until the dimension value you want is displayed,
and click once; or enter a value.

NOTE The Lengthen Stair grips move a straight stair unless it ends
with a landing.

4 Click the Edit Edges grip to access the edges edit mode (flight
width and flight taper).

NOTE Alternatively, click Stair tab ➤ Modify panel ➤ Customize Edge
drop-down ➤ Edit.
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Straight stair Flight Taper, Flight Width, and Exit
Edit Edges grips

5 When you have finished editing the stair edges, click the Exit Edit
Edges grip to return to the default stair edit mode.

6 Continue edting, or right-click and click Deselect All to turn off
grips.

Changing the Location or Position of a Straight Stair

1 Select the straight stair.

2 Select the appropriate grip to change the location of the stair, its
start point, construction line, graphics path, or endpoint.
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Straight stair Flight Start and End, Lengthen
Stair, and Location grips

Straight stair Construction Line Location,
Graphics Path Location, and Edit Edges grips

3 Move the stair to the desired location, and click once; or enter a
value, and press ENTER.
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If you want to enter a specific value for the second direction in
any edit mode (for example, in the Y direction when editing along
the XY plane), press TAB to cycle to the second direction.

You can also lock the movement of the stair along a specific
direction. If you enter a value for either dimension direction in
the current edit mode, and then press TAB, the movement of the
stair is constrained to the second dimension direction. When
editing along the XY plane, for example, you can enter a value for
X dimension, and then press TAB. The X dimension is locked at
that value, and movement of the stair is constrained to the Y
dimension direction.

4 Right-click, and click Deselect All to turn off grips.

Changing the Height of a Straight Stair

1 Select the straight stair.

2 Move the Height grip to change the height of the stair.

NOTE This grip displays only in 3D views of the stair. Height cannot
be edited in Plan view.
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Straight stair Height grip

3 Right-click, and click Deselect All to turn off grips.

Using Grips to Edit Multi-Landing Stairs
Refer to the illustrations and steps in this topic to use multi-landing stair grips
to edit stairs.

AnimationDescriptionGrip

Lets you move the flight of a multi-
landing stair.

(Move Flight)

Lets you move the turn point of a
multi-landing stair.

(Turn Point)

Lets you change the fight taper of
a multi-landing stair.

(Flight Taper)
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AnimationDescriptionGrip

Lets you change the flight width of
a multi-landing stair run by moving
an edge.

(Edge)

Lets you change the construction
line location of a multi-landing stair.

(Construction
Line Location)

Lets you change the graphics path
location of a multi-landing stair.

(Graphics Path
Location)

Editing Multi-Landing Stair Dimensions

1 Select the multi-landing stair.

2 Select the grip for the dimension you want to change.

Multi-landing stair landing Edge and Vertex, and Exit
Edit Edges grips

3 Move the grip until the dimension value you want is displayed,
and click once; or enter a value.

4 Click the Edit Edges grip to access the edges edit mode (flight
width and flight taper).
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NOTE Alternatively, click Stair tab ➤ Modify panel ➤ Customize Edge
drop-down ➤ Edit.

Multi-landing stair Flight Taper and Flight Width, and Landing
Width grips

5 When you have finished editing the stair edges, click the Exit Edit
Edges grip to return to the default stair edit mode.

6 Continue edting, or right-click, and click Deselect All to turn off
grips.

Changing the Location or Position of a Multi-Landing Stair

1 Select the multi-landing stair.

2 Select the appropriate grip to change the location of the stair, its
start point, construction line, graphics path, or endpoint.
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Multi-landing stair Flight Start and End, Move Flight, Move
Multi-Landing, and Lengthen Stair grips
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Multi-landing stair Landing Turn Point, Construction
Line Location, Graphics Path Location, and Edit
Edges grips

3 Move the stair to the desired location, and click once; or enter a
value, and press ENTER.

If you want to enter a specific value for the second direction in
any edit mode (for example, in the Y direction when editing along
the XY plane), press TAB to cycle to the second direction.

You can also lock the movement of the stair along a specific
direction. If you enter a value for either dimension direction in
the current edit mode, and then press TAB, the movement of the
stair is constrained to the second dimension direction. When
editing along the XY plane, for example, you can enter a value for
X dimension, and then press TAB. The X dimension is locked at
that value, and movement of the stair is constrained to the Y
dimension direction.

4 Right-click, and click Deselect All to turn off grips.

Changing the Shape of Landings for Multi-Landing Stair

1 Select the multi-landing stair.

2164 | Chapter 28    Stairs



2 Select the Edit Edges grip to access the edges edit mode (landing
width, landing edges, and landing vertices).

NOTE Alternatively, click Stair tab ➤ Modify panel ➤ Customize Edge
drop-down ➤ Edit.

Multi-landing stair Flight Taper and Flight Width, and Landing
Width grips
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Multi-landing stair Landing Edge and Vertex, and Exit
Edit Edges grips

3 Move the appropriate grip to change the shape of the landing of
the stair.

NOTE Once a landing edge has been customized by moving any of
the vertex or edge grips, the landing width grips are no longer
displayed.

4 When you have finished editing the landing edges, click the Exit
Edit Edges grip to return to the default stair edit mode.

5 Right-click, and click Deselect All to turn off grips.

Changing the Location of a Landing for a Multi-Landing Stair

1 Select the multi-landing stair.

2 Move the appropriate grip to change the location of the landing
by changing the location of the turn point for each side of the
landing, or by moving the entire landing.

3 Right-click, and click Deselect All to turn off grips.

Changing the Construction Line or Graphics Path of a Multi-Landing Stair

1 Select the multi-landing stair.
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2 Move the Construction Line or Graphics Path grip.

Multi-landing stair landing Turn Point, Construction
Line Location, Graphics Path Location, and Edit
Edges grips

NOTE Only one of the Construction Line or Graphics Path can be
displayed at a time. This is controlled on the Other tab of the current
plan display representation. For information about this setting, see
Specifying the Display of Other Characteristics of a Stair on page 2269.

3 Right-click, and click Deselect All to turn off grips.

Changing the Height of a Multi-Landing Stair

1 Select the multi-landing stair.

2 Move the Height grip to change the height of the stair.

NOTE This grip displays only in 3D views of the stair.
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Multi-landing stair Height grip

3 Right-click, and click Deselect All to turn off grips.

Using Grips to Edit U-Shaped Stairs
Refer to the illustrations and steps in this topic to use U-shaped stair grips to
edit stairs.

AnimationDescriptionGrip

Lets you change the flight start
point of a u-shaped stair.

(Flight Start)

Lets you flip the end of a u-shaped
stair.

(Flip End)

Lets you flip the side of a u-shaped
stair.

(Flip Side)

Lets you change the fight taper of
a u-shaped stair.

(Flight Taper)

Lets you change the flight width of
a u-shaped stair by adding an edge.

(Edge)
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AnimationDescriptionGrip

Lets you change the flight width of
a u-shaped stair by moving an
edge.

(Edge)

Lets you change the construction
line location of a u-shaped stair.

(Construction
Line Location)

Lets you change the graphics path
location of a u-shaped stair.

(Graphics Path
Location)

Lets you change the landing width
of a u-shaped stair by adding an
edge.

(Edge)

Lets you change the landing width
of a u-shaped stair by moving an
edge.

(Edge)

Editing U-Shaped Stair Dimensions

1 Select the U-shaped stair.

2 Select the Edit Edges grip to access the edges edit mode (flight
width, flight taper, and landing width).

NOTE Alternatively, click Stair tab ➤ Modify panel ➤ Customize Edge
drop-down ➤ Edit.

U-shaped stair Flight Taper, Flight Width, and Landing Width
grips
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U-shaped stair Landing Vertex and Edge, and Exit
Edit Edges grips

3 Move the grip until the dimension value you want is displayed,
and click once; or enter a value.

4 When you have finished editing the stair edges, click the Exit Edit
Edges grip to return to the default stair edit mode.

5 Right-click, and click Deselect All to turn off grips.

Changing the Location or Position of a U-Shaped Stair

1 Select the U-shaped stair.

2 Select the appropriate grip to change the location of the stair, its
start point, construction line, graphics path, or endpoint.

U-shaped stair Flight Start and End, Flip, and
Location grips
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U-shaped stair Graphics Path Location,
Construction Line Location, and Edit Edges
grips

3 Move the stair to the desired location, and click once; or enter a
value, and press ENTER.

If you want to enter a specific value for the second direction in
any edit mode (for example, in the Y direction when editing along
the XY plane), press TAB to cycle to the second direction.

You can also lock the movement of the stair along a specific
direction. If you enter a value for either dimension direction in
the current edit mode, and then press TAB, the movement of the
stair is constrained to the second dimension direction. When
editing along the XY plane, for example, you can enter a value for
X dimension, and then press TAB. The X dimension is locked at
that value, and movement of the stair is constrained to the Y
dimension direction.

4 Right-click, and click Deselect All to turn off grips.

Changing the Shape of Landings for a U-Shaped Stair

1 Select the U-shaped stair.

2 Select the Edit Edges grip to access the edges edit mode (landing
width, landing edges, and landing vertices).

NOTE Alternatively, click Stair tab ➤ Modify panel ➤ Customize Edge
drop-down ➤ Edit.
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U-shaped stair Flight Taper, Flight Width, and Landing Width
grips

U-shaped stair Landing Vertex and Edge, and Exit
Edit Edges grips

3 Move the appropriate grip to change the shape of the landing of
the stair.

4 When you have finished editing the landing edges, click the Exit
Edit Edges grip to return to the default stair edit mode.

5 Right-click, and click Deselect All to turn off grips.

Changing the Construction Line or Graphics Path of a U-Shaped Stair

1 Select the U-shaped stair.

2 Move the Construction Line or Graphics Path grip.
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U-shaped stair Graphics Path Location,
Construction Line Location, and Edit Edges
grips

NOTE Only one of the Construction Line or Graphics Path can be
displayed at a time.

3 Move the appropriate Flip grip to flip the stair landing from one
side of the flight start grip to the other, or to switch the two
flights.

4 Right-click, and click Deselect All to turn off grips.

Changing the Height of a U-Shaped Stair

1 Select the U-shaped stair.

2 Move the Height grip to change the height of the stair.

NOTE This grip displays only in 3D views of the stair.
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U-shaped stair Height grip

3 Right-click, and click Deselect All to turn off grips.

Using Grips to Edit Spiral Stairs
Refer to the illustrations and steps in this topic to use spiral stair grips to edit
stairs.

AnimationDescriptionGrip

Lets you change the radius of a
spiral stair.

(Radius)

Lets you rotate the flight of a spiral
stair.

(Rotate Flight)

Lets you change the height of a
spiral stair.

(Height)

Lets you change the fight taper of
a spiral stair.

(Flight Taper)
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AnimationDescriptionGrip

Lets you change the flight width of
a spiral stair by adding an edge.

(Edge)

Lets you change the flight width of
a spiral stair by moving an edge.

(Edge)

Lets you flip a spiral stair.(Flip)

Lets you change the graphics path
location of a spiral stair.

(Graphics Path
Location)

Editing Spiral Stair Dimensions

1 Select the spiral stair.

2 Select the Edit Edges grip to access the edges edit mode (flight
width and flight taper).

NOTE Alternatively, click Stair tab ➤ Modify panel ➤ Customize Edge
drop-down ➤ Edit.

3 Select the grip for the dimension you want to change.

Spiral stair Flight Taper and Width, and Exit Edges Edit grips

4 Move the grip until the dimension value you want is displayed,
and click once; or enter a value.

5 When you have finished editing the stair edges, click the Exit Edit
Edges grip to return to the default stair edit mode.

6 Right-click, and click Deselect All to turn off grips.
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Changing the Location or Position of a Spiral Stair

1 Select the spiral stair.

2 Select the appropriate grip to change the location of the stair, its
start point, construction line, graphics path, or endpoint. You
can also flip the stair around the start point.

Spiral stair Radius, Flip, Rotate Flight, and Location grips

Spiral stair Graphics Path Location and Edit Edges grips

3 Move the stair to the desired location, and click once; or enter a
value, and press ENTER.

If you want to enter a specific value for the second direction in
any edit mode (for example, in the Y direction when editing along
the XY plane), press TAB to cycle to the second direction.

You can also lock the movement of the stair along a specific
direction. If you enter a value for either dimension direction in
the current edit mode, and then press TAB, the movement of the
stair is constrained to the second dimension direction. When
editing along the XY plane, for example, you can enter a value for
X dimension, and then press TAB. The X dimension is locked at
that value, and movement of the stair is constrained to the Y
dimension direction.

2176 | Chapter 28    Stairs



4 Right-click, and click Deselect All to turn off grips.

Changing the Height of a Spiral Stair

1 Select the spiral stair.

2 Move the Height grip to change the height of the stair.

NOTE This grip displays only in 3D views of the stair.

Spiral stair Height grip

3 Right-click, and click Deselect All to turn off grips.

Changing the Width of a Flight
Use this procedure to change width of a stair flight. You can also change the
stair width on the Properties palette.

For more information about stair grips, see Using Grips to Edit Stairs on page
2154.
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NOTE If you change the width of the stair after grip-editing a side, the grip changes
are lost.

1 Select the stair.

2 Select a Flight Width grip, move the grip until the width value
you want is displayed, and click once.

After selecting a grip, you can also enter a precise value to increase
or decrease the width of the stair.

The entire edge of the flight moves to the selected location. The
flight entry width also changes to fit the new stair width.
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Using grips to change stair flight width

3 Right-click, and click Deselect All to turn off grips.
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Changing the Shape of a Flight
Use this procedure to change the top and bottom width of a single flight on
U-shaped, multi-landing, or spiral-shape stairs. Each side of a flight can be
tapered independently using grip points.

For more information about stair grips, see Using Grips to Edit Stairs on page
2154.

NOTE If you change the width of the stair after grip editing a side, the grip changes
are lost.

1 Select the stair to modify.

2 Select the Flight Taper grip on the stair flight, and move the grip
away from stair path to new location.

The flight changes to the new shape.
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Using grips to change stair flight taper
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3 Right-click, and click Deselect All to turn off grips.

Changing the Shape of a Landing
Use this procedure to change the angles and positions of landing edges on
U-shaped and multi-landing stairs. Each edge of a landing can be tapered or
moved independently using grip points.

For more information about stair grips, see Using Grips to Edit Stairs on page
2154.

NOTE If you change the width of the stair after grip-editing a side, the grip changes
are lost.

1 Select the stair to modify.

2 Select a Vertex grip on the landing, and move the grip away from
the stair path to a new location.

The landing changes to the new shape. If the vertex grip is shared
between a landing and flight, the flight moves with the landing.

3 Select an Edge grip on the landing, and move the grip
perpendicular to the stair path to the new location.

The entire edge of the landing moves to the selected location.
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Using grips to change a stair landing width by adding an edge
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4 Select an Edge grip on the side of a landing, press CTRL, then move
the grip away from the stair path.

An adjacent edge of the landing is created.

5 Right-click, and click Deselect All to turn off grips.

Changing the Side of a Stair
You can determine the shape of one edge of a stair run that includes flights
and landings for straight, U-shaped, multi-landing, or spiral stairs.

The size of the landing must be adjusted to prevent overlapping treads when
the inner edge of a stair is projected to a profile that lies outside the original
stair. The initial size of the landing is determined by projecting the diagonal
of the original landing to the profile.
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Using grips to change a stair landing width
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Pushing one tread into the landing with its grip forces the landing to lengthen
in the other direction. Pulling one tread away from the landing does not affect
the other end of the landing. The stair is lengthened at its top to accommodate
the larger landing. You can modify the length with the top and bottom grips,
at the end of the stair walking path.

About Projecting the Side of a Stair
You can project the edge of a stair to most AEC objects, such as walls or mass
elements, but excluding multi-view blocks.

Projecting a stair edge to an object

NOTE When projecting an edge of a stair that has an inner corner, it is clear how
to project the outer edge of the stair to the selected object, but projection of the
inner corner is ambiguous. Rather than attempting to guess the correct solution,
these cases are not projected, and a dialog box is displayed with an explanation
that edges of stairs with interior corners can be projected only to objects that
extend beyond both ends of the stair.
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The stair length is extended at its original width when the object (or polyline)
does not extend far enough for the stair to project completely.

Projecting the Side of a Stair
Use this procedure to project the side of a stair to an existing polyline, wall,
other AEC object, or solid. Objects to project to must extend the full length
of the stair for an interior corner to project properly.

For more information about stair grips, see Using Grips to Edit Stairs on page
2154.

Projecting stair edges to curved polyline
segments
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Projecting stair edges to straight polyline
segments

NOTE If you change the width of the stair after projecting a side, the changes to
the projected edge are lost.

1 Select a stair, and click Stair tab ➤ Modify panel ➤ Customize
Edge drop-down ➤ Project.

2 Select the edge of a stair to change.

3 Select a polyline, object or profile to project to, and press ENTER.
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Projecting stair edges to a profile

Treads are extended using the line of the current front and back
edge.

NOTE If edges intersect, which can happen with only spiral and winding shapes,
a solution tip icon displays.

Offsetting the Side of a Stair
Use this procedure to offset the side of a stair flight by a specified value.

For more information about stair grips, see Using Grips to Edit Stairs on page
2154.

NOTE If you change the width of the stair after offsetting a side, the offset changes
are lost.

1 Select a stair, and click Stair tab ➤ Modify panel ➤ Customize
Edge drop-down ➤ Offset.

2 Select the edge of a stair to be offset.
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3 Enter the distance to offset, where positive is out and negative is
in, and press ENTER.

Treads are extended using the line of the current front and back
edge.

Offsetting the edge of a stair

NOTE If edges intersect, which can happen with only spiral and
winding shapes, a solution tip icon displays.

Generating a Polyline from the Edge of a Stair
Use this procedure to generate a polyline from the edge of a stair. The polyline
is generated at the stair bottom elevation.

For more information about stair grips, see Using Grips to Edit Stairs on page
2154.
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You can keep some sample polylines in the drawing, and use the final choice
to project to. That way, you can project the stair edge, edit the stair, and then
generate the polyline, change the stair again, generate another polyline, change
the stair again, and, finally, project to the best version you created.

Generating a polyline from a stair edge

1 Select a stair, and click Stair tab ➤ Modify panel ➤ Customize
Edge drop-down ➤ Generate Polyline.

2 Select the edge of a stair.

3 Press ENTER.

A polyline is created at the stair bottom elevation along the length of the stair
run.

Removing Changes from the Side of a Stair
Use this procedure to return the selected edge of the stair to its default profile.
If the stair is back to its original condition, the width is restored to the original
value, rather than *VARIES*. This change affects the treads, risers, and stringers.
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For more information about stair grips, see Using Grips to Edit Stairs on page
2154.

Removing changes made to the side of a stair

1 Select a stair, and click Stair tab ➤ Modify panel ➤ Customize
Edge drop-down ➤ Remove Customization.

2 Select the edge of a stair.

3 Press ENTER.

Changing the Height of a Stair
Use this procedure to change the height of a stair. You can also change the
stair height on the Properties palette.

For more information about stair grips, see Using Grips to Edit Stairs on page
2154.
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Changing the height of a stair using grips

1 Select the stair in an isometric view.

2 Select the Height grip, move the grip until the value you want is
displayed, and click once.

After selecting a grip, you can also enter a precise value to increase
or decrease the height of the stair.

NOTE If you edit the height of a stair with landings, so that a landing
would be below the new height, the landing is not displayed. If you
edit the height again, and move it to a location above the previous
landing, the landing is no longer there. To retain the stair path, which
includes the landing, use the AecStairFit command to set Automatic
Landings to No.
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Changing the Justification of a Stair
Use this procedure to change the justification of an individual stair. The stair
remains in the same location, but changes in the width keep the new
justification point constant.

For example, a stair with right justification changes the left edge when the
width is changed.

1 Select the stair you want to change, and double-click it.

2 On the Properties palette, click the Design tab, expand Basic, and
expand General.

3 Select Left, Center, or Right for Justify.

This does not change the location of the stair, but changing this
value specifies the point from which changes to the width are
calculated from now on.

Changing the Style of a Stair
Use this procedure to select a different stair style for one or more stairs.

1 Select the stairs to change, and double-click one of them.

2 On the Properties palette, click the Design tab, expand Basic, and
expand General.

3 Select a different style.

Changing the Horizontal Direction of a Spiral or U-Shaped Stair
Use this procedure to change the orientation of a spiral stair.

1 Double-click a spiral or U-shaped stair to open the Properties
palette.

2 Click the Design tab, expand Basic, and expand General.

3 Specify the horizontal orientation of the stair:

Then…If you want to…

select Counterclockwise for Hori-
zontal Orientation.

draw the spiral or U-shaped stair in
a counterclockwise direction

select Clockwise for Horizontal Ori-
entation.

draw the spiral or U-shaped stair in
a clockwise direction
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NOTE This is equivalent to selecting the Flip grip that mirrors the
stair around its start point.

Changing the Constraints of a Spiral Stair
Use this procedure to control what constrains the spiral stair by specifying
the total degrees or the number of degrees per tread to use. These fields are
available only when you select a spiral-shaped stair to modify.

1 Double-click a spiral stair to open the Properties palette.

2 Click the Design tab, expand Basic, and expand Dimensions.

3 Specify the arc constraint:

Then…If you want to…

select Free for Arc constraint.display the spiral stair with no con-
straint

select Total degrees for Arc con-
straint, and enter a value for Arc
angle.

specify the total degrees for the
stair flight

select Degrees per tread for Arc
constraint, and enter a value for Arc
angle.

specify the specific degree for each
tread in the stair

4 Specify the Radius of the stair.
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The radius is measured from the center point of the spiral stair to
the selected justification point.

Changing the Outside Edge of a Spiral Stair
Use this procedure to change the outside edge of a spiral stair. You can change
the edge in two ways:

■ When you use the Flight Width grip point, you uniformly change the
width of the stair along the entire arc. The endpoints of the outer edges
of the stair move. This changes the size of the stair.

■ When you click the Flight Width grip point and press CTRL, you maintain
the center of the stair and the outside grip points. This changes the shape
of the stair.

1 Select a spiral stair.
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2 Change a spiral stair:

Then…If you want to…

click the Flight Width grip of the
spiral stair.

uniformly change the width of a
spiral stair along the entire arc

click the Flight Width grip of the
spiral stair and press CTRL.

maintain the center and outside
grip points while changing the
shape of a spiral stair

3 Move the grip to change the size or shape of the stair.
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Using grips to change the flight width of a spiral stair run
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Using grips to change the shape of a spiral stair run by adding an edge

4 Right-click, and click Deselect All to turn off grips.

Changing the Dimensions of a Stair
Use this procedure to control the various dimensions associated with
calculating the stair.

Some of the interacting dimensions can be user-defined and some are
automatic, depending upon the combination of fields that are selected. Only
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logical combinations are available when the rule-based calculator is in effect.
When the rule-based calculator is not in effect, either tread or straight length
can be user-defined and either riser count or riser height can be user-defined.

1 Double-click the stair to open the Properties palette.

2 Click the Design tab, expand Basic, and expand Dimensions.

3 Change any of the dimensions of the stair:

Then…If you want to…

enter a value for Width.

NOTE If you change the width
of the stair after grip-editing or
otherwise customizing an edge,
the changes are lost.

specify the width of the stair run

enter a value for Height.specify the floor-to-floor height for
the stair

select Left, Center, or Right for Jus-
tify. This does not change the loca-

specify the justification of the stair

tion of the stair, but changing this
value determines the point from
which the width is calculated if it is
subsequently changed.
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4 Select  next to Calculation rules:

Then…If you want to…

enter values for Straight Length and
Riser Count.

specify the overall linear length of
the stair

■ When Straight Length is set to

 (automatic), the value is
calculated based on the tread
size and riser count.

■ When Straight Length is set to

 (user-defined), the stair
length is equal to the dimen-
sion entered, and the other
three values are adjusted within
the code limits. If these values
fall outside the stair limits, an
error message is displayed.

■ When Riser Count is set to 
(user-defined), the tread depth
is increased or decreased to ac-
commodate the stair.

enter a value for Riser Count.specify the total number of stair
risers

■ When Riser Count is set to 
(automatic), the number of
risers is based on the overall
length and overall height of the
stair and the code limits spe-
cified on the Design Rules tab.
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Then…If you want to…

The Straight Length value of
the stair is adjusted automatic-
ally.

■ When Riser Count is set to 
(user-defined), you can specify
a value that is used to calculate
the tread depth and riser
height. If these values fall out-
side the stair limits, an error
message is displayed.

set all fields to  (automatic),
click the icon to Riser to change it

specify the height of each riser in
the stair flight

to  (user-defined), and enter a
riser height value.

set all fields to  (automatic),
click the icon next to Tread to

specify the tread depth for each
tread in the stair flight

change it to  (user-defined),
and enter a tread depth value. You
can also specify the Riser Count
when you set the tread depth.

NOTE If  is displayed next to a field in the Calculation Rules dialog
box, that field can’t be changed until another field is changed from

 (user-defined) to  (automatic).

5 Click OK.

Changing the Floor Settings of a Stair
Use this procedure to control how the stair interacts with the floor at the
beginning and end of the stair run.

1 Double-click a stair to open the Properties palette.
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2 Click the Design tab, expand Advanced, and expand Floor Settings.

3 Change settings for how the stair meets the top and bottom floors:

Then…If you want to…

enter a value for Top Offset.specify the thickness of the floor
finish material at the top floor of
the stair

enter a value for Top Depth.specify the depth of the structure
at the top floor

enter a value for Bottom Offset.specify the thickness of the floor
finish material at the bottom floor
of the stair

enter a value for Bottom Depth.specify the depth of the structure
at the bottom floor

NOTE The Top and Bottom Depth settings currently have no effect
on the stair or stringers. In addition, the Top offset has no visible
effect on the stair. Bottom offset extends or truncates any attached
stringers. Both offset values affect the rough floor-to-floor height, if
it is displayed.

Adjusting Stair Length Automatically
Use this procedure to adjust stair length automatically with the StairFit setting.

With the StairFit setting enabled, a stair adjusts its length to accommodate a
height change. With the StairFit setting disabled, a stair does not adjust its
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length to accommodate a height change. Also, a solution tip icon displays if
the stair path is not long enough to accommodate the new height.

All newly created stairs have the StairFit setting enabled. All stairs created in
versions earlier than Autodesk Architectural Desktop 2004 have the StairFit
setting disabled.

1 Draw a stair run.

2 On the Command Line, enter StairFit.

3 Select the stair run.

4 Enter Y to enable the StairFit setting or N to disable the StairFit
setting.

5 Double-click the stair run to open the Properties palette.

6 Specify a new stair height.

The following illustration shows an example of a straight stair
run with the StairFit option enabled before and after height
changes.

Stair run height change with StairFit option enabled
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The following illustration shows an example of a straight stair
run with the StairFit option disabled before and after height
changes.

Stair run height change with StairFit option disabled

Changing the Length Limits of a Flight
Use this procedure to change the limits for the flight of a stair. A flight can
have no limits, or limits that are constrained by a minimum number of risers,
minimum height, maximum number of risers, or maximum height.

Use these settings to create automatic landings in a stair flight. For example,
if a stair flight has 18 treads and you set the maximum treads to 15, the stair
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will have two flights with one landing in the middle, keeping under the 15
maximum risers on either side of the landing.

Specifying flight height limits for a stair run

1 Double-click a stair to open the Properties palette.

2 Click the Design tab, expand Advanced, and expand Flight Height.

Flight Height with Risers Limit type

3 Specify the constraints for flight length:

Then…If you want to…

select None for Minimum Limit type
and None for Maximum Limit type.

specify no limits on the flight

select Risers for Minimum Limit
type, and enter a value for Minim-
um risers.

specify a minimum number of risers
per flight

select Height for Minimum Limit
type, and enter a value for Minim-
um height.

specify a minimum height for the
flight
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Then…If you want to…

select Risers for Maximum Limit
type, and enter a value for Maxim-
um risers.

specify a maximum number of risers
per flight

select Height for Maximum Limit
type, and enter a value for Maxim-
um height.

specify a maximum height for the
flight

Anchoring a Stair to a Landing
Use this procedure to anchor a stair or other AEC object to an existing landing.

1 Draw a stair with a landing and draw a second stair to attach to
the landing. For more information about creating stairs, see Using
Stair Tools to Create Stairs on page 2107.

2 Select the stair with a landing, and click Stair tab ➤ Modify

panel ➤ Anchor Object To Stair Landing  .

3 Select the stair or other AEC object to anchor to the landing.

4 Select a location on the landing to anchor the center of the start
of the stair run. The flight will be perpendicular to the landing
edge.

Select the insertion point of the AEC object that you are attaching
to the landing. The object will be oriented parallel to the edge of
the landing.
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Anchoring a stair run to a landing

NOTE Stairs created with a vertical orientation of Up go up from the
landing, while stairs created with a vertical orientation of Down go
down from the landing.

The riser numbering feature is helpful in this situation. See Specifying the
Riser Numbering Display for Individual Stairs on page 2271.

2208 | Chapter 28    Stairs



Releasing Anchored Stairs
Use this procedure to release stairs anchored to landings.

■ Select the stair to anchor to the landing, right-click, and click Stair Landing
Anchor ➤ Release.

NOTE The stair remains in the same location, but is no longer anchored to
the landing.

Editing Winders
Three different winder types give you different levels of control for 1/2 turn
and 1/4 turn stairs: Balanced, Single Point, and Manual.

The Balanced winder style has the total turn distributed evenly throughout
the stair run.

The Single Point winder styles allow you to align tread edges or riser faces
with the winder turn center, and add or remove individual treads from the
winder turn. You can also assign a default number of treads to a winder turn,
resulting in the specified number of treads appearing in the stair turn zone.

Manual winder styles can be based on any winder style, by assigning either a
Manual - Tread or Manual - Riser condition to a stair run. Both manual styles
allow you to straighten individual treads or risers in the stair run and to move
the tread endpoints on either side of individual treads so you can angle tread
edges or riser faces to suit your stair design.

For information about creating new winder styles, see Creating a Stair Winder
Style on page 2298.
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Winder style examples

Lengthening a Flight to Align a Tread Edge with a Winder Turn
Center

Use this procedure to lengthen a flight to align a Single Point winder style
tread edge with a winder turn center.

The winders within the turn zone are set to an angle converging on the Turn
Center grip.
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1 Select a 1/2 turn or 1/4 turn stair to activate grips.

2 If the Winder Style is balanced, select the circular Edit Turns trigger
grip. The Select Winder Style dialog box is displayed.

NOTE Only the winder styles present in the drawing are displayed.

Select Winder Style dialog box

3 Select a Single Point style from the list, and click OK.

NOTE To select the style from the Properties palette, click the Design
tab, expand Basic, expand General, and select Single Point for Winder
Style.

4 Select the Edit Turns trigger grip.

Note the initial flight length of the existing stairs.

5 Select the Lengthen Flight to Align Tread grip.

The flight is lengthened as the tread edge is now aligned with the
turn center.
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Lengthening a Flight to Align a Tread Edge with Turn Center
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NOTE To have the converging point on the edge of the stair, you
must clear the Use Riser Lines setting. See Specifying the Stair Winder
Style Settings on page 2299 for more information about this setting.

6 When you have finished editing the flight length, you can click
the Exit Edit Turns grip to return to the default stair edit mode,
or right-click and click Deselect All to turn off grips.

Aligning a Tread Edge with a Winder Turn Center
Use this procedure to align a Single Point winder style tread edge with a winder
turn center.

The winders within the turn zone are set to an angle converging on the Turn
Center grip.

1 Select a 1/2 turn or 1/4 turn stair.

2 If the Winder Style is balanced, select the circular Edit Turns trigger
grip. The Select Winder Style dialog box is displayed.

NOTE Only the winder styles present in the drawing are displayed.

Select Winder Style dialog box

3 Select a Single Point style from the list, and click OK.
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NOTE To select the style from the Properties palette, click the Design
tab, expand Basic, expand General, and select Single Point for Winder
Style.

4 Select the Edit Turns trigger grip.

5 Select the Align with Turn Center grip.

The tread edge is now aligned with the turn center, and the grip
is no longer displayed.
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Aligning a tread edge with turn center

NOTE To have the converging point on the edge of the stair, you
must clear the Use Riser Lines setting. For more information about
this setting, see Specifying the Stair Winder Style Settings on page
2299.
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6 When you have finished editing the tread edge alignment, you
can click the Exit Edit Turns grip to return to the default stair edit
mode, or right-click and click Deselect All to turn off grips.

Removing a Tread from a Winder Turn
Use this procedure to remove a tread from a winder turn.

The winders within the turn zone are set to an angle converging on the Turn
Center grip.

1 Select a 1/2 turn or 1/4 turn stair.

2 If the Winder Style is balanced, select the circular Edit Turns trigger
grip. The Select Winder Style dialog box is displayed.

NOTE Only the winder styles present in the drawing are displayed.

Select Winder Style dialog box

3 Select a Single Point style from the list, and click OK.

NOTE To select the style from the Properties palette, click the Design
tab, expand Basic, expand General, and select Single Point for Winder
Style.

4 Select the Edit Turns trigger grip.

5 Select the Remove Tread from Turn grip.
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The selected tread is removed from the winder turn. If you
continue to remove treads, the stair will eventually display a
solution tip icon. Use the Undo command to restore the previous
tread configuration.

Removing a Tread from a Winder Turn
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NOTE To have the converging point on the edge of the stair, you
must clear the Use Riser Lines setting. For more information about
this setting, see Specifying the Stair Winder Style Settings on page
2299.

6 When you have finished removing treads, you can click the Exit
Edit Turns grip to return to the default stair edit mode, or
right-click and click Deselect All to turn off grips.

Adding a Tread to a Winder Turn
Use this procedure to add a tread to a winder turn.

The winders within the turn zone are set to an angle converging on the Turn
Center grip.

1 Select a 1/2 turn or 1/4 turn stair.

2 If the Winder Style is balanced, select the circular Edit Turns trigger
grip. The Select Winder Style dialog box is displayed.

NOTE Only the winder styles present in the drawing are displayed.

Select Winder Style dialog box

3 Select a Single Point style from the list, and click OK.
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NOTE To select the style from the Properties palette, click the Design
tab, expand Basic, expand General, and select Single Point for Winder
Style.

4 Select the Edit Turns trigger grip.

5 Select the Add Tread to Turn grip.

A tread is added to the winder turn. If you continue to add treads,
the stair will eventually display a solution tip icon. Use the Undo
command to restore the previous tread configuration.
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Adding a tread to a winder turn

NOTE To have the converging point on the edge of the stair, you
must clear the Use Riser Lines setting. For more information about
this setting, see Specifying the Stair Winder Style Settings on page
2299.
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6 When you have finished adding treads, you can click the Exit Edit
Turns grip to return to the default stair edit mode, or right-click
and click Deselect All to turn off grips.

Straightening Treads with the Manual Winder Style
Use this procedure to straighten individual treads on stairs assigned either the
Manual - Tread or Manual - Riser Balanced winder style.

The Straighten Tread grip is located at the intersection of the tread edge or
riser face and the stair construction line, based on the Use Riser Line setting
in the Stair Winder Style dialog box. For more information, see Specifying the
Stair Winder Style Settings on page 2299.

1 Select a 1/2 turn or 1/4 turn stair.

2 If the Winder Style is balanced, select the circular Edit Turns trigger
grip. The Select Winder Style dialog box is displayed.

Select Winder Style dialog box

3 Select either Manual - Tread or Manual - Riser from the list, and
click OK.

NOTE To select the style from the Properties palette, click the Design
tab, expand Basic, expand General, and select either Manual - Tread
or Manual - Riser for Winder Style.

4 Select the Edit Turns trigger grip.
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5 Select the Straighten Tread grip on the tread edge or riser face that
you want to straighten.

The selected tread is straightened.

Straightening a tread with a manual riser style
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NOTE Because the tread depth must be the same for each tread, the
tread edge line will pivot around the construction line.

6 When you have finished straightening treads, you can click the
Exit Edit Turns grip to return to the default stair edit mode, or
right-click and click Deselect All to turn off grips.

Moving Tread Ends with the Manual Winder Style
Use this procedure to move the ends of individual treads on stairs assigned
either the Manual - Tread or Manual - Riser Balanced winder style. Each tread
edge or riser face pivots on a point established by the intersection of the tread
edge and the stair’s construction line. Drag the Tread Edge grip to a new
location to specify a new angle for the tread edge.

The Tread End grips are located at each end of the tread edge or riser face,
based on the Use Riser Line setting in the Stair Winder Style dialog box. For
more information, see Specifying the Stair Winder Style Settings on page 2299.

1 Select a 1/2 turn or 1/4 turn stair.

2 If the Winder Style is balanced, select the circular Edit Turns trigger
grip. The Select Winder Style dialog box is displayed.

Select Winder Style dialog box

3 Select either Manual - Tread or Manual - Riser from the list, and
click OK.
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NOTE To select the style from the Properties palette, expand Basic,
expand General, and select either Manual - Tread or Manual - Riser
for Winder Style.

4 Select the Edit Turns trigger grip.

5 Select the Tread End grip on the tread edge or riser face that you
want to move.

6 Specify a new location for the Tread End grip.

The selected tread is angled as specified.
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Moving a tread edge with a manual riser style
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NOTE Because the tread depth must be the same for each tread, the
tread edge line will pivot around the construction line.

7 When you have finished moving tread ends, you can click the
Exit Edit Turns grip to return to the default stair edit mode, or
right-click and click Deselect All to turn off grips.

Working with Stair Body Modifiers
Body modifiers use the three-dimensional (3D) geometry of an object, such
as a mass element or a mass group, to add to or subtract from a stair component
(tread, riser, or stringer depending on the stair style). Body Modifiers only
work on a single instance of a tread, riser, or stringer at a time.

After you create a body modifier from an object, you can delete the original
object. However, if you have created a complex object, such as a mass group
comprising many mass elements, you may want to retain the object in the
drawing until you are sure you have the results you want for the stair.

Adding a Body Modifier to a Stair Component
Use this procedure to create a body modifier and add it to a stair.

You can create a three-dimensional (3D) body modifier from a mass element,
a mass group, or any other AEC object with mass. You can also create body
modifiers from ACIS solids or blocks that form 3D bodies. You must place the
object in the location you want in the drawing before defining the object as
a body modifier.

The following illustration shows you how to use a mass element as a body
modifier to add to a stair stringer component.
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Adding a body modifier to a stair component

1 Place the object in the location where you want to add the body
modifier to the stair.

2 Select the stair you want to change with the body modifier, and
click Stair tab ➤ Modify panel ➤ Body Modifier drop-down ➤ Add

 .

3 Select the object to add to the stair component.

4 In the Add Body Modifier dialog box, select Stringer for Stair
Component and Additive for Operation.

5 Enter a description for the body modifier.

6 Select Erase Selected Object(s) if you do not want to keep the
original object, or clear this option to keep the object in the
drawing.

7 Click OK.
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Subtracting a Body Modifier from a Stair Component
Use this procedure to create a body modifier and subtract it from a stair
component.

You can create a three-dimensional (3D) body modifier from a mass element,
a mass group, or any other AEC object with mass. You can also create body
modifiers from ACIS solids or blocks that form 3D bodies. You must place the
object in the location you want in the drawing before defining the object as
a body modifier.

The following illustration shows you how to use a mass element as a body
modifier to subtract from a stair tread component.

Subtracting a body modifier from a stair component

1 Place the object in the location where you want to subtract the
body modifier from the stair.

2 Select the stair you want to change with the body modifier, and
click Stair tab ➤ Modify panel ➤ Body Modifier drop-down ➤ Add

 .

3 Select the object to subtract from the stair.

4 In the Add Body Modifier dialog box, select Tread for Stair
Component and Subtractive for Operation.
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5 Enter a description for the body modifier.

6 Select Erase Selected Object(s) if you do not want to keep the
original object, or clear this option to keep the object in the
drawing.

7 Click OK.

Replacing a Stair Component with a Body Modifier
Use this procedure to create a body modifier to replace a stair component.

You can create a three-dimensional (3D) body modifier from a mass element,
a mass group, or any other AEC object with mass. You can also create body
modifiers from ACIS solids or blocks that form 3D bodies. You must place the
object in the location you want in the drawing before defining the object as
a body modifier.

The following illustration shows you how to use a channel as a body modifier
to replace a stair stringer component.

Replacing a stair component with a body modifier

1 Place the object in the location where you want to replace the
stair component with the body modifier.

2 Select the stair you want to change with the body modifier, and
click Stair tab ➤ Modify panel ➤ Body Modifier drop-down ➤ Add

 .

3 Select the object to replace the stair component.
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4 In the Add Body Modifier dialog box, select Stringer for Stair
Component and Replace for Operation.

5 Enter a description for the body modifier.

6 Select Erase Selected Object(s) if you do not want to keep the
original object, or clear this option to keep the object in the
drawing.

7 Click OK.

Editing the Geometry of a Body Modifier
Use this procedure to edit the shape of a body modifier that is attached to a
stair. You can edit the body using grips to edit faces, using Boolean commands
to add or remove other objects from the body modifier, and other editing
commands to change its shape.

1 Select the stair that has the body modifier you want to change,
and click Stair tab ➤ Modify panel ➤ Body Modifier

drop-down ➤ Edit In Place  .

A temporary mass element is created for you to edit the geometry
of the body modifier. If the stair contains multiple body modifiers,
a mass element is created for each body modifier. If the object
was not originally a mass element (for example, if you used a slab
as a body modifier), the object becomes a temporary Free Form
mass element with faces that you can edit.
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NOTE After you perform an editing task from the contextual Edit in
Place ribbon, you may need to select a profile again to perform
another editing task. If you do not see the editing commands that
you expect on the ribbon, re-select a profile to redisplay the Edit in
Place contextual tab.

2 Edit the body modifier:

Then …If you want to …

select the body modifier. Select a
Face grip to activate edge grips for

change the shape of a body modifi-
er that is a Free Form mass element

the face. Move the grips to the de-
sired locations. Continue editing
other faces in the same manner.

select the body modifier. Select
grips and move them to change the

change the shape of a body modifi-
er that is a conventional mass ele-
ment shape of the body modifier. The

grips that are available depend on
the type of mass element used as a
body modifier and the current view
direction.

place the object in the location
where it is needed. Select the body

add an object to a body modifier

modifier and click Edit in Place: Stair

Body Modifier tab ➤ Modify pan-

el ➤ Boolean drop-down ➤ Union.
Select the object, and press ENTER.
Enter y (Yes) to keep the object in
the drawing, or press ENTER to
erase it.

place the object in the location
where it is needed. Select the body

subtract an object from a body
modifier

modifier, and click Edit in Place:

Stair Body Modifier tab ➤ Modify

panel ➤ Boolean drop-

down ➤ Subtract. Select the object,
and press ENTER. Enter y (Yes) to
keep the object in the drawing, or
press ENTER to erase it.
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Then …If you want to …

place the object in the location
where it is needed. Select the body

create a body modifier that is the
intersection of the original body
modifier with another object modifier, and click Edit in Place:

Stair Body Modifier tab ➤ Modify

panel ➤ Boolean drop-down ➤ In-
tersect. Select the object, and press
ENTER. Enter y (Yes) to keep the
object in the drawing, or press
ENTER to erase it.

select the body modifier, and click
Edit in Place: Stair Body Modifier

trim a body modifier

tab ➤ Modify panel ➤ Trim by

Plane  . Specify the points that
define the trim plane, and select the
side of the body modifier to be
trimmed. The trimmed body modi-
fier is converted to a Free Form
mass element.

select the body modifier, and click
Edit in Place: Stair Body Modifier

divide the face of a body modifier
into two faces

tab ➤ Modify panel ➤ Split Face

 . Specify the points that define
the edge created by splitting the
faces.

select the body modifier, and click
Edit in Place: Stair Body Modifier

join two faces that are on the same
plane into a single face

tab ➤ Modify panel ➤ Join Faces

 . Select the edge that separates
the coplanar faces.

select the object that forms the
body modifier, and press DELETE.

remove a body modifier
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3 Save or discard the changes:

Then …If you want to …

select the body modifier, and click
Edit in Place: Stair Body Modifier

tab ➤ Edits panel ➤ Cancel.

restore the body modifier to its ori-
ginal shape

select the body modifier, and click
Edit in Place: Stair Body Modifier

save the changes to the body
modifier

tab ➤ Edits panel ➤ Finish. The
body modifier uses the edited mass
element to define its geometry.

Managing Body Modifiers
Use this procedure to edit or remove three-dimensional (3D) body modifiers
from a stair. You can change the component the body modifier is added to
and select a different operation. You can also enter or edit the descriptions of
body modifiers.

NOTE To remove a body modifier from a stair and restore the modifier as a mass
element that you can edit or apply to other stairs, see Restoring a Body Modifier
to a Mass Element on page 2234.

1 Select the stair you want to change, and click Stair tab ➤ Modify

panel ➤ Body Modifier drop-down ➤ Body Modifiers  .

NOTE You can also access the Body Modifiers worksheet for a selected
stair on the Properties palette’s Design tab, under Advanced.

2 Select a body modifier, and change its settings:

Then …If you want to …

select a different component for
Component.

apply the body modifier to a differ-
ent stair component
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Then …If you want to …

select a different operation for Op-
eration:

change the operation used to apply
the body modifier to the stair

■ Select Additive to add the body
modifier to the stair compon-
ent.

■ Select Subtract to subtract the
shape of the body modifier
from the stair component.

■ Select Replace to replace the
stair component with the body
modifier.

select the body modifier, and click

 .

delete the body modifier from the
stair component

click Description, enter text, and
press ENTER.

enter a description of the body
modifier

3 Click OK.

Restoring a Body Modifier to a Mass Element
Use this procedure to remove a body modifier from a stair and add it to the
drawing as a mass element. Restoring a body modifier to a mass element
enables you to modify the shape as a mass element and then add it to the
stair again as a body modifier. You can also restore the body modifier to a
mass element while leaving the body modifier still applied to the stair. This
is useful if you want to create other stairs with the same shape.

If the object used to create the body modifier was a conventional mass element,
it is restored to that mass element. For example, a Gable mass element is
restored as a Gable mass element. However, if the body modifier was created
from another object, such as a slab, or was edited using Boolean operations
or face editing commands, the body modifier is restored as a Free Form mass
element.

1 Select the stair you want to change, and click Stair tab ➤ Modify
panel ➤ Body Modifier drop-down ➤ Restore.
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NOTE This procedure restores all body modifiers attached to a stair.

2 Create mass elements from the body modifiers:

Then …If you want to …

press ENTER.create mass elements from the body
modifiers while keeping the body
modifiers attached to the stair

enter y (Yes), and press ENTER.remove all body modifiers from the
stair, and create mass elements
from their shapes

Stair Interference Conditions
You can control the height and width of a stair’s interference condition with
walls, slabs, spaces, curtain walls, and door and window assemblies. When
you add an interference condition between a stair and one of the valid objects,
a box is cut out around the stair, based on the specified headroom height and
side clearance.

Creating an Interference Condition in a Wall
Use this procedure to create a stair interference area in a wall. When you add
an interference condition between a stair and a wall, an opening is created in
the wall around the stair, based on the stair’s specified headroom height and
left and right side clearances for straight and multi-landing stairs or inside
and outside clearances for spiral and U-shaped stairs.

Stair Interference Conditions | 2235



Specifying the left and right side clearances for a wall interference condition

1 Create a stair that intersects with a wall. For information about
creating stairs, see Using Stair Tools to Create Stairs on page 2107.

2 Double-click the stair object to open the Properties palette.

3 Click the Design tab, expand Advanced, and expand Interference.

4 Set the size of the interference condition:

Then…If you want to…

enter a value for Headroom height.specify the height above the treads
for the interference condition

enter values for Left and Right
Clearance.

specify the left and right side clear-
ances for the interference condition
for straight and multi-landing stairs
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Then…If you want to…

enter values for Inside and Outside
Clearance.

specify the inside and outside
clearances for the interference con-
dition for spiral and U-shaped stairs

5 Click in the drawing, not on the stair, to remove the selection.

6 Select the wall to intersect, and click Wall tab ➤ Modify

panel ➤ Interference Condition drop-down ➤ Add  .

7 Select the stair, and press ENTER.

8 Select the shrinkwrap effect, and press ENTER. For more
information about shrinkwrapping, see Working with Interference
Conditions on page 1292.

NOTE Changing the Interference values of the stair changes the size
of the intersection with the wall.
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Creating a wall and stair interference condition

Removing a Stair Interference Condition from a Wall
Use this procedure to remove a stair interference from a wall.

1 Click in the drawing.
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2 Select the wall from which to remove the interference, and click
Wall tab ➤ Modify panel ➤ Interference Condition

drop-down ➤ Remove  .

3 Select the stair, and press ENTER.

Creating an Interference Condition in a Slab
Use this procedure to create a stair interference area in a slab. When you add
an interference condition between a stair and a slab, a box is cut out around
the stair based on the specified headroom height and left and right side
clearances for straight and multi-landing stairs or inside and outside clearances
for spiral and U-shaped stairs.

Specifying the left and right side clearances for a slab interference condition
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Specifying the inside and outside clearances for a slab interference condition

1 Create a stair that intersects with a slab. For information about
creating stairs, see Using Stair Tools to Create Stairs on page 2107.

2 Double-click the stair to open the Properties palette.

3 Click the Design tab, expand Advanced, and expand Interference.

4 Set the size of the interference condition:

Then…If you want to…

enter a value for Headroom height.specify the height above the treads
for the interference condition

enter values for Left and Right
Clearance.

specify the left and right side clear-
ances for the interference condition
for straight and multi-landing stairs
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Then…If you want to…

enter values for Inside and Outside
Clearance.

specify the inside and outside
clearances for the interference con-
dition for spiral and U-shaped stairs

5 Click in the drawing, not on the stair, to remove the selection.

6 Select the slab to intersect, and click Slab tab ➤ Modify

panel ➤ Interference Condition drop-down ➤ Add  .

7 Select the stair, and press ENTER.

8 Select the shrinkwrap effect, and press ENTER. For more
information about shrinkwrapping, see Working with Interference
Conditions on page 1292.

Creating a slab and stair interference condition
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NOTE Changing the Interference values of the stair changes the size
of the intersection with the slab.

Removing a Stair Interference Condition from a Slab
Use this procedure to remove a stair interference from a slab.

1 Select the slab from which to remove the interference, and click
Slab tab ➤ Modify panel ➤ Interference Condition

drop-down ➤ Remove  .

2 Select the stair, and press ENTER.

Creating an Interference Condition in a Space
Use this procedure to create a stair interference area in a space. When you add
an interference condition between a stair and a space, a box is cut out around
the stair based on the specified headroom height and side clearance.

1 Create a stair that intersects with a space. For information about
creating stairs, see Using Stair Tools to Create Stairs on page 2107.

2 Double-click the stair to open the Properties palette.

3 Click the Design tab, expand Advanced, and expand Interference.

4 Set the size of the interference condition:

Then…If you want to…

enter a value for Headroom height.specify the height above the treads
for the interference condition

enter values for Left and Right
Clearance.

specify the left and right side clear-
ances for the interference condition
for straight and multi-landing stairs

enter values for Inside and Outside
Clearance.

specify the inside and outside
clearances for the interference con-
dition for spiral and U-shaped stairs
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5 Click in the drawing, not on the stair, to remove the selection.

6 Select the space to intersect, and click Space tab ➤ Modify

panel ➤ Interference Condition drop-down ➤ Add  .

7 Select the stair, and press ENTER.

NOTE Changing the Interference values of the stair changes the size
of the intersection with the space.

Removing a Stair Interference Condition from a Space
Use this procedure to remove a stair interference from a space.

1 Select the space from which to remove the interference, and click
Space tab ➤ Modify panel ➤ Interference Condition

drop-down ➤ Remove  .

2 Select the stair, and press ENTER.

Creating an Interference Condition in a Curtain Wall
Use this procedure to create a stair interference area in a curtain wall. When
you add an interference condition between a stair and a curtain wall, a box
is cut out around the stair based on the specified headroom height and left
and right side clearances for straight and multi-landing stairs or inside and
outside clearances for spiral and U-shaped stairs. You have the option of cutting
the infills, frames and mullions of the curtain wall.
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Specifying the left and right side clearances for a curtain wall interference condition
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Specifying the inside and outside clearances for a curtain wall interference condition

1 Create a stair that intersects with a curtain wall. For information
about creating stairs, see Using Stair Tools to Create Stairs on page
2107.

2 Double-click the stair to open the Properties palette.

3 Click the Design tab, then expand Advanced, and expand
Interference.

4 Set the size of the interference condition:

Then…If you want to…

enter a value for Headroom height.specify the height above the treads
for the interference condition

enter values for Left and Right
Clearance.

specify the left and right side clear-
ances for the interference condition
for straight and multi-landing stairs
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Then…If you want to…

enter values for Inside and Outside
Clearance.

specify the inside and outside
clearances for the interference con-
dition for spiral and U-shaped stairs

5 Click in the drawing, not on the stair, to remove the selection.

6 Select the curtain wall to intersect, and click Curtain Wall
tab ➤ Modify panel ➤ Interference Condition drop-down ➤ Add

 .

7 Select the stair.

8 Specify whether to apply the interference condition to the infill,
frames or mullions of the curtain wall.

Removing a Stair Interference Condition from a Curtain Wall
Use this procedure to remove a stair interference from a curtain wall.

1 Click in the drawing, not on the stair, to remove the selection.

2 Select the curtain wall from which to remove the interference,
and click Curtain Wall tab ➤ Modify panel ➤ Interference

Condition drop-down ➤ Remove  .

3 Select the stair, and press ENTER.

Creating an Interference Condition in a Door/Window Assembly
Use this procedure to create a stair interference area in a door/window
assembly. When you add an interference condition between a stair and a
door/window assembly, a box is cut out around the stair based on the specified
headroom height and side clearance. You have the option of cutting the infills,
frames, and mullions of the door/window assembly.

1 Create a stair that intersects with a door/window assembly. For
information about creating stairs, see Using Stair Tools to Create
Stairs on page 2107.

2 Double-click the stair to open the Properties palette.
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3 Click the Design tab, expand Advanced, and expand Interference.

4 Set the size of the interference condition:

Then…If you want to…

enter a value for Headroom height.specify the height above the treads
for the interference condition

enter values for Left and Right
Clearance.

specify the left and right side clear-
ances for the interference condition
for straight and multi-landing stairs

enter values for Inside and Outside
Clearance.

specify the inside and outside
clearances for the interference con-
dition for spiral and U-shaped stairs

5 Click in the drawing, not on the stair, to remove the selection.

6 Select the door/window assembly to intersect, and click
Door/Window Assembly tab ➤ Modify panel ➤ Interference

drop-down ➤ Add  .

7 Select the stair.

8 Specify whether to apply the interference condition to the infill,
frames, or mullions of the door/window assembly.

Removing a Stair Interference Condition from a Door/Window
Assembly

Use this procedure to remove a stair interference from a door/window assembly.

1 Click in the drawing, not on the stair, to remove the selection.

2 Select the door/window assembly from which to remove the
interference, and click Door/Window Assembly tab ➤ Modify

panel ➤ Interference drop-down ➤ Remove  .

3 Select the stair, and press ENTER.
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Changing the Interference Size of a Stair
Use this procedure to control the size of the stair interference area.

Specifying headroom height and side clearance for a stair and a space object

1 Double-click the stair to open the Properties palette.

2 Click the Design tab, expand Advanced, and expand Interference.

3 Set the size of the interference condition:

Then…If you want to…

enter a value for Headroom height.specify the height above the treads
for the interference condition

enter values for Left and Right
Clearance.

specify the left and right side clear-
ances for the interference condition
for straight and multi-landing stairs

enter values for Inside and Outside
Clearance.

specify the inside and outside
clearances for the interference con-
dition for spiral and U-shaped stairs
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Changing the Alignment of a U-Shaped Stair
Use this procedure to change the alignment and the alignment offset of a
U-shaped stair. These fields are available only when you select a U-shaped
stair.

1 Double-click a U-shaped stair to open the Properties palette.

2 Click the Design tab, expand Advanced, and expand Constraints.

3 Specify the alignment of a U-shaped stair:

Then…If you want to…

select Free for Alignment type.place the treads and risers where
necessary to complete the stair

select Tread to Tread for Alignment
type.

align the tread of the up flight to
the tread of the down flight

select Tread to Riser for Alignment
type.

align the tread of the up flight to
the riser of the down flight

select Riser to Riser for Alignment
type.

align the riser of the up flight to the
riser of the down flight

4 Specify a value for Alignment offset.

When you select Tread to Tread, Tread to Riser, or Riser to Riser,
you can specify an offset value. A positive offset value means that
the down flight tread location is closer to the landing than the
up flight tread location.

Specifying tread to riser alignment offsets

5 Specify Upper flight or Lower flight for Extend alignment.

6 Specify a value for Uneven tread on. This value specifies which
flight will be longer if the total number of treads is uneven. Select
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Upper flight to place the uneven tread on the upper flight. Select
Lower flight to place the uneven tread on the lower flight.

Changing the Components of a Flight
Use this procedure to change the tread, riser thickness, and nosing length for
each stair. You can also turn on or off the display of the tread and riser.

NOTE If component settings are unavailable, they are controlled by the stair style,
and you cannot change them for individual stairs.

1 Double-click the stair to open the Properties palette.

2 Click the Design tab, expand Advanced, and expand Worksheets.

3 Click  next to Components.

4 Under Flight Dimensions, select or clear the Plan display of treads
and risers.

When the tread or riser display is off, the corresponding thickness
becomes unavailable.

5 Specify the flight dimensions:

Then…If you want to…

select Tread, and enter a value for
Tread Thickness.

specify the thickness of each tread

select Riser, and enter a value for
Riser Thickness.

specify the thickness of the riser
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Then…If you want to…

enter a value for Nosing Length.specify the length of the edge of a
stair tread that projects over the
riser

select Sloping Riser.specify sloping risers

6 Click OK.

Changing the Components of a Landing
Use this procedure to change the landing thickness and specify additional
width for stair landings.

NOTE If component settings are unavailable, they are controlled by the stair style,
and you cannot change them for individual stairs.

1 Double-click the stair to open the Properties palette.

2 Click the Design tab, expand Advanced, and expand Worksheets.

3 Click  next to Components.

4 Enter a value for Landing Thickness.

5 Enter a value for Additional Width.
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NOTE The setting for additional landing width affects only true
landings of Multi-landing and U-shaped stairs. The automatic landings
introduced by flight height limits and terminating landings are not
affected by this setting.

The type of landing and the justification of the stair determine
where the additional width is added to the landing.

Adding width to a quarter landing based on stair justification
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Adding width to a half landing based on stair justification

6 Click OK.

About the Dimensions of Landing Components
Landing components are specified as part of the style, but apply only to
multi-landing and U-shaped stairs. Stringer dimensions are specified for the
flight and landing in a single table. The flight stringer type (slab, housed, or
saddled) controls what is available for the landing (total depth only for housed
and ramp, waist depth for all types). If the flight has no stringers, the landing
has none.

All landings of a single stair initially use the same dimensions. You can then
customize each one separately by grip-stretching or projection. Horizontal
positions and the widths of stringers are identical between flights and landings.

Landing extension values apply only to U-shaped and multi-landing stairs
with flat landings. Landing-specific dimensions are ignored for turn landings.
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The default values for styles in the Stair Styles drawing are specified in
accordance with the most common situation for stairs.

If the option to resolve the meeting of flight and landing stringers is off, the
flight stringer terminates at the landing.

Changing the Extension of a Landing
Use this procedure to change the distances between landings and treads and
the stringer resolution for stairs. You can differentiate the size of landing
components from those used for the stair flights.

NOTE If settings for landing extensions are unavailable, they are controlled by
the stair style, and you cannot change them for individual stairs.

1 Double-click the stair to open the Properties palette.

2 Click the Design tab, expand Advanced, and expand Worksheets.

3 Click  next to Landing extensions.

4 Specify the extension distances:

Then…If you want to…

enter a value for Distance to First
Tread DOWN. To extend the land-

add to the distance to the first tread
on the down side of the landing

ing down by a single tread, select
Add Tread Depth.
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Then…If you want to…

enter a value for Distance to First
Tread UP. To extend the landing up

add to the distance to the first tread
on the up side of the landing

by a single tread, select Add Tread
Depth.

For more information about landing extensions and stringer
resolution, see About the Dimensions of Landing Components
on page 2253.

5 Under Stringer Resolution, select Extend Landings to Merge Flight
Stringers with Landing Stringers to automatically merge the flight
stringers with the landing stringers.

This provides additional landing extension, if necessary, to make
the flight stringers meet the landing stringers without any
discontinuity.

NOTE Automatic landing settings are always controlled by the stair
style.

Stairs created in earlier versions of the software have the setting for Extend
Landings to Prevent Risers and Treads Sitting Under Landings turned on. This
setting should be turned off to achieve flush or rectangular landings, but it
will change the position of the top or bottom of the stair, which may require
adjusting other building objects.

6 Click OK.

Specifying Stair Component Display by Cut Plane Elevation
Use this procedure to specify the display of stair components in plan view
depending on their occurrence above or below the cut plane elevation. You
can specify the above cut plane, up, and down component properties for each
type of stair component.

Cut Plane Elevation Display Properties

1 Take a look at the display properties for these kinds of stair
components.

Select the stair and click Stair tab ➤ General panel ➤ Edit Style

drop-down ➤ Stair Style  .
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2 Click the Display Properties tab.

3 Verify that Plan is the default Display Representation, and then

click  (Edit Display Properties).

4 Click the Layer/Color/Linetype tab.

There are components to support the representation of stair
components above the cut plane elevation so that the down stair
components are only used to display the stair components that
occur below the current level.

5 Click the Other tab.

For stairs created in versions of Autodesk Architectural Desktop
earlier than 2004, the Override Display Configuration Cut Plane
option is selected by default. In the current version, this option
is cleared by default, and the display of stair components is
handled automatically by specific display configurations for each
level.
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When the Override Display Configuration Cut Plane option is
selected, the cut height elevation is measured from the bottom
of each stair run. The up display components and the above cut
plane display components above the current level are displayed,
and the down display components are not.

Specifying cut plane elevation with display configuration override

When the Override Display Configuration Cut Plane option is
cleared, the cut height elevation is measured from the current
level. The up display components above the current level are
displayed, as are the down display components below the current
level.

Specifying cut plane elevation without display configuration override

6 Make changes to the display of stair components as needed, then
click OK twice.

Specifying Stair Display at Different Levels

1 The following procedure provides an example of how to specify
the display of stair components at different levels in a stair tower.

Create a U-shaped stair, 5’-0” (1520 mm) wide and 12’-0” (3650
mm) high to represent the lobby stairs.

2 Create a second U-shaped stair, 3’-8” (1120 mm) wide and 10’-0”
(3050 mm) high, and locate it 12’-0” (1520 mm) above the lobby
stairs.
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3 Create a third U-shaped stair, 3’-8” (1120 mm) wide and 10’-0”
(3050 mm) high, and locate it 10’-0” (3050 mm) above the second
set of stairs.

The following illustration shows how the stair tower should appear
with added floor slabs in a 3D view:

3D view of stair tower

4 Save this stair tower configuration as the base stair drawing file.

5 Create 4 new host drawing files as follows:

■ First Floor

■ Second Floor

■ Third Floor

■ Roof Level

The following illustration shows how the levels should appear in
an elevation view:
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Elevation view of stair tower

6 Open the First Floor drawing, and attach the base stair as an Xref
at an elevation of 0’-0” (0 mm).

7 Verify that the Medium Detail display configuration is current.

8 View the first floor lobby stairs in plan.

Stair display components at first floor

9 The up display components above the first floor are displayed, as
are the above cut plane display components, in outline with a
dashed linetype.

10 Open the Second Floor drawing, and attach the base stair as an
Xref at an elevation of -12’-0” (-3650 mm).

11 Verify that the Medium Detail Intermediate Level display
configuration is current.

12 View the second floor stairs in plan.
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Stair display components at second floor

13 The up display components above the second floor are displayed,
as are the down display components below the second floor.

14 Open the Third Floor drawing, and attach the base stair as an Xref
at an elevation of -22’-0” (-6700 mm).

15 Verify that the Medium Detail Intermediate Level display
configuration is current.

16 View the third floor stairs in plan.

Stair display components at third floor

17 The up display components above the third floor are displayed,
as are the down display components below the third floor.

18 Open the Roof Level drawing, and attach the base stair as an Xref
at an elevation of -32’-0” (-9750 mm).

19 Verify that the Medium Detail Top Level display configuration is
current.

20 View the roof level stairs in plan.
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Stair display components at roof level

21 Only the down display components below the roof level are
displayed.

Changing the Display of an Overlapping Stair
Use this procedure to create an overlapping stair and set the display properties
to view the overlapped section correctly. For this example, we will display all
components of the stair above the overlap section outlined in red.

To set the stair display, the Plan Overlapping display representation needs to
be turned on and specific components need to be set. For overlapping stairs,
in addition to the usual up and down groups, four other groups of display
components are available in Plan Overlapping.

DefinitionDisplay representation group

Stair components below the cut height that
are above the overlap section

“components” up (above overlap)

Stair components above the cut height that
are above the overlap section

“components” down (above overlap)

Stair components below the cut height that
are below the overlap section

“components” up (below overlap)

Stair components above the cut height that
are below the overlap section

“components” down (below overlap)

1 Open the tool palette that you want to use, and select a stair tool.

If necessary, scroll to display the tool that you want to use.
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NOTE Alternatively, click Home tab ➤ Build panel ➤ Stair

drop-down ➤ Stair  .

2 On the Properties palette, click the Design tab, expand Basic, and
expand General.

3 Select a style.

4 In Shape, select Multi-landing.

5 Specify the 1/2 landing for Turn type.

6 Draw a multi-landing stair that overlaps itself.

Viewing an overlapping stair condition

7 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

8 Expand Sets, and select the current (bold) display set.

9 Click the Display Representation Control tab.

10 Scroll to the Stair object.

11 Turn on Plan Overlapping in addition to the current display
representation.

12 Click OK.

13 Select the stair, right-click, and click Edit Object Display.

14 Click the Display Properties tab.

15 Click Object Override for Plan, Plan Low Detail, or Plan High
Detail (whichever is displayed in the current display set). Select
all the components, turn off visibility, and click OK.

16 Click Object Override for Plan Overlapping. Select the desired
components and turn on visibility. For this example, turn on
visibility for Riser up, Nosing up, Path up, Outline up, Riser down,
Nosing down, Path down, Outline down, Riser down (above
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overlap), Nosing down (above overlap), Path down (above
overlap), Outline down (above overlap), Riser down (below
overlap), Nosing down (below overlap), Path down (below
overlap), and Outline down (below overlap).

17 Select Riser down (above overlap), Nosing down (above overlap),
Path down (above overlap), and Outline down (above overlap).
Select any of the colors from the selected components; then select
red in the Select Color dialog box.

NOTE If the stair style includes stringers, they should be added to
the set of components.

18 Click OK twice.

Applying Tool Properties to an Existing Stair
Use this procedure to apply the properties of a stair tool to one or more existing
stairs. The properties include the stair style and any other settings specified
in the tool you select.

1 Open the tool palette that you want to use.

If necessary, scroll to display the tool that you want to use.

2 Right-click a stair tool, and click Apply Tool Properties to Stair.

3 Select the stairs, and press ENTER.

4 Edit the properties of the stairs in the Properties palette, if
necessary.

NOTE Some tool properties cannot be applied to existing stairs. For example,
stair shape and turn type do not change. In addition, some properties may be
incompatible with existing stairs. For example, a stair that has a vertical orientation
of Down cannot terminate with a landing.

Changing the Location of a Stair
Use this procedure to relocate a stair by changing the coordinate values of its
insertion point. The stair also has an orientation with respect to the WCS or
the current UCS. For example, if the top and bottom of the stair are parallel
to the XY plane, its normal is parallel to the Z axis. You can change the
orientation of the stair by aligning its normal with another axis. You can also
rotate the stair on its plane by changing the rotation angle.
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For information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use Coordinates and Coordinate Systems” in
AutoCAD help.

1 Double-click the stair you want to change.

2 In the Properties palette, click the Design tab, expand Basic, and
expand Location.

3 Select  next to Additional information.

4 Specify the location of the stair:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the stair

make the normal of the stair parallel
to the Z axis: under Normal, enter
1 for Z, and enter 0 for X and Y.

locate the stair on the XY plane

make the normal of the stair parallel
to the X axis: under Normal, enter
1 for X, and enter 0 for Y and Z.

locate the stair on the YZ plane

make the normal of the stair parallel
to the Y axis: under Normal, enter
1 for Y, and enter 0 for X and Z.

locate the stair on the XZ plane

enter a new value for Rotation
Angle.

change the rotation of the stair

5 Click OK.

Specifying the Materials of a Stair
Use this procedure to select a different material for components of an
individual stair.

To change the materials assigned to all stairs of the same stair style, see
Assigning Materials to a Stair Style on page 2288.
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NOTE If a material assignment does not determine the display properties of a stair
component, you can change the properties of the display component as described
in Specifying the Display Properties of a Stair Style on page 2289.

1 Select the stair you want to change, right-click and click Edit
Object Display.

2 To verify that the material assignment determines the display
properties of the component, click the Display Properties tab,
select the display representation where you want the changes to

appear, and click  .

NOTE Only the Model display representation supports properties By
Material.

3 Click the Layer/Color/Linetype tab, verify that By Material is
selected for the component, and click OK.

4 Click the Materials tab.

5 Select the component you want to change, select Object Override,
and select a different material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Although you can edit a material definition from this
dialog box, any changes you make to the material definition apply
to all objects that are assigned the material.

6 Click OK.

Changing the Display Properties of Individual Stairs
In most cases, you want the appearance of stairs that belong to the same style
to be consistent throughout a drawing. However, in certain instances, you
may need to override a display property for an individual stair to achieve a
specific result. All the display properties that you can specify in stair styles are
available for individual stairs. You can override the following specifications:

■ Whether the display properties of stair components are determined by
material assignments
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■ The layer, color, and linetype of the display components of the stair

■ The cut plane height and the display of components relative to the cut
plane

■ Other specific stair display information, such as riser numbering

When you change the display properties of an individual stair, the changes
apply only to that stair. Other stairs of the same style are not affected. To
change the display properties of all stairs of a specific stair style, see Stair Styles
on page 2274.

Specifying the Layer, Color, and Linetype of a Stair
Use this procedure to change the following display properties of the
components of an individual stair:

■ Visibility (component is on or off)

■ By Material (a material assigned to the display component determines its
display properties)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

To change these display properties for all stairs of the same stair style, see
Specifying the Display Properties of a Stair Style on page 2289.

NOTE If a material assignment determines the properties of a stair display
component, you can change the properties of the display component by clearing
By Material or by overriding the material assignment with a different material. For
more information, see Specifying the Materials of a Stair on page 2264.

1 Select the stair you want to change, right-click, and click Edit
Object Display.
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NOTE You can also use the Display tab of the Properties palette to
change the display property settings for a selected object display
component in the current display representation. For more
information, see Using the Properties Palette to Change Display
Properties on page 793.

2 Click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 Click the Layer/Color/Linetype tab.

6 Select the component to change, and select a different setting for
the property.

7 Click OK twice.

Specifying the Cut Plane Display of a Stair
Use this procedure to specify the properties of one or more cut planes for an
individual stair. Cut plane display properties apply only to display
representations, such as Plan, that are used in the Top view (plan view) of a
drawing.

1 Double-click the stair you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all stairs in the drawing, select
Drawing default setting. To apply changes to all stairs of this style,
select Stair Style:<style name>. For more information on styles, see
Stair Styles on page 2274.

5 If necessary, expand Object Display Properties ➤ Cut Plane.

6 For Override cut plane, specify whether you want to override the
global cut plane defined for the current display configuration.
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7 If you selected Yes for Override cut plane, enter a value for Height
to define the cut plane for this object.

8 For Cut line angle, enter a value to specify the angle between the
stair cut lines.

9 For Cut line distance, enter a value to specify the distance between
the 2 cut lines.

10 If you selected No for Override cut plane, for Show entire stair
down, specify whether you want to display the stair’s down display
components (Stringer down, Riser down, Nosing down, and so
on; for more information, see Specifying Stair Component Display
by Cut Plane Elevation on page 2255).

You can also access and modify these same cut plane settings through the
stair’s context menu, as follows:

1 Select the stair you want to change, right-click, and click Edit
Object Display.

2 Click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 Click the Other tab.

6 In the Cut Plane panel, change the settings as needed.
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7 Click OK twice.

Specifying the Display of Other Characteristics of a Stair
Use this procedure to specify other display properties for an individual stair,
such as how to display the arrow in the path, which Display Path to show,
and what type of break mark to use in the stair display. These display properties
apply only to display representations, such as Plan, that are used in the Top
view (plan view) of a drawing.

1 Double-click the stair you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all stairs in the drawing, select
Drawing default setting. To apply changes to all stairs of this style,
select Stair Style:<style name>. For more information on styles, see
Stair Styles on page 2274.

5 If necessary, expand Object Display Properties ➤ Advanced, and

click  next to Additional properties.

6 Specify the additional display properties for the stair:

Then…If you want to…

enter a value for Size.change the display size of the arrow
and break mark

enter a value for Offset.change the offset location of the
arrow display
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Then…If you want to…

select a style for Dim Style.

NOTE If a dimension style oth-
er than Standard is used for the
arrow, and you want the arrow
size to be controlled by the di-
mension style, select Arrow Size
from Dimension Style Only. This
is the default for all previous
version drawings. If you do not
select this option, the size of the
arrow is multiplied by the arrow
size setting.

change the dimension style used
for the arrow display

select a shape for Shape. Curved
adds an arc when the stair line

change the shape of the stair line

changes. Straight displays an angle
when the stair line changes.

select Cut Plane - Parallel for Apply
to and make sure that Draw for
Each Flight is not selected.

display the arrow at the end of each
cut plane pointing in the same dir-
ection throughout the length of the
stair

select Cut Plane - Parallel for Apply
to and make sure that Draw for
Each Flight is selected.

display the arrow at the end of each
cut plane and at the end of each
flight pointing in the same direction

select Entire Stair for Apply to and
make sure that Draw for Each Flight
is not selected.

display the arrow at the end of the
entire stair

select Cut Plane - Opposite for Ap-
ply to.

display the arrow on each side of
the cut plane

select Graphics path or Construc-
tion line for Display Path.

change which stair line is displayed

under Break Mark, select a mark for
Type.

change the type of break mark that
is displayed at the cut plane
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Then…If you want to…

select Custom Shape for Type, and
then select a block for Block.

specify a custom break mark to dis-
play at the cut plane

7 Click OK.

You can also access and modify these same settings through the stair’s context
menu, as follows:

1 Select the stair you want to change, right-click, and click Edit
Object Display.

2 Click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 Click the Other tab.

6 Specify the additional display properties as needed.

7 Click OK twice.

Specifying the Riser Numbering Display for Individual Stairs
Use this procedure to define and display riser numbers for individual stairs.
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1 Double-click the stair you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all stairs in the drawing, select
Drawing default setting. To apply changes to all stairs of this style,
select Stair Style:<style name>. For more information on styles, see
Stair Styles on page 2274.

5 If necessary, expand Object Display Properties ➤ Advanced, and

click  next to Riser numbering.

6 Specify the riser numbering display properties for the stair:

Then…If you want to…

select a style for Text Style, or click

 to edit the text style.

change the text style of the riser
numbers

select an alignment for Text Align-
ment.

change the alignment of the riser
numbers

select an orientation for Text Orient-
ation.

change the orientation of the riser
numbers

enter a value for Text Height.change the text height of the riser
numbers

select Left, Center or Right for Justi-
fy to.

change the location to which the
numbers are justified

enter a value for X Offset. This is
relative to the selected position of
the riser.

change the location of the numbers
along the length of the stair flight

enter a value for Y Offset. This is re-
lative to the selected position of the
riser.

change the location of the numbers
to the left or right
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Then…If you want to…

enter a value for First Riser Number.set the first number for the riser
numbering

select Number Final Riser.number the last riser in the stair

7 Click OK.

You can also access and modify these same cut plane settings through the
stair’s context menu, as follows:

1 Select the stair you want to change, right-click, and click Edit
Object Display.

2 Click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 Click the Riser Numbering tab.

6 Specify riser numbering settings as needed.

7 Click OK twice.

Attaching Hyperlinks, Notes, or Files to a Stair
Use this procedure to attach hyperlinks, notes, or files to a stair. You can also
edit hyperlinks and notes, and edit or detach reference files from a stair.

1 Select the stair to which you want to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click  next to Hyperlink, and specify the
link.

For more information about adding hyperlinks, see “Add
Hyperlinks to a Drawing” in AutoCAD help.

4 Click OK.

5 To add a note, click  next to Notes, and enter the note.
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6 Click OK.

7 To add a reference file, click  next to Reference documents,
and attach, edit, or detach a reference file:

Then…If you want to…

click, select a file, click Open and
click OK.

attach a reference file

click the document’s Description
field. Enter the description, and
click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

NOTE If the referenced file is
an AutoCAD drawing, you must
click OK in the Reference Docs
dialog before the drawing is
displayed.

edit a reference file

select the file name, and click 
.

detach a reference file

8 Click OK.

Stair Styles
A stair style is a group of properties assigned to a stair that determines the
appearance and other characteristics of the stair.

You can use a stair style to control properties for all stairs that use that style,
rather than changing properties for each stair in the drawing. Various styles
exist in the templates for common stair configurations, such as steel-pan,
ramp - concrete, and wood-housed. Within the stair style, you can specify the
dimensions, landing extensions, components, and display properties of the
stair.
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Stair Components and Design Rules

In a stair style, you specify these properties of stair components:

■ risers and treads

■ stringers

■ landings

■ landing extensions

Design rules determine the code limits for maximum, optimum, and minimum
slopes for the stair style.

Display Components of Stairs

Display components determine the graphical characteristics, such as color
and linetype, of stair components. Other display properties you can change
for a stair style include cut plane, stair line, arrow properties, and the break
mark.

Using Materials in Stair Styles

You can use materials to control how stairs of each style are displayed in a
drawing. You assign materials to the stair components in the style. The
components are then displayed using the display properties of the assigned
materials.

Creating Tools from Stair Styles

You can create a stair tool from any stair style. You can drag the style from
the Style Manager onto a tool palette. You can then specify default settings
for any stair created from the tool. For more information, see Creating a Stair
Tool on page 2152.

Managing Stair Styles
To create, copy, or purge styles, you access the Style Manager. The Style
Manager provides a central location in AutoCAD Architecture for working
with styles from multiple drawings and templates. For more information about
using the Style Manager, see Style Manager Overview on page 870.
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Creating a Stair Style
Use this procedure to create a stair style. You can create a style that uses default
style properties by copying an existing style. After you create the style, you
edit the style properties to customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Architectural Objects, and expand Stair Styles.

3 Create a stair style:

Then…If you want to…

right-click Stair Styles, and click
New.

create a style with default properties

right-click the stair style you want
to copy, and click Copy. Right-click,
and click Paste.

create a style from an existing style

4 Enter a name for the new stair style.

5 Edit the new stair style:

Then…If you want to…

see Specifying the Design Rules of
a Stair Style on page 2277.

specify design rules for the style

see Specifying the Stringers of a
Stair Style on page 2279.

specify the stringer properties for
the style

see Specifying the Components of
a Stair Style on page 2283.

specify the thicknesses and widths
of treads, risers, and landings for
the style

see Specifying the Landing Exten-
sion of a Stair Style on page 2285.

specify the landing extension prop-
erties of the style

see Specifying the Layer/Color/Line-
type of a Stair Style on page 2290.

specify display properties, such as
layer, color, and linetype, for the
components of the style
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Then…If you want to…

see Specifying the Display of Other
Characteristics of a Stair Style on
page 2292.

specify cut plane properties, arrow
properties, and other display prop-
erties of the style

see Adding Notes and Files to a
Stair Style on page 2297.

add notes and files to the style

6 When you finish specifying the properties of the stair style, click
OK.

7 If you want to assign the style to a stair tool, drag the style from
the Style Manager to a tool palette.

You can later rename the tool and specify other properties for it
as described in Creating a Stair Tool on page 2152.

8 Click OK.

Specifying the Design Rules of a Stair Style
Use this procedure to specify the minimum, maximum, and optimal code
limits for the riser height and tread depth, and to specify the stair calculator
rules.

Specifying stair design rules

1 Open a tool palette that has a stair tool.

2 Right-click a stair tool, and click Stair Styles.

NOTE Alternatively, select a stair in the drawing, and click Stair

tab ➤ General panel ➤ Edit Style drop-down ➤ Stair Styles  .
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3 Select the stair style you want to change.

4 Click the Design Rules tab.

5 Specify the default Riser Height and Tread Depth for Minimum
Slope, Optimum Slope, and Maximum Slope.

NOTE Use values that represent the actual dimensions of the tread
and riser components you want to create, and not just the ratios of
these dimensions.

Subject to the constraints of the calculator rules and the fact that
the tread heights must be an even divisor of the floor-to-floor
height, the software gets as close as possible to the selected optimal
tread length and riser height.

6 To change the default stair calculator, select Use Rule Based
Calculator.

The fields in the Calculator Rule section become available for
editing.

7 When you finish changing the properties of the stair style, click
OK.
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Specifying the Stringers of a Stair Style
Use this procedure to include stringers with the stair style. A stair style can
have one or more stringers. You can specify the properties of each stringer. If
the style uses stringers, you can specify the depth of the waist at flights and
landings, as well as have center stringers with mitered or curved corners at
landing turns. For Ramp or Housed stringers, you can also specify the total
depth at flights and landings.

1 Open a tool palette that has a stair tool.

2 Right-click a stair tool, and click Stair Styles.

NOTE Alternatively, select a stair in the drawing, and click Stair

tab ➤ General panel ➤ Edit Style drop-down ➤ Stair Styles  .

3 Select the stair style you want to change.

4 Click the Stringers tab.

If the style does not use stringers, proceed to step 6.

5 Add or remove stringers:

Then…If you want to…

click Add.add a stringer to the stair style

select the stringer you want to du-
plicate, and click Copy.

add an identical stringer to the list
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Then…If you want to…

select the stringer, and click Re-
move.

delete a stringer from the list

6 Specify the properties of each stringer:

Then…If you want to…

select the current name, and enter
a new name.

specify the name of a stringer

click the current Type, and select
Saddled or Housed.

specify the type of stringer

click the current alignment, and
select Align Left, Align Right, Cen-
ter, or Full Width.

specify the alignment of a stringer

enter a value for Width.specify the width of a stringer

enter a value for Offset.specify the offset of a stringer

under Flight, enter a value for
Waist.

specify the flight waist

under Flight, enter a value for Total.specify the flight total

under Landing, enter a value for
Waist.

specify the landing waist

under Landing, enter a value for
Total.

specify the landing total

select Truncate for Cleanup.stop the stringer at a landing

select Cleanup for Cleanup.allow the stringer to continue under
a landing

clear Curve center stringer at turnsspecify mitered corners for a center
stringer at a turn or landing
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7 Click Slab for Type to edit the slab settings:

Then…If you want to…

under Flight, enter a value for
Waist.

specify the thickness of the slab at
flights

under Landings, enter a value for
Waist.

specify the thickness of the slab at
landings

8 When you finish changing the properties of the stair style, click
OK.

Specifying Mitered Corners for Center Stringers
Use this procedure to specify mitered corners for center stringers at landings
and turns. You can specify this option when working with multi-landing,
u-shaped, and custom stairs. You cannot specify this option when working
with straight or spiral stairs.

1 Open a tool palette that has a stair tool.

2 Right-click a stair tool, and click Stair Styles.

NOTE Alternatively, select a stair in the drawing, and click Stair

tab ➤ General panel ➤ Edit Style drop-down ➤ Stair Styles  .

3 Select the stair style you want to change.

4 Click the Stringers tab.
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5 Clear Curve center stringers at turns.

6 Click OK.

Curved and mitered center stringers at landing turns
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With the Curve center stringers at turns option cleared, the center
stringer is mitered to match the angle of the landing turn. In most
cases, this will be a right angle, but any other angle is also possible.

Mitered center stringers at angled landing turns

Specifying the Components of a Stair Style
Use this procedure to specify the display of treads and risers and edit the
thicknesses and widths of treads, risers, and landings. Also, you can specify
whether these properties of the style are allowed to vary with individual stairs.

1 Open a tool palette that has a stair tool.

2 Right-click a stair tool, and click Stair Styles.

NOTE Alternatively, select a stair in the drawing, and click Stair

tab ➤ General panel ➤ Edit Style drop-down ➤ Stair Styles  .
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3 Select the stair style you want to change.

4 Click the Components tab.

5 Specify whether stairs of this style can vary:

Then…If you want to…

select Allow Each Stair to Vary.specify flight dimensions, such as
tread thickness, riser thickness, and
nosing length, when you add or
modify stairs

clear Allow Each Stair to Vary.require that all stairs of this style use
the flight dimension settings of the
style

NOTE If Allow Each Stair to Vary is checked, changes on this tab do
not affect existing stairs. To make these stairs match the style settings,
select the stair, display its properties, display the Components
worksheet, and click Reset to Style Values.

6 Turn the display of treads and risers on or off.

If tread is off, the tread thickness and landing thickness become
unavailable.

2284 | Chapter 28    Stairs



7 Specify the flight dimensions:

Then…If you want to…

enter a value for Tread Thickness.specify the thickness of treads

enter a value for Riser Thickness.specify the thickness of risers

enter a value for Nosing Length.specify the length of the edge of a
stair tread that projects over the
riser

select Sloping Riser.specify sloping risers

8 Specify the landing dimensions:

Then…If you want to…

enter a value for Landing Thickness.specify the thickness of landings

enter a value for Additional Width.specify additional width for landings

9 When you finish changing the properties of the stair style, click
OK.

Specifying the Landing Extension of a Stair Style
Use this procedure to change the distances between landings and treads and
the stringer resolution of stairs. You can differentiate the size of landing
components from those used for the stair flights.

1 Open a tool palette that has a stair tool.

2 Right-click a stair tool, and click Stair Styles.

NOTE Alternatively, select a stair in the drawing, and click Stair

tab ➤ General panel ➤ Edit Style drop-down ➤ Stair Styles  .

3 Select the stair style you want to change.
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4 Click the Landing Extensions tab.

5 Specify whether stairs of this style can vary:

Then…If you want to…

select Allow Each Stair to Vary.specify stringer resolution and exten-
sion dimensions, such as distance
to first tread up and distance to first
tread down, when you add or
modify stairs

clear Allow Each Stair to Vary.require that all stairs of this style use
the extension dimension settings of
the style

6 Specify extension distances:

Then…If you want to…

enter a value for Distance to First
Tread DOWN. To extend the land-

increase the distance to the first
tread on the down side of the
landing ing down by a single tread, select

Add Tread Depth.

enter a value for Distance to First
Tread UP. To extend the landing up

increase the distance to the first
tread on the up side of the landing
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Then…If you want to…

by a single tread, select Add Tread
Depth.

7 Select Extend Landings to Merge Flight Stringers with Landing
Stringers.

This option extends the landing to merge the flight stringers with
the landing stringers.

8 Select Extend Landings to Prevent Risers and Treads Sitting Under
Landings.

This option is on by default for all stairs from earlier-release
drawings. Clear it to allow the creation of flush rectangular
landings.

9 When landings are placed automatically, their length and location
are specified in Landing Length and Landing Location.

Then…If you want to…

enter a value for Landing Length.set the size of automatic landings

select Top, Middle, or Bottom for
Landing Location.

set the placement of automatic
landings

10 When you finish changing the properties of the stair style, click
OK.

Assigning Materials to Components in a Stair Style
A stair consists of a number of components whose display properties can be
determined by the materials assigned to each component. You assign one
material to each physical component of the stair; for example, you assign a
wood or metal material to treads, concrete to a concrete component, and so
on. You assign materials to components in each display representation where
you want the materials to be used.

If you want to use the display properties of the stair style instead of material
display properties, you can turn off the material assignments in the display
properties of the stair style.
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Material definitions consist of display components that correspond to
component types of objects. For example, the 3D body component of a
material is used for all linework in model views.

Stair Materials and Display Components
The following table identifies the material component that corresponds to
each stair component.

Material ComponentStair Component

Model

3D BodyStringer

3D BodyTread

3D BodyLanding

3D BodyRiser

Assigning Materials to a Stair Style
Use this procedure to assign materials to the individual components of a stair
style. When By Material is selected for a component, the component uses the
display properties of the material instead of the style display properties.

You can assign a material to any physical component of the stair. Custom
components and components that are only symbolic graphics do not use
materials for their display properties. For example, a riser is a physical
component that can be assigned a material while the graphics path is a symbol
that cannot be assigned a material.

NOTE If a material assignment does not determine the display properties of a stair
component, you can change the display properties of the stair style as described
in Specifying the Display Properties of a Stair Style on page 2289.

1 Open a tool palette that has a stair tool.

2 Right-click a stair tool, and click Stair Styles.
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NOTE Alternatively, select a stair in the drawing, and click Stair

tab ➤ General panel ➤ Edit Style drop-down ➤ Stair Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

NOTE Only the Model display representation uses materials.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select By Material for any component to which you want to assign
a material, and click OK.

If the setting for By Material is not available, the display of this
component cannot be determined by a material.

9 Click the Materials tab.

10 Select the component you want to change, and select a different
material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Although you can edit a material definition from this
dialog box, any changes you make to the material definition apply
to all objects that are assigned the material.

11 Click OK.

Specifying the Display Properties of a Stair Style
In most cases, you can assign materials to stair components so that the
appearance of stairs that belong to the same style is consistent throughout a
drawing and with other stairs and objects that use the same materials.

If a component cannot be assigned a material, or if you do not want to use
materials but still want consistency among stairs of the same style, you can
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specify the following display properties of the stair components in the stair
style:

■ The layer, color, and linetype of stair components

■ The cut plane height and the display of components relative to the cut
plane

■ Stair cut line extensions and ramp arrows

■ Other specific stair display information, such as riser numbering

Specifying the Layer/Color/Linetype of a Stair Style
Use this procedure to specify how the various components of the stair are
displayed in a particular view. You can change the following display properties
of the components of a stair style:

■ Visibility (on or off)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

■ Plot style (if the drawing uses style-based rather than color-based plotting)

Plan views of stairs include stringers, risers, nosing, path symbols, and stair
outlines. You can specify the visibility of these components for above and
below the cut plane of the stair. Isometric (model) views of stairs include
stringers, treads, and risers.

To change these display properties for an individual stair, see Changing the
Display Properties of Individual Stairs on page 2265.

NOTE If a material assignment determines the display properties of components
in the stair style, you can change the properties of the display component by
clearing By Material. You can also override the material assignment with a different
material. For more information, see Assigning Materials to a Stair Style on page
2288.
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1 Open a tool palette that has a stair tool.

2 Right-click a stair tool, and click Stair Styles.

NOTE Alternatively, select a stair in the drawing, and click Stair

tab ➤ General panel ➤ Edit Style drop-down ➤ Stair Styles  .

3 Select the stair style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select the component to change, and select a different setting for
the property.

9 Click OK.

Specifying the Stair Cut Line Extension Distance
Use this procedure to specify the display of stair cut line extension distance
in plan view.

You can specify the stair cut line extension distance between the edge of the
stair and end of the stair cut line. In the Display Manager, access the
appropriate Stair display representation and then specify the stair cut line
extension distance. A distance of 0 (zero) means the cut line does not extend
past the edge of the stair.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Representation by Object, and scroll to the Stair object.
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3 Expand Stair, and select the appropriate Plan display
representation.

4 Click the Other tab.

5 Under Cut Plane, specify a distance for Cut Line Extension.

Specifying the Display of Ramp Arrows
Use this procedure to specify the display of ramp arrows in plan view.

In the Display Manager, access the appropriate Stair display representation
and then specify the display of a ramp arrow.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Representation by Object, and scroll to the Stair object.

3 Expand Stair, and select the appropriate Plan display
representation.

4 Click the Other tab.

5 Under Stair Line, select Display Ramp Arrows.

Specifying the Display of Other Characteristics of a Stair Style
Use this procedure to specify settings for the cut plane and related symbols.

Plan views of stairs includes stringers, risers, nosing, path symbols, and stair
outlines. You can specify the visibility of these components for above and
below the cut plane of the stair.

1 Open a tool palette that has a stair tool.

2 Right-click a stair tool, and click Stair Styles.
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NOTE Alternatively, select a stair in the drawing, and click Stair

tab ➤ General panel ➤ Edit Style drop-down ➤ Stair Styles  .

3 Select the stair style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 Click Override Display Configuration Cut Plane to change the
elevation of the Display Configuration cut plane for the stair.

NOTE When the Display Configuration Cut Plane is used, stairs display
only from the current floor elevation up to the cut height, and from
the current floor elevation down to the appropriate cut height of the
level below.

9 Enter a value for Elevation.

10 Enter a value for Cut Line Distance to change the space between
the two cut plane lines.

11 Enter a value for Cut Line Angle to change the angle of the stair
cut lines.

12 Specify the display of the cut plane:

Then…If you want to…

enter a value for Elevation. The
space for the cut plane is centered
on the closest tread.

specify the height of the cut plane
measured from the beginning of
the stair

enter a value for Cut Line Distance.specify the width of the cut plane

enter a value for Cut Line Angle.specify the angle of the cut plane

13 Specify the display of the arrow and the stair line:

Then…If you want to…

enter a value for Size.change the display size of the arrow
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Then…If you want to…

enter a value for Offset.change the offset location of the
arrow display

select a style for Dim Style.

NOTE If a dimension style oth-
er than Standard is used for the
arrow, and you want the arrow
size to be controlled by the di-
mension style, select Arrow Size
from Dimension Style Only. This
is the default for all previous
version drawings. If you do not
select this option, the size of the
arrow is multiplied by the arrow
size setting.

change the dimension style used
for the arrow display

select a shape for Shape. Curved
adds an arc when the stair line

change the shape of the stair line

changes. Straight displays an angle
when the stair line changes.

select Cut Plane - Parallel for Apply
to and make sure that Draw for
Each Flight is not selected.

display the arrow at the end of each
cut plane pointing in the same dir-
ection throughout the length of the
stair

select Cut Plane - Parallel for Apply
to and make sure that Draw for
Each Flight is selected.

display the arrow at the end of each
cut plane and at the end of each
flight pointing in the same direction

select Entire Stair for Apply to and
make sure that Draw for Each Flight
is not selected.

display the arrow at the end of the
entire stair

select Entire Stair for Apply to and
make sure that Draw for Each Flight
is selected.

display the arrow at the end of each
flight pointing in the same direction

select Cut Plane - Opposite for Ap-
ply to.

display the arrow on each side of
the cut plane
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Then…If you want to…

select Graphics path, or Construc-
tion line, for Display Path.

change which stair line is displayed

under Break Mark, select a mark for
Type.

change the type of break mark that
is displayed at the cut plane

select Custom Shape for Type, and
then select a block for Block.

specify a custom break mark to dis-
play at the cut plane

14 Specify the display of the break mark:

Then…If you want to…

select an option for Type. The
available options are None, Curved,
Zigzag, and Custom Shape.

change the style of the break mark

select Custom Shape for Type, and
select the desired name for Block.

specify a custom shape for the
break mark

15 Click OK twice.

Specifying the Riser Numbering Display of a Stair Style
Use this procedure to define the display of riser numbers for a stair style.

1 Open a tool palette that has a stair tool.

2 Right-click a stair tool, and click Stair Styles.

NOTE Alternatively, select a stair in the drawing, and click Stair

tab ➤ General panel ➤ Edit Style drop-down ➤ Stair Styles  .

3 Select the stair style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Riser Numbering tab.
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8 Select the riser numbering display properties for the stair style:

Then…If you want to…

select a style for Text Style, or click

 to edit the text style.

change the text style of the riser
numbers

select an alignment for Text Align-
ment.

change the alignment of the riser
numbers

select an orientation for Text Orient-
ation.

change the orientation of the riser
numbers

enter a value for Text Height.change the text height of the riser
numbers

select Left, Center or Right for Justi-
fy to.

change the location to which the
numbers are justified

enter a value for X Offset. This is
relative to the selected position of
the riser.

change the location of the numbers
along the length of the stair flight

enter a value for Y Offset. This is re-
lative to the selected position of the
riser.

change the location of the numbers
to the left or right

enter a value for First Riser Number.set the first number for the riser
numbering

select Number Final Riser.number the last riser in the stair

9 Click OK twice.

Specifying Classifications for a Stair Style
Use this procedure to specify classifications for any classification definition
applied to a stair style.

For more information about creating and applying classification definitions,
see Classification Definitions on page 3872.

1 Open a tool palette that has a stair tool.
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2 Right-click a stair tool, and click Stair Styles.

NOTE Alternatively, select a stair in the drawing, and click Stair

tab ➤ General panel ➤ Edit Style drop-down ➤ Stair Styles  .

3 Select the style that you want to change.

4 Click the Classifications tab.

By default, the classification for all classification definitions is
Unspecified. If no classification definitions are listed, none are
applied to stair styles.

5 For each classification definition, select the classification you want
to apply to the current stair style.

6 Click OK.

Adding Notes and Files to a Stair Style
Use this procedure to enter notes and attach reference files to a stair style. You
can also edit notes and edit or detach reference files attached to the style.

1 Open a tool palette that has a stair tool.

2 Right-click a stair tool, and click Stair Styles.

NOTE Alternatively, select a stair in the drawing, and click Stair

tab ➤ General panel ➤ Edit Style drop-down ➤ Stair Styles  .

3 Select the stair style that you want to change.

4 Click the General tab.

5 To add a description to the stair style, enter it for Description.

6 Click Notes.

7 To add a note, click the Text Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file
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Then…If you want to…

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

9 Click OK.

Stair Winder Styles
A stair winder style is a group of properties assigned to a stair winder that
determines the type of winder used in stairs that contain 1/4 turn or 1/2 turns.

To create, copy, or purge styles, you access the Style Manager. The Style
Manager provides a central location in AutoCAD Architecture for working
with styles from multiple drawings and templates. For more information about
using the Style Manager, see Style Manager Overview on page 870.

Creating a Stair Winder Style
Use this procedure to create a stair winder style. You can create a style that
uses default style properties by copying an existing style. After you create the
style, you edit the style properties to customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Architectural Objects, and expand Stair Winder Styles.

3 Create a stair winder style:

Then…If you want to…

right-click Stair Winder Styles, and
click New.

create a style with default properties

right-click the stair winder style you
want to copy, and click Copy.
Right-click, and click Paste.

create a style from an existing style
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4 Enter a name for the new stair winder style.

5 Edit the new stair winder style. For more information, see
Specifying the Stair Winder Style Settings on page 2299.

6 When you finish specifying the properties of the stair winder
style, click OK.

Specifying the Stair Winder Style Settings
Use this procedure to determine which type of winder is defined for the
selected winder style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Architectural Objects, and expand Stair Winder Styles

NOTE Alternatively, select a stair in the drawing, and click Stair

tab ➤ General panel ➤ Edit Style drop-down ➤ Winder Styles  .

3 Select a Stair Winder Style.

4 Click the Settings tab.
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5 Specify the stair winder settings:

Then…If you want to…

select Use Riser Line.use the riser lines to adjust the
winders

clear Use Riser Line.use the tread lines to adjust the
winders

select Balanced for Winder Type.

NOTE This is the type used by
all earlier-release version stairs
with 1/2 or 1/4 turns.

have the treads turn continuously
along the length of the stair

select Manual for Winder Type.adjust each winder separately

select Single Point for Winder Type.adjust winders based on a single
point and a turn zone

select Adjust Winder Turn and enter
a value for Number of Treads in
Turn.

set a number of winders to use
when Single Point is selected for
Winder Type

NOTE When using the single point type, it is important to clear Use
Riser Line if the turn point will be on the edge or corner of the stair.
Otherwise, the treads will overlap and the stair will be defective,
causing a solution tip icon to display in the drawing.

6 When you finish specifying the properties of the stair winder
style, click OK.

Adding Notes and Files to a Stair Winder Style
Use this procedure to enter notes and attach reference files to a stair winder
style. You can also edit notes and edit or detach reference files attached to the
style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.
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2 Expand Architectural Objects, and expand Stair Winder Styles.

NOTE Alternatively, select a stair in the drawing, and click Stair

tab ➤ General panel ➤ Edit Style drop-down ➤ Winder Styles  .

3 Select a Stair Winder Style.

4 Click the General tab.

5 To add a description to the stair style, enter it for Description.

6 Click Notes.

7 To add a note, click the Text Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

9 Click OK.

Stair Tower Generator
The Stair Tower Generator creates vertically stacked stairs based on a single
stair and selected levels in the building. Optionally, slabs and railings can be
included in the stair tower.

Creating a Stair Tower
You create a stair tower from one stair, which is replicated on selected levels
in the building. You can create a stair tower with all stair shapes except spiral.
The floor-to-floor height and starting elevation of each stair are adjusted to
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match these values for each selected level. The x,y coordinates for each stair
start point are fixed.

NOTE The stair must be in a construct with multiple levels for the stair tower to
be created. For more information, see Constructs on page 400.

1 Create a stair within a construct.

2 Click Home tab ➤ Build panel ➤ Stair drop-down ➤ Stair Tower

 .

3 Select the stair.

4 Select any slabs or railings to be added to the stair tower.

NOTE If you select a slab to include in the stair tower, the slab should
be at the top of the selected stair.

5 In the Select Levels dialog box, select the levels on which the stair
tower generates the stairs.

You can include anchored railings by clicking Include Anchored
Railings, even if they have not been selected in step 3.

6 If the stair you created was U-shaped, you can select Keep Landing
Location while Adjusting U-Shaped Stair to maintain the landing
position instead of the start point of the stair when it is edited.

7 Click OK.

The stair tower is created by adding stairs to the selected levels.
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Generating a Stair Tower From and Existing U-Shaped Stair Run

NOTE If the stair height is different than the floor to floor height, the height of
the stair is changed to match the floor height.
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Modifying a Stair Tower
Once a stair tower has been created, you can modify each stair individually.
You can also change one stair and propagate that change throughout the stair
tower.

1 Select a stair in the tower.

2 Modify the stair.

For more information about modifying stairs, see Editing Stairs
on page 2154.

3 Select the edited stair, right-click, and then click Stair Tower
Generate.

4 Select any slabs or railings to be added to the stair tower.

NOTE If you select a slab to include in the stair tower, the slab should
be at the top of the selected stair.

5 In the Select Levels dialog box, select the levels on which to
change the existing stairs.

You can include anchored railings by selecting Include Anchored
Railings.

6 If the stair you created was U-shaped, you can select Keep Landing
Location while Adjusting U-Shaped Stair to maintain the landing
position instead of the start point of the stair when it is edited.

7 Click OK.

Each selected stair is changed to match the modified stair.
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Railings

Railings are objects that interact with stairs and other objects. You can add railings to existing
stairs, or you can create freestanding railings.

Railings
Railings are objects that interact with stairs and other objects. You can add
railings to existing stairs, or you can create freestanding railings.

Railing Components

Railings can have guardrails, handrails, posts, balusters, and one or more bottom
rails. Additionally, you can add custom blocks to railings.

Railing components

Railing Shapes

You can attach railings to one or both sides of a stair, and you can wrap them
around a landing. You can also attach railings to any other type of AEC object,
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like a massing element. You can create a custom railing by converting a
polyline. Therefore, railings can have a variety of shapes and can be anchored
to a straight stair, a multi-landing stair, a U-shaped stair, or a spiral stair.

Custom Railings

You can create custom railings by specifying custom blocks and profiles to be
used for individual railing components. You can assign profiles to railing
components by style so that you can reuse the custom portion to create detailed
railings.

Railing Styles and Their Properties

You can use a railing style to control properties for all railings that use that
style, rather than changing properties for each railing in the drawing. Various
styles exist in the templates for common railing configurations, such as
guardrail pipe, handrail grip, and handrail round. Within the railing style,
you can specify the rail locations and height, post locations and intervals,
components and profiles, extensions, material assignments, and display
properties of the railing.

Materials in Railings

In AutoCAD Architecture, you can assign materials to a railing. These materials
are displayed in wireframe and working shade views, or when rendered.
Materials have specific settings for the physical components of a railing, such
as the various types of rails and posts, and the baluster. You could, for example,
create a wooden railing with a stainless steel handrail and bottomrail.

Railing in 2D wireframe model and rendered views

AutoCAD Architecture provides a number of predefined materials for common
design purposes, which contain settings for railings. You can use these
predefined materials “as is”, or modify them to your special designs. You can
also create your own materials from scratch.
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For more information, see Specifying the Materials of a Railing Style on page
2365.

Using Railing Tools to Create Railings
Tools provided with AutoCAD Architecture let you quickly place railings using
a railing tool with specific predefined properties. You can use the default
settings of the tool, or you can change the properties. You can also use railing
tools to convert linework to railings and to apply the settings of a railing tool
to existing railings.

Tool palettes containing railing tools

The default tool palettes in the workspace contain sample railing tools that
you can use and customize as needed. In addition, the following catalogs
provided with the software contain railing tools that you can add to your tool
palettes:

■ Stock Tool catalog

■ AutoCAD Architecture Sample Palette catalog

Custom palettes created by your CAD manager or other users may also contain
railing tools with railing styles and properties that are customized for your
projects or office standards.
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Creating a Railing
Use this procedure to add a new railing that has the properties specified in
the railing tool that you select. To specify settings when you add a railing, see
Creating an Attached Railing with User-Specified Settings on page 2308 and
Creating a Freestanding Railing with User-Specified Settings on page 2312.

1 Open the tool palette that you want to use, and select a railing
tool.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Stair

drop-down ➤ Railing  .

2 Specify the start point of the railing.

You can move or hide the Properties palette to expose more of
the drawing area.

3 Specify the endpoint of the railing.

4 Continue adding railings, and press ENTER.

Creating an Attached Railing with User-Specified
Settings

Use this procedure to create a railing that is attached to a stair and that has
the settings that you specify.

Creating a railing attached to a stair

1 Open the tool palette that you want to use, and select a railing
tool.
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NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Stair

drop-down ➤ Railing  .

2 On the Properties palette, expand Basic, and expand General.

3 Select a style.

4 Expand Dimensions.

5 Click the setting for Rail Locations.

NOTE If the settings in the Rail Locations worksheet are read-only,
the rail locations have been set in the style, and cannot be overridden
here. For more information, see Specifying the Upper Rails of a Railing
Style on page 2356 and Specifying the Bottom Rails of a Railing Style
on page 2358.

6 Specify the parameters for the guardrail or the handrail:

Then…If you want to…

enter a value for Horizontal Height.specify the height of the guardrail
or the handrail

enter a value for Sloping Height.specify the height of guardrail or
the handrail while it is on a stair
flight

enter a value for Offset from Post.specify the distance that the
guardrail or the handrail is offset
from the posts

select Center, Left, Right, or Auto
for Side for Offset. Side for Offset is

specify the side of the post for the
offset, based on the direction the
stair (or railing) was drawn available only when there is an off-

set value.

Auto is useful only for railings attached to the edges of stairs. A
positive value is toward the center of the stair, while a negative
value is toward the outside edge. Side for Offset for handrails also
has a selection of Both, so you can specify a handrail on both
sides of the railing.

If you select Auto, and the railing is not attached to or is along
the center of a stair, the offset is to the right.
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7 Specify the settings for bottom rails:

Then…If you want to…

enter a value for Horizontal.specify the height of the lowest rail
when it is horizontal

enter a value for Sloping.specify the height of the lowest rail
when it is on a stair flight

enter a value for Offset from Post.specify the distance that the bottom-
rail is offset from the posts

select Center, Left, Right, or Auto
for Side for Offset. (Side for Offset

specify the side of the post for the
offset, based on the direction the
stair (or railing) was drawn is available only when there is an

offset value.)

enter a value for Number of Rails.
When you designate multiple bot-

designate more than one bottom
rail

tom rails, you can enter a value for
Spacing of Rails.

8 If you want to revert to the rail settings defined in the style, click
Reset To Style Values.

9 Click OK to return to the Properties palette.

10 Click the setting for Post Locations.

NOTE If the settings in the Post Locations worksheet are read-only,
the post locations have been set in the style, and cannot be overridden
here. For more information, see Specifying Posts of a Railing Style on
page 2359.

11 Specify the post locations:

Then…If you want to…

select Fixed Posts.include fixed posts at the beginning
and end of the railing

enter a value for Extension of ALL
Posts from Top Railing.

specify the distance above or below
the top rail for all posts
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Then…If you want to…

enter a value for Extension of ALL
Posts from Floor Level.

specify the height of all posts from
the floor

select Fixed Posts at Railing Corners.include fixed posts at the corners
of the railing

select Dynamic Posts. You can then
enter a value for Maximum Center
to Center Spacing.

include dynamic posts with the
railing

select Balusters.include balusters with the railing

enter a value for Extension of Bal-
usters from Floor Level.

specify the height of all balusters
from the floor

enter the appropriate value for
Maximum Center to Center Spa-
cing.

specify the maximum distance
between the balusters

select Stair Tread Length Override.
You can then enter a value for

override the number of balusters on
each stair tread

Number per Tread. (This applies
only to railings that are attached to
stairs.)

12 If you want to revert to the post settings defined in the style, click
Reset To Style Values.

13 Click OK to return to the Properties palette.

14 Expand Location.

15 For Attached to, select Stair or Stair Flight.

16 To offset the railing in or out from the side of the stair, enter an
offset value.

Positive values are in toward the center of the stair and negative
values are out from the center of the stair. If the railing is center
justified, a positive value is to the right and a negative value is to
the left.

17 To attach the railing automatically to the full length of the stair
or the stair flight, select Yes for Automatic Placement.
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NOTE This option is available only if you have selected to attach the
railing to a whole stair. If you are attaching the railing to a stair flight,
it is always attached to the full length of the stair flight.

18 Select the stair or stair flight in the drawing to which you want
to attach the new railing.

19 Select a side of a stair or a stair flight to place the railing.

20 If you have selected no automatic placement for the stair, define
the contour of the desired railing by selecting points in the
drawing. Then press ENTER.

Creating a Freestanding Railing with User-Specified
Settings

Use this procedure to create a freestanding railing in the drawing.

Creating a freestanding railing

1 Open the tool palette that you want to use, and select a railing
tool.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Stair

drop-down ➤ Railing  .
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2 On the Properties palette, expand Basic, and expand General.

3 Select a style.

4 Expand Dimensions.

5 Click the setting for Rail Locations.

NOTE If the settings in the Rail Locations worksheet are read-only,
the rail locations have been set in the style, and cannot be overridden
here. For more information, see Specifying the Upper Rails of a Railing
Style on page 2356 and Specifying the Bottom Rails of a Railing Style
on page 2358.

6 Specify the parameters for the guardrail or the handrail:

Then…If you want to…

enter a value for Horizontal Height.specify the height of the guardrail
or the handrail

enter a value for Sloping Height.specify the height of the guardrail
or the handrail while it is on a stair
flight

enter a value for Offset from Post.specify the distance that the
guardrail or the handrail is offset
from the posts

select Center, Left, Right, or Auto
for Side for Offset. (Side for Offset

specify the side of the post for the
offset, based on the direction the
stair (or railing) was drawn is available only when there is an

offset value.)

Auto is useful only for railings attached to the edges of stairs. A
positive value is toward the center of the stair, while a negative
value is toward the outside edge. Side for Offset for handrails also
has a selection of Both, so you can specify a handrail on both
sides of the railing.

If you select Auto, and the railing is not attached to a stair, or, if
the railing is along the center of a stair, the offset is to the right.
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7 Specify the settings for bottom rails:

Then…If you want to…

enter a value for Horizontal.specify the height of the lowest rail
when it is horizontal

enter a value for Sloping.specify the height of the lowest rail
when it is on a stair flight

enter a value for Offset from Post.specify the distance that the bottom-
rail is offset from the posts

select Center, Left, Right, or Auto
for Side for Offset. (Side for Offset

specify the side of the post for the
offset, based on the direction the
stair (or railing) was drawn is available only when there is an

offset value.)

enter a value for Number of Rails.
When you designate multiple bot-

designate more than one bottom
rail

tom rails, you can enter a value for
Spacing of Rails.

8 If you want to revert to the rail settings defined in the style, click
Reset To Style Values.

9 Click OK to return to the Properties palette.

10 Click the setting for Post locations.

NOTE If the settings in the Post Locations worksheet are read-only,
the post locations have been set in the style, and cannot be overridden
here. For more information, see Specifying Posts of a Railing Style on
page 2359.

11 Specify the post locations:

Then…If you want to…

select Fixed Posts.include fixed posts at the beginning
and end of the railing

enter a value for Extension of ALL
Posts from Top Railing.

specify the distance above or below
the top rail for all posts
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Then…If you want to…

enter a value for Extension of ALL
Posts from Floor Level.

specify the height of all posts from
the floor

select Fixed Posts at Railing Corners.include fixed posts at the corners
of the railing

select Dynamic Posts. You can then
enter a value for Maximum Center
to Center Spacing.

include dynamic posts with the
railing

select Balusters.include balusters with the railing

enter a value for Extension of Bal-
usters from Floor Level.

specify the height of all balusters
from the floor

enter the appropriate value for
Maximum Center to Center Spa-
cing.

specify the maximum distance
between the balusters

select Stair Tread Length Override.
You can then enter a value for

override the number of balusters on
each stair tread

Number per Tread. (This applies
only to railings that are attached to
stairs.)

12 If you want to revert to the post settings defined in the style, click
Reset To Style Values.

13 Click OK to return to the Properties palette.

14 Expand Location.

15 For Attached to, select NONE.

16 Specify the start point of the railing.

17 Specify further points for the railing.

18 Press ENTER.
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Creating a Railing from a Polyline
Use this procedure to convert a polyline to a railing that has the properties of
the railing tool you select. You can edit these properties after creating the
railing.

Converting a polyline to a railing

1 Open the tool palette that you want to use.

If necessary, scroll to display the tool that you want to use.

2 Right-click a railing tool, and click Apply Tool
Properties ➤ Polyline.

3 Select the polyline to convert, and press ENTER.

4 When prompted to erase the original geometry, press ENTER to
keep the linework, or enter y (Yes) to erase it.

5 Edit the properties of the railing in the Properties palette, if
needed.

Creating a Railing Tool
Use this procedure to create a railing tool and add it to a tool palette. You may
want to create your own railing tools if you are placing multiple railings of a
specific style that all have the same properties.

1 Open the tool palette on which you want to add a tool.
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2 Create the tool:

Then…If you want to…

select the railing, and drag it to the
tool palette.

create a tool from a railing in the
drawing

Click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from a railing style in
the Style Manager

the style you want to copy, and
drag it to the tool palette. Click OK
to close the Style Manager.

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the tool palette where you
want to add the tool, right-click,
and click Paste.

open the catalog in the Content
Browser, and locate the tool you

copy a tool from a tool catalog

want to copy. Position the cursor
over the i-drop handle, and drag
the tool to the tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

6 Expand Basic, and expand General.

7 Click the setting for Description, enter a description of the railing
created from this tool, and click OK.

8 Specify a layer key and any layer key overrides if you do not want
to use the layer assignments specified in the layer key style used
in the drawing.

9 Select a railing style.

10 Select the drawing file containing the style used for this railing.

11 Expand Location.
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12 Select whether railings created from this tool should be attached
to a stair, a stair flight, or be freestanding (**NONE**).

13 Click OK.

Editing Railings
You can edit railings by changing the style of the railing, the inclusion and
location of various rails and posts, and the insertion point. You can also specify
the height and offset of guardrails and handrails, and the extension and
spacing of posts.

Methods of Editing Railings

AutoCAD Architecture offers several methods for editing railings:

■ You can directly edit railings using grips for dimensions and other physical
characteristics.

■ For grip edit operations where you are changing a dimension or an angle,
the Dynamic Input feature lets you enter a precise value instead of moving
a grip. When this feature is active (click DYN on the application status
bar), selecting a grip displays a text box in which you can enter the desired
value for the associated dimension or angle. For more information, see
“Use Dynamic Input” in AutoCAD Help.

■ You can change railing settings on the Properties palette. You can also use
the Display tab of the Properties palette to change the display property
settings for a selected object display component in the current display
representation. For more information, see Using the Properties Palette to
Change Display Properties on page 793.

■ You can use editing commands from the contextual Railing ribbon tab
and shortcut menu for a selected railing.

Using Grips to Edit Railings
Use these procedures to edit railings using grips.

Editing Railing Dimensions

1 Select the railing.

2 Select the grip for the dimension you want to change.
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Viewing railing Start, End, Location, and Reverse Direction grips

3 Move the grip until the dimension value you want is displayed,
and click once; or enter a value.

Viewing railing Fixed Post Position and Lengthen grips

Changing the Location or Position of a Railing

1 Select the railing.

2 Move the appropriate grip to change the location of the railing,
its start point, or its endpoint.

Reversing the direction of the Railing

1 Select the railing.

2 Click the direction grip (arrow grip).

Adding a Post to a Railing
Use this procedure to add a post to a railing. The post is placed at a selected
point on the railing.
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Adding a post to a railing

1 Select a railing.

2 Click Railing tab ➤ Posts panel ➤ Add  .

3 Select a location for a new post.

4 Press ENTER.

Removing a Post from a Railing
Use this procedure to remove posts you have added to railings. You can only
remove fixed posts. You cannot remove dynamic posts. The manually added
post closest to the selected point is removed from the railing. If two posts are
equidistant from the selected point, the post closer to the starting point of
the railing is removed. If the current first fixed post is removed, then the next
post becomes the first fixed post. Likewise, if the current last fixed post is
removed, then the next post from the last becomes the last fixed post. If all
but one post is removed from a railing, then the sole remaining post becomes
the first fixed post.

1 Select a railing.

2 Click Railing tab ➤ Posts panel ➤ Remove  .

3 Select the railing post to remove.

4 Continue removing railing posts, or press ENTER.
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Redistributing Posts on a Railing
Use this procedure to reposition dynamic posts to account for posts that have
been added or removed. You cannot redistribute displayed posts to account
for hidden posts.

You may also want to redistribute posts after dragging the endpoints (start
and end offset) of a railing attached to a stair. If posts are lost after trimming
a railing, use the Redistribute Posts command to restore the posts.

If you have created a railing that is so short that only one post can be created,
grip-editing and dragging the railing does not create another post. You must
use the Redistribute Posts command to add another post to the end of the
railing.

1 Select an existing railing.

2 Click Railing tab ➤ Posts panel ➤ Redistribute  .

Hiding Posts
Use this procedure to hide posts in a railing. It is useful to hide posts in plan
view so that the railing is visible as a solid component. These posts are not
deleted; they are merely hidden from view. You can only hide fixed posts.
You cannot hide dynamic posts. If the current first or last fixed post is hidden,
then it remains the first or last fixed post regardless of its visibility.

1 Select a railing.

2 Click Railing tab ➤ Posts panel ➤ Hide  .

3 Select the railing post to hide.

4 Continue selecting railing posts, or press ENTER.

Showing Hidden Posts
Use this procedure to show hidden posts.

1 Select a railing.

2 Click Railing tab ➤ Posts panel ➤ Show  .
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Reversing the Direction of the Railing
Use this procedure to reverse the direction of the railing to change the location
of railing components. The direction in which the railing is drawn affects the
behavior of the railing and its components.

NOTE You can also reverse the direction of a railing by clicking its direction grip
(arrow grip).

1 Select a railing.

2 Click Railing tab ➤ Anchor panel ➤ Reverse  .

Anchoring an Existing Railing to a Stair
Use this procedure to anchor an existing railing to a stair. Once attached, the
railing stays where it is located in the drawing, but it moves when the attached
stair is moved. This allows you to create free-form paths for a railing along a
stair. For example, you might want to create a curved railing in the middle of
a straight stair.

Railings attached to stairs respect the stair cut plane. The height of the railing
follows the slope of the stair, no matter where the posts are placed on the
treads.
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Attaching a railing to a stair

Railings that are attached to a stair or to a stair flight when created are
anchored to the stair, at either side of the stairs or at the centerline.

1 Select a railing.

2 Click Railing tab ➤ Anchor panel ➤ Set To Stair  .

3 Select a stair.

Anchoring an Existing Railing to an Object
Use this procedure to anchor an existing railing to an AEC object other than
a stair. Once attached, the railing stays where it is located in the drawing, but
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it moves when the attached object is moved. This allows you to create free-form
paths for a railing along a stair or other object.

Railings attached to objects other than stairs follow the height of the centerline
of each post.

Attaching a railing to an AEC object

1 Select a railing.

2 Click Railing tab ➤ Anchor panel ➤ Set To Objects  .

3 Select an AEC object other than a stair, and press ENTER.

4 If you want to clean up the railing posts with the surface of the
object to which it is attached, enter y (Yes) on the command line.

5 Define the contour of the railing:

Then…If you want to…

press ENTER to specify At Post Loca-
tions Only for Calculate Height.

adapt only the posts to the surface
of the attached object, and have
straight segments between the
posts
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Then…If you want to…

enter f to Follow Surface for Calcu-
late Height.

adapt the whole railing to the sur-
face of the attached object,

Releasing an Anchored Railing
Use this procedure to release an anchored railing from a stair. After the railing
is released, it is independent of the stair. The railing and the stair can then be
moved separately.

NOTE When a railing that is anchored to a stair is released, any changes to the
railing (such as grip-editing or changing properties) may cause the railing to lose
its slope. Be sure to correct the appearance of the railing before releasing it from
the stair.

1 Select a railing.

2 Click Railing tab ➤ Anchor panel ➤ Release  .

3 The railing is no longer anchored to the stair.

Center a Railing Using Modify Tools
Use this procedure to center a railing on a specified axis or between any two
specified points.

1 Select the railing to center.

2 Click Railing tab ➤ Modify panel ➤ Center  .

3 Select an existing axis line on which to center the railing, or press
ENTER and then specify two points between which to center the
railing.

Create a Railing Array Using Modify Tools
Use this procedure to create an array of identical railings along a stair, or as
free-standing railings.

1 Select the railing to array.
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2 Click Railing tab ➤ Modify panel ➤ Array  .

3 Select an edge from which to start the array that is perpendicular
to the array axis, then drag in the direction of the array. Do one
of the following:

■ Offset: start the railing array a specified offset distance from
the edge.

■ Clear Distance: specify a clear distance between each arrayed
railing.

■ Pick Array Distance: specify a distance between arrayed railings.

■ Enter Count: specify the number of railings to appear in the
array.

Alternatively, you can press ENTER and then specify two points
between which to array the railing.

Repositioning a Railing with Modify Tools
Use this procedure to reposition a railing.

1 Select the railing to reposition.

2 Click Railing tab ➤ Modify panel ➤ Reposition From  .

3 Select an existing stair edge or another specified boundary from
which to reposition the railing, or specify two points to define a
reference edge.

Spacing Railings Evenly with Modify Tools
Use this procedure to space railings evenly along a stair or in a free-standing
layout.

1 Select the railing to space evenly.

2 Click Railing tab ➤ Modify panel ➤ Space Evenly  .

3 Select an edge as the axis along which to space all the railings
evenly, and specify a start point and an endpoint along the edge.

Alternatively, press ENTER and specify two points between which
the railings will be spaced evenly from each other.
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Specifying the Display of Custom Block Components of a Railing
Use this procedure to specify the display of custom block components for an
individual railing in any of the display representations used for model views.
If you are going to use custom graphics for a new component, draw the
component and save it as a block before you start this procedure.

1 Double-click the railing.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all railings in the drawing, select
Drawing default setting. To apply changes to all railings of this style,
select Railing Style:<style name>. For more information on styles, see
Railing Styles on page 2353.

5 For Display representation, verify that the desired display
representation is selected.

6 If necessary, expand Object Display Properties ➤ Advanced, and

for Custom block display, click  (the number in parentheses
indicates the number of blocks currently attached to the railing).

7 If you want to turn off the display of custom blocks for this railing
without removing them, select Disable Custom Blocks.

8 Specify whether to add, edit, or remove a block component:

Then…If you want to…

click Add, and then click Select
Block, select the block, and click
OK.

add a new block component

select the component to edit, and
click Edit.

edit an existing block component

select the block, click Remove, and
click OK.

remove an existing block compon-
ent
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9 When adding or editing a block component, specify the scale of
the custom block:

Then…If you want to…

clear all options under Scale to Fit.use the block at its drawn size

select Width.scale the custom block to the width
of the object to which it is attached

select Depth.scale the custom block to the depth
of the object to which it is attached

select Height.scale the custom block to the
height of the object to which it is
attached

select Lock Ratio. If the object is
scaled in one direction to fit another

lock the XY shape of the object

criterion for Scale to Fit, the whole
custom block is scaled equally.

select Between Comp. Baluster,
Fixed Post, and Dynamic Posts are

add the selected block to the rail-
ings between the selected compon-
ents the only valid component selec-

tions.

10 Specify the Mirror In direction, if necessary:

Then…If you want to…

select Mirror X.create a mirror of the component
in the X direction, along the length
of the railing

select Mirror Y.create a mirror of the component
in the Y direction, across the width
of the railing

select Mirror Z.create a mirror of the component
in the Z direction
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11 Specify the location of the insertion point in relation to the object:

Then…If you want to…

select Left, Center, or Right for X.specify the location of the X inser-
tion point

select Front, Center, or Back for Y.specify the location of the Y inser-
tion point

select Bottom, Middle, or Top for
Z.

specify the location of the Z inser-
tion point

Specify the post orientation relative to the up and down directions
on a stair run in plan view as shown in the following illustration:

Specify the post orientation relative to the up and down directions
on a stair run in elevation view as shown in the following
illustration:

12 Specify the insertion offset for the component in the X, Y, and Z
directions.

13 Specify the type of railing component that the block represents:

Then…If you want to…

select Baluster for Component.represent balusters with the block

select Fixed Post for Component.represent fixed posts with the block
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Then…If you want to…

select Dynamic Post for Compon-
ent.

represent dynamic posts with the
block

select Replace.replace the current baluster, fixed
post, or dynamic post with the
block

select Guardrail for Component.represent a guardrail with the block

select Handrail for Component.represent a handrail with the block

select Bottomrail for Component.represent a bottom rail with the
block

The two groups of components are mutually exclusive, so selecting
an object from one column makes the other unavailable. You can
select more than one object in each column to apply the block
to each selected component. For example, you can use the same
block for the fixed posts and dynamic posts.

14 Specify where the block is applied to the components:

Then…If you want to…

select All for Attach to.apply the block to all instances of
the selected components

select First for Attach to.apply the block to the first instance
of the selected component, based
on the direction the railing was
drawn

select Last for Attach to.apply the block to the last instance
of the selected component, based
on the direction the railing was
drawn

select Selection for Attach to. The
components are numbered in the

apply the block to a selected num-
ber of components

order the railing was drawn, begin-
ning with 1.
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15 Click OK.

You can also specify custom block display properties through the
railing’s context menu, as follows:

1 Right-click the railing, and click Edit Object Display.

2 Click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

4 If necessary, click  .

5 Click the Other tab.

6 Add, edit, or remove custom blocks as explained in the previous
procedure.

Specifying Cleanup Settings for a Railing
Use this procedure to specify the cleanup settings for a railing in display
representations used for model views.

1 Double-click the railing.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all railings in the drawing, select
Drawing default setting. To apply changes to all railings of this style,
select Railing Style:<style name>. For more information on styles, see
Railing Styles on page 2353.

5 For Display representation, verify that the desired display
representation is selected.

6 If necessary, expand Object Display Properties ➤ Advanced, and

click  Cleanup properties.

7 Specify whether you want to disable the cleanup of rails at post.

8 Specify whether you want to disable the cleanup of balusters at
rails.

9 Click OK.
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You can also access and modify the same cleanup settings through the railing’s
context menu, as follows:

1 Select the railing you want to change, right-click, and click Edit
Object Display.

2 Click the Display Properties tab.

3 Select the desired display representation, and select Object
Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 Click the Other tab.

6 Under Cleanup, adjust the settings as desired, and click OK twice.

Adding a Custom Profile to a Railing Component
Use this procedure to add a custom profile to a railing component.

Guardrails, handrails, bottom rails, and fixed and dynamic posts can be defined
by a custom profile. You can add a profile to a railing component either in
the railing style, as described in Specifying the Components of a Railing Style
on page 2361 or directly on screen. When you add a custom profile on screen,
the new profile is automatically saved back to the railing style. You can also
add, remove, or edit custom profiles from the Properties palette, as described
in Specifying the Display of a Custom Profile Component of a Railing on page
2337.

1 Create the necessary profile definition, as described in Creating
a Profile for a Custom Railing Component on page 2363.

2 Select the railing.

3 Click Railing tab ➤ Profile panel ➤ Add Profile  .

4 Select the railing component to which you want to add a profile.

You can select guardrails, handrails, bottom rails, fixed posts, and
dynamic posts.

NOTE If you have difficulty selecting the correct component, switch
to another view that makes the selection easier. For example, to select
a bottom rail, switch to a Model view.
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Adding a custom profile to a railing post

5 Select the profile for the railing component.

6 Either save the custom profile to the railing style immediately, or
proceed with editing the profile:

Then…If you want to…

click OK.save the new profile to the railing
style

click Continue Editing, and then
click OK. For information on editing

edit the new profile

a custom profile, see Editing a Cus-
tom Profile of a Railing Component
on page 2333.

Editing a Custom Profile of a Railing Component
Use this procedure to edit a custom profile of a railing component.

1 Select the railing with a custom profile you want to edit.

2 Click Railing tab ➤ Profile panel ➤ Edit In Place  .

This command is available only if you have profile-based
components in the railing.

3 Select the component you want to edit.
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NOTE If you have difficulty selecting the correct component, switch
to another view that makes the selection easier. For example, to select
a bottom rail, switch to a Model view.

You have begun an in-place editing session, depicted by the
magenta-colored grips and light blue hatch of the temporary
in-place editing profile, as well as the faded color of other objects
in the drawing. Note that while you are editing in-place, you have
limited access to other commands in the drawing. Before working
on other objects, you should first end the in-place editing session.

4 Use the grips or the ribbon in order to make any of the following
changes to the profile:

Then…If you want to…

move the edge or vertex grips as
needed.
The Edge grip has three edit modes:
Offset, Add Vertex, and Convert to

use grips to edit the profile

Arc. The default mode is Offset,
which offsets the selected edge in
a direction that is perpendicular to
the midpoint of the edge. Depend-
ing on the shape of the profile and
the edge you choose to modify,
neighboring lines are extended or
trimmed, and new lines are added
as necessary.
Use the Add Vertex edit mode to
add a vertex to the selected edge,
and create a new edge. If the selec-
ted edge is an arc, the new edge is
an arc as well.
Convert to Arc changes the selected
edge to an arc and stretches the
midpoint of the edge. The edge
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Then…If you want to…

grip for an arc also has a Stretch
mode, so that you can stretch the
midpoint of the edge after it has
been converted to an arc.

add a vertex to the profile ■ Grips: Select an Edge grip, and
press CTRL to switch to the Add
Vertex edit mode. Move the
edge to the desired location,
and click; or enter a value, and
press ENTER.

■ Ribbon: Click Edit In Place

tab ➤ Profile panel ➤ Add Ver-

tex  , and then select a point
to add.

remove a vertex from the profile ■ Grips: Select the Vertex grip for
the vertex you want to remove,
and press CTRL to switch to the
Remove edit mode. Move the
cursor off the selected vertex,
and click.

■ Ribbon: Click Edit In Place

tab ➤ Profile panel ➤ Remove

Vertex  , and then select a
point to remove.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Add

add a ring to a profile

Ring  . Then select a closed
polyline, spline, ellipse, or circle for
an additional ring. Specify if you
want to erase the source linework,
and press ENTER.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Remove

remove a ring from a profile
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Then…If you want to…

Ring  . Then select the ring you
want to remove.

NOTE You cannot remove the
last ring from a profile.

select the profile, and click Edit In

Place tab ➤ Profile panel ➤ Replace

replace a ring on a profile

Ring  . Then select a closed
polyline, spline, ellipse, or circle for
the replaced ring. Specify if you
want to erase the source linework,
and press ENTER.

5 Save the changes to the profile:

Then…If you want to…

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  .

change the existing profile defini-
tion to reflect the new shape

click Edit In Place tab ➤ Edits pan-

el ➤ Save As  .Enter a name for

create a new profile definition with
the shape you have created

the new profile, and click OK. The
in-place edit session closes and the
new profile definition is available in
the Style Manager.

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

discard all changes on the profile
and revert to the previous shape
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Specifying the Display of a Custom Profile Component of a
Railing

Use this procedure to add, remove, or edit a custom profile component for an
individual railing in any of the display representations used for plan views. If
you are adding a new profile, you must first create the necessary profile
definition, as described in Creating a Profile for a Custom Railing Component
on page 2363.

1 Double-click the railing.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all railings in the drawing, select
Drawing default setting. To apply changes to all railings of this style,
select Railing Style:<style name>. For more information on styles, see
Railing Styles on page 2353.

5 For Display representation, verify that the desired display
representation is selected.

6 If necessary, expand Object Display Properties ➤ Advanced, and

for Custom profile display, click  (the number in parentheses
indicates the number of profiles currently attached to the railing).

7 If you want to turn off the display of custom profiles for this
railing without removing them, select Disable Custom Profiles.

8 Specify whether to add, edit, or remove a profile component:

Then…If you want to…

click Add, and then click Select
Profile, select the profile, and click
OK.

add a new profile component

select the component to edit, and
click Edit.

edit an existing profile component

select the component, click Re-
move, and click OK.

remove an existing profile compon-
ent
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9 Specify the scale of the custom profile:

Then…If you want to…

clear all options under Scale to Fit.use the profile at its drawn size

select Width.scale the custom profile to the
width of the object to which it is
attached

select Depth.scale the custom profile to the
depth of the object to which it is
attached

select Height.scale the custom profile to the
height of the object to which it is
attached

select Lock Ratio. If the object is
scaled in one direction to fit another

lock the XY shape of the object

criterion for Scale to Fit, the entire
custom profile is scaled equally.

select Between Comp. (Baluster,
Fixed Post, and Dynamic Posts are

add the selected profile to the rail-
ings between the selected compon-
ents the only valid component selec-

tions.)

10 Specify the Mirror In direction, if necessary:

Then…If you want to…

select Mirror X.create a mirror of the component
in the X direction, along the length
of the railing

select Mirror Y.create a mirror of the component
in the Y direction, across the width
of the railing

11 Specify the angle to rotate the component in the Z direction, if
necessary.
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12 Specify the location of the insertion point in relation to the object:

Then…If you want to…

select Left, Center, or Right for X.specify the location of the X inser-
tion point

select Front, Center, or Back for Y.specify the location of the Y inser-
tion point

Specify the post orientation relative to the up and down directions
on a stair run in plan view as shown in the following illustration:

Specify the post orientation relative to the up and down directions
on a stair run in elevation view as shown in the following
illustration:

13 Specify the insertion offset for the component in the X and Y
directions.

14 Specify the type of railing component that the profile represents:

Then…If you want to…

select Baluster for Component.represent balusters with the selec-
ted profile

select Fixed Post for Component.represent fixed posts with the selec-
ted profile

select Dynamic Post for Compon-
ent.

represent dynamic posts with the
selected profile
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Then…If you want to…

select Replace.replace the current baluster, fixed
post, or dynamic post with the se-
lected profile

select Guardrail for Component.add a guardrail to the selected pro-
file

select Handrail for Component.add a handrail to the selected pro-
file

select Bottomrail for Component.add a bottom rail to the selected
profile

The two groups of components are mutually exclusive, so selecting
an object from one column makes the other unavailable. You can
select more than one object in each column, and apply the profile
to each selected component. For example, you can use the same
profile for the fixed posts and dynamic posts.

15 Specify where the profile is applied to the components:

Then…If you want to…

select All for Attach to.apply the profile to all instances of
the selected components

select First for Attach to.apply the profile to the first instance
of the selected component, based
on the direction the railing was
drawn

select Last for Attach to.apply the profile to the last instance
of the selected component, based
on the direction the railing was
drawn

select Selection for Attach to. The
components are numbered in the
order the railing was drawn.

apply the profile to a selected
number of components

16 Click OK.
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You can also specify custom profile display properties through
the railing’s context menu, as follows:

1 Right-click the railing, and click Edit Object Display.

2 Click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

4 If necessary, click  .

5 Click the Other tab.

6 Add, edit, or remove custom profiles as explained in the previous
procedure.

Changing the Style of a Railing
Use this procedure to change the style associated with existing railings.

1 Select the railings for which you want to change the style, and
double-click one of them.

2 On the Properties palette, click the Design tab, then expand Basic,
and expand General.

3 Under Style, select a different style.

Changing the Upper Rails
Use this procedure to change the following settings for an individual railing:

■ guardrails

■ handrails

■ height

■ sloping height

■ offset from posts

■ side for offset

NOTE If these settings are unavailable, they are controlled by the railing style.
You cannot modify them for individual railings.
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1 Double-click the railing for which you want to change the upper
rails.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Dimensions.

3 Click the setting for Rail Locations.

4 Select whether to include guardrails or handrails.

NOTE A railing must have a guardrail or a handrail. Both cannot be
turned off.

5 Specify the parameters for the guardrail or the handrail:

Then…If you want to…

enter a value for Horizontal Height.specify the height of the guardrail
or the handrail

enter a value for Sloping Height.specify the height of guardrail or
the handrail while it is on a stair
flight

enter a value for Offset from Post.specify the distance that the
guardrail or the handrail is offset
from the posts

select Center, Left, Right, or Auto
for Side for Offset. (Side for Offset

specify the side of the post for the
offset, based on the direction the
stair (or railing) was drawn is available only when there is an

offset value.)

Auto is useful only for railings attached to the edges of stairs. A
positive value is toward the center of the stair, while a negative
value is toward the outside edge. Side for Offset for handrails also
has a selection of Both, so you can specify a handrail on both
sides of the railing.

If you select Auto, and the railing is not attached to or is along
the center of a stair, the offset is to the right.

6 If you want to undo your changes and revert to the values set in
the railing style, click Reset to Style Values.

7 Click OK.
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Changing the Bottom Rails
Use this procedure to change the following settings for the bottom rails of an
individual railing:

■ whether to use bottom rails

■ number of bottom rails

■ distance between rails

■ height of lowest rail

NOTE If these settings are unavailable, they are controlled by the railing style.
You cannot modify them for individual railings.

1 Double-click the railing for which you want to change the bottom
rails.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Dimensions.

3 Click the setting for Rail Locations.

4 Select Bottomrail to add bottom rails to the railing.

5 Specify the settings for bottom rails:

Then…If you want to…

enter a value for Horizontal Height.specify the height of the lowest rail
when it is horizontal

enter a value for Sloping Height.specify the height of the lowest rail
when it is on a stair flight

enter a value for Offset from Post.specify the distance that the bottom-
rail is offset from the posts

select Center, Left, Right, or Auto
for Side for Offset. (Side for Offset

specify the side of the post for the
offset, based on the direction the
stair (or railing) was drawn is available only when there is an

offset value.)

enter a value for Number of Rails.
When you designate multiple bot-

designate more than one bottom
rail

tom rails, you can enter a value for
Spacing of Rails.
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6 If you want to undo your changes and revert to the values set in
the railing style, click Reset to Style Values.

7 Click OK.

Changing the Posts
Use this procedure to change the following settings for the posts of an
individual railing:

■ type of posts

■ number of posts that extend above the railing

■ maximum center-to-center spacing between posts

■ maximum center-to-center spacing between balusters

■ number of balusters per tread for railings that are attached to stairs

NOTE If these settings are unavailable, they are controlled by the railing style.
You cannot modify them for individual railings.

1 Double-click the railing for which you want to change the post
locations.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Dimensions.

3 Click the setting for Post locations.

4 Specify the post locations:

Then…If you want to…

select Fixed Posts.include fixed posts at the beginning
and end of the railing

enter a value for Extension of ALL
Posts from Top Railing.

specify the distance above or below
the top rail for all posts

enter a value for Extension of ALL
Posts from Floor Level.

specify the height of all posts from
the floor

select Fixed Posts at Railing Corners.include fixed posts at the corners
of the railing
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Then…If you want to…

select Dynamic Posts. You can then
enter a value for Maximum Center
to Center Spacing.

include dynamic posts with the
railing

select Balusters.include balusters with the railing

enter a value for Extension of Bal-
usters from Floor Level.

specify the height of all balusters
from the floor

enter the appropriate value for
Maximum Center to Center Spa-
cing.

specify the maximum distance
between the balusters

select Stair Tread Length Override.
You can then enter a value for

override the number of balusters on
each stair tread

Number per Tread. (This applies
only to railings that are attached to
stairs.)

5 If you want to undo your changes and revert to the values set in
the railing style, click Reset to Style Values.

6 Click OK.

Changing the Railing Extensions at Floor Levels
Use this procedure to control the length of the handrail and guardrail
extensions at the top and bottom of stair flights. If a bottom rail exists, it
extends as far as the railing above it.

NOTE If these settings are unavailable, they are controlled by the railing style.
You cannot modify them for individual railings.

1 Double-click the railing for which you want to change the
extensions.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Dimensions.

3 Click the setting for Railing Extensions.
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4 Specify the railing extension properties:

Then…If you want to…

under At Floor Levels, clear Use Stair
Landing Extension.

use values in this dialog box to
specify extensions

under Top of Entire Stair, enter val-
ues for Handrail and Guardrail. Se-

specify the length of the handrail
and guardrail at the top of an entire
stair lect + T next to the value to add the

tread length to the extension value.

under Bottom of Entire Stair, enter
values for Handrail and Guardrail.

specify the length of the handrail
and guardrail at the bottom of an
entire stair Select + T next to the value to add

the tread length to the extension
value.

5 If you want to undo your changes and revert to the values set in
the railing style, click Reset to Style Values.

6 Click OK.

Changing the Railing Extensions at Landings
Use this procedure to control the length of the handrail and guardrail
extensions at landings. If a bottom rail exists, it extends as far as the railing
above it.

NOTE If these settings are unavailable, they are controlled by the railing style.
You cannot modify them for individual railings.

1 Double-click the railing for which you want to change the
extensions.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Dimensions.

3 Click the setting for Railing Extensions.

4 Specify the railing extension properties:

Then…If you want to…

clear Use Stair Landing Extension
under At Landings.

use values in this dialog box to
specify extensions
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Then…If you want to…

under Top of Flight, enter values for
Handrail and Guardrail. Select + T

specify the length of the handrail
and guardrail at the top of a flight

next to the value to add the tread
length to the extension value.

under Bottom of Flight, enter values
for Handrail and Guardrail. Select +

specify the length of the handrail
and guardrail at the bottom of a
flight T next to the value to add the tread

length to the extension value.

5 If you want to undo your changes and revert to the values set in
the railing style, click Reset to Style Values.

6 Click OK.

Changing the Anchor Properties of a Railing
Use this procedure to change the justification of a railing and the side, start,
and end offsets. These properties apply only to railings attached to stairs.

1 Double-click the railing for which you want to change the anchor
properties.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Location.

3 Click Anchor.

4 Change the justification of the railing.
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5 Change the side offset from the stair:

■ A value of zero places the start and end fixed posts exactly at
the ends of the stair.

■ Positive values move the start/end onto the stair.

■ Negative values extend the railing beyond the stair bounds.

NOTE If Automatic is selected, the start and end offset options are
not available.

6 Change the start offset from the top of the stair.

7 Change the ending offset at the bottom of the stair.

8 Click Redistribute Posts to change the existing posts.

NOTE If you edit a railing using grips so that the railing does not end
on a post, you can use Redistribute Posts to move a post to the end
of the edited railing.

9 Click OK.

Specifying Perpendicular Railing Orientation
Use this procedure to specify perpendicular or vertical railing orientation
relative to a stair flight. By default, railing have a vertical orientation when
you create them.

Specifying perpendicular railings

1 Double-click the railing.

2 On the Properties palette, click the Design tab.
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3 Under Dimensions, select Yes for Perpendicular Posts.

4 Under Location, select Yes for Automatic Cleanup.

Once a perpendicular railing orientation has been specified, you
can use grips to change first and last posts to a vertical orientation.

Specifying perpendicular railings

1 Select the perpendicular railing.

2 Select the Make Vertical grip.

The Make vertical grip changes to a Make perpendicular grip once
you have specified a vertical orientation for the railing post. Select
the Make perpendicular grip to return the post to a perpendicular
orientation.

Viewing post orientation grips

When a stair has a landing, you also have the option of specifying
the orientation of landing posts.
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Specifying landing post orientation

1 Double-click the railing, and on the Properties palette, click the
Design tab.

2 Under Dimensions, select Yes for Perpendicular Posts, and Yes for
Maintain Sloping Posts at Landings.

3 Under Location, select Yes for Automatic Cleanup.

Changing the Location of a Railing
Use this procedure to relocate a railing by changing the coordinate values of
its insertion point. The railing also has an orientation with respect to the WCS
or the current UCS. For example, if the top and bottom of the railing are
parallel to the XY plane, its normal is parallel to the Z axis. You can change
the orientation of the railing by aligning its normal with another axis. You
can also rotate the railing on its plane by changing the rotation angle.
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For information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use Coordinates and Coordinate Systems” in
AutoCAD help.

NOTE You can change the location of freestanding railings only. The location of
a railing attached to a stair is defined by the stair.

1 Select the railings you want to relocate, and double-click one of
them.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Location.

3 Enter a value for Rotation.

4 Enter a value for Elevation.

5 Click Additional Information for further location properties:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the railing

make the normal of the railing par-
allel to the Z axis: under Normal,

locate the railing on the XY plane

enter 1 for Z, and enter 0 for X
and Y.

make the normal of the railing par-
allel to the X axis: under Normal,

locate the railing on the YZ plane

enter 1 for X, and enter 0 for Y
and Z.

make the normal of the railing par-
allel to the Y axis: enter 1 for Y, and
enter 0 for X and Z.

locate the railing on the XZ plane

enter a new value for Rotation
Angle.

change the rotation of the railing

6 Click OK.
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Applying Tool Properties to an Existing Railing
Use this procedure to apply the properties of a railing tool to one or more
existing railings. The properties include the railing style and any other settings
specified in the tool you select.

1 Open the tool palette that you want to use.

If necessary, scroll to display the tool that you want to use.

2 Right-click a railing tool, and click Apply Tool Properties
to ➤ Railing.

3 Select the railings, and press ENTER.

4 Edit the properties of the railing in the Properties palette, if
necessary.

Attaching Hyperlinks, Notes, and Files to a Railing
Use this procedure to attach hyperlinks, text notes, and files to a railing.

1 Double-click the railing to which you want to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

For more information about adding hyperlinks, see “Add
Hyperlinks to a Drawing” in AutoCAD help.

4 Click the setting for Notes, and add a note. Then click OK.

5 Click the setting for Reference Documents.

6 Attach or detach reference files:

Then …If you want to …

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file
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Then …If you want to …

select the file name, and click 
.

detach a reference file

7 Click OK.

Railing Styles
A railing style is a group of properties assigned to a railing that determines
the appearance and other characteristics of the railing.

Railing Components

In a railing style, you specify the following properties of railing components:

■ guardrails

■ handrails

■ bottom rails

■ first fixed post

■ last fixed post

■ interior fixed posts

■ dynamic posts

■ balusters

You can specify the height of rails and posts, the spacing between posts, the
spacing between rails, and the width and depth of components. You can
specify the display of different first and last posts, as well as different interior
fixed posts. You can also create custom railing components by assigning
custom profiles to replace standard railing components.

Custom Railing Components and Special Conditions

To create custom extruded components (railings, posts, or balusters) in a railing
style, you define a profile and select it to replace a component on the
Components tab of the railing style in the Style Manager. The resulting
component is displayed appropriately in all views and does not have to be
added to the display properties.
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You can create a custom block to represent a complex design for a component
that cannot be created from a profile, such as an elaborate wrought iron design
in place of balusters, or an unusually shaped component. That block is used
to represent the component in model views. You can create a profile to
represent the custom component in plan views.

You can also use the custom blocks and profiles features of the display
properties to represent additional railing components other than posts, rails,
and balusters. In such cases, the component is added to the component rather
than replacing it. For example, you can create a custom block for Model views
and a profile for Plan views of a curved-railing return piece that ends by
attaching to a wall. You can then add the block or profile to the rail
components.

Using Materials in Railing Styles

You can use materials to control how railings of each style are displayed in a
drawing. You assign materials to the railing components in the style. The
components are then displayed using the display properties of the assigned
materials.

AutoCAD Architecture provides a number of predefined materials for common
design purposes. You can use these materials “as is,” or modify them for your
project requirements. You can also define new materials. For more information
about materials and how to define them, see Materials on page 885.

Creating Tools from Railing Styles

You can create a railing tool from any railing style. You can drag the style
from the Style Manager onto a tool palette. You can then specify default
settings for any railing created from the tool. For more information, see
Creating a Railing Tool on page 2316.

Managing Railing Styles

To create, copy, or purge styles, you access the Style Manager. The Style
Manager provides a central location in AutoCAD Architecture, for working
with styles from multiple drawings and templates. For more information about
using the Style Manager, see Style Manager Overview on page 870.
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Creating a Railing Style
Use this procedure to create a railing style. You can create a style using default
style properties or by copying an existing style. After you create the style, you
edit the style properties to customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Railing Styles.

NOTE Alternatively, you can select a railing in the drawing, then click
Railing tab ➤ General panel ➤ Edit Style drop-down ➤ Railing Styles

 .

3 Create a railing style:

Then…If you want to…

right-click Railing Styles, and click
New.

create a style with default properties

right-click the railing style you want
to copy, and click Copy. Right-click,
and click Paste.

create a style from an existing style

4 Right-click the new style name, and click Rename. Enter a name
for the new railing style, and press ENTER.

5 Edit the new railing style:

Then…If you want to…

see Specifying the Upper Rails of a
Railing Style on page 2356.

specify default dimensions and off-
sets for upper rails of the style

see Specifying the Bottom Rails of
a Railing Style on page 2358.

specify default dimensions and off-
sets for bottom rails of the style

see Specifying Posts of a Railing
Style on page 2359.

specify the location and interval of
posts and balusters for the style

see Specifying the Components of
a Railing Style on page 2361.

specify the structural components
of the style
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Then…If you want to…

see Specifying the Railing Exten-
sions of a Railing Style on page 2363.

specify railing extensions at floor
levels and at landings

see Assigning Materials to a Railing
Style on page 2367.

assign materials to the components
of the railing style

see Specifying Classifications for a
Railing Style on page 2369.

add classifications to a railing style

see Specifying the Display Compon-
ents of a Railing Style on page 2368.

specify display components of the
style

see Attaching Notes and Files to a
Railing Style on page 2369.

add notes and files to the style

6 If you want to assign the style to a railing tool, drag the style from
the Style Manager to a tool palette.

You can later rename the tool and specify other properties for it
as described in Creating a Railing Tool on page 2316.

7 Click OK.

Specifying the Upper Rails of a Railing Style
Use this procedure to change the following settings for guardrails and handrails
in a railing style:

■ sloping height

■ offset from posts

■ side for offsets

1 Select a railing.

2 Click Railing tab ➤ General panel ➤ Edit Style

drop-down ➤ Railing Styles  .

3 Select the style you want to edit.
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4 Click the Rail Locations tab.

5 Specify whether upper rail properties of this railing style can be
overridden for individual railing objects:

Then…If you want to…

select Allow Each Railing to Vary.specify guardrail and handrail
properties, such as horizontal
height, sloping height, and offset
distance, when you add or modify
railings

clear Allow Each Railing to Vary.require that all railings of this style
use the upper rail settings of the
style

NOTE Changes to guardrails and handrails do not affect existing
railings of this style unless Allow Each Railing to Vary is cleared.

6 Select whether to include guardrails and handrails.

A railing must have a guardrail or handrail. Both cannot be turned
off.

7 Specify the following parameters for the guardrail or the handrail:

Then…If you want to…

enter a value for Horizontal Height.specify the height for the guardrail
or the handrail

enter a value for Sloping Height.specify the height for the guardrail
or the handrail while it is on a stair
flight

enter a value for Offset from Post.specify the distance that the
guardrail or the handrail is offset
from the posts
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Then…If you want to…

select Center, Left, Right, or Auto
for Side for Offset. (Side for Offset

specify the side of the post for the
offset, based on the direction the
stair (or railing) was drawn is available only when there is an

offset value.)

Auto is useful only for railings attached to the edges of stairs. A
positive value is toward the center of the stair, while a negative
value is toward the outside edge. Side for Offset for handrails also
has a selection of Both, so you can specify a handrail on both
sides of the railing.

If you select Auto, and the railing is not attached to a stair or is
along the center of a stair, the offset is to the right.

8 Click OK.

Specifying the Bottom Rails of a Railing Style
Use this procedure to change the following settings for bottom rails in a railing
style:

■ number of bottom rails

■ distance between rails

■ height of lowest rail

1 Select a railing.

2 Click Railing tab ➤ General panel ➤ Edit Style

drop-down ➤ Railing Styles  .

3 Select the style you want to edit.

4 Click the Rail Locations tab.
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5 Specify whether bottom rail properties of this railing style can be
overridden for individual railing objects:

Then…If you want to…

select Allow Each Railing to Vary.specify bottom rail properties, such
as horizontal height, sloping height,
and number of rails, when you add
or modify railings

clear Allow Each Railing to Vary.require that all railings of this style
use the bottom rail settings of the
style

6 Select Bottomrail to add bottom rails to the railing.

NOTE Changes to bottom rails do not affect existing railings of this
style unless Allow Each Railing to Vary is cleared.

7 Specify the parameters for bottom rails:

Then…If you want to…

enter a value for Horizontal.specify the height of the lowest rail
when it is horizontal

enter a value for Sloping.specify the height of the lowest rail
when it is on a stair flight

enter a value for Number of Rails.
When you designate multiple bot-

designate more than one bottom
rail

tom rails, you can enter a value for
Spacing of Rails.

8 Click OK.

Specifying Posts of a Railing Style
Use this procedure to change the following settings for posts in a railing style:

■ type of posts (first fixed, last fixed, fixed, dynamic, and balusters)

■ distance the posts extend above railings
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■ maximum spacing between posts and balusters

■ number of balusters for each tread for railings that are attached to stairs

First fixed posts and last fixed posts are attached at the beginning and end of
each railing, respectively. Additional fixed posts and dynamic posts are added
to the railing between the first and last fixed posts. Balusters are closely spaced
supports for a railing. You can specify the spacing between dynamic posts and
between balusters.

1 Select a railing.

2 Click Railing tab ➤ General panel ➤ Edit Style

drop-down ➤ Railing Styles  .

3 Select the style you want to edit.

4 Click the Post Locations tab.

5 Specify whether the post properties of this railing style can be
overridden for individual railing objects:

Then…If you want to…

select Allow Each Railing to Vary.specify post properties, such as
fixed posts, dynamic posts, and
balusters, when you add or modify
railings

clear Allow Each Railing to Vary.require all railings of this style to use
the post settings of the style
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NOTE Changes to posts do not affect existing railings of this style
unless Allow Each Railing to Vary is cleared.

6 Specify the post locations:

Then…If you want to…

select Fixed Posts.include fixed posts at the beginning
and end of the railing

enter a value for Extension of ALL
Posts from Top Railing.

specify the distance above or below
the top rail for all posts

enter a value for Extension of ALL
Posts from Floor Level.

specify the height of all posts from
the floor

select Fixed Posts at Railing Corners.include fixed posts at the corners
of the railing

select Dynamic Posts. You can then
enter a value for Maximum Center
to Center Spacing.

include dynamic posts with the
railing

select Balusters. You can then enter
a value for Maximum Center to
Center Spacing.

include balusters with the railing

select Stair Tread Length Override.
You can then enter a value for

override the number of balusters on
each stair tread

Number per Tread. This applies
only to railings that are attached to
stairs.

7 Click OK.

Specifying the Components of a Railing Style
Use this procedure to specify the shape of the railing components, and the
width, depth, and rotation of each component for each railing style.

You can use profiles to create railing components with custom shapes. The
custom profile replaces a component on the Components tab of the railing
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style in the Style Manager. For more information, see Creating a Profile for a
Custom Railing Component on page 2363.

1 Select a railing.

2 Click Railing tab ➤ General panel ➤ Edit Style

drop-down ➤ Railing Styles  .

3 Select the style you want to edit.

4 Click the Components tab.

5 Select the component to change.

6 Select the profile you want to use for the selected component.

The default profiles are circular and rectangular. Any profiles in
the current drawing are also displayed.

7 Click Width, and enter a width for the selected component.

8 Click Depth, and enter a depth for the selected component.

Depth is not available for the default circular profile.

9 Click Rotation, and enter a rotation for the selected component.

Rotation is not available for rail components, or when the default
circular profile is used for posts.

10 Click OK.
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Creating a Profile for a Custom Railing Component
Use this procedure to create a profile from a closed polyline. You can then use
the profile to define a custom railing component. The custom shape is extruded
from the profile along the length of the component.

The height and the width of the polyline you use to create the profile define
the height and the width of the railing component. You can change the scale
and dimensions of the profile as you add it.

1 Draw a closed polyline of the height and the depth needed for
the resulting railing component.

2 Click Manage tab ➤ Style & Display panel ➤  ➤ Profile

Definitions  .

3 Right-click Profiles, and click New.

4 Enter a name for the profile.

5 In Style Manager, right-click the new profile, and click Set From.

6 Select the profile in the drawing area.

7 When prompted to add another ring, press ENTER.

8 Press ENTER to accept Centroid as the insertion point of the profile.

9 Click OK.

You can now use the profile to replace a railing component. For
more information, see Adding Custom Railing Blocks and Profiles
to a Railing Style on page 2370.

Specifying the Railing Extensions of a Railing Style
Use this procedure to control the length of the handrail and guardrail
extensions at the top and bottom of stair flights. If a bottom rail exists, it
extends as far as the railing above it. If railing extensions are not allowed to
vary, the endpoint cannot be grip-edited.

1 Select a railing.

2 Click Railing tab ➤ General panel ➤ Edit Style

drop-down ➤ Railing Styles  .

3 Select the style you want to edit.
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4 Click the Extensions tab.

5 Specify whether railing extensions of this railing style can be
overridden for individual railing objects:

Then…If you want to…

select Allow Each Railing to Vary.specify railing extension properties,
such as handrails and guardrails at
the top and bottom of entire stairs,
when you add or modify railings

clear Allow Each Railing to Vary.require that all railings of this style
use the extension settings of the
style

NOTE Changes to railing extensions do not affect existing railings
of this style unless Allow Each Railing to Vary is cleared.

6 Specify the properties of railing extensions:

Then…If you want to…

clear Use Stair Landing Extension
under At Floor Levels.

use values in this dialog box to
specify extensions at floor levels.

under At Floor Levels, enter values
for Handrail and Guardrail. Select +

specify the length of the handrail
and guardrail at the top of an entire
stair T next to the value to add the tread

length to the extension value.
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Then…If you want to…

under At Floor Levels, enter values
for Handrail and Guardrail. Select +

specify the length of the handrail
and guardrail at the bottom of an
entire stair T next to the value to add the tread

length to the extension value.

clear Use Stair Landing Extension
under At Landings.

use values in this dialog box to
specify extensions at landings.

under At Landings, enter values for
Handrail and Guardrail. Select + T

specify the length of the handrail
and guardrail at the top of a flight

next to the value to add the tread
length to the extension value.

under At Landings, enter values for
Handrail and Guardrail. Select + T

specify the length of the handrail
and guardrail at the bottom of a
flight next to the value to add the tread

length to the extension value.

7 Click OK.

Specifying the Materials of a Railing Style
A railing consists of a number of components whose display properties can
be determined by the materials assigned to each component. You assign one
material to each physical component of the railing. For example, you assign
a wood material to the balusters of a railing and a stainless steel material to
the handrail and bottomrail. You assign materials to components in each
display representation where you want the materials to be used.

If you want to use the display properties of the railing style, instead of using
material display properties, you can turn off the material assignments in the
display properties of the railing style.

Material definitions consist of display components that correspond to
component types of objects. For example, the Linework component of a
material is used for all linework in plan view. The Surface Hatch component
of a material is used to hatch all object surfaces in three dimensional (3D)
model views and in elevations.
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Railing Materials and Display Components
The following table identifies the material component that corresponds to
each railing component.

Material ComponentRailing Component

Plan, Plan Screened, Plan High Detail

LineworkPosts

LineworkGuardrail

LineworkHandrail

LineworkBottomrail

Plan Low Detail

LineworkPosts

LineworkGuardrail

LineworkHandrail

Model, Model ByBlock, Model Mono-
chrome

3D BodyBaluster

3D BodyPosts

3D BodyGuardrail

3D BodyHandrail

3D BodyBottomrail
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Assigning Materials to a Railing Style
Use this procedure to assign materials to the individual components of a railing
style. The component uses the display properties of the material instead of
the style display properties.

You can assign a material to any physical component of the railing. Custom
components and components that are only symbolic graphics do not use
materials for their display properties.

NOTE If a material assignment does not determine the display properties of a
railing component, you can change the display properties of the railing style as
described in Specifying the Display Components of a Railing Style on page 2368.

1 Select a railing.

2 Click Railing tab ➤ General panel ➤ Edit Style

drop-down ➤ Railing Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select By Material for any component to which you want to assign
a material, and click OK.

If the setting for By Material is not available, the display of this
component cannot be determined by a material.

9 Click the Materials tab.

10 Select the component you want to change, and select a different
material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Although you can also edit a material definition from this
dialog box, any changes you make to the material definition apply
to all objects that are assigned the material.

11 Click OK.
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Specifying the Display Components of a Railing Style
Use this procedure to change the following properties of the display
components of a railing style:

■ Visibility (display component is on or off)

■ By Material (material assigned to the display component determines its
display properties)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

NOTE If a material assignment determines the display properties of components
in the railing style, you can change the properties of the display component by
clearing By Material. You can also override the material assignment with a different
material. For more information, see Specifying the Materials of a Railing Style on
page 2365.

1 Select a railing.

2 Click Railing tab ➤ General panel ➤ Edit Style

drop-down ➤ Railing Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select the component to change, and select a different setting for
the property.

9 Click OK.
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Specifying Classifications for a Railing Style
Use this procedure to specify classifications for any classification definition
applied to a railing style.

For more information about creating and applying classification definitions,
see Classification Definitions on page 3872.

1 Select a railing.

2 Click Railing tab ➤ General panel ➤ Edit Style

drop-down ➤ Railing Styles  .

3 Select the style that you want to change.

4 Click the Classifications tab.

By default, the classification for all classification definitions is
Unspecified. If no classification definitions are listed, none are
applied to area styles.

5 For each classification definition, select the classification you want
to apply to the current railing style.

6 Click OK.

Attaching Notes and Files to a Railing Style
Use this procedure to enter notes and attach reference files to a railing style.
You can also edit notes and edit or detach reference files from a railing style.

1 Select a railing.

2 Click Railing tab ➤ General panel ➤ Edit Style

drop-down ➤ Railing Styles  .

3 Select the style you want to edit.

4 Click the General tab.

5 To add a description to the railing style, enter the description
under Description.

6 Click Notes.

7 To add a note, click the Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file
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Then…If you want to…

select the file, and click Edit. Edit
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application. Click OK
when you finish editing.

edit a reference file

select the file name, click Delete,
and click OK.

detach a reference file

9 Click OK.

Adding Custom Railing Blocks and Profiles to a Railing
Style

You can specify custom blocks and profiles to add to or replace individual
railing components. You can add to or replace posts, dynamic posts, and
balusters can be added to or replaced, and you can add to (but not replace)
other railing components.

When you add a custom block and profile, you can specify several rules for
positioning and scaling the new component. Each custom block or profile is
also added to the display properties so that you can control its layer, color,
and linetype. Be sure that the objects used to create the custom blocks are
created with their properties designated as ByBlock. Otherwise, they cannot
be controlled through the display properties. For more information about
ByBlock, see “Control the Color and Linetype Properties in Blocks” in AutoCAD
help.

After you create custom blocks and profiles, you can attach them to railing
styles. Using custom blocks and profiles, railing styles can provide a much
richer and more flexible set of railing graphics.

Adding a Custom Block to a Railing Style
Use this procedure to add a custom block to a railing style. The block can
replace a railing component, such as a baluster, or be added to a component.
You attach the block in display representations, such as Model, that show the
railing in three dimensions.
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Assigning a custom block as a baluster component to a railing

You can use a block to replace a component on the Components tab of a
railing style in the Style Manager, or you can use a block to represent additional
railing components in the display of railings. You add a block to the display
components of a style; a component that you replace on the Components tab
is already a part of the display properties.

1 Create a block to represent the component to add to the railing.

Create the block in the same plane as the railing to which you
will attach it. Be sure that the objects used to create the custom
blocks are created with their properties designated as ByBlock.
Otherwise, they cannot be controlled through the display
properties.

2 Select a railing.

3 Click Railing tab ➤ General panel ➤ Edit Style

drop-down ➤ Railing Styles  .

4 Select the style you want to edit.

5 Click the Display Properties tab.

6 Select the display representation where you want the changes to
appear, and select Style Override.

NOTE You can add a custom block to a railing only in Model-based
display representations.
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7 If necessary, click  .

8 Click the Other tab.

9 Under Custom Block Display, click Add.

10 In the Custom Block dialog box, click Select Block.

11 Select the block to use, and click OK.

12 Specify the scale of the custom block:

Then…If you want to…

clear all options under Scale to Fit.use the block at its drawn size

select Width.scale the custom block to the width
of the object to which it is attached

select Depth.scale the custom block to the depth
of the object to which it is attached

select Height.scale the custom block to the
height of the object to which it is
attached

select Lock Ratio. If the object is
scaled in one direction to fit another

lock the XY shape of the object

criterion for Scale to Fit, the whole
custom block is scaled equally.

select Between Comp. Baluster,
Fixed Post, and Dynamic Posts are

add the selected block to the rail-
ings between the selected compon-
ents the only valid component selec-

tions.

13 Specify the Mirror In direction, if necessary:

Then…If you want to…

select Mirror X.create a mirror of the component
in the X direction, along the length
of the railing

select Mirror Y.create a mirror of the component
in the Y direction, across the width
of the railing
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Then…If you want to…

select Mirror Z.create a mirror of the component
in the Z direction

14 Specify the location of the insertion point in relation to the object:

Then…If you want to…

select Left, Center, or Right for X.specify the location of the X inser-
tion point

select Front, Center, or Back for Y.specify the location of the Y inser-
tion point

select Bottom, Middle, or Top for
Z.

specify the location of the Z inser-
tion point

Specify the post orientation relative to the up and down directions
on a stair run in plan view as shown in the following illustration:

Specify the post orientation relative to the up and down directions
on a stair run in elevation view as shown in the following
illustration:

15 Specify the insertion offset for the component in the X, Y, and Z
directions.
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16 Specify the type of railing component that the block represents:

Then…If you want to…

select Baluster for Component.represent balusters with the block

select Fixed Post for Component.represent fixed posts with the block

select Dynamic Post for Compon-
ent.

represent dynamic posts with the
block

select Replace.replace the current baluster, fixed
post, or dynamic post with the
block

select Guardrail for Component.represent a guardrail with the block

select Handrail for Component.represent a handrail with the block

select Bottomrail for Component.represent a bottom rail with the
block

The two groups of components are mutually exclusive, so selecting
an object from one column makes the other unavailable. You can
select more than one object in each column to apply the block
to each selected component. For example, you can use the same
block for the fixed posts and dynamic posts.

17 Specify where the block is applied to the components:

Then…If you want to…

select All for Attach to.apply the block to all instances of
the selected components

select First for Attach to.apply the block to the first instance
of the selected component, based
on the direction the railing was
drawn

select Last for Attach to.apply the block to the last instance
of the selected component, based
on the direction the railing was
drawn
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Then…If you want to…

select Selection for Attach to. The
components are numbered in the

apply the block to a selected num-
ber of components

order the railing was drawn, begin-
ning with 1.

18 Click OK twice.

After adding the block to the style, you can specify the layer, color,
and linetype of the block. For more information, see Specifying
the Display Components of a Railing Style on page 2368.

Adding a Custom Profile to a Railing Style
Use this procedure to add a custom profile to a railing style in the Plan display
representation. You can replace one or more railing components with a custom
profile, or you can assign different custom profiles to different railing
components.

You can use a profile to replace a component on the Components tab of the
railing style in the Style Manager, or you can use a profile to represent
additional railing components in the display of railings. You add a profile to
the display properties of a style; a component that you replace on the
Components tab is already a part of the display properties.

For more information about creating profiles for railing components, see
Creating a Profile for a Custom Railing Component on page 2363.
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Assigning a profile to a baluster in a railing

1 Create a profile to represent the component to add to the railing.
Create the profile in the XY plane.

2 Select a railing.

3 Click Railing tab ➤ General panel ➤ Edit Style

drop-down ➤ Railing Styles  .

4 Select the style you want to edit.

5 Click the Display Properties tab.

6 Select the display representation where you want the changes to
appear, and select Style Override.

NOTE You can add a custom profile to a railing only in Plan-based
display representations.

7 If necessary, click  .

8 Click the Other tab.

9 Under Custom Profile Display, click Add.

10 In the Custom Profile dialog box, click Select Profile.

11 Select the profile, and click OK.

12 Specify the scale of the custom profile:

Then…If you want to…

clear all options under Scale to Fit.use the profile at its drawn size
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Then…If you want to…

select Width.scale the custom profile to the
width of the object to which it is
attached

select Depth.scale the custom profile to the
depth of the object to which it is
attached

select Height.scale the custom profile to the
height of the object to which it is
attached

select Lock Ratio. If the object is
scaled in one direction to fit another

lock the XY shape of the object

criterion for Scale to Fit, the entire
custom profile is scaled equally.

select Between Comp. Baluster,
Fixed Post, and Dynamic Posts are

add the selected profile to the rail-
ings between the selected compon-
ents the only valid component selec-

tions.

13 Specify the Mirror In direction, if necessary:

Then…If you want to…

select Mirror X.create a mirror of the component
in the X direction, along the length
of the railing

select Mirror Y.create a mirror of the component
in the Y direction, across the width
of the railing

14 Specify the angle to rotate the component in the Z direction, if
necessary.

15 Specify the location of the insertion point in relation to the object:

Then…If you want to…

select Left, Center, or Right for X.specify the location of the X inser-
tion point
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Then…If you want to…

select Front, Center, or Back for Y.specify the location of the Y inser-
tion point

Specify the post orientation relative to the up and down directions
on a stair run in plan view as shown in the following illustration:

Specify the post orientation relative to the up and down directions
on a stair run in elevation view as shown in the following
illustration:

16 Specify the insertion offset for the component in the X and Y
directions.

17 Specify the type of railing component that the profile represents:

Then…If you want to…

select Baluster for Component.represent balusters with the selec-
ted profile

select Fixed Post for Component.represent fixed posts with the selec-
ted profile

select Dynamic Post for Compon-
ent.

represent dynamic posts with the
selected profile

select Replace.replace the current baluster, fixed
post, or dynamic post with the se-
lected profile
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Then…If you want to…

select Guardrail for Component.add a guardrail to the selected pro-
file

select Handrail for Component.add a handrail to the selected pro-
file

select Bottomrail for Component.add a bottom rail to the selected
profile

The two groups of components are mutually exclusive, so selecting
an object from one column makes the other unavailable. You can
select more than one object in each column, and apply the profile
to each selected component. For example, you can use the same
profile for the fixed posts and dynamic posts.

18 Specify where the profile is applied to the components:

Then…If you want to…

select All for Attach to.apply the profile to all instances of
the selected components

select First for Attach to.apply the profile to the first instance
of the selected component, based
on the direction the railing was
drawn

select Last for Attach to.apply the profile to the last instance
of the selected component, based
on the direction the railing was
drawn

select Selection for Attach to. The
components are numbered in the
order the railing was drawn.

apply the profile to a selected
number of components

19 Click OK twice.
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Turning Off a Custom Block or Custom Profile in a Railing Style
Use this procedure to turn off the display of all custom blocks or profiles
without actually removing them from the railing style.

You can selectively turn off the visibility of individual display blocks on the
Layer/Color/Linetype tab. This is one way to switch between alternate blocks.
For more information, see Specifying the Display Components of a Railing
Style on page 2368.

1 Select a railing.

2 Click Railing tab ➤ General panel ➤ Edit Style

drop-down ➤ Railing Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

NOTE Custom blocks are added and turned off in Model-based
display representations; Custom profiles are added and turned off in
Plan-based display representations.

6 If necessary, click  .

7 Click the Other tab.

8 Disable the custom component:

Then…If you want to…

click Disable Custom Blocks.turn off a custom block

click Disable Custom Profiles.turn off a custom profile

9 Click OK.

Removing a Custom Block from a Railing Style
Use this procedure to delete custom components from a railing style.

1 Select a railing.
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2 Click Railing tab ➤ General panel ➤ Edit Style

drop-down ➤ Railing Styles  .

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

NOTE Custom blocks are added and removed in Model-based display
representations; Custom profiles are added and removed in Plan-based
display representations.

6 If necessary, click  .

7 Click the Other tab.

8 Select the component to remove, and click Remove.

9 Click OK.

Removing a Custom Block from a Railing Style | 2381



2382



Roofs

Roofs are AEC objects that model an entire roof surface. You can create roofs independently
of other objects, or you can select a polyline shape and place a roof on that shape. You can
also select closed walls and place a roof on the walls, change the slope of a roof, and edit its
edges and faces.

Roofs
Roofs are AEC objects that you can use to model an entire multiple-face roof
surface. You can create roofs independently of other objects, or you can place
a roof on a shape defined by a polyline or by a closed set of walls. After creating
the roof, you can change its overall dimensions and slope, or edit its edges and
faces individually. For more flexibility in customizing a roof, you can convert
it to a collection of individual roof slabs.

Roof Slabs

A roof slab models a single face of a roof. Roof slab objects also differ from roof
objects in that each roof slab is a separate entity with no direct connection to
other entities. When you use multiple roof slabs to model an entire roof surface,
you have more flexibility in editing the roof, but the combined topology (3D
geometry) of the roof is not calculated automatically. For this reason, it is
recommended that when you design complex roofs, you start with a roof object.
Then, when the design is substantially complete, but you need more flexibility
for customizing edges and other details, you can convert the roof to individual
roof slabs. For information on creating and editing roof slabs, see Slabs and Roof
Slabs on page 2405.

While roof slabs do not dynamically interact with each other, they do allow
significant control over the roof geometry. For example, you can trim roof slabs
individually, extend them, and miter them with other roof slabs. You can also
cut holes in roof slabs, add or subtract mass elements, and apply detailed fascia

30

2383



and soffit profiles to any edge at any angle and orientation. Because roof slabs
are style-based, you can apply design changes globally.

Materials in Roofs

You can assign materials to a roof. Materials are displayed in wireframe and
working shade views, or when rendered. Materials have specific settings for
the physical components of a roof, such as slab. For more information see
Material Components and Display Properties on page 898.

Viewing roofs in 2D wireframe and rendered views

AutoCAD Architecture provides predefined materials for common design
purposes. These materials contain settings for roof components. You can use
the predefined materials as they are, or modify them for your designs. You
can also create your own materials. Object styles provided with the software
have appropriate materials already assigned to them. For more information,
see Slab/Roof Slab Materials and Display Components on page 2497 and Material
Components and Display Properties on page 898.

Using Roof Tools to Create Roofs
Tools provided with AutoCAD Architecture let you quickly place roofs by
selecting a roof tool with a specific roof style and other predefined properties.
You can use the tool with all of its default settings, or you can change any
properties that are not controlled by the style. You can create roofs with single
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or double slopes and gable roofs. You can also use roof tools to create new
roofs by applying tool properties to existing polylines and walls.

Tool palette containing roof tool

The default tool palettes in the workspace contain sample roof tools that you
can use and customize as necessary. In addition, the following catalogs
provided with the software contain roof tools that you can add to your tool
palettes:

■ Stock Tool catalog

■ Sample Palette catalog

Custom palettes created by your CAD manager or other users may also contain
roof tools with properties customized for your projects or office standards.

Creating a Slope Roof
Use this procedure to add a slope roof that has the properties specified in the
roof tool that you select. You can create a single slope or a double slope roof
object. To specify settings when you add a roof, see Creating a Slope Roof with
User-Specified Settings on page 2388.

NOTE To add additional slopes to a roof face, right-click a roof object and click
Edit Edges/Faces.
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Creating a single slope roof

Creating a double slope roof

1 Open the tool palette that contains the roof tool you want to use,
and select the tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Roof Slab

drop-down ➤ Roof  .

2 On the Properties palette, select Single slope or Double slope for
Shape.

TIP After specifying the desired setting, you can move or hide the
Properties palette to expose more of the drawing area.

3 In the drawing area, specify points for the corners of the roof.

4 When you are finished specifying points, press ENTER.

Creating a Gable Roof
Use this procedure to add a gable roof that has the properties specified in the
roof tool that you select. You can create a single sloped roof and set each edge
to gable as needed. You can specify a slope for the gable ends to create a hip.
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To specify settings when you add a roof, see Creating a Gable Roof with
User-Specified Settings on page 2389.

Viewing a gable roof end

NOTE You can create a gable on an existing roof by gripping any ridge line point
and stretching it past the roof edge.

1 Open the tool palette that contains the roof tool you want to use,
and select the tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Roof Slab

drop-down ➤ Roof  .

2 On the Properties palette, select Single slope for Shape.

3 In the drawing area, specify the first point for the first roof edge.

4 Specify the second point to complete the first sloped roof edge.

5 On the Properties palette, select Gable for Shape.

6 In the drawing area, specify the next point to create a gable roof
edge.

7 Select Single slope for Shape.

8 Specify the next point to create a sloped roof edge.

9 Select Gable slope for Shape.

10 Specify additional points as needed to define the roof, and press
ENTER.

To create a clipped gable roof, you first need to convert the gabled
roof to roof slabs. For more information, see Creating a Roof Slab
from a Roof on page 2418 and Creating a Clipped Gable Roof on
page 2484.
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Creating Dormers
To add a dormer to a roof, you must first convert the roof to roof slabs, and
then create additional roof slabs, walls, and all other parts of the dormer. For
more information, see Creating a Roof Slab from a Roof on page 2418 and
Creating a Dormer in a Roof Slab on page 2485.

Creating a Slope Roof with User-Specified Settings
Use this procedure to add a slope roof with settings that you specify. You can
create a single slope or a double slope roof object.

Creating a single slope roof

Creating a double slope roof

1 Open the tool palette that contains the roof tool you want to use,
and select the tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Roof Slab

drop-down ➤ Roof  .

2 On the Properties palette, expand Basic, and expand Next Edge.

3 Select Single slope or Double slope for Shape.

4 Enter a value for Overhang.
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5 Expand Lower Slope, and enter values for Plate Height, Rise, and
Slope.

Plate height is the height of the bottom surface of the roof at its
lowest edge (where the overhang begins). This is usually the height
of the top plate of the wall that the roof sits on.

6 For a double slope roof, expand Upper Slope, and enter values for
Upper Height, Rise, and Slope.

TIP After specifying the desired settings, you can move or hide the
Properties palette to expose more of the drawing area.

7 In the drawing area, specify points for the corners of the roof.

8 When you are finished specifying points, press ENTER.

Creating a Gable Roof with User-Specified Settings
Use this procedure to add a gable roof with settings that you specify. You
create a single sloped roof and set each edge to gable as needed. You can specify
a slope for the gable ends to create a hip.

TIP You can create a gable on an existing roof by dragging a ridge line grip to
the roof edge or beyond, as shown.

Viewing a gable roof end

Creating a Gable Roof with User-Specified Settings | 2389



1 Open the tool palette that contains the roof tool you want to use,
and select the tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Roof Slab

drop-down ➤ Roof  .

2 On the Properties palette, expand Basic, and expand Next Edge.

3 Select Single slope for Shape.

TIP You can move or hide the Properties palette to expose more of
the drawing area.

4 In the drawing area, specify the first point for the first roof edge.

5 Specify the second point to complete the first sloped roof edge.

6 On the Properties palette, select Gable for Shape.

7 In the drawing area, specify the next point to create a gable roof
edge.

8 Select Single slope for Shape.

9 Specify the next point to create a sloped roof edge.

10 Select Gable slope for Shape.

11 Specify additional points as needed to define the roof, and press
ENTER.

Creating a Roof from Walls
Use this procedure to create a roof that is based on a selected closed set of
walls and has the properties of the roof tool you select. You can edit these
properties after creating the roof. The roof takes its plate height from the top
of each wall segment.

NOTE If your walls are not properly cleaned up, the roof conversion is
unpredictable. For more information, see Cleanup Group Definitions on page 1351.
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Creating a roof from walls

1 Open the tool palette that contains the roof tool you want to use.

2 Right-click a roof tool, and click Apply Tool Properties
to ➤ Linework and Walls.

3 Select the walls to convert, and press ENTER.

NOTE If the walls you select are not closed, a roof is added to the
top of each wall segment.

4 When prompted to erase the original geometry, press ENTER to
keep the wall, or enter y (Yes) to erase it.

5 Edit the properties of the roof on the Properties palette, if needed.

Creating a Roof from Polylines
Use this procedure to create a roof that is based on a two-dimensional (2D)
polyline and has the properties of the roof tool you select. You can edit these
properties after creating the roof.
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Creating a roof from a polyline

1 Draw a closed 2D polyline in the shape of the intended roof, in
the location where you want to place the roof.

2 Open the tool palette that contains the roof tool you want to use.

(You may have to scroll to display the desired tool.)

3 Right-click a roof tool, and click Apply Tool Properties
to ➤ Linework and Walls.

4 Select the polyline to convert, and press ENTER.

5 When prompted to erase the original geometry, press ENTER to
keep the linework, or enter y (Yes) to erase it.

6 Edit the properties of the roof on the Properties palette, if needed.

Creating a Roof Tool
Use this procedure to create a roof tool and add it to a tool palette. You may
want to create your own roof tools if you are placing multiple roofs that have
the same properties.

For example, you are creating an office building that has a multi-peaked roof.
Although the entire roof is single sloped, each peak has a different slope. To
work efficiently, you can create a roof tool for each slope, and select the
appropriate tool to place the roofs with the correct slope on each area of the
building.

1 Open the tool palette on which to create a tool.
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2 Create the tool:

Then…If you want to…

select the object, and drag it to the
tool palette.

create a tool from a roof in the
drawing

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the palette where you want
to add the tool, right-click, and click
Paste.

click Home tab ➤ Build pan-

el ➤ Tools drop-down ➤ Content

copy a tool from the Content
Browser

Browser , and locate the tool
you want to copy. Position the
cursor over the i-drop handle, and
drag the tool to the tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

6 Expand Basic, and expand General.

7 Click the setting for Description, enter a description of the roof
created from this tool, and click OK.

8 Specify a layer key and any layer key overrides if you do not want
to use the layer assignments specified in the layer key style used
in the drawing.

9 Specify roof settings:

Then…If you want to…

expand Dimensions, and enter a
value for Thickness.

change the thickness value

expand Dimensions, and select a
new setting for Edge cut.

change the type of edge
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Then…If you want to…

expand Next Edge, and select a
new setting for Shape.

change the roof shape

expand Next Edge, and enter a
value for Overhang.

add or remove the overhang, or
change the overhang value

expand Lower Slope, and enter a
value for Plate Height.

change the plate height

expand Upper Slope, and enter a
value for Upper Height.

change the upper height for a
double slope roof

expand Lower Slope, or Upper
Slope for a double slope roof, and
enter a value for Rise or Slope.

change the rise or slope angle for
each slope

10 Click OK.

Editing Roofs
After placing roofs, you can edit any characteristics of the roof that you
specified when you drew the roof. You can change the basic geometry of a
roof, apply a different roof shape, and change the roof edge or overhang
conditions.

AutoCAD Architecture offers several methods for editing roofs:

■ Edit roofs directly using grips for dimensions and other physical
characteristics.

■ For grip edit operations where you are changing a dimension or an angle,
the Dynamic Input feature lets you enter a precise value instead of moving
a grip. When this feature is active (click DYN on the application status
bar), selecting a grip displays a text box in which you can enter the desired
value for the associated dimension or angle. For more information, see
“Use Dynamic Input” in AutoCAD Help.

■ Change roof settings on the Properties palette. You can also use the Display
tab of the Properties palette to change the display property settings for a
selected object display component in the current display representation.
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For more information, see Using the Properties Palette to Change Display
Properties on page 793.

■ Select editing commands from the context menu for a selected roof.

Using Grips to Edit Roofs
Refer to the illustrations and steps in this topic to use roof grips to edit roofs.

Editing Roof Dimensions

1 Select the roof.

2 Select the grip for the dimension you want to change.

Roof grips

3 Move the grip until the dimension value you want is displayed,
and click once, or enter a value.

Applying Tool Properties to an Existing Roof
Use this procedure to apply the properties of a roof tool to one or more existing
roofs. The properties include any settings specified in the tool you select.

1 Open the tool palette that you want to use.

If necessary, scroll to display the tool that you want to use.

2 Right-click a roof tool, and click Apply Tool Properties to ➤ Roof.

3 Select the roof, and press ENTER.

4 When prompted to erase the original geometry, press ENTER to
keep the linework, or enter y (Yes) to erase it.
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5 Edit the properties of the roof on the Properties palette, if
necessary.

Changing the Dimensions of a Roof
Use this procedure to change the dimensions of a roof, including the plate
height, the upper height for a double slope (gambrel) roof, the slope, and the
depth of the overhang. You can also change the thickness of the roof slabs
and the type of roof edge.

NOTE You can create a gable end on a roof by gripping any ridge line point and
stretching it past the roof edge.

1 Select the roof.

2 On the Properties palette, specify roof settings:

Then…If you want to…

under Dimensions, enter a value for
Thickness.

change the thickness value

under Dimensions, select a new
setting for Edge cut.

change the type of edge

under Dimensions, select a new
setting for Shape.

change the number of slopes

under Dimensions, enter a value for
Overhang.

add or remove the overhang, or
change the overhang value

under Lower Slope, enter a value
for Plate Height.

change the plate height

under Upper Slope, enter a value
for Upper Height.

change the upper height for a
double slope roof

under Lower Slope, or Upper Slope
for a double slope roof, enter a
value for Rise or Slope.

change the rise or slope angle for
each slope
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Changing the Edges and Faces of a Roof
Use this procedure to edit the edges and faces of a roof. You can edit:

■ the height and overhang of individual edges

■ the number of segments and the radius for curved segments

■ the height and slope of individual roof faces

1 Select the roof you want to change.

2 Click Roof tab ➤ Modify panel ➤ Edit Edges  .

3 Select roof edges that you want to change and press ENTER.

As you select edges, they are numbered consecutively, beginning
with zero, for display in the dialog box.

4 Specify new values for each roof edge:

Then…If you want to…

select Height for the roof edge, and
enter the height value.

change the height of a roof edge

select Overhang for the roof edge,
and enter the overhang value.

change the overhang of a roof edge

select Segments for the roof edge,
and enter the number of segments.

change the number of segments in
a curved roof for a roof edge
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Then…If you want to…

select Radius for the roof edge, and
enter the radius.

change the radius of the curved
roof edge

5 Specify new dimensions for the roof faces of the selected edges:

Then…If you want to…

select Height for the roof face, and
enter the height value.

change the height of a roof face

select Slope for the roof face, and
enter the slope value.

change the slope of a roof face

click the blank space under the last
number in the Face column, and
enter values for Height and Slope.

add a face to the selected edge

select the Face column number,
and press DELETE.

remove a roof face

6 Click OK.

Converting a Roof to Roof Slabs
Use this procedure to convert a roof to one or more roof slabs, each modeling
a separate face of the roof. Roof slab objects differ from roof objects in that
each roof slab is a separate entity, defined by its perimeter, edge conditions,
and style. This gives you more flexibility in controlling to geometry of the
roof and its edges. Also, because roof slabs are style based, you can apply design
changes globally.

For more information about working with roof slabs, see Slabs and Roof Slabs
on page 2405.

1 Select the roof you want to convert.

2 Click Roof tab ➤ Modify panel ➤ Convert  .

The Convert to Roof Slabs worksheet displays the roof slab styles
that exist in your current drawing.

2398 | Chapter 30   Roofs



Convert to Roof Slabs worksheet

3 Select a roof slab style.

4 Select Erase Layout Geometry to erase the roof and click OK.

5 Select individual roof slabs and edit them as needed.

Specifying the Material of a Roof
Use this procedure to select a different material for the components of an
individual roof.

NOTE If a material assignment does not determine the display properties of the
roof component, you can change the properties of the display component as
described in Specifying the Display Properties of a Roof on page 2400.

1 Select the roof you want to change, right-click, and click Edit
Object Display.

2 To verify that the material assignment determines the display
properties of the component, click the Display Properties tab,
select the display representation in which to display the changes,

and click  .

3 Click the Layer/Color/Linetype tab, verify that By Material is
selected for the component, and click OK.

4 Click the Materials tab.

5 Select the component you want to change, and select a different
material definition.

You can select any material definition in the current drawing, or

click  to create a new one and assign it to a component.

WARNING Although you can edit a material definition from this
dialog box, any changes you make apply to all objects that are
assigned the material.

6 Click OK.
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Specifying the Display Properties of a Roof
Use this procedure to change the following properties of the display
components of an individual roof:

■ Visibility (display component is on or off)

■ By material (material assigned to the display component determines its
display properties)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

NOTE If a material assignment determines the properties of a roof display
component, you can change the properties of the display component by clearing
By Material or by overriding the material assignment with a different material. For
more information, see Specifying the Material of a Roof on page 2399.

1 Select the roof you want to change, right-click, and click Edit
Object Display.

NOTE You can also use the Display tab of the Properties palette to
change the display property settings for a selected object display
component in the current display representation. For more
information, see Using the Properties Palette to Change Display
Properties on page 793.

2 Click the Display Properties tab.

3 Select the display representation in which to display the changes,
and select Object Override.

The display representation in bold is the current one.

4 If necessary, click  .

5 Click the Layer/Color/Linetype tab.

6 Select the component to change, and select a different setting for
the property.

7 Click OK twice.
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Specifying the Hatching of a Roof
Use this procedure to specify the hatching of the components of an individual
roof. Hatching is displayed only in the section display representation.

NOTE If a material assignment determines the hatching properties of a roof display
component, you can change the hatching of the display component by clearing
By Material or by overriding the material assignment with a different material. For
more information, see Specifying the Material of a Roof on page 2399.

1 Select the roof you want to change, right-click, and click Edit
Object Display.

NOTE You can also use the Display tab of the Properties palette to
change the display property settings for a selected object display
component in the current display representation. For more
information, see Using the Properties Palette to Change Display
Properties on page 793.

2 Click the Display Properties tab.

3 Select the Section display representation, and select Style Override.

4 If necessary, click  .

5 Click the Hatching tab.

6 Select the display component, and click the setting for Pattern.

7 Select the hatching for the display component:

Then…If you want to…

select Predefined for Type, and se-
lect a pattern.

specify a hatching pattern that is
available in the software

select Custom for Type, and enter
the name of the custom pattern. If

specify a custom pattern

necessary, click Browse, and navig-
ate to the folder that contains the
custom pattern file.

select User-Defined for Type, and
clear Double Hatch.

specify single hatching

select User-Defined for Type, and
select Double Hatch.

specify double hatching
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Then…If you want to…

select Solid Fill for Type.specify solid fill

8 Click OK.

9 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

10 Click Angle, and enter the angle for the selected pattern.

11 Click Orientation, and specify how the hatching is oriented:

Then…If you want to…

select Object.orient the hatching to the roof slab,
regardless of the roof slab rotation

select Global.orient the hatching to the world
coordinate system

12 Click X Offset and Y Offset, and enter offset values.

13 Click OK twice.

Changing the Location of a Roof
Use this procedure to relocate a roof by changing the coordinate values of its
insertion point. The roof also has an orientation with respect to the world
coordinate system (WCS) or the current user coordinate system (UCS). For
example, if the top and bottom of the roof are parallel to the XY plane, its
normal is parallel to the Z axis. You can change the orientation of the roof by
aligning its normal with another axis. You can also rotate the roof on its plane
by changing the rotation angle.

For information about the WCS and UCS, see “Use Coordinates and Coordinate
Systems” in AutoCAD help.

1 Select the roof you want to change.

2 On the Properties palette, expand Basic, and expand Location.

3 Select Additional information.
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4 Specify the location of the roof:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the roof

make the normal of the roof parallel
to the Z axis: under Normal, enter
1 for Z, and enter 0 for X and Y.

locate the roof on the XY plane

make the normal of the roof parallel
to the X axis: under Normal, enter
1 for X and enter 0 for Y and Z.

locate the roof on the YZ plane

make the normal of the roof parallel
to the Y axis: under Normal, enter
1 for Y, and enter0 for X and Z.

locate the roof on the XZ plane

enter a new value for Rotation
Angle.

change the rotation of the roof

5 Click OK.

Attaching Hyperlinks, Notes, or Files to a Roof
Use this procedure to attach hyperlinks, notes, or files to a roof. You can also
edit hyperlinks and notes, and edit or detach reference files from a roof.

1 Select the roof to which you want to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

4 Click OK.

5 To add a note, click the setting for Notes, and enter the note.

6 Click OK.

7 To add a reference file, click the setting for Reference documents,
and attach, edit, or detach a reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file
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Then…If you want to…

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

8 Click OK twice.
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Slabs and Roof Slabs

In AutoCAD Architecture, a slab object is a three-dimensional (3D) body that is bounded by
a planar polygon (perimeter) of any shape, and has multiple edges. A slab is defined by its
perimeter, edge conditions, and style. You can use slabs to draw floors and other building
model components that require a flat surface and edge conditions.

Roof slabs are similar to slabs in most respects, but are based on distinct roof slab styles. When
modeling a roof, you can convert individual faces of the roof into roof slabs, which give you
more flexibility in modeling details of the roof’s geometry.

Overview of Slabs and Roof Slabs
Slabs and roof slabs are AutoCAD Architecture objects that you use to model
floors, roof faces, and other flat surfaces where edge conditions need to be
specified. The slab or roof slab object is a three-dimensional (3D) body bounded
by a planar polygon (perimeter) of any shape, and has multiple edges. The object
is defined by its perimeter, edge conditions, and style. Though they share many
of the same properties, slabs and roof slabs represent separate style categories
and tool types. For instance, you cannot apply the properties of a slab tool to
an existing roof slab object.

Roof Slabs

A roof slab models a single face of a roof. Roof slab objects also differ from roof
objects in that each roof slab is a separate entity with no direct connection to
other entities. When you use multiple roof slabs to model an entire roof surface,
you have more flexibility in editing the roof, but the combined topology (3D
geometry) of the roof is not calculated automatically. For this reason, it is
recommended that when you design complex roofs, you start with a roof object.
Then, when the design is substantially complete, but you need more flexibility
for customizing edges and other details, you can convert the roof to individual
roof slabs.

31
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While roof slabs do not dynamically interact with each other, they do allow
significant control over the roof geometry. For example, you can trim roof
slabs individually, extend them, and miter them with other roof slabs. You
can also cut holes in roof slabs, add or subtract mass elements, and apply
detailed fascia and soffit profiles to any edge at any angle and orientation.
Like slabs, roof slabs are style-based, so you can apply design changes globally.

Methods of Creating Slabs/Roof Slabs

Using slab and roof slab tools, you can create slabs and roof slabs
independently, or you can create them from existing objects, such as walls
and polylines. Slabs and roof slabs created from other objects do not maintain
a link to the original object.

Pitched roofs are usually designed by specifying a plate line and a slope angle.
Roof slabs are designed so that you can use the same approach in laying them
out. To add a roof slab, you simply specify two points and an angle.

If you have a traditionally designed roof created from a two-dimensional (2D)
plan showing ridge, hip, and valley lines, you can trace over that plan with
roof slabs, specifying the desired height and slope. From these values and the
specified points, the software creates the correct three-dimensional (3D) model.

Slab/Roof Slab Bodies

The body of a slab or roof slab is an extrusion perpendicular to the plane of
the perimeter and is defined by the following geometry:

■ The perimeter of a slab or roof slab is a planar polygon defined by the X,Y,Z
coordinates of its vertices.

■ A slab or roof slab has 3 or more vertices, with the ability to add or remove
vertices. Each pair of vertices defines an edge.

■ The thickness of a slab or roof slab extrusion is specified either in the object
style (when it has a fixed thickness) or for the individual object.

■ The position of the slab or roof slab bottom, relative to its perimeter plane,
is controlled by the thickness offset value in the style.

■ The baseline of a slab or roof slab is defined by the first two points you
select when defining the vertices.

■ The slab or roof slab insertion point, by default, is the first point on the
baseline. You can offset the baseline either horizontally or vertically from
the insertion point to allow for precise alignment with walls or structural
elements.
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■ A slab or roof slab has a slope (pitch), which you can specify either as an
angle or as a rise-to-run ratio. If you change the slope, the slab or roof slab
rotates around the slope pivot point.

■ The pivot point is initially the first vertex of the baseline, but you can
move it to any other point, either on or off the slab or roof slab. A small
pyramid-shaped marker represents the pivot point.

■ An imaginary line passing through a slab or roof slab at the perimeter line
(in section) is called the slopeline. The slopeline aligns the slab or roof slab
with the wall base height. The slopeline is the position of the slab or roof
slab baseline relative to its bottom face. The value you enter for the
thickness offset in the slab or roof slab style determines the distance
between the slab or roof slab baseline and the bottom face of the slab or
roof slab.

Geometry of a roof slab
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Slab/Roof Slab Edges

The following parameters define a slab or roof slab edge:

■ edge cut orientation (plumb or square)

■ angle (relative to the orientation)

■ edge style (fascia and soffit)

■ overhang (defines the point at which the fascia begins)

You apply a fascia and soffit to slab or roof slab edges with styles that define
edge conditions

■ The fascia is defined by a profile, with its insertion point located at the
top of the slab or roof slab edge. The local Y axis of the profile polyline
aligns with the slab or roof slab edge angle.

■ The soffit is also defined by a profile, with its insertion point positioned
at the X and Y offsets from the fascia insertion point.

Roof slab with fascia and soffit components

Edge Control

You can customize each slab or roof slab edge individually, applying styles
and making other adjustments as required by your design. A slab or roof slab
edge style defines the fascia and soffit design from profiles that you create for
these components. You can specify whether the style uses a fascia, a soffit,
both, or neither. You also specify how the fascia and soffit are positioned
relative to the slab or roof slab.

Slab and Roof Slab Styles

Slabs and roof slabs have their own distinct style categories in which individual
styles specify the default properties for specific types of slabs or roof slabs.
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These properties include dimensions, edge styles for the fascia and soffit, and
entity properties for layer, color, and linetype. Slab and roof slab styles allow
you to use a different edge style for each edge.

Materials in Slabs and Roof Slabs

You can assign materials to a slab or roof slab. For example, a floor slab can
be assigned a material representing tiles with concrete edges. These materials
are displayed in wireframe or rendered views. Materials have specific settings
for individual components of slabs or roof slabs, such as the body, fascia and
soffit.

Slab appearance in different views

AutoCAD Architecture provides predefined materials for common design
purposes. These materials contain settings for slabs or roof slabs that you can
use as provided or modify for special designs. You can also create materials
from scratch. If you create a material to use only for slabs, name it accordingly;
for example, Slab—Ceramic Tile or Slab Edge—Concrete. This will help in
organizing your material definitions. For more information, see Specifying
the Materials of a Slab or Roof Slab Style on page 2496.

Editing Tools

In addition to the control provided by slab or roof slab styles and edge styles,
AutoCAD Architecture includes a variety of tools that let you edit slabs and
roof slabs to fit unique conditions. For example, you can add holes to slabs
for structures such as chimneys and vent pipes. You can also use roof slabs to
create dormers. For a description of the tools available, see Editing Slabs and
Roof Slabs on page 2426.
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Using Tools to Create Slabs and Roof Slabs
Tools provided with AutoCAD Architecture let you quickly place slabs or roof
slabs by selecting a tool with a specific slab or roof slab style and other
predefined properties. You can use the tool with all of its default settings, or
you can change any properties that are not controlled by the style. You can
also use slab or roof slab tools to create new slabs or roof slabs by applying
tool properties to existing linework, walls, and spaces.

The Design tool palette contains sample slab and roof slab tools that you can
use and customize as needed. Custom palettes created by your CAD manager
or other users may also contain slab or roof slab tools with styles and properties
that are customized for your projects or office standards.

Tool palette containing slab and roof slab tools

Slab and roof slab tools are also included in the Stock Tool catalog supplied
with the Content Browser. For information about using the Content Browser,
see Content Browser Overview on page 129.

Creating a Slab or a Roof Slab
Use this procedure to add a new slab or roof slab that has the properties
specified in the slab or roof slab tool you select. To specify your own settings
when you add a slab or roof slab, see Creating a Slab/Roof Slab with
User-Specified Settings on page 2412.

You add the slab or roof slab by specifying points to define its perimeter as
follows:

■ The first point determines the insertion point of the slab or roof slab and
the start of the baseline. This point also locates the default pivot point of
the slab or roof slab.

■ The second point determines the endpoint of the baseline.

■ Subsequent points establish the vertices of the perimeter.
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1 Open the Design tool palette, and select the Slab tool or the Roof
Slab tool.

(You may have to scroll to display the desired tool.)

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Roof

Slab drop-down ➤ Roof Slab  , or Home tab ➤ Build panel ➤ Roof

Slab drop-down ➤ Slab  .

2 Specify the start point of the slab or roof slab.

3 Specify a second point to define the first edge (baseline) of the
slab.

4 Specify further points to finish defining the perimeter:

Then…If you want to…

specify a point in the direction in
which the perimeter is to close;

close the perimeter by drawing two
edges that meet at a right angle

then enter o (for Ortho). The edge
is extended until it meets another
edge perpendicular to the first
edge.

enter c (for Close).close the perimeter by adding an
edge from the previous point to the
start point of the baseline

5 Press ENTER.
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Drawing a slab

Creating a Slab/Roof Slab with User-Specified Settings
Use this procedure to create a slab or roof slab with settings that you specify.

1 Open the Design tool palette, and select the Slab tool or the Roof
Slab tool.

(You may have to scroll to display the desired tool.)

NOTE You can also access Slab and Roof Slab tools from the Build
panel on the ribbon’s Home tab.

2 On the Properties palette, click the Design tab, expand Basic, and
expand General.

3 Under Style, select a slab or roof slab style.

4 Specify a value for Bound Spaces:

Then…If you want to…

select Yes.allow the slab or roof slab to be
used as a bounding object for asso-
ciative spaces
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Then…If you want to…

select No.prevent the slab or roof slab from
being used as a bounding object
for associative spaces

select By Style.use the bounding settings from the
slab or roof slab style

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

5 Select Projected or Direct for Mode.

If you select Projected, the X,Y coordinates of the first point you
specify are projected to a Z value of the current base height. This
establishes the insertion point. The second point establishes the
baseline. All subsequent points are projected onto a plane
established by the baseline and the specified slope angle. This
mode is provided for architects who wish to lay out a slab or roof
slab by tracing over a plan drawing.

If you select Direct, the points you specify become the vertices of
the slab perimeter.

6 Expand Dimensions.

7 Enter a value for Thickness.

8 Enter a value for the vertical offset distance from the insertion
point for Vertical Offset.

9 Enter a value for the horizontal offset distance from the insertion
point for Horizontal Offset.

10 Select the justification:

Then, for Justify,…If you want to align the …

select Top.top of the slab or roof slab with the
first specified point

select Center.center of the slab or roof slab with
the first specified point

select Bottom.bottom of the slab or roof slab with
the first specified point
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Then, for Justify,…If you want to align the …

select Slopeline.slopeline of the slab or roof slab
with the first specified point

NOTE This justification is used only for inserting a slab or roof slab
and is not retained as a parameter of the inserted object. Justification
is intended primarily for Direct mode.

The slopeline is the position of the slab or roof slab baseline
relative to its bottom face. The thickness offset in the style
determines the distance between the baseline and the bottom
face.

11 Enter a value for the height of the slab or roof slab insertion point
for Base Height.

This is available only when you select Projected mode.

12 Select a direction, or define how the slab or roof slab is drawn
relative to the baseline.

13 Enter a value for the depth of the overhang for Overhang.

14 Select a style for Perimeter edge.

15 If you selected the Projected mode, expand Slope, and enter values
for Rise, Run, or Angle to define the slope of the slab or roof slab.

16 Specify the start point of the slab or roof slab.

The start point is the insertion point and the start of the baseline.
The start point also determines the location of the default pivot
point for the slab or roof slab.

17 Specify a second point to define the first edge (baseline).

18 Specify further points to establish the vertices of the slab or roof
slab perimeter:

Then…If you want to…

specify a point in the direction in
which the perimeter is to close;

close the perimeter by drawing two
edges that meet at a right angle

then enter o (for Ortho). The edge
is extended until it meets another
edge perpendicular to the first
edge.
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Then…If you want to…

enter c (for Close).close the perimeter by adding an
edge from the previous point to the
start point of the baseline

19 Continue to place slabs or roof slabs, and press ENTER when
finished.

Creating a Slab or Roof Slab from Walls
Use this procedure to create a rectangular slab or roof slab from one or more
walls. This is useful when you want a specific alignment between the slab or
roof slab baseline and the wall baseline. When you create a slab or roof slab
from a single wall, the base height of the wall defines the baseline edge of the
slab or roof slab. When you create a slab or roof slab from multiple walls, the
top of the first selected wall defines the baseline edge of the slab or roof slab.

You can create a flat slab or roof slab that follows the outline of multiple walls
by specifying a zero slope. If you select multiple walls and a non-zero slope,
multiple slabs or roof slabs are created.

If the closed polyline intersects one of the selected walls, the slab or roof slab
is invalid and you must select the walls again.

TIP This procedure is useful to place roof slabs on top of existing walls. The Convert
command, accessed from an existing roof object’s contextual Roof tab, is useful
when you want a specific alignment between the slab baseline and the wall
baseline.
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Creating a roof slab from a wall

NOTE When selecting multiple walls, if your walls are not properly “cleaned up,”
the slab or roof slab conversion is unpredictable. For more information, see Cleanup
Group Definitions on page 1351.

1 Open the Design tool palette, and select the Slab tool or the Roof
Slab tool.

(You may have to scroll to display the desired tool.)

2 Right-click the tool, and click Apply Tool Properties to ➤ Linework
and Walls (or Linework, Walls and Roof, in the case of roof slab
tools).

3 Select one or more walls, and press ENTER.

4 Enter y (Yes) to erase the walls, or n (No) to keep the walls in the
drawing.

5 Specify a slab justification method:

Then…If you want to align the …

enter t (Top).top of the slab or roof slab with the
first specified point
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Then…If you want to align the …

enter c (Center).center of the slab or roof slab with
the first specified point

enter b (Bottom).bottom of the slab or roof slab with
the first specified point

enter s (Slopeline).slopeline of the slab or roof slab
with the first specified point

NOTE This justification is used only for inserting a slab or roof slab
and is not retained as a parameter of the inserted object.

The slopeline is the position of the slab or roof slab baseline
relative to its bottom face. The thickness offset in the style
determines the distance between the baseline and the bottom
face.

6 Specify the wall justification for edge alignment:

Then…If you want to align the
baseline edge of the slab or
roof slab to the…

enter l (Left).left side of the wall, based on the
direction the wall was drawn

enter c (Center).center of the wall

enter r (Right).right side of the wall, based on the
direction the wall was drawn

enter b (Baseline).baseline of the wall

7 To specify the slope direction, enter l (Left) or r (Right).

This is based on the direction the wall was drawn.
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Creating a slab based on walls

8 Edit the properties of the slab or roof slab in the Properties palette,
if needed.

Creating a Roof Slab from a Roof
Use this procedure to convert the faces of an existing roof object to individual
roof slabs that have the properties of the roof slab tool you select. You can
then edit the roof slabs and their edges individually.

You can also convert a roof to roof slabs from the contextual Roof tab. For
more information, see Converting a Roof to Roof Slabs on page 2398.

TIP When you convert a roof to roof slabs, the roof slabs will have the same
overhang as the roof.

1 Open the tool palette that contains the roof slab tool you want
to use.

(You may have to scroll to display the desired tool.)

2 Right-click the tool, and click Apply Tool Properties
to ➤ Linework, Walls and Roof.
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3 Select the roof to convert, and press ENTER.

4 When prompted to erase the original geometry, press ENTER to
keep the existing roof, or enter y (Yes) to erase it.

5 Edit the properties of the roof slabs on the Properties palette, if
needed.

Creating a Slab or Roof Slab from a Polyline
Use this procedure to convert a closed polyline to a single slab or roof slab
that has the properties of the tool you select. You can edit these properties
after the object is created. The first line drawn in the polyline becomes the
baseline edge of the slab or roof slab.

Creating slabs or roof slabs from polylines is useful when you need to create
a complex shape or one with curved edges. The smoothness (tessellation) of
curved edges is controlled by 2 AEC display resolution settings called Facet
Deviation and Facet Maximum. Beginning with Autodesk Architectural Desktop
2007, you can adjust these settings after the slab or roof slab is created. Also,
the individual segments or facets making up a curved edge are no longer
treated as separate edges; each arc on the perimeter of a slab or roof slab is
treated as a single edge. For more information, see Specifying the Display
Resolution of Objects with Facets on page 202.

1 Draw a closed polyline of the desired shape in the location where
you want to place the slab or roof slab.

2 Open the tool palette that contains the slab or roof slab tool you
want to use.

(You may have to scroll to display the desired tool.)

3 Right-click the tool, and click Apply Tool Properties to ➤ Linework
and Walls (or Linework, Walls and Roof, in the case of roof slab
tools).

4 Select a closed polyline, and press ENTER.

5 Enter y (Yes) to erase the polyline, or n (No) to keep the polyline
in the drawing.

6 Specify a mode:

If you enter d (Direct), the polyline vertices become the vertices
of the slab or roof slab perimeter. Any slope value specified in the
tool properties is ignored.
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Converting a polyline to a slab using the direct mode

Converting a polyline to a roof slab using direct mode

Converting a polyline to a roof slab using direct mode and adding a slope angle

If you enter p (Projected), you are prompted for the base height
of the slab or roof slab. The X,Y coordinates of the first polyline
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vertex are projected to a Z value of the base height. This establishes
the insertion point.

Converting a polyline to a slab using the projected mode

7 If you specified Projected mode, enter a value for Base Height.

8 Specify a slab justification method:

Then…If you want to align the slab or
roof slab…

enter t (Top).top with the polyline (or base
height, when using projected
mode)

enter c (Center).center with the polyline (or base
height, when using projected
mode)
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Then…If you want to align the slab or
roof slab…

enter b (Bottom).bottom with the polyline (or base
height, when using projected
mode)

enter s (Slopeline).slopeline with the polyline (or base
height, when using projected
mode)

NOTE This justification is used only for inserting a slab or roof slab
and is not retained as a parameter of the inserted object.

9 Edit the properties of the slab or roof slab in the Properties palette,
if needed. For example, you can add a slope angle.

Creating a Slab from a Space
Use this procedure to convert a space to a slab that has the properties of the
slab tool you select. You can edit these properties after creating the slab. If
there is an interference condition on any of the selected spaces, you can specify
whether you want these applied as holes in the new slab.

NOTE This procedure is currently available for slab tools only.

1 Open the tool palette that contains the slab tool you want to use.

(You may have to scroll to display the desired tool.)

2 Right-click the tool, and click Apply Tool Properties to ➤ Space.

3 Select one or more spaces, and press ENTER to open the Convert
Space to Slab worksheet.
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4 If you want to create a slab from the ceiling of the space, select
Convert Ceiling to Slab.

5 If you want to create a slab from the floor of the space, select
Convert Floor to Slab.

6 If you want interference conditions on any of the spaces you
selected to be ignored, clear Apply Interferences to Slab.

7 Select Erase Layout Geometry to erase the space.

8 Click OK.

9 Edit the properties of the new slab in the Properties palette, if
needed.

Creating a Slab or Roof Slab Tool
Use this procedure to create a slab tool or a roof slab tool and add it to a tool
palette. You may want to create your own tools if you are placing multiple
slabs or roof slabs of specific styles that have the same properties.

For example, you are creating an office building that has a complex roof
system. Although all sections of pitched roof use the same roof slab and edge
style, each roof slab has a different slope. To work efficiently, you can create
a roof slab tool for each slope, and select the appropriate tool to place the roof
slabs with the correct slope for each section of the roof.

You can use any of the following methods to create a slab or roof slab tool:

■ Drag a slab or roof slab that has the properties you want to a tool palette.

■ Drag a slab or roof slab style from the Style Manager to a tool palette, and
then customize the properties of the new tool.

■ Copy an existing slab or roof slab tool, and then customize the properties
of the new tool.

■ Drag a slab or roof slab tool from a tool catalog in the Content Browser,
and then customize the properties of the tool.

1 Open the tool palette on which you want to create a tool.
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2 Create the tool:

Then…If you want to…

select the slab or roof, and drag it
to the tool palette.

TIP Drag the slab or roof slab
by a point on its perimeter, not
by one of its grips.

create a tool from a slab or roof slab
in the drawing

Click Manage tab ➤ Style & Display

panel ➤ Style Manager , locate

create a tool from a slab or roof slab
style in the Style Manager

the style you want to copy, and
drag it to the tool palette. Click OK
to close the Style Manager.

right-click the tool, click Copy, and
click Paste.

copy a tool on the current palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another palette

open the palette where you want
to add the tool, right-click, and click
Paste.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

This description is used as the tool’s tooltip on the tool palette,
and to describe the tool if it is stored in a tool catalog.

6 Expand Basic, and expand General.

7 Click  next to Description to enter a description of the tool.

8 If you do not want to use the default layer key, click  next to
Layer key to select a layer key.

9 If you want to override the default layer names, click  next to
Layer overrides to select a layer override.

10 Select a slab or roof slab style.

2424 | Chapter 31   Slabs and Roof Slabs



11 For Style location, select the drawing file containing the style to
be used for this tool, or select Browse and use a standard file
selection dialog box to select the file.

12 Specify a value for Bound Spaces:

Then…If you want to…

select Yes.allow the slab or roof slab to be
used as a bounding object for asso-
ciative spaces

select No.prevent the slab or roof slab from
being used as a bounding object
for associative spaces

select By Style.use the bounding settings from the
slab or roof slab style

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

13 Select Projected or Direct for Mode.

14 Expand Dimensions.

15 Enter a value for Thickness.

16 Enter a value for the vertical offset distance from the insertion
point for Vertical Offset.

17 Enter a value for the horizontal offset distance from the insertion
point for Horizontal Offset.

18 Select the justification:

Then…If you want to align the …

select Top.top of the slab or roof slab with the
first specified point

select Center.center of the slab or roof slab with
the first specified point

select Bottom.bottom of the slab or roof slab with
the first specified point

select Slopeline.slopeline of the slab or roof slab
with the first specified point
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NOTE This justification is used only when inserting the slab and is
not retained as a parameter of the slab. Justification is intended
primarily for Direct mode.

The slopeline is the position of the slab or roof slab baseline
relative to its bottom face. The thickness offset in the style
determines the distance between the baseline and the bottom
face.

19 Select a direction, or define how the slab or roof slab is drawn
relative to the baseline.

20 Enter a value for the depth of the overhang for Overhang.

21 Select a style for Perimeter edge.

22 For Edge style location, select the drawing file containing the edge
style used for slabs created with this tool, or select Browse and
use a standard file selection dialog box to select the file.

23 Click OK.

Editing Slabs and Roof Slabs
After placing a slab or roof slab object, you can change its style, location, size,
shape, slope, edge styles, and other characteristics. You can miter its edges
and trim or extend it using another object as a reference. You can also modify
slabs and roof slabs using other objects as interference conditions or body
modifiers.

Depending on the type of editing you want to perform, various methods may
be available:

■ After selecting a slab or roof slab, you can click any non-grip point along
the perimeter and drag the entire object to a new location. You can also
move the object by clicking a grip, pressing the Space bar, and then moving
the object to the new location and clicking again.

■ You can drag the grips that are displayed on a selected slab or roof slab to
reorient it, resize it, or change other physical characteristics.

■ For grip edits where you are changing a dimension or an angle, the
Dynamic Input feature lets you enter a precise value instead of dragging
a grip. (This feature is activated by default; you can toggle it on and off by
clicking DYN on the application status bar. For more information, see
Dynamic Dimensions on page 120.)
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■ You can apply the properties of a slab tool to an existing slab or the
properties of a roof slab tool to an existing roof slab.

■ You can change settings on the object’s Properties palette. You can also
use the Display tab of the Properties palette to change the display property
settings for a selected object display component in the current display
representation. For more information, see Using the Properties Palette to
Change Display Properties on page 793.

■ You can use editing commands from the object’s contextual ribbon tab.

Using Grips to Edit Slabs/Roof Slabs
Various types of editing grips are displayed for a selected slab or roof slab
object. You can drag these grips as needed to reposition or resize the object,
or you can enter precise distance or angle values using the Dynamic Input
feature. When you select a grip that has multiple functions, you can cycle
among them by pressing Ctrl.

The types of editing grips available for a selected slab or roof slab depend on
the view direction. As shown in the following illustrations, Edge, Edge
Overhang, Vertex, and Pivot Point grips are displayed in both plan and
three-dimensional (3D) isometric views. Angle, Vertical Offset, Horizontal
Offset, and Thickness grips are available only in 3D isometric views.
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Slab Vertex and Edge grips

Slab Edge Overhang and Pivot Point grips
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Slab Angle, Thickness, Horizontal Offset, and Vertical Offset
grips

Roof Slab Vertex and Edge grips

Roof Slab Edge Overhang and Pivot Point grips
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Roof Slab Angle, Thickness, Horizontal Offset, and Vertical Offset grips

Using Slab/Roof Slab Edge Grips
Edge grips let you change the size, shape, or slope of a selected slab or roof
slab by moving one edge at a time. When you move the cursor over an Edge
grip, a tooltip lists the available edit modes (see mode descriptions following
the procedure below). After you click the Edge grip, you can cycle through
the modes by pressing Ctrl.

Use the following general procedure to select an Edge grip mode and edit an
edge of a slab or roof slab:

1 Select the slab or roof slab you want to edit.

Edge grips are displayed.

2 Move the cursor over the Edge grip on the edge you want to edit.

The list of available edit modes is displayed. (Modes differ for
straight and curved edges; see descriptions below.)

3 Click the Edge grip, and move the cursor slightly in the direction
that you want to move the edge. If you want to use the default
edit mode, proceed to the next step; otherwise, press Ctrl to cycle
through the edit modes to the one you want.

4 Either enter values as needed to specify a distance or position, or
move the cursor until the preview is in the desired position, and
then click to complete the edit and deselect the grip.

5 Press Esc, or right-click, and click Deselect All to deselect the slab
and turn off all grips.

Normal grip editing maintains the slope angle of the slab or roof
slab regardless of the Z value of the specified point.

NOTE The pivot point is unaffected by editing the slab or roof slab
edges with grips.
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Edit Modes for Straight Edges

Edge grips for straight slab or roof slab edges have the following
6 edit modes:

■ Move edge - maintain slope

■ Move edge - change slope

■ Add new edges - maintain slope

■ Add new edges - change slope

■ Convert to arc - maintain slope

■ Offset all edges - maintain slope

Move edge - maintain slope

As you move the edge, adjacent edges stretch or shorten
accordingly with no change to the slope. This is the default mode
for straight edges.
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Move edge - change slope

As you move the edge, adjacent edges stretch or shorten according
to the direction of the move, and the slope changes as necessary
to maintain the elevation of the edge being moved.

Side view
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Add new edges - maintain slope

As you move the edge outward, rather than adjacent edges being
stretched, new edges are added, each with its own Edge and Edge
Overhang grips. There is no change to the slope.

Add new edges - change slope

As you move the edge outward, rather than adjacent edges being
stretched, new edges are added, each with its own Edge and Edge
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Overhang grips. The slope changes as necessary to maintain the
elevation of the edge being moved.
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Convert to arc - maintain slope

Converts the edge to an arc, which you can move inward or
outward in the current plane to specify the arc direction and
degree. Adjacent edges are not affected.

Offset all edges - maintain slope

All outside perimeter edges move inward or outward in the current
plane the same distance as you move the selected Edge grip. The
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degree of arc is maintained. If holes have been added to the slab
or roof slab, their edges are unaffected.

Edge Grip Edit Modes for Curved Edges

For curved edges (whether originally created as such, or converted
from a straight edge using the Convert to arc mode listed above),
the Edge grip has 5 modes, none of which change the slope:

■ Stretch edge - maintain slope

■ Move edge - maintain slope

■ Add new edges - maintain slope

■ Convert to line - maintain slope

■ Offset all edges - maintain slope

Stretch edge - maintain slope

Move the Edge grip inward or outward in the current plane to
reposition the midpoint of the arc. Adjacent edges are not affected.
This is the default mode for curved edges.
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Move edge - maintain slope

As you move the Edge grip inward or outward in the current plane,
adjacent edges stretch or shorten according to the direction of
the move. The distance between the endpoints of the arc changes,
but the degree of arc is maintained.

Add new edges - maintain slope

As you move the Edge grip outward in its current plane, rather
than adjacent edges being stretched or reoriented, new edges are
added, each with its own Edge and Edge Overhang grips. The
degree of arc and the distance between the arc endpoints are both
maintained.

Covert to line - maintain slope

When you click, the curved edge is converted to a straight line
between the endpoints of the arc. Adjacent edges are not affected.

Offset all edges - maintain slope

All outside perimeter edges move inward or outward in the current
plane the same distance as you move the selected Edge grip. The
degree of arc is maintained. If holes have been added to the slab
or roof slab, their edges are unaffected.

Using Slab/Roof Slab Edge Overhang Grips
Use this procedure to change the overhang of a slab or roof slab edge. (You
can also change the overhang using the worksheet available from the object’s
Properties palette or its contextual ribbon tab. For more information, see
Changing the Edges of a Slab/Roof Slab on page 2452.)

1 Select the slab or roof slab.

2 Select an Edge Overhang grip.

3 Enter a value to specify the desired overhang distance, or move
the grip until the desired value is displayed.
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Changing the edge overhang of a slab using the Edge Overhang grip
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Using Slab/Roof Slab Vertex Grips
Use this procedure to change the size or shape of a slab or roof slab by moving
one or more of its vertices.

1 Select the slab or roof slab.

2 Select the Vertex grip for the vertex you want to move (or press
Shift while selecting multiple Vertex grips).

3 Move the vertex to the desired location, and click. Adjacent edges
stretch or shorten accordingly. If you have Shift-selected multiple
Vertex grips, drag one of them to the desired location, and click;
any other selected Vertex grip also moves, maintaining its position
relative to the grip you drag.

Changing the perimeter of a slab by moving a Vertex grip
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Using Slab/Roof Slab Thickness Grips
Use this procedure to change the thickness of a slab or roof slab in a 3D
isometric view. (To change the thickness of multiple objects at once, regardless
of the type of view, see Changing the Thickness of a Slab or Roof Slab on page
2447.)

1 Select the slab or roof slab.

2 Select the Thickness grip.

3 Enter a value to specify the desired thickness, or move the cursor
until the desired value is displayed, and then click.

Changing the thickness of a slab using the Thickness grip

Using Slab/Roof Slab Offset Grips
Use this procedure to change the vertical and horizontal offsets of a slab or
roof slab object in a 3D isometric view. (To change the horizontal or vertical
offsets of multiple objects at once, regardless of the type of view, see Changing
the Offsets of a Slab or Roof Slab on page 2447.)
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The offsets are the vertical and horizontal distances from the insertion point
of the slab.

1 Select the slab.

2 Select the Vertical Offset or Horizontal Offset grip.

3 Enter a value to specify the desired offset distance, or move the
cursor until the desired value is displayed, and then click.

Changing the horizontal offset of a slab using the Horizontal Offset grip
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Changing the vertical offset of a slab using the Vertical Offset grip

Using Slab/Roof Slab Angle Grips
Use this procedure to change the slope of a slab or roof slab in a 3D isometric
view. (You can also use the Properties palette to adjust the slope and control
the automatic alignment of the fascia. For more information, see Changing
Slab/Roof Slab Slope Settings on page 2448).

1 Select the slab.
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2 Select the Angle grip. If Dynamic Input is turned on, the associated
Slope, Rise, and Run values are displayed in the drawing area.

IMPORTANT The Angle grip is available only when you select a slab
or roof slab in a 3D isometric view.
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Using the Angle grip to edit slab slope
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Using the Angle grip to edit roof slab slope

3 Adjust the slope:

Then…If you want to…

either enter a value, or move the
grip until the desired angle is dis-
played, and then click.

adjust the slope manually

press TAB until the rise value is
highlighted, and then either enter

adjust the slope by changing the
rise of the slab

a value, or move the grip until the
desired rise is displayed, and then
click.

4 Click once.
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Using Slab/Roof Slab Pivot Point Grips
Use this procedure to change the pivot point of a slab or roof slab. (You can
also use the Properties palette to change the X, Y, and Z values of the pivot
point.)

By default, the pivot point is the first vertex of the baseline. However, you
can move the pivot point to any other point, either on or off the slab or roof
slab.

NOTE If a Hold fascia elevation constraint was set for the object, the pivot point
is ignored. For information about setting this option, see Changing Slab/Roof Slab
Slope Settings on page 2448.

1 Select the slab or roof slab.

2 Select the Pivot Point grip.

3 Move the cursor until the pivot point is in the desired location,
and then click.

Applying Tool Properties to an Existing Slab/Roof Slab
Use this procedure to modify one or more slabs or roof slabs by applying the
properties of a slab or roof slab tool. The properties include the style and any
other settings specified in the tool you select.

1 Open the tool palette that contains the slab or roof slab tool you
want to use.

(You may have to scroll to display the desired tool.)

2 Right-click the tool, and click Apply Tool Properties to ➤ Slab or
Apply Tool Properties to ➤ Roof Slab.

3 Select the slabs or roof slabs to be modified, and press ENTER.

4 Edit the properties of the modified slabs or roof slabs in the
Properties palette, if necessary.

Changing the Properties of Slabs or Roof Slabs
Many of the slab or roof slab properties that you can edit using grips can also
be edited on the Properties palette. In cases where multiple selected objects
have the same value for a property, you can change the value for all the objects
with a single entry on the Properties palette. The Properties palette also
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provides access to the Slab Edges and Roof Slab Edges worksheets, and enables
you to attach hyperlinks, notes, or files to slabs or roof slabs.

Changing the Style of Slabs or Roof Slabs
Use this procedure to change the style for one or more slabs or for one or more
roof slabs in a drawing. Note that the procedure cannot be applied to slabs
and roof slabs simultaneously.

1 Select one or more slabs or roof slabs, and double-click one of
them.

2 On the Properties palette, click the Design tab, expand Basic, and
expand General.

If the selected objects are of different styles, the value of the Style
property is *VARIES*.

3 For Style, select a new style from the drop-down list.

The selected style is assigned to all selected objects.

Changing the Thickness of a Slab or Roof Slab
Use this procedure to change the thickness of a slab or roof slab for which the
Base Thickness (BT) variable is used to define the Thickness value in the object
style. If the style specifies a fixed thickness for the slab or roof slab (or for any
component of a multi-component slab or roof slab), then the Thickness value
on the Properties palette is read-only and can only be changed by editing the
style or applying a different style. For more information on using the BT
variable, see Specifying the Thickness and Offset of a Slab/Roof Slab
Component on page 2493.

1 Select the slab or roof slab you want to change.

2 On the Properties palette, expand Basic, and expand Dimensions.

3 Click the Thickness value, and enter a new value.

Changing the Offsets of a Slab or Roof Slab
Use this procedure to change the vertical or horizontal offset of a slab or roof
slab. The offsets are the vertical and horizontal distances from the insertion
point of the slab or roof slab.

1 Double-click the slab or roof slab you want to change.
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2 On the Properties palette, click the Design tab, expand Basic, and
expand Dimensions.

3 Click the Vertical offset or Horizontal offset value, and enter a
new value.

Changing Slab or Roof Slab Edges
Use this procedure to access the Slab Edges or Roof Slab Edges worksheet from
the Properties palette.

1 Double-click the slab or roof slab whose edge(s) you want to
change.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Dimensions.

3 Click  next to Edges.

The Slab Edges and Roof Slab Edges worksheets are identical in
function to the Edit Slab Edges and Edit Roof Slab Edges
worksheets accessed from the slab or roof slab contextual tab. For
more information on using these worksheets, see Changing the
Edges of a Slab/Roof Slab on page 2452

4 Click OK.

Changing Slab/Roof Slab Slope Settings
Use this procedure to change the slope settings of a slab or roof slab, and to
specify whether the fascia is to be aligned when the slope is changed.

You can also control the adjustment of the overhang or baseline height of the
slab. This constraint applies only to the baseline edge, and it works only when
the baseline is horizontal.

1 Double-click the slab you want to change.

2 On the Properties palette, click the Design tab, expand
Dimensions, and expand Slope.

3 Enter a value for Rise, Run, or Angle to define the slope.
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4 Select a setting for Hold fascia elevation:

Then…If you want to…

select By adjusting overhang.force the fascia to align with other
slab or roof slab fascias, regardless
of style, by adjusting the overhang

select By adjusting baseline height.force the fascia to align with other
slab or roof slab fascias, regardless
of style, by adjusting the baseline
height

select No.ignore fascia alignment

Changing the Location of a Slab or Roof Slab
Use this procedure to relocate a slab or roof slab by changing the coordinate
values of its insertion point. The slab or roof slab object also has an orientation
with respect to the WCS or the current UCS. For example, if the top and
bottom of the object are parallel to the XY plane, the object’s normal is parallel
to the Z axis. You can change the orientation of the object by aligning its
normal with another axis. You can also rotate the object on its plane by
changing the rotation angle.

For information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use Coordinates and Coordinate Systems” in
AutoCAD Help.

TIP The quickest way to locate and view an AutoCAD topic referenced in AutoCAD
Architecture Help is to click the Search tab in the Help window, select the Search
titles only option, and then copy and paste or type in the AutoCAD topic name,
and click List Topics.

1 Double-click the slab or roof slab you want to move.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Location.

3 Click  next to Additional Information.

Changing the Properties of Slabs or Roof Slabs | 2449



4 Specify the location of the slab or roof slab:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the slab or roof slab

make the normal of the slab or roof
slab parallel to the Z axis: under

locate the slab or roof slab on the
XY plane

Normal, enter 1 for Z, and enter 0
for X and Y.

make the normal of the slab or roof
slab parallel to the X axis: under

locate the slab or roof slab on the
YZ plane

Normal, enter 1 for X and enter 0
for Y and Z.

make the normal of the slab or roof
slab parallel to the Y axis: under

locate the slab or roof slab on the
XZ plane

Normal, enter 1 for Y, and enter 0
for X and Z.

enter a new value for Rotation
Angle.

change the rotation of the slab or
roof slab

5 Click OK.

Specifying the Cut Plane Display of a Slab or Roof Slab
Use this procedure to specify the properties of one or more cut planes for an
individual slab or roof slab. Cut plane display properties apply only to display
representations, such as Plan, that are used in the Top view (plan view) of a
drawing.

1 Double-click the slab or roof slab you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.
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NOTE To apply your changes to all slabs or roof slabs in the drawing,
select Drawing default setting. To apply changes to all slabs or roof
slabs of this style, select Slab or Roof Slab Style:<style name>. For
more information on styles, see Slab and Roof Slab Styles on page
2486.

5 If necessary, expand Object Display Properties ➤ Cut Plane.

6 For Override cut plane, specify whether you want to override the
global cut plane defined for the current display configuration.

7 If you selected Yes for Override cut plane, enter a value for Height
to define the cut plane for this object. Alternatively, you can click

 , and specify 2 points in the drawing area to define the new
height.

You can also access and modify these same cut plane settings through the
slab’s or roof slab’s context menu, as follows:

1 Select the slab or roof slab you want to change, right-click, and
click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 In the Display Properties dialog, click the Cut Plane tab, and then
change the settings as needed.

5 Click OK twice.

Attaching Hyperlinks, Notes, or Files to a Slab/Roof Slab
Use this procedure to attach hyperlinks, enter notes, or attach reference files
to a slab or roof slab. You can also edit existing notes and edit or detach
currently attached reference files.

1 Double-click the slab or roof slab to which to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click  next to Hyperlink, and specify the
link.
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4 To add or edit a note, click  next to Notes, enter text, and click
OK.

5 To attach, detach, or edit a reference, click  next to Reference
documents, and then do any of the following:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

6 Click OK.

Using Slab and Roof Slab Contextual Tools
In addition to grip-editing slabs and roof slabs, or changing values on their
Properties palettes, you can edit these objects using the tools available on their
contextual ribbon tabs and context menus. These tools let you trim, extend,
and cut an object, edit its edges, add and edit interference conditions and
body modifiers, and edit the object display properties.

Changing the Edges of a Slab/Roof Slab
Use this procedure to edit one or more edges of a slab or roof slab. For each
selected edge, you can change the overhang, style, cut (square or plumb), and
angle. A viewer box shows you which edge(s) of the slab you are editing.
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1 Select the slab or roof slab to be modified, and,

then…if the object selected is…

click Slab tab ➤ Edge panel ➤ Edit

 .

a slab

click Roof Slab tab ➤ Edge pan-

el ➤ Edit  .

a roof slab

2 Select the edges to be modified, and press ENTER.

3 In the Edit Slab Edges or Edit Roof Slab Edges worksheet, in the
list of edges, select the edge to edit. To modify multiple edges
using the same values, press and hold CTRL while selecting each
edge.

NOTE Beginning with Autodesk Architectural Desktop 2007, the
individual segments or facets making up a curved edge are no longer
listed as separate edges on this worksheet. Each arc on the perimeter
of a slab or roof slab is treated as a single edge.

The selected edges are highlighted in the viewer in the right pane
of the worksheet.

4 Enter a value for Overhang.

5 Select a slab edge style.

6 Select Square or Plumb for Edge Cut.

7 Enter a value for Angle.

To reset the angle to the slab or roof slab style defaults, right-click
the edge number, and click Reset to Style Defaults. This option is
available only if an edge style has been assigned, and the value
for Angle is different than the default.

8 If desired, select additional edges from the list and edit them as
described above.

9 When edits are completed for all edges, click OK.

Trimming a Slab/Roof Slab
Use this procedure to trim a slab or roof slab using a polyline, wall, roof slab,
or slab to define the trim plane. The trimming object itself does not need to
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intersect the slab or roof slab, as long as it projects an intersection in the
current user coordinate system (UCS). However, the trim plane must intersect
the slab or roof slab perimeter line; you cannot trim only the overhang.

Any fascia or soffit profile that intersects the trim plane is trimmed at the
same angle as the slab or roof slab.

If the trimming object is a wall or a slab, the trim plane is at the closest surface.
The new edge at the trim plane has its edge angle defined by the trim plane.

Trimming a slab to a wall
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Trimming a roof slab to a wall

1 Select the slab or roof slab to be trimmed, and

then…if the object selected is…

click Slab tab ➤ Modify pan-

el ➤ Trim  .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Trim  .

a roof slab

2 Select a wall, a polyline, or another slab or roof slab for the
trimming object.

3 Select the side of the slab or roof slab to be trimmed.
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Extending a Slab/Roof Slab
Use this procedure to extend a slab or roof slab to a plane defined by another
slab, roof slab, or wall. This target object itself does not have to intersect with
the extended slab or roof slab, as long as it projects an intersection in the
current user coordinate system (UCS).

Because multiple edges may need to move in an extend operation, you are
prompted to select the adjacent edges to lengthen, rather than the specific
edges to move. These selected edges retain their current vector (angle) and are
stretched until they intersect the plane of the target object.

If multiple edges exist between the selected edges, they are joined to form a
single edge. The new edge is set to the angle of the target surface.

Any fascia or soffit profile on the adjacent edges is extended to the target
surface and trimmed to its angle.

Extending a slab to a wall
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Extending a roof slab to a wall

1 Select the slab or roof slab to be extended, and

then…if the object selected is…

click Slab tab ➤ Modify panel ➤ Ex-

tend  .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Extend  .

a roof slab
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2 Select the target wall, slab, or roof slab to which the slab or roof
slab is to be extended.

3 Select the slab or roof slab to be extended.

4 Select the first edge to lengthen.

5 Select the second edge to lengthen.

NOTE You cannot use curved walls as objects to lengthen a slab or
roof slab to.

Mitering Slabs/Roof Slabs by Intersection
Use this procedure to miter 2 intersecting slabs or roof slabs. Both slabs or
roof slabs are trimmed along the intersection of their perimeter lines. Vertices
are added or removed as required. The new edges of the slabs or roof slabs are
set to angles required for a true miter cut. If the slab thicknesses of the two
edges are different, the angles are different.

If you want to miter slabs or roof slabs that do not intersect, you can miter
them by edges. For more information, see Mitering Roof Slabs Using Edges on
page 2460
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Mitering roof slabs by intersection

1 Select one of the two slabs or roof slabs you want to miter, and

then…if the object selected is…

click Slab tab ➤ Modify pan-

el ➤ Miter  .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Miter  .

a roof slab

2 Enter i (Intersection) to miter at the intersection of the two slabs
or roof slabs.

3 Select the first roof slab at the side of that slab to keep.
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The opposite side is trimmed.

4 Select the second roof slab at the side of that slab to keep.

The opposite side is trimmed.

Mitering Roof Slabs Using Edges
Use this procedure to miter two roof slabs that do not intersect. You can select
particular edges to miter. You can miter edges of overlapping roof slabs without
trimming the entire slab. To accomplish this, however, you may need to insert
additional vertices. Only one edge of each roof slab is mitered.

If you need to miter multiple edges of a roof slab, stretch them to overlap the
other roof slab and then miter them at their intersection. For more
information, see Mitering Slabs/Roof Slabs by Intersection on page 2458.

Mitering roof slabs by edge
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1 Select one of the two roof slabs you want to miter, and

then…if the object selected is…

click Slab tab ➤ Modify pan-

el ➤ Miter  .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Miter .

a roof slab

2 Enter e (Edges) to miter selected edges of the roof slabs.

3 Select one edge on the first roof slab.

4 Select one edge on the second roof slab.

Cutting a Slab/Roof Slab
Use this procedure to cut a slab or roof slab into two or more slabs or roof
slabs. You can use any 3D object or polyline to define the cutting geometry.
If you use a 3D body, such as a wall, slab, mass element, or closed polyline,
the slab or roof slab is cut along the intersection lines of the surfaces.

The slab or roof slab is cut only when the 3D body or closed polyline intersects
its perimeter line. If you use an open polyline, the slab or roof slab is cut along
the projection to its surface.

In either case, when the intersection line crosses the slab or roof slab multiple
times, multiple slabs or roof slabs are created. If the intersection line has
multiple edges, multiple edges are added to the new objects.

The smoothness (tessellation) of curved edges is controlled by 2 AEC display
resolution settings called Facet Deviation and Facet Maximum. Beginning
with Autodesk Architectural Desktop 2007, you can adjust these settings after
the slab or roof slab is created. Also, the individual segments or facets making
up a curved edge are no longer treated as separate edges; each arc on the
perimeter of a slab or roof slab is treated as a single edge. For more information,
see Specifying the Display Resolution of Objects with Facets on page 202.

1 Draw an object or polyline for defining the cutting geometry.
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2 Select the slab or roof slab to be cut, and

then…if the object selected is…

click Slab tab ➤ Modify pan-

el ➤ Cut  .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Cut  .

a roof slab

3 Select the objects or polylines that represent the cutting geometry,
and press ENTER.

4 Enter n (No) to keep the geometry, or enter y (Yes) to erase the
geometry.

Adding a Vertex to a Slab/Roof Slab
Use this procedure to add a vertex to a slab or roof slab edge. Adding a vertex
creates two edges from one edge.

1 Select a slab or roof slab, and

then…if the object selected is…

click Slab tab ➤ Modify panel ➤ Ver-

tex drop-down ➤ Add  .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Vertex drop-down ➤ Add
.

a roof slab

2 Specify a point for the new vertex.

To place a new vertex at a precise intersection point, use
Intersection or Apparent Intersection object snaps.

The new vertex is added to the nearest edge, perpendicular to the
specified point. If there is no point perpendicular to the slab or
roof slab, no vertex is added.
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Adding a vertex to a roof slab

3 To see the new vertex, select the slab or roof slab.

A new Vertex grip is displayed at the point you specified, and new
grips are displayed for the edge that has been added.

Deleting a Vertex from a Slab/Roof Slab
Use this procedure to delete a vertex from a slab or roof slab. After the vertex
is deleted, the 2 adjacent vertices connect in a straight line.

1 Select the slab or roof slab, and

then…if the object selected is…

click Slab tab ➤ Modify panel ➤ Ver-

tex drop-down ➤ Remove  .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Vertex drop-down ➤ Remove

 .

a roof slab

2 Select the vertex to remove.
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Adding a Hole to a Slab/Roof Slab
Use this procedure to add a hole to a slab or roof slab. The hole adds new
vertices and edges, which you can edit as you do other slab or roof slab vertices
and edges.

You can use polylines or three-dimensional (3D) objects, such as walls and
mass elements, to create the hole.

■ Holes generated by a closed polyline are projected from the polyline to
the slab or roof slab, using the current user coordinate system (UCS).

■ 3D objects must intersect the slab or roof slab without any projection.

If the objects contain an interior void, you are prompted to use the inside or
outside surface to create the hole. For example, if you create a chimney using
four wall objects, you can cut the hole at the inside or outside of the chimney.
The new hole faces are aligned with the surfaces of the cutting bodies, and
are not necessarily parallel to each other.

The smoothness (tessellation) of curved edges is controlled by 2 AEC display
resolution settings called Facet Deviation and Facet Maximum. Beginning
with Autodesk Architectural Desktop 2007, you can adjust these settings after
the slab or roof slab is created. Also, the individual segments or facets making
up a curved edge are no longer treated as separate edges; each arc on the
perimeter of a slab or roof slab is treated as a single edge. For more information,
see Specifying the Display Resolution of Objects with Facets on page 202.
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Adding a hole to a slab

Adding a hole to a roof slab

1 Draw a closed polyline in the shape and location for the hole, or
add an object in the location for the hole.

2 Select the slab or roof slab, and

then…if the object selected is…

click Slab tab ➤ Modify pan-

el ➤ Hole drop-down ➤ Add  .

a slab
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then…if the object selected is…

click Roof Slab tab ➤ Modify pan-

el ➤ Hole drop-down ➤ Add  .

a roof slab

3 Select the closed polyline or the connected objects that define
the hole, and press ENTER.

4 Enter n (No) to keep the geometry, or enter y (Yes) to erase the
geometry.

5 If you select 3D objects, you are prompted to create the hole at
the inside or outside surface of the cutting objects. Press ENTER to
use the outside of the object to define the hole, or enter i (Inside)
to use the inside or void of the object to define the hole. This
prompt is displayed even if the bodies do not contain an inner
void, in which case the Inside option does not create a hole.

NOTE If you create a hole that is outside or which overlaps the slab or roof slab
baseline or perimeter line at an overhang, the body of the slab or roof slab is cut,
but the fascia and soffit remain. In this case, it is better to create a hole by cutting
the slab or roof slab. For more information, see Cutting a Slab/Roof Slab on page
2461.

Removing a Hole from a Slab/Roof Slab
Use this procedure to remove a hole from a slab or roof slab.

Removing a hole from a slab
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1 Select the slab or roof slab, and

then…if the object selected is…

click Slab tab ➤ Modify pan-

el ➤ Hole drop-down ➤ Remove

 .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Hole drop-down ➤ Remove

 .

a roof slab

2 Select any edge of the hole to remove.

Creating Slab/Roof Slab Interference Conditions
Just as you can use another object to define the perimeter of a hole you want
to add to a slab or a roof slab, you can also modify the geometry of a slab or
roof slab by using another object to create an interference condition within
the slab or roof slab. Unlike the object used to add a hole, which has no
connection to the slab or roof slab and can be erased after the hole is added,
the object used to create an interference condition remains partially or wholly
embedded in the slab or roof slab, cutting out and replacing a part of its
geometry. All interference conditions are subtractive in this sense, but the
shrinkwrap effect option you use to create the interference condition (Additive
or Subtractive) determines whether the outline of the interference condition
is included in or excluded from the shrink wrap outline of the slab or roof
slab in plan view.

Typically, after creating interference conditions for a slab or roof slab, you
freeze the layer where the interfering objects are placed. If you move or edit
the objects, the slab or roof slab updates accordingly.

NOTE Objects used as interference conditions are not included for the Area in the
LIST command or in a Schedule Query result.

Use the following procedure to create either additive or subtractive interference
conditions for a slab or roof slab. If you want to create both additive and
subtractive interference conditions, you need to perform the procedure
separately for each type.
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1 Create one or more objects in the actual location where you want
the interference condition positioned in relation to the slab or
roof slab.

2 Select the slab or roof slab, and

then…if the object selected is…

click Slab tab ➤ Modify panel ➤ In-
terference Condition drop-

down ➤ Add  .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Interference Condition drop-

down ➤ Add  .

a roof slab

3 Select the objects to use as interference conditions, and press
ENTER.

NOTE AEC objects from externally referenced (xref) files can be added
to a slab or roof slab as interference conditions so long as the
following conditions are met:

■ The object is a three-dimensional (3D) body

■ The xref is found

■ The xref is read/write

■ The xref is not locked or opened by another user

■ The xref is loaded

4 Specify the desired shrinkwrap effect:

Then…If you want to…

enter a (Additive).include the interference condition(s)
within the shrink wrap outline in
plan view

enter s (Subtractive).exclude the interference condi-
tion(s) from the shrink wrap outline
in plan view
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The selected objects are added to the slab or roof slab as either
additive or subtractive interference conditions. You can delete an
interference condition or change its shrinkwrap effect using the
Interference Conditions worksheet. For more information, see
Editing Slab/Roof Slab Interference Conditions on page 2469

Removing Slab/Roof Slab Interference Conditions
Use this procedure to remove an interference condition from a slab or roof
slab. Note that only the interference condition is removed; the object from
which the interference condition was created remains in the drawing.

1 Select the slab or roof slab, and

then…if the object selected is…

click Slab tab ➤ Modify panel ➤ In-
terference Condition drop-

down ➤ Remove  .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Interference Condition drop-

down ➤ Remove  .

a roof slab

2 Select the objects to remove as interference conditions, and press
ENTER.

NOTE You can also remove interference conditions through the
Interference Conditions worksheet. For more information, see Editing
Slab/Roof Slab Interference Conditions on page 2469.

Editing Slab/Roof Slab Interference Conditions
Objects applied as interference conditions in slabs and roof slabs can be edited
like any other objects, using grips, contextual tab options, or the Properties
palette. If you move or edit the objects, the slab or roof slab updates
accordingly. You can also change the setting that determines whether an
interference condition is added to or subtracted from the shrink wrap outline
of the slab or roof slab in plan view by using the following procedure.
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1 Select the slab or roof slab, and,

then…if the object selected is…

click Slab tab ➤ Modify panel ➤ In-
terference Condition drop-

a slab

down ➤ Interference Conditions

 .

click Roof Slab tab ➤ Modify pan-

el ➤ Interference Condition drop-

a roof slab

down ➤ Interference Conditions

 .

NOTE You can also access this worksheet on the Design tab of the
Properties palette, under Advanced.

2 On the Interference Conditions worksheet, click the Shrinkwrap
Effect value you want to change, and select a different value from
the drop-down menu.

3 Click OK.

NOTE You can also use this worksheet to remove an interference
condition by right-clicking its Object or Type value and then clicking
Remove. The alternate method is to use the contextual tab of the
slab or roof slab, as explained under Removing Slab/Roof Slab
Interference Conditions on page 2469. When you remove an interference
condition, you remove the association between the slab or roof slab
and the object that was used to create the interference condition.
The object itself is not removed from the drawing.

2470 | Chapter 31   Slabs and Roof Slabs



Creating Slab/Roof Slab Body Modifiers
Like interference conditions, body modifiers let you modify the geometry of
a slab or roof slab by incorporating another three-dimensional (3D) object.
However, where interference conditions always subtract from the mass of a
slab or roof slab and affect only components that they touch, body modifiers
can be used to add to, subtract from, or completely replace a specific
component. If a slab or roof slab has only one component, then the body
modifier applies to the entire slab or roof slab.

You can create a body modifier from a mass element, a mass group, or any
other AEC object with mass. You can also create body modifiers from ACIS
solids or blocks that form 3D bodies. You must place the object in the location
you want in the drawing before defining the object as a body modifier.

After you create a body modifier from an object, you can delete the original
object. However, if you have created a complex object, such as a mass group
comprising many mass elements, you may want to retain the object in the
drawing until you are sure you have the results you want for the slab or roof
slab.

NOTE Objects used as interference conditions are not included for the Area in the
LIST command or in a Schedule Query result.

To create a body modifier for a slab or roof slab:

1 Create one or more objects in the location where you want the
body modifier positioned in relation to the slab or roof slab.

2 Select the slab or roof slab you want to modify, and

then…if the object selected is…

click Slab tab ➤ Modify pan-

el ➤ Body Modifier drop-

down ➤ Add .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Body Modifier drop-

down ➤ Add  .

a roof slab
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3 Select the objects to be applied as body modifiers, and press ENTER.

4 On the Add Body Modifier worksheet, specify the following:

■ For Slab Component (or Roof Slab Component), select the
component to which you want the body modifier applied.

■ For Operation, select Additive, Subtractive, or Replace,
depending on whether you want the body modifier added to
the selected component, subtracted from it, or used to replace
the entire component.

■ For Description, enter a text description of the body modifier(s)
you are applying.

5 If you do not want the outline of the object(s) to be visible in the
drawing, select Erase Selected Object(s).

6 Click OK.

Editing a Slab/Roof Slab Body Modifier in Place
Use this procedure to edit the shape of a body modifier that is attached to a
slab or a roof slab. You can edit the body using grips to edit faces, using
Boolean commands to add or remove other objects from the body modifier,
and other editing commands to change its shape.
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1 Select the slab or roof slab that has the body modifier you want
to change, and

then…if the object selected is…

click Slab tab ➤ Modify pan-

el ➤ Body Modifier drop-

down ➤ Edit In Place  .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Body Modifier drop-

down ➤ Edit In Place  .

a roof slab

A temporary mass element is created for you to edit the geometry
of the body modifier. If the slab or roof slab contains multiple
body modifiers, a mass element is created for each body modifier.
If an object was not originally a mass element (for example, if
you used a structural member as a body modifier), the object
becomes a temporary Free Form mass element with faces that you
can edit.

2 NOTE After you perform an editing task from the Edit in Place
contextual tab, you may need to select a profile again to perform
another editing task. If you do not see the editing commands that
you expect on the contextual tab, re-select a profile to redisplay the
Edit in Place contextual tab.

Edit the body modifier:

Then …If you want to …

select the body modifier. Select a
Face grip to activate edge grips for

change the shape of a body modifi-
er that is a Free Form mass element

the face. Move the grips to the de-
sired locations. Continue editing
other faces in the same manner.

select the body modifier. Select
grips and move them to change the

change the shape of a body modifi-
er that is a conventional mass ele-
ment shape of the body modifier. The

grips that are available depend on
the type of mass element used as a
body modifier and the current view
direction.
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Then …If you want to …

place the object in the location
where it is needed.

add an object to a body modifier

■ For a slab object, click Edit In
Place: Slab Body Modifi-

er ➤ Modify panel ➤ Boolean

drop-down ➤ Union.

■ For a roof slab object, click Edit
In Place: Roof Slab Body Modifi-

er ➤ Modify panel ➤ Boolean

drop-down ➤ Union.

Select the object, and press ENTER.
Enter y (Yes) to keep the object in
the drawing, or press ENTER to
erase it.

place the object in the location
where it is needed.

subtract an object from a body
modifier

■ For a slab object, click Edit In
Place: Slab Body Modifi-

er ➤ Modify panel ➤ Boolean

drop-down ➤ Subtract.

■ For a roof slab object, click Edit
In Place: Roof Slab Body Modifi-

er ➤ Modify panel ➤ Boolean

drop-down ➤ Subtract.

Select the object, and press ENTER.
Enter y (Yes) to keep the object in
the drawing, or press ENTER to
erase it.

place the object in the location
where it is needed.

create a body modifier that is the
intersection of the original body
modifier with another object ■ For a slab object, click Edit In

Place: Slab Body Modifi-

er ➤ Modify panel ➤ Boolean

drop-down ➤ Intersect.

■ For a roof slab object, click Edit
In Place: Roof Slab Body Modifi-
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Then …If you want to …

er ➤ Modify panel ➤ Boolean

drop-down ➤ Intersect.

Select the object, and press ENTER.
Enter y (Yes) to keep the object in
the drawing, or press ENTER to
erase it.

trim a body modifier ■ if the object is a slab, click Edit
In Place: Slab Body Modifi-

er ➤ Modify panel ➤ Trim by

Plane  .

■ if the object is a roof slab, click
Edit In Place: Roof Slab Body

Modifier ➤ Modify pan-

el ➤ Trim by Plane  .

Specify the points that define the
trim plane, and select the side of
the body modifier to be trimmed.
The trimmed body modifier is con-
verted to a Free Form mass ele-
ment.

divide the face of a body modifier
into two faces

■ if the object is a slab, click Edit
In Place: Slab Body Modifi-

er ➤ Modify panel ➤ Split Face

 .

■ if the object is a roof slab, click
Edit In Place: Roof Slab Body

Modifier ➤ Modify pan-

el ➤ Split Face  .

Specify the points that define the
edge created by splitting the faces.

join two faces that are on the same
plane into a single face

■ if the object is a slab, click Edit
In Place: Slab Body Modifi-

er ➤ Modify panel ➤ Join Faces

 .
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Then …If you want to …

■ if the object is a roof slab, click
Edit In Place: Roof Slab Body

Modifier ➤ Modify panel ➤ Join

Faces  .

Select the edge that separates the
coplanar faces.

select the object that forms the
body modifier, and press DELETE.

remove a body modifier

3 Save or discard the changes:

Then …If you want to …

select the body modifier, andrestore the body modifier to its ori-
ginal shape ■ if the object is a slab, click Edit

In Place: Slab Body Modifi-

er ➤ Edits panel ➤ Cancel.

■ if the object is a roof slab, click
Edit In Place: Roof Slab Body

Modifier ➤ Edits panel ➤ Can-
cel.

select the body modifier, andsave the changes to the body
modifier ■ if the object is a slab, click Edit

In Place: Slab Body Modifi-

er ➤ Edits panel ➤ Finish.

■ if the object is a roof slab, click
Edit In Place: Roof Slab Body

Modifier ➤ Edits panel ➤ Fin-
ish.

Managing Slab/Roof Slab Body Modifiers
Use this procedure to edit or remove three-dimensional (3D) body modifiers
from a slab or a roof slab. You can change the component to which the body
modifier is applied or the way it is applied (whether it adds to, subtracts from,
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or replaces the selected component). You can also enter or edit the descriptions
of body modifiers.

NOTE To remove a body modifier from a slab or roof slab component and restore
the modifier as a mass element that you can edit or apply to other slabs or roof
slabs, see Restoring a Slab/Roof Slab Body Modifier to a Mass Element on page
2478.

1 Select the slab or roof slab you want to change, and

then…if the object selected is…

click Slab tab ➤ Modify pan-

el ➤ Body Modifier drop-

down ➤ Body Modifiers  .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Body Modifier drop-

down ➤ Body Modifiers  .

a roof slab

NOTE You can also access this worksheet on the Design tab of the
Properties palette, under Advanced.

2 Select a body modifier, and change its settings:

Then …If you want to …

select a different component for
Component.

apply the body modifier to a differ-
ent slab or roof slab component
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Then …If you want to …

select a different operation for Op-
eration:

change the operation used to apply
the body modifier to the slab or
roof slab component ■ Select Additive to add the body

modifier to the component.

■ Select Subtract to subtract the
shape of the body modifier
from the component.

■ Select Replace to replace the
component with the body
modifier.

select the body modifier, and click

 , or right-click, and click Re-
move.

delete the body modifier from the
slab or roof slab component

click Description, enter text, and
press ENTER.

enter a description of the body
modifier

3 Click OK.

Restoring a Slab/Roof Slab Body Modifier to a Mass Element
Use this procedure to remove a body modifier from a slab or a roof slab and
add it to the drawing as a mass element. Restoring a body modifier to a mass
element enables you to modify the shape as a mass element and then add it
to the slab or roof slab again as a body modifier. You can also restore the body
modifier to a mass element while leaving the body modifier still applied to
the slab or roof slab. This is useful if you want to create other slabs or roof
slabs with the same shape.

If the object used to create the body modifier was a conventional mass element,
it is restored to that mass element. For example, a Gable mass element is
restored as a Gable mass element. However, if the body modifier was created
from another object, such as a structural member, or was edited using Boolean
operations or face editing commands, the body modifier is restored as a Free
Form mass element.
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1 Select the slab or roof slab you want to change, and

then…if the object selected is…

click Slab tab ➤ Modify pan-

el ➤ Body Modifier drop-

down ➤ Restore  .

a slab

click Roof Slab tab ➤ Modify pan-

el ➤ Body Modifier drop-

down ➤ Restore  .

a roof slab

2 NOTE This procedure restores all body modifiers attached to a slab
or roof slab.

Create mass elements from the body modifiers:

Then …If you want to …

press ENTER.create mass elements from the body
modifiers while keeping the body
modifiers attached to the slab or
roof slab

enter y (Yes), and press ENTER.remove all body modifiers from the
slab or roof slab, and create mass
elements from their shapes

Specifying the Material of a Slab/Roof Slab
Use this procedure to select a different material for components of an
individual slab or roof slab.

To change the materials assigned to all slabs or roof slabs of the same style,
see Specifying the Materials of a Slab or Roof Slab Style on page 2496.

NOTE If a material assignment does not determine the display properties of the
component, you can change the properties of the display component as described
in Specifying the Display Properties of a Slab/Roof Slab on page 2480.

1 Select the slab or roof slab you want to change, right-click, and
click Edit Object Display.
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2 To verify that the material assignment determines the display
properties of the component, click the Display Properties tab,
select the display representation on which to display the changes,

and click  .

3 Click the Layer/Color/Linetype tab, verify that By Material is
selected for the component, and click OK.

4 Click the Materials tab.

5 Select the component you want to change, and select a different
material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING When you edit a material definition from this dialog box,
any changes you make will apply to all objects that are assigned the
material.

6 Click OK.

Specifying the Display Properties of a Slab/Roof Slab
Use this procedure to change the following properties of the display
components of an individual slab or roof slab:

■ Visibility (display component is on or off)

■ By Material (material assigned to the display component determines its
display properties)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

To change these display properties for all slabs or roof slabs of the same style,
see Specifying the Display Properties of a Slab or Roof Slab Style on page 2499.
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NOTE If a material assignment determines the display properties of a component,
you can change the properties by clearing By Material or by overriding the material
assignment with a different material. For more information, see Specifying the
Material of a Slab/Roof Slab on page 2479.

1 Select the slab or roof slab you want to change, right-click, and
click Edit Object Display.

NOTE You can also use the Display tab of the Properties palette to
change the display property settings for a selected object display
component in the current display representation. For more
information, see Using the Properties Palette to Change Display
Properties on page 793.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 Click the Layer/Color/Linetype tab.

5 Select the component to change, and select a different setting for
the property.

6 Click OK twice.

Specifying the Hatching of a Slab/Roof Slab
Use this procedure to specify the hatching of the components of a slab or roof
slab. Hatching is displayed only in display representations that are used in
the Top view (plan view) of a drawing.

To change the hatching for all slabs or roof slabs of the same style, see
Specifying the Hatching of a Slab/Roof Slab Style on page 2501.

NOTE If a material assignment determines the hatching properties of a slab display
component, you can change the hatching of the display component by clearing
By Material or by overriding the material assignment with a different material. For
more information, see Specifying the Material of a Slab/Roof Slab on page 2479.

1 Select the slab or roof slab you want to change, right-click, and
click Edit Object Display.
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NOTE You can also use the Display tab of the Properties palette to
change the display property settings for a selected object display
component in the current display representation. For more
information, see Using the Properties Palette to Change Display
Properties on page 793.

2 On the Display Properties tab, select the display representation
for which you want to change a property, and select Style
Override.

3 If necessary, click  .

4 On the Hatching tab, select the display component, and click the
setting for Pattern.

5 Select the hatching for the display component:

Then…If you want to…

select Predefined for Type, and then
select a pattern.

specify a hatching pattern that is
available in the software

select Custom for Type, and enter
the name of the custom pattern. If

specify a custom pattern

necessary, click Browse, and navig-
ate to the folder where the custom
pattern file is located.

select User-Defined for Type, and
clear Double Hatch.

specify single hatching

select User-Defined for Type, and
select Double Hatch.

specify double hatching

select Solid Fill for Type.specify solid fill

6 Click OK.

7 Click the setting for Scale/Spacing, and enter a value that
determines how the selected pattern is repeated.

8 Click the setting for Angle, and enter the angle for the selected
pattern.
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9 Click the setting for Orientation, and specify how the hatching
is oriented:

Then…If you want to…

click to select Object.orient the hatching to the slab or
roof slab, regardless of its rotation

click to select Global.orient the hatching to the World
Coordinate System

10 Click the setting for X Offset, and enter an offset value.

11 Click the setting for Y Offset, and enter an offset value.

12 Click OK twice.

Specifying the Cut Plane Height of a Slab/Roof Slab
Use this procedure to specify the cut plane height of a slab or roof slab.

If the value you specify for the cut plane height is greater than zero, you must
specify the layer, color, and linetype for the elements above and below the
cut plane height. This is especially important for slabs or roof slabs with
interference conditions or body modifiers.

To change the cut plane height for all slabs or roof slabs of the same style, see
Specifying the Cut Plane Height of a Slab/Roof Slab Style on page 2503.

1 Select the slab or roof slab you want to change, right-click, and
click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 Click the Other tab.

5 Select Override Display Configuration Cut Plane, and enter a value
for Cut Plane Height.

6 Click OK twice.
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Creating a Clipped Gable Roof
Use this procedure to modify two roof slabs to add a third slab, creating a
clipped gable roof.

1 Create a gable roof with two roof slabs.

2 In an isometric view, draw a 3D polyline in the shape and location
of the clipped roof slab.

3 Enter roofslab.

4 Enter e (Edit).

5 Enter x (Xcut).

6 Select the two roof slabs and press ENTER.

7 Select the 3D polyline and press ENTER twice.

Creating a clipped gable roof

NOTE You can edit the outside edge of the new roof slab to change
it from square to plumb. For more information, see Changing Slab
or Roof Slab Edges on page 2448.
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Creating a Dormer in a Roof Slab
Use this procedure to add a dormer to a roof slab. You must first create the
roof slabs, walls, and all other parts of the dormer, so that an appropriate hole
can be cut in the roof slab. The walls you create for the dormer must include
a back segment, so that a complete hole for the dormer can be cut in the roof
slab.

Adding a dormer to a roof slab

1 Create the walls for the dormer, including a closing rear wall.

2 Open the tool palette that contains the roof slab tool you want
to use.

(You may have to scroll to display the desired tool.)

3 Right-click the tool, and click Apply Tool Properties
to ➤ Linework, Walls and Roof.
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4 Select the walls, and press ENTER.

5 Miter the roof slab edges as required.

6 Move the structure so that the walls and roof slabs of the dormer
fully penetrate the existing roof slab in the correct position.

7 Select the roof slab to add the dormer to, and click Roof Slab

tab ➤ Dormer panel ➤ Add  .

8 Select the objects that form the dormer, and press ENTER.

9 When prompted to slice the walls with the roof slab, press ENTER
to slice the walls, or enter n (No) to leave the walls as they are.

10 Erase the wall at the rear of the dormer.

Slab and Roof Slab Styles
A slab or roof slab style is a set of parameters that determines the appearance
and other characteristics of the slab or roof slab object to which it is assigned.
By editing a style, you can control the properties of all objects that use that
style, without having to change the properties of each such object in a drawing.
For slabs and roof slabs, the style controls the following properties:

■ default dimensions, including thickness

■ default edge conditions, including fascia and soffit styles

■ default display properties, including fascia and soffit

■ physical components (concrete, metal deck, and so on)

■ materials assigned to components of slabs

The default slab and roof slab tools provided with the software use standard
styles. You can use these as provided, edit the standard styles in the Style
Manager, or create your own styles and use them to make new tools.

Using Materials in Slab/Roof Slab Styles

You can control how slabs or roof slabs of a particular style are displayed in
a drawing by assigning materials to the slab or roof slab components in the
style. The components are then displayed using the display properties of the
assigned materials. For more information see Material Components and Display
Properties on page 898.

AutoCAD Architecture provides predefined materials for common design
purposes. You can use these materials as provided, modify them to meet your
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project requirements, or define new materials. For more information about
materials and how to define them, see Creating and Editing Material
Definitions on page 919 and Specifying the Material of a Slab/Roof Slab on
page 2479.

Creating Tools from Slab/Roof Slab Styles

You can create a slab or roof slab tool from a slab or roof slab style by dragging
the style from the Style Manager onto a tool palette. The default settings
provided by the style are then applied to any object created with that tool.
For more information, see Using Tools to Create Slabs and Roof Slabs on page
2410.

Managing Slab/Roof Slab Styles

To create, copy, edit, or purge styles for slabs and roof slabs, you use the Style
Manager. The Style Manager provides a central location in AutoCAD
Architecture where you can work with styles from multiple drawings and
templates. For more information, see Style Manager Overview on page 870.

Creating a Slab or Roof Slab Style
Use this procedure to create a slab or roof slab style. You can start by using
the default properties of the standard style, or you can copy an existing style
to use as your template. You then edit the style properties to customize the
style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Slab Styles or Roof Slab
Styles.

3 Create a style:

Then …If you want to…

right-click Slab or Roof Slab Styles,
and click New. Enter a name for the
new style, and press ENTER.

create a style with default properties

right-click the slab or roof slab style
you want to copy, and click Copy.

create a style from an existing style

Right-click, and click Paste. Right-
click the copy, and click Rename.
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Then …If you want to…

Enter a name for the new style, and
press ENTER.

4 To specify or edit the properties of the new style, use the tabs on
the right pane of the Style Manager as described in the following
table.

Then …If you want to …

click the General tab, and enter a
description.

enter a description of the style

see Specifying the Components of
a Slab or Roof Slab Style on page
2489.

specify the physical components of
the slab or roof slab

see Specifying the Thickness and
Offset of a Slab/Roof Slab Compon-
ent on page 2493.

specify either a fixed or variable
thickness or offset for the slab or
roof slab or its components

see Assigning Materials to a
Slab/Roof Slab Style on page 2498

assign materials to the display
components of the style

and Turning on Materials for a
Slab/Roof Slab Style on page 2501.

see Adding Classifications to a Slab
or Roof Slab Style on page 2504.

add classifications to the style

see Specifying the Display Proper-
ties of a Slab or Roof Slab Style on
page 2499.

specify hatching, cut plane proper-
ties, and other display properties of
the style

see Attaching Notes and Files to a
Slab or Roof Slab Style on page 2505.

add notes and files to the style

5 If you want to create a tool that uses the new style, drag the style
from the Style Manager to a tool palette.

You can later rename the tool and specify other properties for it
as described in Creating a Slab or Roof Slab Tool on page 2423.

6 Click OK.
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Specifying the Components of a Slab or Roof Slab Style
Slab or roof slab components are the physical structures of the slab or roof
slab, such as concrete, metal deck, insulation, and so on.

Slab/Roof Slab Components and Their Properties

Each component in a slab or roof slab style corresponds to a structural
component or material of a slab or roof slab. When you create a component,
you specify values for the following properties of the component:

■ Name (generally identifies the material used, such as concrete, metal deck,
or insulation)

■ Thickness (analogous to the Width property of a wall component; can be
a fixed value or a variable)

■ Thickness Offset (specifies the position of the component within the slab
or roof slab, relative to the slab or roof slab baseline or to adjacent slab or
roof slab components; can be a fixed value or a variable)

Using Components from Other Slab/Roof Slab Styles

In addition to creating new components from scratch within a slab or roof
slab style, you can also paste in components you have copied from a different
style of the same type. That is, you can paste components from one slab style
into another slab style, or components from one roof slab style into another
roof slab style.

Components Tab
Use the Components tab of the Style Manager for the following tasks:

■ Add or remove slab or roof slab components and edit their properties.

■ View the components as you create and configure them.

■ Change the order of components relative to other components in the style.
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Specifying the properties of slab components

Creating or Editing a Component in a Slab/Roof Slab Style
Use this procedure to create a slab or roof slab component, or to edit existing
components in a slab or roof slab style.

You can also add components to a style by pasting in components you have
copied from other styles of the same type.

TIP Only the first 20 components of a slab or roof slab style are controlled by the
display system. It is suggested that you limit the number of components to 20,
since any additional components would be controlled by material assignment
only.

1 Open a tool palette that has a slab or roof slab tool, right-click
the tool, and click Slab Styles or Roof Slab Styles.

NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Styles or Roof Slab Styles from the Edit Style drop-down
on the General panel of ribbon’s contextual menu.
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2 Select the style that you want to change.

3 Click the Components tab.

4 To add a new component, click  .

If no existing component was selected, the new component is
assigned an Index number of 2, but otherwise has the same values
as the first component in the list. If an existing component was
selected, the new component is a duplicate of the selected
component, except that its Index number is 1 higher. In either
case, you can edit the properties of the new component as
described in the following steps.

5 To edit the name of a selected component, click in the Name
column, and enter a new name.

6 To specify the thickness of a component, double-click its Thickness
value, and then do one of the following:

Then …If you want to …

enter a new value for Thickness.specify a fixed thickness that cannot
be edited when you add or edit
objects of this style

click  to display text boxes that
let you specify a formula that

specify a variable thickness based
on a Base Thickness (BT) value that
can be determined when you add
or edit objects of this style defines how the Base Thickness

variable is used to calculate compon-
ent thickness. For more information,
see Specifying the Thickness and
Offset of a Slab/Roof Slab Compon-
ent on page 2493.

7 To specify the offset distance between the component and the
slab or roof slab baseline, double-click the Thickness Offset value
for the component, and then do one of the following:

Then …If you want to …

click  or  in the lower-left
corner of the Components tab to

move the component up or down
by a specified increment

offset the component by the Offset
Increment value that you specify.
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Then …If you want to …

The selected component is high-
lighted in green in the viewer.

select Auto Calculate Thickness
Offset.

let the software calculate the offset

enter a value for Thickness Offset.specify a fixed offset

click  in the Thickness Offset
column to display text boxes that

specify a variable offset that is calcu-
lated from values that you specify

let you specify a formula that
defines how the Base Thickness
variable is used to calculate compon-
ent thickness. For more information,
see Specifying the Thickness and
Offset of a Slab/Roof Slab Compon-
ent on page 2493.

8 Repeat steps 5 through 8 to add more components to the style.

9 To change the order of components in the style, select a

component, and click  or  at the upper-right side of the tab
to move the component to the desired position relative to the
other components.

The Index numbers update to reflect the new order.

10 Click OK.

Adding a Component from Another Slab or Roof Slab Style
Use this procedure to copy a slab or roof slab component from one style and
add it to another style of the same type that you are creating or editing.

TIP Only the first 20 components of a slab or roof slab style are controlled by the
display system. It is suggested that you limit the number of components to 20,
since any additional components would be controlled by material assignment
only.

1 Open a tool palette that has a slab or roof slab tool, right-click
the tool, and click Slab Styles or Roof Slab Styles.
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NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Styles or Roof Slab Styles from the Edit Style drop-down
on the General panel of ribbon’s contextual menu.

2 Select the style that contains the component you want to copy:

Then …If you want to …

in the left pane of the Style Man-
ager, select a style. The right pane

view the components for a style in
the current drawing

lists the components and their
properties and displays the style in
the viewer.

click  , navigate to the drawing
you want, click Open, and then se-

view the components for a style in
another drawing

lect a style in the left pane of the
Style Manager.

3 On the Components tab for the selected style, right-click the
desired component, and click Copy.

4 In the left pane of the Style Manager, select the style to which
you want to add the component:

5 Move the cursor onto the Components tab, right-click, and click
Paste.

You can now edit or delete the new components as needed. For
more information, see Creating or Editing a Component in a
Slab/Roof Slab Style on page 2490 and Removing a Component from
a Slab/Roof Slab Style on page 2495.

6 Click OK to save the style with the new component.

Specifying the Thickness and Offset of a Slab/Roof Slab
Component

When you create or edit a slab or roof slab component in a style, you can
enter values that establish a fixed thickness and a fixed offset from the slab
or roof slab baseline. If all the components in a slab or roof slab style use these
fixed values, then you cannot change the thickness for an object of that style
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when you add one to a drawing. (The Thickness value on the Properties palette
is read-only, and no Thickness grip is available on the object itself.)

Specifying slab component offsets

Alternatively, when you specify the Thickness or Thickness Offset values for
a slab or roof slab component, you can use a variable called Base Thickness
(BT), which has a default value of 4'' but can be changed at the time you add
the slab or roof slab to a drawing or subsequently, either through the Properties
palette or by grip editing. You can use the Base Thickness variable by itself,
or as part of a formula that will be used to calculate the component thickness
or offset.

For example, if you want to create a style in which a 2'' paving component is
positioned directly above a paving base of variable thickness whose bottom
edge is the same as the slab baseline, you would specify the Thickness and
Thickness Offset values as follows:

For more complicated positioning relationships involving the Base Thickness
variable, you can construct formulas for calculating the Thickness and
Thickness Offset values. For example, if you know you want .5'' rebar to be
positioned in the middle of a concrete layer with a fixed thickness of 6'', you
might configure the components in the slab style as follows:
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However, if you want the rebar to be positioned in the middle of the concrete
component, regardless of its thickness, you can configure the components as
follows, where the concrete thickness is specified as a variable (BT), and the
offset of the rebar component is specified as one half of the concrete thickness,
whatever that may be, minus half the thickness of the rebar (1/4'').

To specify a formula using the Base Thickness variable, click the Thickness or

Thickness Offset value for the component, and then click  to display the
text boxes for the formula as shown.

The formula can be as simple as the one shown, in which only the Base
Thickness is used, or it can specify a value to be added to the Base Thickness,
or a further mathematical operation involving the Base Thickness. (Note that
the operation drop-down menu and the operand box at the far right are only
available if Base Thickness is selected.) In the case of the 1/2'' rebar positioned
in the middle of a variable thickness concrete slab, the formula for the rebar
Thickness Offset would be constructed as follows:

After you have entered the desired formula, press Enter to dismiss the text
boxes and transfer the formula to the Thickness or Thickness Offset value for
the selected component.

Removing a Component from a Slab/Roof Slab Style
Use this procedure to delete a component from a slab or roof slab style. When
you remove a component from a style, the component is also removed from
all existing objects that use that style.

1 Open a tool palette that has a slab or roof slab tool, right-click
the tool, and click Slab Styles or Roof Slab Styles.

NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Styles or Roof Slab Styles from the Edit Style drop-down
on the General panel of ribbon’s contextual menu.
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2 Select the style that you want to change.

3 Click the Components tab.

4 Select the slab or roof slab component you want to remove, and

click  .

5 Click OK.

Specifying the Materials of a Slab or Roof Slab Style
A slab or roof slab object consists of a number of components whose display
properties can be determined by the materials assigned to them.

You assign one material to each display component of the object. For example,
you might assign a floor tile material to a slab body and a concrete material
to a slab edge.

If you want to use the display properties of a slab or roof slab object or style,
instead of using material display properties, you can turn off the material
assignments in the display properties of the object or its style.

Material definitions consist of display components that correspond to
component types of objects. For example, the Linework component of a
material is used for all linework in Plan view. The Surface Hatch component
of a material is used to hatch all object surfaces in 3D model views and
elevations.

For a complete list of material components and their description, see Material
Components and Display Properties on page 898.

Roof slabs with assigned materials
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Slab/Roof Slab Materials and Display Components
The following table identifies the material component that corresponds to
each slab or roof slab component.

Material Display Compon-
ent

Slab/Roof Slab Display
Component

Display Representa-
tions

Below Cut Plane Body
Shrinkwrap

Plan, Plan High Detail,
Plan Low Detail, Reflec-
ted Plan, Screened

NoneAbove Cut Plane Body
Shrinkwrap

NoneBelow Cut Plane Outline

NoneAbove Cut Plane Outline

NoneCut Plane Shrinkwrap

NoneCut Plane Shrinkwrap
Hatch

Plan LineworkBoundary

Plan HatchHatch

NoneBaseline

Plan LineworkFascia

Plan LineworkSoffit

NonePivot Point

NoneBaselineModel

3D BodySlab

3D BodyFascia

3D BodySoffit
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Material Display Compon-
ent

Slab/Roof Slab Display
Component

Display Representa-
tions

NonePivot Point

Assigning Materials to a Slab/Roof Slab Style
Use this procedure to assign materials to the individual components of a slab
or roof slab style. The components will then use the display properties of the
materials instead of the style display properties.

You can assign a material to any physical component of the slab or roof slab.
Custom components and components that are only symbolic do not use
materials for their display properties. For example, the slab or roof slab body
is a physical component, while the pivot point is a symbolic component.

NOTE Although fascias and soffits are physical components of slabs or roof slabs,
they are defined in the slab or roof slab edge style, and not in the slab or roof slab
style. For information on assigning materials to edge styles, see Assigning Materials
to a Slab/Roof Slab Edge Style on page 2520.

NOTE If a material assignment does not determine the display properties of a slab
or roof slab component, you can change the display properties of the style as
described in Specifying the Display Properties of a Slab or Roof Slab Style on page
2499.

1 Open a tool palette that has a slab or roof slab tool, right-click
the tool, and click Slab Styles or Roof Slab Styles.

NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Styles or Roof Slab Styles from the Edit Style drop-down
on the General panel of ribbon’s contextual menu.

2 Select the style you want to edit.

3 Click the Display Properties tab.

4 Select the display representation in which to display the changes,
and select Style Override.

5 If necessary, click  .

6 Click the Layer/Color/Linetype tab.

7 Select By Material for any component to which you want to assign
a material, and click OK.
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If the setting for By Material is not available, the display of this
component cannot be determined by a material.

8 Click the Materials tab.

9 Click the component you want to change, click its current material
definition, and select a different material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Any changes you make to the material definition in this
dialog will apply to all objects that are assigned the material.

10 Click OK.

Specifying the Display Properties of a Slab or Roof Slab Style
In most cases, you want the appearance of slabs or roof slabs that use the same
style to be consistent throughout a drawing. To achieve this, you specify the
following display properties in each style:

■ The layer, color, and linetype of slab or roof slab components

■ The hatching used for the surface of the slab or roof slab in plan views

■ The cut plane height

Components with display properties include dimensions for slab or roof slab
thickness, edge conditions for the fascia and soffit, line work, cut planes, cut
lines, 3D shading factors, baseline, and pivot point. The display properties of
the fascia and soffit are also controlled by the slab or roof slab style, although
the geometry of these components is controlled through edge styles.

You can also use materials to control the display properties of the physical
components of a slab or roof slab. Symbolic components, such as the pivot
point, are not controlled by materials. For more information about using
materials in slabs and roof slabs, see Specifying the Materials of a Slab or Roof
Slab Style on page 2496.
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Specifying the Layer, Color, and Linetype of a Slab/Roof Slab
Style

Use this procedure to change the following display properties for display
components of a slab or roof slab style:

■ Visibility (component is on or off)

■ By material (material assigned to the display component determines its
display properties)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype Scale

NOTE If a material assignment determines the properties of components in the
slab or roof slab style, you can change the properties of the display component
by clearing By Material, or by overriding the material assignment with a different
material. For more information, see Assigning Materials to a Slab/Roof Slab Style
on page 2498.

1 Open a tool palette that has a slab or roof slab tool, right-click
the tool, and click Slab Styles or Roof Slab Styles.

NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Styles or Roof Slab Styles from the Edit Style drop-down
on the General panel of ribbon’s contextual menu.

2 Select the style you want to edit.

3 Click the Display Properties tab.

4 Select the display representation in which to display the changes,
and select Style Override.

5 If necessary, click  .

6 Click the Layer/Color/Linetype tab.

7 Select the component to change, and select a different setting for
the property.
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8 Click OK.

Turning on Materials for a Slab/Roof Slab Style
Use this procedure to turn on material assignments for individual display
representations in a slab or roof slab style.

For more information about using materials to control the display of slab or
roof slab components, see Specifying the Materials of a Slab or Roof Slab Style
on page 2496.

1 Open a tool palette that has a slab or roof slab tool, right-click
the tool, and click Slab Styles or Roof Slab Styles.

NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Styles or Roof Slab Styles from the Edit Style drop-down
on the General panel of ribbon’s contextual menu.

2 Select the style you want to edit.

3 Click the Display Properties tab.

4 Select the display representation in which to display the changes,
and select Style Override.

5 If necessary, click  .

6 Click the Layer/Color/Linetype tab.

7 Select By Material for each component to be controlled by the
material. The By Material check box is unavailable for components
that cannot be assigned a material.

When you select By Material for a display component, all other
settings in the dialog box are unavailable. Since the display
properties are now taken from the material definition, you can
no longer set them directly in the display properties of the slab
or roof slab style.

8 Click OK.

Specifying the Hatching of a Slab/Roof Slab Style
Use this procedure to specify the hatching of a slab or roof slab style. Hatching
is displayed only in display representations, such as Plan, that are used in the
Top view (plan view) of a drawing.
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1 Open a tool palette that has a slab or roof slab tool, right-click
the tool, and click Slab Styles or Roof Slab Styles.

NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Styles or Roof Slab Styles from the Edit Style drop-down
on the General panel of ribbon’s contextual menu.

2 Select the style you want to edit.

3 Click the Display Properties tab.

4 Select the display representation in which to display the changes,
and select Style Override.

5 If necessary, click  .

6 Click the Hatching tab.

7 Click the setting for Pattern.

8 Select the hatching pattern:

Then…If you want to…

select Predefined for Type, and then
select a pattern.

select a hatching pattern that is
available in the software

select Custom for Type, and then
enter the name of the custom pat-

select a custom pattern

tern. If necessary, click Browse, and
navigate to the folder where the
custom pattern file is located.

select User-defined for Type, and
then clear Double Hatch.

select single hatching

select User-defined for Type, and
then select Double Hatch.

select double hatching

select Solid Fill for Type.select solid fill

9 Click OK.

10 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

11 Click Angle, and enter the angle for the selected pattern.
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12 Click Orientation, and specify how the hatching is to be oriented:

Then…If you want to…

click to select object.orient the hatching to the slab or
roof slab, regardless of its rotation

click to select global.orient the hatching to the World
Coordinate System

13 Click OK twice.

Specifying the Cut Plane Height of a Slab/Roof Slab Style
Use this procedure to specify the cut plane height of a slab or roof slab style.

If the value you specify for the cut plane height is greater than zero, you must
specify the layer, color, and linetype for the elements above and below the
cut plane height. This is especially important when interference conditions
or body modifiers are present.

1 Open a tool palette that has a slab or roof slab tool, right-click
the tool, and click Slab Styles or Roof Slab Styles.

NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Styles or Roof Slab Styles from the Edit Style drop-down
on the General panel of ribbon’s contextual menu.

2 Select the style you want to edit.

3 Click the Display Properties tab.

4 Select the display representation in which to display the changes,
and select Style Override.

5 If necessary, click  .

6 Click the Other tab.

7 Select Override Display Configuration Cut Plane, and enter a value
for Cut Plan Height.

8 Click OK twice.
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Adding Classifications to a Slab or Roof Slab Style
Use this procedure to specify classifications for any classification definition
applied to a slab or roof slab style.

For more information about creating and applying classification definitions,
see Classification Definitions on page 3872.

1 Open a tool palette that has a slab or roof slab tool, right-click
the tool, and click Slab Styles or Roof Slab Styles.

NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Styles or Roof Slab Styles from the Edit Style drop-down
on the General panel of ribbon’s contextual menu.

2 Select the style you want to edit.

3 Click the Classifications tab.

By default, the classification for all classification definitions is
Unspecified. If no classification definitions are listed, none are
applied to slab or roof slab styles.

4 For each classification definition, select the classification you want
to apply to the current style.

5 Click OK.

Defining a Slab/Roof Slab Style as Bounding for Associative
Spaces

Use this procedure to define a slab or roof slab style that can bound associative
spaces.

When a style is set as bounding, by default all objects of that style will be used
in the selection set for an associative space. For more information about
associative spaces see Generating Associative Spaces on page 2940.

By default, this setting is checked.

You can override the bounding setting for the style in an individual slab or
roof slab if necessary.

1 Open a tool palette that has a slab or roof slab tool, right-click
the tool, and click Slab Styles or Roof Slab Styles.
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NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Styles or Roof Slab Styles from the Edit Style drop-down
on the General panel of ribbon’s contextual menu.

2 Select the style you want to edit.

3 Click the General tab.

4 Select the checkbox for Objects of this style may act as a boundary
for associative spaces.

5 Click OK.

Attaching Notes and Files to a Slab or Roof Slab Style
Use this procedure to enter notes and attach reference files to a slab or roof
slab style. You can also edit notes and edit or detach reference files from the
style.

1 Open a tool palette that has a slab or roof slab tool, right-click
the tool, and click Slab Styles or Roof Slab Styles.

NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Styles or Roof Slab Styles from the Edit Style drop-down
on the General panel of ribbon’s contextual menu.

2 Select the style you want to edit.

3 Click the General tab.

4 To add a description to the style, enter it under Description.

5 Click Notes.

6 To add or edit a note, click the Notes tab, and enter the note or
edits.

7 To attach, edit, or detach a reference file, click the Reference Docs
tab:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Edit
the description, and click OK.

edit the description of a reference
file
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Then…If you want to…

double-click the reference file name
to start its application. Click OK
when you are finished editing.

edit a reference file

select the file name, click Delete,
and click OK.

detach a reference file

8 Click OK.

Slab and Roof Slab Edge Styles
Slab and roof slab edge styles control the appearance of the edges of slab and
roof slab objects. Using edge styles, you can specify dimensions, such as the
overhang length, and the orientation and angle of the edges. You can also
specify a fascia and soffit for the edge style.

Components of Slab/Roof Slab Edge Styles

The slab or roof slab edge style defines the appearance of slab or roof slab
edges. Each style consists of two optional components: a fascia and a soffit.

A fascia is a shape applied to the outside face of a slab or roof slab edge. A
soffit is a shape applied to the underside of an edge overhang.

You can create fascia and soffit components by defining profiles that provide
the two-dimensional (2D) geometry of the component whose shape is then
extruded along the slab or roof slab edge.

The fascia component follows the orientation of the slab edge (plumb or
square cut). The soffit component, however, is always oriented to the
horizontal. Either component can have a positive or negative angle, relative
to its base orientation.

The +/- directions for edge component angles remain the same regardless of
their orientation in the XY plane. They always follow the slab or roof slab
slope, so that, for example, a +30° soffit and a +30° slab or roof slab would be
parallel to each other. Similarly, a +10° (plumb cut) fascia and a -10° soffit
would meet at a right angle. Mirroring a slab or roof slab maintains the same
angle signs for all components.
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Controlling the Placement of the Fascia and Soffit on Slab/Roof Slab Edges

The fascia profile is drawn at actual size, except when you select Auto-Adjust.
If the slab or roof slab edge is sloped relative to the ground plane, then the
length is measured parallel to that slope, and not plumb with the ground.
When you select Auto-Adjust to Edge Height, the fascia profile is scaled about
its insertion point so that its lowest Y axis point aligns with the bottom of the
slab or roof slab edge.

NOTE Slope offsets are measured relative to the slab or roof slab edge angle from
the ground plane, and not relative to the world UCS.

The soffit profile is drawn at actual size, except when you select Auto-Adjust.
The soffit angle is measured about its insertion point, using the local X axis
of the profile.

When you select Auto-Adjust to Overhang Depth, the soffit profile is scaled
about the insertion point, so that the furthest X axis point aligns with a plumb
line from the slab or roof slab baseline or perimeter line. Auto-Adjust scaling
is adjusted by the horizontal offset from the baseline dimension.

Display Properties of the Fascia and Soffit

In most cases, you want the appearance of fascias or soffits that use the same
edge style to be consistent throughout a drawing. To achieve this, you specify
the following display properties in each slab or roof slab edge style:

■ The layer, color, and linetype of slab or roof slab edge components

■ The hatching used for the surface of slab or roof slab edges in plan views

■ The cut plane height

Slab edge components with display properties include dimensions for slab
thickness, fascia and soffit, vertical and horizontal offsets, line work, cut planes,
cut lines, 3D shading factors, baseline, slab, and pivot point. The display
properties of the fascia and soffit are also controlled by slab or roof slab style,
although the geometry of these components is controlled through slab or roof
slab edge styles.

Materials in Slab/Roof Slab Edges

You can assign materials to a slab or roof slab edge. These materials are then
displayed in wireframe or rendered views. Materials have specific settings for
individual components of a slab or roof slab edge, such as the fascia and soffit.
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Viewing Slab Edge detail in 2D wireframe and rendered views

AutoCAD Architecture provides predefined materials for common design
purposes. These materials contain settings for slabs and slab edges that you
can use “as is” or modify for special designs. You can also create materials
from scratch. For more information, see Specifying the Materials of a Slab or
Roof Slab Style on page 2496.

Managing Slab/Roof Slab Edge Styles

To create, import, export, or edit styles, you use the Style Manager. The Style
Manager provides a central location where you can work with styles from
multiple drawings and templates. For more information about using the Style
Manager, see Style Manager Overview on page 870.

Creating a Slab or Roof Slab Edge Style
Use this procedure to create a new slab or roof slab edge style. You can start
by using the default properties of the standard style, or you can copy an
existing style to use as your template. You then edit the style properties to
customize the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Slab Edge Styles or
Roof Slab Edge Styles.

NOTE Alternatively, select a slab or roof slab object drawing, and
then from the contextual ribbon’s General panel, click the Edit Style
drop-down menu, and choose Edge Styles.

3 Create a slab or roof slab edge style:

Then…If you want to…

right-click Slab Edge Styles or Roof
Slab Edge Styles, and click New.

create a style with default properties
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Then…If you want to…

Enter a name for the new style, and
press ENTER.

right-click the style you want to
copy, and click Copy. Right-click,

create a style from an existing style

and click Paste. Right-click the copy,
and click Rename. Enter a name for
the new style, and press ENTER.

4 To specify or edit the properties of the new style, use the tabs on
the right pane of the Style Manager as described in the following
table:

Then…If you want to…

click the General tab, and enter a
description.

enter a description of the style

see Specifying the Overhang, Edge
Cut, and Angle of a Slab/Roof Slab
Edge Style on page 2510.

specify the overhang, edge cut, and
angle for the style

see Specifying a Fascia and a Soffit
for a Slab/Roof Slab Edge Style on
page 2514.

specify soffits and fascias for the
style

see Assigning Materials to a
Slab/Roof Slab Edge Style on page
2520.

assign materials to the display
components of the style

see Turning on Materials for a
Slab/Roof Slab Edge Style on page
2521.

turn on materials for the style

see Attaching Notes and Files to a
Slab/Roof Slab Edge Style on page
2522.

add notes and files to the style

5 When you finish specifying the properties of the style, click OK.
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Specifying the Overhang, Edge Cut, and Angle of a Slab/Roof
Slab Edge Style

Use this procedure to specify the default overhang depth, edge cut, and edge
angle for slab or roof slab edges using an edge style.

1 Select a slab or roof slab, and

then…if the object selected is…

click Slab tab ➤ General pan-

el ➤ Edit Style drop-down ➤ Slab

Edge Style  .

a slab

clickRoof Slab tab ➤ General pan-

el ➤ Edit Style drop-down ➤ Roof
Slab Edge Style.

a roof slab

2 Select an edge of the slab or roof slab.

3 Click the Defaults tab.

4 Specify the overhang, edge cut, and angle of the edge:

Then…If you want to…

enter a value for Overhang.specify the overhang of the slab or
roof slab
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Then…If you want to…

select a setting for Edge Cut:specify the orientation of the edge
cut ■ Select Square to cut the edge

90 degrees with the plane of
the slab or roof slab.

■ Select Plumb to cut the edge
perpendicular to the ground.

enter a value for Angle. A positive
value moves the bottom of the

specify the angle of the edge

edge out and a negative value
moves the bottom of the edge in.

Specifying square and plumb edges

5 Click OK.

Creating Profiles for the Fascia and Soffit
Use this procedure to create a profile for the fascia and soffit.

The profile is made up of closed polylines. To represent solid fascia or soffits,
such as a wood fascia, you can create a profile from a single polyline. To
represent fascia or soffits that are extruded, such as aluminum soffits, you can
create a profile from concentric polylines that can include one or more voids.
The outer polyline, or ring, becomes the exposed shape, and the inner polyline,
if used, becomes the void. You can create multiple voids by adding more inner
closed polylines. The polylines are proportional in size and shape to each
other and to the slab.
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You can draw these polylines anywhere in the drawing and use any convenient
scale relative to your final fascia or soffit size. One method for sizing the
polylines relative to the slab or roof slab edge is to draw them by snapping to
an existing fascia, and then move your completed polylines to an open area
of the drawing to create the profile.

Assigning a profile as a fascia

Assigning a profile as a soffit

1 Draw one or more closed polylines representing the fascia or soffit.

2 Select the polylines, right-click, and click Convert to ➤ Profile
Definition.

3 Select the outermost polyline.

4 Enter a (Add ring) as needed.

5 Select an inner polyline as needed.

6 Repeat steps 3 and 4 as needed to add more voids to the profile.

7 Specify the insertion point for the fascia or soffit. (The insertion
point is typically the lower-left corner.)

8 Enter n (New), enter a name for the profile, and click OK.
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Controlling Profile Edges and Extrusion
Use this procedure to specify the following parameters for a profile:

■ the position of each edge in a profile (left, right, back, discard, none)

■ the axis along which an object is extruded from the shape of a profile

These settings determine how surface hatching is applied to objects created
from the profile and how the objects are extruded from the two-dimensional
(2D) profile.

NOTE Objects already created from the profile change when you change profile
edges or the axis of extrusion.

1 Click Manage tab ➤ Style & Display panel ➤  ➤ Profile

Definitions  .

2 Select the profile you want to change.

3 Click the Profile Edges tab.

4 Specify edge positions:

Then…If you want to…

click Calculate Default Edge Posi-
tions. You can then override the

let the software determine the pos-
ition of edges

position of individual edges, if ne-
cessary.

select edge number under Edge,
and select a new position under
Position.

select a position for an edge

select the edge number under
Edge, and select None under Posi-
tion.

exclude an edge from surface
hatching

select the edge number under
Edge, and select Discard under Pos-
ition.

discard an edge
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5 Specify the axis of extrusion based on the type of object created
from the profile:

Then…If you want to…

select X for Extrusion Direction.create a roof slab or slab fascia

select Y for Extrusion Direction.create a slab soffit

select Z for Extrusion Direction.extrude mass elements

6 Click OK.

Specifying a Fascia and a Soffit for a Slab/Roof Slab Edge Style
Use this procedure to specify a fascia and a soffit for a slab or roof slab edge
style. The drawing must contain profiles for the fascia and soffit. For more
information, see Creating Profiles for the Fascia and Soffit on page 2511.

1 Select a slab or roof slab, and

then…if the object selected is…

click Slab tab ➤ General pan-

el ➤ Edit Style drop-down ➤ Slab

Edge Styles  .

a slab

click Roof Slab tab ➤ General pan-

el ➤ Edit Style drop-down ➤ Roof
Slab Edge Styles.

a roof slab

NOTE Alternatively,click Manage tab ➤ Style & Display panel ➤ Style

Manager  , and then expand Architectural Objects, and expand
Slab Edge Styles or Roof Slab Edge Styles.

2 Select the slab or roof slab edge style that you want to edit.
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3 Click the Design Rules tab.

4 Select Fascia, and select a profile that defines the geometry of the
fascia.

If you select *NONE*, display component settings apply to the
slab or roof slab edge line or plane where the fascia is located.

5 Specify how the fascia is to be scaled on the slab or roof slab edge:

Then…If you want to…

select Auto-Adjust to Edge Height
to scale the fascia to edge height.

scale the fascia to fit the height of
the edge

clear Auto-Adjust to Edge Height.use the fascia at its drawn size

6 Select Soffit, and select a profile that defines the geometry of the
soffit.

If you select *NONE*, display component settings apply to the
slab or roof slab edge line or plane where the soffit is located.

7 Specify how the soffit is to be scaled on the slab or roof slab
overhang:

Then…If you want to…

select Auto-Adjust to Overhang
Depth.

scale the soffit to fit the depth of
the overhang
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Then…If you want to…

clear Auto-Adjust to Overhang
Depth.

use the soffit at its drawn size

8 Specify the placement of the soffit:

Then…If you want to…

enter a value for the Angle, with
zero being horizontal. A positive

specify the soffit angle of the slab
or roof slab edge

value slopes the soffit up from the
insertion point, and a negative
value slopes the soffit down.

enter a value for Horizontal Offset
from [Slab/Roof Slab] Baseline. (This

specify the horizontal offset from
the slab or roof slab baseline or
perimeter line for the slab edge option is available only if you select

Auto-Adjust to Overhang Depth.)

enter a value for “X” Direction and
“Y” Direction.

specify the soffit offsets from the
insertion point of the fascia

9 Click OK.

Editing the Geometry of Fascia and Soffits
Use this procedure to edit the geometry of the profile used to define the fascia
and soffit of a slab or roof slab edge style. You can also add a profile to the
fascia or soffit of an edge style that does not currently use a profile to define
its shape.

NOTE If you want to replace the geometry of the profile with newly drawn
polylines, draw them before you start this procedure.

1 Select the slab or roof slab that has the style you want to change.

2 Add or edit a profile:

Then…If you want to…

add an existing profile to the style ■ For a slab, click Slab

tab ➤ Edge panel ➤ Add Pro-

files  .
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Then…If you want to…

■ For a roof slab, click Roof Slab

tab ➤ Edge panel ➤ Add Pro-

files  .

Select an edge. Select the name of
the profile for the fascia or soffit,
and click OK.

create a profile and add it to the
style

■ For a slab, click Slab

tab ➤ Edge panel ➤ Add Pro-

files  .

■ For a roof slab, click Roof Slab

tab ➤ Edge panel ➤ Add Pro-

files  .

Select an edge. Select Start from
scratch for Fascia or Soffit Profile
Definition, enter a name for the
new profile, and click OK. A rect-
angle profile is created for you to
edit.

edit the existing profile for the style ■ For a slab, click Slab

tab ➤ Edge panel ➤ Edit Profile

In Place  .

■ For a roof slab, click Roof Slab

tab ➤ Edge panel ➤ Edit Profile

In Place  .

NOTE If you are prompted about the selected edge not having an
edge style and overhang, click Yes.

3 If you receive a message that the profile is not drawn to size, click
Yes.

The area of the slab or roof slab edge defined by the profile is
selected and hatched in the drawing.
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NOTE After you perform an editing task from the Edit in Place
contextual tab, you may need to select a profile again to perform
another editing task. If you do not see the editing commands that
you expect on the contextual tab, re-select a profile to redisplay the
Edit in Place contextual tab.

4 Edit the profile as necessary:

Then…If you want to…

select the profile, and use edge and
vertex grips to adjust the shape.

change the shape of the perimeter
of the profile or its rings

The Edge grip has two edit modes:
Stretch and Move. The default
mode is Stretch, and the direction
of the stretch depends on the orient-
ation of edges connected to the
selected edge. For example, if the
edges at both ends of the selected
edge are parallel to each other, the
grip edit mode is Stretch (Parallel)
and the stretch direction is limited
to the direction of the parallel
edges. If the connected edges are
not parallel, the grip edit mode is
Stretch (Offset) and the stretch dir-
ection is perpendicular to the direc-
tion of the selected edge. The Move
edit mode allows an unconstrained
move of the selected edge.

add vertices to the profile ■ if the object is a slab, click Edit
In Place: Slab Edge Profile

tab ➤ Profile panel ➤ Add Ver-

tex  .

■ if the object is a roof slab, click
Edit In Place: Roof Slab Edge

Profile tab ➤ Profile pan-

el ➤ Add Vertex  .

Select a point for each new vertex,
and press ENTER.
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Then…If you want to…

remove vertices from the profile ■ if the object is a slab, click Edit
In Place: Slab Edge Pro-

file ➤ Profile panel ➤ Remove

Vertex  .

■ if the object is a roof slab, click
Edit In Place: Roof Slab Edge

Profile tab ➤ Profile panel ➤ Re-

move Vertex  .

Select each vertex to remove, and
press ENTER.

replace an existing ring of the pro-
file with new geometry

■ if the object is a slab, click Edit
In Place: Slab Edge Profile

tab ➤ Profile panel ➤ Replace

Ring  .

■ if the object is a roof slab, click
Edit In Place: Roof Slab Edge

Profile tab ➤ Profile panel ➤ Re-

place Ring  .

Select the ring to replace, and select
the new geometry. Press ENTER to
keep the geometry, or enter n (No)
to erase it.

5 Save or discard the changes:

Then…If you want to…

restore the profile to its original
shape

■ if the object is a slab, click Edit
In Place: Slab Edge Profile

tab ➤ Edits panel ➤ Cancel.

■ if the object is a roof slab, click
Edit In Place: Roof Slab Edge

Profile tab ➤ Edits panel ➤ Can-
cel.
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Then…If you want to…

save the changes to the current
profile

■ if the object is a slab, click Edit
In Place: Slab Edge Profile

tab ➤ Edits panel ➤ Finish.

■ if the object is a roof slab, click
Edit In Place: Roof Slab Edge

Profile tab ➤ Edits panel ➤ Fin-
ish.

The slab or roof slab style uses the
edited profile to define its geo-
metry. Any other objects or styles
that use this profile are also up-
dated with the edited geometry.

save the changes to a new profile
definition

■ if the object is a slab, click Edit
In Place: Slab Edge Profile

tab ➤ Edits panel ➤ Save As

 .

■ if the object is a roof slab, click
Edit In Place: Roof Slab Edge

Profile tab ➤ Edits panel ➤ Save

As  .

Enter a name for the new profile
definition, and click OK. The slab or
roof slab uses the new profile to
define its geometry. Any other ob-
jects of this style are updated with
the new geometry. Other styles or
objects that use the original profile
are not affected.

Assigning Materials to a Slab/Roof Slab Edge Style
Use this procedure to assign materials to individual components of a slab or
roof slab edge style.
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1 Click Manage tab ➤ Style & Display panel ➤ Style Manager ,
then expand Architectural Objects, and expand Slab Edge Styles
or Roof Slab Edge Styles.

NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Edge Styles or Roof Slab Edge Styles from the Edit Style
drop-down on the General panel of ribbon’s contextual menu.

2 Select the style to which to assign materials.

3 Click the Materials tab.

4 Select the edge component to which to assign a material, and
click its current material definition.

5 Select a material definition from the list.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Any changes you make to the material definition in this
dialog will apply to all objects that are assigned the material.

6 Click OK.

Turning on Materials for a Slab/Roof Slab Edge Style
Use this procedure to turn on material assignments for individual display
representations in a slab or roof slab edge style. Display components for edges
are not turned on in the edge style, but rather in the slab or roof slab style
that uses them.

For information on creating and assigning materials, see Specifying the
Materials of a Slab or Roof Slab Style on page 2496.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .
Expand Architectural Objects, and expand Slab Styles or Roof Slab
Styles.

NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Styles or Roof Slab Styles from the Edit Style drop-down
on the General panel of ribbon’s contextual menu.

Turning on Materials for a Slab/Roof Slab Edge Style | 2521



2 Select the style that contains the edges you want to turn on.

3 Click the Display Properties tab.

4 Select the display representation in which to display the changes,
and select Style Override.

5 If necessary, click  .

6 Click the Layer/Color/Linetype tab.

7 Select By Material for each component to be controlled by the
material.

If the setting for By Material is not available, the display of this
component cannot be determined by a material.

8 Click OK twice.

Attaching Notes and Files to a Slab/Roof Slab Edge Style
Use this procedure to enter notes and attach reference files to a slab or roof
slab edge style. You can also edit notes and edit or detach reference files from
the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .
Expand Architectural Objects, and expand Slab Edge Styles or
Roof Slab Edge Styles.

NOTE Alternatively, you can select a slab or roof slab in the drawing,
and click Slab Edge Styles or Roof Slab Edge Styles from the Edit Style
drop-down on the General panel of ribbon’s contextual menu.

2 Select the style you want to edit.

3 Click the General tab.

4 To add a description to the edge style, enter it under Description.

5 Click Notes.

6 To add or edit a note, click the Notes tab, and enter the note.

7 To attach, edit, or detach a reference file, click the Reference Docs
tab:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file
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Then…If you want to…

select the file, and click Edit. Edit
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application. Click OK
when you are finished editing.

edit a reference file

select the file name, click Delete,
and click OK.

detach a reference file

8 Click OK.
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Structural Members

A structural member is an object that can represent a beam, brace, or column in a drawing.
All the beams, braces, and columns that you create are sub-types of a single structural member
object.

Structural Members
A structural member is an object that can represent a beam, brace, or column
in a drawing. All the beams, braces, and columns that you create are sub-types
of a single structural member object.

Creating Structural Members

You create a structural member in AutoCAD Architecture by extruding a
structural shape along a path. The style that you use to create the structural
member provides the shape. The shape, similar to a profile, is a 2-dimensional
cross-section of a structural member. You define the extrusion path (axis) of
the member when you specify start and endpoints for the member or when you
convert linework to a member.

Creating a structural member

32
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Connecting Structural Members

Connections between structural members are supported. Structural members
are considered connected when an endpoint of one member lies on an
endpoint or along the axis of another. With some exceptions, you have the
option of maintaining or breaking these connections when you move a
member using its Location grip. Connections between structural members are
also recognized across external reference (xref) drawings, and you can use
objects in an xref to position and establish trim planes for members you are
adding. For example, while working in one drawing, you can open an xref
containing a column grid and use it to lay out columns or beams. If you edit
the xref in-place, connections between structural members are maintained
just as they would be in the host drawing. For more information on the
behavior of connections during edits, see Using Grips To Edit Structural
Members on page 2586.

Creating Styles with the Structural Member Catalog and Structural Member
Style Wizard

To create styles for most standard beams, braces, and columns, you can use
the Structural Member Catalog included in AutoCAD Architecture. The catalog
contains specifications for industry-standard concrete, steel, and timber
structural shapes organized in a Windows® Explorer-like tree view. You can
browse the catalog, select a shape, and create a style.

Structural Member Catalog

If you know the type, shape, and shape dimensions of the member that you
want to create, you can quickly enter the information in the Structural Member
Style wizard to create a style. You can create a structural member shape within
a style that is based on any of the member shapes in the catalog.
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Structural Member Style Wizard

After you create structural member styles, you can drag them from the Style
Manager onto tool palettes to create structural member tools.

Adding Graphics to Structural Members

You can add blocks to the display of structural members as components in
display representations. For example, you can create blocks that represent
stiffener plates and add them to beams or create blocks that represent clip
angles and add them to members.

Beam with added stiffener plates

Trimming Structural Members

Structural members are trimmed using objects called trim planes, which let
you clean up joints between multiple structural members or between structural
members and other objects. Using the Properties palette for a structural member
tool, you can create specific trim planes that are applied when you add a new
member with the tool. Or you can specify that trim planes be created
automatically when you connect the new member to an existing structural
member in a drawing. Once a member has been added to a drawing, you can
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edit its trim planes or add new ones. Additional trim planes can be defined
on the member itself or in relation to an edge of another object. For more
information, see Trimming Structural Members on page 2602.

Trimming a structural member with a trim plane

Creating Column Grids

When you create a column, you can attach it to a grid. You can also create a
column grid with the structural column grid tool that is included in AutoCAD
Architecture. The tool creates a grid with columns pre-anchored to nodes on
the grid. For more information, see Using Column Grid Tools to Create Column
Grids on page 2750.
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Materials in Structural Members

In AutoCAD Architecture, you can assign materials to a structural member.
These materials are displayed in wireframe and working shade views, or when
rendered. Materials have specific settings for the physical components of a
structural member.

AutoCAD Architecture provides a large number of predefined materials for all
common design purposes, which contain settings for structural members. You
can use these predefined materials, or modify them to your special designs.
You can also create your own materials from scratch.

For more information, see Specifying the Materials of a Structural Member
Style on page 2630.

Creating Columns with User-Defined Profiles

If you need a custom shape for a column which does not exist in the tool
palettes or structural member catalog of your application, you can create a
column with a user-defined linework profile. For more information, see
Creating Columns with User-Defined Profiles on page 2538.

Creating Custom Structural Members

You can use the styles from the Structural Member Catalog and Structural
Member Style wizard to create structural members for most of your design
needs. However, your project requirements may require you to create structural
members that cannot be created from a shape in the catalog or created with
the wizard. For example, you may want to create:

■ a column with a shape that tapers from start to end

■ a composite column created from a steel shape encased in a concrete shape

■ a rigid frame created from multiple tapering shapes extruded along the
path of the frame
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■ a structural member with a custom shape that cannot be created in the
catalog or with the wizard

To create custom structural members, you use the design rules within a
structural member style to extrude one or more shapes along the path of the
member. You can use shapes created in the catalog or with the wizard, or you
can create your own custom shapes.

Predefined Custom Structural Member Styles

You can access predefined styles for custom structural members from the
Member Styles and Bar Joists Styles drawings located in
C:\ProgramData\Autodesk\ACA 2012\enu\Styles\<Imperial or Metric>.

Workflow to Create Styles for Structural Members
Structural members include braces, beams, and columns as the same object is
used for all three, the orientation just differs to achieve them (diagonal,
horizontal, vertical). In addition to predefined styles of structural members,
you can also create new styles.

Review the stepsWatch the movie

Create a style on page 2533 based on a shape you
manually define or use a predefined shape.
Alternatively, if you know the type of shape and
the dimensions of the member that you want to-----

Create a style for a structural
member create, enter the information in the Structural

Member Style wizard on page 2536 to create a style.
Using styles with design rules, you can also create
complex on page 2645 custom structural members.

Create a structural member tool on page 2539 by
dragging the new style on page 876 onto a tool
palette.

-----
Create a tool that you can use to
add the structural member
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Review the stepsWatch the movie

Create on page 2553 a structural member in the
drawing with the tool you made.

-----
Add the structural member to your
building

Creating Structural Member Styles in the Structural
Member Catalog

The Structural Member Catalog contains specifications for different types and
sizes of standard structural shapes. You can browse the catalog, select a shape,
and create a structural member style that contains the selected shape. When
you create a structural member with the style, the style provides the shape of
the member.

Organization of the Structural Member Catalog

The left pane of the Structural Member Catalog contains standard structural
shapes organized in a Windows® Explorer-like tree view. Several industry
standard specifications are organized in the tree, first by imperial or metric
units, and then by material.

Structural Member Catalog

Browsing the Catalog

You can open all the levels in the tree pane under a unit and material to view
the different structural shape types available in the catalog. When you select
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a shape type in the tree view, a preview image of the shape with its dimensions
displays in the upper right pane. All the available sizes of the shape type display
in the lower right pane.

If you have a structural member in a drawing with a style created in the catalog,
you can locate the catalog shape contained in that style from the member.

Creating Structural Member Styles from Catalog Shapes

When you create a structural member style in the catalog, the dimensions of
the catalog shape that you select define and store the shape in the style.

For example, the dimensions of the steel beam selected in the previous
illustration include its depth (d), flange width (bf), flange thickness (tf), and
web thickness (tw). When you create a style, these dimensions create the
following shape that is stored in the style.

Wide-flange structural shape cross-sectional parameters

When you create a beam in your drawing with this style, the style provides
the shape of the beam. You determine the length, start and end offsets,
justification, and roll of the beam when you create the beam.

Contents of the Structural Member Catalog

When you display the Structural Member Catalog, a default catalog file,
-AecStructural.apc, provides the catalog content. This file is located in:
C:\Program Files\AutoCAD Architecture 2012\Catalogs\Structural.

In the future, additional catalog files that you can open in the catalog may
become available on the Autodesk web site, or you may create your own catalog
files.
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Opening the Structural Member Catalog
Use this procedure to open the Structural Member Catalog.

1 Click Manage tab ➤ Style & Display panel ➤  ➤ Structural

Member Catalog  .

Opening the Structural Member Catalog

2 Move and resize the Structural Member Catalog, or resize the left
and right panes within the catalog as needed to view catalog
information.

3 Click  to close the Structural Member Catalog.

Creating a Style from a Shape in the Structural Member Catalog
Use this procedure to create a structural member style from a shape that you
select in the Structural Member Catalog.

1 Click Manage tab ➤ Style & Display panel ➤  ➤ Structural

Member Catalog  .

A tree view in the left pane of the catalog lists the available shapes.

2 Expand Imperial or Metric in the tree view.

3 Expand the type of material (Concrete, Steel, or Timber) for the
structural shape that you want to create with the style.

4 Expand the shape that you want to create.
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Depending on the member, you may need to expand one or more
levels in the tree.

5 Select the shape type of the member that you want to create.

In the top right pane, a preview of the shape displays.

In the bottom right pane, a list of the available sizes of the selected
shape display. The following shapes may take a significant amount
to time to display:

■ Imperial ➤ Steel ➤ AISC ➤ HSS and Pipes ➤ HSS, Small Hollow
Structural Sections

■ Metric ➤ Steel ➤ CISC ➤ Angles ➤ L, Angle Shapes

■ Metric ➤ Steel ➤ CISC ➤ I-Shaped ➤ W, Wide Flange Shapes

■ Metric ➤ Steel ➤ CISC ➤ I-Shaped ➤ WWF, Welded Wide
Flange Shapes

■ Metric ➤ Steel ➤ CISC ➤ Structural Tees ➤ WT, Shapes

6 Under Shape Designation in the bottom right pane, select the
shape size that you want to use to create your style, right-click,
and click Generate Member Style.

7 Enter a style name, if necessary, and click OK.

The name of the shape is used as the default style name. Special
characters in the shape name, such as quotation marks, are
substituted with underscores. If you change the default style name,
you cannot use any of the following special characters in your
style name:

■ Less-than and greater-than symbols (< >)

■ Forward slashes and backslashes (/ \)

■ Quotation marks (")

■ Colons (:)

■ Semicolons (;)

■ Question marks (?)

■ Commas (,)

■ Asterisks (*)

■ Vertical bars (|)
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■ Equal signs (=)

■ Back quotes (`)

8 Continue creating structural member styles, or click  to close
the Structural Member Catalog.

You can access the style that you created in the Style Manager, create a new
structural member tool from the style, modify an existing tool to use that
style, or apply the style to an existing member.

Locating a Shape in the Structural Member Catalog from a
Structural Member in a Drawing

Use this procedure to locate a shape in the Structural Member catalog from a
shape contained in the style of a structural member in a drawing. You may
find this command useful if you created a style from a shape in the catalog
and did not name it with the same name as the catalog shape.

1 Click Manage tab ➤ Style & Display panel ➤  ➤ Structural

Member Catalog  .

2 On the Tools menu in the Structural Member Catalog, click Locate.

3 Select the structural member in the drawing that you want to
select in the catalog.

The shape that you located from the existing member is selected in the
Structural Member Catalog.

Opening a Catalog File in the Structural Member Catalog
Use this procedure to open a new catalog file in the Structural Member Catalog.

1 Click Manage tab ➤ Style & Display panel ➤  ➤ Structural

Member Catalog  .

2 Specify the location of the new catalog file:

Then…If you…

enter the full path and name of the
catalog file in the Catalog bar under

know the location and name of the
catalog file
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Then…If you…

the Structural Member Catalog
toolbar.

on the File menu in the Structural
Member Catalog, click Open. Select
a new catalog file, and click Open.

want to browse your hard disk or
server for a catalog

Creating a Structural Member Style with the Structural
Member Style Wizard

Use this procedure to create a structural member style with the Structural
Member Style wizard. You can create a structural member shape within the
style that is based on any of the 19 different shape types in the Structural
Member Catalog. The current drawing units determine the units of the style
that you create.

1 Click Manage tab ➤ Style & Display panel ➤  ➤ Structural

Member Wizard  .

2 Select the type of structural member shape that you want to create,
and click Next.

Selecting a structural member shape type

3 Enter dimensions for the shape, and click Next.
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Entering the structural member dimensions

4 Enter a name for the structural member style, and click Finish.

Entering a structural member style name

You cannot use the following special characters in your style
names:

■ Less-than and greater-than symbols (< >)

■ Forward slashes and backslashes (/ \)

■ Quotation marks (")

■ Colons (:)

■ Semicolons (;)

■ Question marks (?)

■ Commas (,)

■ Asterisks (*)
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■ Vertical bars (|)

■ Equal signs (=)

■ Back quotes (`)

You can access the style that you created in the Style Manager, create a new
structural member tool from the style, modify an existing tool to use that
style, or apply the style to an existing member.

Creating Columns with User-Defined Profiles
If you need a custom shape for a column which does not exist in the tool
palettes or structural member catalog of your application, you can create a
column with a user-defined linework profile. You can use the following closed
and non-self intersecting linework objects as column profiles:

■ circles and rectangles

■ ellipses and splines

■ closed polylines

TIP You can insert a profile definition as a polyline into the drawing and use
it as the column profile. For more information, see Converting Profiles to
Polylines on page 2864.

1 Draw the linework for the profile of the customized column.

2 Click Home tab ➤ Build panel ➤ Column drop-down  ➤ Custom
Column.

3 Select the linework.

4 Define the insertion (base) point of the column.
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5 In the Convert to Column dialog, enter a name for the column
style.

6 If you want to remove the source linework for the new style, select
Erase layout geometry.

7 Click OK.

The column is inserted into the drawing. At the same time, a new
column style is created in Style Manager.

8 Use the Properties palette to change dimension, location, and
other properties of the column instance, and use Style Manager
to change design rules, materials, and display properties for the
new style, if necessary.

Creating Structural Member Tools
You can create structural member tools and add them to tool palettes. Tool
palettes in AutoCAD Architecture let you quickly place beams, braces, and
columns by selecting a structural member tool with a specific style and other
predefined properties.

If you created structural member styles in the Structural Member Catalog or
with the Structural Member Style wizard, you can drag the styles from the
Style Manager to tool palettes and then customize the properties of the new
tools.

You can also use any of the following methods to create structural member
tools:

■ Drag a structural member that has the properties you want to a tool palette.

■ Copy an existing tool in the current palette, paste it onto the current
palette or a different palette, and then customize the properties of the new
tool.

■ Drag a tool from the Content Browser to a tool palette and then customize
the properties of the new tool.

Creating a Beam Tool
Use this procedure to create a structural beam tool and add it to a tool palette.

1 Open the tool palette on which you want to add a tool.
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2 Create the tool:

Then…If you want to…

click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from a structural
member style in the Style Manager

the style you want to copy, and
drag it to the tool palette. Click OK
to close the Style Manager.

select the beam, and drag it to the
tool palette.

create a tool from a beam in the
drawing

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another palette

open the palette where you want
to add the tool, right-click, and click
Paste.

open the Content Browser, and
locate the tool you want to copy.

copy a tool from the Content
Browser

Position the cursor over the i-drop
handle, and drag the tool to the
tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

The description displays in the tooltip when you select the tool
from the tool palette, and describes the tool if you store it in a
tool catalog in the Content Browser.

6 Expand Basic, and expand General.

7 Enter a description of the beams that you can create using this
beam tool.

8 If you do not want to use the layer assignments specified in the
layer key style used in the drawing, specify a layer key and any
layer key overrides.
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9 Select a structural member style, and select a style location, if not
the current drawing.

The style provides the shape of the beam.

10 Specify a value for Bound spaces:

Then…If you want to…

select Yes.allow the beam to be used as a
bounding object for associative
spaces

select No.prevent the beam from being used
as a bounding object for associative
spaces

select By Style.use the bounding setting from the
beam style

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

11 Specify a value for Trim automatically:

Then…If you want…

select Yes.the geometry of the beam to be
automatically trimmed to any other
structural members, other architec-
tural objects, or linework to which
it is logically connected

select No.prevent the geometry of the beam
from being trimmed automatically

select By Style.use the trim setting from the beam
style

NOTE This setting affects only the structural member being added.
Adding a new structural member will not change the geometry of
an existing structural member, regardless of the setting for Trim
automatically.

12 Expand Dimensions.
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13 Specify offsets:

Then…If you want to…

enter a value for Start offset. A pos-
itive value shortens the beam on its

offset the beam on its extruded axis
at the start point of the beam

axis, while a negative value
lengthens the beam on its axis.

enter a value for End offset. A posit-
ive value lengthens the beam on its

offset the beam on its extruded axis
at the endpoint of the beam

axis, while a negative value shortens
the beam on its axis.

14 Enter a value for Roll.

This value specifies the orientation of the beam relative to its
extruded axis in terms of degrees of roll. A positive value rolls the
beam counterclockwise when viewed from its end to its start.

15 If Layout type is Fill, and you want beams to be added to the
selected edge of a column grid, slab, roof slab, or wall at an angle
other than the default of 90 degrees, enter a value for Angle
relative to selected object.

16 Select a Layout type to specify how a beam is positioned in relation
to a highlighted edge of a column grid, slab, roof slab, or wall:

Then…If you want to position the
beam…

select Edge for Layout type.along the highlighted edge of the
object

select Fill for Layout type.within the boundaries of the object
(from one edge to an opposite
edge or edges)
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17 Specify the beam justification, which positions the beam shape
in relation to its extruded axis when you draw the beam:

Then…If you want to…

select Baseline for Justify.

NOTE This applies to members
created with styles from the
Structural Member Catalog
only.

position the axis of the beam along
the centroid of the beam shape

select one of the 9 positions for
Justify.

NOTE These positions are
defined at a roll of zero, viewing
the beam from the end to the
start.

position the axis of the beam along
one of 9 positions on the beam
shape

Justification options for a beam
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18 To specify the justification of members with multiple shapes and
segments created with this tool, select a setting for Justify using
overall extents:

Then…If you want to justify the
member…

select Yes. The justification is ap-
plied ONLY to the lowest priority

based on the largest cross-sectional
extent of the member’s lowest pri-
ority shapes shape definitions, and is calculated

based on the node (vertex) of the
member with the greatest cross
section.

select No. The justification is calcu-
lated based on the cross-sectional

at each node, based on all shapes

extents at each node, and applied
to all the shapes without regard to
priority.

For more information about members with multiple shapes and
segments, see Creating Custom Structural Members on page 2645.

19 If Layout type is Fill, and you want to array multiple beams
between two existing beams or within a column grid, slab, roof
slab, or wall, expand Layout and select Yes for Array.

20 Specify the layout method for the array:

Then…If you want to array beams…

select Space evenly for Layout
method, and enter a value for
Number of bays.

so that they create a specific num-
ber of equal-sized bays

select Repeat for Layout method,
and enter a value for Bay size.

at a specific distance from each
other

21 Click OK.

Creating a Brace Tool
Use this procedure to create a structural brace tool and add it to a tool palette.

1 Open the tool palette on which you want to add a tool.
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2 Create the tool:

Then…If you want to…

click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from a structural
member style in the Style Manager

the style you want to copy, and
drag it to the tool palette. Click OK
to close the Style Manager.

select the brace, and drag it to the
tool palette.

create a tool from a brace in the
drawing

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another palette

open the palette where you want
to add the tool, right-click, and click
Paste.

open the Content Browser, and
locate the tool you want to copy.

copy a tool from the Content
Browser

Position the cursor over the i-drop
handle, and drag the tool to the
tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

The description displays in the tooltip when you select the tool
from the tool palette, and describes the tool if you store it in a
tool catalog in the Content Browser.

6 Expand Basic, and expand General.

7 Enter a description of the braces that you can create using this
brace tool.

8 If you do not want to use the layer assignments specified in the
layer key style used in the drawing, specify a layer key and any
layer key overrides.
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9 Select a structural member style, and select a style location, if not
the current drawing.

The style provides the shape of the brace.

10 Specify a value for Bound spaces:

Then…If you want to…

select Yes.allow the brace to be used as a
bounding object for associative
spaces

select No.prevent the brace from being used
as a bounding object for associative
spaces

select By Style.use the bounding setting from the
brace style

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

11 Specify a value for Trim automatically:

Then…If you want…

select Yes.the geometry of the brace to be
automatically trimmed to any other
structural members, other architec-
tural objects, or linework to which
it is logically connected

select No.prevent the geometry of the brace
from being trimmed automatically

select By Style.use the trim setting from the brace
style

NOTE This setting affects only the structural member being added.
Adding a new structural member will not change the geometry of
an existing structural member, regardless of the setting for Trim
automatically.

12 Expand Dimensions.
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13 Specify offsets:

Then…If you want to…

enter a value for Start offset. A pos-
itive value shortens the brace on its

offset the brace on its extruded axis
at the start point of the brace

axis, while a negative value
lengthens the brace on its axis.

enter a value for End offset. A posit-
ive value lengthens the brace on its

offset the brace on its extruded axis
at the endpoint of the brace

axis, while a negative value shortens
the brace on its axis.

14 Enter a value for Roll.

This value specifies the orientation of the brace relative to its
extruded axis in terms of degrees of roll. A positive value rolls the
brace counterclockwise when viewed from its end to its start.

15 Specify the brace justification, which positions the brace shape
in relation to its extruded axis when you draw the brace:

Then…If you want to…

select Baseline for Justify.

NOTE This applies to members
created with styles from the
Structural Member Catalog
only.

position the axis of the brace along
the centroid of the brace shape

select one of the 9 positions for
Justify.

NOTE These positions are
defined at a roll of zero, viewing
the beam from the end to the
start.

position the axis of the brace along
one of 9 positions on the brace
shape
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Justification options for a brace

16 To specify the justification of braces with multiple shapes and
segments created with this tool, select a setting for Justify using
overall extents:

Then…If you want to…

select Yes. The justification is ap-
plied ONLY to the lowest priority

justify the brace based on the
largest cross-sectional extent of the
member’s lowest priority shapes shape definitions, and is calculated

based on the node (vertex) of the
member with the greatest cross
section.

select No. The justification is calcu-
lated based on the cross-sectional

justify the brace at each node,
based on all shapes

extents at each node, and is applied
to all the shapes without regard to
priority.

For more information about members with multiple shapes and
segments, see Creating Custom Structural Members on page 2645.
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17 Specify the rise, which is the vertical distance between the start
point and endpoint of the brace:

Then…If you want to…

select No for Specify Rise on Screen.
For Method, select either Angle,

specify the rise of the brace before
you draw it

Distance, or Height. If you select
Angle, enter a value for Distance
along first member (measured from
the point where the two members
are connected to the point on the
first member where you want the
brace to start) and a value for Angle
from first member. If you select
Distance, enter values for both Dis-
tance along first member and Dis-
tance along second member. If you
select Height, enter a value for Rise.

select Yes for Specify Rise on Screen.specify the rise of the brace by spe-
cifying a 3D endpoint for the end
of the brace

18 Click OK.

Creating a Column Tool
Use this procedure to create a structural column tool and add it to a tool
palette.

1 Open the tool palette on which you want to add a tool.

2 Create the tool:

Then…If you want to…

click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from a structural
member style in the Style Manager

the style you want to copy, and
drag it to the tool palette. Click OK
to close the Style Manager.
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Then…If you want to…

select the column, and drag it to
the tool palette.

create a tool from a column in the
drawing

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another palette

open the palette where you want
to add the tool, right-click, and click
Paste.

open the Content Browser, and
locate the tool you want to copy.

copy a tool from the Content
Browser

Position the cursor over the i-drop
handle, and drag the tool to the
tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

The description displays in the tooltip when you select the tool
from the tool palette, and describes the tool if you store it in a
tool catalog in the Content Browser.

6 Expand Basic, and expand General.

7 Enter a description of the columns that you can create using this
column tool.

8 If you do not want to use the layer assignments specified in the
layer key style used in the drawing, specify a layer key and any
layer key overrides.

9 Select a structural member style, and select a style location, if not
the current drawing.

The style provides the shape of the column.
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10 Specify a value for Bound spaces:

Then…If you want to…

select Yes.allow the column to be used as a
bounding object for associative
spaces

select No.prevent the column from being
used as a bounding object for asso-
ciative spaces

select By Style.use the bounding setting from the
column style

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

11 Specify a value for Trim automatically:

Then…If you want…

select Yes.the geometry of the column to be
automatically trimmed to any other
structural members, other architec-
tural objects, or linework to which
it is logically connected

select No.prevent the geometry of the
column from being trimmed auto-
matically

select By Style.use the trim setting from the
column style

NOTE This setting affects only the structural member being added.
Adding a new structural member will not change the geometry of
an existing structural member, regardless of the setting for Trim
automatically.

12 Expand Dimensions.
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13 Specify offsets:

Then…If you want to…

enter a value for Start offset. A pos-
itive value shortens the column on

offset the column on its extruded
axis at the start point of the column

its axis, while a negative value
lengthens the column on its axis.

enter a value for End offset. A posit-
ive value lengthens the column on

offset the column on its extruded
axis at the endpoint of the column

its axis, while a negative value
shortens the column on its axis.

14 Specify the roll of the column (how it is oriented relative to its
extruded axis):

Then…If you want to…

select No for Specify on Screen, and
enter a value for Roll.

specify the roll of the column before
you insert it

select Yes for Specify on Screen.specify the roll of the column when
you insert it

This value specifies the orientation of the column relative to its
extruded axis in terms of degrees of roll. A positive value rolls the
column counterclockwise when viewed from the end (top) to the
start (bottom) of the column.

15 Specify the column justification, which positions the column
shape in relation to its extruded axis when you draw the column:

Then…If you want to…

select Baseline for Justify.

NOTE This applies to members
created with styles from the
Structural Member Catalog
only.

position the axis of the column
along the centroid of the column
shape
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Then…If you want to…

select one of the 9 positions for
Justify.

NOTE These positions are
defined at a roll of zero, viewing
the column from the top to the
bottom.

position the axis of the column
along one of 9 positions on the
column shape

16 To specify the justification of members with multiple shapes and
segments created with this tool, select a setting for Justify using
overall extents:

Then…If you want to…

select Yes. The justification is ap-
plied ONLY to the lowest priority

justify the member based on the
largest cross-sectional extent of the
member’s lowest priority shapes shape definitions, and is calculated

based on the node (vertex) of the
member with the greatest cross
section.

select No. The justification is calcu-
lated based on the cross-sectional

justify the member at each node,
based on all shapes.

extents at each node, and is applied
to all the shapes without regard to
priority.

For more information about members with multiple shapes and
segments, see Creating Custom Structural Members on page 2645.

17 Click OK.

Using Structural Member Tools to Create Structural
Members

Tool palettes in AutoCAD Architecture let you quickly place beams, braces,
and columns by selecting a structural member tool with a specific style and
other predefined properties. You can also use structural member tools to
convert linework to structural members and to apply the settings of a structural
member tool to existing structural members.
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Custom palettes created by you or your CAD manager may contain structural
member tools from styles created in the Structural Member Catalog or
Structural Member Style wizard. These palettes may be customized for your
projects or office standards.

The default tool palettes in the workspace contain sample structural member
tools that you can use and customize as needed. In addition, the following
catalogs provided with the software contain structural member tools that you
can add to your tool palettes:

■ Stock Tool catalog

■ Sample Palette catalog

■ My Tool catalog

When you create structural members using structural member tools, you can
use the default settings of the tool, or you can specify settings for any structural
member properties that are not controlled by the style.

IMPORTANT Columns grids that have numerous columns attached to them can
take longer than expected to display on screen. This is because structural members
carry additional information that may be used for structural analysis.

Creating a Beam
Use this procedure to add one or more new beams that have the property
settings specified in the structural beam tool that you select. You can add a
beam anywhere in the drawing area by specifying a start point and an
endpoint, or you can position and size a beam in relation to an edge of an
existing object. The style specified in the tool provides the beam shape, which
is extruded along the path you define in the drawing area.

To specify settings when you add a beam, see Creating Beams with
User-Specified Settings on page 2556.

Creating a beam
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1 Open the tool palette that contains the structural beam tool you
want to use, and select the tool.

TIP You may have to scroll to display the desired tool. After selecting
it, you can move or hide the Properties palette to expose more of the
drawing area.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Column

Grid drop-down ➤ Beam  .

2 If you want to offset the new beam(s) from the elevation of the
current level, double-click the Elevation value on the application
status bar at the bottom of the workspace, enter an elevation value
(or specify a point on an existing object in the drawing area), click
OK, and then click the Z-snap button to the right of the Elevation
Value.

3 Position the new beam(s) in the drawing area:

Then…If you want to…

specify a start point and an end-
point for the beam, and then press
ENTER.

create a single beam independent
of other objects

specify a start point and an end-
point, and then specify additional

create multiple beams independent
of other objects but connected to

endpoints as required. Press ENTER
to end the command.

each other using the endpoint of
one beam as the start point of the
next beam

specify a start point and an end-
point, one of which must be on the

create a beam that is connected to
an existing structural member

axis or the endpoint of the existing
member. Press ENTER to end the
command.

move the cursor over an edge of
the object to display a preview of

add beams along one or more
edges of a slab, roof slab, or wall

the beam, and then click to add a
beam along that edge, or press Ctrl
and click to add beams along all
edges of the object. Press ENTER to
end the command.
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Then…If you want to…

move the cursor over a segment of
the grid to display a preview of the

add beams along one or more seg-
ments of a column grid

beam, and then click to add a beam
along that segment; or press Ctrl
and click to add beams along all
segments in that grid line; or press
Ctrl twice and click to add beams
along all segments in the grid. Press
ENTER to end the command.

NOTE If you want to add a beam that spans an object from edge to
edge rather than lying along one of its edges, you can change the
Layout type setting from Edge to Fill on the Properties palette. For
more information on property settings for beam tools, see Creating
Beams with User-Specified Settings on page 2556.

Creating Beams with User-Specified Settings
Use this procedure to add one or more new beams with property settings that
you specify. You can add a beam anywhere in the drawing area by specifying
a start point and an endpoint, or you can position and size a beam in relation
to an existing object. You can also create multiple beams, either one at a time
(connected endpoint to start point) or arrayed within boundaries defined by
other beams or by column grids, slabs, roof slabs, or walls. The style specified
in the tool provides the beam shape, which is extruded along the paths you
define in the drawing area.

Creating a beam

Optionally, offset the beam from its start point or endpoint.
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Offsetting a beam

1 Open the tool palette that contains the structural beam tool you
want to use, and select the tool.

(You may have to scroll to display the desired tool).

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Column

Grid drop-down ➤ Beam  .

2 On the Properties palette, under General, click Style, and select a
structural beam style.

3 Specify a value for Bound spaces:

Then…If you want to…

select Yes.allow the beam to be used as a
bounding object for associative
spaces

select No.prevent the beam from being used
as a bounding object for associative
spaces

select By Style.use the bounding setting from the
beam style

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

4 Specify a value for Trim automatically:

Then…If you want…

select Yes.the geometry of the beam to be
automatically trimmed to any other
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Then…If you want…

structural members, other architec-
tural objects, or linework to which
it is logically connected

select No.prevent the geometry of the beam
from being trimmed automatically

select By Style.use the trim setting from the beam
style

NOTE This setting affects only the structural member being added.
Adding a new structural member will not change the geometry of
an existing structural member, regardless of the setting for Trim
automatically.

5 Specify a value for On object:

Then…If you want…

select Yes.layout structural members on a
column grid, slab, wall, or polyline

select No.layout structural members independ-
ent from a column grid, slab, wall,
or polyline

NOTE On object is an Add Only property. You may not specify a
value for On object when editing a structural member.

6 Expand Dimensions.

7 Specify offsets:

Then…If you want to…

enter a value for Start offset. A pos-
itive value shortens the beam on its

offset the beam on its extruded axis
at the start point of the beam

axis, while a negative value
lengthens the beam on its axis.

enter a value for End offset. A posit-
ive value lengthens the beam on its

offset the beam on its extruded axis
at the endpoint of the beam
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Then…If you want to…

axis, while a negative value shortens
the beam on its axis.

8 Enter a value for Roll.

This value specifies the orientation of the beam relative to its
extruded axis in terms of degrees of roll. A positive value rolls the
beam counterclockwise when viewed from its end to its start.

9 Specify the beam justification, which positions the beam shape
in relation to its extruded axis when you draw the beam:

Then…If you want to…

select Baseline for Justify.

NOTE This applies to members
created with styles from the
Structural Member Catalog
only.

position the axis of the beam along
the centroid of the beam shape

select one of the 9 positions for
Justify.

NOTE These positions are
defined at a roll of zero, viewing
the beam from the end to the
start.

position the axis of the beam along
one of 9 positions on the beam
shape
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Justification options for a beam

10 Select a Layout type to specify how a beam is positioned in relation
to a highlighted edge of a column grid, slab, roof slab, or wall:

Then…If you want to position the
beam…

select Edge for Layout type.along the highlighted edge of the
object

select Fill for Layout type.within the boundaries of the object
(from one edge to an opposite
edge or edges)
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11 If Layout type is Fill, and you want to array multiple beams
between 2 existing beams or within a column grid, slab, roof slab,
or wall, expand Layout and select Yes for Array.

12 Specify the layout method for the array:

Then…If you want to array beams…

select Space evenly for Layout
method, and enter a value for
Number of bays.

so that they create a specific num-
ber of equal-sized bays

select Repeat for Layout method,
and enter a value for Bay size.

at a specific distance from each
other

TIP After specifying the desired settings, you can move or hide the
Properties palette to expose more of the drawing area.

13 If you want to offset the new beams from the elevation of the
current level, double-click the Elevation value on the application
status bar at the bottom of the workspace, enter an elevation value
(or specify a point on an existing object in the drawing area), click
OK, and then click the Z-snap button to the right of the Elevation
value.

Adding a beam to a single segment
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Adding beams to one grid line

Adding beams to all grid lines

Adding a beam to a specified point
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Adding a beam array to a single cell

Adding a beam array to all cells

14 Position the new beams in the drawing area:

Then…If you want to…

specify a start point and an end-
point for the beam, and then press
ENTER.

create a single beam independent
of other objects

specify a start point and an end-
point, and then specify additional

create multiple beams independent
of other objects but connected to

endpoints as required. Press ENTER
to end the command.

each other using the endpoint of
one beam as the start point of the
next beam

specify a start point and an end-
point, one of which must be on the

create a beam that is connected to
an existing structural member

axis or the endpoint of the existing

Creating Beams with User-Specified Settings | 2563



Then…If you want to…

member. Press ENTER to end the
command.

move the cursor over an edge of
the object until a preview of the

add a beam along one or more
edges of a slab, roof slab, or wall
(assuming Layout type is Edge) beam is displayed, and then click

to add a beam along that edge, or
press Ctrl and click to add beams
along all edges of the object. Press
ENTER to end the command.

move the cursor over a segment of
the grid until a preview of the beam

add a beam along one or more
segments of a column grid (assum-
ing Layout type is Edge) is displayed, and then click to add

a beam along that segment; or
press Ctrl and click to add beams
along all segments in that grid line;
or press Ctrl twice and click to add
beams along all segments in the
grid. Press ENTER to end the com-
mand.

move the cursor over the object
edge or column grid segment until

add a beam that spans a slab, roof
slab, wall, or column grid cell from

a preview of the beam is displayededge to edge at an angle of 90 de-
grees (assuming Layout type is Fill) in the desired position perpendicu-

lar to the edge/segment, and then
click. Press ENTER to end the com-
mand.

move the cursor over the object
edge or column grid segment until

add a beam that spans a slab, roof
slab, wall, or column grid cell from

a preview of the beam is displayed,edge to edge at an angle other than
enter a value for the desired angle,90 degrees (assuming Layout type

is Fill) press ENTER, and then click. Press
ENTER to end the command.

move the cursor over one of the
structural members until its baseline

array beams between 2 structural
members (assuming Array is Yes)

is displayed, click that member,
specify a point on the second
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Then…If you want to…

member, and press ENTER. New
beams are arrayed according to the
Layout Method selected on the
Properties palette and at an angle
determined by the point you specify
on the second member. Press
ENTER to end the command.

move the cursor over an edge until
a preview of the array is displayed,

array beams perpendicularly within
a slab, roof slab, wall, or one or

and click. New beams are arrayedmore cells of a column grid (assum-
ing Array is Yes) perpendicular to the selected edge

according to the Layout Method
selected on the Properties palette.
If you want to add the array to all
cells of a column grid, press Ctrl
before clicking. Press ENTER to end
the command.

move the cursor over an edge until
a preview of the array is displayed,

array beams at an angle other than
90 degrees within a slab, roof slab,

enter a value for the desired angle,wall, or one or more cells of a
column grid (assuming Array is Yes) press ENTER, and then click. New

beams are arrayed at the specified
angle according to the Layout
Method selected on the Properties
palette. If you want to add the array
to all cells of a column grid, press
Ctrl before clicking. Press ENTER to
end the command.

Creating a Brace
Use this procedure to add a new brace that has the properties specified in the
structural brace tool that you select. The style specified in the tool provides
the brace shape, which is extruded along the path you define by specifying a
start point and an endpoint.

To specify your own settings when you add a brace, see Creating a Brace with
User-Specified Settings on page 2566.
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Creating a brace

1 Open the tool palette that contains the structural brace tool you
want to use, and select the tool.

TIP You may have to scroll to display the desired tool. After selecting
it, you can move or hide the Properties palette to expose more of the
drawing area.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Column

Grid drop-down ➤ Brace  .

2 Specify the start point of the brace.

3 Specify an endpoint:

Then…If you want to…

specify the endpoint of the brace,
and press ENTER.

create a single brace

continue to specify brace start
points and endpoints, and press
ENTER.

create additional braces

Creating a Brace with User-Specified Settings
Use this procedure to add a new brace with property settings that you specify.
The style specified in the tool provides the brace shape, which is extruded
along the path you define by specifying a start point and an endpoint.
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Creating a brace

Optionally, offset the brace from its start point or endpoint.

Offsetting a brace

1 Open the tool palette that contains the structural brace tool you
want to use, and select the tool.

(You may have to scroll to display the desired tool).

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Column

Grid drop-down ➤ Brace  .

2 On the Properties palette, under General, click Style, and select a
structural brace style.
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3 Specify a value for Bound spaces:

Then…If you want to…

select Yes.allow the brace to be used as a
bounding object for associative
spaces

select No.prevent the brace from being used
as a bounding object for associative
spaces

select By Style.use the bounding setting from the
brace style

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

4 Specify a value for Trim automatically:

Then…If you want…

select Yes.the geometry of the brace to be
automatically trimmed to any other
structural members, other architec-
tural objects, or linework to which
it is logically connected

select No.prevent the geometry of the brace
from being trimmed automatically

select By Style.use the trim setting from the brace
style

NOTE This setting affects only the structural member being added.
Adding a new structural member will not change the geometry of
an existing structural member, regardless of the setting for Trim
automatically.

5 Expand Dimensions.
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6 Specify offsets:

Then…If you want to…

enter a value for Start offset. A pos-
itive value shortens the brace on its

offset the brace on its extruded axis
at the start point of the brace

axis, while a negative value
lengthens the brace on its axis.

enter a value for End offset. A posit-
ive value lengthens the brace on its

offset the brace on its extruded axis
at the endpoint of the brace

axis, while a negative value shortens
the brace on its axis.

7 Enter a value for Roll.

This value specifies the orientation of the brace relative to its
extruded axis in terms of degrees of roll. A positive value rolls the
brace counterclockwise when viewed from its end to its start.

8 Specify the brace justification, which positions the brace shape
in relation to its extruded axis when you draw the brace:

Then…If you want to…

select Baseline for Justify.

NOTE This applies to members
created with styles from the
Structural Member Catalog
only.

position the axis of the brace along
the centroid of the brace shape

select one of the 9 positions for
Justify.

NOTE These positions are
defined at a roll of zero, viewing
the beam from the end to the
start.

position the axis of the brace along
one of 9 positions on the brace
shape
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Justification options for a brace

9 Specify the rise, which is the vertical distance between the start
point and endpoint of the brace:

Then…If you want to…

select No for Specify rise on screen. For
Method, select either Angle, Distance,

specify the rise of the brace be-
fore you draw it

or Height. If you select Angle, enter a
value for Distance along first member
(measured from the point where the
two members are connected to the
point on the first member where you
want the brace to start) and a value
for Angle from first member. If you se-
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Then…If you want to…

lect Distance, enter values for both
Distance along first member and Dis-
tance along second member. If you
select Height, enter a value for Rise.

select Yes for Specify Rise on Screen.specify the rise of the brace by
specifying a 3D endpoint for the
end of the brace.

TIP After specifying the desired settings, you can move or hide the
Properties palette to expose more of the drawing area.

10 In the drawing area, specify the start point of the brace.

11 Specify an endpoint for the brace:

■ If you entered a value for Rise in step 9, then the endpoint of
the brace is the X and Y coordinates of the endpoint that you
selected. The Z coordinate equals the Z coordinate of the start
point plus the value for the rise.

■ If you selected Specify rise on screen in step 9, the endpoint
of the brace is the 3D point that you selected.

12 Continue adding braces, and press ENTER.

Creating a Freestanding Column
Use this procedure to add a new freestanding column that has the property
settings specified in the structural column tool that you select. The style
specified in the tool provides the column shape. When you specify an insert
point for the column, the shape is extruded in a positive direction along the
current UCS Z-axis to a height determined by the Start offset, End offset, and
Logical length properties of the tool.

To specify settings when you add a column, see Creating a Freestanding
Column with User-Specified Settings on page 2572.
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Creating a column

1 Open the tool palette that contains the structural column tool
you want to use, and select the tool.

TIP You may have to scroll to display the desired tool. After selecting
it, you can move or hide the Properties palette to expose more of the
drawing area.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Column

Grid drop-down ➤ Column  .

2 Specify the insert point for the column.

3 If the Properties palette value for Specify roll on screen is Yes,
move the cursor to roll the column around its extruded axis as
desired, and then click; or enter a value for the roll angle, and
press ENTER.

A positive value rolls the column counterclockwise around its
extruded axis when viewed from its end (top) to its start (bottom).

4 Specify an insert point for another column, or press ENTER to end
the command.

Creating a Freestanding Column with User-Specified Settings
Use this procedure to create a new freestanding column with property settings
that you specify. The style specified in the tool provides the column shape.
When you specify an insert point for the column, the shape is extruded in a
positive direction along the current UCS Z-axis to a height determined by the
Start offset, End offset, and Logical length properties you specify.
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Creating a free-standing column

Optionally, offset the column from its start point or endpoint.

Offsetting a column

1 Open the tool palette that contains the structural column tool
you want to use, and select the tool.

(You may have to scroll to display the desired tool).

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Column

Grid drop-down ➤ Column  .

2 On the Properties palette, under General, click Style, and select a
structural column style.
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3 Specify a value for Bound spaces:

Then…If you want to…

select Yes.allow the column to be used as a
bounding object for associative
spaces

select No.prevent the column from being
used as a bounding object for asso-
ciative spaces

select By Style.use the bounding setting from the
column style

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

4 Specify a value for Trim automatically:

Then…If you want…

select Yes.the geometry of the column to be
automatically trimmed to any other
structural members, other architec-
tural objects, or linework to which
it is logically connected

select No.prevent the geometry of the
column from being trimmed auto-
matically

select By Style.use the trim setting from the
column style

NOTE This setting affects only the structural member being added.
Adding a new structural member will not change the geometry of
an existing structural member, regardless of the setting for Trim
automatically.

5 Expand Dimensions.
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6 Specify offsets:

Then…If you want to…

enter a value for Start offset. A pos-
itive value shortens the column on

offset the column on its extruded
axis at the start point of the column

its axis, while a negative value
lengthens the column on its axis.

enter a value for End offset. A neg-
ative value lengthens the column

offset the column on its extruded
axis at the endpoint of the column

on its axis, while a positive value
shortens the column on its axis.

7 Enter a value for Logical length.

The logical length of the column is the length (height) of the
column before offsets are applied.

8 Select Yes or No for Specify roll on screen:

Then…If you want to…

select No for Specify Roll on Screen,
and enter a value for Roll.

specify the roll of the column before
you insert it

select Yes for Specify Roll on Screen,
and specify the roll as explained in
step 10.

specify the roll of the column when
you insert it

A positive value rolls the column counterclockwise around its
extruded axis when viewed from its end (top) to its start (bottom).

9 Specify the column justification, which positions the column
shape in relation to its extruded axis when you draw the column:

Then…If you want to…

select Baseline for Justify.

NOTE This applies to members
created with styles from the
Structural Member Catalog
only.

position the extruded axis of the
column at the centroid of the
column shape
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Then…If you want to…

select one of the 9 positions for
Justify.

NOTE These positions are
defined at a roll of zero, viewing
the column from the top to the
bottom.

position the extruded axis of the
column along one of 9 positions on
the column shape

TIP After specifying the desired settings, you can move or hide the
Properties palette to expose more of the drawing area.

10 In the drawing area, specify the insert point for the column.

11 If you selected Yes for Specify roll on screen, move the cursor to
roll the column around its extruded axis as desired, and then click;
or enter a value for degrees of roll, and press ENTER.

12 Specify an insert point for another column, or press ENTER to end
the command.

Creating Columns with User-Defined Profiles
If you need a custom shape for a column which does not exist in the tool
palettes or structural member catalog of your application, you can create a
column with a user-defined linework profile. You can use the following closed
and non-self intersecting linework objects as column profiles:

■ circles and rectangles

■ ellipses and splines

■ closed polylines

TIP You can insert a profile definition as a polyline into the drawing and use
it as the column profile. For more information, see Converting Profiles to
Polylines on page 2864.
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1 Draw the linework for the profile of the customized column.

2 Click Home tab ➤ Build panel ➤ Column Grid
drop-down ➤ Custom Column .

3 Select the linework.

4 Define the insertion (base) point of the column.

5 In the Convert to Column dialog, enter a name for the column
style.

6 If you want to remove the source linework for the new style, select
Erase layout geometry.

7 Click OK.

The column is inserted into the drawing. At the same time, a new
column style is created in Style Manager.

8 Use the Properties palette to change dimension, location, and
other properties of the column instance, and use Style Manager
to change design rules, materials, and display properties for the
new style, if necessary.

Creating Grid-Anchored Columns
Use this procedure to create a column that is anchored to a grid and has the
property settings specified in the structural column tool that you select. The
style specified in the tool provides the column shape. When you specify an
insert point on the grid, the shape is extruded in a positive direction along
the current UCS Z-axis to a height determined by the Start offset, End offset,
and Logical length properties of the tool. To specify your own settings when
you anchor a column to a grid, see Creating Grid-Anchored Columns with
User-Specified Settings on page 2579.

To create a column grid with pre-anchored columns, see Creating a Column
Grid on page 2752.
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Creating a column grid with specified column shapes

1 Open the tool palette that contains the structural column tool
you want to use, and select the tool.

TIP You may have to scroll to display the desired tool. After selecting
it, you can move or hide the Properties palette to expose more of the
drawing area.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Column

Grid drop-down ➤ Column  .

2 Move the cursor over the grid so that the grid is highlighted and
the list of column-add options is displayed. (You press Ctrl to cycle
through the options.)

3 Specify the insert point for the column on the grid.

Then…If you want to…

move the cursor over the node (or
near it), and click. A column is ad-

add a column at a particular node
in the grid
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Then…If you want to…

ded to the node nearest to the
cursor position.

press Ctrl, and click.add a column to all nodes in the
grid

press Ctrl twice, move the cursor to
the point where you want to add

add a column at a particular point
on or within the grid

the column, and click. If the Proper-
ties palette value for Specify roll on
screen is Yes, move the cursor to
roll the column around its extruded
axis as desired, and then click; or
enter a value for the roll angle, and
press ENTER.
A positive value rolls the column
counterclockwise around its ex-
truded axis when viewed from its
end (top) to its start (bottom).

4 When you are finished adding columns to the grid, press ENTER
to end the command.

IMPORTANT Column grids that have numerous columns attached
to them can take longer than expected to display on screen. This is
because structural members carry additional information that may
be used for structural analysis.

Creating Grid-Anchored Columns with User-Specified Settings
Use this procedure to anchor a column to a grid as you create it, with property
settings that you specify. The style specified in the tool provides the column
shape. When you specify an insert point on the grid, the shape is extruded in
a positive direction along the current UCS Z-axis to a height determined by
the Start offset, End offset, and Logical length properties of the tool.

To create a column grid with pre-anchored columns, see Creating a Column
Grid on page 2752.
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Add a column to a single node of a column grid

Add columns to all nodes of a column grid

Add a column to a single point on a column grid

1 Open the tool palette that contains the structural column tool
you want to use, and select the tool.

(You may have to scroll to display the desired tool).

2580 | Chapter 32   Structural Members



NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Column

Grid drop-down ➤ Column  .

2 Select the grid.

3 On the Properties palette, under General, click Style, and select a
structural column style.

4 Specify a value for Bound spaces:

Then…If you want to…

select Yes.allow the column to be used as a
bounding object for associative
spaces

select No.prevent the column from being
used as a bounding object for asso-
ciative spaces

select By Style.use the bounding setting from the
column style

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

5 Specify a value for Trim automatically:

Then…If you want…

select Yes.the geometry of the column to be
automatically trimmed to any other
structural members, other architec-
tural objects, or linework to which
it is logically connected

select No.prevent the geometry of the
column from being trimmed auto-
matically

select By Style.use the trim setting from the
column style
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NOTE This setting affects only the structural member being added.
Adding a new structural member will not change the geometry of
an existing structural member, regardless of the setting for Trim
automatically.

6 Expand Dimensions.

7 Specify offsets:

Then…If you want to…

enter a value for Start offset. A pos-
itive value shortens the column on

offset the column on its extruded
axis at the start point of the column

its axis, while a negative value
lengthens the column on its axis.

enter a value for End offset. A neg-
ative value lengthens the column

offset the column on its extruded
axis at the endpoint of the column

on its axis, while a positive value
shortens the column on its axis.

8 Enter a value for Logical length.

The logical length of the column is the length (height) of the
column before offsets are applied.

9 Select Yes or No for Specify roll on screen:

Then…If you want to…

select No for Specify Roll on Screen,
and enter a value for Roll.

specify the roll of the column before
you insert it

select Yes for Specify Roll on Screen,
and specify the roll as explained in
step 12.

specify the roll of the column when
you insert it

A positive value rolls the column counterclockwise around its
extruded axis when viewed from its end (top) to its start (bottom).
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10 Specify the column justification, which positions the column
shape in relation to its extruded axis when you draw the column:

Then…If you want to…

select Baseline for Justify.

NOTE This applies to members
created with styles from the
Structural Member Catalog
only.

position the axis of the column
along the centroid of the column
shape

select one of the 9 positions for
Justify.

position the axis of the column
along one of 9 positions on the
column shape

TIP After specifying the desired settings, you can move or hide the
Properties palette to expose more of the drawing area.

11 Move the cursor over the grid so that the grid is highlighted and
the list of column-add options is displayed. (You press Ctrl to cycle
through the options.)

12 Specify the insert point for the column on the grid.

Then…If you want to…

move the cursor over the node (or
near it), and click. A column is ad-

add a column at a particular node
in the grid

ded to the node nearest to the
cursor position.

press Ctrl, and click.add a column to all nodes in the
grid

press Ctrl twice, move the cursor to
the point where you want to add

add a column at a particular point
on or within the grid

the column, and click. If the Proper-
ties palette value for Specify roll on
screen is Yes, move the cursor to
roll the column around its extruded
axis as desired, and then click; or
enter a value for the roll angle, and
press ENTER.
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Then…If you want to…

A positive value rolls the column
counterclockwise around its ex-
truded axis when viewed from its
end (top) to its start (bottom).

13 When you are finished adding columns to the grid, press enter to
end the command.

NOTE Column grids that have numerous columns attached to them
can take longer than expected to display on screen. This is because
structural members carry additional information that may be used
for structural analysis.

Creating a Structural Member from Linework
Use this procedure to convert any of the following objects to structural
members with structural member tools:

■ Arcs

■ Lines

■ Open polylines

■ Open polylines with arc segments

NOTE Converting an arc to a structural member is the only method of creating
a curved structural member. For more information about curved structural
members, see About Curved Structural Members on page 2598.

When you use a tool to convert linework to a structural member, the style
specified in the tool provides the shape of the member. The linework defines
the extrusion path for the shape. You can convert multiple lines to create
multiple members, convert curved lines to create curved members, and convert
multi-segmented lines to create multi-segmented members.

1 Open the tool palette that contains the structural member tool
you want to use.

(You may have to scroll to display the desired tool).
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2 Right-click a structural member tool, and click Apply Tool
Properties to  ➤ Linework.

3 Select the linework to convert, and press ENTER.

NOTE You cannot convert a closed polyline (a polyline with a start
node that coincides with its end node) to a structural member.

A worksheet opens appropriate to the tool you selected.

4 Clear One Member Per Polyline Segment to create a structural
member for each segment.

5 Select Erase Layout Geometry to erase the linework, and click OK.

If you created a structural member by converting a polyline, the
initial orientation of the structural member is set to the UCS that
was current when you drew the polyline. You can change the
orientation by adjusting the Roll property of the member.

Editing Structural Members
After you create a structural member, you can change any properties of the
member that you specified when you created it and make additional
modifications. You can change the start and end offsets of a member, or add
or remove them. You can change the length, justification, and location of a
member, specifying whether its connections with other structural members
are maintained. For a curved structural member, you can change the radius.

You can change the geometry of a structural member by trimming it. By
changing the structural member type, you can change a brace to beam, or a
column to a brace. By changing the style of a structural member, you can
change its shape.

AutoCAD Architecture offers several methods for editing structural members:

■ You can directly edit structural members using grips for dimensions and
other physical characteristics.
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■ For grip edit operations where you are changing a dimension or an angle,
the Dynamic Input feature lets you enter a precise value instead of moving
a grip. When this feature is active (click DYN on the application status
bar), selecting a grip displays a text box in which you can enter the desired
value for the associated dimension or angle. For more information, see
“Use Dynamic Input” in AutoCAD Help.

■ You can change structural member settings on the Properties palette. You
can also use the Display tab of the Properties palette to change the display
property settings for a selected object display component in the current
display representation. For more information, see Using the Properties
Palette to Change Display Properties on page 793.

■ You can use the tools available on the Modify panel of the Structural
Member tab.

■ You can select editing commands from the context menu for a selected
structural member.

Using Grips To Edit Structural Members
Refer to the illustrations and steps in this topic to use grips to edit structural
members.

NOTE If the value of Trim automatically (on the Properties palette) is Yes for each
of 2 connected structural members, then any kind of grip edit to either member
will result in a mitered joint between them.

Editing Structural Member Dimensions

1 Select the structural member.

2 Select the grip for the dimension you want to change.
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Grips for length, start offset, and end offset of a straight beam or brace

Grips for length, start offset, and end offset of a straight column

Grips for start and end angles, radius, and start and end offsets of a curved beam or
brace
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Grips for start and end angles, radius, and start and end offsets of a curved column

3 Move the grip until the dimension value you want is displayed,
and click once; or enter a value.

Changing the Location of a Structural Member

1 Select the structural member.

Select the Location grip to change the location of the structural
member, or the Roll grip to change its roll (the rotation of the
member around its extruded axis).

Location and roll grips for a straight beam or brace
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Location and roll grips for a straight column

Location and roll grips for a curved beam or brace
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Location and roll grips for a curved column

In Model view, the Location grip has six edit options you can
cycle through by pressing CTRL. For each plane in which you can
move the member (XY, YZ, or XZ), you have the option of
maintaining or breaking connections with other structural
members.

When you choose to maintain connections, all connections are
not necessarily maintained for every type of move. Maintenance
of connections depends on whether the move is in or out of plane,
how the members are connected, and which type of members are
involved. Generally, columns take precedence over beams and
braces in determining how connected members behave when one
is moved. This behavior is summarized in the following table:

Then …If you spe-
cify Main-
tain Connec-
tions when
moving …

other columns, beams, and braces connected to an end-
point of the column will also move, changing length and

a column

orientation as necessary to maintain the connection. (This
is also true for any other members connected along the
length of a member that is endpoint-connected to the
column.) Structural members connected along the length
of the column will only extend or shorten to remain
connected; they will not change orientation unless the
column is moved out of plane. For example, if a column
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Then …If you spe-
cify Main-
tain Connec-
tions when
moving …

is moved in the XY plane, beams or braces connected
along its length will stay connected, even though their
orientation changes.

other beams and braces connected to an endpoint of the
beam or brace will also move, changing length and ori-

a beam or a
brace

entation as necessary to maintain the connection. Struc-
tural members connected along the length of the beam
or brace will only extend or shorten to remain connected;
they will not change orientation unless the beam is moved
out of plane. For example, if a ridge beam is moved ver-
tically, rafters connected along its length will stay connec-
ted, even though their orientation changes.

The default edit mode is to maintain connections for moves along
the XY plane. In Plan view, the Location grip is restricted to
movement in one plane, but you still have the option to maintain
or break connections.

2 Move the grip until the dimension value you want is displayed,
and click once; or enter a value and press ENTER.

If you want to enter a specific value for the second direction in
any edit mode (for example, in the Y direction when editing along
the XY plane), press TAB to cycle to the second direction.

You can also lock the movement of the structural member along
a specific direction. If you enter a value for either of the dimension
directions in the current edit mode and then press TAB, the
movement of the structural member is constrained to the second
dimension direction. When editing along the XY plane, for
example, you can enter a value for X dimension, and then press
TAB. The X dimension is locked at that value, and movement of
the structural member is constrained to the Y dimension direction.

3 Right-click, and click Deselect All to turn off grips.
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NOTE When you shift-select the Location grips of end-connected
beams, the common endpoint moves approximately twice as far as
the grip you move. In the example shown below, if you shift-select
the two vertical beams in the structure on the left, and then move a
grip toward the right, the result is a configuration like the one at the
top right. To get a configuration like the one at the bottom right,
you would select all five beams using a crossing selection or a crossing
polygon, and then use the Stretch command. (For more information,
see “STRETCH Command” and “SELECT Command” in AutoCAD
Help.) Beams may also move twice as far as you might expect when
they are attached to columns on a column grid, and the grid,
columns, and beams are all selected. If you select and move only the
grid, the columns and beams will move with it, maintaining their
same relative positions. For instructions on selecting one object when
other objects are superimposed on it, see “Select Objects Individually”
in AutoCAD Help.

Changing the Structural Member Length
Use this procedure to change the length of a structural member. You can also
change the structural member length on the Properties palette.

1 Select the structural member.
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2 Select a Lengthen grip, move the grip until the length value you
want is displayed, and click once.

Changing the length of a beam structural member with grips

After selecting a grip, you can also enter a value to increase or
decrease the length of the structural member.

Changing the Structural Member Start and End Offsets
Use this procedure to offset a structural member from the start point or
endpoint of its path. You can remove or change existing offsets, or add new
offsets to the start point or endpoint of a structural member. You can also
change the structural member start and end offsets on the Properties palette.
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1 Select the structural member.

2 Select a Start Offset grip, move the grip until the start offset value
you want is displayed, and click once.

A positive start offset value shortens the member on its axis (path),
while a negative start offset value lengthens the member on its
axis.

Change the end offset of a beam structural member with grips

3 Select an End Offset grip, move the grip until the end offset value
you want is displayed, and click once.

A positive end offset lengthens the member on its axis, while a
negative end offset shortens the member on its axis.

After selecting a grip, you can also enter a value to increase or
decrease the start or end offset of the structural member.
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Changing the Structural Member Start Point and Endpoint
Use this procedure to change a structural member start point or endpoint.
You can also change the structural member start and endpoints on the
Properties palette.

1 Select the structural member.

2 Select a Start or End grip, move the grip until the length value
you want is displayed, and click once.

Moving the Start grip in the positive direction shortens the
member on its axis (path), while moving the Start grip in the
negative direction lengthens the member on its axis.

Moving the End grip in the positive direction lengthens the
member on its axis (path), while moving the End grip in the
negative direction shortens the member on its axis.
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Change the end of a beam structural member with grips

3 Select a Start or End grip, move the grip until the length value
you want is displayed, and click once.

After selecting a grip, you can also enter a value to increase or
decrease the length of the structural member.

Changing the Structural Member Roll
Use this procedure to change the orientation of a structural member relative
to its extruded axis by specifying a number of degrees to roll it. A positive
value rolls the member counterclockwise when viewed from its end to its start.

1 Select the structural member.
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2 Select the Roll grip, move it until the desired number of degrees
is displayed, and click once; or enter a value, and press ENTER.

A positive value rolls the member about its axis in a
counterclockwise direction when viewed from its end to its start.

Changing beam orientation with the Roll grip

Changing the Radius of a Curved Structural Member
Use this procedure to change the radius of a curved structural member. You
can also change the structural member radius on the Properties palette. For
more information about curved structural members, see About Curved
Structural Members on page 2598.

1 Select the structural member.

2 Select a Curve Radius grip, move the grip until the radius value
you want is displayed, and click once.
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Change the curve radius of a curved beam structural member with grips

About Curved Structural Members
The smoothness (tessellation) of curved edges is controlled by the FACETDEV
variable. This variable sets the number of facets to display on curved AEC
objects. The default value is 1/2'' for drawings created from imperial templates
and is 12.7 mm for drawings created from metric templates.

The number you specify for facet deviation defines the maximum distance
from the chord to the arc—the chord being an edge that is created from
faceting the curve to the true mathematical arc. The facet deviation has a
range of greater than zero (0) and no upper limit.
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The minimum number of facets is 8. For example, if you create a cylinder
mass element to have a 1' radius, and specify 1' for FACETDEV, the cylinder
has 8 faces.

The plan representation of individual curved components of columns uses
the true curved representation of the member shapes. The above and below
cut components will always be faceted.

The maximum number of facets is controlled by the FACETMAX variable.
This variable can be set from 100 to 10,000. Note that using a small value for
FACETDEV and a large value for FACETMAX will adversely affect drawing
performance.

To specify the facet deviation values for the current drawing, see Specifying
the Display Resolution of Objects with Facets on page 202. The settings apply
to all curved objects in the drawing, including curved structural members.

Changing the Structural Member Justification
Use this procedure to change the justification of a structural member.
Justification positions the shape of a structural member in relation to its
extruded axis. Changing the justification of an existing member moves the
member and can affect how the member relates to other objects, such as how
a column is positioned in relation to a column grid when it is anchored to
the grid.
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Justification options for a beam

You can also specify the justification of structural members with multiple
shapes and segments. For more information about these members, see Creating
Custom Structural Members on page 2645.

1 Select the structural member to change, and double-click it.

2 On the Properties palette, expand Basic, and expand Dimensions.
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3 Select a setting for Justification:

Then…If you want to…

select Baseline for Justify.

NOTE This applies to members
created with styles from the
Structural Member Catalog
only.

position the axis of the member
along the centroid of the member
shape

select one of the 9 positions for
Justify.

position the axis of the member
along one of 9 positions on the
member shape

4 To specify the justification of members with multiple shapes and
segments created with this tool, select a setting for Justify using
overall extents:

Then…If you want to…

select Yes. The justification is ap-
plied ONLY to the lowest priority

justify the member based on the
largest cross-sectional extent of the
member’s lowest priority shapes shape definitions, and is calculated

based on the node (vertex) of the
member with the greatest cross
section.

select No. The justification is calcu-
lated based on the cross-sectional

justify the member at each node,
based on all shapes.

extents at each node, and is applied
to all the shapes without regard to
priority.

Changing the Structural Member Type
Use this procedure to change the type of one or more structural members.
Because beams, braces, and columns are sub-types of a single structural member
object, you can change a beam to a brace, a column to beam, or a brace to a
beam.

1 Select the structural members to change, and double-click one of
them.
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2 On the Properties palette, expand Basic, and expand General.

3 Select a setting for Member type: Beam, Brace, or Column.

Trimming Structural Members
Structural members can be trimmed using 2-dimensional objects called trim
planes. You can manually add a trim plane for a structural member either by
defining its position in relation to the member itself (using the Trim Planes
worksheet available from the Properties palette), or by selecting a plane defined
(or implied) by another structural member, an architectural object of another
type, or linework. You can also configure structural member styles and insertion
tools so that a trim plane is created automatically when an endpoint of a new
structural member is logically connected to an existing structural member or
other object (see Creating a Structural Member Style in the Style Manager on
page 2629).

You can add multiple trim planes to individual structural members, allowing
you to clean up joints between multiple structural members. For example, use
multiple trim planes to angle both ends of a brace in a diagonally braced
frame.

Trim planes can be edited using the Trim Planes worksheet or grip-edited. You
can remove trim planes from a structural member to restore it to its original
dimensions.

NOTE Although trim planes are depicted as square grids when selected for editing,
they are actually infinite planes; thus you cannot use them to notch, cope, or cut
holes in structural members.
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Trimming a structural member with a trim plane

Adding a Trim Plane to a Structural Member
You can add any number of trim planes to a structural member. When you
add a trim plane to one or more structural members, you define the position
of the trim plane relative to the structural member that you are trimming.

When defining trim planes, you can:

■ Define the position of the trim plane relative to the start or end of the
extruded axis of the member.

■ Offset the trim plane in the X direction to move the origin of the trim
plane along the extruded axis of the member.
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Offsetting a trim plane in the X direction

■ Offset the trim plane in the Y and Z directions to move the origin of the
trim plane perpendicular to the extruded axis of the member in the Y
and/or Z direction.

■ Rotate the trim plane around its Y axis to specify a cutting plane angle.
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Rotating a trim plane about its Y axis

■ Rotate the trim plane around its Z axis to specify a cutting plane angle.
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Rotating a trim plane about its Z axis

1 Select the structural member you want to change.

2 Click Structural Member tab ➤ Modify panel ➤ Trim Planes  .

3 Click Add  .

4 Specify settings to position the trim plane:

Then…If you want to…

select Start or End under Offset.offset the trim plane from the start
point or endpoint of the member
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Then…If you want to…

enter an X value for Offset.offset the trim plane in the X direc-
tion along the extruded axis of the
member

enter Y and Z values for Offset.offset the trim plane in the Y and Z
directions to position the trim plane
perpendicular to the extruded axis
of the member

enter Y and Z values for Rotation.rotate the trim plane around its Y
or Z axis

5 To copy a trim plane, select the trim plane, and click Copy  .

6 Continue adding trim planes, and click OK.

Adding a Trim Plane Based on Another Object or Linework
Use this procedure to generate trim planes for one or more structural members
based on a plane defined (or implied) by another structural member, an
architectural object of another type, linework, or any 2 points you specify.
The edge, face, or line that defines the trim plane does not have to intersect
the members selected for trimming. The trim plane is projected perpendicular
to the current UCS XY plane. Selected members are extended or trimmed to
the trim plane, depending on whether they intersect it.

Extending a structural member to another structural member
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1 Select the structural member(s) you want to extend or trim.

2 Click Structural Member tab ➤ Modify panel ➤ Add Trim Plane

 .

3 Define the trim plane:

Then…If you want to…

press ENTER, specify the start point
and endpoint of the trim plane, and

define a trim plane independent of
any existing objects

then click the side on which you
want to remove members.

select the object or linework, and
then click the side on which you

use the edge or face of an existing
object or linework as the trim plane

want members removed. If you
want to trim to the face of an ob-
ject rather than its edge, press Ctrl
before selecting the object.

Mitering Structural Members with Trim Planes
Use this procedure to generate trim planes that produce a mitered joint between
2 structural members that are connected at their endpoints.

NOTE If the value of Trim automatically (on the Properties palette) is Yes for each
of the connected structural members, then any kind of grip edit to either member
will result in a mitered joint between them.

Mitering two structural members with coincident endpoints

1 Select one of the structural member(s) you want to miter.
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2 Click Structural Member tab ➤ Modify panel ➤ Miter  .

3 Select the other structural member.

Changing a Structural Member Trim Plane
After you add one or more trim planes to a structural member, you can change
the orientation of the trim planes. You can also grip-edit trim planes to move
and rotate them.

1 Select the structural member you want to change.

2 Click Structural Member tab ➤ Modify panel ➤ Trim Planes  .

3 Change any of the trim plane settings:

Then…If you want to…

select Start or End under Offset.change the start or end offset of the
trim plane

change the X value for Offset.change the trim plane offset in the
X direction along the extruded axis
of the member

change the Y and Z values for Off-
set.

change the trim plane offset in the
Y and Z directions to position the
trim plane perpendicular to the ex-
truded axis of the member

change Y and Z values for Rotation.change the rotation of the trim
plane around the Y or Z axis

NOTE If you rotate a trim plane between 90 and 270 degrees, the
opposite end of the structural member is completely removed.

4 Click OK.

Removing a Trim Plane from a Structural Member
Use this procedure to remove a trim plane from a structural member. When
you remove all trim planes from a structural member, the structural member
is restored to its original dimensions.
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1 Select the structural member you want to change.

2 Click Structural Member tab ➤ Modify panel ➤ Trim Planes  .

3 Select the trim plane that you want to remove.

4 Click Remove  .

5 Click OK.

Changing the Style of a Structural Member
Use this procedure to select a different structural member style for one or more
structural members. The style of a structural member provides its shape, so
changing the style of a member changes its shape.

1 Select the structural members to change, and double-click one of
them.

2 Expand Basic, and expand General.

3 Select a different style.

Applying Tool Properties to a Structural Member
Use this procedure to apply the properties of a structural member tool to one
or more members of the same tool type (beam, brace, or column) in a drawing.
The properties include any settings specified in the tool you select.

1 Open the tool palette that you want to use.

(You may have to scroll to display the desired tool.)

2 Right-click a structural member tool, and click Apply Tool
Properties to  ➤ <Beam, Brace, or Column>.

3 Select the structural members that coincide with the tool, and
press ENTER.

4 Edit the properties of the structural member on the Properties
palette, if needed.

Specifying the Cut Plane Display of a Structural Member
Use this procedure to specify the properties of one or more cut planes for an
individual structural member. Cut plane display properties apply only to
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display representations, such as Plan, that are used in the Top view (plan view)
of a drawing.

1 Double-click the structural member you want to change.

2 On the Display tab of the Properties palette, under General, for
Display component, verify that *NONE* is selected.

3 For Display controlled by, select This object.

NOTE To apply your changes to all structural members in the
drawing, select Drawing default setting. To apply changes to all
structural members of this style, select Structural Member Style:<style
name>. For more information on styles, see Structural Member Styles
on page 2628.

4 If necessary, expand Object Display Properties ➤ Cut Plane.

5 For Override cut plane, specify whether you want to override the
global cut plane defined for the current display configuration.

6 If you selected Yes for Override cut plane, enter a value for Height
to define the cut plane for this object. (Alternatively, you can click

the value, click  , and specify 2 points in the drawing area to
define the new height.)

7 Specify whether to display the true cut body of the structural
member.

8 Specify whether to display object components both above and
below the cut plane.

You can also access and modify these same cut plane settings through the
structural member’s context menu, as follows:

1 Select the structural member you want to change, right-click, and
click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 In the Display Properties dialog, click the Cut Plane tab, and then
change the settings as needed.
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6 Click OK twice.

Specifying the Display of Custom Block Components of a
Structural Member

Use this procedure to specify the display of custom block components for an
individual structural member in a particular display representation. If you are
going to use custom graphics for a new component, draw the component and
save it as a block before you start this procedure.

1 Double-click the structural member.

2 On the Display tab of the Properties palette, under General, for
Display component, verify that *NONE* is selected.

3 For Display controlled by, select This object.

NOTE To apply your changes to all structural members in the
drawing, select Drawing default setting. To apply changes to all
structural members of this style, select Structural Member Style:<style
name>. For more information on styles, see Structural Member Styles
on page 2628.

4 For Display representation, verify that the desired display
representation is selected.

5 If necessary, expand Object Display Properties ➤ Advanced, and

for Custom block display, click  (the number in parentheses
indicates the number of blocks currently attached to the structural
member).

6 If you want to turn off the display of custom blocks for this
structural member without removing them, select Disable Custom
Blocks.

7 Specify whether to add, edit, or remove a block component:

Then…If you want to…

click Add, and then click Select
Block, select the block, and click
OK.

add a new block component

select the component to edit, and
click Edit.

edit an existing block component
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Then…If you want to…

select the block, click Remove, and
click OK.

remove an existing block compon-
ent

8 Select a setting for Position Along (x) to position the block in a
location along the X-axis of the member.

9 Specify an insertion offset of the block in the X, Y, and Z directions.

10 Specify whether you want repeat the block display along the X-axis
of the member:

Then…If you want to…

select Repeat Block Display.repeat the display of the block
along the X-axis of the member

enter values for Start Offset and End
Offset.

offset the repeated blocks from the
start or endpoint of the member

enter a value for Space Between.specify the space between the re-
peated blocks

select Fit, and select Space Evenly.increase the spacing between re-
peated blocks so the insertion point
of the last block is at the end offset
distance from the end of the mem-
ber

select Fit, and select Scale to Fit.scale the block so the extents of all
the blocks fit between the start and
end offset distances

11 Specify whether to mirror the block in the X,Y, or Z direction:

Then…If you want to…

select Mirror X.create a mirror of the block in the
X direction

select Mirror Y.create a mirror of the block in the
Y direction

select Mirror Z.create a mirror of the block in the
Z direction
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12 Click OK twice.

You can also add offsets between members to display them as you typically
would in a top view framing plan. Note that the Use Member Offsets check
box applies only to the start and end offsets. The Offset value below the check
box applies only to structural braces, and allows you to offset them horizontally
so that they are visible even when positioned directly underneath a beam.

Specifying the Offsets for a Structural Member in Plan Low
Detail

Use this procedure to specify offset values for a selected structural member in
the Plan Low Detail display representation.

Adding offsets between members lets you display them as you typically would
in a top view framing plan. Note that the Use Member Offsets check box
applies only to the start and end offsets.

1 Double-click the structural member.

2 On the Display tab of the Properties palette, under General, for
Display component, verify that *NONE* is selected.

3 For Display controlled by, select This object.

NOTE To apply your changes to all structural members in the
drawing, select Drawing default setting. To apply changes to all
structural members of this style, select Structural Member Style:<style
name>. For more information on styles, see Structural Member Styles
on page 2628.

4 For Display representation, select Plan Low Detail.

5 If necessary, expand Object Display Properties ➤ Advanced, and

click  Offsets.

6 For Use Member Offsets, specify whether you want to use the start
and end offsets of the member.

7 If you did not select Use Member Offsets, enter values for Start
Offset and End Offset.

8 For Offset, enter the horizontal offset distance you want to use
to make structural braces visible even when positioned directly
underneath a beam.

9 Click OK.

2614 | Chapter 32   Structural Members



Attaching Hyperlinks, Notes, and Files to a Structural Member
Use this procedure to enter notes and attach hyperlinks and reference files to
a structural member. You can also edit notes and edit or detach reference files
from a structural member.

1 Double-click the structural member.

2 In the Properties palette, click the Extended Data tab.

3 Click the setting for Hyperlink.

4 Specify the link, and click OK.

5 Click the setting for Notes.

6 Enter the note, and click OK.

7 Click the setting for Reference documents, and attach, edit, or
detach a reference file:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter your comments under Descrip-
tion for the document you are de-
scribing.

edit the description of a reference
file

double-click the reference file name
to start the application needed to
edit it.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

8 Click OK.

Working with Structural Member Body Modifiers
Body modifiers use the three-dimensional (3D) geometry of an object, such
as a mass element or a mass group, to add to or subtract from a structural
member. You can also use a body modifier to replace a structural member.

After you create a body modifier from an object, you can delete the original
object. However, if you have created a complex object, such as a mass group
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comprising many mass elements, you may want to retain the object in the
drawing until you are sure you have the results you want for the structural
member.

Adding a Body Modifier to a Structural Member
Use this procedure to create a body modifier and add it to a structural member.

You can create a three-dimensional (3D) body modifier from a mass element,
a mass group, or any other AEC object with mass. You can also create body
modifiers from ACIS solids or blocks that form 3D bodies. You must place the
object in the location you want in the drawing before defining the object as
a body modifier.

The following illustration shows you how to use an angle as a body modifier
to add to a beam.

Adding a body modifier to a structural member

1 Place the object in the location where you want to add the body
modifier to the structural member.

2 Select the structural member you want to change with the body
modifier.

3 Click Structural Member tab ➤ Modify panel ➤ Body Modifiers

drop-down ➤ Add  .

4 Select the object to add to the structural member.
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5 In the Add Body Modifier dialog box, select Additive for Operation.

6 Enter a description for the body modifier.

7 Select Erase Selected Object(s) if you do not want to keep the
original object, or clear this option to keep the object in the
drawing.

8 Click OK.

Subtracting a Body Modifier from a Structural Member
Use this procedure to create a three-dimensional (3D) body modifier and
subtract it from a structural member.

You can create a three-dimensional (3D) body modifier from a mass element,
a mass group, or any other AEC object with mass. You can also create body
modifiers from ACIS solids or blocks that form 3D bodies. You must place the
object in the location you want in the drawing before defining the object as
a body modifier.

The following illustration shows you how to use a box mass element as a body
modifier to cope a beam.

Subtracting a Body Modifier from a Structural Member | 2617



Subtracting a body modifier from a structural member

1 Place the object in the location where you want to subtract the
body modifier from the structural member.

2 Select the structural member you want to change with the body
modifier.

3 Click Structural Member tab ➤ Modify panel ➤ Body Modifiers

drop-down ➤ Add  .

4 Select the object to subtract from the structural member.

5 In the Add Body Modifier dialog box, select Subtractive for
Operation.

6 Enter a description for the body modifier.

7 Select Erase Selected Object(s) if you do not want to keep the
original object, or clear this option to keep the object in the
drawing.

8 Click OK.
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Replacing a Structural Member with a Body Modifier
Use this procedure to create a three-dimensional (3D) body modifier and
replace a structural member with the modifier.

You can create a three-dimensional (3D) body modifier from a mass element,
a mass group, or any other AEC object with mass. You can also create body
modifiers from ACIS solids or blocks that form 3D bodies. You must place the
object in the location you want in the drawing before defining the object as
a body modifier.

The following illustration shows you how to use a mass group as a body
modifier to replace a beam.

Replacing a structural member with a body modifier

1 Place the object in the location where you want to replace the
structural member with the body modifier.

2 Select the structural member you want to change with the body
modifier.

3 Click Structural Member tab ➤ Modify panel ➤ Body Modifiers

drop-down ➤ Add  .

4 Select the object to replace the structural member.
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5 In the Add Body Modifier dialog box, select Replace for Operation.

6 Enter a description for the body modifier.

7 Select Erase Selected Object(s) if you do not want to keep the
original object, or clear this option to keep the object in the
drawing.

8 Click OK.

Editing the Geometry of a Body Modifier
Use this procedure to edit the shape of a body modifier that is attached to a
structural member. You can edit the body using grips to edit faces, using
Boolean commands to add or remove other objects from the body modifier,
and other editing commands to change its shape.

1 Select the structural member that has the body modifier you want
to change.

2 Click Structural Member tab ➤ Modify panel ➤ Body Modifiers

drop-down ➤ Edit In Place  .

A temporary mass element is created for you to edit the geometry
of the body modifier. If the wall contains multiple body modifiers,
a mass element is created for each body modifier. If object was
not originally a mass element (for example, if you used a slab as
a body modifier), the object becomes a temporary Free Form mass
element with faces that you can edit.

NOTE After you perform an editing task, you may need to select a
profile again to perform another editing task.

2620 | Chapter 32   Structural Members



3 Edit the body modifier:

Then …If you want to …

select the body modifier. Select a
Face grip to activate edge grips for

change the shape of a body modifi-
er that is a Free Form mass element

the face. Move the grips to the de-
sired locations. Continue editing
other faces in the same manner.

select the body modifier. Select
grips and move them to change the

change the shape of a body modifi-
er that is a conventional mass ele-
ment shape of the body modifier. The

grips that are available depend on
the type of mass element used as a
body modifier and the current view
direction.

place the object in the location
where it is needed. Select the body

add an object to a body modifier

modifier, and click Edit In Place

tab ➤ Modify panel ➤ Boolean

drop-down ➤ Union  . Select
the object, and press ENTER. Enter
y (Yes) to keep the object in the
drawing, or press ENTER to erase it.

place the object in the location
where it is needed. Select the body

subtract an object from a body
modifier

modifier, and click Edit In Place

tab ➤ Modify panel ➤ Boolean

drop-down ➤ Subtract  . Select
the object, and press ENTER. Enter
y (Yes) to keep the object in the
drawing, or press ENTER to erase it.

place the object in the location
where it is needed. Select the body

create a body modifier that is the
intersection of the original body
modifier with another object modifier, and click Edit In Place

tab ➤ Modify panel ➤ Boolean

drop-down ➤ Intersect  . Select
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Then …If you want to …

the object, and press ENTER. Enter
y (Yes) to keep the object in the
drawing, or press ENTER to erase it.

select the body modifier, and click

Edit In Place tab ➤ Modify pan-

trim a body modifier

el ➤ Trim By Plane  . Specify the
points that define the trim plane,
and select the side of the body
modifier to be trimmed. The
trimmed body modifier is converted
to a Free Form mass element.

select the body modifier, and click

Edit In Place tab ➤ Modify pan-

divide the face of a body modifier
into two faces

el ➤ Split Face  . Specify the
points that define the edge created
by splitting the faces.

select the body modifier and click

Edit In Place tab ➤ Modify pan-

join two faces that are on the same
plane into a single face

el ➤ Join Faces  . Select the edge
that separates the coplanar faces.

select the object that forms the
body modifier, and press DELETE.

remove a body modifier

4 Save or discard the changes:

Then …If you want to …

click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the body modifier to its ori-
ginal shape

click Edit In Place tab ➤ Edits pan-

el ➤ Finish  . The body modifier

save the changes to the body
modifier

uses the edited mass element to
define its geometry.
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Managing Body Modifiers
Use this procedure to edit or remove three-dimensional (3D) body modifiers
from a structural member. You can select a different operation, or you can
enter or edit the descriptions of body modifiers.

NOTE To remove a body modifier from a structural member and restore the
modifier as a mass element that you can edit or apply to other structural members,
see Restoring a Body Modifier to a Mass Element on page 2624.

1 Select the structural member you want to change.

2 Click Structural Member tab ➤ Modify panel ➤ Body Modifiers

drop-down ➤ Body Modifier  .

3 Select a body modifier, and change its settings:

Then …If you want to …

select a different structural member.apply the body modifier to a differ-
ent structural member

select a different operation for Op-
eration:

change the operation used to apply
the body modifier to the structural
member ■ Select Additive to add the body

modifier to the structural
member

■ Select Subtractive to subtract
the shape of the body modifier
from the structural member

■ Select Replace to replace the
structural member with the
body modifier.

select the body modifier, and click

 .

delete the body modifier from the
structural member

click Description, enter text, and
press ENTER.

enter a description of the body
modifier

4 Click OK.

Managing Body Modifiers | 2623



Restoring a Body Modifier to a Mass Element
Use this procedure to remove a body modifier from a structural member and
add it to the drawing as a mass element. Restoring a body modifier to a mass
element enables you to modify the shape as a mass element and then add it
to the structural member again as a body modifier. You can also restore the
body modifier to a mass element while leaving the body modifier still applied
to the structural member. This is useful if you want to create other structural
members with the same shape.

If the object used to create the body modifier was a conventional mass element,
it is restored to that mass element. For example, a cylinder mass element is
restored as a cylinder mass element. However, if the body modifier was created
from another object, such as a slab, or was edited using Boolean operations
or face editing commands, the body modifier is restored as a Free Form mass
element.

1 Select the structural member you want to change.

2 Click Structural Member tab ➤ Modify panel ➤ Body Modifiers

drop-down ➤ Restore  .

3 NOTE This procedure restores all body modifiers attached to a
structural member.

Create mass elements from the body modifiers:

Then …If you want to …

press ENTER.create mass elements from the body
modifiers while keeping the body
modifiers attached to the structural
member

enter y (Yes), and press ENTER.remove all body modifiers from the
structural member, and create mass
elements from their shapes

Working with Structural Member Interference
Conditions

You can modify the geometry of a Structural Member by using another object
to create an interference condition within the structural member. For example,
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you can create a hole in a structural member. Unlike the object used to add
a hole, which has no connection to the structural member and can be erased
after the hole is added, the object used to create an interference condition
remains partially or wholly embedded in the structural member, cutting out
and replacing a part of its geometry. All interference conditions are subtractive
in this sense, but the option you use to create the interference condition (Add
or Subtract) determines whether the outline of the interference condition is
included or excluded from the shrink wrap outline of the structural member
in plan view.

Creating Structural Member Interference Conditions
Use the following procedure to create structural member interference
conditions. Typically, after creating interference conditions for a structural
member, you freeze the layer where the interfering objects are placed. If you
move or edit the objects, the structural member updates accordingly.

NOTE Objects used as interference conditions are not included for the Area in the
LIST command or in a Schedule Query result.

To create interference conditions for a structural member:

1 Create one or more objects in the actual location where you want
the interference condition positioned in relation to the structural
member.

2 Select the structural member.

3 Click Structural Member tab ➤ Modify panel ➤ Interference

Condition drop-down ➤ Add  .
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4 Select the objects to use as interference conditions, and press
ENTER.

NOTE AEC objects from externally referenced (xref) files can be added
to a structural member as interference conditions so long as the
following conditions are met:

■ The object is a three-dimensional (3D) body

■ The xref is found

■ The xref is read/write

■ The xref is not locked or opened by another user

■ The xref is loaded
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Removing Structural Member Interference Conditions
Use this procedure to remove an interference condition from a structural
member. Note that only the interference condition is removed; the object
from which the interference condition was created remains in the drawing.

1 Select the structural member.

2 Click Structural Member tab ➤ Modify panel ➤ Interference

Condition drop-down ➤ Remove  .

3 Select the objects to remove as interference conditions, and press
ENTER.

NOTE You can also remove interference conditions through the
Interference Conditions worksheet. For more information, see Editing
Structural Member Interference Conditions on page 2627.

Editing Structural Member Interference Conditions
Objects applied as interference conditions in structural members be edited
like any other objects, using grips, tools on the Structural Member tab, context
menu options, or the Properties palette. If you move or edit the objects, the
structural member updates accordingly. You can also change the setting that
determines whether an interference condition is added to or subtracted from
the shrink wrap outline of the structural member in plan view by using the
following procedure.

1 Select the structural member.

2 Click Structural Member tab ➤ Modify panel ➤ Interference

Condition drop-down ➤ Interference Condition  .
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3 On the Interference Conditions worksheet, click the Shrinkwrap
Effect value you want to change, and select a different value from
the pull-down menu.

4 Click OK.

NOTE You can also use this worksheet to remove an interference
condition by right-clicking its Object or Type value and then clicking
Remove. The alternate method is to use the context menu of the
structural member. When you remove an interference condition, you
remove the association between the structural member and the object
that was used to create the interference condition. The object itself
is not removed from the drawing.

Structural Member Styles
A structural member style is a group of properties assigned to a structural
member that determines the shape and other characteristics of the structural
member. You can use structural member styles to represent standard structural
member types for specific jobs and drawings or for office standards. When
you create or modify a structural member style, the structural members using
the style have the settings and characteristics of the style.

Usually you create structural member styles from the Structural Member
Catalog or with the Structural Member wizard and drag them from the Style
Manager onto a tool palette. You can also create your own structural member
styles for custom structural members that you cannot create from the catalog
or with the wizard. For more information, see Creating Custom Structural
Members on page 2645.

Creating Tools from Structural Member Styles

You can create a structural member tool from any structural member style.
Usually, you want to create structural members tools from styles that you
create in the Structural Member Catalog or with the Structural Member Style
wizard. However, you can also create a structural member tool from a style
that you create in the Style Manager. You can save the style to a drawing file
and create a structural member tool with the style. You can then specify default
settings for any structural member created with that tool. For more
information, see Creating Structural Member Tools on page 2539.
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Managing Structural Member Styles

To create, edit, copy, or purge structural member styles, you access the Style
Manager. The Style Manager provides a central location in AutoCAD
Architecture where you can work with styles from multiple drawings and
templates. For more information about using the Style Manager, see Style
Manager Overview on page 870.

Creating a Structural Member Style in the Style Manager
Use this procedure to create a structural member style in the Style Manager.
You can create a style using default style properties, by copying an existing
style. After you create the style, you edit the style properties to customize the
characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Structural Member
Styles.

3 Create a structural member style:

Then…If you want to…

right-click Structural Member Styles,
and click New.

create a style with default properties

right-click the structural member
style you want to copy, and click
Copy. Right-click, and click Paste.

create a style from an existing style

4 Enter a name for the new structural member style, and press ENTER.

5 Edit the new structural member style:

Then…If you want to…

click the General tab, and enter a
description.

enter a description of the style

click the Design Rules tab, and se-
lect or clear Trim Members Automat-

specify whether a member with this
style will automatically trim to exist-

ically. This option is selected by de-ing members when added to a
fault for new styles. The setting candrawing and whether its trim planes
be overridden in the tool or object
properties.

will be adjusted automatically if it
is grip edited directly, or if its end-
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Then…If you want to…

points move in response to grip-
editing of a logically connected
member

see Creating Custom Structural
Members on page 2645.

change the design rules of the style
to create a custom structural mem-
ber

see Specifying the Materials of a
Structural Member Style on page
2630.

specify materials for the compon-
ents of the style

see Specifying the Display Proper-
ties of a Structural Member Style on
page 2633.

specify hatching, cut plane proper-
ties, and other display properties of
the style

see Specifying Classifications for a
Structural Member Style on page
2643.

add classifications to a structural
member style

see Attaching Notes and Files to a
Structural Member Style on page
2644.

add notes and files to the style

6 Click OK.

7 If you want to assign the style to a structural member tool, drag
the style from the Style Manager to a tool palette.

You can later rename the tool and specify other properties for it
as described in Creating Structural Member Tools on page 2539.

8 Click OK.

Specifying the Materials of a Structural Member Style
A structural member consists of a number of components whose display
properties can be determined by the materials assigned to each component.
When you assign materials to a structural member style, you assign one
material to each physical component of the structural member. You assign
materials to components in each display representation where you want the
materials to be used.
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If you want to use the display properties of the structural member style, instead
of using material display properties, you can turn off the material assignments
in the display properties of the structural member style.

Material definitions consist of display components that correspond to
component types of objects. For example, the Linework component of a
material is used for all linework in plan view. The Surface Hatch component
of a material is used to hatch all object surfaces in three dimensional (3D)
model views and in elevations.

Structural Member Materials and Display Components
The following table identifies the material component that corresponds to
each structural member component:

Material ComponentStructural Member Component

Elevation, Elevation High Detail

Plan LineworkVisible Comp 1-10

Model, Model High Detail, Model Low
Detail

3D BodyComponent 1 - 10

Plan, Plan Low Detail, Plan High Detail, Plan
Presentation, Plan Screened

Plan LineworkVisible Comp 1-10

Plan HatchHatch 1 - 20

Reflected, Reflected Screened

Plan LineworkVisible Comp 1-10

Assigning Materials to a Structural Member Style
Use this procedure to assign materials to the individual components of a
structural member style. When you assign a material to a structural member
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component, the component uses the display properties of the material instead
of the style display properties.

You can assign a material to any physical component of the structural member.
Custom components and components that are only symbolic graphics do not
use materials for their display properties. For example, all structural member
components are physical components that you can assign materials. The
connection and axis are symbols, and you cannot assign materials to them.

NOTE If a material assignment does not determine the display properties of a
structural member component, you can change the display properties of the
structural member style as described in Specifying the Display Properties of a
Structural Member Style on page 2633.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Structural Member
Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select By Material for any component to which you want to assign
a material, and click OK.

If the setting for By Material is not available, the display of this
component cannot be determined by a material.

9 Click the Materials tab.

10 Select the component you want to change, and select a different
material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Although you can edit a material definition from this
dialog box, any changes you make to the material definition apply
to all objects that are assigned the material.
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11 Click OK.

Specifying the Display Properties of a Structural Member Style
In most cases, you can assign materials to structural member components so
that the appearance of structural members that belong to the same style is
consistent throughout a drawing and with other structural members and
objects that use the same materials.

If a component cannot be assigned a material, or if you do not want to use
materials but still want consistency among structural members of the same
style, you can specify the display properties of the structural member
components in the structural member style:

■ Layer, color, and linetype of structural member components

■ Hatching used with each component

■ Cut plane height and the display of components relative to the cut plane

■ Other specific structural member display information, such as whether
custom blocks are added to the display of the structural member

You can also use the Display tab of the Properties palette to change the display
property settings for a selected object display component in the current display
representation. For more information, see Using the Properties Palette to
Change Display Properties on page 793.

About Structural Member Display Representations
Structural member geometry is created by a shape contained in the style of
the structural member that is extruded along the axis of the member. Each
shape can have different levels of detail in its geometry, allowing different
displays of the structural member that the shape is defining. If you look at
the display representations of a structural member, you see that there may be
more than one of the same representation. Each representation displays the
structural shape in a different level of detail.

For example, you can use the Plan, Plan High Detail, and Plan Low Detail
structural member representations to display a plan view of a structural
member.
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Displaying a structural member with the Plan High Detail, Plan Low
Detail, and Plan display representations

The Plan Low Detail display representation displays the member with simple
lines and arcs. You can use this display representation to create a top view
framing plan where you want a single line representation of a column. The
Plan Low Detail display representation includes two display components,
Beam Sketch and Brace Sketch. You can change the display properties of these
components, such as layer, color, and linetype, to differentiate the display of
beams and braces. On the Other tab of the style override dialog box for this
display representation, you can also add offsets between members to display
them as you typically would in a top view framing plan. Note that the Use
Member Offsets check box applies only to the start and end offsets. The Offset
value below the check box applies only to structural braces, and allows you
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to offset them horizontally so that they are visible even when positioned
directly underneath a beam.

The Plan and Plan High Detail display representations display the previous
column using closed polylines. Both representations display the column
geometry, but the Plan High Detail representation is more detailed, including
fillets in the column display. Use the Plan representation to improve
performance while modeling, and the Plan High Detail representation to
display an added level of detail for detail drawings.

The following table lists the structural member display representations and
their uses:

To…Use this display representation…

display an elevation view of a structural
member with simplified geometry for bet-
ter performance when modeling.

Elevation

display an elevation view of a structural
member in full detail.

Elevation High Detail

display the extruded axis of a structural
member and connections between mem-

Logical

bers. Connections are automatically estab-
lished between members when they touch
endpoint to endpoint or endpoint to a
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To…Use this display representation…

point on the extruded axis of another
member.

display a 3D structural member with simpli-
fied geometry for better performance when
modeling.

Model

display a 3D structural member in full detail
for large scale details.

Model High Detail

display a 2D structural member in less de-
tail than the Plan High Detail representation

Plan

to improve performance. Members display
as closed polylines, rather than lines and
arcs as in the Plan Low Detail representa-
tion.

display a 2D structural member in full de-
tail.

Plan High Detail

display a 2D structural member with simple
lines and arcs to create a top view framing

Plan Low Detail

plan. Includes a Beam Sketch and Brace
Sketch display component to differentiate
beams and braces in plan view.

display a 2D structural member with solid
hatching (poche) for plan view presenta-
tion drawings.

Plan Presentation

display a 2D structural member in the
screened portion of a screened floor plan,

Plan Screened

with components and hatching visibly
lighter than some other objects.

display a 2D structural member in a reflec-
ted ceiling plan.

Reflected

display a 2D structural member in the
screened portion of a screened reflected

Reflected Screened

ceiling plan with components and hatching
visibly lighter than some other objects.
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Specifying the Layer, Color, and Linetype of a Structural Member
Style

Use this procedure to change the following display properties of the
components of a structural member style:

■ Visibility (component is on or off)

■ By material (material assigned to the display component determines its
display properties)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

NOTE If a material assignment determines the display properties of components
in the structural member style, you can change the properties of the display
component by clearing By Material. You can also override the material assignment
with a different material. For more information, see Assigning Materials to a
Structural Member Style on page 2631.

NOTE For multi-component structural members, hidden lines are calculated one
component at a time.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Structural Member
Styles.

3 Select the structural member style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select the component to change, and select a different setting for
the property.
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9 Click OK twice.

Specifying the Hatching for Components of a Structural Member
Style

Use this procedure to specify the hatching of the components of a structural
member style. Structural member hatching is displayed only in display
representations, such as Plan, that are used in the Top view (plan view) of a
drawing.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Structural Member
Styles.

3 Select the structural member style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Hatching tab.

8 Select a component, and click the setting for Pattern.

9 Select the hatching for the component:

Then…If you want to…

select Predefined for Type, and then
select a pattern.

select a hatching pattern that is
available in the software

select Custom for Type, and then
enter the name of the custom pat-

select a custom pattern

tern. If necessary, click Browse, and
navigate to the folder where the
custom pattern file is located.

select User-defined for Type, and
clear Double Hatch.

select single hatching

select User-defined for Type, and
select Double Hatch.

select double hatching

select Solid Fill for Type.select solid fill

2638 | Chapter 32   Structural Members



10 Click OK.

11 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

12 Click Angle, and enter the angle for the selected pattern.

13 Click Orientation, and specify how the hatching is oriented:

Then…If you want to…

select Object.orient the hatching to the object,
regardless of the object rotation

select Global.orient the hatching to the World
Coordinate System

14 Click OK twice.

Specifying the Cut Plane Elevation of a Structural Member Style
Use this procedure to specify the cut plane elevation of a structural member
style. The cut plane settings you specify in the structural member style override
the cut plane settings in any display configuration applied to a viewport.

NOTE If the cut plane does not intersect the structural member, all visible and
hidden components display. If the cut plane does intersect the member, only the
cross section of the components of the structural member displays. These are the
actual member shapes unless you select True Cut Body.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Structural Member
Styles.

3 Select the structural member style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 Select Override Display Configuration Cut Plane.

9 Enter a value for Cut Plane Height.

10 Click OK twice.
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Using Custom Blocks to Add Graphics to a Structural Member
Style

You can add custom blocks to the display of a structural member as a
component in a display representation. For example, you can add stiffener
plates to beams as a custom blocks or add clip angles to members as a custom
blocks.

Adding stiffener plates to a beam

Custom blocks can be either 2D or 3D. When you add a custom block, you
can specify several rules for positioning and scaling the new component. Each
custom block also appears in the display properties component list so that
you can control its layer, color, and linetype. For more information, see Adding
Custom Blocks as a Display Component in a Structural Member Style on page
2640.

Be sure to set the properties of the objects used to create your custom blocks
to ByBlock. Otherwise, you cannot control these objects through the display
properties. For more information about ByBlock, see “Control the Color and
Linetype Properties in Blocks” in AutoCAD help.

To change these display properties for all structural members of the same
structural member style, see Specifying the Display Properties of a Structural
Member Style on page 2633.

Adding Custom Blocks as a Display Component in a Structural
Member Style

Use this procedure to add or edit custom block components in the display
representation of a structural member style.

1 Create a 2D or 3D block for the component that you want to add
to the structural member.

Create the block in the same plane as the structural member that
you use to represent structural member. For more information
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about custom blocks, see Using Custom Blocks to Add Graphics
to a Structural Member Style on page 2640.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 Expand Architectural Objects, and expand Structural Member
Styles.

4 Select the structural member style that you want to change.

5 Click the Display Properties tab.

The display representation in bold is the current display
representation.

6 Select the display representation where you want the changes to
appear, and select Object Override.

7 If necessary, click  .

8 Click the Other tab.

9 Under Custom Block Display, click Add.

10 Click Select Block and select the block you created.

11 Select a setting for Position Along (x) to position the block in a
location along the X-axis of the member.

12 Specify an insertion offset of the block in the X, Y, and Z directions.

13 Specify whether you want repeat the block display along the X-axis
of the member:

Then…If you want to…

select Repeat Block Display.repeat the display of the block
along the X-axis of the member

enter values for Start Offset and End
Offset.

offset the repeated blocks from the
start or endpoint of the member

enter a value for Space Between.specify the space between the re-
peated blocks

select Fit, and select Space Evenly.increase the spacing between re-
peated blocks so the insertion point
of the last block is at the end offset
distance from the end of the mem-
ber
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Then…If you want to…

select Fit, and select Scale to Fit.scale the block so the extents of all
the blocks fit between the start and
end offset distances

14 Specify whether to mirror the block in the X,Y, or Z direction:

Then…If you want to…

select Mirror X.create a mirror of the block in the
X direction

select Mirror Y.create a mirror of the block in the
Y direction

select Mirror Z.create a mirror of the block in the
Z direction

15 Click OK twice.

Turning Off Custom Blocks in a Structural Member Style
Use this procedure to turn off the display of custom blocks without removing
them from the structural member style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Structural Member
Styles.

3 Select the structural member style that you want to change.

4 Click the Display Properties tab.

The display representation in bold is the current display
representation.

5 Select the display representation where you want to turn off
custom blocks, and select Object Override.

6 If necessary, click  .

7 Click the Other tab.

8 Under Custom Block Display, select Disable Custom Blocks.

9 Click OK twice.
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Removing Custom Blocks from a Structural Member Style
Use this procedure to remove custom blocks from the display of a structural
member.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Structural Member
Styles.

3 Select the structural member style that you want to change.

4 Click the Display Properties tab.

The display representation in bold is the current display
representation.

5 Select the display representation where you want to turn off
custom blocks, and select Object Override.

6 If necessary, click  .

7 Click the Other tab.

8 Under Custom Block Display, select the block and click Remove.

9 Click OK twice.

Specifying Classifications for a Structural Member Style
Use this procedure to specify classifications for any classification definition
applied to a structural member style.

For more information about creating and applying classification definitions,
see Classification Definitions on page 3872.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Structural Member
Styles.

3 Select the style that you want to change.

4 Click the Classifications tab.

By default, the classification for all classification definitions is
Unspecified. If no classification definitions are listed, none are
applied to structural member styles.

5 For each classification definition, select the classification you want
to apply to the current structural member style.
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6 Click OK.

Defining a Structural Member Style as Bounding for Associative
Spaces

Use this procedure to define a structural member style that can bound
associative spaces.

When a structural member style is set as bounding, by default all beams,
braces, and columns that have the style assigned will be used in the selection
set for an associative space. For more information about associative spaces see
Generating Associative Spaces on page 2940.

You can override the bounding setting from the structural member style in
an individual beam, brace, or column, if necessary.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Structural Member
Styles.

3 Select a structural member style.

4 Click the General tab.

5 Select the check box for Objects of this style may act as a boundary
for associative spaces.

6 Click OK.

Attaching Notes and Files to a Structural Member Style
Use this procedure to enter notes and attach reference files to a structural
member style. You can also edit notes and edit or detach reference files from
a structural member style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Structural Member
Styles.

3 Select the structural member style you want to change.

4 Click the General tab.

5 To add a description to the structural member style, enter it for
Description.

6 Click Notes.

2644 | Chapter 32   Structural Members



7 To add a note, click the Text Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

9 Click OK.

Creating Custom Structural Members
You can specify design rules within a structural member style to create a
custom structural member. The design rules allow you to specify one or more
shapes to extrude along the path (axis) of a structural member. You can assign
and position a start and end shape for each segment of a structural member.

Creating Single-Segmented Custom Structural Members

A single-segment member can start and end with the same shape, or you can
specify different start and end shapes. For example, you can create a tapered
column by assigning different start and end shapes to a single-segment column.
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Creating a tapered column

You can also assign different shapes to the same single-segment member by
adding a component to the member. By adding a component in the design
rules and assigning different shapes to the same segment, you can create a
structural member with overlapping shapes. For example, you can create a
concrete encased steel column by adding a component with a steel column
shape to a concrete column.
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Creating a composite steel and concrete column

Creating Multi-Segmented Custom Structural Members

For multi-segmented structural members, you can assign different shapes to
each segment of the member as components of the member. A series of nodes
(starting at 0 at the start point of the member) correspond to each vertex of
the member path. By assigning different shapes to segments between nodes
on the member path, you can create a structural member that transforms from
one shape to different shapes along the member path. For example, you can
use this method to create a rigid frame.
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Creating the rigid frame

Creating Custom Shapes for Structural Members

When you create custom structural members, you can use the shapes contained
in styles that you create from the Structural Member Catalog or Structural
Member Style wizard, or you can create your own custom shapes. When you
create a custom shape, you can only add it to a structural members in the
design rules of the structural member style.

Understanding the Design Rules of a Structural Member
Use this procedure to access and understand the options in the design rules
of a structural member.

1 Select a structural member.

2 Click Structural Member tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

3 Click Design Rules.

4 On the Design Rules tab, click Show Details.

You can use the following options in the design rules to create
custom members:

Allows you to…This option…

add multiple components to a
structural member. Each compon-

Component

ent includes a name and can in-
clude a start and end shape and a
priority. You can remove and copy
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Allows you to…This option…

the components of a structural
member.

select a shape and a set of paramet-
ers to the start and end of a struc-

Start Shape and End Shape

tural member component. The
component shapes can be the same
shape or a different shape. If End
Shape is using the Start Shape, an
asterisk (*) displays next to the end
shape. To transform the shape of
the member along the member
path, the end shape must be expli-
citly set.

assign a priority to a component.
Components that start and end at

Priority

a common node are mitered based
on their priorities. Components
with the same priority are factored
into the miter angle between the
components. Components with
different priorities are not factored
into the miter angle. Components
with the lowest priority will affect
the justification of the member
when Justify Overall Extents is
cleared on the Dimensions tab in
the properties of the member.

select shapes that you assign to the
start and end of the member or

Name

member segment. You can select
shapes contained in structural
member styles, or custom shapes
that you create.

define the position of the shape rel-
ative to the start or end of the
member.

Relative to
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Allows you to…This option…

place shapes on the member path
relative to the start or end of the

Node

member. To place shapes on the
member path, assign them to
nodes on the member path. A
single segment member has two
nodes; the start point and the end-
point of the member. Multi-segmen-
ted members have additional nodes
located at each vertex of the mem-
ber path, allowing you to assign
different shapes to the start and end
of each segment of the member. If
you place shapes on the member
path relative to the start of the
member, then the start point of the
member path is Node 0. The first
vertex on the member path is Node
1, and so on until the endpoint of
the member path is defined as the
final node. If you place shapes on
the member path relative to the
end of the member, then the end-
point of the member is Node 0.

scale the shape.Scale

mirror the shape.Mirror

rotate the shape.Rotation

offset the shape in the X direction
along the member path.

X Offset

offset the shape in the Y direction
perpendicular to the member path.

Y Offset

offset the shape in the Z direction
perpendicular to the member path.

Z Offset

5 Click Add to add a component to a structural member.
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A component with the same values as the preceding component
is added to the design rules.

6 Click Copy to copy a component.

7 Click Remove to remove a component.

8 Click OK.

Changing the Shape in the Style of a Structural Member
Use this procedure to change the shape that is extruded along the axis of a
structural member created from a single shape. You can create a new shape
for the structural member by creating a custom shape, or by creating a new
style from the Structural Member Catalog that contains a shape.

1 Create a structural member with a single shape.

For more information, see Using Structural Member Tools to Create
Structural Members on page 2553.

2 Create a new shape for the structural member:

Then…If you want to create…

create a custom shape. See Creat-
ing a Custom Shape for a Structural
Member on page 2667.

a custom shape for the member

create a structural member style in
the Structural Member Catalog that

a shape from the Structural Mem-
ber Catalog

contains the shape. See Creating a
Style from a Shape in the Structural
Member Catalog on page 2533.

3 Select the structural member.

4 Click Structural Member tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

5 Click the Design Rules tab.

6 In the Name list under Start Shape, select the shape that you
created in step 2.

If you created a custom shape in step 2, the name of the shape
displays in the Name list. If you created a style from the Structural
Member Catalog, the shape displays in the Name list with the
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name of the shape that you selected in the catalog to create the
style, not with the style name that you created.

7 Click OK.

Adding a Shape to a Structural Member
Use this procedure to add one or more shapes to a structural member in the
design rules of the structural member style. You can create a new shape to
add to the structural member by creating a custom shape, or by creating a
new style from the Structural Member Catalog that contains a shape.

1 Create a structural member with a single shape.

For more information, see Using Structural Member Tools to Create
Structural Members on page 2553.

2 Create a new shape to add to the structural member:

Then…If you want to…

create a custom shape. See Creat-
ing a Custom Shape for a Structural
Member on page 2667.

create a custom shape for the
member

create a structural member style in
the Structural Member Catalog that

create a shape from the Structural
Member Catalog

contains the shape. See Creating a
Style from a Shape in the Structural
Member Catalog on page 2533.

3 Select the structural member.

4 Click Structural Member tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

5 Click the Design Rules tab.

6 Click Add.

A new component is added to the structural member.

7 Type a name for each component under Component.

8 For the new component, from the Name list under Start Shape,
select the shape that you created in step 2.

If you created a custom shape in step 2, the name of the shape is
displayed in the Name list. If you created a style from the
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Structural Member Catalog, the shape is displayed in the Name
list with the name of the shape that you selected in the catalog
to create the style, not with the style name that you typed.

9 Click OK.

The structural member is redrawn with the new shape added to its geometry.

Process Overview: Creating a Single-Component Structural
Member (Tapered Column)

Use this example to create a tapered column, a single-component structural
member that starts with one shape and ends with another.

Creating a tapered column

The process of creating this tapered column has four steps:

1 Create two structural member styles in the Structural Member Catalog
that contain the start and end shapes to taper over the length (height)
of the column.

2 Create a Tapered Column tool.

3 Create a column with the tapered column style.

4 Specify design rules in the tapered column style to add the start and end
shapes in the styles that you created in step 1 to the tapered column.
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Creating Start and End Shapes for the Tapered Column
Use this procedure to create two styles that contain the start and end shapes
for the tapered column. The first style contains the start shape for the column
and the second style contains the end shape for the column.

1 Click Manage tab ➤ Style & Display panel ➤  ➤ Structural

Member Catalog  .

2 Expand Imperial in the tree view in the left pane of the Structural
Member Catalog.

3 Expand Steel, AISC, and then I-Shaped.

4 Select Wn, Wide-Flange Shapes.

5 Right-click W8X31 in the lower right pane of the Structural
Member Catalog, and click Generate Member Style.

6 Enter W8X31, and click OK.

7 Select W1n, Wide-Flange Shapes in the tree view in the left pane.

8 Right-click W14X43 in the lower right pane of the Structural
Member Catalog, and click Generate Member Style.

9 Enter W14X43 and click OK.

10 Click  to close the Structural Member Catalog.

Creating the Tapered Column Tool
Use this procedure to create a tapered column tool. Save the style for the
tapered column in the Member Styles (Imperial).dwg located in
C:\ProgramData\Autodesk\ACA 2012\enu\Styles\Imperial.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Click Open Drawing  .

3 Open Member Styles (Imperial).dwg located in
C:\ProgramData\Autodesk\ACA 2012\enu\Styles\Imperial.

4 Expand Architectural Objects, right-click Structural Member Styles,
and click New.

5 Enter Tapered Column for the name, and press ENTER.

6 Click OK to close the Style Manager.

7 Click Yes to save changes to the Member Styles (Imperial).dwg.
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8 In the title bar of the tool palettes set, click  , and then click
New Palette.

9 Enter Structural, and press ENTER.

10 Open the Design palette, select the Structural Column tool,
right-click, and click Copy.

11 Open the Structural palette, right-click, and click Paste.

12 Select the new tool, right-click, and click Properties.

13 Enter Tapered Column for the Name.

14 Click the setting for Description.

15 Enter Creates a tapered column, and click OK.

16 Expand Basic, and expand General.

17 Click Style location.

18 Select Browse, select the Member Styles.dwg located in
C:\ProgramData\Autodesk\ACA 2012\enu\Styles\Imperial, and click
Open.

19 Click Style and select Tapered Column.

20 Click OK.

Creating a Column with the Tapered Column Tool
Use this procedure to create a column with the tapered column tool that you
created.

1 Select the Tapered Column tool from the tool palette.

2 Press ENTER to create a column that is not anchored to a grid.

3 Specify the insert point of the column.

4 Specify the roll, which is the rotation around the extruded axis
of the column, and press ENTER.

Adding the Start and End Shapes to the Tapered Column
Use this procedure to add the start and end shapes to the tapered column and
transform them along the member path.

1 Select the column, and click Structural Member tab ➤ General

panel ➤ Edit Style drop-down ➤ Edit Style  .

2 Click Design Rules.
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3 Click Show Details.

4 Select Unnamed under Component, and enter Component 1.

5 Under Start Shape, select W8X31 from the Name list.

6 Scroll to the end of the Design Rules dialog box to display the
End Shape parameters.

7 Under End Shape, select W14X43 from the Name list.

8 Click OK.

The complete tapered column displays in your drawing.

Process Overview: Creating a Multi-Component Structural
Member (Composite Column)

Use this example to create a steel column encased in concrete, a
multi-component structural member with a single segment. The steel column
shape is one component of the member, the concrete column shape another.

Creating a composite steel and concrete column

The process of creating this composite column has four steps:
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1 Create two structural member styles: one that contains the shape for the
concrete column and one that contains the shape for the steel column.

2 Create a Composite Column tool.

3 Create a column with the composite column style.

4 Specify design rules in the composite column style to add the concrete
and steel shapes to the column.

Creating the Steel and Concrete Shapes for the Composite
Column

Use this procedure to create two styles: one that contains the steel shape and
one that contains the concrete shape.

1 Click Manage tab ➤ Style & Display panel ➤  ➤ Structural

Member Catalog  .

2 Expand Imperial in the tree view in the left pane of the Structural
Member Catalog.

3 Expand Steel, AISC, and then I-Shaped.

4 Select Wn, Wide-Flange Shapes.

5 Right-click W8X31 in the lower right pane of the Structural
Member Catalog, and click Generate Member Style.

6 Enter W8X31, and click OK.

7 Expand Concrete, and then Pre-Cast.

8 Select Rectangular Columns.

9 Right-click 16X16 in the lower right pane of the Structural Member
Catalog, and click Generate Member Style.

10 Enter 16X16 and click OK.

11 Click  to close the Structural Member Catalog.

Creating the Composite Column Tool
Use this procedure to create a composite column tool. Save the style for the
composite column in the Member Styles (Imperial).dwg located in
C:\ProgramData\Autodesk\ACA 2012\enu\Styles\Imperial.
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1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Click Open Drawing  .

3 Open Member Styles (Imperial).dwg located in
C:\ProgramData\Autodesk\ACA 2012\enu\Styles\Imperial.

4 Expand Architectural Objects, right-click Structural Member Styles,
and click New.

5 Enter Composite Column for the name, and press ENTER.

6 Click OK to close the Style Manager.

7 Click Yes to save changes to the Member Styles (Imperial).dwg.

8 In the title bar of the tool palettes set, click  , and then click
New Palette.

9 Enter Structural, and press ENTER.

10 Open the Design palette, select the Structural Column tool,
right-click, and click Copy.

11 Open the Structural palette, right-click, and click Paste.

12 Select the new tool, right-click, and click Properties.

13 Enter Composite Column for the Name.

14 Click the setting for Description.

15 Enter Creates a composite column, and click OK.

16 Expand Basic, and expand General.

17 Click Style location.

18 Select Browse, select the Member Styles.dwg located in
C:\ProgramData\Autodesk\ACA 2012\enu\Styles\Imperial, and click
Open.

19 Click Style and select Composite Column.

20 Click OK.

Creating a Column with the Composite Column Tool
Use this procedure to create a column with the composite column tool that
you created.

1 Select the Composite Column tool from the tool palette.

2 Press ENTER to create a column that is not anchored to a grid.

3 Specify the insertion point of the column.
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4 Specify the roll, or rotation around the extruded axis of the
column, and press ENTER.

Adding the Steel and Concrete Shapes to the Composite Column
Use this procedure to add the steel and concrete shapes to the composite
column.

1 Select the column, and click Structural Member tab ➤ General

panel ➤ Edit Style drop-down ➤ Edit Style  .

2 Click Design Rules.

3 Click Show Details.

4 Select Unnamed under Component, and enter Component 1.

5 Under Start Shape, select 16X16 from the Name list.

6 Click Add.

A new component is added to the design rules of the column. By
default, the start and end shapes are the same as the preceding
component.

7 Select Unnamed under Component, and enter Component 2.

8 Under Start Shape for Component 2, select W8X31 from the Name
list.

Do not change the other Start Shape parameters.

9 Click OK.

The composite column displays in your drawing.

Process Overview: Creating a Multi-Component Structural
Member Using Multiple Segments (Rigid Frame)

Use this example to create a rigid frame, a multi-segmented structural member
created from multiple shapes that transform at each vertex of the structural
member path.

To create the rigid frame, you convert a multi-segmented polyline to a
structural member and assign different start and end shapes to each segment
of the member as components in the design rules of the rigid frame style. A
series of nodes correspond to the start point, vertices, and the endpoint of the
member path. By assigning different shapes to segments between nodes on
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the member path, the rigid frame transforms from one shape to several shapes
along its path.

Assign shapes to the rigid frame member relative to the start of the member.
The start point is defined as Node 0. The first vertex of the member is defined
as Node 1, the next vertex is Node 2, and so on until the endpoint of the
member, which is defined as the end node.

NOTE If you assign shapes relative to the end of the member, the endpoint of
the member is defined as Node 0.

Identifying nodes on the member path

Creating the rigid frame

The process of creating this rigid frame has seven steps:
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1 Create two styles in the Structural Member Catalog that contain the
shapes that transform over the path of the rigid frame.

2 Create a rigid frame style and tool.

3 Draw a multi-segmented polyline path for the rigid frame and use the
rigid frame tool to convert the path to a structural member.

4 Create the first leg of the rigid frame by assigning start and end shapes
to the first segment of the frame.

5 Create the first rafter of the rigid frame by assigning start and end shapes
to the second segment of the frame.

6 Create the second rafter of the rigid frame by assigning start and end
shapes to the third segment of the frame.

7 Create the second leg of the rigid frame by assigning start and end shapes
to the fourth segment of the frame.

Creating Shapes for the Rigid Frame
Use this procedure to create two styles that contain the two shapes that
transform over the path of the rigid frame.

1 Click Manage tab ➤ Style & Display panel ➤  ➤ Structural

Member Catalog  .

2 Expand Imperial in the tree view in the left pane of the Structural
Member Catalog.

3 Expand Steel, AISC, and then I-Shaped.

4 Select Wn, Wide-Flange Shapes.

5 Right-click W8X31 in the lower right pane of the Structural
Member Catalog, and click Generate Member Style.

6 Enter W8X31, and click OK.

7 Select W1n, Wide-Flange Shapes in the tree view in the left pane.

8 Right-click W14X43 in the lower right pane of the Structural
Member Catalog, and click Generate Member Style.

9 Enter W14X43 and click OK.

10 Click  to close the Structural Member Catalog.
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Creating the Rigid Frame Tool
Use this procedure to create a rigid frame tool. Save the style for the rigid
frame in the Member Styles (Imperial).dwg located in
C:\ProgramData\Autodesk\ACA 2012\enu\Styles\Imperial.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Click Open Drawing  .

3 Open Member Styles (Imperial).dwg located in
C:\ProgramData\Autodesk\ACA 2012\enu\Styles\Imperial.

4 Expand Architectural Objects, right-click Structural Member Styles,
and click New.

5 Enter Rigid Frame for the name, and press ENTER.

6 Click OK to close the Style Manager.

7 Click OK to save changes to the Member Styles (Imperial).dwg.

8 In the title bar of the tool palettes set, click  , and then click
New Palette.

9 Enter Structural, and press ENTER.

10 Open the Design palette, select the Structural Column tool,
right-click, and click Copy.

11 Open the Structural palette, right-click, and click Paste.

12 Select the new tool, right-click, and click Properties.

13 Enter Rigid Frame for the Name.

14 Click the setting for Description.

15 Enter Creates a rigid frame, and click OK.

16 Expand Basic, and expand General.

17 Click Style location.

18 Select Browse, select the Member Styles.dwg located in
C:\ProgramData\Autodesk\ACA 2012\enu\Styles\Imperial, and click
Open.

19 Click Style and select Rigid Frame.

20 Click OK.
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Drawing the Rigid Frame Path and Converting it to a Structural
Member

Use this procedure to draw a polyline path in the shape of the rigid frame,
and then convert it with the Rigid Frame tool you created in Step 2.

1 In plan view, draw a polyline path for the rigid frame.

Drawing the rigid frame path

2 On the Structural palette, select the Rigid Frame tool.

3 Right-click, select Apply Tool Properties to ➤ Linework.

4 Select the polyline that you created in step 1.

5 Enter y (Yes) to leave the original polyline in the drawing and
press ENTER.

Creating the First Leg of the Rigid Frame
Use this procedure to create the first leg of the rigid frame by assigning a
different start and end shape to the first segment of the rigid frame member.

Creating the first leg of the rigid frame

1 Select the rigid frame.
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2 Select the column, and click Structural Member tab ➤ General

panel ➤ Edit Style drop-down ➤ Edit Style  .

3 Click Design Rules.

4 Click Show Details.

5 Select Unnamed under Component, and enter Leg 1.

6 Under Start Shape, in the Name list, select W8X31.

7 Select Start for Relative to.

8 Enter 0 for Node.

Node 0 is relative to the start point of the member path.

9 Enter 90 for Rotation.

10 Scroll to the end of the Design Rules dialog box to display the
End Shape parameters for Leg 1.

11 Under End Shape, in the Name list, select W14X43.

12 Select Start for Relative to.

13 Enter 1 for Node.

Node 1 corresponds to the vertex formed by the endpoint of the
first segment of the member path and the start point of the second
segment of the member path.

Creating the First Rafter of the Rigid Frame
Use this procedure to create the first rafter of the rigid frame by assigning a
different start and end shape to the second segment of the rigid frame member.

Creating the first rafter of the rigid frame

1 Click Add to add a second component to the structural member.

2 Select Unnamed under Component, and enter Rafter 1.

3 Under Start Shape, in the Name list, select W14X43.

4 Select Start for Relative to.
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5 Enter 1 for Node.

6 Scroll to the end of the Design Rules dialog box to display the
End Shape parameters for Rafter 1.

7 Under End Shape, in the Name list, select W8X31.

8 Select Start for Relative to.

9 Enter 2 for Node.

Creating the Second Rafter of the Rigid Frame
Use this procedure to create the second rafter of the rigid frame by assigning
a different start and end shape to the third segment of the rigid frame member.

Creating the second rafter of the rigid frame

1 Click Add to add a third component to the structural member.

2 Select Unnamed under Component, and enter Rafter 2.

3 Under Start Shape, in the Name list, select W8X31.

4 Select Start for Relative to.

5 Enter 2 for Node.

6 Scroll to the end of the Design Rules dialog box to display the
End Shape parameters for Rafter 2.

7 Under End Shape, in the Name list, select W14X43.

8 Select Start for Relative to.

9 Enter 3 for Node.

Creating the Second Leg of the Rigid Frame
Use this procedure to create the second leg of the rigid frame by assigning a
different start and end shape to the final segment of the rigid frame member.
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Creating the second leg of the rigid frame

1 Click Add to add a fourth component to the structural member.

2 Select Unnamed under Component, and enter Leg 2.

3 Under Start Shape, in the Name list, select W14X43.

4 Select Start for Relative to.

5 Enter 3 for Node.

6 Scroll to the end of the Design Rules dialog box to display the
End Shape parameters for Leg 2.

7 Under End Shape, in the Name list, select W8X31.

8 Select Start for Relative to.

9 Enter 4 for Node.

10 Click OK.

The complete rigid frame displays in your drawing.

Creating Custom Shapes for Structural Members
If you want to design a member with one or more shapes that are not available
from the Structural Member Catalog and cannot be created using the Structural
Member Style Wizard, you can use the Style Manager to create custom shapes.

When you create a custom shape, you can define three separate geometries
(Low Detail, Medium Detail, and High Detail) to accommodate the different
levels of detail in different display representations (for example, Plan Low
Detail, Plan, and Plan High Detail). The geometries for the new shape can be
set entirely from linework in the drawing area, or you can use an existing
custom shape definition as a template and edit it to redefine any of its
geometries.
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Hollow core concrete plank display representations example

Once you have created a custom shape, it is added to the list of Structural
Member Shape Definitions in the Style Manager. You can then create a new
style from the shape, or you can assign the shape to an existing structural
member style by adding it as a component in the design rules of the style.
You can also edit, copy, paste, and purge shape definitions just as you can
other styles. For more information on these operations, see Style Manager on
page 869.

Creating a Custom Shape for a Structural Member
Use this procedure to create a custom shape for a structural member based on
linework you have drawn or otherwise inserted in the drawing area.

1 In the drawing area, create three geometries to define the Plan
Low Detail, Plan, and Plan High Detail display representations of
the shape. You can draw entirely new geometries, or you can
insert geometries from existing shape definitions (see Inserting a
Custom Shape in a Drawing on page 2669.)

For Plan Low Detail, you can use lines, arcs, circles, or polylines.
For Plan and Plan High Detail, use closed polylines, splines,
ellipses, or circles. Note that these entities must not intersect.

2 Select a structural member.

3 Click Structural Member tab ➤ Member Shape panel ➤ Edit Shape

Style  .

The Style Manager is displayed with the Architectural Objects
folder open and Structural Member Shape Definitions selected.

4 Right-click Structural Member Shape Definitions, and click New
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5 In the right pane of the Style Manager, click the General tab.

6 Enter a name and description for the new shape, and then click
the Design Rules tab.

7 For Shape Geometry, select Low Detail, and then click  .

8 In the drawing area, select the line(s), arc(s), circle(s), or polyline(s)
to define the Plan Low Detail display representation for the new
shape, and then press ENTER.

9 Select an insertion point.

The low detail shape is displayed in the viewer under the Design
Rules tab.

10 For Shape Geometry, select Medium Detail, and then click  .

11 In the drawing area, select a closed polyline, spline, ellipse, or
circle to define the Plan display representation for the selected
shape designation.

12 Select an insertion point, or enter c (Centroid) or p (Previous
Point) to position the selected shape in the viewer.

13 For Shape Geometry, select High Detail, and then click  .

14 In the drawing area, select a closed polyline, spline, ellipse, or
circle to define the Plan High Detail display representation for
the shape.

15 Select an insertion point, or enter c (Centroid) or p (Previous
Point) to position the selected shape in the viewer.

2668 | Chapter 32   Structural Members



16 If you want to create a new structural member style from the

shape, click  , enter a name for the new style, and click OK.

17 Click OK to add the new shape to the list of Structural Member
Shape Definitions and dismiss the Style Manager.

The new shape can now be added to existing structural member
styles. For more information, see Adding a Shape to a Structural
Member on page 2652.

Inserting a Custom Shape in a Drawing
Use this procedure to insert one or more of the geometries defined for a custom
shape into a drawing. The geometry can then be edited or used as is to define
one of the display representations for another custom member shape you are
creating or editing.

1 Click Manage tab ➤ Style & Display panel ➤  ➤ Member

Shape  .

2 In the right pane of the Insert Member Shapes worksheet, select
a custom member shape.

3 Click one or more of the Shape Geometry check boxes.

The geometry for each selected shape designation is highlighted
in the viewer.

4 Click Insert.

5 Specify an insertion point for each of the selected shape
designations in the drawing area.

Creating Custom Shapes for Structural Members | 2669



2670



Design Utilities

2671



2672



Anchors

Anchors create links between different objects. Anchors are often used to connect an object,
such as a column or a structural element, to a grid or layout curve. Anchors can also be used
to anchor architectural objects to each other, or to linework objects, like lines and circles.

Anchors
An anchor links an AEC object to another object or to a layout curve or grid.
You can create anchors between objects and also remove anchors from objects.
AEC objects can be anchored to each other, to AutoCAD objects like lines and
circles, or to layout curves or grids.

Automatic and user-defined anchors enable you to use anchors for many
different purposes.

Automatic and User-Defined Anchors

Automatic anchors are set by the program. Certain objects are by default anchored
to other objects. For example, doors and windows are usually anchored to walls.
Curtain wall units or window assemblies might be anchored to curtain walls.
Although these anchors are inserted automatically, when you place the objects
their behavior can differ slightly. For example, a door that is anchored to a wall
can be moved to an unconnected wall. The door cannot, however, be moved
outside a wall and stand alone. To do this, you must remove the anchor between
door and wall. The anchor of a column to a column grid behaves differently:
you can move the column inside the grid, but you cannot move the column to
another grid without first removing the anchor.

User-defined anchors are manual links that you can create between two objects.
Most anchors are used with layout curves, layout grids, or volumes. You can
also attach anchors to other AEC objects or AutoCAD objects.

33
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Anchoring objects to a layout curve can be useful for positioning washbasins
along a wall or rafters along a roof. Anchoring objects to layout grids can help
you to position columns on a column grid, planters on a sidewalk grid, or tile
accents on a floor tile grid. For information about layout curves or grids, see
Using Layout Curves on page 2704 and Using Layout Grids on page 2719.

Types of User-Defined Anchors
There are six different types of anchors that you can use to attach objects:

Then…If you want to…

use object anchors.attach AEC objects to other AEC objects

use curve anchors.attach AEC objects to the base curve of
other objects, such as lines, arcs, circles,
mass elements, polylines, roofs, or walls

use leader anchors.attach objects to nodes on layout curves
or grids with leaders

use node anchors.attach objects to nodes on layout curves
or grids

use cell anchors.attach objects to cell positions on 2D layout
grids and 3D volume grids

use volume anchors.attach objects to volumes on 3D grids

Working with Object Anchors
You can use object anchors to attach an AEC object to the base curve of another
AEC object. When an AEC object is anchored to another AEC object, it will
be moved together with the anchoring object. When the anchoring object is
deleted, the anchored object will be deleted, too. Changes that are made to
the anchored object, however, will not be replicated in the anchoring object.

When the anchored object is selected, a temporary graphic displays the anchor.
The temporary anchor graphic contains a trigger grip to release the object
anchor.
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Mass element anchored to a wall

Adding Object Anchors
Use this procedure to create an object anchor between two AEC objects.

Creating an object anchor

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.
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3 Select the Object Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter ObjectAnchorAttach on the
command line.

4 Select the AEC object that should be anchored to another AEC
object, and press ENTER.

5 Select the anchoring AEC object.

An object anchor is added. When you select the anchored object,
you can see the anchoring connection.

Releasing Object Anchors
Use this procedure to release an object anchor between two AEC objects.

Releasing an object anchor

1 Select the AEC object that is anchored to another AEC object.

2 Click the Release Object Anchor grip on the anchor line.

The object anchor is removed.
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Working with Curve Anchors
You can use curve anchors to attach AEC objects to the base curve of other
AEC objects or linework, such as lines, arcs, circles, mass elements, polylines,
roofs, or walls. The movement of an object that is anchored to another object
with a curve anchor is constrained by the object to which it is anchored. Curve
anchors are best suited for attaching objects to linear objects like lines, arcs,
or walls as opposed to grids or layout volumes.

Adding Curve Anchors
Use this procedure to add a curve anchor to attach objects to the base of other
objects.

Anchoring an object to a layout curve

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.

3 Select the Curve Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter CurveAnchor on the command
line.

4 Enter at (Attach object), and select the object to be anchored.
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5 Select a point on the curve that you want to anchor the object
to.

The object is anchored to the curve at the X position. When the
object is first placed, the Y and Z positions are 0.

6 Press ENTER.

Changing the Position of Objects Anchored to Curves
Use this procedure to change the position of objects anchored to curves. You
can change the position of an anchored object relative to the curve in the X,
Y, and Z directions. You can also rotate and flip the object along its axes.

Moving an object along a layout curve in the X direction
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Moving an object along a layout curve in the Y direction
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Moving an object along a layout curve in the Z direction

NOTE The positioning of multi-view blocks assumes that the insertion point of
the multi-view block is at its midpoint.

1 Double-click the anchored object.

2 On the Properties palette, expand Basic, and expand Location on
Curve.
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TIP You can also access commands to change the position of the
anchored object from the context menu. Select the anchored object,
right-click, and click Curve Anchor. From the submenu, choose the
desired command to manipulate the anchored object in relation to
its anchoring curve.

3 Click Anchor.

4 Change the position along the X axis:

Then…If you want to…

select Start of curve, Midpoint of
curve, or End of curve for From.

change the X reference point on
the curve

enter a value for Distance.specify the X distance between the
reference point on the curve and
the anchored object

select Start edge of object, Center
of object, or End edge of object for
To.

select from which point on the
anchored object the X distance to
the curve is measured

5 Change the position along the Y axis:

Then…If you want to…

select Left edge of curve width,
Center of curve width, or Right
edge of curve width for From.

change the Y reference point on the
curve

enter a value for Distance.specify the Y distance between the
reference point on the curve and
the anchored object

select Front of object, Center of
object, or Back of object for To.

select from which point on the
anchored object the Y distance to
the curve is measured

6 Change the position along the Z axis (vertical):

Then…If you want to…

select Bottom of curve height,
Center of curve height, or Top of
curve height for From.

change the Z reference point on the
curve
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Then…If you want to…

enter a value for Distance.specify the Z distance between the
reference point on the curve and
the anchored object

select Bottom of object, Center of
object, or Top of object for To.

select from which point on the
anchored object the Z distance to
the curve is measured

7 To change the rotation of the anchored object, enter values for
the X and Z rotation.

8 To flip the object along one of the axes, select Flip X, Flip Y, or
Flip Z.

9 Click OK.

Anchoring Objects to New Curves
Use this procedure to anchor objects to new curves. You can anchor an object
to a new object without first releasing the previous anchor. The new anchor
is of the same type as the previous one; in this case, it is a curve anchor.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.

3 Select the Curve Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter CurveAnchor on the command
line.

4 Enter s (Set curve), and select anchored objects.

NOTE You can select only AEC objects here.

5 Press ENTER.

6 Select a new object to anchor the object to.

NOTE You can select AEC objects and AutoCAD objects here.
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7 Press ENTER.

Working with Leader Anchors
You can use leader anchors to anchor objects to nodes on layout curves or
grids with leaders. The movement of the anchored object is constrained by
the leader on the anchor.

For information about creating layout curves or grids and nodes, see Using
Layout Curves on page 2704 and Using Layout Grids on page 2719.

Adding Leader Anchors
Use this procedure to add leader anchors to your drawing. An object can be
anchored to only one node at a time. When you try to anchor it to a second
node, the object is released from the first node. You can, however, anchor
any number of objects to a single layout node.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.

3 Select the Leader Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter LeaderAnchor on the command
line.

4 Enter a (Attach object), select the object to be anchored, and then
specify a point on or near a node on a layout curve, layout grid,
or volume grid.

The object is anchored to the node that you selected. By default,
the leader anchor is created at a direction of 0 from the node and
has first and second extensions of 1 inch (25.4 mm). These
extensions are measured from the node to the center of the
anchored object.

5 Press ENTER.
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Changing the Position of Objects Anchored to Layout Nodes
with Leader Anchors

Use this procedure to change the position of objects anchored to layout nodes
with leader anchors. You can change the coordinate system, orientation, and
rotation of an object anchored to a layout node. You can also define offsets
from the node.

1 Double-click the object anchored to a layout node.

2 On the Properties palette, expand Basic, and expand Location
from Node.

TIP You can also access commands to change the position of the
anchored object from the context menu. Select the anchored object,
right-click, and click Leader Anchor. From the submenu, choose the
desired command to manipulate the anchored object in relation to
its anchoring node and leader.

3 Click Anchor.

4 Specify changes in the position or orientation of anchored objects:

Then…If you want to…

specify insertion offset values for the
X, Y, or Z position.

specify an offset from the object to
the node

select Center on Node.anchor the object to the center of
the node

select Use Node Coordinate System.have the anchored object use the
coordinate system of the node

specify X, Y, or Z normals for the
anchored object.

not have the anchored object use
the coordinate system of the node

specify values for the X, Y, or Z rota-
tion angles.

change the rotation angle of the
anchored object

select Flip X, Flip Y, or Flip Z.flip the object along the X, Y, or Z
axes

specify a value for Angle to Node.change the angle of the leader to
the node
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Then…If you want to…

enter an offset value for First Exten-
sion.

change the offset of the leader start
grip from the center of the base
curve of the layout node

enter an offset value for Second Ex-
tension.

NOTE By default the leader ex-
tensions are slightly offset so as
not to overlap the leader grip
with the object location grip.

change the offset of the leader end
grip from the center of the base
curve of the anchored object

5 Click OK.

Grip-Editing Leaders
Use this procedure to grip-edit leaders. A leader anchor connects an object to
a layout node with a leader between the two. You can change the length and
shape of the leader.

A leader consists of one segment or several segments. You can change the
leader shape by grip-editing the object.

You can use grips to add segments to existing leaders.

1 Select the anchored object.

2 Move the leader grip to move the leader in the appropriate
direction.

3 After you release the leader, select the anchored object again.

An additional leader grip is added at the point from which the
leader originally started.

4 Move the leader grip at the start of the leader line to add another
segment to the leader.

5 Repeat this procedure until the leader has all the segments you
need.

You can later edit the leader in the same way you edit an AutoCAD
polyline.
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Extending Leaders
Use this procedure to extend the leader line beyond the first and last grip
points on the leader line.

1 Double-click the anchored object.

2 On the Properties palette, expand Basic, and expand Location
from Node.

3 Click Anchor.

4 Edit the leader line:

Then…If you want to extend…

in the First Extension field, enter the
extension value.

the start point of the leader line

in the Second Extension field, enter
the extension value.

the endpoint of the leader line

5 Click OK.

Copying Objects to All Layout Nodes
Use this procedure to copy objects to all layout nodes. You can select an AEC
object and, instead of manually anchoring it to a layout node, you can copy
the object and anchor one copy to each node on a layout curve or grid.

TIP If you want the leader to be displayed in the same way at every node, first
anchor the object to a single node. Adjust the leader attributes (direction, extension,
or properties), and then use the Copy to Nodes option. Next, select the object
that is anchored to the single node, and select the layout curve or grid.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.

3 Select the Leader Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter LeaderAnchor on the command
line.
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4 To copy the anchored object to every node on the layout curve
or grid, enter c (Copy to Nodes).

5 Select the object that you want to copy and anchor to every node
on the layout curve or grid.

6 Select the layout curve or grid.

If an existing object is anchored to any of the nodes, you are
prompted to specify whether you want to skip nodes that already
have something anchored to them. Enter y to avoid duplicate
anchored objects on those nodes.

Working with Node Anchors
You can use node anchors to attach objects to nodes on layout curves or grids.
Anchoring objects to a layout curve might be useful for positioning washbasins
along a wall or rafters along a roof. Anchoring objects to layout grids might
help you to position columns on a column grid, planters on a sidewalk grid,
or tile accents on a floor tile grid.

WARNING When you change the position of an object that is anchored to a curve,
the anchored object needs to stay on the curve. Keeping the association between
the object and the node prevents all objects that are being moved from attaching
to the same node.

Adding Node Anchors
Use this procedure to add node anchors. You can add as many node anchors
in your drawing as you have layout nodes. An individual object can be
anchored to only one layout node. If you try to anchor an object to a second
node, the first anchor is released. You can, however, anchor several objects
to the same layout node and edit them individually.
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Anchoring an object to a layout curve node

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.

3 Select the Node Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter NodeAnchor on the command
line.

4 Enter a (Attach object), and select the object to be anchored.

5 Specify a point on or near a node on a layout curve or grid.

6 Press ENTER.

Changing the Position of Objects Anchored to Layout Nodes
with Node Anchors

Use this procedure to change the position of objects anchored to layout nodes
with node anchors. You can change the coordinate system and orientation
of an object anchored to a layout node. You can also define offsets from the
node.

1 Double-click the anchored object.

2 On the Properties palette, expand Basic, and expand Location
from Node.
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TIP You can also access commands to change the position of the
anchored object from the context menu. Select the anchored object,
right-click, and click Node Anchor. From the submenu, choose the
desired command to manipulate the anchored object in relation to
its anchoring node.

3 Click Anchor.

4 Change the position or orientation of the anchored object:

Then…If you want to…

specify offset values for the X, Y, or
Z position.

specify an offset from the object to
the node

select Center on Node.anchor the object to the center of
the node

select Use Node Coordinate System.have the anchored object use the
coordinate system of the node

specify X, Y, or Z normals for the
anchored object.

not have the anchored object use
the coordinate system of the node

select Flip X, Flip Y, or Flip Z.flip the object along the X, Y, or Z
axes

5 Click OK.

Anchoring Objects to Different Nodes
Use this procedure to anchor objects to different nodes. You can attach an
anchored object to another node on the same layout curve or grid, or to
another layout curve or grid altogether.
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Moving an anchored object to another layout curve node

NOTE If you want to move an anchored object to a different node on the same
layout curve or grid, you can also drag the object to the node.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.

3 Select the Node Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter NodeAnchor on the command
line.

4 Enter s (Set node), and select the anchored object.

5 Press ENTER.

6 Select the node you want to anchor the object to.

7 Press ENTER.

Copying Objects to All Layout Nodes
Use this procedure to copy objects to all layout nodes. You can select an AEC
object and, instead of manually anchoring it to a layout node, you can copy
the object and anchor one copy to each node on the layout curve or grid.
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Copying an object to all layout curve nodes

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.

3 Select the Node Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter NodeAnchor on the command
line.

4 To copy the object to every node on the layout curve or grid, enter
c (Copy to each node).

5 Select the object that you want to copy and anchor to every node
on the layout curve or grid.

6 Select the layout curve or grid.

If an object is already anchored to any of the nodes, you are
prompted to specify whether you want to skip nodes that already
have something anchored to them. Enter y (Yes) to avoid duplicate
anchored objects on those nodes.

Working with Cell Anchors
A cell is a subdivision of a layout grid or volume grid. A cell anchor attaches
objects to cell positions on layout grids and volume grids. When an object is
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anchored to a cell, the object is resized to fit the cell size. When the grid or
volume itself is resized, you can decide whether the anchored object is updated
accordingly or remains its original size.

Adding Cell Anchors
Use this procedure to add cell anchors. You can add cell anchors to objects to
connect them to cells in layout grids and volume grids.

Anchoring an object to a layout grid cell

NOTE There is no rule that determines which cell the object attaches to when
you anchor it. You can turn on the Node display component to display the cell
nodes of the layout grid or volume for easier cell selection. You can also move the
object after you anchor it to the layout grid or volume.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.

3 Select the Cell Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter CellAnchor on the command line.

4 Enter a (Attach object), and select the object to be anchored.

5 Specify a point on or near a cell of a layout grid or volume grid.

The object is automatically scaled to fill the entire cell.

6 Press ENTER.
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Changing the Position and Size of Objects Anchored to Layout
Cells

Use this procedure to change the position and size of objects anchored to
layout cells. You can change the coordinate system and orientation of an
object anchored to a layout cell. You can also define insertion and size offsets
and indicate whether the object should be resized when the cell is resized.

1 Double-click the anchored object.

2 On the Properties palette, expand Basic, and expand Location in
Cell.

TIP You can also access commands to change the position of the
anchored object from the context menu. Select the anchored object,
right-click, and click Cell Anchor. From the submenu, choose the
desired command to manipulate the anchored object in relation to
its anchoring grid cell.

3 Click Anchor.

4 Change the position or orientation of anchored objects:

Then…If you want to…

specify offset values for the X, Y, or
Z position.

specify an offset from the object to
the cell

select Center on Cell.anchor the object to the center of
the cell

select Use Cell Coordinate System.have the anchored object use the
coordinate system of the cell

clear Use Cell Coordinate System,
and specify X, Y, or Z normals for
the anchored object.

not have the anchored object use
the coordinate system of the cell

select Flip X, Flip Y, or Flip Z.flip the object along the X, Y, or Z
axes
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5 Specify how an anchored object is resized to fit the edges of the
cell:

Then…If you want to…

select Apply Resize.resize the object every time the cell
is resized

clear Apply Resize.not resize object every time the cell
is resized

enter an appropriate negative value
for Size Offset.

specify a distance between the
anchored object and the cell

enter an appropriate positive value
for Size Offset.

extend the anchored object beyond
the cell edges

6 Click OK.

Anchoring Objects to a Different Cell
You can attach an anchored object to another cell in the same layout grid or
volume grid, or to another grid altogether.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.

3 Select the Cell Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter CellAnchor on the command line.

4 Enter se (Set cell), and select the object.

5 Press ENTER.

6 Select the cell you want to anchor the object to.

The object is moved to the new cell. If the new cell is different in
size from the original one, the object is resized accordingly.

NOTE You can also drag the object if you want to move an anchored
object to a different cell on the same layout grid or volume grid.
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Copying Objects to All Layout Cells
Use this procedure to copy objects to all layout cells. You can select an AEC
object and, instead of manually anchoring it to a layout cell, you can copy
the object and anchor one copy to each cell on the layout grid or volume grid.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.

3 Select the Cell Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter CellAnchor on the command line.

4 To copy the anchored object to every cell in the layout grid or
volume grid, enter c (Copy to each cell).

5 Select the object.

6 Select the layout grid or volume grid that you want to copy and
anchor the object to.

If an object is already anchored to any of the cells, you are
prompted to specify whether you want to skip cells that already
have something anchored to them. Enter y (Yes) to avoid duplicate
anchored objects appear in those cells.

Working with Volume Anchors
You can use volume anchors to attach objects to volumes in 3D volume grids.
The movement of an object that is anchored to a volume grid is constrained
by that volume grid.

When an object is anchored to a volume inside a volume grid, the object is
resized to fit the volume size. When the volume itself is resized, you can decide
whether the anchored object is updated accordingly or remains its original
size.

Adding Volume Anchors
Use this procedure to add volume anchors. You can add volume anchors to
objects to connect them to volume grids.
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Anchoring an object to a volume grid

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.

3 Select the Volume Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter VolumeAnchor on the command
line.

4 Enter a (Attach object), and select the object to be anchored.

5 Specify a point on or near a volume in a volume grid.

The object is scaled to fill the entire volume.

6 Press ENTER.

Changing the Position and Size of Objects Anchored to Volumes
Use this procedure to change the position and size of objects anchored to
volumes. You can change the coordinate system and orientation of an object
anchored to a volume. You can also define insertion and size offsets and
indicate whether the object should be resized when the volume is resized.

1 Double-click the anchored object.
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2 On the Properties palette, expand Basic, and expand Location in
volume.

TIP You can also access commands to change the position of the
anchored object from the context menu. Select the anchored object,
right-click, and click Volume Anchor. From the submenu, choose the
desired command to manipulate the anchored object in relation to
its anchoring volume grid.

3 Click Anchor.

4 Change the position or orientation of anchored objects:

Then…If you want to…

specify offset values for the X, Y, or
Z position.

specify an offset from the object to
the volume

select Center on Node.anchor the object to the center of
the volume

select Use Node Coordinate System.have the anchored object use the
coordinate system of the volume
grid

clear Use Node Coordinate System,
and specify X, Y, or Z normals for
the anchored object.

not have the anchored object use
the coordinate system of the
volume grid

select Flip X, Flip Y, or Flip Z.flip the object along the X, Y, or Z
axes

5 Specify how an anchored object is resized to fit the edges of the
volume:

Then…If you want to…

select Apply Resize.resize the object every time the
volume is resized

clear Apply Resize.not resize the object every time the
volume is resized

enter an appropriate negative value
for Size Offset.

specify a distance between the
anchored object and the volume
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Then…If you want to…

enter an appropriate positive value
for Size Offset.

extend the anchored object beyond
the volume edges

6 Click OK.

Anchoring Objects to a Different Volume
Use this procedure to anchor objects to a different volume. You can attach an
anchored object to another volume in the same volume grid, or to another
volume grid.

NOTE If you want to move an anchored object to a different volume on the same
volume grid, you can also drag it there.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.

3 Select the Volume Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter VolumeAnchor on the command
line.

4 Enter s (Set volume), and select the anchored object.

5 Press ENTER.

6 Select the volume you want to anchor the object to.

The object is moved to the new volume. If the new volume is
different in size from the original one, the object is resized
accordingly.

Copying Objects to All Layout Volumes
Use this procedure to copy objects to all layout volumes. You can select an
AEC object and, instead of manually anchoring it to a volume, you can copy
the object and anchor one copy to each volume on the volume grid.
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1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 Navigate to Stock Tool Catalog  ➤ Parametric Layout & Anchoring
Tools.

3 Select the Volume Anchor tool, and drag it to the workspace.

NOTE Alternatively you can enter VolumeAnchor on the command
line.

4 To copy the anchored object to every volume in the volume grid,
enter c (Copy to each volume).

5 Select the object that you want to copy and anchor to every
volume in the volume grid.

6 Select the volume grid.

If an object is already anchored to any of the volumes, you are
prompted to specify whether you want to skip volumes that
already have something anchored to them. Enter y (Yes) to avoid
duplicate anchored objects on those volumes.

Releasing and Positioning Anchored Objects
You can release and position anchored objects. Release an anchored object
from another object to remove the relationship between the objects. Position
an anchored object to offset it from the object it is anchored to.

Releasing Anchored Objects
Use this procedure to release objects from anchors and remove the anchoring
relationship. Any anchored object can be released, including a railing that is
anchored to a stair object or a window that is anchored to a wall.

■ Right-click the anchored object, and click <Type> Anchor ➤ Release.

Positioning Anchored Objects
Use this procedure to position anchored objects. You can position an object
with anchors to offset it from the object that it is anchored to.
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1 Right-click the anchored object, and change the position of the
anchored object:

Then…If you want to…

click Set X Position.specify the X position

click Set Y Position.specify the Y position

click Set Z Position.specify the Z position

click Set Anchored End.specify the end position

click Set Rotation.specify the rotation

click Flip X.flip the X position

click Flip Y.flip the Y position

click Flip Z.flip the Z position

2 Enter an XYZ coordinate value for the desired offset position.

Entering a coordinate for the offset distance is equivalent to setting
all three of the individual position offsets.

Creating an Anchor Tool
Use this procedure to create an anchor tool and add it to a tool palette. You
may want to create your own anchor tools if you are placing multiple anchors
of specific styles with additional properties that you want to be the same every
time you add an anchor of each type.

You can use any of the following methods to create an anchor tool:

■ Drag a copy of a tool from another palette to the current palette, and then
customize the properties of the new tool.

■ Copy an existing tool in the current palette, and then customize the
properties of the new tool.

■ Drag a tool from the Content Browser to a tool palette, and then customize
the properties of the new tool.

1 Open the tool palette where you want to create a tool.
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2 Create the tool:

Then…If you want to…

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the palette where you want
to add the tool, right-click, and click
Paste.

click Home tab ➤ Build pan-

el ➤ Tools drop-down ➤ Content

copy a tool from the Content
Browser

Browser  .open the Content
Browser, and locate the tool you
want to copy. Position the cursor
over the i-drop handle, and drag
the tool to the tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

6 Click OK.
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Layout Curves and Grids

Three types of layout objects help you to position objects relative to each other: layout curves,
two-dimensional (2D) layout grids, and three-dimensional (3D) layout volumes (also called
volume grids). Each type of layout object has anchors to which you can attach objects. All
use nodes as anchor points. Layout grids and layout volumes also provide cells as anchoring
points for cell anchors and volume anchors. For more information, see Anchors on page 2673.

Layout Curves and Grids
Three types of layout objects help you to position objects relative to each other:
layout curves, two-dimensional (2D) layout grids, and three-dimensional (3D)
layout volumes (also called volume grids). Each type of layout object has anchors
to which you can attach objects. All use nodes as anchor points. Layout grids
and layout volumes also provide cells as anchoring points for cell anchors and
volume anchors. For more information, see Anchors on page 2673.

Layout Curve

By defining an object as a layout curve and placing nodes along the curve, you
can position objects precisely along a path. Layout curves are useful for
positioning wash basins along a wall or rafters along a roof.

Layout Grid

A layout grid is an arrangement of rectangular or radial spaces, called bays, that
are delineated with parallel or radial lines. Use a two-dimensional (2D) layout
grid to position objects in a grid pattern. Anchoring objects to layout grids
might help you to position planters in a sidewalk grid, or tile accents in a floor
tile grid.
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Layout Volume

A layout volume (also called a volume grid) is a three-dimensional (3D)
arrangement of rectangular spaces. Use three-dimensional (3D) layout volumes
to position objects on a multilevel grid. Changing the size of a layout volume
changes the spacing of objects attached to that grid and can also change the
size and height of objects attached to that grid.

Using Layout Curves
Use a layout curve to anchor objects along a path. You can define the following
objects as layout curves:

■ Walls

■ Curtain walls

■ Window assemblies

■ Spaces

■ Mass elements

■ Roofs

■ Lines

■ Arcs

■ Circles

■ Ellipses

■ Polygons

■ Polylines

■ Splines

Layout curves are best suited for objects with linear geometry, such as polylines,
walls, or splines. If you need nodes on a two-dimensional (2D) object, consider
using a layout grid instead.
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Creating a Layout Curve Tool
Use this procedure to create a layout curve tool and add it to a tool palette.
You may want to create your own layout curve tools if you are placing multiple
layout curves of a specific style and they all have the same properties.

1 Open the tool palette where you want to add the tool.

2 Create the tool:

Then…If you want to…

select the object, and drag it to the
tool palette.

create a tool from a layout curve in
the drawing

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the palette where you want
to add the tool, right-click, and click
Paste.

open the Content Browser, and
locate the tool you want to copy.

copy a tool from the Content
Browser

Position the cursor over the i-drop
handle, and drag the tool to the
tool palette.

3 Right-click the new tool, and click Properties.

4 For Name, enter the name you want displayed for this tool’s
tooltip. This name will also be displayed with the tool if it is
published to a catalog in the Content Browser.

5 For Description, click in the text box, and then enter the
description you want displayed for this tool’s tooltip. This
description will also be displayed with the tool if it is published
to a catalog in the Content Browser.

6 Expand Basic, and expand General.

7 Under General, click the Description text box, enter a description
of the tool, and click OK.

8 For Layer key, click the text box, select a layer key, and click OK.
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9 For Layer overrides, click the text box, select a layer key override,
and click OK.

10 Under Dimensions, specify a Layout type.

11 Specify the number of nodes, or enter a spacing value.

12 Click OK.

Adding Layout Curves
Use this procedure to define an object as a layout curve. The spacing between
anchor nodes determines the spacing between objects that you attach to the
layout curve, even if you change the geometry of the layout curve.

The following spacing options are available:

■ Manual: You specify the position of each node along the layout curve.

Manually placing a node on a layout curve

■ Repeat: You specify equidistant spacing between nodes along the layout
curve. The number of anchor nodes is determined by the length of the
layout curve. As the length of the curve changes, nodes are added or
subtracted accordingly. The spacing of the nodes remains fixed.
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Placing nodes at repeat spacing on a layout curve

■ Space Evenly: You specify the number of nodes along the curve. The space
between nodes is determined by the length of the layout curve. As the
length of the curve changes, the spacing between nodes is lengthened or
shortened accordingly. The number of nodes remains fixed.
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Placing nodes at even spacing on a layout curve

1 Open the tool palette that contains the layout curve tool you
want to use, and select the tool.

TIP You may have to scroll to display the desired tool. After selecting
it, you can move or hide the Properties palette to expose more of the
drawing area.

If there are no layout curve tools available on tool palettes in the
workspace, you can use the Content Browser to access the Stock
Tool catalog, which contains a layout curve tool under Parametric
Layout and Anchoring Tools. You can add this tool to any tool
palette. For more information, see Content Browser Overview on
page 129.

2 Select the object to define as a layout curve.
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3 Place nodes along the layout curve:

Then…If you want to…

press ENTER. Enter the number of
nodes, and specify the locations of

Place nodes at locations that you
specify

nodes by selecting them or by en-
tering distances from the start point
of the curve.

enter r (Repeat). Specify the start
and end offsets of the first and last

Repeat nodes at fixed intervals
along the curve

nodes, and specify the spacing
between nodes.

enter s (Space evenly). Specify the
start and end offsets of the first and

Space a fixed number of nodes
along the curve

last nodes, and specify the number
of nodes.

Adding Nodes to Layout Curves
Use this procedure to add nodes to layout curves.

Layout curve with evenly spaced node grips

You can add nodes only to those layout curves that have manually spaced or
evenly spaced nodes. Layout curves with nodes at fixed repeated spacing
cannot be changed without changing either the length of the curve or the
spacing of the first node. For more information, see Changing the Spacing
Mode of Layout Curves on page 2714.
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Adding a node to a layout curve using grips

1 Select the layout curve by selecting one of the node anchors.

2 Click an Add Node grip.

Alternatively you can click Layout Curve tab ➤ Modify

panel ➤ Add Node  .

■ If you have added a node to a layout curve with manually
spaced nodes, the new node is inserted at the specified
position. The position of the other nodes remains unchanged.

■ If you have added a node to a layout curve with evenly spaced
nodes, the new node is added and all nodes are recalculated,
so that they are evenly spaced again.

3 Right-click, and click Deselect All to turn off grips.

Removing Nodes from Layout Curves
Use this procedure to remove nodes from layout curves.

You can remove nodes from only those layout curves that have manually
spaced or evenly spaced nodes. Layout curves with nodes at fixed repeated
spacing cannot be changed without changing either the length of the curve
or the spacing of the first node.
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Removing a node from a layout curve using grips

1 Select the layout curve by selecting one of the node anchors.

2 Click a Remove Node grip.

Alternatively, you can click Layout Curve tab ➤ Modify

panel ➤ Remove Node  .

■ If you have removed a node from a layout curve with manual
nodes, the node is removed from the specified position. The
position of the other nodes remains unchanged.

■ If you have removed a node from a layout curve with evenly
spaced nodes, the node is removed from the specified position
and the remaining nodes are recalculated, so that they are
evenly spaced again.

3 Right-click, and click Deselect All to turn off grips.

Changing the Offsets of Layout Curves
Use this procedure to change the start and end offsets of layout curves.

You can change the offsets for evenly spaced and repeated layout curves. By
repositioning the offset grips, you can move the start or end offset to any
position on the layout curve. You cannot extend an offset beyond the bounds
of the curve.
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Changing the start offset node location of a layout curve using grips

1 Select a layout curve by selecting one of the node anchors.

2 Click an Offset grip.

3 Move the grip to the desired location, and click once; or enter a
value on the command line, and press ENTER.

4 Right-click, and click Deselect All to turn off grips.

Changing the Node Spacing of a Layout Curve
Use this procedure to change the spacing between nodes on a layout curve
with fixed repeated spacing.

Layout curve with evenly spaced node
grips
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Changing the node spacing of a layout curve using grips

1 Select a layout curve by selecting one of the node anchors.

2 Click the Spacing grip.

The Spacing grip is attached to the first node of the layout curve.

3 Move the grip to the desired location, and click once; or enter a
value on the command line, and press ENTER.

If you move the grip to the left to decrease the space between
nodes, the number of nodes increases. If you move the grip to
the right to increase the space between nodes, the number of
nodes decreases.

4 Right-click, and click Deselect All to turn off grips.

Changing the Node Positions on a Layout Curve
Use this procedure to change the positions of nodes on a layout curve with
manual node placement.
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Changing a node position on a layout curve using grips

1 Select a layout curve by selecting one of the node anchors.

2 Click a Node Distance grip.

3 Move the grip to the desired location, and click once; or enter a
value on the command line, and press ENTER.

4 Right-click, and click Deselect All to turn off grips.

Changing the Spacing Mode of Layout Curves
Use this procedure to change how modes are positioned along a layout curve.
For more information, see Adding Layout Curves on page 2706.

For example, you can change the mode so that a curve with manually spaced
nodes becomes a curve with evenly spaced nodes. If you want to add nodes
to a layout curve with a fixed number of nodes, you must first convert the
layout curve to manually spaced or evenly spaced mode.

You can also change the layout mode on the Properties palette.

1 Select the layout curve by selecting one of the node anchors.

2 Click Layout Curve tab ➤ Modify panel ➤ Layout Mode  .
Alternatively, you can right-click, and click Layout Mode.

3 Select the desired mode, and press ENTER.

■ If you are changing a layout curve with manually spaced nodes
to a curve with nodes at fixed repeated spacing, you are
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prompted for start and end offsets, and the distance between
nodes. If there are too few nodes on the curve to fill it, new
nodes are created at the specified distance.

■ If you are changing a layout curve with manually spaced nodes
to a curve with evenly spaced nodes, you are prompted for
start and end offsets for the curve. The existing nodes are
distributed evenly on the curve.

■ If you are changing a curve with nodes placed at a fixed
repeated spacing value to a curve with manually spaced nodes,
there is no visible change. However, the nodes have been
converted to manual nodes, so that you now can add nodes
to and remove nodes from the curve.

■ If you are changing a curve with nodes placed at a fixed
repeated spacing value to a curve with evenly spaced nodes,
you are prompted for start and end offsets. The existing nodes
are then recalculated and distributed evenly. You can now add
nodes to and remove nodes from the curve.

■ If you are changing a curve with evenly spaced nodes to a
curve with manually spaced nodes, there is no visible change.
If you change the curve, however, the nodes remain fixed and
are no longer redistributed evenly.

■ If you are changing a curve with evenly spaced nodes to a
curve with nodes placed at fixed repeated spacing, you are
prompted for start and end offsets, and the distance between
nodes. If there are too few nodes on the curve to fill it, new
nodes are created at the specified distance.

Switching Layout Curves
Use this procedure to move a layout curve from one object to another object.
The layout mode is retained in this action. If the layout curve was inserted
originally with evenly spaced nodes, the nodes remain evenly spaced on the
new object.

If you switch the curve to an object that already contains a layout curve, the
two curves are not merged. They are still separate objects and can be edited
separately.
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Switching nodes from one layout curve to another

1 Select the layout curve by selecting one of the node anchors.

2 Click Layout Curve tab ➤ Modify panel ➤ Switch Curve  .
Alternatively, you can right-click, and click Switch Curve.

3 Select the object to which to attach the layout curve.

The layout curve is moved to the new object.

Changing the Display Properties of Layout Curves
Use this procedure to change the display properties of the nodes on a layout
curve. Display properties you can change include the following:

■ Visibility (display component is on or off)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale
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■ Node size

1 Select the layout curve that you want to change, right-click, and
click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 Click the Layer/Color/Linetype tab.

5 Select the component to change, and select a different setting for
the property.

6 Click OK twice.

Changing the Node Radius for a Layout Curve
Use this procedure to change the node radius for a layout curve by editing its
display properties.

1 Double-click the layout curve you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all layout curves in the drawing,
select Drawing default setting.

5 If necessary, expand Object Display Properties ➤ Advanced.

6 Click the value for Node radius, and enter a new value.

(Alternatively, you can click  and specify 2 points in the
drawing area to set the new radius.)

You can also access and modify the node radius property through the layout
curve’s context menu, as follows:

1 Select the layout curve, right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.
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The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 In the Display Properties dialog, click the Other tab, and then
change the radius as needed.

5 Click OK twice.

Attaching Hyperlinks, Notes, or Files to a Layout Curve
Use this procedure to attach hyperlinks, notes, or files to a layout curve. You
can also edit hyperlinks and notes, and edit or detach reference files from a
layout curve.

1 Select the layout curve to which you want to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

For more information, see “Add Hyperlinks to a Drawing” in
AutoCAD help.

4 Click OK.

5 To add a note, click the setting for Notes, and enter the note.

6 Click OK.

7 To add a reference file, click the setting for Reference documents,
and attach, edit, or detach a reference file:

Then…If you want to…

click  , select a file, and click OK.
attach a reference file

select the file, enter the description,
and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file
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8 Click OK.

Using Layout Grids
Use a layout grid to arrange objects in a 2D grid pattern. You can create a
radial or rectangular layout grid. You can anchor objects to the intersection
of the grid lines (node anchors) or to the center of the grid bays (cell anchors).
For more information about anchors, see Working with Node Anchors on
page 2687 and Working with Cell Anchors on page 2691.

NOTE By default, the markers for node anchors and cell anchors are not displayed
when you insert a grid. To display them, turn these components on in the Entity
Display. For information about turning on display components, see Changing the
Display Properties of Layout Curves on page 2716.

Changing the size of a grid changes the spacing of objects anchored to that
grid and can also change the size of objects anchored to that grid. You can
use a clipping profile to define a boundary around a layout grid or to make a
hole in a layout grid. The layout grid is not displayed outside a boundary or
inside a hole. Use closed polylines to define the boundary or hole. For example,
you can use a clipping profile to cut a hole in a reflected ceiling grid.

Creating a Layout Grid Tool
Use this procedure to create a 2D layout grid tool and add it to a tool palette.
You may want to create your own layout grid tools if you are placing multiple
layout grids of a specific style and they all have the same properties.

1 Open the tool palette where you want to add the tool.

2 Create the tool:

Then…If you want to…

select the object, and drag it to the
tool palette.

create a tool from a layout grid in
the drawing

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the tool palette where you
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Then…If you want to…

want to add the tool, right-click,
and click Paste.

open the Content Browser, and
locate the tool you want to copy.

copy a tool from the Content
Browser

Position the cursor over the i-drop
handle, and drag the tool to the
tool palette.

3 Right-click the new tool, and click Properties.

4 For Name, enter the name you want displayed for this tool’s
tooltip. This name will also be displayed with the tool if it is
published to a catalog in the Content Browser.

5 For Description, click in the text box, and then enter the
description you want displayed for this tool’s tooltip. This
description will also be displayed with the tool if it is published
to a catalog in the Content Browser.

6 Expand Basic, and expand General.

7 Under General, click the Description text box, enter a description
of the tool, and click OK.

8 For Layer key, click the text box, select a layer key, and click OK.

9 For Layer overrides, click the text box, select a layer key override,
and click OK.

10 Expand Dimensions.

11 Click Yes to specify the dimension of the grid on the drawing
screen as you are creating it.

12 Click No to specify numerical values for the Width, Depth, and
Height of the grid.

13 Expand X Axis, and specify a Layout type, a Bay size, and Start
and End offsets.

14 Expand Y Axis, and specify a Layout type, a Bay size, and Start
and End offsets.

15 Click OK.

Adding Radial Layout Grids
Use this procedure to create a 2D radial layout grid.
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Radial layout grid parameters

1 Open the tool palette that contains the layout grid 2D tool you
want to use, and select the tool.

TIP You may have to scroll to display the desired tool. After selecting
it, you can move or hide the Properties palette to expose more of the
drawing area.

If there are no layout grid 2D tools available on tool palettes in
the workspace, you can use the Content Browser to access the
Stock Tool catalog, which contains a layout grid 2D tool under
Parametric Layout and Anchoring Tools. You can add this tool to
any tool palette. For more information, see Content Browser
Overview on page 129.

2 On the Properties palette, expand Basic, and expand General.

3 For Shape, select Radial.

4 Specify the boundary object attached to the grid, if necessary.
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5 Expand Dimensions, and select Yes to specify dimensions on the
drawing screen or No to specify dimensions on the Properties
palette.

6 On the Properties palette, enter the width and the angular
dimension of the grid.

7 Expand X Axis.

8 For Layout type, select Space evenly, and enter a value for Number
of bays, or select Repeat, and enter a value for Bay size.

9 Enter a value for Inside radius.

10 Enter a value for End offset.

11 Expand Y Axis.

12 For Layout type, select Space evenly, and enter a value for Number
of bays, or select Repeat, and enter values for Bay angle, Start angle
offset, and End angle offset.

13 Specify an insertion point in the drawing for the center of the
radial layout grid.

14 Specify the rotation of the radial grid about the insertion point.

Changing Radial Layout Grids
Use this procedure to change the angle or size of a radial layout grid. You can
also change the number and size of the grid bays.

If you use grips to stretch a radial layout grid, the behavior of the radial layout
grid depends on the spacing type of each axis. The overall size of the grid
“jumps” in directions that are specified to use a certain bay size with repeat
spacing because the exact bay size is maintained. The overall size changes in
directions that are specified to be evenly spaced or manually spaced.

1 Double-click one or more 2D layout grids.

2 On the Properties palette, expand Basic, expand General.

3 Expand Dimensions and enter new values for the width and angle.

4 Expand X Axis, and depending on the layout type, enter new
values for Number of bays, Bay size, Inside radius, and End offset.

5 Expand Y Axis, and depending on the layout type, enter new
values for Number of bays, Bay angle, Start angle offset, and End
angle offset.
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Adding Rectangular Layout Grids
Use this procedure to add rectangular layout grids.

Rectangular layout grid parameters

1 Open the tool palette that contains the layout grid 2D tool you
want to use, and select the tool.

TIP You may have to scroll to display the desired tool. After selecting
it, you can move or hide the Properties palette to expose more of the
drawing area.

If there are no layout grid 2D tools available on tool palettes in
the workspace, you can use the Content Browser to access the
Stock Tool catalog, which contains a layout grid 2D tool under
Parametric Layout and Anchoring Tools. You can add this tool to
any tool palette. For more information, see Content Browser
Overview on page 129.

2 On the Properties palette, expand Basic, and expand General.

3 For Shape, select Rectangular.
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4 Specify the boundary object attached to the grid, if necessary.

5 Expand Dimensions, and select Yes to specify dimensions on the
drawing screen or No to specify dimensions on the Properties
palette.

6 Enter values for the X-Width and Y-Depth properties.

7 Expand X Axis.

8 For Layout type, select Space evenly, and enter values for Number
of bays and Start and End offset, or select Repeat, and enter values
for Bay size and Start and End offset.

9 Expand Y Axis.

10 For Layout type, select Space evenly, and enter values for Number
of bays and Start and End offset, or select Repeat, and enter values
for Bay size and Start and End offset.

11 Specify an insertion point in the drawing for the lower-left corner
of the rectangular layout grid.

12 Specify the rotation of the rectangular grid about the insertion
point.

Changing Rectangular Layout Grids
Use this procedure to change the angle or size of a rectangular layout grid.
You can also change the number and size of the grid bays.

If you use grips to stretch a rectangular layout grid, the behavior of the
rectangular layout grid depends on the spacing type of each axis. The overall
size of the grid “jumps” in directions that are specified to use a specific bay
size with repeat spacing because the exact bay size is maintained. The overall
size changes in directions that are specified to be evenly spaced or manually
spaced.

1 Double-click one or more 2D layout grids.

2 On the Properties palette, expand Basic, and expand General.

3 Enter a new X width and Y depth value.

4 Select the repeat spacing option and enter a value, or enter a new
X and Y bay size value.
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Creating a Layout Grid with User-Specified Settings
Use this procedure to add a layout grid with settings that you specify. Layout
grids can be either rectangular or radial.

1 Open the tool palette that contains the layout grid tool you want
to use, and select the tool.

TIP You may have to scroll to display the desired tool. After selecting
it, you can move or hide the Properties palette to expose more of the
drawing area.

If there are no layout grid 2D tools available on tool palettes in
the workspace, you can use the Content Browser to access the
Stock Tool catalog, which contains a layout grid 2D tool under
Parametric Layout and Anchoring Tools. You can add this tool to
any tool palette. For more information, see Content Browser
Overview on page 129.

2 On the Properties palette, expand Basic, and expand General.

3 Click the setting for Description, enter a description of the grid,
and click OK.

4 For Shape, select either Rectangular or Radial.

5 Specify the boundary object attached to the grid, if necessary.

6 Expand Dimensions, and for Specify on screen select No.

7 If you selected a rectangular grid shape, specify the dimensions.

■ For X - Width, enter a value to define the width of the grid.

■ For Y - Depth, enter a value to define the depth of the grid.

8 Under X Axis, specify the layout:

Then…If you want to…

select Space evenly for Layout type,
and enter a value for Number of
bays.

lay out the grid with evenly spaced
bays along the X direction

select Repeat for Layout type, and
enter a value for Bay size.

lay out the grid with a fixed bay size
along the X direction

■ For Start offset, enter the offset distance from the start point
of the grid.
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NOTE The offset distance may be used to reduce the effective
grid size.

■ For End offset, enter the offset distance from the end point of
the grid.

9 Under Y Axis, specify the layout:

Then…If you want to…

select Space evenly for Layout type,
and enter a value for Number of
bays.

lay out the grid with evenly spaced
bays along the Y direction

select Repeat for Layout type, and
enter a value for Bay size.

lay out the grid with a fixed bay size
along the Y direction

■ For Start offset, enter a value for the offset distance from the
start point of the grid.

NOTE Offsets may be used to reduce the effective grid size.

■ For End offset, enter the offset distance from the end point of
the grid.

10 If you selected a radial grid shape, specify the dimensions.

■ For X - Width, enter a value to define the width of the grid.

■ For A - Angle, enter a value to define the angle of the grid.

11 Under X Axis, specify the layout:

Then…If you want to…

select Space evenly for Layout type,
and enter a value for Number of
bays.

lay out the grid with evenly spaced
bays along the X direction

select Repeat for Layout type, and
enter a value for Bay size.

lay out the grid with a fixed bay size
along the X direction

■ For Inside radius enter a value for the inside radius of the grid.
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■ For End offset enter a value for the offset distance from the
end point of the grid. The offset distance may be used to reduce
the effective grid size.

12 Under Y Axis, specify the layout:

Then…If you want to…

select Space evenly for Layout type,
and enter a value for Number of
bays.

lay out the grid with evenly spaced
bays along the Y direction

select Repeat for Layout type, and
enter a value for Bay angle.

lay out the grid with a fixed bay
angle along the Y direction

■ For Start angle offset enter a value for the offset angle from
the start angle of the grid.

NOTE Offsets may be used to reduce the effective grid size.

■ For End angle offset enter a value for the offset angle from the
end angle of the grid.

13 In the drawing area, specify the insertion point of the grid.

14 Specify the rotation angle of the grid, and press ENTER.

Creating a Custom Layout Grid from Linework
Use this procedure to convert custom linework to a layout grid that has the
properties of the layout grid tool you select. You can edit these properties after
creating the layout grid.

1 Open the tool palette that contains the layout grid tool you want
to use.

TIP You may have to scroll to display the desired tool. After selecting
it, you can move or hide the Properties palette to expose more of the
drawing area.

2 Right-click a layout grid tool, and click Apply Tool Properties
to ➤ Linework.

3 Select the linework to convert, and press ENTER.
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4 When prompted to erase the original linework, press ENTER to
keep the linework, or enter y (Yes) to erase it.

5 Edit the properties of the layout grid on the Properties palette, if
necessary.

Adding Lines to Layout Grids
Use this procedure to add grid lines to a grid. You can separately add grid lines
on the X plane and on the Y plane. If you are adding lines to a custom grid
that was created by applying tool properties to linework, draw the new line
or lines in the desired position before staring the procedure.

NOTE For non-custom grids, you can add lines only if the grid was inserted with
manually spaced lines or evenly spaced lines. Layout grids with lines placed at a
fixed repeated spacing value cannot be changed manually. For information about
grid modes, see Changing the Spacing Mode of Layout Grids on page 2730.

1 Select the layout grid

2 Select an add option:

Then…If you want to add a grid line
to …

click Layout Grid 2D tab ➤ X Axis

panel ➤ Add Grid Line  , then
proceed to next step.

the X plane of the grid

click Layout Grid 2D tab ➤ Y Axis

panel ➤ Add Grid Line , then
proceed to next step.

the Y plane of the grid

click Layout Grid 2D tab ➤ Custom

Grid panel ➤ Add Grid Lines  .

a custom grid that was created by
applying tool properties to linework

Then select the linework to be ad-
ded, and press ENTER. Press ENTER
again to keep the linework, or enter
y (Yes) to erase it.

3 Specify the distance of the new grid line from the start of the grid.

■ If you have added a line to a layout grid with manually spaced
lines, the new line is inserted at the specified position. The
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position of the other lines remains unchanged. The grid size
changes accordingly.

■ If you have added a line to a layout grid with evenly spaced
lines, the new line is inserted and all lines are recalculated, so
that they are evenly distributed again. The grid size remains
unchanged.

Removing Grid Lines from Layout Grids
Use this procedure to remove individual grid lines from a grid. You can
separately remove grid lines from the X plane and the Y plane.

NOTE You can remove lines only from grids that have been inserted with manually
spaced lines or evenly spaced lines. Layout grids with lines placed at a fixed
repeated spacing value cannot be changed. For information about grid modes,
see Changing the Spacing Mode of Layout Grids on page 2730.

1 Select the layout grid, and:

Then…If you want to remove a grid
line from…

click Layout Grid 2D tab ➤ X Axis

panel ➤ Remove Grid Line  .
Then proceed to next step.

the X plane of the grid

click Layout Grid 2D tab ➤ Y Axis

panel ➤ Remove Grid Line  .
Then proceed to next step.

the Y plane of the grid

click Layout Grid 2D tab ➤ Custom

Grid panel ➤ Remove Grid Lines

a custom grid that was created by
applying tool properties to linework

 . Then select the linework to be
removed, and press ENTER. The
linework remains visible in the
drawing but is no longer part of the
grid. You can select it and delete it
if desired.
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2 Click the grid line to be removed from the grid.

■ If you have removed a line from a layout grid with manually
spaced lines, the specified line is removed from the grid. The
position of the other lines remains unchanged.

■ If you have removed a line from a layout grid with evenly
spaced lines, the specified line is removed from the grid. All
remaining lines are recalculated, so that they are evenly
distributed again.

Changing the Spacing Mode of Layout Grids
Use this procedure to change the spacing mode of a radius or rectangular
layout grid. Layout grids can have three different spacing modes. These modes
are set separately for the X and Y planes:

■ Manual: You specify the position of each line on the layout grid.

■ Repeat: You specify equidistant spacing between lines on the layout grid.
The number of lines is determined by the size of the layout grid. As the
size of the grid changes, lines are added or subtracted accordingly. The
distance between the lines remains fixed.

■ Space Evenly: You specify the number of lines on the grid. The space
between the lines is determined by the size of the layout grid. As the size
of the grid changes, the spacing between the lines is lengthened or
shortened accordingly. The number of lines remains fixed.

By default, layout grids are inserted with evenly spaced lines.

1 Select the layout grid, and:

Then…If you want to change…

click Layout Grid 2D tab ➤ X Axis

panel ➤ Layout Mode  .

the spacing mode of the X plane of
the grid

click Layout Grid 2D tab ➤ Y Axis

panel ➤ Layout Mode  .

the spacing mode of the Y plane of
the grid
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2 Select the desired mode, and press ENTER.

■ If you are changing a layout grid with manually spaced lines
to a grid with lines placed at a fixed repeated spacing value,
you are prompted for start and end offsets, and the distance
between the lines. If there are too few lines on the grid to fill
it according to your specifications, new lines are created.

■ If you are changing a layout grid with manually spaced lines
to a grid with evenly spaced lines, you are prompted for start
and end offsets for the grid. The existing lines are distributed
evenly on the grid.

■ If you are changing a layout grid with lines placed at a fixed
repeated spacing value to a grid with manually spaced lines,
there is no visible change, but the lines have been converted
to manual lines, so that you now can add lines to and remove
lines from the grid.

■ If you are changing a layout grid with lines placed at a fixed
repeated spacing value to a grid with evenly spaced lines, you
are prompted for start and end offsets. The existing lines are
then recalculated and distributed evenly. You can now add
lines to and remove lines from the grid.

■ If you are changing a grid with evenly spaced lines to a grid
with manually spaced lines, there is no visible change.
However, if you change the grid, the lines remain fixed and
are not distributed evenly anymore.

■ If you are changing a grid with evenly spaced lines to a grid
with lines placed at a fixed repeated spacing value, you are
prompted for start and end offsets, and the distance between
the lines. If there are too few lines on the grid to fill the grid
according to your specifications, new lines are created.

Changing the Display Properties of Layout Grids
Use this procedure to change any of the following display properties of the
nodes on a layout grid:

■ Visibility (display component is on or off)

■ Layer
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■ Color

■ Linetype

■ Lineweight

■ Linetype scale

■ Node size

1 Select the layout grid that you want to change, right-click, and
click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 Click the Layer/Color/Linetype tab.

5 Select the component to change, and select a different setting for
the property.

6 Click OK twice.

Changing the Node Radius for a Layout Grid
Use this procedure to change the node radius for a layout grid by editing its
display properties.

1 Double-click the layout grid you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all layout grids in the drawing, select
Drawing default setting.

5 If necessary, expand Object Display Properties ➤ Advanced.
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6 Click the value for Node radius, and enter a new value.

(Alternatively, you can click  and specify 2 points in the
drawing area to set the new radius.)

You can also access and modify the node radius property through the layout
grid’s context menu, as follows:

1 Select the layout grid, right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 In the Display Properties dialog, click the Other tab, and then
change the radius as needed.

5 Click OK twice.

Creating and Removing Boundaries for Layout Grids
Use this procedure to create a boundary around a 2D layout grid. Areas of the
grid outside the boundary are not shown. However, objects anchored to the
grid outside the boundary are still displayed. Boundaries are useful when you
need to create a grid in an irregularly shaped area.

You can also remove a boundary to redisplay the entire grid.

1 Draw a closed polyline to define the grid boundary.

2 Select a layout grid, and then click Layout Grid 2D tab ➤ Clipping

panel ➤ Set Boundary  .

3 Select the layout grid, and press ENTER.

4 Select the closed polyline for the boundary of the layout grid, and
press ENTER.

5 To remove a grid boundary, erase the polyline that defines the
boundary.
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Creating Holes in Layout Grids
Use this procedure to create a hole in a layout grid. The area of the grid within
the hole is not displayed.

1 Draw a closed polyline to define the hole.

2 Select a layout grid, and click Layout Grid 2D tab ➤ Clipping

panel ➤ Add Hole  .

3 Select the layout grid, and press ENTER.

4 Select the closed polyline for the hole, and press ENTER.

A hole is cut in the layout grid.

Removing Holes from Layout Grids
Use this procedure to remove holes that you have created in layout grids.

1 Select a layout grid, and click Layout Grid 2D tab ➤ Clipping

panel ➤ Remove Hole  .

2 Select a layout grid, and press ENTER.

3 Select the closed polyline of the hole.

Changing the Location of Layout Grids
Use this procedure to change the location of layout grids. You can relocate a
layout grid by changing the coordinate values of its insertion point. The layout
grid also has an orientation with respect to the world coordinate system (WCS)
or the current user coordinate system (UCS). For example, if the top and
bottom of the layout grid are parallel to the XY plane, its normal is parallel to
the Z axis. You can change the orientation of the layout grid by aligning its
normal with another axis. You can also rotate the layout grid on its plane by
changing the rotation angle.

For information about WCS and UCS, see “Use Coordinates and Coordinate
Systems” in AutoCAD help.

1 Double-click the layout grid that you want to change.

2 On the Properties palette, expand Basic, and expand Location.

3 Select Additional information.
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4 In the Location dialog, specify the location of the layout grid:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the layout grid

make the normal of the layout
curve parallel to the Z axis: under

locate the layout grid on the XY
plane

Normal, enter 1 for Z, and enter 0
for X and Y.

make the normal of the layout grid
parallel to the X axis: under Normal,

locate the layout grid on the YZ
plane

enter 1 for X and enter 0 for Y and
Z.

make the normal of the layout grid
parallel to the Y axis: under Normal,

locate the layout grid on the XZ
plane

enter 1 for Y, and enter 0 for X and
Z.

enter a new value for Rotation
Angle.

change the rotation of the layout
grid

5 Click OK.

Attaching Hyperlinks, Notes, or Files to a Layout Grid
Use this procedure to attach hyperlinks, notes, or files to a layout grid. You
can also edit hyperlinks and notes, and edit or detach reference files from a
layout grid.

1 Double-click the layout grid to which to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

For more information, see “Add Hyperlinks to a Drawing” in
AutoCAD help.

4 Click OK.

5 To add a note, click the setting for Notes, and enter the note.
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6 Click OK.

7 To add a reference file, click the setting for Reference documents,
and attach, edit, or detach a reference file:

Then…If you want to…

click  , select a file, and click
OK.

attach a reference file

select the file, enter the description,
and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

8 Click OK.

Using Layout Volumes
Use a layout volume to arrange objects in a 3D grid. Changing the size of a
layout volume changes the spacing of objects attached to that volume and
can also change the size and height of objects attached to that volume.

Creating a Layout Volume Tool
Use this procedure to create a layout volume tool and add it to a tool palette.
You may want to create your own layout volume tools if you are placing
multiple layout volumes of a specific style and they all have the same
properties.

1 Open the tool palette where you want to add the tool.

2 Create the tool:

Then…If you want to…

select the object, and drag it to the
tool palette.

create a tool from a layout volume
in the drawing
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Then…If you want to…

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the palette where you want
to add the tool, right-click, and click
Paste.

open the Content Browser, and
locate the tool you want to copy.

copy a tool from the Content
Browser

Position the cursor over the i-drop
handle, and drag the tool to the
tool palette.

3 Right-click the new tool, and click Properties.

4 For Name, enter the name you want displayed for this tool’s
tooltip. This name will also be displayed with the tool if it is
published to a catalog in the Content Browser.

5 For Description, click in the text box, and then enter the
description you want displayed for this tool’s tooltip. This
description will also be displayed with the tool if it is published
to a catalog in the Content Browser.

6 Expand Basic, and expand General.

7 Under General, click the Description text box, enter a description
of the tool, and click OK.

8 For Layer key, click the text box, select a layer key, and click OK.

9 For Layer overrides, click the text box, select a layer key override,
and click OK.

10 Expand Dimensions.

11 For Specify on screen:

Then…If you want to…

click Yes.specify the dimension of the grid
on the drawing screen as you are
creating it

click No, and enter values for
Width, Depth, and Height.

specify numerical values on the
Properties palette
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12 Expand X Axis.

13 Select Space evenly for Layout type, and enter a value for Number
of bays.

14 Select Repeat for Layout type, and enter a value for Bay size.

15 Enter a value for Start offset.

16 Enter a value for End offset.

17 Expand Y Axis.

18 Select Space evenly for Layout type, and enter a value for Number
of bays.

19 Select Repeat for Layout type, and enter a value for Bay angle.

20 Enter a value for Start offset.

21 Enter a value for End offset.

22 Expand Z Axis.

23 Select Space evenly or Repeat for Layout type.

24 Enter a value for Start offset.

25 Enter a value for End offset.

26 Click OK.

Adding Layout Volumes
Use this procedure to add a layout volume, which is a three-dimensional (3D)
layout grid.

2738 | Chapter 34   Layout Curves and Grids



Layout volume parameters

1 Open the tool palette that contains the volume layout tool you
want to use, and select the tool.

TIP You may have to scroll to display the desired tool. After selecting
it, you can move or hide the Properties palette to expose more of the
drawing area.

If there are no volume layout tools available on tool palettes in
the workspace, you can use the Content Browser to access the
Stock Tool catalog, which contains a volume layout tool under
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Parametric Layout and Anchoring Tools. You can add this tool to
any tool palette. For more information, see Content Browser
Overview on page 129.

2 Select the volume layout tool.

3 On the Properties palette, expand Basic, and expand General.

4 Enter a value for the X width, Y depth and the Z height.

5 Select the Repeat option for Layout type, and enter values, for X
Axis, Y Axis, and Z Axis bay size and start and end offsets.

6 Specify an insertion point in the drawing for the lower-left corner
of the rectangular layout grid.

7 Specify the rotation of the rectangular grid about the insertion
point.

Changing Layout Volumes
Use this procedure to change the angle or size of three-dimensional (3D) layout
volumes. You can also change the number and size of the grid bays.

If you use grips to stretch a layout volume, the behavior of the layout volume
depends on the spacing type of each axis. The overall size of the grid “jumps”
in directions that are specified to use a certain bay size with repeat spacing
because the exact bay size is maintained. The overall size changes in directions
that are specified to be evenly spaced or manually spaced.

1 Double-click one or more 3D volume grids.

2 On the Properties palette, expand Basic, and expand General.

3 Enter a new X width, Y depth, and Z height value.

4 Select and change the Layout type option under X Axis, Y Axis,
and Z Axis, if necessary, and adjust values for Number of Bays or
Bay size, Start offset, and End offset.

Adding Grid Lines to Layout Volumes
Use this procedure to add grid lines to a layout volume. You can add grid lines
on the X, Y, and Z planes separately.
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NOTE You can add lines only to volumes inserted with manually spaced lines or
evenly spaced lines. Layout volumes with lines placed at a fixed repeated spacing
value cannot be changed. For information about grid modes, see Changing the
Spacing Mode of Layout Grids on page 2730.

1 Select the layout volume.

2 Specify the axis to which to add the grid line:

Then…If you want to add…

click Layout Grid 3D tab ➤ X Axis

panel ➤ Add Grid Line  .

a grid line to the X plane of the
volume

click Layout Grid 3D tab ➤ Y Axis

panel ➤ Add Grid Line  .

a grid line to the Y plane of the
volume

click Layout Grid 3D tab ➤ Z Axis

panel ➤ Add Grid Line  .

a grid line to the Z plane of the
volume

3 Specify the distance of the new grid line from the start of the grid.

■ If you have added a line to a layout volume with manually
spaced lines, the new line is inserted at the specified position.
The position of the other lines remains unchanged. The grid
size changes accordingly.

■ If you have added a line to a layout volume with evenly spaced
lines, the new line is inserted and all lines are recalculated, so
that they are evenly distributed again. The grid size remains
unchanged.

Removing Grid Lines from Layout Volumes
Use this procedure to remove individual grid lines from a volume. You can
remove grid lines from the X, Y, and Z planes separately.

NOTE You can remove lines only from volumes which have been inserted with
manually spaced lines or evenly spaced lines. Layout volumes with lines placed at
a fixed repeated spacing value cannot be changed. For information about grid
modes, see Changing the Spacing Mode of Layout Grids on page 2730.

1 Select the layout volume.
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2 Specify the axis from which to remove the grid line:

Then…If you want to remove…

click Layout Grid 3D tab ➤ X Axis

panel ➤ Remove Grid Line  .

a grid line from the X plane of the
volume

click Layout Grid 3D tab ➤ Y Axis

panel ➤ Remove Grid Line  .

a grid line from the Y plane of the
volume

click Layout Grid 3D tab ➤ Z Axis

panel ➤ Remove Grid Line  .

a grid line from the Z plane of the
volume

3 Click the grid line to be removed from the volume.

■ If you have removed a line from a layout volume with
manually spaced lines, the specified line is removed from the
volume. The position of the other lines remains unchanged.

■ If you have removed a line from a layout volume with evenly
spaced lines, the specified line is removed from the volume.
All remaining lines are recalculated, so that they are evenly
distributed again.

Changing the Spacing Mode of Layout Volumes
Use this procedure to change how modes are positioned along a layout volume.
For more information, see Adding Layout Volumes on page 2738.

For example, you can change the mode so that a volume with manually spaced
nodes becomes a volume with evenly spaced nodes. If you want to add nodes
to a layout volume with a fixed number of nodes, you must first convert the
layout volume to the manually spaced or evenly spaced mode.

You can also change the layout mode on the Properties palette.

1 Select the layout volume by selecting one of the node anchors.

2 Choose the desired command:

■ For X axis, click Layout Grid 3D tab ➤ X Axis panel ➤ Layout

Mode  .
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■ For Y axis, click Layout Grid 3D tab ➤ Y Axis panel ➤ Layout

Mode  .

■ For Z axis, click Layout Grid 3D tab ➤ Z Axis panel ➤ Layout

Mode  .

3 Select the desired mode, and press ENTER.

■ If you are changing a layout volume with manually spaced
nodes to a volume with nodes placed at a fixed repeated
spacing value, you are prompted for start and end offsets, and
the distance between the nodes. If there are too few nodes on
the curve to fill it, new nodes are created at the specified
distance.

■ If you are changing a layout volume with manually spaced
nodes to a volume with evenly spaced nodes, you are prompted
for start and end offsets for the volume. The existing nodes
are distributed evenly on the volume.

■ If you are changing a volume with nodes placed at a fixed
repeated spacing value to a volume with manually spaced
nodes, there is no visible change. However, the nodes have
been converted to manual nodes, so that you now can add
nodes to and remove nodes from the volume.

■ If you are changing a volume with nodes placed at a fixed
repeated spacing value to a volume with evenly spaced nodes,
you are prompted for start and end offsets. The existing nodes
are than recalculated and distributed evenly. You can now add
nodes to and remove nodes from the volume.

■ If you are changing a volume with evenly spaced nodes to a
volume with manually spaced nodes, there is no visible change.
If you change the volume, however, the nodes remain fixed
and are no longer redistributed evenly.

■ If you are changing a volume with evenly spaced nodes to a
volume with nodes placed at a fixed repeated spacing value,
you are prompted for start and end offsets, and the distance
between the nodes. If there are too few nodes on the curve to
fill it, new nodes are created at the specified distance.
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Changing the Display Properties of Layout Volumes
Use this procedure to change any of the following display properties of the
nodes on a layout volume:

■ Visibility (display component is on or off)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

■ Node size

1 Select the layout volume that you want to change, right-click,
and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 Click the Layer/Color/Linetype tab.

5 Select the component to change, and select a different setting for
the property.

6 Click OK twice.

Changing the Node Radius for a Layout Volume
Use this procedure to change the node radius for a layout volume by editing
its display properties.

1 Double-click the layout volume you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.
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NOTE To apply your changes to all layout volumes in the drawing,
select Drawing default setting.

5 If necessary, expand Object Display Properties ➤ Advanced.

6 Click the value for Node radius, and enter a new value.

(Alternatively, you can click  and specify 2 points in the
drawing area to set the new radius.)

You can also access and modify the node radius property through the layout
volume’s context menu, as follows:

1 Select the layout volume, right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 In the Display Properties dialog, click the Other tab, and then
change the radius as needed.

5 Click OK twice.

Changing the Location of Layout Volumes
Use this procedure to change the location of layout volumes. You can relocate
a layout volume by changing the coordinate values of its insertion point. The
layout volume also has an orientation with respect to the world coordinate
system (WCS) or the current user coordinate system (UCS). For example, if
the top and bottom of the layout volume are parallel to the XY plane, its
normal is parallel to the Z axis. You can change the orientation of the layout
volume by aligning its normal with another axis. You can also rotate the
layout volume on its plane by changing the rotation angle.

For information about WCS and UCS, see “Use Coordinates and Coordinate
Systems” in AutoCAD help.

1 Double-click the layout volume that you want to change.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Location.

3 Select Additional information.
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4 Specify the location of the layout volume:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the layout volume

make the normal of the layout
volume parallel to the Z axis: under

locate the layout volume on the XY
plane

Normal, enter 1 for Z, and enter 0
for X and Y.

make the normal of the layout
volume parallel to the X axis: under

locate the layout volume on the YZ
plane

Normal, enter 1 for X and enter 0
for Y and Z.

make the normal of the layout
volume parallel to the Y axis: under

locate the layout volume on the XZ
plane

Normal, enter 1 for Y, and enter 0
for X and Z.

enter a new value for Rotation
Angle.

change the rotation of the layout
volume

5 Click OK.

Attaching Hyperlinks, Notes, or Files to a Layout Volume
Use this procedure to attach hyperlinks, notes, or files to a layout volume.
You can also edit hyperlinks and notes, and edit or detach reference files from
a layout volume.

1 Double-click the layout volume to which to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

For more information, see “Add Hyperlinks to a Drawing” in
AutoCAD help.

4 Click OK.

5 To add a note, click the setting for Notes, and enter the note.
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6 Click OK.

7 To add a reference file, click the setting for Reference documents,
and attach, edit, or detach a reference file:

Then…If you want to…

click  , select a file, and click
OK.

attach a reference file

select the file, enter the description,
and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

8 Click OK.
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Grids

Grids are AEC objects on which you can anchor other objects, such as

s, and constrain their locations.

Grids
Grids are AEC objects on which you can anchor other objects, such as columns,
and constrain their locations. Grids are useful in the design and documentation
phases of a project.

Types of Grids

There are several types of grids, each with its own purpose:

Layout grids help you position objects relative to each other in your building
design. For more information about layout grids, see Layout Curves and Grids
on page 2703.

Column grids are layout grids that place a column at each intersection of the
grid as you add it to your drawing. For more information about columns, see
Creating a Freestanding Column on page 2571 or Creating Grid-Anchored Columns
on page 2577.

Ceiling grids are specialized layout grids that represent suspended ceiling systems
or cassette ceilings. They can be anchored to a space object at ceiling height.

All of these grid types share some common features.

Anchoring Objects to Grids

Grids can be used to anchor other objects. This is most visible in column grids,
where special functionality allows you to anchor columns to the grid during
insertion. Once the grid is inserted, you can add other objects to it as well.

35
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There are 2 anchoring mechanisms available for grids:

■ Anchoring objects to a grid cell (Cell Anchor)

■ Anchoring objects to a grid intersection (Node Anchor)

For more information about anchoring objects, see Anchors on page 2673.

Using Column Grid Tools to Create Column Grids
Tools in the software let you quickly place column grids using a structural
column grid tool with specific predefined properties. You can use the default
settings of the tool, or you can change the properties. You can also use
structural column grid tools to convert linework to column grids, and to apply
the settings of a structural column grid tool to existing column grids.

Tool palettes containing structural column grid tools

The default tool palettes in the workspace contain sample structural column
grid tools that you can use and customize as needed. In addition, the following
catalogs provided with the software contain structural column grid tools that
you can add to your tool palettes:

■ AutoCAD Architecture Stock Tool catalog

■ AutoCAD Architecture Sample Palette catalog
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Custom palettes created by your CAD manager or other users may also contain
structural column grid tools with column grid properties that are customized
for your projects or office standards.

Creating Rectangular and Radial Column Grids
You can create column grids with symmetric sides by using column grid tools.

The above column grids are inserted via a Tool from the Tools palette. You
can edit their properties on the Properties palette.

Layout Types for Column Grids

There are 3 different layout types that control the spacing of lines in a grid.
Layout type is specified separately for the X and Y planes.

■ Manual: You specify the position of each line on the grid.

■ Repeat (Fixed Bay Size): You specify equidistant spacing between lines on
the grid. The number of lines is determined by the size of the grid. As the
size of the grid changes, lines are added or subtracted accordingly. The
distance between lines remains fixed.

■ Space Evenly: You specify the number of lines on the grid. The space
between lines is determined by the size of the grid. As the size of the grid
changes, the spacing between lines is lengthened or shortened accordingly.
The number of lines remains fixed.
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NOTE By default, grids are inserted with evenly spaced lines.

Creating a Column Grid
Use this procedure to add a column grid from a column grid tool. Column
grids can be either rectangular or radial.

Rectangular grid

Radial grid

1 Open the tool palette that you want to use, and select a structural
column grid tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Column

Grid drop-down ➤ Column Grid  .

2 On the Properties palette, expand Basic, and expand General.

3 Select a shape, either Rectangular or Radial.

4 Expand Dimensions.

5 If you have selected a rectangular grid shape, specify the settings:

Then…If you want to…

expand Dimensions, and enter a
value for X - Width.

define the width of the grid
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Then…If you want to…

expand Dimensions, and enter a
value for Y - Depth.

define the depth of the grid

expand X Axis, select Space evenly
for Layout type, and enter a value
for Number of bays.

lay out the grid with evenly spaced
bays along the X direction

expand X Axis, select Repeat for
Layout type, and enter a value for
Bay size.

lay out the grid with a fixed bay size
along the X direction

expand X Axis, and enter a value
for Start offset. The offset distance

specify the offset distance from the
start point along the X direction of
the grid may be used to reduce the effective

grid size.

expand X Axis, and enter a value
for End offset. The offset distance

specify the offset distance from the
end point along the X direction of
the grid may be used to reduce the effective

grid size.

expand Y Axis, select Space evenly
for Layout type, and enter a value
for Number of bays.

lay out the grid with evenly spaced
bays along the Y direction

expand Y Axis, select Repeat for
Layout type, and enter a value for
Bay size.

lay out the grid with a fixed bay size
along the Y direction

expand Y Axis, and enter a value for
Start offset. The offset distance may

specify the offset distance from the
start point along the Y direction of
the grid be used to reduce the effective grid

size.

expand Y Axis, and enter a value for
End offset. The offset distance may

specify the offset distance from the
end point along the Y direction of
the grid be used to reduce the effective grid

size.
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6 If you have selected a radial grid shape, specify the settings:

Then…If you want to…

expand Dimensions, and enter a
value for X - Width.

define the width of the grid

expand Dimensions, and enter a
value for A - Angle.

define the angle of the grid

expand X Axis, select Space evenly
for Layout type, and enter a value
for Number of bays.

lay out the grid with evenly spaced
bays along the X direction

expand X Axis, select Repeat for
Layout type, and enter a value for
Bay size.

lay out the grid with a fixed bay size
along the X direction

expand X Axis, and enter a value
for Inside radius.

specify the inside radius of the grid

expand X Axis, and enter a value
for End offset. The offset distance

specify the offset distance from the
end point along the X direction of
the grid may be used to reduce the effective

grid size.

expand Y Axis, select Space evenly
for Layout type, and enter a value
for Number of bays.

lay out the grid with evenly spaced
bays along the Y direction

expand Y Axis, select Repeat for
Layout type, and enter a value for
Bay angle.

lay out the grid with a fixed bay
angle along the Y direction

expand Y Axis, and enter a value for
Start angle offset. The offset angle
may be used to reduce the grid size.

specify the offset angle from the
start angle along the X direction
grid curve

expand Y Axis, and enter a value for
End angle offset. The offset distance
may be used to reduce the grid size.

specify the offset angle from the
end angle along the X direction
grid curve

7 To add columns to the grid intersection during insertion, expand
Column, and specify a style for the structural member.
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If you choose to add columns, you can specify the dimensions of
the column:

■ Start offset

■ End offset

■ Logical length

■ Justify

■ Justify using overall extents

TIP After specifying the desired settings, you can move or hide the
Properties palette to expose more of the drawing area.

8 In the drawing area, specify the insertion point of the column
grid.

9 Specify the rotation angle of the grid, and press ENTER.

10 Continue adding column grids, and press ENTER.

Creating a Column Grid from a Layout Grid
Use this procedure to convert a two-dimensional (2D) layout grid to a column
grid that has the properties of the structural column grid tool you select. You
can edit these properties after creating the column grid.

1 Open the tool palette that contains the column grid tool you want
to use.

TIP You may have to scroll to display the desired tool. After selecting
it, you can move or hide the Properties palette to expose more of the
drawing area.

2 Right-click the tool, and click Apply Tool Properties to ➤ Layout
Grid 2D.

3 Select the layout grid to convert, and press ENTER.

4 When prompted to erase the original geometry, press ENTER to
keep the linework, or enter y (Yes) to erase it.

5 Edit the properties of the column grid in the Properties palette,
if necessary.
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Creating a Column Grid Dynamically
Use this procedure to create column grids dynamically by specifying their
dimensions on screen as you draw them.

1 Open the tool palette that contains the column grid tool you want
to use.

Alternatively, you can click Home tab ➤ Build panel ➤ Column

Grid drop-down ➤ Column Grid  .

2 On the Properties palette, expand Dimensions, and select Yes for
Specify on screen.

3 To add columns to the grid during insertion, expand Column,
and select the desired column style.

TIP After specifying the desired settings, you can move or hide the
Properties palette to expose more of the drawing area.

4 Specify the insertion point for the grid in the drawing.

5 Specify the overall size of the grid by dragging the cursor to the
desired size and clicking once.

6 Drag the crosshairs inside the resulting shape vertically and
horizontally to define the correct number of bays in the column
grid.

NOTE The closer the crosshairs go to the left and bottom of the grid,
the more spaces are created.

7 Click once to confirm the number of vertical and horizontal bays.

8 Specify the rotation angle of the grid, and press ENTER.

The column grid is inserted into the drawing according to your specifications.

Creating a Structural Column Grid Tool
Use this procedure to create a structural column grid tool and add it to a tool
palette. You may want to create your own structural column grid tools if you
are placing multiple column grids of a specific style, and they all have the
same properties.

1 Open the tool palette on which you want to add a tool.
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2 Create the tool:

Then…If you want to…

select the object, and drag it to the
tool palette.

create a tool from a column grid in
the drawing

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the palette where you want
to add the tool, right-click, and click
Paste.

click Home tab ➤ Build pan-

el ➤ Tools drop-down ➤ Content

copy a tool from a tool catalog

Browser , and locate the tool
you want to copy. Position the
cursor over the i-drop handle, and
drag the tool to the tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

6 Expand Basic, and expand General.

7 Click the setting for Description, enter a description of the column
grid created from this tool, and click OK.

8 Specify a layer key and any layer key overrides if you do not want
to use the layer assignments specified in the layer key style used
in the drawing.

9 Select a column grid shape.

10 Specify the settings for the dimensions of the grid.

For more information, see Creating a Layout Grid with
User-Specified Settings on page 2725.

11 Click OK.
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Editing Column Grids
The following editing operations can be applied to a column grid.

Labeling Column Grids
You can label existing column grids in the X direction and the Y direction.

1 Select the column grid you want to label.

2 Click Column Grid tab ➤ Label panel ➤ Label  .

3 Specify the grid location for labels:

Then…If you want to…

click the X - Labeling tab.add labels to the X axis of the grid

click the Y - Labeling tab.add labels to the Y axis of the grid

4 Enter a starting number or letter for the label under Number in
the table.

Each grid line in the X direction or the Y direction is listed in the
table. If Automatically Calculate Values for Labels is selected,
numbers or letters are consecutively assigned to the remaining
grid lines in the order you specify (ascending or descending).

NOTE To renumber a grid, enter a new value in the first location.
The remaining values are updated if Automatically Calculate Values
for Labels is selected.

5 If you do not want to use certain characters in the sequence, select
Never Use Characters, and enter the characters, separated by
commas.

6 To change the label symbol, click Bubble.

7 Select a new label symbol from the MvBlockDef Select dialog box,
and click OK.

Any multi-view block currently defined in the drawing can be
used.

8 Click Generate New Bubbles On Exit to update the bubbles.
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9 Specify the location of bubbles:

Then…If you want to…

select Top and/or Bottom.place bubbles in the X direction of
the grid

select Left and/or Right.place bubbles in the Y direction of
the grid

10 Enter a value for Extension.

Extension is the length of the bubble lines from the grid to the
bubble.

11 Click OK.

Labeling a column grid

Dimensioning Column Grids with Automatic AEC Dimensions
Use this procedure to dimension column grids and set the distance between
the dimensions and the grid. For this, you can use the automatic AEC
Dimension.

When you dimension a column grid with an automatic AEC dimension, the
resulting dimension is associative. When you update the grid, the dimension
is updated accordingly. Also, you can choose an AEC dimension style. For
more information, see AEC Dimensions on page 3387.
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NOTE Custom column grids cannot be dimensioned automatically. To dimension
a custom column grid, follow the instruction in Associative Dimensions From Picked
Points on page 3402 and Creating an AEC Dimension with User-Specified Settings
on page 3408.

With an AEC dimension, you cannot display angle dimensions or edit
individual dimension chains.

1 Select the column grid you want to dimension.

2 Click Column Grid tab ➤ General panel ➤ Dimension  .

3 On the Properties palette, expand Basic, and expand General.

4 Select a style.

NOTE Be sure to select an AEC dimension style that contains
dimensioning points for grids. For more information about AEC
dimension contents, see Associative Dimensions from Objects on
page 3393.

5 Click to specify the position of the AEC dimension.

The dimension can, for example, be placed above or below the
column grid.

■ To set the direction of the dimension, drag the mouse. The
extension lines are drawn in the opposite direction.

■ If you want to align the dimension, enter a on the command
line, and select the geometry to align to.

■ If you want a user-defined angle for the dimension, enter r
and enter the rotation angle on the command line.

NOTE The angle you specify here is calculated in relation to the
UCS, and not to the dimensioned grid.

Changing the Dimensions of a Column Grid
Use this procedure to change the overall dimensions of a column grid. A
rectangular grid is defined by its width and depth. A radial grid is defined by
its radius, angle, and optionally, its inner radius.

1 Double-click the column grid to which you want to make changes.
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2 Expand General, and expand Dimensions.

3 Modify the desired settings:

Then…If you want to…

enter new values for X - Width and
Y - Depth.

change the dimensions of a rectan-
gular column grid

enter new values for X - Width and
A - Angle.

change the dimensions of a radial
column grid

TIP You can also change the size of a grid by dragging its grip points. When you
have a manual grid, you drag the individual lines, and not the grid.

Changing the Lines of a Column Grid
Apart from the overall dimensions of a column grid, you can also change the
number and position of grid lines on the X and Y axes. There are 3 different
layout types that control the spacing of lines in a grid. Layout type is specified
separately for the X and Y planes on the Properties palette for the grid.

■ Manual: You specify the position of each line on the grid.

■ Repeat (Fixed Bay Size): You specify equidistant spacing between lines on
the grid. The number of lines is determined by the size of the grid. As the
size of the grid changes, lines are added or subtracted accordingly. The
distance between lines remains fixed.

■ Space Evenly: You specify the number of lines on the grid. The space
between lines is determined by the size of the grid. As the size of the grid
changes, the spacing between lines is lengthened or shortened accordingly.
The number of lines remains fixed.

NOTE By default, grids are inserted with evenly spaced lines.

The procedures for adding or removing grid lines vary depending on the
Layout type in effect, as explained in the following sections.
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Adding Lines to a Column Grid
In some cases, you need to add lines to an existing grid. Depending on the
Layout type in effect, you do this in different ways.

Adding Lines to a Column Grid with Evenly Spaced Lines
Use this procedure to add lines to a grid with evenly spaced lines. The lines
will always be distributed evenly along the grid axis. If you need non-regular
lines with different spacing between them, open the grid’s Properties palette,
and change the Layout type to Manual.

1 Select the column grid to which you want to add lines.

2 Add grid lines:

Then…If you want to…

click Column Grid tab ➤ X Axis panel ➤ Add

Grid Line . Click the grid X axis. The

add grid lines to the X axis
of the grid

number of grid lines increases by one while
the overall size of the grid remains the same.

click Column Grid tab ➤ Y Axis panel ➤ Add

Grid Line  .Click the grid Y axis. The

add grid lines to the Y axis
of the grid

number of grid lines increases by one while
the overall size of the grid remains the same.

Alternatively, you can add grid lines by increasing the value of
Number of Bays for X axis and Y axis on the Properties palette.

Adding Grid Lines to a Manual Column Grid
Use this procedure to add lines to a manual grid. A manual grid allows
maximum control over the grid, but requires that you define the exact number
and position of grid lines.

1 Select the column grid to which you want to add lines.
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2 Add grid lines:

Then…If you want to…

click Column Grid tab ➤ X Axis

panel ➤ Add Grid Line . Then,

add grid lines to the X axis of the
grid

specify the position on the X axis
where you want to add a line.

click Column Grid tab ➤ Y Axis

panel ➤ Add Grid Line  . Then,

add grid lines to the Y axis of the
grid

specify the position on the Y axis
where you want to add a line.

3 Alternatively, on the Properties palette, click Bays  for the X
and Y axis, and change the number of lines in the Bays worksheet.

4 To add a line, click under the last number in the Bays list.

A new line is inserted with default values for distance and spacing.
You can edit these values by clicking them and entering new
values.

NOTE You cannot enter a line number for the new line. The line
number is provided by the application after you close the worksheet.

5 Click OK.

Adding Grid Lines to a Column Grid with Fixed Bay Size
Use this procedure to add lines to a grid with bays of a fixed size. Normally,
in a grid with fixed bays, the distance between the grid lines is more important
than the number of grid lines.

To add lines to a grid with a fixed bay size, you have 2 options:

■ Enlarge the overall grid size (for more information, see Changing the
Dimensions of a Column Grid on page 2760).

■ Decrease the size of the bays.

TIP In cases where the number of lines is important for the grid, change the Layout
type of the grid from Repeat to Space evenly or Manual.
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1 Double-click the column grid to which you want to add lines.

2 Expand Dimensions.

3 Add grid lines:

Then…If you want to…

expand X Axis, and enter a value
for Bay size.

add grid lines to the X axis of the
grid

expand Y Axis, and enter a value for
Bay size.

add grid lines to the Y axis of the
grid

If you enter a value that reduces the size of the bays, the number
of grid lines increases as the extra bays are added to the grid.

Removing Lines from a Column Grid
You can remove individual grid lines from regular column grids. The method
used will depend on the layout type of the specific column grid.

Removing Lines from a Column Grid with Evenly Spaced Lines
Use this procedure to remove lines from a grid with evenly spaced lines. The
lines will always be distributed evenly along the grid axis. To remove a
particular line and have all the other lines stay in their original places, open
the grid’s Properties palette, and change the Layout type to Manual.

1 Select the column grid from which you want to remove lines.

2 Remove grid lines:

Then…If you want to…

click Column Grid tab ➤ X Axis

panel ➤ Remove Grid Line  .

remove grid lines from the X axis
of the grid

Then, click on the X axis. The num-
ber of grid lines decreases by one,
while the overall size of the grid re-
mains the same.

Click Column Grid tab ➤ Y Axis

panel ➤ Remove Grid Line  .

remove grid lines from the Y axis of
the grid
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Then…If you want to…

Then, click on the Y axis. The num-
ber of grid lines decreases by one,
while the overall size of the grid re-
mains the same.

Removing Grid Lines from a Manual Column Grid
Use this procedure to remove grid lines from a manual grid. On a manual grid,
you can remove each line individually.

1 Select the column grid from which you want to remove lines.

2 Remove grid lines:

Then…If you want to…

click Column Grid tab ➤ X Axis

panel ➤ Remove Grid Line  .

remove grid lines from the X axis
of the grid

Then, click on the grid line on the
X axis you want to remove.

Click Column Grid tab ➤ Y Axis

panel ➤ Remove Grid Line  .

remove grid lines from the Y axis of
the grid

Then, click on the grid line on the
Y axis you want to remove.

NOTE The Bays worksheet lists all bays on the selected axis, their
distance from the start point of the grid, and the spacing between
the grid lines that define the bays. You can also remove manual grid
lines here.

Removing Lines from a Column Grid with Fixed Bay Size
Use this procedure to remove lines from a grid with fixed bays. Normally, in
a grid with fixed bays, the distance between the grid lines is more important
than the number of grid lines.
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To remove lines from a grid with a fixed bay size, you have 2 options:

■ Decrease the overall grid size (for more information, see Changing the
Dimensions of a Column Grid on page 2760).

■ Increase the size of the bays

TIP In cases where the number of lines is important for the grid, change the
Layout type of the grid from Repeat to Space evenly or Manual.

1 Double-click the column grid from which you want to remove
lines.

2 Expand Dimensions.

3 Remove grid lines:

Then…If you want to…

expand X Axis, and enter a value
for Bay size.

remove grid lines from the X axis
of the grid

expand Y Axis, and enter a value for
Bay size.

remove grid lines from the Y axis of
the grid

If you enter a value that increases the size of the bays, the number
of grid lines decreases as the extra bays are removed from the grid.

Changing the Position of Column Grid Lines
You can change the position of individual lines in column grids for which
the Layout type is Manual. (Grids with a Layout type of Repeat or Space, evenly
calculates the line position according to the number of bays or the size of the
grid.) A manual grid has grip points for every line. You can use either the grip
points or the Bays worksheet to change the position of a grid line.

Using Grip Points to Move Column Grid Lines
Use this procedure to move a column grid line by dragging the grip points of
the line. Manual grids have a pair of grip points for the start point and
endpoint of each line.

1 Select the grid where you want to move grid lines.
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For each line in the grid, a pair of grip points (start point and
endpoint) is displayed.

TIP If your grid displays only four lines for the corners of the grid,
the Layout type needs to be changed to Manual on the grid’s
Properties palette.

2 Use the grip points to drag the lines in either a horizontal or
vertical direction.

■ If you move a grid line beyond the grid border, the grid is
enlarged accordingly.

■ If you move one of the border lines to the inside of the grid,
the grid is decreased accordingly.

Changing the Position of Column Grid Lines by Editing Grid Bays
Use this procedure to reposition grid lines by editing the number and spacing
of grid bays using the Bays worksheet.

1 Double-click the column grid where you want to move lines.

2 Expand Dimensions.

3 Edit grid bays:

Then…If you want to…

expand X Axis, and click the value
for Bays.

edit grid bays along the X axis

expand Y Axis, and click the value
for Bays.

edit grid bays along the Y axis

The Bays worksheet lists all bays on the selected axis, their distance
from the start point of the grid, and the spacing of each bay.

4 To change a bay, click one of its measuring values in the list, and
edit the value.

5 Click OK.

The line positions have changed according to your specifications.
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Creating a Custom Column Grid from Linework
You can create a custom column grid based on linework that is non-orthogonal
in shape. For example, if you have a drawing of an irregular plot, you can
create a custom column grid based on linework. Since the resulting grid has
a custom shape, the ability to edit it after creation is limited to general
properties and location properties. You cannot change the number or spacing
of grid lines, nor can you automatically label them.

Custom grid from linework

1 Create the linework you want to convert to a column grid.

2 Open the tool palette that contains the column grid tool you want
to use.

TIP You may have to scroll to display the desired tool. After selecting
it, you can move or hide the Properties palette to expose more of the
drawing area.

3 Right-click a structural column grid tool, and click Apply Tool
Properties to ➤ Linework.

4 Select the linework to convert, and press ENTER.

5 When prompted to erase the original linework, press ENTER to
keep the linework, or enter y (Yes) to erase it.

6 Edit the properties of the column grid in the Properties palette,
if necessary.

Labeling Custom Column Grids
When converting linework (such as polylines) to a custom column grid, you
can automatically generate labels at the column ends.

1 Select the linework you want to convert to a custom column grid.
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2 Click Home tab ➤ Build panel ➤ Custom Grid Convert.

3 Press Enter to accept the default settings, or enter an extension
value.

Extension is the length of the bubble lines from the grid to the
bubble.

4 To erase the linework, enter yes and press Enter.

Labeling a custom column grid

Characteristics of Custom Column Grid Labels

■ The default labeling is ‘-’

■ The character of labels attached to the same grid line is synchronized.

■ If you change the value of a label in a grid line, values of the other labels
in the same grid line are automatically updated.

NOTE However, when you modify a label attribute in the Properties palette,
values of other labels in the same grid line are not updated automatically.

■ If you erase a label, other labels and their values are not affected.

Editing Custom Column Grid Labels
You can add, remove, and edit custom column grid labels.

Labeling Custom Column Grids | 2769



Adding Labels

1 Select the custom column grid.

2 On the ribbon, click Column Grid contextual tab  ➤  Label panel  ➤  Add
labels.

3 Enter 10 and press Enter for the label extension value.

When you add labels, the following characteristics are maintained:

■ If there is no previous value assigned, labels are added to every end of the
grid line with a default value as ‘-’. Otherwise, existing values are used.

■ If there is a label on a grid line and you add another label, the existing
label and its value is maintained. Duplicate labels are not generated on
the grid ends.

Editing Labels

1 Select the custom column grid.

2 On the ribbon, click Column Grid contextual tab  ➤  Label panel  ➤  Edit
labels.

3 Click the first custom column grid line.

4 Click the second column grid line.

5 At the command prompt, enter a label value and press Enter.
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When you edit labels, the following characteristics are maintained:

■ You can select only one custom column grid line with a label at a time.

■ The selection order determines the automatic labeling order which is
generated after you enter an initial value.

■ The label values of grid lines that are not selected are not affected.

■ If the new value has more than one symbol (example: dash, underscore
etc.), only the value of the last character or number is incremented. For
example: A-1.4, A-1.5, A-1.6.

■ The label value can be of any alphanumeric character. There is no limit
on which character to enter.

NOTE When you add a grid line to an existing custom column grid, labels with
the default value as ‘-’ are automatically generated without the auto-labeling
support. When you remove a grid line, automatic labeling is not supported.

Changing the Lines of a Custom Column Grid
The procedures for adding or removing grid lines are explained in the following
sections.

Adding Lines to a Custom Column Grid
Use this procedure to add grid lines to a line-based custom column grid that
was created by applying tool properties to linework.

1 Draw the new line or lines in the desired position.

2 Select the column grid.

3 Click Column Grid tab ➤ Custom Grid panel ➤ Add Grid Lines

4 Select the linework to be added, and press ENTER.

5 Press ENTER again to keep the linework, or enter y (Yes) to erase
it.

Removing Lines from Custom Column Grids
Use this procedure to remove grid lines from a custom column grid that was
created by applying tool properties to linework.
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1 Select the column grid.

2 Click Column Grid tab ➤ Custom Grid panel ➤ Remove Grid
Lines

3 Select the linework to be removed, and press ENTER.

Using Grip Points to Move Custom Column Grid Lines
Use this procedure to move a column grid line by dragging the grip points of
the line. Manual grids have a pair of grip points for the start point and
endpoint of each line.

1 Select the grid where you want to move grid lines.

For each line in the grid, a pair of grip points (start point and
endpoint) is displayed.

2 Use the grip points to drag the lines in either a horizontal or
vertical direction.

■ If you move a grid line beyond the grid border, the grid is
enlarged accordingly.

■ If you move one of the border lines to the inside of the grid,
the grid is decreased accordingly.

Creating Enhanced Custom Column Grids Using the
Column Grid Dialog Box

Using the Column Grid dialog box, you can define and edit various properties
of the enhanced custom column grids.

Variable Grid Lines for Each Grid Side

You can define a different number of grid lines for each of the four grid sides.
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For information on how to generate variable grid lines, see Creating an
Enhanced Grid with Varying Grid Lines for each side on page 2783.

Using Primary and Secondary Grid Numbering

You can use primary and secondary numbering when labeling a grid.

Inserting a grid line with secondary numbering

You can add grid lines with a secondary numbering scheme during the grid
creation, or add them later on. For more information, see Defining the
Numbering Scheme for Secondary Grid Lines on page 2790.

Selective Grid Numbering per Grid Side

You can define the display of labels for each individual grid side. You make
this decision during the grid insertion, or you can add grid labels later. For
more information, see Defining the Display of Grid Numbering when Inserting
the Grid on page 2787 and Adding Labels to an Enhanced Custom Column Grid
after Insertion on page 2797.
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Grid Properties

In addition, the Enhanced Custom Column Grid dialog lets you control the
following properties of the column grid:

■ Orthogonal or radial grid shape

■ number of grid lines

■ vertical and horizontal bay size

■ inner grid radius (radial grid)

■ clockwise or counter-clockwise grid direction (radial grid)

■ multi-view block for grid label

■ grid label numbering/lettering scheme

■ prefixes for grid labels

■ grid extension

■ grid label extension

Creating a Rectangular Grid
Rectangular grids are defined by their width, height, and number of grid lines.

1 Click Home tab ➤ Build panel ➤ Column Grid
drop-down ➤ Enhanced Custom Grid.

Alternatively, you can select the Enhanced Custom Column Grid
tool on the Design Tool Palette.

2 In the Column Grid dialog, click the Orthogonal radio button.

3 Click the Top tab.
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4 By default the first line of the grid is already present.

5 To add the first bay to the grid, determine the desired size (for
example 3000 mm) and click the corresponding value in the value
list on the left.

TIP You can either directly edit the bay size value after entering it,
or you can edit the list of pre configured default values. For more
information, see Editing the List of Preconfigured Bay Sizes on page
2780.

6 For a grid with regularly sized bays, you have these options of
generating grid Bays:

■ Under Number, enter the number of grid bays you would like
to see in the grid. This will generate the specified number of
identically sized bays. This is the quickest way, but it does not
allow you set different grid numbering types for individual
lines, or change the width of one specific bay after insertion.

■ Click on the right side of the last row. This adds a new row
with the same settings as the last one.

TIP You can also select a whole row (click on the left side of the
row), right-click, and use the copy-and-paste commands.
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7 Under Type, select if the grid line associated with the bay should
be labelled as primary grid line or secondary grid line. By default,
primary grid lines are chosen. (For more information about
primary and secondary grid lines, see Defining the Numbering
Scheme for Secondary Grid Lines on page 2790).

NOTE The Label column is a read-only column showing you the grid
label for the associated grid line. You can change the labeling of the
grid under Bubble Parameters below.

8 Proceed to the Left tab and add grid lines there with the same
method.

IMPORTANT For a regular grid that has the same grid line layout on
both sides (Top/Bottom, Left/Right), you do not need to make any
settings on the Right and Bottom tabs. By default the Top and Left
side settings are mirrored to the Bottom and Right sides, if they are
not separately defined.

9 If needed, set further properties for your grid:

■ Editing the List of Preconfigured Bay Sizes on page 2780

■ Defining the Display of Grid Numbering when Inserting the
Grid on page 2787

■ Defining the Numbering and Lettering Scheme for Grid
Bubbles on page 2789

■ Defining the Numbering Scheme for Secondary Grid Lines on
page 2790
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10 Press ENTER and insert the grid in the drawing.

This will result in grid bay spacing like in the below example:

Creating a Radial Grid

1 Click Home tab ➤ Build panel ➤ Column Grid
drop-down ➤ Enhanced Custom Grid.

Alternatively, you can select the Enhanced Custom Column Grid
tool on the Design Tool Palette.

2 In the Column Grid dialog, click the Radial radio button.

3 Click the Radial tab.

4 To add the first bay to the grid, determine the desired angle (for
example 15°) and click the corresponding value in the value list
on the left.
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TIP You can either directly edit the bay angle value after entering it,
or you can edit the list of preconfigured default values. For more
information, see Editing the List of Preconfigured Bay Sizes on page
2780.

5 For a grid with regular angles, you have two options of generating
grid Bays:

■ Under Number, enter the number of grid bays you would like
to see in the grid. This will generate the specified number of
identically angled bays. This is the quickest way, but it does
not allow you set different grid numbering types for individual
lines, or change the width of one specific bay after insertion.

■ Click on the right side of the last row. This adds a new row
with the same settings as the last one.

TIP You can also select a whole row (click on the left side of the
row), right-click, and use the copy-and-paste commands.

6 Under Type, select if the grid line limiting the bay should be
labelled as primary grid line or secondary grid line. By default,
primary grid lines are chosen. (For more information about
primary and secondary grid lines, see Defining the Numbering
Scheme for Secondary Grid Lines on page 2790).

NOTE The Label column is a read-only column showing you the grid
label for the associated grid line. You can change the labeling of the
grid under Bubble Parameters below.

7 Enter a value for the inner radius of the grid.

8 Define if the grid should be developed in clockwise or
counter-clockwise direction.

9 Proceed to the Arcs tab and add grid bays there with the same
method.

10 If needed, set further properties for your grid:

■ Editing the List of Preconfigured Bay Sizes on page 2780

■ Defining the Display of Grid Numbering when Inserting the
Grid on page 2787

■ Defining the Numbering and Lettering Scheme for Grid
Bubbles on page 2789
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■ Defining the Numbering Scheme for Secondary Grid Lines on
page 2790

11 Press ENTER and insert the grid in the drawing.

This will result in grid bay spacing like in the below example:

Creating an Enhanced Column Grid from an Existing Enhanced
Column Grid or Regular Grid

1 Click Home tab ➤ Build panel ➤ Column Grid
drop-down ➤ Enhanced Custom Grid.

Alternatively, you can select the Enhanced Custom Column Grid
tool on the Design Tool Palette.

2 In the Column Grid dialog box, click Set From. The Column Grid
dialog box temporarily closes.
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3 Select an existing enhanced column grid or regular grid.

In the Column Grid dialog box, the extracted data of the selected
grid is displayed on the Grid Layout table. The preview of the
selected grid is also generated and displayed.

4 If needed, set further properties for your grid, as described in the
following topics:

■ Editing the List of Preconfigured Bay Sizes on page 2780

■ Defining the Display of Grid Numbering when Inserting the
Grid on page 2787

■ Defining the Numbering and Lettering Scheme for Grid
Bubbles on page 2789

■ Defining the Numbering Scheme for Secondary Grid Lines on
page 2790

5 Press OK and insert the grid in the drawing.

Editing the List of Preconfigured Bay Sizes
If the preconfigured values in the list of bay sizes does not contain the values
you need, you can change the list.
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If you want to re-use the same set of values across drawings, you can export
an edited list as an XML file.

Editing the list of values

1 Click Home tab ➤ Build panel ➤ Column Grid
drop-down ➤ Enhanced Custom Grid.

Alternatively, you can select the Enhanced Custom Column Grid
tool on the Design Tool Palette.

2 Click the  Edit button.

3 Select the value in the list you want to change and overwrite it.
Then, press ENTER.

4 Repeat this step for all preconfigured values you want to change.

5 To exit the editing mode, click the Edit button again.

Exporting a list of values

6 Click the Export button  .

7 In the Export Profile dialog, choose a name and location for the
exported list and click Save.

The list is saved as an XML file.

Importing a list of values

8 Click the Import button  .

9 In the Import Profile dialog, select the file to import and click
Open.

Creating an Enhanced Grid with Different Sized Grid Bays
You can create a grid with differently sized grid bays.
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1 Click Home tab ➤ Build panel ➤ Column Grid
drop-down ➤ Enhanced Custom Grid.

Alternatively, you can select the Enhanced Custom Column Grid
tool on the Design Tool Palette.

2 In the Column Grid dialog, click the Orthogonal or Radial radio
buttons.

3 Click the Top or Radial tab.

4 Under Bay Size/Bay Angle enter the first grid bay by clicking the
desired value in the preconfigured values list.

5 For a grid with different sized bays, you need to add one row for
each bay. To add a new row for a bay, select the desired value in
the list on the left and click it.

TIP If the preconfigured values do not contain the size you need,
you can either directly edit the row after adding it, or you can edit
the list of preconfigured default values. For more information, see
Editing the List of Preconfigured Bay Sizes on page 2780.

6 Proceed to the Left or Arcs tab and add grid bays there with the
same method.

7 If needed, set further properties for your grid by:

■ Editing the List of Preconfigured Bay Sizes on page 2780

■ Defining the Display of Grid Numbering when Inserting the
Grid on page 2787

2782 | Chapter 35   Grids



■ Defining the Numbering and Lettering Scheme for Grid
Bubbles on page 2789

■ Defining the Numbering Scheme for Secondary Grid Lines on
page 2790

8 Press ENTER and insert the grid in the drawing.

NOTE After inserting the grid, you can shorten and lengthen the bay
size manually. The new bay size gets automatically revised in the
Column Grid dialog box input table.

Creating an Enhanced Grid with Varying Grid Lines for each side
You can define a different number of grid lines for each of the four grid sides.

1 Click Home tab ➤ Build panel ➤ Column Grid
drop-down ➤ Enhanced Custom Grid.

Alternatively, you can select the Enhanced Custom Column Grid
tool on the Design Tool Palette.

2 First, generate the grid layout for the side that has the larger set
of grid lines. For example, if you want to create a grid that has
lines 1,2,3,4,5 on top, and 1,3,4, 5 on the bottom, you first select
the Top tab and enter 4 grid bays at the desired distance.
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3 Then switch to the Bottom tab. You will see, that although no
grid bays have been defined yet, all grid lines from the Top side
have been drawn through to the bottom. This is the default
setting.
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TIP The preview window displays all grid lines defined in the currently
selected tab in purple. Grid lines defined previously in a currently
non-active tab are displayed in black.

4 Now, start adding bays for the bottom part of the grid with the
same bay size as the top ones. You will see that the color of the
grid lines changes from black to purple, indicating that these lines
are defined in the bottom part.

NOTE The first and the last lines of the grid extend to both sides by
default.

At this point, you have an incomplete set of grid bays for the
Bottom tab. If this already gives you the configuration you need
(as in the example below), you can now either place the grid in
the drawing, or switch to the Left/Right tabs, in order to define
the horizontal lines.

5 If this does not give you the desired result, proceed filling in the
bottom part of the grid, until you have one grid bay less than in
the top part. (You have to do this because the final grid line always
is drawn at both sides). In this example, we added 4 bays (5 grid
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lines) for the top. If you want to have one less for the bottom,
add only three bays for the bottom part:

6 In order to leave out one line, you must enlarge the bay to double
its size. For example, if you want to leave out grid line 2, then the
first bay must be doubled from 3000 mm to 6000 mm:
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Now, the first bay spans two bays at the bottom, and as a result,
you have only four grid lines instead of five. You can now either
switch to the Left tab to edit the other grid axis, or you can press
ENTER to place the grid in the drawing.

NOTE You can also work the other way around and create the full
set of grid lines on the Top tab, copy-and-paste them to the Bottom
tab, and then start to delete and edit individual rows as necessary.

Defining the Display of Grid Numbering when Inserting the Grid
You can define for which grid side to display the labels during insertion. You
can insert a grid with partial or no grid numbering, but later add grid
numbering to it. For more information, see Adding Labels to an Enhanced
Custom Column Grid after Insertion on page 2797.
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1 Click Home tab ➤ Build panel ➤ Column Grid
drop-down ➤ Enhanced Custom Grid.

Alternatively, you can select the Enhanced Custom Column Grid
tool on the Design Tool Palette.

2 Define the grid as described in Creating a Rectangular Grid on
page 2774 or Creating a Radial Grid on page 2777.

3 Under Bubble Parameters, click Generate Bubbles to activate the
generation of grid bubbles.

4 Turn the grid labeling selectively on and off for different grid axes
and directions with the four individual check boxes.

NOTE You can switch off the grid labels fully or partially during
insertion of the grid, but switch them back on later. For more
information, see Adding Labels to an Enhanced Custom Column Grid
after Insertion on page 2797.

5 Click Advanced Settings, and set the following parameters:

■ Under Bubble Extension, define the extension of the labels
from the grid.

■ Under Grid Extension, define the extension of the grid lines
beyond the grid.

■ Under Grid End Space, define how far a grid line that does not
extend in this direction should be removed from the grid
extents.

6 If needed, set further properties for your grid:

■ Defining the Numbering and Lettering Scheme for Grid
Bubbles on page 2789

■ Defining the Numbering Scheme for Secondary Grid Lines on
page 2790
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7 Press ENTER and add the grid to the drawing.

Defining the Numbering and Lettering Scheme for Grid Bubbles

1 Click Home tab ➤ Build panel ➤ Column Grid
drop-down ➤ Enhanced Custom Grid.

Alternatively, you can select the Enhanced Custom Column Grid
tool on the Design Tool Palette.

2 Define the grid as described in Creating a Rectangular Grid on
page 2774 or Creating a Radial Grid on page 2777.

3 Define the content of the grid bubbles by selecting the desired
labeling scheme under X-Labeling (X-axis) and Y-Labeling (Y-axis).

By default, you can choose between a number scheme (1, 2, 3) or
a lettering scheme (A, B, C). In order to generate more advanced
labeling schemes, select Define Custom.

4 Use the Custom Label setting dialog to fine-tune the following
labeling aspects:

■ Define a prefix.

■ Select a different numbering scheme, for example using small
letters or composite numbers or letters.

■ Define the sequence of continuation after the end of the
regular list.

■ Define if the numbering/lettering should go in the left to right,
bottom to top directions (default value), or rather go from
right to left or top to bottom.

5 Click OK.

6 If you want to exclude certain numbers or letters from grid labels,
list them under Skip Characters and separate them with commas.

For example, you may want to exclude the letter O because it can
be confused with a zero.
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IMPORTANT If you exclude a character or number that you have
defined as a custom label value, the Skip setting will override the
custom label setting, and the character will not be displayed in the
grid.

7 If needed, set further properties for your grid:

■ Defining the Display of Grid Numbering when Inserting the
Grid on page 2787

■ Defining the Numbering Scheme for Secondary Grid Lines on
page 2790

Defining the Numbering Scheme for Secondary Grid Lines
You can use primary and secondary numbering when labeling an enhanced
custom grid.

Using primary and secondary numbering in a grid

You can add grid lines with secondary numbers during the grid creation, or
add them later on.

1 Click Home tab ➤ Build panel ➤ Column Grid
drop-down ➤ Enhanced Custom Grid.

Alternatively, you can select the Enhanced Custom Column Grid
tool on the Design Tool Palette.

2 When you create grid lines with secondary numbering, the label
contains the following components:

■ Number of the primary grid line after which the secondary
line is inserted
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■ Number of the secondary grid line

■ Delimiter

When you insert secondary lines, you can build up the numbering
either to primary number - delimiter - secondary number, or the
other way around as secondary number - delimiter - primary
number:

3 In order to use the primary grid number - delimiter - secondary
grid number order, select Primary for Format.

4 In order to use the secondary grid number - delimiter - primary
grid number order, select Secondary for Format.

5 Select a delimiter.

6 If needed, set further properties for your grid:

■ Defining the Display of Grid Numbering when Inserting the
Grid on page 2787

■ Defining the Numbering Scheme for Secondary Grid Lines on
page 2790

7 Use the Preview window to verify that all grid settings are correct,
and then click OK to place the grid in the drawing area.

Editing Enhanced Custom Column Grids
You can edit enhanced custom column grids manually or with the Column
Grid dialog box.
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Editing Enhanced Custom Column Grids with Column Grid Dialog
Box

Edit enhanced custom column grids with the Column Grid dialog box.

1 Select the enhanced custom column grid.

2 On the ribbon, click Column Grid contextual tab  ➤  Custom Grid panel
 ➤  Edit Grid.

Since the same dialog box is used for creating and editing enhanced custom
column grids, most of the editing options are the same as the creation options.
For more information, see Creating Enhanced Custom Column Grids Using
the Column Grid Dialog Box on page 2772.

NOTE The Grid Layout option is disabled when you edit an enhanced custom
column grid using the Column Grid dialog box.
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Editing the labels of an existing enhanced custom column grid in the Column
Grid dialog box

1 You can manually edit the labels of an existing enhanced custom column
grid and change the automatic labeling parameters (primary and
secondary). When you edit this manually edited enhanced custom column
grid with the Column Grid dialog box, the following characteristics are
maintained:

■ The custom label format is enabled and the automatic Label Format
option is disabled.

■ All recognized secondary label formats are classified as Secondary.

■ You can add, delete, and modify the grid layout using the input table.

■ The values of manually edited labels are displayed in the preview.

■ Subsequent primary grid lines that are added have label and label
values generated according to the Label Format settings in the Column
Grid dialog box.

2 To define a different bubble, click Bubble and select a different multi-view
block as the bubble definition.

■ Under Bubble Parameters, the General Bubbles option is disabled and
the Custom bubble display configuration is enabled.

■ You can continue to add, delete, and modify the grid layout using
the input table.

■ If subsequent grid lines are added, labels generated are according to
the General Bubble formatting.

Editing Enhanced Custom Column Grids Manually
The following editing manually operations can be applied to an enhanced
custom column grid.

Adding Lines to an Enhanced Custom Column Grid
You can manually add lines to an enhanced custom column grid.

A grid line that is added to an existing grid can be either a primary grid line
or a secondary grid line. A primary line fits into the numbering/lettering order
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of the existing lines, whereas a secondary line is a compound of the primary
grid number and the secondary grid number. For information on defining the
format of secondary grid numbers, see Defining the Numbering Scheme for
Secondary Grid Lines on page 2790.

Adding primary and secondary grid line

NOTE When you add a grid line before the first line of the grid or after the last
line of the grid, the endpoints of the intersecting grid lines are extended
automatically to the new line. Non-intersecting grid lines will not be affected.

1 Select the enhanced custom column grid.

2 Click Column Grid tab ➤ Custom Column Grid panel ➤ Offset
Grid Line.

3 Select a grid line that serves as a reference for to offset the new
grid line from.

4 Do one of the following:

■ Press T (Through) and specify the insertion point of the new
line in the drawing area.

■ Enter the distance of the new line from the reference line, and
press ENTER. Then click in the drawing area to define the
direction of the new line in relation to the selected reference
line.

5 If the new grid line should be a primary grid line press N (No).

6 If the new grid line should be a secondary grid line, press Y (Yes).

The numbering of the grid is updated automatically.
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Removing Lines from an Enhanced Custom Column Grid
You can remove lines from an enhanced custom column grid.

NOTE When you remove the first line of the grid or last line of the grid, the
endpoints of the intersecting grid lines are shortened automatically to the next
existing grid line. Non-intersecting grid lines will not be affected.

1 Select the enhanced custom column grid.

2 Click Productivity Extension tab ➤ Custom Column Grid
panel ➤ Remove Grid Lines.

3 Select the grid lines to remove, and press ENTER.

The numbering of the grid is updated automatically.

Editing Enhanced Custom Column Grids with Grips
In an enhanced custom column grid, grips are located in the middle and at
the ends of each grid line. Maneuver these grips to edit the enhanced custom
column grid.

Editing Linear Enhanced Custom Column Grid with Grips
Edit with Linear Middle Grips When you manipulate the linear middle grips,
the following characteristics are maintained:

■ Movements of the middle grips are constrained and are limited to the
direction perpendicular to the grid line being dragged.

Edit with Linear End Grips When you manipulate the linear end grips, the
following characteristics are maintained:

■ Movements of the end grips are not constrained and can be moved in any
direction.

NOTE This may result in breaking the regularity of the linear grid line and
changing the original geometry.

■ If you only shorten and lengthen the end grips without changing the
direction, the regularity of the linear grid line is maintained.
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Editing Radial Enhanced Custom Column Grid s with Grips
Edit with Radial Middle Grips When you manipulate the radial middle grips,
the following characteristics are maintained:

NOTE This may result in breaking the regularity of the radial grid line and changing
the original geometry.

■ The movement of the middle grip is constrained and limited to direction
perpendicular to the tangent of the middle grip. Therefore, when you use
the center of the radius as the origin, the radius of the grid arc changes.

■ Both sides of the arc fall along the path of the radial grid line.

■ It is not possible to drag the middle grip in such a way that the arc radius
is less than zero.

Edit with Radial End Grips When you manipulate the radial end grips, the
following characteristics are maintained:

■ Movements of the end grips are not constrained and can be moved in any
direction.

■ If you only shorten and lengthen the end grips without changing the
direction, the regularity of the radial grid line is not broken.

When you add grips, stretch the middle grip, or extend the end grips within
or beyond the first and last extension point, all endpoints of the intersecting
grid lines closest to the first or last grid lines are adjusted accordingly.

Dimensioning an Enhanced Custom Column Grid
You can dimension an enhanced custom column grid. The dimension
command on the contextual column grid tab will create a 2-chain grid
dimension for the overall grid extent and the grid bays.
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NOTE The dimension command on the contextual Grid tab inserts AutoCAD
dimensions.

1 Select the enhanced custom column grid.

2 Click Column Grid tab ➤ Custom Column Grid
panel ➤ Dimension Grid.

3 Select the grid.

4 Define the offset of the dimension from the grid.

By default, a set of rotated dimensions with the Annotative
dimension style are created. If you want to change the dimension
style, select the dimensions and set a different dimension style
in the Properties palette.

Adding Labels to an Enhanced Custom Column Grid after
Insertion

You can label an enhanced custom column grid after inserting it in the drawing
area. Sometimes you may not want to add the labeling at the beginning of
the schematic design phase when the arrangement of the grid lines are not
yet finalized. The grid in this phase is drawn as a reference to align the
structure, and the grid line spacing may still need to be adjusted and modified
during design exploration. When the design is finalized and the grid line
layout is settled, you can add the labeling.
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NOTE The direction of the numbering (left to right or right to left; top to bottom
or bottom to top) cannot be changed after insertion. These need to be correctly
set when creating the grid.

For information on suppressing the label generation when creating an
enhanced custom column grid, see Defining the Display of Grid Numbering
when Inserting the Grid on page 2787.

1 Select the enhanced custom column grid.

2 Click Column Grid tab ➤ Custom Column Grid panel ➤ Add
Labels.

3 Re-select the column grid to label.

Editing Labels on an Enhanced Custom Column Grid
You can change the labeling for an enhanced custom grid.

Manually changing the labeling for a grid can be useful for example when
you are adding secondary grid lines before the first main grid line, and would
like to change the formatting for the preceding secondary lines, but not for
the secondary lines within the grid:
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Using the same numbering format before and within grid

Using a different numbering format (preceding zero) before the grid

You can change one label individually or you can define arrange of labels for
changing.

1 Select the enhanced custom column grid.

2 Click Column Grid tab ➤ Custom Column Grid panel ➤ Edit
Labels.

3 Do one of the following:

■ To change the labels for a range of grid lines, select the start
and end lines for the editing range.

■ To change a single label, select the line, and enter e (Edit) on
the command line.

4 Enter the value for the label. If you have selected a range of grid
lines to update, then the value will be logically progressed through
the range. For example, if you select the value of “A”, then the
following labels will read “B”, “C” etc.

Editing Enhanced Custom Column Grids Manually | 2799



Dimensioning Individual Grid Bays
You can dimension individual grid bays, or a range of multiple grid bays on
an enhanced custom column grid.

NOTE This command inserts a rotated AutoCAD dimension with the Annotative
dimension style.

1 Select the enhanced custom column grid.

2 Click Column Grid tab ➤ Custom Column Grid
panel ➤ Dimension Bay.

3 Select the grid line from which to start the dimension.

4 Select the grid line on which to end the dimension, and place the
dimension as desired.

Editing General Column Grid Properties
The following editing operations can be applied to all types of column grids.

Attaching Clipping Profiles to Column Grids
You can attach a clipping profile to define a mask around a column grid or
to make a hole in a column grid. You could, for example, create a mask to
define a column grid for an irregularly shaped room, or exclude parts of a
room from the column grid.

NOTE To attach a clipping profile, you must first draw a closed polyline with the
desired boundary or hole shape.
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Masking Column Grids
Use this procedure to mask a column grid. A mask is a polyline shape that
defines the boundaries of a column grid. Those parts of the grid outside the
boundary are not displayed.

1 Draw a closed polyline with the boundary or hole shape you want.

2 Select the grid you want to mask.

3 Click Column Grid tab ➤ Clipping panel ➤ Set Boundary  .

4 Select the column grid, and press ENTER.

5 Select the closed polyline you want to use as a mask.

The parts of the column grid that are outside the masking polyline are no
longer displayed.

TIP If columns are connected to the invisible part of the grid, they are still displayed
after masking. If necessary, you can delete them.

TIP If you want to restore the original grid shape, go to the Properties palette,
and select None for Boundary.

Creating Holes in Column Grids
Use this procedure to create a hole in an existing column grid. The hole is
created from a closed polyline placed within the boundaries of the grid. Any
parts of the grid inside the hole are not displayed.

1 If it does not already exist within the boundaries of the grid, draw
a closed polyline in the shape of the desired hole.

2 Select the grid.

3 Click Column Grid tab ➤ Clipping panel ➤ Add Hole  .

4 Select the column grid, and press ENTER.

5 Select a closed polyline for the hole.

A hole is cut in the column grid.

6 Press ESC to end the command.

TIP If columns are connected to the hole in the grid, they are still displayed. If
necessary, you can delete them.
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Removing Holes from Column Grids
Use this procedure to remove holes you have created in column grids.

1 Select the grid from which you want to remove holes.

2 Click Column Grid tab ➤ Clipping panel ➤ Remove Hole .

3 Select the grid again, and press ENTER.

4 Select the closed polyline of the hole.

The hole is removed from the layout grid. The polyline, however, remains in
the drawing. If necessary, you can delete it.

Attaching Hyperlinks, Notes, or Files to a Column Grid
Use this procedure to attach hyperlinks, notes, or files to a column grid. You
can also edit hyperlinks and notes, and edit or detach reference files from a
column grid.

1 Select the column grid to which you want to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

For more information, see “Add Hyperlinks to a Drawing” in
AutoCAD Help.

TIP The quickest way to locate and view an AutoCAD topic is to click
the Search tab in the Help window, select the Search titles only option,
and then copy and paste or type in the AutoCAD topic name, and
click List Topics.

4 Click OK.

5 To add a note, click the setting for Notes, and enter the note.

6 Click OK.

7 To add a reference file, click the setting for Reference documents,
and attach, edit, or detach a reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file
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Then…If you want to…

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

8 Click OK twice.

Changing the Location of Column Grids
Use this procedure to change the location of column grids. You can relocate
a column grid by changing the coordinate values of its insertion point. The
column grid also has an orientation with respect to the world coordinate
system (WCS) or the current user coordinate system (UCS). For example, if
the top and bottom of the column grid are parallel to the XY plane, its normal
is parallel to the Z axis. You can change the orientation of the column grid
by aligning its normal with another axis. You can also rotate the column grid
on its plane by changing the rotation angle.

For more information about the world coordinate system, see “Use World and
User Coordinate Systems in 3D” in AutoCAD Help.

TIP The quickest way to locate and view an AutoCAD topic referenced is to click
the Search tab in the Help window, select the Search titles only option, and then
copy and paste or type in the AutoCAD topic name, and click List Topics.

1 Select the column grid that you want to change.

2 On the Properties palette, expand Basic, and expand Location.

3 Select Additional information.

4 Specify the location of the column grid:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the column grid

make the normal of the column
grid parallel to the Z axis: under

locate the column grid on the XY
plane
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Then…If you want to…

Normal, enter 1 for Z, and enter 0
for X and Y.

make the normal of the column
grid parallel to the X axis: under

locate the column grid on the YZ
plane

Normal, enter 1 for X, and enter 0
for Y and Z.

make the normal of the column
grid parallel to the Y axis: under

locate the column grid on the XZ
plane

Normal, enter 1 for Y, and enter 0
for X and Z.

enter a new value for Rotation
Angle.

change the rotation of the column
grid

5 Click OK.

Changing the Display of Column Grids
Use this procedure to change any of the following display properties for lines,
node markers, or cell markers in a column grid:

■ Visibility (display component is on or off)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

1 Select the column grid you want to change, right-click, and click
Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.
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3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 Click the Layer/Color/Linetype tab.

5 Select the component to change, and select a different setting for
the property.

6 Click OK twice.

Changing the Node Radius for a Column Grid
Use this procedure to change the node radius for a column grid by editing its
display properties.

1 Double-click the column grid you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all column grids in the drawing,
select Drawing default setting.

5 If necessary, expand Object Display Properties ➤ Advanced.

6 Click the value for Node radius, and enter a new value.

(Alternatively, you can click  and specify 2 points in the
drawing area to set the new radius.)

You can also access and modify the node radius property through the column
grid’s context menu, as follows:

1 Select the column grid, right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 In the Display Properties dialog, click the Other tab, and then
change the radius as needed.
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5 Click OK twice.

Using Ceiling Grid Tools to Create Ceiling Grids
Tools in the software let you quickly place ceiling grids using a ceiling grid
tool with a specific ceiling grid style and other predefined properties. You can
use the default settings of the tool, or you can change its properties. You can
also use ceiling grid tools to convert linework to ceiling grids and to apply the
settings of a ceiling grid tool to existing ceiling grids.

Tool palettes containing ceiling grid tools

The default tool palettes in the workspace contain sample ceiling grid tools
that you can use and customize as needed. In addition, the following catalogs
provided with the software contain ceiling grid tools that you can add to your
tool palettes:

■ AutoCAD Architecture Stock Tool catalog

■ AutoCAD Architecture Sample Palette catalog

Custom palettes created by your CAD manager or other users may also contain
ceiling grid tools with ceiling grid properties that are customized for your
projects or office standards.
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Creating a Ceiling Grid
Use this procedure to add a new ceiling grid that has the properties specified
in the ceiling grid tool that you select. To specify settings when you add a
ceiling grid, see Creating a Ceiling Grid with User-Specified Settings on page
2807.

1 Open the tool palette that contains the ceiling grid tool you want
to use, and select the tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Ceiling

Grid  .

2 Specify the insertion point of the ceiling grid.

3 Specify the rotation of the ceiling grid, and press ENTER.

4 Continue adding ceiling grids, and press ENTER.

Creating a Ceiling Grid with User-Specified Settings
Use this procedure to add a ceiling grid with settings that you specify on the
Properties palette. Spaces and closed polylines can be used as boundaries for
ceiling grids.

1 Open the tool palette that you want to use, and select a ceiling
grid tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Ceiling

Grid  .

2 On the Properties palette, expand Basic, and expand General.

3 Select a boundary:

Then…If you want to…

click Select object for Boundary,
and select a space in the drawing.

place a ceiling grid within a space

click Select object for Boundary,
and select a closed polyline in the
drawing.

place a ceiling grid within a closed
polyline

4 Expand Dimensions, and select No for Specify on screen.
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5 Specify the settings:

Then…If you want to…

enter a value for X - Width.define the width of the grid

enter a value for Y - Depth.define the depth of the grid

expand X Axis, select Space evenly
for Layout type, and enter a value
for Number of bays.

lay out the grid with evenly spaced
bays along the X direction

expand X Axis, select Repeat for
Layout type, and enter a value for
Bay size.

lay out the grid with a fixed bay size
along the X direction

expand X Axis, and enter a value
for Start offset. The offset distance

specify the offset distance from the
start point along the X direction of
the grid may be used to reduce the effective

grid size.

expand X Axis, and enter a value
for End offset. The offset distance

specify the offset distance from the
endpoint along the X direction of
the grid may be used to reduce the effective

grid size.

expand Y Axis, select Space evenly
for Layout type, and enter a value
for Number of bays.

lay out the grid with evenly spaced
bays along the Y direction

expand Y Axis, select Repeat for
Layout type, and enter a value for
Bay size.

lay out the grid with a fixed bay size
along the Y direction

expand Y Axis, and enter a value for
Start offset. The offset distance may

specify the offset distance from the
start point along the Y direction of
the grid be used to reduce the effective grid

size.

expand Y Axis, and enter a value for
End offset. The offset distance may

specify the offset distance from the
endpoint along the Y direction of
the grid be used to reduce the effective grid

size.
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TIP After specifying the desired settings, you can move or hide the
Properties palette to expose more of the drawing area.

6 In the drawing area, specify the insertion point of the ceiling grid.

7 Specify the rotation angle of the grid, and press ENTER.

8 Continue adding ceiling grids, and press ENTER.

Creating a Ceiling Grid from a Layout Grid
Use this procedure to convert a two-dimensional (2D) layout grid to a ceiling
grid that has the properties of the ceiling grid tool you select. You can edit
these properties after creating the ceiling grid.

1 Open the tool palette that contains the ceiling grid tool you want
to use.

(You may have to scroll to display the desired tool.)

2 Right-click the ceiling grid tool, and click Apply Tool Properties
to ➤ Layout Grids.

3 Select the layout grid to convert, and press ENTER.

4 When prompted to erase the original geometry, press ENTER to
erase the linework, or enter n (No) to keep it.

5 Edit the properties of the ceiling grid in the Properties palette, if
necessary.

Creating a Custom Ceiling Grid from Linework
Use this procedure to convert custom linework to a ceiling grid that has the
properties of the ceiling grid tool you select. You can edit these properties
after creating the ceiling grid.

1 Open the tool palette that contains the ceiling grid tool you want
to use.

(You may have to scroll to display the desired tool.)

2 Right-click a ceiling grid tool, and click Apply Tool Properties
to ➤ Linework.

3 Select the linework to convert, and press ENTER.

4 When prompted to erase the original linework, press ENTER to
keep the linework, or enter y (Yes) to erase it.
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5 Edit the properties of the ceiling grid in the Properties palette, if
necessary.

Creating a Ceiling Grid Dynamically
Use this procedure to create ceiling grids dynamically by specifying their
dimensions on the screen as you draw them.

1 Open the tool palette that contains the ceiling grid tool you want
to use, and select the tool.

Alternatively, you can click Home tab ➤ Build panel ➤ Ceiling

Grid  .

2 On the Properties palette, expand Dimensions, and select Yes for
Specify on screen.

3 Expand X Axis and Y Axis, and specify the settings:

Then…If you want to…

select Space evenly for Layout type,
and enter a value for Number of
bays.

lay out the grid with evenly spaced
bays along the X direction

select Repeat for Layout type, and
enter a value for Bay size.

lay out the grid with a fixed bay size
along the X direction

enter a value for Start offset. The
offset distance may be used to re-
duce the effective grid size.

specify the offset distance from the
start point along the X direction of
the grid

enter a value for End offset. The
offset distance may be used to re-
duce the effective grid size.

specify the offset distance from the
endpoint along the X direction of
the grid

select Space evenly for Layout type,
and enter a value for Number of
bays.

lay out the grid with evenly spaced
bays along the Y direction

enter a value for Bay size.lay out the grid with a fixed bay size
along the Y direction
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Then…If you want to…

enter a value for Start offset. The
offset distance may be used to re-
duce the effective grid size.

specify the offset distance from the
start point along the Y direction of
the grid

enter a value for End offset. The
offset distance may be used to re-
duce the effective grid size.

specify the offset distance from the
endpoint along the Y direction of
the grid

4 Specify an insertion point in the drawing.

5 Specify the overall size of the grid by dragging the cursor to the
desired size and clicking once.

6 Specify the rotation angle for the grid, and press ENTER.

Creating a Ceiling Grid with a Clipping Boundary
Use this procedure to create a ceiling grid within a closed polyline or a space
object. If the ceiling grid is within a space, the grid is created at the ceiling
height of the space.

1 Open the tool palette that contains the ceiling grid tool you want
to use, and select the tool.

(You may have to scroll to display the desired tool.)

2 On the Properties palette, expand Basic, and expand General.

3 Click the setting for Boundary.

4 Click Select object, and then select an existing space or a closed
polyline in the drawing.

5 Specify an insertion point in the drawing.

NOTE The insertion point of the ceiling grid is the lower-left corner
of the ceiling grid if the rotation is set to 0 degrees.

6 Specify the overall size of the grid by dragging the cursor to the
desired size and clicking once.

Drag the cursor along the X axis to specify the number of bays
along the X direction, and drag the cursor along the Y axis to
specify the number of bays along the Y direction.

7 Specify the rotation angle of the grid, and press ENTER.
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The grid is displayed only within the space or closed polyline.

Creating a ceiling grid from a polyline

NOTE In some templates, the ceiling grid object is turned off in a number of plan
views. It is displayed in most model views, however, so if you cannot see your grid
in top view, switch to a model view to make sure it is there. For more information
about turning on the display of ceiling grids in plan view, see Display System on
page 791.

Creating a Ceiling Grid Tool
Use this procedure to create a ceiling grid tool and add it to a tool palette. You
may want to create your own ceiling grid tools if you are placing multiple
ceiling grids of a specific style, and they all have the same properties.

1 Open the tool palette on which you want to add a tool.

2 Create the tool:

Then…If you want to…

select the object, and drag it to the
tool palette.

create a tool from a ceiling grid in
the drawing

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other palette, right-click
the tool, and click Copy. Reopen

copy a tool from another tool
palette

the palette where you want to add
the tool, right-click, and click Paste.

click Home tab ➤ Build pan-

el ➤ Tools drop-down ➤ Content

copy a tool from a tool catalog

Browser , and locate the tool
you want to copy. Position the
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Then…If you want to…

cursor over the i-drop handle, and
drag the tool to the tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

6 Expand Basic, and expand General.

7 Click the setting for Description, enter a description of the ceiling
grid created from this tool, and click OK.

8 Specify a layer key and any layer key overrides if you do not want
to use the layer assignments specified in the layer key style used
in the drawing.

9 Specify the settings for the dimensions of the grid.

For more information, see Creating a Ceiling Grid with
User-Specified Settings on page 2807.

10 Click OK.

Editing Ceiling Grids
You can change existing ceiling grids in different ways. You can change the
overall dimensions of the grid, the number and position of grid lines, and the
location of the grid within the drawing. You can also specify a clipping
boundary for the grid and use that to mask the grid or insert a hole into the
grid.

Changing the Dimensions of a Ceiling Grid
Use this procedure to change the overall dimensions of a ceiling grid. A ceiling
grid is defined by its width and depth.

1 Double-click the ceiling grid you want to change.

2 Expand General, and expand Dimensions.

3 Modify the values for X - Width or Y - Depth.
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TIP You can also change the size of a grid by dragging its grip points. Note that
when you have a manual grid, you are dragging the individual lines, and not the
grid.

Changing the Lines of a Ceiling Grid
Apart from the overall dimensions of a ceiling grid, you can also change the
number and position of grid lines on the X and Y axes. There are 3 different
layout types that control the spacing of lines in a grid. Layout type is specified
separately for the X and Y planes on the Properties palette for the grid.

■ Manual: You specify the position of each line on the grid.

■ Repeat (Fixed Bay Size): You specify equidistant spacing between lines on
the grid. The number of lines is determined by the size of the grid. As the
size of the grid changes, lines are added or subtracted accordingly. The
distance between lines remains fixed.

■ Space Evenly: You specify the number of lines on the grid. The space
between lines is determined by the size of the grid. As the size of the grid
changes, the spacing between lines is lengthened or shortened accordingly.
The number of lines remains fixed.

NOTE By default, grids are inserted with evenly spaced lines.

The procedures for adding or removing grid lines vary depending on the
Layout type in effect, as explained in the following sections.

Adding Lines to a Ceiling Grid
In some cases, you need to add lines to an existing grid. Depending on the
Layout type in effect, you do this in different ways.

Adding Lines to a Ceiling Grid with Evenly Spaced Lines
Use this procedure to add lines to a grid with evenly spaced lines. The lines
will always be distributed evenly along the grid axis. If you need non-regular
lines with different spacing between them, open the grid’s Properties palette,
and change the Layout type to Manual.

1 Select the ceiling grid to which you want to add lines.
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2 Add grid lines:

Then…If you want to…

click Ceiling Grid tab ➤ X Axis panel ➤ Add

Grid Line  . Then, click on the X axis of

add grid lines to the X axis
of the grid

the grid. The number of grid lines increases
by one, while the overall size of the grid re-
mains the same.

click Ceiling Grid tab ➤ Y Axis panel ➤ Add

Grid Line  . Then, click on the Y axis of

add grid lines to the Y axis
of the grid

the grid. The number of grid lines increases
by one, while the overall size of the grid re-
mains the same.

Your grid has been updated accordingly, with the new number of grid lines
distributed evenly along the grid axis.

Adding Lines to a Manual Ceiling Grid
Use this procedure to add lines to a manual grid. A manual grid allows
maximum control over the grid, but requires that you specify the exact number
and position of grid lines.

1 Select the ceiling grid to which you want to add lines.

2 Add grid lines:

Then…If you want to…

click Ceiling Grid tab ➤ X Axis

panel ➤ Add Grid Line  . Then,

add grid lines to the X axis of the
grid

click the location on the X axis
where the new grid line should ap-
pear.

click Ceiling Grid tab ➤ Y Axis pan-

el ➤ Add Grid Line  . Then, click

add grid lines to the Y axis of the
grid

the location on the X axis where the
new grid line should appear.
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The Bays worksheet lists all of the bays on the selected axis, their
distance from the start point of the grid, and the spacing between
the grid lines that define the bays.

3 Alternatively, on the Properties palette, click Bays  for the X
and Y axis, and change the number of lines in the Bays worksheet.

4 To add a line, click under the last number in the Bays list.

A new line is inserted with default values for distance and spacing.
You can edit these values by clicking them and entering new
values.

NOTE You cannot enter a line number for the new line. The line
number is provided by the application after you close the worksheet.

5 Click OK.

TIP To add lines to the ceiling grid, you can also right-click the grid, and click X
Axis/Y Axis ➤ Add Grid Line.

Adding Lines to a Ceiling Grid with Fixed Bay Size
Use this procedure to add lines to a grid with fixed bays. Normally, in a grid
with fixed bays, the distance between the grid lines is more important than
the number of grid lines.

To add lines to a grid with a fixed bay size, you have 2 options:

■ Enlarge the overall grid size (for more information, see Changing the
Dimensions of a Ceiling Grid on page 2813).

■ Decrease the size of the bays

TIP In cases where the number of lines is important for the grid, change the
Layout type of the grid from Repeat to Space evenly or Manual.

1 Double-click the ceiling grid to which you want to add lines.

2 Expand Dimensions.
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3 Add grid lines:

Then…If you want to…

expand X Axis, and enter a value
for Bay size.

add grid lines to the X axis of the
grid

expand Y Axis, and enter a value for
Bay size.

add grid lines to the Y axis of the
grid

If you enter a value that reduces the size of the bays, the number
of grid lines increases as the extra bays are added to the grid.

A number of new lines have been added by decreasing the size of the individual
bays.

Adding Lines to Custom Ceiling Grids
Use this procedure to add grid lines to a custom ceiling grid that was created
by applying tool properties to linework.

1 Draw the new line or lines in the desired position.

2 Select the ceiling grid.

3 Click Ceiling Grid tab ➤ Custom Grid panel ➤ Add Grid Lines

4 Select the linework to be added, and press ENTER.

5 Press ENTER again to keep the linework, or enter y (Yes) to erase
it.

Removing Lines from a Ceiling Grid
In the same way that lines can be added to a ceiling grid, they can also be
removed.

Removing Lines from a Ceiling Grid with Evenly Spaced Lines
Use this procedure to remove lines from a grid with evenly spaced lines. The
lines will always be distributed evenly along the grid axis. To remove a
particular line and have all the other lines stay in their original places, open
the grid’s Properties palette, and change the Layout type to Manual.
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1 Double-click the ceiling grid from which you want to remove
lines.

2 Expand Dimensions.

3 Remove grid lines:

Then…If you want to…

click Ceiling Grid tab ➤ X Axis pan-

el ➤ Remove Grid Line  . Then, click

remove grid lines from the X
axis of the grid

anywhere on the X axis. The number of
grid lines is decreased by one.

click Ceiling Grid tab ➤ Y Axis panel ➤ Re-

move Grid Line  . Then, click any-

remove grid lines from the Y
axis of the grid

where on the Y axis. The number of grid
lines is decreased by one.

Your grid has been updated accordingly, with the new number of grid lines
distributed evenly along the grid axis.

Removing Lines from a Manual Ceiling Grid
Use this procedure to remove grid lines from a manual grid. On a manual grid,
you can remove each line individually.

1 Select the ceiling grid from which you want to remove lines.

2 Remove grid lines:

Then…If you want to…

click Ceiling Grid tab ➤ X Axis

panel ➤ Remove Grid Line  .

remove grid lines from the X axis
of the grid

Then, click on the grid line on the
X axis to remove.

click Ceiling Grid tab ➤ Y Axis pan-

el ➤ Remove Grid Line  . Then,

remove grid lines from the Y axis of
the grid

click on the grid line on the Y axis
to remove.
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3 Alternatively, on the Properties palette, click Bays  for the X
and Y axis, and change the number of lines in the Bays worksheet.

4 To remove a line, click the bay number in the Bays list, and click
Remove.

5 Click OK.

The bay is deleted from the grid, and the grid size is reduced accordingly.

Removing Lines from a Ceiling Grid with Fixed Bay Size
Use this procedure to remove lines from a grid with bays of fixed size.
Normally, in a grid with fixed bays, the distance between the grid lines is more
important factor than the number of grid lines.

To remove lines from a grid with a fixed bay size, you have 2 options:

■ Decrease the overall grid size (for more information, see Changing the
Dimensions of a Ceiling Grid).

■ Increase the size of the bays.

TIP In cases where the number of lines is important for the grid, change the
Layout type of the grid from Repeat to Space evenly or Manual.

1 Double-click the ceiling grid from which you want to remove
lines.

2 Expand Dimensions.

3 Remove grid lines:

Then…If you want to…

expand X Axis, and enter a value
for Bay size.

remove grid lines from the X axis
of the grid

expand Y Axis, and enter a value for
Bay size.

remove grid lines from the Y axis of
the grid

If you enter a value that increases the size of the bays, the number
of grid lines decreases as the extra bays are removed from the grid.

A number of lines have been removed by increasing the size of
the individual bays.
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Removing Lines from Custom Column Grids
Use this procedure to remove grid lines from a custom ceiling grid that was
created by applying tool properties to linework.

1 Select the ceiling grid.

2 Click Ceiling Grid tab ➤ Custom Grid panel ➤ Remove Grid Lines

3 Select the linework to be removed, and press ENTER.

The linework remains visible in the drawing but is no longer part
of the grid. You can select it and delete it if desired.

Changing the Position of Ceiling Grid Lines
You can change the position of individual lines in ceiling grids for which the
Layout type is Manual. (Grids with a Layout type of Repeat or Space evenly
calculate line position according to the number of bays or the size of the grid.)
A manual grid has grip points for every line. You can use either the grip points
or the Bays worksheet to change the position of a grid line.

Using Grip Points to Move Ceiling Grid Lines
Use this procedure to move a ceiling grid line by dragging the grip points of
the line. Manual grids have a pair of grip points for the start point and end
point of each line.

1 Select the grid where you want to move grid lines.

For each line in the grid, a pair of grip points (start point and end
point) is displayed.

TIP If your grid displays only four lines for the corners of the grid,
the Layout type needs to be changed to Manual on the grid’s
Properties palette.

2 Use the grip points to drag the lines in either horizontal or vertical
direction.

■ If you move a grid line beyond the grid border, the grid is
enlarged accordingly.

■ If you move one of the border lines of the grid to the inside
of the grid, the grid is decreased accordingly.
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Changing the Position of Ceiling Grid Lines by Editing Grid Bays
Use this procedure to reposition grid lines by editing the number and spacing
of grid bays using the Bays worksheet.

1 Double-click the ceiling grid where you want to move lines.

2 On the Properties palette, expand Dimensions.

3 Edit grid bays:

Then…If you want to…

expand X Axis, and click the value
for Bays.

edit grid bays along the X axis

expand Y Axis, and click the value
for Bays.

edit grid bays along the Y axis

The Bays worksheet lists all bays on the selected axis, their distance
from the start point of the grid, and the spacing of each bay.

4 To change a bay, click one of its measuring values in the list, and
edit the value.

5 Click OK.

The line positions have changed according to your settings.

Attaching Clipping Profiles to Ceiling Grids
You can attach a clipping profile to define a mask around a ceiling grid or to
make a hole in a ceiling grid. You could, for example, create a mask to define
a ceiling grid for an irregularly shaped room, or exclude parts of a room from
the ceiling grid.

For a mask, you can use closed polylines and spaces. For more information,
see Creating a Ceiling Grid with a Clipping Boundary on page 2811.

NOTE To attach a clipping profile, you must first draw a closed polyline or space
with the desired boundary or hole shape.
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Masking Ceiling Grids
Use this procedure to mask a ceiling grid. A mask is a polyline shape or space
that defines the boundaries of a ceiling grid. Those parts of the grid outside
the boundary are not displayed.

1 Draw a closed polyline with the boundary or hole shape you want.

2 Select the grid you want to mask.

3 Click Ceiling Grid tab ➤ Clipping panel ➤ Set Boundary  .

4 Select the closed polyline or space you want to use as a mask.

The parts of the ceiling grid that are outside the masking polyline or space
are no longer displayed.

TIP If you want to restore the original grid shape, go to the Properties palette and
select None for Boundary.

Creating Holes in Ceiling Grids
Use this procedure to create a hole in an existing ceiling grid. The hole is
created from a closed polyline or AEC object placed within the boundaries of
the grid. Any parts of the grid inside the hole are not displayed.

1 If it does not already exist within the boundaries of the grid, draw
a closed polyline in the shape of the desired hole.

2 Select the ceiling grid to which you want to add a hole.

3 Click Ceiling Grid tab ➤ Clipping panel ➤ Add Hole .

4 Select a closed polyline or AEC object for the hole.

A hole is cut in the ceiling grid.

5 Press ENTER to end the command.
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Adding a hole to a ceiling grid

Removing Holes from Ceiling Grids
Use this procedure to remove holes you have created in ceiling grids.

1 Select the grid from which you want to remove holes.

2 Click Ceiling Grid tab ➤ Clipping panel ➤ Remove Hole .

3 Select the closed polyline of the hole.

The hole is removed from the ceiling grid. The polyline, however, remains in
the drawing. If necessary, you can delete it.

Removing a hole from a ceiling grid
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Attaching Hyperlinks, Notes, or Files to a Ceiling Grid
Use this procedure to attach hyperlinks, notes, or files to a ceiling grid. You
can also edit hyperlinks and notes, and edit or detach reference files from a
ceiling grid.

1 Select the ceiling grid to which you want to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

For more information, see “Add Hyperlinks to a Drawing” in
AutoCAD Help.

TIP The quickest way to locate and view an AutoCAD topic is to click
the Search tab in the Help window, select the Search titles only option,
and then copy and paste or type in the AutoCAD topic name, and
click List Topics.

4 Click OK.

5 To add a note, click the setting for Notes, and enter the note.

6 Click OK.

7 To add a reference file, click the setting for Reference documents,
and attach, edit, or detach a reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

8 Click OK twice.
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Changing the Location of Ceiling Grids
Use this procedure to change the location of ceiling grids. You can relocate
an existing ceiling grid by changing the coordinate values of its insertion
point. The ceiling grid also has an orientation with respect to the world
coordinate system (WCS) or the current user coordinate system (UCS). For
example, if the top and bottom of the ceiling grid are parallel to the XY plane,
its normal is parallel to the Z axis. You can change the orientation of the
ceiling grid by aligning its normal with another axis. You can also rotate the
ceiling grid on its plane by changing the rotation angle.

For more information about the world coordinate system, see “Use World and
User Coordinate Systems in 3D” in AutoCAD help.

TIP The quickest way to locate and view an AutoCAD topic is to click the Search
tab in the Help window, select the Search titles only option, and then copy and
paste or type in the AutoCAD topic name, and click List Topics.

1 Select the ceiling grid that you want to change.

2 On the Properties palette, expand Basic, and expand Location.

3 Select Additional information.

4 Specify the location of the ceiling grid:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the ceiling grid

make the normal of the ceiling grid
parallel to the Z axis: under Normal,

locate the ceiling grid on the XY
plane

enter 1 for Z and enter 0 for X
and Y.

make the normal of the ceiling grid
parallel to the X axis: under Normal,

locate the ceiling grid on the YZ
plane

enter 1 for X, and enter 0 for Y
and Z.

make the normal of the ceiling grid
parallel to the Y axis: under Normal,

locate the ceiling grid on the XZ
plane

enter 1 for Y, and enter 0 for X
and Z.
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Then…If you want to…

enter a new value for Rotation
Angle.

change the rotation of the ceiling
grid

5 Click OK.

Changing the Display of Ceiling Grids
Use this procedure to change any of the following display properties for lines,
node markers, or cell markers in a ceiling grid:

■ Visibility (display component is on or off)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

1 Select the ceiling grid you want to change, right-click, and click
Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 Click the Layer/Color/Linetype tab.

5 Select the component to change, and select a different setting for
the property.

6 Click OK twice.

Changing the Node Radius for a Ceiling Grid
Use this procedure to change the node radius for a ceiling grid by editing its
display properties.
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1 Double-click the ceiling grid you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all ceiling grids in the drawing, select
Drawing default setting.

5 If necessary, expand Object Display Properties ➤ Advanced.

6 Click the value for Node radius, and enter a new value.

(Alternatively, you can click  and specify 2 points in the
drawing area to set the new radius.)

You can also access and modify the node radius property through the ceiling
grid’s context menu, as follows:

1 Select the ceiling grid, right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 In the Display Properties dialog, click the Other tab, and then
change the radius as needed.

5 Click OK twice.
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Detail Drafting Tools

AutoCAD Architecture includes a number of easily accessible tools designed to help you work
more intuitively and effectively with linework in detail drawings.

Construction Lines
Construction lines (also known as xlines) are temporary linework entities that
can be used as references when creating and positioning other objects or
linework. For example, you can use construction lines to prepare multiple views
of the same item, or create temporary intersections to serve as object snaps.

Construction lines are either circles or straight lines that extend to infinity in
both directions. In either case, they do not change the total area of the drawing
and have no effect on zooming or viewports. You can move, rotate, copy, or
delete construction lines just like other objects.

The regular AutoCAD construction line functionality is still available via the
XLINE command. However, the AutoCAD Architecture construction line feature
is designed to give you a more intuitive way of drawing construction lines based
on the geometry of existing objects or linework. No command line entry is
required.

In most cases, you would probably want to draw construction lines based on
segments of existing objects, but you can also draw them by specifying any two
points in the drawing area, without regard to existing objects or linework.

Creating Construction Lines From Existing Objects/Linework
Use this procedure to create a construction line based on the geometry of any
straight, arced, or circular segment of any object or linework, except hatches,
splines, and ellipses. If based on a straight segment, the resulting construction
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line is a straight line that extends to infinity in both directions; if based on
an arced or circular segment, the construction line is a circle.

1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Construction

Line  .

2 In the drawing area, move the cursor over the segment on which
you want to base your construction line (the “construction line
base”).

A preview of the construction line is displayed.

3 Click to display an offset indicator, which dynamically shows the
distance between the preview line and the construction line base.

4 Either drag the preview line to the desired distance, and click to
position the construction line, or enter the desired distance and
press ENTER.

Drawing a construction line at a zero offset based on a straight wall segment
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Drawing a construction line at a zero offset based on a arc wall segment

Drawing a construction line at a specified offset based on a straight wall segment
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The resulting construction line displays three grips when selected.
You can move the line by moving the middle grip, or you can
change its orientation by moving either of the end grips.

Creating Construction Lines Independently
Use this procedure to create a straight construction line that passes through
any two points of your choice.

1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Construction

Line  .

2 Press ENTER.

3 In the drawing area, specify the first point that you want the
construction line to pass through. (This will be the root or
conceptual midpoint of the construction line.)

4 Specify a second point.

Drawing a construction line by specifying points

The construction line is displayed. If you select it, three grips are
displayed. You can move the line by moving the middle grip, or
you can change its orientation by moving either of the end grips.

Hatch Productivity Tools
The context menu for hatches includes options that allow you to easily
reposition hatches relative to their origins, generate AEC Polygons to provide
boundaries for non-bounded hatches, and redefine hatch boundaries based
on other selected closed-boundary linework.
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Repositioning a Hatch
Use this procedure to align brick and masonry hatch patterns within a
boundary so that whole units display along a particular edge.

1 Select the hatch.

2 Right-click, and click Set Origin.

3 Specify an endpoint on the boundary, and press ENTER.

The hatch is repositioned with its origin at the endpoint you
specified.

Repositioning a hatch within a boundary

Generating a Hatch Boundary
Use this procedure to generate a boundary for a hatch whose original boundary
has been deleted or moved during the course of other drawing operations.
The boundary generated by this procedure is a polyline. Polylines are also
created for any islands within the selected hatch. These polylines remain
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selected after you generate the boundary, so you can directly manipulate them
into the desired configuration. You can then apply the hatch to the new
boundary configuration using the Set Boundary option, as described under
Redefining a Hatch Boundary on page 2834.

1 Select the hatch.

2 Right-click, and click Generate Boundary.

All grips are displayed for any polylines created.

Generating a hatch boundary

Redefining a Hatch Boundary
Use this procedure to redefine the boundaries of associative or non-associative
hatches based on any selected closed-boundary linework. In cases where a
non-associative hatch originally filled closed-boundary linework, but the
linework was subsequently stretched or moved, this procedure lets you expand
or reposition the hatch to fill the new boundary.
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You can also use this procedure to extend or move a hatch from one boundary
to others. (If you do not also select the linework currently bounding the hatch,
the hatch is moved from the original boundary to the other boundaries that
you select.) The linework you select for the new hatch boundaries can be AEC
Polygons, closed polylines, circles, text, or multiline text (Mtext).

1 Select the hatch.

2 Right-click, and click Set Boundary.

3 Select the linework, and press ENTER.

4 Press ENTER to keep the selected linework, or enter y (Yes) to erase
it.

The selected hatch is applied within all selected boundaries.

Transferring a hatch from one boundary to another
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Moving a hatch back to original boundary
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Resizing a hatch to fill a boundary
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Copying a hatch from one boundary to another

NOTE If a hatch was originally created as associative, its associativity is not
transferred to other linework to which the hatch is applied using the Set Boundary
option. And if the original boundary itself is one of the boundaries selected during
the operation, the association between the boundary and the hatch is discontinued.

AEC Modify Tools
You can perform a variety of editing operations on linework components and
certain architectural objects using AEC Modify tools. AEC Modify tools can
be used on any of the following objects:

■ Hatches

■ Polylines

■ Circles

■ Arcs

2838 | Chapter 36   Detail Drafting Tools



■ Text/Multiline text (Mtext)

■ Spaces

■ AEC Polygons

■ Mass element extrusions

■ Any of the above when embedded in blocks

Although some of the AEC Modify Tools can only be applied to the types of
objects listed above, objects of any type can be used as reference points or
boundaries for the editing operations. For example, linework can be trimmed
or extended in relation to architectural objects such as walls. Likewise,
architectural objects can be used to define a cropping boundary or an area to
subtract from linework. Architectural objects can also be included as part of
a collection of objects for which a shrinkwrap outline is generated.

When you work with architectural objects, such as windows and doors, you
can use Array, Reposition From, Space Evenly, and Center tools in this suite
in addition to linework and profile-based objects.

Trimming Linework or Profile-Based Objects
Use this procedure to trim hatches, lines, polylines, arcs, circles, AEC Polygons,
mass element extrusions, spaces, or any block-based content (including detail
components) made up of these types of linework or objects.

1 Select the linework, object, or block to trim.

2 Click Home tab ➤ Modify panel ➤ Trim Extend drop-down ➤ AEC

Trim  .

3 Specify two points to establish the trim line.

The trim line changes color once the second point is selected, as
does all linework (except hatches) on the side of the trim line
where the cursor is positioned.

4 Click the side of the trim line where the region you want to
remove is located.

All linework on the selected side of the trim line is removed, and
boundaries for any closed polylines on the other side are redrawn
along the trim line.
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Trimming a block

Trimming Linework or Profile-Based Objects to an Edge
Use this procedure to trim one or more lines, polylines, arcs, circles, hatches,
AEC Polygons, mass element extrusions, or spaces precisely to a selected edge
or side of any straight segment of AEC linework. This feature lets you easily
trim linework to components of walls.

TIP If you need to trim linework to the edge of an arced segment of an object,
use either the Crop option (see Cropping Linework or Profile-Based Objects on
page 2847) or the Subtract option (see Subtracting from Linework and Profile-Based
Objects on page 2844). The Crop option removes linework outside the implied
boundary of the arc, while the Subtract option removes linework inside the implied
boundary of the arc.
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1 Select the linework or object to trim.

2 Click Home tab ➤ Modify panel ➤ Trim Extend drop-down ➤ AEC

Trim  .

3 Press ENTER.

4 Move the cursor over the edge or line to which you want to trim
the selected linework or object.

5 Click when the trim line displays.

6 Click the side of the trim line you want trimmed.

All selected linework is trimmed to the edge you selected.

Trimming linework to the edge of a wall

Extending Linework to an Edge
Use this procedure to extend one or more lines, open polylines, or arcs precisely
to an implied edge of a straight or arced segment of any object, or to an implied
extension of that segment.

1 Select the linework you want to extend.
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2 Click Home tab ➤ Modify panel ➤ Trim Extend drop-down ➤ AEC

Extend  .

3 Move the cursor over the edge or line to which you want to extend
the selected linework, and click when a temporary line is displayed
extending along and beyond the edge/line in both directions.

4 Click any point on the linework you want to extend, or click the
edge or line to which you want to extend the linework.

The linework is extended to the edge. If you selected multiple
lines, clicking on any one of them extends them all.

Extending linework to the edge of a wall

Dividing Linework and Profile-Based Objects
Use this procedure to divide linework, AEC Polygons, mass element extrusions,
spaces, or a block containing any of these objects into two (or more) parts
defined by a divide line you draw. The parts on either side of the line are then
separately selectable. If a closed-boundary object is divided into two parts
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using this option, both parts are recreated as closed. If an open polyline in a
zigzag pattern is divided along its length, many selectable segments are created.

1 Select the linework, object, or block you want to divide.

2 Click Home tab ➤ Modify panel ➤  ➤ Align

drop-down ➤ Divide  .

3 Specify two points to establish the divide line. In the case of a
closed-boundary object, the points can be inside or outside the
boundaries; the divide line is automatically extended until it
intersects all boundaries of the selected object.

The divided parts of the linework or object on either side of the
divide line are now selectable. Note that the divide line is no
longer visible once the second point is selected.

Dividing a space object
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Subtracting from Linework and Profile-Based Objects
Use this procedure to subtract a selected part from linework, AEC Polygons,
mass element extrusions, spaces, or from a block containing any of these
objects, without having to redraw any of the remaining components. You can
also specify the corners of a rectangle as the subtraction. The part to be
subtracted can contain or be delineated by lines, polylines (closed or open),
arcs, circles, text, or hatches. If the subtraction removes part of a closed
polyline, the polyline is recreated as closed. If the subtraction bisects a closed
polyline, both parts are recreated as separate closed polylines. However, in
cases where the subtraction bisects a hatch, the hatch remains a single linework
entity that you can select by clicking either “part.”

NOTE Anything subtracted by this operation is actually deleted from the drawing.
If you only want to hide linework from view, you may want to use the Obscure
command instead. For more information, see Obscuring Regions of Linework on
page 2845.

1 If it does not already exist, draw the linework that delineates what
you want to subtract.

2 Select the linework or object from which to subtract the delineated
part.

3 Click Home tab ➤ Modify panel ➤  ➤ Merge Subtract

drop-down ➤ Subtract  .

4 Press ENTER and specify a rectangular shape to be subtracted from
the object.

5 Alternately, select the linework delineating the part you want to
subtract and press ENTER.

6 Press ENTER to keep the selected linework, or enter y (Yes) to erase
it.
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Subtracting part of a block with an existing polyline

Subtracting part of a block by specifying rectangle corners

Obscuring Regions of Linework
Use this procedure to obscure or “hide” a region of linework in relation to
other linework. This feature is chiefly useful when you want to indicate that
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one entity extends behind or beneath another entity that you want to display
in the foreground. The obscured linework is placed on the layer specified by
the HIDDEN layer key. Once you have begun the Obscure command, you can
also specify two corners of a rectangle to use.

1 Select the linework to hide (the linework “being obscured”).

2 Click Home tab ➤ Modify panel ➤  ➤ Obscure Crop

drop-down ➤ Obscure  .

3 Select the “obscuring linework” (that is, the linework behind
which you want to hide the originally selected linework), and
press ENTER.

The obscured region is delineated with a dashed line. You can
select it (or its component segments) separately from the linework
it was part of before being obscured.

Obscuring linework with a block

4 Alternately, press ENTER and specify a rectangular shape to obscure
the object.

Merging Linework or Profile-Based Objects
Use this procedure to merge contiguous closed polylines, circles, hatches, AEC
Polygons, mass element extrusions, spaces, or blocks into a single
closed-boundary object or linework entity.
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1 Select the linework or object to which you want to add one or
more other linework entities or objects.

2 Click Home tab ➤ Modify panel ➤  ➤ Merge Subtract

drop-down ➤ Merge  .

3 Select the linework/object(s) you want to merge with the originally
selected linework/object, and press ENTER.

4 Press ENTER to keep the selected linework, or enter y (Yes) to erase
it.

All selected linework and/or objects are merged into a single entity
of the type you selected first. That is, if you select an AEC Polygon
in Step 1 and a space object in Step 3, the resulting entity is an
AEC Polygon.

Merging a region with a block

5 Alternately, press ENTER after Step 2 and specify a rectangular
shape to merge with the linework or object.

Cropping Linework or Profile-Based Objects
Use this procedure to crop linework or a profile-based object to a smaller area
with a boundary you define. You can crop hatches, lines, polylines, arcs,
circles, AEC Polygons, mass element extrusions, spaces, and/or blocks. Neither
the linework to be cropped nor the linework that defines the new boundary
needs to have closed boundaries. For example, you can use a v-shaped polyline
to crop a circle, or you can use a circle to crop a v-shaped polyline. Once you

Cropping Linework or Profile-Based Objects | 2847



have begun the Crop command, you can also specify two corners of a rectangle
to crop the linework or objects.

1 Draw the linework that defines the new boundary to which you
want to crop the existing linework.

2 Click Home tab ➤ Modify panel ➤  ➤ Obscure Crop

drop-down ➤ Crop  .

3 Select the linework to crop and press ENTER.

4 Select the linework you want to define the new boundary (the
linework you drew in Step 1), and press ENTER.

5 Press ENTER to keep the selected linework (the crop boundary), or
enter y (Yes) to erase it.

All of the originally selected linework outside the crop boundary
is erased. If you choose to erase the crop boundary, boundaries
are redrawn for any closed-boundary entities inside the crop area,
but any open-boundary objects that have been cropped remain
open.

Cropping a block with a polyline

6 Alternately, press ENTER after Step 2 and specify a rectangular
shape to crop the linework or object.
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Shrinkwrapping Linework
Use this procedure to automatically create a profile or shrinkwrap outline
around any collection of contiguous linework entities, including architectural
objects. The visual result of the procedure is similar to merging the entities
(see Merging Linework or Profile-Based Objects on page 2846), but in this case
the outline you create is a separately selectable entity. Unlike the other AEC
Linework Tools, the Shrinkwrap tool is accessed from the General tool palette.
The AecLineworkShrinkwrap command the tool invokes is wrapped in a
DesignCenter command to accommodate layer keying (that is, shrinkwrap
polylines created using this tool are automatically placed on a particular layer
as specified by the associated layer key).

1 Open the Detailing tool palette, and click the Basic tab.

2 Click the Shrink Wrap tool.

3 Select all of the objects you want to shrinkwrap.

4 Press ENTER.

All objects within the shrinkwrap remain selected. You can now
select and move the shrinkwrap profile independently of the
linework it encloses.

Shrinkwrapping Linework | 2849



Creating Arrays
Use this procedure to create an array of identical linework (such as hatches
and polylines), architectural objects (such as doors and walls), AEC polygons,
or profile-based objects (such as mass element extrusions, and spaces). You
can also array any block-based content (including detail components) made
up of these types of linework and objects.

1 Select the linework, object, or block to array.

2 Click Home tab ➤ Modify panel ➤  ➤ Arrays

drop-down ➤ AEC Array  .

3 Select an edge and drag the cursor to specify the direction of the
array for a rectangular array.

The number of objects you are adding to the array is displayed in
the tooltip as Array Count.

Arraying a block

4 Enter a value for the distance offset between each instance of the
linework or object, and press ENTER.

Alternately, for a polar array, specify two points to establish the
angle of the array, enter a value for the distance offset between
the linework or object, and press ENTER.

5 Click in the drawing area to specify the endpoint of the array.

For more information on arrays, see “Array Dialog Box” in
AutoCAD Help.
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Repositioning from a Reference Point
Use this procedure to reposition architectural objects, linework, or blocks from
a specific reference point in your drawing. For example, if you have a kitchen
island that you want repositioned 6'-0” from existing cabinetry, you can place
the island using the interior edge of the cabinet as a reference point. You can
also use this procedure with hatches, lines, polylines, arcs, circles, AEC
Polygons, mass element extrusions, spaces, or any block-based content
(including detail components and DesignCenter content) made up of these
types of linework or objects.

1 Select the linework, object, or block to reposition.

2 Click Home tab ➤ Modify panel ➤  ➤ Align

drop-down ➤ Reposition From  .

3 Select an existing edge from which to reposition the object, or
specify two points to define a reference edge.

4 Select the object to be repositioned, and enter a value for the
distance between it and the reference edge.

5 Press ENTER.

Evenly Spacing Linework or Objects
Use this procedure to space a collection of existing architectural objects,
linework, or blocks at an equal distance from each other. For example, if you
have windows along walls that are not colinear, you can space the windows
evenly across the entire facade by specifying points along an axis. You can
use this procedure with hatches, lines, polylines, arcs, circles, AEC Polygons,
mass element extrusions, spaces, or any block-based content (including detail
components) made up of these types of linework or objects.

1 Select the linework, object, or block to space.

2 Click Home tab ➤ Modify panel ➤  ➤ Align

drop-down ➤ Space Evenly  .

3 Select an edge as the axis along which to space all the objects
evenly, and specify a start point and an endpoint along the edge;
or press ENTER, and specify two points between which the objects
will be spaced evenly from each other.
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NOTE For example, if you select two objects to be spaced between
two points, the spacing of the objects is from the specified start point
to the center of the first object, from the center of the first object to
the center of the second object, and from the center of the second
object to the specified endpoint.

Centering Linework or Objects
Use this procedure to center any of the following between two points:
architectural objects, hatches, lines, polylines, arcs, circles, AEC Polygons,
mass element extrusions, spaces, or any block-based content (including detail
components) made up of these types of linework or objects.

1 Select the linework, object or block to center.

2 Click Home tab ➤ Modify panel ➤  ➤ Align

drop-down ➤ Center  .

3 Select an existing edge as an axis, and then specify two points
between which to center the object on that axis; or press ENTER,
and specify any two points between which to center the object.
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Profiles

Profiles are closed linework shapes that can be used to define components of complex objects.

What are Profiles?
Profiles are closed linework shapes that can be used to define components of
complex objects.

Example: default and profile-based curtain wall frames
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Example 2: extruded mass element

Example 3: roof slab fascia and soffit

They can be used to create the following objects and components:

■ extruded and revolution mass elements

■ slab and roof slab edges (fascia and soffits)

■ frames for doors, windows, openings, door and window assemblies, and
curtain walls

■ muntins for doors, windows, openings, door and window assemblies, and
curtain walls

■ railing guardrails, handrails, bottom rails, and posts

■ wall sweeps

NOTE Because profiles are supporting objects that define the shape of other
objects, you cannot create a profile tool on the tools palette, or insert a standalone
profile in the drawing.

Profiles consist of one or more closed lines, which are referred to as rings.
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Mass element extruded from profile.

Profiles can be created from the following objects:

■ closed polylines

■ rectangles

■ circles

■ ellipses

■ splines

■ AEC polygons

You can draw more than one closed linework ring in order to create a profile.
A two-ring profile will create a void in the resulting object; a three-ring profile
will create a void with an island.

Creating Profiles
Use this procedure to create a profile.

1 Draw closed linework in the shape you need for the profile-based
component.

2 Select the linework, right-click, and click Convert To ➤ Profile
Definition.

3 To add another closed linework component to the profile, enter
a (Add Ring), and select the desired linework.
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4 Define the insertion point of the profile:

■ To create the insertion point at the object center, enter c
(Centroid).

■ To create the insertion point at a different point of the object,
specify an insertion point on screen.

5 Press ENTER.

6 Enter a name for the profile, and click OK.

You can now use the profile as a building block for profile-based
object components.

NOTE Alternatively, you can click Manage tab ➤ Style & Display

panel ➤  ➤ Profile Definitions  , and add a new profile. In
order to define the geometry, right-click the new profile definition
in Style Manager, click Set From, and select the desired linework on
screen.

Defining the Direction of Profile Edges and Extrusion
When a profile is used to extrude objects or components, you need to set the
following parameters:

■ the position of each edge in a profile (left, right, back, discard, none)

■ the axis along which the object is extruded from the shape of the profile

These settings determine how surface hatching is applied to objects created
from the profile and how the objects are extruded from the two-dimensional
(2D) profile.

For information of surface hatching, see Working with Surface Hatches on
page 904. See below some examples for different extrusion directions.

2856 | Chapter 37   Profiles



Face assignments from edges extruded in the X direction

Face assignments from edges extruded in the Y direction

Face assignments from edges extruded in the Z direction
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NOTE Objects already created from the profile change when you change profile
edges or the axis of extrusion.

1 Click Manage tab ➤ Style & Display panel ➤  ➤ Profile

Definitions  .

2 Select the profile you want to change.

3 Click the Profile Edges tab.

4 Select an edge, and specify its position:

Then…If you want to…

click Calculate Default Edge Posi-
tions. You can then override the

let the software determine the pos-
ition of edges

position of individual edges, if ne-
cessary.

select the setting for Edge, and se-
lect a new position.

select a position for an edge

select the setting for Edge, and se-
lect None.

exclude an edge from surface
hatching

select the setting for Edge, and se-
lect Discard.

discard an edge

5 Specify the axis of extrusion based on the type of object created
from the profile:

Then…If you want to…

select X for Extrusion Direction.create a profile for roof slab or slab
fascia, wall sweeps, or railings

select Y for Extrusion Direction.create a profile for a slab soffit, or
opening frame

select Z for Extrusion Direction.create a profile for an extruded
mass element

6 Click OK.
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Adding a Profile to an Object Component
Profiles can be used to determine the shape of various objects and object
components. The table below contains links for how to add a profile to the
various objects and components:

How toObject component

Creating a Mass Element by Extruding a Profile on page
1019

extruded mass elements

Creating a Mass Element by Revolving a Profile on page
1020

revolution mass elements

Specifying a Fascia and a Soffit for a Slab/Roof Slab Edge
Style on page 2514

roof slab and slab edges

Specifying the Design Rules of a Door Style on page 1903door frames
Replacing the Door Shape in a Door Style on page 1906

Specifying the Design Rules of a Window Style on page
2010

window frames

Replacing the Window Shape in a Window Style on page
2011

Creating an Opening with a Custom Shape on page 2066opening frames

Adding Glass to a Door Style on page 1928door muntins

Adding a Custom Profile to a Railing Component on page
2332

railings

Defining a Curtain Wall Frame Using a Profile on page 1464curtain wall frames/mul-
lions Defining the Mullions of a Curtain Wall Using a Profile on

page 1471
Defining a Curtain Wall Unit Frame Using a Profile on page
1602
Defining the Mullions of a Curtain Wall Unit Using a Profile
on page 1609

Defining a Door and Window Assembly Frame Using a
Profile on page 1733

door and window assembly

Defining the Mullions of a Door and Window Assembly
Using a Profile on page 1741
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How toObject component

Creating an AEC Polygon from a Profile on page 1833AEC polygon

Adding a Sweep to a Wall on page 1258wall sweeps

Editing a Profile In Place
Profiles that are assigned to objects in the drawing provide in place editing,
so that you can change the shape of the profile (and thereby the component)
on screen. The edit in place mode is a special editing mode where object
components can be edited, but other editing capabilities are limited. For
example when you are in edit in place mode, you cannot save and close the
drawing. Upon exiting the edit in place mode, you can choose if the changes
should discarded, overwrite the existing profile definition, or if a new profile
definition should be created.

Entering the edit in place mode

1 Insert an object with the desired profile into the drawing. For a
list of objects that can have profiles, see What are Profiles? on
page 2853.

2 Select the object and do one of the following:

■ On the contextual tab of the object on the ribbon, select the
Edit in Place command. Depending on the object, the edit in
place command can be located in different panels. Also, some
objects like walls or curtain walls can have multiple
profile-based components. In this case, first select the
appropriate panel for the component, and then the associated
Edit in Place command.

■ Select the Edit Profile in Place command from the context
menu of the object. If an object has multiple profile-based
components, first select the correct submenu, for example
Sweeps  ➤ Edit in Place.
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The edit in place mode is characterized by the following user
interface changes:

■ On the ribbon, the contextual Edit in Place tab for the selected
component is displayed.

Edit in Place tab for Wall Endcaps

■ Grips on editable profiles display in a magenta color to identify
an edit in place grip mode.

■ A number of commands, such as closing or saving the drawing,
are deactivated while the in-place edit mode is active. In order
to access them, you must exit the in-place edit mode first.

Editing the profile

3 Select the profile you want to edit.
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Grip-edit options for profiles

4 Use the grips, the ribbon, or the context menu in order to make
any of the following changes to the profile:

Select the vertex grip, and move it.Move a Vertex

Add a Vertex ■ Grips: Select the edge grip that is closest to the
location of the new vertex. Then, press Ctrl once
and use the preview image to place the new
vertex.

■ Ribbon: On the Edit in Place tab of the selected

profile, click Profile panel  ➤ Add Vertex  .
Then, specify the location of the new vertex on
screen.

■ Context menu: Click Add Vertex, and specify
the location of the new vertex on screen.

Remove a vertex ■ Grips: Select the vertex grip you want to re-
move. Then, press Ctrl once and click to remove
the vertex.

■ Ribbon: On the Edit in Place tab of the selected

profile, click Profile panel  ➤ Remove Vertex 
. Then, select the vertex to remove on screen.

■ Context menu: Click Remove Vertex, and select
the vertex to remove.

Offset a vertex with its edges ■ Grips: Select the vertex grip which you want to
offset with its associated edges. Then, press Ctrl
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twice and drag the vertex to the desired loca-
tion.

Offset a profile edge ■ Grips: Select the grip of the edge you want to
offset and drag it to the desired location.

Convert an edge to an arc ■ Grips: Select the grip of the edge you want to
convert, and press Ctrl twice. Then, drag the
grip until the desired arc shape is in place.

Offset all edges of the profile ■ Grips: Select any edge grip on the profile, and
press Ctrl three times. Then, drag the grip until
the overall profile shape is correct.

Add a ring to a profile ■ Ribbon: On the Edit in Place tab of the selected

profile, click Profile panel  ➤ Add Ring  .
Then, select a closed polyline, spline, ellipse or
circle to convert.

■ Context menu: Select the profile, and click Add
ring. Then, select a closed polyline, spline, el-
lipse to convert.

Remove a ring from a profile ■ Ribbon: On the Edit in Place tab of the selected

profile, click Profile panel  ➤ Remove Ring 
. Then, select the ring you want to remove from
the profile, and press Enter.

■ Context menu: Select the profile, and click Re-
move Ring. Then, select the ring you want to
remove from the profile, and press Enter.

Replacing a ring with another ■ Ribbon: On the Edit in Place tab of the selected

profile, click Profile panel  ➤ Replace Ring 
. Then, select the ring you want to replace and
the ring that should be used instead.

■ Context menu: Select the profile, and click Re-
place Ring. Then, select the ring you want to
replace, and after that the ring that should be
used instead.

Editing a Profile In Place | 2863



Ending the edit in place mode

5 When you have made all changes to the profile, you can end the
edit in place mode in one of the following ways:

Then…If you want to…

discard the changes and revert
the profile to its original shape

■ Ribbon: On the Edit in Place tab of the

selected profile, click Edits panel ➤ Can-

cel  .

■ Context menu: Click Discard All
Changes.

save the changes to the current
profile

■ Ribbon: On the Edit in Place tab of the

selected profile, click Edits panel ➤ Fin-

ish  .

■ Context menu: Click Save Changes.

save the changes to a new
profile definition

■ Ribbon: On the Edit in Place tab of the
selected profile, click Edits pan-

el ➤ Save As  . Enter a name for the
new profile definition, and click OK.

■ Context menu: Click Save as New
Profile.

Converting Profiles to Polylines
You cannot insert a standalone profile into a drawing. You can however insert
a profile as a polyline into the drawing. This process would be most useful
when you want to make changes to the profile shape. You insert the profile
as a polyline, make changes to the polyline, and then re-convert the polyline
to the profile.

1 Click Manage tab ➤ Style & Display panel ➤  ➤ Insert As
Polyline.

2 Select the profile you want to insert as a polyline.

3 Select the insertion point in the drawing, and place the polyline.
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4 Make changes to the polyline as needed.

5 If you want to save the polyline shape back to the profile, select
the polyline, right-click, choose Convert to ➤ Profile.

6 On the command line, enter e (Existing), and select the name of
the existing profile in the Profile Definitions worksheet.

The current polyline shape will overwrite the profile definition.

7 If you want to save the changed polyline shape to a new profile,
enter n (New) and enter the name for the new profile.
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Mask Blocks

A mask block is a two-dimensional (2D) block that covers, or “masks,” part of the graphic
display of an AEC object in a plan view. You can use mask blocks to clean up or correct objects
in your drawings or to create custom 2D shapes from predefined drawing objects, such as
walls or grids.

Mask Blocks
A mask block is a two-dimensional (2D) block that covers, or “masks,” part of
the graphic display of an AEC object in a plan view. You can use mask blocks
to clean up or correct objects in your drawings or to create custom 2D shapes
from predefined drawing objects, such as walls or grids.

For example, attach a light fixture as a mask block to a ceiling grid in a plan
view. If the light fixture is bigger than one or more of the ceiling grid bays, the
light fixture masks, or covers, the ceiling grid lines that would visibly pass
through the light fixture if it had been defined as a regular AutoCAD block.

Before you can begin to mask objects in your plan view drawings, you must
have an existing mask block or a mask block definition created in your drawing.
You can find predefined mask blocks on the Drafting tool palette and in the
AutoCAD Architecture Stock Tool catalog. You can also create a mask block
with the AEC Content Wizard. For more information about custom content,
see Creating an AEC Content Masking Block for DesignCenter on page 3924.

After you have selected a mask block, add it to your drawing in plan view.
Adding the mask block to your drawing is like adding a regular AutoCAD block:
specify an insertion point or scale factors and a rotation angle. The mask block
and the object that you want to mask must be coplanar; that is, for the mask
object to cover the other object, they must be on the same plane.

After you insert a mask block in your drawing, attach the objects to be masked.
The mask block clips the graphics of the objects that you are masking when the
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objects regenerate themselves in a plan view. Only the objects that you attach
to the mask block are clipped. The masked objects are plotted as you see them
on your screen.

If you change your drawing from a 2D view to a three-dimensional (3D) view,
the mask block is still displayed, but it no longer masks the objects that are
attached to it. You can detach the mask block from the objects at any time.
You can also import and export mask block definitions. If you create a mask
block definition that you decide not to use in your drawings, you can purge
it.

Creating Mask Block Definitions
You can define a mask block by selecting a closed polyline in the drawing and
defining it as a mask block, by copying and editing an existing mask block,
or by using the AEC Content Wizard.

Use the AEC Content Wizard to save mask blocks in content drawings for
convenient reuse. For more information, see Creating an AEC Content Masking
Block for DesignCenter on page 3924.

Managing Mask Block Definitions

To create, edit, copy, or purge mask block definitions, use the Style Manager.
The Style Manager provides a central location in AutoCAD Architecture, where
you can work with definitions and styles from multiple drawings and
templates. For more information, see Style Manager Overview on page 870.

Creating a Mask Block Definition from a Polyline
Use this procedure to create a mask block definition from one or more closed
polylines. If you use more than one polyline to create your mask block
definition, the polylines must be completely within or completely outside
each other: they cannot overlap or touch. Polylines that are within each other
can be specified as void areas that become holes when the mask block is
created. After you create the definition, edit the definition properties to
customize the characteristics of the definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed, with the current drawing
expanded in the tree view.

2868 | Chapter 38   Mask Blocks



2 Expand Multi-Purpose Objects, right-click Mask Block Definitions,
and click New.

3 Enter a name for the new mask block definition, and press ENTER.

4 Right-click the new mask block definition name, and click Set
From.

5 Select the closed polyline to use to create the mask block
definition.

6 Do one of the following to complete the mask block definition:

■ Press ENTER to create the mask block definition from a single
polyline.

■ Enter y (Yes) to select additional polylines to add to the mask
block definition. These polylines must be entirely within or
outside each other; they cannot overlap or touch. Polylines
that are within other rings can be specified as void areas that
become holes in the mask block.

7 Specify an insertion base point for the mask block.

8 Select additional graphics to include in the mask block definition,
or press ENTER if you do not want to include additional graphics.

NOTE You can select text or symbols to include in the mask block
definition.

9 Click OK.

A mask block definition is created from the polyline or polylines that you
selected. The new mask block definition is listed in the mask block definition
tree and can be viewed in the graphics screen of Style Manager. The original
polylines remain in the drawing.

Creating a Mask Block Definition from an Existing Mask Block
Definition

Use this procedure to create a mask block definition from a mask block
definition that already exists in a drawing. After you create the new definition,
you edit the definition properties to customize the characteristics of the
definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .
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The Style Manager is displayed, with the current drawing
expanded in the tree view.

2 Expand Multi-Purpose Objects, and expand Mask Block
Definitions.

3 Right-click the mask block definition to copy, and click Copy.

4 Right-click, and click Paste.

5 Right-click the new mask block definition, and click Rename.

6 Enter a name, and press ENTER.

7 Click OK.

Importing Mask Block Definitions
Use this procedure to import a mask block definition from another drawing.
After you create the definition, you edit the definition properties to customize
the characteristics of the definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed, with the current drawing
expanded in the tree view.

2 On the File menu, click Open drawing to browse for the drawing
that contains the definition that you want to copy to your current
drawing.

3 Select the drawing with the definition to copy, and click Open.

4 Expand Multi-Purpose Objects, and expand Mask Block
Definitions.

5 Right-click the mask block definition to copy, and click Copy.

6 Select the current drawing, and expand Multi-Purpose Objects.

7 Right-click Mask Block Definitions, and click Paste.

The definition is copied into the current drawing. If the current
drawing already contains a definition with the same name, the
duplicate names are displayed in the Import/Export - Duplicate
Names Found dialog box.

8 To resolve duplicate names, select one of the following options:

■ To not replace the existing definition in the drawing with the
new definition of the same name, select Leave Existing, and
click OK.
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■ To replace the existing definition in the drawing with the new
definition, select Overwrite Existing, and click OK.

■ To rename the new definition so both definitions exist in the
drawing, select Rename to Unique, and click OK. New
definition names are appended with a numeral in the Style
Manager.

9 Click OK.

Exporting Mask Block Definitions to a New Drawing
Use this procedure to copy mask block definitions from your current drawing
to a new drawing. After you create the definition, you edit the definition
properties to customize the characteristics of the definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed, with the current drawing
expanded in the tree view.

2 On the File menu, click New drawing to create the drawing to
which you want to copy the definition.

3 Enter a name for the new drawing, and click Save.

The new drawing opens in the Style Manager.

4 In the current drawing, Expand Multi-Purpose Objects, and expand
Mask Block Definitions.

5 Right-click the mask block definition to copy to the new drawing,
and click Copy.

6 Select the new drawing, and expand Multi-Purpose Objects.

7 Right click Mask Block Definitions, and click Paste.

8 Click OK.

Exporting Mask Block Definitions to an Existing Drawing
Use this procedure to copy mask block definitions from your current drawing
to another drawing. After you create the definition, you edit the definition
properties to customize the characteristics of the definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .
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The Style Manager is displayed, with the current drawing
expanded in the tree view.

2 On the File menu, click Open drawing to browse for the drawing
to which you want to copy the definition.

3 Select the drawing that you want to copy the definition to, and
click Open.

The drawing opens in the Style Manager.

4 In the current drawing, Expand Multi-Purpose Objects, and expand
Mask Block Definitions.

5 Right-click the mask block definition to copy to the second
drawing, and click Copy.

6 Select the second drawing, and expand Multi-Purpose Objects.

7 Right-click Mask Block Definitions, and click Paste.

8 The definition is copied into the second drawing. If the drawing
already contains a definition with the same name, the duplicate
names are displayed in the Import/Export - Duplicate Names
Found dialog box.

9 To resolve duplicate names, select one of the following options:

■ To not replace the existing definition in the drawing with the
new definition of the same name, click Leave Existing, and
click OK.

■ To replace the existing definition in the drawing with the new
definition, click Overwrite Existing, and click OK.

■ To rename the new definition so both definitions exist in the
drawing, click Rename to Unique, and click OK. New definition
names are appended with a numeral in the Style Manager.

10 Click OK.

Editing a Mask Block Definition
Use this procedure to make any of the following types of modifications to a
mask block definition:

■ Change the objects or styles to which the mask block can be attached.

■ Add and remove properties.

■ Change the name, description, type, and format of properties.
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Changes that you make to a mask block definition are immediately applied
to any objects or styles to which the mask block created from the definition
is attached.

1 Select a mask block object, and click Mask Block Reference
tab ➤ General panel ➤ Edit Style drop-down ➤ Mask Definition
Styles.

The Style Manager is displayed, and Mask Block Definitions is
highlighted in the tree view of the current drawing.

NOTE Alternatively, you can click Manage tab ➤ Style & Display

panel ➤ Style Manager  , expand Multi-Purpose Objects, and
expand Mask Block Definitions.

2 Select the mask block definition.

3 Click the Classifications tab.

4 Select a classification for the classification definition.

For more information, see Classification Definitions on page 3872.

5 Click the Display Properties tab.

6 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

7 If necessary, click  .

8 Click the Layer/Color/Linetype tab.

9 Select the component to change, and select a different setting.

10 Click OK.

11 Click the General tab.

12 Enter text for Description.

13 Click Notes.

14 Click the Notes tab, and enter a note.

15 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file
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Then…If you want to…

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

16 Click OK.

17 To attach or edit schedule data, click Property Sets. For more
information, see Attaching Property Set Data to Objects on page
3811 and Entering Manual Properties and Fields for Objects on page
3812.

18 Click OK.

Adding Classifications to a Mask Block Definition
Use this procedure to specify classifications for any classification definition
applied to a mask block definition. Classifications enable you to track objects
by construction status, vendor, or other criteria. For more information about
creating and applying classification definitions, see Classification Definitions
on page 3872.

1 Open a tool palette that has a mask block definition tool.

2 Right-click a mask block definition tool, and click Mask Block
Definitions.

3 Select the definition that you want to change.

4 Click the Classifications tab.

By default, the classification for all classification definitions is
Unspecified. If no classification definitions are listed, none are
applied to mask block definitions.

5 For each classification definition, select the classification you want
to apply to the current mask block definition.

6 Click OK.
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Purging Mask Block Definitions
Use this procedure to purge mask block definitions from your drawing. You
have the option to purge any mask block definition unless it is currently
applied as a mask block in the drawing.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed, with the current drawing
expanded in the tree view.

2 Expand Multi-Purpose Objects, and expand Mask Block
Definitions.

3 Purge mask block definitions:

Then…If you want to…

right-click the style you want to re-
move, and click Purge.

purge one unused mask block
definition style

right-click Mask Block Definitions,
and click Purge. When prompted,

purge all unused mask block defini-
tion styles

verify that the styles you want to
purge are selected, and click OK.

4 Click OK.

Using Mask Block Tools to Create Mask Blocks
Tools provided with AutoCAD Architecture let you quickly place mask blocks
using tool with a specific mask block definition and other predefined
properties. You can use the default settings of tool, or you can change any
properties that are not controlled by the definition. You can also create new
mask blocks by applying tool properties to existing mask blocks or to closed
polylines. For more information, see Creating a Mask Block Tool on page 2878.

Mask block tools are found in the following locations:

ToolLocation

a mask block tool for the Standard mask
block definition style and default settings
for other mask block properties

Drafting tool palette
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ToolLocation

a mask block tool for the Standard mask
block definition style and default settings

Drafting Tools category in the Stock Tool
catalog

for other mask block properties. For more
information on accessing tools in this
catalog, see Content Browser Overview on
page 129.

Mask block tools with mask block definition
styles and properties customized for your
projects or office standards

custom tool palettes created by your CAD
manager

NOTE The Standard mask block definition style is imported if you create your
drawing with a template. It will not be present if you start your drawing without
using a template. For more information, see About Templates on page 179.

Adding a Mask Block
Use this procedure to add a new mask block that has the properties specified
in the mask block tool that you select. To specify settings when you add a
mask block, see Adding a Mask Block with User-Specified Settings on page 2877.
You can add a mask block to a drawing if the drawing contains a mask block
definition. For more information, see Creating Mask Block Definitions on
page 2868.

TIP When you add mask blocks to your drawing, insert them on a separate layer.
You can turn the layer off in 3D views, where the mask blocks no longer mask any
objects.

1 If you have created your own mask block definition, create a tool
from it as described in Creating a Mask Block Tool on page 2878.

2 If you are working with an existing mask block tool, open the
palette it is located on.

A mask block tool is located on the Drafting tool palette and in
the Drafting Tools category in the AutoCAD Architecture Stock
Tool catalog. You can add this tool to any tool palette. For more
information, see Content Browser Overview on page 129.

3 Select the mask block tool on the palette.

4 Specify the insertion point of the mask block.
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You can move or hide the Properties palette to expose more of
the drawing area.

NOTE If you are using a mask block to mask a wall, the mask block
must be located at the baseline of the wall (Z = 0). Even though the
wall components are at different heights, the plan display
representation draws them at the height of the baseline, as they
would be drawn on paper.

5 Continue adding mask blocks, and press ENTER.

The mask blocks are displayed in the drawing at the insertion
point you specified. To use a mask block to clean up or correct
an object in the drawing, attach the object to the mask block.

Adding a Mask Block with User-Specified Settings
Use this procedure to add a mask block with settings that you specify.

1 Open the tool palette that contains the mask block tool you want
to use, and select the tool.

(You may have to scroll to display the desired tool.)

2 On the Properties palette, expand Basic, and expand General.

3 Select a definition.

4 Expand Scale.

5 Enter the X, Y, and Z scale of the mask block. The X, Y, and Z scales
represent the distance from the insertion point.

6 Alternately, select Yes for Specify scale on screen. Use your
pointing device to designate the scale of the mask block.

7 Expand Location.

8 Enter rotation and elevation values.

9 Alternately, select Yes for Specify rotation on screen. Use your
pointing device to designate the rotation of the mask block.

10 In the drawing area, specify the insertion point of the mask block.

You can move or hide the Properties palette to expose more of
the drawing area.

11 Continue adding mask blocks, and press ENTER.

To use a mask block to clean up or correct an object in the
drawing, attach the object to the mask block.
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Creating a Mask Block from Polylines
Use this procedure to create a mask block reference from one or more closed
polylines. If you use more than one polyline to create your mask block, the
polylines must be completely within or completely outside each other; they
cannot overlap or touch. Polylines that are within each other can be specified
as void areas that become holes when the mask block is created.

1 Select the polylines, right-click, and click Convert To ➤ Mask
Block.

The Convert to Mask Block worksheet is displayed.

2 Enter a name for the new mask block.

3 Clear Mask AEC Objects Automatically to avoid masking existing
AEC objects overlapping the polylines being converted.

4 To select existing AEC objects for masking with the new mask
block, make sure Select AEC Objects to Mask is selected.

5 Select Erase Layout Geometry to erase the original polylines, and
click OK.

6 Edit the properties of the mask block in the Properties palette, if
necessary.

Creating a Mask Block Tool
Use this procedure to create a mask block tool and add it to a tool palette. You
may want to create your own mask block tools if you are placing multiple
mask blocks of a specific style and they all have the same properties.

You can use any of the following methods to create a mask block tool:

■ Drag a mask block that has the properties you want to a tool palette.

2878 | Chapter 38   Mask Blocks



IMPORTANT Make sure that the mask block is in a drawing that has been
saved and that will be available in the future.

■ Drag a mask block definition from the Style Manager to a tool palette, and
then customize the properties of the new tool.

■ Drag a copy of a tool from another palette to the current palette, and then
customize the properties of the new tool.

■ Copy an existing tool in the current palette, and then customize the
properties of the new tool.

■ Drag a tool from a tool palette in the Content Browser to a tool palette,
and then customize the properties of the new tool.

1 Open the tool palette on which you want to add a tool.

2 Create the tool:

Then…If you want to…

select the mask block, and drag it
to the tool palette.

create a tool from a mask block in
the drawing

open Style Manager. Locate the
mask block definition you want to

create a tool from a mask block
definition in the Style Manager

copy, and drag it to the tool
palette. Click OK to close the Style
Manager.

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the palette where you want
to add the tool, right-click, and click
Paste.

open the Content Browser, and
locate the tool you want to copy.

copy a tool from a tool palette in
the Content Browser

Position the cursor over the i-drop
handle, and drag the tool to the
tool palette.
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3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

This description is used as the tooltip on the tool palette, and to
describe the tool if it is stored in a tool catalog.

6 Expand Basic, and expand General.

7 Specify properties for the mask block created from the tool:

Then…If you want to…

click Description, enter a description
of the tool, and click OK.

enter a description of the mask
block that you can create using this
tool

click Layer Key, select a layer key,
and click OK.

specify a unique layer key for the
object type

click Layer Overrides, clear Do not
specify Layer Overrides, specify the
override, and click OK.

specify a layer override for the tool

click Definition, select a mask block
definition, and click OK.

specify a definition

click Definition location, select the
file containing the mask block

specify a definition location

definition you want to use, click
Open, and click OK.

8 Expand Scale.

9 Specify the scale for the mask block created from the tool:

Then…If you want to…

click Yes for Specify scale on screen.use your pointing device to desig-
nate the scale for the mask block

click No for Specify scale on screen,
and enter the X, Y, and Z scale for
the mask block.

specify the scale of the mask block
on the Properties palette

10 Expand Location.
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11 Specify the rotation for the mask block created from the tool:

Then…If you want to…

click Yes for Specify rotation on
screen.

use your pointing device to desig-
nate the angle for the mask block

click No for Specify rotation on
screen, and enter the angle for Ro-
tation.

specify the angle of the mask block
on the Properties palette

12 Click OK.

Attaching Mask Blocks to Objects
Use this procedure to mask an object by attaching the mask block to the object
after you have the mask block placed correctly.

1 Select the mask block or blocks that you want to attach to an
object.

2 Click Mask Block Reference tab ➤ Modify panel ➤ Attach Objects.

3 Select the object that you want to mask.

4 Select a display representation from the list of current display
representations, and click OK.

Attaching a mask block to an object

The object is now hidden by the mask block.
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Mask blocks mask AutoCAD Architecture objects only and mask them only
in plan views. Mask blocks are visible in 3D views, but they do not mask the
objects that are attached to them.

Detaching Mask Blocks from Objects
Use this procedure to unmask an object in plan view by detaching the object
from the mask block.

1 Select the mask block that you want to detach from an object.

2 Click Mask Block Reference tab ➤ Modify panel ➤ Detach Objects.

3 Select the object that you want to detach from the mask block.

Detaching an object from a mask block

The object is detached from the mask block and is no longer hidden by the
mask block.

Editing Mask Blocks
AutoCAD Architecture offers several methods for editing mask blocks:

■ Change the location using grips.

■ Change settings on the Properties palette.

■ Edit the profile.

■ Select commands from the context menu.
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■ Change how a mask block is displayed.

Using Grips to Move Mask Blocks
Use this procedure to change the location of a mask block with grips.

1 Select the mask block.

2 Select the highlighted grip.

Viewing Mask Block Location grip

3 Move the grip until the door is in the desired location, and click
once.

Changing the Location of a Mask Block
Use this procedure to change the rotation, elevation, and location of the mask
block on the Properties palette.

You can relocate a mask block by changing the coordinate values of its
insertion point. The mask block also has an orientation with respect to the
WCS or the current UCS. For example, if the top and bottom of the mask
block are parallel to the XY plane, its normal is parallel to the Z axis. You can
change the orientation of the mask block by aligning its normal with another
axis. You can also rotate the mask block on its plane by changing the rotation
angle.

For information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use Coordinates and Coordinate Systems” in
AutoCAD Help.

TIP The quickest way to locate and view an AutoCAD topic referenced in AutoCAD
Architecture Help is to click the Search tab in the Help window, select the Search
titles only option, and then copy and paste or type in the AutoCAD topic name,
and click List Topics.

1 Double-click the mask block you want to change.

2 On the Properties palette, expand Basic, and expand Location.
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3 Specify the placement of the mask block:

Then…If you want to…

enter a new value for Rotation
Angle.

change the rotation

enter a new value for Elevation.change the elevation

4 Click Additional information to specify location of the mask block:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the mask block

make the normal of the mask block
parallel to the Z axis: under Normal,

locate the mask block on the XY
plane

enter 1 for Z, and enter 0 for X
and Y.

make the normal of the mask block
parallel to the X axis: under Normal,

locate the mask block on the YZ
plane

enter 1 for X and enter 0 for Y
and Z.

make the normal of the mask block
parallel to the Y axis: under Normal,

locate the mask block on the XZ
plane

enter 1 for Y, and enter 0 for X
and Z.

enter a new value for Rotation
Angle.

change the rotation of the mask
block

Editing the Profile of a Mask Block
Use this procedure to edit the geometry of a mask block.

NOTE If you want to replace the geometry of the mask block with newly drawn
polylines, ellipses, or circles, draw them before you start this procedure.

1 Select the mask block that you want to change.
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2 Click Mask Block Reference tab ➤ Modify panel ➤ Edit In Place

 .

3 If prompted that the profile is not drawn to size, click Yes.

A temporary profile is created for you to edit the geometry of the
mask block.

4 NOTE After you perform an editing task from the Edit in Place tab,
you may need to select the profile again to perform another editing
task. If you do not see the editing commands that you expect on the
ribbon, reselect the profile, then choose the Edit in Place command
again.

Edit the profile:

Then…If you want to…

select the profile, and use edge or
vertex grips to adjust the shape.

change the shape of the perimeter
of the profile or its rings

The Edge grip has two edit modes:
Stretch and Move. The default
mode is Stretch, and the direction
of the stretch depends on the orient-
ation of edges connected to the
selected edge. For example, if the
edges at both ends of the selected
edge are parallel, the grip edit
mode is Stretch (Parallel) and the
stretch direction is limited to the
direction of the parallel edges. If the
connected edges are not parallel,
the grip edit mode is Stretch (Off-
set) and the stretch direction is
perpendicular to the direction of
the selected edge. The Move edit
mode allows an unconstrained
move of the selected edge.

Click Edit In Place tab ➤ Profile

panel ➤ Add Vertex  . Select a

add vertices to the profile

point for each new vertex, and
press ENTER.

Editing the Profile of a Mask Block | 2885



Then…If you want to…

Click Edit In Place tab ➤ Profile

panel ➤ Remove Vertex  . Select

remove vertices from the profile

each vertex to remove, and press
ENTER.

Click Edit In Place tab ➤ Profile

panel ➤ Replace Ring  . Select

replace an existing ring of the pro-
file with new geometry

the ring to replace, and select the
new geometry. Press ENTER to keep
the geometry, or enter n (No) to
erase it.

Click Edit In Place tab ➤ Profile

panel ➤ Add Ring  . Select the

add a ring to the profile

geometry to define the ring. Press
ENTER to keep the geometry, or
enter n (No) to erase it.

Click Edit In Place tab ➤ Profile

panel ➤ Remove Ring  . Select

remove a ring from the profile

the ring to remove, and press
ENTER.

5 Save or discard the changes:

Then…If you want to…

Click Edit In Place tab ➤ Edits pan-

el ➤ Cancel  .

restore the mask block to its original
shape

Click Edit In Place tab ➤ Edits pan-

el ➤ Finish  . The mask block

save the changes to the current
mask block

uses the edited profile to define its
geometry. Any other objects or
styles that use this profile are also
updated with the edited geometry.

2886 | Chapter 38   Mask Blocks



Applying Tool Properties to an Existing Mask Block Reference
Use this procedure to apply the properties of a mask block tool to one or more
existing mask blocks. The properties include the mask block definition and
any other settings specified in the tool you select.

1 Open the tool palette that you want to use.

If necessary, scroll to display the tool that you want to use.

2 Right-click a mask block tool, and click Apply Tool Properties to
Mask Block Reference.

3 Select the mask block reference, and press ENTER.

4 Edit the properties of the mask blocks in the Properties palette, if
necessary.

Changing Display Properties of Mask Blocks
In most cases, you want the appearance of objects that belong to the same
style to be consistent throughout a drawing. To achieve this, you specify the
display properties of the mask blocks in each mask block definition style.
However, in certain instances, you may need to override a display property
for an individual mask block to achieve a specific result. All the display
properties that you can specify in mask block definition styles are available
for individual mask blocks:

■ The visibility of mask block components

■ The layer, color, and linetype of mask block components

■ The lineweight, linetype scale, and plot style of mask block components

NOTE If the mask block is attached to a grid, you can change the anchor properties
as well.

When you change the display properties of a mask block, the changes apply
only to that mask block. Other mask blocks of the same definition style are
not affected. To change the display properties of all mask blocks of a specific
definition style, see Creating Mask Block Definitions on page 2868.
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Changing the Display Properties of a Mask Block
Use this procedure to change any of the following properties of the display
components of an individual mask block:

■ Visibility (display component is on or off)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

1 Select the mask block you want to change, right-click, and click
Edit Object Display.

2 Click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 Click the Layer/Color/Linetype tab.

6 Select the component to change, and select a different setting for
the property.

7 Click OK twice.

Attaching Hyperlinks, Notes, and Files to a Mask Block
Use this procedure to attach hyperlinks, enter notes, or attach reference files
to a mask block in a drawing. You can also edit notes and edit or detach
reference files from a mask block.

1 Double-click the mask block to which you want to attach
information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click  next to Hyperlink, and specify the
link.
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For more information about adding hyperlinks, see “Add
Hyperlinks to a Drawing” in AutoCAD Help.

4 To add or edit a note, click  next to Notes, enter text, and click
OK.

5 To attach, detach, or edit a reference file, click  next to
Reference documents:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file
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Multi-View Blocks

A multi-view block is an AutoCAD Architecture object that can have different representations
in different view directions. You create a multi-view block from AutoCAD blocks that represent
the different views of the custom object that you are creating.

Multi-View Blocks
A multi-view block is an AutoCAD Architecture object that can have different
representations in different view directions. You create a multi-view block from
AutoCAD blocks that represent the different views of the custom object that
you are creating.

Understanding Multi-View Blocks

Multi-view blocks can represent different types of objects in AutoCAD
Architecture. They are typically used to represent the following items:

■ Furniture and fixtures, such as tables and kitchen sinks

■ Annotation components, such as revision clouds or fire rating signs

■ Schedule tags, such as door numbers

Multi-view blocks can be displayed differently in each view direction and each
display representation. For example, the top view of a multi-view block
representing a kitchen sink shows the top of the sink; the bottom view shows
the bottom of the sink; and there are representations for left, right, front, and
back views. Additionally, you can define a different group of displays for each
display representation, so that you can have one set of views for Plan view and
another for Reflected view.
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You can use a multi-view block as a cutout in objects such as walls, slabs, and
curtain walls. You create a view block to represent the cutting body. The block
forms the body that will be subtracted from objects by applying the multi-view
block as interference. For example, you can create a skylight as a multi-view
block and specify the block as a subtractive Boolean in a slab.

Predefined Multi-View Blocks

The content folders of AutoCAD Architecture contain predefined multi-view
blocks for various design purposes, such as furniture, electrical appliances,
annotation symbols, schedule tags, and other useful elements. You can access
these multi-view blocks from DesignCenter™. For more information, see AEC
Content and DesignCenter on page 3907.

Creating Multi-View Block Definitions
Each multi-view block in a drawing is based on a definition that specifies the
display representations in which the block can be viewed, as well as the views
available in each representation. From a multi-view block definition, you can
create as many multi-view blocks as you need.

Multi-view blocks typically represent 3D architectural objects. For example,
you can create customized cabinetry by drawing plan, elevation, and model
views, and saving each view as an individual AutoCAD block. You assign each
block to a view when you create the multi-view block definition. The blocks
(top, bottom, front, back, left, right, and model views) are used to define the
custom object as a single multi-view block. Prior to defining the block, you
can add points on the Defpoints layer to identify additional insertion points
for the view block. You set the display representations and view directions in
the process of defining the multi-view block.

You can see the individual blocks of your custom object as one assembly in
plan, elevation, and isometric views after inserting them in the drawing as a
multi-view block. For more information about working with blocks, see
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“Overview of Blocks” in AutoCAD Help. For more information about display
representations, see Display Representations on page 803.

TIP The quickest way to locate and view an AutoCAD topic referenced in AutoCAD
Architecture Help is to click the Search tab in the Help window, select the Search
titles only option, and then copy and paste or type in the AutoCAD topic name,
and click List Topics.

Process Overview: Creating Multi-View Block Definitions
There are four general steps for creating a multi-view block:

1 Create a set of view blocks for each view direction in every display
representation you need.

For example, if you need a multi-view block definition that displays in
Model view and Reflected Plan view, create a set of views for each
representation. You create views only for those view directions where
you want a different result. For example, if the top and bottom views are
supposed to look the same in the Reflected Plan display representation,
you draw the view block only once, and assign it to both view directions.

2 Create a multi-view block definition in which you assign the view blocks
to view directions in individual display representations.

3 If you want the new multi-view block definition to be available through
DesignCenter™, add the definition to DesignCenter.

4 If you want the new multi-view block definition to be available from a
tool palette, add it to a palette.

Creating View Blocks
Use this procedure to create AutoCAD blocks to represent each view of the
multi-view block definition in display representations.

1 Draw the views you need for a specific display representation:

Then…If you want to…

draw them on the XZ plane.create views for the front and back
directions
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Then…If you want to…

draw them on the YZ plane.create views for the left and right
directions

draw them on the XY plane.create views for the top and bottom
directions

create a block containing objects,
such as mass elements, to be used
as the subtractive body.

create a block for an interference
condition

2 Specify additional insertion points on the Defpoints layer through
the AutoCAD point command, if necessary.

NOTE The points added to view blocks are cumulative. For example,
if you add one point to a view block used for the top view and two
points to the view block used for the model view, you have a total
of four points to cycle through. The fourth point is the regular base
point defined during the creation of the block.

3 Select the World Coordinate System before making blocks from
these individual views.

For more information about coordinate systems, see “Use
Coordinates and Coordinate Systems” in AutoCAD Help.

4 Define each view as a block, and coordinate the location of the
insertion base point as you define each block.

For example, if you specify the insertion base point of the model
view block as the midpoint of the bottom edge on the back side,
the front and back view blocks have an insertion base point at
the midpoint of the bottom edge. Then, the left and right view
blocks have an insertion base point at the bottom corner on the
back side, with the insertion base point for the top and bottom
view blocks at the midpoint of the back edge.

For more information about blocks, see “Create and Use Blocks
(Symbols)” in AutoCAD Help.
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Creating individual blocks for multi-view block definition

TIP It is helpful to have a naming convention for saving views as
blocks. For example, name the plan view block desk-p, and name the
right view block desk-r.

Creating a New Multi-View Block Definition
Use this procedure to create a multi-view block definition from the view blocks
you created to represent different views of a custom object.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects.

3 Right-click Multi-View Block Definitions, and click New.

4 Enter a name for the new multi-view block definition, and press
ENTER.
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5 Edit the new multi-view block definition:

Then…If you want to…

see Connecting View Blocks to View
Directions on page 2896.

connect view blocks to the view
directions of the different display
representations

see Attaching Notes and Files to a
Multi-View Block Definition on page
2898.

add notes and files to the multi-
view block definition

see Adding Classifications to a
Multi-View Block Definition on page
2899.

add classifications to a multi-view
block definition

click Set Interference Block, select
a block, and click OK.

specify a cut body for the multi-
view block when the block is used
as interference in other objects (for
example, walls, curtain walls,
spaces, slabs)

6 Click OK.

Connecting View Blocks to View Directions
Use this procedure to connect view blocks to the view directions of individual
display representations.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Multi-View Block
Definitions.

NOTE Alternatively, you can select a multi-view block in the drawing,
and click Multi-View Block tab ➤ General panel ➤ Edit Style

drop-down ➤ Multi-View Block Definitions  .

3 Select the multi-view block definition to which you want to
connect view blocks.

4 Click the View Blocks tab.

5 Select the display representation to which to connect view blocks.
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Six display representations are available for multi-view blocks:

PurposeDisplay Representation

Plan views, Section views, and
Sketch views

General

Model viewsModel

Plan viewsPlan

Plan High Detail viewsPlan High Detail

Plan Low Detail viewsPlan Low Detail

Reflected viewsReflected

6 Click Add, and select a view block for the display representation.

7 Click OK.

8 Select the view directions that correspond to the selected block.

For example, to connect the view block to the left side of the
multi-view block definition, select Left and clear all other
directions.

You can connect a view block to multiple view directions. For
example, if you have a symmetrical element that looks identical
from left and right, you can select Left and Right.

The Other view direction represents a view that displays the block
three-dimensionally. It is used for non-orthogonal (isometric or
perspective) views of the custom object.

To ensure that the multi-view block is visible in all views, assign
a block to every view direction.

9 To specify view blocks in other display representations, continue
from step 5.

10 Click OK.
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Defining a Multi-View Block Definition as Bounding for
Associative Spaces

Use this procedure to define a multi-view block definition that can bound
associative spaces.

When a multi-view block definition is set as bounding, by default all multi-view
blocks that have the definition assigned will be used in the selection set for
an associative space. For more information about associative spaces see
Generating Associative Spaces on page 2940.

You can override the bounding settings from the multi-view block definition
in an individual multi-view block, if necessary.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Multi-View Block
Definitions.

NOTE Alternatively, you can select a multi-view block in the drawing,
and click Multi-View Block tab ➤ General panel ➤ Edit Style

drop-down ➤ Multi-View Block Definition  .

3 Select a multi-view block definition.

4 Click the General tab.

5 Select the check mark for Objects of this style may act as a
boundary for associative spaces.

6 Click OK.

Attaching Notes and Files to a Multi-View Block Definition
Use this procedure to enter notes and attach reference files to a multi-view
block definition. You can also edit notes and edit or detach reference files
from a multi-view block.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Multi-View Block
Definitions.
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NOTE Alternatively, you can select a multi-view block in the drawing,
and click Multi-View Block tab ➤ General panel ➤ Edit Style

drop-down ➤ Multi-View Block Definitions  .

3 Select the multi-view block definition to which you want to attach
notes or files.

4 Click the General tab.

5 To add a description to the multi-view block, enter the description
under Description.

6 Click Notes.

7 On the Notes tab, add or edit a note, as applicable.

8 On the Reference Docs tab, attach, edit, or detach a reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Edit
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application. Click OK
when you are done editing.

edit a reference file

select the file name, click Delete,
and click OK.

detach a reference file

9 Click OK twice.

Adding Classifications to a Multi-View Block Definition
Use this procedure to specify classifications for any classification definition
applied to a multi-view block definition. For more information, see
Classification Definitions on page 3872.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Multi-View Block
Definitions.
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NOTE Alternatively, you can select a multi-view block in the drawing,
and click Multi-View Block tab ➤ General panel ➤ Edit Style

drop-down ➤ Multi-View Block Definitions  .

3 Select the definition that you want to change.

4 Click the Classifications tab.

By default, the classification for all classification definitions is
Unspecified. If no classification definitions are listed, none are
applied to multi-view block definitions.

5 For each classification definition, select the classification you want
to apply to the current multi-view block definition.

6 Click OK.

Adding a Multi-View Block Definition to DesignCenter
Use this procedure to add a multi-view block to DesignCenter™. You can then
create new multi-view blocks by dragging and dropping them from
DesignCenter to your drawing. To add a multi-view block definition to
DesignCenter, you need to create a DWG file using the AEC Content Wizard.

For a detailed description of the AEC Content Wizard, see Overview of AEC
Content on page 3907.

1 On the command line, enter AecCreateContent.

2 Select Multi-View Block.

3 Under Current Drawing, select a multi-view block definition, and
click Add to add it to the Content File list.

4 Click Next.

5 Select the layer key to use when the multi-view block is inserted,
and specify any additional properties:

Then…If you want to…

select Explode on Insert.explode the multi-view block when
it is inserted in a drawing

enter a value for Preset Elevation.specify an elevation for the multi-
view block

select an anchor type.associate an anchor with the multi-
view block
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Then…If you want to…

under Scale, enter X, Y, and Z scale
values, and select an option for Ad-
ditional Scaling.

specify the scale for the multi-view
block

select Enable AEC Unit Scaling.scale the multi-view block based on
the drawing units specified in the
Drawing Setup dialog box

select options for Attribute Text
Style and Attribute Text Angle.

specify properties for attributes as-
sociated with the multi-view block

6 Click Next.

7 Specify the drawing file in which to store the multi-view block
definition:

Then…If you want to store the multi-
view block…

select Current Drawing.in the current drawing

clear Current Drawing, and then
either enter a file name or click
Browse to specify a file.

in a different drawing

8 Select the icon to represent the multi-view block in DesignCenter:

Then…If you want to…

click Default Icon.use a bitmap of the drawing as the
icon

click New Icon, and select a bitmap
file.

specify a bitmap (.bmp) file contain-
ing the image to be used as the
icon

9 Enter a description of the multi-view block.

The description is displayed in DesignCenter, along with the icon
representing the multi-view block.

10 Select Save Preview Graphics to enable previewing in
DesignCenter, or clear Save Preview Graphics to disable
previewing.
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11 Click Finish.

Creating a Multi-View Block Tool
Use this procedure to create a multi-view block tool and add it to a tool palette.
You may want to create your own multi-view block tool for customized
multi-view blocks you plan to use repeatedly. For example, you might create
an office floor plan in which each conference room and office contains a floor
lamp. Conference rooms and executive offices get the deluxe model floor
lamp, and all other rooms get the standard model. You could define a
multi-view block to represent each type of floor lamp, and then create a floor
lamp tool for each type. You would then select the appropriate tool to place
a floor lamp in each room.

You can use any of the following methods to create a multi-view block tool:

■ Drag a multi-view block that has the properties you want to a tool palette.

■ Drag a multi-view block definition from the Style Manager to a tool palette,
and then customize the properties of the new tool.

■ Copy an existing multi-view block tool, and then customize the properties
of the new tool.

■ Drag a multi-view block tool from a tool catalog in the Content Browser,
and then customize the properties of the tool.

1 Open the tool palette on which you want to add a tool.

2 Create the tool:

Then…If you want to…

select the multi-view block and drag
it to the tool palette.

create a tool from a multi-view
block in the drawing

click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from a multi-view
block definition in the Style Man-
ager

the definition you want to copy,
and drag it to the tool palette. Click
OK to close the Style Manager.

click Home tab ➤ Build pan-

el ➤ Tools drop-down ➤ Content

copy a multi-view block tool from
a tool catalog
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Then…If you want to…

Browser  . Locate the multi-view
block tool you want to copy, then

click the  icon associated with
the tool and drag it to the tool
palette in the workspace.

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool on the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the palette where you want
to add the tool, right-click, and click
Paste.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

This description is used as the tool’s tooltip on the tool palette,
and to describe the tool if it is stored in a tool catalog.

6 Expand Basic, and expand General.

7 Click  next to Description to enter a description of the tool.

8 If you do not want to use the default layer key for multi-view

blocks, click  next to Layer key to select a layer key.

9 If you want to override the default layer name for multi-view

blocks, click  next to Layer overrides to select a layer override.

10 Select a multi-view block definition.

11 For Style location, select the drawing file containing the definition
used for this multi-view block, or select Browse and use a standard
file selection dialog box to select the file.

12 Under Bound Spaces, define if this multi-view block tool can be
used as a bounding object for associative spaces.
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You can select three options here:

■ Yes: this multi-view block tool can be used as bounding object
for associative spaces.

■ No: this multi-view block tool cannot be used as bounding
object for associative spaces.

■ By style: this multi-view block tool will use the bounding
settings from the multi-view block definition.

NOTE For more information on associative spaces, see Generating
Associative Spaces on page 2940.

13 Expand Scale.

14 Specify the scale of the multi-view block:

Then…If you want to…

select No for Specify scale on
screen, and enter X, Y, and Z values
for the scale.

specify fixed values for the scale

select Yes for Specify scale on
screen.

allow users to specify the scale of
the object upon insertion

15 Expand Location.

16 Specify the rotation of the multi-view block:

Then…If you want to…

select No for Specify rotation on
screen, and enter a value for Rota-
tion.

specify a fixed value for the rotation

select Yes for Specify rotation on
screen.

allow users to specify the rotation
of the object upon insertion

17 Expand Advanced.

18 Click  next to Insertion offsets, and enter X, Y, and Z offsets
for each view block in the multi-view block, as necessary.

19 Click OK.
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20 Click  next to Attributes, and edit the prompt and value of
each attribute, as necessary.

21 Click OK twice.

Adding Multi-View Blocks to a Drawing
Multi-view blocks are inserted in a drawing by referencing their definitions
in one or more of the following locations:

■ DesignCenter™

■ Tool palettes

■ Tool catalogs

Predefined multi-view blocks supplied with AutoCAD Architecture are available
with DesignCenter. These blocks represent items such as furniture, electrical
appliances, pipes, ducts, annotation symbols, and schedule tags.

A generic multi-view block reference tool is supplied in the AutoCAD
Architecture Stock Tool catalog. This tool is in the Helper Tools category.

How you access a custom multi-view block definition—for example, blocks
that you or someone else in your organization defined—depends on what you
do with the block after you define it. You can use the multi-view block
definition to create AEC content in DesignCenter, or to create a multi-view
block tool that can be stored in a tool palette or tool catalog.

When you insert a multi-view block reference in a drawing, you are prompted
to specify the insertion point for the block. Depending on how the multi-view
block was defined, you may be prompted to specify rotation angle and scale
values.

Inserting a Multi-View Block
Use this procedure to add a multi-view block to a drawing.

1 Find the multi-view block definition and begin the insertion
process:

Then…If the multi-view block is…

click Insert tab ➤ Content pan-

el ➤ Content Browser drop-

stored as AEC content
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Then…If the multi-view block is…

down ➤ Design Center  . Loc-
ate the AEC content, and double-
click the content.

open the tool palette containing
the multi-view block tool, and click
the tool.

inserted using a tool on a tool
palette

click Home tab ➤ Build pan-

el ➤ Tools drop-down ➤ Content

inserted using a tool stored in a tool
catalog

Browser  . Locate the tool, click

the  icon for the tool, and drag
it to the drawing area.

2 Specify the insertion point for the block.

If you added insertion points to the view blocks, you can cycle
through the points with the CTRL key.

3 Specify the scale, if prompted:

Then…If you want to…

enter a value at the Command
prompt.

specify a scale value

use the pointing device, and click
when you see the appropriate scale.

dynamically set the scale

enter m (match) at the Command
prompt, and select a multi-view
block to match the scale.

set the scale to match that of anoth-
er multi-view block in the drawing

4 Specify the rotation angle, if prompted:

Then…If you want to…

enter a value at the Command
prompt.

specify a rotation value
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Then…If you want to…

use the pointing device, and click
when you see the appropriate rota-
tion.

dynamically set the rotation

enter m (match) at the Command
prompt, and select a multi-view
block to match the rotation.

set the rotation to match that of
another multi-view block in the
drawing

5 To insert additional references to the multi-view block, continue
from step 2.

6 Press ENTER to finish inserting blocks.

Modifying Multi-View Blocks
You can change the attributes of a multi-view block in a drawing. For example,
you can change the rotation or the scaling factor.

Changing the Rotation of a Multi-View Block
Use this procedure to change the rotation of a multi-view block.

1 Double-click the multi-view block whose rotation you want to
change.

2 On the Properties palette, expand Basic, and expand Location.

3 Enter a value for Rotation.

Changing the Associated Multi-View Block Definition
Use this procedure to change the multi-view block definition associated to
the multi-view block. For information about the relationship between
multi-view blocks and multi-view block definitions, see Creating Multi-View
Block Definitions on page 2892.

1 Double-click the multi-view block you want to change.

2 On the Properties palette, expand Basic, and expand General.

3 Click Definition, and select a new multi-view block definition for
the multi-view block.
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Changing the Scale Factor of a Multi-View Block
Use this procedure to change the scale factor of a multi-view block.

1 Double-click the multi-view block you want to change.

2 On the Properties palette, expand Basic, and expand Scale.

3 Change the scale factor as needed:

Then…If you want to…

enter a new value for X.change the X scale factor

enter a new value for Y.change the Y scale factor

enter a new value for Z.change the Z scale factor

Changing the Offset of a Multi-View Block Using Grips
Use this procedure to change the offset of a multi-view block using the Location
grip.

When you first add a multi-view block to a drawing, the offset value is set to
0. You can change the position of the multi-view block by offsetting it from
its original insertion point. You can also change the offset of a multi-view
block using the Properties palette.

1 Select the multi-view block you want to change.

2 Click Multi-View Block tab ➤ Modify panel ➤ Edit View Block
Offsets.

3 Select the view block to change.
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In Model view, the Location grip has three possible edit modes:
Edit Along XY Plane, Edit Along XZ Plane, and Edit Along ZX
Plane. Press CTRL to cycle among modes until you are in the
desired mode. The default edit mode is along the XY plane. In
Plan view, the Location grip is restricted to movement in one
plane.

4 Offset the multi-view block to the desired location and click once,
or enter a value and press ENTER.

If you want to enter a specific value for the second direction in
any edit mode (for example, in the Y direction when editing along
the XY plane), press TAB to cycle to the second direction.

You can also lock the movement of the multi-view block along a
specific direction. If you enter a value for either dimension
direction in the current edit mode, and then press TAB, the
movement of the multi-view block is constrained to the second
dimension direction. When editing along the XY plane, for
example, you can enter a value for X dimension, and then press
TAB. The X dimension is locked at that value, and movement of
the multi-view block is constrained to the Y dimension direction.

5 Click Multi-View Block tab ➤ Modify panel ➤ Edit View Block
Offsets to exit view block offset editing mode.

The selected view block is offset from the original insertion point.

Changing the Location of a Multi-View Block Using Grips
Use this procedure to relocate an existing multi-view block using the Location
grip. In Model view, the Location grip has three possible edit modes: Edit
Along Object’s XY Plane, Edit Along Object’s YZ Plane, and Edit Along Object’s
XZ Plane. Press CTRL to cycle among modes until you are in the desired mode.
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The default edit mode is along the XY plane. In Plan view, the Location grip
is restricted to movement in one plane.

You can also change the location of a multi-view block using the Properties
palette.

1 Select the multi-view block you want to relocate.

2 Select the Location grip.

3 Move the multi-view block to the desired location and click once,
or enter a value and press ENTER.

If you want to enter a specific value for the second direction in
any edit mode (for example, in the Y direction when editing along
the XY plane), press TAB to cycle to the second direction.

You can also lock the movement of the multi-view block along a
specific direction. If you enter a value for either dimension
direction in the current edit mode, and then press TAB, the
movement of the multi-view block is constrained to the second
dimension direction. When editing along the XY plane, for
example, you can enter a value for X dimension, and then press
TAB. The X dimension is locked at that value, and movement of
the multi-view block is constrained to the Y dimension direction.
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4 Right-click, and click Deselect All to turn off grips.

Attaching Hyperlinks, Notes, or Files to a Multi-View Block
Use this procedure to attach hyperlinks, enter notes, or attach reference files
to a multi-view block in a drawing. You can also edit notes and edit or detach
reference files from a multi-view block.

1 Double-click the multi-view block to which you want to attach
information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click  next to Hyperlink, and specify the
link.

For more information about adding hyperlinks, see “Add
Hyperlinks to a Drawing” in AutoCAD Help.

4 To add or edit a note, click  next to Notes, enter text, and click
OK.

5 To attach, detach, or edit a reference file, Click  next to
Reference documents:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file
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Then…If you want to…

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

Editing the Location and Rotation of Attributes in a Multi-View
Block

Use this procedure to change the location and rotation of attributes within a
multi-view block.

NOTE The location and rotation of an attribute in a multi-view block can only be
modified if the attributes have not been inserted with the Lock position in block
option selected during attribute creation. For more information, see “Attribute
Definition Dialog Box” in AutoCAD Help.

Rotating a tag attribute in Plan view

1 Select the multi-view block whose attributes you want to edit.

2 Click Multi-View Block tab ➤ Modify panel ➤ Edit Attributes.

Each attribute has a grip for location and for rotation.

In Model view, the Location grip has three possible edit modes:
Edit Along Object’s XY Plane, Edit Along Object’s YZ Plane, and
Edit Along Object’s XZ Plane. Press CTRL to cycle among modes
until you are in the desired mode. The default edit mode is along
the XY plane. In Plan view, the Location grip is restricted to
movement in one plane.

If there is more than one attribute with the same offset value, the
attribute location grips reposition themselves according to their
priority over other offset grips.
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3 To change the location of an attribute relative to the multi-view
block, select the Location grip, move the block attribute to the
desired location and click once, or enter a value and press ENTER.

If you want to enter a specific value for the second direction in
any edit mode (for example, in the Y direction when editing along
the XY plane), press TAB to cycle to the second direction.

You can also lock the movement of the block attribute along a
specific direction. If you enter a value for either dimension
direction in the current edit mode, and then press TAB, the
movement of the block attribute is constrained to the second
dimension direction. When editing along the XY plane, for
example, you can enter a value for X dimension, and then press
TAB. The X dimension is locked at that value, and movement of
the block attribute is constrained to the Y dimension direction.

4 To change the rotation of an attribute relative to the multi-view
block, select the Rotation grip, rotate the block attribute to the
desired angle and click once, or enter a value and press ENTER.

5 To exit the attribute editing mode, right-click, and click Exit Edit
Attribute Orientations.

Alternatively, you can deselect the multi-view block.

Updating Multi-View Block Attributes
Use this procedure to update the attributes of blocks in your drawing, using
the current attributes defined for the view blocks upon which each multi-view
block is based. You need to do this if you change attribute definitions in one
or more of the block definitions on which the multi-view block is based.

1 Select the multi-view block.

2 Click Multi-View Block tab ➤ Modify panel ➤ Edit Attributes.

3 Enter y (Yes) to include text style properties (for example, width
factor, oblique, mirroring) when updating attributes, or n (No) to
update all attributes properties except those relating to text style.

4 Press ENTER to end the update process.
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Spaces

Spaces are 2-dimensional or 3-dimensional style-based architectural objects that contain
spatial information about a building, including floor area, wall area, volume, surface
information, and more. Spaces can be used for organizing reports such as statements of
probable construction cost, energy requirements and analysis, leasing documents, operating
costs and fixtures, and lists of furniture and equipment.

Space Types
The following types of spaces can be modeled in AutoCAD Architecture:

Associative and Non-Associative Spaces

Associative spaces are generated from boundary objects. When the boundary
objects change, the space updates accordingly.

In addition to associative spaces you can also create non-associative spaces with
user-defined geometry. A non-associative space can stand alone in the drawing,
but you can use it to generate calculations just like you would use an associative
space.

Non-associative spaces can be connected to boundary objects after their creation;
similarly, associative spaces can be disconnected from their boundary objects.

2D Spaces

2D spaces display spatial information in 2 plan dimensions.

40
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2D spaces in Plan view

The Z direction is by default set to 0 and ignored during creating, editing, and
scheduling the space. 2D spaces can be rectangular or polygonal. 2D spaces
can either be non-associative or associative. A 2D space can be bounded by
3D objects and linework. 2D spaces are typically used for Plan views, where
3D information is not needed.

Extruded 3D Spaces

An extruded 3D space is similar to a 2D space, but has a user-defined extrusion
height. Extruded spaces are useful for regularly shaped 3D spaces like
uniform-height rooms in a building. Extruded spaces can have floor and ceiling
components and space above the ceiling and below the floor. The space above
the ceiling is often used to place ductwork, cables and electrical installations
in a room.

Space height components

Space ceiling and floor components
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Extruded 3D spaces can be associative to 3D objects and linework, but they
are bounded only in the X and Y directions. The Z direction is defined by the
extrusion height. If you need a space that is fully bounded by objects in all 3
spatial dimensions, you need to generate a 3D freeform space.

Additional space dimension components

3D Freeform Spaces

3D freeform spaces are generated from boundary objects, like walls and slabs,
and are associative to them. Associative 3D freeform spaces must be bounded
in all directions to form a valid boundary shape. A 3D freeform space is a
complex 3D geometry with any number of surfaces needed to generate the
space shape.

Some examples for 3D freeform spaces
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Workflows for Spaces

Workflow for Generating Associative Spaces
Associative spaces are generated from building geometry in the drawing and
are updated if it changes. Updates can be triggered automatically or manually.

Use walls on page 1161 or other building objects
to create the floor plan.
If you are working in a structured AutoCAD
Architecture project, open a construct on page
411 from the Project Navigator.

-----
Create the floor plan or open a
drawing

Select a space tool on page 2939 to generate a
space. You can specify that a tag is added as the-----Click the type of space to add
space is created on the Properties palette on page
2933.

Specify Generate on page 2953 on the Properties
palette, and then specify a point within bounding

-----Create a space
geometry, or type G to generate spaces within
all valid on page 2941 boundaries.
If you change your bounding geometry and the
space does not update, check the space settings
on page 2964.

Workflow for Manually Defining Net, Usable, and Gross Areas
Spaces can have separate boundaries for the base area, net area, usable area,
and gross area of the space. These can be defined manually.
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If you want to use a predefined area calculation standard, see Workflow for
Determining Net, Usable, and Gross Areas With a Calculation Standard on
page 2921.

Use walls on page 1161 or other building objects
to create the floor plan.
If you are working in a structured AutoCAD
Architecture project, open a construct on page
411 from the Project Navigator.

-----
Use the floor plan to identify the
perimeter of the space

Use a space tool on page 2939 to create the space.-----Create a space

Use grips on page 3017 on the space boundaries
to manually on page 3005 define the net, usable,
and gross areas of the spaces.

-----Define the spaces

Workflow for Determining Net, Usable, and Gross Areas With
a Calculation Standard

Spaces can have separate boundaries for the base area, net area, usable area,
and gross area of the space. AutoCAD Architecture includes standards based
on the rules of DIN 277 (Germany), BOMA (United States), and SIS (Sweden).

If you want to define these manually, see Workflow for Manually Defining
Net, Usable, and Gross Areas on page 2920.

Use walls on page 1161 or other building objects
to create the floor plan.
If you are working in a structured AutoCAD
Architecture project, open a construct on page
411 from the Project Navigator.

-----
Use the floor plan to identify the
perimeter of the space
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Use a tool on page 2939 to create the space.-----Create a space

Use a calculation standard on page 3010.-----
Determine how boundaries are
offset and calculated

Classify on page 3011 spaces if required by the
selected area calculation standard.

-----
Connect the building standard
with a drawing

Workflow for Creating a Space Evaluation Report
After creating spaces and zones in your floor plan, you can generate a space
evaluation report.

Generate the spaces and zones you need for the
space evaluation with a tool on page 2939.

-----
Create the space or zone needed
for the evaluation

Attach calculation modifiers on page 3163 as
necessary.

-----
Apply a formula to modify an area
or a perimeter value

Specify on page 3178 how the space evaluation
information displays.

-----
Identify the type of file in which to
display the evaluation
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Generate on page 3186 the evaluation file either as
Microsoft® Excel spreadsheet or a text (TXT)
document.

-----Create the evaluation

Adjusting Space Calculations
Spaces are a powerful tool to create any type of room-based object, schedule
it and create calculations for it. The following sections outline some main
features associated with spaces in AutoCAD Architecture.

Working with List Definitions - Overview
List definitions are named lists for spaces and zones. You can attach a list
definition to a space style or to a zone style to ensure that all spaces or zones
inserted with that style use names from the list. List definitions can be created
for a number of purposes, for example to enforce consistent naming of spaces
according to a building standard.

1 Create a list definition in Style Manager, as described in List
Definitions on page 3109.
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2 Attach the list definition to a space or zone style, as described in
Attaching a List Definition to a Space Style on page 3097 and
Attaching a List Definition to a Zone Style on page 3140.

3 Add a space or zone to the drawing, and select a name from the
list.

Working with Zones - Overview
Zones are objects that can be used to group spaces. Zones can have spaces
attached to them and can contain other zones in an hierarchical structure.
For example, you can create a zone called Office Building with sub-zones for
the individual offices in the building. Each workplace within an office can be
represented by a space.
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Zones in a building

1 Create a zone style in Style Manager, as described in Creating a
Zone Style on page 3139.

2 If you have a zone structure that you want to use again because
it represents a standard, create a zone template, as described in
Creating a Zone Template on page 3151.

Zones based on DIN277 template

3 Add a zone or zone template to the drawing.

4 If necessary, attach calculation modifiers to the zone. A calculation
modifier attached to a zone is used for all spaces and zones
attached to the zone.

5 Attach spaces or other zones to the zone, as described in Attaching
Spaces and Zones to Zones on page 3127.
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Zone with attached subzones and spaces

Working with Calculation Modifiers - Overview
A calculation modifier is a value or formula you can add to the area and
perimeter values of each boundary of a space to modify values for certain
calculations. For example, you can specify a 3% plaster deduction for all
interior walls, or calculate a balcony at only 50% of its square meters for
renting.

1 In Style Manager, create a new calculation modifier style, as
described in Creating a Calculation Modifier Style on page 3165.

2 Define a formula with which to calculate the value of the base
area or base perimeter of the space.

3 Add the calculation modifier to a space or to a zone, as described
in Adding and Removing Calculation Modifiers for Spaces on page
3164 and Changing Calculation Modifiers for a Zone on page 3132.
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4 To apply the modifier to the net, usable, and gross boundaries of
a space, create and apply a property set definition that contains
properties for the calculated area and perimeter values of the net,
usable and gross boundaries. For more information, see Property
Set Definitions on page 3823.

5 Use the modified values in a schedule table or in a space
evaluation. For more information, see Basic Schedules on page
3747 and Space Evaluation on page 3177.

Working with Calculation Cut Planes - Overview
If you are working with 3D freeform spaces, you can calculate their area at 2
different cut plane heights. This is useful for attics, where different heights
are calculated differently.
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1 Create a 3D freeform space, as described in Generating an
Associative Space on page 2953 or Converting Mass Elements to
Spaces on page 2987.

2 Define the calculation cut planes of the space, as described in
Setting Calculation Cut Planes for 3D Freeform Spaces on page
3169.

3 Define the display properties for the 2 calculation cut planes and
the cut plane hatches, as described in Specifying the Display
Properties of a Space Style on page 3101.

4 Generate and apply a property set definition with automatic
properties for calculation cut planes. Then create a schedule table
with the calculated cut plane values. For more information, see
Basic Schedules on page 3747.

Moving Forward to AutoCAD Architecture 2012 from
Autodesk Architectural Desktop 2006 and Earlier

If you are transitioning from Autodesk Architectural Desktop 2006 or earlier
to AutoCAD Architecture, you will see a number of changes in the space
planning features. In AutoCAD Architecture, spaces, areas, and space
boundaries have been unified into one space object which contains the
properties formerly associated with these other objects, as well as new and
enhanced features designed to provide a comprehensive solution for spatial
design within the building model.
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The table below maps objects from earlier releases to their newer counterparts.

AutoCAD Architecture 2012Prior Releases

SpacesSpaces

SpacesSpace boundaries

SpacesAreas

ZonesArea groups

List definitionsArea name definitions

Zone templatesArea group templates

Space evaluationArea evaluation

Spaces

Spaces now contain the properties associated with spaces and areas prior to
AutoCAD Architecture 2012, as well as engineering properties for working in
AutoCAD MEP. Spaces can be associatively generated as 3D freeform objects,
as extruded 3D spaces, or as 2D spaces. A space can have different boundaries
for base area, net area, usable area, and gross area. Spaces can be grouped into
zones and processed in space evaluations.

Space Boundaries

Space boundaries are now part of the space object, and not separate objects
as they were prior to AutoCAD Architecture 2012. A space has a base boundary,
net boundary, usable boundary, and a gross boundary. Space boundaries
created in previous versions will be converted to walls when the drawing that
contains them is opened in the current version of the software. Managed
spaces will be converted to associative spaces. Space boundaries include a
number of scheduling properties.

For information about converting space boundaries to walls and spaces, see
Conversion of Space Boundaries to Walls and Spaces on page 3197.
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Space boundaries

Areas

Areas have been integrated into spaces, which now include the properties
formerly specific to areas. Among the area-specific features are the
decomposition view, name definitions, calculation modifiers, and space
evaluation. When you open a drawing that contains areas, the areas are
automatically converted to spaces, with all area properties being converted to
the corresponding space properties. For new properties, default values are
used. Area tools are no longer needed and are omitted.

For information about converting areas to spaces, see Auto-Converting Legacy
Areas to Spaces on page 2931.

Area Groups and Zones

Area groups have been converted to zones. When you open a drawing that
contains area groups, the area groups are automatically converted to zones,
with all area group properties being converted to the corresponding zone
properties. For new properties, default values are used. Area group tools are
no longer needed and are omitted.

Zones are a new object and serve as a grouping mechanism for spaces. Zones
can be created to group spaces according to function, location, or any
user-defined system. You can attach specific calculation modifiers and schedule
properties to a zone. You can also build hierarchical zone structures that
represent the structure of your building, a space categorization standard, or
any user-defined grouping structure.

For information about converting area groups to zones, see Converting Area
Groups to Zones on page 3125.
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Area Name Definitions and List Definitions

Area name definitions have been converted to list definitions. A list definition
is a list of names that can be assigned to a space or zone style to ensure
consistent naming of spaces and zones across a project. For example, a list
definition could contain entries for bedroom, living room, bathroom, and so
on. When you open a drawing that contains area name definitions associated
with an area or area group, the area name definition is automatically converted
to a list definition. You can assign the list definition to the converted space
or zone through its style.

Area Group Templates and Zone Templates

Area group templates have been converted to zone templates, which provide
structure definitions for zone hierarchies. You define a zone template with a
set of subzones and content restrictions, and use it to create the zone structure
in the drawing. When you open a drawing that contains area group templates,
the area group templates are automatically converted to zone templates.

Area Evaluation and Space Evaluation

The area evaluation feature has been converted to the space evaluation feature.
Space evaluation is a documentation feature that calculates the area and
perimeter information for your finished floor plan. This information is
displayed in a separate file that you export from AutoCAD Architecture to a
spreadsheet or text processing application. Evaluation templates ensure that
the information is displayed in a consistent, structured way. Architects need
the space evaluation feature for submitting floor plans to the building
authorities and customers. Space evaluation can also be used for performing
cost estimates, assigning jobs to contractors, or organizing the facility
management of buildings.

Auto-Converting Legacy Areas to Spaces
If you have legacy drawings created in previous versions, and they contain
area objects, these areas will automatically be converted to spaces when you
open the drawing with the current software. The following table maps area
properties to space properties.

Value/Default valueSpace propertyArea property

Existing valueNameName

Existing valueDescriptionDescription
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Value/Default valueSpace propertyArea property

Existing layer (A-Area-G)LayerLayer

Area style is converted to space
style. Properties are matched

StyleStyle

where possible; new properties
have default values. For more in-
formation, see Converting Area
Styles to Space Styles on page
3108.

Existing modifiers

NOTE By default, converted cal-
culation modifiers are applied
only to the base area and base
perimeter of the space.

Calculation modifiersCalculation modifiers

2DGeometryN/A

Existing valueBase AreaBase Area

Existing valueCalculated AreaCalculated Area

Existing valueBase PerimeterBase Perimeter

Existing valueCalculated perimeterCalculated Perimeter

Existing valueRotationRotation

Existing valueElevationElevation

Existing valuesAdditional Information
(Location)

Additional Information
(Location)

Existing valueLengthN/A

Existing valueWidthN/A
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NOTE Subtracted areas and hatches will be ignored when converting a legacy
area from Autodesk Architectural Desktop 2006 or earlier to a space in AutoCAD
Architecture. If necessary, you can re-subtract any void portions, as described in
Creating Holes in Extruded 3D Spaces on page 3041.

If the legacy area has no override for display properties at the style level, then
one will be created on the migrated space to mimic the drawing default display
properties of the legacy areas. This is intended to preserve visual fidelity for
legacy areas that do not have display property overrides. Existing style or
object display property overrides on legacy areas will carry forward to the
migrated spaces.

Previous versions of the software allowed users to create areas that self-intersect.
Spaces cannot self-intersect. During migration, a self-intersecting area is
converted into a self-intersecting space, and a solution tip displays, advising
you to grip-edit the base boundary to remove the self-intersection. For more
information on grip-editing, see Grip-Editing Space Boundaries on page 3017.

Space Properties
The properties of space objects are illustrated and described below. Note that
some properties are limited to specific space types. For example, a 2D space
does not have any height properties.

DescriptionSpace TypeProperty

General Category

User-defined description of the space.AllDescription

Specifies the layer on which the space is
placed. By default the layer assignment is
defined in the space style.

AllLayer

Specifies the space style. The style defined in
the space tool is the default.

AllStyle

The name of the space. If a list definition has
been specified in the space style, the defined

AllName

list of names is available as a drop-down list.
For more information, see Attaching a List
Definition to a Space Style on page 3097.
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DescriptionSpace TypeProperty

Specifies a space tag to be inserted when
adding the space. Space tags are available in

All (only avail-
able during

Tag

the sample drawings shipped with the soft-space add
ware. You can also create your own space
tags.

and in tool
properties)

Indicates whether the space is associative. The
geometry of an associative space is dependent

AllAssociative

on its boundary objects. You can disconnect
the associativity of a space after adding it.

NOTE If you insert a non-associative space,
the Associative field reads No and is read-only.
To change the space associativity, see Making
a Space Associative or Non-Associative on
page 2972.

Specifies the calculation type by which the 4
space boundaries (base boundary, net

AllOffset Boundaries

boundary, usable boundary, and gross
boundary) are calculated.

■ Manual: you use the grips on the individu-
al boundaries to generate offsets between
the individual boundaries.

■ By Style: you define the boundaries by
defining offsets between them in the
space style.

■ By Standard <Standard Name>: the space
boundaries and their offsets from each
other are determined by the area calcula-
tion standard listed. For more information,
see Specifying an Area Calculation
Standard for a Drawing on page 3010.

Identifies any calculation modifiers for the
space. A calculation modifier is a formula that

AllCalculation Modifiers

modifies area and perimeter values of the
boundaries of the space.
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DescriptionSpace TypeProperty

NOTE To apply the modifier to the net, us-
able, and gross boundaries of a space, you
need to create and apply a property set
definition that contains properties for the
calculated area and perimeter values for those
3 boundaries. For more information, see
Schedule Properties of Spaces on page 3158.

Accesses the Space/Zone Manager worksheet,
in which you enter information used to pro-

AllSpace/Zone Manager

cess spaces in engineering applications. For
more information, see Editing Space Surface
Properties on page 3061.

Specifies the type of space to be created:Non-Associat-
ive Spaces

Create Type

■ Insert: inserts a space according to the
target dimension settings in the space(only available

style. For information on setting targetduring adding

dimensions of a space in the space style,a space and in

see Specifying Target Dimensions for the
Space on page 3095.

tool proper-
ties)

■ Rectangle: lets you create a rectangular
space with user-defined dimensions.

■ Polygon: lets you create a space com-
posed of user-defined line and arc seg-
ments.

■ Generate: lets you generate a space from
boundary objects. The space is associative
to the boundary objects.

Specifies whether the individual segments of
a polygonal space are lines or arcs.

Non-associat-
ive polygonal

Segment type

spaces (only
available dur-
ing adding a
space and in
tool proper-
ties)
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DescriptionSpace TypeProperty

Associative
spaces (only

Generate Space Cat-
egory

available dur-
ing adding a
space and in
tool proper-
ties)

Specifies whether you can generate spaces
from boundary objects that already contain
a space. By default, this setting is set to No.

Allow overlapping
spaces

Component Dimen-
sions Category

Specifies the geometry type of the space to
be created:

AllGeometry Type

■ 2D: creates a 2D space.

■ Extrusion: creates a 3D space with a
height extruded from the 2D geometry.
Extruded 3D spaces have floor and ceiling
components and can have room above
the ceiling and below the floor.

■ Freeform: creates a 3D freeform space. A
3D freeform space can be generated from
boundary objects or be converted from
a mass element shape.

Specifies the overall height of the space, in-
cluding floor to ceiling height, floor thickness,

3D spacesOverall Space Height

ceiling thickness, space above ceiling, and
space below floor.

NOTE This value is read-only for 3D freeform
spaces.
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DescriptionSpace TypeProperty

Specifies the ceiling height of the space.

NOTE This height is calculated from the top
of the floor to the bottom of the ceiling. You
can define additional floor and ceiling thick-
ness.

3D spacesCeiling height

Specifies the thickness of the floor.
If the floor thickness is set to 0, no floor is
displayed.

3D spacesFloor thickness

Specifies the thickness of the ceiling.
If the ceiling thickness is set to 0, no ceiling
is displayed.

3D spacesCeiling thickness

Specifies the distance between the top of the
space ceiling to the top of the space.

3D spacesHeight above ceiling

Specifies the distance between the bottom of
the space floor and the bottom of the space.

3D spacesHeight below floor

Specifies the combined height of ceiling
height, ceiling thickness, and height above
ceiling.

3D spacesDefault surface height

Specifies the relative vertical position of the
space insertion point on the space as one of
the following:

Extruded 3D
spaces

Justification

■ Top of floor

■ Bottom of floor

■ Bottom of space below floor (available
only if the height of the space below the
floor is greater than 0.)

3D freeform spaces are always justified to the
top of floor.

Actual Dimensions
Category

Specifies the length of the space.AllLength
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DescriptionSpace TypeProperty

Specifies the width of the space.AllWidth

Displays the base area of the space.
When inserting a space based on target dimen-
sions, you can enter a base area value if you
have not chosen to constrain the area.

AllBase area

Displays the base perimeter of the space.AllBase Perimeter

Displays the base volume of the space.3D spacesBase Volume

Advanced Dimen-
sions

Specifies the height for calculating the areas
of a 3D freeform space on 2 different calcula-

3D freeform
spaces

Calculation Plane 1 +
2 Height

tion planes. This would be useful to calculate
the rentable area of a room directly under the
roof at 2 different room heights.

Target Dimensions

Displays the target area defined in the space
style.

Non-associat-
ive spaces

Target area

based on tar-
get dimen-
sions

Displays the maximum area defined in the
space style.

Non-associat-
ive spaces

Maximum area

based on tar-
get dimen-
sions

Displays the minimum area defined in the
space style.

Non-associat-
ive spaces

Minimum area

based on tar-
get dimen-
sions

Location
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DescriptionSpace TypeProperty

Specifies the rotation of the space.Non-associat-
ive spaces

Rotation

Specifies the elevation of the space.Non-associat-
ive spaces

Elevation

Specifies the location and coordinate system
of the space.

Non-associat-
ive spaces

Additional Information

In addition to these object properties there are a number of schedule properties
that can be attached and calculated for a space. For a full list, see Schedule
Properties of Spaces on page 3158.

Using Space Tools to Create Spaces
Tools provided with AutoCAD Architecture let you quickly place spaces by
selecting a space tool with a specific space style and other predefined properties.
You can use the tool with its default settings, or you can change any properties
that are not controlled by the style. You can also use space tools to create new
spaces by applying tool properties to existing objects.

Tool palette containing space tools

The default tool palettes in the workspace contain space tools that you can
use and customize as needed. In addition, the following catalogs provided
with the software contain space tools that you can add to your tool palettes:

■ Stock Tool catalog
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■ Sample Palette catalog

■ Design Tool catalog

For more information on accessing tools in these catalogs, see Content Browser
on page 129.

Custom palettes created by your CAD manager or other users may also contain
space tools with space styles and properties that are customized for your
projects or office standards.

Generating Associative Spaces
Associative spaces are bounded by objects that define the space area. If the
boundary objects change, the space inside them is updated, too. You will
typically work with associative spaces when entering the documentation phase
of the project.

Geometry Types of Associative Spaces

Associative spaces can be 2D spaces, extruded 3D spaces, or 3D freeform spaces.
An associative 2D or extruded 3D space is associative only to the objects in
the X and Y direction of the floor plan. The height is either 0 or a user-defined
extrusion height. A 3D freeform space is associative to the objects bounding
it in all 3 spatial dimensions.

Spaces can be associative to many 3D and linework objects. For a listing of
valid boundary objects, see Valid Boundary Objects for Associative Spaces on
page 2941.

External References

A space can be associative to boundary objects in external references. If the
boundary objects in the external reference change, the space in the host
drawing changes, too. However, spaces that have been generated in an external
reference do not interact with boundary objects in the host drawing.
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Boundary Objects for Associative Spaces
Associative spaces are bounded by objects. An object must fulfill a number of
conditions to bound a space:

■ The object must be a valid boundary object for associative spaces. For a
complete list, see Valid Boundary Objects for Associative Spaces on page
2941.

■ The Bound Spaces property of the object must be set to Yes. For more
information, see Setting the Bound Spaces Property for Boundary Objects
on page 2947.

Valid Boundary Objects for Associative Spaces
The following table lists all objects that are valid as boundary objects for
associative spaces. There are different valid boundary objects for 2D/extruded
3D spaces and 3D freeform spaces. 3D freeform spaces must be bounded by
objects that have a 3D geometry; 2D and extruded 3D spaces can be bounded
by 2D linework, too.

All valid boundary objects must have their Bound Spaces property set to Yes
in order for associative spaces to be generated from them. The Bound Spaces
property for an object is located on the Properties palette. For objects that use
styles, the Bound Spaces property can also be set in the style. The default value
of the setting varies depending on the object type. Objects like walls and
curtain walls ave a default Bound Spaces value of Yes. Others, like structural
members or linework have a default Bound Spaces value of No. Change the
Bound Spaces properties of objects as needed to generate your spaces (as
described in Setting the Bound Spaces Property for Boundary Objects on page
2947).

IMPORTANT Objects that are set as boundary objects for associative spaces and
then are placed on a frozen or hidden layer still participate in the generation of
associative spaces. It is possible to generate spaces from invisible boundary objects.
If this is the case, review your layer settings, and unhide or unfreeze those layers
as necessary.
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The following table lists all valid boundary objects for both 2D/Extruded 3D
spaces and 3D freeform spaces, as well as the default value of their Bound
Spaces property when inserted in a drawing:

Default Bound
Spaces value

Boundary object
for 2D/Extruded
3D spaces

Boundary object for 3D freeform
spaces

Object

Yes (by Style)YesYes
The 3D freeform space is generated at
the near face of the wall body (at base
curve)

Wall

NOTE If a modifier creates a hole or
gap through the wall, then the gap
might be ignored in the space genera-
tion if the maximum gap size value (see
Defining a Maximum Gap Size for Asso-
ciative Spaces on page 2962) is greater
than the width of the hole.

Plan modifiers, body modifiers, interfer-
ences, sweeps, end caps, and opening
end caps are included in the geometry
of the generated space.

Yes (by Style)YesYes
The 3D freeform space is generated at
the curtain wall body.

Curtain wall/Curtain
wall unit

Interferences, roof line, floor line, and
frame profiles are included in the geo-
metry of the generated space.

NOTE Empty cells or holes created by
a curtain wall modifier do not impact
the space generation. They are ignored
and the space is generated as if the
curtain wall was closed.

Yes (by Style)YesYes
The 3D freeform space is generated at
the near face of the frame (at base
curve).

Door and window as-
sembly
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Default Bound
Spaces value

Boundary object
for 2D/Extruded
3D spaces

Boundary object for 3D freeform
spaces

Object

Interferences and frame profiles are in-
cluded in the geometry of the gener-
ated space boundary.

NOTE Empty cells or holes created by
a door and window assembly modifier
do not impact the space generation.
They are ignored and the space is
generated as if the assembly was
closed.

Door/Window:
Yes (by Style)
Opening: Yes

YesYes

NOTE If a door, window, or opening
is anchored in a wall, the Bound Spaces
setting of the wall is used for the
opening, too.

Door/Window/Open-
ing

The opening shape also defines open-
ings in generated freeform space sur-
faces.

No (by Style)Yes
The 2D/Extruded
3D space is gener-

Yes
The 3D freeform space is generated on
the near face of the mass element
body.

Mass element

ated at the near
face of the mass
element body at
the mass element
bottom.

YesNoYes
The 3D freeform space is generated at
the near face of the roof body.

Roof

Yes (by Style)NoYes
The 3D freeform space is generated at
the near face of the roof slab body (at
cut plane).

Roof slab
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Default Bound
Spaces value

Boundary object
for 2D/Extruded
3D spaces

Boundary object for 3D freeform
spaces

Object

Body modifiers, fascia, and soffit bodies
are included in the geometry of the
generated space boundary.

NOTE Interferences and holes in the
roof slab will be ignored when the
space is generated.

Yes (by Style)NoYes
The 3D freeform space is generated at
the near face of the slab body (at cut
plane).

Slab

Body modifiers, fascia, and soffit bodies
are included in the geometry of the
generated space boundary.

NOTE Interferences and holes in the
slab will be ignored when the space is
generated.

No (by Style)YesYes
The freeform space is generated at the
near face of the member body (at base
curve).

Structural member

Holes or gaps in the structural member
are ignored when the placement of the
space boundary is determined.

No (by Style)YesYes
In order to bound 3D freeform spaces,
a multi-view block must contain objects

Multi-view block

that have a 3D geometry and are valid
boundary objects for spaces. The geo-
metry stored in the model view block
is used to generate the space.
The space is generated from the model
geometry (at bottom).

Yes (by Style)NoYesCustom display
blocks
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Default Bound
Spaces value

Boundary object
for 2D/Extruded
3D spaces

Boundary object for 3D freeform
spaces

Object

Dependent on
the objects con-

YesYes
In order to bound 3D freeform spaces,
a block must contain objects that have

Block

tained in the
blocka 3D geometry and are valid boundary

objects for spaces.

YesYesYes
In order to bound 3D freeform spaces,
an external reference must contain

External Reference

objects that have a 3D geometry and
are valid boundary objects for spaces.

NoYesNoLine

NoYesNoCircle

NoYesNoPolyline

NoYesNo3D Polyline

NoYesNoEllipse

NoYesNoSpline

NoYesNoArc

TIP AutoCAD 3D solids are not valid boundary objects for spaces. In order to use
a 3D solid to generate a space, use one of the following methods:

■ Convert the 3D solid to a mass element, as described in Creating a Mass
Element from a 3D Solid on page 1021, and use the mass element to generate
the space.

■ Wrap a polyline around the solid and use the polyline to generate the
space.
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The Space Separator Tool
In addition to the regular objects that can be used as boundary objects for
spaces, you can also use a space separator tool that lets you separate spaces
when no real object is there to separate them. This could be the case when
you have different functional areas within the same room.

Using the room separator tool to create two different spaces in one room

1 Select the Space Separator tool on the Spaces tool palette.

If your tool palette layout does not contain the Spaces palette,
open Content Browser (Home tab ➤ Build panel ➤ Tools

drop-down ➤ Content Browser  ) and search for “Space
Separator”.

NOTE Alternatively you can select the space to be divided and click
Space tab ➤ Modify panel ➤ Divide Space.

2 Specify the separating line on screen.

TIP The space separator uses a polyline to generate the separating
line, so that you can create a multi-segment separator line.

3 Press Enter to finish the separator line.

4 To remove the separator line, you can either delete it from the
drawing, or select it, and set its Bound Spaces property on the
Properties palette to No.
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Setting the Bound Spaces Property for Boundary Objects
The objects designed to form the boundary of an associative space must have
their Bound Spaces property set to Yes before generating the space. You can
set the Bound Spaces property on the object, or, for objects that use styles,
you can set it in the object style.

TIP Before setting the Bound Spaces property of a boundary object to Yes, verify
that this type of object is a valid boundary object for the space you want to
generate. For example, a roof or roof slab is a valid boundary object only for 3D
freeform spaces; you cannot use it to generate an extruded 3D space or a 2D
space, even if the slab’s Bound Spaces property is set to Yes.

The following overview graphic shows how the setting of the Bound Spaces
property on the boundary object affects the generation of associative spaces.
For detailed information on how to set the Bound Spaces property for a
boundary object, consult the sections following below.

Note that the term “AutoCAD object” in the graphic below refers to AutoCAD
linework (lines, arcs, circles, and polylines etc.)
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Migrating Profiles from Previous Versions of the Software

Beginning with AutoCAD Architecture 2009, the mechanism by which objects
are defined as boundary objects for spaces has changed. In previous versions,
objects were selected by applying an object filter during the space generation.
In AutoCAD Architecture 2012, each object has its own Bound Spaces property
on the Properties palette or in the object style and is there defined as a
boundary object.

When you import a profile (ARG file) from a previous release, the Bound spaces
property in the Properties palette is not displayed for AutoCAD linework (lines,
arcs, circles, polylines) in the imported profile. In order to display that property
for AutoCAD linework, run the AecSpaceDisplayBoundSpacesProperty
command on the command line. This will enable the display of the Bound
Spaces property for AutoCAD linework in the Properties palette.

2948 | Chapter 40   Spaces



Setting the Bound Spaces Property in the Object Style
Use this procedure to set the Bound Spaces property of objects designed to
bound associative spaces in the object style. You can use this method for all
boundary objects that use styles. When an object style is set to bound spaces,
all objects of that style will bound associative spaces. You can however override
the Bound Spaces property for an individual object of that style in the
Properties palette.

For example, if walls of a specific style - such as toilet stall walls or half-height
kitchen counter walls - should normally not be used as boundary objects, you
can set the Bound Spaces property of the wall style to No, so that any walls
of that style are ignored when you generate a space.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects.

3 Expand the desired object category, and select the style for which
you want to set the Bound Spaces property.

4 Click the General tab.

5 Select the check box for Objects of this style may act as a boundary
for associative spaces.

6 Click OK.

Setting the Bound Spaces Property in the Properties Palette
Use this procedure to set the Bound Spaces property of objects designed to
bound associative spaces in the Properties palette. You can use this method
for all boundary objects, regardless of whether they use styles. If you set a
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different value for the Bound Spaces property in the Properties palette than
in the object style, the settings from the Properties palette override the settings
from the style.

TIP If you want to define walls that do not act as boundary objects for spaces you
must place these walls in a different cleanup group than those walls that do act
as space boundaries. Otherwise the cleanup will result in unexpected results.

1 Select the object for which you want to set the Bound Spaces
property, and double-click.

2 In the Properties palette, display the Bound Spaces setting in one
the following locations:

Location of Bound Spaces
property

Object Type

Expand the General category.Architectural objects:

Expand the Advanced category.Linework objects:

NOTE The Bound Spaces property will not be displayed when
opening the drawing in an AutoCAD Architecture Object Enabler
environment such as AutoCAD, Civil 3D, or Land Desktop, or when
you run AutoCAD Architecture as AutoCAD. It will only be displayed
in full installations of AutoCAD Architecture or AutoCAD MEP.

3 For Bound Spaces, select one of the following options:

■ By Style (Yes/No): This object uses the Bound Spaces setting
defined in the object’s style. This is the default setting for
objects that have styles.

■ Yes: this object can bound associative spaces.

■ No: this object cannot bound associative spaces.
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Displaying all Boundary Objects in the Drawing Area
In large drawings it can sometimes be difficult to determine which objects
can act as boundary objects for spaces. If you are trying to generate associative
spaces, and you get unexpected results or error messages, this is frequently

due to wrong boundary objects. Click Home tab ➤ Inquiry panel ➤ 

 ➤ Show Space Boundaries  to display only the objects in the drawing area
that are currently defined as boundary objects. If one of the objects you need
for a space boundary is not displayed, the object is either not a valid boundary
object or its Bound Spaces property has been set to No.

You can use objects on frozen, hidden, and locked layers as boundary objects
for associative spaces. When you choose to display all boundary objects in
the drawing area, frozen and hidden objects are displayed, too. When you
end the boundary objects-only view mode, these objects will be hidden or
frozen again, and not displayed anymore. If you choose to remain in the
boundary objects-only view, these objects will remain visible until you return
to the normal view.

In the following example, you want to generate two spaces from the geometry
below, for two different functional areas in a lobby. However, only one space
is generated:
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To find out if there is a problem with your boundary objects, you display only
boundary objects, and get the following result:

From this result, you can deduce that the line that should separate the two
functional areas has its Bound Spaces property currently set to No. After you
have ended the command to display boundary objects, you can change the
property accordingly (Setting the Bound Spaces Property in the Properties
Palette on page 2949) in order to get the correct result:

1 Zoom in the drawing area until all desired spaces are visible.

2 Click Home tab ➤ Inquiry panel ➤  ➤ Show Space Boundaries

 .

3 Select one of the following options:

ThenIf you want to

press ENTER.

NOTE The view includes
boundary objects on frozen,
hidden, and locked layers.

see boundary objects and associat-
ive spaces

enter S (hide associative Spaces).see only boundary objects but no
associative spaces
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ThenIf you want to

enter X (eXit).

NOTE Any boundary objects
on frozen, hidden, and locked
layers will not be displayed
anymore.

exit the command and restore the
original visibility settings

Generating an Associative Space
Use this procedure to generate an associative space. Associative spaces are
generated from boundary objects, and are updated when the boundary objects
change.

Associative 3D Freeform Spaces

To create an associative 3D freeform space, the space must be fully bounded
by objects on all surfaces.

Generating a 3D freeform space

Associative 2D and Extruded 3D Spaces

When you generate an associative 2D or extruded 3D space from boundary
objects, the boundary objects determine the extents of the space in the X and
Y directions, and the space is associative to these. The Z-direction is either 0
(for a 2D space) or it is a user-defined extrusion height (in extruded 3D spaces).

For an associative 2D or extruded 3D space, you can define the gap allowed
between colinear boundary objects. This would be useful for example if you
have created a plan of a building with lines, and represented doors and
windows as gaps between the lines. You can set a gap tolerance for these gaps,
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and the software will calculate the missing geometry from the existing colinear
line segments. (AEC windows, doors, and openings in walls are not considered
as gaps.)

NOTE Gaps are allowed only between colinear segments that do not contain
other boundary objects, not between objects that are at other angles to each other
or between colinear segments when the gap contains other boundary objects.

Generating an extruded 3D space from walls

As a special case, you can generate an associative 2D or extruded 3D space
from the outline of an object in a drawing. In this case, the object outline will
be used as the boundary of the new space. For example, if you generate spaces
from wall outlines, spaces will be generated from the wall outline.
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Walls (left) and space generated from wall outlines (right)

IMPORTANT  In previous versions of the software, objects that were invisible due
to a frozen or hidden layer were never included in the generation or update of
associative spaces. Beginning with this version, frozen and hidden objects are
included in the space generation and update if they are set as boundary objects.

Generating an associative space

1 Verify that all necessary boundary objects have their Bound Spaces
property set to Yes.

TIP Click Home tab ➤ Inquiry panel ➤  ➤ Show Space

Boundaries  to display all objects that currently have their Bound
Spaces property set to Yes (including objects on frozen, hidden, and
locked layers.) If the selection does not meet your needs, cancel the
space generation, and first change the Bound Spaces property on all
necessary objects, as described in Setting the Bound Spaces Property
for Boundary Objects on page 2947.

2 Open the tool palette that contains the Space tool you want to
use, and select it.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Space

drop-down ➤ Generate Space  .

3 For Offset boundaries, select how the 4 space boundaries (base,
net, usable, and gross boundary) are calculated. For information
about space boundaries, see Working with Space Boundaries on
page 3004.

■ Manual: The net, usable, and gross boundaries can be manually
edited with grips.
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■ By style: The net, usable, and gross boundaries are offset from
the base boundary by a value defined in the space style. For
more information, see Specifying Space Boundary Offsets in
a Space Style on page 3096.

■ By standard <Standard Name>: The net, usable, and gross
boundaries are defined by the area calculation standard listed.
For more information, see Specifying an Area Calculation
Standard for a Drawing on page 3010.

4 On the Properties palette, for Create type, select Generate.

NOTE The Associative property is interlinked with the Create type.
If the Create type is Generate, the Associative setting defaults to Yes.
If the Create type is Insert, Rectangle, or Polygon, the Associative
setting defaults to No and becomes read-only.

5 Select Yes for Allow Overlapping Spaces if you want to be able to
generate spaces from boundaries that already contain a space.

This could be useful if you want to generate spaces from an xref
drawing that already contains spaces, but you need to generate
spaces with different settings (for example, with a different area
calculation standard).

6 For Geometry type, select one of the following:

■ 2D: generates an associative 2D space.

■ Extrusion: generates an associative extruded 3D space. For an
extruded 3D space, the height (Z) is defined by the user and
is applied uniformly to the space.

■ Freeform: generates an associative 3D freeform space.

IMPORTANT For descriptions of other Spaces settings on the
Properties palette, see Space Properties on page 2933.

7 Before creating the spaces, you can perform these two optional
steps to help with successfully creating spaces:

■ Verify that all necessary boundary objects have their Bound
Spaces property set to Yes. In order to do this, enter sh (SHow
Bounding Objects). This option displays all objects that have
their Bound Spaces property set to Yes. If an object you need
for your space is not displayed, you can cancel the space
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generation and first change the Bound Spaces property on the
object to Yes.

■ Verify that all boundary objects are visible in the drawing area.
If necessary, zoom in or out to display the desired objects, and
then enter v (reset Visible boundaries) to update the drawing
area.

8 In the drawing, generate the spaces:

Then…If you want to…

Enter G (Generate all).generate a 3D freeform space

use one of the following options:generate a 2D or extruded 3D
space ■ Enter G (Generate all) to gener-

ate spaces for all visible bound-
aries.

■ Pick inside closed boundaries
in order to generate spaces for
them.

Generating Associative Spaces from Xrefs and Blocks
You can generate associative spaces from objects in xrefs and blocks. The
workflow for this has changed between the previous version of AutoCAD
Architecture and the current version. The following sections describe the
changes, as well as the workflows recommended for using xrefs and blocks
for generating spaces.

Automatic Update of Associative Spaces through External References

Associative spaces that are bounded by objects in external references are now
included in the automatic update of associative spaces. No manual updates
are necessary anymore.

Migrating Xref Spaces from previous Versions of AutoCAD Architecture

Beginning with AutoCAD Architecture 2009, the mechanism by which linework
objects (line, arc, circle, polyline) are defined as boundary objects for spaces
has changed. In previous versions, linework boundaries were selected by
applying an object filter during space generation. In AutoCAD Architecture
2012, each linework object has its own Bound Spaces property on the Properties
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palette and can be defined as a boundary object there. Additionally, xrefs and
blocks now have a Bound Spaces property as well.

When you migrate a drawing with associative spaces that use linework from
an xref as boundary objects you’ll see the following behavior:

■ All lines, arcs, circles, and polylines (as well as object outlines selected via
the All Linework filter) that were defined as boundary objects in the host
drawing will have their Bound Spaces setting correctly translated to the
new mechanism and will continue to bound spaces.

■ All lines, arcs, circles, and polylines from not-yet migrated xrefs however
will not act as boundary objects for spaces in the host drawing anymore,
so that if the spaces in the host drawing are updated (or new spaces are
generated), the generation or update fails for these xref linework objects.

In order to update your spaces correctly, you can use an xref override on the
affected linework objects (see Changing the Display Configuration Used in
Xref Drawings on page 839). Alternatively, you can open the xref drawing, set
the Bound spaces property on the desired linework objects to Yes, re-load the
xref, and regenerate the spaces.

NOTE When you are converting drawings with xrefs and associative spaces from
a previous version, the first time the host drawing is opened, will be accompanied
by a noticeable performance delay. This is however only a one-time effect; once
the host drawing and its associated xref drawings have been opened and saved
with the current version, the performance will be improved in all future sessions.

Generating Spaces from Xrefs or Blocks Using the Xref or Block
Settings

Within an xref or block you can define objects as boundary objects for spaces.
These objects can be used to generate spaces in a host drawing.

In order to use boundary objects from an xref in a host drawing, the xref must
have its Bound Spaces property set to Yes. (This is the default setting when
inserting an xref.) If the xref’s Bound Spaces property is set to Yes, objects in
it that have their Bound Spaces property set to Yes, too, will be used to generate
spaces in the host drawing. If the Bound Spaces property of the xref has been
set to No, any objects in the xref are ignored when generating spaces in the
host drawing, regardless of whether they have their Bound Spaces property
set to Yes.
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Perform these steps to use boundary objects from an xref to generate spaces
in a host drawing:

1 Set the Bound Spaces property of the desired objects in the xref drawing
to Yes. For instructions, see Setting the Bound Spaces Property for
Boundary Objects on page 2947.

2 Reference the drawing into the host drawing where you want to generate
spaces.

3 Select the xref.

4 In the Properties palette, expand the Advanced category.

5 Verify that the Bound Spaces property is set to Yes.

6 Generate spaces as described in Generating an Associative Space on page
2953.

This mechanism allows you to generate different spaces from multiple instances
of the same xref, because the same referenced geometry can be used as
boundary for spaces in one instance but not in another.

NOTE External references in Project Navigator have different default settings for
the Bound Spaces property: By default, external references attached to elements,
constructs and views from Project Navigator have their Bound Spaces property
set to Yes; external references attached to sheets from Project Navigator have their
Bound Spaces property set to No.

Blocks work according to the same principle, except that the default setting
for the Bound Spaces property of a block is dependent on the Bound Spaces
properties of the objects inside the block. If none the objects inside the block
has its Bound Spaces property set to Yes, then the block’s Bound Spaces
property will be No. If there is at least one object inside the block that has its
Bound Spaces property set to Yes, then the block’s Bound Spaces property will
be set to Yes, too.

IMPORTANT When you change the Bound Spaces properties of objects inside a
block via the Block Editor, these changes are not automatically updated in the
host drawing upon saving and closing the Block Editor. In order to verify that all
spaces are updated correctly, you must perform a manual update of all affected
spaces, as described in Manually Updating Associative Spaces on page 2966.

When blocks or external references are nested, and a block or external reference
in the hierarchy has its Bound Spaces property set to No, then all blocks and
external references nested in it are not used to bound spaces, even if some of
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the nested blocks or external references contain objects that have their Bound
Spaces property set to Yes. In order to use boundary objects from nested blocks
and xrefs, the containing level must have its Bound Spaces property set to
Yes.

If a legacy drawing is opened in AutoCAD Architecture 2012, all blocks and
external references that contain boundary objects will by default have their
Bound Spaces property set to Yes.

Generating Spaces from Xrefs Using Overrides in the Host
Drawing

If you do not want to make changes to the Bound Spaces property of objects
in the xref drawing, you can use an override in the host drawing to change
the boundary objects in xrefs without making a change to the xref drawing.
For example, if you are a building engineer and receive an architectural drawing
from which you want to generate spaces, but you do not want to change any
boundary objects in the original drawing, you can xref the drawing into a
new host drawing, and override the Bound Spaces property of xref objects in
the new host drawing. The source drawing remains unchanged, but you can
still generate spaces in the new drawing that are different from those generated
in the xref drawing.

Override the Bound Spaces properties of xref objects in a host drawing

1 Xref the drawing from which you want to generate spaces into the host
drawing.

2 Select the xref.

3 In the Properties palette, expand the Advanced category.

4 Verify that the Bound Spaces setting is set to Yes.

5 Display all boundary objects in the drawing (both host and xref) by

clicking Home tab ➤ Inquiry panel ➤  ➤ Show Space Boundaries
.

If the objects displayed by that command do not meet your needs, you
need cancel space generation, and first apply overrides to the Bound
Spaces properties of the desired xref objects.

6 At the command prompt, enter AecSpaceSetBoundingObjects.

7 Select the desired boundary objects in the xref, and press ENTER.
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8 On the command line, enter Y (Yes) to generate the override, and press
ENTER.

NOTE An xref override is only valid for the selected instance of the xref in
the host drawing where it is set. If the same xref drawing is referenced into
a different host drawing, or as another instance into the same host drawing,
no overrides exist.

If you now generate the spaces, all overridden objects in the xref will
now be used to generate spaces.

9 If you have not applied any overrides yet, and no valid space boundaries
can be found because none of the objects in the xref drawing have their
Bound Spaces property set to Yes or the objects that are do not enclose
a valid space, a task dialog will appear and prompt you to select objects
that should bound spaces.

10 In this case either select all visible objects as boundary objects, or select
individual objects, and press ENTER. This will automatically set the Bound
Spaces properties of all selected objects to Yes, and if those objects are in
an xref will add an override to them in the current drawing.

You can remove space boundary overrides from objects in xrefs. When the
override is removed, the Bound Spaces settings of the xref objects are used
again.

To remove a space boundary override from an object in an xref

1 At the command prompt, enter AecSpaceSetBoundingObjects.

2 Select the boundary objects in the xref from which you want to remove
the override, and press ENTER.

3 On the command line, enter R (Remove Override), and press ENTER.

4 If necessary, update the spaces in your drawing.

Generating Spaces from an Xref Drawing Containing Spaces

If you receive a drawing with spaces, but want to generate a different set of
spaces, verify that the Allow Overlapping Spaces setting in the Properties
palette is set to Yes before you pick your spaces. Otherwise, spaces can only
be generated in areas that do not contain a space from the xref.
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Defining a Maximum Gap Size for Associative Spaces
When you are generating 2D or extruded 3D spaces, it is possible to define an
allowed gap size between colinear boundary objects. The software will calculate
the missing segments and create the space profile from that. You cannot define
a gap size for 3D freeform spaces.

1 Click  ➤ Options.

2 Click the AEC Object Settings tab.

3 Under Maximum Gap Size, select the largest gap you want to
allow between the boundary objects of an associative space.

4 Click OK.

TIP Alternatively, you can set the maximum allowed gap size between
boundary objects on the command line by entering
AecSpaceMaxGapSize.
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Updating Associative Spaces
Associative spaces are defined by their boundary objects and are updated when
the boundary objects change. You can choose to have associative spaces update
automatically whenever there is a relevant change to boundary objects, or
you can choose to perform the space update manually.

Updating Associative Spaces Bounded by External References

Objects in external references can serve as boundary objects for associative
spaces in the host drawing. When the objects in the external reference change,
the space is updated too. In previous versions, a manual update was necessary
to propagate changes in the external reference’s boundary objects to the spaces
in the host drawing; now changes from external references are automatically
updated when reloading the external reference, if the automatic update of
associative spaces is activated (see Activating and Deactivating Automatic
Updates on page 2964).

Roundtripping Associative Spaces between AutoCAD Architecture 2012
and previous Versions

In previous versions of the software, boundary linework objects were defined
by a filter selection during space generation. In the current version, each object
has its own Bound Spaces property in the Properties palette. This includes
blocks and xrefs. These changes can cause discrepancies when roundtripping
drawings that contain 2D linework, blocks, and external references. For
example, when a line in the current version of the software has its Bound
Spaces property set to Yes, and is opened in a previous version, it will still be
a boundary object for spaces, but it will be selected via the boundary filter of
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the space. When the filter is removed from the space in the previous version,
and the drawing is re-opened in AutoCAD Architecture 2012, the change in
the filter setting will be ignored. It is recommended that you carefully examine
your spaces after roundtripping them between different versions of AutoCAD
Architecture in order to avoid space errors.

Activating and Deactivating Automatic Updates
Use this procedure to activate or deactivate the automatic update of associative
spaces.

Updating each temporary change to the space geometry might not be necessary
or desirable. For example, if you delete a wall only to replace it with a different
one in the same position, you only need the space to update after the new
wall is in place, rather than once when the old wall is removed and again
when the new one is inserted.

Manual updates offer better performance, but mean that the geometry of
spaces and their boundary objects might be out-of-synch at a given time during
the drawing session.

When the automatic update of associative spaces is deactivated, and an area
calculation standard has been selected to calculate boundary offsets, the rules
of the standard will only be applied to changed spaces when either the
automatic update has been activated again or the spaces are updated manually,
as described in Manually Updating Associative Spaces on page 2966.

IMPORTANT When you re-activate the automatic update of spaces, only those
spaces will be updated that had no boundary objects added while the update was
off. For example, if you added a dividing wall to a space while the automatic
update was off, and then turn the automatic update on, the space will not be
divided by the wall. Update the space manually to reflect the new geometry.

1 Click  ➤ Options.

2 Click the AEC Object Settings tab.
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3 Under Space Settings, specify whether associative spaces will be
updated automatically:

Then…If you want to…

select Automatically update associative spaces.update associative spaces
automatically each time
you make a change to
the boundary objects

clear Automatically update associative spaces.update associative spaces
manually

4 Click OK.

TIP The automatic update of spaces can also be turned on or off via
the AecSpaceAutoUpdate command.
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Manually Updating Associative Spaces
Use this procedure to manually update an associative space after its boundary
objects have changed. A manual update can be necessary in these cases:

■ The automatic update of associative spaces has been deactivated, as
described in Activating and Deactivating Automatic Updates on page 2964,
and the boundary objects of an associative space have been modified.

■ A new boundary object has been added while the automatic update of
spaces was deactivated.

■ The automatic update cannot be performed due to any of the conditions
described in Troubleshooting Associative Spaces on page 2974.

You can choose to either update only selected spaces, or all associative spaces
in the drawing.

IMPORTANT Previously, objects that were on a frozen or hidden layer were not
included in any space updates. Now, frozen or hidden objects are included in the
space update if their Bound Spaces property is set to Yes.

When the automatic update of associative spaces is deactivated, and an area
calculation standard has been selected to calculate boundary offsets, the rules
of the standard will only be applied to changed spaces when either the
automatic update has been activated again or the spaces are updated manually.

Manually updating selected spaces

1 Select the associative space you want to update.

2 Click Space tab ➤ Modify panel ➤ Update drop-down ➤ Selected

Space  .
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Manually updating all associative spaces in the drawing

1 Select any associative space in the drawing.

2 Click Space tab ➤ Modify panel ➤ Update drop-down ➤ All

Associative Spaces  .

Merging Associative Spaces
Associative spaces can be merged by removing boundary objects that separate
them. If you activated the automatic update of associative spaces (as described
in Activating and Deactivating Automatic Updates on page 2964), the update is
run automatically.

Merging Associative Spaces | 2967



The following rules determine in descending order the precedence of property
inheritance in the merged space:

1 If only one of the spaces to be merged has object property set data, the
properties of that space are applied to the merged space.

2 If only one of the spaces to be merged has classification data, the
properties of that space are applied to the merged space.

3 If both of the spaces have object property set data or classification data,
the properties of the larger space are applied to the resulting space.

4 If only one of the spaces to be merged has style-defined property set data,
the properties of that space are applied to the merged space.

5 If all of the above criteria apply to none or both of the spaces to be
merged, the properties of the older spaces are applied to the merged space.

This can result in unexpected property assignments, so it is recommended
that you check the merged space’s properties.

If the automatic update of associative spaces is not activated, you need to
merge spaces between deleted boundary objects manually. This process involves
more steps than the automatic update, but allows you more control over which
space’s properties are retained in the resulting space.

Manually merging associative spaces

1 Verify that the automatic update of associative spaces is
deactivated, as described in Activating and Deactivating Automatic
Updates on page 2964.
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2 Select the boundary object that separates the spaces you want to
merge, and delete it.

You now have 2 separate spaces within the same boundary objects.

3 Select and delete the space whose properties you do not want to
keep.

If you have no preference, you can delete either space.

4 Click Space tab ➤ Modify panel ➤ Update drop-down ➤ Selected

Space  .

The space is updated to the new boundaries.

Dividing an Associative Space
Associative spaces can be divided by adding new boundary objects. If you
activated the automatic update of associative spaces (as described in Activating
and Deactivating Automatic Updates on page 2964), the update is run
automatically.

TIP To divide a space without additional boundary objects, see The Space Separator
Tool on page 2946.
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NOTE Verify that the new boundary object has its Bound Spaces property set to
Yes before the space will be divided. For more information, see Setting the Bound
Spaces Property in the Properties Palette on page 2949.

Manually dividing associative spaces

1 Verify that the automatic update of associative spaces is
deactivated, as described in Activating and Deactivating Automatic
Updates on page 2964.

2 Create a new boundary object to divide the existing space.

The space object now spans 2 sets of boundary objects.

3 Select the space, and click Space tab ➤ Modify panel ➤ Update

drop-down ➤ Selected Space  .

The existing space is updated to fit into one of the 2 sets.

4 Create a new associative space in the empty set, as described in
Generating an Associative Space on page 2953.
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Deducting Spaces from an Associative Space
You can deduct objects enclosed in an associative space from the overall space
area. This would be useful for deducting areas filled by columns or shafts.

Enclosed objects included in space area

Deducting Spaces from an Associative Space | 2971



Enclosed objects deducted from space area

1 Before generating the space, verify that the enclosed objects you
want to deduct from the overall space volume are both valid
boundary objects (see Valid Boundary Objects for Associative
Spaces on page 2941) and have their Bound Spaces property set to
Yes (see Setting the Bound Spaces Property for Boundary Objects
on page 2947).

2 Generate the space by one of the methods described in Generating
an Associative Space on page 2953.

Objects that are fully enclosed in the generated space are
automatically deducted.

Making a Space Associative or Non-Associative
When you make a space associative, you connect it to a set of boundary objects
that define the space’s geometry. To make it non-associative you disconnect
it from its boundary objects, so that it is not affected by future modifications
to those objects.

If you make a non-associative space associative, the software checks if a valid
set of enclosing boundary objects can be found. If this is so, the space is made
associative to them and the geometry is updated accordingly.
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Making a space associative to boundary walls

If you make an associative space non-associative, the space is disconnected
from its boundary objects. The space geometry retains its current shape after
the associativity is deactivated, but is grip-editable.

Removing the associativity of a space to the boundary walls

Making an associative space non-associative

1 Double-click the space you want to make non-associative.

2 On the Properties palette, for Associative select No.

Edit the space as desired.

Making a non-associative space associative

1 Select the space you want to make associative to boundary objects.
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2 Click Space tab ➤ Modify panel ➤ Make Associative  .

If a valid set of boundary objects is detected, the space geometry
is updated to the boundary of these objects, and the Associative
property on the Properties palette is set to Yes.

If no valid set of boundary objects is detected, the space geometry
remains unchanged and the Associative property on the Properties
palette remains read-only and set to No.

TIP When a non-associative space is made associative, and its Offset
boundaries property is set to Manual, then making the space
associative will align only the base boundary of the space to the new
boundary objects. The net, usable, and gross boundaries will stay in
their previous shape. You can fix this by changing the Offset
boundaries property to either By style or By standard.

Troubleshooting Associative Spaces
In this section, frequently asked questions about associative spaces are
addressed.

When I use the Generate all option to generate spaces from my drawing,
the process takes a very long time. How can I speed it up?

Before starting the space generation, zoom in on the model to decrease the
current drawing area. The space generation processes all objects in the current
drawing area, so the larger the drawing area, the longer the processing will
take.

I have noticed a decrease in performance between space drawings in previous
versions of AutoCAD Architecture and in the current version. There have
been no changes to the drawings, so what can be the reason?

Check if your drawing contains spaces bounded by objects in external
references. In previous versions of the software, a manual update was necessary
to propagate changes in the external reference’s boundary objects to associative
spaces in the current drawing; now changes from external references are
automatically updated, if the automatic update of associative spaces is
activated. This can result in a noticeable performance lag. Deactivate the
automatic update, as described in Activating and Deactivating Automatic
Updates on page 2964.

Another possibility can be that when you are converting drawings with xrefs
and associative spaces from a previous version, the first time the host drawing
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is opened will be accompanied by a noticeable performance hit. This is however
only a one-time effect; once the host drawing and its associated xref drawings
have been and opened and saved with the current version, the performance
will be improved for all future sessions.

When I try to generate a 3D freeform space from my model, why do I get an
error message: Valid boundary not found?

The space generation mechanism may not be able to detect a valid space
boundary for any of the following reasons:

1. The boundary objects are not 100% closed

Double-check your model to verify that the objects are really enclosing the
space. There may be tiny, barely visible gaps between the designated boundary
objects in the building model.

For example, if an interior wall is auto-projected to a roof slab without ceiling,
and the interior wall extends only to the baseline and not to the outside of
the outside wall, the 3D freeform space cannot be generated. In such a case
you could create a ceiling under the roof slab, so that walls are projected to
the ceiling instead of the actual roof. Or you could extend the interior wall
all the way to the outside of the exterior wall. You could also place a sweep
on the wall to make the top of the wall flush with the sloping roof slab.

2. Objects intended as boundary objects are not valid for the 3D freeform
space generation

The boundary objects for an associative 3D freeform space must belong to the
objects listed under Valid Boundary Objects for Associative Spaces on page
2941. Any other AutoCAD Architecture objects, such as railings or 2D linework,
will not be recognized by the space generation. If your selection set includes
one of these objects, it will be filtered out, and the boundary set will be
considered not closed. To create a valid bounded space, substitute a valid
boundary object for the invalid one.

3. Edges of boundary objects touch, but do not overlap

When boundary objects like walls, slabs, and other 3D geometry just touch
each other but do not have any overlap, or when objects intersect only along
an edge (to form a line rather than a surface intersection), they are considered
open even though the corresponding real-world components would be closed.
In such cases, no 3D freeform space can be created. To fix this problem, extend
one of the objects just far enough to create an overlap.
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When I try to generate a 2D or extruded 3D space from my model, why do I
get an error message: Valid boundary not found?

The space generation mechanism may not be able to detect a valid space
boundary for any of the following reasons:

1. Some objects are not boundary objects

Some objects that are needed to create a closed boundary for the space are
either not valid boundary objects for spaces or their Bound Spaces property
is set to No. To see all objects that are currently boundary objects for spaces,

click Home tab ➤ Inquiry panel ➤  ➤ Show Space Boundaries  . If an
object that is needed for the boundary does not display, it is either not a valid
boundary object or its Bound Spaces property is set to No. For more
information see Valid Boundary Objects for Associative Spaces on page 2941
and Setting the Bound Spaces Property for Boundary Objects on page 2947.

2. The Maximum gap size is smaller than some colinear gaps in your model

When you generate a 2D or extruded 3D space, you can define an allowed
gap size between colinear boundary objects. If the colinear gaps in your model
are larger than the allowed gap size, the model is considered not closed, and
a space cannot be generated or might flow into an adjacent area. In that case,
change the maximum gap size to a value greater than your largest colinear
gaps, as described in Defining a Maximum Gap Size for Associative Spaces on
page 2962.

Are there other factors I should check if my associative spaces are not
generated correctly?

There are a number of general possibilities to check when your spaces are not
generated:

Boundary walls have been placed in the same cleanup group as walls that
are no boundary objects

If a wall that is no boundary object intersects with a wall that is a boundary
object, and they are in the same cleanup group, the wall that is a boundary
object is considered to be not a boundary object because of its cleanup with
the other wall. As a result, no space can be generated even if the geometry
would otherwise be closed. In that case, you need to create a new cleanup
group and place only the walls that are no boundary objects in that group.
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The visible drawing area was changed by zooming or panning in between
starting the Space tool and selecting the boundary objects

When you generate associative spaces, only boundary objects visible in the
drawing area at the time you start the space generation tool are included in
the selection set. If you have zoomed or panned before generating spaces, the
space detection is not automatically updated to the new drawing area. To
update the selection set, use the v (reset Visible boundaries) option on the
command line. This option will update the drawing area to its current extents.
Then, generate the space again.

When I generate spaces by using the Generate all option, the spaces are
generated but not according to the boundary objects visible in the drawing
area. The same happens when I try to update some existing spaces. What is
the reason?

Some boundary objects for these spaces might be on a frozen or hidden layer.
In previous versions of AutoCAD Architecture, objects that were invisible due
to a frozen or hidden layer were not included in associative spaces. Now,
frozen or hidden objects are included in the space generation if they are set
as boundary objects and are located in the current drawing area. To verify if
this is the case, display all boundary objects in the drawing area, as described
in Displaying all Boundary Objects in the Drawing Area on page 2951. If you
now see previously invisible objects, these objects are on a frozen or hidden
layer. To exclude objects on a frozen or hidden layer from the boundary set,
unfreeze or unhide the layer, and change the Bound Spaces property of the
objects from Yes to No.

I have generated spaces from walls with modifiers. Now I have edited the
wall cleanup in place, and after saving the in-place edit changes, there are
suddenly a number of new and unwanted spaces inside the walls. Where do
these spaces come from?
Extra spaces might be generated when walls with modifiers or wall cleanups
are edited in place. This is due to the calculation mechanism of the space
generation. If you encounter this case you should delete the unwanted spaces
from the drawing.

I have one room that contains multiple functional areas, which I want to
display and schedule independent from each other. There are however no
real-live boundary objects between them. Is there a way to separate a space
without adding boundary objects?

Use the Space Separator tool as described in The Space Separator Tool on page
2946.

When I try to generate a space from the outlines of walls, I get unexpected
space boundaries. How can I fix this?
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Generating spaces from object outlines can be useful for generating spaces
that are deducted from other spaces, like a mass element representing a shaft,
or walls that represent a construction space. A space generated from wall
outlines should look like this:

In some cases, the space generation may result in different and segmented
boundaries like this:

If this is the case, the maximum allowed gap size between boundary objects
is too big, and the end wall conditions between walls are not calculated
correctly. Recreate the space with a very small maximum gap size. For more
information, see Defining a Maximum Gap Size for Associative Spaces on page
2962.

When I update the boundary objects for associative spaces (for example, I
move a wall to a different position) the space does not update. In some
cases, it displays a solution tip icon, but in other cases just does not update.
How can I get the space to update?

The following factors can be responsible for spaces not updating:

1. The space is no longer associative

Verify that the Associative setting on the Properties palette is still set to Yes.
If it has been accidentally set to No, the space loses its associativity to the
boundary objects. The space no longer updates, but displays no solution tip
icon.

2. In the AEC Options, the Automatic update of associative spaces has been
disabled

You can choose to not automatically update associative spaces each time a
change in geometry occurs. This can be useful to improve performance. If the
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Automatically update associative spaces option on the AEC Object Settings
tab of the Options dialog has been cleared, then a space will not automatically
react to changes in the boundary objects. You can either reselect the automatic
update option, or, if you do not want to have automatic updates, you can
select the space, and click Space tab ➤ Modify panel ➤ Update

drop-down ➤ Selected Space  .

NOTE When you activate the automatic update of spaces, only those spaces will
be updated that had no boundary objects added while the update was off. For
example, if you add a dividing wall to a space while the automatic update is off,
and then turn the automatic update on, the space will not be divided by the wall.
You should then manually update the space. For more information, see Manually
Updating Associative Spaces on page 2966.

3. Grip-editing the boundary objects has introduced a new boundary object
for the space

If a grip-edit operation on the boundary objects has resulted in additional
boundary objects, the space will not automatically update to reflect this change,
but will display a solution tip icon. In that case, select the space and click

Space tab ➤ Modify panel ➤ Update drop-down ➤ Selected Space  .

4. The change in the boundary objects has invalidated the closed boundary

Verify that the change in the geometry has not accidentally opened up a gap
in the boundary objects. This could happen if you move a wall so that it no
longer intersects neighboring walls. It could also happen if a wall is moved
so that it intersects with another wall that is not defined as a boundary object
and is in the same cleanup group.

5. The visible drawing area has changed between creating and updating the
space

The Update Space Geometry command uses the current viewport’s zoom value.
This might lead to unexpected results, if you have zoomed in on the drawing
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area between generating and updating the space. Zoom out so that the space
and its boundary objects are entirely visible, and try to update again.

After trimming a part of a boundary object enclosed in a space (for example,
if you trim a part of a shaft,) the enclosed object is not recognized as a
boundary object anymore, and the surrounding space flows into it. What is
the reason and how can I fix this?
When trimming a boundary object by substituting a new boundary object in
the trimming position, the new object will not be recognized automatically
as boundary object for the space, because it did not bound the space previously.
In this case, you need to update the space manually to recognize the new
bounding object. See the following example:

I have updated an associative space. The base boundary updates correctly,
but the net, usable, and gross boundaries stay as they were before the
update. What causes that behavior?

If the net, usable, and gross boundaries of an associative space do not get
updated when the base boundary is updated after a change in the boundary
objects, the space uses manual boundary offsets.

Net, usable, and gross boundaries not updating
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Manual net, usable, and gross boundaries do not automatically react to changes
in the base boundary. To make the net, usable and gross boundaries update
automatically when the base boundary is updated, you need to define the
boundary offset of the space as By Style or By Standard on the Properties
palette.

I am using an area calculation standard to generate associative spaces.
Sometimes when generating or updating my spaces, I see solution tip icons
for which I cannot find a valid reason in the boundary objects. What is the
reason for this and how can I work around it?

A solution tip icon can appear when the area calculation standard is for some
reason unable to generate or update the space boundaries correctly. Install
the standard or support file as advised in the solution tip, or correct the
boundary offsets, by deactivating the area calculation standard and working
with manual offsets, as described in Defining the Boundary Offset Type of a
Space on page 3008. Then, grip-edit the incorrect boundaries so that they are
correct again. Note that you have to do this only for those spaces that display
that solution tip icon, not for all associative spaces based on the area
calculation standard. It is not recommended to switch back to the offset
boundary type By Standard after making the change, because as soon as the
space is updated again, the corrected boundaries will be overwritten with the
incorrect standard-based ones.

I have problems with incorrect offsets of the net, usable, and gross
boundaries of associative spaces when I use an area calculation standard to
generate them. What can be the reason?

There are a number of conditions under which the correct calculation of
boundary offsets for associative spaces does not work when using an area
calculation standard:

■ The space and its boundary objects have been mirrored. When associative
spaces are mirrored, they need to be updated manually to recalculate the
net, usable, and gross boundaries correctly. For instructions, see Manually
Updating Associative Spaces on page 2966.

■ Some boundary objects are arc walls. In some cases, the net, usable, and
gross boundaries of associative spaces are not calculated correctly when
the boundary objects include arc walls. If this happens, deactivate the rule
based offset calculation and set manual offsets, as described in Defining
the Boundary Offset Type of a Space on page 3008. Then, grip-edit the
incorrect boundaries so that they are correct again. It is not recommended
to switch back to the offset boundary type By Standard after making the
change, because as soon as the space is updated again, the corrected
boundaries will be overwritten with the incorrect standard-based ones.
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Some of my walls have sweeps and modifiers attached to them. When I try
to generate spaces from them, the space boundary ignores the sweeps and
modifiers and generates the space from the wall profiles. How can I get the
space generation to observe sweeps and modifiers?

To make the space generation include wall sweeps and wall modifiers into the
boundary of an associative space, the cut plane height of the wall with the
sweep or modifier must be set to 0. For more information, see Specifying the
Cut Plane Display of a Wall Style on page 1319.

When I turn on the automatic update of associative spaces, as described in
Activating and Deactivating Automatic Updates on page 2964, some of my
existing spaces suddenly display solution tip icons. How can I fix this?

When a solution tip icon appears after you have activated the automatic
update of associative spaces, the space and its boundary objects are
out-of-synch. Select the space with the solution tip icon showing, and click

Space tab ➤ Modify panel ➤ Update drop-down ➤ Selected Space  .

When I deselect the automatic update of associative spaces, and divide an
associative space with a new boundary object, as described in Dividing an
Associative Space on page 2969, the space will not be divided immediately.
This is according to my expectations. However, if I then activate the
automatic update of associative spaces, my space is not divided either. Is
this correct?
Boundary objects added while the automatic space update is turned off will
not be used to update spaces later when the setting is turned on again. Only
objects added or modified while the automatic update is turned on will be
used to update the spaces. If you encounter the situation above, delete the
wall and re-insert it with the automatic update turned on.

When I insert a scaled external reference with boundary objects into a
drawing, any associative spaces generated from the objects in the external
reference will not be correctly calculated when using an area calculation
standard. What I can I do to fix this?

Currently, when an external reference is scaled during insertion, the boundary
offset calculation will never be correct if the boundary offsets are calculated
by an area calculation standard. You can either re-insert the external reference
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without scaling, or you can change the boundary offsets from By Standard to
By Style or Manual and try to emulate the rules of the area calculation standard
in the style of by manually offsetting the boundaries.

Creating Non-Associative Spaces
Non-associative spaces are freestanding spaces with user-defined geometry.
You can either draw a space or convert linework, object outlines, mass
elements, or slabs to spaces, which you can then modify according to your
needs.

Drawing a Non-Associative 2D or Extruded 3D Space
When you draw a non-associative 2D or extruded 3D space, you can either
base it on target dimensions taken from the space style, or you can draw
rectangular or polygonal spaces with dimensions that you define.

Inserting a Space with Style-Defined Target Dimensions
Use this procedure to insert a non-associative space based on target dimensions
set in the space style. For information about setting target dimensions in the
space style, see Specifying Target Dimensions for the Space on page 3095.

1 Open the tool palette that contains the Space tool you want to
use, and select it.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Space

drop-down ➤ Space  .

2 On the Properties palette, for Create type, select Insert.

NOTE For spaces with the Create type of Insert, Rectangle, or
Polygon, the Associative setting is always No.

3 Expand Component Dimensions.

4 Specify the geometry type of the new space:

Then…If you want to…

select 2D from the list.create a 2D space
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Then…If you want to…

select Extrusion from the list.create an extruded 3D
space

5 Expand Actual Dimensions.

6 To specify the geometry of the space within the boundaries of the
target dimensions on screen, select Yes for Specify on screen.

To specify the geometry of the space by entering values in the
Properties palette, select No for Specify on Screen.

7 Specify which dimension of the space is to be constrained during
insertion:

Then…If you want to…

select Area for Constrain. This lets you
change the length and width of the

fix the space area value during
insertion

space, but only within the range of the
target dimensions. For example, if you
constrain the area to 9m2, you can still
choose to make both length and width
3m, or to make the length 4m, and the
width 2.25 meters, as both combina-
tions result in an area of 9 m2.

select Length for Constrain. If you con-
strain the length of a space, then any

fix the space length during in-
sertion

change to the space area will only
change the width dimension of the
space, and vice versa.

select Width for Constrain. If you con-
strain the width of a space, then any

fix the space width during in-
sertion

change to the space area will only
change the length dimension of the
space, and vice versa.

select *NONE* for Constrain. In this case
no individual dimension is constrained,

do not fix a specific dimension
during insertion

and you can specify any geometry as
long as it is within the target dimen-
sions.
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8 If you have selected to not specify the space on screen, enter values
for the non-constrained dimensions for Base Area, Length, and
Width.

9 Insert spaces in the drawing:

Then…If…

click in the drawing to define the
insertion point of the space. Then

you have selected to specify the
space on screen,

drag and click to define the space
dimension, and specify a rotation.

click in the drawing to define the
insertion point of the space, and
then specify a rotation.

you have entered values for the
space geometry in the Properties
palette

10 Continue adding spaces, and press ENTER.

IMPORTANT For descriptions of other Spaces settings on the
Properties palette, see Space Properties on page 2933.

Drawing a Rectangular Space
Use this procedure to draw a non-associative rectangular 2D or extruded 3D
space.

1 Open the tool palette that contains the Space tool you want to
use, and select it.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Space

drop-down ➤ Space  .

2 On the Properties palette, expand Basic, and expand General.

3 For Create type, select Rectangle.

NOTE For spaces with the Create type of Insert, Rectangle, or
Polygon, the Associative setting is always No.

4 Expand Component Dimensions.
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5 Specify the geometry type of the new space:

Then…If you want to…

select 2D from the list.create a 2D space

select Extrusion from the list.create an extruded 3D
space

6 In the drawing area, specify the start point of the space, and drag
and click to define the opposite corner.

7 Continue adding spaces, and press ENTER.

IMPORTANT For descriptions of other Spaces settings on the
Properties palette, see Space Properties on page 2933.

Drawing a Polygonal Space
Use this procedure to draw a non-associative polygonal 2D or extruded 3D
space. A polygonal space is composed of line and arc segments and can be
used to represent non-rectangular rooms.

1 Open the tool palette that contains the Space tool you want to
use, and select it.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Space

drop-down ➤ Space  .

2 On the Properties palette, for Create type, select Polygon.

NOTE For spaces with the Create type of Insert, Rectangle, or
Polygon, the Associative setting is always No.

3 For Segment type, select if the first space segment should be a line
or an arc.

4 Expand Component Dimensions.

5 Specify the geometry type of the new space:

Then…If you want to…

select 2D from the list.create a 2D space
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Then…If you want to…

select Extrusion from the list.create an extruded 3D
space

6 If you have selected Line for Segment type, specify the start and
end point of the first linear segment on screen.

7 If you have selected Arc for Segment type, specify the start point,
a point on the arc, and the endpoint of the segment on screen.

8 Proceed with adding segments for the space.

By default, for each new segment the segment type of the previous
segment is used. If necessary, you can change the segment type
in the Properties palette.

9 Close the space and press ENTER.

IMPORTANT For descriptions of other Spaces settings on the
Properties palette, see Space Properties on page 2933.

Converting Objects, Profiles, and Polylines to Non-Associative
Spaces

Various objects can be converted to non-associative spaces. If you are
converting a non-extruded mass element, you can convert its geometry to a
3D freeform space. If you are converting other AEC objects or polylines, the
2D profile of the object or polyline is converted to a 2D space or an extruded
3D space.

Converting Mass Elements to Spaces
Use this procedure to convert a mass element to a space.

Converting a Mass Element to a 3D Freeform Space

When you convert a non-extrusion type mass element to a space, it is created
as a 3D freeform space, unless the space tool you use has its geometry type
set expressly to Extrusion. Non-extrusion type mass elements include:

■ Arch
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■ Barrel Vault

■ Isosceles Triangle

■ Right Triangle

■ Pyramid

■ Cone

■ Dome

■ Sphere

■ Gable

■ Freeform

Converting a Mass Element to an Extruded 3D Space

When you convert an extrusion type mass element to a space, it is created as
an extruded 3D space. Non-extrusion type mass elements include:

Mass elements that can be converted to an extruded 3D space include:

■ Box

■ Cylinder

■ Extrusion
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NOTE To make sure that the converted space uses the mass element geometry,
verify that the space tool used has its geometry type set to Undefined (--). If it is
set to Extrusion, a mass element is converted based on its profile shape and
extruded from that. A non-extruded mass element shape, like for example a
pyramid, will be converted to an extruded box shape with the pyramid profile.

1 Select the mass element that you want to convert to a space.

2 Click Mass Element tab ➤ Convert To panel ➤ Space  .

3 When prompted to erase the original geometry, press ENTER to
keep the mass element or enter y (Yes) to erase it.

4 Edit the properties of the space in the Properties palette as needed.

Converting Mass Groups to Spaces
Use this procedure to convert a mass group to a space.

IMPORTANT If the mass group contains multiple mass elements that do not
intersect, one space with multiple profiles will be created. In most cases, this is
not the desired result, so it is recommended that you disconnect each mass element
from the mass group first, and convert it individually.

1 Select the mass group that you want to convert to a space.

2 Click Mass Group tab ➤ Convert To panel ➤ Space  .

3 When prompted to erase the original geometry, press ENTER to
keep the mass group or enter y (Yes) to erase it.

4 Edit the properties of the space in the Properties palette as needed.

Converting Polylines, Profiles, and Object Outlines to Spaces
Use this procedure to convert polylines or 2D profiles of objects to spaces.
This can be useful for defining construction spaces that usually consist of the
outlines of walls, columns, stairs, and other building objects.

The new space generated from the profile of the object will be created with
the properties defined in the space tool. If a specific setting has been set to
Undefined (--) in the space tool properties or cannot be set in the tool
properties, the last used setting on the Properties palette will be used.
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You can use the following object outlines as space boundaries:

■ Walls/Curtain walls

■ Columns/Braces/Beams/Slabs

■ Doors/Windows/Window assemblies

■ Roofs/Roof slabs/Slabs

■ Stairs/Railings

■ Mass elements/Mass groups

■ AEC polygons

■ Profiles

■ Closed polylines

Column objects (left), converted to spaces (right)

1 Open the tool palette that contains the Space tool you want to
use, and select it.

(You may have to scroll to display the desired tool.)

2 Right-click a space tool, and click Apply Tool Properties to  ➤ 

Linework and Aec objects.

3 Select the objects and closed polylines to convert, and press ENTER.

4 In the Convert to Space worksheet, under Cut Plane Height, the
height at which the object should be cut to generate the profile
of the new space.

5 If you want to erase the underlying object, select Erase Layout
Geometry. To keep the object in the drawing, verify that the
option is cleared.
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6 If you want to define the cut plane height on screen, select Specify
on Screen.

7 Click OK.

8 If necessary, select the cut plane height in the drawing.

Creating a Space Tool
Use this procedure to create a space tool add it to a tool palette. You may want
to create your own tools if you frequently place multiple spaces of specific
styles that have the same properties.

For example, you might create an office plan with spaces for cubicles. Although
all cubicles use the same space style in your floor plan, the cubicle walls in
administrative areas are lower than the walls in office areas. To work efficiently,
you can create a space tool for each space height. You can then select the
appropriate tool to place the cubicles with the correct height in each area of
the floor plan.

TIP Space tools can be created for associative and non-associative spaces. When
a tool for associative spaces is started, the initial processing of valid boundaries in
the drawing can be a lengthy process, depending on the size of the model.
Therefore, it is recommended to clearly name your space tools regards to their
associativity.

1 Open the tool palette where you want to create a tool.

2 Create the tool:

Then…If you want to…

select the space, and drag it to the
tool palette.

create a tool from a space in the
drawing

click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from a space style in
the Style Manager

the style you want to copy, and
drag it to the tool palette. Click OK
to close the Style Manager.

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette
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Then…If you want to…

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the palette where you want
to add the tool, right-click, and click
Paste.

click Home tab ➤ Build pan-

el ➤ Tools drop-down ➤ Content

copy a tool from a tool catalog

Browser  , and locate the tool
you want to copy. Position the
cursor over the i-drop handle, and
drag the tool to the tool palette.

3 Right-click the new tool, and click Properties.

Defining general tool properties

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

6 To add keywords to the tool, click More Info.

7 Expand Basic, and expand General.

8 Click the setting for Description, enter a description displayed for
all spaces created from this tool, and click OK.

9 If you do not want to use the layer assignments specified in the
layer key style used in the drawing, specify a layer key and any
layer key overrides.

10 Select a space style.

11 Select the drawing file containing the style used for this space
tool.

12 Enter a name for spaces inserted with the tool.

13 Select a space tag.

14 Select the drawing file containing the tag used for this space tool.
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NOTE The Associative property is interlinked with the Create type.
If the Create type is Generate, the Associative setting can be edited.
You can use the default setting of Undefined (--). If the Create type
is Insert, Rectangle, or Polygon, the Associative setting defaults to
Undefined (--) and becomes read-only.

15 For Offset boundaries, select how the 4 space boundaries (base,
net, usable, and gross boundary) are calculated. For information
about space boundaries, see Working with Space Boundaries on
page 3004.

■ Manual: The net, usable, and gross boundaries can be manually
edited with grips.

■ By style: The net, usable, and gross boundaries are offset from
the base boundary by a value defined in the space style. For
more information, see Specifying Space Boundary Offsets in
a Space Style on page 3096.

■ By standard <Standard Name> (associative spaces only): The
net, usable, and gross boundaries are defined by the area
calculation standard listed. For more information, see
Specifying an Area Calculation Standard for a Drawing on page
3010.

16 Select the Create type of the space. You can choose one of these
options:

■ Insert: Inserts a space according to the target dimensions in
the space style.

■ Rectangle: Inserts a rectangular space with user-defined length
and width.

■ Polygon: Inserts a polygonal space with user-defined segments.

■ Generate: Inserts a space associative to boundary objects.

17 If you selected Polygon for Create type, define the shape of the
first space segment for Segment Type.

You can select a line or an arc segment.

Defining settings for associative spaces

18 If you need to generate spaces within boundaries that already
contain a space, select Yes for Allow overlapping spaces.
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By default, you cannot generate a new space in a boundary that
already contains an existing space. However, a situation can arise
where you want to establish an interference between 2 spaces and
therefore need to generate a space within a boundary that already
contains a space.

Defining the geometry type of the space

19 Expand Component Dimensions.

20 Specify the geometry type of the space tool:

Then…If you want to…

select 2D from the list.create a 2D space tool

select Extrusion from the list.create an extruded 3D
space tool

select Freeform from the list.create an associative 3D
freeform space tool (asso-
ciative spaces only)

select Undefined (--) from the list.create multiple space
types with the tool

Defining the space height in the space tool

21 If you are creating a space tool for a 3D space, you can enter
parameters for the space height.

NOTE If you want to create spaces of different heights with this tool,
you can leave all the settings as Undefined (--).

Then…If you want to…

enter a value for Overall space height.specify the overall height of the
space, including floor to ceiling
height, ceiling and floor thick-
ness, and space above ceiling and
below floor

enter a height value.specify the ceiling height of the
space
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Then…If you want to…

enter a value for Floor thickness.specify a floor thickness

enter a value for Ceiling thickness.specify a ceiling thickness

enter the appropriate value for Height
above ceiling.

specify the distance between the
top of the space ceiling to the
top of the space

enter the appropriate value for Height
below floor.

specify the distance between the
bottom of the space floor and the
bottom of the space

enter a value for Default surface
height.

specify the combined height of
ceiling height, ceiling thickness,
and height above ceiling

22 Select one of the following options for Justification to specify the
vertical position of the space insertion point relative to the space:

■ Top of floor

■ Bottom of floor

■ Bottom of space below floor (available only if the height of
the space below the floor is bigger than 0.)

Defining target dimensions in the space tool

23 Expand Actual Dimensions.

NOTE The settings for target dimensions of a space are visible only
if you have selected Insert as the Create type. Rectangular and
polygonal spaces do not observe target dimensions. The range of
values allowed here depends on the target dimensions defined in the
space style.

24 To specify the geometry of the space within the boundaries of the
target dimensions on screen, select Yes for Specify on Screen.

To specify the geometry of the space by entering values in the
Properties palette, select No for Specify on Screen.
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25 Specify which dimension of the space should be constrained
during insertion:

Then…If you want to…

select Area for Constrain. This lets you
change the length and width of the

fix the area value during inser-
tion

space, but only within the range of the
target dimensions. For example, if you
constrain the area to 9m2, you can still
choose to make both length and width
3m, or to make the length 4m, and the
width 2.25 meters, as both combina-
tions result in an area of 9 m2.

select Length for Constrain. If you con-
strain the length of a space, then any

fix the length during insertion

change to the space area will only
change the width dimension of the
space, and vice versa.

select Width for Constrain. If you con-
strain the width of a space, then any

fix the width during insertion

change to the space area will only
change the length dimension of the
space, and vice versa.

select *NONE* for Constrain. In this case
no individual dimension is constrained,

do not fix a specific dimension
during insertion

and you can specify any geometry as
long as it is within the target dimen-
sions.

26 If you selected No for Specify on screen, enter values for the
non-constrained dimensions for Base Area, Length, and Width.

27 If you have selected to generate a 3D freeform space, define the
2 calculation cut planes under Advanced Dimensions.

28 Click OK.

Editing General Space Properties
These general properties of a space can be edited for all space types:
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Renaming a Space
Use this procedure to rename a space.

1 Double-click the space you want to rename.

2 On the Properties palette, expand Basic, and expand General.

3 For Name, do one of the following:

■ If a list definition has been attached to the space style, select
a name from the list.

■ If no list definition has been attached to the space style, enter
a name in the Name field.
For more information, see List Definitions on page 3109.

Changing the Style of a Space
Use this procedure to assign a different space style to a space. The space style
defines the list definition used, boundary offsets, and the display properties
of the space. For more information, see Space Styles on page 3093.

1 Double-click the space you want to change.

2 On the Properties palette, select a new style for Style.

When you change the space style, and the new space style has a different list
definition in which the existing space name is not contained, it is possible
that the existing space name is deleted and the space name defaults to the
first name in the new list definition.

For more information, see List Definitions on page 3109.

Changing the Location of a Space
Use this procedure to relocate a space by changing the coordinate values of
its insertion point. The space also has an orientation with respect to the world
coordinate system (WCS) or the current user coordinate system (UCS). For
example, if the top and bottom of the space are parallel to the XY plane, its
normal is parallel to the Z axis. You can change the orientation of the space
by aligning its normal with another axis. You can also rotate the space on its
plane by changing the rotation angle.

NOTE This procedure is valid only for non-associative spaces. The location of an
associative space is determined by its boundary objects.
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For information about moving individual space boundaries, see Changing the
Location of a Space Boundary on page 3025.

For more information about the WCS and the UCS, see “Use Coordinates and
Coordinate Systems” in AutoCAD Help.

1 Double-click the space you want to change.

2 On the Properties palette, expand Basic, and expand Location.

3 Click Additional information.

4 On the Location worksheet, specify the location of the space:

Then…If you want to…

enter new coordinate values for In-
sertion Point.

relocate the space

make the normal of the space paral-
lel to the Z axis: for Normal, enter
1 for Z, and enter 0 for X and Y.

locate the space on the XY plane

make the normal of the space paral-
lel to the X axis: for Normal, enter
1 for X and enter 0 for Y and Z.

locate the space on the YZ plane

make the normal of the space paral-
lel to the Y axis: for Normal, enter
1 for Y, and enter 0 for X and Z.

locate the space on the XZ plane

enter a new value for Rotation
Angle.

change the rotation of the space

5 Click OK.

Specifying the Decomposition Type for a Space
Use this procedure to specify the type of subentities into which a space is
decomposed and the type of AutoCAD entities into which the decomposed
space is converted when exploded.

1 Double-click the decomposed space.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.
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4 For Display controlled by, select This object.

NOTE To apply your changes to all space decompositions in the
drawing, select Drawing default setting. To apply changes to all space
decompositions of this style, select Space Style:<style name>. For
more information on styles, see Space Styles on page 3093.

5 For Display representation, verify that Decomposed is selected.

6 If necessary, expand Object Display Properties ➤ Advanced.

7 Click  Decomposition.

8 Under Decomposition Type, select an option for Type:

Then…If you want to…

select Trapezoid.display a trapezoid decomposition

select Triangle.display a triangular decomposition
without overlapping triangles

select Triangle (overlap).display a triangular decomposition
with overlapping triangles

9 Under Explode Result, select an option:

Then…If you want to…

select Lines.change the decomposed space into
single lines after exploding
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Then…If you want to…

select Faces.change the decomposed space into
closed polylines for each decom-
posed part

10 Click OK.

You can also access these option through the decomposed space’s context
menu, as follows:

1 Select the decomposition, right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 In the Display Properties dialog, click the Decomposition tab, and
then specify the options that you want.

5 Click OK twice.

Specifying the Decomposition Text Properties for a Space
Use this procedure to specify the text properties for the tags and edge
dimensions displayed for subentities in a space decomposition.

1 Double-click the decomposed space.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all space decompositions in the
drawing, select Drawing default setting. To apply changes to all space
decompositions of this style, select Space Style:<style name>. For
more information on styles, see Space Styles on page 3093.

5 For Display representation, verify that Decomposed is selected.

6 If necessary, expand Object Display Properties ➤ Advanced.
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7 Click  Proof.

8 Under Tag Display, define the prefix settings:

Then…If you want to…

enter a prefix.display a prefix for the numbers of
the space subdivisions

either select a text style from the
list or click the Browse button and

change the style of the numbers of
the space subdivisions

create a new text style. For more
information, see “Text Style Dialog
Box” in AutoCAD Help.

enter a value for Height.change the height of the numbers
in the space subdivisions

9 Under Display of Dimensions, define the edge dimension settings:

Then…If you want to…

either select a text style from the
list or click the Browse button and

change the style of the edge dimen-
sions

create a new text style. For more
information, see “Text Style Dialog
Box” in AutoCAD Help.
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Then…If you want to…

enter a value for Height.change the height of the edge di-
mensions

10 Click OK.

You can also access these option through the decomposed space’s context
menu, as follows:

1 Select the decomposition, right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 In the Display Properties dialog, click the Proof tab, and then
specify these options as desired.

5 Click OK twice.

Specifying the Cut Plane Display of a Space
Use this procedure to specify the properties of one or more cut planes for an
individual space. Cut plane display properties apply only to display
representations, such as Plan, that are used in the Top view (plan view) of a
drawing.

1 Double-click the space you want to change.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all spaces in the drawing, select
Drawing default setting. To apply changes to all spaces of this style,
select Space Style:<style name>. For more information on styles, see
Space Styles on page 3093.

5 If necessary, expand Object Display Properties ➤ Cut Plane.
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6 For Override cut plane, specify whether you want to override the
global cut plane defined for the current display configuration.

7 If you selected Yes for Override cut plane, enter a value for Height
to define the cut plane for this object. (Alternatively, you can click

the value, click  , and specify 2 points in the drawing area to
define the new height.)

You can also access and modify these same cut plane settings through the
space’s context menu, as follows:

1 Select the space you want to change, right-click, and click Edit
Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 In the Display Properties dialog, click the Cut Plane tab, and then
change the settings as needed.

5 Click OK twice.

Attaching Hyperlinks, Notes, or Files to a Space
Use this procedure to attach hyperlinks, notes, or files to a space. You can also
edit hyperlinks and notes, and edit or detach reference files from a space.

1 Double-click the space to which you want to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

4 Click OK.

5 To add a note, click the setting for Notes, and enter the note.

6 Click OK.

7 To add a reference file, click the setting for Reference documents,
and attach, edit, or detach a reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file
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Then…If you want to…

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

8 Click OK twice.

Working with Space Boundaries
Spaces have 4 different boundaries. You can use them to display, edit, and
schedule different aspects of the space. You can choose that these boundaries
are not offset from each other, and lie on top of each other. If you do not
need different boundaries, you can even turn off the display components for
the additional boundaries. Here are some typical use cases for using individual
boundaries:

■ Base boundary: Normally representing the inner area of a room covered
by a space. This is the area generated by boundary objects in an associative
space. In most cases, the base boundary is identical to the net boundary,
except in some area calculation standards like the Swedish SIS standard.

■ Net boundary: This boundary can be used for planning and detailed design.
For example, if you need to determine the hiring of cleaning personnel
for an office, you would use the net area as the calculation basis. The net
boundary can also be used for special applications when the calculated
area of a space is smaller than the base boundary.

■ Usable boundary: This boundary is in many area calculation standards
used for planning and detailed design, renting calculations, tax and other
duty calculations, statistical calculations, maintenance, pricing, and more.
The usable boundaries typically extend from the inside of the exterior walls
to the middle of the interior walls (or a specified distance into the interior
walls).

■ Gross boundary: the gross boundary can be used in connection with cost
calculation, price estimation, calculation of tax and other duties, key
numbers for the building or a specific floor, and more. Normally, the gross
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boundary is measured from the outside of the exterior walls to the middle
of the interior walls.

There are different ways to determine how the boundaries should be offset
from each other and calculated:

■ Manual

■ By style

■ By area calculation standard

Working with Manual Boundaries
You can define the boundaries of a space manually. Manual boundaries have
grips to edit the boundary shape of each boundary. If you insert a new space
with manual boundaries, by default the offsets between the boundaries are 0.
To grip-edit manual boundaries, you first must activate the boundaries
(Activating Manual Space Boundaries on page 3015) and then grip edit them
(Grip-Editing Space Boundaries on page 3017.)
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Grip-editable manual boundaries

In a non-associative space with manual boundaries all 4 boundaries are
grip-editable. In an associative space with manual boundaries, the net, usable,
and gross boundaries are editable. The base boundary of an associative space
is controlled by the boundary objects.

Working with Style-Based Boundaries
You can define the offsets between space boundaries in the space style
(Specifying Space Boundary Offsets in a Space Style on page 3096.) In a
non-associative space with style-based boundary offsets, you can grip-edit the
base boundary only; the net, usable, and gross boundary are controlled by the
style. In an associative space with style-based offsets, you cannot grip-edit any
boundary. The base boundary is controlled by the boundary objects of the
space, and the net, usable, and gross boundaries are controlled by the style.

Working with Boundaries Based on an Area Calculation Standard
You can define the boundaries of a space by an area calculation standard
specified in the drawing. The area calculation standard may consider the
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space's type, classification, location, and relation to other spaces when
calculating the space's boundaries. For example if a room is bounded by an
exterior wall, the area calculation standard may place the gross boundary of
the space at the outside of the exterior wall. If a room is bounded by an interior
wall, the area calculation standard may place the net boundary at the middle
of the interior wall. In many cases, spaces need to be classified to have their
offsets calculated correctly. For example, if a space is classified as Office Area
using the BOMA area calculation standard, then its usable boundary is
measured to the inside face of the wall if the adjacent space is classified as
Common Floor Area. If the adjacent space is also classified as Office Area, the
usable boundary is measured to the centerline of the wall.

To use an area calculation standard, you need to define it for your drawing,
as described in Specifying an Area Calculation Standard for a Drawing on page
3010. For some standards you also need to classify spaces, as described in
Classifying a Space According to an Area Calculation Standard on page 3011.

Standards shipped with AutoCAD Architecture include a general Basic standard,
DIN-277, BOMA, and SIS. For more information, see Appendix 2: Predefined
Area Calculation Standards on page 3201.

Only associative spaces may have their boundaries calculated by an area
calculation standard. In a space with standard-based offsets, you cannot
grip-edit any boundary. The base boundary is controlled by the boundary

Working with Boundaries Based on an Area Calculation Standard | 3007



objects of the space, and the net, usable, and gross boundaries are controlled
by the area calculation standard.

Defining the Boundary Offset Type of a Space
Use this procedure to define how the boundaries of a space are offset. You can
set the boundary offset type while creating a space or you can select an existing
space and change the existing offset type.

For non-associative spaces, you can select manual and style-based offsets. For
associative spaces, you can select manual, style-based, and calculation
standard-based offsets.

Defining the boundary offset type of a new space

1 Select a space tool to create a space.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Space

drop-down ➤ Space  .

2 In the Properties palette, under Offset boundaries, select one of
these boundary offset types:

■ Manual
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■ By Style

■ By Standard

3 Proceed with creating the space as described in Creating
Non-Associative Spaces on page 2983.

Changing the boundary offset type of an existing space

1 Select the space where you want to change the boundary
calculation.

2 In the Properties palette, under Offset boundaries, select the
desired boundary offset type.

Depending on which type you choose, the boundaries can react
in different ways:

EffectSwitch
to

Switch
from

Associativ-
ity

The net, usable, and gross
boundaries are re-calculated ac-

By StyleManualNon-asso-
ciative

cording to the style offsets, and
become non-editable. The base
boundary remains unchanged and
editable.

The net, usable, and gross
boundaries keep their offsets but

ManualBy StyleNon-asso-
ciative

become editable. The base
boundary remains unchanged and
editable.

The boundaries are re-calculated
according to the style offsets, and

By StyleManualAssociative

become non-editable. The base
boundary remains unchanged and
non-editable.

The boundaries are re-calculated
according to the rules in the area

By Stand-
ard

ManualAssociative

calculation standard, and become
non-editable. The base boundary
remains unchanged and non-edit-
able.
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EffectSwitch
to

Switch
from

Associativ-
ity

The net, usable, and gross
boundaries keep their offsets but

ManualBy StyleAssociative

become editable. The base
boundary remains unchanged and
non-editable.

The net, usable, and gross
boundaries are re-calculated ac-

By Stand-
ard

By StyleAssociative

cording to the rules in the area
calculation standard. All boundar-
ies remain non-editable.

The net, usable, and gross
boundaries keep their offsets but

ManualBy Stand-
ard

Associative

become editable. The base
boundary remains unchanged and
non-editable.

The net, usable, and gross
boundaries are re-calculated ac-

By StyleBy Stand-
ard

Associative

cording to the offsets defined in
the space style. All boundaries re-
main non-editable.

Specifying an Area Calculation Standard for a Drawing
Use this procedure to specify an area calculation standard for a drawing. The
standard defines the calculation of the individual boundaries according to the
rules of the chosen standard.

AutoCAD Architecture ships with a number of predefined area calculation
standards based on the rules of these country-specific standards:

■ BOMA standard (USA)

■ DIN-277 standard (Germany)

■ SIS standard (Sweden)

■ Basic standard (Generic standard)
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NOTE An area calculation standard can be used only for associative spaces. The
boundaries of non-associative spaces can only be calculated in the space style or
modified manually.

1 Click  ➤ Options.

2 Click the AEC Object Settings tab.

3 For Calculation Standard, select the area calculation standard you
want to use when generating spaces from your floor plan.

4 Click OK.

TIP Alternatively, you can set the area calculation standard on the
command line by entering AecSpaceCalculationStandard.

Classifying a Space According to an Area Calculation Standard
If you have generated a space that has its boundaries calculated by an area
calculation standard, you may need to classify the space according to the
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selected standard, in order to provide the standard with the necessary
information to calculate the boundaries. For example, the BOMA standard
requires classifying spaces according to their space type, as the space type is
relevant for determining boundary offsets.

1 Select a space that has its boundary calculation defined by an area
calculation standard.

2 On the Properties palette, click the Extended Data tab.

3 For Classification, the classification definition belonging to the
area calculation standard defined for this drawing is displayed.

For example, if you have selected the BOMA area calculation
standard for your drawing, the BOMA classification definition is
displayed.

4 Click the setting for the required classification type, and select a
classification in the Select Classification worksheet.

5 Click OK.

Changing the Area Calculation Standard for Existing Spaces
If you have created a number of spaces in your drawing with an area calculation
standard, and then change the area calculation standard for the drawing, the
spaces get recalculated according to the rules of the new standard. The
classification definition for the new area calculation standard is inserted in
the drawing, but the space might need to get re-classified according to the
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new standard. For example, if you calculate your spaces according to the SIS
standard, and classify a space as “Shaft”, and then re-calculate the spaces
according to the BOMA standard, then the initial BOMA classification is set
to “Unspecified.” You need to select a corresponding BOMA classification,
like for example “Major Vertical Penetration.”

For more information, see Specifying an Area Calculation Standard for a
Drawing on page 3010 and Classifying a Space According to an Area Calculation
Standard on page 3011.

When a new area calculation standard is selected for the drawing, the
classification definition for the previously used standard is not removed, but
remains in the drawing. This can be helpful if you need to switch back and
forth between different standards, and do not want to lose the classifications
of the currently not active standard every time you switch.

If you know that you will not be using a certain standard anymore, you can
delete its classification definition from Style Manager. To delete a classification
definition, it must not be referenced by any objects. To remove the references
to the classification standard, change all spaces that use a classification from
this definition to *Unspecified*.

Working with Drawings with Different Area Calculation
Standards

When you exchange drawings that contain spaces with boundary offsets
calculated by an area calculation standard, the recipient of the drawing must
have the same area calculation standard available in their version of AutoCAD
Architecture. If you try to open the drawing in a version of AutoCAD
Architecture where you cannot select that standard in the AEC Options page
- meaning that this standard is not installed - all spaces will be drawn with a
solution tip icon. To remedy this, copy the DLL for the necessary standard
into \\Autodesk AutoCAD Architecture 2012\Space Calculation Standards\ folder.
In AutoCAD Architecture DLLs for these 4 standards are included: Basic, BOMA,
SIS, and DIN-277. The Basic standard is located directly in the application
folder and should not be moved or deleted.

If you are working with spaces in external references, each space will use the
boundary offsets and area calculation standard defined in its containing
drawing. This can cause different boundary offsets to be used across a project,
so you should verify that each drawing uses the same boundary offsets and
area calculation standard.
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User-Defined Area Calculation Standards
Each area calculation standard is written in a separate module using .NET.
Each .NET module includes the space calculation method as well as generating
the space classification. In AutoCAD Architecture there are 4 standards
included: Basic, BOMA, SIS, and DIN-277. The .NET modules for BOMA, SIS,
and SIN are in the folder \\AutoCAD Architecture 2012\Space Calculation Standards\
. The Basic standard .NET module is located directly in the application folder
and should not be moved or deleted. Users can create and use their own
standards. For more information, see Appendix 3: Implementing an Area
Calculation Standard Plug-in with the AutoCAD Architecture .NET API on
page 3217.

Editing Space Boundaries
Spaces have 4 boundaries.

Depending on which type of space you have created and which boundary
offset type you use, different boundaries can be edited with grips:

Editable BoundariesBoundary Offset TypeSpace Type

Net, Usable, GrossManualAssociative

NoneBy StyleAssociative

Base, Net, Usable, GrossManualNon-Associative 2D or
extruded 3D

BaseBy StyleNon-Associative 2D or
extruded 3D

Net, Usable, GrossManualNon-Associative 3D
Freeform

NoneBy StyleNon-Associative 3D
Freeform

IMPORTANT The net, usable, and gross boundaries of a space can only be
displayed in plan views. In model views, only the base boundary and the base
body of the space are displayed.
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Editable boundaries of a space with manual offsets

Displaying Space Boundaries
By default, only the base boundary of a space is displayed. If you want to
display or edit the net, usable, and gross boundaries, you need to make their
display components visible.

For instructions on how to display the additional space boundaries in the
space style, see Specifying the Display Properties of a Space Style on page 3101.

Activating Manual Space Boundaries
After making the net, usable, and gross boundaries visible, you need to activate
them in order to be able to grip-edit them.
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NOTE Activating a boundary is a precondition for any operation you want to
perform on the boundary, like grip-editing or boolean operations.

1 If necessary, switch to a Plan view.

The net, usable, and gross boundaries of a space can only be
activated and displayed in Plan views.

2 Select a space for which you want to display a boundary.

Activated boundary grips

3 Verify that Offset Boundaries in the Properties palette is set to
Manual.

4 Use the trigger grip for the appropriate boundary to activate and
deactivate the grip set.

Alternatively, you can right-click a space, click Edit Boundary on
the context menu, and then select a boundary from the submenu
to activate or deactivate.
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Grip-Editing Space Boundaries
Use this procedure to edit a space using grips.

The Edge grip has 4 edit modes:

■ Offset: This is the default. Use it to offset the selected edge in a direction
perpendicular to the midpoint of the edge. Depending on the shape of the
boundary and the edge, neighboring lines are extended or trimmed, and
new lines are added as necessary.
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Offsetting the edge of a space boundary using the Edge grip

■ Add Vertex: Use this edit mode to add a vertex to the selected edge, and
create a new edge. If the selected edge is an arc, the new edge is also an
arc.
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Adding a vertex to the edge of a space boundary using the Edge grip

■ Convert to Arc: Use this edit mode to convert the selected edge to an arc
and stretch the midpoint of the arc. The edge grip for an arc also has a
Stretch mode. You can use it to stretch the midpoint of the arc, thus
increasing the size of the arc.
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Converting the edge of a space boundary to an arc using the Edge grip

■ Offset all: Use this option to move all edges of a space boundary an identical
distance. When you drag one edge, all other edges are repositioned
accordingly. This option is very useful for regular resizing operations, like
scaling a space boundary.
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Offsetting all edges of a space boundary using the Edge grip

Changing the edge of a space boundary

1 Activate the boundary where you want to change an edge.

2 Select the Edge grip for the edge you want to change.

3 Specify the new edge location:

Then…If you want to…

move the edge to the desired loca-
tion and click, or enter a value and
press ENTER.

offset the edge
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Then…If you want to…

press CTRL to switch to the Add
Vertex edit mode. Move the edge

add a vertex and create an edge

to the desired location and click, or
enter a value and press ENTER.

press CTRL twice to switch to the
Convert to Arc/Convert to Line edit

change a selected edge to an
arc/change a selected arc to a line

mode. Stretch the midpoint to the
desired location and click, or enter
a value and press ENTER.

press CTRL 3 times to switch to the
Offset All edit mode. Move the selec-

offset all edges at an identical dis-
tance

ted edge to the desired location for
all edges and click, or enter a value
and press ENTER.

4 Right-click, and click Deselect All to turn off grips.

Changing the vertex of a space boundary

1 Activate the boundary where you want to change a vertex.

2 Select the Vertex grip for the vertex you want to change.

The Vertex grip has 3 edit modes:

■ Move: This is the default. Use it to move the selected vertex
in any direction. The neighboring segments are stretched if
necessary.
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Moving the vertex of a space boundary using the Vertex grip

■ Remove: Use this edit mode to remove a vertex. The
neighboring segments are replaced with a line.

Removing the vertex of a space boundary using the Vertex grip

■ Offset Edges: Use this edit mode to move a vertex and the
adjacent edges of the space boundary with it.
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Offsetting edges of a space boundary using the Vertex grip

3 Edit the vertex as necessary:

Then…If you want to…

move the vertex to the desired loca-
tion and click; or enter a value, and
press ENTER.

move the vertex

press CTRL to switch to the Remove
Vertex edit mode, and click to con-
firm the removal.

remove the vertex

press CTRL twice to switch to the
Offset Edges edit mode. Move the

move the vertex and the adjacent
edges

vertex to the desired location, and
click; or enter a value, and press
ENTER.

4 Right-click, and click Deselect All to turn off grips.

Resetting Manual Space Boundaries
Use this procedure to cancel all changes made by grip-editing the net, usable,
or gross boundaries of a space. The boundaries will revert back to the geometry
of the base boundary.

1 Select the space the boundaries of which you want to reset.
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2 Click Space tab ➤ Boundary panel ➤ Reset All  .

Changing the Location of a Space Boundary
Use this procedure to move an individual space boundary to a different location
with grips. You can move individual boundaries only if you have selected
Manual for Offset boundaries.

For associative spaces, only the net, usable, and gross boundaries can be moved.
The base boundary is tied to the boundary objects.

For information about moving a space with the location worksheet, see
Changing the Location of a Space on page 2997.

1 Select the space for which you want to move an individual
boundary.

2 Move a boundary as necessary:

Then…If you want to…

move space to the desired location
and click to release it.

move the entire space

click and hold the location grip, and
press CTRL to switch to Move base

move the base boundary of the
space

boundary mode. Then move the
base boundary to the desired loca-
tion, and click to release it.

click and hold the location grip, and
press CTRL twice to switch to Move

move the net boundary of the
space

net boundary mode. Then move the
net boundary to the desired loca-
tion, and click to release it.
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Then…If you want to…

click and hold the location grip, and
press CTRL 3 times to switch to

move the usable boundary of the
space

Move usable boundary mode. Then
move the usable boundary to the
desired location, and click to release
it.

click and hold the location grip, and
press CTRL 4 times to switch to

move the gross boundary of the
space

Move gross boundary mode. Then
move the gross boundary to the de-
sired location, and click to release it.

Changing the Type of a Space
You can change an extruded 3D space to a 2D space, or to a 3D freeform space,
and vice versa. You can also make a non-associative space associative to
boundary objects or disconnect an associative space from its boundary objects.
Each of these operations will change editable properties of the space and the
user interaction. The following table shows the results of changing a space
from one geometry type to another.

ResultNew Geometry TypeOriginal Geo-
metry Type

Non-associative ex-
truded 3D

Non-associat-
ive 2D

■ Editable properties for the space height
and space justification are added. The
insertion point and justification of the
space will be set to the top of the floor.

■ Surface editing is enabled.

Non-associative 3D
freeform

Non-associat-
ive 2D

■ Editable properties for a subset of the
space height are added.

■ Editable properties for calculation cut
planes are added.

■ Surface editing is enabled.

■ Length and width properties become
non-editable.
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ResultNew Geometry TypeOriginal Geo-
metry Type

Associative 2DNon-associat-
ive 2D

■ Length, width, rotation, and elevation
become dependent on the boundary
objects and are not editable anymore.

■ Base boundary becomes dependent on
boundary objects and is not grip-edit-
able anymore.

Associative extruded
3D

Non-associat-
ive 2D

■ Length, width, rotation, and elevation
become dependent on the boundary
objects and are not editable anymore.

■ The insertion point and justification of
the space will be set to the top of the
floor.

■ Editable properties for the space height
and space justification are added.

■ Base boundary becomes dependent on
boundary objects and is not grip-edit-
able anymore.

Associative 3D freeformNon-associat-
ive 2D

■ Length, width, rotation, and elevation
become dependent on the boundary
objects and are not editable anymore.

■ Editable properties for a subset of the
space height are added.

■ Editable properties for calculation cut
planes are added.

■ Base boundary becomes dependent on
boundary objects and is not grip-edit-
able anymore.

Non-Associative 3D
Freeform

Non-Associat-
ive Extruded
3D

■ Overall space height property can only
be edited by in-place editing the space
geometry. Properties for Default surface
height and space justification are not
available.
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ResultNew Geometry TypeOriginal Geo-
metry Type

■ Length and width properties can only
be edited by in-place editing of space
geometry.

■ Editable properties for calculation cut
planes are added.

Associative extruded
3D

Non-Associat-
ive Extruded
3D

■ Length, width, rotation, and elevation
become dependent on boundary ob-
jects and are not editable anymore.

■ Surface editing is disabled.

■ Base boundary becomes dependent on
boundary objects and is not grip-edit-
able anymore.

Associative 3D Free-
form

Non-Associat-
ive Extruded
3D

■ Overall space height, length, width, ro-
tation, and elevation become depend-
ent on boundary objects and are not
editable anymore. Properties for Default
surface height and space justification
are not available.

■ Editable properties for calculation cut
planes are added.

■ Surface editing is disabled.

■ Base boundary becomes dependent on
boundary objects and is not grip-edit-
able anymore.

Associative 3D Free-
form

Non-Associat-
ive 3D free-
form

■ Rotation and elevation become depend-
ent on boundary objects and are not
editable anymore.

■ Surface editing is disabled.
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Space types with grips

Use this procedure to change the type of a space.

1 Select the space for which you want to change the geometry type,
and double-click to display the Properties palette.

2 Expand Basic, and expand Component Dimensions.

3 For Geometry type, select the desired geometry.

4 For information on changing the associativity of a space, see
Making a Space Associative or Non-Associative on page 2972.

Changing the Space Height
Depending on the geometry type of a space various of its height properties
can be edited.

Changing the Height of Extruded 3D Spaces
Use this procedure to change the height of an extruded 3D space. An extruded
space is not constrained in the z-direction, and all height components are
user-definable. The sum of all components’ heights is the overall space height.

NOTE This procedure is valid for associative and non-associative spaces.
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1 Double-click the space for which you want to change a height
component.

2 On the Properties palette, expand Basic, and expand Component
Dimensions.

3 Modify the height of the space:

Then…If you want to…

enter a value for Overall space height.specify the overall height of the
space, including floor to ceiling
height, ceiling and floor thick-
ness, and space above ceiling and
below floor

enter a height value. The value you
enter here is applied uniformly to the
space.

specify the ceiling height of the
space

enter a value for Floor thickness.specify a floor thickness

enter a value for Ceiling thickness.specify a ceiling thickness

enter the appropriate value for Height
above ceiling.

specify the distance between the
top of the space ceiling to the
top of the space

enter the appropriate value for Height
below floor.

specify the distance between the
bottom of the space floor and the
bottom of the space

enter a value for Default surface
height.

specify the combined height of
ceiling height, ceiling thickness,
and height above ceiling
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Changing the Height of 3D Freeform Spaces
In a 3D freeform space, the overall space height is determined either by the
boundary objects in an associative space, or by the height of the 3D geometry
in a non-associative space. Within the overall space height, you can change
the height of individual components, but they will not add or subtract from
the overall space height. For example, if you increase the height above the
ceiling, then the ceiling height is lowered in return.

These additional restrictions apply to changing the height of a 3D freeform
space:

■ You can change the ceiling thickness and the height above the ceiling.
However, if the ceiling thickness is set to 0, the height above ceiling is 0
and read-only.

■ You can change the floor thickness and the height below the floor.
However, if the floor thickness is set to 0, the height below floor is 0 and
read-only.

■ If both ceiling thickness and floor thickness are 0, the ceiling height is
read-only.

■ The justification of a 3D freeform space is always set to Top of Floor.

■ If you put the bottom of the ceiling to the same height as the top of the
space, then the ceiling is situated above the actual bounded volume, and
will not be drawn. You cannot, however put the bottom of the ceiling
above the top of the space.

■ If you put the top of the floor to the same height as the bottom of the
space, then the floor is situated below the actual bounded volume, and
will not be drawn. You cannot, however put the top of the floor below the
bottom of the space.

■ The ceiling height of a 3D freeform space ranges from the bottom of the
ceiling to the top of the floor. In cases where the ceiling and floor are set
to 0, the ceiling height ranges from the top of the space to the bottom of
the space.

Changing the overall height of a 3D freeform space

This procedure is valid only for non-associative spaces.

1 Select a 3D freeform space for which you want to change the
overall height.
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2 Click Space tab ➤ Modify panel ➤ Edit In Place  .

3 Select the surface grip for the top surface, and drag it to the desired
height.

4 Changing the height of a 3D freeform space

5 To save the changes to the space height, click Edit in Place

tab ➤ Edits panel ➤ Finish  .

Changing the height of individual components of a 3D space

This procedure is valid for associative and non-associative spaces.

1 Select the 3D freeform space for which you want to change
individual height components.

2 On the Properties palette, expand Basic, and expand Component
Dimensions.
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3 Modify the height components of the space:

Then…If you want to…

enter a height value. The value you
enter here is applied uniformly to the
space.

specify the ceiling height of the
space

enter a value for Floor thickness.specify a floor thickness

enter a value for Ceiling thickness.specify a ceiling thickness

enter the appropriate value for Height
above ceiling.

specify the distance between the
top of the space ceiling to the
top of the space

enter the appropriate value for Height
below floor.

specify the distance between the
bottom of the space floor and the
bottom of the space

Changing the Height of Space Surfaces (Extruded 3D Spaces)
Use this procedure to grip-edit the height of an individual surface of an
extruded 3D space.

NOTE This procedure is valid for associative and non-associative spaces.

1 Verify that you are working in a 3D isometric view.

2 Select the extruded 3D space for which you want to change the
height of a surface, and click the Edit Surfaces grip.

3 Select the Surface Height grip for the surface you want to edit,
and drag it to the desired height or enter a value for the height.
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TIP If you can move the height grip for a surface, but do not see the
resulting changed surface, the Surfaces display component might
have been turned off either in the space style or in the object display
properties. For information about making the component visible, see
Specifying the Display Properties of a Space Style on page 3101.

Boolean Operations for Extruded 3D Spaces
There are a number of boolean operations to change the geometry of an
extruded 3D space.
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Creating Interference Conditions for Spaces
Use this procedure to place objects such as mass elements in a space in order
to create custom openings or cutouts. For example, a column grid structure
might have columns within the space. Once defined as interference conditions,
the columns cut out an area at the floor and ceiling of the space.

NOTE This procedure is valid for associative and non-associative spaces.

Any AEC object that has a 3D geometry can be used as an interference
condition, as can AutoCAD polylines.

NOTE Interference conditions are deducted from the base volume of a space. You
can add the automatic property Base Area Minus Interference to schedule the
value of the area with without the interference condition.

When another object, such as a ceiling grid, is attached to a space object, it
recognizes the interference condition. For example, if you add a column to
the space as an interference condition, as long as the ceiling grid is anchored
to the space object, the ceiling grid is cut. If you move the column, the ceiling
grid is updated with the new column location.

Adding an interference condition to a space

1 Place the object you want to use as the interference condition in
a location intersecting the space as needed.

2 Select the space to which you want to add the interference
condition.
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3 Click Space tab ➤ Modify panel ➤ Interference drop-down ➤ Add

 .

4 Select the objects intersecting the space as the interference
condition, and press ENTER.

Removing Interference Conditions from Spaces
Use this procedure to remove interference conditions from spaces.

NOTE This procedure is valid for associative and non-associative spaces.

1 Select the space with the interference condition.

2 Click Space tab ➤ Modify panel ➤ Interference

drop-down ➤ Remove  .

3 Select the object(s) functioning as the interference condition, and
press ENTER.

Merging Extruded 3D Spaces
Use this procedure to merge 2 or more 3D spaces in a drawing. When you
merge spaces that overlap each other, their boundaries are combined to form
the boundaries of the merged space.

NOTE This procedure is valid for non-associative spaces.

You can merge a non-associative 3D freeform space into a 2D space or extruded
3D space. In that case, the base profile of the 3D freeform space is used for
the merge. You cannot merge a 2D or extruded 3D space into a 3D freeform
space.

The following properties of the first selected space are applied to subsequent
spaces merged into it:

■ Name

■ Description

■ Layer

■ Style

■ Tag
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■ Calculation modifiers

■ Zone attachments

■ Space height

■ Floor thickness

■ Ceiling thickness

■ Height above ceiling

■ Height below floor

■ Default Surface height

■ Justification

■ Boundary offset type

■ Rotation

■ Display properties

■ Schedule properties

Merging Spaces with Manual Boundary Offsets

If you merge spaces that have manual boundary offsets, each activated
boundary on the first space is merged with the corresponding boundary on
the other space (base with base, net with net, and so on).

If a manual space boundary on the first space is not activated (displaying its
grips), it is not included in the merge operation. Whether the boundaries on
the second space are activated is not relevant for the merge. They are merged
if their corresponding boundary on the first space is activated. If a boundary
on the first space is not activated, the existing boundary on the first space will
remain as it is, and the corresponding boundary on the second space will be
deleted. This can result in irregular space boundaries. To avoid this, make sure
that on the first space all relevant boundaries are activated, and can be merged.

For information on activating manual space boundaries, see Activating Manual
Space Boundaries on page 3015.

The display properties of the boundaries of the first selected space are applied
to the resulting merged boundary. For example, if the net boundary of the
first space is red with a lineweight of 0.18 mm, the net boundary of the
resulting merged space will be red with a lineweight of 0.18 mm.
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Merging spaces with manual boundaries

Merging Spaces with Style-Defined Boundary Offsets

If you merge spaces with style-defined boundary offsets, the base boundaries
of both spaces are merged, and the boundary offsets defined in the style of
the first space are applied to the resulting merged space.

Merging spaces with style-defined boundaries

Merging Spaces with Different Boundary Offsets

If the space boundaries of the merging spaces are determined by different
methods, the method used for the first selected space is used for the resulting
space.

Example 1: The boundaries of the first space are offset by style, and the style
defines an offset between boundaries of 0.25 m. The boundaries of the second
space are offset manually, and have 0 offset between the individual boundaries.
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If the first space is merged with the second space, the boundaries previously
belonging to the second space are recalculated by the style of the first space,
and offset from each other by 0.25 m.

Merging spaces with different boundary offset types

Example 2: The boundaries of space 1 are offset manually, and have 0.3 offset
between the individual boundaries. The boundaries of space 2 are offset by
style, and the style defines an offset between boundaries of 0.25 m. If space
1 is merged with space 2, the value of the Offset boundaries property for the
resulting space will be Manual. Since the net, usable, and gross boundaries of
a space with style-based offsets are not grip-editable, only the base boundaries
of both spaces will be merged. The boundaries of the second space are deleted
from the drawing.

1 Select one of the spaces to be merged right-click, and click AEC

Modify Tools ➤ Merge  .

2 Select the space to merge with the first space.

NOTE You can merge only those spaces that lie on the same Z-plane.
Spaces with different Z-positions in the same coordinate system
cannot be merged.

3 Enter y (Yes) to erase the second space or n (No) to leave the space
in the drawing.
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Dividing Extruded 3D Spaces
Use this procedure to divide an extruded 3D space into smaller spaces by using
a divide line. The space is split at the line.

NOTE This procedure is valid for non-associative spaces only.

All properties - like for example property data, calculation modifiers, or
boundary offset types - will be applied to both resulting spaces.

IMPORTANT If you are dividing a space with manual boundary offsets, verify that
the all boundaries are activated. Boundaries that are not activated are not divided.
For information about activating manual boundaries, see Activating Manual Space
Boundaries on page 3015.

1 Select a space to divide, right-click, and click AEC Modify

Tools ➤ Divide  .

2 Specify the divide line start point.

3 Specify the divide line endpoint.

Depending on the boundary offset type, the divide line will create
different results for the net, usable, and gross, boundaries.
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Creating Holes in Extruded 3D Spaces
Use this procedure to subtract extruded 3D spaces from one another in order
to create a hole in a space.

NOTE This procedure is valid for non-associative spaces only.

To create a hole, you need to select spaces that intersect one another.
Alternatively, you can select a closed polyline as the shape to subtract. You
can choose whether to keep the subtracted space or polyline in the drawing
as a separate unit. For example, you may want to keep the space if you need
to subtract the same shape from other spaces.

When you subtract one space from another, the base boundary of the
subtracted space is subtracted from all boundaries of the first space. The other
boundaries of the subtracted space are just deleted without interacting with
the first space. Depending on whether the first space has style-defined offsets
or manual offsets, the boundaries around the hole are either re-calculated
according to the style offsets or cut off at the intersection.

IMPORTANT Before subtracting a space from another space with manual boundary
offsets, verify that all boundaries you want to be cut are activated. If a boundary
is not activated, the hole will not cut through it. For information about activating
manual boundaries, see Activating Manual Space Boundaries on page 3015.

Subtracting spaces with style-defined boundary offsets
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Subtracting spaces with manual boundary offsets

1 Create a space in which to create a hole.

2 Create a second, smaller space to be subtracted from the larger
space.

You can draw the second space within or overlapping the first
space, or you can draw it in another location and then move it
onto the larger space.

Alternatively, you can select a closed polyline to subtract from
the space.

3 Select the larger space, right-click, and click AEC Modify

Tools ➤ Subtract  .

4 Select the smaller space to subtract from the larger space.

5 Enter y (Yes) to erase the subtracted space, or n (No) to leave the
space in the drawing.

Creating Spaces from the Intersection of Other Spaces
Use this procedure to create a new extruded 3D space from the overlapping
portion of 2 intersecting extruded 3D spaces. You can choose whether to retain
the original geometry after creating the new intersection space.

NOTE This procedure is valid for non-associative spaces only.
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When a space is created from 2 intersecting spaces, the following properties
of the first selected space are applied to the resulting intersection space:

■ Name

■ Description

■ Layer

■ Style

■ Tag

■ Calculation Modifiers

■ Zone attachments

■ Space height

■ Floor thickness

■ Ceiling thickness

■ Height above ceiling

■ Height below floor

■ Default surface height

■ Justification

■ Boundary offset type

■ Rotation

■ Display properties

■ Schedule properties

Intersecting Spaces with Manual Boundary Offsets

If you intersect spaces with manual boundary offsets, each activated space
boundary is intersected with the corresponding space boundary on the other
space (base to base, net to net, and so on.)
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Intersecting spaces with all boundaries activated

If a manual space boundary on the first space is not activated (displaying its
grips), it is not included in the intersecting operation. This will effect the
existing boundary on the first space to remain as it is, and the corresponding
boundary on the second space to be deleted. This can result in irregular space
boundaries. To avoid this, make sure that all relevant boundaries on the first
space are activated.

Intersecting spaces with only base boundary activated

For information on activating manual space boundaries, see Activating Manual
Space Boundaries on page 3015.

The display properties of the boundaries of the first selected space are applied
to the resulting intersection boundary. For example, if the net boundary of

3044 | Chapter 40   Spaces



space 1 is red with a lineweight of 0.18 mm, the net boundary of the resulting
space will be red with a lineweight of 0.18 mm.

Intersecting Spaces with Style-Defined Boundary Offsets

If you intersect spaces with style-defined boundary offsets, the base boundaries
of both spaces are intersected with each other, and the boundary offsets defined
in the style of the first space are applied to the resulting intersection space.

Intersecting spaces with style-defined boundary offsets

Intersecting Spaces with Different Boundary Offsets

If the space boundaries of the 2 spaces are calculated with different offset
types, the method used by the first selected space is also used for the resulting
space.

Example 1: The boundaries of space 1 are offset by style, and the style defines
an offset between boundaries of 0.25 m. The boundaries of space 2 are offset
manually, and have 0 offset between the individual boundaries. If space 1 is
intersected with space 2, the base boundaries of the 2 spaces are intersected
with each other, and the remaining boundaries are recalculated by the offsets
of the style of space 1, and offset from each other by 0.25 m.
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Intersecting style-based boundaries (left) with manual boundaries (right)

Example 2: The boundaries of space 1 are offset manually, and have 0.3 offset
between the individual boundaries. The boundaries of space 2 are offset by
style, and the style defines an offset between boundaries of 0.25 m. If space
1 is merged with space 2, the value of the Offset boundaries property for the
resulting space will be Manual. Since the net, usable, and gross boundaries of
a space with style-based offsets are not grip-editable, only the base boundaries
of both spaces will be intersected. The boundaries of the second space are
deleted from the drawing.

Intersecting manual boundaries (left) with style-based boundaries (right)

1 Create 2 overlapping spaces.

2 Select the first overlapping space, right-click, and click AEC Modify

Tools ➤ Crop  .

3 Select the second overlapping space.
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4 Enter y (Yes) to erase the original spaces, or n (No) to leave the
spaces in the drawing.

Trimming an Extruded 3D Space
Use this procedure to trim an extruded 3D space with a trim line.

NOTE This procedure is valid for non-associative spaces only.

IMPORTANT If you are trimming a space with manual boundary offsets, verify
that the all boundaries are activated. Boundaries that are not activated are not
trimmed. For information about activating manual boundaries, see Activating
Manual Space Boundaries on page 3015.
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Trimming spaces with different boundary offset types

1 Select the space to be trimmed, right-click, and click AEC Modify

Tools ➤ Trim  .

2 Specify a start point for the trim line.

3 Specify an endpoint for the trim line.

4 Select the side of the space to be trimmed.
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Removing Voids from Spaces
Use this procedure to remove individual voids from a space with multiple
rings.

NOTE This procedure is valid for non-associative 2D and extruded 3D spaces only.

Voids can be created in the following cases:

■ You cut a hole in a space as described in Creating Holes in Extruded 3D
Spaces on page 3041.

■ You generate a space from boundary objects that have interference objects
within their boundaries. For example, you can generate a space for a room
with a row of columns in it. In that case, the boundaries for the room
would be defined as the outer space ring and the columns would be
deducted as holes from the generated room. If you deactivate the
associativity of the space, you can remove the resulting space rings.

■ A legacy multi-ring area is converted to a space using the current software.

1 Select a space with voids.

2 Click Space tab ➤ Modify panel ➤ Remove Void  .

3 Select the void you want to remove from the space.

The void is removed.

4 Press ENTER.

Reversing Space Rings
Use this procedure to reverse the value of an individual space ring, so that a
positive ring (space) can be transformed into a negative ring (hole), or a
negative ring back into a positive ring.

NOTE This procedure is valid for non-associative 2D and extruded 3D spaces only.

Multi-level space rings are most likely to occur in legacy area objects that have
been converted to spaces.

1 Select a space of which you want to reverse a ring.

2 On the command line, enter SpaceReverseRing.

3 Select the space ring you want to reverse.
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Reversing All Rings in a Space
Use this procedure to reverse all rings of a space at once.

NOTE This procedure is valid for non-associative 2D and extruded 3D spaces only.

When you reverse the space rings, all positive rings are transformed into
negative rings and all negative rings are transformed into positive rings.

Reversing the value of all space rings may be desirable for legacy area objects
that have been converted to spaces.

1 Select the space you want to reverse.

2 On the command line, enter SpaceReverseProfile.

3 Select further spaces for reversing.

4 Press ENTER to end your selection.

Boolean Operations for 3D Freeform Spaces
You can change the shape of a 3D freeform space by in-place editing the
surfaces of the space.

NOTE When you start an in-place edit operation on an extruded 3D space, it is
automatically converted to a 3D freeform space. You can convert it back to an
extruded 3D space once you have finished editing it, but you will loose any
geometry changes that are not compatible with extruded 3D spaces.

Trimming 3D Freeform Spaces
You can trim a part of an existing 3D freeform space by trimming one of its
surfaces.

NOTE This procedure is valid for non-associative spaces only. If you perform it on
an associative space, it will loose associativity after exiting the in-place edit mode.
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Trimming a 3D space

1 Verify that you are working in a 3D isometric view.

2 Select the space you want to trim along the horizontal or vertical
plane.

3D space (left) in in-place editing mode (right)

3 Click Space tab ➤ Modify panel ➤ Edit In Place  .

4 Click Edit In Place tab ➤ Modify panel ➤ Trim By Plane  .

5 Specify the trim plane either on screen or by entering 3 points on
the command line.

TIP Use a Front view to generate a horizontal trim plane and a Plan
view to generate a vertical trim plane.

6 To save the changes to the space, click Edit in Place tab ➤ Edits

panel ➤ Finish  .
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Splitting Surfaces of 3D Freeform Spaces
You can split a surface of a 3D freeform space. This is useful when you need
to change the geometry of only one part of a space surface, as when creating
a cable channel in a space ceiling.

NOTE This procedure is valid for non-associative spaces only. If you perform it on
an associative space, it will loose associativity after exiting the in-place edit mode.

Splitting a surface

1 Select the space where you want to split a surface.

3D space (left) in in-place editing mode (right)

2 Click Space tab ➤ Modify panel ➤ Edit In Place  .

3 Click Edit In Place tab ➤ Modify panel ➤ Split Face  .

4 Select the start point of the splitting line.

5 Select the endpoint of the splitting line.

6 To save the changes to the space, click Edit in Place tab ➤ Edits

panel ➤ Finish  .
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Joining Surfaces of 3D Freeform Spaces
Use this procedure to join 2 previously split surfaces of a 3D freeform space.

NOTE This procedure is valid for non-associative spaces only.

Joining 2 space surfaces

1 Verify that you are working in a 3D isometric view.

2 Select the space where you want to join 2 surfaces.

3 Click Space tab ➤ Modify panel ➤ Edit In Place  .

3D space (left) in in-place editing mode (right)

4 Click Edit In Place tab  ➤ Modify panel ➤ Join Faces  .

5 Select the edge separating the 2 surfaces, and press ENTER.

6 To save the changes to the space, click Edit in Place tab ➤ Edits

panel ➤ Finish  .
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Merging 3D Freeform Spaces with AEC Objects
Use this procedure to merge a 3D freeform space with a space or other AEC
object. You can merge a 3D freeform space with all AEC objects that have a
3D geometry.

NOTE This procedure is valid for non-associative spaces only. If you perform it on
an associative space, it will loose associativity after exiting the in-place edit mode.

1 Switch to a 3D isometric view.

2 Select the 3D freeform space you want to merge with another
object.

3 Click Space tab ➤ Modify panel ➤ Edit In Place  .

4 Click Edit In Place tab  ➤ Modify panel ➤ Boolean
drop-down ➤ Union.

5 Select the AEC object you want to merge with the 3D freeform
space, and press Enter.

6 Enter y (Yes) to erase the merged-in object, or n (No) to leave the
object in the drawing.

Merging an extruded space to a freeform space
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7 To save the changes to the space, click Edit in Place tab ➤ Edits

panel ➤ Finish  .

Subtracting AEC Objects from 3D Freeform Spaces
Use this procedure to subtract a space or other AEC object from a 3D freeform
space. You can subtract any AEC object that has a 3D geometry from a space.

NOTE This procedure is valid for non-associative spaces only. If you perform it on
an associative space, it will loose associativity after exiting the in-place edit mode.

1 Switch to a 3D isometric view.

2 Select the 3D freeform space from which you want to subtract an
object.

3 Click Space tab ➤ Modify panel ➤ Edit In Place  .

4 Click Edit In Place tab ➤ Modify panel ➤ Boolean
drop-down ➤ Subtract.

5 Select the AEC object you want to subtract from the 3D freeform
space, and press Enter.

6 Entery (Yes) to erase the subtracted object, or n (No) to leave the
object in the drawing.
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Subtracting an extruded space from a freeform space

7 To save the changes to the space, click Edit in Place tab ➤ Edits

panel ➤ Finish  .

Intersecting 3D Freeform Spaces with AEC Objects
User this procedure to intersect a 3D freeform space with a space or other AEC
object. You can intersect a 3D freeform space with all AEC objects that have
a 3D geometry.

NOTE This procedure is valid for non-associative spaces only. If you perform it on
an associative space, it will loose associativity after exiting the in-place edit mode.

1 Switch to a 3D isometric view.

2 Select the 3D freeform space that you want to intersect with an
AEC object.

3 Click Space tab ➤ Modify panel ➤ Edit In Place  .

4 Click Edit In Place tab ➤ Modify panel ➤ Boolean
drop-down ➤ Intersect.

5 Select the AEC object you want to intersect with the 3D freeform
space, and press Enter.
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6 Enter y (Yes) to erase the object, or n (No) to leave the object in
the drawing.

7 To save the changes to the space, click Edit in Place tab ➤ Edits

panel ➤ Finish  .

Grip-Editing the Surfaces of 3D Freeform Spaces
Use this procedure to grip-edit individual surfaces of a 3D freeform space.

NOTE This procedure is valid for non-associative spaces only. If you perform it on
an associative space, it will loose associativity after exiting the in-place edit mode.

You have 6 different options for grip-editing a space surface.

As you cycle through the options by pressing CTRL, the tooltip advances
sequentially to indicate the current option. Pressing CTRL more than 5 times
returns you to the first option, allowing you to continue cycling through the
edit choices.

The cursor is constrained when you choose an orthogonal option and
unconstrained when you choose a free option.

Moving a space surface orthogonally while stretching adjacent surfaces
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Moving a space surface freely while stretching adjacent surfaces

Moving a space surface orthogonally while maintaining the planes of adjacent surfaces

Pulling a space surface orthogonally while adding adjacent surfaces
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Pulling a space surface freely while adding adjacent surfaces

Pulling a space surface orthogonally while adding adjacent surfaces

Pushing a space surface orthogonally to create a hole

1 Verify that you are working in a 3D isometric view.

2 Select the space you want to edit.

3 Click Space tab ➤ Modify panel ➤ Edit In Place  .
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4 Select the surface grip to edit.

The tooltip displays the available edit operations:

5 Select the grip edit operation you want to perform:

Then…If you want to…

click the surface grip. Then, move
it to the new position.

move the space surface orthogon-
ally while stretching adjacent sur-
faces

click and hold the surface grip,
press CTRL once, and specify the
new location.

move the space surface freely while
stretching adjacent surfaces

click and hold the surface grip,
press CTRL twice, and specify the
new location.

move the space surface orthogon-
ally while maintaining the planes of
adjacent surfaces

click and hold the surface grip,
press CTRL 3 times, and specify the
new location.

pull the space surface orthogonally
while adding adjacent surfaces

click and hold the surface grip,
press CTRL 4 times, and specify the
new location

NOTE The location of the cur-
rent UCS is temporarily moved
to coincide with the original
position of the surface grip that
you select when you are work-
ing with this option. Only the
UCS origin is changed, not its
orientation.

pull the space surface freely while
adding adjacent surfaces

click and hold the surface grip,
press CTRL five times, and specify
the new location.
Push into the space to create a hole,
or pull out of the space to add adja-
cent faces.

push or pull the space surface ortho-
gonally while either adding adja-
cent surfaces or creating a hole
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NOTE You cannot pull the space surface at such an angle, either
horizontally or vertically, that the adjacent surfaces become
non-planar. If this distorted condition occurs, the space surface
automatically returns to its original position and an error message is
displayed on the command line.

6 To save the changes to the space, click Edit in Place tab ➤ Edits

panel ➤ Finish  .

Editing Space Surface Properties
You can edit the properties of 3D space surfaces with the Space/Zone Manager
worksheet.

Space surfaces can be assigned a number of properties important for processing
spaces in a downstream engineering or facility management application. You
can define these properties in the architectural plan, and later export the plan
or open it in an engineering application to perform calculations, such as
determining the heating/cooling load on a building.

Use this procedure to edit any of the following surface properties for a
non-associative 3D space:

■ Surface name

■ Surface type

■ Surface style

■ Surface height (extruded 3D spaces only)

■ Surface openings

■ Opening name

■ Opening type

■ Opening style

■ Opening dimensions

■ Opening area

■ Opening reported area (3D freeform spaces only)
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IMPORTANT For the surfaces of an associative space, only the surface name, the
surface type, and the ceiling and floor style as can be edited. All other surface
properties, including the properties for associative surface openings, are read-only.

Opening the Space/Zone Manager
Use this procedure to open the Space/Zone Manager.

 ➤ Select a space, and click Space tab ➤ Helpers panel ➤ Space/Zone

Manager  .

To see all spaces in the drawing, as well as their surfaces and
surface openings, verify that the settings for Show all Zones and
Spaces and Show Space Surfaces are selected.

■ Non-associative extruded 3D spaces only: Select a space, click
the Edit Surfaces grip, and then click the Edit Surface Properties
grip.
To see all spaces in the drawing, as well as their surfaces and
surface openings, verify that both settings for Show all Zones
and Spaces and Show Space Surfaces are selected.
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■ Non-associative 3D freeform spaces only: Select a space, click
the Edit Surfaces grip, and then click the Edit Surface grip on
one surface. Then click the Edit Surface Properties grip for that
surface.
To see all spaces in the drawing, as well as their surfaces and
surface openings, verify that both settings for Show all Zones
and Spaces and Show Space Surfaces are selected.

In the tree view on the left, all spaces are listed either under their
containing zone or under the Unattached Spaces folder. The
surfaces of a space are listed under the space. Surface openings
are listed under the surface that contains them. To access a space,
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surface or zone, you may need to expand the tree until you reach
the desired item.

Editing Surface Properties
Use this procedure to edit the properties of a space surface.

1 Open the Space/Zone Manager with one of the instructions
described in Opening the Space/Zone Manager on page 3062.

2 Verify that Show Space Surfaces is selected.

3 If necessary expand the tree view to display the surface you want
to edit.

4 Select the surface in the tree view and change its properties on
the right:

OptionsProperty

enter a new value for Name.Name

Surface type (3D
freeform only)

■ Ceiling

■ Floor

■ Surface

This setting can be useful for complex freeform
shapes, where the ceiling or the floor of the space
can be represented by more than one surface.
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OptionsProperty

for Type, select one of the following:Type

■ Interior Wall

■ Exterior Wall

■ Shade

■ Air

■ Underground Wall

all available wall and curtain wall styles in the
drawing

Style

select Override Default Surface Height, and enter a
new value for either Height or Area. Both of these
fields change only the height of the surface.

Height/Area (ex-
truded 3D spaces
only)

5 Click OK.

Editing Ceiling and Floor Surfaces
Use this procedure to edit the ceiling and floor surfaces of a space.

1 Open the Space/Zone Manager with one of the instructions
described in Opening the Space/Zone Manager on page 3062.

2 Verify that Show Space Surfaces is selected.

3 If necessary expand the tree view to display the ceiling and floor
surfaces you want to edit.
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4 Select the ceiling surface of a space in the tree view, and make the
necessary changes on the right:

Then…If you want to…

enter a new value for Name.change the name of the ceiling

for Type, select one of the following:change the ceiling type

■ Ceiling

■ Roof

■ Underground ceiling

for Style, select a slab or roof slab style
from the drop-down list.

change the assigned roof slab
style of the ceiling

5 Select the floor of a space in the tree view, and make the necessary
changes on the right:

Then…If you want to…

enter a new value for Name.change the name of the floor

for Type, select one of the following:change the floor type

■ Interior Floor

■ Raised Floor

■ Slab on Grade

■ Underground Slab
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Then…If you want to…

for Style, select a slab style from the
drop-down list.

change the assigned slab style
of the floor

6 To add an opening to a ceiling or floor, select the ceiling or floor
in the tree view, right-click, and click Add Opening.

7 To remove an opening from a ceiling or floor, select the opening
in the tree view, right-click, and click Remove Opening.

8 Click OK.

Working with Surface Openings
Openings on space surfaces can be important for building systems calculations
when the drawing is used in AutoCAD MEP or other building applications.

You can add openings to the surfaces of extruded 3D spaces and 3D freeform
spaces. Depending on the geometry type of the space, the openings have
different features. For example, on a 3D freeform space, you can edit the
opening profile into any shape; however, on an extruded 3D space surface,
the openings are limited to rectangular shapes.

Surface openings can have properties like opening name, opening type and
opening dimensions attached to them. For more information, see Editing
Space Surface Properties on page 3061.

NOTE You can add openings only to non-associative spaces. The openings in an
associative space are determined by the openings in the boundary objects.
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Adding Openings to Extruded 3D Space Surfaces
Use this procedure to add an opening to the surface of an extruded 3D space.
Openings can be added to flat surfaces or curved surfaces (like a cylinder
surface).

You can use grips or the Space/Zone Manager to add openings to a space
surface. For more information about working with the Space/Zone Manager,
see Editing Space Surface Properties on page 3061.

1 Select the space to which you want to add a surface opening, and
click the Edit Surfaces grip.
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2 Click the Add Window grip on the surface to which you want to
add an opening. By default, a window opening is created.
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To add a door, hold down CTRL while clicking the Add Window
grip. Note that doors are positioned at the top of the floor surface.

3 When you are finished, click the Exit Editing Surfaces grip.

NOTE If an opening is added to the ceiling or floor surface of an
extruded 3D space, it is always created on the bottom or top surface
of the space geometry. The position of the opening is not affected
by the justification of the space.
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NOTE If the openings are not displayed after you exit the surface
editing mode, then the Surface components display component in
the space style or the space object display properties has not been
activated. For more information, see Specifying the Display Properties
of a Space Style on page 3101.

Editing Openings in Extruded 3D Space Surfaces
Use this procedure to stretch, move, or copy a surface opening in an extruded
3D space.

1 Select the space where you want to edit a surface opening, and
click the Edit surfaces grip.

2 Select one of the corner grips of the surface opening.

3 Edit the opening:

Then…If you want to…

move the corner grip to the desired position.stretch an edge of the
opening

press CTRL, and move the opening to the
desired position.

move the opening to a
new position on the sur-
face

press CTRL twice, and copy the opening to
the desired position.

copy the opening on the
surface
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Stretching a surface opening
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Moving a surface opening
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Copying a surface opening

4 When you are finished, click the Exit Editing Surfaces grip.

Adding Openings to 3D Freeform Space Surfaces
Use this procedure to add an opening to the surface of a 3D freeform space.
Openings can be added to flat surfaces or curved surfaces (like a cylinder
surface).

NOTE Openings cannot be added to dome- and sphere-shaped surfaces.

1 Select the space to which you want to add a surface opening, and
click the Edit Surfaces grip.

2 Click the surface grip for the surface to which you want to add
an opening.

3 Click the Add Window grip on the activated surface.
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Adding a window opening to a freeform space surface

To add a door, hold down CTRL while clicking the Add Window
grip. Note that doors are positioned at the bottom of the selected
surface.

NOTE If the openings are not displayed after you exit the surface
editing mode, then the Surface components display component in
the space style or the space object display properties has not been
activated. For more information, see Specifying the Display Properties
of a Space Style on page 3101.
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Moving 3D Freeform Space Openings
Use this procedure to move an opening in a 3D freeform space surface.

1 Select the space on which you want to move a surface opening,
and click the Edit Surfaces grip.

2 Click the grip for the surface with the opening you want to move.

3 Select the Location grip for the opening you want to move, and
move it to another location on the surface.

Moving a window opening on a freeform space surface

NOTE Moving the opening onto another surface or outside the space
will result in the opening area being reported as zero.
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4 To exit the surface editing mode, click the Exit Editing Surfaces
grip.

Editing the Shape of 3D Freeform Space Openings
Use this procedure to edit the shape of a 3D freeform space opening.

3D freeform space surface openings can be edited like any profile-based
boundary in AutoCAD Architecture. The opening boundary has vertex and
edge grips to generate the desired shape.

Changing the edge of a space surface opening

1 Select the space on which you want to edit the edge of a surface
opening, and click the Edit Surfaces grip.

2 Click the grip for the surface with the opening you want to edit.

3 Select the Edge grip for the edge you want to change.
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Offsetting the edge of a window opening on a freeform space surface
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Adding a vertex to the edge of a window opening on a freeform space surface
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Converting the edge of a window opening to arc on a freeform space surface
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Offsetting all edges of a window opening on a freeform space surface
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4 Specify the new edge location:

Then…If you want to…

move the edge to the desired loca-
tion, and click; or enter a value, and
press ENTER.

offset the edge

press CTRL to switch to the Add
Vertex edit mode. Move the edge

add a vertex and create an edge

to the desired location, and click; or
enter a value, and press ENTER.

press CTRL twice to switch to the
Convert to Arc/Convert to Line edit

change a selected edge to an
arc/change a selected arc to a line

mode. Stretch the midpoint to the
desired location, and click; or enter
a value, and press ENTER.

press CTRL 3 times to switch to the
Offset All edit mode. Move the selec-

offset all edges at an identical dis-
tance

ted edge to the desired location for
all edges, and click; or enter a value,
and press ENTER.

5 To exit the surface editing mode, click the Exit Editing Surfaces
grip.

Changing a vertex of a space surface opening

1 Select the space on which you want to edit an opening vertex,
and click the Edit Surfaces grip.

2 Click the grip for the surface with the opening you want to edit.

3 Select the Vertex grip for the vertex you want to change.

The Vertex grip has 3 edit modes:

■ Move: This is the default. Use it to move the selected vertex
in any direction. The neighboring segments are stretched if
necessary.

■ Remove: Use this edit mode to remove a vertex. The
neighboring segments are replaced with a line.

■ Offset Edges: Use this edit mode to move a vertex and the
adjacent edges of the space boundary with it.
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Moving the vertex of a window opening on a freeform space surface
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Removing the vertex of a window opening on a freeform space surface
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Offsetting the edges of a window opening on a freeform space surface

4 Edit the vertex as necessary:

Then…If you want to…

move the vertex to the desired loca-
tion, and click; or enter a value, and
press ENTER.

move the vertex
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Then…If you want to…

press CTRL to switch to the Remove
Vertex edit mode, and click to con-
firm the removal.

remove the vertex

press CTRL twice to switch to the
Offset Edges edit mode. Move the

move the vertex and the adjacent
edges

vertex to the desired location, and
click; or enter a value, and press
ENTER.

5 To exit the surface editing mode, click the Exit Editing Surfaces
grip.

NOTE You cannot create non-rectangular shaped openings on
extruded 3D spaces. If you need a different surface opening shape,
convert the extruded 3D space to a 3D freeform space first as
described in Changing the Type of a Space on page 3026.

Removing Openings from Extruded 3D and 3D Freeform Space
Surfaces

Use this procedure to remove an opening from the surface of a 3D space.

1 Select the space from which you want to remove a surface opening
and display the grips for the surface openings in one of these
ways:

■ If you have selected an extruded 3D space, click the Edit
Surfaces grip. All surface opening grips on the space are
displayed.

■ If you have selected a 3D freeform space, click the Edit Surfaces
grip, and then select the Edit Surface grip for the surface
containing the opening you want to remove. The grips for the
openings on this surface are displayed.
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2 Click the Remove Opening grip for the opening you want to
remove.

Editing Surface Openings in Space/Zone Manager
Use this procedure to edit surface openings.

1 Open the Space/Zone Manager with one of the instructions
described in Opening the Space/Zone Manager on page 3062.

2 Verify that Show Space Surfaces is selected.

3 If necessary expand the tree view to display the surface and the
opening you want to edit.
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4 To add a new opening to a surface, select the surface in the tree
view, right-click, and click Add Opening.

The new opening is inserted with default properties.

5 To change the properties of an opening, select the opening in the
tree view, and make the desired changes on the right:

Then…If you want to…

enter a new value for Name.change the open-
ing name

for Type, select a new type from the drop-down list.
Depending on whether the opening is a door or
window opening, different types are available:

change the open-
ing type

■ Fixed Window

■ Operable Window

■ Fixed Skylight

■ Operable Skylight

■ Non sliding Door

■ Sliding Door

■ Air

select a window style, door style, or door/window
assembly style from the list. The list contains all
styles available in the drawing.

change the as-
signed window or
door/window as-
sembly style of the
opening

enter values for Area, Height, or Width of the
opening.

NOTE For a 3D freeform space opening, you
cannot edit the height or width on this work-
sheet. You can change the width and height
of a 3D freeform surface opening using grips,
as described in Editing the Shape of 3D Free-
form Space Openings on page 3077.

change the area of
a surface opening

For openings in 3D freeform spaces, the reported
area is displayed alongside the overall area. The re-
ported area can differ from the overall area in cases
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Then…If you want to…

where an opening is only partly on the surface, and
the rest is either on a different surface or outside
the space. In this case, the reported area displays
the part of the opening that is on the surface. The
value for reported area is read-only.

6 To remove an opening from a surface, select the opening,
right-click, and click Remove Opening.

7 Click OK.

How Changing the Space Geometry Affects Surface Openings
When you change the geometry of a space, it can have different results for
openings attached to the space surfaces.

Changing the Shape of a 3D Freeform Space

3D freeform spaces have a large number of possible geometries, such as a box,
a pyramid, or an irregular freeform shape. Changing the geometry of the space
can affect openings in space surfaces in the following ways:

■ When a surface is deleted or moved so that it is no longer coplanar to an
opening it contains, the opening will be deleted.

■ When a surface is edited in a way that does not affect the opening, the
opening is retained unchanged.

■ When a surface is split and an opening crosses the split line, the opening
is split into 2 openings.

NOTE If the space geometry is changed in any way that changes the total
number of surfaces, then openings may be deleted or may occasionally move
from one surface to another.

Changing the Geometry Type

You can convert a 3D freeform space to an extruded 3D space, and vice versa.
This will affect contained openings in different ways.
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To change the geometry type of a space, see Changing the Type of a Space on
page 3026.

■ When an extruded 3D space is converted to a 3D freeform space, all
openings will be retained with the same location, shape, and area. The
opening grips change to the grips of an extruded 3D space surface opening.

Viewing Extruded and Freeform space surface openings

■ When a 3D freeform space is converted to an extruded 3D space, the
openings on the horizontal roof or floor surfaces will be kept on the roof
or floor of the extruded 3D space. The openings on the surfaces that
intersect with the base profile will be retained on the respective edge
surfaces. All other openings will be lost. The openings that are retained
will change to rectangles, and the area of the opening will remain the
same.

Viewing Freeform and Extruded space surface openings

■ When an extruded 3D space or a 3D freeform space is changed to a 2D
space, all surface openings are lost.

Changing the Associativity

You can convert associative spaces to non-associative spaces, and vice versa.
This will affect contained openings in different ways.

To change the associativity of spaces, see Making a Space Associative or
Non-Associative on page 2972.
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The openings in associative spaces are generated by any openings that are in
the boundary walls. For example, if a boundary wall has a window and a door,
openings with the shape of the window and door are inserted in the space.

■ If an associative extruded 3D space is converted to a non-associative
extruded 3D space, all openings will be retained in their original position,
but will now have editing grips. If the shape of the original opening is not
rectangular, the opening shape will change to a rectangle identical in area
to the original shape.

■ If an associative 3D freeform space is converted to a non-associative 3D
freeform space, all openings will be retained with identical location, size,
and shape, and will have editing grips.

Setting Up Adjacency Relations between Space Surfaces
Spaces can detect adjacencies between surfaces of neighboring spaces. This is
important for processing a building plan in an engineering application like
AutoCAD MEP. You can define the maximum allowed adjacency distance
between space surfaces.

1 Click  ➤ Options.

2 Click the AEC Object Settings tab.
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3 For Maximum Automatic Adjacency select the maximum allowed
distance between 2 surfaces that should be considered adjacent
to each other.

4 Click OK.

TIP Alternatively, you can set the maximum automatic adjacency
between space surfaces on the command line by entering
AecSpaceMaxAutoAdjacency.

Displaying Adjacency Relations between Space Surfaces
In most cases, adjacency relations between space surfaces are important for
exporting and processing building plans to an engineering application. If you
need to check the status of adjacency relations within AutoCAD Architecture,
you can make the adjacency relations visible in the drawing.
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Displaying surface adjacencies

1 On the command line, enter AecShowSpaceAdjacencies.

2 Adjacent space surfaces are displayed with lines.

3 To hide the surface adjacency lines, press ENTER.

Space Styles
A space style is a set of parameters that determines the appearance and other
characteristics of the space object to which it is assigned. Depending on the
scope of the drawing, you may want to create different space styles to represent
different types of spaces, such as different room types in an office building.

Within the space style you can set up the space decomposition. Decomposition
geometrically divides an existing space into triangular or trapezoid subparts.
In some countries, such as Germany and Japan, the visual decomposition of
spaces into subdivisions is needed for the space proof that must be presented
to the building administration for approval.

You can use styles for controlling the following aspects of spaces:

■ Boundary offsets: You can specify the distance that a space's net, usable,
and gross boundaries will be offset from its base boundary. Each boundary
has its own display components that you can set according to your needs.

■ Name lists: You can select a list of allowed names for spaces of a particular
style. This helps you to maintain consistent naming schemes across a
building project.
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■ Target dimensions: You can define a target area, length, and width for
spaces inserted with a specific style. This is helpful when you have upper
and lower space limits for a type of room that you want to insert.

■ Displaying different space types: You can draw construction spaces,
demolition spaces, and traffic spaces with different display properties. For
example, you might draw all construction areas in green and hatched, and
the traffic areas in blue with a solid fill.

■ Displaying different decomposition methods: You can specify how spaces
are decomposed (trapezoid or triangular). If you are not working with space
decomposition extensively, you will probably set it up in the drawing
default. For information about space decomposition, see Space
Decomposition on page 3171.

Creating a Space Style
Use this procedure to create a space style. You can start by using the default
style or you can copy an existing style to use as your template. You then edit
the style properties to customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Architectural Objects, and expand Space Styles.

3 Create a space style:

Then…If you want to…

right-click Space Styles, and click
New.

create a style with default properties

right-click the space style you want
to copy, and click Copy. Right-click,
and click Paste.

create a style from an existing style

4 Enter a name for the new space style, and press ENTER.

5 Edit the new space style:

Then…If you want to…

see Specifying Target Dimensions
for the Space on page 3095.

define target dimensions for the
space base boundary
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Then…If you want to…

see Specifying Space Boundary
Offsets in a Space Style on page 3096.

specify style-based offsets for the
net, usable, and gross boundaries

see Attaching a List Definition to a
Space Style on page 3097.

add a list definition to the style

see Specifying the Materials of a
Space Style on page 3098.

specify materials for space compon-
ents

see Specifying Classifications for a
Space Style on page 3098.

add a classification to the style

see Specifying the Display Proper-
ties of a Space Style on page 3101.

set the display of space boundaries
and calculation cut planes

see Specifying the Hatching for
Components of a Space Style on
page 3104.

define the hatching of the space

see Setting the Object Cut Plane of
a Space Style on page 3106.

define the cut plane for the space

see Attaching Notes and Files to a
Space Style on page 3107.

attach notes and files to the style

see Space Decomposition on page
3171.

specify a space decomposition view

6 When you finish specifying properties, click OK.

Specifying Target Dimensions for the Space
Use this procedure to specify a target area for the space in the space style.
Target dimensions can be useful when dimension requirements for a space
are already known and cannot be exceeded. If the area, length, or width of a
space you insert falls outside the sizes specified in the style, the dimension is
truncated to the target size, and a solution tip icon displays.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .
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2 Expand Architectural Objects, and expand Space Styles.

3 Select the space style that you want to change.

4 Click the Design Rules tab.

5 Specify the target dimensions for the space style:

Then…If you want to…

enter a new value for Target Area,
Min Area, or Max Area.

specify a different area

enter a new value for Target
Length, Min Length, or Max
Length.

specify a different length

enter a new value for Target Width,
Min Width, or Max Width.

specify a different width

Target values must fall between the set minimum and maximum
values.

6 Click OK twice.

Specifying Space Boundary Offsets in a Space Style
Use this procedure to define the offsets of the net, usable, and gross boundaries
of a space from the base boundary in the space style. Space boundary offsets
can also be set manually. When the net, usable, and gross boundaries of a
space are determined manually, they can be grip-edited. When they are
determined from the space style, they cannot be grip-edited.

For information about applying style-based offsets to a space, see Specifying
Space Boundary Offsets in a Space Style on page 3096.

Space boundaries by style

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Space Styles.

3 Select the space style that you want to change.
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4 Click the Design Rules tab.

5 Specify the distance to offset the net, usable, and gross boundaries
from the base boundary:

Then…If you want to…

enter a value for Net Offset.

NOTE In many calculations, the
net boundary is identical to the
base boundary. If you enter 0 for
the Net Offset, the net boundary
is not offset from the base bound-
ary.

offset the net boundary from the
base boundary

enter a value for Usable Offset.offset the usable boundary from
the base boundary

enter a value for Gross Offset.offset the gross boundary from
the base boundary

6 Click OK.

Attaching a List Definition to a Space Style
Use this procedure to attach a list definition to a space style so that spaces
using the style are named consistently according to a defined list of names.
List definitions can be created according to government standards, company
standards, or any other naming system you want to implement. For
information about creating list definitions, see List Definitions on page 3109.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Space Styles.

3 Select the space style that you want to change.

4 Click the Design Rules tab.

5 For Space Names, select a list definition from the drop-down list.

NOTE The drop-down list displays only list definitions that apply to
spaces. For more information, see Specifying the Application for a
List Definition on page 3111.

Attaching a List Definition to a Space Style | 3097



6 Click OK.

When you change the name list in the space style, it is possible that the new
space style has a different name list. In this case, the space name can interact
with the new list definition in the following ways:

■ The name of an existing space is also included in the new list definition.
In this case, no change to the name is made.

■ The name of an existing space is not included in the new list definition,
but the list definition allows individual names to differ from the list. In
this case, the existing name is retained as a non-standard name.

■ The name of an existing space is not included in the new list definition,
and the list definition does not allow individual names to differ from the
list. In this case, the existing name is removed and the space name defaults
to the first name in the new list definition.

Specifying Classifications for a Space Style
Use this procedure to specify classifications for any classification definition
applied to a space style.

For more information about creating and applying classification definitions,
see Classification Definitions on page 3872.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Space Styles.

3 Select the space style that you want to change.

4 Click the Classifications tab.

By default, the classification for all classification definitions is
Unspecified. If no classification definitions are listed, none are
applied to space styles.

5 For each classification definition, select the classification you want
to apply to the current space style.

6 Click OK.

Specifying the Materials of a Space Style
A space consists of a number of components whose display properties can be
determined by the materials assigned to each component.
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When you assign materials to a space style, you assign one material to each
physical component of the space. For example, you assign a wood material
to the floor and a ceiling tile material to the ceiling.

If you want to use the display properties of the space style, you can turn off
the material assignments in the display properties of the space style.

Material definitions consist of display components that correspond to
component types of objects. For example, the Linework component of a
material is used for all linework in plan view. The Surface Hatch component
is used to hatch all object surfaces in 3 dimensional (3D) model views and in
elevations.

Space Materials and Display Components
The following table lists space components and the material components that
determine them in specific views.

Material ComponentSpace ComponentDisplay Representation

Plan, Plan High Detail,
Plan Low Detail, Plan
Presentation, Plan
Screened, Reflected, Re-
flected Screened

Plan LineworkBase Boundary

Plan HatchBase Hatch

No materialNet Boundary

No materialNet Hatch

No materialUsable Boundary

No materialUsable Hatch

No materialGross Boundary

No materialGross Hatch

No materialCut Plane
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Material ComponentSpace ComponentDisplay Representation

No materialCut Plane Hatch

No materialAbove Cut Plane

No materialBelow Cut Plane

No materialCalculation Plane 1

No materialCalculation Plane 1 Hatch

No materialCalculation Plane

No materialCalculation Plane Hatch

Model

3D BodyFloor

3D BodyCeiling

No materialNet Volume

No materialSurfaces

No materialSurface Components

No materialUsable Volume

No materialGross Volume

Assigning Materials to a Space Style
Use this procedure to assign materials to individual components of a space
style. The component may use the display properties of the material instead
of the style display properties.

You can assign a material to any physical component of the space. Custom
components and components that are only symbolic graphics do not use
materials for their display properties. For example, the floor and ceiling are
physical components. The gross boundary is a symbolic component.
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NOTE If a material assignment does not determine the display properties of a
space component, you can change the display properties of the space style as
described in Specifying the Display Properties of a Space Style on page 3101.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Space Styles.

3 Select the space style that you want to change.

4 Click the Materials tab.

5 Select the component you want to change, and select a different
material definition.

You can select any material definition in the current drawing, or

click  to create a new material definition and assign it to a
component.

WARNING Any changes you make to the material definition in this
dialog will apply to all objects that are assigned the material.

6 Click the Display Properties tab.

7 Select the display representation where you want the changes to
appear, and select Style Override.

8 If necessary, click  .

9 Click the Layer/Color/Linetype tab.

10 Select By Material for any component to which you want to assign
a material, and click OK.

If the setting for By Material is not available, the display of this
component cannot be determined by a material.

11 Click OK.

Specifying the Display Properties of a Space Style
Use this procedure to define any of the following display components of a
space in the style:

■ Space boundaries (Plan views): You can set the display of the base, net,
usable, and gross boundaries. If boundaries are offset from each other, it
is a good idea to differentiate them by color, linetype, or lineweight. If you
do not need boundary offsets, you could also hide the net, usable, and
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gross boundaries and their respective hatches, so as not to clutter the
drawing.

■ Boundary hatches (Plan views): Each space boundary has an associated
hatch that you can display.

■ Above and Below Cut Plane components (Plan views): If the space is cut
by an object cut plane, you can define different visuals for the parts that
lie above the cut plane and below the cut plane.

■ Calculation cut planes and hatches (Plan views): For 3D freeform spaces,
2 calculation cut planes can be set. This helps to create evaluations of
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non-uniform space heights. For each of the calculation cut planes, you
can set a boundary display and a hatch.

■ Floor and ceiling components (Model views): 3D spaces can have floors
and ceilings with a user-specified thickness. You can display them in a
model view.

NOTE If the thickness of the ceiling or floor component is set to 0, it does not
display in the drawing.

Floor and ceiling components in Model view

■ Surfaces and surface components (Model views): 3D freeform spaces are
composed of individual surfaces, which can have additional components
like door and window openings.

Space surface with surface openings
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NOTE If a material assignment determines the display properties of components
in the space style, you can change the properties of the display component by
clearing By Material. You can also override the material assignment with a different
material. For more information, see Specifying the Materials of a Space Style on
page 3098.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Space Styles.

3 Select the space style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 Click the Layer/Color/Linetype tab.

7 Select the space component to change, and change the following
settings:

■ Material: If you select By Material, all display settings are taken
from the assigned material. Components that cannot be set
by material have the check box deactivated.

■ Visibility

■ Layer

■ Color

■ Linetype/Lineweight/Linetype Scale

■ Plot Style

8 Click OK.

Specifying the Hatching for Components of a Space Style
Use this procedure to specify the hatching for display components of a space
style. Space hatching is displayed only in display representations that represent
a Plan view.

The following hatch components are available for spaces:

■ Base hatch: the hatch component for the base boundary of a space.

■ Net hatch: the hatch component for the net boundary of a space.
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■ Usable hatch: the hatch component for the usable boundary of a space.

■ Gross hatch: the hatch component for the gross boundary of a space.

■ Cut Plane hatch: the hatch for the object cut plane. This cut plane is
different from the calculation cut planes you can set for 3D freeform spaces.

■ Calculation Cut Plane Hatch (1 and 2): If you define calculation cut planes
for a 3D freeform space, you can add a hatch to the calculation cut plane
boundary.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Space Styles.

3 Select the space style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and click Style Override.

The display representation in bold is the current display
representation.

6 Click the Hatching tab.

7 Select a display component, and click the setting for Pattern.

8 Select the hatching for the display component:

Then…If you want

select Predefined for Type, and then
select a pattern.

a hatching pattern that is available
in the software

select Custom for Type, and then
enter the name of the custom pat-

a custom pattern

tern. If necessary, click Browse, and
navigate to the folder where the
custom pattern file is located.

select User-defined for Type, and
clear Double Hatch.

single hatching

select User-defined for Type, and
select Double Hatch.

double hatching

select Solid Fill for Type.solid fill
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9 Click OK.

10 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

11 Click Angle, and enter the angle for the selected pattern.

12 Click Orientation, and specify how the hatching is oriented:

Then…If you want to…

select Object.orient the hatching to the object,
regardless of the object rotation

select Global.orient the hatching to the World
Coordinate System

13 Click OK.

Setting the Object Cut Plane of a Space Style
Use this procedure to set the object cut plane of a space style.

The object cut plane of a space is used to display the space in Plan views at a
defined cut height. It is unrelated to the calculation cut planes you can set
for 3D freeform spaces. The object cut plane cannot, for example, be used in
scheduling properties or in a space calculation. In most cases the cut plane of
a space is determined by the cut plane of the display configuration of the
current view. You can set up a different cut plane for individual spaces, if
necessary.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Space Styles.

3 Select the space style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and click Style Override.

The display representation in bold is the current display
representation.

6 Click the Other tab.

7 To use the cut plane defined in the display configuration, verify
that Override Display Configuration Cut Plane is cleared.
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8 To define a cut plane differing from the cut plane of the display
configuration, select Override Display Configuration Cut Plane,
and enter the desired height for Cut Plane Height.

9 Click OK.

Attaching Notes and Files to a Space Style
Use this procedure to enter notes and attach reference files to a space style.
You can also edit notes and edit or detach reference files from a space style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Space Styles.

3 Select the space style that you want to change.

4 Click the General tab.

5 To add a description to the space style, enter it for Description.

6 Click Notes.

7 To add a note, click the Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

9 Click OK twice.
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Converting Area Styles to Space Styles
If you open a drawing from a previous version of AutoCAD Architecture that
has area styles in it, the area styles will be automatically converted to space
styles. The following settings will be converted:

Value/Default valueSpace style propertyArea style property

Existing valueNameName

Existing valueDescriptionDescription

Existing valueKeynoteKeynote

Existing notes and attached doc-
uments

Notes/Reference DocsNotes/Reference Docs

Area property sets are converted
to space property sets and at-

Property SetsProperty Sets

tached to the converted space
style

Standard

NOTE In older versions of Auto-
CAD Architecture, list definitions
were attached to area groups or
area group templates. Now, list
definitions are attached either to
the space style or to the zone
style.

List DefinitionN/A

DefaultTarget AreaN/A

DefaultTarget LengthN/A

DefaultTarget WithN/A

0Net OffsetN/A

0Usable OffsetN/A

0Gross OffsetN/A
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Value/Default valueSpace style propertyArea style property

StandardFloor MaterialN/A

StandardCeiling MaterialN/A

Existing classification values.

NOTE Area classification defini-
tions from older versions of
AutoCAD Architecture are conver-
ted to space classification defini-
tions and applied to converted
space styles.

ClassificationsClassifications

Display Representa-
tions

Drawing DefaultModelN/A

Existing settingsPlanPlan

Existing settingsPlan High DetailPlan High Detail

Existing settingsPlan Low DetailPlan Low Detail

Drawing DefaultPlan PresentationN/A

Drawing DefaultPlan ScreenedN/A

Drawing DefaultReflectedN/A

Drawing DefaultReflected ScreenedN/A

Drawing DefaultVolumeN/A

Existing settingsDecomposedDecomposed

List Definitions
A list definition is a list of names that may be used as allowed names for spaces
or zones. List definitions can be attached to a space style or a zone style, so
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that the list of names is available on the Properties palette when you create
or edit a space or zone with that style.

For more information see Attaching a List Definition to a Space Style on page
3097 and Attaching a List Definition to a Zone Style on page 3140.

List definition for a space

For a description of the typical workflow for list definitions, see Working with
List Definitions - Overview on page 2923.

List definitions are useful when you create spaces according to government
or company standards.

When you change the name list in a space or zone style, a space or zone name
can interact with the new list definition in the following ways:

■ The existing name is also included in the new list definition. In this case,
no change to the space name is made.

■ The existing name is not included in the new list definition, but the list
definition allows individual names to differ from the list. In this case, the
existing name is retained as a non-standard name.

■ The existing name is not included in the new list definition, and the list
definition does not allow individual names to differ from the list. In this
case, the existing name is removed and the name defaults to the first name
in the new list definition.
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Creating a List Definition
Use this procedure to create a list definition that can be attached to a space
or zone style to specify the allowable values for the name property.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand List Definitions.

3 Create a new list definition:

Then…If you want to…

right-click List Definitions, and click
New.

create a new list definition with de-
fault properties

right-click the list you want to copy,
and click Copy. Right-click, and
click Paste.

create a new list definition from an
existing list definition

4 Enter a name for the list definition, and press ENTER.

5 Edit the properties of your new list:

Then…If you want to…

see Specifying the Application for a
List Definition on page 3111.

define the objects the list definition
applies to

see Editing a List Definition on page
3112.

edit the list definition

see Attaching Notes and Files to a
List Definition on page 3112.

add notes or files to the definition

6 Click OK.

Specifying the Application for a List Definition
You can create list definitions that apply to spaces names, to zone names, or
that can be used as drop-down lists for manual scheduling properties. For
information on manual scheduling properties, see Entering Manual Properties
and Fields for Objects on page 3812.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .
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2 Expand Multi-Purpose Objects, and expand List Definitions.

3 Select the definition you want to edit.

4 Click the Applies to tab.

5 Select one or more of the following options:

■ Spaces: (If you want the list to be available for space names)

■ Zones: (If you want the list to be available for zone names)

■ Manual Property Definition: (If you want the list to be available
for manual schedule properties)

6 Click OK.

Editing a List Definition
Use this procedure to edit a list definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand List Definitions.

3 Select the list you want to edit.

4 Click the Items tab.

5 Add, delete, or rename entries in the list definition:

Then…If you want to…

click Add, and enter the name of
the entry.

add a new entry to the list

select the entry, and click Remove.delete an entry from the list

select the entry, and enter the new
name.

rename an entry in the list

6 If you want users to have the alternative of entering a non-list
name for the space or zone, select Allow individual property values
to vary from this list.

7 Click OK.

Attaching Notes and Files to a List Definition
Use this procedure to attach text notes and files to a list definition.
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1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand List Definitions.

3 Select the list definition for which you want to add a note or file.

4 Click the General tab.

5 To add a description to the list, enter the description for
Description.

6 Click Notes.

7 To add a note, click the Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click
Open.

attach a reference file

select the file, and click Edit. Edit
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application. Close the

edit a reference file

application when you are done
editing.

select the file name, click Delete,
and click OK.

detach a reference file

9 Click OK.

Zones
In AutoCAD Architecture, a zone is a container in which you can group spaces
and other zones. You need zones to create an evaluation of your floor plan.
With zones, you structure spaces into various groups, according to different
schemes. For example, you can have functional zones (construction, traffic,
and so on) or zones for building units (Apartment 1 Ground Floor, Apartment 2
Ground Floor, and so on.)

Spaces can be contained in more than one zone. For example, you can attach
a balcony space to both the Construction Spaces group and the Apartment 1
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Ground Floor group. You can set up a restriction in the zone style, so that a
space can only be attached to one zone of a specific style.

Spaces attached to zones

A zone can have list definitions and calculation modifiers attached. List
definitions are attached through the zone style, whereas calculation modifiers
are attached directly to the zone.

Zone Templates

Zones can be connected and nested into complex structures. A zone structure
for a building, for example, may have one top-level zone named “Building.”
Below that zone would a be a number of zones for apartments— the apartment
1 zone, the apartment 2 zone, and so on. The individual apartment zones can
contain other zones like a construction areas zone, a 50% deduction zone, or
spaces like the living room, the bedroom, and so on.

When you often need a complex zone structure, you can create a zone template
that defines the necessary zones and their grouping. For example, when
designing a new building, you can insert a zone structure based on a Building
zone template, which would contain the main building zone plus all
subordinate zones. A number of predefined zone templates are provided with
the software.

Zones in the Space Evaluation

When you create a space evaluation of the floor plan, you can specify which
zones are included.

For example, if you wanted to create a space evaluation for a single apartment
in a building to determine the area and set the rent accordingly, you would
select the zone representing that apartment. Within the same drawing you
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might also want to create an evaluation that contains only bathrooms, to
determine how many tiles to order from a supplier. To do this you would first
create a bathrooms zone, add all bathrooms from all apartments to it, and
then evaluate the overall area of that zone.

For information about space evaluations of the floor plan, see Space Evaluation
on page 3177.

Zone Attachments Across External References

You can attach spaces or zones from an external reference to a zone in the
current drawing. You cannot however, attach spaces and zones in the current
drawing to zones in an external reference. If you detach an external reference
from which spaces or zones have been attached to a zone in the current
drawing, those spaces or zones are also detached. If you re-attach the external
reference to the current drawing, you would need to manually re-attach the
spaces and zones from the external reference, if desired.

Using Zone Tools to Create Zones
Tools provided with AutoCAD Architecture let you quickly place zones by
selecting a zone tool with a specific zone style and other predefined properties.
When you place zones using zone tools, you can use the default settings of
the tool, or you can change settings for the zone properties. You can also use
zone tools to apply the settings of a zone tool to existing zones.

Tool palettes containing zone tools

The default tool palettes in the workspace contain sample zone tools that you
can use and customize as needed. In addition, the following catalogs provided
with the software contain zone tools that you can add to your tool palettes:

■ Stock Tool catalog
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■ Sample Palette catalog

Custom palettes created by your CAD manager or other users may also contain
zone tools with zone styles and properties that are customized for your projects
or office standards.

Zone Properties
In AutoCAD Architecture, a zone is a documentation object that is used to
group and organize spaces. The following table describes the properties that
are displayed for a zone in the Properties palette.

DescriptionZone Property

General Category

User-specified description of the zone objectDescription

Specifies the layer on which the zone is placed.
By default, the layer assignment is defined in
the zone style.

Layer

Specifies the zone style. The style defined in
the zone tool is the default.

Style

The name of the zone. If a list definition has
been specified in the zone style, the list is

Name

available as a drop-down list. For more inform-
ation, see Attaching a List Definition to a Zone
Style on page 3140.

Specifies a zone tag to be inserted when
adding the zone. Zone tags are available in the

Tag

sample drawings shipped with the software.
You can also create your own zone tags.

NOTE This property is available only during
adding a zone.

Identifies any calculation modifiers for the
zone. A calculation modifier is a formula that

Calculation Modifiers

modifies selected values of spaces attached to
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DescriptionZone Property

the zone. For more information, see Calculation
Modifiers on page 3163.

Displays the number of spaces that are directly
attached to the zone.

Number of Spaces

Displays the number of spaces that are directly
attached to the zone plus the number of spaces

Total number of spaces

that are attached indirectly through subzones
of the zone.

Displays the number of zones that are directly
attached to the zone.

Number of Zones

Displays the number of zones that are attached
directly to the zone plus the number of zones

Total number of zones

that are attached through subzones of the
zone.

An icon providing access to the Space/Zone
Manager worksheet where you can rename

Space/Zone Manager

zones, attach spaces and zones, define the
content model of the zone, and attach calcula-
tion modifiers.

Dimensions Category

Displays the combined base area of all spaces
attached to the zone.

Base area

Displays the base area of all spaces attached
to the zone processed with any calculation
modifiers attached to the zone.

Calculated area

Displays the combined base perimeter of all
spaces attached directly or indirectly to the
zone.

Base perimeter

Displays the base perimeter of all spaces at-
tached to the zone processed with any calcula-
tion modifiers attached to the zone.

Calculated perimeter
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DescriptionZone Property

Displays the combined base volume of all
spaces attached directly or indirectly to the
zone.

Base volume

Specifies the offset distance for the zone
boundary that is drawn around any space at-

Zone Boundary Offset

tached to the zone to show the space/zones
relationship.

Calculation Category

Specifies whether the area of spaces that are
attached to the zone will be calculated using
any applicable calculation modifiers.

Calculate area

Specifies whether the perimeter of spaces that
are attached to the zone will be calculated us-
ing any applicable calculation modifiers.

Calculate perimeter

Content

This property defines that the zone is allowed
to have spaces directly attached.

Can contain spaces

This property defines that the zone is allowed
to have zones attached.

NOTE If you select both content options, the
zone can contain spaces and zones.

Can contain zones

Location

Specifies the rotation of the zone.Rotation

Specifies the elevation of the zone.Elevation

Specifies the location and coordinate system
of the zone.

Additional Information
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Creating a Zone
Use this procedure to add a new a zone that has the properties specified in
the zone tool that you select. To specify settings when you add a zone, see
Creating Zones with User-Specified Settings on page 3119.

1 Open the tool palette that contains the Zone tool you want to
use, and select it.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Space

drop-down ➤ Zone  .

2 Specify the insertion point of the zone.

You can move or hide the Properties palette to expose more of
the drawing area.

3 Continue adding zones as needed, and then press ENTER.

Creating Zones with User-Specified Settings
Use this procedure to add a zone with settings that you specify.

1 Open the tool palette that contains the Zone tool you want to
use, and select it.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Space

drop-down ➤ Zone  .

2 On the Properties palette, expand Basic, and expand General.

3 Enter a name for the zone.
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If you have assigned a list definition to the zone style, you can
select a name from the drop-down list.

4 Select a style.

5 Select a tag for the zone.

NOTE If no zone tags are contained in the list, you can drag a tag
into the drawing from the Content Browser. You can also create your
own tags from multi-view blocks.

6 To add a calculation modifier to the zone, click the setting for
Calculation Modifiers, and select one or more calculation modifiers
for the zone.

If you assign a calculation modifier to a zone, the area and
perimeter values of spaces attached to the zone will be modified
with the calculation modifier. For information about calculation
modifiers, see Calculation Modifiers on page 3163.

7 Expand Dimensions.

8 For Zone boundary offset, enter a value to specify the distance
you want between the zone boundary and the base boundary of
any attached space.

If you select 0 offset, the zone boundary is identical to the base
boundary of the space.

Zone boundary offset at 0 (left) and at an offset value (right)

TIP If you cannot see the zone boundary, the display component for
the zone boundary may not be activated in the zone style. For more
information, see Specifying the Layer, Color, and Linetype Properties
of a Zone Style on page 3142.

9 Expand Calculation.
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10 Specify which space values should be calculated in the zone:

Then…If you want to …

select Yes for Calculate Area.calculate the area values of attached
spaces including any applicable
calculation modifiers

select Yes for Calculate Perimeter.calculate the perimeter values of
attached spaces including any ap-
plicable calculation modifiers

For information about space evaluations, see Space Evaluation on
page 3177.

11 Expand Content.

12 Define the content allowed in the zone:

Then…If you want to …

select Yes for Can Contain Spaces.allow spaces to be attached to the
zone

select Yes for Can Contain Zones.allow zones to be attached to the
zone

13 In the drawing area, specify the insertion point of the zone.

You can move or hide the Properties palette to expose more of
the drawing area.

14 Continue adding zones as needed, and then press ENTER.

Creating Zone Structures from a Zone Template
Use this procedure to create zone structures based on a zone template. This
procedure is recommended if you use the same zone structure frequently.

When you add a zone structure, all zones that are connected in that structure
are inserted in the drawing. Depending on the style settings for the zone
template, you can display individual zones with different color and hatch.
You can also display zone connection lines. Below is an example for a zone
structure representing the DIN 277 building norm.
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Zones according to DIN277 zone template

For information about creating zone templates, see Zone Templates on page
3150.

1 Open the tool palette that contains the Zone from Template tool
you want to use, and select it.

(You may have to scroll to display the desired tool.)

2 On the Properties palette, expand Basic, and expand General.

3 Select the zone template you want to create a structure of zones
from.

4 Define the offsets between individual zones in the structure:

Then…If you want to…

enter a value for Row Offset.define the offset between rows of
the zone structure

enter a value for Column Offset.define the offset between columns
of the zone structure

5 In the drawing area, specify the insertion point of the zone
structure.

You can move or hide the Properties palette to expose more of
the drawing area.

6 Continue adding zone structures from the template as needed,
and then press ENTER.
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Creating a Zone Tool
Use this procedure to create a zone tool and add it to a tool palette. You may
want to create your own zone tools if you are placing multiple zones with
specific properties that you want to be the same for each instance.

For example, if you are creating an office floor plan with different calculation
types for zones, you can create a zone tool for each calculation type.

1 Open the tool palette where you want to create a tool.

2 Create the tool:

Then…If you want to…

select the zone, and drag it to the
tool palette.

create a tool from a zone in the
drawing

click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from an zone style in
the Style Manager

the style you want to copy, and
drag it to the tool palette. Click OK
to close the Style Manager.

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the palette where you want
to add the tool, right-click, and click
Paste.

click Home tab ➤ Build pan-

el ➤ Tools drop-down ➤ Content

copy a tool from a tool catalog

Browser , and locate the tool
you want to copy. Position the
cursor over the i-drop handle, and
drag the tool to the tool palette.

3 Right-click the new zone tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.
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6 Expand Basic, and expand General.

7 Click the setting for Description, enter a description of the zone
created from this tool, and click OK.

8 Specify a layer key and any layer key overrides if you do not want
to use the layer assignments specified in the layer key style used
in the drawing.

9 Select a zone style.

10 Select the drawing file containing the style used for this zone tool.

11 Select a tag for the zone.

12 Select the drawing file containing the tag used for this zone tool.

13 Expand Dimensions.

14 Enter the distance you want the zone boundary to be offset from
attached spaces.

15 Expand Calculation.

16 Specify which values will be calculated for zones created from this
tool:

Then…If you want to …

select Yes for Calculate Area.calculate the area of attached
spaces

select Yes for Calculate Perimeter.calculate the perimeter of attached
spaces

17 Expand Content.

18 Define the allowed content in the zone tool:

Then…If you want to …

select Yes for Can contain spaces.allow spaces to be attached to
zones created from this tool

select Yes for Can contain zones.allow zones to be attached to zones
created from this tool

For information about zone content, see Changing the Content
Rules of a Zone on page 3131.

19 Click OK.
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Converting Area Groups to Zones
Area groups in legacy drawings are automatically converted to zones when
you open the drawing in the current version of AutoCAD Architecture. The
following table maps area group properties to zone properties:

Value/Default ValueNew zone propertyLegacy area group
property

Existing value

NOTE Name lists that were at-
tached to the area group are not
re-attached to the zone. To use
a converted legacy name list, you
must attach it to the zone style.

NameName

Existing valueDescriptionDescription

Existing layerLayerLayer

Area group style is converted to
zone style. Properties are

StyleStyle

matched where possible; new
properties have default values.
For more information, see Con-
verting Area Group Styles to Zone
Styles on page 3148.

Existing modifierCalculation modifiersCalculation modifiers

Existing valueNumber of spacesN/A

Existing valueTotal number of spacesN/A

Existing valueNumber of zonesN/A

Existing valueTotal number of zonesN/A

Existing valueBase areaNet area

Existing valueCalculated areaCalculated area

Existing valueBase perimeterNet perimeter
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Value/Default ValueNew zone propertyLegacy area group
property

Existing valueCalculated perimeterCalculated perimeter

0Base volumeN/A

Default valueZone boundary offsetN/A

Existing valueCalculate areaCalculate area

Existing valueCalculate perimeterCalculate perimeter

Existing valueCan contain spacesCan contain areas

Existing valueCan contain zonesCan contain area
groups

Existing valueRotationRotation

Existing valueElevationElevation

Existing valuesAdditional information
(Location)

Additional information
(Location)

NOTE If you are converting a legacy zone structure, and connections between
zones are not converted correctly, it is possible that the source drawing contained
an error in the content rules for the parent zone. In cases like this, verify that the
content rules of the parent zone allow attaching zones, as described in Changing
the Content Rules of a Zone on page 3131, and then re-attach the lost zones as
described in Attaching Spaces and Zones to Zones on page 3127.

Zones and Spaces
Zones are used to group spaces and subordinate zones.
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Attaching Spaces and Zones to Zones
Use this procedure to attach spaces and zones to a selected zone.

NOTE You can attach spaces and zones to zones inside blocks, or attach spaces
or zones inside a block to a zone outside the block, but if the blocks are exploded
the attachments will be removed.

Connections of spaces and zones are not unique. You can attach a space or a
zone to any number of different zones, unless you place restrictions on
space/zone and zone/zone attachments in the zone, style:

■ You can specify that a space can only be attached to one zone of the same
style. That would prevent a space from being calculated multiple times, as
in a case where you do not want the same room to be attached to multiple
apartment zones.

■ You can specify that zones of this style can only be attached to other zones
of the same style. This would be useful for Building Systems applications
where you want to generate HVAC and Lighting zones, but do not want
to allow a zone of one kind to be attached to a zone of the other kind.

For more information, see Restricting the Content of a Zone Based on the
Zone Style on page 3141.

In the properties of a zone, you can restrict the type of objects can be attached
to the zone, allowing only spaces or only zones. For more information, see
Changing the Content Rules of a Zone on page 3131.

When you attach a zone to another zone, it is attached as a subzone to the
first zone.

1 Select the zone to which you want to attach a space or zone.
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2 Attach the space or zone to the selected zone in one of the
following ways:

■ Click the Add (Plus) grip on the zone, and select spaces and
zones to attach.

■ Click Zone tab ➤ Modify panel ➤ Attach  .

3 Press ENTER.

Detaching Spaces and Zones from Zones
Use this procedure to detach spaces and zones from a zone.

You can detach only directly attached spaces or zones.

1 Select the zone from which you want to detach a space or zone.

2 Detach the space or zone in one of the following ways:

■ Click the Detach (Minus) grip on the connection line to the
attached space or zone.

■ Click Zone tab ➤ Modify panel ➤ Detach  . Then, select
the space or zone you want to detach from the zone, and press
ENTER.

Selecting Spaces and Zones Attached to a Zone
Use this procedure to select the spaces and zones that are attached to a zone.

1 Select a zone that has zones or spaces attached to it.

2 Click Zone tab ➤ Modify panel ➤ Select Attached  .
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The spaces and zones that are attached to the zone are selected
in the drawing.

NOTE Spaces and zones that are located in an external reference will
be highlighted, but not selected.

Editing Zones
You can use either of the following methods to change zone properties such
as the ones that control the allowed content for the zone, the types of
calculation performed, and the calculation modifiers applied:

■ You can change zone settings on the Properties palette.

■ You can select editing commands from the context menu for a selected
zone.

Renaming a Zone
Use this procedure to rename a zone.

If a list definition has been attached to the zone style, you can choose a name
from the list. A list definition can either be restrictive and allow only names
selected from the list, or it can allow you to enter a name of your choice. For
more information, see List Definitions on page 3109.

1 Double-click the zone you want to rename.

2 On the Properties palette, expand Basic, and expand General.

3 For Name, do one of the following:

■ Select a name from the list.

■ Enter a name.

Changing the Zone Style
Use this procedure to change the style associated with a zone. Zone styles
contain information about the content rules of the zone and the display of
the zone and its attached zones and spaces. You can also add classifications
here. For information about how to define zone styles, see Zone Styles on page
3138.
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1 Select one or more zones, and double-click one of them.

2 Expand Basic, and expand General.

3 Select a new zone style.

When you change the zone style, it is possible that the new zone style has a
different name list definition. In this case, the zone name can interact with
the new list definition in the following ways:

■ The existing name of the zone is also included in the new list definition.
In this case, no change to the zone name is made.

■ The existing name of the zone is not included in the new list definition,
but the list definition allows individual names to differ from the list. In
this case, the existing zone name is retained as a non-standard name.

■ The existing name of the zone is not included in the new list definition,
and the list definition does not allow individual names to differ from the
list. In this case, the existing zone name is removed and the zone name
defaults to the first name in the new list definition.

For more information about list definitions, see List Definitions on page 3109.

Changing the Zone Boundary Offset
Use this procedure to redefine the offset of the zone boundary from its attached
spaces.

The zone boundary is a boundary around a space attached to a zone. It helps
to display the connections between spaces and zones. You can use it in addition
to the zone connection line, or instead of it. For information on displaying
and hiding the zone connection line and the zone boundary, see Specifying
the Layer, Color, and Linetype Properties of a Zone Style on page 3142.

Zone boundary offset at 0 (left) and at an offset value (right)
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If you define a zone boundary offset at 0, the boundary is drawn on top of
the space base boundary. Depending on the draw order, it is possible that the
zone boundary is invisible because it is underneath the space base boundary.
To avoid this effect, define an offset greater than 0.

1 Select one or more zones, and double-click one of them.

2 Expand Dimensions.

3 For Zone boundary offset, enter the desired offset from the base
boundary of the attached spaces.

TIP If you cannot see the zone boundary, the display component for
the zone boundary may not be activated in the zone style. For more
information, see Specifying the Layer, Color, and Linetype Properties
of a Zone Style on page 3142.

Changing the Content Rules of a Zone
Use this procedure to redefine the allowed content for the zone as spaces only,
zones only, or both types of object.

NOTE You can set additional content restrictions in the zone style. For more
information, see Restricting the Content of a Zone Based on the Zone Style on
page 3141.

1 Select one or more zones, and double-click one of them.

2 Expand Content.

3 Define the allowed content in the zone:

Then…If you want to …

select Yes for Can Contain Spaces.allow spaces to be attached to the
zone

select Yes for Can Contain Zones.allow zones to be attached to the
zone

Changing the Calculation Type of a Zone
Use this procedure to change the type of calculation (area, perimeter, or both)
to be performed for spaces attached to a zone.
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When you create zones from a zone template, the calculation type for each
zone is predefined in the zone template. For more information, see Zone
Templates on page 3150.

1 Select one or more zones, and double-click one of them.

2 Expand Calculation.

3 Specify the types of calculation to be performed for this zone:

Then…If you want to …

select Yes for Calculate Area.calculate the base area values of at-
tached spaces

select Yes for Calculate Perimeter.calculate the base perimeter values
of attached spaces

4 Click Close.

Changing Calculation Modifiers for a Zone
Use this procedure to add, remove, or sort calculation modifiers for a zone.

By default, a calculation modifier is applied only to the base area and base
perimeter of spaces attached to a zone. To apply the modifier to the net, usable,
and gross boundaries of an attached space, you need to create and apply a
property set definition that contains properties for the calculated area and
perimeter values of these 3 boundaries. For more information, see Property
Set Definitions on page 3823

For information about creating calculation modifiers, see Calculation Modifiers
on page 3163.

1 Select the zones you want to change, and double-click one of
them.

2 Expand Basic, and expand General.

3 Click the setting for Calculation modifiers.

NOTE This setting can be edited for multiple zones only if these zones
have the same modifiers attached in the same order.
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4 Attach or detach calculation modifiers:

Then …If you want to…

for Available, select the desired cal-
culation modifier style, and click

 .

attach a calculation modifier style

for Attached, select the desired cal-
culation modifier style, and click

 .

detach a calculation modifier style

for Attached, select the calculation
modifier style to move to a different

rearrange the order of attached
calculation modifier styles

position. Click  to move the
calculation modifier style up in the

list, or click  to move the calcu-
lation modifier style down in the
list.

5 Click OK.

Ordering Zone Structures
Use this procedure to sort zones according to their hierarchy when you have
a complex zone structure with many levels, and it has become difficult to
recognize the hierarchy of the zones. To sort the zones according to their
hierarchical positions, AutoCAD Architecture offers you an easy-to-use
command.
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Ordering zone structures

1 Select the top node of the zone structure you want to sort.

2 Click Zone tab ➤ Modify panel ➤ Zone Layout  .

3 Specify the vertical (column) and horizontal (row) distance
between the entries in the zone structure, and press ENTER.

Creating Polylines from Zones
Use this procedure to create polylines from a zone, in cases such as the
following:

■ You want to export the floor plan to an application that can process only
polylines.

■ You need the space profile for other operations.
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Creating polylines from zones

After converting spaces to polylines, you can convert the polylines back to
spaces, as described in Converting Polylines, Profiles, and Object Outlines to
Spaces on page 2989.

NOTE If the net, usable, and gross boundaries are offset from the base boundary,
a polyline is created for each boundary.

1 Select the zone containing spaces you want to convert to polylines.

2 Click Zone tab ➤ Modify panel ➤ Create Polyline  .

3 Specify the source of the polylines:

■ To create polylines only from directly attached spaces, enter
D (Directly Attached Spaces) on the command line.

■ To create polylines from all attached spaces, regardless of
whether they are attached directly or through subzones, press
ENTER.

Polylines are created on top of the specified spaces. You can edit
them as any other polyline.

TIP When polylines lie above spaces, it can be difficult to select the space without
the polyline. Try one of the following:

■ Press CTRL, and click the boundary. Then click until the space is highlighted.

■ If the space hatch is displayed, click the hatch.

■ Enter qselect on the command line and filter for spaces.
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Specifying Additional Display Properties for a Zone
Use this procedure to specify the text style, zone marker size, and zone
connection line arrow for a selected zone. You can also specify whether the
zone hatch is used only for directly attached spaces of for those attached
through subzones as well.

1 Double-click the zone.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all zones in the drawing, select
Drawing default setting. To apply changes to all zones of this style,
select Zone Style:<style name>. For more information on styles, see
Zone Styles on page 3138.

5 For Display representation, verify that the desired display
representation is selected.

6 If necessary, expand Object Display Properties ➤ Advanced.

7 Click  Additional properties.

8 Under Name, for Text Style, select a style for the zone name from
the drop-down list, or click the worksheet button, and create a
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new text style, which will then be selectable from the list. For
more information, see “Text Style Dialog Box” in AutoCAD Help.

9 For Height, enter the desired value.

10 Under Marker, specify whether you want to define the scaling for
the zone marker:

Then…If you want to display the
marker at…

clear User Defined Scaling.1/50 of the screen size

select User Defined Scaling, and
enter the desired values for Width
and Height.

the scale you specify

11 Under Arrow, enter the desired value for Arrow Size.

12 Specify which spaces will inherit the hatch of the zone:

Then…If you want to…

clear Draw All.use the zone hatch only for directly
attached spaces

select Draw All.use the zone hatch for all directly
attached spaces and all spaces at-
tached through another zone

13 Click OK.

You can also access these option through the zone’s context menu, as follows:

1 Select the zone, right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

The current display representation is displayed in bold.

3 Select the display representation where you want the changes to
appear, and select Object Override. If Object Override is already

selected, click  at the upper-right corner of the tab.

4 In the Display Properties dialog, click the Other tab, and then
specify these options as desired.

5 Click OK twice.
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Attaching Hyperlinks, Notes, or Files to a Zone
Use this procedure to attach hyperlinks, text notes, or files to a zone.

1 Double-click the zone you want to attach information to.

2 Click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

For more information about adding hyperlinks, see “Add
Hyperlinks to a Drawing” in AutoCAD Help.

4 Click the setting for Notes, and add a note. Then click OK.

5 Click the setting for Reference Documents.

6 Attach or detach reference files:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text for Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

7 Click OK.

Zone Styles
The zone style can be used to control the display of the zone object, the zone
and space connection lines, the zone boundary, and the zone hatch. If you
add a hatch to a zone, the hatch is also displayed in spaces attached to the
zone to indicate the relationship.

You can use zone styles to create zones with different display properties for
construction spaces, rentable rooms, traffic spaces, or other space types. For
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example, you might draw and hatch all spaces in the construction zone, create
the traffic zone in blue with a solid fill, and so on.

Living rooms and construction spaces with different styles

Properties in the zone style can also be used to set content restrictions for
zones.

Zones are very useful for determining what is included or excluded when space
evaluations are performed.

Creating a Zone Style
Use this procedure to create a zone style. You can start by using the default
style or you can copy an existing style to use as your template. You then edit
the style properties to customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Zone Styles.

3 Create a new zone style:

Then…If you want to…

right-click Zone Styles, and click
New.

create a new style with default
properties

right-click the zone style you want
to copy, and click Copy. Right-click,
and click Paste.

create a new style from an existing
style

4 Enter a name for the new zone style, and press ENTER.
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5 Edit the style properties of your new zone style:

Then…If you want to…

click the General tab, and enter a
description.

enter a description of the style

see Attaching a List Definition to a
Zone Style on page 3140

attach a list definition to the style

see Restricting the Content of a
Zone Based on the Zone Style on
page 3141.

restrict the allowed content of the
style

see Specifying Classifications for a
Zone Style on page 3142.

add classifications to the style

see Specifying the Display Proper-
ties of a Zone Style on page 3142.

change the display of the zone

see Attaching Notes or Files to a
Zone Style on page 3148

add notes, files, or documents to
the style

6 If you want to assign the style to a zone tool, drag the style from
the Style Manager to a tool palette.

You can later rename the tool and specify other properties for it
as described in Creating a Zone Tool on page 3123.

7 Click OK.

Attaching a List Definition to a Zone Style
Use this procedure to attach a list definition to a zone style, so that zones
using that style are named consistently according to a user-defined list of
names. List definitions can be created according to government or company
standards or other systematics. For information about creating list definitions,
see List Definitions on page 3109.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Zone Styles.

3 Select the zone style that you want to change.

4 Click the Design Rules tab.
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5 For Zone Names, select a list definition from the drop-down list.

NOTE Only those list definitions that apply to zone names will appear
here. For more information, see Specifying the Application for a List
Definition on page 3111.

6 Click OK.

Restricting the Content of a Zone Based on the Zone Style
You can set content restrictions for zones based on the zone style. Content
restrictions can help you to ensure that only valid zone structures are built.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Zone Styles.

3 Select the zone style that you want to change.

4 Click the Design Rules tab.

5 For Exclusivity, select either or both of the following options:

■ Space Exclusive: Define that spaces can be attached only to
one zone of the style. This would be useful for zones that
represent real-world space compounds, like for example a zone
style for apartments. In that case, you need to prevent that
individual spaces can be attached to multiple zones of that
style and be calculated more than once.
If you attach a space to a second zone of the same style, it is
disconnected from the first zone.

■ Zone Exclusive: Define that zones of the style can only be
attached to other zones of the same style. This would be useful
for Building Systems applications where you want to generate
HVAC and Lighting zones and want to ensure that an HVAC
zone only can get attached to another HVAC zone, and a
Lighting zone only to another Lighting zone.
If you try to attach a zone of the style to a zone with another
style the connection is not created, and an error message is
displayed on the command line.

IMPORTANT Zone content restrictions are observed in external
references.

6 Click OK.
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Specifying Classifications for a Zone Style
Use this procedure to specify classifications for any classification definition
applied to a zone style.

For more information about creating and applying classification definitions,
see Classification Definitions on page 3872.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Zone Styles.

3 Select the zone style that you want to change.

4 Click the Classifications tab.

By default, the classification for all classification definitions is
Unspecified. If no classification definitions are listed, none are
applied to zone styles.

5 For each classification definition, select the classification you want
to apply to the current zone style.

6 Click OK.

Specifying the Display Properties of a Zone Style
You can change the display of zones and their attached spaces in the zone
style.

Specifying the Layer, Color, and Linetype Properties of a Zone
Style

You can specify these display properties for the following display components
of a zone in the style:

Display components in plan views 

DescriptionComponent

The boundary around any spaces attached
to the zone

Zone boundary

Hatch component of the zone symbol and
of any spaces connected to the zone. The

Hatch
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Display components in plan views 

DescriptionComponent

zone hatch is drawn on top of the space
hatch if both are visible.

Zone labelName

Zone symbolMarker

Connecting line between the zone and any
attached zones

Zone Connection Line

Connecting line between the zone and any
attached spaces

Space Connection Line

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Zone Styles.

3 Select the zone style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 Click the Layer/Color/Linetype tab.

7 Select the zone component to change, and change the following
settings:

■ Visibility

■ Layer

■ Color
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■ Linetype/Lineweight/Linetype Scale

■ Plot Style

8 Click OK.

Specifying the Hatching of a Zone Style
Use this procedure to specify the hatch settings of a zone style. The specified
hatch is applied to the zone symbol and to any spaces attached to the zone,
allowing you to easily detect the structure in your drawing if you have many
spaces and zones. The hatch is also important if you want to create a coding
legend from the zone.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Zone Styles.

3 Select the zone style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Hatching tab.

8 Select a component, and click the setting for Pattern.

9 Select the hatching for the component:

Then…If you want to…

select Predefined for Type, and then
select a pattern.

select a hatching pattern that is
available in the software

select Custom for Type, and then
enter the name of the custom pat-

select a custom pattern

tern. If necessary, click Browse, and
navigate to the folder where the
custom pattern file is located.

select User-defined for Type, and
clear Double Hatch.

select single hatching

select User-defined for Type, and
select Double Hatch.

select double hatching
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Then…If you want to…

select Solid Fill for Type.select solid fill

10 Click OK.

11 Click Scale/Spacing, and enter a value that determines how the
selected pattern is repeated.

12 Click Angle, and enter the angle for the selected pattern.

13 Click Orientation, and specify how the hatching is oriented:

Then…If you want to…

select Object.orient the hatching to the object,
regardless of the object rotation

select Global.orient the hatching to the World
Coordinate System

14 Click OK twice.

Inheriting the Zone Hatch to Different Levels of Attached Spaces
Use this procedure to specify to which level of attached spaces the hatch of
the zone should be inherited.

The zone hatch can either be inherited only to the directly attached spaces,
or it can be inherited to all attached spaces, directly or indirectly through
subzones.
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Inheriting zone hatch to all attached spaces (top) or only to directly attached spaces
(bottom)

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Zone Styles.

3 Select the zone style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 Specify whether the hatch of the zone should be used only for
directly attached spaces, or for all spaces:

Then…If you want to…

clear Draw All.use the zone hatch only for directly
attached spaces

select Draw All.use the zone hatch for all directly
attached spaces and all spaces at-
tached through another zone

9 Click OK.
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Specifying Text Style, Marker Size, and Arrow of a Zone Style
Use this procedure to define the text style, zone marker size, and the zone
connection line arrow of a zone.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Zone Styles.

3 Select the zone style that you want to change.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 Change the width and height of the zone marker by selecting
User Defined Scaling and then entering a width and height.

To display the zone marker always in 1/50 of the screen size, clear
User Defined Scaling.

9 Change the appearance of the zone name.

Then…If you want to…

enter a new height.change the height of the zone
name

either select a text style from the
list, or click the Browse button and

change the text style of the zone
name

create a new text style. For more
information, see “Text Style Dialog
Box” in AutoCAD Help.

10 Click OK twice.
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Attaching Notes or Files to a Zone Style
Use this procedure to attach text notes and files to a zone style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Zone Styles.

3 Select the zone style that you want to change.

4 Click the General tab.

5 To add a description to the zone style, enter it for Description.

6 Click Notes.

7 To add a note, click the Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click
Open.

attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application. Close the

edit a reference file

application when you are done
editing.

select the file name, and click De-
lete.

detach a reference file

9 Click OK twice.

Converting Area Group Styles to Zone Styles
If you open a drawing from a previous version of AutoCAD Architecture that
has area group styles in it, the area group styles will be automatically converted
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to zone styles. The following table maps area group style properties to zone
style properties:

Value/Default valueZone style propertyArea group style
property

Existing valueNameName

Existing valueDescriptionDescription

Existing valueKeynoteKeynote

Existing notes and attached doc-
uments

Notes/Reference DocsNotes/Reference Docs

Area group property sets are
converted to zone property sets

Property SetsProperty Sets

and attached to the converted
zone style

Standard

NOTE In previous versions of
AutoCAD Architecture, list defini-
tions were attached to zones or
zone templates. They are now
attached to the space style or the
zone style.

List DefinitionN/A

Exclusivity

Not selectedAllow a space to only be
attached to one zone of
this style

N/A

Not selected’Allow a zone of this style
to only be attached to
other zones of this style

N/A
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Value/Default valueZone style propertyArea group style
property

Existing classification values.

NOTE Area group classification
definitions from legacy drawings
are converted to zone classifica-
tion definitions and applied to
converted zone styles.

ClassificationsClassifications

Display Representa-
tions

Existing settingsPlanPlan

Existing settingsPlan High DetailPlan High Detail

Existing settingsPlan Low DetailPlan Low Detail

Drawing DefaultPlan PresentationN/A

Drawing DefaultPlan ScreenedN/A

Zone Templates
A zone template is a structure definition for zones with multiple hierarchical
levels. You define the zone template as a hierarchy with certain properties,
and use it to create the zone structure in the drawing.
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Zones according to DIN277

You use a zone template only to insert a zone structure. Later changes to the
zone template are not copied to existing zones based on this template.

Similarly, when you change a zone structure that is based on a zone template,
those changes do not affect the template.

You can create zone templates for structures you need frequently, and make
them available through AutoCAD Architecture style drawings.

NOTE Area group templates from legacy drawings are automatically converted
to zone templates when the drawings are opened in with the current version of
the software. Area name definitions that were attached to an area group template
will be disconnected from the zone template, as name definitions are now attached
to the space style or the zone style rather than the zone template. For information
about attaching list definitions to a zone style, see Attaching a List Definition to a
Zone Style on page 3140.

Creating a Zone Template
Use this procedure to create a zone template. You can start by using the default
template or you can copy an existing template and modify it.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Zone Templates.
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3 Create a new zone template:

Then…If you want to…

right-click Zone Templates, and
click New.

create a new template with default
properties

right-click the template you want
to copy, and click Copy. Right-click,
and click Paste.

create a new template from an ex-
isting template

4 Enter a name for the new zone template, and press ENTER.

5 Edit the style properties of your new zone template:

Then…If you want to…

see Building the Structure of a Zone
Template on page 3152.

define the content of the zone
template

see Attaching Notes and Files to a
Zone Template on page 3155.

add notes or files to the zone tem-
plate

6 Click OK.

Building the Structure of a Zone Template
When you create a zone template, you set the following properties:

■ structure of contained zones

■ zone style (for each contained zone)

■ zone content (for each contained zone)

■ zone calculation type (for each contained zone)

■ calculation modifier styles (for each contained zone)

For information about creating zones from a zone template, see Creating Zone
Structures from a Zone Template on page 3121.
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1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Zone Templates.

3 Select the template you want to edit.

4 Click the Content tab.

In the left pane of the Content tab, a tree structure displays the
structure of the zone template with all zones and subzones. If you
are creating a new zone template, only the top level zone node
is present. All other subzones are yet to be inserted.

5 Add the desired subzones to your zone template.

Then…If you want to…

select the zone that will contain the
subzone, right-click, and click New.

add a subzone to the template

select the zone, right-click, and click
Rename.

rename a zone

select the zone, right-click, and click
Delete.

delete a zone
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NOTE To rearrange zones within the structure, drag-and-drop them
within the tree.

6 Select a zone.

7 Enter a description for the zone.

8 Select a style for the zone. For information about zone styles, see
Zone Styles on page 3138.

TIP If you select a style that requires zone exclusivity, you will be able
to add only subzones that are of the same style. If you try to attach
a subzone of a different style, you will receive an error message. For
information on setting exclusivity rules for zone styles, see Restricting
the Content of a Zone Based on the Zone Style on page 3141.

9 Specify the types of objects that can be attached to the zone
(spaces, zones, or both.)

10 Select the types of calculations performed for the zone in the
evaluation of the floor plan.

For example, you might want to have a Carpet zone node to
calculate how much carpet you need and Base board zone node
to calculate how much baseboard you need. For the Carpet zone
node, you would select Yes for Calculate area. For the Baseboard
zone node, you would select Yes for Calculate perimeter.

You can select both calculation types if you want both values to
appear in the evaluation.

11 Select one or more calculation modifiers to apply to the zone.

For example, if you have a Balconies zone node, you can attach
a calculation modifier that reduces all calculated space values in
this zone by 50 percent.

NOTE By default, a calculation modifier is applied only to the base
area and base perimeter of spaces attached to the zone. To apply the
modifier to the net, usable, and gross boundaries of spaces attached
to a zone, you need to create and apply a property set definition that
contains properties for the calculated area and perimeter values of
these 3 boundaries.

Calculation modifiers are applied accumulatively. If you attach a
50 percent calculation modifier to a space directly, and then attach
the space to a zone that also has a 50 percent calculation modifier,
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the resulting space value is 25 percent, because both calculation
modifiers are applied.

Calculation modifiers are processed top-down, with the first style
in the list processed first, the second style after that, and so on.
Depending on your calculation formulas, you can receive different
result values. To change the order of calculation modifiers, drag
them to the correct positions within the list. For an example of
how the order of calculation modifiers can affect the calculation
results, see Calculation Modifiers on page 3163.

12 Click Attach.

13 In the Select a Space Calculation Modifier Style worksheet, select
a calculation modifier to attach to the zone node, and click OK.

14 To detach a calculation modifier, select it, and click Detach.

15 Click OK.

Attaching Notes and Files to a Zone Template
Use this procedure to attach text notes and files to a zone template.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Zone Templates.

3 Select the template for which you want to add a note or file.

4 Click the General tab.

5 To add a description to the zone template, enter the description
for Description.

6 Click Notes.

7 To add a note, click the Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click
Open.

attach a reference file

select the file, and click Edit. Edit
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application. Close the

edit a reference file
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Then…If you want to…

application when you are done
editing.

select the file name, click Delete,
and click OK.

detach a reference file

9 Click OK twice.

Converting Area Group Templates to Zone Templates
If you open a drawing from a previous version of AutoCAD Architecture that
has area group templates in it, the area group templates will be automatically
converted to zone templates. The following table maps area group template
properties to zone template properties:

Value/Default valueZone template propertyArea group tem-
plate property

Existing valueNameName

Existing valueDescriptionDescription

Existing notes and attached doc-
uments

Notes/Reference DocsNotes/Reference Docs

NOTE In previous versions of the
software, name definitions could
be attached to zone templates.
Now, list definitions are attached
to the space style or the zone
style.

N/AList Definition

Area group styles from legacy
drawings are automatically con-

StyleStyle

verted to zone styles and at-
tached to the corresponding
node in the zone template.

Existing content permissions.
Area permissions are now space

ContentContent
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Value/Default valueZone template propertyArea group tem-
plate property

permissions, and area group per-
missions are zone permissions.

Existing valuesCalculation typesCalculation types

Existing calculation modifiersCalculation Modifier StylesCalculation Modifier
Styles

Working with Space Data
Spaces can have a number of different data types attached to them:

■ Geometric data belonging to the space: This is data inherent to the space
like its height or width. This data can be displayed in the Properties palette
or used in schedule tables and space tags. For more information, see
Schedule Properties of Spaces on page 3158.

■ Modified and calculated data derived from the space: this is data derived
from the geometric data by applying calculation modifier styles, boundary
offset calculation formulas, or formula properties. For more information,
see Calculation Modifiers on page 3163, Working with Space Boundaries on
page 3004 and Adding a Formula Property Definition to a Property Set
Definition on page 3830. Schedule properties exist for values created by
calculation modifiers, boundary offsets, and formulas, so that they can be
displayed in the Properties palette and used in a schedule table, too.

■ Data generated by a geometric decomposition of the space area. For more
information, see Space Decomposition on page 3171.

■ Space surface properties: Data attached to the surfaces of a space. For more
information, see Editing Space Surface Properties on page 3061.

■ User-defined information sets: you can define any set of relevant property
set data for spaces, like for example, floor finish, ceiling material etc. This
data can be displayed in the Properties palette and used in schedule tables
and space tags. For more information, see Adding a Manual Property
Definition to a Property Set Definition on page 3845.
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Schedule Properties of Spaces
There are a large number of schedule properties you can attach to a space.
Property data is placed in a property set definition and attached to a space or
space style. You can display it in the Properties palette or use it to create
schedule tables. For information about how to create a property set definition
containing schedule properties, see Creating a Property Set Definition on page
3841 and Adding an Automatic Property Definition to a Property Set Definition
on page 3849.

The following schedule properties are available as automatic properties directly
derived from a space:

DescriptionProperty

Area bounded by the base boundaryBase Area

Area bounded by base boundary minus the area
deducted by interference conditions. For more

Base Area Minus Interferences

information, see Creating Interference Condi-
tions for Spaces on page 3035.

Area bounded by the ceiling boundary. The
ceiling boundary is always derived from the

Base Ceiling Area

base boundary of the space. In an extruded 3D
space, the base ceiling area is identical to the
base area; in a 3D freeform space the base ceil-
ing area can differ from the base area.

Perimeter of the base boundaryBase Perimeter

Perimeter of the base boundary including the
length created by interference conditions. For

Base Perimeter Including Interferences

more information, see Creating Interference
Conditions for Spaces on page 3035.

The sum of surface areas on a space, calculated
from the base volume of the space

Base Surface Area

Volume of the space as calculated from the base
boundary

Base Volume
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DescriptionProperty

Base area of a space after applying calculation
modifiers. For more information, see Calculation
Modifiers on page 3163.

Calculated Area

Base perimeter of a space after applying calcu-
lation modifiers

Calculated Perimeter

List of all calculation modifiers applied to the
space

Calculation Modifier

Space area at the height of calculation cut
planes 1 and 2. This property should be used

Calculation Plane 1 Area
Calculation Plane 2 Area

for 3D freeform spaces only; in an extruded 3D
space the calculation cut plane area is identical
at each cut plane. For more information, see
Setting Calculation Cut Planes for 3D Freeform
Spaces on page 3169.

Height of calculation cut planes 1 and 2.Calculation Plane 1 Height
Calculation Plane 2 Height

Perimeter of calculation cut planes 1 and 2.Calculation Plane 1 Perimeter
Calculation Plane 2 Perimeter

Thickness of the ceiling boundary. For more in-
formation, see Changing the Height of Extruded

Ceiling Thickness

3D Spaces on page 3029 and Changing the
Height of 3D Freeform Spaces on page 3031.

Color assigned to the space in the AutoCAD
properties

Color

Color of textColor - Text

Description added to the spaceDescription

Description added to the space styleDescription from Style

List of all documents attached to the space. For
more information, see Attaching Hyperlinks,
Notes, or Files to a Space on page 3003.

Documents
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DescriptionProperty

List of all documents added to the space style.
For more information, see Attaching Notes and
Files to a Space Style on page 3107.

Documents from Style

System value used in export to Building Systems
applications

Drawing Fingerprint GUID

Thickness of the floor boundary. For more in-
formation, see Changing the Height of Extruded

Floor Thickness

3D Spaces on page 3029 and Changing the
Height of 3D Freeform Spaces on page 3031.

Area bounded by the gross boundaryGross Area

Area bounded by gross boundary minus the
area deducted by interference conditions. For

Gross Area Minus Interferences

more information, see Creating Interference
Conditions for Spaces on page 3035.

Area bounded by the gross boundary after ap-
plying calculation modifiers

Gross Calculated Area

Perimeter of the gross boundary after applying
calculation modifiers

Gross Calculated Perimeter

Perimeter of the gross boundaryGross Perimeter

Perimeter of the gross boundary including the
length created by interference conditions. For

Gross Perimeter Including Interfer-
ences

more information, see Creating Interference
Conditions for Spaces on page 3035.

Internal ID of spaceHandle

Legacy value from Autodesk Architectural
Desktop 2006

Has Net, Usable, and Gross Boundaries

Ceiling height of the space.Height

Lists all hyperlinks you have attached to the
space. For more information, see Attaching

Hyperlink
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DescriptionProperty

Hyperlinks, Notes, or Files to a Space on page
3003.

Layer of the spaceLayer

Length of the spaceLength

AutoCAD linetype of the spaceLinetype

Maximum values for area, length, and width of
spaces that have target dimensions defined in

Maximum Area/Length/Width

the space style. For more information, see Spe-
cifying Target Dimensions for the Space on
page 3095.

Minimum values for area, length, and width of
spaces that have target dimensions defined in

Minimum Area/Length/Width

the space style. For more information, see Spe-
cifying Target Dimensions for the Space on
page 3095.

Name of the spaceName

Area bounded by the net boundaryNet Area

Area bounded by net boundary minus the area
deducted by interference conditions. For more

Net Area Minus Interferences

information, see Creating Interference Condi-
tions for Spaces on page 3035.

Area bounded by the net boundary after apply-
ing calculation modifiers

Net Calculated Area

Perimeter of the net boundary after applying
calculation modifiers

Net Calculated Perimeter

Perimeter of the net boundaryNet Perimeter

Perimeter of the net boundary including the
length created by interference conditions. For

Net Perimeter Including Interferences

more information, see Creating Interference
Conditions for Spaces on page 3035.
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DescriptionProperty

Offset of net boundary from gross boundaryNet to Gross Offset

Notes attached to the spaceNotes

Notes attached to the space styleNotes from Style

Internal IDObject ID

AEC object type. For spaces, this property is al-
ways set to SPACE.

Object type

Space above the ceiling boundary. For more
information, see Changing the Height of Ex-

Space Above Ceiling

truded 3D Spaces on page 3029 and Changing
the Height of 3D Freeform Spaces on page 3031.

The style of the spaceStyle

Target values for area, length, and width of
spaces that have target dimensions defined in

Target Area/Length/Width

the space style. For more information, see Spe-
cifying Target Dimensions for the Space on
page 3095.

Area bounded by the usable boundaryUsable Area

Area bounded by usable boundary minus the
area deducted by interference conditions. For

Usable Area Minus Interferences

more information, see Creating Interference
Conditions for Spaces on page 3035.

Area bounded by the usable boundary after
applying calculation modifiers

Usable Calculated Area

Perimeter of the usable boundary after applying
calculation modifiers

Usable Calculated Perimeter

Perimeter of the usable boundaryUsable Perimeter

Perimeter of the usable boundary including the
length created by interference conditions. For

Usable Perimeter Including Interfer-
ences
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DescriptionProperty

more information, see Creating Interference
Conditions for Spaces on page 3035.

Volume of the space above the ceiling bound-
ary. All volumes are calculated from the base
volume.

Volume Above Ceiling

Volume of the space below the floor boundary.Volume Below Floor

Overall volume of the space including ceiling
and floor boundaries, and the volume above
the ceiling and below the floor.

Volume Overall

The area of the wall sides. Used for example in
paint and plaster calculations.

Wall Area

Width of the spaceWidth

Calculation Modifiers
A calculation modifier is a formula that you can apply to a space to change
the calculated results of its associated area or perimeter values. Calculation
modifiers can also be applied to a zone to change the calculated results of all
spaces attached to that zone. You might want to change calculated results for
number of purposes; for example, to account for plaster deductions or the
tiling in a bathroom.

By default, a calculation modifier is applied only to the base area and base
perimeter of the space. To apply the modifier to the net, usable, and gross
boundaries of a space, you need to create and apply a property set definition
that contains properties for the calculated area and perimeter values of the
those boundaries. For more information, see Property Set Definitions on page
3823.

Calculation modifiers work cumulatively. When you apply several different
modifiers to a space or a zone, they are all applied. Therefore, it is important
to define the order in which they are used.

Example: You have a space area of 25 square meters. You want to apply 2
different calculation modifiers to it. Calculation modifier A deducts a value
of 0.3 square meters for a column. Calculation modifier B divides the space
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by 2 (in some international calculation schemes, this is used for calculating
balconies).

■ If you apply the plaster deduction first and the division second, you get
the following result:
Calculation Modifier A: 25 m2 - 0.3 m2 = 24.7 m2

Calculation Modifier B: 24.7 m2 / 2 = 12.35 m2

■ If you apply the division first and the plaster deduction second, you get
the following result:
Calculation Modifier B: 25 m2 / 2 = 12.5 m2

Calculation Modifier A: 12.5 m2 - 0.3 m2 = 12.2 m2

You can set the order of calculation modifiers in the properties of the space.
For information about ordering calculation modifiers, see Adding and
Removing Calculation Modifiers for Spaces on page 3164.

Adding and Removing Calculation Modifiers for Spaces
Use this procedure to attach, detach, or sort calculation modifiers for spaces.

Calculation modifiers are values and formulas that can be applied to the area
and perimeter values of a space to modify them. By default, a calculation
modifier is applied only to the base area and base perimeter of a space. To
apply the modifier to the net, usable, and gross boundaries of a space, you
need to create and apply a property set definition that includes properties for
these boundaries. For more information, see Property Set Definitions on page
3823

1 Select the spaces you want to attach a calculation modifier to,
and double-click one of them.

NOTE This procedure can be applied to multiple spaces only when
they all have the same modifiers attached in exactly the same order.

2 On the Properties palette, expand Basic, and expand General.

3 Click the setting for Calculation modifiers.
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4 Attach or detach calculation modifiers:

Then …If you want to…

for Available, select the desired cal-

culation modifier, and click  .

attach a calculation modifier

for Name, select the desired calcu-

lation modifier, and click  .

detach a calculation modifier

for Name, select the calculation
modifier you want to move to a

rearrange the order of attached
calculation modifiers

different position. Click  to
move the calculation modifier up

in the list, or click  to move the
calculation modifier down in the
list.

NOTE Calculation modifiers are
processed in the same top-
down order in which they are
listed on this worksheet.

5 Click OK.

Creating a Calculation Modifier Style
Use this procedure to create a calculation modifier style. You can start by using
the default style or you can copy an existing style to use as your template.
You then edit the style properties to customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Calculation Modifier
Styles.

Calculation Modifiers | 3165



3 Create a new calculation modifier style:

Then…If you want to…

right-click Calculation Modifier
Styles, and click New.

create a new modifier style with
default properties

right-click the calculation modifier
you want to copy, and click Copy.
Right-click, and click Paste.

create a new modifier style from an
existing style

4 Enter a name for the new calculation modifier style, and press
ENTER.

5 Edit the properties of your new calculation modifier style:

Then…If you want to…

see Specifying the Application for a
Calculation Modifier Style on page
3166.

define the calculation type of the
modifier style

see Defining the Formula for a Cal-
culation Modifier on page 3167.

define the formula of the modifier
style

see Attaching Notes and Files to a
Calculation Modifier Style on page
3169.

add notes, files, or documents to
the modifier style

6 Click OK.

Specifying the Application for a Calculation Modifier Style
A space contains 2 values that can be affected by a calculation modifier: the
area and the perimeter. You can choose to have a calculation modifier apply
to either or both of these calculations.

For example you might want to set up a modifier that reduces the calculated
base area by 50 percent. (This is obligatory for several space types in various
international architectural standards.)

Or you might want a modifier that deducts length from the perimeter of a
room for openings and stairs. This would be helpful in calculating the amount
of baseboard material needed for this room.
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1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Calculation Modifier
Styles.

3 Select the modifier for which you want to set the calculation type.

4 Click the Apply To tab.

5 Select whether you want to apply the modifier to the (base) area
or (base) perimeter of the space. You can also select both values
here.

6 Click OK.

Defining the Formula for a Calculation Modifier
Use this procedure to define or edit the formula for a calculation modifier
style.

Variable and formula for modifier

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Calculation Modifier
Styles.

3 Select the modifier for which you want to define a formula.

4 Click the Definition tab.

5 Add a variable to the calculation modifier.

A variable consists of the variable name and its value. For example,
to create a plaster deduction of 3 percent, click Add, and enter
Plaster_Deduction for Variable and 0.97 for Value.

You should use a descriptive name as a variable name to add
transparency to your formulas.

To set up formulas, you can also enter direct mathematical values.
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The following characters and words are not allowed:

■ Special characters such as ?()*- (You may, however use an
underscore).

■ Spaces

■ Accent marks such as ä, ö, ü, ê, è, å

■ Key words from Visual Basic®.

For information about Visual Basic key words, refer to the Visual
Basic Reference.

One of the following values is displayed for Data depending on
current selections on the Apply To tab:

■ AreaValue (if Area is selected)

■ PerimeterValue (if Perimeter is selected)

■ Value (if both Area and Perimeter are selected)

You cannot edit this value; if you want to change it, click the
Apply To tab and change the current selections there as desired.

6 For Expression, enter the formula for calculating the modifier.

You can enter direct mathematical values and operators, variables
you have created, and Visual Basic key words, such as Mod, Exp,
or Log.

For example, if you want to set up a plaster deduction of 3 percent,
and you have defined a variable called Plaster_Deduction with a
value of 0.97, enter AreaValue * Plaster_Deduction.

NOTE It is important to enter the variable names AreaValue and
PerimeterValue exactly as they are displayed in the Data field.
Alternative spellings such as “Area Value” or “perimetervalue” are
not recognized.

7 To test your formula, enter a sample value for Input, press ENTER,
and check the result for Output.

8 Click OK.
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Attaching Notes and Files to a Calculation Modifier Style
Use this procedure to enter notes and attach reference files to a calculation
modifier style. You can also edit reference files attached to the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Calculation Modifier
Styles.

3 Select the modifier to which you want to attach notes or files.

4 Click the General tab.

5 To add a description to the modifier, enter it for Description.

6 Click Notes.

7 To add a note, click the Notes tab, and enter the note.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click
Open.

attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application. Close the

edit a reference file

application when you are done
editing.

select the file name, and click De-
lete.

detach a reference file

9 Click OK.

Setting Calculation Cut Planes for 3D Freeform Spaces
Use this procedure to set calculation either or both of the cut planes available
for 3D freeform spaces. These can be useful for rooms under a roof where the
space area can be calculated only for the parts of a space with a specific height.
Calculation planes can be automatically scheduled.
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1 Select the spaces for which you want to define the 2 calculation
cut planes, and double-click one of them.

2 Expand Basic, and expand Advanced Dimensions.

3 For Calculation plane height 1 and Calculation plane height 2,
enter the desired values for the calculation cut plane height.

TIP You can activate display components for the calculation cut
planes and the calculation cut plane hatches in Plan view. For more
information, see Specifying the Display Properties of a Space Style
on page 3101.

Generating Output Data and Exporting Space Data
Space data can be displayed and delivered in various output formats.
Depending on your needs, you should choose one of the methods below to
deliver and communicate space data:

■ Schedule table (DWG): When you create a schedule table within a drawing
file, the space property data is available for every user that has a version
of AutoCAD Architecture, or any software that can read DWG files, like
AutoCAD. For information on creating schedule tables, see Basic Schedules
on page 3747.

■ DWF: You can export a drawing file with property data to a DWF file. For
more information, see Publishing Drawings to DWF and DWFx on page
276.

■ Database (XLS/CSV/TXT): You can export space property data to XLS
(Microsoft Excel), CSV, and TXT formats which are readable by a number
of spreadsheet calculation and database applications. For more information,
see Exporting a Schedule on page 3791 and Exporting Schedule Data for
Selected Objects on page 3792.

■ Space evaluation (XLS/TXT): When you generate a space evaluation
document, selected properties of spaces are exported to either an XLS or
TXT document. Space evaluations display only a subset of space properties.
You need a space evaluation for example if you want to export space
decomposition data. For more information, see Space Decomposition on
page 3171 and Space Evaluation on page 3177.

■ Autodesk MapGuide: you can export space property set data to Autodesk
MapGuide. For more information, see Publishing Drawing Files to Autodesk
MapGuide on page 268.
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■ Database (MDB): You can export space property data to a Microsoft Access
MDB file. For more information, see Exporting Property Set Data to an
MDB on page 276.

NOTE If you previously used the SpaceInfo command to generate MDB data
from spaces, you would now use the AecExportPropertyData command.

Space Decomposition
In some countries, such as Germany and Japan, an important part of space
evaluation is the visual decomposition of spaces into subdivisions for the
proof that must be approved by the cognizant administrative authority.

A space decomposition is a Plan display representation in which the spaces
are displayed as triangles or trapezoids, depending on the decomposition
method. Additionally, the decomposition shows height lines as well as edge
and height dimensions. Architects need space decomposition for calculation
proof.

Decomposition is set in the display properties of the space object, the space
style, or in the drawing defaults.

With styles, you can control how the decomposition is displayed, the
decomposition method used, color settings for decomposition components,
and tags.
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Different space decomposition methods

Displaying the Space Decomposition
In the Plan High Detail and Plan Low Detail display configurations, the space
decomposition is displayed by default in the bottom view direction.

If the space decomposition is not displayed in the desired display configuration,
use the following steps to display it:

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Select the display configuration where you want to display the
space decomposition.

3 Expand the display configuration.

4 Select the display set in which you want to display the space
decomposition.

3172 | Chapter 40   Spaces



5 Click the Display Representation Control tab.

6 Scroll through the list of objects until you reach the Space object.

7 Select the check box for the Decomposed display representation.

8 Click OK.

Specifying Layer/Color/Linetype Settings of the Space
Decomposition

Use this procedure to change the properties of the display components of the
space decomposition view for a space style.

The following decomposition display components are available:

DescriptionComponent

Decomposition lines of a space with a
positive value, such as a room

Additive Edge

Decomposition lines of a space with a
negative value, or a hole

Subtractive Edge

Tag for a space subdivision with a positive
value

Additive Tag

Tag for a space subdivision with a negative
value

Subtractive Tag

Height lines of a space subdivision with a
positive value

Additive Height

Height lines of a space subdivision with a
negative value

Subtractive Height

Label for a space edge displaying its lengthEdge Dimension Text

Label for a height line displaying its lengthHeight Dimensions

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Space Styles.

3 Select the space style where you want to change decomposition
settings.
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4 Click the Display Properties tab.

5 Select the Decomposed display representation, and select either
Style Override or Drawing Default, depending on which display
source you want for the decomposition.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select the space decomposition component to change, and change
the following settings:

■ Visibility

■ Layer

■ Color

■ Linetype/Lineweight/Linetype Scale

■ Plot Style

9 Click OK twice.

Specifying the Type of Space Decomposition
In the decomposition view of the space style, you specify the type of subentities
into which the space will be decomposed (trapezoid or triangulated) and the
AutoCAD entities the decomposed space is converted to when exploded (lines
or closed polyline faces).

3174 | Chapter 40   Spaces



Trapezoid and triangulated space decompositions

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Space Styles.

3 Select the space style where you want to change decomposition
settings.

4 Click the Display Properties tab.

5 Select the Decomposed display representation, and select either
Style Override or Drawing Default, depending on which display
source you want for the decomposition.

6 If necessary, click  .

7 Click the Decomposition tab.

8 Under Decomposition Type, select an option for Type:

Then…If you want to…

select Trapezoid.display a trapezoid decomposition
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Then…If you want to…

select Triangle.display a triangular decomposition
without overlapping triangles

select Triangle (overlap).display a triangular decomposition
with overlapping triangles

9 Under Explode Result, select an option:

Then…If you want to…

select Lines.change the decomposed space into
single lines after exploding

select Faces.change the decomposed space into
closed polylines for each decom-
posed part

10 Click OK twice.

Specifying Text Settings for Space Decomposition
Use this procedure to modify the numbers of the space subdivisions as well
as the edge and height annotations.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Architectural Objects, and expand Space Styles.

3 Select the space style where you want to change decomposition
settings.

4 Click the Display Properties tab.

5 Select the Decomposed display representation, and select either
Style Override or Drawing Default, depending on which display
source you want for the decomposition.

6 If necessary, click  .

7 Click the Proof tab.
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8 Define the prefix settings:

Then…If you want to…

enter a prefix.display a prefix for the numbers of
the space subdivisions

either select a text style from the
list or click the Browse button and

change the style of the numbers of
the space subdivisions

create a new text style. For more
information, see “Text Style Dialog
Box” in AutoCAD Help.

enter a value for Height.change the height of the numbers
in the space subdivisions

9 Define the edge dimension settings:

Then…If you want to…

either select a text style from the
list or click the Browse button and

change the style of the edge dimen-
sions

create a new text style. For more
information, see “Text Style Dialog
Box” in AutoCAD Help.

enter a value for Height.change the height of the edge di-
mensions

10 Click OK twice.

Space Evaluation
The space evaluation is a documentation feature that calculates and evaluates
the space information of your finished floor plan. This information is stored
in a separate file that you can export to a spreadsheet or word processing
application. Evaluation templates ensure that the information is formatted
and arranged in a consistent, structured way.

Examples for Using the Space Evaluation

Architects need the space evaluation feature for submitting floor plans to the
building plan approval authorities and to customers. Space evaluation can

Space Evaluation | 3177



also be used for performing cost estimates, assigning jobs to contractors, or
organizing facility management.

You can create evaluations for

■ Selected spaces and zones in the current drawing

■ Selected spaces and zones from multiple open drawings

■ All spaces and zones in a drawing

■ All spaces and zones from all open drawings

■ Spaces and zones from external references

Transitioning from Area Evaluation to Space Evaluation

In previous versions of the software, areas and area groups could be evaluated
with the area evaluation feature. Areas are now converted to spaces, area groups
to zones, and the area evaluation has been converted to the space evaluation.
If you attempt to use a legacy tool or run a legacy command to start the area
evaluation, the following message will appear:

If you click Run Space Evaluation, the space evaluation will be started instead.
You should remove area evaluation tools from your palettes and exchange
area evaluation commands for space evaluation commands in your scripts.
For a listing of obsolete commands and their corresponding new commands,
see Appendix 1: Command Changes for Spaces and Areas on page 3198.

Preparing the Space Evaluation
Before you create an evaluation file, you select the spaces and zones to include,
and you set a number of options that control the output for export.

3178 | Chapter 40   Spaces



Selecting Spaces and Zones for Evaluation
Use this procedure to select spaces and zones to include in the evaluation.

1 Open the Scheduling tool palette, and select the Space Evaluation
tool.

NOTE Alternatively, you can click Home tab ➤ Inquiry panel ➤ 

 ➤ Space Evaluation  .

Selecting space and zones for an evaluation

In the left pane, all open drawings are listed with spaces and zones
in a tree structure.

When you highlight one of the spaces or zones, the following
information is displayed on the right side:

■ Name

■ Description

■ Base Area

■ Calculated Area (base space after application of calculation
modifiers)

■ Base Perimeter

■ Calculated Perimeter (base perimeter after application of
calculation modifiers)

■ Calculation Type (Area or Perimeter)
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■ Calculation Modifier Styles

2 To include spaces and zones from external references in the list

view, click  .

NOTE Spaces and zones from external references are displayed with

the External References icon (  ). You can select them in the same
way as spaces and zones from open drawings.

3 Select the spaces and zones you want to include in the evaluation
of the floor plan by selecting their check boxes.

There are different colors for the check box marks:

■ A black check mark means that you have selected this space or zone directly
for evaluation. You can clear that mark directly.

■ A gray check mark means that you have selected a space or zone contained
in the gray-marked zone. This does not mean that the gray-marked zone
is included in the evaluation; if you want to include it, select it directly.

■ A blue check mark on a space or zone means that you have selected the
zone these items are contained in. These zones and spaces are included in
the evaluation because their containing zone is included.

NOTE There is one exception to this rule. If you want to run a Space Evaluation
on a drawing that contains a zone, but the zone’s associated spaces are located
in an xref, the referenced spaces need to be explicitly checked (black) in the
Evaluation dialog in order to be included in the evaluation.

Evaluation Content
Use this procedure to specify which of the following components to include
in the evaluation file. You select components for spaces and zones separately.

1 Open the Scheduling tool palette, and select the Space Evaluation
tool.

NOTE Alternatively, you can click Home tab ➤ Inquiry panel ➤ 

 ➤ Space Evaluation  .
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2 Click Evaluation Options.

3 Click the Evaluation tab.

4 Select Space for Select.

5 In the list displayed, select the components you want to appear
in the evaluation file.

You can choose these components:

DescriptionComponent

Name of the space or zoneName

Description of the space or zoneDescription

Graphic image of the space or zone
in bitmap format

Overview Image

Fixed prefix for the base area value
of the space or zone

Base Area Label

Base area value of space or zone
without calculation modifiers ap-
plied

Base Area Result

Fixed prefix for the area of the
space or zone after applying calcu-
lation modifiers

Calculated Area Label

Area value of the space or zone with
calculation modifier styles applied

Calculated Area Result

Prefix showing the name of a mod-
ifier applied to space area

(Area) Modifier Label

Formula of calculation modifier ap-
plied to the space area

(Area) Modifier Expression

Resulting value of applied calcula-
tion modifier

(Area) Modifier Result

Number of the space subdivisions
plus any prefixes you may have set

(Area) Proof Label - Spaces only
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DescriptionComponent

Formula of the decomposition
method applied to the space

(Area) Proof Expression - Spaces
only

Result of the space decomposition(Area) Proof Result - Spaces only

Preview image of the space decom-
position

(Area) Decomposed Image - Spaces
only

Fixed prefix for the space or zone
base perimeter value

Base Perimeter Label

Base value of the space or zone
perimeter without calculation
modifier styles applied

Base Perimeter Result

Fixed prefix for the base perimeter
of the space or zone after calcula-
tion modifiers are applied

Calculated Perimeter Label

Perimeter value of the space or zone
after calculation modifiers are ap-
plied

Calculated Perimeter Result

Prefix showing the name of perimet-
er modifier

(Perimeter) Modifier Label

Formula of calculation modifier ap-
plied to perimeter

(Perimeter) Modifier Expression

Resulting value of any applied peri-
meter calculation modifiers

(Perimeter) Modifier Result

6 If necessary, repeat the component selection for zones.

7 Click OK.

Image Display Properties
Use this procedure to specify display settings for any preview images you want
to include in your evaluation file.
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1 Open the Scheduling tool palette, and select the Space Evaluation
tool.

NOTE Alternatively, you can click Home tab ➤ Inquiry panel ➤ 

 ➤ Space Evaluation  .

2 Click Evaluation Options.

3 Click the Image Display tab.

Image display for space evaluation document

4 Select the drawing for which you want to set image properties.

NOTE If you want to create include several open drawings in the
evaluation, you need to set the image properties for each open
drawing separately.

5 Choose the desired color depth for the images in the evaluation
file. Not that a high resolution enhances the quality of the images
but also enlarges the file size.

6 For each object category (Spaces, Spaces Decomposed, and Zones)
select the desired display configuration, and specify the desired
width and height for the image size:

NOTE In the list, you will see only those display configurations in
which display representations for spaces, zones, or decomposed
spaces are turned on.

7 Click OK.
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Data Format Style Properties
You can set different data format styles for different components of the
evaluation file.

NOTE For information about creating data format styles, see Property Data Formats
on page 3802.

1 Open the Scheduling tool palette, and select the Space Evaluation
tool.

NOTE Alternatively, you can click Home tab ➤ Inquiry panel ➤ 

 ➤ Space Evaluation  .

2 Click Evaluation Options.

3 Click the Data Format Styles tab.

4 In the tree view under Apply To, select the element to which you
want to assign a data format style. You can choose from these
elements:

■ Area Result

■ (Area) Modifier Expression

■ (Area) Proof Expression

■ Perimeter Result

■ (Perimeter) Modifier Expression

5 Select the drawing from which you want to take a data format
style.
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6 Select the desired data format style.

7 For Area Result and Perimeter Result, if you want to include the
exact, unrounded values as additional information in the
evaluation file, select Additional Exact value.

The area or perimeter result will then displays with the precision
set in the data format style and, in an extra column, with their
exact precision without rounding.

Example:

Exact Calculated Perimeter =
33.777692 m

Calculated Perimeter = 33.778 m

Exact Calculated Area =
88.5321423 m2

Calculated Area = 88.532 m2

8 Click OK.

Setting the Default Templates
An evaluation document is saved as a spreadsheet (XLS) file or as an ASCII
text format (TXT) file. To create an XLS file, you need an XLT template, and
to create a TXT document, you need a TXT template.

AutoCAD Architecture includes preset templates for both formats. You can
use those templates as provided or you can modify them according to your
needs.

You can also create your own XLT and TXT templates in Microsoft® Excel or
any word processor, like NotePad or Microsoft® Word.

After a default template is set, it is used for all evaluations until you change
the default settings again. If no default template has been set, you are prompted
for a template each time you create an evaluation.

1 Open the Scheduling tool palette, and select the Space Evaluation
tool.

2 Click Evaluation Options.

3 Click the Templates tab.
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4 Set a default template for evaluations:

Then…If you want to…

enter a file name and directory path
for Excel Template File.

set a default template for XLS eval-
uation files

enter a file name and directory path
for Text Template File.

To set a default template for TXT
evaluation files

NOTE The evaluation templates shipped with the software are located
under C:\ProgramData\Autodesk\ACA 2012\enu\Template\Evaluation
Templates.

5 Click OK.

Creating the Space Evaluation Document
When you perform a space evaluation, a separate file that contains the space
information from the specified drawing files. This file is saved as an XLS file
or a TXT file, depending on your settings.

Creating an XLS Evaluation Document
Use this procedure to export a space evaluation to an Excel spreadsheet.

One of the most frequently used formats for space evaluation documents is
XLS, the native file format of Microsoft® Excel. It is a powerful spreadsheet
file format with numerous calculation and formatting abilities. You can easily
export data from Excel to formats like HTML, XML, CSV (comma-delimited)
or DBF (dBase).

You can export text (results, modifier expressions, and labels) and images
(bitmap previews of spaces and zones). For a detailed list of elements that can
be exported, see Evaluation Content on page 3180.

You can create your own XLT templates into which the evaluation is integrated.
For more information, see Creating XLT Templates on page 3188.

1 Open the Scheduling tool palette, and select the Space Evaluation
tool.
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NOTE Alternatively, you can click Home tab ➤ Inquiry panel ➤ 

 ➤ Space Evaluation  .

2 Prepare the space evaluation as described in Preparing the Space
Evaluation on page 3178.

3 In the Space Evaluation dialog box, click  .

If you did not select a default XLT template in the Evaluation
Properties dialog box, you are prompted to select a template now.

4 Select a file directory, and enter a name for the XLS evaluation
file.

5 Click Save.

6 When the export is finished, click Close.

The space evaluation file is saved to the specified directory. You can open it
with Microsoft Excel or any other spreadsheet application that can read XLS.

Creating a TXT Evaluation Document
Use this procedure to export a space evaluation to a text file.

NOTE In TXT format, you can export text (results, modifier expressions, and
labels), but not images. If you need to export images in the evaluation, use XLS
format instead.

You can create your own TXT templates into which the evaluation is then
integrated.

1 Open the Scheduling tool palette, and select the Space Evaluation
tool.

NOTE Alternatively, you can click Home tab ➤ Inquiry panel ➤ 

 ➤ Space Evaluation  .

2 Prepare the evaluation as described in Preparing the Space
Evaluation on page 3178.

3 In the Space Evaluation dialog box, click  .
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If you did not select a default TXT template in the Evaluation
Properties dialog box, you are prompted to select a template now.

4 Select a file directory, and enter a name for the space evaluation
file.

5 Click Save.

6 When the export is finished, click Close.

The space evaluation file is saved to the specified file directory. You can open
it with any word processor.

Creating XLT Templates
Use this procedure to create the XSLT template file needed for exporting a
space evaluation to an Excel spreadsheet.

You can use the following predefined field settings to format your XLT
templates:

DescriptionField name

The row in which the space evaluation be-
gins

AREA_EVALUATION_BEGIN

The column in which the exported space
images are placed

AREA_COLUMN_IMAGE

The column in which the space labels and
descriptions are placed

AREA_COLUMN_LABEL

The column in which the space decompos-
ition expressions and modifier formulas are
placed

AREA_COLUMN_EXPRESSION

The column in which all space results are
placed

AREA_COLUMN_RESULT

The column in which the unrounded space
results are placed

AREA_COLUMN_EXACT_VALUE

1 Open Microsoft Excel.

2 Select the table cell in which you want to place a special type of
information, such as pictures or results.
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3 Click the name box in the upper-left corner of the Excel sheet,
and enter the desired field definition.

4 Repeat steps 2 and 3 for all field settings you want to place.

5 Define additional settings for your template. Settings in an XLT
file include

■ Header and footer information

■ Company logos

■ Company fonts

■ Special cell formatting (borders, colors)

6 Save the resulting file with the extension XLT (Excel Template)
to the default directory you are using for templates.

The template is then available for selection next time you create
a space evaluation.

Using Spaces for Load Analysis
You can use spaces and zones to aid in calculating the heating and cooling
loads for a building plan.

After you create spaces and zones, you can assign to them engineering data
necessary for calculating loads and airflows. You export the engineering and
building information in Green Building XML (gbXML) format. You can use
gbXML files in external analysis tools. After you analyze the file, you can
import the results into your drawing. You can view the calculated loads and
airflows for the spaces and zones, and design your duct systems accordingly.

Configuring Space Styles
You can configure space styles for the different room types in the building
plan. For example, if you are designing an HVAC system for a manufacturing
facility, you can create space styles for offices, manufacturing areas, and
warehouse areas.

Regarding load calculations, the most important setting for a space style is its
classification. When you define a classification for a space style, the occupant
density and outside air flow requirements are automatically set. These values
are included in the software, and are based on the appropriate mechanical
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standard or code. For more information, see Viewing Classification Settings
on page 3191.

If multiple rooms use the same density of lighting and equipment, you can
add property sets to the style that enable you to specify lighting and equipment
loads per area. This alleviates the need to manually enter lighting and
equipment loads for each individual space. If you need to change the lighting
and equipment load for a space, you can override these values using the
Properties palette.

To specify a lighting and equipment load per area in the space style

1 Create a new space style, as described in Creating a Space Style
on page 3094.

2 In the right pane, click the General tab.

3 At the bottom of the pane, click Property Sets.

4 In the Edit Property Sets Data dialog, click  (Add property sets).

5 In the Add Property Sets dialog, select SpaceEngineeringStyles,
and click OK.

NOTE If this property set is not available, you can copy and paste it
from the Aecb Model drawing template using Style Manager. In Style
Manager, it is located in Documentation Objects ➤ Property Set
Definitions.

6 In the Edit Property Sets Data dialog, enter the area lighting and
equipment loads.

You can also specify a gbXML space type override if you want to
restrict this style to a specific space type. If you use this setting,
it overrides any classification you specify for the space style as
shown in the following steps.

7 Click OK.

To specify a classification

8 Click the Classifications tab.

9 For Space Occupancy, click [...].

10 In the Select Classification dialog, expand the directories under
the desired standard, select a space type, and click OK.

11 Use the previous steps to create additional space styles.

12 To modify the display of spaces with the selected style, click the
Display Properties tab, and modify the display settings as desired.
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NOTE You must assign a classification to use the gbXML export
feature. You can assign a classification to the space style, or you can
specify a classification override in the space style property set. You
can also manually specify a classification on the Extended Data tab
of the Properties palette.

13 Click OK.

Viewing Classification Settings
You can view the occupant densities and air flows configured for classification
types.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 In Style Manager, click Space Occupancy.

3 In the right pane, click the Classifications tab.

4 Expand the classifications under Space Occupancy, and select the
space type you want to view.

5 On the right side of Style Manager, click Property Sets.

The Edit Property Set Data dialog displays the values for the
classification.

Configuring Zone Styles
You can create zone styles to specify the display and design rules for zones.
In regard to load calculations, however, zone styles have no relevant settings
that you need to configure. Zone styles are located in Style Manager under
the Documentation Objects. For complete information, see Zone Styles on
page 3138.

Adding Engineering Data to Spaces
For load calculation purposes, you must add a SpaceEngineeringObjects,
ThermalProperties, andZoneEngineeringObjects styles property sets to all
spaces that you want to analyze. From the Style Manager, copy property set
definitions from the gbxml Property Set Definitions drawing into your current
drawing. Once you have assigned these property set definitions to the spaces
and zones in your drawing, you can edit the engineering data to model the
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appropriate environmental conditions. You are then ready export this data
in gbXML format for use in various analysis software programs.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 In the Style Manager, click File menu ➤ Open Drawing.

3 In the Open Drawing dialog, click Content.

4 Navigate to the Styles/Imperial folder.

5 Select the gbxml Property Set Definitions (Imperial) drawing and
click Open.

6 Expand the gbxml Property Set Definitions Documentation
Objects folder.

7 Select Property Set Definitions.

The SpaceEngineeringObjects, ThermalProperties, and
ZoneEngineeringObjects styles comprise this property set.

8 Copy the Property Set Definitions to your current drawing, and
then click OK.

The engineering data styles are ready to be applied the spaces and
zones in your drawing.

9 Select the spaces to which you want to add the property set data.

10 On the Properties palette, click the Extended Data tab, and then

click  (Add property sets).

11 In the Add Property Sets dialog, select SpaceEngineeringObjects
and SpaceObjects, and then click OK.
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The property set is added to the selected spaces, and it can be
viewed on the Extended Data tab.

12 Under Property Sets, you can specify values for the following
properties:

DescriptionProperty

Specify how to condition the
room.

ConditionType

Enter the lighting load for the
room. If you specified lighting

LightingLoad

load per area in the style, the
DefaultLightingLoad property set
calculates the lighting load based
on the room area. You can over-
ride that value by entering a
value for LightingLoad here.

Enter the equipment load for the
room. If you specified equipment

EquipmentLoad

load per area in the style, the
DefaultEquipmentLoad property
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DescriptionProperty

set calculates the equipment load
based on the room area. You can
override that value by entering a
value for EquipmentLoad here.

Enter outside airflow value.OutsideAirFlow

Enter supply and return airflow
values for your reference. These

SupplyAirFlow
and ReturnAir-
Flow values are for the flow rate for

the room, not for the flow per
unit area or per person.

Attaching Property Sets to Zones
Before exporting space data to gbXML, you must assign all spaces to a zone.
You configure a zone for analysis by specifying the heating and cooling
temperatures for the zone.

To attach property sets to a zone

1 Create zones, as described in Creating a Zone Style on page 3139.

2 Select all zones.

3 On the Extended Data tab of the Properties palette, click  (Add
property sets).

4 In the Add Property Sets dialog, select ZoneEngineeringObjects,
and click OK.
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The property set is added to the selected zone, and it can be viewed
on the Extended Data tab.

5 Under Property Sets, specify the appropriate values for design
heating and cooling temperatures.

Attaching Spaces to Zones
For load calculation purposes, you must assign all spaces to one or more zones.
You can also attach zones to other zones. This is useful for exporting zone
data through reference drawings.

1 Select a zone.

2 Click the Add (Plus) grip or click Zone tab ➤ Modify

panel ➤ Attach  .

3 Select the spaces or zones to attach to the zone.

You can attach spaces or zones in reference drawings to a zone
in the current drawing.

4 Continue attaching spaces to zones using the previous steps.

IMPORTANT Zones in reference drawings cannot be exported to
gbXML unless they are attached to a zone in the current drawing.

TIP You can use the Space/Zone Manager to review the zone
hierarchy, and to review space information such as surface and
opening type. For more information, see Opening the Space/Zone
Manager on page 3062 and Editing Surface Properties on page 3064.
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Exporting Zones for Load Analysis
After you have configured spaces with property set values, and have attached
spaces to zones, you can export the engineering and building information in
gbXML format.

1 Open the drawing that contains the zone data you want to
analyze.

NOTE You can analyze a complete building by attaching zones and
spaces in xref drawings to zones in a current drawing. The adjacent
spaces and space surface types are automatically detected for all
spaces at export.

2 Click  ➤ Export ➤ gbXML.

3 In the Export to gbXML dialog, specify the export settings:

■ File name: Specify a file name and location.

■ Select Objects: The dialog automatically detects all zones in
the current drawing. Zones in reference drawings cannot be
exported unless they are attached to a zone in the current
drawing. If the dialog does not detect all zones, click Select
Objects and select the desired zones.

■ Building Type: Specify a building type and postal ZIP code
that may be used by the external analysis program.

■ Progress: Click Start to run the export.
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■ Success: If any errors occur during export, click View Event
Log to view error messages.

4 Click Close.

The gbXML file can now be used in various analysis software
programs.

Conversion of Space Boundaries to Walls and Spaces
Space boundaries from previous versions of the software will not persist as
independent objects in AutoCAD Architecture. When a legacy drawing is
opened in the current version of the software, any legacy space boundaries
will be converted to walls. If the legacy space boundary manages contained
spaces, these will be converted to spaces associative to the converted walls.

All legacy space boundary edges are converted to walls. Edges of the boundary
type Separation or edges of the boundary type Solid with 0 width are converted
to 0 width walls. If the legacy space boundary manages contained spaces,
those spaces are associative to the converted walls.

Legacy property set definitions that apply to legacy space boundaries will
automatically be migrated to property set definitions that apply to walls.
Legacy property data attached to space boundaries will be attached to the
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walls that are optionally created from the space boundary during drawing
migration.

Appendix 1: Command Changes for Spaces and Areas
Since the merge of areas and spaces, a number of commands have become
obsolete or have been changed to other names.

Area Commands
The following area-related commands are obsolete. Corresponding current
space commands are listed where applicable:

New commandPrevious command

N/AAecSpaceConvertArea

AecSpaceAddAecAreaAdd

N/AAecAreaConvert

AecSpaceAutoGenerateAecAreaDetect

AecSpaceStyleAecAreaStyle

AecListDefinitionAecNameDef

AecSpaceAecArea

AecSpaceAddSelectedAecAreaAddSelected

AecSpaceAttachAecAreaAttach

AecSpaceCreatePlineAecAreaCreatePline

AecSpaceDetachAecAreaDetach

AecLineworkDivideAecAreaDivide

AecSpaceEvaluationAecAreaEvaluation

AecLineworkCropAecAreaOpIntersect
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New commandPrevious command

AecLineworkMergeAecAreaOpJoin

AecLineworkSubtractAecAreaOpSubtract

AecSpacePropsAecAreaProps

AecSpacePropertiesN/A

AecSpaceRemoveVoidAecAreaRemoveRing

AecSpaceReverseProfileAecAreaReverseProfile

AecSpaceReverseRingAecAreaReverseRing

AecSpaceStyleAecAreaStyle

AecSpaceStyleEditAecAreaStyleEdit

N/AAecAreaToolToAutoDetection

N/AAecAreaToolToLinework

AecLineworkTrimAecAreaTrim

AecSpaceVertexModifyAecAreaVertexModify

AecSlabConvertSpaceAecSlabConvertArea

Area Group Commands
The following area group-related commands are obsolete. Corresponding
current zone commands are listed where applicable:

New commandPrevious command

AecZoneAddAecAreaGroupAdd

AecZoneStyleAecAreaGroupStyle

AecZoneCreateFromTemplateAecGroupCreateFromTemplate
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New commandPrevious command

AecZoneTemplateAecGroupTemplate

AecZoneAecAreaGroup

AecZoneAddSelectedAecAreaGroupAddSelected

AecZoneAttachAecAreaGroupAttach

AecZoneCreatePlineAecAreaGroupCreatePline

AecZoneDetachAecAreaGroupDetach

AecZoneLayoutAecAreaGroupLayout

AecZonePropsAecAreaGroupProps

AecZonePropertiesN/A

AecZoneStyleEditAecAreaGroupStyleEdit

Space Boundary Commands
The following space boundary commands are now obsolete:

New commandPrevious command

AecWallAecSpaceBoundary

AecWallAddAecSpaceBoundaryAdd

N/AAecSpaceBoundaryConvert

N/AAecSpaceBoundarySplit

N/AAecSpaceBoundaryProps

N/AAecSpaceBoundaryAddEdges

N/AAecSpaceBoundaryRemoveEdges

N/AAecSpaceBoundaryConvertEdges
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New commandPrevious command

N/AAecSpaceBoundaryInsertJoint

N/AAecSpaceBoundaryMerge

N/AAecSpaceBoundaryMergeSpace

N/AAecSpaceBoundaryGenerateWalls

N/AAecSpaceBoundaryEdge

N/A-AecSpaceBoundaryModify

N/AAecSpaceBoundaryConvertSpace

N/AAecSpaceBoundaryConvertSlice

N/AAecSpaceBoundaryConvertEdge

N/AAecSpaceBdyToolToEdges

N/AAecSpaceBdyToolToSpace

N/AAecSpaceBdyToolToSlice

N/AAecSpaceBoundaryAddSelected

Appendix 2: Predefined Area Calculation Standards
You can calculate the offsets of space boundaries according to an area
calculation standard defined for a drawing. Area calculation standards usually
contain country or organization specific rules by which space boundaries must
be set up. AutoCAD Architecture provides 3 predefined area calculation
standards based on the rules of the BOMA, DIN-277, and SIS standards. In
addition, a generic Basic standard is supplied. The following sections outline
the rules of these standards that have been implemented in the software. For
more detailed information, use a regulation book for the desired standard.

For information about applying an area calculation standard to a drawing,
see Working with Space Boundaries on page 3004.
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For information about creating your own area calculation standard, see
Appendix 3: Implementing an Area Calculation Standard Plug-in with the
AutoCAD Architecture 2012 .NET API on page 3217.

Calculating Spaces Based on the Basic Area Calculation Standard
The Basic area calculation standard supplied with AutoCAD Architecture
provides a rule for the general practice of measuring gross and net area as
accepted by most building inspectors and zoning officials in the US.

BoundaryWall Typeboundary
Objects

Classi-
fica-
tion

Space
Boundary
Type

Measured to center-
line of door panel

Wall with adjacent
spaces

DoorN/ANet

Measured to center-
line of opening frame

Wall with adjacent
spaces

OpeningN/ANet

Measured to adjacent
face

WallWallsN/ANet

Measured to oppos-
ite face

Wall without adja-
cent spaces

WallsN/AGross

Measured to center-
line of wall

Wall with adjacent
spaces

WallsN/AGross

Calculation Rules for AutoCAD Objects

You can use AutoCAD objects like closed polylines or rectangles to generate
a space that is deducted from an associative space (see Deducting Spaces from
an Associative Space on page 2971.) You could do this for example to represent
construction spaces or otherwise unavailable areas. Since AutoCAD objects
cannot be classified to control their behavior, the following standard behavior
is applied to enclosed deducted spaces formed by AutoCAD objects in the
Basic standard:

■ Net area: the area enclosed by AutoCAD linework is deducted from the
net area.

■ Gross area: the area enclosed by AutoCAD linework is not deducted from
the gross area.
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Calculating Spaces Based on the DIN 277 Standard
DIN 277 is the area calculation standard for Germany and German-speaking
countries. The DIN 277 standard included in AutoCAD Architecture includes
the subset of DIN 277 rules described in the following sections:

Space Classifications in DIN 277
The space type classifications in DIN 277 are the following:

DefinitionSpace Type_DIN

A ■ has roof

■ fully enclosed by walls or curtain walls
on all sides

■ the wall or curtain wall is as high or
higher than the space=full height en-
closure

B ■ has roof

■ partially enclosed by walls or curtain
walls

■ at least one wall or curtain wall is lower
than the space=partial height enclosure

C ■ no roof

Exterior ■ exterior space

The net area type classifications in DIN 277 are the following:

UseNetArea Type_DIN

Living, office, production, craft, experiments,
storage, sale, education, culture, health care,
other uses

Utilized

Operations, mechanical room, water supply,
heating room, electrical room, etc.

Technical
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UseNetArea Type_DIN

Halls, corridors, stairs, elevators, etc.Circulation

Calculation Rules for AutoCAD Objects

You can use AutoCAD objects like closed polylines or rectangles to generate
a space that is deducted from an associative space (see Deducting Spaces from
an Associative Space on page 2971.) You could do this for example to represent
construction spaces or otherwise unavailable areas. Since AutoCAD objects
cannot be classified to control their behavior, the following standard behavior
is applied to enclosed deducted spaces formed by AutoCAD objects in the DIN
277 standard:

■ Net area: the enclosed area is deducted from the net area.

■ Gross area: the enclosed area in not deducted from the gross area.

Net Area Calculations

The net boundaries are created on the inside of the walls.

Technical spaces: When the area of a technical space is larger than or equal
to 1 m2, the net boundary will be calculated to the inside of the wall. When
the area of a technical space is smaller than 1 m2, the space will not have a
net boundary, and the area will be calculated as constructive area.
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Gross Area Calculations
The gross boundaries are created according to the following rules:

Gross Area (Space Type_DIN A)

BoundaryAdjacent Space

Measured from centerline of wallSpace Type_DIN A

Measured from outside face of wallSpace Type_DIN B or C, or no adjacent
space

Measured from outside face of wallAdjacent space not classified (unspecified)
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Gross Area (Space Type_DIN B)

BoundaryAdjacent Spaces

Measured from inside face of wallSpace Type_DIN A

Measured from centerline of wallSpace Type_DIN B

Measured from outside face of wallSpace Type_DIN C or no adjacent space

Measured from outside face of wallAdjacent space not classified (unspecified)

Gross Area (SpaceType_DIN C)

BoundaryAdjacent Spaces

Measured from inside face of wallSpace Type_DIN A or B

Measured from centerline of wallSpace Type_DIN C
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Gross Area (SpaceType_DIN C)

BoundaryAdjacent Spaces

Measure from outside face of wallNo adjacent space

Measured from outside face of wallAdjacent space not classified (unspecified)

Calculating Spaces Based on the SIS Standard
SIS is the area calculation standard for Sweden and is used with some variations
across all Scandinavian countries. The SIS standard included in AutoCAD
Architecture includes the subset of SIS rules described in the following sections:

Tenants/Units

When selecting the SIS area calculation standard in AutoCAD Architecture,
the zone style Unit Usage_SIS will automatically be created. This zone style
can be used to specify the usage of the spaces in the drawing. The calculation
of the usable boundary is dependent on whether the adjacent spaces are in
the same unit or not. The usable boundaries are created to the interior side of
the wall when the adjacent space is attached to another zone. If the adjacent
space is attached to the same zone, the usable boundary is offset 0.15m into
the wall.

Shafts

Shafts need to be classified as Shaft. (For more information, see Classifying a
Space According to an Area Calculation Standard on page 3011.) Shaft spaces
do not have usable boundaries. The usable area will report N/A. When a shaft
is in the same zone as its adjacent spaces, the usable boundaries of the adjacent
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spaces are measured 0.15m into the shaft. The distance is measured from the
inside of the wall and into the shaft. When a shaft is not in the same zone as
its adjacent spaces, the usable boundaries of the adjacent spaces are measured
to the inside of the wall.

NOTE The interaction between the spaces and zones will only work as described
if the zones are in the same drawing as the attached spaces.

Calculation Rules for AutoCAD Objects

You can use AutoCAD objects like closed polylines or rectangles to generate
a space that is deducted from an associative space (see Deducting Spaces from
an Associative Space on page 2971.) You could do this for example to represent
construction spaces or otherwise unavailable areas. Since AutoCAD objects
cannot be classified to control their behavior, the following standard behavior
is applied to enclosed deducted spaces formed by AutoCAD objects in SIS:

■ Net area: the enclosed area is deducted from the net area.

■ Usable area: the enclosed area is deducted from the usable area.

■ Gross area: the enclosed area is not deducted from the gross area.
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Room Height

According to the SIS standard, a space should have a room height of at least
1.90 meter with a width of at least 0.6 meter to be counted as measurable area.
The SIS calculation standard delivered with this software is automatically
checking the height of each space to make sure the space height conditions
are met. Otherwise, the boundaries for Net area (NTA) and Usable Area (BRA)
are offset according to the SIS standard rules.

The room height rule is applied only to associative 3D freeform spaces. For
extruded 3D spaces the user-defined space height is used uniformly on the
space.

NOTE The calculation of the room height for SIS is new to AutoCAD Architecture
2012. In previous versions the room height was not automatically calculated for
the SIS standard. If you have legacy drawings from earlier versions, SIS-calculated
spaces might change their boundaries when opening the drawing in AutoCAD
Architecture 2012.

Net Area (NTA)

The following rules apply to the generation of net boundaries with the SIS
standard:

■ The net boundaries are measured to the inside of the wall.
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■ If wall openings have a width larger than or equal to 1.50m, the net
boundaries are offset to the center of the wall.

■ If doors have a width larger than or equal to 1.50m, the net boundaries
are offset to the inside of the door frame.

■ If wall openings have a width smaller than 1.50m, the net boundaries are
measured to the inside of the wall.

■ If columns are set to bound spaces, as described in Setting the Bound Spaces
Property in the Object Style on page 2949 and Setting the Bound Spaces
Property in the Properties Palette on page 2949, the area of the column will
be subtracted from the net area.

Usable Area (BRA)

The following rules apply to the generation of usable boundaries with the SIS
standard:

■ The usable boundaries of a space are offset 0.15m into the wall if the space
has an adjacent space. If the width of the wall is less then 0.30m the offset
will be to the center of the wall. If there is no adjacent space, the usable
boundaries are measured to the inside of the wall.
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■ If wall openings have a width larger than or equal to 1.50m, the usable
boundaries are offset to the center of the wall.

■ If doors have a width larger than or equal to 1.50m, the usable boundaries
are measured to the inside of the door frame.

■ If wall openings have a width smaller than 1.50m, the usable boundaries
are offset 0.15m into the wall.

■ If columns are set to bound spaces, as described in Setting the Bound Spaces
Property in the Object Style on page 2949 and Setting the Bound Spaces
Property in the Properties Palette on page 2949 the usable boundary will be
offset 0.15m into the column. The rest of the column area will be subtracted
from the usable area.
Freestanding columns are calculated as an interior wall. The usable
boundary is offset 0.15m into the column.
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Gross Area

The following rules apply to the generation of gross boundaries with the SIS
standard:

■ The gross boundaries are measured to the center of the wall if the space
has an adjacent space. If there is no adjacent space, the gross boundary is
offset to the opposite side of the wall.

■ If columns are set to bound spaces, as described in Setting the Bound Spaces
Property in the Object Style on page 2949 and Setting the Bound Spaces
Property in the Properties Palette on page 2949 the area of the column will
not be subtracted from the gross area.

Calculating Spaces Based on the BOMA Standard
BOMA is an area calculation standard used predominantly in the United States.
The BOMA standard included in AutoCAD Architecture includes the subset
of BOMA rules that are described in the following sections.
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In the BOMA area calculation standard, spaces are classified as follows:

Space TypeClassification

OfficeOffice Area

StoreStore Area

Stairs, elevator shafts, flues, pipe shafts,
vertical ducts, atria, atrium spaces above

Major Vertical Penetration (MVP)

the finished floor, light wells, and similar
penetrations above the finished floor

NOTE Not included are vertical penetra-
tions built for the private use of a tenant
occupying office area on more than one
floor.

Washrooms, janitorial closets, electrical
rooms, telephone rooms, mechanical

Floor Common Area (FCA)

rooms, elevator lobbies, and public cor-
ridors

Lobbies, atrium spaces at the level of the
finished floor, concierge area or security

Building Common Area (BCA)

desks, conference rooms, lounges or
vending areas, food service facilities, health
or fitness centers, daycare facilities, locker
or shower facilities, mail rooms, fire control
rooms, fully enclosed courtyards outside
the exterior walls, and building core and
service areas such as fully enclosed mech-
anical or equipment rooms.

Exterior spacesExterior

Exterior space of store spaces at street levelStreet frontage

Calculation Rules for AutoCAD Objects

You can use AutoCAD objects like closed polylines or rectangles to generate
a space that is deducted from an associative space (see Deducting Spaces from
an Associative Space on page 2971.) You could do this for example to represent
construction spaces or otherwise unavailable areas. Since AutoCAD objects
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cannot be classified to control their behavior, the following standard behavior
is applied to enclosed deducted spaces formed by AutoCAD objects in BOMA:

■ Net area: the enclosed area is deducted from the net area.

■ Usable area: the enclosed area is not deducted from the usable area.

■ Gross area: the enclosed area in not deducted from the gross area.

Net Area

The net boundaries will be created inside of the wall.

Usable Area

When calculating exterior walls, the usable boundaries will be created inside
the window glass if the window height is larger or equal to 50% of the space
ceiling height. The usable boundaries will be created inside of the wall if the
window height is smaller than 50% of space ceiling height.

Usable Area (Space Type_BOMA:
MVP)

BoundaryAdjacent Spaces

Measured from outside face of wallOffice, Store, BCA, FCA

Measured from centerline of wallMVP
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Usable Area (Space Type_BOMA:
FCA)

BoundaryAdjacent Spaces

Measured from outside face of wallOffice, Store, BCA

Measured from centerline of wallFCA

Measured from inside face of wallMVP

Usable Area (Space Type_BOMA:
Store Area)

BoundaryAdjacent Spaces

Measured from outside face of wallStreet frontage

Measured from centerline of wallOffice, Store, BCA
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Usable Area (Space Type_BOMA:
Store Area)

BoundaryAdjacent Spaces

Measured from inside face of wallMVP, FCA

Usable Area (Space Type_BOMA: Of-
fice Area)

BoundaryAdjacent Spaces

Measured from inside face of wallFCA, MVP

Measured from centerline of wallOffice, Store, BCA

Usable Area (Space Classification:
BCA)

BoundaryAdjacent Spaces

Measured from inside face of wallFCA, MVP

Measured from centerline of wallOffice, Store, BCA
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Gross Area

The gross boundaries will be created to the outside face of the wall if there is
no adjacent space or the adjacent space is street frontage.

The gross boundaries will be created to the centerline of the wall if there is an
adjacent space other than street frontage/exterior.

Appendix 3: Implementing an Area Calculation Standard
Plug-in with the AutoCAD Architecture .NET API

Area calculation standards are .NET plug-ins that implement a set of rules to
define offsets for the net, usable, and gross boundaries of spaces in AutoCAD
Architecture 2012. When a plug-in is loaded into the software, it will be
available to be applied to a drawing as described in Specifying an Area
Calculation Standard for a Drawing on page 3010. Only one area calculation
standard can be applied to a drawing. If the boundary offsets of a space are
set to By Standard, the calculation standard that is currently assigned to the
drawing will be applied to create the boundary offsets. For more information,
see Changing the Area Calculation Standard for Existing Spaces on page 3012.
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Boundaries generated by Basic area calculation standard

The API (Application Programming Interface) that is used to implement those
plug-ins is available for 3rd party developers as part of the AutoCAD
Architecture .NET API. This appendix describes how to implement a custom
area calculation standard.

System Requirements

In order to implement a new area calculation standard plug-in, you must have
a system with AutoCAD Architecture 2012 installed. You also need a
development environment capable of creating assemblies for the .NET
Framework 2.0, such as Visual Studio 2005, Visual C# 2005, Visual Basic 2005
or the .NET Framework 2.0 Software Development Kit (SDK).

Implementing an Area Calculation Standard
The following sections describe the .NET API that is used to implement area
calculation standards, referencing the sample project that is delivered with
AutoCAD Architecture as a C# as well as a VB.NET project. This documentation
uses the C# project.

Setting up a New Project
Before you can implement a new standard, you must create a new project
from your development environment. Alternatively, you may use the sample
project AecSpaceOffsetStandardSample.

NOTE An area calculation standard plug-in is implemented as a .NET class library,
not a Windows application.

1 Open Microsoft Visual Studio 2005.
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2 Select the New tab on the main menu.

3 Click File menu ➤ Project.

4 In the New Project dialog, choose the class library template from
one of these locations:

■ Visual Basic ➤ Windows

■ Visual C# ➤ Windows

■ Visual C++ ➤ CLR.

Defining project settings

5 Enter a name for the new project.

It is recommended to use the prefix AecAreaCalculationStandard,
for example to create a name like
AecAreaCalculationStandardMyOffsetRules. This way the naming is
consistent with the naming of the plug-ins provided with
AutoCAD Architecture (for example AecAreaCalculationStandardBasic,
AecAreaCalculationStandardBOMA, etc.) The software then recognizes
that this prefix describes an area calculation plug-in and is able
the extract the name from the assembly for diagnostic purposes.

Before proceeding, verify that you have a .NET class library project
set up, so you can start editing the source code and project files.

Setting up required assembly references

6 In order to create an area calculation standard plug-in, the .NET
class library created in the previous steps needs to reference the
.NET API that AutoCAD Architecture provides. This API is
implemented in the AecSpaceOffsetRuleManager.dll assembly which
you need to reference in your new project.

Adding references to the project

7 If you are working with Microsoft Visual Studio, you can add the
assembly reference to AecSpaceOffsetRuleManager.dll to your class
library project by right-clicking References in the Solution Explorer
of the project, and selecting Add Reference.

8 Navigate to the Browse page on the property sheet and search for
the AecSpaceOffsetRuleManager.dll assembly under C:\Program
Files\AutoCAD Architecture 2012 (or the path you chose during
installation).
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Referencing the AutoCAD Architecture and AutoCAD .NET API

9 Add references to the following assemblies of your installation:

■ acdbmgd.dll (AutoCAD .NET API)

■ aecbasemgd.dll (AutoCAD Architecture base classes)

■ aecarchmgd.dll (AutoCAD Architecture objects)

These DLLs are found in the same folder as the
AecSpaceOffsetRuleManager.dll assembly.

10 Right-click each reference in the Solution Explorer tree under
References, and click Properties to verify that the Copy Local
reference property is set to False for each of the references.

Setting up copying the .dll so that AutoCAD Architecture can reference it

AutoCAD Architecture searches for custom area calculation standard assemblies
in C:\Program Files\AutoCAD Architecture 2012\Space Calculation Standards, or the
path you chose during installation (see Usage of a New Standard on page 3243).
Each time you compile the .dll you need to restart AutoCAD Architecture in
order to load and test it. Do the following to set up copying the .dll to the
appropriate folder each time it is compiled:

11 Select the project in the Solution Explorer.

12 Right-click, and click Properties.

13 Click the Build Events tab.

14 On the Post-build event command line, enter the following:

@if exist $(TargetPath) @copy $(TargetPath) "C:\Program

Files\AutoCAD Architecture 2012\Space Calculation Stand

ards\"

@if exist $(TargetDir)$(TargetName).pdb @copy $(Target

Dir)$(TargetName).pdb "C:\Program Files\AutoCAD Architec

ture 2012\Space Calculation Standards\"

Creating a Space Standard Class
You must define a new class derived from AecSpaceOffsetStandard. This class
will be the framework that manages the individual rules and the entry point
that AutoCAD Architecture calls into when loading and applying the standard.
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Adding a new class derived from AecSpaceOffsetStandard

1 If you have created a new project, as described in Setting up a
New Project on page 3218, the project will include one source file
similar to this:

using System;

using System.Collections.Generic;

using System.Text;

namespace AecSpaceOffsetStandardSample

{

public class Class1

{

}

}

Add your standard class derived from the abstract base class
Autodesk.Aec.SpaceOffsetRulesManager.AecSpaceOffsetStandard.

NOTE The Autodesk.Aec.SpaceOffsetRulesManager namespace is only
available if you have correctly set up the reference to
AecSpaceOffsetRuleManager.dll.

Including the Autodesk.Aec.SpaceOffsetRulesManager namespace

2 To simplify the creation of the area calculation standard plug-in,
it is recommended to add a namespace for all required classes.
Add the following code line to your source file:

using Autodesk.Aec.SpaceOffsetRulesManager;

3 Rename Class1 to a name describing your standard (for example,
AecSpaceOffsetStandardMyStandard) and make it a derivation of the
AecSpaceOffsetStandard abstract base class.

4 Add a parameterless default constructor to the class, which will
be needed in the following steps:

using System;

using System.Collections.Generic;

using System.Text;

using Autodesk.Aec.SpaceOffsetRulesManager;

namespace AecSpaceOffsetStandardSample

{

public class AecSpaceOffsetStandardSample : AecSpaceOff

setStandard

{

public AecSpaceOffsetStandardSample()
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{

}

}

}

Implementing the standard interfaces

5 When the new class is set up correctly in your source file, you can
start implementing some of the methods that the base class
AecSpaceOffsetStandard exposes and that AutoCAD Architecture
will call into.

Adding a call to the AecSpaceOffsetStandard.SetName(string name) method

6 The AecSpaceOffsetStandard.SetName() method is implemented in
the base class and cannot be overridden. It needs to be called to
register a name for the standard in the constructor of the class.
This is the name that will show up in the list of available area
calculation standards in AutoCAD Architecture. For more
information, see Specifying an Area Calculation Standard for a
Drawing on page 3010.

Add the call to the SetName() method in the constructor of your
class.

The following example shows the call for the sample project
AecSpaceOffsetStandardSample which registers itself in the software
as the Basic area calculation standard.

public class AecSpaceOffsetStandardSample : AecSpaceOff

setStandard

{

public AecSpaceOffsetStandardSample ()

{

SetName("Basic");

}

}
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Adding the AecSpaceOffsetStandard.InitRules() method

7 After registering the area calculation standard plug-in name, you
must add the new AecSpaceOffsetStandardSample.InitRules() method
to your class. The method will override the abstract
AecSpaceOffsetStandard.InitRules() interface. AutoCAD Architecture
will call that interface to register all individual offset rules you
are going to implement. As this method is abstract, it must be
implemented by your custom standard class. See the following
example for instructions:

public class AecSpaceOffsetStandardSample : AecSpaceOff

setStandard

{

public AecSpaceOffsetStandardSample ()

{

SetName("Basic");

}

protected override void InitRules()

{

// register rules

}

}

Registering rules with InitRules()

8 The rule objects of the standard must be registered with the 3
different offset boundaries (net, usable, and gross). The
AecSpaceOffsetStandard base class has 3 containers for these rule
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sets, which the derived class can add new rule instances to. These
containers can be referenced with the following methods:

■ AecSpaceOffsetStandard.NetRules()

■ AecSpaceOffsetStandard.UsableRules()

■ AecSpaceOffsetStandard.GrossRules()

For information about implementing the individual rules in a
standard, see Implementing Offset Rules on page 3226.

Each of these calls will return a reference to an object of the
Autodesk.Aec.SpaceOffsetRulesManager.AecSpaceOffsetRuleCollection
class, which exposes functions to register the different rule types.
These objects are maintained and used by AutoCAD Architecture.
The following example shows how to register rules with the 3
different offset types:

public class AecSpaceOffsetStandardSample : AecSpaceOff

setStandard

{

public AecSpaceOffsetStandardSample ()

{

SetName("Basic");

}

protected override void InitRules()

{

// Register the rules with this standard, so the

// offset calculation algorithm can call them

// for the according boundary type

NetRules().AppendBoundingOpeningRule(new BoundingOpen

ingRuleNet());

// no usable boundary

UsableRules().SetSpaceRule(new NullSpace());

GrossRules().AppendBoundingObjectRule(new BoundingOb

jectRuleGross());

GrossRules().AppendBoundingAdjacencyRule(new

BoundingAdjacencyRuleGross());

}

}

Implementing the AecSpaceOffsetStandard.InitCurrentDatabase() method
(Optional)

9 AecSpaceOffsetStandard provides another virtual method that your
own standard can implement:
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AecSpaceOffsetStandard.InitCurrentDatabase(). Since this is not an
abstract method of the base class, it can be implemented, but is
not mandatory, as opposed to the InitRules() method. It can be
used by an area calculation standard to initialize the current
drawing with additional data that the rules might require, such
as classification definitions or zone styles. If implemented,
AutoCAD Architecture will call that implementation every time
the standard is assigned to a drawing. The usage of that method
is described in an example in Advanced: Using Classifications in
Area Calculation Standards on page 3244.

public class AecSpaceOffsetStandardSample : AecSpaceOff

setStandard

{

public AecSpaceOffsetStandardSample ()

{

// set the name of the standard

SetName("Basic");

}

// must be overriden

protected override void InitRules()

{

}

// can be overriden

protected override void InitDatabase(Database* database)

{

// ...init database with classification definitions

or zone styles, etc...

}

}
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Reference: AecSpaceOffsetStandard Class

The following list shows all members of the AecSpaceOffsetStandard base class:

namespace Autodesk.Aec.SpaceOffsetRulesManager

{

public abstract class AecSpaceOffsetStandard

{

protected internal AecSpaceOffsetStandard();

protected internal void SetName(string str);

protected internal abstract void InitRules();

protected internal AecSpaceOffsetRuleCollection NetRules();

protected internal AecSpaceOffsetRuleCollection UsableRules();

protected internal AecSpaceOffsetRuleCollection GrossRules();

protected internal virtual void InitDatabase(Database* data

base);

protected internal virtual bool IsStandardStyle(ObjectId id

Style);

}

}

Reference: AecSpaceOffsetRuleCollection Class

The following list shows all members of the AecSpaceOffsetRuleCollection base
class:

namespace Autodesk.Aec.SpaceOffsetRulesManager

{

public class AecSpaceOffsetRuleCollection

{

public void AppendBoundingAdjacencyRule(AecBoundingAdjacencyR

ule rule);

public void AppendBoundingObjectRule(AecBoundingObjectRule

rule);

public void AppendBoundingOpeningRule(AecBoundingOpeningRule

rule);

public void SetSpaceRule(AecSpaceRule rule);

}

}

Implementing Offset Rules
After creating a new standard class, rules must be implemented. The code so
far can be compiled and the built assembly can successfully be loaded as an
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area calculation standard into AutoCAD Architecture and be applied to space
objects in a drawing. However, no offsets will be created, because no rules
have been set up yet.

There are 4 different types of offset rules that can be combined to define an
area calculation standard. A rule can be applied to one or more offset types
(net, usable, and gross) in the implementation of
AecSpaceOffsetStandard.InitRules(). For each rule type there is a base class that
the implementation of a custom rule needs to derive from. All of these base
classes are derived from one common abstract base class, so it is recommended
to view that class first.

AecSpaceOffsetBaseRule Abstract Base Class
The AecSpaceOffsetBaseRule public abstract base class is a member of the
namespace Autodesk.Aec.SpaceOffsetRulesManager and the base class for all rule
classes.

Void AecSpaceOffsetBaseRule.RegisterType(System.Type type) Method

The only method the AecSpaceOffsetBaseRule base class implements is void
RegisterType(System.Type type). This method defines functionality that is required
for all specific rule types. This method is used to register object types for which
a specific rule implementation needs to be called by AutoCAD Architecture.
The following sections contain some examples for the usage of this method.
If a rule implementation needs to be called for all object types, you do not
need to call the RegisterType method for all of them. Instead, you can make
one call to RegisterType(Autodesk.Aec.SpaceOffsetRulesManager.kAllTypes).

Reference: AecSpaceOffsetBaseRule Class

namespace Autodesk.Aec.SpaceOffsetRulesManager

{

public abstract class AecSpaceOffsetBaseRule

{

protected AecSpaceOffsetBaseRule();

protected void RegisterType(Type type);

}

}
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Implementing Specific Offset Rules
Common to all rules is a public abstract Apply method, where the return type
and arguments are specific to the rule type, which needs to be implemented
by each new rule class. The following sections describe the base class of each
rule type, and show one example for an implementation of such a rule.

Space Rule
(SpaceOffsetRulesManager.AecSpaceRule Base Class)

A space rule is applied to the whole space, as opposed to all other rule types
which are more specific. Space rules are the only type of offset rules that can
only be registered once for each standard (once for each of the offset types
net, usable, and gross.)

Implementing a Space Rule

To implement a space rule, you must add a new class that is derived from the
SpaceOffsetRulesManager.AecSpaceRule base class. The new class must implement
the Apply interface of the base class. It need not call the
AecSpaceOffsetRuleBase.RegisterType() method of the base class since it always
applies to space objects. The Apply method that each rule needs to implement
has the following syntax for the AecSpaceRule class:

public abstract bool Apply(Autodesk.AutoCAD.DatabaseServices.Ob

jectId idSpace);)
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The boolean return value determines if the space has a valid offset boundary.
If so, it can be used to deactivate all boundaries of a certain offset type. The
following example shows the framework for a new space rule class:

namespace AecSpaceOffsetStandardSample

{

public class SpaceRule: AecSpaceRule

{

public SpaceRule()

{

}

public override bool Apply(ObjectId idSpace)

{

// return false to switch boundary off

}

}

}

Sample Space Rule NullSpace

A common use case is that an area calculation standard includes only net and
gross offsets, but no usable offset. You can accomplish that by implementing
a space rule derived from AecSpaceRule that always returns false in the
implementation of the Apply method. Register one instance of that rule with
the usable offset in the standards implementation of
AecSpaceOffsetStandard.InitRules().

A more complex space rule might define that all spaces with an area smaller
than a certain predefined value do not contribute to a certain offset type. The
following example shows the space rule that is part of the sample project and
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that will invalid all spaces. It is used within the sample standard to switch off
the usable boundary:

namespace AecSpaceOffsetStandardSample

{

public class NullSpace: AecSpaceRule

{

public SpaceRuleNet()

{

}

public override bool Apply(ObjectId idSpace)

{

return false;

}

}

}

Reference: AecSpaceRule Class

The following list shows all members of the AecSpaceRule base class:

namespace Autodesk.Aec.SpaceOffsetRulesManager

{

public abstract class AecSpaceRule : AecSpaceOffsetBaseRule

{

public AecSpaceRule();

public abstract bool Apply(

Autodesk.AutoCAD.DatabaseServices.ObjectId idSpace,

Autodesk.Aec.Modeler.Body body);

}

}

Bounding Object Rule
(SpaceOffsetRulesManager.AecBoundingObjectRule Base Class)

Bounding object rules allow objects that are bounding the base profile of the
space, such as structural members, to be marked as non-bounding, so that
they will not be processed when creating the offset profile. Each standard can
define and apply multiple bounding object rules for each boundary offset
type.
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Implementation of a Bounding Object Rule

To implement a custom bounding object rule, you need to add a new class
that is derived from the SpaceOffsetRulesManager.AecBoundingObjectRule base
class. The new class needs to implement the Apply interface of the base class
and register itself for the object types it should be called for in the constructor
by calling the AecSpaceOffsetRuleBase.RegisterType() base method. The Apply
method of this rule type has the following syntax:

public abstract bool Apply(Autodesk.AutoCAD.DatabaseServices.Ob

jectId idSpace,

Autodesk.AutoCAD.DatabaseServices.ObjectId idObject);

The first argument is the current space for which the offset boundary profile
is to be calculated. The second argument idObject is the Object ID of the object
that bounds the space. Within the Apply method, the space object as well as
the bounding object can now be opened and queried for certain properties to
decide if this object should contribute to the generated profile. If the method
returns false, the boundaries of the object are removed from the offset profile.
This implies that the object will not be considered anymore when the offset
rules are applied. The following example shows the framework for a new space
rule called BoundingObjectRuleGross:

namespace AecSpaceOffsetStandardSample

{

public class BoundingObjectRuleBasic: AecBoundingObjectRule

{

public BoundingObjectRuleGross()

{

RegisterType(typeof(kAllTypes));

}

public override bool Apply(ObjectId idSpace, ObjectId idObject)

{

//return false to mark object as non-contributing

}

}

}

Sample Bounding Object Rule BoundingObjectRuleGross

The following example shows the bounding object rule implementation used
for the gross profile of the sample project. This rule removes all segments from
the profile that are bound by a structural member. This is a common case for
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defining the gross area of a space, where structural members are not considered,
even if they are bounding the base profile of the space.

public class BoundingObjectRuleGross : AecBoundingObjectRule

{

public BoundingObjectRuleGross()

{

RegisterType(typeof(kAllTypes));

}

public override bool Apply(ObjectId idSpace, ObjectId idObject)

{

bool result=true;

Autodesk.AutoCAD.DatabaseServices.Database db =idObject.Data

base;

using (Autodesk.AutoCAD.DatabaseServices.Transaction transac

tion =db.TransactionManager.StartTransaction())

{

Member member = transaction.GetObject(idObject, OpenMode.For

Read) as Member;

if ( member == null )

{

MemberType memType = member.MemberType;

if ( memType == MemberType.Column )

{

result = false;

}

}

transaction.Commit();

}

return result;

}

}

The figure below shows an example of applying this rule, where the net
boundary (green) includes the columns, while the gross boundary (blue)
ignores them
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Reference: AecBoundingObjectRule Class

The following list shows all members of the AecBoundingObjectRule base class:

namespace Autodesk.Aec.SpaceOffsetRulesManager

{

public abstract class AecBoundingObjectRule : AecSpaceOffsetBaseR

ule

{

public AecBoundingObjectRule();

public abstract bool Apply(

Autodesk.AutoCAD.DatabaseServices.ObjectId idSpace,

Autodesk.AutoCAD.DatabaseServices.ObjectId idObject);

}

}

Bounding Adjacency Rule
(SpaceOffsetRulesManager.AecBoundingAdjacencyRule Base Class)

Bounding adjacency rules define an offset for segments of the space base
profile depending on the space that is adjacent to this segment. A common
use case for gross offset profiles is that bounding adjacency rules define that
the boundary should be offset to the center of the bounding object at interior
walls and to the outside of the bounding object at exterior walls.

Implementation of a Bounding Adjacency Rule

To implement a bounding adjacency rule, you need to add a new class that
is derived from SpaceOffsetRulesManager.AecBoundingAdjacencyRule. As with all
previously described offset types, the new class needs to implement the Apply
interface of this base class and register itself for the object types it should be
called for in the constructor by calling the base method
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AecSpaceOffsetRuleBase.RegisterType(). The Apply method each rule needs to
implement has the following form in AecBoundingAdjacencyRule:

public abstract bool Apply(Autodesk.AutoCAD.DatabaseServices.Ob

jectId idSpace,

Autodesk.AutoCAD.DatabaseServices.ObjectId idObject,

Autodesk.AutoCAD.DatabaseServices.ObjectId idAdjSpace);

The first ObjectId argument is the current space for which the offset boundary
is to be calculated. The second ObjectId is the bounding object between the
space from the first argument and the adjacent space. The third argument is
the ObjectId of the adjacent space. When there is no adjacent space, which is
the case at exterior walls, the value of this argument will be ObjectId.Null. The
following example shows the frame for a new space rule called
BoundingAdjacencyRuleGross:

namespace AecSpaceOffsetStandardSample

{

public class BoundingAdjacencyRuleGross : AecBoundingAdjacencyR

ule

{

public BoundingAdjacencyRuleGross()

{

}

public override AecSpaceOffsetInfo Apply(ObjectId idSpace,

ObjectId idObject, ObjectId idAdjSpace)

{

//

}

}

}

Sample Bounding Adjacency Rule BoundingAdjacencyRuleGross

The following example shows the implementation of a bounding adjacency
rule that is used in the sample project. It defines an offset to the center of the
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bounding object for 2 spaces at interior walls and an offset to the outside of
the wall if there is no adjacent space.

public class BoundingAdjacencyRuleGross : AecBoundingAdjacencyRule

{

public BoundingAdjacencyRuleGross()

{

}

public override AecSpaceOffsetInfo Apply(ObjectId idSpace, Ob

jectId idObject, ObjectId idAdjSpace)

{

if (idAdjSpace.IsNull)

{

// If there is no adjacent space (exterior wall), keep the

'Opposite' offset

return new AecSpaceOffsetInfo(AecSpaceOffsetType.Opposite);

}

else

{

// If there is an adjacent space (interior wall), its center

return new AecSpaceOffsetInfo(AecSpaceOffsetType.Center);

}

}

}
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Reference: AecBoundingAdjacencyRule Class

The following list shows all members of the AecBoundingAdjacencyRule base
class:

namespace Autodesk.Aec.SpaceOffsetRulesManager

{

public abstract class AecBoundingAdjacencyRule : AecSpaceOffset

BaseRule

{

public AecBoundingAdjacencyRule();

public abstract AecSpaceOffsetInfo Apply(

Autodesk.AutoCAD.DatabaseServices.ObjectId idSpace,

Autodesk.AutoCAD.DatabaseServices.ObjectId idObject,

Autodesk.AutoCAD.DatabaseServices.ObjectId idAdjSpace);

}

}

Bounding Openings
(SpaceOffsetRulesManager.AecBoundingOpeningRule Base Class)

A bounding opening rule can be used to define an offset at the openings in
walls that are bounding a space, such as doors and windows. For example, the
net offset profile cannot be defined by offsetting the profile only from the
bounding walls. Usually, the wall is cut at doors and windows too. This rule
type can be used to describe this in the offset profile calculated by the area
calculation standard.

Implementation of a Bounding Opening Rule

To implement a bounding opening rule, you need to add a new class that is
derived from SpaceOffsetRulesManager.AecBoundingOpeningRule. The new class
needs to implement one or more of the Apply interfaces of the base class and
register itself for the object types it should be called for in the constructor by
calling the AecSpaceOffsetRuleBase.RegisterType() base method. Note that this rule
can only be applied to the following classes:

■ Openings

■ Doors

■ Windows

■ Door and Window Assemblies
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Registering this rule for other object types will not have any result. The Apply
method of that class that each rule needs to implement has the following
syntax in AecBoundingOpeningRule:

public abstract AecSpaceOffsetOpeningInfo*

Apply(Autodesk.AutoCAD.DatabaseServices.ObjectId idSpace,

Autodesk.AutoCAD.DatabaseServices.ObjectId idAdjSpace,

Autodesk.AutoCAD.DatabaseServices.ObjectId idObject,

Autodesk.AutoCAD.DatabaseServices.ObjectId idOpening);

The first argument is the ObjectId of the current space for which the boundary
offset is to be calculated. The second argument is the ObjectId of the adjacent
space. When there is no adjacent space, which is the case at exterior walls,
the value of this argument will be ObjectId.Null. The third argument is the
ObjectId of the object the opening is anchored to, which usually is a wall that
bounds the space and owns the opening. The fourth parameter is the ObjectId
of the opening that is under investigation. The following example shows the
framework for a new opening rule called BoundingOpeningRuleNet:

namespace AecSpaceOffsetStandardSample

{

public class BoundingOpeningRuleNet : AecBoundingOpeningRule

{

public BoundingOpeningRuleNet ()

{

RegisterType(typeof(Door));

}

public override AecSpaceOffsetInfo* Apply(ObjectId idSpace,

ObjectId idAdjSpace, ObjectId idObject, ObjectId idOpening)

{

}

}

}

Sample Bounding Opening Rule BoundingOpeningRuleNet

The following example shows a simple bounding opening rule, where an offset
is defined for doors. To make sure the rule is not applied to windows, it is only
registered for the Door object, so that AutoCAD Architecture will not call it
for any other openings. This rule is used in the sample project
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AecSpaceOffsetStandardSample. The offset is defined to go to the inside of the
door panel.

namespace AecSpaceOffsetStandardSample

{

public class BoundingOpeningRuleNet : AecBoundingOpeningRule

{

public BoundingOpeningRuleNet()

{

RegisterType(typeof(Door));

}

public override AecSpaceOffsetOpeningInfo* Apply(ObjectId id

Space, ObjectId idAdjSpace, ObjectId idObject, ObjectId

idOpening)

{

return new AecSpaceOffsetOpeningInfo(AecSpaceOffsetOpening

Type.PanelAdjacent);

}

return new AecSpaceOffsetInfo(AecSpaceOffsetType.NoChange);

}

}

}

Net boundary and net hatch are offset to the center of the door, but not offset at the
wall opening
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Reference: AecBoundingOpeningRule Class

The following list shows all members of the AecBoundingOpeningRule base class:

namespace Autodesk.Aec.SpaceOffsetRulesManager

{

public abstract class AecBoundingOpeningRule : AecSpaceOffset

BaseRule

{

public AecBoundingOpeningRule();

public AecSpaceOffsetOpeningInfo* Apply(

Autodesk.AutoCAD.DatabaseServices.ObjectId idSpace,

Autodesk.AutoCAD.DatabaseServices.ObjectId idAdjSpace,

Autodesk.AutoCAD.DatabaseServices.ObjectId idObject,

Autodesk.AutoCAD.DatabaseServices.ObjectId idOpening

);

}

}

Reference1
AecSpaceOffsetInfo Class

The AecSpaceOffsetInfo class is used to describe an offset as a result of the
application of a bounding adjacency rule. It is returned by the implementation
of the Apply methods of that class that is called by AutoCAD Architecture when
the software needs to calculate the boundary offsets of a space according to
the standard this rule is assigned to.

You define an offset with 2 properties, the type and the value. The type defines
where on the bounding object the offset is to align, such as the adjacent face
of the wall. The value defines an additional offset distance from that alignment,
where positive is away from the space under consideration. For example, you
can define an offset that is aligned with the center of the wall, which is then
offset an additional 1" toward the opposite face.
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Reference: AecSpaceOffsetInfo Class

The following list shows all members of the AecSpaceOffsetInfo base class:

namespace Autodesk.Aec.SpaceOffsetRulesManager

{

public class AecSpaceOffsetInfo

{

public static AecSpaceOffsetInfo kNoChange;

public static AecSpaceOffsetInfo kOffsetToAdjacent;

public static AecSpaceOffsetInfo kOffsetToCenter;

public static AecSpaceOffsetInfo kOffsetToOpposite;

public AecSpaceOffsetInfo(AecSpaceOffsetType type);

public AecSpaceOffsetInfo(AecSpaceOffsetType type, double

value);

public AecSpaceOffsetType OffsetType { get; set; }

public double OffsetValue { get; set; }

}

}

}

The Autodesk.Aec.SpaceOffsetRulesManager.AecSpaceOffsetType enumeration type
can be one of the following values:

DescriptionValue

Defines an offset to the inside of the
bounding object (usually this equals no
offset at all)

Adjacent

Defines an offset to the center of the
bounding object

Center

Defines an offset to the opposite side of
the bounding object

Opposite

Will not change any offsets already appliedNoChange

Reference 2
AecSpaceOffsetOpeningInfo Class

The AecSpaceOffsetOpeningInfo class is used to describe an offset as a result of
the application of a bounding opening rule. It is returned by the
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implementation of the Apply methods of that class that is called by AutoCAD
Architecture when the software needs to calculate the boundary offsets of a
space according to the standard this rule is assigned to.

You define an offset with two properties, the type and the value. The type
defines where on the bounding object the offset is to align, such as the adjacent
face of the wall or the center of the door panel. The value defines an additional
offset distance from that alignment, where positive is away from the space
under consideration. For example, you can define an offset that is aligned
with the adjacent frame, which is then offset an additional 1" toward the
opposite face.

Reference: AecSpaceOffsetOpeningInfo Class

The following list shows a list of all members of the AecSpaceOffsetOpeningInfo
base class:

namespace Autodesk.Aec.SpaceOffsetRulesManager

{

public class AecSpaceOffsetOpeningInfo

{

public AecSpaceOffsetOpeningInfo(AecSpaceOffsetOpeningType

type);

public AecSpaceOffsetOpeningInfo(AecSpaceOffsetOpeningType

type, double value);

public AecSpaceOffsetOpeningType OffsetType { get; set; }

public double OffsetValue { get; set; }

}

}

}

The Autodesk.Aec.SpaceOffsetRulesManager.AecSpaceOffsetOpeningType
enumeration type can be one of the following values:

DescriptionValue

Defines an offset to the inside of the
bounding object (usually this equals no
offset at all)

WallAdjacent

Defines an offset to the center of the
bounding object

WallCenter

Defines an offset to the opposite side of
the bounding object

WallOpposite
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DescriptionValue

Defines an offset to the inside of the frame
of the bounding opening

FrameAdjacent

Defines an offset to the center of the frame
of the bounding opening

FrameCenter

Defines an offset to the opposite side of
the frame of the bounding opening

FrameOpposite

Defines an offset to the inside of the panel
of the bounding opening

PanelAdjacent

Defines an offset to the center of the panel
of the bounding opening

PanelCenter

Defines an offset to the opposite side of
the panel of the bounding opening

PanelOpposite

Defines an offset to be whatever the offset
is for the bounding object that owns the

OpeningOwner

opening. No additional defined rules will
be applied.

Defines an offset to align with the base
curve of the bounding opening

OpeningBaseCurve

Defines no offset. Additional defined rules
will continue to be applied until an offset
is defined.

NotApplicable

NOTE  Currently, door and window assemblies do not support the Frame and
Panel options, which will be converted to OpeningBaseCurve.
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Usage of a New Standard

Installation
When the required rules are implemented and the plug-in assembly has been
successfully built, you need to test the results in AutoCAD Architecture. In
order to apply the new standard, it must be moved or copied into the AutoCAD
Architecture area calculation standards plug-ins subfolder under \\Program
Files\AutoCAD Architecture 2012\Space Calculation Standards\ where the predefined
standards that are delivered with the software also located. Note that if you
copy the assembly into the plug-in folder while AutoCAD Architecture is
running, you will need to restart it in order for the standard to be loaded.

Application
When you start AutoCAD Architecture after copying the new standard plug-in
into the folder specified above, the software will automatically find and load
the standard together with all other standards located in the same folder. If
the standard is correctly implemented, it will show up with its name and can
be selected to be applied to the current drawing.

1 Start AutoCAD Architecture.

2 Click  ➤ Options.

3 Click the AEC Object Settings tab.

4 Under Calculation Standards, select your standard.
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Advanced: Using Classifications in Area Calculation Standards
A common way of implementing a standard is to define offsets between spaces
depending on their classifications. Even though you can do this with the area
calculation standard API described in the previous sections and through usage
of the available .NET API from AutoCAD Architecture, the
Autodesk.Aec.SpaceOffsetRulesManager.AecSpaceOffsetClassification class provides
some functionality to make the handling of classifications for offset
calculations easier.

Definition of Classifications in Resource Assembly
Since classification names are displayed to the user in AutoCAD Architecture,
their names should be localized. The API to use classifications within area
calculations pays respect to that through the usage of resources to define the
classification names of the classification set of a standard. Before your can
apply and use classifications in your custom area calculation standard, you
need to define them in a resource file that you need to add to your existing
project (alternatively, you could create a resource-only assembly that is
referenced). Please refer to the help of your development environment or the
MSDN Online Library for information about creating string resources. It is
assumed that the reader of this appendix is able to create and build a project
that contains localized strings. Within this example, a resource file that
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implements one string table is assumed that defines the following global/local
string pairs:

ValueName

Office AreaOffice

Street FrontageExterior

Adding Classification Support to the Standard
If you want your standard to work with classifications, you need to add an
object of the type AecSpaceOffsetClassification to the standard after creating a
resource set for the classification names. This class will handle all the
classification-related functionality for the standard and within the
implementation of the rule.

Initializing the Database with Classifications

The following example shows the required steps to populate the drawing the
standard is applied to with the classification definitions. This must occur
within the standard’s AecSpaceOffsetStandard.InitDatabase virtual base class
method, because the classifications need to be added to each new drawing
that uses this standard. The following example shows how a new
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AecSpaceOffsetClassification object is created and initialized into the currently
active database:

namespace AecSpaceOffsetStandardISA

{

public class AecSpaceOffsetStandardISA: AecSpaceOffsetStandard

{

public AecSpaceOffsetClassification classification

public AecSpaceOffsetStandardISA()

{

}

protected override void InitDatabase(Database database)

{

classification = new AecSpaceOffsetClassification();

classification.Init(

database,

Assembly.GetExecutingAssembly(),

new CultureInfo(SystemObjects.DynamicLinker.ProductLcid,

true);

"AecSpaceOffsetStandardISA.AecSpaceOffsetStandardISAClas

sifications",

"Classification Name"

);

}

}

}

The AecSpaceOffsetClassification.Init method is defined as:

public void Init(Database database, Assembly assembly, CultureInfo

culture, string

resBaseName, string classificationSetName)

The first 3 arguments are usually identical in all cases. The first one is the
database to which the classification set needs to be applied. The second
argument is the current assembly that implements the standard plug-in. The
third argument is the localization for which the classifications are to be set
up (in the example, the current setting of AutoCAD Architecture is used, which
is the recommended procedure). The fourth argument is the name of the string
table within the resources of the assembly. The last argument defines a name
for the classification set in AutoCAD Architecture. This should be localized
too, because it will be visible to the user. However, this section focuses on
classification handling only. When running the standard with the resource
file set up correctly, the drawing should now contain classification definitions

3246 | Chapter 40   Spaces



that apply only to spaces with the names defined in the resource’s string-table
when the standard is assigned to the drawing.

BOMA classification inserted in drawing

Using Classifications in the Rule Implementation
After adding classifications to the current database, you want to use them
within area calculation standard plug-ins. You are in principle able to
determine the classification from a space that is passed to a rule with the
existing AutoCAD Architecture .NET API. This however could be complex,
especially as you always need to use the global name of classifications within
your rules, in order to work with all localizations of the classifications display
name. Therefore, the class AecSpaceOffsetClassification provides functionality
to simplify this.

Reading the Global Classification Name from a Space Object

The AecSpaceOffsetClassification class has a method to get the global classification
name from a space object so that it can be compared to the names defined by
the resource string table to decide how to offset boundaries. The method is
the public string GetClassificationName(Object Id objId). The following example
shows a bounding adjacency rule that uses the classifications described in the
example table above. Because the rule needs to be able to access the
AecSpaceOffsetClassification object of the standard, the standard is passed through
the constructor and assigned to a member of the rule. This means you will
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need to create the rule in the standard’s InitRules() implementation with a
“this” reference to the current standard.

public class BoundingAdjacencyRuleGross : AecBoundingAdjacencyRule

{

private AecSpaceOffsetStandardISA standard;

public BoundingAdjacencyRuleGross(AecSpaceOffsetStandardISA

standardISA)

{

standard = standardISA;

}

public override AecSpaceOffsetInfo Apply(ObjectId idSpace, Ob

jectId idObject, ObjectId idAdjSpace)

{

String classificationNameThis = "";

String classificationNameAdjacent = "";

if (!idSpace.IsNull)

{

classificationNameThis = standard.Classification.GetClassi

ficationName(idSpace);

}

if (!idAdjSpace.IsNull)

{

classificationNameAdjacent = standard.Classification.GetClas

sificationName(idAdjSpace);

}

if (idAdjSpace.IsNull || classificationNameAdjacent =="Exter

ior")

{

return new AecSpaceOffsetInfo(AecSpaceOffsetType.Opposite);

}

if (!idAdjSpace.IsNull && classificationNameThis == "Exterior")

{

return new AecSpaceOffsetInfo(AecSpaceOffsetType.Adjacent);

}

if (classificationNameThis == "Office")

{

return new AecSpaceOffsetInfo(AecSpaceOffsetType.Adjacent);

}

// for the rest

return new AecSpaceOffsetInfo(AecSpaceOffsetType.Center);

}

}
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Reference: AecSpaceOffsetClassification Class
The following list shows all members of the AecSpaceOffsetClassification base
class:

namespace Autodesk.Aec.SpaceOffsetRulesManager

{

public class AecSpaceOffsetClassification

{

public AecSpaceOffsetClassification();

public ObjectId ClassificationDefinitionID { get; }

public string GetClassificationName(ObjectId objId);

public void Init(Database database, Assembly assembly, Culture

Info culture, string resBaseName, string classificationSet

Name);

}

}
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Sections

A section represents a building model as if the model were cut vertically to show interior
detail. You can create two-dimensional (2D) or three-dimensional (3D) section objects, or a
live section view of the model. You can control the size and shape of the section you generate
and assign materials to the section for an optimal visual representation of the sectioned
objects. Section objects remain linked to the building model that you used to create them,
unless you explode the section. Because of this link between the section and the building
model, any changes to the building model can be reflected in the section as well.

Sections
A section represents a building model as if the model were cut vertically to show
interior detail. You can create two-dimensional (2D) or three-dimensional (3D)
section objects, or a live section view of the model. You can control the size
and shape of the section you generate and assign materials to the section for
an optimal visual representation of the sectioned objects. Section objects remain
linked to the building model that you used to create them, unless you explode
the section. Because of this link between the section and the building model,
any changes to the building model can be reflected in the section as well.

Section Line and Marks

The section line defines the extents of the section that you extract from the
building model. Sections lines can be straight or jogged. You can also specify
the length and the height of the area defined by the section line. Section marks,
which typically contain a letter or number and indicate the direction of the
section, appear at each end of the section line.

After you draw the section line, you can create a section object or a live section
view from the line.

41
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Creating a Section

2D Sections

2D sections are created by cutting a number of objects with a section line and
then creating a 2D section object from them. The section object is drawn
without hidden and overlapping lines. You can edit a 2D section by changing
its object display properties or its style display properties. The 2D section style
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lets you add display components to the display representation of the section
and create rules that assign different parts of the section to different display
components. You can control the visibility, layer, color, linetype, lineweight,
and linetype scale of each component. You can also choose whether materials,
such as brick or concrete hatches, are used to display individual components
of the section object or the 2D section style. Furthermore, you can use linework
editing commands to assign individual lines in a 2D section to different display
components, and merge geometry into a 2D section. You can dimension 2D
sections.

2D section with surface and shrinkwrap hatch detail

3D Sections

3D sections are created by cutting a number of objects with a section line and
then creating a 3D isometric section object from them. 3D sections do not
use styles. However, you can control the display of subdivisions within 3D
sections. Using the Hidden Line Projection command, you can create 2D
hidden line projections of any view of the 3D section that you can explode
and edit or hatch. For more information about using this command, see
Creating a Hidden Line Projection on page 3385.
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3D section in 3D view

Section Subdivisions

A 2D or 3D section object can have a number of subdivisions partitioning the
section object. This feature is useful when you want to create a view of the
object in which the parts that are closer to the viewer are drawn with darker
and stronger lines, and parts that are farther off are drawn lighter.

3D section with subdivisions and assigned colors in perspective view

Live Section View

A live section view is a special view of a 3D section where the objects that are
sectioned are not converted to a 3D section object. Instead, the existing model
objects are displayed as a 3D section. The parts of the objects within the
bounding box of the section line keep their individual display components
while the parts of the objects outside of the section line can optionally be
displayed or hidden. To control the appearance of the object parts outside of
the section line, you need to assign a material to the sectioned objects. When
you render a live section, you can show the outside part as a half-transparent
addition, for example.

For more information, see Creating and Editing a Live Section View on page
3275.

Materials in Sections

In AutoCAD Architecture, you can assign materials to different components
of an object. These materials are displayed when you create a 2D or 3D section
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object or a live section view. Materials have specific settings for sections, such
as a 2D section hatch setting and a sectioned boundary for live section views.
In a 2D or 3D section object, you can specify whether to use the display
properties of the materials or the display properties of the section object.

2D section with different surface hatches

AutoCAD Architecture provides a large number of predefined materials for all
common design purposes. You can use these predefined materials, or modify
them to your special designs. You can also create your own materials from
scratch. For more information, see About 2D and 3D Section Display
Components and Materials on page 3306.

Subdivisions in 2D Section Styles and Materials

When you create subdivisions in your style, you usually want the objects in
them to be visually distinct from other subdivisions. When you assign materials
to the objects, you can set the 2D section style so that it uses the hatch pattern
from the material, but uses the color and linetype from the subdivision display
properties.

3D section with subdivisions and assigned colors in 3D view
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For more information see Use Subdivision Properties and Materials in 2D
Section Styles on page 3313.

Material Boundaries in 2D Sections

Material boundaries allow you to erase or limit portions of a 2D section or
elevation. For example, you might do the following:

■ Limit the amount of hatching to produce cleaner construction documents.

■ Highlight a region in an elevation or section.

2D section with highlighted hatching region detail

■ Mask out a portion of a section so that more detail can be drawn.

2D section with hatch masked

■ Crop an irregular-shaped portion of a section or elevation.
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2D section with cropped material display detail

For more information, see Creating a Material Boundary in a 2D Section on
page 3285.

Workflow to Create a 2D or 3D Section or a Live Section
View

Review the stepsWatch the movie

The section line on page 3260 defines the extents
of the section (its width, height, and length) to-----Draw a section line and mark
extract from the building model for 2D, 3D, and
live section views.

Create a 2D or 3D section by selecting the section
line and the objects to be included, and generate
on page 3271 a section.
Live section views on page 3275 are created from
the section line. All objects in the drawing are
automatically included.

-----
Create a 2D or 3D section or a live
section view

You can edit on page 3258 the section line and the
section object to refine the appearance of the
objects.

-----
Make changes to the section or the
building model
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Review the stepsWatch the movie

Update on page 3295 sections to apply changes
you made to the section line, the section object,

-----Update the section and the building model. You can also globally on
page 3299 update all sections within a project or a
specified folder all at once.

Drawing and Editing Section Lines
The first step in creating a section is to draw a section line through the building
model. The section line defines the extents of the section to extract from the
building model.

NOTE You can create vertical sections and horizontal sections.

Creating a Section Object from a Section Line
When you generate a section from a section line, you specify the type of
section object that is created.

The result is…When you create…

an orthographic projection from the
building model.

a 2D section object

the area of the building model defined in
the section line.

a 3D section object or a live section

Creating a Live Section View from a Section Line

When you create a live section view from a section line, you do not create a
new section object but instead switch to a special view of the 3D building
model. You do not select objects to include in the section; the live section
view includes all objects in the drawing. The section line controls how objects
are displayed in a live section view. Objects or parts of objects that are within
the bounding box of the section line retain their original display properties.
Objects or parts of objects that are outside of the section line are either not
displayed at all or are displayed with a special display component for the
sectioned body.
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Viewing the Section Line

In plan view, the section line is displayed as you would expect on a
construction document. The section marks point in the direction that the
section is cut.

Viewing the section line and mark in plan view

In an isometric view, the same section line is displayed with a boundary that
defines the extents of the section.

Viewing a section line in isometric view

Changing the Section Line

You can change the section line to control the section that you create. Using
the section line, you can change the height and shape of the section. You can
also add a lower extension to the section and create section subdivisions.

You can change section line properties before or after you create a section.
After changing section line properties, you can apply the changes to a section
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that you previously created with the section line. For information about
updating existing sections, see Updating a 2D or 3D Section on page 3295.

For information about updating existing live section views, see Updating a
Live Section View on page 3277.

Using Subdivisions in Sections

You can set up graphic subdivisions in section line properties. These
subdivisions are added to the 2D or 3D section you create. Subdivisions are
specified at distances from the cutting plane of the section line. You can
control the lineweight and other display properties of subdivisions to add
levels of depth to sections. For example, you can display one subdivision with
a heavy lineweight and another subdivision with a lighter lineweight to suggest
that the first subdivision is in front of the second subdivision.

You can use the display properties of a subdivision together with the display
properties of a material. For more information, see Use Subdivision Properties
and Materials in 2D Section Styles on page 3313.

Drawing a Section Line and Marks
Use this procedure to draw a section line with a section mark at each end. You
draw a section line by specifying a start point, an endpoint, a length, and a
height for the section. You can specify additional points between the start
point and the endpoint to create jogs in the section. The section line acts as
a cutting plane, slicing a section from the building model.

NOTE If you are working with a drawing set where several xrefs are linked to a
main drawing, draw the section line in the main drawing.

TIP You can also create sections with Callout tools. For more information, see
Placing Section Callouts on page 3709.

1 On the default tool palette set, click the Design tab, and then click
the Vertical Section tool.

If necessary, scroll the palette to display the tool that you need.

NOTE Alternatively, click Home tab ➤ Section & Elevation

panel ➤ Section Line  .

2 Specify the start point of the section line.

3 Continue to specify points to define the section line, if needed.
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You can create jogs in the section line to cut through portions of
the building model that you want to show in the section, but
which are not along a single straight path.

4 Specify the endpoint of the section line, and press ENTER.

Specifying section line start and end points in 3D view

5 Specify the length of the section, or press ENTER to accept the
length taken from the endpoints of the line.

The section line is displayed in the drawing. Depending on the
direction in which you drew the section line, the section marks
point in the direction of the section.
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The section marks are multi-view blocks, anchored to the section line. You
can edit the section marks to change the information displayed in the bubbles.
For more information, see Changing Section Mark Attributes on page 3268.

The height of the section line is set to the extents of the selected objects. You
can change the properties of the line to change the height and depth of the
section, add a lower extension, or add subdivisions. For more information,
see Changing the Height of a Section Using Grips on page 3262.

Changing the Height of a Section Using Grips
Use this procedure to change the height of any section connected to the
section line. You can change the height of the section line before or after you
create a connected section. If you change the height after creating the section,
you need to update the section to show the changes.

You can also change the height of a section using the Properties palette.

1 Click View tab ➤ Appearance panel ➤ Views  ➤ SW Isometric

 .

2 Select the section line you want to change.

3 Select the Model Extents grip to turn off use of model extents for
section height.

4 Select the Height grip.

NOTE If you use model extents for height mode, the height of the
section is determined by the height of the objects in the section and
is not available to modify dynamically.
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Viewing Section Grips in 3D View

5 Move the grip until the height value you want is displayed, and
click once; or enter a value.

The objects are cut at this height when you create or update a
section.

6 Right-click, and click Deselect All to turn off grips.

To update a 2D or 3D section created from this section line, see Updating a
2D or 3D Section on page 3295.

Changing the Lower Extension of a Section Using Grips
Use this procedure to change the lower extension of any section connected
to the section line. You can change the lower extension of the section line
before or after you create a connected section. If you change the lower
extension after creating the section, you need to update the section to show
the changes.

You can also change the lower extension of a section using the Properties
palette.

1 Click View tab ➤ Appearance panel ➤ Views  ➤ SW Isometric

 .

2 Select the section line you want to change.
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3 Select the Model Extents grip to turn off model extents for height.

4 Select the Lower Extension grip.

NOTE If you turn off model extents, the default for the lower section
is 1 foot below the XY plane.

Viewing Section Grips in 3D View

5 Move the grip until the lower extension value you want is
displayed, and click once; or enter a value.

6 Right-click, and click Deselect All to turn off grips.

To update a 2D or 3D section created from this section line, see Updating a
2D or 3D Section on page 3295.

Changing the Length of a Section Using Grips
Use this procedure to change the length of any section boundary connected
to the section line. You can change the length of the section as a whole, or
you can change the length of the sides of the section boundary individually.

You can change the length of the section boundary before or after you create
a connected section. If you change the length after creating the section, you
need to update the section to show the changes.

You can also define the depth of a section (its length) by changing the length
of the sides of a section boundary on the Properties palette.
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1 Select the section line you want to change.

2 Select the Length grip.

Viewing Section Grips in Plan View

3 Move the grip until the length value you want is displayed, and
click once.

The entire section boundary length is updated.

4 To change the length of side 1 of the section boundary, click the
Side 1 Endpoint grip.

Side 1 starts from the first point specified for the section line.

5 Move the grip to the desired location, and click once; or enter a
value on the command line, and press ENTER.

Viewing Section Grips in Plan View

6 To change the length of side 2 of the section boundary, click the
Side 2 Endpoint grip.
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Side 2 starts from the endpoint of the section line.

7 Move the grip to the desired location, and click once; or enter a
value on the command line, and press ENTER.

8 Right-click, and click Deselect All to turn off grips.

To update a 2D or 3D section created from this section line, see Updating a
2D or 3D Section on page 3295.

Changing the Angle Dimensions of a Section
Use this procedure to change the angle of the sides of the building section
boundary. You can change the angle dimensions before or after you create a
connected section. If you change the angles after creating the section, you
need to update the section to show the changes.

1 Double-click the section line you want to change.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Component Dimensions.

3 Specify values for Angle 1 and Angle 2.

These values define the angles of the two sides from the section
line to create the section box. The apex of Angle 1 is the start
point of the section line. The apex of Angle 2 is the endpoint of
the section line. Values for these angles must be between 0 and
90 degrees.

Specifying section angle parameters

4 Right-click, and click Deselect All to turn off grips.
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To update a 2D or 3D section created from this section line, see Updating a
2D or 3D Section on page 3295.

Creating Graphic Subdivisions for 2D and 3D Sections
Use this procedure to define subdivisions that are created when you generate
a section. Each subdivision is specified as a distance from the cutting plane
of the section line.

A section line with graphic subdivisions

You can control the lineweight and other display properties of the subdivisions
to add different levels of depth to sections.

You can use the display properties of a subdivision together with the display
properties of a material. For more information, see Workflow to Create a 2D
or 3D Section or a Live Section View on page 3257 and Use Subdivision Properties
and Materials in 2D Section Styles on page 3313.

1 Double-click the section line you want to change.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Dimensions.

3 Click the setting for Subdivisions, and then add or modify
subdivisions:

Then…If you want to…

click  . To change the default
distance from the section line, select

create a subdivision
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Then…If you want to…

the subdivision, click the value, and
enter a new one.

select the subdivision, click its value,
and enter a new one.

change the length of a subdivision

select the subdivision, and click 
.

delete a subdivision

4 Click OK.

Changing a Subdivision Using Grips
Use this procedure to change the distance of a subdivision, as measured from
the section line. You can drag the constrained grip to the desired distance, or
you can enter a specific value for the distance measurement.

Viewing Section Subdivision Grips

1 Select the section line you want to change.

2 Select the Distance grip for the subdivision you want to modify.

3 Move the grip until the distance value you want is displayed, and
click once; or enter a value.

4 Right-click, and click Deselect All to turn off grips.

Changing Section Mark Attributes
Use this procedure to change the information displayed in the section mark.
The section mark is a multi-view block.
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1 Double-click the section mark you want to change.

2 On the Properties palette, expand Advanced.

3 Click Attributes.

4 Select the existing attribute under Value, and enter the new
information to include in the bubble.

5 Click OK.

Changing the Location of a Section Line
Use this procedure to relocate a section line by changing the coordinate values
of its insertion point. The section line also has an orientation with respect to
the WCS or the current UCS. For example, if the top and bottom of the section
line are parallel to the XY plane, its normal is parallel to the Z axis. You can
change the orientation of the section line by aligning its normal with another
axis. You can also rotate the section line on its plane by changing the rotation
angle.

For information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use Coordinates and Coordinate Systems” in
AutoCAD Help.

1 Double-click the section line you want to relocate.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Location.

3 Click Additional Information.

4 Specify the location of the section line:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the section line

make the normal of the section line
parallel to the Z axis: under Normal,

locate the section line on the XY
plane

enter 1 for Z, and enter 0 for X
and Y.

make the normal of the section line
parallel to the X axis: under Normal,

locate the section line on the YZ
plane

enter 1 for X, and enter 0 for Y
and Z.
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Then…If you want to…

make the normal of the section line
parallel to the Y axis: under Normal,

locate the section line on the XZ
plane

enter 1 for Y, and enter 0 for X
and Z.

enter a new value for Rotation
Angle.

change the rotation of the section
line

5 Click OK.

To update an existing section created from this section line, see Updating a
2D or 3D Section on page 3295.

Modifying a Section Line Using Grips
Use this procedure to change the start point, endpoint, edge, or vertex of a
section line. You can drag the grip to the desired location, or you can enter a
specific value for the measurement.

1 Select the section line you want to change.

2 Select a section line grip, and move it to the desired location.

You can also move the grip in the desired direction and enter a
specific value on the command line.

Viewing Section Grips in Plan View

3 Right-click, and click Deselect All to turn off grips.
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Attaching Hyperlinks, Notes, and Files to a Section Line
Use this procedure to add hyperlinks, enter notes, and attach reference files
to a section line. You can also edit notes and edit or detach reference files
from a section line.

1 Double-click the section line you want to attach notes or files to.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click  next to Hyperlink, and specify the
link.

4 To add a note, click  next to Notes, enter text, and click OK.

5 To attach, detach, or edit a reference file, click  next to
Reference documents, and then do any of the following:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click  .
detach a reference file

6 Click OK.

Creating a 2D or 3D Section
Use this procedure to create a 2D or 3D section. After you draw a section line,
you extract a section from the section line and the objects you select in the
building model.

TIP Before you create a section, thaw and turn on all layers containing objects
that you want to include in the section. Objects on layers that are off or frozen
cannot be part of the selection set for the section. To enhance performance, turn
off the layers of the objects that you do not need to include in the section.
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WARNING If you want to insert a 2D section in a Plan view, make sure that the
display set used for the Plan view does not section objects by display range. In
that case, the section result would not be displayed in the Plan view. To make sure
that this is not the case, click Manage tab ➤ Style & Display panel ➤ Display

Manager  . Select the Plan display set for the currently used display
configuration. On the Display Options tab, verify that Section AEC Objects by
Display Range defined in Display Configuration is cleared.

1 Draw a section line in the drawing.

For more information, see Drawing a Section Line and Marks on
page 3260.

2 Select the section line, and click Building Section Line

tab ➤ Modify panel ➤ Generate Section  .

3 Select the type of section object you want to create:

Then…If you want to create…

select 2D Section/Elevation Object
with Hidden Line Removal.

a 2D section

select 3D Section/Elevation Object.a 3D section

4 For Style to Generate, select a style for a 2D section.

If you want to use a particular style, select it from Style to
Generate. Otherwise, use the Standard style. For more information,
see 2D Section Styles on page 3301.

3D sections do not use styles.

5 Under Selection Set, click  (Select Objects), and select the
objects that you want to include in the section. Press ENTER when
you finish selecting objects.

NOTE If you select an object that you do not want to include in the
section, hold down SHIFT and select the object again to remove it
from the selection set.

6 Under Display Set, select a display set for the section object.

The display set controls the representation of the section.
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7 Under Placement, select New Object, and specify where to place
the section:

Then…If you want to…

click  (Pick Point), and specify
the location for the new section
object in the drawing.

specify a location graphically

enter X, Y, and Z coordinates for
the location of the new section ob-
ject.

specify the coordinates of the inser-
tion point for the section

8 Click OK.

A 2D or 3D section is created from the section line properties and
the selected objects in the building model. The section is linked
to the building model. If you make changes to the building model
after you create the section, you can update the section to reflect
the changes. For more information, see Updating a 2D or 3D
Section on page 3295.

You can edit certain characteristics of the section to control its placement and
appearance. For more information, see Editing a 2D or 3D Section on page
3279.

You can also use a 2D section style to control the display of selected objects
in a 2D section, and you can control the display of individual lines in a 2D
section. For more information, see 2D Section Styles on page 3301 and Editing
and Merging Linework in a 2D Section on page 3291.

Creating a Horizontal 2D Section
Use this procedure to create a horizontal section or elevation of a plan view.

The Hidden Line control available in AutoCAD Architecture makes it possible
to create horizontal sections and elevations of Plan views. With a horizontal
section or elevation, you can look “down” on the model. Previously, users
could achieve that effect only by manually changing the UCS. Now, a tool
enables you to create a horizontal section or elevation. This feature could be
useful for creating a detailed display of sill components in tapered walls.

The illustration below displays a horizontal section line for an irregularly
shaped building.
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Horizontal section line

The illustration below displays the section results. Note the sill displays of the
tapered walls and the correct representation of the sloped curtain walls.

1 On the default tool palette set, click the Design tab, and then click
the Horizontal Section tool.

If necessary, scroll the palette to display the tool that you need.
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NOTE Alternatively, click Home tab ➤ Section & Elevation
panel ➤ Horizontal Section.

2 Specify the first point of the section plane.

3 Specify the second corner of the section plane.

4 Specify the elevation of the section plane, and press ENTER.

5 Specify the depth of the section, and press ENTER.

6 Proceed with creating the section, as described in Creating a 2D
or 3D Section on page 3271.

Creating and Editing a Live Section View
A live section view is a special view of a 3D model section.

A live section view is always applied to all objects in the drawing. Unlike a 2D
or 3D section, you do not choose a selection set of objects to be contained in
the section. All objects are contained in the live section view. Their display
properties are determined by whether or not they are situated within the
bounding box of the section line.

The objects contained in the live section view are not converted into a section
object, but are retained as objects in the drawing. They keep all of their
properties and display components, and can be edited. The area of objects
that lie outside of the section line, or objects that lie completely outside of
the section line, can be displayed or hidden. The appearance of these objects,
and of parts of objects outside of the section line, is controlled by the Sectioned
Body component. When you render a live section, you can show the outside
part as a half-transparent addition, for example.

The live section view can be turned on and off in a drawing.
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Rendered live section view with transparent outside material

NOTE When a live section view contained in a project view drawing is dragged
onto a project sheet, and the live section view should be displayed in the sheet
view, the external reference of the view needs to be selected in the sheet, and
have a display configuration override applied to it, as described in Changing the
Display Configuration Used in Xref Drawings on page 839.

Creating a Live Section View
Use this procedure to create a live section view of your building model.

1 Draw a section line through the building model.

For more information, see Drawing a Section Line and Marks on
page 3260.

NOTE You do not need to select objects for the live section view.
The live section view is created from the whole drawing.

2 Switch to a 3D view, such as SW Isometric.

3 Select the section line, and click Building Section Line tab ➤ Live

Section panel ➤ Enable Live Section  .
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Updating a Live Section View
When you create a live section view, the sectioned objects are not converted
into a section object. Instead, the objects remain in the drawing. The objects
and object areas which are inside the section line retain their previous display
properties. A brick wall inside a section line retains its brick pattern and its
dark red linework. The objects and object areas outside of the section line
change their display properties, since they are now placed on the Sectioned
Body display component and use its display properties.

The live section updates interactively when you change the objects associated
with it. If you drag a wall outside of the section line, the wall uses the display
properties of the Sectioned Body component. If you drag a wall inside of the
section line, the wall uses its own display properties.

When you change the material assignment of an object in a live section view,
the new material is automatically used in the live section.

NOTE  If you change from a material in which the Sectioned Boundary and
Sectioned Body components are turned on, to a material in which these
components are turned off, it might look as if objects outside of the section line
disappear. You can edit the current material definition to display objects outside
of the section line, as described in Displaying the Sectioned Body in a Live Section
View on page 3277.

Displaying the Sectioned Body in a Live Section View
Use this procedure to display the parts of the drawing in a live section view
that are outside the section.

Whether objects and areas of objects outside the section line are displayed in
the live section view depends on the material settings for each object and
object style. The sectioned objects inside the section are displayed with their
regular display components and material assignments. For example, a brick
wall inside a section displays its regular brick surface hatch.

Objects or object parts that are outside of the section are displayed differently.
You can either hide them completely, or display them on the Sectioned Body
display component. The Sectioned Body display component is specified in
the material assigned to the object.

The sectioned body is often displayed in a lighter, half-transparent color, or
as dotted linework.
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Live section view with sectioned body displayed as light blue linework

In a material definition, the Sectioned Body and Sectioned Boundary display
components influence the display of the live section view. The Sectioned Body
includes the objects or object parts outside of the section line. The Sectioned
Boundary is the cut line created by the section line.

1 Select the object for which you want to display the sectioned
body, right-click and click Edit Object Display.

2 Click the Materials tab.

3 Select the material definition you want to change, and click 
.

4 Select the display representation of the material, and click  .

5 Click the Layer/Color/Linetype tab.

6 Change the display of the sectioned body and sectioned boundary:

Then…If you want to…

set Visible off for the Sectioned
Body and Sectioned Boundary
components.

hide the sectioned body

set Visible on for the Sectioned
Body and Sectioned Boundary

display the sectioned body

components, and assign them dis-
play properties as needed.

7 Click OK three times.
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NOTE When the Sectioned Body component is set to visible and the material
display component is on, you can turn the display of the sectioned body on and
off by selecting the section line and clicking Building Section Line tab ➤ Live
Section panel ➤ Toggle Body Display.

Removing a Live Section View
Use this procedure to turn off a live section view. You can also remove the
live section view by deleting the section line that was used to create it.

1 Select the section line that was used to create the live section view.

2 Click Building Section Line tab ➤ Live Section panel ➤ Disable

Live Section  .

After turning off the live section view, you see the regular 3D
building model again. You can turn live section view on and off
as long as the section line remains in the drawing.

Editing a 2D or 3D Section
After you create a 2D or 3D section, you can edit the section line and the
section object to refine the appearance of the section in any of the following
ways:

■ Add, remove, or modify graphic subdivisions.

■ Reverse the section to display a different area of the building.

■ Relocate the section.

■ Add notes or reference files.

■ Select a different style. A section style determines how the linework in a
2D section is displayed.

■ Change the display properties of selected linework.

■ Add linework and details that are not part of the building model.

In addition, you can continue to modify the building model and then update
the section to incorporate the changes.

You can also create and edit material boundaries for 2D sections. For more
information, see Creating a Material Boundary in a 2D Section on page 3285.
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For information about switching from a view other than a section to a
temporary section view to edit objects, see Editing Objects in a Temporary
Section View on page 1136.

Using Grips to Edit Linework in a 2D Section
Use this procedure to edit linework in a 2D section. You can assign selected
linework to fixed display components that determine the display of every
section that you generate, or you can assign linework to display components
that you have defined.

For information about adding custom display components, see Adding a
Display Component to a 2D Section Style on page 3304. After you assign linework
to display components, you can change the display properties (visibility, color,
layer, lineweight, linetype, and linetype scale) to change the display of lines.

1 Select the section to be changed.

2 Select the Edit Linework grip.

NOTE Alternatively, click 2D Section/Elevation tab ➤ Linework

panel ➤ Edit  .

The contextual Edit In Place: Linework tab appears on the ribbon.

3 Click Edit in Place: Linework tab ➤ Profile panel ➤ Zoom To
to zoom to the section.

4 Select the linework to edit and click Edit In Place ➤ Linework

tab ➤ Profile panel ➤ Modify Component  .
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5 Select the component you want to put the lines on. For example,
if you want to make the lines invisible, select Erased Vectors for
Linework Component.

You can also click  (Match existing linework), and select
linework in the elevation whose display component you want to
match.

6 Click OK.

7 Exit the linework edit in place mode:

Then click…If you want to...

Edit in Place tab ➤ Edits pan-

el ➤ Finish.

save all changes to the linework

Edit in Place tab ➤ Edits pan-

el ➤ Cancel.

discard all changes to the linework

Changing the Display of Graphic Subdivisions in a 2D Section
Use this procedure to change the display of subdivisions in a 2D section by
changing its display properties.

You create subdivisions by adding them to the section line. You can then
change their length using grips or by editing the values in the section line
properties. For more information, see Creating Graphic Subdivisions for 2D
and 3D Sections on page 3267.
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Each subdivision in a 2D section is assigned to a numbered subdivision display
component in the display properties of the section or the 2D section style.
You can control the visibility, layer, color, linetype, lineweight, and linetype
scale of each subdivision by changing the display properties of each
component. You can apply these changes to the selected section, to the current
2D section/elevation style, or to all 2D sections and elevations in the drawing
that do not have a style override.

1 Select the 2D section in the drawing, and do one of the following:

■ To change the display for the graphic subdivisions in the 2D
section style, click 2D Section/Elevation tab ➤ General

panel ➤ Edit Style drop-down ➤ Edit Style  .

■ To change the display for the graphic subdivisions for the
selected 2D section object only, right-click, and Edit Object
Display. Then, check the Object Override box.

2 Click the Display Properties tab.

3 Select the property source to edit:

■ To change the display for the graphic subdivisions in the 2D
section style, check the Style Override box.

■ To change the display for the graphic subdivisions for the
selected 2D section object only, check the Object Override
box.

4 If necessary, click  .

5 Click the Layer/Color/Linetype tab to list all the components that
contribute to the display of the object.

The defining line represents the cutting plane of the section line.
The numbered subdivision components correspond to subdivisions
added to the section line. For example, the display component
Subdivision 1 corresponds to the subdivision closest to, but not
on, the cutting plane of the section line.

6 Turn the visibility on or off, and change the layer, color, linetype,
lineweight, or linetype scale as needed for each subdivision
component.

7 Click the Hatching tab to change the shrinkwrap hatch pattern
of the section.

8 Click the Other tab to add a custom display component to the
display of the 2D section.
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For more information about adding custom display components,
see Adding a Display Component to a 2D Section Style on page
3304.

9 Click OK twice.

Changing the Display of Graphic Subdivisions in a 3D Section
Use this procedure to change the display of subdivisions in a 3D section by
changing its display properties.

You create the subdivisions by adding them to the section line. You can then
change their length using grips or by editing the values in the section line
properties. For more information, see Creating Graphic Subdivisions for 2D
and 3D Sections on page 3267.

Each subdivision in a 3D section is assigned to a numbered subdivision display
component in the display properties of the 3D section. You can control the
visibility, layer, color, linetype, lineweight, and linetype scale of each
subdivision by changing the display properties of each component. You can
apply these changes to the selected 3D section or to all 3D sections in the
drawing.

1 Select the 3D section in the drawing, right-click, and click Edit
Object Display.

2 Click the Display Properties tab.

3 Select the Sub-divisions display representation.

4 Check the Object Override box.

5 If necessary, click  .

6 Click the Layer/Color/Linetype tab to list all the components that
contribute to the display of the object.

The defining line represents the cutting plane of the section line.
The numbered subdivision components correspond to subdivisions
added to the section line. For example, the display component
Subdivision 1 corresponds to the subdivision closest to, but not
on, the cutting plane of the section line.

7 Turn the visibility on or off, and change the layer, color, linetype,
lineweight, or lineweight scale as needed for each subdivision
component.

8 Click OK twice.
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Reversing a 2D or 3D Section
Use this procedure to reverse the direction of a section by reversing the section
line and refreshing the section.

The direction of the section is determined by the direction in which you drew
the section line. You can select the section line in plan view to see the
bounding box that defines the area of the model included in the section. If
the box does not include the area of the model that you intended, you can
reverse the section line. If you have already created a section from the section
line, update the section after reversing the section line.

1 Select the section line that you used to create the section, and

click Building Section Line tab ➤ Modify panel ➤ Reverse  .

The section line is mirrored about its own axis, as is the bounding
box with its original parameters.

2 Select the existing section.

Then click…If you selected…

click 2D Section/Elevation

tab ➤ Modify panel ➤ Regenerate

 .

NOTE If you do not need to
respecify the objects to include
in the section, you can instead
click 2D Section/Elevation
tab ➤ Modify panel ➤ Refresh

. This immediately updates
the section.

a 2D section

click 3D Section/Elevation

tab ➤ Modify panel ➤ Regenerate

a 3D section

3 If you want to include different objects in the updated section,

click  (Reselect Objects), and select the objects. Press ENTER
when you finish selecting objects.

4 Click OK.
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Changing the Style of a 2D Section
Use this procedure to select a different style for a 2D section. A 2D
section/elevation style controls the appearance of any 2D section object to
which the style is applied.

1 Double-click the section you want to change.

2 On the Properties palette, click the Design tab, expand Basic, and
expand General.

3 Select a new style for the section.

Creating a Material Boundary in a 2D Section
Use this procedure to create a material boundary in a 2D section. For more
information, see Material Components and Display Properties on page 898.

1 Draw a polyline around the area in the section that you want to
mask or to highlight.

2 Select the section, and click 2D Section/Elevation tab ➤ Material

Boundary panel ➤ Add  .

3 Select the polyline.

4 Enter y (Yes) to erase the polyline, or n (No) to keep the polyline
in the drawing.

5 Specify the settings of the material boundary:

Then…If you want to…

select Limit for Purpose.highlight the area inside the poly-
line

select Erase for Purpose.mask (erase) the area inside the
polyline

select the appropriate parts for Ap-
ply to. You can choose Surface and

apply the highlight or mask only to
specific parts of the section

Section Hatching, Section Hatching
Only, Surface Hatching Only, Edge
Linework Only, and All Linework.

select All Materials for Material Se-
lection.

apply the material boundary to all
materials used in the section
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Then…If you want to…

select Specific Materials for Material
Selection and then select the de-
sired materials in the list below.

apply the material boundary only
to selected materials

select Apply to section shrinkwrap
linework. For information on section

apply the highlighting or masking
within the polyline to the shrink-
wrap linework shrinkwrap, see Shrinkwrap on page

3308 and Shrinkwrap Hatch on page
3309.

select Apply to section shrinkwrap
hatching. For information on sec-

apply the highlighting or masking
within the polyline to the shrink-
wrap hatching tion shrinkwrap, see Shrinkwrap on

page 3308 and Shrinkwrap Hatch on
page 3309.

6 Click OK.

Editing a Material Boundary
You can edit existing material boundaries in a number of different ways:

■ Change the content within the material boundary. For example, you can
determine if you want to see only surface hatching, or both surface and
section hatching.

■ Change the shape of the material boundary. For example, you can make
the boundary bigger or smaller, or add additional rings and vertex points
to it.

For more information, see Material Components and Display Properties on
page 898.

Editing the Content of a Material Boundary
Use this procedure to change the content of a material boundary. The content
includes such settings as materials displayed, hatch types, and boundary type.
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1 Select the 2D section with the material boundary, and click 2D
Section/Elevation tab ➤ Material Boundary panel ➤ Edit In Place

 .

You are now in edit in place mode. The material boundary is
highlighted, and the grips are displayed.

2 Click Edit In Place tab ➤ Profile panel ➤ Edit Material Boundary

 .

3 Specify the content of the material boundary:

Then…If you want to…

select Limit for Purpose.highlight the area inside the
boundary

select Erase for Purpose.mask (erase) the area inside the
boundary

select the appropriate parts for Ap-
ply to. You can choose Surface and

apply the highlight or mask only to
specific parts of the section

Section Hatching, Section Hatching
Only, Surface Hatching Only, Edge
Linework Only, and All Linework.

select All Materials for Material Se-
lection.

apply the material boundary to all
materials used in the section

select Specific Materials for Material
Selection, and then select the de-
sired materials from the list below.

apply the material boundary only
to selected materials

4 Click OK.

5 To exit edit in place mode,

then click…if you want to..

Edit in Place: Material Boundary

tab ➤ Edits panel ➤ Finish.

save all changes

Edit in Place: Material Boundary

tab ➤ Edits panel ➤ Cancel.

discard all changes
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Adding a Vertex to a Material Boundary
Use this procedure to add a vertex to a material boundary.

1 Select the 2D section with the material boundary to change, and
click 2D Section/Elevation tab ➤ Material Boundary panel ➤ Edit

In Place  .

You are now in edit in place mode. The material boundary is
highlighted, and the grips are displayed.

2 Right-click, and click Add Vertex.

3 Specify the point at which to add a vertex.

4 Specify additional vertex points as needed.

5 Press ENTER.

6 To exit edit in place mode,

then click…if you want to..

Edit in Place: Material Boundary

tab ➤ Edits panel ➤ Finish

save all changes

Edit in Place: Material Boundary

tab ➤ Edits panel ➤ Cancel

discard all changes

Removing a Vertex from a Material Boundary
Use this procedure to remove a vertex from a material boundary.

1 Select the 2D section with the material boundary to change, and
click 2D Section/Elevation tab ➤ Material Boundary panel ➤ Edit

In Place  .

You are now in edit in place mode. The material boundary is
highlighted, and the grips are displayed.

2 Right-click, and click Remove Vertex.

3 Specify the vertex points to remove.

4 Press ENTER.
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5 To exit edit in place mode,

then click…if you want to..

Edit in Place: Material Boundary

tab ➤ Edits panel ➤ Finish.

save all changes

Edit in Place: Material Boundary

tab ➤ Edits panel ➤ Cancel.

discard all changes

Adding a Ring to a Material Boundary
Use this procedure to add a ring to a material boundary.

A material boundary can consist of more than one closed polyline. For example,
you could use one polyline to highlight a wall detail and another polyline to
highlight a window detail in another location.

1 Draw a polyline for the new material boundary ring.

2 Select the material boundary to add a new ring to, and click 2D
Section/Elevation tab ➤ Material Boundary panel ➤ Edit In Place

 .

You are now in edit in place mode. The material boundary is
highlighted, and the grips are displayed.

3 Click Edit In Place: Material Boundary tab ➤ Profile panel ➤ Add

Ring  .

4 Select the polyline you drew in Step 1.

5 Enter y (Yes) to erase the polyline, or n (No) to keep the polyline
in the drawing.

6 To exit edit in place mode,

then click…if you want to..

Edit in Place: Material Boundary

tab ➤ Edits panel ➤ Finish

save all changes

Edit in Place: Material Boundary

tab ➤ Edits panel ➤ Cancel

discard all changes
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Removing a Ring from a Material Boundary
Use this procedure to remove a ring from a material boundary.

A material boundary can consist of more than one closed ring. You can remove
each ring individually.

NOTE You cannot remove the last ring from a material boundary.

1 Select the 2D section with the material boundary to change, and
click 2D Section/Elevation tab ➤ Material Boundary panel ➤ Edit

In Place  .

You are now in edit in place mode. The material boundary is
highlighted and the grips are displayed.

2 Click Edit In Place: Material Boundary tab ➤ Profile

panel ➤ Remove Ring  .

3 Select the ring you want to remove.

4 To exit edit in place mode,

then click…if you want to..

Edit in Place: Material Boundary

tab ➤ Edits panel ➤ Finish

save all changes

Edit in Place: Material Boundary

tab ➤ Edits panel ➤ Cancel

discard all changes

Replacing a Ring from a Material Boundary with Another
Use this procedure to replace a ring from a material boundary with a different
ring.

1 Draw the polyline to replace one of the existing material boundary
rings.

2 Select the 2D section with the material boundary to change, and
click 2D Section/Elevation tab ➤ Material Boundary panel ➤ Edit

In Place  .

You are now in edit in place mode. The material boundary is
highlighted and the grips are displayed.
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3 Click Edit In Place: Material Boundary tab ➤ Profile

panel ➤ Replace Ring  .

4 Select the ring to be replaced.

5 Select the closed polyline you drew in Step 1.

6 Enter y (Yes) to erase the polyline, or n (No) to keep the polyline
in the drawing.

7 To exit edit in place mode,

then click…if you want to..

Edit in Place tab ➤ Edits pan-

el ➤ Finish

save all changes

Edit in Place tab ➤ Edits pan-

el ➤ Cancel

discard all changes

Editing and Merging Linework in a 2D Section
After you create a 2D section, you can edit the display of individual lines that
make up the section. For example, you may want to assign linework for small
details to a display component with a lighter lineweight, so that the details
are not obscured when plotted.

You can also merge existing geometry into the section.

Editing Linework in a 2D Section
Use this procedure to edit individual lines in a 2D section by assigning them
to display components in the section. For information about the Edit Linework
grip, see Using Grips to Edit Linework in a 2D Section on page 3280.

You can assign selected linework to fixed display components that determine
the display of every section that you generate, or you can assign linework to
display components that you have defined. For information about adding
custom display components, see Adding a Display Component to a 2D Section
Style on page 3304. After you assign linework to display components, you can
change the display properties (visibility, color, layer, lineweight, linetype, and
linetype scale) to change the display of lines.
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1 Select the section to be changed, and click 2D Section/Elevation

tab ➤ Linework panel ➤ Edit  .

The contextual Edit In Place: Linework tab is displayed.

2 Select the lines that you want to assign to a display component,
and click Edit In Place ➤ Linework tab ➤ Profile panel ➤ Modify

Component  .

A list of available display components is displayed.

3 Select the component on which to put the lines.

For example, to make the lines invisible, select Erased Vectors for
Linework Component.

You can also click  (Match existing linework) and select
linework in the section whose display component you want to
match.

4 Click OK.

5 If you want to undo an individual component change, enter
Aec2dSectionResultAbortChanges on the command line, and
select the component. This will undo all changes to that
component during the edit in place session, and automatically
exit the edit in place mode.

6 To finish the linework editing process,

then click…if you want to..

Edit in Place: Linework tab ➤ Edits

panel ➤ Finish

save all changes

Edit in Place: Linework tab ➤ Edits

panel ➤ Cancel

discard all changes

Merging Linework into a 2D Section
Use this procedure to merge geometry into a 2D section. When you merge
linework into a section, you assign additional linework to a display component
of a section. Use this feature to add detail, or to add linework that you did not
model.

1 Draw the geometry that you want to merge into a 2D section.
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2 Select the 2D section to be changed, and click 2D

Section/Elevation tab ➤ Linework panel ➤ Merge  .

3 Select the geometry to merge into the section, and press ENTER.

4 Select the display component to assign the linework to.

You can also click  (Match existing linework) and select
linework in the section whose display component you want to
match.

5 Click OK.

The linework is merged into the 2D section. When you select the
section, the linework is selected with it.

Changing the Location of a 2D or 3D Section
You can relocate a section by changing the coordinate values of its insertion
point. The section also has an orientation with respect to the WCS or the
current UCS. For example, if the top and bottom of the section are parallel to
the XY plane, its normal is parallel to the Z axis. You can change the orientation
of the section by aligning its normal with another axis. You can also rotate
the section on its plane by changing the rotation angle.

For information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use Coordinates and Coordinate Systems” in
AutoCAD help.

1 Double-click the section you want to move.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Location.

3 Click Additional information.

4 Specify a new location or rotation:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the section

make the normal of the section
parallel to the Z axis: under Normal,

locate the section on the XY plane

enter 1 for Z, and enter 0 for X
and Y.
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Then…If you want to…

make the normal of the section
parallel to the X axis: under Normal,

locate the section on the YZ plane

enter 1 for X, and enter 0 for Y
and Z.

make the normal of the section
parallel to the Y axis: under Normal,

locate the section on the XZ plane

enter 1 for Y, and enter 0 for X
and Z.

enter a new value for Rotation
Angle.

change the rotation of the section

5 Click OK.

Attaching Hyperlinks, Notes, and Files to a 2D or 3D Section
Use this procedure to add hyperlinks, enter notes, and attach reference files
to a 2D or 3D section. You can also edit notes and edit or detach reference
files from a 2D or 3D section.

1 Double-click the 2D or 3D section you want to attach notes or
files to.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click  next to Hyperlink, and specify the
link.

4 To add a note, click  next to Notes, enter text, and click OK.

5 To attach, detach, or edit a reference file, click  next to
Reference documents, and then do any of the following:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file
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Then…If you want to…

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

6 Click OK.

Updating a 2D or 3D Section
Use this procedure to update a 2D or 3D section to reflect changes you have
made to the building model or to section line properties. For 2D sections, you
also update the section to show changes made to the 2D section style. You
can update a 2D or 3D section if you have not exploded the section, which
destroys the link between the section and the building model.

When you update a section, you can add or remove objects from the section,
change the location of the section in the drawing, and change the display set
of the section.

If you do not need to change the section definition in any way, you can skip
the following procedure. Instead, select the section you want to update, and

click 2D Section/Elevation tab ➤ Modify panel ➤ Refresh  .

1 Select the section you want to update.

then…If you selected…

click 2D Section/Elevation

tab ➤ Modify panel ➤ Regenerate

 .

a 2D section object

click 3D Section/Elevation

tab ➤ Modify panel ➤ Regenerate

 .

a 3D section object
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2 Select a result type:

Then…If the section is…

select 2D Section/Elevation Object
with Hidden Line Removal.

a 2D section object

select 3D Section/Elevation Object.a 3D section object

3 To change the style of a 2D section, select a new style for Style to
Generate.

4 If you edited linework in the 2D section, select a style in which
to save the changes you made that cannot be reapplied. Choose
a style that will distinguish the unapplied changes in the section.

5 Under Selection Set, specify the objects that you want to include
in the section:

Then…If you want to…

proceed to the next step.use the objects in the selection set
you specified when you created the
section or when you previously up-
dated it

click Select Additional Objects, se-
lect the new objects in the drawing,
and press ENTER.

add new objects to the selection set
that you specified when you created
the original section

click Reselect Objects, select a new
selection set of objects for the sec-
tion, and press ENTER.

select a new selection set of objects
for the section

NOTE If you select an object that you do not want to include in the
section, hold down SHIFT, and select the object again to remove it
from the selection set.

6 Under Display Set, select a display set for the section.

7 Under Placement, locate the section in the drawing:

Then…If you want to…

select New Object, and either click

 to specify an insertion point in

create a new section object without
overwriting the original object
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Then…If you want to…

the drawing area, or enter X, Y, and
Z coordinates for the new section.

select Replace Existing.replace the original section with the
updated section

8 Click OK.

Globally Updating 2D Sections
AutoCAD Architecture makes it possible for you to globally update all sections
and elevations within a project or a specified folder.

Updating Sections and Elevations in a Project

AutoCAD Architecture includes the Drawing Management feature that allows
users to combine their floor plans, section and elevation views, construction
sheets, and reusable components in one building project. A project consists
of a number of drawings linked together with a powerful external referencing
mechanism. You can open a project and update all 2D sections and elevations
included in that project in one comfortable workflow. For information on
which project file types can be updated, see Supported Project Drawing Types
on page 3298.

Updating Sections and Elevations in a Specific Folder

When you are working without a project, you can also globally update sections
and elevations by specifying a folder and updating all sections and elevations
in that folder. When you select a specific folder for updating, you can also
include its subfolders in the update.
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Section of a building project

For more information about building projects, see Drawing Management on
page 303.

Supported Project Drawing Types
When you are updating a project, you can globally update all 2D sections and
elevations within the views and sheets of the project. You cannot globally
update elements and constructs, because these project drawings usually contain
reusable elements and individual parts of the building project. They normally
do not contain sections or elevations.

For more information about project drawing types, see Views on page 446 and
Sheets on page 481.

NOTE When you globally update the sections and elevations in a project drawing,
all model and paper space layouts are updated.

When you are updating a specified folder within a project, or a folder outside
of a project, all sections and elevations in that folder are updated regardless
of their type. For example, if you choose to update a specific folder within the
Constructs category of a project, the sections and elevations in that folder will
be updated, even though they are Construct drawings. If you do not specify
a folder, but choose to update the whole project, these construct drawings are
not updated.
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Globally Updating 2D Sections and Elevations in a Project or a
Folder

Use this procedure to globally update all 2D sections and elevations in a project
or a specified folder.

NOTE To update all 2D sections and elevations in a project, the project must be
defined as current. If no project is current, you receive an error message if you try
to globally update 2D sections and elevations. For information on setting a project
current, see Setting a Project Current on page 327.

1 Click Home tab ➤ Section & Elevation panel ➤  ➤ Batch

Refresh  .
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2 Select if you want to update the 2D sections and elevations in the
current project, or only the 2D sections and elevations in a specific
folder.

Then...If you want to...

select Current Project.update the 2D sections and el-
evations in the current project

select Folder. Then click the Browse

button  , select the folder containing

update the 2D sections and el-
evations in a specific folder

the files you want to update, and click
OK.

3 If you have specified a folder, you can specify whether the
subfolders of that folder should be updated as well. To update the
subfolders, select Process subfolders.

NOTE When you are working with a large building project, updating
all sections and elevations can be a time-consuming process. In this
case, you might consider updating only a selected subfolder of your
project and thereby improve system performance.

4 Click Begin.

Globally updating all sections and elevations may take a while.
A status window lets you know which drawing is currently being
updated.

When you start the global update, the Stop button is available. If
you want to interrupt the global update, click Stop. When the
global update is finished, the Begin button is available.

Updating Legacy Drawings
During the global update of 2D sections and elevations, each drawing in the
project or specified folder is opened, updated, and saved again. If you are
updating drawings from an earlier version of the software, the drawings are
converted to the current version. Before you convert the drawings, a warning
message notifies you of the conversion. To update the drawings to the new
version, click OK. To cancel the update of all sections and elevations, press
CTRL+BREAK.

3300 | Chapter 41   Sections



Update Exceptions

There are a number of cases in which a 2D section or elevation cannot be
updated with the global update.

■ The drawing containing the 2D section or elevation is read-only.

■ The 2D section or elevation is placed on a locked layer.

■ There have been user edits to a 2D section or elevation that could not be
reapplied to the 2D section or elevation.

When a 2D section or elevation cannot be updated, an error message is
displayed in the status window.

To fix the problem, you can set the drawing to read/write instead of read-only,
you can unlock the section layer, or you can undo a specific user edit to a 2D
section or elevation.

2D Section Styles
A 2D section/elevation style is a group of properties assigned to a 2D section
or to an elevation that determines the appearance and other characteristics
of that object.

Using 2D Section Styles

A 2D section/elevation style controls the linework in a section, using design
rules that determine how different parts of the section are displayed. You can
apply the style to one or more sections to control their appearance. You can
also change the display of individual lines in the section, and save the changes
in a 2D section/elevation style.

Display Components and Design Rules

Display components determine the graphical characteristics, such as color
and linetype, of linework assigned to each display component. Design rules
determine how the linework in a section is assigned to display components.

When you create a design rule, you specify the part of the 2D section to control
based on the color of those objects in the building model and their context
in the section. You then select the display component to use for linework that
meets the criteria you specified. You can assign the linework to a default
display component or to a custom display component that you have added
to the style. For example, you might define a rule that assigns all objects that
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are color 150 in the model and that are located along the section line (the
defining line) to a custom display component named Darker that you created
in the style. Or you might hide a staircase behind a wall using a rule that
assigns all blue linework to the Hidden display component.

Managing 2D Section Styles

To create, edit, copy, or purge styles, you access the Style Manager. The Style
Manager provides a central location in AutoCAD Architecture where you can
work with styles from multiple drawings and templates. For more information
about using the Style Manager, see Style Manager Overview on page 870.

Materials and 2D Section Styles

You can use 2D section styles to specify which section components will have
their display controlled by materials and which will not. Custom components
cannot use materials.

Subdivisions in 2D Section Styles and Materials

When you are creating subdivisions in your style, you usually want the objects
in them to be visually distinct from other subdivisions. When you assign
materials to the objects, you can set the 2D section style so that it uses the
hatch pattern from the material, but the color and linetype from the
subdivision display properties.

Section subdivision surface hatching with color assignments
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Creating a 2D Section Style
Use this procedure to create a 2D section style. You can create a style using
default style properties or by copying an existing style. After you create the
style, you edit the style properties to customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand 2D Section/Elevation
Styles.

NOTE Alternatively, select a 2D section in the drawing, and click 2D
Section/Elevation tab ➤ General panel ➤ Edit Style drop-down ➤ 2D

Section/Elevation Style  .

3 Create a 2D section style:

Then…If you want to…

right-click 2D Section/Elevation
Styles, and click New. Enter a name

create a style using default proper-
ties

for the new 2D section style, and
press ENTER.

right-click the 2D section style you
want to copy, and click Copy.

create a style from an existing style

Right-click, and click Paste. Right-
click the new style, and click Re-
name. Enter a name and press
ENTER.

4 Edit the 2D section style:

Then…If you want to…

see Adding a Display Component
to a 2D Section Style on page 3304.

add display components to the style

see Removing a Display Component
from a 2D Section Style on page
3305.

remove display components from
the style

see Use Subdivision Properties and
Materials in 2D Section Styles on
page 3313.

use the subdivision properties of the
section for the display
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Then…If you want to…

see Use the 3D Body Component
of a Material for the 2D Section
Linework on page 3313.

use the 3D Body component of the
material for the section linework

see Adding a Design Rule to a 2D
Section Style on page 3314.

add design rules to the style

see Changing a Design Rule in a 2D
Section Style on page 3316.

change design rules in the style

see Adding Classifications to a 2D
Section Style on page 3317.

add classifications to a style

see Changing the Layer, Color, and
Linetype of a 2D Section Style on
page 3317.

change the display properties of the
display components in the style

see Attaching Notes and Files to a
2D Section Style on page 3318.

add notes, files, or documents to
the style

5 Click OK.

Adding a Display Component to a 2D Section Style
Use this procedure to add a custom display component to a 2D section style.
After you add a component, you assign linework in the section to the new
component. To apply these style changes to existing 2D sections, you must
update the section.

2D sections include the following default display components: Defining Line,
Hidden, Erased, Unknown, and Subdivision.

1 Select a section that has the style you want to change, and click
2D Section/Elevation tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

2 Click the Components tab.

3 Click Add.

4 Enter a name and a description for the new component.
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To enter a name, click Unnamed and enter a new name. To enter
a description, click in the Description column next to the name,
and enter a description.

5 Click the Display Properties tab.

6 Select the display representation in which to display the changes,
and select Style Override.

7 If necessary, click  .

8 Click the Layer/Color/Linetype tab.

9 Specify the display properties of the new component.

10 Click OK twice.

To create a design rule that uses the new display component, see
Adding a Design Rule to a 2D Section Style on page 3314. To
manually assign linework to the display component, see Editing
Linework in a 2D Section on page 3291.

Removing a Display Component from a 2D Section Style
Use this procedure to remove a custom display component from a 2D section
style. Removing a display component also removes any design rules that use
the component. You cannot remove the default display components.

1 Select a section that has the style you want to change, and click
2D Section/Elevation tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

2 Click the Components tab.

3 Select the component that you want to remove, and click Remove.

If the component is used in a design rule, a dialog box is displayed,
warning you that the associated design rule is removed as well.

4 Click OK.

5 Update the section to apply the style changes to the section.

For more information, see Updating a 2D or 3D Section on page
3295.
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About 2D and 3D Section Display Components and Materials
2D and 3D section object consist of a number of display components which
can be determined by materials.

When you assign materials to an object, you assign one material to each
display component of an object. For example, you assign a wood material to
the frame of a window and a glass component to the glass of a window.

When you create a 2D or 3D section object from building objects, the material
assignments of the source objects are applied to the section. You do not assign
a material directly to a 2D/3D section. The section takes its material
assignments from the objects that are sectioned. For example if you create a
section through a wall with a window, the section hatch you have defined in
the glass, wood, and brick materials of the wall and the window are displayed
in the section.

If you do not want to use the material display properties, but instead use those
of the 2D or 3D section object, or the 2D section style, you can deactivate the
material assignments in the display properties of the section or the section
style.
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Material Component Assignments

Material definitions consist of display components which correspond to
component types of objects. For example, the Linework component of a
material is used for all linework of objects in Plan view. The Surface Hatch
component of a material is used to hatch all object surfaces in 3D model views
and elevations.

For a complete list of material components and their description, see Material
Components and Display Properties on page 898.

The following table lists all section components plus information about the
material components that determine them.

NOTE Keep in mind that materials are not assigned directly to 2D section objects,
but that the assignment of materials happens indirectly via the sectioned objects.
For example, if a brick material has a surface hatch component with a red brick
pattern, this surface hatch determines the display of the surface hatch in a brick
wall. When you create a 2D section from that wall, the resulting section object
will inherit the red brick pattern from the wall. When you change the material of
the wall from brick to concrete, and then update the 2D section, it will now display
with a grey concrete pattern.

Material Component2D Section Component

2D Section/Elevation Linework or 3D Body.
For information on switching between

Defining Line

these material components, see Use the
3D Body Component of a Material for the
2D Section Linework on page 3313.

No MaterialOuter Shrinkwrap

No MaterialInner Shrinkwrap

No MaterialShrinkwrap Hatch

Surface HatchSurface Hatch Linework

Section HatchSection Hatch Linework

No MaterialHidden

No MaterialErased
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Material Component2D Section Component

2D Section/Elevation Linework or 3D Body.
For information on switching between

Subdivision 1-10

these material components, see Use the
3D Body Component of a Material for the
2D Section Linework on page 3313.

Defining Line
The defining line determines where the section cuts the objects it contains.
The material component which controls the display of the Defining Line is
the Linework component. The defining line is a display component of both
2D and 3D section objects.

For example, if you cut a brick wall that contains a window, you can specify
one uniform color for the defining line, or use different colors where the
section line cuts the wall and where it cuts the window. If you want to use a
uniform color for the Defining Line component, assign a color to it and do
not use the properties of the material. If you want the color of the defining
line to be influenced by the objects in the section, use the material properties.
In the case of a section through a brick wall with a window, you might use a
red defining line where the wall is cut and a blue defining line where the
window is cut.

Specifying cut line colors for different materials

Shrinkwrap
The shrinkwrap displays the union of all object faces cut by the section line.
The Outer Shrinkwrap component represents the outline of solid, filled
components, such as a wall shrinkwrap. The Inner Shrinkwrap component
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represents the outline of holes which have been cut, such as a space. These
components are specific to 2D sections.

You can exclude individual objects from contributing to the shrinkwrap. For
example, you might do this for glass components in windows. For information
on excluding objects from the 2D shrinkwrap, see Excluding a Material
Definition from 2D Section Shrinkwrap on page 928.

2D section with red outer shrinkwrap

Window glass excluded from shrinkwrap

The Outer and Inner Shrinkwrap components cannot be defined by a material
component.

Shrinkwrap Hatch
The Shrinkwrap Hatch component hatches the union of all object faces cut
by a section line. The Shrinkwrap Hatch is defined by either an outer or an
inner shrinkwrap line component. This component is specific to 2D sections.
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Shrinkwrap Hatch with glass excluded from shrinkwrap detail

The Shrinkwrap Hatch component cannot be defined by a material component.

NOTE The Shrinkwrap Hatch and Section Hatch components overlap each other.
This could result in two different hatches in the same location. To avoid a conflict,
either assign a solid hatch for Shrinkwrap Hatch, or do not use the Shrinkwrap
and Section Hatch components simultaneously.

Surface Hatch Linework
The Surface Hatch Linework component draws all linework coming from
surface hatches of the objects cut. Surface hatches appear in faces of the section
object that are not cut by the section line. This component is specific to 2D
sections.

NOTE Surface hatches that you have assigned to objects will display in a 3D section
object. However, you cannot set them separately in a 3D section; you can do that
only in a 2D section object.

The surface hatch linework component is controlled by the surface hatch
component of the material. For information about the surface hatch
component of the material, see Surface Hatch Material Component on page
900.
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2D section with roof surface hatch

Section Hatch Linework
The Section Hatch Linework component draws all linework coming from
section hatches. Section hatches appear on all faces that are cut by the section
line. A section hatch is similar to a shrinkwrap hatch. The difference is that
in a section hatch the sectioned faces are not merged into one shrinkwrap
component. Use either a section hatch or a shrinkwrap hatch on a 2D section.
For information on shrinkwrap hatches see Shrinkwrap Hatch on page 3309.

The Section Hatch Linework display component is specific to 2D section.

Section hatches on walls, roof and door

The Section Hatch Linework component is controlled by the Section Hatch
component of the material. For information about the Section Hatch
component of the material, see Creating a Hidden Line Projection on page
3385.

Hidden Component
The Hidden component contains all linework that is hidden in the 2D
projection because other components are in front of it. By default, this
component is turned off. You can use design rules to achieve special effects,
such as a see-through effect, using the Hidden component. The Hidden
component is specific to 2D sections.
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The Hidden component cannot be defined by a material component. You can
only set it in the display properties of the 2D section. For information on
setting the display properties of a 2D section, see Creating a Hidden Line
Projection on page 3385.

Erased Component
The Erased component contains linework in the section object that you do
not want to see. For example, if you have a section of a multi-story building
in which you want to hide the lines between each floor, you can edit the
linework of the section and assign the floor lines to the Erased component.
Since the Erased component is turned off by default, the floor lines do not
display. For information on linework editing of a section, see Editing Linework
in a 2D Section on page 3291.

The Erased component is specific to 2D sections.

The Erased component cannot be defined by a material component.

Subdivision Components
The subdivision components partition a section object. They are useful to
create perspective effects, where parts closer to the viewer are drawn with
darker, stronger lines and parts which are farther from the user are drawn with
lighter, thinner lines. Subdivisions can have no individual material
assignments. However the display properties of the subdivisions can be used
for the surface hatching of the subdivisions by selecting “Use Subdivision
Properties for Surface Hatching” in the Other tab of the 2D section display
properties. For information on using the subdivision display properties to
display the section divisions, see Use Subdivision Properties and Materials in
2D Section Styles on page 3313.

Subdivisions are a display component of both 2D and 3D section objects.

The subdivision components are either controlled by the 2D Section/Elevation
Linework component of the material or by the 3D Body component of a
material. For information how to switch between these component
assignments, see Use the 3D Body Component of a Material for the 2D Section
Linework on page 3313.
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Use Subdivision Properties and Materials in 2D Section Styles
Use this procedure to use the display properties of materials together with the
display properties of section subdivisions.

1 Select a section that has the style you want to change, and click
2D Section/Elevation tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

2 Click the Display Properties tab.

3 Select the display representation in which to display the changes,
and select Style Override.

4 If necessary, click  .

5 Click the Layer/Color/Linetype tab.

6 To set a subdivision to use the surface hatch of the material, while
using the layer, color, and linetype display properties of the
subdivision, perform the following steps:

■ Clear By Material.

■ Specify the layer, color and linetype settings of the subdivision
as desired. For example, the first subdivision could have a
darker color and stronger linetype the second subdivision.

7 Click the Other tab.

8 Select Use Subdivision properties for surface hatching.

9 Click OK twice.

For more information, see Updating a 2D or 3D Section on page
3295.

Use the 3D Body Component of a Material for the 2D Section
Linework

Use this procedure to use the 3D Body component of a material for the
linework in a 2D section.

1 Select a section that has the style you want to change, and click
2D Section/Elevation tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

2 Click the Display Properties tab.
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3 Select the display representation in which to display the changes,
and select Style Override.

4 If necessary, click  .

5 Click the Other tab.

6 Determine if the 3D body component of the selected material
should control the display of the linework in the 2D section:

Then…If you want to…

select Use 3D Body display compon-
ent for By Material linework.

control the display of the 2D sec-
tion linework by the 3D Body com-
ponent of the material,

clear Use 3D Body display compon-
ent for By Material linework. This is
the default behavior.

control the display of the 2D sec-
tion linework by the 2D Section/El-
evation Linework component of the
material,

7 Click OK twice.

For more information, see Updating a 2D or 3D Section on page
3295.

Adding a Design Rule to a 2D Section Style
Use this procedure to add a design rule to a 2D section style. A design rule has
four fields of information that identify lines in the section and determine how
to display them:

DescriptionField

Identifies the color of the objects in the
building model represented by lines in the
section.

Color

Identifies the context of the lines in the 2D
section, such as on the defining line (the
cutting plane) or in a graphic subdivision.

Context

Identifies the display component to which
the lines are assigned.

Component

Contains a description of the design rule.Description
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For example, a design rule has the color 50, a context of Within Subdivision
2, and a component of New. This rule assigns any lines in the section
representing objects that have the color 50 in the building model and that
are within subdivision 2 in the section to the user-defined display component,
New.

You can also specify that all hidden linework that is not handled by a specific
design rule will be assigned to the Hidden display component. You could use
this option if you want to generate a section of an object or a set of objects
and see all edges, for example, if you are creating foundations and formwork.

NOTE Alternatively, you can define which hidden linework should be displayed
by object material. For more information, see Controlling the Display of Hidden
Lines by Material on page 929.

1 Select a section that has the style you want to change, and click
2D Section/Elevation tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

2 Click the Design Rules tab, and click Add.

A new design rule is created with default color, context, and
component values.

3 Specify settings for the new design rule:

Then…If you want to…

click the default color, select a new
color, and click OK.

specify the color of objects in the
building model that are affected by
this rule

click the default context, and select
a new context.

specify the context in which the
linework for the objects appears in
the section

click the default component, and
select a new component.

select the display component for
the linework

click the Description field, enter a
description, and press ENTER.

enter a description of the rule

4 To place all hidden linework on the Hidden display component,
select Keep all hidden linework.

5 Click OK.
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6 Update the section to apply the style changes to the section.

For more information, see Updating a 2D or 3D Section on page
3295.

Changing a Design Rule in a 2D Section Style
Use this procedure to change the settings in the fields that define a design
rule.

1 Select a section that has the style you want to change, and click
2D Section/Elevation tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

2 Click the Design Rules tab.

3 Specify settings for the design rule you want to change:

Then…If you want to…

click the current color, select a new
color, and click OK.

specify the color of objects in the
building model that are affected by
this rule

click the current context, and select
a new context.

specify the context in which the
linework for the objects appears in
the section

click the current component, and
select a new component.

select the display component for
the linework

click the description, edit the de-
scription, and press ENTER.

edit the description of the rule

4 Click OK.

5 Update the section to apply the style changes to the section.

For more information, see Updating a 2D or 3D Section on page
3295.

Removing a Design Rule from a 2D Section Style
Use this procedure to remove a design rule from a 2D section style.
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1 Select a section that has the style you want to change, and click
2D Section/Elevation tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

2 Click the Design Rules tab.

3 Select the rule that you want to remove, and click Remove.

4 Click OK.

5 Update the section to apply the style changes to the section.

For more information, see Updating a 2D or 3D Section on page
3295.

Adding Classifications to a 2D Section Style
Use this procedure to specify classifications for any classification definition
applied to a 2D section style.

For more information about creating and applying classification definitions,
see Classification Definitions on page 3872.

1 Select a section that has the style you want to change, and click
2D Section/Elevation tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

2 Click the Classifications tab.

By default, the classification for all classification definitions is
Unspecified. If no classification definitions are listed, none are
applied to 2D section styles.

3 For each classification definition, select the classification you want
to apply to the current 2D section style.

4 Click OK twice.

Changing the Layer, Color, and Linetype of a 2D Section Style
Use this procedure to change the following display properties of a 2D section
style:

■ Visibility (component is on or off)

■ Display properties by materials

■ Layer
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■ Color

■ Linetype

■ Lineweight

■ Linetype scale

NOTE The custom display components in the display properties are identical to
those listed on the Components tab of the 2D Section/Elevation Styles dialog box.
For more information about custom display components, see Adding a Display
Component to a 2D Section Style on page 3304.

1 Select a section that has the style you want to change, and click
2D Section/Elevation tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

2 Click the Display Properties tab.

3 Select the display representation in which to display the changes,
and select Style Override.

4 If necessary, click  .

5 Click the Layer/Color/Linetype tab.

6 Select the component to change, and select a different setting for
the property.

7 Select By Material for any component that you want to use the
display properties of the materials assigned to the sectioned
objects.

NOTE Not all display components of a 2D section have an associated
material definition. For example, Hidden and Erased cannot be set
by material. For a list of all display components and their associated
material components, see About 2D and 3D Section Display
Components and Materials on page 3306.

8 Click OK twice.

Attaching Notes and Files to a 2D Section Style
Use this procedure to enter notes and attach reference files to a 2D section
style. You can also edit reference files attached to the style.
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1 Select a section that has the style you want to change, and click
2D Section/Elevation tab ➤ General panel ➤ Edit Style

drop-down ➤ Edit Style  .

2 Click the General tab.

3 To add a description to the 2D section, enter the description under
Description.

4 Click Notes.

5 To add or edit a note, click the Notes tab, and enter the note.

6 To attach, edit, or detach a reference file, click the Reference Docs
tab:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Edit
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application. Click OK
when you are done editing.

edit a reference file

select the file name, click Delete,
and click OK.

detach a reference file

7 Click OK twice.
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Elevations

You can create elevations of the building models in your drawings by first drawing an elevation
line and mark, and then creating a 2D or 3D elevation based on that line. You can control
the size and shape of any elevation that you create, and you can update an existing elevation
when the objects included in the elevation are modified. 2D elevations are created with hidden
and overlapping lines removed. You can control the appearance of 2D elevations by applying
rules that are controlled by the style and display properties of the 2D elevation.

Working With Elevations
You can create elevations of the building models in your drawings by first
drawing an elevation line and mark, and then creating a 2D or 3D elevation
based on that line. You can control the size and shape of any elevation that
you create, and you can update an existing elevation when the objects included
in the elevation are modified. 2D elevations are created with hidden and
overlapping lines removed. You can control the appearance of 2D elevations
by applying rules that are controlled by the style and display properties of the
2D elevation.

Elevation Line and Marks

The elevation line defines the extents of the elevation view of your building
model. Elevation lines can be straight or jogged. You can also specify the length
and the height of the area defined by the elevation line. Elevation marks, which
typically contain a letter or number and indicate the direction of the elevation,
appear at each end of the elevation line.

After you draw the elevation line, you create an elevation object from the line.
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Viewing the elevation line and mark

2D Elevations

2D elevations are created by drawing an elevation line in front of a number
of objects and then creating a 2D elevation object from them. The elevation
object is drawn without hidden and overlapping lines. You can edit a 2D
elevation by changing its object display properties or its style display properties.
The 2D elevation style lets you add display components to the display
representation of the elevation and create rules that assign different parts of
the elevation to different display components. You can control the visibility,
layer, color, linetype, lineweight, and linetype scale of each component. You
can also assign a material, such as a brick or concrete hatch, to individual
components of the object or the style. Furthermore, you can use linework
editing commands to assign individual lines in a 2D elevation to different
display components, and merge geometry into a 2D elevation. You can
dimension 2D elevations.

2D building elevation
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3D Elevations

3D elevations are created by drawing an elevation line in front of a number
of objects and then creating a 3D isometric elevation object from them. 3D
elevations do not use styles. However, you can control the display of
subdivisions within 3D elevations. Using the Hidden Line Projection command,
you can create 2D hidden line projections of any view of the 3D elevation
that you can explode and edit or hatch. For more information about using
this command, see Creating a Hidden Line Projection on page 3385.

3D elevation in 3D view

Elevation Subdivisions

A 2D or 3D elevation object can have a number of subdivisions partitioning
the elevation object. This feature is useful when you want to create a
perspective view of the object, in which the parts that are closer to the viewer
are drawn with darker and stronger lines, and parts that are farther off are
drawn lighter.

3D elevation with subdivisions in perspective view

Live Section View

A live section view is a special view of a 3D section where the objects that are
sectioned are not converted to a 3D section object, but remain in the drawing
as objects. The parts of the objects within the bounding box of the section
line keep their individual display components while the parts of the objects
outside of the section line can be displayed or hidden. To control the
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appearance of the object parts outside of the section line, you need to assign
a material to the sectioned objects.

When you render a live section, you can show the outside part as a
half-transparent addition, for example.

You can use the live section view in an elevation in order to clip out just the
region you need momentarily and to focus on that specific area. This can
accelerate performance and make working with the building model easier.

For information on creating live section views, see Creating a Live Section
View on page 3276.

Rendered live section view with transparent body component

Materials in Elevations

In AutoCAD Architecture, you can assign materials to different components
of an object. These materials are displayed when you create a 2D or 3D
elevation object. You can specify whether to use the display properties of the
materials or the display properties of the elevation object.
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2D elevation with different surface hatches

AutoCAD Architecture provides a large number of predefined materials for all
common design purposes. You can use these predefined materials or modify
them to your special designs. You can also create your own materials. For
more information, see About 2D and 3D Elevation Display Components and
Materials on page 3374.

Subdivisions in 2D Elevation Styles and Materials

When you are creating subdivisions in your style, you usually want the objects
in them to be visually distinct from other subdivisions. When you have
assigned materials to the objects, you can set the 2D elevation style so that it
uses the hatch pattern from the material, but uses the color and linetype from
the subdivision display properties.
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Elevation subdivisions with assigned surface hatching

For more information see Use Subdivision Properties and Materials in 2D
Elevation Styles on page 3378.

Material Boundaries in 2D Elevations

Material boundaries allow you to erase or limit portions of a 2D elevation:

■ Limit the amount of hatching to produce cleaner construction documents.

■ Highlight a region in an elevation.

■ Mask out a portion of an elevation so that more detail can be drawn.
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■ Crop an irregular-shaped portion of an elevation.

For more information, see Creating a Material Boundary in a 2D Elevation on
page 3356.

Workflow to Create a 2D or 3D Elevation

The elevation line on page 3331 defines the extents
of the elevation (its width, height, and length) to
extract from the building model.

-----Draw an elevation line and mark

Select the elevation line and the objects to be
include, and generate on page 3342 an elevation.

-----Create a 2D or 3D elevation
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You can edit on page 3346 the elevation line, edit
linework, or edit objects to refine the appearance
of the elevation.

-----
Make changes to the elevation or
the building model

Update on page 3364 elevations to apply the
changes you made to the elevation line, elevation

-----Update the elevation object, or the building model. You can also
globally on page 3366 update all elevations within
a project or a specified folder all at once.

Drawing and Editing Elevation Lines
The first step in creating elevations is to draw an elevation line relative to your
building model. The elevation line defines the extents of the elevation view
of the building model.

NOTE You can create vertical elevations and horizontal elevations.

Creating an Elevation Object from an Elevation Line
When you generate an elevation from an elevation line, you specify the type
of elevation object that is created.

The result is…When you create…

an orthographic projection from the
building model.

a 2D elevation object

the area of the building model defined in
the elevation line.

a 3D elevation object

Viewing the Elevation Line

In plan view, the elevation line is displayed as you would expect on a
construction document.
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Creating an Elevation

In an isometric view, the same elevation line is displayed with a boundary
that defines the depth of elevation view.
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Drawing an elevation line in 3D view

Resulting elevation line in 3D view

Changing the Elevation Line

You can change the elevation line to control the elevation that you create.
Using the elevation line’s grips, you can change the height and shape of the
elevation. You can also add a lower extension to the elevation and create
elevation subdivisions.
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You can change elevation line properties before you create an elevation. You
can also change elevation line properties and update an elevation that you
have already created. For more information about updating existing elevations,
see Updating a 2D or 3D Elevation on page 3364.

Using Subdivisions in Elevations

You can set up graphic subdivisions in elevation line properties. These
subdivisions are then added to the 2D or 3D elevation you create. Subdivisions
are specified at distances from the elevation line. You can control the
lineweight and other display properties of subdivisions to add levels of depth
to elevations. For example, you can display one subdivision with a heavy
lineweight and another subdivision with a lighter lineweight to suggest that
the first subdivision is in front of the second subdivision.

Drawing an Elevation Line and Mark
Use this procedure to draw an elevation line with an elevation mark at each
end. You draw an elevation line by specifying a start point and an endpoint
for the line in relation to your building model.

NOTE If you are working with a drawing set in which several xrefs are linked to
a main drawing, draw your elevation line in the main drawing.

TIP You can also create elevations with Callout tools. For more information, see
Placing Elevation Callouts on page 3717.

1 Click Home tab ➤ Section & Elevation panel ➤ Elevation Line
.

2 Specify the elevation line start point.

NOTE Specify the start point and endpoint for the elevation line so
that it extends past the face or segment of your building model view,
thus ensuring that all objects are included in the elevation view.

3 Specify the elevation line endpoint.

The elevation line is displayed in your drawing with an elevation
mark. The elevation line boundary is drawn using the elevation
line as its left side and forming a box with the elevation line. This
is the area that defines the elevation.
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Drawing an elevation line in 3D view

Drawing an elevation line in 3D view

Depending on the direction in which you drew the elevation line,
the elevation mark points in the direction of the elevation view.

The elevation mark is a multi-view block, anchored to the elevation line. You
can edit the elevation mark to change the information that is displayed in
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the bubble. For more information, see Changing Elevation Mark Attributes
on page 3339.

Once you have an elevation line in your drawing, you can change the
properties of the line to change the elevation.

Changing the Height of an Elevation Using Grips
Use this procedure to change the height of any elevation connected to the
elevation line. You can change the height of the elevation line before or after
you create a connected elevation. If you change the height after creating the
elevation, you need to update the elevation to show the changes.

You can also change the height of an elevation using the Properties palette.

1 On the floating View panel, click View drop-down ➤ SW isometric

 .

2 Select the elevation line you want to change.

3 Select the Model Extents grip to turn off model extents mode.

If you use model extents for height, the height of the elevation
is determined by the height of the objects in the elevation and is
not available to modify dynamically.

4 Select the Height grip.

Viewing Elevation Grips in 3D View

5 Move the grip until the height value you want is displayed, and
then click once, or enter a value.
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The objects are cut at this height when you create or update an
elevation.

6 Right-click, and click Deselect All to turn off grips.

To update an elevation created from this elevation line, see Updating a 2D or
3D Elevation on page 3364.

Changing the Lower Extension of an Elevation Using Grips
Use this procedure to change the lower extension of any elevation connected
to the elevation line. You can change the lower extension of the elevation
line before or after you create a connected elevation. If you change the lower
extension after creating the elevation, you need to update the elevation to
show the changes.

You can also change the lower extension of an elevation using the Properties
palette.

1 On the floating View panel, click View drop-down ➤ SW isometric

 .

2 Select the elevation line you want to change.

3 Select the Model Extents grip to turn off model extents for height
mode.

If you use model extents, the default for the lower elevation is 1
foot below the XY plane.

4 Select the Lower Extension grip.
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Viewing Elevation Grips in 3D View

5 Move the grip until the lower extension value you want is
displayed, and click once; or enter a value.

6 Right-click, and click Deselect All to turn off grips.

To update an elevation created from this elevation line, see Updating a 2D or
3D Elevation on page 3364.

Changing the Length of an Elevation Using Grips
Use this procedure to change the length of any elevation boundary connected
to the elevation line. You can change the length of the elevation as a whole,
or you can change the length of the sides of the elevation boundary
individually.

You can change the length of the elevation boundary before or after you create
a connected elevation. If you change the length after creating the elevation,
you need to update the elevation to show the changes.

You can also define the depth of an elevation (its length) by changing the
length of the sides of an elevation boundary on the Properties palette.

1 Select the elevation line you want to change.

2 Select the Length grip.

Changing the Length of an Elevation Using Grips | 3335



View Elevation Grips in Plan View

3 Move the grip until the length value you want is displayed, and
click once.

The entire elevation boundary length is updated.

4 To change the length of side 1 of the elevation boundary, click
the Side 1 Endpoint grip.

Side 1 starts from the first point specified for the elevation line.

5 Move the grip to the desired location, and click once; or enter a
value on the command line, and press ENTER.

6 To change the length of side 2 of the elevation boundary, click
the Side 2 Endpoint grip.

Side 2 starts from the endpoint of the elevation line.

7 Move the grip to the desired location, and click once; or enter a
value on the command line, and press ENTER.

8 Right-click, and click Deselect All to turn off grips.

To update an elevation created from this elevation line, see Updating a 2D or
3D Elevation on page 3364.

Changing the Angle Dimensions of an Elevation
Use this procedure to change the angle of the sides of the building elevation
boundary. You can change the angle dimensions before or after you create a
connected elevation. If you change the angles after creating the elevation,
you need to update the elevation to show the changes.

1 Double-click the elevation line you want to change.
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2 On the Properties palette, expand Basic, and expand Component
Dimensions.

3 Specify values for Angle 1 and Angle 2.

These values define the angles of the two sides from the elevation
line to create the elevation box. The apex of Angle 1 is the start
point of the elevation line. The apex of Angle 2 is the endpoint
of the elevation line. Values for these angles must be between 0
and 90 degrees.

Specifying section angle parameters

4 Right-click, and click Deselect All to turn off grips.

To update an elevation created from this elevation line, see Updating a 2D or
3D Elevation on page 3364.

Creating Graphic Subdivisions for 2D and 3D Elevations
Use this procedure to define subdivisions that are created within the elevation
when you generate it. Each subdivision is specified as a distance from elevation
line.

You can view the location of a subdivision by viewing the elevation line with
its boundary in an isometric view. In this view, you can use grips to relocate
a subdivision.
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An elevation line with graphic subdivisions

You can control the lineweight and other display properties of the subdivisions
to add different levels of depth to elevation.

1 Double-click the elevation line you want to change.

2 On the Properties palette, expand Basic, and expand Dimensions.

3 Click the setting for Subdivisions, and then add or modify
subdivisions:

Then…If you want to…

click  . To change the default
distance from the elevation line,

create a subdivision

select the subdivision, click the
value, and enter a new value.

select the subdivision, click its value,
and enter a new value.

change the length of a subdivision

select the subdivision, and click 
.

delete a subdivision

4 Click OK.
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Changing Elevation Mark Attributes
Use this procedure to change the information displayed in the elevation mark.
The elevation mark is a multi-view block.

1 Double-click the elevation mark you want to change.

2 On the Properties palette, expand Advanced.

3 Click Attributes.

4 Select the existing attribute under Value, and enter the new
information to include in the bubble.

5 Click OK.

Changing the Location of an Elevation Line
Use this procedure to relocate an elevation line by changing the coordinate
values of its insertion point. The elevation line also has an orientation with
respect to the WCS or the current UCS. For example, if the top and bottom
of the elevation line are parallel to the XY plane, its normal is parallel to the
Z axis. You can change the orientation of the elevation line by aligning its
normal with another axis. You can also rotate the elevation line on its plane
by changing the rotation angle.

For information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use World and User Coordinate Systems in 3D”
in AutoCAD Help.

TIP The quickest way to locate and view an AutoCAD topic referenced in AutoCAD
Architecture Help is to click the Search tab in the Help window, select the Search
titles only option, and then copy and paste or type in the AutoCAD topic name,
and click List Topics.

1 Double-click the elevation line you want to relocate.

2 On the Properties palette, expand Basic, and expand Location.

3 Click Additional Information.

4 Specify the location of the elevation line:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the elevation line
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Then…If you want to…

make the normal of the elevation
line parallel to the Z axis: under

locate the elevation line on the XY
plane

Normal, enter 1 for Z, and enter 0
for X and Y.

make the normal of the elevation
line parallel to the X axis: under

locate the elevation line on the YZ
plane

Normal, enter 1 for X, and enter 0
for Y and Z.

make the normal of the elevation
line parallel to the Y axis: under

locate the elevation line on the XZ
plane

Normal, enter 1 for Y, and enter 0
for X and Z.

enter a new value for Rotation
Angle.

change the rotation of the elevation
line

5 Click OK.

To update an existing elevation created from this elevation line, see Updating
a 2D or 3D Elevation on page 3364.

Modifying an Elevation Line Using Grips
Use this procedure to change the start point, end point, or edge of an elevation
line. You can drag the grip to the desired location, or you can enter a specific
value for the measurement.

1 Select the elevation line you want to change.

2 Select an elevation line grip and move it to the desired location.

You can also move the grip in the desired direction and enter a
specific value on the command line.
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View Elevation Grips in Plan View

3 Right-click, and click Deselect All to turn off grips.

Attaching Hyperlinks, Notes and Files to an Elevation Line
Use this procedure to add hyperlinks, enter notes and attach reference files
to an elevation line. You can also edit notes and edit or detach reference files
from an elevation line.

1 Double-click the elevation line you want to attach notes or files
to.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

For more information, see “Add Hyperlinks to a Drawing” in
AutoCAD Help.

4 To add a note, click  next to Notes, enter text, and click OK.

5 Click  next to Reference documents, and then attach, detach,
or edit a reference file:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file
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Then…If you want to…

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

6 Click OK.

Creating a 2D or 3D Elevation
Use this procedure to create a 2D or 3D elevation. After you draw an elevation
line, you extract an elevation from the elevation line and the objects you
select in the building model.

When you create a 2D elevation, the object that is created is a
2D Section/Elevation object. Both 2D sections and elevations share the same
object type and style.

TIP Before you create an elevation, thaw and turn on all layers of objects in the
building model that you want to include in the elevation. Objects on layers that
are off or frozen cannot be part of the selection set for the elevation. To speed
performance, turn off the layers of the objects that you do not need to include in
the elevation.

1 Draw an elevation line in the drawing.

For more information, see Drawing an Elevation Line and Mark
on page 3331.

2 Select the elevation line.

3 Click Building Elevation Line tab ➤ Modify panel ➤ Generate

Elevation  .

4 Select the type of elevation object you want to create:

Then…If you want to create…

select 2D Section/Elevation Object
with Hidden Line Removal.

a 2D elevation

select 3D Section/Elevation Object.a 3D elevation
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5 For Style to Generate, select a style for a 2D elevation.

If you want to use a particular style, select it from Style to
Generate. Otherwise, use the Standard style. For more information,
see 2D Elevation Styles on page 3369.

3D elevations do not use styles.

6 Under Selection Set, click  (Select Objects), select the objects
that you want to include in the elevation, and press ENTER.

NOTE If you select an object that you do not want to include in the
elevation, press and hold SHIFT and select the object again to remove
it from the selection set.

7 Under Display Set, select a display set for the elevation object.

The display set controls the representation of the elevation.

8 Under Placement, select New Object, and specify where to place
the elevation:

Then…If you want to…

click  (Pick Point), and specify
the location for the new elevation
object in the drawing.

specify a location graphically

enter X, Y, and Z coordinates for
the location of the new elevation
object.

specify the coordinates of the inser-
tion point for the elevation

9 Click OK.

A 2D or 3D elevation is created from the elevation line properties
and the selected objects in the building model. The elevation is
linked to the building model. If you make changes to the building
model after you create the elevation, you can update the elevation
to reflect the changes. For more information, see Updating a 2D
or 3D Elevation on page 3364.

You can edit certain characteristics of the elevation to control its placement
and appearance. For more information, see Editing a 2D or 3D Elevation on
page 3346.

You can also use a 2D section/elevation style to control the display of selected
objects in a 2D elevation, and you can control the display of individual lines
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in a 2D elevation. For more information, see 2D Elevation Styles on page 3369
and Editing and Merging Linework in a 2D Elevation on page 3361.

Creating a Horizontal 2D Elevation
Use this procedure to create a horizontal section or elevation of a plan view.

The Hidden Line control available in AutoCAD Architecture makes it possible
to create horizontal sections and elevations of Plan views. With a horizontal
section or elevation, you can look “down” on the model. Previously, users
could achieve that effect only by manually changing the UCS. Now, a tool
enables you to create a horizontal section or elevation. This feature could be
useful for creating a detailed display of sill components in tapered walls.

The illustration below displays a horizontal section line for an irregularly
shaped building.

Horizontal elevation line

The illustration below displays the view results. Note the sill displays of the
tapered walls and the correct representation of the sloped curtain walls.
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1 Click Home tab ➤ Section & Elevation panel ➤ Horizontal Section

 .

NOTE Alternatively, on the default tool palette set, click the Design
tab, and then click the Horizontal Section tool. If necessary, scroll the
palette to display the tool that you need.

2 Specify the first point of the elevation plane.

3 Specify the second corner of the elevation plane.

4 Specify the elevation of the plane, and press ENTER.

5 Specify the depth of the elevation, and press ENTER.

6 Proceed with creating the elevation, as described in Creating a
2D or 3D Elevation on page 3342.
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Editing a 2D or 3D Elevation
After you create an elevation, you can edit the elevation line and the elevation
object to refine the appearance of the elevation in any of the following ways:

■ Edit the elevation line to add, remove, or modify graphic subdivisions.

■ Display a different area of the building model by reversing the elevation.

■ Place the elevation in a different location in the drawing.

■ Add notes or reference files to the elevation.

■ Select a different style for 2D elevations. An elevation style determines
how the linework in a 2D elevation is displayed.

■ Edit a 2D elevation object to change the display properties of selected
linework or to add linework and details that are not part of the building
model.

In addition, you can continue to modify the building model, updating the
elevation later to incorporate the changes.

For information about switching from a view other than an elevation to a
temporary elevation view to edit objects, see Editing Objects in a Temporary
Elevation View on page 1137.

Using Grips to Edit Linework in a 2D Elevation
Use this procedure to edit linework in a 2D elevation. You can assign selected
linework to fixed display components that determine the display of every
elevation that you generate, or you can assign linework to display components
that you have defined. After you assign linework to display components, you
can change the display properties (visibility, color, layer, lineweight, linetype,
and linetype scale) to change the display of lines.

For information about adding custom display components, see Adding a
Display Component to a 2D Elevation Style on page 3373.

1 Select the elevation.
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2 Select the Edit Linework grip.

The Edit In Place tab opens.

3 Click Edit In Place tab ➤ Profile panel ➤ Zoom To  to zoom to
the elevation.

4 Select the linework to edit.

5 Click Edit In Place tab ➤ Profile panel ➤ Modify Component
.

6 Select the component you want to put the lines on. For example,
if you want to make the lines invisible, select Erased Vectors for
Linework Component.

You can also click  (Match existing linework), and select
linework in the elevation whose display component you want to
match.

7 Click OK.

8 To finish the linework editing process, click Edit In Place

tab ➤ Edits panel ➤ Finish  to save all changes, or click Edit In

Place tab ➤ Edits panel ➤ Cancel  to discard them and exit the
edit-in-place session.

Using Grips to Edit Linework in a 2D Elevation  | 3347



Changing the Display of Graphic Subdivisions in a 2D Elevation
Use this procedure to change the display of subdivisions in a 2D elevation by
changing its display properties.

You create subdivisions by adding them to the elevation line. You can then
change their length using grips or by editing the values in the elevation line
properties. For more information, see Creating Graphic Subdivisions for 2D
and 3D Elevations on page 3337.

Each subdivision in a 2D elevation is assigned to a numbered subdivision
display component in the display properties of the elevation or the 2D
elevation style. You can control the visibility, layer, color, linetype, lineweight,
and linetype scale of each subdivision by changing the display properties of
each component. You can apply these changes to the selected elevation, to
the current 2D section/elevation style, or to all 2D sections and elevations in
the drawing that do not have a style override.

You can use the display properties of a subdivision together with the display
properties of a material. For more information, see Use Subdivision Properties
and Materials in 2D Elevation Styles on page 3378.

1 Select the 2D elevation in the drawing, right-click, and click Edit
Object Display.

2 Click the Display Properties tab.

3 Select the property source to edit:

Then…If you want to edit graphic
subdivisions…

select Drawing Default.for all 2D sections and elevations in
the current drawing (except those
that have a 2D Section/Elevation
Style override)

select 2D Section/Elevation Style,
and click Object Override.

for all 2D sections and elevations
that use the current style

Select 2D Section/Elevation, and
click Object Override.

for the selected 2D elevation

4 If necessary, click  .

5 Click the Layer/Color/Linetype tab to list all the components that
contribute to the display of the object.
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6 Turn the visibility on or off, and change the layer, color, linetype,
lineweight, or linetype scale as needed for each subdivision
component.

7 Click the Other tab to add a custom display component to the
display of the 2D elevation.

For more information about adding custom display components,
see Adding a Display Component to a 2D Elevation Style on page
3373.

8 Click OK twice.

Changing the Display of Graphic Subdivisions in a 3D Elevation
Use this procedure to change the display of subdivisions in a 3D elevation by
changing its display properties.

You create the subdivisions by adding them to the elevation line. You can
then change their length using grips or by editing the values in the elevation
line properties. For more information, see Creating Graphic Subdivisions for
2D and 3D Elevations on page 3337.

Each subdivision in a 3D elevation is assigned to a numbered subdivision
display component in the display properties of the elevation. You can control
the visibility, layer, color, linetype, lineweight, and linetype scale of each
subdivision by changing the display properties of each component. You can
apply these changes to the selected 3D elevation or to all 3D elevations in the
drawing.

1 Select the 3D elevation in the drawing, right-click, and click Edit
Object Display.

2 Click the Display Properties tab.

3 Select the Subdivisions display representation.

4 Select the property source to edit:

Then…If you want to edit graphic
subdivisions…

select Drawing Default.for all 3D elevations in the current
drawing

select Bldg Section, and click Object
Override.

for the selected 3D elevation
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5 If necessary, click  .

6 Click the Layer/Color/Linetype tab to list all the components that
contribute to the display of the object.

The defining line represents the cutting plane of the elevation
line. The numbered subdivision components correspond to
subdivisions added to the elevation line. For example, the display
component Subdivision 1 corresponds to the subdivision closest
to, but not on, the cutting plane of the elevation line.

7 Turn the visibility on or off, and change the layer, color, linetype,
lineweight, or lineweight scale as needed for each subdivision
component.

8 Click OK twice.

Reversing a 2D or 3D Elevation
Use this procedure to reverse the direction of an elevation by reversing the
elevation line and updating the elevation.

The direction of the elevation is determined by the direction in which you
drew the elevation line. You can select the elevation line in plan view to see
the bounding box that defines the area of the model included in the elevation.
If the box does not include the area of the model that you intended, you can
reverse the elevation line. If you have already created an elevation from the
elevation line, update the elevation after reversing the elevation line.

1 Select the elevation line that you used to create the elevation.

2 Click Building Elevation Line tab ➤ Modify panel ➤ Reverse
.

The elevation line is mirrored about its own axis, as is the
bounding box with its original parameters.

3 Select the existing elevation.

4 Click 2D or 3D Section/Elevation tab ➤ Modify panel ➤ Regenerate

 .

NOTE For a 2D elevation, if you do not need to respecify the objects
to include in the elevation, you can click 2D Section/Elevation

tab ➤ Modify panel ➤ Refresh  instead of Regenerate. This
immediately updates the elevation.
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5 If you need to include different objects in the updated elevation,

click  (Reselect Objects), select the objects, and press ENTER.

6 Click OK.

Changing the Style of a 2D Elevation
Use this procedure to select a different style for a 2D elevation. A 2D
section/elevation style controls the appearance of any 2D elevation object to
which the style is applied.

1 Double-click the elevation you want to change.

2 On the Properties palette, expand Basic, and expand General.

3 Select a new style for the elevation.

Adding and Removing Custom Components for an Elevation
Use this procedure to add or remove custom display components for an
elevation.

1 Double-click the elevation.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all elevations in the drawing, select
Drawing default setting. To apply changes to all elevations of this
style, select Elevation Style:<style name>. For more information on
styles, see 2D Elevation Styles on page 3369.

5 If necessary, expand Object Display Properties ➤ Advanced.
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6 Click  Additional Properties.

7 Add or remove components or edit component names:

Then…If you want to…

click Add, double-click the Un-
named entry, and enter a name for
the new component.

add a new component

select the component, and click
Remove.

remove an existing component

double-click the component name,
and edit it as needed.

edit the name of an existing com-
ponent

8 When you are finished working with the Custom Display
Components list, click OK. To specify display properties for a
component you have added, click the value (*NONE*) for Display
component, select the component, and then adjust the default
settings under Component Display Properties as needed.

You can also access and modify these same additional settings through the
elevation’s context menu, as follows:

1 Select the elevation, right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

3 Select the display representation where you want the changes to
appear, and select Object Override.

The display representation in bold is the current display
representation.
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4 If necessary, click  .

5 In the Display Properties dialog, click the Other tab, and then
change the settings as needed.

6 To specify display properties for any component you add, click
the Layer/Color/Linetype tab, select the component, and change
the column values as needed.

7 Click OK twice.

Specifying the Display of Surface Hatching for an Elevation
Subdivision

Use this procedure to specify whether the surface hatching for an elevation
subdivision is determined by the display properties of the subdivision
component or those of the Surface Hatch Linework component.

1 Double-click the elevation.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all elevations in the drawing, select
Drawing default setting. To apply changes to all elevations of this
style, select Elevation Style:<style name>. For more information on
styles, see 2D Elevation Styles on page 3369.

5 If necessary, expand Object Display Properties ➤ Advanced.
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6 Click  Additional properties.

7 Specify which properties to use for surface hatching:

Then…If you want to use the display
properties of…

select Use Subdivision properties for
surface hatching.

the subdivision component

clear Use Subdivision properties for
surface hatching.

the Surface Hatching Linework
component

8 Click OK.

9 If you cleared the Use Subdivision properties for surface hatching
option, the display is now controlled by the By material property
of the Surface Hatching Linework component. To change this
setting, click the value (*NONE*) for Display component, select
the Surface Hatching Linework component, and then select a
different value for By material.

You can also access the Use Subdivision properties for surface hatching option
through the elevation’s context menu, as follows:

1 Select the elevation, right-click, and click Edit Object Display.

2 In the Object Display dialog, click the Display Properties tab.

3 For the General display representation, select Object Override.

4 If necessary, click  .

5 In the Display Properties dialog, click the Other tab, and then
select or deselect this option as desired.
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6 Click OK twice.

Specifying the Display of 2D Linework for an Elevation
Use this procedure to specify whether to use the 3D Body display component
of a material for the linework in a 2D elevation.

1 Double-click the elevation.

2 On the Properties palette, click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all elevations in the drawing, select
Drawing default setting. To apply changes to all elevations of this
style, select Elevation Style:<style name>. For more information on
styles, see 2D Elevation Styles on page 3369.

5 If necessary, expand Object Display Properties ➤ Advanced.

6 Click  Additional properties.

7 Select or deselect Use 3D Body display component for By Material
linework.

8 Click OK.

You can also access this option through the elevation’s context menu, as
follows:

1 Select the elevation, right-click, and click Edit Object Display.
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2 In the Object Display dialog, click the Display Properties tab.

3 For the General display representation, select Object Override.

4 If necessary, click  .

5 In the Display Properties dialog, click the Other tab, and then
select or deselect this option as desired.

6 Click OK twice.

Creating a Material Boundary in a 2D Elevation
Use this procedure to create a material boundary in a 2D elevation.

1 Draw a polyline around the area in the elevation that you want
to mask or to highlight.

2 Select the elevation.

3 Click 2D Section/Elevation tab ➤ Material Boundary panel ➤ Add

 .

4 Select the polyline.

5 Enter y (Yes) to erase the polyline, or n (No) to keep the polyline
in the drawing.

6 Specify the settings of the material boundary:

Then…If you want to…

select Limit for Purpose.highlight the area inside the poly-
line

select Erase for Purpose.mask (erase) the area inside the
polyline

select the appropriate parts for Ap-
ply to. You can choose Surface

apply the highlight or mask only to
specific parts of the elevation

Hatch, Edge Linework, and All
Linework.

select All Materials for Material Se-
lection.

apply the material boundary to all
materials used in the elevation

select Specific Materials for Material
Selection and then select the appro-
priate materials in the list below.

apply the material boundary only
to selected materials
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7 Click OK.

Editing a Material Boundary
You can edit existing material boundaries in two ways:

■ Change the content within the material boundary. For example, you can
determine of you want to see only brick hatching, or both brick and glass
hatching.

■ Change the shape of the material boundary. For example, you can make
the boundary bigger or smaller, or add additional rings and vertex points
to it.

Editing the Content of a Material Boundary
Use this procedure to change the content of a material boundary. The content
includes such settings as materials displayed, hatch types, and boundary type.

1 Select a 2D elevation.

2 Click 2D Section/Elevation tab ➤ Material Boundary panel ➤ Edit

In Place  .

The material boundary is highlighted and edit-in-place grips are
displayed.

3 Click Edit In Place tab ➤ Profile panel ➤ Edit Material Boundary

 .

4 Specify the content of the material boundary:

Then…If you want to…

select Limit for Purpose.highlight the area inside the
boundary

select Erase for Purpose.mask (erase) the area inside the
boundary

select the appropriate parts for Ap-
ply to. You can choose Surface

apply the highlight or mask only to
specific parts of the elevation

Hatch, Edge Linework, and All
Linework.
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Then…If you want to…

select All Materials for Material Se-
lection.

apply the material boundary to all
materials used in the elevation

select Specific Materials for Material
Selection, and then select the appro-
priate materials from the list below.

apply the material boundary only
to selected materials

5 Click OK.

6 Click Edit In Place tab ➤ Edits panel ➤ Finish  to save the
changes you made, or click Edit In Place tab ➤ Edits

panel ➤ Cancel  to undo them.

Adding a Vertex to a Material Boundary
Use this procedure to add a vertex to a material boundary.

1 Select the elevation to which the material boundary has been
assigned.

2 Click 2D Section/Elevation tab ➤ Material Boundary panel ➤ Edit

In Place  .

The material boundary is highlighted and edit-in-place grips are
displayed.

3 Right-click, and click Add Vertex.

4 Specify the point at which to add a vertex.

5 Specify additional vertex points.

6 Press ENTER.

7 Select the material boundary again, right-click, and click Save
Changes to save the changes you made, or click Discard All
Changes to undo the changes to the material boundary.

Removing a Vertex from a Material Boundary
Use this procedure to remove a vertex from a material boundary.

1 Select the elevation to which the material boundary has been
assigned.
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2 Click 2D Section/Elevation tab ➤ Material Boundary panel ➤ Edit

In Place  .

The material boundary is highlighted and edit-in-place grips are
displayed.

3 Right-click, and click Remove Vertex.

4 Specify the vertex points to remove.

5 Remove additional vertex points as needed.

6 Press ENTER.

7 Select the material boundary again, right-click, and click Save
Changes to save the changes you made, or click Discard All
Changes to undo the changes to the material boundary.

Adding a Ring to a Material Boundary
Use this procedure to add a ring to a material boundary.

A material boundary can consist of more than one closed polyline. For example,
you could use one polyline to highlight a wall detail, and another polyline to
highlight a window detail in another location.

1 Draw a polyline for the new material boundary ring.

2 Select a 2D elevation.

3 Click 2D Section/Elevation tab ➤ Material Boundary panel ➤ Edit

In Place  .

The material boundary is highlighted and edit-in-place grips are
displayed.

4 Click Edit In Place tab ➤ Profile panel ➤ Edit Material Boundary

 .

5 Click Edit In Place tab ➤ Profile panel ➤ Add Ring  .

6 Select the polyline you drew in step 1.

7 Enter y (Yes) to erase the polyline, or n (No) to keep the polyline
in the drawing.

8 Click Edit In Place tab ➤ Edits panel ➤ Finish  to save the
changes you made, or click Edit In Place tab ➤ Edits

panel ➤ Cancel  to undo the changes to the material boundary.
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Removing a Ring from a Material Boundary
Use this procedure to remove a ring from a material boundary.

A material boundary can consist of more than one closed ring. You can
individually remove each ring.

NOTE You cannot remove the last ring from a material boundary.

1 Select a 2D elevation.

2 Click 2D Section/Elevation tab ➤ Material Boundary panel ➤ Edit

In Place  .

The material boundary is highlighted and edit-in-place grips are
displayed.

3 Click Edit In Place tab ➤ Profile panel ➤ Edit Material Boundary

 .

4 Click Edit In Place tab ➤ Profile panel ➤ Remove Ring  .

5 Select the ring you want to remove.

6 Click Edit In Place tab ➤ Edits panel ➤ Finish  to save the
changes you made, or click Edit In Place tab ➤ Edits

panel ➤ Cancel  to undo the changes to the material boundary.

Replacing a Ring from a Material Boundary with Another
Use this procedure to replace a ring from a material boundary with a different
ring.

1 Draw the polyline to replace one of the existing material boundary
rings.

2 Select a 2D elevation.

3 Click 2D Section/Elevation tab ➤ Material Boundary panel ➤ Edit

In Place  .

The material boundary is highlighted and edit-in-place grips are
displayed.

4 Click Edit In Place tab ➤ Profile panel ➤ Edit Material Boundary

 .
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5 Click Edit In Place tab ➤ Profile panel ➤ Replace Ring  .

6 Select the ring to be replaced with another ring.

7 Select the closed polyline you drew in step 1.

8 Enter y (Yes) to erase the polyline, or n (No) to keep the polyline
in the drawing.

9 Click Edit In Place tab ➤ Edits panel ➤ Finish  to save the
changes you made, or click Edit In Place tab ➤ Edits

panel ➤ Cancel  to undo the changes to the material boundary.

Editing and Merging Linework in a 2D Elevation
After you create a 2D elevation, you can edit the display of individual lines
that make up the elevation. For example, you may want to assign linework
for small details to a display component with a lighter lineweight, so that the
details are not obscured when plotted.

You can also merge existing geometry into the elevation.

Editing Linework in a 2D Elevation
Use this procedure to edit linework in a 2D elevation. You can also edit
individual lines in a 2D elevation by assigning them to display components
in the elevation. For information about the Edit Linework grip, see Using Grips
to Edit Linework in a 2D Elevation on page 3346.

You can assign selected linework to fixed display components that determine
the display of every elevation that you generate, or you can assign linework
to display components that you have defined. For information about adding
custom display components, see Adding a Display Component to a 2D
Elevation Style on page 3373. After you assign linework to display components,
you can change the display properties (visibility, color, layer, lineweight,
linetype, and linetype scale) to change the display of lines.

1 Select the elevation to be changed.

2 Click 2D Section/Elevation tab ➤ Linework panel ➤ Edit  .

3 Select the lines that you want to assign to a display component

4 Click Edit In Place ➤ Linework tab ➤ Profile panel ➤ Modify

Component  .
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A list of available display components is displayed.

5 Select the component you want to put the lines on.

For example, if you want to make the lines invisible, select Erased
Vectors for Linework Component.

You can also click  (Match existing linework), and select
linework in the elevation whose display component you want to
match.

6 Click OK.

7 To finish the linework editing process, click Edit In Place

tab ➤ Edits panel ➤ Finish  to save the changes you made, or

click Edit In Place tab ➤ Edits panel ➤ Cancel  to undo your
linework changes.

Merging Linework into a 2D Elevation
Use this procedure to merge geometry into a 2D elevation. When you merge
linework into an elevation, you assign additional linework to a display
component of an elevation. Use this feature when you want to add detail, or
add linework that you did not model.

1 Draw the geometry that you want to merge into a 2D elevation.

2 Select the 2D elevation to be changed.

3 Click 2D Section/Elevation tab ➤ Linework panel ➤ Merge  .

4 Select the geometry to merge into the elevation, and press ENTER.

5 Select the display component to which you want to assign the
linework.

You can also click  (Match existing linework) and select
linework in the elevation whose display component you want to
match.

6 Click OK.

The linework is merged into the 2D elevation. When you select
the elevation, the linework is selected with it.
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Changing the Location of a 2D or 3D Elevation
You can relocate an elevation by changing the coordinate values of its insertion
point. The elevation also has an orientation with respect to the WCS or the
current UCS. For example, if the top and bottom of the elevation are parallel
to the XY plane, its normal is parallel to the Z axis. You can change the
orientation of the elevation by aligning its normal with another axis. You can
also rotate the elevation on its plane by changing the rotation angle.

For information about the world coordinate system (WCS) and the user
coordinate system (UCS), see “Use World and User Coordinate Systems in 3D”
in AutoCAD Help.

1 Double-click the elevation you want to move.

2 On the Properties palette, expand Basic, and expand Location.

3 Click  Additional Information.

4 Specify a new location or rotation:

Then…If you want to…

enter new coordinate values under
Insertion Point.

relocate the elevation

make the normal of the elevation
parallel to the Z axis: under Normal,

locate the elevation on the XY plane

enter 1 for Z, and enter 0 for X
and Y.

make the normal of the elevation
parallel to the X axis: under Normal,

locate the elevation on the YZ plane

enter 1 for X, and enter 0 for Y
and Z.

make the normal of the elevation
parallel to the Y axis: under Normal,

locate the elevation on the XZ plane

enter 1 for Y, and enter 0 for X
and Z.

enter a new value for Rotation
Angle.

change the rotation of the elevation

5 Click OK.
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Attaching Hyperlinks, Notes, and Files to a 2D or 3D Elevation
Use this procedure to add hyperlinks, enter notes, and attach reference files
to a 2D or 3D elevation. You can also edit notes and edit or detach reference
files from a 2D or 3D elevation.

1 Double-click the 2D or 3D elevation you want to attach notes or
files to.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

For more information, see “Add Hyperlinks to a Drawing” in
AutoCAD Help.

4 To add a note, click  next to Notes, enter text, and click OK.

5 Click  next to Reference documents, and then attach, detach,
or edit a reference file:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

6 Click OK.

Updating a 2D or 3D Elevation
Use this procedure to regenerate a 2D or 3D elevation to reflect changes you
have made to the building model or to elevation line properties. For 2D
elevations, you also update the elevation to show changes made to the 2D
elevation style. You can update a 2D or 3D elevation if you have not exploded
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the elevation, which destroys the link between the elevation and the building
model.

When you update an elevation, you can add or remove objects from the
elevation, change the location of the elevation in the drawing, and change
the display set of the elevation.

If you do not need to change the elevation definition in any way, you can
skip the following procedure. Instead, click 2D Section/Elevation tab ➤ Modify

panel ➤ Refresh  .

1 Select the elevation you want to update.

2 Click 2D or 3D Section/Elevation tab ➤ Modify panel ➤ Regenerate

 .

3 Select a result type:

Then…If the elevation is…

select 2D Section/Elevation Object
with Hidden Line Removal.

a 2D elevation object

select 3D Section/Elevation Object.a 3D elevation object

4 To change the style of a 2D elevation, select a new style for Style
to Generate.

5 If you edited linework in the 2D elevation, select a style in which
to save the changes you made that cannot be reapplied.

Select a style that distinguishes the unapplied changes in the
elevation.

6 Under Selection Set, specify the objects that you want to include
in the elevation:

Then…If you want to…

proceed to the next step.use the objects in the selection set
you specified when you created the
elevation or when you previously
updated it

click Select Additional Objects, se-
lect the new objects in the drawing,
and press ENTER.

add new objects to the selection set
that you specified when you created
the original elevation
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Then…If you want to…

click Reselect Objects, select a new
selection set of objects for the elev-
ation, and press ENTER.

select a new selection set of objects
for the elevation

NOTE If you select an object that you do not want to include in the
elevation, press and hold SHIFT and select the object again to remove
it from the selection set.

7 Under Display Set, select a display set for the elevation.

8 Under Placement, locate the elevation in the drawing:

Then…If you want to…

select New Object, and either click

 to specify an insertion point

create a new elevation object
without overwriting the original
object

in the drawing area, or enter X, Y,
and Z coordinates for the new elev-
ation.

select Replace Existing.replace the original elevation with
the updated elevation

9 Click OK.

Globally Updating 2D Elevations
AutoCAD Architecture makes it possible for you to globally update all sections
and elevations within a project or a specified folder.

Updating Sections and Elevations in a Project

AutoCAD Architecture includes the Drawing Management feature that allows
users to combine their floor plans, section and elevation views, construction
sheets, and reusable components in one building project. A project consists
of a number of drawings linked together with a powerful external referencing
mechanism. AutoCAD Architecture enables you to open a project and update
all 2D sections and elevations included in that project in one comfortable
workflow. For information on which project file types can be updated, see
Supported Project Drawing Types on page 3367.
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Updating Sections and Elevations in a Specific Folder

When you are working without a project, you can also globally update sections
and elevations by specifying a folder and updating all sections and elevations
in that folder. When you select a specific folder for updating, you can also
include its subfolders in the update.

Section of a building project

For more information about building projects, see Drawing Management on
page 303.

Supported Project Drawing Types
When you are updating a project, you can globally update all 2D sections and
elevations within the views and sheets of the project. You cannot globally
update elements and constructs, because these project drawings usually contain
reusable elements and individual parts of the building project. They normally
do not contain sections or elevations.

For more information about project drawing types, see Views on page 446 and
Sheets on page 481.

NOTE When you globally update the sections and elevations in a project drawing,
all model and paper space layouts are updated.

When you are updating a specified folder within a project, or a folder outside
of a project, all sections and elevations in that folder are updated regardless
of their type. For example, if you choose to update a specific folder within the
Constructs category of a project, the sections and elevations in that folder will
be updated, even though they are Construct drawings. If you do not specify
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a folder, but choose to update the whole project, these construct drawings are
not updated.

Globally Updating 2D Sections and Elevations in a Project or a
Folder

Use this procedure to globally update all 2D sections and elevations in a project
or a specified folder.

NOTE To update all 2D sections and elevations in a project, the project must be
defined as current. If no project is current, you receive an error message if you try
to globally update 2D sections and elevations. For information on setting a project
current, see Setting a Project Current on page 327.

1 Click Home tab ➤ Section & Elevation panel ➤  ➤ Batch

Refresh  .

2 Select if you want to update the 2D sections and elevations in the
current project, or only the 2D sections and elevations in a specific
folder.

Then...If you want to...

select Current Project.update the 2D sections and el-
evations in the current project

select Folder. Then click the Browse

button  , select the folder con-

update the 2D sections and el-
evations in a specific folder

taining the files you want to update,
and click OK.

3 If you have specified a folder, you can specify whether the
subfolders of that folder should be updated as well. To update the
subfolders, select Process subfolders.

NOTE When you are working with a large building project, updating
all sections and elevations can be a time-consuming process. In this
case, you might consider updating only a selected subfolder of your
project and thereby improve system performance.

4 Click Start.
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Globally updating all sections and elevations may take a while.
A status window lets you know which drawing is currently being
updated.

When you start the global update, the Stop button is available. If
you want to interrupt the global update, click Stop. When the
global update is finished, the Start button is available.

Updating Legacy Drawings
During the global update of 2D sections and elevations, each drawing in the
project or specified folder is opened, updated, and saved again. If you are
updating drawings from an earlier version of the software, the drawings are
converted to the current version. Before you convert the drawings, a warning
message notifies you of the conversion. To update the drawings to the new
version, click OK. To cancel the update of all sections and elevations, press
CTRL+BREAK.

Update Exceptions

There are a number of cases in which a 2D section or elevation cannot be
updated with the global update.

■ The drawing containing the 2D section or elevation is read-only.

■ The 2D section or elevation is placed on a locked layer.

■ There have been user edits to a 2D section or elevation that could not be
reapplied to the 2D section or elevation.

When a 2D section or elevation cannot be updated, an error message is
displayed in the status window.

To fix the problem, you can set the drawing to read/write instead of read-only,
you can unlock the section layer, or you can undo a specific user edit to a 2D
section or elevation.

2D Elevation Styles
A 2D section/elevation style is a group of properties assigned to a 2D elevation
that determines the appearance and other characteristics of that object.
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Using 2D Elevation Styles

A 2D section/elevation style controls the linework in an elevation, using design
rules that determine how different parts of the elevation are displayed. You
can apply the style to one or more elevations to control their appearance. You
can also change the display of individual lines in the elevation, and save the
changes in a 2D section/elevation style.

Display Components and Design Rules

Display components determine the graphical characteristics, such as color
and linetype, of linework assigned to each display component. Design rules
determine how the linework in an elevation is assigned to display components.

When you create a design rule, you specify the part of the 2D elevation to
control based on the color of those objects in the building model and their
context in the elevation. You then select the display component to use for
linework that meets the criteria you specified. You can assign the linework to
a default display component or to a custom display component that you have
added to the style. For example, you might define a rule that assigns all objects
that are color 150 in the model and located along the elevation line to a
custom display component named Darker that you created in the style. Or
you might hide a staircase behind a wall using a rule that assigns all blue
linework to the Hidden display component.

Managing 2D Elevation Styles

To create, edit, copy, or purge styles, you access the Style Manager. The Style
Manager provides a central location in AutoCAD Architecture to work with
styles from multiple drawings and templates. For more information about
using the Style Manager, see Style Manager Overview on page 870.

Materials and 2D Elevation Styles

Two-dimensional elevation styles offer an easy way to assign materials to 2D
elevation objects. You can specify which section components should have its
display controlled by materials and which do not. Custom components cannot
have any material assignments.

Subdivisions in 2D Elevation Styles and Materials

When you are creating subdivisions in your style, you usually want the objects
in them to be visually distinct from other subdivisions. When you have
assigned materials to the objects, you can set the 2D elevation style so that it
uses the hatch pattern from the material, but the color and linetype from the
subdivision display properties.
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Elevation subdivisions with assigned surface hatching

Creating a 2D Elevation Style
Use this procedure to create a 2D elevation style. You can create a style using
default style properties or by copying an existing style. After you create the
style, you edit the style properties to customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand 2D Section/Elevation
Styles.

3 Create a new 2D elevation style:

Then…If you want to create a style…

right-click 2D Section/Elevation
Styles, and click New.

using default properties

right-click the 2D elevation style
you want to copy, and click Copy.
Right-click, and click Paste.

style from an existing style

4 Enter a name for the new 2D elevation style, and press ENTER.
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5 Edit the 2D elevation style:

Then…If you want to…

see Adding a Display Component
to a 2D Elevation Style on page 3373.

add display components to the style

see Removing a Display Component
from a 2D Elevation Style on page
3373.

remove display components from
the style

see Use Subdivision Properties and
Materials in 2D Elevation Styles on
page 3378.

use the subdivision properties of the
elevation for the display

see Use the 3D Body Component
of a Material for the 2D Elevation
Linework on page 3379.

use the 3D Body component of the
material for the elevation linework

see Adding a Design Rule to a 2D
Elevation Style on page 3379.

add design rules to the style

see Changing a Design Rule in a 2D
Elevation Style on page 3381.

change design rules in the style

see Adding Classifications to a 2D
Elevation Style on page 3382.

add classifications to a style

see Changing the Layer, Color, and
Linetype of a 2D Elevation Style on
page 3383.

change the display properties of the
display components in the style

see Attaching Notes and Files to a
2D Elevation Style on page 3384.

add notes, files, or documents to
the style

6 Click OK.

You can click Apply instead of OK to save the changes and
continue working in the Style Manager.
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Adding a Display Component to a 2D Elevation Style
Use this procedure to add a custom display component to a 2D elevation style.
After you add a component, you assign linework in the elevation to the new
component. To apply these style changes to existing 2D elevations, you must
update the elevation.

2D elevations include the following default display components: Defining
Line, Hidden, Erased, Unknown, and Subdivision.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, expand 2D Section/Elevation
Styles, and select the style you want to change.

3 Click the Components tab.

4 Click Add.

5 Enter a name and a description for the new component.

To enter a name, click Unnamed and enter a new name. To enter
a description, click in the Description column next to the name,
and enter a description.

6 Click the Display Properties tab.

7 Select 2D Section/Elevation Style for the property source, and

click  .

8 Click the Layer/Color/Linetype tab.

9 Specify the display properties of the new component.

10 Click OK twice.

To create a design rule that uses the new display component, see
Adding a Design Rule to a 2D Elevation Style on page 3379. To
manually assign linework to the display component, see Editing
Linework in a 2D Elevation on page 3361.

Removing a Display Component from a 2D Elevation Style
Use this procedure to remove a custom display component from a 2D elevation
style. Removing a display component also removes any design rules that use
the component. You cannot remove the default display components.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .
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2 Expand Documentation Objects, expand 2D Section/Elevation
Styles, and select the style you want to change.

3 Click the Components tab.

4 Select the component that you want to remove, and click Remove.

If the component is used in a design rule, the associated design
rule is removed as well.

5 Click OK.

6 Update the elevation to apply the style changes to the elevation.

For more information, see Updating a 2D or 3D Elevation on page
3364.

About 2D and 3D Elevation Display Components and Materials
A 2D or 3D elevation object consists of a number of display components that
can be determined by materials. When you assign materials to an object, you
assign one material to each display component of the object. For example,
you assign a wood material to the frame of a window and a glass component
to the glass of a window.

When you create a 2D or 3D elevation object from building objects, the
material assignments of the source objects are applied to the elevation. You
do not assign a material directly to a 2D/3D elevation. The elevation takes its
material assignments from the objects. For example, if you create an elevation
of a wall with a window, the surface hatches you have defined in the glass,
wood, and brick materials of the wall and the window are displayed in the
elevation object.
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If you do not want to use the material display properties, but instead use those
of the 2D or 3D elevation object or the 2D elevation style, you can deactivate
the material assignments in the display properties of the elevation or the
elevation style.

Material definitions consist of display components that correspond to
component types of objects. For example, the Linework component of a
material is used for all linework of objects in Plan view. The Surface Hatch
component of a material is used to hatch all object surfaces in 3D model views
and elevations.

For a complete list of material components and their description, see Material
Components and Display Properties on page 898.

The following table lists elevation components plus information about the
material components that determine them.
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NOTE An elevation is technically the same object as a section, and has the same
display components as a section. The following topics describe the display
components most relevant to elevations. For a complete list of all section and
elevation components, see About 2D and 3D Section Display Components and
Materials on page 3306.

Material Component2D Elevation Component

Surface HatchSurface Hatch Linework

No MaterialHIdden

No MaterialErased

2D Section/Elevation Linework or 3D Body.
For information on switching between

Subdivision 1-10

these material components, see Use the
3D Body Component of a Material for the
2D Elevation Linework on page 3379.

Surface Hatch Linework in Elevations
The Surface Hatch Linework component draws all linework coming from
surface hatches of the objects in the elevation. This component is specific to
2D elevations.

NOTE Surface hatches you have assigned to objects display in a 3D elevation
object. However, you cannot set them separately in a 3D elevation; you can do
that only in a 2D elevation object.

The surface hatch linework component is controlled by the surface hatch
component of the material. For information about the surface hatch
component of the material, see Surface Hatch Material Component on page
900.
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2D elevation with building roof, wall, and foundation surface hatching

Hidden Component
The Hidden component contains all linework that is hidden in the 2D
projection because other components are in front of it. By default, this
component is turned off. You can use design rules to achieve special effects,
such as a see-through effect, using the Hidden component. The Hidden
component is specific to 2D elevations.

The Hidden component cannot be defined by a material component. You can
only set it in the display properties of the 2D elevation. For information on
setting the display properties of a 2D elevation, see Changing the Layer, Color,
and Linetype of a 2D Elevation Style on page 3383.

Erased Component
The Erased component contains linework in the elevation object that you do
not want to see. For example, if you have an elevation of a window front with
three windows, but you want to display only one (for a higher level of
abstraction), edit the linework of the elevation and assign the linework of the
remaining two windows to the Erased component. Because the Erased
component is turned off by default, the two windows do not display. For
information on linework editing of an elevation, see Creating a Hidden Line
Projection on page 3385.

The hidden component is specific to 2D elevations, and cannot be defined
by a material component.

Subdivision Components
The subdivision components partition an elevation object. They are useful to
create perspective effects, where parts closer to the viewer are drawn with
darker, stronger lines and parts farther from the user are drawn with lighter,
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thinner lines. Subdivisions can have no individual material assignments.
However the display properties of the subdivisions can be used for the surface
hatching of the subdivisions by selecting Use Subdivision Properties for Surface
Hatching in the Other tab of the 2D elevation display properties. For
information on using the subdivision display properties to display the elevation
divisions, see Use Subdivision Properties and Materials in 2D Elevation Styles
on page 3378.

Subdivisions are a display component of both 2D and 3D elevation objects.

The subdivision components are either controlled by the 2D Section/Elevation
Linework component of the material or by the 3D Body component of a
material. For information on how to switch between these component
assignments, see Use the 3D Body Component of a Material for the 2D
Elevation Linework on page 3379.

Use Subdivision Properties and Materials in 2D Elevation Styles
Use this procedure to use the display properties of materials together with the
display properties of elevation subdivisions.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, expand 2D Section/Elevation
Styles, and select the style you want to change.

3 Click the Display Properties tab.

4 Select 2D Section/Elevation Style for the property source, and
click Style Override.

5 If necessary, click  .

6 Click the Layer/Color/Linetype tab.

7 To set a subdivision to use the surface hatch of the material, while
using the layer, color, and linetype display properties of the
subdivision, clear By Material, and specify the layer, color and
linetype settings of the subdivision.

For example, the first subdivision could have a darker color and
stronger linetype than the second subdivision.

8 Click the Other tab.

9 Select Use Subdivison Properties for Surface Hatching.

10 Click OK twice.
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Use the 3D Body Component of a Material for the 2D Elevation
Linework

Use this procedure to use the 3D Body component of a material for the
linework in a 2D elevation.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, expand 2D Section/Elevation
Styles, and select the style you want to change.

3 Click the Display Properties tab.

4 Select 2D Section/Elevation Style for the property source, and
click Style Override.

5 If necessary, click  .

6 Click the Other tab.

7 Specify whether the 3D body component of the selected material
should control the display of the linework in the 2D elevation:

Then…If you want to control the dis-
play…

select Use 3D Body Display Com-
ponent for By Material Linework.

of the 2D elevation linework by the
3D Body component of the material

deselect Use 3D Body Display
Component for By Material Line-
work. This is the default behavior.

of the 2D elevation linework by the
2D Section/Elevation Linework
component of the material

8 Click OK twice.

Adding a Design Rule to a 2D Elevation Style
Use this procedure to add a design rule to a 2D elevation style. A design rule
has four fields of information that identify lines in the elevation and determine
how to display them:

DescriptionField

Identifies the color of the objects in the
building model presented by the lines in
the elevation

Color
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DescriptionField

Identifies the context of the lines in the el-
evation, such as in a graphic subdivision

Context

Identifies the display component to which
the lines are assigned

Component

Contains a description of the design ruleDescription

For example, a design rule has the color 50, a context of Within Subdivision
2, and a component of New. This rule assigns any lines in the elevation
representing objects that have the color 50 in the building model and that
are within subdivision 2 in the elevation to the user-defined display
component, New.

On the Design Rules tab, you can also specify that all hidden linework that is
not handled by a specific design rule will be assigned to the Hidden display
component. You could use this option if you want to generate an elevation
of an object or a set of objects and see all edges, for example, if you are creating
foundations and form work.

NOTE Alternatively, you can define which hidden linework should be displayed
by object material. For more information, see Controlling the Display of Hidden
Lines by Material on page 929.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, expand 2D Section/Elevation
Styles, and select the style you want to change.

3 Click the Design Rules tab, and click Add.

A new design rule is created with default color, context, and
component values.

4 Specify settings for the new design rule:

Then…If you want to…

click the default color, select a new
color, and click OK.

specify the color of objects in the
building model that are affected by
this rule

click the default context, and select
a new context.

specify the context in which the
linework for the objects appears in
the elevation
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Then…If you want to…

click the default component, and
select a new component.

select the display component for
the linework

click the Description field, enter a
description, and press ENTER.

enter a description of the rule

5 Click OK.

6 Update the elevation to apply the style changes to the elevation.

For more information, see Updating a 2D or 3D Elevation on page
3364.

Changing a Design Rule in a 2D Elevation Style
Use this procedure to change the settings in the fields that define a design
rule.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, expand 2D Section/Elevation
Styles, and select the style you want to change.

3 Click the Design Rules tab.

4 Specify settings for the design rule you want to change:

Then…If you want to…

click the current color, select a new
color, and click OK.

specify the color of objects in the
building model that are affected by
this rule

click the current context, and select
a new context.

specify the context in which the
linework for the objects appears in
the elevation

click the current component, and
select a new component.

select the display component for
the linework

click the description, edit the de-
scription, and press ENTER.

edit the description of the rule

5 Click OK.
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6 Update the elevation to apply the style changes to the elevation.

For more information, see Updating a 2D or 3D Elevation on page
3364.

Removing a Design Rule from a 2D Elevation Style
Use this procedure to remove a design rule from a 2D elevation style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, expand 2D Section/Elevation
Styles, and select the style you want to change.

3 Click the Design Rules tab.

4 Select the rule that you want to remove, and click Remove.

5 Click OK.

6 Update the elevation to apply the style changes to the elevation.

For more information, see Updating a 2D or 3D Elevation on page
3364.

Adding Classifications to a 2D Elevation Style
Use this procedure to specify classifications for any classification definition
applied to a 2D elevation style.

For more information about creating and applying classification definitions,
see Classification Definitions on page 3872.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, expand 2D Section/Elevation
Styles, and select the style you want to change.

3 Click the Classifications tab.

By default, the classification for all classification definitions is
Unspecified. If no classification definitions are listed, none are
applied to 2D elevation styles.

4 For each classification definition, select the classification you want
to apply to the current 2D elevation style.

5 Click OK twice.
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Changing the Layer, Color, and Linetype of a 2D Elevation Style
Use this procedure to change the following display properties of a 2D elevation
style:

■ Visibility (component is on or off)

■ Display properties by materials

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

NOTE The custom display components in the display properties are identical to
those listed on the Components tab of the 2D Section/Elevation Styles dialog box.
For more information about custom display components, see Adding a Display
Component to a 2D Elevation Style on page 3373.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, expand 2D Section/Elevation
Styles, and select the style you want to change.

3 Click the Display Properties tab.

4 Select 2D Section/Elevation Style for the property source, and
click Style Override.

5 If necessary, click  .

6 Click the Layer/Color/Linetype tab.

7 Select the component to change, and select a different setting for
the property.

8 Select By Material for any component that you want to use the
display properties of the materials assigned to the elevation
objects.
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NOTE Not all display components of a 2D elevation have an
associated material definition. For example, Hidden and Erased cannot
be set by material. For a list of all display components and their
associated material components, see About 2D and 3D Elevation
Display Components and Materials on page 3374.

9 Click OK twice.

Attaching Notes and Files to a 2D Elevation Style
Use this procedure to enter notes and attach reference files to a 2D elevation
style. You can also edit notes and edit or detach reference files attached to the
style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, expand 2D Section/Elevation
Styles, and select the style you want to change.

3 Click the General tab.

4 To add a description to the 2D elevation, enter the description
under Description.

5 Click Notes.

6 To add or edit a note, click the Notes tab, and enter the note.

7 To attach, edit, or detach a reference file, click the Reference Docs
tab:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Edit
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application. Click OK
when you are done editing.

edit a reference file

select the file name, click Delete,
and click OK.

detach a reference file

8 Click OK twice.
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Hidden Line Projection

You can create flat 2D projections with hidden background lines from a 3D view of objects
in your drawing. The Hidden Line Projection command produces quick sections and elevations
of objects in your drawings that are not updated automatically when you make changes to
your 3D model.

Hidden Line Projection
You can create flat 2D projections with hidden background lines from a 3D
view of objects in your drawing. The Hidden Line Projection command produces
quick sections and elevations of objects in your drawings that are not updated
automatically when you make changes to your 3D model.

Creating a Hidden Line Projection
Use this procedure to create a 2D graphic from a 3D view of one or more objects
in your drawing. The 2D graphic that you create is a flattened representation
of the objects in the current 3D view, with hidden background lines. Use the
Hidden Line Projection command to create quick 2D elevations and sections.

After you create an elevation or section hidden line projection, you can hatch
or shade the cut areas. You can also use hidden line projections to create detail
drawings. For more information about creating elevations and sections, see
Working With Elevations on page 3321 and Sections on page 3251.

When you create hidden line projections, the 3D objects that you select are
copied and collected into an unnamed (also called anonymous) 2D block. The
unnamed block can be placed in your drawing in the current 3D view, or placed
parallel to the XY plane to be viewed in plan view. You can edit or explode the
inserted block. If you want to insert the block in another drawing as a named
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block, define the block. For more information about inserting blocks, see
“Insert Blocks” in AutoCAD help.

TIP The quickest way to locate and view an AutoCAD topic is to click the Search
tab in the Help window, select the Search titles only option, and then copy and
paste or type in the AutoCAD topic name, and click List Topics.

NOTE Your 2D hidden line projections are not dynamically linked to the objects
in the 3D view. Therefore, if you edit the original object or objects in 3D view, the
2D graphic does not change. You must edit or re-create the 2D hidden line
projection to reflect any changes that you make to the original objects.

1 Open the tool palette that you want to use, and select a hidden
line projection tool.

A hidden line projection tool is located with the Helper Tools in
the Stock Tool Catalog. For more information, see Content Browser
Overview on page 129.

Alternatively, you can click Home tab ➤ Section & Elevation

panel ➤  ➤ Hidden Line Projection  .

2 In a 3D view select one or more objects that you want to use to
create your hidden line projection, and press ENTER.

3 Specify an insertion point in your current drawing for the 2D
hidden line projection.

4 Specify the insertion point for the 2D hidden line projection into
your drawing:

■ Press ENTER to insert the 2D block in plan view.

■ Enter n (No) to insert the 2D block in the current view.
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AEC Dimensions

AEC dimensions are associative annotation objects used to display the relevant measurements
of a building object, like the width of a wall or the length of a beam. The appearance of
dimensions is controlled through styles and can be adjusted for different drawing views or
to accommodate the standards of a particular company or country.

AEC Dimensions
AutoCAD Architecture offers different ways of dimensioning objects and points
in a drawing. AEC dimensions can be associative to objects or be used to
dimension user-specified points in the drawing. If you create an associative
dimension, the dimension value changes when the object changes its
measurements.

Components of an AEC dimension

Using Grips to Modify AEC Dimensions

When you select an AEC dimension, various grips are displayed. You can use
the grips to add and remove dimension points, move dimension chains, change
the offset of extension lines, and override wall component dimensions.
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AEC dimension grips

Dimensioning Wall Components

When dimensioning wall components, you have the option of using the center
of the component or either side as the dimension point. For example, you
can dimension a wall component from its center or from one of its edges. You
can also dimension wall components according to their structural function.

Grips for the individual component dimension points allow you to override
style-defined dimension points on walls to accommodate special cases.

Wall component dimension grips

Overriding Dimension Values

The dimension values in an AEC dimension are calculated from the actual
current dimensions of associated objects. You can override a value with a
manually inserted value. For detailed information, see Overriding Dimension
Values and Hiding Dimension Segments on page 3443.

Overriding dimension text with a new value
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Dimension Options and Uses
In AutoCAD Architecture, you can dimension object points specified in the
AEC dimension style, points on objects picked in the drawing, or user-specified
points in the drawing. AEC dimensions associated with objects update when
the object changes. User-specified points are not associative and have to be
changed manually, if necessary. In addition to AEC dimensions, you can also
use AutoCAD dimensions. The following table lists the differences between
the different dimension methods:

An AEC dimension can contain both associative and non-associative points.
For example, you can create an AEC dimension that dimensions a wall, a
multi-view block representing a floor drain, and user-specified points selected
anywhere in the drawing.

Associative Dimensions from Selecting Objects
Associative AEC dimensions are style-based annotation objects that update
automatically when the associated object changes. The AEC dimension style
defines the dimension points that determine which measurements are
displayed for each object that the style can be used to dimension.

In the example below, walls lengths, opening widths, and wall intersections
are set as the dimensioned points in the style. If a door is made wider, the
dimensions update to reflect the new measurements.

Associative wall dimensions

You can define styles for specific object types. For example, one AEC dimension
style might specify that for walls, dimensions will be displayed for lengths,
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maximum opening widths of windows in walls, and wall intersections. Another
AEC dimension style for mass elements might specify the mass element edges
and center as dimension points.

For a complete list of objects for which you can specify dimension points in
AEC dimension styles, see Associative Dimensions from Objects on page 3393.

NOTE AEC objects can be associatively dimensioned in external references, even
when they are nested multiple levels deep. This is useful for large drawing projects,
where the parts of the building are distributed over various drawing files.

You can also define different dimension points for different views. For example,
in Plan Low Detail, you might want to dimension only the outer boundaries
of a building, whereas in Plan High Detail you might want to dimension wall
lengths and openings in walls as well.

In the AEC dimension style, you can define up to ten dimension chains, each
with different dimension points. For example, the first chain can dimension
wall lengths and openings in walls, while the second chain dimensions
structural components of multi-component walls.

In the AEC dimension style, you can also specify whether to use superscripting
in dimensions, and whether the extension line length is fixed or variable.

Associative Dimensions from Picked Points
When you use an AEC dimension tool, the Pick points option lets you select
the base point and OSNAP points on an AEC object to create an associative
dimension. In addition, you can define an offset from a selected point, so that
virtually any point on an object can be dimensioned. This option lets you
dimension AEC objects for which dimension points cannot be set in the AEC
dimension style, like multi-view blocks or 2D building sections, or objects for
which the dimension point you need is not settable in the style. For example,
you cannot dimension the location of a pilaster in a wall in the AEC dimension
style, but you can pick an endpoint on the wall, and then offset it so that
becomes a dimension point for the pilaster location.

Because a dimension generated by picking points on objects is associative, if
you move the object, the dimension points are updated accordingly, observing
any offsets you have specified.

For a list of objects that can only be dimensioned associatively by picking
points on them, see Associative Dimensions From Picked Points on page 3402.
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Picking associative points to dimension

Non-Associative Dimensions from Picked Points
You can create non-associative dimensions from points you pick anywhere
in the drawing. For each point you pick, a location point is generated and
dimensioned. If the point is used to dimension an object, and the object is
moved, the non-associative point is not updated. You have to manually move
the non-associative point to reflect the change.

Non-associative grip points on AEC dimension

You can convert AutoCAD dimensions to non-associative AEC dimensions.
The AutoCAD dimension points are converted to location points on the AEC
dimension. For more information, see Converting an AutoCAD Dimension
to an AEC Dimension on page 3418.

AutoCAD Dimensions
AutoCAD dimensions can be associated with AutoCAD objects like polylines.
Additionally you can create non-associative AutoCAD dimensions.

Associative AutoCAD dimensions are turned on by default in AutoCAD
Architecture. To work with traditional non-associative AutoCAD dimensions,
set the system variable DIMASSOC to 1 (Non-Associative Dimensions). To
create AutoCAD object dimensions, set DIMASSOC to 2 (Associative
Dimensions).

For more information about AutoCAD dimensions, see “Dimensions and
Tolerances” in AutoCAD Help.
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Process Overview: Creating AEC Dimensions
An AEC dimension consists of a number of components and settings to make
it the optimal tool for dimensioning objects.

TIP AutoCAD Architecture ships with predefined dimension tools for many uses.
Before you create a new tool or AEC or AutoCAD dimension style, look through
the templates to find an existing tool or style that contains most or all of your
desired settings. You can then modify it for your purposes, if necessary.

The general process for creating AEC dimensions involves the following steps:

1 Specify the drawing options for the AEC dimension, as described in
Specifying AEC Dimension Preferences on page 3403.

Important settings include the dimension unit, superscripting preferences,
and the automatic scaling of AutoCAD dimension styles.

2 Verify that there is an AutoCAD dimension style that has the settings
you need. If necessary, create a new AutoCAD dimension style that defines
the color of the dimension lines, size and font of the dimension text,
arrows, unit format, and unit precision.

For more information, see “Use Dimension Styles” in the AutoCAD help.

3 If you are dimensioning walls, create or modify a wall style with
dimension settings for wall components.

For more information, see Defining the Dimension Settings for Wall
Components on page 1309.

4 Create an AEC dimension style that specifies the desired values for the
following settings:

■ number of dimension chains

■ object types to be dimensioned (for example, walls or mass elements)

■ object points to be dimensioned (for example, wall components and
wall intersections)

■ underlying AutoCAD dimension style

For more information, see AEC Dimension Styles on page 3453.

5 Use a dimension tool and dimension objects and points in the drawing.

For more information, see Creating an AEC Dimension with User-Specified
Settings on page 3408.
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Associative Dimensions from Objects
The AEC dimension style defines the dimension points that determine which
measurements are displayed for each type of object to which the AEC
dimension can be applied. You can either create a dimension style that defines
dimension points for multiple object types, or you can create separate styles
for individual object types.

For information about how to define dimension points in AEC dimension
styles, see Specifying Object Dimension Points in AEC Dimension Styles on
page 3460.

Dimension Points for Walls
The following wall dimension points can be specified in the AEC dimension
style:

Wall Dimension
Points

ExamplesDescriptionSelection

Dimensions the two outer points of
all dimensioned walls.

Overall

Dimensions the outer boundaries of
every selected wall. When wall
boundaries overlap, only those fa-

Length of Wall:
Outer Boundaries

cing the dimension direction are
dimensioned.

Dimensions the length of each wall
in the selection set.

Length of Wall: Wall
Length

Dimensions the overall width of a
wall.

Wall Width: Overall

Dimensions the width of each com-
ponent in a wall.

Wall Width: All
Components
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Wall Dimension
Points

ExamplesDescriptionSelection

Dimensions the center line of a
single-component or multi-compon-
ent wall

Wall Width: Center

Dimensions the wall components
according to the settings in the wall
style. For more information, see

Wall Width: From
Style

Defining the Dimension Settings for
Wall Components on page 1309.

Dimensions the structural wall
components according to the set-
tings in the wall style. For more in-

Wall Width: Structur-
al from Style

formation, see Defining the Dimen-
sion Settings for Wall Components
on page 1309.

Dimensions the intersection points
of walls that are connected to the
selected walls.

Wall Intersections

Dimension Points for Wall Components

The dimensioning of wall components can be specified in 2 different locations:
in the wall style and in the AEC dimension style.

In the wall style, you can set following information that is relevant to the
dimension:

■ Component side to dimension: In the wall style, you can define for each
wall component whether it should be dimensioned to its positive or
negative side, or to the center of the component. The positive and negative
sides of a wall are determined by the direction in which the wall is drawn:
if you draw a wall from left to right, the positive side is the left (top). If
you draw a wall from the right side to the left, then the positive side is the
right (bottom). If you determine that a wall component is only
dimensioned to one side, you can select either the positive or negative side
of the wall.
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■ Structural function: You can define a wall component as structural or
non-structural. When you set up the AEC dimension style you can define
that only structural wall components, or all wall components should be
dimensioned.

In the AEC dimension style you can define the following additional or
overriding settings for dimensioning wall components:

■ By Style: the dimension points selected in the wall style are used to
dimension the wall components width.

■ Structural by Style: the dimension points specified for the structural
components of the wall style are used.

■ All Components: each component of the wall is dimensioned.

■ Overall: the overall width of the wall is dimensioned.

■ Center: the center of the wall is dimensioned.
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Dimension Points for Wall Openings
The following wall opening dimension points can be specified in the AEC
dimension style:

Window, Door,
and Opening Di-
mension Points 

ExamplesDescriptionSelection

Dimensions the maximum width of
a window, door or opening in a wall.

Opening Max.
Width

Dimensions the minimum width of
a window, door, or opening in a
wall.

Opening Min. Width

Dimensions the center point of a
window, door, or opening in a wall.

Center of Opening

NOTE If you click  ➤ Options, and then click AEC Object Settings, there
are two options under Wall settings: Dimension to Center of Opening and
Dimension to Outer Frame of Opening. These settings have no influence on how
openings are dimensioned in AEC dimensions.

Dimension Points for Grids
You can set dimension points for the following grid types in the AEC
dimension style:

■ Column grids

■ Ceiling grids

■ 2D layout grids

NOTE 3D layout volumes have no style-based associative dimension points.
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The following grid dimension points can be specified in the AEC dimension
style:

Grid Dimension
Points

ExamplesDescriptionSelection

Dimensions the two outermost grid
lines of all selected grids

Overall

Dimensions the outer grid lines of
selected grids

Outer Grid Lines

Dimensions all grid lines in selected
grids

All Grid Lines

Dimension Points for Other Object Types
The same set of dimension points can be specified individually in the AEC
dimension style for these objects:

■ Mass elements/mass groups

■ Curtain walls

■ Window assemblies

■ Structural members (columns/braces/beams)

■ Standalone windows/doors/openings

■ Others

■ Stairs

■ Railings

■ Spaces

■ Roofs/roof slabs/slabs
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TIP If you need different dimension points for individual items from the Other
group, it is recommended that you create different dimension styles containing
the varying settings. For example, you can create an AEC dimension style for stairs
where you dimension the bounding box only, and another dimension style for
spaces that dimensions the space edges.

The following dimensions points an be specified in the AEC dimension style
for the objects in this category:

Other Building Ob-
ject Dimension
Points 

ExamplesDescriptionSelection

Dimensions the two outer points of
selected objects

Overall

Dimensions the bounding box of
each object in the selection set

Bounding Box

Dimensions all edges in an objectEdges: All Edges

Dimensions the edges of the object
that are visible from the direction of
the dimension line

Edges: Facing Edges

Dimensions the center point of an
object

Center

AutoCAD Dimension Points
You can define points for most AutoCAD linework objects in the AEC
dimension style.
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Dimensioning line endpoints and midpoints example

Dimensioning polyline endpoints and midpoints example

Dimensioning circle centers and quadrants example

Use an AEC dimension style to dimension the following AutoCAD linework
objects:

■ Lines

■ Arcs

■ Circles

■ Open and closed polylines

■ AutoCAD polygons

■ Rectangles
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The following AutoCAD points can be associatively dimensioned in the AEC
dimension style:

AutoCAD Line-
work Dimension
Points 

ExamplesDescriptionSelection

Dimensions the two overall outer
points of all selected objects.

Extents

Dimensions the endpoints of selected
objects. If you selected a polyline
with multiple segments, the end-

Endpoints

points of each segment are meas-
ured. Endpoints can be measured for
all AutoCAD linework objects listed
above except circles.

Measures the midpoints of all seg-
ments of the selected object that are
lying in the direction of the dimen-

Midpoints

sions. Midpoints can be measured
for all AutoCAD linework objects lis-
ted above except circles.

Measures the center of the curve of
circular objects. Centers can be
measured for circles, arcs, and curved
polyline segments.

Center

Measures the quadrants of circles,
arcs, and curved polylines segments.

Quadrant

AutoCAD linework objects include line-based objects, such as lines and open
polylines, as well as non-linear geometry, such as closed polylines and circles.
The results of using AEC dimensions to dimension these objects can be quite
different. For example, for a single line, the options Overall, Bounding Box,
All Edges, and Facing Edges return exactly the same dimension points. Some
objects, like circles, have no edges to dimension.
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TIP The best way to handle the different dimension points for AutoCAD linework
is to create a number of AEC dimension styles for the individual objects. For
example, you can create a style named “Line,” which has only one dimension
chain for dimensioning line edges, or a dimension style named “Circle,” which
dimensions only circle centers and circle quadrants. For more information on
creating AEC dimension styles, see AEC Dimension Styles on page 3453.

You cannot define associative dimension points for the following AutoCAD
linework objects in the AEC dimension style:

■ Multilines

■ Splines

■ Ellipses

■ Blocks

■ AutoCAD dimensions

■ Leaders

■ Text

■ Surfaces

■ Images

■ OLE frames

■ Proxies

■ Solids

Associative Dimensions in External References
You can associatively dimension objects from external references in the
following cases:

■ Attach an external reference drawing to a host drawing, and dimension
objects from the external reference and the host drawing in the host
drawing.

■ Attach a nested external reference drawing to a host drawing, and
dimension objects from the external reference, its nested external reference
and from the host drawing in the host drawing.
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Objects from external references are dimensioned in the same way and with
the same dimension points as objects from the host drawing.

You can create any level of nesting inside the external reference and still
dimension all nested referenced objects.

You will need the ability to dimension external references often when you
are working in a project environment. For detailed information on using
dimensions in a project, see Workflow for Annotating a Project on page 529.

Associative Dimensions From Picked Points
For AEC objects that cannot have associative dimension points specified in
the AEC dimension style, you can pick points on the object in the drawing
to generate an associative dimension; points that are picked on the object
remain associative to the object.

You can pick either the base point of an object to dimension or any of its
OSNAP points. For each point, you can additionally define an offset from the
picked point to the dimension point, so that you can dimension virtually any
point on an object.

You can also pick a point on an object that can be set in the dimension style,
in case you want to dimension a point that is not included in the style-based
points. For example, if you want to dimension a recess in a wall with an
individual dimension point, you can pick a point on the desired location on
the wall.

NOTE You cannot pick associative points on AutoCAD objects.

The following AEC objects can be dimensioned associatively only by picking
points on them:

■ Multi-view blocks

NOTE You cannot dimension multi-view blocks that have Xdata attached to
them.

■ Curtain wall units

■ AEC polygons

■ Mask blocks

■ 2D Sections/Elevations
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■ Entity references

■ Layout curves

■ 3D layout volumes

Specifying AEC Dimension Preferences
Use this procedure to specify dimension preferences before you add AEC
dimensions to your drawing.

Settings for AEC dimensions include the following:

■ Superscript for millimeters

■ Dimension display unit

■ Automatic rescale of existing AutoCAD dimension styles

■ Update behavior of points added or removed

1 Click  ➤ Options.

2 Click the AEC Dimension tab.
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Settings for AEC dimensions

3 Specify how dimension chains are updated when you remove or
add dimension points:

Then…If you want to…

select Update Added / Removed
Points Immediately.

update the display after every point
you remove from or add to a dimen-
sion chain

clear Update Added / Removed
Points Immediately.

update the display only after you
have finished removing or adding
dimension points

For more information, see Adding Non-Associative Dimensions
from Picked Points to an AEC Dimension on page 3428 and
Removing Object Points Set in the AEC Dimension Style on page
3429.
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4 Specify if manual dimension points are associative or
non-associative:

Then…If you want to…

select Make Manual Dimension
Points Associative

specify associative manual dimen-
sion points

clear Make Manual Dimension
Points Associative

specify non-associative manual di-
mension points

5 Set the global behavior of manually overridden dimension values:

Then…If you want to…

select Override Display of Under-
lined Text, and then select Under-
line All.

have an automatic underline for
each manually overridden dimen-
sion value

select Override Display of Under-
lined Text, and then select Under-
line None.

have no underline for any overrid-
den dimension value

clear Override Display of Underlined
Text.

set underlines for each overridden
dimension value manually

For more information, see Overriding Dimension Values and
Hiding Dimension Segments on page 3443.

6 Under Units, for Dimension in, select the unit in which
dimensions are to be displayed.

This unit can differ from the drawing unit. For example, you can
create a drawing in meters, but have the dimensions displayed in
centimeters.

7 If meters or centimeters are your drawing units, and you want to
display the millimeters as superscripted text, select Use Superscript
mm.

Millimeters superscripted (left) and millimeters not superscripted (right)
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8 If you do not want zeros at the end of superscripted numbers,
select Trailing Zeros Suppression for Superscript.

You can select this option only if you have selected Use Superscript
mm.

Trailing zeros not suppressed (left) and suppressed (right)

9 Under Automatic Scale of AutoCAD Dimstyles, select the AutoCAD
dimension styles to be rescaled when you change the drawing
units.

For example, you change the drawing units from meters to
millimeters. The following settings in your AutoCAD dimension
style are rescaled:

:

AutoCAD
Dimstyle

VariableDescription

MillimetersMeters

500.00000.5000DIMDLIDimension line spacing

125.00000.1250DIMDLEDimension line exten-
sion

125.00000.1250DIMEXEExtension line length

100.00000.1000DIMGAPText offset from dimen-
sion line

200.00000.2000DIMTXTDimension text height

Creating AEC Dimensions Using AEC Dimension Tools
Tool palettes provided with AutoCAD Architecture let you quickly place AEC
dimensions by selecting an AEC dimension tool with a specific AEC dimension
style and other predefined properties. You can also use the AEC dimension
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tools to convert AutoCAD dimensions to AEC dimensions and to apply the
settings of an AEC dimension tool to an existing AEC dimension.

Tool palette containing AEC dimension tools

The default tool palettes in the workspace contain sample AEC dimension
tools that you can use and customize as needed. In addition, the following
catalogs provided with the software contain AEC dimension tools that you
can add to your tool palettes:

■ AutoCAD Architecture Stock Tool catalog

■ AutoCAD Architecture Sample Palette catalog

Custom palettes created by your CAD manager or other users may also contain
AEC dimension tools with AEC dimension styles and properties that are
customized for your projects or office standards.

Creating an AEC Dimension
Use this procedure to add a new AEC dimension that has the properties
specified in the AEC dimension tool that you select. To specify settings when
you add an AEC dimension, see Creating an AEC Dimension with
User-Specified Settings on page 3408.

1 Open the tool palette that you want to use, and select the tool.

NOTE Alternatively, you can click Home tab ➤ Annotation

panel ➤ Dimension drop-down ➤ AEC Dimension  or Annotate
tab ➤ Dimensions panel, and select one of the available dimension
tools there.
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2 Select the objects or points you want to dimension, and press
ENTER.

You can move or hide the Properties palette to expose more of
the drawing area.

3 Click where you want to insert the AEC dimension.

Creating an AEC Dimension with User-Specified Settings
Use this procedure to create an AEC dimension with the settings that you
specify.

TIP To ensure that the Properties palette is displayed before you select a tool,
right-click in the drawing area, and click Properties.

An AEC dimension can include associative dimensions from objects, associative
dimensions from picked points on objects, and non-associative dimensions
from points anywhere in the drawing.

Associative wall dimensions

Associative dimension picked on multi-view block
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Non-associative dimension

1 Open the tool palette that you want to use, and select an AEC
dimension tool.

NOTE Alternatively, you can click Home tab ➤ Annotation

panel ➤ Dimension drop-down ➤ AEC Dimension  or Annotate
tab ➤ Dimensions panel, and select one of the available dimension
tools there.

2 On the Properties palette, expand Basic, and expand General.

3 Select a style.

4 Specify which objects or points to dimension:

Then…If you want to…

select objects in the drawing that
have been specified in the AEC di-
mension style.

dimension objects specified in the
AEC dimension style (creates an
associative dimension)

select multiple objects of the object
list in Associative Dimensions From
Picked Points on page 3402.

dimension the base point of ob-
jects that cannot be set in the AEC
dimension style (creates an associ-
ative dimension)

verify that OSNAP is turned on. Enter
p (Pick Points) on the command line,

dimension OSNAP points on ob-
jects (creates an associative dimen-
sion) and select points on objects by

snapping to them.

verify that OSNAP is turned off. Enter
p (Pick Points) on the command line,
and specify points in the drawing.

dimension non-associative points
in the drawing (creates a non-asso-
ciative dimension)
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NOTE During adding an AEC dimension, you cannot select objects
specified in the style and non-associative points in the same
command. You can however, once a dimension is added to the
drawing, attach objects and points as necessary. For more information,
see Adding Points to an AEC Dimension on page 3423.

5 Press ENTER.

6 Specify the style, position, rotation, and direction of the new
dimension:

Then…If you want to…

enter s (Style) on the command line,
and press ENTER; then, enter the style
name and press ENTER again.

change the style of the AEC
dimension

drag the cursor in the desired direction,
and click at the desired insertion point.

NOTE If your selection set contains
objects with different directions, the
direction of the first selected object
defines the parallel and perpendicu-
lar directions.

insert the AEC dimension paral-
lel or perpendicular to the di-
mensioned object

enter r (Rotation) on the command line,
and press ENTER.Then, enter a rotation

insert the AEC dimension at a
specified rotation

angle, either by clicking in the drawing
or by entering it on the command line.
Press ENTER, and click at the desired in-
sertion point. Alternatively, pressing the
SPACE bar rotates the dimension by 90°.

NOTE If your selection set contains
objects with different directions, the
rotation is calculated with reference
to the first selected object.

enter a (Align) on the command line,
and press ENTER. Then, select the object

insert the AEC dimension paral-
lel to an object other than the

to which to align the AEC dimension.dimensioned object in the
drawing
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Then…If you want to…

Press ENTER, and click in the drawing at
the desired insertion point.

NOTE The direction of the AEC di-
mension is dependent on the rota-
tion of the chosen object. The
drawing direction of the object has
no influence on the AEC dimension
direction.

Use Cases for AEC Dimensions
AEC dimensions give you the freedom to dimension your model according
to your needs. The following sections outline some frequently used use cases
for your work with AEC dimensions.

Creating an Interior Dimension

Use this procedure to create an interior wall dimension.

When you are dimensioning a set of interior walls and want to place the
dimension inside the walls, you need a dimension without extension lines,
as shown in the graphic below.

Dimension string without extension lines

1 Create a single-component wall style for interior walls and define in the
wall style that only one side of the wall component should be
dimensioned. For detailed information, see Specifying the Components
of a Wall Style on page 1299.

Use Cases for AEC Dimensions | 3411



2 Create an AEC dimension style that has the following settings:

■ Single dimension chain: For detailed information, see Changing the
Number of Chains in an AEC Dimension Style on page 3456.

■ Wall width dimension “By Style:” This setting ensures that wall
components will be dimensioned according to the points you have
set in the wall style. For more information, see Dimension Points for
Walls on page 3393 and Specifying Object Dimension Points in AEC
Dimension Styles on page 3460.

■ Extension line length of 0. For detailed information, see Selecting the
AutoCAD Dimension Styles and Other Properties of AEC Dimension
Styles on page 3462.

3 Use the AEC dimension style to dimension a set of interior walls in your
plan, as described in Creating an AEC Dimension with User-Specified
Settings on page 3408.

Use the preview graphic to place the AEC dimension within the walls as
desired.

NOTE You can reposition the AEC dimension later with grips.

Dimensioning the Overall Building Length for Multiple Walls

You can use any of the following methods to dimension the overall length of
a building consisting of multiple walls.

■ You can use an AEC dimension style that is designed to create an associative
dimension for the overall length of a building.

■ You can pick the outside points of the two outermost walls by snapping
to them, and create an associative AEC dimension.

■ You can manually specify two points representing the outermost extents
of the building and create a non-associative dimension to these points.

Dimensioning the outer length of a building with an AEC dimension style

1 Create an AEC dimension style that dimensions the outer length of all
selected walls.

For more information, see Dimension Points for Walls on page 3393 and
Specifying Object Dimension Points in AEC Dimension Styles on page
3460.
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2 Select an AEC dimension tool with the style created in the previous step.

3 Select only those walls facing the direction where you want to create the
AEC dimension, and insert the dimension in the drawing.

TIP Do not select any walls that are perpendicular to the dimension. This
creates additional unwanted dimension points.

Dimensioning the outer length of a building with points picked on the walls

1 Select an AEC dimension tool, and verify that OSNAP is turned on.

2 Enter p (Pick Points) on the command line and press ENTER.

3 Select the two outermost snap points on the building you want to
dimension.

4 Place the AEC dimension in the drawing.
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TIP You can select the associative dimension points later and offset them
from their original position on the wall.

Dimensioning the outer length of a building with non-associative points

1 Select an AEC dimension tool, and verify that OSNAP is turned off.

2 Enter p (Pick Points) on the command line and press ENTER.

3 Specify two points in the drawing you want to dimension, press ENTER,
and place the AEC dimension.

The points you selected are not associative to the walls in the building.
If you move the walls, you have to move the location points accordingly
to bring the dimension up to date.
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Dimensioning Wall Components in the Wall Length

Wall components are a part of the wall width, not the wall length. To generate
an AEC dimension that displays wall components in the wall length, you have
to select the walls vertically intersecting the wall for which you want to
dimension the components in the length.

Dimensioning wall components on wall length

Creating Dimensions to OSNAP Points

When you are using an AEC dimension tool with the OSNAP setting turned
on, and select ia point that snaps to an AEC object, you create a dimension
point that is associated with the selected point on the object. For example, if
you pick an Endpoint, then an associative dimension to the Endpoint of the
object is generated. This allows you to create an AEC dimension that
dimensions multiple associative points on one object.

Example: Dimensioning a 2D Building Section

A 2D building section is one of the objects for which dimension points can
not be specified in the AEC dimension style. When you start an AEC dimension
tool, and select a building section, its base point is the default dimension
point. However, because you need at least 2 points to dimension you need to
select 2 or more OSNAP points on the 2D section.
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Dimensioning a 2D building section

1 Verify that OSNAP is turned on.

2 Select an AEC dimension tool.

3 On the command line, enter P (Pick Points).

4 Select the snap points on the 2D building section you want to dimension.

5 Press ENTER to create the dimension.

The OSNAP points you selected on the section object are inserted as
associative points on the dimension.

Creating Dimensions Associated with the Object Base Point

When you create associative dimensions for points on objects for which
dimension points cannot be set in the AEC dimension style, one associative
point is created for each object you select. The point is placed at the base point
of the object.
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Example: Dimensioning Multi-View Blocks

Associative dimensions for multi-view blocks

1 Verify that OSNAP is turned off.

2 Select an AEC dimension tool.

3 Select at least 2 multi-view blocks. If you select only one, the dimension
will display as a defect marker.

4 Insert the dimension in the drawing.

For each selected object, an associative dimension point is inserted at the
base point of the object.

Dimensioning Points in Multi-Chain Dimensions

When you create a multi-chain dimension for which you select points in the
drawing, the same points are included in every chain on the dimension.

This may be the desired behavior in a case where you are dimensioning a
point of reference that should appear on every chain. If you need a particular
point on one chain only, you can do either of the following:
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Dimension multi-view blocks with a two-chain dimension

■ Delete the superfluous points by clicking their Remove grips.

■ Add points to individual dimension chains, as described in Adding
Associative Dimensions from Picked Points to an AEC Dimension on page
3426 and Adding Non-Associative Dimensions from Picked Points to an AEC
Dimension on page 3428.

Converting an AutoCAD Dimension to an AEC Dimension
Use this procedure to create an AEC dimension from an AutoCAD dimension.
For each AutoCAD dimension point, a non-associative AEC dimension point
is created. The resulting AEC dimension has the properties of the AEC
dimension tool you select. You can edit these properties after creating the
AEC dimension.

For detailed information about non-associative AEC dimension points, see
Non-Associative Dimensions from Picked Points on page 3391.
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Converting an AutoCAD dimension to an AEC dimension

1 Open the tool palette that you want to use.

2 Right-click an AEC dimension tool, and click Apply Tool Properties
to ➤  AutoCAD Dimension.

3 Select the AutoCAD dimensions, and press ENTER.

4 Do one of the following:

■ If you selected one AutoCAD dimension to convert, proceed
to Step  7.

■ If you selected multiple AutoCAD dimensions to convert,
proceed to Step  5.

5 Specify the position of the AEC dimension by clicking the desired
position in the drawing. The AEC dimension can, for example,
be placed above or below the object.

6 Do any of the following:

■ Drag the mouse to set the direction of the dimension. The
extension lines are drawn into the opposite direction.

■ To place the AEC dimension perpendicular to a point in the
drawing, enter perp (Perpendicular) on the command line,
and specify the point the dimension is perpendicular to.

■ To set a user-specified angle for the AEC dimension, enter the
desired angle on the command line.

NOTE The angle you specify here is calculated in relation to the UCS,
and not to the dimensioned object.

7 When prompted to erase the original AutoCAD dimension, press
ENTER to keep the AutoCAD dimension, or enter y (Yes) to erase
it.
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The resulting AEC dimension is displayed as follows:

Then…If…

the new AEC dimension is inserted
at the same position as the Auto-

you selected only one AutoCAD di-
mension

CAD dimension. If you did not erase
the original AutoCAD dimension,
the AEC dimension is placed on top
of it.

the new AEC dimension is inserted
according to your specifications

you selected more than one Auto-
CAD dimension

from steps 6 and 7. If you did not
erase the original AutoCAD dimen-
sions, they remain in their original
positions.

Copying Properties of AEC Dimensions to AutoCAD
Dimensions

Use this procedure to copy the display properties of an AEC dimension to an
AutoCAD dimension without converting the AutoCAD dimension. In this
case, a number of display attributes are changed while the functionality and
behavior of the AutoCAD dimension are not changed.

NOTE When you copy the properties of an AEC dimension to an AutoCAD object
dimension (DIMASSOC = 2), the associativity of the resulting AutoCAD dimension
is lost. Therefore, copy properties to an associative AutoCAD dimension only as
the last step in your drawing process, or use traditional, non-associative AutoCAD
dimensions (DIMASSOC = 1).

The following dimension display properties are copied from the AEC dimension
to the AutoCAD dimension:

■ AutoCAD dimension style: AEC dimensions have an underlying AutoCAD
dimension style, defining settings for the dimension not explicitly set in
the AEC dimension style.
When you copy the properties of an AEC dimension to an AutoCAD
dimension, the underlying AutoCAD dimension style of the AEC dimension
is applied to the AutoCAD dimension.
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For detailed information about the connection between AutoCAD
dimension styles and AEC dimension styles, see AEC Dimension Styles
and AutoCAD Dimension Styles on page 3453.

■ Superscript settings: If you have specified superscripted millimeters for
AEC dimensions, this is applied to the AutoCAD dimension.
For more information about superscripts, see Specifying AEC Dimension
Preferences on page 3403.

■ Extension line length: The extension length you have specified for your
AEC dimension is applied to the AutoCAD dimension.
When you copy the properties of an AEC dimension to an AutoCAD
dimension that has a different extension line length, the definition points
of the AutoCAD dimension are adjusted to the new length.

The AutoCAD dimension style and length of the extension lines are
view-dependent settings. When you copy the properties of an AEC dimension
to an AutoCAD dimension, the settings for the current view are applied.

1 On the command line, enter AecDimMatch.

2 Select the AEC dimension to copy properties from.

3 Select the AutoCAD dimensions to copy properties to.

4 Press ENTER.

Creating an AEC Dimension Tool
Use this procedure to create an AEC dimension tool and add it to a tool palette.
You may want to create your own AEC dimension tools if you are placing
multiple AEC dimensions of specific styles with additional AEC dimension
properties that you want to be the same each time you add an AEC dimension
of that type.

1 Open the tool palette where you want to create a tool.

2 Create the tool:

Then…If you want to…

select the AEC dimension, and drag
it to the tool palette.

create a tool from an AEC dimen-
sion in the drawing

click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from an AEC dimen-
sion style in the Style Manager

the style you want to copy, and
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Then…If you want to…

drag it to the tool palette. Click OK
to close the Style Manager.

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

right-click the tool, and click Copy.
Open the other palette, and click
Paste.

copy a tool from another tool
palette

click Home tab ➤ Build pan-

el ➤ Tools drop-down ➤ Content

copy a tool from a tool catalog

Browser  . Locate the tool you
want to copy. Position the cursor
over the i-drop handle, and drag
the tool to the tool palette.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

6 Expand Basic, and expand General.

7 Click the setting for Description, enter a description of the AEC
dimension created from this tool, and click OK.

8 Specify a layer key and any layer key overrides if you do not want
to use the layer assignments specified in the layer key style used
in the drawing.

9 Select an AEC dimension style.

10 Select the drawing file containing the style used for this AEC
dimension tool.

11 Click OK.

Editing AEC Dimensions
You can change the attributes of an AEC dimension, such as the objects and
points dimensioned or the dimension display. You can add dimension points
to an AEC dimension. You can reverse the dimension direction and manually
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change the length of extension lines. You can also move individual dimension
text in crowded plans and override dimension values with “false” values.

AutoCAD Architecture offers several methods for editing AEC Dimensions:

■ You can directly edit AEC dimensions using grips.

■ You can change AEC dimension settings on the Properties palette.

■ You can select editing commands from the context menu for the selected
AEC dimension.

Adding Points to an AEC Dimension
You can add points to an AEC dimension in the following ways:

■ You can attach a new object to the dimension; if dimension points have
been defined for that object type in the dimension style, corresponding
associative points are added to the dimension.

■ You can add associative points to the dimension by picking base points
or OSNAP points on AEC objects.

■ You can add non-associative points to the dimension by picking points
selected anywhere in the drawing. These points are not connected to objects
and are therefore not associative. To change their position, you need to
move the location grips generated on the dimension.

When you attach an object for which dimension points have been specified
in the AEC dimension style, the points are dimensioned and added to the
appropriate dimension chains. For example, if you add a wall to an AEC
dimension that has style settings for wall components in 2 chains, component
dimensions are added to these 2 chains.

If an object is not specified in the AEC dimension style, you can either
dimension the base point of the object or pick any of its OSNAP points as
dimension points. These dimension points can be manually offset while
retaining the associativity to the object. For example, you can dimension the
base point of a multi-view block and offset the dimension from the base point.
If the multi-view block is moved or rotated, the dimension moves and rotates
with it while observing the offset.

To add non-associative dimension points in a drawing, you specify points,
which are added as location grips, and are dimensioned on the selected
dimension chain. When the location grip is moved, the dimension point is
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updated accordingly. Non-associative dimension points can be useful if you
want to dimension a component not represented by an AEC object, like a
property line, or AutoCAD objects like blocks.

NOTE You can specify if manual dimension points near custom objects can be
associative or non-associative. For more information, refer to Specifying AEC
Dimension Preferences on page 3403

Moving a non-associative location point and updating an AEC dimension

Adding Associative Dimensions to Objects Defined in the AEC
Dimension Style

Use this procedure to add associative dimensions by attaching an object for
which dimension points have been defined in the AEC dimension style.

3424 | Chapter 44   AEC Dimensions



Attaching objects to an AEC dimension

You can also attach AEC objects for which dimension points are not specified
in the AEC dimension style. In that case, the base point of the selected object
is added as a dimension point.

1 Select the AEC dimension to which you want to attach objects,

and click the Add grip (  ) or click AEC Dimension tab ➤ Modify

panel ➤ Add Objects  .

2 Select the objects for which you want dimension points to be
added to the AEC dimension, and press ENTER.
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Any dimension points specified in the style for the selected objects
are added to the chains of the AEC dimension.

If a selected object has no dimension points specified in the AEC
dimension style, a dimension point is added at the base point of
the object.

3 If you want to offset a dimension point from an object not
specified in the AEC dimension style, select its location grip on
the dimension, and move it to the desired location.

Adding Associative Dimensions from Picked Points to an AEC
Dimension

Use this procedure to add associative dimensions to an AEC dimension by
picking OSNAP points on an AEC object.
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Adding and offsetting non-style defined dimension point to an AEC dimension

1 Verify that OSNAP is turned on.

2 Select the AEC dimension to which you want to add associative
points, and click AEC Dimension tab ➤ Modify panel ➤ Add

Extension Lines  .

3 Select the AEC object OSNAP points you want to dimension.

NOTE OSNAP points on AutoCAD objects will be filtered out of the
dimension.

4 Press ENTER.
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5 Select the AEC dimension chain to which the points should be
added.

Adding Non-Associative Dimensions from Picked Points to an
AEC Dimension

Use this procedure to add non-associative points picked in the drawing to an
AEC dimension.

1 Select the AEC dimension to which you want to add points, and
click AEC Dimension tab ➤ Modify panel ➤ Add Extension Lines

 .

2 Select the points in the drawing that you want to dimension, and
press ENTER.

3 Select the dimension chain to which the points should be added.

For each added point, a location grip is added at the end of the
extension line, and the dimensions on the chain are updated.

Detaching Dimension Points from an AEC Dimension
You can detach dimension points from an AEC dimension.

Detaching Objects from an AEC Dimension
Use this procedure to detach objects from an AEC dimension. When you
detach the object, all style-specified dimension points for the object are
removed from the dimension.

Detaching objects from a dimension
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1 Select the AEC dimension from which you want to detach objects,
and click AEC Dimension tab ➤ Modify panel ➤ Remove Objects

 .

2 Select the objects to detach from the AEC dimension.

3 Press ENTER.

The dimension points belonging to the selected objects are removed from the
AEC dimension.

Removing Object Points Set in the AEC Dimension Style
Use this procedure to remove object points set in the AEC dimension style
from an AEC dimension.

Removing these dimension points creates an override to the AEC dimension
style.

IMPORTANT Removing points from an object dimension is not identical to
detaching an object from an AEC dimension. Even if you remove all extension
lines pointing to dimensioned points on an object, the object is still invisibly
attached to the dimension through the AEC dimension style. If you turn on the
display component Removed Points Marker in the AEC dimension style, you can
see that the object points still exist and can be restored. If you want to detach an
object from an AEC dimension completely, use the procedure in Detaching Objects
from an AEC Dimension on page 3428.

1 Select the AEC dimension from which you want to remove
style-defined points.

2 Click the Remove grip (  ) on the extension line of the point
you want to remove, or click AEC Dimension tab ➤ Modify

panel ➤ Remove Ext. Lines  .

3 Proceed to remove points.

NOTE Make sure to select only extension lines referring to objects
that are specified in the AEC dimension style. Only these points can
be restored later.

Detaching Dimension Points from an AEC Dimension | 3429



If you remove object points using the context menu, the behavior
of the removal can differ according to your preference settings:

■ If the Update Added/Removed Points Immediately setting is
selected, the selected points are deleted immediately.

■ If the Update Added/Removed Points Immediately setting is
cleared, the selected points are deleted after you end the
command.

For more information, see Specifying AEC Dimension Preferences
on page 3403.

NOTE If the deleted points are still visible as a crossed circle, the display component
Removed Points Marker is turned on. If you do not want the removed points
marker to appear, turn off the component. For more information, see Restoring
Object Points Set in the AEC Dimension Style on page 3430.

When you remove multiple points, some removed points may reappear. This can
happen when you have selected the option Update Added/Removed Points
Immediately, and the entity display component Removed Points Marker is turned
off. The reason for this behavior is that during your current removal operation,
you accidentally selected an invisible removed point marker for a dimension point
already removed. Removing an already removed point restores it. To avoid this
effect, turn on the Removed Points Marker component in the entity display. For
more information about turning components on and off, see Changing the AEC
Dimension Display Components on page 3457.

Restoring Object Points Set in the AEC Dimension Style
Use this procedure to restore dimension points that have been removed from
an AEC dimension and that are set in the AEC dimension style. Because the
object points are set in the AEC dimension style, information about the type
and position of the removed point is still present in the AEC dimension style.

1 Select the dimension chain on which to restore a removed object
point.

2 Verify that the removed point is visible:

Then…If…

proceed to step 9.the point removed is still visible as
a crossed circle
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Then…If…

make it visible by following steps 3
through 9.

the point removed is not visible as
a crossed circle

3 Right-click, and click Object Display.

4 Click the Display Properties tab.

5 Select the display representation on which the changes should
appear, and select Object Override.

The display representation in bold is the current one.

6 If necessary, click  .

7 Click the Layer/Color/Linetype tab.

8 Select the Removed Points Marker component, and turn on the
setting for Visibility.

9 Click OK twice.

The removed dimension point on the dimension chain is now
visible as a crossed circle.

10 If necessary, select the AEC dimension again, and click AEC

Dimension tab ➤ Modify panel ➤ Remove Ext. Lines  .

11 Click the center of the circle for the dimension points to restore.

■ If the Update Added/Removed Points Immediately setting is
selected, the selected points are deleted immediately.

■ If the Update Added/Removed Points Immediately setting is
cleared, the selected points are deleted after you end the
command.

For more information, see Specifying AEC Dimension Preferences
on page 3403.
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Removing and restoring object points on an AEC dimension

Removing Non-Style Defined Dimension Points
Use this procedure to remove dimension points that are not set in the AEC
dimension style from an AEC dimension. These can be points that are
generated by picking object OSNAP points or by picking non-object associated
points in the drawing. Unlike style-defined dimension points, they cannot be
restored once they are deleted, however, you can recreate them if desired.
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Removing a point from an AEC dimension

1 Select the AEC dimension from which to remove dimension
points.

2 Click the Remove grip(  ) on the extension line of each point
to remove, or click AEC Dimension tab ➤ Modify panel ➤ Remove

Ext. Lines  .

Reversing the Direction of an AEC Wall Dimension
You can reverse the direction of an AEC dimension that is associated with
walls. Reversing the dimension direction can change the points on the wall
that are dimensioned.
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For an AEC dimension to be reversible, these conditions must be met:

■ The dimensioned wall has either two interior or two exterior sides.

TIP If you want to reverse the dimensioned points on a wall with an interior
and exterior side, you need to reverse the wall direction.

■ Wall components must be dimensioned on only one side, either on the
positive or the negative side.

For example, if you dimension one side of a wall component of a wall that
has two interior or two exterior sides, reversing the dimension direction will
dimension the opposite side of the component. For information on defining
the dimensioning of wall components, see Defining the Dimension Settings
for Wall Components on page 1309 and Specifying Object Dimension Points in
AEC Dimension Styles on page 3460.

Reversing an AEC dimension

 ➤ Select the dimension for which you want to reverse the direction,

and click  , or click AEC Dimension tab ➤ Modify

panel ➤ Reverse  .
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Flip Text Position for AEC Dimensions
AutoCAD is introducing two new text settings for the AutoCAD dimension
style:

■ Vertical text position: controls the vertical placement of text in relation
to the dimension line. Possible settings are above the dimension line, below
the dimension line, centered between extension lines, outside the
dimension line, and according to JIS (Japanese Industrial Standard).

■ Text view direction: Specifies the reading direction of dimension text.
Possible settings are left-to-right and right-to left.
For more information, see “Control the Location of Dimension Text” in
the AutoCAD Help.

When vertical AEC dimensions are rotated greater than 90 degrees, the
dimension text flips sides. In some cases, when dimensions are part of a series
of dimensions this is an undesired result.

Using the Text Flip grip addresses this issue by swapping the settings of vertical
text position and reading direction so that the dimension displays correctly.
In detail, these are the changes that are made:

■ The vertical text setting defined in the AutoCAD dimension style will be
overridden, and be set to the Below setting.

■ The reading direction will be swapped from left-to-right to right-to-left or
vice versa.

■ Any dimension texts that have a positional override will flip in place
around their location point.

NOTE You can also perform these changes in the underlying AutoCAD dimension
style. This will however, affect all AEC dimensions of that style, whether they are
rotated or not. In most cases an override on a specific dimension will work better.
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1 Select the rotated dimension.

2 Click the Flip text to opposite side of dimension grip  .

Overriding Associative Wall Component Dimension Points
If you have specified wall component dimension points in the AEC dimension
style, you can override individual component dimension points on the
dimension so that they override their style settings.

You can make the following overrides to a wall component dimension point:

■ Move a dimension point from one location on the component to another:
For example, you can move a dimension point from the center of the
component to the left side or to the right side.
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Modify an existing wall component dimension

■ Move a dimension point from one component to another: For example,
you can move a dimension point from the stud component to the gyp
board component on the same wall.

■ Add a new dimension point for a component: You can add a dimension
point to the edges or to the center of the selected component, in a case
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where this dimension point is not specified in the AEC dimension style
or wall style.

Adding wall component dimension point

■ Remove overrides and revert back to the component dimension settings
specified in the style.
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Overriding a component dimension

1 Select the AEC dimension on which you want to override a wall
component dimension point.

2 Select the Override grip (  ) for the desired component.

When you select the Override grip, the associated component is
highlighted in the drawing.

3 Move the grip to the desired position on the component, or onto
another component.

A red temporary line shows you the position on the component.

Add a new dimension point for a component

1 Select the AEC dimension to which you want to add a wall
component dimension point.

2 While pressing control, click the Override grip (  ) for the
desired component, and drag the new point to the desired
location.

You can add a dimension point in 3 locations on a component:
the positive edge, the negative edge, and the center.

Modifying an overridden component dimension

1 Select the AEC dimension on which you want to modify a wall
component override.

2 Select an overridden component dimension.

When a component dimension point is overridden, it is marked

with a yellow grip (  ).

3 Drag the grip to the desired position.

Remove overrides from a component dimension

1 Select the AEC dimension from which you want to remove a wall
component dimension override.

2 Do one of the following:

Then…If you want to…

drag the override grip (  ) to the origin-
al position on the component. When you

move a component back to
its style-defined position
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Then…If you want to…

release and re-select the grip its color

changes to cyan (  ).

click the Remove Extension line grip ( 
).

remove a component you
have added through an
override

click AEC Dimension tab ➤ Modify pan-

el ➤ Remove Override drop-down ➤ All

Components  .

reset all overrides

Repositioning Dimension Texts, Extension Lines, and Dimension
Chains

Use this procedure to reposition individual dimension texts, extension lines,
and dimension chains on an AEC dimension.

The length of extension lines and the distance between dimension chains are
set in the AEC dimension style, and are identical for all chains and all extension
lines in the dimension. In some cases, you need to override those settings,
and display varying extension lines or chain distances. Also, you might need
to move individual dimension texts to a different location.

Viewing AEC Dimension Move All Chains and Edit in Place grips

AEC dimensions offer you the ability to change the display of a dimension
with direct editing via grips.

NOTE You can only display and move the in-place grips of an AEC dimension if
the underlying AutoCAD dimension style has the correct text placement settings.
To ensure this, select the AEC dimension, right-click, and click AEC Dimension
Style. Then, select the display representation where you want the changes to

appear, and select Style Override. If necessary, click  , and click the Other tab.
Click Edit, and in the Dimension Style Manager click Modify. Click the Fit tab, and
select Over the dimension line, without a leader for Text Placement.
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1 Select the AEC dimension on which to reposition individual texts,
extension lines or dimension chains, and click its Edit In Place
grip.

NOTE Alternatively, you can click AEC Dimension tab ➤ Modify

panel ➤ Edit in Place  .

The dimension now displays grip points for

■ individual texts

■ individual extension lines

■ individual dimension chains

Viewing AEC Dimension Edit In Place grips

2 Use the grips to reposition dimension texts, lengthen or shorten
extension lines, and reposition dimension chains.

Resetting Repositioned Dimension Texts, Extension Lines and
Dimension Chains

Use this procedure to reset repositioned dimension texts, extension lines and
dimension chains.
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Repositioning text in a dimension

NOTE You can only reset those dimension texts that you have manually moved
to a different place. If dimension texts are offset from their positions because they
do not, for example, fit on the appropriate dimension segment, you cannot
automatically reset them here. To make sure that your dimension texts are always
placed on the dimension segment, set this in the underlying AutoCAD dimension
style. Select the AEC dimension, right-click, and click AEC Dimension Style. Then,
select the display representation where you want the changes to appear, and select

Style Override. If necessary, click  , and click the Other tab. Click Edit, and in
the Dimension Style Manager click Modify. Click the Fit tab, and select Always
keep text between ext lines under Fit Options.

1 Select the AEC dimension with repositioned components to be
reset.
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2 Set the components to their original positions:

Then…If you want to…

click AEC Dimension tab ➤ Modify

panel ➤ Remove Override drop-

down ➤ All Extension Lines  .

set the extension lines to their style
settings

click AEC Dimension tab ➤ Modify

panel ➤ Remove Override drop-

down ➤ All Text Positions  .

set the text strings to their original
position

NOTE To reset the distance between dimension chains, set the
distance between chains to the original value in the AEC dimension
style. For information, see Selecting the AutoCAD Dimension Styles
and Other Properties of AEC Dimension Styles on page 3462.

Overriding Dimension Values and Hiding Dimension Segments
The dimension values in an AEC dimension are the real-life calculated values
taken from the objects that are dimensioned. When the dimensioned object
is updated, the dimension value is updated accordingly. In some cases you
might want to override that value and exchange it for a manually inserted
value.

Overriding dimension text with a new value

In other cases, you might want to retain the original value, but supplement
it with a prefix or suffix.
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Overriding dimension text with a suffix

Sometimes, you need to hide a dimension text or a whole dimension segment.

Overriding dimension text by hiding text

Overridden dimension values can be marked in different ways:

■ Each manually overridden value, hidden text, or prefixed/suffixed value,
is marked by a short overline. For information on how to hide the overline,
see Hiding the Overline of Overridden Dimension Values on page 3447.

■ You can add an underline to each overridden value. For information, see
Hiding the Overline of Overridden Dimension Values on page 3447.

■ You can specify in the drawing setup to underline each override
automatically. For information, see Global Underline Options for Overrides
on page 3446.

When you manually override a dimension value, the correct automatic value
still exists. You can remove the override, and restore the correct value again.

Overriding Dimension Values
Use this procedure to exchange an automatic dimension value for a manually
inserted one, to add prefixes and suffixes to dimension values, and to hide
dimension texts and segments.
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1 Select the dimension on which to override a dimension value,
and click AEC Dimension tab ➤ Modify panel ➤ Override Text

& Lines  .

2 Click the value to override.

3 Specify the value override:

Then…If you want to…

select Hide Text.hide the selected dimension text

select Hide Text and Lines.hide the selected dimension seg-
ment

enter a value for Text.

NOTE You can enter all alpha-
numeric characters here.

override the dimension value

select Underline Text.mark an overridden value with an
underline

enter one for Prefix.add a prefix to a dimension value

enter one for Suffix.add a suffix to a dimension value

4 Click OK.

Removing Overrides from Dimension Values
Use this procedure to remove overrides from dimension values.

The results of removing overrides are as follows:

■ Overridden values are reset to their correct value.

■ Underlines and overlines are removed.

■ Prefixes and suffixes are removed.

■ Hidden text and hidden segments are redisplayed.
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1 Select the dimension from which to remove an override, and click

AEC Dimension tab ➤ Modify panel ➤ Override Text & Lines
.

2 Click the value or segment from which to remove an override.

3 Click Remove Override.

4 Click OK.

Global Underline Options for Overrides
Use this procedure to set the underlines of overridden dimension values
globally in the drawing.

Documentation guidelines of a company or regional office may require
underlining all overridden dimension values. It would be cumbersome to
underline each overridden value individually. AutoCAD Architecture offers
you the ability to set underlining of overridden values as the default behavior.
This means that whenever you override a dimension value, it is automatically
underlined.

Similarly, you might need a quick way to remove all underlines from a plan;
for example, to create a preview sheet from a not-yet-finished plan.

In this case, you can set global underlining instead of underlining or removing
underlines from individual overrides.

NOTE The global underline setting is applied to existing overrides and new
overrides.

1 Click  ➤ Options.

2 Click the AEC Dimension tab.

3 Select Override Display of Dimensioned Text.

4 Set the global underline behavior:

Then…If you want to…

Select Underline All.underline all overridden dimension
values in the drawing, regardless of
individual settings

Select Underline None.remove the underline from all
overridden dimension values in the
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Then…If you want to…

drawing, regardless of individual
settings

Hiding the Overline of Overridden Dimension Values
Use this procedure to hide the overline of overridden dimension values.

When you create an override for a dimension value—entering a different
value, hiding a text or a segment, adding a prefix/suffix—the override is marked
by a small overline above the changed value. The overline is useful for seeing
at a glance which values have been overridden.It is also useful when you have
hidden texts and segments, to select the hidden segment.

In some cases, however, you might want to hide the overline. The overline is
placed on the DEFPOINTS layer, and by default is not plotted. If you want to
hide it in the AutoCAD Architecture session as well, you need to hide the
DEFPOINTS layer.

1 In the Layer Properties toolbar, select the DEFPOINTS layer.

2 Click the light bulb icon to hide the layer.

NOTE Alternatively, you can hide the DEFPOINTS layer in the Layer Manager.

Changing the AEC Dimension Style
Use this procedure to change the style of an AEC dimension. AEC dimension
styles contain information about the objects to dimension, the number of
chains, and the display of the dimension. For information about how to define
AEC dimension styles, see AEC Dimension Styles on page 3453.

1 Select one or more AEC dimensions and double-click one of them.

2 Expand Basic, and expand General.

3 Select an AEC dimension style.

Specifying Object Dimension Points for an AEC Dimension
Use this procedure to specify the objects and points to be dimensioned
associatively for an AEC dimension in a particular display representation.
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1 Double-click the window.

2 Click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all AEC dimensions in the drawing,
select Drawing default setting. To apply changes to all AEC dimensions
of this style, select AEC Dimension Style:<style name>. For more
information on styles, see AEC Dimension Styles on page 3453.

5 For Display representation, verify that the desired display
representation is selected.

6 If necessary, expand Object Display Properties ➤ Advanced, and

click  Contents.

7 For Apply To, select the type of object you want to dimension.

Example: In the first chain, you want to dimension the length of
walls and wall intersections. For Apply To, you select Wall.

8 Under Chains, select the chain on which the dimension points
appear.

Example: In the first chain, you want to dimension the length of
walls. In the previous step, you selected Wall. Now, you select
Chain 1.

NOTE Selecting in this context means highlighting the desired chain,
and not selecting the check mark. The check mark is set automatically
depending on whether dimension points for this chain are selected.
Example: If you clear all possible dimension points for a chain, its
check is automatically cleared.

9 On the right side, select the points to include in the highlighted
chain.

Example: In the first chain, you want to dimension the length of
walls and wall intersections. In the previous steps, you selected
Walls and highlighted Chain1. Now, you select the check box for
Length of Wall and choose Wall Length. Then, you select the
check mark for Wall Intersections.
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NOTE Under Wall Width, you have two settings that override the
AEC dimension style settings for the dimensioning of wall
components: From Style and Structural from Style. If you select From
Style, the dimensioning of wall components is done according to the
settings in the wall style. If you select Structural from Style, the
dimensioning of wall components is done according to the settings
in the wall style, but takes into account only components that have
been marked as Structural in the wall style. For information on setting
the dimensioning of wall components in the wall style, see Defining
the Dimension Settings for Wall Components on page 1309.

10 Repeat steps 7–9 until your dimension contains all objects and
points you want to dimension.

11 Click OK.

You can also access and modify AEC dimension contents through the AEC
dimension’s context menu, as follows:

1 Select the AEC dimension you want to change, right-click, and
click Edit Object Display.

2 Click the Display Properties tab.

3 For the desired display representation, select Object Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 Click the Contents tab.

6 Adjust the settings as desired, and click OK twice.

Specifying the AutoCAD Style and Other Properties for an AEC
Dimension

Use this procedure to specify the AutoCAD dimension style underlying the
current AEC dimension style and to specify other display settings for an AEC
dimension in a particular display representation. These settings include:

■ Distance between dimension chains

■ Length of extension lines

■ Dimension layer
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■ Display of height of openings

1 Double-click the AEC dimension.

2 Click the Display tab.

3 Under the General category, for Display component, verify that
*NONE* is selected.

4 For Display controlled by, select This object.

NOTE To apply your changes to all AEC dimensions in the drawing,
select Drawing default setting. To apply changes to all AEC dimensions
of this style, select AEC Dimension Style:<style name>. For more
information on styles, see AEC Dimension Styles on page 3453.

5 For Display representation, verify that the desired display
representation is selected.

6 If necessary, expand Object Display Properties ➤ Advanced, and

click  Dimension settings.

7 To change the underlying AutoCAD dimension style of the AEC
dimension style, select an AutoCAD dimension style.

8 To edit the AutoCAD dimension style, click Edit.

For more information about AutoCAD dimension styles, see AEC
Dimension Styles and AutoCAD Dimension Styles on page 3453.

9 When you are finished editing the selected style, click OK.

10 Under AEC Dimension Settings, for Distance Between Chains,
enter the desired distance between the single dimension chains
in the AEC dimension.

Different distances between dimension chains

11 Specify whether you want fixed or variable extension lines.
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Fixed extension lines have the same length. Variable extension
lines adapt to the outline of the object they dimension. AutoCAD
dimensions use variable extension lines by default.

Fixed extension lines (left) and variable extension lines (right)

12 If you selected Use Fixed Length Extension Lines, enter the length
of the extension lines.

Different lengths of extension lines

13 Specify whether to display the height of openings.

NOTE This opening dimension is used specifically for European
working plans, where you need a detailed description of
measurements.

14 Click Layer to select the layer on which to place the AEC
dimension.

15 Click OK twice.

You can also access and modify these same settings through the AEC
dimension’s context menu, as follows:

1 Select the AEC dimension you want to change, right-click, and
click Edit Object Display.

2 Click the Display Properties tab.

3 For the desired display representation, select Object Override.
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The display representation in bold is the current display
representation.

4 If necessary, click  .

5 Click the Other tab.

6 Adjust the settings as desired, and click OK twice.

Attaching Hyperlinks, Notes, and Files to an AEC Dimension
Use this procedure to attach hyperlinks, text notes, and files to an AEC
dimension.

1 Double-click the AEC dimension to which to attach information.

2 Click the Extended Data tab.

3 To add a hyperlink, click the setting for Hyperlink, and specify
the link.

For more information about adding Hyperlinks, see “Add
Hyperlinks to a Drawing” the AutoCAD help.

4 Click the setting for Notes, and add a note. Then, click OK.

5 Click the setting for Reference Documents.

6 Attach or detach reference files:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

7 Click OK.
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AEC Dimension Styles
The AEC dimension style defines objects to dimension in the AEC dimension,
and the display of the AEC dimension.

You can create and edit AEC dimension styles, import and export AEC
dimension styles between drawings, and purge AEC dimension styles that are
not in use. When you create, purge, import, export, or edit styles, you access
the Style Manager. The Style Manager provides a central location in AutoCAD
Architecture where you can work with styles from multiple drawings and
templates. For more information about using the Style Manager, see Style
Manager Overview on page 870.

You can create an AEC dimension tool from any AEC dimension style. You
can drag the style from the Style Manager onto a tool palette. You can then
specify default settings for any AEC dimensions created from the tool. For
more information, see Creating an AEC Dimension Tool on page 3421.

AEC Dimension Styles and AutoCAD Dimension Styles
Every AEC dimension style has an underlying AutoCAD dimension style,
which controls settings that are not set directly in the AEC dimension style.

The AutoCAD dimension style defines the following properties:

■ Color of dimension lines and extension lines

■ Lineweight of dimension lines and extension lines

■ Shape and size of dimension arrowheads

■ Dimension text height and color

■ Units, precision, and decimal separator symbol

The AEC dimension style defines the following properties:

■ Number of dimension chains

■ Dimensioned objects

■ Distance between dimension chains

■ Fixed or variable extension lines

■ Display of opening height dimensions
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The AEC Dimension Style Wizard
There are two ways of editing a dimension style:

■ You can edit the dimension style in the Style Manager. The advantage of
this method is that you can edit all AEC dimension style settings here.

■ You can edit the dimension style with the AEC Dimension Style Wizard.
The advantage of this method is that you can edit the most important
display settings of the style in a fast and uncomplicated way. However,
you can not change all settings here; for example, the number of chains
and the objects to dimension can be edited only with the AEC Dimension
Styles Properties dialog box. For more information about the AEC
Dimension Style Wizard, see Changing Style Properties with the AEC
Dimension Style Wizard on page 3464.

Creating AutoCAD Dimension Styles
You need to create an underlying AutoCAD dimension style before you create
an AEC dimension style.

AutoCAD Architecture comes with a number of preset AutoCAD dimension
styles specifically designed for use in AEC dimensions. To save time, look at
these, to see if you can use them directly or with modifications.

To create an AutoCAD dimension style for use with AEC dimension styles, be
sure to specify the following settings:

■ Dimension line and extension line settings

■ Arrowhead settings

■ Text display settings

■ Unit settings

1 Click Home tab ➤ Annotation panel ➤  ➤ AEC Dimension

Style  .

2 In the Dimension Style Manager, click New.

3 Follow the instructions for creating a new AutoCAD dimension
style, as described in “Use Dimension Styles” in AutoCAD help.
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For more information about connecting the AutoCAD dimension style to an
AEC dimension style, see Selecting the AutoCAD Dimension Styles and Other
Properties of AEC Dimension Styles on page 3462.

Creating an AEC Dimension Style
Use this procedure to create an AEC dimension style. You can create a new
style with default style properties, or you can create a new style by copying
an existing style. After you create the style, you edit the style properties to
customize the characteristics of the style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand AEC Dimension
Styles.

3 Create a new AEC dimension style:

Then…If you want to…

right-click AEC Dimension Styles,
and click New.

create a new style with default
properties

right-click the AEC dimension style
you want to copy, and click Copy.
Right-click, and click Paste.

create a new style from an existing
style

4 Enter a name for the new AEC dimension style, and press ENTER.

5 To edit the style properties of your new AEC dimension style,
select the style and edit it in the Style Manager tabs:

Then…If you want to…

see Changing the AEC Dimension
Display Components on page 3457.

change the Layer/Color/Linetype
properties

see Changing the Number of
Chains in an AEC Dimension Style
on page 3456.

change the number of chains in an
AEC dimension style

see Specifying Object Dimension
Points in AEC Dimension Styles on
page 3460.

specify objects and points to dimen-
sion
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Then…If you want to…

see Selecting the AutoCAD Dimen-
sion Styles and Other Properties of
AEC Dimension Styles on page 3462.

change the AutoCAD dimension
style and other settings

see Changing Style Properties with
the AEC Dimension Style Wizard on
page 3464.

change an existing AEC dimension
style with the AEC Dimension Style
Wizard

see Attaching Notes and Files to an
AEC Dimension Style on page 3467.

add notes, files, or documents to
the style

6 When you have finished changing the AEC dimension style
properties, click OK.

7 If you want to assign the style to an AEC dimension tool, drag
the style from the Style Manager to a tool palette.

You can later rename the tool and specify other properties for it
as described in Creating an AEC Dimension Tool on page 3421.

8 Click OK.

Changing the Number of Chains in an AEC Dimension Style
Use this procedure to change the number of dimension chains in an AEC
dimension style.

To set the contents of chains, see Specifying Object Dimension Points in AEC
Dimension Styles on page 3460.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand AEC Dimension
Styles.

3 Select the style you want to edit.

4 Click the Chains tab.

5 Enter the number of dimension chains to define for this dimension
style.

6 Click OK twice.
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Changing the AEC Dimension Display Components
Use this procedure to change the properties of the display components of an
AEC dimension style.

The following AEC dimension display components are available:

Display components of AEC dimen-
sions

DescriptionComponent

Use this component only to turn the visib-
ility of an AEC dimension on or off for a

AEC Dimension Group

specific view. All the other settings, like
color, linetype, and lineweight are specified
in the underlying AutoCAD dimension
style; any changes you enter here are not
displayed.

This component shows removed associative
dimension points. Make it visible if you

Removed Points Marker

want to restore removed dimension points,
as described in Restoring Object Points Set
in the AEC Dimension Style on page 3430.

Marker of the dimension base point.AEC Dimension Group Marker

This component is displayed when a dimen-
sion segment is hidden or a dimension text

Override Text & Lines Marker

hidden or overwritten. For more informa-
tion, see Overriding Dimension Values and
Hiding Dimension Segments on page 3443.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand AEC Dimension
Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .
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7 Click the Layer/Color/Linetype tab.

8 Select the component to change, and select a different setting for
the property.

9 Click OK twice.

Defining Dimensioned Objects in the AEC Dimension Style
In an AEC dimension style, you can define points on objects that are
dimensioned associatively with this AEC dimension style. The points that are
available for each object are dependent on the object features. For example,
in a wall you can dimension length, width, wall components, and openings
in the wall. In a window, you can dimension the maximum and minimum
opening widths, and the window center.

For a complete list of objects that can be specified in the AEC dimension style,
see Associative Dimensions from Objects on page 3393.

Each AEC dimension can have up to ten dimension chains. Each chain can
contain dimension points for the objects specified in the style. For more
information, see Changing the Number of Chains in an AEC Dimension Style
on page 3456.

Example 1: You create an AEC dimension style that contains only one chain.
This chain contains wall lengths and wall intersections and the maximum
opening width of openings within the wall.

Single AEC dimension chain example

Example 2: You create an AEC dimension style designed exclusively to
dimension walls, but the wall dimension points are distributed on four
individual chains:

■ Chain 1 dimensions the wall lengths and the wall widths.

■ Chain 2 dimensions the wall lengths, wall widths and wall intersections.

■ Chain 3 dimensions only the wall lengths.

■ Chain 4 dimensions the outer boundaries of all selected walls.
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Four AEC dimension chains example

Example 3: You create an AEC dimension style that dimensions the length of
walls in a building on one chain, and a row of structural columns within the
building on a second chain.

Two AEC dimension chains example

The following guidelines can help you to create AEC dimension styles:

■ Create a separate dimension style for each use. For example, create a style
that dimensions window assemblies and curtain walls, and another one
that dimensions walls and openings in walls.

■ Do not include too many dimension points in one dimension chain.

■ Do not include too many objects within one dimension style.
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Specifying Object Dimension Points in AEC Dimension Styles
Use this procedure to specify the objects and points to be dimensioned
associatively in an AEC dimension style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand AEC Dimension
Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Contents tab.

Selecting the contents of dimension chains

Under Apply To, you find the list of objects that can be
dimensioned associatively.

Refer to Associative Dimensions from Objects on page 3393 for a
complete list of objects and their dimension points.

Below the Apply To list, you find the list of available chains in
this AEC dimension style.

For information on changing the number of chains, see Changing
the Number of Chains in an AEC Dimension Style on page 3456.
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8 For Apply To, select a object you want to dimension.

Example: In the first chain, you want to dimension the length of
walls and wall intersections. For Apply To, you select Wall.

9 Under Chains, select the chain on which the dimension points
appear.

Example: In the first chain, you want to dimension the length of
walls. In the previous step, you selected Wall. Now, you select
Chain 1.

NOTE “Selecting” in this context means highlighting the desired
chain, and not selecting the check mark. The check mark is set
automatically depending on whether dimension points for this chain
are selected. Example: If you clear all possible dimension points for
a chain, its check is automatically cleared.

10 On the right side, select the points to include in the highlighted
chain.

Example: In the first chain, you want to dimension the length of
walls and wall intersections. In the previous steps, you selected
Walls and highlighted Chain1. Now, you select the check box for
Length of Wall and choose Wall Length. Then, you select the
check mark for Wall Intersections.

NOTE Under Wall Width, you have two settings that override the
AEC dimension style settings for the dimensioning of wall
components: From Style and Structural from Style. If you select From
Style, the dimensioning of wall components is done according to the
settings in the wall style. If you select Structural from Style, the
dimensioning of wall components is done according to the settings
in the wall style, but takes into account only components that have
been marked as Structural in the wall style. For information on setting
the dimensioning of wall components in the wall style, see Defining
the Dimension Settings for Wall Components on page 1309.

11 Repeat steps 7–9 until your dimension contains all objects and
points you want to dimension with this style.

12 Click OK three times.
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Selecting the AutoCAD Dimension Styles and Other Properties
of AEC Dimension Styles

Use this procedure to select the AutoCAD dimension style underlying the AEC
dimension style and these other settings that affect the appearance of the AEC
dimension:

■ Distance between dimension chains

■ Length of extension lines

■ Dimension layer

■ Display of height of openings

NOTE Activating the display of the opening height takes effect only if you
select dimension points for openings in one or more chains of this dimension
style. For information on selecting opening dimension points, see Specifying
Object Dimension Points in AEC Dimension Styles on page 3460.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand AEC Dimension
Styles.

3 Select the style you want to edit.

4 Click the Display Properties tab.

5 Select the display representation where you want the changes to
appear, and select Style Override.

6 If necessary, click  .

7 Click the Other tab.

8 To change the underlying AutoCAD dimension style of the AEC
dimension style, select an AutoCAD dimension style.

9 To edit the AutoCAD dimension style, click Edit.

For more information about AutoCAD dimension styles, see AEC
Dimension Styles and AutoCAD Dimension Styles on page 3453.

To return to the Other tab in the Display Properties dialog box,
click Close.

10 Specify the distance between the single dimension chains in the
AEC dimension.
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Different distances between dimension chains

11 Specify whether you want fixed or variable extension lines.

Fixed extension lines have the same length. Variable extension
lines adapt to the outline of the object they dimension. AutoCAD
dimensions use variable extension lines by default.

Fixed extension lines (left) and variable extension lines (right)

12 If you select fixed extension lines, enter the length of the
extension lines.

Different lengths of extension lines

13 Specify whether to display the height of openings.

NOTE This opening dimension is used specifically for European
working plans, where you need a detailed description of
measurements.
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14 Click Layer to select the layer on which to place the AEC
dimension and click OK.

15 Click OK twice.

Changing Style Properties with the AEC Dimension Style Wizard
Use this procedure to change a number of AEC dimension style properties
with the help of a wizard. The AEC Dimension Style Wizard offers you a fast
way of changing these properties of a style:

■ Arrowhead shape and size

■ Length and color of extension lines

■ Color of dimension lines

■ Distance between dimension chains

■ Dimension text style, size, and color

■ Rounding-off value

■ Layer assignment

1 Click Manage tab ➤ Style & Display panel ➤  ➤ Dimension

Style Wizard  .
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2 Select the AEC dimension style to edit and click Next.

IMPORTANT If you choose a dimension style that has its property
source set to System Default, you get a warning message. If you want
to edit the style, close the Wizard, open the style in the Style Manager,
and set the display property source to a style override. For more
information about working with the Style Manager, see Style Manager
Overview on page 870.

3 Select the display representation to change.

NOTE If the AEC dimension style you choose to edit is based on the
same AutoCAD dimension style for different display representations,
the edits you make apply to all display representations. To avoid this,
make sure that the AEC dimension style uses different AutoCAD
dimension styles for different display representations. For more
information about assigning AutoCAD dimension styles to AEC
dimension styles, see Selecting the AutoCAD Dimension Styles and
Other Properties of AEC Dimension Styles on page 3462.

4 Specify line and arrow settings:

■ Select new arrowhead symbols.

■ Change the size of the arrowheads.

■ Define a new length for the extension lines.

■ Define a new distance between the individual dimension
chains.
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5 Click Next.

6 Specify text settings:

■ Select a new text style.

■ Enter a new text height.

■ Define a new round-off precision for dimension values.

7 Click Next.
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8 Specify Color and Layer settings:

■ Select a new text color.

■ Select a new dimension line color.

■ Select a new extension line color.

■ Select a new layer for the dimension.

9 Click Finish.

Attaching Notes and Files to an AEC Dimension Style
Use this procedure to attach text notes and files to an AEC dimension style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand AEC Dimension
Styles.

3 Select the style you want to edit.

4 Click the General tab.

5 To add a description to the AEC dimension style, enter the
description under Description.

6 Click Notes.

7 To add a note, click the Notes tab, and enter the note.
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8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Edit
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application. Click OK
when you are done editing.

edit a reference file

select the file name, click Delete,
and click OK.

detach a reference file

9 Click OK twice.

Q and A for Working with AEC Dimensions
This topic contains questions and answers that can help you to achieve the
results you want when working with AEC dimensions.

Changing Color, Text Size and Arrowheads
How do I change the color, text size, and arrowheads of an AEC dimension?

Those settings are specified in the AutoCAD dimension style that underlies
the AEC dimension style. To access them easily, use the AEC Dimension Style
Wizard. For more information, see The AEC Dimension Style Wizard on page
3454.

Updating AEC Dimensions On Demand
How can I specify that AEC dimensions are updated only on demand?

If you freeze the layer on which an AEC dimension is placed, the AEC
dimension is updated only when the layer is thawed again or if you execute
the REGEN command.

When you switch to another view, for example, a three-dimensional (3D)
view, and then back to a Plan view, the AEC dimension is not updated. Freezing
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the dimension layer can enhance drawing performance, especially for big
drawings.

You can add new AEC dimensions even when the layer is frozen. However,
you can edit them only after the layer has been thawed again.

Changing the Text Height of Superscripted Numbers
How can I change the text height of superscripted numbers in an AEC
dimension?

By default, the text height of superscripted numbers in AEC dimensions is set
to 50 percent of the text height of the underlying AutoCAD dimension style
(DIMTXT). To change this default, you must change the corresponding value
in the Registry file.

WARNING Making changes in the Registry file can have far-reaching consequences
for the whole application. Before you change anything here, make sure that this
is what you really want to do. If you are not sure, consult your CAD manager or
IT department.

1 Open the Windows Registry Editor.

2 Navigate to
HKEY_LOCAL_MACHINE\SOFTWARE\Autodesk\AutoCAD\R18.0\ACAD-8004:409\AEC\6.0\AecArchDACHBase60\ObjectDefaults\AEC
Dimension\SuperscriptScaleFactor.

3 Enter the desired value. The value here is relative to the AutoCAD
dimension text height (DIMTXT).

Fixing the Error Symbol
The AEC dimension for a wall 1 meter high is displayed only with an error
symbol. How can I get a correct dimension display?

The cut plane of the AEC dimension is taken from the cut plane of the
dimensioned wall in the current display configuration. If the cut plane is set
to a higher value, you must change it to include the lower wall into the
dimension. For information on setting the wall cut plane, see Specifying the
Cut Plane Display of a Wall Style on page 1319.
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Finding More Dimension Points than Expected
I am dimensioning the intersection points of walls and receive more
dimension points than expected on the dimension. How can I check if this
dimension is correct?

When you receive more wall intersection dimension points than you expect,
it is possible that the walls you are dimensioning intersect with other walls
that are not included in this dimension chain. To see if this is so, and if your
dimension is correct, you can prolong the extension lines so that they actually
meet the point they dimension. You can then verify that the dimension points
on your chain are placed correctly.

3470 | Chapter 44   AEC Dimensions



Elevation Labels

Elevation labels are used to dimension height values in plan and section views.

Elevation Labels
Elevation labels are used to dimension height values in plan and section views.

Elevation Labels and Coordinate Systems

Elevation labels are interactive multi-view blocks used for dimensioning heights
in a drawing. They are anchored to either the world coordinate system (WCS)
or a named user coordinate system (UCS). Elevation labels are used primarily
for measuring the heights of building elements like walls or windows, but they
can be used to measure every point in your drawing. You can add elevation
labels in plan and section views. AutoCAD Architecture offers a number of
predefined blocks for commonly used elevation labels. You can also define your
own elevation labels.

When elevation labels are moved along the Z-axis, their Z-values change
accordingly. Elevation labels can, however, be anchored only to a named UCS
or the WCS; not to any building object. If the object height is changed, the
value of the elevation label is not updated automatically.

An elevation label measures the height of a point with relation to the reference
height. The reference height can be taken from the Z-coordinate of the WCS or
the Z-coordinate of a named UCS.

45
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Elevation labels

Using Elevation Label Tools to Create Elevation Labels
Tools provided with AutoCAD Architecture let you quickly place elevation
labels using an elevation label tool with specific predefined properties. You
can use the default settings of the tool, or you can change the properties.

Tool palette containing elevation label tools

The default tool palettes in the workspace contain sample elevation label tools
that you can use and customize as needed. In addition, the following catalogs
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provided with the software contain elevation label tools that you can add to
your tool palettes:

■ Stock Tool catalog

■ AutoCAD Architecture Sample Palette catalog

■ My Tool catalog

Custom palettes created by your CAD manager or other users may also contain
elevation label tools with multi-view block definitions and properties that are
customized for your projects or office standards.

Creating an Elevation Label
Use this procedure to add a new elevation label that has the properties specified
in the elevation label tool that you select. To specify settings when you add
an elevation label, see Creating Elevation Labels with User-Specified Settings
on page 3473.

1 Click Annotate tab ➤ Tools panel ➤ Annotation Tools  .

2 Select an elevation label tool.

If necessary, scroll to display the tool that you want to use.

3 Specify the insertion point of the elevation label.

You can move or hide the Properties palette to expose more of
the drawing area.

4 Click OK.

Creating Elevation Labels with User-Specified Settings
Use this procedure to add an elevation label with settings that you specify.

1 Click Annotate tab ➤ Tools panel ➤ Annotation Tools  .

2 Select an elevation label tool.

If necessary, scroll to display the tool that you want to use.

3 In the drawing area, specify the insertion point of the elevation
label.
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You can move or hide the Properties palette to expose more of
the drawing area.

The Add Elevation Label dialog is displayed.

4 Select the coordinate system for the elevation label:

Then…If you want to…

under UCS, select the coordinate
system from the list.

select an existing coordinate system
from the drawing

click  (Define UCS), and define
the new UCS on screen. For more

create a new named user coordin-
ate system (UCS)

information about creating user
coordinate systems, see “Use Co-
ordinates and Coordinate Systems”
in AutoCAD help.

TIP The quickest way to locate
and view an AutoCAD topic
referenced in AutoCAD Architec-
ture Help is to click the Search
tab in the Help window, select
the Search titles only option,
and then copy and paste or
type in the AutoCAD topic
name, and click List Topics.

click  (Match UCS) and select
the elevation label on screen.

use the UCS of an existing elevation
label

5 Enter the elevation value of your label.

The value you enter here is always calculated in relation to the
coordinate system you have selected. When you redefine the
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coordinate system, the Z-value of the elevation label is recalculated
accordingly.

For example, you have a UCS named “First Floor,” with its Z-origin
at 3 m. When you insert an elevation label in WCS and set it to
2 m, and then change the coordinate system to “First Floor” the
Z-value of the elevation label is changed to -1 m.

6 If necessary, enter a prefix and suffix for the elevation label.

7 Click OK.

Creating an Elevation Label Tool
Use this procedure to create an elevation label tool and add it to a tool palette.
You may want to create your own elevation label tools if you are placing
multiple elevation labels of a specific style and they all have the same
properties.

Elevation labels consist of a multi-view block definition connected to a custom
AEC command. Therefore, the process of creating an elevation label tool differs
from the process of creating a regular object tool, like a door tool.

To create an elevation label tool, you need a multi-view block definition with
a custom command that is placed in DesignCenter™. Predefined elevation
labels are available in DesignCenter, so check to see if the desired elevation
label is already there.

If you find no elevation label meeting your needs, create one, as described in
Creating User-Defined Elevation Labels on page 3481, and place it into AutoCAD
DesignCenter.

From AutoCAD DesignCenter, you create an elevation label tool.

1 Click Insert tab ➤ Content panel ➤ Content Browser

drop-down ➤ Design Center  .

2 Navigate to the folder containing the elevation label from which
you want to create a tool.

3 Open the tool palette on which you want to add the elevation
label tool.
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4 Create the tool:

Then…If you want to…

drag the desired elevation label
from the AutoCAD DesignCenter
to the tool palette.

create a tool from the AutoCAD
DesignCenter

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

right-click the tool, and click Copy.
Reopen the tool palette where you

copy a tool from another tool
palette

want to add the tool, right-click,
and click Paste.

Click Home tab ➤ Build pan-

el ➤ Tools drop-down ➤ Content

copy a tool from a tool catalog in
the Content Browser

Browser , open the catalog and
locate the tool you want to copy.
Position the cursor over the i-drop
handle, and drag the tool to the
tool palette.

5 Right-click the new tool, and click Properties.

6 Enter a name for the tool.

7 Click the setting for Description, enter a description of the tool,
and click OK.

Modifying Elevation Labels
You can change the attributes of an elevation label, such as the associated
UCS or the scaling factor.

■ You can change elevation label settings on the Properties palette.

■ You can select editing commands from the contextual ribbon tab and
shortcut menu for a selected elevation label.
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Changing the Elevation of an Elevation Label
Use this procedure to change the value for the elevation of an elevation label.

The value of an elevation label is always calculated in relation to the coordinate
system of the label.

1 Select the elevation label you want to change, right-click, and
click Elevation Label Modify.

2 Enter the new elevation value.

3 Click OK.

Changing the Coordinate System of an Elevation Label
Use this procedure to change the coordinate system of an elevation label.

For more information on how elevation labels are dependent on coordinate
systems, see Elevation Labels on page 3471.

1 Select the elevation label you want to change, right-click, and
click Elevation Label Modify.

2 Select a new coordinate system for the elevation label from the
list.

3 Click OK.

Changing the Associated Multi-View Block Definition
Use this procedure to change the multi-view block definition associated to an
elevation label. For information about multi-view block definitions and
elevation labels, see Creating User-Defined Elevation Labels on page 3481.

1 Select the elevation labels you want to change, and click Home

tab ➤ Build panel ➤ Tools drop-down ➤ Properties  .

NOTE Alternatively, right-click and choose Properties.

2 On the Properties palette, expand Basic, and expand General.

3 Select a different multi-view block definition for Definition.
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Changing the Scale Factor of an Elevation Label
Use this procedure to change the scale factor of an elevation label.

1 Select the elevation labels you want to change, and click Home

tab ➤ Build panel ➤ Tools drop-down ➤ Properties  .

NOTE Alternatively, right-click and choose Properties.

2 On the Properties palette, expand Basic, and expand Scale.

3 Change the scale factor of the elevation label:

Then…If you want to…

enter a new value for X.change the X scale factor

enter a new value for Y.change the Y scale factor

enter a new value for Z.change the Z scale factor

Changing the Offset of an Elevation Label
Use this procedure to change the offset of the elevation label from its insertion
point.

When you add an elevation label to a drawing, the offset value is set to 0. You
can change the position of the elevation label in the drawing by offsetting it
from its original insertion point.

1 Select the elevation label you want to change and click Home

tab ➤ Build panel ➤ Tools drop-down ➤ Properties  .

NOTE Alternatively, right-click and choose Properties.

2 On the Properties palette, expand Advanced.

3 Click  next to Insertion Offsets.

4 Select the view block for the appropriate view. For example, to
change the offset in Plan 1:100, select a view block to indicate
that it belongs to that view (for example, ElevationLabel100).
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5 Change the offset of the elevation label from its insertion point:

Then…If you want to…

enter a new value for X offset.change the offset from the X inser-
tion point

enter a new value for Y offset.change the offset from the Y inser-
tion point

enter a new value for Z offset.change the offset from the Z inser-
tion point

6 Click OK.

Display the View Blocks and Attributes of an Elevation Label
Use this procedure to display the blocks and attributes contained in an
elevation label.

An elevation label is created from a multi-view block definition which, in
turn, is built from blocks and attributes. You can display the blocks and
attributes to understand how the label is structured.

1 Select the elevation label for which to display blocks and
attributes, and click Home tab ➤ Build panel ➤ Tools

drop-down ➤ Properties  .

NOTE Alternatively, right-click and choose Properties.

2 On the Properties palette, expand Advanced.

3 Click  next to Attributes.

In the Multi-view Block Attributes worksheet, the blocks from
which your elevation label is composed are displayed.

The list on the right shows the attributes of the blocks and their
current values.

For more information about multi-view blocks, blocks, and
attributes, see Creating User-Defined Elevation Labels on page 3481.
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NOTE Although you can edit the values in the list, those modifications
are not applied; your modified values are overwritten by the values
the elevation label gets from its coordinate system.

4 Click OK.

Attaching Hyperlinks, Notes, or Files to an Elevation Label
Use this procedure to attach hyperlinks, text notes, and files to an elevation
label.

1 Select the elevation label to which you want to attach information,
and click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties

 .

NOTE Alternatively, right-click and choose Properties.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click  next to Hyperlink, and specify the
link.

For more information, see “Add Hyperlinks to a Drawing” in
AutoCAD help.

4 Click  next to Notes, add a note, and then click OK.

5 Click  next to Reference Documents.

6 Attach or detach reference files:

Then…If you want to…

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file
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Then…If you want to…

select the file name, and click 
.

detach a reference file

7 Click OK.

Creating User-Defined Elevation Labels
The AutoCAD Architecture templates provide a number of predefined elevation
labels.You may, however, want to create specific labels that are not included
in any of the templates.

You can choose attributes for your own elevation labels, combine them into
blocks, and create elevation labels from them.

Process Overview: Creating User-Defined Elevation Labels

Creating a user-defined elevation label consists of these basic steps:

1 Determine the location of the property set definition of the custom label.

2 If necessary, create a new property set definition to use in the custom
label.

3 Create a graphic symbol.

4 Add attributes from the property set definition to the drawing.

5 Create a block from the attributes.

6 Create a multi-view block from the block.

7 Add the elevation label to DesignCenter™.

Creating a Graphic Symbol
Elevation labels usually consist of a graphic symbol and attributes that define
elevation height and other information.

You can create a graphic symbol with any of the drawing commands in
AutoCAD, or you can import a symbol from another drawing or from a symbol
library.
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For information about drawing objects in AutoCAD, see “Create and Use Blocks
(Symbols)” in AutoCAD help.

Adding Attributes
Use this procedure to add attributes to an elevation label.

An elevation label usually contains attributes for displaying the elevation,
prefixes, and suffixes.

Elevation label attributes come from a property set definition. Predefined
attributes are available when you start with one of the templates, or when
you start from scratch and drag a predefined elevation label from
DesignCenter™ into the drawing.

Elevation label attributes 

DescriptionAttribute/Tag

Displays the height of an elevation label in
relation to the coordinate system chosen.

ELEVATION

Displays the millimeters of the elevation
value in superscript. You need this attribute
only when working with metric units.

ELEVATION:MM

To enter a prefix for the elevation label,
you must add this attribute. For more in-

PREFIX

formation about entering prefixes, see
Creating Elevation Labels with User-Spe-
cified Settings on page 3473.

To enter a suffix for the elevation label, you
must add this attribute. For more informa-

SUFFIX

tion about entering suffixes, see Creating
Elevation Labels with User-Specified Set-
tings on page 3473.

To use different attributes in elevation labels, create your own Property Set
Definition for elevation labels. For more information, see Property Set
Definitions on page 3823.

1 Click Insert tab ➤ Attributes panel ➤ Define Attributes  .
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2 For Tag, enter one of the attributes from the table. For example,
to create an attribute for the height of the elevation, enter
-ELEVATION.

3 Proceed with creating the attribute. For more information, see
“Attach Data to Blocks (Block Attributes)” in AutoCAD help.

4 Repeat steps 1–3 for each attribute you want to add to the
elevation label.

Creating a Block
Use this procedure to create a block from the attributes you have created.

1 Click Insert tab ➤ Block panel ➤ Create Block  .

2 Enter a name for the block.

3 Click Select Objects, and select the graphic symbol and the
attributes to include in the elevation label.

4 For Insert Units, select Unitless.

5 Proceed with creating the block as described in “Block Definition
Dialog Box” in AutoCAD help.

Creating a Multi-View Block
Use this procedure to create a multi-view block for the elevation label.

For detailed information about multi-view blocks, see Multi-View Blocks on
page 2891.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Multi-View Block
Definitions.

3 Right-click Multi-View Block Definitions, and click New.

4 Enter a name for the new multi-view block definition.

5 Select the new multi-view block definition.

6 Click the View Blocks tab.

7 Select a display representation for the elevation label.

8 Click Add.

9 Select the block you defined in Creating a Block on page 3483, and
click OK.
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10 Select the view directions for the block.

11 Repeat steps 6–9 for each display representation where you want
the elevation label to display.

12 Click OK.

Adding the Elevation Label to the AutoCAD DesignCenter
Use this procedure to add user-defined elevation labels to DesignCenter.

To add the elevation label to AutoCAD DesignCenter, you need to create a
DWG file in the AEC Content Wizard. For a detailed description of the AEC
Content Wizard, see Using the AEC Content Wizard on page 3917.

1 On the command line, enter AecCreateContent.

2 Select Custom Command.

3 Select the multi-view block you created in Creating a Multi-View
Block on page 3483, and click Add to add it to the Content File.

4 For the Command string, enter AecAnnoScheduleTagAdd,
followed by a space and then the name of the multi-view block,
and its parameters. The command is built as follows:

_AecAnnoScheduleTagAdd <name of the drawing containing the
property set definition>.dwg _SYMBOL <name of the multi-view
block created> _LEADER _None _DIMSTYLE _Current

In our example, the custom command could look like this:

_AecAnnoScheduleTagAdd ElevationLabelPropertySetDefs.dwg
_SYMBOL ElevationLabelMVBlock _LEADER _None _DIMSTYLE
_Current

5 Click Next.

6 Select Enable AEC Unit Scaling.

7 Select a layer key for the label.

NOTE The default layer key for elevation labels is DIMLINE.

8 Click Next.

9 Enter a file name and a folder for the label.
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NOTE Be sure to save the custom label in a folder one level below
the used property set definition drawing. If the property set definition
drawing is saved in C:\ProgramData\Autodesk\ACA 2012\enu\AEC
Content\Metric\Documentation\Elevation Labels, then the custom label
could be saved in C:\ProgramData\Autodesk\ACA 2012\enu\AEC
Content\Metric\Documentation\Elevation Labels\Custom Labels.

10 Click Finish.
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Fields

A field is a multiline text object consisting of a field name and a field value which can be
automatically updated to show the latest value for data that may change during the lifecycle
of the project. Fields enhance the documentation capabilities within a drawing file and add
value to the drawing data.

Fields Overview
Fields are updatable data units within an AutoCAD Architecture drawing. Fields
can be entered into the drawing as standalone multi-text elements, as
components of AutoCAD text elements or table cells, as attribute values or as
part of AutoCAD Architecture property set data. You can choose from a number
of field types specific to architectural processes and tasks. For a complete list,
see AutoCAD Architecture Field Types on page 3505.

You can update field values on demand or specify various automatic update
mechanisms, for example updating a field when the drawing is opened or saved.

For detailed information about AutoCAD field types, see “Use Fields in Text”
in AutoCAD help.

TIP The quickest way to locate and view an AutoCAD topic referenced in AutoCAD
Architecture Help is to click the Search tab in the Help window, select the Search
titles only option, and then copy and paste or type in the AutoCAD topic name,
and click List Topics.

You can use fields in the following drawing components:

AutoCAD Text Elements

You can insert fields into AutoCAD text, multi-line text, table cells and attributes.
When you insert fields in attributes, you can create interactive annotation that
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displays sheet numbers, project details, and other important information. For
an example, see Creating New Callout Tools on page 3732.

Property Set Data

Fields can be inserted in property set data. You can insert a field into a property
set definition, thereby adding it to any object or object style to which the
property set is attached. You can also insert a field in any manual property
attached to an object or style, using the manual property as a placeholder for
the field.

Property set data can be used to create schedule tables of objects and drawings,
or to build tags, annotation, and other content. Schedule reports can be placed
in an AutoCAD Architecture drawing, or they can be exported to XLS,
tab-delimited text, or comma-separated text.

Annotation Tools

AutoCAD Architecture provides a number of predefined annotation tools that
use different kinds of fields. For example, keynote tools use keynote fields,
while callout tools use sheet set fields.

You can also use fields to create your own annotation tools. For an example,
see Creating New Callout Tools on page 3732.
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Callout tools in AutoCAD Architecture

Inserting Fields
Fields can be inserted directly into drawings, or as components of other
elements. When a field is inserted directly, it is entered as a multiline text
element. You can also insert it in existing text and multiline text, tables cells,
attributes, and property set definitions.

Inserting Fields in a Drawing
You can create field anywhere in a drawing. When a field is inserted directly,
and not within another element, it is created as a multiline text element.
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1 Click Annotate tab ➤ Text panel ➤  ➤ Field.

2 Select a field category to choose from.

3 Select a field, and if necessary, specify additional information
regarding this field.

For example, if you want to insert a Plot Date field, you need to
specify the date format.

4 Click OK.

5 Insert the field in the drawing.

Then…If you want to…

click where the field should be inserted in
the drawing area.

insert the field directly

enter h (Height) on the command line and
press Enter. Enter the new height and press

change the height of the
field

Enter again. Then, select the insertion
point.

enter j (Justify) and press Enter. Enter the
combination for the desired orientation,

change the orientation of
the preview cursor,
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Then…If you want to…

and press Enter. Then, select the insertion
point.

Date field inserted in drawing

Inserting Fields in Property Set Definitions
Use this procedure to insert a field in a property set definition.

When you insert a field in a property set definition, the field will appear in
the properties of any object or object style that has the property set attached.

NOTE Fields are always contained in manual properties.

Wall properties with keynote, date, and sheet number fields

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 In the Style Manager, expand Documentation Objects, and then
expand Property Set Definitions.

3 Either click an existing property set definition, or right-click, and
click New.
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4 Click the Definition tab.

5 Click  to create a manual property.

6 Enter a name for the manual property, such as Keynote.

7 Verify that DEFAULT is selected for Start With.

8 Click OK.

9 Verify that Text is selected for Type.

10 Right-click in the Default field, and select Insert Field.
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11 Define and insert the field and its format.

Then…If you want to insert a …

see “Use Fields in Text” in AutoCAD
help.

date/time, document, hyper-
link, object, system variable,
Diesel expression, or plot field

see Selecting a Project Field on page
3506.

project field

see Selecting a Sheet Set Field on page
3510.

sheet set field

see Selecting a Keynote Field on page
3513.

keynote field

see Selecting a Database Field on page
3516.

database field
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Inserting Field Placeholders in Object Properties
Use this procedure to insert a field placeholder in the properties of an
individual object.

You can add a field to the properties of an individual object by creating a
manual property as a placeholder for the field, to be filled when necessary.
This would be useful if you want to add information that is different for each
object and needs to be updatable.

Creating the placeholder

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 In the Style Manager, expand Documentation Objects, and then
expand Property Set Definitions.

3 Either click an existing property set definition, or right-click, and
click New.

4 Click the Definition tab.

5 Click  to create a manual property.

6 Enter a name for the manual property, such as LinkedFile.

7 Verify that DEFAULT is selected for Start With.

8 Click OK.

9 Verify that Text is selected for Type.

NOTE Do not enter any text in the Default field.

10 Click OK.

Inserting a field in the placeholder

11 Double-click the object in the drawing, and on the Extended Data

tab of the Properties palette, click  .

12 Select the property set containing the manual property, and click
OK.
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13 Right-click in the empty manual property, and click Insert Field.

14 Define and insert the field and its format.

Then…If you want to insert a…

see “Use Fields in Text” in AutoCAD
help.

date/time, document, hyper-
link, object, system variable,
Diesel expression, or plot field

see Selecting a Project Field on page
3506.

project field

see Selecting a Sheet Set Field on page
3510.

sheet set field

see Selecting a Keynote Field on page
3513.

keynote field

see Selecting a Database Field on page
3516.

database field

15 Define and insert the field and its format.

Then…If you want to…

see “Use Fields in Text” in AutoCAD
help.

insert a date/time, document,
hyperlink, object, system vari-
able, Diesel expression, or plot
field,

Inserting Field Placeholders in Object Properties | 3495



Then…If you want to…

see Selecting a Project Field on page
3506.

insert a project field

see Selecting a Sheet Set Field on page
3510.

insert a sheet set field

see Selecting a Keynote Field on page
3513.

insert a keynote field

see Selecting a Database Field on page
3516.

insert a database field

In this example, you would likely insert a hyperlink to another
file. selecting Linked for Field category and then selecting a file
as the hyperlink.

Adding Fields to Object Style Properties
Use this procedure to add fields to object style properties.

Once a field has been inserted into a property set, you can add the field to an
object style by attaching the property set to the style. All objects of that style
will then have the property set attached.

1 Create a property set definition containing the necessary fields,
as described in Inserting Fields in Property Set Definitions on page
3491.

2 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

3 In the Style Manager, expand Architectural Objects, and expand
the object type for which you want to add a field.

4 Click an existing object style.

5 Click the General tab, and click Property Sets.

6 Click click  .

7 Select the property set that contains the field.

8 Click OK three times.
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NOTE You can view and edit the style property set data on the
object’s Properties palette, just like the object property set data. To
edit property set data from a style on the Properties palette, click the

worksheet button (  ).

Inserting Fields in AutoCAD Text Elements
You can insert fields in the following types of AutoCAD text elements:

■ Text

■ Multiline text (mtext)

■ Attributes

■ Table cells

Inserting Fields in AutoCAD Text
Use this procedure to insert fields into AutoCAD text elements.

For information on creating text elements, see “Create Single-Line Text” in
AutoCAD help.

1 Select the AutoCAD text in which you want to insert a field.

2 Right-click, and click Text Edit.

3 Right-click at the point within the text where you want to insert
a field, and click Insert Field.

4 Define the field and its format.

Then…If you want to insert a …

see “Use Fields in Text” in AutoCAD
help.

date/time, document, hyper-
link, object, system variable,
Diesel expression, or plot field

see Selecting a Project Field on page
3506.

project field

see Selecting a Sheet Set Field on page
3510.

sheet set field
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Then…If you want to insert a …

see Selecting a Keynote Field on page
3513.

keynote field

see Selecting a Database Field on page
3516.

database field

5 Click OK.

Inserting Fields in AutoCAD Multiline Text
Use this procedure to insert fields into AutoCAD multiline text.

For information on creating Multiline text elements, see “Create Multiline
Text” in AutoCAD help.

1 Select the AutoCAD multiline text in which you want to insert a
field.

2 Right-click, and click Mtext Edit.

3 In the Multiline Text Editor, right-click within the Text at the
point where you want to insert the field, and click Insert Field.

NOTE Alternativly, click within the Text at the point where you want
to insert the field, and click Text Editor tab ➤ Insert panel ➤ Field.

4 Define the field and its format.

Then…If you want to insert a …

see “Use Fields in Text” in AutoCAD
help.

date/time, document, hyper-
link, object, system variable,
Diesel expression, or plot field

see Selecting a Project Field on page
3506.

project field

see Selecting a Sheet Set Field on page
3510.

sheet set field

see Selecting a Keynote Field on page
3513.

keynote field
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Then…If you want to insert a …

see Selecting a Database Field on page
3516.

database field

5 Click OK.

Inserting Fields in AutoCAD Attributes
Use this procedure to insert fields into AutoCAD attributes.

Attributes are often used to provide design and documentation content for
tools. When combined with graphics, they can be used as annotation symbols.

Field attributes in callout symbol

1 Click Insert tab ➤ Attributes panel ➤ Define Attributes.

2 Enter a name in the Tag field.
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3 Under Value, click  .

4 Define the field and its format.

Then…If you want to insert a …

see “Use Fields in Text” in AutoCAD
help.

date/time, document, hyper-
link, object, system variable,
Diesel expression, or plot field

see Selecting a Project Field on page
3506.

project field

see Selecting a Sheet Set Field on page
3510.

sheet set field

see Selecting a Keynote Field on page
3513.

keynote field

see Selecting a Database Field on page
3516.

database field

5 Click OK.
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Inserting Fields in AutoCAD Table Cells
Use this procedure to insert fields into AutoCAD table cells.

For information on creating AutoCAD tables, see “Create and Modify Tables”
in AutoCAD help.

1 Select the AutoCAD table cell in which you want to insert a field,
and double-click it.

2 Right-click, and click Insert Field.

NOTE Alternatively, click Table Cell tab ➤ Insert panel ➤ Field.

3 Define the field and its format.

Then…If you want to insert a…

see “Use Fields in Text” in AutoCAD
help.

date/time, document, hyper-
link, object, system variable,
Diesel expression, or plot field

see Selecting a Project Field on page
3506.

project field

see Selecting a Sheet Set Field on page
3510.

sheet set field

see Selecting a Keynote Field on page
3513.

keynote field

see Selecting a Database Field on page
3516.

database field

4 Click OK.

Editing Fields
Use this procedure to edit a field.

Fields can be contained in AutoCAD text, multiline text (mtext), table cells,
attributes, property set definitions, object properties, and object styles. For
information on inserting fields, see Inserting Fields on page 3489.
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When you edit a field, you can change the field value, the field category, and
the field format.

1 Navigate to the field you want to edit.

Then…If you want to…

select the text element, right-click, and click
Text Edit. Then, select the field, right-click,
and click Edit Field.

edit a field in AutoCAD
text

select the multiline text element, right-click,
and click MText Edit. In the Multiline Text

edit a field in multiline
text

Editor, select the field, right-click, and click
Edit Attribute.

select the tool or block containing the attrib-
ute field, right-click, and click Edit Attributes.

edit a field in an attribute

In the Enhanced Attribute Editor, select the
field value, right-click, and click Edit Field.

select the table cell, and double-click it. Then,
right-click the field, and click Edit Field.

edit a field in a table cell

open the property set definition in Style
Manager, and click the Definition tab. Select

edit a field in a property
set definition

the field property. Right-click the field value
in the Default field, and click Edit field.

open Style Manager and open the style. On
the General tab, click Property Sets. In the

edit a field in an object
style

Edit Property Set Data worksheet, select the
field value you want to change, right-click,
and click Edit Field.

select the object and double-click it. In the
Properties palette, click the Extended Data

edit a field in the proper-
ties of an object
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Then…If you want to…

tab. Select the field value you want to change,
right-click, and click Edit field.

2 Change the field as necessary.

The editable parameters of a field vary depending on the type of
field. In date related fields, for example, you can change the date
format of the field.

Then…If you want to…

select a new the category under Field
category, and then select a new field
under Field name.

change the field category

select a new field under Field name.change the field

select a different format under Format.change the field formatting

3 Click OK.
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Editing the Field Display
You can choose if you want to display a field in your drawing with a grey
background rectangle or with a transparent background. A grey background
helps you identify field values within your drawings easily. In some cases
however when you want to display the field value just like other text or
attribute values, you can turn off the grey background.

Field display with grey background (left) and transparent (right)

1 On the command line, enter FIELDDISPLAY.

2 Select a value for the display of field backgrounds.

■ To display the background of a field value in grey, enter 1.

■ To display the background of a field value as transparent, enter
0.

TIP By default the field display value is set to 1.

Updating Fields
Use this procedure to update a field manually.

By default fields are updated automatically when the drawing is opened, saved,
plotted, regenerated, or sent via e-transmit. For more information, see “Update
Fields” in AutoCAD help.

If you have changed that default, or want to update a field without performing
any of the operations listed above, you can do so by updating the field
manually.

1 Navigate to the field you want to update.

Fields can be contained in AutoCAD text, multiline text (mtext),
table cells, attributes, property set definitions, object properties,
object styles., and project details. For information about inserting
fields in text components, see Inserting Fields on page 3489.
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2 Select the field, and double-click the text. Then, select the text,
right-click, and click Update Field.

TIP To update all fields in the drawing, click Annotate tab ➤ Text

panel ➤  ➤ Update Fields. Then, select the fields to update and
press ENTER.

Converting Fields to Text
Use this procedure to convert a field to text.

NOTE This procedure cannot be reversed.

1 Navigate to the field you want to convert to text.

Fields can be contained in AutoCAD text, multiline text (mtext),
table cells, attributes, property set definitions, object properties,
object styles, and project details. For information about inserting
fields in text components, see Inserting Fields on page 3489.

2 Select the field, right-click, and click Convert Field to Text.

AutoCAD Architecture Field Types
There are a number of field types that have been created specifically for
AutoCAD Architecture users. These fields are generated by information from
AutoCAD Architecture projects, keynotes, and databases connected to an
AutoCAD Architecture drawing.

Project Fields
AutoCAD Architecture has a number of fields for project-specific information.
You could use project fields for example in title blocks on plotting sheets.

The following project-specific fields are available in AutoCAD Architecture:

■ Project Name

■ Project Number

■ Project Description
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■ Project Location

■ Project Details: When you create a project, you can create user-defined
detail categories and details relevant to the project. These details can be
inserted as fields into the drawing. For information on creating project
details, see Adding Detailed Information to Project Properties on page 337.

■ Number of Levels

■ Number of Divisions

Selecting a Project Field
Use this procedure to select a project field to insert into a drawing.

1 Open the Field dialog box from one of the following components:

Then…If you want to…

see Inserting Fields in AutoCAD Text Ele-
ments on page 3497.

insert a project field into a
text element

see Inserting Fields in AutoCAD Multiline
Text on page 3498.

insert a project field into a
multiline text (mtext) ele-
ment

see Inserting Fields in AutoCAD Table Cells
on page 3501.

insert a project field into an
AutoCAD table cell

see Inserting Fields in AutoCAD Attributes
on page 3499.

insert a project field into an
attribute definition

see Inserting Fields in Property Set Defini-
tions on page 3491.

insert a project field into a
property set definition

see Inserting Field Placeholders in Object
Properties on page 3494.

insert a project field into an
object property

see Adding Fields to Object Style Properties
on page 3496.

insert a project field into an
object style
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2 Under Field Category, select AEC Project.

Under Field Names, all project-related fields are displayed.

3 Select the field you want to insert.

4 If you have selected Project Details, you need to select the detail
from the categories listed under Project Information.

5 Under Format, select a text format for the field. You can choose
between Uppercase, Lowercase, First Capital, and Title case.

6 Click OK.

Sheet Set Fields
AutoCAD Architecture has a number of fields for sheet set information.

NOTE Sheet set fields can be used for AutoCAD Architecture project sheet sets
and for AutoCAD sheet sets. For information about AutoCAD Architecture project
sheet sets, see Sheets on page 481. For information about AutoCAD sheet sets, see
“Work with Sheets in a Sheet Set” in AutoCAD help.

Sheet Set Fields | 3507



The following sheet set fields are available:

■ Current Sheet Custom: You can select an AutoCAD custom property defined
for the current sheet here.

NOTE When you are working with an AutoCAD Architecture project sheet set,
you will in most cases use Project Details instead of Custom Properties.

■ Current Sheet Description

■ Current Sheet Number

■ Current Sheet Number and Title

■ Current Sheet Set

■ Current Sheet Set Custom: You can select an AutoCAD custom property
defined for the current sheet here.

■ Current Sheet Set Description

■ Current Sheet Subset

■ Current Sheet Title

■ Sheet Set: You can select any sheet from a sheet set as the field content
here. Available sheet properties for display are the sheet title, sheet number
and sheet description.

■ Sheet Set Placeholder: In the Sheet Set Placeholder field category, you can
define a field as a placeholder for sheets and sheet views. You often use
that functionality in callouts referenced to model space views, that are
later referenced into sheets. The field placeholder in the callout is resolved
when the model space view is linked into a sheet. For more information,
see Creating New Callout Tools on page 3732. The following fields are
available as placeholders:

■ Sheet Number and Title

■ Sheet Title

■ Sheet Number

■ Sheet Description

■ Sheet custom: You can select an AutoCAD custom property defined for
the referenced sheet here.

■ (Model Space) View Number and Title

3508 | Chapter 46   Fields



■ (Model Space) View Title

■ (Model Space) View Number

■ (Model Space) Viewport Scale

NOTE The fields for sheet title, sheet number, sheet description, view title,
and view number can be associated with a hyperlink that jumps to the sheet
or model space view referenced.

Callout symbol with sheet set placeholder

Resolved sheet set placeholders

Sheet Set Fields | 3509



Selecting a Sheet Set Field
Use this procedure to select a sheet set field to insert into a drawing.

1 Open the Field dialog box from one of the following components:

Then…If you want to…

see Inserting Fields in AutoCAD Text Ele-
ments on page 3497.

insert a sheet set field into
a text element

see Inserting Fields in AutoCAD Multiline
Text on page 3498.

insert a sheet set field into
a multiline text (mtext) ele-
ment

see Inserting Fields in AutoCAD Table Cells
on page 3501.

insert a sheet set field into
an AutoCAD table cell

see Inserting Fields in AutoCAD Attributes
on page 3499.

insert a sheet set field into
an attribute definition

see Inserting Fields in Property Set Defini-
tions on page 3491.

insert a sheet set field into
a property set definition

see Inserting Field Placeholders in Object
Properties on page 3494.

insert a sheet set field into
an object property

see Adding Fields to Object Style Properties
on page 3496.

insert a sheet set field into
an object style

2 Under Field Category, select SheetSet.
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Under Field Names, all sheet set-related fields are displayed.

3 Select the field you want to insert.

4 If you have selected CurrentSheetSetCustom or
CurrentSheetCustom, select the desired property under Custom
property name.

5 If you have selected SheetSet, you can select any sheet set and
any sheet to be displayed in the field. You can insert the sheet set
or sheet field as a hyperlink, so that clicking on the field in the
drawing will open the sheet or sheet set associated to the field.

If necessary, browse to a different sheet set.

6 If you have selected SheetSetPlaceholder, select the correct
placeholder under Placeholder Type.

NOTE The fields for sheet title, sheet number, sheet description, view
title, and view number can be created as a hyperlink that jumps to
the sheet or model space view referenced.

7 Under Format, select a text format or data format for the field.

8 Click OK.
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Keynote Fields
Keynoting is a consistent way of annotating the different types of drawings
in a set of construction documents to identify building materials or to provide
special instructions or explanations. AutoCAD Architecture provides a flexible
tool-based method of inserting keynotes that are linked to a keynote database
and thus can be modified globally as well as individually. This method supports
both reference keynoting (where the keynote key corresponds to a section in
an accompanying specification and may appear on different drawings) and
sheet keynoting (where keynote keys are sequentially numbered for each
drawing). AutoCAD Architecture supplies pre-specified keynotes for its
size-specific default detail components and for architectural objects that
represent assemblies with multiple components (for example, 8” CMU wall).
In cases where no keynotes are pre-specified, you can configure a keynote
insertion tool containing a keynote field.

Keynotes with field

The following keynote fields are available in AutoCAD Architecture:

■ Reference Key only

■ Reference Note only

■ Reference Key and Note

■ Sheet Key only

■ Sheet Note only

■ Sheet Key and Note

3512 | Chapter 46   Fields



You can also insert keynote fields as placeholders that are filled in when they
are connected to a building object.

For detailed information on keynotes, see Keynoting Tools on page 3608.

Selecting a Keynote Field
Use this procedure to select a keynote field into a drawing.

1 Open the Field dialog box from one of the following components:

Then…If you want to…

see Inserting Fields in AutoCAD Text Ele-
ments on page 3497.

insert a keynote field into a
text element

see Inserting Fields in AutoCAD Multiline
Text on page 3498.

insert a keynote field into a
multiline text (mtext) ele-
ment

see Inserting Fields in AutoCAD Table Cells
on page 3501.

insert a keynote field into
an AutoCAD table cell

see Inserting Fields in AutoCAD Attributes
on page 3499.

insert a keynote field into
an attribute definition

see Inserting Fields in Property Set Defini-
tions on page 3491.

insert a keynote field into a
property set definition

see Inserting Field Placeholders in Object
Properties on page 3494.

insert a keynote field into
an object property

see Adding Fields to Object Style Properties
on page 3496.

insert a keynote field into
an object style

2 Under Field Category, select AEC Keynotes.
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Under Field Names, all keynote-related fields are displayed.

3 Under Field Names, select the type of keynote field you want to
insert.

4 Click Select Keynote to select a keynote from a database.

5 If you want to insert pre-specified keynotes or prompt for manual
keynote selection when the keynote is inserted, select Insert as
placeholder.

6 If you have selected Reference Key and Note or Sheet key and
Note, select a keynote format.

7 Under Format, select a text format for the keynote field.

8 Click OK.

Database Fields
Database fields allow the user to insert a formatted cell from a database into
a drawing. A database field consists of a single field of a query or table in a
database. This enables users to work with data in a full database environment,
creating reports, queries, links to other databases, and link that data into any
drawing.
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Supported Data Types

The following data types are supported in AutoCAD Architecture database
fields:

■ Text

■ Memo

■ Date/Time

■ Integer

■ Real

■ Boolean

All other data types are ignored and will not display in the drawing.

Supported Database Providers and Data Sources

The following database providers are supported in AutoCAD Architecture:

■ Microsoft Jet 4.0 OLE DB Provider (Access)

■ Microsoft OLE DB Provider for ODBC Drivers

These database providers let you link to the following data sources:

■ Microsoft Access database (MDB)

■ Microsoft Excel file (XLS)

■ Microsoft Text file (TXT, CSV)

The database fields support secure databases in as far at the Microsoft Data
Link feature supports them. They may need to encrypt the connection
information so as to prevent the wrong users from inadvertently gaining
knowledge of the passwords.

The database fields support multi-user access.

Creating a Database Link to a 64-bit Data Source

If you are using a computer with 64-bit architecture, you can create a link to
a database source using the 64-bit model. You can also link to any legacy
32-bit data sources.
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Selecting a Database Field
Use this procedure to select a database field to insert into a drawing.

1 Open the Field dialog box from one of the following components:

Then…If you want to…

see Inserting Fields in AutoCAD Text Ele-
ments on page 3497.

insert a database field into
a text element

see Inserting Fields in AutoCAD Multiline
Text on page 3498.

insert a database field into
an multiline text (mtext)
element

see Inserting Fields in AutoCAD Table Cells
on page 3501.

insert a database field into
an AutoCAD table cell

see Inserting Fields in AutoCAD Attributes
on page 3499.

insert a database field into
an attribute definition

see Inserting Fields in Property Set Defini-
tions on page 3491.

insert a database field into
a property set definition

see Inserting Field Placeholders in Object
Properties on page 3494.

insert a database field into
an object property

see Adding Fields to Object Style Properties
on page 3496.

insert a database field into
an object style

2 Under Field Category, select AEC Database.
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3 Under Field Names, select DatabaseField.

4 To select an existing database link file (UDL), click  .

In the Select Data Link dialog box, browse for the required UDL
file.

5 To create a new database link file (UDL), click one of the following
buttons:

DescriptionButton

Use this button if you want to create a new
UDL link on a 32-bit computer.

Use this button if you are working on a 64-
bit computer, but want to create a link to
a 32-bit data source.

Use this button if you are working on a 64-
bit computer, and want to create a link to
a 64-bit data source.
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For more information, see Creating a Data Link to an ODBC Source
on page 3519.

6 Under Path Type, specify whether you want a full path to the
database or a relative path.

7 Under Select a table or query from the database, select a table or
query.

■ To select a database table, expand Tables and click on the
desired table entry.

■ To select a database query, expand Queries and click on the
desired query.

8 Under Select a record and a field from the table, select the database
field you want to insert in the drawing.

NOTE  You can preview the database field value in the static text
field on the top right of the Field dialog. You can preview the field
expression under Field expression at the bottom of the dialog.

Formatting the field or query

9 Under Format, select a text format.

If you have selected a field or query that does not retrieve a text
string, you can format the value with an existing property data
format.

10 Click Set From Property Data format.

11 Select a property data format, and click OK.

The settings of the selected property data format are copied to
the format codes in the field.

12 Click OK to insert the database field in the drawing.
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Creating a Data Link to an ODBC Source
You can link data from a number of data sources to an AutoCAD Architecture
drawing. You can use the following database providers for linking to data
sources:

■ Microsoft Jet 4.0 OLE DB Provider (Access)

■ Microsoft OLE DB Provider for ODBC Drivers

These database providers let you link to the following data sources:

■ Microsoft Access database (MDB)

■ Microsoft Excel file (XLS)

■ Microsoft Text file (TXT, CSV)

NOTE The instruction below describes the process of creating a link to a data
source from a Microsoft Excel file. In the same way, can create data links to
Microsoft Access databases, plain ASCII text files, and comma-separated files.

1 Open the Field dialog box from one of the following components:

Then…If you want to…

see Inserting Fields in AutoCAD Text Ele-
ments on page 3497.

insert a database field into
a text element

see Inserting Fields in AutoCAD Multiline
Text on page 3498.

insert a database field into
an multiline text (mtext)
element

see Inserting Fields in AutoCAD Table Cells
on page 3501.

insert a database field into
an AutoCAD table cell

see Inserting Fields in AutoCAD Attributes
on page 3499.

insert a database field into
an attribute definition

see Inserting Fields in Property Set Defini-
tions on page 3491.

insert a database field into
a property set definition

see Inserting Field Placeholders in Object
Properties on page 3494.

insert a database field into
an object property
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Then…If you want to…

see Adding Fields to Object Style Properties
on page 3496.

insert a database field into
an object style

2 Under Field Category, select AEC Database.

3 Under Field Names, select DatabaseField.

4 Click one of the following buttons:

DescriptionButton

Use this button if you want to create a new
UDL link on a 32-bit computer.

Use this button if you are working on a 64-
bit computer, but want to create a link to
a 32-bit data source.

Use this button if you are working on a 64-
bit computer, and want to create a link to
a 64-bit data source.
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5 Click the Provider tab.

Creating a data link to a Microsoft Excel file

6 Select Microsoft OLE DB Provider for ODBC Drivers, and click
Next.

7 In the Connection tab, click Use connection string.
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8 Click Build.

9 Click New to build to a new DSN file.

10 In the Create New Data Source dialog box, select the Microsoft
Excel Driver (*.xls).

NOTE The other supported drivers here are Microsoft Access Driver
(*.mdb) and Microsoft Text Driver (*.txt, *.csv). You can use these to
create a link to an Access database, a plain ASCII text file, or a
comma-separated file.
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11 Click Next.

12 Enter a name for the new DSN file, and click Next.

13 Confirm that your data source settings are correct, and click Finish.

14 In the ODBC Microsoft Excel Setup dialog box, select the version
of Microsoft Excel that the DSN file should support.

15 Click Select Workbook.
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16 Select an XLS file that should be used as your data source, and
click OK three times until you are back in the Connection tab of
the Data Link Properties dialog box.

The Microsoft Excel file you have selected as your data source is
displayed under Connection String.

17 To verify that the connection to the data source is working
correctly, click Test Connection.

18 Enter a user name and optionally a password for the database
connection.

19 Under Enter the initial catalog to use, select the Excel file from
the drop-down list.

20 Optionally, you can click the Advanced tab to define network
and permission settings.

21 If you have selected a data source on a network server, you can
define the network settings.

22 Define the access permissions for the data source.

23 Optionally, you can click the All tab to view and edit the OLE DB
initialization properties available for the selected OLE DB provider.

24 Click OK.

25 In the Field dialog box, the selected Excel file is displayed as the
data source.
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You can select data tables and entries as described in Selecting a
Database Field on page 3516.
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Detail Components

AutoCAD Architecture uses a tool-based system for managing the components that make up
detail drawings. In addition to the wide selection of pre-configured detail component insertion
tools provided on the sample tool palettes and in the Sample Palette Catalog, an extensive
database of components can be accessed through the Detail Component Manager. These
components can be inserted directly into a drawing, or dragged and dropped onto tool palettes.
All tools can be customized and are fully integrated with the keynoting feature. You can also
use your own databases.

Understanding Detail Components
Detail components represent specific building materials and products, and are
made up of simple two-dimensional (2D) linework entities such as lines,
polylines, arcs, circles, and hatches. In most cases, the detail component is a
collection of such entities grouped as a block, which can be easily copied or
moved like a single entity. The following are examples of detail components
that are inserted as blocks:

■ Bolt heads

■ Fixed-length nails

■ Section views of beams and columns

■ Most section views of framing members

■ Units such as CMUs, bricks, and pavers

■ Connectors

■ Materials with views generated from interrelating parameters; for example,
trusses, precast concrete, and hollow metal frames
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Other detail components are inserted as loose linework entities if they represent
material of variable length, amorphous shape, or something that would likely
be cut or otherwise modified in the field. This is the case for views showing
the length of a material, such as framing members, sheathing material, or
fasteners, for which the detail component database does not include a
fixed-length table.

Detail components are inserted into drawings parametrically, using a tool that
prompts you for the information needed to perform the drawing routine
associated with a particular component. Once inserted into a drawing, the
components are largely static: although they can be rescaled or repositioned
using Properties palette settings, they do not have object-like intelligence that
allows for parameter modifications to the extent that architectural objects do.
You can, however, perform various editing operations on detail components
using the tools available on the ribbon and the context menu.

The Detail Component Manager provides a centralized location for storing
and accessing detail components. Its filter mechanism lets you quickly locate
a particular component in a database. You can then insert the component
directly into a drawing, or, if you are likely to use it frequently, you can drag
and drop it onto a tool palette for even more convenient access.

Many detail components are also available as tools on the default Detailing
tool palettes, which can be transferred to the workspace from the Sample
Palette Catalog. You can also create a tool by dragging a detail component
from a drawing and dropping it onto a tool palette. Because detail component
tools can be moved between tool palettes and tool catalogs, or copied over
the Internet using i-drop® functionality, they are easily shared by project team
members. Tools can be modified using the associated Tool Properties worksheet.
You can also apply detail component tool properties to any linework within
a drawing so that it can be reference-keynoted according to the organizational
system you are using.

In addition to the database supplied with the software (based on the CSI
MasterFormat™ 2004) you can add and access your own detail component
databases as needed (see Configuring Detail Component Database Availability
on page 3583). The Detail Component Manager includes a wizard that lets
advanced users define the drawing routines and other parameters required to
add new component tables to a database.

Inserting Detail Components
All detail components are inserted into drawings using the same basic tool,
which performs the insertion routine associated with a selected component.
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Each detail component tool provided on the sample tool palettes represents
a different configuration of the basic tool. You can activate the detail
component insertion tool in five different ways:

■ Select a component in the Detail Component Manager, and click Insert
Component (or double-click the component).

■ Click a detail component tool icon on a tool palette.

■ Drag and drop a detail component tool from a Content Browser tool catalog
directly into a drawing.

■ Select a component in a drawing, right-click, and click Add Selected. This
reruns the tool with the same property settings used to insert the existing
component, so that you can quickly insert additional copies of the same
component.

■ Select a component in a drawing, right-click, and click Replace Selected.
This erases the selected component and reruns the tool with the same
property settings used to insert the erased component; however, you can
modify the tool to insert a different component by changing the
Component properties (Category, Type, Description, or View) on the
Properties palette.

Once the tool is activated, the procedure for inserting the detail component
varies according to the type of material or product the component represents
and the viewing direction. Some components are available only in one viewing
direction. For example, a backfill component, such as gravel, is always oriented
for a section view. On the other hand, a steel beam component is available
in elevation view, section view, and plan view. The different drawing routines
involve different prompts for user input. When depicting a variable-length
material with a repeating pattern, such as corrugated sheet metal, you need
to specify the start point and endpoint. In the case of bricks, you have the
option of specifying a number of courses. For other products, such as screws
or bolts, you may want to flip or rotate the component to change its
orientation. The procedures described in the following sections offer examples
of the basic insertion routines and options for detail components.

Stamp Components
Use this procedure to insert detail components that may need to be depicted
multiple times at a particular orientation, such as nails or screws. In this
example, the tool for inserting a steel beam has the View property set to
Section.
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1 Activate the detail component insertion tool for the component
using any of the methods described under Inserting Detail
Components on page 3528.

2 Click an insertion point in the drawing area to insert the
component at the default orientation, or select one of the
following options:

Then…If you want to…

enter b (for Base point), select the new base point,
and press ENTER to insert the component using
the new base point.

specify a different
base point

enter r (for Rotate), and then either enter the
number of degrees to rotate the component in a

change the default
orientation angle of
the component counterclockwise direction, or manually rotate

the component to the desired angle and click to
set the new orientation. Click again to insert the
component at the specified angle.

enter x (for Xflip), and click to insert the compon-
ent.

flip the component
along its X axis

enter y (for Yflip), and click to insert the compon-
ent.

flip the component
along its Y axis

3 Click elsewhere in the drawing area to “stamp” additional copies
of the component, either at the default orientation or as specified
in Step 2.

Steel beam component inserted at default orientation
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Linear Array Components
Use this procedure to insert detail components that consist of a pattern
repeated as a linear array, such as shingles or corrugated sheet metal. In this
example, the tool for inserting corrugated sheet metal has the View property
set to End, but the same user prompts are displayed if the View setting is Side.

1 Activate the detail component insertion tool for the component
using any of the methods described under Inserting Detail
Components on page 3528.

2 Click a start point in the drawing area to insert the component
at the default orientation, or select one of the following options:

Then…If you want to…

enter x (for Xflip), and then click to specify the
starting point for the component.

flip the component
along its X axis

enter y (for Yflip), and then click to specify the
starting point for the component.

flip the component
along its Y axis

enter l (for Left), and then click to specify the
starting point for the component.

position the compon-
ent to the left of the
baseline when drawn
vertically

enter r (for Right), and then click to specify the
starting point for the component.

position the compon-
ent to the right of the
baseline when drawn
vertically

enter c (for Center), and then click to specify the
starting point for the component.

center the component
on the baseline when
drawn in any direction

3 Click the desired endpoint to insert the component.
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Corrugated sheet metal in end view

Backfill Components
Use this procedure to insert backfill detail components, such as gravel or soil,
that are positioned within a boundary provided by existing linework or an
existing object. In this example, the tool for inserting Undisturbed Soil has
the View property set to Section, which is the only view available for this type
of component.

1 Activate the detail component insertion tool for the component
using any of the methods described under Inserting Detail
Components on page 3528.

2 Select the object you want to be the boundary for the backfill.

3 Click within the boundary of the selected object to insert the
backfill component.

Backfill component inserted within polyline boundary
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Bookends Components
Use this procedure to insert detail components, such as louvers and vents,
that consist of a pattern repeated as a linear array but bounded by unique
items at each end. In this example, the tool for inserting louvers has the View
property set to Section, which is the only view available for this type of
component.

1 Activate the detail component insertion tool for a particular
component.

2 Click a start point in the drawing area to insert the component
at the default orientation, or select one of the following options:

Then…If you want to…

enter x (for Xflip), and then click to specify the
starting point for the component.

flip the component
along its X axis

enter y (for Yflip), and then click to specify the
starting point for the component.

flip the component
along its Y axis

3 Specify the desired endpoint to insert the component.
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Bookends component inserted in section view

Countable Linear Array Components
Use this procedure to insert detail components that need to be depicted
multiple times in a linear array, such as bricks. In this example, the tool for
inserting bricks has the View property set to Section. The same prompts are
displayed if the View setting is Plan. If the setting is Elevation, the prompts
described under Stamp Components on page 3529 are used. If the setting is
Elevation (Pattern), the prompts described under Backfill Components on
page 3532 are used.

1 Activate the detail component insertion tool for the component
using any of the methods described under Inserting Detail
Components on page 3528.

2 Click an insertion point in the drawing area.
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3 Orient the component image, and then click to insert it, or select
one of the following options:

Then…If you want to…

enter x (for Xflip), and then click to specify the
insertion point for the component.

flip the component
along its X axis

enter y (for Yflip), and then click to specify the
insertion point for the component.

flip the component
along its Y axis

enter c (for Count), enter the number of units to
insert, and click to specify the starting point for

insert a specific num-
ber of components

the array. Note that the x and y options are still
available at this point.

4 Orient the component or the array of components, and then click
to complete the insertion.

Course of bricks inserted in section view
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Surface Components
Use this procedure to insert rectangular detail components of a specific depth
that have a hatch, such as base courses. In this example, the tool for inserting
the base course has the View property set to Section, which is the only view
available for this type of component.

1 Activate the detail component insertion tool for the component
using any of the methods described under Inserting Detail
Components on page 3528.

2 Specify a start point in the drawing area to insert the component
at the default orientation, or select one of the following options:

Then…If you want to…

enter x (for Xflip), and then click to specify the
starting point for the component.

flip the component
along its X axis

enter y (for Yflip), and then click to specify the
starting point for the component.

flip the component
along its Y axis

enter l (for Left), and then click to specify the
starting point for the component.

position the compon-
ent to the left of the
baseline when drawn
vertically

enter r (for Right), and then click to specify the
starting point for the component.

position the compon-
ent to the right of the
baseline when drawn
vertically

enter c (for Center), and then click to specify the
starting point for the component.

center the component
on the baseline when
drawn in any direction

3 Click the desired endpoint to insert the component.
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Base course inserted in section view

Dynamically Sized Surface Components
Use this procedure to insert rectangular detail components, such as concrete
joists or slabs with metal decking, for which you determine the dimensions.
In this example, the tool for inserting a concrete slab with metal decking has
the View property set to Plan. If the setting is Section or Elevation, the prompts
described under Linear Array Components on page 3531 are used.

1 Activate the detail component insertion tool for the component
using any of the methods described under Inserting Detail
Components on page 3528.

2 Specify the first corner of the rectangle.

3 Specify the opposite corner to insert the component.
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Concrete slab in plan view

Bolt Components
Use this procedure to insert bolt components when you need to specify the
distance between the bolt head and the nut. In this example, the tool for
inserting the bolt has the View property set to Side. If the setting is Head or
Nut, you are not prompted to perform the first two steps.

1 Activate the detail component insertion tool for the component
using any of the methods described under Inserting Detail
Components on page 3528.

2 Specify the center bearing point for the bolt head.

3 Orient the component image, and then specify the center bearing
point for the nut to insert the component.
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4 If desired, you can “stamp” additional components into the
drawing at the same orientation, or you can change the
orientation for subsequent insertions:

Then…If you want to…

enter b (for Base point), select the new base
point, and press ENTER to insert the compon-
ent using the new base point.

specify a different base
point

enter r (for Rotate), and then either enter the
number of degrees to rotate the component

change the default orient-
ation angle of the com-
ponent in a counterclockwise direction, or manually

rotate the component to the desired angle
and click to set the new orientation. Click
again to insert the component at the specified
angle.

enter x (for Xflip), and click to insert the
component.

flip the component along
its X axis

enter y (for Yflip), and click to insert the
component.

flip the component along
its Y axis

Bolt inserted in side view

Editing Detail Components in a Drawing
Once a detail component has been inserted into a drawing, you can edit the
component using the tools found on the Modify panel of the Home tab, or
the AEC Modify Tools option on the detail component’s context menu. (For
detailed instructions on using these tools, see Detail Drafting Tools on page
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2829.) Using these tools on block-based detail components creates unique block
definitions for edited inserts, so that the edits will not affect inserts of the
same block in other locations. However, if you use the context menu option
Edit Block in-place to edit a block definition used in multiple locations, you
can use the Copy Block Definition and Assign option (also on the context
menu) to create a unique block definition for the block insert you want to
edit.

You can view and modify certain properties of a detail component by clicking

Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties  . The following
illustrations show examples of the Design and Extended Data tabs of the
Properties palette for a detail component. You can modify many of the settings
on the Design tab by inserting text or through an associated drop-down list.
On the Extended Data tab, you can specify hyperlinks, insert text notes, or
set references using the worksheet icons under Documentation. The
Component data is read-only, as it displays live data from the detail
components database.

NOTE When either the Add Selected or Replace Selected context menu option is
selected, the Component data is displayed on the Design tab of the Properties
palette (instead of the Extended Data tab) and is modifiable. For more information
on these two options, see Inserting Detail Components on page 3528.
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The following image shows the Design tab of the Properties palette for a
concrete masonry unit detail block.
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The following image shows the Extended Data tab of the Properties palette
for a concrete masonry unit detail block.

Using Detail Component Tools
Like other AutoCAD Architecture tools, the tools for inserting detail
components offer great flexibility in the ways you can create, customize, store,
and apply them. This section includes topics that pertain to the configuration
and management of these tools. For descriptions of the various ways to insert
detail components using these tools, refer to Inserting Detail Components on
page 3528.

Adding Detail Component Tools to a Tool Palette
Tools for inserting specific detail components can be added to a tool palette
from three main sources: the Detail Component Manager, the Content Browser,
and linework in a drawing.
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Creating Tools from the Detail Component Manager
Use this procedure to drag and drop a selected detail component from the
Detail Component Manager to a tool palette in the workspace, thus
instantiating the basic detail component insertion tool for that component).

1 Open the tool palette to which you which you want to add a
detail component tool.

2 Click Home tab ➤ Details panel ➤ Detail Components .

NOTE Alternatively, you can right-click any detail component tool,
and click Detail Component Manager.

The Detail Component Manager

3 Navigate the tree view or use the Filter mechanism to display the
desired detail component in the table at the bottom of the dialog
box. (To view the entire contents of large component tables, you
can use the vertical scroll bar to the right of the table.)
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4 Click the selector column to the left of the desired table row, and
drag the selected component to the tool palette.

You can now use the tool to insert the component into a drawing.
For more information, see Inserting Detail Components on page
3528.

Copying Tools from the Content Browser
Use this procedure to copy a detail component insertion tool or a palette of
tools from the Sample Palette Catalog in the Content Browser to your tool
palettes set in the workspace. Most of these palettes are also included on the
sample tool palettes set available in the workspace, but this catalog in the
Content Browser serves as a backup tool repository and a source of tools you
can customize without changing tools that are already on a workspace palette.
Generally these tools are preset to insert a particular type and size of
component, but once they are on a palette in the workspace, they can be
customized to insert a different size of component, or even a component in
a different category. For more information, see Modifying Detail Component
Tools on page 3545. The same basic procedure can be used to copy tools or
palettes from catalogs you create to hold tools that are preconfigured and
grouped for particular projects.

Content Browser showing Details palettes in Sample Palette Catalog
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1 Confirm that your tool palettes set is open in the workspace. If
you want to copy a particular tool to a particular palette, make
sure that palette is open.

2 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

3 Double-click the Sample Palette Catalog in your catalog library.

4 Double-click the Detailing folder.

5 Click the i-drop® icon for the palette (or double-click the palette,
and click the i-drop icon for a tool on that palette), and then drag
the palette or tool onto the open palette in the workspace.

If you are copying an entire palette from the Content Browser, a
new palette is added to the set.

Creating Tools from Linework in a Drawing
You can create a detail component insertion tool from linework in a drawing
simply by dragging and dropping the linework onto a tool palette. The linework
can be a detail you have drawn using two-dimensional (2D) AutoCAD
commands, or it can be a detail component inserted from a tool or from the
Detail Component Manager. Once added to the tool palette, the new tool can
be renamed or otherwise modified through its Tool Properties worksheet. For
more information, see Modifying Detail Component Tools on page 3545.

Modifying Detail Component Tools
Detail component tools on a tool palette in the workspace can be modified
through the Tool Properties worksheet. You access the Tool Properties
worksheet by right-clicking the tool and clicking Properties. To modify a tool
in a catalog in the Content Browser, you must first copy the tool to a palette
in the workspace.

The appearance of the Tool Properties worksheet varies depending on the type
of component and the current configuration of property settings. The following
illustrations show two configurations of the Tool Properties worksheet for the
04 - Masonry tool that is included on the sample Basic tool palette. The tool
is set to add standard 3/8” joint brick in both cases, but the first configuration
has the View property set to Section, while the second has this property set
to Elevation (Pattern). For detail components that can be oriented differently
in different views, the View setting determines the particular drawing routine
used to insert the image into the drawing. Note that the different View settings
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result in different orientation illustrations on the worksheet. Note also that
the Mortar specifications are not applicable for the Elevation (Pattern) setting
and are not displayed for that configuration. The properties displayed under
Specifications may also vary depending on other settings. For example, if the
Show Mortar property is No when the View setting is Section, no other Mortar
properties are displayed. For some detail components, no Specifications apply,
and the heading is not displayed.

Detail component Tool Properties worksheet configurations

The following table describes the Tool Properties worksheet categories and
settings that are common to most detail component insertion tools.

DescriptionProperty/Category
Name

Displays the image specified for the component in its table
in the database. If no image is specified, then the image

Image

for the table is displayed. You can right-click the image
and click Refresh Image to recall the stock image for the
tool from the database, or you can right-click and click
Specify Image to browse for a different image.
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DescriptionProperty/Category
Name

The name of the tool. This may be the name originally as-
signed to one of the tools on the sample palettes, or, if

Name

you have copied the tool from the Detail Component
Manager, it is the name specified in the Description column
of its parent size table. Note that the name is not updated
if you change the Category, Type, or Size properties under
Component. However, you can edit the name.

This is the tool description used if the tool is published to
a catalog. You can change this description by clicking the
worksheet icon to open a Description editing box.

Description

Clicking the worksheet icon on this line accesses the Detail
Component Manager through the Select Component

Component

dialog box and allows you to change the settings for the
Description, Description and Type, or Description, Type,
and Category. Note that if you change the Category set-
ting, the Name, Description, and Image properties are not
updated automatically.

Specifies the group or subgroup that is the parent of the
table containing the component specified by the Descrip-

Category

tion property. If other groups or subgroups exist at the
same hierarchical level within the same parent group, they
are selectable from a drop-down list.

Specifies the table containing the particular component
specified by the Description property. A drop-down list

Type

lets you select other tables within the same parent group
or subgroup.

Specifies a particular component of the specified Type and
Category. Other components within the same table can
be selected from the drop-down list.

Description

Specifies the type of view for which the component is ori-
ented. Possible values are Section, Plan, Elevation, and El-

View

evation (Pattern). For components such as bolts, compon-
ent-specific terminology is used, such as Head, Side, Bolt,
or Nut. A drop-down list is present if more than one view
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DescriptionProperty/Category
Name

is applicable for the specified component. This setting de-
termines the drawing routine and the command line
prompts for the insertion process. For more information,
see Inserting Detail Components on page 3528.

Clicking the icon on this line displays of an image depicting
the orientation at which the detail component will be in-

Specifications

serted (determined by the View property). Other properties
displayed here provide the top-level parameters required
to insert the component with the specified View setting.
For components with only one possible View setting, no
Specification properties are displayed.

Applying Detail Component Properties to Linework
Linework that you have drawn using two-dimensional (2D) AutoCAD
commands can be keynoted using a keynoting tool to select a keynote from
the database. If you have multiple occurrences of the linework, and you want
them to have the same keynote, you can specify a keynote by applying the
properties of the detail component for which the desired keynote is already
specified. If a tool for inserting the component already exists, you can apply
the tool properties to the linework. If no such tool exists, you can use the
DtlComp command to select a component from the Detail Component
Manager, and its ASsign id command line option to assign its properties to
the linework.

Applying Detail Component Properties to Linework from a Tool
Use this procedure to apply the properties of a detail component insertion
tool to linework in a drawing so that the linework can be keynoted with the
keynote of the component the selected tool inserts.

1 Draw the linework.

2 Right-click a tool on a tool palette, and click Apply Detail
Component Data to Linework.

3 Select the linework, and press ENTER.

The linework can now be keynoted just as if it were a component
inserted using the selected tool.
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Applying Detail Component Properties to Linework from the
Detail Component Manager

Use this procedure to apply the properties of a selected detail component to
linework in a drawing so that the linework can be keynoted with the keynote
for that component.

1 Draw the linework.

2 On the command line, enter DtlComp.

3 Enter as (for ASsign).

4 Select the linework, and press ENTER.

5 In the Select Component dialog box, select the component whose
properties you want to assign to the linework, and click Select
Component. For more information, see Locating a Detail
Component on page 3550.

The linework can now be keynoted just as if it were a component
inserted directly from the Detail Component Manager.

Using the Detail Component Manager
Using the Detail Component Manager dialog box, you can navigate among
different detail component databases. A hierarchical tree view and a filter
feature make it easy to locate individual components within a database. Once
you find the component you need, you can insert it into a drawing, or you
can drag and drop it onto a tool palette for repeated use. Note that the five
buttons arranged vertically in the middle of the dialog box are unavailable
unless you have edit privileges for the selected database. For more information,
see Creating and Modifying Detail Component Databases on page 3553.

You can access the Detail Component Manager in the following ways:

■ Click Home tab ➤ Details panel ➤ Detail Components  .

■ Right-click any detail component insertion tool on a tool palette in the
workspace, and then click Detail Component Manager.

■ On the Tool Properties worksheet for a detail component tool, click the
Select a Component icon on the Component line.
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NOTE When accessed from the Tool Properties worksheet, the Detail Component
Manager is displayed in read-only mode, and the dialog box is titled “Select
Component.” The hierarchical tree view is expanded to highlight the component
currently specified for the tool, and the component table is open at the bottom
of the dialog box. Note also that the Insert Component button is replaced by a
Select Component button.

The Detail Component Manager dialog

Locating a Detail Component
Use this procedure to locate a detail component.

1 Use any of these methods to open the Detail Component Manager
(sometimes also called the Select Component dialog box):

Then...To start the command
from...

click Home tab ➤ Details panel ➤ Detail

Components  .

the ribbon
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Then...To start the command
from...

right-click the tool, and choose Detail Com-
ponent Manager.

a tool on a tool palette

open the Tool Properties worksheet for a tool,
and click the Select a Component icon on the
Component title bar.

a tool properties work-
sheet

enter DtlComp and then enter as (for ASsign).the command line

2 For Current detail component database, select a database from
the drop-down list. The database provided with the software is
the AEC Detail Component database (AecDtlComponents(US).mdb),
which is based on the CSI MasterFormat 2004 standard. You may
also access other locally installed databases. For more information,
see Configuring Detail Component Database Availability on page
3583.

3 Navigate to the detail component table level of the hierarchy for
the selected database using either of the following methods:

■ Expand nodes in the hierarchical tree view until you reach
the table level, then select a table name to display its contents
in the grid at the bottom of the dialog box.
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The Detail Component Manager dialog with concrete mansonry table displayed

■ Type a word or character string in the Filter box, and then

click  , or press Tab, or press ENTER. This expands all nodes
under any node whose name includes the string you entered,
and displays the component table for the first table name that
contains that string. This is a quick way to navigate to a
component whose name you know, but it may expand
multiple groups or subgroups in multiple divisions. If you
know the division or group containing the component table
you want, it is faster to expand the nodes yourself.
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Using the Detail Component Manager filter

4 Once the components for the selected table are displayed in the
bottom panel of the dialog box, you can use the vertical scroll
bar or your mouse scroll wheel to locate a particular component.
Clicking anywhere on a row selects that component. Note that
the number of column headings varies from one component table
to another. For some tables, you need to expand the window or
use the horizontal scroll bar to view all columns.

Creating and Modifying Detail Component Databases
AutoCAD Architecture uses Microsoft® Access for its detail component
databases. You can create and modify detail component databases using
Microsoft Access directly if you are familiar with that product and with the
structure of detail component databases. (For more information, see
Customizing and Adding New Content for Detail Components on page 3945.)
If you have edit privileges, you can also create and modify detail component
databases through the Detail Component Manager, without using Microsoft
Access. Nonetheless, before attempting advanced edits using the Detail
Component Manager, you should be familiar with the schema for detail
component databases, as described in the above-referenced topic.
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NOTE If you are working in a multi-user environment, it is recommended that
you modify a keynote database only when no other users are accessing it.

Editing Detail Component Database Properties
Use this procedure to edit a component in a detail component database.

1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 Select a database from the Current detail component database
list.

3 Click  to enter edit mode.

4 Right-click the root node in the tree view, and click Edit.

The Details Database Properties dialog box is displayed for the
selected database.

5 Edit the following database properties as applicable.

Description/InstructionsProperty Name

Right-click the Image box, and click Specify Im-
age to browse images available for the selected

Image

group in the location specified by its Path Key
value. The image you select will be displayed
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Description/InstructionsProperty Name

on the Image tab of the Detail Component
Manager when the database node is selected.
This is an optional field.

The name from the database Fingerprint table.Display Name

The description displayed for this database on
the Information tab in the Detail Component
Manager. This is an optional field.

Description

The name of the person or other entity respons-
ible for this database. This is an optional field.

Author/Manufacturer

The URL for the author/manufacturer. This is an
optional field.

Web Address

6 Click OK.

Editing Groups in a Detail Component Database
Use this procedure to edit a component group in a detail component database.

1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 Select a database from the Current detail component database
list.

3 Click  to enter edit mode.

4 Expand the root node and group/subgroup nodes as necessary to
locate the group you want to edit.

5 Right-click the group, and click Edit.
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The Group Properties dialog box is displayed.

6 Edit the following properties as applicable:

Description/InstructionsProperty Name

The image displayed on the Image tab of the
Detail Component Manager when this group is

Image

selected. To change the image, right-click the
Image box, and click Specify Image to browse
images available for the selected group in the
location specified by its Path Key value. This is
an optional field.

The name from the database Groups table dis-
played for this group in the Detail Component
Manager.

Group Name

An entry from the database DirKeys table, this
value is a shortcut alias identifying the location

Path Key

of drawing and image files external to the
database for this group.

A comma-delimited list of keywords to be used
when searching for components within this

Filter Keywords

group in the Detail Component Manager. This
is an optional field.

7 Click OK.
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Editing Components in a Detail Component Database
Use this procedure to edit the properties of individual components within a
detail component database. The properties on the General and Parameters
tabs of the Component Properties dialog box are the basis for one or more
recipes the software uses to draw the component in different views. Each recipe
specifies the type of jig, or drawing routine, for placing the component in a
specific view. The recipe may also contain information pertaining to layer
and hatch pattern (for more information, see Recipe Specifications on page
3954). You can also use this procedure to customize components in the default
imperial and metric detail component databases supplied with the software,
or to edit components in databases that you create.

1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 Select a database from the Current detail component database
list.

3 Click  to enter edit mode.

4 Expand the root node and group/subgroup nodes as necessary to
locate the component you want to edit.

5 Right-click the component, and click Edit.

The Component Properties dialog box is displayed. The read-only
ID field shows the database identifier for the group to which the
component belongs. In most cases, you can edit values on the
General tab and the Parameters tab within this dialog box. For
components that use a jig other than one of the six supported
types (Stamp, Bookends, Linear Array, Surface, Surface Linetype,
and Surface Top), no parameters are displayed on the Parameters
tab. For information on editing this type of component, see
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Customizing and Adding New Content for Detail Components
on page 3945.

6 On the General tab, edit the following values as applicable:

Description/InstructionsProperty Name

The image displayed on the Image tab of the
Detail Component Manager when this compon-

Image

ent is selected. To change the image, right-click
the Image box, and click Specify Image to
browse images available for the selected group
in the location specified by its Path Key value.
This is an optional field.

The name displayed for this component in the
Detail Component Manager.

Display Name

The name of the size table for this component,
as specified in the TableName field in the data-
base Components table.

Table Name

The unit of measurement for this component.Units
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Description/InstructionsProperty Name

The name of the RecipeSpec XML file containing
the recipes for drawing this components.

Recipe

The description displayed for this component
on the Information tab in the Detail Component
Manager.

Description

The default keynote key for this component.
Click Select Keynote to browse for or create a
different keynote. This is an optional field.

Keynote

A comma-delimited list of keywords to be used
in searching for this component. This is an op-
tional field.

Filter Keywords

The name of the person or other entity respons-
ible for this component, as specified in the Au-

Author/Manufacturer

thor field in the database Fingerprint table. This
is an optional field.

The address specified in the URL field in the
Fingerprint table for the database containing
this component. This is an optional field.

Web Address

This read-only property shows the creation date
for the component if it was created using the
Detail Component Manager.

Date Created

This read-only property shows the date of the
last modification for this component if it was
modified using the Detail Component Manager.

Date Modified

7 If the Parameters tab is available for the selected component, you
can change the jig type, if desired, and then edit parameter values
according to the instructions following the illustration below.

You can also change the specified view by renaming it (click 

), or you can create additional views by clicking  . Any views
you create or rename are then available from the drop-down list.
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NOTE You can specify only one jig type for each view.

See...To define a recipe
using this jig type...

Parameters for Recipes Using Stamp Jigs on page
3573.

Stamp

Parameters for Recipes Using Bookends Jigs on
page 3574.

Bookends

Parameters for Recipes Using Linear Array Jigs
on page 3577.

Linear Array

Parameters for Recipes Using Surface Jigs on
page 3579.

Surface

Parameters for Recipes Using Surface Linetype
Jigs on page 3581.

Surface Linetype

Parameters for Recipes Using Surface Top Jigs
on page 3582.

Surface Top
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8 Click OK.

Deleting Groups or Components from a Detail Component
Database

Use this procedure to delete a group, subgroup, or component from a detail
component database. Note that deleting a group also deletes any subgroups
and components within that group.

1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 Select a database from the Current detail component database
list.

3 Click  to enter edit mode.

4 In the tree view, select the node representing the group, subgroup,
or component you want to delete.

5 Click  .

The selected node and all its children are deleted from the
hierarchical tree view in the Detail Component Manager.

Moving Groups or Components in a Detail Component Database
Use this procedure to move a group, subgroup, or component to a different
group or level within the database hierarchy. Note that moving a group also
moves any subgroups and components within that group.

1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 Select a database from the Current detail component database
list.

3 Click  to enter edit mode.

4 Select the node (group, subgroup, or component) to move, and
drag it to the desired location in the hierarchical tree view.
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Editing Component Size Tables
A component size table is displayed in the pane at the bottom of the Detail
Component Manager whenever a component is selected in the tree view. If
you have edit privileges for the currently selected database, you can add rows
to the table, remove rows, or edit individual cells. You can also add or remove
columns and change column names.

Adding a Row to a Component Size Table
Use this procedure to add a row to the size table for a selected component in
the Detail Component Manager.

1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 Select a database from the Current detail component database
list.

3 Click  to enter edit mode.

4 In the hierarchical tree view, expand the root node and
group/subgroup nodes as necessary to locate the component you
want to edit.

5 If necessary, scroll to the bottom of the table, and then click
anywhere in the blank row that has an asterisk (*) in the first
column.
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The row is selected.

6 Enter text as required for cells in the row.

As you begin to edit a cell, an edit symbol appears in the first
column, and the blank row is displayed again below the row you
are editing.

NOTE The Keynote column is not directly editable. Right-click in the
cell, and click Edit to open the Select Keynote dialog box. For more
information, see Specifying Keynotes for Detail Components on page
3633.

7 Click  to leave edit mode (or click Close), and then click OK
when prompted to save the changes to the table. If you forgot to
enter a required value, you are prompted to go back and enter it.

Removing a Row from a Component Size Table
Use this procedure to remove a row from the size table for a selected
component in the Detail Component Manager.
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1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 Select a database from the Current detail component database
list.

3 Click  to enter edit mode.

4 In the hierarchical tree view, expand the root node and
group/subgroup nodes as necessary to locate the component you
want to edit.

5 If necessary, resize the window or use the vertical scroll bar to
find the row that you want to remove from the table. Then click
the gray cell in the first column of the row, and click DELETE to
remove the row.

6 Click  to leave edit mode (or click Close), and then click OK
when prompted to save the changes to the table.

Editing Values Within a Component Size Table Row
Use this procedure to edit individual cells in the size table for a selected
component in the Detail Component Manager.

1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 Select a database from the Current detail component database
list.

3 Click  to enter edit mode.

4 In the hierarchical tree view, expand the root node and
group/subgroup nodes as necessary to locate the component you
want to edit.

5 If necessary, resize the window or use the scroll bars to find the
cell that you want to edit in the table. You can add or change
existing text within a cell, or you can click a cell and press Delete
to clear the cell and then add new text.

NOTE To edit the Keynote column, right-click in the cell, and click
Edit to open the Select Keynote dialog box. For more information,
see Specifying Keynotes for Detail Components on page 3633.
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6 Click  to leave edit mode (or click Close), and then click OK
when prompted to save the changes to the table. If you forgot to
enter a required value, you are prompted to go back and enter it.

Adding a Column to a Component Size Table
Use this procedure to add a column to the size table for a selected component
in the Detail Component Manager.

1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 Select a database from the Current detail component database
list.

3 Click  to enter edit mode.

4 In the hierarchical tree view, expand the root node and
group/subgroup nodes as necessary to locate the component you
want to edit.

5 In the table, right-click any column title, and click Add Column.

6 In the Add New Column dialog box, enter a name for Field Name.
If the name you enter matches one of the GlobalName values in
the ColumnDisplay table for this database, the LocalName value
associated with that global name will be displayed when you click
in the Display Name field. You can use this as the display name
for the new column, or you can enter a different name, in which
case a new entry will be added to the ColumnDisplay table to
reflect the new LocalName value you have created for an existing
GlobalName value. (A new ColumnDisplay table entry will also
be created if the name you enter for Field Name does not match
an existing GlobalName value.)

7 Select a data type (String, Memo, Integer, or Real), specify a length
(up to 255 characters), and click OK.

The specified column is added to the right of any existing
columns.

Removing a Column from a Component Size Table
Use this procedure to remove a column from the size table for a selected
component in the Detail Component Manager.
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1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 Select a database from the Current detail component database
list.

3 Click  to enter edit mode.

4 In the hierarchical tree view, expand the root node and
group/subgroup nodes as necessary to locate the component you
want to edit.

5 In the table, right-click the title of the column you want to
remove, and click Delete Column.

6 Click OK when prompted to confirm that you want to delete the
column.

Editing a Column in a Component Size Table
Use this procedure to edit the name of a column in the size table for a selected
component in the Detail Component Manager.

1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 Select a database from the Current detail component database
list.

3 Click  to enter edit mode.

4 In the hierarchical tree view, expand the root node and
group/subgroup nodes as necessary to locate the component you
want to edit.

5 In the table, right-click the title of the column you want to edit,
and click Rename Column.

6 In the Rename Column dialog box, enter a new name for the
column in the Display Name field, and click OK. Note that the
Field Name displays the GlobalName value for this column from
the ColumnDisplay table for this database. When you change the
display name, a new entry is added to the ColumnDisplay table
to reflect the new display name you have created for an existing
GlobalName value.
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Creating a Detail Component Database
Using the Detail Component Manager to create a new detail component
database requires the following basic steps:

1 Create a blank Microsoft® Access database by copying and
renaming the detail component database template
(AecDtlComponents-Template.mdb) located in
C:\ProgramData\Autodesk\ACA 2012\enu\Template\Details and
Keynotes.

2 Add the renamed database to the list of available databases. (For
detailed instructions, see Adding a Detail Component Database
to Available Databases on page 3583.)

3 Using the Detail Component Manager, add groups and subgroups
to reflect the major and minor divisions within the detailing
scheme. (For detailed instructions, see Adding Groups to a Detail
Component Database on page 3568.)

4 Add individual components within groups and subgroups as
applicable. (For detailed instructions, see Adding Components to
a Detail Component Database on page 3569.)

5 Add rows to the size tables as applicable for each group/subgroup,
editing table columns as desired. (For detailed instructions, see
Adding a Row to a Component Size Table on page 3562.)

When you exit the Detail Component Manager, the new database is available
to other users with access privileges.

Creating a Blank Detail Component Database
Use this procedure to create a blank Microsoft® Access database with all
required tables and queries for detail component storage and retrieval. This
is the first step in the process of creating a new detail component database
using the Detail Component Manager.

1 Navigate toC:\ProgramData\Autodesk\ACA 2012\enu\Template\Details
and Keynotes.

2 Copy the file AecDtlComponents-Template.mdb and rename it as
desired.

3 Add the new blank database to the list of active databases, as
described under Adding a Detail Component Database to Available
Databases on page 3583.
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Adding Groups to a Detail Component Database
Use this procedure to add a group to a detail component database. You can
use the same basic procedure to add various subgroups within a group.

1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 Click  to enter edit mode.

3 Select a database from the Current detail component database
list.

4 Select the root node for the selected database if you want to add
a top-level group, or expand the root node and group/subgroup
nodes as necessary until you can select the node to which you
want to add a subgroup.

5 Click  .

The Add Component Group dialog box is displayed with the
read-only ID field showing the value assigned to this group in the
Groups table in the database.

6 For Group Name, enter the name you want displayed in the Detail
Component Manager for this group. This value will be added to
the database Groups table entry.

7 If you are using the standard database, select a Path Key from the
drop-down list to specify a shortcut alias identifying the location
of drawing and image files for this group. Path Key values are
retrieved from the database DirKeys table. You can add new key
values to this table manually using Microsoft® Access. If you are
creating a new database from the template file, no Path Key values
will be available for selection in this dialog box unless you have
first populated the DirKeys table using Microsoft® Access. For
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more information, see Customizing and Adding New Content for
Detail Components on page 3945.

8 For Filter Keywords, enter a comma-delimited list of keywords to
be used when searching for components in this group.

9 Click OK.

The group or subgroup you have defined is displayed as a new
node in the hierarchical tree view.

Adding Components to a Detail Component Database
Use this procedure to add a component to a detail component database and
create a blank size table to which you can then add rows representing the sizes
in which the component is available. When you add a component, the values
you specify on the General and Parameters tabs of the New Component dialog
box are used to create one or more recipes for drawing the component in
different views. Each recipe specifies the type of jig, or drawing routine, for
placing the component in a specific view. The recipe may also contain
information pertaining to layer and hatch pattern (for more information, see
Recipe Specifications on page 3954). Note that this procedure can be used to
add components to the default imperial and metric detail component databases
supplied with the software, or to populate databases that you create.

1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 Click  to enter edit mode.

3 Select a database from the Current detail component database
list.

4 Expand the root node and group/subgroup nodes as necessary
until you can select the node to which you want to add a
component table.

5 Click  .
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The New Component dialog box is displayed.

6 On the General tab, specify the following values as applicable for
the component you are adding:

Description/InstructionsValue Name

Right-click the Image box, and click Specify Im-
age to browse images available for the selected

Image

group in the location specified by its Path Key
value. The image you select will be displayed
on the Image tab of the Detail Component
Manager when this component is selected.

Enter the name you want displayed for this
component in Detail Component Manager.

Display Name

Enter the name of the size table for this compon-
ent.

Table Name

Select a unit from the drop-down list.Units
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Description/InstructionsValue Name

Enter a name for the RecipeSpec XML file to
contain the recipes you specify for drawing this
component.

Recipe

Enter the description you want to display for
this component on the Information tab in the
Detail Component Manager.

Description

Click Select Keynote to browse for or create a
keynote to be the default for this component.

Keynote

Enter a comma-delimited list of keywords to be
used in searching for this component.

Filter Keywords

Enter the name of the person or other entity
responsible for this component.

Author/Manufacturer

Enter the URL for the author/manufacturer.Web Address

NOTE The ID property on the General tab is a read-only value
identifying a particular Groups table in the selected database. These
values are assigned automatically as groups are added to a database.

7 On the Parameters tab, if desired, select a jig type other than the
default (Stamp) for the default Section view, and then specify
parameter values to define the component according to
instructions referenced in the table following the illustration
below. You can also change the default view by renaming it (click

 ), or you can create additional views by clicking  . Any
views you create or rename are then available from the drop-down
list.
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NOTE You can specify only one jig type for each view.

See...To define a recipe
using this jig type...

Parameters for Recipes Using Stamp Jigs on page
3573.

Stamp

Parameters for Recipes Using Bookends Jigs on
page 3574.

Bookends

Parameters for Recipes Using Linear Array Jigs
on page 3577.

Linear Array

Parameters for Recipes Using Surface Jigs on
page 3579.

Surface

Parameters for Recipes Using Surface Linetype
Jigs on page 3581.

Surface Linetype
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See...To define a recipe
using this jig type...

Parameters for Recipes Using Surface Top Jigs
on page 3582.

Surface Top

8 Click OK.

You can now add a table row for each available component size.
You can also add, edit, or delete columns as needed. For detailed
instructions, see Editing Component Size Tables on page 3562.

Parameters for Recipes Using Stamp Jigs
Stamp jigs are used to insert components that consist of a single block. Refer
to the following table if you are adding a new detail component (or editing
one that was created using the New Component option) and you want to
define a recipe that uses a stamp jig to insert the component in the specified
view.

Description/InstructionsParameter Name

Specifies the layer key for the layer to which the compon-
ent will be assigned in the specified view. To specify a

Layer key

layer key or change the existing one, click the worksheet

icon (  ) to access the Select Layer Key dialog box.

The name of the drawing file (a DWG, DWT or DWS file)
containing the blocks for the component table.

Block drawing location

A drop-down list lets you specify either Fixed value or
Database. If you select Fixed value, the value you enter

Block type

will apply to every row in the size table for this compon-
ent. If you select Database, a column will be added to the
table allowing values to be entered for individual sizes.

Displayed only if Block type is Fixed value, this parameter
specifies the block definition to be inserted for this com-
ponent.

Block
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Description/InstructionsParameter Name

Displayed only if Block type is Database, this parameter
specifies the name of the component table column in
which the block to be inserted is specified for each size.

Block field

A drop-down list lets you specify either Fixed value or
Database. If you select Fixed value, the value you supply

Scaling type

will apply to every row in the size table for this compon-
ent. If you select Database, a column will be added to the
table allowing values to be entered for individual sizes.

Displayed only if Scaling type is Fixed value, this parameter
specifies the scaling value for the block.

Scale

Displayed only if Scaling type is Database, this parameter
specifies the name of the component table column in

Scale field

which the scaling value for the block is specified for each
size.

Specifies whether the command-line option for specifying
scaling is displayed for this component.

Allow scaling

Specifies whether the command-line option for specifying
rotation is displayed for this component.

Allow Rotation

Specifies whether the command-line option for flipping
the block on its X axis is displayed for this component.

Allow X flip

Specifies whether the command-line option for flipping
the block on its Y axis is displayed for this component.

Allow Y flip

Specifies whether the command-line option for specifying
an alternate base point is displayed for this component.

Allow Base point

Parameters for Recipes Using Bookends Jigs
Bookends jigs are used to insert components that consist of a pattern repeated
as a linear array but bounded by unique items at each end. Thus, the recipe
must define a start block, a repeat block, and an end block. Refer to the
following table if you are adding a new detail component (or editing one that
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was created using the New Component option) and you want to define a
recipe that uses a bookends jig to insert the component in the specified view.

NOTE Parameters preceded by an asterisk (*) are specified separately for the start
block, the repeat block, and the end block.

Description/InstructionsParameter Name

Specifies the layer key for the layer to which the compon-
ent will be assigned in the specified view. To specify a

Layer key

layer key or change the existing one, click the worksheet

icon (  ) to access the Select Layer Key dialog box.

Specifies whether the blocks comprising the component
are inserted as a single block.

Block entire component

Specifies the drawing file (a DWG, DWT, or DWS file)
containing the blocks for the component table.

Block drawing location

A drop-down list lets you specify either Fixed value or
Database. If you select Fixed value, the value you enter

*Block type

for the corresponding Block parameter will apply to every
row in this component’s size table. If you select Database,
a column (with the name specified for the corresponding
Block field parameter) will be added to the component
table, allowing different block definitions to be specified
for individual sizes.

Displayed only if Block type is Fixed value, this parameter
specifies the block definition to be used for all sizes.

*Block

Displayed only if Block type is Database, this parameter
specifies the name of the component table column in
which the block definition is specified for each size.

*Block field

Specifies the layer key for the layer to which the block will
be assigned in the specified view. To specify a layer key

*Layer key

or change the existing one, click the worksheet icon ( 
) to access the Select Layer Key dialog box.

A drop-down list lets you specify either Fixed value or
Database. If you select Fixed value, the value you enter

*Scaling type
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Description/InstructionsParameter Name

for the corresponding Scale parameter will apply to every
row in this component’s size table. If you select Database,
a column (with the name specified for the corresponding
Scale field parameter) will be added to the component
table, allowing values to be entered for individual sizes.

Displayed only if Scaling type is Fixed value, this parameter
specifies the scaling value for the block.

*Scale

Displayed only if Scaling type is Database, this parameter
specifies the name of the component table column in

*Scale field

which the scaling value for the block is specified for each
size.

A drop-down list lets you specify Fixed value, Database,
or Block extents. If you select Fixed value, the value you

*Width type

enter for the corresponding Width parameter will apply
to every row in the size table for this component. If you
select Database, a column (with the name specified for
the corresponding Width field parameter) will be added
to the component table, allowing values to be entered
for individual sizes. If you select Block extents, then block
width is calculated dynamically as the block is inserted.

Displayed only if Width type is Fixed value, this parameter
specifies the width for the block.

*Width

Displayed only if Width type is Database, this parameter
specifies the name of the component table column in
which the block width is specified for each size.

*Width field

Specifies the distance between repeat blocks. A negative
value causes blocks to overlap.

Gap

Specifies the string to display for the start point prompt.Start prompt

Specifies the string to display for the endpoint prompt.End prompt

Specifies whether the block is oriented along the X axis
or the Y axis.

Block orientation
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Description/InstructionsParameter Name

Specifies whether the jig is oriented along the X axis or
the Y axis.

Jig orientation

Specifies whether the command-line option for flipping
the block on its X axis is displayed for this component.

Allow X flip

Specifies whether the command-line option for flipping
the block on its Y axis is displayed for this component.

Allow Y flip

Parameters for Recipes Using Linear Array Jigs
Linear Array jigs are used to insert multiple copies of a block in a line along
the X or Y axis. Refer to the following table if you are adding a new detail
component (or editing one that was created using the New Component option)
and you want to define a recipe that uses a linear array jig to insert the
component in the specified view.

DescriptionParameter Name

Specifies the layer key for the layer to which the compon-
ent will be assigned in the specified view. To specify a

Layer key

layer key or change the existing one, click the worksheet

icon (  ) to access the Select Layer Key dialog box.

Specifies whether the blocks comprising the component
are inserted as a single block.

Block entire component

Specifies the drawing file (a DWG, DWT, or DWS file)
containing the blocks for the component table.

Block drawing location

A drop-down list lets you specify either Fixed value or
Database. If you select Fixed value, the value you enter

Block type

for the corresponding Block parameter will apply to every
row in this component’s size table. If you select Database,
a column (with the name specified for the corresponding
Block field parameter) will be added to the component
table, allowing different block definitions to be specified
for individual sizes.
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DescriptionParameter Name

Displayed only if Block type is Fixed value, this parameter
specifies the block definition to be used for all sizes.

Block

Displayed only if Block type is Database, this parameter
specifies the name of the component table column in
which the block definition is specified for each size.

Block field

A drop-down list lets you specify either Fixed value or
Database. If you select Fixed value, the value you enter

Scaling type

for the corresponding Scale parameter will apply to every
row in this component’s size table. If you select Database,
a column (with the name specified for the corresponding
Scale field parameter) will be added to the component
table, allowing values to be entered for individual sizes.

Displayed only if Scaling type is Fixed value, this parameter
specifies the scaling value for the block for all sizes.

Scale

Displayed only if Scaling type is Database, this parameter
specifies the name of the component table column in

Scale field

which the scaling value for the block is specified for each
size.

A drop-down list lets you specify Fixed value, Database,
or Block extents. If you select Fixed value, the value you

Width type

enter for the corresponding Width parameter will apply
to every row in the size table for this component. If you
select Database, a column (with the name specified for
the corresponding Width field parameter) will be added
to the component table, allowing values to be entered
for individual sizes. If you select Block extents, then block
width is calculated dynamically as the block is inserted.

Displayed only if Width type is Fixed value, this parameter
specifies the width for the block for all sizes.

Width

Displayed only if Width type is Database, this parameter
specifies the name of the component table column in
which the block width is specified for each size.

Width field
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DescriptionParameter Name

Specifies the distance between repeat blocks. A negative
value causes blocks to overlap.

Gap

Specifies the string to display for the start point prompt.Start prompt

Specifies the string to display for the endpoint prompt.End prompt

Specifies whether the command-line options for specifying
a count are displayed (see Count prompt parameter be-
low).

Display count option

Displayed only if the Display count option parameter is
Yes, this parameter specifies the command-line prompt
to be displayed.

Count prompt

Specifies whether the block is oriented along the X axis
or the Y axis.

Block orientation

Specifies whether the jig is oriented along the X axis or
the Y axis.

Jig orientation

Specifies whether the command-line option for flipping
the block on its X axis is displayed for this component.

Allow X flip

Specifies whether the command-line option for flipping
the block on its Y axis is displayed for this component.

Allow Y flip

Parameters for Recipes Using Surface Jigs
Surface jigs are used to insert components that have a specified depth and a
hatch-filled rectangular boundary with user-specified start points and
endpoints. Refer to the following table if you are adding a new detail
component (or editing one that was created using the New Component option)
and you want to define a recipe that uses a surface jig to insert the component
in the specified view.

DescriptionParameter Name

Specifies the layer key for the layer to which the compon-
ent boundary will be assigned in the specified view. To

Layer key

specify a layer key or change the existing one, click the
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DescriptionParameter Name

worksheet icon (  ) to access the Select Layer Key
dialog box.

Specifies the layer key for the layer to which the compon-
ent hatch infill will be assigned in the specified view. To

Layer key (for hatching)

specify a layer key or change the existing one, click the

worksheet icon (  ) to access the Select Layer Key
dialog box.

A drop-down list lets you specify either Fixed value or
Database. If you select Fixed value, the value you enter

Hatching type

for the corresponding Hatch alias parameter will apply to
every row in this component’s size table. If you select
Database, a column (with the name specified for the cor-
responding Hatching parameter) will be added to the
component table, allowing values to be entered for indi-
vidual sizes.

Displayed only if Hatching type is Fixed value, this para-
meter specifies the hatch alias (from the Hatches table for
this database) for all sizes of the component.

Hatch alias

Displayed only if Hatching type is Database, this parameter
specifies the name of the component table column in
which the hatch is specified for each size.

Hatching

Specifies the string to display for the start point prompt.Start prompt

Specifies the string to display for the endpoint prompt.End prompt

Specifies whether the command-line option for flipping
the block on its X axis is displayed for this component.

Allow X flip

Specifies whether the command-line option for flipping
the block on its Y axis is displayed for this component.

Allow Y flip
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Parameters for Recipes Using Surface Linetype Jigs
Surface linetype jigs are similar to surface jigs in that they are used to insert
components that have a specified depth and a rectangular boundary with
user-specified start points and endpoints. Instead of a hatch-filled boundary,
however, the surface linetype jig fills the boundary with a wide polyline of a
specified linetype. Refer to the following table if you are adding a new detail
component (or editing one that was created using the New Component option)
and you want to define a recipe that uses a surface linetype jig to insert the
component in the specified view.

DescriptionParameter Name

Specifies the layer key for the layer to which the compon-
ent boundary will be assigned in the specified view. To

Layer key

specify a layer key or change the existing one, click the

worksheet icon (  ) to access the Select Layer Key
dialog box.

Specifies the layer key for the layer to which the compon-
ent infill will be assigned in the specified view. To specify

Linetype/Layer key

a layer key or change the existing one, click the worksheet

icon (  ) to access the Select Layer Key dialog box.

A drop-down list lets you specify either Fixed value or
Database. If you select Fixed value, the value you enter

Linetype type

for the corresponding Linetype parameter will apply to
every row in this component’s size table. If you select
Database, a column (with the name specified for the cor-
responding Linetype field parameter) will be added to the
component table, allowing values to be entered for indi-
vidual sizes.

Displayed only if Linetype type is Fixed value, this para-
meter specifies the linetype alias for all sizes of the com-
ponent.

Linetype

Displayed only if Linetype type is Database, this parameter
specifies the name of the component table column in
which the linetype is specified for each size.

Linetype field

Specifies the string to display for the start point prompt.Start prompt
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DescriptionParameter Name

Specifies the string to display for the endpoint prompt.End prompt

Specifies whether the command-line option for flipping
the block on its X axis is displayed for this component.

Allow X flip

Specifies whether the command-line option for flipping
the block on its Y axis is displayed for this component.

Allow Y flip

Parameters for Recipes Using Surface Top Jigs
Surface top jigs are similar to surface jigs in that they are used to insert
components with a specified depth and a hatch-filled rectangular boundary.
However, the surface top jig is designed for components such as concrete
topping that are poured onto or bounded by another entity, which provides
the bottom edge of the rectangle. Thus, the surface top jig draws only the top
and side edges of the rectangle. Refer to the following table if you are adding
a new detail component (or editing one that was created using the New
Component option) and you want to define a recipe that uses a surface top
jig to insert the component in the specified view.

DescriptionParameter Name

Specifies the layer key for the layer to which the compon-
ent boundary will be assigned in the specified view. To

Layer key

specify a layer key or change the existing one, click the

worksheet icon (  ) to access the Select Layer Key
dialog box.

Specifies the layer key for the layer to which the compon-
ent hatch infill will be assigned in the specified view. To

Layer key (for hatching)

specify a layer key or change the existing one, click the

worksheet icon (  ) to access the Select Layer Key
dialog box.

A drop-down list lets you specify either Fixed value or
Database. If you select Fixed value, the value you enter

Hatching type

for the corresponding Hatch alias parameter will apply to
every row in this component’s size table. If you select
Database, a column (with the name specified for the cor-
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DescriptionParameter Name

responding Hatching parameter) will be added to the
component table, allowing values to be entered for indi-
vidual sizes.

Displayed only if Hatching type is Fixed value, this para-
meter specifies the hatch alias (from the Hatches table for
this database) for all sizes of the component.

Hatch alias

Displayed only if Hatching type is Database, this parameter
specifies the name of the component table column in
which the hatch is specified for each size.

Hatching

Specifies the string to display for the start point prompt.Start prompt

Specifies the string to display for the endpoint prompt.End prompt

Specifies whether the command-line option for flipping
the block on its X axis is displayed for this component.

Allow X flip

Specifies whether the command-line option for flipping
the block on its Y axis is displayed for this component.

Allow Y flip

Configuring Detail Component Database Availability
AutoCAD Architecture provides a detail component database
(AecDtlComponents.mdb), which is based on the CSI MasterFormat 2004
standard. You can add other detail component databases to accommodate
your office standards or other project-specific requirements. You can also
remove databases from the active list, depending on whether you want them
available to a particular project. For a given project, you can also control
whether users can see and access all detail component databases or only those
associated with the project. For more information, see Specifying the Project
Detail Component Databases for a Project on page 343.

Adding a Detail Component Database to Available Databases
Use this procedure to add a database to the list of active detail component
databases from which components can be selected for insertion, copied to a
tool palette, or used to modify an existing tool.
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1 Click  ➤ Options.

2 In the Options dialog box, click the AEC Content tab.

3 On the AEC Content page, click the Add/Remove button for Detail
Component Databases.

4 In the Configure Detail Component Databases dialog box, click
Add.

5 In the Select Component Database browser window, locate the
database you want to add, and click Open.

The selected database is added to the bottom of the list in the
Configure Detail Component Databases dialog box.

6 Click OK twice.
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Removing a Detail Component Database from Available
Databases

Use this procedure to remove a database from the list of active detail
component databases.

1 Click  ➤ Options.

2 In the Options dialog box, click the AEC Content tab.

3 On the AEC Content page, click the Add/Remove button for Detail
Component Databases.

4 In the Configure Detail Component Databases dialog box, select
the database you want to remove from the list, and click Remove.

5 Click OK twice. Note that if you remove the top database in the
list, the next database listed becomes the current selection in the
Detail Component Manager dialog box.

Setting Detail Component Database Permissions in a
Multi-User Environment

If you are working in a multi-user network environment with keynote and
detail content on a remote server, you may want to allow some users to edit
databases and others to have read-only access. For this to work properly, all
users must have write permission to the folder where the databases are
installed. Without write permission to the folder, a user will not be able to
open any database within the folder, because the necessary lock file cannot
be generated on that user’s behalf, regardless of whether the user has write
permission to the database itself. Once all users have write permission to the
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folder, permissions for individual databases (*.mdb files) can then be set on
a per-user basis. Note, however, that this arrangement allows users to access
and edit other content within the folder, such as drawing, image, and XML
recipe files, unless you set permissions on these files individually to prevent
it. For this reason, you may want to keep the folders containing keynote and
detail content separate from other content installed with AutoCAD Architecture
so that write permission is not available to all users for all content.

Merging Old and New Detail Component Databases
If you have modified one of the default detail component databases supplied
with a previous release of AutoCAD Architecture, and you want to migrate
your modifications to the corresponding database in the current release, you
can do so using the Detail Component/Keynote Database Migration utility.
For detailed instructions, see Migrating Detail Component and Keynote
Databases on page 4001.

IMPORTANT Beginning with AutoCAD Architecture 2012, the US detail component
and keynote databases supplied with the software use the CSI MasterFormat 2004
standard. Using the Detail Component/Keynote Database Migration utility to
migrate your customizations from a database that uses the CSI MasterFormat 95
standard (as in Autodesk Architectural Desktop 2007 and previous releases) is not
supported. The utility will not properly migrate custom records from the older
database and may errantly overwrite records in the new database with
MasterFormat 95 data. If you want to use a MasterFormat 95 database with the
current release of AutoCAD Architecture, you can load it as described under Adding
a Detail Component Database to Available Databases on page 3583 or Adding a
Keynote Database on page 3635. Note that the older database must be located with
the previous release content and must maintain that content folder structure to
function properly. An older detail component database will not function with 2008
or later US details content. Likewise, an older keynote database will not
automatically keynote 2008 or later US details content; it will only keynote detail
components inserted using previous version details or details in previous version
drawings. The Detail Component/Keynote Database Migration utility can still be
used to migrate records from one CSI MasterFormat 95 database to another.
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Annotation and Keynoting
Tools

Annotation tools let you easily insert multiline text annotations with or without leaders,
keynotes that scale and layer key automatically, and cut lines with single or double breaks
that can mask or trim underlying objects. You can edit multiline attributes used in multi-view
blocks. You can create and manipulate many kinds of multiline leaders. Annotation scaling
allows you to plot annotation at the same height or size at different specified annotation
scales. You can link display configurations to specific annotation scales as well, and carry
participating annotation scales from one AEC object to another. The keynote tools support
both reference keynoting and sheet keynoting. You can manually select keynotes to insert,
or you can apply pre-specified keynotes at various levels: object, object component,
two-dimensional (2D) section/elevation linework, or detail component.

The Basic Annotation Tool
AutoCAD Architecture uses the same basic customizable tool for adding the
following types of annotations to drawings:

■ Multiline text notes with single or multiline leaders

■ Symbol-based notes with attributes

■ Reference keynotes

■ Sheet keynotes

■ Break marks

The specific type of annotation, its appearance, and other characteristics are
determined by editable values on the Tool Properties worksheet, which is
accessed from the context menu of the tool. Annotation objects are created at
a scale based on the specified annotation scale.
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Several default versions of this annotation tool are provided with the software,
each representing a different configuration of the Tool Properties worksheet.
Depending on how your system is set up, you may find one or more of these
tools (or locally customized versions of them) on the sample Annotation tool
palette in the workspace. These tools are also available from the Stock Tools
Catalog and the Documentation Tool Catalog in the Content Browser. Using
the i-drop® feature, you can copy any of these tools to a tool palette in the
workspace and customize it to meet your needs.

The basic annotation tool lets you insert either text-based or block-based
annotations. In both cases, the annotation can be created with or without a
leader that connects it visually to a particular object or point in the drawing.
The annotation tool also supports keynoting, where a predefined keynote is
retrieved from a database, either through direct selection or automatically,
based on a selected object within the drawing. Generally, text-based
annotations are used for reference keynoting, and block-based annotations
are used for sheet keynoting. However, the annotation tool accommodates
many different styles of drawing annotation, such as break marks.

Annotation Tool Properties

The following illustrations show the Tool Properties worksheet settings for
two of the default versions of the annotation tool: the text-based Text (Straight
Leader) tool and the block-based Square (Straight Leader) tool. Note the
different values for Content type under the General category. When the
content type is multiline text (Mtext), additional settings are displayed under
the Text category. Likewise, when the content type is Block, settings are
displayed for Symbol and Symbol location. The settings available under the
Leader category also vary based on the current value for Leader type.
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MText annotation tool properties

Block annotation tool properties

The Basic Annotation Tool | 3589



The following table lists and describes the annotation tool properties that can
be configured through the Tool Properties worksheet. Once an annotation is
inserted into a drawing, properties of the annotation or its leader can be
modified using the associated Properties palette. For more information on
modifying the text of an existing annotation, see Editing a Text-Based
Annotation on page 3606.

DescriptionProperty Cat-
egory/Name

Specifies the layer key for the layer to which annotation
is assigned. To change, click the current value (default is
ANNOBJ) to access the Select Layer Key dialog box.

General/Layer key

Specifies one or more layer key overrides. Click the work-
sheet icon to access the Select Layer Overrides dialog box.

General/Layer override

Specifies the multileader style for the annotation. Possible
styles include Text, Block, and Standard.

Multileader style

Possible values are Mtext (for basic multiline text notes
and reference keynotes) or Block (for symbols with attrib-

General/Content type

utes and sheet keynotes). When inserting an Mtext object
using default settings, you are prompted to specify text
width.

Displayed only if Content type is Block, this property
specifies the block-based symbol to be used for the an-

General/Symbol

notation. For sheet keynotes, the block contains an auto-
matically updatable field value that determines keynote
format and either specifies a particular keynote or serves
as a placeholder. The placeholder value is then replaced
by whatever keynote is associated with the selected object
or component or by a keynote selected manually during
the insertion process. For more information, see Configur-
ing the Annotation Tool for Keynoting on page 3609.

The location of the drawing file containing the specified
symbol. Click the property and use the Browse option

General/Symbol location

from the drop-down list to locate and enter the path to
the file. If this property is unspecified (--), then only those
blocks in the current drawing file are listed.

Possible values are None, Straight, or Spline.Leaders/Leader type
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DescriptionProperty Cat-
egory/Name

By default, this property is unspecified (--), and the dimen-
sion style for the current drawing is used. Or you can click

Leaders/Leader dimension
style

the property and select a style from the drop-down list.
The style controls the leader arrow head as well as the
text options as set on the Text tab of the style.

Specifies the location of the dimension style if different
from the current drawing dimension style. Click the

Leaders/Leader dimension
style location

property and use the Browse option from the drop-down
list to locate and enter the path to the selected style. If
this property is unspecified (--), then only those styles in
the current drawing are used.

Displayed only if a leader type is specified, this property
indicates whether there is a limit to the number of points

Leaders/Limit points

in the leader. If unspecified (--), the corresponding leader
setting for the current drawing is used.

Displayed only if the Limit points setting is yes, this
property specifies the maximum number of points allowed

Leaders/Maximum points

in the leader before the text or symbol is inserted. If un-
specified, the corresponding leader setting for the current
drawing is used, if applicable.

Displayed only if Content type is Mtext. For basic text
notes, this value is unspecified (--), and you enter the text

Text/Default text

upon insertion. For reference keynotes, the value should
be a placeholder keynote field. The placeholder value is
then replaced by whatever keynote is associated with the
selected object or component, or by a keynote selected
manually during the insertion process. For more informa-
tion, see Configuring the Annotation Tool for Keynoting
on page 3609.

Specifies the angle for multiline text or attribute text. The
default is Force horizontal. Other drop-down list options

Text/Angle

are As inserted (which sets text rotation at the angle of
the last leader segment) and Right reading (which keeps
the text right-side up regardless of rotation angle).
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DescriptionProperty Cat-
egory/Name

Displayed only if Content type is Block, this property
specifies whether attribute text within the symbol uses

Text/Attribute style

the target drawing text style or the style defined by the
attribute tag.

Indicates whether you are prompted to specify a width
for the annotation. If unspecified (--), the corresponding
leader setting for the current drawing is used.

Text/Prompt for width

Displayed only if Content type is Mtext and Leader type
is other than None, this property specifies whether each

Text/Always left justify

word in the annotation text is always left-justified. If un-
specified (--), the corresponding leader setting for the
current drawing is used.

Displayed only if Content type is Mtext and Leader type
is other than None, this property specifies where text at-

Text/Left side attachment

taches to a leader positioned to its left. This setting can
be selected from a drop-down list. If unspecified (--), the
corresponding leader setting for the current drawing is
used.

Displayed only if Content type is Mtext and Leader type
is other than None, this property specifies where text at-

Text/Right side attachment

taches to a leader positioned to its right. Setting can be
selected from drop-down list. If unspecified (--), the cor-
responding setting for the current drawing is used.

Displayed only if Content type is Mtext and Leader type
is other than None, this property specifies whether a

Text/Underline bottom line

leader attaches to text as an underline below the bottom
line of text. If unspecified (--), the corresponding leader
setting for the current drawing is used.

Displayed only if Content type is Mtext and Leader type
is other than None, this property specifies whether text

Text/Frame

is enclosed in a frame. If unspecified (--), the correspond-
ing leader setting for the current drawing is used.
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DescriptionProperty Cat-
egory/Name

Displayed only if Content type is Mtext, this property
specifies whether text has an opaque background to mask
out objects below it. The default setting is No.

Text/Mask background

Editing Multiline Attributes in Multi-View Blocks

You can edit multiline attributes in multi-view blocks using grips to reposition
or reconfigure text. Change the width and justification of multiline attributes
to refine your annotation text layout on your drawings. For example, you can
edit a Room tag’s attributes to fit text inside a room boundary.

Displaying Edit Attribute Justification Grips

Follow this procedure to display a multiline attribute’s width and justification
grips, as well as its standard location, rotation, and exit edit grips.

1 Select an existing tag.

The attribute Location and Edit Attributes grips are displayed.

2 Select the Edit Attributes grip.

Alternatively, you can click Tag tab ➤ Modify panel ➤ Edit

Attributes  .

The attribute Rotation, Width, Edit attribute justification, and
Exit Edit Attribute grips are displayed.

3 Select the Edit attribute justification grip.

The eight available text box justification and Exit attribute
justification grips are displayed.
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4 After you edit the attribute width or justification, select Exit
attribute justification, and then select Exit Edit Attributes to save
your changes.

The following illustration shows the attribute Location and Width grips, and
well as the multiline attribute’s bounding box. By default, the attribution
width is 0 (zero). You specify a width value to resize the extents of the
bounding box.
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The following illustration shows the available bounding box justification and
Exit edit attribute justification grips. By default, the Bottom Middle justification
is current.

The following illustration shows the results of specifying the 3 top grips as
the current multiline attribute justification. The text in green shows how the
multiline attribute would be repositioned.
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The following illustration shows the results of specifying the 3 middle grips
as the current multiline attribute justification. The text in green shows how
the multiline attribute would be repositioned.

The following illustration shows the results of specifying the 3 bottom grips
as the current multiline attribute justification. The text in green shows how
the multiline attribute would be repositioned.

Editing the Width of a Multiline Attribute

Use this procedure to change the width of a multiline attribute.

1 Select the room tag.
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2 Select the Edit Attributes grip.

3 Select one of the Width grips.

4 Specify a new grip location.

Using grips to change the width of a multiline attribute
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Break Mark Tool Properties

Block-based break mark tools are used to mask or trim underlying objects with
a polyline and an AEC Polygon. The default break mark tool is the Cut Line
tool provided on the Annotation tool palette. Additional types of break marks
are available from the Stock Tool and Documentation Catalogs of the Content
Browser. For more information about working with AEC Polygons, see AEC
Polygon Styles on page 1858.

The following table lists and describes tool properties for break marks that can
be configured through the Tool Properties worksheet. Once a break mark is
inserted into a drawing, its properties can be modified using the associated
Properties palette.

DescriptionProperty Cat-
egory/Name

Specifies the layer key for the layer to which the break
mark is assigned. To change, click the current value (de-

Layer key

fault is ANNSYMOBJ) to access the Select Layer Key dialog
box.

Specifies one or more layer key overrides. Click the work-
sheet icon to access the Select Layer Overrides dialog box.

Layer override

Specifies the block-based symbol to be used for the break
mark. For sheet keynotes, the block contains an automat-

Symbol

ically updatable field value that determines keynote format
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DescriptionProperty Cat-
egory/Name

and either specifies a particular keynote or serves as a
placeholder. The placeholder value is then replaced by
whatever keynote is associated with the selected object
or component or by a keynote selected manually during
the insertion process. For more information, see Configur-
ing the Annotation Tool for Keynoting on page 3609.

The location of the drawing file containing the specified
break mark symbol. Click the property and use the Browse

Symbol location

option from the drop-down list to locate and enter the
path to the file. If this property is unspecified (--), then
only those blocks in the current drawing file are listed.

Specifies whether the break mark inserts as Scaled or
Stretched. If Stretched is selected, the cut line is stretched

Symbol behavior

to correspond with the start point and endpoint, but the
graphic of the cut remains the same. If Scaled is selected,
the graphic in the cut line is scaled to correspond with
the start point and endpoint of the cut line.

Specifies whether the break mark has masking properties.
If this property is unspecified (--), the style defaults to the
standard style.

AEC Polygon style

Specifies the location of the drawing file containing the
AEC Polygon. Click the property and use the Browse op-

AEC Polygon style location

tion from the drop-down list to locate and enter the path
to the file. If this property is unspecified (--), then only
those AEC Polygons in the current drawing file are listed.

Specifies whether the break mark masks or trims the un-
derlying object. An AEC Polygon and a polyline together

Break mark behavior

represent the mask behavior of a break mark and do not
modify the underlying object. A polyline represents the
trim behavior of a break mark and clips the underlying
object.

This property specifies whether the cut line is represented
by a single edge of an AEC Polygon (single break) or two
parallel edges of an AEC Polygon (dual break).

Type
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Creating a Text-Only Annotation
Use this procedure to add a multiline text object (without a leader) anywhere
in the drawing area. The annotation does not have to be associated with any
object or linework.

NOTE These instructions are based on one of the annotation tool configurations
provided with the software. Depending on customization, the same tool may or
may not appear on your Annotation tool palette. However, the same basic
procedure applies to any annotation tool configuration in which the Content type
is set to Mtext, the Leader type is set to None, and the Default text is unspecified
(--). A basic Text Tool is also included in the Stock Tool Catalog in your Content
Browser.

1 On the Annotation tool palette, click the Text Tool.

Alternatively, you can click Annotate tab ➤ Text panel ➤ Text.

2 In the drawing area, specify the point where you want the
annotation to begin.

3 Press ENTER to accept the default width for the annotation, or
specify a width either by entering a value or by specifying a second
point.

4 Enter the first line of text, and press ENTER to indicate the end of
the line.

5 Press ENTER again to indicate the end of the annotation, or repeat
Step 3 for each subsequent line of text.

Each line of text is displayed on the command line as you enter
it. The completed annotation is displayed horizontally in the
drawing area when you press ENTER twice in succession.

Creating Text with Single Leader Annotation
Use this procedure to add a multiline text object with a single leader that
points to any point you specify in the drawing area. Leaders are drawn in the
same manner as polylines: you specify two points to insert a straight line
segment. Or, depending on the setting for the Limit points property, you can
specify additional points to insert an angled leader consisting of two or more
segments.
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NOTE These instructions are based on one of the annotation tool configurations
provided with the software. Depending on customization, the same tool may or
may not appear on your Annotation tool palette. However, the same basic
procedure applies to any annotation tool configuration in which the Content type
is set to Mtext, the Leader type is set to Straight, and the Default text is unspecified
(--). Leader properties can be modified on the Tool Properties worksheet of the
annotation tool. Any unspecified properties use the leader settings in effect for
the current drawing, which can be modified using the Leader Settings dialog box.
A basic Text Tool is also included in the Stock Tool Catalog in your Content
Browser.

1 On the Annotation tool palette, click the Text (Straight Leader)
tool.

Alternatively, you can click Annotate tab ➤ Keynoting
panel ➤ Text drop-down ➤ Text (Straight Leader).

2 Specify the starting point for the leader. (This determines where
the leader arrow is displayed.)

3 Specify one or more additional points to create the desired leader,
and then press ENTER.

4 Press ENTER to accept the default width for the annotation, or
specify a width either by entering a value or by specifying a second
point.

5 Enter the first line of text, and press ENTER to indicate the end of
the line.

6 Press ENTER again to indicate the end of the annotation, or repeat
Step 4 for each subsequent line of text.
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Drawing annotation text with leaders

Each line of text is displayed on the command line as you enter
it. When you press ENTER twice in succession, the completed
annotation is displayed in the drawing area.

Adding and Removing Leader Lines from Leaders
Use this procedure to add and remove leader lines from the following
Annotation tools:

■ Text (Straight Leader)

■ Square (Straight Leader)

■ Reference Keynote (Straight Leader)

■ Sheet Keynote

Adding a Leader Line

1 Select an existing leader.

2 Right-click and click Add Leader.
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A new leader is added starting from the nearest point on the leader
line or symbol that you specify.

3 Specify the new leader arrowhead location.

Adding a leader line

Removing Leader Line

1 Select an existing multiline leader.

2 Right-click and click Remove Leader.

3 Select the leader to remove.
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Removing a leader line

Creating a Break Mark
Use this procedure to add a new break mark that has the properties specified
in the break mark tool that you select.

NOTE These instructions are based on the default Cut Line tool provided with the
software. Depending on customization, the same tool may or may not appear on
your Annotation tool palette. However, the same basic procedure applies to any
break mark tool.

1 On the Annotation tool palette, click the Cut Line Tool.

2 In the drawing area, specify the point where you want the cut
line to begin.

3 Specify the point where you want the cut line to end.

4 Specify the extents of the break.

3604 | Chapter 48   Annotation and Keynoting Tools



Creating a Block-Based Annotation with a Leader
Use this procedure to add a block-based symbol with a leader that points to
any point you specify in the drawing area.

NOTE These instructions are based on one of the annotation tool configurations
provided with the software. Depending on customization, the same tool may or
may not appear on your Annotation tool palette. However, the same basic
procedure applies to any annotation tool configuration in which the Content type
is set to Block, the Leader type is set to Straight, and the Symbol and Symbol
location properties specify a block-based symbol that is accessible to the tool.
Leader properties can be modified on the Tool Properties worksheet of the
annotation tool. Any unspecified properties use the leader settings in effect for
the current drawing, which can be modified using the Leader Settings dialog box.

1 On the Annotation tool palette, click the Square (Straight Leader)
tool.

Click Annotate tab ➤ Keynoting panel ➤ Text
drop-down ➤ Square (Straight Leader).

2 Specify the starting point for the leader. (This determines where
the leader arrow is displayed.)

3 Specify one or more additional points to create the desired leader,
and then press ENTER.

The symbol and its default attribute value are inserted at the end
of the leader, and the Edit Attributes dialog box is displayed. (If
a limit has been set for the number of leader points, this happens
as soon as you specify the last point within the limit.)

4 In the Edit Attributes dialog box, edit the ID attribute text as
desired, and then click OK.

The edited attribute text is displayed within the symbol.
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Drawing block-based annotation with a leader

Editing a Text-Based Annotation
Use this procedure to edit a text-based annotation or change its typographical
characteristics using the Multiline Text Editor.

1 Double-click the annotation to display the Multiline Text Editor.

Multiline Text Editor dialog box

2 Edit the text as desired in the text editing box, or change the text
style, font, height, color, or other characteristics using the
drop-down lists and buttons on the toolbar.

3 Click OK on the toolbar or click anywhere in the drawing area to
close the Multiline Text Editor and implement your changes.

NOTE The Multiline Text Editor also lets you add automatically updatable fields
(such as a date and time stamp or other project information) to an annotation by
right-clicking the annotation and clicking Insert Field (or Edit Field, if the annotation
already includes such a field). This will display the Field dialog box. For more
information, see “Use Fields in Text” in AutoCAD Help.
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Editing a Masking Break Mark
Use this procedure to hide or show the boundary of a break mark that masks
an underlying object. A masking break mark is defined by an AEC Polygon
style and a polyline.

NOTE To see these options you must select the AEC Polygon, not the polyline
(which defines the cut line).

 ➤ Select the break mark.

Then…If you want to…

click AEC Polygon tab ➤ Modify pan-

el ➤ Show Edge  . The boundary edge of

show an edge

the break mark (represented by the AEC
Polygon) highlights. Select the edge to show,
and press ENTER.

click AEC Polygon tab ➤ Modify panel ➤ Hide

Edge  . The boundary edge of the break

hide an edge

mark (represented by the AEC Polygon)
highlights. Select the edge to hide, and press
ENTER.

Since the masking behavior of a break mark depends on an AEC
Polygon, many of the same editing options available for AEC
Polygons can also be applied to masking break marks. For more
information, see Editing AEC Polygons on page 1835 and Masking
Underlying Objects with AEC Polygons on page 1861.

Editing a Block-Based Annotation
Use this procedure to edit a block-based annotation or change its typographical
characteristics and other properties using the Edit Attributes dialog.

1 Double-click the annotation to display the Edit Attributes dialog.

NOTE Alternatively, you can click Insert tab ➤ Attributes panel ➤ Edit

Attribute drop-down ➤ Single  .
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Attribute Editor

2 Specify the changes you want to make to the annotation:

3 Click OK to dismiss the Edit Attributes dialog and implement any
changes you have made to the annotation.

Keynoting Tools
Keynoting is a consistent way of annotating the different types of drawings
in a set of construction documents to identify building materials or to provide
special instructions or explanations. AutoCAD Architecture provides a flexible
tool-based method of inserting keynotes that are linked to a keynote database
and thus can be modified globally as well as individually. This method supports
both reference keynoting (where the keynote key corresponds to a section in
an accompanying specification and may appear on different drawings) and
sheet keynoting (where keynote keys are sequentially numbered for each
drawing).

AutoCAD Architecture supplies pre-specified keynotes for its size-specific
default detail components and for architectural objects that represent
assemblies with multiple components (for example, 8” CMU wall). For
variable-size objects and material definitions, a keynote classification group
is pre-specified, and you specify a size when the keynote is inserted. For detail
components, these keynotes and groups are based on the widely used
MasterFormat 2004 standard maintained by the Construction Specifications
Institute (CSI). For assemblies, the CSI Uniformat standard is used. However,
because the software accommodates multiple keynote databases, it also supports
other common or locally developed keynoting systems, so your localized
version of AutoCAD Architecture may vary. Whatever the source of the
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keynote, you can also associate it with a particular object style or material
definition (see Specifying Keynotes on page 3631). This lets you use the keynote
insertion tools on individual components of an object or on linework in
two-dimensional (2D) sections or elevations. In cases where no keynotes are
pre-specified, you select a keynote from the available database(s). You can also
configure a keynote insertion tool to insert a particular keynote, regardless of
the insertion point (see Inserting or Editing an AEC Keynotes Field on page
3612).

In addition to tools for inserting keynotes (derived from the basic annotation
tool), the software includes tools for generating keynote legends that list
selected keynotes from one or more drawing sheets and help you to quickly
locate all instances of a particular keynote. You can also generate a keynote
legend for a drawing prior to inserting keynotes; in this case the legend would
include all keynotes that are likely to be used.

Other keynoting features include the ability to toggle the format for all
keynotes within a drawing to display keys only, notes only, or both keys and
notes. Moving the cursor over a keynote in the drawing lets you view keynote
text without having to toggle the format or zoom in.

NOTE The keynoting feature supports automatic updating of keynotes to reflect
changes to the corresponding entry in the keynote database. However, automatic
updating of a keynote to reflect changes to a keynoted object is not currently
supported. Changes in objects can be addressed using the re-keynoting option
described in Viewing and Editing Keynotes in a Drawing on page 3626.

Configuring the Annotation Tool for Keynoting
AutoCAD Architecture provides several default tools for inserting keynotes
into a drawing. If your software has not been customized locally, these tools
can be found on the sample Annotation tool palette. They are also accessible
from the Documentation Tool Catalog in the Content Browser and can be
copied to any tool palette using the i-drop® feature. These keynote insertion
tools are derived from the basic annotation tool and can be further customized
through the Tool Properties worksheet available from their context menus.

The mechanism that allows the annotation tool to insert keynotes is the AEC
Keynotes field. This is an Mtext object that specifies the type and format of
the keynote annotation to be inserted and includes an automatically updatable
field value that serves as a placeholder for the actual keynote. The keynote
itself is obtained from a database, and can be pre-specified for a selected object
or selected manually from the Select Keynote dialog box. For more information,
see Using Keynote Insertion Tools on page 3613. In cases where the same keynote
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needs to be inserted frequently, you can configure the AEC Keynotes field to
specify a particular keynote rather than serve as a placeholder.

For reference keynote insertion tools, the AEC Keynotes field value is specified
as the Default text property on the Tool Properties worksheet. For a sheet
keynote insertion tool, the AEC Keynotes field value is specified as an attribute
definition within the block identified by the Symbol and Symbol location
properties. In either case, you can insert an AEC Keynotes field or edit an
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existing one using the Field dialog box. For specific instructions, see Inserting
or Editing an AEC Keynotes Field on page 3612.
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Inserting or Editing an AEC Keynotes Field
Use this procedure to insert an AEC Keynotes field or edit an existing one for
a reference keynote tool or a sheet keynote tool.

1 Open the Tool Properties palette for the tool.

2 Open the Field dialog box:

Then…If…

double-click the Default text property. If the prop-
erty is unspecified, right-click and click Insert Field.

the Content type is
Mtext

open the drawing specified by the Symbol location
property and select the symbol. Click Insert

the Content type is
Block

tab ➤ Reference panel ➤  ➤ Edit Reference.
In the Reference Edit dialog box, click OK. Double-
click the KEY tag in the symbol to open the Edit
Attributes Definition dialog box, and then double-
click the Default value. If the value is not an updat-
able field, right-click and click Insert Field.

3 In the Field dialog, confirm that the Field category is AEC
Keynotes.

Field dialog
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4 From the Field names list, select the type and form of keynote
you want to insert.

5 If the selected Field name is Reference Key and Note or Sheet Key
and Note, select a Keynote Format to determine how the key and
the note are separated typographically.

6 Select a Format to determine case and capitalization for the
keynote text.

7 Confirm that Insert as placeholder is selected if you want to insert
pre-specified keynotes or prompt for manual keynote selection,
as applicable. Otherwise, the keynote indicated by the Key and
Note values is inserted. You can select a particular keynote by
clicking Select Keynote.

8 Click OK to close the Field dialog box and implement the AEC
Keynotes field you have specified.

Using Keynote Insertion Tools
The keynote insertion tools provided on the sample Annotation palette (also
available from the Documentation Tool Catalog in the Content Browser)
represent two basic kinds of keynotes: reference and sheet. The tool for sheet
keynotes is configured to let you draw a leader that connects the keynote to
the selected object or point. For reference keynotes, two tools are provided:
one that inserts a leader and one that inserts only the keynote.

For both sheet and reference keynotes, you have the option of keynoting
either a particular object or “nothing” (that is, a point within an empty region
of the drawing area). Both tools insert any keynote that is pre-specified for a
selected object, unless there is ambiguity, as when keynotes are specified for
the components of an object. In that case, you must select a component or
use the keynote that is pre-specified for the object as a whole. You can also
choose a different keynote from the Select Keynote dialog box. This dialog
box is presented if no keynote is pre-specified for a selected object or its
components.

The Select Keynote Dialog Box

The Select Keynote dialog box provides a hierarchical tree view of a keynote
database. You can select a keynote to insert into a drawing or to associate with
an object style, a material definition, or a detail component. This dialog box
is displayed if you attempt to keynote an object for which no keynote is
specified. You can also select it from the Field dialog box and from the dialog
boxes used to specify keynotes for architectural objects or their components.
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When generating a keynote legend, you can access the Select Keynote dialog
box during the insertion process by right-clicking and clicking from Database,
or by entering d (for database) at the command line.

You select a keynote database at the top of the dialog box. The AEC Keynote
database is the default for keynoting detail components, while the
AecKeynote-Assemblies database is the default for keynoting architectural
objects that are assemblies of multiple components.

You can expand nodes in the tree view to find individual components, or you
can type text into the Filter box below the tree view. Clicking the Filter button,
pressing TAB, or pressing ENTER expands all nodes under any node whose name
includes the text you enter. When a keynote is highlighted, clicking OK
completes the selection.

NOTE The Save button at the bottom of the dialog box and the 5 buttons arranged
vertically along the right side are displayed only if you have read-write privileges
for the currently selected keynote database. These buttons let you modify a
database by adding, editing, or deleting keynotes and keynote groups. The buttons
function in the same manner as they do in the Keynote Editor dialog box. For
detailed information, see Creating and Modifying Keynote Databases on page 3639.
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Inserting a Keynote
Use this procedure to annotate a drawing with either a sheet keynote or a
reference keynote. If using a tool configured to insert a leader, you can select
an object for the leader to point to, or you can specify a point in an empty
region of the drawing.

1 On the Annotation tool palette, click the tool for the type of
keynote you want to include. The tools included on the sample
palette include Reference Keynote, Reference Keynote w/Straight
Leader, and Sheet Keynote (which also inserts a leader).

Alternatively, you can click one of the keynote tools on the
Annotate tab ➤ Keynoting panel ➤ Keynotes drop-down.

NOTE The default leader is a straight line. You can change the leader
type and other properties using the Tool Properties palette, which is
accessed from the context menu of the tool.

2 Select the object/component/linework you want to keynote, or
press ENTER and specify a point in the drawing area.

If a keynote is already associated with your selection, you can
finish drawing the leader as explained in Step 4. Otherwise, a
dialog is displayed.

3 Specify the keynote you want to insert:

Then…If…

the Select Keynote dialog box is displayed. Make
sure the currently selected database is the one you

no keynote is associ-
ated with the selec-

want. Then navigate the hierarchical tree view to
find the keynote you want, select it, and click OK.

ted object (or if you
specified a point
rather than select-
ing an object)

the Select Element to Keynote dialog box is dis-
played.

one or more key-
notes are already

■ If you want to keynote an object component,
select it in the Component column, and click
OK.

associated with the
object style or with
the material defini-
tions of the selected
objects components

■ If you want to keynote the object as a whole,
and a keynote is specified for the object style,
select Style, and then click OK.
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Then…If…

■ If you do not see the keynote you want, click
Select Keynote to display the Select Keynote
dialog box. Select a keynote and click OK. The
keynote is now displayed in the Select Element
to Keynote dialog box. Click OK to complete
the selection process.

Select Element to Keynote dialog box

4 To insert a leader, specify one or more additional points to create
the desired leader, and then press ENTER.

The pre-specified keynote (or the keynote you specified in Step
3) is displayed. If you also inserted a leader, the keynote is attached
to the leader.

NOTE Sheet keynotes are not resolved at the time of insertion. The
attribute to be displayed inside the symbol is determined when a
sheet keynote legend is generated. Until then, sheet keynotes display
a question mark as shown in the following illustration. The sequential
numbering for resolved keynotes is based on group order and keynote
order within the source keynote database.
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Sheet keynote before and after sheet keynote legend is generated

Repeating a Keynote Insertion
After you have inserted a keynote into a drawing with a keynote insertion
tool, you can activate the same tool again by pressing ENTER, pressing the
spacebar, or right-clicking and clicking Repeat. If you have used other tools
since the one you want to repeat, you can activate the tool by right-clicking
any keynote it inserted and then clicking Add Selected.

Using Keynote Legends
AutoCAD Architecture lets you insert or view keynotes in three formats: key
only, note only, or both key and note. By using keys only, you can reduce the
amount of annotation in a drawing. However, keys alone are not likely to be
useful unless the reader also has access to the corresponding notes. The keynote
legend tool enables you to easily annotate a drawing with a keynote legend
that lists keys along with their corresponding notes. All keys and column
headings in the keynote legend can be validated at any time through a simple
context menu selection. Moreover, when viewing a drawing in model space
or paper space, you can select a keynote in the legend and quickly locate all
instances of that keynote in the drawing.
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Keynote Legend Tool Properties

The following illustrations show the Tool Properties worksheet settings for
two versions of the keynote legend tool (sheet and reference) that are included
on the sample Annotation tool palette. Under the General category, note the
different settings for Table style, Legend type, Table title, Grouping level, and
Blank rows.
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The following table describes the keynote legend tool properties that can be
configured through the Tool Properties worksheet. For information on
modifying an existing keynote legend, see Editing a Keynote Legend on page
3622.

DescriptionProperty Name

Specifies the layer key for the layer to which the legend
is assigned. To change, click the current value (default is
ANNOBJ) to access the Select Layer Key dialog box.

Layer key

Specifies one or more layer key overrides. Click the field
to access the Select Layer Overrides dialog box.

Layer override

Specifies the AutoCAD table style for the keynote legend.
Possible values are Reference Keynote Legend, Sheet

Table style

Keynote Legend, and Standard. When this property is
unspecified (--), the current table style for the drawing is
used.

Specifies the location of the drawing file containing the
table style. Click the property and use the Browse option

Table style location

from the drop-down list to locate and enter the path to
locations other than the default.

Possible values are Reference Keynote Legend, Sheet
Keynote Legend, and Basic Table.

Legend type

Specifies whether the symbol inserted for block-based
sheet keynotes also appears in the keynote legend. (Not
displayed if Legend type is Basic Table).

Display symbol

The title that appears for keynote legend in the drawing.
You can edit the default value as needed.

Table title

Specifies the number of keynoting standard organizational
levels (such as division, group, and subgroup) for which

Grouping level

headings will appear in the legend. For example, if three
levels are specified for a legend containing keynotes for
metal studs from the Aec Keynote Database, the metal
stud keynotes are listed under three headers: DIVISION 9
- FINISHES, 09100 METAL SUPPORT ASSEMBLIES, and
09110 NONLOADBEARING WALL FRAMING. For the Sheet
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DescriptionProperty Name

Keynote Legend tool, the default setting for this property
is zero. (Not displayed if Legend type is Basic Table).

Specifies the number of blank rows, if any, to be inserted
between headers in the keynote legend. (Not displayed
if Legend type is Basic Table).

Blank rows

Unspecified (--) by default. You can add a delimiter to
appear between the name of the group and its descrip-

Data delimiter

tion. Use of a delimiter adds a column to the table. (Not
displayed if Legend type is Basic Table.)

Specifies a delimiter to appear between the key and the
note. The default for both reference and sheet keynote

Group delimiter

legends is a dash (-). Use of a delimiter adds a column to
the table. (Not displayed if Legend type is Basic Table.)

Generating a Keynote Legend
Use this procedure to generate and position a keynote legend within the
current drawing. Keynotes to include in the legend can be selected individually
from the current drawing, or you can specify one or more sheets from which
all keynotes of the selected type (sheet or reference) will be included. You can
also generate a legend containing keynotes that have not yet been inserted.
In this case, you select the keynotes from a database.

1 On the Annotation tool palette, click either the Sheet Keynote
Legend tool or the Reference Keynote Legend tool.

NOTE Alternatively, you can click Annotate tab ➤ Keynoting
panel ➤ Sheet Keynote Legend drop-down ➤ Sheet Keynote Legend

 or Annotate tab ➤ Keynoting panel ➤ Sheet Keynote Legend

drop-down ➤ Reference Keynote Legend  .
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2 Specify the keynotes to be included in the keynote legend:

Then…If you want to…

select each keynote you want to include, and
press ENTER.

include only selected
keynotes from the cur-
rent drawing

right-click, and click Sheets to display the Select
Sheets for Keynote Legend dialog box. The left

include all keynotes
from other sheets

pane lists sheets in the current project. Select
sheets as desired and move them to the right
pane by clicking Add. You can also click Browse
to find and retrieve sheets from other projects
or drawings that have not been saved as sheets.
When the right pane shows all the draw-
ings/sheets from which you want to include
keynotes, click OK.

right-click, and click from Database to display
the Select Keynote dialog box. To select mul-

include selected key-
notes from a keynote
database tiple keynotes, press CTRL while you click con-

secutive keynotes. You can repeat this tech-
nique in different groups within the hierarchy.
When all selections are made, click OK.

NOTE If you select keynotes of a type other than the type specified
for the keynote legend, they will be filtered from the resulting keynote
legend.

Selecting sheets to include in keynote legend
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NOTE If your selections include keynotes from databases that do not
share the same group hierarchy, you are prompted to select one
database. Only keynotes from that database are included in the
resulting legend. To include other keynotes, you can create additional
legends by rerunning the keynote legend command and specifying
different databases.

3 Specify an insertion point for the upper-left corner of the keynote
legend table.

The keynote legend is displayed in the drawing area, automatically
layer keyed and scaled to 1:1 in paper space, or to the scale of the
current drawing in model space.

Editing a Keynote Legend
Although keynote legends are actually AutoCAD® tables, they are similar to
other AutoCAD Architecture schedule tables in that the size, location, color,
and other aspects of the keynote legends appearance can be modified using
the Properties palette or the Basic Modify Tools option on the context menu.
Individual rows, columns, and cells can also be edited through their context
menus. The topics in this section describe editing functions that apply to the
keynote legend as a whole and are available from its context menu.

Reselecting Keynotes for a Keynote Legend
Use this procedure to regenerate a keynote legend with a different selection
of keynotes. You might like this method better than adding or removing
keynotes individually, or deleting the legend and generating a new one,
especially if you have modified the size, location, or appearance of the existing
one.

1 Select the keynote legend, right-click, and click
Selection ➤ Reselect.

2 Specify the keynotes to include in the keynote legend.

Then…If you want to…

select each keynote you want to include, and
press ENTER.

include only selected
keynotes from the cur-
rent drawing
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Then…If you want to…

right click, and click Sheets to display the Select
Sheets to Keynote dialog box. The left pane

include all keynotes
from other sheets

lists sheets in the current project. Select sheets
as desired and move them to the right pane by
clicking Add. You can also click Browse to find
and retrieve sheets from other projects or
drawings that have not been saved as sheets.
When the right pane shows all the draw-
ings/sheets from which you want to include
keynotes, click OK.

right-click, and click from Database to display
the Select Keynote dialog box. You can select

include selected key-
notes from a keynote
database multiple keynotes by pressing TRL key while

clicking consecutive keynotes. You can repeat
this technique in different groups within the
hierarchy. When all selections are made, click
OK.

The keynote legend is regenerated to include only your new
selections. It may be larger or smaller, depending on whether
keynotes were added or removed, but the location and other
characteristics remain unchanged.

NOTE If your selections include keynotes from databases that do not
share the same group hierarchy, you are prompted to select one
database. Only keynotes from that database are included in the
resulting legend. To include other keynotes, you can create additional
legends as necessary by rerunning the keynote legend command and
specifying different databases.

Updating a Keynote Legend
Use this procedure to validate a keynote legend against the database on which
it was based. (All keynotes in a keynote legend must be from the same
database.) Any keynotes not found in the database are invalid and are removed
from the keynote legend.

1 Select the keynote legend.

2 Right-click, and click Update Keynote Legend.
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The keynote legend is updated to include only valid keynotes,
and the number of rows removed is reported on the command
line.

Adding Keynotes to a Keynote Legend
Use this procedure to add keynotes to a keynote legend. The procedure is
similar to generating a keynote legend, but the prompts vary depending on
whether the legend was created from selected drawings/sheets or from selected
keynotes.

1 Select the keynote legend, right-click, and click Selection ➤ Add.

2 Specify the keynotes to include in the keynote legend.

Then…If …

select each keynote you want to include, and
press ENTER.

the keynote legend was
based on keynotes selec-
ted only from the cur-
rent drawing

right-click, and click Sheets to display the Select
Sheets to Keynote dialog box. The left pane

the keynote legend was
based on keynotes from
other sheets lists sheets in the current project. Select sheets

as desired and move them to the right pane by
clicking Add. You can also click Browse to find
and retrieve sheets from other projects or
drawings that have not been saved as sheets.
When the right pane shows all the draw-
ings/sheets from which you want to include
keynotes, click OK.

right-click, and click from Database to display
the Select Keynote dialog box. To select mul-

the keynote legend was
based on keynotes selec-
ted from a database. tiple keynotes, press CTRL while you click con-

secutive keynotes. You can repeat this tech-
nique in different groups within the hierarchy.
When all selections are made, click OK.
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NOTE If your selections include keynotes from databases that do not
share the same group hierarchy, you are prompted to select one
database. Only keynotes from that database are included in the
resulting legend. To include other keynotes, you can create additional
legends by rerunning the keynote legend command and specifying
different databases.

Removing Keynotes from a Keynote Legend
You can remove keynotes from a keynote legend simply by selecting them
and pressing DELETE. Likewise, you can select and delete the rows/cells that
contain keynote division and group names.

Using a Keynote Legend to Locate Keynotes
Use this procedure to locate all instances of a selected sheet or reference
keynote in a drawing for which a keynote legend has been generated.

1 Select the keynote legend, right-click, and click Selection ➤ Show.

2 Hover the cursor above the row containing the keynote you want
to locate.

All instances of the selected keynote are highlighted in the
drawing and a tooltip displays the total number of instances. Only
those keynotes of the same type as the selected keynote legend
(sheet or reference) are highlighted or included in the count.

Alternatively, press CTRL and click a row in the legend to zoom
to a magnification that bounds all instances of the selected
keynote.

Editing Keynote Legend Table Styles
Keynote legends use AutoCAD table styles. Use this procedure to modify the
available table styles.

1 Click Home tab ➤ Annotation panel ➤  ➤ Table Style.

2 In the Styles list, select the style you want to modify, and then
click Modify.
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3 Adjust the settings under the Data, Column Heads, and Title tabs
as desired, and then click OK. For more detailed explanations of
style settings, see “New and Modify Table Style Dialogs” in
AutoCAD help.

Table Style and Modify Table Style dialogs

Viewing and Editing Keynotes in a Drawing
This section describes editing operations that can be performed on keynotes
once they have been inserted in a drawing.
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Re-Keynoting
Use this procedure to change a keynote so that it references a different keynote.
The new keynote can be from the same database as the original or from a
different one.

1 Select the keynote, right-click, and click Re-Keynote.

2 Select the keynoted object, or press ENTER if the keynote does not
apply to a specific object.

3 In the Select Keynote dialog box, select the keynote you want to
use, and then click OK.

The new keynote is added to the drawing in place of the old one.
Note that the change is not reflected in keynote legends that
include the original keynote. If the new keynote is from the same
database as the original one, you can update any associated
keynote legends by adding and deleting individual entries.
However, if different databases are involved, you must regenerate
keynote legends for each of them. In any case, if you have
performed more than a few re-keynotings, it may be preferable
to use the Reselect option on the keynote legend context menu,
or to regenerate the keynote legend. See Generating a Keynote
Legend on page 3620 and Reselecting Keynotes for a Keynote Legend
on page 3622.

Editing Keynotes
Use the following procedure to edit a keynote after it has been inserted into
a drawing. You cannot directly edit the key or the note, but you can add text
before or after the keynote using the Multiline Text Editor, and you can change
the keynote or its format using the Field dialog box.

1 Double-click the keynote to display the Multiline Text Editor.

Multiline Text Editor

2 Add text before or after the keynote, or double-click the keynote
to change the format or specify a different keynote using the Field
dialog box (see Inserting or Editing an AEC Keynotes Field on
page 3612).

Viewing and Editing Keynotes in a Drawing | 3627



3 Click OK to close the Field dialog box, if necessary.

4 Click OK on the toolbar or click anywhere in the drawing area to
close the Multiline Text Editor and implement your changes.

NOTE You can also add automatically updatable fields (such as a date and time
stamp or other project information) before or after the keynote by right-clicking
and clicking Insert Field.

Changing Keynote Formats
Keynotes can be displayed in three formats: key only, note only, or both key
and note. When using both keys and notes, you can also specify the
typographical device used to separate the key from the note (for example, key
- note as opposed to key:note).

You can change keynote formats individually or globally within a single
drawing. For example, you may want to display both keys and notes while
you are keynoting a drawing, but display only keys when you finish.

Changing Individual Keynote Formats
Use this procedure to change the format of a keynote that has been inserted
in a drawing.

1 Double-click the keynote to display the Multiline Text Editor.

2 In the Text Formatting box, right-click the selected keynote.

3 In the Field dialog box, make sure the current Field category is
Aec Keynotes, and then select a keynote format under Field names.
If one of the key-and-note options is selected, you can select an
option under Keynote Format. You can also change the setting
under Format, if desired.
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Keynote format options in the Field dialog box

4 Click OK twice.

The selected keynote is reformatted.

Globally Changing Keynote Formats
Use this procedure to change the format of all keynotes of a given type
(reference or sheet) within a drawing.

1 Click Annotate tab ➤ Keynoting panel ➤  ➤ Reference

Keynote Display  . or click Annotate tab ➤ Keynoting panel ➤ 

 ➤ Sheet Keynote Display  .

2 In the Select Reference Keynote Display or Select Sheet Keynote
Display dialog box, select an option for Field names. If you select
the Key and Note option, you can also select an option for Keynote
Formats. You can change the Format setting regardless of the Field
name selection.
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Select Reference Keynote Display dialog (identical for sheet keynotes)

3 Click OK to implement the format changes for all keynotes of the
selected type within the drawing.

Changing Databases for Existing Keynotes
AutoCAD Architecture keynoting functionality includes a tool that lets you
globally change database references for existing keynotes within a drawing,
provided the same keys exist in both the currently referenced database and
the one you want to use instead. When you run the tool, it identifies all
currently referenced databases for selected keynotes in the drawing, and then
prompts you to identify the database you want to switch from and the database
you want to switch to. This capability is useful in situations where it is
discovered that project team members have inadvertently used two different
databases to keynote a drawing, or when you decide to switch from an office
standard keynote database to a project standard keynote database. The tool
can be run from the command line by entering AecKeynoteDatabaseReselect,
or you can set it up as a menu selection, as in the following procedure.

1 Click Annotate tab ➤ Keynoting panel ➤  ➤ Select Database

 .

2 Select the keynotes you want to run the tool against and press
ENTER.

All databases referenced by the selected keynotes are listed on the
command line.

3 Enter the full path or the Globally Unique ID (GUID) for the
database currently referenced by the keynotes you want to change.
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4 Enter the full path or the Globally Unique ID (GUID) for the
database you want to be referenced.

The number of keynotes updated by the tool is displayed on the
command line.

Specifying Keynotes
AutoCAD Architecture provides pre-specified keynotes for detail components
and many architectural objects that are included with the software. You can
change these associations to specify different keynotes from either the
AecKeynotes or AecKeynotes-Assemblies databases or from a database that
you have loaded. You can also specify keynotes for individual components of
architectural objects by associating keynotes with material definitions. Because
material definitions supplied with the software are not size-specific, individual
keynotes are not pre-specified. Instead, each material definition is
pre-associated with a particular group from the MasterFormat 2004 scheme.
This streamlines the process of locating the appropriate keynote when you
want to specify one for the material.

The method used to specify a keynote depends on the type of object. For
architectural objects and their components, you associate keynotes with
individual styles and material definitions using the Style or Material Definition
Properties dialog box, which can be accessed through the Style Manager or
from the context menu of the object. For detail components, you use the
Detail Component Manager to access and edit the Keynote field values.

Specifying Keynotes for Object Styles
Use this procedure to specify a keynote for an architectural object by associating
the keynote with the object style. The same procedure applies whether you
are specifying a keynote association for the first time or changing an existing
one. Note, however, that if you change the keynote association for an object
style, it does not affect previously inserted keynotes for objects created using
that style. Those objects must be re-keynoted if you want them to reflect the
newly specified keynote.

If you are establishing keynote associations for a number of the object styles
that are included with AutoCAD Architecture, you may find it most efficient
to work from the Styles drawing files (located at C:\ProgramData\Autodesk\ACA
2012\enu\Styles).

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .
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2 In the left pane of the Style Manager, expand Architectural Objects
and any subcategories as necessary to locate the object style for
which you want to specify a keynote.

3 Select the desired object style.

4 On the General tab of the Style Properties dialog box, click Select
Keynote.

5 In the Select Keynote dialog box, make sure the correct database
is displayed in the Keynote Database field (if you are using the
default keynote databases, it should be AecKeynote-Assemblies),
and then select the desired keynote from the hierarchical tree
view.

6 Click OK twice.

The keynote is specified for the selected object style and will be
used for subsequent keynote insertions for objects using that style.

Specifying Keynotes for Object Components
Use this procedure to specify a keynote for a particular component of an
architectural object by associating the keynote with the material definition
for that component. The same procedure applies, whether you are specifying
a keynote association for the first time or changing an existing one. Note,
however, that if you change the keynote association for a material definition,
it does not affect previously inserted keynotes for object components using
that material definition. Those object components must be re-keynoted if you
want them to reflect the newly specified keynote.

If you are establishing keynote associations for a number of material definitions
that are included with AutoCAD Architecture, you may find it most efficient
to work from the material definitions drawing file (located at
C:\ProgramData\Autodesk\ACA 2012\enu\Styles).

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 In the left pane of the Style Manager, expand Multi-Purpose
Objects, and expand Material Definitions. Locate the material
definition for which you want to specify a keynote.

3 Select the desired material definition.

4 On the General tab of the Material Definition Properties dialog
box, click Select Keynote.

5 In the Select Keynote dialog box, make sure the correct database
is displayed in the Keynote Database field (if you are using the
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default keynote databases, it should be Aec Keynote), and then
select the desired keynote from the hierarchical tree view.

6 Click OK twice.

The keynote is specified for the selected material definition and
will be used for subsequent keynote insertions for object
components with that material definition.

Specifying Keynotes for Detail Components
Use this procedure to specify a keynote for a detail component. The same
procedure applies, whether you are specifying a keynote association for the
first time or changing an existing one. Note, however, that if you change the
keynote association for a detail component, it does not affect previously
inserted keynotes for that detail component. Those detail components must
be re-keynoted if you want them to reflect the newly specified keynote.

1 Click Home tab ➤ Details panel ➤ Detail Components  .

2 In the Detail Component Manager, make sure the Current detail
component database field displays the correct database.

3 In the hierarchical tree view, select the group that contains the
detail component for which you want to specify a keynote, and
then select the detail component in the size table at the bottom
of the window.

4 Resize the Detail Component Manager window, or use the scroll
bar at the bottom of the window as necessary so that the Keynote
column is visible.

5 Select the Keynote field for the selected detail component,
right-click, and click Edit.

6 In the Select Keynote dialog box, make sure the correct database
is displayed in the Keynote Database field, and then select the
desired keynote from the hierarchical tree view.

7 Click OK.

The key for the selected keynote is displayed in the Keynote field.

8 Click Close, and click Yes when prompted to save changes.

The keynote is specified for the selected detail component and
will be used for subsequent keynote insertions for that component.
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NOTE If no keynote is specified for the detail component, the Select
Keynote dialog box is displayed. If a keynote is specified for the
components table or group to which the detail component belongs,
the node representing that group is highlighted within the tree view.
Keynotes cannot be specified at the table level using AutoCAD
Architecture functionality. This requires customization of the detail
component database using Microsoft® Access.

Working with Keynote Databases
Keynotes used in AutoCAD Architecture are stored in Microsoft® Access
databases. There are two default keynote databases:

■ AecKeynotes: This database is used for keynoting individual detail
components and materials according to the Construction Specifications
Institute (CSI) MasterFormat 2004 standard.

■ AecKeynotes-Assemblies: This database is used for keynoting architectural
objects that are assemblies of multiple components. These keynotes are
based on the CSI Uniformat standard.

To accommodate proprietary office standards and other project-specific
keynoting schemes, you can modify the default databases or you can create
your own databases using either Microsoft® Access or the editing functionality
provided with the software. You can also configure keynote databases to
control which ones are available for assigning to individual projects and to
specify the order in which they are searched.

Configuring Keynote Databases
AutoCAD Architecture supports multiple keynote databases, which you can
assign to individual projects (see Specifying the Project Detail Component
Databases for a Project on page 343). When you are working within a given
project, only those databases assigned to that project are accessible through
the Select Keynote dialog box.

Before a database can be assigned to a project, however, it must be on the list
of available databases. Both keynote databases provided with the software
(AecKeynotes and AecKeynotes-Assemblies) are included on this list by default.
You can add databases to the list or remove them. If a particular keynote exists
in multiple databases, you can specify the order in which the databases are
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searched to find a keynote that has been specified for an object. (Only the key
is stored with the object style; the corresponding note must be retrieved from
a database at the time of insertion.)

Adding a Keynote Database
Use this procedure to add a database to the list of available keynote databases.

1 Click  ➤ Options.

2 In the Options dialog box, click the AEC Content tab.

3 On the AEC Content page, click the Add/Remove button for
Keynote Databases.

4 In the Add/Remove Keynote Databases dialog box, click Add.

5 In the Select Component Database browser window, locate the
database you want to add, and click Open.
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The selected database is added to the bottom of the list in the
Add/Remove Keynote Databases dialog box. You can specify the
order in which databases are searched by clicking the Move Up
and Move Down buttons to change the position of a selected
database within the list. Moving a database to the top of the list
makes it the default selection for the Select Keynote dialog box.

6 Click OK twice.

Removing a Keynote Database
Use this procedure to remove a database from the list of available keynote
databases.

1 Click  ➤ Options.

2 In the Options dialog box, click the AEC Content tab.

3 On the AEC Content page, click the Add/Remove button for
Keynote Databases.

4 In the Add/Remove Keynote Databases dialog box, select the
database you want to remove from the list, and click Remove.
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5 Click OK twice. Note that if you remove the top database in the
list, the next database listed becomes the default selection in the
Select Keynote dialog box.

Merging Old and New Keynote Databases
If you have modified one of the default keynote databases supplied with a
previous release of AutoCAD Architecture, and you want to migrate your
modifications to the corresponding database in the current release, you can
do so using the Detail Component/Keynote Database Migration utility. For
detailed instructions, see Migrating Detail Component and Keynote Databases
on page 4001.

Working with Keynote Databases | 3637



IMPORTANT Beginning with AutoCAD Architecture 2012, the US detail component
and keynote databases supplied with the software use the CSI MasterFormat 2004
standard. Using the Detail Component/Keynote Database Migration utility to
migrate your customizations from a database that uses the CSI MasterFormat 95
standard (as in Autodesk Architectural Desktop 2007 and previous releases) is not
supported. The utility will not properly migrate custom records from the older
database and may errantly overwrite records in the new database with
MasterFormat 95 data. If you want to use a MasterFormat 95 database with the
current release of AutoCAD Architecture, you can load it as described under Adding
a Detail Component Database to Available Databases on page 3583 or Adding a
Keynote Database on page 3635. Note that the older database must be located with
the previous release content and must maintain that content folder structure to
function properly. An older detail component database will not function with 2008
or later US details content. Likewise, an older keynote database will not
automatically keynote 2008 or later US details content; it will only keynote detail
components inserted using previous version details or details in previous version
drawings. The Detail Component/Keynote Database Migration utility can still be
used to migrate records from one CSI MasterFormat 95 database to another.

Setting Keynote Database Permissions in a Multi-User
Environment

If you are working in a multi-user network environment with keynote and
detail content on a remote server, you may want to allow some users to edit
databases and others to have read-only access. For this to work properly, all
users must have write permission to the folder where the databases are
installed. Without write permission to the folder, a user will not be able to
open any database within the folder, because the necessary lock file cannot
be generated on that user’s behalf, regardless of whether the user has write
permission to the database itself. Once all users have write permission to the
folder, permissions for individual databases (*.mdb files) can then be set on
a per-user basis. Note, however, that this arrangement allows users to access
and edit other content within the folder, such as drawing, image, and XML
recipe files, unless you set permissions on these files individually to prevent
it. For this reason, you may want to keep the folders containing keynote and
detail content separate from other content installed with AutoCAD Architecture
so that write permission is not available to all users for all content.
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Creating and Modifying Keynote Databases
You can create and modify keynote databases using Microsoft® Access directly
if you are familiar with that product and with the structure of keynote
databases in AutoCAD Architecture (for more information, see Keynote
Database Schema on page 3649). However, the preferred method is to use the
Keynote Editor provided with the software. For databases to which you have
read/write access, most of the Keynote Editor functions are also available from
the Select Keynote dialog box.

NOTE If you are working in a multi-user environment, it is recommended that
you modify a keynote database only when no other users are accessing it.

The Keynote Editor
The Keynote Editor is a standalone application that lets you create and modify
keynote databases. Accessed from the CAD Manager menu, the Keynote Editor
dialog box provides a hierarchical tree view of the currently selected database,
which displays as a root node. For an existing database, you can expand the
root node to display groups, and then expand group nodes to display
sub-groups or individual keynotes. Alternatively, you can enter text into the
Filter box below the tree view. Clicking the Filter button, pressing TAB, or
pressing ENTER expands all nodes under any node whose name includes the
text you enter.

If you are creating a new database, you add the root node using the New
Database button, and then add groups and keynotes using the buttons along
the right side of the dialog box. These buttons (Add Group, Delete, Add
Keynote, Edit, and Specify Keysort) are also available from the Select Keynote
dialog box for databases to which you have read-write access.
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Creating a Keynote Database
Using the Keynote Editor to create a new keynote database entails the following
basic steps:

1 Create a blank database by specifying a name and location. (For
detailed instructions, see Creating a Blank Keynote Database on
page 3641.)

2 Add groups and subgroups to reflect the major and minor divisions
within the keynoting scheme. (For detailed instructions, see
Adding Groups to a Keynote Database on page 3642.)

3 Add individual keynotes within groups and subgroups as
applicable. (For detailed instructions, see Adding Keynotes to a
Keynote Database on page 3643.)

4 Save the new database.
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After saving the new database, you can add it to the list of available databases
(see Adding a Keynote Database on page 3635) and assign it to projects (see
Specifying the Project Detail Component Databases for a Project on page 343).

Creating a Blank Keynote Database
Use this procedure to create a blank Microsoft® Access database with all
required tables and queries for keynote storage and retrieval. This is the first
step in creating a new keynote database using the Keynote Editor.

1 Click Annotate tab ➤ Keynoting panel ➤  ➤ Keynote Editor

 .

2 At the bottom of the Keynote Editor dialog box, click New
Database.

The Create a new keynote database browser window is displayed.

3 In the browser window, navigate to the location for the new
database.

4 Enter a name for the new database in the File name field.

5 Click Save.

A node named New Keynote Database is displayed in the Keynote
Editor.

6 Select the new database node, and click  .
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7 In the Keynote Database Properties dialog box, enter the Display
Name, Description, and Author for the new database, and click
OK.

A blank Microsoft® Access database is created with all required
tables and queries for keynote storage and retrieval. The new
database has the global unique identifier shown in the GUID field
and is displayed in the Keynote Editor as a root node with the
display name you provided.

8 Click Save.

You can now begin populating the database by using the Keynote
Editor to add groups and individual keynotes.

Adding Groups to a Keynote Database
Use this procedure to add a group to a keynote database. You can use the same
basic procedure to add as many levels of subgroups as you want within a
group.

1 Click Annotate tab ➤ Keynoting panel ➤  ➤ Keynote Editor

 .

NOTE The rest of this procedure can also be performed from the
Select Keynote dialog box.

2 Select a database from the Keynote Database list.

3 Select the root node for the database if you want to add a top-level
group, or expand the root node and group/subgroup nodes as
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necessary until you can select the node to which you want to add
a subgroup.

4 Click  .

The Add Group dialog box is displayed with the read-only ID field
showing the database identifier for the group you are adding.

5 Enter a Group Name and a Description, and click OK.

The group or subgroup you have defined is displayed as a new
node in the hierarchical tree view.

Adding Keynotes to a Keynote Database
Use this procedure to add a keynote to a group or subgroup within a keynote
database.

1 Click Annotate tab ➤ Keynoting panel ➤  ➤ Keynote Editor

 .

NOTE The rest of this procedure can also be performed from the
Select Keynote dialog box.

2 Select a database from the Keynote Database list.

3 Expand the root node and group/subgroup nodes as necessary
until you can select the node to which you want to add a keynote.

4 Click  .
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The Add Keynote dialog box is displayed with the read-only ID
field showing the database identifier for the keynote you are
adding.

5 Enter a key and a note, and click OK.

The keynote you have defined is displayed as a new node in the
hierarchical tree view.

TIP If you need to add a series of keynotes within a group or
subgroup, you can save time by adding the first keynote, right-clicking
it, and clicking Copy Series. You then specify the number of copies
to make and click OK. The specified number of sequentially numbered
keys are added to the group. For example, if you create key A1001
and then use the Copy Series option to add 10 copies, keys A1002
through A1011 are added. You can then edit keynote nodes
individually to add the notes, as explained under Adding Components
to a Detail Component Database on page 3569.

Editing Groups in a Keynote Database
Use this procedure to change the name or description of a group within a
keynote database.

1 Click Annotate tab ➤ Keynoting panel ➤  ➤ Keynote Editor

 .

NOTE The rest of this procedure can also be performed from the
Select Keynote dialog box.

2 Select a database from the Keynote Database list.
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3 Expand the root node and group/subgroup nodes as necessary,
and select the group/subgroup you want to edit.

4 Click  .

The Group Properties dialog box is displayed with the read-only
ID field showing the database identifier for the group you are
editing.

5 Edit the Group Name and Description values as desired, and click
OK.

Editing Keynotes in a Keynote Database
Use this procedure to change the key or the note for a keynote within a
database.

1 Click Annotate tab ➤ Keynoting panel ➤  ➤ Keynote Editor

 .

NOTE The rest of this procedure can also be performed from the
Select Keynote dialog box.

2 Select a database from the Keynote Database list.

3 Expand the root node and group/subgroup nodes as necessary,
and select the keynote you want to edit.

4 Click  .
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The Keynote Properties dialog box is displayed with the read-only
ID field showing the database identifier for the keynote you are
editing.

5 Edit the Key and Note values as desired, and click OK.

Deleting Keynotes or Groups from a Keynote Database
Use this procedure to delete one or more groups, subgroups, or keynotes from
a keynote database. Note that deleting a group also deletes any subgroups and
keynotes within that group.

1 Click Annotate tab ➤ Keynoting panel ➤  ➤ Keynote Editor

 .

NOTE The rest of this procedure can also be performed from the
Select Keynote dialog box.

2 Select a database from the Keynote Database list.

3 Select the nodes representing keynote groups, subgroups or
keynotes you want to delete.

TIP To select multiple nodes, hold down the CTRL key while clicking
the nodes.

4 Click  .

The selected nodes are deleted from the hierarchical tree view in
the Keynote Editor.
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Moving Keynotes or Groups in a Keynote Database
Use this procedure to move a keynote, group, or subgroup to a different group
or level within the database hierarchy. Note that moving a group also moves
any subgroups and keynotes within that group.

1 Click Annotate tab ➤ Keynoting panel ➤  ➤ Keynote Editor

 .

NOTE The rest of this procedure can also be performed from the
Select Keynote dialog box.

2 Select a database from the Keynote Database list.

3 Select the node (group, subgroup, or keynote) to move and drag
it to the desired location in the hierarchical tree view.

Specifying Sort Order for Keynotes
Use this procedure to specify the order in which keynotes in a given database
are listed when displayed in the Keynote Editor, the Select Keynote dialog
box, or keynote legends. To specify the sort order, you enter one or more
masks that correspond to the patterns used for keys in the database. Keynotes
are sorted on a field-by-field basis within each pattern. In other words, all
keynotes having the same key pattern as the first mask you enter will be listed
before any keynotes having the second pattern you enter.

When entering a mask, use the following conventions to represent the fields,
characters, and delimiters that comprise the key pattern:

■ Enclose sortable fields in brackets [ ] and delimiters in curly brackets { }.
Example: [field]{delimiter}[field].

■ Delimiters can be any character except a backslash (\) or any character
string that does not begin with a backslash. (The backslash is reserved for
system use.)

■ Use a pound sign (#) to indicate a numeric character and a question mark
(?) to indicate an alphanumeric character (digit, letter, or punctuation
mark).

■ For fixed-length fields, use the specified number of characters. Example:
[###] indicates a 3-digit fixed-length field.
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■ Use [#...#] to indicate a variable-length numeric field, and [?...?] for a
variable-length alphanumeric field.

■ A variable-length field is always followed by a delimiter unless it is the
final field in the mask.

As an example, the AecKeynotes database uses keys that consist of a 5-digit
field, followed by a delimiter (.), a 1-character alphanumeric field, and a
variable-length numeric field (for example, 09250.A101). The mask representing
this pattern would be [#####]{.}[?][#...#]

1 Click Annotate tab ➤ Keynoting panel ➤  ➤ Keynote Editor

 .

2 Select a database from the Keynote Database list.

3 Click  to display the Specify Key Sort dialog box.

4 In the Specify Key Sort dialog box, enter a key sort mask for each
key pattern in the selected database. Use a different line for each
mask.

5 Click OK.
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Keynote Database Schema
To create or modify a keynote database by using Microsoft® Access (rather
than using the Keynote Editor), you need to be familiar with the database
schema used in AutoCAD Architecture.

A keynote database contains four tables:

■ Fingerprint

■ Groups

■ Keynotes

■ KeySort

Fingerprint Table

The Fingerprint table uniquely identifies a keynote database and contains the
following fields:

■ GUID: The GUID is the global unique identifier for a particular keynote
database. When you insert an AEC Keynotes field to specify a keynote, a
link to the keynote database is established using this GUID and the row
ID of the keynote in the Keynotes table. If you leave this field empty when
creating a database, a GUID is generated when the database is loaded using
the Add/Remove Keynote Databases dialog box.

■ Type: For a keynote database, this field must contain the string “Keynote.”
(For a detail component database, the string must be “Component.”)

■ Author, Display Name, and Description: The values for these fields are
displayed in the corresponding fields in the Add/Remove Keynote Databases
dialog box.
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Groups Table

The Groups table defines the hierarchical organization of keynotes within the
database. This hierarchy determines the order in which divisions, groups,
subgroups and individual keynotes are displayed in the Keynote Editor, the
Select Keynote dialog box, and keynote legends. The following fields apply to
each row in the table:

■ ID: A sequential number identifying a particular row in the table. This
number should never change.

■ Parent: Identifies the parent of the group identified in the Group field.

■ Group: Identifies a particular division, group, or subgroup. Note that the
root parent group (\-*) is special and its ID is zero.

■ Description: Provides the descriptive name of the group.

■ Modified: When the box is checked, it indicates that the row has been
modified and prevents the row from being overwritten if the database is
migrated when new content is released by Autodesk. You must click the
box to enable this protection for any row you modify.
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Keynotes Table

This table defines the individual keynotes for all the groups identified in the
Groups table. The following fields are included:

■ ID: A sequential number identifying a particular row in the table. This
number should never change. This ID, combined with the GUID of the
database, is tracked by the AEC Keynotes field when you insert a keynote
into a drawing. This enables keynotes in a drawing to be updated when
changes are made to the keynote database.

■ Parent Group: Identifies the parent of the keynote, displaying the Group
and Description field values from the Groups table.

TIP If you want a flat (non-hierarchical) keynote list, you can assign the root
parent group (\-*) to all keynotes in this table.

■ Key: Specifies the key for the keynote. If you are creating a database and
have already created the Groups table, this field displays the value from
the Group field. The delimiter and suffix are user-definable.

■ Note: Provides the note for the specified key.

■ Modified: When the box is checked, it indicates that the row has been
modified and prevents the row from being overwritten if the database is
migrated when new content is released by Autodesk. You must click the
box to enable this protection for any row you modify. For more information
on database migration, see Migrating Detail Component and Keynote
Databases on page 4001.

Working with Keynote Databases | 3651



KeySort Table

This table contains key sort masks that represent the different key patterns
used in the database. The order in which the masks are listed in this table
determines the order in which key patterns are listed in the Keynote Editor,
the Select Keynote dialog box, and keynote legends; that is, all keynotes with
keys using the pattern identified by the mask in record 1 are listed before
keynotes with key patterns identified by subsequent records in the table. The
illustration above shows the key sort mask for the AecKeynotes database
provided with AutoCAD Architecture. The following conventions are used for
key sort masks:

■ Enclose sortable fields in brackets [ ] and delimiters in curly brackets { }.
Example: [field]{delimiter}[field].

■ Delimiters can be any character except a backslash (\) or any character
string that does not begin with a backslash. (The backslash is reserved for
system use.)

■ Use a pound sign (#) to indicate a numeric character and a question mark
(?) to indicate an alphanumeric character (digit, letter, or punctuation
mark).

■ For fixed-length fields, use the specified number of characters. Example:
[###] indicates a 3-digit fixed-length field.

■ Use [#...#] to indicate a variable-length numeric field, and [?...?] for a
variable-length alphanumeric field.

■ A variable-length field is always followed by a delimiter unless it is the
final field in the mask.

Examples of keys using the pattern defined by the [#####]{.}[?][#...#] mask in
the illustration above would include 03250.A1, 07250.B102, and 09250.C1007.

You can also specify key sort masks using the Keynote Editor, as explained in
Specifying Sort Order for Keynotes on page 3647.
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North Arrow and Datum Point Tools
North arrow and datum point annotations are used for defining directions in
a drawing. Formerly available as content blocks in DesignCenter, these
annotations are now available through tools on the tool palettes and in
Content Browser.

In this release of AutoCAD Architecture, north arrows and datum points are
converted from DesignCenter content blocks to true tools with tool properties.

North arrow and datum point symbols

By default, all north arrow and datum point tools are set to be annotative,
which means that the annotations you insert with these tools are controlled
by annotative scaling. For more information, see Annotation Scaling on page
3675.

IMPORTANT If you have legacy drawings with old DesignCenter-based annotation
symbols in them, then the old block definition will continue to be used for new
tool-based blocks if the blocks are identically named. (This is the case for the datum
point tool, but not the north arrow tools which have been renamed.) In such a
case, either change the Annotative setting manually by using BEDIT, or rename
the old block before inserting new tool-based annotation symbols into the drawing.

You can find north arrow tools and a datum point tool in these locations in
a default US install of AutoCAD Architecture:

■ In the Annotation tool palette
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■ In Content Browser in these catalogs:

■ Stock Tool Catalog

■ Sample Palette Catalog (Imperial or Metric), under
\Document\Annotation

■ Documentation Tool Catalog (Imperial or Metric), under \Miscellaneous

TIP You can also search for these types of tools by name in Content Browser.

These properties of north arrow and datum point tools can be customized:

DescriptionProperty Cat-
egory/Name

Specifies the layer key for the layer to which the north
arrow or datum point is assigned. To change, click the

General/Layer key

current value to access the Select Layer Key worksheet.
The default layer key for north arrows is ANNOBJ; the
default value for the datum point is ANNSYMOBJ.

Specifies one or more layer key overrides. Click the work-
sheet icon to access the Select Layer Overrides worksheet.

General/Layer overrides

Specifies the block-based symbol to be used for the north
arrow or datum point.

General/Symbol

The location of the drawing file containing the specified
north arrow or datum point symbol. Click the property

General/Symbol location

and use the Browse option from the drop-down list to
locate and enter the path to the file. If this property is
unspecified (--), then only those blocks in the current
drawing file are listed.
Symbol blocks shipped with AutoCAD Architecture are
by default located in %AECCONTENT_DIR%\Styles\Im-
perial\AEC Annotation Symbols (Imperial).dwg or
%AECCONTENT_DIR%\Styles\Metric\AEC Annotation
Symbols (Metric).dwg.

This property specifies whether attribute text within the
symbol uses the text style of the current drawing (Target

Text/Attribute text style

drawing text style) or the style defined by the attribute
tag (As defined by content).
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DescriptionProperty Cat-
egory/Name

Specifies the angle for attribute text. The choices are Right
reading (which keeps the text right-side up regardless of

Text/Attribute text angle

rotation angle), As inserted (which sets text rotation at
the angle of the last leader segment), and Force horizontal
(which keeps the text horizontal regardless of the match
line rotation angle.)

NOTE The north arrow and datum point tools shipped
with AutoCAD Architecture do not have attributes in their
block definitions, so that these settings are set to Un-
defined (--).

Inserting a North Arrow or Datum Point in the Drawing
Use this procedure to insert a north arrow or datum point into the drawing.

1 Select a north arrow or datum point tool on a tool palette.

(A north arrow tool and a datum point tool are located on the
Annotation palette.)

2 Specify the insertion point of the north arrow or datum point in
the drawing area.

3 Specify the rotation.

For information about editing the properties of north arrows and datum points
in the drawing, see Editing Block-Based Annotation Symbols on page 3669.

NOTE North arrows and datum points that have been inserted with a north arrow
or datum point tool can be modified in the drawing and saved back as a tool on
a tool palette. By default, a north arrow or datum point tool created that way will
have the same layer key, layer overrides, and symbol as the original tool that was
used to create the annotation symbol in the drawing. The symbol location will be
the current drawing.

Fire Rating Line Tools
Fire rating annotations are used for adding fire rating information a drawing.
Formerly available as content blocks in DesignCenter, these annotations are
now available through tools on the tool palettes and in Content Browser.

Inserting a North Arrow or Datum Point in the Drawing | 3655



In this release of AutoCAD Architecture, fire rating lines are converted from
DesignCenter content blocks to true tools with tool properties.

Fire rating lines are polylines and are not controlled by annotative scaling.

Fire rating line tools

You can find fire rating line tools in these locations in a default US install of
AutoCAD Architecture:

■ In the Annotation tool palette

■ In Content Browser in these catalogs:

■ Stock Tool Catalog

■ Sample Palette Catalog (Imperial or Metric), under
\Document\Annotation

■ Documentation Tool Catalog (Imperial or Metric), under
\Miscellaneous\Fire Rating

TIP You can also search for these types of tools by name in Content Browser.

These properties of Fire Rating Line tools can be customized:

DescriptionProperty Cat-
egory/Name

Specifies the layer key for the layer to which the fire rating
line is assigned. To change, click the current value to ac-

General/Layer key

cess the Select Layer Key worksheet. The default layer key
is WALLFIRE.

Specifies one or more layer key overrides. Click the work-
sheet icon to access the Select Layer Overrides worksheet.

General/Layer overrides

Specifies the line width of the fire rating polyline.General/Line width
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DescriptionProperty Cat-
egory/Name

Specifies the linetype of the fire rating line. In the fire rat-
ing line tools shipped with AutoCAD Architecture there

General/Linetype

is a specific linetype for each fire rating level - for example,
the 1 Hr fire rating line tool has the Aec_Rating_1Hr line-
type specified. The linetypes for rating line tools have been
added to the acad.lin and acadISO.lin files.

Inserting a Fire Rating Line in the Drawing
Use this procedure to insert a fire rating line into the drawing.

1 Select a fire rating line tool on a tool palette.

(A fire rating line tool is located on the Annotation palette.)

2 Specify the start point of the wall you want to annotate with a
fire rating line.

3 Specify the wall endpoint in the direction you want the line to
be drawn.

4 Continue specifying wall points to extend the line as needed.

5 Press ENTER to end the command.

Adding a fire rating line to a wall segment

For information about editing the properties of fire rating lines in the drawing,
see Editing Polyline-Based Annotation Symbols on page 3672.
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NOTE Fire rating lines that have been inserted with fire rating tools can be modified
in the drawing and saved back as tools on a tool palette. By default, a fire rating
line tool created that way will have the same layer key, layer overrides, linetype,
and line width as the original tool that was used to create the annotation symbol
in the drawing.

Match Line Tools
Match line annotations are used for annotating a drawing. Formerly available
as content blocks in DesignCenter, these annotations are now available through
tools on the tool palettes and in Content Browser.

In this release of AutoCAD Architecture, match lines are converted from
DesignCenter content blocks to true tools with tool properties.

Match line tools

By default, all match line tools are set to be annotative, which means that the
annotations you insert with these tools are controlled by annotative scaling.
For more information, see Annotation Scaling on page 3675.

IMPORTANT If you have legacy drawings with old DesignCenter-based annotation
symbols in them, then the old block definition will continue to be used for new
tool-based blocks if the blocks are identically named. In such a case, either change
the Annotative setting manually by using BEDIT, or rename the old block before
inserting new tool-based annotation symbols into the drawing.

You can find match line tools in these locations in a default US install of
AutoCAD Architecture:

■ In the Annotation tool palette

■ In Content Browser in these catalogs:

■ Stock Tool Catalog

■ Sample Palette Catalog (Imperial or Metric), under
\Document\Annotation
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■ Documentation Tool Catalog (Imperial or Metric), under
\Miscellaneous\Match Lines

TIP You can also search for these types of tools by name in Content Browser.

These properties of match line tools can be customized:

DescriptionProperty Cat-
egory/Name

Specifies the layer key for the layer to which the match
line is assigned. To change, click the current value to ac-

General/Layer key

cess the Select Layer Key worksheet. The default layer key
is ANNOBJ.

Specifies one or more layer key overrides. Click the work-
sheet icon to access the Select Layer Overrides worksheet.

General/Layer overrides

Specifies the block-based symbol to be used for the match
line.

General/Symbol

The location of the drawing file containing the specified
match line symbol. Click the property and use the Browse

General/Symbol location

option from the drop-down list to locate and enter the
path to the file. If this property is unspecified (--), then
only those blocks in the current drawing file are listed.
Symbol blocks shipped with AutoCAD Architecture are
by default located in %AECCONTENT_DIR%\Styles\Im-
perial\AEC Annotation Symbols (Imperial).dwg or
%AECCONTENT_DIR%\Styles\Metric\AEC Annotation
Symbols (Metric).dwg.

Specifies the line width of the match line.

NOTE This setting uses paper size, not model size.

General/Line width

Specifies the linetype of the match line. For the match
line tools shipped with AutoCAD Architecture, linetype

General/Linetype

Aec_Match_Line is specified. This linetype has been added
to the acad.lin and acadISO.lin files.

This property specifies whether attribute text within the
symbol uses the text style of the current drawing (Target

Text/Attribute text style
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DescriptionProperty Cat-
egory/Name

drawing text style) or the style defined by the attribute
tag (As defined by content).

Specifies the angle for attribute text. The choices are Right
reading (which keeps the text right-side up regardless of

Text/Attribute text angle

rotation angle), As inserted (which sets text rotation at
the angle of the last leader segment), and Force horizontal
(which keeps the text horizontal regardless of the match
line rotation angle.)

Inserting a Match Line in the Drawing
Use this procedure to insert a match line into the drawing.

1 Select a match line tool on a tool palette.

(A match line tool is located on the Annotation palette.)

2 Specify the first point of the match line in the drawing area.

3 Specify the next points of the match line, and press ENTER when
the line is complete.

4 In the Edit Attributes dialog, enter the text you want displayed
on the match line, and click OK.

For information about editing the properties of match lines in the drawing,
see Editing Block-Based Annotation Symbols on page 3669 and Editing
Polyline-Based Annotation Symbols on page 3672.

NOTE Match lines that have been inserted with match line tools can be modified
in the drawing and saved back as tools on a tool palette. By default, a match line
tool created that way will have the same layer key, layer overrides, symbol, line
width, linetype, attribute text style, and attribute text angle as the original tool
that was used to create the annotation symbol in the drawing. The symbol location
will be the current drawing.

Revision Cloud Tools
Revision cloud annotations are used for marking up to-be-revised areas in a
drawing. Formerly available as content blocks in DesignCenter, these
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annotations are now available through tools on the tool palettes and in
Content Browser.

In this release of AutoCAD Architecture, revision clouds are converted from
DesignCenter content blocks to true tools with tool properties.

Revision cloud tools

If a revision cloud has a tag, the tag symbol is a block reference which can be
controlled by annotative scaling. The polyline representing the cloud shape
does not participate in annotation scaling. For more information, see
Annotation Scaling on page 3675.

IMPORTANT If you have legacy drawings with old DesignCenter-based annotation
symbols in them, then the old block definition will continue to be used for new
tool-based blocks if the blocks are identically named. In such a case, either change
the Annotative setting manually by using BEDIT, or rename the old block before
inserting new tool-based annotation symbols into the drawing.

You can find revision cloud tools in these locations in a default US install of
AutoCAD Architecture:

■ In the Annotation tool palette

■ In Content Browser in these catalogs:

■ Stock Tool Catalog
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■ Sample Palette Catalog (Imperial or Metric), under
\Document\Annotation

■ Documentation Tool Catalog (Imperial or Metric), under \Revision
Clouds

TIP You can also search for these types of tools by name in Content Browser.

These properties of Revision Cloud tools can be customized:

DescriptionProperty Cat-
egory/Name

Specifies the layer key for the layer to which the revision
cloud is assigned. To change, click the current value to

General/Layer key

access the Select Layer Key worksheet. The default layer
key is ANNREV.

Specifies one or more layer key overrides. Click the work-
sheet icon to access the Select Layer Overrides worksheet.

General/Layer overrides

If the revision cloud tool contains a tag, this line specifies
the block-based symbol to be used for the tag. If the revi-

General/Symbol

sion cloud tool does not contain a tag, the symbol is un-
defined.

The location of the drawing file containing the specified
tag symbol. Click the property and use the Browse option

General/Symbol location

from the drop-down list to locate and enter the path to
the file. If this property is unspecified (--), then only those
blocks in the current drawing file are listed.
Symbol blocks shipped with AutoCAD Architecture are
by default located in %AECCONTENT_DIR%\Styles\Im-
perial\AEC Annotation Symbols (Imperial).dwg or
%AECCONTENT_DIR%\Styles\Metric\AEC Annotation
Symbols (Metric).dwg.

Specifies the line width of the cloud polyline.

NOTE This setting uses paper size, not model size.

General/Line width
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DescriptionProperty Cat-
egory/Name

Specifies the arc length of each cloud segment.

NOTE This value is in paper space units.

General/Arc length

This property specifies whether attribute text within the
symbol uses the text style of the current drawing (Target

Text/Attribute text style

drawing text style) or the style defined by the attribute
tag (As defined by content).

Specifies the angle for attribute text. The choices are Right
reading (which keeps the text right-side up regardless of

Text/Attribute text angle

rotation angle), As inserted (which sets text rotation at
the angle of the last leader segment), and Force horizontal
(which keeps the text horizontal regardless of the match
line rotation angle.)

Inserting a Revision Cloud in the Drawing
Use this procedure to insert a revision cloud into the drawing.

1 Select a revision cloud tool on a tool palette.

(A revision cloud tool with a tag symbol is located on the
Annotation palette.)

2 Specify the first point of the cloud shape in the drawing area.

NOTE Revision clouds are drawn counter-clockwise.

3 Specify the cloud shape, and click once when the cloud is closed.

If the revision cloud tool contains a tag, the Edit Attributes dialog
opens.

4 Enter the text you want displayed in the tag, and click OK.

For information about editing the properties of revision clouds in the drawing,
see Editing Block-Based Annotation Symbols on page 3669 and Editing
Polyline-Based Annotation Symbols on page 3672.
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NOTE Revision clouds that have been inserted with revision cloud tools can be
modified in the drawing and saved back as tools on a tool palette. By default, a
revision cloud tool created that way will have the same layer key, layer overrides,
symbol, line width, arc length, attribute text style, and attribute text angle as the
original tool that was used to create the annotation symbol in the drawing. The
symbol location will be the current drawing.

Bar Scale Tools
Bar scale annotations are used for annotating a drawing. These annotations
are now available through tools on the tool palettes and in Content Browser.

Bar scale tool

By default, all bar scale tools are set to be non-annotative, which means that
the annotations you insert with these tools are not controlled by annotative
scaling. You can make them annotative if desired. For more information, see
Annotation Scaling on page 3675.

IMPORTANT If you have legacy drawings with old DesignCenter-based annotation
symbols in them, then the old block definition will continue to be used for new
tool-based blocks if the blocks are identically named. In such a case, either change
the Annotative setting manually by using BEDIT, or rename the old block before
inserting new tool-based annotation symbols into the drawing.

IMPORTANT The bar scale tool has been set to be non-annotative by default
because the numerical values created on insertion are static and will not update
automatically when the annotation scale of the symbol is changed.

You can find a bar scale tool in these locations in a default US install of
AutoCAD Architecture:

■ In the Annotation tool palette

■ In Content Browser in these catalogs:

■ Stock Tool Catalog

■ Sample Palette Catalog (Imperial or Metric), under
\Document\Annotation

■ Documentation Tool Catalog (Imperial or Metric), under \Miscellaneous
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TIP You can also search for these types of tools by name in Content Browser.

These properties of bar scale tools can be customized:

DescriptionProperty Cat-
egory/Name

Specifies the layer key for the layer to which the bar scale
is assigned. To change, click the current value to access

General/Layer key

the Select Layer Key worksheet. The default layer key is
TITTEXT.

Specifies one or more layer key overrides. Click the work-
sheet icon to access the Select Layer Overrides worksheet.

General/Layer overrides

Specifies the block-based symbol to be used for the bar
scale.

General/Symbol

The location of the drawing file containing the specified
symbol. Click the property and use the Browse option

General/Symbol location

from the drop-down list to locate and enter the path to
the file. If this property is unspecified (--), then only those
blocks in the current drawing file are listed.
Symbol blocks shipped with AutoCAD Architecture are
by default located in %AECCONTENT_DIR%\Styles\Im-
perial\AEC Annotation Symbols (Imperial).dwg or
%AECCONTENT_DIR%\Styles\Metric\AEC Annotation
Symbols (Metric).dwg.

This property specifies whether attribute text within the
symbol uses the text style of the current drawing (Target

Text/Attribute text style

drawing text style) or the style defined by the attribute
tag (As defined by content).

Specifies the angle for attribute text. The choices are Right
reading (which keeps the text right-side up regardless of

Text/Attribute text angle

rotation angle), As inserted (which sets text rotation at
the angle of the last leader segment), and Force horizontal
(which keeps the text horizontal regardless of the match
line rotation angle.)
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Inserting a Bar Scale in the Drawing
Use this procedure to insert a bar scale into the drawing.

1 Select a bar scale tool on a tool palette.

(A bar scale tool is located on the Annotation palette.)

2 Specify the insertion point of the bar scale.

3 Specify the rotation of the bar scale.

For information about editing the properties of bar scales in the drawing, see
Editing Block-Based Annotation Symbols on page 3669.

NOTE Bar scales that have been inserted with a bar scale tool can be modified in
the drawing and saved back as a tool on a tool palette. By default, a bar scale tool
created that way will have the same layer key, layer overrides, symbol, attribute
text style, and attribute text angle as the original tool that was used to create the
annotation symbol in the drawing. The symbol location will be the current drawing.

Column Grid Bubble Tools
Column grid bubble annotations are used for annotating column grids in a
drawing. These annotations are available through tools on the tool palettes
and in Content Browser. The column grid bubble is a true tool with tool
properties.

Column grid bubble tool

The default column grid bubble tool is set to be annotative, which means that
the annotations you insert with the tool are controlled by annotative scaling.
For more information, see Annotation Scaling on page 3675.

IMPORTANT If you have legacy drawings with old DesignCenter-based annotation
symbols in them, then the old block definition will continue to be used for new
tool-based blocks if the blocks are identically named. In such a case, either change
the Annotative setting manually by using BEDIT, or rename the old block before
inserting new tool-based annotation symbols into the drawing.

The column grid bubble tool is based on a multi-view block. To make changes
to the annotative behavior, you must change the referenced block within the
multi-view block with BEDIT.
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You can find a column grid bubble tool in these locations in a default US
install of AutoCAD Architecture:

■ In the Annotation tool palette

■ In Content Browser in these catalogs:

■ Stock Tool Catalog

■ Sample Palette Catalog (Imperial or Metric), under
\Document\Annotation

■ Documentation Tool Catalog (Imperial or Metric), under \Miscellaneous

TIP You can also search for these types of tools by name in Content Browser.

These properties of Column Grid Bubble tools can be customized:

DescriptionProperty Cat-
egory/Name

Specifies the layer key for the layer to which the column
grid bubble is assigned. To change, click the current value

General/Layer key

to access the Select Layer Key worksheet. The default
layer is GRIDBUB.

Specifies one or more layer key overrides. Click the work-
sheet icon to access the Select Layer Overrides worksheet.

General/Layer overrides

Specifies the block-based symbol to be used for the
column grid bubble.

General/Symbol

The location of the drawing file containing the specified
symbol. Click the property and use the Browse option

General/Symbol location

from the drop-down list to locate and enter the path to
the file. If this property is unspecified (--), then only those
blocks in the current drawing file are listed.
Symbol blocks shipped with AutoCAD Architecture are
by default located in %AECCONTENT_DIR%\Styles\Im-
perial\AEC Annotation Symbols (Imperial).dwg or
%AECCONTENT_DIR%\Styles\Metric\AEC Annotation
Symbols (Metric).dwg.

Specifies the default bubble text. The last character of the
prefix will be incremented if multiple column grid bubbles

Label prefix

Column Grid Bubble Tools | 3667



DescriptionProperty Cat-
egory/Name

are inserted within one command sequence. For example,
if the label prefix is A1, then subsequent bubbles will be
named A2, A3, and so on.

NOTE When the command is ended, and later the tool
is started again, it will start incrementing from 1 again.

Specifies whether a bubble is applied to only the selected
node (No) or to the node on the opposite end of the grid
as well (Yes).

Label both ends

Specifies the length of the extension line from the column
grid node to the bubble.

NOTE These values are defined in model space units.

Extension length

This property specifies whether attribute text within the
symbol uses the text style of the current drawing (Target

Text/Attribute text style

drawing text style) or the style defined by the attribute
tag (As defined by content).

Specifies the angle for attribute text. The choices are Right
reading (which keeps the text right-side up regardless of

Text/Attribute text angle

rotation angle), As inserted (which sets text rotation at
the angle of the last leader segment), and Force horizontal
(which keeps the text horizontal regardless of the match
line rotation angle.)

Inserting a Column Grid Bubble in the Drawing
Use this procedure to add a column grid bubble to a column grid in the
drawing.

1 Select a column grid bubble tool on a tool palette.

(A column grid bubble tool is located on the Annotation palette.)

2 Select the desired node on the column grid you want to label.

3 In the Create Grid Bubble dialog, you can either choose to confirm
the tool settings for label prefix, extension line length, and one-
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or two-sided labelling, or you can overwrite them. Click OK when
the settings are according to your wishes.

4 To label more nodes on the column grid, select them and repeat
the previous step.

5 To end the bubble creation, press ENTER.

The column grid bubble tool shipped with AutoCAD Architecture is a
multi-view block referencing a bubble definition in a block. To edit the block,
you must run the BEDIT command.

NOTE Column grid bubbles that have been inserted with a column grid bubble
tool can be modified in the drawing and saved back as a tool on a tool palette.
By default, a column grid bubble tool created that way will have the same layer
key, layer overrides, symbol, label prefix, extension line length, attribute text style,
and attribute text angle as the original tool that was used to create the annotation
symbol in the drawing. The symbol location will be the current drawing.

Editing Annotation Symbols in the Drawing
Depending on whether you are using a block-based or polyline-based
annotation tool, different properties of the inserted annotation symbols can
be edited.

Editing Block-Based Annotation Symbols
The annotation symbols for north arrows, datum points, match lines, bar
scales, and revision clouds (with tag) contain block references. To edit the
properties of the block, select the desired tool in the drawing, and change the
following properties on the Properties palette:

TIP Match lines and revision clouds with tags are composed of a block reference
and a polyline. To confirm that you have selected the block reference part of the
symbol, verify that the drop-down list in the Properties palette reads “Block
Reference.”

DescriptionCategory/Property

The default color of an annotation symbol
is defined by the layer the symbol is inser-

General/Color

ted on. You can manually select a different
color.
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DescriptionCategory/Property

The layer of an annotation symbol is
defined by the layer key of the tool. You
can manually select a different layer.

General/Layer

The default linetype of an annotation sym-
bol is defined by the layer the tool is inser-

General/Linetype

ted on. You can manually select a different
linetype.

The linetype scale of a block-based annota-
tion symbol is set in the block referenced

General/Linetype scale

by the tool. To change the linetype scale
of the block, you must run BEDIT.

NOTE Changing the linetype scale of the
block will affect all tools and symbols refer-
encing that block.

The plot style is controlled by the plot style
table defined for the drawing. To change

General/Plot style

the plot style, you must select a different
plot style table.

The default lineweight of an annotation
symbol is defined by the layer the symbol

General/Lineweight

is inserted on. You can manually select a
different lineweight.

You can attach a hyperlink to an annotation
symbol in the drawing.

General/Hyperlink

The default material used when displaying
the drawing in a 3D visualization style is

3D Visualization/Material

defined by the layer the symbol is on. In
most cases material settings do not affect
annotation symbols, as they typically do
not appear in rendered views of the draw-
ing.

The position of the symbol is initially
defined by the location at which it is inser-

Geometry/Position X/Y/Z
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DescriptionCategory/Property

ted in the drawing. You can change the
position either by dragging the symbol to
a different location or by entering different
position coordinates in the Properties
palette.

The scale of the symbol when inserted is
defined by the Annotation plot size defined

Geometry/Scale X/Y/Z

for the drawing. You can manually change
the scale. The values for X, Y, and Z are al-
ways proportional; changing the X scale
changes the Y and Z scales, too. For inform-
ation about annotation plot size, see Creat-
ing Annotation Scales and Assigning them
to Display Configurations on page 187.

The name of the block that is referenced
by the symbol.

Misc/Name

The rotation is specified by the user when
inserting the symbol. You can change the

Misc/Rotation

rotation by entering a different angle on
the Properties palette.

Indicates whether the symbol is participat-
ing in annotation scaling. To change the

Misc/Annotative

annotative behavior, you must change the
annotative behavior of the referenced block
by running BEDIT.

The currently active annotation scale (vis-
ible only for symbols that are controlled by
annotation scaling.)

Misc/Annotative scale

Indicates whether the symbol is aligned to
the spatial orientation of the drawing lay-

Misc/Match orientation to layout

out. The default setting is No. To change
the orientation behavior, you must change
the orientation of the referenced block by
running BEDIT.
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DescriptionCategory/Property

Specifies the insertion units. To change this
setting, you must change the insertion

Misc/Block Unit

units of the referenced block by running
BEDIT.

Specifies the conversion factor between
block units and drawing units. To change

Misc/Unit factor

this value, you must change the unit factor
of the referenced block by running BEDIT.

If the block reference of the annotation
symbol contains one or more editable at-

Attributes/<Attribute Name>

tributes, you can directly edit them in the
Properties palette. By default, match lines
and bar scales contain editable attributes.

Editing Polyline-Based Annotation Symbols
The annotation symbols for fire rating lines, match lines, and revision clouds
contain polylines. To edit the properties of the polyline, select the desired
tool in the drawing, and change the following properties on the Properties
palette:

TIP Match lines and revision clouds with tags are composed of a block reference
and a polyline. To confirm that you have selected the polyline, verify that the
drop-down list in the Properties palette reads “Polyline.”

DescriptionCategory/Property

By default, the color of a polyline in an an-
notation symbol is defined by the layer the

General/Color

symbol is inserted on. You can manually
select a different color.

The layer of an annotation symbol is
defined by the layer key of the tool. You
can manually select a different layer.

General/Layer

By default, the linetype of a polyline in an
annotation symbol is defined by the line-

General/Linetype
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DescriptionCategory/Property

type setting in the tool. You can manually
select a different linetype.

By default, the linetype scale of a polyline
in an annotation symbol is defined by the

General/Linetype scale

layer the symbol is inserted on. You can
manually select a different linetype scale.

The plotstyle is defined by the plot style
table defined for the drawing. To change

General/Plot style

the plot style, you must select a different
plot style table.

By default, the lineweight of an annotation
symbol is defined by the layer the symbol

General/Lineweight

is inserted on. You can manually select a
different lineweight.

You can attach a hyperlink to a polyline in
the drawing.

General/Hyperlink

The thickness setting lets you add a 3D
thickness to a 2D polyline. By default this

General/Thickness

is set to 0 as annotation symbols and their
linework components normally do not re-
quire a 3D extrusion.

By default, the material used when display-
ing the drawing in a 3D visualization style

3D Visualization/Material

is defined by the layer the symbol is on.
Normally this setting does not need to be
changed, as annotation symbols are rarely
used in rendered views of a drawing.

The Vertex option displays the number of
the vertex that is currently editable. Use
the arrows to scroll between vertices.

Geometry/Vertex

Here, you can edit the vertex coordinates
of the vertex selected in the line above.

Geometry/Vertex X/Y
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DescriptionCategory/Property

This setting defines the width of the poly-
line segment at the start of the selected
vertex.

Geometry/Start segment width

This setting defines the width of the poly-
line segment at the end of the selected
vertex.

Geometry/End segment width

Here, you can enter a global width for the
overall polyline. By default the line width
setting defined in the tool is used.

Geometry/Global width

This setting specifies the elevation of the
polyline relative to the z-axis of the poly-

Geometry/Elevation

line’s object coordinate system. Annotation
symbols are by default inserted at elevation
0.

This value is set only if the polyline has
been set to have a width.

Geometry/Area

This value displays the overall length of the
polyline.

Geometry/Length

This setting displays whether the polyline
in the annotation symbol is closed or open.

Misc/Closed

Typically, fire rating lines and match lines
are open polylines; a revision cloud is a
closed polyline.

This setting allows you to use a smaller
linetype scale than the regular selected

Misc/Linetype generation

linetype scale on very short polyline seg-
ments. This can be useful when the line-
type has a pattern (for example dashed)
and certain segments are too short to dis-
play the pattern. In this case, enabling
linetype generation generates the pattern
on those segments with a scale small
enough to display.
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Annotation Scaling
Annotation scaling allows you to plot annotation at the same height or size
regardless of the viewport zoom scale. Annotation scales can be associated
with annotative objects in AutoCAD Architecture so that these objects can be
sized properly for specific annotation scales in model space and displayed
correctly in paper space. You can also toggle on or off the display of annotation
objects that do not participate in the current annotation scale.

The following illustration shows a door tag displayed at two different
annotation scales. The door tag was created in the drawing at the first
annotation scale, then the annotation scale was changed.

The following illustration shows an AEC dimension displayed at two different
annotation scales. The AEC dimension was created in the drawing at the first
annotation scale, then the annotation scale was changed.

Annotation Tools with Annotative Properties
Use annotation tools to create annotation objects that respond to specific
annotation scales. An annotation tool is a customizable AutoCAD Architecture
tool for adding the following types of annotations to drawings:

■ Multi-line text notes
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■ Symbol-based notes with attributes

■ Reference keynotes

■ Sheet notes

■ Callouts

The annotation tools appear on the Annotation tab of the Document tool
palette:

For more information about working with annotation tools, see The Basic
Annotation Tool on page 3587.

NOTE DesignCenter tools do not generate objects that respond to annotation
scaling.

An annotation object is any object that participates in annotation scaling.
The following are annotation objects created by AutoCAD Architecture:

■ Multi-view blocks

■ AEC dimensions

Multi-view blocks derive their annotative properties from their block definition.
AEC dimensions derive their annotative properties from their dimension style.
For more information, refer to AutoCAD help.

The following are annotation objects created by AutoCAD:

■ Text
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■ MText

■ Dimensions

■ Leaders

■ Block References

■ Hatches

The following AutoCAD styles are also annotative:

■ Text

■ Dimensions

■ Block Definitions

■ MLeaders

The specific type of annotation, its appearance, and other characteristics are
determined by user-editable values on the Tool Properties worksheet, which
is accessed from the context menu of the particular tool.
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Specifying Annotation Scale
When you use AutoCAD Architecture tools to generate AutoCAD objects such
as leaders and callouts, these objects become annotative objects that respond
to annotation scaling. When you generate Multi-view blocks and AEC
dimensions, these objects are also annotative and respond to annotation
scaling with respect to scale and location based on the current annotation
scale.

The annotation scale is a setting associated with the model tab and paper
space viewports and is also saved with model views. It is controlled by the
CANNOSCALE system variable value which sets the current annotation scale.
Different annotation scales can be assigned to model views and paper space
viewports.

Specify the current annotation scale by selecting one from the Annotation
Scale flyout menu.

Annotation Scales and Viewports
When working in a paper space viewport, the annotation scale of the viewport
controls the scale of the annotative objects created in the viewport. If multiple
scale representations are supported, the annotative objects in the viewport
are drawn and scaled based on the annotation scale without affecting the scale
or display in the model tab or in other paper space viewports.

The viewport and annotation scales are synchronized when the annotation
scaling controls are used. For example, when you change the viewport scale,
the annotation scale updates to match the new viewport scale. However, as
you zoom in or out of a viewport with your mouse wheel or by using the
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Zoom commands, the viewport scale updates while the annotation scale will
remain unchanged.

Scale representations allow for the display of the same annotative object
differently in different paper space viewports at the same time. Scale
representations allow annotative objects to be drawn at different sizes based
on the annotation scale. Each scale representation may also have different
values for positional properties, such as a text string base point. The properties
that can vary per scale representation depend on the object type.

The following illustration shows a door tag shown at two different annotation
scales and different locations based on the annotation scale and base point.

Whenever an annotation object is identified as annotative as you add it to a
drawing, the current annotation scale is added to the object as a participatory
scale. AutoCAD Architecture objects identified as annotative will scale to
match the current annotation scale. The scale point is the insertion point of
the block definition.

NOTE Any annotation settings within all nested text or dimension styles referred
to by an AutoCAD Architecture object, such as materials or component hatching,
schedule tables, or stairs, will be ignored. Display properties for these objects do
not respect annotation scaling.

Annotative objects such as door tags now have a Scale Representation Location
Grip. Use this grip to relocate the current scale representation instance. Use
the Location grip to relocate all of the scale representations at once. If there
is only one scale representation supported for a particular tag, only the
Location grip is displayed.
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The model space or paper space text height is the height at which text will be
plotted for a given scale. The following formula determines object scaling:

Object Height x Annotation Scale x Annotation Plot Size = Model Space
or Paper Space Height

For example, the model space text height for a text string when displayed in
a viewport scaled to 1/4" = 1' - 0" is 12". Assuming an object height of 1 unit,
the formula applies as follows:

1 x 48 x 1/4” = 12”

Blocks used by AutoCAD Architecture callouts, title marks, and other kinds
of annotation must be created relative to a single AutoCAD unit (either an
inch or a millimeter, depending upon whether your working in imperial or
metric units). Documentation content files, regardless of whether they are
based on blocks or multi-view blocks have the additional requirement that
they be inserted at a scale relative to your anticipated plot scale, and taking
into account the “Annotation Plot Size” setting in the drawing setup dialog
box. As a baseline, you can use one AutoCAD unit, and anything in the content
file that is one unit in size will be the annotation plot size when plotted at
the specified annotation scale. Everything in the block, including geometry
and text, must be created relative to the single AutoCAD unit. The entire block
is scaled proportionally.

Updating Legacy Annotative Objects
When you are working with previous versions of Architectural Desktop, you
can update appropriate objects in AutoCAD Architecture so that they are
annotative. This sections outlines the procedure for updating three types of
objects: AutoCAD objects (text, dimensions, and hatching, for example),
AutoCAD Architecture blocks, and AutoCAD Architecture multi-view blocks
and AEC dimensions.

If you choose only one occurrence of an object to make annotative, only that
instance of the object will be annotative. To apply an annotative property to
all of the objects in a particular style, edit that style and assign an annotative
property to all instances of that style. You can also enter ANNOUPDATE on
the Command line to update the selected text objects. Leaders, MText,
dimensions, and other objects are assigned an annotative property by this
same procedure.
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Updating Legacy AutoCAD Text to Annotative

Use this procedure to edit a legacy AutoCAD text style and add an annotative
property. You can also use this procedure to update AutoCAD dimensions.

1 Open the legacy Architectural Desktop drawing in AutoCAD
Architecture.

2 Specify the same annotation scale in the new AutoCAD
Architecture drawing as in the legacy Architectural Desktop
drawing.

3 From the Format menu, click Text Style.

4 In the Text Style dialog, from the Styles list, select the appropriate
text style.

5 Under Size, select Annotative.

6 Click Apply.

7 On the Command Line, enter ANNOUPDATE to update all
annotative objects.

Any text strings of the selected text style are now annotative.

Updating Legacy Architectural Desktop Blocks to Annotative

Use this procedure to edit legacy Architectural Desktop blocks, such as callouts
or titlemarks, and add an annotative property.

1 Open the legacy Architectural Desktop drawing in AutoCAD
Architecture.

2 Specify the same annotation scale in the new AutoCAD
Architecture drawing as in the legacy Architectural Desktop
drawing.

3 Click Insert tab ➤ Block panel ➤ Edit Block.

4 In the Edit Block Definition dialog, select the block to edit, and
then click OK.

5 On the Properties Palette, under Block, select Yes for Annotative.
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6 On the Block Editor toolbar, click Close Block Editor and then
save your changes.

Any blocks of the selected block style are now annotative.

Updating Legacy Architectural Desktop Multi-view Blocks to Annotative

Use this procedure to edit a legacy Architectural Desktop multi-view block
and add an annotative property to each block for each view. You can also use
this procedure to update legacy AEC dimensions.

1 Open the legacy Architectural Desktop drawing in AutoCAD
Architecture.

2 Specify the same annotation scale in the new AutoCAD
Architecture drawing as in the legacy Architectural Desktop
drawing.

3 Click Insert tab ➤ Block panel ➤ Edit Block.

4 In the Edit Block Definition dialog, select the first block to edit,
and then click OK.

5 On the Properties Palette, under Block, select Yes for Annotative.

6 On the Block Editor toolbar, click Close Block Editor and then
save your changes.

7 Repeat these steps for the remaining blocks of the remaining views
of the multi-view block.

8 On the Command Line, enter ANNOUPDATE to update the
selected blocks.

The selected blocks now have an annotative property.

Copying Participating Annotation Scales from One AEC Object to Another

You can copy annotation scales from annotative multi-view blocks and AEC
dimensions as source AEC objects to other AEC objects. A prerequisite is that
your drawing must contain an annotative AEC object that participates in at
least 2 annotation scales. For example, you can copy annotation scales from
one door tag to another.

1 Add 2 doors to your drawing.

2 Add a door tag to the first door.
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This is the source object.

3 Select the door tag, and click Annotate tab ➤ Annotation Scaling
panel ➤ Add/Delete Scales.

You can also specify a new current annotation scale by selecting
one from the Annotation Scale flyout menu.

4 In the Annotation Object Scale dialog, click Add.

5 Select additional scales to add to the source object and click OK.

6 Verify the new scales added to the source object in the Annotation
Object Scale dialog, and click OK.

7 Select the door tag, right-click and click Add Selected.

8 Select the second door.

9 Add the new door tag to your drawing.

10 Select the new door tag, and click Annotate tab ➤ Annotation
Scaling panel ➤ Add/Delete Scales.

11 In the Annotation Object Scale dialog, verify that the new door
tag has the same assigned scales as the source door tag.
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Linking Display Configurations to Annotation Scales

You can specify which display configuration is associated with a particular
annotation scale in your drawing. For example, you can link a Low Detail
Reflected Ceiling Plan display configuration with a 1/8” = 1’-0” annotation
scale and a Medium Detail Reflected Ceiling Plan display configuration with
a 1/4” = 1’-0” annotation scale.

This relationship exists for the following display configuration conditions:

Model Tab: Annotation scale and display configuration changes

Current Paper Space Viewport: Annotation scale changes, zoom scale changes,
and display configuration changes

Selected Paper Space Viewports: Annotation scale changes for all unlocked
viewports, zoom scale changes for all unlocked viewports, and display
configuration changes for all unlocked viewports

Derivation of Annotative Properties
The following table lists objects, their associated AutoCAD Architecture tool
that creates them, and the source of their annotative properties, if any.

Annotative Property DerivationAutoCAD Architec-
ture Tool

Object

Leader Dimension Style tool proper-
ties

AnnotationMText*

Block Style definitionAnnotation/Callout/De-
tail Mark/Title Mark

Blocks*

Leader Dimension Style tool proper-
ties

Annotation/Callout/De-
tail Mark/Title Mark

Leaders*

Block Style definitionMulti-view Block
Tool/Schedule Tag Tool

Multi-view Blocks

None; Annotative property can be
assigned to view blocks

DesignCenter Content
Tool/DesignCenter
Command Tool/

Multi-view Blocks

AutoCAD Dimension Style specified
in the AEC Dimension display proper-
ties

Dimension ToolAEC Dimensions
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* AutoCAD object created by AutoCAD Architecture tool

Derivation of Annotative Properties | 3685



3686



Callouts

Details, sections, and elevations are views of the building model and part of the construction
documentation. They can be created with callouts. Callout tools create a callout that is
referenced to a model space view containing a user-defined part of the building model, such
as a section, an elevation or a detail. They are coordinated across the complete construction
document set with the help of projects and sheet sets.

Working with Callouts
Callout tools allow you to define portions of the building model as details,
sections, and elevations. These portions are placed in model space views created
for the callout.

A model space view is a portion of a view drawing that may be displayed in its
own viewport on a layout tab of a drawing. A model space view has its own
name, description, display configuration, layer snapshot, drawing scale, layer
state, and view direction. Model space views are an evolution of the Named
Views concept of AutoCAD, but as opposed to Named Views, model spaces
views have a defined boundary.

You can place a model space view containing a detail, section, or elevation in
the current view drawing, an existing project view drawing, or a new project
view drawing.

The New View Drawing Types

View drawings have been enhanced for AutoCAD Architecture. In addition to
the existing general view drawings, users may now access some specialized
drawing types designed for saving details, sections, and elevations in a project.
All of these view types are organized in the Project Navigator.
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These are the types of view drawings in the Drawing Management feature:

■ General view drawings: A general view drawing contains referenced constructs
from the project, representing a specific view on the building model.
General view drawings are based on the general view template defined in
the project settings.

3D view of entire building

■ Detail view drawings: A detail view drawing can contain one or more model
space views that show a defined portion of the building model. This could
be a detail or an enlarged part of a plan. You can specify the level of detail
with the help of the display configuration and the 2D Section/elevation
style. A model space view containing a detail can be created with a callout.
Detail view drawings are based on the detail view template defined in the
project settings.

Detail view in callout
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■ Section/Elevation view drawings: A section/elevation view drawing can contain
one or more model space views that show a section/elevation of the
building model. A model space view containing a section or elevation can
be created with a callout. Specific callout tools have been added to make
the creation of four-way exterior and interior elevations easier and better.
Section/elevation view drawings are based on the section/elevation view
template defined in the project settings.

4 model space exterior elevations

For more information on the view system in AutoCAD Architecture, see Views
on page 446.

Using Fields in Callout Tools

Fields enhance the documentation capabilities within a drawing file. A field
is updatable text that is set up to display data that may change during the life
cycle of the drawing. When the field is updated, the latest value of the field
is displayed. Fields can be inserted into attribute definitions and can be used
to create callout tools.

For more information, see Fields on page 3487 and Creating New Callout Tools
on page 3732.
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Callouts and Projects

Callouts and their referenced model space views are closely linked to projects
in the Drawing Management feature. Although you can use callouts to some
degree outside a project, to use them optimally, you need to be working within
a project. For information on working outside a project, see Working with
Callouts Outside a Project on page 3728.

Callout Tools
Plans, sections, elevations, and details are typically referenced to a callout.
AutoCAD Architecture provides a number of predefined callout tools for the
various view types. You can also place a callout that is not referenced to a
view, and reference it later.

Callout tools in AutoCAD Architecture

The default tool palettes in the workspace contain sample callout tools that
you can use and customize as needed. In addition, the following catalogs
provided with the software contain callout tools that you can add to your tool
palettes:

■ Stock Tool catalog

■ AutoCAD Architecture Sample Palette catalog

■ Documentation Tool Catalog
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Custom palettes created by your CAD manager or other users may also contain
callout tools with properties that are customized for your projects or office
standards.

The following callout tools are provided with the software:

DescriptionTool

A detail callout tool with a circular boundary that can optionally insert
a title mark. The callout symbol has field placeholders for the sheet
number and the detail number, which are resolved when the detail
is placed on a sheet.

A detail callout tool with a rectangular boundary that can optionally
insert a title mark. The callout symbol has field placeholders for the
sheet number and the detail number, which are resolved when the
detail is placed on a sheet.

A detail callout tool with a freeform boundary that can optionally insert
a title mark. The callout symbol has field placeholders for the sheet
number and the detail number, which are resolved when the detail
is placed on a sheet.

A detail tool with a leader line. The callout symbol has a field place-
holder for the detail number that gets resolved when the detail is
placed on a sheet.

A detail tool with a leader line and a tail. The callout symbol has a
field placeholder for the detail number that gets resolved when the
detail is placed on a sheet.

A detail tool with a leader line. The callout symbol has field placehold-
ers for the detail number and the sheet number that get resolved
when the detail is placed on a sheet.

A detail tool with a leader line and a tail. The callout symbol has field
placeholders for the detail number and the sheet number that get
resolved when the detail is placed on a sheet.
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DescriptionTool

A single elevation mark tool. The elevation mark has a field placeholder
for the elevation number that gets resolved when the elevation is
placed on a sheet.

NOTE This tool is just a variation of the other single elevation mark
tools, using a different symbol style.

A single elevation mark tool. The elevation mark has field placeholders
for the elevation number and the sheet number that get resolved
when the elevation is placed on a sheet.

NOTE This tool is just a variation of the other single elevation mark
tools, using a different symbol style.

A four-way interior elevation mark tool in the format 1/2/3/4. The
elevation marks contain a field placeholder for the sheet number that
gets resolved when the elevation are placed on a sheet.

A four-way interior elevation mark tool in the format N/S/E/W. The
elevation marks contain a field placeholder for the sheet number that
gets resolved when the elevation are placed on a sheet.

A four-way exterior elevation mark tool. The elevation marks contain
a field placeholder for the sheet number that get resolved when the
elevation are placed on a sheet.

A single interior elevation mark tool. The elevation mark contains field
placeholders for the sheet number and the elevation number that get
resolved when the elevation is placed on a sheet.

A single interior elevation mark tool with inverted text. The elevation
mark contains field placeholders for the sheet number and the eleva-
tion number that get resolved when the elevation is placed on a sheet.

A single section mark tool with a leader line. The section mark contains
a field placeholder for the section number that gets resolved when
the section is placed on a sheet.

A single section mark tool with a leader line and a tail. The section
mark contains a field placeholder for the section number that gets
resolved when the section is placed on a sheet.
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DescriptionTool

A single section mark tool with a leader line. The section mark contains
field placeholders for the section number and the sheet number that
get resolved when the section is placed on a sheet.

A single section mark tool with a leader line and a tail. The section
mark contains field placeholders for the section number and the sheet
number that get resolved when the section is placed on a sheet.

A double section mark tool with a section line. The section marks
contain field placeholders for the section number and the sheet
number that get resolved when the section is placed on a sheet.

A title mark with fields for view title, viewport scale and view number.

A title mark with fields for view title and viewport scale.

Workflow for Annotating Drawings with Callouts

Open the drawing in which you want to add a
callout.
If you are working in a structured AutoCAD
Architecture project, open a view on page 461
drawing from the Project Navigator.

-----Open a drawing

Select a callout tool on page 3690, and add the
callout to the drawing.

-----Identify the type of callout to add
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Determine if the callout is connected to a model
space view on page 3728 or not Placing a Callout-----

Decide if you want a new model
space view Without a Model Space View on page 3723, and

name the model space view if necessary.

Generate a model space view for a detail on page
3703, section on page 3709, or elevation on page 3717

-----
Specify the scale and placement of
the model space view

callout by specifying its scale and where it is to
be created.
If you are working in a structured AutoCAD
Architecture project on page 462, you have options
of where to place the image generated by the
callout.

Add the model space view by specifying the
insertion point on page 3729 in the current
drawing.
If you are working in a structured AutoCAD
Architecture project, fields on page 3732 contain
placeholder information in the callout.

-----
Add the model space view to the
drawing

Resolve on page 3727 the field placeholder
information, like the view number or the sheet

-----
Update the view number and sheet
number number, in the callout by placing the model space

view on a sheet if you are working in a structured
AutoCAD Architecture project.

The Properties of a Callout Tool
You can use callout tools to create section views, elevation views, and detail
views that are referenced to a callout. Depending on the view type you want
to create, you need to set different options in the callout tool.
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Properties of a detail callout
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Properties of an elevation callout
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Properties of a title mark tool

The following table lists the properties you can set for the individual tool
types.

DescriptionTool TypeProperty

General Category

Here, you specify the layer key in which the
callout symbol should be inserted.

General (all
callout types)

Layer Key

If necessary, you can specify a layer key over-
ride for the callout symbol here.

GeneralLayer Overrides

Here, you define the type of callout tool you
want to insert. You can choose between these
types:

GeneralCallout type

■ Detail Boundary: a tool consisting of a
detail boundary and a detail mark

■ Detail Mark: a tool consisting of only a
detail mark

■ Elevation Single: a tool consisting of a
single elevation mark

■ Elevation Four-Way: a tool consisting of
four elevation marks and lines
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DescriptionTool TypeProperty

■ Section Tag and Tail: a tool consisting of
a section line with a tag and a tail

■ Section Tag and Tag: a tool consisting of
a section line with two tags on start and
end

You can choose the shape of the detail
boundary. Available options are circular,
rectangular, and freeform.

Detail Bound-
ary

Callout boundary type

You can select the type of four-way elevation
the tool should create. Available options are
interior and exterior elevations.

NOTE For an interior elevation, you can select
spaces as the elevation region.

Elevation Four
Way

Four way elevation
type

Here, you define the block that is used as the
callout tag.

GeneralTag name

Defines the location of the available callout
symbol tags, and, if applicable, the location
of the available tag arrows.

GeneralTag and arrow loca-
tion

Define the block for the section/elevation
mark arrow.

Section/ Eleva-
tion

Arrow

Here you select if the text style for attributes
in the callout should be the text style of the

GeneralAttribute text style

callout tag (Content) or the current text style
of the drawing (Target).

Here, you select the text angle of the attribute
text. You can choose to insert the attribute

GeneralAttribute text angle

text at the same angle as the callout symbol
(As Inserted), horizontal in the drawing (Hori-
zontal), or to be read from the right side
(Right Reading).

Dimensions Category
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DescriptionTool TypeProperty

Defines the corner radius of rectangular and
freeform detail boundaries.

Detail Bound-
ary

Corner Radius

Defines the linetype of the detail boundary.Detail Bound-
ary

Boundary linetype

Defines the line width of the boundary lines.Detail Bound-
ary

Boundary width

View Defaults Cat-
egory

This setting determines the type of view gen-
erated by the callout tool. You can choose
between the following:

GeneralView Type

■ Detail View: If you have selected Detail
View for type, and create a model space
view in a new drawing, the Detail View
template set in the project will be used
for the new drawing.

■ Section/Elevation View: If you have selec-
ted Section/Elevation View for type, and
create a model space view in a new
drawing, the Section/Elevation View
template set in the project will be used
for the new drawing.

■ General View: If you have selected Gener-
al View for type, and create a model space
view in a new drawing, the General View
template set in the project will be used
for the new drawing.

Here, you can choose if the tool should create
a 2D section elevation.

GeneralGenerate Section/Elev-
ation

If you have selected to generate a 2D sec-
tion/elevation from the tool, you need to set
a 2D section/elevation style.

GeneralSection/Elevation style
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DescriptionTool TypeProperty

Sets the drawing or template file from in
which the available 2D section/elevation styles
reside.

GeneralSection/Elevation style
location

If you have selected to generate a 2D sec-
tion/elevation from the tool, you need to set
a display set for the 2D section/elevation here.

GeneralDisplay set

Sets the drawing or template file from in
which the available display sets reside.

GeneralDisplay set location

In this setting, you define the scale of the
model space view generated from the tool,

GeneralScale

as well as the scale of sheet views generated
from the model space view.

NOTE You can override the scale set in the
tool during insertion of the callout in the
drawing.

Sets a default name for model space views
that are created by this tool. You can override

GeneralName

the name set in the tool when inserting a
callout in the drawing.

Sets a default incrementing method for nam-
ing multiple model space views created with

GeneralIncrement

this callout tool. Available options are Integer
and Character.

Here, you can select if a title mark should be
attached to model space views created with
this tool.

GeneralPlace a title mark

Title mark Category

By default, a title mark that is associated to a
callout tool is inserted on the same layer as

GeneralLayer Key

the model space view generated. You can
however define a different layer for the title
mark by selecting a different layer key here.
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DescriptionTool TypeProperty

If necessary, you can specify a layer key over-
ride for the title mark here.

GeneralLayer Overrides

This setting specifies the justification of the
title mark in relation to the title mark line.
Available options are Left and Right.

GeneralJustify

In this list, you select the block used for the
title mark symbol.

GeneralTag

Sets the drawing or template file from in
which the available blocks reside.

GeneralTag location

Here, you define the title symbol.GeneralTitle

Sets the drawing or template file from in
which the available title symbols reside.

GeneralTitle location

Here you select if the text style for attributes
in the title should be the text style of the title

GeneralAttribute Text Style

tag (Content) or the current text style of the
drawing (Target).

This setting specifies the width of the polyline
separator. The value is measured in plotting

GeneralPolyline width

units and scaled appropriately based on the
current annotation scale.

Setting the Properties of a Callout Tool
Use this procedure to set the properties of a callout tool.

1 On the Tool Palettes, click  (Properties), and click Document.

2 Click the Callouts palette.

3 Select the callout tool for which you want to change properties,
right-click, and click Properties.

4 Change the properties as necessary. For a description of the
available properties, see The Properties of a Callout Tool on page
3694.
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5 Click OK.

Placing Title Marks
You can place title marks in a drawing. A title mark can contain fields for
information about model space views and sheet views. A title mark cannot be
used to create a model space view, but it can be connected to an existing one.
This is useful when working with legacy drawings or when annotating drawings
at a later stage. You can connect title marks to any type of model space view,
like details, sections, and elevations.

Placing a Title Mark
Use this procedure to place a title mark in a drawing.

NOTE The title marks shipped with AutoCAD Architecture contain fields for (model)
view number, (model) view title, and (model) viewport scale. To display that
information, they need to be associated with a model space view.

1 Open the view drawing containing the model space view to which
you want to add the title mark.

2 On the Tool Palettes, click  (Properties), and click Document.

3 Click the Callouts palette.

4 Select a title mark tool.

Alternatively you can click Annotate tab ➤ Callouts panel ➤ Title

drop-down ➤ Title  .

5 Select the model space view you want to associate the title mark
to.

NOTE When you hover over the a model space view, its boundaries
are highlighted.

6 Click to place the start point of the title mark.

7 Click to specify the end point of the title mark.

The title mark is inserted with the view fields filled in. If your title
mark contains fields for sheet information, the model space view
might need to be associated with a sheet before resolving these
fields.
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Title mark

Placing Detail Callouts
You can use callouts to create specific, enlarged views of the building model.
Typically, you detail components to a detail to call out items that are not
included as part of the building model, like bolts and connectors, or detailed
brick hatches. You can also use callouts to generate sections or elevations of
an existing section or elevation. For example, you could create a section of
the building model, and then create an enlarged detail from part of the section.
To that detail, you could then add detail components for the construction
document.

For more information about detail components, see Detail Components on
page 3527.

Door head detail example

Creating a Detail in the Current View Drawing
Use this procedure to place a callout that creates a detail in the current view
drawing.
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Viewing building section detail boundary

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 Select the view drawing in which you want to place the detail
callout, right-click, and click Open.

4 On the Tool Palettes, click  (Properties), and click Document.

5 Click the Callouts palette.

6 Select a detail callout tool.

Then …If you want to …

select one of the detail boundary tools. Auto-
CAD Architecture provides tools for circular,
rectangular, and freeform detail boundaries.

create a callout with a
detail boundary and a
detail mark

select one of the detail mark tools. AutoCAD
Architecture provides tools for regular detail

create a callout without
a detail boundary

marks, detail marks with a tail, and detail
marks with a sheet number attribute.

Alternatively, you can click Annotate tab ➤ Callouts panel ➤ 

 ➤ Detail Boundary drop-down for callouts with a detail boundary,
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or Annotate tab ➤ Callouts panel ➤  ➤ Detail drop-down for
callouts without a detail boundary.

7 If you selected a detail boundary tool, specify the extents of the
detail boundary.

8 Specify the detail leader line, and press ENTER.

9 Under New Model Space View Name, enter a name for the new
model space view containing the detail.

10 If necessary, select Generate Section/Elevation.

11 If you want to add a title mark to the model space view, select
Place Titlemark.

12 Select the scale for the model space view.

13 Click Current Drawing.

14 If you selected to create a detail with a section/elevation, specify
the insertion point of the 2D section/elevation result.

15 If you selected to create a detail without a section/elevation,
specify the extents of the model space view containing the area
being detailed.

The extents of the model space view will dictate the default sheet
view size, so if the model space boundary is too small, you may
have problems placing annotations in it.

Once the model space view has been placed in the drawing, the
field placeholders in the callout change to a question mark. To
resolve them, the model space view needs to be placed onto a
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sheet, as described in Resolving Fields in Callout Symbols on page
3727.

The model space view is displayed in the Project Navigator under
the view drawing in which you have created it.

Creating a Detail in an Existing Drawing
Use this procedure to place a callout that creates a detail in an existing project
view drawing.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 Select the view drawing in which you want to place the detail
callout, right-click, and click Open.

4 On the Tool Palettes, click  (Properties), and click Document.

5 Click the Callouts palette.

6 Select a detail callout tool:

Then…If you want to…

select one of the detail boundary tools. Auto-
CAD Architecture provides tools for circular,
rectangular, and freeform detail boundaries.

create a callout with a
detail boundary and a
detail mark

select one of the detail mark tools. AutoCAD
Architecture provides tools for regular detail

create a callout without
a detail boundary

marks, detail marks with a tail, and detail
marks with a sheet number attribute.

Alternatively, you can click Annotate tab ➤ Callouts panel ➤ 

 ➤ Detail Boundary drop-down for callouts with a detail boundary,

or Annotate tab ➤ Callouts panel ➤  ➤ Detail drop-down for
callouts without a detail boundary.

7 If you selected a detail boundary tool, specify the extents of the
detail boundary.

8 Specify the detail leader line, and press ENTER.

9 Under New Model Space View Name, enter a name for the new
model space view containing the detail.
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10 If necessary, select Generate Section/Elevation.

11 If you want to add a title mark to the new model space view, select
Place Titlemark.

12 Select the scale for the model space view.

13 Click Existing View Drawing.

Select a drawing to place the detail

14 Select the project view drawing in which to place the model space
view, and click OK.

15 If you selected to create a detail with a section/elevation, specify
the insertion point of the 2D section/elevation result.

16 If you selected to create a detail without a section/elevation,
specify the extents of the model space view containing the area
being detailed.

The extents of the model space view will dictate the default sheet
view size, so if the model space boundary is too small, you may
have problems placing annotations in it.

Once the model space view has been placed in the drawing, the
field placeholders in the callout change to a question mark. To
resolve them, the model space view needs to be placed onto a
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sheet, as described in Resolving Fields in Callout Symbols on page
3727.

17 To display the model space view in the Project Navigator, navigate
to the target drawing, and expand it.

The model space view is listed under the drawing.

For information on opening the model space view, see Opening
a Model Space View on page 3726.

Creating a Detail in a New Drawing
Use this procedure to place a callout that creates a detail in a new project view
drawing.

You can place each detail in its own detail drawing. The Detail View template
set in the project is used to create the new drawing. For more information,
see Creating a New Project on page 328.

When you create a new drawing for a detail, it contains by default the same
constructs, levels, and divisions as the drawing from which the detail is taken.
You can change that assignment, if necessary.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 Select the view drawing in which you want to place a detail
callout, right-click, and click Open.

4 On the Tool Palettes, click  (Properties), and click Document.

5 Click the Callouts palette.

6 Select a detail callout tool:

Then…If you want to…

select one of the detail boundary tools. Auto-
CAD Architecture provides tools for circular,
rectangular, and freeform detail boundaries.

create a callout with a
detail boundary and a
detail mark

select one of the detail mark tools. AutoCAD
Architecture provides tools for regular detail

create a callout without
a detail boundary

marks, detail marks with a tail, and detail
marks with a sheet number attribute.
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Alternatively, you can click Annotate tab ➤ Callouts panel ➤ 

 ➤ Detail Boundary drop-down for callouts with a detail boundary,

or Annotate tab ➤ Callouts panel ➤  ➤ Detail drop-down for
callouts without a detail boundary.

7 If you selected a detail boundary tool, specify the extents of the
detail boundary.

8 Specify the detail leader line, and press ENTER.

9 Under New Model Space View Name, enter a name for the new
model space view containing the detail.

10 If necessary, select Generate Section/Elevation.

11 If you want to add a title mark to the new model space view, select
Place Titlemark.

12 Select the scale for the model space view.

13 Click New View Drawing.

14 Define the properties of the new view drawing, as described in
Creating a New View Drawing on page 453.

15 Click Finish.

Once the model space view has been placed in the new view
drawing, the field placeholders in the callout change to a question
mark. To resolve them, the model space view needs to be placed
onto a sheet, as described in Resolving Fields in Callout Symbols
on page 3727.

Placing Section Callouts
You can use callouts to create sections of the building model. A section can
be used as the basis for a detail, containing information about components
such as insulation, materials, and finishes.
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Viewing a wall section mark

Creating a Section in the Current Drawing
Use this procedure to place a callout that creates a 2D section in the current
project view drawing.

NOTE The 2D section style and the display set for the model space view containing
the section are set in the callout tool. For more information, see Setting the
Properties of a Callout Tool on page 3701.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 Select the view drawing in which you want to place the section
callout, right-click, and click Open.

4 On the Tool Palettes, click  (Properties), and click Document.

5 Click the Callouts palette.

6 Select a section callout tool.

For a description of the section callout tools included with the
software, see Callout Tools in AutoCAD Architecture on page 3690.

Alternatively, you can click Annotate tab ➤ Callouts
panel ➤ Sections drop-down, and select one of the section tools.

7 In the drawing area, specify the first point of the section line.
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8 Continue to add points to the section line. When you have
finished the shape of the section line, press ENTER.

9 Specify the direction of the section mark arrow.

10 Under New Model Space View Name, enter a name for the new
model space view containing the section.

11 Verify that Generate Section/Elevation is selected.

12 If you want to add a title mark to the new model space view, select
Place Titlemark.

13 Select the scale for the model space view.

14 Click Current Drawing.

15 In the drawing area, select the insertion point for the model space
view.

Once the model space view has been placed, the field placeholders
in the section callout change to a question mark. To resolve them,
the model space view needs to be placed onto a sheet, as described
in Resolving Fields in Callout Symbols on page 3727.

Creating a Section in the Current Drawing | 3711



Building section view

Creating a Section in an Existing Drawing
Use this procedure to place a callout that creates a 2D section in an existing
project view drawing.

Sections are often placed into a designated section drawing. Whenever a new
section is created, it is added to that drawing.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 Select the view drawing in which you want to place a section
callout, right-click, and click Open.

4 On the Tool Palettes, click  (Properties), and click Document.

5 Click the Callouts palette.

6 Select a section callout tool.

For a description of the section mark tools included with the
software, see Callout Tools in AutoCAD Architecture on page 3690.

Alternatively, you can click Annotate tab ➤ Callouts
panel ➤ Sections drop-down, and select one of the section tools.

7 In the drawing area, specify the first point of the section line.

8 Continue to add points to the section line. When you have
finished the shape of the section line, press ENTER.
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9 Specify the direction of the section mark arrow.

10 Under New Model Space View Name, enter a name for the new
model space view containing the section.

11 Verify that Generate Section/Elevation is selected.

12 If you want to add a title mark to new model space view, select
Place Titlemark.

13 Select the scale for the model space view.

14 Click Existing View Drawing.
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Select a drawing to place the section

15 In the Add Model Space View dialog, select the project view
drawing in which the model space view should be placed, and
click OK.

16 In the drawing area, select the insertion point of the generated
section.

NOTE Although you select the insertion point in the current drawing,
it will be used in the target drawing where the section result is placed.
That way, you have control over the insertion point of the 2D section
without opening the target drawing. You can change the location of
the 2D section later, when you open the drawing in which the 2D
section was placed, and change it there.

Once the model space view has been placed, the field placeholders
in the section callout change to a question mark. To resolve them,
the model space view needs to be placed onto a sheet, as described
in Resolving Fields in Callout Symbols on page 3727.

17 To display the section view in the Project Navigator, navigate to
the target drawing, and expand it.

The model space view is listed under the drawing.
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For information on opening the model space view, see Opening
a Model Space View on page 3726.

Creating a Section in a New Drawing
Use this procedure to place a callout that creates a 2D section in a new project
view drawing.

When you create a section view in a new drawing, the building model is
referenced into the new drawing. A 2D section is based on the geometry of
the objects cut by the section line. If you place a callout in your First Floor Plan
view drawing, and create a 2D section in that drawing, then the section will
only contain the first floor geometry - only those building model objects that
are present either as drawing objects or external references it the current
drawing. When you create a new section view drawing for the 2D section,
you can control which levels, divisions, and constructs are included in the
section. This affords you enhanced control over what objects will be included
in the section. You could, for example, deselect the Furniture construct from
the First Floor Plan view drawing, to avoid cluttering up the section with
unnecessary building components. In the same way, you can add constructs,
levels or divisions not present in the current view drawing, for example, to
create background graphics.

Floor plan (top) and building section (bottom)

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.
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3 Select the view drawing in which you want to place a section
callout, right-click, and click Open.

4 On the Tool Palettes, click  (Properties), and click Document.

5 Click the Callouts palette.

6 Select a section mark tool.

For a description of the section mark tools provided with the
software, see Callout Tools in AutoCAD Architecture on page 3690.

Alternatively, you can click Annotate tab ➤ Callouts
panel ➤ Sections drop-down, and select one of the section tools.

7 In the drawing area, specify the first point of the section line.

8 Continue to add points to the section line. When you have
finished the shape of the section line, press ENTER.

9 Specify the direction of the section mark arrow.

10 Under New Model Space View Name, enter a name for the new
model space view containing the section.

11 Verify that Generate Section/Elevation is selected.

12 If you want to add a title mark to the new model space view, select
Place Titlemark.

13 Select the scale for the model space view.

14 Define the properties of the new view drawing, as described in
Creating a New View Drawing on page 453.

NOTE By default, all constructs, levels, and divisions are preselected
here.

15 Click Finish.

16 In the drawing area, select the insertion point of the generated
section.

NOTE Although you select the insertion point in the current drawing,
it will be used in the target drawing where the section result is placed.
That way, you have control over the insertion point of the 2D section
without opening the target drawing. You can change the location of
the 2D section later, when you open the drawing in which the 2D
section was placed, and change it there.

Once the model space view has been placed in the new view
drawing, the field placeholders in the section callout change to

3716 | Chapter 49   Callouts



a question mark. To resolve them, the model space view needs to
be placed onto a sheet, as described in Resolving Fields in Callout
Symbols on page 3727.

Placing Elevation Callouts
You can use callouts to create elevations of the building model. With the
callout tools of AutoCAD Architecture, you can create interior and exterior
elevations. When you create an interior elevation, you can select spaces as
the elevation boundary.

4 model space exterior elevations

AutoCAD Architecture comes with a number of predefined elevation callout
symbols. For a list, see Callout Tools in AutoCAD Architecture on page 3690.

Placing a Single Elevation Callout
Use this procedure to place a callout that creates a single elevation.

NOTE The 2D section/elevation style and the display set for the model space view
containing the elevation are set in the elevation callout tool. For more information,
see Setting the Properties of a Callout Tool on page 3701.
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1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 Select the view drawing in which you want to place an elevation
callout, right-click, and click Open.

4 On the Tool Palettes, click  (Properties), and click Document.

5 Click the Callouts palette.

6 Select a single elevation callout tool.

Alternatively, you can click Annotate tab ➤ Callouts

panel ➤ Elevations drop-down ➤ Elevation (Single)  , or
Annotate tab ➤ Callouts panel ➤ Elevations

drop-down ➤ Elevation (Single, Inverted Text)  .

7 Select the location for the elevation mark in the drawing.

8 Specify the direction of the elevation.

9 Under New Model Space View Name, enter a name for the new
model space view containing the elevation.

10 Verify that Generate Section/Elevation is selected.

11 If you want to add a title mark to the new model space view, select
Place Titlemark.

12 Select the scale for the model space view.
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13 Select where to place the elevation:

Then…If you want to…

click Current Drawing.place the elevation in the view
drawing in which you placed
the callout

click Existing View Drawing and follow
the instructions in Creating a Section
in an Existing Drawing on page 3712.

place the elevation in an exist-
ing elevation view drawing

click New View Drawing and follow the
instructions in Creating a Section in a
New Drawing on page 3715.

place the elevation in a new el-
evation drawing

14 In the drawing, select the first corner of the elevation region.

15 Select the opposite corner of the elevation region.

16 Define the insertion point of the elevation result.

NOTE If you chose to place the elevation in a different drawing, you
still select the insertion point in the current drawing. The elevation
view however, will be inserted in the drawing you have specified.

Once the model space view has been placed, the field placeholders
in the elevation tool change to a question mark. To resolve them,
the model space view needs to be placed onto a sheet, as described
in Resolving Fields in Callout Symbols on page 3727.

Placing a Four-Way Interior Elevation Callout
Use this procedure to place a callout that creates a four-way interior elevation.

When you create a four-way interior elevation, you can define the elevation
region either by specifying its corner points in the drawing, or by selecting
spaces as the elevation boundary.

NOTE The 2D section/elevation style and the display set for the model space views
containing the elevations are set in the elevation callout tool. For more information,
see Setting the Properties of a Callout Tool on page 3701.

1 On the Quick Access toolbar, click Project Navigator  .
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2 Click the Views tab.

3 Select the view drawing in which you want to place an elevation
callout, right-click, and click Open.

4 On the Tool Palettes, click  (Properties), and click Document.

5 Click the Callouts palette.

6 Select a four-way interior elevation callout tool.

Alternatively, you can click Annotate tab ➤ Callouts
panel ➤ Elevations drop-down ➤ Elevation (Interior. 1, 2, 3, 4)

or Annotate tab ➤ Callouts panel ➤ Elevations

drop-down ➤ Elevation (Interior. N, S, E, W)  .

7 Select the location for the elevation mark in the drawing.

8 Specify the direction of the first elevation number.

9 Under New Model Space View Name, enter a name for the model
space view containing the first of the four elevations.

10 Verify that Generate Section/Elevation is selected.

11 If you want to add a title mark to the new model space view, select
Place Titlemark.

12 Select the scale for the model space view.
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13 Select where to place the elevation:

Then…If you want to…

click Current Drawing.place the elevation in the view
drawing in which you placed
the callout

click Existing View Drawing and follow
the instructions in Creating a Section
in an Existing Drawing on page 3712.

place the elevation in an exist-
ing elevation view drawing

click New View Drawing and follow the
instructions in Creating a Section in a
New Drawing on page 3715.

place the elevation in a new el-
evation drawing

14 In the drawing, select the elevation region:

Then…If you want to…

select the space, and press ENTER.define the elevation region with
a space

press ENTER. Then, select the two
boundary points of the elevation re-
gion.

define the elevation region by
picking two boundary points

15 Specify the depth of the elevations.

16 Specify the height of the elevations.

17 Specify the insertion point of the elevations.

NOTE If you chose to place the elevations in a different drawing, you
still select the insertion point in the current drawing. The elevations,
however, will be inserted in the drawing you specified.

18 Specify the distance between the elevations and their orientation.

Once the model space views have been placed, the field
placeholders in the elevation callouts change to a question mark.
To resolve them, the model space views need to be placed onto
sheets, as described in Resolving Fields in Callout Symbols on
page 3727.
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Placing a Four-Way Exterior Elevation Callout
Use this procedure to place a callout that creates a four-way exterior elevation.

NOTE The 2D section/elevation style and the display set for the model space views
containing the elevations are set in the elevation mark tool. For more information,
see Setting the Properties of a Callout Tool on page 3701.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 Select the view drawing in which you want to place an elevation
callout, right-click, and click Open.

4 On the Tool Palettes, click  (Properties), and click Document.

5 Click the Callouts palette.

6 Select a four-way exterior elevation callout tool.

Alternatively, you can click Annotate tab ➤ Callouts

panel ➤ Elevations drop-down ➤ Elevation (Exterior)  .

7 Specify the first corner of the elevation region.

8 Specify the opposite corner of the elevation region.

9 Under New Model Space View Name, enter a name for the model
space view containing the first elevation.

10 Verify that Generate Section/Elevation is selected.
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11 If you want to add a title mark to the new model space views,
select Place Titlemark.

12 Select the scale for the model space view.

13 Select where to place the elevation:

Then…If you want to…

click Current Drawing.place the elevation in the view
drawing in which you placed
the callout in

click Existing View Drawing and follow
the instructions in Creating a Section
in an Existing Drawing on page 3712.

place the elevation in an exist-
ing elevation view drawing

click New View Drawing and follow the
instructions in Creating a Section in a
New Drawing on page 3715.

place the elevation in a new el-
evation drawing

14 Specify the height of the elevations.

15 Specify the insertion point of the elevations.

NOTE If you chose to place the elevations in a different drawing, you
still select the insertion point in the current drawing. The elevations
however, will be inserted in the drawing you specified.

16 Specify the distance between the elevations and their orientation.

Once the model space views have been placed, the field
placeholders in the callout change to a question mark. To resolve
them, the model space views need to be placed onto sheets, as
described in Resolving Fields in Callout Symbols on page 3727.

Placing a Callout Without a Model Space View
Use this procedure to place a callout that is not connected to a model space
view.

Placing a callout that is not referenced to a model space view might be useful
if you have legacy view drawings that are not yet referenced to a callout. You
can create a standalone callout in a building model, and then reference it to
an existing model space view or sheet view in the project.
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When you insert a callout without a referenced model space view in a drawing,
the field placeholders in the callout are not connected to a view. Therefore,
the field placeholders are displayed in the callout by their names; for example
“Viewnumber,” or “Sheetnumber.”

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 Select the view drawing in which you want to place a callout,
right-click, and click Open.

4 On the Tool Palettes, click  (Properties), and click Document.

5 Click the Callouts palette.

6 Select a callout tool.

For a description of the callout tools shipped with AutoCAD
Architecture, see Callout Tools in AutoCAD Architecture on page
3690.

Alternatively, you can click Annotate tab ➤ Callouts panel, and
select a callout tool.

7 Add the callout tool to the drawing, following the instructions
for the type of tool you selected.

8 Click Callout Only.

An unconnected callout symbol is inserted in the drawing.
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Referencing a Callout to an Existing View
Use this procedure to reference a callout to an existing model space view or
to an existing sheet view in the project. For information on creating model
space views, see Creating a Model Space View on page 468. For information on
creating sheet views, see Creating a Sheet View on page 497.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 Select the view drawing that contains the callout, right-click, and
click Open.

4 Select the callout.

5 In the Project Navigator, navigate to the model space view or
sheet view you want to reference to the callout:

Then…If you want to…

click the Views tab, and navigate to the
view drawing containing the model space
view. Then, expand the view drawing.

reference the callout to an
existing model space view

click the Sheets tab, and click  . Navig-
ate to the sheet containing the sheet view,
and expand the sheet.

NOTE If a sheet view already exists,
you can reference the callout to either
the sheet view or the model space
view.

reference the callout to an
existing sheet view

6 Drag the callout from the drawing onto the model space view or
the sheet view in the Project Navigator.

If you referenced the callout to a model space view, the field
placeholders in the callout change to question marks. For
information on resolving field placeholders in callouts, see
Resolving Fields in Callout Symbols on page 3727.

If you have connected the callout to a sheet view, the field
placeholders in the callout are resolved with the sheet information.
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Opening a Model Space View
Use this procedure to open a model space view.

When you create a model space view that is referenced to a callout, the model
space view can be placed in the drawing in which the callout was placed, into
an existing project view drawing, or in a new project view drawing.

Model space views are displayed and opened in the Views tab of the Project
Navigator.

Exterior elevation model space views in Project Navigator

1 On the Quick Access toolbar, click Project Navigator  .

2 In the Project Navigator, navigate to the view drawing containing
the model space view.

It is not important whether the drawing is already open.

3 If necessary, expand the view drawing to display the model space
views contained in it.

4 Select the model space view you want to open, and double-click
it.

Alternatively, you can select the model space view in the Project
Navigator, right-click, and click Open.
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Deleting a Model Space View
Use this procedure to delete a model space view.

When you delete a model space view, any callout symbols and title marks
associated with the view are not deleted automatically. After deleting the
model space view, you need to manually delete the callout symbol and title
mark from the source drawing.

1 On the Quick Access toolbar, click Project Navigator  .

2 Click the Views tab.

3 Select the view drawing that contains the model space view you
want to delete, and expand it.

4 Select the model space view to delete, right-click, and click Delete.

Resolving Fields in Callout Symbols
Use this procedure to place a model space view on a sheet and resolve its field
placeholders.

The predefined callout tools in AutoCAD Architecture contain field placeholder
information about the sheet number and the view number. This information
can be resolved only when the model space view created by the callout is
referenced into a sheet. As long as the model space view is not placed on a
sheet, the information is unresolved, and a question mark is displayed.

Unresolved (left) and resolved (right) elevation callout symbols

Once the model space view is placed on a sheet, and the sheet information
in the callout is resolved, a link is created between the field information in
the model space view and the sheet on which it is placed. When you CTRL-click
the sheet number, the corresponding sheet drawing is opened.

1 Create a model space view referenced to a callout, as described in
Placing Detail Callouts on page 3703, Placing Section Callouts on
page 3709, or Placing Elevation Callouts on page 3717.
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2 In the Project Navigator, click the Sheets tab, and click  .

3 In the Sheet Set View, locate the sheet onto which you want to
place the model space view.

4 Open the sheet in one of these ways:

■ Select the sheet, right-click, and click Open.

■ Double-click the sheet.

The drawing containing the sheet is opened in the drawing area
of AutoCAD Architecture. The sheet you selected is the active
layout.

5 In the Project Navigator, click the Views tab.

6 Select the model space view you want to place onto the sheet,
and place it in one of these ways:

■ Select the model space view, and drag it from the Project
Navigator to the drawing area of the sheet.

■ Select the model space view, right-click, and click Place on
Sheet. Then, select an insertion point on the sheet.

When you open the model space view, you can see that the sheet
information has been updated.

Working with Callouts Outside a Project
Model space views are based on the concepts of the Drawing Management
feature. A model space view normally is created from a project view drawing
and referenced into a project sheet drawing.

You can use a part of the callout functionality outside a project, in a standalone
DWG file, with the following limitations:

■ You can place model space views only within the current drawing.

■ You can access model space views only from the Named Views dialog of
AutoCAD.

■ You cannot templates for details, sections, or elevations.

■ Field placeholders containing information about views and sheets are not
automatically resolved. You must enter values manually.
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Placing a Callout in a Non-Project Drawing File
Use this procedure to place a callout in a drawing that does not belong to a
Drawing Management project.

1 On the Tool Palettes, click  (Properties), and click Document.

2 Click the Callouts palette.

3 Select a callout tool.

Alternatively, you can click Annotate tab ➤ Callouts panel, and
select a callout tool.

4 Insert the callout into the drawing.

Then…If you want to…

insert the tool as described in Creating a
Detail in the Current View Drawing on page
3703.

place a detail callout

insert the tool as described in Creating a
Section in the Current Drawing on page
3710.

place a section callout

insert the tool as described in Placing a
Single Elevation Callout on page 3717.

place a single elevation cal-
lout

insert the tool as described in Placing a
Four-Way Interior Elevation Callout on page
3719.

place a four-way interior el-
evation callout
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Then…If you want to…

insert the tool as described in Placing a
Four-Way Exterior Elevation Callout on page
3722.

place a four-way exterior
elevation callout

5 Under New Model Space View Name, enter a name for the new
model space view.

6 If you want to add a title mark to your model space view, select
Place Titlemark.

7 Select the scale for the model space view.

8 Under Create in, select Current Drawing.

A model space view is placed in the current drawing.

Opening Model Space Views in a Non-Project Drawing File
Use this procedure to open a model space view in a drawing that does not
belong to a Drawing Management project.

1 Place a callout in the drawing, as described in Placing a Callout
in a Non-Project Drawing File on page 3729.
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2 Click View tab ➤ Appearance panel ➤ Views drop-down ➤ View
Manager.

In the View Manager, the model space view you created is listed
under Views.

3 Select the model space view you want to open, and click Set
Current.

4 Click OK.

Deleting Model Space Views in a Non-Project Drawing File
Use this procedure to delete a model space view from a drawing that does not
belong to a Drawing Management project.

1 Open the drawing containing the model space view you want to
delete.

2 On the command line, enter view.

The model space views contained in the drawing are listed under
Model Views.

3 Select the model space view you want to delete, right-click, and
click Delete.

4 Click OK.
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Creating New Callout Tools
AutoCAD Architecture provides a number of predefined callout tools. You can
also create callout symbols with user-defined visuals and content.

Using Fields in Callout Tools
Fields enhance the documentation capabilities within a drawing file. A field
is updatable text that is set up to display data that may change during the life
cycle of the drawing. When the field is updated, the latest value of the field
is displayed. Usually, you use property set data for this type of updatable
information about the building model. However, property set data can be
used only in MV-blocks. Fields can be inserted into manual properties in
property set definitions, text, MText, attribute definitions and AutoCAD table
cells.

For detailed information about fields, see “Use Fields in Text” in AutoCAD
Help.

There are a number of predefined fields for sheet set information. Most of the
fields refer to the current sheet, and should be inserted only in a sheet drawing.

When you are creating a callout tool, you will often use a field from the Sheet
Set Placeholder category: These fields let you define a field as a placeholder
in a callout for a referenced sheet. The fields are resolved when the callout is
referenced into a sheet. For more information, see Resolving Fields in Callout
Symbols on page 3727.

■ Current Sheet Custom: You can select an AutoCAD custom property defined
for the current sheet here.

■ Current Sheet Description

■ Current Sheet Number

■ Current Sheet Number and Title

■ Current Sheet Set

■ Current Sheet Set Custom: You can select an AutoCAD custom property
defined for the current sheet here.

■ Current Sheet Set Description

■ Current Sheet Subset

■ Current Sheet Title
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■ Sheet Set: You can select any sheet from a sheet set as the field content;
available properties are sheet title, sheet number and sheet description.

■ Sheet Set Placeholder: You can insert a placeholder representing
information of a sheet. This placeholder is resolved when the callout is
referenced into a sheet. The following fields are available as placeholders:

■ Sheet Number and Title

■ Sheet Title

■ Sheet Number

■ Sheet Description

■ Sheet custom: You can select an AutoCAD custom property defined for
the referenced sheet here.

■ (Model Space) View Number and Title

■ (Model Space) View Title

■ (Model Space) View Number

■ (Model Space) Viewport Scale

NOTE The fields for sheet title, sheet number, sheet description, view title,
and view number can be associated with a hyperlink that jumps to the sheet
or model space view referenced.

■ Sheet View: You can select any sheet view from a sheet set as the field
content here; available properties are sheet view number, sheet view title,
and sheet view viewport scale.

NOTE The fields for sheet view number and sheet view title can be associated
with a hyperlink that jumps to the sheet view referenced.

Creating a Callout Tool
You can create callout tools that display information specific to the sheet set.
Callouts can be referenced to model space views and can contain fields that
point to a sheet or sheet view. When the model space view is placed onto into
a sheet, the field is resolved and displays the sheet information.
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For a list of available project and sheet set related fields, see Using Fields in
Callout Tools on page 3732.

Process Overview: Creating a Callout Tool
Creating a callout tool consists of these basic steps:

1 Open the drawing in which you want to store the callout block.

NOTE By default, callout blocks are placed in C:\ProgramData\Autodesk\ACA
2012\enu\Styles\Imperial\Callouts (Imperial).dwg. You can save your callout
blocks there, or create your own callout drawings.

2 Add callout attributes to the drawing.

3 Create a block from the attributes.

4 Create a callout tool on a tool palette.

Adding Callout Attributes
Use this procedure to create attributes for a callout tool.

1 Click Insert tab ➤ Attributes panel ➤ Define Attributes.

2 Define the first attribute for the callout tool.

3 Enter a name in the Tag field.

4 Under Value, click  .

5 Under Field category, select the desired category.
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TIP The Sheet Set category contains fields for views and sheets.

6 Under Field names, select the field you want to insert.

Some fields require additional information, like a file name or
property information.

7 Select the text format for the field text.

8 Click OK.

9 Proceed to adding the attribute as described in “Attribute
Definition Dialog Box” in AutoCAD help.

NOTE An attribute can contain only one sheet set field. If you want
to create a callout line that reads, for example, View Number - View
Title, you must define two separate attributes.

10 Repeat steps 1–3 for each attribute to add to the callout tool.

11 Complete the attribute block with lines, borders, and other desired
components.

The result is have a number of attributes and graphic elements in your drawing.
Your callout attributes might look like this:
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Callout attribute block

Creating a Callout Block
Use this procedure to create a block that contains the attributes you added in
the previous step.

1 Click Insert tab ➤ Block panel ➤ Create Block  .

2 Enter a name for the block.

3 Click Select Objects, and select the attributes and additional
graphics to include in the title block.

4 From the Drag-and-drop units list, select Unitless.

5 Proceed to creating the block as described in “Block Definition
Dialog Box” in AutoCAD help.

6 Save the drawing containing the callout block.

NOTE If you are creating a callout tool that will be used by multiple
users, make sure that the drawing is located in a folder all users have
access to. Otherwise, the tool won’t be able to be used by all users.

Creating a Callout Tool on a Tool Palette
Use this procedure to create the callout tool on a tool palette.

1 On the Tool Palettes, click  (Properties), and click Document.

2 Click the Callouts palette.

3 Select the callout tool most similar to the tool you want to create.

For example, if you want to create a detail tool, select one of the
existing detail tools.

4 Right-click, and click Copy. Then, right-click, and click Paste.

A copy of the selected tool is placed on the Callouts palette.
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5 Select the copied tool, right-click, and click Properties.

6 Rename the tool as desired.

7 Under Tag location, select the drawing you have saved the callout
block in.

8 Under Tag name, select the block you created.

9 Change other properties as needed; for example, add a new title
mark or change the 2D section/elevation style.

10 Click OK.

Creating a Callout Tool | 3737



3738



Schedules and Display
Themes

Schedules can be inserted in your drawings to display information about selected components
in your building. The information is extracted from objects in the drawing based on
information attached to objects and object styles.

Display themes provide another way to present data by using color, fills, and hatches. For
example, you can specify that all 2-hour fire-rated walls appear with a red fill. A display theme
legend identifies the correlation.

Data for display themes is also extracted from information attached to objects or object styles.
Display themes and schedule tables are style-based annotation objects, for which styles can
be created and modified in the Style Manager. For more information, see Style Manager
Overview on page 870.

Schedules
Schedules are tables you can insert in drawings to list information about selected
objects in your building model. Objects are made up of properties that contain
data. Schedule tags provide an efficient tool of collecting the property data
attached to the objects for display in a schedule table. You can create schedules
with varying levels of detail by defining and attaching sets of properties to object
styles or to individual objects and then extracting and displaying the data in a
schedule table.

You can produce basic schedule tables using the default tools provided with the
software. Before you perform more complex tasks such as creating your own
schedule tables, classifications, or working with formulas in your project, it is
important to understand how property data, property sets, and property set
definitions interact. We recommend the following topics:

■ Property Sets and Property Set Definitions on page 3743
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■ Property Data Formats on page 3802

■ Property Set Data on page 3810

■ Property Set Definitions on page 3823

If you want to add simple tags and schedules for common objects like doors
using one of the default tools, refer to the following topics:

■ Basic Schedules on page 3747

■ Schedule Tags on page 3754

If you want to manage the format and other display properties of schedules,
refer to the following topics about schedule table styles:

■ Working with Schedule Table Styles on page 3769

■ Specifying the Display Properties of a Schedule on page 3793

If you want to work with more advanced scheduling tasks, such as adding
classifications and formulas, refer to the following topics for information
about identifying and collecting detailed information from your objects:

■ Property Set Data on page 3810

■ Understanding Formulas on page 3830

■ Classification Definitions on page 3872

Each section gives you conceptual as well as procedural information for the
tasks you want to accomplish. Cross-references to additional supporting
information are provided throughout. For answers to various questions about
working with schedules, see Troubleshooting Schedule Tables on page 3898 and
Troubleshooting Schedule Table Styles on page 3901.

Schedule Table Terminology in AutoCAD Architecture
You can add basic schedules to your drawings using tools provided with the
software. These tools have predefined styles and properties. You can schedule
additional details about objects, such as door hardware, by customizing an
existing schedule table style or creating a new style. The following terms apply
to creating and managing schedules:
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Schedule Tags

You can use project-based or standard schedule tags in your drawings to
graphically display the property data of an object. By linking the schedule tag
to a property in a property set, such as the width of a door, you report property
data of the object, such as 3'-0''. When you anchor the tag to an object to
which the property set is applied, the value of the property displays in the
tag. The information in the tag is updated if the object or property change.
For more information, see Schedule Tags on page 3754.

Schedule Tools

The software provides default tools for project-based and standard wall, door,
and window schedules on the Scheduling tool palette and in the Content
Browser. Selecting one of these tools that has a style and other properties
predefined, lets you quickly place a schedule table in your drawing. You can
also apply the properties of a schedule table tool to existing schedule tables.
You can create schedule table tools from schedule table styles. For more
information, see Adding Schedules Using Schedule Table Tools on page 3747.

Schedule Styles

A schedule table style specifies the properties that can be included in a table
for a particular object type. The style also controls the table formatting, such
as text height and spacing, columns, and headers. Display properties in the
style control the visibility, layer, color, linetype, lineweight, and linetype scale
of table components. For more information, see Working with Schedule Table
Styles on page 3769.

Options in schedule table styles let you create both regular and matrix
schedules (also called dot schedules). You can also specify a matrix format for
individual columns in a regular schedule.

Property Data

Property data is information about properties of an object. For example, width
and height are typical properties of a door. The data collected on these
properties might reflect 3'-0" for width and 7'-0" for height. This property data
is contained within a property set. For more information, see Property Sets
and Property Set Definitions on page 3743.

NOTE Property data values are not contained in the schedule or schedule tag,
but on the object itself. The schedule and schedule tag simply displays values
retrieved directly from the object to which it is anchored.
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Property Sets

A property set is a user-definable group of related object properties. When you
attach a property set to an object or a style, the property set becomes the
container for the property data associated with the object. Property sets are
specified using property set definitions (see below). For more information, see
Property Set Definitions on page 3823 and Property Set Data on page 3810.

Property Set Definitions

A property set definition is a documentation object that specifies the
characteristics of a group of properties that can be tracked with an object or
style. For example, you could create a property set definition named DoorProps
that contains property definitions for DoorNumber, DoorWidth, and
FireRating. Each property has a name, description, data type, data format, and
default value. For more information, see Property Set Definitions on page 3823.

Property Data Formats

A property data format is specified for each property definition within a
property set definition to control how the data for that property displays in
a schedule table, in a schedule tag, or on the property palette. For example,
you can use property data formats to display a door that is three feet wide,
with a raw value of 36 units in a drawing, with inch units as 3'-0", or 3', or 3
ft. Property set definitions and schedule table styles use property data formats
to control the display format of values for each property. For more information,
see Property Data Formats on page 3802.

Workflow to Annotate Drawings with Tags and Schedules
If you use the annotation tools provided with the software, the definitions
and formats are already created for you.

Open a drawing.
If you are working in a structured AutoCAD
Architecture project, open a view on page 461
from the Project Navigator.

-----Open a drawing

Open the Document tool palette on page 70 set
or the Documentation Tool Catalog in the
Content Browser on page 129 to find the tag.

-----Find the schedule tag needed
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Add tags on page 3756 that are not designated as
project-based to objects in the drawing.
If you are working in a structured AutoCAD
Architecture project, you can add project-based

-----
Link construction information to
objects

tags on page 530 which collect additional
information for the objects.

Attach property set data on page 3810 to objects
on page 3811 in the drawing.
If you are working in a structured AutoCAD
Architecture project, creating property set-----

Customize the information to
display in the schedule table

definitions on page 536 allows you to group
specific property data from objects for a schedule
on page 532.

Edit the fields on page 3813 on the tag.-----Change information on the tag

Add a schedule table on page 3747 to display
property data collected from objects in your-----Add a schedule table
drawing or from objects in an
externally-referenced drawing on page 3796.

Property Sets and Property Set Definitions
The data reported in a schedule table is collected from property sets that you
attach to the objects or object styles you are scheduling. The properties
contained in a property set are determined by the property set definition,
which also specifies the object type, style, and definition to which the property
set can be applied.
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NOTE If you are using both AutoCAD Architecture and Revit MEP, locks may
appear on some property set definitions and property definitions when you open
legacy engineering drawings. Data that is programmatically set cannot be modified
and is protected and identified by locks:

■ selections on the Applies To tab and names for property set definitions

■ anything that affects the value of underlying data and names for property
definitions

A property set definition is a group of related properties of the objects and
object styles to be reported in the schedule. Once attached to an object or its
style, a property set becomes the container for the property data associated
with the object. Values for properties are obtained directly from the object or
are entered manually for the object or the style.

A property set definition for a door object

Automatic and Manual Properties

Properties for AEC object types fall into two categories:

■ Automatic properties are built into objects and styles when you create the
object. Examples are width, length, height, and data retrieved from other
sources, such as the project or the object’s material. For more information,
see Understanding Automatic Properties on page 3826.

■ Manual properties are those that you enter explicitly, such as fire rating,
manufacturer, or finish. For more information, see Adding a Manual
Property Definition to a Property Set Definition on page 3845.

Automatic properties are available to include in your property set definitions.
You create and enter values for manual properties.
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Applying Property Set Definitions to Objects and Styles

You can create a property set definition for either objects or styles and
definitions (like multi-view block definitions). Manual properties that are
likely to be different for each instance of an object belong in an object-based
property set definition that is applied by object.

Property set definition that applies to door objects

Manual properties that will be the same for all instances of a style belong in
a style-based property set definition that is applied to a style (such as a wall
style) or a definition (such as a multi-view block definition).

Property set definition that applies to multi-view block definition
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Automatic properties are dynamically retrieved from the object. Most automatic
properties should be put in a style-based property set definition, even if values
may vary for each instance of the object. For example, the properties “Door
Width” and “Door Height” are extracted automatically from door objects.
Placing these properties in a style-based property set definition provides a
value for each door object of that style, and is more efficient than putting
them in an object-based property set definition that you then attach to each
door.

NOTE A mismatch of data can occur if, after you create a schedule table with
property set data added, you change from an object-based property set definition
to a style-based definition. To correct this, remove the property sets and update
the schedule table. For more information, see Removing Property Set Data from
an Object on page 3814 and Removing Property Set Data from a Style or Definition
on page 3820.

Fields in Property Set Data

You can enter AutoCAD fields in a manual property attached to an object or
style. Fields enhance the documentation capabilities within a drawing file
because the values they display update whenever the associated property
changes. Fields can also be associated with hyperlinks. For example, if you
insert a field pointing to a drawing using a hyperlink in a manual property,
and create a schedule table that contains that property, you can jump from
the table cell with the field property in it to the drawing to which it is linked.

For more information, see Entering Manual Properties and Fields for Objects
on page 3812 and Adding a Field to a Property Set Definition on page 3847.

Lists in Property Set Data

List items are created in a list definition and are attached to a manual property
definition. With a predefined list of valid items, you can select an item from
the list for a manual property either in the property set definition or on the
Extended Data tab of the Properties palette. This reduces the redundancy of
entering values that are commonly used. For more information, see Creating
a List Definition for a Manual Property Definition on page 3869 and Adding a
Field to a Property Set Definition on page 3847.

Predefined Content for Schedules

There are predefined styles and properties for schedule table tools, schedule
tag tools, and property set definitions provided with the software. The tools
are located on the Scheduling tool palette in the Document tool palette set,
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and the property set definitions are in Style Manager under Documentation
Objects.

You can also access default schedule table styles, schedule tags, and property
set definitions in C:\ProgramData\Autodesk\ACA 2012\enu\Styles\<Imperial or
Metric>\Schedule Tables.dwg. You can use any of this content to create additional
schedules or as the basis for creating custom schedules, tags, and property set
definitions.

Basic Schedules
You have everything you need to add schedule tables and perform common
documentation tasks, such as tagging objects, when you open the software.
Schedule tables are objects. As with other objects in your drawing, properties
of schedule tables are displayed on the Properties palette when you add a
schedule or if you select a schedule. For more information, see The Properties
Palette on page 107.

Schedule table tools with predefined styles and properties are provided with
the software. Using these tools you can add door, window, space, and room
schedules to your drawing. They are located on the Scheduling tool palette
in the Document tool palette set.

Additional schedule table tools are located in the Documentation Tool Catalog
in the Content Browser. You can add tools from the Content Browser to any
tool palette. For more information, see Content Browser on page 129.

IMPORTANT The contextual tab for schedule tables includes a Convert to Table
option, which creates a copy of your AutoCAD Architecture schedule table that
can be inserted as an AutoCAD® table. AutoCAD Architecture commands, such
as Update or Add All Property Sets cannot be used on the converted table. Also
be aware that you may get unexpected results if you use special characters in your
schedule headings, such as equal signs (=). Avoid this problem by adding an
apostrophe (‘) in front of the character before doing the conversion. For more
information about working with AutoCAD® tables, see “Create and Modify Tables”
in AutoCAD Help.

Adding Schedules Using Schedule Table Tools
Use this procedure to add a schedule table to a drawing with a schedule table
tool. You can specify properties on the Properties palette when you add a
schedule table, or you can modify the schedule table later.
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When you use default tools, it is not necessary to make changes to the style
before you begin to capture data in your drawing. Property set data is already
attached to objects. For more information, see Working with Schedule Table
Styles on page 3769 and Property Set Data on page 3810.

1 Open the tool palette that contains the schedule table tool you
want to use, and select the tool.

Alternatively, you can click Annotate tab ➤ Scheduling panel,
and select one of the schedule table tools there.

2 Select the objects to include in the schedule table, or press ENTER
to schedule an external drawing.

For more information, see Changing External Source Properties
of a Schedule on page 3796.

You can use a selection window or a crossing window to select
objects. Objects that are not of the type specified for the schedule
table are filtered out.

3 In the drawing area, specify the insertion point for the upper-left
corner of the schedule table.

4 Specify the lower-right corner of the table, or press ENTER to scale
the schedule table to the current drawing scale.

■ If the schedule table contains question marks in any cells, the
property set containing that property is not attached to an
object or style.

■ Empty cells or dashes in cells indicate that the property set is
attached, but data is not available or is not entered for that
object or style.

For more information about attaching property sets for property
set data, see Property Set Data on page 3810.

Creating a Schedule Table Tool
Use this procedure to create a schedule table tool and add it to a tool palette.
You may want to create your own schedule table tools if you are placing
multiple schedule tables of specific styles that have the same properties.

1 Open the tool palette on which you want to create a tool.
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2 Create the tool:

Then…If you want to…

select the object, and drag it to the
tool palette.

create a tool from a schedule table
in the drawing

click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from a schedule table
style in the Style Manager

the style you want to copy, and
drag it to the tool palette. Click OK
to close the Style Manager.

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the palette where you want
to add the tool, right-click, and click
Paste.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

6 Expand General, and specify general properties for the schedule
table:

Then…If you want to…

enter text for Description.add a description

select Layer Key.specify the layer key

select Layer Overrides.specify layer overrides

select Style.specify the schedule table style

select Style Location or Browse to
specify a location.

specify an external drawing file
source for the style

enter a value for Scale.change the schedule table scale
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Then…If you want to…

select Yes for Update automatically.automatically update the schedule
table when data in the drawing
changes

select No for Update automatically.manually update the schedule table
when the drawing changes

NOTE Turning on the automatic update feature may slow drawing
performance, especially in large drawings. For information about
updating schedules manually, see Property Set Data on page 3810.

7 Expand Selection, and specify how to add objects to the schedule
table:

Then…If you want to…

select Yes for Add new objects
automatically.

automatically add new objects to
the schedule table as they are ad-
ded to the drawing

select No for Add new objects
automatically.

manually add new objects to the
schedule table

select Yes for Scan xrefs.include objects from xref drawings
in the schedule table

select No for Scan xrefs.exclude objects from xref drawings
in the schedule table

select Yes for Scan block references.include objects from block refer-
ences in the schedule table

select No for Scan block references.exclude objects from block refer-
ences in the schedule table

specify a layer wild card.apply a layer filter to the table
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NOTE When adding a schedule table that must scan xrefs or blocks,
use a layer filter that includes both the name of the layer that contains
the xref or block and the name of the layer of the object inside the
xref or block. You can separate multiple layer wild cards with a
comma. You cannot select individual objects within an xref drawing
or a block reference. For more information, see Working with Layer
Groups on page 733.

8 Click OK.

Adding Objects to a Schedule
Use this procedure to add objects to an existing schedule table.

1 Select the schedule.

2 Click Schedule Table tab ➤ Scheduled Objects panel ➤ Add  .

3 In the drawing, select the objects to add to the schedule, and press
ENTER.

Use a window or a crossing window to select multiple objects.
Objects that are already in the table are not added.

NOTE You cannot add objects to a schedule table through RefEdit. Although the
command appears to work during the RefEdit session, as soon as changes are
saved back, the rows disappear from the schedule table. This is because you are
actually selecting temporary copies of the objects in the file. In order to have
objects that are in an xref or block display in a schedule table, select the xref. To
include only selected objects from the xref or block, use a layer filter with the
schedule table. For more information, see Editing Style-Based Property Sets
Attached to Objects in External References on page 3818.

Removing Objects from a Schedule
Use this procedure to remove objects from a schedule table.

1 Select the schedule table.

2 Click Schedule Table tab ➤ Scheduled Objects panel ➤ Remove

 .

3 In the drawing, select the objects to remove from the table, and
press ENTER.
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Reselecting Objects for a Schedule
Use this procedure to reselect objects to include in a schedule table. After
reselection, the table contains only the newly-selected objects.

1 Select the schedule table.

2 Click Schedule Table tab ➤ Scheduled Objects panel ➤ Reselect

 .

3 In the drawing, select the objects to include in the table, and press
ENTER.

Turning Off the Out-of-Date Marker
Use this procedure if you do not want the out-of-date marker to display when
an object, object style, or attached property set data has changed but the
schedule is not updated. This appears by default.

With the out-of-date marker display component turned on in the General
schedule display representation of your drawing, a line is drawn through the
schedule to indicate that the information tracked by the schedule has changed.
For example, a line is drawn through the schedule if an object tracked in the
schedule is moved or deleted, or if its dimensions are edited. The line is
removed when you update the schedule. For more information about display
components, see Display System Structure on page 801.

Displaying an out-of-date schedule

NOTE If this display component is on, it can slow drawing performance, especially
in large drawings.

1 Select the schedule table, right-click, and click Edit Object Display.

2 Click the Display Properties tab.

3 Select the General display representation.

4 If necessary, click  .

5 Scroll to display the Out-of-Date Marker component, and click
Visible.
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6 Click OK twice.

Updating a Schedule Manually
You can update a schedule table at any time by selecting it, and clicking

Schedule Table tab ➤ Modify panel ➤ Update . This updates the values in
a schedule table when the automatic update option is turned off. Always
update schedule tables before plotting the drawings that contain them.

When you update a table manually, the table is refreshed to reflect any changes
to objects or to property set data attached to objects or object styles. Objects
added to the drawing after creating the schedule table are not included in the
table unless Add Objects Automatically is specified in the table properties. To
add objects manually, see Adding Objects to a Schedule on page 3751. To change
the numbering in a schedule table, see Renumbering Property Set Data on
page 3765. To ensure that the table contains accurate information, close and
re-open your drawing before plotting schedule tables. Certain changes to
drawings, such as reference editing, are reflected in schedule tables only when
a drawing is reopened.

NOTE You can specify that a schedule table updates automatically whenever
changes are made to data for scheduled objects. This is managed on the Properties
palette. For more information, see Changing General Schedule Properties on page
3794.

Locating and Viewing Scheduled Objects in a Drawing
Use this procedure to highlight objects in the drawing that are included in a
schedule table.

1 Select the schedule table.

2 Click Schedule Table tab ➤ Scheduled Objects panel ➤ Show
.

3 Select the border of the schedule table to show all the objects in
the table, or select a specific cell to show only the object contained
on that row.

The selected objects are highlighted in the drawing.
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Schedule Tags
Schedule tags are symbols that connect building objects with lines of data in
a schedule table. Schedule tags display data about the objects to which they
are attached. There are schedule tag tools with predefined properties provided
with the software on the Scheduling tool palette in the Document tool palette
set and in the Documentation Tool Catalog in the Content Browser. For more
information, see Tools on page 85 and Content Browser on page 129.

You can also create schedule tags to display specific property set data for objects
in the building. After you create a schedule tag, you can drag it to any tool
palette to create a schedule tag tool. For more information, see Creating a
Schedule Tag on page 3757 and Creating a Schedule Tag Tool on page 3760.

Tags in an AutoCAD Architecture Project Environment

It is recommended that you tag objects in view drawings if you are working
in a project environment. You can use one of the default project-based schedule
tags, or you can create project-specific tags that display the project information
you define. A project-based schedule tag recognizes the location of the object
(the level in the building project). A standard schedule tag does not. When
you want this additional information captured, work in a project environment
and use a project-based schedule tag. For more information about working in
AutoCAD Architecture projects, see Workflow for a Project Environment on
page 303.

Tags as Multi-View Block Definitions

Tag tools have predefined properties. Each tag is a multi-view block with
attributes. Values from the property set data of the object can be transferred
to the tag attributes if, when the tag is added, the tag attributes include the
names of the property set definition and the property definition. An example
of an attribute definition tag for a door is DoorStyles:DoorHeight. Attribute
definition tags cannot have extended names (names that contain spaces). If
you use extended names for your property set or property definitions, you
cannot display those objects automatically through the use of a tag anchor.

Because tag attributes are linked to property set data, the tag attributes change
when the property set data changes. For example, the number displayed in a
door tag associated with a door is updated when the number property of the
door is renumbered. To edit the information that displays in the tag, edit the
property set data. For more information, see Entering Manual Properties and
Fields for Objects on page 3812.
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Schedule tags are organized as multi-view block definitions under Multi-Purpose
Objects in the Style Manager. For more information, see Style Manager
Overview on page 870.

Connection Between Tags and Objects

Tags are constrained (anchored) to objects by default. This is controlled in the
properties for the tag tool. It is possible to turn on the graphic that displays
the connection between tags and objects. The Anchor Tag To Entity graphic
controls the display for tags that are not constrained to objects, and the Anchor
Extended Tag to Entity graphic controls the display for tags that are constrained
to objects. For more information, see Viewing the Connection Between Tags
and Objects on page 3764 .

Tags for Multiple Objects

Select one object at a time when using the multiple tag option in order to
control the numbering sequence of the tags. The sequence of
auto-incrementing is undefined if you use a crossing window or another
multiple selection tool.

When you use the same schedule tag tool to tag multiple objects, it ensures
that the same property set is attached to each object. When adding schedule
tags to objects in an external reference (xref), you can avoid broken links by
selecting Attach as the Reference Type instead of Overlay. For more
information, see “Reference Other Drawing Files” in AutoCAD Help.

Placement and Position of Tags

When you are tagging multiple objects, tag a single object first. The placement
of the first tag relative to the object you are tagging is used to determine the
placement of subsequent tags. Tags are positioned relative to the objects being
tagged.

■ For walls, the tag (or the end of its leader) is positioned relative to the
midpoint of the wall.

■ For spaces, the tag (or the end of its leader) is positioned relative to the
center of the geometric extents of the space.

■ For all other objects, a tag with a leader is placed with the end of the leader
at the geometric center of the object. Tags without leaders are placed at
the same distance and direction as the first tag, relative to the center of
the object.
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Adding Tags Using Schedule Tag Tools
One of the most frequent uses of annotation in a project is tagging the
individual objects. Adding schedule tags to your drawings can be done simply
and quickly with schedule tag tools that are provided with the software.

NOTE When you insert schedule tags into drawings, use the appropriate base
units for the tag to match the drawing scale properly. For more information, see
Units in Property Data Formats on page 3804.

Adding Tags to Objects
Use this procedure to add schedule tags to objects, a block reference, or a
multi-view block reference, such as equipment or furniture. You can use one
of the predefined tag tools provided with the software, or you can create a
new tool for a tag you define. For more information, see Creating a Schedule
Tag on page 3757.

If you are working in a structured project environment in AutoCAD
Architecture, project-based tags recognize additional information about the
objects if you tag objects in view drawings. There are predefined, project-based
tags provided.

1 Open the tool palette that contains the tag tool you want to use,
and select it.

Alternatively, you can click Annotate tab ➤ Scheduling panel,
and select one of the tag tools there.

Additional predefined tag tools are located in the Documentation
Catalog in the Content Browser. You can add these tools to any
tool palette.

2 Select the object to which to attach the tag.

3 Specify the location of the tag.

NOTE Different object tags may have different prompts. The steps
below may not correspond exactly to those for the object tag you
are placing.

4 If prompted, enter property set data on the Edit Property Set Data
worksheet, and click OK.
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For information about preventing the worksheet from displaying
each time you add a tag, see Turning Off the Edit Property Set
Data Worksheet on page 3757.

If property set data is not yet attached to the object, you can attach
an appropriate property set from the current drawing or the
Schedule Tables.dwg file in C:\ProgramData\Autodesk\ACA
2012\enu\Styles\<Imperial or Metric> For more information about
property sets, see Property Set Definitions on page 3823.

5 Enter m, press ENTER, and select multiple objects to tag.

6 Alternatively, press ENTER, and add schedule tags one at a time.

Turning Off the Edit Property Set Data Worksheet
Use this procedure to prevent the Edit Property Set Data worksheet from
displaying each time you add a schedule tag.

Depending on the property set definitions that are attached to the object, you
can edit or enter new property set data when this worksheet displays. This
option is turned on in the software by default. If you are adding tags that
contain only automatic properties, it is more efficient to turn off this option.

1 Click  ➤ Options.

2 Click the AEC Content tab.

3 Clear Display Edit Property Data Dialog During Tag Insertion, and
click OK.

Creating a Schedule Tag
Use this procedure to create a schedule tag that captures and displays property
set data for a particular object in your drawing.

The property set attached to the object must contain the property or properties
for the information that you want to display in the tag. For more information,
see Property Set Data on page 3810.

You can create the schedule tag by drawing a symbol and adding text as a
placeholder for attributes or by exploding and customizing an existing schedule
tag. When you create a schedule tag, each attribute is assigned a unique name
(called an attribute tag), which is formed by combining the names of the
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associated property set definition and property definition. When the schedule
tag is anchored to objects to which the property set definition applies, the tag
displays the value of the property identified by the attribute tag.

For example, you have a property set definition named DoorProps, which
contains a property definition named FireRating. The FireRating property
contains fire rating information for door objects. To create a door tag that
displays the fire rating of a door to which the tag is anchored, you must first
create a schedule tag that contains an attribute definition whose attribute tag
is DoorProps:FireRating.

1 Draw a symbol for the tag, and add text as necessary to designate
the property data you want displayed as an attribute of the tag.

Tags may have multiple attributes and be linked to multiple
property definitions.

2 Create the schedule tag:

Then…If you want to…

click Annotate tab ➤ Scheduling

panel ➤  ➤ Create Tag  .

create a schedule tag from your
custom graphic and text

Select the objects from which to
create the tag, and press ENTER.

click Home tab ➤ Modify pan-

el ➤ Explode  . Select the ob-

create a schedule tag from an exist-
ing tag

ject, and press ENTER. Repeat until
all nested blocks are exploded, and

click Annotate tab ➤ Scheduling

panel ➤  ➤ Create Tag  .
Select the objects from which to
create the tag, and press ENTER.
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3 On the Define Schedule Tag worksheet, enter a name to identify
the new tag.

4 Click  to select additional objects.

5 Select the attributes of the tag:

Then…If you want the label to…

select Property for Type, select a Property
Set and a Property Definition, and click
OK.

collect property data from
the objects tagged

select Text for Type and click OK.display as the text you
entered
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6 Specify a point on the tag as the insertion point.

Creating a Schedule Tag Tool
Use this procedure to create a schedule tag tool and add it to a tool palette.
You may want to create tools that display different information as attributes
for different types of objects.

For example, your floor plan has space allocated to specific functions. To
efficiently view the total area of space used by the different functions, you
can create a schedule tag that displays the property data of the base area of
each space. For more information, see Property Sets and Property Set
Definitions on page 3743.

1 Open the tool palette on which you want to create a tool.

2 Create the tool:

Then…If you want to…

select the schedule tag, and drag it
to the tool palette.

create a tool from a schedule tag in
the drawing

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other tool palette, right-
click the tool, and click Copy. Re-

copy a tool from another tool
palette

open the palette where you want
to add the tool, right-click, and click
Paste.

3 Right-click the new tool, and click Properties.
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4 Enter a name for the tool.

5 Click the value for Description, enter a description of the tool,
and click OK.

6 Click More Info to add keywords for the tool, and click OK.

7 Expand General, and specify general properties for the schedule
tag:

Then…If you want to…

click Type, and select Tag to identi-
fy the tool as a schedule tag, or se-

identify the type of tool

lect Property set data to specify that
the tool attaches property data
without displaying a tag. When
property set data is attached to an
object, properties display in the
schedule and on the Properties
palette without displaying a tag on
the object.
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Then…If you want to…

click the value for Property Data,
select the property set definitions,
and click OK.

attach property set data

select Property def location, and
Browse to specify a location.

specify an external drawing file
source for the property definition
location

8 If you selected Tag as the tool type, expand Tag to edit the tag
properties.

Then…If you want to…

click the value for Layer key, select
the layer key, and click OK.

specify an alternative layer key

click the value for Layer key over-
rides, select overrides, and click OK.

specify layer key overrides

click Tag name, and select the
name.

select a different name for the
schedule tag

select Tag location, and Browse to
specify a location.

specify a source file location from
which to import the property set
definition

select Yes for Constrain to object.specify that the tag moves with the
object to which it is anchored

select No for Constrain to object.specify that the tag does not move
when the object to which it is
anchored moves

select Yes for Rotate to object.specify that the rotation of the tag
is oriented to the object to which it
is anchored

select No for Rotate to object.specify that the rotation of the tag
is not oriented to the object to
which it is anchored
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9 If you selected Tag as the tool type, expand Leader to edit the
leader properties.

Then…If you want to…

click Leader type, and select None.add the schedule tag without a
leader

click Leader type, and select
Straight.

add the schedule tag using a
straight line as the leader

click Leader type, and select Spline.add the schedule tag using a spline
as the leader

10 If you selected Tag as the tool type, expand Text to edit the text
properties.

Then…If you want to…

click Attribute text style, and select
As defined by content.

add text in the schedule tag as
defined in the source drawing

click Attribute text style, and select
Target drawing text style.

add text in the schedule tag as it is
defined in the target drawing

click Attribute text angle, and select
As inserted.

determine the angle of the text
when you insert the schedule tag

click Attribute text angle, and select
Force horizontal.

consistently display the text in the
schedule tag horizontally

click Attribute text angle, and select
Right reading.

consistently display the text in the
schedule tag right justified

11 Click OK.

Anchoring an Existing Schedule Tag to an Object
Use this procedure to anchor an existing schedule tag to an object or re-anchor
a tag to a new object.

If you copy a tag from one object to another, the tag remains anchored to the
original object. Use this procedure to re-anchor the tag to the new object.
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NOTE You can view the current relationship between schedule tags and objects.
For more information, see Viewing the Connection Between Tags and Objects on
page 3764.

1 Select the tag.

2 Click Tag tab ➤ Anchor panel ➤ Set  .

3 Select an object to which to anchor the tag.

Releasing an Anchored Schedule Tag
Use this procedure to release a tag that is anchored to an object. After you
release the tag, you can anchor it to another object.

1 Select the tag.

2 Click Tag tab ➤ Anchor panel ➤ Release  .

Viewing the Connection Between Tags and Objects
Use this procedure to view the current link between a schedule tag and an
object. If you have many tags and are not sure how they are attached, it is
useful to see this link displayed. This procedure turns on the General display
representation for Anchor Tag To Entity and Anchor Extended Tag to Entity
in the current view.

1 Click Manage tab ➤ Style & Display panel ➤ Display Manager
.

2 Expand Sets.

3 Select the current display set, which appears in bold in the list
under Sets.

4 Click the Display Representation Control tab.
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5 In the Objects list, locate Anchor Tag To Entity and Anchor
Extended Tag to Entity, and select the General display
representation for both.

6 Click OK.

7 Regenerate the drawing, if necessary.

The link between the schedule tag and the object is displayed as
an arc. The tag and object are attached from insertion point to
insertion point.

Renumbering Property Set Data
Use this procedure to renumber objects that are included in a schedule or
linked to schedule tags. You may want to do this if you moved them in the
building model or if you have deleted objects. Only those property definitions
with a Type of Auto Increment—Integer can be renumbered with this
procedure. For more information, see Adding Tags Using Schedule Tag Tools
on page 3756.

1 Open the tool palette that you want to use, and select the
Renumber Data tool.

A Renumber Data tool is located with the Scheduling and
Reporting Tools in the Stock Tool Catalog. You can add this tool
to any tool palette. For more information, see Content Browser
on page 129.

2 In the Data Renumber dialog, select the property set to renumber.

You select the property set that contains the number property.
For example, if you renumber doors, you select the DoorObjects
property set.

3 Select the start number.

4 Select an increment value.

Each number in the drawing is increased by this amount in the
drawing when the property set data is renumbered. For example,
if the start number is 1 and the increment is 3, the sequence would
number 1, 4, 7, 10, and so on.

5 Select Attach New Property Set to add a new property set to the
numbering sequence.

6 Click OK.
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7 Select the object or schedule tag to which you want to assign the
new start number, continue renumbering, and press ENTER.

NOTE Under certain circumstances, such as after Renumber Data during RefEdit,
you may see duplicate property set definition names. For example, the property
set definition name may be preceded by “$1$.” Modify these property set
definitions by opening the attached drawing and making the changes. For more
information, see “Edit Selected Objects in Referenced Drawings and Blocks” in
AutoCAD Help.

Managing Schedule Tables
You can customize the content and appearance of schedule tables. You can
also export schedule table data.

IMPORTANT The contextual tab for schedule tables includes a Convert to Table
option, which creates a copy of your AutoCAD Architecture schedule table that
can be inserted as an AutoCAD® table. AutoCAD Architecture commands, such
as Update or Add All Property Sets cannot be used on the converted table. Also
be aware that you may get unexpected results if you use special characters in your
schedule headings, such as equal signs (=). Avoid this problem by adding an
apostrophe (‘) in front of the character before doing the conversion. For more
information about working with AutoCAD® tables, see “Create and Modify Tables”
in AutoCAD Help.

Using Schedule Table Styles

Schedule table styles control the content and appearance of schedule tables.
A drawing must contain a schedule table style for the type of schedule table
you want to create. When you copy a schedule table style into a drawing,
property set definitions and data formats specified in the style are also copied.
For more information, see Working with Schedule Table Styles on page 3769.

Updating Schedules

Because the property set data is attached to objects and styles, you can create
and update schedules at any stage of a project. Rather than waiting until the
end of a project to create schedules, you can create preliminary schedules and
update them to reflect changes in your drawings. For more information, see
Updating a Schedule Manually on page 3753.
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Attaching Property Set Data

Before creating schedule tables, you attach the property sets referenced in the
schedule table style to the objects and object styles. The attached property
sets become the containers for data. For more information, see Property Set
Data on page 3810.

NOTE A schedule table extracts data from objects and displays the data in the
table. No data is saved in the table itself.

Updating Property Set Data

When you add a schedule table to a drawing, you specify whether new objects
are added to the table as they are added to the drawing and whether the data
in the schedule table is updated when objects or styles are modified. If you
do not select these automatic updating options, you can update a schedule
manually at any time. For more information, see Adding Property Set Data to
All Objects on page 3801.

You can also directly edit the data in individual cells and columns for any
manual properties included in the table. After you add, remove, or change
objects in a schedule, you can renumber the objects and their schedule tags.
For more information, see Renumbering Property Set Data on page 3765.

Exporting Property Set Data

You can export data directly to external files in the following formats:

■ Microsoft® Excel spreadsheet (XLS) files (2 formats)

■ Comma-separated values (CSV) files

■ Tab-delimited text (TXT) files

For more information, see Exporting a Schedule on page 3791 and Exporting
Schedule Data for Selected Objects on page 3792.

Workflow to Customize Schedule Tables
You can specify property set definitions and property data formats to customize
the information collected from objects and how it displays in the schedule.
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You can also create schedule tables with the schedule tools that are provided.
For more information, see Basic Schedules on page 3747.

Create or modify schedule table styles on page
3769 to determine the types of objects listed in a-----

Adjust the information collected
and displayed from objects schedule table, what data is displayed, and how

the data is organized.

Identify the property set definitions on page 3823
to be listed for each object in the schedule table.

-----
Specify the object’s information to
display

Create or modify the property data format on
page 3802 to specify how data is displayed in a
schedule table.

-----
If you are not using predefined
schedule tools, modify information
to display in the schedule table

Create a new schedule table  on page 3748 or use
a predefined schedule table tool  on page 3747 to-----Add a schedule table
display construction data collected from objects
in your drawing.

Attach property set data on page 3810 to objects
on page 3811 in the drawing.

-----Add or modify object information

Changes you make to objects, styles, and object
data are reflected in the schedule table. You can-----Edit the schedule as needed
also edit on page 3799 schedule tables on page 3765
directly.
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Working with Schedule Table Styles
Schedule table styles determine the content and appearance of schedule tables
you add to drawings. You can customize a schedule table by adding headings,
organizing columns, or specifying the sort order. The schedule table tools
provided with the software have predefined styles and properties. You can
customize these styles or create new ones.

Content and Format of Schedule Tables

Use schedule table styles to specify the following characteristics of schedule
tables:

■ Objects that can be included

■ Property data to be tracked

■ Sequence and format of columns

■ Property data format of schedule values

■ Format of table titles, column headers, and table cells

■ Sorting sequence of rows

■ Display properties of tables

Flagging Out-of-Date Schedules

In a schedule table style, you can specify whether a schedule is updated when
objects included in the schedule change. If you turn off the automatic update
option, you can still determine whether data in the schedule reflects changes
in the drawing. The display properties of the schedule style include an
out-of-date marker. When this marker is turned on, a diagonal slash is drawn
through the table when the schedule has not been updated. Updating the
schedule removes the out-of-date marker.

NOTE You should always update your schedules before plotting and not rely
completely on the out-of-date-marker.
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What You Need to Create a Schedule Table Style

Your drawings must contain the following information for you to create a
new schedule table style:

■ Property set definitions for any property data to be included in the tables
created from the style. Each column in a schedule table corresponds to
one property in a property set for an object or an object style. For more
information, see Property Set Definitions on page 3823.

■ Property data formats to control the format of values in each column of
a schedule table. Typically, you use the same data format specified in
property set definitions. However, you can override those formats in the
schedule table style. For more information, see Property Data Formats on
page 3802.

The content and tools include schedule table styles for typical schedules, such
as door and window schedules or room finish schedules. You can customize
these styles for your projects.

Creating Styles for Matrix Schedules

In AutoCAD Architecture, a matrix schedule is a table in which column
headings identify object properties. A symbol, such as a dot or a cross, is
displayed in cells to indicate that an object has the property identified. Matrix
schedules are also called dot schedules.

You can define schedule table styles to include matrix columns for specific
properties. In addition, you can control the following characteristics of matrix
schedules or matrix columns in regular schedules:

■ The symbol used in each cell containing the property listed in the column
header

■ The maximum number of columns for each matrix property. If the unique
property values in the column exceed this maximum number, the column
is displayed as a normal column.

If the property data displayed in a matrix column is a string containing a
semicolon-delimited list of values, each value in the list will be displayed
separately. You can use this format to assign multiple values to the same
property, such as multiple floor materials in the same space.
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Creating Tools from Schedule Table Styles

You can create a schedule table tool from a schedule table style by dragging
the style from the Style Manager onto a tool palette. You can then specify
settings for the tool properties. For more information, see Creating a Schedule
Table Tool on page 3748.

Managing Schedule Table Styles

To create, edit, copy, or purge schedule table styles, you access the Style
Manager. The Style Manager provides a central location for working with
styles from multiple drawings and templates. For more information, see Style
Manager Overview on page 870.

Creating a Schedule Table Style
Use this procedure to create a schedule table style. You can either use the
default style properties or copy an existing style and then customize the
properties. After creating the style, you can create a schedule table tool, and
use the tool to add the schedule to your drawing. For more information, see
Adding Schedules Using Schedule Table Tools on page 3747.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Schedule Table
Styles.

3 Create a new schedule table style:

Then…If you want to…

right-click Schedule Table Styles,
and click New.

create a style with default properties

right-click the schedule table style
you want to copy, and click Copy.
Right-click, and click Paste.

create a style from an existing style

4 Enter a name for the new style, and press ENTER.

5 Click the General tab, and enter a description.
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6 Edit the options for the new schedule table style:

Then…If you want to…

see Specifying the Default Format of a
Schedule Table Style on page 3773.

change the default format for
the style

see Specifying Objects for a Schedule
Table Style on page 3774.

specify the objects to be tracked
in schedules using this style

see Filtering Scheduled Objects by
Classification in a Schedule Table Style
on page 3776.

use classifications to filter the
objects in a schedule

see Adding Columns to a Schedule on
page 3777.

add columns for properties to
be reported for tracked objects

see Including a Formula Column in a
Schedule Table on page 3781.

add formula columns to display
calculations

see Spanning Schedule Table Columns
with a Heading on page 3784.

add headings that span
columns

see Editing Columns in a Schedule
Table on page 3785.

edit column placement settings
and formats for column data

see Specifying the Sort Order in a
Schedule Table Style on page 3787.

specify the sort order of rows

see Specifying Title Formats in a
Schedule Table Style on page 3788.

specify the formats of the table
title, column headings, and
matrix column headings

see Specifying Display Properties in a
Schedule Table Style on page 3789.

specify visibility, layer, linetype,
and other display properties

see Attaching Notes and Files to a
Schedule Table Style on page 3790.

enter notes and attach, edit, or
delete reference files

7 Click OK.
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Specifying the Default Format of a Schedule Table Style
Use this procedure to specify the default text format and placement for table
columns and their contents. You can also specify the default symbol used in
matrix schedules and for true/false values in regular schedules.

If necessary, you can override these settings for individual columns and table
titles.

NOTE Most schedule table styles provided by AutoCAD Architecture have overrides
applied to their titles and column headers. You can access these settings on the
Layout tab in the Schedule Table Style Properties dialog.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Schedule Table
Styles.

3 Select the schedule table style that you want to change.

4 Click the Default Format tab.

5 For Text Appearance, specify the following:

■ For Style, select an AutoCAD® text style already defined in the
drawing. To use a font other than those available from the
drop-down list, you must first define an AutoCAD text style
that uses the font. For more information, see “Overview of
Text Styles” in AutoCAD Help.
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■ For Alignment, select positioning for the text. For more
information about aligning text using the Multiline Text
Editor, see “Justify Multiline Text” in AutoCAD Help.

■ For Height, enter the text height that you want. Height is
normally specified as the size you want to use when plotting
the drawing containing the schedule.

■ For Gap, enter the space between the text and the schedule
table lines that you want. Gap is normally specified as the size
you want to use when plotting the drawing containing the
schedule table.

■ For Rotation, select the desired orientation for text within
cells. For the table title and group titles, Rotation also controls
the orientation of these cells relative to the rest of the table.

6 Select a symbol (Check, Dot, Cross, or Slash) for use in matrix
columns and, optionally, for true/false values.

7 Select or clear Use for True/False to control whether matrix
symbols or the text in the property data format is used for
true/false values.

8 Enter a fixed width for all columns, or enter 0.0 if you want
columns to adjust to fit the data within them.

Fixed Width is normally specified as the size you want to use
when plotting the drawing containing the schedule table.

NOTE Cell Size Height is a read-only field. Its value is calculated from
the Height and Gap values.

9 Click OK.

Specifying Objects for a Schedule Table Style
Use this procedure to specify which objects to track in schedules created from
a schedule table style. You can specify more than one object type. For example,
you can create a schedule table style for windows that tracks both individual
windows and window assemblies.

The property sets must apply to all object types specified in the style. For
example, in a schedule table style for windows and window assemblies, the
window assembly styles property set is not available because it does not apply
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to windows. In addition, limiting the number of object types in a schedule
table style improves drawing performance.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Schedule Table
Styles.

3 Select the schedule table style that you want to change.

4 Click the Applies To tab.

5 Select the object types to be tracked for schedule tables using this
style.

You can select any objects on the list. The area above the list
displays the objects that are currently selected. If you click Select
All or Clear All, you can include any object in this schedule table
style.

The right pane lists all classification definitions that apply to any
of the selected object types. You can select multiple classifications
in multiple classification definitions. If classifications are selected,
schedule tables of this style can include objects selected on the
left only if they have been classified with the selected
classifications. For more information, see Classification Definitions
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on page 3872 and Filtering Scheduled Objects by Classification in
a Schedule Table Style on page 3776.

6 Click OK.

Filtering Scheduled Objects by Classification in a Schedule Table
Style

Use this procedure to specify the classification criteria that an object must
satisfy to be included in schedules created from a schedule table style. You
can specify more than one classification for an object type.

For example, if you want to schedule only doors with a New construction
classification and a vendor with preferred classification, you can specify those
criteria in the schedule table style. Only doors that meet both criteria can be
included in the schedule table. For more information, see A Classification Use
Case on page 3874.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Schedule Table
Styles.

3 Select the schedule table style that you want to change.

4 Click the Applies To tab, and select the object types to be tracked
for schedule tables using this style.

5 To specify classification criteria, expand a classification definition,
and select one or more classifications.

For example, you can select a construction classification of New
and 2 preferred vendors. For an object to be included in schedules
of this style, its object style must specify New for the construction
classification, and the classification for Vendor must be 1 of the
2 vendors selected.
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Specifying multiple classification criteria in a schedule table style

6 Click OK.

Adding Columns to a Schedule
Use this procedure to add columns for each property to be reported in schedule
tables created from a schedule table style.

Each column contains the values for one property in a property set. The
property set definitions for the properties you specify must exist in the drawing
before you can create columns for them. For more information, see Property
Set Definitions on page 3823.

You must also specify the objects that the schedule table style applies to before
you add columns. For more information, see Specifying Objects for a Schedule
Table Style on page 3774.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Schedule Table
Styles.

3 Select the schedule table style that you want to change.

4 Click the Columns tab.

5 Click Add Column to add a column to the right of the last column.
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The Add Column worksheet opens.

6 Select the property to track for the new column from the pane
on the left.

Properties that have already been designated for another column
are unavailable in the properties list.
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7 Enter the heading for the column.

The property description is the default text for the column header.

8 Select the property data format, or use the default format from
the property set definition.

The data format selected here takes precedence if it does not match
the format specified in the property set definition for this property,
and any formatted value stored in the property set definition is
converted to display in the data format selected for this column.
For more information, see Property Data Formats on page 3802.

9 Specify additional settings for the column:

Then…If you want to…

click Override Cell Format, and
specify format settings that apply
only to data cells in this column.

specify a format and orientation for
cells in this column
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Then…If you want to…

click Override Header Format, and
specify format settings that apply
only to data cells in this column.

specify a format and orientation for
the column heading

select Matrix, and enter the maxim-
um number of columns used to re-

use a matrix format for the values
in the column

port the values for the selected
property.

select Total.report a total value from all the val-
ues in this column

select Hide.hide the column from view in the
drawing

When you edit property data to be displayed in a matrix column,
you can assign multiple values by using a text data type and
separating the values with semicolons. Each value is displayed in
a separate column in the matrix column.

10 Specify the placement of the new column relative to existing
columns.

You can change the location of a column by dragging it to a new
location in the schedule table. For more information, see Editing
Columns in a Schedule Table on page 3785

11 Click OK twice.

Including a Quantity Column in a Schedule
Use this procedure to include a quantity column in schedules created from a
schedule table style. If you include a quantity column, the objects in the table
with the same values in every column are displayed in one row, with the
number of objects displayed in the Quantity column. Quantity columns are
inserted as the first column in the schedule table by default. For more
information, see Adding Columns to a Schedule on page 3777. For information
about repositioning quantity columns, see Editing Columns in a Schedule
Table on page 3785.
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Include Quantity Column must be selected if you want to use quantities in a
formula column. For more information, see Including a Formula Column in
a Schedule Table on page 3781.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Schedule Table
Styles.

3 Select the schedule table style that you want to change.

4 Click the Columns tab, and select Include Quantity Column.

The Quantity column is inserted as the first column in your
schedule table style.

5 Click OK.

Repeating the First Column of a Schedule
Use this procedure to insert a copy of the first column in a schedule as the
last column in the schedule table style. This is helpful if you have a very wide
schedule table, and you want the information in the first column repeated at
the end for ease of use. For more information, see Adding Columns to a
Schedule on page 3777.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Schedule Table
Styles.

3 Select the schedule table style that you want to change.

4 Click the Columns tab, and select Repeat First Column.

5 Click OK.

Including a Formula Column in a Schedule Table
Use this procedure to include a formula column in schedules created from a
schedule table style. Property definitions in the formula dialog are limited to
the objects or styles to which the schedule table applies. For more information,
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see Adding Columns to a Schedule on page 3777 and Understanding Formulas
on page 3830.

Use the formula column to create an expression based on the quantity or any
other property set definition included in the schedule table style. For example,
you can use a formula column to multiply a unit cost for an object by the
number of objects to get a total cost. For more information, see Understanding
Formulas on page 3830.

NOTE There is no conversion made between units for a formula result.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Schedule Table
Styles.

3 Select the schedule table style that you want to change.

4 Click the Columns tab, and click Include Quantity Column if you
want to insert quantities in your formula column.

5 Click Add Formula Column.

6 On the Add Formula Column worksheet, specify properties for
the formula:

Then…If you want to…

enter text for Heading.identify the formula column with a
heading

select a data format.specify a data format for the for-
mula result

click Override Cell Format, and
specify format settings that apply
only to data cells in this column.

change the format and orientation
for cells in the column

click Override Header Format, and
specify format settings that apply
only to data cells in this column.

change the format and orientation
for the column heading

select Total.report a total value from all the val-
ues in this column
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Then…If you want to…

select Hide.hide the column from view in the
drawing

click Apply Formula to Total.create a formula that calculates a
total using property data from all
columns

NOTE Hiding a column does not change the data displayed in it or
any other column in the table. It only affects the display of the data.

7 Enter the formula:

Then…If you want to…

click in the Formula pane, and enter
the value.

use a value that you supply

locate and double-click (or right-
click and click Insert) the definition

use the value of another property
definition in the formula

in the Insert Property Definitions
list. You can also select the defini-
tion, and press INSERT.

locate and double-click (or right-
click and click Insert) the function

use a VBScript function

in the Insert VBScript code list. You
can also select the function, and
press INSERT.

enter RESULT anywhere in the for-
mula.

evaluate the formula as a VBScript
function

The property definitions available for use in the formula must be
applied to the same objects as the property set definition
containing the formula.

The names of property definitions used in the formula are
displayed within brackets, such as [Width]. If a property definition
belongs to a property set definition other than the one containing
the formula, that name is displayed as well, such as
[DoorObjects:Height].
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The formula property definition cannot be used in the formula

it defines, as indicated by the  and the addition of [Self] after
its name. Property definitions that end up using the value of the

formula cannot be used in the formula, as indicated by the 
and the addition of [Circular Reference] after their names.

NOTE If you enter the name of a property definition directly in the
formula string, or copy and paste between formulas, the property
definition is displayed as normal text. For property values of property
definitions to be inserted correctly, they must be selected from the
list in the Insert Property Definitions pane.

For more information, see Adding a Formula Property Definition
to a Property Set Definition on page 3830 and Use Case for the
Formula Property Definition Worksheet on page 3835.

8 Enter a value in the Enter Sample Values pane.

The property value you enter displays in the current format
specified.

9 Select a property data format to specify how the property value
is formatted in the formula.

The format you select becomes the default format in a formula
when this property is added to a schedule table style. It can be
changed at any time. The Example column on the Definition tab
shows how the default value is displayed using the selected format.
For more information, see Property Data Formats on page 3802.

10 Click OK.

Spanning Schedule Table Columns with a Heading
Use this procedure to add a heading that spans multiple adjacent columns in
a schedule table style. For example, you can create a Hardware heading to
span the columns for hinges, handles, and locks in a door schedule.

You can also remove a heading that spans multiple columns.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.
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2 Expand Documentation Objects, and expand Schedule Table
Styles.

3 Select the schedule table style that you want to change.

4 Click the Columns tab.

5 Select the first column you want to include under a heading, and
press CTRL while you select the other columns.

Columns must be adjacent.

6 Click Add Header.

7 Enter a title for the heading, and press ENTER.

8 To remove a heading, select it, and click Delete.

9 Click OK twice.

Editing Columns in a Schedule Table
Use this procedure to change placement and formats for columns in schedule
tables created from a schedule table style. You can also delete a column. When
you modify columns within a schedule table style, changes apply to all
schedule tables of the same style and override the default format settings.

To change the format of all column headings, see Specifying Title Formats in
a Schedule Table Style on page 3788.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Schedule Table
Styles.

3 Select the schedule table style that you want to change.

4 Click the Columns tab.

5 Select a column, and click Modify.

6 Specify properties for the column:

Then…If you want to…

enter the new column heading for
Heading.

change the column heading
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Then…If you want to…

click Override Cell Format, and
specify format settings that apply
only to data cells in this column.

change the format and orientation
for cells in the column

click Override Header Format, and
specify format settings that apply
only to data cells in this column.

change the format and orientation
for the column heading

select Matrix, and enter the maxim-
um number of columns used to re-

use a matrix format for the values
in this column

port the values for the selected
property.

select Total.report a total value from all the val-
ues in this column

select Hide.hide the column from view in the
drawing

NOTE Hiding a column does not change the data displayed in it or
any other column in the table. It only affects the display of the data.

7 Click OK.

8 Change the order of columns:

Then…If you want to…

select the column heading, and
drag the column to a new location.

move an individual column

select the common heading, and
drag the column group to a new
location.

move a group of columns that have
a common heading that spans the
columns

select the heading for the column
group, and click Delete. Hold down

remove a column from a column
group

SHIFT or CTRL to select multiple
columns. In the Remove
Columns/Headers dialog, select the
columns or headers to be deleted,
and click OK.
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Then…If you want to…

Select the columns to include in the
column group, and click Add

add a column in a column group

Header. Hold down SHIFT or CTRL
to select multiple columns. In the
Add Header dialog, enter the
heading name. If you want to
change the header format, click
Override Header Format. For more
information, see Specifying Title
Formats in a Schedule Table Style
on page 3788.

9 To delete a column, select the column, and click Delete.

10 To use a different property in a column, delete the column, and
add a new column with the property you want to use.

11 Click OK.

NOTE Property data format styles, property set definitions, and schedule table
styles cannot be changed through RefEdit. Changes seem to work, but will revert
to the previous settings when saved back to the xref file. Open the xref drawing
directly, and make the changes there.

Specifying the Sort Order in a Schedule Table Style
Use this procedure to specify the sort order of rows in a schedule table style.
You can sort rows in ascending or descending order of the values in one or
more columns.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Schedule Table
Styles.

3 Select the schedule table style that you want to change.

4 Click the Sorting tab.
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5 Specify the sort order of the rows:

Then…If you want to…

click Add, select a property to sort
by, and click OK. The Select Prop-

add a property to sort by

erty dialog lists all properties
defined on the Columns tab but not
already selected for sorting.

select the property, and select As-
cending or Descending for Sort Or-
der.

specify the sorting method for a
property

select the property, and click Re-
move.

remove a property from the sorting
list

select the property, and click Move
Up or Move Down, as needed.

change the location of a property
in the sort order

6 Click OK.

Specifying Title Formats in a Schedule Table Style
Use this procedure to enter the title of a schedule table, and to specify the
formats of the table title, column headings, and matrix column headings. The
formats that you specify in this procedure for regular and matrix column
headings override the default format settings. Value overrides display in red
in the Cell Format Override dialog.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Schedule Table
Styles.

3 Select the schedule table style that you want to change.

4 Click the Layout tab.

5 Enter the title of the schedule table for Table Title.

6 Select Override Cell Format next to the type of title format you
want to change.

7 In the Cell Format Override dialog, select a text style.
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For Style, select an AutoCAD® text style already defined in the
drawing. To use a font other than those available from the
drop-down list, you must first define an AutoCAD text style that
uses the font. For more information, see “Overview of Text Styles”
in AutoCAD Help.

8 For Alignment, select positioning for the text. For more
information about aligning text using the Multiline Text Editor,
see “Justify Multiline Text” in AutoCAD Help.

9 For Height, enter the text height that you want. Height is normally
specified as the size you want to use when plotting the drawing
containing the schedule table.

10 For Gap, enter the space between the text and the schedule table
lines that you want. Gap is normally specified as the size you want
to use when plotting the drawing containing the schedule table.

11 For Rotation, select the desired orientation for text within cells.
For the table title and group titles, Rotation also controls the
orientation of these cells relative to the rest of the table.

For the table title and group titles, this option also controls the
location of the cell relative to the rest of the table.

NOTE Cell Size Height is a read-only field. Its value is calculated from
the Height and Gap values.

12 Click OK.

13 To remove an override, clear the check box next to the title format
you want to restore to the default format.

14 Click OK.

Specifying Display Properties in a Schedule Table Style
Use this procedure to change the following properties of the display
components in a schedule table style:

■ Visibility (display component is on or off)

■ Layer

■ Color

■ Linetype

■ Lineweight
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■ Linetype scale

You can specify display properties for the table outer frame, lines between
rows and columns, the table title, column headers, and the data in table cells.

You can also turn on an out-of-date marker that indicates when the data in
a schedule table created from the schedule table style does not show the latest
changes. This component is turned off by default. Turning it on can slow
drawing performance, especially in large drawings.

1 Select the schedule table style you want to change, right-click,
and click Edit Object Display.

2 Click the Display Properties tab.

3 Select the display representation on which to display the changes,
and select Style Override.

The display representation in bold is the current display
representation.

4 If necessary, click  .

5 On the Layer/Color/Linetype tab, select the component to change,
and select a different setting for the property.

Use Data Major Row Lines for every fifth row and Data Minor
Row Lines for all other rows to control the display properties for
lines separating each row of data. This is useful for long schedule
tables.

6 Click OK twice.

Attaching Notes and Files to a Schedule Table Style
Use this procedure to enter notes and attach reference files to a schedule table
style. You can also edit notes and edit or detach reference files from a schedule
table style.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Schedule Table
Styles.

3 Select the schedule table style that you want to change.
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4 Click the General tab.

5 Click Notes.

6 To add a note, click the Notes tab, and enter the note.

7 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

8 Click OK.

Exporting a Schedule
Use this procedure to export the contents of a schedule table to a separate file.
You can export the data in the following file formats:

■ Microsoft® Excel spreadsheet (XLS) files (2 formats)

■ Comma-separated values (CSV) files

■ Tab-delimited text (TXT) files

NOTE You must have Microsoft Excel installed to export a file to Excel format.

1 Open the drawing file that includes the table you want to export.

2 Select the schedule table.

3 Click Schedule Table tab ➤ Modify panel ➤ Export  .

The Export Schedule Table dialog opens.

4 Select a file type to Save As.

5 Enter a name for the file, or click Browse to select a file, and click
OK.
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The Format dialog opens if you selected an XLS file type for Save
As Type.

6 Convert the schedule values in the exported file by selecting Use
Unformatted Decimal Value or Convert to Formatted Text.

The format of values does not change in the drawing file. Selecting
Convert to Formatted Text displays the architectural format (6'-0")
in Microsoft Excel.

7 Click OK to format columns one at a time, or select Apply to All
Columns, and click OK.

If a file already exists with the name you specified, a warning is displayed.
Overwrite the existing file, specify a unique name, or cancel the export
command.

Exporting Schedule Data for Selected Objects
Use this procedure to export selected property set data from a schedule table
to a separate file. You can export the data in the following file formats:

■ Microsoft® Excel spreadsheet (XLS) files (2 formats)

■ Comma-separated values (CSV) files

■ Tab-delimited text (TXT) files

NOTE You must have Microsoft Excel installed to export a file to Excel format.

Using this procedure, you can create a file with property set data for selected
objects even if the schedule table does not exist in the drawing. To export all
the data in a schedule table, see Exporting a Schedule on page 3791.

1 On the command line enter AecScheduleExport.

The Export Schedule Table dialog opens.

2 Select a file type to Save As.

3 Enter a name for the file, or click Browse to select a file.

4 Clear Use Existing Table.

5 Select the table style to use in the exported file.

Columns included in the schedule table style determine the
property set data that is exported for the objects. For more
information, see Creating a Schedule Table Style on page 3771.
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6 Select the layer wild card to use as a filter in the exported file.

7 Specify whether to scan for xrefs or block references, and click
OK.

8 Select the objects to include in the exported table, and press ENTER.

The Format dialog opens if you selected an XLS file type for Save
As Type.

9 Convert the schedule values in the exported file by selecting Use
Unformatted Decimal Value or Convert to Formatted Text.

The format of values does not change in the drawing file. Selecting
Convert to Formatted Text displays the architectural format (6'-0")
in Microsoft Excel.

10 Click OK to format columns one at a time, or select Apply to All
Columns, and click OK.

If a file already exists with the name you specified, a warning is displayed.
Overwrite the existing file, specify a unique name, or cancel the export
command.

Specifying the Display Properties of a Schedule
Use this procedure to change the following properties of display components
for a schedule table:

■ Visibility (display component is on or off)

■ Layer

■ Color

■ Linetype

■ Lineweight

■ Linetype scale

To change these display properties for all schedule tables of the same style,
and to see additional information about schedule table style display
components, see Specifying Display Properties in a Schedule Table Style on
page 3789.

1 Select the schedule table you want to change, right-click, and click
Edit Object Display.

2 Click the Display Properties tab.
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3 Select the display representation on which to display the changes,
and select Style Override.

The display representation in bold is the current one.

4 If necessary, click  .

5 Click the Layer/Color/Linetype tab.

6 Select the component to change, and select a different setting for
the property.

7 Click OK twice.

Changing General Schedule Properties
Use this procedure to change general properties of basic schedule table settings
for a specific schedule table on the Design tab of the Properties palette.

1 Double-click the schedule table you want to change.

2 On the Properties palette, expand Basic, and expand General.

3 Specify general properties for the schedule table:

Then…If you want to…

enter text for Description.change the description

click Layer, and select a layer from
the drop-down list.

change the layer

click Style, and select a style from
the drop-down list.

change the schedule table style

click Title, and enter new text for
Title.

change the schedule title

click Scale, and enter a value for
Scale.

change the schedule table scale

select Yes for Update automatically.automatically update the schedule
table when data in the drawing
changes

select No for Update automatically.manually update the schedule table
when the drawing changes

3794 | Chapter 50   Schedules and Display Themes



NOTE Turning on the automatic update feature may slow drawing
performance, especially in large drawings. For information about
updating schedules manually, see Updating a Schedule Manually on
page 3753.

Changing the Selection Criteria for a Schedule
Use this procedure to change how objects are added to the schedule table.

1 Double-click the schedule table you want to change.

2 On the Properties palette, expand Basic, and expand Selection.

3 Change how objects are added to the schedule table:

Then…If you want to…

select Yes for Add new objects
automatically.

automatically add new objects to
the schedule table as they are ad-
ded to the drawing

select No for Add new objects
automatically.

manually add new objects to the
schedule table

select Yes for Scan xrefs.include objects from xref drawings
in the schedule table

select No for Scan xrefs.exclude objects from xref drawings
in the schedule table

select Yes for Scan block references.include objects from block refer-
ences in the schedule table

select No for Scan block references.exclude objects from block refer-
ences in the schedule table

specify a layer wild card.apply a layer filter to the table

NOTE When adding a schedule table that must scan xrefs or blocks,
use a layer filter that includes both the name of the layer that contains
the xref or block, and the name of the layer of the object inside the
xref or block. You can separate multiple layer wild cards with a
comma.
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Changing the Location of a Schedule Using Grips
Use this procedure to relocate a schedule table using the Location grip. For
schedule tables, the Location grip is restricted to movement in the XY plane.
You can enter specific values for distance for both the X and Y dimensions.

You can also change the location of a schedule table using the Properties
palette.

1 Select the schedule table you want to change.

2 Select the Location grip.

3 Move the schedule table to the desired location, and click; or enter
a value, and press ENTER.

If you want to enter a specific value for the second direction in
any edit mode (for example, in the Y direction when editing along
the XY plane), press TAB to cycle to the second direction.

You can also lock the movement of the schedule table along a
specific direction. If you enter a value for either of the dimension
directions in the current edit mode and then press TAB, the
movement of the schedule table is constrained to the second
dimension direction. When editing along the XY plane, for
example, you can enter a value for the X dimension, and then
press TAB. The X dimension is locked at that value, and movement
of the schedule table is constrained to the Y dimension direction.

4 Right-click, and click Deselect All to turn off grips.

Changing External Source Properties of a Schedule
Use this procedure to create a schedule table that contains property data from
an external drawing such as a project drawing.

Schedule tables can contain information from external references and block
references if it exists in the same drawing as the schedule table. Optionally,
schedule tables can specify an external drawing. The information is scheduled
as if it were an external reference in the same drawing as the table. The
advantage is that the graphics of the external drawing do not need to be
generated in order to fill out the data in the table.

1 Double-click the schedule table you want to change.

2 On the Properties palette, expand Advanced, and expand External
Source.
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3 Specify the external drawing you want to schedule:

Then…If you want to…

select Yes for Schedule external
drawing. The External drawing
property is displayed.

schedule an external drawing

select No for Schedule external
drawing. The External drawing
property is hidden.

not schedule an external drawing

click the value for External drawing,
select a drawing, or click Browse,

specify the external drawing to
schedule

and in the Select a drawing file dia-
log, browse to select a drawing,
and click OK.

The External drawing property is displayed with a drop-down list
containing all drawings in the View directory of the current
project. Each drawing corresponds to a view defined in the project.
If no project is active, the list contains all drawings in the last
directory browsed.

TIP If you want to schedule the entire project, you can set up one
drawing as a container file, and xref in all project drawings. Then
select the name of this drawing for the external drawing source.

Adding Table Breaks to a Schedule
Use this procedure to split long tables into a series of shorter pages.

1 Double-click the schedule table you want to change.

2 On the Properties palette, expand Advanced, and expand Table
Breaks.

3 Specify how you want to display the pages of tables:

Then…If you want to…

select Right for Direction.display pages horizontally to the
right of one another
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Then…If you want to…

select Down for Direction.display pages vertically below one
another

select Yes for Repeat title.display the title on each page

select Yes for Repeat Headers.display the column headers on each
page

select No for Repeat Headers.hide the column headers on each
page

select Yes for Manual heights.control the height of each page in-
dividually

select No for Manual heights.have all pages approximately the
same height

enter a value for Maximum height,
or select and drag the Maximum

specify the maximum height of
each page when Manual heights is
No Page Height grip at the bottom of

the table.

enter a value for Spacing.specify the distance between each
page

You can control the height of all pages by setting one value if
Manual heights is set to No. If the table contains more than one
object, select and drag the Maximum Page Height grip at the
bottom of the table.

You can control the height of each page individually if Manual
heights is set to Yes. If the table contains more than one object,
it will have one Insert Page grip at the bottom of the last page
and one Page Height grip at the bottom of all other pages. Select
the Insert Page grip, and drag it up to insert a new page. Select a
Page Height grip, and drag it up or down to set the height of that
page. Continuing to drag a Page Height grip down reduces the
height of the last page, and could possibly remove it.
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Adding Documentation Information to a Schedule
Use this procedure to add hyperlinks, notes, and reference documents to the
schedule table.

1 Double-click the schedule table to which to add documentation.

2 On the Properties palette, expand Documentation.

3 Specify documentation information:

Then…If you want to…

click  . Select the file, and click
Open.

add a hyperlink

click  , and enter text.
edit notes

click  . Click Add, and select a
file. Click Open, and click OK.

change an attached reference doc-
ument

click  . Select the document,
right-click, and click Edit. Select a

edit the reference document at-
tached

new document, click Open, and
click OK.

click  . Select the description,
enter the new description, and click
OK.

edit the description of a reference
file

click  . Select the file name, and
click Remove.

detach a reference file

Editing Table Cell Data
Use this procedure to highlight scheduled objects in a drawing and edit manual
property set data in a schedule table.

Automatic property set data cannot be edited in a schedule table. You must
edit the object, style, or other data to change the values of automatic property
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data. For more information about property set data, see Property Set Data on
page 3810.

You can use this procedure to troubleshoot problems between a table cell and
a source object. If the object is not currently visible in your drawing area, press
CTRL while selecting the cell to zoom to display the source object. The changes
you make to the manual property set data in the table cell are saved with the
object. If the schedule table cell references several objects in a quantity cell,
making your selection while pressing CTRL displays an area that includes all
the source objects. Holding the cursor over a quantity cell highlights the
objects counted by that cell.

If you are working in a table that schedules a drawing from an external source,
you cannot edit table cells.

1 Select the schedule table.

2 Click Schedule Table tab ➤ Modify panel ➤ Edit Table Cell  .

3 Position the cursor over the cell.

The source object is highlighted if it is visible. A tooltip is
displayed regardless of whether the cell can be edited, what type
of data is presented in the table cell, or any potential problems
with the data in that cell.

Viewing tooltips for editing table cell objects

An external reference icon is displayed if the cell data is from an
object in an externally referenced drawing. If you edit this cell,
the externally referenced drawing is modified. If the drawing is
locked by another user, you cannot edit it.
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4 Identify the different views:

Then…If you want to…

press CTRL, and select the data in
the schedule table cell. The drawing

view all source objects associated
with the schedule table cell

changes to show the source objects
associated with the cell.

click Zoom Previous.restore the previous view

5 Edit the data in the schedule table:

Then…If you want to…

select the individual cell, and enter
a new value on the Edit Referenced
Property Set Data worksheet.

edit the value in an individual table
cell

select the border of the schedule
table, and enter a value for the se-

edit the value for all instances of a
property

lected property on the Edit Refer-
enced Property Set Data worksheet.

NOTE Cells that display property set data attached to styles may affect multiple
objects. Editing one cell changes the value for all objects of that style in the
schedule table.

Adding Property Set Data to All Objects
Use this procedure to add property set data to all objects for which a question
mark (?) in a schedule table cell is displayed. This symbol indicates that the
property set containing that required property data has not been attached to
the object. You can attach these property sets individually, as described in
Editing Table Cell Data on page 3799, or you can attach the property sets to all
of the objects at once.

1 Select the schedule table.

2 Click Schedule Table tab ➤ Modify panel ➤ Add All Property Sets

 .
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NOTE If you are working in a table that schedules an external
drawing, you cannot add property sets to those objects. For more
information, see Changing External Source Properties of a Schedule
on page 3796.

Property Data Formats
Property data formats are style-based documentation objects that control how
data is displayed in schedule tables, schedule tags, the Edit Property Set Data
worksheet, and on the Properties palette. Property data formats are created
and modified using the Style Manager. For information about overriding a
format, see Units in Property Data Formats on page 3804.

Data Types

Each property data format contains separate settings for formatting each of
the following data types:

■ Text

■ True/False values

■ Integers

■ Real numbers

When you apply a data format to schedule data, the value for each property
is displayed using the specified settings for that property’s data type. For
example, the same schedule data format can specify that a dimension value
uses the real number settings, while a remark uses the settings for text.
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Using Different Data Formats

You can specify different data formats for the same property in property set
definitions, schedule table styles, and schedule tags. This enables you to display
the same value differently in different contexts. For example, you may want
to use a data format with greater precision for real numbers in a property set,
and display fewer digits in a schedule table.

Managing Data Formats

To create, edit, copy, or purge data formats, you access the Style Manager. The
Style Manager provides a central location for working with data formats from
multiple drawings and templates. For more information, see Style Manager
Overview on page 870.

Applying Property Data Formats
Property data is retrieved from an object as raw, unformatted values. Property
set definitions, schedule table styles, schedule tags, and the Properties palette
use data formats to display property data as formatted values. The Edit Property
Set Data worksheet uses the data formats from property set definitions to
format values.
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You typically apply the same data format to similar properties and then select
a data format that is appropriate for each property, such as the width, height,
and thickness of a door. The software includes several default data formats.
You can customize one of these, or you can create new data formats, to display
units in a specific manner. For example, when you want to show the length
of a wall in feet, you can select Length for Type, Feet for Units, and
Architectural for Format. Real numbers for costing properties, however, require
a monetary format. You can create different property data formats for these
situations.

The data formats available for property set definitions, schedule table styles,
and tags are those stored in the current drawing. When you copy property set
definitions or schedule table styles into a drawing, data formats used in the
definitions and styles are also copied into the drawing.

If you modify a data format, the display of the property data is affected in any
property set, schedule table, or schedule tag that uses the format.

Units in Property Data Formats
Property data formats control how units display in schedule tables, schedule
tags, the Edit Property Set Data worksheet, and on the Properties palette. Units
behave differently with real numbers in manual properties than they do with
automatic properties. For more information, see Applying Property Data
Formats on page 3803.

Units for Automatic Properties

Units for automatic properties are collected directly from the objects. An
automatic property, such as width, uses the units specified on the Units tab
in the Drawing Setup dialog by default. Using different property data formats
allows you to override the default format.

When you use a property data format, the AutoCAD units are converted to
display as defined in the property data format. You can specify a property data
format on the Definition tab of a property set definition.

Units for Manual Properties

Units specified for manual properties in the property set definition control
what is stored in the drawing. The Extended Data tab of the Properties palette
displays the units as defined in the property data format. When the type of
unit is Real, you can select a format and type of unit in the property set
definition to override the property data format when entering units. For more
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information, see Adding a Manual Property Definition to a Property Set
Definition on page 3845.

Creating a Property Data Format
Use this procedure to create a property data format. You can create a format
using default properties or by copying an existing data format. You can then
edit the properties to customize the characteristics of the new data format.

NOTE Certain automatic properties cannot be formatted with property data
formats because their values are formatted from within the automatic query.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Property Data
Formats.

3 Right-click Property Data Formats, and click New.

4 Enter a name for the new property data format, and press ENTER.

5 Select the new property data format.

6 On the Formatting tab, specify general formatting values:

Then…If you want to…

enter a string to be placed in front
of data for Prefix. For example, tol-

specify a prefix

erances might require a preceding
plus/minus symbol; a tolerance of
10 could be displayed as +10. A
currency string could be prefixed
with a dollar sign.

enter a string to be placed after
data for Suffix. For example, a door

specify a suffix

leaf thickness of 35 could have a
millimeter suffix (35mm).
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Then…If you want to…

NOTE If you override the unit
type in a manual property set
definition, change the suffix
here to display the units cor-
rectly.

enter a text string to be displayed
when the requested property has

specify text for a property that is
undefined

not been attached to an object for
Undefined. A typical undefined
string is “?.”

enter a text string to be displayed
when the requested property does

specify text for a property that is
not applicable

not apply to an object for Un-
defined. For example, the rise
property does not apply to a door
with a rectangular opening, but it
does apply to one with an arched
opening. A typical not applicable
string is “NA.”

7 Specify the case for the schedule text:

Then…If you want to…

select As Is for Case.use no case formatting

select Upper for Case.convert all text to uppercase

select Lower for Case.convert all text to lowercase

select Sentence for Case.capitalize the first letter of the first
word

select Title for Case.capitalize the first letter of each
word

8 Enter the maximum number of digits, including leading zeroes,
for integers.
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Zero padding is the expansion of integer values to include leading
zeros. The value entered specifies the maximum length of a
numeric value after it has been padded with leading zeros. For
example, with Zero Padding at 3, the number 6 would become
006. This option primarily is intended for identity numbers, such
as those used by door and window tags. For example, to number
doors as D01 through to D99, the raw value of the data would be
saved as a simple integer, but the prefix would be D and Zero
Padding would be 2. Entering zero for Zero Padding applies no
zero padding.

9 Enter the values for True and False.

For example, you can specify Yes for True and No for False.

10 Enter data to display a sample of your current settings for Result.

11 For formatting that can be specified by dimension style, click Set
from Dimension Style, select a dimension style, and click OK.

Undefined, Not Applicable, Case, Zero Padding, and True/False
are not defined by dimension styles.

12 Select the unit type, format, numerical precision, fraction format,
and scale for real numbers. Definitions of these items are as
follows:

■ Unit Type: The format in which to display the type of units,
such as length, area, and volume.

■ Units: The drawing units in which the unit is stored. For
example, if you select Volume for Unit Type, options to select
from include cubic inches, cubic feet, cubic millimeters, cubic
centimeters, and cubic meters.

■ Unit Format: The drawing unit format in which the value is
displayed. The AutoCAD® conversion units (Architectural,
Scientific, Decimal, Engineering, and Fractional) are used when
converting numeric values into strings. For example, a value
of 14.25 is displayed as 1'–2 1/4" in architectural units.

■ Precision: The number of decimal places used to display
floating point numbers (for example, 0, 0.0, 0.00, and so on).

■ Fraction Format: If the unit format is Architectural or
Fractional, set the format used to display fractions (Horizontal,
Diagonal, or Not Stacked). Note that all fonts do not support
all fraction formats.
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■ Scale: The value by which the real number is scaled before it
is displayed. For example, if the current drawing units are
inches, a scale of 2.54 converts a dimension to centimeters.

13 Select the Round Off value for real numbers:

Then…If you want to…

select Nearest.round to the nearest value

select Up.round to the nearest greater value

select Down.round to the nearest lesser value

If you enter a value of 0.25, all numeric values are rounded to the
nearest 0.25 unit. Similarly, if you enter a value of 1.0, all numeric
values are rounded to the nearest integer. The number of digits
displayed after the decimal point depends on the precision
specified. No round-off occurs for a value of 0.0.

14 Specify the rules for suppression of leading and trailing zeros, and
feet and inches of floating point numbers:

Then…If you want to…

select Leading for Zero Suppression.
For example, 0.5000 becomes
.5000.

suppress leading zeros in all decimal
numeric values

select Trailing for Zero Suppression.
For example, 12.5000 becomes
12.5.

suppress trailing zeros in all decimal
numeric values

select 0 Feet for Zero Suppression.
For example, 0'–6 1/2" becomes
6 1/2".

suppress the feet portion of a feet-
and-inches numeric value when the
value is less than one foot

select 0 Inches for Zero Suppres-
sion. For example, 2'–0" becomes
2'.

suppress the inches portion of a
feet-and-inches numeric value when
the value is an integral number of
feet

For more information, see “New, Modify, and Override Dimension
Style Dialog Boxes” in AutoCAD Help.
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TIP The quickest way to locate and view an AutoCAD topic referenced
in AutoCAD Architecture 2012 Help is to click the Search tab in the
Help window, select the Search titles only option, and then copy and
paste or type in the AutoCAD topic name, and click List Topics.

15 Select the decimal separator.

16 Select the whole number separator.

17 Click OK.

Attaching Notes and Reference Files to a Property Data Format
Use this procedure to enter notes and attach reference files to a property data
format. You can also edit notes and edit or detach reference files from a
property data format.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Property Data
Formats.

3 Select the property data format that you want to change.

4 Click the General tab.

5 To add a description to the property data format, enter it for
Description.

6 To add a note, click the Notes tab, and enter the note.

7 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, click Open,
and click OK.

attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file
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Then…If you want to…

select the file name, and click De-
lete.

detach a reference file

8 Click OK.

Expanding the Scope of Scheduled Data
The data that can be collected and graphically presented in a schedule table
is extensive. To effectively customize schedule tables to meet your needs, you
need to understand the following elements which control how data is displayed
and which data is collected.

■ Property set data

■ Property set definitions

■ Automatic properties

■ Manual properties

■ Formula definitions

■ Classification definitions

■ Material definitions

■ Project definitions

■ Anchor definitions

■ Graphic definitions

Property Set Data
Objects to be included in schedule tables or linked to tags must have property
set data attached to them. Schedule tables and tags do not store any data, but
extract and display property set data from the associated objects.

Property set data is collected from one or more property sets attached to an
object or a style. Some property data, such as a dimension, comes from
automatic properties of the object or the object style and cannot be manually
entered, such as dimensions. Other property data consists of manual properties
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for which you must enter values for each object or object style, such as
manufacturer’s name.

IMPORTANT If an entity or style containing a property set is copied from a source
drawing into a target drawing that already contains a property set with the same
name, the property set in the target drawing does not change. There is a potential
for a loss of data in this case. For example, assume a property set in one drawing
has a number of manual properties defined and is attached to a door style with
manual property values set. This door style is then copied into another drawing
that contains a duplicate property set that does not have the same manual
properties defined. In the target drawing the door style will contain the target
drawing’s property set, not the source drawing’s property set. Any data values
associated with the source drawing’s manual properties will be lost.

Attaching Property Set Data to Objects
Use this procedure to attach property set data to objects that you want to
include in a schedule table or link to schedule tags.

You attach property set data to objects by attaching one or more property
sets, defined by a property set definition. After property sets are attached, the
values for automatic properties are determined from the object, and you can
enter values for the manual properties.

For information about attaching property set data to an object style, see
Attaching Property Set Data to Styles and Definitions on page 3814. For
information about property sets and external references, see Attaching Property
Sets to Objects from External References on page 537.

1 Double-click the object(s) for which you want to attach property
set data.

NOTE If you select more than one type of object, you can attach
only the property set definitions that apply to all the selected objects.
For example, if you select doors and windows, you can attach only
those property sets that apply to both doors and windows.

2 On the Properties Palette, click the Extended Data tab.

3 Click  .

4 Select the property set you want to attach, and click OK.
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Entering Manual Properties and Fields for Objects
Use this procedure to enter values for manual properties for one or more
objects. For example, to enter a remark that applies to several doors in a
drawing, you can select the doors and enter the remark as data for Notes.

You can insert fields into manual properties. Fields enhance the documentation
capabilities within a drawing file because the values they display update
whenever the associated property changes. You can also enter AutoCAD fields
into manual properties attached to objects or styles.

NOTE Fields can be associated with hyperlinks. For example, if you insert a field
pointing to a drawing using a hyperlink in a manual property, and create a schedule
table that contains that property, you can jump from the table cell with the field
property in it to the drawing to which it is linked. For detailed information about
fields, see “Use Fields in Text” in AutoCAD Help.

1 Select the object(s) for which you want to add a manual property
or field, right-click, and click Properties.

2 On the Properties palette, click the Extended Data tab.

NOTE If no property set data appears, no property sets are attached
to the objects. To attach property sets, see Attaching Property Set
Data to Objects on page 3811.

3 Enter a value for a manual property.

ThenIf you want to…

select the property, and enter the value.specify an alphanumeric
value

right-click in the current value for the prop-
erty, and click Insert Field. Select a field from

insert a field

one of the available categories, specify the
desired format, and click OK.
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NOTE You can also define a default field for the manual property in
the property set definition. For example, if you want all walls to have
a field that displays the last save date of the drawing, you can enter
the “SaveDate” field in the property set definition, so that it will be
displayed for each object connected to the property set. For more
information, see Adding a Field to a Property Set Definition on page
3847.

Editing or Updating Fields in Manual Properties
Use this procedure to update or edit field values in a manual property. When
you edit a field, you can change the field formatting and other settings. For
more information, see Entering Manual Properties and Fields for Objects on
page 3812.

1 Double-click the object(s) for which you want to edit the fields.

2 On the Properties palette, click the Extended Data tab.

3 Place the cursor in the row containing the field to update.

Then…If you want to…

right-click, and click Update Field.update the field value

right-click, and click Edit Field.change the field format or other
settings

Converting Fields in Manual Properties to Text
Use this procedure to convert fields in manual properties to text. When you
convert a field to text, it loses its connection to the referenced information.
For example, if the field had a hyperlink to a drawing, the hyperlink to the
drawing will be lost. For more information, see Entering Manual Properties
and Fields for Objects on page 3812.

1 Double-click the object(s) for which you want to convert field
properties to text.

2 On the Properties palette, click the Extended Data tab.

3 Place the cursor in the row containing the field you want to
convert to text, right-click, and click Convert Field to Text.
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Removing Property Set Data from an Object
Use this procedure to remove one or more property sets from an object. If an
object is included in a schedule table, any data in the table obtained from the
removed property set displays question marks in the table.

1 Double-click the objects from which to remove property set data.

2 On the Properties Palette, click the Extended Data tab.

3 Click  .

4 Select property sets to remove, and clear any property sets to
remain attached to the object.

5 Click OK.

Attaching Property Set Data to Styles and Definitions
Use this procedure to attach data to object styles and definitions, such as space
styles, curtain wall styles, door styles, and multi-view block definitions.

You attach data to a style or a definition by attaching one or more property
sets to it. Objects that use the style or definition inherit its property set data.
The values for automatic properties, which may be different for each instance
of the style, are determined from the objects, and you can enter values for
manual properties. For more information, see Property Set Data on page 3810.
For information about attaching property set data to individual objects, see
Attaching Property Set Data to Objects on page 3811.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Architectural Objects, and locate the style or definition
to which to attach property set data.

3 Select the style or definition.

4 Click the General tab, and click Property Sets.

5 Click  .

6 Select the property sets that you want to attach.

7 Click OK twice.
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Entering Manual Properties and Fields for Styles and Definitions
Use this procedure to enter values for manual properties in the property set
data for a style or definition. The values you enter apply to all instances of
objects associated with the style or definition.

You can insert fields into manual properties. Fields enhance the documentation
capabilities within a drawing file because the values they display update
whenever the associated property changes. You can also enter AutoCAD fields
into manual properties attached to objects or styles.

NOTE Fields can be associated with hyperlinks. For example, if you insert a field
pointing to a drawing using a hyperlink in a manual property, and create a schedule
table that contains that property, you can jump from the table cell with the field
property in it to the drawing to which it is linked. For detailed information about
fields, see “Use Fields in Text” in AutoCAD Help.

TIP The quickest way to locate and view an AutoCAD topic referenced in AutoCAD
Architecture 2012 Help is to click the Search tab in the Help window, select the
Search titles only option, and then copy and paste or type in the AutoCAD topic
name, and click List Topics.

If the property you want to edit is not listed in the property set data for the
style or definition, it may be in a property set attached directly to the objects.
To enter values for manual properties attached to objects, see Entering Manual
Properties and Fields for Objects on page 3812.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Architectural Objects, and locate the style or definition
for which to add manual properties.

3 Select the style or definition.

4 Click the General tab, and click Property Sets.

NOTE If no data appears, no property sets are attached to the style
or definition. To attach property sets, see Attaching Property Set Data
to Styles and Definitions on page 3814.
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5 Enter a value for a manual property.

Then…If you want to…

select the property, and enter the value.specify a alphanumerical
value

right-click the current value for the property,
and click Insert Field. Select a field from one

insert a field

of the available categories, specify the desired
format, and click OK.

NOTE You can also define a default field for the manual property in
the property set definition. For example, if you want all walls of a
specific style to have a field that displays the last save date of the
drawing, you can enter the SaveDate field in the property set
definition, so that it will be displayed for each wall of that style. For
more information, see Adding a Field to a Property Set Definition on
page 3847.

6 Click OK twice.

Editing Style-Based Property Sets
Use this procedure to edit values of manual, style-based property set data
attached to objects in your drawing. For more information, see Attaching
Property Set Data to Styles and Definitions on page 3814.

1 Double-click the object for which you want to edit property set
data.

2 On the Properties palette, click the Extended Data tab.

If object-based and style-based property sets are attached to the
object, both display on the Extended Data tab.
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3 Click  (Edit style property set data) next to Property Sets From
Style.
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4 On the Edit Property Set Data worksheet, enter new values for the
property set data and click OK.

5 Click OK.

Editing Style-Based Property Sets Attached to Objects in
External References

Use this procedure to edit values of manual, style-based property set data
attached to objects that are referenced externally (xrefs) in your drawing. For
more information on attaching property data across xrefs, see Attaching
Property Sets to Objects from External References on page 537.
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1 Double-click the xref in your drawing.

2 In the Reference Edit dialog, on the Identify Reference tab, select
Prompt to select nested objects, and click OK.

3 Select the object in the xref, and press ENTER.

4 Double-click the object to make changes to the property set data.

5 On the Properties palette, click the Extended Data tab.

If object-based and style-based property sets are attached to the
object, both display on the Extended Data tab.

6 Next to Property Sets From Style, click  (Edit style property set
data).
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7 On the Edit Property Set Data worksheet, enter new values for the
property set data, and click OK.

8 Click Multiple Objects tab ➤ Edit Reference panel ➤ Save Changes
or Multiple Objects tab ➤ Edit Reference panel ➤ Discard Changes.

9 Click OK to verify your selection.

Removing Property Set Data from a Style or Definition
Use this procedure to remove one or more property sets from a style or
definition. If objects using the style or definition are included in a schedule
table, the cells for data obtained from the removed property set display
questions marks.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Architectural Objects, and locate the style or definition
from which to remove property set data.

3 Select the style or definition.

4 Click the General tab, and click Property Sets.

5 Click  .
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6 Select property sets to remove, and clear any property sets that
should remain attached.

7 Click OK three times.

Browsing Property Data
Use this procedure to access and view the data for all property sets in a drawing.

For more information about browsing property sets attached to objects
scheduled from external references, or to override property sets for those
objects, see Attaching Property Sets to Objects from External References on
page 537.

1 Open the tool palette that contains the Browse Property Data tool,
and select it.

This tool is located with the Scheduling and Reporting Tools in
the Stock Tool Catalog. You can add this tool to any tool palette.
For more information, see Content Browser on page 129.

2 Specify view options:

Then…If you want to…

select Highlight.allow an object to be highlighted
in the drawing when you select a
property set that is attached to the
object or its style

clear Highlight.prevent an object from being high-
lighted in the drawing when you
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Then…If you want to…

select a property set that is attached
to the object or its style

clear Hide objects without property
set definitions.

display objects in the left pane re-
gardless of whether the selected
property set definition is attached

select Hide objects without property
set definitions.

display only objects that have the
selected property set definition at-
tached

clear Format data.view the raw, unformatted data in
the property set

3 View property sets and the objects or styles to which they are
assigned:

Then…If you want to…

select the property set. The right
pane lists the property values, if

view the object or style type to
which a property set applies

available, and the objects or the
styles to which the property set can
be attached.

apply the object filter to the prop-
erty set. The left pane lists objects

view the list of objects or styles to
which a property set is attached

or styles to which the property set
is attached. If Highlight is selected,
any objects to which the property
set is attached (directly or through
a style) are highlighted in the
drawing.

under the property set, select the
object or style. The right pane

view the property values for a spe-
cific property set and a specific ob-
ject or style shows the values for the selected

object or style.
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Viewing property values for objects with property sets attached

4 Select the object or style from the left pane to edit property sets
and values, and click OK.

5 Remove property sets from objects or styles:

WARNING If you detach a property set from an object or style, any
manually entered values are lost. If you mistakenly detach a property
set, click OK, and then immediately click Undo on the Quick Access
Toolbar.

Then…If you want to…

clear the selection of the object or
style.

detach a property set from a object
or style

select the object or style.add a property set to objects or
styles

6 Click Zoom to to view the selected object in the drawing

7 Click OK.

Property Set Definitions
A property set definition specifies the characteristics of a group of properties
that can be tracked with an object. For example, you could create a property
set definition named DoorProps that contains property definitions for
DoorNumber, DoorWidth, and FireRating. Each property has a name,
description, data type, data format, and default value.
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Property Sets and Property Data

A property set is an object created from a property set definition. It contains
a user-definable group of related object properties. When you attach a property
set to an object or a style, the property set becomes the container for the
property data associated with the object.

Creating Property Set Definitions for Objects or Styles

When you create a property set definition, you specify whether the property
set can be attached to objects or to styles, depending on which of the following
kinds of properties you want to track:

■ Automatic properties generally belong in style-based definitions. Automatic
properties, even when attached to a style, can vary for each instance of
the object. It is more efficient to include automatic properties in a
style-based definition because the properties are immediately associated
with any object that uses the style.

■ Manual properties can belong to either style-based or object-based
definitions. The value of a manual property associated with a style is the
same for every object. For example, a Manufacturer property will probably
be the same for every instance of a particular door style, so it should be in
a style-based property. However, a Door Number property is different for
each instance of a door, so it should be in an object-based property.

■ Fields enhance the documentation capabilities within a drawing file. A
field is updatable text that is set up to display data that may change during
the life cycle of the drawing. When the field is updated, the latest value
of the field is displayed. You can insert fields in a manual property in the
property set definition or in a property attached to an object or style.

NOTE Fields can be associated with hyperlinks. For example, if you insert a
field pointing to a drawing in a manual property, and create a schedule table
that contains that property, you can jump from the table cell with the field
property in it to the drawing it is linked to. For detailed information about
fields, see “Use Fields in Text” in AutoCAD Help.

TIP The quickest way to locate and view an AutoCAD topic referenced in
AutoCAD Architecture 2012 Help is to click the Search tab in the Help window,
select the Search titles only option, and then copy and paste or type in the
AutoCAD topic name, and click List Topics.
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Automatic and Manual Properties

Property sets, whether attached to objects or to styles, can include both manual
and automatic properties.

■ Automatic properties cannot be edited directly because they are obtained
from the object or other source. For example, the physical characteristics
of an object, such as its dimensions or material, are automatic properties.
To change the value of an automatic property, you must modify its source.
The change then appears in the property set data for the object.

■ Manual properties must be edited in the property set data for the object
or style. For example, object numbers (for tagging) and notes or remarks
are manual properties. The value entered for a manual property in an
object-based property set is saved with the object. The value entered for a
manual property in a style-based property set is saved with the style and
is available to all objects using that style.

■ Fields are used with manual properties and are selected from a list of
available fields in the software. Fields contain values that update when the
value changes and can also contain hyperlinks to other drawings or other
files. For detailed information about fields, see “Use Fields in Text” in
AutoCAD Help.

Using Property Data Formats in Property Set Definitions

Property data formats control how values for numbers and text display. Both
property set definitions and schedule table styles use property data formats.
For more information about creating property data formats, see Property Data
Formats on page 3802.

Managing Property Set Definitions

To create, edit, copy, or purge property set definitions, you access the Style
Manager. The Style Manager provides a central location where you can work
with definitions and styles from multiple drawings and templates. For more
information about using the Style Manager, see Style Manager Overview on
page 870.
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WARNING If you overwrite one property set definition with another, you may
lose data. For example, a drawing might contain a property set definition with a
number of manual properties. The property set is attached to doors with the
manual properties entered, and is included in a schedule table. If you overwrite
this property set definition with one that does not have the same properties, the
values entered for the manual properties are lost. In addition, any columns in the
schedule table that reference these manual properties are flagged as invalid.
Changes to the schedule table that result from changes to the property set
definition are displayed the next time the table is updated manually or
automatically.

Understanding Automatic Properties
The data in an automatic property is obtained from individual objects or their
styles and is not entered manually. For example, a number of doors might
have the same style but different widths. The automatic property Width may
be different for each door. However, those doors have the same thickness,
because thickness is a property of the style. The automatic property Thickness
has the same value for all doors of the same style. For more information, see
Adding an Automatic Property Definition to a Property Set Definition on page
3849.

More than a 1,000 automatic properties are available in AutoCAD Architecture
2012. Most are self-explanatory, but a few need additional explanation.

Wall Area Properties
The following 4 automatic properties provide data for wall area calculations:

■ Area—Right Gross

■ Area—Right Net

■ Area—Left Gross

■ Area—Left Net

The right and left sides of a wall are determined as if you were standing on
the start point of the wall and facing the endpoint. Gross area is the area of
one side without allowing for holes for openings such as doors and windows.
Net Area is the area of one side of a wall after holes are cut for openings. Gross
Area might be used to determine the quantity of gypsum board needed for a
wall, while Net Area might be used to determine the quantity of brick.
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WARNING The area of a wall is determined by adding the union of the wall
components (not including body modifiers or interferences) to the area of all faces
that point to the right (for right areas) or the left (for left areas). If a particular wall
style has multiple components with air space between them, the wall area may
not be reported as expected. For example, a wall typically used in construction
has a brick exterior, an air space, and a CMU interior. A style defined for this wall
might have a component for the brick and a component for the CMU, but no
component for the air space. If the wall was drawn with the brick on the left side,
the wall area computed for the right side would include the right face of the CMU
as well as the right face of the brick. The area reported would be twice the actual
area. To avoid this situation, create components for interior air spaces in wall styles,
so that no interior faces exist when the wall components are unioned.

The shape of a wall can be modified by adding or subtracting body modifiers.
Automatically calculating appropriate areas for every possible wall shape is
practically impossible. Because of this, body modifiers and interferences are
not currently included in wall area calculations. Wall areas for unusually
shaped walls must be computed manually.

Wall Volume Properties
The following 4 automatic properties provide data for wall volume calculations:

■ Volume—Gross

■ Volume—Net

■ Volume—Gross With Mods

■ Volume—Net With Mods

Gross volume is the volume of wall components without allowing for holes
for openings such as doors or windows. Net volume is the volume after holes
are cut for openings.

You can obtain the wall volume with or without wall body modifiers.

■ Gross and net show the volume of the wall components as if no body
modifiers exist.

■ Gross With Mods and Net With Mods include body modifiers.
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Wall Length Property
Like wall area, wall length is practically impossible to calculate automatically
when body modifiers are present. Because of this, the Wall Length property
returns only the distance between the start point and endpoint of the wall.
To get a more accurate report for the length of a wall, you may have to
reposition the endpoint of the wall.

The visible length of a wall may differ from the distance between the endpoints
due to wall cleanups.

Slab and Roof Slab Volume Properties
Volumes for slabs and roof slabs do not include the volumes of fascias or
soffits.

Slab and Roof Slab Elevation Properties
Slabs and roof slabs have the following elevation properties:

■ Elevation—High

■ Elevation—Low

These properties provide the highest and lowest elevation value of all slab and
roof slab vertices, including fascias and soffits.

Door Size Properties
Values for the dimension properties of Width, Height, and Thickness can be
combined in 3 additional Door Size properties. The table below shows how
these properties appear for a number of different doors, each with a width of
3'-0", a height of 6'-8", and a thickness of 2", but differing in the number and
size of individual door panels.

Uneven DoorDouble DoorSingle DoorProperty

3'-0"x6'-8"3'-0"x6'-8"3'-0"x6'-8"Door Size - W x H

2'-0"(1'-0")x6'-8"2@1'-6"x6'-8"3'-0"x6'-8"Door Size - 2 @ W x
H
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Uneven DoorDouble DoorSingle DoorProperty

2'-0"(1'-0")x6'-8"PR 1'-6"x6'-8"3'-0"x6'-8"Door Size - PR W x H

NOTE Try using a formula property definition if you need more control in
formatting multiple door size properties. For more information, see Adding a
Formula Property Definition to a Property Set Definition on page 3830.

Door Swing Direction Properties
Different countries have different conventions for specifying the swing
direction of a door. For example, the door shown below is considered a
left-swinging door in the United States and Great Britain, but a right-swinging
door in Australia, Russia, and most of Europe. To accommodate these
differences, AutoCAD Architecture includes a property called Swing Direction
- Reverse. You can select the door swing property you want to use when you
create or modify a property set definition.

Structural Member Properties
The length of a structural member is its logical length—the length between
its grip points—rather than the actual length, which can be difficult to
compute. To get the actual length, you can add the Length along Baseline
property, which projects all parts of the member to its baseline for
measurement. This property will give the actual length for members to which
trim planes or offsets are applied or when interference conditions or body
modifiers affect the overall length. Such members give a visible length that is
different from the logical length.

The location properties of a structural member (X, Y, Z) give information
about the coordinates on which a structural member has been inserted. This
is important for downstream applications in the structural engineering field.

Understanding Automatic Properties | 3829



Understanding Formulas
Formulas are user-defined equations for calculating the value of a property.
You can use a formula to add data about a selected group of objects or object
styles to a schedule table after you define the formula property set definition.
and then add the formula property definition to a property set definition. For
more information about property sets and property set definitions, see Property
Sets and Property Set Definitions on page 3743.

The worksheet you use to specify the formula also lets you evaluate sample
results. Formulas can contain variables, operators, and functions allowed in
VBScript. For more detailed information about VBScript, go to
http://msdn.microsoft.com and search for “VBScript Language Reference.”
Additionally, in the Formula Property Definition worksheet, links to online
Help are available from the Insert VBScript code and Formula context menus
for VBScript items used in the formula.

Adding a Formula Property Definition to a Property Set
Definition

Use this procedure to add a formula property definition to a property set
definition. Formula property values can be computed based on the values of
other property data. (For more information about how a formula is evaluated,
see Formula Evaluation on page 3834.) For example, width and height are
automatic door properties, which you can use to compute the perimeter of
the door. Defining (2 * [Width]) + (2 * [Height]) as a formula for a 36" x 84"
door results in a value of 240. A formula property definition is a type of
automatic property, because the value it displays is determined automatically,
based on its definition, and cannot be edited directly.

NOTE There is no conversion made between units for a formula result.

Formulas can be simple mathematical expressions, such as 2+2. They can also
contain variables, operators, and functions allowed in VBScript, as shown in
the examples below.

Statements

Set StatementProperty Get State-
ment

For Each...Next
Statement

Call Statement
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Statements

Sub StatementProperty Let State-
ment

For...Next State-
ment

Class Statement

While...Wend State-
ment

Property Set State-
ment

Function StatementConst Statement

Set StatementPublic StatementIf...Then...Else
Statement

Dim Statement

With StatementRandomize State-
ment

On Error StatementDo...Loop State-
ment

ReDim StatementOption Explicit
Statement

Erase Statement

Select Case State-
ment

Private StatementExecute Statement

Functions

ScriptEngineMinorVer-
sion

LBoundEscapeAbs

SecondLCaseEvalArray

SetLocaleLeftExpAsc

SgnLenFilterAtn

SinLoadPictureFormatCurrencyCBool

SpaceLogFormatDateTimeCByte

SplitLTrimFormatNumberCCur

SqrMathsFormatPercentCDate

StrCompMidGetLocaleCDbl

StringMinuteGetObjectChr
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Functions

TanMonthGetRefCInt

TimeMonthNameHexCLng

TimerMsgBoxHourConversions

TimeSerialNowInputBoxCos

TimeValueOctInStrCreateObject

TrimReplaceInStrRevCSng

TypeNameRGBInt, FixDate

UBoundRTrimIsArrayDateAdd

UCaseRightIsDateDateDiff

UnescapeRndIsEmptyDatePart

VarTypeRoundIsNullDateSerial

WeekdayScriptEngineIsNumericDateValue

WeekdayNameScriptEngineBuild-
Version

IsObjectDay

YearScriptEngineMa-
jorVersion

JoinDerived Math

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Select the property set definition to change.

4 On the Definition tab, click  .
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5 On the Formula Property Definition worksheet, enter a name for
the formula property.

6 If you do not want to use the formula as the description of the
property, clear Use formula for description.

7 Enter the formula:

Then…If you want to…

click in the Formula pane, and enter
the value.

use a value that you supply

locate and double-click (or right-
click, and click Insert) the definition

use the value of another property
definition in the formula

in the Insert Property Definitions
list. You can also select the defini-
tion, and press INSERT.

locate and double-click (or right-
click, and click Insert) the function

use a VBScript function

in the Insert VBScript code list. You
can also select the function, and
press INSERT.

enter RESULT anywhere in the for-
mula.

evaluate the formula as a VBScript
function
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The property definitions available for use in the formula must be
applied to the same objects as the property set definition
containing the formula.

The names of property definitions used in the formula are
displayed within brackets, such as [Width]. If a property definition
belongs to a property set definition other than the one containing
the formula, that name is displayed as well, such as
[DoorObjects:Height].

The formula property definition cannot be used in the formula

it defines, as indicated by the  and the addition of [Self] after
its name. Property definitions that end up using the value of the

formula cannot be used in the formula, as indicated by the 
and the addition of [Circular Reference] after their names.

NOTE If you enter the name of a property definition directly in the
formula string, or copy and paste between formulas, the property
definition is displayed as normal text. For property values of property
definitions to be inserted correctly, they must be selected from the
list in the Insert Property Definitions pane.

8 In the Enter Sample Values pane, enter a value.

The property value you enter displays with the current format
specified in the Sample Result pane.

9 In the Enter Sample Values pane, select a property data format.

The format you select effects how the data in the Value column
displays in the Sample Result pane and how the formula evaluates
in the in the schedule table. It can be changed at any time. For
more information, see Property Data Formats on page 3802.

10 Click OK twice.

Formula Evaluation
Use this procedure to evaluate the result of a formula. After you complete the
formula property definition and add the property set to objects, you can use
the result of the formula in schedule tables and schedule tags.
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1 Confirm that for each property definition in the formula, the
value of the property is:

retrieved from the object or style.

formatted using the property data format defined in the sample value
format.

inserted into the formula in place of the property definition name and the
brackets surrounding it.

2 Evaluate the formula string:

Then…If the formula string…

it is evaluated as a VBScript function, and
the value displayed for the property is the
result of that evaluation.

contains the word “RES-
ULT”

it is evaluated as a mathematical expression.does not contain the word
“RESULT”

NOTE Make sure that all property sets used in the formula have been
applied to the object or style. Otherwise, a question mark (?) is
displayed in the schedule table.

For more information, see Adding a Formula Property Definition
to a Property Set Definition on page 3830. There is access to online
Help for VBScript code from the context menu in the Formula
Property Definitions worksheet.

Use Case for the Formula Property Definition Worksheet
Creating a formula that returns valid data can be a complex task. As the
following example shows, you can simplify the process by using the Formula
Property Definition worksheet to construct the formula with VBScript Code.
You then insert sample values into the formula and evaluate the result.

Example of Completed Formula

The space object has a single numeric value for its height, which is adequate
for the majority of spaces in a room schedule. However, to get more control
over how space heights are displayed for rooms without flat ceilings, you can

Understanding Formulas | 3835



create a formula that returns a text override, such as “Vaulted” for a cathedral
ceiling, or return the actual height. The completed worksheet for such a
formula is shown below.

Process Used to Complete Example

Using primarily the default property set definitions in the Style Manager, the
following process was completed.

Added SpaceStyles as a new property set definition

■ Imported space styles from schedule table styles drawing.

On the Definition tab for the SpaceObjects property set definition

■ Added a manual text property definition called HeightOverride.
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■ Added a formula property definition called HeightDisplayed.

Edited the HeightDisplayed formula property definition on the Formula
Property Definition worksheet

■ On the first line under Formula, entered strHeightOverride = "".
As you make changes to the formula, you can view a sample result. For
example, entering the formula “2+3” displays “5” in the Sample Result
pane. This lets you correct a formula that fails to evaluate as expected.
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■ Under SpaceObjects with the cursor between the double quotes, selected
HeightOverride.

When a property definition is first inserted in a formula, its sample value
is taken from an object in the current drawing that uses the formula’s
property set definition or from a default object.

■ With the cursor after the second quotation mark, pressed ENTER twice to
insert 2 lines.

■ From Statements under Insert VBScript code, added If…Then..Else (Block).

3838 | Chapter 50   Schedules and Display Themes



When you move the cursor over an item, a tooltip displays the text that
appears in the formula when it is inserted.

After you add VBScript code to the formula, red or gray text may be inserted
to help construct the formula. Red indicates fields where additional code
must be added. To remove a red field, select it, and enter text, insert a
property definition, or insert other VBScript code.

Gray fields surrounded by brackets indicate optional fields. Typing
anywhere within the gray brackets, or deleting one bracket, will remove
the brackets and convert the code from optional to required.

You can save a formula containing red and gray fields for future editing,
but a warning dialog displays because the formula will not be evaluated
correctly. You can access online Help for VBScript code in the formula for
more information on its proper usage.

■ Selected red condition field, and entered strHeightOverride = "".

■ Selected red statements field, and entered RESULT = CDbl( ).
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■ With the cursor between the parentheses, selected Height under SpaceStyles.

■ Deleted the ElseIf line and the line below it.

■ Selected red “elseStatements” field, and entered RESULT =
strHeightOverride.

■ Entered Vaulted for sample value of HeightOverride.
Every time a sample value is changed a new sample result displays.

■ Entered 108 for sample value of SpaceStyles:Height.

■ Selected Length - Long for Format.
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Sample values are formatted and inserted into the formula in place of the
corresponding property definition names with brackets surrounding them.
The entire sample formula is evaluated, and the result displays in the Sample
Result pane.

Because this formula contains the word RESULT, it is evaluated as a function
instead of an expression, and the value of the formula property is the last
value assigned to RESULT. The result of this valid formula is Vaulted.

Creating a Property Set Definition
Use this procedure to create a property set definition. You can create a new
property set definition by copying an existing definition. You then edit the
definition properties to customize the characteristics of the definition. For
more information, see Editing a Property Set Definition on page 3863.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Create a property set definition:

Then…If you want to…

right-click the style or definition,
and click New. Enter a name for the

create an empty property set
definition with default properties

new property set definition, and
press ENTER.

right-click the property set defini-
tion to copy, and click Copy. Right-

create a property set definition from
an existing property set definition

click, and click Paste. Right-click the
new property set definition, and
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Then…If you want to…

click Rename. Enter a name, and
press ENTER.

NOTE If this property set definition will be used with schedule tags,
do not enter spaces in the name.

4 Click OK.

Attaching Notes or Reference Files to a Property Set Definition
Use this procedure to enter notes and attach reference files to a property set
definition. You can also edit notes and edit or detach reference files from a
property set definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Select the property set definition to which you want to attach
notes or reference files.

4 Click the General tab.

5 To add a description to the property set definition, enter it for
Description.

6 To add a note, click Notes, click the Notes tab, and enter the note.

7 Click Notes, click the Reference Docs tab, and attach, edit, or
detach a reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file
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Then…If you want to…

select the file name, and click De-
lete.

detach a reference file

8 Click OK twice.

Specifying How the Property Set Definition is Applied
Use this procedure to specify whether a property set definition applies to
objects or to styles and definitions. You also select the objects or the styles
and definitions that can use the property sets created from this definition.

If the property set that you define contains properties that are the same for
all objects created using a specific style, select a style-based property set. This
eliminates the need to attach data for each instance of the object that you
create. Objects created using the style with the property set assigned have
access to the associated style-based property set.

In general, use automatic properties only within property set definitions that
are applied to styles or definitions.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Select the property set definition that you want to change.

4 Click the Applies To tab.

5 Specify how the property set definition is applied:

Then…If you want to apply it to…

select Objects. The list of objects
becomes available.

objects

select Styles and Definitions. The
list of styles and definitions be-
comes available.

styles and definitions
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6 Select the objects or the styles and definitions to which the
property set applies.

Then…If you want to…

select the objects from the list in
the left pane.

define an object-based property set
definition

select the styles or definitions from
the list in the left pane.

define a style- or definition-based
property set definition

click Select All.select all objects or style and defini-
tions

click Clear All.clear the current selection

If all the objects or none of the objects are selected, your property
set definition can be added to any object or style. The area above
the list displays the objects that are currently selected.

7 To specify classification criteria, expand a classification definition,
and select one or more classifications.

For example, you can select a construction status of New and two
preferred vendors. To meet the criteria, the classification in the
object style must be New for construction status and the Vendor
classification must be one of the two vendors selected.

Specifying multiple classification criteria in a property set definition
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All classification definitions that apply to the same objects to
which the property set definition applies are displayed on the
right with a list of their classifications. If classifications are
selected, the property set definition can be applied only to those
objects or styles and definitions selected on the left that have all
the classifications selected on the right.

8 Click OK.

Adding a Manual Property Definition to a Property Set Definition
Use this procedure to add a manual property definition to a property set
definition. Manual properties are those that must be entered rather than
obtained directly from the object. You can define a list of manual property
values to use in property definitions. For example, you could predefine the
values for paint color or manufacturer to avoid repeatedly typing the
information. For more information, see Creating a List Definition for a Manual
Property Definition on page 3869.

When you use real numbers for Type in manual property definitions, you
specify only how units are entered and stored for properties of the object or
style. How units are displayed is controlled by the property data format. For
more information, see Property Data Formats on page 3802.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Select the property set definition for which to add a manual
property.

4 On the Definition tab, click  .

5 Enter the Name for the property.

NOTE If this property is for use with schedule tags, do not enter
spaces in the property name.

6 To define a property by using existing properties, select a property
from the Start With list.

7 Click OK, and continue working on the property set definition
on the Definition tab of the Property Set Definition dialog.
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8 Enter a description of the property, and click OK.

The default description is the same as the property definition
name. This text is for a column header in a schedule table that
uses this property.

NOTE The description does not change if you edit the property name.
Edit the description separately.

9 Specify the type of data the property contains.

Select List to associate a list definition with this manual property.
For more information, see Creating a List Definition for a Manual
Property Definition on page 3869.

Changing the data type of a definition for property data already
stored in the drawing will set the data to the default value, possibly
removing data previously edited.

For property definitions to be displayed in a matrix column in a
schedule table, you can assign multiple values to the same property
by using a text data type and separating the values with
semicolons. Each value will be displayed in a separate matrix
column.

10 Select a property data format to specify how the data included in
the property set definition is displayed.

The format you select becomes the default format of a column
when this property is added to a schedule table style. It can be
changed at any time. The Example column shows how the default
value is displayed using the selected format.

11 Select how units are entered.

If you assign a type of unit other than the default for Format, an
override is applied to the property data format. The type of units
specifies how they are stored in the drawing. on the Extended
Data tab of the Properties Palette.

12 Enter a default value.

Values for Default are used in the example fields and as example
data for schedule table columns. The Extended Data tab of the
Properties palette displays units in the same format as they appear
for Example.
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NOTE If you create a manual property, it is helpful to enter neutral
characters, such as “--,” as the default value. When you create a
schedule table, the characters fill the cells for which you have not
entered values. You can edit the characters in each cell later. If you
leave the default value blank in the property set definition, the
corresponding cells are blank. You cannot select and edit blank cells.

13 Clear Visible if you do not want this property definition to appear
on the Extended Data tab of the Properties palette.

For more information, see Hiding Properties on page 3862.

14 Enter a number for Order if you want this property definition to
appear on the Extended Data tab in a particular order.

For more information, see Sequencing Property Definitions on
page 3862.

15 Click OK.

NOTE When you attach property set data to an xref drawing or block using RefEdit
and the property set includes Auto Increment—Integer or Auto
Increment—Character, then you must set the default value to the first number to
be used in the xref or block to avoid creating duplicate numbers.

Adding a Field to a Property Set Definition
Use this procedure to add a field to a property set definition. Fields contain
updatable values or hyperlinks, and are selected from a list.

You can create a manual property as a placeholder for a field. In that case,
you enter the field in the property once it is attached to an object or style. If
you enter a field as a default value for a manual property in the definition, all
objects or styles that have the property attached already contain the field.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Select the property set definition to which you want to add a field.

4 On the Definition tab, click  .
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5 Enter the name for the property.

NOTE If this property will be used with schedule tags, do not enter
spaces in the property name.

6 Select *DEFAULT* for Start with.

7 Click OK.

8 Enter a short description of the property.

The default description is the same as the property definition
name. This text is for a column header in a schedule table that
uses this property.

NOTE The description does not change if you edit the property name.
You can edit the description.

9 Under Type, select Text.

10 If you want to create a field placeholder property that can be filled
when the property set is attached to an object or style, do not
enter a value for Default.

For information about adding fields to properties attached to
objects, see Entering Manual Properties and Fields for Objects on
page 3812.

11 If you want to set a default field used for every object or style
attached to the property set, right-click the Default column, and
click Insert Field.
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12 Under Field Category, select the desired category.

13 Under Field names, select the field you want to enter.

Some field names require additional information, like a file name
or field property information.

14 Select the text format of the field text.

15 Click OK.

Adding an Automatic Property Definition to a Property Set
Definition

Use this procedure to add an automatic property definition to a property set
definition. The values for automatic properties are obtained directly from an
object or its style. Selecting a format for this property definition controls how
these values display. For general information about automatic properties and
additional explanation about some properties for walls, slabs, roof slabs, doors,
and structural members, see Understanding Automatic Properties on page 3826.

NOTE Ensure that the property data formats you want to use are stored in the
current drawing. For more information, see Property Data Formats on page 3802.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .
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The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Select the property set definition to which to add the automatic
property.

4 Click the Definition tab.

5 Click  .

6 Select one property for each object to which the property set
definition applies.

For example, if the definition applies to windows and window
assemblies, you can select the Width property for windows and
the Width property for window assemblies. A warning is displayed
if you select different properties from different object types.

NOTE If the property set definition applies to only one object, you
can create multiple automatic property definitions at the same time
by selecting multiple items on the Automatic Property Source
worksheet. If the property set definition applies to more than one
object, you can only create one property definition at a time. Typically,
you would like to select items with the same name for every object
the property set definition applies to. Selecting or clearing an item
for one object selects or clears items with the same name for all other
objects. You can control the selection of individual items by pressing
CTRL.

7 Click OK.

8 Click on the value for Description, enter a short description of
the property definition, and click OK.

The default description is the same as the property definition
name. This is the default text for a column header in a schedule
table that uses this property.

NOTE The description does not change if you edit the property name.

9 Select a format to specify the how the data displays.

The format you select becomes the default format of a column
when this property is added to a schedule table style. It can be
changed at any time. The Example column shows how the default
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value is displayed using the selected format. For more information,
see Property Data Formats on page 3802.

10 Clear Visible if you do not want this property definition to appear
on the Extended Data tab of the Properties palette.

For more information, see Hiding Properties on page 3862.

11 Enter a number for Order if you want this property definition to
appear on the Extended Data tab in a particular order.

For more information, see Sequencing Property Definitions on
page 3862.

12 Click OK.

Adding a Location Property Definition to a Property Set
Definition

Use this procedure to add a location property definition to a property set
definition. Location property values are obtained from property data on AEC
polygons or spaces in or near an object. When a selected object has a property
set that contains a location property, a Data Location grip is displayed along
with its other grips. If the location property is defined to retrieve property
data from a space object, for example, and the property data comes from the
space underneath the grip, then the grip moves when the object is moved. If
an MvBlock representing a piece of furniture is moved from one space to
another, it has access to the space’s property data, which might include the
occupant of a room.

A location property definition is a type of automatic property, because the
value it displays is determined automatically, based on its definition, and
cannot be edited directly. To create a location property definition, you select
a property definition contained in a property set definition that can be applied
to AEC polygons or space objects.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Select the property set definition that you want to change.

4 On the Definition tab, click  .
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5 Enter a name for the location property.

6 Clear Use property name for description if you do not want to
use the location property as the description of the property.

7 Expand AEC Polygon or Space.

8 Expand a property set definition.

9 Select the property data you wish to retrieve.

10 Click OK.

To change the name of the property definition, click Name and
double-click the property definition in the table, or select Edit
Location. If Use property name for description is not set, edit the
description.

11 Select a property data format to specify the method used to display
the data included in the definition.

The format you select becomes the default format of a column
when this property is added to a schedule table style. It can be
changed at any time. The Example column shows how the default
value is displayed using the selected format.

12 Clear Visible if you do not want this property definition to appear
on the Extended Data tab of the Properties palette.

For more information, see Hiding Properties on page 3862.

13 Enter a number for Order if you want this property definition to
appear on the Extended Data tab in a particular order.

For more information, see Sequencing Property Definitions on
page 3862.

14 Click OK.

Adding a Classification Property Definition to a Property Set
Definition

Use this procedure to add a classification property definition or its properties
to a property set definition. Including classifications or classification properties
in a property set definition for schedules enables you to report classification
data for the objects in a schedule table.

For example, if you have a classification definition for vendors, you can specify
the vendor for different object types. You can then include the vendor
classification or its properties in a property set definition and use the
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classification properties in a schedule table for the objects. For more
information, see Attaching Property Set Definitions to a Classification
Definition on page 3881.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Click the property set definition that you want to change.

For example, if you want to include classifications in a door
schedule, select a property set definition that applies to door styles.

4 Click the Definition tab.

5 Click  .

The Classification Property Definition dialog is displayed. The
pane on the left lists classification definitions that apply to the
object style for the current property set definition. For example,
if the current property set definition applies to door styles, the
Classification pane lists all the classification definitions that apply
to door styles.

The pane on the right lists all the properties that apply to the
classification definitions.

Example of the Classification Property Definition dialog

6 Enter a name for the property.

The name identifies the property in the property set definition.
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7 Clear Use classification name for description if you do not want
to use the classification name for the description of the property.

By default, schedule table styles use the description for the column
heading. The default description for classification properties
comprises the names of the classification definition, the property
set definition, and the property (such as Vendor - Vendor Class -
Delivery Date).

8 Select the classification or the classification property to add to
the property set:

Then…If you want to…

in the left pane, select the classifica-
tion definition.

include the value specified for each
object for a classification definition

in the left pane, select the classifica-
tion definition. In the right pane,

include the value of a property that
is attached to a classification

select Classification Property, ex-
pand the property set, and select
the property.

Selecting a classification property

9 Click OK, and continue working on the property set definition
on the Definition tab of the Property Set Definition dialog.

10 If Use classification name for description was not selected, enter
a description for the new property by selecting the empty value,
entering text for Description, and clicking OK.
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To change the name of the property definition, double-click the
value for Name.

11 Select a format to specify the how the data displays.

The format you select becomes the default format of a column
when this property is added to a schedule table style. It can be
changed at any time. The Example column shows how the default
value is displayed using the selected format. For more information,
see Property Data Formats on page 3802.

12 Clear Visible if you do not want this property definition to appear
on the Extended Data tab of the Properties palette.

For more information, see Hiding Properties on page 3862.

13 Enter a number for Order if you want this property definition to
appear on the Extended Data tab in a particular order.

For more information, see Sequencing Property Definitions on
page 3862.

14 Click OK.

Adding a Material Property Definition to a Property Set
Definition

Use this procedure to add a material property definition to a property set
definition. Material property values are obtained from an object’s component
materials or from property data specified for an object’s component materials.

A material property definition is a type of automatic property, because the
value it displays is determined automatically, based on its definition, and
cannot be edited directly.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Select the property set definition that you want to change.

4 On the Definition tab, click  .

5 Enter a name for the material property.
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6 Clear Use material name for description if you do not want to use
the material property as the description of the property.

7 Select a material:

Then…If you want to…

select a Material in the left pane.retrieve the name of a material
specified for a component on an
object or style

select Material Property in the right
pane.

retrieve property data for the mater-
ial specified for a component on an
object or style

8 Click OK, and continue working on the property set definition
on the Definition tab of the Property Set Definition dialog.

9 If Use material name for description was not selected, enter a
description for the new property by selecting the empty value,
entering text for Description, and clicking OK.

To change the name of the property definition, double-click the
value for Name.

10 Select a format to specify the how the data displays.

The format you select becomes the default format of a column
when this property is added to a schedule table style. It can be
changed at any time. The Example column shows how the default
value is displayed using the selected format. For more information,
see Property Data Formats on page 3802.

11 Clear Visible if you do not want this property definition to appear
on the Extended Data tab of the Properties palette.

For more information, see Hiding Properties on page 3862.

12 Enter a number for Order if you want this property definition to
appear on the Extended Data tab in a particular order.

For more information, see Sequencing Property Definitions on
page 3862.

13 Click OK.
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Adding a Project Property Definition to a Property Set Definition
Use this procedure to add a project property definition to a property set
definition. Project property values are obtained from the drawing management
project in which an object is located. Project properties let you collect and
display specific project details in a schedule table, such as:

■ mobile, fax, and telephone numbers of the project principal, manager,
and architect

■ contact information for public services

■ sources for site information

A project property definition is a type of automatic property. The values
displayed are determined by the information previously entered in the project
and cannot be edited directly in the property definition. If, while working in
the project, you modify project details that are included in the property
definition and a schedule, the schedule displays the out-of-date marker. For
more information, see Turning Off the Out-of-Date Marker on page 3752.

In order for a project property definition to return correct project data, a
drawing management project must be currently open, and the drawing
containing the object must be part of that project. Not meeting either of these
conditions has the following consequences:

■ The data on the Extended Data tab of the Properties palette and on similar
dialogs is displayed as “No Project.”

■ Attributes of schedule tags that display project data are not updated.
Attributes display data as updated from the last time the conditions were
met and the drawing was saved. In this case, the data displayed may not
be accurate.

■ Schedule tables that display project data in one or more cells are not
updated. Schedule tables display data as updated from the last time the
conditions were met and the drawing was saved. In this case, the data
displayed may not be accurate.

These conditions allow drawings that contain project data to be viewed and
plotted when drawing management is not available.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.
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2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Select the property set definition that you want to change.

4 On the Definition tab, click  .

5 Enter a name for the project property.

6 Clear Use project information for description if you do not want
to use the project property as the description of the property.

7 Select the project information to include in the property
definition.

8 Click OK, and continue working on the property set definition
on the Definition tab of the Property Set Definition dialog.

9 If Use project information name for description was not selected,
enter a description for the new property by selecting the empty
value, entering text for Description, and clicking OK.

To change the name of the property definition, double-click the
value for Name.

10 Select a format to specify the how the data displays.

The format you select becomes the default format of a column
when this property is added to a schedule table style. It can be
changed at any time. The Example column shows how the default
value is displayed using the selected format. For more information,
see Property Data Formats on page 3802.

11 Clear Visible if you do not want this property definition to appear
on the Extended Data tab of the Properties palette.

For more information, see Hiding Properties on page 3862.

12 Enter a number for Order if you want this property definition to
appear on the Extended Data tab in a particular order.

For more information, see Sequencing Property Definitions on
page 3862.

13 Click OK.

Adding an Anchor Property Definition to a Property Set
Definition

Use this procedure to add an anchor property definition to a property set
definition. Anchor property definitions allow one object to get data from
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another object to which it is anchored. For example, an anchor property of a
door in a 2-hour fire-rated wall could display the 2-hour fire-rating of the wall
with an anchor property definition specified. The information displayed
cannot be edited directly.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Select the property set definition that you want to change.

4 On the Definition tab, click  .

5 Enter a name for the anchor property.

6 If you do not want to use the property name for the description,
clear Use property name for description.

7 Select the property definition to be associated with this property
set.

8 Click OK, and continue working on the property set definition
on the Definition tab of the Property Set Definition dialog.

9 If Use property name for description was not selected, enter a
description for the new property by selecting the empty value,
entering text for Description, and clicking OK.

To change the name of the property definition, double-click the
value for Name.

10 Select a format to specify the how the data displays.

The format you select becomes the default format of a column
when this property is added to a schedule table style. It can be
changed at any time. The Example column shows how the default
value is displayed using the selected format. For more information,
see Property Data Formats on page 3802.

11 Clear Visible if you do not want this property definition to appear
on the Extended Data tab of the Properties palette.

For more information, see Hiding Properties on page 3862.

12 Enter a number for Order if you want this property definition to
appear on the Extended Data tab in a particular order.

For more information, see Sequencing Property Definitions on
page 3862.

13 Click OK.
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Adding a Graphic Property Definition to a Property Set
Definition

Use this procedure to add a graphic property definition to a property set
definition. Graphic property values can be blocks in the current drawing or
image files, such as BMP, GIF, JPG, PNG, or TIF. The image displayed cannot
be edited directly.

Schedules display blocks as graphic properties only if the blocks exist in the
current drawing and if the block is not annotative. If you copy a schedule or
a schedule table style to a new drawing, make sure that you also copy all
blocks.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Select the property set definition that you want to change.

4 On the Definition tab, click  .

5 Enter a name for the graphic property.
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6 Specify a source for the graphic property:

Then…If you want to…

select Block, and select the block
name from the drop-down list.

select a block from the current
drawing

select Block, click Browse, select a
block, and click Open.

select a block from outside of the
current drawing

select Block, click Browse, select a
drawing, and click Open.

select a drawing file

select Image, and click Browse. In
the Select Image File dialog, browse

select an image file

to select the image, and click Open.
Select the path type from the drop-
down list. Using relative paths
makes your project more portable.

7 If you want to enter a new description in the property set
definition, clear Use block or image name for property description.

8 For Rotation, enter an angle for the graphic.

9 If you want to change the layer key, click Select Layer Key.

10 Click OK, and continue working on the property set definition
on the Definition tab of the Property Set Definition dialog.

11 If Use graphic name for description was not selected, enter a
description for the new property by selecting the empty value,
entering text for Description, and clicking OK.

To change the name of the property definition, double-click the
value for Name.

12 Select a format to specify the how the data displays.

The format you select becomes the default format of a column
when this property is added to a schedule table style. It can be
changed at any time. The Example column shows how the default
value is displayed using the selected format. For more information,
see Property Data Formats on page 3802.

NOTE Images and blocks are uniformly scaled to fit within the table
cell. The cell dimension is determined by the row height and column
width.
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13 If you do not want this property definition to appear on the
Extended Data tab of the Properties palette, clear Visible.

For more information, see Hiding Properties on page 3862.

14 If you want this property definition to appear on the Extended
Data tab in a particular order, enter a number for Order.

For more information, see Sequencing Property Definitions on
page 3862.

15 Click OK.

Sequencing Property Definitions
Use this procedure to specify the order in which properties are listed on the
Extended Data tab of the Properties palette. When you have many object
properties in a property set definition, it can be helpful to see the most
important properties first rather than the default alphabetical order. Items
with numbers appear before items without numbers.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Select the property set definition that you want to change.

4 On the Definition tab, select the property, and enter a number
value for Order to specify the sequence in which the property is
to appear on the Properties palette.

5 Click OK.

Hiding Properties
Use this procedure to prevent properties from being listed on the Extended
Data tab of the Properties palette. If the object has many properties associated
with it, it could be helpful to exclude some of the less important properties
from displaying on the Properties palette.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 Select the property set definition that you want to change.
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4 Click the Definition tab, select the property, and clear Visible if
you do not want the property to display on the Properties palette.

5 Enter a name for the graphic property.

6 Click OK.

Editing a Property Set Definition
Use this procedure to perform any of the following edits on a property set
definition.

■ change the objects or styles to which the property set can be attached.

■ add and remove properties.

■ change the name, description, and format of properties.

■ change additional items for each type of property definition.

■ change the visibility and the display order on the Properties palette.

Changes are immediately applied to any objects or styles attached to the
property set that was created from the definition. If automatic update is
specified for a schedule table, the changes also appear in the schedule table.
If automatic update is not specified, you need to update the table.

NOTE If you remove a property that is used in a schedule table, INVALID is
displayed for value in the table.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, and expand Property Set
Definitions.

3 To change how the property set is applied, click the Applies To
tab, and specify objects or styles:

Then…If you want to…

select Objects, and select the ob-
jects to which the property set can

apply the property set created from
this definition to objects

be attached. For more information,
see Specifying How the Property
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Then…If you want to…

Set Definition is Applied on page
3843.

select Styles and Definitions, and
select the styles and definitions to

apply the property set created from
this definition to styles or definitions

which the property set can be at-
tached.

4 Click the Definition tab.

5 Edit the characteristics for each property definition:

Then…If you want to…

click Name. Enter a new name, and
press ENTER. For more information,

edit the name of a manual property
definition

see Adding a Manual Property
Definition to a Property Set Defini-
tion on page 3845.

select the description, enter new
text, and click OK.

edit a manual property definition
description

select type, default, format, visibil-
ity, or order and make your

edit the type of data, default value,
format, visibility, or order of a
manual property definition changes. If a property definition is

not visible, you cannot enter a value
for Order.

after the format is assigned, select
a new value for Units.

edit how the units display for a
manual property definition

select definition, source, format,
visibility or order and make your

edit an automatic property defini-
tion

changes. You cannot change the
data type or default value of auto-
matic properties.For more informa-
tion, see Adding an Automatic
Property Definition to a Property
Set Definition on page 3849.

double-click the formula property
definition. Change the name, clear

edit a formula property definition
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Then…If you want to…

or select Use formula for descrip-
tion, and modify the formula by
entering data or selecting property
definitions. Click OK. Select the
source, format, visibility, or order
and make your changes. For more
information, see Adding a Formula
Property Definition to a Property
Set Definition on page 3830.

double-click the location property
definition. Change the name, clear

edit a location property definition

or select Use property name for de-
scription, and select a property
definition. Click OK. Select the
source, format, visibility, or order
and make your changes. For more
information, see Adding a Location
Property Definition to a Property
Set Definition on page 3851.

double-click the classification prop-
erty definition. Change the name,

edit a classification property defini-
tion

clear or select Use classification
name for description, select from
the classification definitions avail-
able in the left pane, and select a
classification property from the
right pane with Classification Prop-
erty selected. Click OK. Select the
source, format, visibility, or order
and make your changes. For more
information, see Adding a Classific-
ation Property Definition to a Prop-
erty Set Definition on page 3852.

double-click the material property
definition. Change the name, clear

edit a material property definition

or select Use material name for de-
scription, select from the materials
available in the left pane, and select
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Then…If you want to…

a material property from the right
pane with Material Property selec-
ted. Click OK. Select the source,
format, visibility, or order and make
your changes. For more informa-
tion, see Adding a Material Property
Definition to a Property Set Defini-
tion on page 3855.

double-click the project property
definition. Change the name, clear

edit a project property definition

or select Use project information
name for description, select from
the project information available,
and click OK. Select the source,
format, visibility, or order and make
your changes. For more informa-
tion, see Adding a Project Property
Definition to a Property Set Defini-
tion on page 3857.

double-click the anchor property
definition. Change the name, clear

edit an anchor property definition

or select Use property name for de-
scription, select a property defini-
tion, and click OK. Select the
source, format, visibility, or order
and make your changes. For more
information, see Adding an Anchor
Property Definition to a Property
Set Definition on page 3858.

double-click the graphic property
definition. Change the name, select

edit a graphic property definition

a new block or image for Source,
clear or select Use block (or image)
name for description, change the
scale and rotation, and click OK.
Select the format, visibility, or order
and make your changes. For more
information, see Adding a Graphic
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Then…If you want to…

Property Definition to a Property
Set Definition on page 3860.

select a property, and click  .
For more information, see Remov-

remove a property from the prop-
erty set definition

ing All Property Sets from Objects
and Styles on page 3867.

6 Click OK.

NOTE Property data format styles, property set definitions, and schedule table
styles cannot be changed through RefEdit. Changes seem to work, but will revert
to the previous settings when saved back to the xref file. Open the xref drawing
directly, and make the changes there.

Removing All Property Sets from Objects and Styles
Use this procedure to remove a property set that no longer applies to the
objects and object styles to which it is attached.

If you remove an object or style from the Applies To list in a property set
definition after the property set based on the definition is attached to the
object, the property set is not automatically removed. This allows you to
retrieve data that might have been entered for manual properties.

1 On the command line, enter PropertySetClean, and press ENTER.

2 Enter the name of the property set that you want to remove, or
press ENTER to remove all the property sets from all objects or
styles.

Merging Property Set Definitions
Use this procedure to replace one property set definition with another for all
objects or object styles.

1 On the command line, enter PropertySetDefMerge, and press
ENTER.

2 Enter the name of the property set definition that you want to
keep, and press ENTER.
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3 Enter the name of the property set definition that you want to
merge, and press ENTER.

4 Specify whether to purge the merged property set definition:

Then…If you want to…

enter y (yes), and press ENTER.purge the property set definition
that you merged

press ENTER.keep the merged property set
definition in the drawing

If you keep the merged property set definition in the drawing, it
is not attached to any objects.

5 Specify whether to remove property sets:

Then…If you want to…

enter y (yes), and press ENTER.remove the property sets that do
not apply after the merge

press ENTER.keep the property sets attached to
objects and styles even though they
may not apply

List Definitions
A list definition is a multi-purpose object that lets you create a list of items to
use in a manual property definition. After you create a list definition, values
can be selected from the list without having to enter them manually each
time.

For example, if you create a predefined list of acceptable values for paint color
or manufacturers, you remove the risk of forgetting a correct name or making
a typographical error when setting up manual properties. Create the list once,
copy it into the appropriate project files as needed, and then you can easily
select values for manual properties when you add them to property definitions.
For more information, see Adding a Manual Property Definition to a Property
Set Definition on page 3845.
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Creating a List Definition for a Manual Property Definition
Use this procedure to create a list definition with a list of items that can be
used for manual properties.

NOTE List definitions can also be created for space and zone names. For more
information, see Creating a List Definition on page 3111.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Multi-Purpose Objects, right-click List Definitions, and
click New.

3 Create a list definition:

Then…If you want to…

right-click List Definitions, and click
New.

create a definition with default
properties

right-click the list definition you
want to copy, and click Copy.
Right-click, and click Paste.

create a definition from an existing
definition

4 Enter a name for the new list definition, and press ENTER.

5 On the General tab, enter a description for the list definition
under Description.

6 Click the Applies To tab, and select Manual Property Definition.
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You can clear the list definition from applying to a manual
property definition only if it is not in use.

7 Click the Items tab.

8 Select Allow individual property values to vary from this list if
you want to allow values other than those specified here to be
displayed on the Properties palette.

9 Click Add, and enter a value for Name.

10 Enter a value for Description.

11 Continue to add values to this list definition.

12 Click OK.
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Editing List Definitions
Use this procedure to edit or remove items in a list definition. You can remove
only those items that are not currently in use.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand List Definitions.

3 Select the list definition.

4 Click the Items tab, and edit the list:

Then…If you want to…

select the property and edit the text
under Name.

edit the name of the property

select the property and edit the text
under Description.

edit the property description

5 Click OK.

6 To remove an item from the list definition, select the item, and
click Remove.

If the Remove button is unavailable, you cannot delete the
property because it is currently assigned to an object, or it is in a
property set definition that is in use.

7 Click OK.

Changing the List Item for an Object
Use this procedure to change a list item on the Properties palette for an object.
If you specified that property values for the item could vary from the list, you
can enter a new value on the Properties palette.

1 Double-click the object to select a different list item.

2 On the Properties palette, click the Extended Data tab.

3 Select a different list item, or enter a new value.

If entering a new value is not an option on the Properties palette,
open the list definition and select Allow individual property values
to vary from this list. For more information, see Creating a List
Definition for a Manual Property Definition on page 3869.
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Attaching Notes or Reference Files to a List Definition
Use this procedure to enter notes and attach reference files to a list definition.
You can also edit notes and edit or detach reference files from a list definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Multi-Purpose Objects, and expand List Definitions.

3 Select the list definition to which to attach notes or reference
files.

4 On the General tab, enter a description for the list definition
under Description

5 To add a note, click Notes, click the Notes tab, and enter the note.

6 Click Notes, click the Reference Docs tab, and attach, edit, or
detach a reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

7 Click OK twice.

Classification Definitions
A classification definition is a group of named properties or characteristics
that you can assign to building objects such as walls and doors. Classifications
enable you to track objects by construction status, project phase, building
element, vendor, or other criteria. A classification definition is applied to an
object type. The definition contains classification names and descriptions.
Each classification can have property sets attached to it.
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Classifications and Schedule Tables

Classifications provide additional control over the content of schedule tables.
You can include:

■ only those objects that meet the classification criteria.

■ classification definitions as columns.

■ additional information from property sets you create and attach to
individual classifications.

Uses for Classifications

Here are some examples of classification definitions:

■ Classifications for multi-view blocks enable you to distinguish among
blocks to use for furniture, appliances, fixtures, and equipment

■ Classifications for project phases can call out changes specified for new or
demolition work and existing structure to remain

■ Classifications for door types let you filter partition doors in bathrooms
from door schedules

Classifications and the Display System

You can modify display sets in a display configuration to show or hide objects
based on their classification. For more information, see Displaying Objects by
Classification on page 840.

Managing Classification Definitions

Classifications are organized in a hierarchical view in the Style Manager.
Classification names must be unique within classification property definitions.
To create, edit, copy, or purge classification definitions, you access the Style
Manager. The Style Manager provides a central location for working with
definitions and styles from multiple drawings and templates. For more
information about using the Style Manager, see Style Manager Overview on
page 870.

After classifications are applied to objects in the classification definition, they
display on the Extended Data tab of the Properties palette when the object is
selected. You can change the classification for an object from the Extended
Data tab in the Select Classification worksheet. If the classification change
results in an object not displaying in your drawing window, a warning dialog
displays. You can also open the object style in the Style Manager and make
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changes on the Classifications tab. For more information, see Changing the
Classification of an Object on page 3884.

Process Overview: Including Classification Data in Schedules
The process of including classification data for objects in a schedule table has
the following major steps:

1 Create a classification definition, and specify the object type to which it
is applied. For more information, see Creating a Classification Definition
on page 3877.

2 Create and attach property sets to the classifications in the classification
definition. For more information, see Attaching Property Set Definitions
to a Classification Definition on page 3881.

3 Specify the classification for each object type that you want to schedule.
For more information, see Specifying the Object Types for a Classification
Definition on page 3878.

4 Add the classification or its properties to a property set definition for the
object type. For more information, see Adding a Classification Property
Definition to a Property Set Definition on page 3852.

5 Add the classification or its properties as columns in a schedule table
style that uses the property set definition you edited in step 4. For more
information, see Adding Columns to a Schedule on page 3777.

6 If necessary, specify filtering options for classifications in the schedule
table style. For more information, see Filtering Scheduled Objects by
Classification in a Schedule Table Style on page 3776.

7 Create the schedule table. For more information, see Adding Schedules
Using Schedule Table Tools on page 3747.

The classification information for each object is included in the columns you
added to the schedule table style.

A Classification Use Case
You can create a classification definition that contains a classification for each
construction status, such as Existing, Demo, and New.
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Creating a classification definition for construction status

You also specify the objects to which the classification definition applies.

Specifying object types in the classification definition

The classification definition is listed on the Classifications tab in the object
style properties. You select a classification, such as New, in the object style.
For example, your drawing might contain certain door styles for existing doors,
and different styles for new construction. All doors created from these styles
have the classification specified in their style.
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Door style with the classification specified

When you are ready to schedule doors, you can specify in the schedule table
style that only those doors with the New classification will be included. Any
other doors included in the selection set are filtered from the table.

Specifying classification criteria in a schedule table style

You can also include classifications as a column in your schedule tables. You
can create and attach property sets to individual classifications to track
additional data, and you can include this data in schedule tables. In addition,
you can modify settings in the display system to filter the display of objects
based on their classification.
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You can change the classification of a specific object on the Extended Data
tab of the Properties palette. If this change causes an object to not display, a
warning dialog appears on your drawing screen.

Changing classification on the Extended Data tab

Creating a Classification Definition
Use this procedure to create a classification definition. You can create a
definition using default properties or by copying an existing definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Classification
Definitions.

3 Create a classification definition:

Then…If you want to…

right-click Classification Definitions,
and click New.

create a definition with default
properties
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Then…If you want to…

right-click the classification defini-
tion you want to copy, and click
Copy. Right-click, and click Paste.

create a definition from an existing
definition

4 Enter a name for the new classification definition, and press ENTER.

5 Edit the classification definition:

Then…If you want to…

click the General tab, and enter the
description.

enter a description of the classifica-
tion definition

see Specifying the Object Types for
a Classification Definition on page
3878.

specify the object types to which
the definition applies

see Adding Classifications to a
Classification Definition on page 3879.

enter classifications

see Attaching Property Set Defini-
tions to a Classification Definition
on page 3881.

attach property sets to the individu-
al classifications in the definition

see Attaching Notes and Files to a
Classification on page 3884.

add notes or files to the definition

6 Click OK.

Specifying the Object Types for a Classification Definition
Use this procedure to specify the object types to which a classification
definition applies. The classification will be listed on the style’s Classification
tab for all object types you specify.

For example, if you specify that a classification definition applies to doors and
windows, the classification is listed on the Classifications tab for all door and
window styles in the drawing. You can also select an individual classification
appropriate for each door and window object on the Extended Data tab of
the Properties palette. For more information about specifying a classification
for a particular type of object, see the topic for that object type in the online
Help and Displaying Objects by Classification on page 840.
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1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Classification
Definitions.

3 Select the classification definition.

4 On the Applies To tab, select the object types to which the
classification definition will apply.

5 Selecting object types to which a classification definition applies

6 Click OK.

Adding Classifications to a Classification Definition
Use this procedure to add classifications to an existing classification definition.
Classifications are individual entries organized hierarchically within a
classification definition. For example, a classification definition for
construction status may contain the classifications existing, demo, and new.
Lower-level classifications can be added to each of these classifications.

NOTE Be sure to specify the object types to which the classification definition
applies. The classifications are not available until you specify the object types in
the classification definition. For more information, see Specifying the Object Types
for a Classification Definition on page 3878.

Due to the connection of classifications to the definition of display sets,
classification definitions can only be purged from Style Manager if none of
the classifications contained in them is used to filter out objects from a display
set. If you encounter difficulty in purging a classification definition in Style
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Manager, do the following: Open Display Manager, and for each display set,
verify that on the Display Options tab, all classifications in that set are selected.

If one or several of the classifications are unchecked and therefore serve as a
filter for a display set, the purge operation cannot be completed. For more
information about Display Sets, see Display Sets on page 808.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Classification
Definitions.

3 Select the classification definition.

4 On the Classifications tab, click Add.

5 Select the new classification, and enter a name under Item.

6 Under Description, enter a description of the classification.

Adding classifications to a classification definition

7 Continue adding classifications.
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8 Select any of the classifications added, and drag and drop them
to organize the hierarchy as desired.

9 Click OK.

Attaching Property Set Definitions to a Classification Definition
Use this procedure to add property set definitions to individual classifications
in a classification definition. When you add property set definitions, you can
track additional information.

For example, if you create a classification definition for vendors, you can
attach a property set to each vendor classification. The property sets can
contain any properties that you specify, such as a vendor–specific part number.
The properties are then associated with each object to which the classification
is applied. These properties can then be included in the schedule table when
the objects are scheduled.

For more information about creating property sets, see Property Set Definitions
on page 3823. For more information about adding classification property data
to property set definitions, see Adding a Classification Property Definition to
a Property Set Definition on page 3852.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Classification
Definitions.

3 Select the classification definition.

4 On the Classifications tab, select one or more classifications, and
click Property Sets.

Selecting a classification to which you attach property sets
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5 Click  .

6 Clear property sets that you do not want to attach to the
classification, and click OK.

Clearing property sets you do not want to attach to classifications

7 Enter values for the property data, and click OK.

You can enter or edit values later, if necessary.

Entering data for a property set attached to a classification

8 Continue attaching property sets to other classifications.

9 Click OK.

Editing a Classification Definition
Use this procedure to edit or remove classifications in a classification definition,
to add or edit data in property sets attached to classifications, and to detach
property sets from classifications.
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NOTE You can remove only those classifications not currently applied to an object
type. You cannot delete classifications that are in use.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Classification
Definitions.

3 Select the classification definition.

4 On the Classifications tab, edit classifications:

Then…If you want to…

select the classification, edit the text
under Item, and click OK.

edit the classification name

select the classification, edit the text
under Description, and click OK.

edit the classification description

select the classification, and click
Property Sets. Enter or edit property
data, and click OK.

add or edit property set data in
property sets already attached to a
classification

5 To detach property sets from a classification, select the
classification, and click Property Sets.

6 Click  .

7 Clear the property sets you do not want to remove, and click OK.

Removing property sets from a classification

Editing a Classification Definition | 3883



8 Click OK.

9 To remove a classification, select the classification, and click
Remove.

If the Remove button is unavailable, you cannot delete the
classification because it is currently assigned to an object type.

10 Click OK.

Changing the Classification of an Object
Use this procedure to change the classification of an object in your drawing.
Only classifications defined for and applied to that specific object are available
for selection. For more information, see Creating a Classification Definition
on page 3877.

Classifications, but not their descriptions, are listed for objects and styles on
the Classifications tab in the Style Manager. If descriptions have been entered,
you can view them in the classification definition under Multi-Purpose Objects
in the Style Manager.

1 Double-click the object for which you want to change a
classification.

2 On the Properties palette, click the Extended Data tab.

3 Select the classification you want to change.

4 On the Select Classification worksheet, select a different
classification, and click OK.

Attaching Notes and Files to a Classification
Use this procedure to enter notes and attach reference files to a classification
definition. You can also edit notes and edit or detach reference files from a
definition.

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

2 Expand Multi-Purpose Objects, and expand Classification
Definitions.

3 Select the classification definition that you want to change.

4 Click the General tab.

5 To add a description to the definition, enter it for Description.

6 Click Notes.
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7 Enter the note on the Notes tab.

8 Click the Reference Docs tab, and attach, edit, or detach a
reference file:

Then…If you want to…

click Add, select a file, and click OK.attach a reference file

select the file, and click Edit. Enter
the description, and click OK.

edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click De-
lete.

detach a reference file

9 When you finish making changes to the classification definition,
click OK.

Display Themes
Display themes use color, fills, and hatches to present data that is not typically
visible in a drawing. For example, you can specify that all 2-hour fire-rated
walls appear with a red fill. The display theme legend activates the display
theme in the drawing and identifies the meaning of the different colors, fills,
or hatches used in the theme.

The data for display theme legends is collected from the property set data
attached to the objects or object styles. Styles for display themes are specified
in the Style Manager under Documentation Objects.

Process Overview: Creating Display Themes
Typically, manual properties of an object—such as a wall’s fire rating or a
door’s manufacturer—are not visible in a drawing. Display themes let you
incorporate such non-graphic data in your drawing by using certain colors,
fills, or hatches to highlight objects that meet criteria (theme rules) you
establish in a display theme style. For example, you might define a property
named Function for room objects, and then set up a theme rule specifying
that rooms with a Function value equal to “storage” will be displayed with a
solid yellow fill.
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You activate a display theme in a drawing by using a display theme tool to
insert a display theme legend, which explains the meaning of color, fills, or
hatches specified in the theme.

If you use display theme styles provided with AutoCAD Architecture 2012,
the property set definitions and property data formats for the style are already
created for you. You can begin the process of creating a display theme from
Step 4.

Create and implement a display theme by following these basic steps:

1 Create property data formats (or modify existing ones as necessary) to
specify formats for properties you want to include in the theme. For more
information, see Creating a Property Data Format on page 3805.

These formats determine how data is displayed in the display theme
legend.

2 Create or modify property set definitions for objects or object styles
incorporating formats from Step 1. For more information, see Creating
a Property Set Definition on page 3841.

3 Create or modify a display theme style. For more information, see Creating
a Display Theme Style on page 3894.

The legend is a key that incorporates the property set definitions from
Step 2 to specify which visual indicator will be applied to which objects
in the drawing and what the content of the display theme legend will
be.

4 Attach property set data to the objects and object styles to be included
in your display theme. For more information, see Attaching Property Set
Data to Objects on page 3811.

5 Activate the display theme by adding the display theme legend to the
drawing or activating an existing legend. For more information, see
Adding a Display Theme to a Drawing on page 3890.

Creating and Editing Display Themes
When you use a display theme in a drawing, you can show data that is not
typically visible. For example, you can use different hatches to designate
different functional areas within a building. Typically, manual properties of
an object—such as a wall’s fire rating or a door’s manufacturer—are not visible
in a drawing. Display themes let you incorporate such non-graphic data in
your drawing by using certain colors, fills, or hatches to highlight objects that
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meet criteria (theme rules) you establish in a display theme style. For example,
you might define a property named Function for room objects, and then set
up a theme rule specifying that rooms with a Function value equal to “storage”
will be displayed with a solid yellow fill.

You activate a display theme in a drawing by using a display theme tool to
insert a display theme legend or by activating an existing legend. The legend
explains the meaning of color, fills, or hatches specified in the theme.

Display themes are an effective way to present information during the
conceptual design phase of a project, or when working with construction
documents. With display themes you can identify changes to a project that
are not in the contract, identify the staging of a project, and identify objects
that meet or do not meet specific standards. For example, you may choose to
specify that all fire-rated walls are displayed with red fills.

The criteria for the display theme are based on the property data attached to
the objects or object styles. The property data overrides the display properties
to produce the visual effects produced by inserting a display theme. For more
information about how objects display and their property data, see Display
Configurations on page 810 and Property Sets and Property Set Definitions on
page 3743.

If you use the drawing as an external reference (xref) in a project, the display
theme is imported into the host drawing by default. If the host drawing already
contains a display theme, then the display theme in the host drawing overrides
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the display theme in the xref. A marker appears over the disabled display
theme legend.

Attaching Property Set Data

Before applying a display theme to a drawing, the property sets referenced in
the display theme style must be attached to the objects or object styles in the
drawing. The attached property sets are the source of the data for the display
theme. For more information, see Property Sets and Property Set Definitions
on page 3743.

Using Display Theme Styles

Display theme styles control the visual change to the objects as well as the
content and appearance of the display theme legend in the drawing. A drawing
must contain a display theme style to effect the visual changes or to add a
display theme legend. When you copy a display theme style into a drawing,
property set definitions and data formats specified in the style are also copied.
For more information, see Display Theme Styles on page 3893.

Creating a Display Theme Legend Using Display Theme Tools

A display theme legend provides a key to the display theme, mapping specific
colors, fills, or hatches to properties of objects in a drawing. You insert a
display theme legend into a drawing to activate a display theme and visually
change the appearance of objects by overriding the current display properties.

The tools provided let you quickly place display theme legends by selecting
a display theme tool with a specific display theme style and other predefined
properties. When you place display theme legends using display theme tools,
you can use the default settings of the tool, or you can change settings for the
display theme properties. You can also use display theme tools to apply the
settings of a display theme tool to existing display themes.

The default Scheduling palette in the Tool palette set contains three sample
display theme tools that you can use and customize as needed. Custom palettes
created by your CAD manager or other users may also contain display theme
tools with display theme styles and properties that are customized for your
projects or office standards.

Creating a Display Theme Tool
Use this procedure to create a display theme tool and add it to a tool palette.
You may want to create your own display theme tools if you are creating

3888 | Chapter 50   Schedules and Display Themes



multiple display themes of specific display theme styles. The display theme
is activated when the display theme legend is inserted in the drawing with
the display theme tool. For more information, see Creating a Display Theme
Style on page 3894.

You can use any of the following methods to create a display theme tool:

■ Drag a display theme style from the Style Manager to a tool palette, and
then customize the properties of the new tool.

■ Copy a tool from another palette to the current palette, and then customize
the properties of the new tool.

■ Copy an existing tool in the current palette and then customize the
properties of the new tool.

1 Open the tool palette on which you want to create a tool.

2 Create the tool:

Then…If you want to…

click Manage tab ➤ Style & Display

panel ➤ Style Manager  . Locate

create a tool from a display theme
style in the Style Manager

the style you want to copy, and
drag it to the tool palette. Click OK
to close the Style Manager.

right-click the tool, and click Copy.
Right-click, and click Paste.

copy a tool in the current tool
palette

open the other palette, right-click
the tool, and click Copy. Reopen

copy a tool from another tool
palette

the palette where you want to add
the tool, right-click, and click Paste.

3 Right-click the new tool, and click Properties.

4 Enter a name for the tool.

5 Click the setting for Description, enter a description of the tool,
and click OK.

6 Expand General.
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7 Specify general properties for the display theme:

Then…If you want to…

enter text for Description.add a description

click the setting for Layer key, select
a layer key, and click OK.

specify the layer key

click the setting for Layer overrides.
Clear Do not specify Layer Over-

specify layer overrides

rides, select an override, and click
OK twice.

click the setting for Style, and select
a style.

specify the display theme style

click the setting for Style location,
and click Browse to specify a loca-
tion.

specify an external drawing file
source for the style

enter a value for Scale.change the scale of the display
theme legend

8 Click OK.

Adding a Display Theme to a Drawing
Use this procedure to add a display theme to a drawing by inserting a display
theme legend.

The display theme legend activates the display theme in the viewport and
identifies the meaning of the different colors, fills, or hatches used in the
theme. The data for the display theme legend is collected from the property
set data attached to the objects or object styles, as specified in the display
theme style. When you add new objects to a drawing, data is added to the
legend if it meets the criteria you specified in the display theme style. For
more information, see Display Theme Styles on page 3893.

If you insert a display theme legend while working in paper space, the legend
is attached to a viewport. If you insert a display theme legend while working
in model space, all model space viewports are affected.
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Legend for display theme based on Space Size property

To ensure that the display theme can be implemented, verify that:

■ The drawing contains a display theme style that specifies theme settings
and establishes conditions (theme rules) for those objects that you wish
to display differently. For more information, see Creating a Display Theme
Style on page 3894.

■ Property set data is attached to the objects or object styles for objects to
which you want the display theme style applied. For more information,
see Attaching Property Set Data to Objects on page 3811.

1 Open the tool palette containing the Display Theme tool you
want to use, and select the tool.

Three sample Display Theme tools are located on the default
Scheduling palette in the Tool palette set. There are additional
Display Theme tools located in the Documentation Tool Catalog
and with the Scheduling and Reporting Tools in the Stock Tool
Catalog. You can add this tool to any tool palette. For more
information, see Working with Tool Palettes on page 70.

2 In the drawing area, specify the insertion point for the upper-left
corner of the display theme legend.

3 Specify the lower-right corner of the legend, or press ENTER to
scale the display theme legend to the current drawing scale.

The objects affected by the display theme visually change in the
drawing as indicated by the legend.
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Disabling Display Themes
Use this procedure if you want to manually disable a display theme. A disabled
display theme is indicated by a marker through the legend. This does not
prevent the display theme legend from plotting on your sheet. For more
information about display properties for the legend, see Accessing the Default
Display Properties of an Object on page 824.

If you attach or overlay a drawing as an external reference (xref) in a project,
all display themes in the xref are imported into the host drawing by default.
If the host drawing has existing display themes, then the active display theme
in the host drawing overrides any active display theme in the xref.

1 Select an active display theme legend.

2 Click Display Theme tab ➤ Modify panel ➤ Disable Display Theme

 .

Disabled display theme

Activating Display Themes
Use this procedure if you want to activate a different theme. Regardless of
how many display themes you add to your drawing, only one theme at a time
can be active. If you add a display theme to a drawing that has existing themes,
the other themes are disabled. A disabled display theme is indicated by a
marker through the legend.

If you attach or overlay a drawing as an external reference (xref) in a project,
all display themes in the xref are imported into the host drawing by default.
If the host drawing has existing display themes, then the active display theme
in the host drawing overrides any active display theme in the xref.

1 Select a disabled display theme legend.

2 Click Display Theme tab ➤ Modify panel ➤ Apply Display Theme

 .
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The marker is removed from the selected legend and applied to
any others in the drawing.

Active display theme legend

Display Theme Styles
A display theme style defines a particular display theme for incorporating
non-graphic data in a drawing by highlighting objects that meet criteria you
specify. The type of highlighting is controlled through one or more theme
settings, each of which specifies a particular color fill, hatch, or linetype. For
each theme setting, there are one or more theme rules that determine which
objects will be highlighted using that setting.

The display theme style also specifies the format and display properties for
the display theme legend that identifies the data represented by the highlighted
objects.
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As you work with different display theme styles within a project, you can
synchronize the versions with your project standards. For more information,
see Synchronizing Selected Styles and Display Settings with AEC Standards
on page 659.

What You Need to Create a Display Theme Style

Your drawings must contain the following information to create a new display
theme style:

■ Property set definitions for any property data to be included in the display
theme created from the style. For more information, see Property Set
Definitions on page 3823.

■ Property data formats to control the format of values of display theme
rules. Typically, you use the data format for values that the property set
definition uses. However, you can override data formats. For more
information, see Property Data Formats on page 3802.

Creating Tools from Display Theme Styles

You can create a display theme tool from a display theme style by dragging
the style from the Style Manager onto a tool palette. You can then specify
properties for the tool. For more information, see Creating a Display Theme
Tool on page 3888.

Creating a Display Theme Style
Use this procedure to create design rules for display theme styles and to specify
the format for the legend of the display theme in the Style Manager. A display
theme changes how objects or object styles display in your drawing based on
the criteria you specify. For more information, see Creating and Editing Display
Themes on page 3886. Property set definitions must already be defined in your
drawing before you can specify one for a theme rule. For more information,
see Property Set Definitions on page 3823.

Specify the design rules for the display theme

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager  .

The Style Manager is displayed with the current drawing expanded
in the tree view.

2 Expand Documentation Objects, right-click on Display Theme
Styles, and click New.
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3 Enter a name for the new display theme style and press ENTER.

4 To add a description of the display theme style, enter it for
Description.

5 Click the Design Rules tab.

6 Click  to create a new display theme setting.

An unnamed display theme setting is created with the index
number of 1.

7 Create the settings for the display theme.

Then…If you want to…

select Unnamed and enter text for Name.specify a name for the
display theme

click the light bulb. If the light bulb is yellow,
the identifying color or hatch and the name

turn off the visibility of
the identifying color or

of the display theme are visible in the display
theme legend.

hatch for this display
theme in the display
theme legend

click BYBLOCK, and select a color from the
Select Color worksheet. For more information,

add a color to the display
theme

see “Choose Hatch Patterns and Solid Fills”
in AutoCAD Help.

TIP The quickest way to locate and view
an AutoCAD topic referenced in
Autodesk AutoCAD Architecture Help is
to click the Search tab in the Help win-
dow, select the Search titles only option,
and then copy and paste or type in the
AutoCAD topic name, and click List
Topics.

click SOLID, select a Type from the Hatch
Pattern worksheet, and click OK. For more

add a hatch pattern to
the display theme

information, see “Choose Hatch Patterns and
Solid Fills” in AutoCAD Help.
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Then…If you want to…

enter a value for Scale/Spacing. For more in-
formation, see “Hatch Tab (Hatch and Gradi-
ent Dialog Box)” in AutoCAD Help.

scale a hatch pattern for
the display theme

enter a value for Angle. For more information,
see “Hatch Tab (Hatch and Gradient Dialog
Box)” in AutoCAD Help.

change the angle of the
hatch pattern

click global.specify the orientation of
the hatch pattern from
global to object

enter a value for X Offset.specify the X offset of the
hatch pattern

enter a value for Y Offset.specify the Y offset of the
hatch pattern

click ByBlock, select a linetype, and click OK.
For more information, see “Custom Hatch
Patterns” in AutoCAD Help.

specify a Linetype for the
hatch pattern

click ByBlock, select a lineweight, and click
OK. For more information, see “Overview of
Lineweights” in AutoCAD Help.

specify a Lineweight for
the hatch pattern

enter a value for Lt Scale. For more informa-
tion, see “Work with Linetypes” in AutoCAD
Help.

specify a Linetype Scale
for the hatch pattern

click ByBlock, select a plot style, and click OK.
For more information, see “Use Plot Styles to
Control Plotted Objects” in AutoCAD Help.

specify a Plot Style for the
hatch pattern

8 Under Theme Rules for selected Theme Settings, click  .

A display theme rule is created with the index number of 1.1. This
corresponds with the display theme setting. You can create
multiple rules for each display theme.

9 Select a property set definition.
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Property set definitions that exist in the drawing appear in the
drop-down list.

10 Select a property.

The properties available are contingent upon the property set
definition you selected.

11 Select a condition.

The conditions available are contingent upon the property set
definition and property you selected.

12 Enter a value appropriate to the condition you selected.

13 Select an operator appropriate to the formula you are creating for
the display theme rules.

Specify the format for the design theme legend

14 Click the Legend Format tab.

15 For Title, enter the text you want to appear on the heading of the
display theme legend.

16 Select the shape of the symbol for the legend key as either round
or square.

17 Select a style for the text in the legend.

18 Enter the height for the text in the legend.

19 Enter the gap between words in the legend.

Specify the display properties for the display theme legend

20 Click the Legend Display Properties tab.

21 Select the display representation on which to display the changes,
and select Style Override.

The display representation in bold is the current display
representation. For more information, see Display Representations
on page 803.

22 If necessary, click  .

23 Click the Layer/Color/Linetype tab.

24 Select the component to change, and select a different setting for
the property.

25 Click OK twice.
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Troubleshooting Schedule Tables
This topic provides answers to some common questions about schedule tables
and their data:

Question Marks in Cells
I added a schedule table, but all the cells contain question marks. Why did
this happen?
Question marks appear in table cells when property sets are not attached to
the objects included in the table, or to the object styles for objects in the table.
When attached to an object or a style, a property set becomes the container
for the property data. The schedule table stores no data.

For more information about attaching property sets to objects and styles, see
Property Set Data on page 3810.

To attach property sets to objects and styles individually, select the table, click

Schedule Table tab ➤ Modify panel ➤ Edit Table Cell , and select the cell.
For more information, see Editing Table Cell Data on page 3799.

To attach property sets to all objects and styles that need them, select the
table, and click Schedule Table tab ➤ Modify panel ➤ Add All Property Sets

 . For more information, see Adding Property Set Data to All Objects on
page 3801.

For more information about attaching property sets to objects and styles, see
Attaching Property Set Data to Objects on page 3811 and Attaching Property Set
Data to Styles and Definitions on page 3814.

Object not Listed
Why is an object I added to the drawing not listed in the schedule table?
Objects added to a drawing after you add a schedule table are not added to
the table unless the Add New Objects Automatically option is selected in the
table properties. However, you can manually add objects to a table schedule.

For more information, see Adding Objects to a Schedule on page 3751.

If the schedule table style uses classifications to filter objects, review the
troubleshooting information in Troubleshooting Classification Definitions
on page 3902.
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Which Property Sets to Attach
How do I know which property sets to attach to objects or styles to remove
question marks from columns in a schedule table?

You can find this information by viewing the column definitions in the
schedule table style used to create the schedule table. Select the schedule table,
and click Schedule Table tab ➤ General panel ➤ Edit Style

drop-down ➤ Schedule Table Styles  . Select the current style, and click the
Columns tab. You can view the property assigned to each column and the
property set from which the property is obtained. Click Cancel to return to
the drawing.

The property sets provided use the words Object and Style in their names to
identify how the property set can be attached. For example, you can attach
the DoorObjects property set to doors. You can attach the DoorStyles property
set to any door style.

To attach property sets to objects and styles individually, select the table, click

Schedule Table tab ➤ Modify panel ➤ Edit Table Cell , and select the cell.
For more information, see Editing Table Cell Data on page 3799.

To attach property sets to all objects and styles that need them, select the
table, and click Schedule Table tab ➤ Modify panel ➤ Add All Property Sets

 . For more information, see Adding Property Set Data to All Objects on
page 3801.

For more information about attaching property sets to objects and styles, see
Attaching Property Set Data to Objects on page 3811.

Changing Data in the Schedule Tables
Why doesn’t the data in the schedule table show the changes I made to
objects in the drawing?
Changes that you make to objects—whether through graphically modifying
the object, editing the object properties or style, or editing property
data—automatically appear in a schedule table only when the Automatic
Update option is specified in the schedule table properties. However, you can
manually update a table to reflect the changes.

For more information, see Updating a Schedule Manually on page 3753.
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Object Numbers Out of Order
After adding and removing objects, I updated the schedule table. Why are
the object numbers still out of order?
Updating a schedule table does not change the numbers assigned to the objects.

To renumber objects in a schedule table, see Renumbering Property Set Data
on page 3765.

Locating an Object
Is there an easy way to locate an object that is listed in a schedule table?
Yes. You can select a row in the schedule table to highlight the object that
corresponds to the row.

For more information, see Locating and Viewing Scheduled Objects in a
Drawing on page 3753.

Selecting an Empty Cell
Why can’t I select an empty cell in the schedule table to enter a value for a
manual property?
A table cell must contain at least one character for you to be able to select an
individual cell. If the property was defined without a default entry and no
data for that property was entered before the table was created, the cell is
blank.

You can enter the value by accessing the property data directly in the object
or the object style, depending on where the property is attached. For more
information, see Property Set Data on page 3810.

INVALID in a Table Cell
Why do all the cells of one column in a schedule table show a value of
INVALID?
A property value appears as invalid in a schedule table if the property was
deleted from a property set that is used in the schedule table.

To edit the schedule table style to remove the property from the table, see
Editing Columns in a Schedule Table on page 3785. To edit the property set
definition to restore the property, see Adding a Manual Property Definition
to a Property Set Definition on page 3845 or Adding an Automatic Property
Definition to a Property Set Definition on page 3849.
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Troubleshooting Schedule Table Styles
This topic provides answers to the following questions:

Add Column Button Unavailable
Why is the Add Column button unavailable when I try to add columns to a
schedule table style?
This button is unavailable if the drawing does not contain any property sets
that apply to the same objects or styles that the schedule table style is applied
to.

For more information, see Specifying Objects for a Schedule Table Style on
page 3774 and Adding Columns to a Schedule on page 3777.

Property Sets Unavailable
Why are the property sets I want to use unavailable when I try to add a
column?
Property sets are listed only if property set definitions are stored in the current
drawing. Also, only property sets that apply to all the objects you selected on
the Applies To tab are available to use in schedule table columns. A property
set that applies only to some of the selected objects cannot be included in the
schedule table. For example, a window schedule that applies to windows and
window assemblies cannot contain columns for properties that apply only to
window assemblies.

Quantity Column not Totalling
Why is the Quantity column in my schedule table style not totalling objects
that are the same.
Objects that are the same, such as all doors of a certain style with identical
dimensions, are not grouped and totaled if values for any cell are different.
For example, the objects are not totalled if the table contains object numbers
or if some objects have remarks and some do not.

Matrix Column Displaying Data Instead of a Matrix Symbol
Why does the matrix column I formatted for a property show data values
instead of the matrix symbol?
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If the property specified in the column can have multiple values, you need to
add columns to the matrix format to accommodate all possible values. For
example, in a finish schedule in which walls may be assigned one of four
finishes, you need to enter a number greater than three for Max Columns to
create a column for each finish. When you then create a table from the style,
the matrix symbol appears in the finish column for the finish value entered
in the property data for the walls of each space.

Troubleshooting Classification Definitions
This topic answers the following questions about troubleshooting classification
definitions:

Empty Classification Tab in Style Properties
Why does the Classifications tab in the style properties have nothing in it?
The Classifications tab in the object style properties contains no data if no
classification definitions are defined for styles of that object type. For example,
if the drawing contains no classification definitions that apply to wall styles,
the Classifications tab in the Wall Style Properties dialog does not contain
any classification information. You specify the object styles to which a
classification definition applies when you create the definition.

For more information, see Specifying the Object Types for a Classification
Definition on page 3878.

Long Title for a Classification Property
My schedule table contains an extremely long title for a classification
property. How can I fix this?
The default column header in schedule table styles is the description of the
property selected in the property set definition. The default description for
classification properties comprises the names of the classification definition,
the classification property set, and the classification. In the schedule table
style, you can edit the column header to create a shorter header.

For more information, see Adding Columns to a Schedule on page 3777.

If you clear Use classification name for description when you add or edit a
classification property in the property set definition, you can enter a shorter
description. For more information, see Adding a Classification Property
Definition to a Property Set Definition on page 3852.
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Classifications Property to a Property Set Definition
Why are no classification property sets listed when I try to add a classification
property to a property set definition?
No classification property sets are listed if there are no classification property
sets for the classification definitions that apply to the object or object style
specified in the current property set definition.

Including Classifications in a Schedule Table
I want to include classifications in a schedule table. Why do I not see an
option for them in the schedule table style?
The schedule table style must use property sets that contain classification
properties. The classification properties are then available to include in a
schedule table style.

Objects Not Included in the Schedule
Why were numerous objects in my drawing not included in a schedule table?
If you use classification filters in the schedule table style, only objects of the
specified type that meet all the classification criteria are included in the
schedule table.

For example, if you create a door schedule for doors that are classified new
and exterior, only doors that meet both criteria are included in the schedule
table. If an object meets only some of the classification criteria, it is not
included in the schedule table.

Classifications Selected but Object Not Included
I selected all the classifications for a classification definition in the schedule
table style, but many objects were not included in the schedule. Why did
this happen?
If a classification was not selected in the object style for the classification
definition used in the schedule table style, objects of that style are not included
in the schedule. The classification for such objects is Unspecified, and they
are filtered from the schedule table. To include all objects in a schedule table,
regardless of classification, do not select any classifications on the Applies To
tab in the schedule table style.
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Troubleshooting Schedule Tags
This topic answers the following questions about troubleshooting schedule
tags:

Difference Between Schedule Tags and Project Schedule Tags
When do I select a project-based schedule tag instead of basic schedule tag?
The difference between a standard schedule tag and a project-based schedule
tag is that a project-based schedule tag recognizes the level in the project in
which the object is located. When you want this additional information
captured, use a project-based schedule tag.

For more information, see Adding Tags Using Schedule Tag Tools on page 3756
and Workflow for Annotating a Project on page 529.

Troubleshooting Units
This topic answers the following question about troubleshooting units:

Values on the Extended Data Tab
Why does the display change for the units of a manual property when I select
the value on the Extended Data tab?
An override was applied in the property set definition that is attached to the
object. Property data formats control how units are edited and displayed. If
you assign a type of unit other than the default in the property set definition,
an override is applied to the property data format. Units specified in the
property set definition controls what is stored in the drawing. The Extended
Data tab of the Properties palette displays the units as defined in the property
data format.

For example, with units specified as inches and unit format specified as
Architectural in the property data format for Length–Long, when you select
Length–Long for Format in the property set definition, Inches displays for
Units by default. You can select any other type of unit that is identified for
Length–Long (such as feet and millimeters). If you select Feet in place of Inches
in the property set definition, and select a door with a manual property called
HeightOverride, and enter 84 on the Extended Data tab, the value displays
7'-0''.
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For more information, see Adding a Manual Property Definition to a Property
Set Definition on page 3845 and Units in Property Data Formats on page 3804.
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AEC Content and
DesignCenter

Architectural, engineering and construction (AEC) content consists of drawing files,
architectural symbols, object styles, and annotation routines that you add to drawings to
design and document your project. Predefined AEC content can be accessed from the Content
Browser and from the AEC Content tab in DesignCenter™. You can also create custom content
using the AEC Content Wizard.

Overview of AEC Content
AEC (architectural, engineering and construction) content consists of drawing
files, architectural symbols, object styles, and annotation routines. You use AEC
content to create and annotate your drawings. Doors and windows are examples
of design content, while schedule tables and keynotes are examples of
documentation content. You can access AEC content from either the Content
Browser or the AEC Content tab in DesignCenter™.

51
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DesignCenter AEC Content tab

In some design situations, you may want to create custom content for a unique
piece of construction, or you may want to create a custom command to insert
AEC content by following a series of procedures. You can make your own
content by modifying existing content or by constructing new content using
the AEC Content Wizard. For more information, see Creating Custom AEC
Content on page 3917.

In addition to AEC content, there are other types of predefined content,
including layers, templates, and materials. This content is located in
C:\ProgramData\Autodesk\ACA 2012\enu\.

Predefined AEC Content
With the AEC content provided in the software, you can begin the design
process for imperial and metric drawings immediately. You can access AEC
content from either the Content Browser or the AEC Content tab in
DesignCenter™.

The Content Browser holds a collection of tool catalogs for predefined AEC
content and sample object styles. Design, Documentation, and Stock Tool
catalogs are available for both metric and imperial tools. The content in
DesignCenter supplements AEC content in the Content Browser. In some
situations, content such as elevation labels provides alternatives to tools in
the Content Browser.

Each method of accessing AEC content is unique and has advantages and
disadvantages. Some AEC content appears in both the Content Browser and
DesignCenter. For example, there are schedule tag tools in the Content Browser
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and schedule tags in DesignCenter. For more information, see Adding AEC
Content to Drawings on page 3912.

AEC Content in the Content Browser
The Content Browser has a comprehensive collection of content. You store,
organize, share, exchange, and insert AEC content into drawings using tools.
For example, because windows are governed by styles, the window tool specifies
the location of the external drawing file from which to import the style of the
window. For more information, see Exploring the Content Browser on page
131.

Tools in the Content Browser are organized within tool catalogs by category.
There are imperial and metric Design, Documentation and Stock Tool catalogs
in the Content Browser. When you first open the application, a collection of
tools appears in the drawing area. The tools are organized on tool palettes by
type. For example, the Walls Tool Palette contains a variety of commonly used
wall styles. Tools on the tool palettes reference the content organized in the
Content Browser. For more information, see Working with Tool Palettes on
page 70.

The Content Browser is also the most flexible method of organizing and adding
content to your drawing. You can easily customize your own tool palettes by
dragging and dropping frequently used tools onto a palette. Because the
Content Browser runs independently, you can exchange tools and tool palettes
with other Autodesk applications. For more information, see Content Browser
Overview on page 129.

AEC Content in DesignCenter
Like the Content Browser, DesignCenter™ also lets you store, organize, share,
and exchange AEC content that can be inserted into drawings. Instead of
being tool-based, however, AEC content in DesignCenter is organized in a
hierarchical tree view, and once you select an AEC content item, you can
preview it, edit it, or drag it onto a tool palette or directly into a drawing.

When you open the DesignCenter from the Palettes panel drop-down on the
View tab, and click the AEC Content tab, the Custom Applications tree view
is displayed in the left pane with AutoCAD Architecture as the root node.
Within the Imperial and Metric folders under the root node, there are folders
for categories that roughly approximate the CSI MasterFormat 2004 divisions.
At the lowest level of the tree view, each folder points to one or more external
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drawing files, each containing one piece of AEC content. You can toggle the

tree view on and off by clicking  at the top of the DesignCenter window.

There are 3 panes on the right side of the AEC Content tab.

■ The top pane is the content area, which displays the contents of the folder
currently selected in the tree view. The Views drop-down list at the
upper-right corner of the window provides 4 content display options: Large
Icons, Small Icons, List, and Details. The Large Icons option displays an
image of the content item. All other options display the generic DWG
icon. Regardless of whether the content item is displayed as an image or
an icon, it can be dragged and dropped into a drawing or onto a tool
palette.

■ The middle pane displays a higher resolution preview of the AEC content
item currently selected in the top pane and behaves like the Object Viewer.
For more information, see Object Viewer on page 1111. You can toggle the

preview pane on or off by clicking  at the top of the window.

■ The bottom pane displays a text description of the AEC content item
currently selected in the top pane. You can toggle the description on or

off by clicking  at the top of the window.

The AEC Content tab in DesignCenter
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Fixture Layouts in DesignCenter
Fixture layouts are located in the Plumbing Fixtures folder (under
Imperial/Design/Mechanical). They are unique because you can drag them
into your drawings and then edit the components of the layout by clicking

Insert tab ➤ Reference panel ➤  ➤ Edit Reference. For more information,
see Adding Fixture Layouts from DesignCenter on page 3914 and Modifying
Fixture Layouts on page 3930.

NOTE Fixture layouts are intended to provide samples from which to create your
own office standards for restroom design. All the components can be modified to
meet project and code requirements, and then added to DesignCenter™ for access.
The samples provided do not necessarily meet jurisdictional regulations or ADA
(Americans with Disabilities Act) requirements.

The following notes and hints apply when working with the fixture layouts
available in DesignCenter. For more information, see Modifying Fixture Layouts
on page 3930.

■ The layout files are custom content set to the Drawing content type.

■ The layout files have no layer key because all objects have hard-coded
layers within the file. You can change the layers as required.

■ The layout files are not set to Explode on Insert because you can place
them at only one rotation and orientation (not mirrored) when you drag
them into a drawing, and it is easier to reposition them as unexploded
blocks.

■ To set rotation and mirroring before insertion, double-click the icon to
display the standard AutoCAD Insert dialog box instead of dragging the
content.

■ The rotation angle and scale (for mirroring) can be set in the Insert dialog
box or on the command line. If you use the command line, you can see
the result of each option before actually inserting the content. You can
apply multiple settings on the command line, even though the prompt
says “Specify insertion point:” after the first one. You can still type another
X, Y, or R.

■ Use X = -1 or Y = -1 to mirror the content.

■ Use the node object snap to position individual stall and urinal layouts
next to each other. The toilet partitions and screens are inserted with
centered baselines, so the node snap places them correctly.
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■ After insertion, click Insert tab ➤ Reference panel ➤  ➤ Edit Reference
to adjust the layout, extend partitions, or to move doors, fixtures, or grab
bars.

■ Stall partitions are wall objects placed in the wall group “Toilet_Ptn.” They
do not clean up with other walls. Urinal screens are in the “Standard”
group, but set to “Do Not Cleanup.”

■ Each lavatory layout consists of a counter, made of a wall object with the
cleanup group “Toilet_Counter” with lavatory MV Blocks anchored as
follows:
Lavs (1) Wall anchor; centered along curve

Lavs (2) - (4) Layout Curve (on counter); even spacing (1'-6'' start and end
offset)

Lavs (5) Layout Curve (on counter); repeat at 3'-0'' (1'-6'' start and end
offset)

■ Use the endpoint object snap to position a counter against a stall or urinal
screen.

■ After exploding, the lavatory counters can be trimmed or extended to the
restroom walls. The lavatory counters adjust appropriately, depending on
the anchoring mode.

■ The restroom files are preconfigured assemblies of individual layouts,
arranged as typical men’s and women’s rooms.

For more information, see Detail Components on page 3527 and Layout Curves
and Grids on page 2703.

Adding AEC Content to Drawings
You add AEC content to drawings from tools in the Content Browser or from
files in the content area of the AEC Content tab in DesignCenter™. Although
you can drag and drop content from DesignCenter onto a tool palette to create
tools for the content, you cannot drag tools from the Content Browser into
DesignCenter.

Adding Content from the Content Browser
Use this procedure to add AEC content to a drawing using tools from the
Content Browser. When you drag a tool directly into the drawing area from
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the Content Browser, the Properties palette opens so that you can enter
properties for the new object. Tools can have preset parameters so that you
can add an object with one click. There is no need to change properties before
placement. For detailed information, see Content Browser Overview on page
129.

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content

Browser  .

2 The Content Browser opens in a window outside the drawing
area. To see both the drawing and the Content Browser, reduce
the size of drawing and the Content Browser on your screen.

3 Click the catalog that contains the category of tools you want to
use.

4 Click the category that contains the tool.

5 Drag the i-drop® icon for the tool into the drawing area to add
the content to your drawing.

6 Define properties for the content on the Properties palette, if
necessary.

For more information, see Properties Palette on page 44.

7 Press ENTER.

Adding Content from DesignCenter
Use this procedure to add DesignCenter content to a drawing. You can also
drag AEC content onto a tool palette for direct access or to create a custom
tool. For more information see Moving Content Between DesignCenter and
the Content Browser on page 3915.

1 Click Insert tab ➤ Content panel ➤ Content Browser

drop-down ➤ Design Center  .

2 Click the AEC Content tab.

3 Under Custom Applications, expand AutoCAD Architecture, and
expand Imperial or Metric.

4 Expand the folder containing the content you want to place in
the drawing.

5 Drag the desired image or file icon from the content area (the top
right pane) to the desired location in the drawing area.
(Alternatively, you can double-click the content item, or right-click
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it and click Insert, and then specify a location in the drawing
area.)

The content is placed in your drawing using the current display configuration.
For more information about display configurations, see Display System
Structure on page 801.

Adding Fixture Layouts from DesignCenter
Use this procedure to place fixture layouts in your drawing. For more
information, see Fixture Layouts in DesignCenter on page 3911 and Modifying
Fixture Layouts on page 3930.

1 Click Insert tab ➤ Content panel drop-down ➤ Design Center

 .

2 Click the AEC Content tab.

3 Under Custom Applications, expand AutoCAD Architecture, and
expand Imperial or Metric.

4 Expand Design, and expand one of the following layouts:

■ For imperial content, expand Mechanical\Plumbing
Fixtures\Layouts.

■ For metric content, expand Bathroom\Layouts.

5 Double-click a layout.

6 Use the Insert dialog box to control the placement of the layout.

7 Specify a rotation angle or a scale to mirror the layout.

Enter -1 for X or -1 for Y to mirror the content.

8 Click OK.

9 Specify a location for the fixture layout.

NOTE You can also add the layout by dragging it to the drawing, or
by right-clicking and clicking Insert. You have the most control over
the insertion if you use the double-click or right-click methods.
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Moving Content Between DesignCenter and the Content
Browser

When you want to create a tool from AEC content in DesignCenter™, you
drag and drop the selected content item from the AEC Content tab in
DesignCenter onto a tool palette. From the tool palette, you can drag and
drop the newly created tool into a catalog in the Content Browser. You cannot
drag AEC content from a DesignCenter folder directly into the Content Browser
or drag tools from the Content Browser into DesignCenter.

For more information about creating your own tool palettes or working with
content in catalogs, see Working with Tool Palettes on page 70.

Creating a Tool from AEC Content in DesignCenter
Use this procedure to create a tool by dragging an AEC content item from
DesignCenter™ onto a tool palette.

NOTE You can also create tools from blocks in DesignCenter, but they have slightly
different tool options.
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Adding AEC DesignCenter content to a tool palette

1 Open the tool palette where you want to add a new tool.

2 Click Insert tab ➤ Content panel drop-down ➤ Design Center

 .

3 On the AEC Content tab, navigate to the folder for the AEC
content from which you want to create a tool.

4 Drag the content onto the tool palette.

A new tool is inserted on the tool palette. To change the icon of
the tool, see Changing a Tool Icon on page 90.

5 Define additional properties for the tool, if necessary.

For more information, see Changing the Tool Properties on page
89.
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Creating Custom AEC Content
When you want to create custom content to represent unique or frequently
used objects that are not currently included in either the Content Browser or
DesignCenter™, use the AEC Content Wizard to construct the content. The
AEC Content Wizard is designed specifically for working within DesignCenter.
After you create the content in DesignCenter, you can move it onto a tool
palette. For more information, see Adding AEC Content to Drawings on page
3912.

Using the AEC Content Wizard
The AEC Content Wizard helps you create custom content. You can create
blocks, drawings, and commands from data existing in the current drawing.

AEC Content Wizard

To create custom content, you first select the content type. Next, you specify
options to be used when content is inserted into a drawing. The final step is
to specify the output file and other parameters that control how DesignCenter™

displays the content.

When creating content in an existing AEC file (that is, a drawing generated
from the AEC Content Wizard), the default values for each page of the wizard
are set to the value used to create the drawing. The default settings provide
an easy way for you to make small modifications to existing content files.
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Creating an AEC Content Block for DesignCenter
Use this procedure to create an AEC content block and add it to
DesignCenter™. You create the new block from an existing block in the current
drawing. The block is saved in a new drawing that can be accessed from
DesignCenter.

1 On the command line, enter AecCreateContent.

2 Select Block for Content Type.

All the defined blocks in the current drawing are displayed under
Current Drawing.

3 Select a block for Current Drawing, and click Add.

Only one block at a time can be selected for Current Drawing and
added to Content File.

4 Click Next.

5 Specify an insertion method for Insert Options:

Then…If you want to…

select Explode on Insert.explode the block when you add it
to your drawing

clear Explode on Insert.have the block remain a block when
you add it to your drawing

enter a value for Preset Elevation.specify an elevation for the block
when you add it to your drawing

select a type of anchor for Anchor
Type.

specify an anchor type to use when
you add the block to your drawing

6 Specify an insertion scale factor for Scale:

Then…If you want to…

enter values for X, Y, and Z for
Scale.

scale the block instance using a co-
ordinate (X, Y, Z) direction

select None for Additional Scaling.apply no additional scaling method
to the block instance

3918 | Chapter 51   AEC Content and DesignCenter



Then…If you want to…

select Annotation for Additional
Scaling.

scale the block instance by the an-
notation scale of the drawing you
are adding the block to

select Drawing for Additional Scal-
ing.

scale the block instance by the
drawing units of the drawing you
are adding the block to

select Enable AEC Unit Scaling.scale the block definition by the
drawing units of the drawing you
are adding the block to

7 If the block has attributes, specify a text style for Attribute Text
Style:

Then…If you want to…

select As Defined by Content.use the default text style of content
in the current drawing

select Target Drawing Text Style.use the text style of the target
drawing

8 If the block has attributes, specify an angle for Attribute Text
Angle:

Then…If you want to…

select As Inserted.use the rotation angle of the block
as the attribute text angle

select Force Horizontal.set the angle of the attribute text
to zero

select Right Reading.be able to read the attribute text
from the right direction

9 Click Select Layer Key, select a layer key, and click OK.

You can also enter a layer name for Layer Key.

10 Click Next.

11 Enter a name for File Name, or click Browse.
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If you want to save the current drawing as the content file, select
Current Drawing.

12 Select an image for Icon to represent the block in DesignCenter:

Then…If you want to…

click New Icon, select an image,
and click OK.

specify an existing bitmap image

click Default Icon.specify the default image of the
block itself

13 Enter a description for Detailed Description.

14 If you want to save the drawing objects in the content file, select
Save Preview Graphics.

15 Click Finish.

Creating an AEC Content Drawing for DesignCenter
Use this procedure to create an AEC content drawing and add it to
DesignCenter™. The content drawing can then be inserted into a drawing
with all of its content, including styles, blocks, layers, and linetypes.

1 On the command line, enter AecCreateContent.

2 Select Drawing for Content Type, and click Next.

3 Specify an insertion method for Insert Options:

Then…If you want to…

enter a value for Preset Elevation.specify an elevation

select a type of anchor for Anchor
Type.

specify an anchor type

4 Specify an insertion scale factor for Scale:

Then…If you want to…

enter values for X, Y, and Z for
Scale.

scale the drawing instance using a
coordinate (X, Y, Z) direction

select None for Additional Scaling.apply no additional scaling method
to the drawing instance
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Then…If you want to…

select Annotation for Additional
Scaling.

scale the drawing instance by the
annotation scale of the drawing you
are adding the block to

select Drawing for Additional Scal-
ing.

scale the drawing instance by the
drawing units of the drawing you
are adding the block to

select Enable AEC Unit Scaling.scale the drawing definition by the
drawing units of the drawing you
are adding the block to

5 Specify an angle for Attribute Text Angle:

Then…If you want to…

select As Inserted.assign the angle of the attribute
text to be the same as the rotation
angle of the drawing

select Force Horizontal.set the angle of the attribute text
to zero

select Right Reading.be able to read the attribute text
from the right direction

6 Click Select Layer Key, select a layer key, and click OK.

You can also enter a layer name for Layer Key.

7 Click Next.

8 Enter a name for File Name, or click Browse.

If you want to save the current drawing as the content file, select
Current Drawing.

9 Select an image for Icon to represent the drawing in DesignCenter:

Then…If you want to…

click New Icon, select an image,
and click OK.

specify an existing bitmap image
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Then…If you want to…

click Default Icon.specify the default image of the
drawing itself

10 Enter a description for Detailed Description.

11 Click Finish.

Creating an AEC Content Multi-View Block for DesignCenter
Use this procedure to create an AEC multi-view block and add it to
DesignCenter™. You define the multi-view block from view blocks created in
your drawing that represent different views of your custom object. The block
is saved in a new drawing that can be accessed from DesignCenter. For more
information, see Creating View Blocks on page 2893.

1 On the command line, enter AecCreateContent.

2 Select Multi-View Block for Content Type.

All the defined blocks in the current drawing are displayed in
Current Drawing.

3 Select a multi-view block under Current Drawing, and click Add.

Only one block at a time can be selected for Current Drawing and
added to Content File.

4 Click Next.

5 Specify an insertion method for Insert Options:

Then…If you want to…

select Explode on Insert.explode the multi-view block when
you add it to your drawing

clear Explode on Insert.have the multi-view block remain a
block when you add it to your
drawing

enter a value for Preset Elevation.specify an elevation for the multi-
view block when you add it to your
drawing
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Then…If you want to…

select a type of anchor for Anchor
Type.

specify an anchor type to use when
you add the multi-view block to
your drawing

6 Specify an insertion scale factor for Scale:

Then…If you want to…

enter values for X, Y, and Z for
Scale.

scale the multi-view block instance
using a coordinate (X, Y, Z) direc-
tion

select None for Additional Scaling.apply no additional scaling method
to the multi-view block instance

select Annotation for Additional
Scaling.

scale the multi-view block instance
by the annotation scale of the
drawing you are adding the block
to

select Drawing for Additional Scal-
ing.

scale the multi-view block instance
by the drawing units of the drawing
you are adding the block to

select Enable AEC Unit Scaling.scale the multi-view block definition
by the drawing units of the drawing
you are adding the block to

7 If the block has attributes, specify a text style for Attribute Text
Style:

Then…If you want to…

select As Defined by Content.use the default text style of content
in the current drawing

select Target Drawing Text Style.use the text style of the target
drawing
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8 If the block has attributes, specify an angle for Attribute Text
Angle:

Then…If you want to…

select As Inserted.use the rotation angle of the multi-
view block as the attribute text
angle

select Force Horizontal.set the angle of the attribute text
to zero

select Right Reading.be able to read the attribute text
from the right direction

9 Click Select Layer Key, select a layer key, and click OK.

You can also enter a layer name for Layer Key.

10 Click Next.

11 Enter a name for File Name, or click Browse.

If you want to save the current drawing as the content file, select
Current Drawing.

12 Select an image for Icon to represent the multi-view block in
DesignCenter:

Then…If you want to…

click New Icon, select an image,
and click OK.

specify an existing bitmap image

click Default Icon.specify the default image of the
multi-view block itself

13 Enter a description for Detailed Description.

14 Click Finish.

Creating an AEC Content Masking Block for DesignCenter
Use this procedure to create a custom AEC masking block that you can add
to your drawing using DesignCenter™. You create the new masking block
from an existing masking block in the current drawing. The masking block is
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saved in a new drawing that can be accessed from DesignCenter. For more
information about using masking blocks, see Mask Blocks on page 2867.

1 On the command line, enter AecCreateContent.

2 Select Masking Block for Content Type.

All the defined blocks in the current drawing are displayed in
Current Drawing.

3 Select a masking block for Current Drawing, and click Add.

Only one block at a time can be selected for Current Drawing and
added to Content File.

4 Click Next.

5 Specify an insertion method for Insert Options:

Then…If you want to…

enter a value for Preset Elevation.specify an elevation

select a type of anchor for Anchor Type.specify an anchor type

6 Specify an insertion scale factor for Scale:

Then…If you want to…

enter values for X, Y, and Z for Scale.scale the masking block in-
stance using a coordinate (X,
Y, Z) direction

select None for Additional Scaling.apply no additional scaling
method to the masking block
instance

select Annotation for Additional Scaling.scale the masking block in-
stance by the annotation scale
of the drawing you are adding
the block to

select Drawing for Additional Scaling.scale the masking block in-
stance by the drawing units of
the drawing you are adding
the block to

select Enable AEC Unit Scaling.scale the masking block defini-
tion by the drawing units of
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Then…If you want to…

the drawing you are adding
the block to

7 If the block has attributes, specify a text style for Attribute Text
Style:

Then…If you want to…

select As Defined by Content.use the default text style of
content in the current drawing

select Target Drawing Text Style.use the text style of the target
drawing

8 If the block has attributes, specify an angle for Attribute Text
Angle:

Then…If you want to…

select As Inserted.use the rotation angle of the
masking block as the attribute
text angle

select Force Horizontal.set the angle of the attribute
text to zero

select Right Reading.be able to read the attribute
text from the right direction

9 Click Select Layer Key, select a layer key, and click OK.

You can also enter a layer name for Layer Key.

10 Click Next.

11 Enter a name for File Name, or click Browse.

If you want to save the current drawing as the content file, select
Current Drawing.
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12 Select an image for Icon to represent the masking block in
DesignCenter:

Then…If you want to…

click New Icon, select an image, and
click OK.

specify an existing bitmap im-
age

click Default Icon.specify the default image of
the drawing itself

13 Enter a description for Detailed Description.

14 Click Finish.

Creating an AEC Content Custom Command for DesignCenter
Use this procedure to create a custom command that you can add to your
drawing environment using DesignCenter™. In the AEC Content Wizard,
select one or more content blocks, specify a command string, and save a new
drawing that contains all the content of the current drawing. When the custom
command is added to a target drawing from DesignCenter, the set of content
blocks is copied into the target drawing and the routine is executed, enabling
the custom command.

Following is a detailed example of a custom command that you can create in
the AEC Content Wizard. This custom command string adds a schedule tag
to a room symbol and creates the leader and tag with the desired style.
AecAnnoScheduleTagAdd "C:\ProgramData\Autodesk\ACA

2012\enu\Styles\Imperial\Schedule Tables (Imperial).dwg" _symbol

aec3_room_tag _leader _none _dimstyle _current

The equivalent prompts on the command line are as follows; however, entering
text for custom commands on the command line is not recommended. Custom
commands should be created with the AEC Content Wizard.

AnnoScheduleTagAdd

Property set definitions drawing <C:\ProgramData\Autodesk\ACA

2012\enu\Styles\Imperial\Schedule Tables (Imperial).dwg>

Select object to tag

[Symbol/Leader/Dimstyle/Edit/Constrain/Rotation]:Symbol

Enter tag symbol name <>: Aec3_Room_Tag_
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Select object to tag

[Symbol/Leader/Dimstyle/Edit/Constrain/Rotation]:Leader

Enter leader type [None/STraight/SPline] <None>:None

Select object to tag

[Symbol/Leader/Dimstyle/Edit/Constrain/Rotation]:Dimstyle

Enter leader dimstyle CURRENT <Aec-Arch-I-96>: Current

Select object to tag [Symbol/Leader/Dimstyle/Edit]:

1 On the command line, enter AecCreateContent.

2 Select Custom Command for Content Type.

All the defined blocks in the current drawing, regardless of type,
are displayed in Current Drawing.

3 Select one or more blocks for Current Drawing, and click Add.

4 Enter the command string for Custom String.

You can also click Expand to display the Custom Command String
dialog box, and enter the command string.

The command string is limited to 255 characters.

5 Click Next.

6 Specify an insertion method for Insert Options:

Then…If you want to…

enter a value for Preset Elevation.specify an elevation

select a type of anchor for Anchor
Type.

specify an anchor type

7 Specify an insertion scale factor for Scale:

Then…If you want to…

enter values for X, Y, and Z for
Scale.

scale the drawing instance using a
coordinate (X, Y, Z) direction

select None for Additional Scaling.apply no additional scaling method
to the drawing instance

select Annotation for Additional
Scaling.

scale the drawing instance by the
annotation scale of the drawing you
are adding the block to
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Then…If you want to…

select Drawing for Additional Scal-
ing.

scale the drawing instance by the
drawing units of the drawing you
are adding the block to

select Enable AEC Unit Scaling.scale the drawing definition by the
drawing units of the drawing you
are adding the block to

8 Specify an angle for Attribute Text Angle:

Then…If you want to…

select As Inserted.assign the angle of the attribute
text to be the same as the rotation
angle of the drawing

select Force Horizontal.set the angle of the attribute text
to zero

select Right Reading.be able to read the attribute text
from the right direction

9 Click Select Layer Key, select a layer key, and click OK.

You can also enter a layer name for Layer Key.

10 Click Next.

11 Enter a name for File Name, or click Browse.

If you want to save the current drawing as the content file, select
Current Drawing.

12 Select an image for Icon to represent the drawing in DesignCenter:

Then…If you want to…

click New Icon, select an image,
and click OK.

specify an existing bitmap image

click Default Icon.specify the default image of the
drawing itself

13 Enter a description for Detailed Description.

14 Click Finish.
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Editing AEC Content
You can edit AEC content that was added to the drawing from DesignCenter™.
For information about editing tools in the Content Browser, see Customizing
a Tool on page 166.

Modifying DesignCenter Content with the AEC Content Wizard
Use this procedure to edit DesignCenter content with the AEC Content Wizard.

1 Click Insert tab ➤ Content panel drop-down ➤ Design Center

 .

2 Click the AEC Content tab.

3 Under Custom Applications, expand AutoCAD Architecture, and
expand Imperial or Metric.

4 Expand the folder containing the content you want to edit.

5 Select the content item you want to modify, right-click and click
Edit.

The AEC Content Wizard opens and the content type is displayed.

6 Follow the screens in AEC Content Wizard to make your
modifications.

Modifying Fixture Layouts
Use this procedure to modify the components of fixture layouts with the Edit
Block in-place option. This method is more efficient than exploding the layout.
For example, if you drop a toilet stall into your drawing and then explode it,
the stall walls are wall objects, the door to the stall is a door object, and the
toilet is a multi-view block. When you use Edit Block in-place, the layout
remains a single piece of content. You can also drag the fixture layouts onto
a tool palette to create custom tools.

NOTE After you create your custom fixture layout, save the layout as Custom
Design Content for easy placement in future drawings.

For more information about fixture layout content, see Fixture Layouts in
DesignCenter on page 3911.

1 Select a layout.
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2 click Insert tab ➤ Reference panel ➤  ➤ Edit Reference.

The Reference Edit dialog box opens.

3 Click OK.

The components can now be edited separately.

For more information, see “Reference Edit Dialog Box” in
AutoCAD Help.

TIP The quickest way to locate and view an AutoCAD topic is to click
the Search tab in the Help window, select the Search titles only option,
and then copy and paste or type the AutoCAD topic name, and click
List Topics.

Turning Off the Dimension Scale Override
Use this procedure to prevent the software from automatically applying an
override to the current dimension scale style in the drawing. This control is
on by default, and it overrides the active dimension scale style. With the
override on, dimensions added to the drawing are scaled based on the current
drawing scale. For more information, see “Set Plot Scale” in AutoCAD Help.

If you want to make the dimension scale match your drawing scale, leave
Automatically Create Dimscale Override selected. The override applies a scale
factor to the dimension style properties.

WARNING Any time you close the Drawing Setup dialog box by selecting OK or
Apply, an override is applied if Automatically Create Dimscale Override is selected,
regardless of the tab that was originally opened.

AEC dimensions added with tools are not affected by the dimension scale
override because an AEC dimension style depends on which display
representation is active. For more information about AEC Dimensions, see
Dimension Options and Uses on page 3389.

1 Click  ➤ Utilities ➤ Drawing Setup.

2 Click the Scale tab.

3 Clear Automatically Create Dimscale Override.
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When you clear this setting, you can adjust the dimension scale
independently of the drawing scale.

4 Select Save As Default if you want subsequent drawings to use
these settings, or clear Save As Default to save your settings in the
current drawing only.

5 Click OK.
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Other Utilities

3933



3934



Cameras

The camera is a visualization tool, modeled after a real camera. It uses a point-and-shoot
process to help you view the drawing as if you were standing within the building model. You
can add any number of camera views to your drawing and create a video dry run of your
design with a camera. For more information about working with cameras, see “Overview of
Cameras” in the AutoCAD Help.

You can save perspective views of your drawing using a camera. By adjusting the position of
your camera, you can change these views incrementally.

Adjusting the Camera Position
Use this procedure to incrementally change the position of the camera. This
changes your views.

1 Click Render tab ➤ Camera panel ➤  ➤ Adjust.

2 Select the camera to adjust.

3 Click the appropriate button to adjust the view.

■ Change the Step value: This value controls how far each click
of the following buttons moves the camera: Forward, Back, Left,
Right, Up, and Down.
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■ Change the Angle value: This value controls how far each click
of the following buttons moves the camera angle: Turn Left,
Turn Right, Look Up, and Look Down.

■ Change the Zoom percentage: This value controls how far
each click of the button zooms the camera for Zoom In and
Zoom Out.

■ Click Hide to view the drawing with hidden lines removed.

If the view in the drawing wasn’t the camera’s view, then the first
selected button places the drawing into the camera’s view.

As you click each button, the view changes in increments
determined by values in the Adjustment Increments section. If
Auto View is selected, you can see the change after you click each
button. If Auto View is cleared, click View to see the changes.

4 Click OK.
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Converting Objects to 3D
Solids

You can convert objects to 3D solids when preparing to use CNC machining applications to
create a physical building model from a computer-generated building model. You may also
want to convert objects to 3D solids if the objects are to interact with other 3D solids.

Converting Objects to 3D Solids
You can convert objects to 3D solids when preparing to use CNC machining
applications to create a physical building model from a computer-generated
building model. You may also want to convert objects to 3D solids if the objects
are to interact with other 3D solids.

You cannot convert the following objects or blocks:

■ Objects with no integral 3D presence, such as building grids or cameras

■ 3D sections

■ Objects in a block or an external reference

■ Custom display blocks created from 3D solids

For more information, see “Create 3D Solids” in AutoCAD Help.

Converting Objects to 3D Solid Objects
Use this procedure to convert objects such as walls, doors, and mass elements
into three-dimensional (3D) solid AutoCAD objects.
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TIP Convert custom display blocks to Free Form mass elements, and then convert
the mass elements to 3D solids.

1 Open the tool palette that contains the Convert to 3D Solid tool
you want to use, and select the tool.

A default Convert to 3D Solid tool is located with the Modeling
Tools in the AutoCAD Architecture Stock Tools catalog. You can
add this tool to any tool palette. For more information, see
Content Browser Overview on page 129.

2 Select the objects to convert, and press ENTER.

3 Enter y (Yes) to erase the selected geometry after conversion, or
enter n (No) to keep the geometry in the drawing

Any selected objects that cannot be converted are filtered out
during the conversion. Highly-faceted objects, such as curved
railings and stairs, may take a longer time to convert.

After you convert an object to a solid, you can convert it to a Free Form mass
element and modify it using grips or the Properties palette. You can then
convert the Free Form mass element back to a 3D solid. For more information,
see Using the Model Explorer to Create Mass Models on page 1087.
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Visual Audit

Visual Audit is a utility that helps you manage the integrity of your design data by identifying
non-AEC objects, such as AutoCAD® objects and exploded AEC objects, in your drawings.

Working with Visual Audit
When you perform a visual audit, all of the AEC objects in the drawing are
temporarily removed from the display, leaving only non-AEC objects in view.
You can inspect the remaining objects more closely to see if they should be
replaced with AEC objects.

To add clarity to the audit, a visual audit also removes single and multi-line
text, leaders, and dimension objects from the display. Attribute text remains
visible in the drawing. All objects are displayed again when you end the visual
audit.

In the following illustration, the railing, door, and the framed opening are
exploded AEC objects.
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Performing a visual audit with AEC and non-AEC objects in the drawing

Performing a Visual Audit
Use this procedure to perform a visual audit on your drawing.

NOTE For best results, perform a visual audit in a 2D wireframe view.

1 Click Home tab ➤ Inquiry panel ➤  ➤ Show AutoCAD Entities

 .

2 All AEC objects are removed from the display. Attribute text
remains visible in the drawing.

3 Pan and zoom to inspect the drawing:

Then…If you want to…

enter ‘z (Zoom). You can use real
time zoom or right-click to access
additional zoom options.

access zoom options

enter ‘p (Pan). You can pan or
right-click to access pan options.

access pan options

4 Press ENTER.

All objects are restored to the display.
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Reference AEC Objects

You can create reference copies of objects that are updated automatically when you change
the original object. You can add identical objects, such as columns, to your drawing.

Creating an AEC Entity Reference
An AEC entity reference is a reference copy of an object. These entity references
update when you change the original object. When you select an object to
reference, you must specify a point on the original object as an insertion point
for the marker of the entity reference. A reference marker is displayed in the
drawing to mark the insertion point.

You can place the entity reference in the drawing at any location or rotation
angle. The distance between the entity reference and the reference marker
remains equal to the distance between the original object and the insertion
point specified. You can change this distance by specifying a new insertion
point at a new location in relation to the original object.

When you change the properties of the original object or edit it with grips, the
reference object reflects the changes. For example, if you want to add
custom-shaped mass elements to a drawing, you can add one mass element and
reference it. If you make changes to the original, the entity reference is updated.

Adding a Reference to an Object
Use this procedure to create an entity reference from another object.

1 Open the tool palette that you want to use, and select an AEC entity
reference tool.
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An AEC entity reference tool is located in the Helper Tools
category of the AutoCAD Architecture 2012 Stock Tool catalog.
For more information, see Content Browser Overview on page
129.

2 Enter ad (Add), and press ENTER.

3 Select the object that you want to reference.

4 Specify a point on the original object to use as the insertion point
for the entity reference marker.

5 Specify a location for the entity reference in the drawing.

The distance between the entity reference and the reference marker
is equal to the distance between the original object and the
insertion point that you specified.

6 Enter a rotation angle for the entity reference, or press ENTER for
zero rotation.

7 Press ENTER.

The entity reference and reference mark are placed in the drawing at the
specified location and rotation angle. If you edit the original object, the same
changes are made to the entity reference.

Attaching an Object to an Existing Entity Reference
Use this procedure to attach an object to an existing entity reference.

1 Open the tool palette that you want to use, and select an AEC
entity reference tool.

An AEC entity reference tool is located in the Helper Tools
category of the AutoCAD Architecture 2012 Stock Tool catalog.
For more information, see Content Browser Overview on page
129.

2 Enter at (Attach), and press ENTER.

3 Select the reference marker that you want to use.

4 Select the new object that you want to use to replace the entity
referenced, and press ENTER.

The new entity reference replaces the former entity reference. The original
object is unchanged.
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Attaching Hyperlinks, Notes, and Files to an Entity Reference
Use this procedure to attach hyperlinks, enter notes, or attach reference files
to an entity reference in a drawing. You can also edit notes and edit or detach
reference files from an entity reference.

1 Double-click the entity reference to which to attach information.

2 On the Properties palette, click the Extended Data tab.

3 To add a hyperlink, click  next to Hyperlink, and specify the
link.

For more information about adding hyperlinks, see “Add
Hyperlinks in a Drawing” in AutoCAD Help.

4 To add or edit a note, click  next to Notes, enter text, and click
OK.

5 Click  next to Reference documents, and attach, detach, or
edit a reference file:

Then …If you want to …

click  , select a file, and click
Open.

attach a reference file

enter text under Description.edit the description of a reference
file

double-click the reference file name
to start its application.

edit a reference file

select the file name, and click 
.

detach a reference file

6 Click OK twice.

Changing the Location of an Entity Reference
Use this procedure to relocate an existing entity reference by changing the
coordinate values of its insertion point. The entity reference also has an
orientation with respect to the world coordinate system (WCS) or the current
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user coordinate system (UCS). For example, if the top and bottom of the
reference object are parallel to the XY plane, its normal is parallel to the Z axis.
You can change the orientation of the entity reference by aligning its normal
with another axis. You can also rotate the entity reference on its plane by
changing the rotation angle.

For more information about the world coordinate system and the user
coordinate system, see “Use Coordinates and Coordinate Systems” in AutoCAD
Help.

1 Double-click the entity reference you want to relocate or reorient.

2 On the Properties palette, click the Design tab, expand Basic, and
expand Location.

3 Click Additional information.

4 Specify the location of the entity reference:

Then …If you want to …

enter new coordinate values under
Insertion Point.

relocate the entity reference

make the normal of the entity refer-
ence parallel to the Z axis: under

locate the entity reference on the
XY plane

Normal, enter 1 for Z, and enter 0
for X and Y.

make the normal of the entity refer-
ence parallel to the X axis: under

locate the entity reference on the
YZ plane

Normal, enter 1 for X and enter 0
for Y and Z.

make the normal of the entity refer-
ence parallel to the Y axis: under

locate the entity reference on the
XZ plane

Normal, enter 1 for Y, and enter 0
for X and Z.

enter a new value for Rotation
Angle.

change the rotation of the entity
reference

5 Click OK.
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Customizing and Adding
New Content for Detail
Components

The details feature in AutoCAD Architecture has a framework for content that can be
customized and extended in several different ways. Detail components are stored in Microsoft®
Access databases, which end users can modify or even create using the Detail Component
Manager, as described under Creating and Modifying Detail Component Databases on page
3553.

Developers may prefer to work on detail component databases using Microsoft Access directly,
in which case they will definitely need to refer to the descriptions and code samples in this
appendix. However, it is recommended that any user be familiar with this information before
attempting to create or customize a detail component database.

Introduction
AutoCAD Architecture detail components are not custom objects in AutoCAD.
They are made up of simple entities like line, arc, polyline, block, and hatch.
Usually, the various entities that make up a detail component are grouped as
an anonymous block so that they can easily be copied or moved like a single
entity. But a detail component can also be as simple as a polyline boundary
with a hatch interior. This accommodates the type of component for which it
is natural to use the STRETCH command. The exact makeup of the component
is left to the discretion of the developer.

Each Detail Component is also stamped with “Xdata” (Extended Entity Data)
that identifies where it came from in the original database of components. This
data can be used later to retrieve additional information or create another
component of the same type.
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Detail components are integrated with the Property palette and Tool palette
systems. However, the details framework handles this interaction automatically,
and an author of a new detail component only has to provide a simple
description of what type of data should appear.

The details framework includes four main components:

■ Database of Components and Sizes

■ Recipe Specification

■ Recipe Implementation

■ Framework Utilities

These framework components are described individually in the following
sections.

Database of Components and Sizes

The AEC Detail Component database is a Microsoft® Access database, which
contains a size table for each available component, as well as several related
tables that support the overall structure of the database. End users can add or
modify existing component tables through the user interface provided by the
Detail Component Manager dialog box, but more advanced customization
requires Microsoft Access.

Recipe Specification

A Recipe Specification (RecipeSpec) is an XML file that describes the different
Recipes that can be used to create a particular component in AutoCAD. For
each Recipe, it identifies the types of controls (prompts) that should appear
in the Properties palette and specifies how to call the function that implements
the given Recipe. The RecipeSpec also provides view-specific information such
as the layers and hatch patterns to use when creating the component.

Recipe Implementation

A Recipe Implementation is (usually) a small piece of code that creates the
component in AutoCAD. The Recipe Implementation can be written in
ObjectARX C++, VBA (Visual Basic for Applications), or any Microsoft .NET
language (such as C# or Visual Basic .NET). The Recipe can be as easy as a
simple block insert, or it can involve more complex operations, such as
bringing up a dialog box with many choices.
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Framework Utilities

The Framework utilities make the job of implementing a Recipe much easier.
They provide many of the common functions to look up data from the
database and from the user controls that populate the Properties palette. These
utilities also provide a number of common “Jigs” that help place the
component once it is created. For more information on Jigs, see Jigs and JigEnts
on page 3979.

A Walkthrough of the Process
As with a real recipe, the ingredients for a detail component Recipe can come
from many places. As the recipe author, you have the freedom to put the
ingredients together however you choose. Nonetheless, the following
walkthrough of the process the user goes through to insert a detail component
in a drawing should help give you a better understanding of how all the pieces
fit together.

1 The user chooses a detail component to create, either by selecting one
from the Detail Component Manager dialog box, or by clicking on a tool
that has been configured to insert that component.
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2 The RecipeSpec that is assigned to the selected detail component is read,
and the information within it is displayed on the Properties palette, as
shown below. The Category, Type, and Description values all come from
the user’s selection of the component. The Receipe can then retrieve other
information it needs directly from the database. The user can change any
of the values displayed on the Properties palette to affect the currently
running Recipe.

3 The RecipeSpec may have one or more Recipes defined within it, each
associated with a different View setting on the Properties palette. By
selecting a View (or accepting the default) the user in effect selects the
Recipe that is responsible for creating that view of the component. When
a particular Recipe is selected, the Recipe Implementation function
described in the XML RecipeSpec is called.

The three controls shown under Specifications (Hatch block, Grout fill
cores, and Show mortar) are defined by the <Controls> section of the
RecipeSpec. Their values can be retrieved by the Recipe function and used
to control the basic parameters of the component.

In this example, Mortar is a subcomponent of the CMU component, as
specified in its RecipeSpec. Values and options for all mortar components
are retrieved from the database and displayed on this section of the
Properties palette. The final three controls under Mortar (Left joint type,
Right joint type, and Hatch mortar), are specified in the subcomponent’s
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RecipeSpec, and their values can be retrieved by the subcomponent’s
Recipe function.

4 The Recipe Implementation then does whatever it needs to in order to
create the component. It has access to the size data in the database, the
data in the RecipeSpec, and user input provided through the Properties
palette. It also has access to a host of utility functions that can help create
and place the component.

The layering and hatch properties for the component come from the
<Data> section of the RecipeSpec. Specific options for the Jig to use come
from the <Options> section of the RecipeSpec.

Component Databases
A detail component database contains a size table for each available component
and several related tables that support the overall structure of the Microsoft®

Access database. A component database has references to external files, such
as Recipe Specifications and preview image files. For this reason, it is suggested
that the database and all of its external references be located in the same tree
structure of the file system. For example:

MyContent/

MyComponentDb.mdb

MajorComponentGroup1/

*.xml, *.dwg, *.png, etc. supporting this group of components

MajorComponentGroup2/

*.xml, *.dwg, *.png, etc. supporting this group of components

Such a structure makes installing or moving the content a much easier task
because all of the external content can use relative paths from the main
database.

Database Schema

Several tables must be present in order for the Recipe system to function
correctly. When creating a new database, you should start with either the
standard database (AecDtlComponents.mdb) or with the empty template database
(AecDtlComponents-Template.mdb).

Fingerprint Table

This table uniquely identifies a component (or keynote) database with a Global
Unique IDentifier (GUID). It also provides information that can be displayed
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in the user interface. All detail components placed in a drawing, and all detail
component tools used in Tool palettes record this database GUID. If your
database changes location in the directory structure, the tools and components
can still find the database using the unique GUID.

The Type field should contain either the string “Component” or “Keynote”
depending on which type of database you are creating.

To obtain a GUID for your database, simply delete the existing GUID from
the database you are using as a template, and a new GUID will be generated
automatically.

Groups Table

The Groups table defines the hierarchical organization of components within
the database. This hierarchy determines the order in which component groups
are displayed in the tree view of the Detail Component Manager dialog box.
To set up this table, you simply need to make a Group entry for each collection
of like components, and then, for each Group, define its Parent, which is
either another Group or the root node (\ - *). The following fields apply to
each row in the table:

ID A unique number within the given table that identifies the particular row
in the table used to create a component. Once created, this number should
never change. Components that have already been placed in the drawing are
stamped with this ID and must be able to consistently reference this row in
the database.

Parent The group that is the parent of the group identified in the Group field.

Group The text string used to display the name of this group.

PathKey An entry from the DirKeys table (described later in this section).
DirKeys tell the system where to find the files external to the database for this
given component.

SearchKey A comma-delimited list of keywords used by the Detail Component
Manager to search for components. When a keyword is specified for a group,
any component within that group is considered a match for a search on that
keyword.

MODIFIED A Boolean flag indicating whether this row has been changed
since it was originally created. If the user modifies the row using the Detail
Component Manager dialog box, this field is marked so that future versions
of the database can merge in the changes. The notion of “modified” is relative
to the version of the database. For instance, if you are copying an existing
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database and changing all the values, it would be considered the first version
of the new database, and all MODIFIED fields should be set to FALSE.

PICTURE This column allows you to specify a unique picture when this Group
node is selected in the Detail Component Manager. It is recommended that
you use an image file of type PNG. The location of the image file is usually
specified by appending the filename to the path assigned to the DirKey for
this Group.

Components Table

The Components table is the main “map” of how all the information about
a given component is tied together. The following fields apply to each row in
the table:

ID A unique number within this table that identifies the particular component
within this database. Once created, this number should never change.
Components that have already been placed in the drawing are stamped with
this ID and must be able to consistently reference this row in the database.

GroupName The parent Group of this component. This establishes the place
of the component in the overall hierarchy of components.

Name The text string used for display purposes in the Detail Component
Manager and on the Properties palette.

TableName The name of the size table for this component (Component Size
Tables are described in the following section).

Keynote This value references an entry in a keynotes database. This is the
default keynote to be used for all sizes of this component, but it can be
overridden if a size-specific keynote is defined in the size table.

SubComponentKey This value identifies the component as a valid
subcomponent for the context specified. For example, the Recipes for Brick
and CMU allow for a subcomponent of mortar. The Recipe system will search
for all components in the database that identify themselves as being valid
subcomponents for mortar.

RecipeSpec This value specifies the XML file to use as the RecipeSpec for this
component. The RecipeSpec has instructions for how to actually create and
place the component in the drawing. The RecipeSpec is found by searching
in the directory specified by the PathKey for the Group in which this
component resides. For more information, see the subsequent section on
Recipe Specifications.
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SearchKey A comma-delimited list of keywords used by the Detail Component
Manager to search for components.

Units This value specifies the unit of measure for the size table for this
component.

MODIFIED A Boolean flag indicating whether this row has been changed
since it was originally created. If the user modifies the row using the Detail
Component Manager, this field is marked so that future versions of the
database can merge in the changes. The notion of “modified” is relative to
the version of the database. For instance, if you are copying an existing
database and changing all the values, it would be considered the first version
of the new database, and all MODIFIED fields should be set to FALSE.

PICTURE This column allows you to specify a unique picture to display when
this particular row is selected in the Detail Component Manager. If the field
is left blank, then the picture specified at the Component level is used. If no
picture is specified in the Components table, the picture specified for the
component’s Group is used.

It is recommended that you use an image file of type PNG.

Component Size Tables

For each component in the database, there should be a corresponding size
table. A size table can be named anything you desire, but must include the
following columns:

Description A textual description of the item, which is used as a display string
in the Properties palette.

ID A unique number within the given table that identifies the particular row
in the table used to create a component. Once created, this number should
never change. Components that have already been placed in the drawing are
stamped with this ID and must be able to consistently reference this row in
the database.

MODIFIED A Boolean flag indicating whether this row has been changed
since it was originally created. If the user modifies the row using the Detail
Component Manager, this field is marked so that future versions of the
database can merge in the changes. The notion of “modified” is relative to
the version of the database. For instance, if you are copying an existing
database and changing all the values, it would be considered the first version
of the new database, and all MODIFIED fields should be set to FALSE.

PICTURE This column allows you to specify a unique picture to display when
this particular row is selected in the Detail Component Manager. If the field
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is left blank, then the picture specified at the Component level is used. If no
picture is specified in the row of a given size table, the picture specified for
the Component in general is used.

It recommended that you use an image file of type PNG.

The location of the image file is usually specified by appending the filename
to the path assigned to the DirKey for this component’s Group.

If the component is created by doing a simple Block insertion, you can have
the preview image created dynamically by drawing the referenced block. For
these types of components, set the Picture value to _blockthumbnail.

Keynote This value references an entry in a Keynotes database. As with the
PICTURE column, if no value is specified here at the Size level, the one specified
at the Component level is used.

Units Table

This table defines the units of measure available to assign to individual
component size tables. It currently includes only inches and millimeters.
However, centimeters, meters, and feet should also work. In the Components
table, each entry must specify the unit in which the assigned size table is
defined.

DirKeys Table

This table defines directory keys, which are shortcut aliases to use in identifying
the directory structure of the user’s file system. Typically, there is one directory
for each major division in your component hierarchy. You can match the
component hierarchy in the database with the external files stored on the file
system.

DirKeys are referenced in the PathKey field of the Groups table and from the
XML RecipeSpec files. They are intended to allow you to easily reorganize the
internal hierarchy, the external hierarchy, or both.

ColumnDisplay Table

Column names used in component size tables cannot be localized in other
languages because these names are referenced programmatically. However,
these column names also need to appear in the user interface. The
ColumnDisplay table serves as a lookup for user interface components, so that
user-friendly, localized names for the columns can be displayed.

GlobalName This is the fixed name of the column in a given component size
table. It is the lookup key used to find the local name.
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LocalName This is the translated, user-friendly display string to use for a
column of this global name.

TableId If left blank, then any column with the given GlobalName uses the
LocalName for display purposes. In some cases, however, the same column
name may have two different translations depending on its context. Specify
a size table if the translation only applies to a specific context.

Hidden Some columns, such as ID and MODIFIED, are not intended to be
seen by the user in the Detail Component Manager. These can be hidden by
checking this box. Note, however, that this only applies when the database
is marked as read-only. A database that is being edited from the Detail
Component Manager must show all columns so that a valid row can be entered.

Modified A Boolean flag indicating whether this row has been changed since
it was originally created.

Hatches Table

This table defines a set of hatch aliases. Individual components that create
hatches can reference an alias instead of specifying the pattern, scale, and
angle directly. This allows you to standardize the look of certain materials
across the entire database. For instance, you can have all components that are
made of concrete use the “concrete” alias. If you want to change the look of
all concrete components, simply edit the entry in the Hatches table to change
the look of any component that references that alias.

NOTE For a description of the database schema for keynotes, see Keynote Database
Schema on page 3649.

Recipe Specifications
A Recipe Specification (RecipeSpec) is an XML file that describes which views
(section, elevation, and so on) are available for a given detail component and
how those views are to be created and placed within the drawing.
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Here is a simple example of a RecipeSpec.
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<?xml version="1.0" encoding="UTF-8"?>

<AecRecipeSpec defaultUnit="in">

<Recipe idStr="side">

<Label>Side</Label>

<Implementation>

<ObjectARX>

<AppName>AecDtl50</AppName>

<RcpFunc>AecDtlRcpColumnCapCCSide</RcpFunc>

</ObjectARX>

</Implementation>

<Data>

<Item idStr="block">

<AcadEntityProps>

<Layer ref="layerKey">THIN</Layer>

</AcadEntityProps>

</Item>

<Item idStr="boundary">

</Item>

<Item idStr="holes">

</Item>

<Item idStr="hidden">

<AcadEntityProps>

<Layer ref="layerKey">FINE</Layer>

<Linetype>HIDDEN</Linetype>

</AcadEntityProps>

</Item>

</Data>

</Recipe>

<Recipe idStr="end">

<Label>End</Label>

<Implementation>

<ObjectARX>

<AppName>AecDtl50</AppName>

<RcpFunc>AecDtlRcpColumnCapCCEnd</RcpFunc>

</ObjectARX>

</Implementation>

<Data>

<Item idStr="block">

<AcadEntityProps>

<Layer ref="layerKey">THIN</Layer>

</AcadEntityProps>

</Item>

<Item idStr="boundary">
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</Item>

<Item idStr="holes">

</Item>

</Data>

</Recipe>

</AecRecipeSpec>

A RecipeSpec is composed of one or more Recipes. Each Recipe is responsible
for creating a single view of the component. In the example above, the first
Recipe creates a side view of the drawing, and the second creates an end view.
When the component is inserted in a drawing, the user-configurable View
setting on the Properties palette determines which recipe is used.

Each Recipe contains the following four major sections:

■ Implementation: This section identifies the function to call and includes
information specific to the particular language in which it is implemented.
In short, it specifies how to call the Recipe function (RcpFunc).

■ Controls: This section defines controls that will be added to the Properties
palette. The control can be defined directly here, or it can reference a
globally defined control in the <ControlDefs> section that is part of the
overall RecipeSpec.

■ Data: This section has customization data that the Recipe function can
retrieve to help control how the component is drawn, such as layer and
hatch pattern information.

■ Options: This section specifies options for the Jig or JigEnt that is used to
place the component.

In short, the <Data> and <Controls> sections help define what the basic
component looks like, and the <Options> section helps define how the
component is placed. In many cases, you will not need an <Options> section,
because the default behavior of the Jig is sufficient.

Each of these sections is described in more detail further on in this section.

Id Strings

Everything in the RecipeSpec that needs to be identifiable programmatically
has an idStr attribute. The idStr value should never change and should be
unique within the file (or at least within a given element type). The Rcp
function will be expecting ID strings with certain values, so when writing a
RecipeSpec, you need to know the implied contract from the Rcp function.

Recipe Specifications | 3957



NOTE One way to find out the implied contract of the Rcp function is to turn on
logging. For more information, see Recipe Logging on page 3987.

Display Strings

Elements with the tag <Label> or <Description> are intended to be translated.
These will be displayed in the Properties palette and other user interface
constructs, but will never be used to refer to anything and will never be
referenced from the code (that is the job of the idStr).

References

Within the Recipe Spec, the value of an item appears between the element
tags. It is taken as a literal value unless the ref attribute is specified. In this
case, the value between the element tags is considered a lookup value and is
used to retrieve the actual value.

ref [Optional]

Specifies that the value between the element tags is to be used as a lookup
key. It can have one of the following values:

(AutoCAD Architecture LayerKey)layerKey

(Column in the table from component
database)

dbTable

(idStr of a <Control>)control

NOTE The layerKey reference type is only valid within the element <Layer>.
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The dbTable reference will use the value as the column name within the size
table for the current component. Consider the following two examples.

<Data>

<Item idStr="block">

<AcadBlockProps>

<BlockName dwgLib="dwgs/AecDtlLib_BlockTest.dwg">Jimbo</Block

Name>

<Scale>6.0</Scale>

</AcadBlockProps>

<AcadEntityProps>

<Layer>DOOR</Layer>

</AcadEntityProps>

</Item>

</Data>

In the first case, the <Scale> and <Layer> values have been specified literally.
This component, regardless of what row was selected in the database, will
have a scale factor of 6.0. Likewise, regardless of what Layer Key style is current
within AutoCAD Architecture, this component will go on the DOOR layer
(not the layer assigned to the LayerKey “DOOR”).

<Data>

<Item idStr="block">

<AcadBlockProps>

<BlockName dwgLib="dwgs/AecDtlLib_BlockTest.dwg">Jimbo</Block

Name>

<Scale ref="dbTable">SCALE</Scale>

</AcadBlockProps>

<AcadEntityProps>

<Layer ref="layerKey">DOOR</Layer>

</AcadEntityProps>

</Item>

</Data>

In this example, references were used to look up the values dynamically. The
<Scale> will be set to the value in the SCALE column of the current row in
the component’s size table. Likewise, the reference “DOOR” is the Layer Key
to use to look up the Layer, not the actual Layer name itself. There is also a
reference of type “control,” which lets you use the idStr of a control defined
within the Recipe. The value of that control is then used as the actual value
of the Element.
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Units

Each Recipe Spec has a default unit that applies to the entire XML file. Any
unit-dependent value that appears within the XML file is automatically
converted from the default unit to the current drawing unit when the value
is retrieved from XML.

To specify the default unit, use the following syntax in the root node of the
RecipeSpec.

<?xml version="1.0" encoding="UTF-8"?>

<AecRecipeSpec defaultUnit="mm">

<Recipe idStr="section">

<….. omitted ….>

</Recipe>

</AecRecipeSpec>

The defaultUnit attribute must be one of the values: in, ft, mm, cm, dm, or
m. If no value is speciifed, “in” is used by default.

In some cases, a simple hard conversion from Metric to Imperial (or vice versa)
is not good enough. For instance, the <GapSpacing> between paver bricks
should be a logical distance for each measurement system instead of an
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arbitrary distance created by a hard conversion. You can specify a unit-specific
element by including the “unit” attribute, as in the following example.

<Data>

<Item idStr="block">

<AcadEntityProps>

<Layer ref="layerKey">THIN</Layer>

</AcadEntityProps>

</Item>

<Item idStr="head">

<Params>

<Overhang unit="in">0.25</Overhang>

<Overhang unit="mm">6.5</Overhang>

<Depth unit="in">0.375</Depth>

<Depth unit="mm">10.0</Depth>

</Params>

</Item>

<Item idStr="tip">

<Params>

<Depth unit="in">0.0625</Depth>

<Depth unit="mm">1.5</Depth>

</Params>

</Item>

<Item idStr="shaft"/>

<Item idStr="hidden">

<AcadEntityProps>

<Linetype>HIDDEN2</Linetype> <!-- override the Linetype

for hidden components -->

</AcadEntityProps>

</Item>

</Data>

In this case, different values are given depending upon whether the current
drawing is Imperial or Metric.

NOTE if you have unit-specific values, you must include an element for both
Imperial and Metric. You cannot include two entries from the same unit system
(for example, “mm” and “cm”). A hard conversion will be done for any units
specified within the same unit system.

<Implementation> Section

The Implementation section can look like any of the following examples
(<ObjectARX>, <VBA>, and <ManagedDotNet>):
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<ObjectARX>

<Implementation>

<ObjectARX>

<AppName>AecDtl50</AppName>

<RcpFunc>AecDtlRcpColumnCapCCSide</RcpFunc>

</ObjectARX>

</Implementation>

Is...Where...

the logical appname that appears in the
Registry for an ObjectARX application.

AppName

the name of a Recipe function that is imple-
mented within the ObjectARX module and

<RcpFunc>

is registered using the AecRcpBase frame-
work object AecRcpFuncTable. The function
signature should take no arguments and
must return a value of type RcpStatus

<VBA>

<Implementation>

<VBA projectName="M:/Juneau/bin/TestDtl_VBA.dvb" macro

Name="DrawRectangle"/>

</Implementation>

Is...Where...

the pathname of the VBA project file that
contains the macro. This can be a full

projectName

pathname, a partial path relative to the
location of the XML file, or it can use the
“dirKey” attribute to specify a path from
the DirKeys table in the component data-
base.

The VBA macro name to call. This macro
should take no arguments and returns no

macroName

value. It needs to call the function aecDtl-
SetRcpReturnStatus()before returning.
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<ManagedDotNet>

<Implementation>

<ManagedDotNet moduleName="M:/Juneau//bin/TestDtl_VB.dll" fun

cRcp="DrawRectangle"/>

</Implementation>

Is...Where...

the DLL pathname where the function ex-
ists. This can be a full pathname, a partial

moduleName

path relative to the location of the XML
file, or it can use the “dirKey” attribute to
specify a path from the DirKeys table in the
component database.

the name of a Recipe function that is imple-
mented within the ObjectARX module and

funcRcp

is registered usingn the AecRcpBase
framework object AecRcpFuncTable. The
function signature should take no argu-
ments and must return a value of type
RcpStatus

<Controls> Section

The Controls section contains a list of control definitions that will be added
to the Properties palette, or prompted for on the command line. All controls
must have an idStr attribute that the program can use to reference it. It must
also have a <Label> element to display in the Properties palette. Optionally,
controls can have a <Description> element to use as a “tip” string in the bottom
of the Properties palette when this control has focus. If no <Description>
element is present, the <Label> element will be used.

Each specific type of control is listed below.

<ComboBox>
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This type of control is used to present a list of choices. It is a simple
single-selection list.

<ComboBox idStr="head">

<Label>Head type</Label>

<Description>Head type to use for bolt</Description>

<ComboBoxValue idStr="blkHeadHex">

<Label>Hex</Label>

</ComboBoxValue>

<ComboBoxValue idStr="blkHeadSq">

<Label>Square</Label>

</ComboBoxValue>

<ComboBoxValue idStr="blkHeadRnd">

<Label>Round</Label>

</ComboBoxValue>

<Default>blkHeadHex</Default>

</ComboBox>

A ComboBox has a list of <ComboBoxValue> nodes that simply specify an
idStr used to uniquely identify that item in the list. Each <ComboBoxValue>
must also have a <Label> element to display within the list.

If the <ComboBox> has a <Default> element, the listed idStr will be used as
the default <ComboBoxValue>. If no <Default> element is present, the first
<ComboBoxValue> will be used as the default.

<Default> [Optional]

The <ComboBoxValue> idStr to use as the default selection in the list.

<CheckBox>

This type of control is used for Boolean values.

<CheckBox idStr="doStagger">

<Label>Stagger columns</Label>

<Default>0</Default>

</CheckBox>

It can have the following elements:

DescriptionElement

The default Boolean value. It can be spe-
cified as any of the following values: “1”,
“0”, “true”, or “false.”.

<Default> [Optional]

<EditBoxAngle>
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This type of control corresponds to the AecEditBoxAngle class in AutoCAD
Architecture and has the same basic options.

<EditBoxAngle idStr="slope">

<Label>Slope angle</Label>

<Default>0.0</Default>

<Validation>range</Validation>

<RangeLow>-45.0</RangeLow>

<RangeHigh>45.0</RangeHigh>

</EditBoxAngle>

It can have the following elements:

DescriptionElement

The default angle value. This value is spe-
cified in degrees:

<Default> [Optional]

Specifies what type of validation rule is
used. Possible values are: “Any”, “NoZero”,

<Validation> [Optional]

or “Range”. If not specified, “Any” is used
by default.

The lower end of the range of allowable
values.

<RangeLow> [Optional, except when valid-
ation="Range"]

The high end of the range of allowable
values.

<RangeHigh> [Optional, except when val-
idation="Range"]

<EditBoxDistance>

This type of control corresponds to the AecEditBoxDist class in AutoCAD
Architecture and has the same basic options.

<EditBoxDistance idStr="rowSpacing" unitDep="true">

<Label>Y-Axis</Label>

<Description>Spacing between bolts in Y direction</Description>

<Default>2.0</Default>

<Validation>NoNeg</Validation>

</EditBoxDistance>
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It can have the following attributes:

DescriptionAttribute

This attribute indicates whether the value
of this control needs to be scaled to the

unitDep [Optional]

current unit in the drawing. A value of “1”
or “true” will cause the value to be scaled.
A value of “0” or “false” will leave the value
as specified

The <EditBoxDistance> control can have the following elements:

DescriptionElement

The default distance value.<Default> [Optional]

Specifies what type of validation rule is
used. Possible values are: “Any”, “NoNeg”,

<Validation> [Optional]

“NoZero”, or “Range”. If not specified,
“Any” is used by default.

The lower end of the range of allowable
values.

<RangeLow> [Optional, except when valid-
ation="Range”]

The high end of the range of allowable
values.

<RangeHigh> [Optional, except when val-
idation="Range"]

<EditBoxInt>

This type of control corresponds to the AecEditBoxDist class in AutoCAD
Architecture (with precision set to “0”) and has the same basic options.

<EditBoxInteger idStr="cols">

<Label>Columns</Label>

<Description>Number of bolts in Y direction</Description>

<Default>2</Default>

<Validation>NoNegNoZero</Validation>

</EditBoxInteger>

It can have the following elements:

DescriptionElement

The default integer value.<Default> [Optional]
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DescriptionElement

Specifies what type of validation rule is
used. Possible values are: “Any”, “NoNeg”,

<Validation> [Optional]

“NoZero”, “NoNegNoZero”, or “Range”.
If not specified, “Any” is used by default.

The lower end of the range of allowable
values.

<RangeLow> [Optional, except when valid-
ation="Range"]

The high end of the range of allowable
values.

<RangeHigh> [Optional, except when val-
idation="Range"]

<Picture>

A Picture control is used to display a static image in the Properties palette. It
has a list of <PictureValue> elements that may be used to fill the Picture control
under certain conditions.

<Picture idStr="end_conditions_illustration" rowHeight="5">

<Label>End conditions illustration</Label>

<Default>plain_plain</Default>

<Varies>plain_plain</Varies>

<PictureValue idStr="regular_regular" idFile="Images/cmu_regu

lar_regular.png">

<ParentControl idRef="leftEndStyle" idStr="regular"/>

<ParentControl idRef="rightEndStyle" idStr="regular"/>

</PictureValue>

<PictureValue idStr="regular_plain" idFile="Images/cmu_regu

lar_plain.png">

<ParentControl idRef="leftEndStyle" idStr="regular"/>

<ParentControl idRef="rightEndStyle" idStr="plain"/>

</PictureValue>

</Picture>

A Picture control can have the following attributes:

DescriptionAttribute

The number of rows that this control
should occupy in the Properties palette.
The default value is 3.

rowHeight [Optional]
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A Picture control can have the following elements:

DescriptionElement

The idStr of the <PictureValue> to show by
default.

<Default> [Optional]

The idStr of the <PictureValue> to show
under a multiple selection condition in the

<Validation> [Optional]

Properties palette. If not specified, the
<Default> is used.

Specifying Controls

When the same control is used by different Recipes within the same RecipeSpec,
you can define them in the <ControlDefs> section and then reference them
within the <Controls> section of a specific Recipe.

<ControlRef idRef="head"/>

Simply use the idRef attribute to refer to the idStr of the Control that is defined
in the <ControlDefs> section.
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The following example shows a control defined at the <RecipeSpec> level that
can be referenced from any <Recipe>. It also shows a control that is defined
local to a specific <Recipe>.

<?xml version="1.0" encoding="UTF-8"?>

<AecRecipeSpec defaultUnit="in">

<ControlDefs>

<CheckBox idStr="hatchBlock">

<Label>Hatch block</Label>

<Description>Specifies whether to hatch the block. </Descrip

tion>

<Default>1</Default>

</CheckBox>

</ControlDefs>

<Recipe idStr="section">

<Label>Section</Label>

<Implementation>

<ObjectARX>

<AppName>AecDtl50</AppName>

<RcpFunc>ConcreteUnit2CoreSection</RcpFunc>

</ObjectARX>

</Implementation>

<Controls>

<ControlRef idRef="hatchBlock"/>

<CheckBox idStr="hatchCores">

<Label>Grout fill cores</Label>

<Description>Specifies whether to hatch the cores solid with

grout.</Description>

<Default>0</Default>

</CheckBox>

</Controls>

<Data> Section

This section has customization data that is used by the Rcp function. This
includes things like simple Layer/Color/Linetype properties, hatch pattern
information, spacing parameters, and so on. It is the Rcp function’s
responsibility to look back to this section and find any data that may be
relevant.

There is an implicit contract between the Rcp function and the RecipeSpec.
The Rcp function can decide what is allowed to be in the <Data> section, but
it will usually contain a set of commonly seen elements. You can put virtually
anything in the <Data> section, but if the Rcp function is not expecting it, it
will be ignored.
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The data within this section is divided into <Item> sections. Each Item section
can contain virtually anything that the Recipe dictates. An Item section usually
defines the data for a portion of the overall component, such as “boundary”,
“infill”, and “hidden”.

The following standard types of information appear regularly within an Item
section:

■ <AcadEntityProps>

■ <AcadBlockProps>

■ <AcadMInsertProps>

■ <AcadHatchProps>

■ <Params>

These standard information elements are described individually in the
following sections.

<AcadEntityProps>

This Element specifies the Layer/Color/Linetype properties of an entity. All
the items are optional and are only used if specifically listed. If they are not
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listed, the Rcp function should use either ByBlock or ByLayer (or whatever
the appropriate setting is) as the default. Here are four examples:

<AcadEntityProps>

<Layer ref="layerKey">FINE</Layer>

<Linetype>HIDDEN</Linetype>

</AcadEntityProps>

<AcadEntityProps>

<Layer>Jimbo</Layer>

<ColorIndex>1</ColorIndex>

<Linetype>DASHED</Linetype>

<LinetypeScale>3.0</LinetypeScale>

<Lineweight>53</Lineweight>

</AcadEntityProps>

<AcadEntityProps>

<Layer>Jimbo</Layer>

<Color>

<Red>73</Red>

<Green>179</Green>

<Blue>157</Blue>

</Color>

<Linetype>DASHED</Linetype>

</AcadEntityProps>

The following Elements can be specified within <AcadEntityProps>:

■ <Layer> [Optional]

■ <ColorIndex> [Optional]

■ <Color> [Optional]

■ <Linetype> [Optional]

■ <LinetypeScale> [Optional]

■ <Lineweight> [Optional]

NOTE Either <Color> or <ColorIndex> can appear, but not both. If <Color> is
used, it should have <Red>, <Green>, and <Blue> sub-elements, as in the example
above.

<AcadBlockProps>
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This Element specifies the properties of a block reference. Here are a few
examples:

<AcadBlockProps>

<BlockName dwgLib="dwgs/AecDtlLib_BlockTest.dwg"

remapLayers="true">Jimbo</BlockName>

<ScaleX ref="dbTable">SCALE_X</ScaleX>

<ScaleY ref="dbTable">SCALE_Y</ScaleY>

<ScaleZ ref="dbTable">SCALE_Z</ScaleZ>

</AcadBlockProps>

<AcadBlockProps>

<BlockName dwgLib="dwgs/AecDtlLib_BlockTest.dwg"

remapLayers="true">Jimbo</BlockName>

<Scale>6.0</Scale> <!-- This one uses uniform scale-->

</AcadBlockProps>

<AcadBlockProps>

<BlockName dwgLib="dwgs/AecDtlLib_TrenchDrains.dwg" remapLay

ers="true"

ref="dbTable">R_BLOCK</BlockName>

</AcadBlockProps>

The following Elements can be specified within <AcadBlockProps>:

■ <BlockName>

■ <Scale> [Optional]

■ <ScaleX> [Optional]

■ <ScaleY> [Optional]

■ <ScaleZ> [Optional]

■ <Rotation> [Optional]

The <BlockName> element tells the name of the block definition to use and
can include the following attributes providing instructions on how to load
the block if it is not found in the current drawing:

DescriptionAttribute

The pathname of the library DWG file
where the block is defined. If a relative path

dwgLib [Optional]

is specified, it is relative to the XML Re-
cipeSpec’s location.
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DescriptionAttribute

A directory key to look up in the detail
component database. The dwgLib attribute

dirKey [Optional]

value is then appended to the dirKey value
to form the full pathname.

A Boolean value specifying whether the
layers for entities within the block are to

remapLayers [Optional]

be searched for LayerKeys. If a LayerKey is
found as the value of the Layer, the Layer
is remapped to that LayerKey. This value
should only be specified as true if you know
for certain that there are LayerKeys defined
within the block.

If specified, the block name is a lookup
value to find the real block name.

ref [Optional]

If <Scale> is used, it is a uniform scale for each axis of the block reference.

<AcadMInsertProps>

This element specifies the additional values that an MInsert can have above
and beyond a Block Reference. Anything common to both MInserts and Block
References will thus appear in the <AcadBlockProps> section.

<AcadMInsertProps>

<Rows>2</Rows>

<RowSpacing>5.0</RowSpacing>

<Columns>3</Columns>

<ColumnSpacing>6.0</ColumnSpacing>

</AcadMInsertProps>

<AcadMInsertProps>

<Rows ref="dbTable">ROWS</Rows>

<RowSpacing>5.0</RowSpacing>

<Columns ref="dbTable">COLUMNS</Columns>

<ColumnSpacing>6.0</ColumnSpacing>

</AcadMInsertProps>

The following Elements can be specified within <AcadMInsertProps>:

■ <Scale> [Optional]

■ <Rows> [Optional]

Recipe Specifications | 3973



■ <RowSpacing> [Optional]

■ <Columns> [Optional]

■ <ColumnSpacing> [Optional]

<AcadHatchProps>

This Element specifies the properties of a hatch. Here are a few examples:

<AcadHatchProps>

<HatchAlias>brick</HatchAlias>

</AcadHatchProps>

<AcadHatchProps>

<HatchAlias ref="dbTable">PAT_ALIAS</HatchAlias>

</AcadHatchProps>

<AcadHatchProps>

<PatternName>Escher</PatternName>

<PatternScale>4.0</PatternScale>

<PatternAngle>45.0</PatternAngle>

</AcadHatchProps>

The following Elements can be specified within < AcadHatchProps >:

DescriptionElement

The name of an Alias from the Detail
Component database’s Hatches table. This

<HatchAlias> [Optional]

table is used so that you can centrally
define the Pattern, Scale, and Angle for
representative materials used throughout
the database. Most RecipeSpecs will use a
Hatch Alias to define all the parameters of
the Hatch. However, you can specify these
values directly by using the other elements.

Possible values are: “PreDefined” (the de-
fault), “User”, or “Custom”.

<PatternType> [Optional]

If the <PatternName> specified (or indir-
ectly referenced from <HatchAlias>) does
not exist, the pattern “ANSI31” is used.

<PatternName> [Optional]

<PatternScale> [Optional]
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DescriptionElement

<PatternMultiplier> [Optional]

<PatternAngle> [Optional]

<PatternDouble> [Optional]

<PatternSpace> [Optional]

<Params>

This Element specifies the parameters specific to this particular Recipe. These
are typically values that the Recipe needs, but that are not hardwired into the
code, and thus are customizable. Here are a few examples:

<Item idStr="boundary">

<Params>

<Tongue>0.125</Tongue>

<GrooveSpacing>0.03125</GrooveSpacing>

</Params>

</Item>

<Item idStr="boundary">

<Params>

<Chamfer>0.5</Chamfer>

</Params>

</Item>

The Element names are defined by the Rcp function itself and must be known
in advance of editing them in the Recipe Spec.

NOTE One way to find out the implied contract of the Rcp function is to turn on
logging. For more information, see Recipe Logging on page 3987.

<Options> Section

This section provides customization data that is used by the placement phase
(Jig) of the Rcp function. In most cases, Recipe functions divide their labor
into two phases:

1 Creation of the component

2 Placement of the component
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The job of placing the component is usually handled by a standard Jig that
may be controlled by elements specified in the <Options> section. You must,
of course, have advanced knowledge of which Jig and JigEnt are used by a
Recipe function in order to take advantage of this.
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The example below is from the Brick Pavers component group. It uses the
LinearArrayJig to repeat a row of blocks at a specified spacing.
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<?xml version="1.0" encoding="UTF-8"?>

<AecRecipeSpec defaultUnit="in">

<Recipe idStr="section">

<Label>Section</Label>

<Implementation>

<ObjectARX logicalAppname="AecDtl50" funcRcp="AecDtlRcpUnit

Paver"/>

</Implementation>

<Controls>

<CheckBox idStr="doHatch">

<Label>Hatch item</Label>

<Default>1</Default>

</CheckBox>

</Controls>

<Data>

<Item idStr="block">

<AcadEntityProps>

<Layer ref="layerKey">MED</Layer>

</AcadEntityProps>

</Item>

<Item idStr="boundary">

<Params>

<Chamfer>0.0</Chamfer>

</Params>

</Item>

<Item idStr="infill">

<AcadHatchProps>

<HatchAlias>brick</HatchAlias>

</AcadHatchProps>

<AcadEntityProps>

<Layer ref="layerKey">HATCH</Layer>

</AcadEntityProps>

</Item>

</Data>

<Options>

<JigEnt>

<GapSpacing>0.25</GapSpacing>

</JigEnt>

<Jig>

<PromptCount>Number of courses</PromptCount>

</Jig>

</Options>

</Recipe>
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</AecRecipeSpec>

In the <Options> section, it tells the JigEnt to put a ¼" spacing between each
paver, and it changes the prompt string for one of the prompts issued by the
Jig.

For more information about which options are available for specific Jigs and
JigEnts, see Jigs and JigEnts on page 3979.

Jigs and JigEnts
A “Jig” is a programming construct that defines how the user adds objects to
the drawing. You can think of it as an “Add” command that gives visual
feedback as you are specifying what the object looks like. For instance, the
simple Arc Jig in AutoCAD dynamically sketches out the potential arc while
you input various values.

A “JigEnt” is the object used to draw the visual feedback. In AutoCAD and
AutoCAD Architecture, this is usually the same type of object that is being
created (for example, the Wall Jig would use a Wall object). In the Recipe
framework, most components are not represented by an object type, but by
a collection of AutoCAD primitive objects such as hatch, polyline, and block.
In this case, a JigEnt is a temporary in-memory object that is used to draw
during the lifetime of the Jig, but is then thrown away when the real objects
are added to the drawing.

The Recipe framework uses a system that plugs specific JigEnts into common
Jigs. This allows a single Jig that is responsible for linear components (that is,
one that prompts for “Start point” and “Endpoint”) to look completely
different depending upon the JigEnt being used (for example, a row of bricks
vs. a metal joist).

Although development of new Jigs and JigEnts is currently available only to
ObjectARX programmers, many aspects of the existing Jigs and JigEnts can
be controlled via lightweight customization techniques. In order to understand
this, it is helpful to have an idea of how the existing Jigs and JigEnts are
programmed.
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Hierarchy of Jigs

AecEdJigRcp

AecEdJigCircle

AecEdJigLine

AecEdJigLineBlockBased

AecEdJigLinearArray

AecEdJigStretch

AecEdJigLineOriented

AecEdJigLineExtend

AecEdJigSurface

AecEdJigRectangle

AecEdJigStamp

NOTE The level of indentation shows the inheritance. For example, if you want
to know the behavior and options for AecEdJigLinearArray, you can see that it
inherits all the behavior and options for AecEdJigLineBlockBased, AecEdJigLine,
and AecEdJigRcp.

Hierarchy of JigEnts

AecEdJigRcp

AecEdJigEntCircle

AecEdJigEntLine

AecEdJigEntLineBlockBased

AecEdJigEntBookends

AecEdJigEntLinearArray

AecEdJigEntStretch

AecEdJigEntLineOriented

AecEdJigEntLineExtend

AecEdJigEntSurface

AecEdJigEntSurfaceHlines

AecEdJigEntMeasure

AecEdJigEntRectangle

As you can see, Jigs and JigEnts correspond pretty closely at the upper levels.
However, there are extra JigEnts that can re-use the same Jig. The ones listed
here are only the common JigEnts. There are many specific JigEnts derived
off of these. For example, there is a specific JigEnt for each type of wood and
metal joist, all derived off AecEdJigEntLineExtend to get the majority of their
behavior. No special Jig is needed for each of these, because they all ask for
the same sequence of information. If all the internal programmed objects for
detail components were listed, you would see many more JigEnts, but not
many more Jigs.
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Common Jigs
The common Jigs and JigEnts listed in the hierarchy above have options that
can be specified in the <Options> section of the Recipe Spec, and in some
cases, they have common Recipes that can be utilized without writing any
new code.

Brief descriptions for some of the common Jigs are provided below, along with
information on the <Options> or Recipe func that can be used with each one,
if applicable.

Stamp Jig

The Stamp Jig is similar to the INSERT command in that it does a basic block
insertion (with a few extra controls). Here is an example showing how the
Options section is used to control the Jig’s behavior.

<Options>

<Jig>

<AllowScaling>false</AllowScaling>

<AllowRotation>true</AllowRotation>

<AllowXFlip>true</AllowXFlip>

<AllowYFlip>true</AllowYFlip>

<AllowBasePt>true</AllowBasePt>

</Jig>

</Options>

In each case, the value listed is the default, which would be used if nothing
was specified.

The following table lists the options for Stamp Jigs

CommentOption

<AllowScaling>

<AllowRotation>

<AllowXFlip>

<AllowYFlip>

Boolean value specifying whether the
common command line options of the Jig
are valid options for this Recipe.

<AllowBasePt>
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To use this Jig directly from a common recipe function, use the following
section of RecipeSpec:

<Implementation>

<ObjectARX>

<AppName>AecRcpBase40</AppName>

<RcpFunc>Stamp</RcpFunc>

</ObjectARX>

</Implementation>

Linear Array Jig

The Linear Array Jig puts multiple copies of a block reference in a line, oriented
in either the X or Y direction, with a specified spacing between each instance.
Here is an example showing how the Options section is used to control the
Jig’s behavior.

<Options>

<Jig>

<IsOrientedX>true</IsOrientedX>

<PromptStart>Start point</PromptStart>

<PromptEnd>End point</PromptEnd>

<PromptCount>Count</PromptCount>

<AllowXFlip>true</AllowXFlip>

<AllowYFlip>true</AllowYFlip>

<AllowCount>true</AllowCount>

</Jig>

<JigEnt>

<IsOrientedX>true</IsOrientedX>

<Width>0.0</Width>

<GapSpacing>0.0</GapSpacing>

<JigEnt>

</Options>

In each case, the value listed is the default and would be used if nothing was
specified.

The following table lists the Jig options for Linear Array Jigs

CommentJig Option

Boolean value specifying whether items
along the line are oriented in the X direc-
tion or the Y direction.

<IsOrientedX>
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CommentJig Option

Text string to use for the start point
prompt.

<PromptStart>

Text string to use for the endpoint prompt.<PromptEnd>

Text string to use for the count prompt.<PromptCount>

<AllowXFlip>

<AllowYFlip>

Boolean value specifying whether the
common command line options of the Jig
are valid options for this Recipe.

<AllowCount>

The following table lists the JigEnt options for Linear Array Jigs

CommentJigEnt Option

Boolean value specifying whether items
along the line are oriented in the X direc-
tion or the Y direction.

<IsOrientedX>

Specifies the exact width of the Block Ref-
erence being arrayed. If you do not know

<Width>

this value and leave this element out, the
extents of the block will be dynamically
measured. If you know this value, you
should specify it, because measuring the
extents dynamically can sometimes intro-
duce rounding errors that can affect the
overall dimensions of the array.

The distance between each arrayed item.
You can use a negative value to get items
to overlap.

<GapSpacing>
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To use this Jig directly from a common recipe function, use the following
section of Recipe Spec.

<Implementation>

<ObjectARX>

<AppName>AecRcpBase40</AppName>

<RcpFunc>LinearArray</RcpFunc>

</ObjectARX>

</Implementation>

When using this function, you can also specify an <RcpFunc> directive that
will allow you to package all the individual blocks in the array into a single
block reference. By default, this value is set to “false” and each item in the
array will be its own block reference.

<Options>

<RcpFunc>

<PackageAsBlock>true</PackageAsBlock>

</RcpFunc>

</Options>

Bookends Jig

The Bookends Jig is similar to the Linear Array Jig, but allows for a different
block on each end as well as a block that is arrayed to fill the gap between the
two ends. The “start” and “end” blocks are used once, and the “repeat” block
is used however many times it needs to be in order to fill the space between.
Here is an example usage:

<Options>

<Jig>

<IsOrientedX>true</IsOrientedX>

<PromptStart>Start point</PromptStart>

<PromptEnd>End point</PromptEnd>

<AllowXFlip>true</AllowXFlip>

<AllowYFlip>true</AllowYFlip>

</Jig>

<JigEnt>

<IsOrientedX>true</IsOrientedX>

<WidthStart>0.0</WidthStart>

<WidthRepeat>0.0</WidthRepeat>

<WidthEnd>0.0</WidthEnd>

<GapSpacing>0.0</GapSpacing>

</JigEnt>

</Options>

3984 | Chapter 56   Customizing and Adding New Content for Detail Components



In each case, the value listed is the default and would be used if nothing was
specified.

The following table lists the Jig options for Bookends Jigs

CommentJig Option

Boolean value specifying whether items
along the line are oriented in the X direc-
tion or the Y direction.

<IsOrientedX>

Text string to use for the start point
prompt.

<PromptStart>

Text string to use for the endpoint prompt.<PromptEnd>

Text string to use for the count prompt.<PromptCount>

<AllowXFlip>

Boolean value specifying whether the
common command line options of the Jig
are valid options for this Recipe.

<AllowYFlip>

The following table lists the JigEnt options for Bookends Jigs

CommentJigEnt Option

Boolean value specifying whether items
along the line are oriented in the X direc-
tion or the Y direction.

<IsOrientedX>

Specifies the exact width of the Block Ref-
erence at the beginning of the array. If you

<WidthStart>

do not know this value and leave this ele-
ment out, the extents of the block will be
dynamically measured. If you know this
value, you should specify it, because
measuring the extents dynamically can
sometimes introduce rounding errors that
can affect the overall dimensions of the ar-
ray.
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CommentJigEnt Option

Same as above, but for the ending block
of the array.

<WidthEnd>

Same as above, but for the repeating block
of the array

<WidthRepeat>

The distance between each arrayed item.<GapSpacing>

To use this Jig directly from a common recipe function, use the following
section of RecipeSpec.

<Implementation>

<ObjectARX>

<AppName>AecRcpBase40</AppName>

<RcpFunc>Bookends</RcpFunc>

</ObjectARX>

</Implementation>

When using this function, you can also specify an <RcpFunc> directive that
will allow you to package all the individual blocks in the array into a single
block reference. By default, this value is set to “false” and each item in the
array will be its own block reference.

<Options>

<RcpFunc>

<PackageAsBlock>true</PackageAsBlock>

</RcpFunc>

</Options>

Surface Jig

This Jig creates a basic rectangular boundary of a given depth, where the user
is asked for an arbitrary start and endpoint (similar to adding Walls in AutoCAD
Architecture). Here is an example usage:

<Options>

<Jig>

<PromptStart>Start point</PromptStart>

<PromptEnd>End point</PromptEnd>

<AllowXFlip>true</AllowXFlip>

<AllowYFlip>true</AllowYFlip>

</Jig>

</Options>
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In each case, the value listed is the default and would be used if nothing was
specified.

To use this Jig directly from a common recipe function, use the following
section of RecipeSpec.

<Implementation>

<ObjectARX>

<AppName>AecRcpBase40</AppName>

<RcpFunc>Surface</RcpFunc>

</ObjectARX>

</Implementation>

StampMInsert Jig

The StampMInsert Jig is the same as the Stamp Jig, except that it uses an
MInsert instead of a simple Block Reference.

SurfaceBound Jig

The SurfaceBound Jig is the same as the Surface Jig, except that it keeps only
the top three edges of the rectangle. It is used for components that are poured
onto or bounded by another entity that provides the bottom edge of the
rectangle. For an example, see Concrete Topping.

SurfaceLtype Jig

The SurfaceLType Jig is the same as the Surface Jig, except that it fills with a
wide polyline of a given linetype, instead of a hatch.

ApplyToLinework Jig

The ApplyToLinework Jig is used when you simply need to “brand” existing
linework geometry as a specific component. For example, you could draw a
detail using basic AutoCAD commands and then use this Jig to apply the
Xdata and keynote for a particular component in the database. It will move
the selected geometry to a new layer, if specified, but will not create any
geometry of its own.

Recipe Logging
Without knowing the implied contract of a Recipe function, it is hard to know
(or debug) where all the values are supposed to come from. In some cases,
there may be values for an existing Recipe that you could customize if you
just knew they were there (and currently not specified).

Recipe Logging | 3987



Recipe Logging is a mechanism that will print to the command line every
piece of data that is being retrieved by the Recipe. It will give the source of
the data (for example, the component database, the Recipe Section, the
Properties palette prompt), and whether the value was found or not. Using
this information, you can reverse-engineer what data is expected by the Recipe.

3988 | Chapter 56   Customizing and Adding New Content for Detail Components



The following is an example produced by running the 02/Brick Paver Recipe
with Recipe Logging turned on.
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Command: dtlcompmanager

RCP LOG > Source: Database

Field: WIDTH

Type: double

Required: True

Found: True

Value: 4.00000

RCP LOG > Source: Database

Field: LENGTH

Type: double

Required: True

Found: True

Value: 8.00000

RCP LOG > Source: Database

Field: THICKNESS

Type: double

Required: True

Found: True

Value: 1.50000

RCP LOG > Source: <Data>

Context: Item[@idStr='boundary']/Params

Tag: Chamfer

Type: double

Required: False

Found: True

Value: 0.00000

RCP LOG > Source: Prompt

Field: coarseOutline

Type: bool

Required: False

Found: False

RCP LOG > Source: Prompt

Field: doHatch

Type: bool

Required: False

Found: True

Value: True

RCP LOG > Source: <Data>

Context: Item[@idStr='infill']/AcadHatchProps

Tag: HatchAlias

Type: str

Required: False

Found: True
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Value: brick

RCP LOG > Source: <Data>

Context: Item[@idStr='infill']/AcadHatchProps

Tag: PatternType

Type: str

Required: False

Found: False

RCP LOG > Source: <Data>

Context: Item[@idStr='infill']/AcadHatchProps

Tag: PatternName

Type: str

Required: False

Found: False

RCP LOG > Source: <Data>

Context: Item[@idStr='infill']/AcadHatchProps

Tag: PatternAngle

Type: double

Required: False

Found: False

RCP LOG > Source: <Data>

Context: Item[@idStr='infill']/AcadHatchProps

Tag: ScaleMultiplier

Type: double

Required: False

Found: False

RCP LOG > Source: <Data>

Context: Item[@idStr='infill']/AcadHatchProps

Tag: PatternScale

Type: double

Required: False

Found: False

RCP LOG > Source: <Data>

Context: Item[@idStr='infill']/AcadEntityProps

Tag: Layer

Type: str

Required: False

Found: True

Value: A-Detl-Patt

RCP LOG > Source: <Data>
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Context: Item[@idStr='infill']/AcadEntityProps

Tag: ColorIndex

Type: long

Required: False

Found: False

RCP LOG > Source: <Data>

Context: Item[@idStr='infill']/AcadEntityProps

Tag: Linetype

Type: str

Required: False

Found: False

RCP LOG > Source: <Data>

Context: Item[@idStr='infill']/AcadEntityProps

Tag: LinetypeScale

Type: double

Required: False

Found: False

RCP LOG > Source: <Data>

Context: Item[@idStr='infill']/AcadEntityProps

Tag: Lineweight

Type: long

Required: False

Found: False

RCP LOG > Source: <Data>

Context: Item[@idStr='block']/AcadEntityProps

Tag: Layer

Type: str

Required: False

Found: True

Value: A-Detl-Medm

RCP LOG > Source: <Data>

Context: Item[@idStr='block']/AcadEntityProps

Tag: ColorIndex

Type: long

Required: False

Found: False

RCP LOG > Source: <Data>

Context: Item[@idStr='block']/AcadEntityProps

Tag: Linetype

Type: str

Required: False

Found: False

RCP LOG > Source: <Data>
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Context: Item[@idStr='block']/AcadEntityProps

Tag: LinetypeScale

Type: double

Required: False

Found: False

RCP LOG > Source: <Data>

Context: Item[@idStr='block']/AcadEntityProps

Tag: Lineweight

Type: long

Required: False

Found: False

RCP LOG > Source: <Options>

Context: Jig

Tag: IsOrientedX

Type: bool

Required: False

Found: False

RCP LOG > Source: <Options>

Context: Jig

Tag: PromptStart

Type: str

Required: False

Found: False

RCP LOG > Source: <Options>

Context: Jig

Tag: PromptEnd

Type: str

Required: False

Found: False

RCP LOG > Source: <Options>

Context: Jig

Tag: AllowXFlip

Type: bool

Required: False

Found: False

RCP LOG > Source: <Options>

Context: Jig

Tag: AllowYFlip

Type: bool

Required: False

Found: False

RCP LOG > Source: <Options>
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Context: Jig

Tag: AllowCount

Type: bool

Required: False

Found: False

RCP LOG > Source: <Options>

Context: Jig

Tag: PromptCount

Type: str

Required: False

Found: True

Value: Number of courses

RCP LOG > Source: <Options>

Context: JigEnt

Tag: IsOrientedX

Type: bool

Required: False

Found: False

RCP LOG > Source: <Options>

Context: JigEnt

Tag: Width

Type: double

Required: False

Found: False

RCP LOG > Source: <Options>

Context: JigEnt

Tag: GapSpacing

Type: double

Required: False

Found: True

Value: 0.25000

Start point or [Xflip/Yflip/Count]:

End point or [Xflip/Yflip/Count]: <Ortho on>

Start point or [Xflip/Yflip/Count]:

To turn Recipe Logging on, use the REGEDIT program to change a value in
the Win32 Registry. The entry can be found in:

HKEY_CURRENT_USER\Software\Autodesk\AutoCAD\R17.1\ACAD-XXXX\Pro

files\AutoCAD Architecture\Preferences\AecRcpBase50\RecipeLog

Change this value to "1" to turn it on.

Change this value to "0" to turn it off.
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Blocks and Block Libraries
Libraries of block content for detail components should be created and stored
according to the following guidelines, each of which is discussed in more
detail subsequently.

■ Block content should be drawn with the current style of geometry. (See
Using Optimal Geometry on page 3995.)

■ Blocks should have namespace prefixes. (See Naming Blocks on page 3997.)

■ Base points for inserting blocks should be positioned logically. (See Base
Points for Blocks on page 3997.)

■ Similar blocks should be stored in the same DWG file. (See Collecting
Similar Blocks on page 3997.)

■ Properties of block entities should be set to ByBlock. (See Block Properties
on page 3998.)

■ All unnecessary objects should be removed from block library drawings.
(See Removing Unnecessary Objects on page 3999.)

Using Optimal Geometry
Many block libraries that were created in legacy versions of AutoCAD contain
geometry that is non-optimal in that it can result in performance problems,
incorrect snap points, or tolerance discrepancies that cause errors when Aec
Modify tools or other AutoCAD editing commands are used. You should avoid
using this old-style geometry when creating new blocks, and you should
remove or replace it whenever you encounter it in existing block content.

The following sections describe five main areas in which you should strive to
use optimal geometry.

Polylines

Prior to AutoCAD Release 14, the polyline entity consisted of multiple vertex
entities and was not stored in a compact form. You can identify these old-style
polylines by running the LIST command, which identifies them as type
POLYLINE. Any such entities should be recreated as new-style polylines by
tracing over them manually with the Polyline tool. The LIST command
identifies new-style polylines as LWPOLYLINE.
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Hatch Patterns

Be sure to use actual hatch entities when creating blocks that require hatch
patterns. Prior to AutoCAD Release 14, hatches were anonymous blocks with
all of the entities comprising the pattern stored in the drawing. If you run the
LIST command on an entity that appears to be a hatch, and the entity is
identified as a BLOCK REFERENCE and has a name beginning with *X, then
it is an old-style hatch. Remove and replace with a new, equivalent HATCH
entity.

NOTE In addition to the old-style hatch patterns described above, some blocks
have been found to contain multiple individual line segments repeated so as to
simulate an actual hatch. In such cases, the line segments should be erased and
replaced with an appropriate hatch at the appropriate scale.

Unjoined Polylines

When the endpoints of line or arc segments that form a boundary coincide,
it is vastly more efficient to represent the boundary by using a single polyline.
For example, a rectangle made of four separate lines should be converted to
a single polyline. To do this, use the following procedure:

1 Run the PEDIT command, and select one of the lines.

2 When prompted to turn the line into a polyline, enter y (for Yes).

3 Enter j (for Join), select the other three lines, and press ENTER. In some
cases, the join will fail because the endpoints are not coincident, even
though they appear to be. If this occurs, use object snaps to carefully
reposition the endpoints so that they do coincide.

Pixelized Line Segments

Some conversion programs create a literal translation of what was on the
screen at the time of conversion. This can result in thousands of tiny line
segments placed end-to-end, where there should be a single line segment. In
such cases, you should trace over the entire course of the end-to-end segments
to create a single segment, and then erase all the original pixelized line
segments.

Imprecise Geometry

As is the case with unjoined polylines, any endpoints that appear to coincide
should actually do so. Small tolerance discrepancies can cause other editing
operations to fail. Make sure that geometry that meets visually also meets at
a high degree of precision. One way to ensure coincidence is to turn on Nearest,
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Endpoint, and Midpoint object snap modes, and then adjust the geometry
using its grip points.

Naming Blocks
The names of blocks containing detail component content should have a
namespace prefix to avoid conflicts with other blocks. For example, all blocks
in libraries provided with AutoCAD Architecture use “AecDtl_” as the
namespace prefix. If you are creating your own blocks, you should use a unique
prefix.

Base Points for Blocks
Each block should have a base point that is logically positioned for inserting
the block in relation to other geometry in a drawing; that is, the base point
location should allow the user to insert the block using an object snap on
some other piece of geometry as an insertion point. If possible, the base point
location should also facilitate repeated placement of the item. For example,
a block representing a paver should not have the base point in the middle of
the block, because you would not likely want the middle of the block inserted
at any object snap on existing geometry. Likewise, a base point in the upper-left
corner only makes sense if the item is to be placed under some other geometry.
However, if the base point is at the lower-left corner, the user can snap to the
ground plane, and repeated insertions are easy.

Collecting Similar Blocks
Similar or closely related block definitions should be collected in a single DWG
file. For example, in the details block library supplied with AutoCAD
Architecture, the block definitions for all the different sizes of nails are collected
in a block library drawing file called AecDtlLib_Nails.dwg, and all block
definitions detailing carpet accessories are in a file called
AecDtlLib_CarpetAcc.dwg. As shown below, for each block definition, the drawing
should include a block reference inserted on a horizontal line to show how
the block’s base point is used to position the block in relation to other
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geometry. For each block reference, there should also be a text label containing
the name of the block.

Setting up block library drawings this way makes it easy for the user to quickly
survey the entire library. It also helps you in the process of cleaning up the
drawing, which is explained in a subsequent section (see Removing
Unnecessary Objects on page 3999).

Block Properties
In most cases, blocks should be defined to have their component entity
properties set as follows:

Layer=0

Color=BYBLOCK

Linetype=BYBLOCK

Linetype Scale=1.0

Lineweight=BYBLOCK

To accomplish this after a block has been defined, right-click the block
reference, and click Set Nested Objects to ByBlock.
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Layer Keys
You can use a layer key to map specific entities within a block to a layer in
the drawing into which the block is inserted. For example, the millwork blocks
depicted earlier (see Collecting Similar Blocks on page 3997) have the hatch
entity assigned to the layer “HATCH.” If the Recipe Specification (XML file)
that references this block library has the attribute “remapLayers” set to true,
as shown below, then any layer that matches a layer key in the current drawing
will be replaced with the layer that is assigned to that layer key. In the case
of a drawing using the standard AutoCAD Architecture template file, in which
the HATCH layer key is mapped to the AecDtl-Patt layer, any block library
entities that were assigned to the HATCH layer will end up on the AecDtl-Patt
layer when inserted into the drawing.

<AcadBlockProps>

<BlockName dwgLib="dwgs/AecDtlLib_WoodMillwork.dwg"

remapLayers=”true”>AecDtl_millworkBlk1</BlockName>

<Scale>6.0</Scale>

</AcadBlockProps>

Removing Unnecessary Objects
Once you have ensured that a block library drawing conforms to all the
previously explained guidelines, the final step is to remove all unnecessary
objects (unused layers, text styles, block definitions, and so on) by performing
the following procedure.

1 Use the ZOOM, EXTENTS command to display the extents of the current
drawing.

2 Enter wblock (for Write Block).

3 In the Write Block dialog box, under Source, select Objects.

4 Under Base point, click the Pick point button, and then select a base
point in the lower-left corner of the drawing extents.

5 Under Objects, with Retain selected, click the Select Objects button,
specify a crossing window over the entire contents of the drawing, and
then press ENTER.

6 Under Destination, enter the name of the drawing to be created (for
example, enter the name of the current drawing with a “2” appended),
and specify the units to be used for automatic scaling when the block is
inserted into a drawing that uses different units.
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7 Click OK.

8 Close the drawing.

9 Using Windows Explorer, delete the original drawing.

10 Rename the new drawing by removing the “2” you appended.

The new drawing now contains only the entities you selected and any
other entities directly or indirectly referenced by the selected entities. In
other words, the drawing contains only the absolute minimum set of
objects that it needs.
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Migrating Detail
Component and Keynote
Databases

If you have modified one of the default keynote or detail component databases supplied with
a previous release of the software, you can migrate your modifications to the corresponding
database in the current release using the Detail Component/Keynote Database Migration
utility. As explained in the following topics, use of this utility is not supported if the previous
and current databases use different versions of the CSI MasterFormat standard.

Migrating Your Database Modifications
AutoCAD Architecture provides default Microsoft® Access databases for detail
components and keynotes. If you have modified either of these databases in a
previous release (or created your own databases using the same schema), you
can migrate your modifications to the corresponding database in the current
release using the Detail Component/Keynote Database Migration utility. Accessed
from the CAD Manager menu, this utility compares the modified database (the
source) with its counterpart in the current release (the target) and updates the
current database to reflect your modifications.
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IMPORTANT Beginning with AutoCAD Architecture 2012, the US detail component
and keynote databases supplied with the software use the CSI MasterFormat 2004
standard. Using the Detail Component/Keynote Database Migration utility to
migrate your customizations from a database that uses the CSI MasterFormat 95
standard (as in Autodesk Architectural Desktop 2007 and previous releases) is not
supported. The utility will not properly migrate custom records from the older
database and may errantly overwrite records in the new database with
MasterFormat 95 data. If you want to use a MasterFormat 95 database with the
current release of AutoCAD Architecture, you can load it as described under Adding
a Detail Component Database to Available Databases on page 3583 or Adding a
Keynote Database on page 3635. Note that the older database must be located with
the previous release content and must maintain that content folder structure to
function properly. An older detail component database will not function with 2008
or later US details content. Likewise, an older keynote database will not
automatically keynote 2008 or later US details content; it will only keynote detail
components inserted using previous version details or details in previous version
drawings. The Detail Component/Keynote Database Migration utility can still be
used to migrate records from one CSI MasterFormat 95 database to another. Note
also that using the Database Migration utility to update an older database with
data from a current-release database is not supported. The utility is designed only
for migrating modifications in the other direction; that is, from the older database
to the database in the current release.

The migration utility operates according to the following assumptions and
rules:

■ Both the source and target databases must be of the same type (either
Component or Keynote), as identified by the first record in their Fingerprint
tables. (For more information on the tables and records included in these
databases, see Customizing and Adding New Content for Detail
Components on page 3945 and Keynote Database Schema on page 3649.)

■ Both the source and target databases must use the same version of the CSI
MasterFormat standard.

■ If a table in the source database has no counterpart in the target database,
the table and all its records are added to the target database.
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■ Tables of the same type (as identified by their ID fields) are compared, and
source records that differ from their counterparts in the target database
(or have no counterparts) are processed as shown in the following matrix.

No corresponding target
record exists

Corresponding target
record exists

source record added to target
table

source record overwrites
target record

Modified field in
source record = true

source record added to target
table

source record is not mi-
grated; target record is not
changed

Modified field in
source record =
false

NOTE If you have added a detail component size table or keynote of your
own in the previous release, and it happens to have the same table name or
keynote key as a new table or keynote supplied in the current release, it will
not be processed by the migration utility, because its ID will differ from its
namesake in the current release. If this scenario seems likely in your case, it is
recommended that you check to see if the name you assigned is present in
the current release. If so, you should change the name of your table or keynote
key before running the migration utility.

■ If a source database record has been modified using the Detail Component
Manager or the Keynote Editor, its Modified field value is set to true
automatically, and the record will overwrite the corresponding record in
the target database, or be added to the target database if there is no
corresponding record present.

■ If a source database record has been modified using Microsoft® Access
directly, and the Modified field value was not set to true manually, the
record will be added to the target database if there is no corresponding
record present.

■ The migration utility processes only tables and records as described above;
it does not migrate any associated XML or DWG content files, nor does it
migrate default values specified for particular fields in tables. Preserving
such information requires manually updating the target database.

NOTE If migrated records were created using Microsoft® Access directly (rather
than through the Detail Component Manager), and they do not have a valid
record ID (equal to or greater than 100000), it may result in a conflict with records
in the target database.
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Running the Detail Component/Keynote Database Migration
Utility

Use this procedure to migrate modifications from a detail component database
or keynote database supplied with a previous release of the software to the
corresponding database in the current release. Both databases should use the
same version of the CSI MasterFormat standard.

NOTE Be sure to create a backup copy of the target database before running the
migration utility. If the migration process is terminated before completion, the
target database may not be usable.

1 On the Start menu (Windows), click Programs  ➤ Autodesk
 ➤ AutoCAD Architecture 2012 ➤ Detail Component - Keynote
Database Migration Utility.

2 For Merge from, click  , select the modified detail component
or keynote database (the source) you want to migrate, and click
Open.
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3 For Merge into, click  , select the database to which you want
to migrate your modifications (the target), and click Open.

NOTE The target database selected in this step must be the same
type (either detail component or keynote) as the source database
selected in Step 2.

4 Click OK.

The utility compares the two specified databases and displays the
results for each table processed, including which tables have been
added and how many records have been modified or added for
each table in the target database.
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AEC dimension tools
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objects 3424
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reversing direction 3433
selecting objects in style 3460
specifying object dimension

points 3447
specifying other display

properties 3449
specifying the AutoCAD style 3449
stairs 3397
superscript 3405
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AEC drawings, creating 3920
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center 2852
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standards 2981
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editing 3669
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editing 3014
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tools 2539
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creating 3605
editing 3607
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manual 3005
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creating 3733
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adjust position 3935
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libraries) 130
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adding catalogs from registry 145
managing 136
opening a web page 149

catalog types
creating 152

catalog, Renovation styles 597
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sorting 153
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categories, project 390
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changing 398
creating by dragging folders 394
creating in Project Navigator 393
default folder structure 313, 390
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overview 312
redirecting top-level 396–397
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creating 2812
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with 2811
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creating
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from layout grids 2809
user-specified settings 2807

defined 2749
dimensions, changing 2813
display, changing 2826
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location 2825
masking 2822
modifying 2813
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notes 2824
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adding 2692
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editing objects in cells 1573
inserting objects 1485
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editing 3882
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schedules, including in 3874
troubleshooting 3902

cleanup circles
about 1333
radius circles in walls 1333

cleanup group definitions, in Style
Manager 870

cleanup radius, changing 1341
cleanups

conditions 1336

dynamic cleanup radius
variable 1335

guidelines 1339
L-intersections 1325
multiple intersections 1330
overrides 1357
troubleshooting 1343
vertices 1363
wall cleanup groups 1352
wall priorities 1337
workflow 1323

clipping profiles
ceiling grids 2821
column grids 2800

CNC machining applications 3937
COGO points

importing 260
Coincident constraints 1150
Collinear constraints 1152
colors

wall components 1239
column grid bubbles

creating 3666
inserting 3668

column grid tools, finding in
palettes 2750

column grids
changing dimensions 2760
changing location 2803
changing node radius 2805
clipping profiles 2800
creating 2751–2752

dynamically 2756
from layout grid 2755

creating tools 2756
defined 2749
dimensioning 2759
display, changing 2804
door and window placement 1182
editing 2758
enhanced custom column

grids 2772
holes 2801
hyperlinks 2802
labeling 2758, 2768–2769
layout grid, creating from 2755
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layout types 2751
lines

adding 2762–2763
changing 2761, 2814
moving 2766–2767, 2772, 2820
removing 2764–2765
removing from manual

grids 2765
masking 2801
notes 2802
properties 2774
radial 2751
rectangular 2751
reference files 2802
removing holes 2802

columns
(See also structural members) 2525
anchoring to grids 2577, 2579
creating with user-defined

profiles 2538, 2576
freestanding 2571–2572
steel and concrete 2656
tools 2549

command line
drawing compare commands 711
drawing management

commands 562
new project environment,

selecting 564
opening drawing compare

palette 711
opening visual filter dialog 711
Project Browser 562
Project Navigator 563–564
projects, refreshing 563
views, regenerating 563

command tools 96
command window 47
commands, custom AEC 3927
Communication Center 54
component cleanup overrides 1357
components (See individual component

names) 1497
conceptual models 1003

(See also mass models) 1003
ConditionType property 3191

cone mass elements 1013
configurations, display (See display

configurations) 810
constraints

AEC objects 1148
Aligned constraints 1155
Angular constraints 1156
Coincident constraints 1150
Collinear constraints 1152
Fix constraints 1155
Horizontal constraints 1154
Radial constraints 1158
Vertical constraints 1151
working with AEC object

constraints 1148
construction lines 2829

creating 2832
creating from existing objects 2829
creating from linework 2829
multi-landing stairs, changing 2166
u-shaped stairs, changing 2172

constructs, project 400, 402
blocks, inserting 415
content of 403
creating 404, 425
deleting 422, 425
divisions 400
dragging objects into 412
drawings, converting 408
electronically transmitting 421
elements

compared to 427
converting to 423

external references
attaching 414
displaying 417
overlaying 414

interactions with project 425
legacy drawings, converting 401, 

409
levels 400
levels and divisions 425
levels, copying to 401, 407
names 425
opening and closing 411
overview 305
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properties 419
referencing elements into 413
referencing elements into

multiple 415
views, compared to 401
when to start with 402
XML files 401

Content Browser
(See also tool catalog libraries, tool

catalogs, tool packages, tool
palettes) 129

AEC content 3909
Always on Top option 167
catalog items

dragging 175
opening 174

command prompt, starting
from 177

multiple windows 173
overview 129
project library 344, 632
rows, specifying number of 134
tool catalogs, opening 174
tool palettes 82
tools 101

adding from styles 141, 629
creating from styles 138, 626

user interface 131
viewing a web page 149
window, keeping on screen 167

Content Browser library
activating for projects 378
for projects 318
project catalog, adding 631

context help 54
context menus 42
contours

generating from LandXML 266
converting

drawing files to constructs 433
copying and assigning object styles 875
copying, projects 328
corner frames (windows) 1961
corner windows

about 1958
creating 1964

dimensions 1960
editing 1959
frames 1961
grips 1959, 1985
measuring 1960
properties 1960
relocating 1985
styles 1960

countable linear repeating pattern
components 3534

Create AEC Content wizard 2868
creating objects with tools 87
Crop command 2847
curtain wall cells

cell assignments 1487
filling with panels 1484
infills 1455, 1486
objects, inserting 1485

curtain wall components
custom graphics 1503
display 1500
hatching 1501
layer, color, and linetype 1501

curtain wall dimensions 1422, 1425
curtain wall frames 1467

assigning definitions 1489
curtain wall grids 1417

cells 1477
fixed numbers 1448
fixed size 1445
manually defining number and

size 1449
custom 1429
divisions 1442–1443, 1452, 1476
frame edges 1491–1492
frames, adding 1490
gables, excluding 1450
mullions 1468, 1470–1471, 1475
nested grids 1478
offset 1453
polylines 1452
steps, excluding 1450

curtain wall grips, editing curtain walls
using 1538

curtain wall properties 1507, 1642
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curtain wall styles
assigning

definitions to elements 1475
definitions to mullions 1493
divisions to grids 1476
infills to cells 1477

assignments, removing 1488
cell infills 1461, 1477
changing 1547
creating 1440
cut planes 1504
defined 1436
division definitions 1454
elements of 1439, 1475
frames 1461, 1463

offsets 1466
profiles 1464

grid cells 1442, 1445
infills

alignment 1458
offset 1459
overriding 1508

matching styles 1548
modifying element definitions 1535
mullions 1468

assignments 1493–1494
offsets 1473
profiles 1471
removing definitions 1475
removing from grid 1496
width and depth 1470

notes and reference files 1506
overrides 1507
overview 1437
panel infills 1456

curtain wall tools 1433
curtain wall unit cells

cell assignments 1621
filling with panels 1619
infills 1594, 1620

curtain wall unit components
custom graphics 1637
display 1634
hatching 1635
layer, color, and linetype 1635

curtain wall unit frames 1606
assigning definitions 1623

curtain wall unit grids 1576
cells 1614

fixed number 1590
fixed size 1587
manually defining number and

size 1591
custom 1580
divisions 1585
frame edges 1624–1625
frames 1624
mullions 1606–1609, 1612
offset 1592

curtain wall unit grips 1671
curtain wall unit styles

assigning
definitions to elements 1613
definitions to mullions 1627
infills to cells 1614

assignments 1622
cell infills 1599, 1614
changing 1675
creating 1583
cut planes 1638
defined 1582
division definitions 1594
elements of 1582, 1613
frames

defining 1599, 1601
defining by profile 1602
offsets 1604
profiles 1602

grid cells 1585, 1587
infills

alignment 1596
offset 1597
overriding 1642

matching styles 1676
mullions

assignments 1627–1628
defining 1606
defining by width and

depth 1607
offsets 1611
profiles 1608–1609
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removing definitions 1612
removing from grid 1629

notes and reference files 1640
overrides 1641
panel infills 1595

curtain wall units
alignment of anchored 1680
auto-adjusting cells 1589
base height 1674
cell markers 1642
components 1631
creating 1577
cut plane display 1680
dimensions 1677
display of 1633
division overrides 1664
door assemblies, inserting into 1755
editing 1670
frame and mullion overrides 1652–

1653
frame edges 1656
hyperlinks 1684
in-place editing 1659
infill overrides 1646
length 1674
location 1678–1679
matching properties 1676
merging cells 1643
mitered corners 1677
moving 1670
mullion edges 1656
nested grids 1615
notes and reference files 1684
offset 1680
overrides, removing 1670
window assemblies 1755

curtain walls
AEC polygon infills 1827
alignment of objects in cells 1573
anchored objects in cells 1574
base height 1541
cell and edge assignments 1507, 

1642
cell markers 1508
cells, merging 1509

creating 1419, 1421
from walls 1431

curved 1423, 1426
curves, referencing 1426
custom grids 1429
cut plane display 1553
dimensions 1548
direction, reversing 1546
display of 1499
display of custom

components 1554, 1682
divisions, overriding 1529
editing 1537
editing objects in cells 1573
floor lines 1559, 1566

editing 1560
height 1562
modifying 1557
shape 1562

frame edges 1521
frames and mullions,

overriding 1518–1519
gables, adding 1564
hyperlinks 1556
in-place editing 1524
infills

for inserting objects 1457
overrides 1515

interference conditions 1550–1551
length 1543
matching properties 1548
materials 1498, 1632
mitered corners 1551–1552
moving 1537, 1549
mullion edges 1521
multiple, with same style 1433
nested grids 1478, 1480
notes and reference files 1556
offset of objects in cells 1574
orientation of objects in cells 1573
overrides, removing 1535
profiles 2853
radius 1546
roof lines 1557, 1566

editing 1560
height 1562
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modifying 1557
shape 1562

straight 1426
swapping two objects 1574

curve anchors
adding 2677
anchoring to new 2682
changing position of objects 2678
defined 2677

curved surfaces, hatching 905
custom blocks, railing components 2370
custom ceiling grids

adding grid lines 2817, 2820
custom column grids

editing 2758
enhanced custom column

grids 2772
labeling 2768–2769
lines

adding 2771
moving 2772, 2795
removing 2771

placing doors 1179, 1182
placing windows 1179, 1182

custom commands, AEC content 3927
custom components

curtain walls 1554, 1682
door/window assemblies 1821

custom layout grids
creating

from linework 2727
linework, creating from 2727

custom shapes for structural
members 2666

Cut Plane Elevation Display Properties
Stairs 2255

cut planes 548
anchoring objects 561
and levels 550
curtain wall units 1680
curtain walls 1553
display range 549
door and window assemblies 1818
global 548
in space style 3106
manual 562

mass elements 1055
mass groups 1079
object-specific 549, 559
overriding for walls 559
slabs and roof slabs 2450
spaces 3002
stairs 2267
structural members 2610, 2639
wall styles 1319
walls 1241

cut planes, object-specific overrides 561
cylinder mass elements 1013

D

data format styles
publishing to DWF 279, 299

database fields 3514
ASCII data link 3519
comma-separated data link 3519
creating data link 3519
inserting 3516
Microsoft Access link 3519
Microsoft Excel link 3519
ODBC drivers 3519
supported data sources 3519
supported data types 3515
supported database providers 3515
udl files 3517, 3520

datum points
creating 3653
editing 3669
inserting 3655

default display sets
specifying 836

default project options 318
default standards folder 620
defining lines, sections 3308
defining mullions 1737
definitions

mask block 870
multi-view block 870
profile 870
property set 870

demolished objects 581, 585, 589
demolition plans 579
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design rules
2D elevation styles

adding 3379
changing 3381
removing 3382

2D section styles 3314, 3316
changing default options 592
door styles 1903
Renovation mode 586
window styles 2010

DesignCenter
AEC content 3909
AEC drawings 3920
content file locations 201
fixture layout 3911, 3914

modifying 3930
moving content to Content

Browser 3915
multi-view block definitions,

adding 2900
detail component database

adding 3583
configuring 3583
jigs 3979
merging 3586
recipe specification 3946, 3954
removing 3585

detail component database (project) 343
Detail Component Manager

component group tables 3562
locating a component in 3550
using 3549

detail component table
adding rows 3562
editing values 3564
removing rows 3563, 3565–3566

detail component tools
adding to tool palette 3542
applying to linework 3548–3549
copying from Content Browser 3544
creating from linework 3545
modifying 3545
using 3542

detail components
bolts 3538
bookends-type 3533

boundary filling 3532
countable linear repeating

pattern 3534
dynamically-sized rectangular 3537
editing 3539
inserting 3528
jigs 3979
linear array 3531
migrating 4001
multiple insertion 3529
recipe specification 3946
rectangular predefined-depth

surface 3536
detail pane 368
detail tools 3690

properties 3694
detail views

creating from a callout 462
details

creating with callouts 3703
in current drawing 3703
in existing project

drawing 3706
in new drawing 3708

for a project 337
diagnostic messages 197
dialog boxes, placement of 197
diamond pattern in window

muntins 2032
dimension column grids 2759
dimension scale overrides 3931
dimensional constraints 1148
dimensions

AEC (See AEC dimensions) 3387
corner windows 1960
curtain wall units 1671, 1677
curtain walls 1538, 1548
door assemblies 1694, 1813
elevations 3333–3336
enhanced custom column grid

bays 2800
enhanced custom column

grids 2796
project 547
sections 3262–3264, 3266
stair (See stair dimensions) 2154
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window (See window
dimensions) 1975

window assemblies 1813
DIN

area calculation standard 3010
direct editing

dynamic dimensions 115
grips 115

display components
changing visibility 793

display configurations 810, 824
copying between drawings 846–847
creating 824, 826
default 814, 837
deleting 844
emailing 847, 849
managing 843
notes 845
predefined, in templates 801
purging 849
reference files 845
renaming 843
templates 801
tips for working with 825
viewing 816
viewports 835, 837
xrefs 837, 839

display management
(See Also display system) 801
layers 720

Display Manager 814, 843
(See also display system, display

representations, display sets,
display configurations) 810

left pane 814
opening 816
right pane 815
standard settings 851

adding 860
excluding from

synchronization 854
purging version history 863
purging version

information 863
synchronizing 853
synchronizing standards 864

updating 855
updating from drawings 858

view direction icons 815
display overrides 670
display representations 803

assigning to display sets 831
comparing between display

sets 833–834
copying between drawings 846–847
creating 828
customizing display of objects 806
default 193, 805, 824
deleting 845
editing 829
materials 903
purging 850
renaming 843
structural members 2633
tips for working with 825
viewing 820
viewing objects that use 822–823

display sets 808
classifications 840
comparing display

representations 833–834
copying between drawings 846–847
creating 827
default 810
deleting 844
display representations 808

assigning 831
viewing 823

notes 845
purging 850
reference files 845
renaming 843
specifying a default display set 836
tips for working with 825
view direction 809
viewing 818

display settings
adding standard settings 860
excluding from

synchronization 854
external references 802
live sections 841
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materials 841
standard 851
synchronizing standards 864
synchronizing with project

standards 853
updating standards 855, 858
version history

editing 862
purging 863

version information, purging 863
display style, Renovation mode 586
display system 801

(See also display representations,
display sets, display
configurations, Display
Manager) 801

elements of 801
materials definition 802
troubleshooting 865

display theme legend 3890
display theme tool

creating 3888
display themes

activating 3892
adding to a drawing 3890
creating 3885–3886
disabling 3892
editing 3886
legend 3888
legend, inserting 3890
styles 3888, 3893
tools 3888
tools, creating 3888

display themes style
creating 3894

displaying edit attribute justification
grips 3593

Divide command 2842
dividing

spaces 3040
divisions

curtain wall units 1585
curtain walls 1442–1443
door assemblies 1711
interaction with projects 389

project 387
changing 388
creating 387, 389
deleting 389–390
ID 390
name 389
overview 311

window assemblies 1711
documentation

spaces 2917
dome mass elements 1014
door and window assemblies

cut plane display 1818
endcaps 1690
profiles 2853

door assemblies
alignment of objects in cells 1825
anchored objects in cells 1826
auto-adjusting cells 1715
cell markers 1780
cells, merging 1780
centering in walls from xref

drawings 1350
creating 1691, 1694
curtain walls, inserting into 1485
custom grids 1699
dimensions 1813
display of 1770
divisions, overriding 1802
door assembly tools, creation

with 1693
editing 1809
editing objects in cells 1824
frame edges 1793
frames and mullions,

overriding 1789–1790
freestanding 1814
hyperlinks 1823
in-place editing 1796
infills

for inserting objects 1725
overrides 1783

interference conditions 1815–1816
matching properties 1813
materials 1769
mitered corners 1817
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moving 1809, 1812
mullion edges 1793
multiple, with same style 1700
nested grids 1748, 1750
notes and reference files 1823
offset of objects in cells 1825
orientation of objects in cells 1824
overrides, removing 1807
positioning 1695
swapping two objects 1826

door assembly cells
cell assignments 1757
filling with panels 1752
infills

defining 1722
removing 1756

objects, inserting 1755
door assembly components

custom graphics 1774
display 1771
hatching 1773
layer, color, and linetype 1772

door assembly dimensions 1694
door assembly frames 1737

assigning definitions 1759
door assembly grids

cells 1746
fixed number 1717
fixed size 1712
manually defining number and

size 1718
custom 1699
divisions 1711, 1746
elements 1688
frame edges 1761, 1763
frames, adding 1760
mullions 1737, 1739–1742, 1744
nested grids 1748
offsets 1719

door assembly grips 1810
door assembly styles 1737

assigning
definitions to elements 1745
definitions to mullions 1763
divisions to grids 1746
infills to cells 1746

assignments 1759
cell infills 1746
changing 1812
creating 1708
cut planes 1776
defined 1703
division definitions 1721
element definitions 1808
elements of 1707, 1745
frame offsets 1735
frames 1730

profiles 1732–1733
grid cells 1712
infills

alignment 1727
definitions 1729
offset 1727
overriding 1780

matching styles 1813
mullions

assignments 1764–1765
offsets 1742
profiles 1740–1741
removing from grid 1766
width and depth 1739

notes and files 1778
overrides 1779
overview 1705
panel infills 1724
shape 1814

door assembly tools, creating 1700
door components

custom blocks for 1916
display of, turning off 1919
door styles, removing from 1920
layer, color, and linetype 1914

door dimensions
changing for door styles 1902

door frames, assigning materials 1912
door muntins

display of, turning off 1953
editing 1952
glass 1928
materials 1912
prairie-lights 1934
rectangular or diamond 1929
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removing 1954
starburst 1939
sunburst 1946
void for 1927

door panels, assigning materials 1912
door sizes

properties 3828
door stops, assigning materials 1912
door styles

classifications 1913
components 1917, 1920
creating 1900
custom shapes 1905
defined 1899
dimensions 1902
display of components, turning

off 1919
display properties 1914
door swings 1920
files, attaching 1923
geometry 1907
materials 1915
muntins, removing 1954
notes, attaching 1923
opening percentage 1921
shapes, replacing 1906
specifying design rules for 1903
standard sizes 1904

door swings
direction properties 3829
displaying as straight line 1920

door thresholds
display properties 1921
symbols 1922

door tools
creating 1874

door/window assemblies
display of custom components 1821

doors
array doors between two

points 1894
array doors using Modify Tool 1894
center door between two

points 1894
center door using Modify Tool 1894

centering in walls from xref
drawings 1350

creating 1873
from assemblies 1875
from openings 1875
from windows 1875
in door and window

assemblies 1875
in walls 1873

curtain walls, inserting into 1485
custom block components 1895
custom shapes 1905
display components and

materials 1910
display properties, specifying 1914
door and window assemblies,

inserting into 1755
door assemblies, inserting into 1755
endcaps 1872
evenly space doors along a

wall 1895
evenly space doors using Modify

Tool 1895
freestanding 1893
geometry 1907
horizontal position 1887
in space surfaces

adding 3068, 3074
removing 3086

materials
assigning 1912
predefined 1873

moving
along walls 1885
to a different wall 1892
within walls 1886

multiple, with same style 1874
muntins block components 1895
notes and reference files 1899
opening percents, specifying 1921
overview 1871
placing across length of wall 1182
placing relative to column

grids 1182
positioning

along walls 1885
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horizontally 1890
within walls 1886

profiles 2853
properties of 1876
releasing from walls 1892
reposition door using Modify

Tool 1894
repositioning doors between two

points 1894
reversing handing 1895
schedule tags, adding 3756
shapes 1906
specifying the swing display 1895
standard sizes 1904
threshold dimensions 1895, 2614
type and shape 1903
vertical alignment

changing 1881
overview 1872

vertical orientation 1892
vertical position 1889

dormers in roof slabs 2388, 2485
drape mass elements 1016
drawing

fields 3489
drawing compare

command line 711
creating a visual filter 710
frequently asked questions 711
overview 695
review tab 704
setup tab 698
starting a session 698

Drawing Explorer 367
drawing management

command line 562
concepts 305
frequently asked questions 564
overview 305

drawing templates, for projects 334
drawing window status bar 44

modifying 47
turning on and off 47

drawings
AEC, creating 3920
closing in Style Manager 882–883

creating
from scratch 181
from templates 180
in Style Manager 882

default display representations 193
displaying objects with facets 202
dragging in Style Manager 883
elevations 3321
exporting

to AutoCAD 206, 208
to DXF files 206, 211

layer key styles 190
layer management 720
layer standards 190
legacy, opening 182
opening in Style Manager 881–882
project-related information,

removing 358
proxy graphics 206–207
publishing to PDF 294
read-only status indicator 872
saving as AutoCAD objects 183
saving as Proxy Graphics 183
saving to previous file format 183
scale 187, 3931
setting up 183
sharing with other users 205

methods 207
standards, adding 642
status of 881
units, specifying 184

DWF
data format styles 279, 299
publishing property set data 276

DXF files, exporting drawings to 206, 
211

dynamic cleanup radius variable 1335
dynamic dimensions 115, 120
dynamically-sized rectangular

components 3537

E

edges
hiding 1357
showing 1359, 1388
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wall endcaps 1389
edit in place

3D body modifiers 1144
changing display components 1146
context menu 1141
material hatches 1145
object components 1140
polyline-based components 1142
profile-based components 1143
profiles 2860
ribbon 1141
wall intersections 1354

editing
column grid labels 2769
enhanced column grids 2793
fields 3501
renovation plan objects 589
wall intersections in place 1354

editing multiline attributes 3593
editing multiline attributes in multi-view

blocks 3593
electronically transmitting a project 352
elements 426

constructs
compared to 427
converting to 443

creating 429
deleting 439, 445
dragging objects into 436
electronically transmitting 438
external references, displaying 442
interactions with projects 445
legacy drawings, converting 427, 

431–433
name 445
opening and closing 435
overview 426
projects, adding to 445
properties 437
referencing in multiple

constructs 428
referencing into other elements 440
templates 427
uses for 429
when to use 428
XML files 427

elevation labels 3471
attributes 3479, 3482
blocks 3479, 3483
coordinate systems 3477
creating 3473
defined 3471
DesignCenter 3484
elevation values 3477
graphic symbols 3481
hyperlinks 3480
modifying 3476
multi-view blocks 3477, 3483
notes 3480
offset 3478
reference files 3480
scale factor 3478
tools

creating 3475
creating with 3472

user-defined 3481
user-specified settings 3473

elevation lines 3321, 3328
changing 3330
drawing with elevation marks 3331
hyperlinks, notes, and reference

files 3341
location 3339
subdivisions 3331

changing display 3348
components 3377
creating 3337

viewing 3328
elevation marks 3321

attributes 3339–3340
drawing 3331

elevation tools 3690
properties 3694

elevations 3321
(See also 2D elevations, 3D elevations,

elevation lines, elevation
marks) 3321

adding and removing custom
components 3351

creating with callouts 3717
four-way exterior

elevations 3722
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four-way interior
elevations 3719

single elevations 3717
dimensions, changing 3333–3336
horizontal 3344
live section views 3323
specifying surface hatching for

subdivisions 3353
specifying the display of 2D

linework 3355
subdivisions 3323

changing display 3348
components 3377
creating 3337

endcaps
door and window assemblies 1690
doors 1872
opening 2077
openings 2060
window opening 1993
windows 1957

engineering data, adding to spaces 3191
enhanced custom column grids

adding labels after insertion 2797
creating

Column Grid dialog box 2772
editing preconfigured list 2780
from existing grids 2779
irregular 2781
radial 2777
rectangular 2774
varying grid lines 2783

defining numbering and
lettering 2789

defining numbering display 2787
defining numbering scheme for

secondary grid lines 2790
dimensioning 2796
dimensioning bays 2800
editing 2793
editing labels 2798
grid bubbles 2789
labeling grids 2773
labeling sides 2773
lines

adding 2793

moving 2795
removing 2795

primary and secondary
numbering 2773

properties 2774
selective numbering 2773
variable lines 2772

entity references
hyperlinks 3943
location 3943
notes 3943
reference files 3943

EquipmentLoad property 3191
erased component, sections 3312
existing objects, Renovation plans 581, 

585, 589
exploded objects, identifying 3939
export file formats

IFC format 214
exporting

display configurations 846
display representations 846
display sets 846
drawings

as IFC file format 214
Extend command 2841
extending

wall endcaps 1391
wall intersections 1372

extension lines, AEC dimension
styles 3451, 3463

external references (xrefs)
constructs, attaching to 414
dimensioning 567
display configurations 837, 839
display settings 528
isolating objects in 1135
overview 310
paths, in projects 315
troubleshooting 1349–1350
within a project 314

extruded 3D spaces 2953, 2983
extrusion mass elements 1018
extrusions, hatching 907
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F

F1 help 54
faces

aligning UCS 124
faces, hatching multiple 906
facet deviation 1685
FACETDEV variable 1410, 2598
fascia 2506

in slab edges 2408
fields 3487

adding to a property set
definition 3847

annotation 3487
background color 3504
converting to text 3505, 3813
creating database links 3519
editing 3501, 3813
FIELDDISPLAY variable 3504
in callout symbols 3732
in manual properties 3812
in property set data 3824
in styles and definitions 3815
inserting 3489

attributes 3499
AutoCAD table cells 3501
multiline text 3498
object properties 3494
object styles 3496
property set definitions 3491
text elements 3497

ODBC drivers 3519
overview 3487
supported database providers 3519
types 3505

database fields 3514
keynote fields 3512
project fields 3505
sheet set fields 3507

updating 3504, 3813
fields, layer standards 776

AIA Long Format 778
BS1192 780, 782

files, LY 760
files, reference (See reference files) 1246

fill type
for an opening, changing the

display 2092
fillet

wall cleanup 1361
filleting

wall endcaps 1385
walls 1217

filters, layer (See layer filters) 738
fire rating lines

creating 3655
editing 3672
inserting 3657

Fix constraints 1155
floor lines

curtain walls 1559
changing 1557, 1566
changing vertices 1567

editing 1224, 1229
offsetting 1226
projecting 1226
reversing 1233
steps, adding 1228
vertices 1234
walls 1224, 1226, 1228, 1234

floor settings
changing, for stairs 2202
multi-landing stairs 2119
spiral stairs 2136
u-shaped stairs 2130

floorplates (See slices) 1101
floors

in space surfaces 3061
formulas

evaluating results 3834
Formula Property Definition

worksheet 3835
in schedule tables 3830
property set definition 3830
use case 3835
VBScript code 3835

four-way exterior elevations 3722
four-way interior elevations 3719
frames

door, assigning materials to 1912

4030 | Index



of a window, changing the
display 1895, 1998

window, assigning materials to 2016
frames, curtain wall units

offsets 1604
profiles 1602
removing 1606
width and depth 1601

frames, curtain walls
offsets 1466
profiles 1464
removing 1467
width and depth 1463

frames, door assemblies
profiles 1733
removing 1737

frames, window assemblies
corner windows 1961
offsets 1735
profiles 1733
removing 1737
width and depth 1731

free form mass element
editing faces 1042

freestanding columns 2571–2572
freestanding door assemblies 1814
freestanding doors

creating 1873
location 1893

freestanding window assemblies 1814
freestanding windows

creating 1965
location 1993

freezing walls 592
friction measurements 195
full xref paths in projects 315

G

gable mass elements 1015, 1030–1031
gable roof lines

curtain walls, adding to 1564
in walls 1227
settings 1569

gable roofs
creating 2389

creating with roof tools 2386
GBXMLEXPORT command 3196
geometric constraints 1148
geometry

door, editing 1907
spaces 3089
window, editing 2011

glass, door muntins 1928
glass, window 1961
global cut planes 548, 550

clipped model view 556
display range 551–553
displaying different levels 554

globally updating 2D sections and
elevations 3297, 3366

in a folder 3297, 3366
in a project 3297, 3366
updating 3299, 3368

gothic pattern in window muntins 2049
graphics path

multi-landing stairs, changing 2166
u-shaped stairs, changing 2172

graphics, preview 3920
grid bays 2781, 2800
grid bubbles 2789
grid lines

centering items between 1184
defining numbering scheme for

secondary grid lines 2790
door and window placement 1183–

1184
numbering 2773
per side numbering 2773
variable 2772, 2783

grids
(See also ceiling grids, column grids,

curtain wall unit grids,
curtain wall grids, door
assembly grids, layout grids,
window assembly
grids) 2820

about 2749
anchoring objects to 2749
anchoring to objects 2673
basing enhanced column grids

on 2779
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ceiling grid tools, creation
with 2807

column grids 1182, 2751
curtain wall units 1578
curtain walls 1427
dimensioning bays 2800
door assemblies 1696
fixed baysize 2751, 2761, 2814
labels 2789

numbering 2787
moving ceiling grids 2820
preconfigured bay sizes 2780
types of 2749
window assemblies 1696

grids, door assembly 1737
grids, window assembly 1737
grips 115

AEC dimensions
dimension text, moving 3440
extension lines, moving 3440

AEC polygon 1836
column grid lines 2772, 2795
corner windows 1959, 1985
CTRL grips 119
curtain wall 1538
curtain wall unit 1671
direct editing 115
door assembly 1810
dynamic dimensions 120
grip color 118
grip constraints 123
grip tips 117
mass group

attaching mass element 1070
detaching mass element 1071

opening 2074
railing 2318
roof 2395
roof slab 2427
slab 2427
stair 2154
structural members 2586
temporary coordinate systems 123
trigger grips 119
wall 1191
window 1975

window assembly 1810
gross boundaries

activating 3015
displaying 3015
editing 3014
spaces 3004

GUID
version 675

H

hatch
generating boundary 2833
repositioning 2833

hatch boundary
creating 2833
redefining 2834

hatch productivity tools 2832
hatches

(See also surface hatches) 904
AEC polygon styles 1864
curved surfaces 905
extrusions 907
free form mass elements 909
mass element styles 1062
mass elements 1053
material components 899–900
multiple faces 906
space styles 3104
wall styles 1319

head height
openings 2064
window 1969

height
3D freeform spaces 3031
extruded 3D spaces 3029
walls 1191

help
context help 54
F1 help 54

hidden component, sections 3311
hidden line projection

creating 3385
overview 3385

hiding
wall endcap edges 1389
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wall intersection edges 1357
holes

spaces 3055
Horizontal constraints 1154
horizontal elevations 3344
horizontal orientation

spiral stairs 2132
u-shaped stairs 2125

horizontal sections 3273
HVAC components

measurement units 195

I

i-drop icon for tool catalogs 134
IFC

importing and exporting files 213
import file formats

IFC files 248
importing

display configurations 846
display representations 846
display sets 846
IFC files 248
Inventor components 255

in-place editing
curtain wall units 1659
curtain walls 1524
door assemblies 1796
window assemblies 1796

Industry Foundation Classes
importing and exporting files 213

InfoCenter 52
insertion point

of openings 2064
of windows 1969

installing tool catalogs in libraries 145
integration with AutoCAD 127
intelligent wall cleanup

about 1324
cleanup circles 1333
conditions 1336
justification lines 1333
L-intersections 1325
multiple intersections 1330
T-intersections 1328

interference conditions
adding to walls 1294
removing from walls 1295
spaces

adding 3035
removing 3036

stairs 2235
in curtain walls 2243, 2246
in door assemblies 2246–2247
in slabs 2239
in slabs, removing from 2242
in spaces 2242–2243
in walls 2235, 2238
in window assemblies 2246–

2247
intersections

spaces 3042, 3056
walls 1324

Inventor
importing into AutoCAD

Architecture 255
isolating objects

ending object isolation 1134
external references 1135
hiding selection 1133
saving selection 1134
selecting objects 1135

isosceles triangle mass elements 1012

J

joining walls 1215
justification lines in walls 1333

K

keynote database (project) 342–343
keynote databases

adding 3635
configuring 3634
creating 3639
groups

adding 3642
deleting 3646
editing 3644
moving 3647
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keynotes
adding 3643
deleting 3646
editing 3645
moving 3647

modifying 3639
overview 3634
permissions 3638
removing 3636
schema 3649

Keynote Editor 3639
keynote database 3640

keynote fields 3512
inserting 3513

keynote insertion tools
using 3613

keynote legend styles
editing 3625

keynote legends
adding keynotes 3624
editing 3622
generating 3620
removing keynotes 3625
reselecting keynotes for 3622
updating 3623
using 3617

keynotes
changing databases 3630
changing formats 3628

globally 3629
individually 3628

configuring database 3634
databases 3634
editing 3626–3627
inserting 3615
insertion tools 3613
legends

adding keynotes 3624
editing 3622
generating 3620
removing keynotes 3625
updating 3623
using 3617

migrating 4001
repeat insertion 3617
sort order 3647

specifying 3631
specifying for detail

components 3633
specifying for object

components 3632
specifying for object styles 3631
viewing 3626

keynoting tools
overview 3608

keys, layer (See layer keys) 719

L

L-intersections 1325
l-shaped stairs

creating 2120
labels

adding later 2797
custom column grids 2768
editing 2769
numbering 2773, 2787

landing shapes 2171
LandXML, importing 258

clipping surface model 266
COGO points 260
contours 266
drawing units 264
layer keys 267
options 264
parcels 260
parcels as polylines 265
parcels as spaces 265
schema version 259
selecting model base thickness 266
surfaces 260
validating 263

layer assignment
modify 594
modifying 594
Renovation style 586

layer filters
layer colors 739
layer names 740
linetype 740
lineweight 740
specifying 738
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layer groups
filter groups 735
filters 735

converting property to
group 744

creating 735
property 736
standard 741

layers, adding 742
overview 733
properties, changing 743
renaming and deleting 744
rules for 734
types of 734

layer key styles 759
AIA 759
BS1192 759
creating 766
creating from LY files 767
defined 719
editing 768
in Style Manager 870
notes and reference files 770
overrides to 760
properties of 760
specifying 190

layer keying
defined 719
values for new layer keys 766

layer keys
default 761, 774
default values 766
defined 719, 759
overrides 771

specifying 772
turning on and off 773

remapping 773
selecting for LandXML 267

Layer Manager
layer filters 735
layer groups

properties 743
layer standards 775
layer states 750
layers

creating 722–723

creating nonstandard 723
deleting 724
making current 721
renaming 724

opening 720
overview 715

layer settings
in model space views 468
in sheet views 475
in views 475

layer snapshots (See layer states) 749
layer standards

AIA Long Format 774, 778
assigning layers to 725
BS1192 774, 779, 781
component fields 775
creating 783
creating layers conforming to 722
defined 718
editing 784–787
exporting 789
fields 776
importing 788
included with Layer Manager 775
match description 776
purging 787
specifying 190

layer states
creating 750
deleting 757
editing 753
exporting 759
importing 757
overview 749
restoring 755
saving 750

layers
(See also Layer Manager) 721
adding with same name 723
AEC Editor 197
current 721
deleting 724
display management 720
layer 0 (zero) on and thawed to use

AEC object OSNAPs 728
layer standards 722, 725
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nonstandard 723
renaming 724
snap to points on AEC objects 728
wall components 1239

layout curves 2703
adding 2706
adding nodes 2709
anchoring objects 2704
anchoring to objects 2673
changing node positions 2713
changing node radius 2717
changing node spacing 2712
changing offsets 2711
changing spacing mode 2714
display properties 2716
notes and files 2718
switching 2715
tools 2705

layout grids 2703, 2719
adding and removing

boundaries 2733
adding grid lines 2728
adding notes and files 2735
changing node radius 2732
changing spacing mode 2730
converting to column grids 2755
creating 2725
creating holes 2734
curtain wall units 1578
curtain walls 1427, 1478
defined 2749
display properties 2731
door assemblies 1696, 1748
location 2734
radial

adding 2720
changing 2722

rectangular
adding 2723
changing 2724

removing grid lines 2729
tools 2719
window assemblies 1696, 1748

layout modes (grids)
fixed baysize 2751, 2761, 2814

layout volumes 2736
adding 2738
adding grid lines 2740
changing 2740
changing node radius 2744
changing spacing mode 2742
creating 2736
location 2745
notes and files 2746
removing grid lines 2741

leader anchors
adding 2683
changing position of objects anchored

to 2684
copying objects to all layout

nodes 2686
defined 2683
extending leaders 2686
grip editing 2685

legacy drawings, opening 182
length

limits for stairs 2203, 2205
wall 1191

levels 379
copying 380, 382
creating 380, 386
defaults 379
deleting 385–386
floor-to-floor height 386
IDs 386
interaction with projects 386
name 386
overview 311
properties 384

LightingLoad property 3191
linear repeating pattern

components 3531
lines

ceiling grids 2814
column grids 2761–2762, 2771, 

2793, 2795, 2814
linetype scale

display properties of AEC objects and
LTSCALE 867

troubleshooting 867
linetype settings, AEC Editor 197

4036 | Index



linetypes
wall components 1239

linework
2D elevations 3361

edit 3361
grip-edit 3346
merge 3361

2D sections 3291
editing 3291
grip-edit 3280
merging 3291
using 3D body

component 3313
erased component (2D

elevations) 3377
hidden component (2D

elevations) 3377
section hatch 3311
section surface hatch 3310
structural members, creating 2584
surface hatch (2D elevations) 3376

linework material components 899
link

drawing file to construct 433
linking objects (See object anchors) 2673
list definitions 3868

creating 3111, 3869
defined 3109
editing 3112, 3871
files 3112
for spaces 3111
for zones 3111
list items 3869
name lists 3112
notes 3112
notes and reference files 3872
setting in space style 3097
setting in zone style 3140
type 3111

live section views 3254
creating 3257, 3275–3276
display settings 841
editing 3275
in elevations 3323
materials 902
removing 3279

section lines, creating from 3258
sectioned body, displaying 3277
updating 3277

load calculations, specifying data
for 3191

location
spaces 2997

LY files, creating layer key styles
from 760

M

manual properties
fields in 3815
styles and definitions 3815

manual synchronization 615
mapped drives

for projects 316
for remote locations 321
opening projects on 321

mask block definitions
creating 2868

from existing definitions 2869
from polylines 2868

editing 2872
exporting 2871
importing 2870
purging 2875
Style Manager 870, 2868

mask blocks 2867
adding 2876
AEC content 3924
attaching to object 2881
definitions (See mask block

definitions) 2867
detaching from objects 2882
display properties 2887–2888
editing 2882
grips, editing with 2883
hyperlinks, notes, and reference

files 2888
location 2883
profiles, editing 2884
tool properties 2887
tools

adding using 2875
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creating 2878
user-specified settings 2877

mass element styles 1057
creating 1058
display properties 1061
hatching 1062
materials 1059
materials and display

components 1059
materials, assigning 1060
notes 1064
reference files 1064

mass elements 1003
additive 1072, 1097
arch 1009, 1029
barrel vault 1010
Boolean operations 1036
box 1010
circular 1032
cone 1013
converting from

objects 1040
converting to

3D solid 1039
roof slabs 1039
slabs 1039
spaces 1040
walls 1039

creating 1007
creating with massing tools 1005
cut plane display 1055
cylinder 1013
display components 1083
display properties 1052
dividing 1037
dividing face of 1041
dome 1014
drape

Delaunay triangulation 1016
rectangular 1016
regular 1016

editing 1024
editing with grips 1024
faces

dividing 1041
joining 1041

free form element 1038
freeform

faces, editing 1042
gable 1015

rise 1031
roof height 1030

grips 1024
hatching 1053
hatching free form 909
height 1029
hyperlinks 1056
intersections 1074, 1099
isosceles triangle 1012
joining faces of 1041
location 1054
mass groups 1033, 1096

adding to 1070
attaching objects to 1097
detaching from 1071

materials 1004, 1051, 1082, 1085
Model Explorer 1095
moving 1101
notes 1056
order within mass group 1100
profiles 2853

extruding 1018–1019
revolving 1018, 1020–1021

profiles, editing 1034
pyramid 1011
rectangular

area 1026
edge 1027

reference files 1056
restoring body modifiers 1292
right triangle 1012
shapes 1007, 1033
size 1007, 1033
sphere 1015
subtractive 1073, 1098
tools, creating 1021
trimming 1037
user-specified settings 1008

mass groups 1003
anchors 1077
Boolean operations 1067
changing 1034
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creating 1066
cut plane display 1079
display components 1083
hyperlinks 1080
location, changing using grips 1075
markers 1069
mass elements 1096

adding 1070
attaching 1070, 1097
detaching 1071

mass group markers 1066
materials 1067, 1082, 1085
materials, assignng 1068
Model Explorer 1096
moving 1101
nested, creating 1074
nested, removing 1075
notes 1080
reference files 1080
tools 1081

creating with 1065
working with 1077

mass models 1003
Model Explorer 1087

massing studies 1004
(See also mass groups) 1004

massing tools
mass elements 1005
mass groups 1065

match lines
creating 3658
editing 3669, 3672
inserting 3660

material boundaries 3256
adding ring 3359
adding vertex 3358
content 3357
creating 3285
editing 3286, 3357
highlights 3285
masks 3285
removing ring 3360
removing vertex 3358
replacing ring 3360
rings

adding 3289

removing 3290
replacing 3290

vertices
adding 3288
removing 3288

material components 898
2D section and elevation

linework 901
3D body 900
linework 899
patterns 921
plan hatch 899
section hatch 902
sectioned body and sectioned

boundary 902
surface hatch 900

material definitions
creating 919
notes and reference files 932

materials
(See also material boundaries) 3254
2D section shrinkwrap 928
2D section styles 3313
creating 917
curtain wall styles 1498, 1632
display settings 802, 841
door assembly styles 1769
door components 1912
door styles 1915
doors 1910
in display representations 903
listing 916
mass elements 1004, 1082, 1085
mass groups 1067, 1082, 1085
naming 918
objects 888, 917
objects that support 887
overview 885
properties, defining 920
queries 917
railings 2306
rendering 925
Renovation style 587
roof slab components 2498, 2520
roof slab edge style 2521
roof slab styles 2496, 2501
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roofs 2399
section components 3306
sections 3254
slab components 2498, 2520
slab edge style 2521
slab styles 2496, 2501
space styles 3098, 3100
structural member styles 2630–2631
structural members 2529
styles 919
wall components 1313
window assembly styles 1769
window components 2016
window styles 2018
windows 2014

maximum gap size
for space generation 2962

MDB
exporting property set data 276
file structure 271

menu browser
displaying recent documents 39–40

Merge command 2846
merging

profiles with wall endcaps 1395
profiles with wall intersections 1368
spaces 3036, 3054

messages, diagnostic 197
migrating

detail components 4004
keynote database 4004

mitered corners
curtain wall units 1677
curtain walls 1552
door assemblies 1817
window assemblies 1817

mode
renovation 581

mode, Renovation 581
Model Explorer 1004

display configurations 1090
left pane 1087
mass commands 1094
mass elements 1095

attaching 1096
mass groups 1096

mass models 1087
menu bar and toolbar 1088
navigating 1091
opening 1089
position of object 1094
projection 1090
right pane 1088
SteeringWheel 1092
toolbar commands 1094
view directions 1090
ViewCube 1091
viewing objects 1093
visual styles 1090
zoom percentage 1094

model space views
creating 468
deleting 474
editing profiles in place 1355, 1376
layer settings 468
layer snapshots 468
outside project

deleting 3731
opening 3730

placing on sheet 471
properties 473

Modify Tools
array AEC Polygons 1847
array doors 1894
array openings 2087
array railings 2325
array windows 1991
center AEC Polygon 1845
center door 1894
center opening 2087
center railing 2325
center window 1991
crop AEC Polygons 1850
divide AEC Polygons 1849
evenly space AEC Polygons 1848
evenly space doors 1895
evenly space openings 2088
evenly space railings 2326
evenly space windows 1992
merge AEC Polygons 1846
reposition AEC Polygon 1848
reposition door 1894
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reposition opening 2088
reposition railing 2326
reposition window 1992
trim AEC Polygons 1849

mullions, curtain wall units
definitions, removing 1612
profiles 1608–1609
width and depth 1607

mullions, curtain walls
definitions, removing 1475
profiles 1471
width and depth 1470

mullions, door assemblies
offsets 1742
profiles 1740–1741
width and depth 1739

mullions, window assemblies
definitions, removing 1744
offsets 1742
profiles 1740–1741
width and depth 1739

multi-landing stairs
creating 2113
floor settings 2119
terminating with 2116
turn types 2115
vertical orientation 2115

multi-view block definitions
classifications 2874, 2899
creating 2892–2893
DesignCenter, adding to 2900
in Style Manager 870
notes 2898
reference files 2898
view blocks

connecting 2896
creating 2893
creating from 2895

multi-view block references, object
tags 3756

multi-view block tool
creating 2902

multi-view blocks 2891, 3593
(See also multi-view block

definitions) 2891
adding to drawings 2905

AEC content 3922
attributes

editing 2912
updating 2913

definitions, changing
associated 2907

elevation marks 3340
hyperlinks 2911
location 2909
modifying 2907
notes 2911
offset 2908
predefined 2892
reference files 2911
rotation 2907
scale factor 2908
section marks 3268, 3270
types of objects represented 2891

multiline text
fields 3498

muntins, door (See door muntins) 1924
muntins, window (See window

muntins) 2028
MWX file 269

N

naming Renovation blocks and
styles 596

napkin sketch
appearance of objects 1123
changing 1127
creating 1125
line formats 1124
lock settings 1127
napkin sketch tools, creation

with 1125
nested objects 1127
overview 1123

net boundaries
activating 3015
displaying 3015
editing 3014
spaces 3004

new objects, Renovation plans 585, 589
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nnotation scaling
north arrows 3653

node anchors
adding 2687
anchoring to different nodes 2689
changing position of objects anchored

to 2688
copying objects to all layout

nodes 2690
defined 2687

node radius
ceiling grids 2826
column grids 2805
layout curves 2717
layout volumes 2744

node raidius
layout grids 2732

non-AEC objects, identifying 3939
non-associative AEC dimensions 3391
non-associative spaces

2D 2983
converted 3D freeform 2983
extruded 3D 2983

north arrows
creating 3653
editing 3669
inserting 3655

numbering
display options 2787
grid bubbles 2789
primary and secondary grid

numbering 2773
secondary grid lines 2790
selective grid numbering 2773

O

object anchors 2673
(See also cell anchors, curve anchors,

leader anchors, node
anchors, volume
anchors) 2674

adding 2675
defined 2674
positioning 2699
released 2676

releasing 2699
types, user-defined 2674

object properties
fields 3494

object styles
fields 3496

object tags, adding 3756
Object Viewer 1111

display configurations 1115
embedded 1113
Model Explorer 1113
navigating 1117
objects 1111
projection 1115
saving preview image 1121
set view direction in drawing 1120
SteeringWheel 1119
styles 1112
view directions 1115
ViewCube 1118
visual styles 1115

objects
adding 62
adding to structural members 2616
adding to walls 1285
alignment

in curtain walls 1573
in door assemblies 1825
in window assemblies 1825

categorizing 590
constraints 1148
converting to

mass elements 1040
converting to 3D solids 3937
default display properties 824
demolished 581
detaching mask blocks 2882
dimensioning 3389
display system 801
displaying in viewports 812
editing

in curtain walls 1573
in door assemblies 1824
in window assemblies 1824

existence in drawings 866
facets, displaying 202
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interactions in Renovation
mode 588

isolating 1135
isolating in external references 1135
isolating to display 1133
isolating to edit in elevation

view 1137
isolating to edit in plan view 1137
isolating to edit in section

view 1136
isolating to hide 1133
isolating, saving 1134
layer, color, and linetype

settings 197
mask blocks, attaching 2881
modifying 62
offset

in curtain walls 1574
in door assemblies 1825
in window assemblies 1825

orientation
in curtain walls 1573
in door assemblies 1824
in window assemblies 1824

releasing
anchored objects in curtain

walls 1574
anchored objects in door

assemblies 1826
anchored objects in window

assemblies 1826
Renovation mode 581
selecting by category 590
selecting similar 1131
stairs, adding to 2226
subtracting from stairs 2228
subtracting from structural

members 2617
subtracting from walls 1286

Obscure command 2845
Occupancy property 3191
ODBC drivers 3519
opening

sizes 2063
opening components

custom blocks for 2098

display of, turning off 2099
opening styles, removing from 2100

opening endcap styles
applying to wall style 1408
creating 1407
overriding on walls 1409

opening endcaps 2077
opening grips, editing openings

using 2074
opening height, AEC dimension

styles 3451, 3463
opening percents

door, specifying 1921
window, specifying 2023–2024

opening tools
copying 2072
creating 2072
finding in palettes 2060

openings
aligning by threshold or head

height 2073
array openings between two

points 2087
array openings using Modify

Tool 2087
center opening between two

points 2087
center opening using Modify

Tool 2087
centering in walls from xref

drawings 1350
components 2098, 2100

custom blocks 2098
creating 2062
creating from

assemblies 2065
doors 2065
windows 2065

creating in walls 2062
custom block components 2091
custom shapes 2066, 2069
dimensions 2076
display components 2095, 2099
display properties 2094
editing 2074
endcap style 2077
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endcaps 2060
evenly space openings along a

wall 2088
evenly space openings using Modify

Tool 2088
filll type 2092
flipping 2076
hatching 2096
head height 2064
horizontal position 2081
hyperlinks 2094
in space surfaces

adding 3068, 3074
copying 3071
grip-editing 3077
moving 3071, 3076
removing 3086
stretching 3071

insertion 2064
location 2086
moving 2074
multiple, with same style 2072
notes 2094
opening tools, creation with 2061
overview 2059
positioning 2064, 2073

horizontally 2084
profiles 2065, 2853
reference files 2094
reposition opening using Modify

Tool 2088
repositioning 2078
repositioning openings between two

points 2088
shape 2076
sill display 2089
threshold or head height, alignment

by 2064
thresholds 2064
tool properties 2077
using cut plane of containing

object 2089
vertical orientation 2086
vertical position 2083

optimization
limiting snap points 197

Ortho Close option 1409
OutsideAirFlow property 3191
overrides

component cleanups 1357
display 670
opening endcap styles 1409
wall endcap styles 1402

P

panels, door 1912
parcels

importing 260
importing as polylines 265
importing as spaces 265

PDF
publishing drawings 294

performance (See optimization) 197
plan elevations 3344
plan hatch material components 899
plan sections 3273
plan views, dimensioning (See elevation

labels) 3471
plan views, editing profiles in place 1355
plans

demolition 579
renovation 579
revision 580

plotting
sheet set

reverse order 510
with page setup override 510

plotting sheets
annotation 482
categories 482
changing 511
external references, displaying 500
interactions with projects 511
plotting in reverse order 510
plotting with page setup

override 510
project sheet set 487
sheet

creating 484
electronically transmitting 508
importing in sheet set 493
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opening and closing 495
properties 496
registering 494
synchronizing layer settings with

views 475
sheet drawings

deleting 497
sheet list

changing 505
inserting 502
updating 505

sheet selection
activating 507
creating 506
deleting 507

sheet set
electronically transmitting 508
publishing 510
refreshing 505

sheet subset 491
creating 490
removing 493

sheet template 489
sheet view

creating 497
deleting 499
numbering 498
opening 498
synchronizing layer settings with

views 475
subsets 482
when to start with 483
XML files 482

points
dimensioning 3390

Polyline Close option 1409
polyline outline

creating from objects 1109
polylines

converting to profiles 2855
converting to wall modifiers 1270
from zones 3134
roof slabs 2419
slabs 2419

postlinking views to sheet views 479

PPL file
new 292

prairie-12 lights in window
muntins 2039

prairie-9 lights in window muntins 2036
preliminary studies (See mass

models) 1003
preview graphics 3920
preview pane 368
primary grid line numbers 2773, 2790
profile definitions in Style Manager 870
profiles 2853

add rings 2860
adding to objects 2859
converting to polylines 2864
creating 2855
door geometry 1907
edge direction 2856
edges 2860
edit in place 2860
extrusion direction 2856
grips 2860
railing components 2370, 2375
remove rings 2860
replace rings 2860
rings 2855
vertices 2860
wall cleanups 1354
wall endcaps 1375, 1393
window geometry 2011

project browser
opening 322

Project Browser
closing 357
command line 562
details, exporting 565
Internet Explorer view 326
navigation bar 324
overview 321
project header 324
project selector 325
projects

deleting 357
moving 348
renaming 349

properties 333
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using 322
project bulletin board 340
project fields 3505

inserting 3506
project files

closing 350
project image 340
Project Navigator 315, 360

AutoCAD undo commands 360
categories, creating 393
command line 563

closing 564
context menu 369
details pane 368
drag-and-drop operations 375
Drawing Explorer 367
MDI compliance 568
opening 360
preview pane 368
project status bar 376
tabs 361

Constructs 362
Project 361
Sheet Explorer View 364
Sheet Set View 364
Sheets 364
Views 363

toolbar 372
tooltip styles 368, 374
views

refreshing 527
project sheet set, properties 487
project standard styles

adding 677
changing 677
deleting 677
renaming 677

project standards 309, 599
accessing in Content Browser 644
accessing in Display Manager 646
accessing in Style Manager 644
accessing in tool palettes 643
activating 621
auditing 668
AutoCAD standards 618
changing 677

commands 692
configuring 609

AutoCAD standards 618
display settings 609
styles 609
synchronization 614

Content Browser library 632
copy from project 619
creating tool catalogs 626
default standards folder 620
defining 339
defining standards drawings 609
display settings 601
editing drawings outside of

projects 671
overview 601
prerequisistes 607
project template 608
saving 672
selecting standards tool palettes 637
setting up synchronization 616
setup 607
setup report 622
styles 601
synchronization

conditions 649
options 614
order 650
report 665
settings 614
status 652
with AutoCAD standards 666

synchronizing 647, 654
tool catalog 632

creating 639
tool content root path 633
updating 674
version 675

exceptions 676
history 677
new 676

workflow 601, 606
project standards display drawings 672
project standards drawings

adding styles and display
settings 684

4046 | Index



adding to projects 609
associating styles 612
creating 671
editing outside of project 691
editing version history 686
purging version 689
purging version history 688
removing from project 609
saving 672
synchronizing 690
updating 679
updating from project drawings 682
versioning 687

project standards style drawings 672
project template 328, 330

overview 317
setup 608

project templates
specifying 334

projects
(See also categories, constructs,

divisions, Project Browser,
Project Navigator) 305

activating project tool palettes 376
addendums, alternates, and

as-builts 566
AEC dimensions and external

references 567
annotating 529

schedules 532–533
tagging 530

archiving 566
auditing 668
basepoints 566
closing all files 350
command line 563
command line, new project

environment 564
configuring standards 339, 609
constructs

copying 567
moving 567

Content Browser library 318, 344
copying 328
copying standards 619

creating 328
from scratch 331
from template 328, 330
with existing structure 330

current, selecting 327
cut planes 548

anchoring objects 560–561
and levels 550
display range 549
manual 562
object-specific 549, 559, 561
overriding for walls 559

default folders 204
default options 318
defining standards drawings 609
deleting 357
detail component database 343
details, adding 337
dimensioning 547
disk space needed for project

files 565
displaying

by folder structure 325
by history 326

drawing templates 317
electronically transmitting 352
elements

copying 567
locking 567

external references 314, 567
global cut planes 548, 550

clipped model view 556
display range 551–553
displaying different levels 554

keynote database 342–343
mapped drives 316, 321
moving 348
new 328
opening project browser 322
opening project library 378
overview 305
palettes 204
paths 525
project (APJ) file 313
project standards 599
project tool catalog 344
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project-related information,
removing 358

properties
bulletin board 340
defining 333
drawing templates 334
project image 340

property set definitions 535–536
property sets 533, 535, 567

example of using 532
renaming 349
schedule tables 540
schedule tags 567
setting up standard display

settings 609
setting up standard styles 609
settings 333

bulletin board 340
Content Browser library 344
detail component database 343
keynote database 342–343
project details 337
project image 340
project standards 339
templates 334
tool palettes 344

sheet set 313
sheet set template 317
specifying templates 334
standards drawings 318
structure 330
subcategories 397–398
support files 316
synchronization report 665
synchronizing overview 605
synchronizing view layers with sheet

layers 480
synchronizing with AutoCAD

standards 666
synchronizing with standards 647, 

654
templates 204
tips for working with 315
title blocks 541

creating tools 545
inserting 546

multi-view blocks 545
project attributes 542
project blocks 544

tool palettes 318
updating standards 674
user access 316, 565
wall cleanup work 567
workflow overview 303
XML files 310, 314, 564

corrupted 565
xref paths

full 315
relative 315

properties
AEC dimension styles 3457
column grids 2774
door 1876
fields, for objects 3812
manual, for objects 3812
on Extended Data tab, hiding 3862
on Extended Data tab,

sequencing 3862
section lines 3269
styles and definitions 3815
window 1974

Properties palette
adjusting transparency 110
appearance 108
Design tab 110
Display tab 112
docking 109
Extended Data tab 113
hiding 109
opening 108
transparency 110
worksheets 114

property data formats 3802
applying 3803
creating 3805
managing 3803
notes and reference files 3809
property set definitions 3825
units 3804
using different 3803

property set data
adding 3801, 3810
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attaching to objects and styles 3888
attaching to styles and

definitions 3814
browsing 3821
edit property set data

worksheet 3757
editing 3799, 3810
exporting 3792
exporting to MDB 276
objects and styles, attaching to 3811
publishing to DWF 276
removing 3814
renumbering 3765
styles and definitions, removing

from 3820
property set definitions 3743, 3823

anchor property definitions 3858
automatic properties 3826
automatic property definition 3849
classification property

definitions 3852
classifications 3881
creating 3841
defining 3824
door size properties 3828
door swing direction

properties 3829
editing 3863
fields 3491, 3847
formula property definitions 3830
graphic property definitions 3860
in Style Manager 870
location property definitions 3851
managing 3825
manual property definitions 3845
material property definitions 3855
merging 3867
notes and reference files 3842
project property definitions 3857
property data formats 3825
slab and roof slab properties 3828
specifying application of 3843
structural member length

properties 3829
wall area properties 3826
wall length properties 3828

wall volume properties 3827
property sets 3824

attaching to objects in xrefs 537
fields

converting to text 3813
editing 3813
properties 3812
updating 3813

formulas 3834
evaluating results 3834
inserting VBScript code 3834

manual and automatic
properties 3825

removing 3814, 3867
schedule tables 3743

proxy graphics 183, 206–207
publishing

drawings to PDF 294
publishing drawings to Autodesk

MapGuide and Autodesk
Envision 268

blocks and MVblocks 269
default map file 269
exported data types 268
external references 269
graphic data 268
MDB file 271
point databases 269
prerequisites 268
project data 274
property set data 269
publishing 273
SDF Component Toolkit 268
SDF Loader 269

purging
classification definitions 3879

pyramid mass elements 1011

Q

queries, material 917
quick access toolbar 41
Quick Slice

creating 1109
Quick Slice tool 1109
quick view drawings 66
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quick view layouts 65

R

Radial constraints 1158
radial grids 2777, 2796
radial layout grids 2720
radius, wall 1191
railing styles

bottom rail location 2358
changing 2341
classifications 2369
components 2361
creating 2355
custom blocks

adding 2370
removing 2380
turning off 2380

custom blocks and profiles 2370
custom profiles

adding 2375
turning off 2380

defined 2353
display components 2368
extensions 2363
files 2369
materials 2365, 2367
notes 2369
post location 2359
profile from closed polyline 2363
upper rail location 2356

railing tools
creating 2316
finding in palettes 2307

railings 2331
anchor properties, changing 2347
anchoring

to objects 2323
to stairs 2322

array railings between two
points 2325

array railings using Modify
Tool 2325

bottom rails, changing 2343
center railing between two

points 2325

center railing using Modify
Tool 2325

custom block components 2327
custom profile 2332
direction, reversing 2322
display of custom profiles 2337
editing 2318
evenly space railings along a

wall 2326
evenly space railings using Modify

Tool 2326
freestanding 2312
grips, using to edit 2318
hyperlinks 2352
location 2350
materials 2306
multiple, with same style 2316
notes 2352
polylines, creating from 2316
posts

adding 2319
changing 2344
hiding 2321
redistributing 2321
removing 2320
showing hidden 2321

profiles 2853
railing extensions 2345–2346
railing tools, creation with 2308
reference files 2352
releasing anchored 2325
reposition railing using Modify

Tool 2326
repositioning railings between two

points 2326
stairs, attaching to 2308
tool properties 2352
upper rails, changing 2341

ramps, creating 2150
read-only drawings, status indicator 872
rectangular components

dynamically-sized 3537
rectangular layout grids 2723, 2774
rectangular mass elements 1026–1027
rectangular pattern in window

muntins 2029
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rectangular predefined-depth surface
components 3536

reference files
AEC dimension styles 3467
AEC polygon styles 1867
calculation modifiers 3169
curtain wall units 1640
curtain walls 1506
door assemblies 1778
doors 1923
list definitions 3112
railing styles 2369
slab edges 2522
slabs 2505
space styles 3107
wall cleanup definitions 1353
wall endcap styles 1407
wall modifier styles 1284
wall styles 1323
walls 1246
window assemblies 1778
windows 2027
zone styles 3148
zone templates 3155

referencing AEC objects 3941
relative xref paths in projects 315
removing frame 1467, 1606, 1737
removing from style

curtain wall styles 1467
curtain wall unit styles 1606
door assembly styles 1737
window assembly styles 1737

removing vertices 1366
rendering materials, assigning 925
Renovation

categories 589
display modes 592
layers 594
modifying objects 589
settings 585
styles catalog 597

renovation mode 581
Renovation mode

about 581
activating 582
design rules 592

renovation plans 579
renumbering objects for schedules 3765
repathing projects 525
Reposition From command 2851
reposition linework 2851
reposition profile-based object 2851
representations, display (See display

representations) 803
restoring layer states 755
return offsets

wall endcap styles 1406
ReturnAirFlow property 3191
reversing handing

doors 1895
windows 1998

reversing wall direction 1222
revision clouds

creating 3660
editing 3669, 3672
inserting 3663

revision plans 580
revolution mass elements 1018
ribbon 24
right triangle mass elements 1012
rigid frame structural members 2659

first and second rafter 2664–2665
second segment 2665

rings
spaces 3049–3050

roof dormers 2388, 2485
roof grips, editing roofs using 2395
roof lines

editing 1224, 1228–1229
offsetting 1224
projecting 1224
reversing 1233
steps, adding 1228
vertices 1234
walls 1224, 1228, 1234

roof lines, curtain walls
changing 1557, 1566
offsetting 1557
projecting 1557
vertices, changing 1567

roof slab body modifiers
editing in place 2472
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roof slab edge styles
materials 2521
profile edges and extrusion 2513
soffits

geometry 2516
roof slab edges

profiles 2853
roof slab grips 2427
roof slab offsets 2447
roof slab styles

display components and
materials 2496

materials 2501
roof slab thickness

changing 2447
roof slabs

adding objects to 2467, 2471
clipped gable 2484
creating

from roofs 2398, 2418
creating from

polylines 2419
cutting 2461
defined 2383, 2405
dormers 2388, 2485
editing 2426
holes 2464, 2466
materials 2498, 2520
mitering 2458, 2460
moving 2426
polylines 2419
properties 3828
removing objects from 2469
styles 2447
vertices 2462–2463
xcut 2484

roof tools
creating 2392
finding in palettes 2384

roofs
dimensions 2396
display components and

materials 2399
display properties 2400
edges and face 2397
editing 2394

hatching 2401
hyperlinks 2403
location 2402
moving 2394
multiple, with same style 2392
notes 2403
polylines, creating from 2391
reference files 2403
roof slabs, converting to 2398
tool properties 2395
walls, creating from 2390

root path
tool content 344

rules, design (See design rules) 1903

S

sash, window 1961, 2016
saving

AutoCAD objects 183
Proxy Graphics 183
to previous file format 183

scale
specifying in drawings 187

schedule table styles 3769
columns

adding 3777
editing 3785
formula 3781
quantity 3780
repeating 3781
spanning with a heading 3784

creating 3769, 3771
default format of 3773
display properties 3789
filtering by classification 3776
headings 3784
notes and reference files 3790
sort order 3787
specifying objects 3774
title formats 3788
troubleshooting 3901

schedule tables
(See also schedule table styles) 3741
adding objects 3751
adding to drawing 3747
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basic 3747
cell data, editing 3799
convert to table option 3766
creating 3766
customizing appearance 3766
default tools 3747
display properties 3793
editing 3766
exporting 3791
exporting data for objects 3792
external source properties 3796
formulas 3830
general properties 3794
hyperlinks, notes, and reference

files 3799
managing 3766
markers, turning off 3752
out-of-date, flagging 3769
placement 3796
property set data, adding 3801
removing objects 3751
reselecting objects 3752
selection criteria 3795
showing objects 3753
table breaks 3797
tools, creating 3748
troubleshooting 3898
updating 3753

schedule tag tool,creating 3760
schedule tags 3756

adding 3756
anchoring to objects 3763
connection to objects 3764
creating 3754, 3757
doors and windows, adding to 3756
editing 3754
property set data worksheet 3757
releasing anchored objects 3764
troubleshooting 3904

schedules
(See also schedule tables) 3739
classifications in 3874
creating 3767
matrix 3770
overview 3739
renumbering objects for 3765

terminology 3740
SDF Component Toolkit 268
SDF Loader 269
secondary grid line numbers 2773, 2790
section hatch linework 3311
section hatch material components 902
section lines 3258

and section marks 3260
changing 3259
defined 3251
graphic subdivisions 3267
hyperlinks, notes and reference

files 3271
location properties 3269
viewing 3259

section marks
and section lines 3260
attributes 3268, 3270
defined 3251

section subdivisions (See subdivisions,
section) 3254

section tools 3690
properties 3694

section views
creating from a callout 462

section views, dimensioning (See elevation
labels) 3471

sectioned bodies in live section
views 3277

sectioned body material
components 902

sectioned boundary material
components 902

sections
(See also 2D sections and 3D

sections) 3251
creating with callouts 3709

in current drawing 3710
in existing drawing 3712
in new drawing 3715

defining lines 3308
dimensions, changing 3262–3264, 

3266
display components 3306
erased component 3312
hidden component 3311
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horizontal 3273
live section views 3254, 3275
location properties 3269
material boundaries 3256, 3285
materials 902, 3254, 3307
section hatch linework 3311
shrinkwrap 3308
shrinkwrap hatch 3309
subdivisions 3255, 3260, 3312
surface hatch linework 3310

semi-automatic synchronization 615
separator lines

in tool palettes 81
settings, Renovation objects 585
sheet drawings

deleting 497
Sheet Explorer View 364
sheet index 502
sheet list 502
sheet selection 506

activating 507
deleting 507

sheet set
for projects 313
overview 307
publishing 510

sheet set fields 3507
inserting 3510

sheet set template
consolidating inconsistent project

information 347
creating 511

from existing drawings 519
from existing sheet set 512

for projects 317
Sheet Set View 364
sheet subset 491
sheet template in projects 489
sheet views 481

creating from model space
views 471

creating from view drawings 465
postlinking to views 479
synchronizing layer settings with

views 475

using display configurations from
views 478

viewport layer overrides 478
sheets 481

display configurations 478
layer settings 475
overview 307
sheet

deleting from sheet set 496
sheet drawings 481
sheet view 481
synchronizing layer settings with

views 475
viewport layer overrides 478

ShowMotion 70
shrinkwrap 3308

cut plane display 1241, 1319
shrinkwrap hatch 3309
sills 1819, 2089

of a window, changing 1996, 2025
sills of assemblies, changing 1819
sills of openings, changing 2089
SIS

area calculation standard 3010
sizes

openings 2063
windows 1968

slab body modifiers
editing 2476
editing in place 2472
removing 2476
restoring to mass element 2478

slab edge styles 2508
angles 2510
creating 2508
defined 2506
edge cuts 2510
fascia

geometry 2516
placement 2507
specifying 2514

materials 2521
notes and reference files 2522
overhang 2510
profiles

fascia 2511
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soffits 2511
soffits

placement 2507
specifying 2514

slab edges
defined 2408
editing 2452
overhang 2437
profiles 2853

slab grips 2427
slab styles

changing 2447
classifications 2504
cut plane height 2503
defined 2486
display components and

materials 2496
display properties 2499
hatching 2501
materials 2501
notes and reference files 2505

slab tools
creating 2423
finding in palettes 2410

slabs
adding objects to 2467, 2471
based on walls 2415
bodies 2406
components 2500
creating 2412

from spaces 2422
overview 2405

creating from
polylines 2419

creating with slab tools 2410
cutting 2461
edge styles 2506
editing 2426
extending 2456
holes 2464, 2466
hyperlinks 2451
justification 2413
location 2449
material components 2497
materials 2498, 2520
moving 2426, 2449

multiple walls 2415
multiple with same style 2423
notes 2451
offsets 2440
pivot points 2446
polylines 2419
properties 3828
reference files 2451
removing objects from 2469
slopes 2442, 2448
thickness 2440
tool properties 2446
trimming 2453
vertices 2462–2463

slabs and roof slabs
cut plane display 2450

slices 1101
attaching objects 1104
converting

to polylines 1105
detaching objects 1104
elevation 1104
generating 1102
hyperlinks 1106
location 1105
notes 1106
reference files 1106

sloped roofs
creating 2388
creating with roof tools 2385

soffits 2506
slab edge 2408

solution tips 59
space boundaries

activating 3015
by area calculation standard 3006
by style 3006
classifying 3011
displaying 3015
dividing 3040
editing 3014
grip-editing 3017
intersecting 3042
manual 3005
merging 3036
moving 3025
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removing voids 3049
resetting 3024
reversing rings 3049–3050
subtracting holes 3041
trimming 3047

space boundaries (legacy)
converting to spaces 3197
converting to walls 3197

space calculation modifier styles (See
calculation modifier
styles) 3163

space decomposition
defined 3171
display settings 3173
displaying 3172
layer, color, linetype settings 3173
methods 3174
text settings 3176
trapezoid 3174
triangulated 3174

space evaluation document formats
TXT (ASCII text) 3187
XLS (spreadsheet) 3186

space evaluations
content, defining 3180
creating XLT template 3188
data format style properties 3184
default templates 3185
defined 3177
documents (See space evaluation

document formats) 3186
image display 3182
preparing the evaluation 3178
selecting spaces 3179
selecting zones 3179

Space Evenly command 2851
space linework evenly 2851
space profile-based object evenly 2851–

2852
space styles 3093

boundary offsets 3096
classifications 3098
converting from area styles 3108
creating 3094
cut plane 3106
defined 3093

display properties 3101
hatching 3104
list definitions 3097
materials 3098, 3100
notes 3107
reference files 3107
target dimensions 3095
tools, creating with 2939

space surfaces
adjacencies

defining 3091
displaying 3092

ceilings 3061
doors

removing 3086
floors 3061
grip-editing 3057
joining 3053
openings 3067

adding 3068, 3074
copying 3071
grip-editing 3077
moving 3071, 3076
removing 3086
stretching 3071

properties 3061
splitting 3052
windows

removing 3086
space type

changing 3026
space types 2917

associative 2940
non-associative 2983

SpaceEngineeringObjects property
set 3191

spaces
adjacencies 3091–3092
associative 2940
attaching to zones 3127
autogenerating 2940

2D spaces 2953
3D freeform spaces 2953
extruded 3D spaces 2953

automatic updates 2964
base boundaries 3014
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boolean operations 3034, 3050
boundaries 3004

grip-editing 3017
boundary objects 2941
boundary objects in blocks 2958
boundary objects in xrefs 2958
calculating and evaluating

information (See space
evaluations) 3177

calculation cut planes 3169
calculation formula 3167
calculation modifiers 3164
calculation type 3166
changing height (3D freeform) 3031
changing height (extruded 3D) 3029
changing space type 3026
changing styles 2997
changing surface height (extruded

3D) 3033
classifying according to area

calculation standard 3011
commands 3198
converting from

areas 2931
mass elements 2987
mass groups 2989
object outlines 2989
polylines 2989
profiles 2989

converting mass elements 1040
creating

2D 2983
converting from objects 2987
extruded 3D 2983
polygonal 2986
rectangular 2985
with target dimensions 2983

cut plane display 3002
decomposition (See space

decomposition) 3171
deducting objects 2971
detaching from zones 3128
display components 3099
dividing 2969, 3040
editing

space boundaries 3014

geometry 3089
grip-editing 3017
gross boundaries 3014
hyperlinks 3003
inheriting zone hatch 3145
interference conditions

adding 3035
removing 3036

intersections 3042, 3056
issues with area calculation

standards 2981
issues with boundaries 2980
issues with boundary objects 2975
issues with updating 2978
issues with wall sweeps and wall

modifiers 2982
issues with xrefs 2982
joining surfaces 3053
location 2997
making associative 2972
making non-associative 2972–2973
manual updates 2966
merging 2967, 3036, 3054
net boundaries 3014
notes 3003
override boundary objects in

xrefs 2960
planning 2917
properties 2933
reference files 3003
removing voids 3049
renaming 2997
reversing rings 3049–3050
space boundaries 3014

activating 3015
displaying 3015
resetting 3024

space calculation modifier styles (See
calculation modifier
styles) 3163

specifying additional display
properties for zones 3136

specifying text type for a
decomposition 3000

specifying the decomposition
type 2998
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splitting surfaces 3052
subtracting holes 3041, 3055
surfaces

grip-editing 3057
height 3033
openings 3067

tools 2939, 2991
trimming 3047, 3050
troubleshooting 2974
types 2917
updating 2963
usable boundaries 3014
zone boundary offset 3130

spaces, adding engineering data to 3191
special conditions in walls 1255
specifying cleanup settings 2331
Specifying Stair Display at Different

Levels 2255
sphere mass elements 1015
spiral stairs

arc constraints 2134
constraints, changing 2195
creating 2130
drawn direction, changing 2194
floor settings 2136
horizontal orientation 2132
outside edge, changing 2196
terminating with 2133
vertical orientation 2132

stair
custom from linework 2137
custom from tread profiles 2141

stair anchors
landing 2207
releasing 2209

stair body modifiers
editing 2233
geometry 2230
removing 2233
restoring to mass element 2234
stair components

adding to 2226
replacing 2229
subtracting from 2228

working with 2226

stair dimensions
height, changing 2192
justification, changing 2194
multi-landing stairs, changing 2161
spiral, changing 2175
straight stairs, changing 2156
u-shaped, changing 2169
width, changing 2177

stair flights
components, changing 2250
shape 2180

stair height
multi-landing stairs,

changing 2166–2167
spiral stairs, changing 2177
straight stairs, changing 2159
u-shaped stairs, changing 2173

stair interference conditions 2235
curtain walls 2243, 2246
door assemblies 2246–2247
size, changing 2248
slabs 2239, 2242
spaces 2242–2243
walls 2235, 2238
window assemblies 2246–2247

stair landings
components, changing 2251
extensions, changing 2254
shape 2182

stair location
multi-landing stairs, changing 2162
spiral stairs, changing 2176
straight stairs, changing 2157
u-shaped stairs, changing 2170

stair sides, changing shape 2184
generating polyline 2190
offsetting side 2189
projecting side 2187
removing changes 2191

stair styles
changing 2194
classifications 2296
color 2290
components 2283, 2288
creating 2276
defined 2274

4058 | Index



dimension properties 2277
display properties 2289, 2292
editing 2277
files 2297
landing extensions 2285
layer 2290
linetype 2290
materials 2287–2288
notes 2297
riser numbering display 2295
stringers 2279

stair tools
creating 2152
finding in palettes 2107

stair tower
creating 2301
modifying 2304

Stair Tower Generator 2301
stair winder styles

creating 2298
defined 2298
files 2300
notes 2300
settings 2299

stair winders
adding a tread 2218
aligning a tread edge 2213
editing 2209
lengthening a flight to align tread

edge 2210
manual editing 2221, 2223
moving tread ends 2223
removing a tread 2216
straightening treads 2221

StairFit 2203
stairs

adding and subtracting
objects 2226, 2228

AEC options 2106
attaching railings 2308
components 2266
cut planes 2267
dimensions 2199
display properties 2269
display properties, changing 2265
editing 2154

files 2273
grips 2154
hyperlinks 2273
location 2263
materials, specifying 2264
multiple, with same style 2152
notes 2273
overlapping 2255, 2261
replacing stairs with objects 2229
riser numbers, displaying 2271
shape 2164
stair tools, creation with 2108
tool properties 2263

Stairs
Cut Line Extension 2291
Display Ramp Arrows 2292
Specifying Down Display

Components 2255
Specifying Up and Down Display

Components 2255
Specifying Up Display

Components 2255
stamp-type components 3529
standard display settings 851

accessing 646
standard sets (See default display

sets) 836
standard styles

accessing 644
standard tools 604

project 622
standards drawings

for projects 318
standards, layer (See layer standards) 718
starburst pattern in window

muntins 2043
status indicator for read-only

drawings 872
SteeringWheels 68
steps, adding to roof or floor line 1228, 

1570
Stock Tool catalog

categories 157
viewing 132

stops, door 1912
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straight curtain walls
curtain wall tools, creation

with 1420
straight stairs

calculation rules 2111, 2117, 2127, 
2135

creating 2108
terminating with 2110
vertical orientation 2109

straight swing
specifying the display of 1895

structural column grid tools 2756
structural column grids 2756
structural member body modifiers

adding 2616
editing 2623
geometry 2620
removing 2623
restoring to mass element 2624
structural member components

replacing 2619
working with 2615

Structural Member Catalog 2526
browsing 2531
content of 2532
locating shapes 2535
opening 2533
opening catalog files 2535
organization of 2531
structural member styles,

creating 2531–2533
structural member length

properties 3829
Structural Member Style wizard 2526

structural member styles,
creating 2536

structural member styles
catalog shapes, creating from 2532–

2533
changing 2610
classifications 2643
custom blocks

adding 2640
removing 2643
turning off 2642

cut plane elevation 2639

display components 2631
display properties 2633
hatching 2638
layer, color, and linetype 2637
materials 2630–2631

assigning 2631
notes 2644
overview 2628
reference files 2644
Structural Member Catalog 2531
Structural Member Style

wizard 2536
Style Manager 2629

structural members
adding objects to 2624
creating 2530
curved structural members 2598
custom 2645
custom block components 2612
custom shape 2667
custom shapes

adding 2652
creating 2666

cut plane display 2610
design rules 2648
display representations 2633
editing 2585
endpoint 2595
grips, editing with 2586
hyperlinks 2615
justification 2599
length 2592
linework, creating from 2584
materials 2529
modifying 2651
multi-component 2656, 2659
notes 2615
overview 2525
radius of curved 2597
reference files 2615
removing objects from 2627
replacing structural members with

objects 2619
rigid frames (See rigid frame structural

members) 2659
roll 2596
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shapes, adding 2652
start and end offsets 2593
start point 2595
styles 2610
subtracting objects 2617
tool properties 2610
tools 2539, 2553

beam tools 2539
brace tools 2544
column tools 2549

trim planes
adding 2603
adding, based on object or

linework 2607
changing 2609
mitering 2608
overview 2602
removing 2609

type of 2601
structural members body modifiers

structural members
subtracting from 2617

Style Manager
drawings and templates

closing 882–883
creating new 882
determining status of 881
dragging 883
opening 881–882

left pane 872
menu bar and toolbar 872
opening 871
overview 870
right pane 872
status bar 873
structural member styles 2629
styles

creating 874
dragging to tool palettes 876
sorting 873

styles 597
(See also individual component

names, Style Manager) 871
attaching property set data 3814
cleanup group definitions 870
copying between drawings 877

copying between objects 875
corner windows 1960
creating 874
creating tools from 876
displaying 872
entering properties 3815
layer key 870
materials 888, 919
previewing 872
removing property set data 3820
renaming 877
sending to other users 879
sorting 873
spaces 3093
standard tools 604
unused, removing 880
viewing across multiple

drawings 873
walls 1212

styles locations 126
subcategories (See categories,

project) 397
subdivisions, section 3254–3255, 3260

components 3312
display of 3281, 3283
section lines 3267

Subtract command 2844
subtracting

profiles 1367
profiles from wall endcaps 1393
spaces 3041

subtractive mass elements 1073, 1098
sunburst pattern in window

muntins 2046
SupplyAirFlow property 3191
support files

for projects 316
support files locations 126
surface hatch linework, sections 3310
surface hatch material components 900
surface hatches 904

curved surfaces 905
extrusions 907
free form mass elements 909
hidden, displaying 912
hiding 910
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multiple faces 906
offset, horizontal and vertical 914
overrides, editing 916
overriding 909
patterns 923
rotation 913

surfaces
importing 260, 266

surfaces (See space surfaces) 3033
swings, door

displaying as straight line 1920
swings, window

angles 1979
synchronization

automatic 614
display settings 659
exceptions 656
excluding display settings 665
excluding styles 665
individual display settings 664
individual styles 664
manual 615
of project standards 614
performing 654
project drawing 667
project drawing with standards 657
report 665
selected styles 659
semi-automatic 615
setup 616
with AutoCAD standards 666

synchronizing layers in project 475
postlinking 479
view layers and sheet view

layers 475
synchronizing project standards 647

T

T-intersections 1328
target dimensions

for spaces 3095
technical support 10
templates

closing in Style Manager 882–883
creating drawings from 180

creating in Style Manager 882
default folders 179
defined 179
dragging in Style Manager 883
opening in Style Manager 881–882
predefined display

configurations 801
space evaluation documents 3185

terminating with
multi-landing stairs 2116
spiral stairs 2133
straight stairs 2110
u-shaped stairs 2126

text
fields 3497
in tool palettes 81

text-based annotation
editing 3606

text-only annotation
creating 3600

text-with-leader annotation
creating 3600

thawing walls 592
thresholds, door

display properties 1921
symbols 1922

title blocks 541
inserting 546
multi-view blocks 545
project attributes 542
project blocks 544
tools, creating 545

title marks 3690
inserting 3702
properties 3694

tool catalog libraries 130
catalogs

adding 144
copying 146
creating 137
editing properties 150
removing 154
viewing 132

opening 154
renaming 155
websites, adding 148
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tool catalogs
adding tools from drawings 141, 

629
catalog libraries 144
categories, definition of 157, 160
copying 146

tool packages 171
tool palettes 170

creating 137
creating a catalog install file 145
creating from drawings 138, 626
creating from projects 626
customizing tools 166
deleting items 167
dragging items to workspace 135
for projects 632
i-drop icon 134
linked 150
linked and unlinked items 167–168
moving tools between 164
name limitations 137
opening in Content Browser 174
properties, editing 150
publishing 146
read-only 134
refresh options for tool palettes 173
removing 154
searching 155–156
supplied with Autodesk Architectural

Desktop 130
tool packages, adding 161
tool palettes, adding 160
tools

adding 162
using 168

unlinked 150
viewing 132

tool content
root path 344

tool content root path
in projects 633

tool packages
adding to tool catalogs 161
adding tools 162
copying 163, 171
moving 163

moving tools between 164
opening in Content Browser 174
overview 159

tool palettes 43, 70
activating for projects 376
adding from Content Browser 83
adding to tool catalogs 160
adding tools 162
appearance 79
AutoCAD tool palettes 128
central location 82
copying 163, 170
creating 78
dragging to workspace 135
for projects 318
in Content Browser 82
moving 163
moving tools between 164
opening in Content Browser 174
overview 159
project profile, adding 641
refreshing 173
selecting project standards 637
separator lines 81
setting the appearance 79
text 81
updating from Content Browser 84
working from central location 82

tool palettes group 72
creating 77

tool palettes set 71
adjusting transparency 75
appearance 73
creating 76
different palette combinations 75
docking 74
hiding 74
opening 73
renaming 75
setting appearance 73
specifying tool palettes 75

tools 72, 85
AEC dimension 3406, 3421
AEC polygon 1830, 1833
anchor 2700
applying properties to object 105
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ceiling grid 2806, 2812
column grid 2750
command tools 96
copying from tool palette 93
creating 1250
creating from DesignCenter 95, 

3915
creating from objects 92
creating from Style Manager 94
creating from styles 876
creating objects 87
curtain wall 1433
deleting 107
door 1874
door assembly 1700
elevation label 3475
from a central location 101
icon

changing 90
refreshing 92

in Content Browser 101
linking from Content Browser 101
multi-view blocks 2902
openings 2060, 2072
properties, changing 89
railing 2307, 2316
re-importing styles 106
refreshing 172
removing link to Content

Browser 105
roof 2384, 2392
slab 2410, 2423
stair 2107, 2152
structural column grid 2756
style location 86
tool types 86
updating from Content Browser 104
updating in Content Browser 104
wall 1163, 1211
window 1962, 1971
window assembly 1700
zone 3123

tooltips 54
command tooltips 54
dialog tooltips 56
extended tooltips 54

object grip tooltips 60
object rollover tooltips 56
palette tooltips 56
property tooltips 57
solution tips 59
thumbnail previews 57
turning on and off 55

top-level categories, specifying location
of 396

Trim command 2839–2840
trim linework 2839
trim linework to edge 2840
trim planes, structural members 2602–

2603, 2609
trim profile-based object 2839
trim profile-based object to edge 2840
trimming

spaces 3047, 3050
wall endcaps 1390
wall intersections 1370

troubleshooting
AEC Editor 197
classifications 3902
display changes upon dragging 866
display system 865
existence of objects in drawings 866
linetypes 867
schedule table styles 3901
schedule tables 3898
schedule tags 3904
units, on extended data tab 3904
viewports 866
wall cleanups 1343

true colors
AEC polygons 1855, 1866
masking in AEC polygons 1865

true length 1410
turn types

multi-landing stairs 2115
u-shaped stairs 2124

U

u-shaped stairs
alignment, changing 2249
constraints 2129
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creating 2123
floor settings 2130
horizontal orientation 2125
terminating with 2126
turn types 2124
vertical orientation 2126

UCS
aligning to object face 124

unconstrained doors and windows 1178
units

property data formats 3804
troubleshooting 3904

units, specifying in drawings 184, 195
updating

associative spaces 2963
fields 3504

usable boundaries
activating 3015
displaying 3015
editing 3014
spaces 3004

user interface
working with objects in 61

utilities
referencing AEC objects 3941

V

validating LandXML 263
variable grid lines 2772, 2783
velocity measurements 195
version

editing 686
exceptions 676
GUID 675
history 677
new 676
project standards 675
project standards drawing 687
purging 689
purging history 688

version history 686
Vertical constraints 1151
vertical orientation

multi-landing stairs 2115
spiral stairs 2132

straight stairs 2109
u-shaped stairs 2126

vertices
adding to wall intersections 1363
removing 1366
roof and floor lines 1234

vertices in roof and floor lines 1571
view directions

and display representations 822
view drawings

placing on sheets 465
synchronizing layers with sheet

views 475
ViewCube 67
viewers, placement of 197
viewports

display configurations 810
assigning 835
default 837

displaying objects 801, 812
troubleshooting 866

views
and constructs 450
and sheet views 446
annotation 451
changing 480
content 481
creating 453

assigning levels and
divisions 455

defining properties 454
selecting constructs 456

deleting 467, 481
display configurations 478
electronically transmitting 466
external references, displaying 458
interactions with projects 480
layer settings 475
layer snapshots 446
model space view drawings 462
model space views 468
names and categories 481
opening and closing 461
overview 306, 446
placing on sheets 465
plotting sheets 446
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postlinking to sheet views 479
projects, adding to 480
properties 463
regenerating 465, 563
synchronizing display configurations

with sheet view 478
synchronizing view layers with sheet

views 475
templates 452
updating 451
viewport layer overrides 478
when to start with 452

visibility
display components 793

Visual Audit utility 3939
performing 3940

voids
spaces 3049

volume anchors
adding 2695
anchoring to different

volumes 2698
copying objects to all layout

volumes 2698
defined 2695
position of objects attached to,

changing 2696
size of objects attached to,

changing 2696

W

wall area properties 3826
wall body modifiers

adding 1285
editing 1291
geometry 1288
removing 1291
replacing wall components 1287
restoring to mass elements 1292
subtracting from walls 1286
working with 1284

wall cleanup
chamfering 1362
fillet 1361

wall cleanup groups
assigning different definitions 1340
creating 1352
definitions 1351
notes and reference files 1353

wall cleanups
definitions 1353
notes and reference files 1353
profiles 1354
troubleshooting 1343

wall components
cleanup priorities of 1302
hatching 1240, 1317
index 1302
layer, color, and linetype 1239, 

1316
material components 1313

wall endcap styles
applying to wall style 1402
modifying 1403, 1406
notes and files 1407
overriding on walls 1402
return offset 1406
substituting geometry 1403
wall endcap profile 1403

wall endcaps
adding vertex grips 1382
Calculate Automatically

feature 1396
chamfering 1387
converting edges to arcs 1383
creating with in-place edit

grips 1375
drawing polylines 1396
editing 1379
extending 1391
filleting 1385
hiding edges 1389
merging 1395
modifying components with in-place

edit grips 1375
modifying with in-place edit

grips 1375
offsetting 1380
profiles 1375
showing edges 1388
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subtracting profiles 1393
trimming 1390
Vertex grips 1379

wall grips 1191
wall interference conditions 1292
wall intersections

cleanup workflow 1323
cleanups 1324, 1354, 1357
dynamic cleanup radius

variable 1335
editing in place 1354
extending 1372
hiding edges 1357
merging profiles 1368
multiple intersections 1330
removing vertices 1366
showing edges 1359
subtracting profiles 1367
trimming 1370
vertices 1363

wall justification
changing while drawing 1165

wall length
changing 1191
properties 3828

wall modifier styles
creating 1283
notes and files 1284

wall modifiers
adding 1273
applying opposite faces 1268
bump-outs or chases 1268
converting polylines to 1270
editing 1275
placement 1279
removing 1295
working with 1268

wall orientation
changing while drawing 1164

wall properties 1295
wall radius 1191
wall styles

adding components from other
styles 1307

classifications 1322
complex endcaps 1320

components 1299, 1305
components browser 1301
creating 1297
creating components 1305
cut planes 1319
defined 1296
display properties 1316
endcap styles 1402
hatching 1317
information 1320
materials 1313, 1315
miters 1320
notes and reference files 1323
offset 1412
opening endcap styles 1408
removing components 1313
viewing components 1300
width 1412

wall sweeps
adding to walls 1258
editing 1267
geometry 1260
mitering 1267
profiles 2853
profiles, creating for 1257
removing 1267

wall tools 1250
wall volume properties 3827
wall width 1191
walls

3D objects, creating from 1176
adding and subtracting

objects 1285–1286
adding assemblies 1187
adding doors and windows 1178, 

1187
adding sweeps 1258
anchoring objects to 1188
arced wall segments 1163
base height 1191, 1204
chamfering 1220
cleanup guidelines 1339
cleanup priorities 1337
cleanup radius 1341
cleanup workflow 1323
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cleanup, specifying for specific
walls 1340

converting polylines to wall
modifiers 1270

converting to curtain walls 1431
corner windows 1958, 1964
creating from arcs 1174
creating from circles 1174
creating from lines 1173
creating from linework 1173
creating from polylines 1175
creating roofs from 2390
creating with tools 1163
curved walls 1410
customized surfaces 1255
cut plane display 1241
detaching objects 1189
direction 1161, 1222
display properties 1238, 1244
draw wall from wall justification

line 1171
duplicated in xref drawings 1350
editing 1190
filleting 1217
floor line vertices 1411
floor lines 1224, 1226
gable roof lines 1227
grips 1191
intelligent cleanups 1324–1325, 

1328, 1330
interference conditions 1294–1295
interference objects,

modifying 1295
intersection cleanup 1324
intersections 1324
joining 1215
justification 1165, 1170, 1207
justification lines 1333
length 1191, 1205, 1410
length properties 3828
location 1213
materials 1236
merging 1214
merging profiles 1368
miters 1267
modifier styles 1283

modifiers 1268, 1275
moving 1190, 1196
multiple, with same style 1250
notes and reference files 1246
offsets 1167, 1171, 1207
openings 1187
orientation 1164
plan views 1244
profiles for sweeps 1257
properties 1169, 1295
radius 1191
releasing doors from 1892
releasing windows from 1991
removing all merged 1215
removing individual merged 1214
removing objects 1188
removing sweeps 1267
replacing walls with objects 1287
repositioning 1167, 1209–1210
reverse baselines 1222
reversing direction 1222
roof line vertices 1411
roof lines 1224
shape, changing 1199
special conditions 1255
start and end points 1222
straight wall segments 1163
styles 1212, 1412
sweep geometry 1260
sweeps 1256, 1258, 1260, 1267
tools 1163, 1211, 1250
vertices in roofs and floors 1234
volume properties 3827
wall component priorities 1342
wall modifiers 1273, 1279
width 1191, 1200, 1202, 1412

websites, adding to tool catalog
libraries 148

width
wall 1191
window 1978

winders
editing 2209
manual editing 2221, 2223

4068 | Index



window
repositioning windows between two

points 1992
window assemblies

alignment of objects in cells 1825
auto-adjusting cells 1715
cell markers 1780
creating 1691, 1694
curtain walls, inserting into 1485
custom grids 1699
dimensions 1813
display of 1770
division overrides 1802
editing 1809
editing objects in cells 1824
frame and mullion overrides 1790
frame edges 1793
frames and mullion overrides 1789
freestanding 1814
hyperlinks 1823
in-place editing 1796
infills

for inserting objects 1725
overrides 1783

interference conditions 1815–1816
matching properties 1813
materials 1769
merging cells 1780
mitering 1817
moving 1809, 1812
mullion edges 1793
multiple, with same style 1700
nested grids 1748, 1750
notes and reference files 1823
offset of objects in cells 1825
orientation of objects in cells 1824
positioning 1695
releasing anchored objects in

cells 1826
removing overrides 1807
swapping two objects 1826
window assembly tools, creation

with 1693
window assembly cells

cell assignment 1757
filling with panel 1752

infills
defining 1722
removing 1756

objects, inserting 1755
window assembly components

custom graphics 1774
display 1771
hatching 1773
layer, color, and linetype 1772

window assembly dimensions 1694
window assembly frame 1737
window assembly frames 1759
window assembly grids

cells 1746
fixed size 1712
manually defining number and

size 1718
custom 1699
divisions 1711, 1746
elements 1688–1689
fixed number 1717
frame edges 1761, 1763
frames, adding 1760
mullions 1737, 1739–1742
nested grids 1748
offset 1719

window assembly grips
editing window assemblies

using 1810
window assembly properties 1779
window assembly styles 1737

assigning
definitions to elements 1745
definitions to mullions 1763
divisions to grids 1746
infills to cells 1746

assignments 1759
cell infills 1746
changing 1812
creating 1708
creating cut planes 1776
defined 1703
division definitions 1721
element of 1808
elements of 1707, 1745
frame offsets 1735
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frames 1730
width and depth 1731

grid cells 1712
infills

alignment 1727
definitions 1729
offset 1727
overriding 1780

matching styles 1813
mullions

assignments 1764–1765
definitions 1744
offsets 1742
removing from grids 1766
width and depth 1739

notes and reference files 1778
overrides 1779
overview of creating 1705
panel infills 1724
profiles

frames 1732–1733
mullions 1740–1741

shape 1814
window assembly tools 1700
window components

custom blocks for 2019
display of, turning off 2022
layer, color, and linetype 2018
window styles, removing from 2022

window dimensions
changing for window styles 2006

window frames, assigning
materials 2016

window glass 1961
window measurements (See window

dimensions) 1978
window muntins

creating 2028
diamond pattern 2032
display of, turning off 2053
editing 2052
gothic pattern 2049
materials 2016
prairie-12 lights 2039
prairie-9 lights 2036
rectangular pattern 2029

starburst pattern 2043
sunburst pattern 2046
window styles, removing from 2054

window sash materials 2016
window sashes 1961
window sills

height 1969
specifying display 2025

window styles
changing 1977
components 2020, 2022, 2024
corner windows 1960
creating 2004
creating window tools from 1971
custom window shapes 2008
defined 2003
design rules for 2010
dimensions 2006
display of components, turning

off 2022
display properties 2017
geometry 2011
materials 2018
muntins 2054
notes and files 2027
opening percentage 2023–2024
shapes, replacing 2011
standard sizes 2007

window swings
angles 1979
opening percent 1979

windows
adding 1178
aligning by head height or sill

height 1969
array windows between two

points 1991
array windows using Modify

Tool 1991
assemblies 1350
center window between two

points 1991
center window using Modify

Tool 1991
centering in walls from xref

drawings 1350
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corner windows 1958, 1964
creating 1964

from door and window
assemblies 1970

from doors 1970
from openings 1970
in door and window

assemblies 1970
in walls 1965

custom block components 1999
custom shapes 2008
display components and

materials 2014
display of endcaps in model

views 1243
display properties, specifying 2017
door and window assemblies,

inserting
into 1755

editing 1974
endcaps 1957
evenly space windows along a

wall 1992
evenly space windows using Modify

Tool 1992
frame display 1895, 1998
frames 1961
freestanding 1993
geometry, editing 2011
head height, aligning 1969
horizontal position 1986
in space surfaces

adding 3068, 3074
removing 3086

inserting 1969
into door assemblies 1755

inserting into curtain walls 1485
materials, assigning 2016
moving 1974

along walls 1981
to a different wall 1991
within walls 1984

multiple with same style 1971
muntins block components 1995
notes and reference files 2002
opening endcap styles 1993

opening percents, specifying 2023–
2024

placing across length of wall 1182
placing evenly on wall 1179
placing relative to column

grids 1182
positioning 1969, 1974

horizontally 1989
profiles 2853
properties of 1974
releasing from walls 1991
reposition window using Modify

Tool 1992
reversing handing 1998
schedule tags, adding 3756
shapes 2011
sill display 1996
sizes 1968
sizes, standard 2007
tools, creating 1971
type and shape 2010
using cut plane of containing

object 1994
vertical alignment, changing 1980
vertical orientation 1990
vertical position 1987
width

changing how measured 1978
grips, using to edit 1975

window tools, creating with 1962
wings (See divisions) 311
wizard, Create AEC Content 2868
worksheets 114
workspace

adding objects 62
application menu 36
application status bar 48
command window 47
Communication Center 54
components 23
context menus 42
drawing window status bar 44
InfoCenter 52
modifying objects 62
overview 22
Project Navigator palette 51
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Properties palette 44, 107
quick access toolbar 41
quick view drawings 66
quick view layouts 65
ribbon 24
ShowMotion 70
SteeringWheels 68
tool palettes 43, 70
tool palettes group 72
tool palettes set 71
tools 72, 85
tooltips 54

command tooltips 54
dialog tooltips 56
extended tooltips 54
object grip tooltips 60
object rollover tooltips 56
palette tooltips 56
property tooltips 57
solution tips 59
thumbnail previews 57
turning on and off 55

ViewCube 67

X

XML files
constructs 401
corrupted or deleted 565
elements 427
plotting sheets 482
project 310, 314, 564

xrefs
associatively dimensioning 3401

xrefs (See external references (xrefs)) 310

Z

zone boundary offset 3130
zone hatch

inheriting to spaces 3145
zone styles

arrow 3147
classifications 3142
component hatching 3144
content restrictions 3141

converting from area group
styles 3148

creating 3139
defined 3138
display properties 3142
files 3148
hatching components 3144
inheriting hatch to spaces 3145
layer, color, linetype 3142
list definitions 3140
marker size 3147
notes 3148
text style 3147

zone templates
contents 3152
converting from area group

templates 3156
creating 3151
defined 3150
files 3155
notes 3155
properties 3152

zone tools
creating 3123
zones, creating 3115

zones
attaching to zones 3127
calculation modifier styles 3132
calculation type 3131
changing style 3129
commands 3199
content restrictions 3141
content rules 3131
converting from area groups 3125
creating 3119
defined 3113
detaching from zones 3128
hyperlinks 3138
modifying 3129
multiple, with same style 3123
notes 3138
ordering structure 3133
polylines, creating 3134
properties 3116
reference files 3138
renaming 3129
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selecting attached spaces 3128
selecting attached zones 3128
specifying additional display

properties 3136
structure 3133

templates 3114, 3121
(See also zone templates) 3150

tools 3115
zone boundary offset 3130
zone templates, creating from 3121
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