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Part 1. Welcome to Autodesk
NavisWorks Freedom 2009

Autodesk NavisWorks Freedom 2009 is a free 3D viewer for NavisWorks NWD and Autodesk DWF files.
It offers an unrestricted interface for real-time navigation of even the largest 3D models complete with
textures and materials, as well as animation playback, hyperlinks and saved viewpoints.

In this documentation set you can find information on:

Installation

* Working with Freedom




Chapter 1. New Features

Autodesk NavisWorks Freedom 2009 contains a number of key enhancements for this release.

Interface Enhancements

.NET GUI Modernization
Up-to-date look and feel including new icons, improved control bar docking and tabbed control bars.
The Selection Tree Control Bar

Shows the internal structure of the loaded NWD, allowing direct navigation through the tree list to
required elements in the project.

The Properties Control Bar

Shows all properties of a selected geometry item.
TimeLiner Playback

Abitlity to play back a TimeLiner sequence.
Animation Playback

Ability to play back viewpoint and object animation.
New Editor for Global Options.

A change from complex tabs to a logical tree structure, making finding options much simpler. Also
making global options sharable across multiple PCs through import and export.

Viewable Comments

Ability to view comments recorded in NWD files.

Display Enhancements

3D Text Support

The visualization of 3D text brought into other NavisWorks products from AutoCAD and MicroStation,
and exported in the NWD.

Parametric Support

Any parametric data brought into other NavisWorks products and exported in the NWD will be
displayed in Freedom. This data increases cylinder accuracy, and dramatically reduces the memory
footprint to load and display them.

Operating System Support




New Features

e Microsoft Vista Support
Full support for Microsoft's latest operating system.
* 64-bit Support

Support for 64-bit versions of both XP and Vista.

File Formats

* Autodesk DWF support

Freedom is now capable of reading and displaying Autodesk’s DWF Design Review format.




Part 2. Installation

This section provides step-by-step installation instructions for Autodesk NavisWorks Freedom 2009. In
particular, you will learn how to:

* Prepare for installation
e Install and run NavisWorks Freedom

» Troubleshoot your installation




Chapter 2. Quick Start to Stand-Alone

Installation

This section provides step-by-step instructions about how to install Autodesk NavisWorks Freedom 2009

on your system.

How to Prepare for Installation

Before you install Autodesk NavisWorks Freedom 2009, you must review the system requirements,
understand administrative permission requirements, and close all running applications. After you
complete these tasks, you can install Autodesk NavisWorks Freedom 2009.

Before you can install Freedom, you need to download the redistributable Freedom installer package to

your computer's drive.

System Requirements

Before you install your product on a stand-alone computer, make sure that your computer meets the
minimum system requirements. See the following table for hardware and software requirements.

Hardware and software requirements

Hardware/Software

Requirement

Operating system

Windows©XP®© Professional, SP 2 (recommended)

Windows XP Home, and Professional, SP 2

Windows Vista Ultimate

Windows Vista Enterprise

Windows Vista Business

Windows Vista Home Premium

Windows Vista Home Basic

Web browser

Microsoft© Internet Explorer 6.0, SP 1 (or later)

Processor

AMD®ALthlon®©, 3.0 GHz or faster (minimum)

Intel©Pentium® |V, 3.0 GHz or faster
(recommended)

Memory (RAM)

512 MB (minimum)

2 GB or greater (recommended)

128 meg, 1024 x 768 VGA, True Color (minimum)

Display card 256 meg or greater - 1280 x 1024 32-it color video
display adapter, True Color (recommended)

Hard disk Installation 800 MB

Pointing device MS-Mouse compliant

DVD-ROM Any speed (for installation only)
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Hardware and software requirements

Open GLO©-compatible 3D video card

Printer or plotter

Optional hardware Modem or access to an Internet connection

Network interface card

How to Understand Administrative Permission Requirements

To install Autodesk NavisWorks Freedom 2009, you must have administrator permissions. You do not
need to have domain administrative permissions. See your system administrator for information about
administrative permissions.

To run Autodesk NavisWorks Freedom 2009, you do not need administrator permissions. You can run the
program as a limited user.

How to Install and Run NavisWorks Freedom

This section contains information for installing NavisWorks Freedom on a stand-alone computer. You
must have administrative permissions to install NaviswWorks.

To install Freedom:

1. Double-click the downloaded Freedom installer package.

2. Choose the folder in which Freedom will be installed. The default location is displayed in the
Destination Folder field. You can change the location by clicking the Browse button, and selecting
a new location in the Browse for Folder dialog.

3. Click the Install button.

When all necessary files have been extracted, the Autodesk NavisWorks Freedom 2009 Installation
wizard automatically launches in the language that best matches the settings on your computer.

4. In the Installation wizard, click Install Products.
5. Select the product you want to install and click Next.
6. Review the Autodesk software license agreement for your country or region. You must accept this

agreement to proceed with the installation. Choose your country or region, click | Accept, and then
click Next.

Note:

If you do not agree to the terms of the license and want to terminate the installation, click Cancel.

7. Onthe Product and User Information page, enter the required information and click Next.

The information you enter here is permanent and is displayed in the Autodesk NavisWorks Freedom
2009 window (accessed by Help > About) on your computer. Because you can't change this
information later without uninstalling the product, make sure you enter the correct information now.




Quick Start to Stand-Alone Installation

8. Onthe Begin Installation page, click Install to begin installation.

9. Onthe Installation Complete page, select View the Autodesk NavisWorks Freedom 2009 Readme if
you want to launch the Autodesk NavisWorks Freedom 2009 Help system.

10. Click Finish.

Running Freedom

Assuming that you've followed the steps in the previous procedure, you can launch NavisWorks and start
taking advantage of its new and updated features.

You can start NavisWorks in the following ways:
» Desktop shortcut icon. When you install NavisWorks Freedom, a Freedom shortcut icon is placed on
your desktop. Double-click the Freedom icon to start Freedom.

» Start menu. On the Start menu, click Programs (Windows XP) or All Programs (Windows Vista)
Autodesk > Autodesk NavisWorks Freedom 2009 > Autodesk NavisWorks Freedom 2009.

How to Launch NavisWorks in Another Language

To run NavisWorks in another of the supported languages, you need to add one of the language selector
arguments to the desktop shortcut.

1. Right-click the NavisWorks desktop shortcut, and click Properties on the shortcut menu to open the
NavisWorks Properties dialog box.

2. Onthe Shortcut tab, enter a space in the Target field after .\roamer.exe", and then enter one of the
following arguments:

-lang enu Enter this for English localization

-lang deu Enter this for German localization

-lang jpn Enter this for Japanese localization
-lang rus Enter this for Russian localization

-lang chs Enter this for Chinese (PRC) localization

3. Click OK to save the changes.

Reinstall or Repair Autodesk NavisWorks Freedom 2009

If you accidentally delete or alter files that are required by NavisWorks Freedom, Freedom might not
perform correctly, and you might receive error messages when you try to execute a command or find a
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file. You can attempt to fix this problem by reinstalling or repairing NavisWorks Freedom. The
reinstallation or repair uses the features that were part of the installation type you chose when you initially
installed the program.

To reinstall or repair NavisWorks Freedom:

1. Inthe Control Panel, double-click Add or Remove Programs.

2. Inthe Add or Remove Programs dialog box, click Autodesk NavisWorks Freedom 2009, and then
click Change/Remove in Windows XP or Uninstall/Change in Vista.

The Autodesk NavisWorks Freedom 2009 Installation wizard re-opens in Maintenance Mode.
3. Click Repair Autodesk NavisWorks Freedom 2009.
4. On the Select Repair or Reinstall page, click one of the following, and then click Next:
e Repair My Autodesk NavisWorks Freedom 2009 Installation. This option replaces all registry

entries that NavisWorks initially installed and restores Autodesk NavisWorks Freedom 2009 to its
default state.

« Reinstall My Autodesk NavisWorks Freedom 2009 Installation. This option repairs the registry
and reinstalls all files from the original installation. Use this option if the Repair My Autodesk
NavisWorks Freedom 2009 Installation option does not solve the problem.

5. On the Repair Autodesk NavisWorks Freedom 2009 page, click Next to start the process.

6. On the Repair Complete page, you are informed when the repairs have been performed. Click Finish.

Uninstall Autodesk NavisWorks Freedom 2009

When you uninstall Autodesk NavisWorks Freedom 2009, all components are removed. This means that
even if you've previously added or removed components, or if you've reinstalled or repaired Autodesk
NavisWorks Freedom 2009, the uninstall removes all NavisWorks installation files from your system.

To uninstall Autodesk NavisWorks Freedom 2009:

1. Inthe Control Panel, double-click Add or Remove Programs.

2. Inthe Add or Remove Programs dialog box, click Autodesk NavisWorks Freedom 2009, and then
click Change/Remove in Windows XP or Uninstall/Change in Vista.

The Autodesk NavisWorks Freedom 2009 Installation wizard re-opens in Maintenance Mode.
3. Click Uninstall.

4. On the Uninstall Autodesk NavisWorks Freedom 2009 page, click Next to remove NavisWorks from
the system.
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5. When informed that the product has been successfully uninstalled, click Finish.




Chapter 3. Installation Troubleshooting

This section outlines common issues and their solutions that may arise while performing a general
installation of your product.

What are the minimum system requirements?

Before you install your product on a stand-alone computer, make sure that your computer meets the
minimum system requirements.

Hardware and software requirements

Hardware/Software Requirement

Windows©XP®© Professional, SP 2 (recommended)

Windows XP Home, and Professional, SP 2

Windows Vista Ultimate

Operating system Windows Vista Enterprise

Windows Vista Business

Windows Vista Home Premium

Windows Vista Home Basic

Web browser Microsoft© Internet Explorer 6.0, SP 1 (or later)
AMD®ALthlon®©, 3.0 GHz or faster (minimum)

Processor Intel©Pentium® IV, 3.0 GHz or faster
(recommended)
512 MB (minimum)

Memory (RAM) 2 GB or greater (recommended)
128 meg, 1024 x 768 VGA, True Color (minimum)

Display card 256 meg or greater - 1280 x 1024 32-it color video
display adapter, True Color (recommended)

Hard disk Installation 800 MB

Pointing device MS-Mouse compliant

DVD-ROM Any speed (for installation only)

Open GLO©-compatible 3D video card

Printer or plotter

Optional hardware Modem or access to an Internet connection

Network interface card

How can | check my graphics card driver to see if it needs
to be updated?

It is recommended that you verify and update your graphics card driver to optimize your program. Use the
following procedure to identify your current graphics card driver.

10



Installation Troubleshooting

To identify your graphics card driver:

1. Start Autodesk NavisWorks Freedom 2009.
2. Click Help > System Info.
The Autodesk NavisWorks Freedom 2009 information dialog box opens.

3. Review the information about your system including the graphics card driver and driver version, and
click OK to close the dialog.

Where are my product manuals?

All documentation created for Autodesk products are built in two different formats: PDF and CHM.

CHM files are made available during installation; click the Documentation link in the Installation wizard. To
access CHM files after the product is installed, use the Help system in the product.

PDF files are available after the product is installed; they are located in the \ Aut odesk Navi sWor ks
Freedom 2009\ Manual s folder.

CHM files are installed to the \ Aut odesk Navi sWor ks Fr eedom 2009 folder.

Maintenance Issues

This section outlines common issues and their solutions with regards to adding and removing features,
reinstalling or repairing your installation, and uninstalling products.

Is it possible to change the installation folder when adding or
removing features?

Once your product is installed, you cannot change the installation path from the Add/Remove Features
page. Changing the path while adding features results in program corruption, so it is not an option.

When should I reinstall the product instead of a repair?
You should reinstall your product if you accidentally delete or alter files that are required by the program.

Missing or altered files adversely affect the performance of your product and cause error messages when
you try to execute a command or find a file.

If an attempt to repair an installation fails, reinstalling is the next best option.
Do | need my original disk to reinstall my software?

When performing a reinstall of the product, you do not need to have the original DVD on hand. Installation
data is cached locally on your drive and that data is reused when reinstalling.

When | uninstall my software, what files are left on my system?

11



Installation Troubleshooting

If you uninstall the product, some files remain on your system such as files you created or edited.

Your license file also stays on your workstation when you uninstall your product. If you reinstall on the
same workstation, the license information remains valid and you do not have to reactivate the product.

12



Part 3. Working with Freedom

Freedom enables you to explore project models without specialist design software or specialist skills. In
this section, you will learn how to:

Manage files
» Use Freedom tools

Use TimeLiner playback tools




Chapter 4. Overview

The basis of Autodesk NavisWorks Freedom 2009 is its ability to walk through any size model in real
time. NavisWorks guarantees a user-defined frame rate using a unique algorithm which automatically
calculates which items to render first during navigation, based on the size of items and distance from the
viewpoint. ltems which NavisWorks does not have time to render are, therefore, sacrificed or "dropped
out" in the name of interactivity. These items are, of course, rendered when navigation ceases. The
amount of drop-out depends on several factors including: hardware (in particular graphics card and driver
performance), as well as the size of the NavisWorks navigation window and the size of the model. If you
wish to reduce drop-out during navigation, you have the option to reduce frame rate and, therefore, trade
it off against drop-out.

When working with truely large "supermodels" in NavisWorks, you will require a sufficient amount of RAM
to load and review the data. NavisWorks employs JetStream technology which optimizes the usage of the
available RAM. Before running out of memory, NavisWorks will page unnecesary data to the hard disk,
freeing up space for loading to continue. JetStream technology also enables the user to commence
navigating the supermodel, before it has completely loaded into memory.

NavisWorks is large address aware, utilizing any additional memory assignment following the 3GB switch
available on Windows XP systems.

To start NavisWorks, double-click the NavisWorks icon on the desktop, or go to Start > Programs >
Autodesk > Autodesk NavisWorks Freedom 2009 > Autodesk NavisWorks Freedom 2009. The
following sections will describe the interface in more detail.

NavisWorks contains full context-sensitive Help. Click @ , and click the toolbar button or menu option

to display the appropriate Help topic. Or, alternatively, go to the Help menu.

14



Chapter 5. File Management

To manage files, you can use both the File menu and the Standard toolbar.

IR ).

File Menu

The File menu includes the following items:

* New

* Open
 Open URL
e Print

e Print Preview
» Print Setup
* Recent Files

o EXxit

New Files

This option resets NavisWorks and closes existing files.

To create a new file:
e On the File menu, click New

or

* Click New D on the Standard toolbar.

Opening Files

With Autodesk NavisWorks Freedom 2009 you can open .nwd (published NavisWorks Data) and .dwf
files.

To open a model file:

e On the File menu, click Open

15



File Management

or

* Click Open |:—:'7 on the Standard toolbar.

Note:

The standard Open dialog use of Shift and Control keys allows multiple files to be selected and
appended to the current set of models.

Opening Files via URL
With Autodesk NavisWorks Freedom 2009 you can open NavisWorks published .nwd files via the
Internet. Having uploaded your .nwd file to a web server, this file can then be opened directly from within
NavisWorks. Utilizing JetStream technology, it will not be necessary for the entire file to be downloaded
before navigation can commence - between 10% and 50% will be sufficient for this, depending on the file
structure. (The greater the hierarchical structure of the model, the closer to 50% will be required for
navigation to commence. Similarly, the lesser the hierarchical structure of the model, the closer to 10%
will be required).

To open a file via a URL:
* On the File menu, click Open URL.
Printing
You can print a hard copy of the current viewpoint to any printer or plotter.

Printing the Current Viewpoint

When the print option is selected, it prints the current viewpoint scaled to fit and centered on the page.

Printing the current viewpoint:

1. On the File menu, click Print

or

Click Print é on the Standard toolbar.

2. Check the printer settings are as required, and click OK to print the viewpoint or Cancel to return to
NavisWorks without printing anything.

Note:

16



File Management

The maximum image size is 2048x2048 pixels.

The Properties button controls printer-specific ink and paper settings.

Previewing Printouts

Before you print out a copy of the model you are working on, you may wish to see how it will appear.

Previewing a model before printing:

1. On the File menu, click Print Preview.
2. Use Zoom In and Zoom Out to do just that with the preview image.

3. Click Print, OK to confirm and print the image, or click Close to return to Navisworks.

Setting up printouts

This option enables the setting up of paper size and orientation options.

Changing the print setup:

1. On the File menu, click Print Setup.
The Print Setup dialog box is displayed.

2. Make changes as required to the paper, orientation, and click the Properties button to change
printer-specific settings.

3. Click OK to print the image, or click Cancel to return to NavisWorks.

Quitting NavisWorks

Quitting NavisWorks:

. On the File menu, click Exit

17



Chapter 6. Converting Files

With Autodesk NavisWorks Freedom 2009 you can open .nwd (published NavisWorks Data) and .dwf
files.

File Readers

e« .nwd
o .dwf
NWD Files

.nwd files are files published by NavisWorks Publisher and are snapshots of the model at a certain time.

DWF Files

Autodesk's DWF (Design Web Format) was specifically developed by Autodesk as a file format for
architects, engineers, and GIS professionals to share design data. The NavisWorks file reader reads all
3D geometry, as well as textures and properties. A full list is given below.

Supported Entities

» All 3D geometry

» Texture coordinates

» Colors (per-vertex, per-face)
e Property fields

» Categories

Unsupported Entities

» 2D lines/plot sections

*  Thumbnails

» Marked-up sketches

» More than one 3D section per file (any others are ignored)
* NURBS Surfaces

e« Cameras

DWF File Reader Options
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Setting the .dwf file reader options:

1. Onthe Tools menu, click Global Options.

2. Expand the File Readers node in the Options Editor dialog box, and click the DWF option.

The DWF page is displayed.

Options Editor

General Faceting Factor |1 |
Model

Interface Max Facet Deviation {m;) |IZI.EIEI |
- Fle Readers Extract bextures

[+

Defaulks

Export... H Import... ] l Ok H Cancel H Help ]

3. Enter the Faceting Factor (the value must be greater than 0). The higher the value, the more
NavisWorks will facet rounded entities and therefore the smoother they will appear. See Faceting
Factor for more information.

4. Enter the Max Facet Deviation. This will facet entities to within the specified tolerance. See Max
Facet Deviation for more information.

5. Click OK to set these options or Cancel to exit the dialog without setting them.
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Chapter 7. Navigating

NavisWorks enables intuitive and interactive navigation around your 3D models at a guaranteed frame
rate. The nine navigation modes give you complete flexibility to navigate around the model in real time. In
addition to these navigation modes, there are selection and measuring tools that further facilitate the
interrogation of model data.

The navigation tools allow you to do things such as focus on objects and change the view parameters.
There are also options to look from predefined views, set the world up vector to a direction different than
the one brought through from the CAD model.

Navigation Modes

There are nine navigation modes to control how you move around the main navigation view - six
camera-centric modes and three model-centric modes. In a camera-centric mode, the camera moves
within the scene, whereas in a model-centric mode, model moves inside the scene. For example, the
Orbit and Examine modes essentially do the same thing, except that Orbit moves the camera around
the focal point and Examine moves the model around the focal point. Movement in each mode is based
on the cursor keys, the Shift and Control keys and mouse drags. The mouse wheel is also supported,
allowing quick and easy zooming or tilting, depending on the current navigation mode.

Note:

Dragging with the left mouse button while holding down the Control key performs the same
actions as dragging with the middle mouse button, which is useful if you only have a two-button
mouse.

The Shift and Control keys modify the movement, for example holding down Shift in Walk mode speeds
up movement, and holding down Control in this mode, glides the camera left/right and up/down.

Note:

Gliding the camera is opposite to panning the model. Gliding is a camera-centric motion and
panning is a model-centric motion.

Below is shown the Navigation Mode toolbar and the navigation modes available:

Fla s ene

nnmn
o

b

Walk [

Look Around n

Zoom l:l\
Zoom Box ':'\
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Pan [+

Orbit

Examine

Fly [r-
¥

Turntable @

Walking

Walk mode enables you to walk through the model on a horizontal plane ensuring that "up” is always
"up”.
To walk through a model:

* On the Viewpoint menu, click Navigation Mode > Walk

or

* Click Walk on the Navigation Mode toolbar.

ni

Dragging the left mouse button, or using the cursor keys, spins the camera left and right and moves it
forwards and backwards.

Holding down the Shift key speeds up this movement.

Holding down the Control key glides the camera left and right and up and down. As walk mode is
camera-centric, this mode differs from the normal pan mode in that the camera is moved rather than the
model.

Spinning the mouse wheel tilts the camera up and down.

Looking Around

Look around mode enables you to look around the model from the current camera position and gives the
effect that you are moving your head around.

To look around a model:

* On the Viewpoint menu, click Navigation Mode > Look Around

or
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e Click Look Around [ | on the Navigation Mode toolbar.

Dragging the left mouse button, or using the cursor keys, looks left, right, up or down.
Holding down the Shift key speeds up this movement.

Holding down the Control key rotates the camera around its viewing axis.

Zooming

Zoom mode enables you to zoom into and out of the model. Cursor up zooms in and cursor down zooms
out.
To zoom:

* Onthe Viewpoint menu, click Navigation Mode > Zoom

or

» Click Zoom Cl\ on the Navigation Mode toolbar.

Dragging the left mouse button up and down, or using the up and down cursor keys, zooms in and out
respectively.

Zooming to a Box

The zoom-to-a-box mode enables you to drag a box so that the contents of the box fill the view.

To use the zoom box:
e Onthe Viewpoint menu, click Navigation Mode > Zoom Box

or

* Click the Zoom Box Q\ on the Navigation Mode toolbar.

Dragging a box with the left mouse button over the main navigation view fills the view with the contents of
the box.

Holding down the Shift or Control keys, or spinning the mouse wheel, temporarily puts this mode into
normal Zoom mode.

Panning

The pan mode enables you to pan the model rather than the camera.
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To pan a model:

* Onthe Viewpoint menu, click Navigation Mode > Pan

or

e Click Pan [, ] on the Navigation Mode toolbar.

Dragging the left mouse button pans the model up, down, left and right.

Holding down the Shift or Control keys, or spinning the mouse wheel, temporarily puts this mode into
normal Zoom mode.

Orbiting
The orbit mode enables you to orbit the camera around the model, ensuring that "up" is always "up". The
camera always orbits around the focal point of the model.
To orbit a model:

* On the Viewpoint menu, click Navigation Mode > Orbit

or

» Click Orbit A on the Navigation Mode toolbar.

i<

Dragging the left mouse button, or using the cursor keys, rotates the camera around the model.

Holding down the Shift key or spinning the mouse wheel, temporarily puts this mode into normal Zoom
mode.

Holding down the Control key glides the camera left and right and up and down. As orbit mode is
camera-centric, this mode differs from the normal pan mode in that the camera is moved rather than the
model.

Examining

The examine mode enables you to rotate the model about.

To examine a model:
* Onthe Viewpoint menu, click Navigation Mode > Examine

or
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e Click Examine on the Navigation Mode toolbar.

®,

Dragging the left mouse button, or using the cursor keys, rotates the model about.

Holding down the Shift key or spinning the mouse wheel, temporarily puts this mode into normal Zoom
mode.

Holding down the Control key, temporarily puts this mode into normal Pan mode.

If the mouse is moving when you let go of the button, the model keeps spinning! Click on it to stop.
Holding the Shift key allows you to zoom in and out.

Flying
The fly mode enables you to fly around the model like in a flight simulator.

To fly through a model:
* Onthe Viewpoint menu, click Navigation Mode > Fly

or

* Click Fly on the Navigation Mode toolbar.

II _}.,I:'

Holding down the left mouse button moves the camera forward. As in a flight simulator, the left mouse
button banks left/right when dragged left or right and tilts up/down when dragged up or down.

The up and down cursor keys will zoom in and out respectively and the left and right cursor keys will spin
the camera left and right respectively.

Holding down the Shift key speeds up this movement.
Holding down the Control key rotates the camera around its viewing axis, while still moving forward.

Spinning on a Turntable

The turntable mode enables you to spin the model around the up vector. This navigation mode behaves
as though the model is sitting on a turntable, ensuring that "up" is always "up".
To use the turntable:

* On the Viewpoint menu, click Navigation Mode > Turntable

or

e Click Turntable E on the Navigation Mode toolbar.
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Dragging the left mouse button left and right, or using the left and right cursor keys, spins the turntable left
and right respectively.

Holding down the Shift key or spinning the mouse wheel, temporarily puts this mode into normal Zoom
mode.

Holding down the Control key, temporarily puts this mode into normal Pan mode.

Spinning the mouse wheel, or using the up and down cursor keys, tilts the turntable up and down, like the
tilt bar.

Navigation Tools

Navigational tools are a number of handy tools for altering, resetting or changing the type of the camera,
and the viewpoint displayed. These tools can be accessed from the Viewpoint > Navigation Tools
menu, or from the Navigation Tools toolbar:

o LG P|Podied 3@ |BR%H

Navigation Tools comprises the following functions:

View All

iy

View Selected [ —

Focus ﬁ'

Perspective Camera k/l

Orthographic Camera [

Collision Detection

Gravity

22,

=

Third Person fﬁ]ﬁ

Crouch

Align With X-Axis L'E

Align With Y-Axis ‘Eﬁ
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h
Viewing Everything

This function dollies and pans the camera so that the entire model is in view, which is very useful if you
get lost inside a model or lose it completely.

Sometimes on doing a View All, you seem to just get a blank view. This is usually because there are
items that are very small in comparison to the main model located a long way away from the main model.
In these cases, it is best to click on an item in the selection tree and do a View Selected to at least find
your way back to the model before trying to figure out which items are "lost".

To view everything:

* Onthe Viewpoint menu, click Navigation Tools > View All.

or

e Click View All -0 on the Navigation Tools toolbar.

Viewing Selected Items

This function zooms the camera so that the selected item fills the main navigation view.

To view a selected item:
» Onthe Viewpoint menu, click Navigation Tools > View Selected

or

» Click View Selected on the Navigation Tools toolbar.

Focusing

This function puts the main navigation view into focus mode until the next click. Left-click on an item and
the view swivels so that the point clicked is in the center of the view. The point clicked becomes the focal
point for examine, orbit, turntable navigation modes.

To focus the camera:

» Onthe Viewpoint menu, click Navigation Tools > Focus

or
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e Click Focus @. on the Navigation Tools toolbar

Perspective Camera

Uses a perspective camera to view with.

To select a perspective camera:
e Onthe Viewpoint menu, click Navigation Tools > Perspective Camera

or

* Click Perspective on the Navigation Tools toolbar.

L

Orthographic Camera

Uses an orthographic camera to view with.

To select an orthographic camera:
e Onthe Viewpoint menu, click Navigation Tools > Orthographic Camera

or

» Click Orthographic on the Navigation Tools toolbar.

Note:

Orthographic cameras are not available with Walk and Fly navigation modes.

Collision Detection

This function defines you as a collision volume - a 3D object that can navigate around and interact with
the model, obeying certain physical rules that confine you within the model itself. In other words, you have
a mass and as such, cannot pass through other objects, points or lines in the scene.

You can walk over, or climb over objects in the scene that are up to half the height of the collision volume,
thus allowing you to walk up stairs, for example.

The collision volume, in its basic form, is a sphere (with radius = r), that can be extruded to give it height
(with height = h >=r). See diagram below:
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Collision detection is only available when in either the walk or fly navigation mode.

To activate collision detection:

* In Walk or Fly navigation mode, on the Viewpoint menu, click Navigation Tools > Collision
Detection

or

» Click Collision Detection [ = | on the Navigation Tools toolbar.

]

or

e Press D to toggle collision detection on/off.

Note:

When Collision Detection is turned on, rendering prioritization is changed so that objects around
the camera or avatar are displayed with much higher detail than normal. The size of the region of
high detail is based on collision volume radius and speed of movement (needing to see what is
about to be walked into).
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Gravity

This function only works in connection with collision detection.

Where collision detection gives you mass, gravity gives you weight. As such, you (as the collision volume)
will be pulled downwards whilst walking through the model scene (gravity is only available when in the
walk navigation mode).

This allows you to walk down stairs, for example, or follow terrain.

To activate gravity:
* In the Walk navigation mode, on the Viewpoint menu, click Navigation Tools > Gravity

or

e Click Gravity on the Navigation Tools toolbar.

or

» Press G to toggle gravity on/off.

Crouching

This function only works in connection with collision detection.

When walking around the model with collision detection activated, you may encounter object that are too
low to walk under, a low pipe for example. This function enables you to crouch under any such objects.

With crouching activated, you will automatically crouch under any objects that you cannot walk under at
your specified height, thereby not impeding your navigation around the model.

If however, you are using collision detection to identify areas of the model that you cannot walk under,
(again, using a low pipe for example) then there is also a temporary crouch function to allow navigation to
proceed once the obstacle has been identified.

To activate crouching:
* In Walk or Fly navigation mode, on the Viewpoint menu, click Navigation Tools > Crouch

or

e Click Crouch on the Navigation Tools toolbar.

=

or, if you only want to temporarily crouch
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» Hold down the Space bar to turn crouching on. Releasing it will turn it off again.

Third Person View

This function allows you to view from a third person perspective.

When third person is activated, you will be able to see an avatar which is a representation of yourself
within the 3D model. Whilst navigating you will be controlling the avatar's interaction with the current
scene.

Using third person in connection with collision detection and gravity makes this a very powerful function,
allowing you to visualize exactly how a person would interact with the intended design.
To view in third person:

* On the Viewpoint menu, click Navigation Tools > Third Person

or

e Click Third Person cﬁu on the Navigation Tools toolbar.

or

* Press T to toggle third person view on/off.

Note:

When Third Person mode is turned on, rendering prioritization is changed so that objects around
the camera or avatar are displayed with much higher detail than normal. The size of the region of
high detail is based on collision volume radius, speed of movement (needing to see what is about
to be walked into) and the distance of the camera behind the avatar (in order to see what the
avatar is interacting with).

Preset Viewpoints

The orthogonal viewpoints are preset inside NavisWorks and can be accessed from the Navigation
Tools toolbar and the Viewpoints menu.

Aligning With The X-Axis
This function toggles between Look From, Front and Look From, Back views.

To align the viewpoint with the x-axis:
* On the Viewpoint menu, click Navigation Tools > Align X

or
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e Click Align X Eé! on the Navigation Tools toolbar.

Aligning With The Y-Axis
This function toggles between Look From, Left and Look From, Right views.

To align the viewpoint with the y-axis:
* Onthe Viewpoint menu, click Navigation Tools > Align Y

or

e Click Align Y fﬁ on the Navigation Tools toolbar.

Aligning With The Z-Axis
This function toggles between Look From, Top and Look From, Bottom views.

To align the viewpoint with the z-axis:
» On the Viewpoint menu, click Navigation Tools > Align Z

or

* Click Align z E on the Navigation Tools toolbar.

Looking From a Preset Viewpoint

When this option is chosen the model is displayed from this viewpoint in the main navigation view. This is
equivalent to toggling the Align X, Align Y and Align Z buttons on the Navigation Tools toolbar.

Looking from a preset viewpoint:

1. Onthe Viewpoint menu, click Look From.

2. Choose any direction from Top, Bottom, Front, Left, Back and Right.

Straighten

This function straightens the camera to align with the world up vector when it is already close to the world
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up vector.

To straighten the camera:

* On the Viewpoint menu, click Navigation Tools > Straighten

Set World Up

These functions set the world up vector to align with the selected orientation.

To set the world up vector to the current view:
* Onthe Viewpoint menu, click Set World Up > Current View.
Alternatively, to set the world up vector to one of the orthogonal axes:

* On the Viewpoint menu, click Set World Up and choose one of the pre-defined axes (+X Axis, -X
AXxis, +Y Axis, -Y Axis, +Z Axis, or -Z Axis).

Using a SpaceBall

Note:

The term SpaceBall is used as a generic term for all 3D motion controllers from 3Dconnexion™,
including the SpaceBall, SpaceMouse and SpaceTraveler.

A SpaceBall can be used as an alternative to the mouse to move around the main navigation view. The
behavior of the SpaceBall corresponds to the currently selected Navigation Mode. If no mode is selected
on the Navigation Mode toolbar or if the selected mode is not a valid mode for the SpaceBall, then a
default navigation mode will be used. This enables the user to navigate with the SpaceBall whilst
performing other operations with the mouse. The default navigation mode can be set in the Options Editor
dialog box.

The speed of navigation is sensitive to the amount of force applied to the SpaceBall. However, the user
can also adjust the speed of translation and rotation by applying a factor to each of these in the Options

Editor dialog box. These options are offered in addition to the adjustments that can be made using the
Control Panel for the device which is supplied by the SpaceBall manufacturer with the installation.

Setting the SpaceBall behavior:

1. Onthe Tools menu, click Global Options.
2. Expand the Interface node in the Options Editor dialog box, and click the SpaceBall option.

The SpaceBall page is displayed.
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Options Editor

General

Model

=) Inkerface Scale rokation bey: |1 |
Displary Uniks
Selection
Measure
Snapping
Viewpaoint Defaulks

Hypetlinks

SrnartTags
Developer
Display

Scale translation by |1

havigation mode: |Last Selected L |

SpaceBall
File Readers
Tools

Defaulks

[ Expart. .. H Import. .. ] [ (0] 4 H Cancel H Help ]

Modify the Scale translation value if you want to increase or decrease the speed of translation.
Modify the Scale rotation value if you want to increase or decrease the speed of rotation.

Select the Default navigation mode from the drop-down list. This will be used when no valid
navigation mode is currently selected.
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Chapter 8. Selecting Items

With large models it is potentially a very time-consuming process to select items of interest. NavisWorks
makes this a much simpler task by providing a range of functions for quickly selecting items both
interactively and by searching the model manually and automatically. The main groups of functionality
concerned with selecting items are:

» The selection tree

* Interactive selection

In NavisWorks there is the concept of an active selection set (the currently selected items, or the current

selection) and saved selections sets. You cannot save any selection or search sets yourself, but you can
use the selection or search sets saved in the model.

Below is shown the Selection Tools toolbar and the selection modes available:

s sl

Select [
ot

In addition to the selection modes, you can also use three editing options on the Selection Tools toolbar.
See Chapter 10, Editing for more information on the editing tools.

Selection Trees

The selection tree is a tabbed control bar which displays a variety of hierarchical views of the structure of
the model, as defined by the CAD application in which the model was created.

34



Selecting Items

Selection Tree & X

£

Standard | Compack || Properties || Sets

EI Meadowgate - Site.nwd

=3 6005q Paving Slabs - Footpaths
(71 30 Face Sek

*:= Buff Block Paving - Bay Markers

# 3 Buff Block Paving - Internal Roads

# & Buildings

# 3 Charcoal Block Paving - Parking Bays

*3 Cobbles

#& Concrete - Ground slab

* & Concrete - Ground walls

# 3 Concrete - Upper slab

#& Concrete - Upper walls

*:= DBM - Roads

* & Ground

# & HRA - Roads

*& Kerbs - Granite Setts

® 3 Runway

® & Traffic Island

® 2 White lines

By default there are four tabs, called Standard, Compact, Properties and Sets:

"Standard" displays the default tree hierarchy, including all instancing.
"Compact" displays a simplified version of the "Standard" hierarchy, omitting various items. You can
control the level of complexity of this tree using the Select options (see * Selection Options ” for more
information).

"Properties” displays the hierarchy based on the items' properties. This enables simple manual
searching of the model by item property.

"Sets" shows selection and search sets saved with the model, if applicable.

Naming of items reflects the names from the original CAD application, wherever possible.
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There are several different tree icons representing the types of item that make up the structure of a
model:

A model, such as a drawing file or design file.

i A layer or level.

ggl A group, such as a block definition from AutoCAD or cell definition from MicroStation.

% An instanced group, such as an inserted block from AutoCAD or cell from MicroStation. If in the
imported file the instance was unnamed, NavisWorks names the instance to match its child's name.

(51 An item of geometry, such as a polygon.

é’a An instanced item of geometry, such as an instance from 3D Studio.

ggl A composite object. A single CAD object that is represented in NavisWorks by a group of geometry
items.

ﬂ A search. Behind the scenes, NavisWorks is searching the model for all items with a property of this

type and sets up the find specification to repeat this search if the selection set is saved. See “ Selection
and Search Sets ” for more information on this.

Each of these item types can be Hidden (gray), Unhidden (dark blue) or Required (red).

Note:

If a group is selected as Hidden or Required then all instances of that item will be hidden or
required. If you wish to operate on a single occurrence of an item then you should make the
instanced group (the level above, or the "parent”, in the hierarchy) Hidden or Required.

You can use the selection tree in combination with the main navigation window to select items into the
current selection, which is highlighted in both the selection tree and the main navigation window.

Note:

Using the Shift and Control keys while selecting items in a selection tree will do the standard
Windows™ multiple selection: Control allows multiple selection item by item and Shift allows
multiple selection between the first and last items selected.

Interactive Selection

NavisWorks provides several methods to interactively select items into the current selection. You can use
the tabs in the selection tree, select items in the main navigation window with select mode, and you can
select other items with similar properties to an existing selection using the selection commands.

Note:

Presing Esc deselects everything.

Select Mode
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As standard, this mode is mutually exclusive to the navigation modes so that when you are selecting, you
cannot navigate and vice versa.

Note:

When using a SpaceBall in conjunction with the standard mouse control, the SpaceBall can be
configured for navigation and the mouse for selecting. See “ Using a SpaceBall ” for more
information.

Select mode allows you to click on an item in the main navigation window to select it. Once a single item
is selected, its properties will be shown in the Properties control bar.

You can select multiple items in the main navigation window using the familiar Windows™ methods of
holding down the Control key while selecting items. This will add them to the current selection.

Alternatively, if the items are already in the current selection, holding down Control while selecting them
again will remove them from the current selection.

Holding the Shift key whilst selecting items in the main navigation window will cycle through the selection
resolution, allowing you to get more specific with your selections. See Selection Resolution for more
information on this.

To select an item:

* On the Edit menu, click Select > Select

or

* Click Select on the Selection Tools toolbar.

i

Selection Commands

Selection commands enable you to quickly alter the current selection using logic. You can select multiple
items based on the currently selected items' properties, or quickly invert the set, select everything or
nothing.

Selecting items with selection commands:

1. On the Edit menu, click Select.
2. Choose the required selection command.
Standard selections are:

» Select All

All items contained within the model are selected.
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» Select None

Deselects everything in the model.
* Invert Selection

Every selected item becomes deselected and vice versa.
» Select Multiple Instances

Selecting an item then selecting Multiple Instances will select all instances (sometimes called
insertions) of that geometry group that occur in the model.

» Select Same Name
Every item with the same name as the selected item will also be selected.
» Select Same Type

Every item of the same type as the selected item will also be selected.

Selection and Search Sets

Selection sets store a group of items for later retrieval. There is no intelligence behind this set - if the
model changes at all, the same items will be selected (assuming they are still available in the model)
when recalling the selection set.

Search sets work in a similar way, except that they save search criteria instead of the results of a
selection. So, if there are any search sets saved in the model, then you use them in Freedom to run the
search and select the resulting objects.

Selection and search sets can be named and contain comments. They can also be highlighted with icons
in the main navigation window, so that when you click on one, the selection set is restored to the active
set and all the items within it are re-selected.

Recalling Selection and Search Sets

To re-select items from a selection set:

* On the Selection Tree, click the Sets tab, and click the saved selection or search set from the list.

Note:

On recalling a selection set, all the items that were selected when the set was saved are
re-selected into the current selection.

On recalling a search set, the search that was saved into the set is re-run and any items matching
the specification are selected into the current selection.

Selection Resolution

Selection resolution affects what geometry you select when selecting items in the main navigation window
using Select mode.
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When you click on an item in Select mode, NavisWorks doesn't know what level of item to start selecting
at - do you mean the whole model, or the layer, or the instance, or group, or just the geometry? The
selection resolution tells NavisWorks what level in the selection tree to start selecting items at by default.

The options are:

*  Model
Selects the whole model.
* Layer
Selects all items on a layer.
» First Object
Selects the first item in the selection tree path that isn't a layer.
e Last Unique

Selects the most specific item (furthest along the selection tree path) that is unique (not multiply
instanced).

e Last Object
Selects the most specific item (furthest along the selection tree path) that is marked as a composite
object. If no composite object is found, the geometry is selected. This is the Default selection
resolution setting.
* Geometry
Selects the last item in the selection tree path (most specific, but may be multiply instanced).
If you find you have selected the wrong level of item, you can interactively "cycle" through the selection
resolution, without having to go to the options dialog or the selection tree. You do this by holding down
the Shift key when selecting an item. This selects an item one level more specific each time you select
the item until the resolution gets to "geometry"”, at which point it will revert back to "model". The selection
resolution remains as set in options for the next selection.

You can set the default selection resolution on the Selection page in the Options Editor.

Selection Options

Use the Selection options to configure how you select items in the NavisWorks scene. You can set the
level at which you select items (selection resolution), the distance from an item you have to be for it to be
selected (useful for lines and points) and also the color in which selected items are displayed.

Setting selection options:

1. Onthe Tools menu, click Global Options.

2. Expand the Interface node in the Options Editor dialog box, and click the Selection option.
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The Selection page is displayed.

Options Editor

General Pick Radius |1 %
Miodel
= Inkerface Resolution | Last Object
Display Units
Measure Highlight
Snapping
W
Viewpoint Defaulks Enabled
Hyperlinks Method |Shaded
SmartTags
Developer Color E]
Displary

SpaceBall I:l

File Readers Tink Level (%]

Tools
Expott. .. H Impatt. .. ] [ (0] 4 H Cancel H Help ]

To set the color that selected items are displayed in, click the Color button. The default highlight
color is blue. Alternatively, clear the Enabled check box to disable selected item highlighting (items
won't change color when selected).

In the Pick Radius box, enter the radius, in pixels, that an item has to be within in order for it to be
selected.

In the Resolution box, choose the level of selection that you wish to use as the default, see selection
resolution.

In the Compact Tree box, choose what level of detail you wish to see in the selection tree. Models
will restrict the tree to just displaying model files, Layers will restrict it down to the layer level and
Objects will show a similar tree to the Standard tree, but without the levels of instancing inserted
above an inserted block.

Click OK to set the options or Cancel to exit the dialog box without setting them.
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You can run simple manual searches of the model by item property. To do this:

* Onthe Selection Tree, click the Properties tab, and click the saved property search in the list.

The corresponding model geometry is selected in the main Freedom window.

Properties

The Properties control bar shows all the properties of a selected item. Properties are categorized into
categories such as Item and Material and this control bar has a tab for each property category of the

selected item. Whenever a single item is selected, this control bar will be updated to show the properties
of that item.

Note:

If more than one item is selected the Properties bar will only show the number of items selected
and won't show any property information.

The Properties control bar looks like this:

Propetties JL° 4

Item | Material | GUID

Froperty Walue

Type Wl

lcon Geormetny

Hidden Mo

Hequired Mo

b aternial Whitewazh

Source File ice stadium. rvwd

Layer A0S
£ >

To activate it, click the Properties button @ on the Workspace toolbar.

Every property has a type associated with it, for example, an item's Name is a string, and so on. Internal
file properties, such as transform and geometry properties, are not shown by default. If you want to view
this information, use a developer profile by selecting the Show Internal Properties check box on the
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Developer page of the Options Editor dialog box.

42



Chapter 10. Editing

Most editing is done from the Edit menu, which includes the following items:

* Undo

* Redo

» Select

» Hidden

* Required

* Unselected Hidden

* Reset All

Undo/Redo

You can undo or redo your actions in NavisWorks. The Edit > Undo and Edit > Redo menu item states
what type of action you will undo/redo.

File | Edit | Miewpoink  Tools  Help

|—_.| E  Undo Selection  Chel+Z

To undo an action:

* On the Edit menu, click Undo
or

* Press Ctrl-Z

or

e Click Undo on the Standard toolbar

Repeat as many times as required or your options allow.

To redo an action:

* On the Edit menu, click Redo
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or

e Press Ctrl-Y

or

* Click Redo - on the Standard toolbar

Repeat as many times as required, or your options allow.

Undo Options

You can set the amount of space you wish to allocate to the undo buffer. The default settings should be
adequate for most normal usage.

Setting undo options:

1. Onthe Tools menu, click Global Options.
2. Expand the General node in the Options Editor dialog box, and click the Undo option.

The Undo page is displayed:

Options Editor

= Genera o Buffer Size (kB)
|_|r|| [n]

Locations
Ervironment
[=)- Model
Performance
MWD
W
[=)- Interface
Display Units
Selection
Measure —
Snapping
Viewpoint Defaults
Hypetlinks
SmarkTags

Defaults

Expott. .. H Impatt. .. ] [ (0] 4 H Cancel ][ Help ]
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3. Set the amount of space you wish to allocate for saving undo/redo actions.

4. If you want to return to the system default values, click the Defaults button.
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5. Click OK to set these options or Cancel to exit the dialog without setting them.

Hiding Items

This command hides the current selection and allows you to hide and reveal items by toggling on and off.

Note:

In the selection tree the object will appear gray when hidden.

Hiding an item:

1. Select the item(s) that you want to hide (see Chapter 8, Selecting Iltems for more information on how
to do this).

2. On the Edit menu, click Hidden

or

Click Hidden [===]on the Selection Tools toolbar.

S

Making items required

This option makes the current selection required for rendering which means that they will always be
rendered during navigation and not drop out. The command allows you to make an item required or
unrequired by toggling on and off.

Note:

A Required item may also be Hidden. In the selection tree the object will appear red when
required.

Making an item required:

1. Select the item(s) that you want to make required (see Chapter 8, Selecting Iltems for more
information on how to do this).

2. Onthe Edit menu, click Required

or

Click Required [===] on the Selection Tools toolbar.

i |
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Hiding Unselected Items

This command hides all items except those currently selected so that they are not drawn in the main view.
The command allows you to hide and reveal the hidden items by toggling on and off.

Note:

In the selection tree the items will appear gray when hidden.

Hiding all non-selected items:

1. Select the item(s) that you want to remain visible (see Chapter 8, Selecting Items for more
information on how to do this).

2. Onthe Edit menu, click Unselected Hidden.

or

.

Click Unselected Hidden Ee' on the Selection Tools toolbar.

—

Resetting All Overriden Properties

Once an override has been applied to several items, you can reset them all at once to return them to the
values that they had when the file was originally converted from the native CAD file.

Revealing All Items

This option reveals (unhides) all items.

To reveal all items:

* On the Edit menu, click Reset All > Unhide All.

Making All Items Unrequired

This option makes all items unrequired so that no items are forced to be rendered during navigation.

To make all items unrequired:

* On the Edit menu, click Reset All > Unrequire All.
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Chapter 11. Display Modes

The Rendering Styles toolbar controls the appearance of the model in the main navigation window. From
here you can control the lighting effect, the rendering type and enable or disable the different types of
primitives drawn. Linked with the display options (see “ Display Options ” later in this chapter) and file
options (see “ File Options ", this enables you to fully control the appearance of the NavisWorks main
navigation window.

Rendering Styles

The rendering process interactively draws the scene's items in the main navigation window. You have a
choice of one of four interactive lighting modes (full lights, scene lights, head light, or no lights), four
rendering modes (full render, shaded render, wireframe or hidden line) and you can individually turn each
of the five primitive types (surfaces, lines, points, snap points and text) on and off.

The Rendering Style toolbar looks like this:

sRlv 2B ec. e T

To access it, right-click any toolbar (for example, Standard) in the main navigation window, and click
Rendering Style on the shortcut menu.

Lighting

Lights come through from various CAD file formats as scene lights. The intensity of the head light and
scene lights can be set using the File Options under the Tools menu (see “ File Options ” for details on
this).

The spheres below demonstrate the effect the lighting styles have on them. In order from the left, these
are full lights, scene lights, head light and no lights.

No Lights

This option turns off lighting. The models are shaded with flat rendering.

To turn off all lights:
* On the Viewpoint menu, click Lighting > No Lights

or
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e Click No Lights @ on the Rendering Style toolbar.

Head Light

This option uses a single directional light located at the camera that always points in the same direction
as the camera. You can set the head lights properties using Head Light options.
To turn on the head light:

* Onthe Viewpoint menu, click Lighting > Head Light

or

* Click Head light % on the Rendering Style toolbar.

Head Light options
Sliders are available to change the intensity of the scene's ambient light and headlight.

The Ambient slider controls the general overall brightness of the scene while the Headlight slider
controls the brightness of the light located at the viewpoint.

Note:

Changes made in Head Light options will not be visible unless you have selected the Head Light
rendering style.

Changing head light intensity:

1. Onthe Tools menu, click File Options.

2. Inthe File Options dialog box, click the Head Light tab.
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File Options g'
Culling | Onentation 5pee::|| Head Light |S|:ene Lightz | DataT ools
Y 1
Armnbient: i
Headlight: ; j
ak. | | Cancel | | Help

3. Move the sliders to affect the ambient and head light intensities. You will see the effect your changes
have on the scene in the main navigation window, as long as head light is selected as the rendering

style.

4. Click OK to set these options or Cancel to exit the dialog box without setting them.

Scene Lights

This option uses whatever lights are defined in the model, or two default opposing lights, if none are
available. You can set the scene lights properties using Scene Lights options.

To turn on scene lights:
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e Onthe Viewpoint menu, click Lighting > Scene Lights

or

» Click Scene lights on the Rendering Style toolbar.

=

Scene Lights Options
Sliders are available to change the intensity of the scene’s lights.

The Ambient slider controls the general overall brightness of the scene when scene lights is selected as
the rendering style.

Note:

Changes made in Scene Lights options will not be visible unless you have selected the Scene
Lights rendering style.

Changing scene light intensity:

1. Onthe Tools menu, click File Options.

2. Inthe File Options dialog box, click the Scene Lights tab.
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File Options rz|

Culling | Ornientation | Speed | Head Light| scene Lights |DataTn:n:uIs

Arnbient:

L

ak. || Cancel || Help

3. Move the slider to affect the ambient intensity. You will see the effect your changes have on the
scene in the main navigation window, as long as scene lights is selected as the rendering style.

4. Click OK to set these options or Cancel to exit the dialog box without setting them.

Full Lights

This option uses lights that have been defined with the Presenter tool.

To turn on full lights:
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e Onthe Viewpoint menu, click Lighting > Full Lights

or

* Click Full lights [ == ] on the Rendering Style toolbar.

Render Modes

The four render modes affect how the items are rendered in the main navigation window.

The spheres below demonstrate the effect that the render modes have on their appearance. In order from
the left, these are full render, shaded, wireframe and hidden line.

Full Render

This option renders the model with smooth shading including any Presenter materials that have been
applied using NavisWorks Presenter or have been brought through from the native CAD file (although
NavisWorks does not convert all native CAD file's textures - see Chapter 6, Converting Files for more
details).

To select full render:
* On the Viewpoint menu, click Rendering > Full Render

or

e Click Full Render [:i on the Rendering Style toolbar.

Shaded Render

This option renders the model with smooth shading and without textures.

To select shaded render:

* On the Viewpoint menu, click Rendering > Shaded
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or

* Click Shaded l-:- on the Rendering Style toolbar.

Wireframe Render

This option renders the model in wireframe. As NavisWorks uses triangles to represent surfaces and
solids, all triangle edges are visible in this mode.
To select wireframe render:

* On the Viewpoint menu, click Rendering > Wireframe

or

» Click Wireframe [=z= ] on the Rendering Style toolbar.

ek

Hidden Line Render

This option renders the model in hidden line. This requires a two pass rendering algorithm so is
equivalent to rendering shaded and wireframe at the same time. The output is low quality as all the facet
edges in the model are visible.

To select hidden line render:

e Onthe Viewpoint menu, click Rendering > Hidden Line

or

* Click Hidden Line

=== | on the Rendering Style toolbar.

Display Primitives

The second part of the rendering style toolbar allows you enable and disable the drawing of surfaces,
lines, points, snap points, and 3D text. Points are "real" points in the model, whereas snap points mark
locations on other primitives, for example the center of a circle, and are useful for snapping to when
measuring.

Surfaces

Surfaces are the triangles that make up the 2D and 3D items in the scene.

To toggle the rendering of surfaces on or off:
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e Onthe Viewpoint menu, click Display > Surfaces

or

* Click Surfaces [ 4, ]on the Rendering Style toolbar.

Lines

As well as turning all lines on and off, it is possible to change the width of the lines. See “ Display Options
" for details on how to do this.

To toggle the rendering of lines on or off:

* On the Viewpoint menu, click Display > Lines

or

 Click Lines [ -~ ]on the Rendering Style toolbar.

Points
Points are real points in the model, for example, the points in a point cloud from a laser scan. As well as

turning all points on and off, it is possible to change the number of pixels used to draw them. See *“
Display Options " for details on how to do this.

To toggle the rendering of points on or off:

» On the Viewpoint menu, click Display > Points

or

* Click Points [ .= ] on the Rendering Style toolbar.

Snap Points
Snap points are implied points in the model, for example, the center point of a sphere or end points of a
pipe. As well as turning all snap points on and off, it is possible to change the number of pixels used to
draw them. See “ Display Options ” for details on how to do this.

To toggle the rendering of snap points on or off:

* Onthe Viewpoint menu, click Display > Snap Points
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or

» Click Snap Points b4 on the Rendering Style toolbar.

Text is the 3D text saved in the scene.

To toggle the rendering of text on or off:

* Onthe Viewpoint menu, click Display > Text

or

e Click Text I]_EI on the Rendering Style toolbar.

Background Color

This option allows you to select or mix a background color for the main view. Setting the background color
is equivalent to setting a Plain Background on the Effects tab of the Presenter dialog box. This option is
only available if you have the NavisWorks Presenter tool.

Setting the background color:

1. Onthe Tools menu, click Background Color.
2. Select the color from the Windows™ color palette.

3. Click OK to set the background color or Cancel to exit the dialog box without setting it.

Culling Options

There are three methods of culling objects in NavisWorks: backface, by area, and by near or far plane. All
of these options are configurable using the Culling tab of the File Options dialog box.

Backface culling only draws the front face of every polygon in NavisWorks, which is clearly faster.
Sometimes, however, the conversion process mixes up the front and back face of polygons and so you
have to tell NavisWorks to draw both sides in order to not see right through some objects.

Area culling options allow you to set the size of objects within a model that will not be displayed. For
example, if you were to set the value to 100 pixels any object within the model that would be drawn less
than 10x10 pixels in size will not be displayed.

Culling options by near and far plane allows some degree of control over the resolution of the axis
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perpendicular to the screen. NavisWorks uses the near and far clip plane to maximize the resolution of
the model on screen. The near and far clip plane boxes dictate constraints for the near and far culling
planes.

Setting culling options:

1. Onthe Tools menu, click File Options.

2. Inthe File Options dialog box, click the Culling tab.

File Options [Z|

Culling | Ornentation | Speed | Head Light | Scene Lightz | DataT ools

Area Backface
Enable Salid o
Murnber of
pixels below
which objects
are culled: | !
Mear Clip Plane Far Clip Plane
Automatically Automatically
generated generaked

Defaults

ak. || Cancel || Help

3. Select the Enable check box under Area to enable the definition of the screen area (in pixels) below
which objects are culled and type in the number of pixels in the box.
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4. Inthe Near Clip Plane area, check the Automatically generated check box to tell NavisWorks to
constrain the near plane to give the best view of the model it possibly can. Alternatively, uncheck this
box to manually constrain the near clip plane. NavisWorks will put the near clip plane no further than
the value you type into the Furthest distance box.

5. Similarly, in the Far Clip Plane area, select the Automatically generated check box to tell
NavisWorks to constrain the far plane to give the best view of the model it possibly can. Alternatively,
clear this check box to manually constrain the far clip plane. NavisWorks will put the far clip plane no
closer than the value you type into the Closest distance box.

6. From the Backface drop-down list, select On to enable backface culling of all objects. Select Solid to
cull the backface of solid objects only. This is the default option and that which you are most likely to

require. If you find that parts of items are missing in the NavisWorks scene, you might want to disable
this option, by selecting Off.

7. Click OK to set these options or Cancel to exit the dialog box without setting them.

Orientation Options

NavisWorks has a concept of orientation and provides a heads up directional display. For this to work
effectively, it is essential that the current model is orientated correctly.

To orientate the model:

1. Onthe Tools menu, click File Options.

2. Inthe File Options dialog box, click the Orientation tab.
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File Options rz|

Culing | Orientation | Speed | Head Light | Scene Lights | DataTools

Up

% | 0 v |1 Z 0
Marth

v | 0 v |0 £ -1

| Defaults |

ak. || Cancel || Help

The defaults take the positive Z-axis as Up and the positive Y-axis as North.

If the models orientation is different to the defaults, enter XYZ values to correctly position the Up and
North directions.

Click OK to accept your changes, or Cancel to return to NavisWorks without accepting them.

Speed Options

The basis of NavisWorks is its ability to walk through any size model in real time. NavisWorks guarantees
a user-defined frame rate using a unique algorithm which automatically calculates which items to render
first during navigation, based on the size of items and distance from the viewpoint. Items which
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NavisWorks does not have time to render are therefore sacrificed or "dropped out” in the name of
interactivity. These items are, of course, rendered when navigation ceases. The amount of drop-out
depends on several factors including: hardware (in particular graphics card and driver performance), as
well as the size of the NavisWorks navigation window and the size of the model. If you wish to reduce
drop-out during navigation, you have the option to reduce frame rate and therefore trade it off against
drop-out. You can set the frame rate anywhere between 1 and 60 frames per second.

Setting the frame rate:

1. Onthe Tools menu, click File Options.

2. Inthe File Options dialog box, click the Speed tab.

File Options [z|
Culling Elrientaticnn| Speed | Head Light | Scene Lights | DataT ools
Frame R.ate: 6 1%
Q. | | Cancel | | Help
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3.

4,

Select the number of frames per second to be applied to the rendered display of the model.

Click OK to set these options or Cancel to exit the dialog box without setting them.

Display Options

Use these options to control several aspects of the NavisWorks main navigation window display to suite
your preferences and setup.

Setting display options:

1.
2.

On the Tools menu, click Global Options.

Expand the Interface node, and click the Display option.

The Display page opens.

Options Editor

General
Model
[=)- Interface
Display Units
Selection
Measure
Snapping
Viewpoint Defaulks
Hypetlinks
SmarkTags
Developer

SpaceBall
File Readers
Tonls

[ Export... H Import, .,

Acceleration
Hardware Acceleration

Occlusion Culling

Transparency

Interactive Transparency

Owerhead Adjust

Detail
Guarantee Frame Rate
Fill in Detail
Batch Fill

I [ Cancel

J

Help

Select the Hardware Acceleration check box to allow NavisWorks to utilize any available OpenGL

hardware acceleration on your video card. If your video card drivers do not function well with

NavisWorks, then you may wish to disable this option. This option is grayed out if your video card

does not support OpenGL hardware acceleration.

Select the Occlusion Culling check box to have NavisWorks only draw visible objects, i.e. ignores
objects that are behind other objects. This option will improve the display performance when much of
the model is not visible. For example, when you're walking down the corridor of a building. Occlusion

culling can only be utilized on a machine with an OpenGL 1.5 compliant graphics card.

Select the Interactive Transparency check box to allow the rendering of transparent items during
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10.

11.

12.

13.

14.

15.

interactive navigation. This may have an effect on performance - especially if your video card does
not support hardware accelerated OpenGL - and so by default transparent items are only drawn
when interaction has ceased.

Select the Guarantee Frame Rate check box to enable the NavisWorks engine to maintain the user
defined frame rate set on the Speed tab of the File Options dialog box (see “ Speed Options ”). By
default the target rate is maintained while moving. When movement stops the complete model is
rendered. If the Guarantee Frame Rate check box is cleared, the complete model is always
rendered during navigation, no matter how long it takes.

Select the Fill In Detail check box if you want NavisWorks to fill in any discarded detail when
navigation has ceased.

Select the Batch Fill check box if you want NavisWorks to fill in detail in chunks rather than
gradually. By default this is disabled as gradual rendering is generally better but some video cards
may work better with batch fill enabled.

In the Point Size box, enter a number between 1 and 9 to set the size (in pixels) of points drawn in
the main window. See “ Points ” for more information on points.

In the Line Size box, enter a number between 1 and 9 to set the width (in pixels) of lines drawn in the
main window. See “ Lines ” for more information on lines.

In the Snap Size box, enter a number between 1 and 9 to set the size (in pixels) of snap points
drawn in the main window. See “ Snap Points ” for more information on snap points.

Select the Enable Parametric Primitives check box to allow the dynamic rendering of parametric
models during interactive navigation. When this check box is selected, the level of detail will be
changed depending on the distance from the camera. When the check box is cleared, a default
representation of the primitive is used, and the level of detail does not change. Modifying this option
requires a restart of NavisWorks to take effect.

From the Mode drop-down list, select XYZ to turn on the XYZ indicator, or Compass to turn on the
north-south indicator, or Off to display neither.

Select the Show Position check box to show the absolute X, Y, Z position of the camera (or the
avatar's eye position if the avatar is visible). These position coordinates are shown at the bottom left
of the main view, and can be shown with or without the other Heads Up elements.

Note:

See Orientation Options for more information on correctly orientating your model file.

Click OK to set these options or Cancel to exit the dialog box without setting them.

Performance Options

Use these options to customize the performance of NavisWorks.

Setting Performance options:

1.

On the Tools menu, click Global Options.
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2.

Expand the Model node, and click the Performance option.

The Performance page is displayed:

Options Editor

General Memary Limik i
= Model
Performance Auta
MWD Limit. {ME)
YW
Interface
File Readers Merge Duplicates
Tools Cn Convert
Cn Append
on Load
On Save HWF
on Load
Collapse on Convert | Composite Objects  w
Close NWC/NWD Files on load O b
[ Expott. .. ] [ Impatt. .. ] I (0] 4 I [ Cancel ] [ Help

Memory. Select the Auto check box for NavisWorks to automatically calculate the maximum
memory that may be used. This will take the lowest of your available physical memory or address
space, less that required for your Windows operating system.

Alternatively, clear this option and manually enter the limit.

Merge Duplicates. These options improve performance by multiply instancing matching items.
Rather than storing every item in memory, if any items are the same, NavisWorks can store one
instance of them and 'copy’ that instance into other positions. This is of particular benefit on larger
models, where there are significant numbers of these duplicate geometries.

The options available determine when NavisWorks should perform this merging process:

e On Convert. Merge duplicates when converting a CAD file.
« On Append. Merge duplicates when a new file is appended to the current scene.

e On Load. Merge duplicates when loading a file into Navisworks.

On Load. The Collapse on Convert box can be set to alter layers shown in the Selection Set
window on loading native CAD model files. Each type collapses the Selection Set tree up to the
specified level. So None does not collapse the tree, Composite Objects collapses the tree up to the
level of composite objects, etc. This enables performance to be prioritized over structure/properties
and has the added benefit of improving streaming by cutting down the logical structure.

It should be noted that whilst NavisWorks will try to collape items to the fewest number possible, it
may be necessary to prevent collapsing in some cases to preserve model fidelity. For example if an
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item has properties or materials unique to itself, then collapsing would endanger this information, and
therefore it will not be collapsed.

Select the Create Parametric Primitives check box to enable creation of parametric models (models
described by formulae not vertices). Using this option allows you to get better looking visuals, faster
rendering, smaller memory footprint (especially when loading DGN and RVM files that contain

significant amounts of parametric data that will no longer need to be converted into vertices in
NavisWorks. Modifying this option will take effect when you next load or refresh file.

6. Temporary File Location. Select the Auto check box for NavisWorks to automatically select your

user Temp directory. Alternatively, if you prefer to select another location, clear this option and enter
the path accordingly.

Presenter Options

Use these options to control the appearance of Presenter materials in the main navigation window during
navigation. You may want to adjust these settings to get optimum performance from your graphics card
when navigating around heavily textured scenes.

Setting Presenter options:

1. Onthe Tools menu, click Global Options.
2. Expand the Tools node, and click the Presenter option.

The Presenter page is displayed

Options Editor

General Profile  |Basic w o
Model
Interface Smoothed textures
:“E lReaders Filtered kextures
ools
Interactive materials
Scripter Interactive lighting
animatar
Max Texkure Size 125 w
Max Image Texture Size  |256 W
Max Background Texture | 256 W
Blend transparent textures F]
|Jse Texbure Anti-Aliasing F]
Hardware Shading b
Export... ] [ Import... ] I Ok I [ Cancel l [ Help ]

3. Use the Profile drop-down list to adjust the Presenter to your level of knowledge. Select Advanced
to use the advanced Presenter features (e.g., extra materials, lights, render styles and so on). By
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10.

11.

12.

13.

14,

default, the Basic profile is used.

Select the Smoothed Textures check box if you want textures to look smooth but take longer to
render. Clear it if you want textures to appear pixelated but render faster.

Select the Filtered Textures check box if you want to turn on mipmapping. This will improve the
appearance of textures in the distance.

Clear the Interactive Materials check box if you want to turn off texture display during navigation.
The materials reappear automatically when navigation ceases, as long as the Full Render rendering
style is on. Clearing this check box will ease the load on less capable graphics cards and give less
drop out in heavily textured scenes.

Clear the Interactive Lighting check box if you want to turn off Presenter lights during navigation.
The lights reappear automatically when navigation ceases, as long as the Full Lights lighting style is
on. Clearing this option will ease the load on less capable graphics cards and give less drop out in
heavily lit scenes.

Use the Max Texture Size drop-down list to set the maximum size that any texture can be (in pixels,
e.g. 128 is 128 pixels x 128 pixels). The higher the value, the more MB in memory will be taken and
thus performance could be affected on less capable graphics cards.

Use the Max Image Texture Size drop-down list to set the maximum size that any texture image can
be (in pixels, e.g. 256 is 256 pixels x 256 pixels). The higher the value, the more MB in memory will
be taken and thus performance could be affected on less capable graphics cards.

Similarly, use the Max Background Texture drop-down list to set the maximum size that the
background texture can be (in pixels, e.g. 256 is 256 pixels x 256 pixels). The higher the value, the
more MB in memory will be taken and thus performance could be affected on less capable graphics
cards.

Select the Blend Transparent Textures check box if you want better quality but slower rendering of
transparent items in the main navigation window. With this option off, items with transparency of
more than 50% are treated as completely transparent and not rendered at all.

Select the Use Texture Anti-Aliasing check box if you want procedural materials (such as some
bricks and tiles - you can tell a procedural material in Presenter because it has a ball style preview
icon) to be rendered using anti-aliasing. With this option on, it will take longer to open files containing
procedural textures, but the quality will be better.

Hardware Shading can only be utilized on machines with OpenGL 1.5 compliant graphics cards.

From the Hardware Shading drop-down list, select:

« Interactive Shadows. Select this option to enable lights and shadows whilst navigating.

« Passive Shadows. Select this option to disable lights and shadows whilst navigating, then turn
them on when navigation ceases.

» Lighting. Select this option to turn lighting on with no shadows.
» Off. Select this option to have no hardware shading enabled.
Select Hardware Bump Maps check box to display bump map textures interactively, whilst

navigating. This can only be utilized on a machine with an OpenGL 1.5 compliant graphics card.
Hardware Shading also needs to be enabled.
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15.

16.

Select Hardware Marble check box to display hardware rendered marble materials in realtime. This
can only be utilized on a machine with an OpenGL 1.5 compliant graphics card. Hardware Shading
also needs to be enabled.

Click OK to set the options or Cancel to exit the dialog box without setting them.
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Viewpoints are snapshots taken of the model as it is displayed in the scene. Viewpoints may include a
variety of comments and redline tags, which have been previously added to a viewpoint. You cannot
create viewpoints in Freedom, but you can use any of the viewpoints and viewpoint animations saved in
the model. Viewpoint animation typically contains both the user movement through the model and views
of the model.

Recalling Viewpoints

To return to a viewpoint
» Click Viewpoint > Saved Viewpoints, and choose the saved viewpoint from the list.
or

* Inthe Viewpoints control bar, simply click on the viewpoint from the list.

Note:

On recalling viewpoints the navigation mode that was active when the viewpoint was created will
be re-selected. Any redlines and comments associated with the viewpoint will also be reinstated.

The Viewpoints Control Bar

Viewpoints allow you to keep a record of all the different views of a model so that you can jump to preset
viewpoints without having to navigate each time to reach an item. Viepoint animations are also saved with
the viewpoints, as they are simply a list of viewpoints treated as keyframes.
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The Viewpoints control bar is shown above. To open it,

» Click Viewpoints @ on the Workspace toolbar.

Icons are used to represent different elements:

D represents a folder which may contain all other elements (including other folders).
@ represents a viewpoint saved in orthographic mode.

[:D represents a viewpoint saved in perspective mode.

H:H represents a viewpont animation clip.

o represents a cut inserted into a viewpoint animation clip.

You can select more than one viewpoint by either holding down the Control key and left-clicking, or by
left-clicking on the first item, and then clicking on the last item while holding down the Shift key. You can
drag viewpoints around the Viewpoints control bar, but you cannot save any changes.

Editing Viewpoints
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You can edit by hand any current viewpoints attributes, including camera position, field of view, and
speed of motion. All entries are measured in scene units (see “ Units ”).

Editing a viewpoint

1. To edit the current main navigation viewpoint, go to Viewpoint > Edit Current Viewpoint.

The Edit Viewpoint dialog box is displayed.

Edit Viewpoint - Current View

iZamera
- W 7

Pasition {m): -10845.2| | 3967.94
Laak Ak () 1586.49 -6695,19| | 2535.86
Vertical Field OF View (=) 61.47
Horizontal Field OF Yiew (=) 81.46
Maokion
Linear Speed {m)sec): 553.49
angular Speed {°fsec): 43.00
Saved Attributes Collision Detection

Ik | | Cancel | | Help |

2. Set the camera position's x-, y- and z- coordinates using the Position boxes.

3. Set the focal point's x-, y- and z- coordinates of the camera using the Look At boxes.
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Enter the Vertical Field Of View and Horizontal Field Of View. If the units are set to degrees, then
these numbers should be between 0.1 and 90 and if in radians, between 0.002 and 3.124. See Field
Of View for more details on what field of view means.

Enter the Roll of the camera about its viewing axis. This value is not editable where the world up
vector stays upright (i.e. in walk, orbit and turntable modes).

Enter the speed of motion in a straight line for the viewpoint in the Linear Speed box (the minimum
value is 0 and the maximum is based on the size of the scene's bounding box).

Enter the speed of turning for the viewpoint in the Angular Speed box.

Click the Settings button to open the Collision Detection dialog box:

Collision Detection [‘5__(

Caollision Detection

|:| Graviky

[ ] Auka Crouch

Viewer

F.adius i) 0,75
Height () 1.70
Eye OFFset () 0,15

Third Person

Enable
Auko Zoom

Avatar Hurman 1 v
Angle (%) 15.00
Distance (i) 4.0

Ik, | | Cancel

» Select the Collision Detection check box to activate collision detection.
» Select the Gravity check box to activate gravity.
« Select the Auto Crouch check box to activate crouching.

* |nthe Viewer, Radius text box, enter a value for the radius of the collision volume. See “ Collision
Detection ”.
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* Inthe Viewer, Height text box, enter a value for the height of the collision volume. See “ Collision
Detection .

* Inthe Viewer, Eye Offset text box, enter a value for the distance below the top of the collision
volume, where the camera will focus upon when auto zoom is activated.

» Select the Third Person, Enable check box to view from a third person perspective.

» Select the Auto Zoom check box to automatically zoom from third person view into first person
view, whenever the line of vision is obscured by an item in the model scene.

« From the Third Person, Avatar drop-down, select the avatar you wish to represent yourself as.
See “ Third Person View ".

e Inthe Third Person, Angle text box, enter the angle at which you wish to look at the avatar. For
example, zero degrees will be directly behind and 15 degrees will be looking down on the avatar
at a 15 degree angle.

* Inthe Third Person, Distance text box, enter the distance behind the avatar, from which you
wish to view from.

« Click OK to accept the settings, or Cancel to return to the Edit Viewpoint dialog without
changing the settings.

Click OK to set the viewpoint or Cancel to exit the dialog without setting it.
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Chapter 13. Animation

In NavisWorks there are two types of animation:

* Object animation

* Viewpoint animation

Viewpoint animation contains pre-recorded user and camera movements in the model. Object animation
contains pre-recorded object movements in the model. You cannot record any animation in Freedom, but

you can play back animations saved with the model. If there are any animation scripts, you can switch
them on and interact with animated objects.

The Animation Toolbar

The Animation toolbar in Freedom enables you to play viewpoint animations. It can also be used to play
back object animations and enable/disable interactive animation scripts.

The Animation toolbar is shown below.

Il | gy L | [ =MLl J Bnirnation w Eﬁ!

To open it, right-click anywhere in the toolbar area of the screen, and click Animation on the shortcut
menu.

Rewind (7] - rewinds the animation back to the beginning.
I
Step Back [ - steps back a single keyframe.
|MJ|J|
Reverse Play |_| - plays the animation backwards.
‘:'--.j
Pause |_| - pauses the animation at the frame you press it at. You can then look

around and wonder off in the model, or step forwards and backwards through the
animation. To continue playing from where you paused, just press Play again.

Stop [ | - stops the animation playing and rewinds it back to the beginning.
| L |

Play [— | - plays the currently selected animation.
| L~ |

Step Forward |E| - steps one keyframe forwards.

Fast Forward |Q| - fast forwards the animation to the end.
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Animation Position slider 1] controls the current playback

position.

Animation Position - indicates the current playback position in
0:02,97 praybackp

seconds.

Available Animations - allows you to choose the animation

Door Open W
to play.

Toggle Scripts =1k enables/disables animation scripts in your file.
= |

Playing Back Animations

You can play back both pre-recorded object animation and viewpoint animation in the main navigation
window. The animation plays in real time; this means that the NavisWorks engine is still attempting to
maintain the guaranteed frame rate so some drop-out may still occur, just as in real-time navigation.

Playing back an animation:

1. Select the animation you wish to play back from either the Viewpoints control bar, or from the
Available Animations drop-down list on the Animation toolbar.

2. You can use the Animation Position slider to quickly move forwards and backwards through the
animation. Full left is at the beginning and full right is at the end. The text box next to the slider shows
the point in time (in seconds) through the animation that the camera is. You can type a number into
this box to set the camera at a certain point in the animation and play back from that point.

3. For viewpoint animations, you may notice that the frame in the animation in the Viewpoints control
bar is highlighted when the animation is playing. You can click on any frame to set the camera to that
point in time in the viewpoint animation and continue playing back from there.

4. Use the VCR buttons on the Animation toolbar to step and play forwards and backwards through the
animation.

Enabling Scripting:

» To enable animation scripts in your file, click the Toggle Scripts button on the Animation

toolbar.

You can now interact with your model. For example, if there is a scipt to open a door on pressing a
specific key on the keyboard, pressing this key will open the door.
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Chapter 14. Reviewing

The reviewing tools available in NavisWorks are:

» Commenting
* Hyperlinks

* Smart Tags

Commenting

Multiple comments can be attached to any item in the Viewpoints control bar (see “ The Viewpoints
Control Bar "), or to any item in the Selection Sets control bar (see “ Selection and Search Sets ”).

You cannot record any comments yourself in Freedom.

The Comments control bar allows you to view all comments attached to one of these sources.

To open it, click ':.;-) on the Workspace toolbar.

Commenks =
Commenk Date Author i Skatus
[:]:] Corment 2 12446 ... kevg 2 [ew

Camment 2

When the source of the comments is recalled, such as a viewpoint, all comments attached to it appear in
the Comments control bar, showing the time and date, author, ID and status of each comment. The icon
on the far left represents the source type:

@ - selection set.

ﬂ - search set.
@ or ED - viewpoint.

73



Reviewing

H:H or o - viewpoint animation.

ﬁ}-tag.
Hyperlinks

Hyperlinks are an extremely useful review tool to allow you to access non-graphical information through
the graphical interface of NavisWorks.

Hyperlinks are categorized so that you can switch them on and off by category, and they can be anything
internal (such as a viewpoints or selection set) or external (such as a web page, script, or spreadsheet) to
NavisWorks. By turning on hyperlinks in the main navigation window, you can simply click on the link to
activate it. Hyperlinks can be displayed as a text description, or as an icon and can also optionally have
leader lines pointing to points on the item to help you identify which item has the link attached.

To turn on hyperlinks:

* Click Hyperlinks on the Workspace toolbar

or

* Onthe Tools menu, click Hyperlinks.

Hyperlinks Categories

Hyperlinks can be categorized so that you can group them to distinctly display or not display in the main
navigation window at one time. The seven default categories are:

» Hyperlink

« Tag

* Viewpoints

» Selection sets

* Redline tags

You can customize the display of both standard and user-defined categories in the Options Editor.
Displaying Hyperlinks

To turn on hyperlinks:

e Click Hyperlinks on the Workspace toolbar
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or

» Click Tools > Hyperlinks on the menu bar.

Following Hyperlinks

To follow a hyperlink, simply click on it in the main navigation window. If multiple hyperlinks are attached
to an item, the default hyperlink will be followed.

Hyperlinks Options

Setting hyperlinks options:

1. Onthe Tools menu, click Global Options.
2. Expand the Interface node, and click the Hyperlinks option.

The Hyperlinks page is displayed:

Options Editor

General In 3D
Miodel _
[=)- Interface Max Icons |29 &
Display Uinits Hide Colliding Icons O
Selection
Measure Cull Radius {m} |D.EIEI

Snapping
Wiewpoint Defaulks Hlezday elfie:
Y Leader Offsek

Hyperlinks
SmarkTags
Developer
Displary
SpaceBall
File Readers
Toals

Defaults

[ Expart. .. H Import. .. ] l (o)A H Cancel H Help ]

3. lcons that appear overlapped in the main view can be hidden if the Hide Colliding Icons check box
is selected.

4. Enter the distance in the Cull Radius box for how close hyperlinks have to be in order to be drawn in
the main view. Any hyperlinks further away than this distance will not be drawn. The default value of
0 means that all hyperlinks will be drawn.

5. Select the In 3D check box if you want to draw the hyperlinks icons in 3D in the main view. They then
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float in 3D space just in front of their attachment points to the items. If this box is unchecked, then all
hyperlink icons are drawn in 2D over the top of the all geometry.

Note:

In 3D mode hyperlinks can become hidden by other objects in the scene when you are
navigating.

6. Enter the maximum number of icons to draw in the main view in the Max lcons box.

7. Hyperlinks can be drawn with leader lines (arrows) pointing to the attachment point on the item that
the hyperlink is attached to. Enter the X- and Y- distance in Leader Offset for the number of pixels to
the right and up that these leader lines will use.

8. Click OK to set the options or Cancel to exit the dialog without setting them.

Configuring standard hyperlinks categories:

1. Onthe Tools menu, click Global Options.

2. Expand the Interface node, expand the Hyperlinks option, and click Standard Categories.

The Categories page is displayed:

Options Editor

-

General
Model
Interface
Display Units
Selection
Measure
Snapping
Viewpoint Defaulks
(= Hypetlinks
Standard Cateqories
User-Defined Categories
SrnarktTags
Developer
Display
SpaceBall
File Readers
Toals

Hyperlink
Icon Type
Wisible
Tag
Icon Type
Wisible
Clash Detective

Icon Type
Visible

Hide Icons Without Comment

TimeLiner

Icon | »

Texk =

Icon (&

[ Expott. .. H Impatt. .. ] H Cancel ][ Help

Each hyperlink is a member of a category. This enables you to easily manage sets of hyperlinks. Use
the Visible check box to switch a category on or off in the main view. Some categories also have
comments associated with them. Use the Hide Icons Without Comments check box, if available, to
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do exactly that - only draw hyperlinks that have a comment attached to it, so that you can see any
areas of issue in the model. See “ Commenting ” for more information on comments.

Use the Icon Type field to specify how to display the hyperlink.

Select Icon to use a default hyperlink @

icon in the main view.

Select Text to use the hyperlinks description as a tooltip style text box in the main view

instead of an icon.

Click OK to set the options or Cancel to exit the dialog without setting them.

Configuring user-defined hyperlinks categories:

1.
2.

3.

On the Tools menu, click Global Options.

Expand the Interface node, expand the Hyperlinks option, and click User-Defined Categories.

The Categories page is displayed:

Options Editor

General Hypetlink.

Miodel

= Inkerface
Display Uniks
Selection
Measure
Snapping
Viewwpoint Defaults

[= Hypetlinks

Tag

Standard Cateqaries
User-Defined Categories
SmartTags Clash Detective
Developer
Display
SpaceBall
File Readers

&

Tools

< * TimeLiner

[ Export... H Import, ., ]

Icon Type

Ican Type  |Text

Icon Type |Icon »

Hide Icons Without Comment

Visible

Visible

Visible

l (o)A H Cancel H Help ]

Only the custom hyperlink categories are shown here. The padlock E icon indicates that you

cannot add or remove categories directly from here.

Choose the way categories are shown in the Options Editor:
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—_—

|._._._| to display categories in a tabular format.
[—=1]

Click List View |:| to display categories in a list format (the same way as the standard

—_

categories are shown).

—

Click Records View |E| to display categories as records.

4. Use |_| | and |_> | to navigate between the categories. If you selected Records View, this is the

only way to move between the records.

5. Use the Visible check box to switch a category on or off in the main view.

6. Use the Icon Type field to specify how to display the hyperlink.

Select Icon to use a default hyperlink

i

icon in the main view.

Select Text to use the hyperlinks description as a tooltip style text box in the main view

instead of an icon.

7. Click OK to set the options or Cancel to exit the dialog without setting them.

Smart Tags

Smart tags pop up information on the item hovered over by the cursor in a tooltip style window, without
having to select the item itself. The smart tag will disappear after a few seconds. This is a useful way to
quickly get information about an item in the main navigation window when navigation has ceased. The
default information shown is the name and type of the item, but you can define which properties to show

using the smart tags options.

Note:

If the item hovered over doesn't have the property requested, smart tags will search up the
selection tree for a parent that does, so maximising the useful information you get.

To turn on smart tags:

e Click Smart Tags F on the Workspace toolbar

or

* Onthe Tools menu, click Smart Tags.
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Smart Tags Options

Setting smart tags options:

1. Onthe Tools menu, click Global Options.
2. Expand the Interface node, and click the Smart Tags option.

The Smart Tags page is displayed.

Options Editor

General Hide Category [
Miodel

= Inkerface

Display Units
Selection
Measure
Snapping
Viewpoint Defaulks
Hypetlinks

-

SmarkTags
Developer
Displary
SpaceBall
File Readers
Tools

Defaults

Export... H Import... ] l (0] 4 H Cancel H Help ]

3. Select the Hide Category check box if you do not want to see category hames included in the smart
tags tooltip.

4. Click OK to set the options or Cancel to exit the dialog without setting them.

The default information displayed is the name and type of the item, but the actual information displayed
can be customized.

Customizing smart tags:

1. Onthe Tools menu, click Global Options.
2. Expand the Interface node, expand the Smart Tags option, and click Definitions.

The Definitions page is displayed.
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Options Editor

g FEEEE

=) Inkerface
Display Urits Categary
Selection
Measure

Snapping

Viewpaoint Defaulks ategary
Hypetlinks
=] SmarkTags

Property |Name b |

Property |T';-'|:ue b |

Definitions
Developer
Display
SpaceBall

File Readers
Tools

Defaulks

Export. .. H Impott. .. ] I QK H Cancel H Help ]

3. Choose the way smart tag definitions are shown in the Options Editor:

Click Grid View to display definitions in a tabular format.

Click List View to display definitions in a list format.

Click Records View to display definitions as records.

4. Use m and to navigate between the definitions. If you selected Records View, this is the

only way to move between the records.

5. For every smart tag definition, you can change the Category and Property by clicking on the item
and choosing the relevant entry from the drop-down list.

6. To add a smart tag definition, click @
7. To delete a smart tag definition, select it, and click @

8. Click OK to set the options or Cancel to exit the dialog without setting them.
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Chapter 15. Object Manipulation

You cannot modify object properties in Freedom but you can adjust the way currently selected objects are
highlighted in the main navigation window.

Highlighting Objects

To get a clearer view of geometry objects in the main NavisWorks window, you can use the Options
Editor to adjust the way in which the current selection is highlighted.

You can use three different highlighting methods:

» Shaded

*  Wireframe




Object Manipulation

To adjust highlighting:

1.
2.

Tinted

On the Tools menu, click Global Options.

Expand the Interface node in the Options Editor dialog box, and click the Selection option.

The Selection page is displayed.

Options Editor

General
Maodel
= Inkerface
Display Units
Selection
Measure
Snapping
Viewpaoint Defaulks
Hypetlinks
SmarkTags
Developer
Display
SpaceBall
File Readers
Tools

Expork. .. H Irnpork, ..

Pick. Radius
Resolution

Campack Tree
Highlight
Enabled

Method

Color

Tink Level (%)

1

e
w
Lask Object W

Layers w

Wireframe | w

Defaulks

(0] 4 H Cancel H Help ]
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Locate the Highlight area, and select the Enabled check box to turn on highlighting of the selected
items.

Use the Method drop-down list to select the type of highlighting you want (Shaded, Wireframe or
Tinted).

Click the Color button to select the highlight color.
If you selected Tinted in the Method box, use the slider to adjust the Tint Level.

Click OK to set these options or Cancel to exit the dialog box without setting them.
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Chapter 16. Interface

The NavisWorks interface is intuitive and easy to learn and use. It contains a number of traditional
Windows elements, such as toolbars, control bars, and dialog boxes.

{3 Gatehouse.nwd - Autodesk NavisWorks Freedom 2009

Wiewpoint  Tools  Help

saydadoly

squodealy,

L
@
1]
2
=
(=1
3
=
1]
o

Cormrments
e B2 ME
1 - Menu bar
2 - Toolbars

3 - Navigation window
4 - Control bars

5 - Status bar

The Main Interface Components
This section briefly describes the main interface components.

The Menu Bar

The Menu bar contains all commands available in NavisWorks, grouped together by similar or 'like’
functionality.

84



Interface

When a menu has a right-pointing arrow, such as , there is a

Mavigation Mode »

submenu associated with that choice.

When a menu item is followed by a series of dots, such as . . .
y Edit Current Viewpoint. ..

there is a dialog box associated with that choice.

The Toolbars

NavisWorks toolbars provide quick access to frequently used commands. Every button on a toolbar
includes a tooltip, which describes the function the button activates. Placing the mouse over a button
displays a brief instruction on how to use this feature in the Status bar.

You can rearrange, open and close toolbars:

» To move a toolbar, click the dotted line at the edge of the toolbar, and drag it to a different location.

e To open or close toolbars, right-click an empty area next to the last toolbar on the screen, and choose
from the list of available toolbars on the shortcut menu.

Some toolbar buttons enable you to choose a program mode. For example, to look around your model,
you need to be in look around mode. To rotate the model, you need to be in examine mode and so on.
NavisWorks remains in the selected mode until instructed otherwise. To identify the mode you are in, look
at the buttons. If a button is highlighted and has a dark blue boarder around it, the corresponding mode is
currently active.

€A T o r S8

To leave the mode, either click the same button again or choose a different mode.

Some buttons are used to toggle the display of control bars, and and window panes (for example, the
TimeLiner window). Again, if a button is highlighted and has a dark blue boarder around it, it means that
the corresponding display element is currently open.

As you open more toolbars on the screen, or resize the NavisWorks window, the toolbars may get
overlapped with each other to reduce the screen clutter. When this happens, some buttons will be hidden
under the overlaps. To quickly access the entire set of commands on a toolbar, click the chevron .

button at the right end of the toolbar. The remaining commands available for that toolbar will appear.

The Main Navigation Window

The main navigation window (also referred to as 'main NavisWorks window' and 'main 3D navigation
view") is used to interact with 3D models.

The Control Bars

Some features are accessible from the control bars (also referred to as 'palettes’). To display a control
bar, click the desired control bar button on the Workspace toolbar.

All control bars are dockable and resizable, and will automatically lock to specific locations near to where
they are moved.
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Note:

Holding down the CTRL key when moving a control bar prevents it from auto docking.

Using the Docking Tool

When you drag a control bar or a window pane from its current location towards a new destination on the
interface, a docking tool appears.

The docking stickers point towards the four edges of the interface.

When the control bar you are dragging is close to the place where you want it to dock, move the mouse
over the corresponding area of the docking tool. You will see an outline of the control bar appear on the
interface. To dock the control bar there, release the mouse button.

Tiling Control Bars

You can tile control bars and window panes on the interface. To do this, drag a control bar you want to tile
over the control bar where you want it to be placed. When a rectangular outline appears, release the
mouse button.

Auto Hiding Control Bars

You can auto hide control bars and window panes; this keeps the control bars active while maximizing
the amount of available screen space. If auto-hide is active, the body of the control bar disappears when
you move the cursor out of it, leaving only the title bar visible. Move the cursor over the title bar to display
the entire control bar again.

To switch auto-hide on, click w|on the title bar. To switch auto-hide off, click = ]on the title bar.

The Status Bar

The Status bar appears at the bottom of the NavisWorks screen.

The left-hand corner of the Status bar is used to display short instructions on how to use the NavisWorks
features.
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In the right-hand corner of the Status bar there are four performance indicators, that give you constant
feedback as to how NavisWorks is performing on your machine.

= wla .
e ME

e The progress bar under the left hand icon (pencil) indicates how much of the current view is drawn, i.e.
how much drop-out there is in the current viewpoint. When the progress bar is at 100%, the scene is
completely drawn, with no drop-out. The icon will change color when it is working. Whilst the scene is
being drawn, the pencil will change to yellow. If there is too much data to handle and your machine
cannot process this quickly enough for NavisWorks, then the pencil will change to red, indicating a
bottleneck.

e The progress bar under the central icon (disk) indicates how much of the current model is loaded from
disk, i.e. how much is loaded into memory. When the progress bar is at 100%, the entire model,
including geometry and property information, is loaded into memory. The icon will change color when
it is working. Whilst data is being read, the disk will change to yellow. If there is too much data to
handle and your machine cannot process this quickly enough for NavisWorks, then the disk will
change to red, indicating a bottleneck.

» The progress bar under the right hand icon (web server) indicates how much of the current model is
downloaded, i.e. how much has been downloaded from a web server. When the progress bar is at 100
%, the entire model has been downloaded. The icon will change color when it is working. Whilst data
is being downloaded, the web server will change to yellow. If there is too much data to handle and
your machine cannot process this quickly enough for NavisWorks, then the web server will change to
red, indicating a bottleneck.

» The field to the right of the icons reports the amount of memory currently being used by NavisWorks.
This is reported in Megabytes (MB).

Units

NavisWorks has the concept of what unit the scene is presented in. There is a single scene unit that is set
from the Global Options dialog and this unit is used throughout the interface whenever appropriate.

There is a default unit setting for each file type so that when files are opened, they are scaled

appropriately to the scene's units. They can, of course, be rescaled after if the units turn out to be wrong
for the scene.

Units Options

Setting units options:

1. Onthe Tools menu, click Global Options.
2. Expand the Interface node in the Options Editor dialog box, and click the Display Units option.

The Display Units page is displayed.
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Options Editor

General

Linear Uniks | Meters

Model

= Interface Angular Units |Degrees v|
Displary Uniks
Seleckion Decimal Places:
Measure

Fractional Display Precision:
Snapping

Viewpaoint Defaulks
Hypetlinks
SrnartTags

Developer
Display
SpaceBall
File Readers
Tools
Defaulks
Export. .. H Impott. .. QK H Cancel H Help ]

3. Choose the Linear Units from the list. You should be able to choose the exact format you wish.

4. Choose the Angular Units from the list.

5. Enter the number of decimal places you want to see throughout the interface for your units in the
Decimal Places box. If the unit chosen is a fractional unit, rather than decimal unit, then you have
the choice of what level of fraction to display the units from the Fractional Display Precision
drop-down list.

6. Click OK to set the options or Cancel to exit the dialog without setting them.

Profiles

NavisWorks can be adjusted to your level of CAD technical knowledge. By default, a standard profile is
used. If necessary, you can use a developer profile to display additional object properties.

Using a developer profile:

1. Onthe Tools menu, click Global Options.
2. Expand the Interface node, and click the Developer option.

The Developer page is displayed
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4,

Options Editor

General Shawe internal properties
Model
=) Inkerface
Displary Uniks
Selection
Measure
Snapping
Viewpaoint Defaulks
Hypetlinks
SrnartTags

Developer
Display
SpaceBall
File Readers
Tools
[ Expart. .. H Import. .. ] I (0] 4 H Cancel H Help ]

Select the Show Internal Properties check box to display additional object properties.

Note:

Now the Geometry tab and Tranform tab will be shown in the Properties control bar for the
associated models and items.

Click OK to set the profile or Cancel to exit the dialog box without setting it.

Search Directories

NavisWorks searches for a variety of configuration files in subdirectories of three standard directories.
These files can be overridden on a per user, all users or per installation basis. The search directories are :

Appl i cation Dat a\ Aut odesk Navi sWwrks Freedom 2009 within the current user profile.
Usually C: \ Docunrent s and Settings\user\Application Data\ Aut odesk Navi sWrks
Freedom 2009 where user is the name of the current user.

Appl i cation Dat a\ Aut odesk Navi sWrks Freedom 2009 within the all users default profile.
Usually C: \ Docunent s and Settings\All Users\Application Data\Aut odesk
Navi sWwor ks Freedom 2009.

Within the NavisWorks install directory. Usually C: \ Progr am Fi | es\ Aut odesk Navi s\Wor ks
Freedom 2009.
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Chapter 17. Tools

The Tools menu in NavisWorks gives access to a series of useful tools and options.

The Tools menu includes the following items:

« TimeLiner Playback
* Hyperlinks

* Smart Tags

* Animation

» Background Color

» File Options

* Global Options
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There are two types of options: File Options and Global Options. These are both accessed from the
Tools menu. File options are saved in NavisWorks files (.nwf or .nwd) and reinstated when opening it.
Global options, on the other hand, are set for all NavisWorks sessions.

File Options
To get to the File Options dialog, go to Tools, File Options. You will get a tabbed dialog box offering one
of the following five file options:
e Culling. See “ Culling Options ”.
» Orientation. See “ Orientation Options ".
» Speed. See “ Speed Options .
* Head light. See “ Head Light options .
e Scene lights. See “ Scene Lights Options .
These options are predominantly concerned with the appearance of the model and the speed of

navigation around it. Any changes that you make are temporary, and the options are reverted back to
default when you exit Freedom.

Location Options

These options enable centralized sharing of global NavisWorks settings, workspaces, datatools, avatars,
Clash Detective rules, Presenter archives, custom Clash Detective tests, object animation scripts etc. The
settings can be shared across an entire project site, or across a specific project group depending on the
required level of granularity.

Setting location options:

1. Onthe Tools menu, click Global Options.
2. Expand the General node in the Options Editor dialog box, and click the Locations option.

The Locations page is displayed:
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Options Editor

G |
=] EHE:-,ad.;. Project Direckory |E:'I,Team.ﬁ. | E]
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3. Inthe Project Directory field, browse to the directory that contains the NavisWorks settings specific
to your project group.

4. Inthe Site Directory field, browse to the directory that contains the NavisWorks settings standard
across the entire project site.

5. Click OK to save the changes or Cancel to exit the dialog without saving them.

Note:

When you run NavisWorks for the first time, the settings are picked up from the installation
directory. Subsequently, NavisWorks examines the current user profile and the all users profile on
the local machine, and then checks the settings in the Project directory and the Site directory.
The files in the Project directory take precedence.

Environment Options

Setting environment options:

1. Onthe Tools menu, click Global Options.
2. Expand the General node in the Options Editor dialog box, and click the Environment option.

The Environment page is displayed:
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3. Enter the desired number into the Maximum Recently Used Files to specify how many file shortcuts
NavisWorks can remember. By default, shortcuts to the 4 most recently opened files can be
displayed.

4. Click OK to save the changes or Cancel to exit the dialog without saving them.

Global Options

These options are persistent across NavisWorks sessions and are not saved into NavisWorks files.

The Options Editor can be accessed via the Tools menu, or it can be launched as a separate
application. To do this, go to Start > Programs > Autodesk > Autodesk NavisWorks Freedom 2009 >
Options Editor. The options are grouped together, and presented in a tree structure, making it quicker to
find and change them.
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Options can be exported and imported, making it quick and easy for project managers, or systems
administrators, to ensure the NavisWorks settings on all machines are identical.

Configuring Global Options

The options are presented in the dialog box in a hierarchical tree structure. The following categories are

available:

e General
*  Model

* Interface

* File Readers

General Options

You can configure:

» Buffer Size. See “ Undo Options ”.

» File Locations. See “ Location Options ".

* Number of Recent File Shortcuts to Store. See “Environment Options”.

Model Options
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You can configure:

» NavisWorks Performance. See “ Performance Options .

Interface Options

You can configure:

» Display Units. See “ Units Options ”.

» Selection and Highlighting Parameters. See “ Selection Options ", and “Highlighting Objects”.
» Hyperlinks. See “ Hyperlinks Options ”.

* Smart Tags. See “ Smart Tags Options ”.

* Profiles. See “ Profiles .

» Display Parameters. See “ Display Options ".

» SpaceBall Parameters. See “ Using a SpaceBall ”

File Readers Options

You can configure:

« DWF. See “ DWF File Reader Options ".
Importing and Exporting Global Options

To export Global Options:

1. Onthe Tools menu, click Global Options.
2. Inthe Options Editor dialog box, click the Export button.

The Select Options to Export dialog box is displayed:
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Select the check boxes for all options you want to be exported (or 'serialized"). If an option cannot be
exported, it is greyed out.

Note:

To quickly select/deselect all options for a given category, use the top-level check boxes. For
example, selecting the General check box, instantly selects all options under this node.

Click OK to export the settings.

In the Save As dialog box, enter a name for the settings file. You can also select the name of an
existing settings file to overwrite it with your modified configuration.
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Click Save.

Click OK to close the Options Editor.

To import Global Options:

1.
2.
3.

On the Tools menu, click Global Options.
In the Options Editor dialog box, click the Import button.

In the Open dialog box, browse to the folder containing the settings file, select it, and click Open.
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Click OK to close the Options Editor.
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Chapter 19. Getting Help

The Help menu gives you access to useful resources about your system, your product and the
documentation. NavisWorks comes with full context-sensitive help as well as user guides in Adobe
Acrobat™ .pdf format. The Help menu contains:

* Help Topics

*  What's This?

* NavisWorks on the Web

e Customer Involvement Program

» System Info

» About NavisWorks

If the online documentation and help does not answer your query, try www.autodesk.com/support. If the

website does not help answer your problem, you should contact the reseller from whom you purchased
the software.

Help Topics

NavisWorks contains full help documentation. This is structured in chapters, sections and procedures
which can be easily navigated on the Contents tab.

To open the NavisWorks help documentation, click Help > Help Topics on the menu bar.

The NavisWorks help window is displayed:
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In the Contents tab, select an item to view its contents. Expand and contract the chapters and sections
(identified with a book icon) using the plus and minus icons to the left of them. The contents of the
selected item will be displayed in the right hand pane.

The Index tab has a full index of all NavisWorks help topics. Select the topic you are interested in
learning more about from the list, then click Display. The selected topic will be displayed in the right hand
pane.

Should you not be sure of the topic name that you are interested in learning more about, use the Search
tab to search on any keyword. Enter the keyword to be found, then click List Topics. Any topics within
the NavisWorks help containing the keyword you entered, will be listed. Select the topic you are
interested in and then click Display. The selected topic will be displayed in the right hand pane.

You can enclose a phrase in quotation marks to search on that exact phrase.

What's This?

NavisWorks contains full context-sensitive help. If you want to find out more about any item in the
interface. Click @ and click over the toolbar button, window or menu command that you want to know

more about. The appropriate Help topic will then be displayed.

NavisWorks on the Web

To visit the NavisWorks pages on the Internet, click Help > NavisWorks on the Web on the menu bar.
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Customer Involvement Program

The Customer Involvement Program (CIP) is a program that dramatically improves the way Autodesk
designs software and measures performance and quality. It lets customers be involved in helping make
Autodesk products better meet their needs and the needs of the larger community of users.

CIP automatically collects information about software features usage, system configuration and software
errors from those customers that choose to participate. About once a day, a small file containing CIP
information is sent to Autodesk'’s servers. The CIP program DOES NOT send actual design information to
Autodesk so it is not possible for Autodesk to replicate your actual drawings or design information using
the CIP information.

If you'd like to join the Customer Involvement Program, click Help > Customer Involvement Program on
the menu, select the participation option in the dialog box, and click OK.

You can stop your participation in the CIP program at any time by accessing the CIP dialog box again.

System Info

Opens a dialog giving you detailed information about your system, which can be helpful in support

situations.
Autodesk MavisWorks Freedom 2009 El
& 23 Microsoft windows %P Prafessional Service Pack 2 (Build 26000
Jr) Processard: InkellR) PentiumiR) O CPU 3, 40GHz (%586 Family 15 Madel 6 Skepping 50
Processard Speed; 3391 MHz
Processar]: InkellR) PentiumiR) O CPU 3, 40GHz (x86 Family 15 Madel 6 Skepping 50

Processarl Speed: 3391 MHz

Memory: 1527 MEB

Mernary Lirniks 1114 MEB

Cpenal Yendor: Inkel

Cpenial Renderer: Intel 965/963 Graphics Media Accelerakor
CpenGl Yersion: 1.4.0 - Build 6,14, 10,4704

Pixel Format: &

Color Bits: 32

Depth Bits; 24

iaraphics Driver: Intel{R) Q9650963 Express Chipset Family (6, 14,10,4704)
OpenGl Driver Wersion: 6,14, 10,4704 (igticd3z . dil}

About NavisWorks

Opens a dialog giving you information about your product, including version and build number, which can
be helpful in support situations.
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Part 4. Using TimeLiner Playback

In this section you will learn how to play back a TimeLiner construction sequence in Freedom.




Chapter 20. Overview of TimeLiner

The TimeLiner tool adds 4D schedule simulation to Autodesk NavisWorks Freedom 2009.

In NavisWorks, TimeLiner has a playback-only option, allowing any externally created project data to be
simulated, but no changes to be made to that data.

Working with the TimeLiner Window

By default, the TimeLiner window floats in the main NavisWorks window. Like all other floating windows,
TimeLiner window is dockable and resizable, and will automatically lock to specific locations near to
where it is moved. You can prevent it from docking while you drag it, by holding down Ctrl.

Note:

You can quickly dock and undock any floating window by double-clicking the window's control
bar.

To open the TimeLiner window, select TimeLiner from the Tools menu.

The TimeLiner window contains the following:

» Simulate tab - enables you to set up and play simulations.

The Task Status

The Status Icons

Each task has its own Status identified by an icon, representing planned against actual relationships.
Each icon shows two bars. The top bar represents the Planned dates, and the bottom bar represents the
Actual dates. If the Actual start and finish dates are the same as the Planned start and finish dates, the
bars are displayed in green. Any variations between Planned and Actual dates are displayed in red.
Missing Planned or Actual dates are shown in grey.

= Actual start and end dates equal Planned start and end dates.
m:' Actual end date before Planned start date.
':'m Actual start date after Planned end date.

— Actual start date before Planned start date and Actual end date after Planned

end date.

—  Actual start date before Planned start date and Actual end date equals Planned

end date.

—_ Actual start date equals Planned start date and Actual end date after Planned

103



Overview of TimeLiner

end date.
|
Ea
end date.
|
Ea

end date.

Actual start date equals Planned start date and Actual end date before Planned

Actual start date after Planned start date and Actual end date equals Planned

m; Actual start date before Planned start date and Actual end date before Planned

end date.
|
B3

date.

 —

The Simulate Tab

Actual start date after Planned start date and Actual end date after Planned end

Actual start and end dates only.

Planned start and end dates only.

The Simulate tab enables you to simulate your TimeLiner sequence throughout the duration of the

project schedule.

TirneLiner
Simulate
1]/ =
00;00:00 00;00:00
05/03/2008 17/03)2008
Active Tasks
MNarne Status Progress % o
o= = &0 0
L4 >

The Playback Controls

Use the standard VCR buttons to step and play forwards and backwards through the simulation:

Rewind

Ll

will rewind the simulation back to the beginning.
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will step back a single step size.

sJU
Reverse Play will play the simulation backwards.
{"-.j
Pause will pause the simulation at the time you press it at. You can then look

ULl

around and interrogate the model, or step forwards and backwards through the
simulation. To continue playing from where you paused, just press Play again.

Stop O will stop the simulation playing and rewind back to the beginning.

Play will play the simulation from the currently selected time.
I.-"':-

Step Forwards will step forwards a single step size.

UL

Forward will fast forward the simulation to the end.

UL

You can use the Simulation Position slider to quickly move forwards and backwards through the
simulation. Full left is at the beginning and full right is at the end.

v

0o:00:00 09:35:10
280712003 250212008

The Date/Time box below the VCR buttons shows the point in time through the simulation. You can click
on the drop-down icon to the right of the date to display a calendar, from which you can select a date to
‘jump’ to.

The Active Tasks

You can view the current simulation time for each of the active tasks, and how close to completion they
are (Progress is displayed as a percentage). The Status of each active task is also displayed as an icon.
For simulations where Planned and Actual dates are available, the status provides a visual representation

as to whether there is any variance between the planned and actual dates. See TimeLiner task status for
more information.

Playing Simulations
To play a simulation:

1. If the TimeLiner window is not already open, select Tools > TimeLiner from the menu bar.

2. Click the Play button.

105



Overview of TimeLiner

The TimeLiner window displays the tasks as they are carried out, and the main NavisWorks window
shows the sections of the model added or removed over time, in accordance with the task types.
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Glossary of technical terms relating to Autodesk NavisWorks Freedom 2009.

Display Terminology

Average Frame Rate

Average Frame Time

Average Triangle Rate

Culling

Drop-Out

Frame Rate

This shows the current measured frame rate, averaged over the last
second.

This shows the time taken to render the last frame.

This shows the rate at which triangles are being rendered and is a
measure of how well your graphics card is working.

Culling is a process for determining items not to draw during the render
of a scene. NavisWorks does a level of prioritized culling with the
drop-out method of rendering interactive scenes, but you have a certain
level of control over other aspects of culling such as backface, near and
far planes.

In order to maintain interactivity and guarantee a user-defined frame
rate, NavisWorks only renders what it can in the fraction of a second it
has. The remainder is "dropped out", or not rendered. However,
NavisWorks prioritizes what is rendered and what is dropped out based
on size of the item's bounding box, distance from viewer and size on
screen, so only the less significant items in the scene are dropped out.
Once navigation has ceased, the scene continues rendering until all
items are visible.

The frame rate is the number of frames per second (FPS) that are
rendered in the main navigation window. NavisWorks guarantees a
user-defined frame rate in order to maintain interactivity.

Export Terminology

These are terms specific to NavisWorks that are used in relation to exporting.

Codec

File Terminology

Codec stands for "COmpression-DECompression” and is a program that
compresses and decompresses animations when creating and playing
back .avi files. Codecs are installed independently of NavisWorks and
are available when installed on your Windows™ system and the same
codec that was used to create an .avi file is required to play it back.
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.nwc Cache Files

.nwd Published Data Files

.nwf Review Files

External References

Faceting Factor

When any native CAD file file is opened or appended, NavisWorks
creates a cache file (.nwc) if the write cache option is set. When the file
is next opened or appended, NavisWorks will read data from the
corresponding cache file rather than re-converting the original data if the
cache is newer than the original file. If the original file is altered,
NavisWorks will re-create the cache file when it is next loaded. Cache
files speed up access to commonly used files. They are particularly
useful for models made up of many files of which only a few are changed
between viewing sessions. Cache files can also be exported from some
CAD applications where a native file reader is not available with
NavisWorks. Cache options can be edited from the Global Options
dialog box under the Tools menu.

Published .nwd files are useful when wanting to take a snapshot of the
model at a certain time. All the geometry and review information is saved
into the .nwd file and cannot then be changed. Published .nwd files can
also contain information about the file, as well as being able to be
password protected and time-bombed for security. These files are also
very small, compressing the CAD data by up to 80% of the original size.

Published .nwd files are useful when issuing models for viewing by
others with the NavisWorks Freedom free viewer, as well as being
appendable themselves into NavisWorks to build up a larger scene.

Review files are useful when using the native CAD files appended into
NavisWorks. They store the location of the appended files, along with
any design reviews made in NavisWorks, such as comments, redlines,
viewpoints, animations and so on.

If a group of files is appended into a NavisWorks scene, and saved as an
.nwf file, then on re-opening this .nwf file later, once the original CAD
files have been changed, the updated CAD files will be loaded into the
scene for review.

External references (sometimes called reference files or "XRefs") are
shown in NavisWorks selection tree as an inserted group. NavisWorks
looks for the externally referenced files in the same place as AutoCAD or
MicroStation would.

If the Unresolved XRef dialog box is shown, then this link has somehow
been broken and the referenced files need to be relocated to where
AutoCAD or MicroStation would expect them to be.

If these XRefs are not important for the current session, then you can
Ignore the reference and the file will load without that XRef inserted.
Similarly, Ignore All will load the file without any unresolved XRefs.

You can also use the DWG/DXF and DGN options in the Tools, Global
Options dialog to set whether external references are loaded or not,
giving you more control over file appending into NavisWorks.

During an export from a CAD package to .nwc, or while NavisWorks is
reading a native CAD file, decisions must be made as how a curved
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surface is reduced to flat facets. For most applications and file formats,
you have control over the level of faceting that takes place.

All items, no matter what their size, will use the same faceting factor and
so have the same number of sides to curved entities. Therefore, you
need to experiment a little with different values to account for the size
that these items will appear on screen.

The faceting factor must be greater or equal to 0, where 0 results in the
faceting factor being turned off. The default value is 1, if you double the
value you get twice the number of facets, if you halve the value you get
half as many facets. Larger faceting factors will result in more polygons
to a model and larger NavisWorks files. There is little point having a large
faceting factor if these curved entities are golf balls viewed from 200
yards!

For AutoCAD exports, the faceting factor is set from the NWCOPT
command, MicroStation's faceting factor is set from Options, which is
available from the NWCOUT export dialog, and the option to set the
faceting factor on reading CAD files is found by choosing Tools, Global
Options, and the relevant options tab.

Max Facet Deviation
Maximum facet deviation is used in conjunction with faceting factor to
ensure that larger objects, with too large a deviation from the original,
have additional facets added. If a difference greater than the entered
value is found in a model it adds more facets. The values are measured
in the model units.

d

Where d is greater than the maximum faceting deviation value, more
facets are added to the object.

If the max faceting deviation is set to 0, then this function is ignored and
just the faceting factor is used.

Shape Merge Threshold
MicroStation shapes are polygons that can have 3 or more vertices.
They're often used to model more complex objects which can waste
memory. So, NavisWorks merges all shapes on the same level or in the
same cell and with the same color into a "Shape Set" if these shapes
have less than or equal to the number of vertices given by the Shape
Merge Threshold.

Selection Terminology
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These are terms specific to NavisWorks that are used in relation to selecting items.

Composite Objects

Instances

Item Name

Item Type

Selection Resolution

User Name and Internal Name

A composite object is a group of geometry that is considered a single
object in the selection tree. For example, a window object might be made
up of a frame and a pane. If a composite object, the window object would
be both the frame and the pane and be selected all at once.

An instance is a single object, which is referred to several times within a
model, for example a tree. This has the advantage of cutting down on file
size by not unnecessarily repeating an object.

The original CAD or NavisWorks assigned identifier. Any item can have a
name and this name will usually come from the original CAD package
that the model was created in.

Every item in NavisWorks has a type. Examples of types are reference
files, layers, instances (sometimes called inserts) and groups. Every
CAD package also has a number of geometry types, for example,
polygons, 3D Solids and so on.

The selection resolution is the level in the selection tree you start
selecting at. You can cycle through items in the tree by holding down the
shift key during a selection.

Each category and property name has two parts - a user visible string
which is localized and an internal string which isn't and is mainly used by
the API. By default when matching names in the Smart Tags and Find
Items dialogs, both parts must be the same, but you can use the flags to
match only on one part. You might use ignore user name if you wanted
to match something irrespective of which localized version was being
used.

Viewpoint Terminology

Angular Speed

Aspect Ratio

Anti-aliasing

The speed that the camera moves when turning right and left in any
navigation mode.

Aspect ratio is the proportion of x-axis to y-axis size. For example, in
exporting a bitmap of a viewpoint, maintaining the aspect ratio would
keep the proportion of the view even if the number of pixels was
different.

Anti-aliasing improves image quality by softening the jagged edge
appearance of sharp lines. 2x to 64x refers to the extra number of frames
that are required for the anti-aliasing process. The greater the number of
frames, the finer the effect, (with the consequent increase in rendering
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Camera-Centric

Field of View

Focal Point

Model-Centric

Roll

Saved Attributes

Tilt Angle

World Up Vector

time).

Navigation modes in which the camera is moved around the model (c.f.
model-centric).

The field of view of a camera is the angle that the camera can see. A
large field of view will fit more into the view, but will look distorted and a
small field of view will tend to make the view more flat, tending towards
an orthographic view. There are two fields of view in NavisWorks -
vertical and horizontal. Editing one will change the other and the two are
related by the viewpoint's aspect ratio.

The focal point is the position in 3D space that the camera will rotate
around or zoom into in examine, orbit, turntable and zoom modes.

Navigation modes in which the model is moved in front of the camera
(c.f. camera-centric).

The roll of the camera is its angle around the viewing axis. This cannot
be edited in a navigation mode where the world up vector stays upright
(walk, orbit and turntable).

Each viewpoint can optionally save the state of its hidden and "required"
items, as well as any material (color and transparency) overrides. Then,
on recalling the viewpoint, those same items are re-hidden, re-made
required, and the materials reinstated. This can be useful in the creation
of animations when dragging on viewpoints onto an empty animation.

This is indicated in the scene's units below (negative) or above (positive)
horizontal (0) at the base of the tilt bar.

The direction that NavisWorks considers "up" is called the "world-up
vector". This is maintained in the walk, orbit and turntable modes.
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Symbols

A

3D motion controller , 32

animation , 71
animations

playing , 72

background color , 55

camera

orthographic , 27
perspective , 27

collision detection, 27
commenting , 73
crouching, 29

culling

options , 55

directory

search , 89

display

batch fill, 61

detail, 61

hardware acceleration, 60
heads up mode, 61

line size, 61

occlusion culling, 60
options , 60

parametric primitives, 61
point size, 61

show camera position, 61
show position, 61

shap point size, 61
transparency, 60

DWEF files , 18

file reader options , 18

editing , 43
examining , 23

file management, 15
files

new, 15
opening, 15

opening URL, 16
reading , 18
finding , 41
properties , 41
flying , 24
focusing , 26
frame rate , 58
guaranteed, 61
full lights , 51
full render , 52

gravity, 29

hardware acceleration, 60
head light , 48

options , 48
help , 99

About , 101

NavisWorks , 99
online , 100
System Info , 101
topics , 99

what's this? , 100
hidden line render , 53
hiding items , 45

unselected , 46
hyperlinks , 74

displaying , 74

following , 75

options , 75

interactive selection , 36

interface
smarrttags_definition, 79
standard hyperlinks, 76
user hyperlinks, 77

item properties
resetting , 46

lighting , 47
full lights , 51
head light
(see also head light)
scene lights
(see also scene lights )
lines , 54
looking around , 21

menu
File, 15

112



Index

navigating , 20

examining , 23

flying , 24

looking around , 21

modes , 20

orbiting , 23

panning , 22 S

spinning , 24

walking , 21

zooming , 22

zooming to a box , 22
navigation tools , 25
NavisWorks published files , 18
NWD files , 18

options
developer, 88
file, 91
global, 93
location, 91
orbiting , 23
orientation, 57
orthographic camera , 27

panning , 22
performance options, 61
perspective camera , 27
points , 54
Presenter
options , 63
primitives , 53
lines , 54
points , 54
shap points , 54
surfaces , 53
text, 55
printing, 16
current viewpoint, 16
previewing, 17
setup, 17
profiles , 88

quitting, 17 T

reading files , 18
redo , 43
render modes , 52
full , 52
hidden line , 53

shaded , 52

wireframe , 53
rendering

styles , 47
required items , 45
reviewing

commenting , 73

scene lights , 49
options , 50
search directories , 89
search sets , 38
searching
(see also finding )
selection commands , 37
all, 37
invert, 38
multiple instances, 38
none, 38
same name, 38
same type, 38
selection options , 39
selection resolution , 38
first object, 39
geometry, 39
last object, 39
last unique, 39
layer, 39
model, 39
selection sets , 38
recalling , 38
selection trees , 34
shaded render , 52
showing items , 46

simulate
tab , 104
smart tags , 78
Smart Tags
options , 79
shap points , 54
spaceball , 32

spacemouse , 32
spacetraveler , 32
spinning , 24
straighten , 31
surfaces , 53

text , 55

third person
avatar, 30

TimeLiner
overview , 103

tools , 90

transparency, 60
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undo , 43
options , 44

units , 87
options , 87

viewing
everything , 26
selected items , 26

viewpoints
align X, 30
aligny, 31
align z, 31
control bar , 66
editing , 67
preset, 30
recalling , 66

walking , 21
wireframe render , 53
world up vector , 32

zooming , 22
to a box , 22
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