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Copyright and Disclaimer
Product specifications are subject to change without notice and do not represent a commitment on the part of Avid Technology, 
Inc.

The software described in this document is furnished under a license agreement. You can obtain a copy of that license by 
visiting Avid's Web site at www.avid.com. The terms of that license are also available in the product in the same directory as 
the software. The software may not be reverse assembled and may be used or copied only in accordance with the terms of the 
license agreement. It is against the law to copy the software on any medium except as specifically allowed in the license 
agreement.

Avid products or portions thereof are protected by one or more of the following United States Patents: 4,746,994; 4,970,663; 
5,045,940; 5,267,351; 5,309,528; 5,355,450; 5,396,594; 5,440,348; 5,452,378; 5,467,288; 5,513,375; 5,528,310; 5,557,423; 
5,577,190; 5,583,496; 5,584,006; 5,627,765; 5,640,601; 5,644,364; 5,654,737; 5,715,018; 5,719,570; 5,724,605; 5,726,717; 
5,729,673; 5,745,637; 5,752,029; 5,754,851; 5,799,150; 5,812,216; 5,828,678; 5,842,014; 5,852,435; 5,999,406; 6,038,573; 
6,061,758; 6,141,007; 6,211,869; 6,532,043; 6,546,190; 6,596,031; 6,636,869; 6,747,705; 6,763,523; 6,766,357; 6,813,622; 
6,847,373; 7,081,900; D352,278; D372,478; D373,778; D392,267; D392,268; D392,269; D395,291; D396,853; D398,912. 
Other patents are pending.

This document is protected under copyright law.  An authorized licensee of  Avid Thunder products may reproduce this 
publication for the licensee’s own use in learning how to use the software. This document may not be reproduced or 
distributed, in whole or in part, for commercial purposes, such as selling copies of this document or providing support or 
educational services to others. This document is supplied as a guide for Avid Thunder products. Reasonable care has been 
taken in preparing the information it contains. However, this document may contain omissions, technical inaccuracies, or 
typographical errors. Avid Technology, Inc. does not accept responsibility of any kind for customers’ losses due to the use of 
this document. Product specifications are subject to change without notice.

Copyright © 2006 Avid Technology, Inc. and its licensors. All rights reserved.

Attn. Government User(s). Restricted Rights Legend
U.S. GOVERNMENT RESTRICTED RIGHTS. This Software and its documentation are “commercial computer software” or 
“commercial computer software documentation.” In the event that such Software or documentation is acquired by or on behalf 
of a unit or agency of the U.S. Government, all rights with respect to this Software and documentation are subject to the terms 
of the License Agreement, pursuant to FAR §12.212(a) and/or DFARS §227.7202-1(a), as applicable.

Trademarks
888 I/O, Adrenaline, AirPlay, AirSPACE, AirSPACE HD, AirSpeed, AniMatte, AudioSuite, AudioVision, AutoSync, Avid, 
Avid DNA, Avid DNxcel, Avid DNxHD, AVIDdrive, AVIDdrive Towers, Avid DS Assist Station, Avid ISIS, 
Avid Learning Excellerator, Avid Liquid, Avid Mojo, AvidNet, AvidNetwork, Avid Remote Response, AVIDstripe, Avid Unity, 
Avid Unity ISIS, Avid Xpress, AVoption, AVX, CamCutter, ChromaCurve, ChromaWheel, DAE, Dazzle, Deko, Deko2200, 
DekoCast, D-Fi, D-fx, DigiDelivery, Digidesign, Digidesign Audio Engine, Digidesign Intelligent Noise Reduction, DigiDrive, 
Digital Nonlinear Accelerator, DigiTranslator, DINR, DNxchange, do more, D-Verb, Equinox, ExpertRender, Face Robot, 
FieldPak, Film Composer, FilmScribe, FluidMotion, FXDeko II, HIIP, HyperSPACE, HyperSPACE HDCAM, IllusionFX, 
Image Independence, iNEWS, iNEWS ControlAir, Instinct, Interplay, Intraframe, iS9, iS18, iS23, iS36, LaunchPad, Lightning, 
Lo-Fi, Magic Mask, make manage move | media, Marquee, Matador, Maxim, MCXpress, Media Browse, Media Composer, 
MediaDock, MediaDock Shuttle, Media Fusion, Media Illusion, MediaLog, Media Reader, Media Recorder, MEDIArray, 
MediaShare, MediaStream, Meridien, MetaSync, MissionControl, NaturalMatch, Nearchive, NetReview, NewsCutter, Nitris, 
OMF, OMF Interchange, OMM, Open Media Framework, Open Media Management, PCTV, Pinnacle MediaSuite, 
Pinnacle Studio, Pinnacle Systems, ProEncode, Pro Tools, QuietDrive, Recti-Fi, RetroLoop, rS9, rS18, Sci-Fi, ScriptSync, 
SecureProductionEnvironment, Show Center, Softimage, Sound Designer II, SPACE, SPACEShift, SpectraGraph, 
SpectraMatte, SteadyGlide, Symphony, TARGA, Thunder, Trilligent, UnityRAID, Vari-Fi, Video RAID, Video Slave Driver, 
VideoSPACE, and Xdeck are either registered trademarks or trademarks of Avid Technology, Inc. in the United States and/or 
other countries.

Windows is either a registered trademark or trademark of Microsoft Corporation in the United States and/or other countries. 
Quantel, Video PaintBox, PaintBox, PictureBox and PictureBank are trademarks of Quantel. All other trademarks contained 
herein are the property of their respective owners.

GOT FOOTAGE?

Editors — Filmmakers — Special Effects Artists — Game Developers — Animators — Educators — Broadcasters — Content 
creators of every genre — Just finished an incredible project and want to share it with the world?

Send us your reels and we may use your footage in our show reel or demo!*

For a copy of our release and Avid’s mailing address, go to www.avid.com/footage.

*Note: Avid cannot guarantee the use of materials submitted.

http://www.avid.com
http://www.avid.com/footage


3

Avid Thunder Products User’s Guide • 0130-07656-01B • November 2006



  

4



Contents

Contents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5

Using This Guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  13

Symbols and Conventions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  13

If You Need Help. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  14

Accessing the Online Library  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  15

How to Order Documentation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  15

Avid Training Services  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  15

Chapter 1 Fundamentals . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  17

Starting Thunder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  18

Using Thunder Hybrid Systems  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  19

Opening a Database . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  19

User Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  20

Network Tree. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  21

Browse Window  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  23

Picons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  24

Selecting Picons. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  26

Picon Sizes. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  27

Copy and Replace Still Picons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  28

Show Picture  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  28

Clip Numbers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  29

MiniMonitor Window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  30

Hardware Channels . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  31

Software Channels . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  32

Function Controls . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  32

Preview Dialog Box . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  32

Dockable Items . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  33

Selecting Images. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  34



6

Workspaces . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  35

Copying Clips, Stills, and Sequences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  36

Copying Clips and Stills Between Sequences. . . . . . . . . . . . . . . . . . . . . . . . . .  37

Status Bar. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  40

Background Tasks. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  40

Numeric Keypad. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  41

Chapter 2 File Management  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  43

Copying Clips and Stills . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  43

Deleting Clips and Stills . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  44

Importing Clips and Stills . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  45

Importing Images into the Thunder Database . . . . . . . . . . . . . . . . . . . . . . . . . .  46

Dragging and Dropping an Image into the Thunder Database . . . . . . . . . . . . .  47

Copying an Image to the Clipboard and then to the Thunder Database . . . . . .  47

Import/Export Options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  47

Overwriting Items  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  48

Default Database. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  50

Modifying Image File Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  51

Renumbering Clips and Stills . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  52

Chapter 3 Working with Clips . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  55

Recording a Clip. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  55

Clip Recording Methods  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  58

Bad Frames. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  61

Recording a Clip from a VTR. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  61

Creating Subclips . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  64

Inserting a Clip . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  68

Clips with Keys. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  69

Editing Clips . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  69

Using the Item Properties Dialog Box . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  69

Using the Preview Dialog Box . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  71

Playing Clips. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  72

Clip Playback and Encoding . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  73

Cueing Clips  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  73

Previewing Clips . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  74



7

Playing in Program Channel. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  74

Directed Play in a Database Window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  75

Directed Play in a Sequence Window  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  76

Clip Picons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  77

Changing a Clip’s Picon . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  78

Playing Clips and Stills Together (Compound Playout) . . . . . . . . . . . . . . . . . . .  79

Playing Clips in a Sequence . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  82

Selecting Multiple Clips  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  83

Adding Clips into the Middle of a Sequence. . . . . . . . . . . . . . . . . . . . . . . . . . . .  83

Adding Clips to the End of a Sequence . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  83

Sequence Play . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  84

Item Properties . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  86

Chapter 4 Working with Stills . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  89

Capturing Stills With the Air Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  89

Using the Air Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  90

Playing Bugs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  93

Using Animated Logos . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  95

Unloading Bug Layers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  96

Playing Stills . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  96

Cueing a Still  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  96

Previewing a Still  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  97

Item Properties Dialog Box for Still Images. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  98

Adding Titles to Stills with PostDeko. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  99

Accessing PostDeko  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  99

Saving an Image File and Title in PostDeko  . . . . . . . . . . . . . . . . . . . . . . . . . .  100

Closing a File in PostDeko . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  100

Editing a Title in PostDeko . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  101

Exporting a Title File. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  101

Chapter 5 Working with Sequences. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  103

Creating Sequences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  103

Inserting an Image File or Clip into a Sequence  . . . . . . . . . . . . . . . . . . . . . . .  104

Selecting Multiple Clips or Still Files. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  105

Adding Clips or Stills into the Middle of a Sequence . . . . . . . . . . . . . . . . . . . .  105



8

Adding Clips or Stills to the End of a Sequence . . . . . . . . . . . . . . . . . . . . . . .  105

Default Item Properties . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  106

Editing Sequences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  107

Making Changes to an Event within a Sequence . . . . . . . . . . . . . . . . . . . . . .  108

Item Properties — Sequence Tab . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  110

Playing Sequences. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  112

Moving the Play Box to Another Event . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  114

Using the Play Modes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  114

Previewing Events . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  115

Playing Events . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  115

Using the General Purpose Interface (GPI) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  116

GPI Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  117

Chapter 6 Working with Databases  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  119

Connecting to a Lightning or another Thunder. . . . . . . . . . . . . . . . . . . . . . . . . . . .  120

Connecting to an ENPS Network . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  121

Creating a New Database  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  122

Setting the Default Database . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  125

Setting Database Options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  126

Removing All Locks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  128

Restoring the Full Database. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  129

Showing Properties for a Database File. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  130

Searching the Workspace  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  131

Search Syntax Rules. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  133

Security Database . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  134

Network Tree . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  135

Workspace Search. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  137

Database Section  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  138

Workspace Section . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  138

Search Section  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  139

Chapter 7 Working with Layouts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  141

Using Layouts. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  141

Creating Layouts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  144

Changing the Placement of an Image . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  145



9

Changing the Size of an Image  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  146

Cropping an Image. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  148

Chapter 8 Working with DNA  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  149

Creating DNA Entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  149

Browse a ClipDeko Database . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  153

Connecting to a Quantel Product  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  154

Connecting to an FTP Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  156

Connecting to a Chyron Product . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  157

Appendix A File Formats and Options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  161

Image File Formats . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  161

Supported Formats. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  162

Unsupported Formats. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  163

Software Application Key  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  164

Adding Options to Thunder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  164

Hints and Tips . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  165

General. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  165

Databases  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  165

Sequences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  166

Paint . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  166

Appendix B Thunder Toolbars and Menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  167

Main Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  168

Air Toolbar. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  169

Sequence Toolbar. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  170

VTR Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  171

MiniMonitor Window — MiniMonitor Section. . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  173

MiniMonitor Window — Control Section . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  175

Contexts and Controllers. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  176

Title Bar. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  177

Move. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  178

Size  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  178

Minimize . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  178

Maximize  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  178

Close  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  179



10

Next Window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  179

Exit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  179

Scroll Bars  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  180

Right-Click Menus  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  181

File Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  183

File > New Sequence  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  184

File > Open . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  185

File > Close . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  186

File > Save  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  186

File > Save As . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  186

File > Lock Database. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  187

File > Logout . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  187

File > Print . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  188

File > Print Preview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  189

File > Page Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  190

File > Preferences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  191

File > Advanced Menu. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  221

Edit Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  228

Edit > Cut. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  230

Edit > Copy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  230

Edit > Paste . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  230

Edit > Paste Master Clip . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  231

Edit > Delete . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  231

Edit > Insert . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  231

Edit > Select All . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  232

Edit > Renumber . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  232

Edit > Edit Layouts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  234

Edit > Edit Template  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  235

View Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  249

View > Show Main Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  251

View > Show Air Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  251

View > Show MiniMonitors  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  251

View > Show Tree . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  252



11

View > Show VTR Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  252

View > Show Status Bar. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  253

View > Text Mode  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  255

View > Select Details . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  257

View > Large, Small, or Tiny Images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  258

View > Sort Images  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  258

View > Key Image  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  260

View > Workspace/Search . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  261

View > Refresh. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  262

View > Independent Context  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  262

Air Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  263

Air > Take. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  266

Air > Freeze . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  266

Air > Filter . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  266

Air > Save Still  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  267

Air > Quick Save Still . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  268

Window Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  268

Window > New Window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  269

Window > Cascade  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  270

Window > Tile. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  270

Window > Arrange Icons  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  271

Window > Toolbar Layouts. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  272

Window > 1, 2... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  273

Help Menu. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  273

Help > Tip Of The Day . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  274

Help > Help Topics. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  274

Help > Display Input Status . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  275

Help > About... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  275

Appendix C Using ODBC on Thunder and Browse Systems . . . . . . . . . . . . . . . . . .  277

Enabling the ODBC Option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  277

Setting Up an ODBC Database. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  285

Index  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  287



12



Using This Guide

Congratulations on your purchase of an Avid® broadcast database server. You can use your 
application to create broadcast-quality output incorporating every possible production 
element from full-speed, high-resolution footage, to multimedia artwork and animation, to 
computer-generated effects and titling.

This guide contains all the task-oriented instructions, conceptual information, and reference 
material you need to use the effects and titling features of your Avid broadcast database 
server.

This guide is intended for all Thunder® and Thunder Browse users, from beginning to 
advanced. When Thunder is mentioned, it applies to Thunder Browse as well.

Thunder Browse is a software-only version of Thunder that allows remote users from any 
PC to connect to any Thunder database.  Thunder Browse provides remote content browsing 
and management and enables users to perform such tasks as browsing media, previewing 
stills and clips, trimming clips, deleting and copying files, and creating sequences. Remote 
control also includes complete record and playback capability, allowing a Thunder channel 
to be controlled from a separate control room.

n The documentation describes the features and hardware of all models. Therefore, your 
system might not contain certain features and hardware that are covered in the 
documentation.

Symbols and Conventions

Avid documentation uses the following symbols and conventions:

Symbol or Convention Meaning or Action

n A note provides important related information, reminders, 
recommendations, and strong suggestions.

c A caution means that a specific action you take could cause harm to 
your computer or cause you to lose data.
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If You Need Help

If you are having trouble using Thunder:

1. Retry the action, carefully following the instructions given for that task in this guide. It 
is especially important to check each step of your workflow.

2. Check for the latest information that might have become available after the 
documentation was published:

- If the latest information for your Avid product is provided as printed release notes, 
they ship with your application and are also available online.

- If the latest information for your Avid product is provided as a ReadMe file, it is 
supplied in your Avid application folder as a PDF document (ReadMe.pdf) and is 
also available online.

You should always check online for the most up-to-date ReadMe because the 
online version is updated whenever new information becomes available. To 
view the online ReadMe, select ReadMe from the Help menu, or visit the 
Knowledge Base at www.avid.com/readme.

3. Check the documentation that came with your Avid application or your hardware for 
maintenance or hardware-related issues.

w A warning describes an action that could cause you physical harm. 
Follow the guidelines in this document or on the unit itself when 
handling electrical equipment.

> This symbol indicates menu commands (and subcommands) in the 
order you select them. For example, File > Import means to open the 
File menu and then select the Import command.

t This symbol indicates a single-step procedure. Multiple arrows in a 
list indicate that you perform one of the actions listed.

Margin tips In the margin, you will find tips that help you perform tasks more 
easily and efficiently.

Italic font Italic font is used to emphasize certain words and to indicate variables.

Courier Bold font Courier Bold font identifies text that you type.

Ctrl+key or mouse action Press and hold the first key while you press the last key or perform the 
mouse action. For example, Ctrl+drag.

Symbol or Convention Meaning or Action

http://www.avid.com/readme 
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4. Visit the online Knowledge Base at www.avid.com/onlinesupport. Online services are 
available 24 hours per day, 7 days per week. Search this online Knowledge Base to find 
answers, to view error messages, to access troubleshooting tips, to download updates, 
and to read or join online message-board discussions.

Accessing the Online Library

The Thunder Online Library CD-ROM contains all the product documentation in PDF 
format. You can access the library from the Online Library CD-ROM or from the Help 
menu.

n You will need Adobe® Acrobat® Reader® to view the documentation online. You can 
download the latest version from the Adobe web site. 

To access the online library from the Online Library CD-ROM:

1. Insert the Online Library CD-ROM into the drive.

2. Double-click the Mainmenu file.

How to Order Documentation

To order additional copies of this documentation from within the United States, call Avid 
Sales at 800-949-AVID (800-949-2843). If you are placing an order from outside the United 
States, contact your local Avid representative.

Avid Training Services

Avid makes lifelong learning, career advancement, and personal development easy and 
convenient. Avid understands that the knowledge you need to differentiate yourself is always 
changing, and Avid continually updates course content and offers new training delivery 
methods that accommodate your pressured and competitive work environment.

To learn about Avid's new online learning environment, Avid Learning Excellerator™ 
(ALEX), visit http://learn.avid.com.

For information on courses/schedules, training centers, certifications, courseware, and 
books, please visit www.avid.com/training or call Avid Sales at 800-949-AVID 
(800-949-2843).

http://www.avid.com/onlinesupport
http://learn.avid.com
http://www.avid.com/training
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Chapter 1

Fundamentals

This chapter describes an overview of the various components of the Thunder application.

The following sections are included:

• Starting Thunder

• Using Thunder Hybrid Systems

• Opening a Database

• User Interface

• Network Tree

• Browse Window

• Picons

• MiniMonitor Window

• Preview Dialog Box

• Dockable Items

• Selecting Images

• Workspaces

• Status Bar

• Numeric Keypad
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Starting Thunder

During the installation process, a shortcut to Thunder was installed on your 
computer’s desktop. 

1. Log into Windows® XP.

2. Double-click on the shortcut to launch Thunder.

If a security database has been set up, Thunder will prompt you to enter your ID name 
and Password in the Login dialog box. In case you need administrator privileges for this 
system, the default administrators’s password is “avid”.

3. Type the appropriate information and click the OK box or press Enter. 

Thunder will then give you access to the database. If no security database exists, you can 
skip this stage.

4. After reading the tip of the day, you can choose to receive tips every time you start 
Thunder, to see another tip, or just close the “Tip of the day” window.
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Using Thunder Hybrid Systems

If your system is a Thunder Hybrid (HY), you can work with both standard-definition (SD) 
and high-definition (HD) formats on the same system. Therefore, you will need to know how 
to switch between SD and HD formats.

To switch from one format to another:

1. Select File > Preferences > Channel Configuration.

2. Select the desired SD or HD video standard from the Video Standard list.

3. Click OK.

4. Restart the system. 

The system launches in the selected video standard.

Opening a Database

A database in Thunder is a collection of clips and stills, represented by thumbnail images 
called picons, and associated data. This data includes the name of the clip or image file, 
notes about its content, the dates captured, and so on. If the Thunder system has multiple 
databases installed, or if you have many machines networked together, there can be several 
folders in the Network Tree. Thunder Browse can also have its own databases, which show 
up in this location.
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1. Double-click on a folder. The contents of the folder display in the Network Tree. A 
folder named DNA (Dynamic Network Access) is a folder containing the DNA 
connections available to this machine. This is optional software and might not be 
present on your system.

2. Double-click on the icon for the .pff file (.pff is extension for an image database in 
Thunder). The database opens. The network tree shows all of the databases that your 
system is aware of. If no folders are shown, there are no databases currently selected on 
your system.

3. If you know a database exists somewhere on your system, select File > Open, and 
navigate to the location of the database. 

4. If there are no other databases on your system, create one by selecting File > Advanced 
> Create New Database. For more information, see “Creating a New Database” on 
page 122.

User Interface

Thunder has a graphic user interface incorporating windows, toolbars and menus similar to 
other Windows-based applications. The following illustration identifies the key elements of 
the Thunder user interface. The function and use of these elements is discussed in this 
chapter and throughout this guide.
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Network Tree
Keyboard shortcut: Ctrl+T

Use the keyboard shortcut to show or hide the Network Tree.
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The Network Tree shows each Thunder or Lightning workstation with its associated files. 
Each system is represented as a folder. To open a folder, click on the + sign to the left of the 
folder or double-click on the folder title. Once open, a list of databases on that system 
appears, followed by a list of sequences. 

A database is identified by the blue Thunder icon and a .pff file extension. A sequence 
associated with a database is listed directly below the database and has a .seq extension. To 
open a database or sequence, double-click the left mouse button on the icon or name. 

The lowest system shown in the example is labeled DNA (Dynamic Network Access) and is 
neither Lightning nor Thunder. Rather, it is a folder containing the DNA connections 
available to this machine. DNA is a software option; consequently your system might not 
show this network. 

The Tree can be shown or hidden by using the Tree View command in the View Menu. A 
check mark next to the menu item indicates the Tree is visible. For more information, see 
“Network Tree” on page 135.
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Browse Window

The Browse Window, shown in the illustration below, is a picon view of a sequence (top) or 
a database (bottom) and has several modes and sort orders. The blue title bar indicates that 
this sequence window is active, while the gray indicates that the database window is 
not active.

If you want to change the order and quantity of fields for the database and sequence 
windows, click View > Select Details. See “View > Select Details” on page 257. 

Picons might have additional symbols on them to identify the files they represent. For 
information on these symbols, see “Picons” on page 24.
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To change the sort order of the clips and image files in a database view:

1. Click View > Details or press Ctrl+F2. 

2. Click on the criteria to sort by at the top of the window (Title, Category, User, and so 
on). Alternatively, you can use a shortcut button on the Main Toolbar to access the 
Details view.

Picons

The term “Picon” is an abbreviation for Picture Icon, and refers to individual image files and 
clips used in Thunder’s database and sequence windows. Picons might have additional 
symbols on them to identify the kinds of files they represent. The following is an example of 
a picon representing a still image. Picons represent image files and clip files that Thunder 
stores and manages.
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Green film icon upper right corner: This image is a clip residing on Thunder or another clip 
server. When the film icon turns RED, the clip will not play. For help in correcting the 
problem, see “Clip Picons” on page 77. 

Green film icon with shortcut arrow: This image is a sub-clip of the original. It contains 
instructions to play a portion of the original clip as edited.

Yellow key icon upper left corner: This still image file has an associated Key that will be 
played back along with the video when placed on a hardware channel. Clips might also have 
keys associated with them.

Yellow rectangle lower left corner: This picon represents a 16x9 image. Thunder displays 
anamorphic saved images.
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When you first save a clip in Thunder, you have a choice of picons. You can specify an 
all-black picon and select a representative frame for the picon later. For more information, 
see “Recording a Clip” on page 55.

The following topics provide more information about picons:

• “Selecting Picons” on page 26

• “Picon Sizes” on page 27

• “Copy and Replace Still Picons” on page 28

• “Show Picture” on page 28

• “Clip Numbers” on page 29

Selecting Picons

Select picons by clicking, Shift+clicking, and Ctrl+clicking on them using standard 
Windows techniques. 

For more information, see “Selecting Images” on page 34.
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Picon Sizes

There are several methods to change Picon size in Thunder. Picon size can be changed 
among large, small and tiny images. 

To change the Picon size, do one of the following:

t Click View and select the size you want (Tiny, Small, or Large).

t Click the Picon size icon you want in the Main Toolbar.

t Right-click on the database window (not on a picon) and select the size you want (Tiny, 
Small, or Large).
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Copy and Replace Still Picons

To copy a still image file:

t Right-click on a picon and drag the mouse over another picon. 

The Copy and Replace popup menu appears. Some functions only pertain to clips. For 
more information on these shortcuts, see “Right-Click Menus” on page 181.

Show Picture

The clip or image file’s picon can be enlarged, allowing you to examine the details more 
closely. Depending on the size of your SVGA monitor, you might have to rearrange toolbars 
or temporarily hide the MiniMonitors or Database window to make room for the Show 
Picture window. 

If you find imperfections in a still image that you want to touch-up, close the Show Picture 
window and start Windows Paint or another graphic application.

To enlarge a picon’s image:

t Right-click on the picon and select Show Picture from the menu.

The picon opens in a separate window at 400%.
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To close the Show Picture window and return to your previous Thunder window, do 
one of the following:

t Double-click on the Avid icon represented by a red P in the upper left corner of the 
window.

t Click the Close button in the Window.

Clip Numbers

Each clip has an individual number, and where applicable, a workspace number and a 
database number. In this example, clip number 41 from Workspace 5 in Database 2, is 
identified by this number: 2.5.41.
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If you are working in only one database, the clips reflect just the workspace and individual 
numbers, such as: 5.41.

When only Workspace 0 is open, the clips have only their individual numbers. For example, 
the clip above would have only the number 41.

Clips will play individually from any workspace and any database that is accessible from the 
Thunder. The same clips can be placed in a sequence and played as long as they all belong to 
the same database.

MiniMonitor Window 

This window has two major areas: the Control section to the left and the MiniMonitor 
section to the right. The MiniMonitor window might be hidden and revealed using the View 
menu, or by selecting Ctrl+M. A check mark in the View menu indicates that the 
MiniMonitor window is currently visible.

The Control section contains the following selections:

• Transition — The transition is used for takes

• Duration — The duration of the transition in hours, minutes, seconds and frames

• Input — The input source used for live video

Control section MiniMonitor section
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The down triangle to the right of each control opens a pull-down list of additional available 
selections. The current Context is shown underneath the Input field. A Context indicates the 
assignment of items to an individual controller such as an automation controller or the 
QWERTY keyboard.

Each MiniMonitor has the components shown in the following figure.

The MiniMonitor section contains multiple individual MiniMonitors. Each MiniMonitor 
corresponds to a system channel and can be turned on or off in the Channel Configuration 
dialog box. For more information, see “File > Preferences > Channel Configuration” on 
page 193. There are two kinds of system channels: hardware and software.

The following topics provide more information about the MiniMonitor Window:

• “Hardware Channels” on page 31

• “Software Channels” on page 32

• “Function Controls” on page 32

Hardware Channels

Thunder has one to three hardware channels. Each hardware channel can be assigned as the 
Program channel, the Preview channel or the Live channel, or some combination of the 
three. For example, you can configure a single hardware channel as Program, Preview, and 
Live simultaneously.

System channel number

Play nodes

Cue window

Bug windowBug fader

next clip in cue

Clip number

Function controls
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Software Channels

The system also supports Soft channels, which are software only. You can use them as a 
Preview channel if you desire. Although these channels have no hardware associated with 
them, frame buffers allow them to be included in the user interface. The MiniMonitor 
section displays the picon of the current clip or image file on that output. Below left of the 
picon is the clip’s or image file’s number, and below right is the name of that output as 
assigned in the Channel Configuration dialog box. For more information, see “File > 
Preferences > Channel Configuration” on page 193.

Function Controls

Each MiniMonitor has three function controls. The indicator lights vary depending on how 
the channel is currently programmed: 

While you can separate these functions onto different MiniMonitors, we recommend that 
you keep them together on one.

You can lock channel assignments so they don’t change, or link them so they change 
together. For more information, see “Air Toolbar” on page 169 and “File > Preferences > 
Channel Assignments” on page 196.

Preview Dialog Box

The Preview dialog box, also called Preview window, enables you to do the following 
with clips:

• Play clips with audio on the VGA monitor

• Scrub and trim clips

• Mark in and out points

• Create subclips

• Set loop points and times

• Set picons

Indicator  Color Video

Left Red Program

Center Yellow Preview

Right Green Live
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• Create stills

To access the Preview window:

1. Select the picon of the clip.

2. Do one of the following:

t Press F3.

t Right-click on the picon and select Preview from the menu.

For more information, see “Using the Preview Dialog Box” on page 71.

.

Dockable Items

The MiniMonitor window and the Network Tree, along with the Main toolbar, the Air 
toolbar and the VTR toolbar are all dockable items. This means they can be moved about the 
screen in horizontal or vertical orientation. Double-click the left mouse button on the 
background inside one of the above items, and the bar will be undocked. You can then place 
it anywhere you like. When you close the application, Thunder remembers the new location 
for these toolbars.

When there is more than one user, each can save and later recall their own preferred layout 
under “Window > Toolbar Layouts” on page 272.
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n Toolbars and windows can sometimes “disappear” when they are moved. For example, the 
toolbar might have moved behind another object where you cannot see it. To locate the 
missing toolbar, use the View menu to hide each of the tools one by one until you locate the 
missing toolbar. You can then reposition it where it is visible.

Selecting Images

There are two methods for selecting multiple images (clips or still image files). 

To select individual clips

t Ctrl+click and select individual clips.

To select a series of clips

t Shift+click and select consecutive clips.

n You can also use this method to select events in a sequence.

Example of selecting individual clips

In the following database window, clip 0 in the upper left corner was clicked on and while 
holding down the Ctrl key, clip 12 in the lower right corner was clicked on. Only those two 
clips are selected.

.
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Example of selecting a series of clips

In the following database window, clip 0 in the upper left corner was clicked on and while 
holding down the Shift key and clicking on clip 12 in the lower right corner, all clips 
between 0 and 12 are selected. 

Workspaces

Workspaces can be thought of as folders, which subdivide the main database. Individual 
workspaces have their own set of permissions. Certain users can be granted access to a 
specific workspace, while others cannot. This concept of workspaces is fundamental to the 
operation of the database search engine.
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To show the accessible workspaces, do one of the following:

t Select View > Workspace/Search.

t Press F4, to display the Workspace/ Search dialog box.

If Security Administrator software was not purchased and used to create a secure.dbc file for 
your Thunder, a single workspace is created and named Workspace 0.

All users have access to Workspace 0, regardless of whether Security Administrator is 
installed. When searching or browsing in Thunder, you must first tell the system which 
workspaces you want to access. Use the Workspace/Search box to view the list 
of workspaces.

n Searches can only be performed on a database window opened at the base station. If a 
sequence window is selected, the search area is dimmed.

The following topics provide more information about workspaces:

• “Copying Clips, Stills, and Sequences” on page 36

• “Copying Clips and Stills Between Sequences” on page 37

Copying Clips, Stills, and Sequences

You can copy clip and still image files and sequences from one Thunder Database to another 
over a network, and from one Workspace to another in either of two ways: Drag and Drop or 
using the Clipboard.

To select your first Workspace:

t Press F4 to access the Workspace/Search dialog box. 
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To open another Workspace in the same Database:

1. Select Window > New Window. 

2. Press F4 to select the Workspace to which you want to copy.

To copy a clip, still or sequence from one database window to another database 
window, or one workspace window to another workspace window:

1. From the Network Tree, open the Database from which you want to copy the 
image files.

2. Again from the Network Tree, open the Database to which you want copy the 
image files.

3. With the two Database windows open, tile them with one above the other.

4. Select the files you want to copy.

5. Do one of the following:

t Drag the files from one Database window to the other and release the mouse button.

t Click Edit > Copy, then click on the other window and select Edit > Paste. 

t Press Ctrl+C then click on the other window and press Ctrl+V. 

If any of the files you are copying have the same numbers as files that already exist in the 
target database, you will be asked if you want to overwrite the files. If you do, click “Yes” or 
“Yes All” to complete the copy and overwrite the files in the target database. If you don’t, 
click “No” or “No All,” and the new files will be copied to the next available numbers in the 
target database.

If the Databases are not under your Network Tree, click File > Open to open a Database 
under the Network Tree. If the Database does not exist, ask your System Administrator to 
create the Database with the Create New Database command.

Copying Clips and Stills Between Sequences

All sequences are built from clips and stills belonging to a single database. Consequently, 
you can only build a sequence from the clips and stills from the database to which the 
sequence belongs.

To copy clips and stills to other workspaces:

t Click+drag the clip or still from one workspace window to the new workspace window. 
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In the following example, copy a clip from sequence seq00000.seq to sequence 
seq00002.seq by click+drag. These two sequences both belong to database 4b.pff, as shown 
in the Network Tree.

In the following example, copy a clip from the sequence seq00000.seq of database 4b.pff to 
sequence seq00001.seq of database 6c.pff. Since the sequences belong to different databases, 
you cannot copy clips or stills directly.

Copy a clip from sequence
to sequence in the same database

Copy a clip from one sequence 
to the other
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Open the two databases and copy the clip from 4b.pff to 6c.pff. Then place the clip from 
database 6c.pff into the sequence.

Copy a clip from sequence
to sequence in a different database

Copy a clip from database to 
database, then to the sequence
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Status Bar

Use the Status Bar command to show or hide the Status bar which displays across the bottom 
of the application window. A check mark appears next to the Status Bar command in the 
View Menu when the Status bar is displayed.

The left area shows the action triggered by buttons and menu items as you move around the 
menu screen with arrow keys or the mouse cursor. The areas at the right of the Status bar 
example indicate the following:

For more information about the Status bar, see “Background Tasks” on page 40.

Background Tasks

The Background Tasks feature allows you to program Thunder to perform time-consuming, 
low-priority tasks in the background while you continue your work. When Thunder is 
working on background tasks, a progress bar appears on the Status bar.

You are not required to do anything or wait for processing to take place. For more 
information on this feature, see “Background Tasks” on page 254

Indicator Description 

216257 MB Free The amount of free space on the hard drive that holds this 
database.

Items:0/14/24 Indicates that 0 items are selected out of 14 displayed in the 
currently active window, and that there are a total of 24 items in 
the database.

75 Shows the number 75 is currently in the keypad.

1/31/05 Shows the current date.

17:05 Shows the current time.
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Numeric Keypad

Thunder has different interpretations for the two sets of number keys on the keyboard. The 
numbers across the top of the keyboard are used to select the Thunder output channels.

The numbers on the keypad (far right of the keyboard) are used to enter clip or image file 
and event numbers.
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Chapter 2

File Management

This chapter describes how to manage and move your clips and still images in the Thunder 
database. The following sections are included:

• Copying Clips and Stills

• Deleting Clips and Stills

• Importing Clips and Stills

• Import/Export Options

• Modifying Image File Data

• Renumbering Clips and Stills

Copying Clips and Stills

Clips and stills can be copied from one Thunder database to another over a network, and 
from one Workspace to another in either of two ways: Drag and Drop or using the Clipboard. 

To select your first Workspace, 

t Press F4 to access the Workspace/Search dialog box. 

To open another Workspace in the same database

1. Select Window > New Window.

2. Press F4 to select the Workspace to which you want to copy. 

n If the Databases are not under your Network Tree, use File > Open to open a database 
under the Network Tree. If the database does not exist, ask your System Administrator to 
create the database with the Create New Database command. 
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n You can only build a Sequence from files in the database to which the Sequence belongs. In 
order to copy the events of one Sequence into a Sequence in another database, you must first 
copy the files to the database, then add them to the Sequence.

To copy from one database window to another database window, or one workspace 
window to another workspace window:

1. From the Network Tree, open the database from which you want to copy the image files. 

2. Again from the Network Tree, open the database to which you want copy the 
image files. 

3. With the two database windows open, tile them with one above the other.

4. Select the files you want to copy.

5. Do one of the following:

t Click+drag the file(s) from one database window to the other. 

t Select Edit > Copy, then click on the other window and select Edit > Paste. 

t Press Ctrl+C, then click on the other window and press Ctrl+V. 

To select your first Workspace, 

t Press F4 to access the Workspace/Search dialog box. 

To open another Workspace in the same Database

1. Select Window > New Window.

2. Press F4 to select the Workspace to which you want to copy. 

n If the databases are not under your Network Tree, select File > Open to open a database 
under the Network Tree. If the database does not exist, ask your System Administrator to 
create the database with the Create New Database command. 

n You can only build a Sequence from files in the database to which the Sequence belongs. In 
order to copy the events of one Sequence into a Sequence in another database, you must first 
copy the files to the database, then add them to the Sequence.

Deleting Clips and Stills

Clips and stills can be deleted from a database or sequence window as described below.

To delete clips and stills from the database:

1. Select the database or sequence window containing the item(s) to be deleted.

2. Select the desired image files.
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3. Do one of the following:

t Press Delete.

t Select Edit > Delete. 

The Delete Warning appears.

4. Click Yes or press Enter to confirm the delete. The selected image file(s) are 
permanently deleted from the active window. 

n Once clips or stills have been deleted from a database window, they are permanently lost 
and cannot be recovered. However, deleting the events in a sequence does not remove the 
corresponding clip or still files from the database.

You can protect image files from accidental deletion by selecting read-only or using your 
permission set, on the Security tab of the Item Properties dialog box. See “Template and 
Item Properties — Security Tab” on page 238.

Importing Clips and Stills 

There are three ways to clip and still files into a Thunder Database: Import Image, Drag and 
Drop, and using the Clipboard. When you import image files, you are converting their file 
type, such as .bmp or .jpg, to Thunder native .g format.

The following topics provide more information about importing clips and stills:

• “Importing Images into the Thunder Database” on page 46

• “Dragging and Dropping an Image into the Thunder Database” on page 47

• “Copying an Image to the Clipboard and then to the Thunder Database” on page 47
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Importing Images into the Thunder Database

To import a single image into the Thunder database:

1. Select File Import.

2. Browse to the file you want to import and click on it. 

Its name appears in the File name box. You can specify the database information for the 
new file in the fields at the left. Thunder fills in the next available number for the new 
item, but you can change it. To change the title to something besides the filename, 
uncheck the “User Filename as Title” box.

3. Click Open or press Enter. The selected image is imported to the currently selected 
database window.

The Import Image dialog box imports one image at a time, but you can import a set of .tga or 
.tif images as an animation. This feature requires that Apple® QuickTime® is installed on the 
Thunder system.

To import a set of images into the Thunder database: 

1. Select the “Import As Animation Series” option.

2. Select the first file of the sequence. 

The files must have sequential numbers at the end of their filenames, for example 
“file001.tga, file002.tga, file003.tga, and so on. 
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Dragging and Dropping an Image into the Thunder Database

To drag and drop an image into the Thunder database:

1. Open Windows Explorer.

2. Find and select the desired image files. 

3. Click+drag the file into a Thunder database window. 

The file is imported to that database window. Drag and drop allows you to import 
several image files at one time.

Copying an Image to the Clipboard and then to the Thunder Database

To copy an image to the clipboard and then Paste it in the Thunder database:

1. Open Windows Explorer.

2. Browse to the image.

3. Select Edit > Copy or Edit > Cut in the Explorer Edit menu. Edit > Cut moves the 
selected file to the clipboard.

4. Click in the Thunder database in which you want to place the image file and select 
Edit > Paste. The file is imported to that database window.

These methods for importing an image file into Thunder include the Key if the image has 
one, whether or not Key is selected in the Video tab of the current Template.

Import/Export Options

Thunder can automatically import clips and stills into its default database when they are 
placed in a designated “watched” folder. Thunder regularly checks this folder and imports 
any compatible files into its default database.
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To set up the import and export option:

1. Select File > Preferences > Import/Export Options. 

The Import/Export Options dialog box appears.

2. Select the Enable Import Watcher option.

3. Do one of the following:

t Type the location of the watched folder, and the database you want (if it is not the 
default database).

t Press the ellipsis (...) button and browse to the folder. 

4. Select the folder and click OK.

The folder appears in the Auto Import Folder field.

5. Click OK again and the Import Watcher is activated.

The following topics provide more information about import/export options:

• “Overwriting Items” on page 48

• “Default Database” on page 50

Overwriting Items

The Import Watcher can be set to automatically overwrite items in the database with 
new ones. 
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c Since there no confirmation that database items are being overwritten, this option can 
cause inadvertent data loss. Make sure you intend on overwriting the existing items in 
the database.

To overwrite items: 

1. Select File > Preferences > Import/Export Options.

2. Check the “Overwrite Existing Item in Database” box in the Import/Export Options 
dialog box.

New items replace old ones in the database if their filenames follow these conventions:

n In the previous table, it is important to note that n indicates a number, and x indicates an 
alphanumeric character. It is also important to note that .jpg is used as an example of a 
media file extension. It can also be substituted with other media file extensions such as .mov, 
.mxf, .dv, and so on.

File Name Where Placed Imported Title
Imported 
Media ID Comments

xxx.jpg 1st available 
database slot

xxx.jpg xxx

#nnn.jpg Specified #nnn #nnn.jpg 0_nnn

#nnn xxx.jpg Specified #nnn #nnn xxx.jpg 0_nnn The original file 
name has a space 
between the 
numbers and 
letters.

#nnn,xxx.jpg Specified #nnn #nnn,xxx.jpg xxx The original file 
name has a 
comma between 
the numbers and 
letters.
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Default Database

To designate the default database:

1. Click the Network Tree (View > Show Tree) and select a database.

2. Right-click the database and select Set Default Database from the menu.

This database opens when Thunder is started and receives files from the watched folder.
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Modifying Image File Data
To modify a clip or still image file’s database information:

1. Click the picon to select it. 

2. Do one of the following:

t Press Enter to bring up the Item Properties dialog box. 

t Right-click on the picon and select Properties from the menu.

3. Enter the new database information in the appropriate fields. 

4. Click Apply. 

The new information is immediately transferred to the image file. 

5. Click OK to close the dialog box and return to the previous window.

n When modifying a image file’s database, you can only enter information in the Title, 
Category, User, Memo, and Media Id fields. The Number and Date fields are dimmed, 
indicating they cannot be changed.

For more information on the Item Properties dialog box, see “Template and Item Properties 
— General Tab” on page 236.
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Renumbering Clips and Stills
To renumber clip and still image files in a database window:

1. Select the image files to be renumbered.

2. Select Edit > Renumber. 

The Renumber Items dialog box appears.

3. Enter the new image file number.

4. (Option) Check the Keep Selection Order check box to renumber the image files in the 
order you selected them.

5. Click OK. 

The image files selected are given new numbers starting from the number specified. If 
image files already exist within the destination range specified, a dialog box appears, 
asking if you want to overwrite the items at those numbers or place the new items at the 
next available numbers.

To move image files from one workspace to another:

t Specify a starting number that includes the destination workspace, such as 2.45 for 
workspace 2, image file 45.

To move image files from one database to another:

t Specify a starting number that includes the destination database and workspace, such as 
3.2.45 for database 3, workspace 2, image file 45.
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To access the Renumber Items dialog box:

1. Select the image files. 

2. Right-click on one of the images and select Renumber.

When the Add to End of Workspace option is enabled, and you specify a file number that is 
not in use, one file goes to that number, but the rest of the files goes to the end of the 
workspace. If your files do not renumber to the area you expect, check your 
Database Options.
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Chapter 3

Working with Clips

This chapter describes how to create individual clips, edit them, and subdivide them multiple 
times to generate sub-clips, each with its own in-point, out-point, database information and 
picon. The following sections are included:

• Recording a Clip

• Creating Subclips

• Inserting a Clip

• Clips with Keys

• Editing Clips

• Playing Clips

• Playing Clips in a Sequence

• Item Properties

Recording a Clip

You can record clips from your live video feed. A database window must be open and 
selected to record the new clips. 

To record a clip:

1. Select a Channel’s MiniMonitor.

2. Right-click the MiniMonitor window and select Record Mode from the menu. 

The MiniMonitor turns red and displays the word Record, indicating it is in 
Record Mode.
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3. Right-click the window again and select Record from the menu.

The Item Properties dialog box appears. 

4. Make your entries on the tabs as required and click OK to close the dialog box and begin 
recording the clip.

To change compression rate and key type:

t Select Edit > Edit Template and click on the Record Setup tab of the Template 
dialog box.
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If recording clips with Keys:

1. Enable Key recording on the Input Channel you are using. See “File > Preferences > 
Channel Configuration” on page 193.

2. Enable Key on the Video tab of the Item Properties / Template dialog box. See 
“Template and Item Properties — Video Tab” on page 240.

3. Select the type of filter on the Record Setup tab of the Item Properties / Template dialog 
box. See “Template and Item Properties — Record Tab” on page 243.

The MiniMonitor turns red and displays a duration window, reading in 
hours:minutes:seconds:frames.

4. When you have recorded the time you want, click the Stop button below the 
MiniMonitor.

Stop
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Thunder saves the new Clip to the active database. The Clip will have the same number that 
appeared at the upper left corner of the MiniMonitor while it recorded. In this example, the 
clip number is 0.247.

n You can record a clip on one channel while playing clips on another. 

To record while playing a clip:

t Select an unused MiniMonitor and follow the steps in the topic “To record clips with 
Keys:” on page 241.

The following topics provide more information about recording a clip:

• “Clip Recording Methods” on page 58

• “Bad Frames” on page 61

• “Recording a Clip from a VTR” on page 61

Clip Recording Methods

To record clips, Thunder must be in Record Mode. Right-click on a MiniMonitor to see the 
popup menu and select Record Mode. When a checkmark appears beside it, Record Mode is 
the active mode.
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There are five clip recording methods on Thunder, described below:

Recording Methods  

Setting Description

Record Brings up the Item Properties dialog box. When you press the OK 
button on the dialog box, recording begins. Recording continues 
until you click the Stop button (black square) or as programmed on 
the Clip page of Item Properties.

Quick Record Bypasses the Item Properties dialog box. Recording starts 
immediately and continues until you click the Stop (square) button 
or as programmed.

Cue Record Brings up the Item Properties dialog box. Recording does not start 
until you press the Record (round) button. Recording continues 
until you click the Stop (square) button or as programmed.

Quick Cue Record Bypasses the Item Properties dialog box. Recording does not start 
until you press the Record (round) button. Recording continues 
until you click the Stop (square) button or as programmed.

VTR Record Configures Thunder to record clips from a VTR. It controls the 
VTR and cues it to in and out points.
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In all five clip recording modes, Thunder assigns the clip the next consecutive number and 
places it in the active database.

The control buttons (Stop, Pause, and Record) change to red when active in the MiniMonitor 
while in Record Mode. 

To turn off the recording process, do one of the following:

t Right-click the MiniMonitor and select Playback Mode.

t Play a clip to the same channel that you were previously recording to.

Control Buttons  

Button Description

Stop Stops recording of the clip. Thunder then saves the clip to the active 
database.

Pause Temporarily stops recording of the clip. When recording is paused, click 
on Record to resume or Stop to finish recording.

Record Starts or resumes recording of the clip.

Stop Pause Record
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Bad Frames

When the combined size of clips and their corresponding keys exceeds Thunder’s bandwidth 
during recording, Thunder displays a bad frames warning in the MiniMonitor. The number 
of bad frames is given, but just one bad frame can spoil a clip.

To correct the exceeded bandwidth error:

1. Stop recording the clip and delete it.

2. Select Edit > Template or press F5 to bring up the Record Setup tab of the Template 
dialog box.

3. In the Key Type drop-down menu, select Filtered.

4. Click OK to record the clip again.

The Filtered Key reduces bandwidth by removing noise before compression. Since this 
process might reduce image quality, use this Key only when you get a bad frame count 
during recording.

Recording a Clip from a VTR

This function is an option on Thunder. Before attempting to use it, be sure the Ingest option 
is enabled and properly configured. See “File > Preferences > Options” on page 217 for 
installation and “File > Preferences > Configure VTR” on page 202 for configuration. 

Select filtered
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To use VTR Recording:

1. Select the MiniMonitor for the Hardware Channel connected to the VTR.

2. Put the MiniMonitor into Record Mode (right-click, select Record Mode).

3. Right-click on the MiniMonitor again and select VTR Record. The VTR Record dialog 
box appears.
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4. In the VTR Record dialog box, Mark In and Mark Out points on the tape, using the 
playback controls to position the tape. If the incoming video has a key, click in the 
Key checkbox.

The Properties button brings up the Item Properties dialog box. In most cases you do not 
need to access it.

5. Click Start to begin the recording.

Thunder stops recording at the designated out point and saves the new clip to the 
active database.

VTR Record Options  

Option Description

Stop Stops recording at the current point in the tape and saves the clip in 
Thunder.

Delete Stops recording and deletes the clip from Thunder.

Done Closes the VTR Record dialog box. If you click the Done button 
during recording, the record stops at the current point and saves the 
clip in Thunder.
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Creating Subclips

A subclip is a subset of a master clip. A master clip is an original clip recorded or imported 
into Thunder. The sub-clip function enables you to use parts of a master clip individually or 
in a sequence as many times as required without having to fill up the hard disk with several 
copies of the same material.

To create a subclip:

1. Select a clip from the active database.

2. Right-click to display the popup menu.
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3. Select Preview. The Preview dialog box appears.

4. In the Preview dialog box, click the New Sub-Clip button. 

Thunder assigns the subclip a number, in this case 0.248. 
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5. Use the slider, thumbwheel or VTR controls to view the clip as necessary.
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6. Set the starting point of the subclip with the slider or type in the values and click the 
Mark In button.

7. Set the ending point of the subclip with the slider or type in the values and click the 
Mark Out button.

8. Position the slider or type in a value for the frame you want for a picon and click the 
Picon button.

9. Click the close window button to close the Preview dialog box.

The new subclip is added to the Database. The film icon with an arrow indicates this is a 
subclip rather than a master clip.
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Inserting a Clip

This command is used to insert a new clip into a database. Select Edit > Insert Clip to 
display the Clip tab of the Item Properties dialog box.

From this dialog box, the specifics of the clip can be entered prior to the clip being inserted 
into the database. Thunder does not store the actual video for a given clip. The Clip tab 
contains the following fields: 

Item Properties — Clip Tab  

Option Description

Clip Name File name of the clip itself. To generate a new clip, leave this field blank.

In In-point of this clip.

Out Out-point of this clip.

Duration Duration of this clip.

Loop In Point in the clip where looping starts.

Key Item number of the key for this clip.

Master Clip Master clip, if any.
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You can play any portion of the clip between the Mark In and Mark Out points. Any frame 
of video can be selected from the clip and saved as the picon in the database.

Clips with Keys

If you are recording clips with Keys, you must:

• Enable Key recording on the Input Channel you are using. See “File > Preferences > 
Channel Configuration” on page 193.

• Enable Key on the Video tab of the Item Properties / Template dialog box. See 
“Template and Item Properties — Video Tab” on page 240.

• Select the type of filter on the Record Setup tab of the Item Properties / Template dialog 
box. See “Template and Item Properties — Record Tab” on page 243.

Thunder cannot generate a real-time proxy when recording clips with keys, but you can set it 
to automatically create a proxy after recording by selecting the “Automatically Generate 
Proxy After Record” option. Also, you can manually generate a proxy for any clip by right-
clicking on it and selecting “Generate New Proxy” from the menu.

Editing Clips

Editing clips can be done using the following two methods:

• Using the Item Properties Dialog Box

• Using the Preview Dialog Box

Using the Item Properties Dialog Box

To edit a clip:

1. Right-click the clip picon and select Properties from the popup menu. 

The Item Properties dialog box appears. 

Base TC Base timecode used by the clip.

Looping How many times to loop the clip.

Server Thunder workstation this clip resides on.

Item Properties — Clip Tab (Continued)  

Option Description
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2. Click the Clip tab. 

The dialog box provides the following fields for data entry:

Item Properties — Clip Tab  

Option Description

Clip Name The file name of the clip. To generate a new clip, leave this field blank.

In The in-point of this clip.

Out The out-point of this clip.

Duration The duration of this clip.

Loop In Point in the clip where looping starts.

Key Item number of the key for this clip.

Master Clip Master clip, if any.

Base TC Base timecode used by the clip.

Looping How many times to loop the clip.

Server The Thunder workstation that this clip resides on.
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Using the Preview Dialog Box

To edit an existing clip:

t Right-click the Picon and select Preview from the popup list. 

The Preview dialog box opens. A proxy of the clip appears in the window.

The following are the fields and controls used to edit a clip: 

Monitor 
Window

Mark In/Out
buttons

Current
position

Clip
name

Go To
buttons

Timeline 
scrubber

Playback
controls

Thumbwheel Set picon
button

Clip
duration

Preview Dialog Box Fields and Controls  

Setting Description

Clip Name Name of the clip file to load, delete or create.

Current Position Displays current clip position. Click here to specify a timecode position. 
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Playing Clips

The following topics describe functions you can perform when playing clips:

• “Clip Playback and Encoding” on page 73

• “Cueing Clips” on page 73

• “Previewing Clips” on page 74

• “Playing in Program Channel” on page 74

• “Directed Play in a Database Window” on page 75

• “Directed Play in a Sequence Window” on page 76

• “Changing a Clip’s Picon” on page 78

• “Playing Clips and Stills Together (Compound Playout)” on page 79

In/Out/Duration Specifies which portion of the clip to play. Click on these buttons to 
make changes.

Picon Sets the picon image. When the monitor window displays an image 
representative of the clip, click this button. The timecode shows the 
position in the clip from which the image was taken.

Goto Moves you to the beginning, end or picon set point of the clip.

Audio Channels Thunder records the audio portion of its clips in two stereo pairs. This 
allows your to record and play back two different sound tracks, for 
programs broadcast in two different languages. For the purpose of editing 
a clip, use the radio buttons to select either stereo pair, in audio channels 
1 and 2 or 3 and 4.

Looping How many times to loop the clip.

New Sub-Clip Click on this button to create a subclip based on the clip you 
are previewing.

New Still Create a still from the frame displayed in the window.

Scrubber Moves you forward and backward through the full length of the clip. 

Thumbwheel Allows fine-tuned searches, but it is limited to a small area. When you 
reach the end of the scrub, lift the mouse to continue. 

Playback Controls Allows you to play the clip to verify your settings.

Preview Dialog Box Fields and Controls (Continued)  

Setting Description
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Clip Playback and Encoding

Clip playback and encoding on Thunder systems based on the Corsica hardware is restricted 
to MPEG-2 MXF (I-frame). Thunder transcodes all clips that are copied between databases 
or imported. In order to do this properly, Thunder databases must have the proper codec 
selected when they are created. This is done by selecting MPEG-2 IFRAME from the Codec 
list box on the Create New Database dialog box. For more information, see “Creating a New 
Database” on page 122.

Cueing Clips

To play a clip to the selected output, do one of the following:

t Type the clip file number on the numeric keypad and then press the channel number key 
at the top of the keyboard. For example, to play image file 45 to channel 1, type 45 on 
the keypad, then press 1 on the number keys at the top of the keyboard.

t Type the clip file number on the numeric keypad and then press a letter A through D. 
For example, to play image file 45 to channel 1, type 45 on the keypad, then press A.

t Use the directed play features of the numeric keypad. This is where specific keys are is 
used to trigger specific play events.The / (slash) keys plays to Program, the * (asterisk) 
key plays to Preview, and the + (plus) key plays to the Cue window.

t Click+drag a picon to the MiniMonitor to play the clip.

t Click+drag a clip from one MiniMonitor to another.

n If your Thunder has the Security Administrator option, you could have access to play clips in 
other workspaces. If your Thunder has the ODBC option, you could have access to play 
clips in other databases.

Number keys at the top of the keyboard

Number keys on the keypad
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Previewing Clips

Preview a clip only when you need to see the clip on one channel before it goes out on 
another channel. Set the Program (red) and Preview (yellow) controls to a different channel 
before you begin playout.

To play a clip to the Preview (yellow) channel, do one of the following:

t Double-click on the picon.

t Right-click the picon and select Play.

t Enter the desired clip’s number on the numeric keypad, press Enter, and press 
Spacebar.

t If you have a middle mouse button, click the picon with the middle mouse button.

You can play a clip on one channel while recording clips on another. 

To play while recording a clip:

1. Select an unused MiniMonitor.

2. Drag the clip in the Preview (yellow) channel or the Cue Window.

3. Press F2 (Take key) or click on the Take icon to move the clip to the Program channel.

Playing in Program Channel

To play, pause, or re-cue a clip in the Program Channel, you can use the “<”, “>”, and “/” 
keys at the bottom right of the keyboard. You do not need to hold down the Shift key when 
using these keys.
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Directed Play in a Database Window

The following table explains ways to play a clip in the Database window.

Use the keys on the numeric keypad to select the image file; use the numbers across the top 
of the keyboard to specify the channel. For example, to play image file 45 to Channel 3, 
press 4, then 5 on the numeric keypad, then press the number 3 key on top of the keyboard. 
(The letters A through D also work to select channels 1 through 4.)

To do this: Steps Result

Play an image file to the Preview 
channel or Cue window. 

1. Type the image file’s number.

2. Press Space.

The image file is played to the 
Preview channel.

Play an image file to a specific 
channel. Program, Preview and 
Live controls set to one 
MiniMonitor (recommended).

1. Type the image file’s number.

2. Do one of the following:

t Press the channel’s number.

t Type the image file’s number.

3. Press + (plus)

Image file plays to specified 
channel.

Plays to Cue on active channel.

Play an image file to a specific 
channel. Program, Preview and 
Live controls set to different 
MiniMonitors (not recommended).

1. Type the image file’s number.

2. Do one of the following:

t Press the channel’s number.

t Type the image file’s number.

t Press / (forward slash).

t Press * (asterisk).

t Press + (plus). 

Image file plays to specified 
channel.

Plays to

• Program channel. 

• Preview channel. 

• Live channel.

Go to an image file 1. Type the image file’s number.

2. Press Enter.

The selection cursor moves to the 
requested image file.

Cue a file to a specific channel 1. Type the file’s number.

2. Press Shift and the desired 
channel number.

File cued on specified channel.

Cue a file to a specific channel and 
show the first frame

1. Type the file’s number.

2. Press Ctrl and the channel 
number.

File cued on specified channel with 
first frame visible.
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Directed Play in a Sequence Window

The following table explains ways to play a sequence in the Database window.

Use the / * + keys on the numeric keypad. See the following illustration.

To do this: Steps Result

Insert an image file into a sequence. 1. Type the image file’s number.

2. Press the Insert key.

The image file is inserted into the 
sequence immediately after the 
currently selected sequence event.

Play an sequence event. Program, 
Preview and Live controls set to one 
MiniMonitor (recommended).

1. Type the image file’s number.

2. Press + (plus) Plays to Cue on active channel.

Play an sequence event. Program, 
Preview and Live controls set to 
different MiniMonitors 
(not recommended).

1. Type the image file’s number. 

2. Do one of the following:

t Press / (forward slash).

t Press * (asterisk).

t Press + (plus). 

Plays to:

• Program channel.

• Preview channel. 

• Live channel.

Go to a sequence event. 1. Type the event number.

2. Press Enter.

The selection cursor moves to the 
requested sequence event.

Play A: program channel

Play B: preview channel

Play D: cue on active channel
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Clip Picons

Clips are identified within the database by a picon with a green film icon, located in the 
upper right corner. When a red icon appears on a clip picon, it indicates that one or more of 
the following must be corrected in order for the clip to play:

• The Thunder or other clip server where this clip resides is unknown or improperly 
selected. See “File > Preferences > Configure Clip Servers” on page 207.

• The clip has invalid In and Out points. See “Editing Clips” on page 69.

The MiniMonitor display turns brown when Thunder begins recording and orange when it 
begins playing back.

Green icon Red icon

The MiniMonitor displays the delay time you specified 
and turns brown. Thunder begins recording.

After the delay period has passed, the MiniMonitor 
turns orange. Thunder begins playback.
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Changing a Clip’s Picon

A clip's picon image is taken from the first, middle or last frame of the clip, or it is 
completely black, depending on the Default Picon setting.

To change the picon image: 

1. Right-click on the picon and select Preview, or press F3.

The Preview dialog box appears. 

2. Move the timeline slider to until the picture field shows a frame you want to represent 
this clip. 

3. Click the Picon button to set the image.

Timeline scrubber

picture field

Set picon button
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The clip now has a new picon image and is ready to play. This clip also has a key, as shown 
by the key icon in the upper left corner.

.

When a clip is a subclip of another master clip, it displays the subclip icon (arrow within the 
film icon) in the upper right corner.

Playing Clips and Stills Together (Compound Playout)

Thunder enables you to associate a clip with a still. Once this association is made, every time 
that still is played, the associated clip plays with it, whether it be within a sequence, through 
drag and drop from the database up to a MiniMonitor, or directly via direct number recall.  
Compound Playout allows for many different stills to have the same background clip 
without creating unique clips of each, saving creation time and storage space. It also 
provides the ability to quickly and easily change background clips.

n Because of the way the hardware is being utilized, Compound Playout does not work on a 
channel if the bug layer of that channel is being used, or if you use a transition other than 
Cut or Dissolve. You can not use a Wipe transition to bring a compound item on or off.  
Compound Playout can use layouts.

n Compound Playout only works on Master Clips.

The following topics provide more information on playing clips and stills together:

• “Associating a Clip with a Still” on page 80

• “Changing or Removing a Compound Clip Association” on page 81

key icon

subclip icon
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Associating a Clip with a Still

To associate a clip with a still:

1. Determine which clip and still you want to play together.

2. Select a still (with key) that you want to play with a clip.

n If you want to associate a clip with multiple stills, you can select all of the desired stills at 
once using any of the multi-select options (Ctrl+click, Shift+click, drag rubber band).

3. Right-click on the still and select Properties from the menu. 

The Items Properties dialog box opens for that still.

4. Select the Clip tab.

5. In the Master Clip field of the metadata, type the clip number for the clip that you want 
to play each time that this still is played.

6. Click OK.

Still with key

Type the number of the master 
clip you want to associate with 
the still here
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7. Load the still. You should see a yellow picon with a “C” in the lower right hand corner, 
indicating that there is an associated clip for this still.

The mark in and mark out information for the clip should be retained.

Changing or Removing a Compound Clip Association

Thunder enables you to change or remove the associated clip from the still.

To change or remove the associated clip from the still:

1. Right-click on the still and select Properties from the menu. 

The Items Properties dialog box opens for that still.

2. Select the Clip tab.

3. In the Masterclip field of the metadata, change or remove the clip number for the 
associated clip.

4. Click OK.

5. Load the still. 

If you:

- Removed the clip number, the yellow “C” picon no longer appears on the still.

- Changed the clip number, the yellow “C” picon remains in the lower right hand 
corner of the still, indicating that there is an associated clip for the still.

Compound clip picon
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Playing Clips in a Sequence

There are two methods of sequence play. Once a sequence window is active, you can make 
play mode selections from the Air Menu, or the sequence play buttons in the 
Sequence window.

A clip, when it is part of a sequence, is referred to as an event. There are three basic methods 
for inserting clips into a sequence.

To insert clips into a sequence, do one of the following:

t Drag their picons from the Database window to the Sequence window.

t Copy their picons to the Clipboard and paste them into the sequence.

t Type their number and press Insert on the keyboard.

Dragging is faster, but copying allows you to paste a group of picons into the sequence more 
than once without having to return to the Database window to reselect them. The clips will 
be placed into the sequence window in the order that you selected them. You can repeat this 
action as many times as you want.

The following topics provide more information about playing clips in a sequence:

• “Selecting Multiple Clips” on page 83

• “Adding Clips into the Middle of a Sequence” on page 83

• “Adding Clips to the End of a Sequence” on page 83

• “Sequence Play” on page 84

Sequence play buttons
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Selecting Multiple Clips

To select multiple clips or image files:

1. Ctrl+click on their individual picons or click and drag over multiple picons. 

2. Drag the selected picons into the Sequence window.

Adding Clips into the Middle of a Sequence

To add clips or image files to the middle of a sequence, select their picons in the database 
window and drag them to the sequence window. Release the mouse over the event that you 
want to immediately precede the ones you are adding. Alternatively, left-click on an event to 
select it, then perform a copy-and-paste as detailed above. The new events are inserted into 
the sequence after the event you selected.

Adding Clips to the End of a Sequence

To add clips or image files at the end of a sequence:

1. Select their picons in the Database window.

2. Drag the picons to the Sequence window. 

The sequence is created as a standard Program/Preview list, and all image files first play to 
the Cue window, then are transferred to the selected Channel. 

To play the sequence, do one of the following:

t Press spacebar.

t Click the red monitor icon in the Sequence toolbar.

t Send a Take command from your ShotBox.
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Sequence Play

Sequence play can be controlled by one of two methods. Once a sequence window is active, 
you might make play mode selections from the Air Menu.

Once a sequence window is active, make play mode selections in the Sequence Toolbar.

Sequence Play Menu  

Command Description

Play Forward Plays the sequence forward.

Loop Forward Loops the sequence forward.

Play Backward Plays the sequence backward.

Loop Backward Loops the sequence backward.

Stop Stops the sequence.

Preview Event Causes an event with inhibited preview to play to the Preview channel.

Play Event Plays the currently selected sequence event.
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Remember these rules when you create sequences with clips:

• Do not change Duration (event duration), as it might cause your clips to play 
abnormally. But you can have pauses between clips.

• If you changed Duration and want to change it back, enter the clip’s original duration in 
the Duration column. To find the original duration, right-click on the clip’s picon and 
select Properties from the popup menu to bring up the Item Properties dialog box. Click 
the Clip tab where the clip’s original duration is listed.

The color of the Current Event box provides information about which outputs will be altered 
by the event. A purple box appears in the example above.

Current Event Color Information  

Color Description

Red This is an A-Play event which plays directly to Program without 
being previewed.

Pink This event is preview inhibited.

Yellow This is a B-Play event which plays directly to Preview.

Green This is a C-Play event which plays directly to Live.

Orange This is a normal transition event which previews and then 
transitions to program.

Magenta This is a normal transition event that will not be previewed 
(because preview is inhibited). Press Enter to force a preview.
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Item Properties

When you use Record, the Item Properties dialog box displays before recording begins. 
Quick Record uses the settings in the Template, so you do not see Item Properties.

To access Item Properties for a specific clip:

t Right-click on the item and select Properties.

The Item Properties dialog box appears with the General tab displayed.
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Information from the template is automatically entered into the Item Properties of individual 
image files as they are quick saved. During a regular save, the Item Properties dialog box 
appears, giving you an opportunity to make changes. 

For more information on the Item Properties dialog box see: 

• “Template and Item Properties — General Tab” on page 236

• “Template and Item Properties — Security Tab” on page 238

• “Template and Item Properties — Video Tab” on page 240

• “Template and Item Properties — Clip Tab” on page 242

• “Template and Item Properties — Record Tab” on page 243

• “Template and Item Properties — Sequence Tab” on page 246

• “Item and Template Properties — Sequence Details Tab” on page 248

To perform database searches:

t Select View > Workspace Search. For more information, see “Workspace Search” on 
page 137.
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Chapter 4

Working with Stills

This chapter describes the functions you can do when working with still images. The 
following sections are included:

• Capturing Stills With the Air Toolbar

• Using the Air Menu

• Playing Bugs

• Playing Stills

• Item Properties Dialog Box for Still Images

• Adding Titles to Stills with PostDeko

Capturing Stills With the Air Toolbar

The Air toolbar contains the following buttons and are used as shortcuts to many of the tasks 
in the Air menu. 

The Air toolbar can be used to capture and store still image files.

To capture and store images using the Air toolbar:

1. Select the channel you want to use.

2. Make the channel live (green).

3. Click the Freeze button or press F10 to freeze the channel.
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4. Click Save or Quick Save to store the result to the database.

You can perform the following actions using the buttons on the Air toolbar. Some actions are 
also controlled by the function (“F”) keys. The action of capturing still images uses the Live 
(green) channel of Thunder only.

Using the Air Menu
To use the Air menu (or its shortcut keys) to capture and store still image files:

1. Select the channel you want.

2. Make the channel live by deselecting Air > Freeze in the Air menu (or press F10). The 
check mark disappears and live video appears as the Live channel’s output.

3. Select the required input in the control section of the MiniMonitor window. The video 
input is displayed on the output of the Live channel.

Perform a Take. (F12)

Freeze or unfreeze the Live channel. (F10)

Apply the Filter. The filter modifies the image in the Live channel by removing interfield 
flicker or motion. (F11)

Quick Save an image file to the active database window using the template for the database 
information. (F8)

Save an image file to the active database window while entering database information. 
(Shift+F8)

Lock the Channel assignments to their current settings.

Link the Channel assignments so they move together from one MiniMonitor to another.
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4. Reselect Freeze by selecting Air > Freeze (or press F10) to capture the image.

5. When frozen, the image might exhibit jitter due to motion between the fields. Correct 
this jitter by selecting Air > Filter (or press F11).

 
6. Select Air > Save Still (or press Shift+F8) to save the image into the database. 

The Item Properties dialog box appears. 

7. Fill in the information under the General, Security and Video tabs.

The date field automatically is filled in by the system when you are finished. The 
General tab defines the text data associated with the clip or image file.

8. Use the Security tab to set Read and Write permissions for the image file or mark it as 
read-only. The Owner field is automatically filled in with your user name.
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9. Select how you want video to be stored with the still. Options are Key, Shaped, 
and 16X9.

10. The check boxes indicate whether the still has a key signal, is shaped, or is a 
16x9 format.

11. (Option) If you want to associate this still with a clip so that the clip plays every time the 
still does, click the Clip tab, and type the number of the master clip in the Master Clip 
field. For more information, see “Playing Clips and Stills Together (Compound 
Playout)” on page 79.

12. Click OK to complete the storage of the image file.

13. If you are capturing a batch of image files, record and save an image and then proceed to 
use the Air > Quick Save Still (or press F8) instead of Save Still. 

n The Quick Save Still command uses the data from the template in the Properties tabs, while 
changing the image file number to the next one. Quick Save Still saves time and effort.
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Playing Bugs

Bugs are a special type of still or clip commonly used to display a small logo on a lower 
corner of the viewer’s screen. 

To add and play a still bug:

1. Create the bug in applications such as Adobe Photoshop or Avid Deko®.

2. Import the image file into the Thunder database you are using. A key is required with 
the image, since you want the background to be visible around the image.

3. Click on its picon in the Database window and drag it to the bug window under the 
MiniMonitor.
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4. Click on the edge of the yellow slider to adjust the opacity (transparency). The 
percentage displays as you move the slider. The bug’s database number 
returns automatically.

The bug appears on your video monitor. You can use bugs in conjunction with layouts. 
Bugs work equally well with sequences. Take time to experiment with several 
combinations until you find one that suites your needs.

The following topics contain more information on playing bugs:

• “Using Animated Logos” on page 95.

• “Unloading Bug Layers” on page 96.

Adjust the opacity

Newly added 
bug
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Using Animated Logos

You can convert an existing clip into a moving bug, or what is referred to as an 
animated logo. 

To convert an existing clip into a moving bug:

1. Right-click the clip and select Create Bug Clip from the menu. 

The Create Bug Clip dialog box opens.

You can apply a pre-defined layout to the clip or create a new one. If you create a new 
layout, you can choose between making a standard hardware layout or one based 
on software. 

2. Click Create Bug to create the new bug clip. You can identify a bug in a database or 
sequence by the small yellow icon in its lower right corner.

Bug clips play in parallel with the regular video clips in a sequence.
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Unloading Bug Layers

You can remove a cel animation or still from the bug layer of a channel.

To remove a still or cel animation from the bug layer of a channel:

t Right-click on the MiniMonitor on the channel that has the cel animation or still 
playing, and select Unload Bug from the menu. The bug layer for that channel will 
be emptied.

Playing Stills

When playing stills, you have the following two options:

• Cueing a Still

• Previewing a Still

Cueing a Still

To play a still to the output you select, do one of the following:

t Type the desired still image file number on the numeric keypad, then press the channel 
number key at the top of the keyboard, or use the letters A through D. For example, to 
play image file 45 to channel 1, type 45 on the keypad, then press the 1 on the number 
keys of the keyboard, or the letter A.

t Use the directed play features of the numeric keypad. This is where specific keys are is 
used to trigger specific play events.The slash (/) keys plays to Program, the asterisk (*) 
key plays to Preview, and the plus (+) key plays to the Cue window.

Number keys at the top of the keyboard

Number keys on the keypad
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t Position the mouse pointer on a picon, then click and drag the mouse pointer to a 
MiniMonitor. Once inside the MiniMonitor, release the mouse button to play the still.

t Click and drag a still from one MiniMonitor to another.

n If your Thunder has the Security Administrator option, you can have access to play stills in 
other workspaces. If your Thunder has the ODBC option, you can have access to play stills 
in other databases.

Previewing a Still

Preview a still on a channel before it goes out on another channel only when you need to 
check the still.

Set the Program (red) and Preview (yellow) controls to a different channel before you 
begin playout.

To play a still to the Preview (yellow) channel, do one of the following:

t Double-click on a picon.

t Right-click on a picon and select Play from the menu.

t Enter the still number using the numeric keypad and press Enter, then press Spacebar.

t (Three button mouse) Click the picon using the middle mouse button.

t Place the clip in the Preview (yellow) channel or the Cue Window then press the Take 
key (or press F12) or click on the Take icon to move the still to the Program channel. 
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Item Properties Dialog Box for Still Images

The multi-purpose Item Properties dialog box is displayed when using Save to record the 
image file in the Live channel. You can also access it by right-clicking on an image file and 
selecting Properties.

The Item Properties dialog box appears with the General tab displayed.
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Information from the template is automatically entered into the Item Properties of individual 
image files as they are quick saved. During a regular save, the Item Properties dialog box 
appears, giving you an opportunity to make changes. 

For more information on the Item Properties dialog box, see “Template and Item Properties 
— General Tab” on page 236.

Adding Titles to Stills with PostDeko

With the included PostDeko software, you can add titles to your still image files. When you 
save these files in PostDeko, an updated Thunder (.g) file is created along with the 
corresponding Deko title (.dko) file.

The following topics contain more information on adding titles to stills with PostDeko:

• “Accessing PostDeko” on page 99

• “Saving an Image File and Title in PostDeko” on page 100

• “Closing a File in PostDeko” on page 100

• “Editing a Title in PostDeko” on page 101

• “Exporting a Title File” on page 101

For more information on using PostDeko, see the Avid Deko Products User’s Guide.

Accessing PostDeko

To access PostDeko:

1. Select the image file you want. 

2. Right-click on the image and select Open with PostDeko. 

The PostDeko application launches, with the selected image file appearing in the 
PostDeko application window.
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A .dko file is created that contains the title information for each image file that has been 
modified. Since it’s a separate file, you can reopen and edit it using any stand-alone Deko 
product. You cannot open the .dko file in Thunder.

Saving an Image File and Title in PostDeko

To save an image file and title in PostDeko:

t Select File > Save.

When you save an image file from Deko, it saves an updated Thunder (.g) file and a 
corresponding title (.dko) file created for it. The title appears with the image file when it 
plays in Thunder.

Closing a File in PostDeko

To close the graphic without saving your changes:

t Click the close button on the Graphic Window (showing the selected still and your 
added title). The graphic closes and any changes to the title are lost.



Adding Titles to Stills with PostDeko

101

If you haven’t saved the file yet, and then click on the close button to close PostDeko, you 
are prompted to save your still and title. If you decide to save the title or still, the following 
happens:

• Thunder automatically updates the native .g file.

• The picon of the newly titled image file adds a Deko logo for identification in the upper 
right corner.

Editing a Title in PostDeko

To edit a title:

1. Right-click the title’s picon and select Open with PostDeko. 

2. Open the image file in PostDeko. 

The PostDeko application starts, the selected image file opens and appears in the 
PostDeko application window.

3. Make your changes to the title.

4. Save the title. For more information, see “Saving an Image File and Title in PostDeko” 
on page 100.

Exporting a Title File

To export a Title File:

t Select File > Export.

When titled image files are exported, the title information becomes part of the image. 
Therefore, unlike the title in the original image file, you cannot edit the title in the 
exported file.
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Chapter 5

Working with Sequences

This chapter describes the functions you can use when working with sequences. The 
following sections are included:

• Creating Sequences

• Editing Sequences

• Item Properties — Sequence Tab

• Playing Sequences

• Previewing Events

• Playing Events

• Using the General Purpose Interface (GPI)

Creating Sequences

Sequences are lists of images and/or clips that Thunder plays back in order either 
automatically or with operator assistance. Sequences are usually created and edited before 
going to air. However, Thunder gives you the capability to edit a sequence while it is 
physically being played. 

Sequences are shown in the Network Tree under the database that was active when the 
sequence was first created, and use the clips and image files in that database 
during playback. 
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To create a new sequence: do one of the following:

t Select File > New Sequence. 

t Press Ctrl+N. 

The system opens an empty window, assigns it a name and creates an icon for it under the 
database that was active at the time the sequence was created. The allocated name is 
seqXXXXX.seq, where XXXXX is a number assigned by the system. If this is the first 
sequence created under any particular database, the name given by the system is seq.seq; in 
other words, the system does not display five zeros.

The empty sequence window looks like the following. Some of the items in the title bar 
might be truncated if the monitor is not wide enough to show them completely at the 
current resolution.

An image file in a sequence is referred to as an event. There are three basic methods for 
inserting image files and clips into the sequence.

The following topics provide more information about creating sequences:

• “Inserting an Image File or Clip into a Sequence” on page 104

• “Selecting Multiple Clips or Still Files” on page 105

• “Adding Clips or Stills into the Middle of a Sequence” on page 105

• “Adding Clips or Stills to the End of a Sequence” on page 105

• “Default Item Properties” on page 106

Inserting an Image File or Clip into a Sequence

To insert an image file or clip into a sequence:

t Do one of the following:

- Drag the desired picons from the database window to the sequence window.

- Copy the desired picons to the clipboard and paste them into the sequence.

- Type the number of the image file or clip and press Insert on the keyboard.
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n Dragging is faster, but copying allows you to paste a group of picons into the sequence more 
than once without having to return to the database window to reselect them.

The image files are placed into the sequence window in the order that you selected them. 
You can repeat this action as many times as you want.

Selecting Multiple Clips or Still Files

To select multiple clips or stills:

t Press Ctrl+click on their individual picons and drag the selected picons into the 
sequence window.

t Click and drag over multiple picons and drag the selected picons into the 
sequence window.

Adding Clips or Stills into the Middle of a Sequence

To add clips or stills to the middle of a sequence, do one of the following:

t Select the picons in the database window and drag them to the sequence window over 
the event that you want to immediately precede the ones you are adding. 

t Click on an event to select it and perform a copy-and-paste. The new events are inserted 
into the sequence after the event you selected.

Adding Clips or Stills to the End of a Sequence

To add clips or stills to the end of a sequence

t Select the picons in the database window and drag them to the bottom of the 
sequence window. 

The sequence is created as a standard Program/Preview list, where all image files will 
first play to the Preview channel or Cue window, then be transferred to the 
Program Channel. 

To play the sequence, do one of the following:

t Press spacebar.

t Click the red monitor icon in the Sequence Toolbar.

t Send a Take Command from you automation controller or ShotBox.

For more information, see “Playing Sequences” on page 112.
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n Depending on the settings, your sequence window might appear different on your system.

n You can only build a Sequence from files in the Database to which the Sequence belongs. In 
order to copy the events of one Sequence into a Sequence in another Database, you must first 
copy the files to the Database, then add them to the Sequence.

Default Item Properties

To set the default properties of any new item added to a sequence, select Edit Template from 
the Edit menu, or press F5. You will see the Item/Template Properties dialog box described 
in “Working with Clips” on page 55. Any settings you make automatically are applied to the 
items added to the current sequence.
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Editing Sequences

The Sequence window contains several items of information. 

n Depending on the settings, your sequence window might appear different on your system.

Sequence Window Column  

Column Description

EventNum The consecutive number of each event.

ItemNum The item number of this clip or image file.

Duration The period of time this event will play. In the case of clips, this time might 
be less than the duration of the clip itself. The number appears in red if clip 
length was modified.

Transition The transition applied when this event ends and the next one begins.

Trans. Dur. The period of time the selected transition will play, in seconds and frames.

Title The name of the clip image file.

In / Out The in and out times in hours:minutes:seconds:frames. If the numbers 
appear in red, it means the clip’s in or out point has been modified.

Channel The channel to which the event will play: Program, Preview, or Live.
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For more information about editing sequences see “Making Changes to an Event within a 
Sequence” on page 108.

Making Changes to an Event within a Sequence

Thunder enables you to make changes to an event within a sequence. Generally, all you need 
to do is select the event you want to change, then select the parameter you want to alter and 
make the change.

The following topics provide more information about making changes to an event within 
a sequence:

• “Deleting an Event from a Sequence” on page 109

• “Adding an Event to a Sequence” on page 109

• “Replacing an Event” on page 109

• “Changing an Event’s Duration” on page 109

• “Changing an Event’s Transition” on page 110

• “Changing an Event’s Transition Duration” on page 110

Control The follow four options trigger this event to play:

• Absolute — Plays at a specified time of day.

• Follow — Plays when the preceding event in the sequence is done 
playing.

• Manual — Plays when you press the space bar.

• GPI — Plays when triggered by a GPI input, see “File > Preferences > 
Assign GPIs” on page 218 and “GPI Setup” on page 117.

Start Time The time of day at which the event will play. This pertains to events where 
the Control is set to Absolute.

Layout The layout applied to this clip image file.

GPI The GPI action associated with this event.

BugOpacity The opacity percentage for the bug associated with this event.

BugNumber The item number of the bug associated with this event.

Sequence Window Column (Continued)  

Column Description
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Deleting an Event from a Sequence

To delete an event:

1. Select the event(s) you want to delete by left-clicking on any item in the sequence. 

2. Do one of the following:

t Press Delete on the keyboard.

t Select Delete in the Edit Menu.

t Right-click on one of the selected items and select Delete. 

All subsequent events in the list ripple up.

Adding an Event to a Sequence

To add an event to a sequence:

t Select the new item(s) in the database and drag into the sequence window, over the 
existing event you want to precede the new events. 

All subsequent events in the sequence ripple down.

Replacing an Event

To replace an event:

1. Double-click in the Item Num column of the event you want to replace. 

2. Type in the number of the new clip or image file (remember to include the workspace 
number and database number, if you have more than one).

3. Press Enter.

Changing an Event’s Duration

To change an event’s duration:

1. Double-click in the Duration column of the event you want to edit. 

2. Type in the time interval you want the clip or image file to display. 

The time format is minutes:seconds:frames (mm:ss:ff). You can use a period (.) when 
you enter the numbers. Thunder assumes any entry without a colon or a period is a 
frame, and the system will convert it to mm:ss:ff when you press Enter.

n To enter a pause (where the system will wait for user input to continue to the next event), 
type a P. Thunder fills in the rest for you.

3. Press Enter.
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Changing an Event’s Transition

To change an event’s transition:

1. Double-click in the Transition column of the event you want to edit. 

A pop up list of available transitions is displayed.

2. Scroll up or down the list with the scroll bar and double-click on the transition you want.

n User-defined transitions are also listed here.

Changing an Event’s Transition Duration

To change an event’s transition duration:

1. Double-click on the Trans. Dur. column of the event you want to edit. 

2. Type in the duration you want the transition to have. 

3. Press Enter. 

Transition duration are shown in minutes:seconds:frames (mm:ss:ff).

Item Properties — Sequence Tab
To use the Sequence tab:

1. Right-click on the event you want to edit.

2. Select Properties from the menu. 

The Item Properties dialog box opens with the Sequence tab enabled. You now have 
access to all of the editable fields for this event simultaneously. 
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An example of the Item Properties dialog box is shown in the following illustration.

It is also possible to edit several events simultaneously. 
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To select all of the events you want to edit:

t Press Ctrl+click on each one to select multiple events individually.

t Click-and-drag or Shift+click to select a block of events.

t Press Ctrl+A to select all the events in the sequence.

t Right-click to display the Item Properties dialog box, if the event number or clip title are 
not displayed. 

Any changes made affect all the selected events simultaneously. This is convenient for block 
changes, such as changing the transition of several items to Dissolve.

To rename any sequence, do one of the following:

t Select File > Save As and type in the new name.

t Click the sequence’s name in the Network Tree, then click again to bring up a text box 
outline. Type the new name and press Enter.

To delete the original sequence in the Network Tree:

1. Collapse the folder containing the database.

2. Expand the folder in order to see the new sequence in the Network Tree.

3. Do one of the following:

t Right-click on the sequence you don’t want, then select Delete Item in the menu.

t  Click on a sequence to select it, then press Delete.

Playing Sequences

Sequence play can be controlled by one of two methods. Once a sequence window is active, 
you can make play mode selections from the Air menu, or the sequence play buttons in the 
Sequence window (described in Play Modes). Both control mechanisms function identically. 
Press the spacebar to advance through the sequence list.
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As playback progresses, the current play event is outlined with a colored Play box. The color 
of the Play box provides information about which outputs are altered by the event. 

When a single MiniMonitor is set to Program, Preview, and Live (all three channel 
indicators are lit), the upcoming clip appears in the Cue window just below it. The Play box 
is one of two colors.

Play Sequence Window Colors  

Color Description

Red This is an “A-Play” event which plays directly to Program without being 
previewed. 

Yellow This is a “B-Play” event which plays directly to Preview. 

Green This is a “C-Play” event which plays directly to Live. 

Orange This is a normal transition event which previews and then transitions to 
program. 

Purple This is a normal transition event that will not be previewed (because preview 
is inhibited). Press Enter to force a preview. 

Orange This is a normal transition event which previews (in the Cue window), and 
then transitions to program (in the MiniMonitor itself). 

Purple This is a normal transition event that will not be previewed (because preview 
is inhibited). Press Enter to force a preview. 

Clip number

Function controls

Next clip in cue

Bug number

System channel number

Play Modes

Cue window

Bug window
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You can move the Play box to another event to allow an event or set of events to skip or 
repeat while a sequence is actually playing. After the Play box has been moved to a new 
sequence event, that event is cued and the sequence continues to run in the specified 
direction from there.

The following topics provide more information about playing sequences:

• “Moving the Play Box to Another Event” on page 114

• “Using the Play Modes” on page 114

Moving the Play Box to Another Event

To move the Play box to another event, do one of the following:

t Hold down the Alt key, then use the up or down arrow on the keyboard to move the Play 
box up or down respectively. Release the Alt key when the desired sequence item 
is highlighted.

t Hold down the Alt key and click on the sequence event. 

Using the Play Modes

The Play Modes are listed below. In all cases, to select the start point for the sequence, click 
on the event you want to start on. 

Play Forward

Keyboard shortcut: F7

The Play Forward command plays a sequence forward from the currently highlighted event.

Play Backward

Keyboard shortcut: Ctrl+F7

The Play Backward command plays a sequence backward from the currently highlighted 
sequence event.

Stop

Keyboard shortcut: Esc

The Stop command stops a sequence that is currently being played.
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Loop Forward

Keyboard shortcut: Shift+F7

The Loop Forward command plays a sequence forward in a loop beginning with the 
currently highlighted sequence event. When a looping sequence reaches the bottom of the 
event list, starts over from the top.

Loop Backward

Keyboard shortcut: Shift + Ctrl+F7

The Loop Backward command plays a sequence backward in a loop beginning with the 
currently highlighted sequence event. When a backward looping sequence reaches the top of 
the event list, it starts over again from the bottom.

Previewing Events
Keyboard shortcut: Enter

The Preview Event command (yellow button) turns off Preview Inhibit and force the next 
event to the B (Preview) channel. This is indicated by a purple “next-event” box.

Creating a sequence using drag-and-drop automatically creates a playlist that plays every 
event to the Preview channel or Cue window, and then takes it to Program with a dissolve.

Directed play prevents previewing of sequence events. The events still plays back, but you 
do not see them until they play to the Program channel. Turning off directed play restores the 
Preview channel.

When a single MiniMonitor is set to Program, Preview and Live, the preview image appears 
in the Cue window just below it. The result will be an orange next-event box.

Playing Events
Keyboard shortcut: Spacebar

Use the Play Event command (red button) to play an event to air during a sequence. If the 
event on air has its duration set to Pause, the next event will not play until the operator 
selects this command. If the event on-air has a duration, this command can be used to 
advance the next event to air early.
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Using the General Purpose Interface (GPI)

The General Purpose Interface (GPI) is a means whereby you program Thunder to navigate 
around a sequence window. The GPI User (control device) can be a keyboard or a ShotBox 
connected to Thunder by cable. When programmed, a specific keystroke causes Thunder to 
perform a supported function. 

Thunder supports up to eight GPI inputs and five commands:

• Play next event

• Cue to first frame

• Start Sequence

• Stop Sequence 

• Off

To program the GPI:

1. Select File > Preferences > Assign GPIs. 

The Assign GPI Triggers dialog box appears.

2. When the Assign GPI Triggers dialog box appears, assign the function you want for 
each input, GPI 1 through GPI 8. 

3. Select the GPI User, which is the device that signals Thunder to perform the assigned 
functions, either All Users (such as an external computer or ShotBox) or the Keyboard 
only.
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To set a non-running sequence to ignore Play triggers

t Select the Ignore Play triggers if Sequence not running option.

To enable the GPI triggers under 

t Select File > Preferences > Enable GPI Triggers. A check mark means the GPIs 
are enabled.

For more information, see “GPI Setup” on page 117.

GPI Setup

GPIs must be set for each sequence individually. By default, a sequence has no GPIs 
assigned, as shown in the following figure.

1. Click on “GPI” on the Sequence toolbar. 

The Setup GPIs for Sequence dialog box appears.

GPI setup icon
GPI Off 
indicates no GPI
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2. Check the boxes of the functions you specified in the Assign API Triggers dialog box.

3. Click OK to close the dialog box. 

The sequence toolbar now displays the GPIs you selected for this sequence.

GPI 2, 4, and 6. apply to 
this sequence
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Working with Databases

This chapter describes the functions you can perform with Thunder databases. The following 
sections are included:

• Connecting to a Lightning or another Thunder

• Connecting to an ENPS Network

• Creating a New Database

• Setting the Default Database

• Setting Database Options

• Removing All Locks

• Restoring the Full Database

• Showing Properties for a Database File

• Searching the Workspace

• Search Syntax Rules

• Security Database

• Network Tree

• Workspace Search
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Connecting to a Lightning or another Thunder

When connecting to another network Thunder for the first time, the remote system does not 
automatically appear in the Network Tree view. You must connect to the remote system 
manually.

To connect to a remote system (such as a Lightning® or another Thunder) manually:

1. Ensure that you have a physical network connection to the remote system.

2. Select File > Open. 

The Open dialog box opens.

3. Double-click on Network Neighborhood.

4. Navigate through the network until you find the system you want and double-click on 
the name to open it.

5. Double-click the correct exported drive to open it. Usually this is Drive D.

6. Double-click the Thunder Directory on that drive to open it.
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7. Double-click the .PFF file in that directory to open it.

8. Exit from the Thunder application to save the above changes.

9. Restart Thunder.

Once restarted, the remote system appears in the network Tree View, and you should not 
have to navigate to the remote system again. 

n You must follow this procedure for each remote system you want to access through your 
local system. If you plan to connect to several remote systems, you must complete steps 1 
through 7 until all remote systems have been accessed. When you are finished, follow steps 8 
and 9 to save all the changes at one time.

Connecting to an ENPS Network

Thunder can form part of an Electronic News Production System (ENPS®) network. Under 
this configuration, Thunder’s default database will display in the ActiveX® window on the 
operator’s workstation. Refer to the documentation accompanying the ENPS system for 
additional information and instructions. Electronic News Production System is a product of 
Associated Press. 
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Creating a New Database

When creating a new database, it is important to understand that the default information that 
is included on the Create New Database dialog box is based on the hardware your system 
came installed with, and the video standard that was selected when the application was first 
launched. If you want to change any of this information for the new database you are 
creating, make sure that the selections you make are compatible with your hardware, and 
work for your site and workflow.

To create a database, 

1. Select File > Advanced > Create New Database.

The Create New Database dialog box appears, which allows you to select the type, video 
standard, location and name for the new database.

Video Standard

Codec list
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2. Enter information indicating where to place the various files that make up the database. 
As you enter data into the Database Path field, Thunder will complete many of the fields 
for you. Avid recommends you keep the paths and drives that Thunder sets under File > 
Advanced Options.

n Thunder requires that the hard disk on which your database will be stored must be shared. If 
you are unsure how to set up sharing on your hard disk, contact your System Administrator. 

3. Complete the fields as shown in the following table: 

Create New Database Window — Database Type  

Setting Description

Database Type Options include:

• Thunder - Stores images in Thunder format. Lightning versions 
4.1 and later can also read these images.

• Thunder MXF - Stores images in Thunder MXF format. 

Video Standard

• NTSC

• PAL

• 720p 59.94

• 720p 60

• 1080i 50

• 1080i 59.94

• 1080i 60

Specifies the database images format. Standard definition (SD) is 
either NTSC or PAL. 

High definition (HD) image formats include: 

• 720 Progressive 59.94, and 60 

• 1080 Interlaced 50, 59.94, and 60 

Codec Specifies the codec used for the selected database and video 
standard. For Corsica systems, make sure you select MPEG-2 
IFRAME. When an HD video standard is selected, this is the 
only choice.

Location The Location section enables you to select the database name and 
path, and computer name and drive share name for the new database.

• Database Name The name of the new database. It can be any name but normally 
should be easily recognizable to all users.

• Database Path This must contain the full local path name of the directory where the 
new database will reside. This path must include a drive letter for the 
local drive.
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• Computer Name The network name of the machine where the database is to reside. 
This can be determined by looking at the network properties in the 
Windows XP Control Panel. Thunder fills in this name 
automatically.

• Drive Share Name The share name for the drive where the database resides. This can be 
determined by looking at the properties of the drive in Windows XP 
(right-click on the drive’s icon).

Options

• Unicode All Thunder databases are Unicode™; you cannot deselect it. This 
allows storage of non-ASCII characters such as Katakana and Kanji 
from Asian languages or Middle Eastern languages in the database.

• ODBC Stores images in an ODBC database for access over a network. This 
database requires a Microsoft® SQL server and ODBC driver 
installed on the Thunder workstation. For more information, see 
“Setting Up an ODBC Database” on page 285.

ODBC Database Number The number assigned to identify each ODBC database. This field is 
grayed out when the ODBC option is not checked. For more 
information, see “Setting Up an ODBC Database” on page 285.

• Removable Media Check this box if the database will reside on media which can be 
removed from the drive and placed in another system. A Jaz drive is 
an example of removable media.

• Default Server Default clip server used by this station.

Advanced Options — Proxy 
Location

• Computer Name The network name of the machine where the proxy files will reside. 
You can determine the location by looking at the network properties 
in the Windows XP Control Panel. Proxies are low-resolution MPEG 
(.mpg) files playable from your workstation.

• Path This must contain the full local path name of the directory where the 
proxy files will reside. This path must include a drive letter for the 
local drive.

• Drive Share Name The share name for the drive where the proxy files reside. You can 
determine the drive by looking at its properties in Windows XP 
(right-click on the drive’s icon).

Advanced Options — Path

Create New Database Window — Database Type (Continued)  

Setting Description
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4. Click Create. The new database is created.

Setting the Default Database

Another important task to perform in Thunder is to select the default database. This is 
especially important if you have more than one database.

To designate the default database:

1. Click the Network Tree (View > Show Tree) and select a database. 

2. Right-click the database and a popup menu appears.

.

3. Select Set Default Database. The database opens when Thunder is started and receives 
files from the watched folder.

• Image This must contain the full local path name of the directory where still 
image files will reside. It is automatically filled in when the 
Database path is entered, but it can be changed if desired.

• YUV Picon This must contain the full local path name of the directory where the 
YUV picon images will reside. It is automatically filled in when the 
Database path is entered, but it can be changed if desired.

• RGB Picon This must contain the full local path name of the directory where the 
RGB picon images will reside. It is automatically filled in when the 
Database path is entered, but it can be changed if desired. Note that 
RGB picons are not used or created by Thunder, but this directory 
must be supplied for use by FlashFile™ systems.

• Clip This must contain the full local path name of the directory where the 
clips will reside. It is automatically filled in when the Database path 
is entered, but it can be changed if desired.

Drive Share Name The share name for the drive where the Image File, YUV, and RGB 
picons reside.

Create New Database Window — Database Type (Continued)  

Setting Description
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Setting Database Options
To set the database options:

1. Select File > Preferences > Database Options. 

The Database Options dialog box opens.

2. Select your options according to the following table, and click OK when you’re done.

Database Options Window  

Option Description

Add Items to End of 
Workspace

When you add a new clip or image file to a workspace, Thunder 
searches through a workspace until it finds the next available number to 
assign that item. This option directs Thunder to place new clips and 
image files at the end of the workspace, making them easier to find. 

In this workspace there is no clip number 206, 214 or 217. Thunder 
normally assigns those numbers to an incoming clip. With the Add 
Items to End of Workspace option checked, new clips and image files 
are assigned at the end of the workspace. In this example, the incoming 
clip is numbered 221.

Keep Write Lock During 
Copy/Modify Operations

Where multiple users have access to a database, they can be copying or 
modifying clips and image files at the same time, slowing the operation 
and possibly mixing one set of clips and image files into another. This 
option locks out other users from a database while clips and image files 
are being saved or modified, saving time and keeping each series of 
clips and image files in consecutive order. 
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Keep Database Views 
Updated

Normally, Thunder keeps all open databases current through automatic 
updates. When there are multiple users, a delay result while Thunder 
checks each database for changes. This option lets you disable 
automatic updates to speed operation. 

To manually update the database if you disable this option:

Press Ctrl+R.

Update Clip Length While 
Recording

This option determines whether Thunder dynamically updates the 
length value for a clip while recording.

Update Media Id When 
Modifying Item Number

This option determines whether the Media Id of a clip will be 
automatically updated when its item number is modified.

Give warning while 
recording

During recording, Thunder monitors the content on your hard drive and 
when it reaches the percentage indicated in the % field, gives you a 
visual warning. Use this advice to avoid having your system “max-out” 
unexpectedly in the middle of a recording session.

Database Options Window (Continued)  

Option Description

Adding a new clip to the workspace
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Removing All Locks 

The Remove All Locks function was designed as a remedial measure to access databases 
after the Thunder that locked them is no longer on the network. 

Before proceeding, contact the user that locked the database to find out why it was locked. 
That user might be running a session or in the process of modifying files; access by another 
user might interrupt or corrupt that process.

To remove all locks:

1. Right-click in the Tree View (except over a DNA entry) the popup menu appears.

2. Select Remove All Locks from the popup menu.

The Unlock Database dialog box opens.

If you are attempting to remove the lock from a database that another user has accessed 
and locked (using File > Lock Database) or started a process such as copying, the 
network ID of the Thunder that locked the database (in this case “SQA_D3”) is shown 
in the window. 



Restoring the Full Database

129

Restoring the Full Database
To return to the full database:

1. Press F4 to open the Workspace/Search dialog box.

2. Click Clear or press Alt+E.

3. Click OK.
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Showing Properties for a Database File

This feature displays properties for a selected database.

To view the properties of a database:

1. Right-click a database in the Database tree view and select Properties.

The Database Properties dialog box opens.

2. Notice in the Database Type field, the type of database (in this case, Thunder MXF), the 
video standard (NTSC), and the type of video (DV; MPEG 2). This is consistent with 
what you would see in a Thunder MX (SD) TARGA-based system. If your system uses 
the Corsica SD/HD video board, it records and plays MPEG-2 MXF (I-Frame) clips 
only.

3. For more information on the fields in this dialog box, see “Creating a New Database” on 
page 122.
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Searching the Workspace

The Search section of the Workspace/Search dialog box is used to search the database for 
matching clips and image files. With the search fields set to their default states, and the 
secure.dbc file created from Security Administrator software is not installed, only clips and 
image files in Workspace 0 are shown. 

If the secure.dbc file is installed, clips and image files in all selected workspaces are shown. 
Enter data in the search fields as described below to truncate the database. The example 
shown will look in Workspace 1 “Famous People” for all clips and image files numbered 
100-199, created between the March 24, 2000 and March 25, 2001, with “Temple” 
anywhere in the title and either “Independent” in the Category field. 

Typically the search will be less restrictive (fewer criteria filled in). For more information on 
basic searching, see “Search Syntax Rules” on page 133.

To clear the fields in the search to return to the default state:

t Click Clear.

Search information can be entered into any or all of the following fields. 

Workspace Search Fields  

Field Description

Number These two fields set the range of clip or image file numbers to display. 
The left field contains the lowest clip or image file number; the right field 
contains the highest. 
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n The picon browser is substantially slower when search parameters remain active. Clicking 
Clear does not turn off MultiMatch if it was previously selected.

n Only database windows with Keyboard or Independent Context are capable of searches. 
Context is shown in the Control Section of the MiniMonitor Window.

A truncated database window can be fully used to play clips and image files, and drag and 
drop clips and image files into sequences. 

To return to the full database:

1. Click Clear or press Alt+E.

2. Click OK.

The following topics provide more information about searching the workspace:

Date These two fields set the range of creation dates. 

Title 
/Category/User/Memo

Each of these fields are used to specify the text which must be included 
within that field in order for that clip or image file to be shown. For 
example, if the word “football” is placed in the title field, only those clips 
and image files with the word football somewhere in the title will be 
shown. If data is entered in multiple fields, then all fields must match in 
order for the clip or image file to display. More complex searches can be 
performed using search syntax. 

MultiMatch Allows you to find clips and image files that contain a given piece of text 
when you don’t know which field it is in. When checked, the Title field is 
relabeled MultiMatch, and the other text fields are disabled. The search 
engine will check whether any of the four text fields have matching data. 

Ignore Case This check box causes all searches to ignore the differences between 
upper and lower case letters. 

Clear This button clears the search fields and restores the default values. 

Workspace Search Fields (Continued)  

Field Description
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• “Search Syntax Rules” on page 133

• “Workspace Search” on page 137

Search Syntax Rules

When entering the data for searches in a database, use the following syntax rules:

• A plus (+) sign before any expression makes that expression required. 

• A minus (–) sign before any expression excludes that expression. 

• Quotes (“ ”) can be used to combine multiple words into one expression. 

The following are search syntax examples.

The following is an example of search syntax input to the Workspace/Search dialog box:

Search Syntax Examples  

Search String Results

dog cat cow Matches all clips and image files containing dog, cat, or cow

+dog cat cow Matches all clips and image files which contain dog. The cat and cow do 
not matter. 

+dog-cat Matches all clips and image files which contain dog but do not contain 
cat.

“big dog” Matches “big dog” but does not match “big ugly dog” 

“big dog” “little dog” Matches “big dog” or “little dog” but not “little yellow dog” 
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Security Database

Security databases are enabled by the Security Administrator option in Thunder. One way to 
visualize the Thunder database is as a directory with picture files within it. Using the 
optional Security Administrator software, it is possible to place these pictures into 
subdirectories or workspaces. A security database file, secure.dbc, is created by Security 
Administrator software to apply privileges to each of these folders. Therefore, not all users 
might be able to see all of the picture files, or perhaps they can browse all of the database, 
but can only play certain clips and image files to air. 

The only workspace which cannot be protected in this fashion is workspace 0, which is the 
“scratchpad” database. Any user can access the clips and image files in workspace 0 
(subject, of course, to each file’s individual security properties in the Item Properties dialog 
box. See “Template and Item Properties — General Tab” on page 236.

Security is administered by the security database secure.dbc file. This database file can 
reside directly on the Thunder system itself, on a PC on the network, or a combination of 
both. On the other hand, the Security Administrator software should not be installed on 
several systems because anyone with access to the Security Administrator software can 
modify the secure.dbc file. This violates the purpose of having security. Also, do not have 
more than one version of a secure.dbc file, because it will cause problems with hidden 
workspaces that nobody will be able to access and it might even corrupt your database. 

To use the security features, each Thunder system must know the location of the security 
database (secure.dbc) file. A copy of the file can be located on an individual Thunder, but 
there should be only one such file to prevent problems managing clips and image files. 
Multiple Thunders on a network can use the same secure.dbc file located on a server. 
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To select a security database:

t Click File > Preferences > Select Security Database. Select a security database in the 
dialog box.

For more information about workspaces, see “Workspace Search” on page 137. 

To quit using a security database and run in unsecured mode:

1. Select the Security Database again and press Cancel. The following dialog box appears.

2. Click Yes to complete the dialog and remove the popup. In unsecured mode, you are 
able to access only workspace 0. 

c Running in unsecured mode might lead to problems; avoid it whenever possible.

Network Tree
Keyboard shortcut: Ctrl+T

The Network Tree shows each Thunder with its associated files. Each system is represented 
as a folder. 
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To expand the network tree:

1. Click the + (plus) sign to the left of the folder or double-click on the folder title. 

Once opened, a list of databases on that system appears followed by a list of sequences. 

A database is identified by the red and gray Thunder icon. It also has a .PFF file extension. 
Sequences associated with a database are listed directly below the database and have a .SEQ 
extension. 

To open a database or sequence:

t Double-click on the icon or name. 

The lowest system shown in the example is labeled DNA. It is a folder containing all of the 
DNA connections available to this machine.

To rename a sequence in the tree: 

1. Click the sequence you want to rename. 

2. Click the outline around the sequence name. 

3. Type in the new sequence name and press Enter.

4. Double-click the narrow border surrounding the Tree View to undock the Tree from the 
edge of the window. The undocked window can be resized, moved, and docked to any 
side of the window. To re-dock the view, drag it past the edge of the Main Window, then 
release the left mouse button. 

5. Use the Show Tree command in the View Menu to show or hide the Tree. A check mark 
next to the menu item indicates the Tree is visible. 
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To access Network Tree menus:

t Right-click inside the Network Tree area to access one of two popup menus.

This menu appears when you right-click anywhere in the window except over a DNA 
entry:

The different menu appears when you right-click on a DNA entry. 

Both the Create New DNA Connection and the Edit DNA Connection items bring up the 
DNA Connection Properties dialog box from which the necessary data can be entered or 
modified.

Workspace Search

When searching or browsing in Thunder, you must first tell the system which workspace(s) 
you want to view. The Workspace/Search dialog box is used to specify which clips and 
image files to display in a database window. It is divided into three major sections:

• Database

• Workspace

• Search

Network Tree Menu  

Command Description

Delete Item Deletes the selected folder or sequence. 

Create New Sequence Creates a new sequence window. 

Set Default Database Selects the database that will open when Thunder is started. 

Remove All Locks Removes the lock from a database that another user has accessed and 
locked or started a process such as copying.
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To open the Workspace/Search window:

t Click View > Workspace/Search Command, or press F4. 

The following topics provide more information about the sections of the Workspace/Search 
dialog box:

• “Database Section” on page 138

• “Workspace Section” on page 138

• “Search Section” on page 139

Database Section

The Database section only appears when the ODBC option to Thunder has been installed. It 
shows all the available databases on other ODBC-equipped Thunders or on a file server. 

• Select one or more databases to display in the active database window. 

• Ctrl+click selects multiple databases individually. 

• Shift+click selects all the databases between the first database and the second database 
you click.

Workspace Section

The Workspace section only appears when the secure.dbc file, created by the Security 
Administrator option, is installed. If the secure.dbc file is not installed, you have access only 
to Workspace 0. Use the Workspace section to select one or more workspaces for display in 
the active database window. When multiple workspaces are selected, clips and image files in 

Database section Workspace section Search section
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the database window display both workspace and clip/image file number. For example, clip 
61 in Workspace 23 will display 23.61 under the picon. Workspaces with parentheses ( ) 
around them do not contain any clips or image files.

Search Section

Use the Search Section to search the database for matching items. With the search fields set 
to their default states, all items in the currently selected workspace are shown. For more 
information on searching, see “Searching the Workspace” on page 131.
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Chapter 7

Working with Layouts

Layouts are applied as the clip is played to air, with no performance penalty. This chapter 
explains how to create and edit layouts to tailor playback to your specific needs. The 
following sections are included:

• Using Layouts

• Creating Layouts

Using Layouts

Thunder uses layouts to alter the way a still or clip is played to air. Thunder allows for real 
time layouts at the time of playback. For example, you can have a 1/3 size over-the-shoulder 
on the left as shown in the following example. In the example, a layout was used to 
composite the close-up image of an eagle over the background of a forest and lake. Layouts 
can also be used to play a clip over live video.
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A layout determines the size and position of stills as they are played. The default layout is 
full screen which means the still fills the entire raster. A common layout is an over-the-
shoulder (OTS) which scales the still down to about 1/4 size, and then places it in the upper 
right or left of the monitor to appear over the shoulder of a talking head.

The current layout is selected in the Control Section of the MiniMonitor window. In this 
example, Right OTS is the Layout selected.
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Layouts appear on your video monitor but not on the Thunder user interface. You will be 
able to see the results of your manipulations in real time on the video output, such as an 
external video monitor. In the example below, a clip is playing through a Right OTS layout 
over a live video feed.
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Within a sequence, each event selects a layout by number. The number 3 selects Layout 3, 
shown in the following example.

Creating Layouts

In the Edit Layout window, you can create, modify, copy, rename or delete layouts. When 
you play clips from a database window, you can use the same ten layouts, plus any 
additional layouts with names you assign.

To create new layouts:

1. Select Edit > Edit Layouts. 

The Edit Layouts dialog box opens.
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2. Click the Edit button.

The Layout Properties dialog box opens.

You can now edit the following attributes of the video:

- placement

- size

- crop

The following topics provide more information about creating layouts:

• “Changing the Placement of an Image” on page 145

• “Changing the Size of an Image” on page 146

• “Cropping an Image” on page 148

Changing the Placement of an Image

The Placement tab is used to move an image to a location in three-dimensional space. When 
you place an image along the Z axis, it will appear to change size. The axis of rotation moves 
with the image. The numeric values for Placement are screen-specific. The numbers 
represent the distance between the center of the image and the center of the screen. 
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An easy way to remember what Placement does is to think of the image as a piece of paper. 
You can move the piece of paper to your left or right, or up and down, or you can move it 
closer to you or farther away.

Changing the Size of an Image

The Size tab is used to stretch and compress the video horizontally and vertically. When 
adjusted individually, X and Y sizing effectively changes the image’s aspect ratio. When the 
two values are equal, the image retains the 4:3 aspect ratio and will proportionally stretch or 
compress. A value of .500 in each Text Box will size the picture to one-half of the original in 
each dimension, so that it occupies one-quarter of the screen. 

Layout Properties — Placement Tab Settings  

Setting Description

Reset Returns all values to the default.

X Slider Moves the video horizontally along the screen’s X axis. Positive X 
values are right of screen center; negative X values are left of 
screen center. 

Y Slider Moves the video vertically along the screen’s Y axis. Positive Y 
values are above screen center; negative Y values below 
screen center. 

Z Slider Moves the video along the screen’s Z axis. Positive Z values are in 
front of the screen, negative Z values are behind the screen. 
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Numeric values for Size are image-specific. The default setting fills the screen.

n Although it might appear the image is moving closer or further away as you adjust size, the 
image remains at a fixed position in 3D space and only its size changes. Keep the X and Y 
values equal to maintain proportion.

n Use Z-placement as an easier way to change the apparent size while maintaining aspect 
ratio. Click on the Placement tab to access this property.

Layout Properties — Size Tab Settings  

Setting Description

Reset Returns all values to the default.

X Slider Stretches or compresses the video horizontally along the image’s X 
axis. When the Text Box value shows 1.000, the image will fill the 
video raster horizontally. 

Y Slider Stretches or compresses the video vertically along the image’s Y 
axis. When the Text Box value shows 1.000, the image will fill the 
video raster vertically. 
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Cropping an Image

This Layout page is used to trim an image to eliminate unwanted picture areas. The numeric 
values for Crop are image-specific and represent the distance of each edge from the center of 
the image.

Layout Properties — Crop Tab Settings  

Setting Description

Reset Returns all values to the default.

Left slider Moves the left crop edge in and out.

Right slider Moves the right crop edge in and out.

Top slider Moves the top crop edge down and up.

Bottom slider Moves the bottom crop edge up and down.
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Working with DNA

This chapter describes the Thunder Dynamic Network Access (DNA) option. The DNA 
option allows you to browse any network-accessible directory and display all of the clips or 
image files contained there in exactly the same way that Thunder displays a regular Thunder 
database. This is achieved by using the DNA feature to establish a connection to 
that directory.

The following sections are included:

• Creating DNA Entries

• Browse a ClipDeko Database

• Connecting to a Quantel Product

• Connecting to an FTP Server

• Connecting to a Chyron Product

Creating DNA Entries

The DNA feature is accessed through the Network tree. Once the connection is opened, 
picons begin to appear for all of the image files in the directory. The picons are treated like 
any other picons. For example, they can be “dragged and dropped” to Thunder databases. 
Images from Thunder databases can be dragged to the server database.

n If you want to play a DNA item in a sequence, it must be added to the Thunder database first. 
Then drag the newly created Thunder clips and image files from the database to 
the sequence.
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There are six DNA scenarios:

• Connecting to a Deko device. For more information, see “Creating DNA Entries” on 
page 149.

• Connecting to a Quantel® Product. For more information, see “Connecting to a Quantel 
Product” on page 154.

• Connecting to a Chyron® Product,. for more information, see “Connecting to a Chyron 
Product” on page 157.

• Connecting to an FTP server. For more information, see “Connecting to an FTP Server” 
on page 156.

• Connecting to a File System Directory (such as an Apple® Macintosh®)

• Connecting to a ClipDeko database. For more information, see “Browse a ClipDeko 
Database” on page 153.

Normally, the DNA Connection Properties dialog box is configured at installation. If you 
need to adjust these settings, contact your Avid representative for assistance.

To create a DNA entry:

1. Make sure that you know the full path name to the directory you want. This can be a 
UNC path name such as \\machine_name\directory or a full local path name such as 
d:\directory.

2. Within Thunder, make the Network Tree visible.
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3. Right-click on the DNA entry in the Network Tree and select Create New 
DNA Connection.

The DNA Connection Properties dialog box opens.

4. Enter the appropriate information regarding the directory. The name and path fields 
must be filled in. The Host Address, Login and Password fields will be ignored (this is 
not true for TCP/IP). For file system connections, make sure that Use FTP is 
not checked.

5. Enter the information you want and click OK to accept the information.
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6. Double-click on the DNA entry in the Network Tree to see a list of available 
DNA connections.

7. Double-click on the appropriate DNA connection to open it.

The following table describes the settings in the DNA Connection Properties dialog box.

DNA Connection Properties Settings  

Setting Description

Name The name of this connection. This name will appear in the network 
Tree View. Select a name that will be meaningful to all users.

Host Address The IP network address or name of the FTP server. This can be of 
the form of an IP address, such as 204.118.92.101, or a host name 
such as ftp.pinnaclesys.com. This field is unused for non-
FTP connections.

Port The IP port number to use. For 99% of all FTP servers this will be 
21. This field is unused for non-FTP connections.

Passive Mode Tells the system to use passive mode for talking to the FTP server. 
This is sometimes necessary when connecting through a firewall. 
This field is unused for non-FTP connections.

Login The user name for FTP server login. This field is unused for 
Chyron and Quantel mode connections and for Non-FTP 
connections. The name “anonymous” is often used for FTP sites.

Password The password for FTP server login. This field is unused for Chyron 
and Quantel mode connections and for non-FTP connections. 
When the user name is “anonymous,” enter a valid email address 
for the password.

Path The path on the server for FTP connections. For example /pub 
would be a likely FTP path. For a non-FTP connection, this should 
contain the full UNC for the local path name of the directory where 
the desired clips and image files are located, e.g., d:\images\*.bmp.

For a Quantel™ FTP connection, this field can be used to prefilter 
the clips and image files shown. For example /date=today will 
show only those clips and image files created today. Refer to the 
Quantel documentation for a list of items that can appear in 
this field.

# of Picons Enter the maximum number of picons you want to download at a 
time from the remote system.
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Browse a ClipDeko Database

Thunder can directly hook up to a Deko database if the DNA option is installed. You might 
need to install DAO from the CD by going to the folder Resources > jetinstall and running 
setup.exe. After the installation, run the appropriate service pack for your operating system 
in the Service Packs subfolder.

1. Right-click on DNA and select Create New DNA Connection.

Use FTP Check this box if the connection uses FTP. Uncheck it for file 
system connections.

Chyron Mode FTP Check this box when talking to a Chyron product. It causes 
Thunder to use the non-standard FTP protocol used by 
Chyron products.

Quantel Mode FTP Check this box when talking to a Quantel™ product. It causes 
Thunder to use the non-standard FTP protocol used by 
Quantel products.

Text Mode Check this box to make a text mode connection.

Keep FTP open Check this box to keep the FTP connection open even if it 
is inactive.

Deko DB Check this box to connect to a ClipDeko database. The Host 
Address field will change to read “Deko DB” and let you specify 
the path to the desired database.

Image Format This set of buttons selects the format to use when sending new 
image files to this connection.

Chyron Import/Export Control Makes adjustments for frame size and offset of images from a 
Chyron product.

DNA Connection Properties Settings (Continued)  

Setting Description
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2. Check the Deko DB box in the DNA Connection Properties dialog box.

3. Give the connection a name in the Name field. This is the name that will appear under 
DNA in the tree list.

4. The second field at the top changes to Deko DB. Click on the ellipsis ("…") button to 
the right of the field to browse to the desired Deko database.

5. Click OK.

The new connection appears under the DNA folder in the tree list. 

6. Double-click on it to open the ClipDeko database. You can drag and drop items 
between databases.

Connecting to a Quantel Product

The Thunder DNA option allows you to browse a Quantel™ product which supports FTP 
connectivity, and to display all of the image files contained there in exactly the same way 
that Thunder displays a regular Thunder database. 

To connect to a Quantel product:

1. Make sure that the Quantel FTP option is installed on the Quantel product. You must 
also know the IP address of the Quantel product.

2. Make your that your Thunder system is on a network that can communicate with the 
Quantel device. Test this by running the DOS FTP client from a Command Prompt 
window within Windows XP.

3. Within Thunder, ensure that the Network Tree is visible.

4. Right-click the DNA entry in the Network Tree and select Create New 
DNA Connection.
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5.  When the DNA Connection Properties dialog box appears, enter the appropriate 
information regarding the Quantel device in the dialog box.

The Host Address and Name field must be filled in. The Login and Password field will 
be ignored. Ensure that Quantel Mode FTP is checked and that .vpb is selected under 
Image Format.

6. After all of the desired information is entered, press OK to accept the information.

7. Double-click on the DNA entry in the Network Tree to see a list of available 
DNA connections.

8. Double-click on the appropriate DNA connection to open it.

n If you want to play a DNA item in a sequence, it must be added to the Thunder database first. 
Then drag the newly created Thunder clips and image files from the database to 
the sequence.
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Connecting to an FTP Server

The Thunder DNA option allows you to browse a remote FTP server and display all of the 
image files contained there in exactly the same way that Thunder displays a regular 
Thunder database. 

To connect to an FTP server:

1. Make sure you know the network name or IP address of the desired FTP server. You also 
make need to know the login name and password on that system.

2. Make your that your Thunder system is on a network that can communicate with the 
FTP server. Test this by running the DOS FTP client from a Command Prompt window 
within Windows XP.

3. Within Thunder, ensure that the Network Tree is visible.

4. Right-click the DNA entry in the Network Tree and select Create New 
DNA Connection.
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5. Enter the appropriate information regarding the desired FTP server in the DNA 
Connection Properties dialog box. Be sure the FTP box is checked.

6. After all of the desired information is entered, click OK to accept the information.

7. Double-click on the DNA entry in the Network Tree to see a list of available 
DNA connections.

8. Double-click on the appropriate DNA connection to open it.

Connecting to a Chyron Product

The Thunder DNA option allows you to browse a Chyron product which supports FTP 
connectivity, and to display all of the still images contained there in exactly the same way 
that Thunder displays a regular Thunder database. 
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To connect to a Chyron product:

1. Make sure that the Chyron FTP option is installed on the desired product. Also make 
sure that you know the IP address of the desired Chyron product.

2. Make sure that your Thunder system is on a network that can communicate with the 
Chyron device. Test this by running the DOS FTP client from a Command Prompt 
window within Windows XP.

3. Within Thunder, ensure that the Network Tree is visible.

4. Right-click the DNA entry in the Network Tree and select Create New 
DNA Connection.
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5.  When the DNA Connection Properties dialog box appears, enter the appropriate 
information regarding the Chyron device in the dialog box.

The Host Address and Name field must be filled in. The Login and Password field will 
be ignored. Ensure that Chyron Mode FTP is checked and that .bin is selected under 
Image Format.

6. After entering the information you want, click OK to accept the information.

7. Double-click on the DNA entry in the Network Tree to see a list of available 
DNA connections.

8. Double-click on the appropriate DNA connection to open it.

9. Under the Chyron Import/Export Control, adjust the Offset to line up the Chyron 
images. The range is from �10 to +10. The offset might depend on which Chyron model 
you are using.

10. Determine the dimensions of the clips or stills on the Chyron machine and enter their 
frame width in pixels and their frame height in scanlines in the fields provided.

11. Click OK when you are done.
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n If you want to play a DNA item in a sequence, it must be added to the Thunder database first. 
Then drag the newly created Thunder clips and image files from the database to the 
sequence.
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File Formats and Options

This chapter describes the supported formats and options in the Thunder application. The 
following sections are included:

• Image File Formats

• Adding Options to Thunder

• Software Application Key

• Hints and Tips

Image File Formats

Many kinds of graphic files are used in broadcasting. This section describes the graphic file 
formats that are supported and unsupported when importing graphics into Thunder.

The following topics provide more information about image file formats:

• “Supported Formats” on page 162

• “Unsupported Formats” on page 163
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Supported Formats 

The following graphic file formats have been thoroughly tested and are known to work 
with Thunder:

Supported Image File Formats  

Extension Format

.avi Windows AVI files, including MPEG2 clips. Can be exported in 
.mp2 format or as a combination of .mp2 and .wav files.

.bin Chyron files (using the Avid file name suffix)

.bmp Windows Bitmap files

.dib Windows Device Independent Bitmap files

.dko Avid TypeDeko files

.dv DV25 files

.g Avid 10-bit YUVK file used by Thunder and DVExtreme. Can carry 
key information.

.jpg JPEG files

.m2v M2V files

.mov QuickTime movie files

.mp2 MPEG audio files

.mxf MXF Files

.tga Targa® files. Can carry key information.

.tif TIFF files

.tmf Avid clips

.vpb Quantel Video PaintBox™ format used by PaintBox™, PictureBox™ 
and PictureBank™

.wav Windows WAV files
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Unsupported Formats

The following image file formats have not been tested with Thunder. Files saved in one of 
these formats might not work when imported into Thunder. Avid recommends using the 
fully supported file formats listed in “Supported Formats” on page 162 whenever possible 
for the best and consistent results.

Unsupported Image File Formats  

Extension Format Extension Format

.brk Brooktrout .pcx ZSoft Pc Paintbrush

.cal CALS Raster .pgm Portable Graymap

.cals CALS Raster .pct Macintosh PICT

.cif IBM® Converted Image .png Portable Network Graphics 

.clp Windows Clipboard .pnm Portable Any-map

.cut Dr. Halo® Image .ppm Portable Pixmap

.dcx ZSoft® Multiple pcx .psd Adobe Photoshop

.eps Encapsulated Post Script .ras CALS Raster

.epi Encapsulated Post Script .ras Sun Raster™ Format

.ico Windows Icon .rle Run Length Encoded

.iff Electronic Arts Interchange 
Format

.sgi SGI® Image File Format

.img GEM Raster .wmf Windows MetaFile

.ica IBM IOCA .wpg Word Perfect Graphic

.mac MacPaint® .xbm X-windows Bitmap

.msp Microsoft Paint .xpm X-windows Pixmap

.pbm Portable Bitmap .xwd X-windows Window dump

.pcd Photo CD
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Software Application Key

A software application key (also called a dongle) is programmed to enable the software and 
options on individual Thunder systems. This arrangement allows you to upgrade that 
Thunder without installing additional hardware or software. The software application key 
plugs into the USB port on the back of the Thunder system.

Each software application key has a serial number and belongs to a specific Thunder system. 
Do not attempt to exchange software application keys among different Thunder systems. 
Some functions do not work if software application keys are switched or removed.

Adding Options to Thunder

Thunder can be upgraded by enabling certain options in its software. Options can be 
purchased through your dealer or from Avid, who will supply a 32 character password and a 
dongle to activate them. When you have purchased your option(s), click 
File > Preferences > Options to bring up the Options dialog box. Type the password into the 
Password field and select the options you want.

Thunder Options  

Option Description

Thunder The full Thunder software.

Thunder Browse A limited version of the Thunder software that operates on a 
regular PC.
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Copy your password to a Notepad or Wordpad file and save it in a separate directory on your 
system. Then it will be readily available if you ever have to reinstall Thunder.

You can continue to run Thunder after entering the password, but you must restart Thunder 
for the newly enabled option(s) to become active.

Hints and Tips

The following sections provide hints and tips that might help you with your Thunder 
application.

• “General” on page 165

• “Databases” on page 165

• “Sequences” on page 166

• “Paint” on page 166

General

Thunder starts in the display mode in which it was last set. For example, if Thunder was 
minimized when you closed the application, it is minimized when it is started.

Databases

Helpful database tips include:

• After adding new databases or a new DNA connection to the Network Tree, close the 
Thunder application to ensure that these databases are recorded in the tree.

• When using Renumber to renumber clips or image files to a different workspace, 
specify the workspace and starting still numbers in order to renumber correctly. For 
more information, see “Edit > Paste” on page 230.

Thunder Clip Enables Thunder to view video clips as well as stills.

Thunder DNA (Dynamic Network Access) Enables access to non-Thunder 
databases.

Thunder Ingest Enables Thunder to control and record clips from a VTR.

PostDeko Titling Interface with PostDeko character generator.

Thunder Options  

Option Description
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• Good databases result from careful and consistent use of fields for specific information, 
common abbreviations, and so on. All users should agree on these conventions before 
creating new clips and image files.

Sequences

Helpful sequence tips include:

• When using networked databases, new sequences don’t appear in the Network Tree until 
you double-click on the networked database folder.

• If you want to use the same clip or image file numbers but a different workspace in a 
sequence, create a sequence without the workspace number. For example, instead of 
typing “0.3” in the item event number box, you can just type “3”. This sequence can 
now be applied to any workspace with the appropriate item numbers.

Paint

Helpful Paint tips include:

• Paint only works on images files (stills), not on clips.

• When using your favorite paint application with Thunder, select a paint format which 
both your paint application and Thunder supports.

• If the image file permissions are set to “Nobody Read or Write”, you will not be able to 
launch paint with this image file.
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Thunder Toolbars and Menus

This chapter describes the user controls in the Thunder application. The following sections 
are included:

• Main Toolbar

• Air Toolbar

• Sequence Toolbar

• VTR Toolbar

• MiniMonitor Window — MiniMonitor Section

• MiniMonitor Window — Control Section

• Contexts and Controllers

• Title Bar

• Scroll Bars

• Right-Click Menus

• File Menu

• Edit Menu

• View Menu

• Air Menu

• Window Menu

• Help Menu
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Main Toolbar 
Keyboard shortcut: Ctrl+l 

The Main Toolbar is usually displayed across the top of the application window and below 
the menu bar, providing quick point-and-click mouse access to many tools used in the 
application. To show or hide the Main Toolbar, choose Show Main Toolbar from the View 
Menu. You can also move the toolbar to another location.

Icon Function

Open a sequence window

Save the currently active sequence window

Cut the selected sequence event(s) to the clipboard, deleting them from the sequence

Copy the selected clip(s) or sequence event(s) to the clipboard

Insert the contents of the clipboard into the current database or sequence

Print the active database or sequence window

Display the About Box

Enter Help Mode

Change the current database or sequence window to Text Below display

Change to Text Right display

Change to Detail display

Change the size of the picons in the current window to Tiny Images

p
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Air Toolbar
Keyboard shortcut: Ctrl+i 

The Air Toolbar is usually displayed across the top of the application window below the 
menu bar and provides quick mouse access to many tools used for on-air operations. The Air 
Toolbar can be moved to another location if you so desire. To display the Air Toolbar, select 
View > Show Air Toolbar. A check mark next to the menu item indicates that it is currently 
displayed. The functions on the Air Toolbar are also available on the Air Menu.

Change size to Small Images

Change size to Large Images

Change the current window to display Key Picons

Lock the Database

Icon Function

Icon Function

Perform a Take (F12).

Switch AutoTake on or off. When AutoTake is active (checked), the Preview clip or still 
transfers to the Program channel whenever a new item is played to the Preview channel. 

n AutoTake is only meant to work with databases (not sequences). In addition, 
AutoTake can only be controlled with the keyboard spacebar. You cannot use drag 
and drop, or F12 functionality.

n Toggle Mode and AutoTake mode can not be active at the same time.

Switch Toggle Mode on or off. If Toggle Mode is active (checked), the Program and 
Preview channels swap automatically after each item is played. 

n Toggle Mode is only meant to work with sequences (not databases).

n Toggle Mode and AutoTake mode can not be active at the same time.
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These functions do not have an icon on the Air Toolbar, but they are critical nonetheless:

• Record Clip. Records a clip from the current video feed. Right-click on a MiniMonitor 
and select Record Mode. Right-click again and select Record. This option brings up the 
Item Properties dialog box first.

• Quick Record Clip. Records a clip from the current video feed. Right-click on a 
MiniMonitor and select Record Mode. Right-click again and select Quick Record. This 
applies the existing template; the Item Properties dialog box does not appear.

Sequence Toolbar

The Sequence Toolbar is displayed across the top of each sequence window and provides 
quick mouse access to sequence play functions.

When using the Toolbar buttons, the Air Menu command equivalents or the keyboard 
shortcuts, the currently selected sequence event is always the point at which the play 
commences. For example, if sequence event #7 is currently selected when the Play Forward 
command is activated, sequence event #7 plays to the appropriate channel and the sequence 
proceeds in a forward direction playing #8, #9, etc. If you want to play the sequence from 
the beginning, remember to select sequence event #1 to select it before activating a 
play command. 

Freeze or unfreeze the Live channel (F10).

Apply the Filter (F11).
The filter modifies the image in the Live channel by removing interfield flicker or motion.

Quick Save a still image file to the active database window using the template for the 
database information (F8).

Save a still image file to the active database window while entering database information 
(Shift+F8).

Lock the Channel assignments to their current settings.

Link the Channel assignments so they move together from one MiniMonitor to another.

Icon Function
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VTR Toolbar 

This function is an option on Thunder. Before attempting to use it, be sure the Ingest option 
is enabled and properly configured. The VTR Toolbar lets you control your VTR from the 
Thunder user interface.

The VTR Toolbar consists of playback controls, combined with a slider to control deck 
shuttle speeds and timecode display. With your mouse, click and drag the slider left or right 
to move the tape. When you release the mouse button, the slider returns to center and the 
tape stops moving.

To see the VTR Tool bar, select it in the View Menu. When the VTR Toolbar is black, as 
shown above, it is online and ready to work. If the VTR Toolbar is grayed out, you must 
configure the connection between your VTR and Thunder. See also “Recording a Clip from 
a VTR” on page 61.

Icon Function

Play the active sequence forward starting from the currently selected item (F7).

Loop the active sequence forward from the currently selected item (Shift+F7).

Play the active sequence backward starting from the currently selected item (Ctrl+F7).

Loop the active sequence backward from the currently selected item (Shift+Ctrl+F7).

Stop the sequence run (Esc).

[Red] Play the current event to air (Space).

[Yellow] Preview the current event [turns off preview-inhibit] (Enter).
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Icon Function

Rewinds the clip

Rewinds the clip used for a reverse search

Plays the clip backward

Steps the clip backward one frame at a time

Stops the clip on the current frame

Pauses the clip on the current frame

Steps the clip forward one frame at a time

Plays the clip forward

Fast-forwards the clip used for a forward search

Fast-forwards the clip

Jog and shuttle slider. Click on the slider and mover it to the left and right to 
view the clips forward and backward.

Displays timecode embedded in the frame
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MiniMonitor Window — MiniMonitor Section
Keyboard shortcut: Ctrl+m

This window has two major areas: the MiniMonitor Section is on the right.

MiniMonitors have several components, including the assigned clip with its icons, the clip 
number, play mode controls to play the clip, and a cue showing the next clip in the sequence.

MiniMonitor
section

System channel number

Play nodes

Cue window

Bug windowBug fader

next clip in cue

Clip number

Function controls
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Each MiniMonitor corresponds to a system channel and can be turned on or off in the 
Channel Configuration dialog box. 

To access the Channel Configuration dialog box:

t Click File > Preferences > Channel Configurations. 

The MiniMonitor displays the picon of the current clip on that output. 

Above each picon are three function controls that set the MiniMonitor outputs to the 
Program, Preview or Live channels. Any one MiniMonitor might have zero, one, two, or 
three channel assignments. To make channel assignments, click on the appropriate indicator 
box above each MiniMonitor. In most cases, you should keep all three controls on the same 
MiniMonitor: 

Use the Lock Channels and Link Channels button on the Air Toolbar to preserve your 
control indicator selection. For more information, see “Air Toolbar” on page 169 and “File > 
Preferences > Channel Assignments” on page 196.

You can also make Channel assignments using the numeric keys along the top the keyboard. 
Be sure the MiniMonitor assignments are not locked or linked, see “Air Toolbar” on 
page 169. You must use the number keys along the top of the keyboard for this purpose (not 
the numeric keypad):

You can click and drag an image from any MiniMonitor to a database to quick save it using 
the current template information.

Indicator  Color Channel

Left Red Program

Center Yellow Preview

Right Green Live

Keyboard Description

Keys 1 through 8 Move the channel selection indicator.

Shift+1 through Shift+8 Move the Program indicator to the corresponding channel.

Ctrl+1 through Ctrl+8 Move the Live indicator to the corresponding channel.
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MiniMonitor Window — Control Section
Keyboard shortcut: Ctrl+m

This window has two major areas: the Control Section is on the left 

The Control Section contains the following:

Control
section

Control Section Setting  

Setting Description

Transition The transition used for takes.

Duration The duration of the transition in hours:minutes:seconds:frames.

Input The input source for recording. Refers to connectors on the back of 
the Thunder.

The “down” arrow to the right of each control opens a pull-down 
list of additional available selections.

Context The current context is shown at the bottom of the Control Section.
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A context is a set of assignments for the MiniMonitor section which is independent for each 
controller. Each window can be set to independent context for Program, Preview and Live 
allocations. Examples of controllers include a QWERTY keyboard and an automation 
system. Independent controllers typically have their own Program outputs. For more 
information, see “Contexts and Controllers” on page 176.

Contexts and Controllers

A Context is a set of assignments for the MiniMonitor section which is independent for each 
controller. Examples of controllers include a QWERTY keyboard and automation protocols 
such as MOS and VDCP. Context is indicated in the Control Section of the MiniMonitor, as 
shown.

Keyboard windows can be set to Independent Context for Program, Preview and Live 
allocations, indicated as follows (the red box is part of the Thunder interface). To the 
contrary, sequence windows cannot have an Independent Context.

A context applies to database and sequence windows. The context settings include: 

• There is a context created for the keyboard when Thunder is run.

• In addition, a context is created for each controller (such as an automation system) that 
is configured.

• All windows opened from the keyboard use the same Keyboard Context assignments.

• Similarly, sequences or databases opened from a controller use the controller’s context. 

Channel Assignments MiniMonitor Control Section Assignments

Program

Preview

Live

Transition

Duration

Input
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When adding new controllers to the system, see “File > Preferences > Configure 
Controllers” on page 200. To specify a controller’s protocol, see “File > Preferences > 
Protocol Setup” on page 213.

Title Bar

The Title Bar is located along the top of a window. The following are example title bars in 
different modes in the Thunder application.

A Title Bar contains the following controls.

• Application Control icon

• Name of the database, sequence, DNA, clip or image file

• Minimize button

• Maximize button

• Close button

The title bar appears at the top of every application window, including Thunder. Click the 
left icon to view the available commands. 

The following topics provide more information:

• “Move” on page 178

• “Size” on page 178

• “Minimize” on page 178

• “Maximize” on page 178

Database

Sequence

DNA

Clip or Image
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• “Close” on page 179

• “Next Window” on page 179

• “Exit” on page 179

Move

Use this command to adjust the position of a window.

To move a window:

t Click the title bar and drag the window to a new location and release the mouse button.

To move a toolbar:

t Position the mouse cursor on any edge, click the edge and drag it to the desired location 
and release the mouse button.

Size

Use this command to adjust the size of a window. 

To size a window:

1. Position the mouse cursor on any edge of the window until the cursor changes to a 
double-pointed arrow. 

2. Click the edge and drag the arrow to size the window.

3. Release the mouse button when the widow is at the size you want.

Minimize

Use the Minimize command to turn a window into an icon, which uses minimum space on 
the screen.

To minimize a window:

t Click the Minimize button.

Maximize

Use the Maximize command to maximize a window or an application. A window is 
maximized when it consumes all available space on the screen.

To maximize a window:

t Click the Maximize button.
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Close

Use the Close command to close a window or an application. 

To close a window do one of the following:

t Click the Close button.

t Press Ctrl+F4 (closes the active sequence or database window) or Alt+F4 (closes a 
dialog box or the entire application).

t Double-click on a window or application control box to close it. The following windows 
close with this action:

- Sequence window

- Database window

- DNA window

- Show Picture window

Next Window

Use this command to switch to the next open Database window or Sequence window. 
Thunder determines which window is next according to the order in which you first opened 
them. 

To switch to the next window:

t Press Ctrl+F6 (closes the active sequence or database window) or Ctrl+Tab 

Exit 

To exit the Thunder application:

1. Do one of the following:

t Double-click the application icon in the upper left of the Title Bar

t Click the close button at the far right of the Title Bar.

t Press Alt+F4.

t Click File > Exit.

2. Click OK to confirm you want to leave the application.
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Scroll Bars

The scroll bars are displayed at the right and bottom edges of the document window. The 
scroll boxes inside the scroll bars indicate your vertical and horizontal location in the 
window. Use the mouse to scroll to other parts of the window.

Scroll bars
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Right-Click Menus

Clicking the right mouse button accesses one of three function-specific popup menus. These 
menus act as additional shortcuts for the related functions.

Clicking the right button on a Picon displays this menu, allowing you to:

• Play the clip or image file to the Preview MiniMonitor.

• Insert this clip or image file after the highlighted picon in a 
Sequence.

• Delete the clip or image file.

• Display an enlarged image of the clip or image file using Show 
Picture.

• Launch the Paint application. Works with still images only.

• Launch the TitleDeko option. Works with still images only.

• Renumber the clip or image file.

• Generate a new proxy for this clip.

• Export this clip.

• Create a bug for this clip.

• Launch Preview Window with the clip pre-loaded.

• Bring up the Item Properties dialog box.

Clicking the right button on a picon and dragging the mouse over another 
picon in a Thunder database allows you to:

• Copy the clip or its shortcut to this new location.

• Copy the Master Clip.

• Copy only the frames used from the Master Clip.

• Create an external clip.

Clicking the right button on a picon and dragging the mouse over another 
picon in a Lightning database allows you to:

• Copy the clip or still to this new location.

To access the DNA Connections menu, right-click on the DNA section of 
the Network Treeand and select Delete, Create, or Edit a DNA 
Connection from the menu.
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When you right-click on the background of a database or sequence 
window (not on a picon), this popup menu appears. 

Most of these are the same functions as the View Menu. 

At the bottom are two additional shortcuts:

• Insert Clip brings up the Clip page Item Properties dialog box.

• Grab Still from Clip brings up the Grab Still from Clip dialog box.

When you right-click in a MiniMonitor window, this popup menu 
appears. A few of these are the same functions as the Air Menu.

The most important functions are:

Apply Filter — Cleans up interfield flicker.

Playback Mode — Configures Thunder to play clips.

Record Mode — Configures Thunder to record clips.

Record — Prompts with the Item Properties dialog box before recording 
clips.

Quick Record — Records clips using settings in the current template.

Cue RecordPrompts with the Item Properties dialog box, then waits 
until you click the record button on the Minimonitor before recording.

Quick Cue Record — Waits until you click the record button on the 
MiniMonitor, then records clips using settings in the current template.

Pause Record — Allows you to pause recording without ending the 
recording of a clip.

VTR Record — Configures Thunder to record clips from a VTR. It 
controls the VTR and cue it to in and out points.

Display Current Timecode — Toggles the time count displayed in the 
MiniMonitor. When checked, it counts up from zero during playback. 
Uncheck it to show the time remaining in the clip.
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File Menu
The File Menu contains the following commands when a sequence window is active.

File Menu Commands  

Command Description

New Sequence Creates a new sequence in the current database. 

Open Opens an existing database or sequence window. 

Close Closes the currently active database or sequence window. 

Save Automatically overwrites the disk copy of the currently active 
sequence. 

Save As Saves the currently active sequence with a new name. 

Lock Database Locks the current database for exclusive access 

Logout Logs the current user out. 

Print Prints the contents of a database or sequence window. 

Print Preview Displays the document on the screen as it will appear when 
printed. 

Page Setup Selects the page format and printer information.
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The following topics provide more information about the submenus in the File menu:

• “File > New Sequence” on page 184

• “File > Open” on page 185

• “File > Close” on page 186

• “File > Save” on page 186

• “File > Save As” on page 186

• “File > Lock Database” on page 187

• “File > Logout” on page 187

• “File > Print” on page 188

• “File > Print Preview” on page 189

• “File > Page Setup” on page 190

• “File > Preferences” on page 191

File > New Sequence

This command opens a new sequence window. 

Preferences Accesses a series of system preferences. 

Advanced Access Create and Restore database commands, and, if you have a 
Thunder HY system, enables you to save one set of user 
preferences for standard-definition (SD) settings and a different set 
for high-definition (HD) settings.

Recent Files Shows a list of the last ten windows closed. Use this to list quickly 
reopen these files without searching for them on the hard drive or 
network.

For a list of open windows, click the Window Menu. 

Exit Closes the Thunder application and exits to the Windows desktop.

File Menu Commands  
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To switch to the next window:

t Click File > New Sequence. 

t Press Ctrl+N. 

The sequence is automatically named “seqXXXXX”, where XXXXX is the number of the 
last new sequence, plus 1. The new sequence is automatically entered into the Network Tree. 
You can rename the sequence using the Save As command, but this does not delete the 
original sequence. 

To place images into the sequence, see “Edit > Copy” on page 230 and “Edit > Paste” on 
page 230. 

File > Open

Keyboard shortcut: Ctrl+O 

Use this command to open an existing database or sequence window. In the Open dialog 
box, double-click the file name to open it.

When you open a file, Thunder adds a path to the database and its sequences in the Network 
Tree. If the database or sequence already appears in the Network Tree, you can open it by 
positioning the mouse cursor on the file and double-clicking the left mouse button. As an 
alternative, select or reopen a file from Recent Files under the File Menu. 

You can switch between multiple open windows using the Window Menu. In addition, it is 
possible to open multiple copies of the same window using the New Window command 
under the Window Menu.
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File > Close 

Keyboard shortcut: Ctrl+F4 

Use this command to close the currently selected database, sequence, picture or DNA 
window. If you are using this command to close a sequence that has been edited, you are 
prompted to save the changes.

Select Yes to overwrite the copy of the changes. To avoid overwriting the sequence, picture 
or DNA window, click Cancel in the dialog box then use the Save As command in the 
File Menu. 

You can also close a window by double-clicking the control box icons (upper left corner).

If multiple copies of a sequence or database windows are open, using this command closes 
all copies. 

File > Save 

Keyboard shortcut: Ctrl+S

This command is used to immediately overwrite the currently selected sequence window on 
the hard drive. There is no warning popup associated with this command. If you want to save 
a new version of the sequence under a different name, use the Save As command. This 
command is only visible when a sequence window is active. 

File > Save As

Use this command to rename an existing sequence, thus avoiding overwriting the original 
copy on the hard drive. When the Save As command is selected, the Save As dialog 
box appears.

Application Sequence Database DNA Picture
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Enter the new file name and click the Save button or press the Enter key to complete the 
process. The new file name is transferred to the active sequence window, which remains 
open. This command is only visible when a sequence window is active.

File > Lock Database

The Lock Database command locks the current database for exclusive use. Once a database 
is locked, it cannot be opened by any other user. Use this command carefully. 

File > Logout 

Use this command to log out of the system. When selected, the current user is immediately 
logged out of the system and the dialog box at the right is displayed.

A new user is required to enter their name and password before the application can be used 
again. Note that if a user closes this window without entering valid ID information (by 
clicking the close button), you will have access only to workspace 0. All other workspaces 
will be disabled. The Security Administrator enables these security features.
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File > Print 

Keyboard shortcut: Ctrl+P 

 

Use the Print command to print the current database or sequence window. This command 
presents a standard Windows Print dialog box in which you specify the range of pages to 
print, the number of copies, the destination printer, and other printer setup options. 

Use the following options to specify how to print the currently selected window.

Print Window Options  

Option Description

Printer The active printer. Click on the down-arrow icon to select other printers. 

Properties Select the Properties option to configure the printer. This displays a 
Setup dialog box which is specific to the type of printer connected. 

Print Range Specifies the pages you want to print: 

All Prints the entire document. 

Selection Prints the currently selected text. 

Pages Prints the range of pages specified in the From and To boxes. 

Copies Specify the number of copies you want to print for the above page range. 



File Menu

189

Paper size, page layout, orientation and margins are set in the Page Setup dialog box, see 
“File > Page Setup” on page 190. 

File > Print Preview 

Use this command to display the active window as it will appear when printed. This 
command replaces the main window with a print preview window in which one or two pages 
will be displayed in their printed format.

To return to the main application:

t Click the Close button. 

n When printing selected items, Print Preview shows all items, however, only the selected 
items are actually printed.
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File > Page Setup

This dialog box lets you select the format of the pages you want to print.

The following controls alter the printed page as shown. 

Page Setup Options  

Option Description

Items per Row Selects the number of picons to appear per row on the printed page. 

Print Database Info When activated, one picon and its database information will be printed 
per row.

Print from Image files When selected, image files are used for printing instead of the picon 
files. 

This results in a much higher quality printout but is very slow since the 
system must read the entire image file, scale it to the appropriate size, 
and send it to the printer. Print preparation times are often in excess of 
one minute per page. 

Paper Size Selects the size of paper you want to use. The available choices will 
depend on your printer and options installed. 

Paper Source Selects the tray, sheet feeder or other source for the paper. The available 
choices will depend on the printer and options installed. 
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To select printers, print range, number of copies, and other printing options:

t Click File > Print to open the Print dialog box.

File > Preferences

The File > Preferences command displays another submenu that contains a number of 
additional commands to enable you to change your Thunder Preferences. For more 
information, see the following table.

Orientation

• Portrait Prints vertically. If the Print Database Info is enabled in Page Layout, 
eight picons with their associated database will be printed on each 8.5 x 
11” page.

• Landscape Prints horizontally. If the Print Database Info is enabled in Page Layout, 
four picons with their associated database will be printed on each 8.5 x 
11” page. 

Margins Selects the amount of unprinted page to the left, right, above and below 
the picons. The margins cannot be set less than allowed by the printer. 

Printer Press this button to bring up the Printer dialog which allows you to 
change printers and set printer-specific options. 

Page Setup Options (Continued)  

Option Description

File Preferences Commands  

Command Description

Channel Configuration Names channels, assign input, control, hardware, MiniMonitors, etc.

Channel Assignments Locks channel assignments of MiniMonitors or Links the 
assignments so they all move together. You can also use the Air 
Toolbar. 

Select Drag Export Format Selects file type for still image files moved by drag and drop.

Import/Export Options Adjusts scaling of imported and exported still image files.

Configure Controllers Configures controls for external devices, such as an automation 
system.

Select Scanner Selects the scanner attached to your Thunder system.
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The following topics provide more information about the submenus in the File > Preferences 
menu:

• “File > Preferences > Channel Configuration” on page 193

• “File > Preferences > Channel Assignments” on page 196

• “File > Preferences > Select Drag Export Format” on page 197

• “File > Preferences > Import / Export Options” on page 198

• “File > Preferences > Configure Controllers” on page 200

• “File > Preferences > Select Scanner” on page 201

• “File > Preferences > Configure VTR” on page 202

• “File > Preferences > Configure Paint” on page 204

• “File > Preferences > Select Background Color” on page 205

• “File > Preferences > Select Security Database” on page 206

• “File > Preferences > Configure Clip Servers” on page 207

Configure VTR Configures protocols, channels and other settings for recording clips 
from a VTR. Called Ingest, this feature is an option.

Configure Paint Sets the path and file format for a Paint application.

Select Background Color Selects color displayed behind the picons.

Select Security Database Selects available databases and sets access and passwords.

Configure Clip Servers Configures connections to Thunder.

Protocol Setup Configures communication with external devices that control 
Thunder.

Database Option Makes three optional changes to clip and image file management.

Options Activates optional features of Thunder.

Assign and Enable GPIs Programs and enables GPI control.

Sequencer Uses Database 
In/Out points

Uses the in/out points for clips as listed in the database, rather than 
those set for the clips when they were added to the sequence (the 
default behavior).

Generate Proxy After Record Toggles option to automatically generate a proxy for any newly-
recorded clip.

File Preferences Commands (Continued)  

Command Description
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• “File > Preferences > Protocol Setup” on page 213

• “File > Preferences > Database Options” on page 215

• “File > Preferences > Options” on page 217

• “File > Preferences > Assign GPIs” on page 218

• “File > Preferences > Enable GPI Triggers” on page 219

• “File > Preferences > Drop Frame Timecode” on page 219

• “File > Preferences > Sequencer Uses Database Input/Output Points” on page 220

• “File > Preferences > Generate Proxy After Record” on page 220

File > Preferences > Channel Configuration

The Channel Configuration dialog box is used to:

• Name channels

• Assign control of channels to the keyboard and/or automation

• Select which channels appear in the MiniMonitor section

• Assign hardware to channels

• Select the background for each channel.

Thunder saves the settings in this dialog box and recalls them when the application 
is reopened.



 Appendix B Thunder Toolbars and Menus

194

The following fields can be changed. 

Channel Configuration Dialog Box  

Setting Description

Name Use this field to type a channel name which will appear below that 
channel in the MiniMonitor Window. 

Kbd When a check mark appears in this column, the associated channel 
can be controlled from the keyboard. If there is no check mark, 
keyboard access to that channel is denied. 

Controllers This column is used to control access to the channels from external 
controllers, such as automation systems. If there are no external 
controllers configured, then this column will be disabled. The 
pulldown menu at the top of the column can be used to select 
which controller is currently being configured. 

MiniMon Determines whether the associated channel is shown in the 
MiniMonitor Window. If there is no check mark, the channel is 
still available for playing clips and image files (provided one or 
more of the Kbd and controller boxes has been checked), but it will 
not be shown on the MiniMonitor. 

Input Key When checked, Thunder will capture the signal supplied to the key 
input at the same time the video is captured. See the note below. 
When not checked, Thunder will replace the input key signal with 
an opaque full screen key in the recorded image file. 
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Hdw Channel Click the down arrow to display a list of the installed hardware 
channels and soft channels. To change the assignment, click the 
new setting. Each Thunder system can support up to four hardware 
channels (the number in your system will depend upon how many 
channels were purchased). To assign a hardware channel as a video 
output, click the down arrow and select the appropriate setting.

In addition, Thunder supports software channels. A soft channel 
has no video output, however you can play clips and image files to 
the frame buffer associated with it. 

Soft channels can also be used as the Preview channel when no 
hardware channel is available. This allows playing of multiple 
sequences simultaneously using a combination of hardware and 
soft channel allocations. Each controller can have a different 
setting, so each “user” can play a sequence.

Soft channels are not required to play a sequence. You can play a 
sequence with transitions to a single hardware channel set to 
Program (red). You can still preview on a soft channel set to 
Preview (yellow).

The number of simultaneous sequences you can play is determined 
by the number of hardware channels your system has.

Background Selects the background for keyed clips and image files. The 
choices are:

• **None** No key processing or background mixing will be performed in 
Thunder. Use this selection when the output will feed a 
downstream keyer.

• Black Clips and image files will be keyed over internally generated 
black (7.5 IRE).

• SuperBlack Clips and image files will be keyed over internally generated super 
black (0 IRE).

• Hdwr. 1, 2, etc. Clips and image files will be keyed over video from these 
external inputs.

Audio Your audio source will be set to Embedded, which uses the audio 
that is part of the video signal.

Enable Bug This option enables the use of a bug (a still or short clip played 
over the output of a channel, such as a logo graphic) on 
this channel.

Channel Configuration Dialog Box (Continued)  

Setting Description
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If you are recording clips with Keys:

1. Enable Key recording on the Input Channel you are using (described above).

2. Enable Key on the Video tab of the Item Properties / Template dialog box. See 
“Template and Item Properties — Video Tab” on page 240.

3. Select the type of filter on the Record Setup tab of the Item Properties / Template dialog 
box. See “Template and Item Properties — Clip Tab” on page 242.

File > Preferences > Channel Assignments

Lock Channel Assignments

When this function is checked in the File > Preferences Menu, it locks channel assignments 
of MiniMonitors. This feature prevents accidental changes.

You can also use the Lock button in the Air Toolbar to lock or unlock the 
channel assignments.

Black on Stop When this item is checked, the channel goes to a black frame when 
playback stops.

Channel Configuration Dialog Box (Continued)  

Setting Description
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 Link Channel Assignments

When this function is checked in the File > Preferences Menu, it links channel assignments 
of MiniMonitors. This feature makes it easy to move assignments together 
among MiniMonitors.

Use the Link button in the Air Toolbar to link or unlink the channel assignments. If there are 
two or more channel assignments on one MiniMonitor, you can move them all together.

It is best to keep all three channel assignments on one MiniMonitor. This is especially 
important for correct viewing of clips.

File > Preferences > Select Drag Export Format

This command selects the file format of still image files being moved to other applications 
by the Drag + Drop method. In the popup menu, click the appropriate file format. A bullet 
marks the current selection. 

There are seven still graphics file formats supported for this feature:

Select Drag Export Format Options  

Graphic Format File Extension

Bitmap bmp

Chyron bin
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File > Preferences > Import / Export Options 

This dialog box selects the options used for scaling still image files to keep or change their 
aspect ratio when they are imported and exported from Thunder.

JPEG jpg

Pinnacle g

Quantel vpb

Targa tga

TIFF tif

Select Drag Export Format Options (Continued)  

Graphic Format File Extension
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The selections are as follows:

Import Options  

Option Description

Rectangular Pixels When selected, the aspect ratio of the original image is not changed. 
It is assumed that the source image already has rectangular pixels. 

Square Pixels When selected, the aspect ratio of the original image is preserved, 
but it is assumed that the original image has square pixels as most 
computer-based paint packages do. This means the image is scaled 
slightly to compensate for the rectangular pixels used by broadcast 
video. For example, a 640x480 source will scale perfectly to 
720x486 or 720x576. 

Ignore Aspect Ratio When selected, the original image is scaled to 720x486 in NTSC and 
720x576 in PAL without regard for the original size. This means that 
the aspect ratio of the original image can be changed. 

Crop Image This check box controls the behavior of Thunder when the image 
does not have a 4x3 aspect ratio. If it is checked, the image is 
cropped to fill the screen, cropping the bottom or the right of the 
original image as necessary. If it is not checked, then black space is 
left at the bottom or right of the screen as necessary. The selections 
for Export are as follows. 

Export No Resizing The image is exported without scaling resulting in an image size of 
720x486 in NTSC and 720x576 in PAL. The exported file will have 
rectangular pixels.

Square Pixels The image is scaled resulting in an image size of 640x480 with 
square pixels.

Chyron Import/Export Control  

Option Description

Enter X/Y Offset Adjust the Offsets to line up the Chyron images. The range is from -
10 to +10. The offset depends on which Chyron model you 
are using.

Enter Frame Width in Pixels Determine the dimensions of the clips or stills on the Chyron 
machine and enter their frame width in pixels.

Enter Frame Height in 
scanlines

Determine the dimensions of the clips or stills on the Chyron 
machine and enter their frame height in scanlines.
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File > Preferences > Configure Controllers

This dialog box is used to configure the controllers used in the system. The Thunder 
software functions as an OLE Automation server. As such, other programs called controllers 
can function as OLE automation clients. These clients can operate Thunder and cause it to 
play clips and image files, record clips and image files, etc.

Each Thunder system can support many controllers at the same time. These controllers can 
be any product which might need to control Thunder. Examples include: a News Room 
interface, an Automation System, etc. Devices that control Thunder through a serial port 
actually communicate with a controller application using the serial port. The controller, in 
turn, controls Thunder.

Auto Import Settings  

Option Description

Enable Import Watcher Check this box to enable the automatic import function.

Auto Import Folder Specify the folder you want the automatic import function to 
monitor. Files placed in this folder are automatically imported to 
Thunder’s default database.

... Press this button to browse for and select the Auto Import folder.

Create Proxy After Import Turning this option off stops the automatic creation of proxies 
when items are imported into the Thunder database. This enables 
the import to complete as quickly as possible. (Proxies are 
automatically created by default.) You can create (or regenerate) a 
proxy for any item later by right-clicking on it and choosing 
“Generate New Proxy” from the menu.
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The Controller Configuration dialog box includes the following options.

To specify a Controller’s protocol, see “File > Preferences > Protocol Setup” on page 213.

File > Preferences > Select Scanner 

Use this command to select a scanner attached to your system for Scan Image commands. 
This command will bring up the configuration interface for your scanner. Refer to your 
scanner’s documentation for information on how to operate this interface. 

Controller Configuration Options  

Option Description

Controller List This is a list of all currently configured controllers. 

Title The title of the controller and is what the controller will be called 
throughout Thunder. 

Path The path to the controller executable file. The button to the right of this 
field can be used to browse the file system to locate a controller. 
Controllers supplied by Pinnacle Systems will be in the same directory as 
the Thunder executable file, which is usually C:\Thunder. For example, 
the file name of a Pinnacle ShotBox controller is FlashShotbox.exe.

Status This displays the status of the controller currently selected in the 
controller list. 

Run Executes the currently selected controller if it is not already running. To 
stop a running controller, switch to that controller’s own window in XP, 
then exit the controller program. 

Delete This deletes the currently selected controller from the list. The controller 
will not start the next time Thunder is run. However, if the controller is 
currently running, it will continue. 

Insert Adds a new controller to the list using the Title and Path currently typed. 
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File > Preferences > Configure VTR

Thunder can record from a video tape recorder. The VTR Toolbar lets you control your VTR 
from the Thunder user interface. This feature requires you to have the Ingest option.

1. Connect an RS-422 cable from an available Thunder COM port to the VTR’s 
Remote port.

2. Connect a BNC cable from the VTR output to the input connector on one of 
Thunder's channels.

3. In the Thunder interface, select File > Preferences > Configure VTR. 

The Configure VTR dialog box appears.

4. Select the Bvw75 Protocol.

5. Select the channel to which the VTR was connected in Step 2.

6. Check Enable.

7. Click the Properties button. 

The Bvw75 Protocol Setup dialog box appears.
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8. Select the Serial (COM) port to which the RS-422 cable was connected in Step 1.

9. Select Video Type (NTSC or PAL).

10. Click Test.

If the connection passes, Thunder is ready to begin recording. Click OK twice to return to 
the Thunder interface. See “Recording a Clip from a VTR” on page 61 for more information 
on recording.

If the connection fails the test, follow the suggestions presented and try again.

This feature requires you to have the Ingest option installed. See “File > Preferences > 
Options” on page 217

VTR Speeds

Click the Speeds button in the Configure VTR dialog to adjust the speed of various 
operations and controls on your VTR, under the Bvw75 protocol. A – (minus) sign is used to 
indicate reverse speeds. Clicking the Test button next to a speed shows you an example of 
that speed in action.
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File > Preferences > Configure Paint

You can install and use the Windows Paint application on your Thunder system. This menu 
command provides a dialog box used to set the default path to the Paint application. This 
allows you to move still image files back and forth between Thunder and the Paint 
application for quick touch-ups.

To set the Paint path:

1. In the Paint Program Path, type the appropriate path to access the paint application. 

2. In the Paint File Format box, select the default file type. The types include: 

3. Click OK or press Enter to save the setting and close the dialog box.

Paint File Format Box  

Setting Description

.bmp Windows Bitmap files

.g Pinnacle 10-bit YUVK files

.jpg JPEG files

.tga Targa files

.tif TIFF files
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After the Paint path is configured, right-click on a still image picon and select Paint from the 
menu. The Paint application launches and opens the still image file you selected.

The .tga (Targa) and .g (Pinnacle) file formats carry key information. If you have an 
application that can work with key or alpha information, use the .tga format.

File > Preferences > Select Background Color

Use this command to select the color displayed behind picons and sequence data.

To select a new color:

1. Click on one of the color squares.

2. (Option) Click the Define Custom Colors button to create colors that are not present on 
the color chips.

3. Click OK or press Enter.
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File > Preferences > Select Security Database

Security databases are enabled by the Security Administrator option to Thunder. One way to 
visualize the Thunder database is as a directory with picture files within it. Using the 
optional Security Administrator software, it is possible to place these pictures into 
subdirectories, called “workspaces.” A security database file, secure.dbc, is created by 
Security Administrator software to apply privileges to each of these folders. Users without 
administrator privileges might not be able to see all of the files, browse all the databases, or 
can only play certain clips and image files to air. The only workspace which cannot be 
protected in this fashion is workspace 0, which is the “scratchpad” database. Any user can 
access the clips and image files in workspace 0 (subject to the clips and image files own 
security properties on the security tab of the Item Properties dialog box). 

Security is administered by the security database secure.dbc file. This database file can 
reside directly on the Thunder system itself, on a PC on the network, or a combination of 
both. On the other hand, the Security Administrator software should not be installed on 
several systems because anyone with access to the Security Administrator software can 
modify the secure.dbc file. This violates the purpose of having security. Also, do not have 
more than one version of a secure.dbc file, because it will cause problems with hidden 
workspaces that nobody will be able to access and it can even corrupt your database. 

To use the security features, each Thunder system must know the location of the security 
database (secure.dbc) file. A copy of the file can be located on an individual Thunder, but 
there should be only one such file to prevent problems managing clips and image files. 
Multiple Thunders on a network can use the same secure.dbc file located on a server. 

Select a security database in the following dialog box.
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For more information about workspaces, see “Workspace Search” on page 137 and 
“Template and Item Properties — Sequence Tab” on page 246. 

To quit using a secure database and run in unsecured mode:

1. Select the Select Security Database.

2. Click Cancel. The following dialog box appears.

3. Click Yes to confirm the removal of the security mode. 

In unsecured mode, you are able to access only workspace 0. 

c Running in unsecured mode puts clips and images at risk of being deleted. Secure you 
database whenever possible.

File > Preferences > Configure Clip Servers

Use this dialog box to configure Thunder to recognize itself and any other clip servers on the 
network. The Thunder software controls clip servers through COM (Component Object 
Model) modules shipped in the form of .dll files. Because of this, new server control 
protocols can be supported by the addition of a new .dll without requiring a new version of 
Thunder. A single Thunder system can access and control other Thunder systems all at the 
same time.

Clip server IDs define the actual machine and must remain the same on every Thunder 
workstation. If two different Thunder systems can control a third, the third Thunder’s ID 
must be the same the on other two. With this arrangement, the two controlling Thunder 
systems each require their own individual server ID.
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The serial ports and input channels can differ for each workstation. For instance, the same 
channel from a given Thunder can be connected to input channel 2 (“Hdwr. 2”) on one 
Thunder workstation and input channel 1 (“Hdwr. 1”) on a different workstation. As long as 
the Server ID is the same, each Thunder connected to this one will play clips properly. 
Information on common setups follows.

The Clip Server dialog box includes the following fields.

Clip Server Dialog Box  

Setting Description

Server List A list of all currently configured servers, including the 
local Thunder.

Server ID An ID number that represents each configured server. Each server 
must have its own unique number. A multi-channel server, such as 
Thunder, uses the same ID for each channel.

Name The name of the Thunder workstation or other clip server as it is 
known on your network. 

Input Specifies the input channel through which an external server is 
connected to this Thunder workstation: Hdwr. 1, Hdwr. 2, etc. 
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If clip picon displays a red icon instead of green, there is a clip server problem to resolve 
before the clip will play. See “Clip Picons” on page 77.

The following topics provide more information about configuring clip servers:

• “Changing the Default Clip Server” on page 210

• “BVW-75 Protocol” on page 210

• “Network Protocol” on page 212

Protocol Lists the supported protocols used to communicate with different 
disk recorders. Select from:

• ThunderNet LOCAL

• Louth

• Bvw75

• Inflexion

• RocketClip

• DoReMi

• Tahoe

• Odetics

• Sierra

• PDR-100

Insert The Insert button is enabled after a valid Server ID and Protocol 
have been entered. Clicking on Insert adds this server to the list. 
This function pertains to adding new protocols for external 
clip servers.

Delete Removes selected server from the list.

Properties The Thunder and BetaCam protocols each have unique 
requirements. Click on the Properties button to configure the 
selected disk recorder. 

ThunderNet Channels Selects how many network channels you want to use. 

Clip Server Dialog Box (Continued)  

Setting Description
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Changing the Default Clip Server

If more than one Clip Server has been configured in the Clip Server dialog box, you can 
select the one you want to be the default server. 

1. Click File > Advanced > Default Clip Server. The following dialog box appears.

2. Type in the number of the Clip Server you want as the default. 

3. Click OK.

The number you input in the Change to: field refers to the number in the Server List of the 
Clip Server dialog box. See the previous page.

BVW-75 Protocol

The BVW Protocol Setup window is shown and described as follows.

l

Parameter Settings  

Setting Description

Server ID The ID number of the server selected in the Clip Server dialog box.

Serial Port The Thunder serial port used to connect to the VTR.
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n Control Settings only apply when Thunder is controlling a VTR, not when an external device 
is controlling Thunder.

Video Type Select NTSC or PAL as appropriate.

Control Settings  

Setting Description

Command Delay The number of frames that pass between a command and its execution.

Clip Server Capacity Total playing time on the clip server.

Calibrate Click on this button to run the tape from beginning to end to measure the 
available play time on the clip server.

Check Initialization  

Setting Description

Test Click on this button to test the connection and settings.

Test Status Reports the results of the test and any errors to correct.

Parameter Settings (Continued)  

Setting Description
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Network Protocol

The Thunder Network Protocol Setup window is shown and described as follows.

Thunder Network Protocol Setup Settings  

Setting Description

Parameter Setting

Server ID The ID number of the server selected in the Clip Server 
dialog box.

Video Type Select NTSC or PAL as appropriate.

Play Preroll Number of frames to play in preroll for each clip.

Interface Type

Network COM Select this option to link to another clip server.

Local COM Select this option when you want Thunder to act as its own clip 
server. This option grays out the Server field.

Interface Settings

Codec Selects the Thunder hardware channel connected to the clip server.
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File > Preferences > Protocol Setup

The Protocol Setup dialog box sets up communication with external devices that control 
Thunder. It displays up to eight different protocols that can be used at the same time.

Server Select the clip server from this dropdown list 

Check Initialization

Test Click on this button to test the connection and settings.

Test Status Reports the results of the test and any errors to correct.

Thunder Network Protocol Setup Settings (Continued)  

Setting Description
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Protocol Setup Settings  

Setting Description

Channel The Thunder Channel on which this protocol is running. (Note that 
there are extra non-physical channels available, so that applications 
can connect to Thunder without taking up a physical 
playout channel.)

Protocol The name of the selected protocol. select from:

• NONE — no protocol

• Louth — serial connection

• Odetics — serial connection

• BVW75 (BetaCam) — serial connection

• Odetics UDP — network connection

• ThunderNET — network connection

• MOS — network connection

• PBus2 — serial connection

Port The Thunder COM port through which this protocol is running. 
Network protocols use the Ethernet port, so the COM port field 
is dimmed.

\Other Thunder channels are also listed; select one to link the 
output of the channel selected above to that channel.

Database The pathname of the database in use. Leave this blank to use the 
default database.

User Name/Password A valid user name and password for the selected database, if you 
are using Security Administrator.

Preset/Cue Check this box to perform a clip preset when a cue command is 
received. This loads the clip and shows the first frame, provided 
there is not already a clip playing in that channel.

Stop Before Preset Check this box to stop the current playing clip before cueing. This 
forces any playing clip to be stopped first, guaranteeing that the 
cue clip command will output the first frame of video. If this box is 
left unchecked and a clip is playing, Thunder will cue the clip but 
not put it on the output video channel until a take/play command 
is received.
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File > Preferences > Database Options

This selection brings up the Database Options dialog box and three options as follows.

All Workspaces For the protocol to have access to all workspaces ordinarily 
allowed for the indicated user, check the “Present Items from all 
Workspaces” box. Otherwise, only workspace 0 will be available.

Media ID The BVW75 protocol requires the Media ID of the clip you plan 
to play.

Use Local ODBC Database Check this box to force the ODBC server number to always be the 
local database.

MOS Settings The MOS protocol requires additional settings, including the MOS 
ID of the server, the GPI in use, and the IP address of the network 
server. Use this protocol for the ENPS network. See “Connecting 
to an ENPS Network” on page 121.

PBusII Settings Selecting the PBusII protocol adds new options to the dialog box. 
Choose the PBusII device ID to assign to this channel and enter the 
pathname of the desired register file. You can edit the individual 
registers in the list window.

Sequence Playback Allows an external controller to see and play Thunder sequences.

Restart Restarts the selected protocol. You must do this to make any 
changes take effect.

Restart All Restarts all protocols.

Protocol Setup Settings (Continued)  

Setting Description
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Database Options  

Options Description

Add Items to End of Workspace When you add a new clip or image file to a workspace, Thunder 
searches through a workspace until it finds the next available 
number to assign that item. This option directs Thunder to place 
new clips and image files at the end of the workspace, making 
them easier to find. See the following illustration. 

Keep Write Lock During 
Copy/Modify Operations

Where multiple users have access to a database, they can be 
copying or modifying clips and image files at the same time, 
slowing the operation and possibly mixing one set of clips and 
image files into another. This option locks out other users from a 
database while clips and image files are being saved or modified, 
saving time and keeping each series of clips and image files in 
consecutive order. 

Keep Database Views Updated Normally, Thunder keeps all open databases current through 
automatic updates. When there are multiple users, a delay result 
while Thunder checks each database for changes. This option lets 
you disable automatic updates to speed operation. 

To manually update the database if you disable this option:

t Press Ctrl+R.

Update Clip Length While 
Recording

This option determines whether Thunder dynamically updates the 
length value for a clip while recording.

Update Media Id When 
Modifying Item Number

This option determines whether the Media Id of a clip will be 
automatically updated when its item number is modified.

Give warning while recording During recording, Thunder monitors the content on your hard 
drive and when it reaches the percentage indicated in the % field, 
gives you a visual warning. Use this advice to avoid having your 
system “max-out” unexpectedly in the middle of a 
recording session.



File Menu

217

In the following workspace example, there is no clip or image file number 206, 214 or 217. 
Thunder would normally assign those numbers to the next incoming clip or image file. With 
the Add Items to End of Workspace option checked, new clips and image files are assigned 
at the end of the workspace. In this example, the incoming clip would be numbered 221.

File > Preferences > Options

Thunder can be upgraded by enabling certain options in its software. Options can be 
purchased through your Avid representative, who can supply a 32 character password to 
activate them.
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For more information on selecting, ordering and activating options, see “Adding Options to 
Thunder” on page 164.

In addition to entering the password, you must have the dongle installed for your Thunder. 
For more information, see “Software Application Key” on page 164.

You can continue to run Thunder after entering the password, but you must restart Thunder 
for the newly enabled option(s) to become active.

n Type your password in a Notepad or Wordpad file and save as Thunder_Password in a 
separate directory on your system. You will always have it if the password is ever forgotten.

File > Preferences > Assign GPIs 

The General Purpose Interface (GPI) is a means whereby you program Thunder to navigate 
around a sequence window. When programmed, a specific GPI closure causes Thunder to 
perform a supported function. 

Thunder supports up to eight GPI inputs and five commands:

• Play next event

• Reset to top of sequence

• Cue to first frame

• Start Sequence

• Stop Sequence 

• Off

When the Assign GPI Triggers dialog box appears, assign the function you want for each 
input, GPI 1 through GPI 8. Select the GPI User, which is the device that signals Thunder to 
perform the assigned functions, in this case the Keyboard.

n GPIs must be set for each Sequence individually.
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To program the GPI:

t Select File > Preferences > Assign GPIs.

File > Preferences > Enable GPI Triggers

To enable the GPI triggers, select File> Preferences > Enable GPI Triggers. A check mark 
means the GPI in enabled.

.

File > Preferences > Drop Frame Timecode

This option determines whether Thunder is using Drop Frame Timecode. A check mark 
means Drop Frame Timecode is enabled.
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With Drop Frame Timecode enabled, the dividers in the time interval fields on Clip tab of 
the Item Properties dialog box change to semicolons. When you are using non-drop frame 
timecode, the dividers appear as colons.

File > Preferences > Sequencer Uses Database Input/Output Points

This option sets Thunder to use the in/out points for clips as listed in the database, rather 
than those set for the clips when they were added to the sequence (the default behavior). A 
check mark means that database input/output points are being used.

Doing this in connection with the “Overwrite Existing Item in Database” Import/Export 
option means that “placeholder” items can appear in the database, to be replaced with actual 
content when it is ready, and the in/out points listed in the database will be used for the item. 
A sequence can be defined and never changed, but its items can change as necessary.

File > Preferences > Generate Proxy After Record

This option determines whether a proxy is automatically generated after a clip is recorded.
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File > Advanced Menu

The File Advanced menu is shown and described as follows.

The following topics provide more information about the submenus in the File > Advanced 
menu:

• “File > Advanced > Rebuild Database” on page 222

• “File > Advanced > Create New Database” on page 224

• “File > Advanced > Restore Default Settings” on page 227

• “File > Advanced > Default Clip Server” on page 228

Advanced Menu Commands  

Command Description

Rebuild Database Repairs a damaged database, removes unneeded files, and reclaims disk 
space.

Create New Database Names, specifies the type, sets the file paths of a new database. 

Default Clip Server Selects which clip server is the default when more than one clip server 
has been configured.

Separate SD/HD Settings For Thunder Hybrid systems selecting this option enables you to save 
one set of user preferences for standard-definition (SD) settings and a 
different set for high-definition (HD) settings.

Restore Factory Defaults Restores the default Preference settings.
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File > Advanced > Rebuild Database

The Rebuild Database dialog box repairs a database that has become damaged, removes 
unneeded files and reclaims disk space. To rebuild a network database, it must not be in use 
by somebody else. Right-click on the Network Tree to remove all locks before rebuilding.

n This function can repair stills, but it cannot repair clips.

The check boxes are used to set parameters that affect how the build is performed. As a 
general rule, each check box that is selected slows down the rebuild, but the rebuild will be 
more thorough. The choices are:

Rebuild Database Options  

Option Description

Picons

Create if Missing Creates missing picons.

Check Integrity Checks each picon file for damage and matches the clip or 
image file. 

Delete Orphans Deletes picons for clips and image files that have been deleted. 

FlashFile Images This function does not apply to Thunder.

Lightning Images

Check Integrity Checks each image for damage and deletes damaged files.

Database
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A Thunder-only database always includes all image components. Therefore, setting this flag 
will turn on all flags, even if there is no meaningful data in them. Create if Missing and 
Delete will be grayed out for a database that is only a Thunder database.

n If the database you want to work on is in use by other workstations, this dialog box will 
appear. All connected workstations must disconnect before you can apply rebuilding 
functions.

Recreate Recreates the database itself. If this box is unchecked, only the 
image files are examined. 

Reindex Quickly repairs a damaged database without looking at the 
index files. 

Reset Video Flags Resets the field 1, field 2, and key flags by looking at the 
image files. 

Rebuild Database Options (Continued)  

Option Description
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File > Advanced > Create New Database

This command is used to set the default file paths for creating a new database on a system.

Create New Database Window — Database Type  

Setting Description

Database Type

• Thunder Stores images in Thunder format. Lightning Versions 4.1 and later 
images can also read these images.

• Thunder MXF Stores images in Thunder MXF format. 
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Video Standard

• NTSC

• PAL

• 720p 59.94

• 720p 60

• 1080i 50

• 1080i 59.94

• 1080i 60

Specifies the database images format. Standard definition (SD) is 
either NTSC or PAL. 

High definition (HD) image formats include: 

• 720 Progressive 59.94, and 60 

• 1080 Interlaced 50, 59.94, and 60 

Codec Specifies the codec used for the selected database and video 
standard. For Corsica systems, make sure you select MPEG-2 
IFRAME. When an HD video standard is selected, this is the only 
choice.

Location

Database Name The name of the new database. It can be any name but normally 
should be easily recognizable to all users.

Database Path This must contain the full local path name of the directory where the 
new database will reside. This path must include a drive letter for the 
local drive.

Computer Name The network name of the machine where the database is to reside, 
and can be determined by looking at the network properties in the 
Windows XP Control Panel. Thunder fills in this name 
automatically.

Drive Share Name The share name for the drive where the database resides. This can be 
determined by looking at the properties of the drive in Windows XP 
(right-click on the drive’s icon).

Options

Unicode All Thunder databases are Unicode, you cannot deselect it. This 
allows storage of non-ASCII characters such as Katakana and Kanji 
from Asian languages or Middle Eastern languages in the database.

ODBC Stores images in an ODBC database for access over a network. This 
database requires a Microsoft SQL server and ODBC driver installed 
on the Thunder workstation.

ODBC Database

Create New Database Window — Database Type (Continued)  

Setting Description
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Number The number assigned to identify each ODBC database. This field is 
grayed out when the ODBC option is not checked.

Removable Media Check this box if the database will reside on media which can be 
removed from the drive and placed in another system. A Jaz drive is 
an example of removable media.

Default Server Default clip server used by this station.

Advanced Options — Proxy 
Location

Computer Name The network name of the machine where the proxy files will reside. 
You can determine the location by looking at the network properties 
in the Windows XP Control Panel. Proxies are low-resolution MPEG 
(.mpg) files playable from your workstation.

Path This must contain the full local path name of the directory where the 
proxy files will reside. This path must include a drive letter for the 
local drive.

Drive Share Name The share name for the drive where the proxy files reside. You can 
determine the drive by looking at its properties in Windows XP 
(right-click on the drive’s icon).

Advanced Options — Path

Image This must contain the full local path name of the directory where still 
image files will reside. It is automatically filled in when the 
Database path is entered, but it can be changed if desired.

YUV Picon This must contain the full local path name of the directory where the 
YUV picon images will reside. It is automatically filled in when the 
Database path is entered, but it can be changed if desired.

RGB Picon This must contain the full local path name of the directory where the 
RGB picon images will reside. It is automatically filled in when the 
Database path is entered, but it can be changed if desired. Note that 
RGB picons are not used or created by Thunder, but this directory 
must be supplied for use by FlashFile systems.

Clip This must contain the full local path name of the directory where the 
clips will reside. It is automatically filled in when the Database path 
is entered, but it can be changed if desired.

Drive Share Name The share name for the drive where the Image File, YUV, and RGB 
picons reside.

Create New Database Window — Database Type (Continued)  

Setting Description
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File > Advanced > Restore Default Settings

If you have changed several Preference settings and need to revert back to the original 
settings Thunder shipped with, use this command. All the settings in the Preference menus 
are reset to how they were set when the Thunder software was installed. You are asked to 
confirm this selection before the settings are changed. Your old settings cannot be recovered.

File > Advanced > Separate SD/HD Settings

For Thunder Hybrid systems selecting this option enables you to save one set of user 
preferences for standard-definition (SD) settings and a different set for high-definition (HD) 
settings. This feature allows you to have different default databases, watch folders, and 
protocols when switching between SD and HD. This feature can be turned on or off.

To allow separate settings for SD and HD:

1. Select File > Advanced > Separate SD/HD Settings. 

A check mark next to the Separate SD/HD settings menu item indicates the the feature is 
turned on, enabling you to have different sets of user preferences for HD and 
SD settings.

2. To turn off this feature, select File > Advanced > Separate SD/HD settings again. 

The check mark next to the Separate SD/HD settings menu item is no longer there, and 
the feature is turned off.
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File > Advanced > Default Clip Server

If more than one Clip Server has been configured in the Clip Server dialog box, you can 
select the one you want to be the default server.

To select a default clip server:

1. Click File > Advanced > Default Clip Server. The following dialog box appears.

2. Type in the number of the Clip Server you want as the default.

3. Click OK.

The number you input in the Change to: field refers to the number in the Server List of the 
Clip Server dialog box. “File > Preferences > Configure Clip Servers” on page 207.

Edit Menu

The Edit Menu offers the following commands.
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The following topics provide more information about the submenus in the File > Edit menu:

• “Edit > Cut” on page 230

• “Edit > Copy” on page 230

• “Edit > Paste” on page 230

• “Edit > Paste Master Clip” on page 231

• “Edit > Delete” on page 231

• “Edit > Insert” on page 231

• “Edit > Select All” on page 232

• “Edit > Renumber” on page 232

• “Edit > Edit Layouts” on page 234

• “Edit > Edit Template” on page 235

Edit Menu Commands  

Command Description

Cut Deletes selected clips or image files from a sequence window and moves 
them to the clipboard

Copy Copies selected clips or image files from a database or sequence window 
to the clipboard

Paste Pastes clips or image files from the clipboard into the currently active 
database or sequence window

Paste Master Clip Pastes master clips from the clipboard into the currently active database 
or sequence window

Delete Deletes selected clips or image files from a database or sequence window

Insert Inserts a new event into the currently active sequence window

Select All Selects all of the items in the current window

Renumber Renumbers clips or image files in a database window

Edit Layouts Edits layout properties

Edit Template Edits template information
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Edit > Cut 

Keyboard shortcut: Ctrl+X 

The Cut command can only be used in a sequence window and is grayed out if no sequence 
events are selected. Similar to the Copy command, the Cut command is used to remove one 
or more selected events from a sequence and move them to the clipboard. Cutting to the 
clipboard replaces the contents previously stored there. After events have been cut, they can 
then be pasted into another sequence window.

Edit > Copy

Keyboard shortcut: Ctrl+C 

The Copy command can be used in both database and sequence windows. The Copy 
command copies one or more clips and image files or sequence events to the clipboard.

Select the clips and image files or events you want to copy, then click the Copy command. 
Once copied to the clipboard, clips and image files can be pasted into another window. clips 
and image files copied to the clipboard remain there until the next Cut or Copy. A block of 
clips and image files can also be copied to a database or sequence window using drag and 
drop.

n If the original clips and image files copied to the clipboard are replaced before a paste 
action is performed, the original clips and image files in the clipboard are lost.

Edit > Paste

Keyboard shortcut: Ctrl+V 

Use the Paste command to a copy the clipboard contents into a database or sequence 
window. This command is grayed out if the clipboard is empty. In a sequence window, the 
clipboard contents are pasted after the currently selected sequence event. In a database 
window, the clipboard clips are pasted to the closest available number. For example, clips 
13, 14 and 15 are pasted into a database that already contains clips and image files with 
those numbers. The incoming clips are renumbered to 20, 21 and 22.

n If the original clips and image files copied to the clipboard are replaced before a paste 
action is performed, the original clips and image files in the clipboard are lost.
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Edit > Paste Master Clip

Keyboard shortcut: Ctrl+Shift+V 

Use this command when you want to copy a large clip file from one workspace to another. 
Unlike the Paste function, which creates only a shortcut of the clip file, Paste Master Clip 
makes a complete copy.

n This command makes a complete copy of clips and you can easily fill up your disk with 
several copies of the same clip file. Use Paste Master Clip only when you must make a full 
copy of a clip file.

Edit > Delete 

Keyboard shortcut: Delete 

This command is used to delete the currently selected clip(s) or image file(s) from the active 
database or events from an active sequence window. This command is unavailable if there 
are no clips and image files or sequence events selected.

Clips and image files or sequence events can be deleted one at a time or as a block. When 
you attempt to delete any item from a database or more than one event in a sequence 
window, an “Are you sure?” dialog box verifies your intention.

Once clips and image files have been deleted from a database window, they are permanently 
lost and cannot be recovered. However, deleting sequence events does not remove the clips 
and image files from the database.

Edit > Insert

Keyboard shortcut: Insert

The Insert command inserts a new event into the currently active sequence window. For 
more information the process of editing sequences, see “Editing Sequences” on page 107. 
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Edit > Select All

Keyboard shortcut: Ctrl+A 

This command selects all of the items in the current window. 

Edit > Renumber

Keyboard shortcut: Alt+E+N 

Use this command to renumber clips and image files. 

To renumber a group of clips: 

1. Select the clips or image files you want to renumber.

2. Select Edit > Renumber or Press Alt+E+N.

The Renumber Items dialog box opens.

3. Type in the Starting Number in the text box.

4. Select Renumber.

5. Click OK.

Renumber Items Settings  

Settings Descriptions

Starting Number The clips or image files selected will be given new file numbers 
starting from the number specified. If clips or image files already 
exist within the destination range specified, those numbers will be 
skipped. 

Keep Selection Order Check to number the clips or image files in the order they 
were selected. 
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n To move clips and image files from one database or workspace to another, specify the 
database and/or workspace number before the file number.

To renumber an individual clip or image file:

1. Right-click on a clip or image file.

2. Select Renumber.

3. Type the new number in the Starting Number text box.

4. Click OK.

When the Add to End of Workspace option is enabled, and you specify a file number that is 
not in use, one item goes to that number, but the rest of the clips and image files goes to the 
end of the workspace. If your clips and image files do not renumber to the area you expect, 
check your Database Options.

For more information on renumbering, see “Clip and Image File Numbers” on page 233.

Clip and Image File Numbers

Each clip and image file has an individual number, and where applicable, a workspace 
number and a database number. In this example, file number 41 from Workspace 5 in 
Database 2, is identified by this number: 2.5.41. If you are working in only one database, the 
clips and image files reflect just the workspace and individual numbers, such as: 5.41. When 
only Workspace 0 is open, the clips and image files have only their individual file number, in 
this example, 41.
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Edit > Edit Layouts

This command lets you edit the clip layouts defined on your system. Select a layout from the 
list on the left, and click Edit to modify it. Clicking Copy creates a new layout with the same 
properties as the selected one. Rename lets you change the name of the selected layout, and 
Delete removes it from the system.

To create a new layout:

1. Enter a name for it in the New box.

2. Click Create. 

You can then edit the layout.
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Edit > Edit Template

Use this command to edit the current template. The Template dialog box appears when this 
command is selected. 

To make changes in the template:

1. Click in the desired text field.

2. Make your changes.

3. Click OK or press Enter to accept the changes and complete the dialog.

To exit from the dialog box without making changes:

t Click Cancel.

The template can have all data fields filled in or you can use the template to partially fill in 
the database for a series of clips and image files that have common information. For 
example, if you are saving a series of engineering test pattern slides, you might want to 
create a template which has “Test Pattern” in the Category field, and “Engineering” in the 
User field. As you save the clips and image files, you will only need to enter the appropriate 
title information.

n Regularly using the Template enables you to find clips and image files much faster. 

The following topics provide more information about the submenus in the Edit > Edit 
Template menu:

• “Template and Item Properties — General Tab” on page 236

• “Template and Item Properties — Security Tab” on page 238

• “Template and Item Properties — Video Tab” on page 240

• “Template and Item Properties — Clip Tab” on page 242

• “Template and Item Properties — Record Tab” on page 243

• “Template and Item Properties — Sequence Tab” on page 246

• “Item and Template Properties — Sequence Details Tab” on page 248
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Template and Item Properties — General Tab

The General tab defines the text data that will be associated with the clip (Thunder 
automatically fills in the date field).

General Tab Settings  

Settings Descriptions

Number Sets the workspace and starting number used for clips and image 
files as they are saved. In the above example, the next clip saved will 
be in Workspace 0 (the default) and have the file number of 0. If 
there is already an clip numbered 0, the system will assign the next 
available number.

If the add clips and image files to end of workspace option is active, 
incoming clips and image files will be added to the end of the 
database and numbered in order. If no workspace is specified, then 
the current workspace will be used whenever saving clips and image 
files (subject to Security Administrator constraints, of course).

Date The system automatically assigns the current date when a clip or 
image file is saved.
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Information contained in the clips’ or image files’ database is an extremely valuable tool. 
Any or all of the fields can be searched to create a new window containing clips and image 
files matching the search criteria.

Good databases result from careful and consistent use of fields for specific information, 
common abbreviations, and so on. All users should agree on these conventions before 
creating new clips and image files. To perform a database search, use the Workspace/Search 
Command in the View menu. 

Title These four fields of user-entered information complete the template.

Category, User, Memo You can enter any information in these fields.

Media Id The name of the clip as it appears to external controllers.

General Tab Settings (Continued)  

Settings Descriptions
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Template and Item Properties — Security Tab

The Security tab allows you to set Read and Write permissions for the clip or mark it as 
read-only. The system fills in the Owner field with the user name. This tab sets the owner of 
the clip or still (usually the person who capture the clip), and allocating Read and Write 
permissions.

If you have not purchased the Security Administrator software, The name “Nobody” appears 
dimmed in a Owner box. When Nobody is the owner, all users are able to open, save and 
play the clip. When a secure.dbc file (created by the Security Administrator software) is on 
the system, only the owner of the clip or the SuperUser can make changes to permissions 
and ownership.

To change the owner:

t Type the new owner’s name in the box. 

If the name selected is not available, you will be presented with a popup dialog asking 
you to re-enter the data.
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Permissions are granted to groups of users as shown in the following table:

To change the Read and/or Write permissions for a clip or still:

1. Click the desired settings.

2. Click Apply. 

3. Click OK to remove the dialog box.

To change the owner:

t Type the new owner’s name in the Owner box. 

If the name selected is not available, Thunder displays a popup dialog box asking you to 
re-enter the data.

User Group Permissions  

Setting Description

Nobody The clip or still is unavailable to everyone except the Super User. 
This is normally used for clips and stills that are archived for 
long-term storage or because of content sensitivity. Only the 
SuperUser can change permissions for these clips and stills. 

Owner Only the current owner of the clip or still can play the clip or still, 
or make database and video changes. 

Workspace The clip or still is restricted to a specific Workspace. Only users 
with access to that workspace can play the clip or still, or make 
changes. 

World The clip or still is unrestricted, regardless of the Workspace in 
which it resides. Anyone can play the clip or still, or make 
changes. 

Read Only When this box is checked, everybody can read the clip or still, but 
it cannot be modified or deleted.
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Template and Item Properties — Video Tab

The Video tab selects which video fields are stored and whether to store a Key for playback. 

n Thunder always saves a full-frame.

This tab allows you to select the video fields and key for playback. 

Video Tab Settings  

Setting Description

Key Store the Key signal if the clip has one.

Shaped In the broadcast environment, video and key signals are normally 
transported on two separate signals. The terms Shaped and 
Unshaped refer to how a separate key signal is used in conjunction 
with an associated video (or fill) signal to represent a non-opaque 
source. 

Shaped refers to a video and key pair that has the key 
“pre-applied” (or pre-multiplied) to the video signal. This is most 
apparent on objects with a soft, semi-transparent border. 

Unshaped refers to a video and key pair that does not have the key 
“pre-applied” to the video. 

16x9 Record your 16x9 images in that format.
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To change the record components of an existing image file:

1. Click the appropriate fields. 

2. Click Apply. 

This feature is useful to turn off a key signal that might be incorrect or no longer needed. 

n On a FlashFile database, unchecking a field of video or a key signal will eliminate them. 
They cannot be recovered.

If the image file has a Key but the Key box is unchecked, the Key is turned off.

To record clips with Keys:

1. Enable Key recording on the Input Channel you are using. See “File > Preferences > 
Channel Configuration” on page 193.

2. Enable Key on the Video tab of the Item Properties / Template dialog box.

3. Select the Key Type on the Record Setup tab of the Item Properties / Template dialog 
box. See “Template and Item Properties — Record Tab” on page 243.
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Template and Item Properties — Clip Tab

The Clip tab provides the name, in and out points, total duration, and server location of 
video clips.

Clip Tab Settings  

Setting Descriptions

Clip Name File name of the clip itself. To generate a new clip, leave this field blank.

Master Clip If this is a sub-clip, the name of the master clip from which it was taken.

In In-point of this clip. Use the shortcut Ctrl+I to set the in-point.

Out Out-point of this clip. Use the shortcut Ctrl+O to set the out-point.

Duration Duration of this clip

Loop In Point in the clip where looping starts

Key Number of frames to slip the key for this clip. The allowed range is –3 
to 3.

Master Clip Master clip, if any
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Template and Item Properties — Record Tab

The Record tab shows data rate in Mbits/s and has settings for video compression, audio 
input source and duration of the recorded clips. In Item Properties, this tab only gives 
information on the selected clip. You must make these settings in the Template dialog box 
before recording clips. Select Edit > Edit Template or press F5, then click on the Record tab.

Base TC Base timecode used by the clip for time calculations

Looping How many times to loop the clip

Server Thunder workstation on which this clip resides

Clip Tab Settings (Continued)  

Setting Descriptions
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Record Tab Settings  

Setting Description

Video Bitrate The data rate, in Mbits/s, at which clips are recorded. If the Key 
checkbox is checked on the Video tab, the maximum rate drops to 
25 Mbits/s because the balance of the data rate is reserved for 
the Key.

n The maximum record/compression rate is 50 Mb/s. The rate 
shown in the field applies to the clip. The difference between 
the field amount and the maximum applies to the clip’s key, 
if the key is being recorded. Use the 15 Mb data rate as a 
starting point.

Video Type The compression method by which clips are stored. The 
selections are:

• MPEG2-4:2:2

• MPEG2-4:2:0

• DV25

VBR  Check this box to enable Variable Bit Rate recording. VBR can 
result in a better compression rate and smaller file sizes with the 
same level of image quality. Left unchecked, Thunder uses 
Constant Bit Rate (CBR) recording. We recommend using VBR at 
all times.

GOP Structure When MPEG2 compression is selected in the Video Type field, 
you can select the group of pictures (GOP) structure. The 
selections are:

• I-frame, GOP=1

• IP, GOP=4

• IBP, GOP=12

• IBP, GOP=14
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Audio The source for the audio portion of the clip. The options are None 
or Embedded (with the video stream). Based on your Thunder 
model, you can also select between:

• 2 Channel

• 4 Channel

• 6 Channel

• 8 Channel

• 16 Bit

• 20 Bit

• 24 Bit

• 32 Bit

n Based on your Thunder model, Audio channels that are not 
supported are not listed, and certain Bit Rate choices that 
are not supported are greyed out.

Duration The duration of the clip recording you want to make. If you set it to 
zero, recording will continue until you stop it manually.

Key Type Key checkbox is checked on the Video tab, this selection 
determines whether Key compression or filtering applies. The 
selections are:

• Blank Space means the clip will record without a Key. A 
Blank Space appears on the Template dialog box only.

• Lossless applies compression that does not degrade Key 
quality.

• Filtered removes noise before compression. This reduces 
bandwidth but might also reduce image quality. Use this option 
only when you get a bad frame count in the MiniMonitor as 
you record clips with Keys.

n Under the Key Type field is an indicator of whether this clip 
is loopable. A clip that is listed as Not Loopable cannot be 
made to loop later.

Lossless Applies compression that does not degrade Key quality.

Record Tab Settings (Continued)  

Setting Description
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To record clips with keys:

1. Enable Key recording on the Input Channel you are using.

2. Enable Key recording on the Video tab of the Item Properties / Template dialog box.

3. Select the Key Type on the Record Setup tab of the Item Properties / Template 
dialog box.

Thunder also uses “proxies” or low-resolution images of each clip that you can play on your 
workstation. Thunder cannot generate a real-time proxy when recording clips with keys, but 
it can automatically create proxies after the clip has been recorded by checking the 
“Automatically Generate Proxy After Record” checkbox. You can also manually generate 
proxies for any clip by right-clicking on the clip and selecting “Generate New Proxy”.

Template and Item Properties — Sequence Tab

When part of a sequence, clips are referred to as events. Right-click on the event you want to 
edit and select Properties from the popup menu, which will display the Item Properties 
dialog box with the Sequence Tab enabled. Changing the Sequence Template properties 
specifies the characteristics of any new clip added to that sequence.

Filtered Removes noise before compression. This reduces bandwidth but 
might also reduce image quality. Use this option only when you get 
a bad frame count in the MiniMonitor as you record clips 
with keys.

Record Tab Settings (Continued)  

Setting Description
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You can also edit several events simultaneously. 

To select all of the events you want to edit:

1. Press Ctrl+click on each event to select multiple events individually.

Click-and-drag or Shift+click to select a block of events.

2. Press Ctrl+A to select all the events in the sequence.

3. Right-click to display the Item Properties dialog box for all events in the sequence.

In this case, the event number and item name do not show, since more than one event has 
been selected. Any changes made here affects all of the selected events simultaneously. This 
is convenient for block changes, such as changing the transition of several items to 
Dissolve simultaneously. 

Sequence Tab Settings  

Setting Description

Event Number The number of the event in the sequence.

Item The clip or image file number, with database and workspace number 
where they apply.

Template The name of this event (clip or image file).

Event Control Elects manual or automated control for the event. The selections are:

Manual — Event plays when you indicate (by pressing the spacebar)

Absolute — Event plays at a specific time

Follow — Event plays automatically after the preceding event

GPI — Event plays when signalled by an external device, such as a 
ShotBox

Event Channel Channel, Program, Preview or Compose; where the event will play.

Event Layout Layout number used for the event.

In/Out Beginning and end points of the clip shown in the event.

Dur. (Duration) Length of the clip.

Transition Transition selected to accompany this event in the sequence.

Duration Duration of the selected transition.
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Item and Template Properties — Sequence Details Tab

This tab includes additional properties for the selected events in a sequence. Changing the 
Sequence Details Template properties specifies the characteristics of any new clip added to 
that sequence.

Sequence Details Tab Settings  

Setting Description

Event Number The number of the event in the sequence.

GPI Outputs The GPI action you want this event to output.

Bug Inserter The item number for the bug you want to include, and its percentage 
of opacity.



View Menu

249

View Menu

With the exception of the last three items, the View menu controls the appearance of items in 
the Thunder software (size, order, etc.)

A check mark indicates the status of items that can be toggled on and off. A dot indicates the 
current display style where there are multiple choices.

View Menu Commands  

Command Description

Show Main Toolbar Toggles the display of the Main toolbar.

Show Air Toolbar Toggles the display of the Air toolbar.

Show MiniMonitors Toggles the display of the MiniMonitors.

Show Tree Toggles the display of the Network tree.

Show VTR Toolbar Toggles the display of the VTR toolbar.

Show Status Bar Toggles the display of the Status bar at bottom of screen.

Text Below Displays the clip or image file number below the picon.

Text Right Displays the clip or image file number to the right of the picon.

Details Displays detailed database information.



 Appendix B Thunder Toolbars and Menus

250

The following topics provide more information about the submenus in the View menu:

• “View > Show Main Toolbar” on page 251

• “View > Show Air Toolbar” on page 251

• “View > Show MiniMonitors” on page 251

• “View > Show Tree” on page 252

• “View > Show VTR Toolbar” on page 252

• “View > Show Status Bar” on page 253

• “View > Text Mode” on page 255

• “View > Select Details” on page 257

• “View > Large, Small, or Tiny Images” on page 258

• “View > Sort Images” on page 258

• “View > Key Image” on page 260

• “View > Workspace/Search” on page 261

• “View > Refresh” on page 262

• “View > Independent Context” on page 262

Select Details Selects which items will be displayed in the database header.

Tiny Images Displays Tiny picons.

Small Images Displays Small picons.

Large Images Displays Large picons.

Sort Images Changes the picon sort order.

Key Images Toggles display of Key picons on or off. 

Workspace/Search Allows selection of workspaces and search criteria for clips and 
image files.

AP Databank Search Searches a connected Associate Press databank.

Refresh Refreshes the current window.

Independent Context Toggles on or off the Independent Context for the current window.

View Menu Commands (Continued)  

Command Description
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View > Show Main Toolbar

Keyboard shortcut: Ctrl+L 

Use this command to display and hide the Main Toolbar, which includes buttons for some of 
the most common commands in the application such as File Open. A check mark appears 
next to the associated menu item when the Main Toolbar button is clicked.

View > Show Air Toolbar 

Keyboard shortcut: Ctrl+I 

Use this command to show and hide the Air Toolbar, which includes point-and-click mouse 
buttons for quick access to commands for on-air operations. A check mark appears next to 
the menu item when the Air Toolbar is displayed.

View > Show MiniMonitors 

Keyboard shortcut: Ctrl+M 

Use this command to show or hide the MiniMonitor window. A check mark appears next to 
the menu item when the MiniMonitor is displayed.

Control section MiniMonitor section
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View > Show Tree

Keyboard shortcut: Ctrl+T 

Use this command to show and hide the Network Tree window, which is used to select and 
open database and sequence windows.

A check mark appears next to the menu item when the Network Tree is displayed.

View > Show VTR Toolbar

The VTR Toolbar lets you control your VTR from the Thunder user interface.

The VTR Toolbar consists of playback controls, combined with a slider to control deck 
shuttle speeds and timecode display. With your mouse, click and drag the slider left or right 
to move the tape. When you release the mouse button, the slider returns to center and the 
tape stops moving.
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You can also move your VTR tape by specifying a position on the tape. Double-click on the 
timecode window to bring up the Cue to Timecode dialog box. Type in the position numbers 
and click the OK key. The VTR rolls to the designated position.

This function is an option on Thunder. Before attempting to use it, be sure the Ingest option 
is enabled and properly configured. When the VTR Toolbar is black, as shown above, it is 
online and ready to work. If the VTR Toolbar is grayed out, you must configure the 
connection between your VTR and Thunder. See “File > Preferences > Configure VTR” on 
page 202 and “Recording a Clip from a VTR” on page 61.

View > Show Status Bar 

The Status Bar is shown at the bottom of the application window and can be toggled on and 
off by the Status Bar Command in the View Menu.

The left area shows the action triggered by buttons and menu items as you move around the 
menu screen with arrow keys or the mouse cursor. The areas at the right of the Status Bar 
example indicate the following:

Status Bar Information  

Indicator Description 

915 MB Free The amount of free space on the hard drive that holds this database.

4/35/35 Indicates that 4 items are selected out of 35 displayed in the 
currently active window, and that there are a total of 35 items in the 
database. 

95 Shows the number 95 is currently in the keypad. 

07/05/01 Shows the current date. 

16:19 Shows the current time.
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For more information, see “Background Tasks” on page 254.

Background Tasks

Thunder does some tasks in the background in order to make the best use of your time. 
When you copy or rename a large quantity of clips, the operation might take several minutes 
or more of processor time, which would normally cause you to wait while Thunder did these 
important, but comparatively low-priority tasks. The Background Tasks feature allows you 
to program Thunder to perform these tasks, then continue your work. Thunder does the tasks 
in the background, without your being aware of it.

You are not required to do anything nor wait for processing to take place. If you want to view 
the remaining tasks in Thunder’s background task queue, click on the progress bar to see the 
Background Task Status dialog box.

The Background Task Status dialog box tells you which task is currently working and the 
remaining or pending tasks to complete.

• To cancel the currently-working task, click the Cancel Current button.

• To cancel a queued task, select it in the list and click the Cancel Task button.

• To give top priority to a specific task, select it and click on the Rush Task button and 
Thunder will do it next.
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View > Text Mode 

Keyboard shortcut: Ctrl+F2 

There are three text display mode settings: Text Below, Text Right, and Detail. The keyboard 
shortcut, Ctrl+F2 switches between the three setting each time the keys are pressed.

The following topics provide more information about the submenus in the View > Text 
Mode menu:

• “Text Below” on page 255

• “Text Right” on page 256

• “Details” on page 256

Text Below

Keyboard shortcut: Ctrl+F2 

The default display for database windows as they are opened is large picons with the item 
numbers below. In a sequence window, the default display is tiny picons with the detailed 
text to the side. A dot to the left of this menu entry indicates that it is the currently 
selected display.

This option is window-specific; each open window can have a different type of display. Use 
the Text Right or the Details command to select a different window display.
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Text Right 

Keyboard shortcut: Ctrl+F2 

When a database window is active and this command is selected, item numbers are shown to 
the right of the picons. In a sequence window, the event number is shown to the right of each 
picon. A dot to the left of this menu entry indicates that it is the currently selected display.

By default, select this command to display small picons. Note that this command is window-
specific, that is, each open window can have a different type of display. Use Text Below or 
Details to select a different window display. 

Details 

Keyboard shortcut: Ctrl+F2 

When a database window is active and this command is selected, detailed database 
information is shown to the right of the picons. Select the Details mode when you want to 
sort the picons. For more information, see “View > Sort Images” on page 258.
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In a sequence window, detailed sequence event information is displayed to the right of the 
sequence picons. A dot to the left of this menu entry indicates that it is the currently selected 
display.

The width of each text column can be changed by positioning the mouse cursor on the bar 
separating an information field, then pressing the left mouse button and dragging the bar to 
the left or right. Note that this command is window-specific—each open window can have a 
different type of display. Use Text Below or Text Right buttons to select a different window 
display. see “Text Below” on page 255 and “Text Right” on page 256.

View > Select Details

When a database window is active and you select this command, you choose which details 
will show in the header and their corresponding information is shown to the right of the 
picons. Use this command to show only needed information so you can reduce the window 
sizes and save space on your desktop.



 Appendix B Thunder Toolbars and Menus

258

View > Large, Small, or Tiny Images 

Keyboard shortcut: Shift+F2 

Picons can be displayed in three sizes: Large, Small and Tiny. To change sizes, click the 
desired size in the View Menu. A dot next to the menu entry indicates it is the currently 
selected size. 

The keyboard shortcut, Shift+F2 switches between the three settings each time the keys are 
pressed.

Large picons are appropriate when using a small VGA monitor or on the composite or Y/C 
output. Tiny picons let you see the most database information and are appropriate when 
using a large VGA monitor. Note that the green film icon, identifying the item as a clip, does 
not appear on the Tiny selection.

View > Sort Images 

By default, the database window is sorted by picon numbers in ascending order. To change 
the sort order, select Sort Images from the View Menu or switch to the Detail mode and then 
click on any column header. In the example below, the clips are sorted by Event Number.
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The database window re-sorts by the column selected. The sort order will be retained even if 
the window is switched to the Text Right or Text Below modes.

Sorts are the same for Clips and Image files. The following describes the different types of 
sorts. 

n When a Title, Category, User or Memo sort is active, items with no information in these 
fields are moved to the top of the window. Clips and Image Files that contain a numerical 
entry in the first position of these fields are sorted next, following by all remaining clips and 
image files sorted alphabetically.

Sort Category  

Option Description

Item Number Clips are sorted in ascending numerical order.

Date Clips are sorted by the date they were saved in descending order, that is, 
the newest clips are first and the oldest ones last.

Title Clips are sorted alphabetically by the title. 

Category Clips are sorted alphabetically by category information.

User Clips are sorted alphabetically by user information.

Memo Clips are sorted alphabetically by memo information.

Media Id Clips are sorted alphabetically by a unique ID for the clip.

Master Clip Clips are sorted numerically by their master clip numbers.

Duration Clips are sorted numerically by their length.
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View > Key Image

Keyboard shortcut: F2 

When a clip or still image file has a key, it causes the picon in the active window to display 
the key signals associated with its file.

When Key Image is active, a check appears to the left of the Key Image item in the 
View Menu.

In the group of four picons on the right, image number 20 has a Key but image 23 does not. 
The top row shows how they appear normally. The bottom row shows how they appear with 
Key Image active.

To activate Key Image:

t Click View > Key Image or press F2. 

When Key Display is active, picons in the current window show the key signal. If an image 
file does not have a key, the words “No Key” are displayed. This command is not available 
when displaying Tiny images. To return to the normal picon display, click View > Key 
Image or press F2 again.

The linear key signal controls the transparency of the associated video image. The key signal 
looks like a black and white video: the black areas are transparent, the white is opaque, and 
the gray areas are varying levels of transparency.

A right-click on a MiniMonitor toggles the channel in and out of Full Key Mode. When a 
channel is in Full Key Mode, its MiniMonitor will be outlined with a blue frame instead of a 
black one. The key associated with the image file on that channel will be replaced by a full 
frame key.
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View > Workspace/Search 

Keyboard shortcut: F4 

Select the Workspace/Search Command in the View Menu to display the Workspace/Search 
dialog box. Workspaces only show up if the secure.dbc file is there. This file is created by 
your system administrator with Security Administrator software, an option on Thunder.

This dialog box is used to specify which clips and image files will be displayed in a 
database window. 

The following topics provide more information about the submenus in the View > 
Workspace/Search menu:

• “Database Section” on page 261

• “Workspace Section” on page 262

• “Search Section” on page 262

Database Section

The Database section only appears when the ODBC option to Thunder has been installed.

It shows all the available databases, on other ODBC-equipped Thunders or on a file server. 
Select one or more databases to display in the active database window. Ctrl+click selects 
multiple databases individually. Shift+click selects all the databases between the two on 
which you click.

Database
section

Workspace
section

Search
section
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Workspace Section

The Workspace section appears only when the secure.dbc file, created by the Security 
Administrator option, is installed.

Use it to select one or more workspaces for display. Ctrl+click selects multiple workspaces 
individually. Shift+click selects all the workspaces between the two on which you click. 
When you select multiple workspaces, items in the database window display both workspace 
and item number. For example, item 61 in Workspace 23 will display 23.61 under the picon. 
Workspaces with parentheses ( ) around them do not contain any items.

Search Section

Use the Search Section to search the database for matching items. With the search fields set 
to their default states, all items in the currently selected workspace are shown.

For additional information, see “Searching the Workspace” on page 131.

View > Refresh 

Keyboard shortcut: Ctrl+R 

Use this command to refresh the current window and show new or modified clips and stills 
without waiting for a periodic update.

View > Independent Context 

Use this command to enable or cancel an Independent Context for the currently active 
window. A window with an Independent Context has its own transition and 
channel configuration.

This advanced feature allows you to give independent settings to each of several sequence or 
database windows. This gives each window its own program channel, which can be helpful 
if you are playing multiple sequences, each to a different output.
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To change the context of the current window, select Independent Context in the View Menu. 
A check mark appears next to Independent Context when it is active. The MiniMonitor 
Window shows the currently selected context.

An Independent Context is window-specific, that is, once a window has an Independent 
Context, changes made to channel assignments, transitions, etc., affect only that window. 
Switching to another window will activate that window’s context.

The Independent Context is not saved when its window is closed. For more information, see 
“Contexts and Controllers” on page 176.

Air Menu

There are two versions of the Air Menu depending on whether the current window is a 
database or a sequence. The functions in the Database version of the Air Menu are repeated 
on the Air Toolbar.

The functions in the database version of the Air Menu are repeated on the Air Toolbar 
(when enabled).

The Database version of the Air Menu has the following commands:



 Appendix B Thunder Toolbars and Menus

264

Air Menu Commands  

Command Description

Toggle Mode If Toggle Mode is active (checked), the Program and Preview 
channels swap automatically after each item is played. 

n Toggle Mode is only meant to work with sequences (not 
databases).

n Toggle Mode and AutoTake mode can not be active at the 
same time.

AutoTake When AutoTake is active (checked), the Preview clip or still 
transfers to the Program channel whenever a new item is played to 
the Preview channel. 

n AutoTake is only meant to work with databases (not 
sequences). In addition, AutoTake can only be controlled 
with the keyboard spacebar. You cannot use drag and drop, 
or F12 functionality.

n Toggle Mode and AutoTake mode can not be active at the 
same time.

Take Performs a take from Preview to Program.

Freeze Toggles a channel between live and frozen to grab a still.

Filter Applies the Filter. The filter modifies the image in the Compose 
channel by removing interfield flicker or motion. Still images only.

Save Still Saves the Compose image to the active database. Allows user-
entered database information in the Item Properties dialog box.

Quick Save Still Quickly saves the Compose image using the information in 
the template.

Record Clip Records a clip from live video, prompts user to fill in Template.

Quick Record Clip Records a clip from live video, uses current Template.
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The Sequence version of the Air Menu has all of the above choices, plus additional 
commands for playing sequences.

These functions are also available in the Sequence Toolbar:

For more information, see “Playing Sequences” on page 112.

Sequence Toolbar Buttons  

Command Description

Play Forward Plays the sequence forward.

Loop Forward Loops the sequence forward.

Play Backward Plays the sequence backward.

Loop Backward Loops the sequence backward.

Stop Stops the sequence.

Preview Event Causes an event with inhibited preview to play to the Preview 
channel.

Play Event Plays the currently selected sequence event.
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The following topics provide more information about the submenus in the Air menu:

• “Air > Take” on page 266

• “Air > Freeze” on page 266

• “Air > Filter” on page 266

• “Air > Save Still” on page 267

• “Air > Quick Save Still” on page 268

Air > Take

Keyboard shortcut: F12 

Transfers the image on the Preview channel to the Program channel. The transition and 
duration used are set in the Control Section of the MiniMonitor Window. Note that Take 
only works in a Database window. 

Air > Freeze

Keyboard shortcut: F10 

Use the Freeze command to freeze or unfreeze the Compose channel. It applies to still 
images only.

Unfreezing the channel causes the current live video input to appear on the video output for 
that channel.

Freezing it captures the current video for recording.

The live video input is selected in the Control Section of the MiniMonitor Window.

Air > Filter

Keyboard shortcut: F11 

Use the Filter command to apply the current filter to the Compose channel image file. The 
filter modifies the image by removing interfield flicker or motion. This function applies to 
still images only.

Select a filter in the Control Section of the MiniMonitor Window. The choices are Adaptive, 
Footprint and Frame Average. The Adaptive filter is the most commonly used and 
recommended.
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Air > Save Still

Keyboard shortcut: Shift+F8 

Use the Save Still command to record a still image on the Compose channel to the 
active database. 

The Item Properties dialog box displays before the clip is saved, allowing you to alter the 
clip’s database information.

To save a still: 

1. Do one of the following:

t Select Air > Save Still.

t Click Save Still.

2. Type in the Item Properties information.

3. Click Ok or press Enter. If the database information does not change, you can save time 
by selecting Air > Quick Save.
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Air > Quick Save Still

Keyboard shortcut: F8 

Use the Quick Save Still command to record a still image in the Compose channel to the 
active database using the template for the database information. This allows you to quickly 
save an image file without having to fill in the database information. If you want to enter 
database information, select Air > Save.

Window Menu

The Window menu offers the following commands which enable you to arrange different 
views of multiple open windows.

Window Menu Commands  

Option Description

New Window Creates a new window that is a copy of the currently 
selected window. 

Cascade Arranges windows in an overlapped fashion. 

Tile Arranges windows in non-overlapped tiles. 

Arrange Icons Arranges icons of closed windows. 

Toolbar Layouts Calls up Toolbar Layout dialog box. 

1, 2, ... Goes to specified window.
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The following topics provide more information about the submenus in the Window menu:

• “Window > New Window” on page 269

• “Window > Cascade” on page 270

• “Window > Tile” on page 270

• “Window > Arrange Icons” on page 271

• “Window > Toolbar Layouts” on page 272

• “Window > 1, 2...” on page 273

Window > New Window 

Use this command to open a new window with the same contents as the currently active 
window. Once opened, the new window can be changed to view another database, 
workspace or sequence.

Multiple windows are useful to simultaneously display different parts or views of a database 
or sequence window. For example, you can display different workspaces within the same 
database, or you can even edit the end of a sequence that you are currently running. 
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When a new window is opened, it becomes the active window and is displayed on top of all 
other open windows. When more than one window is open, you can use the Cascade or Tile 
commands in the Window Menu to arrange the windows.

Window > Cascade 

Use this command to arrange multiple open windows overlapping each other.

.

To cascade the open windows:

t Select Windows > Cascade.

Window > Tile 

Keyboard shortcut: Ctrl+H 

This command arranges multiple opened windows in a non-overlapped fashion. 
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Use this command to see all open windows when they “disappear” behind each other.

To tile the open windows, do one of the following:

t Select Windows > Tile.

t Press Ctrl+H.

Window > Arrange Icons

Minimized Thunder window icons can “disappear” behind other opened windows in the 
Thunder application. Use this command to arrange the minimized window icons in the 
Thunder application to the bottom of the main Thunder window. 

To move the minimized window icons to appear at the bottom of the application 
window:

t Select Windows > Tile.
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Window > Toolbar Layouts

Each user can arrange the windows and toolbars to their favorite positions and save it for 
later session. This command saves current window arrangement, opens and deletes 
previously saved window arrangements. This gives each user a “familiar” display even if 
several users operate the same Thunder.

To save your layout:

1. Arrange the current window and toolbar layout as you want it on your monitor. 

2. Select Window > Toolbar Layouts. 

The Toolbar Layouts dialog box opens. 

3. Type a name for your layout in the “Save the current layouts as:” field. 

4. Click Save, then click Close.

To delete a layout:

1. Select Window > Toolbar Layouts. 

The Toolbar Layouts dialog box opens. 

2. Select the layout you want to delete in the “Existing layouts.” 

3. Click Delete

4. Click Save, then click Close.
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Window > 1, 2... 

This command shows a list of all open windows. The currently active window is indicated 
by a check mark. To go to a window from this list, move the mouse cursor to the entry and 
click the left mouse button.

n For a list of recently closed windows, click the File menu.

Help Menu

The Help Menu offers the following commands to assist you with the Thunder application.

Help Menu Commands  

Command Description

Tip Of The Day Displays quick tips regarding how to use Thunder.

Help Topics Displays the Thunder Help file.

Display Input Status Shows whether Thunder detects a video, key or Genlock signal.
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The following topics provide more information about the submenus in the Help menu:

• “Help > Tip Of The Day” on page 274

• “Help > Help Topics” on page 274

• “Help > Display Input Status” on page 275

• “Help > About...” on page 275

Help > Tip Of The Day 

This dialog box displays quick tips regarding Thunder use.

The check box “Show Tips on StartUp” causes the Thunder application to display a tip each 
time Thunder is started. 

Help > Help Topics 

Use this command to display the opening screen of Help (this document). The opening 
window displays links to topics that provide step-by-step instructions for using Thunder and 
reference information.

About... Displays the copyright notice and software version number.

Help Menu Commands  

Command Description
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Help > Display Input Status

Selecting Display Input Status brings up the Input Video Status dialog box. This dialog box 
shows whether Thunder detects a video, key, or LTC signal connected to its hardware 
channels. A checkmark indicates that Thunder detects a signal at that port.

If your Thunder has fewer than four hardware channels, boxes will only be shown for the 
number of channels present. If a box is unchecked, it means that Thunder does not detect a 
signal for that input. The Reference check box shows whether Thunder detects a 
Genlock connection.

Help > About...

Select this menu option to display the copyright notice and version number of your 
Thunder software.
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Appendix C

Using ODBC on Thunder and Browse 
Systems

Before setting up an ODBC database on the Thunder workstation, you must enable the 
ODBC option on each Thunder Browse, Deko or MOS system that needs to access a 
Thunder database. 

This section contains the following topics:

• “Enabling the ODBC Option” on page 277

• “Setting Up an ODBC Database” on page 285

Enabling the ODBC Option

The ODBC option must be enabled on the Thunder server and on every Thunder Browse, 
Deko, or MOS machine that needs to access a Thunder database. 

n If your dongle does not support ODBC, contact Avid Customer Support to obtain 
information on purchasing the ODBC option.

To enable the ODBC option:

1. Select Start > Settings > Control Panel. 

The Control Panel opens.

2. Select Administrative Tools.
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3. Select Data Sources (ODBC).

The ODBC Data Source Administrator dialog box appears.

4. Select the System DSN tab and click on the Add button. 

The Create New Data Source dialog box appears.  

Click the Add 
button
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5. Select SQL Server and click Finish.

The Create New Data Source to SQL Server wizard appears.

6. Do the following:

- In the Name field, type shark

- In the Description field, type shark. 

- In the Server menu, select your SQL server. 
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7. Click Next.

The following dialog opens.

8. Do the following:

- Select the With SQL Server authentication button. 

- Check the Connect to SQL Server checkbox. 

- Type shark in the Login ID field.

- Type shark in the Password field. 

n Many installations will not use the default of named pipes to connect to the SQL Server. If 
you do not know which network library you will be using, contact your IT Administrator. 
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9. If you:

- Need to change to TCP/IP, click on the Client Configuration button. The Edit 
Network Library Configuration dialog box opens.

- Do not need to change to TCP/IP, go to Step 11.

10. In the Network libraries area, select TCP/IP, and click OK.  

You will return to the previous dialog box.
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11. Click Next.

The next dialog box opens.

12. Verify that “shark” is the default database. If it is not, check the “Change the default 
database” checkbox and select shark from the menu.

13. Click Next.

14. The next dialog box opens.
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15. Keep the default selections on this dialog box, and click Finish. 

The ODBC Microsoft SQL Server Setup dialog box opens.  
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16. Click on the Test Data Source... button.  After a few moments, the test results appear.

The test should return a successful result. 

If the test:

- Is successful, the ODBC setup is complete.  Click OK.

- Fails, recheck your settings for the Server and Thunder, and then run the test again.

- Still fails, contact Avid Technical Support.
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17.  Verify that “shark” is displayed in the System Data Sources window, and click OK.

c Repeat the preceding procedure for every Thunder Browse, Deko, or MOS machine 
that needs to access a Thunder database. 

You are now ready to create an ODBC database on the Thunder server. For more 
information, see “Setting Up an ODBC Database” on page 285.

Setting Up an ODBC Database

Once you have enabled ODBC on your Thunder server, you must set up the ODBC database 
on every Thunder Browse, Deko and MOS system that you want to have access to the 
Thunder database.

For information on enabling ODBC on the Thunder server (and on any other Thunder 
Browse, Deko, or MOS system), see “Enabling the ODBC Option” on page 277.

To set up an ODBC Database on the Thunder server:

1. Launch the Thunder application.

2. Click on File > Advanced > Create New Database.

The Create New Database dialog box opens.
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3. Create a new database as discussed in “Creating a New Database” on page 122. 
However, when you get to the Options section, you should read Step 4 of this procedure 
and then continue.

4. In the Options area, do the following:

- check the ODBC check box.

- In the ODBC Database number field, assign an ODBC database number. 

n The ODBC Database Number must be a unique number.  Assigning the same number to two 
different databases will result in the SQL Server database becoming corrupted.  The 
Thunder application will check if the number you have chosen is already in use, and if it is in 
use will suggest the next available number.

Avid recommends creating a database name that can be used to easily identify the ODBC 
number, such as in this example, ODBC-3.  

5. Click on Create.

6. Select File > Open and browse to the newly created database and open it.

The database is ready for use. This concludes setup and configuration of an ODBC 
database on the Thunder server.
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M
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MiniMonitor Window, MiniMonitor section 173
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Quantel 150, 162, 198
Quantel FTP option 154
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Replace an event 109
Restart protocol 215
Restore Full Database 129
Right Mouse Menu 181

S
Save 90, 183, 186, 264, 267
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W
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Window Menu 268
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Y
YUVK file format 162, 204
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