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Pr
ef

ac
eWelcome to Bento

Bento® software helps you organize your information, 
providing the power of a database without complexity. 

Bento is an easy-to-use database that manages contacts, tasks, and other information 
that is important to you. Because Bento is a database, you can create data 
relationships and view your data in more ways than you can in a spreadsheet. 

Bento was designed for Mac OS X. The Bento window has features that will seem 
familiar to you if you use Address Book, iCal, Keynote, or iTunes. 

Bringing It All Together
Bento brings your important information together in one place to help you get 
organized. You’ll be able to manage your contacts, coordinate events, track projects, 
prioritize tasks, and more. 

For example, say you are running a travel club, and you are planning events for the 
club. You have the contact information for the travel club members in Address Book, 
and you have a few events on the calendar in iCal. But you are also using a 
spreadsheet to track some expenses for each of the members of the travel club. You 
can use Bento to manage all information in one place. 
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Using Address Book Data 

When you open Bento, you see the Home dialog that helps you get started. After you 
start using Bento, you see that the Bento Address Book library displays contact 
records from the Address Book application. 

View data in several form views. 
Bento provides the “Overview” 
and “Details” forms for you. 

A contact in the 
Address Book 
application. 

The same contact 
in the Bento 
Address Book 
library. 

View all the records 
in table view by 
clicking “Table.”
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Using iCal Data 
The Bento iCal Events library displays the events that are in the iCal application. 

An Event in the 
iCal application. 

The same event in 
the Bento iCal 
Events library. 

 View the record data 
in “Table” view or in 

“Form” view.
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Managing Data in Libraries 

Bento comes with more than 20 library templates to help you create libraries easily. 
You can create an Expenses library to track information about expenses, and an Event 
Planning library to track information about your travel club events. 
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Bento provides a Project library, so you’re ready to start managing projects for your 
travel club. 

You can add fields to any library, even the Bento Address Book and iCal libraries. 

Libraries Fields 
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Importing Data from Other Applications 
How do you add your spreadsheet of expenses to Bento? Create a library by 
importing data from another application, or import data into a library you’ve already 
created. 

Save your spreadsheet as a comma-separated values (CSV), tab-separated values 
(TAB), Numbers, or Excel file, and then import the file into Bento. Bento creates the 
fields needed to hold your data and creates records for each row of data in the file.

Importing 
spreadsheet 

data into a 
Bento library. 



Preface    Welcome to Bento 13

 

Creating Collections 
You have a team of people who are working with you on your next travel club event. 
All of your team members are in the Bento Address Book library, but you’d like to 
create a smaller group that includes only your team members, not everyone in the 
Address Book library. You want to create a collection. 

Creating a collection is as easy as creating a group in Address Book or a playlist in 
iTunes. Open the Bento Address Book library in table view. Select the records for the 
team members and choose the New Collection from Selection menu item, or drag the 
selected records to the Libraries pane. 

Give the collection the name “Team Members” and Bento creates the Team Members 
collection. 

Drag the selected 
records to the 

Libraries pane.
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Creating Relationships 
Bento makes it easy to connect your libraries of information using related records 
lists. 

For example, say you want to track expenses by team member. To create a related 
records list, drag “Team Members” to the “Expenses” form. 
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You can also create a related records list that shows expenses for each team member. 
Drag “Expenses” to the “Team Members” form. 

Summary

With Bento, you’re able to display data from Address Book and iCal, create new 
libraries to keep all your data together, import data from other applications, and 
create unique data relationships between libraries and collections. 
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About This Document
The following table tells you where to find information in this documentation. 

Resources for Learning More 
To get the most from Bento, consult the resources listed below. 

User’s Guide 
Bento User’s Guide is a PDF document that provides detailed information on using 
Bento. 

To open the User’s Guide: 
Choose Help > Bento User’s Guide. 

Onscreen Help 
To access help from within Bento, choose Help > Bento Help. You can browse through 
the table of contents to find a specific topic, or enter a question in the search field. 

Tutorial 
For a demonstration of what you can do with Bento, view the tutorials. 

To access the tutorials: 
Choose Help > Video Tutorial, and then follow the instructions. 

For information about See 

The features of Bento Chapter 1, “Overview of Bento,” on page 19

Using libraries to manage your information Chapter 2, “Using Libraries,” on page 33

Using the Address Book and iCal libraries to display 
data from the Address Book and iCal applications 

Chapter 3, “Using the Address Book and iCal 
Libraries,” on page 39

Creating a subset of records from a library Chapter 4, “Using Collections,” on page 47

Viewing your data one record at a time, creating 
forms, changing the appearance of forms, and 
adding new fields to forms 

Chapter 5, “Using Form View,” on page 51

Viewing all the records in a library or collection in a 
table 

Chapter 6, “Using Table View,” on page 61

All the field types that Bento provides, and using 
the Fields pane 

Chapter 7, “Using Fields,” on page 69

Sharing data by importing, exporting, and printing Chapter 8, “Importing, Exporting, and Printing,” on 
page 85

Creating a backup of your Bento data Chapter 9, “Backing Up and Restoring Information,” 
on page 99

Syncing information between Bento and Bento for 
iPhone

Chapter 10, “Using Bento with Bento for iPhone and 
iPod touch,” on page 105

Using keyboard shortcuts Appendix A, “Keyboard Shortcuts,” on page 109



Preface    Welcome to Bento 17

 

Bento Forum
Visit the Bento forum to get technical support, tips, report problems, and share with 
others how you use Bento.

To access the Bento forum: 
Choose Help > Bento Forum.

Web Resources 
Learn more about Bento on the web. 

To access web-based information about Bento: 
1 Choose Help > Bento Help. 

2 Click the Bento Website link.

Technical Support 
To learn more about the support options that are available to Bento users, view the 
service and support information. 

To view the service and support information: 
Choose Help > Service and Support. 
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1 Overview of Bento 

This chapter provides an overview of Bento features. 

This chapter is a description of what you see when you start using Bento. It introduces 
the Home dialog and describes the sections of the Bento window, including the 
Libraries pane, the Fields pane, and the records area where you can display your 
information in table view, form views, or split view. 

Home Dialog
When you first open Bento, you use the Home dialog to learn about Bento, to display 
Address Book and iCal records in Bento, and to create your first library.

To see how easy it is to use, take 
a video tour of Bento.

Display Address Book and iCal 
information in Bento, and you can 
use the data in other libraries, too.

Bento uses libraries to store 
information. One way to start using 

Bento is by creating a library.

When you’re done with the Home dialog, 
click this button to start using Bento.
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Tip:  You can use the Home dialog every time you start Bento. If you decide that you 
don’t need the Home dialog, choose Bento > Preferences and clear the “Display 
Home dialog” checkbox.

Clear this checkbox if 
you don’t need the 

Home dialog. 
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Bento Window
The Bento window contains two main sections: 

1 The left side of the window contains the Libraries pane and the Fields pane. 

1 The right side of the window displays the records in Bento. You can display record 
data in table view, form view, or split view.

By default, both sections of the Bento window are displayed. To hide the Libraries 
pane and Fields pane, choose View > Hide Libraries & Fields Pane.

Libraries pane Records area

Fields pane
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Libraries Pane 
The Libraries pane displays the libraries and collections that are in Bento. 

1 A library categorizes data by content. Bento provides several libraries by default. 
The Address Book, iCal Tasks, and iCal Events libraries display data from the Address 
Book and iCal applications. The Projects library, which stores data about projects, is 
an example library with sample data. You can create libraries to store other 
categories of data. 

To add a library to the Libraries pane, click the New Library button. 

See Chapter 2, “Using Libraries,” on page 33. 

1 A collection is set of records from a library. A collection is similar to an Address Book 
group or to a playlist in iTunes. A collection contains records from its parent library. 
A record from the library can be in more than one collection. For example, one 
person might be both a friend and a co-worker. If you had one collection named 
“Friends” and another named “Co-workers” you could add this person’s contact 
record to both collections in the Address Book library. 

To add a collection to the Libraries pane, click the New Collection button. 

See Chapter 4, “Using Collections,” on page 47.

Address Book 
Library

iCal Events 
Library

Collections of 
Address Book 
records

Collection of 
iCal Events 

Collection of 
records from 

Projects 

New Library 

New Collection 

Projects Library

iCal Tasks Library
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Address Book and iCal Libraries 
Bento displays the data you’ve already entered into the Mac OS X applications 
Address Book and iCal using three libraries: Address Book, iCal Events, and iCal Tasks. 

Address Book Library 
The Address Book library displays contact information from the Mac OS X Address 
Book application, so there is no need to re-enter your contact information. Enter new 
contacts in Address Book or in Bento, and the information appears in both 
applications.

See “Address Book Library” on page 40. 

iCal Events Library 
The iCal Events library displays information from the events in the Mac OS X iCal 
application. You can view those events in Bento, and use them with other data you 
store in Bento. For example, you can display which iCal events are related to a specific 
project by creating a relationship to iCal Events in a Projects library. 

Enter new events in iCal or in Bento, and the information appears in both 
applications. 

See “iCal Events and iCal Tasks Libraries” on page 43. 

iCal Tasks Library
The iCal Tasks library displays information from the To Do items in iCal. You can use 
those tasks in your Bento libraries and collections. For example, you can display which 
iCal tasks are related to a specific project by creating a relationship to iCal Tasks in a 
Projects library. 

Enter To Do items in iCal or task records in Bento, and the information appears in both 
applications.

See “iCal Events and iCal Tasks Libraries” on page 43. 

Collections 
Create a collection when you want a subset of the records from a library. There are 
two kinds of collections:

1 Collections are created by adding records from the library to a new collection. 
Creating a collection is as easy as creating a playlist in iTunes. Select the records in 
the library and use the New Collection from Selection menu item, or drag the 
selected records to the Libraries pane. 

1 Smart Collections are created based on criteria you set up. Records that meet the 
defined criteria appear in the Smart Collection.

See Chapter 4, “Using Collections,” on page 47. 
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Creating Libraries 
Bento comes with more than 20 library templates that make it easy for you to create 
new libraries of information. A template defines the fields of information used in each 
record of a library, which you can change based on your needs. Select the library 
template that most closely matches the category of data you want to store. 

 

See “Creating a Library Using the Bento Templates” on page 34. 
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Records Area 
On the right side of the Bento window, you can display information stored in Bento in 
either table view, a form view, or split view. 

1 Table view shows information in an entire library or collection in a spreadsheet-like 
table, where each row in the table is a record in the library. 

1 Form view shows fields from one record at a time, in arrangements that you can 
customize, using beautiful themes.

1 Split view shows the selected record in both form view and table view at the same 
time.

Table view shows each 
record as a row in a table. Form view shows fields from a single record. 

Split view lets you view a record as a row in a table and in a page-like format at the same time. 
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Table View 
To view the information in an entire library or collection in a spreadsheet-like table, 
use table view.

In table view, you can work with your records in many ways, including: 

1 Selecting the columns (fields) that you want to show. 

1 Arranging the columns in any order. 

1 Sorting records by selecting a specific column. 

1 Analyzing data using a summary row. 

See Chapter 6, “Using Table View,” on page 61. 

Form View 
To view your information one record at a time, use form view. In form view, you can 
create multiple forms for each collection or library, giving each form a different name. 
For example, you could create a form in the Address Book library to show birthdays, 
and track whether you’ve sent a card or gift. 

You can customize forms in many ways, including: 

1 Selecting the fields that you want to show. 

1 Arranging the fields on the form. 

1 Changing the size of fields. 

1 Changing the appearance of the form using themes. 

See Chapter 5, “Using Form View,” on page 51. 

Split View
To view the selected record in form view and table view at the same time, use split 
view.
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Form Themes 
Bento provides an assortment of beautiful themes that you can apply to your forms. 
Every theme includes coordinated colors, layout, fonts, and text attributes. You can 
easily change a form’s theme at any time. 

See “Customizing Form Layouts” on page 56. 
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Navigation Bar
The navigation bar contains several controls that help you display information in 
Bento. 

1 Click the Table button to see records in a spreadsheet-like view.

1 Click one of the form view buttons to see records one at a time in a page-like view. 
In the example below, there are two form view buttons: “Overview” and “Details.” 
You can have as many form views as you want. 

1 Click  to show or hide records in both form view and table view at the same 
time.

1 To move through the records in a library or collection, click the Previous record and 
Next record buttons (the arrow buttons). 

To go to the first record, Option-click the Previous record button. To go to the last 
record, Option-click the Next record button. 

Search Field and Advanced Find 
1 Use the Search field to do a simple search for text in all field types except media, 

related records list, file list, and message list. 

1 Use Advanced Find to find a set of matching records by defining search values and 
criteria for specific fields. 

To use the Search field: 
1 Select the library or collection.

2 Enter a text string into the Search field. 

Form view buttons New form Delete form 

Previous record

Show or hide 
split view

Next record Search field

Table view
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Bento searches across all the applicable fields of the selected library or collection. 
Bento lets you know how many records match the search string, and updates the 
current view to display the matching records for those fields that are selected in table 
view or have been added to a form in form view. Since Bento searches all fields, the 
number of records found may not match the number of records that are displayed.

1. Type “M”and the result is 29 records. 2. Type “Ma” and the result is 12 records. 

3. Type “Mar” and the result is 6 records. 4. Type “Mary” and the result is 2 records. 
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To use Advanced Find: 
1 Select the library or collection. 

2 In the search field, click  and select Advanced Find, or press Command-F. 

3 Specify what you want to find. Add or remove criteria as needed. 

4 Click Find.

Bento performs the search, and displays the matching records. 

1 To save the matching records as a Smart Collection, click Save. See “About Smart 
Collections” on page 49. 

1 To close Advanced Find, click the X next to “Advanced Find” or press Command-F. 
When you close Advanced Find, Bento shows all records. 



Chapter 1    Overview of Bento 31

 

Fields Pane
The Fields pane on the left side of the Bento window displays the fields that are 
defined for the selected library or collection.

1 In a form view, use the Fields pane to add fields to the current form by dragging a 
field name with  to the form.

1 In table view, use the Fields pane to select which columns are shown.

1 In split view, the Fields pane indicates the fields that can be added to the current 
form or can be displayed in table view.

See “Using the Fields Pane” on page 79. 

Drag to add field to 
the current form.

Field is already on 
the current form.

Fields with 
selected 

checkboxes are 
already shown as 
columns in table 

view.

In form view In table view 

Select an 
unchecked field to 

show it as a
column in table 

view.

Address subfields 
can’t be added to the 
form individually.
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2 Using Libraries 

In Bento, you use libraries to organize your information. 
You can use the libraries that Bento provides, and create 
your own libraries using templates. 

Bento contains three libraries that display data from other Mac OS X applications: 

1 Address Book library, which displays contact records from the Address Book 
application

1 iCal Events library, which displays events from the iCal application 

1 iCal Tasks library, which displays To Do items from the iCal application 

For information on these libraries, see Chapter 3, “Using the Address Book and iCal 
Libraries,” on page 39. 

You can also create libraries to hold your information: 

1 By using the New Library dialog 

1 By importing existing information from a comma-separated (CSV), tab-separated 
(TAB), Numbers, Excel, or library template file

This chapter describes how to use libraries to organize and manage your information. 

About Libraries 
Bento stores information in libraries. Libraries are composed of records, and libraries 
are defined by the fields in the records. 

For example, the Address Book library contains contact records. Contact records are 
composed of the fields that are used to store information about contacts and to 
update the Address Book application, such as names, phone numbers and addresses. 

As another example, the Projects library records are composed of fields that are useful 
for managing projects, such as fields for the project status, start and end dates, and 
team member information. 
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Bento provides several ways for you to view the records of a library: 

1 Form view shows fields from a single record. Each page shows one record at a time, 
for example, a single contact record in the Address Book library. You can have more 
than one form view for the library. See Chapter 5, “Using Form View,” on page 51. 

1 Table view shows the records in a table, for example, a list of the contacts in the 
Address Book library. Each row in the table represents a single record in the library. 
See Chapter 6, “Using Table View,” on page 61. 

1 Split view shows a record in form view and table view at the same time.

The remainder of this chapter describes how to create and use libraries: 

1 You can create your own libraries by using library templates. See the following 
section, “Creating a Library Using the Bento Templates.”

1 You can create a library by importing your own data. See “Importing Information 
into Bento” on page 88. 

Creating a Library Using the Bento Templates 
Before you create a library, think about the type of information you want to manage 
with the library. Do you want to manage schedules and dates? Do you want to 
manage contact information? Are you looking for a way to bring tasks and 
assignments together in an event planner? Or do you want to manage a list of things, 
such as inventory or equipment lists? 

Bento provides library templates that create the fields to manage specific kinds of 
information. These templates also apply pre-designed themes to the form views. 

By selecting the library template that most closely fits the type of information you 
want to manage, you create the library you need more quickly. If you can't find a 
template for the kind of information you want to store, you can use the “Blank” 
template and create a library of your own. After you create a library from a template, 
you can customize the form view by adding or removing fields and changing the 
theme. 

Tip:  If you already have information from another application that you want to 
include in Bento, see “Importing Information into Bento” on page 88.
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To create a library using the Bento templates: 
1 Choose File > New Library from Template. 

2 In the New Library dialog, select a template category in the left column, then select 
the template. 

Select “Blank” if none of the templates meet your needs. You can create all of the 
fields yourself with the Blank library. 

3 Enter a name for your library, and click Choose. 

Bento creates the library and opens it in form view. 

If you selected a template other than the Blank template, review the fields that are 
defined for your new library. 

1 If you are happy with the fields and form views in your new library, then you’re 
ready to add records and enter information. See “Editing Records in Form View” on 
page 52. 

1 If you need additional fields, you can customize the library by adding fields. See 
“Adding Fields to a Form” on page 55. 

1 If there are fields defined for information that you do not need, then delete those 
fields. See “Removing Fields from a Form” on page 56. 
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1 If you want to change the layout of the fields on the form view, then see 
“Customizing Form Layouts” on page 56. 

1 If you want to change the appearance of the form view, you can select a different 
theme. See “Customizing Form Layouts” on page 56. 

If you are working in a library created from the Blank template, then the default view 
is an untitled form with default fields and with the default library theme applied. 
Double-click the form name in the navigation bar to rename the form, add fields and 
customize the form layout, if you wish. See Chapter 5, “Using Form View,” on page 51 
for more information. 

Creating a New Blank Library
You can get started quickly by creating a blank library, then add data to it as you 
would in a spreadsheet.

To create a new blank library: 
1 Choose File > New Blank Library. 

Bento creates a library with a default name and opens it in table view. 

2 Double-click the library name to rename it.

3 Click in the highlighted cell to start entering or pasting data.

See “Editing Records in Table View” on page 63 and “Copying and Pasting Data in 
Table View” on page 63.

Creating a Library by Importing 
If you already have information from another application that you want to include in 
Bento, then create a library and records in that library by importing your information. 
See “Importing Information into Bento” on page 88. 

Deleting Records from a Library 

To delete records from a library: 
1 Select the library.

2 Select the records and press Command-Delete. 

When you press Command-Delete, the records are permanently deleted from both 
the library and any collection or related records lists that displayed them. 
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Deleting a Library

To delete a library: 
Select the library and press the Delete key.

When you press Delete, the library and all of its records are deleted. 

Any related records list fields in other libraries based on this library are deleted also. 

Note:  You cannot delete the Address Book, iCal Events, or iCal Tasks libraries. If you do 
not want to display these libraries, see “Displaying the Address Book and iCal 
Libraries” on page 39. 
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3 Using the Address Book and iCal 
Libraries 

Bento provides libraries that display data from the 
Mac OS X Address Book and iCal applications. With these 
libraries, you can manage contacts, events, and tasks 
together, and display them as related records in other 
libraries in Bento. 

Bento contains three libraries that display data from other Mac OS X applications: 

1 Address Book library, which displays information from the Address Book application

1 iCal Events library, which displays events from the iCal application 

1 iCal Tasks library, which displays to-do items from the iCal application 

This chapter describes how to use these libraries to organize information about 
contacts, events, and tasks, and how to add information from these libraries to your 
own libraries. 

Displaying the Address Book and iCal Libraries 
Bento starts with an Address Book library, an iCal Events library, and an iCal Tasks 
library. Even if the Address Book and iCal applications are not running, you see the 
data from these applications in Bento. 

Displaying the Address Book and iCal libraries is optional. When you first start using 
Bento, these libraries are displayed by default. 

If you turn off the display of these libraries in Bento, their records no longer appear in 
Bento, but they still appear in the Address Book and iCal applications. 

Displaying Data from the Address Book Application 

To display the Address Book data in Bento: 
1 In Bento, choose File > Address Book and iCal Setup. 

2 Select “Display Address Book data in Bento.” 



40 Chapter 3    Using the Address Book and iCal Libraries

 

To turn off the display of Address Book data in Bento: 
1 In Bento, choose File > Address Book and iCal Setup. 

2 Clear “Display Address Book data in Bento.” 

When you click OK, the Address Book library no longer appears in Bento. 

If you have related records list fields based on the Address Book library, those related 
records list fields are no longer displayed when you turn off the display of the Address 
Book library. 

Displaying Data from the iCal Application 

To display the iCal data in Bento: 
1 In Bento, choose File > Address Book and iCal Setup. 

2 Select “Display iCal data in Bento.” 

To turn off the display of iCal data in Bento: 
1 In Bento, choose File > Address Book and iCal Setup. 

2 Clear “Display iCal data in Bento.”

When you click OK, the iCal libraries no longer appear in Bento. 

If you have related records list fields based on the iCal libraries, those related records 
list fields are no longer displayed when you turn off the display of the iCal libraries. 

Address Book Library 
By default, Bento displays contact information and groups from the Mac OS X Address 
Book application. When you make changes to records in the Bento Address Book 
library, you are actually updating the records in the Address Book application. 

You can use the Bento Address Book library to edit data from any application or 
device that synchronizes with the Address Book application. 

By displaying the Bento Address Book library, you add your contacts to Bento and 
keep your contacts up-to-date, whether you edit the information in the Address Book 
application or in Bento. 

1 If you add a record in the Address Book library, then it is added to the Address Book 
application. 

1 If you delete a record in the Address Book library, then it is deleted from the 
Address Book application. 

1 For every group that you create in the Address Book application, Bento creates an 
Address Book library collection.

1 For every collection you create in the Address Book library, the Address Book 
application creates an Address Book group. 
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If you delete a collection under the Address Book library, the associated Address Book 
group is deleted also. Similarly, if you delete a group in the Address Book application, 
the associated collection under the Address Book library is deleted also.

You can use the records in the Bento Address Book library just like the records in any 
other library and collection in Bento. The only difference is that changes in the 
Address Book library update information in the Address Book application. 

Note:  Bento does not display Smart Groups from the Address Book application. 
Conversely, Smart Collections from the Bento Address Book library are not added to 
the Address Book application. 

The Address Book library 
displays contact 
information from the 
Address Book application. 

Address Book 
groups display 

as collections 
in Bento. 



42 Chapter 3    Using the Address Book and iCal Libraries

 

Bento Fields That Update the Address Book Application 
The following fields in the Address Book library update information in the Address 
Book application. 

You can add other fields to your Address Book library records in Bento, but your 
additional fields are not added to the Address Book application. (See Chapter 7, 
“Using Fields,” for information on adding fields.) 

Conversely, any custom field labels you have defined in the Address Book application 
are not displayed in the Address Book library in Bento. 

Troubleshooting Address Book Updates 
This section describes some common issues with displaying data from the Address 
Book application. 

1 Why don’t I see my Smart Groups from the Address Book application in Bento? 

Bento does not display Address Book Smart Groups because the criteria used to 
create the groups are not available to Bento. 

1 Why don’t I see my Address Book library’s Smart Collections in the Address Book 
application? 

The criteria used to create Bento Smart Collections cannot be passed to the 
Address Book application because the criteria may use fields that appear only in 
Bento and may involve fields in the Address Book application that are not available 
to Bento. 

Other Address Book Considerations 
1 When you create a Bento backup file, the data from the Address Book application is 

not included in the Bento backup file. To back up the data from Address Book, use 
the Address Book application. 

If you add fields to the Address Book library, information from those additional 
fields is included in the Bento backup file. See Chapter 9, “Backing Up and Restoring 
Information,” on page 99 for information on creating a Bento backup file. 

Address: Home, Work, Other 
Address list
Birthday
Company name 
Department
Email address: Home, Work, Other
Email address list 
First name 
Home page 

IM account: Home, Work, Other 
IM account list 
Is Company
Job title
Last name 
Maiden name
Middle name 
Nickname 
Note 
Phone number: Work, Home, Mobile, 
Main, Home fax, Work fax, Pager, 
Other 

Phone number list 
Phonetic first name
Phonetic last name
Phonetic middle name
Prefix 
Suffix 
URL
URL list 
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1 You can use import and export with the Address Book library. Records imported 
into the Address Book library update the Address Book application. See Chapter 8, 
“Importing, Exporting, and Printing,” on page 85 for information on importing and 
exporting.

iCal Events and iCal Tasks Libraries 
iCal is a convenient application for keeping track of your events and tasks. 

By default, Bento gets the calendar information from the iCal application and keeps 
the information in your iCal Events and iCal Tasks libraries updated with iCal changes. 
In addition, any changes you make in Bento update the iCal application information. 

Bento creates a record for each event or task in the iCal application, for the iCal 
calendars stored on your computer. By default, any events or tasks you create in 
Bento are added to the Bento calendar in iCal, and you can reassign them to other 
iCal calendars.

The iCal Events library 
displays event records 
from the iCal application. 
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You can use the records in the iCal Events and iCal Tasks libraries just like the records 
in any other libraries and collections in Bento. The only difference is that changes in 
the iCal Events and iCal Tasks libraries update the information in the iCal application. 

Note:  Bento does not display information from the subscribed calendars in the iCal 
application. 

Bento Event Fields That Update the iCal Application 
The following fields in the Bento iCal Events library update the iCal application.

1 All Day

1 Calendar

1 End date

1 Location

1 Note

1 Start date

1 Title

1 URL

Note:  In the iCal application, the “URL” field is a text field. In order to correctly display 
this value in Bento, the iCal Events library uses a text field as well, rather than using a 
Bento URL field. 

You can add other fields to your event records in Bento, but your additional fields do 
not update the iCal application. See Chapter 7, “Using Fields,” for information on 
adding fields. 

Bento Task Fields That Update the iCal Application 
The following fields in the Bento iCal Task library update the iCal application.

1 Calendar

1 Completion date

1 Due date

1 Note

1 Priority

1 Title

1 URL

Note:  In the iCal application, the “URL” field is a text field. In order to correctly display 
this value in Bento, the iCal Tasks library uses a text field as well, rather than using a 
Bento URL field. 

You can add other fields to your task records in Bento, but your additional fields do 
not update the iCal application. See Chapter 7, “Using Fields,” for information on 
adding fields. 
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Troubleshooting iCal Updates 
This section describes some common issues with displaying data from the iCal 
application. 

1 Why don’t I see the collections from iCal Events or iCal Task libraries in the iCal 
application? 

The iCal application does not have a way to display a subset of the events or tasks 
from a specific calendar. 

1 Why don’t I see events or tasks from my subscribed calendars? 

Subscribed calendars are stored on an external server; Bento displays information 
for local calendars only. 

1 How do I create a calendar in Bento? 

When you create a calendar in the iCal application, it can be used as a calendar 
selection in Bento. You cannot create a calendar in Bento. 

Other iCal Considerations 
1 When you create a Bento backup file, the data from the iCal application is not 

included in the Bento backup file. To back up the data from iCal, use the iCal 
application. 

If you add fields to the iCal libraries, information from those added fields is included 
in the Bento backup file. See Chapter 9, “Backing Up and Restoring Information,” on 
page 99 for information on creating a Bento backup file. 

1 You can use import and export with the iCal libraries. Records imported into the 
iCal libraries update the iCal application. See Chapter 8, “Importing, Exporting, and 
Printing,” on page 85 for information on importing and exporting. 
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4 Using Collections

This chapter describes how to use collections to further 
organize your records in Bento. 

In Bento, your records are kept in libraries, as described in Chapter 2, “Using Libraries.” 
If you want to organize records in different ways or if you want to work with a subset 
of the records in a library, you can create a collection. 

About Collections 
A collection is a set of records from a library. You can create a collection to: 

1 Create a set of records for a special purpose. For example, you could create a 
collection of the people invited to a specific event. 

1 Sort records in a different order. For example, you could create a collection of 
contacts to sort the contact records by last name. 

1 Export the data from the records in the collection rather than from all the records in 
the library. 

A collection in Bento is similar to a playlist in iTunes. If you have used iTunes, you 
know how convenient it is to use a playlist to create a compilation of songs and 
videos. Collections in Bento give you the same convenience for grouping records 
from a library. 

A collection contains records from a single library. For example, you can put records 
from the Address Book library in an Address Book collection such as Vendors. You 
cannot put any other library’s records in the Vendors collection. 

Vendors collection in the 
Address Book library
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However, a record from a library can be added to any of the collections in a library. For 
example, if you have a “DVD” library with a “Favorites” collection and a “Classic 
Movies” collection, you can have the same record in both collections. 

There are two kinds of collections:

1 collections

1 Smart Collections

You create collections by using the New Collection menu item, by selecting records 
and using the New Collection from Selection menu item, or by dragging selected 
records to an existing collection or to the Libraries pane. 

Smart Collections are created based on criteria you set up. Smart Collections update 
as your library changes; records that meet the defined criteria appear in the Smart 
Collection. 

Creating Collections
Create a collection when you want to make a specific list of records.

To create a collection: 
1 Select a library in which you want to make a collection.

2 Click  or choose File > New Collection. 

3 Type a name for the collection, then press Return. 

4 Select the library you selected in step 1 again.

5 Click Table in the navigation bar or choose View > Table View to show the library in 
table view.

6 Select the record you want to add to the collection. Drag the selected record to the 
collection, or click  and choose Add to Collection to add the selected record to the 
collection. 

To select multiple records, hold down the Command or Shift key while you click. 

Tip:  To quickly create a collection containing selected records, select the records, then 
choose File > New Collection From Selection or drag the records to a blank space in 
the Libraries pane.

Removing Records from a Collection

To remove records from a collection: 
1 Select the collection.

2 Select the records and press the Delete key.
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If you click Remove from Collection, the records are removed only from the collection, 
not from the associated library. If you click Delete, the records are permanently 
removed from both the library and the collection. 

Deleting a Collection

To delete a collection: 
Select the collection and press the Delete key. The records are removed from the 
collection but not from the library.

Note:  If you delete a library or collection that one or more related records lists are 
based on, those related records lists are also deleted.

About Smart Collections 
Create a Smart Collection when you want a collection that contains records that meet 
criteria you define. Smart Collections show all the records that meet the criteria.

For example, you could create a Smart Collection of contacts who live in the same 
city. When you add a new contact record for a person who lives in that city, Bento 
automatically adds that contact record to your Smart Collection. 

Or you could create a Smart Collection of event records that are due in the same 
week. If you add or modify a record so that it meets the criteria, that record appears in 
the Smart Collection the next time you click the Smart Collection in the Libraries 
pane.

Because a Smart Collection is a set of records that match defined criteria, it is different 
from a collection in the following ways: 

1 You cannot manually add records to or remove records from Smart Collections. To 
remove certain records from the Smart Collection, edit the criteria or modify the 
records’ values so that they no longer meet the criteria.

1 You can create Smart Collections in the Address Book library, but Smart Collections 
do not appear in the Address Book application. 

1 You can create Smart Collections in the iCal Tasks and iCal Events libraries, but 
Smart Collections do not appear in the iCal application. 

1 You cannot import records into a Smart Collection. 
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Creating Smart Collections 
You can create a Smart Collection that adds records to or removes records from a 
collection according to criteria that you define.

To create a Smart Collection: 
1 Choose File > New Smart Collection.

2 Type a name for the Smart Collection, then press Return.

Use the pop-up menus and entry fields to specify the criteria for the Smart Collection. 
Click  to add additional criteria.

For example, to create a Smart Collection that only shows iCal tasks that are not 
completed, specify the criteria to be All, Completion Date, and Is empty.

3 Click Save. 

Tip:  You can also create a Smart Collection by clicking Save after you specify the 
criteria for an Advanced Find. See “Search Field and Advanced Find” on page 28.

Working with Smart Collections
After you create a Smart Collection, you can edit and duplicate records within it. See 
“Editing Records in Table View” on page 63 and “Duplicating Records in Table View” 
on page 64.

Changing a Smart Collection
When you change a Smart Collection, Bento updates the collection based on the 
criteria that you define. 

To change a Smart Collection: 
1 Select the Smart Collection and choose File > Edit Smart Collection.

2 Use the pop-up menus and entry fields to modify, add, or delete the criteria.

3 Click Find to see if the new criteria produce the records you want. 

4 Click Save.

Note:  To discard the changes you made to the criteria, click any other item in the 
Libraries pane.

Select the criteria.
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5 Using Form View

In Bento, you use form view to display one record at a 
time from a library or collection.

This chapter describes how to create and edit records in form view, create and modify 
forms, and customize form layouts.

About Forms 
In form view, you can create and use forms to display one record at a time from a 
library or collection in a page-like format. For example, you can display a contact in 
the Address Book library or a task in the iCal Tasks library.

With forms, you can see the fields for an individual record. You can create and use 
multiple forms, or pages, to display different information about that record. 

For a given library or collection, you can use any of its fields on any of its forms.

If you want to see more than one record at a time, or scan and sort your information 
quickly, use table view instead. See Chapter 6, “Using Table View.”

The same record displayed in another form 
view, using a different organization of fields

A record displayed in one form view
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Forms can also display records from other libraries or collections in related records list 
fields. For example, you can display a list of people who are attending an event on a 
form in the iCal Event library. See “Creating Related Records List Fields” on page 76.

Viewing a Form and a Table at the Same Time

You can view a selected record in form view and table view at the same time. Select 
the record, then choose View > Split View.

Creating Records in Form View
You can create records in either form view or table view. For table view instructions, 
see “Creating Records in Table View” on page 62.

To create a record for a library or collection:
1 Select the library or collection you want to add a record to.

2 Click a form name in the navigation bar or choose View > Form View > Form Name.

3 Choose Records > New Record.

4 Type data in the fields.

5 Press Tab to move to the next field in the same record. Press Shift-Tab to move to the 
previous field in the same record.

Tip:  To quickly create a record, Control-click in a blank area on the form and choose 
New Record from the pop-up menu.

Editing Records in Form View

To edit a record:
1 Select the library or collection that contains the record you want to edit.

2 Navigate to the desired record. 

Press Tab or Shift-Tab to move from field to field.

3 Click a form name in the navigation bar or choose View > Form View > Form Name.

4 Click the field you want to change, modify the data, then click outside the field or 
press Tab to save the change.
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Adding the Current Date and Time to a Field
When editing a record, you can add the current date and time to a date, time, or text 
field.

To add the current date and time to a field:
1 Click in the date, time, or text field.

2 Choose Insert > Current Date and Time. 

Duplicating Records in Form View

To quickly add a record with the same or similar data as an existing record: 
1 Navigate to the record you want to duplicate.

2 Choose Records > Duplicate Record.

Deleting Records in Form View

To permanently delete a selected record from a library: 
1 Select the library.

2 Click a form name in the navigation bar or choose View > Form View > Form Name.

3 Select the record.

4 Choose Records > Delete Record or press Command-Delete.

In the dialog, click Delete.

To remove a selected record from a collection: 
1 Select the collection.

2 Navigate to the record you want to remove.

3 Choose Records > Remove Record. 

If you click Remove from Collection, the record is removed only from the collection, 
not the library. If you click Delete, the record is permanently removed from both the 
library and the collection. 

Note:  if you delete a record from the Address Book library, the record is also deleted in 
the Address Book application. If you delete a record from the iCal Events or iCal Tasks 
library, the record is also deleted in the iCal application.

If the field type is You see the current

Date Date. Set the “Display Time” option to also display the time.

Time Time

Text Date and time
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Creating Forms

To create a form:
1 Select the library or collection you want to add a form to.

2 Click  in the navigation bar or choose Forms > New Form.

In the Form name dialog, type a name, then click OK.

3 Add fields to the blank form.

See “Adding Fields to a Form” on page 55.

4 Create records. 

See “Creating Records in Form View” on page 52.

Deleting Forms

To delete a form:
1 Select the library or collection you want to delete a form from.

2 Click  in the navigation bar or choose Forms > Delete Form.

If there is only one form, you can’t delete it.

Duplicating Forms

To duplicate a form:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Forms > Duplicate Form. 

Renaming Forms

To rename a form:
1 Double-click the form name at the top of the window.

2 In the Form name dialog, type a new name, then click OK.
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Adding Fields to a Form

To add a field to a form:
1 Select a library or collection.

2 Select a form in the navigation bar or choose View > Form View > Form Name.

3 Drag a field from the Fields pane to the desired location on the form.

To move a field, see “Moving Fields and Objects on Forms” on page 55. To resize a 
field, see “Resizing Fields and Objects” on page 56. To create a field, choose Insert > 
New Field. See “Creating Fields” on page 72.

Tabbing Between Fields

To tab between fields on a form:
1 Select a library or collection.

2 Select a form.

3 Click in a field, then press Tab to move from field to field, and within each column if 
you have added a column divider. Press Shift-Tab to move in the reverse direction.

Note:  To enable the Tab key to move to all controls, make sure “All controls” is 
selected in the Mac OS X Keyboard and Mouse preferences (Keyboard Shortcuts tab).

Moving Fields and Objects on Forms

To move one field or object:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Move your mouse near the field label or the edges of the field or object. When the 
cursor changes into a hand, click to select the field or object, then drag it to a new 
location.

Bento allows you to drag fields above, below, next to, or between other objects on 
the form.

To move multiple fields or objects:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Command-click or Shift-click to select multiple fields or objects. 

Tip:  To quickly select many fields and objects, click in an empty part of the form, and 
while holding down the mouse button, drag to select multiple items.
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Resizing Fields and Objects
Any field and any object can be resized.

To resize a field:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select the field or object. 

3 Move the cursor to one of the handles. When the cursor changes to a double arrow, 
drag to change the size.

Removing Fields from a Form

To remove a field from a form:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select the field, then press the Delete key or drag the field off the form. 

The data in the field is still in Bento even though the field is no longer displayed on 
the form.

Customizing Form Layouts
You can quickly change the appearance of a form.

Changing the Theme
You can change a form’s theme (the coordinated colors, layout, and text attributes) at 
any time. For example, you can use a light-colored theme for printing records. 

To change a form’s theme:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Forms > Choose Theme.

3 In the Theme Chooser, select a theme, then click OK. 

You see a ripple effect as the theme changes. If you don’t want the ripple effect, 
choose Bento > Preferences, then clear “Display animation.”

If you want to preview a theme before applying it to your form, click Try It.
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Resizing Column Widths
You can change the width of columns. Increase the width to accommodate wider 
fields or to increase the amount of blank space between columns.

To resize the width of a column:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Position the cursor over a column divider, then drag left or right.

To resize fields that touch a column’s right edge, hold down the Option key as you 
move the column divider.

Changing the Position and Size of Labels
You can change how the labels for fields are positioned on a form.

To change the position of labels adjacent to fields:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Forms > Labels.

3 Select Above or Beside.

To change the size of text in labels:
1 Choose Forms > Labels.

2 Select Small, Medium, or Large.

Changing the Size of Text
You can change the size of text that is displayed in fields.

To change the size of text in fields:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select the fields by clicking near the field labels.

Command-click or Shift-click to select multiple fields.

3 Choose Forms > Text Size.

4 Select a size from the list: Smallest, Small, Medium, Large, Largest.

Changing the Shading of Fields
You can change the level of shading that is displayed behind fields.

To change the shading of fields:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select the fields by clicking near the field labels.

Command-click or Shift-click to select multiple fields.

3 Choose Forms > Shading.

4 Select a level of shading: None, Light, or Dark.
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Aligning the Right Edges of Fields
You can align the rightmost edges of selected fields within a column.

To align the right edges of fields:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select the fields whose right edges you want to align within a column.

Command-click or Shift-click to select multiple fields.

Tip:  To quickly align the right edges of many fields, click in an empty part of the form, 
and while holding down the mouse button, drag to select multiple items.

3 Choose Forms > Align Right Edges.

Adding Text Boxes
Add a text box if you want text such as a heading on your form.

To add a text box:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Insert > Text Box.

An untitled box appears at the bottom of the last column.

3 Drag the text box to the desired location, double-click in the text box, and start typing.

Adding Horizontal Separators 
A horizontal separator is an object you can add to a form. Separators help organize 
forms by visually separating the items above and below the separator. The 
appearance of the horizontal separator is defined by the theme applied to the form. 
You can change the horizontal separator's width but not its height.

To add a horizontal separator:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Insert > Horizontal Separator.

3 Drag the horizontal separator to the desired location on the form.

Adding Column Dividers 
You can divide up space on a form with column dividers.

To add a column divider:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Insert > Column Divider.

3 Drag the column divider to the desired location on the form.
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Adding Spacers
Use a spacer to create a blank space between items on a form. For example, add a 
spacer to separate groups of fields. When editing the form, you can change the 
spacer's width, height, and shading. 

To add a spacer:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Insert > Spacer. 

3 Drag the spacer to the desired location on the form.

Drag the right or bottom edge of the spacer to change its width or height.

4 Choose Forms > Shading.

5 Select a level of shading.
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6 Using Table View 

In Bento, you use table view to display data in a 
spreadsheet-like format where rows represent records 
and columns represent fields.

This chapter describes how to create and modify records in table view, sort records, 
and rearrange, summarize, and display data in columns. 

About Table View
In table view, you can see your records in rows with the fields in columns (in a format 
similar to a spreadsheet).

To go to table view, choose View > Table View.

Table view gives you flexibility while working with your data. For example, you can:

1 see more than one record at a time

1 choose which fields are displayed as columns

1 sort records in ascending or descending order by using sort commands in the 
column header pop-up menu

1 duplicate one or more records

1 delete multiple records

1 select multiple records to drag to other collections within the same library

1 enter, select, copy, and paste values in one or more cells, in a spreadsheet-like 
manner

One record

One field
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1 summarize and display data

1 select and drag multiple records to create new collections within one library

In table view, you cannot see media fields or any of the list field types: address, email 
address, phone number, IM account, URL, related records list, file list, and message list. 
See “Working with Media Fields” on page 82 and “List Fields” on page 71.

Viewing a Table and Form at the Same Time
You can view a selected record in table view and form view at the same time. Select 
the record, then choose View > Split View. 

Setting Table View Text Size
You can change the size of text for displaying records in table view.

To change the size of text used in table view: 
1 Choose Bento > Preferences. 

2 For “Table View Text,” select Small or Large.

Selecting Records in Table View

To select one record in table view:
Click a row number. 

To select multiple records in table view:
Click a row number, then Shift-click the last row you want to include in the selection. 
Or Command-click individual rows to include in the selection.

Creating Records in Table View
You can create records in table view or form view.

To create a record for a library or collection: 
1 Select the library or collection you want to add a record to.

2 In table view, choose Records > New Record. Or click in the last empty row and start 
typing.

At the bottom of the window, the record count increases.

3 Type data in the columns.

If you type data in the last column, Bento creates a new field with the default name 
Field.

4 Press Tab to move to the next field in the same record. Press Shift-Tab to move to the 
previous field in the same record.
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To add existing records to another collection within the same library: 
Select the records, choose Edit > Add To, then choose a collection from the list. The 
selected records are added to the collection that you chose in the list.

Editing Records in Table View

To edit a record:
1 Select the library or collection that contains the record you want to edit.

2 Double-click a field (table cell). Press Tab to move to the next field in the same record. 
Press Shift-Tab to move to the previous field in the same record. 

Press Command-Return to insert a line break in a text field.

Copying and Pasting Data in Table View
You can copy and paste data between Bento records in the same or other libraries as 
well as between Bento and spreadsheet applications such as Numbers and Excel. 

To copy data: 
1 Do one of the following:

1 In Bento, select one or more rows of data by clicking the row number. To select 
adjacent rows, select one row, then hold down the Shift key as you select adjacent 
rows. To select nonadjacent rows, hold down the Command key as you select rows.

1 Drag a selected block of data from a spreadsheet application to Bento. 

Note:  In your spreadsheet application, you may need to switch rows of cells to 
columns or columns to rows before copying the data.

2 Choose Edit > Copy.

Bento copies the selected data to the Clipboard.

To paste data:
1 Click a cell.

2 Choose Edit > Paste.

Bento creates additional records and columns as necessary. 

Note:  When pasting into existing fields, Bento pastes as many values as possible. If the 
data being pasted can't be entered in a certain field type, that data is rejected.

To paste data into new columns:
1 Click a cell in the empty column after the last column of data.

2 Choose Edit > Paste.

Bento creates new text fields, and additional records as necessary. 



64 Chapter 6    Using Table View

 

Duplicating Records in Table View

To quickly add a record with the same or similar data as an existing record: 
1 Select the library or collection.

2 Select one or more records, then choose Records > Duplicate Record.

If you duplicated a record in a collection, the record is created in the parent library 
and displayed in the collection.

Deleting Records in Table View

To permanently delete selected records from a library: 
1 Select the library.

2 Select the records, then choose Records > Delete Selected Records or press 
Command-Delete.

In the dialog, click Delete.

To permanently delete selected records from a collection: 
1 Select the collection.

2 Select the records, then choose Records > Remove Selected Records or press 
Command-Delete.

In the dialog, if you click Delete, the records are permanently removed from both the 
library and the collection. If you click “Remove from Collection,” the records are 
removed only from the collection, not the library.

Sorting Records

To sort records: 
Click the pop-up menu in a column header, then choose Sort Ascending or Sort 
Descending.

If you want to sort two or more fields, sort by the least significant field first, followed 
by the more important field or fields. For example, to sort records by last name and 
first name, first sort by the First Name field, then by the Last Name field.
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Working with Fields and Columns in Table View

Creating Fields in Table View

To create a field in table view:
1 For blank libraries, the first field is automatically created with the default name New 

Field. 

2 Double-click the column header and type a new name for the field, then press Return.

3 Enter data in the field.

Bento creates a text field by default. You can change the field to another type. See 
“Changing the Field Type” on page 66. 

4 Press Tab to create another field, where you can continue typing in the same record.

5 Repeat steps 2-4 to create as many fields as you want.

Adding Fields in Table View

To add a field before or after a column:
1 Click  in a column header. 

2 Choose Add Field Before or Add Field After.

A new column is inserted before or after the current column with the default name 
Field.

3 Type a new name for the field.

Changing Options for a Field

To change field options:
1 Click  in a column header. 

2 Choose Edit Field.

3 Change the field name or set options.

Duplicating Fields

To duplicate a field:
1 Click  in a column header. 

2 Choose Duplicate Field.
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Changing the Field Type
You can change the type of some fields to another. For more information see 
“Changing an Existing Field from One Type to Another” on page 80. 

To change the field type:
1 Click  in a column header. 

2 Choose Change To, then select a field type from the list.

Showing and Hiding Columns
To hide columns: 

1 Click  in a column header. 

2 Choose Hide Field. 

To show or hide columns using the Fields pane: 
In the Fields pane, select a field’s checkbox to display the field in table view. Clear the 
checkbox to hide the field in table view. When you hide a field in table view, the field 
and its data are not deleted from the library or collection.

Tip:  To display more data, hide the Libraries and Fields pane. Choose View > Hide 
Libraries & Fields Pane.

Deleting Fields in Table View

To delete a field in table view:
1 Click  in a column header. 

2 Choose Delete Field.

3 In the dialog, click Delete. 

The fields and their data are permanently removed from the library.

Select 
checkboxes 

to display 
fields.
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Reordering Columns

To reorder a column: 
Drag the column header left or right to a new location.

Resizing Columns

To resize a column: 
Drag the edge of a column header to the width you want.

Filling Fields Automatically
Bento lets you use the content in one or more rows to automatically add or replace 
records below the selected fields.

To fill fields automatically:
1 Select one or more fields in one or more records.

2 Drag the fill handle to copy the fields’ values downward as far as you drag. 

Summarizing Column Data 
The summary row provides an easy way to perform basic operations on the values in 
a column and display the results. The summary row is located at the bottom of table 
view and at the bottom of related records list fields.

To show or hide the summary row, choose View > Show Summary Row or Hide 
Summary Row.

Drag header to 
reorder column.

Drag header edge to 
resize column.

Fill handle



68 Chapter 6    Using Table View

 

Depending on the field type, the following functions are available.

You can use the Count function on any type of field. You can use the Sum, Average, 
Maximum, and Minimum functions on fields of the following types: Number, 
Currency, Duration, Rating, Automatic Counter, and Calculation (when the result is 
number, currency, or duration). You can also use the Minimum and Maximum 
functions on Date and Time fields.

To calculate a summary for a column:
Click in the summary row of the selected column, then choose a function from the 
pop-up menu. The name of the function and the results are displayed in the summary 
row.

When you do a search or an Advanced Find, the summary is recalculated based on 
the records that are found. 

Name Purpose

Sum Calculates the total of the values in the selected field

Count Reports the number of items that have an entry in the selected field

Average Reports the average of the values in the selected field

Maximum Reports the highest value of the values in the selected field

Minimum Reports the lowest value of the values in the selected field

Choose Sum in the summary row to 
calculate the total of the amounts 
listed in the Budget column.



7

     69

7 Using Fields

Bento provides a wide variety of field types to store the 
kinds of information you use in your daily life.

In Bento, you can choose from many different field types to track things such as 
names, addresses, dates, times, prices, images, movies, songs, and lists of files. 

This chapter describes the purpose of the field types, how to create and modify fields, 
how to use the Fields pane, and work with file list fields, message list fields, and media 
fields.

About Fields
Each library contains a set of fields. Each field allows you to store a particular kind of 
data. In the record pictured below, there are several fields. The Project Name field 
contains text. The Start and End fields contain dates. The Status and Priority fields 
contain pop-up menus that allow you to make a choice from a list. The Budget field 
stores an amount of money. The Vendors field contains a list of vendors that worked 
on a particular project. The Phone Number field contains a phone number.

Once you have created a field, you can use it on multiple forms within the same 
library or collection.
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From address, email, IM account, phone number, and URL fields you can perform 
tasks such as sending an email message, getting directions to the address in the 
selected field, or displaying a phone number in large type. 

Field Types
These are the types of fields you can create in Bento: 

Table viewForm view

Text field
Fields

Date field

Currency field

Related records 
list field

Choice field

Display phone 
number in large 

type

Field Type Purpose

Text Store anything you type* 

Number Store numeric data**

Choice Create a pop-up menu in order to select an item from a list

Checkbox Provide an on-off type of choice

Media Store image, movie, and sound files

File list Store aliases to other files or folders that are on your computer

Message list Display emails, notes, and RSS articles from the Mac OS X Mail application

Related records list Store records from another library or collection that are related to the 
current record

Time Store a time of day, in hours, minutes, and seconds, AM or PM
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For a list of field types that you can import data into, see “Field Types Supported for 
Import” on page 93.

List Fields
When you create address, phone number, email address, URL, and IM account fields, 
Bento creates an associated list field that lets you store multiple addresses, phone 
numbers, and so on for one record. When you enter data in one of these field types, 
Bento displays the same data in the associated list field. 

Date Store a date and time value. Displays the date by default and can also 
display the time.

Duration Store an amount of time in weeks, days, hours, minutes, and seconds

Calculation Display the result of a specified calculation. Supported operators are 
addition, subtraction, multiplication, division, and concatenation (joining 
two or more words or sentences).

Currency Store an amount of money

Automatic counter Assign a higher number to each new record

Rating Set the rating value of an item by clicking stars in the field

Address Store all components of a single street address

Phone number Store a phone number, including the area code

Email address Store an email address

URL Store a website, FTP site, or AFP site address***

IM account Store an IM account and service name

Notes:
*Maximum text field size is approximately 2 GB.
**The largest number supported is 263.
***The URL field does not support URL values that contain Japanese 
characters. 

Field Type Purpose
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For example, if you create a phone number field named “Home Phone Number” in a 
library that does not yet contain a phone number field, Bento creates a list field 
named “Phone Number List.” If you then add other phone number fields to the same 
library, when you enter data in the phone number fields, Bento displays the data in 
the field named “Phone Number List.”

You can import and export values stored in regular fields (for example, “Home Phone 
Number” in the form shown above) but you can’t import or export values stored in list 
fields. You can see values stored in list fields in form view but not in table view.

Creating Fields 
Follow the steps below to create all types of fields, except calculation, file list, 
message list, and related records list fields. For more information about those field 
types, see “Creating Calculation Fields” on page 73, “Creating File List Fields” on 
page 74, “Creating Message List Fields” on page 75, and “Creating Related Records 
List Fields” on page 76.

To create fields: 
1 Choose Insert > New Field.

2 Choose a field type.

3 Name the field. 

The name must be unique within the library.

4 Set the options on the field, if any.

5 Click “Create and Continue” or press Command-Enter.

On Form 1, you enter data in 
phone number fields.

On Form 2, Bento displays the data in the 
phone number list field that you entered in 
the phone number fields.

Phone number list field
Phone 

number 
fields

Form 1 Form 2



Chapter 7    Using Fields 73

 

6 Repeat steps 2-5 to create additional fields.

7 Click Close.

The fields are added to the Fields pane. 

8 In the Fields pane, add or display fields.

Note:  In table view, you cannot see media fields or any of the list field types: address, 
email address, phone number, IM account, URL, related records list, file list, and 
message list.

After you have created a field, you can enter data into it, one record at a time.

Creating Calculation Fields

To create a calculation field: 
1 Choose Insert > New Field.

2 Choose Calculation.

3 Click Continue.

4 Name the field.

5 Build a formula for your calculation. 

To Do this in the Fields pane

Add a field to a form in form view or split view Drag  to the form.

Display a field as a column in table view or split view Select a field’s checkbox.

To add Do this

A reference to a 
field

In the Available Fields list, double-click a field name. 

A mathematical 
or text operator

Click an operator button or type an operator in the formula.

The current date Click Today to insert the current date.

The current time Click Now to insert the current time.

A pre-formatted 
value

Click Value, then select a value from the list. Replace the pre-formatted value with the 
value you want.
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Choose the correct data type for the result you want and set any other options.

6 Click Create.

The new field is added to the Fields pane.

Tip:  If you are unfamiliar with creating calculations, click Show Examples to see and 
experiment with examples of calculations. 

Creating File List Fields
Use a file list field to store a list of aliases to files or folders on your computer. Each 
alias contains a path to a specific file or folder in a specific location on your hard drive.

If you move or rename a file or folder that an alias refers to, the alias is broken. If you 
try to open the file or folder, you can navigate to it or remove the alias from the list.

You can quickly open files or applications that are stored in file list fields. For example, 
you could store a PDF file of a resume in the record for a prospective employee.

You can preview files that are stored in file list fields with Quick Look. See “Previewing 
Files with Quick Look” on page 82.

To create a file list field and add files to it: 
1 Choose Insert > New Field.

2 Choose File List.

3 Name the field.

4 Click Create, then Close.

The new field is added to the Fields pane.

5 In form view, drag the field to a form. 

See “Adding Fields to a Form” on page 55.

Note:  You can see file list fields in form view but not in table view.

This is what you see in 
the calculation field.

The formula for 
the calculation

Operator buttons
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6 In the bottom-left corner of the table for the file list field, click  or choose 
Insert > File. 

7 In the Open dialog, navigate to the file you want to include in the file list field, then 
click Select.

You can also drag files from the Finder to the file list field.

8 Click  or double-click an alias in the file list field to open the file.

Creating Message List Fields
Use a message list field to store aliases to Mac OS X Mail messages, notes, and RSS 
articles that are relevant to a specific record. For example, you can keep a log of 
correspondence linked to a project or event.

To create a message list field:
1 Choose Insert > New Field.

2 Choose Message List.

3 Name the field.

4 Click Create, then Close.

The new field is added to the Fields pane.

5 In form view, drag the field to a form. 

See “Adding Fields to a Form” on page 55.

Note:  You can see message list fields in form view but not in table view.

6 Add Mac OS X Mail items (messages, notes, and RSS articles) to the field.

See “Adding Mac OS X Mail Items to a Message List Field” on page 81.
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Creating Related Records List Fields
Use a related records list field to display records that are related to the current record 
you are viewing. These related records are from another library or collection. 

For example, if you created a Projects library to manage planning a holiday party and 
wanted to display certain vendors on a form, you could create a related records list 
field to display the vendor or vendors that you hired to supply party equipment. 
These records come from the Vendors collection under the Address Book library. If 
you add a new record in the related records list, the record is displayed there but is 
stored in the Vendors collection.

You can create a related records list by dragging a library or collection to a form, as 
illustrated above, or you can use menu commands, as outlined below.

You can see related records lists in form view but not in table view.

To create a related records list field: 
1 Select the library or collection you want to add related records to.

2 Choose Insert > New Field.

3 Choose Related Records List.

4 Name the field.

1. Drag the Vendors 
collection onto the 
Projects form.

2. Bento creates a new related records 
list field on the form.

3. Add the selected vendor to the related 
records list.
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5 Choose the data source from the list. 

Only one instance of the data source can be used for a given library.

The data source can be a library, collection, or Smart Collection. If you select a library, 
you can add any record from the library to the related records list field. If you select a 
collection, you can only add records from that collection to the related records list 
field. 

6 Click Create, then Close.

The new field is added to the Fields pane.

7 Drag the field to the form you want.

You see an empty related records list field with column headers.

8 Click  to display records from the data source you specified in step 5. 

If the data source is a Smart Collection,  is disabled, since you can’t add records to a 
Smart Collection.

9 Select the record you want to add, then drag it to the related records list or click Add 
to List.

10 Press Esc to close the library or collection window.

1 To remove a record from the related records list, click . This removes the record 
from the related records list only. The record still remains in the data source (the 
library or collection) that the related records list is based on. 

Related records list field

Column headers
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1 If you delete a library or collection that a related records list is based on, the related 
records list field is also deleted.

1 If a record that appears in a related records list is deleted in its data source, the 
record is also deleted from any other related records list it appears in.

Using the Address Book or iCal Library as a Data Source 
You can create related records lists that display records from the Bento Address Book 
library or an Address Book collection. If you add Address Book records to the related 
records list and make changes to the records, you are actually updating the data in 
the Address Book application. 

If you delete a contact record from the Address Book application, it is removed from 
any related records list where it appeared in Bento. 

You can create related records lists that display records from the Bento iCal Events 
and iCal Tasks libraries. If you change an iCal Event or iCal Task record in a related 
records list, you are actually updating the data in the iCal application. 

If you delete an event or task record from the iCal application, it is removed from any 
related records list where it appeared in Bento. 

Navigating to Related Records
You can view the details of a specific record stored in a related records list, and you 
can quickly navigate among records stored in different related records lists.

To navigate among related records:
1 Click a record in a related records list field.

2 Click  to go to the record in its library or collection and view the record’s details.

You can edit the record you are viewing.

3 As you navigate among records in different related records lists, you can quickly 
return to the previously viewed related record by clicking .

However, once you select an item in the Libraries pane, Bento stops keeping track of 
the related records you viewed and  disappears. 
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Using the Fields Pane
The Fields pane displays an alphabetical list of the fields that are available for the 
selected library or collection. Use the Fields pane to select the fields that you want to 
add to the current form (in form view) or to display as columns (in table view). In split 
view, the Fields pane indicates the fields that can be added to the current form or can 
be displayed in table view. 

In the Fields pane you can:

1 create a field by clicking 

1 drag a field with  to a form

1 select a field’s checkbox to display the field in table view

1 double-click field names to modify names and settings. Some fields are locked . 
You can’t modify their names or settings because they are shared with Address 
Book and iCal or are reserved by Bento.

1 duplicate a field by clicking  and choosing Duplicate

1 delete a field and its data by clicking . When you delete a field, it is deleted from 
the library and from collections and related records list fields that use it. You can’t 
delete fields that are used for displaying data from Address Book and iCal, locked 
fields, address subfields (for example, street, city, and country fields), and the Date 
Created and Date Modified fields.

Field has not been 
added to the 
current form.

Field has been 
added to the 
current form.

Field is 
displayed in 

table view.

Field is not 
displayed in 

table view.

List field has no 
checkbox 

because it can’t 
be displayed in 

table view.

In table view In form view

Address subfields 
can’t be added to 
the form 
individually.
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Note:  In the Fields pane in table view, there is no checkbox next to media fields or 
any of the list field types (address, email address, phone number, IM account, URL, 
related records list, file list, and message list) because these fields can’t be displayed 
in table view.

Changing an Existing Field from One Type to Another
You can change the type of some fields to another. See the table below.

To change an existing field from one type to another:
1 Select a column name in table view.

2 Click .

3 Choose Change To, then select a field type from the list. 

Working with List Fields
Each type of list field has a pop-up menu from which you can quickly perform actions 
such as displaying the selected phone number in large type, getting directions to or 
from the selected address, and displaying a map for the selected address.

Sending Emails
In form view, you can quickly send emails to your family, friends, or colleagues. 

To send an email:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Click  next to the email address field. 

If you see , the email address is not valid. 

Convert 
from:

Convert to: 
 
         Text Number Choice Checkbox Time Date Duration Currency Rating Phone

Other list 
fields

Text 1 1 1 1 1 1 1 1 1 1 

Number 1 1 1 1 1 1 

Choice 1 1 1 1 1 1 1 1 1 1 

Checkbox 1 1 1 

Time 1 1 

Date 1 1 

Duration 1 1 

Currency 1 1 1 

Rating 1 1 1 
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3 The default email application opens and displays a blank email message addressed to 
the name in the email address field. 

4 Compose the message and send it.

Adding Mac OS X Mail Items to a Message List Field
In message list fields, you can store aliases to Mac OS X Mail messages, notes, and RSS 
articles that are relevant to a specific record. For instructions on creating message list 
fields, see “Creating Message List Fields” on page 75.

To add a Mac OS X Mail message, note or RSS article to a message list field:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 In the bottom-left corner of the message list field, click  to open the Mac OS X Mail 
application.

3 In Mac OS X Mail, select a folder that contains messages, notes, or RSS articles.

4 Drag one or more items to the message list field.

Tip:  Click  to show the fields for the message list field in the Fields pane.

To open the items in Mac OS X Mail, see “Opening Files Stored in File List Fields and 
Message List Fields” below.

Opening Files Stored in File List Fields and Message List Fields
When browsing records, you can quickly open files or applications stored in file list 
fields, and Mac OS X Mail messages, notes, and RSS articles stored in message list 
fields.

To open files stored in a file list field or message list field:
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select one or more items in the file list field or message list field.

3 Click  or double-click the items you want to open.

4 The application associated with each item starts and displays the contents of the 
items.

For example, if you double-click a PDF file and a QuickTime movie file, the Mac OS X 
Preview and QuickTime Player applications start and display the PDF file and the 
QuickTime movie file. If you double-click an email message, note, or RSS article, the 
Mac OS X Mail application starts and displays the Mac OS X Mail item.
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Previewing Files with Quick Look
With Quick Look, you can quickly view the contents of an item in a file list field or 
message list field without opening it. 

To preview a file: 
1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select one or more items in a file list field or message list field.

3 Click  or press the Space bar.

The content you see depends on the type of file. If it’s an image, you’ll see a smaller 
version of it. If it’s a text document, you can read the text and scroll to see more. Use 
the buttons along the bottom of the window to move from one item to the next.

Working with Media Fields
You can add many types of sound, image, and movie files to a media field, including 
JPEG, QuickTime, and MP3 files.

If you add a sound file that you purchased from the iTunes Store, you may have to 
enter the account name and password for the account that was used to purchase the 
sound file.

Note:  You can’t add movie files that you purchased from the iTunes Store.

Taking Photos
If your computer has an internal or external iSight camera, you can take pictures with 
it to use in your forms.

To take a photo:
1 Click an empty media field. 

For information about how to create a media field, see “Creating Fields” on page 72.

2 Click .

3 In the window, click  , then wait for the image to appear.

4 Optional: Click , then select a special effect to apply to the photo. 

5 Click Set to save and load the image into the media field. 

Tip:  To back up a photo, export it. For more information, see “Exporting Images” on 
page 84.
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Adding Media Files
You can add sound, image, and movie files to media fields in each record. Image files 
include images from the web or other applications. 

To add a media file:
1 Click in the media field.

2 Drag a media file from the Finder, iPhoto, or iTunes to the media field or click  to 
choose a file. 

Except for iTunes files, when you add a media file, Bento copies it into the 
bento.bentodb file. When you add an iTunes file to a media field, Bento creates an 
alias to the file.

If you don’t want to copy the media file into Bento, hold down the Option key after 
you start dragging the media file to the media field. An arrow  appears on the 
thumbnail. Bento creates an alias that contains a path to a specific file in a specific 
location on your hard drive. If you use an alias for the media file, and then move or 
rename the original media file, the alias to it is broken. 

3 In the Open dialog, select the image you want to add, then click Open.

Playing a Movie or Sound File
Playing a movie or sound file in Bento is similar to how you play a movie or sound file 
in QuickTime Player.

To play a movie or sound file: 
1 Click in the media field.

2 Click  in the playbar.

Drag the slider up or down to adjust the volume.

3 To stop playing the movie or sound file, click  again. To pause the movie or sound 
file, click .

Positioning Images 
You can move an image in any direction within a media field. 

To position an image:
1 Click in the media field. 

2 Drag the image within the field.

If you drag the image out of view, click  to bring it back into view.
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Resizing Images
You can resize an image within the media field or make it exactly fit the field. 

To resize an image:
1 Click in the media field.

2 Drag the zoom slider to zoom in or out on the image.

 

3 Click  to make the image the same size as the field.

Exporting Images
You can export (save) any image file with a different name or in a different location. It 
is saved in its original file format.

To export an image:
1 Click in the media field.

2 Click . 

3 In the Save As dialog, navigate to the folder where you want to save the image file.

4 Type a name, then click Save.

Deleting Media Files
When you delete a media file from a record, it is permanently deleted from its library 
and from any collections within the same library. 

To delete content in a media field:
1 Click in the media field.

2 Press the Delete key or choose Edit > Clear.
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8 Importing, Exporting, and Printing 

This chapter describes the various ways you can import 
and export information so others can view or use it. You 
can also print information to share it with others. 

A good way to start using Bento is by importing information. Bento supports 
importing information in a variety of file formats: comma-separated values (CSV) file, 
tab-separated values (TAB) file, Numbers, Excel, Excel 2008, and library template. For 
example, you can import CSV files created from spreadsheets, exported from other 
databases, or downloaded from banking or stock websites.

If you need to share your information, you can export your Bento information as a 
CSV, TAB, Numbers, Excel 2008, or library template file. You can export records from a 
library or from a collection. You can also export a group of records from search or 
Advanced Find. If you create a library with forms that you want to give to another 
Bento user, you can export the library as a library template file. 

Bento lets you print information from form view, table view, split view, and from 
search and Advanced Find. 

About Comma-Separated and Tab-Separated Files
A comma-separated values file (CSV) or a tab-separated values file (TAB) is a file that 
represents a table of data. Each column/field value is separated by a comma or a 
semicolon (for CSV) or a tab character (for TAB). One record appears in each row of the 
data file. Often, the first row of data in the CSV file represents the column names for 
the table. 

Note:  Some locales may use a different separator in CSV files rather than commas. The 
default separator is defined by your locale setting. 
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Exporting CSV and TAB Files from Other Applications 
For the best results when importing information into Bento, follow these guidelines: 

1 Export your data from the other application as a CSV or TAB file. 

1 If your Excel worksheet contains multiple tables, put each table in its own 
worksheet, and make sure the column names are in the first row.

1 Note whether your CSV or TAB file contains a row with the column names. Bento 
can use the values in that row as field names when you import the information into 
a new library. In Bento, these field names appear as labels in form view and as 
column names in table view. 

1 Make a note of the order of the fields in the CSV or TAB file. If the file doesn’t 
contain a row with the column names, you can refer to your notes to manually 
name the fields when you import the file. 

1 ClarisWorks and AppleWorks create tab-separated files when you select the ASCII 
Text option in the Save As dialog. Make sure you add the TAB extension to the 
filename when you save an AppleWorks 6 file that you plan to import into Bento. 
For example, if you have an AppleWorks file named “MyData” save it as 
“MyData.tab” so that Bento recognizes it as a tab-separated file.

Correcting CSV Files 
If you are having difficulty importing a CSV file, open it in a text editor and do the 
following:

1 Put double quotation marks around field values that have embedded commas. 

For example: “10,000 Donors“

1 Put double quotation marks around field values with leading or trailing spaces.

1 Put double quotation marks around field values that contain embedded line-
breaks. 
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1 Put double quotation marks around field values that contain double quotation 
marks. Change the embedded double quotation marks into a pair of consecutive 
double quotation marks. 

For example: “She said ““I will be there”” in her email.“

Example of a comma separated (CSV) file
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Importing Information into Bento
When you import information into Bento, you can either create a library or import the 
information into an existing library or collection. 

Creating a Library by Importing 
If the information you are importing does not belong in an existing library, then 
create a library when you import the file.

Click the pop-up to set 
the field type. If you don’t 
want to create the field, 
choose “Do not create.” 

Enter the name for the 
new library. 

Use the arrows to go to 
the row that contains 
column names, then 
select “Use this record’s 
values as column names.” 

Choose a file. The 
options you see here 
vary according to the file 
format of the selected 
file.



Chapter 8    Importing, Exporting, and Printing 89

 

To create a library by importing: 
1 Choose File > Import > File. 

2 Click Choose, then select the file you want to import in one of the following file 
formats: .csv, .tab, .tsv, .numbers, .xls, .xlsx. 

1 For .csv, .tab, or .tsv files, click “Choose the format,” then choose Comma separated, 
Semicolon separated, or Tab separated.

1 For Numbers files, use the pop-up menus to select a sheet, then a table.

1 For Excel files, use the pop-up menu to select a worksheet.

3 For “Choose a target,” choose New Library, and enter a unique name for the library. 

4 Indicate whether the file contains a row with values that you want to use as field 
names. 

1 If the file contains a row with column names, click the arrow buttons to go to that 
row and select “Use this record’s values as column names.” 

Bento uses the values in this row as the new field names. 

1 If the file does not contain a row with column names, clear “Use this record’s values 
as column names.” 

Bento assigns default names to each new field. To change a default field name, 
double-click the field name and type a unique name. 

5 Bento sets the field types to “Text” by default. To change a field’s type, click the pop-
up menu and select a new field type. 

1 If there is a column that you do not want to import, click the pop-up menu and 
select “Do not create.“

1 For information on the field types supported for import, see “Field Types Supported 
for Import” on page 93. 

6 Click Import. 

When the import is done, Bento displays the records, which you can view in table 
view, form view, or split view. 
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Importing into an Existing Library 
If you want the information that you are importing to go into an existing library, 
import the file into that library. Bento creates new records in the library. 

You can also import a file into a collection. When you choose a collection as the target 
for the import, Bento creates new records in the library that contains that collection, 
and adds the new records to the collection. 

To import information into an existing library or collection: 
1 Choose File > Import > File. 

Click the pop-up and 
select a field name to 
manually map the fields 
set to “Do not import.” 

Use the arrows to go to 
the row that contains 
column names, then 
select “Use this record’s 
values as column names.”

Choose a file. The options 
you see here vary 
according to the file 
format of the selected file.
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2 Click Choose and choose the file you want to import in one of the following file 
formats: .csv, .tab, .tsv, .numbers, .xls, .xlsx. 

1 For CSV or TSV files, click “Choose the format,” then choose Comma separated, 
Semicolon separated, or Tab separated. 

1 For Numbers files, use the pop-up menus to select a sheet, then a table.

1 For Excel files, use the pop-up menu to select a worksheet.

3 For “Choose a target,” choose the library or collection that you want your information 
to be added to. 

The example above shows the “Address Book” library as a target library. 

4 Indicate whether the file contains a row with values that you want to use as column 
names. 

1 If the file contains a row with column names, click the arrow buttons to go to that 
row and select “Use this record’s values as column names.” 

Bento reads the column names in the file, and attempts to match them to the field 
names already defined in the library or collection you have selected. Bento maps 
the column names to field names when their names match exactly. For any names 
that do not match, Bento sets the field name to “Do not import” and you need to 
map the fields to the columns manually. You can also manually map the record 
values that Bento has matched. 

1 If the file does not contain a row with column names, clear “Use this record’s values 
as column names.” 

Without column names, Bento has no way to map the record values to the column 
names. Bento sets the column names to “Do not import” and you need to map the 
fields to the columns manually. 

5 If the new field’s name matches a column name in the file, Bento maps that column’s 
records values to the new field. Otherwise, you can map your column values to the 
new field manually.

For record values that are set to “Do not import,” click the pop-up menu and select 
the column name or record value to manually map it to the adjacent field name. 

6 If there is no field that you can map a given field to, you can create a field. To do this, 
click Add Field. Bento opens the Create a Field dialog to allow you to add a field to the 
library. 

7 (Optional) See how the record values are mapped to the field names by clicking the 
arrow buttons to move through the record contents. 

8 Click Import. 

When the import is done, Bento displays the records, which you can view in table 
view, form view, or split view. 
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Importing a Library Template
A library template file contains all of the forms, collections, Smart Collections, table 
view settings, and related libraries (if any) of an exported library, but no records.

To import a library template: 
1 Choose File > Import > Template.

2 Click Choose and choose a library template file.

3 Click Open.

4 Bento adds the library, collections, and Smart Collections contained in the library 
template file to the Libraries pane. If the library template file contains multiple 
libraries, all of them are added to the Libraries pane except for the default libraries 
(Address Book, iCal Events, and iCal Tasks). For the default libraries, any fields that had 
been added are imported.

Additional Ways to Import Information 
In addition to the File > Import menu items, Bento provides the following ways to 
import information: 

1 Choose File > New Blank Library to open the New Library dialog. Then click “Import 
data.” 

1 Drag a library template file or data file (Text, Numbers, Excel format) to the Libraries 
pane in Bento. 

1 Drag a library template file or data file (Text, Numbers, Excel format) to a specific 
library or collection in the Libraries pane in Bento. 

1 Drag a library template file or data file (Text, Numbers, Excel format) to the Bento 
application icon. 

Choose a library 
template file. 
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Field Types Supported for Import 
You can import into these field types: text, choice, checkbox, number, rating, 
currency, time, date, duration, address, phone number, email address, URL, and IM 
account.  

You cannot import into these field types: file list, media, automatic counter, 
calculation, related records list, or message list. 

For this field type This data can be imported 

text 
choice 
address 
phone number 
IM account 

Any text 

email address Any text, but a valid email address must include the @ character. 

URL Any text, but the URL field does not support URL values that contain 
Japanese characters. 

checkbox “1” for checked; “0” for not checked 
“True” for checked; “False” for not checked 
“Yes” for checked; “No” for not checked

number 
currency 

Numeric data 

rating A number between 0 and 10 

time  Numeric data in the form HH, HH:MM, or HH:MM:SS, optionally with 
“AM” or “PM” where: 
1 HH represents the hour (between 0 and 24, if you don’t use “AM” or 

“PM”, or between 0 and 12 if you use “AM” or “PM”)
1 MM is minutes (between 0 and 59)
1 SS is seconds (between 0 and 59).
For example: 12:59:59 PM 

date  Numeric data in the form DD, MM/DD, or MM/DD/YYYY, where: 
1 DD is the day (between 1 and 31, as valid for the month)
1 MM is the month (between 1 and 12)
1 YYYY is the year (between 1 and 9999).
A date field can also contain a “time” value, as described for the time 
field. 
Note: These formats vary depending on the current system date settings.

duration Text representing a duration in weeks, days, hours, minutes, and seconds. 
The text may use the following abbreviations: 
1 w for weeks 
1 d for days 
1 h for hours 
1 m for minutes 
1 s for seconds 
For example, the following are all valid duration text: 
1 8 days, 5 hours 
1 8d,5h 
1 8d5h 
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When you import into an address, phone number, email, URL, or IM account field, the 
data is automatically added to the associated address list, phone number list, email 
address list, URL list or IM account list field. 

See Chapter 7, “Using Fields,” on page 69 for additional information on field types. 

Note:  The message “Some values in some records can’t be imported” in the Import 
dialog means that one or more record values are not valid for the type of field to 
which you are importing the values. For example, you cannot import alphabetic text 
into a number field or into a date field. You can either change the field type to match 
the data, or proceed with import. If you proceed with import, the invalid values will 
not be imported. Other options are to change the contents of the file or to import the 
data into a Text field. Text fields accept all values.

Exporting Information from Bento
Bento can export information into a CSV, TAB, Numbers, or Excel 2008 file from a 
library, from a collection, from a Smart Collection, or from the results of a search or 
Advanced Find. 

Bento can export a library into a library template file. This is a good way to preserve 
the structure of an individual library or give a library to another Bento user. A library 
template file contains all of the forms, collections, Smart Collections, table view 
settings, and related libraries (if any) of an exported library, but no records. You can 
give the library template file to other Bento users or import it later.

Exporting from a Library, Collection, or Smart Collection 
When you export records from a library or collection, you can choose to export all the 
values from all of the fields in table view or only those fields that are currently 
displayed in table view.

To export from a library, collection, or Smart Collection: 
1 Select the library, collection, or Smart Collection that contains the information you 

want to export. 

2 Choose File > Export.

3 Click Numbers, Excel, Text, or Template. 

To export a file compatible with versions of Excel earlier than Excel 2008, export a Text 
file.

1 For Numbers, Excel, or Text, choose “All records” or “Only current records.” 

1 For Template, choose the related libraries you want to include (if any).
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4 Choose how to export the data. 

1 For Numbers, Excel, or Text, choose “All table view fields” or “Only fields displayed in 
table view.” 

1 For Text, choose Comma separated (.csv), Semicolon separated (.csv), or Tab 
separated (.tab).

5 Click Next, then specify the filename and location for the file. 

Bento exports the table view field data from the library, collection, or Smart 
Collection into a file with the name you specify. 

Exporting from Search or Advanced Find 
If you want to export a subset of records, you can use search or Advanced Find to 
narrow the set of records in a library or collection, and then export the records. 

To export from a subset of records: 
1 Use the search field or Advanced Find to create a subset of records. 

See “Search Field and Advanced Find” on page 28. 

1 For search, the set of records that matches the criteria is displayed as you type the 
search string. 

1 For Advanced Find, click Find to display the set of records that matches the criteria. 

2 Follow steps 2-5 in “Exporting from a Library, Collection, or Smart Collection” on 
page 94.

Bento exports the table view field data from the subset of records into a file with the 
name you specify. 

You can include 
related libraries that 
are contained within 
another library.
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Additional Ways to Export Information 
In addition to the File > Export menu item, Bento provides another way to export 
information as a file: 

1 Drag a library or a collection icon from the Libraries pane in Bento to the desktop or 
to any folder in a Finder window. Bento exports the field data from all the records in 
the library or the collection into a file with a name matching the library or collection 
name and the file format matching the current Export Format setting in the 
Preferences dialog.

Export Considerations for Specific Field Types 
You cannot export: 

1 Contents of address list fields, phone number list fields, email list fields, URL list 
fields, IM account list fields, or message list fields. However, you can export data 
from individual address, phone number, email, URL and IM account fields that are 
displayed in table view.

1 Information displayed in a related records list field. 

1 File aliases in file list fields. 

1 Movie and sound files you have added to media fields. To export images, see 
“Exporting Images” on page 84.

For files that you 
export by dragging 
them to the Finder, 
select a file format.
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Printing Information 
You can print information from a library, from a collection, or from the results of a 
search or Advanced Find. 

Printing from Libraries and Collections
When you print records from a library or a collection, the selected view determines 
the appearance of the printed output. In split view, the location of the cursor at the 
time of printing determines the appearance of the printed records.

To print records from a library or collection: 
1 Select the library or collection that contains the information you want to print. 

2 Select the form or table view that contains the fields you want to print. 

3 Choose File > Print. 

4 Specify options for the printed output. 

1 Select “Selected records only” to print the currently viewed record only (in form 
view) or to print all selected records (in table view). 

1 Select “All displayed records” to print all of the records in the currently viewed 
library or collection. 

1 Select “Don’t print background” to print without the background in form view or 
without the alternating row colors in table view. This option prints in black and 
white without any background color and saves ink.

1 When printing table view data, select “Fit to width” to scale the columns to fit on 
one page. 

1 When printing form view data, select “Print one record per page” to print one 
record per page.

1 Select additional options to include the title banner, page numbers, date, and time. 

Printing from Search or Advanced Find 
If you want to print a subset of records, you can use search or Advanced Find to 
narrow the set of records in a library or collection, and then print the records. 

To print a subset of records: 
1 Use the search field or Advanced Find to create a subset of records. 

See “Search Field and Advanced Find” on page 28. 

1 For search, the set of records that matches the criteria is displayed as you type the 
search string. 

1 For Advanced Find, click Find to display the set of records that matches the criteria. 

2 Choose File > Print. 
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3 Specify which records in the subset to print. 

1 Select “Selected records only” to print the currently viewed record only (in form 
view) or to print all selected records (in table view). 

1 Select “All displayed records” to print all of the records in the current subset. 

Printing Mailing Labels 
When you use the Bento Address Book library, your contact records update the data 
in the Address Book application. 

To print address labels: 
1 Open the Address Book application. 

2 In the Address Book application, select All or a group in the Group column, or select 
specific contacts that you want to print. 

Command-click or Shift-click to select multiple contacts.

3 Choose File > Print. 

4 Choose Mailing Labels from the Style pop-up menu, then set the print options. 

1 Layout tab: Choose a type of label from the Page pop-up menus. Select “Define 
Custom” to set the page margins and gutter space between labels, and to specify 
how many labels to print on a page. 

1 Label tab: Choose which addresses to use from the Addresses pop-up menu. 
Choose the order in which to print the labels using the “Print in” pop-up menu. Add 
a small graphic to the labels by clicking the Image Set button. Change the font by 
clicking the Font Set button. 

For more information, see the Address Book Help. 
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9 Backing Up and Restoring 
Information 

This chapter describes how to create a backup copy of 
your Bento data. Use the backup copy to recover your 
original information if you make an inadvertent change, 
or to revert your data in case of a problem such as a hard 
drive failure. 

A Bento backup file contains the data in Bento at the time you run the back up 
command. The back up command is easy to use; you simply specify a name and 
location for the backup file. Revert is just as easy to use; you select the backup file 
from which you want to restore data. 

Because it’s a good idea to regularly back up your data, Bento provides an optional 
reminder to periodically back up your data. 

Note:  Backup and revert features apply to all of your data in Bento. If you want to save 
the data from an individual library or collection, use the export feature described in 
“Exporting Information from Bento” on page 94. 

You can also use the Mac OS X application technology called Time Machine to back 
up and restore your Bento data. 

Tip:  To save a copy of your backup file, copy it to another location, such as an external 
hard disk or a CD. 
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About Bento Backup Files 
When you create a Bento backup file, you create a copy of the data that is in Bento. 
The backup file contains the data in your libraries and collections at the time you run 
the back up command. 

Important:  The Bento backup file does not contain the data from the Address Book 
and iCal applications. You should back up your Address Book and iCal data whenever 
you back up your Bento data. 

1 To create a backup of the data in the Address Book application, use the Address 
Book application’s archive feature. 

1 To create a backup of the data in the iCal application, use the iCal application’s 
backup feature. 

However, if you add fields to the records in the Address Book library, the iCal Events 
library, or the iCal Task library, then the data in those additional fields is included in 
the Bento backup file. 

How Field Types Are Backed Up 
Consider the following when you back up file list fields, media fields, or related 
records list fields. 

For Bento backs up 

File list fields The listed filenames and locations, but not the contents of the files. 

Media fields The contents of the fields (for most media fields) because Bento stores copies of the 
media files. 
However, if you use aliases to media files rather than copying the media files into 
bento.bentodb, Bento backs up the filenames and locations of the files that are added 
to media fields, but not the contents of the files. You should back up these media files 
to a location in the Finder. 

Related records 
list fields

The data shown in related records lists, because these fields show data from libraries 
and collections. 
However, Bento does not back up the data from the Address Book, iCal Events, and 
iCal Tasks libraries. If you use related records lists that reference those libraries, then 
the data is dependent on what is available in the Address Book and iCal applications. 
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Using the Back Up Reminder 
By default, Bento reminds you to create a backup file once a week.

To create a Bento backup file from the back up reminder dialog: 
1 Click Back Up. 

2 In the dialog that appears, use the default name and location or type a name and 
location for the backup file. 

Changing the Back Up Reminder 
You can change the default back up reminder frequency or turn off the back up 
reminder.

To turn on the back up reminder or to change the reminder frequency: 
1 Choose Bento > Preferences. 

2 Select “Display a reminder to back up” and set the frequency for how often you want 
to see a reminder to back up your data. You can get a reminder to back up your data 
either every week or every month. 

To turn off the back up reminder: 
1 Choose Bento > Preferences. 

2 Clear “Display a reminder to back up.” 
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Creating a Backup File
When you create a Bento backup file, you create a copy of the data that is in Bento. It’s 
a good idea to back up your Bento data before you make extensive changes, such as 
importing data, deleting libraries, or significantly changing forms.

To create a backup file: 
1 Choose File > Back Up Bento Data. 

2 Use the default name and location or type a name and location for the backup file. 

3 Click Save. 

4 (Optional) If you display Address Book and iCal application data in Bento, you should 
back up the data in those applications next. The Bento backup file does not include 
data from those applications. 

Reverting from a Backup File 
When you revert data from a Bento backup file, you replace the data that is in Bento 
with the contents of the Bento backup file. Any additions you have made in Bento 
since you created the backup file are lost. Any deleted records are recovered. 

To revert data from a backup file: 
1 (Optional) If you display Address Book and iCal application data in Bento, you should 

restore the data from those applications’ archive (Address Book) or backup (iCal) files 
first. The Bento backup file does not include data from those applications. 

2 Choose File > Revert to Bento Backup and locate the backup file. 

3 Click Open. 

4 When Bento displays a confirmation dialog, click Continue. Bento loads the contents 
of the Bento backup file. 
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Using Time Machine with Bento 
Time Machine is the Mac OS X application that backs up your computer (including 
Bento data) on a regular basis. You can use Time Machine to restore the Bento data 
from a specific backup date and time. 

When you restore data from a Time Machine backup, you replace all of the data that is 
in Bento with the contents of the backup file. 

To set up the Time Machine options: 
1 Choose Apple menu > System Preferences, and then click Time Machine. 

2 In the Time Machine preferences, slide the switch to ON and choose a backup disk.

3 Verify that the user's Library folder is backed up by Time Machine. (By default, Time 
Machine backs up your entire hard drive.)

To restore Bento data using Time Machine: 
1 Quit Bento.

2 (Optional) If you display Address Book and iCal application data in Bento, restore the 
data from those applications’ backup files first. The Bento backup file does not 
include data from those applications. 

3 Open a Finder window to the user’s Library folder for Bento: 

Library/Application Support/Bento/ 

4 Open Time Machine from the Dock or the Applications folder. 

5 Use the arrows or the timeline along the right side of your screen to browse through 
all the backups that Time Machine has created. 

6 When you find the date for the data you want to restore, select the file bento.bentodb 
and then click Restore. 

7 Click Replace in the confirmation dialog.

The restored bento.bentodb file is copied to Library/Application Support/Bento/, 
replacing all of the data that is in Bento. 

8 Open Bento. Bento loads the contents of the restored bento.bentodb file. 
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10 Using Bento with Bento for iPhone 
and iPod touch

This chapter describes how to sync Bento with Bento for 
iPhone.

Bento for iPhone is a personal database application that allows you to create libraries, 
collections, records, and fields on iPhone or iPod touch. 

What you need:

1 Bento 2.0v4

1 Bento for iPhone

Syncing Information Between Bento and Bento for 
iPhone
Syncing allows you to share information between your computer and your mobile 
device. For example, if you add information to a library in Bento for iPhone, you can 
sync to add that information to Bento on your computer. 

Connecting Bento for iPhone to Bento
Bento for iPhone can sync with Bento when both applications are open and 
connected to the same Wi-Fi network, including a computer-to-computer network. 
See Mac OS X Help for information about computer-to-computer networks.

To connect both applications to the same Wi-Fi network:

1 From the Home screen in your mobile device, tap Settings, then select a Wi-Fi 
network.

2 On your Mac, choose Apple > System Preferences > Network.

3 In the left side of the Network pane, click AirPort.

4 For Network Name, select the same Wi-Fi network that you connected Bento for 
iPhone to.

5 Click Turn Airport On.

6 Click Apply, then close the Network pane.
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Syncing for the First Time
After you have connected Bento for iPhone and Bento to the same Wi-Fi network, you 
can sync the applications. 

Before syncing, back up your Bento data. For more information, see Chapter 9, 
“Backing Up and Restoring Information,” on page 99.

To sync for the first time:
1 Start Bento for iPhone, then tap .

2 In the Sync screen, tap “Set up sync with computer.”

A four-digit passcode appears.

Note:  If your mobile device is not connected to a Wi-Fi network, an alert appears. To 
connect to a Wi-Fi network, see “Connecting Bento for iPhone to Bento” on 
page 105.

3 Start Bento, then choose File > Set Up Sync with Device.

4 Select your mobile device, then click Continue.

5 In the Connect pane, enter the passcode.

6 In the Success pane, click Done.

Syncing
After syncing for the first time, you can add, edit, or delete data in either application, 
then sync the applications. When you sync, changes appear in both applications. 

Bento for iPhone can sync with Bento when both applications are open and 
connected to the same Wi-Fi network. For more information, see “Connecting Bento 
for iPhone to Bento” on page 105.

To sync the applications:
1 In Bento for iPhone, tap . 

2 (Optional) In Bento, in the Devices section of the Libraries pane, select your mobile 
device, then select the libraries you want to sync with.

Note:  By default, all libraries are synced. The iCal Events and iCal Tasks libraries are 
not supported in Bento for iPhone.

3 In Bento for iPhone, tap Sync Now.
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Troubleshooting Syncing
This section describes some common issues with syncing information between Bento 
and Bento for iPhone. For more information on syncing iPhone or iPod touch, see the 
iPhone user’s guide, the iPod touch user’s guide, or the Apple support website.

1 Can I sync more than one mobile device with Bento?

No. Bento can only sync with one mobile device. If you sync a second mobile device 
to Bento, the first device disconnects. To prevent data loss, avoid connecting to 
additional devices.

1 Can I sync more than one Bento desktop with a mobile device?

No. A mobile device can only sync with one Bento desktop. If you sync a second 
Bento desktop to your mobile device, the first desktop disconnects. To prevent data 
loss, avoid connecting to additional desktops.

1 Why weren’t all of my files synced?

Files that are larger than 10 megabytes or that cannot be opened or played on your 
mobile device cannot be synced.

1 What if Bento for iPhone is interrupted while syncing?

If Bento for iPhone is interrupted while syncing (for instance, by a phone call or 
power failure), you must restart the sync.

1 When I sync, what happens if data in one application conflicts with data in the 
other?

If there is a data conflict, data in Bento for iPhone overwrites data in Bento. For 
example, you have John Smith’s phone number stored in both applications. You 
change his phone number to 555-1010 in Bento and 555-9090 in Bento for iPhone. 
When you sync, the phone number on your mobile device overwrites the phone 
number on your computer.

1 Why don’t I see my iCal Events and iCal Tasks libraries in Bento for iPhone?

The iCal Events and iCal Tasks libraries are not supported in Bento for iPhone.
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A Keyboard Shortcuts 

This section provides a reference of the keyboard 
shortcuts. 

You can use your keyboard and mouse to quickly accomplish many tasks in Bento. To 
find the shortcuts for common menu commands, look in the menus (or see the menu 
shortcuts listed here). To complete an action, press the shortcut keys in the order 
shown. 

Note:  To tab and shift-tab to all fields in form and table view, you must set full 
keyboard access to “All controls.” 

To set full keyboard access to all controls: 
1 Open System Preferences (choose Apple menu > System Preferences). 

2 Open “Keyboard & Mouse” preferences. 

3 Click the Keyboard Shortcuts tab. 

4 Under Full keyboard access, select “All controls.”

Action Shortcut 

Working with Form View 

Show or hide form tools Option-Command-C 

Move to next field Tab

Move to previous field Shift-Tab 

Rename form Double-click form name

Select multiple fields Click outside the first field, then drag the selection rectangle 
through the other fields you want to select.

Extend field selection With fields selected, Shift-click or Command-click to add or remove 
items from the selected set of fields.

Select all fields Command-A

Deselect all fields Shift-Command-A
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Working with Table View 
When One Cell is Selected

Edit a value Option-Return

Save and move to next cell Return

Add a carriage return in a text field Command-Return

Move to cell above Up arrow

Move to cell below Down arrow

Move to next field Tab

Move to previous field Shift-Tab 

Working with Table View 
When One or More Cells are Selected

Extend selection upward Shift-up arrow

Extend selection downward Shift-down arrow

Working with Table View 
When Records are Selected

Select a record Click the row number. The entire record is selected.

Select multiple records Select one record, then Shift-click another record to select all records 
in between. 

Extend record selection With records selected, Command-click record to add a record to 
selection, if it is not selected, or to remove a record from selection, if 
it is selected. 

Move to record above Up arrow

Move to record below Down arrow

Working with Records 

Add record Command-N 

Duplicate record Shift-Command-D 

Delete record (Library) 
Remove record (Collection) 

Command-Delete

Go to next record Command-right bracket (])

Go to previous record Command-left bracket ([) 

Go to first record Option-Command-left bracket ([)

Go to last record Option-Command-right bracket (])

Working with Text and Objects 

Select all text within a field being 
edited

Command-A 

Action Shortcut 
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Deselect all text within a field 
being edited

Shift-Command-A 

Cut Command-X

Copy Command-C

Paste Command-V

Duplicate Command-D 

Delete Delete 

Check spelling Command-semicolon (;) 

Show spelling window Command-colon (:) 

Show special characters window Shift-Command-T 

General 

Create library from template 
(opens New Library dialog) 

Command-L 

Create collection Shift-Command-N 

Create Smart Collection Option-Command-N 

Add field Control-N

Show or hide Advanced Find Command-F 

Quick Look selected item Command-Y

Use search field Option-Command-F 

Show table view Command-1 

Show split view Command-2 

Show form view (repeat shortcut to 
move to next form)

Command-3 

Show or hide libraries and fields 
pane 

Command-4 

Move to next area of main window Control-Option-right arrow 

Move to previous area of main 
window

Control-Option-left arrow

Show or hide summary row Command-5 

Import file Shift-Command-I 

Export current library or collection Shift-Command-E 

Print current library or collection in 
the current view 

Command-P 

Undo last action Command-Z 

Redo last undone action Shift-Command-Z 

Close window Command-W

Minimize window Command-M

Show preferences Command-comma (,) 

Action Shortcut 
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Show Bento Help Command-question mark (?) 

Hide Bento Command-H 

Hide other windows Option-Command-H 

Quit Bento Command-Q 

Action Shortcut 
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