
Bento® 4
User’s Guide



© 2007-2012 FileMaker, Inc. All rights reserved. 

FileMaker, Inc. 
5201 Patrick Henry Drive 
Santa Clara, California 95054

FileMaker and Bento are trademarks of FileMaker, Inc. registered in 
the U.S. and other countries. The file folder logo and the Bento logo 
are trademarks of FileMaker, Inc. All other trademarks are the 
property of their respective owners.

FileMaker documentation is copyrighted. You are not authorized to 
make additional copies or distribute this documentation without 
written permission from FileMaker. You may use this documentation 
solely with a valid licensed copy of FileMaker software.

All persons, companies, email addresses, and URLs listed in the 
examples are purely fictitious and any resemblance to existing 
persons, companies, email addresses, or URLs is purely coincidental. 
Credits are listed in the Acknowledgements documents provided 
with this software. Mention of third-party products and URLs is for 
informational purposes only and constitutes neither an endorsement 
nor a recommendation. FileMaker, Inc. assumes no responsibility with 
regard to the performance of these products.

For more information, visit our website at http://www.filemaker.com.

Edition: 03



Contents
Preface 7 Welcome to Bento
8 Managing Data in Libraries

14 About This Document
14 Resources for Learning More

Chapter 1 17 Overview of Bento
17 Home Dialog
18 Bento Window

Chapter 2 29 Using Libraries
29 About Libraries
30 Creating a Library Using the Bento Templates
32 Creating a New Blank Library
32 Changing the Icon for a Library
33 Sharing Your Bento Database
35 Grouping Libraries
35 Deleting Records from a Library
36 Deleting a Library

Chapter 3 37 Using the Address Book Library
37 About the Address Book Library
38 Displaying Data from the Address Book Application 
39 Bento Address Book Fields That Update the Address Book Application
39 Troubleshooting Address Book Updates
40 Address Book Data and Backups

Chapter 4 41 Migrating the iCal, iPhoto, and Address Book Libraries
41 Migrating the iCal Libraries
42 Migrating the iPhoto Library
42 Migrating the Address Book Library
     3



4

Chapter 5 43 Using Collections
43 About Collections
44 Creating Collections
45 Removing Records from a Collection
45 Deleting a Collection
45 About Smart Collections
45 Creating Smart Collections
46 Changing a Smart Collection

Chapter 6 47 Using Form View
47 About Forms
48 Creating Records in Form View
48 Editing Records in Form View
49 Duplicating Records in Form View
49 Deleting Records in Form View
50 Creating Forms
50 Deleting Forms
51 Showing and Hiding Forms
51 Duplicating Forms
51 Copying Forms
51 Renaming Forms
52 Locking and Unlocking Forms
52 Adding Fields to a Form
53 Tabbing Between Fields
53 Moving Fields and Objects on Forms
53 Resizing Fields and Objects
54 Removing Fields from a Form
54 Customizing Form Layouts

Chapter 7 59 Using Table View
59 About Table View
60 Selecting Records in Table View
60 Creating Records in Table View
61 Editing Records in Table View
62 Duplicating Records in Table View
62 Deleting Records in Table View
63 Sorting Records
63 Working with Fields and Columns in Table View
67 Summarizing Column Data
Contents



Chapter 8 69 Using Grid View
69 About Grid View
70 Viewing the Grid and a Form at the Same Time
70 Displaying Grid View Items
70 Setting Grid View Options
70 Changing the Display Size of Grid View Items
71 Working with Library Folders in Grid View

Chapter 9 73 Using Fields
73 About Fields
76 Creating Fields 
84 Navigating to Related Records
84 Using the Fields Pane
86 Working with List Fields
92 Working with Related Data Fields
95 Working with Media Fields
97 Working with Encrypted Fields

100 Working with Location Fields

Chapter 10 103 Importing, Exporting, and Printing
103 About Comma-Separated and Tab-Separated Files
106 Importing Information into Bento
112 Exporting Information from Bento
117 Printing Information

Chapter 11 123 Backing Up and Restoring Information
124 About Bento Backup Files
125 Using the Back Up Reminder
125 Changing the Back Up Reminder
126 Creating a Backup File
126 Restoring from a Backup File
127 Using Time Machine with Bento

Chapter 12 129 Syncing
129 Syncing Information Between Your Mac and Devices

Appendix A 135 Keyboard Shortcuts 

Appendix B 139 Reverting to a Previous Version of Bento
139 Reverting to a Previous Version from Bento 4

Index 143
Contents 5



6
 Contents



Welcome to Bento
Bento® helps you organize your information, providing the 
power of a database without complexity. 

Bento is an easy-to-use database that manages contacts, tasks, and other information 
that is important to you. Because Bento is a database, you can create data 
relationships and view your data in more ways than you can in a spreadsheet. 

Bento brings your important information together in one place to help you get 
organized. You’ll be able to manage your contacts, coordinate events, track projects, 
prioritize tasks, and more. 
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Managing Data in Libraries 
Bento comes with more than 30 library templates to help you create libraries easily. 
You can create an Expenses library to track information about expenses, and an Event 
Planning library to track information about your travel club events. 
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Bento provides a Projects library, so you’re ready to start managing projects for your 
travel club. 

Importing Data from Other Applications 
How do you add your spreadsheet of expenses to Bento? Create a library by importing 
data from another application, or import data into a library you’ve already created. 

Save your spreadsheet as a comma-separated values (.csv), tab-separated values (.tab), 
Numbers, or Excel file, and then import the file into Bento. Bento creates the fields 
needed to hold your data and creates records for each row of data in the file.

Libraries Fields 
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Creating Collections 
You have a team of people who are working with you on your next travel club event. 
All of your team members are in the Bento Address Book library, but you’d like to 
create a smaller group that includes only your team members, not everyone in the 
Address Book library. You want to create a collection. 

Creating a collection is as easy as creating a group in Address Book or a playlist in 
iTunes. Open the Bento Address Book library in table view. Select the records for the 

Importing 
spreadsheet 

data into a 
Bento library. 
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team members and choose the New Collection from Selection menu item, or drag the 
selected records to the Libraries pane. 

Give the collection the name “Team Members” and Bento creates the Team Members 
collection. 

Drag the selected 
records to the 

Libraries pane. 
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Creating Relationships 
Bento makes it easy to connect your libraries of information using related data fields. 

For example, say you want to track expenses by team member. To create a related data 
field, drag “Team Members” to the “Expenses” form. 
Preface    



 

You can also create a related data field that shows expenses for each team member. 
Drag “Expenses” to the “Team Members” form. 
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About This Document
The following table tells you where to find information in this documentation. 

Resources for Learning More 
To get the most from Bento, consult the resources listed below. 

User’s Guide 

Bento User’s Guide is a PDF document that provides detailed information on using 
Bento. 

To open the User’s Guide: 

Choose Help > Bento User’s Guide. 

Onscreen Help 

To access help from within Bento, choose Help > Bento Help. You can browse through 
the table of contents to find a specific topic, or enter a question in the search field. 

For information about See 

The features of Bento Chapter 1, “Overview of Bento” on page 17

Using libraries to manage your information Chapter 2, “Using Libraries” on page 29

Using the Address Book library to display data from 
the Mac OS Address Book application 

Chapter 3, “Using the Address Book Library” on 
page 37

Migrating existing iCal, iPhoto, and Address Book 
libraries

Chapter 4, “Migrating the iCal, iPhoto, and 
Address Book Libraries” on page 41

Creating a subset of records from a library Chapter 5, “Using Collections” on page 43

Viewing your data one record at a time, creating 
forms, changing the appearance of forms, and 
adding new fields to forms 

Chapter 6, “Using Form View” on page 47

Viewing all the records in a library or collection in a 
table 

Chapter 7, “Using Table View” on page 59

Using media fields and library folders in grid view Chapter 8, “Using Grid View” on page 69

All the field types that Bento provides, and using 
the Fields pane 

Chapter 9, “Using Fields” on page 73

Sharing data by importing, exporting, and printing Chapter 10, “Importing, Exporting, and Printing” 
on page 103

Creating a backup of your Bento data Chapter 11, “Backing Up and Restoring 
Information” on page 123

Syncing information between Bento for Mac and 
your device

Chapter 12, “Syncing” on page 129

Using keyboard shortcuts Appendix A, “Keyboard Shortcuts” on page 135

Reverting to a previous version of Bento Appendix B, “Reverting to a Previous Version of 
Bento” on page 139
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Tutorial 

For a demonstration of what you can do with Bento, view the tutorials. 

To access the tutorials: 

Choose Help > Video Tutorial, and then follow the instructions. 

Bento Forum

Visit the Bento forum to get technical support, tips, report problems, and share with 
others how you use Bento.

To access the Bento forum: 

Choose Help > Bento Forum.

Bento Template Exchange

Visit the Bento Template Exchange website to submit your own templates and 
download templates created by other Bento users.

To access the Bento Template Exchange: 

Choose Help > Bento Template Exchange.

Note  You can also submit your templates directly from within Bento. See ”Submitting 
Templates to the Bento Template Exchange” on page 114.

Bento for iPhone and Bento for iPad

Visit the Bento products web page to get information about the features of Bento for 
iPhone and Bento for iPad. 

To view information about Bento for iPhone and Bento for iPad: 

Choose Help > Bento for iPhone, iPod touch and iPad.

Technical Support 

To learn more about the support options that are available to Bento users, view the 
service and support information. 

To view the service and support information: 

Choose Help > Service and Support. 
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Overview of Bento 
This chapter provides an overview of Bento features. 

This chapter is a description of what you see when you start using Bento. It introduces 
the Home dialog and describes the sections of the Bento window, including the 
Libraries pane, the Fields pane, and the records area where you can display your 
information in table view, form view, grid view, or split view. 

Home Dialog
When you first open Bento, you use the Home dialog to learn about Bento and to 
create your first library.

Bento uses libraries to store 
information. One way to start using 

Bento is by creating a library.

When you’re done with the Home 
dialog, click this button to start 

using Bento.

If you decide that you don’t need the Home 
dialog, deselect the “Show this dialog on startup” checkbox.

To see how easy it is to use, 
take a video tour of Bento.
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Bento Window
The Bento window contains two main sections: 

• The left side of the window contains the Libraries pane (which may display the 
Devices section and the Shared section), and the Fields pane. 

• The right side of the window displays the records in Bento. You can display 
record data in table view, form view, grid view, or split view.

By default, both sections of the Bento window are displayed. To hide the Libraries 
pane and Fields pane, choose View > Hide Libraries & Fields Pane.

Libraries pane Records area

Fields pane
Chapter 1    Overview of Bento



 

Libraries Pane
The Libraries pane displays the libraries and collections that are in Bento. 

• A library categorizes data by content. Bento provides several libraries by 
default. The Projects library, which stores data about projects, is an example 
library with sample data. You can create libraries to store other categories of 
data. You can organize a group of libraries within a folder.

To add a library to the Libraries pane, click the New Library button. See ”Using 
Libraries” on page 29.

• A collection is set of records from a library. A collection is similar to an Address 
Book group or to a playlist in iTunes. A collection contains records from its 
parent library. A record from the library can be in more than one collection. 
For example, one person might be both a friend and a co-worker. If you had 
one collection named “Friends” and another named “Co-workers” you could 
add this person’s contact record to both collections in the Address Book 
library. 

To add a collection to the Libraries pane, click the New Collection button. See 
”Using Collections” on page 43.

Tip  If you want to change the size of the icons and text in the Libraries pane, choose 
Bento > Preferences. For “Libraries Pane Text,” select Small or Large.

Address Book 
Library

iCal Events 
Library

Collection of 
iCal Events 

Collection of 
records from 
Projects 

New Library 

New Collection 

iCal Tasks 
Library

Projects Library
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Collections 

Create a collection when you want a subset of the records from a library. There are two 
kinds of collections:

• Collections are created by adding records from the library to a new collection. 
Creating a collection is as easy as creating a playlist in iTunes. Select the 
records in the library and use the New Collection from Selection menu item, 
or drag the selected records to the Libraries pane. 

• Smart Collections are created based on criteria you set up. Records that meet 
the defined criteria appear in the Smart Collection. You use Advanced Find to 
create a Smart Collection. 

See ”Using Collections” on page 43.

Creating Libraries 

Bento comes with more than 30 library templates that make it easy for you to create 
new libraries of information. A template defines the fields of information used in each 
record of a library, which you can change based on your needs. Select the library 
template that most closely matches the category of data you want to store. 

 

See ”Creating a Library Using the Bento Templates” on page 30. 
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Devices Section

The Devices section of the Libraries pane keeps track of how many devices (up to two) 
are currently connected to Bento. The Devices section is hidden when no devices are 
connected.

See ”Syncing” on page 129.

Shared Section

The Shared section of the Libraries pane lists libraries that are being shared over a 
local network (in the same subnet). To hide the Shared section, deselect the option 
“Look for shared databases” in Bento Preferences.

See ”Sharing Your Bento Database” on page 33.

Records Area 
On the right side of the Bento window, you can display information stored in Bento in 
either table view, a form view, grid view, or split view. 

• Table view shows information in an entire library or collection in a 
spreadsheet-like table, where each row in the table is a record in the library. 

• Form view shows fields from one record at a time, in arrangements that you 
can customize, using beautiful themes.

• Grid view shows the media fields and form thumbnails of a selected library or 
collection in a grid layout.

• Split view shows the selected record in either form view and table view, or 
form view and grid view at the same time.
Chapter 1    Overview of Bento 21
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Table View 

To view the information in an entire library or collection in a spreadsheet-like table, 
use table view.

In table view, you can work with your records in many ways, including: 

• Selecting the columns (fields) that you want to show. 

• Arranging the columns in any order. 

• Sorting records by selecting a specific column. 

• Analyzing data using a summary row. 

See ”Using Table View” on page 59. 

Table view shows each record as a row in a table. Form view shows fields from a single record. 

Split table and form view lets you view a record as a row in 
a table and in a page-like format at the same time. 

Grid view shows media fields or form thumbnails 
in the selected library.
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Form View 

To view your information one record at a time, use form view. In form view, you can 
create multiple forms for each collection or library, giving each form a different name. 
For example, you could create a form in the Projects library to show a schedule, and 
track milestones. 

You can customize forms in many ways, including: 

• Selecting the fields that you want to show. 

• Arranging the fields on the form. 

• Changing the size of fields. 

• Changing the appearance of the form using themes. 

• Adding a header and a logo.

See ”Using Form View” on page 47.

Grid View

To view the media fields and form thumbnails in a selected library or collection, use 
grid view.

In grid view, you can work with thumbnails of media fields and forms, called grid view 
items, in many ways, including:

• Filtering grid view items.

• Setting and changing labels of grid view items.

• Changing the display size of grid view items.

See ”Using Grid View” on page 69.

Split View

To view the selected record in form view and table view at the same time, or in form 
view and grid view at the same time, use split view.
Chapter 1    Overview of Bento 23
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Form Themes 

Bento provides an assortment of beautiful themes that you can apply to your forms. 
Every theme includes coordinated colors, layout, fonts, and text attributes. You can 
easily change a form’s theme at any time. 

See ”Customizing Form Layouts” on page 54. 
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Navigation Bar

The navigation bar contains several controls that help you display information in 
Bento. 

• Click  to see records in table view.

• Click  to see records in grid view.

• Click one of the form view buttons to see records one at a time in a page-like 
view. In the example below, there are two form view buttons: “Overview” and 
“Details.” You can have as many form views as you want. 

• Click  to switch to split view from table view or form view.

• Click  to switch to split view from grid view.

• To move through the records in a library or collection, click the Previous 
record and Next record buttons (the arrow buttons). 

To go to the first record, Option-click the Previous record button. To go to the last 
record, Option-click the Next record button. 

Search Field and Advanced Find 
• Use the Search field to do a simple search for text in all field types except 

media, related data, file list, message list, simple list, and encrypted. 

Note  You can search encrypted fields if they are unlocked.

• Use Advanced Find to find a set of matching records by defining search 
values and criteria for specific fields. 

Form view 
buttons

New form Delete form 

Previous 
record

Show or hide 
split view

Next 
record

Search 
field

Grid 
view

Table 
view

Click here for 
Advanced Find
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To use the Search field: 

1 Select the library or collection.

2 Enter a text string into the Search field. 

Bento searches across all the applicable fields of the selected library or collection. 
Bento lets you know how many records match the search string, and updates the 
current view to display the matching records for those fields that are selected in table 
view or have been added to a form in form view.

1. Type “M”and the result is 30 records. 2. Type “Ma” and the result is 15 records. 

3. Type “Mar” and the result is 9 records. 4. Type “Mary” and the result is 3 records. 
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To use Advanced Find: 

1 Select the library or collection. 

2 In the search field, click  and select Advanced Find, or press Command-F. 

3 Specify what you want to find. Add or remove criteria as needed. 

When searching on a location field, make sure you enter the direction (North, 
South, East, or West. Otherwise, Bento assumes North for the latitude and East for 
the longitude).

4 Click Find.

Bento performs the search, and displays the matching records. 

• To save the matching records as a Smart Collection, click Save. See ”About 
Smart Collections” on page 45. 

• To close Advanced Find, click the X next to “Advanced Find” or press 
Command-F. When you close Advanced Find, Bento shows all records. 
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Fields Pane
The Fields pane on the left side of the Bento window displays the fields that are 
defined for the selected library or collection.

• In table view, use the Fields pane to select which columns are shown.

• In a form view, use the Fields pane to add fields to the current form by 
dragging a field name with  to the form.

• In split view, the Fields pane indicates the fields that can be added to the 
current form or can be displayed in table view.

See ”Using the Fields Pane” on page 84. 

Drag to add field to 
the current form.

Field is already on 
the current form.

Fields with 
selected 

checkboxes are 
already shown as 

columns in table 
view.

In form view In table view 

Select an 
unchecked field to 

show it as a 
column in table 

view.

Address subfields 
can’t be added to the 
form individually.
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Using Libraries 
In Bento, you use libraries to organize your information. You 
can use the libraries that Bento provides, and create your 
own libraries using templates. You can share your entire 
database or selected libraries with up to five users on a local 
network.

You can create libraries to hold your information: 

• By using the New Library dialog 

• By importing existing information from a comma-separated (.csv), tab-
separated (.tab), Numbers, Excel, or library template file

This chapter describes how to use libraries to organize, manage, and share your 
information. 

About Libraries 
Bento stores information in libraries. Libraries are composed of records, and libraries 
are defined by the fields in the records. 

For example, the default Projects library records are composed of fields that are useful 
for managing projects, such as fields for the project status, start and end dates, and 
team member information. 

Bento provides several ways for you to view the records of a library: 

• Form view shows fields from a single record. Each page shows one record at a 
time, for example, a single contact record in the Address Book library. You can 
have more than one form view for the library. See ”Using Form View” on 
page 47.

• Table view shows the records in a table, for example, a list of the contacts in 
the Address Book library. Each row in the table represents a single record in 
the library. See ”Using Table View” on page 59.
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• Grid view displays at a glance the media fields and form thumbnails of a 
selected library or collection. See ”Using Grid View” on page 69.

• Split view shows a record in form view and table view or grid view at the same 
time.

The remainder of this chapter describes how to create, use, and share libraries: 

• You can create your own libraries by using library templates. See the 
following section, ”Creating a Library Using the Bento Templates” on page 30.

• You can create a library by importing your own data. See ”Importing 
Information into Bento” on page 106. 

• You can share your libraries with up to five other Bento users on your local 
network. See ”Sharing Your Bento Database” on page 33.

Creating a Library Using the Bento Templates
Before you create a library, think about the type of information you want to manage 
with the library. Do you want to manage schedules and dates? Do you want to 
manage contact information? Are you looking for a way to bring tasks and 
assignments together in an event planner? Or do you want to manage a list of things, 
such as inventory or equipment lists? 

Bento provides library templates that create the fields to manage specific kinds of 
information. These templates also apply pre-designed themes to the form views. 

By selecting the library template that most closely fits the type of information you 
want to manage, you create the library you need more quickly. If you can't find a 
template for the kind of information you want to store, you can use the “Blank” 
template and create a library of your own. After you create a library from a template, 
you can customize the form view by adding or removing fields and changing the 
theme. 

Tip  If you already have information from another application that you want to use in 
Bento, see ”Importing Information into Bento” on page 106.
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To create a library using the Bento templates: 

1 Choose File > New Library from Template. 

2 In the New Library dialog, select a template category in the left column, then 
select the template. 

Select “Blank” if none of the templates meet your needs. You can create all of the 
fields yourself with the Blank library. 

If you select the Contacts template, you can have Bento import your Address Book 
library data.

3 Enter a name for your library, and click Choose. 

Bento creates the library and opens it in form view. 

If you selected a template other than the Blank template, review the fields that are 
defined for your new library. 

• If you are happy with the fields and form views in your new library, then 
you’re ready to add records and enter information. See ”Editing Records in 
Form View” on page 48. 

• If you need additional fields, you can customize the library by adding fields. 
See ”Adding Fields to a Form” on page 52. 
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• If there are fields defined for information that you do not need, delete those 
fields. See ”Removing Fields from a Form” on page 54. 

• If you want to change the layout of the fields on the form view, see 
”Customizing Form Layouts” on page 54. 

• If you want to change the appearance of the form view, you can select a 
different theme. See ”Customizing Form Layouts” on page 54. 

Creating a New Blank Library 
You can get started quickly by creating a blank library, then add data to it as you would 
in a spreadsheet.

To create a new blank library: 

1 Choose File > New Blank Library. 

Bento creates a library with a default name and opens it in table view. 

Bento creates a blank record for you. You can add data to this record (see 
”Creating Records in Table View” on page 60), or you can delete the record (see 
”Deleting Records from a Library” on page 35). 

2 Double-click the library name to rename it.

3 Click in the highlighted cell to start entering or pasting data.

See ”Editing Records in Table View” on page 61 and ”Copying and Pasting Data in 
Table View” on page 61.

Note  If you already have information from another application that you want to 
include in Bento, create a library and records in that library by importing your 
information. See ”Importing Information into Bento” on page 106.

Changing the Icon for a Library
Each library comes with its own icon. You can change the icon for any library you 
create.

Note  You cannot create your own icon in Bento.

To change a library icon:

1 In the Libraries pane, Control-click the library you want to change.

2 Choose “Choose a library icon.” 

3 Click an icon, then click OK.
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Sharing Your Bento Database
You can share your Bento database with up to five other Bento users at the same time 
over a local network (in the same subnet). Sharing requires the current version of 
Bento on each computer that is either sharing a database or looking for shared 
databases. 

You can export data or a template from a shared library. For more information, see 
”Exporting Information from Bento” on page 112.

When you first start Bento, your libraries are set up ready to be shared. You then 
decide whether to share your entire database or only selected libraries. 

To share your database with other Bento users:

1 Choose Bento > Preferences.

2 Click Sharing at the top of the window.

3 Select “Share my Bento database.” 

4 Select “Share entire database” or “Share selected libraries,” then select the 
libraries you want to share.

5 (Optional) Enter a different name for your shared database.

This is the name that is displayed on other users’ computers (if they are set up to 
look for shared databases on your network).

6 If you want other users to be able to make changes to the shared database, 
select “Allow others to make changes to your data.” 

If a shared database is not allowed to be changed, users see italicized field labels 

and  when they move the cursor over the fields. 

Users viewing your shared database can’t create or delete fields or make changes 
to form layouts. 

If you make certain types of changes to the database while it is being shared 
(create fields, collections, or folders; delete folders; change field options or the 
database name), users are prompted to disconnect from the database and then 
reconnect to ensure they have the latest version.

7 Leave Bento open on your computer for users to see your shared database on 
other computers. If you quit Bento, your database will no longer be shared.

Important  Users editing a shared database can’t undo their changes once they have 
tabbed or clicked outside the field currently being edited.

To disconnect a shared database, click  next to the shared database.
Chapter 2    Using Libraries 33



34

 

Turning Off Database Sharing
You can turn off database sharing to prevent other users on your local network from 
seeing your database.

To turn off database sharing:

1 Choose Bento > Preferences.

2 Click Sharing at the top of the window.

3 Deselect “Share my Bento database.” 

Looking for Shared Databases
If your computer is connected to other computers over a local network, you can look 
for databases that are being shared.

To look for shared databases on your local network:

1 Choose Bento > Preferences.

2 Click Sharing at the top of the window.

3 Select “Look for shared Bento databases.” 

Any shared databases appear in the Shared section of the Libraries pane.

Setting a Password for a Shared Database 
If you only want only a select group of users to access your database, you can require 
users to enter a password, called the Sharing Password, before they can view your 
shared items. This password is different from the Database Password. For more 
information about the Database Password, see ”Setting a Password for Your Bento 
Database” on page 98.

To set the Sharing Password:

1 Choose Bento > Preferences.

2 Click Sharing at the top of the window.

3 Select Require Sharing Password, then type a password.

Opening a Password-Protected Shared Database

Password-protected shared databases are indicated by  in the Libraries pane.

To open a password-protected shared database:

1 Select a password-protected shared database. 

2 In the dialog, enter the Sharing Password that was set by the owner of the 
shared database.
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Working with Shared Encrypted Fields
Users can access encrypted fields in shared databases by first entering the Sharing 
Password (if one has been set) and then the Database Password for the shared 
database. For more information about the Database Password, see ”Setting a 
Password for Your Bento Database” on page 98.

Users can lock and unlock data in shared encrypted fields. For more information, see 
”Locking and Unlocking Data in Encrypted Fields” on page 99.

Grouping Libraries
You can organize a group of libraries within a folder.

To create a library folder: 

1 Choose File > New Library Folder.

An untitled folder is created in the Libraries pane above the currently selected 
library or folder.

2 Enter a new name for the folder and press Return.

To add a library to a library folder: 

Select the library and drag it to the desired library folder.

Deleting Records from a Library 
You can delete one record or multiple records from a library. The easiest way to delete 
multiple records is in table view.

To delete one record from a library: 

1 Select the library.

2 Select the record, then choose Records > Delete Record (or press Command-
Delete). 

To delete multiple records at one time:

1 Select the library.

2 In table view, Command-click or Shift-click the records you want to delete, 
then choose Records > Delete Selected Records (or press Command-Delete).

Note  When you press Command-Delete, the records are permanently deleted from 
both the library and any collection or related data fields that displayed them. 
Chapter 2    Using Libraries 35



36

 

Deleting a Library

To delete a library: 

Select the library and press the Delete key. When you press Delete, the library and all 
of its records are deleted. 

Any related data fields in other libraries based on this library are also deleted. 
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Using the Address Book Library
The Address Book library displays contact information from the Mac OS Address Book 
application, so there is no need to re-enter your contact information. Enter new 
contacts in Address Book or in Bento, and the information appears in both 
applications.

Note  The Bento Address Book library is not synced with Bento 4 for iPad. To work with 
your Address Book data on Bento 4 for iPad, migrate your Address Book library to a 
new Contacts library, then sync the new Contacts library with Bento 4 for iPad. For 
more information, see ”Migrating the Address Book Library” on page 42.

About the Address Book Library 
If you set Bento to display the Address Book library, Bento gets the contact 
information and groups from the Mac OS Address Book application. When you make 
changes to records in the Bento Address Book library, you are also updating the 
records in the Address Book application.

• If you add a record in the Address Book library, then it is added to the Address 
Book application. 

• If you delete a record in the Address Book library, then it is deleted from the 
Address Book application. 

• For every group that you create in the Address Book application, Bento 
creates an Address Book library collection.

• For every collection you create in the Address Book library, the Address Book 
application creates an Address Book group. 

• If you delete a collection under the Address Book library, the associated 
Address Book group is also deleted. Similarly, if you delete a group in the 
Address Book application, the associated collection under the Address Book 
library is also deleted.

Note  When you create a new library using the Contacts template, you can choose to 
have Bento import your Address Book library data.
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Displaying Data from the Address Book Application 
Displaying the Address Book library is optional.

To turn on or off the display of Address Book data in Bento: 

1 In Bento, choose File > Address Book and iCal Setup (existing Bento users) or 
File > Address Book Setup (new Bento users). 

2 Do one of the following:

• Select “Display Address Book data in Bento” to display the Address Book 
library in Bento.

• Clear “Display Address Book data in Bento” to remove the Address Book 
library from Bento.

Note  If you turn off the display of the Address Book data, the Address Book library 
is removed from Bento. If you have related data fields based on the Address Book 

The Address Book library 
displays contact 
information from the 
Address Book application. 

Address Book 
groups display 
as collections 

in Bento. 
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library, those related data fields will be deleted. Any fields that were created in 
Bento for the Address Book library will also be deleted.

Bento Address Book Fields That Update the Address Book 
Application 
The following fields in the Address Book library update information in the Address 
Book application. 

You can use import and export with the Address Book library. Records imported into the 
Address Book library update the Address Book application. See ”Importing, Exporting, and 
Printing” on page 103 for information on importing and exporting.

You can add other fields to your Address Book library records in Bento, but your 
additional fields are not added to the Mac OS Address Book application. See ”Using 
Fields” on page 73 for information on adding fields. 

Conversely, any custom field labels you have defined in the Mac OS Address Book 
application are not displayed in the Address Book library in Bento. 

Address: Home, Work, Other 

Address list

Birthday

Company name 

Department

Email address: Home, Work, Other

Email address list 

First name 

Home page 

IM account: Home, Work, Other 

IM account list 

Is Company

Job title

Last name 

Maiden name

Middle name 

Nickname

Note 

Phone number: Work, Home, Mobile, 
Main, Home fax, Work fax, Pager, 
Other 

Phone number list 

Phonetic first name

Phonetic last name

Phonetic middle name

Prefix 

Suffix 

URL

URL list 
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Troubleshooting Address Book Updates 
This section describes some common issues with displaying data from the Address 
Book application. 

• Why don’t I see my Smart Groups from the Address Book application in 
Bento? 

Bento does not display Address Book Smart Groups because the criteria used to 
create the groups are not available to Bento. 

• Why don’t I see my Address Book library’s Smart Collections in the Address 
Book application? 

The criteria used to create Bento Smart Collections cannot be passed to the Address 
Book application because the criteria may use fields that appear only in Bento and 
may involve fields that are not available to the Address Book application. 

• Why don’t I see my Address Book library in Bento for Mac? 

If you migrated your Address Book library in Bento for Mac, it was replaced with 
the Bento Contacts library. See ”Migrating the Address Book Library” on page 42.

Address Book Data and Backups
When you create a Bento backup file, the data from the Address Book application is 
not included in the Bento backup file. To back up the data from Address Book, use the 
Mac OS Address Book application. 

If you add fields to the Address Book library in Bento, information from those 
additional fields is included in the Bento backup file. See ”Backing Up and Restoring 
Information” on page 123 for information on creating a Bento backup file. 
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Migrating the iCal, iPhoto, and 
Address Book Libraries 
When you first start Bento for Mac, if you have any existing iPhoto, iCal Events, or iCal 
Tasks libraries, Bento asks you to migrate the data. 

When you sync Bento for Mac with Bento 4 for iPad, if you have an existing Address 
Book library, Bento asks you to migrate the data.

When you migrate an Address Book or iCal library, all the data in the library is moved 
to a new Bento library. The new library contains all your original data, including all 
your collections, smart collections, forms, relations to other libraries, and settings.

The new Bento libraries with the migrated data are not connected to the Mac OS 
Address Book or iCal applications. For example, if you update a contact in the Mac OS 
Address Book after migrating the data, the information will not be updated in the new 
Bento Contacts library. Similarly, if you update a contact in the new Bento Contacts 
library, the information will not be updated in the Mac OS Address Book.

If the library includes any locked encrypted fields, you are asked to enter the Database 
Password to unlock the fields. If you don’t unlock the encrypted fields, Bento does not 
migrate the library.

Note  Migrating the Bento libraries doesn’t affect your data in the Mac OS Address 
Book, iCal, or iPhoto applications.

Migrating the iCal Libraries
When you start Bento for Mac, if you have any existing Bento iCal Tasks or iCal Events 
libraries, Bento asks you to migrate the data.

Follow the onscreen instructions to migrate the data. Your Bento iCal Tasks library will 
be replaced by a Bento Tasks library. Your Bento iCal Events library will be replaced by 
a Bento Events library. The Bento Tasks and Events libraries are not connected to the 
Mac OS iCal application.

If you choose to migrate the data later, do one of the following:

• Control-click the iCal Tasks library or the iCal Events library in the Libraries 
pane, then choose Migrate iCal. 

• Choose your device in the Devices section of the Libraries pane, then click 
Migrate. Follow the onscreen instructions to migrate the data.
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Note  If you are new to Bento for Mac, you can’t display the iCal data in Bento. The iCal 
Tasks and Events libraries are not supported for new users.

Migrating the iPhoto Library
Displaying the iPhoto library is no longer supported in Bento. When you start Bento 
for Mac, if you have an existing Bento iPhoto library, Bento asks you to migrate the 
data. You must migrate the iPhoto library before you can start using Bento for Mac.

Follow the onscreen instructions to migrate the iPhoto library to a Bento Photos 
library. Bento copies only the following iPhoto library records to the Photos library:

• Any iPhoto library records that are referenced in related data fields.

• Any iPhoto library records that contain data in fields that were created in Bento.

Bento does not create a Photos library or migrate the data if there are no records that 
meet the migration requirements.

The Bento Photos library is not connected to the Mac OS iPhoto application. 

Note  After migrating the iPhoto library, you continue to be able to add images from 
iPhoto into Bento media fields.

Migrating the Address Book Library
You can’t sync the Address Book library in Bento for Mac with Bento 4 for iPad. When 
you sync Bento for Mac with Bento 4 for iPad, if you have an existing Bento Address 
Book library, Bento asks you to migrate the data.

Follow the onscreen instructions to migrate the data from the Bento Address Book 
library to a Bento Contacts library. The Bento Contacts library is not connected to the 
Mac OS Address Book application.

For information about syncing, see ”Syncing Bento for Mac with Bento for iPhone or 
Bento for iPad” on page 131.

To migrate the data, you can also choose your device in the Devices section of the 
Libraries pane, then click Migrate. Follow the onscreen instructions to migrate the 
data.

For information about displaying the Address Book library, see ”Displaying Data from 
the Address Book Application” on page 38.

Note  You can also import the data from the Address Book library when you create a 
new Bento Contacts library using the Contacts template. See ”Creating a Library Using 
the Bento Templates” on page 30.
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Using Collections
This chapter describes how to use collections to further 
organize your records in Bento. 

In Bento, your records are kept in libraries, as described in Chapter 2, “Using Libraries” 
on page 29. If you want to organize records in different ways or if you want to work 
with a subset of the records in a library, you can create a collection. 

About Collections 
A collection is a set of records from a library. You can create a collection to: 

• Create a set of records for a special purpose. For example, you could create a 
collection of the people invited to a specific event. 

• Sort records in a different order. For example, you could create a collection of 
contacts to sort the contact records by last name. 

• Export the data from the records in the collection rather than from all the 
records in the library. 

A collection in Bento is similar to a playlist in iTunes. If you have used iTunes, you know 
how convenient it is to use a playlist to create a compilation of songs and videos. 
Collections in Bento give you the same convenience for grouping records from a 
library. 

A collection contains records from a single library. For example, you can put records 
from the Address Book library in an Address Book collection such as Vendors. You 
cannot put any other library’s records in the Vendors collection. 

Vendors collection in the 
Address Book library
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However, a record from a library can be added to any of the collections within the 
same library. For example, if you have a “DVD” library with a “Favorites” collection and 
a “Classic Movies” collection, you can have the same record in both collections. 

There are two kinds of collections:

• collections

• Smart Collections

You create collections by using the New Collection menu item, by selecting records 
and using the New Collection from Selection menu item, or by dragging selected 
records to an existing collection or to the Libraries pane. 

Smart Collections are created based on criteria you set up. Smart Collections update as 
your library changes; records that meet the defined criteria appear in the Smart 
Collection. 

Creating Collections
Create a collection when you want to make a specific list of records.

To create a collection: 

1 Select a library in which you want to make a collection.

2 Click  or choose File > New Collection. 

3 Type a name for the collection, then press Return. 

4 Select the library you selected in step 1 again.

5 Click Table in the navigation bar or choose View > Table View to show the 
library in table view.

6 Select the record you want to add to the collection. Drag the selected record 

to the collection, or click  and choose Add to Collection to add the 
selected record to the collection. 

To select multiple records, hold down the Command or Shift key while you click. 

Tip  To quickly create a collection containing selected records, select the records, 
then choose File > New Collection From Selection or drag the records to a blank 
space in the Libraries pane.
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Removing Records from a Collection

To remove records from a collection: 

1 Select the collection.

2 Select the records and press Command-Delete.

If you click Remove from Collection, the records are removed only from the 
collection, not from the associated library. If you click Delete, the records are 
permanently removed from both the library and the collection. 

Deleting a Collection

To delete a collection: 

Select the collection and press the Delete key. The records are removed from the 
collection but not from the library.

Note  If you delete a library or collection that one or more related data fields are based 
on, those related data fields are also deleted.

About Smart Collections
Create a Smart Collection when you want a collection that contains records that meet 
criteria you define. Smart Collections show all the records that meet the criteria.

For example, you could create a Smart Collection of contacts who live in the same city. 
When you add a new contact record for a person who lives in that city, Bento 
automatically adds that contact record to your Smart Collection. 

Or you could create a Smart Collection of event records that are due in the same week. 
If you add or modify a record so that it meets the criteria, that record appears in the 
Smart Collection the next time you click the Smart Collection in the Libraries pane.

Because a Smart Collection is a set of records that match defined criteria, it is different 
from a collection in the following ways: 

• You cannot manually add records to or remove records from Smart 
Collections. To remove certain records from the Smart Collection, edit the 
criteria or modify the records’ values so that they no longer meet the criteria.

• You cannot import records into a Smart Collection. 

Creating Smart Collections 
You can create a Smart Collection that adds records to or removes records from a 
collection according to criteria that you define.
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To create a Smart Collection: 

1 Choose File > New Smart Collection.

2 Type a name for the Smart Collection, then press Return.

Use the pop-up menus and entry fields to specify the criteria for the Smart 

Collection. Click  to add additional criteria.

For example, to create a Smart Collection that only shows iCal tasks that are not 
completed, specify the criteria to be All, Completion Date, and Is empty.

3 Click Save. 

Tip  You can also create a Smart Collection by clicking Save after you specify the 
criteria for an Advanced Find. See ”Search Field and Advanced Find” on page 25.

Changing a Smart Collection
When you change a Smart Collection, Bento updates the collection based on the 
criteria that you define. You can edit and duplicate records within a Smart Collection. 
See ”Editing Records in Table View” on page 61 and ”Duplicating Records in Table 
View” on page 62.

To change a Smart Collection: 

1 Select the Smart Collection and choose File > Edit Smart Collection.

2 Use the pop-up menus and entry fields to modify, add, or remove the criteria.

3 Click Find to see if the new criteria produce the records you want. 

4 Click Save.

Note  To discard the changes you made to the criteria, click any other item in the 
Libraries pane.

1. Select the criteria.

2. Save the criteria.
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Using Form View
In Bento, you use form view to display one record at a time 
from a library or collection.

This chapter describes how to create and edit records in form view, create and modify 
forms, and customize form layouts.

About Forms 
In form view, you can create and use forms to display one record at a time from a 
library or collection in a page-like format. For example, you can display a project in the 
Projects library.

With forms, you can see the fields for an individual record. You can create and use 
multiple forms, or pages, to display different information about that record. 

For a given library or collection, you can use any of its fields on any of its forms.

If you want to see more than one record at a time, or scan and sort your information 
quickly, use table view instead. See ”Using Table View” on page 59. You can view a 

The same record displayed in another form 
view, using a different organization of fields

A record displayed in one form view
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selected record in form view and table view at the same time. Select the record, then 
choose View > Split View.

Forms can also display records from other libraries or collections in related data fields. 
For example, you can display a list of people from the Address Book library who are 
attending a party event in the iCal Event library. See ”Creating Related Data Fields” on 
page 80.

Creating Records in Form View
You can create records in any view. For table view instructions, see ”Creating Records 
in Table View” on page 60.

To create a record for a library or collection:

1 Select the library or collection you want to add a record to.

2 Click a form name in the navigation bar or choose View > Form View > Form 
Name.

3 Choose Records > New Record or press Command-N.

4 Type data in the fields.

5 Press Tab to move to the next field in the same record. Press Shift-Tab to move 
to the previous field in the same record.

Tip  To quickly create a record, Control-click in a blank area on the form and choose 
New Record from the pop-up menu.

Editing Records in Form View

To edit a record:

1 Select the library or collection that contains the record you want to edit.

2 Click a form name in the navigation bar or choose View > Form View > Form 
Name.

3 Navigate to the desired record. 

Press Tab or Shift-Tab to move from field to field.

4 Click the field you want to change, modify the data, then click outside the 
field or press Tab to save the change.
Chapter 6    Using Form View



 

Adding the Current Date and Time to a Field
When editing a record, you can add the current date and time to a date, time, or text 
field.

To add the current date and time to a field:

1 Click in the date, time, or text field.

2 Choose Insert > Current Date and Time.

Duplicating Records in Form View

To quickly add a record with the same or similar data as an existing record: 

1 Navigate to the record you want to duplicate.

2 Choose Records > Duplicate Record.

Deleting Records in Form View

To permanently delete a selected record from a library: 

1 Select the library.

2 Click a form name in the navigation bar or choose View > Form View > Form 
Name.

3 Select the record.

4 Choose Records > Delete Record or press Command-Delete.

In the dialog, click Delete.

If the field type is You see the current

Date Date. Set the “Display Time” option to also display the time.

Time Time

Text Date and time
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To remove a selected record from a collection: 

1 Select the collection.

2 Navigate to the record you want to remove.

3 Choose Records > Remove Record. 

If you click Remove from Collection, the record is removed only from the 
collection, not the library. If you click Delete, the record is permanently removed 
from both the library and the collection. 

Creating Forms

To create a form:

1 Select the library or collection you want to add a form to.

2 Click  in the navigation bar or choose Forms > New Form.

In the Form name dialog, type a name, then click OK.

3 Add fields to the blank form.

See ”Adding Fields to a Form” on page 52.

4 Create records. 

See ”Creating Records in Form View” on page 48.

Deleting Forms

To delete a form:

1 Select the library or collection you want to delete a form from.

2 Select the form you want to delete.

3 Click  in the navigation bar or choose Forms > Delete Form.

If there is only one form, you can’t delete it.
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Showing and Hiding Forms

To hide a form:

1 Select the library or collection with the form you want to hide.

2 Select the form you want to hide.

3 Choose Forms > Hide Form.

The form and form name are hidden.

If there is only one form, you can’t hide it.

To show a hidden form:

1 Select the library or collection with the hidden form that you want to show.

2 Choose Forms > Hidden Forms.

3 Choose the form that you want to show.

Duplicating Forms

To duplicate a form within the same library or collection:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Forms > Duplicate Form. 

Copying Forms

To copy a form to collections within a library or from a collection to its parent 
library:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Control-click the form you want to copy, then choose the library or collection 
where you want the form to be copied to.

Note  You can’t copy forms from one library to another.

Renaming Forms

To rename a form:

1 Double-click the form name at the top of the window.

2 In the Form name dialog, type a new name, then click OK.
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Locking and Unlocking Forms
Once you have completed your form layout, you can lock the form to prevent its field 
labels, field objects, or fields from being moved or resized.

When a form is locked, you can’t change its layout but you can add data to it in the 
following ways:

• Enter data in fields in the same way as when the form is unlocked.

• Create fields using the New Field dialog. Fields are automatically added to the 
bottom of the first column.

• Drag libraries and collections from the Libraries pane to create related data 
fields 

• Drag files from the Finder to create media or file list fields

Note  You can’t drag existing fields from the Fields pane to a locked form.

To lock a form:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Forms > Lock Form, or click  then click .

None of the field labels, field objects, or fields can be moved or resized until you 
unlock the form. 

To unlock a form:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Forms > Unlock Form, or click  then click .

Adding Fields to a Form

To add a field to a form:

1 Select a library or collection.

2 Select a form in the navigation bar or choose View > Form View > Form Name.

3 Drag a field from the Fields pane to the desired location on the form.

To move a field, see ”Moving Fields and Objects on Forms” on page 53. To resize a 
field, see ”Resizing Fields and Objects” on page 53. To create a field, choose 
Insert > New Field. See ”Creating Fields” on page 76.
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Tabbing Between Fields

To tab between fields on a form:

1 Select a library or collection.

2 Select a form in the navigation bar or choose View > Form View > Form Name.

3 Click in a field, then press Tab to move from field to field, and within each 
column if you have added a column divider. Press Shift-Tab to move in the 
reverse direction.

Note  To enable the Tab key to move to all controls, make sure “All controls” is selected 
in the Keyboard and Mouse (Mac OS X 10.6) or Keyboard (OS X Lion 10.7) preferences 
(Keyboard Shortcuts tab).

Moving Fields and Objects on Forms

To move one field or object:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select a field or object.

3 Move your mouse near the field label or the edges of the field or object. 
When the cursor changes into a hand, click to select the field or object, then 
drag it to a new location.

Bento allows you to drag fields above, below, next to, or between other objects on 
the form.

To move multiple fields or objects:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Command-click or Shift-click to select multiple fields or objects. 

Tip  To quickly select many fields and objects, click in an empty part of the form, and 
while holding down the mouse button, drag to select multiple items.

Resizing Fields and Objects
Any field and any object can be resized.

To resize a field or object:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select the field or object. 

3 Move the cursor to one of the handles. When the cursor changes to a double 
arrow, drag to change the size.
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Removing Fields from a Form

To remove a field from a form:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select the field, then press the Delete key or drag the field off the form. 

The data in the field is still in Bento even though the field is no longer displayed 
on the form.

Customizing Form Layouts
You can quickly change the appearance of a form.

Changing the Theme
You can change a form’s theme (the coordinated colors, layout, and text attributes) at 
any time. For example, you can use a light-colored theme for printing records. 

To change a form’s theme:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Forms > Theme Chooser.

3 In the Theme Chooser, select a theme, then click OK. 

You see a ripple effect as the theme changes. If you don’t want the ripple effect, 
choose Bento > Preferences, click General at the top of the window, then clear 
“Display animation.”

If you want to preview a theme before applying it to your form, click Try It.

Resizing Column Widths
You can change the width of columns. Increase the width to accommodate wider 
fields or to increase the amount of blank space between columns.

To resize the width of a column:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select a column divider. 

If the column divider is not visible, move the cursor over the area where the 
divider is located, then click.

3 Position the cursor over a column divider, then drag left or right.
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Changing the Position and Size of Field Labels
You can change how the labels for fields are positioned on a form.

To change the position of labels adjacent to fields:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Forms > Field Labels.

3 Select Above or Beside.

To change the size of text in labels:

1 Choose Forms > Field Labels.

2 Select Small, Medium, or Large.

Changing the Size of Text
You can change the size of text that is displayed in fields.

To change the size of text in fields:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Click near the field label or the edges of the field to select the field.

Note  If you click inside the field instead of selecting the field, the text size options 
will be dimmed.

Command-click or Shift-click to select multiple fields.

3 Choose Forms > Text Size.

4 Select a size from the list: Smallest, Small, Medium, Large, Largest.

Changing the Shading of Fields
You can change the level of shading that is displayed behind fields.

To change the shading of fields:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select the field by clicking near the field label or the edges of the field.

Note  If you click inside the field instead of selecting the field, the text size options 
will be dimmed.

Command-click or Shift-click to select multiple fields.

3 Choose Forms > Shading.

4 Select a level of shading: None, Light, or Dark.
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Aligning the Right Edges of Fields
You can align the rightmost edges of selected fields within a column.

To align the right edges of fields:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select the fields whose right edges you want to align within a column.

Command-click or Shift-click to select multiple fields.

Tip  To quickly align the right edges of many fields, click in an empty part of the 
form, and while holding down the mouse button, drag to select multiple items.

3 Choose Forms > Align Right Edges.

Adding Text Boxes
Add a text box if you want text such as a heading on your form.

To add a text box:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Insert > Text Box.

An untitled box appears at the bottom of the form.

3 Drag the text box to the desired location, double-click in the text box, and 
start typing.

Adding Image Boxes 
Add an image box if you want an image such as a logo or letterhead to appear on 
every record in your form. 

Tip  Use a media field if you want a different image to appear in every record. For more 
information about media fields, see ”Working with Media Fields” on page 95.

To add an image box:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Insert > Image Box.

An image box appears on the form.

3 Drag the image box to the desired location.

4 Drag an image file from the Finder into the image box.

5 Click in the image box to reposition or change the display size of the image.

For more information, see ”Positioning Images” on page 96 and ”Changing the 
Display Size of Images” on page 97.

Tip  To delete an image box, click near one of its edges to display the border 
around it. Then press the Delete key.
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Adding Horizontal Separators 
A horizontal separator is an object you can add to a form. Separators help organize 
forms by visually separating the items above and below the separator. The appearance 
of the horizontal separator is defined by the theme applied to the form. You can 
change the horizontal separator's width but not its height.

To add a horizontal separator:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Insert > Horizontal Separator.

3 Drag the horizontal separator to the desired location on the form.

Adding Column Dividers 
You can divide up horizontal space on a form with column dividers. All column 
dividers are the same length.

Bento automatically adds a column divider to the right of any item (field or object) 
that you add horizontally to a form. For example, if you drag a field to a form, Bento 
inserts a column divider to the right of that field. If you then add a text box to the right 
of the column divider, Bento inserts another column divider to the right of the text 
box. Bento does not add a column divider if you add an item above or below an 
existing item, or if you delete some (but not all) items from a form.

You can also add column dividers manually to a form.

To add a column divider:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Insert > Column Divider.

3 Drag the column divider to the desired location on the form.

Tip  To delete a column divider, Control-click the divider, then choose Remove 
from Form.
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Adding Spacers
Use a spacer to create a blank space between items on a form. For example, add a 
spacer to separate groups of fields. When editing the form, you can change the 
spacer's width, height, and shading. 

To add a spacer:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Choose Insert > Spacer. 

3 Drag the spacer to the desired location on the form.

Drag the right or bottom edge of the spacer to change its width or height.

4 (Optional) Choose Forms > Shading.

5 (Optional) Select a level of shading.
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Using Table View 
In Bento, you use table view to display text and media in a 
spreadsheet-like format where rows represent records and 
columns represent fields.

This chapter describes how to create and modify records in table view, sort records, 
and rearrange, summarize, and display data in columns. 

About Table View
In table view, you can see your records in rows with the fields in columns (in a format 
similar to a spreadsheet).

To go to table view, choose View > Table View.

Table view gives you flexibility while working with your data. For example, you can:

• see more than one record at a time

• choose which fields are displayed as columns

• sort records in ascending or descending order by using sort commands in the 
column header pop-up menu

• duplicate one or more records

• delete multiple records

• enter, select, copy, and paste values in one or more cells, in a spreadsheet-like 
manner

One record

One field
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• summarize data

• select and drag multiple records to create new collections within one library

• create, view, and edit media fields

You can view a selected record in table view and form view at the same time. Select 
the record, then choose View > Split View. 

In table view, you cannot see related data fields or any of the list field types, such as 
address, email address, file list, message list, and simple list. See ”Working with Related 
Data Fields” on page 92 and ”Working with List Fields” on page 86.

Setting Table View Text Size
You can change the size of text for displaying records in table view.

To change the size of text used in table view: 

1 Choose Bento > Preferences. 

2 For “Table View Text,” select Small or Large.

Selecting Records in Table View

To select one record in table view:

Click a row number. 

To select multiple records in table view:

Click a row number, then Shift-click the last row you want to include in the selection. 
Or Command-click individual rows to include in the selection.

Creating Records in Table View
You can create records in table view or form view.

To create a record for a library or collection: 

1 Select the library or collection you want to add a record to.

2 In table view, choose Records > New Record. Or click in the last empty row 
and start typing.

At the bottom of the window, the record count indicator increases.
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3 Type data in the columns.

If you type data in the last column, Bento creates a new field with the default 
name Field 1.

4 Press Tab to move to the next field in the same record. Press Shift-Tab to move 
to the previous field in the same record.

To add existing records to another collection within the same library: 

Select the records, choose Edit > Add To, then choose a collection from the list. The 
selected records are added to the collection that you chose in the list.

Editing Records in Table View

To edit a record:

1 Select the library or collection that contains the record you want to edit.

2 Double-click a field (table cell). Press Tab to move to the next field in the same 
record. Press Shift-Tab to move to the previous field in the same record. 

Press Command-Return to insert a line break in a text field.

Tip  To edit a choice field in table view, click close to the right edge of the field to 
display the pop-up menu.

Copying and Pasting Data in Table View
You can copy and paste data between Bento records in the same or other libraries as 
well as between Bento and spreadsheet applications such as Numbers and Excel. 

Tip  To duplicate the same data for multiple cells in the same column, see ”Filling Fields 
Automatically” on page 66.

To copy data: 

1 In Bento, select one or more rows of data by clicking the row number. To 
select adjacent rows, select one row, then hold down the Shift key as you 
select adjacent rows. To select nonadjacent rows, hold down the Command 
key as you select rows.

2 Choose Edit > Copy.

Bento copies the selected data to the Clipboard.
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To paste data:

1 Click a cell.

2 Choose Edit > Paste.

Bento creates additional records and columns as necessary. 

Note  When pasting into existing fields, Bento pastes as many values as possible. If 
the data being pasted doesn’t match the field type, Bento gives you the choice of 
rejecting the data or changing the field type to Text.

To paste data into new columns:

1 Click a cell in the empty column after the last column of data.

2 Choose Edit > Paste.

Bento creates new text fields, and additional records as necessary. 

Duplicating Records in Table View

To quickly add a record with the same or similar data as an existing record: 

1 Select the library or collection.

2 Select one or more records, then choose Records > Duplicate Record.

If you duplicated a record in a collection, the record is created in the parent library 
and displayed in the collection.

Deleting Records in Table View

To permanently delete selected records from a library: 

1 Select the library.

2 Select the records, then choose Records > Delete Selected Records or press 
Command-Delete.

In the dialog, click Delete.

To permanently delete selected records from a collection: 

1 Select the collection.

2 Select the records, then choose Records > Remove Selected Records or press 
Command-Delete.

In the dialog, if you click Delete, the records are permanently removed from both 
the library and the collection. If you click “Remove from Collection,” the records 
are removed only from the collection, not the library.
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Sorting Records

To sort records: 

1 Click  near the right edge of a column header.

2 Choose Sort Ascending or Sort Descending.

If you want to sort by two or more fields, sort by the least significant field first, 
followed by the more important field or fields. For example, to sort records by last 
name and first name, first sort by the First Name field, then by the Last Name field.

Working with Fields and Columns in Table View

Creating Fields in Table View

To create a field in table view:

1 For blank libraries, the first field is automatically created with the default 
name New Field. 

2 Double-click the column header and type a new name for the field, then 
press Return.

3 Enter data in the field.

Bento creates a Text field by default. You can change the field to another type. See 
”Changing the Field Type” on page 64. 

4 Press Tab to create another field, where you can continue typing in the same 
record.

5 Repeat steps 2-4 to create as many fields as you want.

Adding Fields in Table View

To add a field before or after a column:

1 Click  near the right edge of a column header. 

2 Choose Add Field Before or Add Field After.

A new column is inserted before or after the current column with the default 
name Field 1.

3 Type a new name for the field.
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Working with Media Fields in Table View
You can create, view, and edit media fields in table view in the same way as you do 
other field types. 

Changing Options for a Field in Table View

To change field options:

1 Click  near the right edge of a column header. 

2 Choose Edit Field.

3 Change the field name or set options.

Note  To change options for a field in Form View, Control-click the field, then choose 
Edit Field.

Completing Text Automatically as You Type
If you need to enter the same text for several text fields, you can change the field 
option to automatically complete the text as you type.

To complete text automatically while typing:

1 Click  near the right edge of the column header for the field.

2 Choose Edit Field.

3 Select “Automatically complete text while typing.”

Duplicating Fields

To duplicate a field:

1 Click  near the right edge of a column header. 

2 Choose Duplicate Field.

Changing the Field Type
You can change the type of some fields to another. Automatic counter, location, and 
address fields, and any fields you access in a shared database can’t be changed to a 

Press the Space bar 
to view the selected 
media field.
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different type. For more information see ”Changing an Existing Field from One Type to 
Another” on page 86. 

To change the field type:

1 Click  near the right edge of a column header. 

2 Choose Change To, then select a field type from the list.

Showing and Hiding Columns

To hide columns: 

1 Click  near the right edge of a column header. 

2 Choose Hide Field. 

To show or hide columns using the Fields pane: 

In the Fields pane, select a field’s checkbox to display the field in table view. Clear the 
checkbox to hide the field in table view. To select multiple fields at once, select one 
field, then Shift-click another field to select all fields in between. To quickly clear them, 
press the Space bar.

When you hide a field in table view, the field and its data are not deleted from the 
library or collection.

Tip  To display more data, hide the Libraries and Fields pane. Choose View > Hide 
Libraries & Fields Pane.

Select checkboxes 
to display fields.
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Deleting Fields in Table View

To delete a field in table view:

1 Click  near the right edge of a column header. 

2 Choose Delete Field.

3 In the dialog, click Delete. 

The fields and their data are permanently removed from the library.

Reordering Columns

To reorder a column:

Drag the column header left or right to a new location.

Resizing Columns

To resize a column: 

Drag the edge of a column header to the width you want.

Filling Fields Automatically
Bento lets you use the content in one or more rows to automatically add or replace 
records below the selected fields.

To fill fields automatically:

1 Select one or more fields in one or more records.

2 Drag the fill handle to copy the fields’ values downward as far as you drag. 

Drag header to 
reorder column.

Drag header edge to 
resize column.

Fill handle
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Summarizing Column Data
The summary row provides an easy way to perform basic operations on the data in a 
column and display the results. The summary row is located at the bottom of table 
view and at the bottom of simple list fields and related data fields. 

To show or hide the summary row, choose View > Show Summary Row or Hide 

Summary Row. Or, click  . 

Depending on the field type, the following summary functions are available.

You can use the Count function on any type of field. You can use the Sum, Average, 
Minimum, and Maximum functions on fields of the following types: Number, Currency, 
Duration, Rating, Automatic Counter, and Calculation (when the result is number, 
currency, or duration). You can also use the Minimum and Maximum functions on 
Date and Time fields.

Name Purpose

Sum Calculates the total of the values in the selected field

Count Reports the number of items that have an entry in the selected field

Average Reports the average of the values in the selected field

Minimum Reports the lowest value of the values in the selected field

Maximum Reports the highest value of the values in the selected field
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To calculate a summary for a column:

Click in the summary row of the selected column, then choose a function from the pop-
up menu. The name of the function and the results are displayed in the summary row.

When you do a search or an Advanced Find, the summary is recalculated based on the 
records that are found. 

Choose Sum in the summary 
row to calculate the total of 
the amounts listed in the 
Budget column.
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Using Grid View 
In Bento, you can work with your media fields (pictures, 
music, and movies) and forms in an easy-to-use grid layout.

This chapter describes how to work with a library’s media fields and form thumbnails 
in grid view, look at a record in grid view and a form view at the same time, filter grid 
view items, set and change labels of grid view items, change the display size of grid 
view items, and work with library folders in grid view. 

About Grid View
In grid view, the media fields in each record of a library or collection are displayed as 
thumbnails in rows. Each thumbnail is a grid view item. If a library or collection does 
not contain any media fields, Bento displays thumbnails of the forms.

Move the cursor back and forth over a grid view item to flash in succession all the 
media fields within the grid view item.

To go to grid view, choose View > Grid View or click .

Media fields displayed 
in grid view

Form thumbnails 
displayed in grid view 
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Viewing the Grid and a Form at the Same Time
You can view a selected record in a form view and grid view at the same time. 

If you are in grid view, select the record, then choose View > Split View or click . 

If you are in form view, select the record, then choose View > Split View or click .

Displaying Grid View Items

To display grid view items: 

Click  to display photos, music, movies, and documents.

Click  to display form thumbnails. 

Setting Grid View Options

To set labels for grid view items: 

1 Click .

You can specify up to two fields.

2 Click the Title pop-up menu, then choose the fields. 

Note  If you don’t want any labels to be displayed, choose the dash symbol in both 
fields.

To set the default media field for grid view items: 

1 Click . 

2 Click the image in the Grid Settings window, then choose a media field.

Changing the Display Size of Grid View Items

To change the display size of grid view items: 

Drag the zoom slider.
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Working with Library Folders in Grid View
When you select a library folder, you see a grid view of all the libraries contained in the 
folder along with information about the number of records and forms in each library.

Move the cursor back and forth over a library to flash in succession all the forms it 
contains.

To go to a specific form:

1 Move the cursor over a grid view item until you see the form you want.

2 Control-click and choose Go to Form from the pop-up menu.

To set the default form displayed for grid view items:

1 Move the cursor over a grid view item until you see the form you want.

2 Control-click and choose Set Default Grid Form from the pop-up menu.

Library 
folder
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9
Using Fields
Bento provides a wide variety of field types to store the kinds 
of information you use in your daily life.

In Bento, you can choose from many different field types to track things such as 
names, addresses, dates, times, prices, images, movies, songs, locations, and lists of 
files. 

This chapter describes the purpose of the field types, how to create and modify fields, 
how to use the Fields pane, and work with the various types of fields that Bento 
provides.

About Fields
Each library contains a set of fields. Each field stores a particular kind of data. In the 
record pictured on the next page, there are several fields. For example, the Project 
Name field contains text.

Once you have created a field, you can use it on multiple forms and tables within the 
same library or collection. When you want to link data between libraries or collections, 
you can use related data fields.

From email, address, phone number, IM account, URL, and location fields you can 
perform tasks such as sending an email message, getting directions to an address, 
displaying a phone number in large type, or capturing a specific location at the time a 
record is created or modified. 
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Field Types
These are the types of fields you can create in Bento: 

Table viewForm view

Text field Fields

Date field

Currency field

Related data field

Choice field

Display phone 
number in large type

Field Type Purpose

Text Store anything you type* 

Number Store numeric data, with formatting options**

Choice Create a pop-up menu in order to select an item from a list

Checkbox Provide an on-off type of choice

Media Store and use image, movie, sound, and PDF files

Simple list Store data that’s in a variety of data types in columnar format 

File list Store and view thumbnails of aliases to files or folders that are on your 
computer 

Message list Display emails, notes, and RSS articles from the Mac OS X Mail application

Related data Store one or more records from another library or collection that are 
related to the current record

Time Choose and store a time of day, in hours, minutes, and seconds, AM or PM

Date Choose and store a date and time value. Displays the date by default and 
can also display the time.

Duration Store an amount of time in weeks, days, hours, minutes, and seconds

Calculation Display the result of a specified calculation. Supported operators are 
addition, subtraction, multiplication, division, and concatenation (joining 
two or more words or sentences).
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Note  The date and time formats vary depending on the current System Preferences 
settings. See Mac Help for information about changing the format.

For a list of field types that you can import data into, see ”Field Types Supported for 
Import” on page 110.

List Fields

When you create address, phone number, email address, URL, and IM account fields, 
Bento creates an associated list field that lets you display multiple addresses, phone 
numbers, and so on for one record. When you enter data in one of these single field 
types, Bento displays the same data in the associated list field. 

For example, suppose you have a form that displays a home phone number in a phone 
number field named “Home Phone Number.” You add work and mobile phone 
numbers to two other phone number fields. Bento creates a list field and displays all 
three phone numbers in that list field, but the work and mobile phone numbers are 
not added to the “Home Phone Number” field you created.

Currency Store an amount of money and display it in the selected currency format

Automatic counter Assign a higher number to each new record

Rating Set the rating value of an item by clicking stars in the field

Encrypted Protect sensitive or confidential data and hide it from view (data is 
displayed as bullets). Encrypted data is stored in your Bento database.

Location Store location information (latitude and longitude) and display a map of 
the location in a web browser. Locations are displayed either in decimal 
degrees or in degrees, minutes, and seconds.

Latitude values range from -90 to 90 degrees. Positive values correspond to 
North latitudes; negative correspond to South.

Longitude values range from -180 to 180 degrees (or 0 to 360 degrees). 
Positive values correspond to East longitudes; negative correspond to 
West.

Address Store all components of a single street address

Phone number Store a phone number, including the area code

Email address Store an email address

URL Store a website, FTP site, or AFP site address***

IM account Store an IM account and service name

Notes:

*Maximum text field size is approximately 2 GB.

**The largest number supported is 263.

***The URL field does not support URL values that contain Japanese 
characters. 

Field Type Purpose
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You can import and export values stored in regular fields (for example, “Home Phone 
Number” in the form shown above) but you can’t import or export values stored in list 
fields. You can see values stored in list fields in form view but not in table view.

Creating Fields 
Follow the steps below to create all types of fields, except calculation, file list, message 
list, related data fields, and location fields. For more information about those field 
types, see ”Creating Calculation Fields” on page 77, ”Creating File List Fields” on 
page 78, ”Creating Message List Fields” on page 79, ”Creating Related Data Fields” on 
page 80, and ”Creating Location Fields” on page 79.

For information about adding a field to a form, see ”Adding Fields to a Form” on 
page 52.

To create fields: 

1 Choose Insert > New Field or press Control-N.

2 Choose a field type.

3 Name the field. 

The name must be unique within the library.

4 Set the options on the field, if any.

5 Click “Create and Continue” or press Command-Return.

6 Repeat steps 2-5 to create additional fields.

7 Click Close.

The fields are added to the Fields pane and the current form. 

On Form 1, you enter data in single 
phone number fields.

Phone number list field created by Bento

Single 
phone 

number 
fields

Form 1 Form 2

On Form 2, Bento displays the data in the 
phone number list field that you entered in 
the single phone number fields.
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8 Use the Fields pane to add or display fields.

Note  In table view, you cannot see related data fields or any of the list field types, such 
as address, email address, file list, message list, and simple list. 

Creating Calculation Fields

To create a calculation field: 

1 Choose Insert > New Field or press Control-N.

2 Choose Calculation.

3 Click Continue.

4 Name the field.

5 Build a formula for your calculation.

6 Choose the correct data type for the result you want and set any other options.

To Do this in the Fields pane

Add a field to a form in form view or split view Drag the field to the form.

Display a field as a column in table view or split view Select a field’s checkbox.

To add Do this

A reference to a field In the Available Fields list, double-click a field name. 

A mathematical or 
text operator

Click an operator button or type an operator in the formula.

The current date Click Today to insert the current date.

The current time Click Now to insert the current time.

A pre-formatted 
value

Click Value, then select a value from the list. Replace the pre-formatted value with 
the value you want.

This is what you see in 
the calculation field for 
the current record.

The formula for the 
calculation. In this 
example, it’s the value in 
First Name, a space, and 
the value in Last Name. 

Operator buttons
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7 Click Create.

The new field is added to the Fields pane and the current form.

Tip  If you are unfamiliar with creating calculations, click Show Examples to see and 
experiment with examples of calculations. 

To create a calculation in a simple list field:

1 Click the pop-up menu in a column header.

2 Choose Change To > Calculation.

3 Choose Edit Column Name to open the calculation dialog.

4 Build a formula for your calculation as described in steps 5 and 6 in the 
procedure above.

Creating File List Fields
Use a file list field to store a list of aliases to files or folders on your computer. Each alias 
contains a path to a specific file or folder in a specific location on your hard drive.

Storing a file alias creates a connection, or link, to the actual file on your computer. 
Moving, renaming, or deleting the file will break the connection to that file. (To re-
establish the connection, you will need to add the file alias into the field again.) 
Aliased files are included when you export a template with data but not when you 
back up or restore data. 

You can quickly open files or applications that are stored in file list fields. For example, 
you could store an alias to a PDF file of a prospective employee's resume. If you 
double-click the PDF icon, the document opens in your system's default application 
for viewing PDF files.

To create a file list field and add files to it: 

1 Choose Insert > New Field or press Control-N.

2 Choose File List.

3 Name the field.

4 Click Create.

The new field is added to the Fields pane and the current form.

Tip  You can see file list fields in form view but not in table view. Choose View > 
Split View so that when you’re working in table view you can also see file list fields 
in form view. 

5 In the bottom-left corner of the table for the file list field, click  or choose 
Insert > File. 

6 In the Open dialog, navigate to the file you want to include in the file list field, 
then click Select.
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You can also drag files from the Finder to the file list field.

7 To open a file in the field, click  and choose Open, or double-click the 
file thumbnail or row in the field.

• Folders are not included when you export a template with data.

• You can preview files that are stored in file list fields with Quick Look. See 
”Previewing Files with Quick Look” on page 89. See also ”Working with Files 
Stored in File List Fields and Message List Fields” on page 88.

• When you export records with a template that includes data, aliased files are 
also exported. For more information, see ”Exporting from a Library, 
Collection, or Smart Collection” on page 113.

Creating Message List Fields
Use a message list field to store aliases to Mac OS X Mail messages, notes, and RSS 
articles that are relevant to a specific record. For example, you can keep a log of 
correspondence linked to a project or event.

Note  Because the message list field stores aliases to messages, when you delete a 
message from Mac OS X Mail, it is also deleted from the message list field. 

To create a message list field:

1 Choose Insert > New Field or press Control-N.

2 Choose Message List.

3 Name the field.

4 Click Create.

The new field is added to the Fields pane and the current form.

Note  You can see message list fields in form view but not in table view.

5 Add Mac OS X Mail items (messages, notes, and RSS articles) to the field.

See ”Adding Mac OS X Mail Items to a Message List Field” on page 88.

Creating Location Fields
In a library such as a vacation journal or customer visit log, you can use a location field 
to track your location (latitude and longitude) and to see a map of the location in your 
web browser. If you have an active connection to a wireless network and Mac OS X 
10.6 installed, you can set up a location field to capture the information automatically.

To create a location field: 

1 Choose Insert > New Field or press Control-N.

2 Choose Location.

3 Name the field.
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4 Select a format: Decimal Degrees or Degrees, Minutes & Seconds. 

Example of a location in Decimal Degrees format:  
37.406300° N, 121.983400° W

Example of a location in Degrees, Minutes & Seconds format:  
37°24’ 23” N, 121°59’0” W

For more information about latitude and longitude values, see ”Field Types” on 
page 74.

5 Select “Automatically enter location” to capture your current location when a 
record is modified or created (requires an active connection to a wireless 
network and Mac OS X 10.6 installed).

Choose “When the record is modified” or “When the record is created.”

6 Click Create.

The new field is added to the Fields pane and the current form.

Note  Bento can enter your current location only if you have enabled Location 
Services in System Preferences. For OS X Lion 10.7, you also need to select the 
Bento checkbox in the Security & Privacy pane of System Preferences to allow 
Bento to determine your location.

Creating Related Data Fields
Use a related data field to display one or more records from a library or collection that 
are related to the record you are viewing. 

For example, if you used the Projects library to manage planning a triathlon and 
wanted to display a list of vendors on a form, you could create a related data field to 
display the vendors that you hired to supply equipment and food. These records come 
from the Vendors collection. If you add a new record in the related data field, the 
record is displayed there but is stored in the Vendors collection. 

You can create a related data field by using menu commands (as outlined below) or by 
dragging a library or collection to a form (see ”Creating Related Data Fields by 
Dragging Records” on page 82).

You can see related data fields in form view but not in table view. 

To create a related data field: 

1 Select the library or collection you want to add a list of related records to.

2 Choose Insert > New Field or press Control-N.

3 Choose Related Data.

4 Name the field.

5 Choose the data source from the list. 

The data source can be a library, collection, or Smart Collection. If you select a 
library, you can add any record from the library to the related data field. If you 
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select a collection, you can only add records from that collection to the related 
data field. 

6 Click Create.

The new field is added to the Fields list and the current form.

7 Click  to switch to grid view for the related data field.

Related data field Drag here to show or hide the 
Notes section.

Go to the selected 
record in its source 
library or collection.

View related 
records in a grid.

Show or hide the 
summary row.

Switch between fields listed in the Fields 
pane (either the data source or library).
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8 Click  to display records from the data source you specified in step 5. 

Select the records you want to add to the related data field, then click Save 
Changes.

• Click  to add a record. If the data source is a Smart Collection,  is 
disabled, since you can’t add records to a Smart Collection.

• Click  to remove the record from the related data field. The record still 
remains in the data source (the library or collection) that the related data field 
is based on.

• If you delete a library or collection that a related data field is based on, the 
related data field is also deleted.

• If a record that appears in a related data field is deleted in its data source, the 
record is also deleted from any other related data field it appears in.

• To change the data in a related data field, click . A window opens, 
showing records from the related library or collection. Any records that are 
already related to the current record are selected and highlighted. To add 
more related records, select records in the window to add, then click Save 
Changes. To remove records, select records in the window to remove, then 
click Save Changes. Records are removed only from the related data field; 
they remain in the data source.

Creating Related Data Fields by Dragging Records

Another way to create a related data field is to begin with a record or records that you 
want to relate to (appear in) another library or collection. The illustration below shows 
how to have related Projects records in the Vendors collection.
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To create a related data field by dragging records:

1 Open the library or collection that has the records you want to relate to 
another library or collection. (For example, open the Projects library.)

2 Switch to table view.

3 Select the record(s) that you want to relate to another library or collection. 
(For example, to relate Projects records to the Vendors collection, select those 
records in the Projects library.)

4 Drag the selected records to the library or collection in the Libraries pane that 
you want to relate the records to. (For example, drag the selected Projects 
records to the Vendors collection in the Libraries pane.)

5 If a relationship already exists between the two libraries, skip to step 6. If 
there is no relationship between the two libraries, Bento asks if you want to 
create a related data field. Click “Choose Records.”

6 In the window of the library or collection that you dragged records to (in step 
4), select the records that you want to relate to. (For example, select the 
vendor(s) you want to relate to the selected projects.)

Then, select the Vendors record(s) that you 
want to relate the Projects records to.

The new related data field, 
with records, on a form in 
the Vendors collection.

First, select and drag records from the Projects library that 
you want to relate to one or more vendors.
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7 Click Add To Record. 

Bento creates a new related data field in the library or collection you dragged 
records to in step 4. (For example, a related data field named Projects is created in 
the Vendors collection.)

8 In the library or collection that you dragged records to in step 4 (for example, 
the Vendors collection), drag the new related data field from the Fields list 
onto the form.

Navigating to Related Records

To navigate among related records:

1 Click a record.

2 Click  to go to the record in its library or collection and view the record’s 
details.

You can edit the record you have navigated to.

3 As you navigate among records in different related data fields, you can 

quickly return to the previously viewed related record by clicking  in the 
navigation bar.

However, once you select an item in the Libraries pane, Bento stops keeping track 

of the related records you viewed and  disappears. 

Using the Fields Pane
The Fields pane displays an alphabetical list of the fields that are available for the 
selected library or collection. Use the Fields pane to select the fields that you want to 
add to the current form (in form view) or to display as columns (in table view). In split 
view, the Fields pane indicates the fields that can be added to the current form or can 
be displayed in table view. 
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In the Fields pane you can:

• create a field by clicking 

• drag a field with  to a form

• select a field’s checkbox to display the field in table view

• double-click field names to modify names and settings. If a field is locked , 
you can’t modify its name or settings because it is either shared with Address 
Book, iCal, or iPhoto, or is reserved by Bento.

• duplicate a field by clicking  and choosing Duplicate

• delete a field and its data by clicking . When you delete a field, it is 
deleted from the library and from collections and related data fields that use 
it.

Note  In the Fields pane in table view, there is no checkbox next to related data fields 
or the list field types (address, email address, phone number, IM account, URL, file list, 
message list, and simple list) because these fields can’t be displayed in table view. 

Field has not been 
added to the 
current form.

Field has been 
added to the 
current form.

Field is 
displayed in 

table view.

Field is not 
displayed in 

table view.

List field has no 
checkbox 

because it can’t 
be displayed in 

table view.

In table view In form view

Address subfields 
can’t be added to 
the form 
individually.
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on; 
d; 
Changing an Existing Field from One Type to Another
You can change the type of some fields to another. Automatic counter, location, and 
address fields, and any fields you access in a shared database can’t be changed to a 
different type.

The information in the table below also applies to changing the data type of columns 
in simple list fields and columns in the notes section of related data fields.

To change an existing field from one type to another:

1 Select a column name in table view.

2 Click  near the right edge of a column header. 

3 Choose Change To, then select a field type from the list. 

Working with List Fields
Some types of list fields (address, phone number, email address, URL, and IM account) 
have a pop-up menu from which you can quickly perform actions such as displaying 
the selected phone number in large type, getting directions to or from the selected 
address, and displaying a map for the selected address.

Convert 
from:

Convert 
to: 
 
Text Number Choice Checkbox Time Date Duration Currency Rating Phone

Other 
list 
fields

Calculati
Encrypte
Media

Text   •   •   •   •   •   •   •   •   •   •   •
Number   •   •   •   •   •   •
Choice   •   •   •   •   •   •   •   •   •   •
Checkbox   •   •   •
Media   •
Time   •   •
Date   •   •
Duration   •   •
Calculation   •
Currency   •   •   •
Rating   •   •   •
Encrypted   •
Phone 
number

  •

Email 
address

  •

URL   •
IM account   •
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Sending Emails
In form view and table view, you can quickly send emails to your family, friends, or 
colleagues. 

To send an email in form view:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Click  next to the email address field. 

If you see , the email address is not valid. 

3 The default email application opens and displays a blank email message 
addressed to the name in the email address field. 

4 Compose the message and send it.

To send an email in table view:

1 Select one or more email address fields.

You can select any block of fields to quickly select multiple email address fields. 

2 Choose Edit > Email Selected Address or press Shift-Command-M.

3 The default email application opens and displays a blank email message 
addressed to the name or names in the selected email address field or fields.

4 Compose the message and send it.
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Adding Mac OS X Mail Items to a Message List Field
In message list fields, you can store aliases to Mac OS X Mail messages, notes, and RSS 
articles that are relevant to a specific record. For instructions on creating message list 
fields, see ”Creating Message List Fields” on page 79.

Note  Storing an alias in Bento does not store the email message in Bento; it simply 
links to the message that’s in Mail. If you remove the message from Mail, the message 
will also be removed from Bento.

To add a Mac OS X Mail message, note or RSS article to a message list field:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 In the bottom-left corner of the message list field, click  to open the Mac 
OS X Mail application.

3 In Mac OS X Mail, select a folder that contains messages, notes, or RSS articles.

4 Drag one or more items to the message list field.

Tip  Click  to show the fields for the message list field in the Fields pane.

To open the items in Mac OS X Mail, see ”Working with Files Stored in File List 
Fields and Message List Fields” on page 88.

Working with Files Stored in File List Fields and Message List Fields
When browsing records, you can quickly open files or applications stored in file list 
fields, and Mac OS X Mail messages, notes, and RSS articles stored in message list 
fields.

To open files stored in a file list field or message list field:

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select one or more items in the file list field or message list field. Command-
click to select nonadjacent items.

3 Click  and choose Open (file list) or  (message list), or double-click 
the items you want to open.

4 The application associated with each item starts and displays the contents of 
the items.

For example, if you double-click a PDF file and a QuickTime movie file, the Mac OS 
X Preview and QuickTime Player applications start and display the PDF file and the 
QuickTime movie file. If you double-click an email message, note, or RSS article, 
the Mac OS X Mail application starts and displays the Mac OS X Mail item.
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To view files stored in a file list field:

1 Click  to display the items in a table. 

2 Click  to switch back to the grid format. 

Click  to change the display size of items in grid format.

To email a file from a file list field: 

1 In the file list field, select one or more filenames that you want to email.

2 At the bottom-left of the file list field, click , then choose “Send in 
Mail.” 

The Mac OS X Mail application opens.

3 Enter the recipients’ names, make any changes to the subject and message, 
then click Send. 

Previewing Files with Quick Look
With Quick Look, you can quickly view the contents of an item in a file list field or 
message list field without opening it. 

To preview a file: 

1 Select a form in the navigation bar or choose View > Form View > Form Name.

2 Select one or more items in a file list field or message list field.

3 Click  and choose Quick Look filename or press the Space bar.

The content you see depends on the type of file. If it’s an image, you see a smaller 
version of it. If it’s a text document, you can read the text and scroll to see more. If 
you selected multiple items, you can use the arrow keys or the buttons at the 
bottom of the Quick Look window to move from one item to another.

Working with Simple List Fields 
You work with columns and rows in simple list fields in much the same way as you do 
in table view. This section tells you how to do some things with simple list fields. For 
more information about working with columns, see ”Working with Fields and Columns 
in Table View” on page 63. 

To add information to a simple list, first you need to create a field of the type Simple 
List. See ”Creating Fields” on page 76.
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You can drag a simple list field from the Fields pane onto a form and start typing to 
add data that is relevant to the record. Bento creates a text field by default, but you 
can change the field type of the column.

You can work with media data in simple list fields, just as you do in media fields. For 
more information, see ”Working with Media Fields” on page 95. Also, you can create, 
view, and edit calculations in simple list fields. For more information see ”Creating 
Calculation Fields” on page 77.

To add data to a simple list field:

1 Click in a field of the column to which you want to add data, then type in the 
field.

2 Press Tab to create another column, where you can continue typing in the 
same record.

Note  You can also copy and paste data from table view or a spreadsheet file into a 
simple list field.

To add a column in a simple list field:

Click  near the right edge of a column header, choose Add Column Before or Add 
Column After. Type a new name for the column, then press Return or Tab.

To change the name of a column in a simple list field:

Do one of these:

• Double-click the column name, type a new name, then press Return or Tab.

• Click  near the right edge of a column header and choose Edit Column 
Name, then change the column name in the dialog. There, you can also 
change whether you want Bento to complete text automatically as you type 
in the field. 

To change a column from one data type to another:

1 Click  near the right edge of a column header. 

2 Choose Change To, then select a data type from the list.

Note  Not all data types can be changed. For more information, see ”Changing an 
Existing Field from One Type to Another” on page 86. 

To delete a column in a simple list field:

Click   near the right edge of a column header, then choose Delete Column.
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To show or hide columns in a simple list field:

1 Click  in the lower-right corner of the simple list field. 

2 To show a column, in the Fields pane, select the checkbox next to the column 
name. 

To hide a column, do one of these:

• Click   near the right edge of a column header, then choose Hide Column. 

• Click  in the lower-right corner of the simple list field. Then, in the Fields 
pane, deselect the checkbox next to the column name. 

To show or hide the summary row in a simple list field:

Do one of these:

• Choose View > Show Summary Row or Hide Summary Row. 

• Click   in the lower-right corner of the simple list field. 

For more information about the summary row, see ”Summarizing Column Data” on 
page 67.
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To switch between views in the Fields pane:

Click  in the lower-right corner of a simple list field to switch between displaying 
columns in the simple list field and displaying the fields in the library in the Fields 
pane.

Working with Related Data Fields
In a related data field, you can store information about records that is relevant to the 
data source but isn’t linked to the data source. This information is stored in a separate 
section of the related data field called notes. 

For example, in a Recipes library that has a related data field linked to the Ingredients 
library, you could store information such as the required amount of each ingredient in 
a recipe in the notes section of the Ingredients related data field. In other fields in the 
notes section, you could add details about how to prepare the ingredient or the name 
of the store where you purchased it. The information in the note fields is not stored in 
the Ingredients library.

Click to switch 
between the displays 
in the Fields pane.

Fields pane displaying columns 
in the simple list field

Fields pane displaying fields 
in the library
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You can create, view, and edit calculations in the notes section. For more information 
see ”Creating Calculation Fields” on page 77.

To display the notes section:

Position your cursor on the right edge of a related data field. When the cursor changes 

to , drag it to the left. You see the notes section with the first notes column (named 
New Column) created for you. Type a new name for the column, then press Return or 
Tab.

To add a column in the notes section:

Click  near the right edge of a column header, choose Add Column Before or Add 
Column After. Type a new name for the column, then press Return or Tab.

To change the name of a column in the notes section:

Do one of these:

• Double-click the column name, type a new name, then press Return or Tab.

• Click  near the right edge of a column header and choose Edit Column 
Name, then change the column name in the dialog. There, you can also 
change whether you want Bento to complete text automatically as you type 
in the field. 

To change a column from one data type to another:

1 Click  near the right edge of a column header. 

2 Choose Change To, then select a data type from the list.

Note  Not all data types can be changed. For more information, see ”Changing an 
Existing Field from One Type to Another” on page 86. 

 Notes fields

Related records from 
the Ingredients library

Click to display records 
in a grid format.
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To show or hide the summary row:

Do one of these:

• Choose View > Show Summary Row or Hide Summary Row. 

• Click  . 

For more information about the summary row, see ”Summarizing Column Data” on 
page 67.

To delete a column in the notes section:

Click   near the right edge of a column header, then choose Delete Column.

To sort records in related data fields:

Click the pop-up menu in a column header, then choose Sort Ascending or Sort 
Descending. 

To display related data records in a grid format:

Click  to display the records in a grid. 

To set labels for grid view items:

1 In grid view, click . 

2 Click the Title pop-up menu, then choose up to two fields. 

Each field’s data is displayed as a label for the grid items.

If you don’t want a label to be displayed, choose the dash symbol for the field.
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Working with Media Fields
You can add many types of sound, image, and movie files to a media field, including 
JPEG, QuickTime, and MP3 files.

If you add a sound file that you purchased from the iTunes Store, you may have to 
enter the account name and password for the account that was used to purchase the 
sound file.

Note  You can’t add movie files that you purchased from the iTunes Store.

Tip  Use an image box if you want an image such as a logo or letterhead to appear on 
every record in your form. For more information about image boxes, see ”Adding 
Image Boxes” on page 56.

Taking Photos
If your computer has an iSight camera, you can take pictures with it to use in your 
forms.

To take a photo:

1 Click an empty media field. 

For information about how to create a media field, see ”Creating Fields” on 
page 76.

2 Click .

3 In the window, click , then wait for the image to appear.

4 Optional: Click , then select a special effect to apply to the photo. 

5 Click Set to save and load the image into the media field. 

Tip  To back up a photo, export it. For more information, see ”Exporting Images” on 
page 97.
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Adding Media Files
You can add sound, image (pictures, graphics, and so on), and movie files to media 
fields. Image files include images from the web or other applications such as iPhoto. 

To add a media file:

1 Click in the media field.

2 Drag a media file from the Finder, iPhoto, or iTunes to the media field or click 

 to choose a file. 

Except for iTunes files, when you add a media file, Bento copies it into the 
bento.bentodb file. When you add an iTunes file to a media field, Bento creates an 
alias to the file.

If you don’t want to copy the media file into Bento, hold down the Option key 

after you start dragging the media file to the media field. An arrow  appears on 
the thumbnail. Bento creates an alias that contains a path to a specific file in a 
specific location on your hard drive. If you use an alias for the media file, and then 
move or rename the original media file, the alias to it is broken. 

3 In the Open dialog, select the image you want to add, then click Open.

Playing a Movie or Sound File
Playing a movie or sound file in Bento is similar to how you play a movie or sound file 
in QuickTime Player.

To play a movie or sound file: 

1 Click in the media field.

2 Click  in the playbar to start the movie or sound file.

Drag the slider up or down to adjust the volume.

3 To pause the movie or sound file, click . To restart playing the movie or 

sound file, click . 

Positioning Images 
You can move an image in any direction within a media field. 

To position an image:

1 Click in the media field. 

2 Drag the image within the field.

If you drag the image out of view, select Fit to Frame to bring it back into view.
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Changing the Display Size of Images
You can change the display size of an image within the media field. 

To change the display size of an image:

1 Click in the media field.

2 Drag the zoom slider to zoom in or out on the image.
 

3 Select Fit to Frame to make the image the same size as the field.

Exporting Images
You can export (save) any image file with a different name or in a different location. It 
is saved in its original file format.

To export an image:

1 Click in the media field.

2 Click . 

3 In the Save As dialog, navigate to the folder where you want to save the 
image file.

4 Type a name, then click Save.

Deleting Media Files
When you delete a media file from a record, it is permanently deleted from its library 
and from any collections within the same library. 

To delete content in a media field:

1 Click in the media field.

2 Press the Delete key or choose Edit > Clear.

Working with Encrypted Fields
In Bento, to encrypt data in a field, you must first create a field of the type encrypted. 
See ”Creating Fields” on page 76.

You can store sensitive data in encrypted fields. When you enter data in encrypted 
fields, it is securely stored in your Bento database and can only be read within Bento. 
Encrypted data in a locked field is displayed as bullets.
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If you attempt to enter data in an encrypted field and you have not already set the 
Database Password, you won’t be able to proceed until you do so. For information 
about setting the Database Password, see ”Setting a Password for Your Bento 
Database” on page 98.

You can search encrypted fields if they are unlocked. For more information about 
searching, see ”Search Field and Advanced Find” on page 25.

Setting a Password for Your Bento Database
You can set a password to protect your database. The Database Password also protects 
all encrypted fields. To set a password for accessing a shared database, see ”Setting a 
Password for a Shared Database” on page 34.

To set the Database Password:

1 Choose Bento > Preferences.

2 Click Security at the top of the window.

3 Select Use Database Password.

4 For Enter Database Password, type the password. Maximum length is 20 
characters.

5 For Confirm, type the password again.

6 (Optional) For Password Hint, type a word or phrase to help you remember 
the password.

7 Keep your password in a safe place. 

Important  If you forget your password, it is not possible to recover it. 

8 Click Set Password.

9 Click the lock to prevent further changes.

To clear the Database Password:

1 Choose Bento > Preferences.

2 Click Security at the top of the window.

3 Click the lock to make changes.

4 Enter your Database Password, then click Submit.

5 Deselect Use Database Password.

You can’t deselect Use Database Password if there are encrypted fields in use.
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Locking Bento
You can lock Bento to hide the Bento window and protect your data.

To lock Bento:

1 Choose Bento > Preferences.

2 Click Security at the top of the window.

3 Click the lock to make changes.

4 Select “Require Database Password when Bento starts.”

5 Choose Bento > Lock Bento.

The Bento window is hidden.

To make the Bento window visible again:

1 Enter your Database Password.

2 Click Submit.

Locking and Unlocking Data in Encrypted Fields
Locking encrypted fields helps keep your data safer, since you have to first unlock the 
fields before viewing the data. After you lock encrypted fields, you can’t modify their 
contents until you unlock them. 

To lock data in all encrypted fields:

In form view, select an encrypted field and click  next to the field. Then select Lock 
Encrypted Fields. In table view, select an encrypted field and click the pop-up menu in 
the column header, then choose Lock Encrypted Fields.

A  appears next to all encrypted fields in form view, and bullets replace the 
contents of all encrypted fields.

Note  You can’t copy data from encrypted fields, and you can’t paste into encrypted 
fields when they are locked.

To unlock data in all encrypted fields:

1 In form view, select an encrypted field and click  next to the field. Then 
select Unlock Encrypted Fields. In table view, select an encrypted field and 
click the pop-up menu in the column header, then choose Unlock Encrypted 
Fields.

2 Enter your Database Password, then click Submit.

A  appears next to all encrypted fields in form view.
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Showing or Hiding Data in Encrypted Fields

To show data in an encrypted field:

In form view, select the encrypted field and click . In table view, click the pop-up 
menu in the column header, then choose Show Encrypted Field Contents.

The data you encrypted replaces the bullets.

To hide data in an encrypted field:

In form view, select the encrypted field and click . In table view, click the pop-up 
menu in the column header, then choose Hide Encrypted Field Contents.

Bullets replace the encrypted data.

Note  You can’t copy and paste when the data in encrypted fields is hidden.

Working with Location Fields
In a library such as a vacation journal or customer visit log, you can use a location field 
to track your location (latitude and longitude) and to see a map of the location in your 
web browser. 

For information about creating location fields and setting options for them, see 
”Creating Location Fields” on page 79.

To enter latitude and longitude values:

1 Select a location field. 

2 In the Latitude field, enter a value from -90 to 90 degrees. 

Press Option-Shift-8 to enter the degrees symbol (“ ° ”).

3 In the Longitude field, enter a value from -180 to 180 degrees (or 0 to 360 
degrees). 

Decimal Degrees format (Example: 37.406300° N, 121.983400° W). If you type a 
value that is a positive decimal number, Bento adds the degrees symbol and the 
direction (N or E) automatically. For a negative decimal number, Bento adds the 
degrees symbol and the direction (S or W) automatically.

Degrees, Minutes & Seconds format (Example: 37°24’ 23” N, 121°59’0” W). Type 
the degrees value (positive or negative), followed by the degrees symbol (“ ° ”), 
then the minutes value followed by the minutes symbol (‘), then the seconds 
value followed by the seconds symbol (“).

Tip  If you want Bento to format a coordinate for you, type just the degrees value 
(without the degrees symbol). Bento provides default values for the rest of the 
coordinate. Then you can change the minutes, seconds, and direction values as 
needed.
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To display a map of the selected location:

In form view, select a location field, then click . The map is displayed in your default 
web browser.

To get directions to or from the selected location:

In form view, select a location field, click  next to the field, and choose Directions To 
or Directions From.

To capture your current location:

In form view, select a location field, click  next to the field, and choose Set to 
Current Location.

Note  This option requires an active connection to a wireless network and Mac OS X 
10.6 installed. 
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Importing, Exporting, and Printing 
This chapter describes the various ways you can import and 
export information so others can view or use it. You can also 
print information to share with others. 

A good way to start using Bento is by importing existing information. Bento supports 
importing information from a variety of file formats: comma-separated values (.csv) 
file, tab-separated values (.tab) file, Numbers, Excel, Excel 2008, and library template. 
For example, you can import .csv files created from spreadsheets, exported from other 
databases, or downloaded from banking or stock websites.

If you need to share your information, you can export your Bento information as a .csv, 
.tab, Numbers, Excel 2008, or library template file. You can export records from a 
library (including shared libraries) or from a collection. You can also export a group of 
records from a search or Advanced Find. If you create a library with forms that you 
want to give to another Bento user, you can export the library as a library template file 
(with or without data). 

Bento lets you print information from form view, table view, split view, and from 
search and Advanced Find. You can also print labels from within Bento.

About Comma-Separated and Tab-Separated Files
A comma-separated values file (.csv) or a tab-separated values file (.tab or .tsv) is a file 
that represents a table of data. Each column/field value is separated by a comma or a 
semicolon (for .csv) or a tab character (for .tab or .tsv). Each record is separated by a 
carriage return. One record appears in each row of the data file. Often, the first row of 
data in the .csv file represents the column names for the table, making it easier to 
match the data to the fields in an existing library. 

Note  Some locales may use a different separator in .csv files rather than commas. The 
default separator is defined by your locale setting. 
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Exporting .csv and .tab Files from Other Applications 
Note  When exporting .csv or .tab files, make sure the filename extension is “.csv” or 
“.tsv”; the extension must be in lowercase letters. Otherwise, Bento will not recognize 
.csv or .tab files correctly.

For the best results when importing information into Bento, follow these guidelines: 

• Export your data from the other application as a .csv or .tab file.

• If your Excel worksheet contains multiple tables, put each table in its own 
worksheet, and make sure the column names are in the first row.

• Note whether your .csv or .tab file contains a row with the column names. 
Bento can use the values in that row as field names when you import the 
information into a new library. In Bento, these field names appear as labels in 
form view and as column names in table view. 

• Make a note of the order of the fields in the .csv or .tab file. If the file doesn’t 
contain a row with the column names, you can refer to your notes to 
manually name the fields when you import the file. 

• ClarisWorks and AppleWorks create tab-separated files when you select the 
ASCII Text option in the Save As dialog. Make sure you add the “.tab” 
extension to the filename when you save an AppleWorks 6 file that you plan 
to import into Bento. For example, if you have an AppleWorks file named 
“MyData” save it as “MyData.tab” so that Bento recognizes it as a tab-
separated file.
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Correcting .csv Files 

If you are having difficulty importing a .csv file, open it in a text editor (such as 
TextEdit) and do the following:

• Put double quotation marks around field values that have embedded 
commas. 

For example: “10,000 Donors“

• Put double quotation marks around field values with leading or trailing 
spaces.

• Put double quotation marks around field values that contain embedded line-
breaks. 

• Put double quotation marks around field values that contain double 
quotation marks. Change the embedded double quotation marks into a pair 
of consecutive double quotation marks. 

For example: “She said ““I will be there”” in her email.“

Example of a comma separated (.csv) file
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Importing Information into Bento 
When you import information into Bento, you can either create a library or import the 
information into an existing library or collection. 

Creating a Library by Importing
You can create a library when you import a file.

Click the pop-up to set 
the field type. If you don’t 
want to create the field, 
choose “Do not create.” 

Enter the name for the 
new library. 

Use the arrows to go to 
the row that contains 
column names, then 
select “Use this record’s 
values as column 
names.” 

Choose a file. The 
options you see here 
vary according to the file 
format of the selected 
file.
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To create a library by importing: 

1 Choose File > Import > File. 

2 Click Choose, then select the file you want to import in one of the following 
file formats: .csv, .tab, .tsv, .numbers, .xls, .xlsx. 

• For .csv, .tab, or .tsv files, in the section “Choose the format,” choose 
Comma separated, Semicolon separated, or Tab separated.

• For Numbers files, use the pop-up menus to select a sheet, then a table.

• For Excel files, use the pop-up menu to select a worksheet.

3 For “Choose a target,” choose New Library, and enter a unique name for the 
library. 

4 Indicate whether the file contains a row with values that you want to use as 
field names. 

• If the file contains a row with column names, click the arrow buttons to 
go to that row and select “Use this record’s values as column names.” 

Bento uses the values in this row as the new field names. 

• If the file does not contain a row with column names, clear “Use this 
record’s values as column names.” 

Bento assigns default names to each new field. To change a default field 
name, double-click the field name and type a unique name. 

5 Bento sets the field types to “Text” by default. To change a field’s type, click 
the pop-up menu and select a new field type. 

• If there is a column that you do not want to import, click the pop-up 
menu and select “Do not create.“

• For information on the field types supported for import, see ”Field Types 
Supported for Import” on page 110. 

6 Click Import. 

When the import is done, Bento displays the records, which you can view in table 
view, form view, split view, or grid view. 

Importing into an Existing Library
If you want the information that you are importing to go into an existing library, 
import the file into that library. Bento creates new records in the library. 

You can also import a file into a collection. When you choose a collection as the target 
for the import, Bento creates new records in the library that contains that collection, 
and adds the new records to the collection. 
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To import information into an existing library or collection: 

1 Choose File > Import > File. 

2 Click Choose and choose the file you want to import in one of the following 
file formats: .csv, .tab, .tsv, .numbers, .xls, .xlsx. 

• For .csv, .tab, or .tsv files, in the section “Choose the format,” choose 
Comma separated, Semicolon separated, or Tab separated. 

• For Numbers files, use the pop-up menus to select a sheet, then a table.

• For Excel files, use the pop-up menu to select a worksheet.

3 For “Choose a target,” choose the library or collection that you want your 
information to be added to. 

The example above shows the “Address Book” library as a target library. 

Click the pop-up and 
select a field name to 
manually map the fields 
set to “Do not import.” 

Use the arrows to go to 
the row that contains 
column names, then 
select “Use this record’s 
values as column 
names.”

Choose a file. The 
options you see here vary 
according to the file 
format of the selected file.
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4 Indicate whether the file contains a row with values that you want to use as 
column names. 

• If the file contains a row with column names, click the arrow buttons to 
go to that row and select “Use this record’s values as column names.” 

Bento reads the column names in the file, and attempts to match them to the 
field names already defined in the library or collection you have selected. 
Bento maps the column names to field names when their names match 
exactly. For any names that do not match, Bento sets the field name to “Do 
not import” and you need to map the fields to the columns manually. You can 
also manually map the record values that Bento has matched. 

• If the file does not contain a row with column names, clear “Use this 
record’s values as column names.” 

Without column names, Bento has no way to map the record values to the 
column names. Bento sets the column names to “Do not import” and you 
need to map the fields to the columns manually. 

5 If the new field’s name matches a column name in the file, Bento maps that 
column’s records values to the new field. Otherwise, you can map your 
column values to the new field manually.

For record values that are set to “Do not import,” click the pop-up menu and select 
the column name or record value to manually map it to the adjacent field name. 

6 If there is no field that you can map a given field to, you can create a field. To 
do this, click Add Field. Bento opens the Create a Field dialog to allow you to 
add a field to the library. 

7 (Optional) See how the record values are mapped to the field names by 
clicking the arrow buttons to move through the record contents. 

8 Click Import. 

When the import is done, Bento displays the records, which you can view in table 
view, form view, split view, or grid view. 
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Importing a Library Template
A library template file contains all of the forms, collections, Smart Collections, table 
view settings, label settings, and related libraries (if they were included at the time of 
export) of an exported library. Depending on the settings used to create the library 
template, it may or may not contain records.

To import a library template: 

1 Choose File > Import > Template.

2 Choose a library template file.

3 Click Open.

4 Bento adds the library, collections, and Smart Collections contained in the 
library template file to the Libraries pane. If the library template file contains 
multiple libraries, all of them are added to the Libraries pane.

Additional Ways to Import Information
In addition to the File > Import menu items, Bento provides the following ways to 
import information: 

• Choose File > New Library from Template to open the New Library dialog. 
Then click Import Data.

• Drag a data file (Text, Numbers, Excel format) to the Libraries pane in Bento. 

• Drag a data file (Text, Numbers, Excel format) to a specific library or collection 
in the Libraries pane in Bento. 

• Drag a library template file or data file (Text, Numbers, Excel format) to the 
Bento application icon. 

Field Types Supported for Import 
You can import data into the field types listed in the following table.

Choose a library 
template file. 
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For this field type This data can be imported 

text 

choice 

address 

phone number 

IM account 

encrypted (when 
unlocked)

Any text 

email address Any text, but a valid email address must include the @ character. 

URL Any text, but the URL field does not support URL values that contain 
Japanese characters. 

checkbox “1” for checked; “0” for not checked 

“True” for checked; “False” for not checked 

“Yes” for checked; “No” for not checked

number 

currency 

Numeric data 

rating A number between 0 and 10 

time  Numeric data in the form HH, HH:MM, or HH:MM:SS, optionally with 
“AM” or “PM” where: 

• HH represents the hour (between 0 and 24, if you don’t use “AM” or 
“PM”, or between 0 and 12 if you use “AM” or “PM”)

• MM is minutes (between 0 and 59)

• SS is seconds (between 0 and 59).

For example: 12:59:59 PM 

date  Numeric data in the form DD, MM/DD, or MM/DD/YYYY, where: 

• DD is the day (between 1 and 31, as valid for the month)

• MM is the month (between 1 and 12)

• YYYY is the year (between 1 and 9999).

A date field can also contain a “time” value, as described for the time 
field. 

Note: These formats vary depending on the current system date settings.
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You cannot import into these field types: file list, media, automatic counter, 
calculation, related data, message list, or encrypted (when locked). 

When you import into an address, phone number, email, URL, or IM account field, the 
data is automatically added to the associated address list, phone number list, email 
address list, URL list or IM account list field. 

See ”Using Fields” on page 73 for additional information on field types. 

Note  The message “Some values in some records can’t be imported” in the Import 
dialog means that one or more record values are not valid for the type of field to which 
you are importing the values. For example, you cannot import alphabetic text into a 
number field or into a date field. You can either change the field type to match the 
data, or proceed with import. If you proceed with import, the invalid values will not be 
imported. Other options are to change the contents of the file or to import the data 
into a Text field. Text fields accept all values.

Exporting Information from Bento
Bento can export information into a .csv, .tab, Numbers, or Excel 2008 file from a 
library, from a collection, from a Smart Collection, or from the results of a search or 
Advanced Find. 

Bento can export a library into a library template file. This is a good way to preserve 
the structure of an individual library or give a library to another Bento user. A library 
template file contains all of the forms, collections, Smart Collections, table view 
settings, and related libraries (if they were included at the time of export) of an 
exported library. You can include or omit records from the library template. You can 
give the library template file to other Bento users.

duration Text representing a duration in weeks, days, hours, minutes, and seconds. 
The text may use the following abbreviations: 

• w for weeks 

• d for days 

• h for hours 

• m for minutes 

• s for seconds 

For example, the following are all valid duration text: 

• 8 days, 5 hours 

• 8d,5h 

• 8d5h 

location Location information (latitude and longitude) either in decimal degrees 
or in degrees, minutes, hours.

For this field type This data can be imported 
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You can also export (submit) a template that you’ve designed to the Bento Template 
Exchange website, so others can use it. You can submit only the template and not any 
records associated with it. For more information, see ”Submitting Templates to the 
Bento Template Exchange” on page 114.

Exporting from a Library, Collection, or Smart Collection
When you export records from a library or collection, you can choose to export all the 
values from all of the fields in table view or only those fields that are currently 
displayed in table view.

Exported files (for example, in a file list field) cannot exceed 200 megabytes (MB) of 
data each.

To export from a library, collection, or Smart Collection: 

1 Select the library, collection, or Smart Collection that contains the 
information you want to export. 

2 Choose File > Export.

3 Click Numbers, Excel, Text, or Template. 

To export a file compatible with versions of Excel earlier than Excel 2008, export a 
Text file.

• For Numbers, Excel, or Text, choose “All records” or “Only current records.” 

• For Template, choose any related libraries that you want to export. To 
export records with the template, including those of any related libraries 
you have chosen, select “Include records in template.” (Bento by default 
includes records.) Aliased files referenced in any file list fields are also 
exported when this option is selected.

You can include 
related libraries and 
their data when you 
export a library.

You can export 
records.
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4 Choose how to export the data. 

• For Numbers, Excel, or Text, choose “All table view fields” or “Only fields 
displayed in table view.” 

• For Text, choose Comma separated (.csv), Semicolon separated (.csv), or 
Tab separated (.tab).

5 Click Next, then specify the filename and location for the file. 

Bento exports the specified data from the library, collection, or Smart Collection 
into a file with the name you specify. 

Submitting Templates to the Bento Template Exchange
You can submit your own Bento templates to the Bento Template Exchange website, 
either directly from within Bento or through your web browser. You cannot include 
records with the template. 

To learn more about the Bento Template Exchange, including how to submit 
templates directly to the website and how to download other designers’ templates, 
choose Help > Bento Template Exchange.

Note  Before you submit templates to the Bento Template Exchange, make sure your 
computer is connected to the internet.

To submit a template from within Bento:

1 Open the library or collection whose template you want to submit.

2 Choose File > Export, then click Template in the dialog that appears.

3 Select the names of any related libraries you want to include.

4 Make sure “Include records in template” is deselected; you cannot submit 
records with the template. 

Important  If you try to submit a template with records, Bento will remove 
them before submitting the template.
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5 Click “Send to Template Exchange.”

6 In the template exchange dialog, enter the required information, and follow 
the onscreen instructions. Continue following the onscreen instructions in 
each dialog that appears.

Bento compresses the template and places the file (which is the library name with 
the .zip filename extension) on the desktop of your Mac. If a file with the same 
name already exists, Bento appends a number to the filename. This file is removed 
from the desktop after the template has been successfully submitted to the Bento 
Template Exchange. A template file (compressed) can be up to 20 MB in size. 

7 When you’re asked to choose the file to upload, select the compressed 
template (.zip) file from the desktop folder, then continue following the 
onscreen instructions.

Don’t click Close until you see a confirmation that your template was uploaded; 
doing so will stop the uploading process.

Exporting from Search or Advanced Find 
If you want to export a subset of records, you can use search or Advanced Find to 
narrow the set of records in a library or collection, and then export the records. 

To export from a subset of records: 

1 Use the search field or Advanced Find to create a subset of records. 

See ”Search Field and Advanced Find” on page 25. 

• For search, the set of records that matches the criteria is displayed as you 
type the search string.

• For Advanced Find, click Find to display the set of records that matches 
the criteria.

Make sure this option 
is not selected.

Then click this button.

You can include 
related libraries 
when you submit 
your template. 
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2 Follow steps 2-5 in ”Exporting from a Library, Collection, or Smart Collection” 
on page 113.

Bento exports the table view field data from the subset of records into a file with 
the name you specify. 

Additional Ways to Export Information 
In addition to the File > Export menu item, Bento provides another way to export 
information as a file: 

• Drag a library or a collection icon from the Libraries pane in Bento to the 
desktop or to any folder in a Finder window. Bento exports the field data from 
all the records in the library or the collection into a file with a name matching 
the library or collection name and the file format matching the current Export 
Format setting in the Preferences dialog.

Export Considerations for Specific Field Types
If you are exporting into a Numbers, Excel, or Text file you cannot export: 

• Contents of address list fields, phone number list fields, email list fields, URL 
list fields, IM account list fields, or message list fields. However, you can export 
data from individual address, phone number, email, URL and IM account 
fields that are displayed in table view. 

• Contents of locked encrypted fields.

For files that you 
export by dragging 
them to the Finder, 
select a file format.
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• Information displayed in related data fields. 

• File aliases stored in file list fields. 

• Movie and sound files you have added to media fields. To export images, see 
”Exporting Images” on page 97.

Printing Information 
You can print information from a library, from a collection, or from the results of a 
search or Advanced Find. 

Printing from Libraries and Collections
When you print records from a library or a collection, the selected view determines the 
appearance of the printed output. In split view, the location of the insertion point at 
the time of printing determines the appearance of the printed records. 

You can also print information on labels. See ”Printing Labels” on page 119.

To print records from a library or collection: 

1 Select the library or collection that contains the information you want to 
print. 

2 Select the form or table view that contains the fields you want to print. 

3 Choose File > Print > Table/Form.

4 Specify options for the printed output. 

• Select “Selected records only” to print the currently viewed record only 
(in form view) or to print all selected records (in table view). 

• Select “All displayed records” to print all of the records in the currently 
viewed library or collection. 

• Select “Don’t print background” to print without the background in form 
view or without the alternating row colors in table view. This option 
prints in black and white without any background color and saves ink.

• When printing form view data, select “Print one record per page” to print 
one record per page.

• When printing form view data, select “Form only (no data)” to print a 
blank form.

• Select additional options to include the title banner, page numbers, date, 
and time. 

• When printing table view data, select “Fit to width” to scale the columns 
to fit on one page, instead of printing them across multiple pages.

• When printing form view data, select “Show field labels” if you want field 
labels printed.
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• When printing form view data, select “Show field borders” if you want to 
include field borders. (The setting of this option when you open the Print 
dialog box depends on the setting of View > Show Field Borders.)

• To create custom page margins for form view, see ”Creating and Using 
Custom Page Sizes for Form View” on page 118. 

Tip  If you want to prevent certain fields from being printed (for example, Date Created 
or Date Modified), drag them off the form before you print. Remember to drag the 
fields back on to the form after printing is finished. You can also duplicate the form 
and then remove the fields that you don’t want printed (giving you one form for 
viewing and another for printing).

Creating and Using Custom Page Sizes for Form View
You can create and then use custom page sizes when you print from form view. 

To create a custom paper size:

1 In the printing dialog box, for Paper Size, choose Manage Custom Sizes.

2 In the Custom Paper Sizes dialog box, click +, then double-click Untitled in 
the list and type a name for your custom paper size.

3 For Paper Size, type the width and height of the paper.

4 To use the printer margins of an installed printer, choose the printer from 
Non-Printable Area. To define your own margins, choose User Defined, then 
type values for the top, right, bottom, and left margins in the boxes.

5 Click OK to save your custom paper size.

• To remove a custom paper size from the list, select the name in the list, 
then click – .

• To copy a custom paper size, select the name in the list, then click 
Duplicate. You can then make changes to the duplicated paper size. 

To use a custom paper size:

1 Choose File > Print > Table/Form.

2 For Paper Size, choose the custom size you want.
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Printing from Search or Advanced Find 
If you want to print a subset of records, you can use search or Advanced Find to narrow 
the set of records in a library or collection, and then print the records. 

To print a subset of records: 

1 Use the search field or Advanced Find to create a subset of records. 

See ”Search Field and Advanced Find” on page 25. 

• For search, the set of records that matches the criteria is displayed as you 
type the search string. 

• For Advanced Find, click Find to display the set of records that matches 
the criteria. 

2 Choose File > Print > Table/Form.

3 Specify which records in the subset to print. 

• Select “Selected records only” to print the currently viewed record only 
(in form view) or to print all selected records (in table view). 

• Select “All displayed records” to print all of the records in the current 
subset. 

Printing Labels
You can print labels from within Bento.

You can:

• Use information from fields in your own library or a shared library.

• Print up to six lines of information per label. Text can be left-aligned, right-
aligned, or centered on the label. 

• Add a picture or a logo to your labels.

• Print labels for selected records.

• Choose font, style, size, and color.

• Specify the label you want to start printing from.

• Preview labels.

• Save label settings for the selected library.

• Export label settings when you export a template. For more information 
about exporting templates, see ”Exporting from a Library, Collection, or 
Smart Collection” on page 113.
Chapter 10    Importing, Exporting, and Printing 119



120

 

To print labels:

1 Select the library or collection that contains the information you want to 
print. 

2 (Optional) Create a subset of records by using the search field, Advanced Find, 
or selecting records in table view. 

3 Choose File > Print > Labels.

4 Click the Setup tab to specify the fields you want to use in your labels.

To customize label content, you can type text before or after any field.

Click the Address Labels checkbox to automatically add address fields to the 
labels for those records that contain address data. In the dark gray section, you 
can choose to print all the addresses that appear in your records or just the 
addresses from a specific field. You can also choose to print a specific type of 
address from the selected field.

Select Country to include each record’s country on the labels. Select “Except my 
country” to omit your country from the labels.

5 Move the insertion point to the line where you want a field’s data to print, 
then click Insert Field and choose a field from the pop-up menu.

If the label layout has a line that contains a single field and there is no data in that 
field in some records, Bento closes up the space and doesn’t print a blank line on 
those labels. 

Choose a field 
from the current 
library.

Click to automatically 
add address fields to 

the labels for those 
records that contain 

address data.

Choose an image 
to add to the labels.

Click in the text 
box and type text 
to customize the 
labels.

Click to save or 
load a label setup.

 If you click the Address 
Labels checkbox, you 

see the dark gray 
section. Choose the type 

of address.Choose a specific 
address field or the 

address list field of the 
current library.

Click to preview 
the labels. 

Click to print the 
currently selected 

records in table view.
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6 To add an image, click the pop-up menu below Insert Field, then choose a 
media field or an image file. 

If you choose a media field, what is printed depends on the contents of the media 
field for each record. If you choose an image file, the same image prints on all 
labels.

Left Align is the default alignment. Select Right Align to print the media field or 
image file on the right edge of each label.

7 To print labels for the currently selected records in table view, click Print 
Selected Records.

8 Click the Layout tab to specify the label type.

Choose a label type from the Page pop-up menus.

For your convenience, the margin and gutter measurements for the label type and 
size are displayed. Use the Size pop-up menu to change the displayed unit of 
measurement.

9 Click “Start printing on” to specify which label number you want to start 
printing from. Click OK.

10 Click the Appearance tab to specify options that affect the look of the labels. 

Click Set to change a font’s style, size, and other options. Click the color well next 
to Text Color to change the text color. 

Choose an alignment option from the Alignment pop-up menu.

Select Print Label Border to print a thin border on each label. 

11 To preview the current page of labels in a Quick Look window, click Preview 
Labels.

12 Click Print.

Note  Data in a selected checkbox field prints on labels as . Data in an unselected 

checkbox field prints as . Data in a rating field prints the number of stars 

representing the numeric value in the field (for example, ). 

Click to display the Mac OS 
Fonts window.

Click to print a thin border 
on the label.

Click to display the Mac OS 
Colors window.

Click to choose how you want 
text aligned on the label.
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To save a label setup for the selected library: 

1 Click the Setup tab.

2 Click Save/Load Label and choose Save As from the pop-up menu.

3 Type a name for the label setup, then click OK.

Your new label setup appears in the Save/Load Label pop-up menu.

4 Set up the labels as desired.

To print from a saved label setup: 

1 Choose File > Print > Labels.

2 Click the Setup tab.

3 Click Save/Load Label and choose a label setup from the pop-up menu.

4 Click Print.

To define a custom layout setup for the selected library: 

1 Choose File > Print > Labels.

2 Click the Layout tab, click Page, then choose Define Custom from the pop-up 
menu.

3 Type a name for the custom layout setup, then click OK.

4 Set the page margins, the number of labels on a page, and the gutter space 
between labels.

Your custom layout setup appears in the Page pop-up menu.
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Backing Up and Restoring 
Information 
This chapter describes how to create a backup copy of your 
Bento data. Use the backup copy to recover your original 
information if you make an inadvertent change, or to restore 
your data in case of a problem such as a hard drive failure. 

A Bento backup file contains the data in Bento at the time you run the back up 
command. The back up command is easy to use; you simply specify a name and 
location for the backup file. Restore is just as easy to use; you select the backup file 
from which you want to restore data. 

Because it’s a good idea to regularly back up your data, Bento provides an optional 
reminder to periodically back up your data. 

Note  Backup and restore features apply to all of your data in Bento. If you want to save 
the data from an individual library or collection, use the export feature described in 
”Exporting Information from Bento” on page 112. 

You can also use the Mac OS X application technology called Time Machine to back up 
and restore your Bento data. 

Tip  To save a copy of your backup file, copy it to another location, such as an external 
hard disk or a CD. 
     123
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About Bento Backup Files 
When you create a Bento backup file, you create a copy of the data that is in Bento. The 
backup file contains the data in your libraries and collections at the time you run the 
back up command. 

Important  The Bento backup file does not contain the data from the Mac OS Address 
Book and iCal applications. You should back up your Address Book and iCal data 
whenever you back up your Bento data. However, if you add fields to the records in the 
Address Book library, the iCal Events library, or the iCal Tasks library, then the data in 
those additional fields is included in the Bento backup file. 

Backing Up Address Book and iCal Data

• To create a backup of the data in the Mac OS Address Book application, use 
the Address Book application’s archive feature. 

• To create a backup of the data in the Mac OS iCal application, use the iCal 
application’s backup feature. 

How Field Types Are Backed Up

Consider the following when you back up file list fields, media fields, or related data 
fields. 

For Bento backs up 

File list fields The listed filenames and locations, but not the contents of the files.

Media fields The contents of the fields (for most media fields) because Bento stores copies of the 
media files. 

However, if you use aliases to media files rather than copying the media files into 
bento.bentodb, Bento backs up the filenames and locations of the files that are added 
to media fields, but not the contents of the files. You should back up these media files 
to a location in the Finder. 

Related data 
fields

The data shown in related data fields, because these fields show data from libraries 
and collections. 

However, Bento does not back up the data from the Address Book, iCal Events, and 
iCal Tasks libraries. If you use related data fields that reference those libraries, the 
related data is based on the data in the Mac OS Address Book and iCal applications. 
Chapter 11    Backing Up and Restoring Information



 

Using the Back Up Reminder 
By default, Bento reminds you to create a backup file once a week.

To create a Bento backup file from the back up reminder dialog: 

1 Click Back Up. 

2 In the dialog that appears, use the default name and location or type a name 
and location for the backup file. 

Changing the Back Up Reminder 
You can change the default back up reminder frequency or turn off the back up 
reminder.

To turn on the back up reminder or to change the reminder frequency: 

1 Choose Bento > Preferences. 

2 Select “Display a reminder to back up” and set the frequency for how often 
you want to see a reminder to back up your data. You can get a reminder to 
back up your data either every week or every month. 

To turn off the back up reminder: 

1 Choose Bento > Preferences. 

2 Clear “Display a reminder to back up.” 
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Creating a Backup File
When you create a Bento backup file, you create a copy of the data that is in Bento. It’s 
a good idea to back up your Bento data before you make extensive changes, such as 
importing data, deleting libraries, or significantly changing forms.

To create a backup file: 

1 Choose File > Back Up Bento Data. 

2 Use the default name and location or type a name and location for the 
backup file. 

3 Click Save. 

4 (Optional) If you display Address Book or iCal application data in Bento, you 
should back up the data in those applications next. The Bento backup file 
does not include data from those applications. 

Restoring from a Backup File 
When you restore data from a Bento backup file, you replace the data that is in Bento 
with the contents of the Bento backup file. Any additions you have made in Bento 
since you created the backup file are lost. Any deleted records are recovered. 

To restore data from a backup file: 

1 (Optional) If you display Address Book or iCal application data in Bento, you 
should restore the data from those applications’ archive (Address Book) or 
backup (iCal) files first. The Bento backup file does not include data from 
those applications. 

2 Choose File > Restore from Bento Backup and locate the backup file. 

3 Click Open. 

4 When Bento displays a confirmation dialog, click Continue. Bento loads the 
contents of the Bento backup file. 
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Using Time Machine with Bento 
Time Machine is the Mac OS X application that backs up your computer (including 
Bento data) on a regular basis. You can use Time Machine to restore the Bento data 
from a specific backup date and time. 

When you restore data from a Time Machine backup, you replace all of the data that is 
in Bento with the contents of the backup file. 

To set up the Time Machine options: 

1 Choose Apple menu > System Preferences, and then click Time Machine. 

2 In the Time Machine preferences, slide the switch to ON and choose a backup 
disk.

3 Verify that the user's Library folder is backed up by Time Machine. (By default, 
Time Machine backs up your entire hard drive.)

To restore Bento data using Time Machine: 

1 Quit Bento.

2 (Optional) If you display Address Book or iCal application data in Bento, 
restore the data from each application first. (The Bento backup file does not 
include data from those applications.) For more information, see ”Backing Up 
Address Book and iCal Data” on page 124. 

3 Open a Finder window and go to the Bento folder in the user’s Library folder: 

Library/Application Support/Bento/ 

4 Open Time Machine from the Dock or the Applications folder. 

5 Use the arrows or the timeline along the right side of your screen to browse 
through all the backups that Time Machine has created. 

6 When you find the date for the data you want to restore, select the file 
bento.bentodb and then click Restore. 

7 Click Replace in the confirmation dialog.

The restored bento.bentodb file is copied to Library/Application Support/Bento/, 
replacing all of the data that is in Bento. 

8 Open Bento. Bento loads the contents of the restored bento.bentodb file. 
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Syncing
This chapter describes how to sync Bento for Mac with Bento 
for iPhone and Bento for iPad.

Bento for iPhone and Bento for iPad are personal database apps that allow you to 
create libraries, collections, records, and fields on your iPhone, iPod touch, or iPad.

You can sync any two iOS devices with Bento for Mac. For example, you can sync one 
iPhone and one iPad, one iPhone and one iPod touch, or two iPads with Bento for Mac. 
Bento for Mac syncs one set of libraries across all connected devices. 

Although you can have two devices connected to Bento for Mac at the same time, you 
sync each device with Bento for Mac one at a time. If you start a sync from a second 
device but a sync initiated from the first device is still in progress, the first device’s sync is 
not interrupted. The second device’s sync starts after the first device’s sync has finished.

Syncing Information Between Your Mac and Devices
Syncing allows you to share information between your computer and any two iOS 
devices. For example, if you add information to a library in Bento for iPad, you can sync 
with Bento for Mac to add that information to the library in Bento on your desktop and 
Bento for iPhone. 

For information about which versions of Bento for Mac, Bento for iPhone, and Bento 
for iPad you can sync, see the FileMaker Knowledge Base.

Note  You can’t sync Address Book, iCal Events, and iCal Tasks libraries with Bento 4 for 
iPad. You can’t sync the iCal Events library with Bento for iPhone. By default, all other 
libraries are synced. For information about migrating the data from Address Book and 
iCal libraries, see ”Migrating the iCal, iPhoto, and Address Book Libraries” on page 41.

Connecting Your Device to the Same Wi-Fi Network as Your Computer
Bento for Mac can sync with Bento for iPhone or Bento for iPad when both the desktop 
and device applications are open and connected to the same Wi-Fi network, including a 
computer-to-computer (ad hoc) network. See Mac Help for information about networks.
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To connect your device to the same Wi-Fi network as your computer:

1 On your device, click the Home button, then tap Settings, tap Wi-Fi, then 
select a Wi-Fi network.

2 On your Mac, choose Apple menu > System Preferences > Network.

3 In the left side of the Network pane, click AirPort (Mac OS X 10.6) or Wi-Fi (OS 
X Lion 10.7).

4 For Network Name, select the same Wi-Fi network that you connected your 
device to.

5 Click Turn Airport On (Mac OS X 10.6) or Wi-Fi On (OS X Lion 10.7).

6 Click Apply, then close the Network pane.

Syncing for the First Time
After you have connected Bento for Mac and Bento for iPhone or Bento for iPad to the 
same Wi-Fi network, you can sync the databases.

Before syncing, back up your Bento data. For more information, see ”Backing Up and 
Restoring Information” on page 123.

To sync for the first time:

1 Do one of the following:

• Start Bento for iPhone, then tap . 

• Start Bento for iPad, tap , then tap Sync.

2 Tap Sync with a New Computer.

3 A four-digit passcode appears.

Note  If your device is not connected to a Wi-Fi network, an alert appears. To 
connect to a Wi-Fi network, see ”Connecting Your Device to the Same Wi-Fi 
Network as Your Computer” on page 129.

4 Start Bento for Mac, then choose File > Set Up Sync with Device.

5 Select your device, then click Continue.

6 In the Connect pane, enter the passcode that is displayed on your device.

The sync starts.
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7 After the sync is complete, if you have an existing Address Book library, you 
are asked to migrate the data. Follow the onscreen instructions to migrate the 
data.

Note  Bento does not support syncing your Bento Address Book library with 
Bento 4 for iPad. 

If the library includes any locked encrypted fields, you are asked to enter the 
Database Password to unlock the fields. If you don’t unlock the encrypted fields, 
Bento does not migrate the library.

To migrate the data, you can also choose your device in the Devices section of the 
Libraries pane, then click Migrate. Follow the onscreen instructions to migrate the 
data.

After the migration is complete, the Address Book library in Bento for Mac is 
replaced with a Bento Contacts library. The new Bento Contacts library is not 
connected to the Mac OS Address Book application. To view the new Contacts 
library on your device, sync Bento for Mac with your iOS device again.

For information about migrating your data, see ”Migrating the iCal, iPhoto, and 
Address Book Libraries” on page 41.

Syncing Bento for Mac with Bento for iPhone or Bento for iPad
After syncing for the first time, you can add, edit, or delete data in Bento for Mac, Bento 
for iPhone, or Bento for iPad. To keep your data consistent across all your Bento 
products, remember to sync regularly.

Bento for Mac can sync with Bento for iPhone or Bento for iPad when both the desktop 
and device applications are open and connected to the same Wi-Fi network. For more 
information, see ”Connecting Your Device to the Same Wi-Fi Network as Your 
Computer” on page 129.

To sync Bento for Mac with Bento for iPhone or Bento for iPad:

1 (Optional) In Bento for Mac, in the Devices section of the Libraries pane, select 
your device, then verify that the libraries you want to sync are selected. 

2 Do one of the following:

• Start Bento for iPhone, then tap . 

• Start Bento for iPad, tap , then tap Sync.

3 Tap Sync Now.

4 After the sync is complete, if you have an existing Address Book library, you 
are asked to migrate the data. Follow the onscreen instructions to migrate the 
Address Book library to a new Bento Contacts library. For more information, 
see ”Migrating the iCal, iPhoto, and Address Book Libraries” on page 41.
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Tip  If you want to know when you last synced, check the timestamp in the Sync & 
Setup screen (Bento for iPhone) or the Sync window (Bento for iPad).

Managing Connected Devices
You can sync your Bento desktop with any two iOS devices. If you have several devices 
that you sync with your Bento desktop, Bento can help you keep track of which 
devices are currently connected and when they were last synced.

To add a device to the list of currently connected devices:

1 In Bento for Mac, in the Devices section of the Libraries pane, click .

2 At the bottom of the Setup screen, click Add.

If there are two devices already listed, first remove a device by selecting it, then 
clicking Remove.

3 Follow the steps in ”Syncing for the First Time” on page 130.

The device is added to the list in the Setup tab. The list also displays the date and 
time of the most recent sync for each device.

To remove a device from the list of currently connected devices:

1 In Bento for Mac, in the Devices section of the Libraries pane, click .

2 At the bottom of the Setup screen, select a device, then click Remove.

The selected device is removed from the list in the Setup tab.

Troubleshooting Syncing
This section describes some common issues with syncing information between your 
Bento products.

• Can I sync more than one Bento desktop with a device?

No. A device can only sync with one Bento desktop. If you sync a second Bento 
desktop with your device, libraries from the first desktop are removed. To prevent 
data loss, avoid connecting to additional desktops. 

• Can I sync Bento 4 for iPad with my Bento for Mac Address Book library? 

Bento 4 for iPad does not sync with the Bento for Mac Address Book library. You 
can migrate the Bento for Mac Address Book library to a new Bento Contacts 
library, then sync with your iOS device to view the data.

• Can I sync Bento 4 for iPad or Bento for iPhone with my Bento for Mac 
iCal libraries?
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You can’t sync iCal Events and iCal Tasks libraries with Bento 4 for iPad. You can’t 
sync the iCal Events library with Bento for iPhone. You can migrate the Bento for 
Mac iCal Tasks library to a new Bento Tasks library and the iCal Events library to a 
new Bento Events library, then sync with your iOS device to view the data. See 
”Migrating the iCal, iPhoto, and Address Book Libraries” on page 41.

• Why weren’t all of my media files synced?

Media files in Bento for Mac that are larger than 10 megabytes or that cannot be 
opened or played on your device cannot be synced. Media files in Bento for iPad 
or Bento for iPhone that are larger than 10 megabytes can be synced with Bento 
for Mac.

• What if Bento for iPhone or Bento for iPad is interrupted while syncing?

If Bento for iPhone or Bento for iPad is interrupted while syncing (for instance, by a 
phone call or power failure), you must restart the sync.

• When I sync, what happens if data in one device conflicts with data in the 
other?

If there is a data conflict, data in Bento for iPhone or Bento for iPad overwrites data 
in Bento for Mac. For example, you have John Smith’s phone number stored in 
both Bento products. You change his phone number to 555-1010 in Bento for Mac 
and 555-9090 in Bento for iPhone. When you sync, the phone number on your 
device overwrites the phone number on your computer.
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A
Keyboard Shortcuts 
This section provides a reference of the keyboard shortcuts. 

You can use your keyboard and mouse to quickly accomplish many tasks in Bento. To 
find the shortcuts for common menu commands, look in the menus (or see the menu 
shortcuts listed here). To complete an action, press the shortcut keys in the order 
shown. 

Note  To tab and shift-tab to all fields in form and table view, you must set Full 
Keyboard Access to “All controls.” 

To set full keyboard access to all controls: 

1 Open System Preferences (choose Apple menu > System Preferences). 

2 Open Keyboard preferences. 

3 Click the Keyboard Shortcuts tab. 

4 Under Full Keyboard Access, select “All controls.”

Action Shortcut 

Working with Form View 

Show or hide form tools Option-Command-C 

Move to next field Tab

Move to previous field Shift-Tab 

Rename form Double-click form name.

Select multiple fields Click outside the first field, then drag the selection rectangle 
through the other fields you want to select.

Extend field selection With fields selected, Shift-click or Command-click to add or remove 
items from the selected set of fields.

Select all fields Command-A

Deselect all fields Shift-Command-A

Select/deselect checkmark in 
checkbox field

Select the checkbox field, then press the Space bar.
     135



136

 

Working with Table View 
When One Cell is Selected

Edit a value Option-Return

Save and move to next cell Return

Add a carriage return in a text field Command-Return

Move to cell above Up arrow

Move to cell below Down arrow

Move to next field Tab

Move to previous field Shift-Tab 

Working with Table View 
When One or More Cells are 
Selected

Extend selection upward Shift-up arrow

Extend selection downward Shift-down arrow

Working with Table View 
When Records are Selected

Select a record Click the row number. The entire record is selected.

Select multiple records Select one record, then Shift-click another record to select all 
records in between. 

Extend record selection With records selected, Command-click record to add a record to 
selection, if it is not selected, or to remove a record from selection, 
if it is selected. 

Move to record above Up arrow

Move to record below Down arrow

Working with Records 

Add record Command-N 

Duplicate record Shift-Command-D 

Delete record (Library) 

Remove record (Collection) 

Command-Delete

Go to next record Command-right bracket (])

Go to previous record Command-left bracket ([) 

Go to first record Option-Command-left bracket ([)

Go to last record Option-Command-right bracket (])

Working with Text and Objects 

Select all text within a field being 
edited

Command-A 

Action Shortcut 
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Deselect all text within a field being 
edited

Shift-Command-A 

Cut Command-X

Copy Command-C

Paste Command-V

Duplicate Command-D 

Delete Delete 

Check spelling Command-semicolon (;) 

Show spelling window Command-colon (:) 

Show special characters window Option-Command-T 

General 

Create library from template (opens 
New Library dialog) 

Command-L 

Create library from Template 
Exchange

Option-Command-L

Create collection Shift-Command-N 

Create Smart Collection Option-Command-N 

Add field Control-N

Show or hide Advanced Find Command-F 

Quick Look selected item Command-Y

In table view, send email to one or 
more selected email addresses

Shift-Command-M

Use search field Option-Command-F 

Show table view Command-1 

Show grid view Command-2

Show split view (table/form or grid/
form)

Command-3 

Show form view (repeat shortcut to 
move to next form)

Command-4

Show or hide libraries and fields pane Command-5 

Move to next area of main window Control-Option-right arrow 

Move to previous area of main 
window

Control-Option-left arrow

Show or hide summary row Command-6 

Import file Shift-Command-I 

Export current library or collection Shift-Command-E 

Print current library or collection in 
the current view 

Command-P 

Print labels from the current library 
or collection

Shift-Command-P

Action Shortcut 
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Undo last action Command-Z 

Redo last undone action Shift-Command-Z 

Open window Command-0 (zero)

Close window Command-W

Minimize window Command-M

Show preferences Command-comma (,) 

Lock encrypted fields Shift-Command-L

Show Bento Help menu Shift-Command-question mark (?) 

Hide Bento Command-H 

Hide other windows Option-Command-H 

Quit Bento Command-Q 

Action Shortcut 
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B
Reverting to a Previous Version of 
Bento
This section provides instructions for Bento 1, Bento 2, and 
Bento 3 users who installed Bento 4 and then decide to go 
back to their previous version. 

Reverting to a Previous Version from Bento 4
If you have a previous version of Bento installed, Bento 4 will create a new database 
file using your previous Bento database file. Your old Bento database is renamed to 
bentoUpgradeBackup.bentodb, and the Bento 4 database is named bento.bentodb.

If you want to use data that you created in Bento 4 with your previous version of 
Bento, export the Bento 4 records in .csv format before you revert the database. For 
more information, see ”Exporting Information from Bento” on page 112.
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To revert to Bento 1, Bento 2, or Bento 3 from Bento 4:

1 If Bento is currently open, choose Bento > Quit Bento.

2 In the Finder, choose Go > Home. 

3 Open the Library folder, then the Application Support folder, then the Bento 
folder.

You see the current Bento 4 database file (bento.bentodb) and the previous Bento 
database backup file (bentoUpgradeBackup.bentodb).

Bento 1 and Bento 2 users: You see two database backup files: 
bentoUpgradeBackup.bentodb and bentoUpgradeBackup 2.bentodb.
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4 Drag the bento.bentodb (Bento 4) file to the Trash.

5 Rename the bentoUpgradeBackup.bentodb file to bento.bentodb.

Bento 1 and Bento 2 users: Rename only the bentoUpgradeBackup.bentodb file; 
do not rename the bentoUpgradeBackup 2.bentodb file.
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6 Your folder should now look like this (bentoUpgradeBackup.bentodb has 
been replaced with bento.bentodb).

7 Locate and start the previous Bento application.

If you overwrote your previous Bento application with the Bento 4 trial, you can 
download another copy from the Bento Support website. 

8 Your data will appear in Bento 1, Bento 2, or Bento 3 as it did before you started 
Bento 4.

9 Drag the Bento 4 application to the Trash.

Or, rename the Bento 4 application (and store it in another folder) in case you 
need to use it again.
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Numbers files  107
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iPhoto library, migrating  42
iPod touch  129
iSight cameras  95
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