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Software Copyright and Warranty

This legal document is an agreement between you, the
end user, and BIAS, Inc. BY UTILIZING THE SOFT-
WARE ON THESE DISKS, YOU ARE AGREEING TO
BECOME BOUND BY THE TERMS OF THIS AGREE-
MENT, WHICH INCLUDES THE SOFTWARE LICENSE
AND THE SOFTWARE DISCLAIMER OF WARRANTY
(collectively the “Agreement”). THIS AGREEMENT
CONSTITUTES THE COMPLETE AGREEMENT
BETWEEN YOU AND BIAS, INC. IF YOU DO NOT
AGREE TO THE TERMS OF THIS AGREEMENT, DO
NOT USE THE SOFTWARE ON THE DISKS INCLUDED
IN THIS PACKAGE AND PROMPTLY RETURN THE
UNOPENED PACKAGE AND THE OTHER MATERIALS
(INCLUDING WRITTEN MATERIALS, BINDERS OR
OTHER CONTAINERS) THAT ARE PART OF THIS
PRODUCT TO THE PLACE WHERE YOU OBTAINED
THEM FOR A FULL REFUND.

BIAS SOFTWARE LICENSE

1. GRANT OF LICENSE. In consideration of payment
of the LICENSE fee, which is part of the price you paid
for this product, BIAS, as Licensor, grants to you, the
LICENSEE, a non-exclusive right to use and display this
copy of a BIAS software program (hereinafter the
“SOFTWARE") an a single COMPUTER (i.e., with a
single CPU) at a single location. BIAS reserves all rights
not expressly granted to LICENSEE.

2. OWNERSHIP OF SOFTWARE. As the LICENSEE, you
own the magnetic or other physical media on which
the SOFTWARE is originally or subsequently recorded
or fixed, but BIAS retains title and ownership of the
SOFTWARE recorded on the original disk copy (or
copies) and all subsequent copies of the SOFTWARE,
regardless of the form or media on which the original
and other copies may exist. This License is not a sale of
the original SOFTWARE or any copy.

3. COPY RESTRICTIONS. This SOFTWARE and the
accompanying written materials are copyrighted.
Unauthorized copying of the SOFTWARE, including
SOFTWARE that has been modified, merged, or
included with other software, or of the written
materials is expressly forbidden. You may be held
legally responsible for any copyright infringement that
is caused or encouraged by your failure to abide by the
terms of this License. Subject to these restrictions, and

if the SOFTWARE is not copy-protected, you may make
one (1) copy of the SOFTWARE solely for backup
purposes. You must reproduce and include the
copyright notice on the backup copy.

4. USE RESTRICTIONS. As the LICENSEE, you may
physically transfer the SOFTWARE from one computer
to another provided that the SOFTWARE is used on
only one computer at a time. You may not electroni-
cally transfer the SOFTWARE from one computer to
another over a network. You may not distribute copies
of the SOFTWARE or accompanying written materials
to others. You may not modify, adapt, translate,
reverse engineer, de-compile, disassemble, or create
derivative works based on the SOFTWARE. You may
not modify, adapt, translate, or create derivative works
based on the written materials without the prior
written consent of BIAS.

5. TRANSFER RESTRICTIONS. This SOFTWARE is
licensed only to you, the LICENSEE, and may not be
transferred to anyone without the prior written
consent of BIAS. Any authorized transferee of the
SOFTWARE shall be bound by the terms and condi-
tions of this Agreement. In no event may you transfer,
assign, rent, lease, sell, or otherwise dispose of the
SOFTWARE on a temporary or permanent basis except
as expressly provided herein.

6. TERMINATION. This License is effective until
terminated. This License will terminate automatically
without notice from BIAS if you fail to comply with any
provision of this License. Upon termination you shall
destroy the written materials and all copies of the
SOFTWARE, including modified copies, if any.

7. UPDATE POLICY. BIAS may create, from time to
time, updated versions of the SOFTWARE. At its
option, BIAS will make such updates available to the
LICENSEE and transferees who have paid the update
fee and returned the registration card to BIAS.

8. MISCELLANEOUS. This Agreement is governed by
the law of the State of California.

DISCLAIMER OF WARRANTY AND LIMITED WAR-
RANTY

THE SOFTWARE AND ACCOMPANYING WRITTEN
MATERIALS (INCLUDING INSTRUCTIONS FOR USE)
ARE PROVIDED “AS IS” WITHOUT WARRANTIES OF



ANY KIND. FURTHER, BIAS DOES NOT WARRANT,
GUARANTEE, OR MAKE ANY REPRESENTATIONS
REGARDING THE USE, OR THE RESULTS OF THE
USE, OF THE SOFTWARE OR WRITTEN MATERIALS IN
TERMS OF CORRECTNESS, ACCURACY, RELIABILITY,
CURRENTNESS, OR OTHERWISE. THE ENTIRE RISK
AS TO THE RESULTS AND PERFORMANCE OF THE
SOFTWARE IS ASSUMED BY YOU, AND NOT BIAS OR
ITS DEALERS, DISTRIBUTORS, AGENTS, OR EMPLOY-
EES, YOU AGREE TO ASSUME THE ENTIRE COST OF
ALL NECESSARY SERVICING, REPAIR, OR CORREC-
TION.

BIAS warrants to the original LICENSEE that the
disk(s) on which the SOFTWARE is recorded is free
from defects in materials and workmanship under
normal use and service for a period of ninety (90) days
from the date of delivery as evidenced by a copy of the
receipt and. Further, BIAS hereby limits the duration
of any implied warranty (or warranties) on the disk to
the respective periods stated above. Some states do
not allow limitations on duration of an implied

warranty, so the above limitation may not apply to you.

BIAS’ entire liability and your exclusive remedy as to
disk(s) shall be, at BIAS’ option, either (a) return of
the purchase price or (b) replacement of the disk that
does not meet BIAS’ Limited Warranty and which is
returned to BIAS with a copy of the receipt. If failure
of the disk has resulted from accident, abuse, or
misapplication, BIAS shall have no responsibility to
replace the disk or refund the purchase price. Any
replacement disk will be warranted for the remainder
of the original warranty period or thirty (30) days,
whichever is longer.

THE ABOVE ARE THE ONLY WARRANTIES OF ANY
KIND, EITHER EXPRESS OR IMPLIED, INCLUDING
BUT NOT LIMITED TO THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE, THAT ARE MADE BY BIAS
CONCERNING THE BIAS PRODUCT. NO ORAL OR
WRITTEN INFORMATION OR ADVICE GIVEN BY BIAS,
ITS DEALERS, DISTRIBUTORS, AGENTS, OR EMPLOY-
EES SHALL CREATE A WARRANTY OR IN ANY WAY
INCREASE THE SCOPE OF THIS WARRANTY, AND
YOU MAY NOT RELY ON ANY SUCH INFORMATION
OR ADVICE. THIS WARRANTY GIVES YOU SPECIFIC

LEGAL RIGHTS. YOU MAY HAVE OTHER RIGHTS
WHICH VARY FROM STATE TO STATE.

NEITHER BIAS NOR ANYONE ELSE WHO HAS BEEN
INVOLVED IN THE CREATION, PRODUCTION, OR
DELIVERY OF THIS PRODUCT SHALL BE LIABLE FOR
ANY DIRECT, INDIRECT, CONSEQUENTIAL, OR
INCIDENTAL DAMAGES (INCLUDING DAMAGES FOR
LOSS OF BUSINESS PROFITS, BUSINESS INTERRUP-
TION, LOSS OF BUSINESS INFORMATION, AND THE
LIKE) ARISING SUCH DAMAGES. BECAUSE SOME
STATES DO NOT ALLOW THE EXCLUSION OR
LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR
INCIDENTAL DAMAGES, THE ABOVE LIMITATION
MAY NOT APPLY TO YOU.

This Disclaimer of Warranty and Limited Warranty is
governed by the laws of the State of California.

U.S. GOVERNMENT RESTRICTED RIGHTS

The SOFTWARE and documentation is provided with
RESTRICTED RIGHTS. Use, duplication, or disclosure
by the Government is subject to restrictions as set
forth in subdivision (b)(3)(ii) of The Rights in
Technical Data and Computer Software clause at
252.227-7013.

Contractor/manufacturer is BIAS (Berkley Integrated
Audio Software), Inc./ 1370 Industrial Ave., Suite A,
Petaluma, CA 94952

Should you have any questions concerning this
Agreement, or if you desire to contact BIAS for any
reason, please contact in writing:

BIAS Customer Sales and Service,

1370 Industrial Ave., Suita A, Petaluma CA 94952.
Copyright 1998 BIAS, Inc.
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Chapter 1:
Introducing Deck

Welcome!

BIAS Deck 3.0 is a full-featured, multitrack digital
audio application for the Macintosh. Deck has won
critical acclaim for its vast array of professional features
and its intuitive user interface. Deck offers completely
non-destructive editing, allowing you to edit any track
as much as you like, with no fear of losing or altering
the original material. Use Deck to record and edit up
to 64 simultaneous audio playback tracks (dependent
upon the speed of your CPU and hard drives). Deck
also offers up to 999 virtual work tracks.

Deck 3.0 is fully native-capable with any G4, G3, or
PowerPC Macintosh. You can use your Mac's built-in
audio connections with no additional hardware
required. Deck also supports the ASIO industry
standard, giving you a wide choice of audio hardware
options.

Deck delivers real-time signal processing with built-in
graphic EQs, delay, chorusing, and more—on every
track (subject to CPU speed and power). There's full
support for a wide range of VST audio Plug-Ins, as well
as support for Adobe Premiere-compatible audio Plug-
Ins.

Deck offers a wealth of pro-calibre audio post
production features, including frame-accurate spotting
and SMPTE/EBU sync capability, and frame-accurate
sync to QuickTime movies. Deck is an ideal compan-
ion to any Adobe, Avid, Finalcut Pro, iMovie, Media
100, Radius, or other digital video editing system or
software.

Deck is intended for a wide variety of users. Musicians
use it as a composition environment. Engineers use it
for multitrack recording, editing, and mixing. Deck is
used in video post-production for spotting sound
effects and sound tracks. Sound designers use it for
audio sweetening and layback tasks. Multimedia
producers use Deck as a self-contained digital audio
and video post-production environment. Radio
broadcasters use it for field recording as well as cutting
entire programs. Anyone with an interest in audio and
a capable Macintosh system will benefit from Deck.

Deck Features:

* Professional multitrack recording, editing &
processing solution

* Up to 64 simultaneous tracks - no audio hardware
required

* Runs on most Macs - even PowerBooks
* Up to 999 virtual tracks

* Built-in real-time DSP effects include graphic &
parametric EQs, delay, chorus, gain & more

* Support for VST and Adobe Premiere audio plug-
ins

* 24-bit automated level mixing with high-res
moving faders

* Automated mutes, pans & levels
* Copy, paste, drag & draw automation envelopes

* Integrated digital video support - with frame-
accurate MTC & SMPTE/EBU timecode sync

* Syncs to all OMS compatible MIDI sequencers

Introducing Deck




* Launch BIAS Peak or BIAS Peak le directly from
Deck

¢ Includes BIAS Peak LE

What's New in Deck 3.0?

Version 3.0 of Deck includes the following new
features:
* VST Plug-In support

* Enhanced playback track capability, limited only
by your system, with up to 64 simultaneous
playback tracks

* Master Outputs window: includes Master Fader
and Meters, and VST inserts

* Improved Graphics

* CPU Meter window: displays RAM, CPU, and Disk
usage

* Desktop Curtain

* Virtual Memory is supported with Virtual Memory-

compatible 3rd party ASIO drivers and VST plug-
ins

Minimum System Requirements

To use Deck you will need:

* PowerPC, G3, or G4 Processor (266MHz or faster)

* Built-in 16-bit Macintosh sound, or supported
ASIO-compatible audio hardware and the most
recent ASIO 1.0 driver software from ASIO
hardware manufacturer, or Korg 1212 I/O PCI-bus
audio card.

* Frame-accurate sync to SMPTE/EBU timecode
requires an OMS-compatible hardware.

* 32MB System RAM minimum

* 5MB minimum available hard disk space (for
program)

* Mac OS§ 8.5 or later
* QuickTime 3.0 or later
* Sound Manager 3.2.1 or later

* OMS 2.3.8 required for synchronizing Deck to
OMS-compatible MIDI sequencers & playback of
MIDI tracks

* Hard drive(s) running at 7,200 rpm or faster, UW-
SCSI recommended

The Deck application runs in native mode on
PowerPC, G3, and G4 Macintosh computers. Deck
supports ASIO 1.0 compatible sound cards using the
Deck ASIO Plug-in. Deck also offers direct support for
the Korg 1212 1/0 PCI-bus audio card using the DECK
11212 1/O Driver.

To record and play back tracks you will also need the
following:

* To record, a line-level sound source (mixing
board, electronic instrument, CD player, turntable,
cassette player, audio DAT machine, microphone,
etc.).

* To play back, a stereo amplifier and speakers or
powered speakers.

* A mixer or ASIO hardware with an onboard mixer
(e.g., Tascam US-428) is strongly recommended.

Maximizing Deck’s Performance

To get the best performance out of Deck and your
Macintosh, observe the following.

To maximize Deck’s performance:
* Use a minimal number of System Extensions.

Extensions can slow down your Macintosh by
using precious processor cycles. In particular,
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disable third party extensions that you do not
require while running Deck. To set up a dedicated
set of extensions for Deck, duplicate your Mac OS
Base extensions set in the extensions manager
and rename it (something like audio_set), restart
your computer with this extensions set and install
Deck, enable the additional extensions required
for Deck (e.g., OMS, drivers for your audio
hardware, etc.), and, restart your computer with
this updated extensions set.

* Turn File Sharing off, unless you need it.

¢ Unmount network volumes while running Deck
because the Finder can cause slowdowns as it
polls network volumes in the background.

¢ Allocate additional RAM to Deck if possible, using
the Finder’s Get Info command. (Select the Deck
application in the Finder, choose Get Info from
the Finder’s File menu, and enter the desired
RAM allocation in the Preferred Size field. Make
sure you allocate more RAM than the amount
indicated in the Minimum Size field!).

* Optimize your hard drive.

About Your User's Guide

Deck is designed to be simple and intuitive. Your
User’s Guide is designed to help you set up and use
Deck for digital recording and editing as quickly and
easily as possible.

This User’s Guide assumes that you are familiar with
standard Macintosh operating techniques, including:

* Setting up, starting, and using your Macintosh
* Choosing commands from menus

* Double-clicking, selecting, Shift-selecting, and
dragging with the mouse

* Opening, copying, saving and deleting files

* Opening, closing, scrolling, moving, re-sizing, and
selecting Macintosh windows

If you don’t know how to perform these tasks, please
refer to your Macintosh User’s Guide and spend a little
time learning about your Macintosh before going any
further. This will make using Deck much easier and
more enjoyable.

Look for important tips and notes whenever
you see this exclamation mark.

Conventions

The Deck User’s Guide uses the following conventions
to indicate menu choices and key commands:

Convention Action

File > Save Choose Save from the
File menu.

Command-S Hold down the Command
key and press the S key.

Option-click Hold down the Option key
and click with the mouse.

About Deck LE

If you are using the limited edition of Deck, not all
features will be available. Specifically, the following
features are not available in Deck LE:

* No more than 8 playback tracks
* Virtual Tracks

* 24-bit Automation

* Automation Envelopes

* Real-time DSP Effects

* Adobe Premiere Plug-In support
¢ VST Plug-Ins

* QuickTime movie support
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* MIDI Time Code and SMPTE/EBU support

Features that are not supported in Deck LE will
show this icon in the manual. LE features will
also appear grayed out in their menus.

Conclusion

Now that you know a little about Deck, proceed to the
next chapter to learn how to install your software and
get started using it.
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Chapter 2:
Installing and
Configuring Deck

Deck offers powerful high-end synchronization,
editing, mixing, and audio processing functions.
However, before you can begin using Deck, you need
to install and configure your Deck software, and
configure your computer and audio hardware. The
hardware consists of the built-in 16-bit stereo sound
hardware of your Macintosh, or a PCI or PCMCIA audio
card, or a USB or Firewire Audio Interface. You will
also be using some combination of mixer, amplifier,
and speakers to get audio in and out of your
Macintosh.

Installing Deck

Deck’s auto-installer software makes installation very
easy.

Your complete Deck system consists of:

* CD-ROM Installer

¢ Deck serial number and Product Authorization
Code (PAC)

Before you install Deck, please check the
Minimum System Requirements on Page 4 of
this Users Guide.

To install Deck:

1. Ifyou are using any virus-protection software,
turn it off or temporarily remove it, and restart
your Macintosh.

2. Insert the Deck Install CD-ROM in your CD-ROM
drive, open the Product Installers folder, and

double-click the Install Deck icon.

3. When the Installer dialog appears, read the Read
Me for late-breaking information concerning the
Installer, then click Continue to proceed.

4. Select where you would like to install Deck, using
the Switch Disk pop-up menu.

N

. Click Install at the bottom right of this dialog.

6. After you have clicked Install, follow the on-screen
instructions. Deck will be installed into a folder
named Deck 3.0 on your selected hard disk.

7. At the end of the installation, the installer will
allow you to register Deck electronically, which
you may find more convenient than mailing your
registration card.

8. When the installation is complete, a message will
appear indicating that the installation was
successful. Click Quit to quit the Installer, or click
Continue to install additional copies (don't forget
to turn back on any virus-protection software that
you may be using the next time you restart the
computer).

A Ifyou don't register Deck, it will expire, you
will not be eligible for technical support, and
you won't be notified about updates, upgrades
and other important news from BIAS!

Authorization

Deck must be authorized to work on your Macintosh.
To authorize Deck, you will need your Product
Authorization Code (PAC) in addition to the serial
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number that appears on your Deck Owner’s Certifi-
cate. BIAS will provide you with your Product
Authorization Code when you register Deck.

A You must register Deck in order to obtain your
Product Authorization Code; Deck will not
launch after the 14 day registration period
unless you authorize Deck with your Name,
Organization, Serial Number, and Product
Authorization Code!

When you first launch Deck, it will prompt you to
authorize it by entering your Name, Organization,
Serial number, and Product Authorization Code.

If you have not yet received you PAC, Deck will run
fully functional in Registration Mode for 14 days. This
allows ample time to register Deck and get the
Product Authorization Code from BIAS. To run Deck
in Registration Mode, click the “Still waiting for
Product Authorization Code” button. If you have
registered Deck with BIAS, and have received your
PAC, enter your Name, Organization, Serial #, and
Product Authorization Code, and click the “Authorize”
button or press the Return key. Your copy of Deck 3.0
will now be authorized.

Allocating RAM to Deck

Now you will need to allocate RAM for Deck. In most
instances, you will need to allocate more RAM than the
factory default setting.

A Deck is not compatible with Connectix RAM
Doubler.

To change Deck’s RAM allocation:
1. Quit any applications that you have running,

2. Deck now supports virtual memory , so you
should leave virtual memory on unless it conflicts
with the ASIO driver or any of the VST plug-ins
that you are using with Deck. Set virtual memory

to exactly 1MB above the total system memory;
this is the optimal setting, any higher and you risk
degraded performance and/or unexpected results.

3. From the Finder, determine how much free RAM
is available for Deck by selecting About This
Macintosh from the Apple menu.

4. The Largest Unused Block will show how much
RAM is free. Here you can also see how much
RAM is being used by your system software.

N

Select the Deck application icon in the Deck
folder on your desktop.

6. Choose File > Get Info (Command-I).

7. Set the Preferred Size to the amount you want
while leaving enough RAM for your system (and
any other applications you might want to run
simultaneously, e.g., BIAS Peak) to function.

For example, if you have 128MB of RAM and your
System is taking up 24MB, you can safely allocate
92MB of RAM to Deck. You should always leave a
minimum of SMB for the largest unused block in your
system.

You may have to experiment a bit with the amount of
RAM you assign to Deck. Many factors can affect the
amount of RAM you will need, such as the amount of
free RAM in your system, the size and complexity of
your Deck session, and the RAM required to use plug-
in effects or an external audio editor such as BIAS
Peak.

Making Audio Connections

Deck supports most Apple Sound Manager or ASIO
compatible audio hardware, as well as the Macintosh
Built-in sound. Deck also directly supports the Korg
1212 I/0 audio card (via SoundLink) and the Tascam
US-428 USB audio interface (via ASIO). Follow the
manufacturers installation instructions for your
specific audio card/interface.

10
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It is easy to set up audio connections between your cable or adapter.
Macintosh and a mixer or speaker system. Your exact
setup will differ slightly depending on whether you are
using the built-in sound input and output connectors
on your Macintosh, or those of third-party audio
hardware. Instructions for each case are given below.

Macintosh
power amp and peakers

RCA-t0-1/4 inch
Using the Macintosh’s Built-in Inputs and B I LM

Outputs

If you wish to use your Macintosh’s built-in audio
inputs and outputs for recording and playback, do the

llowine 1= [TV |sbdbhid

fermale RCA cables Rt ¢4 et

adapter cables:
Httadh to M MpUts

miner

1. Turn down the volume on your playback system.

Deck can be used with a variety of playback

systems, including; A For advanced users: Certain professional

mixing consoles, DAT decks, or other audio
* astereo receiver or amplifier and speakers sources may have a nominal output level of
+4dBu, whereas the Macintosh expects 1o see a
nominal -10dBu level. Be aware that you may
* a mixer and a pair of amplified (self-powered) need to adjust your mixers output levels

speakers accordingly to prevent overloading the

Macintosh’s input; or alternately, you may
need to use a “+4 1o -10” line-matching

* a mixer, amplifier, and a pair of speakers

* or simply a pair of amplified (self-powered)
speakers, smaller versions of which are often

o transformer.

called “multimedia” speakers. i

2. Connect your audio source output to the 3. Connect your Macintosh’s audio output to your
Macintosh's audio input connector. playback system’s input. The Macintosh’s audio

output jack is a standard stereo mini-plug (1/8-
inch) connector. Most mixer, receiver, and
amplified speaker inputs are equipped with 1/4-

Your audio source can be one of a variety of
devices, such as:

e acassette, CD, DAT, or mini-disc output inch, RCA, or mini-plug jacks. To make this
. connection, you may need to use a mini-plug to 1/
L] . . e
a mixer output, bus send, or auxsend 4-inch or mini-plug to RCA cable or adapter.
* astereo receiver line output (such as “tape deck 4. Raise the volume on your mixer or playback

record” output) system. Your system should now be properly

* aninstrument line output (such as the output of a configured and ready for recording and playback.
synthesizer).

PCl and PCMCIA Audio Cards, and USB and

The audio input jacks on most Macs are a standard = an :
Firewire Audio Interfaces

mini-plug (1/8-inch) connector. Most source outputs

are either 1/4 inch “phone” connectors or RCA If you have a Sound Manager-compatible or ASIO
connectors. To make this connection, you may need compatible audio card, or USB or Firewire audio
to use an 1/4-inch to mini-plug or RCA to mini-plug interface, installed in your computer and wish to use
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its input and output capabilities instead of your
Macintosh’s built-in capabilities, do the following:
1. Turn down the volume on your mixer or playback
system.

2. Make sure that you have installed the audio card
into one of the available PCI expansion slots
inside your Macintosh or a PCMCIA card slot in
your PowerBook, or connect your USB or Firewire
audio interface to an available USB or Firewire
port on your Macintosh. If you are not sure how
to do this, please refer to the manufacturer’s
instructions that came with your audio card or
interface.

3. Install the Sound Manager and/or ASIO drivers for
your audio card or interface. Please refer to the
manufacturer’s installation instructions for your
audio card on how to do this.

To use the audio card’s or interface’s ASIO driver
with Deck, place the ASIO driver inside Deck’s
ASIO Drivers folder in the Deck folder.

4. Connect your mixer’s output to the audio
hardware’s input connectors.

. Connect your audio hardware’s outputs to your
mixer’s (or playback system) input.

N

6. Raise the volume on your mixer or playback
system. Your system should now be properly
configured and ready for recording and playback.

povier amp and speakers

R-tort 4 indh
adapter cables
TO MIER OUTPUT

2
RCi-to-1 A inch
adapter cables
TO MIRER INPUT

BEeEnnng

Tiwer

A A typical mixer/computer configuration is to
have the computer outputs go to channel

————— diitalinputyoutput
analog input
CONNECTTO Mbet TP

analog output
cannectto mbiet inputs

inputs on your mixer and to have the auxiliary
or bus sends from the mixer go to the inputs of
the computer. Instruments you want to record
you patch into other channel inputs on the
mixer and you can then route them to the
auxiliary or bus sends on the mixer to be
recorded by the computer. The mixer’s main
outputs go to the amplifier/speakers.

Using the Inputs and Outputs of an Audio
Card or Audio Interface

Deck supports most Sound Manager compatible and
ASIO compatible audio cards and interfaces. In order
to effectively use these cards with Deck, you will need
to make sure you have installed the sound manager
drivers supplied by the manufacturer (most audio
hardware manufacturers include their own drivers). If
you haven'’t already installed your sound hardware’s
sound manager drivers, please do so now. In most
cases, you will need to place the hardware’s sound
manager driver extension in your System Folder’s
Extensions folder. After you have done this, restart
your computer.

If your audio hardware also has an ASIO 1.0 driver or a
backwards compatible ASIO 2.0 driver you will want to
put it into Deck’s ASIO Drivers folder.

To use a third-party audio hardware’s outputs for
previewing Premiere-format plug-ins:

1. Choose Sound Out from the Sound Control Panel
pop-up menu.

2. Select audio card (Digigram’s VX Pocket is shown
in this example) as the sound output device.

------ Sound Out s

Choose a device for playback:

EQ)
@ E

Euilt-in

DT

Rate: _44.1I:l|:l kHz i
Size: () 8bit @ 16bit

Use: () Mono @@ Stereo

The Apple Sound Control Panel
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3. Close the Sound Control Panel when you have
finished.

ASIO

Deck 3.0 supports ASIO 1.x audio drivers for recording
and playback of audio through your ASIO-supported
audio hardware. ASIO is a standard technology for
routing audio between sound cards and software
application developed by Steinberg Software und
Hardware, GmBH. ASIO, unlike the Apple Sound
Manager, allows for more than 2 channels of simulta-
neous audio. Most audio hardware currently available
have ASIO drivers. BIAS has tested the following cards
for ASIO compatibility with Deck 3.0:

* Apple Sound Manager

* Digidesign Direct I0

* Digigram VX Pocket

* Echo Gina, Layla, and Darla

* Ensoniq PARIS

* Gadget Labs WAVE/8-24

* Korg 12121/0

* Tucid PCI-24

* M-Audio Delta Series

e Midiman DMAN 2044

e MOTU PCI-324

* RME Digi%6

* SeaSound

* Sonorous STUDI/O

* Tascam US-428

* Yamaha DSP Factory

A The MOTU PCI-324 needs to be configured
using the MOTU PCI-324 Console and the PCI-
324 Cuemix Console prior to launching Deck.
The Yamaha DSP Factory requires that you be
running MixTest prior to launching Deck and
selecting the DS2416 ASIO driver. Other cards
may similarly require software utilities
provided by the manufacturer of the card
(such as the M-Audio Delta series).

Configuring Deck for ASIO

In order for Deck to use the ASIO driver for your
audio hardware, you must make sure that the Deck
ASIO Plug-in is located in the Deck Plug-Ins folder.

O=———Pugis=——————=HH

41 items, 1.2 &8 available

(I

[«]»

B

Deck 3.0 also supports the Korg 1212 SoundLink
system. To use SoundLink with Deck, be sure that the
DECK II 1212 I/O Driver is in the Deck Plug-Ins folder.
If you are planning on running Deck with ASIO you
must move the DECK II 1212 I/O Driver to the Plug-
Ins (Unused) folder.

O

3 Plug-Ins (Unused) ==HEIE
1 item, 1.2 GB available

DECK Il 1212 I/0 Driver

=]
B
S

Installing the ASIO Driver

To install an ASIO driver for use with Deck, drag and
drop the ASIO driver for your ASIO-supported audio

card into the ASIO Drivers folder in Deck’s root folder.

Installing and Configuring Deck

13




Once you have installed the ASIO driver for your audio

0 ——— L] ASl0 Drivers — & card, launch the Deck application. Deck will load and
ez GRravalable register the ASIO driver on launch.
Korg SoundLink

Deck 3.0 supports the Korg 1212 /O card via
SoundLink ™. To use SoundLink with Deck and the
Korg 1212 card, be sure that the Deck Korg 1212 I/O
Driver is located in the Deck Plug-Ins folder and that

Please note that the Deck application must reside in the Deck ASIO driver is moved to the Plug-Ins
the same folder (i.e., the Deck folder) as the ASIO (unused) folder.

Drivers folder in order for Deck to be able to
recognize the ASIO driver.

-
ST

Hardware Configuration

O =——=(sIDeck3a=——0HH
7 tems, 921.2 MB awailable
Once Deck is open, you will need to select and
ﬁ configure your audio interface via the Hardware
Deck™ 3 Configuration dialog whether you are using the Apple
r' Sound Manager, ASIO, or Korg SoundLink.
ASIOr'nters ASIO Drivers (Unused) . . .
Choose Hardware Configuration from the Options
menu in Deck to open the Hardware Configuration
Flug-Ins Flug-Ins (Unused) d1alog
= Audio Card
S & 4 ‘
YstPlugins MIDI Maps - Choose either Sound Manager or your audio card’s
KIDZ ASIO driver from the Audio Card pop-up menu.
Please note that Deck can only have one ASIO driver in ——— Hardware Configuration

Deck’s ASIO Drivers folder. You can put multiple ASIO
drivers in the folder called ASIO Drivers (Unused), but

you will need to manually drag them in and out of Ch. 182 Input Tw;e:
Deck’s ASIO driver folder if you wish switch ASIO Digjtcl Format:
drivers. [ Mic Input On

ASI0 Configuration:

[0 == AsI0 Drivers (Unused) = E1 5

2 items, 1.2 GB available

[ Record monitoring

[ Play audio while in background

(emee) o<

b k.
ASI0 Digileszign DirectlD  ASI0 Soundhanager

S D]

[]¥
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Choosing the Sound Manager will allow Deck to use
for audio input and output whatever is selected for
Sound In and Sound Out in you Apple Sound Control
Panel.

If you are using SoundLink with the Korg 1212 card,
choose SoundLink from the Audio Card pop-up menu.

Choose your audio card’s ASIO Driver from the Audio
Card pop-up menu to allow Deck to access the full
multichannel I/O capabilities of your audio card via
ASIO.

Hardware Configuration

Audio Card: | DigiDesign Direct 1/0 i]

sync Mode:
Ch.1&2 InputType:

Digital Format:
[ Mic Input On

AS10 Configuration:

4 Record monitoring

Clock Source:
B4 Play audio while in background
o

If you are using Deck with your audio card’s ASIO
driver, be sure to use the checkboxes to enable or
disable Record monitoring and Play audio while in
background.

Clock Source

It is important to note when recording digital audio
signals (e.g. SPDIF, ADAT optical, etc.) that the Clock
Source be set to the appropriate digital clock source.
Recording a digital signal with the clock source set to
an incorrect source will lead to “jitter” error, resulting
in clicks and pops in the recorded audio stream.

Play audio while in background

The Play audio while in background check box enables
the ASIO driver to operate in the background while
Deck is in the background. If you are running more
than one audio application using the same ASIO driver

(e.g., BIAS Peak), you will want to disable Play audio
while in background.

Record monitoring

If you want to monitor audio input in the digital
domain while you are recording, be sure to enable
Record monitoring in the Hardware Configuration
dialog.

To monitor recording in the digital domain:

1. Enable Record monitoring in the Hardware
Configuration dialog.

2. Choose the channel inputs for the tracks in Deck
you intend to record on.

3. Record enable those tracks.

4. Start recording.

It is strongly recommended that you monitor your
recording in the analog domain when recording live or
overdubbing. Use your analog mixer to monitor the
analog audio signal while recording in Deck. When
you record monitor in Deck, there will be a latency
equal to twice the size of the ASIO buffer (e.g. at
44,100 with a 2,048 byte buffer size there will be
almost 93ms of latency from when you recorded the
signal into Deck to when you hear it come back out of
the speakers). Monitoring the recording in the analog
domain avoids this problem.

To monitor recording in the analog domain:

1. Disable Record monitoring in the Hardware
Configuration dialog.

2. Be sure that the analog signal(s) you intend to
record are correctly routed to the inputs of your
audio interface for recording into Deck as well as
to be monitored through your speakers.

3. Choose the channel inputs for the tracks in Deck
you intend to record on.

4. Record enable those tracks.

5. Start recording.

Installing and Configuring Deck
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Hardware Options

Choose Hardware Options from the Options menu in
Deck to open the ASIO driver’s utility for certain ASIO
supported cards (the Digidesign Hardware Setup
dialog and the Digigram VX Pocket Control Panel are
shown below).

Hardware Setup

Card: MIX Card #1
Interface Port: Aw I
Interface: | 882/20 1/0™ hd
Sample Rate: 44100 |
Sync Mode: Internal -
Ch 1-2 Input: Analog hdl
Other Options
Digidesign Hardware Setup dialog
e ———
o
- o ;.,Ei:,. Output
Serial umber 5340451 o ptoreti
Input:(Cine evel T3] 24 bits
L E,‘;"‘""" e e I Fixed input tever Coan)
B ’7‘:@: [ Monitoring

Digigram VX Pocket Control Panel

A Please note that some cards’ drivers will either
not have driver setup utilities or they will have
driver setup utilities that need to be configured
prior to launching Deck (such as the MOTU
PCI-324 or the M-Audio Delta series) and
cannot be accessed from within Deck.

Configuring Deck and Setting
Maximum Playback Tracks

You need to make sure Deck is set to the correct
hardware. This usually occurs automatically. You may
also need to set the number of playback tracks,
especially if you are upgrading from an earlier version
of Deck or upgrading your computer platform.

To configure Deck and set the playback track count:

1. Within Deck, choose Options > Hardware
Configuration.

2. Select your audio hardware from the Audio Card
option and click OK.

3. Choose File > Preferences > Memory & Storage.

4. Set Max. Play Tracks as desired. (In most cases,
the value will default to the nominal track count
for your system.) The actual maximum playback
tracks will vary depending on your system and
hardware.

Memory & Storage

Disk buffer size: 256 [Kbytes
24

Max. play tracks:

Automation buffer: 3174 events
MIDI buffer: 20000 events
[ cancel | [ ok |

Memory & Storage preferences dialog

A You can always set the maximum play tracks
1o a number below the actual maximum
available. This is advised if you experience
“Disk is too slow” messages, or if you experi-
ence poor interface response.

Optimum track count on any machine depends on
many factors, such as the speed of your drive, the
speed of your CPU, and the model of Macintosh you
run Deck on.
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Using dedicated audio drives

Using your system drive to record and play back will
decrease your system performance, due to system
software design. Use a non-system SCSI hard drive for
recording and playback to achieve optimal perfor-
mance. Using dedicated audio drives running at 7,200
rpm or faster will further improve Deck’s track count
and performance. UW-SCSI is the current standard for
high performance drives, but UDMA-66 drives can
achieve nearly the same performance. Firewire hard
drives provide another exciting new standard with data
transfers up to 30gb/second! (1 16-bit 44,100 audio
channel = 88kb/second.) Remember, the faster the
hard drive the better.

Conclusion

Now that you have installed and configured Deck,
proceed to the next chapter to learn several basic
concepts and functions essential to using Deck.
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Chapter 3:
Getting Started

Deck generally looks and acts just like a portable mixer
and recorder. It enables you to record tracks, monitor
them while recording other tracks, adjust the level and
EQ of what you've recorded, and effects, and mix
down your recording to a master. Deck also offers
many features you would not find on a portable analog
recorder, including advanced visual waveform editing,
noiseless track bounce, multi-point auto-location,
moving-fader mixer automation, non-destructive real-
time and destructive effects, and CD-quality 16-bit
sound. This chapter covers creating and saving
sessions, importing audio files, recording, and the
basic functions of your Deck system.

Deck sessions

A Deck session file is a Macintosh document that
contains a map of a specific recording project. It does
not contain audio files, but instead it contains pointers
to audio files on your hard drive.

When you create a new session, a session file
document and an Audio Files folder are created and
placed in their own folder by Deck, which is named
after the session. If you later create crossfades in the
session, a Crossfades folder is automatically created.
The Audio Files folder contains any audio files you
record into the session and any that are physically
copied during import (either by your choice or if they
need to be converted).

It is a good idea to keep all of the data associated with
each session—the session file, Audio File folder, and
Crossfades folder—in that one session folder,
especially at first. For more information about the
structure of Deck sessions, see Chapter 10, “Digital

Recording and Mixing Basics” and the Appendix, “Fine-
Tuning & Troubleshooting Your System.”

Creating, opening, closing, and saving
sessions

To create a new session:

1. Choose File > New (Command-N).
2. Name your session and select its location.
3. Choose a sample rate and click OK.

Generally you will use the 44100 Hz sample rate (the
CD standard rate). For more information about sample
rates, see “Basic sampling concepts” on page 190.

To open an existing session:
1. Choose File > Open (Command-O).
2. Locate and select the desired session file.
3. Click Open.

The Open command cannot be used to open sound
files. Instead, they must be added to a session.

To save a session:
* Choose File > Save (Command-S).

If you wish to save the current session under a new
name, choose File > Save A Copy As.

To close a session:

* Choose File > Close Session (Option-Command-

W).
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Adding Audio Files and Regions to a
Session

The simplest and most common task you will need to
perform involves placing existing audio files and
organizing them for playback. You can select files in
any supported sound file format from your hard drive,
add them to the Clipboard, and then place them in any
order in the Tracks window. If your Macintosh has a
CD-ROM drive, you can also add audio files or
QuickTime movies from any CD-ROM disk, or audio
files from a regular audio CD. The Library window
automatically keeps track of all source material added
to the session in this manner.

Deck uses monophonic sound files in the Sound
Designer II format. If you add any other type of sound
file, Deck will automatically copy the sound file and
convert the copy to the correct format. Deck imports
Sound Designer I, Sound Designer II, AIFF, Apple
Resource (SND), QuickTime, and WAV audio files.
Audio files may also need to be converted by Deck if
they are not at a supported sampling rate.

Although Deck makes extensive use of the Clipboard
to add audio files to a session, it does not put the
actual audio data on the Clipboard, it merely uses the
Clipboard to keep track of the files you are adding or
editing. Therefore you do not need large amounts of
RAM to add large audio files to a session.

To add sound files and regions to a session:
1. Choose File > Add Audio to Clipboard (Com-
mand-D).

* To add tracks from an audio CD, use the Add
Audio CD Tracks to Clipboard command.

¢ Toadd a SND resource, use the Add SND to
Clipboard command.

* Toadd the audio from a QuickTime movie,
choose QuickTime > Import Movie.

2. Find and select the desired audio file from the list
of files on the left.

Information about the selected file appears in the
comments area in the lower left corner of the
dialog box, and a list of the regions within that
sound file appear in list in the upper right corner.
The top region represents the entire file.

3. Select the desired region in the sound file from
the list on the right.

An audio region marked with ®Fe represents the
entire sound file. Regions marked with ®Re are
simple audio regions, and those marked with ®Le
are loops (AIFF files only). Stereo files are split
and have the suffix .L (left) and .R (right).

* Click Play to audition the selected file, region, or
loop. You can hear the audio looped by turning
on the Loop Audition option.

* Turn on the Make a Copy option to copy all
imported files into the Audio Files folder for the
session. (Note that Deck automatically copies files
added from read-only media to the Audio Files
folder.)

4. Click Add Region to add the selected region to
the current track.

5. The current track is displayed in the lower right
corner of the dialog box. To remove regions from
the current track, select them and click Remove.,

6. Follow steps 2 through 5 until you have added all
of the files and regions you desire, then click
Done.

If necessary, Deck converts the selected files and
regions to match the sample rate and bit depth of the
current session.

Do one of the following:

* To place the selected audio at a specific point in
time, click in the waveform area of the Tracks
window at the desired time and choose Edit >
Paste At. The current time location of the cursor’s
position is displayed at the top of the Tracks
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window. If you are adding stereo or multichannel
files and regions, select two or more tracks. This
assures all the pasted audio will have its channels
in phase. For more information about the Tracks
window, see “The Tracks, Transport, and Mixer
windows” on page 18.

* To place the selected audio on new tracks, choose
Edit > Deselect, then choose Edit > Paste At.
The new track (or tracks if the selected audio is
multichannel) is placed at the top of the Tracks
window and any existing audio is moved to lower
tracks.

* To place the selected audio at different points in
time on various tracks, drag them from the Library
window to the Tracks window.

The Tracks, Transport, Mixer, Master
Outputs, and CPU Meter windows

To perform the basic functions in Deck you will be
frequently using Tracks, Transport, Mixer, Master
Outputs, and CPU Meter windows.

The Tracks window

The Tracks window is where you view, arrange, and
edit audio files along a timeline. Although only the
allotted number of play tracks can play, you can always
bounce those tracks down to one or two tracks, or use
work tracks and virtual mixing to create mixes that are
hundreds of tracks deep. For more information about
bouncing tracks and virtual mixing, see Chapter 8,
“Automation, Mixing, and Mastering.”

sychotropic: Tracks

(oo 5] 20 ]

rﬂhj ps | psyohotropis_
rotife | ps | psychotropic_

||:ﬁ<\»|

2047 ME free

m [«

Tracks window

The Transport window

The Transport window acts a lot like the transport on
any tape recorder, only it has more features and
functions.

psychotropic: Transport

Transport window

The Mixer window

Use the Mixer window for control of audio recording
and playback.

psychotropic: Mix:

Mixer window
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The Master Outputs window

Use the Master Outputs window to monitor and
attenuate the levels of stereo pairs of outputs. You can
also assign VST Plug-Ins to mono and stereo output
channels.

Master Outputs window with multichannel audio interface

The CPU Meter window

Use the CPU Meter window to monitor Deck’s usage
of the CPU, disk, and RAM.

[0 == CPUMeter=—"—"—— 5

CPU Meter window

You can change the default position of all Deck
windows using the File > Preferences > Save Settings
as Template command. Every time you begin a new
session, the windows will appear in these default
positions.

The Transport and Mixer windows can be operated
while in the background. That means you can have the
Transport controls or Mixer faders partially covered by
other Deck windows, yet still access their key
functions in real-time without bringing them to the
foreground. For detailed information about these and
the other Deck windows, see Chapter 9, “Deck
Reference.”

Recording into the Tracks window

The Tracks window allows you to record directly into
any of its playback tracks. By monitoring the signal
with the Mixer window VU meters you can adjust the
signal to avoid it being too quiet (resulting in a noisy
recording due to poor signal-to-noise ratio) or too
loud (resulting in digital distortion due to clipping).

If you intend to integrate MIDI into a Deck session, it
is a good idea to plan for this from the very beginning.
If you have an existing MIDI sequence and you wish to
record audio over that sequence, make sure to load
the MIDI file into Deck’s MIDI window before
recording any audio. If you wish to record audio first
and then lay in MIDI tracks, you may wish to record
the audio tracks in time to a MIDI metronome, which
can be supplied in real-time from OMS-compatible
MIDI sequencing software running in the background,;
you can also accomplish this by recording a simple
MIDI click file and importing it into your session.
Doing this assures that your audio tracks will be
recorded with a consistent, predictable time base, and
your subsequent MIDI tracks will be easy to assemble
and synchronize with your digital audio tracks. For
more information about the integration of MIDI and
audio in Deck, see Chapter 7, “MIDI and Synchroniza-
tion.”
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To record into the Tracks window:

1. Make sure you have a Deck session open and that
a sound source is hooked up to the audio inputs.

2. To hear what you are recording, you should also

hook up the audio outputs to an amplifier with
speakers or a headphone amplifier. For more
information, see “Making Audio Connections” on
page 10.

. Select the desired audio input from the pop-up
menu to the right of the track name.

. Click the R button to record-enable the desired
track.

. Choose Windows > Mixer. The Track VUs will
now be input level VUs and register any input
signal.

. Begin playing from your source and monitor the
incoming signal to keep the VU meter as close to
the top without turning on the clip light (the
small square at the top of the VU meter). The clip
light indicates that audio recorded at this level will
be distorted. Turn off the clip light by clicking it,
and adjust the incoming audio and/or the input
level as follows:

* Ifyou are using the built-in 16 bit audio hardware
of your Power Macintosh, set the Analog Input
Level (from the Options menu) to 0 and turn up
the level of your incoming audio (instrument or
mixer) at the source until it registers correctly in
the input VU meters. An Analog Input Level
setting of 0 does not turn off the input; it turns off
the low-quality on-board preamp that causes
recording anomalies.

* Ifyou have any other audio hardware, you may
need to adjust the volume of the incoming signal
at the source to get a good level.

. Multiple tracks can be recorded at once, but two
record tracks cannot be set to the same input. If
you wish to record in stereo, simply record-enable
two tracks, assigning one to input 1 and the other
to input 2. For true stereo separation, remember

to pan one track hard left and the other hard right
to match the stereo image of your source audio.

. Adjust the monitor level of the track you're

recording by sliding its track fader up or down in
the Mixer window.

When you have a track record-enabled, the track
volume fader adjusts the volume level for
monitoring the track. It does not change the
record level. When the track is not record-
enabled, the track volume fader adjusts the
output level of any audio that is already on the
track. This volume can be set to a different level
than the input monitor volume, which is useful
during punch-in recording. You should use the
track faders to adjust playback volume to your
liking, but always make sure that the analog input
level or output level of your source is set so that
the channel VU meter registers a high signal level,
with no clipping.

Due to limitations in Apple’s Sound Manager, you
cannot change the monitor volume or pan of any
track while it is being recorded with a Power
Macintosh. Moreover, tracks being recorded will
always play back through the system at full
volume while you record, and will monitor
through the channel you've set as their input
channel. (In other words, you cannot record into
input 1 and monitor through output 2.) It may be
useful to use an external mixer hooked up to your
Macintosh computer’s audio output jacks to
better control playback volume and panning.

. When you are ready to record on the enabled

track(s), click the Transport’s Record button, and
then click the Play button (Spacebar).

As soon as you click the Play button, Deck begins
recording.

10. When you are finished recording, click the

Transport’s Stop button (Spacebar).

If the recording ends before you stop it, you have run
out of disk space.
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To hear the track you just recorded:

¢ (lick the Transport window’s Return-to-zero
button (Return) and click the Play button
(Spacebar).

Your recorded track is now being played back, and you
should see Deck’s track VU registering audio level. To
adjust the output level of your recorded track, slide its
mixer volume fader up (louder) or down (quieter). To
pan the track left or right in the stereo image, adjust
the track’s pan fader in the mixer window.

To see the waveform overview of the track you just
recorded:

* In the Tracks window, use the Magnify/Demagnify
buttons to adjust your viewing resolution. Option-
Shift-clicking these buttons will result in larger
resolution jumps.

As you play tracks back, Deck’s cursor moves along the
time axis, indicating your current location. Enabling
Scroll During Playback in the Options menu will make
the entire track display scroll during playback, so your
current location stays on-screen at all times. (As Scroll
During Playback is a computation-intensive feature, its
operation may be disabled on older, slower Macintosh
computers.)

If you are satisfied with the track you just recorded,
you can now go on to recording the next track. If you
wish to re-record the track, repeat the procedure you
just used. To learn how to re-record only a few select
areas of the track, see “Automated punch-in and
punch-out recording” on page 27.

Effects

You can also listen to your tracks with Deck’s Built-in
effects—such as EQ, Delay, Chorus, or Gain —or VST
Plug-Ins. In the Mixer window, click one of the four
Thru pop-up menus on the track to which you wish to
add processing, and select the effect you want. Then
open the Effect window (Command-7) for Deck’s
Built-in effects, or Option-click on the name of the VST
Plug-In, and adjust the parameters of that effect. For
more information about Deck’s Built-in effects and
VST Plug-Ins, see Chapter 5, “Effects.”

Location times

On the right side of the enlarged Transport window
you see two sets of six pop-up menus. The six pop-ups
on the left are Deck’s Location Time buttons.

sychotropic: Transport

Transport window with Location Times and Mixer States visible

For those familiar with multitrack recording devices,
these are the Deck autolocate memories. Each of
these six pop-up menus gives you access to the full list
of all location times you have ever stored for the
current session. The arrows directly to the left of each
menu are the controls that you will use to record and
playback location times.

The Transport window can be collapsed or expanded
by clicking on the box at its upper right-hand corner.
The Location Time, Mixer State, and Punch-In Tools
are all hidden when the Transport window is
collapsed.

To set location times when playback is stopped:

* Scrub or play the session to set the playhead at
the desired time location.

Do one of the following:

e Command-click an arrow button to the left of one
of the Location Times windows.

* Choose New from the Location Times pop-up
menu.

Location Times are reflected in the Tracks Window by
a red flag, or Marker, in the Tracks Window Time Axis
(also known as the timeline, which is right above the
tracks display, and below the tool buttons, in the
Tracks window).
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To set location times during playback:

* Press Enter on the keypad. The time is added to
the list of times on the Location Times pop-up
menu.

To recall location times using the Location Time arrow
buttons:

* In the Transport window, click the arrow button
directly to the left of the stored position.
Whenever you click the arrow button (or select a
location on the pop-up) you will immediately be
snapped to that location time, whether audio is
playing back or not.

All location times also store the current loop/punch
Start and End times. To recall a location time with its
Begin and End times, just hold down the control key
when you click a Location Time arrow button.

To name location times:

1. Command-click the location time pop-up.

2. Type a name and click OK.

Loop mode

The loop mode function lets you define a section of
your session and automatically loop playback of that
section over and over. This is particularly useful for
practicing along with a short section of a session in
preparation for recording a track, or for evaluating
potential loops for arrangement purposes.

To set loop begin and end times, and turn on loop
play:
1. Scrub the small begin tape counter in the
Transport window to the desired loop start point.

* You can scrub the counter by clicking and holding
down the mouse over the counter. When the
cursor changes to right/left arrows, drag to the
right (forward) or left (backward) to set the exact
point in the recording. Scrubbing this way will play
audio as the counter moves. If you wish to slide
the counter value without hearing audio, hold
down the Shift key. Then click and drag the

mouse over the begin tape counter. To set the
loop time with the keyboard, hold down the
Command key and click the begin counter. Then
use the dialog to set your time.

* You can also click the Begin and End buttons to
enter the current master counter time while a
session is playing back. After the times have been
picked up, you can fine tune the begin and end
times by scrubbing. Command-click the Begin and
End buttons to transfer their times to the
Transport window’s master counter.

2. Scrub the small end tape counter to the desired
loop end point.

3. Click the Loop button.

4. Click the Transport’s Play button to play back the
loop. Click the Stop button to halt playback.

Loops may not be shorter than 0.5 seconds. If
you try to set a loop that is shorter than half a
second, Deck will automatically turn off the
loop.

There are a number of tools that greatly enhance the
usability of Loop mode. You can automatically move
the selection range (in the Tracks window) to the
begin and end counters using the Option > Selection
Tools > Set Punch Times From command (or move
the other direction using the Set from Punch Time
command). You can also use other commands on this
submenu to automatically select the waveform range
between the begin and end times indicated in the
Transport window. For more information see Chapter
9, “Deck Reference.” Finally, when the Track window
is open, you can press C on your keyboard at any time.
This issues a Cue command, which automatically sets
the Transport window’s start and end times to match
the current selection and turns on Loop mode.
Option-C turns Loop mode off.

Automated punch-in and punch-out
recording

Although sometimes a recorded track is perfect after
the first try, in most situations at least part of the track
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will need to be recorded again. Picture, for example, a
five-minute vocal track that has only a single line with
a mistake. As the engineer on this session, you would
want to make one more recording pass and replace
only a small piece of the recorded track. In traditional
recording, this process of piecemeal replacement is
called punch-in recording. Deck offers automated
punch-in/punch-out recording.

4. Click the Transport’s Play button.

As the existing track plays, monitor (play) your
new source signal (your instrument, microphone,
and so on). Set the input level so that the
replacement signal meter level approximately
matches the meter level of the signal on the track.

When you are punching-in, you can set the
monitor level of the existing track to a different
level than the monitor level of the incoming
signal. (Remember, monitor level is how loud you
hear it, while input level is how loud it is actually

To punch-in and punch-out a track section automati-
cally:

1. Scrub the small begin tape counter in the

Transport window to the desired punch-in point.
This will be the point where replacement
recording automatically begins.

* You can scrub the counter by clicking and holding
down the mouse over the counter. When the
cursor changes to right/left arrows, drag to the
right (forward) or left (backward) to set the exact
point in the recording. Scrubbing this way will play
audio as the counter moves. If you wish to slide
the counter value without hearing audio, hold
down the Shift key. Then click and drag the
mouse over the begin tape counter. To set the
punch time with the keyboard, hold down the
Command key and click the begin counter. Then
use the dialog to set your time.

* You can also click the Begin and End buttons to
enter the current master counter time while a
session is playing back. After the times have been
picked up, you can fine tune them by scrubbing.

. Scrub the small end tape counter to the desired
punch-out point. This will be the point where the
replacement recording automatically ends.

You have now set your punch-in (begin) and
punch-out (end) times.

. Click the Punch button.

Punch mode is now turned on, and the portion of
the session between the begin and end times will
be recorded automatically on the record-enabled

>

recorded.) When a track is not record-enabled,
the track’s volume fader adjusts the playback
(monitor) level of that track. When a track is
record-enabled, the track’s volume fader adjusts
the playback (monitor) level of the incoming
signal. Switch record enable on and off to match
these two levels.

Adjust the relative monitor levels of the other
tracks by sliding their volume faders up or down.

6. When you are ready to punch into the track, click

the Transport’s Record button, and then on the
Transport’s Play button (Spacebar). Both will be
highlighted.

Deck begins playback, and you will hear both the
existing track and you new input signal. Remem-
ber, however, that only the track section between
the counter’s begin and end times will be
recorded. When playback hits the punch begin
point, recording will start automatically and you
will no longer hear the original audio track.
Recording will continue until the punch end
point, at which time you will hear the original
audio track again.

7. When you are done, click the Transport’s Stop

button (Spacebar). Next click the Transport’s
Return-to-zero button (Return), and then on the
Play button (Spacebar) to hear what you
recorded.

Remember, Deck is a non-destructive recorder, so
when you punch-in new material, the old material is

track on your next recording pass. No other
section of the track will be replaced.
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not deleted. This means you can open the Track
window after you have punched-in and view your
newly recorded range. If you don’t like the new take,
you can delete it and stretch the old region to reveal
the original take. For more information, see Chapter 4,
“Visual Waveform Editing,” and the Appendix, “Fine-
Tuning & Troubleshooting Your System” for tips on
managing multiple takes in Deck.

Naming Tracks

You may wish to begin renaming your tracks when you
start doing multiple tracks. The tracks will name
themselves Track 1, Track 2, and so on. By giving your
tracks more descriptive names, such as “Bass, take 3,”
you will find it much easier to work with them. To
rename a track, Command-click the Track name pop-
up box at the left of its track window. This brings up a
dialog box that allows you to enter in a new name for
your track. (You can also click the track in the Tracks
window to select it, then choose Rename from the File
menu.) For more information about renaming and
editing tracks and regions, see Chapter 4, “Visual
Waveform Editing.”

Compact Session

After you have made you final decisions regarding
takes, you can automatically delete the unused takes
from your session by using Compact Session, or
compact single audio files using Compact Audio.
Before you compact any files, make sure you
understand how compacting works, and what it does.
For information about compacting session audio files,
see Chapter 4, “Visual Waveform Editing.”

Conclusion

Now that you know how to import existing audio files
and regions, record directly into Deck, proceed to the
next chapter to learn how to edit your audio in a Deck
session.
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Chapter 4
Visual Waveform Editing
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Chapter 4:
Visual Waveform
Editing

This chapter of the Deck manual will help you get the
most out of the Tracks window, Deck’s visual
waveform editing environment. You will use the
Tracks window to slip tracks, arrange audio, redefine
regions, place existing audio, create and edit visual
automation envelopes, spot sound to picture, bounce
tracks, create work tracks, and more!

The Tracks window is where you will find Deck’s real
workstation power, and although you do not need to
use the Tracks window to record and mix tracks, you
need to understand the Tracks window in order to use
most of Deck’s editing functions.

Moving and Renaming Tracks

The Tracks window uses track position to determine
which tracks will play back. Active real-time play tracks
are numbered in their Track Control areas, at the left
of each track. All other tracks (up to 999 available) are
work tracks, as indicated by the letter W which
appears in their Track Control areas. Work tracks do
not playback. In order to playback audio regions that
are currently on a work track, you must move them to
a play track. For this reason, it is important that you
understand how to change the position of the
different tracks.

To move a track from one track to another, do one of
the following:

1. In the Track Control area at the left of the
destination track, select the new track from the
Track pop-up menu.

2. Click the Track Control area, then drag the

Control area to its new position. As you drag the

track, you will see a dark horizontal line highlight-

ing the destination spot.

If you are using this method to move tracks from
position to position in the Tracks window, you may
find it easier to accomplish your tasks when the tracks
are set to a smaller size. (Click the Track Size buttons
in the Tracks window to toggle between track display
modes.)

To cut, copy, and paste entire tracks:

1. Click the Track Control area. The track will be
highlighted to indicate that it is selected. When a
track is selected in this fashion, any Edit menu
command can be executed on the track.

2. Choose Edit > Cut (Command-X) or Copy
(Command-C).

3. Click any track’s Control area to select that track
as the destination.

4. Choose Edit > Paste (Command-V).

Tracks are never replaced when you use Deck’s Paste
command. The pasted track is always placed on the
track below the selected destination track.

To rename a track:

1. Click the track’s Control area.

2. Choose Edit > Rename.

3. Type in a new name for the track, then click OK.
The Tracks window will appear immediately showing

the track’s new name in the Control area pop-up.

You can also rename tracks by holding down the
Command key and clicking on the Track pop-up

Visual Waveform Editing
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menu. This method offers a simple way to change the
name of the current item in most of Deck’s list pop-
ups. The same shortcut works with Location Times
and Mixer States in the Deck Transport window.

Navigating the Tracks window

Before you can really edit audio regions and wave-
forms, you will need a basic understanding of the tools
you will use to navigate within the Tracks window and
configure the waveform display area.

To change the waveform display magnification:

* To magnify (zoom in on) the current waveform
display, click the Magnify button.

Magnify button

* To demagnify (zoom out on) the current
waveform display, click the Demagnify button.

Demagnify button

¢ Command-click the Magnify or Demagnify button
to zoom all the way in or all the way out,
respectively. Option-click them to (de)magnify 2
times; Shift-Option-click to (de)magnify 4 times.

* To auto-zoom to show only the current selection,
first select a range or region and then click the Fit
Selection button. This is a particularly useful tool
for display manipulation when accurate waveform
editing is required.

Fit Selection button

* Option-click the Fit Selection button to center the
display on the beginning of the selected range or
region. Command-click the Fit Selection button to
center the display on the end of the selected
range or region.

To magnify the vertical display of waveforms:

* C(lick the up arrow (Waveform Expand) button to
magnify the view of a low-level signal.

* C(lick the down arrow (Waveform Contract) to
return the display to its normal resolution.

Vertical Zoom buttons

This will only magnify the display of the waveform, not
the actual audio data. If you wish to alter the disk data
to increase the actual level of the audio, use the
Normalize command. For more information, see
Chapter 5, “Effects.”

Use the left and right bracket keys ([ and ]) as a quick
shortcut when expanding or contracting the waveform
display.

To store view memories:

1. Set the waveform display so that you are viewing
the range you desire at the magnification you
wish.

2. Command-click any of the four View Memory
buttons.

ENNEREER S
View Memory buttons

To recall the stored view:

* C(lick a view memory button.
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The Deck Magnify and Fit Selection tools allow you to
zoom in and out in steps that are smaller than the
steps between display resolutions. If you are not
paying attention, you may end up with the display
adjusted to an odd resolution. To pop back to the
resolution of your choice, select that resolution on the
Axis Resolution pop-up.

To toggle track size:

* Click the Track Size Buttons to select track size.

The Track Size buttons allow you to select one of four
waveform display modes. The larger modes are best
for locating zero points in a waveform, while the
medium display is best for waveform range or region
editing, and the shortest is quite useful for track
shuffling.

Track Size buttons

To place markers in the Tracks Window Time Axis
(timeline):

* Press Enter on the keypad. Whenever you press
the Enter key, (during recording, playback or
when idle) a red flag—or Marker—is placed in the
Tracks Window Time Axis (or timeline) at the
current location. The numbers that appear next to
the Marker indicates the Marker’s time coordi-
nate.

* To rename a marker, Command-click it and a
naming dialog will appear.

* To delete markers, Option-click them. Pressing
Tab automatically scrolls the Tracks display to
bring the next marker along the Time Axis into
view.

Markers can greatly aid the decision-making and
navigation tasks associated with Tracks window
editing. For example, enter markers while recording or
playing back audio to flag mistakes or keeper passages,
so you can easily locate these areas when you begin
editing. If you tend to get lost when recording long
repetitive parts, use Markers to provide an on-screen

reference to where transitions or changes occur. You
can also use Markers in conjunction with the Tab key
to facilitate locating and returning to parts of your
session where numerous edits or processes are
required.

Markers are identical to Location Times, which are
accessed from the Transport window. Whenever you
create a Marker (by pressing the Enter key) the
Marker’s time or name is added to the Location Times
pop-up menus, and can be accessed through the pop-
up as an autolocate point.

Basic Range Mode and Object Mode
Editing

Range mode lets you select any piece of any waveform
on any track, and slice or copy that piece to create or
alter a region. Object mode lets you select groups of
regions and move those regions for the purposes of
song writing, effects spotting, or general organization.
You can't select anything smaller than one region in
Object mode.

Object and Range Mode buttons

Range mode allows you to select waveform ranges by
dragging across those ranges. Most of the edits you
would perform in Range mode pertain to defining
pieces of an audio track as regions, cutting and pasting
small portions of longer audio regions, and fading or
crossfading sections of audio regions. Object mode is
designed for wholesale arrangement of existing
regions, and general trimming and placement
functions.

For a complete list of keyboard shortcuts that make
editing more efficient, see Chapter 9, “Deck Refer-
ence.”
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To select a waveform range:

1. Click the Range Mode button (or the ~ key) to
make sure you are in Range mode. The button
will be highlighted.

2. Drag over any waveform area.

Range Mode button

Selected waveform range

If you drag anywhere within the selection, you can tear
off the selected range and place it on any track at any
time. If you want to define the selected range as a new
audio region (for later arrangement in Object mode),
you can choose Edit > Slice (Command-R) to create
new regions out of the selected range in place, so no
overall change in timing or audio placement occurs.
You can also process audio ranges with destructive
effects available in the Process menu.

There are a number of key commands that greatly
enhance the Range mode drag-edit functions. For
example, the up and down arrow keys move the
selection range between tracks, holding down the
Option key while pressing the left or right arrow keys
will cause the selection to travel along the timeline,
and holding down the Shift key and pressing the arrow
keys will extend the selection range. Holding down the
Command key when using the arrow keys will let you
move the selected audio.

If you're working in pattern-based music forms, the
Range mode can help you do cookie-cutter editing, so
you can find and edit loops quickly and seamlessly.
Assume you've already recorded or imported a 1-bar
drum loop and pasted copies of it end-to-end in track
one. While listening to this drum loop, you then
record a bass line on track two. Now you can use the
range of the drum loop as a cookie-cutter to ease
selection of a bass passage for looping. Just click once
on any drum loop region in track one, then press the
tilde (~) key. If you were originally in Object mode,
you'll now be in Range mode. If you were originally in
Range mode, press the tilde (~) key once more, to
get back to Object mode. The selection range will now
exactly equal the length of the drum loop. Next, press
the down arrow to move the selection range to your
new bass track. You can audition the bass track (Shift-
Spacebar) and move the selection range along the
track using Option-left/right arrow to find the desired
bass repetition. Slice your best take (Command-R)
then copy and paste it to build a new looped bass
track.

Because you've used your consistent drum-loop
building block as your cutting tool, you won'’t have to
individually edit the begin/end points of subsequent
loops. This editing approach makes the loop
identifying, editing and placement processes much
easier and is an enormous time saver.

To object-select a region:

1. Click the Object Mode button (or ~ key) to make
sure you are in Object mode. The button will be

highlighted.

2. Click the desired waveform region.

Object Mode button
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A selected waveform region

You can hold down the Shift key and click another
region to add that region to the selection. Note that
Deck allows you to select multiple regions which
aren’t next to each other, which can be very useful for
checkerboard-style editing and processing. You can
now edit the selected region in a number of ways. If
you click and drag anywhere within the region, you
can drag and place it anywhere within the Tracks
window. You can accomplish the same thing by
choosing Cut (Command-X) from the Edit menu, and
then placing an insertion point anywhere in the Tracks
window to paste the selection. (You can also delete
the selected range simply by hitting the Delete key on
your Macintosh keyboard, but then it will be deleted—
it won’t go into the Clipboard.) You can use the Edit
menu’s Copy and Paste commands to paste multiple
copies of the region end-to-end (or in any other
desired arrangement). You can also execute destruc-
tive effects on any selected region or regions. To do
50, select the Destructive Effects submenu from the
Process menu. For more information about effects, see
Chapter 5, “Effects.”

Note that when you move a region, the Data Indicator
boxes in the upper right corner of the Tracks window
will update to show you the duration of the region and
the start, stop, and current (mouse) positions. Use
these numbers to help place audio at the desired
sample, frame, beat or second.

Use Option-click and drag to tear off a copy of any
region, while leaving the original behind, Command-

click and drag to paste the current selection at the end
of the preceding region (commonly known as a butt
splice), and the Command-Option arrow key
combinations to move selected audio regions around
in the Tracks window. Note that whenever you move a
region into an area of the Tracks window where other
regions already exist, the region being moved will
actually cut (or edit) any regions it falls onto or
overlaps.

Selecting Axis Units and Managing
the Grid

Deck allows you to adjust any session to show you all
times and waveforms in seconds, samples, SMPTE
frames or bars and beats. You can set these units
based on the type of editing you plan to do, and you
can reset them at any time without worrying about
altering the timing of your tracks. The different units
can be very helpful, and it is important to understand
them, because many Tracks window edit functions are
unit-oriented. One major reason for this is the Tracks
window grid, which is extremely useful for many
arrangement tasks.

Smart Grid

Deck’s smart grid is like an invisible template that
automatically pops your edits to the nearest applicable
unit. It’s called a smart grid because it automatically
adjusts to the most reasonable units for the current
display resolution. For example, if you have chosen
seconds as your Axis Units, the Tracks window grid
can automatically switch between settings—minutes,
10 seconds, 1 second, centiseconds, milliseconds, and
samples—based on how far in you zoom. The Deck
grid is a particularly important tool for musical
arrangement, because it allows you to do drum
machine-style editing of audio regions, and edit
general audio regions to specific tempos. Although
you are free to turn off the grid at any time, it will be
worth your while to learn its basic functions.
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To select time units for viewing the session:

* Select the desired units from the Axis Units pop-
up near the top left of the Tracks window.
Second

E=
SMFTE

Sarnple

Axis Units pop-up menu

These units will be saved as a part of the session, and
when the session is next opened, it will show all time
in these units. Remember, you can change your
chosen units at any time without affecting the
placement of any audio regions.

Beat Mode

If you are working in Beat mode, there is a circum-
stance in which you may wish to have audio regions
stick to their bar and beat placement when tempo is
changed. If you are using Deck as a virtual drum
machine (playing individual drum sounds back as
regions), then you will often want to make sure that
any tempo changes will adjust audio region placement
to make sure that the regions still start at their original
bar and beat locations. In this situation, changing
tempo will alter where bar and beat boundaries occur
in relation to real-time, and bar/beat start times are
considered to be relative times rather than absolute
times. Deck offers a special preference for this type of
editing. If you wish the regions to stick to their bar and
beat locations whenever tempo is changed (in Beat
mode), then see the “Change region start times with
BPM change” preference in the File menu’s General
Preferences submenu. When this option is turned on,
tempo changes in Beat mode will adjust the placement
of audio regions so that they retain their bar and beat
locations. For more information, see Chapter 7, “MIDI
and Synchronization.”

To turn the Grid on and off:

1. Choose Snap to Grid from the Options menu,
which allows you to toggle the grid on and off.
Note also that you can toggle the grid on and off

by clicking on the Grid button directly to the left
of the Axis Units pop-up.

2. Click this button again to turn the grid back on.

Grid button

The Grid button will be highlighted when Snap to Grid
is enabled.

To jump to a specific display resolution:
* Select the desired resolution from the Axis
Resolution pop-up to the right of the Axis Units
pop-up.

1L
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1 Tick

Axis Resolution pop-up menu

This is the fastest and most accurate way to set the
waveform display area to show the resolution you
want. You can now proceed with any edits that should
be based on the current units. Remember, you can use
any of the four Tracks window view memories to store
your current waveform view.

When the resolution is changed, the waveform area is
zoomed in or out at its left side. This may pop the
display to an area that no longer shows the current
selection (or shows its center, but makes it impossible
to see the start or end of the selection). Remember,
regardless of resolution, you can immediately center
the waveform display on the beginning or end of the
current selection. To do so, use Position at Beginning
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(Command-[) or Position at End (Command-]) from
the Option menu’s Selection Tools submenu.

To locate to a specific point in the session, simply click
the Time Axis (also known as the timeline) to jump to
that point. The square black cursor in the Time Axis
indicates your current session location.

Editing Regions

Audio regions are the building block of any Deck
session, and the techniques for creating and defining
regions are among the most important skills to
develop. A region can be created in a number of
simple ways, from simply tearing off a waveform range
to slicing the range in place. Once you have created an
audio region, there is a very simple method to edit the
start and end points of that region. It requires no
special mode, and can be done very quickly.

Whenever possible, make your begin/end points occur
during a silent passage, between sound events. Or;, if
it’s not possible to find a good break between words
or notes, try to cut at the zero-crossing, where the
waveform crosses the line in the middle of the track
display. These simple techniques will help you avoid
audible clicks and pops resulting from abrupt edits.

To re-size an audio region:

1. Click the Object Mode button (or ~ key) to make
sure you are in Object mode.

2. Select the desired waveform region.

3. To re-size the region, click, drag on any of the
four region definition tabs, located in each corner
of the selected object.

Region definition tabs

While you do this, a marquee will appear, highlighting
the new size of the region. You can view the numeric
display in the upper right corner of Tracks window to
see the current size of the region. If you are editing
region size with the grid turned on, the size will
automatically be constrained to the grid.

Remember, an audio region is like a tiny window into
the source sound file. You can adjust that window to
show any part of the sound file, but there is no way to
make an audio region reveal more data than is
contained in the source sound file. When you drag a
region definition tab to re-size the region, but the
region refuses to grow any larger, this means you have
reached the end of the source sound file data.

You can edit the begin and end points of two or more
regions simultaneously by selecting multiple regions in
Object mode. Just click and drag from an empty
section of the Tracks window to create a marquee
selection, or hold down the shift key while clicking on
the regions you wish to select. Then, click any one of
the selected regions’ Region Definition tabs and hold
down the mouse button while re-sizing. All selected
regions will re-size to the begin or end point you set.
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Using Play Tracks and Work Tracks

While Deck looks like a simple multitrack audio
recorder and editor, the concept of virtual tracks
allows you to create mixes that are many layers deep
without bouncing tracks. You can think of it like this:
Deck allows you to record and arrange a virtually
unlimited number of tracks, but at any time you can
choose which of those tracks will play. All tracks other
than the top play tracks in the Tracks window are
called Work tracks. Work tracks do not play back, but
they can be mixed together with the play tracks if you
have the Virtual Mix command enabled. Work tracks
store all information about a track, including automa-
tion. If you do not have the Virtual Mix command
enabled, you can use work tracks as a visual database
of potential playback tracks, arrangements, and pre-
MiX SOUICES.

To move tracks from Play tracks to Work tracks and
back:

* In the Tracks window Control area, click and hold
on the track name of the destination track. You
will see a pop-up listing all tracks currently in your
session. Select the new track. When you let go of
the mouse, the new track and all associated
information will appear on that track.

Fast Cueing and Auditioning

The Deck Tracks window offers a number of shortcut
features you can use to audition specific selections and
autocue a range for loop evaluation.

To audition any waveform range or region:

1. Select the waveform range (Range mode) or
region (Object mode) you wish to audition. You
can select a range or regions on multiple tracks, if
you wish.

2. Select Audition Selection from the Process menu’s
Audition submenu (Command-T, or Shift-
spacebar).

Your selected range or region(s) will play back. On
playback, all audio will be panned to the center, and
automation will be ignored. Note that the Audition
command will play back work track audio, if you have
that audio selected.

To autocue a session range for loop evaluation:

1. Select the waveform range or regions that
constitute the portion of the session you wish to
hear in loop playback. All tracks will play back
when you begin the cue loop, regardless of which
tracks are contained in the selection.

2. Press C. The current selection range is automati-
cally transferred to the Transport window’s begin
and end times, and Loop mode is turned on. You
are now ready to hear the loop.

3. Press the Play button in the Transport window (or
the spacebar on your Macintosh keyboard) to
hear the loop.

The loop will play back repeatedly until you click the
Stop button in the Transport window or hit the
spacebar on your Macintosh keyboard. To turn off the
loop, click the Loop button in Transport window (or
press Option-C).

Loop button

Constructive Fades and Crossfades

The Deck Tracks window offers all of the standard
constructive fade and crossfade functions you would
expect in an audio workstation. Unlike automation
envelopes (which physically control the volume or pan
faders), fades and crossfades create new audio data,
and place that audio data on top of the selected range,
without deleting the original audio data. Crossfades in
particular are extremely important sound design tools,
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because they let you overlap two audio regions on the
same track, and edit the transition between the two
regions so that the first one fades out as the second
one fades in. Normally, this would require two tracks,
but Deck makes it possible to accomplish this on a
single track. This is the kind of range selection you
might make to generate a crossfade between two
regions:

reaqion 1.L Iﬂ!inn 2L
reaqion 1.R Hﬂqmn 2R

If you executed a crossfade in this selection, you
would get the following results. Region 1 will begin
fading out at the beginning of the selected range, and
will be fully faded by the end of the selected range.
Region 2 will begin fading in at the beginning of the
selected range, and will be at full volume by the end of
the selected range. The result of this crossfade would
look like this:

region 1.L gion 2.1

qin:nn 2R

region 1.F

Fades and crossfades are usually based on the current
selection, but Deck offers a number of different fade in
and fade out shapes, which also have a great effect on
the outcome of any fade or crossfade.

Crossfades are based on audio data that is after the
end of region 1 and other data that is before the
beginning of region 2 in the source sound files. If you
attempt to create a crossfade using regions which
reference sound files that contain no data after the
end of region 1 or before the beginning of region 2,
Deck will warn you that there is no data. You will still
be allowed to create the crossfade, but Deck will use
silence as the surrogate data.

—

This curve keeps Region 1 at full volume throughout
the crossfade and then immediately fades it out at the
very end of the selection.

<

This curve fades out Region 1 relatively slowly,
keeping the amplitude fairly high. Towards the end of
the crossfade, the amplitude drops off sharply.

<

This curve fades out Region 1 slightly faster, with the
amplitude slightly lower than the previous envelope.

N

This envelope fades out Region 1 with a linear fade
curve. It creates a smooth, even fade out. It is the
default curve.

Fade out shapes
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.

This curve fades out the amplitude of Region 1
relatively quickly at the beginning of the crossfade.

"

This curve drops the amplitude of Region 1 even more
quickly at the beginning of the crossfade.

L

This envelope silences Region 1 at the beginning of
the crossfade.

Fade in shapes

—

This curve brings up Region 2 at full volume immedi-
ately at the very beginning of the crossfade and keeps
it there throughout the crossfade.

=

This curve fades in Region 2 quickly in the beginning,
reaching full amplitude fairly early in the crossfade.

ya

This curve fades in Region 2 at a moderately fast rate
with slightly lower overall amplitude.

/

This curve fades in Region 2 with a linear fade curve. It
is slightly slower, with an even amplitude throughout
the crossfade. This is the default envelope.

/

This curve fades in Region 2 slowly at the beginning of

the crossfade.

This curve fades in Region 2 even more slowly than

the previous curve.

This curve silences Region 2 until the end of the
crossfade.

Possible envelope combinations

Here are some combinations of Fade Out and Fade In
envelopes that you may wish to try.

Border of region 1 and 2

Region 1 Region 2

Selection range crosses both regions
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Linear Crossfade—A good general purpose
crossfade with a smooth, even transition between
Region 1 and Region 2. If volume drops across the
center of the crossfade, try the equal power

crossfade.

Equal Power Crossfade—A good general purpose
crossfade, useful in cases where a linear crossfade
seems to create an overall drop in volume across

the splice point.

Overlap Fade—This combination of curves keeps
both regions at full amplitude throughout the
crossfade: Region 2 jumps in at the beginning and
Region 1 jumps out at the end.

i

Silence—Choosing these two curves will create
silence for the duration of the crossfade. This
combination is not particularly useful for most

applications.

To fade or crossfade the current selection:

1. Open the Tracks window (Command-3), make
sure you're currently in Range mode (~ key),
then click and drag with the mouse to select the
waveform range you wish to fade or crossfade.

This range must cross at least one region
boundary. If it crosses only the beginning of a
region, a fade in is generated. If it crosses only the
end of a region, a fade out is generated. If it

crosses the border between two touching regions,
a crossfade is generated.

2. Select Fade Selection from the Process menu.

Remember, fade in always begins at the beginning of
the selected region and fade out always ends at the
end of the region. This is true no matter how far from
the beginning or end you select.

Fade in

Fade out

bassriff

Cross fade

To set the default fade/crossfade:
1. Select Set Default Fade from the Process menu.

Crossfade Dut Shapes: Before Splice:

A - NN

Crossfade In Shapes:
— [too0_ Jms
‘ |K—‘/./‘_}‘J‘ After Splice:

Lo« ) I

Cancel ]

The default fade is the basic fade in and fade out
shapes (along with default durations) that are used
when you choose the Fade Selection command or the
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Default Fade command. The Fade Selection command
always uses the default fade curves, but creates the
fade or crossfade according to the current waveform
selection. The Default Fade command always executes
the fade or crossfade using the default fade shapes and
the default fade durations. This is a very useful
command when you want to create tiny smoothing
fades or crossfades, but you don’t want to zoom all the
way in to select a tiny range. The Default Fade
command lets you make large waveform selections
that are capable of creating very subtle fades.
Whenever you want to create a fade or crossfade that
doesn’t use the default fade shapes, use the Custom
Fade command. This command works just like the
Fade Selection command, except it always prompts
you to choose your fade shapes before it creates the
fade.

2. Set your fade in and fade out shapes, and enter
time durations that will be used by the Default
Fade command.

3. Click the OK button.

You have now set your default fade information.

A Remember, Deck allows you to execute fades
and crossfades on any number of regions at
one time. When you select multiple regions and
choose the Default Fade command, all selected
regions are faded or crossfaded using the
default fade shapes and durations. When you
select multiple regions and choose the Fade
Selection command, all selected regions are
faded or crossfaded using the defaull fade
shapes and their whole duration as the fade
durations.

To execute the default fade/crossfade:

1. Make sure you have set your default fade
information as described above.

2. Open the Tracks window and select the waveform
range you wish to fade or crossfade (Range
mode), or any region or regions (Object mode)
you wish to fade or crossfade.

3. Select Default Fade (Command-H) from the
Process menu.

If you have a great number of regions selected, this
process may take a while. After a few moments, the
Deck Tracks window will reappear and all of your
fades and crossfades will be in place.

If you are editing music, dialog, or effects, you can use
the Default Fade command as an auto pop-filter for
correcting the clicks and pops you may have across
region boundaries. To do this, set the default fade
shapes to equal power and the default fade durations
to a short period (60ms, for example). Then select all
regions and choose the Default Fade command. All
regions will be faded in, faded out and/or crossfaded,
guaranteeing that no region transitions will be abrupt.
For more information about fade combinations, see
“Possible envelope combinations” on page 42.

To create a custom fade or crossfade:

1. Open the Tracks window and select the waveform
range you wish to fade or crossfade. This range
must cross at least one region boundary. If it
crosses only over the beginning of a region, a fade
in is generated. If it crosses only over the end of a
region, a fade out is generated. If it crosses the
border between two touching regions, a crossfade
is generated.

2. Select Custom Fade (Command-G) from the
Process menu.

Crossfade Dut Shapes: Before Splice:

A - NN

Crossfade In Shapes:
— [too0_ Jms
‘ |K—‘/./‘_}‘J‘ After Splice:

Lo« ) I

Cancel ]

3. Choose your fade out shape and fade in shape

4. Click the OK button.
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After a few moments, your crossfade will be complete
and you will see it in the Tracks window. Remember, if
there is no audio data in the source file after the end
of Region 1 or before the beginning of region 2, Deck
will warn you that no data is available. However, Deck
will allow you to execute the fade anyway, using
silence as the missing crossfade source data.

If you have selected a waveform range that only covers
a region beginning or a region end, you will see only
one set of fade shapes, rather than two, because you
are executing a fade, not a crossfade.

To delete crossfades:

1. Open the Tracks window and select a waveform
range that touches any crossfade or regions that
contain any crossfades.

2. Choose Delete Fade from the Process menu.

All fades in any regions touched by the current
selection will be deleted. Note that fades and
crossfades are small audio files that are generated
automatically by Deck and placed in the current
session’s Crossfades Folder. When you delete fades,
they will be deleted from your hard disk. However, the
crossfades are not physically deleted until you save the
current session. When you do so, the disk space
occupied by the deleted fades will become available.

When you move regions that are connected by a
crossfade, that crossfade will be deleted automatically.
Any crossfade is related specifically to the two regions
it bridges. The crossfade loses all meaning when the
regions are separated.

Fades and crossfades are generated by Deck from the
original source sound files. Deck always keeps track of
the source sound files, and can recreate the crossfades
automatically if you delete any of them from your
drive. If you ever want to free up disk space consumed
by a session’s Crossfades Folder, you can simply throw
that folder away. The crossfades will be rebuilt
automatically when you next open the session.

Compacting audio that contains crossfades

When you are dealing with crossfades, you must pay
special attention if you plan to use Compact Session or
Compact Audio File later on. Both of these processes
offer an adjustment called Handle Size, which allows
you to choose how much source audio before each
region’s start and after each region’s end will be
retained when the source sound files are compacted
(that is, when unused portions of sound files are
deleted). It is possible to compact a session or sound
file with smaller handles than you would need to
recreate session crossfades. Remember, crossfades are
built from the sound data before the beginning and
after the end of the regions. If you delete crossfades or
perform edits that delete crossfades after you have
compacted with a small handle size, there may not be
enough data to recreate the deleted crossfades.

Using Compact Session and
Compact Audio Files

Compaction is a destructive process, so make sure you
understand what you're doing before you use it. It is
particularly important that you understand the Always
Save Regions when Session is Saved and Rewrite
Regions preferences in the Deck General Preferences
dialog. These preferences have strong effects on the
compaction process. Make sure to read about those
preferences before you compact audio files or
sessions.

Compact Session

The Compact Session function can be very useful.
Because Deck is a non-destructive recorder, audio
data is not deleted when new audio is recorded. This
means that no recording or editing process actually
changes, damages or deletes the original source files,
so you can always go back to previous takes and
versions. The only negative side effect of this
characteristic is that unused takes and throwaway
regions stay on your hard disk, even after you stop
using them. If, for example, you record three voice-
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over takes and decide to keep the second take, takes 1
and 3 remain on your drive even after you remove
them from the session. To permanently delete all
unused audio associated with the current session, you
will use the Compact Session process. To permanently
delete all unused audio from a single audio file, you
will use Compact Audio File.

Compact Session automatically compacts all of the
audio files in the session’s Audio Files folder which are
used in the current session. This is the command you
will always use to get rid of unused audio data (junk
takes, deleted words or unused solos, for example) in
all sound files associated with the session.

Files are compacted in the following way: Deck looks
at the list of audio regions and loops in each audio file.
It then looks through the audio data in each file, and
finds all audio data that is not used in any region. After
the unused audio has been found, it is permanently
deleted from the drive, and all region definitions are
updated.

Compact Session only compacts audio files located in
the current session’s Audio Files folder. It will not
compact audio files located elsewhere on the drive, or
on other drives. This safety feature has been built into
Deck to prevent the accidental compaction of sound
files in a central sound effects library, or of sound files
used in multiple sessions. Make sure you always keep
sound library files and shared sound files in a folders
outside the current session’s Audio Files folder.

To compact a session:
1. Make sure you have deleted all unwanted audio

regions from the Tracks window—Play Tracks and
Work Tracks.

2. Choose File > Preferences > General and turn
on the “Always save regions when session is
saved” and “Rewrite region list” options.

3. Open the Library window (Command-6).

4. Choose Session > Library Operations > Update
from Session.

N

. Save your session (Command-S).

6. Choose Session > Compact Session, set a Handle
Size.

7. Click OK.

The Handle Size setting allows you to keep a little bit
of extra audio data before every region start and after
every region end, which will be useful in the future if
you plan to crossfade the regions. You will probably
want to set your handle size to at least two seconds for
this purpose.

When your session contains crossfades, you must pay
special attention to Handle Size settings. It is possible
to compact a session or sound file with smaller
handles than you would need to recreate your
session’s crossfades. (Remember, crossfades are built
from the sound data before the beginning and after
the end of the regions.) Compacting with too small a
handle size will not alter your current crossfades.
However, if you delete crossfades or perform edits
that delete crossfades after you have compacted with a
small handle size, there may not be enough data to
recreate the deleted crossfades.

Compact Audio File

When you select Compact Audio File, Deck looks
through the audio data in the file, and finds all audio
data in that file that is not used in any region in the
current session. After the unused audio has been
found, it is permanently deleted from the drive, and all
region definitions are updated. The Handle Size
setting allows you to keep a little bit of extra audio
data before every region start and after every region
end, which will be useful if you plan to crossfade the
regions. You will probably want to set handle size to at
least 2 seconds for this purpose.

To compact audio files:

1. Choose File > Preferences > General.

2. Turn on “Always save regions when session is
saved” and “Rewrite region list.”

3. Open the Library window (Command-6) and
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choose Session > Library Operations > Update
from Session.

4. Select File > Compact Audio File.

5. To compact an audio file, just select that file,
enter a handle size and click the Compact button.

This process is permanent, so be sure you want to
alter the selected audio file before you proceed. You
may wish to make a copy of the file if you think you
might want to use it in its original form later on.

Compact Audio File affects only the audio file you
select, unlike Compact Session, which affects all of the
audio in your session’s audio files folder.

Spotting Audio Regions to Timecode

One of the most common tasks in the audio post-
production process is the placement (or spotting) of
sound to a particular SMPTE frame. Deck allows you to
do this in a very simple way using the normal editing
tools.

To spot an audio region to a specific SMPTE frame:

1. Open the Tracks window and set the units of the
window to SMPTE using the Axis Units pop-up.

2. Click the Object Mode button (or ~ key) to
switch to Object mode.

3. Add the audio region you wish to spot using the
process described in “Adding Audio Files and
Regions to a Session” on page 22.

4. Click and hold on the audio region you wish to
spot.

5. Drag the region to the frame you desire.

As you drag the region, the number indicator boxes
near the upper right of the Tracks window are
updated to show the start time, end time, current
time, and duration of the selected range. The current
time is the time that is directly under the cursor.

The current time indicator is particularly useful when
you want to spot a sound to an internal sync point (a
point other than the start or end of the region). If, for
example, you had the sound of a car roaring by, with a
skid sound half way through, you could place the
mouse at the skid sound and spot that sound to the
desired frame.

You do not have to drag the region to place it. You can
also Copy or Cut the region, click to place the
insertion point at the correct frame, and then choose
the Paste At or Paste After command.

If you know the exact time to which you wish to spot a
region, double-click the region, which brings up the
Region Info dialog. You can change the region’s start
time by typing in the new time or capturing one. You
can also change the region’s name by typing in a new
name.

For more information about synchronization and
spotting with Deck, see “Synchronization” on page 93.

Using the Tempo and Time
Signature settings

The Deck Tracks window offers some simple tools that
make it possible to edit audio according to traditional
bar and beat settings. This is an absolute necessity
when you are recording or arranging music to match a
MIDI tempo, click track, or MIDI sequencer track.
When you run Deck with the Metro sequencer, the
tempo settings take on particular importance, because
they allow you to match bar and beat edits between
the two programs. For more information about using
Deck with Metro, see “Using Deck with the Metro
Sequencer” on page 90.

To set and use Deck’s tempo and time signature
information:

1. Open the Tracks window and set the units of the
window to Beat using the Axis Units pop-up.
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2. Drag on the Tempo selector to set a new tempo.

Tempo selector

3. You can also hold down the Command key and
click the selector to enter the new tempo or time
signature as text. Then press the Return key on
your Macintosh keyboard to apply the change.

4. Drag on the time signature numerator selector to
set the number of beats to a measure.

N

. Drag on the time signature denominator selector
to set the value of the note that should be
considered one beat.

For example, setting this to 4 means that a quarter
note is considered to be one beat.

These values are very useful for song-oriented
arrangement. When you set these values, you are
determining the units that will be used by the beat
mode axis markers, and the associated grid settings.
Note that the tempo and time signature values only
effect the way that Deck’s Tracks window Time Axis,
Grid, and numeric indicators functions (and, of
course, the Transport window’s counter). The tempo
and time signature values do not alter the placement
of any audio regions unless you have configured Deck
as described in the following Important message.

If you are using the Metro sequencer, you will
find that any tempo and time signature
changes you make in Metro will automatically
be made in Deck. Also, any current selection
range in Metro’s Note Editor or Tracks window
will automatically be selected when you switch
1o Deck. Note, however, that changes made to
tempo and time signature in Deck are not
passed to Metro when you switch (Metro is
designated as the tempo master), so you should
change your tempo and time signature

information in Metro if you are running both
programs. Remember, Deck supports tempo
maps, so Metro tempo maps will always be
reflected on the Deck Tracks window axis
markers (when you are in Beat mode).

If you are working in Beat mode, there is a circum-
stance in which you may wish to have audio regions
stick to their bar and beat placement when tempo is
changed. If you are using Deck as a virtual drum
machine (playing individual drum sounds back as
regions), you will often want to make sure that any
tempo changes will adjust audio region placement to
make sure that the regions still start at their original
bar and beat locations. In this situation, changing
tempo will alter where bar and beat boundaries occur
in relation to real-time, and bar/beat start times are
considered to be relative times rather than absolute
times. Deck offers a special preference for this type of
editing. If you wish the regions to stick to their bar and
beat locations whenever tempo is changed (in Beat
mode), then see the “Change region start times with
BPM change” preference (under General preferences
in the File menu’s Preferences submenu). When this
option is turned on, tempo changes in Beat mode will
adjust the placement of audio regions so that they
retain their bar and beat locations. For more informa-
tion, see Chapter 7, “MIDI and Synchronization.”

Using an External Editor

Deck allows you to assign an external audio editing
program, such as BIAS Peak, which can be launched
from within Deck and used to process audio files.

Deck is designed to allow you to run an external editor
and Deck at the same time, and Deck’s Launch Editor
command automatically switches you into the other
program.

Editing audio in programs that recognize audio
regions is different than editing in programs that do
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not recognize regions. Both methods are discussed in
the following section.

To use an external editor with Deck, you will have to
have sufficient RAM to run both programs. Use the
Finder’s Get Info command to find out how much
RAM you audio editing programs requires.

To set an external sound editor:
1. Choose File > Preferences > General.
2. Click Set to the right of Sound Editor signature.
3. Locate and select your editing program.

4. Click Open.

General

Autostop at end of Session [ Change region start times with BPM change
[ Always save regions when Sessionis saved [ Loop auciition

[ Rewrite region List [ Scroll atter play:
[4 Stop audio playback if the drive is tee slow [ Enable multi-processing suppert

[4 Show wamingif virtual memory is on

Update speed during playback (1-10): E Transport key

SMPTE Preroll Time: [4.000_|seconds Lags IG5 dhel || B || Gy || G
@ | > | @ |®
(Bey | (sey | (sey | (sey

Sound Ediitor signature: auFM

estey Waveform

[ Use desktop curtain

Curtain top
Curtain bottom

Wavaform highlignt ] Use waveform highlight
Wavaform baskground

Empty region

i

Set Sound Editor signature in the General preferences dialog

To edit Deck audio files using an external editor:

1. Make sure you have selected your sound editor
using the process described above.

2. Make sure the Tracks window is in Object mode
and select the region or file that you wish to edit.

3. Choose Process > Launch Editor (Command-E).

You will immediately be launched into your external
editor, and the entire audio file that contains the
selected region will be opened in that program. You
can now perform any edit you desire, and when you
save the change and switch back to Deck, the changed
sound file will play back.

Edit your audio with care if you plan to play it from
Deck again. If you destructively delete a waveform
range or change the length of the file, you will change
the overall timing of the Deck track(s), and your
Tracks window arrangement may be permanently
altered. It is a good idea to work with a copy of the
sound file if you can.

Using BIAS Peak as Deck’s External Editor

Editing audio regions using Peak as external editor is a
bit different than using any other editor, since Peak
recognizes the concept of audio regions.

To edit a Deck audio region in Peak:

1. Make sure you have selected Peak as your sound
editor using the process described in the previous
section.

2. In the Tracks window, switch to Object mode.
3. Select the audio region you wish to edit.
4. Choose Process > Launch Editor (Command-E).

You will immediately be launched into Peak, and the
selected region will be opened in that program. The
region will be highlighted. You can now perform any
edit you desire, and when you save the change and
switch back to Deck, the changed sound file will play
back.

Only changes made to the waveform and saved will be
reflected in Deck.

Conclusion

You have learned how to edit and manage audio
regions in Deck, proceed to the next chapter to learn
about Deck’s Built-in destructive and real-time effects
as well how to use Premiere format and VST plug-ins
with Deck.
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Chapter 5
Effects
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Chapter 5:
Effects

The effects available in Deck fall into three basic
categories: Destructive effects that actually rewrite
audio files; non-destructive real-time, in-line effects
that act in much the same way as standard external
effects boxes or the EQ controls on an external mixer,
affecting the signal in real-time during playback or
mixdown, leaving the source audio file intact; and
Plug-Ins.

Deck plug-in effects use both the Adobe Premiere
plug-in architecture and Steinberg VST plug-ins, and
are designed by third-party developers such as
Arboretum Systems and Waves. These are separate
optional software packages that may be purchased
from these developers.

You may also choose to use other stand-alone sound
editing programs— such as Peak—to destructively edit
Deck audio files. Virtually any digital audio editing
program that works with Deck-supported audio
formats can be assigned as an external editor in Deck,
and can be launched from within Deck with a single
command.

Deck’s destructive effects

There are certain cases where you might want to
change the actual audio data in a destructive, or
permanent, manner. Suppose you have recorded a
perfect solo, but the overall level is slightly low (or the
waveform seems short). You would definitely want to
increase the level of that track to its maximum. All the
destructive effects are on the Process > Destructive
menu.

Normalize—looks at an audio region (or group of
regions) and automatically adjusts amplitude
(volume) to the maximum allowable level. This
allows you to bring up low-level signals to a
reasonable level, which uses all of the amplitude
resolution available on your system.

Group Normalize—functions in the same manner
as Normalize, except that it finds the peak over a
group of regions and adjusts each region the
same amount.

e D i T it e

v-bazzrifi.E

Waveform before Normalizing

v-bazzritf.E

Waveform after Normalizing

Reverse—takes the selected audio region (or group
of regions) and turns them around so they are
backwards. This is quite useful for specialty effects
and preprocessing effects such as pre-echo.

Invert—flips the audio region (or group of regions)
upside-down. This does not alter the sound of the
region(s), but can be very useful for matching
waveforms for looping and general sound design
tasks.

Duplicate—physically duplicates the range or
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region(s) you have selected and copy the new
audio file(s) to that session’s Audio Files folder.
This is useful if you have copied an audio region
several times in your Deck session, but want to
have only one instance of that audio file affected
by an edit, for example. Deck will make a separate
physical copy of that region in the Audio Files
folder, and changes made to it will not affect
other copies of that region.

To normalize, reverse, invert or duplicate a region or

group of regions:

1. In the Tracks window, select the range or

region(s) you wish to process.

2. Choose the desired effect from the Process >
Destructive Effects submenu.

3. Whenever you perform a destructive effect, Deck
will ask you if the process should be executed on
a copy. Signal processing permanently changes
audio data, and it can’t be undone, so it is always
a good idea to select Make a Copy when using
destructive effects.

4. Click OK or Make a Copy to continue.

If you chose Make a Copy, the copy has been placed in
the position of the original audio region, but the
original region has not been altered.

Real-time effects

Deck offers built-in real-time, in-line non-destructive
effects that are available during playback. The real-time
effects in Deck are: Parametric EQ (single and 4-band),
Delay, Chorus, Hi Shelf EQ, Lo Shelf EQ, Gain, and
Graphic EQ.

These effects are available at each play track’s Mixer
module, and can be configured in the Effect window.
You may assign up to four real-time effects to each
play track. The quantity of each kind of effect you will
have available in the Mixer window and the configura-
tion of the Effect window can be altered in the

Preferences menu’s Effects submenu.

These effects are simple to use, and have an intuitive
graphic interface that is similar to that of any multi-
effects box. In fact, these effects are easier to use than
many hardware multiprocessors, as all the controls for
all of the effects you have chosen are available to you
in a single window.

Assigning effects to play tracks

In Deck, create a new session, or open an existing
session. Open the Mixer window from the Windows
menu (Command-2). You will notice four boxes
labeled Thru at the top of each track’s mixer module.

Effect Selector pop-ups at top of each mixer module

These are the Effect Selector pop-ups. When you click
and hold on Thru in one of the Effect Selector boxes, a
pop-up menu will appear containing the names of all
the Built-in and VST effects available to you. Keep
holding down the mouse button, and scroll through
the list to select an effect to add to that track. (Note
that you can add up to four effects to each play track
by using each of the track’s selector boxes.) Choose
one of Deck’s Built-In effects for the Effect Selector
pop-up menu > Built-in FX submenu.

Thru
Open editor...

Euilt=in Fi Gain

Hi Shelf EQ
Lo Shelf EQ

GraEhic EQ)

EQ-4

Built-in FX submenu in the Effect Selector pop-up menu
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Once you have added effects to your play tracks, you
will see the names of the effects you've selected in
these selector boxes.

Effects selected, the Delay 1 effect is bypassed

You will now hear the effects when you play back your
session. To temporarily bypass an effect, click the
Bypass Button to the left of that effect’s selector box,
and click again to turn the effect back on—the Bypass
Button will be highlighted with the effect is on. This
allows you to turn the effect on for only part of a track,
or to hear the track with and without the effect while
keeping the changes you've made to that effect’s
settings.

To remove an effect and all of its settings from a track,
click that effect’s selector box and scroll up to Thru.
This removes the effect and all of its settings from that
track, but you can always add it, or a different effect, at
any time, and re-configure it in the Effect window.
Now open up the Effect window from the Windows
menu (Command-7). You will see slider controls
corresponding to each of the effects that you have
selected for your session in the Effect window. The
following example shows the Effect window with
multiple effects.

Effect

L [+[v]Z

Effect window

Each effect has a different set of parameters that you
can change to tailor each effect to your needs. Even if
you have chosen one kind of effect for multiple play
tracks, the settings of each track’s effect can be altered
independently of the others. You literally can have up
to four independent effects per play track. Note
however that the actual number of possible simulta-
neous effects is determined by your computer’s clock
speed. You can monitor your system in the CPU Meter
window and avoid exceeding your system’s capabili-
ties.

You will know you have applied too many real-time
effects in a session when Deck starts to behave
erratically. When this occurs, it is a good idea to
reduce the number of real-time effects applied. The
Graphic EQ is the most processor intensive real-time
effect.

Adjusting Effect parameters

Each effect has a different set of parameters that can
be adjusted using the sliders in the Effect window. For
example, the Graphic EQ sliders work like a real
graphic EQ. You can boost or cut each frequency by
moving the sliders.

Graphic EQ Effect sliders in Deck

Many of the effects work in tandem with the Transport
window. For example, as you move the Frequency
slider in the EQ window, the value represented by that
slider will be shown in the Control Value Indicator box
(upper left) of the Transport window, and will track as
you change values by moving the slider. This can be
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very useful for isolating a particular frequency with the
EQ, or for finding a specific delay speed for the Delay
or Chorus effects.

The following diagram shows the Transport window
tracking an EQ Frequency slider.

Notice that the mouse cursor is on the frequency
slider, and the value of that slider is shown in Hz in the
Transport window’s Control Value Indicator box.
Using the Transport window to track each slider can
help you set the various parameters of each effect. You
may want to test each effect individually on the same
track to get acquainted with them.

Remember that these effects are non-destructive, and
will not affect audio files, ranges or regions. They are
available on playback, and during mix to disk
operations, and you can turn them on and off and
change the settings at any time, even on the fly during
playback.

About Deck’s Built-in Effects

Here is a brief description of all of Deck’s real-time
effects, and the different parameters you can adjust for
each of them in the Effect window.

EQ (single and 4-band), Hi EQ, Lo EQ, Graphic
EQ (7-band)—Can be thought of as a very
flexible version of the Treble and Bass controls on
your home stereo. EQ allows you to isolate and

boost, or cut, certain frequencies (that is, turn
them up or down). You might use this to add
mid-range punch to a bass track, or to remove
sibilance from a vocal.

Deck’s EQs (single and 4-band) allow you to
select the frequency affected, the gain (the
amount of cut or boost) and Q, or resonance, for
each EQ selected. The Hi and Lo EQ, are shelf
EQ’s that allow you to select the frequency and
gain of the shelf, or threshold. The Graphic EQs
operate as 7-band graphic equalizers, with a slider
to boost or cut each of the 7 frequency bands.
Both the Graphic EQ and the 4-band EQ are
processor intensive.

Delay—Adds a delayed copy of the audio at specified
intervals, creating an echo effect. A short delay, or
slapback, sounds good on rock vocals and
rockabilly guitar, and sounds almost like reverb. A
long delay yields long, spacey echo effects.

The Delay effects in Deck offer you control over
the delay time (length of delay), amount of
feedback, cutoff frequency and “wet,” or percent
of effect, compared to “dry,” or unaffected, signal.

Gain—A one-control-slider effect, which gives you a
+18/-18 dB gain stage. Try using it pre- or post-
EQ. This is essentially a preamp, or attenuator,
which either increases or decreases the amplitude
(volume) of your playback track.

Chorus—Is really a short delay with modulation. The
delayed sound is mixed with the unaffected audio
to create a thicker sound, and with extreme
settings, a woozy sound. Chorus adds a lot of
body and richness to vocals and guitar, and at
extreme settings makes an excellent special effect.

The Deck Chorus effects allow you to choose
amount of delay, speed, depth of modulation and
“wet,” or percent of effect, compared to “dry,” or
unaffected, signal.

Multitap—Designed to use multiple delays to
simulate reverb-like effects. Multitap is processor-
intensive.
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Setting effects preferences

You may want to change the way the Effect window is
configured, or change the quantity of each kind of
effect available. You can change these settings by using
the Effects Preferences menu.

Effects Preferences

@ Make rows as wide as the window
(e} El sliders per row

Effects

Allocate

EQ 8

Delay 2
Chorus

Hi Shelf EQ
Lo ShelfEQ
Graphic EQ
Multitap

i

ol S-S S

Number to Allocate: |4

Delay line length: |500 mS

[ cancet | [ ok |

Effects Preferences dialog

You can use this dialog to specify how you want the
Effect windows sliders to be arranged, and to select
the number of each kind of effect you want to have
available to you in the Mixer window’s Effect Selector
boxes. You can also select the maximum length of
delay in the delay effects by entering the value, in
milliseconds, into the Delay Line Length field.

Premiere Plug-ins

Premiere format plug-in audio effects for Deck are
currently available from third-party developers
including Arboretum Systems and Waves. You don’t
need any extra hardware to use Premiere plug-ins—any
Macintosh that is supported by Deck should also run
the plug-ins. Although features and interfaces will vary
quite a bit depending on which plug-ins you add, you
can expect to greatly enhance your audio processing
capabilities by using Premiere plug-ins.

You don’t need Adobe Premiere to use Premiere-
compatible effects plug-ins with Deck. We have simply
adopted the architecture that Adobe defined for
Premiere audio plug-ins, as it represents a simple and
open alternative to controlled standards such as the
sound designer or TDM plug-in architectures.

The Plug-ins that come with Adobe Premiere
itself cannot be used in programs other than
Premiere.

Premiere format plug-ins are separate software
packages that can be purchased, copied to your hard
drive, and placed in the Deck Plug-Ins folder. Your
plug-in effects will be listed in the External Effects
submenu.

Although Premiere plug-in effects are destructive,
meaning that they physically rewrite audio files to
contain the processed audio data, they create a copy
of your audio file, and work from that copy. Plug-in
effects will also remove any crossfade information
from the region, and may also remove automation
data from the portion of the track that you have
processed. It is a good idea to add crossfades and
automation after processing audio with plug-in effects.

Note that you may have to leave extra RAM free in your
system in order to use these effects. The more RAM
you can leave free for your Premiere format plug-ins,
the longer preview time you will have to audition the
effect before you process the audio file.

Previewing (or auditioning) plug-in effects occurs
through the Apple Sound Manager. If you are using an
Apple Sound Manager compatible sound card, be sure
that you have installed its Sound Manager drivers and
that it is selected for Sound Out in the Apple Sound
control panel.

To apply a Premiere format plug-in:
1. Select the audio in the Tracks window, either in
Range Mode or Object mode, that you want to
process.
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2. Choose the plug-in you want to process your
audio with from the Process > External Effects
submenu.

3. Adjust the settings of the plug-in and preview the
plug-in before processing the selected audio.

4. Click the Process button in the plug-in to process
the selected audio.

Deck will then process the selected audio with the
plug-in and redraw the waveform.

VST Plug-ins

Deck s supports VST 1.0 format plug-ins. VST is a
standard audio plug-in technology developed by
Steinberg Software und Hardware, GmBH. VST plug-
ins offer an exciting array of real-time effects by
companies like Steinberg, Cycling ‘74, Arboretum,
Waves, and others.

You can chain up to 4 VST plug-ins per channel in real-
time using Deck, as long as you have a fast enough
CPU in your Macintosh—VST plug-ins are real-time,
host-based audio plug-ins that are dependent on the
host processor (i.e., your Mac’s CPU). Use the CPU
Meter window to monitor system usage so as to not
overtax the system when using VST Plug-Ins.

Installing VST Plug-Ins

VST plug-ins are installed in the VstPluglns folder in
the Deck folder. VST Plug-ins are not installed in the
Deck Plug-Ins folder, rather the Deck VSTPluglns
folder. To install a VST plug-in, consult the documen-
tation that came with your VST plug-in.

Organizing VST Plug-Ins

Deck allows you to organize your VST plug-ins in sub-
directories. Create folders in the Deck VSTPluglns
folder and move VST plug-ins into these folders. Doing
this will organize your VST Plug-ins into submenus in
the Effects Selector pop-up menu in the Mixer window
and the Master Outputs window.

Thru

Open editor...

Euilt-in FX »

Ambisone 2.0

Auto-Tune YST 1.20

EChorus

beat

Choirus H-VST Auto Pan
Choirus2 H-VST Band Pass
Cyanide H-"ST Band Re ject
D-Pole H-YST Bass Maximizer
davesplugins_200 Folder p| H-VST Chorus

dB ProDelay H-YST Compressor
DelClickert H-YST Doppler
DeClickers H-"ST Echo

DeMoisert1 H-"ST EchoTranz™
DeMoizerS H-VST Flanger

ESpacial! H-%ST Formant Pitch Shifter
Externalizer H-YST Freguency Shifter
FraserStuart

Freeverb H-YST Hall Reverb

Fuzz H-YST Harmonic Exciter
Gain H-"ST High Pass

GRM p| H-VST HyperPhaser™
Hyperprism [ H-YST HyperVerb

Karlette
EwikkKompZWST

H-VST Lirniter
H-YST Low Pass

Isd Folder p|  H-YST M-S Matrix
PMayhemn p| H-YST More Stereo

MDA B H-YST Multi Delay
MorthPole™ YST Resonant Filter p| H-VST Moise Gate

Opcode p| H-YST Pan

pluggo f p| H-¥ST Phaszer

PolyFractus DR-Yerb H-¥ST Pitch Changer
prodelay_rac_%100 p| H-YST Quasi Stereo
PROSONIG Orange Yocoder H-YST Ring Madulator
FROSONIQ Yocoder Carrier H-YST Room Reverb
RingMod_YST_Mac Folder B H-VST Single Delay
Steinberg p| H-YST Sonic Decimator
TapMet0Z3100 Falder p| H-YST Stereo Dynamics

TC p|  H-YST Tremolo

Trash Coderd.Sh (3 H-YST Tube-Tape Saturation
vhox aliaz H-VST Mibrato

WAYES pl__H-WST Yocoder

Effects Selector pop-up with VST plug-ins and submenus

Inserting VST Plug-Ins

To insert a VST plug-in in the Mixer window:

1. In the Mixer window, select a VST plug-in from

the Effects Selector pop-up menu on the channel

you want to apply the effect to.

2. Choose Open editor from the Effects Selector

pop-up menu or Option-click the name of the VST
plug-in to open its editor.

3. Press the space bar or the play button in the

Transport window to hear the audio processed by

the VST plug-in.

4. Adjust the settings of the VST plug-in.

5. You can hide the VST plug-in editor by clicking in
the close box of the plug-in editor or choose File
> Close (Command-W). The plug-in will remain
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active until you remove it, by selecting Thru in the
Effects Selector pop-up menu. To make the editor
of an active VST plug-ins reappear, simply choose
Open editor from the Effects Selector pop-up
menu or Option-click on the name of the VST
plug-in in the Effects Selector box.

VST channel inserts in the Effects Selector boxes on a channel in the
Mixer window

A The Mixer window supports mono to mono,
and stereo to stereo VST plug-ins. You can use
mono 1o stereo VST plug-ins in the mixer
window, but they are treated as stereo 1o
stereo, so you should pan your signal hard
lefi—panning to the right attenuates the signal
towards -,

To insert a VST plug-in in the Master Outputs window:

1. In the Master Outputs window, select a VST plug-
in from the Effects Selector pop-up menu from
either the left or right channel, or the stereo
channel pair that you want to apply the effect to.

2. Choose Open editor from the Effects Selector
pop-up menu or Option-click the name of the VST
plug-in to open its editor.

3. Press the space bar or the play button in the
Transport window to hear the audio processed by
the VST plug-in.

4. Adjust the settings of the VST plug-in.

5. You can hide the VST plug-in editor by clicking in
the close box of the plug-in editor or choose File
> Close (Command-W). The plug-in will remain
active until you remove it, by selecting Thru in the
Effects Selector pop-up menu. To make the editor
of an active VST plug-ins reappear, choose Open
editor from the Effects Selector pop-up menu or

Option-click on the name of the VST plug-in in
the Effects Selector box.

W theo TN Thes T
o Treo TS Theo T

o Ttreo IS Thes T
B  rdaLimiter ")
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VST channel inserts in the Effects Selector boxes on stereo channels in
the Master Outputs window

The Master Outputs window supporis mono to
mono and stereo 1o stereo VST plug-ins.

Mono, Mono to Stereo, and Stereo VST
inserts

Mono to stereo VST plug-ins are not generally
supported by deck. However, you can use them in a
stereo location with the caveat that the plug-in is
throwing away the right channel.

If you want to use a stereo insert on a pair of mono
tracks, put your mono tracks on adjacent tracks, pan
one hard left, pan the other hard right, then place the
stereo effect on the Master Outputs for that pair.

If you select the wrong type of insert, Deck will warn
you and give you the option of canceling your
selection by clicking on the Oops button, or keeping it
by clicking on the Ignore button.

Validate

You have selected a mono->stereo plug-in
in astereo location. Please select a stereo
plug-in for this insert.

(Coces J
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Mono to Mono plug-ins in a stereo insert mute
the right channel (you hear effect if panned hard
left, silence if panned hard right).

Mono to Stereo plug-ins in a stereo insert mute
the right channel (you hear effect if panned hard
left, silence if panned hard right).

Mono to Stereo plug-ins in a mono insert throw
away the right channel coming out of the plug-in.

Stereo to Stereo plug-ins in a mono insert is
generally not allowed. However, in the rare
instance where it is, it throws away the right
channel coming out of the plug-in.

To remove a VST plug-in:

* Choose Thru from the Effects Selector pop-up
menu. The VST plug-in on that insert will no
longer be active.

Signal flow by channel

In the Mixer window, built-in and mono-to-mono VST
effects are run mono-to-mono at the top of the chain
(pre-fader, pre-pan pot), and stereo-to-stereo VST
effects are run after the built-in effects, after the fader
and pan pot.

Disk channel Digk channel Disk channel
Buit-in FX Built-in FX Built-in FX
iz bz Mo

> window| > window| O window
meter meter Ineter

Digk channel I Disk channel I Digk channel
Built-in FX Built-in FX Built-in FX.
Mo ez

> O window O wirdow
Ineter meter

bz
window
meter

I =] | =]

= | == | | ===

VBT FX VBT FX VBT FX VBT FX VBT FX
2-527 2-527 2227 2-527 2-527
¥
VBT FX VBT FX WETFX VBT FX
1-=1 1-=1 1-=1 1-=1
haster htastar
Master output ;‘:&‘:‘ Haster output ;“e‘tpe‘:‘

Output pair 1-2

TYAT 1.2 (monn to steren) sffacts are supported, however since they appear AFTER
the channel pas, they oaly respond to signal on the laft channsl. To hear 1-=2 V5T effects,
pan the channel hard left, panning to the right attena tes the signal down to -==.

Output pair N-N+1

** V5T 1-52 (mono to staren) effects ate supported, however since they appear in
a STEREOQ position, they only process signal on the left channel and disregacd
what was on the zight channel
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A Ifyou try to assign more VST plug-ins than your
CPU can bandle, audio may begin to playback
erratically. Use the CPU Meters window to
monitor the CPU usage when assigning VST
plug-ins.

Bouncing your VST plug-in assignments

Once you have the right settings for your VST plug-ins,
you may want to permanently apply the effects to the
track(s) to which the VST effects are assigned. Simply
solo the track(s) you want to process and Bounce to
Mono or Bounce to Stereo Clipboard, and then Paste
the clipboard to any available track(s). Active VST plug-
ins will also be applied using the Mix to Disk function.

To bounce VST plug-ins:

1. Solo the track(s) with active VST plug-ins that you
wish to bounce.

2. Choose Process > Bounce to Mono Clipboard or
Process > Bounce to Stereo Clipboard.

3. Place the cursor on the track(s) in the Tracks
window where you wish to place the processed
audio.

4. Choose Edit > Paste (Command-V).

5. Change the VST plug-in(s) to Thru in the Effect
Selector pop-up menu in the Mixer window for
the original track(s).

6. Disable the solo button(s) in the Mixer window
for the original track(s).

7. You may choose to mute the original track(s) or
mix it with the processed track(s).

8. Press the spacebar or click the Play button in the
Transport window to hear the mix.

@ Deck LE does not support VST plug-ins.

Conclusion

You have learned how to use Deck’s built in destruc-
tive and real-time effects as well as how to use
Premiere format and VST plug-ins in Deck. Proceed to
the next chapter to learn about volume and pan
automation, mixing, and mastering in Deck.
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Chapter 6
Automation, Mixing, and Mastering
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Chapter 6:
Automation, Mixing,
and Mastering

Mixing and mastering are generally the final steps in
any audio post-production process. They generate the
finished product which you will publish or deliver to
clients. This chapter covers mixer-based automation,
mixing, and mastering.

When you have finished this chapter, you will have all
of the knowledge necessary to take a Deck audio
project from start to finish and produce a finished
digital audio master.

Mixer-based Automation

The process of mixing down a multitrack recording to
a stereo master is always complicated by the level and
stereo pan changes that must occur during the
mixdown process. Smooth fades in and out, instanta-
neous pan changes that are modulated to a specific
rhythm, usually require quite a bit of physical
coordination and they are difficult to repeat. This is
why high-end mixing boards offer automated mixdown
capabilities.

Deck allows you to create and record mixer automa-
tion so you can fully automate your mixdown process.
Perhaps the simplest way to automate a mixdown is to
create and edit visual volume and pan envelopes in the
Deck Tracks window.

Deck also offers more traditional real-time mixer
automation that is based on the idea of performing a
mix and recording the motion of the faders during the
performance. This mixer-based automation also
creates automation envelopes that can be edited

visually in the Tracks window. To accomplish mixer-
based automation, Deck uses the concepts of real-time
fader motion recording, mixer states, and transition
time. Real-time fader motion recording records the
actual movement of Deck’s mixer faders, and is a
simple, intuitive way to create automation.

Mixer State Automation is scene-by-scene oriented. A
mixer state is like a picture of the current position of
every fader on the mixer. Each state is stored on
Deck’s Mixer State pop-up in the Transport window,
and each can be recalled at any time. A fixed transition
time can be set, and that time is always used to fade
smoothly between each mixer state.

Although real-time recording of fader motion and
mixer states may seem a bit cumbersome at first, you
will find that it often allows simple, one-step recording
mixdown automation.

To record real-time fader motion:

1. Open the session that you wish to automate and
open the Mixer window by selecting Windows >
Mixer (Command-2).

2. Decide which track volume and pan faders you
wish to automate.

3. Use the Automation pop-up on these tracks to
select which automation you wish to record. You
can choose Record Volume, Record Pan, or
Record All. You can choose your controls by track
(for example volume on track 1 and pan on track
2), or you can use the Options menu’s Automa-
tion submenu to record all volumes and pans by
choosing Record All.

Automation, Mixing, and Mastering
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Automation pop-up menu

A Although it is possible to record automation
using the mouse as a controller, you may find
this cumbersome, as the mouse can only move
one control at a time. For the best possible
results, use an external MIDI controller (e.g., a
Peavey PC-1600 or Tascam US-428) to control
the mixer faders that will be recorded. See
“MIDI Setup” on page 87 and “MIDI Key Maps”
on page 88.

4. Click the Transport’s Record button, then click
the Play button (or press Spacebar) to begin
recording automation.

N

Perform your mix as desired. All motion of record-
enabled faders will be recorded.

6. Click the Transport’s Return-to-zero button
(Return), and click the Play button (Spacebar) to
see and hear your new automation.

Deck’s recording functions work the same way with
automation as they do with audio. For example, you
can use punch-in mode to replace a segment of
automation just as you would replace a segment of
audio.

You can erase the automation on any track by using
the erase commands located on the track’s Automa-
tion pop-up. You can also use this pop-up to mute the
automation on any track by setting the pop-up to Off.

Although the faders’ movement may appear jumpy, do
not be deceived by this. Deck automation is always
reproduced with 24-bit accuracy (over 16 million
values between full volume and no volume). Updating
the screen has a lower priority than the control of
volume and pan level. Your automation will always
play and sound smooth even when the faders appear
to jump.

To view the visual envelopes for the motion you have
Jjust recorded:

1. Choose Windows > Tracks (Command-3).

2. Set the Display pop-up on the track that contains
the automation you wish to edit to Volume or
Pan.

Mone
Fan

Display pop-up menu

You can now see and edit the automation envelope
you created when you recorded real-time fader
motion. (In the illustration, track 2 is set to display the
volume envelope.) If you wish to edit these envelopes,
you will find it easier if you first choose Automation
Thin from the Process menu. Automation Thin will
look for straight lines in your automation data and
eliminate extraneous breakpoints.

Visual Automation Envelopes

Controlling the volume and stereo placement of sound
is the essence of a mix. Deck allows you to control the
volume or pan of any playback track in real-time, and
also makes it possible for you to record volume and
pan fader motion as you perform it. The concept of
performing a mix is a traditional one, but is only one
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way to automate a mix.

With the advent of the digital audio workstation, many
other methods for creating automated mixes have
surfaced. The simple visual editing of a line graph
(envelope) to control volume and panning is one of
the most powerful and flexible of these new methods.
Deck allows you to create and edit all automation data
in this fashion if you wish.

Let’s say you had a region of audio and you wanted it
to come in loud, decrease in volume for about half its
duration, and then increase slowly back to full volume.
In the analog world you would play back your tape
deck and use your automated mixing board to record
yourself making the physical fader motion. In Deck,
you could simply open up the Tracks window, find the
audio region, and create this volume envelope.

Volume automation envelope with highlight breakpoint

The volume in this illustration is controlled (and
indicated) by the thick line. The lower the line goes,
the lower the volume; the top of the track is full
volume and the bottom is no volume. If you look
closely, you will see a number of breakpoints in the
line where the angle of the line changes. Creating
these points, which are automatically connected by
lines, is the simplest method you can use to automate
a mix. Adding and editing these points allows you to
alter the mix in very exact ways. These automation
envelopes can be edited using the same basic Tracks
window functions you use to edit the waveforms.

To create an automation envelope:

1. Use the Track Automation View pop-up to choose
the type of automation envelope you plan to
create or edit. To set all tracks to the same
automation type, Option-select the automation

type.

Mone
Fan

Track Automation View pop-up menu

2. The track audio data will dim to light gray which
indicates that you cannot edit audio data at the
same time as automation. When you have the
Track Automation View pop-up set to None, then
you will be viewing and editing only normal audio
waveform data in the waveform area. When the
pop-up is set to Volume, waveform data will still
be shown, but only volume envelopes can be
created and edited on the track. In this situation,
up is full volume and down is no volume. When
the pop-up is set to Pan, waveform data will still
be shown, but only stereo pan envelopes can be
created and edited on the track. In this situation,
up is left channel and down is right channel.

3. You can view the exact setting of any volume or
pan envelope breakpoint by looking at the level
or pan indicator on that track as you move the
point. The exact current value will be shown as
you adjust any point.

4. To create an automation point, hold down the
Command key and click the mouse anywhere in
the track.

N

. Asyou do so, an automation breakpoint appears,
along with the associated flat automation line.
You have now set a single level setting.

6. Continue Command-clicking anywhere over the
waveform to create more automation points and
develop the general envelope shape you wish. To
insert a breakpoint with the same vertical value as
the previous, hold down the Control and
Command keys and click the new location.

At any time you can play back the audio using the
Transport window controls (or the spacebar) to hear
the new automation. If you open the Mixer window,
you can also see the new fader moves reproducing the
envelope you just created.

Automation, Mixing, and Mastering
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To adjust a breakpoint:

* Click the point and drag it to a new position. To
constrain the time to the nearest whole axis unit,
hold down the Shift key while dragging.

To delete a breakpoint:
* Hold down the Option key and click that point.
When you are done, you can set the Track Automation

View pop-up to None to hide the automation
envelope.

You can now continue editing audio waveform ranges
and regions, if you wish. As long as the Automation
Status pop-up is set to the Play position, all automa-
tion on the track will play back.

To edit automation envelopes:

1. Use the Track Automation View pop-up to choose
the type of automation envelope you plan to edit.

2. Do one of the following:

* Toadjust a breakpoint, click the point and drag it
to a new position.

* To delete a breakpoint, Option-click that point.

* To edit automation envelope ranges, switch to
Object edit mode, drag to select breakpoints, and
then use the Command-arrow keys to move
them.

You can also click the Range Mode button (~ key) to
switch the Tracks window to Range mode. Select any
automation envelope range and edit it as if it were a
waveform, tearing off copies and moving them around.
To delete automation ranges, select a range of points
(in either Object or Range mode) and press the Delete
key.

Automation and QuickTime Movie
Scrubbing

If you are working with a QuickTime movie, and have
Chase Positioning enabled in the QuickTime menu,
automation edits will scrub QuickTime frames. As you
move a group of breakpoints earlier or later in a track
with the arrow keys, Deck’s QuickTime window will
update, tracking the lead-edge of your automation
edit. This provides an easy visual reference for precise
positioning of automation events in synch with video
frames.

See Chapter 7, “QuickTime” for more information on
Deck’s QuickTime functions.

Copying and Pasting Automation Envelopes

You can copy and paste automation envelopes. You
can also use the Tracks window range and region
dragging functions and arrow key manipulations to
drag, nudge and copy automation ranges on a track, or
between tracks. A list of all Tracks window key
commands, including automation shortcuts, appears
in Chapter 9, “Deck Reference.”

Muting and Erasing Automation Envelopes

To mute or erase automation envelopes:

1. Choose the track on which you wish to mute or
erase automation.

2. Click and hold on that track’s Automation Status
pop-up.
3. To mute all automation on that track, scroll to Off.

This mutes all of the automation on the current track.
That automation is not deleted; it is simply turned off.
To turn it back on, just set the track’s Automation
Status pop-up to Play.

To erase all automation on that track, select Erase
Volume, Erase Pan, or Erase All in that track’s
Automation Status pop-up. The automation type you
choose will be permanently deleted from the track.
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Show/Hide Automation Envelope

At any time you can use a track’s Automation View
pop-up to show or hide automation envelopes on that
track. Even when you have hidden the current
automation envelopes, the functions on the Automa-
tion Status pop-up (play, off, erase, and so on) will still
function. You do not need to see an automation
envelope to have it play.

Conform to Audio Edits

Deck’s automation follows the track, so that if you
move a track to another track, it's automation moves
with it. However, you may find that you want to only
move or copy a region of audio from one track or
location to another, and you might want to move the
automation with it. Deck allows you to do this with the
Conform to Edits command. Conform to Edits
essentially locks the automation to the region of audio
so that if you move or copy the region, the automation
is moved or copied along with it.

To enable/disable Conform to Audio Edits:

1. Select Options > Automation > Conform to
Audio Edits

2. A check will appear next to Conform to Audio
Edits to indicate that it is enabled.

3. Select Options > Automation > Conform to
Audio Edits again to disable it.

Be sure that your automation breakpoints are
within the region boundaries when using
Conform to Audio Edits, otherwise irregular
automation may be introduced.

Using mixer states

Although it is possible to automate an entire mix
without using Deck’s mixer states, these snapshot-
style states can be very useful (especially for creating
complex automation moves that should occur at
specific spots). The mixer states allow you to move any
or all of the volume and pan faders in the Mixer

window with a single mouse click. In order to use a
mixer state for real-time automation, you will need to
store it. Once a mixer state has been stored, it can be
recorded in the same way that any real-time automa-
tion is recorded. In fact, you can mix real-time fader
motion automation and mixer state automation. Both
styles of automation create automation envelopes that
can be edited in the Deck Tracks window.

To store a mixer state:

1. Open the session that you wish to automate.

2. While playing back the audio, set the volume and
pan faders to your liking. You can also set these
states when Deck is not playing back.

3. When the entire mixing board is set up the way
you desire, Command-click the arrow button next
to the spot where the mixer state should be
stored.

wardrobe: Transport

Stored Mixer States in the Transport window

You have now stored a mixer state, and the button
next to that state can be used at any time to recall or
play that state back onto the Deck Mixer. Note that
new states are created with the name “snap” followed
by a number. You can rename any mixer state by
Command-clicking its name.

Deck allows you to store an unlimited number of
mixer states. Every time you store one, it is added to
the Mixer State pop-up, which contains all of the mixer
states you have created for this session. Each of the six
mixer state arrow buttons can be set to give you
instant access to any mixer state.

Simply use the Mixer State pop-up menu in the
Transport window to select the state you want. That
state will be placed at the current arrow button for
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instant access.

Mewr

all down
snap 2
snap 3
all up
snap 5
snap &
snap 7
snap 2
snap 9
snap 10

snaE 11

Mixer State pop-up menu

To recall a mixer state:

* Click the button to the left of the desired mixer
state. That state is instantly recalled by the Deck
mixer.

To delete a mixer state:

¢ Option-click the Mixer State button to delete the
currently-loaded mixer state.

To rename a mixer state:

¢ Command-click the Mixer State pop-up to rename
the currently-loaded mixer state.

All stored mixer states are saved with the current
session and will be present just as you left them when
you next open the session.

To record mixer state automation:

1. Open the session that you wish to automate and
open the Mixer window.

2. Set the state transition time to zero (choose
Options > State Transition Time).

3. Decide which track volume and pan faders you
wish to automate.

4. Use the Automation pop-up on the tracks you
wish to automate to set (record-enable) which
controls you will be recording.

You can choose Record Volume, Record Pan, or
Record All. You may choose your controls by track
(for example, volume on track 1 and pan on track
2), or you can use the Options menu’s Automa-
tion submenu to record all volumes and pans by
choosing Record All. Even though you are
recording mixer states, only those faders that are
set to record will be recorded from the states.
This allows you to isolate portions of your mixer
states for automation recording.

N

. Click the Transport’s Record button, then click
the Play button (Spacebar) to begin recording
automation.

6. During playback, click the mixer state arrows
whenever you want to record a mixer state.

The mixer state will be recorded at the moment you
click the arrow. Don’t worry about the exact timing
accuracy of the state. All automation can be edited
visually in the Deck Tracks window after it has been
recorded.

Deck’s recording functions work the same way with
automation as they do with audio. For example, you
can use punch-in mode to replace a segment of state
automation just as you would replace a segment of
audio.

Click the Return-to-zero button (or Return) in the
Transport window, then click the Play button
(Spacebar) to see and hear your new automation.

You can erase the automation on any track by using
the erase commands located on the track’s Automa-
tion pop-up. You can also use this pop-up to mute the
automation on any track by setting the pop-up to Off.

To record mixer state automation with pre-pro-
grammed transition fade times:

1. Choose Options > State Transition Time.

2. Enter the duration of the smooth transition fade
you wish, then click OK.

This duration is the period of time that it will take to
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fade to the new mixer state. Suppose you have a mixer
state that has all of the track volume faders at full
volume, but all of the faders are currently turned all
the way down. You set the State Transition Time to 2
seconds and begin playback. After a few moments, you
click your All Up mixer state. You will immediately see
the faders begin to move smoothly, and after 2
seconds, the faders will all be in the full volume
position. This has allowed you to generate smooth
motion on all faders at once with a single mouse click.

To record this motion in real-time, follow the same
steps explained in “Mixer-based Automation” on page
05.

To record mixer states in the Tracks window:

1. Select whether to edit Pan or Volume.

2. In Range (Waveform) mode, make an insertion
point at the point in time where the automation
should be.

3. Click the correct mixer state in the Tracks
window. The new automation envelopes
associated with the mixer state will be at the
desired location.

When you record mixer state automation with
automated smooth transitions, the resulting automa-
tion can be edited visually in the Tracks window.

Remember, Deck’s automation follows the
track. If you move a track to a work track and
record a new one, you will need to create
automation for the new track.

Bouncing tracks in Deck

Bouncing is the process of ping-ponging, or
submixing, multiple tracks together to create one or
two new tracks. The new track is then used in place of
the original source tracks, thereby freeing up formerly-
occupied tracks for more recording. On most four- or
eight-track systems, bouncing presents a solution to

the problems caused by a limited number of tracks.
Although Deck imposes no restrictions on the number
of tracks that can be mixed together, Deck also allows
bouncing. For more information, see “Virtual mixing”
on page 72. Deck brings major improvements to
analog bouncing: Deck bounces tracks digitally, which
doesn’t degrade the sound quality of the source
tracks. Also, Deck allows you to keep all of your source
tracks, so you can always go back to the original tracks
and re-bounce for a new submix. (Analog bouncing
generally requires that the source tracks be erased so
that new tracks can be recorded.)

Deck allows you to bounce tracks in a purely visual
fashion. To bounce tracks in Deck, you simply select a
range of time in the Tracks window and choose one of
the Bounce to Clipboard commands. Your bounce
takes place immediately, and the resulting track or
region can be placed anywhere you desire.

To bounce tracks:

1. Switch to Range mode by clicking the Range
Mode button (~ key):

2. Drag to select the destination range for your
bounced track(s).

When you bounce in Deck, all of your play tracks are
always included in the bounce, except for muted
tracks. For this reason, it really doesn’t matter upon
which track you choose to select the range. Because of
this, you can use the shortcut of selecting the
destination range instead of the source range. This will
return you to the Tracks window after the bounce is
complete, and require only that you use the Paste At
command to finish the bounce and paste the new
audio at the correct point in time. Remember, you will
want to select two destination tracks if you are
choosing Bounce to Stereo Clipboard.

3. If you want to make sure that certain tracks are
not used as source for a bounce, mute those
tracks. Mute and solo are taken into account
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when you Bounce to the Clipboard. Also, set the

Automation pop-up to Play to include automation.

4. Choose Process > Bounce All to Mono Clipboard
(Command-Shift-B) or Bounce All to Stereo
Clipboard (Command-Option-B).

When the bounce is complete, you will be
returned to the Tracks window, and your
originally selected range will still be selected.

N

6. Choose Edit > Paste At (Command-Option-V) to
paste the newly-bounced region at the correct
place in time.

You are now free to delete the regions that were used
to create the bounce. Try using the up and down
arrow keys to move the highlighted selection range up
or down to tracks you wish to delete for a dead-
accurate cut. Or, you can simply move the tracks used
as source for the bounce down to the Work Tracks
area, where they will not play back. This is the best
option, because it allows you to go back to your
original source tracks if you desire.

Virtual mixing

A major advantage in using a digital audio workstation,
like Deck, is that you are not hindered by the
limitations of the analog world. Analog recorders and
mixers are physically limited to the number of tracks

that can be played. Deck does not do its mixing in real-

time, so there is no limit to the amount of audio it can
mix (other than hard disk space). Although you can
only play back the amount of simultaneous real-time
play tracks your system is capable of, you can create
up to 999 work tracks.

Deck’s Virtual Mixing function controls which tracks
Deck will mix when you choose to use the Bounce to
Disk or Mix to Disk functions. When Virtual Mix is
enabled in the Process menu, Deck will mix the audio
in your play tracks, and any audio on the Work tracks
with the Volume and Panning automation you have
created.

To use Virtual mixing:

1. Choose Process > Virtual Mix to enable Virtual
Mix. A check will appear next to the Virtual Mix
menu item. Now, whenever you choose a Bounce
or Mix command, Deck will mix work tracks as
well as play tracks into the new file.

2. Record your tracks as usual. Add any desired
automation to the new tracks.

3. When you have filled up the play tracks, create
work tracks by selecting New Track from the
Process menu. Enter the number of playtracks
you recorded in the dialog box. You will now have
new work tracks that will serve as destination
tracks for the tracks you have just recorded.

4. Move the tracks to the work tracks. Use the Track
Name pop-up menu to select Track 1 on the first
work track, Track 2 on the second, and so on.

Select New Track from the Track pop-up on each
of the play tracks.

N

6. Repeat the above steps until you have recorded all
of your material. When you are finished recording
and editing, create a master as described in “Final
mastering to a mono or stereo disk file” on page
73.

Because you had Virtual Mix selected, the new audio
file which is created by the mix or bounce will contain
the sound of all your play tracks, plus your work
tracks, and all associated automation and effects.

If you chose Bounce to Clipboard, your new mix is in
the Clipboard’s memory and ready for pasting into the
session.

If you did a Mix to Disk, your new mix file is on your
hard drive in the folder you selected and can be
imported into your session using the Add Audio to
Clipboard dialog box.

Using virtual mixing will quickly use up hard disk
space. If your hard disk space is limited, you may be
best served by bouncing tracks and compacting your
session. In either case, be sure you leave enough hard
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disk space for the final Mix to Disk process. For
example, at a rate of 44.1kHz, you should allow about
5MB per minute for a mono mix and 10MB per minute
for a stereo mix.

For more information about moving tracks and using
work tracks, see Chapter 4, “Visual Waveform Editing.”

Renaming Tracks

If you are planning to record many tracks, it is a good
idea to rename them. Using Deck’s default naming
system (Track 1, Track 2, Track 3, and so on) will get
confusing with many tracks.

To rename a track:
1. Command-click the track name.

2. Type in the new name in the resulting dialog box.

For more information about organizing Deck Tracks,
see “File management tips” on page 158.

Final mastering to a mono or stereo
disk file

The last step in a recording project is generally the
mastering process. During mastering, a final stereo
mixdown of the recording is created. This stereo
version is the master from which all distributed copies
will be made. For this reason, the master must be the
best possible copy of the final mix.

Once your final mix is automated to your satisfaction,
you are ready for the digital mastering process. In this
process you will use Deck to create a mono or stereo
Sound Designer I, Audio Interchange (AIFF), Sound
Resource, QuickTime, or .\WAV sound file on your hard
disk. This sound file will be an exact digital copy of the
mixdown from which it is created, including all effects
processing, level and pan settings, and automation.

Remember that there are some planning steps
you will need to take before creating a digital
master. If your session plays back a synchro-

nized MIDI file from the Metro sequencer,
Deck’s MIDI window, or other MIDI sequencer,
the MIDI tracks will obviously not be included
in a digital master until they have been
digitally recorded. The easiest way to do this is
observe the following:

1. When all of your Deck audio tracks are automated
and ready for mastering, select Virtual Mix from
the Process menu. Use the process described
previously in the Virtual Mixing section to free
two play tracks. If you are limited by disk space,
select Bounce All to Stereo Clipboard from the
Process menu to bounce all of your play tracks to
a final stereo image, then paste those bounced
regions on tracks 1 and 2, for example.

2. Mix the playback from your MIDI device into a
stereo image at your mixing board, and record it
in stereo onto two remaining Deck tracks—tracks
3 and 4, for example. You now have your original
audio plus your MIDI instrument tracks in stereo
audio form.

3. Add any extra mixer automation or effects you
might need and you're ready for the mastering.

To create a digital hard disk master of a session:

1. Open the session you wish to master (Command-
0). Make sure that it plays back exactly as you
wish the final mix file to sound, because the
master will be an exact copy of the session as you
now hear it.

2. Ifyou are using Virtual Mixing, be sure to audition
each worktrack in a play track before mixing. The
Virtual Mix will not sound exactly like the session,
as it adds data to the mix from the work tracks,
which cannot be heard during real time playback.

3. Choose Windows > Tracks (Command-3).

4. If you want to mix only a portion of the session to
disk, select the range you wish to mix before you
choose the Mix to Disk command.

Remember, all of your play tracks (and work
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tracks, if Virtual Mixing is enabled) are mixed to
disk, even if you only select a range (or regions)
on a single track. To remove tracks from the mix,
mute those tracks and/or deselect Virtual Mixing
in the Process menu. Be sure to select Play from
the Automation pop-ups to include automation in
the mix.

If you want to mix the entire session to disk, make
sure that no audio range or region is selected.
You can choose Deselect from the Edit menu to
make sure that no audio is currently selected.
Note that you can also choose Select All before
you mix to disk to make sure that the entire
session file is mixed down.

7. Choose Mix to Disk from the Process menu.

3 psychotropic | * = BigLegEmma
psychotropic [ Eject
(5} psychotropic audio files
Ei psychotropic cross-fades
=] [(New(j |
=
Mix to file
Save I
Format: | AIFF =
Sample Rate: | 44100.000 2]
BitDepth: [ 16 ]
Number of Channels: [ Stereo = I
Bit Depth Conv: | Convergent Roundi... | # |

Mix to Disk dialog

8. Type in the name you wish to use for your master
sound file. This will always default to the name of
the session followed by “mix.” It is probably a
good idea to use this naming scheme, because it
associates the master and the source session, and
prevents accidentally replacing an important
existing file.

9. Select the destination folder for the master.

10. Choose from the following options:

Format—sets the type of file you wish to create.

Choose from the following formats:

Sound Designer II (SDII)—The most common
format. This is the native format used by Deck
and is supported by a great number of audio
programs. If you are creating 16-bit stereo
masters for CD mastering, this is generally the
format of choice.

Audio Interchange File Format (AIFF)—
Popular high-resolution audio format. There is no
difference in quality or portability between Sound
Designer II files and AIFF files. AIFF files are
better for cross-platform file exchange and were
designed with this purpose in mind. However,
AIFF files do not allow you to save region
definitions within the sound file, and cannot be
used for direct audio recording in Deck or Sound
Designer II. For this reason, Sound Designer IT
files are generally suggested.

Sound Resource files (.SND)—Apple-standard
format audio files which have the highest level of
desktop integration. Eight-bit sound resource
files are the standard used by older Macintosh
systems, and they can be played back through
most internal Macintosh speakers directly from
the desktop simply by double-clicking on their
icons. Such 8-bit sound resources are also easily
integrated into programs such as Macromedia
Director or Adobe Premiere, although 16-bit
audio is becoming more widely supported by
many programs.

Wave (.WAV)—Is a Windows sound file format
and is useful for transferring sounds or mixed
sessions to the Windows platform.

QuickTime—Sound files can be used for
QuickTime movies, or as stand-alone Macintosh
audio-only sound file-players. This format is
especially useful for transferring shorter sound
file demos over the Internet or to anyone with a
QuickTime capable Macintosh or IBM computer.

Sample Rate—Sets the sample rate you wish to
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have for your final mix file. The pop-up allows
you to choose from a variety of preset, standard
sample rates, such as 44100Hz and 22050Hz, or
you may enter any rate you choose into the pop-
up box. You will use different rates for different
purposes. 44100Hz is the CD standard rate.
Generally speaking, higher sample rates are
better because they offer higher fidelity.
However, they also require more disk space.
Rates such as 22050Hz are good for general
purpose multimedia work, as they take up less
space—but the lower the rate, the noisier the
audio, so choose the lower rates with care.

If you are mixing down to an 8-bit Sound
Resource file for desktop playback, the 22050Hz
setting will produce very good results.

Bit Depth—Specifies the audio bit-depth you wish

for your audio master file when the audio is
mixed. You may choose between 8-bit and 16-bit.
(Remember to select an appropriate Bit-Depth
Conversion method for your session if you
convert to 8-bit sound.) If you wish to create a
true high-fidelity master, always choose 16-bit.

Number of Channels—Determines whether your

mix will be to a mono file, an (interleaved) stereo
file, or split stereo files (which will automatically
have .L and .R suffixes attached to their file
names). If you're mastering for CD-ROM burning,
try using the stereo (interleaved) option, which
combines both left and right channels in a single
file. If you're planning to bring your mix back into
Deck for further work, select the split stereo
option, which results in separate left (L) and
right (R) mix files.

Bit Depth Conversion—Sets the 16-to-8 bit

conversion method. If you are converting your
16-bit Deck file to an 8-bit file, Bit Depth
Conversion makes it possible to create better
sounding 8-bit files.

Truncation—Takes the high byte of your sound
file as the sample value, and throws away the low
byte. Truncation can often cause unpleasant

artifacts, or noise—especially on low-level signals
and human speech.

Rounding—Treats the original 16-bit sample as a
fixed-point number, with the decimal point
between bytes. If the low byte is greater than or
equal to 0.5, then 1 is added to the high byte
(hence the name rounding) and the high byte is
taken as the sample value.

Convergent Rounding—Differs from Rounding
in how it treats the value of 0.5 in the low byte of
your sound file—1 is only added to the high byte
if the low-byte value is greater than or equal to 0.5
and the high byte is even. Otherwise, the high
byte is taken as the sample value.

Dithering—Is similar to the Dithering function in
digital imaging programs. Dithering applies a low
level noise signal to the sound file to cover up the
unpleasant artifacts caused by truncating. This
method is also called Error Diffusion Dithering.

Generally, Rounding and Dithering produce
better results than Truncation, but the results of
these conversion methods will depend on your
source material. Experiment with different kinds
of conversion to see what works best for you.

11. Click Save to create the digital mix file.

Deck uses the exact same set of routines to create a
mix file that it uses to play back the source tracks. For
this reason, you can be absolutely sure that the mix file
will be a true copy of the session’s mix. Once you have
created a digital master of your session, you are free to
transfer it to a portable medium for duplication. Better
still, use BIAS Peak to master your stereo mix and burn
it to CD yourself.
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Conclusion

You have learned how to mix and master in Deck. In
the next chapter you will learn about using Deck to
score QuickTime movies.
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Chapter 7
QuickTime
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Chapter 7:
QuickTime

Deck is the perfect compliment to any QuickTime
movie authoring program, such as Adobe Premiere,
Final Cut Pro, or iMovie. You can import any existing
QuickTime movie into Deck and add synchronized
audio to that movie, exploiting all of Deck’s audio
editing, processing, and mixing features.

Deck is capable of playing back multiple tracks of 16-
bit audio and a QuickTime movie—and that movie’s
native soundtrack, if desired—simultaneously from a
single hard drive. You can add music, narration, and
sound effects to your QuickTime movie, and export it
as a new movie with its soundtrack mixed down in a
variety of sample and bit rates for distribution,
multimedia and CD-ROM production, or just for fun.

You need to have Apple’s QuickTime extension,
version 3.0 or higher, installed in your Macintosh.
(QuickTime is usually included in Apple System
software, but if you don’t have it, you can download it
from Apple’s Web site, or contact Apple directly.) It is
also helpful to have a movie playing program, such as
QuickTime Player, if you want to be able to playback
your finished self-contained QuickTime movies
without opening Deck.

Importing a QuickTime Movie

When importing a QuickTime movie that already has a
soundtrack, you can either discard or import the
movie’s audio along with the movie. If you do import
the movie’s audio, Deck will convert the movie’s audio
to 16-bit at your session’s chosen sample rate.

To import a QuickTime movie into Deck:

1. Create a new session, or open the session you

wish to synchronize to a QuickTime movie.

2. Select QuickTime > Import Movie.
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3. Locate and select the desired movie.
4. Select one of the following:

* Put on Clipboard—Removes the existing
soundtrack from the QuickTime movie and
converts it to 16-bit monophonic Sound Designer
1I file(s) at whatever sampling rate you've selected
for your session. These files are created in the
session’s audio files folder and then placed on the
Clipboard for pasting into any track in the Tracks
window. To guarantee that the Clipboard file will
sync to the imported movie, you will need to drag
or paste it so that it starts at the session zero time.

If the source audio was stereo, you will need to
select two tracks in Deck’s Tracks window when
you paste the audio.

* Put in new work track(s)—Removes the source
audio from the QuickTime movie and converts it
to 16-bit monophonic Sound Designer II files.
These files are created in the session’s Audio Files
folder, and then placed onto new work tracks at
the bottom of the Tracks window. To play back
these tracks, click the track control area(s) to
select the track, then drag the track up to one of
the play tracks. (You can also use the track pop-up
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at the bottom of any track in the Mixer window to
move these new tracks up to playback tracks.)
Choose this option to make sure that the original
QuickTime audio will be included in any 16-bit
stereo mixdowns and in exported QuickTime
movies.

* Discard—Imports the QuickTime movie without
its original audio.

You can change the size of the QuickTime window
using the QuickTime menu’s Size submenu. If you
added the movie’s audio to the Clipboard, you will
need to paste it onto a track by choosing Edit > Paste
At, or by dragging the audio into the Tracks window
from the Library window. Be sure to place the movie's
audio at the very beginning of the session—session
zero. The QuickTime movie will always play back in
sync with that Deck session, and the movie will always
open whenever that session is opened.

Sessions are set to have a default length of 10 seconds
if they contain no audio. If you wish to play back a
QuickTime movie without its native soundtrack, use
Session End Time from the Session menu to set the
session length to be as long or longer than the movie’s
duration.

QuickTime window

To open the QuickTime window, or to bring it to the
front of the screen if it becomes buried under Deck’s
other windows, select QuickTime from the Windows
menu (Command-4). The QuickTime window contains
no controls. The movie’s playback is controlled by
Deck’s Transport controls. However, note that you can
scrub the QuickTime movie by clicking and holding in
the QuickTime window—move the cursor to the left
too scrub back and move it to the right to scrub
forward.

Deck’s QuickTime tools

Now that you have a QuickTime movie imported into
Deck, you will want to get acquainted with Deck’s
QuickTime tools.

Here are some of the QuickTime tools you will find in
Deck’s QuickTime menu:

Dispose Movie—Closes the current movie so that
you can import another; only one QuickTime
movie may be opened at a time.

Get Movie Info—Opens a dialog box that shows you
information about the current movie, including its
location on your hard drive, the date the movie
was created, number of frames, frames per second,
and length.

Copy Frame—Copies whatever frame of your movie
is currently showing to the Clipboard. You can
then paste that frame into the Scrapbook, or into a
word processing or imaging program such as
Microsoft Word or Adobe Photoshop. The frame is
always copied at the size you see. You can also use
Copy Frame to copy a frame of live video from the
Live Video window.

Set Poster—Sets and saves the current QuickTime
movie’s poster—or preview—frame. The poster
frame is the frame that will be used as the movie’s
icon and as the preview frame that will show when
programs like Deck show QuickTime movies for
importing or opening.

Chase Positioning—Turns on QuickTime Chase
Mode, which automatically scrolls the QuickTime
movie along with the audio and automation in the
Tracks window. The QuickTime window will scrub
to the current frame when audio regions are
moved. (The frame at the region’s start time is
always shown.) Alternatively, selecting an audio
region in the Tracks window, then scrubbing in
the QuickTime window (click and hold down the
cursor, then drag left or right) will cause currently-
selected audio to reposition to the lead edge of
the current frame. This is a fast, indispensable
function for spotting music, dialog, and effects to
specific QuickTime movie frames.

If Chase Positioning is enabled, moving volume or pan
automation break points along the track timeline will
also scrub QuickTime frames, enabling fast positioning
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of automation events with sub-frame accuracy.

Set Offset—Lets you start the movie at a time other
than session zero. Normally, when you import a
QuickTime movie into Deck, it will begin at
session zero—the very beginning of the session.

Live Video—Is useful if you are using Deck to add
music or spot effects to live analog video coming
into the video port of your AV Macintosh or the
inputs of a video card.

Configure Live Video—Configures the incoming
video signal, such as selecting a compressor, color
depth, and frame rate. The options available
depend on your video hardware.

Non-real-time QuickTime functions such as scrub or
Chase positioning do allow you to view and spot all
the QuickTime frames in a given movie, up to 30
frames per second, regardless of your computer’s
speed or disk throughput, and don’t require additional
video hardware. So even if your setup won’t play back
full-motion, full-frame video, you can still spot and edit
accurately to 30 frames per second QuickTime.

Size—Sets a size for your QuickTime movie window.
Note that the Size option does not affect the actual
size of the QuickTime movie, and it will revert to
its native size when you export it. The Size option
only affects the size of Deck’s QuickTime window,
and is for your convenience while you work with
QuickTime in Deck.

Center—Places the QuickTime window in the center
of your monitor without the title bar.

Scrubbing QuickTime video

Two of Deck’s other QuickTime features are scrub
video, which allows you to drag smoothly through
video on your hard disk, and scrub-to-spot, which lets
you select an audio region in the Tracks window and
drag through video frames to spot audio to a specific
QuickTime frame.

To scrub video direct from the drive:

1. Place the mouse cursor over the QuickTime
window. Then click and hold down the mouse
button. The arrow cursor changes to a right-left
triangle.

2. Drag to the left (earlier) or right (later) to scrub
video directly from the drive.

To Scrub To Spot:
1. Choose QuickTime > Chase Positioning.

2. Select an audio region or group of regions in the
Tracks window.

3. Place the mouse cursor over the QuickTime
window. Then click and hold down the mouse
button. The arrow cursor changes to a right-left
triangle.

4. Drag to the left (earlier) or right (later) to find the
video frame on which the selected audio should
start. Then let go of the mouse button to auto-spot
the selected region or regions on that frame.

When you let go, the entire Tracks window selection
will be moved so that it starts on the frame you chose.
Use this function for quick spotting of sound effects or
Music cues.

When you have a QuickTime movie imported into
Deck and you know your way around Deck’s
QuickTime features, you may add multitrack audio to
your digital video. All of Deck’s audio importing,
recording, editing, layering, processing, and mixing
features can be used to add a soundtrack to your
movie.

Once you have finished your Deck soundtrack, you
may Export your movie as a new flattened QuickTime
movie with its new audio attached.

Exporting the final QuickTime movie

If you are using Deck as a QuickTime audio post-
production tool, then the last step in your process is
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quite similar to the final audio mastering process
described in Chapter 6, “Automation, Mixing, and
Mastering.” The main difference is that you are
creating a finished file (or files) that consist of a
desktop playable picture as well as sound. The process
of mixing down a final QuickTime movie (with audio)
from the current session is very simple.

To create a final QuickTime movie with session audio:

1. Open the session that contains the audio and
movie you wish to mix down.

2. Make sure that the session and its movie play back
exactly as you wish the final product to look and
sound. The exported movie will be an exact copy
of the session as you see and hear it.

3. Choose QuickTime > Export Movie.

I wardrobe.mov

5 movies | ¥ | = BigLegEmma
% blow.mov [ Eject
i enemy.mov
! old _senate_balcony.mov Desktop
I8 pussycats.mov =
% rouge.mov -~
save os:

[ Make movie self-contained
[ Make playable on Non-Apple computers

b Add audio to movie

Audio Format: 16-Bit Stereo
Sample Rate: |44| 00.000 [E]

BitDepth Conv: [ Convergent Roundi... | 3 |

Export Movie dialog

The Export Movie dialog allows you to create new
QuickTime movies that contain (or reference) 8- or 16-
bit mono or stereo audio interchange file format
(AIFF) audio tracks at a variety of sample rates. The
exported movie contains all of the edited audio,
automation, and audio effects, if any. You can think of
the Export Movie command as a Mix-to-disk command
for picture and sound. It is usually the last step in the
QuickTime audio post-production process, and the

result can be played back on any QuickTime-capable
computer.

4. Choose a destination folder and type in a name for
the movie.

5. Select from the following options:

Make movie self-contained—Creates an entirely
new, self-contained movie. The self-contained
movie will consist of a single QuickTime (Movie
Player) document that contains all picture and
sound. According to QuickTime specifications, the
sound and picture are interleaved, creating a
movie that is fully transportable and plays
efficiently. Note that a self-contained movie will
take a while for Deck to create, because it requires
an extra step (flattening), which can be time
consuming. Remember, a self-contained movie will
generally be quite a large document.

Make a movie self-contained when you want to
create a single document for delivery. If you are
simply performing test edits and mixdowns, do not
make the movie self-contained. When the movie is
not self-contained, a new, extremely small
(typically around 30K) movie document is created.
Like a Deck session, this document simply
references the source sound and picture files. The
Movie Info command in Apple’s QuickTime Movie
Player can always be used to determine which
audio and picture files are used by a movie that is
not self-contained.

Make playable on Non-Apple Computers—
Creates a self-contained movie that is playable on
other QuickTime capable platforms, such as
Windows. It will flatten your movie and remove all
Macintosh-specific data from it. You will need to
check “Make movie self-contained” in order to use
this option.

Add audio to movie—Determines whether the
audio from the current Deck session will be mixed,
converted, and added to the finished movie. You
will generally want to have this option turned on.
When it is turned off, a silent movie document is
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created, and the audio data stays in Deck. (hence the name rounding) and the high byte is

Audio Format—Specifies the audio bit-depth you taken as the sample value.
wish for your audio mixdown file when the audio Convergent Rounding—Differs from Rounding in
is mixed and the movie is exported. An AIFF sound how it treats the value of 0.5 in the low byte of
file is always created unless you chose “Make your sound file—1 is only added to the high byte if
movie self-contained,” in which case the audio is the low-byte value is greater than or equal to 0.5
placed directly into the movie picture data. You and the high byte is even. Otherwise, the high
may choose between 8-bit mono, 8-bit stereo, 16- byte is taken as the sample value.

bit mono, or 16-bit stereo. The 8-bit mono format
requires less disk space, takes less time to upload
to the Internet, and plays back more efficiently on
older Macintosh computers. If you wish to create a
high-fidelity master, choose 16-bit stereo.

Dithering—Is similar to the Dithering function in
digital imaging programs. Dithering applies a low
level noise signal to the sound file to cover up the
unpleasant artifacts caused by truncating. This
method is also called Error Diffusion Dithering.

Sample Rate—Sets the sample rate you wish to have
for your final QuickTime movie audio. You can
select one of the preset, standard rates, or select
other and enter any rate into the pop-up box.
Generally speaking, higher sample rates are better
because they offer higher fidelity. However, they 6. Click Save.
also require more disk space. For the highest-
fidelity results, set this pop-up to the highest
supported rate, such as 48000 or 44100Hz. This
will mix down your audio as a CD-quality Conclusion
soundtrack, but will also create a large movie
document. If you don’t need CD-quality audio, or
if you require a smaller movie, a rate of 22050Hz
provides a good balance between audio quality
and file size.

If you are mixing down a QuickTime movie with 8-
bit sound for desktop playback, a sample rate of
22050Hz and Dithering or Convergent Rounding
will produce very good results.

Now that you know a about Deck’s QuickTime
functionality, proceed to the next chapter to learn
about Deck’s MIDI and SMPTE sync capabilities.

Bit Depth Conversion—Specifies the down
sampling method. If you are converting your 16-bit
Deck file to an 8-bit file, Bit Depth Conversion
makes it possible to create better sounding 8-bit
files.

Truncation—Takes the high byte of your sound file
as the sample value, and throws away the low
byte. Truncation can often cause unpleasant
artifacts, or noise—especially on low-level signals
and human speech.

Rounding—Treats the original 16-bit sample as a
fixed-point number, with the decimal point
between bytes. If the low byte is greater than or
equal to 0.5, then 1 is added to the high byte
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Chapter 8:
MIDI and
Synchronization

Using the MIDI functions will enable you to synchro-
nize your session to SMPTE time code, use Deck as a
master time code source, import a MIDI file for
synchronous playback with your session, and control
Deck with external MIDI devices. You can also
synchronize Deck with a MIDI sequencer, such as
Metro.

The next section of this chapter focuses on the
methods you will employ to synchronize Deck to an
analog video or audio deck. You will need to
understand synchronization in order to add audio to
video or film picture, or extend the tracks of your
analog multitrack with synchronized hard disk audio
tracks. You can also synchronize Deck to QuickTime
movies. For more information, see Chapter 7,
“QuickTime.”

MIDI Setup

Before you can use Deck’s MIDI functions, you will
need to install and configure OMS (Open Music
System, formerly the Opcode MIDI System). The OMS
installer can be downloaded for free from
www.opcode.com. Please refer to the Opcode
Technical Documentation for more detailed informa-
tion on configuring OMS.

OMS must be installed and configured to run
Deck with MIDI.

The Open Music System (OMS)

OMS consists of a set of system documents that, along
with the OMS Setup application, allow you to describe

your MIDI studio’s configuration and have that
description be recognized by all OMS-compatible
programs. Once you have set up your OMS environ-
ment, OMS-compatible applications can list all of your
MIDI instruments (including sound-generating
devices, interfaces and controllers) by name. This
eliminates the need to separately set up and define
your MIDI system configuration in every software
application.

When you have OMS installed, configure Deck as
follows:

1. Open any Deck Session.
2. Choose Options > MIDI Setup.

If you are running Deck with OMS-compatible slave
programs (e.g., Metro) set up the dialog to allow Only
OMS Applications. This will make it possible for you to
switch between Deck and the slave program(s) during
playback without forcing MIDI or audio playback to
stop. If you are running Deck with programs in the
background that are NOT OMS-compatible, select the
Allow Non-OMS Applications option. This will allow
the ports to be shared, but may stop MIDI and/or

audio playback when you switch between applications.

(For more information about configuring and using
OMS, see the OMS documentation available from
Opcode.)

MIDI preferences

The next step in configuring your system for MIDI is
setting your MIDI Preferences. Choose File >
Preferences > MIDI to open the MIDI Preferences
dialog.
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MIDI Preferences

[ Split channels on incoming MIDI files

Default output port: | = IACBus#1 | &
Timecode outputport | = IACBus #1 |

[ cancel | [[ ok |

MIDI Preferences dialog

Split channels on incoming MIDI files—Splits
the channels when you import a MIDI file. This is
useful when you are importing Type 0 MIDI files,
which store all track data in one channel.

Default Output Port—Specifies the default MIDI
output port.

Timecode Output Port—Controls through which
port outgoing MIDI time code is sent. To change
the port, simply select a different port using the
pop-up menu.

If you plan to import large MIDI files, you should first
increase the MIDI buffer size in the Memory and
Storage preferences. Remember, whenever you
increase the buffer size, you should also increase the
amount of RAM allocated to Deck.

You have now finished configuring your MIDI setup
and can use any of Deck’s MIDI functions.

Sending MIDI timecode

You can use Deck as a time code master very easily.
Simply choose Output MIDI Timecode from the
Options menu. Deck will automatically generate time
code and send it through the Timecode Output Port
you chose in the MIDI Preferences. To stop sending
timecode, choose Output MIDI Timecode again. You
can tell if Deck is sending timecode by looking for a
check next to Output MIDI Timecode in Options. If
the command is checked, Deck is sending time code.

MIDI Key Maps

Deck allows you to create, save, and load MIDI Key
Maps. You can map MIDI controllers to the Transport
controls (Rewind, Fast Forward, Stop, Play, and
Record). The Panning and Volume faders, and Solo,
Mute, and Record enable buttons in the Mixer window
can also be mapped to MIDI control. The Mixer state
and Location buttons in the Transport window also
respond to MIDI controller messages in addition to
MIDI keydown and keyup messages. Deck’s MIDI
mapping capabilities allow you to quickly and easily
setup Deck to be controlled by any MIDI control
surface.

MIDI Map Fader
To map MIDI controllers to Deck
1. Enable MIDI Map Faders in the Options menu. All
MIDI mappable faders and buttons will turn
green.

2. Click on the fader(s) or button(s) that you want to
map a MIDI controller to. The fader(s) or
button(s) will turn yellow.

3. Toggle the MIDI control you want mapped to the
highlighted fader(s) or button(s). The fader(s) or
button(s) will turn red.

4. Repeat steps 2 and 3 for each MIDI controller you
want to map.

N

When you have finished assigning MIDI control-
lers to Deck’s faders and buttons, uncheck MIDI
Map Faders in the Options menu.

To map more than one button or fader to a single
MIDI controller, simply click the faders or buttons you
want to map and then toggle the MIDI controller you
want mapped.

Edit MIDI Map
Deck allows you to Edit the MIDI Map manually.
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To manually Edit Deck’s MIDI Map:

1. Choose Edit MIDI Map from the Options menu to

open the Remote Control dialog.

Remote Control

Function Chan  Num
Retumn to zero 1 1 =
Rewind 1 2 i
Stop 1 3
Play 1 4

Qst Fo N NAA
Record 1 6
Mixer State 1 2 1
Mixer State 2 2 2
Mixer State 3 2 3
Mixer State 4 2 4
Mixer State 5 2 5 -
Mixer State 6 2 5 [+

[ et | [ ok |

2. Highlight the Function you wish to edit and click

the Edit button to open the Edit Map Element
dialog.

Edit Map Element

Function: Fast Forward

Channel: l:l
Number: lzl
Ceance) ok
Enter the MIDI Channel and MIDI controller

number that you want to map to the designated
function and click OK.

Repeat steps 2 and 3 for each Function you wish
to edit and click OK in the Remote Control dialog
when you are finished.

To unmap a mapped fader:

1.

Open the session that contains the faders you
wish to unmap.

Move your external MIDI controllers to see how
the mapped screen faders move along with them.

Choose MIDI Map Faders from the Options menu.
All of the mapped faders on the screen will
automatically be highlighted in red. (Other faders
will be highlighted in green.)

4. Click once on any mapped (red) fader to unmap
it. The fader will be filled highlighted in green to

indicate that it is no longer mapped.

5. Choose MIDI Map Faders again to turn off map
mode.

You have now unmapped the fader. Remember to save

the session if you wish to unmap the fader perma-
nently.

Save and Load MIDI Map
Once you have Mapped MIDI controllers to Deck’s

faders and buttons, you can Save your MIDI Maps and

Load them later. This is especially useful if you
regularly work with different control interfaces or if

you frequently use the same MIDI Mappings in every

session. To Save your MIDI Map, simply select Save
MIDI Map from the File menu and you will be

prompted to Save the current MIDI Map to your hard

drive. To Load a previously saved MIDI Map, select
Load MIDI Map from the File menu and locate the

desired MIDI Map on your hard drive and click Open.

CEFOO0 % = Big Note
= Open “

A The Tascam US-428 communicates to Deck via.
MIDI, however most of its faders and buttons

are already mapped to functions in Deck. If
you attempt to MIDI map one of the US-428
controls that Deck already understands, the
built-in bebavior will override the MIDI
mapping that you select. The Aux 1 ... Aux 4
and F2 and F3 buttons on the US-428 are

unused by Deck and could be used to map to
Deck's Location Times or Mixer State buttons in

the transport windouw.
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Using Deck with the Metro
Sequencer

Deck offers the ability to synchronize to the Metro
sequencer on a single Macintosh. Running Deck and
Metro together requires no special software or
complicated setup process. If the two programs are
running simultaneously, they automatically connect to
each other and stay synchronized. You can edit, play,
and record from either program and the other runs in
sync. You can even switch between programs during
playback and edit without stopping. Each program can
save and open documents automatically in the other,
can pass tempos and selections, and can start up and
quit the other. The level of cross-program control is
up to you.

There are a number of key advantages to using Metro
as your MIDI solution with Deck, as opposed to using
other OMS-compatible third party sequencers. One
benefit is the enhanced level of integration and inter-
operability, as described above. Another advantage is
that Deck and Metro use a proprietary timing
architecture which allows the two programs to
continuously share timing data, so they can stay
locked in rock-solid sync. By contrast, OMS and MIDI
Manager only allow for trigger sync, meaning two
programs can start at the same time, but they have no
way to re-synchronize downstream should their timing
slip. Deck and Metro’s continuous MIDI/Audio re-
synchronization therefore gets you more reliable
punch-ins and punch-outs, plus more stability on
longer sessions.

Setting the Deck Connections on the Metro
Setup menu

Metro offers a settings dialog that allows you to
configure the level of interaction between Deck and
Metro. In Metro, choose Setups > Digital Audio.

L Digital Audio Setup

- Far Metro Digital Audio

/&

Record Device: | ]
Sample Rate: 5 Bits
[ Stereo
[ Recording Options... ] [ Advanced... ]
- For ing to DECK™ Il
[ Connect

[] open documents Launch Quit

[ Switch without stopping MIDL.

Tolerate lil errors before syncing u
[

Metro Digital Audio Setup dialog

If you are planning to run Deck with Metro in the
background, you can set the preferences as shown in
the above illustration. This setup assumes that you will
be starting Deck, and that you always want Metro to be
started up and connected in the background. To
complete the configuration process, you will also want
to set up Deck’s Slave Settings, as explained below.

Setting the Slave Settings preference on the
Deck File menu

Deck offers a settings dialog that allows you to
configure the level of interaction between Deck and
any compatible slave program (Metro or other MIDI
sequencers). Choose File > Preferences > Slave
Settings to open the Slave Settings dialog.

Slave Settings

Current Slave: None

[ Open slave documents

[ Quit slave when quitting

[ Save slave’s document when saving
[ Alwerys pass selection

[ cancet | |[ ok |

Slave Settings dialog

When you are running Deck with Metro in the
background, you can set the slave settings as shown in
the above illustration. This setup assumes that you will
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be starting Deck, and that you always want Metro to be
started up and connected in the background. When
you open a session with Deck configured in this
fashion, Deck will automatically open the associated
MIDI file in Metro. Although you will not see Metro
(unless you switch to it), playback within Deck will
automatically control playback from Metro (and vice
versa).

Open Slave Documents—Lets you choose whether
Deck should always start up the slave application
(Metro) and open the Metro document associated
with the Deck session you open.

This keeps Deck sessions linked with their
associated Metro documents. (The same holds
true for any MIDI slave program.)

Quit Slave when Quitting—Makes Deck close the
associated Metro document when the Deck
session is closed.

Save Slave’s Document when Saving—Causes the
Metro session to be saved whenever you save in
Deck.

Always Pass Selection—Passes the current
selection in Deck to Metro—so if you are stopped
at bar 37 in Deck, you will automatically be at bar
37 when you switch to Metro.

When you are running Deck and Metro on a single
Macintosh, choose one of the two programs (the one
you will usually run in the foreground) and set only
that program to Open Documents in the other
program. If you generally plan to open Metro and
work on MIDI first, then set Metro to Open Docu-
ments. If you usually lay down audio before adding
MIDI, then set Deck to Open Documents. (See the
Slave Settings preference in the Deck Preferences
submenu.)

Setting the screen update speed for Metro
within Deck

Deck offers a special preference that allows you to set
how often the Metro screens update when they are in
the background. (It also controls how often the Deck

screens update when they are running in the
background behind Metro.)

To update the screen of Metro (or any other back-
ground program) as often as possible, set “Update
speed during playback” to 1. This will allow the
background program to update as smoothly as
possible, and is suggested if you are using Metro. If
you wish to lock out the screen updates of back-
ground programs during playback, set the “Update
speed during playback” to 10.

Setting up Deck with a MIDI or audio
metronome

Deck is primarily an audio program, so it has no
internal MIDI metronome. If you wish to use a click or
metronome, you will need to use the Metro sequencer
(or another compatible slave sequencer) running in
the background on your Macintosh. You can also
create a click track in a different sequencer and import
the file to play with your session. For more informa-
tion, see “Importing MIDI files” on page 92.

To set up and run Deck with MIDI or audio metronome:

1. Make sure that Deck and Metro are configured to
run together.

The programs are set at the factory to run
correctly together, but you can review these
settings by reading through “Setting the Deck
Connections on the Metro Setup menu” on page
90.

2. Create a new session in Deck, then switch to
Metro and create a new Metro document. You can
accomplish this by selecting New from the File
menu in both programs.

3. Drag the Bars setting on any track in the Metro
Tracks window to set the number of click bars you
want.

You can set this to any number you desire. You
can use a short setting as a basic count in. Set the
bars count to a high number (600, for example) if
you want a long period of click.
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4. Click the dialog door in the lower right-hand
corner of the Metro tempo setting area in Metro’s
Transport window.

5. Use the Metro Tempo dialog to enter the tempo
you desire. Then click the OK button.

6. You have now set the tempo of the click (and the
start tempo of the Metro MIDI file as a whole.)
Now you just need to turn the metronome on.

7. Click the Metro Metronome icon to turn on the
MIDI click.

The click is now on. It can be set to trigger any MIDI
device, or to play a number of sounds using your
Macintosh speaker or Macintosh audio output jack.
Whenever the click is turned on, it will automatically
play when you hit your Deck play button. For more
information about editing and configuring the Metro
metronome, consult your Metro user’s guide.

Deck and Metro share a common tempo setting and
exchange tempo maps. To change the shared tempo,
set the tempo in Metro as described above. Changing
the tempo in Deck will not automatically change the
tempo in Metro, but Metro will change the tempo in
Deck. Note that Deck does support MIDI file playback
in tenths of a BPM, but does not yet allow entry in
tenths.

Remember, the Metro Transport window can be set to
two different sizes. If you can’t find the Tempo and
Metronome setting areas, click the Transport window’s
grow box to reveal all of the Transport controls.

Importing MIDI files

If you do not own Metro but would like to hear a MIDI
file that you have created in a sequencer play back
with your session, you can use Deck to import the
MIDI file.

To Import a Standard MIDI File into Deck:

1. Open up the MIDI window by choosing Windows
> MIDL

=——HH

MIDI window

2. Click the Import button.

3. This will bring up a standard file dialog asking you
to pick a file to import. Choose the standard MIDI
file you wish to import.

4. When you have opened the file, Deck will take a
few moments to translate the file.

5. Click on the Port pop-up menus to assign the
MIDI tracks to specific MIDI instruments in your
setup.

6. Command-click the Track name to rename
individual MIDI tracks.

MIDI window with imported MIDI file

You can change the MIDI file that is played with the
session by clicking the Import button again and
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choosing a new file. Deck will erase the previous MIDI
data to make room for the new file.

MIDI files are imported with their tempo maps, and
Deck will play back those tempo maps and display
audio bar/beat data according to the initial tempo
event. To view audio waveforms visually adjusted to
tempo-accurate bar/beat display, just choose Beat
from the Options menu’s Time Mode submenu.

Deck’s tempo indicator only shows you the first tempo
of any MIDI file. Although Deck will follow tempo
changes in your MIDI file, the display’s not updated to
show each new tempo. Entering a new tempo will
clear out the existing tempo map and set the session
to that single new tempo.

MIDI Thru

Another of Deck’s MIDI functions is MIDI Thru. To use
MIDI Thru, open up the MIDI window, and press the
button on the Thru track.

You can change the port for this track by clicking on it
and selecting a new port using the pop-up menu. Now

all MIDI events coming into the “in” port will be
routed through the port you choose.

Synchronization

This section focuses on synchronizing Deck to a video
or audio deck. You will need this information in order
to add audio to analog video or film, or to extend the
tracks of your analog multitrack with synchronized
hard disk audio tracks. You can also synchronize Deck
to QuickTime movies (Macintosh digital video). For
more information, see Chapter 7, “QuickTime.”

One of the most important features of Deck is that it
provides a true non-linear multitrack synchronization
environment. Deck makes it possible for Macintosh

hard disk audio to operate seamlessly in sync with
film, video, and other sources. The task of synchroniz-
ing picture and sound is handled by Deck, which runs
as a slave to your SMPTE source. All you need to do is
route the SMPTE signal from your video or audio
source to a compatible Macintosh MIDI interface
(Opcode’s Studio 5 or MOTU’s MIDI TimePiece, for
example). Then, when you select the applicable
SMPTE frame rate in Deck and put Deck online, the
current session will automatically synchronize to the
external time code source.

If you plan to use Deck in a sync environment, you
should start with a basic understanding of SMPTE time
code. If you are already familiar with time code, you
are ready to use the system. If you have never used
SMPTE time code, it would probably be wise to read
one of the publications listed in “Suggested reading”
in Chapter 10, “Basics”.

An important note about trigger synchronization

In the world of computer-based audio synchroniza-
tion, most systems differentiate between continuous
re-synchronization and trigger sync.

Continuous re-synchronization refers to systems that
measure the playback speed stability of the master
timing (SMPTE) source, and constantly adjust slave
playback speed to match the master device’s
fluctuation. Trigger sync simply waits for a start frame
and triggers playback. In this case, slave playback
speed is not altered, regardless of master speed
fluctuation.

Deck offers both continuous resync (the native mode)
and trigger sync. It is important to note, however, that
Deck only offers continuous resync on playback. This
makes Deck very useful for audio post-production
tasks, but it makes it difficult to use Deck as a
recording slave with older analog multitrack decks and
low-end VCRs. Whenever you record, Deck must use
trigger sync, because it is impossible to accomplish the
multiple sample rate conversions necessary for
continuous record resync using software alone. There
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are a number of elegant ways for dealing with this
situation.

Make sure all devices are locked to house sync

For the best possible results, you should make sure all
of your devices are plugged into a central sync
reference signal, and run Deck with Trigger Sync
turned on. By putting the burden of servo-accuracy on
the shoulders of the different analog devices instead of
making your Macintosh constantly change the sample
rate, you will always maintain the highest possible
audio fidelity. In most environments a “video black”
signal, referred to as “black burst,” is used as the
central reference. When the same signal is supplied to
all rooms and all devices, it is often called “house
sync.” Many multitrack audio decks and all video decks
can make use of such a signal. Whenever possible,
hook up all of your analog devices to black burst.

If you are using an inexpensive consumer video deck,
you can generally improve your record-sync accuracy
by using the “poor person’s black burst.” You can
accomplish this by turning on any video camera (a
Handycam will suffice), and hooking up the video out
from the camera into the video in on the VCR. This
will force the VCR to gen-lock to the camera, which
usually supplies a much healthier sync signal than the
VCR alone, and forces the VCR to play back with fewer
time fluctuations.

Slave Deck only to digital sources

When you slave Deck to a digital source, such as
timecode striped DAT or digital multitrack recorders,
you can usually avoid any synchronization problems.
These devices are very dependent on the time
accuracy of their playback, and usually will not
fluctuate playback speed. If you are slaving Deck to
such a device, you should put Deck into Trigger Sync
mode, then proceed as usual. This is one of the best
possible configurations for Deck use.

Use a SMPTE Slave Driver

If you have a SMPTE Slave Driver—a device that
converts analog SMPTE signal into digital slave clock

and word clock—you can use it to sync Deck to. The
Slave Driver measures speed fluctuations in the source
SMPTE signal and continuously changes the record
AND playback sample rate. This solution offers the
best system performance and audio fidelity, because
all hard disk audio recording and playback speeds are
adjusted directly at the hardware, thereby avoiding the
degradation of the audio signal often caused by
software-based real-time sample rate conversion.

To synchronize Deck recording or playback to time
code:

1. Make sure that you have your SMPTE source
hooked up to a MIDI interface that is capable of
SMPTE-to-MIDI time code conversion (e.g.,
Opcode’s Studio 5 or Mark of the Unicorn’s MIDI
TimePiece).

2. Open the session you wish to synchronize to time
code.

3. Choose Options > MIDI Setup. Make sure that
you have the correct MIDI port enabled, and that
it is set to the correct speed. For most applica-
tions, you can turn on both the Printer and
Modem ports and set them to the 1.0 MHz,
Generic settings.

A Ifyou are syncing to SMPTE and running
Metro in the background (or foreground),
configure Deck to receive sync and use it to
control synchronized playback. Do not set
Metro to sync to SMPTE. Set up Metro for
normal, simple playback. Deck will handle all
synchronization lasks, and will control Metro
playback directly.

4. Choose Options > SMPTE Start Frame.

N

Type in the hour, minute, second, and frame
number of the SMPTE frame that will be used as
your session zero time (the beginning of program-
material on your time code-striped tape, or the
scene you are working with). Click OK.

6. The time you enter in the previous dialog will be
your SMPTE start time, and the Return-to-zero
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button will always return you to this point.

You can click the dialog’s Capture button to
capture the current time code frame from your
time code source. Note, however, that the
Capture button will not get an accurate time
unless you are syncing to video tape using Vertical
Interval Time Code (VITC). If you are using
standard Longitudinal Time Code (LTC), the
Capture button will lift the last frame that was
received, but that frame can vary by one second
or more from the actual position. This situation is
caused by the fact that only VITC can be read at
slow shuttle speeds and in still-frame/pause
mode. LTC frame addresses are unreadable at
slow speeds and in still-frame/pause.

7. Choose Options > Online.

8. To play back audio in sync with incoming time
code, press the Play button in the Transport
window to put the current session in play-
standby.

The status indicator in the Transport window now says
“Standby” to indicate that Deck is waiting for incoming
time code. As soon as any time code is present at the
selected MIDI port, Deck will synchronize and begin
playback.

To record audio in sync with incoming time code:

1. Make sure you have a track record-enabled in the
Mixer window of Deck.

2. Press the Transport’s Record button, and then the
Play button, to put the current session in record-
standby.

3. The status indicator in the Transport window now
says “Standby” to indicate that Deck is waiting for
incoming time code. As soon as any time code is
present at the selected MIDI port, Deck will
synchronize and begin recording. Note that it may
take a few seconds for audio recording and
playback to lock and begin.

The SMPTE synchronization pre-roll time is user-

adjustable in the General preferences in the File
menu’s Preferences submenu. This setting is adjusted
in seconds, and the time you enter will be the amount
of time Deck takes between the first received SMPTE
frame and the beginning of playback. If you have a fast
Macintosh and a fast drive, you can set this preference
to two seconds or less. If you are having trouble
getting Deck to sync (“missed in-point” messages),
then set this value to six or more seconds.

Conclusion

You have learned about using MIDI to control Deck’s
faders and buttons, and to sync to MIDI sequencers
(e.g., Metro). You also learned about using MIDI Time
Code and SMPTE to sync Deck to Video. The next
chapter is a comprehensive overview of all the menus
and windows in Deck.

MIDI and Synchronization
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Chapter 9:
Deck Reference

This chapter explains all of Deck’s windows, screen
controls, and indicators, and each of the menu
commands found in each of Deck’s menus. If you have
a specific question about a Deck window, command,
control, or function, this chapter is for you. If you are
curious about a specific procedure, or you want to
learn about Deck in general, then you should read
through the previous chapters of this manual. For
more information about digital recording, see Chapter
10, “Digital Recording and Mixing Basics.”
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Tracks Global Control Area

The Tracks Global Control Area runs along the top of
the Tracks window. It includes, from right to left, the
Location Indicator, Track Size buttons, Object/Range
buttons, View Memory buttons, Zoom buttons, Tempo
controls, Snap to Grid, Time Axis, etc.

00:03:05:963 start

00:03:11:401 end
o0:00:05:438 duratin:nn

Location Indicator—Display the current time (under
the hot-spot of the cursor); and the start time, end
time, and duration of the selected object or range. All
times are indicated in the selected axis units. For more
information, see “Selecting Axis Units and Managing
the Grid” on page 37.

You can place (spot) a specific point in any region to
the exact frame or beat by grabbing the desired region
at the start point of the waveform and dragging the
region until the current time indicates the frame or
beat you want. This spotting method makes it possible
to spot sound by points other than region start and

end points.

Track Size Buttons—Set the track display size. The
two larger display modes are useful for detailed
waveform editing; the medium size is a good all-
purpose size; and the smallest can show up to 24
tracks at once, which is particularly useful for
managing complex sessions.

Object and Range Mode Buttons—Enables Object
or Range mode. Object Mode allows you to select and
manipulate entire audio regions as units. It is most

useful for arrangement. Range mode allows you to
select waveform ranges within or across any audio
region. It is most useful for editing of components
before arrangement begins (creation of loops, and so
on).

Use the tilde key (~) to switch between Object and
Range modes.

Fa F= WF= |~

View Memory Buttons—Store and recall the current
state of the Tracks window’s waveform area. For more
information about storing and recalling view memo-
ries, see “Navigating the Tracks window” on page 34.

Zoom In and Zoom Out buttons—Adjusts the
display to show more or less time. Command-click to
zoom all the way in or out. Option-click to zoom in 2
times. Option-Shift-click to zoom in 4 times.

Fit Selection button—Expands or contracts the
display so that the current selection fills the screen. In
Range Mode, press the Z key on your keyboard with
the mouse button still down after making a selection
in the Tracks window to zoom the selection to fill the

screen.

Vertical Zoom buttons—Manipulate the vertical
display resolution of the waveforms. The up arrow
expands the waveform display for viewing audio
recorded at low levels, or for finding the zero points of
a waveform. The down button returns the display to
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normal resolution. Command-clicking on either
button will immediately expand to maximum or return
to normal. The square brackets—( [ and | )—can be
used instead of the Vertical Zoom buttons.

Tempo Controls—Set the base tempo and time
signature that will be used to display and edit audio in
Beat mode. These settings make it possible to set up
Beat mode to snap edits and selections to the desired
bar and beat lengths of positions. If you are using
Metro as your sequencer, the tempo setting will
automatically be set by Metro, and any changes made
to the tempo will be reflected in Metro. Drag on the
tempo and time signature value areas to enter new
settings, or Command-click the controls to enter

settings as text.

Snap to Grid—Turns the grid on and off. The grid

units auto-adjust to match the current axis resolution.

For example, when the axis resolution is set to bars,

the grid is one bar. When it is set to quarter notes, the

grid is one quarter note. The grid is particularly useful

for music or sound arrangement according to specific
Second

tempo.
E=
SMHPTE

Axis Units Pop-up—Sets the time units by which you
will be editing. The selected time units appear at on
the horizontal axis directly above the waveform area of
the window. You may choose between the following
units: Sample, Second, SMPTE, and Beat. Sample
displays the sample number in relation to the start of

Sample

the session. (If your session’s sample rate is 44.1kHz,
there are 44,100 samples per second.) Second displays
all times in wall-clock time. SMPTE displays all times by
SMPTE timecode frame, which is useful for synchroni-
zation to picture or external tape devices. (Choose
Options > SMPTE Format to select your SMPTE frame
format.) Beat is generally used for music composition,
and is particularly useful when you are using Deck in
sync with a MIDI sequencer.

— Bar

Half Mote
Quarter Mote

EiEhth MNote

Z2nd Mote
&dth Note
1281th Note
1 Tick

Axis Resolution Pop-up—Changes the waveform
display to natural subunits of the master axis units. For
example, Beat mode offers Bar, Half Note, Quarter
Note, Eighth Note, Sixteenth Note, 32nd Note, 64th
Note, 128th Note, and 1 Tick as its resolutions.

You can use the Options menu’s Selection Tools
submenu to set the waveform display to specific areas
(the start or end of the current selection, for example)
with a single command, regardless of the view
resolution. Or try the Command-| and Command-]
shortcuts to jump to the beginning or ending of your
selection.

00 :00:00 000 0000 ;25 000
" et I P et i

Time Axis—Indicates the time frame of the wave-
forms in the waveform area. The time axis (or
timeline) is always shown in the units selected on the
Axis Units pop-up, and the axis is constantly adjusted
as the magnification level (view resolution) is changed.
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Markers—Provide a graphic corollary in the Tracks
window to the autolocate points stored in the
Transport window’s Location Time pop-ups. For more
information about using markers, see “Navigating the
Tracks window” on page 34.

I 2047 ME free I

Hard Drive Status Indicator—Shows the amount of
remaining unused space on the hard drive that
contains the current session. You can usually free up
more drive space by selecting File > Compact
Session. If you run out of disk space while recording a
new track, recording stops, thereby ruining your take.
For more information about compacting a session, see
“Compact Session” on page 29.

Track Control Area

There is a Track Control Area for each track in the
Tracks window just to the left of each track. It contains
the Track pop-up menu, input selector box, solo/
mute/record buttons, track level and pan indicators, as
well as track automation view.

Track Label/Drag Area—in the upper left hand
corner of the Track Control Area, lists the number of
the current track and enables you to drag the track
from this area to rearrange track order. For more
information, see “Moving and Renaming Tracks” on
page 33.

Maw 1

Playwlist 1
FlawList 2
FlayList 2
FlawList 4
FlayList 5
FlayList &
FlawList 7
FlayList 2
FlayList 2
FlayList 10
FlawList 11

Playlizt 12

Track Pop-up—Specifies the track that is currently
loaded in the indicated track position. You may
change the track location by clicking and dragging on
the pop-up to select a new track. You may also change
the name of the current track by Command-clicking in
this area.

B @000 31

Jane

Input Selector Pop-up—Specifies which audio input
channels on your hardware will supply signal to the
current track for recording.

Solo and Mute Buttons—Solo enables you to hear
that track alone. Mute turns off that track’s playback.
Note that multiple tracks may be soloed or muted
simultaneously, and that Solo always takes precedence
over Mute.
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Record Button—Enables recording to that track.
When you click this button, you will immediately be
able to hear the audio that is coming through the
input channel selected in the track’s Input Selector.
For more information about recording, see “Recording
into the Tracks window” on page 24.

Track Level and Pan Indicators—Enable you to
monitor level and pan values while editing automa-
tion. Dragging these indicators allows you to set track
volume and pan levels from the Tracks window
(without going to the Mixer).

Track Automation View Pop-up—Allows you to
view, create and edit automation envelopes in the
waveform area of the Tracks window. When this pop-
up is set to None, then the track shows and edits only
waveform information. For more information about
automation envelopes, see “Visual Automation
Envelopes” on page 66.

= off

E Eecord Volurne
E Record Pan
¥ Record Al

E Erase Yolume
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Track Automation Status Pop-up—Functions in
exactly the same fashion as the automation pop-up
explained at length on page 69. For information about
real-time recording of fader motion, see Chapter 6,
“Automation, Mixing, and Mastering.” When you are
editing automation envelopes in the Tracks window,
this pop-up is most useful for turning automation on
or off by track, and for erasing all of the automation on
a track. This pop-up must be set to Play during
monitoring and during the mixing process to ensure
that your automation data is calculated into the new
file.

Hold down the Option key while selecting the
automation status to set all tracks to the same status.

Work Tracks—Deck allows only as many tracks of
audio as your system will allow, but the Tracks window
lets you create an unlimited number of work tracks. A
work track functions just like a play track except that
you cannot hear audio played back from a work track
in real-time, other than when auditioning. Use work
tracks to create a virtual mix. For more information
about virtual mixing, see “Virtual mixing” on page 72.
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Tracks window key commands

Many of the editing features in the Deck Tracks window are available only from key commands. By using key
commands, Deck makes it possible to execute and modify all kinds of edits without requiring a number of different
modes. Here is a list of the Tracks window key commands and what they do:

Keyboard shortcut

Command-,

[

]
C

Tab
Shift-Tab
+

Return

Tilde (~)

Spacebar
Control-Spacebar
Shift-Spacebar or Command-T
Option-C

Option-|

Option-|
Command-]
Command-|

Enter

Option-click marker

Command-click marker

Shift after beginning to drag vertically

Command-drag

Result

Positions to fit

Zooms in wave amplitude

Zooms out wave amplitude

Turns cue loop on and sets cue from current selection
Moves to next location time or marker
Moves to previous location time or marker
Moves selection ahead by set nudge time
Moves selection back by set nudge time
Returns to zero

Toggles between Range and Object modes
Plays/stops/continues

Plays from previous play position
Auditions selection

Turns cue loop off

Full zooms in wave amplitude

Full zooms out wave amplitude

Jumps to left of selection

Jumps to right of selection

Creates marker in Time Axis at current location time
Deletes marker

Renames marker

Constrains to original start time

“Sticks” region to end of previous region (“butt-splice”)
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Keyboard shortcut Result

Control after beginning to drag Slides all regions later in time by length of selected region
Option-drag Copies region, leaves original behind

Arrow keys Move selection up/down/left/right

Command left/right arrow Move selection by current Grid Unit

Option-click magnifier Zooms in/out 2 times

Shift-Option-click magnifier Zooms in/out 4 times

Command-click left magnifier (-) Zooms full out

Command-click right magnifier (+) Zooms full in

Command-click fit selection Positions selection left

Option-click fit selection Positions selection right

Option-click track view display Changes all track displays to new views mode
Option-click automation mode display Changes all track automation displays to new mode
Command-click Track name Renames Track

Command-click track level indicator Opens volume text entry dialog box

Command-click pan indicator Opens panning text entry dialog box

Option-click pan indicator Sets pan position to center

Option-click track level indicator Sets volume slider to 0dB

Command-click horizontal scroll bar Moves Tracks window view by half screen increment
Command-Shift-Option-U Recalculates all region overviews

X-drag Fits marquee to full screen without changing selection
S-drag Solo scrubs current track

Option-S-drag Scrubs all tracks

Option-Command-V Pastes At

Option-click Transport master counter Moves Tracks window to current location time
Command-V Pastes after

Shift-Command-V Pastes before

Command-C Copies

Command-X Cuts
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Keyboard shortcut Result

Command-B Clears

Command-Y Removes

Command-A Selects all

Command-U Deselects

Shift-click automation event Constrains time

Command-click automation event Enters new automation break point

Control-Command-click automation Enters new automation break point with same level as
event preceding breakpoint

Tracks window key commands (Range mode only)

Keyboard shortcut Result
A-click Selects whole region or empty space between regions
Shift-A-click Extends selection/insertion point to region boundary
Option-Shift-A-click Extends selection/insertion point to beginning/end of session
Shift-A-left/right arrow Extends selection/insertion point to region boundary
Option-Shift-A-left/right arrow Extends selection/insertion point to beginning/end of session
Z-drag Fits new selection to full screen
Option-left/right arrow Moves section range left or right by selection amount
Control-left/right arrow Collapses selection to left or right
Shift-left/right arrow Extends selection to left or right
Left/right arrow Moves selection by current grid unit
Up/down arrow Moves selection to neighboring track
Shift-up/down arrow Extends selection to neighboring track
Command-R Slices (creates new region)
Control-click automation event Constrains amplitude
Command-up arrow Nudges up selected automation points pixel by pixel
Command-down arrow Nudges down selected automation points pixel by pixel
Command-Option-left/right arrow Copies selection to left or right
Command-Option-up/down arrow Copies selection above or below
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Tracks window key commands (Object mode only)

Keyboard shortcut Result
Control-click automation event Opens event entry dialog box
Command-up arrow automation event Nudges up selected automation points pixel by pixel
Command-down arrow automation event Nudges down selected automation points pixel by pixel
Command-left arrow automation event Nudges left selected automation points pixel by pixel
Command-right arrow automation event Nudges right selected automation points pixel by pixel

Mixer window

Choose Windows > Mixer (Command-2) to open the
Mixer window. The Mixer window is where you control
basic audio tasks, including recording, overdubbing,
synchronization, mixing, automating and, on Power
Macintosh, assigning real-time effects to play tracks.

[=——— psychotropic Miker=—"—————— [0 B

Mixer window
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Effect Selector Boxes—Allows you to assign up to
four real-time, in-line effects (Built-in or VST) to each
play track. To temporarily turn off an effect, click the
Effect On/Off button to the left of its selector box. To
permanently remove an effect and all of its settings, set
the selector to Thru. To open a VST effect’s edit
window, Option-click on the VST effect name or
choose Open editor from the pop-up menu.

Digi 2
Digi 3
Digi 4
Digi 5
Digi &
Digi 7
Digi &
Digi 2
Digi 10
Drigi 11
Digi 12
Digi 13
Digi 14
Digi 15
Diai 16

Input selector—Specifies which audio input channel
on your hardware will supply signal to the current
track for recording. Each enabled record track must be
set to a different input because multiple tracks cannot
record from the same input.

Each enabled record track must be set to a
different input. Multiple tracks cannot record
from the same input.
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Automation pop-up—Is used to record, play back, and
erase real-time volume and pan automation on this
track. For more information about recording and editing
automation, see “Visual Automation Envelopes” on page
66, and “Mixer-based Automation” on page 65.

Crigi 1 <= Digi 2
Digi 3 <= Digi 4
Digi 5 <> Digi &
Digi 7 <—> Digi &
Ligi 9 <—> Digi 10

Digi 11 <= Digi 12
Digi 13 <—> Digi 14
Digi 15 - Digi 16

Track Output Pan selectors—Specify the output pair
(left and right output channel) through which the
track’s audio will play.
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Mute button—Turns off that track’s playback.
Pan fader—Adjusts the placement of the track’s audio Multiple tracks may be muted simultaneously.
in the stereo field (left and right). This will function

correctly only if you have routed your audio outputs to m

the left and right channels of a stereo amplification

system or powered speakers.
Record-enable button—Enables recording to that

track. When you click this button, you will immediately
be able to hear the audio that is coming through the
input selected in the track’s input selector. For more
information about recording, see “Recording into the
Tracks window” on page 24.

Volume fader—When playing back a track of audio,
the track volume fader controls the overall volume
level of the track. When the track is record-enabled
(with the track’s Rec button highlighted), the volume
fader controls the monitor level of the input signal,
not the actual level of the track’s recording. Fader

values are displayed in the Transport window’s VU Meter and Clip Light—When the track is not
Control Value Indicator box. To enter a specific level record-enabled, the meter shows you the amplitude
for a fader, Command-click it. For information about (volume) level of the audio signal on that track,
setting audio input levels for various audio hardware, regardless of the track’s fader setting, enabling you to
sec Qhap}er 3, “Recording and Adding Audio to see where you have signal, even if that signal is muted
Sessions.” or fully attenuated. When the track is record-enabled,
the meter shows you the amplitude (volume) level of
m the incoming audio signal present at the selected
audio input. Use it to adjust the incoming signal to the
highest possible level without clipping. If the signal is
too high, the Clip Light (top segment of the meter)
will turn on. Click the Clip Light to turn it off, then

Solo button—Enables you to hear that track alone.
Multiple tracks may be soloed simultaneously. If a
track is both muted and soloed, it will play back.
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adjust your signal.

| Mew

Ay

FlayList 2
FlayList &
FlayList 4
FPlayList 5
FlayList &
FPlayList 7
FlayList 2
FPlayList 2
FlayList 10
FlayList 11

PlayList 12

Track Selection pop-up—Specifies the track that is
cued to play on this track location. Command-click
this area to rename the current track.

Channel Signal Flow

The signal flow in Deck from audio file playback to
output is important to understand when applying
panning, as well as VST plug-ins or Deck’s Built-in
effects. The signal path for audio file playback comes
first from disk (or the specified channel input during
recording), passes in mono through Deck’s Built-in
effect(s) (if any are enabled on that channel), through
Deck’s channel volume fader (mono gain control),
through any mono-to-mono VST effects, and through
the volume fader; it is then panned left/right to the
assigned outputs via the panner fader, and finally
passes through any active stereo-to-stereo VST plug-
ins on the channel in question before passing through
the assigned Master Outputs.

Transport Window

Choose Windows > Transport (Command-1) to open
the Transport window. The Transport window
controls audio playback and recording, and linear
movement through your session, much like the
transport controls on an analog tape deck. The
Transport does not have to be the active window for
the Transport buttons to function.

psychotropic: Transport

Transport window, minimum size

The Transport window has three possible sizes. Click
the window’s zoom box to adjust its size.
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Master Counter—Shows your current position in the
session, and allows you to drag on it to scrub audio
playback in either direction for exact location. When
you first start up Deck, the default time units are set to
SMPTE frame (29.97 frames per second non-drop). To
choose a different time unit (such as seconds, or
beats) use the Axis Units pop-up in the Tracks
window. If you wish to set the session start time to a
nonzero value, choose Options > SMPTE Start Time.

Option-click the Master Counter to automatically scroll
the Tracks window to the Master Counter time. The
Tracks window will automatically scroll after playback
stops if you have the Scroll after Play preference
turned on. For more information, see General
Preferences in the File menu section on page 120. The
Tracks window will scroll during play if you have Scroll
during Playback enabled in the Option menu.

Transport Buttons—Function very much like those
on an analog tape deck. The buttons are, from right to
left, Return-to-zero, Rewind, Stop, Play, Fast Forward,
and Record.

The normal function of the Record button is to enable
non-destructive (constructive) recording. This means
that the punching in of new audio over old will not
erase the original audio. This is a safer recording
method, and it allows you to go back to a previous
version if you don’t like a punch-in.

Spacebar is the default keyboard command for both
play and stop. Control-Spacebar to begin playing from
the last counter position, not the current one. The
Return key is the shortcut for Return-to-zero.
Keyboard shortcuts for the transport controls can be
changed with the General Preferences command.

For information about external control of the transport
buttons, see “MIDI Key Maps” on page 88.

Slide Locator—Offers you an easy way to locate
quickly to any part of the current session. Drag on the
horizontal slider to move around in the recording. As
you drag the slider, the tape counter is updated to
show you the current time. When you let go, you will
be ready to begin playback or recording from that
point.

The slide locator is useful for general movement
around the current session, but the autolocation
buttons, explained in “Location times” on page 20,
provide a quicker and more accurate method for exact
time location.

=)

Punch Mode—Toggles Deck record functions into
punch mode. When Deck is in punch mode, the begin
counter sets the punch-in point and the end counter
sets the punch-out point. When punch mode is on, all
recording will occur only between the punch-in point
and punch-out point. For more information about
automated punch-in and punch-out, see “Automated
punch-in and punch-out recording” on page 27.

Loop (Rehearse) Mode—Toggles Deck playback
functions into loop (rehearse) mode. When Deck is in
loop (rehearse) mode, the begin counter sets the loop
start point and the “end” counter sets the loop end
point. When loop mode is turned on, the loop range
alone (from begin to end) will play back repeatedly.
For more information about loop/rehearse, see “Loop
mode” on page 27.
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Begin and End Time Counters—Indicate the times
that will be used by the loop (rehearse) and punch
functions. These counters may be set in five ways:
1.
Set a selection range in the Tracks window, then
press C. This method will automatically enable
looping.

Click the begin and end buttons during playback
to pick up the current counter time.

Drag the counters left or right to scrub their values
with audio.

Command-click the counters to enter precise
times directly.

Choose Options > Selection Tools > Set Punch
Time From to set the begin and end times from
the current Tracks window selection.

Command-click the begin or end button to move that
time up into the Transport window’s main counter.

I EI’IE ine “

Status Indicator—Alerts you to certain situations. For
example, when Deck is set to slave to timecode, the
status indicator will contain the word “Standby.” If you
are ever unsure what is required of you at a particular
stage of Deck production, or if Deck seems to be
waiting for something, make sure to check this

indicator.

Control Value Indicator—Displays the value of the
real-time effect, mixer pan, or mixer volume control

you are currently moving. This indicator will also show
you the value of most of the controls in the Effect
window, so that you can keep track of the parameters
of each Effect control as you adjust it.

LOCATION TIMES

Location Times—Are counter memories that allow
you to store up to 200 times for immediate recall and
location. Location times are stored as a part of the
session file, and will always remain with the session in
which they were created until they are replaced or
reset. Location times are displayed as red markers in
the Tracks window. For more information about
location times, see “Location times” on page 26.

Mixer States—Allow you to take a snapshot of the
current mixer setting for later recall. Mixer states are
stored as a part of the session file, and will always
remain with the session in which they were created
until they are replaced or reset. For more information
about using mixer states, see “Using mixer states” on
page 69.
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Pitch Control Fader—Allows you to adjust the audio
playback speed by small amounts in order to
compensate for pitch and time conflicts (as on a
multitrack tape deck). It acts as a tape speed control
that allows you to slow down playback speed from
normal speed to a near stop (—98%). Some audio
distortion may result from extreme settings.

Digital disk-based pitch control is accomplished using
real-time sample rate conversion, which strains your
CPU to the limit. Resetting the pitch control to zero
will turn the tracks back on.

You may also set the session playback rate using the
Pull-down command from the Options menu. Pitch
control is a playback-only feature. Deck always records
at normal speed.

Library window

Choose Windows > Library (Command-6) to open the
Library window.

The Library window allows you to easily view all of the
audio source material that your session currently
contains. You may also drag and drop, or cut and
paste, audio regions from the Library window into the
Tracks window.

The first column shows the names of the regions you
have placed in your session. The second column
shows the length of the region, and the third column
shows the location on your hard drive of the associ-
ated audio file.

If you are importing large quantities of material, use
the Add Audio dialog box to import all of it. Then use
the Library window to spot the regions accurately,
rather than pasting them directly into the Tracks
window.

The Library window will initially show regions that you
have imported into Deck, with the Add Audio
command, for example. If you want to see all regions
in your session in this window, select Update from
Session from the Session menu’s Library Operations
submenu. For more information about Library
Operations, see “Session menu” on page 138.
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Library window
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MIDI window

Choose Windows > MIDI (Command-5) to open the
MIDI window.

MIDI window

The MIDI window can be used to import a standard
MIDI file to play back with your session, in sync with
your audio tracks. For more information about using
MID], see Chapter 8, “MIDI and Synchronization.”

m EaElZgEUE Il

File Indicator—Shows you the name of the current
MIDI file.

lImPORT |

Import Button—Imports a MIDI file into the session.

If you select a new MIDI file, all current MIDI data will
be erased.

Deck only supports the importation of Standard MIDI
files as defined by the International MIDI Association
specification version 1.0 (that is, Type 0 and Type 1).

Subscribe Button—Subscribes to your Standard
MIDI file. With the subscribe function on, whenever
Deck is switched from the background to the current
application, it will look at the current Standard MIDI
file to see if it has been changed. If the modification
time is more recent than when you first imported the
file, Deck will automatically re-import the file. This
function allows you to edit your MIDI file and have the
changes be reflected in your session.

For the subscribe function to work properly, you must
re-export your file into Standard MIDI format using the

same name.
= e |
MUTE ALL

Mute All Button—Mutes all MIDI tracks. This
command takes precedence over Solo and Mute
buttons on individual MIDI tracks.

TRACH

MIDI Thru Track—The first track in the MIDI
Window is the MIDI Thru track.

MIDI Thru Port—Uses the default port you selected
in the MIDI preferences dialog box as the port through
which outgoing MIDI data is sent.

MIDI Thru Switch—Toggles the MIDI Thru track on
and off. When the switch is on, Deck will send any
MIDI data coming into the system out the MIDI Thru
port.
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QuickTime window

ran 1ang

Choose Windows > QuickTime™ (Command-4) to
open the QuickTime movie window. QuickTime
window allows you to load and play a QuickTime
movie in sync with your digital audio. For more
information about using QuickTime movies, including
descriptions of the commands on the QuickTime

@ menu, see Chapter 7, “QuickTime.” Also see,
“QuickTime menu”, on page 140, for more informa-

Track Name—Rename the track by Command-
clicking on the desired track.

tion on Deck’s QuickTime functions.

Track Port Indicator—If you are using OMS, the
pop-up will display a list of your OMS instruments. If
you are using Deck’s internal MIDI setup, this area will
display the ports you chose in the MIDI Setup
available in the Options menu.

5

Track Channel Indicator—Indicates the channel
through which the MIDI data is played. Change the
channel by clicking in the channel area and dragging
up or down to the desired channel number. A dash (-)
indicates that MIDI data will be played through the
channels indicated in the original file.

Solo and Mute buttons—Solo enables you to hear
that track alone. Note that multiple tracks may be
soloed simultaneously, and that track Solo always

takes precedence over track Mute. Mute turns off that
track’s playback.
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Effect window

Choose Windows > Effect (Command-7) to open the
Effect window. The Effect window contains the
controls for all of Deck’s real-time in-line audio effects.
For more information about using effects, see Chapter
5, “Effects.”

The Effect window contains the controls for all real-
time effects currently selected for your session. To add
effects to a session, use the Effect Selector boxes in
the Mixer window to add up to four effects per play
track. Then open the Effect window (Command-7) and
you will see a set of control sliders for each effect you
have selected. You can configure the Effect window by
using the Preferences submenu, found in the File
menu’s Preferences submenu.

By using the Transport window’s Control Value
Indicator, you can track the value of effects sliders as
you move them. This can help you zero in on a
particular frequency band while using an EQ effect, or
adjust delay time for a Delay effect, for example

Effect

Effect window
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Master Outputs window

Choose Windows > Master Outputs (Command-9) to
open the Master Outputs window. Use the Master
Outputs window monitor and attenuate the levels of
stereo pairs of outputs. You can also assign VST Plug-
Ins to mono and stereo outputs.

=]
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| Thru |
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Master Outputs window, stereo

| Digit |l Digiz |

Output Indicator boxes—Displays the master
channel output assignment of your audio interface.
They are always grouped in stereo pairs.

B mdaLimiter )
Ol H-YST Room Reverb ” |
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Effect Selector pop-ups (Mono/Stereo)—Allows
you to assign up to four real-time, in-line effects (VST
only) to either a mono (mono to mono) master output
channel or to a master output stereo pair (stereo to
stereo). To temporarily turn off an effect, click the
Effect On/Off button to the left of its selector box. To
permanently remove an effect and all of its settings, set
the selector to Thru. To open a VST effect’s edit
window, Option-click on the VST effect name or
choose Open editor from the pop-up menu. For more
information about using VST effects in the Master
Outputs window, see Chapter 5, “Effects.”
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Master Fader—When playing back the mix of your
Deck session, the Master Volume Fader controls the
overall volume level of the stereo master outputs.
Fader values are displayed in the Transport window’s
Control Value Indicator box. The VU Meters and Clip
lights are post-fader on the Master Outputs.

VU Meters and Clip Lights—Show you the
amplitude (volume) level of the audio signal on the
stereo master output. The meters are post-fader. Use it
to adjust the master output signal to the highest
possible level without clipping. If the signal is too
high, the Clip Lights (top segment of the meter) will
turn on. Click a Clip Light to turn it off, then adjust
your signal with the Master Fader.

CPU Meter window

Choose Windows > CPU Meter (Command-0) to open
the CPU Meter window. Use the CPU Meter window to
monitor Deck’s usage of the CPU, disk, and RAM.

E 3 Cpu Meter 3 E
-

CPU Meter window

CPU—monitors the percentage of maximum real-time
CPU cycles Deck is using.

Disk—monitors the percentage of maximum through-
put on your hard drive(s).

RAM—monitors the amount of RAM available from the
amount of RAM that has been allocated to Deck. See
“Allocating RAM to Deck”, on page 10.
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File menu

The File menu contains most of the commands you
will use to create, open, import, load, and maintain the
different files used by Deck.

New (Command-N)—Creates a new empty session.
Open (Command-0)—Opens a session.

Close Session (Option-Command-W)—Closes the
current session.

Save (Command-S)—Saves all of the changes that
have been made to the session since the last save. If
you have the “Always Save Regions when Session is
Saved” preference set (File > Preferences > General)
then saving the session will automatically save all
region definitions to their associated sound files.

Save A Copy As—Allows you to create and save a
copy of the currently open session under a new name.
This procedure will only copy the session document,
and not the associated audio file and crossfade folders.

When two session files share the same audio files, any
destructive audio edits (Normalize, Invert, and so on)
will always appear in both. For this reason, it is often
wise to execute destructive edits on a copy using the
Make a Copy button in the Destructive Effects dialog
box.

Revert—Disregards all changes made to the current
session and opens the most recently saved version of
that session.

Add Audio to Clipboard (Command-D)—Allows
you to select any sound file or set of sound files from
any mounted drive, and add those sound files to the
Clipboard and the Library window for pasting onto any
track in the Tracks window. Note that you must have a
session already open to use this command. For more

information about adding audio to a session, see
“Adding Audio Files and Regions to a Session” on page
22,
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Add SND to Clipboard—Allows you to select any
sound resource on any mounted hard drive, and add
that sound resource to the Clipboard for pasting onto
any track in the Tracks window.

Add SDII Playlist to Clipboard—Allows those with
Digidesign hardware to edit playlists using Sound
Designer II software and easily import their work into
a Deck session.

Load Audio File (Command-1)—This command
remains in Deck from original DECK; and is here for
the convenience of original Deck owners. Generally,
you will be much better served by adding audio
directly to the Tracks window using the Add Audio to
Clipboard command. Using the Load Audio File
command as a shortcut allows you to load an existing
audio sound file directly onto any active play track.

Only monophonic or split stereo Sound Designer 1I
sound files may be loaded using the Load Audio File
command. For other file formats, see Adding Audio
Files and Regions to a Session on page 22.

Add Audio CD Track To Clipboard (Option-
Command-D)—If you have a built-in Apple double
speed or faster CD-ROM drive, or other supported
drive, you can use the Add Audio CD Track command

Deck Reference

119



to add tracks from any audio CD to the Deck
Clipboard. Note that this is a digital transfer process so
there is no loss of signal or sound quality. Also note
that we use QuickTime to accomplish CD audio lifts,
so don’t be confused by the importing movies status
display you'll see as the lifts occur.

A In order to use this feature, you must have
either the Apple CD-ROM driver, or a driver
that is 100% compatible. Also required is the
Foreign File Access System Extension with its
Audio CD support file, version 5.0.1 or later. In
addition, a supported CD-ROM mechanism is
required.

Compact Audio File—Lets you get rid of unused
audio data in a sound file. Compacting audio is a
destructive process. For more information, see “Using
Compact Session and Compact Audio Files” on page
90.

If you use the entire sound file in any session, you will
find that there is no unused audio data to delete. In
such a case, Compact Audio File may not increase your
available drive space.

Defragment Audio File—Defragments a designated
audio file. You may generally prefer to optimize you
audio hard drives with a separate application, such as
Norton Speed Disk.

Launch Metro (Option-Command-1)—If you have
the Metro sequencer installed on your computer, the
Launch Metro command will automatically launch, or
bring Metro to the foreground if it is already open. For
more information on using Deck with Metro, see
“Using Deck with the Metro Sequencer” on page 90.

Import MIDI File—Allows you to import MIDI files
into your session without opening the MIDI window.
For more information about Deck’s MIDI import
functions, see “Importing MIDI Files” on page 92.

Deck’s MIDI Preferences are preset to split channels
when importing. If you do not wish the channels to be
split, turn this preference off.

Dispose MIDI File—Removes the current MIDI file
from your session.

Load MIDI Map—Loads previously configured and
saved MIDI maps. This is especially useful if you
regularly work with different control interfaces or if
you frequently use the same MIDI Mappings in every
session. To Load a previously saved MIDI Map, select
Load MIDI Map from the File menu and locate the
desired MIDI Map on your hard drive and click Open.
For more information on mapping MIDI controllers to
faders in Deck, see “MIDI Key Maps”, on page 88.

Save MIDI Map—Saves your custom MIDI Maps. This
is especially useful if you regularly work with different
control interfaces or if you frequently use the same
MIDI Mappings in every session. To Save your MIDI
Map, simply select Save MIDI Map from the File menu
and you will be prompted to Save the current MIDI
Map to your hard drive. For more information on
mapping MIDI controllers to faders in Deck, see “MIDI
Key Maps”, on page 88.

Preferences

General Preferences

General

[ Autestop at end of Session [ Change region start times with BPM change
[ Always save regions when Session is saved Loop audition
[ Rewrite region list Serall after play
[ Stop audio playback i the drive is too siow [ Enable multi- processing support
[ Show warning if virtual memory is on

Update speed during playbeck (1-10): EI Transport key equivalents

SMPTE Preroll Time: [4.000 |Seconds I8 [Rewincl] WStooH MAlcy/H Ik,
@ | & |0 |® |®

Sound Manager Record Offset: ms
= L] 5oy | ey | 5oy | Goy | Bwy

oy —/—————————

Sound Eclitor signature: aufM

Color scheme:

[ Use desktop curtain
Curtain toy

General Preferences dialog
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Autostop at end of Session—Lets you select
whether Deck should automatically stop playback
when the end of the current session’s longest track is
reached.

Always save regions when Session is saved—
Makes sure that all audio regions you have created or
edited are saved at the same time the session is saved.
If you turn this preference off, the audio regions you
create will be local to the session only, and will not be
available for use within other programs (e.g., Peak)
until you select the Session menu’s Export Session
Regions command. This preference should generally
be turned on. This preference needs to be on for
compacting to work.

Rewrite region list—Allows you to select exactly
what happens when regions are saved out to their
source sound files. If turned on, existing regions are
deleted from the source sound file and replaced by the
current regions when the session is saved. If turned
off, the current regions are added to the source sound
file. Regions with the same name replace their older
versions, but no existing sound file regions are
deleted. Use this option with care. If all of the sound
files in the current session are used only by that
session, this command will keep those sound files in
perfect sync with the session. This will make the sure
that the Compact Session command will yield the best
results by making sure that no extraneous regions
remain in the source sound files. This preference
needs to be on for Compacting to work.

Stop audio playback if the drive is too slow—
Allows you to set how carefully Deck checks to see if
your drive is too slow. If you attempt to play multiple
tracks from a very slow drive, Deck may not be able to
play them without a small skip in playback. Often this
skip is so subtle you will not be able to hear it. When
this preference is turned on, Deck will put up a
warning dialog box and immediately stop playback any
time disk performance might cause a playback skip.
When this preference is turned off, Deck will continue
to play back, even if a slight skip is possible.

A If you are mixing live directly to DAT or a
mastering medium, then turn this preference
on. It guarantees that audio playback will be
supervised and stopped before any skip might
occur. If you are simply editing sound and you
Dplan to mix to disk, then leave this preference
turned off. Almost all skips will not be audible,
and even if you do hear one, it will not appear
in the master file that resulls from a mix-to-
disk.

Change region start times with BPM change—
This preference applies only to edits made in the
Tracks window when you are in Beat mode. When this
preference is turned on, any change to the tempo in
the Tracks window will move all audio regions to
adjust their start times to the new bar/beat bound-
aries. This is useful if you are using Deck as a virtual
drum machine, with individual sounds that should
shift with a tempo change. When this preference is
turned off, any change to the tempo in the Tracks
window will not move any audio regions. This is useful
if you are using Deck to arrange segments of audio
that have their own internal rhythms, or if you are
doing synchronization work, and want to make sure
that audio times always remain unchanged.

Loop audition—When this preference is on, the
Process menu’s Audition Selection command will
automatically loop any selected range during playback.
When the preference is off, Audition Selection will
only play back the selection a single time.

Scroll after play—When this preference is turned on,
Deck will automatically scroll the Tracks window to
the point at which playback stopped. You can use this
function to easily find the waveforms you just played.

Enable multi-processing support—Enables multi-
processing support for Deck’s built-in effects. This
means that Deck’s built-in effects will run on the
second processor, if one is present, while all other
functions run off the primary processor.
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Update speed during playback—This preference
allows you to set how much time is available for other
programs to update in the background behind Deck
audio playback. A setting of 1 allows the background
program to update as often as possible. This setting
makes it easier to see screen activity in background
programs. (If you are running Metro in the back-
ground, you may want to use a setting of 1 to make it
easier to see what's happening in Metro’s windows
during Deck playback.) A setting of 10 prevents
background programs from updating during playback,
allowing Deck to monopolize your display. This setting
does not affect the performance of the background
program at all. It only affects screen drawing. A setting
of 5 is suggested.

SMPTE Preroll Time—This setting applies only if you
are recording or playing audio while online and
synchronized to SMPTE timecode. In such cases, the
preroll time is the time you allot to Deck to lock up
and begin playback. The number of seconds you
choose is the time between the first received SMPTE
frame value and the start of Deck playback. If you have
a fast Macintosh and fast hard drive(s), you can set this
to a lower number (2 seconds, for example) for faster
lockup times. If you have a slow Macintosh, slow
drive(s), or problems locking up to SMPTE, try setting
this value to 6 or 8 seconds. (In almost all configura-
tions, the default will suffice.)

Sound Manager Record Offset—Allows you to
specify an offset time in milliseconds when recording
via the Apple Sound Manager. This allows you to make
adjustments for latency.

Sound Editor signature—This preference applies
only to the Launch Editor command on the Process
menu. It is designed for users who wish to use a
dedicated two-track editor to further edit their Deck
audio regions (e.g., BIAS Peak). This is the Macintosh
signature of the program you wish to launch as your
waveform editor. To choose the program you wish to
use as your an external editor, click the Set button,
and use the resulting Open dialog box to select the
program. When you click the Open button, the

editor’s signature will appear. From that point on,
when you select a waveform region in the Tracks
window (when in Object mode) and select Launch
Editor (Command-E) from the Process menu, you will
be launched into your audio editor, and the correct
sound file will appear with the applicable range
selected. For more information on using an External
Editor with Deck, see “Using and External Editor” on
page 48.

Transport key equivalents—These boxes indicate
the Macintosh keyboard keys that will operate your
Deck Transport controls. Any key that types a visible
character can be used as a Transport key (e.g., keys
such as return and clear cannot be used). Once you
set these equivalents, the Deck Transport buttons can
be controlled directly from the keyboard. To set a key
equivalent, click the applicable Set button. Then press
the key you desire for that function.

A Only one function may be used per key.
During the setting process, if you attempt to

type a key that is already assigned to another
function (or if you click a key that is not
valid), you will hear a warning beep. You must
click a valid key before you will be allowed to
continue.

Color scheme—Allows you to set the color prefer-
ences for the Waveform, Waveform highlight,
Waveform, and Empty region display. You may also
choose to Use desktop curtain and its colors, as well as
whether or not to enable the Use waveform highlight
function.
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Memory & Storage Preferences

Memory & Storage

Disk buffer size: 256
S —

Meoe. play tracks: 24

Automation buffer: 3174 events
MIDI buffer: 20000 events

cancel | [ ok |

Memory & Storage Preferences dialog

Khytes

Disk buffer size—Deck accomplishes its recording
and playback tasks by routing hard disk audio data
through RAM and then out of your audio outputs. The
chunks of audio data that are placed in RAM reside in
the disk buffers. When you have a small disk buffer
(128K or less), Deck can load and manipulate these
buffers quite quickly, so program response may seem
smoother, but more pressure is put on the perfor-
mance of the hard drive. When you have a large disk
buffer (512K or more), it may take Deck longer to load
the buffers from disk, but those loadings can occur
less often, so less performance is required from the
drive. If you have a fast Macintosh and a fast drive,
leave this setting at 192K. This should allow generally
smooth operation. If you have a slower Macintosh, or
especially a slower drive (an erasable optical drive, for
example) increase these buffers until your playback
performance increases. It is not uncommon, with
extremely slow drives, to use a disk buffer setting of
1024K.

Your disk buffer is stored in RAM. If you increase the
size of your disk buffer, you should also increase the
amount of RAM you allocate to Deck. This is accom-
plished by selecting the Deck icon in the Finder, and
choosing Get Info from the File menu. Use the
resulting window to increase the preferred RAM
allocation. Multiply the number of tracks by the
increase in disk buffer size, and enter in that amount.
(Remember, there is one disk buffer for each play
track.)

Max. play tracks—Use this setting to select the
number of playback tracks for Deck sessions. You can
decrease this number if you wish to use fewer
playback tracks (to save RAM by decreasing the
number of allocated buffers, for example) but you
cannot increase the number of tracks above your
system’s limitations. It’s quite possible to exceed your
system’s capacity by throwing up more play tracks
than your CPU or hard drive can handle. If you're
adjusting this value, it is recommended that you keep
the “Stop Audio Playback if the drive is too slow”
General Preference enabled.

Automation buffer—This setting is the number of
automation events allocated to your session. If you are
using basic automation envelopes for simple level and
pan changes, this setting should suffice. If you are
creating complex automation envelopes, or using large
amounts of real-time fader automation recording, then
you may need to increase the buffer size. Remember, if
you increase it by a large amount, you should also
increase the amount of RAM allocated to Deck.

MIDI buffer—This setting is the number of MIDI
events allocated to your session. The default setting
should suffice for small files. If you have long MIDI
files, or many tracks, then you may wish to increase
this allocated amount. Remember, if you increase it by
a large amount, you should also increase the amount
of RAM allocated to Deck. If you never use MIDI, you
can set this to 0 to conserve RAM.
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Levels Preferences
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Audition Volume—Determines the level of audition
volume. You may choose either a dB value or a
number between 0 and 1023.

Audition Outputs—Sets the audition outputs to any
stereo output pairs on your ASIO-compatible audio
interface.

Clip Light Threshold—The clip light turns on if the
incoming signal is above the Clip Light Threshold. The
default setting is 0.00dB—use this setting to lower it.
Remember, audio that is clipped may be distorted.

Only compact files that will free disk space—This
preference and those associated with it control how
much disk space the Compact File and Compact
Session commands will free up. The Compact
command writes each region into a new file and
eliminates any data that is not used in the original file.
However, if you have many regions that overlap in a
file, the compaction process will not save you any disk
space; it may even take up more. It is recommend that
you leave this setting turned on.

Only compact files that will free x percent—Like
the above preference, this preference further
constrains the Compact command. Simply choose a
percentage and the Compact command will not work
below that amount.

Only compact files that will free x MB—Like the
above preference, this preference constrains the
Compact command. Simply choose a number and the
Compact command will not work unless it frees that
much disk space.

Bit Depth Conversion—Sets the default bit-depth
conversion method in the Mix-To-Disk, Mix Regions as
Files and Export Movie dialog boxes. Bit depth
conversion will only affect mixdown, and will only be
enabled when you are converting 16-bit audio down to
8-bit depth. Setting the default will only affect the
default choice that appears in the Bit Depth Conyv.
pop-ups in Deck—you can still use the pop-ups to
select any of the four methods when mixing or
exporting audio.

Use Soft Saturation—Enables Soft Saturation. Soft
Saturation mimics analog distortion and compresses
the dynamic range to give you additional headroom
before clipping. Nonetheless, it is best to adjust your
input levels while recording to avoid clipping and not
use soft saturation.

Slave Settings Preferences

Slave Settings

Current Slave: Mone

[ Open slave decuments

[+ Quit slave when quitting

] Save slave's document when saving
] Always pass selection

Cancel I

Slave Settings Preferences dialog

Current slave—This indicator shows the name of the
program that is running as a time-linked slave to Deck
on your Macintosh. This will generally be a sequencer

(e.g., Metro), but it can be any background-compatible
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program that understands Deck’s timing architecture.
If you have a program that is incompatible with this
slaving architecture, please contact BIAS and the
program’s manufacturer.

You do not need to choose a Current Slave program.
The slave software automatically makes itself known to
Deck using AppleEvents. All you have to do is start up
the slave program one time with Deck running in the
background. If the program is slave-compatible, its
name will then appear in this indicator.

Open Slave Documents—This check box lets you
choose whether Deck should always start up the slave
application and open the slave’s associated document
whenever a Deck session is opened. When you are
running Metro with Deck, for example, Deck keeps
track of what MIDI file is open in Metro and associates
that MIDI file with the current Deck session file. When
you have Open Slave Documents checked in this
dialog box, opening a Deck session will automatically
open the associated MIDI file in Metro in the
background.

Both Deck and Metro offer the ability to open the
other application and its associated document. Turn
on this function in one program or the other, not in
both. Choose which program is the one you generally
use first in the composition or tracking process, and
configure that program to open documents in the
other application.

Quit Slave When Quitting—This check box lets you
set Deck to force the slave application to quit when
you quick Deck. This is a simple timesaving function,
and is particularly useful if you are using the slave in a
transparent way, and you don’t want to be reminded
that the slave is even running.

Save Slave’s Document When Saving—This check
box allows you to choose whether Deck should
automatically save the slave program’s document any
time the current Deck session is saved. This prefer-
ence is useful, because it helps make sure that Deck
session versions always stay in sync with slave

application documents (e.g., Metro MIDI files).

Always Pass Selection—This check box enables the
Pass Selection function in Deck, so that when you stop
at any time in Deck and switch to Metro, Metro’s
Transport and other windows will be set at the same
time. For example, if you stop Deck at Bar 37 to do
some editing and then switch to Metro to edit the
same section, all of Metro’s windows will show the
corresponding Metro MIDI events at Bar 37.

MIDI Preferences

MIDI Preferences

[ Split channels on incoming MIDI files

Default output port: | = IAC Bus #1 >
Timecode output port: = |AC Bus #1 ¥

[ cancet | |[ ok |

MIDI Preferences dialog

Split channels on incoming MIDI files—When this
preference is on, Deck will split the channels when
you import a MIDI file. This is useful when you are
importing Type 0 MIDI files, which store all track data
in one channel.

Default output port—This pop-up lists your MIDI
ports and uses the first one on the list as the default
output port. To change the port, simply select a
different port using the pop-up menu.

Timecode output port—This pop-up controls
through which port outgoing MIDI timecode is sent.
To change the port, simply select a different port using
the pop-up menu.
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Effects Preferences

Effects Preferences

@ Make rows as wide as the window
) E sliders per row

Effects Allocate

EQ ]

Delay 2
Chorus

Hi Shelf EQ
Lo Shelf EQ
Graphic EQ
Multitap

=k A AR A

Number to Allocate: |4

Delay line length: [500 msS

=

Effects Preferences dialog

Make rows as wide as the window and sliders
per row—These options control the on-screen layout
of the Effect window sliders. “Make rows as wide as
the window” allows you to fluidly re-configure the
window size by using the Macintosh window size tool
(the grab area in the lower right-hand corner of the
Effect window). The sliders per row field allows you to
specify a set width for the Effect window.

Effects Allocation—Allows you to specify the
maximum number of Deck’s real-time built-in effects,
for each effect. To set this preference, click the name
of the effect you wish to allocate, then enter a number
in the Number to Allocate box below.

Delay line length—Set the maximum delay line
length (or loop time) for Deck’s real-time delay effect.
This setting is in milliseconds (ms), or thousandths-of-
a-second.

Save Settings as Template

Choose File > Preferences > Save Settings as
Template, and Deck will take a snapshot of the current
location of all open windows in the current session,
and use that as a template. Whenever you create a new
session, Deck will automatically open only those
windows, and they will be in the same location as they
were when you selected Save Settings.

Quit (Command-Q)—Closes the current session and
quits Deck.

Edit menu

Most edits in Deck consist of placing components
(sound file regions), copying and/or pasting those
components. The Edit menu contains all of the
commands you will use to apply your typical
Macintosh edit functions.

Undo (Command-Z)—Reverses the effect of the last
edit operation performed. Undo only reverses the
most recently performed action. Deck will always warn
you if you are executing a process that cannot be
undone (certain destructive effects, for example).

Clipboard Memories—You can copy or cut to, and
paste from, any of four clipboards, labelled A, B, C, and
D. Only one of the four is active at any one time. Use
the Clipboard Memories submenu to select a new
Clipboard, or use the key command shortcuts: Shift-
Command-Option-A/B/C/D. Note that inactive
clipboard memories still retain their contents (if any).
When you have frequently-used regions, keep them in
Clipboard memories, so they're always ready for
pasting into your session.

Cut (Command-X)—Removes selected data from its
original location and places it on the Macintosh
Clipboard for pasting (or for deletion).

Cut removes data; it does not affect time. When you
cut waveform data, a space is left where the data was
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located. If you want to cut out waveform data and
close the gap by sliding later waveform data earlier,
use the Remove command.

Copy (Command-C)—Makes a duplicate of selected
data and places that duplicate data on the Clipboard.

Clear (Command-B or Delete)—Removes the
selected data without placing it on the Macintosh
Clipboard. This command makes it possible to copy a
waveform region, clear a different region, and then
paste the originally copied region.

If you are copying regions from more than one track,
you will need to select more than one destination
track for any Paste command. Selecting a single
destination track will paste only the first copied track.

Paste Before (Shift-Command-V)—Pastes the
Clipboard contents before the insertion point or
selection range, with the end of the pasted region(s)
butt-spliced to the beginning of the previous selected
range.

Paste At (Option-Command-V)—Pastes the
Clipboard contents at the insertion point or selected
range, replacing the selection, if applicable. If the
Clipboard contents are longer than the selected
destination range or region, then the entire Clipboard
will be pasted, potentially covering up audio regions
after the paste point. If you want to constrain the paste
not to exceed the size of the selected range or region,
use Edit > Replace.

Paste After (Command-V)—Pastes the Clipboard
contents after the insertion point or selected range,
with the beginning of the pasted region butt-spliced to
the end of the selection.

Multiple Paste After—Pastes the Clipboard contents
multiple times, as directed, after the insertion point or
selected range.

Replace—Replaces the currently selected range or
region with the Clipboard contents. If the Clipboard

contents are longer than the selected destination
range or region, then only that portion of the
Clipboard that fits into the selected range will be
pasted. If the Clipboard contents are shorter than the
selected destination range or region, then the
Clipboard contents will replace the entire selected
range or region, potentially creating an area of silence
at the end of the destination range or region.

Slice (Command-R)—Performs an in-place separa-
tion of the selected waveform Range, thereby making a
region out of that range. Slice is only available in
Range mode. To slice a waveform range, simply select
that range and choose the Slice command. This will
create a stand-alone waveform region which you can
use for arrangement purposes. Remember, Deck offers
an even faster way to slice a region for arrangement
purposes. You can always just select the waveform
range you desire, then click and hold the mouse on
the selected range, and drag that range (or Option-
drag a copy) to the new destination. This tear-off
solution is often much faster than the Slice command
when you are doing basic arrangement; however, the
Slice command is very useful if you wish to define a
new region without moving that region.

You can also use the Slice command when only an
insertion point is present. This allows you to create a
boundary, thereby generating two regions (the region
before the boundary and the region after the
boundary).

Insert At—Performs the same basic functions as the
Paste At command, except it pushes all of the
waveform data after the insertion point later by the
length of the Clipboard contents. The Insert At
command never replaces waveform data. If a waveform
range or region is selected, the Insert At command will
simply insert Clipboard contents beginning at the
range or region's start point and push all subsequent
regions later in time. The selected range or region will
not be deleted.

If you are copying regions from more than one track,
you will need to select more than one destination
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track for any Insert command. Selecting a single
destination track will insert only the first copied track.

Insert After—Performs the same basic functions as
the Paste After command, except it pushes all of the
waveform data after the insertion point later by the
length of the Clipboard contents. Like the Insert At
command, the Insert After command never replaces
waveform data. If a waveform range or region is
selected, the Insert After command will simply insert
beginning at the range or region’s end point and push
all subsequent regions later in time. The selected
range or region will not be deleted.

Remember that you can perform many important
arrangement edits using drag features or the arrow
keys in tandem with the command, Option and
control keys. (The control key performs Insert
functions.) Experimenting with these key combina-
tions will help you develop more efficient editing
methods. For more information, see “Tracks window”
on page 132.

Insert Time—Inserts empty time on any track or
tracks. To insert time, select the waveform region or
range after which you wish to create empty space,
then choose the Insert Time command. (If you want to
insert time on multiple tracks, select regions or ranges
on multiple tracks.) When the dialog box appears, the
start time will default to the start time of the selected
range or region, and the end time will default to the
end time of the selected range or region. If you want
to change these values, enter the desired new Start
Time and End Time into the boxes. This will deter-
mine the start and end times of the silence you wish to
add. (The example above shows 1 second of empty
time inserted at 4 seconds.) When you are ready, click
OK. Empty space will be inserted as specified on the
tracks that were selected when you chose the Insert
Time command. No waveform data is ever deleted—
empty time is simply inserted, and the waveform(s) to
the right of the selection are moved to the right by the
empty time. If you enter a start time that is in the
middle of existing regions, those regions will be split
into new regions to make room for the empty time.

Note that the Insert Time dialog box time units will
default to whatever Axis units you have selected for
your session.

Remove (Command-Y)—Deletes the actual time
associated with the selected region or range, causing
all later regions on the selected track(s) to slide earlier
in time by the amount of the removed data. Use the
Remove command to prevent the creation of empty
time on a track (or tracks) and close the gap created
by a deletion automatically.

Select All (Command-A)—Deselects all of the
waveform data in the current track or tracks. To select
all on a single track, put an insertion point on that
track, or select a range or region on the track, then
choose the Select All command. To select all on more
than one track, put an insertion point on those tracks,
or select a range or regions on those tracks, then
choose the Select All command.

Deselect (Command -U)—Deselects all ranges or
regions, leaving you with no selection or insertion
point in the Tracks window.

Rename—Renames the selected sound file region or
track. To rename a track, just select that play track or
work track by clicking in the track name area at the
left-hand side of the Tracks window. Then choose the
Rename command. You can rename tracks, mixer
states, and location times in the mixer window and
transport window by Command-clicking on the
specific playlist, mixer state, or location time pop-up.

Make Contiguous—Snaps together any selected
waveforms. This snap will always be to the left. If you
have many separate regions in the same track selected,
all of the regions will snap together, with the first one
placed at session zero. If you have a single region,
Make Contiguous will snap that region to session zero.
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Process menu

The Process menu contains all of the commands you
will use to create new tracks and process audio
constructively or destructively. It gives you access to
fades and crossfades, normalization and other effects,
and lets you control the track bouncing and mixing
functions.

New Track (Command-K)—Creates a specified

number of empty tracks. If you already have your

system’s maximum amount of audio tracks in the

Tracks window, this command creates new empty
work tracks.

If you have added audio regions to the Clipboard
using the File menu’s Add Audio to Clipboard, you can
automatically create new tracks in the Tracks window
simply by choosing the Paste At or Paste After
command with no insertion point or selected range.

Bounce All to Mono Clipboard (Shift-Command-
B)—This is a very important command. The Bounce to
Mono Clipboard command allows you to remix one or
more tracks to disk, in order to combine them for
playback on a single track. The command automati-
cally bounces the currently selected range to the
Clipboard, including automation events, crossfades
and real-time effects. Bounce to Mono Clipboard
always mixes all play tracks, so if you want to remove
certain tracks from the mix, use the mute button to
mute those tracks. When you choose Bounce to Mono
Clipboard, all pan information on the play tracks is
ignored, and a mono sound file is the result. To place
the newly mixed file(s) on a track, select the destina-
tion (with an insertion point or range) and choose any
Paste or Insert command.

If you are bouncing only a portion of the current
session to the Clipboard, select the empty destination
track to specify the range to be bounced. Deck always
bounces all play tracks, so by using this method, you

return to the Tracks window after the bounce with the
correct, phase accurate range selected. Then choose
Paste At to paste the bounce file in phase with its
source tracks. Note that this also works if you select a
destination range on a Deck work track.

Once you have bounced multiple tracks to mono or
stereo and pasted in the resulting files, move the
original source tracks to Deck work tracks, and create
new empty tracks. Use these new empty tracks to
record or arrange more audio. By following this
process, you can create mixes that are hundreds of
tracks deep without any analog signal degradation.
Remember, you may also mix work tracks when the
Virtual Mix command is enabled.

Bounce All to Stereo Clipboard (Option-
Command-B)—Functions in the same fashion as the
Bounce to Mono Clipboard command, except it
creates a stereo mix file and places it on the Clipboard.
This mix file reflects the currently selected range,
including all automation events, crossfades and real-
time effects. Bounce to Stereo Clipboard always mixes
all play tracks, so if you want to remove certain tracks
from the mix, mute those tracks using their mute
buttons. When you choose Bounce to Stereo
Clipboard, all pan and volume automation and real-
time effects is used, and two mono sound files are the
result. To place these newly mixed sound files on
tracks, select the destination tracks (you must set an
insertion point or range across two tracks) and choose
any Paste or Insert command. For some applicable
hints, see Bounce All to Mono Clipboard above.

Bouncing to the Clipboard is very useful for creating
submixes internal to your Deck session. Bounce tracks
when you are attempting to collapse multiple tracks to
make room for new tracks (for overdubbing pur-
poses). If you are done with your Deck session, and
you want to create a master mix file on your hard disk,
see the Mix to Disk command below.

Mix to Disk (Option-Command-M)—Creates a
mono or stereo Sound Designer II, AIFF, Sound
Resource (.SND), Wave (.WAV), or QuickTime sound
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file that exactly reflects the way the session sounds
when it plays back. (There is one exception to this
rule—see the following explanation of Virtual Mix.) All
level and pan settings, automation and real-time
effects are included in the mix. For more information
about creating a final master, see “Final mastering to a
mono or stereo disk file” on page 73.

It is usually better to use the Mix to Disk command to
create your audio master file instead of mastering
directly to DAT. Mixing to a random access medium
(your hard drive), guarantees that your final mix file
will be an exact copy of your session data. You can
then back this copy up to streaming tape, optical disk
or DAT data backup for optimum results. DAT audio
recorders are sequential recorders, and they use error
correction schemes to compensate for data integrity
problems. Unlike a hard drive, a DAT recorder doesn’t
verify that your data is undamaged, and it cannot
rewind and retrieve data if it encounters a data
transmission problem.

Virtual Mix—Controls which tracks Deck will mix
when you choose the Bounce or Mix to Disk com-
mands. When this command is off, Deck will mix only
the active play tracks. This will create a mix that
sounds exactly the same as when you play the session.
However, when the Virtual Mix command is on, Deck
will also mix whatever is on the work tracks, both
audio and automation data.

Mix Regions As Files (Shift-Command-M)—Mixes
selected regions to a separate sound file. Use this to
export regions from a session as a separate sound file.
When you select Mix Regions As Files, the following
dialog box will appear:

[ # Deck Session U1 C audi... i] = 9688 HD

| Eject

Desktop
New Folder

concer

[ open

[ ]

Mix regions to: H Deck Session Ul C audio files ]|

Format: | Sound Designer 11 i]
Sample Rate: [44188.888
Bit Depth: |16
Number of Channels: [ Stereo

Bit Depth Conu: [Dithering

[o)lo Lo

Use this dialog box to select the format, sample rate,
number of channels, bit depth conversion (if mixing
down to 8-bit) and destination for your new sound
files.

Fade Selection (Command-F)—Generates a fade in,
fade out, or crossfade over the selected range using
the default fade curves, but not the fade times (as set
with the Process > Set Default Fade command). If the
selected range crosses only the beginning or end of a
region, a fade in is generated. If the selected range
crosses the border between two regions, a crossfade is
generated. For more information about creating fades,
see “Constructive fades and crossfades” on page 40.

Crossfades require that there is waveform data on your
hard disk after the end of region 1 (the fade out area)
and before the beginning of region 2 (the fade in
area). If you have no data in these areas of the source
sound file, Deck will warn you, but it will allow you to
attempt to build the crossfade using whatever data is
available.

Set Default Fade—Sets the default fade curves and
default fade times. The default fade times only apply to
instances when you are fading and/or crossfading
multiple regions. These default fade times allow you to
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select hundreds of regions and region boundaries, and
execute fades on all regions at once. Use the Custom
Fade command if you want to manually enter precise
fade times.

Crossfade Dut Shapes: Before Splice:

R NN

Crossfade In Shapes:
s
h‘(‘/'/‘_J‘J‘ After Splice:

[ Cancel ]

(ox_J

Set Fade dialog

Default Fade (Command-H)—Executes fades in,
fades out, and crossfades on all of the waveform
regions and region boundaries that are selected. The
fades and crossfades are all created using the fade
curves and fade times set in the Set Default Fade
dialog box. The default fade times are used, regardless
of the selected range.

If you select a single region in Object mode and
choose the Default Fade command, the default fade in
and fade out will both be executed on the region.

Custom Fade (Command-G)—Generates a fade in,
fade out, or crossfade over the selected range,
allowing you to specify fade shapes and fade times. If
the selected range crosses only the beginning or end
of a region, a fade in is generated. If the selected range
crosses the border between two regions, a crossfade is
generated. For more information about creating fades,
see “Constructive fades and crossfades” on page 40.

You should use the Custom Fade dialog box any time
you are creating a specialized fade or crossfade, and
you don’t want to use your selected default shapes.

Fade In Shapes:

[ 1~

Fade Length:

AR [rea s

[ Cancel ] ” 0K ]|

Fade In dialog

If you are using the Custom Fade command to create a
fade in or a fade out, you will only see one set of fade
shape icons.

Crossfades are created in memory, so if Deck tells you
that there is not enough memory to generate a fade,
you can increase the size of Deck’s memory partition
(using the Finder’s Get Info command), and try the
fade again. If you are having trouble generating
extremely long fades or crossfades due to memory
limitations, try using Deck’s volume automation
envelopes. These require no extra RAM, and can
generate 24-bit fades of any length.

Delete Fade—Deletes any existing fade or crossfade
from the selected range.

Rebuild Fades—Rebuilds all crossfades in your
current session.

Destructive Effects

The Destructive Effects submenu contains all of Deck’s
destructive audio effects. In order to use these
functions, you will need to select one or more regions
in Object mode or select a range in Range mode. For
more information about the available effects, see
Chapter 5, “Effects.”

External Effects

The External Effects submenu lists installed Premiere
format plug-ins within the Deck Plug-Ins folder. To use
external processing a region must be selected in
Object mode.

Region Info (Command-M)—Shows you informa-
tion about a selected region. You must select the
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region in Object mode. When you choose the Region
Info command, the following dialog box appears:

Region Information

Name:IPurdie mix.L I

File: 9688 HD:Session U1l C:Deck Session U1l C audio
files:Purdie mix.L

Hr Min Sec Fr
start:[@ |[e |[e (8 |[_capture start |

End: 8 3 43 19

Dur: A 3 43 19

[ Show File | [ Launch Editor | [ Audition | [ Loop Audition

|

Region Information dialog

The dialog box shows you the region’s name, followed
by the associated audio file’s location on your hard
drive. You may rename regions in this dialog box.
Below the file location, the region’s start, end, and
duration times appear. You may change the start time
of the selected region by typing the new time in the
start time fields. If you click the Capture Start button,
the new start time will be the current SMPTE time.

Clicking the Show File button will switch Deck to the
background, and highlight the audio file associated
with the region on the desktop. The Launch Editor
button will switch Deck to the background, and then
open your chosen sound editing program along with
the audio file associated with the selected region. The
selected region will be highlighted in the sound
editing program. The Audition button will play the
selected region. (If you have the Loop Audition box
checked, clicking the Audition button will loop the
selected region.)

Double-clicking on any region in the Tracks window
while in Object mode will open up the Region Info
window for that region.

Audition submenu

Audition Selection (Command-T or Shift-
Spacebar)—The Audition Selection command

plays back only the selected range or regions (in
mono), automatically muting all unselected audio.
You can use this command to listen to specific
portions of your session to evaluate them for
editing or arrangement purposes. Remember,
Audition can be used on one or more tracks at the
same time, and also works on virtual tracks.

Audition End of Selection—This command allows
you to audition the last two seconds of a selected
region or range. This can be useful for auditioning
the end of a long region.

Audition Pre-Post Selection—This command
allows you to audition portions of the audio both
before and after the selected range or region.

A Don’t forget about the Loop Audition setting in
the General preferences (on the File menu’s
Preferences submenu). When this option is
turned on, the selected range or regions always
loop automatically when auditioned using any
of the three Audition methods. This is an
excellent way to test out loops for composition
or ambience-building purposes.

Launch Editor (Command-E)—Opens the sound
editing program you selected using the Set button in
the General preferences dialog box. If you have a
region selected, the sound file that contains that
region will be opened and the region will be selected
automatically in the sound editing program. This
function is intended primarily for users of Sound
Designer IT who wish to access some of that program’s
two-track destructive signal processing. It will work
with other programs, although some audio editing
programs do not support regions. For more informa-
tion, see “Using an external editor” on page 48.

Automation Thin—Use this command to delete
extraneous automation data. If you are using the Mixer
window or an external device to record automation
events, many more break points appear than if you
click in the Tracks window to add automation events.
You will find it easier to edit automation data you have
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recorded after using this command. First select either
volume or pan from the Automation View pop-up of
the track you wish to edit (you must be in the Tracks
window). Select the data you wish to edit, then choose
the Automation Thin command. Deck will find straight
lines in the data and delete the intervening envelopes.
This is a non-destructive process which you may undo.

Strip Silence—This command functions like a non-
destructive gate. When you have audio selected in the
Tracks window, the Strip Silence command will auto-
create regions from a selected range by non-destruc-
tively deleting silent areas based on parameters you
choose in the following dialog box:

Gate Parameters

588 noise threshold

128 frame size (samples)

release size (samples)

[I]efault Ualues] [ Cancel ] H 0K ]l

Strip Silence dialog

Audio that is at a level above the specified Noise
Threshold will appear in new regions. Areas of audio
below the Noise Threshold for a duration equal to the
Frame Size will be non-destructively deleted. The
Noise Threshold can be any number between 0 (no
volume) and 1023 (full volume). The Frame Size
indicates the number of samples in each “window”
Deck uses to calculate whether audio is signal or
noise. If you choose too small a frame size, you may
end up with more regions than you desire. The
Release Size tells Deck how many samples to include
at the beginning and end of audio it has determined to
be signal. The Release Size ensures that the beginning
and end signal are included in each new region. Both
Frame Size and Release Size are in samples, to allow
highly accurate editing.

Options menu

The Options menu contains all of the commands you
will need to configure MIDI input and output,
configure SMPTE setup, enable basic automation
recording and playback, and manipulate general
features of the Tracks window display.

MIDI Setup—Deck requires that you install Open
Music System (OMS)—available for free from
www.opcode.com—in order to use MIDI with Deck.
Generally, you should configure Deck OMS compat-
ibility to accept Only OMS Applications, and you
should avoid Apple’s MIDI Manager. If you are running
the Metro sequencer on your Macintosh in sync with
Deck, make sure to set OMS to allow Only OMS
Applications. This will improve the speed and
smoothness of the switch between the two programs
during playback.

The SMPTE Format submenu—Use this submenu to
select the SMPTE format you wish to receive and send
when Deck is synchronizing to SMPTE. (Deck attempts
to determine incoming time code format automati-
cally, but you should always set it anyway to prevent
time base problems.) You may choose between any of
the following formats: 24 Frame (film), 25 Frame (PAL/
SECAM video), 29.97 Frame (NTSC color video), 29.97
Drop-frame (NTSC wall clock color video), 30 Frame,
and 30 Drop-frame.

24 frame is used for most film applications; 25 frame is
for PAL/SECAM video; 29.97 is for NTSC color video;
29.97 drop is for wall-clock accurate broadcast NTSC
color video; and 30 frame/30-drop frame are misno-
mer formats that were originally used for black and
white video, but are now generally used only for time
stamping synchronization in audio-only applications
(and, cleverly, for various film-to-tape pulldown/pullup
conversions).
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If you are working in NTSC video, and someone sends
you a video tape striped with 30 frame code on the
address track, you can safely assume that the time
code is actually 29.97 frame time base. This mix up is a
leftover from the early days of time code.

SMPTE Start Time—Offsets the Master Counter by a
specific number of SMPTE frames. You can think of
this time as the current session’s zero time. If you then
set Deck to synchronize playback, the session will
begin to play when the SMPTE Start Time frame is
received. For more information, see Chapter 8, “MIDI
and Synchronization.”

You can also use the Capture button in the SMPTE
Start Time dialog box to lift the current SMPTE frame
from tape directly into the dialog box. Remember,
however, that capture functions are often not accurate
if you are using longitudinal time code (LTC), because
this timecode cannot be read at slow shuttle speeds.

If you are using vertical interval time code (VITC), the
capture button will always lift the correct SMPTE frame
address, even when your video deck is crawling or on
a still-frame.

SMPTE Online (Command-J)—This command puts
the current session online, which means it is ready to
synchronize to incoming SMPTE time code. To lock
playback to incoming code, just select this command
and click the Play button in Deck’s Transport window.
This puts Deck in standby mode. As soon as time code
is detected, Deck will begin to play back at the correct
frame.

Remember, you will need a tape source with SMPTE
time code on one track, and a SMPTE-to-MIDI time
code converter/Macintosh MIDI interface in order to
synchronize to SMPTE. (Mark of the Unicorn’s MIDI
TimePiece or Opcode’s Studio 5, are examples MIDI
interfaces with SMPTE-to-MTC capabilities.) For more
information, see Chapter 8, “MIDI and Synchroniza-
tion.”

To record audio while online, just record-enable a
track, select the SMPTE Online command, and press
Record and Play buttons in Deck’s Transport window.
This puts Deck in record-standby mode. As soon as
time code is detected, Deck will begin recording, and
DECK will automatically place the recorded audio at
the correct time.

Timecode Source—Sets the timecode source. If you
have a Korg 1212 1/0 card, use the DECK II 1212 1/O
Driver, and select Soundlink DRS.

Trigger Sync—Deck offers two types of synchroniza-
tion. Deck’s native mode is called “continuous resync,”
and is generally the more desirable of the two modes.
When Trigger Sync is turned off, Deck is in continuous
resync mode. In this mode, Deck watches all incoming
SMPTE frames to determine if the speed of your
source playback unit is correct. When Deck deter-
mines that the SMPTE playback source is slowing
down or speeding up, Deck will alter the playback
sample rate in real-time in order to compensate for the
speed changes. When this happens, you may hear
Deck audio playback slow down or speed up.
Continuous resync mode guarantees that your
session’s digital audio will remain tightly synced to the
SMPTE source.

When Trigger Sync is turned on, the session’s playback
sample rate will not be altered during playback. Deck
will still sync to the incoming SMPTE frame, and chase/
lock correctly, but no playback speed adjustments will
be made. Trigger Sync is designed specifically for users
who know that their SMPTE source is absolutely time-
locked. For video professionals, use Trigger Sync if
you run your SMPTE source video deck with house
sync (a black burst hooked to a video input). For
audio professionals, use Trigger Sync if you run digital
multitracks, or timecoded DAT as your SMPTE source,
or if you have a multitrack audio recorder that is
hooked to house sync.

Real-time sample rate conversion can degrade the
general quality of the audio that is played back. For
this reason, the best results are achieved when you
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run Deck with Trigger Sync turned on, and your
SMPTE source locked to house sync.

Pulldown—Changes the current session’s master
playback sample rate. When you choose this com-
mand, the following dialog box appears:

Session Playback Rate Settings

Session Nominal Rate: 44100 Hz
=

[Pull—dwn] [ Reset ]

Playback rate:
[ Use hardware rate

[ Pull-up ]

[ cancet | [ ok |

Session Playback Rate Settings dialog

The Session Nominal Rate is the playback rate you
chose when you created your session. You may change
the Playback Rate by typing a new value in this field.
Increases in sample rate raise pitch and decrease
session duration. Decreases in sample rate decrease
pitch and increase session duration.

The Pull-down button automatically lowers the
Playback Rate to a rate useful when editing audio to
video transfers of film when you intend to go back to
film (mag or other) for the final result. The Reset
button changes the Playback Rate to the Session
Nominal Rate. The Pull-up button automatically raises
the Playback Rate to a useful rate for laying back your
edited audio to mag film (or to DAT for transfer to
mag film). This is a very specialized command useful in
NTSC countries, and here is an oversimplified
explanation of the scenarios in which you might use it.

If you are rebuilding audio tracks to video telecine
transfers of film by going back to the original location
Nagra 1/4-inch tapes, digitize all audio from the 1/4-
inch tapes at the 44.1 or 48 kHz rate. Then set the
sample rate to Pulldown, and edit the sound to
picture. When laying back the finished audio to DAT
for transfer to mag (or direct to mag), Reset the
pulldown rate. This will yield results that are time-

correct for film, and is the preferred method for
preserving audio quality.

If you have built audio tracks to video telecine
transfers of film using audio files and effects from your
sound libraries or hard disk (which are not location
sound), then you can edit all audio tapes at the
44.1kHz or 48kHz rate. When laying back the finished
audio to DAT for transfer to mag (or direct to mag),
choose the Pull-up option in the Pulldown dialog box.
This will yield results that are time-correct for film.

You can also use the Pulldown command to stretch or
squeeze audio. For instance, if you need to fill a 30-
second spot, but only have 24 seconds of audio, and
your Session Nominal Rate is 44100 Hz, you can use
the following equation to stretch the 24 seconds into
thirty: (24+ 30) = (X+ 44100). Thus if you enter
35280 (X) into the Playback Rate, Deck will stretch
your audio to the desired length. Be warned, however,
radical sample rate adjustments will not sound very
good.

Output MIDI Timecode—This command allows you
to use Deck as a MIDI Timecode master. When you
select Output MIDI Timecode, a check mark will
appear next to it, and Deck will automatically generate
Timecode and send it through the Timecode Output
Port you chose in the MIDI preferences. To stop
sending Timecode, choose the command again to un-
check it. If the command is checked, Deck is sending
Timecode.

Automation submenu

Conform To Audio Edits—Enables a function that
adjusts automation envelopes when edits are
made to the regions that contain them. If you have
an automated track, and you edit a portion of it,
the automation on that track will adjust itself
accordingly.

Mute All—Mutes volume and pan automation
playback on all tracks.

Play All—Sets volume and pan automation on all
tracks to play.
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Record All—Enables volume and pan automation
recording on all tracks.

Erase All—Erases all recorded and drawn volume
and pan automation.

For more information about recording and editing
automation, see Chapter 4, “Visual Waveform Editing,”
and Chapter 6, “Automation, Mixing, and Mastering.”

MIDI Map Faders—This command allows you to map
any MIDI controller (a MIDI keyboard, or JL Cooper
FaderMaster, for example) directly to Deck Mixer
window volume and pan faders and Transport window
controls. This mapping process is quite simple, and
requires no text entry.

To map a Deck Mixer window or effect window fader
to an external controller, just choose the MIDI Map
Faders command. All of your faders will highlight
green, to show you they are ready for mapping. Next,
click the fader or faders you wish to control, which will
turn yellow to indicate they are ready for MIDI input.
Now move the hardware controller that should control
the selected yellow faders. (Your MIDI fader, or
keyboard’s modulation wheel, for example.) These
faders turn red to indicate they are mapped. To begin
moving the faders from an external controller, just
choose the MIDI Map Faders command to exit MIDI
map mode.

To map the Transport window controls to MIDI note-
on events, choose the MIDI map faders command.
Transport window buttons (just like mixer and effect
faders) will turn green, indicating that they are ready
for mapping. Next, click the button(s) you wish to
control, which will turn yellow to indicate they are
ready for mapping. Now generate a MIDI note-on
event from you hardware controller (for example,
press a key on your MIDI keyboard). Selected buttons
will turn red to indicate that they are now mapped. To
begin operating the Transport window controls from
your external MIDI controller, just choose the MIDI
map faders command again to exit MIDI map mode.

You cannot use this function unless you have an OMS-

compatible MIDI interface and a MIDI controller of
some kind. Note that Deck does not directly support
the JL Cooper CS-10, however Deck does directly
support the Tascam US-428.

Mute MIDI Map—This command temporarily stops
your external controllers from moving Deck faders in
the Mixer window. It only functions if you have already
mapped external controllers to faders using the MIDI
Map Faders command. To turn external control back
on, just choose the Mute MIDI Map command again.

Edit MIDI Map—Use this box to assign MIDI fader
numbers, channel numbers and note-on numbers to
specific functions, such as pan, volume and transport
control. When you select Edit MIDI Map, a dialog box
will appear. Now select the function you wish to assign
a MIDI fader to, and click OK. The Edit Map Element
dialog box appears. Use this dialog box to edit the
MIDI channel and MIDI number for any MIDI map-
able function.

State Transition Time—The State Transition Time
command allows you to select a fixed automation fade
time that will automatically be used whenever you
record or play mixer automation using Deck’s Mixer
States (accessed from the Transport window). When
you choose the State Transition Time command, this
dialog box appears:

[ cancel | [ ok |

The appearance of this dialog box will vary, depending
on your current Axis units selection.

Use this dialog box to enter the duration of the fade
you wish to occur between the time you click a Mixer
State arrow, and the moment that the new mixer state
arrives on the screen. Deck automatically fades to the
new mixer state over this duration. Remember, these
fades are recorded if you are recording automation.
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Selection Tools submenu

Position at Beginning (Command-| }—Scrolls the
Tracks window to show you the beginning of the
currently selected range or region. This is a very
useful command when you are zoomed in very
close, and you want to adjust region start time(s)
without zooming out to find the region beginning.

Position at End (Command-])—Scrolls the Tracks
window to show you the end of the currently
selected range or region. This is a very useful
command when you are zoomed in very close, and
you want to adjust region end time(s) without
zooming out to find the region end.

Position to Fit (Command-, )—Performs the same
function as the Fit Selection icon. It automatically
expands or contracts the display so that the
current selection fills the screen. This is true
whether the selection is a region or a waveform
range. This command makes it possible to view
rapidly any specific audio range, region, transition
or event.

Set Punch Time From (Command-\)—Moves the
start time of the current Tracks window selection
to the begin counter and the end time of the
current Tracks window selection to the end
counter in the Deck Transport window. Use this
command when you want to select a waveform
range or region for sample-accurate punch-in
recording or loop mode playback.

Any time you have a waveform range or region
selected, you can press the C key on your
Macintosh keyboard to set a cue loop automati-
cally. This automatically transfers the range or
region's begin and end times to the Transport
window and turns on Loop mode. Option-C turns
off loop mode.

Set from Punch Time (Command-/)—Performs a
function that is the inverse of the Set Punch Time
from command. It automatically reads the start
time and end times from the Transport window
and selects that range in the Tracks window. The
range is selected on any track that currently has a

selected range or insertion point. Remember, you
can move and expand the selection using the
Macintosh keyboard'’s arrow keys and Shift-arrow
keys, respectively.

Set Selection—Enables you to select a range by
specifying start and end times. The range is
selected on any track that currently has a selected
range or insertion point. Remember, you can
move and expand the selection using the
Macintosh keyboard'’s arrow keys and Shift-arrow
keys, respectively.

Make Markers From—Makes markers for the
current selection. For example, if you have a
region selected in the Tracks window, Make
Markers From will automatically create markers at
the beginning and end of that region. Markers also
show up in the location times pop-ups in the
Transport window.

Send to Slave (Command-=)—Sends the current
selection to the slave program. For example, if you
have a one bar region selected at Bar 37 in Deck,
select this command and switch to the slave
program, the slave will also be at Bar 37.

Snap to Grid—When this command is checked, it
turns Deck’s Tracks window grid on and off. When the
grid is on, all range selections and range and region
dragging will be constrained (stick to) the Tracks
window grid. Deck’s Tracks window grid is a smart
grid, in that it always adjusts to match the current
units. If you are viewing waveforms by SMPTE frame,
the grid will snap edits to frame. If you are viewing
waveforms by quarter note, the grid will snap edits to
quarter note. To turn off the grid, select this command
a second time. Remember, the Macintosh keyboard’s
arrow key edits (as well as Shift-arrow, Command-
arrow, and so on) all conform to the grid when the
grid is on.

You can also turn the grid on and off using the Grid
button, located to the left of the Axis Units pop-up in
the Tracks window.
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Set Grid Interval—It is possible to manipulate the
display resolution to a variety of different levels. If the
Axis Resolution pop-up to the right of the Axis Units
pop-up in the Tracks window does not offer you the
grid units you desire, you may choose your own
display resolution using the Set Grid Interval
command.

The appearance of this dialog box will vary, depending
on your current Axis units selection.

Enter the grid interval you desire. You may use the
current SMPTE time by pressing the capture button.

Set Nudge Time—When you use Command-arrow
keys on a selected object or range in the Tracks
window, Deck physically moves the selected object or
range left one unit, right one unit, up one track or
down one track.

The appearance of this dialog box will vary, depending
on your current Axis units selection.

Enter the nudge time you desire. You may use the
current SMPTE time by pressing the capture button.

Time Mode—Deck’s Time Mode submenu duplicates
the function of the Axis units pop-up in the Tracks
window. Use this to set the Axis Units (second, SMPTE,
sample or beat) that will be used by Deck’s grid, Time
Axis, and Tracks window editing functions.

Scroll During Playback—This feature allows you to
turn on or off real-time scrolling in the Tracks window.
When this function is enabled, (signified by a check
mark next to its name in the Options menu) the
Tracks window will continuously update—or scroll—
during playback, so the regions currently being played
will always be seen on-screen.

Hardware Configuration dialog

Hardware Configuration—Enables you to choose
and configure your audio card, or to select the built-in
audio hardware of you Macintosh.

Do not change your hardware configuration with a
track or tracks record enabled in the Mixer or Tracks
window.

These options are only available if you have an audio
card installed.

Hardware Configuration

Ch. 1 &2 Input Type:
DicitcdFormatt:  S/PDIF $

[ Mic Input On

ASI0 Configuration:
[ Record monitoring
Clock Source:

[ Play audio while in background

(emee) o<

Sync Mode—Set this menu to Digital if you are
recording digitally via the S/PDIF or AES/EBU
digital inputs on your audio card. Otherwise set
this to Internal.

Input Type—Set this menu to Digital if you wish to
record from the S/PDIF or AES/EBU digital inputs
on your audio card. Remember, when you do this,
Deck’s inputs 1 and 2 will be taken from your
digital inputs. When you are doing analog
recording, set this to Analog.

Digital Format—Use this menu to choose your
digital input/output format.

Mic Input On—This check box is only available
when if you have an original Audiomedia card.
That card has a built-in microphone preamp
instead of digital input and output. When you turn
this check box on, your original Audiomedia card
will automatically mix its microphone input into
inputs 1 and 2.

Play audio while in background—enables the
selected ASIO driver to operate in the background
while Deck is in the background. If you are
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running more than one audio application using
the same ASIO driver (e.g., BIAS Peak), you will
want to disable Play audio while in background.

Record monitoring—allows you to monitor the
audio input in the digital domain while you are
recording.

Analog Input Level submenu (Command-Option-
0/7)—If you own a Pro Tools 1/442 or Sound Tools IT
system, this submenu is not available to you. All other
hardware systems allow you to set the input level of
the incoming signal. Use this submenu to adjust the
input level for recording. Make sure that you watch
the input VU meters on your Mixer window record
track as you adjust this level, and attempt to set the
input recording level as high as possible (without
clipping). If the level is too high, the clip light will turn
on. You will generally want to set the value to 0 and
adjust the level of the signal coming into your
Macintosh. Note that there is a keyboard command
shortcut: press the Option and Command keys, plus a
number from 0 to 7, to quickly set input level. For
more information about setting the Analog Input Level
for different platforms, see Chapter 3, “Getting
Started”.

Session menu

This menu contains commands that affect the entire
session.

Session Info (Command-I)—Tells you how much
free RAM you have, how much free disk space there is
on the drive that contains the session, and lists the
session’s sample rate and total number of free
automation events. Below this basic information, you
will find a list of all the sound files used in the current
session. You can use this list to track down a file by
selecting that file and clicking on the Show button, or
simply double-clicking on the file name, under the
“Files in session” display. This will automatically switch
you to the Finder, open the folder that contains the

file, and select that file. To hear a sound file, click the
Play button. To give your sound file a new name, click
the Rename button, and enter the new name into the
Rename dialog box. If you wish to delete a sound file,
click the Delete button.

When you want to rename audio files, make sure to
use the Session Info dialog box’s rename button.
Simply renaming the file in the Finder will force you to
re-find the file the next time you reopen the session.
Do not switch out of a session and rename a file while
the session is still open. This can cause unpredictable,
possibly disastrous, results.

Session End Time (Shift-Command-E)—Changes
the end time for your session. This command is useful
when the “Autostop at end of Session” preference is
turned on. Instead of stopping when the last sample of
your session is detected, Deck will stop at the new end
time you enter here.

Compact Session—Compacts all of the audio files in
the session’s Audio Files folder which are used in the
current session. Use this command to get rid of
unused audio data in all sound files associated with
the session. For more information about compacting a
session, see “Using Compact Session and Compact
Audio Files” on page 61

Export Session Regions—Saves all regions defined
in the current session into their source sound files.
When you install Deck, the program is set to save all
regions to their source sound files whenever you save
the current session. This is a good basic configuration,
because it assures you that your regions will always be
saved. You may also choose at any time to save the
regions out to their sound files, even though the
session has not been saved. That is the purpose of the
Export Session Regions command. You might do this,
for example, if you have defined an interesting region
of audio, but you don’t wish to keep it in the current
session. In such a case you can use the Export Session
Regions command to save the region, and then delete
the region from the session. Even though the region is
not present in the session, you will find that it has
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been saved into its source sound file.

Read DECK 1.0 Session—Reads a session that has
been created in DECK 1.0 or later and translate it into
a Deck session.

Import Session—Imports an existing session into the
current session. The imported session will be placed
into new work tracks.

Library Operations submenu

Sort By Name and Sort By Size—Sorts all regions
in the Library window by name or by size,
respectively.

Update from Session—The Library window will
only display regions that are in the Tracks window.
If you would like new regions you have created to
appear in the Library window, choose the Update
from Session command.

Find File—This command is available when you have
a region selected in the Library window. It
automatically switches you out to the Finder and
highlights the audio file that contains the selected
region.

Select Regions—When you select a region in the
Library and then choose Select Regions, all
instances of that region will be selected, or
highlighted.

Windows menu

This menu contains a list of the windows that are
available in Deck. Choose the name of a window to
open that window or bring that window to the front.

Window Shortcut
Transport window Command-1
Mixer window Command-2
Tracks window Command-3

QuickTime window Command-4

MIDI window Command-5
Library window Command-6
Effect window Command-7
Master Outputs window Command-9
CPU Meter window Command-0

Close Window (Command-W)—Closes the currently
active window.

Links menu

The Links menu provides useful and informative links
to BIAS’ Web site, including Product Registration, the
BIAS Home Page, Deck Updates, Deck Tech Support,
and Online Documentation.

QuickTime menu

This menu contains all of the commands you will need
to open, close, edit and export (mixdown) QuickTime
movies in Deck, as well as configure live video. For
more information about using QuickTime movies,
including descriptions of the QuickTime menu
commands, see Chapter 7, “QuickTime.”

QuickTime Shortcuts:

Left/right arrow ~ Moves QT movie backwards/
forwards by a single frame
Moves to beginning/end of QT
region

Click-drag window ~ Scrubs through QT movie

Up/down arrow

Help menu

The Help menu allows you to enable the standard
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Macintosh Balloon Help.

Conclusion

You now know all the details of every Deck window
and menu item. The final chapter presents an
introduction to the basics of digital audio recording.
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Chapter 10
Digital Recording and Mixing Basics
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Chapter 10:
Digital Recording and
Mixing Basics

Although Deck uses complex technologies to
accomplish its recording, editing, and mixing tasks, it
is based on two familiar pieces of equipment: the tape
deck and the multichannel mixing board. Deck uses
your hard disk as the multichannel tape deck, and
your Macintosh screen as the mixing board and editing
table. Anyone who has used a multitrack tape recorder
will find the look of Deck very familiar. Since Deck
builds on the tape deck metaphor, a basic understand-
ing of multitrack recording concepts is essential for
you to get the most out of the program. Also, since
digital representations of waveforms are used to
represent sound, familiarity with audio sampling is
very helpful. At the end of this chapter is a reading list
of excellent books on audio, computer music, MIDI,
and the music business.

Basic Sampling Concepts

Deck accomplishes its direct-to-disk recording tasks
using a method called sampling. Unlike normal
magnetic tape recording, which records an audio
signal as a continuous charge on magnetic tape, a
sampler converts an audio signal to discrete numbers
which are then stored on a digital storage medium (a
hard drive, for example).

Digital sampling of audio tracks is generally superior
to the standard analog recording methods—not only
because it offers extremely high fidelity, but because it
avoids the standard tape generation and playback
degradation problems. Because sampled audio is
stored as a set of numbers, there is no loss of fidelity
when you copy those numbers, regardless of how

many “copies of copies” you make. Also, because the
disk medium is not physically strained by playback (as
is a reel of analog tape when it is pulled across the
playback heads), repeated playback of a digital track
will not alter or degrade that track in any way.

The process of digital recording (or sampling) is really
quite simple: an audio signal is fed into a computer (or
dedicated sampling device). That signal is run through
an analog-to-digital converter (ADC), which measures
the amplitude (volume) of the signal at regular
intervals and passes these measurements, or samples,
on to a storage medium. When the recorded track or
tracks need to be played back, the samples are
retrieved from the storage medium and run through a
digital-to-analog converter (DAC,) which converts
those samples back into a continuous wave. The signal
that comes out of the DAC is the output signal, and it
is a nearly exact image of the signal that was fed into
the ADC.

Taking samples of a soundwave

= = one sample

Amplitude

Time
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As you can see, the incoming audio wave is approxi-
mated by a series of discrete points that describe that
wave. The physical representation of this wave is called
a waveform. The nature of this process illustrates one
of the central questions of digital recording: How
accurate is the digital representation of the original
analog signal? To determine this you will need to
understand the concept of sample rate.

Sample rate is the number of samples of a waveform
that you take in a single second, and it has a very
strong influence upon the quality of the recording you
make. At best, a collection of samples is an extremely
good approximation of the original input signal. By
taking many samples of an audio signal, you end up
with a more accurate depiction of the wave; fewer
samples yield a less accurate, grainy depiction.

Why sample rate affects fidelity
f(“"‘\ « = one sample
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Notice how a higher sample rate yields a more
accurate, and therefore higher-fidelity recording.
Unfortunately, each sample requires storage space.
Since a higher sample rate takes more samples per
second, it will require more disk storage space for
each second of audio than a lower rate. Deck uses set
sample rates of 22,050Hz, 24,000Hz, 44,100Hz or
48,000Hz. (Note that additional hardware is needed to
get a 48kHz rate on a Macintosh.) A sample rate of
44,100 Hz means Deck takes 44,100 samples every
second and puts them on your hard disk. This is the
same rate used by compact discs, and it allows you to
record frequencies up to 22,050Hz accurately. Since
normal human hearing arguably ranges from 20Hz to
20,000Hz, the sample rate of 44.1kHz generally offers
acceptable fidelity. Deck also offers a sample rate of
48,000Hz, which is the basic rate used by many digital

audio tape (DAT) recorders. This higher sample rate
actually allows you to record frequencies up to 24,000
Hz, but since these frequencies are theoretically
outside the audible range for most humans, it is
generally unnecessary to use this higher rate for
fidelity purposes.

MIDI overview

Music and sound on the personal computer has
changed radically over the last ten years. Most people
in the audio industry are very aware of these changes,
particularly due to the development of the MIDI
standard in the early eighties. MIDI, which stands for
Musical Instrument Digital Interface, became the
accepted communications standard for electronic
musical instruments, and it can now be found on
virtually every electronic keyboard, drum machine,
trigger device, tone generator and effects unit.

MIDI was originally conceived as a remote control
standard that would allow musicians to control
multiple instruments from a single keyboard, but it
rapidly developed into an audio network environment.
The creation of MIDI sequencers is largely responsible
for the importance that the MIDI standard holds
today.

By offering an inexpensive way to record and play back
multiple-track compositions without a tape deck, MIDI
sequencers opened the door to accessible computer
music technology. However, MIDI sequencers do not
accomplish this feat by recording an actual audio
signal. You can think of a MIDI sequence as a player
piano roll. The MIDI sequencer records events that
occur at your keyboard: what key you pressed, how
hard you pressed it, how hard you were holding it
down, and when you let go. These little pieces of
information, called MIDI events, are picked up and
remembered by the sequencer as a sequence. To play
the sequence, the sequencer sends the recorded
events back to the keyboard, essentially playing the
keyboard every time the sequence is played back.
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Sequencing offers some new possibilities. For
example, you can change the sound that is on a certain
track by loading a different sound onto the keyboard.
The sequencer is just playing notes, and it pays no
attention to what sound it is playing. You can also
change the tempo of a recorded MIDI sequence
without changing the pitch of the notes (unlike tape,
which changes pitch when playback speed is
changed).

But the concept of MIDI has some inherent weak-
nesses. For example, how do you record a guitar track,
or a vocal track, or a sax? These entities are purely
audio signals; they have no natural place in the MIDI
world. This is where Deck comes in. Although Deck is
a full-functioned digital multitrack recorder, it both
supports and augments MIDI. By running the Metro
sequencer (or any other supported sequencer), on
your Macintosh along with Deck, you can add fully
synchronized MIDI functionality to any audio session.
If you have an existing MIDI sequence, you can import
it directly into Deck’s MIDI window and record
multiple audio tracks over it without running an
external sequencer. If you wish to save disk space, you
can use Metro to add MIDI tracks to your Deck
multitrack audio recordings. Deck and Metro provide
an environment where full-functioned MIDI and
synchronized digital audio coexist.

Digital multitracking and the mixing
board metaphor

The Deck interface looks like a simple mixer with
some additional controls and surfaces. If you have
used a portable multitrack device, then you should
find recording and mixing with Deck very intuitive. If
you haven't, then some background may be helpful.

Take a look at this illustration of the Deck Mixer and
Transport windows:

sychotropic: Transpol

Mixer window

The mixing board consists of several vertical input/
output modules, each with VU meters that register
signal level. The input/output modules all look the
same because they each represent one of Deck’s
digital record/playback tracks. (Remember that Deck
allows you to create an unlimited number of tracks,
but only a certain number of those tracks play at one
time, depending on your hardware.) Each of the
input/output modules has two modes: record and
play. Record allows you to feed a signal into your
audio card, set its monitor level, and record it to your
hard disk. Once a track is recorded, play mode lets you
play that track back, adjust its playback levels, add real-
time effects, and automate its level or pan (placement
in the stereo field).

The buttons in the Transport window function just as
they would on a normal tape recorder. They allow you
to rewind, fast forward, play, stop, and record Deck’s
digital tracks. They also offer controls for adjusting
playback pitch and for storing location times, punch or
loop times, and mixer states.
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Recording from scratch

The production life cycle of a Deck project might
progress like this:

1. You record a first track on track 1.

2. Then you play back track 1 to make sure you like it
and set its volume level.

3. Next, you record track 2 while listening to track 1.

4. Then you play both tracks back while recording
track 3.

5. You follow this same procedure to record track 4.
(Remember, you can also record 2 or more tracks
at once, depending on your audio interface.)

6. Then you listen to and mix levels and pan on all
four tracks. If abrupt or smooth volume level or
stereo pan setting changes are required, you can
automate these changes. You may also wish to add
effects from within Deck, or by using plug-in
effects. When you are satisfied, you may choose to
mix to a master stereo file for pressing a CD or
album, or for playback from within a QuickTime
movie, or from Macromedia Director™ or Flash™,
and so on.

The process detailed above is essentially the same one
you would follow if you were using an analog
multitrack tape deck and mixing board. However,
Deck is a digital recorder, so there are some special
points you will wish to consider.

The input signal

The input signal is the audio signal that you wish to
record. It must be plugged into one of the audio
inputs on the computer, or an audio card or audio
interface box, to route it into Deck. It is often a good
idea to route incoming signals through a mixer, and
then into your computer. This allows you more

control over the incoming signal.

Macintosh audio inputs

On systems where you are using the Macintosh
computer’s built-in audio hardware, it is a good idea to
set a low input volume (Analog Input Level in Deck’s
Options menu) and increase the volume of the signal
at the source. The Macintosh computer’s built-in audio
input amplifier can add noise to an incoming signal,
and by setting the input volume lower and tracking a
louder incoming signal, you can minimize extraneous
noise.

Digital distortion

When you feed a signal into any recorder, including
Deck, you always need to adjust the input level so that
you are optimizing your dynamic range. Essentially this
means that your input signal should register as high as
possible on your input meter without turning on the
clip light. If the input level is too low, the recorded
track will be noisy. If the signal is too high, it will be
clipped.

Clipping is a situation that results when you feed a
signal to a recorder or mixer if that signal is louder or
“hotter” than the device allows. On many analog tape
decks, a little clipping seems to add warmth to the
sound—often by increasing use of the noise reduction
circuitry (Dolby™ B or C, for example). In digital
recording, clipping is to be avoided at all costs. It
causes digital distortion, which almost always sounds
like digital hash.

Automated punching in and out

Automated punching in and punching out are
extremely important concepts in multitrack recording.
To understand the need for these functions, picture
this situation: You are recording the last track of a five
minute multitrack piece. You finish the track and listen
to it playing back. During playback you realize that the
track is perfect, except for a tiny mistake near the end.

Punch in and punch out are functions designed to
cope with this problem. To fix the bad section, you
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would set a punch-in point just before it and a punch-
out point just after it. Then you would rerecord the
track. During the recording process you would hear
the original track right up to the punch-in point. At
that moment the recording deck switches to record
mode and you would play over the mistake. When the
punch-out point is reached, the recording deck
automatically switches out of record mode. This
automated punch-in and punch-out have made it
possible for you to rerecord only a small portion of a
track, without requiring that you operate the tape
transports.

Bouncing tracks and virtual mixing

One of the basic problems inherent in multitrack
recording has always been the limited number of
tracks. What do you do in a four-track environment if
you have five separate instruments to record? There
are two answers to this question.

One way to squeeze extra material into a multitrack
environment is to pre-mix incoming signals together
and record them on a single track (a vocal chorus, for
example). This method offers a high-fidelity solution,
but it has a few serious drawbacks. Specifically, the
relative level and tone of the different signals cannot
be changed independently after they are recorded.
Using the vocal example, you can’t turn up one voice
without turning up the other.

Bouncing, the other solution to the track limitation
problem, offers more flexibility but hurts the overall
fidelity of analog tracks. In an analog tape environment
you might bounce tracks like this: Record three
separate tracks and mix them with the relative level
and EQ you want and then record the three mixed
tracks to the fourth track. Since the three source
tracks now exist as a single track, you are free to
replace the originals with new tracks. In the analog
world this method increases the number of recordable
tracks, but each bounced track ends up being a
recording of a recording, and the overall fidelity
deteriorates.

Deck offers the same track mix and track bounce
capabilities you find in analog recording, but with
some major improvements. The most important
difference is that Deck bounces tracks with no loss of
fidelity. Since all Deck tracks are digital, no noise is
added during a bounce and no high frequencies are
lost. Deck also allows you to save your original digital
source tracks. This makes it possible to retrieve and re-
bounce tracks long after they would have been erased
in analog multitrack recording.

You may want to consider using Deck’s virtual mixing
feature instead of bouncing tracks. Virtual mixing is an
option that really is not available in the analog world.
Analog mixers are physically limited to the number of
tracks that can be recorded. By using a Macintosh
digital workstation, you are not hindered by that
limitation of analog recording.

Deck allows you to work with up to 999 virtual (or
work) tracks, all of which can be moved to active play
tracks, auditioned, edited, processed, or mixed. So,
while you have a limited number of tracks that can
play back at any given time (the track count of your
particular system) you can create mixes that include
virtual tracks as well. Deck does not do its mixing in
real-time, so there is no limit to the amount of audio it
can mix at one time except hard disk space. Deck
allows you to record as many tracks as you like and
mix them all together during the final mixing process.
For more information about Virtual mixing, see
“Virtual mixing” on page 72.

Audio file formats and the Deck session file

A Deck session is a Macintosh document that contains
a map of a specific recording project. This diagram
should give you a better idea of how a Deck session is
organized:

Digital Recording and Mixing Basics

149



Structure of a Deck session

' 1
Audio files (rossfades Other
folder Tolder soundfiles
[ praytst 14 “'i;’;‘: *Crossfade
soundfiles s::ndﬁu soundfiles

*Crassfade files are created and managed by Deck.
They should not be edited or altered.

A session file may contain any number of audio
regions and tracks. Each audio track contains a list of
audio regions that are located on your hard disk(s). An
audio track is a like a playback direction sheet. It tells
Deck what pieces of what audio files to play and when
to play them. Audio tracks make it possible to play any
audio file regions in any order, and they oversee this
playback in a non-destructive fashion. If you want to
repeat something ten times, the same disk region is
played ten times in a row. If you want ten minutes of
silence, no disk region is played. A Deck session is able
to play back multiple tracks simultaneously. The top
tracks (the tracks represented by the Mixer window
faders) are your active playback tracks. They contain
the tracks that will play at any one time.

A Deck session remembers all mixer states (snapshots)
and autolocation settings, and all fader settings and
window configurations. Deck sessions also remember
and reference any MIDI or QuickTime files that have
been imported into the session. When you double-
click on a session, the session’s windows appear
exactly as they were saved, and the associated audio
tracks and automation data are loaded automatically.

New audio files

When you create a new Deck session, no audio files
exist for that session. At any time you have the ability
to load existing mono or stereo Sound Designer II,
QuickTime, PC/Windows-format (WAV), Apple Sound

Resource (SND) or Audio Interchange File Format
(AIFF) audio files into the Tracks window, and to
construct from those audio files an audio track. You
can also create a new audio file by recording a new
track. Whenever you record a new track in Deck, that
track is saved in a new audio file named with the name
of the track. These audio files are placed in the Audio
Files folder (which is in the same folder as the session
document). You will always create a new audio file
every time you record onto a new track. When you
punch in on an existing track (or after the end of an
existing track) that audio is always added to end of
that track’s audio file in the session’s Audio Files
folder.

Support of different audio file formats

Deck supports Sound Designer I and II, AIFF, SND,
WAV and QuickTime audio files, but the native
playback and record format is Sound Designer II
mono. When you select and add any files that are not
in Sound Designer II mono form, Deck will automati-
cally make a Sound Designer II mono copy of those
files in the sessions Audio Files folder. If you select a
stereo file, two mono files will be created. Since non-
Sound Designer II mono files need to be converted in
this fashion, adding them to your session will require
more disk space, and may take a few moments.

If you move an audio file that is referenced by a Deck

session to a new place on the hard disk (or to another
hard disk), Deck will always prompt you to find those

missing audio files when you next open the session.

What is non-destructive recording?

Deck uses non-destructive recording technologies,
which are far more powerful than the simple linear
erase technology of analog recording (or original
DECK). It is very important to understand the concept
of non-destructive recording if you are going to get the
most out of Deck.

In the world of analog audio, there is only one kind of
recording—destructive. Whenever you record onto a
track of analog tape, the new signal permanently
replaces whatever was on that track before. If you
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record something on track 1, and then record
something else over the same time, the original
recording is erased and replaced with the new audio.
This is the nature of magnetic tape.

Because Deck runs on a computer, it offers you many
new and different options. You can think of your Deck
session document as an audio database. It keeps track
of all the audio regions you have recorded and added,
and it plays them back according to how you recorded
or placed them. Because of this, Deck is capable of
keeping track of many more sound files and audio
regions than you are using, and Deck uses this
capability to allow non-destructive recording.

Deck recording is non-destructive because the process
of recording never replaces or deletes any audio file
data. Instead, new data is always recorded and
“mapped in” to the position of the old data. If, for
example, you record a track, and then punch in a
replacement take over one bar in the middle of that
track, when the new take is recorded, it is simply
added as new data to the drive, and this new data
region appears over the old take. Because nothing was
erased, you can return to your original take at any
time. You could even record ten new takes and choose
between them later. The benefits of this scheme are
obvious; you never have to risk erasing a section of
audio just because you want to try another take or
audition another region in the same place. Because of
this scheme, you can also bounce four tracks to one
track without erasing the destination track, and you
can always go back to your original tracks and “re-
bounce” them for a new submix. These facts make
non-destructive recording one of the most powerful
features associated with digital audio workstations.

There is, however, one drawback to non-destructive
recording. Since you never delete old audio by
recording new audio over it, your hard disk will have a
tendency to fill up more quickly, especially if you are
recording multiple long takes. Deck offers you a tool
for dealing with all of this data. Its called the Compact
Session command. This command automatically looks
at the current session and finds all of the audio in your

source audio files that is not used on any track, in any
form. Then it deletes all of the unused audio.
Executing this command does not take very long, and
it will free up all of the disk space that had been
occupied by unwanted audio. The combination of
non-destructive recording and the Compact Session
command make it possible for you to make sure that
you have maximum flexibility, while consuming the
minimum hard disk space. For more information, see
“Using Compact Session and Compact Audio Files” on
page 45. Make sure you understand how Compact
Session works before you use it.

Fader automation

After you have recorded all of the tracks of a multi-
track project, you are ready to begin the mixdown
process. It is called mixdown because you will be
combining all of the monophonic tracks to create a
stereo master. You will use the stereo master to make
your final product—whether that is a compact disc,
album, cassette, DAT, 1/4-inch tape, or a disk file for
multimedia purposes.

In the typical tape-based home recording environ-
ment, final mixdown is accomplished by playing back
the multitrack source repeatedly. During each
playback pass you set levels, and practice moving the
faders to fade the audio in and out, change levels,
change send settings, etc. When you have practiced
the mix enough to feel confident, you attempt to
“perform” it as you record to a mastering deck. This is
usually a very touchy process that is both inconsistent
and inaccurate.

Professional recording studios get around this
problem by using mixing consoles that automate the
movement of all faders. Mixing boards that support
fader automation often allow the engineer to set up
board states, where the position of every fader is
recorded, and assign those states to particular times
during the recording. Some of the more advanced
automated mixing consoles even record the physical
motion of each fader and replicate that motion on
every playback run. The major drawbacks of this type
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of automation are expense and complexity. Generally
the cost of moving fader automation puts it outside
the reach of the individual.

Deck gets around these problems by offering moving
fader automation as a software entity, rather than a
piece of hardware. After you have recorded digital
tracks, you can use Deck to record any adjustment you
make to volume and pan. You can also capture fader
states for all Deck faders and assign those states to
specific times in the recording. You can view and edit
all of these control adjustments in a visual fashion.
These tools allow you to build up a mix slowly and
save that mix as one of a series of different mixes.
When it comes time to create a stereo master, you can
be assured of exactly the same level settings and fader
transitions every time.

Synchronizing sound to picture

For many people, sound editing tasks are aimed
specifically at enhancing or complementing visuals.
These tasks, typically referred to as “audio post-
production” or “sweetening,” put very specific
requirements on audio technology. Generally the
sound editor begins with finished picture, in video or
film form, and perhaps some rough guide tracks on
video tape, audio tape, or magnetic film. The post-
production process then consists of editing the
existing audio, adding new dialog, effects, ambiences
and/or music. Then the editor would automate a mix
of all sound components, and create a two-track (or
more) stereo master, which is again recorded back to
the video master or to another time-referenced master
(timecoded digital audio tape or center track 1/4-inch
tape, for example).

Deck offers all of the basic audio functions you will
need to create soundtracks, synchronize those
soundtracks to picture, automate your mix, and create
a CD-quality digital stereo master.

Deck differs from conventional analog systems in a
number of ways. Particularly important is the fact that
Deck records, bounces, processes, and mixes your
audio completely in the digital domain. This guaran-

tees you maximum editing control with little or no
added processing or generation noise. Also, since the
computer is used as the platform for control, you are
free to use the synchronization method of your
choice. This makes it possible for you to use SMPTE
time code as your sync source, or to work entirely off
your hard disk by using QuickTime video picture as
the sync source. For more information about these
methods, see Chapter 6, “QuickTime.”

Final stereo mixdown

Generally speaking, final stereo mixdown is the last
step in any multitrack production. In order to
distribute any audio project, you will need to put it
into a form that is available everywhere. That means
compact disc, CD-ROM, digital or analog cassette tape,
video tape, or vinyl. Unfortunately, of these media,
only analog cassette tapes and video tapes can be
recorded cheaply at home, and these formats generally
do not offer optimal fidelity.

In the professional recording world, the final stereo
master has traditionally been recorded on analog two-
track reel-to-reel tape. This tape is then used as the
image for duplicating albums, CDs, videos, films, or
cassettes. Although this is the status quo, quality reel-
to-reel mastering machines are quite expensive to own
or use, and a number of high-fidelity, affordable new
options are appearing.

Perhaps the most promising of the new mastering
media is digital audio tape (DAT). Coupled with Deck
and your Macintosh, DAT mastering offers a relatively
inexpensive, extremely high-fidelity solution that can
be used directly for producing CDs, albums or
cassettes. If you own an audio card that offers only
analog outputs, you can hook the analog audio
outputs of the card to the analog inputs of a DAT
recorder and create a final digital stereo master that
rivals the quality of most analog studios. Using a
timecoding DAT machine even makes it possible to
create time-referenced masters.
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Archiving suggestions

Audio is a complex phenomenon, and you need quite
a bit of data to describe it. Recording audio to your
hard disk will use a lot of disk space. For example, a
single track of 44.1kHz, 16-bit digital audio takes up
about 5MB of disk space per minute. For this reason, it
is a good idea to have some type of archiving medium
for keeping master and backup copies of your Deck
audio. In addition to your final mix stereo audio file,
you will most likely want to keep an archive of the
entire session. You can use most any means of data
backup currently available to Macintosh computers:
hard drives, removable media, tape drives, CD-R, etc.

Suggested reading

Most of the items listed here are available through Mix
Bookshelf, a unique clearinghouse for information on
recording technology and the music business. To
order any of these titles, or request a free catalog,
contact Mix Bookshelf at (800) 233-9604 (toll-free U.S.
& Canada) or (510) 653-3307.

All You Need to Know About the Music Business,
Donald Passman. Excellent coverage of record deals
and music publishing, written by a prominent music
attorney. Simon & Schuster, 1994.

The Art of Digital Audio, 2nd Ed., John Watkinson.
Thorough, detailed and authoritative reference work.
The definitive work on the subject. Focal Press, 1994.

Audio in Media, Stanley R. Alten. A classic; broad-based
college level textbook for serious self-directed study of
audio. Wadsworth Publishing Company, 1994.

Becoming a Computer Musician, Jeff Bowen. Exciting
new book/CD-ROM package gives a painless introduc-
tion to MIDI and digital audio. CD-ROM contains
software demos, music clips and more! Howard W.
Sams, 1994.

The Computer Music Turorial. This is THE book on

computer music, dsp, synthesis, MIDI, and so much
more. Curtis Rhoads, MIT Press, 1996.

Digital Audio Operations, Francis Rumsey. Intermedi-
ate-level hands-on guide to tape- and disk-based digital
recording. Focal Press, 1991.

Digital Interface Handbook, Rumsey & Watkinson.
Focuses on maintaining quality throughout the signal
chain. Comprehensive & detailed. Butterworth-
Heinemann 1993.

Electronic Musician Magazine (periodical). P.O. Box
3714, Escondido, California, 92025.

Entertainment Source Library, Greg Forest, ed. A
collection of professional music business contracts on
floppy disk. Not a replacement for qualified legal
advice, but a good starting place for protecting your
rights. Cardinal Business Media, 1992.

Getting Radio Airplay, Gary Hustwit. Learn how to get
your music played on the radio; a proven method for
any style of music. Rockpress, 1993.

Keyboard Magazine (periodical) 20085 Stevens Creek,
Cupertino, California, 95014

Making Music with Your Computer, David (Rudy)
Trubitt, ed. An entry-level look at MIDI, hard-disk
recording and multimedia; compiled from the pages of
Electronic Musician magazine. Mix Books, 1993.

Mechanics of Sound Recording, Tony Zaza. Explains
the technology and techniques of producing audio for
video and film. Prentice-Hall, 1991.

MIDI for Musicians, Craig Anderton. This classic
introduction to MIDI is the book that got us started.
Amsco, 1986.

MIDI for the Professional, Lehrman & Tully. An
advanced reference work for serious MIDI users.
Amsco, 1993.
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Mix Reference Disc, by the editors of Mix magazine.
Studio test tones on CD. Cardinal Business Media
1994.

Modular Digital Multitracks, George Petersen. Learn
how to choose, use, and troubleshoot tape-based
digital recorders including ADATs and DA-88s. The
only book on the subject. Mix Books, 1994.

The Musician's Business & Legal Guide, Mark Halloran,
ed. A comprehensive and easy-to-understand survival
manual; includes sample contracts and documents.
Prentice-Hall, 1991.

The Musician's Guide to MIDI, Christian Braut.
Monumental reference work covers areas the other
titles omit, such as Sysex, General MIDI, Show Control
and Machine Control. Sybex, 1994.

1995 Recording Industry Sourcebook. Comprehensive
directory to record labels, producers, managers,
distributors, suppliers, media contacts and more.
Updated annually. Mix Books 1994.

Practical Recording Techniques, Bruce & Jenny
Bartlett. A no-nonsense, hands-on how-to book for
professional recording. Howard W. Sams, 1992.

Principles of Digital Audio, Ken C. Pohlman. Recom-
mended introduction to digital concepts and
technology--clearly and thoroughly explains the
fundamentals. Howard W. Sams, 1989.

The QuickTime How-To Book, Miller & Harris. A step-
by-step tutorial on QuickTime features and multimedia
authoring. Sybex, 1993.

Releasing an Independent Record, Gary Hustwit. How
to set up your own record label and market your
music on a national level. Written by a former SST
Records staffer. Rockpress, 1993.

The Software Publishers Association Legal Guide to
Multimedia, Thomas Smedinghoff. Covers legal issues
such as licensing, trade secret law, patents, copyright,

trademarks and more. Learn how to market and
protect your multimedia work. Addison-Wesley, 1994.

The Studio Business Book, Jim Mandel. The definitive
book on owning or running a recording studio, in a
new, fully revised edition. Mix Books, 1995.

Studio Business Forms, Kevan Patten. A collection of
business documents, such as invoices, work orders,
track sheets and templates, geared toward the needs
of small studios. Patten Sound, 1993.

Synchronization: From Reel to Reel, Jeffrey Rona.
Entry-level, hands-on coverage of SMPTE and MTC.
Hal Leonard Publishing, 1994.

The Technique of Audio Post-Production in Video and
Film, Tim Amyes. Intermediate-level look at audio
post; includes good coverage of synchronization
issues. Focal Press, 1990.

Tech Terms: A Practical Dictionary for Audio and
Music Production, Petersen & Oppenheimer. Explains
the most commonly-misunderstood words and
phrases in recording and electronic music. Mix Books,
1993.

Time Code: A User’s Guide, John Ratclif. An advanced,
detailed handbook on SMPTE/EBU time code and its
use in film, video and audio production. Focal Press,
1993.
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Appendix 1I:

Fine Tuning and
Troubleshooting Your
System

Deck really pushes your Macintosh to its performance
limits. The information listed in this Appendix will help
you fine-tune your system to keep it as fast and
efficient as possible, and deal with problems if they
arise. If you are having trouble recording tracks due to
computer or drive speed, consider the following
issues.

Drive speed is more important than processor speed.
Deck will perform without problem on most
Macintosh computers. If you are having any type of
recording problem, it is probably dependent on your
drive.

Deck requires a hard disk that has a minimum average
access time of 27ms and a sustained throughput of 300
KB/second or more for four-track recording and
playback. For 8-12 track playback, you'll need access
times of 12ms or less and 1.5MB/second throughput.
For 12-16 track playback you'll need access times of
9ms or less and 3MB/second throughput. Avoid drives
with automatic thermal recalibration routines, which
will interrupt disk access. Manufacturers are con-
cerned with selling hardware, so they are often not the
best source for the average access time of the drives.
Check around, ask friends, check newsgroups on the
Internet, or read reviews of hard drives in computer
magazines like MacWorld to get more accurate
information about drive speeds.

Hard drives, formatting, and SCSI

If you already have a hard disk, and it seems to be too
slow for recording, try optimizing or reformatting the
drive. Often, the reason that your disk may choke
during recording is that the remaining open disk areas
exist as tiny segments that are spread all over the
drive. These segments take much longer to find, and
hence the disk slows down. Optimizing your hard
drive is a good housekeeping procedure if you plan to
do a lot of hard disk recording. Disk optimizing
software, such as Norton Speed Disk ™, will search
your drive and rearrange it so your files (and open disk
space) are no longer fragmented. This often speeds up
the drive significantly.

If optimizing your drive doesn’t work, remember that
it is possible that your disk is too slow. If it is still
under warranty, you may wish to have it benchmarked
to judge if the manufacturer’s information was false. If
the drive is not as fast as claimed, contact the
manufacturer directly. You can use a program such as
FWB Hard Disk Toolkit to run benchmark tests on
your hard drive(s).

Throughput

As far as drive speed is concerned, average access time
is not everything. A high-performance drive needs a
good combination of average access time and
throughput speed (in MB per second). There is no
magic throughput number. The best thing you can do
when considering a drive is to test the specific drive
with your system before purchase or arrange a money-
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back guarantee with the reseller.

Formatting

It is recommended that you format your hard drive(s)
HFS+ using Apple’s own Disk Setup utility. You can
also use other programs, such as Charismac
Engineering’s Anubis ™ software or FWB Hard Disk
Toolkit.

SCSI Termination

The first and last devices in your SCSI chain must be
properly terminated in order to avoid serious
problems when working with Deck, and other disk-
intensive applications. You usually don’t need to worry
about internal termination on the internal hard disk if
it has been factory-installed by Apple. However, if your
internal drive was not installed by Apple, you must be
sure that it has been terminated according to the drive
manufacturer’'s—and Apple’s—specifications. If you
have external SCSI devices connected to your
Macintosh, we strongly recommend installing an active
terminator on the last device in your external SCSI
chain. Unfortunately, those little gray plugs that are
usually provided with SCSI devices do not provide
adequate termination and programs such as Deck
make this evident. The SCSI Sentry from APS is an
active terminator we have had very good results with,
but just about any active terminator should do the job.

Extensions and Control Panel
Conflicts

Keep your system clean. Deck is a program that
accomplishes most of its important tasks in real time.
This means that Deck is adjusting many facets of the
audio as playback occurs. For this reason, you should
make absolutely sure that your system is as simple as
possible. You should attempt to avoid INITs and
programs that run in the background. These programs
may consume valuable processor time, which you
need for Deck. Specifically, Norton DiskLight, certain
virus-checkers, screen savers, background data

compression utilities, and background FAX receivers
may cause you a host of speed problems and crashes if
you run them while using Deck. For the best
performance results, keep your System as simple and
clean as possible.

There are no hard and fast rules, but please remember
that Extensions and Control Panels may cause
problems, and that you should run as lean a system as
possible while using Deck. Many problems encoun-
tered when operating Deck have been traced to
system Extension and Control Panel conflicts. BIAS
recommends leaving the Apple installed extensions
alone; but turning off file sharing, unmounting any and
all network volumes, disconnecting from the internet
(where applicable), turning off speech recognition,
and turning off PC Exchange.

This should always be the first issue investigated when
troubleshooting a problem. Listed below are system
Extensions and Control Panels that have been known
to cause problems with Deck. Third party Control
Panels and Extensions not listed here can also be
suspect.

Incompatible System Extensions and Control Panels:
Aliasmenu
Apple Menu Options
AV Speed Up
Billminder
CD Remote Init
Curtis Trackball
Dal (Data Applications Language)
Directory Assistance 11
Disinfectant
Disk Lite (Norton)
Express Modem

Greg’s Buttons
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My Speech Macros

Now Tool Box & All Now Utilities
Radiusware

RAM Doubler

Record Button

SAM

Serial Extension

Virex

When tracking down system conflicts, you will need to
actually open the System Folder, and open the
Extensions and Control Panels folders. Select View By
Name from the Finder’s View menu. This is preferred
to viewing extensions and control panels in start-up
utilities such as Extensions Manager, where the listings
may not reflect the actual contents of the Extensions
folder. You may also consider using a program like
Conlflict Catcher.

To disable extensions or control panels, simply drag
the items from their folder into the “Disabled
Extensions” or the “Disabled Control Panels” folders
and use them to store the items you wish to tempo-
rarily disable. Remember, you must restart your
computer for the changes you've made to your System
Folder to take effect.

RAM Allocation and Memory
Management Hints

Allocating RAM to Deck

In most instances you will need to allocate more RAM
to Deck, as the factory default allocation is sometimes
insufficient for sessions of any substantial length or
complexity. You can change Deck’s RAM allocation by
highlighting the Deck application icon in the Finder,
and select Get Info from the Finder’s File menu. Enter
the desired RAM allocation in the Preferred Size

window in Deck’s Info Box.

A Changing Deck’s RAM allocation can only be
done while the program is not running.

A good way to keep track of your System’s RAM is to
go to the Apple menu in the Finder and select About
This Macintosh. This dialog box will show you how
much RAM your System has, and how it is being used.
It’s a good way of keeping track of how much memory
your applications are using, and how much unused
RAM may be available to you.

To find out what your current session’s RAM require-
ments are, go to Deck’s Session menu while the
session is active, and select Session Info. This dialog
will tell you how much free RAM Deck has at its
disposal. If the amount of free RAM shown is under
500K, you are running dangerously low on RAM if you
intend to add any more material to the session, or use
effects plug-ins. You should quit Deck and allocate
more RAM to it before continuing with the session.

Set the memory partition for Deck by selecting it in
the Finder and selecting Get Info from the File menu.
Then increase the Preferred memory allocation. You
can always decrease the amount of RAM required by
Deck by decreasing the Max. Play Tracks count. To do
this within Deck, go to the File menu and select
Preferences. Then choose the Memory and Storage
submenu, and change the Max. Play Tracks count to a
lower number. Disk buffers are only allocated for play
tracks, so decreasing the number of play tracks will
decrease the number of buffers that will be placed into
RAM.

MIDI

Keep MIDI trimmed down to a minimum, and mute
tracks you don’t need during record. Deck is an audio
recording and mixing environment that supports
simultaneous MIDI playback and recording (in
background sequencers). As such, Deck puts full
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emphasis on audio. If you are attempting to play back
intense amounts of MIDI while recording audio tracks,
you may run into speed or signal degradation
problems. Although this will not happen in normal use
situations, you may be able to cause problems if you
use the MIDI Manager to split playback of 32 or more
tracks (each of which is sending hundreds of messages
per second). If, for some reason, you wish to play back
such a MIDI file, you may wish to filter controller
information, or mute some of the MIDI tracks while
recording audio tracks. You will generally not
encounter these problems during playback.

File management tips

A basic understanding of file management is very
useful for new Deck users.

Session file

A Deck session file does not contain audio files.
Instead, it contains information that applies to audio
files, such as region pointers, audio file paths,
automations events such as pan and volume, etc.
These files are relevant to the construction of your
Deck sessions. A Deck session file is usually only
around 200K in size.

Track

Deck’s playback track count reaches up to 64 tracks on
some Power Macintosh computers (with very fast hard
drives). A Deck track is analogous to a voice on a
polyphonic synthesizer. A track always points to
regions, and regions point to audio files.

Work tracks

Work tracks are the same as regular tracks, except that
they don’t play. You can, however, audition audio
regions in work tracks at any time by using Deck’s
audition tools. Work tracks can also be heard,
complete with volume and panning automation, after
performing a Bounce To Clipboard or Mix To Disk
procedure, if Virtual Mixing has been enabled. Work

tracks can be moved up to playback tracks. A work
track always points to regions, and regions point to
audio files.

Audio file

Audio files (also called sound files) are always mono
16-bit Sound Designer II files once they have been
imported or recorded within a Deck session. The
sample rate will be identical to the native sample rate
of the session file. Sample rates can vary between
22.050kHz, 24kHz, 44.1kHz and 48kHz, depending on
your CPU and audio hardware. Audio files are stored
as individual files across your hard drive, until you
perform a Mix to Disk or Bounce to Clipboard
procedure, which creates a new audio file of your
entire session. For more information about the Mix to
Disk and Bounce to Clipboard commands, see Chapter
6, “Automation, Mixing, and Mastering.”

Crossfade file

Crossfade files are actual audio files that reside in your
session’s Crossfades folder. They are created each time
you execute a crossfade in a Deck session. Crossfades
are represented graphically within existing regions in a
track.

Region
Regions point to areas of existing audio files. Many

regions can point to a single audio file. Regions can
also be saved/stored within an audio file.

Recording strategies

There are some strategies you can employ to help you
organize your Audio Files, which will save you
confusion later on.

Name your track(s) before recording. (Deck will name
your tracks Track 1, Track 2, and so on, by default
unless you do this.)

If you name each track as you work, you can avoid
ending up with multiple files across various Deck
sessions bearing the same name. By naming your own
tracks, you will find it much easier to organize and
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navigate your session.

To name a track, Command-click on the track’s name
pop-up at the left of the Tracks window that contains
it. This brings up a dialog box that allows you to enter
in a new name for your track. (You can also click on
the track in the Tracks window to select it, then
choose Rename from the File menu.)

Recording multiple passes of audio to the same track
will result in a single, contiguous audio file containing
all of the previous record passes. You can prevent this
by always recording new audio passes onto a new
track. This way, each record pass will exist as an
individual audio file. Naming each track before
recording will result in more manageable audio files,
with recognizable names that are relevant to you. (For
example, you could name multiple passes of a guitar
solo “solo take 1,” “solo take 2,” and so on.) When
choosing which of these multiple passes to use, you
can delete unwanted takes by opening the Session
Info dialog box, selecting the take by clicking on its
name, and clicking the Delete key. This will free up
hard disk space, and make your session less clut-
tered—but remember that this delete is a destructive
edit that you can’t undo.

A Note About Crashing and
Restarting

Whenever your computer crashes and you are forced
to restart, the first thing you should do is wait until the
Desktop reappears, and then shut down normally. Let
the computer sit for about a minute before starting it
up again. This is called a cold boot.

If you have had repeated crashes, it is a good idea to
rebuild the desktop files of your hard drive(s). You can
do this by cold booting your computer while holding
down the Command and Option keys down, and
keeping them down until a dialog appears asking you
if you are sure that you want to rebuild the Desktop
file for your drive(s). Select OK for all of your drives.

Troubleshooting

Deck performs an amazingly complex series of tasks
on a wide variety of Macintosh computers. While
problems are rare, there may be times when you will
get an error message or system crash, or have some
other sort of problem while using Deck. The following
troubleshooting guide will help you identify and
correct these sorts of problems.

Problems with output levels during
monitoring

There is a bug in some Power Macintosh sound
hardware. Specifically, when you turn on playthrough
in your Sound Control Panel to monitor while
recording, the output level of the entire system will
drop by around 20db. This is not a bug in Deck, nor
can it currently be fixed in software—it is a bug in
Apple’s Power Macintosh hardware.

This bug does not affect audio recorded into Deck, but
it does affect the playthrough, or monitor volume.
While setting levels, what you see on the VU meters
and what you hear will be different than what is
actually going into the system. With this in mind, do
not base your record levels on DECK’s VU meters—if
you do, the playback signal will be much weaker than
anticipated.

Solution

Keep the Analog Input Level (DECK’s Options menu)
set at 0 to avoid this bug. With the Analog Input Level
set at 0, the levels that you see and hear will be
correct. You may find it helpful to use a good quality
compact mixer to boost the incoming signal.

Error Message: “Problems initializing
Playback engine. No Supported hardware
installed.”

Possible solutions

Check the sound control panel and make sure that
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both a sound input and a sound output are available.
Otherwise, rebooting will usally correcting this
problem.

Check to see how much free RAM you have on your
Macintosh. Quit Deck, go to the finder and select
About This Macintosh from the Apple menu. The
Largest Unused Block indicates the amount of free
RAM you have available. Make sure you have at least
16MB of free RAM on your Macintosh. (Remember not
to increase the Hard Disk Buffer settings in Deck’s
Memory and Storage menu above the amount of RAM
allocated to Deck.)

If you can, try allocating more RAM to the Deck
Memory Partition. (Remember, to Get Info, you must
highlight the application, not an alias, and the
application must not be running.)

Throw away the Deck Preferences file (in the
Preferences folder, which is found in the System
Folder) and restart your machine. Users of Digidesign
hardware must also throw away the DigiSetup and
Digicomm files, if any, from their System folder. All
new Preferences files will be created automatically the
next time you use Deck.

Within Deck, decrease the Max. Play Tracks in Deck’s
Memory and Storage Preferences menu.

Perhaps Deck was not installed properly. It is possible
that the wrong platform type was selected during
installation, for example. If you suspect that this was
the case, reinstall Deck. To learn how to install Deck,
see Chapter 2, “Installation and Setup.”

Problem: Cannot Record in Stereo—no
Stereo Separation.

Possible solutions

Make sure you are using stereo, as opposed to mono,
adapters going to and from your Mac’s audio input
and output jacks (the following illustration shows a
stereo mini-plug).

Be sure that the plugs fit snugly in the audio input and
output jacks of your Macintosh.

Remember to set each record track to a different input
in the Mixer window.

Problem: Scratchy-sounding Audio
Possible solution

Be sure to use a stereo 1/8-inch adapter with a 1/2-
inch tip and a tapered base that is slightly raised above
the adapter’s casing (see diagram below). The input
socket on an AV Macintosh will prevent certain “flat-
headed” 1/8-inch adapters from making full stereo
contact.

General Problems with audio playback
(glitches, pops, clicks, “Disk is Too Slow”
messages)

Possible solutions

Record audio to a hard drive that does not contain the
System Folder. (This is why two hard drives are
recommended when using Deck on AV Macintosh
computers.)

Change the Disk Buffer setting. (Go to DECK’s File
menu, select Memory and Storage from Preferences,
and enter 192K in the Disk Buffer Size box. This is the
factory setting.)

Problem: Trouble with MIDI or with syncing
to external time code (MTC)

Possible solution

Install Opcode’s OMS version 2.3 or later. We
recommend installing OMS on all machines if you are
doing work that entails synchronization. OMS provides
compensation for dropouts in MIDI time code and is
of great help when slaving Deck to external time code.

Error messages
-36 1/0 errors

These usually signify SCSI termination problems. Be
sure that your internal drive is properly terminated,
and that you install an active terminator device on the
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last SCSI device in your external SCSI chain. (See the
section on SCSI termination earlier in this Appendix
for more information.)

-37 “Bad File Name” errors

Region and audio file names must be less than 31
characters long, and illegal characters such as : and ;
cannot be used when naming files.

-39 errors

These are “End Of File” errors in which a region’s start
and end times have somehow become corrupted.
These errors can occur when importing regions from
files originally saved in Sound Designer II. There have
also been reported instances of -39 errors during
playback within a Deck session. Here are some
instances of -39 errors, and ways to remedy them:

-39 error during playback

Take note of which region, or regions, actually cause
this error. Deck will usually stop playback exactly at
the start point of the problematic region(s). Find the
problematic region’s original position. In Object
mode, use the Trim tool to trim the problem region
inwards to make it smaller. Now trim the region a
second time and extend it back to its original duration.
Now that the region’s start and end times have been
redefined by the Trim tool, the -39 error should
disappear.

-39 error when importing region(s) originally
saved in Sound Designer Il

Rebuild the Desktop file on all of your hard drives.
(Restart your Macintosh while holding down the
Command and Option keys; click OK when the dialog
box appears.) Open your Sound Designer II applica-
tion, redefine the problematic region(s)’ start and end
points, and save them within Sound Designer II. Now
you can Import the region(s) into Deck using Add
Audio to Clipboard in Deck’s File menu.

-43 “File Cannot Be Found” errors

These errors are usually caused by corrupted crossfade

files. This can happen if you've moved session files
from volume to volume. To remedy -43 errors, select
Rebuild Fades from Deck’s Process menu. If the
problem persists, rebuild the Desktop file on all of
your hard drives. (See the previous page for instruc-
tions on how to do this.) If you still get a -43 error, you
may have to delete all of your crossfades (by selecting
Delete Fades from Deck’s Process menu) and recreate
them from scratch. But before resorting to this, try
quitting Deck and throwing away the crossfades files
folder from your problem session. Crossfades will be
automatically re-created upon re-opening the session.

-108 (or - 2012) “Couldn’t Complete the Last
Command due to a Mac OS error”

Allocating more RAM to Deck’s Memory partition will
remedy these errors.

-192 “Required Resources Missing” error

Troubleshoot your Extensions and Control Panel
setup, and rebuild the Desktop file for all of your hard
drives. (These procedures are explained at length
earlier in this Appendix.) If this doesn’t work, reinstall
Deck. If you still get the -192 error message, you may
have to perform a clean install of your System
software.

-2720 error

You have the incorrect input source selected. In the
Sound Control Panel, set the input to Built-in instead
of Digidesign.

“Problems Initializing Playback Engine”

This error is usually the result of increasing Deck’s
Disk Buffer size without first allocating sufficient RAM
to the Deck application in the Finder. Higher Disk
Buffer settings require more RAM allocated to Deck.
To calculate the amount of RAM you'll need to allocate
to Deck in these cases, multiply the amount of the
Disk Buffer increase by the number of tracks running
in Deck. Now change Deck’s RAM allocation by
entering the new amount in the Preferred box in
Deck’s Get Info box in the Finder.
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Deck freezes up or hangs during recording

This may be the result of a SCSI termination problem.
To test whether SCSI termination is the culprit, use
Deck’s Mix To Disk feature. Make a 5 minute selection
in the Tracks window and select Mix to Disk from
Deck’s Process menu. Perform this process with the
same selection a total of three times, creating three
mix files. If any problems arise during any of these
three Mix to Disk procedures, or if you have problems
playing back any of the three mix files you created
when they have been imported into a Deck session,
then it is likely that there is something wrong with
your SCSI chain. See the section on SCSI termination
earlier in this Appendix for more information.

“Calculating File Overview” dialog appears
continually when you attempt to scroll through
the Tracks window

Allocating more RAM to Deck will usually solve this
problem. Unfortunately, allocating more RAM will not
solve -39 error-related calculate overview loops.

“Disk Too Slow” messages or “out of memory”
errors

On slow disks, use the Memory and Storage prefer-
ence (from the File menu’s Preferences submenu) to
increase the disk buffer size. This will increase overall
memory required, but will decrease disk read
frequency and put less strain on your drive.

A note about “Disk Too Slow” messages

If you are running Deck with multiple slave programs
on a single Macintosh, or if your Macintosh or hard
disk is slow or older, you may encounter the “Disk
Too Slow” message in Deck. This is not the kiss of
death for your system. There are a number of simple
adjustments you can make that will generally remedy
this problem.

Try increasing the size of your disk buffers. Often you
will get this message because your disk is really a bit
slow. To compensate for a slow disk, you can increase
the size of your disk buffers. This decreases the
number of disk reads that need to be made, thereby

decreasing the total number of seeks required. Larger
sections of audio are loaded during disk reads, and
overall strain on your hard disk is reduced.

The only drawback may be a slight increase in the
delay between pushing the Play button and begin of
playback. To increase the size of your disk buffers,
choose Memory & Storage from the File menu’s
Preferences submenu.

Use this dialog to enter a larger disk buffer size. Try
256K first, then increase it if that doesn’t improve disk
performance sufficiently. Remember, when you
increase your disk buffer size, you must also increase
the amount of RAM allocated to the Deck application.
(Higher Disk Buffer settings require more RAM.)
Here’s how to calculate the required increase in RAM
allocation when increasing the Disk Buffer for your
session: take the amount of Disk Buffer increase and
multiply that number by the number of tracks in your
Deck session.

Change Deck’s RAM allocation by quitting the
program, selecting its Get Info box from the Finder,
and changing the Preferred Size.

Decrease the update speed setting for background
programs. Deck offers a special “Update speed during
playback” option, available under General in the File
menu’s Preferences submenu. This preference allows
you to set how much time is available for other
programs to update in the background behind Deck
audio playback. A setting of 1 allows the background
program to update as often as possible. This setting
makes it easier to see screen activity in background
programs. A setting of 10 prevents background
programs from updating during playback, allowing
Deck to monopolize your display. This setting does
not affect the performance of the background program
at all. It only affects screen drawing. A setting of 5 is
suggested. If you are running Metro in the back-
ground, and you experience “Disk Too Slow”
messages, you may want to set this to 8 or 10 to
decrease the background strain on your Macintosh
CPU, or try decreasing Metro’s steps per beat setting.
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Turn off the “Stop playback if disk is too slow”
preference. This is a particularly useful preference
available under General in the File menu’s Preferences
submenu. The “Stop playback if disk is too slow”
preference allows you to set how carefully Deck
checks to see if your drive is too slow. If you attempt
to play multiple tracks from a very slow drive, Deck
may not be able to play them without a small glitch, or
skip in playback. Usually this skip is so subtle, you will
not be able to hear it. When this preference is turned
on, Deck will put up a warning dialog and immediately
stop playback any time disk performance might cause
a playback skip. When this preference is turned off,
Deck will continue to play back, even if a slight skip
may potentially occur.

If you are mixing live directly to DAT, or any mastering
medium, then turn on “Stop Playback if Disk is too
Slow.” This will guarantee that audio playback will be
supervised, and stopped before any skip might occur.
If you are simply editing sound and you plan to mix to
disk (which is the suggested way to use Deck), then
leave this preference turned off. Most skips will not be
audible, and, even if you do hear a skip, that skip will
not appear in the master file that results from a Mix to
Disk procedure.
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Appendix 2:
Support for the
Tascam US-428

Deck and Deck LE offer direct support for the Tascam
US-428 control surface. If Deck detects a Tascam US-
428 control port available via OMS, Deck places itself
in “US-428" mode.

To use the US-428 as your audio interface for Deck,
install the US-428 ASIO Driver 16-bit in Deck’s ASIO
Drivers folder. Launch Deck and choose the US-428
ASIO driver 16-bit from the Audio Card pop-up menu
in the Hardware Configuration Dialog.

- Hardware Configuration=——————

Audio Card: [ US428 ASIO Driver 16-bit | 3|

Sync Mode: | Internal s

Ch.1&2 InputType:[Analog | = |

Digital Format: | S/PDIF $
[] Mic Input On

ASI10 Configuration:

[ Record monitoring

Clock Source: Internal 3+

[4 Play audio while in background

Hardware Configuration dialog

Note that you do not have to use the US-428 as
your ASIO driver in order to use the US-428 as
a control surface.

When in US-428 mode, Deck instantiates a Parametric
EQ-4 (version 2.7.1) on the first effects insert of every
track. The “High”, “Hi-mid”, “Low-mid”, and “Low”
buttons on the Tascam US-428 select each of the four
parametric bands in the EQ-4 algorithm.

Moving a fader on the US-428 will move the correlating
Volume fader in Deck. The bank buttons on the US-

428 are used to select which group of Volume faders
will be controlled by the 8 faders on the US-428 (e.g. 1-
8,9-16, 17-24).

Pressing the “Select” buttons on the US-428 selects the
channel. The Pan knob and EQ knobs will control the
Panning and the parameters of the 4-band EQ for the
currently selected channel in Deck.

The Transport buttons on the US-428 map directly to
the Transport controls in Deck. The Record button
also acts as a modifier. To record arm a channel, press
and hold the Record button and press a select button
to toggle record armed status for the channel.

The “Mute” buttons display and toggle the mute status
for the selected channel and the corresponding Track
in Deck. If the “SOLO” button is lit, this function
changes to display and toggle the solo status

for the channel and the corresponding rack in Deck.

The “Locate < <", “Locate >>", and “Set” buttons
on the US-428 are used to set and jump between
location markers in the Tracks window in Deck. Bring
the Tracks window in Deck to the foreground and use
the Set button to drop a location marker at the current
time.

The “Locate < <” button will jump to the nearest
location marker before the current time, and the
“Locate > >" button jumps to the nearest location
marker ahead of the current time.

The select buttons on the US-428 select Tracks 1-8
from the current session in Deck LE. In the full version
of Deck, the select buttons on the US-428 select

Tracks 1-8 from the current bank. The Bank buttons
select which bank of channels are affected by the US-
428 controls (e.g. 1-8,9-16, 17-24, etc.). The number of
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available playback Tracks in the mixer is controlled by
the General/Storage preferences in Deck.

Input/Output channel display when "ASGN” button is pressed

The “ASGN” button in conjunction with the data wheel
selects the input assignment for the currently selected
channel. Press and hold the “ASGN” button and rotate
the data wheel to change input assignment for the
selected channel. While the “ASGN” button is
depressed, the mixer state buttons (SELECT, REC,
MUTE) display the current input channel assigned.

The “F1” button in conjunction with the data wheel
selects the output assignment for the currently
selected channel. Press and hold the “F1” button and
rotate the data wheel to change output pair assign-
ment for the selected channel. While the “F1” button
is depressed, the mixer state buttons (SELECT, REC,
MUTE) display the current output pair assigned (e.g. 1
= output pair 1-2, 2 = output pair 3-4, etc.).
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Glossary

AIFF

Apple’s Audio Interchange File Format used for
recording and storing digital audio.

audio card (third-party audio card, audio
expansion card; audio recording/playback
card)

A third-party expansion card that plus into a NuBus or
PCI or PCMCIA slot in your Macintosh. These cards
enhance a computer’s audio recording and playback
capabilities. Using Apple’s Sound Manager software,
Deck works with a variety of Macintosh audio cards
from Digidesign, Digigram, Echo, Korg, Lucid, Mark of
the Unicorn, MIDI Man, and others. In some cases,
special Sound Manager Driver software or ASIO Driver
software may be needed from the audio card’s
manufacturer to work properly with Deck.

audio document

An audio document is a Macintosh audio data file
created by Deck. Deck can create and open audio
documents in a variety of common audio file formats.
The SDII file format is Deck’s default file format. For
more information, refer to AIFF, WAV, Sound Designer
1T, and QuickTime.

bit resolution (bit rate)

Describes how many bits—as in “0s” and “1s” —are
available to describe a digital recording. In practice,
the bit resolution defines the dynamic range of a
sound, whereas the sample rate defines the frequency
range. 16-bit audio is the professional Compact Disc
standard; 8-bit audio is suitable for less demanding
applications, such as multimedia presentations. More
bits result in better quality, but also require more hard
drive storage space. Also refer to dynamic range,
frequency, and sample rate.

clipping

A type of audio distortion that occurs when a source
signal (such as from an audio CD player) is recorded at
such a high level that the recording device (such as a
Macintosh running Deck) runs out of “headroom.” It
can also occur when a signal is played back from a
audio source into an audio destination at an excessive
level, such as when a mixing console feeds a signal to a
power amplifier at an extremely high level. In either
case, clipping represents a mismatch in level between
an audio source and an audio destination. When
digital clipping occurs, such as during digital record-
ing, the results can be a harsh “crackling” or “raspy”
sound. When you use Deck, you can avoid digital
clipping by ensuring that the record levels are set so
that the loudest incoming audio passages stay below
the maximum input level, as indicated on the record
or playback meters. Deck’s Clip indicators above the
vu meters in the Mixer window will easily show any
clipping that occurs. Also refer to headroom.

dB (decibel)

This is the most common unit used for measuring the
level of audio. The greater the number of decibels, the
higher the audio signal. Within Deck, the vu meters
show a signal’s relative level in terms of dB. There are
many different kinds of decibel scales, but for the
purposes of using Deck, “dB” can be used to describe
the relative gain of different passages of audio, or to
describe the available headroom during recording.
Also refer to gain and headroom.

DSP

DSP stands for digital signal processing. In the world
of audio, DSP refers to manipulating a digital audio
signal by processes such as level changes, reverbera-
tion, delay, or other such effects. Deck uses DSP to
perform many of its audio processing tasks—including
those found in the Destructive Effects submenu and
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Deck’s Built-in Effects.

dynamic range

In audio recording terminology, dynamic range refers
to the range in level between the quietest and loudest
passages of a selection of audio. It is usually expressed
in decibels. Bit resolution determines a recording’s
dynamic range. An 8-bit recording has 256 available
levels, which translates into a dynamic range of 48dB.
This may be suitable for some applications, but it may
also sound noisy, since the difference in gain between
the loudest passages and the quietest passages (which
may contain hiss and other potential noise) is not that
great. A 16-bit recording has 65,536 available levels,
which translates into a high-quality dynamic range of
96dB. As a rule of thumb, you can calculate dynamic
range in decibels by multiplying the bit rate by “6.”
Also refer to bit resolution, decibel, and gain.

fade-in/fade-out

A fade-in is a process where the gain of an audio signal
is increased from zero (silence) to its full volume. A
fade-out is a process where the gain of an audio signal
is decreased from its full volume to zero (silence).
Deck allows you to create fade-ins/fade-outs by making
a selection and choosing the Fade Selection command
from the Process menu (Command-F). Envelope
shapes can be editing with the Set Default Fade or
Custom Fade commands in the Process menu.

frequency

Sound consists of waves, which occur in cycles.
Frequency refers to how frequently these wave cycles
occur in a given period of time (generally, one
second). The higher the frequency of a sound, the
higher its “pitch” as perceived by human ears.
Frequency is measured in Hertz (Hz), or cycles per
second. Roughly speaking, humans are able to hear
sounds in the frequency range between 20Hz and
20,000Hz (20kHz).

gain
1) The process of amplifying a signal. 2) A way to
express relative signal levels for audio. For instance, by

adding 6 decibels of level to a signal, we double the
perceived loudness of the signal. Also refer to decibel
and headroom.

headroom

Describes how much gain is left before a signal
induces clipping or distortion. When recording with
Deck, the vu meters in the Mixer window indicate how
much headroom is left before clipping. When playing
back audio in Deck, the meter strip at the bottom of
the screen will indicate this as well. Most professional
audio engineers leave between 3dB and 12dB of
headroom while recording, to minimize the possibility
of clipping. If you leave too much headroom, however,
your signal may be recorded at too low a level, and
you may end up with excessive noise or hiss. Also refer
to clipping, decibel, and gain.

Hz (Hertz)

This is the unit of measurement for frequency, and
refers to the number how many “cycles per second” a
sound wave generates. In the world of sound, the
higher the number of Hertz, the higher the frequency
of a sound and hence the higher its “pitch” as
perceived by human ears. A thousand Hertz can be
expressed as 1kHz (one kilohertz), so that 20,000
Hertz may also be referred to as 20kHz.

loop

Loops are used to sustain or repeat a section of audio;
aloop is a repeating region of audio.

marker

A marker is a location in the Deck timeline that you
define as important; you can also think of a marker as
a “memory location.” By marking a specific location in
a recording, you can easily navigate to it for selection,
editing or playback purposes.

Plug-Ins

Plug-Ins are optional software enhancements for Deck
that are available from BIAS and other developers that
support the Adobe Premiere Audio Plug-In Standard
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and the Steinberg VST standard. By installing plug-ins
in Deck, you can enhance Deck’s audio editing and
processing capabilities with tools such as filtering,
reverberation, chorusing and flanging, noise reduc-
tion, spatialization, and more.

QuickTime

This is an audio format developed by Apple Computer
for QuickTime-based multimedia. It is supported by all
Macintosh software applications that support
QuickTime. The QuickTime format is best if you plan
to use an audio document in multimedia applications
that support QuickTime, such as Adobe Premiere or
Macromedia Director.

region

A region is a portion of an audio document.

sample

(verb) Sampling refers to the act of recording audio
material digitally by a sampling instrument or other
digital recording device. See sampler and sample rate.

sample

(noun) A sample refers to audio material which has
recorded digitally or “sampled” by a sampling
instrument or other digital recording device. Sample
also refers to a single wave-cycle” snapshot” of sound.
See also sampler and sample rate.

sample rate

Sample rate describes how frequently an analog audio
signal is been “sampled” or analyzed as it is recorded
and converted to a digital medium. Sample rate
directly affects audio fidelity in terms of upper
frequency response: the higher the sample rate, the
higher the available frequency response. A fundamen-
tal principle of sampling states that to accurately
capture a sound, the sample rate must be at least twice
the highest frequency in the sound. The standard
sample rate for Compact Discs is 44.1 kHz. The
following are common sample rates which are
supported by many Macintosh computers and Deck
software.

48.000kHz This is one of two standard sample rates
for digital audio tape (DAT) recorders, and is
often used by sound editors working in audio
post-production for video or film. This rate
results in an upper frequency response of 24kHz
— well above the range of human hearing.

44.100kHz This is the standard sample rate for
Compact Discs, digital audio tape (DAT)
recorders, and high-fidelity audio applications on
Macintosh and PC-compatible computers with 16-
bit playback capability. It is colloquially called
“forty-four one” (as in 44.1kHz). Most sound
engineers working in music production — or
anything that may be distributed on a CD — work
at this rate. This rate results in an upper
frequency response of 22,050Hz — above most
people’s hearing range.

22.050kHz & 11.025kHz These sample rates are
sometimes used for lower-fidelity audio playback
on Macintosh and PC-compatible computers.
Many games, web-sites and other multimedia
productions utilize 22.050kHz (or lower) 8-bit
audio, since it uses half the disc space of CD-
quality audio. The 22.050kHz sample rate results
in an upper frequency response of 12.025kHz;
this may sound “muffled,” since most people can
hear considerably higher frequencies than

12.025kHz.

Also refer to bit resolution, frequency, and Hertz.

SCsl

Stands for Small Computer System Interface. It is a
standard developed to allow a variety of computers
and peripheral devices such as hard disks, CD
recorders, scanners, and other storage media, to
connect and transfer data. Most external hard drives
designed for use with the Macintosh are SCSI hard
drives and must be connected to the SCSI port on the
rear of the Macintosh. The SCSI specification allows up
to seven SCSI-equipped devices to be connected or
“daisy-chained” together.
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Sound Designer II™

This is an audio file format developed by Digidesign
for use with its digital audio products. The format can
also be read by a wide variety of Macintosh-based
audio editing and multimedia development programs.
It is Deck’s standard file format.

WAV

This is Microsoft’s Windows Audio File Format. It is
supported by many Windows software applications
and some Macintosh applications. The WAV format is
best if you plan to use an audio document in an
application that supports or requires WAV format files.

zero-crossing

The zero-crossing is the point where the waveform
meets the zero crossing line or the center line through
the waveform. It is the point of zero amplitude in the
waveform.
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Index

Symbols Autocue 40
Autolocate 26

SND - 74 Automation 65, 108, 135
WAV 74 breakpoint
A adjusting 68
deleting 68
Add Audio CD Track To Clipboard 119 Conform To Audio Edits 135
Add Audio to Clipboard 22, 72, 119 Conform to Audio Edits 69
Add SDII Playlist to Clipboard 119 enable/disable 69
Add SND to Clipboard 22, 119 creating 67
Adobe Premiere 79 Display pop-up 66
AES/EBU 138 editing 68
AIFF 74, 171 envelope breakpoint 67
Allocating additional RAM to Peak 5 envelopes 66
Always save regions when Session is saved 121 Erase All 136
Amplifier 11 mixer states 69
Analog 138 Mute All 135
Analog Input Level 139 Play All 135
Apple Sound Manager 10 Record All 65, 136
Arboretum 58 Record Pan 65
ASIO 10, 11, 12, 13, 171 Record Volume 65
configuring Deck for 13 recording 65
Installing drivers 13 visual envelopes 66
Audio Card 11, 14, 171 Automation buffer 123
Audio Connections 10 Automation Envelopes 66
Audio Document 171 copying and pasting 68
Audio File format 74 creating 67
Audio Files folder 21 editing 68
Audio Format 83 muting and erasing 68
Audio Interchange File Format 74 Show/Hide 69
Audio Interface 11 Automation Status 68
Audio Regions Automation submenu 65
spotting to timecode 47 Automation Thin 132
Audition End of Selection 132 Autostop at end of Session 121
Audition Outputs 124 Axis Resolution 38, 101
Audition Pre-Post Selection 132 Axis Units 37, 38, 101
Audition Selection 132
Audition Volume 124 B
Auditioning 40 Bars and Beats 37
Authorization 9 Beat Mode 38, 48

Product Authorization Code 9
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Begin and End Time Counters 112
Bit Depth 75
Bit Depth Conversion 75, 83, 124
Bit Resolution 171
Bounce All to Mono Clipboard 129
Bounce All to Stereo Clipboard 129
Bounce to Clipboard 72
Bounce to Disk 72
Bouncing tracks 71
Breakpoint

adjusting 68

automation 67

deleting 68
Built-In Effects 54
Bypass 55

C

Capture Start 132

Ch 75

Change region start times with BPM change 121

Channel Signal Flow 110

Chase Positioning 68, 80

Chorus 26, 56

Clear 127

Clip Light 109

Clip Light Threshold 124

Clip Lights 118

Clipboard Memories 126

Clipping 171

Clock Source 15

Close Session 119

Close Window 140

Colors 122

Compact Audio 29

Compact Audio File 45, 46, 120

Compact Files 124

Compact Session 29, 45, 139

Conform To Audio Edits 135

Conform to Audio Edits 69
enable/disable 69

Control Value Indicator 112

Control Value Indicator box 55

Convergent Rounding 75, 83

Copy 33, 127

CPU 118
CPU Meter window 24, 118, 140
Crossfade
equal power 43
linear 43
Crossfades 40, 131
Crossfades folder 21
Custom Fade 44

Cut 33, 126
Cycling 74 58
D

Data Indicator boxes 37
dB (decibel) 171
Decibel 171

Deck

allocating RAMto 10
Built-in effects 26
configuring 16
features 3
installing 9
session file 21
What's New 4
DECK 1.0 140

Deck LE 5

Default Fade 43
Defragment Audio File 120
Delay 26, 56

Delay line length 126
Delete Fade 45
Destructive Effects 53, 131
Digidesign 171
Digigram 171

Digital Format 138
Disk buffer size 123
Dithering 75, 83

DSP 171

Duplicate 53
Dynamic Range 172

E

Echo 171
Edit menu 126
Effect
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adjusting parameters 55
bypass 55

Chorus 56

control value indicator 55
Delay 56

EQ 56

Gain 56

Multitap 56

remove 55

sliders 55

Thru 55

Effect Selector 54, 59, 108, 117
Effect window 55, 116, 140
Effects 26, 53

assigning 54

built-in 54

destructive 53, 131
external 131

in the Mixer window 54
non-destructive 53
real-time 53, 54
Effects Allocation 126
Effects Preferences 57
Envelopes

Automation 66

EQ 26, 56

Equal Power Crossfade 43
Export Movie 82

Export Session Regions 139
External Editor 48, 132
External Effects 131

F

Fade
custom 44, 131
default 43, 131
delete 45, 131
overlap 43
rebuild 131
set default 131
Fade in shapes 42
Fade out shapes 41
Fade Selection 131
Fade-in 172

Fade-out 172
Fades 40

Fast Cueing 40
Fast Forward 111
File Indicator 114
File menu 119
File Sharing 5
Final Cut Pro 79
Final mix 73

Find File 140
Firewire 17

Fit Selection 34, 100
Frequency 172

G

Gain 26, 56, 172
GraphicEQ 56
Grid 37

Grid button 38
Grid Interval 138
Group Normalize 53

H

Handle Size 46

Hard Drive Status Indicator 102
Hardware Configuration 14, 138
Hardware Options 16
Headroom 172

Help 140

Hertz 172

HIEQ 56

Hz (Hertz) 172

iMovie 79

Import Session 140
Input Selector 102, 108
Input Type 138

Insert After 128
Insert At 127

Insert Time 128
Invert 53
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K

Korg 171
12121/0 10, 134
SoundLink 10, 13, 14, 134

L

Launch Editor 48, 132
Library 140
sort by name 140
sort by size 140
update from session 140
Library window 113, 140
Linear Crossfade 43
Live Video 81
LoEQ 56
Load Audio File 119
Location Indicator 100
Location Times 26, 34, 35, 112
Location times 26
Loop 172
Loop (Rehearse) Mode 111
Loop audition 121
Loop button 40
Loop mode 27
Lucid 171

M

Magnification 34

Magnify button 34

Make Contiguous 128

Mark of the Unicorn 171

Marker 26, 172
rename 35

Markers 35, 102, 137
delete 35

Master Counter 111

Master Fader 118

Master Outputs window 24, 59, 117, 140

VST plug-ins 59
Mastering 73
Max. play tracks 123
Metro 48, 90, 94, 120
Always Pass Selection 125

configuring with Deck 90
Mic Input On 138

MIDI 24

Default Output Port 88, 125
Dispose MIDI File 120
Edit MIDI Map 88, 136
Import 114

Import MIDI File 120
Importing MIDI files 92
KeyMaps 88

Load MIDI Map 120
mapping faders 88, 136
metronome 91

MIDI Thru 93

muteall 114

Mute MIDI Map 136
preferences 87

Save and Load MIDI Map 89
Save MIDIMap 120
setup 87

Split channels on incoming MIDI files

Subscribe to Standard MIDI file
timecode 88

Timecode Output Port 88, 125

MIDI buffer 123
MIDI Map Faders 136
MIDI Sequence 24
MIDI Setup 115, 133
MIDI Thru Port 114
MIDI Thru Switch 114
MIDI Thru Track 114
MIDI Timecode 135
MIDI window 114, 140
Minimum Size field 5
Mix Regions As Files 131
Mix to Disk 72, 73, 74, 130
Mixer 11
Mixer State 26
Mixer State Automation 70
recording 70
Mixer State pop-up 69
Mixer States 34, 69, 112
deleting 70
recalling 70

114

recording in the Tracks window 71

88, 125
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renaming 70
storing 69

Mixer window 23, 58, 60, 107, 140

VST plug-ins 58
Mixer-based Automation 65
Mono to Mono VST plug-ins
Mono to Stereo VST plug-ins
MOTU

MIDI TimePiece 93, 94, 134

PCI-324 13

Multi-processing Support 121

Multiple Paste After 127
Multitap 56

Mute 102, 115

Mute button 109

N

New 119

New Track 129
Non-destructive Effects 53
Normalize 53

Nudge Time 138
Number of Channels 75

(o)

Object Mode 35, 100
Object Mode button 36
OMS 87

configuring Deck 87
OMS Instruments 115
OMS Setup 87
Opcode 87

Studio5 93, 94, 134
Open 119
Open editor 59
Open Music System 87
Options menu 133
Output Indicator 117
Overlap Fade 43

P

Pan fader 109
Pan Indicator 103
Paste 33

Paste After 127
Paste At 127

Paste Before

127

Peak 48, 49, 75
Peavey PC-1600 66

Performance

maximizing 4

Pitch Control
Play 26, 11
P
P
P
P

ayback Rate

Premiere
VST 58
insert
install
plug-ins
VST 58

Fader
1

135

ug-Ins 172

57

113

58, 59

58

Position at Beginning

Position at End

Position to Fit
Preferences

137

Effects 57, 126

General

120

Levels 124

Memory and Storage

MIDI 125

Slave Settings 1
Preferred Size field 5

Premiere

137

24

ay audio while in background
ay Tracks 40

137

audio plug-in standard
Premiere Plug-Ins
Premiere Plug-Ins

applying

57

previewing 57

Previewing
Premiere p
Process menu

Product Authorization Code 9

lug-ins
129

Pulldown 135

Punch Mode
Punch Time

111
137

Punch-In 26, 27

Punch-Out

27

131

57

57

123

172
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QuickTime 22, 68, 74, 173

Add audio to movie 82
Audio Format 83

Bit Depth Conversion 83
Chase Mode 80
Configure Live Video 81
Copy Frame 80
Dispose Movie 80
flattening 82

Get Movie Info 80
Live Video 81

Make movie self-contained 82
Sample Rate 83

Scrub to spot 81
Scrubbing video 81
Set Offset 81

Set Poster 80

Size 81

soundtrack 79

QuickTime movie 79

exporting 81
importing 79
scrubbing 80

QuickTime Shortcuts 140
QuickTime window 80, 115, 140
Quit 126

RAM 118, 123, 139

allocating 10

RAM Doubler 10

Range Mode 35, 100
Range Mode button 36
Real-Time Effects 53, 54
Record 103, 111

Record monitoring 15, 139
Record-enable 109
Recording 24

Region 37, 173

re-sizing 39

Region Info 131
Regions

editing 39

Remove 128

Rename 128

Replace 127
Return-to-zero 66, 111
Reverse 53

Revert 119

Rewind 111

Rewrite region list 121
Rounding 75, 83

S

S/PDIF 138

Sample 173

Sample Rate 74, 83, 173
Samples 37

Save 119
Save A Copy As 119
Scroll after play 121
Scroll During Playback 26, 138
Scrubbing 68

SCSI 17, 173

SDII 74

Seconds 37

Select All 128
Select Regions 140
Send to Slave 137
Session 21

adding audioto 22
close 21

create new 21
open 21

save 21

Session End Time 139
Session Info 139
Session menu 139
Session Nominal Rate 135
Set Selection 137
Signal flow 60
Silence 43

Slice 127

Slide Locator 111
Smart Grid 37
SMPTE 93, 95, 132
Online 134
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Preroll Time 122
Slave Driver 94
Start Time 134
SMPTE Format 133
SMPTE Frames 37
SMPTE-to-MIDI 94
SMPTE-to-MTC 134
Snapto Grid 38, 101, 137
Soft Saturation 124
Solo 102, 115
Solo button 109
Sound Control Panel 12
Sound Designer [T 22, 74, 174
Sound Editor Signature 122
Sound Manager 11, 12, 171
Sound Manager Record Offset 122
Sound Resource files 74
Speakers 11
State Transition Time 136
Status Indicator 112
Steinberg 58
Stereo to Stereo VST plug-ins 60
Stop 111
Stop audio playback if the drive is too slow 121
Strip Silence 133
Sync Mode 138
Synchronization 93
trigger synchronization 93
Synchronizing
Open Slave Documents 125
Quit Slave When Quitting 125
Save Slave’s Document When Saving 125
Syncronization
slave to digital source 94
Syncronizing
Current slave 124
System Extensions 4
System Requirements 4

T
Tascam US-428 10, 66, 89
Tempo 47

Tempo Controls 101
Tempo Selector 48

Thru 26, 55

Time Axis 101

Time Mode 138

Time Signature 47

Timecode 47

Timecode Source 134
Timeline 26, 35

Track Automation Status 103
Track Automation View 67, 103
Track Channel Indicator 115
Track Control Area 102

Track Label 102

Track Level 103

Track Name 115

Track Output Pan selectors 108
Track Playlist Selection 110
Track Port Indicator 115

Track Size Buttons 35, 100

Tracks
moving 33
naming 29

renaming 33, 73
Tracks Global Control Area 100
Tracks window 23, 33, 34, 100, 140
key commands 104
Tracks Window Time Axis 35
Transport controls 122
Transport window 23, 26, 110, 140
Trigger Sync 93, 134
Truncation 75, 83

U

Undo 126
Update speed during playback 122
UW-SCSI 17

'}

VCR 94

Vertical Zoom 100

Vertical Zoom buttons 34
View Memory buttons 34, 100
Virtual Mix 40, 130

Virtual mixing 72

Visual Automation Envelopes 66
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Volume fader 109

VST 58

VST inserts
mono 59
mono to stereo 59
stereo 59

VST Plug-Ins 26, 58
bouncing 61
editor 59
inserting 58, 59
installing 58
organizing 58

removing 60
VstPluglns 58
VU Meter 109
VU Meters 118
w
WAVE 174
Wave 74

Waveform Contract 34
Waveform Expand 34
Waveform Overview 26
Waves 58

Windows menu 140

Work Tracks 33, 40, 72, 103

Y

Yamaha
DSP Factory 13

y4

Zero-Crossing 174
ZoomIn 34, 100
Zoom Out 34, 100
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