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Chapter 1
Getting started
Welcome to the FileMaker® Server  application for Windows and 
Mac OS from FileMaker, Inc. FileMaker Server gives you enhanced 
database hosting capabilities on your network when used with the 
FileMaker Pro database management application. 

Note   If you use FileMaker Server 8 with other FileMaker products, 
those other FileMaker products must be version 7 or 8.

Using this manual 
This Administrator’s Guide provides instructions for installing 
FileMaker Server, migrating FileMaker Server from the previous 
version, preparing database files for hosting, and describes features 
for maintaining FileMaker databases. You may need to refer to 
FileMaker Server Help for information on more advanced product 
features.

This guide assumes you’re familiar with general database concepts as 
well as the basics of FileMaker Pro. (If you’re not, refer to the 
FileMaker Pro User’s Guide for more information.)

This guide uses “FileMaker Pro” to refer to both FileMaker Pro and 
FileMaker Pro Advanced, unless describing specific FileMaker Pro 
Advanced features.

Online Help 
FileMaker Server Help provides detailed step-by-step instructions on 
FileMaker Server features. You can open Help from the Help menu in 
the FileMaker Server Admin application.
Using FileMaker Server documentation
The following manuals are included:

1 FileMaker Server Administrator’s Guide (this manual): contains 
key concepts and basic procedures

1 FileMaker Guide to Updating Plug-ins: describes how 
FileMaker Server Auto Update can download the most current plug-
in to FileMaker Pro database client computers

The following manuals only apply to FileMaker Server Advanced 
licensed customers:

1 FileMaker Server Advanced Web Publishing Installation Guide: 
describes how to install and register the Web Publishing Engine and 
associated tools

1 FileMaker Server Advanced Custom Web Publishing Guide: 
describes how to develop custom web publishing solutions using 
XML or XSLT on FileMaker Server Advanced

1 FileMaker Instant Web Publishing Guide: describes how to make 
FileMaker Pro databases accessible to web browser users over an 
intranet or the Internet

1 Installing FileMaker ODBC and JDBC Client Drivers: describes 
how to install the drivers needed to access a FileMaker data source via 
ODBC and JDBC

1 FileMaker ODBC and JDBC Developer’s Guide: describes 
concepts and details to help you share FileMaker data with other 
applications using ODBC and JDBC
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The following manuals are available at www.filemaker.com/
downloads:

1 Converting FileMaker Databases from Previous Versions: 
contains information about converting databases from previous 
versions to FileMaker Pro 7 format

1 FileMaker Security Guide: describes security concerns to keep in 
mind when using FileMaker products

Where to find PDF documentation
Most PDF manuals are located in the folder where you installed 
FileMaker Server. If you performed the default installation of 
FileMaker Server in the default folder location, the PDF manuals are 
located here:

Windows: \Program Files\FileMaker\FileMaker Server\English 
Extras\Electronic Documentation

Mac OS: [hard disk]/Applications/FileMaker Server 8/English 
Extras/Electronic Documentation

Note   PDF manuals for FileMaker Server Advanced are located in the 
folder where you installed FileMaker Server Advanced.

To view the PDF files, you need a PDF reader. In Mac OS, you can use 
either the built-in Preview application or Adobe® Reader®. Windows 
users need Adobe Reader. If you do not have Adobe Reader, you can 
download it from the Adobe web site at www.adobe.com. 

Important   You can download PDFs of FileMaker documentation (and 
any updates) by choosing Help menu > Downloads and Updates 
(Mac OS) or accessing the “FileMaker web resources” topics in 
FileMaker Server Help (Windows).

All of the PDF files use the tagged Adobe Portable Document format 
(PDF). Tagged PDF files work with assistive technology such as the 
screen readers JAWS for Windows and Window-Eyes. For more 
information about tagged PDF files, see the Adobe web site at 
www.adobe.com. 
FileMaker Server web resources
For resources such as white papers and technical articles, see 
www.filemaker.com/server. 

Registration and customer support
Please take the time to register your product during installation, 
through the FileMaker web site at www.filemaker.com/register, or by 
choosing Help menu > Register Now in FileMaker Server Admin 
(Mac OS), or opening FileMaker Server Help and using the 
registration link within the “Register now” topic (Windows).

For information about technical support and customer service, see:

www.filemaker.com (North American customers)  
www.filemaker.com/intl (customers outside North America)

or choose Help menu > FileMaker on the Web (Mac OS), or the 
“FileMaker web resources” topics in FileMaker Server Help 
(Windows). At the web site, you will find the service options available 
to North American customers, as well as links to FileMaker 
worldwide sites, answers to frequently asked questions, and access to 
the TechInfo Knowledge Base. If you do not have access to the web, 
please refer to the FileMaker Service Directory included in the 
software box. North America customers can also call (800) 965-9090 
to learn about the service options available.
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About the license key
FileMaker software comes with a unique, 35-character-string license 
key. Do not lose this license key; it cannot be replaced. We 
recommend that you keep the license key in a safe place in case the 
software ever needs to be reinstalled.

You can find license keys in your volume license agreement, or in one 
of these documents in your product box:

1 Service Directory, License Keys, and Proof of Purchase

1 License Key Information

Important   You must enter the license key during installation or the 
software will not install. 

The license key ensures adherence to the single user license 
agreement, which generally allows for use of one (1) copy of the 
Software on a single computer at a time (refer to your Software 
License). If the license key is invalid or if another copy of the 
application installed with that same license key is running on the 
network, the FileMaker Server application displays an error message 
and does not start.

To install FileMaker Server on multiple computers, you must have a 
unique license key for each installation, or obtain a volume license. 
You must license one copy of FileMaker Server for each computer.
Updating the FileMaker Server license
If you want to upgrade from a trial version of FileMaker Server, or 
from FileMaker Server to FileMaker Server Advanced, you must 
update your FileMaker Server license key.

To update the FileMaker Server license:

1. In FileMaker Server Admin, connect to the FileMaker Server that 
you want to update:

1 Windows: In the Console Root, click the FileMaker Server node 
and choose Action menu > Connect to FileMaker Server. Then click the 
server you just connected to and choose Action menu > Update 
FileMaker Server License.

1 Mac OS: Choose Server menu > Connect to FileMaker Server, select 
the server, then click Connect.

2. In the Update FileMaker Server License dialog box (Windows) or 
the Update FileMaker License area of the Summary view (Mac OS), 
enter the information required, then click Update (Windows) or Update 
License (Mac OS).
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Introducing FileMaker Server
FileMaker Server is a dedicated database server that opens 
FileMaker Pro files and makes them available to clients on your 
network. FileMaker Server uses advanced client-server technology to 
take care of much of the background work associated with managing 
files, thus enhancing performance for clients accessing those files.

Clients include:

1 FileMaker 7 and FileMaker 8 users

1 FileMaker Server 8 Web Publishing Engine clients

1 FileMaker ODBC (open database connectivity) and JDBC (Java 
database connectivity) clients

Your copy of FileMaker Server supports one of the following client 
configurations:

1 FileMaker Server: 

1 up to 250 FileMaker Pro clients

1 up to 125 hosted databases

1 FileMaker Server Advanced: 

1 up to 250 FileMaker Pro clients

1 up to 125 hosted databases

1 up to a total of 100 Custom Web Publishing and Instant Web 
Publishing sessions

1 up to a total of 50 ODBC and JDBC clients

1 FileMaker Server Option Pack: 

1 adds Custom Web Publishing, Instant Web Publishing, and 
ODBC and JDBC client support to FileMaker Server, to the limits 
described for FileMaker Server Advanced.
How does FileMaker Server work?
FileMaker Server has two primary components: an administration 
application called FileMaker Server Admin, and the services 
(Windows) or daemons (Mac OS) that comprise FileMaker Server.

FileMaker Server
The FileMaker Server application is a tool to use with FileMaker Pro 
in a network environment to:

1 Enhance database client performance.

1 Increase the number of FileMaker Pro clients who can connect to a 
file hosted by FileMaker Server. 

1 Increase the number of files that can be hosted.

When you start FileMaker Server, it automatically opens and hosts 
FileMaker Pro files that have the appropriate extended privileges 
enabled and are located in the Databases folder:

Windows: Program Files\FileMaker\FileMaker Server\Data\Databases\

Mac OS: [hard disk]/Library/FileMaker Server/Data/Databases/

FileMaker Server also opens databases in the first level of subfolders, 
and, optionally, an additional folder that you specify. This folder 
structure lets you easily set up the database files that you want 
FileMaker Server to host on the network.

You can publish files hosted by FileMaker Server Advanced on the 
Internet or on a company’s intranet. For more information about web 
publishing, see the FileMaker Instant Web Publishing Guide or the 
FileMaker Server Advanced Custom Web Publishing Guide.
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Keep in mind the following points about the different uses of 
FileMaker Server and FileMaker Pro:

1 Use FileMaker Server to open and host FileMaker Pro files that 
you want to make available to FileMaker Pro clients on your network.

1 Use FileMaker Pro to create database files and to enable the 
extended privileges necessary for sharing with FileMaker Server. 
Then host the database files on FileMaker Server. Use FileMaker Pro 
to modify the structure of existing hosted databases (for example, to 
set up accounts and privileges for each hosted file). 

The FileMaker Server Admin application
FileMaker Server Admin is an application in the Mac OS, and a 
console in Windows. It lets you easily configure and administer 
FileMaker Server, work with and monitor hosted databases and 
clients, and track statistical information.

Console  
Root

Details  
Pane

Scope  
Pane

FileMaker Server Admin (Windows)
FileMaker Server Admin can be run on the same computer where 
FileMaker Server is running (locally). Or, if FileMaker Server has 
been configured to allow remote administration, FileMaker Server 
Admin can be installed and run on a Windows or Mac OS networked 
computer in order to administer one or more FileMaker Servers 
installed on other Windows or Mac OS computers in the same 
network. 

When administering FileMaker Server, you can:

1 Configure FileMaker Server application properties.

1 Open—or host—a FileMaker Pro database file, making it available 
to clients on the network.

1 View information about the files being hosted, like the number of 
clients accessing each database.

1 Send messages to connected clients.

1 Close a hosted FileMaker Pro database, making it unavailable to 
clients.

FileMaker Server Admin (Mac OS)
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1 Disconnect a selected client from all hosted databases.

1 Pause or resume hosted databases.

1 Create scheduled tasks to back up hosted databases.

1 View system events and event logs.

1 Start or stop FileMaker Server.

Using FileMaker Server in your network
FileMaker Server works with the following networking technologies:

1 Multiple interface cards: FileMaker Server works with your 
network operating system’s ability to utilize multiple network 
interface cards (NICs). You can use multiple NICs and IP address 
aliases to provide your clients better access to hosted databases.

1 LDAP: You can use a LDAP (Lightweight Directory Access 
Protocol) directory service to centrally manage your hosted databases 
by registering FileMaker Server with your directory service.

1 Domain controllers: You can use a domain controller to centrally 
manage group accounts that determine client access privileges to 
hosted databases.

1 Encryption: FileMaker Server can be configured for encrypting 
client data for secure data transfers between the client and hosted 
databases. FileMaker Server uses the Secure Sockets Layer (SSL) of 
your network protocol to encrypt and decrypt the data.
New features
In addition to providing reliability and performance improvements, 
FileMaker Server 8 supports both FileMaker 7 and FileMaker 8 
clients.

Note   FileMaker Server 8 is required for full support of all new 
FileMaker Pro 8 features, including complex finds and new 
calculation functions.

For information on this feature See

Migration tools to help you upgrade 
from FileMaker Server 7 to FileMaker 
Server 8

Chapter 2, “Migrating FileMaker 
Server from the previous version”

The Mac OS event log fields are now 
tab-delimited, and there are two new 
fields: event ID and level of severity 
(Error, Warning, or Information)

“Logging FileMaker Server events” 
on page 38

As FileMaker Server opens files that 
were not closed properly or have not 
been opened in a FileMaker 8 product, 
FileMaker Server performs a 
consistency check on each file and logs 
the result of the check in the event log

“Step 4. Verify databases are 
available to FileMaker clients” on 
page 28

The sample database 
(FMServer_Sample.fp7) has extended 
privileges enabled for use with Instant 
Web Publishing and ODBC/JDBC

“Verifying your installation” on 
page 22

Improved functionality in the Client 
Connections assistant for configuring 
FileMaker Server Advanced

FileMaker Server Advanced Custom 
Web Publishing Guide

Improved web publishing support in 
FileMaker Server Advanced

FileMaker Server Advanced Custom 
Web Publishing Guide

Improved ODBC and JDBC applications 
support in FileMaker Server Advanced

FileMaker ODBC and JDBC 
Developer’s Guide
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Migrating FileMaker Server from the previous version
If you are new to FileMaker Server, skip this chapter and proceed 
directly to chapter 3, “Installing FileMaker Server.”

FileMaker Server 8 provides two tools, Back Up Settings and Restore 
Settings, to help you move your preferences and schedules from a 
default installation of FileMaker Server 7 to a FileMaker Server 8 
installation on the same computer using the same configuration. 

If you have a license for FileMaker Server 8 Advanced, there are 
separate Back Up Settings and Restore Settings tools to help you save 
and transfer your Web Publishing Engine settings. For more 
information, see the FileMaker Server Advanced Web Publishing 
Installation Guide.

Important   If you have a license for FileMaker Server 7 Advanced and 
intend to upgrade to FileMaker Server 8 Advanced, plan to do the 
installations for FileMaker Server 8 and FileMaker Server 8 
Advanced in the same session.

Read this first
The steps listed below provide an overview of the migration process. 
See the remaining sections for more information about each step.

It is important to do the migration steps in the order they are presented. 
If you omit steps or don’t follow the sequence, FileMaker Server may 
not work properly or you may have to reconfigure your FileMaker 
Server settings manually.

1. Stop the FileMaker Server 7 service (Windows) or daemon 
(Mac OS) and FileMaker Server 7 Helper service (Windows) or 
daemon (Mac OS).

2. Make a copy of any database files, script files, and plug-ins you 
used with FileMaker Server 7. 
3. Save your FileMaker Server 7 settings using the Back Up Settings 
tool.

4. Uninstall FileMaker Server 7.

5. Install FileMaker Server 8.

6. Move your backed up FileMaker Server 7 settings to FileMaker 
Server 8 using the Restore Settings tool.

7. Move any database files, script files, and plug-ins you used with 
FileMaker Server 7 to the proper folders within the FileMaker Server 
8 folder structure.

8. Confirm that migration was successful.

Note   If the FileMaker Server Web Publishing Engine is installed on 
the same computer as FileMaker Server, run the Web Publishing 
Engine migration tools.

Step 1. Stop FileMaker Server 
You must first stop the FileMaker Server service (Windows) or 
daemon (Mac OS) and the FileMaker Server Helper service 
(Windows) or daemon (Mac OS), then quit FileMaker Server Admin.

See “Stopping FileMaker Server (Windows)” on page 46 or 
“Stopping FileMaker Server (Mac OS)” on page 47.
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Step 2. Make a copy of databases, scripts, and 
plug-ins
You must make a copy of any database files, script files, and plug-ins 
you used with FileMaker Server 7. After you run the Restore Settings 
tool, you will have to move these files to the new locations within the 
FileMaker Server 8 folder structure. 

In a default FileMaker Server 7 installation, database files, script files, 
and plug-ins are stored in the following folders:

Database files
Windows: \Program Files\FileMaker\FileMaker Server 7\Data\
Databases

Mac OS: [hard disk]/Library/FileMaker Server 7/Data/Databases/ 

Server plug-ins
Windows: \Program Files\FileMaker\FileMaker Server 7\Extensions\
Plugins\ 

Mac OS: [hard disk]/Library/FileMaker Server 7/Extensions/Plugins/

Plug-ins to be updated automatically on client machines
Windows: \Program Files\FileMaker\FileMaker Server 7\Data\
Databases\AutoUpdate\

Mac OS: [hard disk]/Library/FileMaker Server 7/Data/Databases/
AutoUpdate/

Command files (Windows) or shell scripts (Mac OS)
Windows: \Program Files\FileMaker\FileMaker Server 7\Data\
Scripts\ 

Mac OS: [hard disk]/Library/FileMaker Server 7/Data/Scripts/
Step 3. Save your settings 
If you want to save your FileMaker Server 7 preferences and 
schedules, you must use the Back Up Settings tool before you 
uninstall FileMaker Server 7. 

Note   To run the Back Up Settings tool you must use a login account 
with administrative privileges.

1. Insert the FileMaker Server 8 CD into the CD or DVD drive.

2. Double-click the Back Up Settings icon.

3. Mac OS: Enter your Mac OS authentication passphrase and click 
OK.

4. Click OK to quit the Back Up Settings tool.

Step 4. Uninstall FileMaker Server 7 
Note   After you have saved your FileMaker Server 7 settings you can 
uninstall FileMaker Server 7. 

Important

1 Before removing FileMaker Server from your computer, be sure to 
stop the FileMaker Server 7 Helper and FileMaker Server 7 services 
(Windows) or daemons (Mac OS), and exit FileMaker Server Admin. 
See “Step 1. Stop FileMaker Server” on page 13.

1 If you didn’t back up your settings in step 3, the uninstallation 
process will delete them, and you won’t be able to use the Restore 
Settings tool.
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Uninstall FileMaker Server 7 (Windows)
To remove FileMaker Server 7 from a computer:

1. Start Windows.

2. Choose the Start button > Control Panel > Add or Remove Programs.

3. Select FileMaker Server 7 from the list, and click Remove.

You may see a message that some files or folders could not be deleted. 
You will have to move those files or folders to the new location after 
restoring your settings (preferences and schedules).

Uninstall FileMaker Server 7 (Mac OS)
Note   The uninstaller for FileMaker Server 7 is provided on the 
FileMaker Server 8 CD.

To remove FileMaker Server 7 from a computer:

1. Insert the FileMaker Server 8 CD into the CD or DVD drive.

2. Double-click the FileMaker Server 7 Uninstaller icon.

3. Enter your Mac OS authentication passphrase and follow the on-
screen instructions.

4. Click Uninstall.

You may see a message that some files or folders could not be deleted. 
You will have to move those files or folders to the proper location 
after restoring your settings (preferences and schedules).

5. Click OK, then Quit.
Step 5. Install FileMaker Server 8
Note   To install FileMaker Server you must use a login account with 
administrative privileges.

See “Installing FileMaker Server (Windows)” on page 19 or 
“Installing FileMaker Server (Mac OS)” on page 20.

Step 6. Restore your settings
After you have saved your FileMaker Server 7 settings and installed 
FileMaker Server 8, you can use the Restore Settings tool to move 
your FileMaker Server 7 preferences and schedules to FileMaker 
Server 8.

Note   To run the Restore Settings tool you must use a login account 
with administrative privileges.

1. If you selected Automatic in the Startup Configuration panel in the 
Installer, you should first stop the FileMaker Server services 
(Windows) or daemons (Mac OS).

See “Stopping FileMaker Server (Windows)” on page 46 or 
“Stopping FileMaker Server (Mac OS)” on page 47.

2. Insert the FileMaker Server CD into the CD or DVD drive.

3. Double-click the Restore Settings icon.

4. Mac OS: Enter your Mac OS authentication passphrase.

5. Click OK to quit the Restore Settings tool.

6. Restart the FileMaker Server services (Windows) or daemons 
(Mac OS). 
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Step 7. Move files to the proper location
After you have restored your FileMaker Server 7 settings, you must 
move any database files, script files, and plug-ins you used with 
FileMaker Server 7 to the proper folders within the FileMaker Server 
8 folder structure.

See “Step 2. Place database files in the proper location” on page 26, 
“Default folders for plug-in files” on page 49, and “Default folders for 
script files” on page 56.

Step 8. Complete your migration
After you have moved any database files, script files, and plug-ins you 
used with FileMaker Server 7 to the proper location, confirm that the 
software is working successfully.

1. Start FileMaker Server Admin and start the FileMaker Server 8 
services (Windows) or daemons (Mac OS) if you stopped them prior 
to using the Restore Settings tool.

See “Starting FileMaker Server (Windows)” on page 45 or “Starting 
FileMaker Server (Mac OS)” on page 46.

2. Verify that your databases are open. See “Verifying your 
installation” on page 22. It may take several minutes to open a large 
file.

Note   As FileMaker Server opens files that were not closed properly 
or have not been opened in a FileMaker 8 product, FileMaker Server 
performs a consistency check on these files and logs the result of the 
check in the event log. 

3. Verify that your preferences and schedules are correct, especially 
the file and folder paths.
For FileMaker Server Advanced users 
If the FileMaker Server Web Publishing Engine is installed on the 
same computer as FileMaker Server, it is important to run the Web 
Publishing Engine Back Up Settings and Restore Settings tools.

For more information, see the FileMaker Server Advanced Web 
Publishing Installation Guide.



Chapter 3
Installing FileMaker Server
This chapter provides step-by-step instructions for installing 
FileMaker Server, FileMaker Server Admin, and associated files on a 
computer running Windows or Mac OS.

Important   If you are upgrading from FileMaker Server 7, first read 
chapter 2, “Migrating FileMaker Server from the previous version.”

If you’re installing FileMaker Server Advanced software, installation 
instructions for the Web Publishing Engine and ODBC and JDBC 
support are described in the following manuals:

1 FileMaker Server Advanced Web Publishing Installation Guide

1 Installing FileMaker ODBC and JDBC Client Drivers

Hardware and software requirements
FileMaker Server should be run on a dedicated computer reserved for 
use as a database server. When FileMaker Server is hosting many 
clients or a large number of database files, it uses a high level of 
processor, hard disk, and network capacity. Other processor-intensive 
applications (for example, web server or disk backup software) or 
heavy network traffic on the same computer will cause 
FileMaker Server to run more slowly and degrade the performance of 
FileMaker Pro on client computers.

Notes

1 Avoid installing FileMaker Server on a computer that is a user’s 
primary workstation or network file server. 

1 Do not enable the operating system (OS) file sharing feature on the 
computer running FileMaker Server, or use OS file sharing to share 
FileMaker Pro files. 
1 You cannot run two different versions of FileMaker Server on the 
same computer at the same time.

1 You must disable Access Control Lists in order to install the 
product. After installing, do not use ACL file permissions to control 
access to any FileMaker file. For more information, see the 
documentation that came with your operating system software.

Windows requirements

Minimum requirements for 1-50 clients
1 Intel-compatible PC with a Pentium III 1GHz or Xeon processor

1 256 MB of installed RAM (1 GB or more recommended)

1 Windows Server 2003 Standard Edition (with Service 
Pack 1),Windows 2000 Server (with Service Pack 4), or Windows XP 
Professional SP 2 operating system

1 hard disk with at least 1 GB of available disk space. Be sure to 
allow additional space for the database files you intend to host, which 
must be located on the same disk as the FileMaker Server application.

1 login account with administrative privileges for installing 
FileMaker Server

1 CD or DVD drive
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Minimum requirements for more than 50 clients
1 Intel-compatible PC with a Pentium 4 or Xeon processor

1 512 MB of installed RAM (1 GB or more recommended)

1 Windows Server 2003 Standard Edition (with Service Pack 1) or 
Windows 2000 Server (with Service Pack 4) operating system

1 hard disk with at least 1 GB of available disk space. Be sure to 
allow additional space for the database files you intend to host, which 
must be located on the same disk as the FileMaker Server application.

1 login account with administrative privileges for installing 
FileMaker Server

1 CD or DVD drive

Networking requirements (Windows)
To share files among users on a network, you need to have the 
following additional software and hardware installed on the host 
computer running FileMaker Server:

1 Windows compatible network card

1 the software driver for your network card

1 TCP/IP network protocol

Note   Because some DHCP servers cycle IP addresses, FileMaker 
recommends using a static IP address.
Mac OS requirements

Minimum requirements for 1-50 clients
1 Power Mac G4 500 MHz

1 256 MB of installed RAM (1 GB or more recommended)

1 Mac OS X (10.3.9 or 10.4), or Mac OS X Server (10.3.9 or 10.4)

1 hard disk with at least 1 GB of available disk space. Be sure to 
allow additional space for the database files you intend to host, which 
must be located on the same disk as the FileMaker Server application.

1 login account with administrative privileges for installing 
FileMaker Server

1 CD or DVD drive

Minimum requirements for more than 50 clients
1 Power Mac G4 1 GHz

1 512 MB of installed RAM (1 GB or more recommended)

1 Mac OS X Server (10.3.9 or 10.4)

1 hard disk with at least 1 GB of available disk space. Be sure to 
allow additional space for the database files you intend to host, which 
must be located on the same disk as the FileMaker Server application.

1 login account with administrative privileges for installing 
FileMaker Server

1 CD or DVD drive

Networking requirements (Mac OS)
1 TCP/IP network protocol

Note   Because some DHCP servers cycle IP addresses, FileMaker 
recommends using a static IP address.
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Important note about supported operating systems
At the time this book was written, FileMaker, Inc. tested 
FileMaker Server with the Windows and Mac OS operating systems 
listed above. These are the minimal requirements; the software may 
also work with later versions certified by FileMaker.

About FileMaker Server Advanced and web publishing 
support
You can install the Web Publishing Engine and its associated software 
components on the same computer as FileMaker Server, or on one or 
two separate host computers, depending on your needs. Web 
publishing requires more server resources and may also require the 
use of more powerful computers, especially when all of the software 
components are installed on a single computer. For more information, 
see the FileMaker Server Advanced Web Publishing Installation 
Guide.

Installing FileMaker Server (Windows)
Note   If you have FileMaker Server 7, you must uninstall it before you 
can install FileMaker Server 8. See “Uninstall FileMaker Server 7 
(Windows)” on page 15.

If you are upgrading from the FileMaker Server 8 Trial, see “Updating 
the FileMaker Server license” on page 9.

This installation procedure describes how to install the 
FileMaker Server application and associated files. FileMaker Server 
Admin is also installed with this procedure.

By default, the Setup program creates a folder named Program Files\
FileMaker\FileMaker Server. FileMaker recommends you install to 
the default folder.
To install FileMaker Server:

1. Insert the FileMaker Server CD into the CD or DVD drive.

2. Double-click setup.exe.

3. Choose the installation language. Click OK.

You see the Welcome screen of the FileMaker Server Setup Wizard.

4. Click Next and follow the on-screen instructions.

5. Select an option for FileMaker Server start-up, then click Next and 
follow the on-screen instructions. 

Note   The FileMaker Server Helper service is set to automatically 
start whether you choose Automatic or Manual. The Helper is needed 
to start the Server service from FileMaker Server Admin when 
FileMaker Server is not set to start automatically. 

6. When installation completes, you see a Product Registration panel. 
You can register online, or by letter or fax.

After installation, you must either restart the computer or start the 
FileMaker Server service manually the first time. For more 
information, see “Starting FileMaker Server (Windows)” on page 45. 
Thereafter, FileMaker Server will start when you restart the computer.

Select If 

Automatic You want FileMaker Server to start whenever Windows starts.

Manual You want FileMaker Server to start only after you start the 
FileMaker Server service in the Services console.
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Installing FileMaker Server Admin only (Windows)
This installation procedure describes how to custom install the 
FileMaker Server Admin application and supporting files. You should 
use this procedure only to install FileMaker Server Admin on a 
networked computer. The FileMaker Server application is not 
installed.

To install FileMaker Server Admin only:

1. Insert the FileMaker Server CD into the CD or DVD drive of the 
computer you intend to use for remote administration.

2. Double-click setup.exe.

3. Choose the installation language. Click OK.

You see the Welcome screen of the FileMaker Server Setup Wizard.

4. Click Next and follow the on-screen instructions.

5. In the Setup Type panel, click Custom, then click Next.

6. Click FileMaker Server Admin, then click Next.

7. When installation completes, you see a Product Registration panel. 
You can register online, or by letter or fax.

Uninstalling FileMaker Server (Windows)
To remove FileMaker Server from a computer:

1. Start Windows.

2. Stop the FileMaker Server services and exit FileMaker Server 
Admin.

For more information, see “Stopping FileMaker Server (Windows)” 
on page 46.
3. Choose the Start button > Control Panel > Add or Remove Programs.

4. Select FileMaker Server from the list, and click Remove.

Your database files, script files, and plug-ins are not deleted.

Installing FileMaker Server (Mac OS)
Note   If you have FileMaker Server 7, you must uninstall it before you 
can install FileMaker Server 8. See “Uninstall FileMaker Server 7 
(Mac OS)” on page 15.

If you are upgrading from the FileMaker Server 8 Trial, see “Updating 
the FileMaker Server license” on page 9.

This installation procedure describes how to install the 
FileMaker Server application and associated files. FileMaker Server 
Admin is also installed with this procedure. 

The installer creates two folders, one named FileMaker Server in the 
[hard disk]/Library folder and one named FileMaker Server 8 in the 
[hard disk]/Applications folder. See “FileMaker Server folders in 
Mac OS” on page 52 for more information on these folders.

Important   FileMaker Server must be installed locally on Mac OS. 
You cannot install FileMaker Server over a network.

To install FileMaker Server:

1. Insert the FileMaker Server CD into the CD or DVD drive. 

You see the CD window. If you see only the disc icon, double-click 
the icon to open its window.

2. Double-click the FileMaker Server 8 installer icon.
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3. Enter your Mac OS authentication passphrase and follow the on-
screen instructions.

You see the FileMaker Server installer dialog box.

4. Click Install.

5. Choose the startup configuration. Click OK. 

Note   The FileMaker Server Helper daemon is set to automatically 
start whether you choose Automatic or Manual. The Helper is needed 
to start the Server daemon from FileMaker Server Admin when 
FileMaker Server is not set to start automatically. 

6. Follow the on-screen instructions.

7. When installation completes, you see a Product Registration panel. 
You can register online, or by letter or fax.

After installation, you must either restart the computer or start the 
FileMaker Server service manually the first time. For more 
information, see “Starting FileMaker Server (Mac OS)” on page 46. 
Thereafter, FileMaker Server will start when you restart the computer.

Installing FileMaker Server Admin only (Mac OS)
This installation procedure describes how to custom install the 
FileMaker Server Admin application and supporting files. You should 
use this procedure only to install FileMaker Server Admin on a 
networked computer. The FileMaker Server application is not 
installed.

The installer creates a folder called FileMaker Server 8 in the [hard 
disk]/Applications folder. 

Select If

Automatic You want FileMaker Server to start whenever Mac OS starts.

Manual You want FileMaker Server to start only after you start the 
FileMaker Server daemon using FileMaker Server Admin. 
To install FileMaker Server Admin only:

1. Insert the FileMaker Server CD into the CD or DVD drive. 

You see the CD window. If you see only the disc icon, double-click 
the icon to open its window.

2. Double-click the FileMaker Server 8 installer icon.

3. Choose Custom Install from the pop-up menu.

4. Click Install and follow the on-screen instructions.

5. When installation completes, you see a Product Registration panel. 
You can register online, or by letter or fax.

Uninstalling FileMaker Server (Mac OS)
Note   Before removing FileMaker Server from your computer, be 
sure to stop the FileMaker Server Helper and FileMaker Server 
daemons, and quit FileMaker Server Admin.

To remove FileMaker Server from a computer:

1. Insert the FileMaker Server CD into the CD or DVD drive. 

You see the CD window. If you see only the disc icon, double-click 
the icon to open its window.

2. Double-click the FileMaker Server 8 installer icon.

3. Enter your Mac OS authentication passphrase and follow the on-
screen instructions.

You see the FileMaker Server installer dialog box.

4. Choose Uninstall from the pop-up menu.
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5. Click Uninstall.

Your database files, script files, and plug-ins are not deleted.

6. Click Quit.

Configuring the firewall to allow FileMaker 
ports
When running FileMaker Server in an environment that uses a 
firewall, be sure to configure the firewall to allow the ports used by 
FileMaker. Restart your computer after configuring the firewall.

Windows: When FileMaker Server Admin is started when the firewall 
is on, an alert is displayed. Click Unblock to launch FileMaker Server 
Admin.

Port usage and remote administration
The best method for remote administration outside the administrator’s 
physical network is to keep your firewall in place and use a secure 
mechanism to connect to your network, such as a virtual private 
network (VPN) or secure dial-in. Use the FileMaker Server Admin 
tool to administer FileMaker Server on a remote computer once you 
are securely connected to your network. 

Important   FileMaker does not recommend using the remote 
administration feature to administer FileMaker Server if you cannot 
use a VPN or remote dial-in to access your network securely. 

Port number Used by

5003 FileMaker Pro and FileMaker Server for hosting files

50003 FileMaker Server service (Windows) or daemon (Mac OS)

50006 FileMaker Server Helper service (Windows) or daemon 
(Mac OS)
Verifying your installation
Before you configure FileMaker Server you should verify that:

1 your copy has been installed and is working correctly

1 the sample database (FMServer_Sample.fp7) is usable from a 
client computer

FileMaker Server installs a pre-configured sample database as part of 
a typical installation. The database FMServer_Sample.fp7 is located 
in the Sample folder within the default Databases folder  
(/FileMaker Server/Data/Databases/Sample/FMServer_Sample.fp7). 
It is opened automatically when FileMaker Server is launched.You 
can close and remove this database after you have verified that 
FileMaker Server is functioning correctly.

To verify that FileMaker Server is functioning correctly:

1. Start FileMaker Server. Depending on the option you chose on 
installation, FileMaker Server either launches automatically or must 
be launched manually. See “Starting FileMaker Server (Windows)” 
on page 45, or “Starting FileMaker Server (Mac OS)” on page 46, for 
more information.

2. Start the FileMaker Server Admin application. 

1 Windows: Choose the Start button > Programs > FileMaker 
Server Admin.

1 Mac OS: Double-click the FileMaker Server Admin icon in the 
Applications/FileMaker Server 8/ folder.

3. Windows: Select FileMaker Server in the Console Root and choose 
Action menu > Connect to FileMaker Server. 

Mac OS: Choose Server menu > Connect to FileMaker Server.
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4. From the pop-up menu at the top of the Connect to FileMaker 
Server dialog box, choose Local Servers, Favorite Servers, or Servers 
Listed by LDAP. 

If you are using FileMaker Server Admin on the same computer that 
is running FileMaker Server, you can choose (localhost) in the Favorite 
Servers view.

For a remote Server, add the IP address to Favorite Servers. You can 
select a Server from the Local Servers list and click Add to Favorites to 
add it to the Favorite Servers list. 

In the Servers Listed by LDAP list, you see the FileMaker Servers that 
have the Register FileMaker Server with a directory service property 
enabled.

5. Select the FileMaker Server you want to administer, then click 
Connect.

6. Type a user name and password, if you are prompted to enter them.

7. Select the Databases node (Windows) or click the Databases button 
(Mac OS). 

8. The FMServer_Sample.fp7 database should be listed as Normal in 
the Status column.
To verify that the database is usable from a client computer:

1. Launch FileMaker Pro or FileMaker Pro Advanced.

2. Choose File menu > Open Remote.

3. Select Local Hosts from the View menu, and choose your server 
from the list. The name of the sample database should appear in the 
column on the right.

4. If your server is not on your local network, you can enter the 
network file path directly in the Open Remote dialog box by typing 
fmnet:/hostIPAddress/FMServer_Sample.fp7, where 
hostIPAddress is the IP address of your server.

5. If you can open the sample database, your copy of 
FileMaker Server is installed correctly.

Close the sample database, and quit FileMaker Pro.

If you cannot open the sample database, review the previous steps and 
see the troubleshooting topics in FileMaker Server Help for more 
suggestions.
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Chapter 4
Hosting databases
Read this first
Before you can share FileMaker Pro database files, it’s important to 
prepare your files for hosting. The steps listed below provide an 
overview of the process. See the remaining sections for more 
information about each step.

1. Edit the accounts and privileges sets that clients will use for shared 
access.

2. Put the FileMaker Pro database files in the proper location.

3. For files that will be shared from Mac OS, change the files to 
belong to the fmsadmin group. To edit databases shared from 
Mac OS, files should also have group read and write access enabled.

4. Verify that your files are listed as opened (status is Normal) in the 
FileMaker Server Admin Databases view, and verify that they are 
available to FileMaker clients.

Converting databases to the current format
You must convert databases created in FileMaker Pro 6 and earlier to 
FileMaker Pro 7 format. FileMaker Pro 7 and FileMaker Pro 8 share 
the same file format. For information about converting databases to 
FileMaker Pro 7 format, see Converting FileMaker Databases from 
Previous Versions, available as a PDF file from www.filemaker.com/
downloads.
Step 1. Edit accounts and privilege sets
In FileMaker Pro, edit the accounts and privilege sets that clients will 
use for shared access to each database. Choose File menu > Define > 
Accounts & Privileges.

Enable the appropriate extended privileges for particular privilege 
sets. Every account assigned to a privilege set with extended 
privileges will be able to access the database through the protocol 
associated with an extended privilege (for example, Access via 
FileMaker Network). 

For more information on accounts, privilege sets, and extended 
privileges, see the FileMaker Pro User’s Guide. 

FileMaker Pro Define Accounts & Privileges dialog box, Extended Privileges tab
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Enable the privilege to Disconnect user from FileMaker Server when idle 
to disconnect idle users from FileMaker Server for each account (or 
keep them connected), as necessary. 

For more information on setting the length of time a user must be idle 
before being disconnected, see “Setting the maximum time allowed 
for idle FileMaker Pro clients” on page 33. 

If your organization uses a server to centrally manage authentication 
for users and groups, FileMaker Server can use that server as an 
authenticator to manage database access if you have defined External 
Server account types in the database. For more information on 
authenticating via an external server for FileMaker Pro accounts, see 
FileMaker Pro Help and www.filemaker.com/server. 

FileMaker Pro Edit Privilege Set dialog box
Step 2. Place database files in the proper 
location
Place the FileMaker Pro files that you want FileMaker Server to open 
in the folders:

Windows: Program Files\FileMaker\FileMaker Server\Data\
Databases\

Mac OS: [hard disk]/Library/FileMaker Server/Data/Databases/

Notes

1 FileMaker Server will also automatically open files located in the 
first level of subfolders within these folders.

1 FileMaker Server folder names no longer include the version 
number, except the Mac OS folder named FileMaker Server 8 in the 
[hard disk]/Applications folder.

You can also place the files in an additional database folder. For more 
information, see “Specifying an additional database folder” on 
page 36.

Up to 125 FileMaker Pro database files can be automatically opened 
when FileMaker Server starts up.

Mac OS: FileMaker recommends adding the .fp7 filename extension 
to all hosted databases. Although this extension is not necessary for 
databases used on the Mac OS, the .fp7 extension is necessary for 
databases used on Windows.

For information on placing script files in the proper folders, see 
“Default folders for script files” on page 56. For information on 
placing plug-ins in the proper folders, see “Default folders for plug-in 
files” on page 49.
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Step 3. Change group ownership for files 
(Mac OS)
FileMaker Server and all database files, plug-ins, and scripts must be 
configured with the correct privileges and permissions to function 
properly in Mac OS.

By default, only the user account that installed FileMaker Server in 
Mac OS can manually operate FileMaker Server from the command 
line, add files to or remove files from the FileMaker Server folder, and 
access any of the FileMaker Pro databases stored within the 
FileMaker Server default databases and database backup folders. All 
users, however, can access the FileMaker Server Admin application.

Other user accounts and database files can be manually added to the 
fmsadmin group using the Mac OS NetInfo Manager or Terminal 
application. This task must be performed by a user with administrative 
privileges.

For more information on Mac OS permissions, see “About file system 
permissions” on page 52.

Changing file permissions for database files hosted by FileMaker 
Server
In Mac OS, all database files hosted by FileMaker Server must belong 
to the fmsadmin group and have read and write access enabled. 

To change the group and permissions for a database:

1. Move the database files to the folder [hard disk]/Library/FileMaker 
Server/Data/Databases/ or the optional additional database folder.

2. In the Finder, select the first database file, and choose File menu > 
Get Info.

3. Expand the Ownership & Permissions area of the Get Info dialog 
box, and the Details area, if necessary.

4. If necessary, click the lock icon to unlock the permissions pop-up 
menus, and enter your account’s password at the prompt.

5. For Group, select fmsadmin.
6. For group Access, select Read & Write.

7. Close the Get Info dialog box.

8. Repeat steps 2–7 for each database in the folder.

Adding a user to the fmsadmin group using the NetInfo Manager 
application
Note   If you’re using Mac OS X Server, you can use the Workgroup 
Manager administration tool to add users to the fmsadmin group.

To add an existing user of the system to the fmsadmin group after 
installation, do the following:

1. Launch the NetInfo Manager application ([hard disk]/
Applications/Utilities/NetInfo Manager).

2. Select groups in the second column (labeled “/”).

3. Select fmsadmin in the groups column.

4. Select users in the properties pane, located in the bottom half of the 
NetInfo Manager window.

5. Click the lock button at the bottom of the window and enter an 
administrative password.

6. Choose Directory menu > Insert Value.

7. Enter the login account name of the user you are adding.

8. To save changes, choose Domain menu > Save Changes.

9. Click Update this copy to confirm your changes.

10. Choose NetInfo Manager menu > Quit NetInfo Manager.

Important   Caution should be taken when making changes with 
NetInfo Manager. See the Apple support web site for more 
information about Mac OS permissions.
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Step 4. Verify databases are available to 
FileMaker clients 
To verify that databases were opened when FileMaker Server started 
and are available to FileMaker clients, check that:

1 the status of files listed in the Databases view is Normal

1 you can open remote files in FileMaker Pro

To check the status of files listed in the Databases view:

1. Connect to a server. See “Connecting to FileMaker Server using 
FileMaker Server Admin” on page 48 for more information.

2. In FileMaker Server Admin, select the Databases node (Windows) 
or click the Databases button (Mac OS). 

When FileMaker Server starts, it automatically opens and hosts all 
FileMaker Pro databases located in the default database folder and in 
an additional database folder, if specified. Those databases should be 
listed as Normal in the Status column. 

If you added files to the default database folder after startup, those 
files are listed as Closed and you must open them manually.

3. If the status of a database is Closed, select the database, then choose 
Action menu > Open (Windows) or Action menu > Databases > Open 
Database (Mac OS).
It may take several minutes to open a large file. As FileMaker Server 
opens files that were not closed properly or have not been opened in a 
FileMaker 8 product, FileMaker Server performs a consistency check 
on each file and logs the result of the check in the event log.

You can also open a database at the command prompt (Windows) or 
Terminal (Mac OS). See “Using the command line to automate tasks” 
on page 54 for more information. 

Tip   If a folder containing databases is closed, double-click the folder. 
If databases are not visible, it may be necessary to refresh the 
Databases view. Select the Databases node (Windows) or click the 
Databases button (Mac OS), then choose Action menu > Refresh 
(Windows) or Action menu > Databases > Refresh View (Mac OS). 

To verify that a database is usable from a client computer:

1. Launch FileMaker Pro or FileMaker Pro Advanced.

2. Choose File menu > Open Remote.

3. Select Local Hosts from the View menu, and choose your server 
from the list. The name of the database should appear in the column 
on the right.

If the database is not listed, review the preceding hosting steps.
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Administering hosted databases
After you are connected to FileMaker Server, you can view 
information about hosted databases by selecting Databases in the 
Console Root (Windows) or by selecting the Databases button 
(Mac OS). From the list of databases, you can select one file or one 
folder for the following administrative tasks:

1 view database details 

1 open and close selected databases

1 pause and resume selected databases

1 send messages to clients accessing hosted databases

1 disconnect clients from hosted databases

Tip   With no database or folder selected, some commands operate on 
all databases.

For more information, see “The FileMaker Server Admin application” 
on page 11.

Viewing hosted databases 
The Databases view shows database folders and files located on the 
FileMaker Server computer. Each folder can be opened to view a list 
of database files in each folder. 

You can view a list of the database files hosted by FileMaker Server, 
regardless of which folder in which they are located, by selecting 
Databases > Files in the Console Root (Windows) or Action menu > 
Databases > Hide Folders (Mac OS). 

You can view detailed information about hosted files and the clients 
that are currently connected to them. For each hosted database, you 
see:

1 the name of the file

1 the number of clients connected to it

1 file status
From the list, you can select one or all clients in order to:

1 send messages to clients

1 disconnect clients

Mac OS: You can sort information in columns by clicking the column 
heading that includes a triangle in the heading.

Listing current clients
You can list FileMaker Pro and FileMaker Pro Advanced clients 
connected to the hosted database files by selecting Console Root > 
Clients (Windows) or the Clients button (Mac OS).

The Clients list shows detailed information about the clients that are 
currently connected to hosted databases. 

For each client, you can display:

1 client account names

1 client computer names

1 client network addresses

1 timestamp (date and time) of when the connection began

1 number of files the client is currently connected to

Sending messages to FileMaker Pro clients 
You can send a message to all FileMaker Pro clients by choosing 
Action menu > Send Message to All (Windows) or Action menu > 
Clients > Send Message to All Clients (Mac OS). If you select a single 
client from the Clients view, the message is sent only to that client.

Another way of sending messages to clients is by scheduling a Send 
Message task. For more information, see chapter 7, “Scheduling 
administrative tasks.”
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Disconnecting clients 
Disconnect a client from a hosted database by selecting Action menu > 
Disconnect All Clients (Windows) or Action menu > Clients > Disconnect 
All Clients from Server (Mac OS). If you select a client from the Clients 
view, only the selected client is disconnected.

You can send the client a message in addition to the standard 
FileMaker Pro message (the default).

The selected client sees a notification dialog box with your message 
requesting that the client disconnect from the server.

When the set time elapses, FileMaker Server disconnects the client 
and the client’s name disappears from the Clients view.

Closing hosted files 
Close a database and disconnect any clients accessing it by choosing 
Action menu > Close (Windows) or Action menu > Databases > Close 
Database (Mac OS).

You can send the client a message in addition to the standard 
FileMaker Pro message (the default).

Clients see a notification dialog box with your message requesting that 
they close their connection to a file. When the set time elapses, 
FileMaker Server disconnects any remaining clients and closes the file 
or files in the folder. 

Closing many databases, a large database file, or a file with many 
connected clients may take several minutes. 

Tip   You can close files from the command prompt (Windows) or the 
Terminal (Mac OS). See “Using the command line to automate tasks” 
on page 54 for more information.
Enabling Auto Update for plug-ins
If the database solutions you will host on FileMaker Server use plug-
ins, you can enable the Auto Update plug-in preference in each 
FileMaker Pro client to automatically install or update required or 
outdated plug-ins. 

To automatically update a plug-in or support file, the required file 
must be installed on FileMaker Server and the Auto Update feature 
must be enabled in FileMaker Pro and on FileMaker Server. See 
“Allowing FileMaker Pro clients to download updates automatically” 
on page 33 and the FileMaker Guide to Updating Plug-ins. 

Plug-ins installed on FileMaker Server (Mac OS) must also be owned 
by the group fmsadmin and have group read and executable 
permissions. For more information, see “Using FileMaker Server in 
Mac OS” on page 52.
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Configuring FileMaker Server
Use the FileMaker Server Admin application to configure FileMaker 
Server for optimal performance. Windows users can also use the 
configuration assistants to set up server properties. Use the Properties 
dialog box (Windows) or Configure view (Mac OS ) for access to the 
complete set of configuration settings.

Note   This chapter provides an overview of the configuration settings 
that are available. For detailed step-by-step procedures about 
configuring FileMaker Server, see FileMaker Server Help.

Using the configuration assistants (Windows)
In Windows, FileMaker Server provides configuration assistants to 
help you set up server properties. You can use the associated 
Properties dialog box to change settings, if needed. The configuration 
assistants are Client Connections, Security, Database Hosting, 
Administration, Directory Service, and Task Scheduling.

To access the configuration assistants:

1. Choose the Start button > Programs > FileMaker Server Admin.

You see the FileMaker Server Administration console.

2. Connect to the server you want to work with.

3. Click one of the icons in the Details Pane to start an assistant or 
select host, then choose Action menu > Assistants.
Configuring client connections
In FileMaker Server Admin, connect to the server you want to work 
with. 

Windows: Configure client properties in the Client Connections 
assistant or select a server and then choose Action menu > Properties > 
Clients tab.

FileMaker Server Properties dialog box, Clients tab
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Mac OS: To configure client properties, choose View menu > 
Configure, then click the Clients tab.

Setting the maximum number of clients
You can specify the maximum number of FileMaker Pro clients that 
can be simultaneously connected to FileMaker Server.

Note   The memory requirements of FileMaker Server and 
FileMaker Server Advanced are directly related to the number of 
clients and open files. If you specify large values for these, you should 
also increase the amount of RAM reserved for the database cache. See 
“Changing the amount of memory used by FileMaker Server” on 
page 34 for more details.

Setting the maximum number of FileMaker Server Advanced clients
If you own FileMaker Server Advanced, you can enable ODBC and 
JDBC data source connections and FileMaker Web Publishing Engine 
sessions. The Web Publishing Engine sessions option and the Server 
Advanced Settings options are only available with FileMaker Server 
Advanced.

FileMaker Server Configure view, Clients tab
Setting the number of combined FileMaker Pro and ODBC/JDBC 
connections
If you have FileMaker Server Advanced, you can specify the number 
of simultaneous FileMaker Pro and ODBC/JDBC clients allowed to 
access FileMaker Server.

Setting the number of Web Publishing Engine sessions
If you have FileMaker Server Advanced, you can specify the 
maximum number of simultaneous web browser sessions connecting 
through the FileMaker Server Web Publishing Engine.

Tip   If you monitor client usage over time and notice you rarely have 
more than a certain number of each type of client active at one time, 
set these options to allow only a few more than that number for best 
performance on your server.

FileMaker Server Advanced Properties dialog box, Clients tab



Chapter 5  |  Configuring FileMaker Server     33
Enabling ODBC and JDBC connections
You can use FileMaker Server Advanced to host a FileMaker database 
file as a data source, sharing your data with other applications using 
ODBC and JDBC.

For information on installing drivers, see Installing FileMaker ODBC 
and JDBC Client Drivers.

For information on configuring FileMaker Server Advanced for 
ODBC and JDBC, see the FileMaker ODBC and JDBC Developer’s 
Guide.

Enabling the xDBC plug-in
The xDBC plug-in is installed with the rest of the product, but you 
must enable the plug-in before you can share data with other 
applications using ODBC and JDBC.

See FileMaker Server Help for more information.

Registering the Web Publishing Engine
You can allow a Web Publishing Engine access to hosted databases by 
registering it with FileMaker Server. The Web Publishing Engine 
server is registered in FileMaker Server by an identifier text string and 
a passcode.

For information about installing and configuring the Web Publishing 
Engine, see the FileMaker Server Advanced Web Publishing 
Installation Guide.

Setting the maximum time allowed for idle FileMaker Pro 
clients
You can specify the length of time that FileMaker Pro clients can be 
idle in any database hosted by FileMaker Server before they are 
disconnected. Because clients who are disconnected have to reopen 
the file, you should make sure the idle time is long enough to avoid 
frequent disconnections.
Note   In FileMaker Pro, you can enable a privilege to disconnect a 
client connected to FileMaker Server when the client is idle. When 
this privilege is enabled, FileMaker Pro disconnects the client from 
FileMaker Server. For more information about privileges, see the 
FileMaker Pro User’s Guide.

Allowing FileMaker Pro clients to download updates 
automatically
You can store plug-in files on the FileMaker Server computer and 
allow FileMaker Pro clients to download these files automatically 
when they open database files hosted by FileMaker Server. Examples 
of files you can download automatically are plug-in license files, 
sometimes required by FileMaker Pro databases.

When a FileMaker Pro file is hosted by FileMaker Server, any plug-
ins required by the file must exist on each client computer used to open 
the database. By allowing plug-in updates to be downloaded 
automatically, you ensure that all clients have access to plug-ins 
required by a database the first time they attempt to open it. In 
addition, when plug-ins are changed by database developers, you can 
store new versions on the FileMaker Server computer, so you don’t 
have to update plug-ins on client computers.

For automatic file downloading to work correctly, you must place 
current plug-in files in the following folders:

Windows: Program Files\FileMaker\FileMaker Server\Data\
Databases\AutoUpdate\

Mac OS: [hard disk]/Library/FileMaker Server/Data/Databases/
AutoUpdate/
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In addition, enable the Auto Update plug-in in FileMaker Pro 
preferences before attempting to open hosted files that require plug-
ins.

Note   FileMaker Pro can check the version of plug-in files required by 
a hosted database and update plug-ins if the current version is not 
located on the client computer. For more information about 
downloading plug-ins automatically, see the FileMaker Server Guide 
to Updating Plug-ins.

Setting database properties
Windows: Change database properties in the Database Hosting 
assistant or select host and then choose Action menu > Properties > 
Databases tab.

Mac OS: To change database properties, choose View menu > 
Configure, then click the Databases tab.
Setting the maximum number of files
You can specify the maximum number of database files 
FileMaker Server can host at one time. If you consistently monitor 
database usage, you can set the maximum number of files for best 
performance on your server. For information on performance and 
optimizing memory settings, see Help.

Changing the amount of memory used by FileMaker Server 
Use Reserve n MB of RAM for database cache to specify a cache size for 
FileMaker Server. Increasing the RAM reserved for the database 
cache can speed up overall performance for a correctly designed 
database, especially if your server hosts large files or a large number 
of clients or files.

For information on performance and optimizing memory properties, 
see Help.

Setting the cache flushing distribution interval
In FileMaker Server, the cache is constantly being flushed. The cache 
flushing routine scans the cache, looking for pages that have changed. 
FileMaker Server inspects up to 1/60th of the cache and writes any 
changed pages it discovers to the disk. The process repeats 
continuously, writing 1/60 of the cache to disk every second, even 
during scheduled backups.

For example, in a 64MB cache, FileMaker Server will inspect up to  
1/60th of the cache, or a little more than a megabyte, and flush all of 
the changed records it finds. It will then wait a second and begin again, 
inspecting up to 1/60th of the cache, looking for changed records. This 
method of flushing the cache distributes writing to the hard disk over 
the span of a minute. 
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By default, the cache flush mechanism will attempt to scan the entire 
cache in a minute. In most cases this means all cached changes on the 
server will be no more than one minute old, although database size and 
hard disk speed can affect these results.

To change this behavior and spread the cache flushing over a longer 
period of time, select Distribute cache flush over (hh:mm). Unsaved 
changes in FileMaker Server will be no older than the interval you 
specify. FileMaker Server reduces the amount of data to inspect every 
second to a smaller value, down to 128k per second. 

This property determines how much cache is flushed each second. 
Before deciding to change this property the administrator must 
balance cache size against the risk of data loss in the event of a 
computer failure. Locations that require maximum performance and 
are less concerned about the potential for lost data can use a longer 
cache flush distribution interval, while locations that want maximum 
data integrity should use a smaller cache flush distribution interval.

For example, if the value is set to 10 minutes with a 64MB cache, the 
engine will inspect 1/600th of the cache each second, or about 110K 
of cache, (less than the minimum, so the engine will actually inspect 
128K of cache) and write only the changed data to disk. However, if 
this interval is set to 10 minutes with a 500 MB cache, it will only 
inspect 853K as opposed to the default value of 1/60th of the cache, or 
8.5 MB. Used this way, the server can distribute its disk writing over 
time, and therefore allow the server CPU a higher priority to service 
client requests, as it will take much less time to inspect 853K 
compared to 8.5MB.
Opening runtime solutions automatically
Runtime solutions are database files created in FileMaker Pro 
Advanced that are typically used with a dedicated, “bound” copy of 
the FileMaker Pro application. If you host runtime database solutions 
created by FileMaker Pro Advanced, you can enable FileMaker Server 
to automatically open runtime solutions when FileMaker Server 
starts, provided runtime solutions are stored in one of the designated 
locations. See “Starting FileMaker Server (Windows)” on page 45 for 
more information.

If the runtime solutions do not have .fp7 filename extensions, you 
must register their filename extensions in FileMaker Server.

Windows: Configure runtime solution properties in the Database 
Hosting assistant or select host and then choose Action menu > 
Properties > Runtime Solutions tab.

Mac OS: To configure runtime solution properties, choose View 
menu > Configure, then click the Runtime Solutions tab.
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Specifying additional database and default 
backup folders
Windows: Change default folder properties in Action menu > 
Properties > Default Folders tab.

Mac OS: To change default folder properties, choose View menu > 
Configure, then click the Default Folders tab.
On startup, FileMaker Server looks in the default database folder as 
well as an optionally specified additional database folder for databases 
to host. In each of these locations, FileMaker Server will only open 
files at the root level and in folders one level down.

Specifying an additional database folder
Specify the path to an additional folder for hosting databases.

Specifying the default backup folder
Specify the path to a folder to be used by FileMaker Server when a 
Back Up Database scheduled task runs. See “Scheduling 
administrative tasks” on page 55 for more information.

Important   Do not put the default backup folder in the same folder as 
the databases to be hosted, or in a subfolder within that folder, because 
any databases in that folder are automatically opened when FileMaker 
Server starts.

Setting administrative properties
Windows: Configure administrative properties in the Administration 
assistant or select host and then choose Action menu > Properties > 
Administration tab.
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Mac OS: To configure administrative properties, choose View menu > 
Configure, then click the Administration tab.

Specifying a custom server name
For the computer running FileMaker Server, you can specify a server 
name that’s different from the name registered by the operating 
system.When you define a custom name, FileMaker Pro clients see 
this new name when they open the Open Remote File dialog box. The 
custom name is also displayed when connecting using FileMaker 
Server Admin. 

Authenticating the administrator
FileMaker Server Admin can be protected by requiring:

1 a password for access

1 the administrator be a member of an administrative group account 
called fmsadmin on the system where FileMaker Server is running 

Note   Unless Allow remote users to administer FileMaker Server is 
enabled, the settings apply only to local users on the system running 
FileMaker Server.

Important   If you require a password or authentication for security 
reasons, also remember to restrict access to the server computer. Do 
not put the computer in an unsecured room.
Enabling remote administration
Using the FileMaker Server Admin application, you can remotely 
control, or administer, FileMaker Server from a different computer 
than the one on which FileMaker Server is installed and hosting 
databases. Select Allow remote users to administer FileMaker Server to 
enable remote administration.

Important   You enable remote administration only with the FileMaker 
Server Admin application installed on the same computer as 
FileMaker Server. You can disable remote administration from a 
remote computer.

After you enable remote administration, you can use FileMaker 
Server Admin on a remote computer to configure FileMaker Server 
properties, view a list of hosted databases, view the clients using them, 
and monitor performance statistics. You can also send messages to 
clients, disconnect clients, and open or close hosted databases 
remotely. 

Recording usage statistics and setting log file 
size limits
Windows: Configure log file properties in the Administration assistant 
or select host and then choose Action menu > Properties > Logging tab.
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Mac OS: To configure log file properties, choose View menu > 
Configure, then click the Logging tab.

Controlling the collection of usage statistics
Use Collect and update usage statistics every n (mm:ss) to set the 
statistics collection interval. FileMaker Server writes this information 
to a log file.

When you enable statistical logging for FileMaker Server, a log file is 
created in the FileMaker Server/Data/Logs/ folder. 

You can view these statistics by opening the Stats.log file in any 
application that can read tab-delimited data (FileMaker Pro, a 
spreadsheet, or a text editor) or the Console application (Mac OS). 
You can also view real-time usage statistics in the Statistics view of 
FileMaker Server Admin.

Note   The Console application on the Mac OS allows you to view a 
.log file while also displaying updates to that file.

For information on the types of statistics that are collected in the 
statistics log, see “Viewing usage statistics for FileMaker Server” on 
page 50.

Operating 
system

Statistics 
log name View log in

Windows Stats.log 1 Performance Logs and Alerts (Windows 2000 
Server)

1 System Monitor (Windows Server 2003)

Mac OS Stats.log 1 The Console application

1 Any application that can read tab-delimited data
Managing log files
When Stats.log reaches its maximum size, FileMaker Server renames 
it Stats-old.log and creates a new Stats.log.

Displaying statistics
In Windows, you can chart real-time statistics for various aspects of 
FileMaker Server performance. See “Monitoring server performance 
(Windows)” on page 50.

Logging FileMaker Server events
Events that occur while FileMaker Server is running are logged and 
timestamped. Typical events that are logged include FileMaker Server 
starting and stopping, database files opening and closing, clients 
logging in and out, scheduled tasks running, and changes to FileMaker 
Server properties. 

In Windows, events are logged in the Windows Application Log. For 
more information, see “Viewing activities in the Event Viewer 
(Windows)” on page 51. In the Mac OS, events are logged in the tab-
delimited Event.log file that is created in the FileMaker Server/Data/
Logs/ folder. When this file reaches 40 MB, it is renamed Event-
old.log and a new Event.log file is created. For more information, see 
“Viewing activities in the Event.log (Mac OS)” on page 51.

Configuring the Event Viewer (Windows)
You can configure the Event Viewer log files to overwrite event 
information, because the default setting is to stop recording events 
when the log files become full. If you have many databases open with 
many users accessing them, and if you flush the cache often, the log 
files could fill up quickly and the information in the log files could 
quickly become out of date.

You can configure the Event Viewer log files by selecting the log file 
in the Console Root and choosing Action menu > Properties. 
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You can increase the Maximum Log Size setting from the default 
512 KB, depending on how much FileMaker Server activity you 
anticipate on your server computer. You can also select Overwrite 
Events as Needed to continue logging events after the log file is full.

Configuring a directory service
Windows: Change properties in the Directory Service assistant or select 
host and then choose Action menu > Properties > Directory Service tab. 
Mac OS: To change properties, choose View menu > Configure, then 
click the Directory Service tab.

If your organization uses a Lightweight Directory Access Protocol 
(LDAP)-compliant directory service, such as Microsoft Active 
Directory, Netscape Directory, OpenLDAP, or Open Directory 
(Mac OS X10.4), you can centrally manage your hosted databases by 
registering FileMaker Server with your directory service.

When FileMaker Server is registered with an LDAP-compliant 
directory service, its server name and IP address are published to the 
directory service. The FileMaker Server administrator’s contact 
information can also be published.
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Registering FileMaker Server with a directory service
Your system administrator should be able to give you the information 
you need to complete the required directory service settings. 

1 Specifying the login settings

Choose from the following options for user authentication.

See “Authenticating client log in” on page 41 for more information.

1 Publishing your contact information to your directory service

As the FileMaker Server administrator, you can publish your name, 
location, phone number, and email address to your directory service. 
This is useful if the directory service administrator needs to contact 
you (for example, if hosted databases are unavailable for client 
access). 

Windows: Click the Options button to access these fields.

1 Changing the port number 

The port number setting indicates the type of the port required by your 
directory service. Some LDAP-compliant directory services use a port 
number other than the default, 389.

Windows: Click the Advanced button to change the LDAP port 
number.

Choose To

Use Windows 
Authentication

Use the account name and password of a Windows 
domain to access Microsoft Active Directory

Log on as current user Log on using the current Windows account, if Use 
Windows Authentication is selected.

Log on anonymously Log on without specifying an account name and password. 
(This option is not available if Use Windows Authentication 
is selected.)

Log on using account Log on using the account name and password you specify
Setting FileMaker Server security
Use the Security tab to configure client authentication, filter the 
display of database files, and enable secure connections to FileMaker 
Server.

Windows: Configure FileMaker Server security with the Security 
assistant or select host and then choose Action menu > Properties > 
Security tab.

Mac OS: To configure FileMaker Server security, choose View menu > 
Configure, then click the Security tab.
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Defining groups for use with security features (Windows)
If you are serving files that use External Server accounts, in order to 
use administrator authentication, client authentication, or to filter the 
display of database files for local or domain users, you must:

1. Define a group on the local system or domain controller. See 
Windows Help for more information on defining groups.

Important   For administrator authentication, this account must be 
named fmsadmin. 

2. Assign to this group the user accounts that will use external server 
authentication.

Authenticating client log in
Client access to hosted databases is determined by accounts defined in 
FileMaker Pro. You can choose how FileMaker Pro clients are 
authenticated when they connect to databases hosted by FileMaker 
Server.

If you choose FileMaker accounts only, the clients’ access privileges are 
determined by the accounts defined in the hosted databases.

If you choose FileMaker and External Server Accounts, the clients’ 
access privileges are determined by the accounts defined in the hosted 
databases and by accounts that are set up on the same computer as 
FileMaker Server (locally) or on an authentication server such as 
Mac OS X Server or a Windows Domain server. This allows you to 
use your existing authentication server to control access to databases 
without having to manage an independent list of accounts in each 
hosted database file. See “Creating accounts that authenticate via an 
external server” in FileMaker Pro Help and www.filemaker.com/
server for more information.

Windows: If you choose FileMaker and External Server Accounts, 
records of all logon attempts are logged in the Windows Security Log. 
For more information about the Security Log, see your Windows 
documentation.
To prevent clients from viewing or modifying data, scripts, and 
layouts in FileMaker Pro, create a privilege set in each of the hosted 
files in FileMaker Pro. See “Protecting databases with accounts and 
privilege sets” in FileMaker Pro Help for more information.

Filtering the display of files
You can limit the list of FileMaker Server-hosted databases displayed 
in FileMaker Pro to only those databases that each client can access. 
If you choose Display only the databases each user is authorized to 
access, the list of databases displayed is determined by the client’s 
access privileges to each hosted database. If you choose Display all 
databases, all FileMaker Server hosted databases are displayed to the 
client.

Note   This setting only affects the display of databases hosted by 
FileMaker Server. Databases hosted peer-to-peer using 
FileMaker Pro are not affected.

Securing connections to FileMaker Server
To protect sensitive data, you can encrypt data passed between 
FileMaker Server and clients. If Secure connections to FileMaker Server 
is enabled, all FileMaker Server client connections use the Secure 
Sockets Layer, except ODBC and JDBC connections. For more 
information about data security, see the FileMaker Security Guide.

Important   Secure connections are slower because of data encryption. 
Data transfer rates are affected by the number of clients and the amount 
of data transferred.

Note   Restart FileMaker Server if the secure connections property is 
changed.
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Protecting files with accounts and privileges
It is important to use the access privileges in FileMaker Pro when files 
are shared on a network. Using FileMaker Pro, you can restrict what 
users see and do in a database file by defining accounts and privilege 
sets. Accounts authenticate clients who are attempting to open a 
protected file. Privilege sets specify a level of access to the database 
file, limiting what clients can do with the layouts and fields they can 
see.

Important   Protect shared FileMaker Pro files by using FileMaker Pro 
accounts and privilege sets. Although the shared FileMaker Pro files 
can reside on a file server, which may have its own security scheme, 
any files available to FileMaker Pro clients bypass network and file 
server protection. For more information about protecting files, see the 
FileMaker Pro User’s Guide or FileMaker Pro Help.

Restoring FileMaker Server default settings 
To restore all default settings, uninstall and reinstall FileMaker Server. 
For more information, see chapter 3, “Installing FileMaker Server.”

How FileMaker Server behaves during 
system sleep or abnormal shutdown
Windows supports Power Conservation mode, which can cause the 
server computer to sleep (hibernate or enter Standby mode). This 
suspends access to hosted databases. 

Mac OS computers can suspend operation when they enter an energy-
saving system sleep state.

FileMaker Inc. recommends that you disable sleep mode on 
computers running FileMaker Server.
To prevent your system from sleeping:

1 Windows: Clear Enable hibernation in the Power options control 
panel on the computer running FileMaker Server. 

1 Mac OS: Disable system sleep in the Energy Saver pane by setting 
the slider control to Never in the Put the computer to sleep when it is 
inactive for area. 

If sleep is enabled on the computer running FileMaker Server, it’s 
important to understand how FileMaker Server reacts, if the computer 
enters sleep mode:

1 If there are no clients connected to hosted files when the operating 
system notifies FileMaker Server that it is going to sleep, 
FileMaker Server flushes the cache to disk and leaves hosted 
databases open. Because the cache is saved to disk before the 
computer sleeps, hosted databases experience no data loss and are 
opened when the operating system wakes up.

Note   Database backups or scripts scheduled in FileMaker Server do 
not run while the operating system is sleeping.

1 If there are clients connected to FileMaker Server when the 
operating system notifies FileMaker Server that it is going to sleep, 
FileMaker Server responds to the operating system, instructing that it 
should not sleep while FileMaker Server is running.

If the operating system shuts down unexpectedly while clients are 
connected and before the cache can be written to disk (for example, 
because the battery is critically low, the computer is overheating, or a 
user turns off the server computer in an emergency), FileMaker Server 
attempts to recover the state of hosted files when it restarts. As it opens 
the files in the default database folder and the additional database 
folder, FileMaker Server performs a consistency check on each file. If 
a file is found to be corrupt, FileMaker Server logs a corruption event 
in the Application Log (Windows) or Event.log (Mac OS). 
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Whenever FileMaker Server restarts after sleep or a forced shutdown, 
you should always check the Application Log (Windows) or Event.log 
(Mac OS) for database corruption notifications. For more information 
about viewing the events, see “Viewing activities in the Event Viewer 
(Windows)” or “Viewing activities in the Event.log (Mac OS)” on 
page 51.

Also, check your scheduled tasks to ensure that important backups or 
scripts were not scheduled to run while the operating system was 
asleep or off. These tasks will not run until the next scheduled time 
when FileMaker Server is running and the operating system is awake.
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Chapter 6
Administering FileMaker Server
This chapter provides information about starting and stopping 
FileMaker Server, monitoring FileMaker Server events, statistics and 
performance, enabling plug-ins, and using FileMaker Server in 
Mac OS.

Starting FileMaker Server (Windows)
FileMaker Server running in Windows has two primary components: 
an administration application called FileMaker Server Admin, and the 
services that comprise FileMaker Server. 

If you didn’t choose to start FileMaker Server automatically during 
Windows startup or if you stopped FileMaker Server, you can start it 
again manually.

To start the FileMaker Server service locally:

1. Choose the Start button > Programs > FileMaker Server Admin.

2. Expand the Windows Administrative Tools node in the Console 
Root.

3. Select Services (Local). 

4. Select FileMaker Server 8 in the Details Pane.

5. Choose Action menu > Start.

Starting the FileMaker Server service also starts the FileMaker Server 
Helper service.

To start the FileMaker Server service on a remote computer:

1. Choose the Start button > Programs > FileMaker Server Admin.

2. Choose Action menu > Connect to FileMaker Server.
3. In the Connect to FileMaker Server dialog box, enter the IP address 
for the remote server for Address at the bottom of the dialog box, or 
select Favorite Servers from the menu at the top of the dialog box.

Note   You must have previously saved the server’s IP address as a 
Favorite Server. 

4. Select the Server you want to connect to.

If you don’t see the server you want, the FileMaker Server Helper 
Service may not be running. The FileMaker Server Helper service 
must be running on the remote computer and the Allow remote users to 
administer FileMaker Server preference must be enabled.

5. Click Connect.

You see the following message:

“FileMaker Server [server name] [IP address] is not running. Would 
you like to start FileMaker Server and then connect?” 

6. Click Yes.

The FileMaker Server Helper service must be running for an 
administrator to connect to FileMaker Server. If it is not running, you 
see a message that you can’t connect.

FileMaker Server opens the FileMaker Pro files for access by 
FileMaker Pro clients on the network. For information about starting 
the FileMaker Server service from the command prompt, see “Using 
the command line to automate tasks” on page 54.
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Notes

1 You can make a shortcut for FileMaker Server Admin, but not for 
the FileMaker Server application.

1 Typically, FileMaker Server is automatically started when the 
computer is started. This can be specified during installation or with 
the Service Property dialog box.

Stopping FileMaker Server (Windows)
Stopping the FileMaker Server service disconnects all FileMaker Pro 
clients, closes all database files hosted by FileMaker Server, and 
disconnects all instances of FileMaker Server Admin. This process 
works only on a connected server and may take several minutes.

To stop the FileMaker Server service locally:

1. Choose the Start button > Programs > FileMaker Server Admin.

2. Expand the Windows Administrative Tools node in the Console 
Root.

3. Select Services (Local). 

4. Select FileMaker Server 8 in the Details Pane.

5. Choose Action menu > Stop.

You see a message informing you that Windows is attempting to stop 
FileMaker Server on the local computer. 

To stop the FileMaker Server service on a remote computer:

1. Choose the Start button > Programs > FileMaker Server Admin.

2. Connect to the FileMaker Server that you want to stop.

3. Choose Action menu > Stop FileMaker Server.
4. You see a message asking for confirmation that you want to stop 
FileMaker Server.

5. Click Yes.

If you have large files or files with many connected clients, the 
stopping process may take several minutes. If you encounter 
problems, try disconnecting clients. For more information see 
“Disconnecting clients” on page 30. Also try closing hosted files. For 
more information see “Closing hosted files” on page 30.

Notes

1 Quitting FileMaker Server Admin does not stop the FileMaker 
Server service.

1 Stopping the FileMaker Server service does not stop the FileMaker 
Server Helper service.

1 Clients are requested to close the files hosted by FileMaker Server.

Starting FileMaker Server (Mac OS)
FileMaker Server running in the Mac OS has two primary 
components: an administration application called FileMaker Server 
Admin, and the daemons (UNIX processes with no interface) that 
comprise FileMaker Server.

To start the FileMaker Server daemon locally:

1. In FileMaker Server Admin, choose Server menu > Local FileMaker 
Server Administration. 

2. Click the lock.

3. At the prompt, enter an OS-level user name and password. 

The account must have administrative privileges.

4. Click Start FileMaker Server Processes.

Both the FileMaker Server and FileMaker Server Helper daemons 
start. 
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To start the FileMaker Server daemon on a remote computer:

Note   The FileMaker Server Helper daemon must be running on the 
remote computer and the Allow remote users to administer FileMaker 
Server preference must be enabled.

1. In FileMaker Server Admin, choose Server menu > Connect to 
FileMaker Server.

2. Select the Server you want to connect to.

3. In the Connect to FileMaker Server dialog box, with no item 
selected in the Favorite Servers list, click Add to Favorites. 

4. Double-click FileMaker Server in the list, then type the hostname.

5. Double-click Address/Hostname, then type the IP address. 

6. Click Connect.

You see the following message:

“FileMaker Server [server name] [IP address] is not running. Would 
you like to start FileMaker Server and then connect?” 

7. Click Yes.

FileMaker Server opens the FileMaker Pro files for access by 
FileMaker Pro clients on the network. For information about starting 
the FileMaker Server service from the command prompt, see “Using 
the command line to automate tasks” on page 54.

Notes

1 Mac OS: You can use the Activity Monitor application to see if 
FileMaker Server or FileMaker Server Helper is running. Use fms as 
the process filter. See Mac OS Help for more information.

1 You can make an alias for FileMaker Server Admin, but not for the 
FileMaker Server application.

1 Typically, FileMaker Server is automatically started when the 
computer is started. This can be specified during installation or with 
the Local FileMaker Server Administration dialog box.
Stopping FileMaker Server (Mac OS)
Stopping the FileMaker Server daemon disconnects all FileMaker Pro 
clients, closes all database files hosted by FileMaker Server, and 
disconnects all instances of FileMaker Server Admin. This process 
works only on a connected server and may take several minutes.

To stop the FileMaker Server and FileMaker Server Helper daemons 
locally:

1. In FileMaker Server Admin, choose Server menu > Local FileMaker 
Server Administration.

2. Click the lock.

3. At the prompt, enter an OS-level user name and password. 

Note   The account must have administrative privileges.

4. Click Stop FileMaker Server Processes.

5. Both the FileMaker Server and FileMaker Server Helper daemons 
stop. 

To stop the FileMaker Server daemon (locally or on a remote 
computer):

1. Connect to the FileMaker Server you intend to stop using 
FileMaker Server Admin.

2. In FileMaker Server Admin, choose Server menu > Stop FileMaker 
Server.

You see a message asking for confirmation that you want to stop 
FileMaker Server.

3. Click Yes.

If you have large files or files with any connected clients, the stopping 
process may take several minutes. If you encounter problems, try 
disconnecting clients. For more information see “Disconnecting 
clients” on page 30. Also try closing hosted files. For more 
information see “Closing hosted files” on page 30.
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Notes

1 Quitting FileMaker Server Admin does not stop the FileMaker 
Server daemon.

1 Stopping the FileMaker Server daemon does not stop the 
FileMaker Server Helper daemon.

1 Clients are requested to close the files hosted by FileMaker Server.

Overview of starting and stopping FileMaker 
Server using FileMaker Server Admin

Mac OS X Windows

Start 
FileMaker 
Server

Locally:

1 Server menu > Local FileMaker 
Server Administration > Start 
FileMaker Server Processes 
button

Starts fmserver and Helper 
daemons

1 Server menu > Connect to 
FileMaker Server

This starts the fmserver daemon 
if the Helper daemon is already 
running

Locally:

1 Services (Local) node

Starts fmserver and Helper 
services

1 Action menu > Connect to 
FileMaker Server

This starts the fmserver 
service if the Helper service is 
already running

On a remote computer:

1 Server menu > Connect to 
FileMaker Server

Starts fmserver daemon if the 
Helper daemon is running 
remotely and the Allow remote 
users to administer FileMaker 
Server preference is enabled

On a remote computer:

1 Action menu > Connect to 
FileMaker Server

Starts fmserver service if the 
Helper service is running 
remotely and the Allow remote 
users to administer FileMaker 
Server preference is enabled
Connecting to FileMaker Server using 
FileMaker Server Admin
After you have started FileMaker Server, you can connect to it locally 
or remotely using FileMaker Server Admin.

To connect to FileMaker Server:

1. Start FileMaker Server Admin. 

Windows: Choose the Start button > Programs > FileMaker Server 
Admin.

Mac OS: Double-click the FileMaker Server Admin icon in the 
Applications/FileMaker Server 8/ folder.

2. Windows: Select FileMaker Server in the Console Root and choose 
Action menu > Connect to FileMaker Server. 

Mac OS: Choose Server menu > Connect to FileMaker Server.

Stop 
FileMaker 
Server

Locally:

1 Server menu > Local FileMaker 
Server Administration > Stop 
FileMaker Server Processes 
button

Stops the fmserver and Helper 
daemons

Locally:

1 Services (Local) node

Select the fmserver service to 
stop only the fmserver 
service. Select the Helper 
service to stop both services. 

On a remote computer:

1 Server menu > Stop 
FileMaker Server. Click Yes.

Stops only the fmserver daemon 
on the server to which you are 
connected through FileMaker 
Server Admin

On a remote computer:

1 Action menu > Stop 
FileMaker Server

Stops only the fmserver 
service on the server to which 
you are connected through 
FileMaker Server Admin

Mac OS X Windows
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3. From the pop-up menu at the top of the Connect to FileMaker 
Server dialog box, choose Local Servers, Favorite Servers, or Servers 
Listed by LDAP. 

If you are using FileMaker Server Admin on the same computer that 
is running FileMaker Server, you can choose (localhost) in the Favorite 
Servers view.

For a remote Server, add the IP address to Favorite Servers. You can 
select a Server from the Local Servers list and click Add to Favorites to 
add it to the Favorite Servers list. 

In the Servers Listed by LDAP list, you see FileMaker Servers that have 
the Register FileMaker Server with a directory service property enabled.

4. Select the FileMaker Server you want to administer, then click 
Connect.

5. Type a user name and password, if you are prompted to enter it.

You are now ready to administer FileMaker Server using FileMaker 
Server Admin. See “Administering hosted databases” on page 29.

Default folders for plug-in files
Before starting FileMaker Server, be sure your plug-ins are in the 
proper folders. 

Server plug-ins
Windows: Program Files\FileMaker\FileMaker Server\Extensions\
Plugins\

Mac OS: [hard disk]/Library/FileMaker Server/Extensions/Plugins/
Plug-ins to be updated automatically on client machines
Windows: Program Files\FileMaker\FileMaker Server\Data\
Databases\AutoUpdate\

Mac OS: [hard disk]/Library/FileMaker Server/Data/Databases/
AutoUpdate/

For information on placing database files in the proper folders, see 
“Step 2. Place database files in the proper location” on page 26. For 
information on placing script files in the proper folders, see “Default 
folders for script files” on page 56.

Enabling database plug-ins
You can enable FileMaker Server to use plug-ins with hosted 
databases. When plug-ins are used by hosted databases, field 
calculations can be performed on the computer running FileMaker 
Server. You copy plug-ins required by the hosted databases to the 
FileMaker Server Extensions folder. Then, you can list and administer 
server plug-ins with Server Plug-ins (Windows) or View menu > 
Plug-ins (Mac OS). See FileMaker Server Help for more information.

For information about creating plug-ins, see “Developing third-party 
plug-ins” in the FileMaker Pro Advanced Development Guide.

Preparing Mac OS plug-in files for conversion to .tar format
Before being converted to the .tar format by FileMaker Server, 
Mac OS plug-in files with resource forks must be processed by 
software that will preserve the resource fork information. 

See FileMaker Server Help for more information.

Note   For information about automatically updating plug-ins on client 
machines, see “Allowing FileMaker Pro clients to download updates 
automatically” on page 33.
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Viewing usage statistics for FileMaker Server 
You can display usage statistics, such as how FileMaker Server is 
performing and how many clients are logged into FileMaker Server.

To display FileMaker Server usage statistics, select Statistics in the 
Console Root (Windows) or View menu > Statistics (Mac OS).

You see the Statistics list.

The following statistics are listed: 

Statistic Description

Network  
(Kbytes/sec)

Amount of data being transferred across the network.

FileMaker Pro 
Clients

Number of connected FileMaker Pro clients. Use this 
information to help configure the maximum number of 
simultaneously connected clients.

Files Number of open databases. Use this information to configure 
the Maximum number of files to host option.

Disk (Kbytes/sec) Amount of data being written to disk. 

Cache Unsaved % Percentage of cache that is currently unsaved. This should be 
a relatively low number, such as 0 or 5, so you won’t lose data 
if you experience a system crash. If the number is consistently 
high, consider decreasing the cache flush interval.

Cache Hit % Percentage of times that FileMaker Server retrieved data 
from the cache (RAM) rather than from the hard disk. 
Reading data from RAM is much more efficient than reading 
it from the hard disk, so this value should be a high number, 
like 90 or 95. If it isn’t, you might need to allocate more 
memory to the FileMaker Server database cache.
When enabled, FileMaker Server updates the Statistics list every 15 
seconds or less but no more than once a second. Although this reduces 
the overhead required to calculate the statistics, it means the statistics 
are approximations of how FileMaker Server is using resources. 

For information about where usage statistics are stored, see 
“Recording usage statistics and setting log file size limits” on page 37.

Monitoring server performance (Windows) 
To monitor usage statistics on the FileMaker Server computer, expand 
the Windows Administrative Tools node in the Console Root and 
select System Monitor.

Using the Windows System Monitor, you can chart real-time statistics 
for various aspects of FileMaker Server performance and display the 
statistics in graph, histogram, or report format. Click the + toolbar 
button to configure the statistics you want to chart.

You can customize the display by selecting the FileMaker Server 
computer, choosing FileMaker Server as the Performance Object, and 
selecting the Counters. The counters are the statistics described in 
“Viewing usage statistics for FileMaker Server” on page 50.

Note   Network KB/sec, Disk KB/sec, Cache Hit %, and Cache Unsaved % 
give you the most information about how your system is performing.

Choose FileMaker Server

Name of the server you are
monitoring

Click to add a selected counter
to your chart

Select FileMaker Server usage
statistics counters to

add to your chart
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Using reported events to track activities
FileMaker Server uses the Windows Event Viewer (Windows) or 
Event.log (Mac OS ) to help you keep track of activities on the server. 
These log files contain time-stamped information on: 

1 FileMaker Server starting and stopping

1 database files opened and closed by FileMaker Server

1 consistency checks performed on files that were not closed 
properly or have not been opened in a FileMaker 8 product

1 clients that connect to and disconnect from FileMaker Server, as 
well as the files they access

1 clients that are disconnected by FileMaker Server

1 new, completed, upcoming, and currently running schedules

1 pre-defined errors and conditions that FileMaker Server detects in 
your configuration

1 current properties settings when FileMaker Server starts up, as well 
as settings that are changed during a FileMaker Server session 

FileMaker
Server usage  

statistics  
counters

Statistics are  
charted in  

real-time here
Viewing activities in the Event Viewer (Windows)
To view information about FileMaker Server activities, expand the 
Windows Admin Tools node in the Console Root and select Event 
Viewer (local). Then, open the Event Viewer to select the Application, 
Security, System, and FileMaker Server logs.

You see a list of FileMaker Server events. Double-click an event to 
display details about it.

To save the log file contents in a text file, choose Action menu > Export 
List to save information displayed in the Event Viewer as a tab-
delimited text file (.TXT) and then import the information into a 
FileMaker Pro database for further analysis.

For more information about the error conditions reported in the event 
log, see topics on event log messages and troubleshooting in Help.

Viewing activities in the Event.log (Mac OS)
The Event.log file is created in the FileMaker Server application 
folder. You can use any application capable of opening plain text files 
or the Mac OS Console application to view or print it. 

You can have the log file open in the Mac OS Console application 
when FileMaker Server is running. Events are logged continuously, 
with the most recent log entry at the bottom of the Console application 
window. Event.log is created when FileMaker Server starts, only if 
there is no existing Event.log. Activities are added to Event.log until 
it reaches the maximum size, at which point it is renamed Event-
old.log, and a new Event.log is created.

The maximum size of the Event.log on Mac OS is 40 MB. For more 
information, see “Logging FileMaker Server events” on page 38.

For more information about the error conditions reported in the event 
log, see topics about event log messages and troubleshooting in Help.



52     FileMaker Server Administrator’s Guide
Using FileMaker Server in Mac OS
FileMaker Server and all database files, plug-ins, and scripts must be 
configured with the correct privileges and permissions to function 
properly in Mac OS.

Mac OS is a UNIX-based operating system. When FileMaker Server 
runs in Mac OS, it does not run as a single executable file. Instead, 
FileMaker Server runs as two background processes, or daemons. 
These daemons run with restricted privileges, which limit their access 
to the file systems. 

When you install FileMaker Server in Mac OS:

1 a user named fmserver and a group named fmsadmin are created

1 all databases hosted by FileMaker Server must belong to the 
fmsadmin group and have read and write access enabled to allow 
clients with the correct privileges to edit the databases

1 the user account installing FileMaker Server is automatically added 
to the fmsadmin group

1 the FileMaker Server executes as this user/group, with restricted 
privileges

Because FileMaker Server is a server application, it should not run 
with administrator or root level privileges, but with the minimum 
permissions levels necessary to perform its tasks.

About the FileMaker Server daemons
When installed, FileMaker Server creates the daemons 
fmserver_helperd and fmserverd. These are owned by the user 
fmserver and the group fmsadmin. The permissions for the two 
daemons include Set User ID, also know as the SUID bit.
The daemons are started with the user id of fmserver and group id 
of fmsadmin.When these daemons are executed by the system or by 
a user, these permissions allow the user or system to switch from the 
current user id to the fmserver id. This will happen automatically, 
provided the user is in the fmsadmin group, or is root. Otherwise, the 
system will return an error indicating that the user doesn’t have 
permission to execute the file. 

About file system permissions
The fmserver_helperd and fmserverd daemons can only read 
and write to the folders to which their privileges give them access. 

FileMaker Server is primarily installed in the [hard disk]/Library/ 
folder, since it is normally run automatically by the system as a 
background application. FileMaker consolidates the necessary files 
for FileMaker Server in /Library/FileMaker Server/, with the 
exception of the FileMaker Server Admin application and 
administration documentation.

The /Library/FileMaker Server folder is owned by the fmserver user 
id and the fmsadmin group id. This means that the FileMaker Server 
daemons can read and write to this folder. It also means that users that 
belong to the fmsadmin group can write to this folder.

FileMaker Server folders in Mac OS

Folder Purpose Notes

/Library/FileMaker Server/ 
Data/Databases/

Primary database 
folder

This folder and subfolders 
must be owned by the 
fmsadmin group.

It is important that any 
databases placed in the 
Databases folder or 
subfolders are group 
readable and writable.

/Library/FileMaker Server/
Data/Backups/

Default backup 
folder

This folder and subfolders 
must be readable, 
writable, and executable 
by the fmsadmin group
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/Library/FileMaker Server/
Data/Logs/

Output folder for 
Event.log and 
Stats.log

Server administrators 
must be members of the 
group fmsadmin to be 
able to read and delete log 
files.

/Library/FileMaker Server/
Data/Scripts/

Location for shell 
and other script files

The administrator can 
place any shell or other 
script files that are to be 
executed as scheduled 
script tasks in this folder. 

It is important that any 
script files placed in this 
folder or subfolders are 
owned by the fmsadmin 
group and are group 
readable and executable.

/Library/FileMaker Server/
Extensions/Plugins/

Location for plug-
ins hosted by 
FileMaker Server

It is important that any 
plug-ins placed in the 
Plugins folder or 
subfolders are owned by 
the fmsadmin group and 
are group readable and 
executable. 

Library/FileMaker Server/
Data/Databases/AutoUpdate/

Location for plug-
ins to be updated 
using the 
AutoUpdate Plugins 
feature. For more 
information see the 
PDF document, 
FileMaker Guide to 
Updating Plug-ins.

It is important that any 
plug-ins placed in the 
AutoUpdate folder or 
subfolders are owned by 
the fmsadmin group and 
are group readable and 
executable. 

Folder Purpose Notes
 Keep these points in mind:

1 Any Mac OS subfolders containing databases, backups, script files, 
or plug-ins must also be readable and executable by the fmsadmin 
group. Some plug-ins or scripts that use preferences or folders of 
additional files may require write permission to those files or folders.

1 If the administrator changes the default backup location, or 
specifies a different backup location, the folder must be writable by 
the group fmsadmin, or backups will fail. 

1 Your shell script is executed with the fmserver user id and 
fmsadmin group id. Therefore, you cannot call some privileged 
commands from your scripts. For example, your script will not have 
access to delete the /etc folder. It is recommended that you enable 
some form of logging for your script to be able to troubleshoot 
possible permissions issues. Refer to the Apple web site for 
information on creating log files in Mac OS.

Changing script and plug-in file permissions
To change the group and permissions for scripts and plug-ins, do the 
following:

1. Launch the Terminal application ([hard disk]/Applications/
Utilities/Terminal).

2. Change directories to the directory where the file or folder resides.

cd <filepath> 

3. Change the owner of the item to fmserver, if necessary.

chown fmserver <filename> 

or 

chown -R fmserver <folder>

4. Change the group of the item to fmsadmin, if necessary.

chgrp fmsadmin <filename> 

or 

chgrp -R fmsadmin <folder>
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5. Set permissions to:

chmod 660 <filename>

or

chmod -R 770 <folder>

6. Enable the group read and executable bits by entering the following 
at the command line:

chmod g+rx <filepath>

or

chmod g+wrx <filepath>

The g+rx is necessary because scripts and plug-ins must have the 
group read and executable bits enabled. Use the g+wrx form to permit 
write permission as well. Some plug-ins or scripts that use preferences 
or folders of additional files may require write permission to those 
files or folders.

See FileMaker Server Help and Mac OS Help for more information, 
including the man (online UNIX manual) pages for chgrp(1), 
chmod(1), sudo(8). For example, type man chgrp at the Terminal 
prompt.

Using the command line to automate tasks 
You can administer FileMaker Server using the command fmsadmin 
at the command prompt (Windows) or the Terminal application 
(Mac OS) for tasks such as opening and closing databases, enabling 
and disabling plug-ins, enabling and disabling schedules, and 
performing scheduled tasks. 

Note   FileMaker Server commands can optionally include the user 
name and password. If a command is used interactively, the name and 
password are visible and can be viewed by others. If a command must 
include a name and password in a script or batch file, ensure that only 
the password owner can view the script or batch file. 
The following table lists a summary of fmsadmin commands. For 
detailed command syntax, see Help. 

fmsadmin 
commands Description 

Backup Back up databases

Close Close databases

Delete Delete a schedule

Disable Disable plug-ins or scheduled tasks

Disconnect Disconnect a client

Enable Enable plug-ins or scheduled tasks

Help Get Help pages for fmsadmin commands

List List files, clients, plug-ins, or schedules

Open Open databases

Pause Temporarily stop database access

Reload Reload configuration properties

Resume Make databases available

Run Run a schedule

Send Send a message

Status Get status of clients or files

Stop Shut down the server
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Scheduling administrative tasks 
You can use the FileMaker Server Task Scheduling assistant 
(Windows) or Schedules (Mac OS) to define three kinds of tasks and 
set the times that they execute. You can:

1 schedule database backups

1 run script files

1 send messages to clients of hosted databases

A new scheduled task is enabled by default, which means the task will 
run at its scheduled time after you close the Schedules window. For 
more information about enabling and disabling scheduled tasks, see 
page 58.

You can define up to 50 schedules in FileMaker Server. If you set up 
schedules that overlap, FileMaker Server starts the first task and holds 
the next task in a queue. When the first task has completed, the next 
task will begin.

You can perform many actions related to scheduled tasks from the 
command line interface in Windows or Mac OS. For more 
information, see “Using the command line to automate tasks” on 
page 54. You can also use utilities such as the Scheduled Task Wizard 
(Windows OS) or cron (Mac OS command line interface) for running 
automated tasks similar to those provided by FileMaker Server.

Note   See Help for step-by-step procedures concerning defining and 
managing scheduled tasks.
Scheduling database backups 
You can:

1 back up all hosted open databases

1 back up hosted databases that are in a selected folder

Database backups are saved in the default backup folder or in a folder 
that you specify. To set the default backup folder, choose Properties 
menu > Default Folders (Windows) or Configure menu > Default Folders 
(Mac OS).

During backups, FileMaker Server copies the database while it is 
active and users continue to make modifications. When the copy is 
complete, the database is paused to synchronize backup files with the 
current database and then the database is resumed.

The destination disk that stores your hosted files and backups must 
have plenty of free space. If the hard disk runs out of space while a file 
is being modified or if a database file reaches the 8 Terabytes size 
limit, the file will be compressed.

If the hard disk runs out of space during a backup, the backup stops, 
the backup file is deleted, and FileMaker Server logs an error in the 
Application log (Windows) or Event.log (Mac OS). You should check 
the schedules list for error conditions, which are reported in the Last 
Run column. To avoid running out of disk space when backing up files, 
choose tape or a different hard disk as your backup destination.
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Running script files
You can use a script to automate administrative tasks performed by 
FileMaker Server. For more information, see FileMaker Server Help.

Default folders for script files 
Before starting FileMaker Server, be sure your command files 
(Windows) or shell scripts (Mac OS) are in the proper folders. 

Windows: Program Files\FileMaker\FileMaker Server\Data\Scripts\

Mac OS: [hard disk]/Library/FileMaker Server/Data/Scripts/

For more information, see “FileMaker Server folders in Mac OS” on 
page 52.

Modifying file permissions for shell scripts (Mac OS)
Your shell script is executed with the fmserver user id and 
fmsadmin group id. Therefore, you cannot call some privileged 
commands from your scripts. For example, your script will not have 
access to the /etc folder. 

It is recommended that you enable some form of logging in order for 
your script to be able to troubleshoot possible permissions issues. 
Refer to the Apple web site for information on creating log files in 
Mac OS.

Sending messages to clients of hosted 
databases 
You can:

1 Send a message to all clients who are currently connected to hosted 
databases

1 Send a message to clients of all open databases in a selected folder
Viewing scheduled tasks in the Schedules 
view (Windows)
After you create scheduled tasks, they appear in the schedules list. The 
list shows you a summary of each defined schedule, including the last 
time the task ran and the next time it will run.

To display the schedules list, select the Schedules node in the Console 
Root.

You can use this view of your scheduled tasks to change, duplicate, 
enable, disable, and run tasks manually.

Click buttons on the toolbar to administer scheduled tasks
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Viewing scheduled tasks in the Schedules 
view (Mac OS)
After you create a scheduled task, it appears in the Schedules view.

To display the Schedules view, choose Schedules. 

The list shows you a summary of each defined schedule, including the 
task it performs, the last time it ran, and the next time it will run.

You can use this view of your scheduled tasks to change, duplicate, 
enable, disable, and run schedules manually.

Running scheduled tasks manually
Select schedules in the schedules list and choose Action menu > Run 
Now (Windows) or Action menu > Schedules > Run Schedule Now 
(Mac OS) to run schedules manually.

The Last Run column is updated with the current date and time.

Click a  
checkbox  
to disable  

or enable a  
scheduled  

task  

Drag the border to
change the column width

Click a column heading to sort 
the list by that column
Editing scheduled tasks
Select a scheduled task in the schedules list and open Properties 
(Windows) or choose Action menu > Schedules > Edit Schedule 
(Mac OS). Make changes to the scheduled task, then save the changes.

Duplicating scheduled tasks
Sometimes it’s easier to use an existing scheduled task as a template, 
rather than defining a completely new schedule.

Windows: Select one or more scheduled tasks and choose Action 
menu > Duplicate. The duplicate schedule appears with “copy ” 
appended to its name.

Mac OS: Select a scheduled task and choose Action menu > 
Schedules > Duplicate Schedule. The duplicate schedule appears with 
“Copy of” appended to its name. 

Deleting scheduled tasks
Windows: Select one or more scheduled tasks from the schedules list 
and choose Action menu > Delete.

Mac OS: Select a scheduled task and choose Action menu > 
Schedules > Delete Schedule.

You see a confirmation message asking you to confirm that you want 
to delete the selected schedule. 

Note   You can’t undo the deletion of a schedule.
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Enabling and disabling scheduled tasks
You can enable or disable selected schedules or disable all schedules 
at once.

To perform  
this action Do this

Enable a 
schedule when 
creating or 
editing it

In the scheduled task Properties (Windows) or Edit Schedule 
dialog box (Mac OS), be sure Enable this schedule is selected.

When you create a schedule, the scheduled task is enabled by 
default.

Enable or disable 
a schedule

Windows: Select or deselect one or more schedules in the 
schedules list and choose Action menu > Enabled. A 
checkmark appears next to the Enabled command in the Action 
menu to indicate the current selection is enabled.

Mac OS: In the schedules list, select the empty checkbox to 
the left of the schedule name. A checkmark appears, 
indicating that the scheduled task is enabled.

Prevent or allow 
all schedules to 
run

Windows: Select or deselect Action menu > Allow schedules to 
run.

Mac OS: Choose the Schedules list > Allow Schedules to Run 
checkbox at the bottom of the schedules list. 

This setting overrides any individual schedule settings you 
have enabled and all checkmarks in the list are dimmed and 
the Next Run column lists the scheduled tasks as Disabled. If 
you open the scheduled task Properties (Windows) or Edit 
Schedule dialog box (Mac OS) for a disabled scheduled task, 
however, the checkmark in the Enable this schedule option 
might still be checked.
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