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1 Introduction

1.1 About MX Linux

MX Linux is a special version of antiX developed in full collaboration with the MEPIS Community, using
the best tools and talents from each distro and including work originally created by Warren Woodford
for his MEPIS project. It is a midweight OS designed to combine an elegant and e�cient desktop with
simple con�guration, high stability, solid performance and medium-sized footprint. It deploys Xfce 4.12 as
Desktop Environment on top of a Debian Stable base; ongoing backports to the Community Repos keep
it current (see the Community Repository page), and one-click installation of many popular additional
packages is available in the MX Package Installer.

Although antiX is its �code-parent,� MX Linux comes with a distinct set of applications and procedures
that in many instances di�er completely. It relies on the excellent upstream work by Linux, Debian, and
Xfce. It also incorporates the independent and innovative development products smxi and inxi.

The following Development Team members (devs AT mxlinux DOT org) played a particularly signi�cant
role in the creation of MX Linux.

� Lead Developer: anticapitalista

� Primary Coders/Packagers: Adrian, BitJam, kmathern, Stevo, timkb4cq

� Project Manager: jerry3904

� Signi�cant contributors: chrispop99, Dolphin_Oracle, Eadwine Rose, fu-sen, Gaer Boy, Ko, m_pav,
megatotoro, namida12, pcallahan80, richb, Utopia, zeeone

Special thanks for strong ongoing support of this project go to the Mepis Community Packagers; to video
producers Dolphin_Oracle and m_pav; to our volunteers, especially Gordon Cooper, mikeinsantarosa,
Old Giza and v3g4n; and to all our Translators!

1.2 About this Manual

Figure 1-1: The *need* for manuals (xkcd.com)

This Users Manual is the product of large group of volunteers from the MX Linux community. As such,
it will inevitably contain errors and omissions, although we have worked hard to minimize them. Please
send us corrections or suggestions using one of the methods listed at the beginning. Updates will occur
online on a regular basis; the backup copy on the hard drive (/usr/local/share/doc/mxum.html) will be
updated less often through the standard package procedures.

The Manual is designed to walk new users through the steps of obtaining a copy of MX Linux, installing it,
con�guring it to work with one's own hardware, and putting it to daily use. It aims to provide a readable
general introduction, and purposely gives preference to graphical tools when available. For detailed or
infrequent topics, the user should consult the Resources or post on the Forum.

New users may �nd some of the terms used in this Manual to be unfamiliar or confusing. We have tried
to limit the use of di�cult terms and concepts, but some are simply unavoidable.
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The Glossary located at the end of the document provides de�nitions and comments that will help in
getting through di�cult passages.

All content is © 2015 by antiX Linux and released under GPLv3. Citation should read:

MX Linux Community Documentation Project. 2015. Users Manual for MX Linux.

1.3 System requirements

For an MX Linux system installed on a harddrive, you would normally need the following components.
(See also LiveMedium options in Section 6.6.)

Minimum

� A CD/DVD drive (and BIOS capable of booting from that drive), or a live USB (and BIOS capable
of booting from USB)

� A modern i486 Intel or AMD processor

� 512 MB of RAM memory

� 5 GB free hard drive space

� A SoundBlaster, AC97 or HDA-compatible sound card.

Recommended

� A CD/DVD drive (and BIOS capable of booting from that drive), or a live USB (and BIOS capable
of booting from USB)

� A modern i686 Intel or AMD processor

� 1 GB of RAM memory or more

� At least 10 GB free hard drive space

� A 3D-capable video card for 3D desktop support

1.4 Support

What kind of support is available for MX Linux? The answer to this question depends on the type of
support you mean:

� User-based problems. A raft of support mechanisms exists for MX Linux, from documents and
videos to forums and search engines. See the Community Support page for details.

� Hardware. Hardware is supported in the kernel, where continuous development goes on. Very new
hardware may not yet be supported, and very old hardware, though still supported, may no longer
be su�cient for the demands of the desktop and applications.

� Desktop. Xfce4 is a mature desktop that remains under development. The version shipped with
MX Linux is considered stable; important updates will be applied as they become available.

� Applications. Applications continue to be developed after the release of any version of MX Linux,
meaning that the shipped versions will get older as time passes. This problem is addressed through
a combination of sources: Debian, individual Developers including MX Devs, and the Community
Packaging Team.

� Security. Security updates from Debian will cover MX Linux users well into the foreseeable future.

1.5 Bugs, issues and requests

Bugs are errors in a computer program or system that produce incorrect results or abnormal behavior.
MX Linux de�nes �issues� as upstream bugs about which the Dev Team can do nothing.
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Finally, �requests� are additions requested by users, either as new applications or new features for existing
applications. MX Linux deals with these in the following manner:

� All three of these are managed by means of the Tracker.

� Users should make a post in the Bugs and Request Forum, being careful to provide information
about hardware, system, and error details

� Devs as well as Community members will respond to those posts with questions, suggestions, etc.

� If Devs conclude that a legitimate bug/issue/request is involved, they create a new entry in Tracker.

� Users can consult Tracker to monitor progress on their post

Figure 1-2: Tracker

1.6 Migration

Whenever possible, a migration path is provided with distribution upgrades (i.e., apt-get dist-upgrade)
so that users can avoid reinstallation. The exception to this standard procedure arises when the Debian
base changes.

Debian Stable is a wonderful solid distribution that can be upgraded in place from version to version
automatically as long as the Debian Stable repos are used exclusively. MX uses Debian Stable as a base,
but updates a lot of the userland programs & libraries, and backports newer programs from testing by
building them against the Stable base. That gives a better user experience but interferes with Debian's
dist-upgrade path. Our current choice to stick with sysvinit instead of going to full systemd also interferes
with that path.

So it's a trade-o�: better desktop user experience at the expense of having to do a quick fresh install
(which lets you save /home if desired) when the Debian base changes, typically every 2-3 years.
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2 Installation

2.1 Introduction

An MX Linux LiveMedium (USB or CD) boots your computer without accessing the hard disk. It copies
a virtual �le system into RAM that acts as the center of a temporary operating system for the computer.
When you end your Live session, everything about your computer is back to the way it was, unchanged
(contrast Section 6.6.1).

This provides a number of bene�ts:

� It enables you to run MX Linux on your computer without installing it.

� It allows you to determine whether MX Linux is compatible with your hardware.

� It helps you to get a feel for how MX Linux works and to explore some of its features.

� You can decide whether MX Linux is what you want without permanently a�ecting your current
system.

Running from the LiveMedium also has some disadvantages if using a Live CD:

� Because the entire system is operating from a combination of RAM and the medium, MX Linux
will require more RAM and run more slowly than if it were installed on the hard drive.

� Some unusual hardware that requires specialized drivers or custom con�guration may not work in
a LiveMedium session where permanent �les can't be installed. Installing and removing software is
also not possible because the CD is a read-only medium.

2.1.1 PAE or non-PAE?

MX Linux is available for two architectures: 32bit (PAE and non-PAE) and 64bit (PAE only) PAE stands
for Physical Address Extension, a way of allowing 32 bit operating systems to access ram beyond around
4GB. It is possible to use a non-PAE version on a PAE system, but not vice versa. MX Linux non-PAE
is exactly the same as MX Linux PAE except it uses the 486 kernel instead of the 686 one.

If unsure whether you need the PAE or non-PAE version, use the method below suitable for the OS you
currently run.

� Linux. Open a terminal and enter this command (install inxi �rst if necessary): inxi -f. If the CPU
Flags entry does not include PAE in the list, then you'll need the non-PAE version.

� Mac. Intel versions of OS X support PAE.

� Windows®

� Windows2000 and earlier: non-PAE

� Windows XP and Vista. Right click My Computer > Properties, General tab. If it says
Physical Address Extension (=PAE) at the bottom, then PAE is the correct version to install.

� Windows 7. Open the Command Prompt window by clicking the Start button > All Programs
> Accessories > Command Prompt. A terminal window will appear. Enter this code at the
command prompt where the cursor is positioned:

wmic os get PAEEnabled

If PAE is enabled, you will get a return like this: PAEEnabled. That return may or may not
be followed by the word TRUE.

� Windows 8. PAE enabled by default.
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2.1.2 32 or 64 bit?

What is the architecture of your cpu? Follow the appropriate method below to �nd out whether
your machine is 32- or 64-bit.*

� Linux. Open a terminal and enter the command lscpu, then examine the �rst few lines for
architecture, number of cores, etc.

� Windows. Consult this Microsoft document.

� Apple. Consult this Apple document.

*If you want to know the architecture of the OS instead, the command uname -m will probably work
on all platforms.

How much memory (RAM) do you have?

� Linux. Open a terminal and enter the command free -h and look at the number in the Total
column.

� Windows. Open the System window using whatever method is recommended for your version, and
look for the entry �Installed memory (RAM).�

� Apple. Click the entry "About this Mac" in the Apple menu on Mac OS X and look for the RAM
information.

MX Linux 64-bit users often report 2GB of RAM to be su�cient for general use, although 4GB RAM is
recommended if you will be running processes (such as remastering) or applications (such as an audio or
video editor) that are memory-intensive.

Which one should you choose?

� Function. In general, if you have a 64-bit cpu and the required RAM for your particular machine
and processor, you should use the 64-bit version. This is because 64-bit is generally faster, though
you may not actually notice the di�erence in daily use. In the long run, moreover, an increasing
number of larger applications will likely be restricted to 64-bit versions.

� Legacy. A 32-bit application or OS can run on a 64-bit cpu, but the reverse is not true.

MORE: here

2.2 Creating a bootable medium

2.2.1 Obtain the ISO

MX Linux is distributed as an ISO, a disk image �le in the ISO 9660 �le system format. It is available
in two formats o� the Download page.

� The original release of a given version.

� This is a static version that, once released, remains unaltered.

� The longer the time since release, the less current it is.

� A monthly update of a given version. This monthly ISO is created from the original release using
MX Snapshot (see Section 6.6.2).

� It includes all upgrades since the original release, and thus removes the necessity of download-
ing a large number of �les after installation.

� It also enables users to run Live with the most recent version of the programs.

� Only available as direct download!
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Purchase It is possible to purchase a CD or USB (original release only) from OSDisk with the ISO
already loaded and ready to use: use the links on the Download page. MX Linux receives a small amount
back from each purchase that it uses to cover costs.

Download MX Linux can be downloaded in two ways from the Download page.

� Direct. Click on the correct link for your architecture and mode, and save the ISO to your Hard
Disk. If one source seems slow, try the other one. Available for both original release and monthly
update.

� Torrent. BitTorrent �le sharing provides an internet protocol for e�cient mass transfer of data. It
decentralizes the transfer in such a way as to utilize good bandwidth connections and to minimize
strain on low-bandwidth connections. An added bene�t is all BitTorrent clients perform error
checking during the download process, so there is no need to do a separate md5sum check after
your download is complete. It has already been done!

The MX Linux Torrent Team maintains a seeded BitTorrent swarm of the latest MX Linux ISO
(original release only), registered at LinuxTracker.org within 24 hours at the latest of its o�cial
release. Here are the basic steps:

How to Create a Torrent

� Go to the Download page and click on the correct Torrent link

� When the LinuxTracker page opens, �nd and click the link for the torrent (e.g., MX-15-586-
pae) in the row labeled �Torrent�

� On the next screen, look for the link labeled �Download Now� and click on it

� Make sure �Open with <NameOfYourDefaultTorrentClient>� is selected and click OK

� Your torrent client (MX installs Transmission by default) will then show the torrent in its list;
highlight it and click Start to begin the download process. If you have already downloaded
the ISO, make sure that it is in the same folder as the torrent you just downloaded.

Figure 2-1: LinuxTracker: small link to torrent
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Figure 2-2: LinuxTracker: small download link

2.2.2 Check validity of downloaded ISOs

After you have downloaded an ISO, the next step is to verify it. There are two methods available.

md5sum Each ISO is accompanied by a matching md5sum �le in the source, and you should check its
md5sum against the o�cial one. It will be identical to the o�cial md5sum if your copy is authentic.
The following steps will let you verify the integrity of the downloaded ISO on any OS platform.

� Windows

Users can check with a tool called WinMD5FREE. Download and unzip it, then put the exe �le in
any folder on your hard drive. It is ready to use, no installation required.

� Linux

In MX Linux, navigate to the folder where you have downloaded the ISO and the md5sum �le.
Right-click the md5sum �le > Check data integrity. A dialog box will pop up saying �<name of
ISO>: OK� if the numbers are identical. You can also right-click the ISO > Compute md5sum
and compare it with another source.

For situations where that option is not available, open a terminal in the location where you down-
loaded the ISO, then type:

md5sum �lename.iso

Be sure to replace ��lename� with the actual �lename (type in the �rst couple of letters then hit
Tab and it will be �lled in automatically). Compare the number obtained by this calculation with
the md5sum �le downloaded from o�cial site. If they are identical, your copy is identical to the
o�cial release.

� Mac

Mac users need to open up a console/terminal and change into the directory with the ISO and
md5sum �les. Then issue this command:

md5 -c �lename.md5sum

Be sure to replace �lename with the actual �lename.

GPG signature As of March 16, 2016, MX Linux ISO �les to be downloaded have been signed by their
developers (anticapitalista, Adrian or Stevo). This security method allows the user to be con�dent that
the ISO is what is says it is: an o�cial ISO from the developer. Detailed instructions about how to run
this security check can be found in the MX/antiX Technical Wiki.
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2.2.3 Create the LiveMedium

DVD Burning an ISO to a DVD is easy, as long as you follow some important guidelines.

� Do not burn the ISO onto a blank CD/DVD as if it were a data �le! An ISO is formatted and
bootable image of an OS. You need to choose Burn disk image or Burn ISO in the menu of your
CD/DVD burning program. If you just drag and drop it into a �le list and burn it as a regular �le,
you will not get a bootable LiveMedium.

� Use a good quality writable DVD-R with a 4.7 GB capacity.

USB You can easily create a bootable USB that works on most systems. MX Linux includes the cross-
platform utility Unetbootin for this work, as well as the advanced MX Tool antix2usb (Section 6.6.1).
Using Unetbootin:

� Plug in the USB stick you want to turn into a LiveUSB and use GParted to make the �rst partition
less than 32 Gig in size and formated with a FAT32 �le system. On Windows, use the My Computer
screen, right-click your USB device in the menu and select Format, then FAT 32.

� Start Unetbootin, and either download the ISO using the top radio button, or click on the button
with the 3 dots to locate your ISO �le.

� Make sure the device that is identi�ed in the bottom line is what you want to use and that there
are no �les on it that you do not want destroyed.

� Click OK to create the �les necessary (it will take some time) on the USB device.

� Either click to restart the system, or exit to reboot manually on a di�erent machine or at another
time.

Figure 2-3: Unetbootin
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NOTES:

� If you want to create a USB on a Windows base, we suggest you use Rufus, which supports our
bootloader.

� If on a Linux base, be sure to upgrade unetbootin, syslinux, and extlinux to the most recent versions.

� If your USB starts but leaves you with an error message: "gfxboot.c32: not a COM32R image,"
you should still be able to boot by typing "live" at the prompt in the next line. Reformatting the
USB and reinstalling the ISO should remove the error.

� If the graphic USB creators fail, use one of the command line options below. Let us assume your
USB is identi�ed as sde, then copy and paste this line for the 32 bit kernels:

dd bs=4M if=MX-15-b1_386-mx.iso of=/dev/sde
&& sync

� and this one for the 64 bit one:

dd bs=4M if=MX-15-b1_x64-mx.iso of=/dev/sde
&& sync

� Be sure to make changes in the above code as needed.

� the version of MX-15 (e.g., MX-15-b1 to MX-15-rc1)

� the identi�er of your USB stick (e.g., sde to sdb)

2.3 Pre-Installation

2.3.1 Coming from Windows

If you are going to install MX Linux as a replacement for Microsoft Windows, it is a good idea to
consolidate and back up your �les and other data currently stored in Windows. Even if you are planning
to dual-boot, you should make a backup of this data in case of unforeseen problems during the install.

Backing up �les Locate all of your �les, such as o�ce documents, pictures, video, or music:

� Typically, most of these are located in My Documents folder.

� Search from the Windows start menu for various types of �les to make sure you have found and
saved them all.

� Once you have located all such �les, burn them to a CD or DVD, or copy them to an external
device such as a USB thumb drive.

Backing up email, calendar, and contact data Depending on the email or calendar program you
use, your email and calendar data may not be saved in an obvious location or under an obvious �le name.
Most email or scheduling applications (such as Microsoft Outlook®) are able to export this data in one
or more �le formats. Consult your application's help documentation to �nd out how to export the data.

� Email data: The safest format for email is plain text, since most mail programs support this feature;
be sure to zip the �le to ensure that its contents are included. If you are using Outlook Express,
your mail is stored in a .dbx or .mbx �le, either of which can be imported into Thunderbird (if
installed) on MX Linux. Use the Windows search feature to locate this �le and copy it to your
backup. Outlook mail should be imported �rst into Outlook Express before being exported for use
in MX Linux.

� Calendar data: export your calendar data to iCalendar or vCalendar format if you wish to use it in
MX Linux.

� Contact data: the most universal formats are CSV (comma separated values) or vCard.

11

https://rufus.akeo.ie/


Accounts and passwords Although not usually stored in readable �les that can be backed up, it's
important to remember to make note of various account information you may have saved in your computer.
Your automatic log-in data for websites or services like your ISP will have to be entered in all over again,
so make sure to store o� disk the information you need to access these services again. Examples include:

� ISP login information: You will need at least your username and password for your internet service
provider, and the phone number to connect if you are on dial-up or ISDN. Other details might include
a dial out number, dialing type (pulse or tone), and authentication type (for dialup); IP address and
subnet mask, DNS server, gateway IP address, DHCP server, VPI/VCI, MTU, Encapsulation type,
or DHCP settings (for various forms of broadband). If you are not sure what you need, consult
your ISP.

� Wireless networking: You will need your passkey or passphrase, and network name.

� Web passwords: You will need your passwords to various web forums, online stores, or other secured
sites.

� Email account details: You will need your username and password, and the addresses or URLs of
the mail servers. You may also need the authentication type. This information should be retrievable
from the Account settings dialog of your email client.

� Instant messaging: Your username and password for your IM account(s), your buddy list, and the
server connection information if necessary.

� Other: If you have a VPN connection (such as to your o�ce), a proxy server, or other con�gured
network service, make sure you �nd out what information is necessary to recon�gure it in the event
that you need to.

Browser favorites Web browser favorites (bookmarks) are often overlooked during a backup, and they
are not usually stored in a conspicuous place. Most browsers contain a utility to export your bookmarks
to a �le, which can then be imported into the web browser of your choice in MX Linux. Here are some
export methods for common web browsers:

� Internet Explorer®: click File > import and export, select export favorites, select the favorites
folder (to export all favorites), select export to �le or address and enter a �lename for the favorites.

� Firefox® 3 and above: click Bookmarks > Organize Bookmarks or Show All Bookmarks, highlight
the bookmark folder to backup, click Import and Backup - Export HTML..., enter a �lename for
the bookmarks.

Software licenses Many proprietary programs for Windows are not installable without a license key or
CD key. Unless you are set on doing away with Windows permanently, make sure you have a license key
for any program that requires it. If you do decide to reinstall Windows (or if dual-boot setup goes awry),
you will be unable to reinstall these programs without the key.

If you can not �nd the paper license that came with your product, you may be able to locate it in the
Windows registry, or use a key�nder such as ProduKey. If all else fails, try contacting the computer's
manufacture for help.

Running Windows programs Windows programs will not run inside a Linux OS, and MX Linux users
are encouraged to look for native equivalents (see Section 4). Applications that are critical for a user
may run under Wine (see Section 6.1), though it varies somewhat.
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2.3.2 Apple Intel computers

Installing MX Linux on Apple computers with Intel chips is generally problematic, though the situation
varies to a certain degree with the exact hardware involved. Users interested in the question are advised
to consult the Debian materials and forums for recent developments; a document for the MX/antiX Wiki
is in development.

Links Installing Debian on Apple Computers:

Debian forums

2.3.3 Harddrive FAQs

Create a new partition with GParted

Partition a Multi-boot system

Where should I install MX Linux? Before starting the install, you need to decide where you are going
to install MX Linux.

� Entire harddrive

� Existing partition on a harddrive

� New partition on a harddrive

You can simply select one of the �rst two during installation, but the third requires the creation of a new
partition. You can do this during installation, but it is recommended that you do that before you start
the installation. In Linux, you will usually be using GParted, a useful and very powerful tool.

MORE: GParted Manual

Figure 2-4: Gparted showing a single partition (sda1) and swap (sda2)
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How can I edit partitions? A very handy tool for such actions is Start menu > System > Disk
manager. This utility provides a graphical presentation of all the partitions on the machine (excluding
swap) with a simple interface for quickly and easily mounting, unmounting and editing some properties of
disk partitions. Changes are automatically and immediately written to /etc/fstab and are thus preserved
for the next boot.

Disk Manager automatically allocates mount points in /media, using /media/LABEL (e.g., /media/HomeData)
if the partition is labeled or /media/DEVICE (e.g., /media/cdrom) if not. These mount points are created
by DM when a partition is mounted, and removed immediately when a partition is unmounted.

HELP: Disk Manager help.

What are those other partitions on my Windows installation? Recent home computers with
Windows are sold with a diagnostic partition and restore partition, in addition to the one that contains
the OS installation. If you see multiple partitions showing up in GParted that you were not aware of, they
are probably those and should be left alone.

Should I create a separate Home? You do not have to create a separate home, since the Installer
will creat a /home partition within / (root). But having it separate makes upgrades easier and protects
against problems caused by users �lling up the drive with a lot of pictures, music, or video data.

How big should / (root) be?

� The installed base size is a little under 2.5GB, so we recommend a minimum of 5GB to allow for
basic functions.

� This minimum size will not allow you to install many programs, and may cause di�culty doing
upgrades, running VirtualBox, etc. Recommended size for normal use is therefore 10 GB.

� If you have /home located within / and store a lot of big �les, then you will need a larger root
partition.

� Gamers playing big games (e.g., Wesnoth) should note that they will need a bigger / partition than
usual for data, images, sound �les; an alternative is to use a separate Data drive.

Do I need to create a SWAP �le? The Installer will create a SWAP �le for you (see Section 2.5.1).
If you intend to hibernate (and not just suspend) the system, swap may need to be something on the
order of 2GB or else the hibernation will fail when the current memory use is more than 1GB. In any
case, hibernate routinely fails and is therefore not supported by MX Linux.

What do names like �sda� mean? Before you begin installation, it is critical that you understand how
Linux operating systems treat hard drives and their partitions.

� Drive names. Unlike Windows, which assigns a drive letter to each of your hard drive partitions,
Linux assigns a short device name to each hard drive or other storage device on a system. The
device names always start with sd plus a single letter. For instance, the �rst drive on your system
will be sda, the second sdb, etc. There are also more advanced means of naming drives, the most
common of which is the UUID (Universally Unique IDenti�er), used to assign a permanent name
that will not be changed by the addition or removal of equipment.

� Partition names. Within each drive every partition is referred to as a number appended to the
device name. Thus, for instance, sda1 would be the �rst partition on the �rst hard drive, while
sdb3 would be the third partition on the second drive.
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� Extended partitions. PC hard disks were originally permitted only four partitions. These are called
primary partitions in Linux and are numbered 1 to 4. You can increase the number by making one
of the primary partitions into an extended partition, then dividing that into logical partitions (limit
15) that are numbered from 5 onward. Linux can be installed into a primary or logical partition.

2.4 First look

In case you want to log out and back in, install new packages, etc., here is the LiveMedium login
information:

� Regular user

� name: demo

� password: demo

� Superuser (Adminstrator)

� name: root

� password: root

2.4.1 Boot the LiveMedium

LiveCD/DVD Simply place the DVD in the tray and reboot.

LiveUSB You may need to take a few steps to get your computer to boot correctly using the USB.

� To boot with the USB Drive, many computers have special keys you can press during booting to
select that device. Typical Boot Device Menu keys are Esc, one of the Function keys or the Shift
key. Look carefully at the �rst screen that shows up when rebooting to �nd the correct key.

� Alternatively, You may have to go into the BIOS to change the boot device order:

� Boot the computer, and hit the required key (e.g., F2, F10 or Esc) at the beginning to get
into the BIOS

� Click on (or arrow over to) the Boot tab

� Identify and highlight your USB device (usually, USB HDD), then move it to the top of the
list. Save and exit

� If unsure or uncomfortable about changing the BIOS, ask for assistance in the Forums.

� On older computers without USB support in the BIOS, you can use the Plop Linux LiveCD that
will load USB drivers and present you with a menu. See the website for details.

� Once your system is set to recognize the USB Drive during the boot process, just plug in the Drive
and reboot the machine.

UEFI If the machine already has Windows 8 or later installed, then special steps must be taken to deal
with the presence of (U)EFI and Secure Boot. Unfortunately, the exact procedure varies by manufacturer:

Methods used for launching UEFI shell depend on the manufacturer and model of the system mother-
board. Some of them already provide a direct option in �rmware setup for launching, e.g. compiled x86-
64 version of the shell needs to be made available as <EFI_SYSTEM_PARTITION>/SHELLX64.EFI.
Some other systems have an already embedded UEFI shell which can be launched by appropriate key
press combinations. For other systems, the solution is either creating an appropriate USB �ash drive
or adding manually (bcfg) a boot option associated with the compiled version of shell. (Wikipedia,
�Uni�ed Extensible Firmware Interface�, retrieved 10/29/15)

The UEFI booting function is restricted to 64bit machines, and is considered experimental. For details,
please consult the MX/antiX Wiki.
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The Black Screen Occasionally it may happen that when you boot up with the LiveMedium, you end
up looking at an empty black screen that may have a blinking cursor in the corner. This represents a
failure to start X, the windows system used by Linux, and is most often due to problems with the graphics
driver being used.

Solution: reboot and select Safe Video or Failsafe boot options in the menu (F6); details on these
bootcodes in the Wiki. You will be able to change drivers if necessary once you have reached the desktop
using sgfxi (Section 6.5.3).

2.4.2 The standard opening screen

Figure 2-5: LiveMedium boot screen of 386 ISO, with pae version highlighted

When the LiveMedium boots up, you will be presented with a screen similar to the Figure above (the
installed screen looks quite di�erent). (Note that the 386 ISO o�ers both the pae and non-pae versions.)
Custom entries may also appear in the main menu. Detailed Help on this screen can be found in this
document.
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Main Menu entries

Table 1: Menu entries in Live boot
Entry Comment

MX-15
(<RELEASE
DATE>)

This entry is selected by default, and is the standard way that most
users will boot the Live system. Simply press Return to boot the
system. On the 386 ISO two entries will appear, one for PAE

(default) and the other for non-PAE.

Boot from Hard
Disk

Allows for user to select a stored ISO to boot.

Memory Test Runs a test to check RAM. If this test passes then there may still be
a hardware problem or even a problem with RAM but if the test fails

then you know something is wrong.

In the bottom row the screen displays a number of vertical entries, below which is a row of horizontal
options; press F1 when looking at that screen for details.

Options

� F1 Help. Help system in English only. Contains much of the same information that is given here.

� F2 Language. Set the language for the bootloader and the MX system. This will automatically
transfer to the hard drive when you install.

� F3 Time Zone. Set the timezone for the system. This will automatically transfer to the hard
drive when you install.

� F4 Options. Options for checking and booting the Live system. Most of these options do not
transfer to the hard drive when you install.

� F5 Persist. Options for retaining changes to the LiveUSB when the machine shuts down.

� F6 Safeboot. Safe Video forces the use of the generic video driver, useful to try if your �rst boot
left you with a blank screen. Failsafe Loads all drivers early in the boot process, a good choice if
the �rst boot does not work at all.

� F7 Console. Set resolution of virtual consoles. May con�ict with Kernel Mode Setting. Can be
useful if you are booting into Command Line Install or if you are trying to debug the early boot
process. This option will transfer when you install.

Other cheatcodes for LiveUSB can be found in the MX/antiX Wiki. The cheatcodes for booting an
installed system are di�erent, and can be found in the same location.

MORE: Linux startup process

17

http://mxlinux.org/wiki/system/boot-parameters
http://en.wikipedia.org/wiki/Linux_startup_process


2.4.3 The UEFI opening screen

Figure 2-6: LiveMedium boot screen of x64 when UEFI

If the user is using a computer set for UEFI boot (see MX/antiX Wiki), the opening screen for UEFI Live
boot will appear instead with 3 choices.

� MX-15_x64

� Failsafe

� Custom boot (with menus)

If you want localisation or other options, choose "Custom boot." That will bring up as second screen of
extensive menu options; just select what you want and follow the prompts.

2.4.4 Login screen

Figure 2-7: Login screen, with arrow indicating session and power buttons
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The installed boot process �nishes with the login screen; in a Live session only the background image is
shown, but if you log out from the desktop you will see the complete screen as shown. The red arrow
points to two small icons at the right end of the top bar:

� The power button at the edge contains options to suspend, restart and shut down.

� The session button to the left of the power button allows you to choose which desktop manager you
wish to use: Default Session, Xfce Session, followed by any other you may have installed (Section
6.3).

If you wish to avoid having to log in each time you boot up (not recommended for security reasons), you
can change the behavior on the �options� tab of MX User Manager (Section 3.2.12).

2.4.5 The desktop

Xfce 4.12

MX-15 tour

The desktop is created and managed by Xfce 4.12, though its appearance and arrangement have been
heavily modi�ed for MX Linux.

Figure 2-8: Default desktop

Panel The default desktop of MX Linux has a single vertical panel on the left side of the screen. A
horizontal panel format is available by clicking MX Tools > MX Panel Orientation.

Default panel elements from top to bottom:

� Clock in LCD format�click for orage calendar

� Window Buttons: area where open applications are shown

� Firefox browser

� File manager (Thunar)

� Noti�cation Area

� Update manager
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� Clipboard manager

� Keyboard manager

� Network manager

� Volume manager

� Power manager

� Other applications (e.g., Bluetooth) may insert icons here when running.

� Pager: displays available workspaces (by default 2, right-click to change)

� Start (�Whisker�) menu

To change the position of the Panel, see Section 3.2.10; to change its properties, Section 3.8.

Welcome screen

Figure 2-9: The Welcome screen in Live mode

When the user boots up for the �rst time, a Welcome screen appears in the center of the screen that
o�ers quick orientation and help links. When running Live (shown here), a small link to the Login info
appears that provides the passwords for demo and root.
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Tips & Tricks

Figure 2-10: Settings Manager is your one-stop location to make changes (contents vary).

Some handy things to know at the beginning:

� If you are having problems with sound, network, etc., see Con�guration (Section 3).

� Adjust sound general loudness by scrolling with the cursor over the speaker icon, or by right-clicking
speaker icon > Open Mixer.

� Set the system to your particular keyboard layout by clicking Start menu > Settings > Keyboard,
Layout tab, and selecting the model with the pull-down menu. This is also where you can add other
language keyboards.

� Adjust preferences for mouse or touchpad by clicking Start menu > Settings > Mouse and
Touchpad.

� Trash can be easily managed in the File Manager (Thunar), where you will see its icon in the left
pane. Right-click to empty. It can also be added to the Desktop or Panel. It is important to realize
that using delete, whether by highlighting and hitting the delete button or via a context menu entry,
removes the item for ever and it will not be recoverable.

� Keep your system current by watching for the green indicator of available updates on the Update
Manager (Apt-Noti�er) icon. See Section 3.2.1 for details.

� Handy key combinations (managed in Settings Manager > Keyboard > Application Shortcuts).
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Table 2: Handy key combinations

Keystrokes Action

F4 Drops a terminal down from top of screen

Windows key Brings up the Whisker menu

Ctrl-Alt-Esc Changes the cursor into a white x to kill any program

Ctrl-Alt-Bksp Closes the session (without saving!) and returns you to the login screen

Ctrl-Alt-F1 Drops you out of your X session to a command line; use Ctrl-Alt-F7 to
return.

Alt-F1 Opens this MX Linux Users Manual

Alt-F2 Brings up a dialog box to run an application

Alt-F3 Opens the Application Finder which also allows editing menu entries

Alt-F4 Closes an application that is in focus

PrtScr Opens the Screenshooter for screen captures

Applications Applications can be started in various ways.

� Click the Start menu (Whisker) icon, in lower left corner.

� It opens to Favorites category, and you can hover mouse over other categories on right side
to see contents in the left pane. You can switch the contents and categories columns by
right-clicking the menu icon (MX logo) > Properties.

� At the top is a powerful incremental search box: just type in a few letters to �nd any application
without needing to know its category.

Figure 2-11: Whisker menu

� Right-click the desktop > Applications.

� If you know the name of the application, you can use Application Finder, started easily in one of
two ways.
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� Right-click the desktop > Run command ...

� Alt-F2

Figure 2-12: Application Finder identifying application

� Use a keystroke you have de�ned to open a favorite application. Click Start menu > Settings,
then Keyboard, Application shortcuts tab.

System

System information

� Click Start menu > System > System Pro�ler and Benchmark (hardinfo) for a nice graphic
display

� Open a terminal and enter: inxi -F

Video and audio

� For basic monitor settings, click Start menu> Settings > Display

� Sound adjustment is done through Start menu > Multimedia > PulseAudio Volume Control
(or right-click Volume manager icon)

NOTE: for troubleshooting areas such as display, sound or internet, consult Section 3: Con�guration.

Links

� Xfce documentation

� Xfce FAQs

2.4.6 Exiting

When you open Whisker menu, you will see by default four command buttons in the upper right corner.
From left to right:

� All Settings (Settings Manager)

� Lock Screen

� Switch Users

� Log Out

Figure 2-13: command buttons at top right corner of Whisker menu, with LogOut active.

It is important to exit MX Linux correctly when you have �nished your session so that the system can be
brought down in a secure way.
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All running programs are �rst noti�ed that the system is going down, giving them the time to save any
�le being edited, exit from mail and news programs, etc. If you just turn the power o�, you risk the
possibilities of damaging the operating system.

Permanent To leave a session for good, select one of the following on the Log Out dialog box:

� Log out. Choosing this will terminate everything you are doing, if you have not closed/stopped
things yourself, and bring you back to the login screen with the system still running.

� The command at the bottom of the screen, �Save session for future logins,� is checked by
default. Its task is to save the state of your desktop (opened applications and their location)
and restore it during the next startup. If you have had problems with your desktop function,
you can uncheck this to get a fresh start; if that does not solve the problem, click Settings
manager > Session and Startup, Session tab, and press the Clear saved sessions button.

� Ctrl-Alt-Bksp will return you to the login screen, but any open programs and processes will not
be saved.

� Restart or Shut Down. Self-explanatory options that alter the system state itself. Also available
using the icon in the upper right corner of the top bar on the login screen.

Temporary You can temporarily leave your session in one of the following ways:

� Lock screen. This option is easily available from an icon in the top right corner of the Start
menu. It protects your Desktop from unauthorized access while you are away by requiring your user
password to return to the session.

� Start a parallel session as a di�erent user. This is available from the Switch User command
button in the top right corner of the Start menu. You choose this to leave your current session
where it is and allows a session for a di�erent user to be started.

� Suspend using Power Button. This option is available from the Log Out dialog box, and places
your system into a low-power state. Information on system con�guration, open applications, and
active �les is stored in main memory (RAM ), while most of the system's other components are
turned o�. It is very handy and generally works very well in MX Linux. Invoked by the Power
Button, suspend works well for many users, though its success varies according to the complex
interaction among a system's components: kernel, display manager, video chip, etc. If you have
problems, consider trying the following changes:

� Switch graphical driver (e.g., from radeon to fglrx, or from nouveau to the proprietary Nvidia
driver)

� Adjust the settings in Start menu > Settings > Power Manager. For instance: on the System
tab, try unchecking "Lock screen when system is going for sleep."

� Click Start menu > Settings > Screensaver, and ajust the Display Power Management vaules
on the Advanced tab.

� AGP cards: add Option "NvAgp" "1" to the Device section of xorg.conf

� Suspend using laptop lid close. This is much less reliable that using the Power Button, and is
not generally recommended. Action on lid closing can be adjusted on the General tab of Power
Manager, where �Switch o� display� has proved reliable in MX users' experience.

� Hibernation. There is no hibernation option readily available on MX Linux, because it has proven
highly unreliable during testing.
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2.5 The Installation process

2.5.1 Detailed installation steps

Installing MX Linux

To begin, boot to the LiveMedium and click on the Installer icon in the upper left corner. The installer
will open in a two-pane format: installation steps to take in the right pane, Help in the left. The installer
is very easy to use with its detailed instructions, and a step-by-step video is linked above. We restrict
ourselves here to a sequence of images with clarifying comments.

Figure 2-14: Installer Screen 1

Comments

� Use disk. If unsure which is the partition you want, use the names you see in GParted. The disk
you select will be examined cursorily for reliability by SMART. If problems are detected, you will
see a warning screen. You will need to decide whether to accept that risk and continue, select
another disk or terminate the installation. For more information, click Start menu > System >
GSmartControl and �Perform tests� on the drive.

Figure 2-15: SMART warning of risk of failure
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� Modify partitions. Most users have concluded that it is better to carry out any such modi�cations
before you start installation to avoid any problems � for instance newly created partitions may not
show up in the drop-down menus. See Section 2.3.2.

� Auto-install using entire disk. Select this option if you plan to use the entire hard drive for MX
Linux and you aren't particular about how the partitions are set up. If you select this, the installer
will create a root and swap partition for you using the entire drive. You can optionally specify an
amount of space to leave unused, if you plan to create more partitions afterward. Make sure you
understand that selecting this option will delete any existing partitions and data. Only
choose this if you are not going to keep anything on the selected hard drive.

� Custom install on existing partitions. If you are installing MX Linux to a dual-boot with another
operating system, or you wish to de�ne the sizes of your partitions manually, you need to select
this option. If you have not previously set up your partitions (see Section 2.3), you may click the
button to run GParted at this point and create them. You must have your partitions created before
moving on if you want to select this option.

Figure 2-16: Installer Screen 2

Comments

(If you chose Auto-install using entire disk on Screen 1, you will not see this screen.)

� Choose Partitions. Specify the root and swap partitions you have set up previously; if you set up
a separate partition for your home directory, specify it here, otherwise leave /home set to root.

� Note that the /home partition being root means here that the user's /home folder will be
inside the same (root) partition where MX is being installed

� Many users prefer to locate their home directory in a di�erent partition that that of / (root),
so that any problem with � or even total replacement of � the installation partition will
leave all the user's individual settings untouched.
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� Preferences.

� Check Preserve data in /home if you are doing an upgrade and already have data in an
existing home partition. This option is not generally recommended because of the risk that
old con�gurations will not match the new installation, but can be useful in speci�c situations,
e.g. repairing an installation.

� Select Check for badblocks if you want to do a scan for physical defects on the hard drive
during formatting. This is recommended for users with older drives.

� You can change the label of the partition where you want to install (e.g., to �MX-15 Testing
Installation�)

� Finally, you can optionally select the type of �le system you want to use on the hard drive. If
you don't know what to choose here, the default ext4 is recommended in MX Linux.

Figure 2-17: Installer Screen 3

Comments

� Note that the partition shown here (sda1) is just an example; your particular selection of partition
may well di�er.

� If you have any doubts about that whether you want to destroy all the data on the partition that you
see listed in this warning message, click No and then use the Back button to review your choices.
Launch Gparted for more details about a particular partition.
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Figure 2-18: Installer Screen 4

Comments

� Most average users will accept the defaults here, which will install the bootloader into the very
beginning of the disk. This is the usual location and will cause no harm.

� When you click Next, a pop-up message will check to see that you accept the location of the
bootloader GRUB. Installing GRUB can take a few minutes in some situations.
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Figure 2-19: Installer Screen 5

Comments

� Many users choose a unique name for their computer: laptop1, MyBox, StudyDesktop, UTRA, etc.
You may also just leave the default name as it is.

� You can just click Next here if you have no computer network.

Figure 2-20: Installer Screen 6
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Comments

� The default settings will usually be correct here, as long as you were careful to enter any exceptions
at the LiveMedium boot screen.

� The settings can be changed again once you have booted into Xfce with TimeSet, Keyboard, etc.

Figure 2-21: Installer Screen 6 (extra)

Comments

� This screen only shows if �View� was clicked at Screen 6, item d.

� Services are applications and functions associated with the kernel that provide capabilities for upper-
level processes.

� These applications and functions require time and memory, so if you are concerned about the
capacity of your computer, you can look at this list for items that you are sure you do not need.
For instance, a user who has no need for Bluetooth (for a mouse or keyboard, for example) can
comfortably uncheck that service.

� If you do not understand what a service is and does, you do best to leave it alone.

� If you later want to change or adjust the startup services you have two choices.

� a command-line tool called sysv-rc-conf is installed by default and must be run as root.

� a graphical tool called Boot-Up Manager (BUM) can be installed from the repos.
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Figure 2-22: Installer Screen 7

Comments

� The level of security on the passwords you choose here will depend greatly on the setting of the
actual computer. A home desktop is generally less likely to be broken into than a laptop or a
computer in a public space.

� If you check Autologin, you will be able to bypass the login screen and speed up the boot process.
The downside of that choice is that anyone with some kind of access to your computer would be
able to log directly into your account. You can later change your autologin preferences on the
�Options� tab of the MX User Manager.

� You can transfer any changes you make to your Live desktop to the HD installation by checking
the last box. A small amount of critical information (e.g., the name of your wireless Access Point)
will be translated automatically.

2.6 Troubleshooting

2.6.1 No operating system found

When rebooting after an installation, it sometimes happens that your computer reports that no operating
system or bootable disc was found. It also may not show another installed OS such as Windows. Usually,
these problems mean that GRUB did not install properly, but that is easy to correct.

� If you can boot into at least one partition, open there a root terminal and run this command:

update-grub

� Otherwise, proceed with MX Boot Repair.

� Boot to the LiveMedium.

� Launch MX Tools > Boot Repair.

� Make sure that �Reinstall GRUB Bootloader� is selected, then click OK.
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� If this still does not �x it, you may have a faulty hard drive. Usually, you will have seen a
SMART warning screen about it when you began your installation.

2.6.2 Data or other partition not accessible.

Partitions and drives other than the one designated as boot may not be booted or require root access
after installation. There are a couple of ways to change this.

� GUI. Click Start menu > System > Disk Manager. Check anything you want mounted at boot
and save; when you reboot it should be mounted and you will have access in Thunar. See HELP:
Disk Manager for details.

� CLI. Open a root Thunar and navigate to the �le /etc/fstab; click on it to open it in a text editor.
Look for the line containing the partition or drive to which you want access (you may need to type
blkid in a terminal to identify the UUID). Change it following this example for a data partition.

UUID=9501<snip>912 /data ext4 users 0 2

This entry will cause the partition to be automatically mounted at boot time, and also allow you
to mount it and umount it as a normal user.This entry will also cause the �le system to be checked
periodically at boot time. If you don't want it mounted automatically at boot time then change
the options �eld from "user" to "user,noauto".

� If you don't want it checked regularly then change the �nal "2" to a "0". Since you have an
ext4 �lesystem I suggest you enable the automated checking.

� If the item is mounted but not showing in Thunar, add an additional "comment=x-gvfs-show"
to the line in your fstab �le, which will force the mount to be visible. In the example above,
the change would look like this:

UUID=9501<snip>912 /data ext4 users,comment=x-gvfs-show 0 2

NOTE: neither of these procedures will change Linux permissions, which are enforced on the folder and
�le level. See Section 7.3.

2.6.3 Keyring problems

If you set a password the �rst time the GNOME Keyring dialog box appeared (usually when you set up
Network Manager), then you will be obligated to reenter it every time you boot. There are two ways to
change that:

� Install seahorse from the repos. Open a root Terminal and enter the command seahorse, Right
click on Default Keyring > Change Password. Replace the password for the �Default� keyring with
an empty return. Details on the use of seahorse here.

� Navigate in Thunar to ~/.local/share/keyrings/ and delete the network password. The next time
the dialog box appears asking for a new password, just hit return to store a blank password.

Note that if malevolent agents get physical access to your machine, using a blank password will make
it easier to break into. But it seems pretty clear that if a malevolent agent has physical access to your
machine it's all over anyway.

32

http://mxlinux.org/wiki/help-files/help-disk-manager
http://mxlinux.org/wiki/help-files/help-disk-manager
https://www.linux.com/learn/tutorials/456149:manage-passwords-encryption-keys-and-more-with-seahorse


2.6.4 Locking up

If MX Linux is locking up during installation, it is usually due to a problem with faulty computer hardware,
or a bad DVD. If you have determined that the DVD is not the problem, it may be due to faulty RAM,
a faulty hard drive, or some other piece of faulty or incompatible hardware.

� Add one of the Boot Options using F4 at boot or consulting the (MX/antiX Wiki). The most
common problem arises from the graphic driver .

� Your DVD drive may be having problems. If your system supports it, create an MX Linux bootable
USB �ash drive and install from that.

� Systems often lock up due to overheating. Open the computer's case and ensure that all the
system's fans are running when it is turned on. If your BIOS supports it, check the CPU and
Motherboard temperatures (enter sensors in a root terminal if possible) and compare them to the
temperature speci�cations for your system.

� Shut down your computer and remove any non-essential hardware, then attempt the installation
again. Non-essential hardware may include USB, serial, and parallel-port devices; removable PCI,
AGP, PCIE, modem slot, or ISA expansion cards (excluding video, if you do not have onboard
video); SCSI devices (unless you are installing to or from one); IDE or SATA devices that you are
not installing to or from; joysticks, MIDI cables, audio cables, and any other external multimedia
devices.
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3 Con�guration

Things to do after installation

This section covers con�guration instructions in order to get your system running correctly from a fresh
installation of MX Linux, and a short guide to personal customization.

3.1 Peripherals

3.1.1 Smartphone

Android Sharing �les with an Android device.

� Many phones running Android 4.xx includemtp capability, and you can use the following procedure.

� Connect phone.

� Open Thunar. When the upper left pane (Devices) shows your phone's name (or: Storage),
click on it.

� Navigate to the location you are looking for.

� Phones lacking mtp capability can be accessed via a web browser by installing an app from Google's
Play Store such as AirDroid.

Music �les can be viewed and managed using Clementine. Click on Device in the left pane, then
double-click CD Drive if necessary.
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Figure 3-1: Thunar connected to an Android phone

iPhone Through the iPhone 4 series, MX Linux is able to mount an iPhone in Thunar and reveal its
contents for manipulation. Since iOS 5.0, iPhones will not allow a Linux installation to be recognized as
a �trusted connection,� and users usually turn to a cloud storage service to carry out transfers.

See also Section 4.2.

Blackberry Open Synaptic and search on blackberry to �nd the �les that need to be installed.

3.1.2 Printer

Attached MX Linux o�ers two utilities for con�guring and managing printers.

� Print Settings application

� Click Start menu > System > Print Settings

� CUPS in a browser

� Click Start menu > System > Printers (CUPS)

� If your printer is not recognized or does not function correctly, consult the MX/antiX Wiki for help.
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Figure 3-2: the CUPS adminstration screen for managing printers

Network Samba on MX Linux allows printing via the network to shared printers on other computers
(Windows, Mac, Linux) and NAS (Network Attached Storage) devices o�ering Samba services. See also
Section 3.5.

Using the Printing Utility to Set Up Printers

� Click Start menu > System > Print Settings

� Select Server > New> Printer

� Select Network Printer > Windows Printer via SAMBA

� In the dialog window for smb:// enter either servername/printername or server-ipaddress/printername.
For example: bigserver/usbprinter1 or 192.168.0.100/printer2

� If you have trouble identifying the server and printer names, click Start menu > System > MX
Find Shares for details.

� Leave the button selected for Prompt user if authentication is required, then click Forward

� Leave the button selected for Select printer from database and then click Forward

� Select the driver and then Forward

� Describe Printer if necessary and then Apply

� When the printer appears in the window, right-click Properties > Print Test Page to make sure the
connection and driver are operating correctly.

Using the Printers (CUPS) Utility to Set Up Printers

� Click Start menu > Printers (CUPS) � Manage Printers in a Browser utility

� Select Adding Printers and Classes > Add Printer

� In the dialog window enter root's password

� In Add Printer > select appropriate choice (e.g., Windows Printer via SAMBA) > Continue

� In the Connection window, enter smb://servername/printername using same method of �nding
these names as in Printing utility instructions above > Continue
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� Enter printer name and descriptions as you would like...Do not tick Share This Printer > Continue

� Select the printer Make > Continue > Add Printer > choose various options > Set Default Options

� Go to Maintenance > Print Test Page to make sure the connection and driver are operating correctly

Troubleshooting

� There is a troubleshooting utility integrated into the Print Settings application. Click Help >
Troubleshoot.

� For HP printers, the extra package hplip-gui will install a useful applet into the Noti�cation Area
which provides troubleshooting tools.

� If your printer suddenly stops printing, check that is still enabled by clicking Start menu > System
> Print settings, then right-click your printer and enable it again.

3.1.3 Scanner

Scanners are supported in Linux by SANE (Scanner Access Now Easy) which is an application programming
interface (API) that provides standardized access to any raster image scanner hardware (�atbed scanner,
hand-held scanner, video- and still-cameras, frame-grabbers, etc.).

Basic steps You can manage your scanner in MX Linux with the default gscan2pdf. In addition to
being a good general scanner manager, it can export directly to a PDF among other formats. A very
helpful tip on how to save startup time by pre-identifying the device can be found in the Wiki.

Troubleshooting

� Make sure your scanner is listed as supported by SANE on this list.

3.1.4 Webcam

Most likely your webcam video will work in MX Linux. If not, there is a recent detailed discussion of
drivers and setup in the Arch Wiki. Webcam audio is sometimes trickier, see Section 4.1 about Skype.

3.1.5 Storage

Disk drives (such as SCSI, SATA and SSD), cameras, USB drives, phones, etc. � these are all di�erent
forms of storage.

Mounting By default, storage devices that are plugged into the system mount automatically in the
/media/<username>/ directory, and then a �le browser window opens for each (that behavior can be
changed in Thunar: Edit > Preferences). Though it is turned o� by default in MX Linux, you can also
have an icon placed on your desktop for mounted devices place by right-clicking an empty space on the
desktop > Desktop Settings... > Icons tab, Default Icons box: check Removeable Devices.

Permissions The extent of the user's access to storage will depend on the �le system that it contains.
Most commercial external storage devices, especially hard drives, will come preformatted as fat32 or ntfs.
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Storage Filesystem Permissions

fat32 None.

ntfs By default, permissions/ownerships are granted to the user that
mounts the device.

ext2, ext4, and
most Linux
�leystems

Full Linux permission capabilities (Section 7.3), including �le/folder
ownership, edit and view permissions.

SSDs Increasingly, there may be an internal SSD: a solid state drive that has no moving components.
These drives tend to accumulate blocks of data are no longer considered in use, slowing down this very
fast drive. To prevent this from happening, MX Linux runs a TRIM operation on a weekly schedule that
you can view by opening the �le /etc/cron.weekly/fstrim-mx.

3.2 Basic MX Tools

MX Apps

MX New utilities

Figure 3-3: MX Tools dashboard
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A number of applications have been developed speci�cally for MX Linux to save the user e�ort with
important repetitious tasks often involving unintuitive steps. (Advanced tools are treated in Section 6.6)

3.2.1 MX Apt-noti�er

Not shown on the MX Tools dashboard, this extremely handy and versatile applet sits in the Noti�cation
Area where it monitors package updates and noti�es you when they are available with a green arrow
above the yellow box. It is much quicker than going through Synaptic (Section 5.3). Be sure to check
the important options available through the context (right-click) menu.

Figure 3-4: View and upgrade screen from MX Apt-noti�er

HELP: here.
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3.2.2 MX Boot repair

The bootloader is the �rst software program to run and is responsible for loading and transferring control to
the kernel. It sometimes happens that the bootloader on an installation (GRUB2) becomes dysfunctional,
usually because the user has made changes of some kind. This tool allows you to restore the bootloader
to a functional state.

Figure 3-5: MX Boot Repair main screen

HELP: here.

3.2.3 MX Broadcom Manager

MX Broadcom Manager

Broadcom chipsets are often di�cult to set up, and this application renders the process much easier by
detecting hardware and permitting Linux and Windows drivers to be added, removed, and blacklisted.
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Figure 3-6: MX Broadcom Manager detecting wireless and wired hardware

HELP: here.

3.2.4 MX Check Apt GPG

Apt (Apt-get) includes package authentication in order to improve security. You can still install non-
authenticated packages, but you will run into an error: The following signatures couldn't be veri�ed
because the public key is not available. This helpful utility saves carrying out the many steps necessary
to obtain that key.
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Figure 3-7: Results of checking repo public keys with MX Check Apt GPG

HELP: here.

3.2.5 MX Codecs Downloader

A codec is a piece of software that enables encoding/decoding a digital data stream or signal. Most
codecs will be installed in MX Linux by multimedia applications such as VLC, but some are restricted.
This tool allows easy installation of certain restricted codecs while transferring the responsibility to the
user.

Figure 3-8: MX Codecs installer main screen

HELP: here.
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3.2.6 MX Find Network Shares

This simple but handy utility shows all shares, i.e., computer resources available to a user's machine.

Figure 3-9: Search screen of MX Find Shares

HELP: here.
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3.2.7 MX Flash Manager

Enabling Adobe Flash

This application facilitates the installation, removal and especially the updating of Flash players.

Figure 3-10: MX Flash Manager main screen

HELP: here.
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3.2.8 MX Menu Editor

MX Menu Editor

This simple menu editor makes it easy to edit, add or delete menu items. Any edits are saved to the user's
directory /.local/shared/applications/, which takes precedence over the /usr/share/application/
when the Xfce menu gets built during startup. Also available by right-clicking the Start menu icon >
Edit Applications.

Figure 3-11: MX Menu Editor with the category Multimedia expanded

Note: the MX Menu Editor can be easily accessed through the context menu of the Whisker icon in the
lower left corner.

HELP: here.
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3.2.9 MX Package Installer

Package Installer

With this application (originally called metapackage-installer) you can install popular packages in a sim-
pli�ed manner. This ability is particularly useful for installations that are not intuitive or require multiple
packages. It is also very handy for installing language packs, which can be troublesome to chase down
with other methods.

Figure 3-12: MX Package Installer main screen

If you would like to suggest changes in the package list, please post on the MX Forum.

HELP: here.

3.2.10 MX Panel Orientation

MX Linux ships with the Panel in vertical orientation. Some users prefer a horizontal orientation, but it
takes a lot of �ddling around to set it up so it looks good and is useable. This nifty application provides
a one-click switch to a standard horizontal panel.
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Figure 3-13: Ready for a one-click change

HELP: here.

3.2.11 MX Repo Manager

Although the most appropriate repository for a user is selected automatically during installation, there are
many reasons why the user might want later to change that choice, ranging from a server being o�ine to
a change in the physical location of the computer. This great tool provides one-click switching of repos,
saving a lot of time and e�ort.

Figure 3-14: Choosing a repository to use

HELP: here.

3.2.12 MX Sound Card

Computers frequently have more than one sound card available. In a common situation, for instance, a
separate card may be present for HDMI output. Unless the correct sound card is identi�ed for the system,
the user will hear nothing and conclude that sound is not working. This clever little application allows
the user to select which sound card should be used by the system, whether in a particular instance or in
general.
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Figure 3-15: Making the selection in Sound Card

HELP: here.

MX System Sounds

This little tool gathers into a single location the various actions and choices involved in setting up system
sounds such as login/logout, actions, etc.

Figure 3-16: Setting up login and logout sounds

HELP: here.

3.2.13 MX Test Repo Installer

MX Linux maintains a Testing repo for new applications and/or versions that need testing on various
hardware before being placed into the Main repo. Since it is recommended that the Testing repo be
disabled by default, this tool saves hunting around and making many keystrokes when a user wants to
install a single package from it by displaying the contents of the Testing repo and enabling installation
with a single click.

48

http://mxlinux.org/wiki/help-files/help-sound-card
http://mxlinux.org/wiki/help-files/help-mx-system-sounds


Figure 3-17: List of available packages, with version info in tooltip

HELP: here.

3.2.14 MX USB Unmounter

This tool for quickly unmounting USB and optical media sits in the Noti�cation Area after being enabled.
A single click displays available media for unmounting with a double-click.

Figure 3-18: USB Unmounter with a device highlighted for unmounting

HELP: here.

3.2.15 MX User Manager

Everything in Linux runs under a speci�c user, and each user's permissions govern whether and how
it runs. The superuser (�root�) can create users, give them speci�c passwords, restrict what they can
do, etc. Moreover, each user belongs to one or more groups. New users are automatically added to
these groups: lp, dialout, cdrom, �oppy, sudo, audio, dip, video, scanner, plugdev, users, fuse, lpadmin
and netdev. In addition, some applications when installed (VirtualBox, for example) will create a new
usergroup, but may or may not add users to it.

This application aids in adding, editing, removing users and groups in your system.
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Figure 3-19: MX User Manager repair screen

HELP: here.

3.3 Display

3.3.1 Resolution

Resolution refers to the physical number of columns and rows of pixels creating the display (e.g.,
1920x1200). In most cases, the resolution is correctly set by the kernel during installation or when a
new monitor is connected. If not, you can change it in the following ways:

� Click Start Menu > Settings > Display. Use the pull-down menus to set the correct values for
the monitor you want to adjust.

� For Nvidia cards, you can install the package nvidia-settings that will give you a graphic tool that
you can use to alter settings as root with the command: nvidia-settings

� In di�cult situations, it is possible to manually alter the con�guration �le /etc/X11/xorg.conf.
Always back up the �le before you change it, and check the Forum for help about the use of that
�le.
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3.3.2 Graphic driver

If you are not satis�ed with your display's performance, you may need to upgrade your graphic driver
(make sure to �rst back up the �le /etc/X11/xorg.conf, if used) most easily done using sgfxi (Section
6.5.3). It is also possible, but more complicated, to download directly from the manufacturer. This
method will require you to select and download the correct driver for your system; for system info, open
a terminal and enter: lspci | grep VGA.

Here are driver websites for the three most popular brands (do a web search on �<brandname> linux
driver� for others):

� Nvidia

� ATI

� Intel

Intel drivers must be compiled Compilation , but Nvidia and ATI drivers are easily installed:

� Navigate in Thunar to the folder where the driver was downloaded

� Right-click the �le, select the Permissions tab, check Is executable

� Press CTRL-ALT-F1 to exit X (the graphical environment) and get to a terminal prompt

� Log in as root

� Type: service lightdm stop

� Type: sh <�lename>.run (make sure to use the actual name of the �le)

� Allow the NVIDIA driver turn o� the nouveau kernel

� When it �nishes, type: service lightdm start to start lightdm and xorg again.

Basic adjustment

1. Click Start Menu > Settings Manager > Appearance, Fonts tab

2. Click on the pull-down menu to see the list of fonts and point sizes

3. Select the one you want, and click OK
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Figure 3-20: Changing font details in Settings Manager

Advanced adjustments

1. A number of options are available by running in a root terminal: dpkg-recon�gure fontcon�g-
con�g

2. Firefox: click Edit > Preferences > Content, and make any desired changes.

3. For further adjustment, see the MX/antiX Wiki.

Adding fonts

1. Click Start Menu > System > Synaptic Package Manager.

2. Use the search function for fonts.

3. Select and download the ones you want. The Microsoft core fonts package ttf-mscorefonts-
installer provides easy installation of the Microsoft True Type Core Fonts for use with websites
and MS applications that run under Wine.

4. Extract if necessary, then copy as root (easiest in a root Thunar) the font folder to /usr/share/fonts/.

5. Your new fonts should be available in the pull-down menu in Settings manager > Appearance,
Fonts tab.

3.3.3 Dual monitors

Multiple monitors are managed in MX Linux with Start menu > Settings > Display. You can use it
to adjust resolution, select whether one clones the other, which ones will be turned on, etc. It is often
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necessary to log out and back in to see the display you select. Finer control of some features is sometimes
available with lxrandr (install if necessary).

Figure 3-21: Selecting display values in Settings Manager

3.3.4 Power management

Click the Power Manager plugins icon in the Panel. Here you can easily switch to Presentation mode, or
go to the Settings to set when a display shuts down, when the computer goes into suspension, the action
initiated by closing the lid of a laptop, brightness, etc. On a laptop, battery status and information is
displayed and a brightness slider is available.

3.4 Network

Internet connections are handled by Network Manager; click the applet in the Noti�cation Area to see
status, connect and explore options.

Right-click the applet > Edit Connections to open up a Settings box with �ve tabs.

� Wired. In most situations this requires no attention; highlight and click the Edit button for special
setups.

� Wireless

� Network Manager will usually automatically detect your network card and use it to �nd avail-
able access points. In some situations, the command-line tool Ceni in the repos may be
helpful.

� For details, see Section 3.4.2 below.

� Mobile Broadband. This tab allows you to use a 3G/4G mobile device for access to the web. Click
the Add button to set up.

� VPN. Click the Add button to set up. If you experience setup problems, consult the MX/antiX
Wiki.

� DSL. Click the Add button to set up.
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:

Figure 3-22: Network Manager main screen

MORE: Ubuntu Wiki: Network Manager

3.4.1 Wired access

MX Linux typically picks up wired internet access upon boot without much problem.

Ethernet and cable MX Linux comes precon�gured for a standard LAN (Local Area Network) that
uses DHCP (Dynamic Host Con�guration Protocol) to assign IP addresses and DNS (Domain Name
System) resolution. This will work in most cases as-is. You can change the con�guration with Network
Manager.

When you boot MX Linux, your network adapters are assigned a short interface name by udev, the kernel's
device manager. For normal wired adapters this is usually eth0 (with subsequent adapters eth1, eth2,
eth3, etc). USB adapters often come up on the eth0 interface in MX Linux, but the interface name can
also depend on the adapter's chipset. For instance, atheros cards often show up as ath0, while ralink
usb adapters may be rausb0. For more a detailed list of all found network interfaces, open a terminal,
become root, and enter: ifcon�g -a.

It is wise to connect to the Internet through a router, as nearly all wired routers contain optional �rewalls.
In addition, routers use NAT (Network Address Translation) to translate from big Internet addresses to
local IP addresses. This a�ords another layer of protection. Connect to the router directly, or through a
hub or switch, and your machine should autocon�gure via DHCP.

ADSL or PPPoE If you use ADSL or PPPoE, connecting to the internet is easy in MX Linux. Right-
click the Network Manager icon, then the DSL tab. Click the Add... button and �ll in the required
information, checking to connect automatically if you want.

NOTE: if you encounter problems when using a USB device to connect, plug the unit into the computer,
open a terminal and type:

dmesg | tail
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Post a message on Forum with the output to get some help in �nding the driver you need.

Figure 3-23: Setting up DSL service

Dial-Up On the Device tab you will need to set up the serial information. Accepting the default
/dev/modem may work, but you might need to try another interface. These are the Linux equivalents of
the COM ports under MS-DOS and MS-Windows:

Table 3: Linux equivalents for COM ports

Port Equivalent

COM 1 /dev/ttyS0

COM 2 /dev/ttyS1

COM 3 /dev/ttyS2

COM 4 /dev/ttyS3

3.4.2 Wireless access

MX Linux comes precon�gured to autodetect a WiFi card, and in most cases your card will be found and
set up automatically. There are two standard ways wireless can be supported in MX Linux:

� With a native driver that comes as part of the Linux kernel (example: ipw3945 for Intel).

� With a Windows driver using the application Ndiswrapper (available from the repos), which �wraps�
your Windows driver so that it can be used in a Linux system (example: bcmwl5 for some Broadcom
chipsets). See below for more.
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Sometimes there is both a native Linux driver and a Windows driver available. You may want to compare
them for speed and connectivity, and you may have to remove the one you are not using to prevent a
con�ict. Wireless cards can be either internal or external. USB modems (wireless dongles) usually show
up on the wlan interface, but if not then check others on the list. NOTE: The successful method varies
for users because of the complicated interactions among the Linux kernel, wireless tools, and the local
wireless card chipset and router.

Basic Wireless Steps Click Start menu > Settings > Network Connections (or just click on the
Network Manager icon in the Noti�cation Area), and then the Wireless tab. One of 3 situations will arise.

1. A wireless network has been found.

� Click on the line that gives the name of the network.

� Click Edit in the right panel, and enter your information.

� When done, click OK.

2. The found network does not function after the completion of Step 1.

� Find out basic information by opening a terminal and entering one at a time:

lspci
lsusb

� Become root in that open terminal and enter:

iwcon�g -a The output from the �rst commands (example below) will give you the exact

name, model and version (if any) of your wireless chipset, as well as the associated driver and
the mac address; from the second, the name of the access point (AP) you are linked to and
other connection information.

Network
Card-2: Intel Ultimate N WiFi Link 5300 driver: iwlwi�
IF: wlan0 state: up mac: 00:21:6a:81:8c:5a

� Use the information you have gathered in one of the following ways:

� Do a web search using that information. Some examples using the above lspci output.

1) linux Intel Ultimate N WiFi Link 5300 (rev 03)
2) debian stable 00:21:6a:81:8c:5a

� Consult the Linux Wireless site below to �nd out which driver your chipset needs, what
con�icts might exist, and whether it needs �rmware installed separately.

� Post your information on the Forum and ask for help.

� Sometimes using the terminal application Ceni (in the repos) can reveal hidden access points
and other di�cult factors. NOTE: using Ceni to con�gure your network interface in MX
Linux will interfere and/or disable management of that interface by the default Network
Manager. Ceni stores its con�guration info in /etc/network/interfaces. Any interface de�ned
in /etc/network/interfaces will be ignored by Network Manager, as Network Manager assumes
that if a de�nition exists, you want some other application managing the device.

3. No wireless interface is found.

� Open a terminal and type these commands one at a time:

lspci
lsusb

Alternatively, this command may be used:

inxi -n
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� Look for the network entry, and note the detailed information on your speci�c hardware, and
look for more information about that from the LinuxWireless site listed below, or ask on the
Forum.

� If you have an external wi� device and no information on a network card is found, unplug the
device, wait a few seconds then plug it back in. Open a terminal and enter:

dmesg | tail

Examine the output for information about the device (such as the mac address) that you can
use to pursue your issue on the web or the forum.

� Probably the most common example of this situation arising is with the Broadcom wireless
chipsets; see the Technical Documentation Wiki.

Firmware For some cards it is necessary to install �rmware (for example, �rmware-ti-connectivity for
Texas Instruments WL1251). MX Linux comes with a good deal of �rmware already available, but you
may have to track down your particular need, again using the LinuxWireless website linked below.

Ndiswrapper Ndiswrapper is an open-source software driver �wrapper� that enables the use of Windows
drivers for wireless network devices in Linux. It does not come pre-installed in MX Linux, but is in the
repos. NOTE: the Windows driver you use must match the OS architecture (e.g., Windows 32-bit driver
for MX Linux 32-bit edition). In general, Windows XP drivers are required.

The easiest method of managing Ndiswrapper is to use MX Broadcom Manager (Section 3.2.3).

Security Wireless security is handled by Network Manager. Here are the basic steps you need to follow:

� Right-click the Network Manager icon in the Noti�cation Area > Edit connections

� Click on the Wireless tab

� Highlight the name of the access point you want to connect to (for example, �linksys� or �starbucks
2345�)

� Click the Edit button and then the Wireless Security tab

� Use the pull-down menu to select the security you want (for example: WPA and WPA2 Personal)

� Enter the password and click Save.
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Figure 3-24: Wireless security in Network Manager

It is equally possible to use Ceni to handle wireless security, as long as subsequently you will not be using
Network Manager, with which it interferes.

Links

� Linux Wireless

� Debian Wiki: Wi�

� Arch Wiki: Wireless

3.4.3 Mobile Broadband

For wireless internet access using a 3G/4G modem, please refer to the Debian Wiki's 3G pages linked
below for compatibility information. Many 3G/4G modems will be recognized on MX Linux by Network
Manager.

Troubleshooting On some systems, modem connections fail due to an upgrade of the packages udev
and libudev1. To solve this, open Synaptic, highlight the packages, and then click Package> Force
version... Use the pull-down menu to drop to a lower version and click the Apply icon.

In some cases this solution has not worked consistently for users, but they have found that the complete
removal of Network Manager solved the problems.

MORE: Debian Wiki: 3G modem

3.4.4 Command line utilities

Command line utilities are useful for seeing detailed information, and are also commonly used in trou-
bleshooting. Detailed documentation available in the man pages. The most common ones below must
be run as root.
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Table 4: Wireless utilities
Command Comment

ifcon�g Main con�guration utility for network interfaces.

ifup <interface> Brings up the speci�ed interface. For example:
ifup eth0 will bring up the ethernet port eth0

ifdown <interface> The opposite of ifup

iwcon�g Wireless network connection utility. Used by itself, displays wireless
status. Can be applied to a speci�c interface, e.g. to select a

particular access point

rfkill Disable softblock for wireless network interfaces (e.g., wlan).
depmod -a Probes all modules and, if they have changed, enables new

con�guration.

3.4.5 Static DNS

It is sometimes desireable to change your internet setup from the default automatic DNS (Dynamic Name
Service) con�guration to a manual static one. Reasons for doing this may include greater stability, better
speed, parental control, etc. You can make such a change either for the whole system or for individual
devices. In either case, get the static DNS settings you are going to use from OpenDNS, Google Public
DNS, etc., before you start.

System You can make the change for everyone using your router using a browser. You will need:

� the router's URL (list here if you have forgotten)

� its password, if you set one

You will need to �nd and change your router's con�guration panel, following the directions for your
particular router (list of guides here).

Individual For single user change, you can use Network Manager.

� Right-click the connection icon in the Noti�cation Area > Edit connections...

� Highlight your connection and click the Edit button.

� On the IPv4 tab, use the pull-down menu to change the Method to �Automatic (DHCP) addresses
only�

� In the box for �DNS Servers� enter the static DNS settings you are going to use.

� Click Save to exit.

3.5 File management

File management in MX Linux is carried out through Thunar, a fast and powerful tool. Much of its basic
use is self-evident, but here are good things to know:

� Hidden �les are out of sight by default, but can be made visible via the menu (View > Show Hidden
Files) or by pressing Ctrl-H

� The Side Pane can be hidden, and directory (folder) shortcuts can be placed there by right-clicking
> Send To

� The context menu has been populated with common actions that vary by what is present or under
focus.

� Root action is available via the context menu to open a terminal, edit as root, or open an instance
of Thunar with root privileges.
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� Thunar easily handles FTP transfers, see below.

Figure 3-25: Custom actions set up in Thunar

3.5.1 Tips and Tricks

Enable thumbnail images in Thunar

� When working in a directory that requires superuser privileges, you can right-click > Open root
Thunar here.

� You can set up tabs with File > New Tab (or Ctrl-T), then move items from one location to another
by dragging them to a tab and releasing it.

� You can assign a keyboard shortcut key to the Custom Action �Open terminal here.� To do so, �rst
enable editable accelerators in Settings Manager > Appearance > Settings. Then, in Thunar, hover
your mouse over the File > Open in Terminal menu item and press the keyboard combination that
you would like to use for that action. Then when browsing in Thunar, use the keyboard combination
to open a terminal window in your active directory. This applies equally to other items on Thunar's
File menu; for instance, you could assign Alt-S to create a symlink for a highlighted �le, etc.

� Actions listed in the context menu can be edited/deleted, and new ones added, by clicking Edit >
Con�gure custom actions...

� Various options and hidden commands are also visible, see Links below.

� Compressed �les can be managed by a right-click on the �le. The archiver working in the background
is �le-roller (Start menu > Accessories > Archive Manager).

� To �nd �les, open Thunar and right-click any folder > Find �les here. A dialog box will pop up to
give you options. Running in the background is cat�sh (Start menu > Accessories > Cat�sh).
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� To set up a soft link (AKA symlink), right-click the target (�le or folder you want the link to point
to) > Create symlink. Then right-click the new symlink, cut it and paste it to where you want it.

Thunar custom actions

3.5.2 FTP

The File Sharing Protocol (FTP) is used to transfer �les from one host to another host over a network.

� Open Thunar and click on the Browse Network icon in the left pane

� In the address �eld, type the server name with the ftp:// pre�x. For example, to reach the MX
documentation (if you have permission) you would enter this address: ftp://mxlinux.org

� Up pops an authorization dialog box. Fill in username and password, and let it save password if
you are comfortable with that.

� That's it. Once you have navigated to the folder you are always going to use, you can right-click
the folder > Send to > Side Pane to create a very simple way to connect.

� Dedicated FTP applications can be installed with the MX Package Installer.

For a discussion of how FTP works, see this page.

3.5.3 File sharing

There are various possibilities to share �les between computers or between a computer and a device

� Samba. SAMBA is the most complete solution to share �les with Windows machines on your
network without making changes to the Windows machines. SAMBA can also be used by many
network media players and Network-attached storage (NAS)] devices. SAMBA o�ers some other
services for interfacing with Windows networks, such as domain authentication, messaging services,
and netbios name resolution. For details, see below.

� NFS. This is the standard Unix protocol for sharing �les. Many feel it is better than Samba for
sharing �les, and it can be used with Windows (2000 & XP) machines if you install �Services for
Unix� or a third-party NFS client on them. Details: see MX/antiX Wiki.

� Bluetooth: For �le exchange, install blueman from the repos, reboot, pair with the device, then
right-click the bluetooth icon in the Noti�cation Area > Send Files to Device.
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3.5.4 Shares (Samba)

Figure 3-26: Using Thunar to browse network shares

Thunar can connect to shared folders (AKA Samba Shares) on Windows, Mac, Linux computers and
NAS (Network Attached Storage) devices. For printing with Samba, see Section 3.1.2.

� Select Browse Network in the left pane to show various networks, including Windows Network

� Click the Network you want to see available Workgroups (often called WORKGROUP by default).
Now drill down to �nd what you are looking for.

� Select a Workgroup for available Samba Servers

� Select a Server for available Samba Shares

� Select a Samba Share to see all the available folders

� A shortcut for the selected Share will be created in the Network sidebar section

3.5.5 Creating shares

On MX, Samba can also be used to create Shares for other computers (Windows, Mac, Linux) to access.
Creating Public Shares is fairly straightforward, but keep in mind that creating Samba Shares is a complex
area from a con�guration perspective. For example, the task creating Shares that are speci�c to individual
users and are authenticated properly is beyond the scope of this help. Comprehensive reference guides
can be found at Using Samba and Samba.org.
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Basic method Create a share with the Samba con�guration tool

Click Start menu > System > Samba to bring up the Samba Server Con�guration tool. Click on the
plus sign icon to add a share; details available by clicking on the Help icon. NOTE: users often �nd that
the con�guration tool must be augmented with the manual method, below.

Manual method Create a share manually

If for some reason you need or want to create shares manually, follow these steps.

� Use an existing /home/foldername or create a folder and make it Read & Write for Owner, Group:
users, and Others. In other words, make it open to the world. Starting with a simple Public Share
is a good place to learn. NOTE: If you are concerned about network security do not use this
approach. Instead, study the references above to learn how to create secure shares.

� To establish the Samba Share, you must edit the con�guration �le as root. It can be found at:
/etc/samba/smb.conf Edit the line: workgroup = xxxxx to match whatever Windows Workgroup
name you are using (default is WORKGROUP)

� At the very end of the �le add the following lines to establish your Share

[SHARENAME]
path = /home/username/foldername
guest ok = yes
read only = no
browseable = yes
force create mode = 777
force directory mode = 777

� Save the �le. When adding a share, the Samba daemon should read it and implement the changes
immediately. If you make changes to an existing share, you will need to restart Samba to make sure
your changes take e�ect by going to the terminal and becoming root and entering: service samba
restart

� You can also check for mistakes in smb.conf by running testparm from the terminal

� Go to another computer and test your ability to see your Samba Share by browsing the network
and testing read & write to the Share

MORE: Xfce Docs: Thunar

3.6 Sound

MX Linux sound depends at the kernel level on Advanced Linux Sound Architecture (ALSA), and at the
user level on PulseAudio. In most cases sound will work out of the box, though it may need some minor
adjustment. Click on the speaker icon to mute all audio, then again to restore. Place cursor over speaker
icon in the Noti�cation Area and use scroll wheel to adjust volume. See also Sections 3.6.4, 3.6.5 and
3.8.9.

3.6.1 Sound Card Set-up

If you have more than one sound card, be sure to select the one you want to adjust using the tool MX
Select Sound. The sound card is con�gured and volume of selected tracks adjusted by right-clicking the
speaker icon in the Noti�cation Area > Open Mixer. If problems persist after logging out and back in,
see Troubleshooting, below. For details about PulseAudio, see below.
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3.6.2 Simultaneous card use

There may be times when you would like to use more than one card simultaneously; for instance, you
may want to hear music both through headphones and through speakers in another location. This is not
easy to do in Linux, but check the PulseAudio FAQ. Also, the solutions on this MX/antiX Wiki page may
work, if you are careful to adjust the card references to your own situation.

3.6.3 Troubleshooting

� No sound, though speaker icon is in the Noti�cation Area.

� Try raising all controls to a higher level.

� Edit the con�guration �le directly: see Section 7.4.

� No sound, and no speaker icon is in the Noti�cation Area. It could be that the sound card is missing
or unrecognized, but the most common problem is that of multiple soundcards, which we address
here.

1. Solution 1: click Start menu > Settings > MX Sound Card, and follow the screen to
select and test the card you want to use.

2. Solution 2: use the volume control of PulseAudio (pavucontrol) to select the correct sound
card

3. Solution 3: enter the BIOS and turn o� HDMI

4. Check the ALSA sound card matrix listed below.

3.6.4 Sound servers

Whereas the Sound Card is a hardware item accessible to the user, the Sound Server is software that
works largely in the background. It permits general management of sound cards, and provides the ability
carry out advanced operations on the sound. The most common is described here.

Install PulseAudio

� PulseAudio. PulseAudio is an advanced open-source sound server that can work with several
operating systems, and is installed by default in MX Linux beginning with MX-15. It has its own
mixer that allows the user to control the volume and destination of the sound signal.

� According to the Debian Wiki, it is possible to switch PulseAudio on/o� if needed.
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Figure 3-27: Using PulseAudio Mixer

3.6.5 Links

� MX/antiX Wiki: Sound not working

� ALSA: SoundCard Matrix

� ArchLinux Wiki: PulseAudio Information

� PulseAudio Documentation: Free desktop

3.7 Localization

MX Linux is maintained by an international Dev Team that constantly works to improve and expand
the options for localization. There are many languages into which our documents have not yet been
translated, and if you can help with this e�ort please post on the Translation Forum.

3.7.1 Installation

The primary act of localization occurs during the use of the LiveMedium.

� When the bootloader screen �rst comes up, make sure to use the function keys to set your prefer-
ences.

� F2. Select the language

� F3. Select the timezone you wish to use.

� If you have a complicated or alternative setup, you can use boot cheat codes. Here is an
example to set a Tartar keyboard for Russian: lang=ru kbvar=tt . A full list of the boot
parameters (=cheat codes) can be found in the MX/antiX Wiki.

� If you set the locale values at the boot screen, then Screen 7 should show them during installation.
If not, or if you want to change them, select the language and timezone you want.
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3.7.2 Post-installation

Figure 3-28: Adding another keyboard layout in Settings Manager

Here are the con�guration steps you can take to localize your MX Linux after installation.

� Change the keyboard:

� Click Start Menu > Settings > Settings Manager > Keyboard, Layout tab.

� Uncheck Use system defaults, then click on the +Add button at the bottom and select the
keyboard(s) you want available.

� Exit, then click Keyboard Switcher (�ag) in the Noti�cation Area to select active keyboard.

� Get language packs for major applications: click Start menu > System > MX Package Installer,
provide the root password, then click Language to �nd and install language packs for the applications
you use.

� Change time settings: click Start Menu > System > TimeSet and select your preferences. If
you are using the digital clock DateTime, right-click > Properties to choose 12h/24h and other
local settings.

� Get spellchecker to use your language: install the aspell or myspell package for your language
(e.g., myspell-es).

� Get local weather info: right-click the Panel > Panel > Add New Items > Weather Update.
Right-click > Properties, and set the locale you want to see (it will guess by your IP address).

� For Firefox localization, install the appropriate �refox-l10n- package for your language of interest;
e.g., for Spanish (Spain), install �refox-l10n-es.

� You may need or want to change the localization info (default language, etc.) available to the
system. To do so, open a terminal, become root and enter:

dpkg-recon�gure locales

� You a see list with all the locales that you can scroll through using the up and down arrow
keys.

� Enable and disable what you want (or don't want), using the spacebar to make the asterisk
in front of the locale appear (or disappear).
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� When done, click OK to advance to the next screen.

� Use arrows to select the default language you want to use. For US users, for instance, that
would typically be en_US.UTF-8.

� Click OK to save and exit.

MORE: Ubuntu documentation

Figure 3-29: Re-setting the default language for the installed system

3.7.3 Further notes

� It may happen that an individual application may not have a translation in your language; unless it
is an MX application, we can do nothing about that, so you should send a message to the developer.

� Some desktop �les that are used to create the Start menu may be missing a comment in your
language, even though the application itself does have a translation in that language; please let us
know with a post in the Translation Forum.

3.8 Customization

Customizing the drop-down terminal

Xfce4 makes it very easy to change basic function and look of a user's con�guration, and the integration
of Xfce 4.12 has now provided additional features.

� Most importantly, remember: Right-click is your friend!

� Great control is available through the Settings Manager (Panel icon)

� User changes are stored in Xfce4 con�g �les in the directory: /.con�g/

� Most system-wide Xfce4 con�g �les are in /etc/skel/ or /etc/xdg/

MORE: Xfce Tips and tricks
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3.8.1 Default Theming

Default theming is controlled by a number of customized elements.

� Login screen (modify with Settings manager > LightDM GTK+ Greeter Settings)

� Theme: Mediterranean Darkest

� Login box: modi�ed in default theme via /usr/sbin/lightdm-gtk-greeter

� Desktop:

� Wallpaper: Settings manager > Desktop: Squam_Lake.png

� Settings manager > Appearance: Theme (greybird-thick-grip), Icons (Faenza-Cupertino),
Font (Droid Sans 10)

� Whisker menu setings

1. ~/.con�g/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml

2. /usr/share/themes/Greybird-thick-grip/gtk-2.0/apps/whisker.rc (covers all greybird and
bluebird themes)

3.8.2 General look

The overall appearance can be customized in Start menu > Settings > Settings Manager.

� Click on Appearance to change style, icons, fonts and some settings.

� Click on Window Manager to select the window treatment. For detailed manipulations (e.g., where
does the window show up on the desktop, what desktop does the window appear on, how big should
it be, etc.), install gdevilspie from the repos.

� Click on Desktop (also by right-clicking desktop) to change background, menus, and some icon
settings.

� Manage default desktop icons such as Removable Devices by right-clicking desktop > Desktop
Settings ... > Icons tab.

MORE: Xfce4 docs: Appearance.
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3.8.3 Panel

Figure 3-30: Preferences screen for customization of panels

� To move the panel, unlock it by right-clicking a panel > Panel > Panel Preferences.

� To change display mode inside the Panel, select from the pull down menu: Horizontal, Vertical, or
Deskbar.

� To automatically hide the panel, choose from pull down menu: Never, Always, or Intelligently (hides
the panel when a window overlaps with it).

� Install new panel items by right-clicking an empty space > Panel > Add New Items.You then have
3 choices:

� Select one of the items on the main list that pops up

� If what you want is not there, select Launcher. Once it is in place, right-click > Properties,
click the plus sign and select an item o� the list that pops up.

� If you want to add an item not on either list, then select the empty item icon below the plus
sign and �ll in the dialog box that pops up.

� New icons show up at the bottom of the vertical Panel; to move them, right-click > Move

� Change the look, orientation, etc. by right-clicking the panel > Panel > Panel Preferences.

� The Orage clock (default) as well as the Xfce plugin �Clock� use strftime codes. To change, consult
this page or open a terminal and type man strftime.
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� Create a double row of icons in the Noti�cation Area by right-clicking it > Properties, and decreasing
Maximum icon size until it changes.

� To show all open applications, click Settings Manager > Windows Buttons, and enable �Show
windows from all workspaces or viewports�

� Add or delete a panel in Panel Preferences by clicking on the plus or minus button to the right of
the top panel pull-down menu.

� One-click horizontal panel installation is available from MX Panel Orientation (Section 3.2.10).

MORE: Xfce4 docs: Panel.

Figure 3-31: Default horizontal panel using MX Panel Orientation.

3.8.4 Desktop

Customizing the desktop

The default desktop (AKA wallpaper, background) can be changed in various ways.

� Right-click any image > Set as wallpaper

� If you want the wallpapers available to all users, become root and put them in the /usr/share/xfce4/backdrops
folder; you will probably have to create this folder, either in a root Thunar or in a root terminal
using the command mkdir.

� If you want to restore the default wallpaper, it is in /usr/local/share/backgrounds/.

Many other customizations are available in Settings Manager.

� Change the default theme (greybird-thick-grip) in Appearance. The default theme is a version of
greybird that has larger borders and speci�es the appearance of Whisker menu.

� Add standard icons such as Trash or Home to the desktop in Desktop, icons tab.

� Window behavior such as switching, tiling, and zooming can be customized in Window Manager
Tweaks.

� Window switching via Alt+Tab can be customized to use a compact list instead of traditional
icons
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� Window switching via Alt+Tab can also be set to show thumbnails instead of icons or a
list, but it requires turning on compositing which some older computers may have di�culty
supporting. To enable, �rst deselect Cycle on a list list on the �Cycling� tab, then click on the
�Compositor� tab and check 'Show windows preview in place of icons' when cycling.

� Window tiling can be accomplished by dragging a window to a corner and releasing it there..

� If composting is turned on, Window zooming is available by using the Alt + Mouse Wheel
combination.

� To select a di�erent wallpaper for each Workspace, got to Background and uncheck the option
'Apply to all workspaces.' Then select a wallpaper and repeat the process for each workspace by
dragging the dialog box to the next workspace and selecting another wallpaper.

Figure 3-32: Setting di�erent backgrounds for each workspace

Conky You can display almost any kind of information on the desktop by using Conky

� Install conky-manager2 from the repos.

� Click Start menu > Accessories to �nd Conky Manager.

� In Conky Manager, you can highlight each conky and hit Preview to see what it looks like. Be sure
to close each preview before going to another.

� If it seems that Conky Manager has frozen, check for a window with the preview hiding behind it.

� Check the box to select any conky you want to use. It will be auto-installed.

� The con�guration �les are stored in the folder ~/conky-manager

MORE: Conky home page
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Figure 3-33: One of many conky con�gurations available in Conky Manager 2

HotCorner Opening programs or activating certain actions/e�ects can be facilitated by installing the
Panel plugin HotCorner. Details on installation and use can be found in the Wiki.
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Figure 3-34: The HotCorner settings dialog box

Pull-down terminal Customizing the drop-down terminal

MX Linux ships with a very handy drop-down terminal triggered with F4 (change if needed with Start
menu > Settings Manager > Keyboard: Applications Shortcuts tab). The default con�guration is very
functional, but many options for look and function are available in the Preferences dialog box.

3.8.5 Keyboard

By default, MX Linux uses the keyboard layout that matches the user's language choice. To make another
layout available, see Section 3.7.2.

3.8.6 Menu (�Whisker�)

Customizing Whisker menu
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Fun with the Whisker menu

MX Linux comes by default with the Whisker Menu, though a classic menu can be easily installed by
right-clicking a panel > Panel > Add New Items > Applications Menu. Whisker Menu is highly �exible.

� Right-click the menu icon > Properties to set preferences, e.g.,

� Move categories column to be next to the Panel.

� Change location of Search box from top to bottom.

� Decide which action buttons you want to show.

� Favorites are easy to add: right-click any menu item > Add to Favorites.

� Simply drag and drop Favorites to arrange them as wished. Right-click any entry to sort or remove.

Whisker menu features

Menu entries can be edited with two applications (the menu entry �desktop� �les are located in /usr/share/applications/
and can also be edited as root directly).

� MX Menu Editor (Section 3.2.8).

� A native Xfce application

� Click Start menu > Accessories > Application Finder (or Alt-F3), and right-click any
entry.

� Context menu contains Edit and Hide (the latter can be very useful).

� Selecting Edit brings up a screen where you can change name, comment, command and icon.

Figure 3-35: Menu entry edit screen

3.8.7 Login greeter

The user has a number of tools to customize the login greeter.
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� Click Start menu > Settings > Settings Manager > LightDM GTK+ Greeter settings to
adjust position, background, font, etc.

� Autologin can be (in)activated from MX User Manager > Options tab.

� Some properties of the default login box are set in the code for the default theme (greybird-thick-
grip) and a few related themes. Change theme using Settings Manager > Appearance for greater
choice.

3.8.8 Bootloader

The bootloader (GRUB) menu of an installed MX Linux can be modi�ed by clicking Start menu >
System > Grub customizer. This tool allows users to con�gure some important Grub settings such as
the boot entry list con�guration, names of partitions, etc.

3.8.9 System and Event sounds

Computer beeps are silenced by default in the �blacklist� lines in the �le /etc/modprobe.d/pc-speaker.conf.
Comment out (# at the beginning) those lines as root if you wish to restore them.

Event sounds can be enabled by clicking Settings Manager > Appearance, Settings tab, and checking the
box �Enable event sounds.� If you do not start hearing small sounds when you close a window or logout,
for instance, try these steps:

� Log out and back in.

� Click Start menu > Multimedia > PulseAudio Volume Control, Playback tab, and adjust the level
as needed (start with 100%).

� Click the start menu, type "!alsamixer" (don't forget the exclamation point). A terminal window
will appear with a single audio control (Pulseaudio Master).

� Use F6 to select your audio card, and then adjust the channels that appear to higher volumes.

� Look for channels like "Surround", "PCM" "Speakers", "Master_Surround", "Master_Mono"
or "Master". The channels that are available depend on your particular hardware.

The sound �le of reference is Borealis, located in /usr/share/sounds. A di�erent one named sound-
theme-freedesktop is in the repos, and others can be found with a web search.

3.8.10 Default applications

General The default applications to be used for general operations are set by clicking Start menu >
Settings > Settings manager > Preferred Applications, where you can set four preferences.

� Web browser

� Mail reader

� File manager

� Terminal emulator

Particular Many defaults for speci�c �le types are set during an application's installation. For instance,
*.docx and *.xlsx �les are associated with LibreO�ce when it is installed. But often multiple options
exist for a given �le type, and a user would like to determine which application would launch the �le. A
common example is when a user wants to open an *.mp3 �le with a di�erent music player than Clementine
(default). A simple method exists to make that change.

� Right-click any example of the �le type you are interested in
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� Make one of the following selections:

� Open with <listed application>. This will open the �le with the selected application for
this particular instance, but will not a�ect the default application.

� Open with Other Application. Scroll down the list to highlight the one you want (including
�Use a custom command�), then check Open. The box at the bottom �Use as default for this
kind of �le� is unchecked by default, so check it if you want your selection to become the new
default application that is launched when you click on any �le of that particular type. Keep
it unchecked for one-time usage.

Figure 3-36: Changing default application
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4 Basic use

4.1 Internet

4.1.1 Web browser

� MX Linux comes with the popular browser Firefox installed, which has a terri�c set of add-ons to
augment the user's experience.

Firefox home page

Firefox add-ons

� Upgrades of Firefox come through the MX Linux repos, and are usually available to users within 24
hours of release.

� Other browsers are available for easy download and installation via the MX Package Installer.

4.1.2 Email

� Thunderbird is installed by default in MX Linux. This popular email client integrates well with
Google Calendar and Google Contacts.

� Other lightweight email clients are available from the repos.

4.1.3 Chat

� HexChat. This IRC chat program is installed by default in MX Linux, and makes the exchange of
text messages easier for the user.

HexChat home page

� Pidgin. This graphical, modular instant messaging client is capable of using multiple networks at
once. MX Package Installer.

Pidgin home page

Video Chat

� Skype. A popular proprietary program for instant messaging as well as voice and video chat. It is
cross-platform and can be installed on MX Linux without problem using theMX Package Installer
> Network. It integrates automatically with PulseAudio, which is installed by default.

Installing Skype (MX 14.4)

� Troubleshooting: occasionally Skype does not pick up a particular webcam. That can often be
solved by opening a terminal, becoming root, and issuing two commands one at a time that will
�rst unload, then reload the driver. (If that works, then a script can be written to execute those
commands automatically.)

� modprobe -r uvcvideo
modprobe uvcvideo

� If your voice is not being picked up, try this:

� Sign into Skype, click on Options in the left pane and go to the Sound Devices tab.

� Click on the button to start a test call. While the call is going on, open PulseAudio Volume
Control and go to the Recording tab.

� Still while the test call is going on - change the Skype input to the Webcam microphone.

� Skype home page

See also Section 4.10.6 Google Talk.
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4.2 Multimedia

Listed here are some of the many multimedia applications available in MX Linux. Advanced professional
applications also exist, and can be found through targeted searches in Synaptic.

4.2.1 Music

Figure 4-1: Playing an internet song with Clementine

� Players

� Clementine. A modern music player and library organizer that can play every source from a
CD to a Cloud Service. Installed by default.

Clementine home page

� Audacious. A full-featured music player and manager. MX Package Installer.

Audacious home page

� DeaDBeeF. A lightweight player with a small memory footprint, robust set of basic features,
and a focus on music playback. MX Package Installer.DeaDBeeF home page

� Rippers and editors

� Asunder. A graphical Audio CD ripper and encoder that can be used to save tracks from
Audio CDs. Installed by default.

Asunder home page

� EasyTAG. A simple application for viewing and editing tags in audio �les.

EasyTAG home page

4.2.2 Video

Enabling Adobe Flash DRM

� Troubleshooting: occasionally Skype

78

https://www.clementine-player.org/
http://audacious-media-player.org/
http://deadbeef.sourceforge.net/
http://littlesvr.ca/asunder/
https://wiki.gnome.org/Apps/EasyTAG
http://www.mxlinux.org/mx-15-enabling-adobe-flash-drm-hulucom-and-other-streaming-media-sites


� Players

� VLC. Plays a large range of video and audio formats, DVDs, VCDs, podcasts, and multimedia
streams from various network sources. Installed by default.

VLC home page

� SM Player. A mediaplayer that can play virtually all video and audio formats. MX Package
Installer. The related YouTube Browser for SM Player is installed by default.

SMplayer home page

� Net�ix. Desktop capability of streaming Net�ix movies can be acquired by installing Google
Chrome from MX Package Installer and simply navigate to the site.

Net�ix home page

Figure 4-2: Running desktop Net�ix in Google Chrome

� Rippers and editors

� HandBrake. A video ripper that is easy to use, fast and simple.

HandBrake home page

� DeVeDe. This utility automatically converts material to formats compatible with audio CD
and video DVD standards.

DeVeDe home page

� DVDStyler. Another good authoring utility. MX Package Installer.

DVDStyler home page

� OpenShot. A simple-to-use and feature-rich video editor. MX Package Installer.

OpenShot home page
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4.2.3 Photos

Figure 4-3: Using the crop tool in Mirage

� Mirage. Installed by default in MX LInux, this speedy application is easy to use and allows you to
view and edit digital photos.

Mirage project page

� Fotoxx. This fast application allows easy photo editing and collection management.

Fotoxx home page

� GIMP. The premier image manipulation package for Linux. Help (gimp-help) must be installed
separately, and is available in many languages. Basic package installed by default, full available
from MX Package Installer.

GIMP home page
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4.2.4 Screencasting

Figure 4-4: Main screen of SimpleScreenRecorder

� SimpleScreenRecorder. A simple but powerful program to record programs and games. MX Package
Installer.

SimpleScreenRecorder home page

� RecordMyDesktop. Captures audio-video data of a linux desktop session. MX Package Installer.

RecordMyDesktop home page.

4.2.5 Illustrations

� Pinta. This easy to use drawing/editing program provides a simpli�ed method to create and
manipulate images.

Pinta home page

� LibreO�ce Draw. Diagrams, drawings and pictures can be created and modi�ed with this applica-
tion.

LO Draw home page

� Inkscape. This illustration editor has everything needed to create professional-quality computer art.
MX Package Installer.

Inkscape home page

81

http://www.maartenbaert.be/simplescreenrecorder/
http://recordmydesktop.sourceforge.net/about.php
http://pinta-project.com/
http://www.libreoffice.org/discover/draw/
https://inkscape.org/en/


4.3 O�ce

4.3.1 O�ce suite

MX Linux comes with a great free o�ce suite called LibreO�ce, which is the Linux equivalent and
near drop-in replacement for Microsoft O�ce®. The suite is available under Start Menu > O�ce >
LibreO�ce. LibreO�ce supports the .docx, .xlsx and .pptx �le formats of Microsoft O�ce 2007 and
above.

Figure 4-5: Main dashboard in LibreO�ce

� Installed by default.

� Word Processor: LibreO�ce Writer. An advanced word processor compatible with .doc and
.docx �les.

� Spreadsheet: LibreO�ce Calc. An advanced spreadsheet compatible with .xls and .xlsx �les.

� Presentation: LibreO�ce Impress. Used for presentations, etc., compatible with .ppt and
.pptx �les.

� Draw: LibreO�ce Draw. Used to create graphics and diagrams.

� Math: LibreO�ce Math. Used for for mathematical equations.

� Base: LibreO�ce Base. Used to create and manipulate databases. If using this application
to create or use databases in the native LibreO�ce format, you must also install libreo�ce-
base-drivers and libreo�ce-sdbc-hsqldb matched to your LO version.

� An upgrade to LibreO�ce 5 (from Debian Backports) is available through the MX Package Installer.
It was placed there because the 5 Series is relatively new and likely not as stable as the well-tested
4.3.3.2 with which MX Linux ships. If signi�cant updates to the new version occur, the user can
simply click the same install link in Package Installer.
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4.3.2 O�ce �nances

� GnuCash. Financial software for o�ce use. It is easy to learn, and allows you to track bank accounts,
stocks, income and expenses. Can import data in QIF, QFX and other formats, and supports double
entry accounting. MX Package Installer. The Help package (gnucash-docs) needs to be installed
separately.

GnuCash home page

5

Figure 4-6: New account in GnuCash

4.3.3 PDF

� QPDFview. A fast and lightweight viewer that includes a number of basic tools. Installed by
default.

QpdfView home page

� Adobe Reader for Linux o�ers greater functionality (such as commenting or form �lling). MX
Package Installer (under O�ce).

Adobe Reader home page

� PDFShu�er makes simple the reordering, deleting and adding of PDF pages. Installed by default.

PDFShu�er home page

� gscan2pdf is a handy method of scanning documents to PDF in addition to serving general scanning
needs. Installed by default.

gscan2pdf home page

� For other functions (e.g., creating a PDF form using LibreO�ce), see MX/antiX Wiki: PDF.

4.3.4 Desktop publication

� Scribus. Professional page layout that produces press-ready output. Available via MX Package
Installer.

Scribus home page
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4.3.5 Video meeting

� TeamViewer. Cross-platform application for Remote Support and Online Meetings. Free for private
use.

TeamViewer home page

4.4 Home

4.4.1 Finances

� Grisbi is very useful for the home. It can import QIF/QFX �les, and has an intuitive interface.

Grisbi home page

4.4.2 Media Center

� Kodi Entertainment Center (formerly XBMC) allows users to play and view most videos, music,
podcasts, and all common digital media �les from local and network storage media.

Kodi home page

Kodi Wiki

4.4.3 Organization

� Notes. This handy Xfce plugin (xfce4-notes-plugin) allows you to create and organize sticky notes
for your desktop.

Notes home page

� Osmo. Nice compact application that includes calendar, tasks, contacts and notes.

Osmo home page

� Lightning calendar. Integrated with Thunderbird.
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Figure 4-7: The personal information manager Osmo

4.5 Security

4.5.1 Firewall

� Gufw. A personal �rewall con�guration utility that makes it easier for the user to con�gure the
�rewall. Installed by default.

Gufw home page

Wikipedia: Personal �rewall

4.5.2 Antivirus

� KlamAV. Useful to stop Linux users from unknowingly passing virus-infected emails and other
documents to susceptible Windows users.

KlamAV home page

Wikipedia: Antivirus

4.5.3 AntiRootkit

� chkrootkit. This application scans systems for known and unknown rootkits, backdoors, sni�ers
and exploits.
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chkrootkit home page

Wikipedia: Rootkit

4.5.4 Password protection

� KeePassX. A password manager or safe that helps you to manage your passwords in a secure way.

KeePassX home page

4.5.5 Web access

� Dansguardian. Provides a �exible method of �ltering web access for kids according to your needs.

Dansguardian home page

Figure 4-8: Web �lter in action on Dansguardian

4.6 Accessibility

Various open-source utilities exist for MX Linux users with disabilities by virtue of Xfce4 tools.

� Install at-spi from the repos and reboot.

� Click Start menu > Settings > Accessibility, and tick Enable Assistive Technologies.

� Change the available options to suit your liking.

MORE: Xfce4 documentation

4.7 System

4.7.1 Get root privileges

There are two ways to obtain root (AKA adminstrator, superuser) privileges that you need to make system
changes (e.g., installing software) using a terminal.

� su: requires the root password and grants privileges for entire terminal session

� sudo: requires your user password and grants privileges for a single command
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In other words, su lets you switch user so that you're actually logged in as root, while sudo lets you run
commands in your own user account with root privileges. Also, su uses the environment (user-speci�c
con�guration) of the user root, while sudo allows root-level changes but keeps the environment of the
user issuing the command. In general, MX Linux uses a �true root,� meaning that this Manual and the
Forum will generally instruct the use of su.

MORE: click Start menu > enter �#su� or �#sudo� (without the quotes) in the search space and return
to see the detailed man pages.

Running a root application Some applications that can be found in the Start Menu require that the
user have root privileges: gparted, grub customizer, lightdm gtk+ greeter, etc. Depending on how the
launch command is written, the dialog box that pops up may show that root access will be stored (default
setting) for as long as your session lasts (i.e., until you log out).

Figure 4-9: Dialog box for root password, showing that it will be saved

The next time you launch an application needed root privileges, you will see another dialog box telling
you that they have been granted.without the need for you to enter the password again. If you want to
change that default behavior, uncheck �Remember password� the next time you see it.

4.7.2 Get hardware specs

� Click Start menu > System > System Pro�ler and Benchmark for a nice graphic display that
includes the results of various tests.

� Open a terminal and enter this command:

inxi -F

See Section 6.5 for the many other features of inxi.

87



4.7.3 Create symbolic links

A symbolic link (also soft link or symlink) is a special kind of �le that points to another �le or folder,
much like a shortcut in Windows or an alias in Macintosh. A symbolic link does not contain any actual
data (as a hard link does), it just points to another location somewhere in the system.

There are two ways to create a symlink: Thunar or the command line.

� Thunar

� Navigate to the �le or folder (target of the link) that you want to point to from another
location or under another name

� Right-click what you want to link > Create Symlink, and a symlink is created where you
currently are

� Right-click the new symlink > Cut

� Navigate to where you want the link to be, right-click an open area> Paste. Change if desired
the link name.

� Command line: Open a terminal and type:

ln -s TargetFileOrFolder LinkName

� Be sure to include full path as well as �le/folder names.

� The -s switch indicates that a symbolic link and not a hard link (that points directly to data)
is being created.

� For example, to symlink a �le named �foo� in your Downloads folder to your Documents folder,
enter this:

ln -s ~/Downloads/foo ~/Documents/foo

4.7.4 Find �les and folders

Figure 4-10: Search screen of Cat�sh

Cat�sh is installed by default in MX Linux, and can be launched from the Start menu > Accessories.
It is also integrated into Thunar so that the user can right-click a folder > Find �les here.

Cat�sh home page
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CLI There are some very handy commands for use in a terminal.

� locate. For each given pattern, locate searches one or more databases of �le names and displays
the ones that contain the pattern. For example, typing:

locate �refox

will return an extremely long list with every single �le that has the word ��refox� in its name or its
path. This command is similar to �nd and is best used when the exact �le name is known.

Locate examples

� whereis. Another command-line tool, installed by default. For each given pattern, whereis searches
one or more databases of �le names and displays the �le names that contain the pattern, but it
ignores paths so the return list is much shorter. For example, typing:

whereis �refox

will return a much shorter list something like this:

�refox: /usr/bin/�refox /etc/�refox /usr/lib/�refox
/usr/bin/X11/�refox /usr/share/�refox

/usr/share/man/man1/�refox.1.gz

Whereis examples

� which: Arguably the most convenient tool of all, for a given pattern, which attempts to identify
the executable. For example, typing:

which �refox

returns a single item:

/usr/bin/�refox

Which examples

4.7.5 Kill runaway programs

� Desktop

1. Press Ctrl-Alt-Esc to change the cursor into an �x�. Click on any open screen to kill it,
right-click to cancel. Be careful not to click on the desktop or your session will end abruptly.

2. Task Manager: click Start menu > System > Task Manager, select process and right-click
to stop, terminate or kill.

3. A traditional tool is also available: click Start menu > System > Htop, which brings up
a terminal showing all running processes. Locate the program you want to stop, highlight it,
press F9, then Return.

� Terminal: Press Ctrl-C, which will usually stop a program/command you started in a terminal
session.

� If the above solutions don't work, try these more extreme methods (listed in increasing severity).

� Restart X. Press Ctrl-Alt-Bksp to kill all session processes, leaving you back at the login
screen. Any unsaved work will be lost.

� Use magic SysRq key (REISUB). Hold down Ctrl and Alt keys (sometimes only the left Alt
key will work) along with the Alt-SysRq or Alt-PrtScrn key with another hand, then slowly
press the keys R-E-I-S-U-B; your system should shut down correctly and reboot.
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The purpose of this magic key is to go through several stages that nurse your system safely
out of a failure of some sort, and often only the �rst 2 letters are su�cient. Example, Ctrl-
Alt-SysRq + R, then E, then try what you were attempting to do before the failure, if the
system is still unresponsive, continue with the I, try again and if you still have no joy, you may
as well �nish the sequence and the machine will usually reboot.

Wikipedia: REISUB

� If nothing else works, hold down the power button of your computer for 10 seconds or so until
it shuts down.

Figure 4-11: Task Manager main screen, ready to kill a process.

4.7.6 Track performance

General

� GUI

� Click Start menu > System > System Pro�ler and Benchmark, where you can not only see a
great many speci�cations but also run performance tests.

� Xfce plugins. Xfce 4.12 brings a number of plugins for monitoring the system that can be
placed in the Panel, including Battery Monitor, CPU Frequency Monitor, CPU Graph, Disk
Performance Monitor, Free Space Checker, Network Monitor, Sensor plugin, System Load
Monitor, and Wavelan. They can all be installed with the metapackage xfce4-goodies.

Xfce4 Goodies home page

� Conky. See Section 3.8.3.
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� CLI

� lm-sensors. This hardware health monitoring package is installed by default in MX Linux.
Open a terminal, become root, and enter:

sensors-detect

Click Return to answer yes to all questions. When it has �nished, you will be able to get
detailed information about the readings of the sensors that are available on your system by
opening a terminal and entering: sensors.

Lm-sensors

Battery Battery level is monitored by the Power Manager plugin on the Panel. A dedicated Panel
plugin is also available.

4.7.7 Schedule tasks

� GUI

� Scheduled tasks (gnome-schedule). A very handy way to schedule system tasks without
having to directly edit system �les. Installed by default.

Gnome-schedule home page

� CLI

� You can manually edit crontab, a simple text �le that holds a list of commands that are to
be run at speci�ed times.

Crontab overview

Easy crontab generator

4.7.8 Correct time

If your clock time is always wrong, there are 4 possible issues:

� wrong timezone

� wrong selection of UTC versus local time

� BIOS clock set wrong

� time drift

These issues are usually addressed by using TimeSet (Start menu > System); for command line
techniques, see the MX/antiX Wiki.
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Figure 4-12: Screen of TimeSet, showing various options.

4.7.9 Show Key Lock

On many laptops there is no indicator light for the activation of the CapsLock or NumLock keys, which
can be very annoying. To solve this with an onscreen noti�er, install indicator-keylock from the repos.

4.8 Backup

The most important practice is to back up your data and con�guration �les regularly, a process that is
easy in MX Linux. It is highly recommended that you back up to a di�erent drive than the one your data
is on! The average user will �nd one of the following graphical tools convenient, though CLI methods
will also work.
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Figure 4-13: Main screen of Lucky Backup

� LuckyBackup. An easy program to back up and sync your �les. Installed by default.

LuckyBackup manual

� SystemBack. Makes it easy to create backups of system and users con�guration �les.

SystemBack home page

� Cloud service. There are many cloud services that can be used for backing up or synching your
data. DropBox and Google Drive are probably the best known, but many others exist.

� Cloning. Create a complete image of the harddrive.

� Clonezilla. Download Clonezilla Live from the Clonezilla home page, and then reboot into it.

� CLI tools. See the discussion in the Arch Wiki: Cloning

� CLI commands for doing backups (rsync, rdi�, cp, dd, tar, etc.).

Arch Wiki: Backup

See also Section 6.6.2 Save system to live ISO.

4.8.1 Data

Make sure you back up your data, including documents, graphics, music, and mail. By default, most of
this is stored in your /home directory unless you have a separate data partition or external data location.
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4.8.2 Con�guration �les

Here is a list of items to consider for backup.

� /home. Holds most of the personal con�guration �les.

� /root. Holds the changes you have made as root.

� /etc/X11/xorg.conf. X con�guration �le, if there is one.

� The GRUB2 �les /etc/grub.d/ and /etc/default/grub.

4.8.3 List of installed program packages:

It's also a good idea to save in your /home directory a �le that contains the list of programs that you
have installed with Synaptic, apt-get or Gdebi. If in the future you need to reinstall, you can recover the
names of the �les for reinstallation.

GUI

A handy tool to list packages installed since the system was initially installed can be found by right-clicking
on the apt-noti�er icon in the Noti�cation Area > Apt History. A list of programs you installed via the
apt system will appear that you can copy and paste into a document for storage and reference.

CLI

You can create an inventory of all packages on your system installed since installation by copying this
long command and running it in a terminal. That will create a text �le in your home directory called
�apps_installed.txt� that contains all the package names.

To reinstall ALL those packages at once: make sure that all needed repositories are enabled, then issue
these commands one at a time:

su
dpkg --set-selections < apps_installed.txt
apt-get update
apt-get dselect-upgrade

NOTE: this should not be attempted between MX releases based on di�erent Debian versions (e.g., from
MX-14.4 to MX-15)

4.9 Games

MX Linux comes with only a few simple games, but many more are available. Browsing the extensive list
of games available through Synaptic (click Sections >Games at the bottom of the left panel) or following
the links below will bring up many other titles for your enjoyment.

The following list contains some examples to whet your appetite.

4.9.1 Adventure and Shooter Games

� Chromium B.S.U.: A fast paced, arcade-style, top-scrolling space shooter. Installed by default.

Chromium B.S.U. home page:

� Beneath A Steel Sky: A science-�ction thriller set in a bleak post-apocalyptic vision of the future.

Beneath a Steel Sky home page

� Kq: A console-style role playing game, similar to Final Fantasy.

Kq home page
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� Mars. �A ridiculous shooter.� Protect your planet from the oncoming doom of your jealous neigh-
bours!

Mars home page

Figure 4-14: Enemy warships on the attack in Chromium B.S.U

4.9.2 Arcade Games

� Defendguin: A clone of Defender, where your mission is to defend little penguins.

Defendguin home page

� Frozen Bubble: Colored bubbles are frozen at the top of the playing screen. As the Ice Press
descends, you must pop out groups of frozen bubbles before the Press reaches your shooter.

Frozen Bubble home page

� Planet Penguin Racer: a fun racing game with your favorite penguin.

� Tuxracer home page

� Ri-li: A toy train game.

Ri-li home page

� Supertux: A classic 2D jump'n'run side-scrolling game in a style similar to the original SuperMario
games.

Supertux home page

� Supertuxkart: A much improved version of tuxkart.

Supertuxcart home page
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Figure 4-15: Ri-li train needs a turn choice soon

4.9.3 Board Games

� Gottcode games: Peg-E (Peg solitaire game) installed by default.

Gottcode home page

� Mines (gnomines): A minesweeper game for 1 player.

� Do'SSi Zo'la: The goal of the basic Isola game is to block the opponent by destroying the squares
which surround him.

Do'SSi Zo'la home page

� Gnuchess: A chess game.

Gnuchess home page
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Figure 4-16: High-tension moment in Mines.

4.9.4 Card Games

Here are some fun card games available from the repos.

� Hearts (gnome-hearts):The classic hearts game.

Gnome-hearts home page

� Pysolfc: Over 1,000 solitaire games from a single application.

Pysolfc home page

4.9.5 Desktop Fun

� Xpenguins. Penguins walk around your screen. Can be customized with other characters like
Lemmings and Pooh Bear (need to allow programs to run in root window).

Xpenguins home page

� Oneko. A cat (neko) follows your cursor (the mouse) around the screen. Can be customized with
a dog or other animal.

Wikipedia neko

� PhunLand. Phun is a free game like 2D physics sandbox where you can play with physics like never
before. The playful synergy of science and art is novel, and makes Phun as educational as it is
entertaining.

How to use Phun

� Xteddy. Puts a cute teddy on your desktop. Alternatively you can add your own image.

Xteddy homepage
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� Tuxpaint. A drawing program for kids of all ages.

Tuxpaint home page

Figure 4-17: Budding genius at work in Tuxpaint
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4.9.6 Children

� Three age-appropriate packages of games and educational applications are available from MX Pack-
age Installer.

� In addition, Scratch is a free programming language and online community where you can create
your own interactive stories, games, and animations. MX Package Installer.

Home page: Scratch

Figure 4-18: Coding screen for Dance Party using Scratch

4.9.7 Tactics & Strategy Games

� Freeciv: A clone of Sid Meyer's Civilization© (version I), a turn-based multiplayer strategy game,
in which each player becomes the leader of a stone age civilization, trying to gain ascendency as
the ages progress.

Freeciv home page

� Lbreakout2: LBreakout2 is a breakout-style arcade game where you use your paddle to aim a ball
at bricks until all bricks are destroyed. Many levels and surprises. Installed by default.

Lgames home page

� Lincity: A clone of the original Simcity. You must build and maintain a city and keep its people
satis�ed so that your population grows.

Lincity home page
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� Battle for Wesnoth: A highly-rated turn-based strategy game with a fantasy theme. Build your
army and �ght to regain the throne.

Battle for Wesnoth home page

Figure 4-19: Trying to break through the �rst wall in Lbreakout

4.9.8 Windows games

A number of Windows games can be played in MX Linux by using a Windows emulator such as Cedega
or DOSBox, or some may even run under Wine: see Section 6.1.

4.10 Google tools

Figure 4-20: Integrated Google Calendar and Contacts in Thunderbird

4.10.1 Gmail

Gmail accounts can be easily integrated into Thunderbird. Directions in the Help �le.

4.10.2 Google's Contacts

Google's Contacts can be linked into Thunderbird by using the add-on gContactSync.

MORE: gContactSync home page
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4.10.3 Gcal

Gcal can be set up on a tab in Thunderbird with the add-ons Lightning and Google Calendar Tab.

MORE: Lightning calendar home page

4.10.4 Gtasks

Gtasks can be included in Thunderbird by ticking the Tasks entry of the calendar.

4.10.5 Google Earth

The easiest method of installing Google Earth is by using MX Package Installer, where GE is in the �Misc�
section.

There is also a manual method that may be useful in some installations.

� Install googleearth.package from the repos or directly from the Google repo.

� Open a terminal and enter:

make-googleearth-package

� Once that is �nished, become root and type:

dpkg -i googleearth*.deb

� An error message will appear on screen about dependency problems. Correct that by entering this
last command (still as root):

apt-get -f install

Now �nally Google Earth will appear in Start menu > Internet.

4.10.6 Google Talk

There is a browser plugin called google-talkplugin available from the Google repos that allows you to
make a voice or video call to someone from your Gmail account.
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5 Software Management

5.1 Introduction

5.1.1 Methods

Synaptic is the recommended method for beginners to manage software packages, although other methods
are also available and may be required for certain situations.

5.1.2 Packages

Software operations in MX are accomplished through the Advanced Package Tool (APT) system. Software
is provided in the form of a package: a discrete, non-executable bundle of data that includes instructions
for your package manager about installation. They are stored on servers called repositories, and can
be browsed, downloaded, and installed through special client software called a package manager. The
recommended package manager for MX is Synaptic, though the command-line utility apt-get is also
included for those who prefer it. The graphical utility Gdebi is launched for downloaded *.deb �les
with a single click on the �le name; an alternative is to open a terminal and use the command dpkg -i
packagename.deb

The majority of packages have one or more dependencies, meaning that they have one or more packages
that must also be installed in order for them to work. The APT system is designed to automatically handle
dependencies for you; in other words, when you try to install a package whose dependencies are not already
installed, your APT package manager will automatically mark those dependencies for installation as well.
It can happen that these dependencies can not be met, preventing the installation of a package.

5.2 Repositories

APT repositories (repos) are much more than just web sites with downloadable software. The packages
on repository sites are specially organized and indexed to be accessed through a package manager, rather
than browsed directly.

5.2.1 Standard repos

MX Linux comes with a set of enabled repositories that o�er you both security and choice. If you are new
to MX Linux (and especially if you are new to Linux), it is recommended that in general you stick with
the default repositories at �rst. For security reasons, these repositories are digitally signed, meaning that
packages are authenticated with an encryption key to make sure they are authentic. If you install packages
from non-Debian repos without the key, you will get a warning that they could not be authenticated. To
get rid of this warning and make sure your installations are secure, you need to install missing keys using
Check Apt GPG (MX Tools).

Repositories are most easily added, removed, or edited through Synaptic, though they can also be altered
by hand by editing the �les in /etc/apt/ in a root terminal. In Synaptic, click Settings > Repositories,
then click the button New and add the information. The repo information is often given as a single line,
like this:

deb http://main.mepis-deb.org/mepiscr/mx-test/ mx-15 test

Be careful to note the location of the spaces, which separate the information into four chunks that are
then entered into separate lines in Synaptic.

102

http://en.wikipedia.org/wiki/Advanced_Packaging_Tool


Figure 5-1: Repos, with the main MX-15 repo highlighted

Some repositories carry special labels:

� contrib, which depend on or are accessory to non-free packages.

� non-free, which do not meet the Debian free software guidelines (DFSG).

� security, which contain security-related updates only.

� backports, which contain packages from newer versions of Debian that have been backwards
compiled for Debian Stable (the version MX is built with) to keep your OS up-to-date.

� MX, which contain the special packages that make MX what it is.

The current list of standard MX repositories is kept in the MX/antiX Wiki.

5.2.2 Community repos

MX Linux has its own Community Repos with packages that the Packagers build and maintain. These
packages are distinct from o�cial MX packages coming from Debian Stable, and typically have been
backported from Debian versions in development (testing or even experimental). The Community Repos
are critical to MX Linux, since they permit an OS based on Debian Stable to stay abreast of important
software developments.

NOTE: The two testing repos should only be enabled to download packages for testing, and immediately
disabled afterward. They should not be used on main production machines or mission critical set-ups, as
there is by de�nition a risk that they will break your system.

To �nd out more about what is available, who the packagers are, and even how to get involved, see MX
Community Packaging Project.
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5.2.3 Dedicated repos

In addition to the general repositories such as Debian, MX, and Community, there also exist a certain
number of dedicated repositories associated with a single application. When you add one of them, either
directly or through Synaptic, then you will receive updates. Some are preloaded but not enabled, others
you will add yourself.

Here is a common example (VirtualBox):

deb http://download.virtualbox.org/virtualbox/debian/stable contrib

5.2.4 Development repos

One �nal category of repository exists for acquiring the most recent (and thus least stable) build of an
application. This is done through a version control system such as Git that can be used by the end user
to stay current with development. The user can check out a copy of the application source code into a
directory on a local machine. The portal GitHub is a convenient method of managing projects using Git.

More: Wikipedia: Software repository

5.2.5 Mirrors

MX Linux repositories for both packages and ISOs are �mirrored� on servers at di�erent sites around
the world. These mirror sites provide multiple sources of the same information, and function to reduce
download time, improve reliability, and provide a certain resiliency in case of server failure. During
installation, the most likely mirror will be automatically selected for you based on location and language.
But the user may have reasons to prefer another:

� the automatic assignment at installation may be wrong in some cases

� the user may change residency

� a new mirror may become available that is much closer, faster or more reliable

� an existing mirror may change its URL the mirror being used may go o�ine

MX Repo Manager makes it easy to switch mirrors, enabling you to choose the one that works best for
you.

5.3 Synaptic

Synaptic is a friendly, easy-to-use frontend (GUI) to the APT packaging system. It is a graphical tool
that allows you to install, remove, upgrade, downgrade, or get information on all the software packages
available in the online repositories on your repository list. Note that your root password is required and,
naturally, you will need to be connected to the Internet.

5.3.1 Installing and removing packages

Installing Here are the basic steps for installing software in Synaptic:

� Click Start menu > System > Synaptic Package Manager, supplying the root password if
necessary.

� Hit the Reload button. This button causes Synaptic to contact the online repository servers and
download a new index �le with information on what packages are available, what versions they are,
and what other packages are required for them to be installed. If you get a message that some of
the repositories failed to be contacted, wait a minute and then try again.

104

http://git-scm.com/
https://github.com/
http://en.wikipedia.org/wiki/Software_repository


� If you already know the name of the package you are looking for, just click in the pane on the right
and start typing, and Synaptic will incrementally search for what you type.

� If you don't know the package's name, use the Search box in the upper right corner to locate
software based on name or keywords. This is one of Synaptic's greatest advantages over other
methods.

� Alternatively, use one of the �lter buttons in the bottom left corner:

� Sections provides subareas such as Editors, Games and Amusement, Utilities, etc. You will
see a description of each package in the bottom pane, and can use the tabs to discover more
information about it.

� Status groups packages by their installation situation.

� Origin will show packages from a speci�c repository.

� Custom Filters provides various �lter options

� Search Results will show a list of previous searches for the Synaptic session you are in.

� Click the empty box next to the package you want and select Mark for Installation. If the package
has dependencies, you will be noti�ed and they will automatically be marked for installation as well.
You can also just double-click the package if it is the only one you are installing.

� Right-click the package name again, and check carefully the packages listed under Mark Recom-
mended for Installation; Mark Suggested for Installation is worth looking at as well.

� Some packages also have �Recommended� and �Suggested� packages that can be viewed via right-
clicking the package name. These are additional packages that add functionality to the selected
package, and it is a good idea to look them over.

� Click Apply to begin the installation. You can safely ignore any warning message: �You are about
to install software that can't be authenticated!�

� There may be additional steps: just follow the prompts as you receive them until the installation
completes.

Figure 5-2: Checking recommended packages during package installation.
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Removing Removing software from your system with Synaptic seems as straightforward as installing,
but there is more to it than meets the eye:

� To remove a package, simply right-click it and select Mark for Removal or Mark for Complete
Removal.

� Removal uninstalls the software, but leaves system con�guration �les in case you want to keep
your settings.

� Complete Removal removes the software and the system con�guration �les as well (purging).
Your personal con�guration �les related to the package will not be removed. Check also for
other con�guration �le remnants in Synaptic, category Not installed (residual con�g).

� When you have other programs that depend on the package being removed, those packages will
have to be removed as well. This usually happens when you remove software libraries, services,
or command-line applications that serve as back-ends to other applications. Make sure you read
carefully the summary Synaptic gives you before clicking OK.

� Removing large applications that are composed of many packages can bring complications. Many
times these packages are installed using a meta-package, which is an empty package that simply
depends on all the packages you need for the application. The best way to remove a complicated
package like this is to inspect the dependency list for the meta-package, and remove the packages
listed there. Take care, however, that you don't uninstall a dependency of another application you
want to keep!

� You may �nd that the status category Autoremoveable begins to accumulate packages. These were
installed by other packages and are no longer needed, so you can click on that status category,
highlight all the packages in the right pane, and then right-click them to remove.

Figure 5-3: Getting ready to clear out the autoremovable packages.
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5.3.2 Upgrading and downgrading

Synaptic enables you to quickly and conveniently keep your system up-to-date.

Upgrading Unless you are using a manual method in a terminal, upgrading is typically triggered by the
appearance of a green arrow on the Apt-noti�er in the Noti�cation Area. There are two ways to proceed
when this arrow appears.

� Right click the Apt-noti�er icon > Upgrade all packages. This is the faster method because there
is no wait for software to load, run, etc. Examine the packages that are available for upgrade, then
hit Return to complete the process.

� Left click the icon to open Synaptic

� Click the Mark All Upgrades icon below the menu bar to select all available packages for
upgrade, or click on the Installed (upgradable) link in the left panel to review the packages or
to select upgrades individually.

� Click Apply to begin the upgrade, ignoring the warning message. As the installation process
begins, you have the option of watching the details in a terminal within Synaptic.

� With some package upgrades, you may be asked to con�rm a dialog, enter con�guration information,
or decide whether or not to overwrite a con�guration �le you have altered. Pay attention here, and
follow the prompts until the upgrade completes.

Downgrading Sometimes you may want to downgrade an application to an older version, for instance
because of problems that arose with the new one. This is easy to do in Synaptic:

1. Open Synaptic, supply the root password, and click Reload.

2. Click on Installed in the panel on the left, then �nd and highlight the package you want to downgrade
in the panel on the right

3. On the menu bar, click Package > Force version...

4. Select from the available versions on the pull-down list

5. Click Force Version, then install in the usual manner.

Figure 5-4: Using Force version to downgrade a package
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Pinning Sometimes you may want to pin an application to a speci�c version to keep it from being
upgraded in order to avoid problems with more recent ones. This is easy to do:

1. Open Synaptic, supply the root password, and click Reload.

2. Click on Installed in the panel on the left, then �nd and highlight the package you want to pin in
the panel on the right.

3. On the menu bar, click Package > Lock version...

4. Synaptic will highlight the package in red and add a lock icon to the �rst column.

5. To unlock, highlight the package again and click Package > Lock version (which will have a check
mark).

5.4 Troubleshooting

Synaptic is very reliable, but sometimes you may get an error message. A full discussion of such messages
may be found in the MX/antiX Wiki, so here we will only mention a couple of the most common.

� You get a message that some repos failed to download repository information: this is usually a
transient event, and you simply need to wait and reload.

� If the installation of a package shows that software you have already installed and still want will be
removed, click Cancel to back out of the operation.

� It may happen with a new repository that you see an error message after reloading that says
something like: W: GPG error: [some repository URL] Release: The following signatures couldn't
be veri�ed . This message appears because apt-get includes package authentication in order to
improve security, and the key is not present. To �x this, click Start menu > System > MX
Check Apt GPG and follow the prompts.

� Occasionally, packages will fail to install because their install scripts fail one or more safety checks;
for instance, a package might try to overwrite a �le that is part of another package, or require
downgrading another package due to dependencies. If you have an install or upgrade that is stuck
on one of these errors, it is called a broken package. To �x this, click on the Broken packages entry
in the left panel. Highlight the package and try �rst to �x the problem by clicking Edit>Fix Broken
Packages. If that is not successful, then right-click the package to uninstall it.

� Should you uninstall? Occasionally, con�icts in package dependencies can cause the APT system
to require the uninstallation of a large number of important packages in order to install some other
package. This is rare with the default con�guration, but becomes increasingly likely as you add
unsupported repositories. BE VERY ATTENTIVE whenever installing a package would require
that others be removed! If a large number of packages are going to be removed, you may want to
investigate another method of installing this application.

� Should you keep? When upgrading, you may sometimes be informed that a new con�guration �le
is available for a certain package, and be asked whether you want to install the new version or keep
your current version.

� If the package in question is from an MX repository, it is recommended that you �install the
maintainer's version�

� Otherwise, answer �keep the current version� (N), which is also the default choice.
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5.5 Other methods

5.5.1 Aptitude

Aptitude is a package manager that can be used instead of apt-get or Synaptic. It is available from the
repos, and is particularly helpful when dependency problems arise. Can be run as a straight CLI or as a
primitive GUI.

Figure 5-5: Aptitude's home screen (GUI), showing dependency resolver.

For details on this option, see the MX/antiX Wiki.

5.5.2 Deb packages

The software packages installed through Synaptic (and APT behind it) are in a format called deb (short
for Debian, the Linux distribution that devised APT). You can manually install downloaded deb packages
using the graphical tool Gdebi or the command-line tool dpkg. These are simple tools to install local
deb packages. NOTE: if dependencies can not be satis�ed, you will receive a notice and the program will
stop.
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Figure 5-6: Gdebi ready to install.

Installing deb �les with Gdebi

1. Navigate to the deb package you want to install and click on it. Gdebi will open the install dialog.

2. Click Install.

3. Enter your root password when prompted.

4. Gdebi will attempt to install the package, and report the results.

Installing *.deb �les with dpkg

1. Navigate to the folder containing the deb package you want to install.

2. Right-click an empty space to open a terminal and become root

3. Install the package with the command (substituting the real package name, of course):

dpkg -i packagename.deb

4. If you are installing multiple packages in the same directory at the same time, you can do it all at
once using:

dpkg -i *.deb

NOTE: In a shell command, the asterisk is a wild card in the argument. In this case it will cause
the program to apply the command to any �le whose name ends with .deb.

5. If required dependencies are not installed on your system already, you will get unmet dependencies
errors as dpkg does not automatically take care of them. To correct these errors and �nish the
installation, run this code:

apt-get -f install

6. Apt-get will attempt to rectify the situation by either installing the needed dependencies (if they
are available from the repositories), or removing your .deb �les (if the dependencies can not be
installed).
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5.5.3 CLI methods

It is equally possible to use the command line to install, remove, update, switch repositories and generally
to manage packages. Instead of launching Synaptic to carry out common tasks, for instance, many users
will just open a terminal, become root and use one of these commands.

Table 5: Common commands to manage packages

Command Action

apt-get install packagename Install a certain package

apt-get remove packagename Remove a certain package

apt-get purge packagename Completely remove a certain package

apt-get autoremove Clear out leftover packages after a removal

apt-get update Refresh the package list from the repos

apt-get upgrade Install all available upgrades

apt-get dist-upgrade Intelligently handles changing dependencies with new
versions of packages

For more information, consult the man page for apt-get.

5.5.4 More install methods

Sooner or later some software that you want to install will not be available in the repositories and you
may need to use other installation methods. These methods include:

� RPM packages: Some distributions of Linux use the RPM packaging system. RPM packages are
similar to deb packages in many ways, and there is a command-line program available from MX
Linux to convert RPM packages to debs called alien. It does not come installed with MX Linux,
but is available from the default repositories. After you have installed it on your system, you can
use it to install an rpm package with this command (as root): alien -i packagename.rpm. That
will place a deb �le with the same name in the location of the rpm �le that you can then install as
described above. For more detailed information on alien, see the internet version of its man page
in the Links section at the bottom of this page.

� Source code: Any open-source program can be compiled from the programmer's original source
code if there is no other option. In ideal circumstances, this is actually a pretty simple operation,
but sometimes you can run into errors that require more skill to sort through. Source is usually
distributed as a tarball (tar.gz or tar.bz2 �le). See the Links for a tutorial on compiling programs.

� Miscellaneous: Many software developers package software in their own custom ways, usually
distributed as tarballs or zip �les. They may contain setup scripts, ready-to-run binaries, or binary
installer programs similar to Windows setup.exe programs. In Linux, such programs often end
in .bin. Google Earth, for example, is often distributed this way. When in doubt, consult the
installation instructions provided with the software.

5.5.5 Links

� MX/antiX Wiki: Synaptic errors

� MX/antiX Wiki: Installing Software

� MX/antiX Wiki: Compiling

� Gdebi

� The Debian package management tools

� Debian APT Guide

� Wikipedia: Alien

111

https://linux.die.net/man/8/apt-get
http://mxlinux.org/wiki/applications-system/synaptic-errors
http://mxlinux.org/wiki/system/installing-software
http://mxlinux.org/wiki/system/compiling
https://launchpad.net/gdebi
https://www.debian.org/doc/manuals/debian-faq/ch-pkgtools.en.html
https://www.debian.org/doc/manuals/apt-guide/ch2.en.html
https://en.wikipedia.org/wiki/Alien_%28software%29


6 Advanced use

6.1 Windows programs under MX Linux

There are a certain number of applications, both open-source and commercial, that will allow Windows
applications to run under MX Linux. They are referred to as emulators, meaning that they replicate the
functions of Windows on a Linux platform. Many MS O�ce applications, games and other programs can
be run using an emulator with varying degrees of success ranging from near-native speed and functionality
to only basic performance.

6.1.1 Open-source

Wine is the primary open-source Windows emulator for MX Linux. It is a kind of compatibility layer for
running Windows programs, but does not require Microsoft Windows to run the applications. Installable
through MX Package Installer (under Misc); if installing with Synaptic, select "winehq-staging" to get all
wine-staging packages. Wine versions are rapidly packaged by the Community Repository members and
made available to users, with the latest version coming from the test repo.

� Wine Home Page

� MX/antiX Wiki: Wine

DOSBox creates a DOS-like environment intended for running MS-DOS-based programs, especially
computer games.

� DOSBox homepage

� DOSBox Wiki

DOSEMU is software available from the repos that allows DOS to be booted in a virtual machine,
making it possible to run Windows 3.1, Word Perfect for DOS, DOOM, etc.

� DOSEMU Home Page

� MX/antiX Wiki: DOSEMU

Figure 6-1: Photoshop 5.5 running under Wine
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6.1.2 Commercial

CrossOver O�ce allows you to install many popular Windows productivity applications, plugins and
games in Linux, without needing a Microsoft Operating System license. Supports Microsoft Word, Excel
and PowerPoint (up to 2003) particularly well.

� CrossOver Linux Home Page

� Wikipedia: Crossover

� Application Compatibility

Links

� Wikipedia: Emulator

� Checklist of games and emulators

� DOS Emulators

6.2 Virtual machines

Virtual machine applications are a class of programs that simulate a virtual computer in memory, allowing
you to install any operating system on the machine. It is useful for testing, running non-native applications,
and providing users the feeling of having a machine of their own. Many MX Linux users make use of
virtual machine software to run Microsoft Windows �in a window� to seamlessly provide access to software
written for Windows on their desktop. It is also used for testing to avoid installation.

6.2.1 Setup

Virtual Box: install and con�gure (14.4)

Virtual Box: set up a shared folder (14.4)

A number of virtual machine software applications for Linux exist, both open-source and proprietary. MX
makes it particularly easy to use VirtualBox, so we will focus on that here. For details and the most
recent developments, see the Links section below. Here is an overview of the basic steps to set up and
run VirtualBox:

� Installation. This is most easily done via the MX Package Installer (in MX Tools on the Menu).
VirtualBox appears in the Misc section. This will enable the VirtualBox repository, download and
install the latest version of VirtualBox. The repository will be left enabled, allowing automatic
updates via apt-noti�er.

� Post-installation. Check that your user belongs to the vboxusers group. Open MX User Manager
> Group Membership tab. Select your username and make sure that 'vboxusers' in the Groups list
is ticked. Con�rm and exit.

� Extension Pack. You should download and install the Oracle VM VirtualBox Extension Pack from
the Oracle web site (see Links). After the �le is downloaded, navigate to it with Thunar and click
on the �le's icon. The Extension Pack will open VirtualBox and install automatically.

� Location. Virtual machine �les are stored by default in your /home folder. They can be fairly
large and if you have a separate data partition you may consider making the default folder there.
Go to File>Preferences>General tab and edit the folder location.
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Figure 6-2: Windows 2000 running in VirtualBox

6.2.2 Use

� Create a Virtual Machine. To create a virtual machine start VirtualBox, then click the New
icon on the toolbar. You will need a Windows CD or a Linux ISO. Follow the wizard, accepting
all suggested settings unless you know better � you can always change them later. If your ISO
has PAE, click on System > Options tab and enable it. You may need to increase the memory
allocated to the Guest above the minimum default �gure, still leaving su�cient memory for your
Host OS. For Windows Guests, consider creating a larger virtual HD than the 10GB default � while
it is possible to increase the size later, it is not a straightforward process. Select a Host Drive or
Virtual CD/DVD Disk File

� Select a mount point. Once the machine is set up, then you can select the mount point to be
either the Host Drive or a Virtual CD/DVD Disk File (ISO). Click Settings > Storage, and a
dialog box will pop up where you will see in the middle a Storage Tree with an IDE Controller and a
SATA Controller below it. By clicking on the CD/DVD Drive icon in the Storage Tree, you will see
the CD/DVD Drive icon appear in the Attributes section in the right side of the window. Click on
the CD/DVD Drive icon in the Attributes section to open a drop-down menu where you can assign
the Host Drive or a Virtual CD/DVD disc �le (ISO) to be mounted on the CD/DVD Drive. (You
can select a di�erent ISO �le by clicking on Choose a Virtual CD/DVD disk �le and navigating to
the �le.) Run the machine. The device you selected (ISO or CD/DVD) will be mounted when you
start the virtual machine and your OS can be installed.

� GuestAdditions. Once your Guest OS is installed, be sure to install VirtualBox GuestAdditions by
booting into the Guest OS, then clicking Devices > Install Guest Additions and pointing toward the
VBoxGuestAdditions.iso that it will automatically locate. This will allow you to enable sharing �les
between Guest and Host and to adjust your display in various ways so that it suits your environment
and habits.
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� Moving. The safest way to move or change the settings of an existing Virtual Machine is to clone
it: right-click the name of an existing machine > Clone, and �ll in the information. To use the
new clone, create a new Virtual Machine and in the wizard when you select the Hard Disk, choose
"Use existing hard disk" and select the new clone's *.vdi �le.

� Documentation. Excellent documentation for VirtualBox is available through Help on the menu
bar or as a PDF from the website.

Figure 6-3: Setting the ISO for a new VirtualBox guest (�Some OS�)

Links

� Wikipedia: Virtual Machine

� Wikipedia: Comparison of virtual machine software

� VirtualBox home page

� VirtualBox Extension Pack

6.3 Alternate Window Managers

A window manager (originally WIMP: Window, Icon, Menu, and Pointing device) in Linux is essentially
the component which controls the appearance of Graphical user interfaces and provides the means by
which the user can interact with them. MX Linux is tightly tied to Xfce, as part of its overall approach,
but other possibilities exist for users. MX Linux makes it easy to install the most popular alternatives
through the MX Package Installer, as described below.
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Figure 6-4: MATE running on top of MX Linux, with YouTube Browser open

� Gnome Ultra, a GTK+ based display manager and desktop that provides an ultra-light desktop
environment.

� Gnome Ultra (GOULD), an ultra-light desktop environment

� IceWM, a window manager for the X Window System whose goal is speed and simplicity.

� IceWM Home Page

� IceWM FAQ and Howto

� K Desktop Environment, or KDE for short, a very large and powerful environment. Two versions
available: Lite and Standard; Lite o�ers more application choices. For installation and con�guration
when used over MX Linux, see the MX/antiX Wiki.

� KDE Home Page

� KDE Forum

� LXDE is a fast and light desktop environment whose components can be installed separately.

� LXDE home page

� LXDE Wiki

� MATE is the continuation of GNOME 2 providing an intuitive and attractive desktop environment.

� MATE home page

� MATE Documentation

Once installed, you can choose the window manager you want from the Session Button on the default
login screen and log in to as you normally would. If you replace the login manager with another from the
repos, make sure you always have at least one available upon reboot.

Wikipedia: X Window Managers

6.4 Command Line

Although MX o�ers a complete set of graphical tools for installing, con�guring, and using your system, the
command line (also called the console, terminal, BASH, or shell) is still a useful and at times indispensable
tool. Here are some common uses:

116

http://sourceforge.net/projects/gould
http://www.icewm.org
http://www.icewm.org/FAQ
http://mxlinux.org/wiki/system/kde-on-mx-linux
http://www.kde.org
http://forum.kde.org
http://lxde.org
http://wiki.lxde.org/en/Main_Page
http://mate-desktop.org
http://wiki.mate-desktop.org
http://en.wikipedia.org/wiki/Comparison_of_X_Window_System_desktop_environments


� Launch a GUI application to see its error output.

� Speed up system administration tasks.

� Con�gure or install advanced software applications.

� Execute multiple tasks quickly and easily.

� Troubleshoot hardware devices.

The default program to run a terminal in an MX desktop window is XFCE Terminal, which can be
found at Start Menu > System > Xfce Terminal (Terminal Emulator). Some commands are only
recognized for super user (root), while others may vary the output depending on user.

To obtain temporary root permissions:

1. open Xfce Terminal.

2. type su.

3. enter root's password (nothing will show on the screen)

You will recognize when Xfce Terminal is running with root privileges by looking at the prompt line right
before the space where you type. Instead of a $, you will see a #; in addition, the user name changes to
root written in red. If you try to run as a regular user a command that requires root privileges such as
iwcon�g, you may receive an error message that the command was not found, see a message box that
the program must be run as root, or simply �nd yourself at the prompt again with no message at all.

Figure 6-5: User now has temporary administrative (root) privileges

6.4.1 First steps

� For more information on running Xfce Terminal for solving system problems, please refer to the
topic Troubleshooting at the end of this section. Also, it is advisable to make backups of the �les
you are working on as a root user with the commands cp and mv (see below).

� Though terminal commands can be fairly complex, understanding the command line is just a matter
of putting together simple things. To see how easy it can be, open Xfce Terminal and try a few
basic commands. This will all make more sense if you do it as a tutorial exercise rather than just
reading it. Let's start with a simple command: ls, which lists the contents of a directory. The basic
command lists the contents of whatever directory you are currently in:

ls
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� That's a useful command, but it's just a few short columns of names printed across the screen.
Suppose we want more information on the �les in this directory. We can add a switch to the
command to make it print out more information. A switch is a modi�er we append to a command
to change its behavior. In this case, the switch we want is:

ls -l

� As you can see on your own screen if you are following along, this switch provides more detailed
information on the �les in any directory.

� Of course, we might want to see the contents of another directory (without going there �rst).
To do this, we add an argument to the command, specifying which �le we want to look at. An
argument is a value or reference we add to a command to target its operation. By giving an
argument of /usr/bin/, we can list the contents of that directory, rather than the one where we
currently are.

ls -l /usr/bin

� There are a lot of �les in /usr/bin/! It would be nice if we could �lter this output so that only
entries that contained, say, the word ��re�would be listed. We can do this by piping the output
of the /ls/ command into another command, grep. The pipe, or character, is used to send
the output of one command to the input of another. The command grep searches for the pattern
you give it and returns all matches, so piping the output of the previous command to it �lters the
output.

ls -l /usr/bin | grep �re

� Finally, suppose we want these results saved in a text �le for use at a later time. When we issue
commands, the output is usually directed to the console display; but we can redirect this output
somewhere else, such as to a �le, using the > (redirect) symbol to instruct your computer to make
a detailed list of all the �les that contain the word ��re� in a particular directory (by default your
Home directory, and to create a text �le containing that list, in this case named �FilesOfFire�

ls -l /usr/bin | grep �re > FilesOfFire.txt

� As you can see, the command line can be used to perform complex tasks very easily by combining
simple commands in di�erent ways.

6.4.2 Common commands

Here is a list of rudimentary terminal commands. For a complete reference, see the Links section, below.

Filesystem navigation Table 6: Filesystem navigation commands

Command Comment

cd /usr/share Changes current directory to the given path: �/usr/share�. With no
argument, cd takes you to your home directory.

pwd Prints the current working directory path

ls Lists the contents of the current directory. Use the -a switch to show
hidden �les as well, and the -l switch to show details on all �les. Often
combined with other terms. lsusb lists all the usb devices, lsmod all the

modules, etc.

118



File management Table 7: File management commands

Command Comment

cp source�le destination�le Copy a �le to another �lename or location. Use the -R
switch (�recursive�) to copy entire directories.

mv source�le destination�le Move a �le or directory from one location to another.
Also used to rename �les or directories and to make a
backup: for example before changing a critical �le such
as xorg.conf you might use this command to move it

to something like xorg.conf_bak.
rm �lename Delete a �le. Use the -R switch to delete a directory,

and the -f switch (�force�) if you don't want to be
prompted to con�rm each deletion.

cat �le.txt Prints the contents of a �le on the screen. Only use on
text �les.

grep Find a given string of characters in a given piece of text,
and print the entire line it was on. Usually used with a
pipe, e.g. cat some�le.txt I grep /somestring/ will

display the line from some�le.txt that contains
somestring. To �nd a network usb card, for instance,
you could type: lsusb I grep Network. The grep

command is case sensitive by default, use the -i switch
to make it case-insensitive.

dd Copies anything bit by bit, so can be used for
directories, partitions, and whole drives. Basic syntax is

dd if=<some �le> of=<some other �le>

Symbols Table 8: Symbols

Command Comment

| The pipe symbol used to send the output of one command to the input of
another. Some keyboards show two short vertical bars instead of on

> The redirect symbol, used to send the output of a command into a �le of device.
Doubling the redirect symbol will cause the output of a command to be added to

an existing �le rather than replacing it.

& Adding the ampersand to the end of a command (with a space before it) causes
it to run in the background so that you don't have to wait for it to complete to
issue the next command. Double ampersand indicates that the second command

should only be run if the �rst has been successful.

Troubleshooting For most new Linux users, the command line is mainly used as a troubleshooting tool.
Terminal commands give quick, detailed information that can be easily pasted into a forum post, search
box, or email when seeking help on the web. It is strongly recommended that you keep this information
at hand when asking for help. Being able to refer to your speci�c hardware con�guration will not only
speed up your process of obtaining help, but also it will let others o�er you more accurate solutions. Here
are some common troubleshooting commands (see also Section 3.4.4). Some of them may not output
information, or not as much information unless you are logged in as root.

119



Table 9: Troubleshooting commands

Command Comment

lspci Shows a quick summary of detected internal hardware devices. If a device shows
as /unknown/, you usually have a driver issue. The -v switch causes more

detailed information to be displayed.

lsusb Lists attached usb devices.

dmesg Shows the system log for the current session (i.e. since you last booted). The
output is quite long, and usually this is piped through grep, less (similar to
most) or tail (to see what happened most recently). For example, to �nd
potential errors related to your network hardware, try dmesg I grep -i net.

top Provides a real-time list of running processes and various statistics about them.
Also available from the Start menu as Htop along with a nice graphical version

Task Manager.

Accessing documentation for commands

� Many commands will print out a simple �usage information� message when you use the � --help� or
�-h� switch. This can be helpful for quickly recalling the syntax of a command. For example: cp
--help

� For more detailed information on how to use a command, consult the command's man page

� Manual pages are conveniently accessed through the Start menu by placing a hash mark and the
command name into the search box at the top. For example, you can view the man page for the
copy command with this entry in the search box: #cp

� The man page may also be read at the console with the command man <commandname>. By
default, man pages are displayed in the terminal's most pager, meaning that only one screenful of
the �le is displayed at a time. Keep these tricks in mind to navigate the resulting screen:

� The space bar (or PageDown key) advances the screen.

� The letter b (or PageUp key) moves the screen backward.

� The letter q exits the help document.

Alias You can create an alias (personal command name) for any command, short or long, that you
want. Details in the MX/antiX Wiki.

6.4.3 Links

� BASH Beginners Guide

� Command Line Basics

6.5 Scripts

A script is a simple text �le that can be written directly from a keyboard, and consists of a logically
sequenced series of operating system commands. The commands are handled one at a time by a command
interpreter which in turn requests services from the operating system. The default command interpreter in
MX is Bash. The commands must be understandable to Bash, and command lists have been established
for programming use. A shell script is the Linux counterpart of batch programs in the Windows world.

Scripts are used throughout the Linux OS and applications that run on it as an economical method of
executing multiple commands in an easily created and modi�ed manner.
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During boot, for instance, many scripts are invoked to start up speci�c processes such as printing, network-
ing, etc. Scripts are also used for automated processes, system administration, application extensions,
user controls, etc. Finally, users of all kinds can employ scripts for their own purposes.

6.5.1 A simple script

Let's do a very simple (and famous) script to get the basic idea.

1. Open the text editor Leafpad (Start Menu > Accessories), and type:

#!/bin/bash
clear
echo Good morning, world!

2. Save that �le in your home directory with the name SimpleScript.sh

3. Right-click the �le name, select Properties, and check �Allow this �le to run as a program� on the
Permissions tab.

4. Open a terminal and type:

sh /home/UserName/SimpleScript.sh

5. The line �Good morning, world!� will appear on your screen. This simple script doesn't do very
much, but it does establish the principle that a simple text �le can be used to send commands to
control your system's behavior.

NOTE: All scripts open with a shebang as in the the beginning of the �rst line: it is a combination of
a hash sign (#), an exclamation point, and the path to the command interpreter. Here, Bash is
the interpreter and it is found in the standard location for user applications.

6.5.2 A useful script

Let's look at a useful script for the ordinary user that reduces all the moves involved in backing up multiple
sets of �les into a single keystroke. The script below relies itself on a system script called Rdi�-backup
that would need to be installed from the repos for the script to work. It copies one directory to another,
keeping a record of the di�erences in a special subdirectory so you can still recover �les lost some time
ago. (Incidentally, Rdi�-backup relies in turn on a script called Di�.)
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In this example, a user named �newbie� wants to set up a script to back up documents, music, mail and
pictures from the /home directory to an external drive.

1 #!/bin/bash
2 #
3 # This Rdi�-Backup script backs up to a second hard drive
4 # It must be run as root in order to mount the second hard drive
5
6 # To restore �les, issue the command: cp -a /mnt/sda1/username /home
7 # To restore, but not overwrite:
8 # cp -a -i --�reply=no /mnt/sda1/username /home
9
10 # Mount the external devices
11
12 mount /dev/sdb1
13 mount /dev/sdb2
14 mount /dev/sdb3
15
16 # Execute the backup
17
18 rdi�-backup /home/newbie/Documents /mnt/sdb2/Documents
19 rdi�-backup /home/newbie/Music /mnt/sdb1/Music
20 rdi�-backup /home/newbie/Mail /mnt/sdb2/Mail
21 rdi�-backup /home/newbie/Pictures /mnt/sdb3/Pictures
22
23 # Unmount the external devices
24
25 umount /dev/sdb1
26 umount /dev/sdb2
27 umount /dev/sdb3

Now let's look at this script's components:

� Lines 2-8: a number sign has been placed in front of these lines (called �commenting them out�)
to indicate to Bash that they are not part of the sequence of commands to be executed. Their
purpose here is to provide anyone who looks at this script with information about such things as
the script's origin, creator, purpose, and license (metadata).

� Line 10: good scripts separate the commands into clearly labeled procedural sections, also in lines
16 and 22.

� Lines 12-14: the three devices to be used for the backup have to �rst be mounted so they are
available to the system.

� Lines 18-21: here bash is told to use the system script rdi�-backup to compare the original directories
(sources) with the backup directories (targets), copy over the di�erences it �nds, and keep a record
of the changes.

� Lines 25-27: once the backup work is done, the external drives are unmounted from the system.

Anyone who wanted to use such a script would have to carry out a few execution steps:

1. Copy the whole script.

2. Right-click the desktop and select Create New>Text �le...

3. Give the �le a name that makes sense (no spaces, though), and add the �sh� extension so you will
recognize it is a script. For this example, you might select Backup_DocsMusicMailPictures.sh

4. Open the new text �le and paste in the script.
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5. Change any names, locations, etc. to what they are on your particular system. In the example
above, you may well have di�erent names and/or locations for the directories to be backed up, and
di�erent devices where they are supposed to go.

6. Save that script in a place you can easily �nd it when you need it, let's say you make a new directory
/home/scripts for it.

7. Right-click the script, select Properties, click on the Permissions tab, and check the Is executable
box and click OK.

8. When you are ready to backup, open a terminal and type: sh /home/scripts/Backup_DocsMusicMailPictures.sh
HINT: use the tab key to autocomplete the �le name after you type the �rst few letters.

Links

� Linux Shell Scripting Tutorial

� Directory of Linux Commands

6.5.3 Pre-installed user scripts

The following scripts allow users to help keep their MX Linux installation up-to-date and running as a
rolling release.

smxi When run, smxi allows users to install a new kernel, install ATI and Nvidia graphics drivers, run
apt-get upgrade or apt-get dist-upgrade safely, and lots more! Written by a programmer named �h2�, the
script is pretty much self explanatory, but for usage options, execute smxi -h.

smxi must be run outside of the X window system (i.e., not from the desktop) for most functions.

� From your desktop:

� Press Ctrl-Alt-F1 to get to a terminal prompt.

� Log in as root (su and password)

� Type: smxi

� At boot:

� Type e when on the GRUB menu to be able to edit it

� Add �3� to the end of the kernel line in GRUB's menu entry for MX Linux

� The system will boot directly to the console.

� Log in as �root� (without quotation marks) and supply the appropriate password

� Type: smxi

smxi will ask a series of questions the �rst time it is run, including which system options you want to run.
The following options are recommended:

� continue-no-changes

� apt-get

� apt-get dist-upgrade

After smxi has completed its operations it will ask if you want to restart the desktop. NOTE: Running
smxi -G in a root terminal while inside a running X session allows certain features of smxi to run, such
as removing unwanted kernels etc.

smxi home page

smxi documentation
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sgfxi This h-2 script runs inside smxi or separately, and deals with installing graphical drivers. Sgfxi
currently supports ATI, fglrx and Nvidia drivers. It also supports converting from or to xorg free drivers
like ati, intel, or nv. Follow the procedure above to start the script, replacing smxi with sgfxi.

Sgfxi requires a working internet connection! Some wireless internet connections may be dropped when
operating outside of X. If this applies to your internet connection either temporarily switch over to a wired
internet connection before proceeding or use the 'Partial install in X, completion outside of X method'
instructions in the next section below.

The sgfxi script automatically downloads and installs the kernel headers and everything else it needs.
Then it downloads the binary graphic driver installers from either Nvidia or ATI, prepares system, installs,
then sets up xorg.conf, all in a fairly clean, reasonably intuitive way. Plus it updates itself so any new
drivers released will be installed. Finally, sgfxi allows you to easily switch between proprietary non free
drivers like ATI's fglrx and Nvidia's nvidia driver and the free xorg drivers.

sgfxi manual

inxi A third script from h-2 included in MX Linux is inxi, a convenient command-line system information
script. Enter inxi -h in a terminal to see all the options available, which include an entire range from
sensor output to the weather.

MORE: MX/antiX Wiki

6.6 Advanced MX Tools

In addition to the con�guration MX Apps discussed in Section 3.2, MX Linux includes 2 utilities for the
advanced user available from MX Tools.

6.6.1 Create live USB

WARNING: for use on a hard drive installation only!

Although UNetbootin is available by default (see Section 2.2.3). antix2usb has a number of advantages:

� It is faster.

� It gives users the signi�cant advantage of setting up persistence prior to creating the USB stick.

� It allows a partition to be created on the USB drive.

� It o�ers other advanced options.

Figure 6-6: The antix2usb tool for creating a live usb

124

http://smxi.org/docs/sgfxi-manual.htm
http://www.mxlinux.org/wiki/antix-faqs-applications/guide-smxisgfxiinxi


HELP: here.

6.6.2 Live remaster/persistence (RemasterCC)

�Remaster� WARNING: for use in a Live session only!

The primary purpose of live remastering is to make it as safe, easy, and convenient as possible for users
to make their own customized version of MX Linux that can be distributed to other computers.

The idea is that you use a LiveUSB (or a LiveHD: a frugal install (see the MX/antiX Wiki) to a hard
drive partition as the development and testing environment. Add or subtract packages and then when
you are ready to remaster, use a simple remaster script or GUI to do the remaster and then reboot. If
something goes horribly wrong, simply reboot again with the rollback option and you will boot into the
previous environment.

�Persistence� WARNING: for use in a Live session only!

WARNING: may fail with large upgrades that can overwhelm the RAM. Alternative procedures are
available.

� Carry out the upgrade in stages, using small (e.g., 200MB) amounts each time

� Wait for the next monthly snapshot, and reinstall. Make sure to copy any non-system folders o�
the stick beforehand

Live USB with persistence (legacy mode)

Live USB with persistence (UEFI mode)

Persistence is a hybrid between a LiveMedium and a full install; it allows you to retain any �les you install
or add during a live session. Programs installed or removed from, and customizations to, the "demo"
user �les during live persistence will be carried over to the installed system.

Figure 6-7: The remaster and persistence tool

HELP: here.

6.6.3 Save system to ISO (Snapshot)

This tool makes a copy of your running system and creates an ISO from it.

The ISO can be put on a LiveMedium in the usual manner (see Section 2.2). To then install from the
LiveMedium, open a root terminal and enter the command: minstall.
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Figure 6-8: Opening screen of Snapshot HELP: here.

6.7 SSH

SSH (Secure Shell) is a protocol used to securely log onto remote systems. It is the most common way
to access remote Linux and Unix-like computers. MX Linux comes with the main packages necessary to
run SSH in active mode, the main one being OpenSSH, a free implementation of the Secure Shell that
consists of a whole suite of applications.

� Start or restart the ssh daemon as root with the command:

/etc/init.d/ssh start

� To start the ssh daemon automatically when the computer starts, click Settings manager >
Session and Startup > Application Autostart. Click the Add button, then in the dialog box
insert a name such as StartSSH, a short description if you want, and the command

/etc/init.d/ssh start

Press OK and you are done. The next time you restart, the SSH daemon will be active.

� KDE users on MX Linux can do the same using Preferences > Settings > Start & Stop >
Automatic Start.

6.7.1 Troubleshooting

Occasionally, SSH does not work in passive mode, sending a message of denied connection. Then you
can try the following:

� Edit as root the �le '/etc/ssh/sshd-con�g'. About line 16 you will �nd the parameter 'UsePrivi-
legeSeparation yes'. Change that to

UsePrivilegeSeparation no

� Add yourself (or the intended users) to the group 'ssh' using MX User Manager or editing as root
the �le /etc/group.
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� Sometimes the certi�cates can be missing or outdated; an easy way to rebuild them is to run (as
root) the command

ssh-keygen -A

� Check if sshd is running by typing

/etc/init.d/ssh status

The system should answer '[ ok ] sshd is running.'

� If you are using a �rewall, check that port 22 is not blocked. It must allow IN and OUT tra�c.

MORE: Openssh manual
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7 Under the hood

7.1 Introduction

MX Linux ultimately inherits its fundamental design from Unix, an operating system that has been around
in various forms since 1970, much earlier than MS-Windows. From that Linux was developed, from which
Debian develops its distribution. The base operating system is the topic of this section. Users coming
from Microsoft Windows typically �nd a lot of unfamiliar concepts, and get frustrated trying to do things
the way they are accustomed to doing them.

This section will give you a conceptual overview of some basic aspects of MX Linux, and how they di�er
from other systems to help ease your transition.

Links

� Wikipedia: Unix

� Linux Home Page

� Wikipedia Debian

7.2 The �le system structure

There are two basic uses of the term ��le system�. The �rst is the Operating System's Filesystem. This
refers to the �les and their organization that the operating system uses to keep track of all the hardware
and software resources it has as its disposal while running.

The other use of the term �le system refers to the Disk Filesystem, designed for the storage and retrieval
of �les on a data storage device, most commonly a disc drive. The Disk Filesystem is set when the disk
partition is �rst formatted, prior to writing any data on the partition.

The Operating System's Filesystem One of the �rst problems many new Linux users struggle with
is how the �le system works. If you have been looking around your MX Linux system trying to �nd the
C:\ drive or D:\ drive, for instance, you are searching in vain: MX Linux handles hard drives and other
storage media di�erently from Windows. Rather than having a separate �le system tree on every device,
MX Linux has a single �le system tree ( called the /root/ of the �le system) which is marked �/� and
contains every attached device. When a storage device is added to the system, its �le system is attached
to a directory or subdirectory of the �le system; this is called mounting a drive or device. If you open
Thunar and click on File System in the upper left pane, you will notice a number of directories with names
based on the Unix Filesystem Hierarchy Standard.
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Figure 7-1: The MX �lesystem viewed in Thunar

Here is a simple description of the major directories in MX Linux along with an example of when users
commonly work with �les in those directories:

� /bin

� This directory contains binary program �les which are used by the system during startup, but
which also may be required by user actions once the system is fully up and running.

� Example: Many basic command-line programs, such as the Bash shell, and utilities like /dd/,
/grep/, /ls/, and /mount/ are located here, in addition to programs only used by the OS.

� /boot

� As you might guess, �les that Linux needs to boot are located here. The Linux kernel, the
core of the Linux operating system, is kept here, as are bootloaders such as GRUB.

� Example: no �le here is commonly accessed by users.

� /dev

� In this directory are special �les that link to the various input/output devices on the system.

� Example: no �le here is commonly accessed directly by users, except in CLI mounting com-
mands.

� /etc This directory contains con�guration �les for the system such as well as application con�gu-
ration �les.

� Example: The �le /etc/fstab speci�es mount points for additional �lesystems on devices,
partitions, etc. that can be con�gured for your optimal use.

� Example: display problems sometimes involve editing the �le /etc/X11/xorg.conf.
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� /home

� Here the user's personal directories (data and settings) reside. If there is more than one user,
a separate subdirectory is set up for each. No user (except root) can read another user's
home directory. The user's directory contains both hidden (where the �lename is preceded by
a dot) and visible �les; hidden �les can be revealed by clicking View >Show Hidden Files
in Thunar.

� Example: users typically organize their own �les at �rst by using default directories such as
Documents, Music, etc.

� Example: your Firefox pro�le is located in the hidden directory .mozilla/�refox/

� /lib

� This directory contains shared object libraries (analogous to Windows DLL's) that are required
at boot time. In particular, kernel modules will be found here, under /lib/modules.

� Example: no �le here is commonly accessed by users.

� /media

� Files for removable media such as CDroms, �oppy drives, and USB memory sticks are installed
here when the media are automounted.

� Example: After dynamically mounting a peripheral device like a �ash drive, you may access it
here.

� /mnt

� Physical storage devices must be mounted here before they can be accessed. After drives or
partitions are de�ned in the �le /etc/fstab, then their �le system is mounted here.

� Example: Users can access drives and partitions mounted here.

� /opt

� This is the intended location of major third-party application subsystems installed by the user.

� Example: if you install Google Earth, this is where it will be installed. Some distros also place
user-installed programs in /usr subdirectories.

� /proc

� The location for process and system information

� Example: no �le here is commonly accessed by users

� /root

� This is the home directory for the root user (administrator). Note that this is not the same
as �/� the �le system root.

� Example: no �le here is commonly accessed by users, but �les saved while logged in as the
root user may be saved here.

� /sbin

� Programs are installed here if they are required by the system startup scripts but will not
normally be run by users, other than root�in other words, system administration utilities.

� Example: no �le here is commonly accessed by users, but this is where �les like modprobe
and ifcon�g are located.
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� /tmp

� This is the location of temporary �les produced by programs�such as compilers�as they run.
In general, these are short-term temporary �les, of use to a program only while it is running.

� Example: no �le here is commonly accessed by users.

� /usr

� This directory contains many things for user applications, and is analogous in some ways to
the Windows directory �Program Files�.

� Example: many executables are located in (/usr/bin)

� Example: documentation (/usr/docs) and con�guration �les, graphics and icons are in
(/usr/share).

� Example: many �les speci�c to MX Linux are located in /usr/local/

� /var

� This directory contains �les that are constantly changing while Linux is running, e.g. logs,
system mail and queued processes.

� Example: you can look in /var/log/ when trying to determine what happened during a
process

The Disk Filesystem The disk �le system is something about which the average user does not need
to be much concerned. The default disk �le system used by MX Linux is called ext4, a version of the
ext2 �le system that is journaled �i.e., it writes changes to a log before enacting them, rendering it more
robust. The �le system ext4 is set during installation when your hard drive is formatted.

By and large, ext4 has more years on its track record than any of its rivals, and combines stability and
speed; for these reasons, we do not recommend installing MX Linux onto a di�erent disk �le system
unless you are well-educated in the di�erences. However, MX Linux can read and write to many other
formatted disk �lesystems, and may even be installed on some of them, if for some reason one of them
is preferred over ext4.

Links

� Wikipedia Filesystem

� Wikipedia. Comparison of �lesystems

� Wikipedia Ext4

� Log �les in the /var/log/ directory

7.3 Permissions

MX Linux is an account-based operating system. This means that no program can run without a user
account to run under, and any running program is thereby limited by the permissions granted to the user
who started it.

NOTE: Much of the security and stability that Linux is known for hinges on the proper use of limited
user accounts, and the protection provided by default �le and directory permissions. For this reason, you
should operate as root only for a procedure that requires it. Never log into MX Linux as root to run the
computer for normal activities�running a web browser as root user, for instance, is one of the few ways
you could get a virus on a Linux system!
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Basic information The default �le permissions structure in Linux is fairly simple, but more than ade-
quate for most situations. For each �le or folder, there are three permissions that can be granted, and
three entities (owner/creator, group, others/world) to which they are granted. The permissions are:

� Read permission means that data can be read from the �le; it also means the �le can be copied.
If you don't have read permission for a directory you can't even see the names of �les listed in it.

� Write permission means that the �le or folder can be changed, appended, or deleted. For directories,
it speci�es whether a user can write to �les in the directory.

� Execute permission means whether or not the user can run the �le as a script or program. For
directories, it determines whether or not the user can enter and make it the current working directory.
Every �le and folder acquires a single user designated as its owner when it is created on the system.
(Note that if you move a �le from another partition where it has a di�erent owner, it will keep the
original owner; but if you copy and paste it, it will be assigned to you.) It also has a single group
designated as its group, by default the group to which the owner belongs. The permissions you
grant to others a�ect everyone who isn't the owner or in the owning group.

NOTE: For advanced users, there are additional special attributes beyond read/write/execute that can
be set: sticky bit, SUID, and SGID. For more information, see Links section below.

Viewing, setting and changing permissions There are many tools available in MX Linux to view and
manage permissions.

� GUI

� Thunar To view or change a �le's permissions, right-click the �le and select Properties.
Click the Permissions tab. Here you can set the permissions granted to the owner, group,
and others using the pull-down menus. For some �les (like scripts , for instance), you need
to check the box to make them executable, and for folders you can check a box to limit the
deletion of �les inside it to the owners. NOTE: you must be operating as root to change
the permission of a �le or directory whose owner is root. On bigger folders you MUST
REFRESH your Thunar window or else the permissions will show incorrectly, even though the
permissions have actually changed. Just hit F5 to refresh the window or else you will see the
original permissions.

� MX User Manager is an easy way to change permissions by associating a user with speci�c
groups.

� CLI

� Internal partitions. By default, the root/superuser password is required to mount internal
partitions. To change this behavior, consult the MX/antiX Wiki.

� New external partitions. Formating a new partition with ext4 requires root permissions,
which can lead to unexpected or undesired result of the regular user not being able to write
any �les to the partition. To change this behavior, consult the MX/antiX Wiki.

� Manual operations. Although MX User Manager covers most daily situations, sometimes
it can be preferable to deal with the command line. Basic permissions are represented by r
(read), w (write) and x (execute). To view permissions of a �le on the command line, type
this: ls -l NameofFile

The -l switch will cause the �le to be listed in long format, displaying its permissions among
other information.

-rw-r--r-- newbie users 277 Jan 7 14:42 .asoundrc

The �rw-r--r-- � bit right after the opening dash (indicating it is a regular �le) contains read/write/execute
permissions for owner, group and others: 9 characters total.
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Here it shows that the owner has read and write but not execute (rw-), but the group and others
can only read (r--). The owner in this case is speci�ed to be �newbie� who belongs to the group
�users�.

If for some reason it was necessary to change the ownership of this �le to root using the command
line, you would use the chown command like in this example: chown root /home/newbie/.asoundrc

For details on using chown, as well as the more detailed chmod, see Links section.

Links

� MX/antiX Wiki: Permissions

� File Permissions

7.4 Con�guration �les

With only rare exceptions, program and system settings on MX Linux are stored in discrete plain text
con�guration �les; there is no �Registry� which requires special tools to edit. Most con�guration �les are
just simple lists of parameters and values which are read by programs when they launch to determine
their behavior.

7.4.1 User con�g �les

Files that hold individual user settings (such as high scores for your games, or the layout of your desktop)
are stored within a Users home directory, typically as a hidden �le or directory, and can only be edited by
that user or by root. These personal con�guration �les are actually less often edited directly than system
�les because most of the user con�guration is done graphically through the applications themselves. When
you open an application and click Edit > Preferences, for example, your selections are written to a
(usually hidden) con�guration �le in your user directory. Likewise in Firefox, when you type about:con�g
in the address bar, you are editing the hidden con�guration �les.

7.4.2 System con�g �les

Files that hold system-wide con�gurations or defaults (such as the �le that determines which services
automatically launch during boot up) are largely stored in the /etc/ directory and are only editable by
root. Most of these �les are never touched directly by regular users, such as these for instance:

� /etc/rc.d/rc5.d � Contains �les to control runlevel 5 into which MX Linux boots after login.

� /etc/syscon�g/keyboard � Used to con�gure the keyboard.

� /etc/network/interfaces � De�nes internet interfaces on the system.

Some con�guration �les can contain just a few lines, or even be empty, while others may be quite long.
The important point is that if you are looking for a con�guration �le for an application or process, head
for the /etc directory and look around. Caution: because these �les a�ect the whole system, 1) back up
any �le you intend to edit (easiest in Thunar: copy and paste back in, adding BAK at the end of the �le
name), and 2) be very careful!

7.4.3 Example

Sound problems can be solved with a number of graphical and command-line tools, but once in a
while a user needs to edit directly the system-wide con�guration �le. For many systems, this will be
/etc/modprobe.d/snd-hda-intel.conf. It is a simple �le whose top paragraph looks like this:

133

http://mxlinux.org/wiki/system/permissions
http://www.linux.com/learn/tutorials/309527-understanding-linux-file-permissions


# some chips require that the model be set manually
# for example asus g71 series may need model=g71v
options snd-hda-intel model=auto

To try to get sound, you might decide to substitute the exact information about the sound model in place
of the word �auto.�. To �nd out your sound model, you could open a terminal and type: lspci grep
Audio

The output will depend on the system, but it will take the following form:

00:05.0 Audio device: nVidia Corporation MCP61 High De�nition Audio (rev
a2)

Now you can plug that information back into the con�guration �le:

# some chips require that the model be set manually
# for example asus g71 series may need model=g71v
options snd-hda-intel model=nvidia

You would save the �le, reboot the machine, and hopefully your sound should be working. You could also
try more precision by using model=nvidia mcp61 instead, if the �rst did not work.

Links

� Understanding Linux Con�guration Files

7.5 Runlevels

MX Linux boots up by executing the program init. After completing the boot process, init executes all
startup scripts in a directory speci�ed by the default runlevel (this runlevel is given by the entry for id in
/etc/inittab). Like most other Linux versions, MX Linux has 7 runlevels:

Table 10: Runlevels in MX Linux
Runlevel Comment

0 Halt the system

1 Single-user mode: provides a root console without logon. Useful if you lose your
root password

2 Multiuser with no network

3 Console logon, no X (i.e. no GUI)

4 Not used/custom

5 Default GUI logon

6 Reboot the system

MX Linux defaults to runlevel 5, therefore any init scripts set up in the level 5 con�g �le will run at boot.

Use Understanding runlevels can be handy. When users have a problem with X Window Manager, for
instance, they can not correct it on the default runlevel 5, because X is running on that level. But they
can get to runlevel 3 to work on the problem in one of two ways.

� From the Desktop: press Ctrl-Alt-F1 to get out of X. To actually drop to runlevel 3, become root
and type telinit 3; this will stop all the other services still operating on runlevel 5.

� From the GRUB menu: press e (for edit) when you see the GRUB screen. On the subsequent
screen, add a space and the number 3 at the end of the line that starts with �linux� located one
above the lowest line (the actual boot command). Press F-10 to boot.
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Once the cursor is at a prompt, login with your normal username and password. If necessary, you can
also login as �root� and provide the administrative password. Useful commands when you are looking at
the prompt on runlevel 3 include:

Table 11: Common runlevel 3 commands
Command Comment

runlevel Returns the number of the runlevel you are on.

halt Run as root. Shuts the machine down. If that does not work on your
system, try powero�.

reboot Run as root. Reboots the machine.

<application> Runs the application, as long as it is not graphical. For instance, you can
use the command nano to edit text �les, but not leafpad.

Ctrl-Alt-F7 If you used Ctrl-Alt-F1 to drop out from a running desktop but did not
continue down to runlevel 3, this command brings you back to your

desktop.

telinit 5 Run as root. If you are on runlevel 3, enter this command to get to the
login manager lightdm.

NOTE: these commands may change in the future if MX Linux switches to a new system manager.

Links

� Wikiipedia: Runlevel

� The Linux Information Project: Runlevel De�nition

7.6 The kernel

Introduction To provide a background, here is a simpli�ed diagram and description of the kernel's
position in a Linux OS, borrowed from Anatomy of the Linux kernel.

Figure 7-2: Diagram of the Linux kernel

At the top is the user space, or application space. This is where the user applications are executed.
Below the user space is the kernel space. Here, the Linux kernel exists. There is also the GNU C Library
(glibc). This provides the system call interface that connects to the kernel and provides the mechanism
to transition between the user-space application and the kernel. This is important because the kernel and
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user application occupy di�erent protected address spaces. And while each user-space process occupies
its own virtual address space, the kernel occupies a single address space.

Upgrading/Downgrading � Basic Unlike other software on your system, the kernel is not upgraded
automatically except below the minor revision level (indicated by the third number in the kernel name).
Before you change your current kernel, you would do well to ask yourself some questions: Why do I want
to upgrade the kernel? Is there a driver I need for new hardware, for instance? Am I aware that I might
have problems of one kind or another?

MX Linux provides an easy method of upgrading/downgrading the default kernel: open MX Package
Installer and click on the �Kernel� category. There you will see two active entries surrounding the greyed-
out default kernel:

� A �fallback� kernel that represents a reasonable choice for dropping down a level

� The latest available kernel in the same series as the default kernel

Once you check and install the new kernel, reboot and make sure the new kernel is highlighted; if not,
click on the options line and select what you want.

Figure 7-3: Kernel options in MX Package Installer for 64bit architecture

Upgrading/Downgrading � Advanced Here is a basic approach for manually upgrading the Linux
kernel on your system.

� First, �nd out what you currently have installed. Open a terminal and enter inxi -S. For instance,
a user of MX 15 64 bit version would see something like this:

$ inxi -S
System: Host: UTRA Kernel: 4.2-3.dmz.3-liquorix-amd64 x86_64
(64 bit) Desktop: Xfce 4.12.2
Distro: MX-15_x64-mx Fusion

Be sure to write down the name of the kernel (bolded above) from the output of that command.

� Second, select and install a new kernel. Open Synaptic, search on linux-image and look for a higher
kernel number that matches the architecture (e.g., 686) and processor (e.g., PAE) that you already
have, unless you have a good reason to change. Install the one you want or need in the usual
manner.

� Third, install the linux-headers package that match the new kernel you selected. There are two
methods of doing this.

� Look carefully at the Synaptic entries beginning linux-headers and match the kernel.

� Alternatively, you can install the headers more easily after rebooting into the new kernel by
typing the following code in a root terminal:

apt-get install linux-headers-$(uname -r)

Headers will also be installed if you use a command such as m-a prepare.

� When you reboot, you will automatically boot into the highest available kernel. If it doesn't work,
you have the option to return to what you were using: reboot, and when you see the GRUB screen
highlight Advanced Options for whatever partition you want to boot into, then select the kernel
and press enter.

136



More options Other considerations and choices exist with respect to kernels:

� Other pre-rolled kernels exist such as the Liquorix kernel, which is a version of the Zen kernel and is
intended to provide a better desktop use experience in terms of responsiveness, even under heavy
loads such as during gaming, plus low latency (important for audio work). That is most easily
installed through Synaptic: enable the Community Repository testing repos (Synaptic) to see and
select it.

� Distros (e.g., MX's code-parent antiX) often roll their own.

� Knowledgeable individuals may compile a speci�c kernel for a particular reason.

Links

� Wikipedia: Linux kernel

� Anatomy of the Linux kernel

� Linux kernel archives

� Interactive map of Linux kernel

7.6.1 Kernel panic and recovery

A kernel panic is a relatively rare action taken by the MX Linux system when it detects an internal fatal
error from which it can not safely recover. It can be caused by a number of di�erent factors that range
from hardware problems to a bug in the system itself. When you get a kernel panic, try rebooting with
the MX Linux LiveMedium, which will overcome temporarily any software problems and hopefully allow
you to see and o�oad your data. If that doesn't work, then unplug all unnecessary hardware and try
again.

Your �rst concern is to access and secure your data. Hopefully, you have it backed up somewhere. If not,
you can use one of the data recovery programs such ddrescue that is supplied with MX Linux. Your last
resort is to take your hard drive to a professional recovery business.

There are a number of steps you might have to take to recover a functional MX Linux system once you
have your data safe, although ultimately you may have to reinstall using the LiveMedium. Depending on
the type of failure, the following steps may be undertaken:

1. Remove packages that broke the system.

2. Reinstall the graphic driver.

3. Reinstall GRUB using MX Boot Repair.

4. Reset the root password.

5. Reinstall MX Linux, selecting the check box on Screen 2 to keep /home so that your personal
con�gurations will not be lost.

Be sure to ask on the Forum if you have any questions about these procedures.

Links

� GNU C Library Home Page

� Ddrescue
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8 Glossary

Introduction

Linux terms can be confusing and o�putting at �rst, so this Glossary provides a list of the ones used in
this Manual to get you started.

� applet: A program designed to be executed from within another application. Unlike an application,
applets can not be executed directly from the operating system.

� backend: Also /back-end./ The backend includes the various components of a program that
process the user input entered through the frontend. See also frontend.

� backport: Backports are new packages that have been recompiled to run on a released distribution
in order to keep it up-to-date.

� BASH: The default shell (command-line interpreter) on most Linux systems as well as on Mac OS
X, BASH is an acronym for Bourne-again shell.

� BitTorrent: Also/bit torrent/ or /torrent./ A method invented by Bram Cohen to distribute
large �les without the need for a single individual to provide the hardware, hosting and bandwidth
resources required.

� boot block: An area of a disk outside the MBR having information for loading the operating
system that is needed to start a computer.

� bootloader: Program that initially chooses an operating system to load after the BIOS has �nished
initializing the hardware. Extremely small in size. the bootloader's only job is to hand control of
the computer over to the Operating System's kernel. Advanced bootloaders o�er a menu to choose
between several installed operating systems.

� chainloading: Also /chain loading./ Instead of directly loading an operating system, a boot man-
ager like GRUB can use chain loading to pass control from itself to a boot sector on a hard disk
partition. The target boot sector is loaded in from disk (replacing the boot sector from which the
boot manager itself was loaded) and the new boot program is executed. In addition to when it is
necessary, as in booting Windows from GRUB, the advantage to chainloading is that each operating
system on the hard disk drive �and there could be dozens� can be responsible for having the
correct data in it's own boot sector. So GRUB residing in the MBR need not be rewritten every
time there are any changes. GRUB can simply chainload the relevant information from the boot
sector of a given partition whether it has changed or remained the same since the last boot time.

� cheat code: Codes can be entered when booting a LiveMedium to change the booting behavior.
They are used to pass options to the MX Linux operating system to set parameters for particular
environments.

� command line interface (CLI): Also known as console, terminal, command prompt, shell, or
bash. This is a UNIX-style text interface, which MS-DOS was also designed to resemble. A root
console is one where administrative privileges have been acquired after entering the root password.

� desktop environment:The software which provides a graphical desktop (windows, icons, desktop,
task bar, etc) for an operating system user.

� disk image: A �le containing the complete contents and structure of a data storage medium or
device such as a hard drive or DVD. See also ISO.

� Distribution: A Linux Distribution, or distro, is a particular packaging of the Linux kernel with
various GNU software packages, and di�erent desktops or window managers. Since�unlike the
proprietary code used in the Microsoft and Apple OS's�GNU/Linux is Free, Open-Source Software,
literally anyone in the world who has the ability can freely build on what has been done and innovate
a new vision of a GNU/Linux operating system. MX Linux is a distro based on the Debian Linux
family.
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� �le system: Also �le system. This refers to the way that �les and folders are logically arranged
on a computer's storage devices so they may be found by the operating system. It can also refer
to the type of formatting on a storage device, such as the common Windows formats NTFS and
FAT32, or the Linux formats ext3, ext4 or ReiserFS, and in this sense refers to the method actually
used to encode binary data on the Hard Disk Drive, �oppy, �ash drive, etc.

� �rmware. The small programs and data structures that internally control the electronic components

� free-as-in-speech: The English word �free� has two possible meanings: 1) without cost, and 2)
without restrictions. In part of the open-source software community, an analogy used to explain the
di�erence is 1) �free� as in beer vs. 2) �free� as in speech. The word /freeware/ is used universally
to refer to software that is simply without cost, whereas the phrase /free software/ loosely refers
to software that is more properly called open-source software, licensed under some type of open
source license.

� frontend: Also front-end. The frontend is the part of a software system that interacts directly
with the user. See also backend.

� GPL: The GNU General Public License. This is a license under which many open-source applications
are released. It speci�es that you may view, modify, and redistribute the source code of applications
released under it, within certain limits; but that you may not distribute the executable code unless
you also distribute the source code to anyone who asks for it.

� Graphical User Interface (GUI): This refers to a program or operating system interface that uses
pictures (icons, windows, etc), as opposed to text (command-line) interfaces.

� home directory: One of the 17 top-level directories branching from the root directory in MX Linux,
/home contains a subdirectory for every registered user of the system. Within each Users home
directory s/he has full read-write privileges. Further, most of the user-speci�c con�guration �les
for various installed programs are stored in hidden subdirectories within the /home/username/ direc-
tory�as is downloaded email. Other downloaded �les usually go by default into the home/username/Documents
or /home/username/Desktop subdirectories.

� IMAP: The Internet Message Access Protocol is a protocol that allows an e-mail client to access
a remote mail server. It supports both on-line and o�-line modes of operation.

� interface: A point of interaction between computer components, often referring to the link between
a computer and a network. Examples of interface names in MX Linux include WLAN (wireless)
and eth0 (basic wired).

� IRC: Internet Relay Chat, an older protocol to render the exchange of text messages easier.

� ISO: A disc image following an international standard that contains data �les and �le system
metadata, including boot code, structures, and attributes. This is the normal method for delivering
Linux versions such as MX Linux over the Internet. See also disk image.

� kernel: The layer of software in an operating system that interacts directly with the hardware.

� LiveCD/DVD: A bootable compact disc from which one can run an operating system, usually
with a complete desktop environment, applications, and essential hardware functionality.

� LiveMedium: a general term that includes both LiveCD/DVD and LiveUSB.

� LiveUSB: A USB �ash drive on which an operating system has been loaded in such a way that it
can be booted and run. See LiveDVD.

� mac address: a hardware address that uniquely identi�es each node (connection point) of a
network. It is formed of a string of usually six sets of two-digits or characters, separated by colons.

� man page: Short for manual, man pages typically contain detailed information about switches,
arguments, and sometimes the inner workings of a command. Even GUI programs often have man
pages, detailing available command line options. Available in Start menu by typing a # before the
name of the man page you want into the Search box, for example: #pulseaudio.
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� MBR: Master Boot Record: the �rst 512-byte sector of a bootable hard disk drive. Special data
written to the MBR enables the computer's BIOS to pass the boot process o� to a partition with
an installed operating system.

� md5sum: A program that calculates and veri�es a �le's data integrity. The MD5 hash (or check-
sum) functions as a compact digital �ngerprint of a �le. It is extremely unlikely that any two
non-identical �les will have the same MD5 hash. Because almost any change to a �le will cause its
MD5 hash to also change, the MD5 hash is commonly used to verify the integrity of �les.

� mirror: Also mirror site. An exact copy of another Internet site, commonly used to provide multiple
sources of the same information to supply reliable access to large downloads.

� module: Modules are pieces of code that can be loaded and unloaded into the kernel upon demand.
They extend the functionality of the kernel without the need to reboot the system.

� mountpoint: The place on the root �le system where a �xed or removable device is attached
(mounted) and accessible as a subdirectory. All computer hardware needs to have a mountpoint in
the �le system to be usable. Most standard devices such as keyboard, monitor and your primary
hard disk drive are mounted automatically at boot.

� mtp: MTP stands for Media Transfer Protocol and operates at the �le level so that your de-
vice doesn't expose its entire storage device. Older Android devices used USB mass storage for
transferring �les back and forth with a computer.

� NTFS®: Microsoft's New Technology File System debuted in 1993 on the Windows NT Operating
System, geared to business networks, and with revisions entered the mainstream Windows user's
desktop computers in later versions of Windows 2000. It has been the standard �le system since
Windows XP was introduced in late 2001. Unix/Linux-oriented folk say it stands for �Nice Try File
System�!

� open-source: Software whose source code has been made available to the public under a license
that allows individuals to modify and redistribute the source code. In some cases, open-source
licenses restrict the distribution of binary executable code.

� package: A package is a discrete, non-executable bundle of data that includes instructions for
your package manager about installation. A package doesn't always contain a single application;
it might contain only part of a large application, several small utilities, font data, graphics, or help
�les.

� package manager: A package manager such as (Synaptic or Gdebi) is a collection of tools to
automate the process of installing, upgrading, con�guring, and removing software packages.

� Panel: The highly con�gurable panel in Xfce4 appears by default at the left side of the screen and
contains navigation icons, open programs and system noti�cations.

� Partition Table: A partition table is a hard disk architecture that expands on the older Master
Boot Record (MBR) partitioning scheme using globally unique identi�ers (GUID) to enable the
existence of more than the original four partitions.

� port: A virtual data connection that can be used by programs to exchange data directly, instead of
going through a �le or other temporary storage location. Ports have numbers assigned for speci�c
protocols and applications, such as 80 for HTTP, 5190 for AIM, etc.

� repo: A shortened form of repository.

� repository: A software repository is an internet storage location from which software packages may
be retrieved and installed via a package manager.

� root: Root has two common meanings in a UNIX/Linux OS; they are intimately connected, but
the distinction is important to understand.

� The root �le system is the basic logical structure of all the �les the operating system can
access, whether programs, processes, pipes or data.
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It should follow the Unix Filesystem Hierarchy Standard, which speci�es where in the hierarchy
to locate all types of �les.

� The root user who owns the root �le system �and so has all permissions necessary to do
anything to any �le. While it is sometimes necessary to temporarily assume the powers of the
/root user/ to install or con�gure programs, it is dangerous and violates the basic security
structure of Unix/Linux to log in and operate as /root/ unless absolutely necessary. In a
command line interface, a regular user can temporarily become root by issuing the command
su then entering the root password.

� runlevel: A runlevel is a preset operating state on a Unix-like operating system. A system can be
booted into any of several runlevels, each of which is represented by a single digit integer. Each
runlevel designates a di�erent system con�guration and allows access to a di�erent combination of
processes (i.e., instances of executing programs). See Section 7.5.

� script: An executable text �le, containing commands in an interpreted language. Usually refers
to BASH scripts which are used extensively �under the hood� of the Linux operating system, but
other languages may be used as well.

� session: A login session is the period of activity between a user logging in and logging out of a
system. In MX Linux, this typically indicates the lifetime of a particular user �process� (the program
code and its current activity) that Xfce invokes.

� source code: The human-readable code in which software is written prior to being assembled or
compiled into machine-language code.

� switch: A switch (also /�ag/, /option/ or /parameter/) is a modi�er appended to a command to
change its behavior. A common example is -R (recursive), which tells the computer to carry out
the command through all subdirectories.

� symlink: Also symbolic link and soft link. A special type of �le that points to another �le or
directory and not to data. It allows the same �le to have di�erent names and/or locations.

� tarball: An archiving format, like zip, popular on the Linux platform. Unlike zip �les, though,
tarballs may use one of a number of di�erent compression formats, such as gzip or bzip2. They
usually end in �le extensions like .tgz, .tar.gz, or .tar.bz2. Many archive formats are supported
in MX with a graphical application called Archive Manager. Usually an archive can be extracted
simply by right-clicking on it in Thunar.

� Unix: Also UNIX. The operating system which Linux is modeled after, developed in the late 1960's
at Bell Labs and used primarily for servers and mainframes. Like Linux, Unix has many variations.

� UUID (Universally Unique IDenti�er). A universally unique identi�er (UUID) is a 128-bit number
that identi�es unique Internet objects or data.

� window manager: A component of a desktop environment that provides the basic maximize
/minimize/close/move functions for windows in the GUI environment. Sometimes it can be used as
an alternative to a full desktop environment. In MX Linux, the default window manager is Xfce4.

� X: Also X11, xorg. The X Window System is a networking and display protocol which provides
windowing on bitmap displays. It provides the standard toolkit and protocol to build graphical user
interfaces (GUIs) on Unix-like operating systems and OpenVMS, and is supported by almost all
other modern operating systems.
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