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 ABOUT THIS MANUAL
The information contained in this document is subject to change without prior notice.
In addition, screenshots included in this manual may differ from the actual product.

Toontrack Music AB makes no warranty of any kind with regards to this material, 
including, but not limited to, the implied warranties of merchantability and fitness 
for a particular purpose. Toontrack Music AB will not be liable for errors contained 
herein or for incidental or consequential damages in connection with the furnishing, 
performance or use of this material.

EZdrummer®, EZplayer pro® and Superior Drummer® are registered trademarks of 
Toontrack Music AB. All other trademarks are the property of their respective owners.

Mac OS™ is a trademark of Apple Computer, Inc. 
DirectX® and Windows® registered trademarks of Microsoft Corporation. 
VST™ is a trademark of Steinberg Media Technologies GmbH.

Rock Band® and Rock Band 2® are trademarks of Harmonix® Music Systems, Inc.
Guitar Hero® is a trademark of Activision® Publishing, Inc.
Rock Revolution® is a trademark of Konami®  Digital Entertainment, Inc.
Xbox 360® is a trademark of Microsoft® Corporation
PlayStation® is a trademark of Sony® Computer Entertainment Inc.
Wii® is a trademark of Nintendo.

Toontrack has no rights to any of these trademarks. Toontrack solo is not supported, 
recommended or endorsed by any of these companies.  Toontrack has tested their 
products with select software platforms and hardware to verify compatibility. Full 
compatibility details can be found at http://www.toontrack.com/toontrack_solo.asp

This manual is copyright Toontrack Music AB. No duplication, copying and distribution 
is permitted without written consent from the originator.



Toontrack solo

3

TABLE OF CONTENTS

1 - INTRODUCTION 6

1.1 Foreword 6
1.2 What is Toontrack solo?  7

2 - INSTALLATION 8

2.1 System Requirements 8
2.2 Installing Toontrack solo for Windows 8
2.3 Installing Toontrack solo for Macintosh 8

3 - OPERATION 10

3.1 Starting a new project 10
3.2 Adding virtual Drummers 10
3.3 Mixer window basics 11
3.4 Superior sub-mixer 11
3.5 Superior Drummer 2 mixer 12
3.6 EZdrummer mixer 12
3.7 EZplayer bridging 12
3.8 Setting the project tempo 13
3.9 Additional controls and features 14
3.10 Saving and recalling projects 14

4 - SETTING UP  16

4.1 Audio device and channels 16
4.2 Audio buffer 16
4.3 MIDI devices 18
4.4 Assigning MIDI ports and channels 18
4.5 MIDI controllers 19
   < E-drums > 19
   < Game Controllers > 20
   < Modwheel > 20

5 - HELP AND RESOURCES  21

5.1 Setting the VST path 21
5.2 RAM and CPU considerations 21



Toontrack solo

4

 CREDITS
Toontrack Development Team:

Concept development: Fredrik Ärletun, Daniel Dermes, Mattias Eklund, 
Nils Eriksson, Henrik Kjellberg, Christoffer Lindmark, Rogue Marechal, 
Erik Phersson, John Rammelt,  Andreas Sundgren, Olof Westman.

Programming: Christoffer Lindmark 

Andreas Sundgren (name and specification) 
Erik Phersson (project management) 
Rogue Marechal (configuration manager) 
Fredrik Ärletun (graphic artist)

Manual written by: Rogue Marechal. 

Betatesters (to whom our undying gratitude goes):

Kevin Afflack, John Alcock, Tony Artimisi, Damian Blunt, Philippe Decuyper, 
Chaim Goldman, Scott Griggs, Brad Holland, Svein Hyttebakk, Mark 
King, Kenny Lee, Emmanuel Lorant, Harry Maes, Murray McDowall, Dave 
Modisette, Wilfredo Nanita, John Rammelt, Marcel Ritsema and Scott 
Sibley.

Additional Thanks:

All Toontrack customers around the world for their custom and support.



Toontrack solo

5



Toontrack solo

6

 1 - INTRODUCTION
1.1 Foreword

Toontrack has always been associated with flexibility in the studio and great tools for 
the live musicians.

Unfortunately, the reality of transposing one’s drum sound to a mobile setup is often 
synonymous with being at the mercy of a sequencer not specifically designed for the 
mission critical environment of the stage/rehearsal room.

Between the sequencer’s own claims over the host computer resources,  prone to 
jeopardize the experience, and the bloat of controls irrelevant to the performer 
getting in the way, it is tempting to just take the kit out of the garage and stick to the 
old fashioned way.  Not that there is anything wrong with the old fashioned way...  it 
helps to have hard-of-hearing neighbours however.

Anyway, when, in the course of 2005, we unleashed our ground breaking non streaming 
proprietary TPC algorithm, first in Superior, and subsequently in EZdrummer,  it 
became clear that this technology opened many horizons for the serious musician 
wanting to take their drum sound on the road with them.  But there was the problem 
of the host application, intrusive and sometimes inefficient.

Of course there are already some streamlined applications out there that do a decent 
job at saving your computer’s resources for what it is really useful: low latency real-
time playing. But at Toontrack we don’t think that decent  is good enough for our 
customers and, more importantly, we know that synergistic development is a better 
approach than a generic one.

We, therefore, decided to take the matter into our own hands and provide the most 
essential functionality in a highly optimized package, making the emphasis on real-time 
performance, knowing EXACTLY what our sampler are capable of and what controls 
can be beneficial to the performer.

Toontrack solo was therefore born out of this desire to create a cool tool for the 
performing musician and you now have at your disposal our very own stand alone host. 

The Development Team
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1.2 What is Toontrack solo?

Toontrack solo is a stand alone application designed to host Toontrack samplers such 
as Superior and EZdrummer.  It is particularly suited for musicians wanting to jam 
along a friend (real ones, if you are a drummer, or a virtual one if you are a guitarist), 
or to perform live (for your own pleasure in isolation from the world or in front of an 
audience).

It can also be use as the foundation of a modular work environment dedicated to song 
writing using EZplayer Pro,  Toontrack’s acclaimed groove factory and musical sketch pad.

In its current incarnation a performer can optimize response from his preferred 
controller with the use of factory presets, and route any of the sampler’s output to a 
hardware mixer for total sonic control.

Toontrack solo  boosts full support for ASIO,  WDM and MME as well as Core Audio / 
Core MIDI devices and allows routing to up to 16 physical Audio outputs.  This means 
that it is optimized for real-time operation with minimal latency and provides the full 
flexibility of sound shaping in your outboard gear.

Multiple sampler instances can of course be controlled from conventional keyboard 
controllers (with full support for modwheel control of hi-hats action) as well as a 
range of specialist devices such as the majority of E-drums and Drum pads available 
on the market. It can even be used with game controllers made for the popular Rock 
Band® Guitar Hero® video games.

So, what are you waiting for? Get that show on the road! 
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 2 - INSTALLATION
2.1 System Requirements

• Windows XP SP2, PIII/Athlon 1,8GHz with 512 Mb of Ram
• Mac OS X 10.4, G4 1GHz with 512 Mb of Ram
• Display capable of 800x600 (1024x768 recommended)
• A virtual drum sampler from Toontrack Music (Superior/EZdrummer)
• a sound card with up-to-date ASIO or Core Audio drivers (recommended)
• one or several MIDI controllers (recommended)

2.2 Installing Toontrack solo for Windows

To install Toontrack solo for Windows simply run the Toontrack solo Installer located 
in the same folder as this document.  To uninstall run this program again or use the 
Add/Remove Program control panel provided by your operating system.

2.3 Installing Toontrack solo for Macintosh

To install Toontrack solo for Macintosh simply run the Toontrack solo Installer located 
in the same folder as this document. To uninstall simply delete the Toontrack solo 
executable from your Applications folder.
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 3 - OPERATION

3.1 Starting a new project

Upon starting the Toontrack solo  application you will 
be presented with a selection box listing all Toontrack 
products installed on the host computer:

If no option appear, please ensure that you have installed 
the desired Toontrack product as per instruction 
that came with it. Please also refer to chapter 5 for 
troubleshooting instructions.

Once you have selected your drum sampler (referred to as ‘Drummer’ in the rest of 
this manual), its graphical interface should appear on screen, ready to be used, in most 
cases without further configuration.  You may however want to refer to chapter 4, 
Audio and MIDI setup, at this stage to define your preferred MIDI input and playback 
devices, as well as perform advanced tweaking.

From here on, if you are already fluent with your Toontrack sampler you should 
intuitively find your way around the interface and experiment. In the opposite scenario 
now is the time to reach for the manual that came with your Toontrack sampler. It is 
also recommended you read this entire documentation to ensure you get the most 
out of it.

3.2 Adding virtual Drummers

Adding further instances of a Toontrack sampler could not be easier.
Select  File > New Drummer 

or click the Drummer  icon on the toolbar:

We will go through the Mixer features in some details shortly but note 
that you can show, hide or delete Drummers  if they are no longer 
required or are cluttering your screen, as per screenshot to the left.
You can also double click the Drummer’s label to show its interface.

You can thus manage windows on screen as you like, using multiple 
drum samplers with different banks loaded, and assign each and every 
one of them to a distinct MIDI port and channel for precise triggering. 
Do not worry about all of this at this stage however, if this paragraph 
is not entirely clear, you probably do not have the need for more than 
one Drummer.
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3.3 Mixer window basics

Each virtual Drummer is represented in the main Mixer by a channel strip with familiar 
controls such as volume, mute and solo. Note that no panning is available in this Mixer 
as each Drummer  can be controlled on a per channel basis from its own mixer for 
maximum flexibility. See the paragraph relevant to your product below for details.

The Mixer can always be called in view using the Mixer icon in the Toolbar:

3.4 Superior sub-mixer (Superior 1.x must be installed)

Toontrack solo  implements a Superior  sub-mixer, providing all controls needed, from 
volume/panning to channel routing if your sound card provides more than 2 physical outputs.

Note that you need to enable your sound card outputs in the
Options > Audio > Audio Channels | dialogue before you can route Superior’s  
outputs to secondary outputs of your sound card. See paragraph 4.1 for further details.

Again the above is only relevant if you own the original Superior  program, see the 
next paragraph for Superior Drummer 2  instructions.
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 3.5 Superior Drummer 2 mixer (only available to Superior 2  users)

Superior Drummer 2  includes a fully featured and flexible built-in mixer. Its operation 
is detailed in the Superior Drummer 2  documentation, please refer to this product’s 
Operation Manual for additional information.

3.6 EZdrummer mixer (only available to EZdrummer users)

EZdrummer  includes a built-in mixer providing a similar set of feature to the Superior 
sub-mixer described above. Its operation is detailed in the EZdrummer documentation, 
please refer to this product’s Operation Manual for additional information.

3.7 EZplayer bridging (EZplayer Pro  must be installed)

In addition to live performances, Toontrack solo  allows you to use all of your 
Toontrack products in a super-charged environment ideal for composing on the go, 
thanks to EZplayer Pro’s  ultra intuitive features.

EZplayer Pro  is Toontrack’s acclaimed solution for the serious song writer (among other 
things). It must of course be installed for the below instructions to work. More information 
about EZplayer Pro  can be found at http://www.toontrack.com/ezplayer_pro.asp

Simply select the EZplayer entry in the View menu.  This will open EZplayer Pro  on 
your screen, ready for you to start composing.

Alternatively click the EZplayer  icon at the far right of the Toolbar:

Note that you can assign a discrete channel 
to control EZplayer  by selecting
Options > EZplayer channel

For example, you want to use a trigger pad 
to start and stop sequences without leaving 
your stool or be required to laboriously 
mouse around trying to find the Play button 
in a semi-obscurity.

For this to work correctly you will need to 
assign different channels to your Drummers  
as well, or use two separate MIDI ports or 
interfaces.

Please refer to paragraph 4.5,  Assigning MIDI Ports and Channels, to learn how to 
route MIDI information to the intended Drummer. 



Toontrack solo

13

3.8 setting project tempo

Some Toontrack samplers such as EZdrummer can be used as a MIDI player for single 
tempo drum backing tracks for you to jam along to. For this reason it is sometimes 
useful to key in a custom tempo for the sampler to line up with.

Simply double click the tempo value or use the up and down arrows to set the tempo 
as desired: 

Alternatively press the            tempo button at regular interval until a suitable tempo 
is achieved (it can of course be fine tuned with the arrow controls at a later stage).

You may also make use of the internal Metronome by selecting  View > Metronome:

By using the Metronome settings you may specify the time signature for the ‘click’ 
to play against, the bar division and of course volume and sounds to be played as a 
reference.

Once you have adjusted the Metronome as desired, note that you do not have 
to call the settings window again and may instead use the Metronome icon in 
the Toolbar, pictured to the left, or press Control+T on your computer keyboard.
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 3.9 additional controls and features

If you are playing along a sampler’s internal sequence there might be times when you 
will want to start or stop playback of one or more virtual Drummers. In the current 
Toontrack solo version the following are available for this purpose:

Pressing the <spacebar> on your computer keyboard will start or stop the active  
Drummer (the instance that has the focus, usually at the forefront of the window 
stack). Pressing <shift> + <spacebar> will on the other hand start or stop all 
Drummers present in the project at once.

3.10 saving and recalling projects

Once you have constructed your multiple Drummers  setup, or more simply a session 
you would like to recall quickly in the future, you can save your Toontrack solo project 
for using the File > Save (Save As...). This will save a Toontrack solo  specific 
file, with file extension .tts, not to be confused with sampler specific saved files.
.tts files cannot be loaded directly in Superior Drummer  or  EZdrummer!

Note the file management controls available 
from the Toolbar, from left to right, New 
Project, Open Project and Save Project:
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 4. Audio and MIDI Setup
Toontrack solo  allows you to specify both MIDI input ports and Audio playback 
devices, commonly referred to as MIDI interfaces and Sound cards respectively. You can 
also adjust many advanced settings via the application’s  Options menus.

4.1 Audio devices and channels

Selecting  Audio > Audio Device... | will present you with all the Audio playback 
devices available to the host computer. Note that only  ASIO or Core Audio interface 
protocols will guarantee optimum performances, with low latency real-time triggering.  
WDM and MME drivers should only be used for ‘offline’ composing using  Toontrack 
EZplayer Pro.

Select your preferred sound card by highlighting it in the list and confirm the selection. 
Again, prefer ASIO or CoreAudio Devices if performing ‘live’ is your goal. A filtering 
drop-down menu is provided to help you discriminate between suitable interfaces for 
real-time and offline performance. 

If your device supports more than two physical OUTs you will also most likely want 
to make use of additional / all channels available to route specific instruments to the 
Front of House or hardware mixer for further processing.

Select  Audio > Audio Channels... | to choose the physical OUTs among those 
published by the ASIO/Core Audio driver for your sound card and allow them to be used 
for internal routing.  Channels selected here should immediately be available and appear 
in the Drummers’  mixers, without an application restart.

4.2 Audio buffer

Triggering sound sources from a computer system unavoidably create a certain amount 
of playback latency, however minimal, which is inherent to the processing of data to be 
sent to the sound system via the Audio interface.

Any computer built in the last 3 years with a dedicated  Audio sound card (as opposed 
to the ‘stock’ or built-in sound hardware) should be able to provide a satisfactory 
experience at minimal latency but to do so it needs properly written drivers, optimized 
to ensure information destined to the sound card is processed efficiently.

For this reason we strongly recommend using non generic ASIO / Core Audio drivers 
for the sound card you intend to use.  The best advice we can give you is to purchase 
a professionally graded sound card and obtain the most up-to-date drivers from the 
manufacturer. Consumer cards, even if recognized, or outdated drivers for that matter, 
will unavoidably compromise your experience and enjoyment.
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Latency is usually observed as a delay in playback, directly related to the transport of 
data between your sound card and Toontrack solo.  , via your computer’s data bus. 
Although it can be expressed in milliseconds it is conventional to specify the latency as 
a buffer value which represent the amount of data processed per processor cycle.

It is usually accepted that a latency under 3 ms cannot be perceptible by the human brain, 
at least if the flow of information is steady (data ‘jittering’, quite common with USB devices, 
can have a large impact on perceived latency).  At 44.1KHz, the fixed rate operated by 
Toontrack solo’s  audio engine, this corresponds to a buffer value of 128 (samples).

To be complete, this is not the entire latency that needs to be taken into account as 
the MIDI interface can add to the delay in playback with a more or less dramatic effect. 
Nonetheless a value of 128 set in the Audio > Latency setting | dialogue 
should yield an adequate response in most cases.

The drawback of setting a low buffer value however is that this increases the demand 
on CPU availability and exclusiveness, something that the audio driver is in charge 
of managing, hence the importance of a non generic and up-to-date driver.  CPU 
resources of the host machine will also limit the minimum value one can expect from a 
given system and, of course, the more powerful the computer the better.

It should be noted that low latency playback is really only relevant to ‘live’ triggering of 
instruments. For composing/arranging with the help of EZplayer Pro  for example, high 
buffer values will have little impact and will, in fact, maximize the number of concurrent 
Drummers  a given system is able to play back at the same time.

In summary, and as indicative values, the following should be adequate for the different 
scenarios outlined above:

Real-Time Triggering: set the Audio buffer between 64 and 256 (samples)
Offline Composing: set Audio buffer between 512 and 2048 (samples)
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 4.3 MIDI devices

(OPTIONS) MIDI > MIDI device | allows you to specify the MIDI input devices to be 
used.  Simply select the appropriate MIDI interfaces and ports in the list (please refer 
to your owner’s manual for port description) and confirm the selection.

As seen in the previous paragraph, MIDI interfaces can induce latency in playback as well 
as MIDI jitter, a fluctuation in the data flow that can be particularly detrimental to your 
playing experience. For this reason, again, a professionally graded MIDI interface is a must.

On a related note, while the great majority of Audio interfaces combine Audio and 
MIDI capabilities nowadays, it is worth noting that MIDI jittering is more prone to be 
occur when the Audio and MIDI data share the same bus and therefore it is strongly 
recommended you use a dedicated MIDI interface, separate from the Playback device, 
for best results.

4.4 Assigning MIDI ports and channels

Each virtual Drummer can be assigned a discrete 
channel to be triggered by, so that a complex set 
up using multiple MIDI controllers (using one or 
several MIDI interfaces) can be performed. It is 
also an essential part of EZplayer pro’s  typical 
workflow.

To specify a discrete MIDI channel for a particular 
Drummer  to respond to, click to reveal the 
contextual menu in the main application Mixer and 
select the desired channel:

Note that you can also restrict the port (or MIDI interface) a particular 
Drummer  listens to, by deselecting individual entries under MIDI Devices, 
as shown in the screenshot to the right.



Toontrack solo

19

4.5 Specialist MIDI controllers

Toontrack samplers, when used from within Toontrack solo, were designed with specialist 
MIDI controllers known as ‘E-Drums’ in mind. By default they will expect to receive basic 
MIDI note information from the controller, but are also  capable of handling Continuous 
Controller data, also known as CC data, to provide advanced triggering control.

Specifically,  foot controller data (CC04) and modwheel MIDI information (CC01) are 
supported to allow real time variation of hi-hats openness, from close to fully open (with 
additional ‘tight’ articulation for some of the sound banks).

There are additional features supported behind the scene however, and it is therefore 
worth specifying the type of controller used to optimize the response from the virtual 
Drummers.  The following paragraph describes the currently supported specialist 
controllers and how to used them efficiently:

< E-drums >

Toontrack solo  features a universal E-drums preset suitable for most electronic drum 
modules on the market.  While specific presets may be added in the future to further 
expand compatibility, all modules from leading manufacturers should yield excellent 
results with minimal tweaking, if any,  as explained below.

Note that Superior Drummer  users are advised to use the features built-in to 
their sampler instead of those described here, for optimum configuration as well as 
avoiding double manipulation of the MIDI data received from the controller. In other 
words, leave the controller type as ‘Default’ and ensure no other options under the 
Controller menu are selected, and perform all changes from within Superior Drummer.

Otherwise, select the E-drums preset from the Options > Controller | list.  In 
most cases, that is all you will need to perform in order to optimize the sampler’s 
response for your particular E-Drum controller. Toontrack solo will automatically 
process incoming MIDI data on-the-fly for access to variable hi-hats control.

Some modules however, particularly those with sophisticated controllers with movable 
parts (sometimes referred to as  Virtual Hats), may require some adjustments to the 
set up before Closed Hats and Tight Hats, can be accessed however.

To help with this matter we have provided a special setting within Toontrack solo, 
labelled “CC Offset”, which will in most cases allow instant optimization with a single 
click. Simply select  Options > Controller > CC Offset | after having ensured 
that the E-Drums preset was the active from the same menu.

Note that it is recommended that you start your module in the ‘Local OFF’ mode to avoid 
latency due to the on-board processing (please see your hardware manual for details).
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< Game Controllers >

As stated in the introduction to the preset operation manual, Toontrack solo  supports 
game controllers made for the popular Rock Band® Guitar Hero® video games.

Any controller that can be connected via USB to your computer, either with a cable 
or with the help of an appropriate wireless receiver, should work for this purpose. You 
do not even have to select any particular Controller type as Toontrack solo  will sense 
and identify the controller appropriately.

Currently, however it is worth noting that only PlayStation® 2 and 3 controllers can be 
guaranteed to work out of the box but additional software and hardware combination 
will work without specific 3rd party drivers. Full compatibility charts are available at
http://www.toontrack.com/toontrack_solo.asp (further controllers will be supported 
in the near future).

< Modwheel >

Toontrack samplers also allow variable hi-hats to be controlled in real-time with MIDI 
modulation messages, in much the same way a foot controller would, for example using 
a standard MIDI keyboard controller.

Select the Modwheel preset from the MIDI > Controller | list to optimize 
the sampler’s response.  This will allow you to control hi-hats openness from your 
keyboard using a single key and the modulation wheel of the controller (or assignable 
controller of a desktop drum pad).

There are 2 groups of notes that can be used, interchangeably so within each group:

24 (C0), 25(C#0) or 26 (D0), where 60 corresponds to the middle C on the keyboard 
grant access to the ‘edge’ samples if available in the bank loaded in the virtual Drummer.

61 (C#3), 62 (D3) or 63 (D#3), where 60 corresponds to the middle C on the keyboard 
grant access to the ‘tip’ samples if available in the bank loaded in the virtual Drummer.
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5. Help and Resources
5.1 Setting the VST path

Toontrack solo  should automatically detect the Toontrack samplers installed on the 
host computer. It also allows you to specify custom paths should you find this useful.

Select Options > Set Paths | to add or amend locations to be scanned by 
Toontrack solo  at startup. In the sampler selection dialogue click Add Path and 
navigate to the desired directory.  The selection dialogue will immediately update 
showing all valid samplers found under the paths set.  You may of course also remove 
unused paths at any point.

Typical locations, and default install paths for the Toontrack samplers are as follows:

Apple Mac: /Library/Audio/Plug-ins/VST/
Windows:  \Program Files\VSTPlugIns\ or \Program Files\Steinberg\VSTPlugIns\

5.2 RAM and CPU considerations

Toontrack solo takes up few resources by itself, leaving plenty of RAM and CPU for the 
samplers to run on.  You are advised to turn off all unnecessary processes however, not 
only to avoid rogue demands on CPU but also to minimize the RAM footprint of the 
entire system.

As a rule of thumb your combined sound banks should take no more than your 
physical RAM minus 200Mb, which is roughly what your operating system and 
Toontrack solo need to operate comfortably.  That said, be aware that your operating 
system may limit the amount of memory that Toontrack solo  is capable of addressing 
so we recommend that you do not attempt to load banks larger than 1.8GB.

To check the RAM consumption in a project containing only Superior instances or 
only EZdrummer instances you can simply monitor the Total figure in any of the virtual 
Drummer.  In projects containing a combination of sampler engines you should, on the 
other hand, add the figure found in Superior  to the one found in EZdrummer.

Should you experience any problem playing in real time, for example glitches and drop 
outs, your first troubleshooting step should be to increase the buffer size as you may 
be demanding too much from your host computer.

If problems persist, load a single kit and make sure no other application is running in 
the background. For further assistance visit the Toontrack forums at
http://www.toontrack.com/forum/
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