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1. Overview

The Devicelnstaller is an all-in-one utility for detecting various Lantronix devices (device servers)
on a network. You can view current device parameters and make more devices available for
viewing.

For Devicelnstaller procedures specific to a device, please see the device's User Guide.



2. Devices

Choose the Network Adapter for Communication

By default, the primary adapter used by Windows is the network adapter used for communication
with devices on the network.

To select a different adapter:

1. From the Tools menu, select Options. The Options window opens, displaying the list of
available adapters.

2. Select the adapter by clicking its checkbox, and click Apply.
3. To exit, click OK.

Search for All Devices on the Network
You can search for all Lantronix devices within the local area network.

To find and list all Lantronix devices:

If your PC has more than one network adapter, you can select the one you want using
Options on the Tools menu. All network communication uses whichever adapter you select.

P
1. Click the Search icon |“== on the toolbar. It may take several seconds for the list of

devices to display in the device list.

Devices that do not have an IP address assigned or are configured for a different network
display in red. You must assign an IP address to the device to use it.

To clear the device list:

1. From the File menu, select New. The device list is cleared.

Change Views
You can view device information in different ways.

To change how devices are identified in the device tree (left pane):
1. You have three options:

e To identify devices by hardware address, on the View menu, click Device Node
Text>Hardware Address. This is the default.

e To identify devices by IP address, on the View menu, click Device Node Text>IP
Address.

e To identify devices by name only, on the View menu, click Device Node
Text>Name.

2. To confirm a change for all devices, select Expand All from the View menu.

To change how devices display in the device list (right pane):



Devices

1. You have two options:

e To display device details, on the View menu, click Device List>Details. This is
the default.

e To display devices as icons, on the View menu, click Device List >Icons.

When you click an icon, device details display in the right pane and the device
expands in the hierarchy in the left pane.

Add a Device to the List

As an alternative to using the Search tool to add devices to the device list, add individual devices
manually to the list.
To add a device to the list manually:

1. From the Device menu, select Add Device. The Add Device window displays.

2. Enter the IP address for the device and click OK. Devicelnstaller searches for the device.
Upon connection to the device, Devicelnstaller adds it to the device list. A message
displays if Devicelnstaller does not find the device.

View Device Details
You can use Devicelnstaller to view some of a device's current configuration settings.

For a complete list of the device's configuration, please access either the Web or Telnet
interface and consult the User Guide for the device.
To view some of a device's configuration settings
1. To view details about the device, you have the following options:
¢ Inthe device list, double-click the device.

¢ In the left pane of the window, open all levels of the hierarchy for the device type
and select the device.

The Device Details tab and the list of properties (settings) display.
For information about the settings, see the User Guide for the device.

2. To view another device, in the left pane of the window, open all levels of the device type
hierarchy and select the device.

Device Lists

Save the Device List

You can save the list of devices as a text file and restore it for later use. The text file includes the
following information:

e Device Name

o Group

e Comments

e |P Address for the device

The configuration of the devices in the list is not stored.

To save the device list:



1
2
3.
4
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From the File menu, select Save or Save As.
Locate the directory where you want you want to save the file.
If desired, replace the default File name (Devices1) with another name.

Click Save.

Open the Device List
To open a previously stored list of devices:

1.
2.
3.

4.

From the File menu, click Open.
Find the location of the stored device file list (in text format).

Highlight the file name and click Open. The list of devices displays in the Devicelnstaller
window.

If Devicelnstaller does not find a device listed in the text file, a message displays.

To close the list, select New from the File menu.

Print the Device List
To print the current list of devices displayed:

1.
2.

3.

Open the device list.

(Optional) To preview the list before printing, select Print Preview from the File Menu.
Click Close to exit.

From the File menu, select Print.

Check Device Diagnostics

To determine whether a device is online and the network is functional, use the Devicelnstaller
Ping option. This option ensures the device is operating and determines the speed of a response
from the device.

To ping a device:

1. Select the device.

2. From the Tools menu, select Ping. The Ping Device window displays.

3. Inthe IP Address box, enter the IP address of the device.

4. Click Ping. After several moments, the Status area displays the ping results.

5. To ping another device, select Clear Status to clear the Status area before entering
another IP address.

6. To exit, click Close.

Reset

Reset is a dangerous capability and is best used by power users only.

The reset option is unavailable by default. To enable the reset option, see Customize Reboots on
page 22.

To reset a device:

1.
2.

Select the device in the menu tree or Device List.

From the Device menu, select Reset.
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After resetting the device, perform a new search to locate all the devices on the

network

Enter Global Credentials

Configure the Global Credentials setting to populate the username and password that
Devicelnstaller uses when it attempts to log into gateways. This setting also defines the action
that Devicelnstaller will take if the login attempt fails: either skip the device and go on to the next
one, or display a login prompt for the device.

Devicelnstaller needs to log into the gateway when it performs a firmware upgrade, configuration
upgrade, or device provisioning. This is particularly useful when Devicelnstaller is upgrading or
provisioning multiple devices.

To configure the global credentials:

1.
2.
3.

From the Tools menu, select Enter Global Credentials.
Enter the gateway credentials for login.

Next, indicate what action Devicelnstaller should take if the login attempt fails. Select
either to skip the device or to prompt with a dialog box to enter login credentials
manually.

Click OK.



3. IP Addresses

Set IP Address Manually

You can set the IP address of a device on the list or identify a device not on the list and set its IP
address.

To set the IP Address of a Device:

1. From the device list, select the device.

@
2. On the toolbar, click Assign IP l=== The Assign IP Address window displays.

The Device Identification window prompts for the device's hardware address if a
device was not selected in the previous step. Enter the hardware address from the product

label and click Next.

3. Onthe Assignment Method page, select Assign a specific IP address and click Next.
The IP Settings window displays.

4. Enter the following information:

7.

IP address

Subnet mask

Default gateway

An IP address that will be unique and valid on your
network. There is no default.

Enter the IP address in dot-quad notation. Do not
use leading zeros in the fields for dot-quad numbers
less than 100. For example, if your IP address is
172.19.201.28, do not enter 028 for the last segment.
The network segment on which the device resides.
There is no default. The subnet mask displays
automatically based on the IP address you entered, but
you can change it.

IP address of the router for this network.

Click Next. The Assignment page displays.

Click Assign to assign the IP address to the device. A status message indicates when
the assignment is complete.

To exit, click Finish.

Set IP Address Automatically

You can specify the method by which the device obtains its network settings. If you are not
familiar with the specific protocols, we recommend you accept the default options.

To set the IP address of the device automatically:

1. From the device list, select the device.

@
2. On the toolbar, click Assign IP l=== The Assign IP Address window displays.
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The Device Identification window prompts for the device's hardware address if a
device was not selected in the previous step. Enter the hardware address from the product
label and click Next.

3. Select Obtain an IP address automatically. Click Next. The IP Discovery Settings page
displays.

4. Select the network protocol for searching and obtaining the IP address and click Next.
The Assignment page displays.

Not all device models support all methods, so some options may be disabled for
your particular device.

5. Click the Assign button to assign the IP address to the device. A message indicates
when the assignment is complete.

6. To exit, click the Finish button. If the device has been configured to require a username
and password to set the IP address, the Password Required page displays.

Enter User ID and Password (if applicable)
A device may have been configured to require a user ID and password to set the IP address.

To enter a username and password:
1. Enter your user ID and password for the specific device.

2. Refer to the documentation for the device for information on how to change passwords.

3. Click the Next button. The Assignment page displays.

TCP/IP and Subnetting Tutorial

TCP/IP Tutorial Overview

This tutorial is designed to provide the user with enough information to resolve a problem being
experienced with Devicelnstaller. For more detailed information on the TCP/IP protocol, please
go to www.google.com and search for RFC791, RFC950, or TCP/IP.

To assist you further in assigning an IP address to your Lantronix device, you can download a
freeware subnet calculator from the Internet. To locate a freeware subnet calculator, go to
www.google.com and search for freeware subnet calculator.

To submit feedback regarding this tutorial, please log onto www.lantronix.com/support and submit
a technical support e-mail.

All IP addresses and subnet masks used in this tutorial are examples. To obtain an IP address to
assign to your device, please contact your network administrator.

Subnets

If Devicelnstaller reported a subnet issue with your PC, it is because the PC’s IP address and the
IP address you are trying to assign to your Lantronix device are on different subnets. The IP
addresses of the device and the PC running Devicelnstaller must be on the same Local Area
Network and subnet.

For Devicelnstaller to assign an IP address to your Lantronix device successfully:

e Your PC's IP address and the address you want to assign to your Lantronix device must
be on the same subnet.

e No routers or gateways can exist between your PC and your Lantronix device.
Devicelnstaller does not support assigning an IP address across a router or gateway.


http://www.google.com/
http://www.google.com/
http://www.lantronix.com/support

IP Addresses

To resolve this issue, configure your PC with a static IP address on the same subnet as the
address you are assigning to your device. For information on configuring a static IP address in
Windows, see the Windows Help files. You can access Windows Help files by clicking the
Windows Start button and selecting Help. Search in Windows Help for static IP address.

Before you change the network settings on your PC, be sure to write them
down so you can restore the settings after assigning an IP address to your device.

IP Addresses and Subnetting

To understand why Devicelnstaller is failing and how to resolve this issue, you must have some
general knowledge of TCP/IP and subnetting.

IP addresses are separated into network classes. Network classes are also known as subnet
classes. The letters A, B and C denote the subnet/network classes. An IP address is made up of
four octets, each separated by a decimal point, as shown below:

AAA.BBB.CCC.DDD
A’s = First Octet

B’s = Second Octet
C’s = Third Octet
D’s = Fourth Octet

To check your PC’s current IP configuration on Windows 2000 or XP:
1. Click Start --> Run.
2. Atthe Open prompt, type cmd. A command window opens.

3. Atthe command window, type ipconfig. Your Windows TCP/IP configuration displays.

To check your PC’s current IP configuration on Windows 98:
1. Click Start --> Run.
2. Atthe Open prompt, type command. A command window opens.

3. Atthe command window, type ipconfig. Your Windows TCP/IP configuration displays.

Class A Subnets and Addresses

Class A networks use a subnet mask of 255.0.0.0. This subnet mask indicates that the first octet
in each IP address on the network must be the same number. This allows network devices to
communicate on the Local Area Network (LAN).

If your PC is on a class A network (meaning it's using a subnet mask of 255.0.0.0), the first octet
of your PC’s IP address and the first octet of the IP Address you are assigning to your Lantronix
device must be the same number.

Class A Example:
Your PC is configured with the IP and subnet mask below:

10.100.110.120 — IP Address
255.0.0.0 — Subnet Mask

Your Lantronix device must be assigned an IP that is:
10. XXX XXX. XXX

where the x’s are an available IP address on the network.
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Class B Networks and Addresses

Class B networks use a subnet mask of 255.255.0.0. This subnet mask indicates the first and
second octet in each IP address on the network must be the same. This allows network devices
to communicate on the LAN.

If your PC is on a class B network (meaning it's using a subnet mask of 255.255.0.0), the first and
second octets of your PC’s IP address and the first and second octet of the IP address you are
assigning to your Lantronix device must be the same numbers.

Class B Example
PC running Devicelnstaller is configured with the IP and subnet mask below:

172.16.224.55 — IP Address
255.255.0.0 — Subnet Mask

To assign an IP address to a Lantronix device successfully, the IP assigned must be:
172.16.XXX.XXX

where the x’s are an available IP address on the network.

Class C Networks and Addresses

Class C networks use a subnet mask of 255.255.255.0. This subnet mask indicates the first,
second and third octet in each IP address on the network must be the same. This allows network
devices to communicate on the LAN.

If your PC is on a class C network (meaning it is using a subnet mask of 255.255.255.0), the first,
second and third octets of your PC’s IP address and the first, second, and third octets of the IP
address you are assigning to your Lantronix device must be the same numbers.

Class C Example
A PC running Devicelnstaller is configured with the IP and subnet mask below:

192.168.12.155 — IP Address
255.255.255.0 — Subnet Mask

To assign an IP address to a Lantronix device successfully, the IP assigned must be:
192.168.12.xxx

where the x's are an available IP address on the network.

Complex Subnet Masks

Your PC is configured with a complex subnet mask if it is configured for a subnet mask other than
three listed below:

255.0.0.0
255.255.0.0
255.255.255.0

In this case, we recommend you download a freeware TCP/IP subnet calculator. To locate a
freeware subnet calculator, go to www.google.com and search for freeware subnet calculator.
The subnet calculator will help ensure you assign a correct IP address to your Lantronix device.

Auto IP Addresses

If Devicelnstaller reported an Auto IP address issue, your PC is configured to obtain an IP
address automatically from a server on the network. If Windows does not obtain an IP address, it
defaults to an Auto-Configuration IP Address. Devicelnstaller is not able to assign an IP address
to your Lantronix device if your PC is using an Auto-Configuration IP address.



IP Addresses

To check whether your PC is using an Auto-Configuration IP address in Windows 2000 or
XP:

1. Click Start and select Run.
2. Atthe Open prompt, type cmd. A command window opens.

3. Atthe command window, type ipconfig. Your Windows TCP/IP configuration displays.

To check your PC’s current IP configuration on Windows 98:
1. Click Start and select Run.
2. Atthe Open prompt, type command. A command window opens.

3. Atthe command window, type ipconfig. Your Windows TCP/IP configuration displays.

To resolve the issue:

If your PC is using an Auto-Configuration IP address, it has an IP address like 169.254.XXX. XXX,
where the X's are randomly chosen numbers. Notice that the first two octets of the IP address are
169.254, indicating an Auto-Configuration IP address.

To resolve this issue, configure your PC with a static IP address. For more information on
configuring a static IP address in Windows, see the Windows Help files. You can access the
Windows Help files by clicking the Windows Start button and selecting Help. Search in Windows
Help for static IP addresses.

10



4. Configuration Methods

Access the Web Interface

To access the web interface to configure a device that has a web page:

1.
2.

4.

From the list of devices, select the device you want to configure.

Click the Web Configuration tab. The Web Configuration page displays. The device's IP

address is at the top.

You have two options:

e To use the Devicelnstaller browser, click the Go button. The device's home page

displays.

Use the arrow buttons to navigate through the browser.

e To use an external browser (Internet Explorer), click the Use External Browser.

The device's home page displays in Internet Explorer.

Consult the device's User Guide for configuration instructions.

Access Telnet
To Telnet to the device's configuration menu:

1.
2.
3.

4
5.
6

From the list of devices, select the device you want to configure.
Click the Telnet Configuration tab. The Telnet configuration screen displays.
Verify that the IP address and Telnet port display at the top.

Click the Connect button. The Telnet user interface displays.

Within 15 seconds, enter your user ID and password for the device and press Enter.

Consult the device's User Guide for configuration instructions.

11



5. Firmware Upgrades

Upgrade Firmware Overview

You can use Devicelnstaller to upgrade firmware on a device. There are two ways to upgrade the
firmware: by using an existing Installer file or by specifying individual files. You can upgrade
multiple devices of the same type and firmware with the same file.

An installer file (.Ixi) is created when installation settings are saved. The individual files are stored
in the .Ixi file for later use.

Devicelnstaller must log into the device in order to upgrade the firmware. Before starting
the firmware upgrade, set the username and password in the Enter Global Credential setting in
the Tools menu to allow Devicelnstaller to use the stored values. For more information, see Enter
Global Credentials.

Upgrade Using Individual Files

The following table details devices that may upgrade using individual files and the file types
required. A .rom file is the device’s firmware file. An .fwx is a firmware extension file. A .cob file
contains the data for the device’s web pages.

Upgrade

XPort XXXX.rom, XXxx.cob

WiPort XXXX.rom, Xxxx.fwx,
XXXX.cob

WiBox XXXX.rom, Xxxx.fwx,
XXXX.cob

ubDS XXXX.rom, XXxx.cob

CoBox-FL XXXX.rom, Xxxx.cob

SDS XXXX.rom, Xxxx.cob

XPress XXXX.rom, Xxxx.cob

To create a custom installation:
1. Select the device from the device list.

To upgrade multiple devices of the same type and firmware with the same files,
select the devices from the device list.

2. Click Device>Upgrade or click the Upgrade icon "** The Device Upgrade Wizard
window displays.

Select the Create a custom installation by specifying individual files and click Next.

4. (Optional) To download the latest ROM file, click the Would you like to check the
Lantronix Website for the latest firmware button.

5. Click Browse under the Firmware (ROM) File field to open the Select ROM Firmware
File window. Locate the appropriate file and click Open to set the file location path in the
Device Upgrade Wizard window.

12



Firmware Upgrades

e For WiPort devices, repeat the previous step for setting the file location of the
appropriate Firmware Extension File (.fwx) by clicking Browse under the
Firmware Extension (FWX) File field.

e If you obtain an intermediate .rom file, select the Intermediate Firmware File
Needed? checkbox.

6. To use the existing .rom and .fwx files, leave these fields blank.
7. Click Next. The Device Upgrade Wizard prompts for the type of files to add.
For some products, these options are not available.
Select one of the following options and click Next:

e No Other Files to Install (Typical) to continue the upgrade without loading any
.cob or individual files.

e Install files individually to add files in their raw form.

e Install files contained in COB partitions to add files in the form of .cob
partitions.

e Install setup records from a file to install previously saved setup records.

To install files individually:
1. You have the following options:

e To install individual files, click Add Files and select the set of files.
e Toremove a file scheduled for installation, select the filename and click Remove.

e To change the file location on the device, select the filename and click Change
Path.

2. Click Next. The Device Upgrade Wizard window displays the status and result of the
upgrade
Green indicates a successful installation; blue indicates that the IP address has
changed.
3. When the upgrade is complete, select Close to exit.

To install files contained in .cob partitions (Web-Manager files):
1. You have the following options:

e To set afile partition, highlight the partition in the displayed list and click Set
Partition. The Select COB Archive File window displays; locate the appropriate
.cob file and click Open. The files in a partition display in the list.

e To erase a file partition, select the partition and click Erase.
e To leave a file partition intact, select the partition and click No Change.
When finished, click Next.

3. (Optional) To save the installation as a Lantronix installation file (.Ixi), click Save
Installation.

4. Click Next to continue the installation, or click Cancel to exit without the actual device
upgrade.

If you continue the installation, the Device Upgrade Wizard window displays the status and
result of the upgrade.

13



Firmware Upgrades

Green indicates a successful installation; blue indicates that the IP address has
changed.

Upgrade Using an Existing Installation File
To use this option, there must be a pre-existing installation (.Ixi) file.

To upgrade the firmware on a device:
1. Select the device in the device list.

To upgrade multiple devices of the same type and firmware with the same file,
select the devices from the device list.

2. Select Upgrade from the Device menu or click the Upgrade icon "**  The device
upgrade Wizard window displays.

To upgrade using an existing installation file, select Use a specific Installation file.

4. Click Browse to open the Select Installation File window. Locate the correct Lantronix
Installer file (.Ixi) and click Open to set the file location path in the Device Upgrade
Wizard window.

5. Click Next to proceed with the upgrade. The Device Upgrade Wizard window displays the
status and result of the upgrade.
Green indicates a successful installation; blue indicates that the IP address has
changed.

6. When the upgrade is complete, click Close to exit.

Setup Records

Save Setup Records

You can save setup records for updating regions of flash memory on the unit. This option is not
enabled if the device does not support this capability.

To save setup records:
1. On the device list, select the device.

2. Onthe File menu, select Save Setup Records. The Save Setup Records window
displays.

3. Select as many records as desired and click Save. The Save As window displays. Some
setup records are unavailable.

4. Save the setup record and name it as desired. (You must save the records one at a
time.)

View Setup Record
You can view the contents of a setup record.

To view a setup record:
1. From the View menu, select Setup Record File.

2. Browse and select the desired setup record. The setup record displays.

14



Firmware Upgrades

Install Setup Records
You can install previously saved setup records to upgrade the device.
To install setup records:

1.

9.

Select the device from the device list.

o

Select Upgrade from the Device menu or click the Upgrade icon""#**  The Device
Upgrade Wizard window displays.

Select the Create a custom installation by specifying individual files and click Next.
The Device Upgrade Wizard prompts for the type of files to add.

Some Lantronix products do not offer these options.
Select Install setup records from a file.
Click Browse to locate the setup record and click Next.

(Optional) To save the installation as a Lantronix installation file (.Ixi), click Save
Installation.

Click Next to continue the installation, or click Cancel to exit without the actual device
upgrade.

If you continue the installation, the Device Upgrade Wizard window displays the status
and result of the upgrade.

Green indicates a successful installation; blue indicates that the IP address has
changed.

Click Close.

Recover Firmware
In the event of a failure, the Recover option allows for firmware installation through the serial port
instead of the network.

Not all devices support the recovery feature. A drop-down list displays the supported

devices. Ensure the firmware is the correct type before installing it over the serial port.

To install firmware over the serial port:

1.

From the Tools menu, select Advanced-->Recover Firmware. The Serial Port Firmware
Upgrade window displays.

Power off the device.

Connect a serial cable from the PC running the Devicelnstaller to the primary serial port
on the device.

From the Serial Port Firmware Upgrade window, choose the PC port from the Port on PC
drop-down menu.

Select a device type from the Device Model drop-down menu.
Locate the firmware file on the PC by clicking Browse.

From the Files of type drop-down menu, select the type of the firmware file. Available file
types are ROM (.rom), serial program binary (.spb), or serial download binary (.sdb).

Click Open. The file's path displays in the Firmware File field.

Serial download binary (.sdb) files download the file temporarily into RAM. The
previous firmware is restored upon reset.
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Firmware Upgrades

9. Click OK. The status bar in the Devicelnstaller window indicates the progress of the
firmware upgrade. A confirmation box displays when the upgrade is complete.

The status bar may prompt to reset the device. If this occurs, reset or toggle the
power on the unit to continue with the firmware upgrade.
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6. Provisioning Devices

Generate Device File

You can use Devicelnstaller to generate a file containing a list of devices that facilitates importing
multiple devices into the Lantronix cloud services (Gateway Central or MACH10). The device file
contains a comma separated list of one or more devices of a single gateway type.

Devicelnstaller must log into the device in order to generate a device file. Before starting
this operation, set the username and password in the Enter Global Credential setting in the Tools
menu to allow Devicelnstaller to use the stored values. For more information, see Enter Global
Credentials.

To generate a device file:

1. From the device list, select one or more devices. They must be of the same gateway
type.
2. Click Generate Device File.

Wait while Devicelnstaller generates the device file. Devicelnstaller displays a dialog box
that lists the number of devices to be included and a progress bar. You may be prompted
to enter the gateway'’s login credentials if the global credentials supplied to
Devicelnstaller do not match the credentials on the gateway.

Click Download to save the device file.

4. Select the folder location for the file. Devicelnstaller uses the following file naming
convention to name the device file: “AddDeviceList_ YYYY_MM_DD_hh.mm.ss.TDI".

Import Provisioning File

You can program a group of gateway devices that are not provisioned for Lantronix cloud
services using a provisioning file generated by Gateway Central or MACH10. You can also
enable or disable the MACH10 client state, firmware updates, and configuration updates.

Devicelnstaller must log into the device in order to provision the device. Before starting this
operation, set the username and password in the Enter Global Credential setting in the Tools
menu to allow Devicelnstaller to use the stored values. For more information, see Enter Global
Credentials.

To provision gateways:
1. From the device list, select the device or devices to be provisioned.
2. Click Import Provisioning File.

3. Select the checkboxes to enable MACHZ10 client settings. Clear the checkboxes to
disable the settings:

a. Enable MACH10 Client State
b. Apply Configuration Update
c. Apply Firmware Update

4. Click Browse to select the provisioning file. (.EDI file extension).
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Customization

Click Update.

Wait while Devicelnstaller provisions the gateway(s). You may be prompted to enter the
gateway's login credentials. After provisioning the devices, Devicelnstaller also generates
a device file that you can use to import the devices into the Lantronix cloud service.

Click Download to save the device file. Devicelnstaller uses the following file naming
convention to name the device file: “AddDeviceList_YYYY_MM_DD_hh.mm.ss.TDI".
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Customization

7. Configuration Update

Update the configuration settings on one or more gateways on the network using a file. There are
two ways to apply configuration updates to the selected gateways:

e Batch Configuration Update - Update selected gateways with a single file. This method
applies the same configuration settings to all gateways using one file.

e Per Device Configuration Update - Update selected gateways with gateway-specific files.
This method applies a different configuration record to each gateway using files that
follow a “<baseName><serialNumber>" file naming convention. The “baseName” is a
user-specified value, such as the gateway model name (for example, “sgx5150-" or
“pwxn-").

XML Configuration Records

Refer to the gateway-specific user guide for details on the XML configuration record (XCR)
syntax. When importing the configuration, you can import a partial XCR; there is no need to
import the entire XCR.

Before starting the configuration update, create and save a valid configuration file. If you are
using the batch configuration method, Devicelnstaller will search for the specified file. If you are
using the per device configuration method, all configuration files must be located in the same
folder. Devicelnstaller will search for files with file extension .xcr or .xml in the specified directory.

Devicelnstaller must log into the device in order to update the configuration. Before starting
this operation, set the username and password in the Enter Global Credential setting in the Tools
menu to allow Devicelnstaller to use the stored values. For more information, see Enter Global
Credentials.

To update configuration:
1. From the device list, select the device or devices.
2. From the Tools menu, select Config Update.
3. Select the configuration method:
a. Batch Configuration Update
b. Per Device Configuration Update

4. If Batch Configuration Update was selected, click Browse and select the configuration
file.

a. Click Apply to start the configuration update.

A dialog box displays the progress and the hardware address of the gateway
being configured. You may be prompted to enter the gateway login credentials.
Enter the gateway username and password and click OK.

5. If Per Device Configuration Update was selected, type a Base Name and then click
Browse to select the folder where the configuration files are located.

a. Click Apply to start the update.
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Customization

b. A dialog box displays the progress and the hardware address of the gateway
being configured. You may be prompted to enter the gateway login credentials.
Enter the gateway username and password and click OK.
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8. Customization

Customize Logging

You can customize the unit's logging features, including when to activate logging, how to change
log file size, and how to view logs.

To customize logging:

1. From the Tools menu, select Options. The Options window displays.

2. Click the Customization tab.

3.

In the Log File section, specify the following information:

Activate logging
during upgrading.
Activate logging
during searching.
Log File

Max File Size

Viewing Program

If you select this option, logging occurs while you are
upgrading the unit.

If you select this option, logging occurs while you
search for devices.

If you selected to activate logging, enter or browse to a
location on your system for naming and saving the log
file.

The maximum number of bytes (in increments of
megabytes). When the file reaches this limit, the first
half of the file is removed; the latter half is retained.
Enter or browse to a program such as NotePad for
viewing the contents of the log file.

4. Click Apply to save and leave the window open.

5. Click OK to save and close the window.

Display a Warning

Devicelnstaller can display a warning when you open a saved search and a device on the list is
no longer online.

To display a warning:

1
2.
3.

From the Tools menu, select Options. The Options window displays.

Click the Customization tab.

In the bottom section of the window, select Display a warning when devices are not
found when importing from afile.

Click Apply to save and leave the window open.

Click OK to save and close the window.

Customize the Category Name
You can include the device version in the name, for example, XPort (R3) - firmware v6.1.0.0.

To include the device version:
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Customization

From the Tools menu, select Options. The Options window displays.
Click the Customization tab.

In the lower section of the window, select Use the Device version as part of the device
category name.

Click Apply to save and leave the window open.

Click OK to save and close the window.

Customize Reboots
You can specify settings for the reboot process.

To enable the reset command and display it in the Device menu:

1.

From the Tools menu, select Options. The Options window displays.
Click the Customization tab.

In the lower part of the window, select Enable reset commands and allow them to be
shown as menu items.

Click Apply to save and leave the window open.

Click OK to save and close the window.

To set reboot wait times:

1.
2.
3.

From the Tools menu, select Options. The Options window displays.
Click the Customization tab.

In the lower part of the window, specify the following:

Device reboot wait Select the number of seconds the unit should unicast

time (Unicast) messages while waiting for a reboot. The unit attempts
a series of unicasts before broadcasting.

Device reboot wait Select the number of seconds the unit should broadcast

time (Broadcast) messages while waiting for a reboot. The unit attempts

a series of broadcasts after completing unicasts.

4. Click Apply to save and leave the window open.

5. Click OK to save and close the window.
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