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Tank Management Software

NOTICE

Read this manual before working with the product. For personal and system safety, 
and for optimum product performance, make sure you thoroughly understand the 
contents before installing, using, or maintaining this product.

For equipment service or support needs, contact your local Emerson Process 
Management/Rosemount Tank Gauging representative.

The contents, descriptions and specifications within this manual is subject to change 
without notice. Rosemount TankRadar AB accepts no responsibility for any errors that 
may appear in this manual.

Version
This manual describes the functionality of TankMaster WinView RevAA.
If an older version of TankMaster is used, all functionality described in this manual may 
not be present and the Graphical User Interface (GUI) may not look the same.
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Section 1 Getting Started

What is TankMaster?  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 1
TankMaster Software Package . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 2
Installing the TankMaster Software . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 4
Hardware Key Info  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 6
Illegal characters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 8

1.1 What is TankMaster?

TankMaster is an Emerson Process Management/Rosemount™ Tank Gauging inventory 
management software package for installation and configuration of level gauging 
equipment. The TankMaster program package provides you with powerful and easy-to-use 
tools for installation and configuration of devices such as the Rosemount 2410 Tank Hub, 
the Rosemount 5900S Radar Level Gauge, the Data Acquisition Unit (DAU), and the Field 
Communication Unit (FCU). You can easily change settings of protocols, devices and tanks 
at any time.

TankMaster is designed to be used in the Microsoft® Windows 7 environment providing easy 
access to measurement data from any PC in your network.

The TankMaster system allows you to use the TRL/2 Modbus protocol and can be connected 
via interfaces like RS232 and RS485. Other communication protocols, e.g. Enraf GPU, are 
also supported. TankMaster works in Windows 7 networks and is based on the open OPC 
standard allowing you to import data to other systems like DCS:s, PLC:s, Scada systems and 
Microsoft Office programs.

The graphical interface gives you a clear overview of installed devices and tanks. For each 
tank you can easily see the associated transmitters and data acquisition units.

Measured data is presented in realtime and you can customize the view of tank data to suit 
your needs.

Key Features
 Monitoring of measured and calculated data.

 Clear overview of installed tanks and devices.

 Simple installation by using “wizards”.

 Open connectivity.

 Object oriented user friendly Graphical User Interface.
1Getting Started
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1.2 TankMaster Software Package

TankMaster comprises the following software modules:

 WinView

 WinOpi

 WinSetup

 Tank Server

 Master Protocol server

 Slave Protocol Server

WinView is the operator´s interface to the tank gauging system. It communicates with the 
Tank Server and the different protocol servers to let the user monitor measured tank data. 
WinView also provides alarm handling, automatic report handling as well as inventory 
calculations like volume and mass.

WinOpi is an extended version of WinView. WinOpi has full support for API calculations. 
WinOpi is the operator´s interface to the tank gauging system. It communicates with the 
Tank Server and the different protocol servers to let the user monitor measured tank data. 
WinOpi also provides alarm handling, batch report, automatic report handling, historical 
data sampling as well as inventory calculations like volume, observed density and other 
parameters

The WinSetup program is a graphical user interface for installation, configuration and 
service of level gauging devices.

The Tank Server communicates with devices via the Master protocol server and handles 
configuration data for all the installed tanks and devices. Tank and device names, 
configuration data like antenna type, number of connected temperature sensors and 
analog inputs and many other parameters are stored by the Tank Server. The Tank Server 

WinView/WinOpi/WinSetup

Tank Server

Master Protocol Server Slave Protocol Server

COM1 COM2
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collects measured data from connected devices and provides these data to the Win-
View/WinSetup user interface.

The Master Protocol Server transfers configuration data and measured data between the 
Tank Server and connected devices in the tank gauging system. The Master Protocol Server is 
able to communicate with various types of devices to collect measurement data such as 
level, temperature, and pressure.

The Slave Protocol Server is used to connect the TankMaster system to a host computer (DCS 
system). The Slave Protocol Server exchanges tank data between the Tank Server and the host 
computer.
3Getting Started
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1.3 Installing the TankMaster Software

1.3.1 System Requirements

The following system specification is recommended to run TankMaster ver. 6.C0 or 
higher(1):

Note
A hardware key is not required to run WinSetup.

1.3.2 Installed Software Modules

The following software program modules are installed:

 TankMaster WinSetup program.

 TankMaster WinView program.

 Tank Server.

 Various Master protocol servers.

 Various Slave protocol servers.

(1) For previous TankMaster versions other system requirements may apply. Please contact 
Emerson Process Management/Rosemount Tank Gauging for more information.

General

Product Rosemount TankMaster; WinOpi, WinSetup, WinView

Operating system English version of:
• Windows 7 Professional, 32- and 64-bit versions, with service pack 1(SP1)
• Windows Server 2008 R2 with service pack 1(SP1)
• Windows 10 version 1511 (64-bit platform recommended)
• Windows Server 2012 R2 SP1

TankMaster PC Hardware

Processor • 2.5 GHz, multi core processor

Internal Memory 
(RAM)

• 4 GB for 32-bit operating systems
• 8 GB for 64-bit operating systems

Hard Disk 128 GB
• TankMaster + SQL Server 2005 Express needs approximately 600 MB
• Supported Operating Systems (up to Windows Server 2012 R2) need 

approximately 25 Gb of available space

Serial Ports USB (RS232)

Monitor A 22 inch or larger monitor is recommended.

Hardware key One key connected to a USB port for each PC with a TankMaster server. 
TankMaster clients do not require a hardware key.
4 Getting Started
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1.3.3 Installation Procedure

To install the TankMaster software package do the following:

1. Insert the TankMaster CD-ROM.

Response: the installation wizard is started.

Note
If the installation wizard does not start automatically when the CD-ROM is inserted, 
double-click the file Tmcd.exe on the TankMaster CD-ROM, or click the Windows Start 
button , choose Run and select the Tmcd.exe file on the TankMaster installation CD in 

order to start the TankMaster installation.

2. In the installation window click the TankMaster button to install the TankMaster 
software(1).

3. Install the Acrobat Reader software if you want to be able to read the online 
documentation in pdf format.

4. Finish the installation.

(1) The TankMaster and Acrobat Reader softwares can be installed in any order. The installation window remains open during 
the complete installation procedure.
5Getting Started
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1.4 Hardware Key Info

The Server Hardware Key Info window displays the functions enabled by the TankMaster 
hardware key. The displayed information is not possible to edit and is only valid for the 
selected server. Also shown is the number of tanks permitted to install according to the 
TankMaster license, and the current number of installed tanks.

Note
If the number of installed tanks exceeds the number of licensed tanks, the inventory 
calculation option will be disabled until a hardware key with a sufficient number of licensed 
tanks is installed, or tanks are uninstalled.

To access the Server Hardware Key Info window, do the following:

1. From the Tools menu, choose View Server HW Key Info.

2. Select server.

3. When finished viewing the Server Hardware Key Info window, click Close to close the 
window.
6 Getting Started
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1.4.1 Enabled Functions

The Enabled Functions pane in the Server Hardware Key Info window shows all the available 
TankMaster options. A selected “radio button” indicates that the corresponding function is 
enabled with the current hardware key. The available functions are listed in the table below:

Function Explanation

Inventory System(a)

(a) Only available in WinOpi.

Enables Alarm, Volume according to API, etc.

WinView System Enables Alarm, Volume, etc.

Host access to server via OPC and 
serial port

Communication to host via OPC DA and Modbus RTU.

Network access for TM client 
node(a)

Enables viewing of all installed tanks in the network 
from any TankMaster PC, independent of WinOPI type.

Redundancy(a) Enables the use of redundant servers.

HTG calculation and Setup(a) Hydrostatic Tank Gauging, Enables the use of pressure 
sensors.

Custody Transfer(a) Setup mode for the Custody System.

Custody Transfer Seal(a) Read Only mode. No possibility to change 
configuration.

Custody Transfer Batch Report(a) Batch report for the Custody System.

Window Customization(a) Enables the use of customized windows.

Service Key (TM will only run for 
48 hours)

Only available for Service engineers.
7Getting Started
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1.5 Illegal characters

Naming objects in TankMaster using certain characters may cause problems. The following 
characters should be avoided:

\ Reverse solidus % Percent sign

 / Solidus < Less-than sign

? Question mark > Greater-than sign

* Asterisk { Left curly bracket

[ Left square bracket } Right curly bracket

] Right square bracket ' Apostrophe

| Vertical line " Quotation mark
8 Getting Started
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Section 2 The WinView Main Window

Menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 11
Toolbar  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 12
Status bar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 13
Workspace - viewing tanks and devices  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 14
Icons  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 16
User management  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 17

The TankMaster WinView main window includes the Workspace to display tanks and devices, 
a menu bar at the top of the screen, a status bar at the bottom of the screen and a number 
of buttons in the toolbar.

Minimize
Maximize Close

Menu bar

Tool bar

Workspace

Status bar
9The WinView Main Window
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The Workspace window can be moved anywhere in the Main window. It can be docked at 
any side, or it can be left floating.

Right click and choose Allow 
Docking to place the 
Workspace window along one 
of the Main window borders.

The Workspace window can 
also be moved around in the 
Main window by deselecting 
Allow Docking.
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2.1 Menus

The menu bar at the top of the screen contains menus such as File, View, Entry, Setup, 
Reports, Tools and Help.

Some menu options are available by clicking the right mouse button. Different options are 
available depending on what type of object is selected in the Workspace window.

Example

By clicking the right mouse button on a tank, the following menu appears:

Menu bar
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2.2 Toolbar

To display the WinView toolbar, from the View menu choose the Toolbar option. The 
toolbar provides buttons acting as shortcuts to different menu options.
The following items are included in the standard toolbar:

1. Lets you log off to View Only mode.

2. Lets you log on to TankMaster as Operator, Supervisor or Administrator.

3. Lets you turn the Workspace window On or Off.

4. Opens the Tank View window.

5. Opens the View Group window.

6. Opens the Bargraph Group window.

7. Opens the Tank Movement window.

8. Opens the Alarm Summary window.

9. Opens the Alarm Log window.

10. Lets you accept alarms.

11. Opens the Tools/Options window.

12. About WinView.

1 2 3 4 5 6 7 8 9 11 1210
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2.3 Status bar

The status bar is located at the bottom of the TankMaster main window.

The status bar displays information about current alarms. It also provides information about 
the current protection level status (View Only, Operator, Supervisor, Administrator etc.).

Status bar

Connection status

Alarm status

Current user

Flashing to indicate normal operation

Current protection level
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2.4 Workspace - viewing tanks and devices

The workspace displays an overview of all devices and tanks. The workspace lets you 
perform a variety of tasks:

 View tank data.

 View tank operation data.

 View alarm logs and alarm summary.

 Supervise alarms.

 Specify reports.

2.4.1 Viewing Tanks

The Workspace window shows the installed tanks:

Group
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Various tank data can be monitored such as level, temperature as well as alarm logs and 
summary of current alarms.
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2.5 Icons

In the Workspace window the different objects are represented by the following icons:

Cylindrical tank

Floating roof tank

Spherical tank.

Horizontal tank

Tank group (blue icon)

Report
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2.6 User management

TankMaster provides several protection levels to prevent unauthorized changes. These 
protection levels are categorized as User Access Levels and User Access Sub Levels. The 
User Access Levels are Administrator, Supervisor, Operator, and View Only and each has 
five User Access Sub Levels. This gives a total of 20 unique access levels.

In order to change WinView settings such as Alarm limits, System Setup, Tank Setup etc. 
you have to be logged on to TankMaster. You can be logged on in ChiefAdmin, 
Administrator, Supervisor, Operator, or View Only mode.

The default usernames and passwords are:

User Level Sub Level Default password

View VIEW ONLY * view

Operator OPERATOR * oper

Supervisor SUPERVISOR * super

Administrator ADMINISTRATOR * admin

ChiefAdmin ADMINISTRATOR ***** chief
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2.6.1 Logging on to TankMaster

To log on to TankMaster do the following:

1. From the File menu choose Log On or click the Log On button in the WinView 
toolbar.

2. Type your Username and Password. The password is case sensitive but the 
username is not.

Note
If logging on fails five consecutive times the user account is disabled. In this case the user 
account has to be enabled by an administrator.

3. Click the OK button.
The currently logged on user and the protection level is displayed in the WinView 
status bar.

Username Protection level
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2.6.2 To administrate user accounts

TankMaster allows you to setup a number of users at different levels and sub levels. You 
must be logged on as an Administrator in order to add new user accounts or to change the 
existing user account settings.

To add a new user:

1. Log on as an Administrator.

2. In the Tools>Administrative Tools menu choose User Manager.

3. In the User Manager window select a cell in an empty row and click the New button.

4. Type a user name and a password. If you like, enter a description in the Description 
field.
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5. Choose the desired Level (User Access Level) and Sub Level and click the OK 
button. See “User management” on page 17 for further information about the 
available User Access Levels and Sub Levels.

6. Check that the new user appears in the User Manager window.
Select the “Use first account...” box if you want a default user name to appear in the 
Log On dialog whenever it is opened. If this box is unmarked the User Name field is 
empty when the Log On dialog opens.

7. Click the OK button.

A new user account 
is added

Use first account with required 
access level as default.

When the “Use first 
account...” box is selected, a 
default user name appears in 
the Logon dialog.
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2.6.3 Configure Access Sub Level description

TankMaster offers the option to change the Sub Level descriptions to something more 
suitable than the default settings. 

To configure the access sub level descriptions, do the following:

1. In the Tools>Administrative Tools menu choose User Manager.

2. In the User Manager window, click the Config Desc button.

3. In the Config Access Sub Levels Description window enter a new description in the 
desired field. 
In the example above, the description of item number 5 of category Admin Sub 
Levels is changed from “*****” to “Sub5-Admin”.

4. Press OK to close the Config Access Sub Level Description window.
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2.6.4 To set required access levels

TankMaster WinView includes the option to set the protection level required for the 
following actions:

 Report Handling

 Accepting Alarms

 Exiting WinView

For example, if you are logged on as an Operator (* * *), you are not allowed to exit WinView 
if the required exit level for this action is set to Operator (****) or higher.

To set the required access levels:

1. From the Tools/Administrative Tools menu choose Set Required Access Levels.

Note
You have to be logged on as an Administrator (* * * * *) to be able to set the required 
access levels. To create an Administrator (* * * * *) account, see chapter 2.6.2 To 
administrate user accounts.

2. Set the required access level for each action and click the OK button.
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2.6.5 To change protection level for separate windows

In TankMaster it is possible to set a Protection Level for a specific window to avoid 
unauthorized users to edit data, e.g. the Alarm Limits window. This function is only available 
if you are logged on at the Administrator (* * * * *) level. To change the protection level do 
the following:

1. Put the cursor on the icon at the upper left corner and click the left mouse button.

2. Choose the Protection Level option.

Note
You have to be logged on as an Administrator (* * * * *) to be able to change the Protection 
Level. To create an Administrator (* * * * *) account, see “To administrate user accounts” 
on page 19.

3. Select the desired Protection Level and Sub Level from the corresponding drop 
down menus and click the OK button. 

4. Now you will be prompted to log on at the specified protection level (or higher 
protection levels) in order to make any changes to this window (Alarm Limits in the 
example above).

1. Click the icon in 
the left corner

2. Choose 
Protection Level
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2.6.6 To change password

To change your TankMaster password, do the following:

1. From the Tools/Administrative Tools menu choose the Set Password option.

2. Enter your Username if the workspace is in View Only mode. If you are already 
logged on, your username appears in the Username field.

3. Enter the old password and the new password in the corresponding fields.

Note
The password is case sensitive.

4. Confirm the new password and click the OK button.

2.6.7 To change inactivity timeout

TankMaster WinView includes the option to set a timeout after which the current user is 
automatically logged off. The timeout period is reset each time the user performs an 
activity that requires an access level check, for example setting a new alarm limit or logging 
on to WinView.

To set the Inactivity Timeout:

1. From the Tools/Administrative Tools menu choose the Set Inactivity Timeout 
option. (You have to be logged on as Administrator).

2. Type the desired value in the corresponding input field.

3. Click the OK button.
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2.6.8 To set program security options

TankMaster WinView provides options which may be used to restrict user privileges to run 
Windows programs or perform certain actions.

The configurations are categorized in two parts:

TankMaster Operator´s Interface
 Run application maximized. If this option is checked, WinView will run maximized 

and the minimize and restore down buttons in the upper right corner of the 
application window will be disabled.

 Disable possibility to switch to other programs. If this option is checked, 
WinView will ignore keyboard commands such as Alt+Tab, Alt+Esc, Ctrl+Esc, etc.

TankMaster Administrator and Windows security
 Run TankMaster Administrator as Shell. Allows the TankMaster Administrator 

program to run as a Windows Shell instead of the standard shell (Windows 
Explorer). When this option is set, all other security options in the “TankMaster 
Administrator and Windows Security” group are automatically set.

 Disable Task Manager. Prevents the user from starting Task Manager 
(Taskmgr.exe). If this option is set and the user tries to start Task Manager, a 
message appears explaining that a system policy prevents the action.

 Disable Lock Workstation. Prevents the user from locking the system. While 
locked, the desktop is hidden and the system cannot be used. Only the user who 
locked the system or the system administrator can unlock it.

 Disable Change Password. Disables the Change Password button on the Windows 
Security dialog box (Which appears when pressing Ctrl+Alt+Del). As a result, the 
user cannot change the Windows password on demand.

 Disable Registry Editor. Disables the Windows registry editors, Regedt32.exe 
and Regedit.exe. If this option is set and the user tries to start a registry editor, a 
message appears explaining that a system policy prevents the action.

 Disable Windows Shutdown/Restart. Prevents the user from shutting down or 
restarting Windows. This option removes the Shut Down option from the Start 
menu and disables the Shut Down button on the Windows Security dialog box that 
appears when you press Ctrl+Alt+Del. This option prevents the user from using the 
Windows user interface to shutdown the system, although it does not prevent 
them from running programs that shut down Windows.

 Disable Command Prompt. Prevents the user from running the interactive 
command prompt, Cmd.exe. This option also determines whether batch files 
(.cmd and .bat) can run on the computer.

 Disable Autorun/Autoplay. Disables the Autoplay feature on all drives.
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To set the program security options:

1. From the Tools/Administrative Tools menu choose the Security Option.

2. Select the desired security options.

3. Click the OK button.
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Section 3 Viewing Tank Data
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TankMaster offers a number of views for presentation of measured and calculated data. You 
can view measured and inventory data for single tanks as well as all tanks.

You can also edit custom views with parameters by your own choice. You can for example 
edit a custom view to only show Level, Level Rate and Level Status. See “ Modifying the 
group views” on page 37 for further instructions on how to modify windows for tanks.
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3.1 Measured values

3.1.1 Single tanks

To open the Tank View window do the following:

1. Select the desired tank in the Workspace window.

2. From the View>Tank menu, choose the Tank View option, or
click the right mouse button and choose View Tank>Tank View.

The Tank View window shows data from the Rosemount™ 2410 Tank Hub, the Rosemount 
5900S Radar Level Gauge, and the Rosemount 2240S Multi-Input Temperature Transmitter 
for a single tank. For each item the value, measurement unit and status is displayed.

Bar graph

A bar graph shows the product level and free water level at the bottom of the tank. Flow 
rates exceeding a certain threshold is indicated by an arrow on the left side of the bar graph. 
Depending on the actual flow rate value one of two arrow types appears. The thresholds 
which control the arrow indication can be changed (Tools>Options>Tank Movement). See 
also “ Tank movement” on page 33 for more information.

Temperature sensors

Temperature sensors immersed in the product are marked with a “*” symbol. The 
temperature sensors can be connected to the Rosemount 2240S Multi-Input Temperature 
Transmitter or the Rosemount 644 Temperature Transmitter for Single Point Temperature 
Sensor.
28 Viewing Tank Data



Reference Manual 
00809-0300-5110, Rev AB

Viewing Tank Data
September 2016
3.1.2 Tank groups

View group

To view data for all tanks do the following:

1. Select All Tanks in the Workspace window.

2. Click the right mouse button and choose View Group>View Group, or from the 
View>Group menu, choose the View Group option.

This window shows Level, Level Status, Level Rate, Average Temperature and other 
variables for all tanks.

Filling/emptying a tank can be indicated with arrows as shown below:

There are two different arrow sizes. By setting appropriate thresholds, the arrows can be 
used to indicate level rates within different ranges. To specify the level rate thresholds, 
choose the Tools/Options/Tank Movement tab. See “ Tank movement” on page 33 for 
more information.

Tank movements can also be highlighted by different color coding to improve visibility, See 
“Enable color highlight” on page 36..

You can change the contents of the View Group window by choosing the 
Tools/Options/Group Templates tab. See “ Modifying the group views” on page 37 for 
more information.

Note
The contents in a group view can be sorted, See “Sorting content in product table” on 
page 56. for further information.
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Bar graph group

To view data presented in bar graph format do the following:

1. Select All Tanks in the Workspace window.

2. Click the right mouse button and choose View Group>Bar Graph Group, or from 
the View>Group menu, choose the Bar Graph Group option.

In the Bargraph Group window each tank is represented by a bar graph showing Product 
Level and Free Water Level for each tank. It also indicates level changes by showing an arrow 
next to the bar graph.

For each tank the following default parameters are listed in a table:

 Product

 Level

 Average Temperature

 Total Observed Volume (TOV)

 Mass

Filling/emptying a tank can be indicated with arrows. There are two different arrow types. 
By setting the Flow Rate thresholds to appropriate values, the arrows can be used to 
indicate low or high flow rates. See “ Tank movement” on page 33 for more information.

You can change the contents of the Bar Graph Group window by choosing the 
Tools/Options/Group Templates tab. See “ Modifying the group views” on page 37 for 
more information.

Note
The tanks can be organized in rows instead of columns, See “Modifying the group views” on 
page 37.
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Shortcut menu

In the different Group View windows, there is a shortcut menu available for quick access to 
other group and tank views. The shortcut menu appears when clicking the right mouse 
button in the open group view.

The shortcut menu includes: 

 View Tank

 View Group

 View Alarms

 Tank Entry

 Sensor Value

 Set-Point Alarm Limits

 Alarm Limits

 Alarm Disconnect

 Tank Capacity

 Tank Set-Point Alarm Setup

 Send Servo Command

 Refresh Group View

 Edit Group Template
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3.2 Tank operation

To view data for a specific tank do the following:

1. Select the desired tank in the Workspace window.

2. Click the right mouse button and choose View Tank>Tank Operation, or from the 
View>Tank menu, choose the Tank Operation option.

See “ Inventory parameters” on page 57 for further information on the relation between 
measured data and inventory parameters.
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3.3 Tank movement

To view tanks which are emptied or filled, click the right mouse button and choose View 
Group>Tank Movement, or select a tank group in the Workspace window and choose 
View>Group>Tank Movement.

The Tank Movement window shows the direction of the current product surface movement. 
It also includes Level Rate and Flow Rate. Limits can be set in order to exclude tanks with 
Flow Rates and Level Rates below certain values. Thus only tanks with flow rates and level 
rates exceeding the specified limits appear in the Tank Movement window.

An arrow points in the direction of surface movement. A thick arrow indicates a high flow 
rate/level rate. A thin arrow indicates a low flow rate/level rate.

Tank movements can also be highlighted by different color coding to improve visibility, See 
“Enable color highlight” on page 36..

You can change the contents of the Tank Movement window by choosing the 
Tools/Options/Group Template tab. See “ Modifying the group views” on page 37 for 
more information.
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3.3.1 Level rate thresholds

To specify thresholds for Level Rate, do the following:

1. From the Tools menu choose Options, and select the Tank Movement tab.

2. Enter the desired Level Rate thresholds.

3. Press Apply and OK to close the Operator’s Interface Options window.

Note
The Flow Rate/Level Rate threshold settings apply to all windows which indicate product 
surface movement such as the View Group window, Tank View window etc.

Level rate thresholds

Minor – Level rates above this value are indicated with a thin arrow in the Tank Movement 
window. There is no movement indication for level rates below this threshold.

Major – Level rates above this value are indicated with a thick arrow in the Tank Movement 
window. 

Note
It is the Flow Rate that controls color highlight indication in the Tank Movement window.
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3.3.2 Common flow rate thresholds

To specify thresholds for Flow Rate Thresholds, do the following:

1. From the Tools menu choose Options, and select the Tank Movement tab.

2. Choose the Use common threshold for all tanks option.

3. Enter the desired threshold values.

4. Click Apply and OK to close the Operator’s Interface Options window.

Note
The Flow Rate/Level Rate threshold settings apply to all windows which indicate product 
surface movement such as the View Group window, Tank View window etc.

Flow rate indication

Minor – Tanks with Flow Rates below this threshold do not appear in the Tank Movement 
window. Flow rates above this limit are indicated with a thin arrow.

Major – Flow rates above this threshold are indicated with a thick arrow.

Tanks with Flow 
Rates below the 
Minor threshold 
value don’t appear 
in the Tank 
Movement window
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3.3.3 Enable color highlight

To enable color coding for Tank Movement, do the following:

1. From the Tools menu, choose Options.

2. In the Group Templates tab, select the desired group template and click the Edit 
button.

3. Select the Highlight Tanks in movement check box.

Note
To change the color definitions of tanks in movement, See “Color Settings for Tank 
Movement” on page 46.
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3.4 Modifying the group views

To change the appearance of a window under the View/Group menu, do the following:

1. From the Tools menu choose Options.

2. Select the Group Templates tab.

3. Select one of the existing tank views and click the Edit button to open the Edit 
Group Template window.

Options
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4. The Menu Item and the View Title fields can be edited:

 The Menu Item name appears as an option in the View>Group menu.

 The View Title name appears in the title bar of the edited group view.

5. The View Type can be changed by selecting one of the options from the View Type 
drop-down menu.

6. You can choose between tables where tanks are presented row by row, column by 
column, or in rows and columns.

Menu Item

View Title

View Type
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7. Select the desired parameters in the left pane and click the Select button.
Now the selected parameters appear in the right-hand pane:

8. In the Show As column, for each parameter choose the format for data 
presentation:

9. Click the OK button.

MI=Temp.Sensor in Liquid,
CV=Current Value,
VU=Value Unit,
AS=Alarm Status,
etc.

Select Button

Selected parameters
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To open the changed window, from the View/Group menu choose the selected Menu Item 
name, in this example View Group.

VU - Value unitCV - Current value
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3.4.1 Common group view settings

In all windows where data is presented in tables, you can change font and alignment of text 
in data cells and headers:

1. From the Tools menu choose Options.

2. Select the Group Templates tab.

3. In the Group Templates tab press the Change button.

Example box
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4. Specify the desired formatting for column headers and data cells. 
A preview of the result is shown in the Example box.
With settings as in the example above, the View Group window would look like this:

Text aligns to the left in the data cells
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3.5 Color Settings

WinView offers the option to specify colors for bar graphs, backgrounds in input fields, 
manually entered values, different types of alarms, and products in the Product Table.

To specify colors do the following:

1. From the Tools menu choose Options.

2. Select the Color tab.

3. Choose the desired item from the list. You can specify colors for bar graphs and 
backgrounds in windows, to indicate manual values, alarms and products.

4. Click the Change button.

5. Choose a color from the Color palette or define a new color by clicking the Define 
Custom Colors button.

6. Click the OK button.
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3.5.1 Product color settings

WinView offers two different options for product colors in Bargraphs:

In the Product Table you can choose colors to represent specific products. These colors will 
then be used in different bargraphs to show the current product level. However, before this 
option is available a set of product colors must be defined, and WinOpi must be configured 
to use these product colors.

To specify product colors do the following:

1. Choose Tools>Options and select the Colors tab.

2. Choose the Bargraph Product item.

3. Select the Use Product Color check box.

Option 1 The same color is used for all products.

Option 2 Each product is associated with a color according to the 
Product Table setup.
44 Viewing Tank Data



Reference Manual 
00809-0300-5110, Rev AB

Viewing Tank Data
September 2016
4. Scroll down to the product list. Edit the desired products: Product1, Product2 etc. 
Up to 20 products can be defined. To define a product color click the Change 
button and choose one of the available colors, or define a new color.

5. Click the OK button when you have specified the desired product colors.

See “ Creating a product table” on page 55 for instructions on how to associate products 
with specific colors.
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3.5.2 Color Settings for Tank Movement

To change the colors for tank movement, do the following:

1. From the Tools menu choose Options.

2. Select the Color tab.

3. The affected fields are Major Moving Up/Down and Minor Moving Up/Down.

4. Press Apply and OK to close the Operator’s Interface Options window.

Response: the colors for tank movement are changed.

Note
To enable the use of color highlight for tank movement, “ Enable color highlight” on 
page 36.
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Section 4 Installing a Tank 
Measurement System

Installation procedure  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 47
System setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 48
Setting up a Tank Capacity Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 50
Creating a product table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 55
Inventory parameters  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 57

4.1 Installation procedure

Setting up a tank measurement system for level measurement and inventory calculation 
includes the following steps:

1. System Setup
Specify measurement units and other system parameters. The System Setup is 
done in TankMaster WinSetup.
See chapter 4.2 System setup for further information.

2. Tank Capacity Table
Specify the geometry of the tank for volume calculation.
See chapter 4.3 Setting up a Tank Capacity Table for further information.

3. Creating a Product Table
Specify the products to be used in the tank.
See chapter 4.4 Creating a product table for further information.

4. Tank Inventory Configuration
Specify parameters for inventory calculation.
See chapter 4.5 Inventory parameters and for further information.

5. Alarm Handling
Specify alarm limits for level, volume and signals from external sensors.
See chapter Section 5 Alarm Handling for further information on alarm handling.
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4.2 System setup

To specify measurement units and other system parameters in WinSetup, do the following:

1. In the WinSetup workspace, select the server to which the device is connected.

2. Click the right mouse button on the server icon and choose the Setup option, or 
from the Service menu choose the Servers>Setup option.

3. The following window appears. Make the desired settings and click the OK button.

Note
Changing the System Setup settings will not affect previously installed tanks. It will only 
affect tanks installed after the change is done.

4.2.1 System units

Choose the desired measurement units to be used for data presentation.
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4.2.2 Tank Capacity Table

You can specify the default type of Tank Capacity Table (TCT) from the TCT Type drop-down 
list. When a TCT table is created for a new tank, the type is automatically specified 
according to the default setting in the System Setup window. However, for a new tank you 
can change TCT type in the Tank Capacity Setup window if you don´t want to use the default 
setting, see chapter 4.3.4 Creating a Tank Capacity Table.

Reference Temperature is only available for WinOpi.
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4.3 Setting up a Tank Capacity Table

The geometry of the tank is defined in a strapping table called the Tank Capacity Table, TCT. 
The TCT describes the geometry of the tank and is used to convert a product level to the 
corresponding volume. The values can be entered either as absolute levels, as relative levels, 
or as pairs of level and volume.

You can choose one of three types of Tank Capacity Tables:

 International (absolute levels)

 Northern (relative levels; mostly used in Sweden and Finland)

 Raw

You can specify a default TCT type that will automatically be used for new tanks (Setup>Sys-
tem). You can change TCT type of a separate tank if you don´t want to use the default 
setting (Setup>Tank Capacity).

When you specify a TCT using either the Northern or the International method, it is very 
important that the resulting level-volume curve is continuous. The calculated volume at the 
top of one interval must correspond exactly to the volume at the bottom of the next 
interval. 

The relative and the absolute method of entering TCT data require four parameters at each 
strapping point:

The Northern and the International methods do not use the same Base Volume and Tank 
Area Coefficient. When you use the Raw Method you have to enter pairs of level and volume. 
For each level you enter the corresponding standard volume.

From level at the beginning of the interval,

To level at the end of the interval,

Volume Base Volume,

Area Tank Area Coefficient.

Base Volume

Calculated Volume
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4.3.1 Using the International method

The Base Volume is the volume at the beginning of the interval. The Tank Area Coefficient 
describes how the volume varies with the level within the interval.

With the International Method, the desired volume is calculated as:

Desired Volume = Vo + Area * (Level - Lo)

where;

Level The measured level.

Lo Level at the beginning of the interval

Vo Base Volume

Desired Volume The volume at the measured level

Area Tank Area Coefficient. This is not the surface 
area of the product, although the mesurement 
unit of this parameter is the same as for a 
surface area (volume/length).

Vo

Lo

Volume
at end of 
interval

Level

Volume

Level at end of 
interval (To)

Level at beginning 
of interval (From)
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4.3.2 Using the Northern method

The Northern method is based on the fact that within the interval, there is an approximately 
linear relationship between level and volume, as illustrated below. The Base Volume 
corresponds to the volume at Level = 0, given by extrapolation of the linear level - volume 
relationship. The Tank Area Coefficient describes how the volume varies with the level 
within the interval based on this Base Volume.

With the Northern Method, the volume is calculated as:

Desired Volume = Vo + Area * Level

where;

4.3.3 Using the Raw method
When you use the Raw Method you have to enter corresponding values of Level and 
Volume. In the following example, it is shown how pairs of Level and Volume values are 
input in TankMaster when using TCT type Raw.

Level The measured level

Desired Volume The volume at the measured level

Vo Base Volume

Area Tank Area Coefficient. This is not the surface area of the 
product, although the mesurement unit of this parameter is 
the same as for a surface area (volume/length).

Level Volume

1.53 10 105

2.72 22 309

3.18 29 934

4.78 41 249

Vo

Volume at 
beginning of 
interval Volume at end 

of interval

Level

Volume

Level at end of 
interval (To)

Level at beginning 
of interval (From)
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4.3.4 Creating a Tank Capacity Table

TankMaster WinView offers you the option to specify a strapping table to be used for 
volume calculations (see chapter 4.5 Inventory parameters for more information on the 
relation between inventory data and measured data).The geometry of the tank is defined in 
the Tank Capacity Table (TCT). The TCT is used for converting a product level to the 
corresponding volume. The values can be entered either as pairs of level and volume, as 
absolute levels or as relative levels depending on the type of TCT that is used. The Tank 
Capacity Table is stored as pairs of level and volume irrespective of the way the values are 
entered into the system.

To create a Tank Capacity Table do the following:

1. Select the desired tank in the WinView Workspace window.

2. In the Setup menu choose Tank Capacity.

3. To change the TCT type for the current tank, or to specify the number of strapping 
points, click the Change button. The default TCT type is specified in the System 
Setup window (WinSetup). This TCT type is automatically chosen when strapping 
tables are created for new tanks. Note that using the Change button only affects 
the current tank.

4. Choose the Level and Volume measurement units to use when the strapping table 
is entered.

5. Type the Maximum and the Minimum Volume of the current tank. The Minimum 
Volume is equal to the volume between the outlet and the bottom of the tank.

6. The Sump Volume is the volume that is left when the tank is emptied down to the 
zero level. Instead of being specified in the Sump Volume field, it may be included 
in the Strapping Table. In this case, the Base Volume at the Zero Level is equal to the 
Sump Volume.
Make sure that the Sump Volume is not specified both ways at the same time!
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7. Enter numerical values for the strapping table points.

8. Click the Apply button to store the entered values without closing the window, or 
click the OK button to finish the tank capacity setup.

ZERO LEVEL MINIMUM VOLUME
SUMP VOLUME
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4.4 Creating a product table

Product specific information is stored in the Product Table. It is possible to edit the default 
selection of products and also add new products to the table. To change an item in the 
Product Table:

1. From the Setup menu, choose the Product Table option.

Note
The content in the product table can be sorted, for more information See “Sorting content 
in product table” on page 56.

2. In the Product table select a cell and double click the left mouse button, or click the 
Edit Product button.

3. Enter the appropriate data for: Product, Description, Group, Product Code and 
Color. The other fields are only available for WinOpi.

Color
Type a number that corresponds to the desired product color. Note that this requires that a 
set of product colors has been specified in the Tools/Options/Color window. See chapter 
3.5.1 Product color settings for more information on how to specify product colors.

4. Repeat steps 2 and 3 for all products you want to add into the Product Table.

5. Click the OK button.

The arrow 
indicates that 
the Product field 
is sorted
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4.4.1 Sorting content in product table

The content in the Product Table can be sorted, to do this perform the following steps:

1. Left click in the cell head of the desired column. Multiple columns may be sorted.

2. If left clicking the cell head again, the sorting changes from descending to 
ascending.

3. To reset the sorting, right click on the desired column cell head.

The arrow 
indicates that 
the Product 
field is sorted
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4.5 Inventory parameters

TankMaster calculates inventory parameters based on input data available for the current 
tank.

The following figure shows an example of how TankMaster converts measured product level 
to TOV and Mass:

Free Water 
Volume

Level

Tank Capacity 
Table

Total Observed 
Volume

Mass

Relation between tank parameters and physical quantities
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The following figure illustrates the relationship between tank parameters and physical 
quantities. The main parameters are shown in the left-hand part, and the input parameters 
are shown in the right-hand part of the flow chart:

Total Observed Volume, TOV is calculated from strapping tables. It is the total volume 
at the observed temperature of the product.

Mass is the TOV multiplied by the Obs Density.

Maximum Volume is entered by the user. The Maximum volume should 
correspond to the maximum product level.

Available Room, AVRM is calculated by substracting the Total Observed Volume 
from the Maximum Volume of the tank.

Sump volume is the volume that is left in a tank when emptied down to 
the Zero level.

Minimum Volume is the volume between the outlet and the bottom of the 
tank.

Pumpable Volume is the Total Observed Volume minus the Minimum 
Volume.

Flow Rate the Flow Rate is calculated using the level rate and the 
strapping tables.

Free Water Level, FWL can be manually entered or measured by a water 
interface sensor. 
To specify the Free Water Level source signal, i.e. the 
analog input to which the sensor is connected, select the 
current tank and choose the 
Tanks>Properties>Configuration menu in the TankMaster 
WinSetup program.

Free Water Volume, FWV calculated on the basis of the Free Water Level and the 
Tank Capacity Table (TCT).

Tank parameters flow chart
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4.5.1 Tank entry

During operation, e.g. changing product in a tank, the setup is performed in the Tank Entry 
window, assuming that the product has been properly defined in the Product Table.

The Tank Entry window is used for specifying a number of product parameters to be used for 
inventory calculations. To enter Observed density, Free Water Level and type of product for a 
specific tank, do the following:

1. Select the desired tank in the Workspace window.

2. Click the right mouse button and choose Tank Entry, or from the Entry menu 
choose the Tank Entry option.

3. Enter the desired values.

Observed Density

Enter a manual value for the Observed Density.

Free Water Level

For the FWL parameter TankMaster can use automatically measured data, or data that is 
manually entered.

To enter manual values select the check box and type the desired value in the 
corresponding input field. Manual values are marked with yellow color. See chapter 3.5 
Color Settings for more information on how to define colors for manual values.

Product

Choose the desired product from the pop-up list. The list contains products specified in the 
Product Table (see chapter 4.4 Creating a product table for information on how to create a 
product table).
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Section 5 Alarm Handling

Alarm limits  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 63
Viewing active alarms - Alarm Summary  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 66
Alarm log  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 68
To accept alarms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 73
Disconnecting alarms  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 74
Alarm Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 76

WinView lets you supervise various types of alarms. You can set alarm levels as well as 
hysteresis and delay times for Level, Level rate and Average temperature.

The status of the alarms can be either HiHi, High, Low, LoLo, Error, Leak Hi, Leak Lo, CFail 
(communication failure) or Normal. The HiHi, High, Low and LoLo alarms, the Alarm Delay 
Times, the Alarm Hysteresis and the Leak Alarms are set by the operator in the Alarm Limits 
window. The operator password is required to do changes in the Alarm Limits window.

The measurement data that the WinView receives from the different field devices are 
continuously checked against the alarm limits. If a value has passed an alarm limit, the 
corresponding alarm will be activated after a certain delay time given by the Delay Time 
setting.

The alarm status is shown with a flashing bright red color in for example, the Alarm 
Summary window, until the operator has accepted the alarm. When an alarm is accepted, 
the status is shown in a steady dark red color. The alarm colors can be changed (see chapter 
5.6.2 Color). Even if the conditions have returned to normal, the alarm status is not reset 
until the operator has accepted the alarm. In order to disable an alarm the parameter that 
caused the alarm must pass below the alarm limit and an extra amount specified by the 
Alarm Hysteresis value. When these conditions are satisfied, the alarm reset is delayed an 
amount of time given by the Delay Time.

Leak alarms

The level leak alarm monitors product level changes. When the Leak Limit is set the current 
tank level is stored. The WinView monitors the difference between the actual level and the 
stored level, and activates the Leak Alarm when this difference becomes greater than the 
Leak Limit programmed by the operator.

Sensor failure

If there is a sensor failure, for example when the signal goes out of range, sensor status 
Error is displayed.
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Communication failure

If a Field Communication Unit, a Radar Tank Gauge or a Data Acquisition Unit does not 
respond after three queries, the alarm status of the tank parameters will be set to CFail.The 
Status Bar will show error messages such as “<Tank Name> FCU CFail”, “<Tank Name> RTG 
CFail”, or “<Tank Name> DAU CFail” in case a device that does not respond. All parameters 
associated with a device does not respond gets the status CFail. Even though the CFail alarm 
can be shown for a number of parameters, it is only concerned as one alarm, and the alarm 
needs only to be accepted once for each unit.

Alarm status priority

Each parameter status has a certain priority as shown below. If for example a 
Communication Failure alarm is activated for a certain tank, the alarm status Error will not 
be shown for that tank as long as the Communication Failure status is valid. If the parameter 
is disconnected (see chapter 5.5 Disconnecting alarms) then Discon will replace CFail as the 
status of the parameter.

The WinView alarms are given the following order of priority:

1. Disconnect (Discon)

2. Communication Failure (CFail)

3. Error

4. Blocked

5. HiHi, LoLo

6. Leak Alarm Hi, Leak Alarm Lo

7. High, Low

Priorities 1 to 4 are valid for automatically measured values only, not for manually entered 
values.
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5.1 Alarm limits

To set the Alarm Limits do the following:

1. Select the desired tank in the WinView Workspace window.

2. Click the right mouse button and choose Alarm Limits.

The Alarm Limits window lets you specify various alarms. You can setup alarm limits for level, 
level rate, average temperature.

3. Enter the desired alarm limits for Level, Level Rate and Avg Temp.

4. Click the OK button to activate the current settings and to close the Alarm Limits 
window.

5.1.1 Level

HiHi, Hi, LoLo, Lo

Type the desired limits in the appropriate input fields.

Leak

Leak alarm limits can be specified for Level. To enable/disable Leak alarms choose the Alarm 
Disconnect option from the Entry menu and deselect/select the corresponding check box, 
see chapter 5.5 Disconnecting alarms.

HiHi Alarm threshold for the extreme high condition.

Hi Alarm threshold for the high condition.

Lo Alarm threshold for the low condition.

LoLo Alarm threshold for the extreme low condition.
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Hysteresis

By setting a hysteresis value you can stop alarms from turning on and off due to turbulent 
measurement conditions.
Example: the Level Hi limit is set to 10 m and the hysteresis to 0.1 m. The alarm is activated 
when the level exceeds 10 m. It remains active until the level drops below 9.9 m. In this case 
small waves on the liquid surface do not influence the Hi alarm.

Delay

The Delay time can be used to prevent temporary changes of the measurement value from 
activating the alarm.

5.1.2 Level Rate

HiHi, Hi. LoLo, Lo

Type the desired limits in the appropriate input fields.

Hysteresis

By setting a hysteresis value you can stop alarms from turning on and off due to turbulent 
measurement conditions.
Example: the Level Rate Hi limit is set to 4,5 m/h and the hysteresis to 0.1 m/h. The alarm is 
activated when the level exceeds 4,5 m/h. It remains active until the level drops below 4,4 
m/h. In this case fluctuations in the flow do not influence the Hi alarm.

Delay

The Delay time can be used to prevent temporary changes of the measurement value from 
activating the alarm.

5.1.3 Average temperature

HiHi, Hi, LoLo, Lo

Type the desired limits in the appropriate input fields.

HiHi Alarm threshold for the extreme high condition.

Hi Alarm threshold for the high condition.

LoLo Alarm threshold for the low condition.

Lo Alarm threshold for the extreme low condition.

Hi Alarm threshold for the high condition.

Lo Alarm threshold for the low condition.
64 Alarm Handling



Reference Manual 
00809-0300-5110, Rev AB

Alarm Handling
September 2016
Hysteresis

By setting a hysteresis value you can stop alarms from turning on and off due to turbulent 
measurement conditions.
Example: the Avg Temp Hi limit is set to 125,0 °C and the hysteresis to 0.1 °C. The alarm is 
activated when the level exceeds 125,0 °C. It remains active until the level drops below 
124,9 °C. In this case fluctuations in the temperature do not influence the Hi alarm.

Delay

The Delay time can be used to prevent temporary changes of the measurement value from 
activating the alarm.
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5.2 Viewing active alarms - Alarm Summary

You can view alarms for all tanks in the system by selecting the appropriate icon in the 
Workspace window.

To view a summary of active alarms do the following:

1. Select All Tanks in the 
Workspace window.

2. Click the right mouse button 
and select View Alarms > 
Alarm Summary, 

or,

from the View/Alarms 
menu choose the Alarm 
Summary.
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Now the Alarm Summary window appears:

The Alarm Summary window displays an alarm until it is accepted and the condition that 
caused the alarm to activate is taken care of.

Alarm status

The Alarm Summary window displays the time when the alarm was activated in the On 
column, and the time it was accepted by an operator in the column designated Accepted.

An alarm is not removed from the list until it has been accepted as well as the condition that 
activated the alarm has returned to normal.

Note
A Leak Lo/Hi alarm is not removed from the list until it has been disconnected in the Alarm 
Disconnect window, (Entry/Alarm Disconnect menu). 
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5.3 Alarm log

You can view an alarm log for a tank or all tanks. To view the Alarm Log do the following:

1. Select the desired tank (or All Tanks) 
in the Workspace window.

2. Click the right mouse button and 
select Alarm Log, 

or,

from the View/Alarms menu, 
choose the Alarm Log option.
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This window shows a list of logged alarms. For each alarm the following information is 
displayed:

 Alarm type (High, Low etc.)

 Tank name.

 The parameter that activated the alarm.

 The parameter value when the alarm was activated.

 Alarm status.

 The time and date when the alarm was activated and accepted.

 The operator who accepted the alarm.

Alarm status

When an alarm is activated the status is indicated as On.
When the alarm is accepted, Acc is added to the status line.

If an alarm is unaccepted, the status remains to be On, even if the measured value that 
caused the alarm to activate has returned to normal.

The alarm status is not changed to Off until the corresponding alarm has been accepted, 
and the measurement value is within the accepted range.
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Filter settings

You can specify which tanks to be displayed (applicable for All Tanks) and the range of days 
or hours to be viewed:

1. In the Alarm Log window, click the Filter button to open the Alarm Log Filter Settings 
window:

Note
In the example above, a single tank was selected for viewing in the Alarm Log window. 
Therefore, only one tank is shown in the Selected Tanks pane when the Filter button is 
pressed. All tanks are available in the Selected Tanks pane if All Tanks is selected in the Alarm 
Log window.

2. Specify the period of time to be viewed.

Choose All dates if you want to view every alarm that has been logged for the selected 
tanks. 

Choose Date between if you want to view alarms for a certain range of days.

Choose Not older than if you want to view all alarms from a certain point of time until now.

3. Mark the Save settings as default check box if you want this filter setting to be the 
standard setting each time you open the Alarm Log window.

4. Click the OK button.
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5.3.1 Saving the alarm log to file

The Alarm Log can be saved to file. To save the Alarm Log do the following:

1. From the Tools menu choose Options.

2. Select the Log Setup tab.

3. Choose the Log to File option.

Set the maximum log file size by specifying the number of records or the number of 
days to be logged.

By setting the size of the log file to for example 10 days all alarm events from the current 
date and 10 days back are stored.

Alarm log file 
settings
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5.3.2 Alarm printer settings

Alarms can be printed directly to an Alarm Printer. The printout of the alarm is executed 
when the alarm is activated.

To print each alarm on an Alarm Printer:

1. From the Tools menu choose Options.

2. Select the Log Setup tab.

3. Choose the Log to Printer option.

4. Select the Printer Port to which the Alarm Printer is connected. Also set the 
maximum number of lines per printed page and the maximum number of 
characters per line.

5. Click the button Verify connection to print a test page on the Alarm Printer.

Alarm Printer 
Settings
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5.4 To accept alarms

To accept an alarm do one of the following:

 Press the <SHIFT + F9> keys.

 Click the toolbar Accept button.

 In the View menu, select Alarms and then Accept Alarm.

Alarms can only be accepted by a user that is logged on at an access level above or equal to 
the required access level. To set the required access level for alarm handling, see “To set 
required access levels” on page 22.

Accept button
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5.5 Disconnecting alarms

Disconnecting alarms can be useful if, for instance, service is required. You can choose to 
disconnect certain alarms which you don´t want to be active or you can choose to 
disconnect all alarms.

To disconnect an alarm do the following:

1. Select the desired tank in the Workspace window.

2. Click the right mouse button and choose Alarm Disconnect, or
from the Entry menu choose the Alarm Disconnect option.

This window lets you specify which alarms you want to disable. WinView continues to 
update the measurement value even if the corresponding alarm is disconnected.

The status of a disconnected alarm will be shown as Discon.

A disconnected temperature sensor is not included in the average temperature calculation.

Note
There are no Error alarms for disconnected sensors. This means that sensor failures will not 
be notified for sensors with disconnected alarms.

3. To disconnect an alarm, select the check box next to the corresponding parameter. 
To disconnect all alarms, select the check box Disconnect Tank.

Note
Even though an alarm is disconnected the measurement of the specific parameter 
continues.

Select Disconnect Tank to 
disconnect all alarms for 
the tank

Select a check box to 
disconnect 
the corresponding alarm
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5.5.1 Enable/Disable Leak Alarms

The Enable/Disable Leak Alarms function is used to enable or disable leak alarms for all 
tanks. 
To enable/disable alarms for individual tanks use the Alarm Disconnect function, See 
“Disconnecting alarms” on page 74.

To enable or disable Leak alarms, do the following:

Right-click on All Tanks and choose Enable/Disable Leak Alarms. Alternatively the 
Enable/Disable Leak Alarms window can be opened from the menu Entry>Enable/Disable 
Leak Alarms.

The only available option is Level.

Press the button Enable to activate the selected leak alarms for all tanks. The button Enable 
is active if the leak alarm is disabled for one or more tanks.

Press the button Disable to disable the selected leak alarms for all tanks. The button Disable 
is active if the leak alarm is enabled for one or more tanks.
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5.6 Alarm Setup

5.6.1 Sound

WinView offers the option to set different kinds of alarm sound signals. This option can be 
used to distinguish between various types of alarms. 

To specify sound signals do the following:

1. From the Tools menu choose Options.

2. Select the Alarm Sounds tab.

3. Choose one of the alarms.

4. Choose the desired alarm type: PC speakers (built-in sounds in Microsoft 
Windows), WAV file or None. The None option disables alarm signalling. Click the 
OK button.
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To use WAV sound files do the following:

1. Select the WAV file sound mode option.

2. Choose the desired alarm: High, Low, etc.

3. Click the Browse button and choose a sound file (WAV) which is available on the 
hard disk to be used for the selected alarm.

4. Repeat steps 2 and 3 for all alarms that you want to associate to a WAV sound.

5. Click the OK button.
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5.6.2 Color

WinView offers the option to specify colors for bar graphs, presentation of tank data, 
manual values, different types of alarms and products in the Product Table. For more 
information on color settings, see chapter 3.5 Color Settings.

To specify colors for different types of alarms do the following:

1. From the Tools menu choose Options.

2. Select the Colors tab.

3. Choose the desired alarm from the Items list.

4. Click the Change button.

5. Choose a color from the Color palette or define a new color by clicking the Define 
Custom Colors button.

6. Click the OK button.
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5.6.3 Alarm notification

WinView can be configured to send notifications via e-mail when an alarm is activated. To 
specify alarm notification properties do the following:

1. From the Tools menu choose Options.

2. Select the Alarm Notifications tab.

This window lets you:

 select Mail Client

 create a list of e-mail recipients for alarm notifications

To add e-mail recipients and configure Alarm Notification:

1. Click the Address Book button.

2. From the left pane choose a name to be included in the list of recipients and click 
the Move button. Click the Add New button to add names which are not available 
in the address book.
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3. Repeat step 2 until all recipients you want to include appear in the right pane.

4. Click the OK button.

5. For the selected e-mail recipient, choose the alarm types to be included in the 
e-mail notification by selecting the corresponding check boxes.

6. For the selected e-mail recipient, choose one or more shifts for which the e-mail 
notification function will be activated.

Alarm types

E-mail 
recipients

Work shifts to 
be notified
80 Alarm Handling



Reference Manual 
00809-0300-5110, Rev AB

Alarm Handling
September 2016
To configure available shifts:

Note
When configuring shifts, each hour of the day must be covered. No time gap is allowed.

a. Click the Shifts button.

b. Configure start and stop times for the shifts, and also which shifts to use. Click 
Configure Weekdays to select which weekdays comprise the work week.

c. Click OK.

7. Choose Mail Client. There are two mail clients to choose from: the Microsoft MAPI 
and the Built-in mail console utility. The Microsoft MAPI does not require further 
configuration. To configure the Built-in e-mail client, see paragraph Built-in E-mail 
client configuration on page 5-82.

Note
On some systems the MAPI mail client generates a security warning dialog from the server 
when trying to send an alarm notification. On these systems, the distribution of alarm 
notifications requires user interaction and no alarm notifications will be sent if the security 
warning dialog is left unattended.

8. Click the OK button.
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Built-in E-mail client configuration

WinView has an e-mail client built in, allowing sending alarm notifications via e-mail. To 
configure the program do the following:

1. From the Tools menu choose Options.

2. Select the E-mail Configurations tab.

3. Enter the following parameters:

4. Click the OK button.

SMTP Server Specify your SMTP server for outgoing messages. You can 
get this information from your Internet service provider or 
LAN administrator.

Sender Address Address for the sending e-mail account (must be located on 
the specified SMTP server).

SMTP Port Optional.

Retries Optional.

Subject Line Mail title (only used for Alarm notification and is optional).
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Section 6 Reports

Automatic reports  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 83
Publish report  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 90

WinView provides the option to automatically print standard reports on a regular basis. The 
reports show information about the tanks and their contents.

6.1 Automatic reports

TankMaster WinView lets you specify reports to be distributed at a predefined schedule.

To set up an automatic report do the following:

1. In the WinView workspace select the Reports icon.

2. Click the right mouse button and select Add Report, or from the Tools menu 
choose Options and select the Reports tab.

Alternatively, select the Reports icon and from the Reports menu choose Add Report.
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The Report Data window lets you specify the following:

 report title

 tanks to send reports to

 how the report will be distributed (publication type): via email, printer, or stored in 
text file format.

 recurrence pattern, i.e. how often the report will be sent
84 Reports



Reference Manual 
00809-0300-5110, Rev AB

Reports
September 2016
6.1.1 Report title

Enter the desired Report Title.

6.1.2 Tanks in report

To define for which Tank/Tanks the report should be published, select the desired option in 
the Tank(s) to keep track of in Report pane.

Enter the desired Report Title

Choose for which tank the report 
should be published

Choose All Tanks to include all tanks 
in the report, or choose a specific 
tank
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6.1.3 Publication type

Reports can be printed, sent by e-mail as well as saved in text file format to be opened by 
any program which can handle text files.

Printer

To configure a report to be printed do the following:

1. In the Report Data window, select Printer from the list of available publication types 
and click the Add button.

2. Select Printer in the right pane (Selected) and click the Config button.

3. Choose the desired printer to publish reports on.

4. Click the OK button.

1. Select Printer

2. Click the Config
button
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E-mail

To configure a report to be sent by e-mail do the following:

1. Select eMail from the list of available publication types and click the Add button.

2. Select eMail in the right pane (Selected) and click the Config button:

3. Add as many recipients as you like to the Recipients list in the E-mail Configuration 
window.

Note
To configure the e-mail client, See “Built-in E-mail client configuration” on page 82.

4. Click the OK button.

You can create several e-mail distribution lists by repeating steps 1 to 4 as described above. 
The report will be sent to all the e-mail distribution lists available in the right pane of the 
Report Data window.

1. Select eMail

2. Click the Config button
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File

To save a report as a text file, do the following:

1. Select File from the list of available publication types and click the Add button.

2. Select File in the right pane (Selected) and click the Config button.

3. Type the file name and the path to the folder where the file will be stored. Select 
Add Unique Suffix to add a unique suffix to the report file name. In this example, 
the first report file will be called AllTanks_1.txt, the second report file 
AllTanks_2.txt, and so on. When the Max number of Report Files is reached, the 
oldest report file will be replaced. In this example, when AllTanks_10.txt has been 
created, the next report file will be AllTanks_1.txt, and the previously stored report 
file “AllTanks_1.txt” will be replaced.

Note
The file extension .txt is automatically added to the file name.

4. Click the OK button.

1. Select File

2. Click the Config button
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6.1.4 Recurrence pattern

Define how often the report will be automatically distributed. Select hourly, daily, weekly, 
or monthly and specify a start time and frequency. The recurrence pattern is applicable to 
all publication types.
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6.2 Publish report

In addition to automatically distributing reports according to a specified recurrence 
scheme, reports can be sent at any time by using the Publish Report option. To publish a 
report do the following:

1. In the WinView workspace select the report to be published (printed, sent by 
e-mail or saved to file).

2. Click the right mouse button and choose Publish Report, or from the Reports menu 
choose Publish Report.

The report is now published according to the specified publication type (Printer, File etc.):

Report Title

Chosen tank or 
All Tanks

Publication Type
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Section 7 Audit Log

Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 91
Viewing the Audit Log  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 92

The Audit Log function enables you to record the various actions that can be carried out by a 
TankMaster operator. Audit Log records such actions as changing the alarm limits, logging 
on/off, setting manual values for level and other parameters. Many other actions are 
recorded as well.

7.1 Setup

The Audit Log function can be enabled or disabled at any time. To activate the Audit Log 
function do the following:

1. From the Tools menu choose Options.

2. Select the Log Setup tab.

3. Activate the Audit Log function by choosing one of the two options: 

 Set size of logfile by number of records.

 Set size of logfile by number of days.

Either of these two options can be used to limit the size of the Audit Log file. When 
the file reaches its size limit, the oldest records will be removed as new records are 
stored.

4. Chose the OK button to activate the current settings.

Size of logfile by 
number of records
Size of logfile by 
number of records
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7.2 Viewing the Audit Log

To view the Audit Log:

1. Choose the Tools>View Audit Log option.

The Audit Log displays different events such as changed parameter values, changed alarm 
limits, logging on and off and many others. You can also see the time that the event was 
recorded and the operator who was logged on.

7.2.1 Filtering
The Audit Log can be filtered by date and by tank.
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Filtering by date

All dates disables filtering by date. All records regardless of date appear in the Audit Log 
window.
Choose Dates between if you want to log events within a certain period of time.

Not older than limits the log to events which are not older than the specified number of 
minutes, hours, days, weeks or months.

If no tanks are selected, the Audit Log will display events for all tanks.
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Filtering by tanks

This Filter option lets you select specific tanks to be displayed in the Audit Log window:

1. Select the desired tank in left pane (Available Tanks).

2. Click the Move  button. Selected tanks appear in the right pane (Selected 

Tanks).

3. Repeat steps 1-2 for all tanks to be viewed in the Audit Log window.

4. Click the OK button.
Response: the Audit Log displays events for the selected tanks.
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Section 8 Servo Commands

Select a servo tank in the workspace window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 95

For servo tanks, it is possible to send commands to the servo gauge, e.g. Enraf ® series 854, 
using the Servo Command window.

8.1 Select a servo tank in the workspace window

In order to make Servo Commands available in WinView, the tank must be installed as a 
Servo Tank. See WinSetup Reference manual for more information on tank installation.

To access the Servo Command window, do the following:

1. Select a Servo Tank in the Workspace window.

2. Right-click the selected Servo Tank and select Send Servo Command.
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3. The following commands are available:

Servo state will be displayed to the left of the level value in the Servo Command and the Tank 
View window.

The table below shows the different Servo commands and servo states shown in WinView 
when using CIU and Rosemount™ 2460 System Hub. The Raise, Freeze and Lower servo 
states refer to the displacer movement.

Freeze (Block) holds the displacer in the current position.

Park (Lock/Stow) raises the displacer to the top of the tank.

Measure (Unlock/Unstow) unlocks the gauge after Freeze or Park, and the displacer moves to 
the product surface.

Test raises the displacer and then returns it to the product surface.

Search for water level initiates the search for the product/water interface.

State Abbreviation

Freeze (Block) F

Park (Lock/Stow) P

Test T

Search for water level W

Servo Command Displayed servo state in Windows

CIU 2460 System Hub

Raise Freeze Lower Raise Freeze Lower

Park (Lock/Stow) P F - T P -

Freeze (Block) - F - - F -

Measure (Unlock/Unstow) - - T - - T

Test T - T T - T

Search for water level - W ? T - W
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The Level/Displacer position field turns orange when Servo Commands are activated from 
the Servo Command window:

When servo commands are active TankMaster only displays Level and Temperature values. 
Inventory calculations are disabled as long as the servo command is active.

Note
When a servo command is active, the Level value does not show the current product level. 
The level shown is the current displacer level.

In the Tank Operation window, the Level position field turns orange. All Inventory 
calculations field are disabled as long as the servo command is executed.
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4. To close the Servo Command window, press the Close button. Make sure the 
indicator next to Level and Displacer pos. is cleared, e.g. the T for Test is switched 
off.

Note
Only level and temperature are shown in TankMaster while a servo command is active. 
Inventory calculations (volume calculations) are disabled during this time.

Note
When a servo command is active and the displacer is in movement, the active device 
communication is prioritized.

OPC and ModBus

The current servo command is viewable via OPC and/or ModBus from a host computer.

To access the current servo command, use the TK.xx.LL.SS OPC tag.
98 Servo Commands



Reference Manual 
00809-0300-5110, Rev AB

Index
September 2016
Index

A
Accept Alarm  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12, 73
Access Levels  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17, 22
Acrobat Reader . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
Active alarms  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66
Add a new user . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
Add Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83
Administrator . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Alarm

Alarm Hysteresis . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Alarm Status . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
CFail. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62
Colors  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78
Communication Failure  . . . . . . . . . . . . . . . . . . . . . 62
Delay Time  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Disconnect  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74
Disconnect Tank . . . . . . . . . . . . . . . . . . . . . . . . . . . 74
Enable/Disable Leak Alarms  . . . . . . . . . . . . . . . . . . 75
Error. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Printer Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72
Save To File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71
Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76
Sound  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76
Summary. . . . . . . . . . . . . . . . . . . . . . . . . . .12, 66, 67
Viewing Active  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66

Alarm Limits  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63
Delay . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64, 65
Hysteresis  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64, 65
Leak . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

Alarm Log . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12, 68
Date. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
Filter Settings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
Save . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71

Alarm Status . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67, 69
Accepted . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

Audit Log. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 91
Filtering . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 92
Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 91
Viewing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 92

Automatic Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83
Available Room. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58
Average Temperature. . . . . . . . . . . . . . . . . . . . . . . . 29, 30
Avg Temp . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64
AVRM  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58

B
Bar Graph  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28
Bar Graph Group . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
Bargraph Group  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Built in E-mail configuration . . . . . . . . . . . . . . . . . . . . . . 82

C
Change color  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43
Change font . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41
Change password. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
Chief Administrator . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Color

Alarm  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .78
Color Highlight. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
Color Settings. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43
Common Flow Rate Thresholds . . . . . . . . . . . . . . . . . . . 35
Common Group View  . . . . . . . . . . . . . . . . . . . . . . . . . . 41
Common Group View Settings  . . . . . . . . . . . . . . . . . . . 41
Configure

Built in E-mail Client . . . . . . . . . . . . . . . . . . . . . . . . .82
Shifts. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .81
Weekdays . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .81

D
Disconnect Alarm. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74
Disconnect Tank. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74

E
Edit Group Template  . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
Edit Product . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55
E-mail

Alarm  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79, 80, 81
Report. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .87

E-mail Configuration  . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
Enable color highlight  . . . . . . . . . . . . . . . . . . . . . . . . . . 36
Enable/Disable Leak Alarms . . . . . . . . . . . . . . . . . . . . . . 75

F
Flow Rate . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33, 58
Flow Rate Indication. . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
Flow Rate Thresholds . . . . . . . . . . . . . . . . . . . . . . . . 34, 35
Free Water Level. . . . . . . . . . . . . . . . . . . . . . . . . . . . 58, 59
Free Water Volume  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58
Freeze (Block). . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
FWL. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58, 59
FWV  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58

G
Group Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . 37, 41
Group Views

Modifying . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .37

H
Hardware key . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .4
Highlight tanks in movement  . . . . . . . . . . . . . . . . . . . . 36
99
Index



Reference Manual
00809-0300-5110, Rev AB

Index
September 2016
Historical Graph
View Setup  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

Historical Table
Table Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

Hysteresis . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64, 65

I
Icons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
Illegal characters. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
Inactivity Timeout. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
Installation Procedure  . . . . . . . . . . . . . . . . . . . . . . . . . . 47
International . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
Inventory Data

Floating roof tanks  . . . . . . . . . . . . . . . . . . . . . . . . . 30
Inventory Parameters . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

Flow Chart . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58

L
Leak Alarm  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61, 63

Enable/Disable  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75
Level  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29, 30, 63
Level Rate . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29, 33, 64
Level Rate Thresholds . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
Level Status. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
Log off . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Log on . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12, 18
Log Setup  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 91
Log to File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71
Log to Printer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72

M
Mass  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30, 58
Master protocol server . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Maximum Volume  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58
Measure (Unlock/Unstow) . . . . . . . . . . . . . . . . . . . . . . . 96
Menu Bar. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Minimum Volume. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58
Modifying the Group Views  . . . . . . . . . . . . . . . . . . . . . . 37

N
Northern . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50

O
Observed Density . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
Operator . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

P
Park (Lock/Stow). . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
Password. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

Change  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
Priority

Alarm Status . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62

Product. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30, 59
Product Color Settings . . . . . . . . . . . . . . . . . . . . . . . . . . 44
Product Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55
Protection Level . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17, 23

Separate Window . . . . . . . . . . . . . . . . . . . . . . . . . . .23
Publish Report  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90
Pumpable Volume . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58

R
Raw. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
Report

Add Unique Suffix . . . . . . . . . . . . . . . . . . . . . . . . . . .88
Automatic. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .83
E-mail  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .87
File  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .88
General Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . .85
Max number of Report Files . . . . . . . . . . . . . . . . . . .88
Printer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .86
Publication Type . . . . . . . . . . . . . . . . . . . . . . . . . . . .86
Publish  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .90
Recurrence Pattern. . . . . . . . . . . . . . . . . . . . . . . . . .89

Report Title  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

S
Save

Alarm Log . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .71
Save a report  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88
Search for water level. . . . . . . . . . . . . . . . . . . . . . . . . . . 96
Security Option  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
Security Options. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
Send Servo Command . . . . . . . . . . . . . . . . . . . . . . . . . . 95
Sensor Failure. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Server Hardware Key Info. . . . . . . . . . . . . . . . . . . . . . . . . .6
Servo Commands. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95
Servo Tank . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95
Set Inactivity Timeout  . . . . . . . . . . . . . . . . . . . . . . . . . . 24
Set Password  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
Set Required Access Levels  . . . . . . . . . . . . . . . . . . . . . . 22
Shifts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
Shortcut Button . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Shortcut menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
Slave Protocol Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . .2
Software

Installation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
Modules  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

Sorting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
Sound

Alarm  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .76
Status Bar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
Status bar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
Strapping Table  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50, 53
Sub Level descriptions . . . . . . . . . . . . . . . . . . . . . . . . . . 21
Sub Levels. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Sump Volume  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58
Supervisor  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Surface movement. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
System Requirements  . . . . . . . . . . . . . . . . . . . . . . . . . . . .4
100
Index



Reference Manual 
00809-0300-5110, Rev AB

Index
September 2016
System Setup  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
System Units. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48

T
Table Setup. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
Tank Capacity Table . . . . . . . . . . . . . . . . . . . . . 49, 50, 53
Tank Entry . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
Tank Groups . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
Tank Movement . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12, 33

Color Highlight  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34

Tank Operation. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
Tank Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Tank View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12, 28
TankMaster . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1
TCT . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49, 53

International . . . . . . . . . . . . . . . . . . . . . . . . . . . 50, 51
Northern . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50, 52
Raw . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50, 52

Temperature Sensors . . . . . . . . . . . . . . . . . . . . . . . . . . . 28
Test . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Tools/Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Total Observed Volume  . . . . . . . . . . . . . . . . . . . . . . 30, 58
TOV . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30, 58
Type of product  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59

U
User Access Levels  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
User Access Sub Levels. . . . . . . . . . . . . . . . . . . . . . . . . . 17
User accounts. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
User Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Username. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

V
View Group  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12, 29
View Only . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
View Server HW Key Info . . . . . . . . . . . . . . . . . . . . . . . . . .6
View Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
Viewing Active Alarms . . . . . . . . . . . . . . . . . . . . . . . . . . 66
Viewing Tank Data

Bar Graph Group. . . . . . . . . . . . . . . . . . . . . . . . . . . .30
Single Tanks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .28

W
WinOpi . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .2
WinSetup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .2
WinView . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .2
Workspace . . . . . . . . . . . . . . . . . . . . . . . . . . .9, 10, 12, 14

Allow Docking. . . . . . . . . . . . . . . . . . . . . . . . . . . . . .10
Icons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .16
Viewing Tanks. . . . . . . . . . . . . . . . . . . . . . . . . . . . . .14
101
Index



102

Reference Manual
00809-0300-5110, Rev AB

Index
September 2016

Index





Reference Manual
00809-0300-5110, Rev AB

September 2016

Global Headquarters and Europe Regional Office

Tank Gauging
Emerson Process Management 
Box 150
(Visiting address: Layoutvägen 1)
SE-435 23 Mölnlycke

+46 31 337 00 00
+46 31 25 30 22
sales.rtg@emerson.com

North America Regional Office
Tank Gauging
Emerson Process Management 
6005 Rogerdale Road
Mail Stop NC 136
Houston TX 77072
United States

+1 281 988 4000 or +1 800 722 2865
sales.rtg.hou@emerson.com

Latin America Regional Office
Emerson Process Management 
1300 Concord Terrace, Suite 400
Sunrise, FL 33323, USA

+1 954 846 5030
+1 954 846 5121
RMTLAContactUS@emerson.com

Asia Pacific Regional Office
Emerson Process Management Asia Pacific Pte Ltd
1 Pandan Crescent
Singapore 128461

+65 6777 8211
+65 6777 0947 
Specialist-OneLevel.RMT-AP@emerson.com

Linkedin.com/company/Emerson-Process-Management

Twitter.com/Rosemount_News

Facebook.com/Rosemount
Middle East and Africa Regional Office
Tank Gauging
Emerson Process Management 
P.O Box 20048
Manama
Bahrain

+973 1722 6610
+973 1722 7771 
rtgmea.sales@emerson.com

Youtube.com/user/RosemountMeasurement

Google.com/+RosemountMeasurement

Standard Terms and Conditions of Sale can be found at: 
Emerson.com/en-us/pages/Terms-of-Use.aspx
The Emerson logo is a trademark and service mark of Emerson Electric Co.
Rosemount, and Rosemount logotype are trademarks of Emerson Process 
Management.
All other marks are the property of their respective owners.
© 2016 Emerson Process Management. All rights reserved.

https://www.linkedin.com/company/2412786?trk=vsrp_companies_res_name&trkInfo=VSRPsearchId%3A170459441442337643781%2CVSRPtargetId%3A2412786%2CVSRPcmpt%3Aprimary
https://twitter.com/Rosemount_News
https://www.facebook.com/Rosemount?_rdr=p
https://www.youtube.com/user/RosemountMeasurement/
https://plus.google.com/+RosemountMeasurement
www.Emerson.com/en-us/pages/Terms-of-Use.aspx

	Contents
	Section 1: Getting Started
	1.3.1 System Requirements 4
	1.3.2 Installed Software Modules 4
	1.3.3 Installation Procedure 5
	1.4.1 Enabled Functions 7

	Section 2: The WinView Main Window
	2.4.1 Viewing Tanks 14
	2.6.1 Logging on to TankMaster 18
	2.6.2 To administrate user accounts 19
	2.6.3 Configure Access Sub Level description 21
	2.6.4 To set required access levels 22
	2.6.5 To change protection level for separate windows 23
	2.6.6 To change password 24
	2.6.7 To change inactivity timeout 24
	2.6.8 To set program security options 25

	Section 3: Viewing Tank Data
	3.1.1 Single tanks 28
	3.1.2 Tank groups 29
	3.3.1 Level rate thresholds 34
	3.3.2 Common flow rate thresholds 35
	3.3.3 Enable color highlight 36
	3.4.1 Common group view settings 41
	3.5.1 Product color settings 44
	3.5.2 Color Settings for Tank Movement 46

	Section 4: Installing a Tank Measurement System
	4.2.1 System units 48
	4.2.2 Tank Capacity Table 49
	4.3.1 Using the International method 51
	4.3.2 Using the Northern method 52
	4.3.3 Using the Raw method 52
	4.3.4 Creating a Tank Capacity Table 53
	4.4.1 Sorting content in product table 56
	4.5.1 Tank entry 59

	Section 5: Alarm Handling
	5.1.1 Level 63
	5.1.2 Level Rate 64
	5.1.3 Average temperature 64
	5.3.1 Saving the alarm log to file 71
	5.3.2 Alarm printer settings 72
	5.5.1 Enable/Disable Leak Alarms 75
	5.6.1 Sound 76
	5.6.2 Color 78
	5.6.3 Alarm notification 79

	Section 6: Reports
	6.1.1 Report title 85
	6.1.2 Tanks in report 85
	6.1.3 Publication type 86
	6.1.4 Recurrence pattern 89

	Section 7: Audit Log
	7.2.1 Filtering 92

	Section 8: Servo Commands

	Section 1 Getting Started
	1.1 What is TankMaster?
	1.2 TankMaster Software Package
	1.3 Installing the TankMaster Software
	1.3.1 System Requirements
	1.3.2 Installed Software Modules
	1.3.3 Installation Procedure

	1.4 Hardware Key Info
	1.4.1 Enabled Functions

	1.5 Illegal characters

	Section 2 The WinView Main Window
	2.1 Menus
	2.2 Toolbar
	2.3 Status bar
	2.4 Workspace - viewing tanks and devices
	2.4.1 Viewing Tanks

	2.5 Icons
	2.6 User management
	2.6.1 Logging on to TankMaster
	2.6.2 To administrate user accounts
	2.6.3 Configure Access Sub Level description
	2.6.4 To set required access levels
	2.6.5 To change protection level for separate windows
	2.6.6 To change password
	2.6.7 To change inactivity timeout
	2.6.8 To set program security options


	Section 3 Viewing Tank Data
	3.1 Measured values
	3.1.1 Single tanks
	3.1.2 Tank groups

	3.2 Tank operation
	3.3 Tank movement
	3.3.1 Level rate thresholds
	3.3.2 Common flow rate thresholds
	3.3.3 Enable color highlight

	3.4 Modifying the group views
	3.4.1 Common group view settings

	3.5 Color Settings
	3.5.1 Product color settings
	3.5.2 Color Settings for Tank Movement


	Section 4 Installing a Tank Measurement System
	4.1 Installation procedure
	4.2 System setup
	4.2.1 System units
	4.2.2 Tank Capacity Table

	4.3 Setting up a Tank Capacity Table
	4.3.1 Using the International method
	4.3.2 Using the Northern method
	4.3.3 Using the Raw method
	4.3.4 Creating a Tank Capacity Table

	4.4 Creating a product table
	4.4.1 Sorting content in product table

	4.5 Inventory parameters
	4.5.1 Tank entry


	Section 5 Alarm Handling
	5.1 Alarm limits
	5.1.1 Level
	5.1.2 Level Rate
	5.1.3 Average temperature

	5.2 Viewing active alarms - Alarm Summary
	5.3 Alarm log
	5.3.1 Saving the alarm log to file
	5.3.2 Alarm printer settings

	5.4 To accept alarms
	5.5 Disconnecting alarms
	5.5.1 Enable/Disable Leak Alarms

	5.6 Alarm Setup
	5.6.1 Sound
	5.6.2 Color
	5.6.3 Alarm notification


	Section 6 Reports
	6.1 Automatic reports
	6.1.1 Report title
	6.1.2 Tanks in report
	6.1.3 Publication type
	6.1.4 Recurrence pattern

	6.2 Publish report

	Section 7 Audit Log
	7.1 Setup
	7.2 Viewing the Audit Log
	7.2.1 Filtering


	Section 8 Servo Commands
	8.1 Select a servo tank in the workspace window

	Index

