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Copyrights
The Motorola Solutions products described in this document may include copyrighted Motorola
Solutions computer programs. Laws in the United States and other countries preserve for Motorola
Solutions certain exclusive rights for copyrighted computer programs. Accordingly, any copyrighted
Motorola Solutions computer programs contained in the Motorola Solutions products described in this
document may not be copied or reproduced in any manner without the express written permission of
Motorola Solutions.
© 2021 Motorola Solutions, Inc. All Rights Reserved

No part of this document may be reproduced, transmitted, stored in a retrieval system, or translated
into any language or computer language, in any form or by any means, without the prior written
permission of Motorola Solutions, Inc.

Furthermore, the purchase of Motorola Solutions products shall not be deemed to grant either directly
or by implication, estoppel or otherwise, any license under the copyrights, patents or patent
applications of Motorola Solutions, except for the normal non-exclusive, royalty-free license to use that
arises by operation of law in the sale of a product.

Disclaimer
Please note that certain features, facilities, and capabilities described in this document may not be
applicable to or licensed for use on a specific system, or may be dependent upon the characteristics of
a specific mobile subscriber unit or configuration of certain parameters. Please refer to your Motorola
Solutions contact for further information.

Trademarks
MOTOROLA, MOTO, MOTOROLA SOLUTIONS, and the Stylized M Logo are trademarks or
registered trademarks of Motorola Trademark Holdings, LLC and are used under license. All other
trademarks are the property of their respective owners.

Open Source Content
This product contains Open Source software used under license. Refer to the product installation
media for full Open Source Legal Notices and Attribution content.

European Union (EU) Waste of Electrical and Electronic Equipment (WEEE)
directive

 The European Union's WEEE directive requires that products sold into EU countries must have
the crossed out trash bin label on the product (or the package in some cases).

As defined by the WEEE directive, this cross-out trash bin label means that customers and end-users
in EU countries should not dispose of electronic and electrical equipment or accessories in household
waste.

Customers or end-users in EU countries should contact their local equipment supplier representative or
service centre for information about the waste collection system in their country.
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Icon Conventions
The documentation set is designed to give the reader more visual clues. The following graphic icons
are used throughout the documentation set.

DANGER: The signal word DANGER with the associated safety icon implies information that, if
disregarded, will result in death or serious injury.

WARNING: The signal word WARNING with the associated safety icon implies information that,
if disregarded, could result in death or serious injury, or serious product damage.

CAUTION: The signal word CAUTION with the associated safety icon implies information that,
if disregarded, may result in minor or moderate injury, or serious product damage.

CAUTION: The signal word CAUTION may be used without the safety icon to state potential
damage or injury that is not related to the product.

IMPORTANT: IMPORTANT statements contain information that is crucial to the discussion at
hand, but is not CAUTION or WARNING. There is no warning level associated with the
IMPORTANT statement.

NOTICE: NOTICE contains information more important than the surrounding text, such as
exceptions or preconditions. They also refer the reader elsewhere for additional information,
remind the reader how to complete an action (when it is not part of the current procedure, for
instance), or tell the reader where something is on the screen. There is no warning level
associated with a notice.
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Chapter 1

CPS Plus Overview
Customer Programming Software (CPS) Plus provides a programming interface between a PC and
TETRA radios.

CPS Plus allows you to program radios with configuration files called codeplugs . A codeplug is a
repository of configuration data for a radio. It includes features (also the selling features ) and
adjustable parameters.

Codeplugs can be modified using CPS Plus.

CPS Plus enables you to easily manage radio software updates. A typical software package contains
platform-specific software components: firmware, codeplugs, language packs, and selling features
(licenses required). Such packages, for all available platforms, are bundled in release packets and
delivered on a disk or online. You can import release packets directly to CPS Plus and use the bundled
software to upgrade radios.

Figure 1: CPS Plus – Overview

Table 1: CPS Plus – Overview

Annotation Description

1 Motorola Solutions supplies its customers with radio software release packets and
CPS Plus.

2 CPS Plus User can modify radio codeplugs, apply audio templates, and manage
radio software upgrades.

3 CPS Plus is compatible with assorted models of Motorola Solutions TETRA radios
and can read and write radio configuration from up to 16 devices through the USB
port on a PC or a laptop.

The most common tasks using CPS Plus include:

• Reading codeplugs from radios.

• Writing codeplugs to radios.
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• Editing codeplugs.

• Upgrading radios with newer software.

• Enabling standard features.

• Enabling selling features.

1.1
Installing / Upgrading CPS Plus
Prerequisites:
• Close all programs.

• Disconnect TETRA radios from the PC.

• Reserve approximately 20 minutes for the complete installation.

Table 2: CPS Plus – System Requirements

System Component Minimal Configuration Recommended Configu-
ration

Processor Single core, 2 GHz; for program-
ming a single radio

Dual core, faster than 2
GHz; for programming
multiple radios

Physical Memory (RAM) 1 GB 2 GB DDR3 1333 MHz

USB Port Two USB 2.0/3.0 ports.

NOTICE: If you program
16 radios in parallel, you
need 16 USB ports (PCI-
USB card) for program-
ming.

-

Free hard disk space 20 GB -

Optical drive DVD-ROM drive -

Monitor display resolution 1024x768 pixels 1280x1024 pixels

Operating system Windows 8/8.1® -

Windows 8/8.1 Pro® -

Windows 8/8.1 Enterprise® -

Windows 10 Pro® -

Windows 10 Enterprise® -

When and where to use:
Depending on the software DVD that you ordered, one of two types of installation are available.

• Standalone Installation: It is used to install a fresh copy or upgrade an old version of CPS Plus.

• Release Packet: It is used to upgrade an old version of CPS Plus.

You want to install the CPS Plus application on your PC. If it is a fresh installation and the CPS Plus is
the only instance of the CPS on this machine, follow the procedure steps. If it is an additional CPS

6802974C10-BR
Chapter 1:  CPS Plus Overview

10  



instance or the legacy CPS replacement, verify the concept of migrating between the CPS versions
and using the USB Driver tool.

Procedure:
1 Insert the CPS Plus DVD in to the DVD-ROM drive.

2 Browse through the DVD contents. Double-click the relevant installation file , for example:
TetraCPSPlus32Setup.exe .

NOTICE: If the Security Window appears, allow to run the software on your machine.

3 Follow the installation wizard and accept the license agreement.

NOTICE: Do not change the default installation directories.

The installation /upgrade begins. For the Complete version, it takes approximately 15 minutes to finish
the installation.

Postrequisites:After a successful installation, you can launch the application using the desktop
shortcut. The default location for the executable file is C:\Program Files\MotorolaSolutions
\Tetra CPS Plus\Bin\ for the 32–bit version of Windows and C:\Program Files
(x86)\MotorolaSolutions\Tetra CPS Plus\Bin\ for the 64–bit version of Windows.

1.2
Starting CPS Plus
Prerequisites:CPS is installed on the computer.

When and where to use:To launch the CPS Plus application.

Procedure:
1 Double-click the TETRA CPS Plus shortcut icon on the desktop or click

Start→Programs→Motorola→TETRA CPS Plus.

NOTICE: To skip the application welcome screen when starting the application, in CPS
click Tools→User Options→Display and select the checkbox Hide Splash Window.

The application launches.

Postrequisites:Before proceeding to further operations, read more about CPS Plus functions.

1.2.1
Power Plans/Schemes
The performance of CPS may go down when your laptop is running on the battery mode and the
Windows high performance power plan (scheme) is not set.

• In Windows 8/8.1 you can change the setting by selecting High performance in the Choose or
customize a power plan section from Control Panel→All Control Panel Items→Power Options.

• In Windows 10 you can change the setting by selecting High Performance in the Choose or
customize a power plan section from Control Panel→Hardware and Sound→Power Options.

1.3
Activating CPS Plus
Perform the following steps when you want to activate your version of CPS Plus and gain access to all
the functions of the application.
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Prerequisites:
• Purchase an official entitlement from Motorola Solutions.

• Run CPS Plus.

Procedure:
1 Perform one of the following actions:

If… Then…

If you want to acti-
vate CPS Plus on-
line and the appli-
cation can connect
to the license serv-
er,

perform the following actions:

a From the License menu, select Activate CPS Application.

b In the Activate CPS window enter the Entitlement ID value and
click Activate CPS.

c Restart CPS Plus to complete the activation procedure.

If you want to acti-
vate CPS Plus off-
line using a license
file stored locally,

perform the following actions:

a From the License menu, select Activate CPS Application.

b In the Activate CPS window click Import License File.

c Navigate to the license file and click Open.

d Restart CPS Plus to verify the imported license.

NOTICE:
The license file from the network drive must not be used
to activate CPS Plus offline.

To generate an offline package from CPS for the Integra-
ted Terminal Management (iTM), ensure that the imported
Release Packet and CPS version are compatible with the
related release.

If you want to use
CPS Plus as an in-
terface to obtain a
license file for a
non-activated CPS
Plus that cannot
connect to the li-
cense server,

perform the following actions:

a In the non-activated CPS Plus, from the License menu, select
Activate CPS Application.

b In the Activate CPS window click Save License Request.
c Navigate to the chosen location, enter the file name and click

Save.

d Transfer the license request file to the PC with the CPS Plus that
can connect to the license server.

e In the CPS Plus, from the License menu, select Request Li-
cense File.

f Optional: If Tools→Options→Licensing→Automatic Licens-
ing Mode is not selected, enter the Entitlement ID value and
click Load Entitlement.

g Click Load Request File.

h Navigate to the license request file and click Open.

i Optional: If needed, load another request file – go to step g.

j Click Request License File.
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If… Then…

k Wait for the response from the server and save the license file to
a chosen folder.

l Transfer the license file to the PC with the non-activated CPS
Plus.

m Import the license file.

1.4
Using CPS Plus Online Help
When and where to use: To learn about the application and to search content.

Procedure:
1 For information about changes in radio software releases (Release Packets), click

Help→What's New in CPS Plus.

2 To open the help file, press F1 or click Help →CPS Help Index .
3 To find the content, browse the table of contents or use the Search tab.

NOTICE: To narrow your search criteria, enter the keyword in quotation marks, for
example “keyword”.

4 To navigate between the viewed pages, press LEFT/RIGHT ARROW + ALT.

5 To preview the pages from the table of contents, press UP/DOWN ARROW + ALT.

6 To increase the font size in the CHM browser click Options→Internet Options→Accessibility.
Select the check box Ignore font sizes specified on Web pages. Click OK.

1.5
Migrating Between CPS Versions
After installing the CPS Plus application, you can still retain previous versions of CPS. Legacy CPS
may be needed if you support radios running on legacy software platforms, not supported by the new
CPS Plus ( lower than MR5.9 ). The new CPS Plus supports multiple radio software versions (release
packets). Therefore you do not need to upgrade CPS Plus for every new radio software release.

Replacing Legacy CPS with CPS Plus
You have decided to replace the legacy CPS with the latest CPS Plus. It is possible only if your radios
run on the software platforms MR5.9 and higher . If not, first upgrade the radios using the legacy CPS
and then you may uninstall the legacy CPS.

Maintaining Legacy CPS and CPS Plus
You have decided to use CPS Plus for newer radios and retain your legacy CPS to use it with radios
running on legacy platforms, not supported by CPS Plus ( lower than MR5.9 ). Always install CPS
Plus as the last one, to make sure that you have installed the latest USB drivers. The legacy CPS
versions lower than R6x.575.01 (also known as lower than MR5.10 radio software) require older USB
drivers. Therefore remember to use the USB Driver Tool before connecting the legacy radios and the
other way around.

Check marks indicate in what cases, when switching between the two instances of CPS, you use the
USB Driver Tool. For example, you currently use CPS Plus but want to program older radios. The old
legacy CPS version that you have on your PC reads D6x.509.02 . It is older version than the
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R6x.575.01 , therefore use the USB Driver Tool and install old drivers. In the table, this case is under
the first row CPS Plus and the third column Legacy CPS Preceding R6x.575.01 .

Table 3: CPS Plus – The Use of USB Driver Tool for Switching Between Different CPS Versions

CPS Plus Legacy CPS Preced-
ing R6x.575.01

Legacy CPS
R6x.575.01 or Newer

CPS Plus

Legacy CPS Preced-
ing R6x.575.01

Legacy CPS
R6x.575.01 or Newer

1.6
Supported File Formats

Table 4: CPS Plus – Supported File Formats

File Exten-
sion Description Create Edit Import Export

.add Audio Device
Descriptors
file format.

.cpd Old codeplug
file format.
Use
File→Save
As to save to
the new .cpe
format.

.cpe Codeplug file
format.

.dbf Old codeplug
file format.
Use
File→Save
As to save to
the new .cpe
format.

.gif A screen sav-
er graphic file
format.

.mou TETRA key
distribution
file format.

.prl Profile file
format.

.rpk Radio soft-
ware release
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File Exten-
sion Description Create Edit Import Export

packets file
format.

.stf Single audio
template file
format.

.stfs Audio tem-
plate pack-
age file for-
mat.

.wav Audio Tones
file format.

.z19 Old radio
software file
format.

 Only
as .rpk soft-
ware release
packet files.

1.7
Motorola Solutions TETRA Radios Supported by CPS Plus
Example:

Table 5: CPS Plus – Supported Radios

Radio Type Radio Model Radio Icon in
CPS Plus

Portable MTP810Ex, MTP830, MTP830FuG, MTP830S,
MTP850, MTP850FuG, MTP850S

MTP850Ex

MTH800
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Radio Type Radio Model Radio Icon in
CPS Plus

CEP400

MTP3100, MTP3200 SIM, MTP3200FuG, MTP3500

MTP3150, MTP3250, MTP3250 SIM, MTP3250FuG,
MTP3550

MTP6450, MTP6550, MTP6650, MTP6750

MTP8500 Ex

MTP8550 Ex

MXP600
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Radio Type Radio Model Radio Icon in
CPS Plus

ST7000, ST7500

Mobile MTM800

Transceiver and Control Head for: MTM800E,
MTM5200, MTM5400, MTM800 FuG, MTM5500,
MTM800 FuG ET

Covert TCR1000

Pager AdvisorTM TPG2200

PDA MTC100
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Chapter 2

User Interface
CPS Plus content is arranged in a classic tri-pane design with the menu on top and the work-spaces
split with adjustable bars.

Figure 2: CPS Plus – Main Window

Table 6: CPS Plus – Graphical User Interface

Annotation GUI Item Description

1a Menu bar An area that groups all the menus.

1b Toolbar An area that groups icons for basic tasks.

2a Codeplug pane – Codeplug
tree

Represents a hierarchical data structure of a co-
deplug.

2b Codeplug pane – Codeplug
fields

A table with data-entry points for features and
values.

3 Radio Icons List A fly-out area that visually represents connected
radios and status of programming operations.

4 Information pane An area that provides a dialog interface between
the application and the user. It contains the fol-
lowing tabs:

• Help – displays context-sensitive topics.
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Annotation GUI Item Description

• Invalid – displays invalid parameters, for ex-
ample when the parameter you have entered
is out of range.

• Warning – displays cautionary messages.

5 Progress bar Conveys the progress of a programming task.

6 Codeplug file name tab Allows you to switch between the opened code-
plugs. Click to bring the preferred codeplug to
front.

2.1
File Menu

Table 7: CPS Plus – File Menu Items

Menu Item Description

Open Codeplug Use to open a configuration file.

Open Profile Use to open a profile.

Open OTAP Profile Use to open an Over-the-Air Programming (OTAP) profile gener-
ated from Generate OTAP Profile.

Open Codeplug with Up-
grade

Use to create a newer version of an existing codeplug and open it
in CPS Plus. You can use your already configured codeplugs with
the newer radio software, but first upgrade the device to the rele-
vant radio software version.

NOTICE: Upgraded codeplugs preserve all the user da-
ta settings.

Open Profile with Upgrade Use to create a newer profile. In order to support newer radio
software versions the profiles must be up-to-date.

NOTICE: The upgraded profile preserves all the set-
tings from the baseline profile.

Convert Model Use to convert a codeplug from one radio model to another.

Close Use to close the active codeplug.

Save Use to save changes to the active codeplug.

Save As Use to save as a new codeplug.

Read Radio Use to transfer a codeplug from a radio to CPS Plus.

Write Radio Use to transfer an active codeplug from CPS Plus to a radio.

Radio Copy Wizard Use to copy and write a subset of specified codeplug parameters
from an active codeplug to the selected radio.

Codeplug Copy Wizard Use to copy and replicate a subset of specified codeplug parame-
ters from an active codeplug to the selected codeplug.

Validate Codeplug/Profile Use to verify the codeplug for errors before copying it to a radio.
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Menu Item Description

Generate Profile Use to create a file with a subset of specified codeplug parame-
ters. This function is like Copy Wizard, but you can save the pro-
file on a disk and reuse it in the future.

Generate OTAP Profile Use to generate an OTAP profile for configuration update.

NOTICE: This profile is platform dependent and is gen-
erated according to the radio model type selected for
update.

Apply Profile to Radio Use to program configuration from a profile to the selected radio.

Apply Profile to Codeplug Use to copy values from a profile and replicate them on to an ac-
tive codeplug. This function is like Codeplug Copy Wizard.

Send MSI Service Package Use to bring out Over the Air Programming window to send crit-
ical updates through OTAP.

Send OTAP Use to bring out Over the Air Programming window to send
OTAP configuration interfaces for setting up targeted radios.

Compare Codeplug Use to examine configuration differences between two code-
plugs.

Import Use to import a file to CPS Plus.

Export Use to export a file from CPS Plus.

Change Codeplug Pass-
word

Use to protect a codeplug with a password.

Exit Use to close CPS Plus.

2.2
Edit Menu
The Edit menu contains commands used while editing codeplugs.

Table 8: CPS Plus – Edit Menu Items

Menu Item Description

Copy Use to copy text content from the selected codeplug field
so you can paste it in another location.

Paste Use to paste the text content you have copied from an-
other codeplug field.

Find Use to search an active codeplug to find a specific field.

Undo Use to reverse changes that you have done to the active
codeplug. This function does not work after you save the
changes to the codeplug.

Redo Use to remake changes done by the Undo command.
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2.3
Tools Menu

Table 9: CPS Plus – Tools Menu Items

Menu Item Description

Authenticate Radio Use to authenticate a radio protected with the Codeplug Authenti-
cation feature.

Set Radio Password Use to set a password to one or more radios. You can also set
the protection scope to Protect Radio and/or Protect Codeplug
File.

Turn Off Radio Use to turn off the radio safely.

Upgrade Radio Use to upgrade a post-MR5.9 version radio without loosing all the
user data.

Write Software Use to write a selected firmware to a radio. Verify that you per-
form this operation to the correct unit. The software version must
match the codeplug version that resides on the radio. The soft-
ware version can be found in the Codeplug →Subscriber Unit
Parameters →Application Image.

Up/Downgrade Radio Lite Upgrade Lite only allow upgrading radios that are version pre-
MR5.9 to a version that is MR 5.9 or newer. Downgrade Lite only
allows downgrading a radio to MR5.9 or newer.

NOTICE: When using the downgrade option, all the
user data is lost. Only the factory and the sensitivity da-
ta remain unchanged. It is not recommended to down-
grade codeplugs and then downgrade radios. Use the
Restore Radio option instead.

Restore Radio Use to write a previous version of software to a radio. CPS Plus
uses radio software from the release packet repository and cop-
ies of compatible codeplugs. Each time after reading a radio,
CPS Plus automatically backs up each codeplug and stores in
the directory chosen during the installation, by default:
C:\Program Files\MotorolaSolutions\Tetra CPS
Plus\BackupCodeplugs .

NOTICE: After this operation, the user data values re-
main unchanged.

Erase Memory Use to delete entire radio flash memory. That is to delete the ra-
dio software, codeplug with all settings, and security keys.

NOTICE: After this operation, the radio is no longer
functional. The radio cannot be restored using the CPS.
To restore the software and codeplug, send the radio to
the Service Center.

Display Radio CPU ID Use to collect the unique CPU HW ID that identifies your radio or
control head.
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Restore Permanent Disable
V2 Radio

Use to reactivate a disabled radio (only for PDV2). CPS Plus au-
tomatically selects the appropriate software version and uses co-
deplugs from the backup folder to restore the radio.

NOTICE: Ensure that a PDV2 feature license file is im-
ported or that the PVD2 selling feature was enabled on
the PC.

Radio Languages Settings Use to write a selected language pack to a radio.

Collect Runtime Log Use to collect mobility log and Short Data Services (SDS) or Call-
out data from the radio or pager.

Detect Radio on RS232 Port Use to detect a radio connected through the RS-232 port.

Import/Remove Audio Tem-
plate Files

By default, audio template files are included in release packets. If
you removed the default audio templates or received a set of cus-
tomized templates, use this option to import the files to the CPS
Plus repository.

Options Use to change CPS Plus general settings.

2.3.1
Options

Table 10: CPS Plus – Description of the Options

Menu Item Description

General Use to set the user interface language and to protect codeplugs with a pass-
word before saving.

Licensing Use to configure the Motorola Solutions Licensing System entitlement.
Automatic Licensing Mode – if selected, when you enable selling fea-
tures on the radio, CPS Plus automatically activates the features included
in the stored entitlements. You can add entitlements to the list (by entering
the unique entitlement IDs and clicking Add ) and remove them from it.
The list can contain maximum twenty entitlements.
Use a Customized Proxy Server to connect to Motorola Solutions Li-
cense Server – select and enter the necessary data if you do not want to
use the default proxy server. To verify the settings, click Test .

Security Protection Mode: – use to set the protection mode for the radio.

• Basic – CPS Plus uses a codeplug password encryption that is backward
compatible to the previous CPS Plus version.

• Enhanced - Manual – CPS Plus uses the new codeplug/radio protection
mechanism. You can set an individual password to the radio through
Tools→Set Radio Password

• Enhanced - Automatic – CPS Plus uses the new codeplug/radio protec-
tion mechanism. You can select one of the following options:

- Use Certification File – allows you to import certification files, remove
them or create PC-bound machine signatures that are used to generate
certification files. Each certification file contains a PC-bound machine
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signature and a password list. When using a certification file, the user
does not know the actual password stored in the file.

NOTICE: The certification file generated by a specific PC-
bound machine signature can only be imported to the CPS
Plus that generated that signature.

- Use Self-defined Passwords – allows you to add passwords to the list
or remove them from it.

• Mixed – CPS Plus allows you to choose the protection scope when you
perform a security action, such as setting or changing the password. If you
select Mixed mode and perform a security action, a password dialog pops-
up with Basic and Enhanced - Manual options.

NOTICE: Send your radio to service provider for reprogramming if
you forgot your password.

Filename Use to define a file name pattern for codeplugs that you have read from radios
and want to store on a hard drive, for example
SN[999ABC9999]_TEI[F8F9FAFBFCFDFEF]_ISSI[100]_CP[7014]_SW[Un-
known].cpe .

NOTICE: Consistent file names help you control a codeplug invento-
ry.

Display Use to control graphical elements of the interface.
Hide splash window

Do not show the splash screen while loading the application (launch faster).

Show tooltips for Codeplug fields (range for parameters)
Display a small box with range values when hovering a mouse cursor over
a codeplug field.

Minimize the icon in the system tray (conserve space on taskbar)
Minimize to an icon in the system tray (next to the system clock icon) —
conserve space on the taskbar for other applications.

Remember USB ports location in Terminal Icon List
Boxes in the Radio Icon List can remember the USB port assignments.
Therefore you can organize and keep the same array of connected radios
and manage the programming almost intuitively. For example, you connect
four radios to four separate USB ports for the first time. CPS Plus remem-
bers the port assignment and next time you connect a single radio to the
USB port 2, the radio appears in the box 2 in Radio Icon List .

Enable feedback tones (Note: this option will impact IE browser as well)
Allows you to enable or disable feedback tones (clicking sound). These
tones are played while you click on codeplug fields. When the flag is
checked, feedback tones are enabled. You may uncheck this option to
mute the feedback tones.

Enable Windows Visual Style
Allows CPS Plus to adopt Windows Visual Style. Windows XP and later op-
erating systems support a feature called Visual Styles that enables the ap-
pearance of common controls to change based on the theme chosen by
you. When the flag is checked, the CPS Plus is configured to use Windows
Visual Styles and if left unchecked, the CPS Plus uses Windows Classic
style.
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Communica-
tions

Use to toggle data compression and enable faster programming.

Directories Use to define the default locations for codeplugs.

IMPORTANT: If you decide to change the backup codeplug directo-
ry, remember to move the backup codeplug files to the new location.

Default Selling
Features

Use to define which selling features are selected by default in the Li-
cense→Enable Radio Selling Features dialog box.

Default Lan-
guage Packs

Use to define which languages appear as default radio languages in the
Tools→Languages option.

Log Use to define the default location and the format for log files.

Recovery Use to define the recovery mode. If you accidentally disconnect and turn off
the radio during programming (corrupted software, codeplug or a language
pack), this function can recover radio.

• Recovery
Detect corrupted software and start recovery automatically — after
you connect the corrupted radio, CPS Plus detects the software ver-
sion, and starts the recovery process automatically. If no suitable soft-
ware or a codeplug is stored in the default location on the hard drive,
CPS Plus switches to the manual recovery.
Detect corrupted software but let me start recovery manually — af-
ter you connect the corrupted radio, CPS Plus detects the software ver-
sion but lets you start the recovery process manually.

• Software Version Strategy
Use the latest available software – CPS Plus uses the most recent ra-
dio software and codeplug available on the hard drive (release reposito-
ry and backup folder).
Use the oldest available software – CPS Plus uses the earliest radio
software and codeplug available on the hard drive (release repository
and backup folder).

2.4
Release Packet Menu
A delivery method for release packets may vary (on a disk or online). Ask your local customer
representative for details.

Table 11: CPS Plus – Release Packet Menu Items

Menu Item Description

Import Release Packet Use to import release packets to the local CPS Plus repository.

Import Software Use to import release packets that contain specific radio soft-
ware.

Release Packet Manager Use to explore and manage (import, view, and remove content)
software files stored in the CPS Plus repository.

Reset all Release Packets Use to restore the packet repository to its default contents (pack-
ets shipped and installed with CPS Plus). CPS Plus deletes all
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the release packets imported manually after the installation and
preserves only the default packets. You can also use this option
to restore the default release packets if you accidentally removed
them from the repository. The default location of the release
packets is: c:\Program Files\MotorolaSolutions\Tetra
CPS Plus\Bin\repository_link_folder\

2.4.1
Release Packet Manager

Table 12: CPS Plus – Description of the Packet Browser Window

Window Element Description

Imported Packets Lists the release packets stored in the CPS Plus repository. To
add a new packet to the repository, click Import New Packets
and select the file. To remove a packet from the repository, select
the item from the list and click Remove Packets . CPS Plus re-
starts after each operation.

Content Manifest Lists all the components of the selected release packet. You can
only view the content but cannot add or remove the packet ele-
ments.

Import New Packets Use to import a packet or packets to the CPS Plus repository.

Remove Packets Use to remove a packet or packets from the CPS Plus repository.

2.5
License Menu

Table 13: CPS Plus – License Menu Items

Menu Item Description

Activate this CPS Applica-
tion

Use to activate the CPS Plus application online (by connecting to
the license server) or offline (by importing a license file stored lo-
cally).

Enable Radio Selling Fea-
tures

Use to enable selling features on the connected radios.

Export Radio Information
List

Use to export radio information to a file. The exported list con-
tains the TETRA Equipment Identity (TEI) number that uniquely
identifies the radio and is necessary when requesting a license
file from a non-activated CPS Plus.

Request License File Use to request license files for CPS Plus applications or radio
selling features.

NOTICE: To generate an offline package from CPS for
the Integrated Terminal Management (iTM), ensure that
the imported Release Packet and CPS version are
compatible with the related release.
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Import License File Use to import selling feature licenses from a file in an activated
CPS Plus.

2.6
View Menu
The View menu contains commands to toggle the CPS Plus panes.

Table 14: CPS Plus – View Menu

Menu Item Description

Hide Tree View Use to toggle the codeplug tree view pane.

Hide Bottom View Use to toggle the bottom information pane.

OTAP Tracking Window Use to track Over-the-Air Programming (OTAP) update sta-
tuses for sent MSI Service Packages and general radio con-
figuration updates.

Task Window Use to verify programming operations history.

2.7
Window Menu
The Window menu contains commands that allow you to arrange codeplug windows that are currently
opened on the desktop.

2.8
Help Menu
The Help menu contains commands that allow you access the online help browser and information
about the CPS Plus version. You can also report CPS Plus related issues by using the Report Issue
option.

NOTICE: To find out more about the supported radio models, go to Help→About.
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2.9
Codeplug Panes
Figure 3: CPS Plus – Codeplug Panes GUI Elements

NOTICE: The number of codeplug nodes and fields varies according to the radio model.

Table 15: CPS Plus – Codeplug Panes GUI Elements

Annotation GUI Item Description

1 Codeplug tree Represents a hierarchical data structure of all
codeplug nodes (features).

2 Codeplug fields search bar Allows you to search the active codeplug and
find a codeplug field.

3 Check boxes Select to enable codeplug features and options.

4 Selling Feature indicator The grey bar indicates that it is a selling feature.

5 Drop-down list Contains multiple values to choose from.

6 Set Default button Allows to reset the field to its default value.

7a Invalid parameter indicator Indicates that the parameter value is incorrect.

7b Indicates that some parameters in this node
have incorrect values.

8 Range tooltip Indicates a range for numerical parameters.
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9 Status bar Indicates the protection mode set for the radio.

Table 16: CPS Plus – Status Bar Protection Mode Icons List

GUI Item Description

Current protection mode set to Basic.

Current protection mode set to Enhanced - Manual.

Current protection mode set to Enhanced - Automatic.

2.10
Radio Icons List
Radio Icons List provides monitoring and operational functions to manage radios. It is a fly-out element
so it can automatically appear and hide out from the working area (useful to save space). Icons and
color codes help you to identify radios and a programming operations status. The context-menu, in
other words the right-click menu, provides access to the most frequently used functions.

Figure 4: CPS Plus – Radio Icons Panels

Table 17: CPS Plus – Radio Icons Panels

Annotation GUI Item Description

1 Programmable ra-
dios

Radios are connected to the PC and operating in the
flashing mode.
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2 Non-programmable
radios

Radios are connected to the PC but not operating in
the flashing mode.

Figure 5: CPS Plus – Radio Icons List (Programmable Radios)

Figure 6: CPS Plus – Radio Icons List (Non-Programmable Radios)

Table 18: CPS Plus – Radio Icons List

Annotation GUI Item Description

1 The radio is detected. CPS Plus initializes the connec-
tion.

Assorted radio model icons.

The radio needs a recovery.

Automatic radio recovery is in progress.

6802974C10-BR
Chapter 2:  User Interface

  29



Annotation GUI Item Description

2 The radio is connected and ready for programming.

An imported license for the radio is detected (the indi-
cator in the bottom-right corner).

The programming operation finished. The radio is
ready for programming.

The programming operation is in progress.

An operation error has occurred.

The radio is protected by the Authentication feature
(the radio authentication icon in the top-left corner).

The radio is protected but not authenticated.

The radio is charging. The battery level is visible in the
top-right corner.

3 Progress bar Conveys the progress of a programming operation.

4 Context-menu Available when the radio is ready for programming.

Table 19: CPS Plus – Radio Authentication Icons List

GUI Item Description

Protection scope set to Protect Radio and Protect Codeplug File.
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Protection scope set to Protect Radio.

Protection scope set to Protect Codeplug File.

2.11
Keyboard Shortcuts

Table 20: CPS Plus – Keyboard Shortcuts

Description Keyboard Shortcut

CPS Help F1

Open Codeplug CTRL + O

Save CTRL + S

Read Radio CTRL + R

Write Radio CTRL + W

Copy CTRL + C

Paste CTRL + V

Undo CTRL + Z

Redo CTRL + Y

Find CTRL + F

Options CTRL + K

Switch focus to the next/previous opened code-
plug

CTRL + TAB

Exit ALT + F4
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Chapter 3

Getting Started
Whether you are a new user or have used earlier versions of the application, the following topics are
designed to help you get started.

3.1
Connecting Radios to a PC
Prerequisites:
• Prepare the USB programming cable.

• For portable radios, ensure that the battery is not discharged (CPS Plus detects the required battery
level before triggering the flashing mode).

• For mobile radios, ensure that a DC power source is attached – a car battery or a DC power supply.

• Run CPS Plus.

When and where to use:Always perform the following steps before using a radio with CPS Plus.
Some of the CPS Plus options are unavailable until you attach a radio and turn it on in flashing mode.

Procedure:
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Figure 7: CPS Plus – Connecting Portable Radios
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Figure 8: CPS Plus – Connecting Mobile Radios

Table 21: CPS Plus – Radio Cables

Annotation Description Part Number Radio Model

1 Programming Cable PMKN4026_ MTH800, MTP850
series, CEP400,
MTP830, TCR1000
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Annotation Description Part Number Radio Model

2 Programming Cable PMLN5235_ MTP810 Ex,
MTP850 Ex

2a Programming Cable PMKN4129_ MTP3100,
MTP3150,
MTP3200, MTP3250

3 Programming Cable HKN6184_ MTM800E,
MTM5200,
MTM5400,
MTM5500 RECH,
MTM800 FuG,
MTM800 FuG ET
RECH

4 Programming Cable PMKN4110_ MTM5x00 Transceiv-
er, MTM800 FuG
Transceiver,
MTM800 FuG ET
Transceiver

4a Programming Cable 3071810M01 MTM800 Transceiv-
er, MTM800E Trans-
ceiver

5 Remote Mount Ca-
ble – 3 m, 5 m, 7 m,
10 m

RKN4077_

RKN4078_

RKN4079_

PMKN4020_

MTM800E,
MTM5200,
MTM5400, MTM800
FuG

6 Desktop power sup-
ply

GPN6145_ MTM800, MTM800E,
MTM5x00, MTM800
FuG, MTM800 FuG
ET

7 USB Programming
Cable

25-124330-01_ MTM5500 TSCH,
MTM800 FuG ET
TSCH

8 Tetra Mobile Ether-
net Cable

PMKN4135_ –
PMKN4141_

(length: 40 m – 3 m)

MTM5500, MTM800
FuG ET

9 Programming Cable PMKN4196_ ST7000, TPG2200

10 Programming Cable PMKN4203_ ST7500

For MTM5200, MTM5400, and MTM800 FuG it is possible to program the transceiver through
the control head cable while the devices are paired. When upgrading MTM5500 and MTM800
FuG ET, the Ethernet control heads and their transceiver should be connected to the PC USB
ports at the same time, using their respective programming cables. When only the transceiver
codeplug is to be programmed, connect the transceiver alone to the PC USB port, using its
respective programming cable. The error message displayed on the connected control heads
during the programming process may be ignored.

When three USB ports are not available, it is possible to upgrade the control heads first, and
then to upgrade the transceiver. You should not upgrade the transceiver first.
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For MTM5500, MTM800FuG, and MTM800 FuG ET languages need to be loaded in both the
control head and the transceiver. When upgrading from an earlier release, load the same
language data in both the control head and the transceiver. If the languages in the transceiver
differ from the languages in the control head (or are their subset), Software Incompatible Ver is
displayed.

MTP6x50 radios have two USB connection modes: Mass Storage and PEI. When CPS Plus
detects an MTP6x50 radio is connected to a PC in the Mass Storage mode, CPS Plus
automatically switches the radio mode to PEI. To operate an MTP6x50 radio in the Mass
Storage mode (as a mass storage device), close CPS Plus before connecting the radio to the
PC.

Before using a USB 3.0 port to program a radio, ensure that the USB 3.0 Host Controller driver
is upgraded to improve stability and prevent connection issues. The driver is usually provided by
your motherboard manufacturer – please refer to the relevant website.

3.1.1
Connecting a Radio to a PC through the RS-232 Port
Prerequisites:
• Prepare the RS-232 programming cable.

Table 22: CPS Plus – RS-232 Cables

Part Number Radio Model

PMKN4025_ CEP400, MTH800, MTP830, MTP830FuG, MTP850, MTP850 S,
MTP850FuG

PMKN4127_ MTP3100, MTP3200, MTP3150, MTP3250

PKMN4122_ MTP3100, MTP3200, MTP3150, MTP3250

• Ensure that the battery is not discharged (CPS Plus detects the required battery level before
triggering the flashing mode).

• Run CPS Plus.

When and where to use:Only when connecting a radio to CPS Plus, using an RS-232 cable. Some of
the CPS Plus options are unavailable until you attach a radio and turn it on in flashing mode.

Procedure:
1 Connect the radio to a PC using the RS-232 programming cable.

2 Click Tools→Detect Radio on RS232 Port.
3 In the Serial Port: field of the Detect RS-232 Radio window enter the RS-232 port to which the

radio is connected. Click the Detect button.

The result of detecting the radio on the defined serial port is displayed in the Detect Result:
box.

4 If the radio is successfully detected, the radio icon is displayed in the Radio Icon List of the CPS.

Postrequisites:
IMPORTANT: When radio programming is complete, turn off the radio. Right-click the radios
icon and select Turn Off Radio.
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3.1.2
Transceiver Installation Configuration through Control Head
CPS Plus is able to program MTM5500 and MTM800 FuG ET radios in a single operation through the
control head USB or GCAI connector.

CPS Plus supports Multi-Radio Control, the programming of multi-transceivers through a single control
head and cable, only from radio software version MR16 onwards.

The following installation configurations are supported.

• Single control head with a single transceiver.

• Single control head with multiple transceivers.

• Multiple control head with a single transceiver.

NOTICE: Each control head is programmed separately. Either one of the control heads can
access the transceiver but are not visible to each other.

The control head can be the Remote Ethernet Control Head (RECH) or Telephone Style Control Head
(TSCH).

3.2
Turning On Radios in the Flashing Mode – Automatically
Prerequisites:
• Connect the radio to a PC.

• Charge the radio battery to more than 15% capacity.

• Insert the radio into a charging dock or attach a charger.

• For mobile radios, ensure that the desktop power supply (12 V DC power source) is connected.

• Enable the Remote Programming feature in Codeplug→Feature Flags.

NOTICE: A portable radio can be turned on or off.

When and where to use:Before programming, each radio must be turned on in flashing mode. If you
insert a fully charged portable radio in to a charging dock, that is connected to the PC through a
programming cable, CPS Plus automatically detects the radio and turns it on in flashing mode. You do
not have to manually turn on the radio in flashing mode, which is useful if you connect and program
multiple radios. The mechanism also works with a single radio connected to CPS Plus through a
programming cable with a charger attached.

Procedure:
1 Perform the following actions:

If… Then…

If you use a portable
radio,

connect the radio to a PC using a proper USB cable.

Step result: The USB alert sound is heard. The radio display
turns red and blinks. The radio is ready for programming when
the radio icon appears in CPS Plus.

If you use a mobile ra-
dio without a control
head or MTM800,

connect the transceiver rear connector to a PC using a proper
USB cable.
Step result: The USB alert sound is heard. The radio is ready
for programming when the radio icon appears in CPS Plus.
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If… Then…

If you use MTM800E,
MTM5200, MTM5400 or
MTM800FuG with
NGCH control head,

perform the following actions:

a Connect the control head to a PC using a proper USB cable.

b If the radio is powered off, press and hold for about three
seconds the POWER key.

Step result: The USB alert sound is heard. The radio display
blinks. The radio and the control head are ready for program-
ming when proper icons appear in CPS Plus.

If you use MTM5500 or
MTM800FuG with
RECH and/or TSCH
control head(s),

perform the following actions:

a Connect each control head to a PC using a proper USB ca-
ble.

b Connect the transceiver rear connector to a PC using a prop-
er USB cable.

Step result: The USB alert sound is heard. The radio and the
control heads are ready for programming when proper icons ap-
pear in CPS Plus.

NOTICE: It takes approximately 15 seconds after the USB notification tone to auto-start
in the flashing mode.

3.3
Turning On Portable Radios in the Flashing Mode – Manually
Prerequisites:
• Turn off the radio.

• Connect the radio to a PC.

• For TCR1000, prepare a pen or a sturdy paper clip to press the Encryption Key button.

When and where to use:Always before using a radio with CPS Plus. Some of the CPS Plus options
are unavailable until you attach a radio and turn it on in flashing mode. Entering in to flashing mode
varies for different radios.

NOTICE: A radio in the flashing mode will revert to the charging mode after a time-out period of
five minutes. Follow the procedure below to set the radio back into flashing mode.

Procedure:
1 Perform the following actions:

If… Then…

If you use a portable radio with a full
numeric keypad or a mobile radio
with a control head,

press and hold the 1+9+POWER keys for about
three seconds.

If you use a portable radio with a limi-
ted keypad,

press and hold the FUN1+FUN2+POWER keys for
about three seconds.

If you use TCR1000, press and hold the POWER+ENCRYPTION keys for
about three seconds (see the picture below).
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Figure 9: Turning On TCR1000 in the Flashing Mode

NOTICE: The application can detect mobile transceivers connected through the rear
connector and automatically turn on in the flashing mode.

The USB alert sound is heard. The radio is ready for programming when the radio icon appears in CPS
Plus.

Postrequisites:To turn off the radio from the flashing mode, right-click the radio icon and select Turn
Off Radio.

3.4
Turning On Mobile Radios in the Flashing Mode – Manually
Prerequisites:
• Turn off the radio.

• Ensure that the desktop power supply (12 V DC power source) is connected.

When and where to use:Always before using a radio with CPS Plus. Some of the CPS Plus options
are unavailable until you attach a radio and turn it on in flashing mode. Entering in to flashing mode
varies for different radios.

NOTICE: A radio in the flashing mode will power off after a time-out period of 15 minutes.
Follow the procedure below to set the radio back into the flashing mode.

Procedure:
Perform the following actions:

If… Then…

If you use a mobile
radio without a con-
trol head,

connect the transceiver rear connector to a PC using a proper
USB cable.
Step result: The USB alert sound is heard. The radio is ready for
programming when the radio icon appears in CPS Plus.
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If… Then…

If you use MTM800, connect the transceiver rear connector to a PC using a proper
USB cable.
Step result: The USB alert sound is heard. The radio is ready for
programming when the radio icon appears in CPS Plus.

If you use MTM800E,
MTM5200, MTM5400
or MTM800FuG with
NGCH control head ,

perform the following actions:

a Connect the NGCH Control Head to a PC using a proper GCAI
USB cable.

b Press and hold the 1+9+POWER keys for about three seconds.

Step result: The USB alert sounds are heard. The transceiver
and the control head are ready for programming when proper
icons appear in CPS Plus.

If you use MTM5500
or MTM800FuG with
RECH and/or TSCH
control head(s),

program each component separately (first the control head, then
the transceiver).
For the control head:

a Connect the RECH/TSCH Control Head to the PC using proper
USB cable (GCAI-USB for RECH, microUSB for TSCH).

b Press and hold the 1+9+POWER keys for about three seconds.

Step result: The USB alert sound is heard. The control head is
ready for programming when its icon appears in CPS Plus.

For the transceiver:

a Connect the transceiver rear connector to a PC using a proper
USB cable.

Step result: The USB alert sound is heard. The radio is ready for
programming when the radio icon appears in CPS Plus.

Postrequisites:To turn off the radio and/or the control head from the flashing mode, right-click the
appropriate icon and select Turn Off Radio.

3.5
Opening a Codeplug
Prerequisites:You have a codeplug on a disk or connected a radio to PC and turned on in flashing
mode.

When and where to use:Always before viewing or modifying a codeplug in CPS Plus.

Procedure:
1 To open a codeplug from a disk, click File→Open Codeplug.

The file manager dialog box appears.

2 Choose a location, select the file, and click Open.

3 To read a codeplug from a radio, in the Radio Icons List, right-click the radio icon.

4 In the context menu click Read Radio.

Once the reading operation begins, do not disconnect or turn off the radio. The radio icon turns
orange and the progress bar displays the operation status. When the operation is complete, the
radio icon turns green.
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5 To read codeplugs from multiple radios, click File→Read Radio.

The Read Radio dialog box appears.

6 Select the radio or radios and click Start Operation.

Once the reading operation begins, do not disconnect or turn off the radio. The radio icon turns
orange and the progress bar displays the operation status. When the operation is complete, the
radio icon turns green.

3.6
Reading Codeplugs from Radios
Prerequisites:Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon
appears on the list. It is possible to connect multiple radios at the same time.

When and where to use:You want to view a current configuration of a connected radio or radios.

Procedure:
1 To read a codeplug from a single radio, right-click the radios icon and select Read Radio.

Once the reading operation begins, do not disconnect or turn off the radio. The radio icon turns
orange and the progress bar displays the operation status. When the operation is complete, the
radio icon turns green. A codeplug displays.

2 To read codeplugs from multiple radios, click File→Read Radio
3 In the Read Radio dialog box select the radios.

4 Click Start Operation.

Once the reading operation begins, do not disconnect or turn off the radio. The radio icon turns
orange and the progress bar displays the operation status. When the operation is complete, the
radio icon turns green. Codeplugs for each selected radio display.

NOTICE: If the radio is protected by enhanced security
(Tools→Options→Security→Protection Mode) and the Protection Scope is set to
Protect Radio, the radio is authenticated before reading a codeplug.

3.7
Reading More than Supported Number of Codeplugs
The CPS can open several codeplugs at a time depending on the size of the codeplug and free
memory.

When and where to use:You want to read more than the number of codeplugs that the CPS can
support at a time.

Procedure:
1 If you read more than the supported number of codeplugs, a pop-out window displays all the

opened codeplugs.

2 Perform one of the following options.

a To save and close codeplugs to free up memory, select the codeplugs and click Start
Operation.

The selected codeplugs are saved in the default directory. If you free up memory by closing
the other codeplugs that are already opened, you can open the codeplugs that are saved in
the default directory.
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b To cancel all pending read-codeplug operations, click Cancel.

3.8
Writing a Codeplug to a Single Radio
Prerequisites:Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon
appears on the list. It is possible to connect multiple radios at the same time.

When and where to use:You want to write a codeplug to a single radio.

IMPORTANT: Hardware calibration values are tuned individually, that means that each radio
has its unique codeplug.
For MTM5500: before connecting to CPS, connect the control head(s) to the transceiver and
power up the radio.

NOTICE: To apply the changes to multiple compatible radios, use a profile or the Copy Wizard
option with a master codeplug.

Procedure:
1 Open a codeplug from a data storage device or read it from a radio.

2 Modify the codeplug accordingly.

3 Save the codeplug.

4 To write the codeplug to the radio, click File→Write Radio.

5 Select the radio and click Start Operation.

Once the programming operation begins, do not disconnect or turn off the radio. The radio icon
turns orange and the progress bar displays the operation status. When the operation is
complete, the radio icon turns green.

NOTICE: If the radio is protected by enhanced security
(Tools→Options→Security→Protection Mode) and the Protection Scope is set to
Protect Radio, the radio is authenticated before writing a codeplug.

3.9
Writing a Master Codeplug to Multiple Radios
Prerequisites:
• Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon appears on

the list. It is possible to connect multiple radios at the same time.

• The codeplug must be compatible with the target radio or radios.

• All the programmed radios are of the exact same model.
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When and where to use:You want to apply common settings to multiple, identical radios. Instead of
writing individual codeplugs to each radio, you can prepare a single, master codeplug or a profile.
Either one allows you to replicate common settings (user data) to another radio or radios.

IMPORTANT:
Using Radio Copy Wizard or a profile you overwrite user data (adjustable parameters) on the
selected radio. Hardware calibration values (so important for each individual device) remain
unchanged.

For MTM5500: before connecting to CPS, connect the control head(s) to the transceiver and
power up the radio.

Procedure:
1 Open a codeplug from a data storage device or read it from a radio.

2 Modify the codeplug accordingly.

The modified codeplug becomes a master codeplug for multiple radios.

3 Save the master codeplug.

4 Click File→Radio Copy Wizard.

5 In the Copy Wizard — Select Groups dialog box, click Select All. Click Next>.

The Copy Wizard dialog box appears.

6 Optional: Perform the following actions:

If… Then…

If you want CPS Plus to au-
tomatically assign consecu-
tive ISSI numbers,

perform the following actions:

a Select the Auto ISSI Assignment check box.

b Enter the starting number.

Each radio must have a unique ISSI.

If you want to enable a pass-
word on the selected radio,

perform the following actions:

a Select the Enable Setting Password check box.

b Enter the chosen password and confirm it.

If the target radio is already protected by a password,
this change will not apply.

If you want to activate the
selected selling features on
each radio,

select the Enable Selling Feature check box.

7 Select the radio or radios and click Start Operation.

IMPORTANT: Once the programming operation begins, do not disconnect or turn off the
radio. The radio icon turns orange and the progress bar displays the operation status.
When the operation is complete, the radio icon turns green.

8 Optional: If you did not assign ISSI values automatically, perform the following actions:

a Go to Codeplug→Subscriber Unit Parameters→Radio ISSI.
b Enter the value.

IMPORTANT: The value needs to match the ISSI enabled on the network.
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c Write the codeplug to the radio.

NOTICE: If the radio is protected by enhanced security and the Protection Scope is set
to Protect Radio, the radio is authenticated before writing a codeplug.

3.10
Adding a First, New Radio to the System
Prerequisites:
• Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon appears on

the list. It is possible to connect multiple radios at the same time.

• This task requires a thorough knowledge about the system and network.

When and where to use:You want to configure a radio to make and receive calls on the network.

Procedure:
1 Read a codeplug from the new radio.

2 Assign ISSI. Go to Codeplug→Subscriber Unit Parameters→Radio ISSI and enter the value.

IMPORTANT: The value needs to match the ISSI enabled on the network.

3 If configured, users can preview the radio ISSI from the menu or as a home screen information,
or a welcome screen. Copy the ISSI number and paste to the following fields accordingly:

a Codeplug→Subscriber Unit Parameters→This Radio Private Number — ISSI displays
on a radio when the user navigates to Menu→My Info→My Private Num.

b Codeplug→Display Parameters→Home Mode Display→Home Mode Display Text —
ISSI displays on a radio in the idle mode.

c Codeplug→Display Parameters→Home Mode Display→Welcome Screen — ISSI
displays as a radio welcome screen; only if a screen saver is disabled.

4 Assign GSSI to talkgroups.

All Motorola Solutions radios support a folder structure for talkgroups. There can be a single
level or dual level folder structure. Before you add GSSI to talkgroups, create the folders and the
talkgroups.

a To create a folder, go to Codeplug→TalkGroups→TMO→TMO Folders List and name
each folder.

b To make the folder visible and allow users to enter talkgroups, select the Status check box.

NOTICE: To fill out multiple fields with the same value or to select multiple check
boxes in the same column, highlight the fields, right-click, and select Fill Down.

c To define the capacity of the folder, enter the value for the Number of Talkgroups in the
Range.

NOTICE: The total number of talkgroups for all folders determines the number of rows
in the Talkgroups In Folder node.

d To organize folders into a structure with subfolders nested underneath the parent folders,
from the Parent Folder, select the primary one.

e To prevent users from transmitting voice, select the Receive Only check box.

f To create a talkgroup, go to Codeplug→TalkGroups→TMO→TMO Talkgroup List, name
each talkgroup and enter the GSSI in to the ID field.
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g To set visibility properties for talkgroups, go to
Codeplug→TalkGroups→TMO→Talkgroups In Folder, click a field under the Name
column and select the talkgroup.

The following statuses are available:
Programmed

Users can see and select this talkgroup. Leave as the default status.

Not Programmed
Users cannot see nor select this talkgroup. It is also unreachable by Call Out messages.

Invisible
Users cannot see nor select this talkgroup but it is reachable by Call Out messages.

NOTICE: To quickly select a talkgroup, enter the first character of the name before
scrolling down the talkgroup list.

h Go back to Codeplug→TalkGroups→TMO→ TMO Talkgroup List and if needed, from the
Default Folder, select the primary folder for each talkgroup.

i If Announcement Talkgroups (ATG) are enabled on the network then each talkgroup can
have one ATG assigned to it. To make the talkgroup ATG, select the Announce Group
check box. You can allow users to start announcement calls. To assign to ATG, from the
Associated Announce Group drop-down list, select the value.

j Select a group priority if the network supports this feature.

5 Verify Group Cipher Key (GCK). Go to Codeplug→TalkGroups→TMO Talkgroup List→GCK
Number.
GCK allows the radio to operate on networks that have this level of security.

a To import the keys, click File→Import→GCK KAR or SDMO KAG.

b Select the appropriate files and click Import.
c For many talkgroups, more than one KAR or KAG file may be required. Make sure that you

import all files.

Once the keys are imported, the GCK Number column displays the values. If no KAGs have
been imported, it shows the default number 65536.

6 Adjust the security settings. Go to Codeplug→Security.

IMPORTANT: Consult your network provider to ensure the correct setup.

7 Set the start scan frequency and a number of frequencies to scan. Go to Codeplug→Mobility
and System Parameters→Frequency List→Frequency List1 – Frequency List4 and enter
the values.

• Frequency List1 — the radio populates this list once it has registered on a network and so
the CPS Plus cannot load frequencies.

• Frequency List2 — a list of permanent frequencies used on a network that can be used to
enable faster initial registration.

• Frequency List3 and Frequency List4 — use to force the radio to scan two sub bands. It
can speed up the first registration of a radio on a network.

• First Frequency to Scan must match the lowest frequency used on the network.

NOTICE: It is not always a round number, such as 490.00000 MHz. For example
a network that uses 12.5 kHz offsets may start at 490.0125 MHz.

• Number of Frequencies is normally set to 400.
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8 Set Country Code and Network Code of the system to register on. Go to Codeplug→Mobility
and System Parameters→Address Extension→Country Code/ Network Code and enter the
values.

9 Save the changes.

10 Write the codeplug to the radio.

NOTICE: Each radio must have unique ISSI. If you write the codeplug to multiple radios,
you can use the Radio Copy Wizard option and assign consecutive numbers of ISSI to
each device.

Postrequisites:Test the radio on the network.

3.11
Adding Another, New Radio to the System
Prerequisites:
• Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon appears on

the list. It is possible to connect multiple radios at the same time.

• You have a master codeplug that you use for existing radios or you have a properly configured
radio to read the codeplug from.

• The codeplug must be compatible with the target radio or radios.

When and where to use:You want to add another radio or radios to an existing fleet. You want the
new radio to have the same configuration as the existing devices (master codeplug).

IMPORTANT: Using Copy Wizard or a profile, overwrites the user data (adjustable
parameters) on the selected radio. Hardware calibration values (important for each individual
device) remain unchanged.

Procedure:
1 Open a codeplug from a data storage device or read it from a radio.

NOTICE: The new and the existing radios must be of the exact same model.

2 Click File→Radio Copy Wizard.

3 In the Copy Wizard — Select Groups dialog box, click Select All.
4 Click Next>.

The Copy Wizard dialog box appears.

5 Optional: Perform the following actions:

If… Then…

If you want CPS Plus to au-
tomatically assign consecu-
tive ISSI numbers,

perform the following actions:

a Select the Auto ISSI Assignment check box.

b Enter the starting number.

Each radio must have a unique ISSI.

If you want to enable a pass-
word on the selected radio,

perform the following actions:

a Select the Enable Setting Password check box.

b Enter the chosen password and confirm it.
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If… Then…

If the target radio is already protected by a password,
this change will not apply.

If you want to activate the
selected selling features on
each radio,

select the Enable Selling Feature check box.

6 Select the radio or radios and click Start Operation.

IMPORTANT: Once the programming operation begins, do not disconnect or turn off the
radio. The radio icon turns orange and the progress bar displays the operation status.
When the operation is complete, the radio icon turns green.

7 Optional: If you did not assign ISSI values automatically, perform the following actions:

a Go to Codeplug→Subscriber Unit Parameters→Radio ISSI.
b Enter the value.

IMPORTANT: The value needs to match the ISSI enabled on the network.

c Write the codeplug to the radio.

NOTICE: If the radio is protected by enhanced security and the Protection Scope is set
to Protect Radio, the radio is authenticated before writing a codeplug.

3.12
Enabling a Standard Feature on a Radio
Prerequisites:Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon
appears on the list. It is possible to connect multiple radios at the same time.

When and where to use:You want to enable a feature on a radio or radios.

Procedure:
1 Open a codeplug from a data storage device or read it from a radio.

2 Go to Codeplug→Feature Flags and select the check box for the appropriate feature.

3 To write the codeplug to a radio, click File→Write Radio or use the right-click menu from the
Radio Icons List.

IMPORTANT: Once the programming operation begins, do not disconnect or turn off the
radio. The radio icon turns orange and the progress bar displays the operation status.
When the operation is complete, the radio icon turns green.

NOTICE: To apply the changes to multiple compatible radios, use a profile or the Copy
Wizard option with a master codeplug.

3.13
Requesting a License File for Selling Features
You want to obtain a license file for relevant selling features that can be enabled on your radio(s).

Prerequisites:
• Activate the CPS Plus application by loading the necessary entitlement or importing the relevant

license file.

• Go to License→Export Radio Information List and export radio information to a file.
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• To generate an offline package from CPS for the Integrated Terminal Management (iTM), ensure
that the imported Release Packet and CPS version are compatible with the related release.

Procedure:
1 Click License→Request License File.

The Request Radio Selling Features License File dialog box appears.

2 Optional: If Tools→Options→Licensing→Automatic Licensing Mode is not selected, enter
the Entitlement ID value and click Load Entitlement.

3 Click Load Radios.

4 Navigate to the radio information file and click Open.

5 Select the radio(s).

6 From the Feature list, select the items.

7 Click Request License File.

8 Wait for the response from the server and save the selling features license file to a chosen
folder.

3.14
Enabling a Selling Feature on a Radio
Prerequisites:
• Ensure that you loaded the necessary entitlement or imported the relevant license file(s).

• Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon appears on
the list. It is possible to connect multiple radios at the same time.

• Close all codeplugs.

When and where to use:You want to update the configuration of the radios and add selling features,
for example the WAP feature. Licenses for the paid features are stored in files that need to be
downloaded from the license server. The availability of features depends on the radio model and the
software version.

Procedure:
1 Click License→Enable Radio Selling Features.

The Enable Feature dialog box appears with all the connected radios listed.

2 From the Feature list, select the items.

3 Select the radio or radios and click Start Operation.

IMPORTANT: Once the programming operation begins, do not disconnect or turn off the
radio. The radio icon turns orange and the progress bar displays the operation status.
When the operation is complete, the radio icon turns green.

4 To verify that the proper features are enabled on the radio, read the codeplug from the radio and
go to Codeplug→Feature Flags.

5 Select the check box for the required feature.

6 To write the codeplug to a radio, click File→Write Radio.

You have added and enabled the selling feature to the radio.
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3.15
Modifying a Codeplug Using an XML File
Prerequisites:
• Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon appears on

the list. It is possible to connect multiple radios at the same time.

• You have MS Excel 2003® or higher or other XML editor.

When and where to use:You want to modify radio configurations using an external XML file. It is
especially useful when you want to change and apply the same configuration to multiple radios of the
same type by creating a template (a master codeplug). For example, in a special event you want to
configure a fleet of radios with the same operational talkgroups. An XML file can be prepared outside
CPS Plus (use MS Excel 2003® or higher), then imported and applied to a master codeplug.

Procedure:
1 Open a codeplug from a data storage device or read it from a radio.

2 To export an XML file from CPS Plus: click File→Export→User Data
3 In the Feature List dialog box, select user data and click OK.

The file manager dialog box appears.

4 Choose a location, enter the file name and click Save.

After a confirmation message appears, you can switch from CPS Plus to an external XML editor
to modify user data values.

5 To modify the XML file: launch the XML editor, open the XML file that you exported from CPS
Plus, modify the values, and save the file as the XML format.

You have modified the XML file. You can switch to CPS Plus and import the User Data file.

6 In CPS Plus, verify that the codeplug you want to modify using the XML file is opened.

7 Clear the unique list before importing user data.

8 To import the XML file to CPS Plus, click File→Import→User Data.

The file manager dialog box appears.

9 Choose a location, select the file, and click Open.

The importing operation begins. Wait until a confirmation message appears.

10 Save the codeplug.

You modified the codeplug using data from the XML file. You can use the modified codeplug as a
master codeplug.

NOTICE: To apply the changes to multiple compatible radios, use a profile or the Copy Wizard
option with a master codeplug.

3.16
Upgrading a Radio
Prerequisites:
• Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon appears on

the list. It is possible to connect multiple radios at the same time.

• Obtain the proper software release pack. See Importing Release Packets to CPS Plus on page 54.
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• If you are upgrading a mobile radio version along with languages, enable the desired languages for
the transceiver in the codeplug. See Adding Languages to Radios on page 61.

When and where to use:You want to load newer software to a radio.

NOTICE:
Due to USB limitations, you can upgrade up to 16 radios at the same time.

When upgrading MTM5x00, MTM800FuG, and MTM800FuG ET radios to MR10.6.9, remember
to load and align the languages of the control head and the transceiver.

To upgrade the radio from any pre-MR10.6.3 release to the MR10.6.9 release (or future
releases), first you need to upgrade the radio to the 10.6.3c release, then restart it, and finally
upgrade it to the MR10.6.9 release.

It is impossible to downgrade an MTP3xx0 radio from the MR10.7 release to the MR10.5/
MR10.5.1 release.

IMPORTANT: Before upgrading MTP3xx0 radios from the MR10.5/MR10.5.1 release to the
MR10.7 release, ensure that the radio battery level is no less than 50%.

Procedure:
1 Click one of the following:

• Tools→Upgrade Radio
• To roll back a radio to its previous version without losing user data, use the Restore

Radio function

• To upgrade a radio between MR5.6 and MR5.9 or post-MR5.9 version, use the Up/
Downgrade Radio Lite function.

• Tools→Up/Downgrade Radio Lite
• Upgrade Lite only upgrades radios that are version pre-MR5.9 to a version that is MR5.9

or newer.

NOTICE: The following radios are supported by Upgrade Lite:

• MTP850

• MTH800

• MTM800

• MTM800E

• NGCH

• Downgrade Lite only downgrades a radio to a version that is MR5.9 or newer.

NOTICE: This removes all the user data and only keeps the selling feature, factory
and sensitivity data after up/downgrade. If you want to keep the user data during the
upgrade, use the Upgrade Radio function instead.

2 From the Up/Downgrade to drop-down list, select the software version.

IMPORTANT: When upgrading the radio to the MR10.6.3c release, select the
R14xxx8288 software version for the control head. Make sure the Keep Control Head
and Transceiver consistent option is enabled.

3 From the Languages drop-down list, select the language(s) that are to be used on the radio.

IMPORTANT: For mobile radios, select matching languages for both transceiver and
control head.
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4 Select the radio or radios and click Start Operation.

IMPORTANT: After upgrading the radio to the MR10.6.3c release, restart the radio
before starting the upgrade to the MR10.6.9 release.

Once the programming operation begins, do not disconnect or turn off the radio. The radio icon
turns orange and the progress bar displays the operation status. When the operation is
complete, the radio icon turns green.

Postrequisites:To verify that the operation is successful and to find logs from other operations, go to
Window→Task Window.

3.17
Changing a Radio Screen Saver
Prerequisites:
• Prepare a GIF image (maximum 256 colors) on a disk (an animated GIF file is also supported for

all platforms except MTP850S, MTP850FuG, MTP830S, MTP830FuG and CEP400).

• Resize the image if needed – the recommended dimensions are 130x130 pixels for portable
radios, 640x480 pixels for mobile control heads, and 240x320 pixels for TSCH (Telephone Style
Control Head).

• Ensure that the graphic file size does not exceed 18 kB for portable radios and 40 kB for mobile
radios.

NOTICE: It applies only to radios with a color display.

When and where to use:You want to replace a default radio screen saver image with a custom
picture, for example the department logo. The screen saver image is a decorative, background element
for the radio display (it does not save the screen or a battery).

NOTICE: To apply the changes to multiple compatible radios, use a profile or the Copy Wizard
option with a master codeplug.

Procedure:
1 Open a codeplug from a data storage device or read it from a radio.

2 To import the image to CPS Plus, click File→Import→Screen Saver.
3 In the Import Screen Saver dialog box, click Load.

The file manager dialog box appears.

4 Choose a location, select the file, and click Open.

The Import Screen Saver dialog box appears. You can preview the selected image.

5 Click Import.
The Operation completed successfully message appears.

NOTICE: For MTM5x00, MTM800FuG, and MTM800FuG ET, the screen saver is
imported to the control head codeplug, not the transceiver codeplug. For MTM800FuG, if
Codeplug→Control Head Configurations→Control Head Settings→Control Head
Type is set to Handset, the screen saver is imported to the transceiver codeplug.

6 To adjust the screen saver parameters, go to Codeplug→Display Parameters→Screen Saver
and modify accordingly.
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7 To verify that the screen saver option is available from the radio menu, go to
Codeplug→Display Parameters→Menu Configuration→Setup→Display→Screen Saver.

Postrequisites:Write the codeplug to the radio.

NOTICE: You can assign One-Touch Button to this function.

6802974C10-BR
Chapter 3:  Getting Started

52  



Chapter 4

CPS Plus Operations
The following topics are designed to help you perform specific tasks using the CPS Plus application.

4.1
Using the USB Driver Tool
Prerequisites:
• CPS is installed on the computer.

• You know your CPS version.

• You understand the concept of switching between the new and old USB drivers.

When and where to use:After installing the CPS Plus application, you can still retain previous
versions of CPS. Legacy CPS may be needed if you support radios running on legacy software
platforms, not supported by the new CPS Plus (lower than MR5.9). The USB Driver Tool ensures that
you always install the proper USB drivers for relevant CPS. If you want to use the legacy CPS
(versions older than R6x.575.01) with old radios (MR5.9 and older), use Install Old Driver. Each time
when you install the drivers, you overwrite the existing USB drivers (newer or older). Therefore, to
program radios using CPS Plus after using the legacy, old CPS and radios, use Install New Driver.
CPS Plus always works with the new USB drivers.

Procedure:
1 Click Start→Programs→Motorola→USB Driver Tool.
2 In the CPS Driver Tool window, click Install Old Driver or Install New Driver to install the

relevant driver.

NOTICE: If the Software Installation window appears, click Continue Anyway.

The installation begins. Wait until the following message appears: Installation finished!
Press any key to continue....

4.1.1
Radio Software Release Versions Matrix
CPS Plus supports radio software from MR5.9 onwards. For older radio software, use the legacy CPS.

Table 23: CPS Plus – Samples of Radio Software Versions

Radio Model MR5.9 MR5.10 MR5.11 MR5.12

MTP850,
800MHz

R10.xxx.6511 R10.xxx.6911 R10.xxx.7108 R10.xxx.7412

MTM800E Con-
trol Head/ Trans-
ceiver

R14.xxx.6511/
R17.xxx.6511

R14.xxx.6911/
R17.xxx.6911

R14.xxx.7108/
R17.xxx.7108

R14.xxx.7412/
R17.xxx.7412
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4.2
Importing Release Packets to CPS Plus
Prerequisites:You have the release packet on the disk.

When and where to use:You have received new release packets and you want to use CPS Plus to
upgrade radios. Also, when you had your CPS Plus repository folder removed from the disk (for
example after a disk failure).

Procedure:
1 Click Release Packet→Import Release Packet.
2 In the Open window, select the release packet file and click Open.

NOTICE: To select multiple files, press and hold the CTRL key. To select a block of files,
press and hold the SHIFT key.

Importing begins. It takes approximately 20 seconds to import a single packet.

3 After the operation is complete, click OK.

CPS Plus restarts.

CPS Plus stores the packet in the default repository folder. The content of the packet (software files,
codeplugs, audio profiles and audio device descriptors) is ready to use with your radios.

4.3
Converting Codeplug/Profile Radio Model
Prerequisites:
• Ensure that the release packet supporting the target radio model is imported into the CPS.

• The source codeplug or profile is opened in the CPS.

When and where to use: Use to convert a codeplug or profile for use with other radios.

Procedure:
1 Click File→Convert Model.
2 In the Convert Model window, select the target radio models that you want to convert the

codeplug or profile to.

3 In the Target Version column, select the target version the codeplug or profile will be converted
to.

4 Click Convert and allow the operation to finish.

The new converted codeplug or profile window appears.

Postrequisites:After converting the codeplug or profile for a radio it is necessary to save the results
for each new window.

4.4
Copying Configuration Between Codeplugs and Radios
Prerequisites:
• The codeplug parameters must be valid.

• The codeplug must be compatible with the target codeplug or codeplugs.

• The codeplug must be compatible with the target radio or radios.
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When and where to use:You want to copy parameter values from one codeplug to other codeplug or
codeplugs, or directly to other radio or radios. CPS Plus provides multiple ways to replicate
configuration between codeplugs or radios.

1 You can copy configuration (whole nodes) between two codeplugs, for example all values for the
Security node from a codeplug A to a codeplug B.

2 You can copy configuration (entire or only selected user data) from a master codeplug to other
codeplugs or radios using the Codeplug Copy Wizard and Copy Wizard options.

3 You can create a profile with a subset of specified codeplug parameters. You can store the profiles
on the disk and apply to codeplugs or radios anytime (the Copy Wizard is a real-time option) or
even share with other CPS Plus users.

NOTICE: If you copy Subscriber Unit Parameters to multiple radios, verify that each radio has
a unique ISSI.

IMPORTANT: Using Copy Wizard or a profile, overwrites the user data (adjustable
parameters) on the selected radio. Hardware calibration values (important for each individual
device) remain unchanged.

Procedure:
1 To copy parameters between a codeplug A and a codeplug B follow the substeps:

a Open the two codeplugs or read the codeplugs from radios.

b To fit the two codeplugs on the screen, click Window→Tile Vertical.
c Click the relevant node in the codeplug A to select it.

d Drag the node from the codeplug A to the corresponding node in the codeplug B.

Figure 10: CPS Plus – Drag-and-Drop Operation Between Codeplugs

You have copied parameter values from the selected node in the codeplug A to the same
node in the codeplug B.
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e Save changes in the codeplug B.

NOTICE: When you attempt to copy audio settings between non-compatible radios
(For example, between MTP850FuG and MTP850Ex), CPS copies only those fields
that have identical paths. The remaining fields in the target codeplug are left
unchanged. CPS does not indicate which fields have been copied.

2 To copy parameters from a master codeplug to other codeplugs using the Codeplug Copy
Wizard, follow the substeps:

a Open the master codeplug from a disk or read it from the radio.

b Click File→Codeplug Copy Wizard.

The Codeplug Copy Wizard — Select Group dialog box appears.

c Select a group or groups with user data parameters and click Next.
NOTICE: Lower-level user data is selected automatically.

Step example:You want to copy over all Ergonomic Parameters. When you select the
Ergonomic Parameters checkbox in the Codeplug Copy Wizard – Select Group window,
all user data of lower level (Keypad, Tones, Dialing Methods, and so forth.) is selected
automatically.
The Select the Target Codeplug Files dialog box appears.

d Select a codeplug or codeplugs and click Open.

The Target Codeplugs dialog box appears. The compatible codeplugs are selected.

e Click Copy.

The operation begins. Wait until it is completed. CPS Plus copies the parameters and saves
changes to the updated codeplugs.

f To change ISSI, open the codeplug, go to Codeplug→Subscriber Unit
Parameters→Radio ISSI and enter the value.

3 To copy parameters from a master codeplug to radios using the Copy Wizard, follow the
substeps:

a Open the master codeplug from a disk or read it from the radio.

b Click File→Copy Wizard
The Copy Wizard — Select Group dialog box appears.

c Select a group or groups with user data parameters and click Next.
NOTICE: Lower-level user data is selected automatically.

Step example:You want to copy over all Ergonomic Parameters. When you select the
Ergonomic Parameters checkbox in the Copy Wizard – Select Group window, all user
data of lower level (Keypad, Tones, Dialing Methods, and so forth.) is selected
automatically.
The Copy Wizard dialog box appears.

d Select the radio or radios and click Start Operation.

Auto ISSI Assignment
To make CPS Plus automatically assign consecutive ISSI numbers (each radio must have a unique
ISSI), select the check box and enter the starting number. Otherwise, after applying the master
codeplug to the radios, you must manually assign ISSI to each device.
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Enable Selling Feature
To activate the selected selling features on each radio, plug in the selling feature dongle and select
the check box.

Once the programming operation begins, do not disconnect or turn off the radio. The radio
icon turns orange and the progress bar displays the operation status. When the operation is
complete, the radio icon turns green.

4.5
Comparing Codeplugs
When and where to use:You want to examine differences in configuration between two codeplugs
and copy the values between the codeplugs.

Procedure:
1 Open the two required codeplugs.

2 Click File→ Compare Codeplug.

3 In the Select Document window, select the check boxes and click OK.

NOTICE:
If the OK button is inactive it means that the codeplugs are not compatible. Verify the
version and the model and open the correct file.

Select the Bypass the User Defined Language comparison checkbox to bypass the
comparison of the User Defined Language Nodes of the two codeplugs.

The Compare Codeplug window with listed differences appears.

4 To filter the codeplug tree and display only the different nodes, click Diff Features.

The codeplug tree shows only the different nodes but all the fields within these nodes.

5 To filter the codeplug tree and display only the different nodes and the particular different fields
within these nodes, click Diff Fields.

The codeplug tree shows only the differing nodes and the differing fields within these nodes.

NOTICE: Click Report to save the comparison results to a *.txt file.

6 (Optional) To copy a value from one codeplug to another, highlight the appropriate codeplug
path in the Compare Codeplug window.

7 (Optional) From the Compare Codeplug window toolbar press <- or -> depending on which
value you want to copy.

The changed codeplug value becomes highlighted.

8 Close the window and chose the codeplug(s) to save. Press Save.

4.6
Validate Codeplug/File
Prerequisites:
• The codeplug or profile is opened in the CPS.
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When and where to use: Use to verify if there are any invalid fields in the codeplug or profile before
copying them to the radio.

Procedure:
1 Select the desired codeplug or profile you would like to verify.

2 Click File→Validate Codeplug/File

• If passed a message box saying Valid profile/codeplug. It`s applicable to
be copied to other radio. is displayed.

• If failed the Potential Invalid Fields window is displayed. Double-click on each filed
displayed in the window and correct the values.

4.7
Upgrading a Codeplug
When and where to use:You have received a new release packet. You can use the new codeplugs
(modify if needed) or upgrade your older, already configured codeplugs, and add the latest radio
features and parameters. After this operation, the user data values in your old codeplug remain
unchanged and only the newly added parameters are set to defaults.

Procedure:
1 Click File→Open Codeplug with Up/Downgrade.

2 Select the file and click Open.

NOTICE: You can select multiple files.

3 From the Target Version drop-down list in the Up/Downgrade Codeplug window, select the
software version.

4 Click Start Operation.

After the upgrade is complete, the individual codeplugs open.

5 Save the upgraded codeplug.

Postrequisites:If needed, configure the new parameters.

4.8
Profile-Based Configuration Modification
Profile is a subset of specified parameters. Unlike codeplugs, profiles contain only selected nodes and
fields. Profiles are smaller than codeplugs; therefore programming time for a single profile is much
shorter than for an entire codeplug.
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Figure 11: CPS Plus – Using Profiles
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Examples for Using Profiles
1 You have a codeplug with default values. You want to have it configured according to operational

requirements. You want to delegate the configuration to engineers with specific knowledge domains
for example GPS experts, audio experts, and so on. You create separate profiles with specific
nodes and send them to the engineers.

2 You received an announcement about an upcoming event and as a result the radios must be
reconfigured for a weekend. It turned out that only Audio Settings must be temporarily tuned up.
You generate two profiles with Audio Settings. The first profile contains current settings. The second
profile is modified according to the new requirements for the weekend event. You program your
radios for the event. After the weekend, you revert the changes using the profile with the original
audio values.

3 You want to make a minor change to the codeplug and replicate the changed configuration among
multiple radios. Creating a profile and writing it to multiple radios is efficient especially when your
change involves a single or a few related fields, for example enabling/disabling features.

4.8.1
Creating a Profile
When and where to use:You want to create a configuration file with a subset of specified parameters
from a codeplug. You can use profiles with codeplugs or radios. Profiles are smaller than codeplugs;
therefore programming time for a single profile is much shorter than for an entire codeplug.

Procedure:
1 Open a codeplug from a data storage device or read it from a radio.

2 To create a profile, click File→Generate Profile.

The Generate Profile — Select Groups dialog box appears.
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3 Select a group or groups with user data parameters and click Next.
NOTICE: Lower-level user data is selected automatically.

The file manager dialog box appears.

4 Choose a location, enter the file name and click Save.

Postrequisites:To modify the profile, click File→Open Profile and adjust the parameters accordingly.

4.8.2
Applying Profiles to Codeplugs
Prerequisites:
• The codeplug is opened and active.

• The profile and the codeplug are for the same radio model type.

• The profile version is not higher than the codeplug version.

When and where to use:To replicate configuration from a profile to a codeplug.

Figure 12: CPS Plus – Applying Profiles to Codeplugs
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Procedure:
1 Click File→Apply Profile to Codeplug.

2 In the Open window, select the profile and click Open.

Configuration from the opened profile is applied to the codeplug.

4.8.3
Applying Profiles to Radios
Prerequisites:
• Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon appears on

the list. It is possible to connect multiple radios at the same time.

• You have the profile file on the disk.

• The profile is appropriate for the radio model type.

• The profile version is not higher than the radio version.

When and where to use:To replicate configuration from a profile to a radio.
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Figure 13: CPS Plus – Applying Profiles to Radios
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Procedure:
1 Click File→Apply Profile to Radio.

The file manager dialog box appears.

2 Select the required profile and click Open.

The Apply Profile to Radio dialog box appears.

3 Select the radio or radios and click Start Operation.

Once the programming operation begins, do not disconnect or turn off the radio. The radio icon
turns orange and the progress bar displays the operation status. When the operation is
complete, the radio icon turns green.

4.9
Adding Languages to Radios
Prerequisites:
• Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon appears on

the list. It is possible to connect multiple radios at the same time.

• The radio software supports the chosen language.

• The radio software ships with default language, it is highly recommended to add local language to
the first codeplug.

When and where to use: You want to localize the radio settings. In other words, after programming
multiple language packs to the radio, the radio user can choose a preferred language from the radio
menu.

Procedure:
1 Click Tools→Radio Languages Settings.

The Languages dialog box appears.

2 From the drop-down list, select a language.

NOTICE: To define a default language pack (always selected languages), click
Tools→User Options →Default Language Packs , then select the default language
packs and click OK.
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3 Select the radio or radios and click Start Operation.

Once the programming operation begins, do not disconnect or turn off the radio. The radio icon
turns orange and the progress bar displays the operation status. When the operation is
complete, the radio icon turns green.

4 To activate a specific language on a radio, open or read the codeplug from the radio.

5 Go to Codeplug →Language Parameters →Language Settings.

6 Select a language.

7 Select the radio or radios and click Start Operation.

Once the programming operation begins, do not disconnect or turn off the radio. The radio icon
turns orange and the progress bar displays the operation status. When the operation is
complete, the radio icon turns green.

Postrequisites:Radio users can select a local language using the language menu on the radio.

4.10
Importing Audio Templates to CPS Plus
Prerequisites:
• Close all codeplugs.

• You have an audio template file (*.stf) or an audio template package (*.sfts).

When and where to use:Default audio template files are included in release packets. In some cases,
engineers can provide you with separate, customized templates. You can import them to the CPS Plus
repository and use for radio audio profiles.
You cannot create audio templates using CPS Plus.

Procedure:
1 Click Tools→Import/Remove Audio Template Files.

The Import/Remove Audio Template Files window appears.

2 To import a new audio file or an audio package, click Import.
3 To replace an existing audio template, select the file and click Remove. Import the new file

afterwards.

4.11
Applying Audio Templates to Radios
Prerequisites:
• The radio must support audio profiles.

• You imported audio templates to CPS Plus.

When and where to use:There are many situations where the demand of audio quality changes
according to the working environment. For example, an airport worker, who works partly in a noisy
outdoor field and partly inside the relatively quiet airport lobby requires different audio settings for those
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two environments. Having different audio profiles programmed on the radio, the radio user can switch
between conditions-specific audio settings when needed.

NOTICE: There is a clear distinction between an audio template and an audio profile. Motorola
Solutions engineers provide audio templates (for example Outdoor, Indoor, Street Use,
General) with a range of default values which customers can adjust. The customer can apply
the audio template to audio profiles (for example Outdoor for User Profile 1, Indoor for User
Profile 1) and program them to radios.

Procedure:
1 Open a codeplug from a data storage device or read it from a radio.

2 Go to Codeplug→Audio Settings→User Profile 1 – User Profile 10→Select Template.

3 From the drop-down menu, select the template for this User Profile.

4 Repeat the task for other user profiles, if needed.

5 Save the codeplug.

6 Write the codeplug to the radio.

The radio user can select an audio profile from the radio menu.

Postrequisites:
NOTICE: You can assign One-Touch Button to this function.

4.12
Importing Audio Tones to the Codeplug
Prerequisites:
• Only the AdvisorTM TPG2200 Pager supports this feature.

• You have an audio tones file (*.wav) that is sampled with 8000 Hz, quantized with 16 bits, and
normalized to the full dynamic range smaller than 100 KB.

When and where to use:You can import and store your own audio tones to the codeplug and pager.
These tones can be selected as indication tones.

Procedure:
1 Open the codeplug from a data storage device or read it from the pager.

2 Go to Codeplug→Ergonomic Parameters→User Tones.

3 At User Tone 1, click Import.
4 Choose a location, select the file, and click Open.

5 Repeat the task for other user tones, if needed.

6 Save the codeplug.

7 To apply the audio tones to the pager, write the codeplug to the pager.

4.13
Removing Audio Tones from the Codeplug
Prerequisites:Audio Tones are already stored in the codeplug. You can see the name of the audio
tones at Codeplug→Ergonomic Parameters→User Tones→User Tone Alias.
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Procedure:
1 Open the codeplug from a data storage device or read it from the pager.

2 Go to Codeplug→Ergonomic Parameters→User Tones.

3 At the selected user tone, click Remove.

The User Tone Alias becomes blank to indicate that the audio tones file is removed from the
codeplug.

4 Repeat the task for other user tones, if needed.

5 Save the codeplug.

6 To remove the audio tones from the pager, write the codeplug to the pager.

4.14
Importing Audio Device Descriptors to CPS Plus
Import Audio Device Descriptors (ADDs) to ensure acceptable audio performance for every accessory
connected to next generation Motorola Solutions mobile and portable radio models (MTM800FuG,
MTM5xx0, MTP3xx0, MTP6xx0).

An ADD is a file containing relevant audio parameters required for a proper RX/TX configuration of a
particular audio accessory. One ADD defines only one audio accessory, so the number of ADDs
corresponds to the number of supported accessories.

ADDs are listed in the order they are imported. You can change the default order by removing all ADDs
and importing them again in the preferred order. It is recommended to remove unused ADDs (see 
Removing Audio Device Descriptors from CPS Plus).

You cannot create an ADD using CPS Plus.

NOTICE: If you are unable to find the Accessory List node, your radio model does not support
ADD files. All information about the accessories hardware is included in the audio templates
and you can skip this procedure.

IMPORTANT: The Car Kit will not work unless relevant ADD files for the related accessories
are imported.

Prerequisites:
• Your accessory is not listed in the following codeplug table: Codeplug→Buttons, Keys and

Accessories→Accessory List
• You have an Audio Device Descriptors (*.add) file. These files are provided separately by Motorola

Solutions.

Procedure:
1 Open a codeplug from a data storage device or read it from a radio.

2 To import the ADD file, go to Codeplug→Buttons, Keys and Accessories→ADD Import /
Remove.

3 Click Import.
The file manager dialog box appears.

4 Choose a location, select the file, and click Open.

The codeplug stores information about the accessories specified in the *.add file. After programming,
the radio supports the listed accessories.
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4.15
Removing Audio Device Descriptors from CPS Plus
Prerequisites:Audio Device Descriptors are already stored by CPS and you can see a list of
supported accessories in the following codeplug table:Codeplug→Buttons, Keys and
Accessories→Accessory List.

When and where to use:Some radio models (MTP3xx0, MTP6xx0) use Audio Device Descriptors for
compatible IMPRES accessories (with an ADS chip). In such cases, a separate ADD file holds
information about the hardware and a separate audio template provides audio settings for the
accessory. You can import an ADD file and store the relevant data in the CPS repository. That means
that you can have your own, custom audio values for the attached accessory, different than those
stored by the ADS chip itself. You cannot create an ADD file using CPS Plus.

NOTICE: If you are unable to find the Accessory List node, that means that your radio model
does not support ADD files. All information about accessories hardware is in audio templates.
You can skip this procedure.

Procedure:
1 Open a codeplug from a data storage device or read it from a radio.

2 To remove an accessory from the codeplug, go to Codeplug→Buttons, Keys and
Accessories→ADD Import / Remove.

3 Click Remove.

The Remove Accessory dialog box appears.

4 Select the accessory and click OK.

5 To save the codeplug, go to File→Save as.

A dialog box appears.

6 Choose the location and a proper file name, and click Save.

CPS stores on the disk and updates the codeplug with the information about the imported
hardware.

The codeplug no longer stores information about the removed hardware. After programming, the radio
no longer supports the removed accessory.

4.16
Restoring a Radio
Prerequisites:
• You have a relevant software release packet on a disk.

NOTICE: After you import a release packet using the Import Release Packet option, CPS
Plus stores all the software components in the following directory:c:\Program Files
\MotorolaSolutions\Tetra CPS Plus\Bin\repository_link_folder\.

• You have copies of the relevant codeplugs in the backup folder.

NOTICE: Each time after reading a radio, CPS Plus automatically backs up each codeplug
and stores in the following directory: c:\Program Files\MotorolaSolutions\Tetra
CPS Plus\BackupCodeplugs\.
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When and where to use:You want to downgrade a radio. In other words, you want to write a previous
version of software to the radio. For example, you wrote a newer beta software to the radio for testing
purposes and afterwards, decided to revert the radio to its previous configuration.

NOTICE: After this operation, the user data values remain unchanged.

Procedure:
1 Click Tools→Restore Radio.

2 From the Restore To drop-down list in the Restore Radio window , select the software version.

CPS Plus automatically selects the appropriate software for the radio.

3 Select the radio or radios and click Start Operation.

Once the programming operation begins, do not disconnect or turn off the radio. The radio icon
turns orange and the progress bar displays the operation status. When the operation is
complete, the radio icon turns green.

IMPORTANT: If the radio software version, that you selected, does not match the
codeplug version, that resides on the radio, an error message appears. Verify that the
radio software used for restoring and the codeplug that resides on the restored radio
have the same version.

4.17
Recovering a Radio
Prerequisites:
• The Tools→Options→Recovery is set to Detect corrupted software but let me start recovery

manually.

• You connected the radio to PC and turned it on in flashing mode.

• The radio icon displays a red warning sign and the context-menu in the Radio Icons List is not
available for the radio.

• You are unable to read the radio.

• You have a relevant software release packet on a disk.

NOTICE: After you import a release packet using the Import Release Packet option, CPS
Plus stores all the software components in the following directory:c:\Program Files
\MotorolaSolutions\Tetra CPS Plus\Bin\repository_link_folder\.

• You have copies of the relevant codeplugs in the backup folder.

NOTICE: Each time after reading a radio, CPS Plus automatically backs up each codeplug
and stores in the following directory: c:\Program Files\MotorolaSolutions\Tetra
CPS Plus\BackupCodeplugs\.
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When and where to use:To manually recover the corrupted areas of the radio flash memory (occurred
due to programming errors) and write the correct software components again.

NOTICE: CPS Plus can trigger the recovery automatically. Go to Tools→Options→Recovery ,
select the Detect corrupted software and start recovery automatically mode and let CPS
Plus perform the recovery when needed. CPS Plus uses radio software from the release packet
repository and copies of compatible codeplugs. If all software components (release packets,
backup codeplugs) are proper and located on the disk, CPS Plus automatically selects the
appropriate radio software and starts the process.

Procedure:
1 To verify that the radio is corrupted, click File→Read Radio.

The Read Radio dialog box appears. You are unable to select the radio and the description line
displays: The radio is corrupted. Please use Recover Radio to repair it
and try again.

2 Click Tools→Recover Radio.

3 From the Recover To drop-down list in the Recover Radio dialog box, select the software
version.

4 Select the radio or radios and click Start Operation.

Once the programming operation begins, do not disconnect or turn off the radio. The radio icon
turns orange and the progress bar displays the operation status. When the operation is
complete, the radio icon turns green.

Once the radio is recovered, the radio icon turns green. You can read the radio.

4.18
Applying a Hotfix File
Prerequisites:
• You have the appropriate .hfx hotfix file.

• Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon appears on
the list. It is possible to connect multiple radios at the same time.

When and where to use:You received a hotfix file that contains customized values of codeplug
parameters. You want to fix radios configuration using the hotfix file.

Procedure:
1 Locate the hotfix file on the disk, using the Windows Explorer.

2 Double-click the hotfix file.

CPS Plus is brought to front and the Select Radio dialog box appear.

3 Select the radio or radios and click Start Operation.

Once the programming operation begins, do not disconnect or turn off the radio. The radio icon
turns orange and the progress bar displays the operation status. When the operation is
complete, the radio icon turns green.

Postrequisites:Verify that the radio settings are correct.
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4.19
Collecting Radio CPU ID
You want to collect the CPU ID that identifies your radio or control head.

Prerequisites:
• Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon appears on

the list. It is possible to connect multiple radios at the same time.

Procedure:
1 Click Tools→Display Radio CPU HW ID.

2 In the Radio CPU HW ID List box, perform one of the following actions:

If… Then…

If you want to
copy the CPU ID
in a text data for-
mat,

a Highlight the relevant cell in the table.

b Click Copy Selection to Clipboard or press CTRL + C.

c Paste the CPU ID into any text editor.

NOTICE: It is possible to highlight multiple cells. To high-
light the whole column, click the column header.

If you want to
save all the CPU
ID data,

a Click Save All to File.

b Navigate to a selected location, enter a chosen file name and click
Save.

The CPU ID of all the radios in the list is saved to a .csv file.

4.20
Collecting Runtime Log
You can use the AT Command to collect mobility log and Short Data Services (SDS) or Call-out data
from the radio or pager.

Prerequisites:
Connect the radio to a PC, turn it on in the flashing mode, and wait until the radio icon appears on the
list. It is possible to connect multiple radios at the same time.

Procedure:
1 Click Tools→Collect Runtime Log.

2 The Read Radio pop-up window displays all the connected radios and general information such
as Model Name, Serial Number, TEI, and Radio Version.

3 Select the required radios.

4 Click <Browse...> to choose a location to save the log.

The default path is ../data/MobilityLog.

5 Click Start Operation.

4.21
Setting Passphrase for OTAP Bridges
You can use Over-the-Air Programming (OTAP) to remotely reconfigure radios over TETRA network.
The OTAP feature is secured with a passphrase which is required every time OTAP is used.

6802974C10-BR
Chapter 4:  CPS Plus Operations

68  



When and where to use:A passphrase must be created during the initial set up of OTAP on your
CPS.

Procedure:
1 Enable the OTAP feature by follow the instructions up to step 2 in Enabling a Selling Feature on

a Radio on page 48.

2 In the Radio Icon List, right-click on the targeted radio model and select Use as OTAP Bridge.

3 Follow the instruction on screen to create your passphrase.

NOTICE: Passphrase is only created once. Once the passphrase is programmed, the
passphrase is not editable or retrievable through CPS or any interface on the radio.
Passphrase reset or recovery options are not available. In cases where the passphrase
is forgotten, the affected radio must be sent to your service provider for reprogramming
for a new OTAP passphrase.

4.22
Setting Up OTAP Bridges
Over-the-Air Programming (OTAP) bridges are over-the-air communication channels between the
Customer Programming Software (CPS) and recipient radios. You can set up a radio to function as a
bridge.

Prerequisites:
1 Connect a radio to the PC.

2 Enable the OTAP feature flag for the connected radio.

3 To avoid interruption due to calls during an OTAP operation, disable feature flags relating to calls on
the bridge radio.

4 To set the radio as an OTAP bridge, the radio must be powered on and in service mode.

5 Ensure that the radio is in Trunked Mode Operation (TMO).

6 Ensure that the radio is not in charger-only mode.

When and where to use:The OTAP bridge must be set up and ready for use before configuring an
update with OTAP.

Procedure:
1 Disable the automatic start programming mode. Do the following:

a Click Tools→Options.

b Clear the Enable auto reset radio to programming mode check box.

2 To enable the connected radio as an OTAP bridge, right-click on the targeted radio model in the
Radio Icon List and select Use as OTAP Bridge.

3 Log on with your passphrase which was created during the initial OTAP setup.

The OTAP bridge is ready for use.

4.23
Sending Critical Updates
Prerequisites:Motorola Solutions sends you a service package for critical update.
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When and where to use:You want to send a critical update (also known as codeplug hotfix) as
provided by Motorola Solutions through Over-the-Air-Programming (OTAP).

Procedure:
1 Click File→Send MSI Service Package.

Over the Air Programming window pops up.

2 Load the provided MSI Service Package.

3 Insert the identity of the target radio.

NOTICE: For group updates, add the identities of the impacted group radios into the list.

4 Click Send after configuration is completed to deliver the update to the identified radio.

4.24
Sending General Radio Configuration Update
When and where to use:You want to send a general radio configuration update through Over-the-Air-
Programming (OTAP). OTAP supports both clear and encypted updates.

Procedure:
1 Connect the identified radio model to the CPS.

2 Read the radio codeplug until completion.

3 To generate an OTAP Profile, perform the following actions:

a Click File→Generate OTAP Profile.

b Select the groups of configurations to be added into the profile from the Generate OTAP
Profile - Select Groups window.

c Save the generated profile to a preferred location.

You are now ready for configuration update over OTAP.

4 To start the OTAP configuration update, load the OTAP profile by clicking File→Open OTAP
Profile. Update the codeplug fields as required.

To successfully send OTAP updates, the payload size must not exceed 100%. As you configure
the OTAP profile, you can view the payload percentage in OTAP List at the bottom pane. If the
payload size exceeds 100%, you must reduce the size by removing some of the codeplug field
selections.

5 When the update is completed, send the configuration update by clicking File→Send OTAP.

Over the Air Programming window pops up.

6 Insert the identity of the target radio.

NOTICE: For group updates, add the identities of the impacted group radios into the list.

7 Click Send after configuration is completed to deliver the update to the identified radio.
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4.25
Viewing OTAP Update Status
Procedure:

Select View→OTAP Tracking Window.

The OTAP Tracking window appears and displays the update status.
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Chapter 5

Troubleshooting
The troubleshooting topics can help you to identify and overcome difficulties while programming your
radio.

5.1
Unable to Launch CPS
Only one CPS instance can run at a time so before re-launching the application you need to verify if
the application window is not minimized.

If the window is not minimized, you can terminate the CPS process manually and launch the
application again. Shut down the process by performing the following actions:

1 Press CTRL+ALT+DELETE.

2 Click Task Manager.
3 Select the cpsplus.exe instance and click End Process.

5.2
Unable to Exit CPS Plus
Terminate the CPS process manually. To shut down the process, perform the following actions.

1 Press CTRL+ALT+DELETE and click Task Manager.
2 Select the cpsplus.exe instance and click End Process.

5.3
A Radio is not Functioning
1 Charge the battery.

2 Remove the battery, wait for 10 seconds and reinstall the battery.

3 Contact customer support.

5.4
Programming Mode Cannot Initiate
You connected the radio to the PC but failed to turn it on in flashing mode.

1 Charge the battery.

2 Verify that the radio functions properly. Turn the radio on and off. If you cannot turn it on, remove
the battery, wait for 10 seconds and reinstall the battery.

3 Connect the radio to a different USB port.

4 Verify that the hardware is properly installed in Windows. Go to Device Manager→Universal
Serial Bus controllers. If the TETRA hardware is not on the list, scan for new USB devices and
reinstall the USB drivers.

5 Verify that you use proper USB drivers dedicated to the software release.

6 Do not disconnect the radio and restart the PC. If new hardware is found, reinstall the USB drivers
manually.
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7 Contact customer support.

5.5
I Disconnected a Radio During Programming
1 Do not turn off the radio.

2 Do not exit CPS Plus.

3 Reconnect the radio to the PC.

4 Wait until CPS Plus discovers the radio (it appears in Radios Icons List).

5 Repeat the programming operation.

NOTICE: To verify the programming operations history, click Window→Task Window.

5.6
Programming Interrupted or Failed
Connect the radio to the PC as for programming. If needed, CPS Plus automatically recovers the radio
using its previous configuration, (CPS Plus backs up the proper configuration on a disk).

IMPORTANT: The radio codeplug must have been read at least once by the CPS in order to
take backup.

NOTICE: To verify the programming operations history, click Window→Task Window.

5.7
Invalid Codeplug Parameters
You are unable to save the codeplug or perform certain operations.

1 To find the invalid parameters, go to the Information pane, click the Invalid tab, and double-click
the path.

NOTICE: Alternatively, you can use the Compare Codeplug to find the differences
(including the invalid parameters) between two files.

2 Correct the values and try again.

5.8
Report Issue
When and where to use:When an application or codeplug error occurs, you may prepare a report,
which can be provided to the Motorola Solutions support in order to determine the root cause.

Procedure:
1 Click Help→ Issue Report.
2 In the Report Issue window enter optional information such as User Name and Issue

Description. Select the check boxes to choose information that will be included in the report.

3 Press Create Report Archive. A pop-up window appears that allows you to save the issue
report to a ZIP file.

A message window saying The report archive has been saved to appears.

4 Inform the Motorola Solutions support about the issue and provide the generated report.
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5.9
Windows Crashes When Using a USB 3.0 Port
If Windows crashes when you are programing the radio using a USB 3.0 port, you need to upgrade the
USB 3.0 Host Controller driver on your PC. The driver is usually provided by your motherboard
manufacturer – please refer to the relevant website.
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Chapter 6

CPS Glossary
Active document or file – The document in which you are working.

ADD – Audio Device Descriptors. A structure which provides hardware information about a particular
audio accessory (for both IMPRESS and core accessories). Files with ADD have an extension .add.

AIE – Air Interface Encryption provides confidentiality on the radio link over the air.

APAC – Asia Pacific region.

ASSI – Alias Short Subscriber Identity.

Audio Profile – represents radios audio characteristics that fit to a specific operating environment, for
example Indoor for an office or Outdoor for high traffic noise. It is not recommended to edit it.

Audio Template – a baseline file for creating audio profiles. Audio experts prepare and modify audio
templates.

BUP – Backup.

Calibration values – a set of important and unique, factory-defined values (such as frequency tuning)
assigned to radios. Also known as Sensitive data.

Call – There are two types of calls: individual call or group call. An individual call is a complete
sequence of related call transactions between two radios in DMO. There are always two participants in
an individual call. A group call is a complete sequence of related call transactions involving two or more
DM-MSs. The number of participants in a group call is not fixed, but it is at least two. Participants may
join (late entry) and leave an on-going group call.

CCK – Common Cipher Key. The infrastructure generates this key to protect a group address signaling
and traffic. Also used to protect SSI identities (ESI).

Class – Also called the security class.

Class 1 – no encryption, may use authentication.

Class 2 – SCK encryption, ESI with SCK, may use authentication.

Class 3 – DCK encryption, ESI with CCK, authentication.

Clear – An application without encryption support.

CP – Codeplug. Repository of personality data for a radio. It includes features (also the selling
features) and adjustable parameters.

Compatibility field – Codeplug fields that include identity information such as Model Type, Codeplug
Structure Version, and Codeplug Default Version.

CPS – Customer Programming Software used to program TETRA radios.

CPV – Codeplug Value, clear-text file format that contains codeplug paths and values in lines;
<fullpath, value>. It is not recommended to export and import CPV files, unless you have a
thorough knowledge about the codeplug structure.

DCE – Data Communication Equipment.

DCK – Derived Cipher Key generated during authentication for protection of individually addressed
signaling and traffic.

DCK – Digital Car Kit

DGNA – Dynamic Group Number Assignment allows a network operator or an authorized user to
dynamically allocate talkgroups to selected radios over the air interface. Using supplementary services
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messages (SS-DGNA) the network operator can command the radio to add talkgroups to the radios
talkgroup list, to attach or select these talkgroups, to delete talkgroups from the list, or modify
parameters of existing talkgroups. A special feature of the radio, if provisioned, causes a new group
that is assigned by the SwMI to be automatically attached as the selected group, whether an
attachment was received with the assignment. In order for an MS to be allowed to participate in
communication of a given group, the MS must request and receive permission from the SwMI. This is
called group attachment.

DMO – Direct Mode Operation a mode of simplex operation where radios may communicate using
radio frequencies that may be monitored by, but which are outside the control of, the TETRA V+D
network. DM is performed without the intervention of a base.

DMO Gateway – Direct Mode Operation Gateway: A device that provides gateway connectivity
between DM-MS and the TETRA V+D network. The gateway provides the interface between the
TETRA DMO and TETRA V+D modes. A gateway may provide only the gateway function (DM-GATE)
or may provide the functions of both a DM repeater and a DM gateway during a call (DM-REP/GATE).

Downgrade – to replace radio firmware with an older version and preserve User and Sensitive Data..

DTE – Data Radio Equipment.

DTMF – Dual Tone Multi-Frequency. Tone-based signaling scheme which combines two of a set of
standard frequencies. The result is a third or beat frequency (signal) which is the desired or usable
signal. DTMF signaling is used as tone-dialing in the common telephone.

EMEA – Europe, the Middle East and Africa regions.

Encryption – Secure communications systems are designed to provide coded (“encrypted ”) signals
between some or all links in the system. In order to do this, each device involved in secure
communications is loaded with a multi-digit encryption variable (called a key). This key is used by an
encryption algorithm built into the device to encrypt voice or data as needed. Only devices in the
system with the same algorithm and encryption key can decode the encrypted signals.

ESI – Encrypted Short Identity.

ESSC – EMEA System Support Center

Firmware – computer instructions that reside as read-only software on a radio's flash memory.

Flash – a storage chip integrated in to radio hardware, that can be erased and reprogrammed.

Flashing – Writing a software image file to a radio.

Fly-out GUI element or menu – a popup menu that extends from other visual element. In CPS Plus, it
is a right-side bar that can auto hide or 'fly out' to display connected radios.

GCK – Group Cipher Key. Predetermined cipher key used to provide confidentiality in Class 3 system
with corresponding algorithm.

GCK KAR – Group Cipher Key Key Association Range

GPIO – General Programmable Input Output pins.

Group Call – an instant communication between users that belong to the same talkgroup.

GSSI – Group Short Subscriber Identity.

Home Location Address – Area within radio coverage of a base station or group of base stations
within which a radio is allowed to operate.

Hotfix – a special purpose file, used by service or support teams, that allows to apply a set of
predefined settings to codeplugs. Hotfixes are similar to profiles but allow to modify not only user data
but also calibration values, which are not available to a regular CPS Plus user.

ISSI – Individual Short Subscriber Identity.

ITSI – Individual TETRA Subscriber Identity.
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Key – Each device involved in secure communications is loaded with a multi-digit encryption variable –
an encryption key. An encryption algorithm built into the device uses this key to encrypt voice or data
as needed. Only devices in the system with the same algorithm and encryption key can decode the
encrypted signals.

LIP – Location Information Protocol.

Local Site Trunking – allows radio subscribers of the same cell site to communicate when the link
between the site and network central controller fails. Entering and exiting Local Site Trunking (that is,
returning to Site Wide Trunking) is done automatically – the display shows the “Local Area Service”
message Any call in progress is dropped upon entering Local Site Trunking mode. Registration, Group
Call, and Emergency Call are available in Local Site Trunking.

LRPP – Location Request/Response Protocol. This protocol allows for a single and efficient format of
passing location information (requests and responses).

MACE – Motorola Advanced Crypto Engine

MCCH – Main Control Channel. The principal common control channel transmitted by the infrastructure
to control the radios in a cell.

MLE – Mobile Link Entity.

MMI – Man Machine Interface, relates to the CPS Plus and radios user interface.

NGCH – Next Generation Control Head.

OTAK – Over the Air Keying.

OTAR – Over the Air Rekeying.

PABX – Private Automatic Branch Exchange, allows to call local (office) extension numbers.

PABX Gateway – A device that provides connectivity from a TETRA user to a PABX subscriber and
the other way around.

PDV2 – Permanent Disable Version 2; you can restore a disabled radio using CPS Plus.

PEI – Peripheral Equipment Interface.

PHF – Personal Hands-Free kit, in other words an earpiece or a handset.

Private Call – call between two and only individuals. Apart from the two interlocutors, no one else can
participate or listen to the call.

Private Duplex Call – a private call between two radios that resembles a telephone conversation. The
two individuals can talk and listen at the same time without pressing PTT.

Private Number – also called Private ID.

PSTN – Public Switched Telephone Network.

PSTN Gateway – a device that provides connectivity from a TETRA user to a PSTN subscriber and
the other way around. Additionally, for the duration of the call, the PSTN gateway allows TETRA
signaling information to be passed from TETRA Switching and Management Infrastructure to the
external network user and from the external network user to the TETRA SwMI in accordance with the
TETRA Call Control (CC) procedures.

PTPC – Point-to-Point Call also known as Private Call.

PTT Button – Push To Talk button that initiates a group call.

RCU – Remote Control Unit, a small device attached to a covert radio over a thin wire, used for
operating the radio.

Remote flashing – programming the transceiver via the control head.

RSM – Remote Speaker Microphone.

RSSI – Receiver Signal Strength Indication.
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RUA – Radio User Assignment.

RUI – Radio User Identity.

SCK – Static Cipher Key, used to provide confidentiality in Class 2 system with corresponding
algorithm.

SDS – Short Data Services.

SDMO KAG – Secure Direct Mode Operation Key Association Group.

Selling Feature – requires an entitlement purchased from Motorola Solutions.

Semi-Duplex Private Call – Also called Private Call or Express Connect Call. In this type of one-way
call, the user presses and holds the PTT while talking, and releases the PTT while listening.

Sensitive data – a set of important and unique, factory-defined values (such as frequency tuning)
assigned to radios.

SIM – Subscriber Identity Module a smart card that holds subscriber information (including the
authentication key) and is inserted into the radio to grant its personality.

Software image – a collection of files distinguished by individual releases. It contains firmware,
codeplug, and audio template files dedicated to specific radio models.

Status ID – A feature that makes it possible for a subscriber to send status messages to other
subscribers. The user can enter a status message for each ID in a Status ID list. When a subscriber
sends a status message, the ID of the subscriber’s unit is sent along with the status message.

SwMI – Switching and Management Infrastructure. The TETRA term for Fixed Network Equipment
(FNE). It consists of the system components, that is, the Central Network Equipment located at the
Master Site (or Mobile switching Office) and all the remote site equipment, but excludes the mobile
equipment.

TEI – TETRA Equipment Identity, an electronic serial number that is permanently embedded in the
TETRA equipment.

Talkgroup – A group of subscribers enabled to initiate and participate in a Group Call.

Telephone Interconnect – also knows as Phone Call.

TETRA – Terrestrial Trunked Radio. The digital trunked radio standard produced by ETSI providing
detailed telecommunications specifications to which Base Stations and Mobile Stations should adhere.

TMO – Trunking Mode Operation.

Trunked – Trunked Radio Communications - A computer controlled communications system that
allocates speech channels on demand selecting on a random basis from the group of channels
available.

Upgrade – to replace radio firmware with a newer version and preserve User and Sensitive Data.

User Data – a set of codeplug nodes and values, that can be edited and replicated to other codeplugs
or radios.

VASSI – Visitor Alias Short Subscriber Identity.

6802974C10-BR
Chapter 6:  CPS Glossary

78  



Chapter 7

Service Information for EMEA
EMEA Technical Support Operations (TSO)
The EMEA Technical Support Operations (TSO) provides a remote Technical Support Service to help
customers resolve technical issues and quickly restore networks and systems. This team of highly
skilled professionals is available to customers with current service agreements in place that include the
Technical Support Service. The TSO technical experts may be accessed through the Service Desk
either electronically or using the listed telephone numbers. If you are unsure whether your current
service agreement entitles you to benefit from this service, or if you would like more information about
the Technical Support Service, contact your local customer support or account manager for further
information.

Contact Details
Technical Requests: techsupport.emea@motorolasolutions.com

Repair Support: repair.emea@motorolasolutions.com

Contact Us: https://www.motorolasolutions.com/en_xu/support.html

Parts Identification and Ordering
If you need help in identifying non-referenced spare parts, direct a request to the Customer Care
Organization of a local area Motorola Solutions representative. Orders for replacement parts, kits, and
assemblies should be placed directly at the local distribution organization of Motorola Solutions or
through the Extranet site Motorola Online at https://emeaonline.motorolasolutions.com.

However, you cannot order export-controlled products or spare parts such as TEA-related boards
through Motorola Online. Send an order form with actual end-customer details by e-mail to your
customer care team.

Your Input
Send questions and comments regarding user documentation to 
documentation@motorolasolutions.com.
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Appendix A

Service Information for APAC
This topic contains contact details to service centers in Asia and Pacific region.

Technical Support
Technical support is available to assist the dealer/distributor in resolving any malfunction which may be
encountered. Initial contact should be by telephone wherever possible. When contacting Motorola
Solutions Technical Support, be prepared to provide the product model number and the serial number.

Further Assistance from Motorola Solutions
You can also contact the Customer Help Desk through the website: http://www.motorolasolutions.com/
en_xp/products. If a unit requires further complete testing, knowledge and/or details of component level
troubleshooting or service than is customarily performed at the basic level, send the radio to a Motorola
Solutions Service Center as listed in the following table:

Table 24: Service Information – Telephone Numbers and Addresses of the Asia and Pacific Motorola
Solutions Centers

Country Telephone Number Address

Singapore +65-6352-6383 Motorola Solutions Singapore Pte. Ltd,
c/o Azure Engineering,
49 Jalan Pemimpin,
#03-11 APS Industrial Building,
Singapore 577203
Contact: Alvin Tan
E-mail: alvin.tan@motorolasolutions.com
Contact: Gan Saw See
E-mail: gan.sawsee@motorolasolutions.com

Malaysia +603-7809-0000 Motorola Solutions Sdn. Bhd.
Level 14, Persoft Tower,
No. 68, Pesiaran Tropicana,
47410 Petaling Jaya,
Selangor Darul Ehsan,
Malaysia
Contact: Koh Tiong Eng
E-mail: A21001@motorolasolutions.com

Indonesia +62-21-3043-5239 PT. Motorola Solutions Indonesia
30th Floor, Gedung BRI II, Suite 3001,
Jl. Jend. Sudirman Kav. 44-46,
Jakarta 10210,
Indonesia
Contact: Eko Haryanto
E-mail: Eko.Haryanto@motorolasolutions.com

Thailand Tel: +662-653-220 Motorola Solutions (Thailand) Ltd.
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Country Telephone Number Address

Fax: +668-254-5922 142 Two Pacific Place Suite 2201,
3220 Sukhumvit Road,
Klongtoey,
Bangkok 10110
Contact: Nitas Vatanasupapon
E-mail: Nitas@motorolasolutions.com

India +91-9844218850 Motorola Solutions India Pvt. Ltd.
C/o Communication Test Design India Private Limited,
#4, 5 Maruthi Industrial Estate,
Rajapalya, Hoodi Village,
Bangalore - 560048,
India
Contact: K. Umamaheswari
E-mail: umamaheshwari@motorolasolutions.com

China +86-10-8473-5128 Motorola Solutions (China) Co. Ltd.
No. 1 Wang Jing East Road,
Chao Yang District,
Beijing, 100102,
P.R. China
Contact: Sophy Wang
E-mail: C18170@motorolasolutions.com

Hong Kong 852-2966-4823 Motorola Solutions Asia Pacific Ltd.
Unit 1807-1812, 18/F, Two Harbourfront,
22 Tak Fung Street,
Hunghom, Kowloon,
Hong Kong
Contact: Judy Leung
E-mail: Judy.Leung@motorolasolutions.com

Philippines Tel: +632 858-7500

Fax: +632 841-0681

Motorola Communications Philippines, Inc.
Unit 2102, One Global Place Building,
5th Ave., Bonifacio Global City,
Taguig, Philippines 1634.
Contact: Arthur Nieves
E-mail: Arthur.Nieves@motorolasolutions.com

Korea +822-3497-3649 Motorola Solutions Korea, Inc.
9th Floor, Hibrand Building,
215, Yangjae-Dong, Seocho-Gu,
Seoul, 137-924,
Korea.
Contact: KS Kwak
E-mail: r45321@motorolasolutions.com

Taiwan +886-2-8729 8000 Motorola Solutions Taiwan, Ltd.
8F, No. 9, Songgao Rd.,
Taipei 110,

6802974C10-BR
Appendix A:  Service Information for APAC

  81



Country Telephone Number Address

Taiwan (R.O.C.)
Contact: Michael Chou
E-mail: ftpe239@motorolasolutions.com

Australia +613-9847-7725 Motorola Solutions Australia Pty. Ltd.
10 Wesley Court,
Tally Ho Business Park,
East Burwood Victoria 3151,
Australia.
E-mail: servicecentre.au@motorolasolutions.com

Piece Parts
Some replacement parts, spare parts, and/or product information can be ordered directly. If a complete
Motorola Solutions part number is assigned to the part, it is available from Motorola Solutions Service
Organization. If no part number is assigned, the part is not normally available from Motorola Solutions.
If a list of parts is not included, that means that no user-serviceable parts are available for that kit or
assembly.

Customer Programming Software has no capability to tune the radio. Tuning the radio can only
be performed at the factory or at the appropriate Motorola Solutions Repair Center. Component
replacement can affect the radio tuning and must only be performed by the appropriate
Motorola Solutions Repair Center.
All orders for parts/information should include the complete Motorola Solutions identification number.
All part orders should be directed to your local Motorola Solutions Service Organization. See your
latest price pages.

Expansion and Vocon board are working in pair for AVR version and NON-AVR version,
whenever expansion board is replaced, Vocon board also have to be replaced and vice versa.
PA000471A02 need to pair with PA000470A03 and PMLF4167D need to pair with PMLF4176C.
There is not allowed to mix the Vocon-expansion pair as it can deeply affect the functionality of
the radio.

Parts Identification and Ordering
Request for help in identification of non-referenced spare parts should be directed to the Customer
Care Organization of Motorola Solutions local area representation. Orders for replacement parts, kits,
and assemblies should be placed directly on a Motorola Solutions local distribution organization or
from the Motorola Solutions Online (Extranet).
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Appendix B

Service Information – Americas
This topic contains contact details to service centers in Latin America and Caribbean region.

Technical Support
To request technical support, go to https://businessonline.motorolasolutions.com, Contact Us.

Some replacement parts, spare parts, and/or product information can be ordered directly. If a complete
Motorola Solutions part number is assigned to the part, it is available from Motorola Solutions. If no
part number is assigned, the part is not normally available from Motorola Solutions. If the part number
is appended with an asterisk, the part is serviceable by Motorola Solutions Depot only. If a list of parts
is not included, that means that no user-serviceable parts are available for that kit or assembly.

Warranty and Repairs

Table 25: Service Information – Telephone Numbers and Addresses of Latin America Radio Support
Centers

Country Telephone Number Address

Colombia 571- 376-6990 Motorola Solutions de Colombia Service Centre
Torre Banco Ganadero
Carrera 7 No. 71-52
Torre B piso 13
Oficina 1301
Bogota

Mexico 5252576700 Motorola Solutions de México Service Centre
Bosques de Alisos #125
Col. Bosques de las Lomas CP
05120 Mexico DF

Piece Parts
To order parts in Latin America and the Caribbean contact your local Motorola Solutions CGISS
representative.

Table 26: Service Information – Telephone Numbers and Addresses of Latin America Motorola
Solutions Centers

Country Telephone Number Address

Argentina 5411-4317-5300 Motorola Solutions Argentina
Ave. del Libertador 1855
B1638BGE, Vicente Lopez
Buenos Aires

Brasil 5511-3847-668 Motorola Solutions Ltda
Av. Chedid Jafet
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Country Telephone Number Address

222 Bloco D Conjuntos 11,12,21,22 E 41
Condominio Millennium Office Park
04551-065- Vila Olimpia, Sao Paulo

Chile 562-338-9000 Motorola Solutions Chile S.A.
Av. Nueva Tajamar 481
Edif. World Trade Center
Of. 1702, Torre Norte
Las Condes Santiago

Colombia 571-376-6990 Motorola Solutions Colombia LTDA.
Carrera 7 #71-52
Torre A, Oficina 1301
Bogotá

Costa Rica 506-201-1480 Motorola Solutions de Costa Rica
Parque Empresarial Plaza Roble
Edificio El Portico, 1er Piso
Centro de Negocios Internacional
Guachepelin, Escazu
San Jose

Ecuador 5932-264-1627 Motorola Solutions del Ecuador
Autopist Gral. Rumiñahui, Puente
2 Conjunto Puerta del Sol Este-Ciudad Jardin
Pasa E, Casa 65
Quito

Mexico 52-555-257-6700 Motorola Solutions de México, S.A.
Calle Bosques de Alisos #125
Col. Bosques de Las Lomas
05120 México D.F.

Peru 511-211-0700 Motorola Solutions del Peru
Ave. República de Panama 3535
Piso 11, San Isidro
Lima 27

USA 954-723-8959 Motorola Solutions, Inc.
Latin American Countries Region
789 International Parkway
Sunrise, FL 33325

Venezuela 58212-901-4600 Motorola Solutions de Los Andes C.A.
Ave. Francisco de Miranda
Centro Lido, Torre A
Piso 15, El Rosal
Caracas, 1060
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