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Important user information 
Read this document and the documents listed in the additional resources section about installation, configuration, and operation of this 
equipment before you install, configure, operate, or maintain this product. Users are required to familiarize themselves with installation and 
wiring instructions in addition to requirements of all applicable codes, laws, and standards. 

Activities including installation, adjustments, putting into service, use, assembly, disassembly, and maintenance are required to be carried 
out by suitably trained personnel in accordance with applicable code of practice. If this equipment is used in a manner not specified by the 
manufacturer, the protection provided by the equipment may be impaired. 

In no event will Rockwell Automation, Inc. be responsible or liable for indirect or consequential damages resulting from the use or 
application of this equipment. 

The examples and diagrams in this manual are included solely for illustrative purposes. Because of the many variables and requirements 
associated with any particular installation, Rockwell Automation, Inc. cannot assume responsibility or liability for actual use based on the 
examples and diagrams. 

No patent liability is assumed by Rockwell Automation, Inc. with respect to use of information, circuits, equipment, or software described 
in this manual. 

Reproduction of the contents of this manual, in whole or in part, without written permission of Rockwell Automation, Inc., is prohibited. 

Throughout this manual, when necessary, we use notes to make you aware of safety considerations. 

 
WARNING: Identifies information about practices or circumstances that can cause an explosion in a hazardous environment, which may lead to 
personal injury or death, property damage, or economic loss. 

 
ATTENTION: Identifies information about practices or circumstances that can lead to personal injury or death, property damage, or economic 
loss. Attentions help you identify a hazard, avoid a hazard, and recognize the consequence 

Important: Identifies information that is critical for successful application and understanding of the product. 

Labels may also be on or inside the equipment to provide specific precautions. 

 
SHOCK HAZARD: Labels may be on or inside the equipment, for example, a drive or motor, to alert people that dangerous voltage may be 
present. 

 
BURN HAZARD: Labels may be on or inside the equipment, for example, a drive or motor, to alert people that surfaces may reach dangerous 
temperatures. 

 
ARC FLASH HAZARD: Labels may be on or inside the equipment, for example, a motor control center, to alert people to potential Arc Flash. Arc 
Flash will cause severe injury or death. Wear proper Personal Protective Equipment (PPE). Follow ALL Regulatory requirements for safe work 
practices and for Personal Protective Equipment (PPE). 

Allen-Bradley, Rockwell Software, Rockwell Automation, and TechConnect are trademarks of Rockwell Automation, Inc. 

Trademarks not belonging to Rockwell Automation are property of their respective companies. 

 



 

 Rockwell Automation Publication ENET-GR001J-EN-E - November 2018 3 

Table of contents 

Purpose of this document ................................................................................ 7 
Intended audience ........................................................................................... 7 
How does the guide fit in with other Rockwell Software product 
documentation? ............................................................................................... 7 

Online help ............................................................................................... 7 
Product manuals ....................................................................................... 7 

Contact Rockwell Automation Technical Support ......................................... 7 
Legal Notices .................................................................................................. 8 

Chapter 1 

Features and benefits .................................................................................... 11 
Understanding EtherNet/IP concepts ............................................................ 13 
Exploring RSNetWorx for EtherNet/IP ........................................................ 14 

Title bar .................................................................................................. 14 
Menu bar ................................................................................................ 14 
Online icon ............................................................................................. 15 
Toolbars .................................................................................................. 15 
Edits enabled .......................................................................................... 17 
Hardware and Favorites views ............................................................... 17 
Graph or Spreadsheet view .................................................................... 17 
Diagnostics view .................................................................................... 18 
Message view ......................................................................................... 19 
Status bar ................................................................................................ 19 

Exploring the Scanlist Configuration Tool ................................................... 20 
Title bar .................................................................................................. 20 
Menu bar ................................................................................................ 20 
Online icon ............................................................................................. 21 
Toolbar ................................................................................................... 21 
Resource usage ....................................................................................... 22 
Scanlist entries ....................................................................................... 22 
Status bar ................................................................................................ 23 

Quick Start steps ........................................................................................... 23 
Online mode ........................................................................................... 24 
Offline mode .......................................................................................... 25 

Chapter 2 

System requirements ..................................................................................... 27 
Hardware requirements .......................................................................... 27 
Software requirements ............................................................................ 27 

Software compatibility .................................................................................. 28 
Installing RSNetWorx for EtherNet/IP software .......................................... 28 

Step 1: Launch the installation wizard and select what to install ........... 29 
Step 2: Set up security in RSNetWorx ................................................... 31 
Step 3: Read and accept license agreements .......................................... 32 
Step 4: Start the installation ................................................................... 33 

Preface 

Welcome to RSNetWorx for 
EtherNet/IP 

Installing and starting 
RSNetWorx for EtherNet/IP 



Table of contents 

 

4 Rockwell Automation Publication ENET-GR001J-EN-E - November 2018 

Step 5: Finish the installation ................................................................. 35 
Installing a client copy from a dedicated server ..................................... 38 

Starting RSNetWorx for EtherNet/IP ........................................................... 39 
Troubleshooting installation ......................................................................... 39 

Chapter 3 

EDS-based devices ....................................................................................... 41 
EDS library ............................................................................................. 41 

Class Instance Editor .................................................................................... 42 

Chapter 4 

Using the online help .................................................................................... 43 
Accessing help for a control or field ...................................................... 43 
Accessing help for messages .................................................................. 44 
Finding step-by-step procedures ............................................................ 45 
Finding definitions ................................................................................. 46 

Accessing the Product Manuals .................................................................... 47 
Training ......................................................................................................... 47 
Technical support .......................................................................................... 48 

When you call ........................................................................................ 48 

Appendix A 

Activate RSNetWorx with FactoryTalk Activation ...................................... 49 
How to activate RSNetWorx .................................................................. 49 
Finding more information about FactoryTalk Activation ...................... 50 
Grace period ........................................................................................... 50 
Some common questions ........................................................................ 50 

My activation files were damaged. What should I do? .................... 50 
I accidentally deleted the software directory on my hard drive. Do I 
need to call Rockwell Software for replacement activation files? ... 51 

Appendix B 

How do I set up security in RSNetWorx? ..................................................... 53 
What can I secure in RSNetWorx? ............................................................... 54 

Appendix C 

Perform unattended installation .................................................................... 57 
Parameters ..................................................................................................... 58 
Examples ....................................................................................................... 59 

Advanced concepts 

Finding the information you 
need 

Activation 

Security 

Use unattended installation 



Table of contents 

 

 Rockwell Automation Publication ENET-GR001J-EN-E - November 2018 5 

  Glossary 

Index 





 

 Rockwell Automation Publication ENET-GR001J-EN-E - November 2018 7 

Preface 

This getting results guide provides you with information on how to install 
and navigate the RSNetWorx™ for EtherNet/IP™ software. It explains how 
to effectively use the RSNetWorx for EtherNet/IP software and how to 
access and navigate the online help. 

We assume that you are familiar with: 

 Microsoft® Windows® operating systems 

 RSLinx® Classic™ communications software 

The Getting Results with RSNetWorx for EtherNet/IP guide can be 
considered the entry point into Rockwell Software’s documentation set for 
this product. Other components of the documentation set include online help, 
Online Books, and electronic release notes. 

The documentation set contains pertinent, easily accessible product 
information. This set ships with the software product, and is designed to free 
you from tedious paper shuffling and reduce information overload. 

The online help includes all overview, procedural, screen, and reference 
information for the product. The help contains these basic components: 
overview topics, quick start topics, step-by-step procedures, troubleshooting 
topics, and screen element descriptions (for example, text boxes, drop-down 
lists, and option buttons). All of the help is context-sensitive with the 
application and provides you with immediate access to application tasks and 
screen element descriptions. Refer to the "Finding the information you need" 
chapter in this guide for a more detailed description of the online help. 

Within RSNetWorx for EtherNet/IP, we provide a Product Manuals feature 
that allows you to immediately access and search your product 
documentation from the Help menu. This feature includes the Getting Results 
with RSNetWorx for EtherNet/IP guide, as well as several hardware product 
reference guides, in an electronic book format. As a part of the product 
installation, you have the option of installing these electronic books to your 
local hard drive during installation, or access them directly from the 
installation files. 

Tip: The product manuals included with RSNetWorx for EtherNet/IP are in portable 
document format (PDF), and can be viewed using the Adobe® Acrobat® Reader. 

 

If you cannot find the answer to your question in the documentation or on 
the Internet, contact Rockwell Automation Technical Support, using any of 
these methods: 

 Telephone: 1-440-646-3434 

Purpose of this document 

Intended audience 

How does the guide fit in 
with other Rockwell 
Software product 
documentation? 

Online help 

Product manuals 

Contact Rockwell 
Automation Technical 
Support 
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 Online: 
https://www.rockwellautomation.com/global/support/overview.page  

Support staff are available Monday to Friday from 8:00 a.m. to 5:00 p.m. 
local time (North America only), except on statutory holidays. 

Copyright notice 

Copyright © 2018 Rockwell Automation Technologies, Inc. All Rights 
Reserved. Printed in USA. 

This document and any accompanying Rockwell Software products are 
copyrighted by Rockwell Automation Technologies, Inc. Any reproduction 
and/or distribution without prior written consent from Rockwell Automation 
Technologies, Inc. is strictly prohibited. Please refer to the license agreement 
for details. 

End User License Agreement (EULA) 

You can view the Rockwell Automation End-User License Agreement 
("EULA") by opening the Rockwell_EULA_02102016_Final.pdf file located 
in your product's install folder on your hard drive. 

Open Source Licenses 

The software included in this product contains copyrighted software that is 
licensed under one or more open source licenses. Copies of those licenses are 
included with the software. Corresponding Source code for open source 
packages included in this product are located at their respective web site(s). 

Alternately, obtain complete Corresponding Source code by contacting 
Rockwell Automation via the Contact form on the Rockwell Automation 
website: 
http://www.rockwellautomation.com/global/about-us/contact/contact.page    
Please include "Open Source" as part of the request text. 

A full list of all open source software used in this product and their 
corresponding licenses can be found in the OPENSOURCE folder  included 
with this product's Release Notes respectively. The default installed location 
of these licenses is: 

 For RSNetWorx for ControlNet, C:\Program Files (x86)\Common 
Files\Rockwell\Help\RSNetWorx for ControlNet Release 
Notes\OPENSOURCE\index.htm. 

 For RSNetWorx for DeviceNet, C:\Program Files (x86)\Common 
Files\Rockwell\Help\RSNetWorx for DeviceNet Release 
Notes\OPENSOURCE\index.htm. 

 For RSNetWorx for EtherNet/IP, C:\Program Files (x86)\Common 
Files\Rockwell\Help\RSNetWorx for EtherNetIP Release 
Notes\OPENSOURCE\index.htm. 

Legal Notices 

https://www.rockwellautomation.com/global/support/overview.page
http://www.rockwellautomation.com/global/about-us/contact/contact.page
/usmkesrv7265/Publishing/PROD/IndividualPublishing/ZhaoRi/Word%20(Manuals)/Getting%20Results%20with%20RSNetWorx%20for%20EtherNetIP/OPENSOURCE/index.htm
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Trademark Notices 

Advanced Interface Series, AdvanceDDE, Allen-Bradley, Arena, 
ControlLogix, ControlView, Data Highway Plus, Datapac, DH+, Emonitor, 
Emonitor Odyssey, Enlab, Enlube, Enpac, Enshare, Entrx, Enwatch, 
eProcedure, FactoryTalk, FactoryTalk Activation, FactoryTalk Activation 
Manager, FactoryTalk Administration Console, FactoryTalk Alarms and 
Events, FactoryTalk AssetCentre, FactoryTalk Audit, FactoryTalk 
Automation Platform, FactoryTalk Batch, FactoryTalk Diagnostics, 
FactoryTalk Directory, FactoryTalk Gateway, FactoryTalk Historian Classic, 
FactoryTalk Historian for Batch, FactoryTalk Live Data, FactoryTalk 
Metrics, FactoryTalk Portal, FactoryTalk ProductionCentre, FactoryTalk 
Scheduler, FactoryTalk Security, FactoryTalk Services Platform, 
FactoryTalk Transaction Manager, FactoryTalk View, FactoryTalk View 
Machine Edition, FactoryTalk View SE, FactoryTalk View Studio, 
GuardLogix, GuardPLC™, MicroLogix, MobileView, MotorMonitor, ODS, 
PanelBuilder, PanelView, PhaseManager, PlantLink, PLC-2, PLC-3, PLC-5, 
PowerMonitor, ProcessLogix, Propack Data, Rockwell Automation, 
Rockwell Software, RSAssetSecurity, RSBizWare, BatchCampaign, 
BatchHistorian, Historian, MaterialTrack, PlantMetrics, Scheduler, 
RSEnergyMetrix, RSLadder, RSLinx, RSLinx Classic, RSLinx Enterprise, 
RSLogix, RSLogix 5, RSLogix 500, RSLogix 5000, RSLogix Emulate, 
RSLoop Optimizer, RSMACC, RSNetWorx, RSNetWorx for ControlNet, 
RSNetWorx for DeviceNet, RSNetWorx for EtherNet/IP, RSOPC Gateway, 
RSPower, RSSql, RSTrend, RSTune, RSView, RSView32, SLC, SLC 500, 
SoftLogix, Studio 5000 Logix Designer, VersaView, WINtelligent, and XM 
are trademarks of Rockwell Automation, Inc. 

Any Rockwell Automation logo, software or hardware product not 
mentioned herein is also a trademark, registered or otherwise, of Rockwell 
Automation, Inc. 

Other Trademarks 

ActiveX, DirectX, Microsoft, SQL Server, Visual Basic, Visual C++, 
Windows, Windows NT, Windows Server, and Windows Vista are either 
registered trademarks or trademarks of Microsoft Corporation in the United 
States and/or other countries. 

Acrobat, Adobe, and Reader are either registered trademarks or trademarks 
of Adobe Systems Incorporated in the United States and/or other countries. 

CIP, ControlNet, DeviceNet, and EtherNet/IP are either registered 
trademarks or trademarks of the ODVA, Inc. in the United States and/or 
other countries. 

IBM is a registered trademark of International Business Machines 
Corporation. 

OPC is a registered trademark of the OPC Foundation. 
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Oracle and SQL*Plus are either registered trademarks or trademarks of 
Oracle Corporation in the United States and/or other countries. 

Intel, Intel Core, and Pentium are either registered trademarks or trademarks 
of the Intel Corporation in the United States and/or other countries. 

All other trademarks are the property of their respective holders and are 
hereby acknowledged. 

Warranty 

This product is warranted in accordance with the product license. The 
product’s performance may be affected by system configuration, the 
application being performed, operator control, maintenance, and other related 
factors. Rockwell Automation is not responsible for these intervening factors. 
The instructions in this document do not cover all the details or variations in 
the equipment, procedure, or process described, nor do they provide 
directions for meeting every possible contingency during installation, 
operation, or maintenance. This product’s implementation may vary among 
users. 

This document is current as of the time of release of the product; however, 
the accompanying software may have changed since the release. Rockwell 
Automation, Inc. reserves the right to change any information contained in 
this document or the software at any time without prior notice. It is your 
responsibility to obtain the most current information available from Rockwell 
when installing or using this product. 

Environmental compliance 

Rockwell Automation maintains current product environmental information 
on its website at 
http://www.rockwellautomation.com/rockwellautomation/about-us/sustainabi
lity-ethics/product-environmental-compliance.page  

Contact Rockwell Automation 

Customer Support Telephone — 1.440.646.3434 

Online Support — http://www.rockwellautomation.com/support/  

 

http://www.rockwellautomation.com/rockwellautomation/about-us/sustainability-ethics/product-environmental-compliance.page
http://www.rockwellautomation.com/rockwellautomation/about-us/sustainability-ethics/product-environmental-compliance.page
http://www.rockwellautomation.com/support/
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Chapter 1 

Welcome to RSNetWorx for EtherNet/IP 

RSNetWorx for EtherNet/IP is a 32-bit Windows application program that 
allows you to configure devices and lay out a network topology. From the 
graphical representation of your network, you can: 

 view I/O data and configuration data for those devices that have EDS 
files that support this functionality (online only) 

 display all connection information for all connections to/from a given 
device including all connections in scanners that are in the 
configuration 

 configure scanners that adhere to the open EtherNet/IP specification 
for scanners, define scanlist entries for certain scanners, and map 
scanner memory onto the network and network data into the scanner 
memory (via the Scanlist Configuration Tool (SCT) that is bundled 
with RSNetWorx for EtherNet/IP) 

 leverage the connection information to diagnose the health of the 
connections, and thus the health of the devices that originate and 
receive those connections 

This chapter contains the following sections: 

 Features and benefits 

 Understanding EtherNet/IP concepts 

 Exploring RSNetWorx for EtherNet/IP 

 Quick Start steps 

RSNetWorx for EtherNet/IP has the following features: 

 Support for Reduced Heartbeat feature of RSLogix 5000 V16. The 
numbers on the Device Usage Properties dialog box in EtherNet/IP 8.0 
will reflect the effect that Reduced Heartbeat calculations, from 
RSLogix 5000 V16, will have on your device's usage. 

Tip: The Reduced Heartbeat feature helps in preserving bandwidth in large network 
installations by reducing the rate at which heartbeat is sent from the Consumer to 
the Producer device. Heartbeat is the name given to the way a Consumer device 
informs a Producer device of its presence. 

 Support for Unicast feature of RSLogix 5000 V16. The numbers on the 
Device Usage Properties dialog box in EtherNet/IP will reflect the 

Features and benefits 
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effect that Unicast calculations, from RSLogix 5000 V16, will have on 
your device's usage. 

Tip: In Unicast the Producer device sends individual packets to each Consumer device. 

 Support for FactoryTalk® Activation. 

 RSNetWorx supports FactoryTalk Security. FactoryTalk Security is 
intended to improve the security of your automation system by limiting 
access to only those with a legitimate need. FactoryTalk Security 
authenticates user identities and authorizes user requests to access a 
FactoryTalk-enabled system. These security services are fully 
integrated into the FactoryTalk Directory and are included as part of 
the FactoryTalk Services Platform that installs with many products. 

 Device usages view displays usage percentages for factors such as 
minimum and maximum CPU and connection usage (when your 
device’s EDS file contains capacity information) or raw transmission 
data information (when your device’s EDS file does not contain 
capacity information). When edits are enabled, you will get to see both 
current and pending device usage information. 

 Embedded EDS is supported. With this functionality, you can now 
change the state of your device from unknown to known by uploading 
and registering its EDS, instead of obtaining the EDS file from an 
external website or a DVD. 

 A Windows-based point and click interface that allows you to easily 
configure EtherNet/IP networks. 

 Use of RSLinx Classic communication services, which allows you to 
browse online through various networks, devices, bridges, etc., to 
choose the network you want to view or edit. 

 The ability to edit configurations either online or offline. 

 Simple and complete network upload/download. You can upload a 
configuration directly from the network or download a configuration to 
the online network. When you upload or download a configuration, the 
scanlist for the open scanners is transferred. 

 The Scanlist Configuration Tool configures both I/O and peer-to-peer 
data addresses. It also supports target devices for Rockwell Automation 
and third-party devices via EtherNet/IP standard Electronic Data Sheet 
(EDS) files. 

 Reports generated in HTML format. 

 Comprehensive context-sensitive online help, including additional 
information and troubleshooting hints on any message that appears in 
the Message View. 

 The ability to interconnect several network configurations for 
navigation. 

 Quickly detect and resolve conditions that arise when initially 
commissioning a system, minimizing initial start-up times and costs. 
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 Debug and correct network/device problems, thereby reducing network 
downtimes and related costs. 

 Detect preventive maintenance needs within the devices on your 
network, thereby preventing system downtimes. 

You begin configuring your EtherNet/IP network by determining how many 
devices will be connected to your network, what EtherNet topology will be 
used, and what addressing method will be used (IP addressing, Host name 
addressing, or a combination of both). Each device must be assigned a 
unique IP address/host name. You may allow the addresses to be 
automatically assigned, or choose to assign a unique address manually. 

Finally, you finish creating the configuration by defining connections 
between the devices at IP addresses/host names on the network. To do this, 
you determine which data is to be consumed by each scanner, and you 
determine where in each scanner’s data table this data is placed. You may 
also choose to determine which scanner will maintain the configuration for 
each adapter device. After you have defined these parameters, you use the 
Scanlist Configuration Tool (for integrated scanners) or RSLogix 5000 (for 
Rockwell Automation’s Logix processors) to enter the connection into your 
configuration for each of your EtherNet/IP scanners. 

For many devices, you can also use the Scanlist Configuration Tool to 
configure how outputs are set in the event of a fault, such as loss of 
communication to the controlling scanner. Depending on the information 
contained in a device’s EDS file, you may be able to configure other device 
parameters. These parameters may be found on the connection’s property 
page from the Configuration Settings tab and/or the Advanced Settings tab 
depending on the device or module for which you are setting the parameters. 

Tip: When you are online, enable edits, and save your configuration in RSNetWorx for 
EtherNet/IP version 4.0 or later, the software displays connections that are created 
in Studio 5000 Logix Designer. 

 

Understanding EtherNet/IP 
concepts 
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When you start RSNetWorx for EtherNet/IP software, the RSNetWorx for 
EtherNet/IP window appears. It shows the current network (EtherNet is the 
default filename) in its view. The following illustration shows the 
RSNetWorx for EtherNet/IP window and the design elements associated 
with it. (The Message view and Favorites view will not be automatically 
shown in the default view, but may be chosen by selecting View > Messages 
> Show or View > Favorites.)  Each of the design elements are described 
the sections following this illustration. 

 

The title bar shows the RSNetworx icon, the name of the current 
RSNetWorx configuration, the name of the software product and so on. 

The RSNetWorx for EtherNet/IP menu bar contains the following menus: 

 

Each menu contains options for performing the following tasks: 

Menu Description 

File New, print, open, and save a network configuration, generate reports, or exit RSNetWorx for EtherNet/IP. 

Edit Invoke actions such as cut, copy, and paste on selected items in the network configuration. 

View Set and change RSNetWorx for EtherNet/IP interface displays. 

Network Browse the network, toggle between online and offline mode, enable and cancel edits, and upload and 
download data to and from the network. 

Device Edit the properties of the selected device, chassis, or module. 

Diagnostics Start and stop the diagnostic scan, add or remove devices from the diagnostic scan, troubleshoot a 
diagnostic fault, and generate a network health report. 

Tools Launch the EDS Wizard and other optional tools. 

Exploring RSNetWorx for 
EtherNet/IP 

Title bar 

Menu bar 
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Menu Description 

Help Access help options for RSNetWorx for EtherNet/IP, EtherNet/IP related hardware, and other Rockwell 
Software products and services. 

 

The online icon displays in the right side of the RSNetWorx for EtherNet/IP 
window at the same level as the menu bar. 

 

This icon indicates whether or not RSNetWorx for EtherNet/IP is in the 
online mode. If you toggle the Online toolbar button to online, the Online 
icon becomes animated. If the icon is not animated, RSNetWorx for 
EtherNet/IP is in offline mode. When online, RSNetWorx for EtherNet/IP 
writes information to the devices and to the offline file when you save. When 
offline, RSNetWorx for EtherNet/IP only updates the offline file when you 
save. 

The toolbars contain shortcuts to several commonly used functions. Each 
toolbar button is a graphical representation of a command (except Symbol 
Legend) that is also available from the RSNetWorx for EtherNet/IP menu 
bar. RSNetWorx for EtherNet/IP contains the standard toolbar and the tools 
toolbar. 

The following items appear on the RSNetWorx for EtherNet/IP standard 
toolbar. 

 

Icon Menu Selection Description 

 

File > New Creates a new network configuration. 

 

File > Open  Opens an existing network configuration. The arrow to the right of the Open 
icon provides quick access to recently used files. 

 

File > Save Saves the current network configuration. 

 

File > Print Prints the current network configuration. 

 

Edit > Cut Cuts the selected device from the network configuration and places it on the 
clipboard. If you cut a device, only the device, not its configuration, is 
retained. 

Online icon 

Toolbars 
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Icon Menu Selection Description 

 

Edit > Copy Copies the selected device to the clipboard. If you copy a device, only the 
device type, not its configuration, is retained. 

 

Edit > Paste Pastes the device from the clipboard to the current network configuration. 

 

Help > What’s This? Places the cursor in What’s This? help mode. Place the cursor on the control 
you want help with and right-click to see the context-sensitive help. 

The following items appear on the RSNetWorx for EtherNet/IP tools toolbar. 

 

Icon Menu Selection Description 

 

View > Zoom-In Increases the size of images located in the current network configuration. The 
choices available are high, medium, and low. Zoom-In only applies to the graph 
view. 

 

View > Zoom-Out Decreases the size of the images located in the current network configuration. 
The choices available are high, medium, and low. Zoom-Out only applies to the 
graph view. 

 

View > Hardware  Displays a list of all available hardware devices. 

 

View > Favorites  Displays a list of hardware devices that you have added to your favorites list. 

 

Network > Single Pass 
Browse or Network > 
Continuous Browse 

Locates all currently available devices based on the drivers configured in RSLinx 
Classic. Allows you to browse once and stop (single pass) or browse continuously 
(continuous browse). 

 

Network > Online Places RSNetWorx for EtherNet/IP in online mode. To go offline, click the button 
or choose Network > Online again. 

 

View > Diagnostics  Displays the Diagnostic view, allowing you to view the diagnostic parameters 
for all of the devices on your network, and indicates the current diagnostic status 
of your network. 

 

View > Refresh Refreshes the window. This will reorder the graphic display by device address. 

 
No menu selection Displays the Symbol Legend, which contains descriptions of the device 

comparison states. The Symbol Legend can also be accessed from the online help 
system by selecting Help > Contents and selecting symbol legend from the 
index tab. 
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The edits enabled area allows you to obtain the edit resource, enabling and 
disabling edits to the current EtherNet/IP offline configuration file (*.enet). 

 

A device can be  added to the network configuration by selecting it from 
Hardware view and dragging it to the configuration (graph or spreadsheet 
view). Once a device is added, it will display in the appropriate 
configuration. The Favorites view displays all hardware devices that you 
have defined as favorites by selection from the Hardware list. To add an item 
from the Hardware list to the Favorites list, select the item, right-click and 
choose Add to Favorites. 

 

Edits enabled 

Hardware and Favorites views 

Graph or Spreadsheet view
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The application workspace displays network information in either a graphic 
or a spreadsheet view. Click the appropriate tab in the network configuration 
to display the desired view. 

 

 

 

Diagnostics view 
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RSNetWorx Diagnostics provides a hierarchical view of the real-time status 
(or health) of a network. At a glance, you can quickly and easily determine 
the overall status of your network, or any device on your network, by 
viewing a single status indicator. Click the Diagnostics tab in the network 
configuration to display this view. 

 

The message view, which appears in the bottom portion of the workspace 
displays a log of messages. Each message consists of four parts: 

 an icon that indicates error, warning, or information 

 an error message code (including a distinguishing software component 
designator and a 16-bit numeric designator) 

 a timestamp that displays the date and time the message is generated 

 a description of the message: 

Tip: If you want more information on any particular message, you can select the 
message and press the F1 key to access the online help. You can Show, Clear, Copy, 
or Clear and Hide messages by making the appropriate selection from the View > 
Messages command on the main menu, or by right-clicking and selecting the 
Message option while in the Message view. 

 

The status bar, which is located at the bottom of the RSNetWorx for 
EtherNet/IP main window, provides information about the status of the 
software. 

The left portion of the status bar displays informational messages about the 
operation of RSNetWorx for EtherNet/IP software. For example, when you 
highlight a device in the application workspace, a brief description of that 
device appears on the status bar. 

Message view 

Status bar 
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The right portion of the status bar displays the current state of the browsing 
operation. 

 

The Scanlist Configuration Tool is an extension of the RSNetWorx software 
that allows you to create, modify, and delete connection entries within a 
scanlist (an EtherNet/IP scanner). Using the Scanlist Configuration Tool, you 
can establish connections among devices and their respective I/O 
components (identifying connection types, sizes, and timing intervals) and 
then map that information to the data table. The following illustration shows 
the Scanlist Configuration Tool window and the design elements associated 
with it. (The Message view will not be automatically shown in the default 
view, but may be chosen by selecting View > Messages > Show.) Each of 
the design elements are described in the sections following this illustration. 

 

The title bar shows the Scanlist Configuration Tool icon, the name of the 
selected scanner, the name of the software product and so on. 

The Scanlist Configuration Tool menu bar contains the following menus: 

 

Each menu contains options for performing the following tasks: 

Menu Description 

File Save a configuration, generate a report for this scanner, or exit the Scanlist Configuration Tool. 

Edit Invoke actions such as cut, copy, and paste on selected items in the configuration. 

View Set and change the Scanlist Configuration Tool interface displays. 

Network Toggle between online and offline mode, and enable or cancel edits. 

Exploring the Scanlist 
Configuration Tool 

Title bar 

Menu bar 
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Menu Description 

Device Change mode of the scanner from, for example, run to program mode or download to device. 

Connection Insert connections or change connection parameters. 

Help View help options for the Scanlist Configuration Tool and other Rockwell Software products and services. 

 

The online icon displays in the right side of the Scanlist Configuration Tool 
at the same level as the menu bar. 

 

This icon indicates whether or not RSNetWorx for EtherNet/IP is in the 
online mode. If you toggle the Online toolbar button to online, the Online 
icon becomes animated. If the icon is not animated, RSNetWorx for 
EtherNet/IP is in offline mode. When online, RSNetWorx for EtherNet/IP 
writes information to the devices and to the offline file when you save. When 
offline, RSNetWorx for EtherNet/IP only updates the offline file when you 
save. 

The toolbars contain shortcuts to several commonly used functions. Each 
button on the toolbars is a graphical representation of a command that is also 
available from the Scanlist Configuration Tool menu bar. 

The following items appear on the Scanlist Configuration Tool toolbar: 

 

Icon Menu Selection Description 

 

File > Save Saves the current network configuration. 

 

Edit > Cut Cuts the selected field value and places it on the clipboard. 

 

Edit > Copy Copies the selected field value to the clipboard. 

 

Edit > Paste Pastes the field value from the clipboard to the current network 
configuration. 

 

Scanlist > Auto Insert > 
All Devices 

Interrogates all devices that can have connections in the EtherNet/IP 
configuration and adds connections to the scanlist. 

Online icon 

Toolbar 
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Icon Menu Selection Description 

 

Scanlist > Auto Insert > Selected 
Devices 

Interrogates selected devices that can have connections in the 
EtherNet/IP configuration and adds connections to the scanlist. 

 

Scanlist > Auto Address > 
All Entries 

Auto maps all unmapped addresses in all entries. 

 

View > Connection Configuration Displays information respective to the selected connection. 

 

View > Connection Status Switches the view to a display of the status of each connection. 

 

Network > Online Places the Scanlist Configuration Tool in online mode. To go offline, 
click the button or choose Network > Online again. This button is 
unpressed when in online mode. 

 

Help > What’s This? Places the cursor in What’s This? help mode. Place the cursor on the 
control you want help with and right-click to see the 
context-sensitive help. 

 

Within the Scanlist Configuration Tool, you can also view the memory 
usage. 

 

Resource usage 

Scanlist entries 
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The scanlist entries enable you to perform tasks such as defining the 
connection targets and inserting connections for the selected devices. 

 

The status bar, which is located at the bottom of the Scanlist Configuration 
Tool window, provides information about the status of the software and the 
scanner. 

The left portion of the status bar displays informational messages about the 
operation of the configuration software. For example, when you mouse over 
a toolbar icon, a brief description of that icon appears on the status bar. 

The right portion of the status bar displays the following information: 

 Online mode - Offline or Online 

 Edit mode - Monitor or Edit 

 Scanner type 

 IP address/host name 

 Scanner mode - Remote Idle, Idle, Remote Run, Run, or Offline 

The fastest way to configure your EtherNet/IP network is to specify an 
EtherNet/IP driver in RSLinx Classic and let the RSNetWorx for 
EtherNet/IP software browse your online network for EtherNet/IP devices 
and automatically add them into your configuration; and then, let the Scanlist 
Configuration Tool automatically configure connections to your target 
devices. You can follow this same procedure for configuring your network in 
the offline mode by manually dragging and dropping devices from your 
Hardware tab into your network configuration. 

Status bar 

Quick Start steps 
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For some devices, you need additional RSLogix software to complete your  
network configuration (for example, if you have ControlLogix processors on 
your network, then you must use Studio 5000 Logix Designer to complete 
your configuration). 

Tip: There is no offline mode when working with ControlLogix processors. Also, for 
more information on using Studio 5000 Logix Designer and ControlLogix 
processors, refer to the online help for the Scanlist Configuration Tool. 

This section walks you through the tasks you will need to perform to use 
RSNetWorx for EtherNet/IP software in both the online and offline modes. 
To remain focused on the high-level nature of each task and on the flow of 
these tasks, the following steps do not include the step-by-step procedure for 
accomplishing each task. When you are ready to use RSNetWorx for 
EtherNet/IP software, you should follow the detailed procedures found in the 
Quick Start, which is located in the RSNetWorx for EtherNet/IP online help. 

To access the software’s quick start, select Help > Quick Start from the 
RSNetWorx for EtherNet/IP window. To see information about any control 
on the RSNetWorx for EtherNet/IP or Scanlist Configuration Tool windows, 
remember to use the What’s This? help. 

Step 1 - Create a new configuration and browse for an online network 

The first step in using RSNetWorx for EtherNet/IP in the online mode is to 
create a new EtherNet/IP configuration (File > New). Once you create the 
configuration, an empty network displays in the network configuration. 

Tip: These steps assume that you have configured a communication driver in RSLinx 
Classic for communication to the EtherNet/IP network. 

Next, go online and select an EtherNet/IP network using the RSWho Browse 
utility. A graphical representation of the selected network appears in the 
network configuration. If you would like to see a tabular view of the 
information instead of the graphical view, click the Spreadsheet tab. 

Step 2 - Start the Scanlist Configuration Tool and insert a connection 

The Scanlist Configuration Tool is a software tool used to create, modify, 
and delete scanlist entries in a scanner. This tool also allows you to define 
how particular devices communicate on the network. To configure devices 
that contain an internal scanlist, use the Scanlist Configuration Tool. Once 
you open the Scanlist Configuration Tool, you can either insert connections 
to other devices on the network manually, or you can use the auto insert 
feature within the Scanlist Configuration Tool to automatically insert the 
scanlist entries. 

Step 3 - Define a connection target and save your network configuration 

To provide data from the scanner to other devices on the network, you must 
define a connection target. You can define the connection target for the 

Online mode 
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scanner IP address/host name on your network manually. After defining your 
connection targets, the final step is to save your network configuration and 
exit the Scanlist Configuration Tool. 

Step 4 - Diagnose and troubleshoot your online network 

Once you save your configuration, you can diagnose the network and 
determine the status of all of the devices on that network. If any of the 
devices are exhibiting diagnostics problems, you can troubleshoot those 
devices and return your network to proper operating condition. 

Step 1 - Create a new configuration and describe your network topology 

The first step in using RSNetWorx for EtherNet/IP in the offline mode is to 
create a new EtherNet/IP configuration (File > New). Once you create the 
configuration, an empty network displays in the network configuration. 

Next, you can describe your network topology by double-clicking on an 
available device or by dragging it from the Hardware tab and dropping it into 
the network configuration. When you are finished, a graphical representation 
of the selected network appears in the network configuration. If you would 
like to see a tabular view of the information instead of the graphical view, 
click the Spreadsheet tab. 

Step 2 - Start the Scanlist Configuration Tool and insert a connection 

The Scanlist Configuration Tool is a software tool used to create, modify, 
and delete scanlist entries in a scanner. This tool also allows you to define 
how particular devices communicate on the network. To configure devices 
that support the open standard for EtherNet/IP scanners, use the Scanlist 
Configuration Tool. Once you open the Scanlist Configuration Tool, you can 
either insert connections for the scanner IP addresses/host names on your 
network manually, or you can use the auto insert feature within the Scanlist 
Configuration Tool to automatically insert the scanlist entries. 

Step 3 - Define a connection target and save your schedule 

To provide data from the scanner to other devices on the network, you must 
define a connection target. You can define the connection target device for 
the scanner IP address/host name on your network manually. After defining 
your connection targets, the final step is to save your configuration and exit 
the Scanlist Configuration Tool. 

 

Offline mode 
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Chapter 2 

Installing and starting RSNetWorx for 
EtherNet/IP 

This chapter explains how to install and start RSNetWorx for EtherNet/IP 
software. This chapter includes information on the following: 

 system requirements 

 software compatibility 

 installation methods 

 installation procedure 

 starting procedure 

 troubleshooting 

After installing the software, we recommend that you read the release notes 
located in the online help. The release notes may contain more up-to-date 
information than was available when this document was published. To view 
the release notes, start RSNetWorx for EtherNet/IP, and then choose Help > 
Release Notes from the main menu. 

To run RSNetWorx for EtherNet/IP, your system must meet the following 
hardware and software requirements: 

To run RSNetWorx for EtherNet/IP, your system must meet the following 
hardware requirements: 

 An Intel® Core™ 2 Duo processor running at 2.8 GHz or faster or 
another processor with equivalent specifications 

 4 GB or more memory RAM 

 At least 16GB of available hard drive space 

 

To run RSNetWorx for EtherNet/IP, you require one of the following 
operating systems: 

 Windows 10 Enterprise v1803 

 Windows 10 Professional v1803 

 Windows 10 Enterprise v1709 

System requirements 

Hardware requirements 

Software requirements 
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 Windows 10 Professional v1709 

 Windows 10 Enterprise v1703 

 Windows 10 Professional v1703 

 Windows 7 Ultimate with Service Pack 1 

 Windows 7 Enterprise with Service Pack 1 

 Windows 7 Professional with Service Pack 1 

 Windows Server 2016 Standard 

 Windows Server 2016 Datacenter 

 Windows Server 2012 Standard 

 Windows Server 2012 Datacenter 

 Windows Server 2012 R2 Standard 

 Windows Server 2012 R2 Datacenter 

 Windows Server 2008 R2 Standard with Service Pack 1 

 Windows Server 2008 R2 Enterprise with Service Pack 1 

 

RSNetWorx for EtherNet/IP version 28.00 is a component aligned to Studio 
5000 Logix Designer™ version 32.00. This version of RSNetWorx for 
EtherNet/IP has been tested with, and is compatible with the following 
products: 

 FactoryTalk® Activation Manager version 4.03 

 FactoryTalk® Services Platform version 6.10 

 RSLinx® Classic version 4.10 

 RSLogix™ 5 version 9.00 

 RSLogix 500® version 12.00 

 Studio 5000 Logix Designer® version 32.00 

It is recommended that you use all products from the same CPR release. 

RSNetWorx supports two installation methods: Setup wizard installation and 
unattended installation. 

The unattended installation reduces user interaction and provides command 
line parameters to install RSNetWorx. For more information, see Use 
unattended installation on page 57. 

This chapter uses the Setup wizard installation method to illustrate the steps. 

Software compatibility 

Installing RSNetWorx for 
EtherNet/IP software 
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Tip: While installing RSNetWorx for EtherNet/IP software, you will have the 
opportunity to specify a directory. The default directory is: 
x:\Program Files\Rockwell Software\RSNetWorxII 
where x is the drive where the operating system is installed. 
We recommend that you use the default directory whenever possible. This 
subdirectory contains all of the application files required to run the product. 
In procedures that appear throughout this document, it is assumed that you used 
the default name. If you did not use the default name, substitute the actual name 
you specified for the default name shown. 

To install RSNetWorx for EtherNet/IP software, perform the following steps: 

1. Launch the installation wizard and select what to install. 

2. Set up security in RSNetWorx. 

3. Read and accept license agreements. 

4. Start the installation. 

5. Finish the installation. 

1. Close all open programs. 

2. In the RSNetWorx installation package, double-click Setup.exe. 

3. If Microsoft .NET Framework 4 is not installed on your computer, the 
Microsoft .NET Framework Setup dialog box shows. Click Install. 

 

Step 1: Launch the installation 
wizard and select what to 
install 
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4. On the RSNetWorx Setup page, select a language to be shown during 
the installation process if needed. By default, your system language is 
selected. 

 

5. To install RSNetWorx for ControlNet, RSNetWorx for EtherNet/IP, 
and RSNetWorx for DeviceNet, click Install now and skip to Step 2: 
Read and accept license agreements on page 32. 

6. To select a particular software product, click Customize. 
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7. On the Customize page, select RSNetWorx for EtherNet/IP 
v27.00.00 and its components. 

 

8. Select the location for Rockwell Automation software. The default 
location is C:\Program Files (x86)\Rockwell Software. 

9. Click Install. 

On this page, you can set up FactoryTalk Security in RSNetWorx to improve 
the security of your automation system by limiting access to those with a 
legitimate need. 

Step 2: Set up security in 
RSNetWorx 
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1. Select the Enable FactoryTalk® Security option. And then select the 
FactoryTalk directory (Network or Local) that will be used to 
authenticate and authorize user access. 

 

2. Click Install. 

 

End-user license agreements (EULA) spell out your rights and 
responsibilities. Depending on the components being installed, there may be 
more than one license agreement on this page. The individual license 
agreements are listed above the text box. 

Step 3: Read and accept license 
agreements 
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Tip: You can also view the license agreements from the License folder of RSNetWorx 
installation package. 

Some software products may be delivered or made available only after you 
agree to the terms and conditions of each of the license agreements. 

1. On the End User License Agreements page, select each agreement 
and read the agreement carefully. 

2. When all license agreements have been read, click Accept All. 

 

Step 4: Start the installation 
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After accepting the license agreements, the Setup Wizard automatically 
installs all the Rockwell Software applications selected previously. 
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During the installation, if prompted to restart your computer, click Restart 
now. 

 

Step 5: Finish the installation 
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After the installation completes, you need to activate the software for its full 
feature capabilities. You can activate the software now or late. For more 
information about activation, see Activation on page 49. 

 

 To active the software, select Activate your software and click Next. 
Make sure your computer is connected to the Internet. 

In the Software Activation dialog box, enter the required information 
and click Continue. 
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You will be prompted to restart the computer after the activation. 

 

 To finish the installation without activation, Select Skip activation and 
click Next. 
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 To view the installation details, click Installation Summary. 

 To receive latest product updates and patch notification, click 
Register for updates. 

 To install the latest version of Adobe Acrobat Reader, click 
Download it free and follow the on-screen instructions. 

Restart the computer to complete the installation. 

 

As a client to a client-server installation, you can install one or more 
Rockwell Software products from the dedicated server location to an 
end-user destination. To install the RSNetWorx for EtherNet/IP software 
from the server, perform the following steps: 

1. Map a network drive to the dedicated server location provided by your 
system administrator. The system administrator must have copied the 
entire installation contents and provided only Read and Execute 
permissions of the files. Users installing the software cannot have write 
access to the files. 

2. Double-click Setup.exe in the client installation directory. 

Installing a client copy from a 
dedicated server 
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3. See the Installing RSNetWorx for EtherNet/IP software on page 28 
section in this chapter. 

To start RSNetWorx for EtherNet/IP software, click Start > All Programs > 
Rockwell Software > RSNetWorx > RSNetWorx for EtherNet-IP. 

If RSNetWorx for EtherNet/IP does not start up or run properly, consider the 
following: 

 Do you have the correct version of RSLinx Classic installed? 
RSNetWorx for EtherNet/IP requires RSLinx Classic version 4.00. 

 Does your computer have enough memory? Running RSNetWorx for  
EtherNet/IP requires a minimum of 4GB of RAM. 

 Have you reinstalled an earlier Service Pack, or removed a component, 
such as DCOM, that RSNetWorx for EtherNet/IP requires? 

 Have you checked the RSNetWorx support on the web for 
troubleshooting information? Go to 
http://www.rockwellautomation.com/support , click Knowledgebase, 
and search for Tech Notes on RSNetWorx for EtherNet/IP. 

 Do you have the up-to-date compatibility information for the software? 
Go to Product Compatibility and Download Center at 
https://compatibility.rockwellautomation.com/Pages/home.aspx . 

 

Starting RSNetWorx for 
EtherNet/IP 
Troubleshooting 
installation 

http://www.rockwellautomation.com/support
https://compatibility.rockwellautomation.com/Pages/home.aspx
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Chapter 3 

Advanced concepts 

This chapter contains the following sections: 

 EDS-based devices 

 EDS library 

 Class Instance Editor 

RSNetworx for EtherNet/IPTM relies on an electronic data sheet (EDS) for 
configuring devices. An electronic data sheet is an ASCII file that is created 
by the manufacturer and supplied with the device. 

As long as the EDS file for the device you want to configure is registered 
with the RSNetWorx for EtherNet/IP software, you can configure its target 
connection configuration (attributes) and how it will communicate with other 
devices on the EtherNet/IP network. Although the procedure for  
configuring a device is basically the same for all devices, each device has a 
unique set of properties. 

The electronic data sheet (EDS) library is a collection of EDS files that have 
been registered with RSNetWorx for EtherNet/IP. The EDS files, which are 
provided by the device manufacturers, contain configuration and 
identification information for the devices. 

RSNetWorx for EtherNet/IP software can access only those devices that have 
been registered. You must use the EDS Registry Wizard for registering EDS 
files for unknown devices, or if you have updated EDS files to install.  To 
access the EDS Wizard, select Tools > EDS Wizard. 

Although you get a large number of electronic data sheet (EDS) files with the 
RSNetWorx for EtherNet/IP software, there may be a time when you need to 
acquire/create additional EDS files. The most common ways to get these files 
are to: 

 obtain them on distribution media that accompany the devices. 

 download them from EtherNet/IP sites on the world wide web. You 
can either select the device in the network configuration, right-click the 
mouse and select Re-register Device, and click Download EDS File in 
the EDS Wizard or access one of the following world wide web sites 
from which EDS files are available: 

EDS-based devices 

EDS library 
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 https://www.rockwellautomation.com/global/support/networks/eds.
page?  (Allen-Bradley technical support site) 

 download them from a different manufacturer’s site. 

The Class Instance Editor is a tool that allows you to send data to, and read 
data from, an EtherNet/IP device that is not otherwise configurable with 
RSNetWorx for EtherNet/IP. Using the Class Instance Editor, you can either 
enter raw data and download it to the device, or read the data from the 
device. 

Important: We do not recommend configuring devices with the Class Instance Editor 
unless you are instructed to do so by technical support personnel for the 
hardware product. 

To use the editor, you will need to know the service code, class, instance, and 
attribute by their appropriate hexadecimal codes within the device. This 
information may be on the printed data sheet accompanying the device. 

Tip: For further information about configuring a device with the Class Instance Editor, 
contact the manufacturer of the device. For more information on how to enter data 
into the Class Instance Editor, contact Rockwell Automation technical support. 

 

 

Class Instance Editor 

https://www.rockwellautomation.com/global/support/networks/eds.page?
https://www.rockwellautomation.com/global/support/networks/eds.page?


 

 Rockwell Automation Publication ENET-GR001J-EN-E - November 2018 43 

Chapter 4 

Finding the information you need 

This chapter describes how to: 

 Use the online help 

 Access product manuals 

 Participate in Rockwell Software training courses 

 Contact technical support 

RSNetWorx for EtherNet/IPTM online help provides general overview 
information, comprehensive step-by-step procedures, and context-sensitive, 
dialog box control definitions for working with all of the features in the 
software. To view online help while running RSNetWorx for EtherNet/IP: 

 choose Contents from the Help menu on the RSNetWorx for 
EtherNet/IP main window 

 click Help on any RSNetWorx for EtherNet/IP dialog box or property 
page 

 position the cursor over a control with which you want help and 
right-click 

 press F1 

 click the What’s This? icon located in the toolbar or in the upper right 
corner of dialog boxes, then click any control 

 

Using the online help 

Accessing help for a control or 
field 



Chapter 4 Finding the information you need 

 

44 Rockwell Automation Publication ENET-GR001J-EN-E - November 2018 

To display a definition for a control or a field, click the What’s This? icon in 
the upper right corner of the dialog box, drag the cursor to the selected area, 
and then click to display the definition. You can also right-click on a control 
to display the definition. In this example, the PanelView properties page was 
selected. 

 

The Message view, which appears in the bottom portion of the workspace, 
displays a log of messages. This view may contain informational, warning, 
and/or error messages. 

 

To troubleshoot a particular message, you can select the message and press 
the F1 key or right-click on the message and select Troubleshoot to access 

Accessing help for messages 



Finding the information you need Chapter 4 

 

 Rockwell Automation Publication ENET-GR001J-EN-E - November 2018 45 

the online help. For example, if you select the ENET:8282 message code 
shown here and press F1, the "The online scanlist in address 192.168.1.6 
does not match its scanlist in the offline file" troubleshooting help topic 
displays. 

 

From the message view, you can also select a message and choose View > 
Messages > Troubleshoot to display online help for the message. You can 
also show, clear, and/or clear and hide messages by making the appropriate 
selection from the View > Messages command on the main menu. The copy 
menu item copies the selected message to the Windows clipboard so it can be 
pasted into other applications (for example, an e-mail message). 

To view a list of tasks related to the task-based topic, move to the What do 
you want to do? section at the bottom of the help window and select one of 
the listed tasks. The contents pane of the help window is updated, displaying 
a step by step procedure for completing the selected task. 

Finding step-by-step 
procedures 
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For example, from the Define or Edit a chassis help topic, if you select 
Change a device’s slot position under the What do you want to do? section, 
the help topic that describes how to change a device’s slot position replaces 
the original help topic. Also, in the Change a device’s slot position help 
topic, How do I access the dialog? is a drop down navigational tip. 

 

Finding definitions 
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Within the RSNetWorx for EtherNet/IP help, blue highlighted text with an 
underline indicates a pop-up definition or a link to a related topic. For 
example: 

 

You can gain immediate access to product documentation through the Online 
Books feature in RSNetWorx for EtherNet/IP. Product Manuals includes this 
Getting Results Guide, as well as many reference guides, in an electronic 
book format. Select Help > Product Manuals to access this documentation. 

 

One of the best ways to increase your proficiency at using Rockwell 
Software products is to attend a Rockwell Automation training program. Our 
training programs can help you master the basics and show you how to 
unleash the full potential of our software. 

We offer a wide range of training programs, from regularly scheduled classes 
conducted at Rockwell Software facilities, to custom-tailored classes 

Accessing the Product 
Manuals 

Training 
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conducted at your enterprise. The size of each class is kept small 
intentionally to maximize student engagement. 

If you would like more information about our training programs, visit the 
Rockwell Software website or contact the Rockwell Automation Training 
Coordinator. Our website address and telephone numbers appear on the 
inside front cover of this document. 

Tip: For more information on Rockwell Automation training, go to the Training Services 
website: 
http://www.rockwellautomation.com/global/products/training/overview.page?  

 

If you cannot find answers to your questions in the Getting Results with 
RSNetWorx for EtherNet/IP guide, the online help, or the Online Books 
documentation, you can call Rockwell Software Technical Support at the 
numbers listed on the inside front cover of this guide. You can also access 
the Rockwell Software Online Support Library and receive information about 
Autofax Product Information System from the website listed on the inside 
front cover of this guide. 

When you call, you should be at your computer and prepared to give the 
following information: 

 product serial number and product version number 

 The product serial numbers and version number can be found in the 
software by selecting Help > About RSNetWorx 

 hardware you are using 

 operating system plus service packs, and version of Internet Explorer 
(if any) installed 

 exact wording of any errors or messages that appeared on your screen 

 description of what happened and what you were doing when the 
problem occurred 

 description of how you attempted to solve the problem 

Tip: For more information on Rockwell Software training, go to the Training Services 
website:  
http://www.rockwellautomation.com/global/products/training/overview.page?  

 

 

Technical support 

When you call 

http://www.rockwellautomation.com/global/products/training/overview.page?
http://www.rockwellautomation.com/global/products/training/overview.page?
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Appendix A 

Activation 

RSNetWorx for EtherNet/IP supports only FactoryTalk activation. If you are 
a new user, you will need to activate your software using FactoryTalk 
Activation. 

RSNetWorx for EtherNet/IP supports the following types of activation: 

Node-locked activation 

This type of activation can be either locked to a particular piece of hardware, 
such as an EtherNet card or a hard disk of a stand-alone computer, or to a 
hardware dongle. Depending upon the kind of device (stand-alone computer 
or hardware dongle) you want to activate, you can purchase either 

 Local "node-locked" activation: This kind of activation activates 
software only on a single computer. If the activation file is copied to 
another computer, the software will not run on that other computer, or 

 Mobile "node-locked" activation: This kind of activation is locked to 
hardware dongle. A dongle is a security or copy protection device that 
must be connected to the computer while the program runs. The 
activation files can be copied to multiple computers, but the software 
activates only on the computer where the dongle is connected. 

Concurrent activation 

This type of activation allows multiple computers across a network to use 
Rockwell Software products at the same time. There are two kinds of 
concurrent activations: 

 Floating activations: activations that "float" from an activation server 
to any computer that needs them. 

 Borrowed activations: activations that are retrieved from a server for a 
specific period of time before expiring and returning automatically to 
the pool of available activations on the server. 

For more information about FactoryTalk Activation, refer to the FactoryTalk 
Activation Manager help. 

You can activate your copy of RSNetWorx on the Software Activation 
dialog box towards the end of installation. If you skipped the activation 
during installation, activate RSNetWorx using the FactoryTalk Activation 
Manager installed during the installation process. 

Activate RSNetWorx with 
FactoryTalk Activation 

How to activate RSNetWorx 
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For help with FactoryTalk Activation at any point, you can click: 

 the Help button in FactoryTalk Activation Manager 

 the Help link on the Rockwell Software Activation website: 
https://activate.rockwellautomation.com/  

 View How to Activate Rockwell Software Products on the Required 
Steps of the Install program 

If you cannot connect to the Internet, call Technical Support for help creating 
an activation file from an e-mail or a fax. 

Phone: 440-646-3434 in North America. Outside of North America, call your 
local support organization. 

In RSNetWorx for EtherNet/IP v9.00.00 (CPR 9 Service Release 1) and 
later, the software supports a seven day activation grace period when a valid 
activation is not found. During grace period: 

 If RSNetWorx is started and an activation key is not present, the 
software shall enter grace period and run with full functionality. 

 Once RSNetWorx has entered grace period, the software shall check 
for an activation key every four hours. If the activation is not found, a 
message will be generated to FactoryTalk Diagnostics. 

 RSNetWorx can be started an unlimited number of times while in 
grace period and be able to run with full functionality. If the grace 
period ends and a valid activation has not been found, RSNetWorx 
shall run in Demo mode. 

 While RSNetWorx is running, the software cannot change modes. 
RSNetWorx can only change to Demo mode when the software is 
restarted and/or grace period has already expired. 

Tip: If RSNetWorx is unable to successfully obtain valid activations (for example, a 
network failure occurs), the software will attempt run in grace period for up to 
seven days. 

 

Following are some common problems that people encounter with activation 
and their solutions. 

If you have lost the activation because the activation file is damaged, you 
need to reset activation. Follow the Reset Codes instructions on the 
Rockwell Software Technical Support web page, or call the technical support 
telephone number. The web page and telephone number are both listed on the 
inside front cover of this guide. 

Finding more information 
about FactoryTalk Activation 

Grace period 

Some common questions 

My activation files were damaged. 
What should I do? 

https://activate.rockwellautomation.com/
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No. Deleting the program files does not delete your activation. The 
activation files are not stored in the program directory; they are located in the 
root directory. Your activation files will not be lost unless you format the 
hard drive, tamper with hidden files in the root directory, or perform certain 
other hard drive operations (refer to the "Protecting your activation files" 
section in this chapter for more information). 

To get the software running again, simply reinstall the software, but do not 
move the activation when given the opportunity. 

 

I accidentally deleted the software 
directory on my hard drive. Do I need 
to call Rockwell Software for 
replacement activation files? 
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Appendix B 

Security 

FactoryTalk Security™ is intended to improve the security of your 
automation system by limiting access to those with a legitimate need. 
FactoryTalk Security authenticates user identities and authorizes user 
requests to access a FactoryTalk-enabled system. These security services are 
fully integrated into the FactoryTalk Directory and are included as part of the 
FactoryTalk Services Platform that installs with many products. 

For more information on how to use security services, refer to FactoryTalk 
Security’s Online help. 

RSNetWorx supports FactoryTalk Security. FactoryTalk Security™ is 
intended to improve the security of your automation system by limiting 
access to those with a legitimate need. FactoryTalk Security authenticates the 
identities of users and authorizes user requests to access a 
FactoryTalk-enabled system against a set of defined user accounts and access 
privileges held in the FactoryTalk Directory. For more information on 
FactoryTalk Security, refer to the ‘About FactoryTalk Security’ topic in 
RSNetWorx for EtherNet/IP Online Help. 

Follow the steps below to set up security in RSNetWorx: 

How do I set up security in 
RSNetWorx? 
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1. During RSNetWorx’s installation, you will see the RSNetworx 
Security Configuration Selection page. On this page, select the 
Enable FactoryTalk® Security option. And then select the 
FactoryTalk Directory (Network or Local) that will be used to 
authenticate and authorize user access. 

 

2. Click Install to continue the RSNetWorx installation. 

3. Follow the screen instructions to complete the installation. 

RSNetWorx implements FactoryTalk Security through three securable 
actions: Access, Modify, and Go Online. These securable actions let you 
restrict user access to actions, such as opening a project file, creating a new 
project file, making changes to a project file, uploading or downloading to a 
device, browsing to a device from the network, viewing the properties of a 
device, etc., in RSNetWorx. 

What can I secure in 
RSNetWorx? 
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Securable action Description 

Access The Access securable action allows you to perform actions such as opening an 
offline project file for viewing, viewing the properties of a device, etc. 

Modify The Modify securable action allows you to perform actions such as creating a 
project file, making changes to a project file, saving any pending edits, etc. 
Note: To modify a project file, you need both Access (to open the file) and Modify 
(to make changes) securable actions. 

Go Online The Go Online securable action allows you to download information saved in a 
project file or upload information into a project file, as well as browse to a device 
on the network. 

Tip: To download information saved in an existing project file, you need 
Access (to open the file), Go Online (to go online to prepare to 
download), and Modify (to download) securable actions. 
To upload information into an existing project file, you need Access (to 
open the file), Go Online (to go online to prepare to upload), and 
Modify (to upload) securable actions. 
To upload information into a new project file, you need Go Online (to 
go online to upload) securable action. 

 

To allow or deny user access to one or more of the above securable actions, 
you will need to: 

1. Start FactoryTalk Administration Console from Start > Programs > 
Rockwell Software > FactoryTalk Administration Console. You 
will see the Log On to FactoryTalk screen, as shown below. 

 

2. Enter your username and password, and select the directory you want 
to log on to. (The username and password were set when you set up an 
account during FactoryTalk Directory configuration.) 

Tips for choosing a directory: 
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 Click Network to access Network (also called Distributed) 
applications on the Network Directory Server. 

 Click Local to access Local (also called Stand-alone) applications 
on the Local Directory. Local applications are always located on 
your local computer. You cannot access local applications 
remotely. 

 If you cannot log on to a particular directory on your computer, it 
may be because it has not yet been configured. For more 
information, refer to the Right FactoryTalk Directory is not 
configured on this computer topic in FactoryTalk help. You can 
launch FactoryTalk Help from FactoryTalk Administration 
Console. 

3. In FactoryTalk Administration Console, click on the RSNetWorx 
folder (located under System > Policies > Product Policies), to 
expand it. You will see the Feature Security file. 

4. Double-click the Feature Security file to launch the Feature Security 
Properties dialog box. 

 

5. In the Feature Security Properties dialog box, click the securable action 
you want to grant the user access to. 

6. In the Configure Securable Action dialog box, from the list of users, 
select the user you want to grant access to, and click Add. 

Tip: For more information on FactoryTalk and FactoryTalk Security, refer to RSNetWorx 
for EtherNet/IP Online Help. 
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Appendix C 

Use unattended installation 

The unattended installation is an automated installation method that you can 
use to install RSNetWorx. You can typically use the unattended installation 
during large-scale rollouts when it might be too slow and costly to have 
administrators or technicians interactively install the RSNetWorx software 
on individual computers. 

In the unattended installation, you enter a specified command line with 
multiple parameters. During the installation process, instead of prompting 
you for installation and configuration information interactively, the process 
follows the parameters you specified in the command lines. 

For detailed description about each parameter, see Parameters. You can also 
type Setup /? in the Command Prompt window, and press Enter to view 
the help information of all parameters and examples. 

To install RSNetWorx in the unattended mode, follow the steps below. The 
steps may vary slightly. Follow the on-screen instructions that apply to your 
operating system. 

1. Close all open Windows programs. 

2. Open the Command Prompt window. 

3. In the Command Prompt window, navigate to D:, where D: is the 
drive containing the RSNetWorx installation DVD or installation 
package, and press Enter. 

Tip: The User Account Control dialog box may show after you press Enter, click Yes 
to continue. The unattended installation requires the administrator permission. 

4. Type a command line with the following syntax: 

Setup {/Q | /QS} 

/IAcceptAllLicenseTerms 

[/AutoRestart] 

[/SetupLanguage=language] 

[/ProductLanguage=product_language] 

[/InstallLocation=location] 

[/SerialNumber=serial_number] 

Perform unattended 
installation 
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[/ProductKey=product_key] 

[/Version=product_version] 

5. Press Enter. The installation process starts with the parameters you 
specified. 

The parameters and values are not case sensitive. If the value includes 
spaces, you need to enclose it in quotation marks (" "). 

If your installation package is Personalized Edition, the following parameters 
will be ignored during installation: 

 /SerialNumber 

 /ProductKey 

/Q 

Required if /QS or /Record is not specified. 

Installs the product in the silent mode without any user interface. 

/QS 

Required if /Q or /Record is not specified. 

Installs the product in the unattended mode without user interaction 
during installation, and shows the progress, errors, or complete 
messages on the user interface. 

/IAcceptAllLicenseTerms 

Required. Specified that you read and acknowledge all license 
agreements, and agree to continue the installation. 

/AutoRestart 

Optional. If specified, the computer will be restarted automatically 
after the installation if a restart is required to complete the installation. 

The parameter is ignored if a restart is not required. 

/SetupLanguage=setup_language 

Optional. Specifies which language will be displayed during the 
installation process. The value must be the one of ENU, CHS, DEU, 
ESP, FRA, ITA, JPN, KOR, or PTB. 

If it is omitted or if the specified language is not available, the default 
language is the user or system user interface language. 

/Record 

Parameters 
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Optional. Records the installation options chosen to a recoding file. 

/Playback 

Optional. Plays back a recording file to specify the installation options. 

/ProductLanguage=product_language 

Optional. Specifies which language of components will be installed. 
The value must be the one of ENU, CHS, DEU, ESP, FRA, ITA, 
JPN, KOR, or PTB. 

If it is omitted or if the specified language is not available, the default 
language is the same as SetupLanguage. 

/InstallLocation=location 

Optional. Specifies the installation location. 

If omitted, the default location is "C:\Program Files (x86)\Rockwell 
Software" (64-bit) or "C:\Program Files\Rockwell Software" (32-bit). 

/SerialNumber=serial_number 

Optional. Specifies the serial number that is required if you want to get 
activation keys during installation. 

/ProductKey=product_key 

Optional. Specifies the product key that is required if you want to get 
activation keys during installation. 

/Version=product_version 

Optional. Specifies the version corresponding to the product version 
that the SerialNumber and ProductKey are able to activate if you 
want to get activation keys during the installation. 

If omitted, the installer uses a default version which is the most recent 
product version available when retrieving the activation. 

The following examples show how to use the commands during the 
unattended installation. 

Example 1: 

Setup.exe /Q /IAcceptAllLicenseTerms 

means: 

 The installation uses the default settings during the installation process. 

Examples 
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Example 2: 

Setup.exe /QS /IAcceptAllLicenseTerms /AutoRestart 
/SetupLanguage=CHS /SerialNumber=0123456789 
/ProductKey=ABCDE-FGHIJ /Version=27.00.00 

means: 

 During the installation, the displayed language is Chinese. 

 The setup will get activation keys for RSNetWorx version 27.00.00 
during installation if the serial number 0123456789 and product key 
ABCDE-FGHIJ are valid. 

 After the installation, if a restart is required, the computer will be 
restarted automatically. 
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Glossary 

Activation file — A hidden, read-only, system file that "activates" a 
Rockwell Software product. The software will run only if your system can 
find the correct activation file. 

Activation key — Activation files contain a database of activation keys. 
Each key is particular to a certain product and must be accessible on a local 
or remote drive for that product to run. 

Bridge — A multi-port device that connects network segments that use 
different physical media. Bridges also monitor network traffic, building and 
maintaining internal tables that list the port on which each Ethernet address 
resides. When a bridge receives a packet destined for a particular address, the 
bridge transmits the packet again only on the port at which the device 
resides. Each port on a bridge represents a separate collision domain. 

Connection — An open, logically binding communication path between two 
devices on a EtherNet/IP network.  Connections can be either point to point 
or multicast connection. 

Connection ID — An identifier assigned to a particular connection between 
producers and consumers that specifies select application information. 

Connection type — The connection type indicates the data ownership of a 
node. It defines the rule for how the connection entry controls outputs to the 
rack, module, or device. The following are standard connection types: 

 Exclusive Owner - specifies an independent connection where a single 
device controls the output states in the target device. If you have an 
existing Exclusive Owner connection to a target device, you cannot 
specify another Exclusive Owner or Redundant connection to that 
same target device. 

 Input Only - specifies an independent connection where a device 
receives inputs from the target device and sends configuration data to 
the network. An Input Only connection does not send outputs; it only 
receives inputs. You can specify multiple Input Only connections to 
the target device from different originators. 

 Listen Only - specifies a dependent connection where a device 
receives  inputs from the target device, but does not send 
configuration data with the network. A Listen Only connection only 
functions properly when another non-Listen Only connection exists to 
the same target device. A Listen Only connection does not send 
outputs; it only receives inputs. You can specify multiple Listen Only 
connections to the target device from different originators. 
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Tip: All Listen Only connections will be terminated when all non-Listen Only 
connections are terminated. 

Consumer — A node that receives data from a producer on a EtherNet/IP 
link. 

Cut-through switching — Cut-through switching starts sending packets as 
soon as they enter a switch and their destination address is read. The entire 
frame is not received before a switch begins forwarding it to the destination 
port. This reduces transmission latency between ports, but it can propagate 
bad packets and broadcast storms to the destination port. 

EtherNet/IP network — An industrial automation network standard that is 
sponsored by EtherNet/IP International. 

FactoryTalk is a manufacturing information platform that integrates 
plant-wide control systems and connects the enterprise with the production 
facility. 

 The FactoryTalk Automation Platform: 

 provides common services (such as diagnostic messages and access to 
real-time data) and shares plant resources (such as tags and graphic 
displays) throughout a production facility 

 allows defining plant-floor resources once, and then allows 
simultaneous access to those resources across product boundaries 

 supports centralized security services 

FactoryTalk Administration Console — Part of the FactoryTalk 
Automation Platform, FactoryTalk Administration Console is an optional, 
stand-alone tool that allows you to: 

 Create and configure application, area, and data server elements in the 
FactoryTalk Directory. 

 Back up and restore an entire directory or an individual application. 

 Set up redundancy for OPC data servers. 

 Configure client computers to recognize the location of a FactoryTalk 
Directory Server computer. 

 Configure options for routing and logging diagnostic messages. 

 View system-wide diagnostic messages. 

 Configure system-wide policy settings. 

 Secure your FactoryTalk-enabled system with FactoryTalk Security™ 
services. 

Run FactoryTalk Administration Console from the Windows Start menu: 
Start > Programs > Rockwell Software > FactoryTalk Administration 
Console. 
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FactoryTalk Directory — FactoryTalk Directory provides a central lookup 
service for software products participating in a FactoryTalk-enabled 
automation system. 

The FactoryTalk Automation Platform includes two separate directories: a 
Local Directory and a Network Directory. Either directory, or both 
directories, can be configured on the same computer. Project information, 
including security settings, cannot be shared between a Local Directory and 
Network Directory, even if both directories are configured on the same 
computer. Create and configure application, area, and data server elements in 
the FactoryTalk Directory. 

 Local Directory — all project information and participating software 
products are located on a single computer, and the FactoryTalk-enabled 
system cannot be shared across a network or accessed remotely. 

 Network Directory — organizes project information from multiple 
software products across multiple computers on a network. 

Some FactoryTalk-enabled products require a Network directory, others 
require only a Local directory, and some require that both directories be 
configured. 

Gateway — The term gateway has many different meanings.  For example: 
a device that performs protocol conversion between different types of 
networks or applications.  Such gateway function at the transport layer and 
above. They perform complete conversions from one protocol to another 
rather than simply supporting one protocol from within another.  Sometimes 
router can implement such gateway functions; and a device that acts as a 
go-between connecting two or more networks that use the same protocols.  
In this case, the gateway functions as an entry/exit point to the network.  
Transport protocol conversion may not be required, but some form of 
processing is typically performed. 

Hub — A hub is a common wiring point for star-topology networks. Hubs 
have multiple ports to attach the different cable runs. Some hubs include 
electronics to generate and time the signal between each hub port. Others act 
as signal splitters, similar to the multi-tap cable-TV splitters you might use 
on your antenna coax. Some route the network signals to each active device 
in series, while other hubs distribute received signals out all ports 
simultaneously. 

Internet Group Management Protocol (IGMP) snooping — This protocol 
constrains the flooding of IP multicast traffic by dynamically configuring the 
switch interfaces so that multicast traffic is forwarded only to those interfaces 
associated with IP multicast devices. 

Multicast connection — A connection made from one node to many nodes. 
Multi-cast connections allow multiple consumer nodes the ability to receive 
data from a single producer node. 
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Node — A node is a EtherNet/IP address. When a device is added to the 
network, it is assigned a node address.. 

Offline Configuration File — In RSNetWorx for EtherNet/IP,  the offline 
configuration file (*.enet) contains network configuration information 
(including scanlist data, device and chassis definitions, rack size and density, 
etc.).  When online, the download operation applies all of the offline 
configuration information to the online network and the upload operation 
applies all of the network configuration information obtained from the online 
network to the offline configuration file. 

Point-to-point connection — A connection made between two nodes only. 

Producer — A node that is responsible for transmitting data on a 
EtherNet/IP link. 

Requested Packet Interval — The requested packet interval (RPI) value is 
determined by how often you want a particular piece of I/O or scheduled 
peer-to-peer data to be transmitted within the scheduled bandwidth of the 
NUI. 

Router — A router is a device that forwards traffic between networks based 
on the network layer information in the data and on the routing tables that it 
maintains. The router builds up a logical picture of the overall network in its 
routing tables, and then uses this information to choose the best path for 
forwarding network traffic. 

Scanlist Configuration Tool (SCT) — A program that maps processor 
memory onto the network and network data into processor memory. SCTs 
are scanner-specific; therefore, a unique SCT is required for each type of 
scanner. 

Scanner — A EtherNet/IP device that is a connection originator. 

Scanner class device — A device that initiates connections and contains a 
scanlist. Refer to the RSNetWorx for EtherNet/IP online tutorial for more 
information. 

Scanner signature — Indicates a hexadecimal value, unique to the open 
scanner, that is assigned to scanner devices that originate scheduled 
connections. This value is stored in the open scanner and in the offline 
configuration, and is used to determine if the offline configuration is 
synchronized. 

Segment — A section of a local area network (LAN) that is used by a 
particular workgroup or department and separated from the rest of the LAN 
by a bridge, router, or switch.  Networks are divided into multiple segments 
for  security and to improve traffic flow by filtering out packets that are not 
destined for the segment.  

Switch — A switch evolved from the bridge.  Like traditional bridges, 
switches build and maintain internal tables that map Ethernet addresses to a 
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port.  A packet received on one port is rapidly switched to the appropriate 
output port (typically within microseconds).  Each port on the switch is its 
own collision domain, so collisions between devices attached to the switch 
do not occur. 

A switch segments a network into many parallel dedicated lines to produce a 
contention-less, scalable architecture.  The switch establishes a direct line of 
communication between two ports and maintains multiple simultaneous links 
between various ports.  The switch uses addressing information in each 
Ethernet frame to forward data only to the port connected to the destination 
device.  The switch manages network traffic by reducing media sharing 
since the traffic is directed only to the segment for which it is destined.   

There are two basic methods of switching: cut-through and 
store-and-forward. 

Store and forward switch — Store-and-forward switching buffers incoming 
packets in memory until they are fully received and a cyclic redundancy 
check (CRC) is performed. This reduces bad packets and collisions that can 
adversely effect the overall performance of the segment. However, the 
buffering adds latency to the processing time. The latency increases in 
proportion to the frame size. 

Cut-through switch — Cut-through switching starts sending packets as soon 
as they enter a switch and their destination address is read. The entire frame 
is not received before a switch begins forwarding it to the destination port. 
This reduces transmission latency between ports, but it can propagate bad 
packets and broadcast storms to the destination port. 
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Rockwell Automation support 
Rockwell Automation provides technical information on the web to assist you in using its products. At 
http://www.rockwellautomation.com/support  you can find technical and application notes, sample code, and links to software service 
packs. You can also visit our Support Center at https://rockwellautomation.custhelp.com  for software updates, support chats and forums, 
technical information, FAQs, and to sign up for product notification updates. 

In addition, we offer multiple support programs for installation, configuration, and troubleshooting. For more information, contact your 
local distributor or Rockwell Automation representative, or visit http://www.rockwellautomation.com/services/online-phone . 

Installation assistance 

If you experience a problem within the first 24 hours of installation, review the information that is contained in this manual. You can 
contact Customer Support for initial help in getting your product up and running. 

United States or Canada 1.440.646.3434 

Outside United States or Canada Use the Worldwide Locator available at http://www.rockwellautomation.com/locations , or contact your local Rockwell 
Automation representative. 

 

New product satisfaction return 

Rockwell Automation tests all of its products to ensure that they are fully operational when shipped from the manufacturing facility. 
However, if your product is not functioning and needs to be returned, follow these procedures. 

United States Contact your distributor. You must provide a Customer Support case number (call the phone number above to obtain one) to 
your distributor to complete the return process. 

Outside United States Please contact your local Rockwell Automation representative for the return procedure. 

 

Documentation feedback 

Your comments will help us serve your documentation needs better. If you have any suggestions on how to improve this document, 
complete the feedback form, publication RA-DU002 

 

http://www.rockwellautomation.com/support
https://rockwellautomation.custhelp.com/
http://www.rockwellautomation.com/services/online-phone
http://www.rockwellautomation.com/locations
http://literature.rockwellautomation.com/idc/groups/literature/documents/du/ra-du002_-en-e.pdf
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