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FOREWORD

Scope and Intended Audience

Scope. This publication describes how to install, configure, administer and use 
the Avamar Exchange Client. 

Intended Audience. The information in this publication is primarily intended 
for:

• System administrators who are responsible for installing software and 
maintaining servers and clients on a network

• Microsoft Exchange Administrators who are responsible for backing up and 
maintaining Microsoft Exchange servers

Prerequisites. Persons using this publication should have current practical 
experience with the following:

• Operating system shell commands on your Exchange platform (root 
permission required)

• The specific version of Microsoft Exchange currently deployed at your site

Product Information
For current documentation, release notes, software updates, as well as 
information about EMC products, licensing and service, go to the EMC Powerlink 
web site at http://Powerlink.EMC.com.
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 Typeface Conventions
FOREWORD
Your Comments
Your suggestions will help us continue to improve the accuracy, organization and 
overall quality of the user publications. Please send your opinion of this document 
to:

SSGDocumentation@emc.com 

Please include the following information:

• Product name and version
• Document name, part number and revision (for example, A01)
• Page numbers
• Other details that will help us address the documentation issue

Typeface Conventions
The following table provides examples of standard typeface styles used in this 
publication to convey various kinds of information.

EXAMPLE DESCRIPTION

Click OK.
 - or -
Select File > Close.

Bold text denotes actual Graphical User Interface 
(GUI) buttons, commands, menus and options (any 
GUI element that initiates action).
Also note in the second example that sequential 
commands are separated by a greater-than (>) 
character. In this example, you are being instructed 
to select the Close command from the File menu.

Type:
 cd /temp

Bold fixed-width text denotes shell commands that 
must be entered exactly as they appear in this 
publication.

--logfile=FILE All caps text often denotes a placeholder (token) 
for an actual value that must be supplied by the 
user. In this example, FILE would be an actual 
filename. 

Installation Complete. Regular (not bold) fixed-width text denotes 
command shell messages. It is also used to list 
code and file contents.
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 Notes, Tips and Warnings
FOREWORD
Notes, Tips and Warnings
The following kinds of notes, tips and warnings appear in this publication:

IMPORTANT:  This is a warning. Warnings always contain
information that if not heeded could result in unpredictable
system behavior or loss of data. 

TIP:  This is a tip. Tips present optional information intended
to improve your productivity or otherwise enhance your
experience with our product. Tips never contain information
that will cause a failure if ignored.

NOTE:  This is a general note. Notes contain ancillary infor-
mation intended to clarify a topic or procedure. Notes never
contain information that will cause a failure if ignored.
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INTRODUCTION

The Avamar Exchange Client provides a complete backup and recovery solution for 
Microsoft Exchange Server 2007, 2003 and 2000 platforms.

Important Terms and Concepts
Recovery data stored in an Avamar system is inherently on line all the time. Once 
an Exchange server has been backed up to the Avamar system, the entire 
Exchange server or one or more Exchange message folders can be quickly 
recovered without having to locate and mount tape media. 

Exchange 2003 and 2000. On Exchange 2003 and 2000 platforms, the 
Avamar Exchange Client adds two plug-ins to the Exchange server — an Avamar 
Exchange Database plug-in for backing up and restoring the Exchange database 
and a MAPI-based Avamar Exchange Message plug-in for backing up and restoring 
the Exchange message folders within individual mailboxes.

Exchange 2007. On Exchange 2007 platforms, the Avamar Exchange Client 
adds two plug-ins to the Exchange server — an Avamar Exchange Database plug-
in for backing up and restoring the Exchange database and a MAPI-based Avamar 
Exchange Message plug-in for backing up and restoring the Exchange message 
folders within individual mailboxes.

Standalone and High-Availability Deployments

Microsoft Exchange Server can be deployed in various configurations. 

The simplest configuration is a single Windows network host running Microsoft 
Exchange Server. This will be referred to as a “standalone” configuration in the 
remainder of this publication.

However, most larger enterprises typically deploy Microsoft Exchange Server in 
some “high-availability” configuration. This typically involves the use of Windows 
clusters, Exchange 2007 replication, or both.
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 Important Terms and Concepts
INTRODUCTION
Windows Clusters

Windows clusters comprise at least two servers (SERVER-A and SERVER-B) and 
some amount of shared external storage. 

For purposes of our discussion, it is crucial to understand that Windows clusters 
are not application specific. A Windows cluster can host any windows application, 
including Microsoft Exchange.

Exchange 2007 Replication

Beginning with Microsoft Exchange 2007, Microsoft has built data replication 
features directly into Exchange. These features allow Exchange data to be 
replicated from one Exchange server to another.

Exchange 2007 offers three levels of data replication:

• Local Continuous Replication (LCR)
• Cluster Continuous Replication (CCR)
• Standby Continuous Replication (SCR)

NOTE:  The following discussion regarding various aspects of
Microsoft Exchange 2007 replication draws heavily on con-
tent authored by Microsoft Corporation. 

However, a complete discussion of Exchange 2007 replica-
tion is beyond the scope of this publication. Refer to your
Microsoft Exchange 2007 documentation for additional infor-
mation. 

Local Continuous Replication (LCR)

Local continuous replication (LCR) is a single-server solution that uses built-in 
asynchronous log shipping and log replay technology to create and maintain a 
copy of a storage group on a second set of disks that are connected to the 
same server as the production storage group. The production storage group is 
referred to as the active copy, and the copy of the storage group maintained 
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 Important Terms and Concepts
INTRODUCTION
on the separate set of disks is referred to as the passive copy. The following 
illustration shows a basic LCR deployment.

LCR deployments do not require any special Avamar Exchange Client set up or 
configuration. Install the Avamar Exchange Client software on the active 
storage group using the normal (non-cluster) installation procedure. Refer to 
Installing/Uninstalling Avamar Exchange Client (page 19) for additional 
information.

Cluster Continuous Replication (CCR) and Standby Continuous Replication (SCR)

Cluster continuous replication (CCR) is a high availability feature of Microsoft 
Exchange Server 2007 that combines the asynchronous log shipping and 
replay technology built into Exchange 2007 with the failover and management 
features provided by the Windows Cluster service.

CCR is designed to provide high availability for Exchange 2007 Mailbox servers 
by providing a solution that:

• Has no single point of failure
• Has no special hardware requirements
• Has minimal shared storage requirements
• Can be deployed in one or two datacenter configurations

CCR uses the database failure recovery functionality in Exchange 2007 to 
enable the continuous and asynchronous updating of a second copy of a 
database with the changes that have been made to the active copy of the 
database. During installation of the passive node in a CCR environment, each 
storage group and its database is copied from the active node to the passive 
node. This operation is called seeding, and it provides a baseline of the 
database for replication. After the initial seeding is performed, log copying and 
replay are performed continuously.

In a CCR environment, the replication capabilities are integrated with the 
Cluster service to deliver a high availability solution. In addition to providing 
data and service availability, CCR also provides for scheduled outages. When 
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updates need to be installed or when maintenance needs to be performed, an 
administrator can move a clustered mailbox server (called an Exchange Virtual 
Server in previous versions of Exchange Server) manually to a passive node. 
After the move operation is complete, the administrator can then perform the 
needed maintenance.

CCR can be combined with standby continuous replication (SCR) to replicate 
storage groups locally in a primary data center (using CCR for high availability) 
and remotely in a secondary or backup datacenter (using SCR for site 
resilience). The secondary datacenter could contain a passive node in a 
failover cluster that hosts the SCR targets. This type of cluster is called a 
standby cluster because it does not contain any clustered mailbox servers, but 
it can be quickly provisioned with a replacement clustered mailbox server in a 
recovery scenario. If the primary datacenter fails or is otherwise lost, the SCR 
targets hosted in this standby cluster can be quickly activated on the standby 
cluster.
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 System Requirements
INTRODUCTION
System Requirements

REQUIREMENT MINIMUM

Operating System • Microsoft Windows 2008 Server 64-bit
• Microsoft Windows 2003 Server 64-bit (Service Pack 1 

minimum)
• Microsoft Windows 2000 Server (Service Pack 2 

minimum; Service Pack 3 required for Exchange Server 
2003)

Filesystems • FAT16 (not compatible with Exchange Server 2003)
• FAT32 (not compatible with Exchange Server 2003)
• NTFS

RAM 64 MB.

Hard Drive Space 100 MB permanent hard drive space (1 GB recommended) 
for software installation.
Avamar Exchange Client software also requires an 
additional 12 MB of permanent hard drive space for each 
64 MB of physical RAM. This space is used for local cache 
files. 

Network Interface 10baseT or higher, configured with latest drivers for your 
platform.

Web Browser • Microsoft Internet Explorer 6.0
• Netscape 6.3.0

Optional. Required in order to use Avamar Web Access 
download and restore features.

Adobe Acrobat 
Reader

5.0 or higher. Available from www.adobe.com.
Optional. Required in order to view online documentation. 

Other Software • Microsoft Exchange Server 2007 SP1
• Microsoft Exchange Server 2003 SP2
• Microsoft Exchange Server 2000 SP3
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 Capabilities and Limitations
INTRODUCTION
Capabilities and Limitations
This topic discusses current capabilities and limitations of the Avamar Exchange 
Client. 

Different Datasets Must Be Applied to Each Storage Group. If there is 
more than one storage group in an Exchange Information Store, each storage 
group within the Exchange Information Store must be assigned its own dataset. 
This gives the administrator the flexibility to assign different backup policies to 
each of the storage groups. If all of the datasets are associated with the same 
backup schedule, then all of the storage groups will be backed up sequentially 
during the scheduled window.

Furthermore, when browsing the Exchange Database, if there are other 
components (for example, “Directory”), each component must be assigned its own 
dataset. 

Similarly, when performing an on-demand backup of an Exchange database, you 
must also individually select each component, such as an individual storage group 
or “Directory” of the Exchange Database to be backed up. If you select the entire 
plug-in by placing a check mark next to the database plug-in, the backup will fail.

NOTE:  This limitation does not apply to the Exchange 2007
database plugin.

Message Level Backup on Exchange 2007. Starting with Exchange 2007, 
neither the Messaging API (MAPI) client libraries nor CDO 1.2.1 are provided as a 
part of the base Exchange 2007 product installation. As a result, you must 
manually download and install these components in order to use the MAPI-based 
Exchange Message Plug-in. These components are available as a single download 
from Microsoft.com at the following location:

http://www.microsoft.com/downloads/details.aspx?FamilyID=E17E7F31-
079A-43A9-BFF2-0A110307611E&displaylang=en

Consider Impact of Exchange Server Maintenance Window. By default, 
Exchange servers typically perform various maintenance activities nightly between 
1:00 AM and 5:00 AM. Performing Avamar backups during this maintenance 
window can prevent these activities from occurring on the Exchange server. 
Therefore, it is best to avoid scheduling Exchange server backups during the 
nightly Exchange server maintenance window.

Refer to the following Microsoft Knowledge Base article for additional information 
about nightly Exchange server maintenance windows:

Microsoft Knowledge Base Article - KB271222, “XADM: Understanding 
Performance and Scalability Characteristics of Exchange 2000 MDB Online 
Maintenance”

NOTE:  This limitation applies to the Exchange Database
Plug-in only.
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 Capabilities and Limitations
INTRODUCTION
Validation Not Supported. The Exchange Database Plug-in does not support 
backup validation.

NOTE:  This capability applies to the Exchange Database
Plug-in only.

Unique User Name Required For Each Exchange Server. If you are backing 
up more than one Exchange server within an Active Directory forest, you must use 
a different Windows user account for each Exchange server. This is because each 
user defined in Active Directory stores an Exchange mailbox as an attribute. It is 
therefore not possible for Avamar to use one user account to backup more than 
one Exchange server.

NOTE:  This limitation applies to the Exchange Message
Plug-in only.

Recommend Restoring an Entire Folder to an Empty Folder. Restoring 
individual messages within an existing Exchange folder is possible but is not 
recommended. Because duplicates messages could be created when restoring to 
populated folders, the best practice is to:

1. Create a temporary dedicated Exchange folder for restoring messages (for 
example, “restored-messages”).

2. Restore messages to that folder.

3. Use Outlook search and sort features to locate the message or messages 
you want to add back into your Exchange mailbox.

NOTE:  This limitation applies to the Exchange Message
Plug-in only.

Initial Message Level Data Deduplication Might Be Low. Initial message-
level data deduplication might be very low across folders and mailboxes. This is 
particularly true for small messages. The reason for these initial low levels of data 
deduplication is that each message contains an embedded globally-unique 
identifier and messages tend to be very small units (usually less than 20KB). This 
means that each message is effectively unique to Avamar. Data deduplication 
levels following initialization will be higher because messages that have not 
changed since the last backup will not be sent to the Avamar server.

NOTE:  This limitation applies to the Exchange Message
Plug-in only.
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Browsing More than a Few Thousand Messages Might Be
 Slow. Attempting to browse a folder that contains more than a few thousand 

messages might result in slow performance. Actual performance has been 
observed to be approximately 48 messages per second.

NOTE:  This limitation applies to the Exchange Message
Plug-in only.

Handling of “/” and “\” in Exchange Object Names. It is generally a bad 
practice to create Exchange objects with forward or backward slashes embedded 
in the object name. However, the Avamar Exchange Client will attempt to handle 
these situations as gracefully as possible, subject to the following limitations and 
known behavior:

1. Forward and backward slashes in mailboxes, folders and the subject line 
can be backed up and restored properly. However, if you attempt to browse 
folders or messages that contain forward or backward slashes, the 
following substitutions are made:

• “/” is replaced with “&#x2f;”
• “\” is replaced with “&#x5c;” 

For example, a folder named “\Infected” is displayed in Avamar 
Administrator as “&#x5c;Infected” and a subject line 
“/home/admin/dpn.pm” is displayed as 
“&#x2f;home&#x2f;admin&#x2f;dpn.pm”

2. If you attempt to browse folders that contain forward or backward slashes 
from the Avamar Administrator Backup window, the folders will appear to 
be empty. The contents actually exist, they just cannot displayed in the 
Backup window.

3. You cannot restore a message to a folder name that contains a forward or 
backward slash. 

For example, although you can select to restore to an existing folder 
named “\Infected,” you cannot specify a redirected restore to a folder 
named “\Infected.”

NOTE:  This limitation applies to the Exchange Message
Plug-in only.

Login Errors. If the client running the Avamar Exchange Message plug-in 
cannot log into the information store to browse the store, Avamar Administrator 
displays an empty list.

NOTE:  This limitation applies to the Exchange Message
Plug-in only.
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Error Reported if There are Duplicate Folders in Mailboxes. When 
browsing a backup within Avamar Administrator, if there are duplicate folders 
within a mailbox, Avamar Administrator will report the following error:

Event Code: 21007
Category: SYSTEM
Severity: PROCESS
Summary: Internal Administrator Client error.
View Details: index unmatched

This situation typically occurs as the result of a client name change and latencies 
in Windows Active Directory updates. If this occurs, rename one of the duplicate 
folders to a different name or wait for the next Active Directory update to 
complete.

NOTE:  This limitation applies to the Exchange Message
Plug-in only.

Backup Size is Larger than Size Reported by Exchange. Avamar server 
stores Exchange messages in Transport-Neutral Encapsulation Format (TNEF). 
This format requires more storage space on the Avamar server than is required 
inside an Exchange database. This difference in storage capacity used by the 
Avamar server is at least an additional 10KB per message.

For this reason, initial backup progress bytes reported by Avamar Administrator 
will be larger than the size reported by Exchange; Progress bytes reported by 
subsequent backups will be more in line with the Exchange sizes.

Additionally, when browsing backups to restore message folders, sizes reported by 
Avamar Administrator will be the size required to restore that folder inside 
Exchange, not the amount of storage space actually consumed on the Avamar 
server.

NOTE:  This limitation applies to the Exchange Message
Plug-in only.

Database Service Requires Manual Intervention. The Database service, 
shown in the cluster administrator, does not automatically return to online status 
immediately following a database restore. The interim solution is to manually 
bring the Database service online following the restore.

NOTE:  This limitation applies to the Exchange 2007 Data-
base plug-in.
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 Capabilities and Limitations
INTRODUCTION
Messages in Outbox Might Not Be Backed Up. Messages in the Outbox 
folder might not be backed up. This can occur for a number of reasons, but all are 
inherent limitations of Microsoft Exchange, for which there are no known interim 
solutions.

NOTE:  This limitation applies to the Exchange Message
plug-in.

Incorrect Initial Reporting of Folder Sizes. There is a known limitation with 
the Exchange 2007 Database and Exchange Message plug-ins in which all folder 
sizes are initially reported to be zero bytes. However, expanding a folder causes 
the folder size to be correctly updated and all contents to be shown. This does not 
affect actual restore behavior.

NOTE:  This limitation applies to the Exchange 2007 Data-
base and Exchange Message plug-ins. It does not apply to
the Exchange Database plug-in.

Restore fails if “Skip Mounted Database On Restore” Option is
 Selected. When performing an Exchange 2007 database restore on a storage 

group that contains only one database, selecting the Skip mounted database on 
restore option will cause that restore to fail even if the database is mounted.

NOTE:  This limitation applies to the Exchange 2007 Data-
base plug-in.

Known Limitations with Region Profiles. If you are performing message-
level backups, the Region Profile for the AvamarBackupUser account must be the 
same as the Exchange Server Region Profile. Otherwise, when you attempt to 
restore message-level backups, Exchange might incorrectly translate certain 
extended characters, which will corrupt the mailbox. This is a limitation of 
Microsoft Exchange.

NOTE:  This limitation applies to the Exchange Message
Plug-in only.
AVAMAR EXCHANGE CLIENT 4.1 • INSTALLATION GUIDE AND REFERENCE MANUAL  17



 Capabilities and Limitations
INTRODUCTION
Large Message-Level Backups Might Fail. There is a known limitation with 
the MSExchangeIS service in which it can run out of resources during a MAPI 
restore involving a large number of folders or mailboxes (that is, typically 500 or 
more). When this occurs, the following error message is returned:

CreateFolder failed 80004005 MAPI_E_CALL_FAILED

This issue is addressed in Microsoft Knowledge Base articles 830829 and 830836 
and an interim solution is offered. Refer to the Microsoft Knowledge Base articles 
for additional information.

NOTE:  This limitation applies to the Exchange Message
Plug-in only.
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INSTALLING/UNINSTALLING AVAMAR EXCHANGE CLIENT

This chapter describes how to install and configure Avamar Exchange Client 
software on a supported Exchange server in either standalone or high-availability 
configurations.

Important Information About Windows Clusters and 
Exchange 2007 CCR

If you intend to deploy Microsoft Exchange 2007 on either Windows Server 2003 
or 2008 and you intend to use the Cluster Continuous Replication (CCR) feature to 
implement a high-availability solution, you must configure your windows cluster in 
accordance with the information presented in the following Microsoft TechNet 
topics:

Windows Server 2003. Refer to TechNet > TechNet Library > Networking 
and Messaging > Exchange Server > Exchange Server 2007 > Operations 
> High Availability > Cluster Continuous Replication > Installing Cluster 
Continuous Replication on Windows Server 2003 at the following URL:

http://technet.microsoft.com/en-us/library/aa997144(EXCHG.80).aspx

Windows Server 2008. Refer to TechNet > TechNet Library > Networking 
and Messaging > Exchange Server > Microsoft Exchange Server 2007 > 
Operations > High Availability > Cluster Continuous Replication > 
Installing Cluster Continuous Replication on Windows Server 2008 at the 
following URL

http://technet.microsoft.com/en-us/library/bb629714.aspx

IMPORTANT:  Failure to properly configure your Windows
clusters for use with Exchange 2007 CCR in accordance with
the information presented in the previously mentioned
Microsoft TechNet topics will compromise operational readi-
ness of your Exchange 2007 deployment.
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 Quick Reference (Road Map)
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 Installing the Avamar Windows Client
INSTALLING/UNINSTALLING AVAMAR EXCHANGE CLIENT
Installing the Avamar Windows Client

IMPORTANT:  You must install both the Avamar Windows
Client and the Avamar Exchange Client on your Exchange
server.

1. Log into the client computer or workstation.

2. Point your web browser at the Avamar server by typing the following URL:

http://AVAMARSERVER

Where AVAMARSERVER is your actual Avamar system network hostname 
(as defined in DNS) or IP address.

You will be automatically redirected to the Avamar secure web server.

Depending on your browser security settings, a security alert dialog box 
might appear. 

3. If a security alert dialog box appears, click Yes or OK to allow redirection 
to the Avamar secure web server. 

The Secure Log On page appears.

4. Page down until the Downloads and Documents hyperlink is visible.

5. Click Downloads and Documents.

The Downloads and Documentation page appears.

IMPORTANT:  If configuring an Exchange 2007 server, you
must install the 64-bit Avamar Windows Client.

If configuring an Exchange 2003 or 2000 server, you must
install the 32-bit Avamar Windows Client.

6. Click the correct operating system hyperlink for your client computer.

A folder listing appears in your browser.

7. Double-click the AvamarClient-windows-x86-VERSION.msi install 
package.

Your browser will prompt you to either open the file “in-place” (on the 
server) or save it to your local computer. Either method will work. However, 
if you save the file to your local computer, you must open (double-click) 
that installation file to continue with this procedure.

8. Open the installation in place (on the server).

The installation wizard appears.

9. Follow the on-screen instructions.

10.Click Finish to complete the installation procedure.
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Installing the Avamar Windows Cluster Client

IMPORTANT:  You must have previously installed the Ava-
mar Windows Client (page 21) on both servers before per-
forming this procedure.

1. Determine which server in the cluster currently has access to the shared 
external storage for that cluster.

This is the “owning server” for that cluster.

2. Log into the owning server

3. Point your web browser at the Avamar server by typing the following URL:

http://AVAMARSERVER

Where AVAMARSERVER is your actual Avamar server network hostname 
(as defined in DNS) or IP address.

You will be automatically redirected to the Avamar secure web server.

Depending on your browser security settings, a security alert dialog box 
might appear. 

4. If a security alert dialog box appears, click Yes or OK to allow redirection 
to the Avamar secure web server. 

The Secure Log On page appears.

5. Page down until the Documents and Downloads hyperlink is visible.

IMPORTANT:  If using Windows Exchange 2007 in a Win-
dows Server 2008 cluster, you must install 64-bit Avamar
Windows Cluster Client.

6. Click Documents and Downloads.

The Documents and Downloads page appears.

7. Click the appropriate operating system hyperlink for your client computer.

A directory listing appears in your browser.

8. Click the AvamarClientCluster-windows-x86-VERSION.exe install 
package.

Your browser will prompt you to either open the file “in-place” (on the 
server) or save it to your local computer. Either method will work. However, 
if you save the file to your local computer, you must open (double-click) 
that installation file to continue with this procedure.
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 Installing the Avamar Windows Cluster Client
INSTALLING/UNINSTALLING AVAMAR EXCHANGE CLIENT
9. Open the installation in place (on the server).

The installation wizard appears.

NOTE:  If installing into an environment that uses Exchange
2007 replication (page 9) but does not use Windows cluster-
ing with shared storage (page 9), you can safely ignore the
No shared storage resource is present in this Group
advisory.

10.Select or type the following:

FIELD/OPTION DESCRIPTION

Choose a Group for 
Install or Update.

Select the correct cluster group, on which 
you want to install this software, from this 
drop-down list.

G
R

O
U

P
 R

E
S

O
U

R
C

E
S

Network name for 
backup agent 
communication

This drop-down list contains all network 
names (hostnames) assigned to this 
cluster group.

Select the network name you want to use 
for Avamar client-server communication 
from this drop-down list.

Physical disk for 
backup agent 
configuration log files

This drop-down list contains all shared 
external storage drives assigned to this 
cluster group.
Select the shared external storage drive on 
which you want to install this software.
AVAMAR EXCHANGE CLIENT 4.1 • INSTALLATION GUIDE AND REFERENCE MANUAL  23



 Installing the Avamar Windows Cluster Client
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R
E

G
IS

T
R

A
T

IO
N

Do not register 
client now option

If selected, client associated with this 
cluster group will not be registered with the 
Avamar server. This client will have to be 
manually registered and activated before 
you can back up any data.

Administrator server 
host name or IP 
address

Administrator server network hostname as 
defined in DNS.

Administrator server 
listen data port

The default data port for Avamar client-
server communication is 28001.
Unless you are using a different data port 
at your site, you should leave this set to 
28001.
Consult your Avamar system administrator 
for the specific data port you should use 
when registering this client.

Backup domain for 
this client

Avamar domain where you want this client 
to reside.
The default domain is “clients.” However, 
your Avamar system administrator might 
have defined other domains and sub-
domains. 
Consult your Avamar system administrator 
for the specific domain you should use 
when registering this client.
IMPORTANT:  If typing a sub-domain 
(for example, clients/MyClients), do not 
include a slash (/) as the first character. 
Including a slash as the first character will 
cause an error and prevent you from 
registering this client.

Override automatic 
backup client name 
with this name

If you do not want the Avamar client name 
to be the same as the cluster group name, 
type another Avamar client name in this 
field.

Override default log 
file location

If selected, after clicking Finish you will be 
prompted to type the UNC path to a folder 
where Avamar log files will be written. This 
entry cannot contain drive letters.
IMPORTANT:  If using Exchange 2007 
Cluster Continuous Replication (CCR), you 
must write Avamar log files to a location 
that can be accessed by either the primary 
or secondary storage group in the event 
that either fails.

FIELD/OPTION DESCRIPTION
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 Installing the Avamar Exchange Client
INSTALLING/UNINSTALLING AVAMAR EXCHANGE CLIENT
11. Follow the on-screen instructions.

12.Click Finish to complete the installation procedure.

IMPORTANT:  If using Cluster Continuous Replication
(CCR), you must start the backup cluster agent from an
account that has full access permissions to the folder where
Avamar log files are written.

Installing the Avamar Exchange Client

IMPORTANT:  You must install both the Avamar Windows
Client and the Avamar Exchange Client on your Exchange
server.

1. Log into the client computer or workstation.

2. Point your web browser at the Avamar server by typing the following URL:

http://AVAMARSERVER

Where AVAMARSERVER is your actual Avamar system network hostname 
(as defined in DNS) or IP address.

You will be automatically redirected to the Avamar secure web server.

Depending on your browser security settings, a security alert dialog box 
might appear. 

3. If a security alert dialog box appears, click Yes or OK to allow redirection 
to the Avamar secure web server. 

The Secure Log On page appears.

4. Page down until the Downloads and Documents hyperlink is visible.

5. Click Downloads and Documents.

The Downloads and Documentation page appears.

6. Click the AvamarExchangeClient install package.

Your browser will prompt you to either open the file “in-place” (on the 
server) or save it to your local computer or workstation. Either method will 
work. However, if you save the file to your local computer or workstation, 
you must open (double-click) that installation file to continue with this 
procedure.

7. Open the installation in place (on the server).

The InstallShield Wizard appears.

8. Follow the on-screen instructions.

9. Click Finish to complete the installation procedure.
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INSTALLING/UNINSTALLING AVAMAR EXCHANGE CLIENT
Configuring an Exchange 2007 Server
 for Message Level Backups and Restores

TIP:  If you do not intend to perform message level backups
and restores of your Exchange 2007 server (your intent is to
only perform full database backups and restores), you can
skip this procedure.

IMPORTANT:  If your Exchange 2007 server is deployed in
a high-availability configuration using Windows clusters, you
must perform this entire procedure on all nodes in the clus-
ter with the exception that only the active node can have the
backup agent service running at any one time. However, all
nodes (including inactive nodes) must be configured to start
and run the backup service as AvamarBackupUser.

Task List If you intend to perform message level backups and restores of an Exchange 2007 
server, you must perform all the following tasks:

• Download and Install MAPI Client Libraries and CDO 1.2.1 (page 26)
• Create New “AvamarBackupUser” User Account and Mailbox (page 27)
• Create New “AvamarBackupProfile” MAPI Profile (page 29)
• Configure Backup Agent Service to Run as AvamarBackupUser (page 30)
• Activate the AvamarBackupUser Mailbox (page 31)

Download and Install MAPI Client Libraries and CDO 1.2.1

IMPORTANT:  This task is only required on Exchange 2007
servers. Skip this task if configuring an Exchange 2003 or
2000 server.

Starting with Exchange 2007, neither the Messaging API (MAPI) client libraries nor 
CDO 1.2.1 are provided as a part of the base Exchange 2007 product installation. 
As a result, you must manually download and install these components in order to 
use the MAPI-based Exchange Message Plug-in. These components are available 
as a single download from Microsoft.com at the following location:

http://www.microsoft.com/downloads/details.aspx?FamilyID=E17E7F31-
079A-43A9-BFF2-0A110307611E&displaylang=en
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Create New “AvamarBackupUser” User Account and Mailbox

1. Log into the Exchange server using an administrative user account.

2. Select Start > Programs > Administrative Tools > Active Directory 
Users and Computers.

The Active Directory Users and Computers application appears. 

3. Create a new user account by selecting Actions > New > User.

The first New Object - User wizard screen appears.

4. Type the following:

5. Click Next.

The next New Object - User wizard screen appears.

FIELD DESCRIPTION

Full name Type the name for this new user account.
The suggested name is AvamarBackupUser.

User logon name Type the logon name for this new user account.
The suggested name is AvamarBackupUser.
Select the desired Active Directory domain from 
the drop-down list.

User logon name 
(pre-Windows 2000)

Type the same logon name from the previous 
field.
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6. Select or type the following:

7. Select the AvamarBackupUser and select right mouse button Properties.

The User Properties dialog box appears.

8. Click the Member Of tab.

9. Make this user a member of the follow groups:

(a) Administrators

(b) Backup Operators

(c) Domain Users

(d) Exchange Domain Servers

(e) Exchange Install Domain Servers

(f) Exchange Organizational Administrators

10. From the Exchange Management Console, create an AvamarBackupUser 
mailbox using all the default settings.

11.Next, add FullAccess permission to the AvamarBackupUser account using 
the Exchange Management Shell by typing the following on a single 
command line:

Get-Mailbox -server SERVERNAME | Add-MailboxPermission
 -User AvamarBackupUser -AccessRights FullAccess | Format-List

FIELD/OPTION DESCRIPTION

Password Type a logon password for this 
new user account.

Confirm password Type the same logon password 
from the previous field.

Password never expires Set this option. 
EMC recommends that you leave 
all other options cleared.
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Create New “AvamarBackupProfile” MAPI Profile

1. Log into the Exchange server using the new AvamarBackupUser account.

2. Open a Command Prompt.

3. Run the profman.exe utility by typing:

cd C:\Program Files\avs\bin

profman.exe

The MAPI Profile Manager window appears.

4. Click the New Profile toolbar button (shown left).

The New Profile dialog box appears.

5. Type AvamarBackupProfile in the Profile Name field and click OK.

The New Profile dialog box closes.

6. Switch to MAPI Profile Manager window

7. Select the AvamarBackupProfile. 

8. Click the Add Service to selected profile toolbar button (shown left).

The New Profile dialog box appears.

9. Select MSEMS (Microsoft Exchange Server) from the list and click OK.

The New Profile dialog box closes and the Microsoft Exchange Server 
properties dialog box appears.
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10.Type the name of your Exchange 2007 mail server in the Microsoft 
Exchange server field.

NOTE:  Use default values for the remaining settings. 

11.Click OK.

The Microsoft Exchange Server properties dialog box closes.

12.Switch to MAPI Profile Manager window and select File > Exit.

The MAPI Profile Manager window closes.

Configure Backup Agent Service to Run as 
AvamarBackupUser

IMPORTANT:  If your Exchange 2007 server is deployed in
a high-availability configuration using Windows clusters, all
nodes (including inactive nodes) must be configured to start
the backup service as AvamarBackupUser. However, only the
active node can have the backup agent service running at
any one time. 

1. Ensure that you are still logged into the Exchange server as 
AvamarBackupUser or some other administrative user account.

2. Launch the Services application by selecting Start > Programs > 
Administrative Tools > Services.

The Services window appears.

3. Locate the Backup Agent service in the Services list and select right mouse 
button Properties.

The Backup Agent Properties dialog box appears.

4. Click the Logon tab.

5. Set This account option.

The Local system account option is now cleared.
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6. Type AvamarBackupUser in the This account field.

NOTE:  If your site has more than one Active Directory
domain, type the user name with the following syntax: 
DOMAIN\AvamarBackupUser. Where DOMAIN is the Active
Directory domain where the AvamarBackupUser user
account resides.

7. Type the AvamarBackupUser password in the Password and Confirm 
Password fields.

8. Click OK.

The Backup Agent Properties dialog box closes. 

9. With the Backup Agent service still selected in the Services list, select right 
mouse button Restart.

10.Select File > Exit.

The Services window closes.

Activate the AvamarBackupUser Mailbox
The AvamarBackupUser Exchange server mailbox must be activated using one of 
the following methods:

1. Access the AvamarBackupUser mailbox with your Outlook email client.

2. Send a test email message to the AvamarBackupUser email account.
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Configuring an Exchange 2003 or Exchange 2000 Server
 for Message Level Backups and Restores

TIP:  If you do not intend to perform message level backups
and restores (your intent is to only perform full database
backups and restores), you can skip this procedure.

IMPORTANT:  If your Exchange 2003 or 2000 server is
deployed in a high-availability configuration using Windows
clusters, you must perform this entire procedure on all nodes
in the cluster with the exception that only the active node
can have the backup agent service running at any one time.
However, all nodes (including inactive nodes) must be con-
figured to start and run the backup service as AvamarBacku-
pUser.

Task List If you intend to perform message level backups and restores, you must perform 
the following tasks:

• Create New “AvamarBackupUser” User Account and Mailbox (page 32)
• Create New “AvamarBackupProfile” MAPI Profile (page 35)
• Configure Avamar Client Agent Service to Run as AvamarBackupUser 

(page 37)
• Activate the AvamarBackupUser Mailbox (page 37)

Create New “AvamarBackupUser” User Account and Mailbox

1. Log into the Exchange server using an administrative user account.

2. Select Start > Programs > Administrative Tools > Active Directory 
Computers and Users.

The Active Directory Computers and Users application appears. 

3. Create a new user account by selecting Actions > New > User.

The first New Object - User wizard screen appears.
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4. Type the following:

5. Click Next.

The next New Object - User wizard screen appears.

6. Select or type the following:

FIELD DESCRIPTION

Full name Type the name for this new user account.
The suggested name is AvamarBackupUser.

User logon name Type the logon name for this new user account.
The suggested name is AvamarBackupUser.
Select the desired Active Directory domain from 
the drop-down list.

User logon name 
(pre-Windows 2000)

Type the same logon name from the previous 
field.

FIELD/OPTION DESCRIPTION

Password Type a logon password for this 
new user account.

Confirm password Type the same logon password 
from the previous field.

Password never expires Set this option. 
EMC recommends that you leave 
all other options cleared.
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7. Click Next.

The next New Object - User wizard screen appears.

8. Select or type the following:

9. Click Next.

The final New Object - User wizard screen appears.

10.Click Finish.

The New Object - User wizard closes.

11.Select the AvamarBackupUser and select right mouse button Properties.

The User Properties dialog box appears.

FIELD/OPTION DESCRIPTION

Create an 
Exchange mailbox

Set this option.

Alias EMC recommends that you leave this set to the 
default value (the logon user name).

Server Select an Exchange server from the drop-down 
list.

Mailbox Store Select a mailbox store from the drop-down list.
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12.Click the Member Of tab.

13.Make this user a member of the follow groups:

(a) Administrators

(b) Backup Operators

(c) Domain Users

(d) Exchange Domain Servers

Create New “AvamarBackupProfile” MAPI Profile

1. Log into the Exchange server using the new AvamarBackupUser account.

2. Open a Command Prompt.

3. Run the profman.exe utility by typing:

cd C:\Program Files\avs\bin

profman.exe

The MAPI Profile Manager window appears.
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4. Click the New Profile toolbar button (shown left).

The New Profile dialog box appears.

5. Type AvamarBackupProfile in the Profile Name field and click OK.

The New Profile dialog box closes.

6. Switch to MAPI Profile Manager window

7. Select the AvamarBackupProfile. 

8. Click the Add Service to selected profile toolbar button (shown left).

The New Profile dialog box appears.

9. Select MSEMS (Microsoft Exchange Server) from the list and click OK.

The New Profile dialog box closes and the Microsoft Exchange Server 
properties dialog box appears.

10. Type the name of your Exchange 2003 or 2000 mail server in the Microsoft 
Exchange server field.

NOTE:  Use default values for the remaining settings. 

11.Click OK.

The Microsoft Exchange Server properties dialog box closes.

12.Switch to MAPI Profile Manager window and select File > Exit.

The MAPI Profile Manager window closes.
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Configure Avamar Client Agent Service to Run as 
AvamarBackupUser

1. Ensure that you are still logged into the Exchange server as 
AvamarBackupUser or some other administrative user account.

2. Launch the Services application by selecting Start > Programs > 
Administrative Tools > Services.

The Services window appears.

3. Locate the Avamar Client Agent service in the Services list and select right 
mouse button Properties.

The Avamar Client Agent Properties dialog box appears.

4. Click the Logon tab.

5. Set This account option.

The Local system account option is now cleared.

6. Type AvamarBackupUser in the This account field.

NOTE:  If your site has more than one Active Directory
domain, type the user name with the following syntax: 
DOMAIN\AvamarBackupUser. Where DOMAIN is the Active
Directory domain where the AvamarBackupUser user
account resides.

7. Type the AvamarBackupUser password in the Password and Confirm 
Password fields.

8. Click OK.

The Avamar Client Agent Properties dialog box closes. 

9. With the Avamar Client Agent service still selected in the Services list, 
select right mouse button Restart.

10.Select File > Exit.

The Services window closes.

Activate the AvamarBackupUser Mailbox

The AvamarBackupUser Exchange server mailbox must be activated using one of 
the following methods:

1. Access the AvamarBackupUser mailbox with your Outlook email client.

2. Send a test email message to the AvamarBackupUser email account.
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Configuring the Avamar Exchange Client Service
1. Select Computer Management > Services and Applications > 

Services.

2. Locate the Avamar Client Agent service in the services list.

3. Select right mouse button Properties.

4. Configure the Avamar Client Agent to login as AvamarBackupUser.

NOTE:  If the AvamarBackupUser is not yet visible, you
should synchronize with your domain controller. 

A message dialog box appears with the following message:

The new logon name will not take effect until you stop and restart the service. 

5. Click OK.

The message dialog box closes.

6. Manually stop, then restart the Avamar Client Agent service.

Uninstalling and Upgrading the Avamar Exchange Client
Unlike other platforms, previous versions of Avamar Exchange Client software do 
not have to be explicitly uninstalled before a new version can be installed. If you 
attempt to install the Avamar Exchange Client on an Exchange server that already 
has it installed, you will be prompted during installation to select one of the 
following choices:

1. Upgrade current Avamar Exchange Client installation to the new version.

2. Remove old Avamar Exchange Client installation.

If you decide to remove the old installation, you will need to re-run the 
installation file to install the new version (the current installation session 
becomes an “uninstall” session, then terminates).

You can also use the Windows Control Panel > Add/Remove Programs feature 
to completely uninstall the Avamar Exchange Client.

IMPORTANT:  Upgrading the Avamar Exchange Client soft-
ware causes the Avamar Client Agent service to revert to
logging in as the local SYSTEM user account, rather than
AvamarBackupUser. Therefore, following any Avamar
Exchange Client software upgrade, you must reconfigure
Avamar Client Agent service to login as AvamarBackupUser
and manually stop and restart the service for that change to
take affect.
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This chapter describes how to use the Avamar Exchange Client to backup or 
recover (restore) to an entire Exchange server or one or more Exchange message 
folders.

You should have current practical experience with the following:

• Operating system shell commands on your Exchange server platform (root 
permission required)

• The specific version of Exchange software currently deployed at your site

Refer to your Microsoft Exchange Server documentation for additional information.
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On-Demand Backup
This topic describes how to perform an on-demand backup of an entire Exchange 
server or one or more Exchange message folders.

Backing Up an Entire Exchange Database

To backup an entire Exchange server, perform the following:

1. Start Avamar Administrator.

2. Select Navigation > Backup and Restore or click the 
Backup & Restore launcher button.

The Backup and Restore window appears. 

3. Click the Select for Backup tab.

4. In the Clients tree, select the Exchange server.

REMINDER:  You cannot view clients outside your domain.
To view all clients, you must be logged into the root domain.

5. Select the Windows Exchange Database plug-in.

IMPORTANT:  Currently, you can only back up one storage
group per backup operation on Exchange 2000 and 2003.
Therefore, if your Exchange database comprises multiple
storage groups, you must select each storage group individ-
ually and perform multiple on-demand backups in order to
backup the entire Exchange database.

This limitation does not apply to Exchange 2007.

6. Select the storage group you want to backup.
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TIP:  Select Actions > Preview List... to view a summary
of all directories and files you have just selected for an on-
demand backup.

7. Select Actions > Backup Now… or click the toolbar icon shown 
immediately to the left.

The On Demand Backup Options dialog box appears.

8. Review your backup settings.

Clicking Cancel returns you to the Backup and Restore window where you 
can modify your backup selections.

9. If you want to change your backup retention setting, select or type the 
following:

FIELD/OPTION DESCRIPTION

Retention period If you want this backup to be deleted from 
the Avamar server after a specific number of 
days, weeks, months or years, select this 
option and type the number of days, weeks, 
months or years.

End date If you want this backup to be deleted from 
the Avamar server on a specific calendar 
date, select this option and browse to that 
date on the calendar.

No end date If you want to keep this backup for as long as 
this client remains active in the Avamar 
server, select this option.
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10.Select the encryption method you want to use for client/server data 
transfer during this backup.

Choices are:

TIP:  If you want to include plug-in options with this backup,
click More Options..., then select or clear the desired
options and type new values where applicable. 

Refer to Appendix B — Plug-in Options (page 65) for a com-
plete list of supported Exchange plug-in options.

11.Click OK.

The On Demand Backup Options dialog box closes and the following status 
message appears: Backup initiated.

12.Click OK.

Medium Medium strength encryption.

High Strongest available encryption setting for that specific client 
platform.

None No encryption.

NOTE:  The exact encryption technology and bit strength used for any 
given client/server connection is dependent on a number of factors, 
including the client platform and Avamar server version. Refer to your 
Avamar Product Security Manual for additional information.
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Backing Up One or More Message Folders

IMPORTANT:  Avamar only supports backup of Exchange
message folders, not individual messages.

To backup one or more Exchange message folders, perform the following:

1. Start Avamar Administrator.

2. Select Navigation > Backup and Restore or click the 
Backup & Restore launcher button.

The Backup and Restore window appears. 

3. Click the Select for Backup tab.

4. In the Clients tree, select the Exchange server.

REMINDER:  You cannot view clients outside your domain.
To view all clients, you must be logged into the root domain.

5. Select the Windows Exchange Message plug-in.

NOTE:  Tree expansion can be expected to take one approx-
imately for every 20-30 entries. This means that a 5000
entry directory can be expected to take approximately 2-3
minutes to fully expand.

6. Select one or more Exchange message folders.

TIP:  Select Actions > Preview List... to view a summary
of all directories and files you have just selected for an on-
demand backup.
AVAMAR EXCHANGE CLIENT 4.1 • INSTALLATION GUIDE AND REFERENCE MANUAL  43



 On-Demand Backup
USING THE AVAMAR EXCHANGE CLIENT
7. Select Actions > Backup Now… or click the toolbar icon shown 
immediately to the left.

The On Demand Backup Options dialog box appears.

8. Review your backup settings.

Clicking Cancel returns you to the Backup and Restore window where you 
can modify your backup selections.

9. If you want to change your backup retention setting, select or type the 
following:

FIELD/OPTION DESCRIPTION

Retention period If you want this backup to be deleted from 
the Avamar server after a specific number of 
days, weeks, months or years, select this 
option and type the number of days, weeks, 
months or years.

End date If you want this backup to be deleted from 
the Avamar server on a specific calendar 
date, select this option and browse to that 
date on the calendar.

No end date If you want to keep this backup for as long as 
this client remains active in the Avamar 
server, select this option.
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10.Select the encryption method you want to use for client/server data 
transfer during this backup.

Choices are:

TIP:  If you want to include plug-in options with this backup,
click More Options..., then select or clear the desired
options and type new values where applicable. 

Refer to Appendix B — Plug-in Options (page 65) for a com-
plete list of supported Exchange plug-in options.

11.Click OK.

The On Demand Backup Options dialog box closes and the following status 
message appears: Backup initiated.

12.Click OK.

Medium Medium strength encryption.

High Strongest available encryption setting for that specific client 
platform.

None No encryption.

NOTE:  The exact encryption technology and bit strength used for any 
given client/server connection is dependent on a number of factors, 
including the client platform and Avamar server version. Refer to your 
Avamar Product Security Manual for additional information.
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Recovery (Restore)

IMPORTANT:  If you are using the Local Continuous Repli-
cation (LCR), you must turn off LCR, perform the restore
operation, then turn LCR back on. If you leave LCR on during
the restore operation, it will fail.

Refer to your Microsoft Exchange Server documentation for
additional information about turning LCR on and off. 

To recover (restore) an entire Exchange database or one or more Exchange 
message folders, perform the following:

1. Do one of the following:

Exchange 2007
Database

Preparation

2. Prepare your Exchange 2007 database for the restore operation by 
performing the following:

(a) Un-mount the database and mark that it is overwritable by a restore 
operation.

(b) Manually delete the contents of the default storage folder.

NOTE:  The default storage folder name will normally be the
same the storage group created. In most cases, the default
name is First Storage Group.

(c) If located elsewhere than default storage folder, also manually delete 
the *.log files.

Exchange 2003/
2000 Database

Preparation

3. Prepare your Exchange 2003 or 2000 database for the restore operation by 
performing the following:

(a) Un-mount the database and mark that it is overwritable by a restore 
operation.

(b) Manually delete the contents of the MDBDATA directory.

(c) If located elsewhere than the MDBDATA directory, also manually delete 
the *.log files.

4. Start Avamar Administrator.

IF DO THIS

You want to recover (restore) an 
entire Exchange 2007 database.

Perform step 2, then go to 
step 4.

You want to recover (restore) an 
entire Exchange 2003/2000 database.

Skip step 2, perform step 3, 
then go to step 4.

You only want to recover (restore) one 
or more Exchange message folders.

Skip steps 2 and 3, and go 
directly to step 4.
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5. Select Navigation > Backup and Restore or click the 
Backup & Restore launcher button.

The Backup and Restore window appears. 

6. Click the Select for Restore tab.

7. In the Clients tree, select the Exchange server.

REMINDER:  You cannot view clients outside your domain.
To view all clients, you must be logged into the root domain.

8. Do one of the following:

IF DO THIS

You want to locate backups stored on 
the server by calendar date.

Perform step 8, then skip step 
9 and go directly to step 10.

You want to locate backups stored on 
the server by content (the specific 
directories and files contained within 
each backup).

Skip step 8 and go directly to 
step 9.
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Selecting by Calendar Date

9. To locate backups stored on the server by calendar date, perform the 
following:

(a) Click the By Date tab.

Clicking the By Date tab displays 
a browsable calendar for locating 
backups in the Avamar server.

Dates highlighted in yellow 
indicate that a backup was 
performed on that date.

Selecting a valid backup date on 
the calendar populates the 
backups list immediately to the 
right of the calendar.

Selecting a backup populates the contents list directly below the 
Backup History pane.

(b) In the Backup History pane, browse to a valid backup date in the 
Calendar (highlighted in yellow).

(c) Select a backup from the backups list directly to the right of the 
calendar.

(d) Select one or more directories or files you want to restore.
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Selecting by File/Folder

10.To locate backups stored on the server by content, perform the following:

(a) Click the By File/Folder tab.

Clicking the By File/Folder tab displays a Backup History pane that can 
be used to retrieve all backups that contain a specified client file or 
folder.

(b) If you know the full path to the desired client file or folder, type that 
path in the Enter path to retrieve history for field.

(c) If you do not know the full path to the desired client file or folder, click 
Browse and locate the desired client file or folder. 

(d) Click Retrieve.

The Version History table lists all versions and sizes for that file or 
folder that have been backed up for this client. 

Selecting a row in the Version History table shows all backups for the 
selected client that contains the selected version of the file or directory. 

(e) Select the backup you want to restore from.

TIP:  Select Actions > Preview List... to view a summary
of all directories and files you have just selected for an on-
demand restore.
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11.Select Actions > Restore Now… or click the toolbar icon shown 
immediately to the left.

The Restore Options dialog box appears.

12.Review your restore settings.

Clicking Cancel returns you to the Backup and Restore window where you 
can modify your restore selections.

13. If you want to change your restore destination choices, select or type the 
following:

FIELD/OPTION DESCRIPTION

Restore Everything 
to its original 
location

Restore Everything to its original location is 
the default destination — all files are restored to 
original client in the original top-level (root) 
directory.

Restore Everything 
to a different 
location

Restore Everything to a different location 
allows you to specify another client or another 
directory on the same client. 

Browse for Client/
Destination

Click Browse to locate a client or directory for 
the restore. You can also type this information 
directly in the Absolute Destination field. 

Restore Plug-in Type Restore Plug-in Type specifies which client plug-in 
will be used to perform this restore. The default 
choice is the same plug-in used to take the 
original backup.
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TIP:  If you want to include plug-in options with this restore,
click More Options..., then select or clear the desired
options and type new values where applicable. 

Refer to Appendix B — Plug-in Options (page 65) for a com-
plete list of supported Exchange plug-in options.

14.Click OK.

The Restore Options dialog box closes and the following status message 
appears: Restore initiated.

15.Click OK.

Encryption Method Encryption method specifies the encryption 
method used for client/server data transfer 
during this restore. Choices are:

Medium Medium strength encryption.

High Strongest available encryption setting 
for that specific client platform.

None No encryption.

NOTE:  The exact encryption technology and bit 
strength used for any given client-server 
connection is dependent on a number of factors, 
including the client platform and Avamar server 
version. Refer to your Avamar Product Security 
Manual for additional information.

FIELD/OPTION DESCRIPTION
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Scheduling Exchange Server Backups
In order to have your Exchange server backups (backups) performed on a regular 
schedule, you must:

• Create a new dataset expressly for Exchange server backups (backups)
• Create a new group expressly for Exchange server backups (backups)
• Add the Exchange server client to this new group
• Assign the new dataset to this new group
• Assign a schedule to this new group
• Assign a retention policy to this new group
• Enable scheduling for this new group

A thorough discussion of groups, group policy, datasets, schedules and retention 
policies is beyond the scope of this publication. Refer to your Avamar System 
Administration Manual for additional information.

Create a New Dataset for Exchange Server Backups

REMINDER:  You must be logged into the root domain as an
administrative user in order to perform this procedure.

IMPORTANT:  If your Exchange server is deployed as a
cluster, you should add all nodes in the cluster to this data-
set.

1. Start Avamar Administrator.

2. Select Tools > Manage Datasets…

The Manage All Datasets window appears.
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3. Click New. 

The New Dataset dialog box appears.

4. Type a name for this new dataset.

IMPORTANT:  Do not use any of the following characters in
your dataset name: ~!@$^%(){}[]|,`;#\/:*?<>'"&.

5. Click the Source Data tab.

The Source Data tab is where you define a list of source data plug-ins that 
contribute data to this dataset. 

6. Select or type the following:

FIELD/OPTION DESCRIPTION

Enter Explicitly Set this option to define which plug-ins will be used 
by this particular source data entry. 
To add a plug-in type to this dataset, select it from 
the drop-down list. 

Select Plug-in 
Type

This list is only available when Enter Explicitly is 
selected.
Select a plug-in type from the list and click + to add 
it to the plug-in list.
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The remaining dialog box tabs are used to set optional parameters such as 
exclude and include list entries and optional plug-in options. 

IMPORTANT:  Neither the Exchange Database nor the
Exchange Message plug-in supports include or exclude lists
in datasets.

If you do not need to set these optional parameters in this dataset, skip 
steps 8 and go directly to step 9. 

7. Click the Options tab.

The Options tab is where you set various plug-in options.

Plug-in options can be set two ways: by using the graphical controls or by 
entering option names and values as free text.

If you want to include plug-in options with future backups, select or clear 
the desired options and type values where applicable. 

IMPORTANT:  When entering option names and values as
free text, it must be understood that no error checking or
validation is performed on these free-text entries and that
free text entries override settings made using graphical con-
trols.

Refer to Appendix B — Plug-in Options (page 65) for a complete list of 
supported Exchange plug-in options that can be executed by a dataset.

8. Click OK.

The New Dataset dialog box closes.

Select Files and/
or Folders

This list is only available when Enter Explicitly is 
selected.
If you want this plug-in to point to a specific client 
subdirectory (somewhere other than the root 
directory), click ... and browse to the directory 
before you click +.
You can also type the full path to any client directory 
directly in this field. 
IMPORTANT:  Do not use any of the following 
characters in your entry: ~!@$^%(){}[]|,`;#\/
:*?<>'"&.

Select All Data 
for All Local File 
Systems

Set this option to include all data on all client 
filesystems. This adds all plug-in types to the source 
data list.

FIELD/OPTION DESCRIPTION
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Setting Up Scheduled Exchange Server Backups

REMINDER:  You must be logged into the root domain as an
administrative user in order to perform this procedure.

1. Start Avamar Administrator.

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Select Actions > New Group… or click the toolbar icon shown 
immediately to the left.

The New Group wizard appears.
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4. Select or type the following:

The remaining wizard screens are used to select a dataset, schedule and 
retention policy, as well as build a client list for this group.

You can click Finish at any time. Doing so will cause the new group to be 
created using system default settings and an empty client list. You can 
change those settings by editing the group properties.

FIELD/OPTION DESCRIPTION

Name Type a name for this new group.
IMPORTANT:  Do not use any of the following 
characters in your group name: ~!@$^%(){}[]|,`;#\/
:*?<>'"&.

Disabled This option is selected by default. Unset this option if 
you want to immediately use this group to take 
regularly scheduled client backups.

Encryption 
Method

This is the group encryption method that will be used by 
all members of this group for client/server network 
communications unless it is overridden at the client 
level. Choices are:

Medium Medium strength encryption.

High Strongest available encryption setting for 
that specific client platform.

None No encryption.

NOTE:  The exact encryption technology and bit 
strength used for any given client-server connection is 
dependent on a number of factors, including the client 
platform and Avamar server version. Refer to your 
Avamar Product Security Manual for additional 
information.

Override 
Schedule

Set this option if you want to override the assigned 
schedule for this group.
You can also skip the next scheduled backup entirely 
(Skip Next Backup) or perform the next scheduled 
backup one time only (Run Next Backup Once).

Domain Location in the Avamar where this group should reside.
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5. Click Next.

The next New Group wizard screen appears.

This screen is used to select a dataset for use with this group.

6. Select the dataset you defined during Create a New Dataset for Exchange 
Server Backups (page 52) from the Select an Existing Dataset drop-
down list.

7. Click Next.

The next New Group wizard screen appears.

This screen is used to select a schedule for use with this group.
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8. Select a schedule from the Select an Existing Schedule drop-down list.

NOTE:  Schedules are not modifiable from this screen.
Detailed schedule properties are shown so that you can
review them prior to making your selection. Refer to your
Avamar System Administration Manual for additional infor-
mation about editing schedule properties.

9. Click Next.

The next New Group wizard screen appears.

This screen is used to select a retention policy for use with this group.

10.Select a retention policy from the Select an Existing Retention Policy 
drop-down list.

NOTE:  Retention policies are not modifiable from this
screen. Detailed retention policy properties are shown so
that you can review them prior to making your selection.
Refer to your Avamar System Administration Manual for
additional information about editing retention policy proper-
ties.
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11.Click Next.

The final New Group wizard screen appears.

This screen is used to build a list of clients that will be members of this 
group. In this case, our group will contain only one client — the Exchange 
server.

12.Select the Exchange server from the client list.

13.Click Finish.

The New Group wizard closes and the new group appears in the Policy 
window.
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Enabling Scheduled Exchange Server Backups

REMINDER:  You must be logged into the root domain as an
administrative user in order to perform this procedure.

1. Start Avamar Administrator.

2. Select Navigation > Policy or click the Policy launcher button.

The Policy window appears.

3. Click the Policy Management tab.

4. Click the Groups tab.

5. Select the group you created in the previous procedure (the group that 
now contains only your Exchange server).

6. Select Actions > Group > Disable Group.

This unsets the Disable Group option on the Actions > Group menu.

A confirmation message appears.

7. Click Yes to enable this group.
AVAMAR EXCHANGE CLIENT 4.1 • INSTALLATION GUIDE AND REFERENCE MANUAL  60



APPENDIX A — SPECIALIZED RECOVERY APPLICATIONS

Recovering From Tape or Hard Disk
This topic describes how to recover Exchange databases from Avamar File System 
(AvFS) files that have been archived to removable tape media.

Although this procedure assumes that the archive media is digital tape, this 
procedure could easily be adapted for use with hard-disk based archive systems 
such as EMC Centera.

Prerequisites

The Avamar File System (AvFS) must be installed and configured according to the 
instructions found in your Avamar System Administration Manual.

The Exchange database that you want to recover must have been previously 
backed up using the avexchange database plug-in. The recovery procedure 
presented in this chapter does not in any way support message level backup, nor 
does it support any backup files that might have created using the Avamar 
Windows Client filesystem plug-in.

Once the Exchange database has been successfully backed up using the 
avexchange database plug-in, it is the Avamar File System (AvFS) representation 
of that Exchange database stream file (and only that file) that can be archived to 
tape and used for future recoveries. 

The same version of avexchange used to backup the Exchange database should be 
used to recover it. Therefore, is highly desirable to put a copy of avexchange.exe 
on the tape with the Exchange database stream file.

The active directory controller for the Exchange server must be restored first. 
Refer to the following Microsoft publications for additional information about 
restoring Exchange server active directory controllers:

• Disaster Recovery Exchange 2000 Server.pdf
• Exchange 2003 Disaster Recovery Operations.doc
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Recovery Procedure

IMPORTANT:  For Exchange 2007, restoring an entire data-
base from the command line is not supported. Restoring a
single storage group from the command line is supported.

1. Restore the active directory controller.

2. Locate and mount the tape containing the archived Exchange database 
files.

3. Create a temporary directory in a convenient location.

C:\TMP is used as an example temporary directory for the remainder of 
this procedure.

4. Using your tape archive and recovery software:

(a) Write the Exchange database stream file from the tape to the 
temporary directory.

(b) If avexchange.exe is present, also write it from the tape to the 
temporary directory.

5. Open a DOS prompt or other command shell.

6. Change directory to the temporary directory by entering:

C:

cd TMP

7. Ensure that avexchange.exe is present in the temporary directory by 
entering:

dir av*

avexchange.exe should be listed.

8. If avexchange.exe is not present, you must obtain a version of 
avexchange.exe to use for this procedure and copy it to the temporary 
directory.

Try to obtain the exact version of avexchange.exe that was used to 
perform the original backup of this Exchange database. 
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9. Restore the Exchange database by entering the following command on a 
single command line (no returns or line feeds allowed):

avexchange -R --logfile=C:\avexchangedb.log
--attachdb=true --backupfile=C:\TMP\MyDBFile --debug=false
--dothecomplete=true --erase_existing=false
--keeplogs=false --pipe=false --restorelogpath=C:\TMP
--skipmounted=false --start_server=false --wait=true
--instance=storage_group_name
--annotation="Microsoft Information Store"

Where MyDBFile is the Exchange stream file that was archived to tape.

IMPORTANT:  The --annotation option must contain
“Microsoft Information Store” as the value. Any other value
will cause this recovery operation to fail.

Restoring a Database to Recovery Storage Group and 
Recovering a Mailbox

This topic describes how to recover an Exchange database to a Recovery Storage 
Group, then recover a single mailbox from that Storage Group.

This procedure might be useful if an Exchange mailbox was accidently deleted and 
message level backups had not been performed.

Refer to Microsoft Document, Using Exchange Server 2003 Recovery Storage 
Groups, for additional information about recovering an Exchange database to a 
Recovery Storage group.

1. From Exchange 2003 System Manager or Exchange 2007 Exchange 
Management Console:

TIP:  On Exchange 2007, you can also use equivalent
Exchange Power Shell commands to perform these actions.

(a) Add Recovery Storage Group to Exchange server.

(b) Add database to Recovery Storage Group.

(c) Verify that Database can be overwritten by restore option is 
selected.

(d) Verify database is not mounted.

(e) Verify that there are no files in the Recovery Storage Group location.

Move or delete any existing files. 

(f) Verify there are no files in C:\Tmp. 

Move or delete any existing files. 
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2. From Avamar Administrator:

(a) Locate the database backup you want to restore by performing steps 1 
thru 7 basic recovery (restore) procedure (page 46). 

(b) Select the exchstream file. 

(c) If restoring to a different server, browse to the server and select 
Windows Exchange Database. 

(d) In the Absolute Destination field, type C:\Tmp.

(e) In Advanced Options, type RSG in the Storage Group Name field. 

(f) Restore database.

3. After the restore completes, launch Exchange System Manager, select the 
Recovery Storage Group and select Actions > Refresh. 

Restoring to Recovery Storage Group on an Alternate Server
If an Exchange server does not have enough available drive space for an 
additional copy of the database, then a Recovery Storage Group can be 
created on an alternative server that has adequate free space. This 
recovery server should be part of the same Domain (AD forest) and be 
added to the existing Exchange organization when installing Exchange. 

IMPORTANT:  In this configuration, always restore to a
Recovery Storage Group; never restore to a production Stor-
age Group. Severe disruption of production Exchange func-
tions could result if a database is restored to any storage
group other than the Recovery Storage Group.
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Plugin options provide additional control of backups and restores. These options 
are context-sensitive to both the operation being performed and the specific 
plugin selected for that operation.

These options can be specified during on-demand backup and restore options, or 
persistently set within datasets for all future scheduled backups

Plugin options can be set two ways: 

• By using the graphical controls (page 66)
• By entering option names and values as free text (page 67)
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Setting Plugin Options Using Graphical Controls
Clicking the Options tab and selecting a plugin displays all current plugin options 
for that specific plugin. The Windows filesystem plugin is shown in this example. 

These settings are represented by graphical controls (for example, options, radio 
buttons, drop-down lists, and so forth).

The advantage to setting plugin options using graphical controls is that you cannot 
enter an option name or value incorrectly — only valid states are shown.
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Setting Show Advanced Options expands this list even further by displaying 
options that are normally only of interest to persons debugging an Avamar 
system. These advanced options are shown in red. A partial list of advanced 
Windows filesystem plugin options is shown as an example (below).

Entering Option Names and Values as Free Text
You can also set plugin options by entering 
option names and values as free text. 

Clicking More expands the dialog box to include 
Enter Attribute and Attribute Value fields. 

The Enter Attribute and Attribute Value fields 
are used to input plugin options and values as 
free text. 

However, it must be understood that no error 
checking or validation is performed on these 
free text entries and that free text entries 
override settings made by way of the graphical 
controls. 
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Common Plugin Options
This topic lists plugin options that are common to nearly all plugins. These options 
can be specified during on-demand backups and restores, or persistently set 
within datasets for all future scheduled backups.

Backup Options

FIELD/OPTION DESCRIPTION

Backup label Assign this descriptive label to backup.

LO
G

G
IN

G

List backup contents Specify how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specify how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.
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FI
LE

S
Y

S
T

E
M

  T
R

A
V

E
R

S
A

L

Do not traverse 
any mounts

If selected, no mount points are traversed during 
this backup.

Traverse fixed-
disk mounts

If selected, only fixed-disk filesystem mount points 
are traversed during this backup.

Traverse fixed-
disk and remote 
network mounts

If selected, both fixed-disk and NFS network mount 
points are traversed during this backup.

Force traversal of 
specified file system 
type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should be traversed during this backup.

Force non-traversal 
of specified file 
system type(s)

Accepts a comma-separated list of one or more 
filesystem types (for example, nfs, ext2, jfs, xfs) 
that should not be traversed during this backup.

P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of backup

Runs user-defined script at beginning of backup 
session.
Script must be located in:

/usr/local/avamar/etc/scripts on AIX and Linux
/opt/AVMRclnt/etc/scripts on HP-UX and Solaris 
C:\Program Files\avs\etc\scripts on Windows

On Windows clients, script must have a .bat, .js or 
.vbs extension. There are no limitations on other 
client platforms.

Abort backup if 
script fails

If selected, stop backup if script returns a non-zero 
status code.

PO
S

T
-S

C
R

IP
T

Run user-defined 
script at end of 
backup

Runs user-defined script at end of backup session.
Script must be located in:

/usr/local/avamar/etc/scripts on AIX and Linux
/opt/AVMRclnt/etc/scripts on HP-UX and Solaris 
C:\Program Files\avs\etc\scripts on Windows

On Windows clients, script must have a .bat, .js or 
.vbs extension. There are no limitations on other 
client platforms.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

FIELD/OPTION DESCRIPTION
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Restore Options

C
LI

E
N

T
 C

A
C

H
E

 C
H

E
C

K
/R

E
P

A
IR

 

Check client-side 
caches and report 
inconsistencies

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a backup is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Maximum client file 
cache size (MBs)

Specifies maximum client file cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client file cache).

Maximum client hash 
cache size (MBs)

Specifies maximum client hash cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client hash cache).

A
D

V
A

N
C

E
D

 O
P

T
IO

N
S Client-side flag file Specifies path to a flag file on the client, which 

contains additional option settings.

Network usage 
throttle (Mbps)

Specifies a setting that reduces network usage to 
specified rate, expressed as megabits/second (for 
example, 0 = unrestricted, 50% of a T1 = 0.772).

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve backup performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION

Overwrite existing files Controls behavior when file to be restored already 
exists. One of the following:

Never

Always

Generate New Name

If Modified

If Newer

FIELD/OPTION DESCRIPTION
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LO
G

G
IN

G

List backup contents Specify how much information about backup 
contents should be included in the log files. One of 
the following:

No file listing

List file names

List files and dates

Informational 
message level

Specify how many informational messages should 
be included in the log files. One of the following:

No informationals All informational messages 
are suppressed. However, 
errors and warnings are 
included in the log files.

Some informationals Some informational 
messages are included in 
the log files.

Many informationals Additional status 
information is included in 
the log files.

All informationals Provides maximum 
information. In addition to 
errors and warnings, all 
informational messages are 
included in the log files.

Report advanced 
statistics

If selected, advanced timing and deduplication 
statistics are written to log files.

Enable debugging 
messages

If selected, maximum information is written to log 
files.
IMPORTANT:  If selected, very large log files are 
created.

P
R

E
-S

C
R

IP
T

Run user-defined 
script at beginning 
of restore

Runs user-defined script at beginning of restore 
session.
Script must be located in:

/usr/local/avamar/etc/scripts on AIX and Linux
/opt/AVMRclnt/etc/scripts on HP-UX and Solaris 
C:\Program Files\avs\etc\scripts on Windows

On Windows clients, script must have a .bat, .js or 
.vbs extension. There are no limitations on other 
client platforms.

Abort restore if 
script fails

If selected, stop restore if script returns a non-zero 
status code.

FIELD/OPTION DESCRIPTION
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P
O

S
T

-S
C

R
IP

T

Run user-defined 
script at end of 
restore

Runs user-defined script at end of restore session.
Script must be located in:

/usr/local/avamar/etc/scripts on AIX and Linux
/opt/AVMRclnt/etc/scripts on HP-UX and Solaris 
C:\Program Files\avs\etc\scripts on Windows

On Windows clients, script must have a .bat, .js or 
.vbs extension. There are no limitations on other 
client platforms.

Exit process with 
script failure 
exitcode

If selected, avtar exits with the exit code of the 
script instead of a standard avtar exit code.

C
LI

E
N

T
 C

A
C

H
E

 C
H

E
C

K
/R

E
P

A
IR

Check client-side 
caches and report 
inconsistencies

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server.

Check and repair 
client-side caches

If selected, a restore is not performed. Instead, 
forces a validation check of client-side cache with 
the Avamar server, and repairs inconsistencies.

Maximum client file 
cache size (MBs)

Specifies maximum client file cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client file cache).

Maximum client hash 
cache size (MBs)

Specifies maximum client hash cache size in MBs. A 
negative value indicates a fraction of RAM (for 
example, -8 specifies that no more than 1/8th of 
physical RAM be allocated to the client hash cache).

A
D

V
A

N
C

E
D

 O
P

T
IO

N
S

Do not descend 
into subdirectories

If selected, restore only the specified top-level 
directory; do not restore any subdirectories.

Recreate original 
path beneath 
target directory

If selected, recreate the original path to files and 
directories beneath the specified target directory.
For example, if restoring F:\Temp\MyFile.txt to 
C:\Temp and you selected this option, the full path 
to the restored file will be 
C:\Temp\F\Temp\MyFile.txt. 

Directly connect to 
all server nodes

If selected, establish multiple connections to the 
server. This can improve restore performance under 
certain circumstances.

FIELD/OPTION DESCRIPTION
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Windows Exchange Database Plugin Options
In addition to the Common Plugin Options (page 8) discussed previously, the 
following additional plugin options are also available for use with the Avamar 
Windows Exchange Database plugin. 

Backup Options

FIELD/OPTION DESCRIPTION

Set when backup 
occurs on 
clustered systems

Choices are:

Always Backs up all nodes in the cluster. This is 
the default setting.

Active node 
only

Only the active node in the cluster is 
backed up.

Passive node 
only

Only passive nodes in the cluster are 
backed up.

Refer to your Avamar Backup Clients Installation Guide 
and Reference Manual for additional information about 
Avamar support for Microsoft Windows Clusters.

Delete log files 
after backup

IMPORTANT:  Do not select this option if you are 
performing concurrent incremental backups.

Enhanced Data 
De-duplication

Enables or disables enhanced data de-duplication. During 
backups, enhanced data de-duplication typically reduces 
the amount of client data that must be sent to the server 
but requires additional client CPU resources. Choices are:

Default Use the global enhanced data de-
duplication setting already set on the 
server. This is the default setting.

Disabled Do not use enhanced data de-
duplication for backups.

Enabled Use enhanced data de-duplication for 
backups.
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A
D

V
A

N
C

E
D

 O
P

T
IO

N
S

Server Name This field can normally be left blank because the 
Exchange server name is automatically stored when the 
target client is browsed during on-demand backups or 
when a dataset is applied to a member of a group during 
a scheduled backup.

Annotation 
(Microsoft 
Information 
Store)

This field names the portion of (Extensible Storage 
Engine (ESE) backup to perform. Choices are: 

Microsoft 
Information 
Store

This is the default setting.

Microsoft Site 
Replication 
Service

Site replication service used for mixed 
Exchange 5.5 and 2000/2003 
environments.

Microsoft Key 
Management 
Service

Storage Group 
Name

This field can normally be left blank because the 
Exchange storage group name is automatically stored 
when the target client is browsed during on-demand 
backups or when a dataset is applied to a member of a 
group during a scheduled backup.

Local Backup 
File Name

If Pipe input/output to avtar is cleared, this field defines 
the filename used to send/receive data. 

Pipe input/
output to avtar

If selected, backups and restores are performed directly 
by the Avamar backup process (avtar).
If cleared, an intermediate local backup file can be used.

FIELD/OPTION DESCRIPTION
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Restore Options

FIELD/OPTION DESCRIPTION

E
X

C
H

A
N

G
E

 2
00

0/
20

03

Perform 
Database 
Recovery after 
restore making 
Exchange 
consistent

Keep logs after 
Restore

Wait for 
Database 
Recovery to 
Complete

Mount the 
database(s) 
after successful 
restore

Restore logs 
path

Specifies alternative location for restore log files. Specify 
this alternative location C:\TMP drive is low on disk 
space.

Skip Mounted 
Databases on 
Restore
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A
D

V
A

N
C

E
D

 O
P

T
IO

N
S

Server Name This field can normally be left blank because the 
Exchange server name is automatically stored when the 
target client is browsed during restore operations.
However, this field can be used to enter another server 
hostname when performing directed restores to another 
network host.

Annotation 
(Microsoft 
Information 
Store)

This field names the portion of (Extensible Storage 
Engine (ESE) backup to perform. Choices are: 

Microsoft 
Information 
Store

This is the default setting.

Microsoft Site 
Replication 
Service

Site replication service used for mixed 
Exchange 5.5 and 2000/2003 
environments.

Microsoft Key 
Management 
Service

Storage Group 
Name

This field can normally be left blank because the 
Exchange storage group name is automatically stored 
when the target client is browsed during restore 
operations.

Local Backup 
File Name

If Pipe input/output to avtar is cleared, this field defines 
the filename used to send/receive data. 

This can be used to restore the exchstream file in one 
step to a local file, then perform a Exchange restore 
using that file.

Pipe input/
output to avtar

If selected, backups and restores are performed directly 
by the Avamar backup process (avtar).
If cleared, an intermediate local backup file can be used.

FIELD/OPTION DESCRIPTION
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Windows Exchange Database 2007 Plugin Options
In addition to the Common Plugin Options (page 8) discussed previously, the 
following additional plugin options are also available for use with the Avamar 
Windows Exchange Database 2007 plugin. 

Backup Options

FIELD/OPTION DESCRIPTION

Set when backup 
occurs on 
clustered systems

Choices are:

Always Backs up all nodes in the cluster. This is 
the default setting.

Active node 
only

Only the active node in the cluster is 
backed up.

Passive node 
only

Only passive nodes in the cluster are 
backed up.

Refer to your Avamar Backup Clients Installation Guide 
and Reference Manual for additional information about 
Avamar support for Microsoft Windows Clusters.

Delete log files 
after backup

IMPORTANT:  Do not select this option if you are 
performing concurrent incremental backups.

Enhanced 
Commonality 
Factoring

Enables or disables enhanced data de-duplication. During 
backups, enhanced data de-duplication typically reduces 
the amount of client data that must be sent to the server 
but requires additional client CPU resources. Choices are:

Default Use the global enhanced data de-
duplication setting already set on the 
server. This is the default setting.

Disabled Do not use enhanced data de-
duplication for Exchange database 
backups.

Enabled Use enhanced data de-duplication for 
Exchange database backups.
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A
D

V
A

N
C

E
D

 O
P

T
IO

N
S

Server Name This field can normally be left blank because the 
Exchange server name is automatically stored when the 
target client is browsed during on-demand backups or 
when a dataset is applied to a member of a group during 
a scheduled backup.

Annotation 
(Microsoft 
Information 
Store)

This field names the portion of (Extensible Storage 
Engine (ESE) backup to perform. Choices are: 

Microsoft 
Information 
Store

This is the default setting.

Microsoft Site 
Replication 
Service

Site replication service used for mixed 
Exchange 5.5 and 2000/2003 
environments.

Microsoft Key 
Management 
Service

Storage Group 
Name

This field can normally be left blank because the 
Exchange storage group name is automatically stored 
when the target client is browsed during on-demand 
backups or when a dataset is applied to a member of a 
group during a scheduled backup.

Pipe input/
output to avtar

If selected, backups and restores are performed directly 
by the Avamar backup process (avtar).
If cleared, an intermediate local backup file can be used.

FIELD/OPTION DESCRIPTION
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Restore Options

FIELD/OPTION DESCRIPTION

E
X

C
H

A
N

G
E

 2
00

0/
20

03

Perform 
Database 
Recovery after 
restore making 
Exchange 
consistent

Keep logs after 
Restore

Wait for 
Database 
Recovery to 
Complete

Mount the 
database(s) 
after successful 
restore

Restore logs 
path

Specifies alternative location for restore log files. Specify 
this alternative location C:\TMP drive is low on disk 
space.

Skip Mounted 
Databases on 
Restore
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A
D

V
A

N
C

E
D

 O
P

T
IO

N
S

Server Name This field can normally be left blank because the 
Exchange server name is automatically stored when the 
target client is browsed during restore operations.
However, this field can be used to enter another server 
host name when performing directed restores to another 
network host.

Annotation 
(Microsoft 
Information 
Store)

This field names the portion of (Extensible Storage 
Engine (ESE) backup to perform. Choices are: 

Microsoft 
Information 
Store

This is the default setting.

Microsoft Site 
Replication 
Service

Site replication service used for mixed 
Exchange 5.5 and 2000/2003 
environments.

Microsoft Key 
Management 
Service

Storage Group 
Name

This field can normally be left blank because the 
Exchange storage group name is automatically stored 
when the target client is browsed during restore 
operations.

Local Backup 
File Name

If Pipe input/output to avtar is cleared, this field defines 
the filename used to send/receive data. 

This can be used to restore the exchstream file in one 
step to a local file, then perform a Exchange restore 
using that file.

Pipe input/
output to avtar

If selected, backups and restores are performed directly 
by the Avamar backup process (avtar).
If cleared, an intermediate local backup file can be used.

FIELD/OPTION DESCRIPTION
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Windows Exchange Message Plugin Options
In addition to the Common Plugin Options (page 8) discussed previously, the 
following additional plugin options are also available for use with the Avamar 
Windows Exchange Message plugin. 

Backup Options

The only backup option available for use with the Avamar Windows Exchange 
Message plugin is Enable debugging messages. Refer to Common Plugin 
Options (page 8) for additional information.

Restore Options

FIELD/OPTION DESCRIPTION

Overwrite existing 
messages

Controls behavior when message to be restored already 
exists. One of the following:

Never

Always

If Modified

If Newer
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Thee Avamar Exchange Client supports backup of an entire Exchange database or 
specific messages within an Exchange database. This is implemented using two 
separate plug-ins:

• Exchange - Database
• Exchange - Messages

All Backups Are Initiated Using Avamar Administrator, Not The
 Client. EMC expects that most customers will simply schedule regular 

Exchange database backups (backups) using Avamar Administrator and not 
perform very many on-demand backups. Furthermore, when on-demand backups 
are required, it is expected that customers will only initiate them from Avamar 
Administrator, not from the client.

Exchange - Database Plug-In
avexchange is the program (executable) that creates the Avamar Exchange 
Database plug-in. 

avexchange {-B | -R | --browse | --help | --version}

 [--annotation=NAME] [--backupfile=FILE]
 [--compress={Disabled | Default | Enabled}] [--ddnstobackup=LIST]
 [--erase_existing] [--fdosoftrecovery] [--ftruncatelogs]
 [--instance=NAME] [--logfile=FILE] [--pipe] [--pluginflag="OPTION"]
 [--restorelogpath=PATH] [--server=NAME] [--skipmounted]
 [--start_server] [--timing] [--usage] [--verbose | -v]

NOTE:  Boolean options (for example, --erase_existing, 
--pipe, and so forth) are true if supplied and false if not
supplied. Boolean options can also be supplied with the true
or false value explicitly set (for example, --pipe=true, 
--pipe=false)
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Commands 

Options

-B Performs a backup.

-R Performs a restore.

--browse Browses backups stored on the Avamar 
server.

--help Shows help for this utility, then exits. 

--version Displays avexchange build version then exits.

--annotation=NAME This can also be set to Site Replication Service or 
Key Management Service to backup those facilities, 
although this will require integration with the 
administrator server. All three services use the ESE 
compatible APIs for backup.

Default is Microsoft Information Store.
NOTE:  Formal support for mixed-case option
--Annotation was discontinued in version 2.1. 
However, while not the preferred syntax, it will still 
work.

--backupfile=FILE Used with --pipe to specify backup FILE.
NOTE:  Formal support for mixed-case option
--BackupFile was discontinued in version 2.1. 
However, while not the preferred syntax, it will still 
work.

--compress={Disabled
 | Default | Enabled}

Enables or disables enhanced data deduplication. 
During backups, enhanced data deduplication 
typically reduces the amount of client data that 
must be sent to the server but requires additional 
client CPU resources. Default is the default setting 
(use the global enhanced data deduplication setting 
already set on the server).

--ddnstobackup=LIST LIST of databases to backup/restore. Currently left 
empty to indicate all databases.
NOTE:  Formal support for mixed-case option
--DDNsToBackup was discontinued in version 2.1. 
However, while not the preferred syntax, it will still 
work.
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--fdosoftrecovery Performs soft recovery (performs a consistency 
check and prepares to put the database online) 
after database is restored. Can be done manually 
with ESEUTIL. Default is true.

This option is only supported on Exchange 2000/
2003.
NOTE:  Formal support for mixed-case option
--fDoSoftRecovery was discontinued in version 
2.1. However, while not the preferred syntax, it will 
still work.

--ftruncatelogs Forces truncation of Exchange backup logs. A full 
backup is supposed to truncate the logs once a 
backup of the database and logs is successful. 
Default is true.
NOTE:  Formal support for mixed-case option
--fTruncateLogs was discontinued in version 2.1. 
However, while not the preferred syntax, it will still 
work.

--logfile=FILE Specifies alternative log file for backup and restore 
operations.

--pipe Pipe all input/output from/to avtar. Default is true. 

This can be set to false to output the backup of 
avexchange to a file which is specified with the 
--BackupFile option. This is useful for debugging.

--pluginflag="OPTION" Specifies an option which will be passed directly to 
the EMC Exchange database plug-in (avexchange) 
and not avtar. 

OPTION must be enclosed in double-quotes and any 
values that contain spaces must also be enclosed in 
single quotes. For example:

"--pluginflag="--instance='Recovery Storage 
Group'"

--restorelogpath=PATH For Exchange 2000/2003, this option specifies 
where restored logs are written to. This location is 
separate from the log files of the running database. 

This option might be necessary if there is 
insufficient space available on C:. Default is C:\TMP.
NOTE:  Formal support for mixed-case option
--RestoreLogPath was discontinued in version 
2.1. However, while not the preferred syntax, it will 
still work.
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--server=NAME It is possible to backup/restore a remote server 
with avexchange though the communication is done 
by way of unsecured RPC calls. This might be useful 
in the future if we get feedback that customers are 
overly sensitive about the load we put on an 
Exchange server for backups.

If NAME is left empty, server name is localhost.
NOTE:  Formal support for mixed-case option 
--Server was discontinued in version 2.1. 
However, while not the preferred syntax, it will still 
work.

--skipmounted Will skip mounted databases on restore without 
flagging an error. It should be noted that if all the 
databases are mounted, a restore will do nothing 
and not return an error. This is used as the way to 
selectively restore only those databases which are 
currently unmounted, so that a user can restore 
selected databases within a storage group on an 
Exchange Server.
This option added in version 3.0.1.

--timing Shows millisecond timing information.

--usage Shows a list of available options.

--verbose | -V Supplying either --verbose or -v turns on verbose 
information including showing the transfer rate 
each second and creating more detailed logs.
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Exchange - Message Plug-In
The actual mechanism used to accomplish Exchange backups involves several 
specialized avtar options, which enable avtar (on the client) to communicate 
with an Exchange database by way of Messaging Application Programming 
Interface (MAPI) protocol. Using these MAPI options, avtar traverses an Exchange 
server as it would any other filesystem. 

For database backup, the plug-in mechanism relies on a executable (avexchange), 
which must also be installed on the client (Exchange server). 

All items in exchange are stored as messages. This includes but is not limited to 
messages, tasks, notes, calendar items and contacts.

avtar considers all messages as files during its message based backup.

Message Identifiers

Messages are identified using the display name. The display name varies 
according to the message type as follows:

The storage hierarchy is the same hierarchy shown in Outlook.

MAPI Storage Path Syntax

The path name conventions for the Exchange hierarchy are:

Contacts for each mailbox are also backed up.

MESSAGE TYPE DISPLAY NAME

Email Subject line

Tasks Title line

Calendar Subject line

Contact Contact name

Notes Title line

"" All mailboxes.

\@public All public mailboxes.

\MAILBOX-NAME Private MAILBOX-NAME.
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avtar MAPI Options

Example avtar Command Lines

Although these command line examples continue (wrap) to more than one line, all 
commands and options must be entered on a single command line (no line feeds 
or returns allowed). 

1. This example avtar command line backs up an Exchange server 
(exchange1) to the Avamar server (avamar-1):

avtar --hfsaddr=avamar-1 --id=root@avamar
 --ap=AVAMAR-ROOT-PASSWORD --path=/clients/exchange1
 --mapi --mapiprofile="AvamarBackupProfile" -cv ""

If a list of mailboxes is not supplied (for example, -cv ""), the backup will 
be taken at the default mailbox defined in the MAPI profile (MS Exchange 
Settings) and will include all mailboxes and messages below it.

To backup one or more individual mailboxes (and all mailboxes and 
messages below them), include one of the MAPI storage path statements 
(page 86). 

The --mapipassword=PASSWORD option might be required in cases where 
the MAPI profile (MS Exchange Settings) requires password authentication.

2. These example avtar command lines show two ways to list Exchange 
server (exchange1) backups stored on the Avamar server (avamar-1):

avtar --backups --hfsaddr=avamar-1 --id=root@avamar
 --ap=AVAMAR-ROOT-PASSWORD --path=/clients/exchange1

avtar -tv --hfsaddr=avamar-1 --id=root@avamar
 --ap=AVAMAR-ROOT-PASSWORD --path=/clients/exchange1

3. This example avtar command line restores an Exchange server 
(exchange1):

avtar --hfsaddr=avamar-1 --id=root@avamar
 --ap=AVAMAR-ROOT-PASSWORD --path=/clients/exchange1 --mapi
 --mapiprofile="MS Exchange Settings" -xv -target restore

restore is the destination folder for the restore. It will overwrite if the 
target is not specified.

--mapi Uses MAPI protocol to communicate with an 
Exchange server.

--mapiprofile=PROFILE Communicates with Exchange server 
defined in this MAPI PROFILE.

--mapipassword=PASSWORD PASSWORD for --mapiprofile=PROFILE. A 
password might not be required in all 
circumstances.
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