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Warranty

THE MATERIAL CONTAINED IN THIS 
DOCUMENT IS PROVIDED “AS IS,” 
AND IS SUBJECT TO BEING 
CHANGED, WITHOUT NOTICE, IN 
FUTURE EDITIONS. FURTHER, TO 
THE MAXIMUM EXTENT PERMITTED 
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Safety Notices

A CAUTION notice denotes a hazard. It 
calls attention to an operating 
procedure, practice, or the like that, 
if not correctly performed or adhered 
to, could result in damage to the 
product or loss of important data. Do 
not proceed beyond a CAUTION 
notice until the indicated conditions 
are fully understood and met. 

A WARNING notice denotes a hazard. 
It calls attention to an operating 
procedure, practice, or the like that, 
if not correctly performed or adhered 
to, could result in personal injury or 
death. Do not proceed beyond a 
WARNING notice until the indicated 
conditions are fully understood and 
met.
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Where to Find the Latest Information

Documentation is updated periodically. For the latest information about these products, including instrument software 
upgrades, application information, and product information, browse to one of the following URLs, according to the name 
of your product:

http://www.keysight.com/find/X-Series_SG

To receive the latest updates by email, subscribe to Keysight Email Updates at the following URL:

http://www.keysight.com/find/MyKeysight

Information on preventing instrument damage can be found at:

www.keysight.com/find/PreventingInstrumentRepair

Is your product software up-to-date?

Periodically, Keysight releases software updates to fix known defects and incorporate product enhancements. To search 
for software updates for your product, go to the Keysight Technical Support website at:

http://www.keysight.com/find/techsupport

http://www.keysight.com/find/techsupport
http://www.keysight.com/find/PreventingInstrumentRepair
http://www.keysight.com/find/MyKeysight
http://www.keysight.com/find/PreventingInstrumentRepair
http://www.keysight.com/find/PreventingInstrumentRepair
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Keysight X-Series Signal Generators

N5171B/72B/73B EXG and N5181B/82B/83B MXG

User’s Guide

1 Signal Generator Overview

— Signal Generator Features on page 2

— Modes of Operation on page 3

— Front Panel Overview on page 5

— Front Panel Display on page 9

— Rear Panel Overview (N5171B, N5172B, N5181B, & N5182B) on page 12

— Rear Panel Overview (N5173B & N5183B) on page 21

To avoid damaging or degrading the performance of the instrument, do 
not exceed  
33 dBm (2W) maximum (27 dBm (0.5W) for N5173N/83B) of reverse power 
levels at the RF input. See also Tips for Preventing Signal Generator Damage 
on www.keysight.com.
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Signal Generator Features

— N5171B/N5181B, RF analog models: 9 kHz to 1 (N5171B only), 3, or 6 GHz (Options 501, 503, 
and 506 respectively)

— N5172B/N5182B, RF vector models: 9 kHz to 3 or 6 GHz (Options 503, and 506 respectively)

— N5173B/N5183B, Microwave analog models: 9 kHz to 13, 20, 31.8 or 40 GHz (Options 513, 520, 
532, and 540 respectively)

— electronic attenuator (N5172B, N5172B, N5181B, N5182B)

— mechanical attenuator (N5173B or N5183B, Option 1E1)

— vector models can include waveforms in list sweep

— automatic leveling control (ALC)

— real-time modulation filtering

— 8648/ESG code compatible

— 10 MHz reference oscillator with external output

— two channel power meter display

— user settable maximum power limit 

— user flatness correction

— external analog I/Q inputs (vector models)

— enhanced assembly replacement

— GPIB, USB 2.0, and 100Base–T LAN interfaces

— deep amplitude modulation providing greater dynamic range

— manual power search (ALC off)

— SCPI and IVI–COM driver 

— multiple baseband generator synchronization when using multiple signal generators 
(master/slave setup)

— with Signal Studio Software, vector models can generate 802.11 WLAN, W–CDMA, cdma2000, 
1xEV–DO, GSM, EDGE, and more

— real-time baseband generator (Option 660)

— pulse train generator (Option 320)

— LF multifunction generator (Option 303)

— narrow pulse modulation, including internal pulse generator (Option UNW)

— analog differential I/Q outputs (vector models, Option 1EL)

— analog modulation: AM, FM, and ΦM (Option UNT)

— arbitrary I/Q waveform playback up to 200 MSa/s (vector models, Option 656/657)
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— external AM, FM, and ΦM inputs (Option UNT)

— Wideband AM (vector models, Option UNT)

— flexible reference input, 1 – 50 MHz (Option 1ER)

— LO In/Out for phase coherency (Option 012)

— phase noise interference (vector models, Option 432)

— expanded license key upgradability (Option 099)

For more details on hardware, firmware, software, and documentation features and options, refer to 
the data sheet shipped with the signal generator and available from the Keysight Technologies 
website at http://www.keysight.com/find/X-Series_SG. 

Modes of Operation
Depending on the model and installed options, the Keysight X-Series signal generator provides up 
to four basic modes of operation: continuous wave (CW), swept signal, analog modulation, and 
digital modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to 
a single frequency and power level. Both the analog and vector models can produce a CW signal.

Swept Signal

In this mode, the signal generator sweeps over a range of frequencies and/or power levels. Both the 
analog and vector models provide list and step sweep functionality.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog 
modulation types available depend on the installed options. 

Option UNT provides AM, FM, and ΦM modulations. Some of these modulations can be used 
together. 

Option 303 provides a multifunction generator that consists of seven waveform generators.

Option UNW provides standard and narrow pulse modulation capability.

The Mod On/Off hardkey and LED functionality are only valid for 
instruments with Option UNT installed.

Refer to 14. Mod On/Off and LED.
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Digital Modulation (Vector Models with Option 65x Only)

In this mode, the signal generator modulates a CW signal with an arbitrary I/Q waveform. I/Q 
modulation is only available on vector models. An internal baseband generator (Option 65x) adds 
the following digital modulation formats:

— Custom Arb Waveform Generator mode can produce a single–modulated carrier or 
multiple–modulated carriers. Each modulated carrier waveform must be calculated and 
generated before it can be output; this signal generation occurs on the internal baseband 
generator. Once a waveform has been created, it can be stored and recalled, which enables 
repeatable playback of test signals. To learn more, refer to “Using the Arbitrary Waveform 
Generator” on page 335.

— Custom Real-Time Waveform Generator mode can produce a single–modulated carrier or 
multiple–modulated carriers. Each modulated carrier waveform must be calculated and 
generated before it can be output; this signal generation occurs on the internal baseband 
generator. Once a waveform has been created, it can be stored and recalled, which enables 
repeatable playback of test signals. To learn more, refer to “Using the Arbitrary Waveform 
Generator” on page 335.

— Multitone mode produces up to 64 continuous wave signals (or tones). Like the Two Tone mode, 
the frequency spacing between the signals and the amplitudes are adjustable. To learn more, 
refer to “Creating a Custom Multitone Waveform” on page 368.

— Two–tone mode produces two separate continuous wave signals (or tones). The frequency 
spacing between the signals and the amplitudes are adjustable. To learn more, refer to Chapter 
15, “Multitone and Two-Tone Waveforms (Option 430).”.

— Dual ARB mode is used to control the playback sequence of waveform segments that have been 
written into the ARB memory located on the internal baseband generator. These waveforms can 
be generated by the internal baseband generator using the Custom Arb Waveform Generator 
mode, or downloaded through a remote interface into the ARB memory. To learn more, refer to 
“Dual ARB Player” on page 151. 
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Front Panel Overview 

1. Host USB

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can 
connect or disconnect a USB device without shutting down or restarting the signal generator. The 
instrument also has a rear panel device USB connector (see page 14) used to remotely control the 
instrument.

2. Display

The LCD screen provides information on the current function. Information can include status 
indicators, frequency and amplitude settings, and error messages. Labels for the softkeys are 
located on the right hand side of the display. See also, “Front Panel Display” on page 9.

3. Softkeys

A softkey activates the function indicated by the displayed label to the left of the key.

4. Numeric Keypad

The numeric keypad comprises the 0 through 9 hardkeys, a decimal point hardkey, a minus sign 
hardkey, and a backspace hardkey. See “Entering and Editing Numbers and Text” on page 41.

Connector Type A

USB Protocol 2.0

22. Power Switch and LEDs 

21. More and LED 

20. Return 

18. Knob 

19. Incr Set 

15. Page 
Down 

16. I Input 
(vector 
models only) 

17. Q Input (vector 
models only) 

12. RF Output 
(N5171B, 
N5172B, 
N5181B, 
N5182B) 

13. RF On/Off and LED 

14. Mod On/Off and LED 

7. MENUS  11. Preset and 
User Preset 

9. Local 
Cancel/(Esc) 

5. Arrows and Select 

6. Page Up 

8. Trigger 

4. Numeric 
Keypad 

3. Softkeys 
2. Display 1. Host USB 

10. Help 
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5. Arrows and Select

The Select and arrow hardkeys enable you to select items on the signal generator’s display for 
editing. See “Entering and Editing Numbers and Text” on page 41.

6. Page Up

In a table editor, use this hardkey to display a previous page. See “Example: Using a Table Editor” 
on page 42. When text does not fit on one page in the display area, use this key in conjunction with 
the PageŚDown key (page 7) to scroll text.

7. MENUS

These hardkeys open softkey menus that enable you to configure instrument functions or access 
information.

8. Trigger

When trigger mode is set to Trigger Key, this hardkey initiates an immediate trigger event for a 
function such as a list or step sweep.

9. Local Cancel/(Esc)

This hardkey deactivates remote operation and returns the signal generator to front panel control, 
cancels an active function entry, and cancels long operations (such an IQ calibration).

10. Help

Use this key to display a description of any hardkey or softkey. See “Viewing Key Descriptions” on 
page 40.

See pageŚ62

See pageŚ56

See pageŚ43

See pageŚ123

See pageŚ133Active only on 
vector models.

See pageŚ43

See pageŚ46

See pageŚ25

See pageŚ129

See pageŚ149

See pageŚ68

See pageŚ70
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11. Preset and User Preset

These hardkeys set the signal generator to a known state (factory or user–defined). See “Presetting 
the Signal Generator” on page 40.

12. RF Output (N5171B, N5172B, N5181B, N5182B)

12. RF Output (N5173B, N5183B)

13. RF On/Off and LED

This hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. The 
RF On/Off LED lights when RF output is enabled.

14. Mod On/Off and LED

This hardkey enables or disables the modulation of the output carrier signal by an active 
modulation format. This hardkey does not set up or activate a format (see “Modulating the Carrier 
Signal” on page 54).

The MOD ON/OFF LED lights when modulation of the output is enabled.

15. Page Down

In a table editor, use this hardkey to display the next page. See “Example: Using a Table Editor” on 
page 42. When text does not fit on one page in the display area, use this key in conjunction with the 
PageŚUp key (page 6) to scroll text.

Connector Standard: 
Option 1EM: 
Impedance:

female Type–N 
Rear panel output 
50 Ω

Damage Levels 50 Vdc, 2 W maximum RF power

Connector Option 
513/520: 
Option 
532/540: 
Option 1ED 
Option 1EM: 
Impedance:

male Precision APC-3.5  
male Precision 2.4 mm  
female Type–N 
Rear panel output 
50 Ω

Damage Levels 0 Vdc, 0.5 W maximum RF power

The Mod On/Off hardkey and LED functionality are only valid for 
instruments with Option UNT installed.
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16. I Input (vector models only)

See also, “I/Q Modulation” on page 209.

17. Q Input (vector models only)

See also, “I/Q Modulation” on page 209.

18. Knob

Rotating the knob increases or decreases a numeric value, or moves the highlight to the next digit, 
character, or item in a list. See also, “Front Panel Knob Resolution” on page 28.

19. Incr Set 

This hardkey enables you to set the increment value of the currently active function. The increment 
value also affects how much each turn of the knob changes an active function’s value, according to 
the knob’s current ratio setting (see “Front Panel Knob Resolution” on page 28).

20. Return 

This hardkey enables you to retrace key presses. In a menu with more than one level, the Return key 
returns to the prior menu page.

21. More and LED

When a menu contains more softkey labels than can be displayed, the More LED lights and a More 
message displays below the labels. To display the next group of labels, press the More hardkey.

22. Power Switch and LEDs

This switch selects the standby mode or the power on mode. In the standby position, the yellow 
LED lights and all signal generator functions deactivate. The signal generator remains connected to 
the line power, and some power is consumed by some internal circuits. In the on position, the green 
LED lights and the signal generator functions activate.

Connector Type: female BNC Impedance: 50 Ω
Signal An externally supplied analog, in–phase component of I/Q modulation. 

The signal level is  = 0.5 Vrms for a calibrated output level.

Damage Levels 1 Vrms

Connector Type: female BNC Impedance: 50 Ω
Signal An externally supplied analog, quadrature–phase component of I/Q modulation. 

The signal level is  = 0.5 Vrms for a calibrated output level.

Damage Levels 1 Vrms
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Front Panel Display

1. Active Function Area

This area displays the currently active function. For example, if frequency is the active function, the 
current frequency setting appears. If the currently active function has an increment value 
associated with it, that value also appears. 

2. Frequency Area

This area displays the current frequency setting.

3. Annunciators

Annunciators show the status of some of the signal generator functions, and indicate error 
conditions. An annunciator position may be used by more than one annunciator; in this case, only 
one of the functions sharing a given position can be active at a given time.

This annunciator appears when...

ΦM Phase modulation is on. If you turn frequency modulation on, the FM annunciator replaces ΦM.

ARB The ARB generator is on. ARB is running and not waiting on a trigger.

ALC OFF The ALC circuit is disabled. The UNLEVEL annunciator appears in the same position if the ALC is enabled and 
is unable to maintain the output level.

AM Amplitude modulation is on.

ARMED A sweep has been initiated and the signal generator is waiting for the sweep trigger event.

ATTNHOLD The attenuator hold function is on. When this function is on, the attenuator is held at its current setting.

AWGN Real Time I/Q Baseband additive white Gaussian noise is on.

BBG DAC A DAC overflow is occurring, adjust the runtime scaling adjust until the BBG DAC annunciator turns off. 
Another annunciator, UNLOCK, appears in the same position and has priority over the BBG DAC annunciator 
(see UNLOCK, below).

CHANCORR The internal channel correction is enabled.

DETHTR The ALC detector heater is not up to temperature. To meet ALC specifications the heater must be at 
temperature.

DIGBUS The digital bus is in use.

5. Error Message Area 6. Text Area 

 
7. Softkey Label Area 

4. Amplitude Area 3. Annunciators 2. Frequency Area 1. Active Function Area 

Scroll Bar
If there is more 
text than can be 
displayed on one 
screen, a scroll 
bar appears here. 
Use the Page Up 
and Page Down 
keys to scroll 
through the text.
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4. Amplitude Area

This area displays the current output power level setting (If the RF Output is off, this area is greyed 
out).

5. Error Message Area

This area displays abbreviated error messages. If multiple messages occur, only the most recent 
message remains displayed. See “Reading Error Messages” on page 68.

6. Text Area

This area displays signal generator status information, such as the modulation status, and other 
information such as sweep lists and file catalogs. This area also enables you to perform functions 
such as managing information (entering information, and displaying or deleting files).

DIGMOD Custom Arb waveform generator is on.

ERR An error message is placed in the error queue. This annunciator does not turn off until you either view all of the 
error messages or clear the error queue (see “Reading Error Messages” on pageŚ68).

EXTREF An external frequency reference is applied.

FM Frequency modulation is on. If you turn phase modulation on, the ΦM annunciator replaces FM.

I/Q I/Q vector modulation is on.

L The signal generator is in listener mode and is receiving information or commands over the GPIB, USB, or 
VXI–11/Sockets (LAN) interface.

M–TONE Multitone waveform generator is on.

MULT A frequency multiplier is set (see “Setting a Frequency Multiplier” on pageŚ108).

OFFS An output offset is set (see “Setting an Output Offset” on pageŚ106).

PN Phase noise interference is on.

PULSE Pulse modulation is on.

R The signal generator is remotely controlled over the GPIB, USB, or VXI–11/Sockets (LAN) interface. When the 
signal generator is in remote mode, the keypad is locked out. To unlock the keypad, press Local (see page 6).

REF An output reference is set (see “Setting an Output Reference” on pageŚ107).

RF OFF The signal generator’s RF Output is not enabled.

S The signal generator has generated a service request (SRQ) over the GPIB, USB, or VXI–11/Sockets (LAN) 
interface.

SWEEP The signal generator is currently sweeping in list or step mode.

SWMAN The signal generator is in manual sweep mode.

T The signal generator is in talker mode and is transmitting information over the GPIB, USB, or VXI–11/Sockets 
(LAN) interface.

T–TONE Two–Tone waveform generator is on.

UNLEVEL The signal generator is unable to maintain the correct output level. This is not necessarily an indication of 
instrument failure; unleveled conditions can occur during normal operation. Another annunciator, ALC OFF, 
appears in the same position when the ALC circuit is disabled (see ALC OFF, above).

UNLOCK Any of the phase locked loops cannot maintain phase lock. To determine which loop is unlocked, examine the 
error messages (see “Reading Error Messages” on pageŚ68).

WATRG The current modulation mode is waiting on the Arb trigger.

WINIT The signal generator is waiting for you to initiate a single sweep.

This annunciator appears when...
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7. Softkey Label Area

This area displays labels that define the function of the softkeys located immediately to the right of 
the display. Softkey labels change, depending on the function selected.
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Rear Panel Overview (N5171B, N5172B, N5181B, & N5182B)

1. AC Power Receptacle

The AC power cord receptacle accepts a three–pronged AC power cord that is supplied with the 
signal generator. For details on line setting requirements and the power cord, see the Getting 

Started Guide.

To avoid the loss of data, GPIB settings, or current user instrument states 
that have not been permanently saved to non-volatile memory, the signal 
generator should always be powered down either via the instrument’s 
front panel power button or the appropriate SCPI command. Signal 
generators installed in rack systems and powered down with the system 
rack power switch rather than the instrument’s front panel switch display a 
Error -310 due to the instrument not being powered down correctly.

4. SWEEP OUT 

2. EXT 1 & 
EXT 2 

5. PULSE 

6. TRIG 1 & 2 

7. REF IN 

9. GPIB 10. LAN 

11. Device USB 

8. 10 MHz OUT 

1. AC Power Receptacle 

Option 1EM 
only  
See pageŚ7

Digital Modulation Connectors (Vector Models 
Only) on page 15

12. Host USB 

13. SD Card 

3. LF OUT 
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2. EXT 1 & EXT 2

3. LF OUT

4. SWEEP OUT

5. PULSE

6. TRIG 1 & 2

7. REF IN

In its factory default mode, the signal generator can detect a valid reference signal at this 
connector and automatically switch from internal to external reference operation. See “Presetting 
the Signal Generator” on page 40. With Option 1ER (flexible reference input), you must explicitly 
tell the signal generator the external reference frequency you wish to use; enter the information 
through the front panel or over the remote interface.

Connector female BNC Impedance nominally 50 Ω
Signal An externally supplied ±1 Vp signal that produces the indicated depth.

Damage Levels 5 Vrms and 10 Vp

Connector female BNC Impedance 50 Ω
Signal Voltage range: 0 to +5 Vp 

Offset: -5 V to +5 V, nominal

For more information, see page 129.

Connector female BNC  
Can drive 2 kΩ.

Impedance <1 Ω

Signal Voltage range: 0 to +10 V, regardless of sweep width 
In swept mode: beginning of sweep = 0 V; end of sweep = +10 V 
In CW mode: no output

This is a multiple use connector. For signal routing selections, see pages 47 and 133.

Connector female BNC Impedance nominally 50 Ω
Signal Externally supplied: +1 V = on; 0 V = off 

Damage Levels ≤ −0.3 and ≥+5.3 V

Connector female BNC Impedance high Z

Signal An externally supplied TTL or CMOS signal for triggering operations, such as point to point in 
manual sweep mode or an LF sweep in external sweep mode. 
Triggering can occur on either the positive or negative edge.

Damage Levels ≤ −0.5 and ≥+5.5 V

Connector female BNC Impedance nominally 50 Ω
Signal An externally supplied −3.5 to +20 dBm signal from a timebase reference that is within ±1 ppm.
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8. 10 MHz OUT

9. GPIB

This connector enables communication with compatible devices such as external controllers, and is 
one of three connectors available to remotely control the signal generator (see also 10. LAN and 
11. Device USB).

10. LAN

The signal generator supports local area network (LAN) based communication through this 
connector, which enables a LAN–connected computer to remotely program the signal generator. 
The LAN interface supports auto–MDIX. The signal generator is limited to 100 meters on a single 
cable (100Base–T). For more information on the LAN, refer to the Programming Guide.

11. Device USB

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal 
generator.

12. Host USB

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can 
connect or disconnect a USB device without shutting down or restarting the signal generator. 

13. SD Card

Holds the Secure Digital (SD) non-volatile memory card.

Connector female BNC Impedance nominally 50 Ω
Signal A nominal signal level greater than 4 dBm.

Connector Type B

USB Protocol Version 2.0

Connector Type A

USB Protocol 2.0
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Digital Modulation Connectors (Vector Models Only)

I OUT, Q OUT,  OUT,  OUT

BB TRIG 1 & BB TRIG 2

EVENT 1

 OUT and  OUT, require Option 1EL.

Connector Type: female BNC Impedance: 50 Ω  
DC–coupled

Signal

 I OUT The analog, in–phase component of I/Q modulation from the internal baseband generator.

 Q OUT The analog, quadrature–phase component of I/Q modulation from the internal baseband 
generator.

  OUT Used in conjunction with the I OUT connector to provide a balanceda baseband stimulus.

a. Balanced signals are signals present in two separate conductors that are symmetrical relative 
to ground, and are opposite in polarity (180 degrees out of phase).

  OUT Used in conjunction with the Q OUT connector to provide a balanceda baseband stimulus.

Damage Levels > 1 Vrms DC Origin 
Offset

typically <10 mV

Output Signal Levels into a 50 Ω Load

— 0.5 Vpk, typical, corresponds to one unit length of the I/Q vector
— 0.69 Vpk (2.84 dB), typical, maximum crest factor for peaks for π/4 DQPSK, 

alpha = 0.5
— 0.71 Vpk (3.08 dB), typical, maximum crest factor for peaks for π/4 DQPSK, 

alpha = 0.35
— Typically 1 Vp–p maximum

Connector female BNC Impedance nominally 50 Ω
Signal Reserved for arbitrary and real-time baseband generators I/O, such as markers or trigger inputs.

Connector female BNC Impedance: nominally 50 Ω
Signal A pulse that can be used to trigger the start of a data pattern, frame, or timeslot.  

Adjustable to ± one timeslot; resolution = one bit 
Markers 
Each Arb–based waveform point has a marker on/off condition associated with it.  
Marker 1 level = +3.3 V CMOS high (positive polarity selected); –3.3 V CMOS low (negative 
polarity selected).  
Output on this connector occurs whenever Marker 1 is on in an Arb–based waveform (see 
“Using Waveform Markers” on pageŚ167).

Damage Levels < −4 and > +8 V

I Q

I Q

I

Q
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PAT TRIG

DIGITAL BUS I/O

This is a proprietary bus used by Keysight Technologies signal creation software. This connector is 
not operational for general purpose use. Signals are present only when a signal creation software 
option is installed (for details, refer to http://www.keysight.com/find/signalcreation).

Connector female BNC 

Signal A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger.  
The input to this connector triggers the internal digital modulation pattern generator to start a 
single pattern output or to stop and re–synchronize a pattern that is being continuously output. 
To synchronize the trigger with the data bit clock, the trigger edge is latched, then sampled 
during the falling edge of the internal data bit clock.  
This is the external trigger for all ARB waveform generator triggers.

Minimum Trigger Input Pulse 
Wid th

(high or low) = 10 ns

Minimum Trigger Delay (trigger edge to first bit of frame) = 1.5 to 2.5 bit clock periods

Damage Levels < −4 and > +8 V

The X-Series’ Digital BUS I/O connector can be used for enabling 
operation with the Keysight Technologies N5106A PXB MIMO Receiver 
Tester.
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AUX I/O Connector

This female 36-pin connector is available only on instruments with an internal baseband generator 
(Option 653, 655, 656, 657). On signal generators without one of these options, this connector is 
not present. 

The AUX I/O connector allows the X-Series signal generator to interface with external equipment 
by sending and/or receiving supplementary (auxiliary) signaling information. This information is 
non-RF related signaling such as:

— output markers to an external device from Arbitrary waveform playback sent to external 
equipment to trigger or respond to waveform changes.

— output of signal markers to an external device from real-time signal generation personalities. 
Signals such as frame markers, pulse-per-second, and even-second, for example, may be 
supported, depending on the signal generation personality (CDMA, 3GPP, GNSS, LTE, etc.).

— input signals from external devices under test to cause the signal generator to modify 
characteristics of a signal being generated, depending on the signal generation personality 
(CDMA, 3GPP, LTE, etc.).

Table 1-1 on page 19 describes the inputs and outputs accessible through the AUX I/O connector. 
The specific functions controllable by auxiliary signaling vary significantly from one real-time signal 
generation personality to another. Refer to the documentation for each real-time signal generation 
personality for additional information.

The AUX I/O connector supports standard 3.3V TTL signaling levels. 
Signals support data rates up to 50 MHz with minimum rise and fall times 
of 3ns. Any pins that are not connected will have a weak pull-up to 3.3V.

18 1

1936

The AUX I/O connector is a shielded .050 series 

View looking into the rear panel 

The AUX I/O mating connector manufacturer’s part number is 
3M® 10136-3000 (wire mount plug).
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Markers (pins 1-4) 
Each Arb–based waveform point has a marker on/off condition associated with it.  
Each real-time signal can be routed to the output marker signals using SCPI commands or the real-time personalities. 
Marker level = +3.3 V high (positive polarity selected); 0V low (negative polarity selected).

Event 1 (pin 1) 
Pin 1 outputs a pulse that can be used to trigger the start of a data pattern, frame, or timeslot.  
Adjustable to ± one timeslot; resolution = one bit

Data Clock Out (pin 7) 
Pin 7 is used with an internal baseband generator. This pin relays a CMOS bit clock signal for synchronizing serial data. 

Data In (pin 23) 
Pin 23 accepts an externally supplied CMOS-compatible signal data input used with digital modulation applications. The 
expected input is a CMOS signal where a CMOS high is equivalent to a data 1 and a CMOS low is equivalent to a data 0.

The maximum input data rate is 50 Mb/s. The data must be valid on the DATA CLOCK 
falling edges.

Symbol Sync In (pin 25) 
Pin 25 accepts an externally supplied symbol sync signal for use with digital modulation applications. 

Data Clock In (pin 29) 
Pin 29 accepts an externally supplied CMOS-compatible signal data-clock input used with digital modulation applications. 
The expected input is a MCOS bit clock signal where the rising edge is aligned with the beginning data bit. The falling edge 
is used to clock the DATA and SYMBOL SYNC signals.

The maximum clock rate is 50 MHz. 

Event 2 (pin 31) 
Pin 31 outputs data enable signal for gating external equipment. The output is applicable when the external data is clocked 
into internally generated timeslots. Data is enabled when the signal is low.
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Table 1-1 AUX I/O Connector Configuration

MXG and EXG AUX I/O Connector Configuration

ARB & ARB-Based 
Applications

Real-Time Custom 
Modulation

Real-Time 
Applications

BERT Capabil ity 

Pin # Input Output Input Output Input Output Input Output

1 Marker(1) Event 1 Marker(1)

2 Marker(2) Marker(2)

3 Marker(3) Marker(3)

4 Marker(4) Marker(4)

5

6 AUX 
Strobe

7 Data 
Clock 
Output

10MHz 
Clock

8 AUX(0)

9 AUX(1)

10 AUX(2)

11 AUX(3)

12 AUX(4)

13 AUX(5)

14 AUX(6) AUX I/O

15 AUX(7) BER Meas 
Enda

16 AUX(8) BER Sync 

Lossa

17 AUX(9) BER Test 

Outa

18 AUX(10) BER Gate 

Outa

19 AUX(11) BER No 

Dataa

20 GND GND GND GND GND GND

21 AUX(12)
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22 GND GND GND GND GND GND

23 Data 
Input

AUX(13)

24 GND GND GND GND GND GND

25 Symbol 
Sync 
Input

AUX(14)

26 GND GND GND GND GND GND

27 Burst 
Input

AUX(15)

28 GND GND GND GND GND GND

29 Data 
Clock 
Input

AUX 
Sample 
Clock

30 GND GND GND GND GND GND

31 Event 2

32 GND GND GND GND GND GND

33 Data Out AUX 
Out(1)

34 GND GND GND GND GND GND

35 Symbol 
Sync 
Output

AUX 
Out(2)

36 GND GND GND GND GND GND

a. Settings shown are for the Error Out signal configuration of the AUX I/O connector (BERT > I/O 
Setup > Aux I/O Out). Press the Help hardkey, then either Reference Out or PN9 Out for the 
respective signal configuration.

Table 1-1 AUX I/O Connector Configuration

MXG and EXG AUX I/O Connector Configuration

ARB & ARB-Based 
Applications

Real-Time Custom 
Modulation

Real-Time 
Applications

BERT Capabil ity 

Pin # Input Output Input Output Input Output Input Output



Keysight EXG and MXG X-Series Signal Generators User’s Guide                                                                      21

Signal Generator Overview

Rear Panel Overview (N5173B & N5183B)

Rear Panel Overview (N5173B & N5183B)

1. AC Power Receptacle

The AC power cord receptacle accepts a three–pronged AC power cord that is supplied with the 
signal generator. For details on line setting requirements and the power cord, see the Getting 

Started Guide.

To avoid the loss of data, GPIB settings, or current user instrument states 
that have not been permanently saved to non-volatile memory, the signal 
generator should always be powered down either via the instrument’s 
front panel power button or the appropriate SCPI command. Signal 
generators installed in rack systems and powered down with the system 
rack power switch rather than the instrument’s front panel switch display a 
Error -310 due to the instrument not being powered down correctly.

4. SWEEP OUT 

2. EXT 1 & EXT 2 5. PULSE 

6. TRIG 1 & 2 

7. REF IN 

9. GPIB 10. LAN 

11. Device USB 

8. 10 MHz OUT 

1. AC Power Receptacle 

Option 1EM 
only  
See pageŚ7 12. Host USB 

13. SD Card 3. LF OUT 

14. ALC INPUT 
15. Z AXIS OUTPUT 
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2. EXT 1 & EXT 2

3. LF OUT

4. SWEEP OUT

5. PULSE

6. TRIG 1 & 2

7. REF IN

In its factory default mode, the signal generator can detect a valid reference signal at this 
connector and automatically switch from internal to external reference operation. See “Presetting 
the Signal Generator” on page 40. With Option 1ER (flexible reference input), you must explicitly 
tell the signal generator the external reference frequency you wish to use; enter the information 
through the front panel or over the remote interface.

Connector female BNC Impedance nominally 50 Ω
Signal An externally supplied ±1 Vp signal that produces the indicated depth.

Damage Levels 5 Vrms and 10 Vp

Connector female BNC Impedance 50 Ω
Signal Voltage range: 0 to +5 Vp 

Offset: -5 V to +5 V, nominal

For more information, see page <PagenumOnlyCallout>129.

Connector female BNC  
Can drive 2 kΩ.

Impedance <1 Ω

Signal Voltage range: 0 to +10 V, regardless of sweep width 
In swept mode: beginning of sweep = 0 V; end of sweep = +10 V 
In CW mode: no output

This is a multiple use connector. For signal routing selections, see pages 47 and 133.

Connector female BNC Impedance nominally 50 Ω
Signal Externally supplied: +1 V = on; 0 V = off 

Damage Levels ≤ −0.3 and ≥+5.3 V

Connector female BNC Impedance high Z

Signal An externally supplied TTL or CMOS signal for triggering operations, such as point to point in 
manual sweep mode or an LF sweep in external sweep mode. 
Triggering can occur on either the positive or negative edge.

Damage Levels ≤ −0.5 and ≥+5.5 V

Connector female BNC Impedance nominally 50 Ω
Signal An externally supplied −3.5 to +20 dBm signal from a timebase reference that is within ±1 ppm.
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8. 10 MHz OUT

9. GPIB

This connector enables communication with compatible devices such as external controllers, and is 
one of three connectors available to remotely control the signal generator (see also 10. LAN and 
11. Device USB).

10. LAN

The signal generator supports local area network (LAN) based communication through this 
connector, which enables a LAN–connected computer to remotely program the signal generator. 
The LAN interface supports auto–MDIX. The signal generator is limited to 100 meters on a single 
cable (100Base–T). For more information on the LAN, refer to the Programming Guide.

11. Device USB

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal 
generator.

12. Host USB

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can 
connect or disconnect a USB device without shutting down or restarting the signal generator. 

13. SD Card

Holds the Secure Digital (SD) non-volatile memory card.

14. ALC INPUT

This input connector is used for negative external detector leveling.

Connector female BNC Impedance nominally 50 Ω
Signal A nominal signal level greater than 4 dBm.

Connector Type B

USB Protocol Version 2.0

Connector Type A

USB Protocol 2.0

Connector female BNC Impedance nominally 100 kΩ
Signal -0.2 mV to -0.5 V

Damage Levels -12 to 1 V
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15. Z AXIS OUTPUT

This female BNC connector supplies a +5 V (nominal) level during retrace and band-switch intervals 
of a step or list sweep. During step or list sweep, this female BNC connector supplies a -5 V 
(nominal) level when the RF frequency is at a marker frequency and intensity marker mode is on. 
This signal is derived from an operational amplifier output so the load impedance should be greater 
than or equal to 5 kohms.1

Connector female BNC Impedance nominally 50 Ω
Signal A nominal signal level greater than 4 dBm.
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2 Setting Preferences & Enabling Options

The Utility menu provides access to both user and remote operation preferences, and to the menus 
in which you can enable instrument options.

Display SettingsŚon page 27

Front Panel Knob ResolutionŚon page 28

Power On and PresetŚon page 28

Enabling an OptionŚon page 36

GPIB Address and Remote LanguageŚon page 30
Configuring the LAN InterfaceŚon page 31
Enabling LAN Services: “Browser,” “Sockets,” and “VXI–11”Śon page 31
Configuring the Remote LanguagesŚon page 32

User Preferences

Remote Operation Preferences

Setting Time and DateŚon page 29

Upgrading FirmwareŚon page 30

Hardware Assembly Installation and Removal SoftkeysŚon page 37

Reference Oscillator TuneŚon page 29
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User Preferences
From the Utility menu, you can set the following user preferences:

— Display Settings, below

— Power On and Preset on pageŚ28

— Front Panel Knob Resolution on pageŚ28
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User Preferences

Display Settings

X-Series signal generators are shipped from the factory with default 
display settings. Automated Test Environment (ATE) users may benefit 
from display settings other than the default settings. When the signal 
generator display is not required to be active for long periods of time, 
consider using the Screen Saver Mode to extend the life of the display. 

With the brightness set to minimum, the display may be too dark to see 
the softkeys. If this happens, use the figure above to locate the brightness 
softkey and adjust the value so that you can see the display.

Range: 0 to 100

Range: 1 to 12 hours, in 1 hour increments

Light Only: turns the display light off, leaving the text visible at a low intensity. 

Light & Text: turns the display light and the text off.
If the display remains unchanged for long periods of time, use this mode to 
prevent the text from burning the display.

When on, commands executed through 
the remote control bus update the signal 
generator display accordingly.

Bright without color

Utility > Display 

See also, Using Secure DisplayŚon page 394.

For details on each key, use key help 
as described on pageŚ40.

pageŚ394

Dark text on a light 
background.

Light text on a dark 
background.
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Power On and Preset

Front Panel Knob Resolution

Select the GPIB language desired after a preset.
See also, the Programming Guide and the SCPI Command 
Reference.

Utility > Power On/Preset 

Restores persistent settings  
(those unaffected by a power 
cycle*, preset, or recall) 
to their factory defaults.

Available only when 8648 is either the selected preset language or 
the selected remote language (see pageŚ30).

*Caution 
To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to 
non-volatile memory, the X-Series signal generator should always be powered down either via the instrument’s front 
panel power button or the appropriate SCPI command. X-Series signal generators installed in rack systems and 
powered down with the system rack power switch rather than the instrument’s front panel switch display a Error -310 
due to the instrument not being powered down correctly.

Note
To define a user preset, set the instrument up as desired and press User Preset > Save User Preset.

Makes the increment value of the current function the active entry.

Utility >  
Instrument Adjustments 

The increment value and the step/knob ratio determine how much each 
turn of the knob changes the active function value.

For example, if the increment value of the active function is 10 dB and the 
step/knob ratio is 50 to 1, each turn of the knob changes the active 
function by 0.2 dB (1/50th of 10 dB). 

To change the amount for each turn of the knob, modify the increment 
value, the step/knob ratio, or both.

For details on each key, use key help 
as described on pageŚ40.

 pageŚ29.

 pageŚ29.

Executes the ALC Modulator Bias Adjustment. When using 
the ALC in open loop mode, this compensates for open loop 
power drift due to temperature and humidity.

SCPI Commands:
:CALibration:ALC:MODulator:BIAS
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Setting Time and Date

The signal generator’s firmware tracks the time and date, and uses the latest time and date as its 
time/date reference point.

Setting the Time or Date Forward

If you set the time or date forward, be aware that you are using up any installed time–based 
licenses, and that you are resetting the signal generator’s time/date reference point. When you 
set a new time or date that is later than the signal generator’s current reference point, that date 
becomes the new reference point. If you then set the date back, you run the risk described in the 
next section.

Setting the Time or Date Backward

When you set the time back, the signal generator notes that the time has moved back from the 
reference point. If you set the time back more than a few hours, you disable the signal generator’s 
ability to use time–based licenses, even if there is no license installed at the time that you set the 
time back. In this case, you can re-enable the signal generator’s ability to use time–based licenses 
by moving the clock forward to the original time or simply waiting that length of time.

Reference Oscillator Tune

CAUTION Changing the time or date can 
adversely affect the signal 
generator’s ability to use time

— based licenses, even if a 
time

— based license is not 
installed.

Utility >  
Instrument Adjustments >

Original time/date reference point

Time

New time/date reference point

Tunes the internal VCTXCO oscillator frequency. 

The user value offsets the factory tuned value (the value is added to the 
factory calibrated DAC value). The tune value of 0 sets the factory 
calibrated value.

The range; –8192 to 8192, can be set by using the front panel keypad, 
knob or remote command. 

For details on each key, use key help 
as described on pageŚ40.

See also the SCPI Command Reference.

Utility > Instrument Adjustments 
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Upgrading Firmware
For information on new firmware releases, go to http://www.keysight.com/find/upgradeassistant.

Remote Operation Preferences
For details on operating the signal generator remotely, refer to the Programming Guide.

GPIB Address and Remote Language

pageŚ31

pageŚ31

NOTES
USB is also available. It is not shown in the menu because it requires no configuration.
For details on using the instrument remotely, see the Programming Guide.

Select the desired language. 

This setting is not persistent and is cleared by performing an 
instrument Preset. In most cases, it is best to use Utility > Power 
On/Preset > Language for a permanent language change. See 
pageŚ32. 

For details on each key, use key help as described on pageŚ40.

Select On to view the associated SCPI command for a key press.

Select On to place a copy of every subsequent SCPI command 
executed in the log.
Select Off to stop logging. Selecting Off does not clear the log.
Press the Clear SCPI Log softkey to clear the log.
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Configuring the LAN Interface

Enabling LAN Services: “Browser,” “Sockets,” and “VXI–11” 

NOTES 
Use a 100Base–T LAN cable to connect the 
signal generator to the LAN. 

Use a crossover cable to connect the signal 
generator directly to a PC.

For details on using the instrument remotely, 
refer to the Programming Guide and to 
www.keysight.com and search on FAQs: 
Hardware Configurations and Installation for the 
Keysight MXG.

Utility > I/O Config

Values are listed in the 
Programming Guide

For details on each key, use key help as described on pageŚ40.

 pageŚ31.

Enable remote (browser) 
access to the 
instrument’s file system. Use a browser to control 

the signal generator.

Utility > I/O Config

For details on each key, use key help 
as described on pageŚ40.

License Manager Server (On) 
allows updates of the 
instrument licenses, disable 
for additional instrument 
security.

For more information refer to 
the Programming Guide.
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Configuring the Remote Languages

Figure 2-1 N5171B/72B/81B/82B

Utility > I/O Config

For details on each key, use key help 
as described on pageŚ40.

Select the desired Remote language.

Refer to the SCPI Command Reference.
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Remote Operation Preferences

Figure 2-2 N5173B/83B

Utility > I/O Config

For details on each key, use key help as described on pageŚ40.

Select the desired Remote language.

Refer to the SCPI Command Reference.
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Configuring the Preset Languages

Figure 2-3 N5171B/72B/81B/82B

Utility > Power On/Preset 

For details on each key, use key help 
as described on pageŚ40.

Select the desired Remote language.

pageŚ28

Refer to the SCPI Command Reference.
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Remote Operation Preferences

Figure 2-4 N5173B/83B

Utility > Power On/Preset 

For details on each key, use key help as described on pageŚ40.

Select the desired Remote language.

pageŚ28

Refer to the SCPI Command Reference.
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Enabling an Option
There are two ways to enable an option: 

— Use the License Manager software utility:

1. Run the utility and follow the prompts.

2. Download the utility from www.keysight.com/find/LicenseManager and select license (.lic) 
files from an external USB Flash Drive (UFD).

— Use SCPI commands, as described in the Programming Guide.

Viewing Options and Licenses
Utility >  
Instrument Info

Service Software Licenses 

Waveform licenses from some 
Instrument options appear 
here. A check mark means that 
an option is enabled.

For details on each key, use key help 
as described on pageŚ40.

Signal Studio applications appear here.

appear here.
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Hardware Assembly Installation and Removal Softkeys

 Hardware Assembly Installation and Removal Softkeys
Utility > More  2 of 2 > 

For details on each key, use key help 
as described on pageŚ40.

Verify output attenuator 
operation using a power 
meter at the RF Output.

Select either Enhanced Factory 
Calibration or Factory Calibration 
to calibrate your instrument.

The Enhanced Factory 
Calibration requires a spectrum 
analyzer in addition to a power 
meter.

The Factory Calibration uses only 
a power meter.

Whether a softkey 
is available depends 
on the model of signal 
generator.

Whether a softkey is 
available depends on 
the model of signal 
generator.
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3 Basic Operation

This chapter introduces fundamental front panel operation. For information on remote operation, 
refer to the Programming Guide.

— Presetting the Signal Generator on page 40

— Viewing Key Descriptions on page 40

— Entering and Editing Numbers and Text on page 41

— Setting Frequency and Power (Amplitude) on page 43

— Setting ALC Bandwidth Control on page 45

— Configuring a Swept Output on page 46

— Modulating the Carrier Signal on page 54

— Working with Files on page 56

— Reading Error Messages on page 68
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Presetting the Signal Generator

Viewing Key Descriptions

To return the signal generator to a known state, press either Preset or User Preset. 

Preset is the factory preset; User Preset is a custom preset** (see also, pageŚ28). 

To reset persistent settings (those unaffected by preset, user preset, or power cycle*), 
press: Utility > Power On/Preset > Restore System Defaults.

*Caution 
To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to non-volatile 
memory, the instrument should always be powered down either via the instrument's front panel power button or the appropriate SCPI 
command. instrument's installed in rack systems and powered down with the system rack power switch rather than the instrument's 
front panel switch display a Error -310 due to the instrument not being powered down correctly.

**You can create more than one user preset by giving each saved state file a different name (see Figure 3-9 on pageŚ66).

The Help hardkey enables you to display a description of any hardkey or softkey.
To display help text:

1. Press Help.

2. Press the desired key. 
The help displays and the key’s normal function does not execute. 
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Entering and Editing Numbers and Text

Entering Numbers and Moving the Cursor

Entering Alpha Characters

Data entry softkeys appear in various 
menus. If their meaning is not clear in 
context, use the help key (described on 
page 40) to display an explanation. Use the 
softkey next to the alpha table for help on 
the table.

Selecting data that accepts alpha 
characters, displays one of the menus 
shown at right.

Use the arrow keys or knob to highlight the 
desired letter, then press the Select 
hardkey (or the softkey next to the alpha table). To correct errors, use Bk Sp or Clear Text.

To terminate the entry, press the Enter softkey.

A subset of this menu appears for hexadecimal characters. The character menu displays only the 
letters A through F (use the numeric keypad for other values).

Up/down arrow keys increase/decrease a selected (highlighted) numeric value, and move the cursor vertically.

To specify a negative value, enter the
negative sign either before or after

Backspace moves the cursor to the left,
deleting characters as it goes.

Left/right arrow keys move the cursor horizontally.

Page up/down keys move tables of data up and down within the display area.

 

Use the number keys and decimal point to enter numeric data.

Note: Rotating the knob increases or
decreases a numeric value, changes a 
highlighted digit or character, or steps 
through lists or items in a row.

the numeric value (this key is a toggle).

For details on each key, see pageŚ40.

Use the Select hardkey to choose part of an entry, as when entering alpha 
characters. In some menus, the Select key also acts as a terminator, and is 
equivalent to the Enter softkey.

See also “Front Panel Knob Resolution” on pageŚ28.

to move the cursor 
within the active value 
rather than within the 
alpha table, turn the 
alpha table off.

Add/edit comments for saved 
instrument state files (see pageŚ62).

Note: File names are limited to 25 characters.
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Example: Using a Table Editor

Table editors simplify configuration tasks. The following procedure describes basic table editor 
functionality using the List Mode Values table editor.

1. Preset the signal generator: Press Preset.

2. Open the table editor: Press Sweep > More > Configure List Sweep.

The signal generator displays the editor shown in the following figure.

3. Highlight the desired item: use the arrow keys or the knob to move the cursor. 

4. (Optional) Display the selected item in the active function area: Press Select.

5. Modify the value:

— If the value is displayed in the active function area, use the knob, arrow keys, or numeric 
keypad to modify the value.

— If the value is not displayed in the active function area, use the numeric keypad to enter the 
desired value (which then appears in the active function area).

6. Terminate the entry:

— If available, press the desired units.
— If units are not displayed, press either Enter (if available) or Select.

The modified item is displayed in the table.

Cursor

Table Editor Softkeys Table Editor Name Table Items

Displays the active item as you edit it. Highlighting indicates the selected item. To make this the active (editable) 
item, either press Select, or simply enter the desired value.

Table items are also 
called data fields.

Used to load, navigate, modify, and 
store table item values. For details 
on each key, use the key help: 
Press the Help hardkey and then 
the desired key.

Active Function Area

Current / Total Number of Pages

Indicates that 
another menu 
is available; to 
display the 
second menu, 
press More.

(vector models only)
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Setting Frequency and Power (Amplitude)

Figure 3-1 Frequency and Amplitude Softkeys

 

pageŚ106

To display the next menu, press More.

For details on each key, use key help 
as described on pageŚ40.

pageŚ44

Refer to the SCPI Command Reference.

Opens the 
Atten/ALC 
Control 
menu.

Enables the optimize signal-to-noise ratio state (Optimize S/N) On or Off.
The optimize signal–to–noise softkey changes the attenuator and alc setting to provide 
optimal signal–to–noise performance; it does not change the RF output power. 
Caution: When the optimize signal-to-noise ratio state is enabled, some increased levels of 
harmonic distortion can occur. This increased harmonic distortion could degrade ACPR and 
EVM.
Note: This mode is mutually exclusive with attenuator hold (Atten Hold), and any modulation 
type. A settings conflict error will be generated if attentuator hold or any modulation is 
activated when optimize signal–to–noise is active (On).

pageŚ45

This softkey sets a user determined 
maximum power level on the 
instrument that is persistent.

Available on vector 
models with BBG. 
Enables the instrument 
to select between two 
power levels with a 
hardware marker or 
using an external BNC.

pageŚ82

In Amplitude mode, this menu is 
automatically displayed when entering 
a numeric value with the front panel 
keypad.

In Frequency mode, this menu is 
automatically displayed when entering 
a numeric value with the front panel 
keypad.

Sets the current relative 
phase of the RF output 
signal as the zero 
reference.
All subsequent 
adjustments are relative 
to this adjustment.

dBuVemf terminates 
the value as dBuV 
electromotive force. 
Emf is the output 
voltage with no load. 
This unit is external 
only. Internal 
representation as well 
as increment and 
decrement values are 
in dBm. 

Note: dBuV, mV, and 
nVemf behave similarly 
(i.e. Values are external 
only. Internal 
representation as well 
as increment and 
decrement values are 
in dBm).

Enables the mode to improve non-harmonics performance (low spurs mode). 

Note: When this mode is enabled, the instrument switching speed and behavior of 
the source’s settled signal are affected.

Modifies the attenuator and ALC settings 
for optimal performance. It does not 
change the RF output power.

Available on 
vector models.
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Example: Configuring a 700 MHz, −20 dBm Continuous Wave Output

1. Preset the signal generator.

The signal generator displays its maximum specified frequency and minimum power level (the 
front panel display areas are shown on page 9).

2. Set the frequency to 700 MHz: Press Freq > 700 > MHz. 

The signal generator displays 700 MHz in both the FREQUENCY area of the display and the 
active entry area.

3. Set the amplitude to −20 dBm: Press Amptd > –20 > dBm.

The display changes to −20 dBm in the AMPLITUDE area of the display, and the amplitude 
value becomes the active entry. Amplitude remains the active function until you press another 
function key.

4. Turn on the RF Output: Press RF On/Off.

The RF Output LED lights, and a 700 MHz, −20 dBm CW signal is available at the RF OUTPUT 
connector.

Using an External Reference Oscillator

When using an external reference, you can select either narrow or wide bandwidth mode.

 

For details on each key, use key help as described on pageŚ40.

Range: 1 to 50 MHz
For guaranteed operation below 2 MHz, select Narrow bandwidth; in Wide bandwidth, 
operation using frequencies below 2 MHz is not guaranteed.

Freq > More

FigureŚ3-2 illustrates the better close in phase noise of the wide bandwidth mode. If the 
external reference you are using is noisy or spurious, use the narrow bandwidth mode.
With Wide bandwidth selected, if you select a frequency less than 2 MHz, the signal 
generator displays a warning message.

uses the signal generator’s internal reference oscillator.

uses the REF IN connector to get it’s Frequency Reference. Note: An error 
screen is displayed if the reference is not connected or is tuned to the wrong 
frequency.
uses the signal generator’s internal reference unless a signal is present at 
the rear panel REF IN connector. If an external signal is present, that signal is 
used as  the reference.

uses the baseband generator clock (BBG) as the reference oscillator source. 
Available on vector models with BBG.
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Setting ALC Bandwidth Control

Figure 3-2 Using an External Reference Oscillator

Setting ALC Bandwidth Control

Figure 3-3 Amplitude Softkeys

To display the next menu, press 
More.

For details on each key, use key help 
as described on pageŚ40.

Refer to the SCPI Command Reference.

Enables the 
automatic 
ALC 
bandwidth 
mode (Auto).
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Configuring a Swept Output
The signal generator has two methods of sweeping through a set of frequency and amplitude 
points:

Step sweep (page 47) provides a linear or logarithmic progression from one selected frequency, 
amplitude, or both, to another, pausing at linearly or logarithmically spaced points (steps) along 
the sweep. The sweep can progress forward, backward, or manually. 

List sweep (page 49) enables you to enter frequencies and amplitudes at unequal intervals, in 
nonlinear ascending, descending, or random order. List sweep also enables you to copy the current 
step sweep values, include an Arb waveform in a sweep (on a vector instrument), and save list 
sweep data in the file catalog (page 61).

Figure 3-4 Sweep Softkeys

Sweep without waiting for  
a trigger at each point.  
Point Trigger pauses for the dwell 
time prior to the first sweep. See 
pageŚ110.

Apply a TTL/CMOS signal to the 
Trigger In connector.

Periodically issue a trigger event to 
whatever selects it as a source.

Using timer trigger with single 
sweep results in a delay prior to the 
first sweep. See pageŚ110.

Trigger on a remote command.

Down sweeps from 
stop to start 
frequency/amplitude.
 
Up sweeps from start 
to stop 
frequency/amplitude.

pageŚ49

The selected sweep type determines the displayed parameter.  
Selecting step sweep also displays the step spacing (Lin or Log).

On vector models:
Available when 
Sweep Type = List

pageŚ53

During a sweep, the swept parameter (frequency, amplitude, or both) turns grey and changes as the parameter sweeps.

Progress Bar: Note that very fast sweeps 
can appear to sweep randomly or 
backward.

pageŚ47

For details on each key, use key help as described on pageŚ40.

 pageŚ47
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Routing Signals

Sweep > More > More > Route Connectors

Step Sweep

Step sweep provides a linear or logarithmic progression from one selected frequency, or amplitude, 
or both, to another, pausing at linearly or logarithmically spaced points (steps) along the sweep. 
The sweep can progress forward, backward, or be changed manually. 

Figure 3-5 Signal Routing Softkeys

These softkeys are 
only available for 
the vector models 
with a BBG.

Routes non 
Step or List 
Sweep signals 
(i.e. SCPI 
command 
development.

Source Settled 
is not affected 
by Trig Out 
Polarity Neg 
Pos softkey 
selection.

Routes Step or 
List Sweep 

For details on each key, use key help as described on pageŚ40.

Opens a menu for 
routing Markers 1 
through 4 to the 
rear panel 
baseband BNC 
connectors.

Routes a signal to the Trig Out (Trig 1 or Trig 2) rear panel 
connectors as follows:

None:  No signals are routed to Trig 1 or Trig 2 BNCs

Sweep Trigger Out: Sweep Trigger Out signal (trigger 
handshake)

Source Settled: Source Settled signal

Pulse Sync: Pulse Modulation Synchronization signal

Pulse Video: Pulse Modulation Video signal

LXI: LXI Trigger Output

Sweep Run: Sweep Run signal (sweep is running)

Other Trigger BNC: The signal on the other Trigger BNC

Pulse BNC: The signal on the PULSE IN BNC

Swept Func Done: Swept Function Sweep Done signal
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Figure 3-6 Sweep Softkeys

Example: Configuring a Continuous, Linear Step Sweep

1. Preset the instrument and open the Sweep/List menu: Press Preset > SWEEP.

Because continuous is the default sweep repeat selection, and linear is the default step 
spacing selection, you do not need to set these parameters.

2. Open the step sweep menu: Press Configure Step Sweep.

3. Set the following parameters:

4. Sweep both frequency and amplitude: Press Return > Return > Sweep > Freq Off On > Amptd 
Off On.

Output: A signal that continuously sweeps from 500 to 600 MHz and from −20 to 0 dBm, with a dwell time of 
500 ms at each of six equally spaced points

Start frequency 500 MHz: Press Freq Start > 500 > MHz

Stop frequency 600 MHz: Press Freq Stop > 600 > MHz

Amplitude at the beginning of the sweep, −20 dBm: Press Amptd Start > −20 > dBm

Amplitude at the end of the sweep, 0 dBm: Press Amptd Stop > 0 > dBm.

6 sweep points: Press # Points > 6 > Enter

Dwell time at each point, 500 milliseconds:
Press More > Step Dwell > 500 > 
msec

Dwell Time = the time that the signal is settled and you can make 
a measurement before the sweep moves to the next point.

(Point to point time is the sum of the value set for the dwell plus 
processing time, switching time, and settling time.) 

Lin = steps equally spaced over the sweep; the output 
changes linearly.

Log = step spacing increases logarithmically over the 
sweep; the output changes exponentially.

Step Sweep and List Sweep dwell times are set 

For details on each key, use key help 
as described on pageŚ40.

Sets the step size for a linear step sweep in frequency (the 
difference between frequency points).

NOTE: Setting the step size will determine the number of 
points in the step sweep based on the current start and stop 
frequencies. Due to the integer number of step points, the 
step size may be adjusted in order to yield a true linear 
sweep between the start and stop frequencies.

Enables protection for the mechanical attenuator by automatically turning on 
Atten Hold during frequency and/or power step sweeps.

This may cause unleveled RF output to occur for certain sweep configurations. 
Disabling this attenuator protection will allow the sweep to optimally set both 
the automatic leveling control (ALC) and output attenuation at each sweep 
point.

When the attenuator protection is disabled, the step dwell time will be set to a 
minimum of 50 ms as a precaution. 

[:SOURce]:SWEep:ATTen:PROTection[:STATe] ON|OFF|1|0
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A continuous sweep begins, from the start frequency/amplitude to the stop 
frequency/amplitude. The SWEEP annunciator displays, and sweep progress is shown in the 
frequency display, the amplitude display, and the progress bar.

5. Turn the RF output on: Press RF On/Off. 

The RF LED lights, and the continuous sweep is available at the RF Output connector.

List Sweep

List sweep enables you to enter frequencies and amplitudes at unequal intervals in nonlinear 
ascending, descending, or random order. List sweep also enables you to copy the current step 
sweep values, include a waveform in a sweep (on a vector instrument), and save list sweep data in 
the file catalog (page 61). Dwell time is editable at each point. For fastest switching speeds, use list 
sweep.

Figure 3-7 List Sweep Configuration Softkeys and Display

see pageŚ50

The selected sweep determines which dwell time the signal generator uses. Step Sweep dwell 
time is the same at each point; List Sweep dwell time can be different at each point.

Dwell Time = the time that the signal is settled and you can make a measurement before the 
sweep moves to the next point.

Point–to–Point Time = the sum of the value set for the dwell plus processing time, switching 
time, and settling time. 

Each line defines the 
corresponding point in 
the sweep. For example, 
line 1 defines point 1.

pageŚ47

Available only on vector models,  
and  
only when Sweep Type = List.

Displays the selected 
sweep type parameters 
(see pageŚ50)

Vector models only

pageŚ47

For details on each key, use key help 
as described on pageŚ40.
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Example: Configuring a List Sweep Using Step Sweep Data

1. Set up the desired step sweep, but do not turn the sweep on. This example uses the step 
sweep configured on page 48.

2. In the SWEEP menu, change the sweep type to list:  
Press SWEEP > Sweep Type List Step to highlight List. 

The display shows sweep list parameters, as shown below.

3. Open the List Sweep menu: Press More > Configure List Sweep.

4. Clear any previously set values from the menu and load the points defined in the step sweep 
into the list: Press More > Preset List > Preset with Step Sweep > Confirm Preset. 

The display updates with the values loaded from the step sweep, as shown.

5. Sweep frequency and amplitude: Press SWEEP (hardkey) > Sweep > Freq Off On > Amptd Off 
On.

Setting the sweep turns on the sweep function; a continuous sweep begins. On the display, 
the SWEEP annunciator appears, and the progress bar shows the progression of the sweep.

6. If not already on, turn the RF output on: Press RF On/Off.  
The RF Output LED lights, and a continuous sweep is available at the RF OUTPUT connector.

Example: Editing List Sweep Points

If you are not familiar with table editors, refer to page 42.

1. Create the desired list sweep. This example uses the list sweep created in the previous 
example.

Vector Models:

Presetting the list clears any 
previously selected waveforms. 

For information on selecting a list 
sweep waveform, see “Example: 
Editing List Sweep Points” on 
pageŚ50.

Waveforms are available 
only on vector models.
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2. If sweep is on, turn it off. Editing list sweep parameters with sweep on can generate an error. 

3. Ensure that the sweep type is set to list: Press SWEEP > Sweep Type List Step to highlight 
List. 

4. In the List Mode Values table editor, change the point 1 dwell time (defined in row 1) to 100 
ms:

a. Press More > Configure List Sweep.
b. Highlight the point 1 dwell time.
c. Press 100 > msec.

The next item in the table (the frequency value for point 2) highlights.

5. Change the selected frequency value to 445 MHz: Press 445 > MHz.

6. Add a new point between points 4 and 5: Highlight any entry in row 4 and press Insert Row. 

This places a copy of row 4 below row 4, creating a new point 5, and renumbers subsequent 
rows.

7. Shift frequency values down one row, beginning at point 5: Highlight the frequency entry in 
row 5, then press More > Insert Item.

This places a copy of the highlighted frequency value in row 6, shifting the original frequency 
values for rows 6 and 7 down one row. The new row 8 contains only a frequency value (the 
power and dwell time entries do not shift down).

8. Change the still active frequency value in row 5 to 590 MHz: Press 590 > MHz. The power in 
row 5 is now the active parameter.

9. Insert a new power value (−2.5 dBm) for point 5, and shift down the original power values for 
points 5 and 6 by one row: Press Insert Item > −2.5 > dBm. 

10.To complete the entry for point 8, insert a duplicate of the point 7 dwell time by shifting a copy 
of the existing value down: Highlight the dwell time in row 7 and press Insert Item.

11.For an analog instrument, go to step 14. For a vector instrument, continue with step 12.

12.Select a waveform for point 2:

a. Highlight the waveform entry for point 2 and press the More > Select Waveform. 
The signal generator displays the available waveforms, as shown in the following example.

b. Highlight the desired waveform (in this example, SINE_TEST) and press either the Select 
hardkey or the Select Waveform softkey.

Either select a waveform, 
pageŚ40

or  

select no modulation.
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13.As desired, repeat step 12 for the remaining points for which you want to select a waveform. 
The following figure shows an example of how this might look.

14.Turn sweep on:  
Press Return > Return > Return > Sweep > Freq Off On > Amptd Off On > Waveform Off On.

15.If it is not already on, turn the RF output on:  
Press RF On/Off. 

The SWEEP annunciator appears on the display, indicating that the signal generator is 
sweeping, and the progress bar shows the progression of the sweep. 

Example: Using a Single Sweep

1. Set up either a step sweep (page 48) or a list sweep (page 50).

2. In the List/Sweep menu, set the sweep repeat to single:  
Press Sweep Repeat Single Cont to highlight Single.

Sweep does not occur until you trigger it.

Note that the WINIT annunciator appears on the display, indicating that the sweep is waiting 
to be initiated.

3. If not already on, turn the RF output on: Press RF On/Off.

4. Initiate the sweep: Press Single Sweep.

A single repetition of the configured sweep is available at the RF Output connector. 

As the signal generator sweeps, the SWEEP annunciator replaces WINIT on the display, and the 
progress bar shows the progression of the sweep. 

At the end of the sweep, there is no progress bar, and the WINIT annunciator replaces SWEEP.

If the instrument is in manual sweep (page 53), the active row (row 6 in the 
figure above) is the selected (manual) point, and the signal generator 
outputs the settings for that selection when the RF output is on.

The empty entry is equivalent to 
choosing CW (no modulation).
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Example: Manual Control of Sweep

1. Set up either a step sweep (page 48) or a list sweep (page 50).

2. In the Sweep/List menu, select a parameter to sweep: Press Sweep > parameter > Return.

3. Select manual mode: Press More > Manual Mode Off On.

When you select manual mode, the current sweep point becomes the selected manual point.

4. If it is not already on, turn the RF output on: Press RF On/Off.

5. Select the desired point to output: Press Manual Point > number > Enter.

The progress bar changes to indicate the selected point.

6. Use the knob or arrow keys to move from point to point. As you select each point, the RF 
output changes to the settings in that selection.

The parameters of the selected sweep point (point 3 
of 6 in this example) define the signal available at the 
RF Output connector.

When you enter a manual point, 
the progress bar moves to and 
stops at the selected point.

The SWMAN annunciator 
indicates that the sweep 
is in manual mode.

When you turn manual mode on, the 
current sweep point becomes the 
manual point.

The currently sweeping 
parameter stops and 
displays the selected point.
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Modulating the Carrier Signal
To modulate the carrier signal, you must have both 

— an active modulation format 
and

— modulation of the RF output enabled

Example

1. Preset the signal generator.

2. Turn on AM modulation: Press AM > AM Off On (requires Option UNT).

You can turn on the modulation format before or after setting signal parameters.

The modulation format generates, but does not yet modulate the carrier signal.

Once the signal generates, an annunciator showing the name of the format appears, indicating 
that a modulation format is active.

3. Enable modulation of the RF output: Press the Mod On/Off key until the LED lights.

If you enable modulation without an active modulation format, the carrier signal does not 
modulate until you subsequently turn on a modulation format.

4. To make the modulated carrier available at the RF output connector, press the RF On/Off key 
until the LED lights.

To turn modulation off, press the Mod On/Off key until the LED turns off. 
 
When the Mod On/Off key is off, the carrier signal is not modulated, even 
with an active modulation format.

See also: “Using Analog Modulation (Option UNT)” on pageŚ123 
“Using Pulse Modulation (Option UNW or 320)” on pageŚ133 
“I/Q Modulation” on pageŚ209

 

Annunciator indicates active AM modulation

AM modulation format on.

A lit LED indicates that any active 
modulation format can modulate 
the carrier.
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Simultaneous Modulation

The Keysight X-Series signal generators are capable of simultaneous 
modulation. All modulation types (AM, FM, fM, Pulse, and I/Q) may be 
simultaneously enabled, but there are some exceptions. Refer to Table 3-1.

Table 3-1 Simultaneous Modulation Type Combinations

AMa

a. Linear AM and Exponential AM cannot be enabled simultaneously. Refer to 
Chapter 6.

FM fM Pulseb

b. Pulse modulation requires Option UNW. Refer to Chapter 7.

I/Q

AM -- x x x x

FM xc

c. FM and fM cannot be enabled simultaneously.

-- not 
applicable

x x

fM xc not 
applicable

-- x x

Pulse x x x -- x

I/Q x x x x --
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Working with Files

— File Softkeys on page 57

— Viewing a List of Stored Files on page 58

— Storing a File on page 60

— Loading (Recalling) a Stored File on page 61

— Moving a File from One Media to Another on page 62

— Working with Instrument State Files on page 62

— Selecting the Default Storage Media on page 67

The signal generator recognizes several types of files, such as instrument state files, license files, 
and list sweep files. Files can be stored either in the signal generator’s internal storage or on the 
USB media. This section provides an overview of how to navigate the signal generator’s file menus, 
and how to view, store, load, and move files.

The Keysight MXG and EXG non-volatile internal memory is allocated according to a Microsoft 
compatible file allocation table (FAT) file system. Refer to the Programming Guide.

See also: Storing, Loading, and Playing a Waveform Segment on page 153.
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File Softkeys

Instrument operating parameters (see pageŚ62).

Sweep data from the List Mode Values table editor.

User flatness calibration corrections.

Note: Available file types depend on the installed options.

For details on each key, use key help as described on pageŚ40.

Deletions require 
confirmation.

Available only with USB connected 
(i.e. Without external USB connected, 
softkeys are greyed out).

pageŚ67

This key changes, depending on 
the selected file. See 

Shows the current directory

pageŚ62

pageŚ62

Requires 
confirmation

The display indicates when the current directory is the default storage path.  
For information on setting the default storage path, see pageŚ67.

When you connect USB media to the instrument, the signal generator displays the USB Media menu and the message External USB Storage attached. When you 
disconnect the USB media, the message External USB Storage detached displays. When you open the External Media menu without USB media connected, the 
signal generator displays the message External Media Not Detected.

The signal generator does not 
format USB media or change file 
permissions. Use a computer to 
perform these operations.

Available only when the 
current directory is not the 
top level directory.

Display internal or USB 
files, depending on the 
selected storage media. 

pageŚ58

Displays IQ Files

Displays FSK 
Files

Displays FIR 
Files

Displays a list of 
Pulse Train files.

Displays Bit 
Files

pageŚ393
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ARB File Softkeys

Viewing a List of Stored Files

The information in this section is provided with the assumption that default storage media is set to 
Auto, as described on page 67.

Viewing a List of Files Stored in the Signal Generator

1. If USB media is connected, disconnect it. The signal generator’s storage media switches to 
internal, so you can now use the file catalogs to see files stored in the signal generator.

2. Select the desired file catalog: Press File > Catalog Type > desired catalog (in this example, 
All). The selected files appear in alphabetical order by file name, as shown in the following 
figure. 

For details on each key, use key help as described on pageŚ40.

Waveform files and their associated marker 
and header information.

Note: Available file types depend on the installed options.

The selected file catalog and 
the storage media
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Viewing a list of Files Stored on USB Media

With USB media connected, you can view files on USB media using either the file catalogs, which 
can display only a selected type of file, or the USB File Manager, which displays all files.

Using the File Catalogs:

— With the USB media connected, select the desired file catalog: press  > Catalog Type > 
desired catalog. The selected files appear in alphabetical order by file name. 

Using the USB File Manager:

— With USB media connected, open the USB File Manager: press File > More > 
USB File Manager.  
The instrument displays the default directory on the USB Media, as shown in the following 
figure. Note that when you attach USB media, the display goes directly to this menu.

Use the Page Up and 
Page Down hardkeys to scroll 
through the contents of the 
directory.
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Storing a File

Several menus enable you to store instrument parameters. For example, you can store instrument 
states, lists, and waveforms.

— An instrument state file contains instrument settings. For this type of file, use the Save hardkey 
shown in Figure 3-8 on page 63.

— For other types of data, use the Load/Store softkey (shown below) that is available through the 
menu used to create the file. 

Use this menu to enter the file name, 
as described on pageŚ41.

For details on each key, use key help as described on pageŚ40.

File Type
List
State
Waveform
User Flatness
User Preset
Pulse Train

Save From
Sweep menu
Save menu
Mode menu
Amplitude menu
User Preset menu
Pulse Train menu

File Length (including extension)

Internal Media: 25 characters

USB Media: 39 characters
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Loading (Recalling) a Stored File

There are several ways to load (recall) a stored file.

— For an instrument state file, use the Recall hardkey shown in Figure 3-8 on page 63.

— For other types of data, use the Load/Store softkey (shown below) that is available through the 
menu used to create the file. 

Loading a File From USB Media

To load a file from USB media, use the USB file manager shown below.

File Type
List
State
Waveform
User Flatness
User Preset
Pulse Train

Recall From
Sweep menu
Save menu
Mode menu
Amplitude menu
User Preset menu
Pulse Train menu

This key changes, depending 
on the selected file. 

If the signal generator does not recognize the file, 
you must select how the file is to be used.

File Type
List
State
Waveform
User Flatness
User Preset
License
Pulse Train

Extension
.list
.state
.waveform
.uflat
.uprst
.lic
.ptrain

Pressing Select with file highlighted...
loads list and starts sweep
load instrument state
loads and plays waveform
loads and applies user flatness
loads and executes user preset
installs purchased license
loads and applies pulse train

For details on each key, use key help as described on pageŚ40.

 
  Copy & Select User Flatness
  Copy & Play Waveform
  Copy & Play Sequence
  Enter Directory
  Recall Instrument State
  Load List
  Load Pulse Train
  Install licenses
  No action (USB disconnected)
  Use As

File > Catalog Type > <type> > More > USB File Manager 
or
File > More > USB File Manager
or
Insert the USB media
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Moving a File from One Media to Another

Use the USB Media Manager to move files between USB and internal media.

Working with Instrument State Files

— Saving an Instrument State on page 64

— Saving a User Preset on page 64

— Recalling an Instrument State on page 64

— Recalling an Instrument State and Associated Waveform File on page 65

— Recalling an Instrument State and Associated List File on page 65

— Moving or Copying a Stored Instrument State on page 66

Selecting a waveform or 
an unknown file type 
displays this softkey.

File > Catalog Type > <type> > More > USB File Manager
or
File > More > USB File Manager
or
Insert the USB Flash Drive (UFD)

For details on each key, use key help as described on pageŚ40.

This key changes, 
depending on the selected 
file. See pageŚ61

Whether a menu is available 
depends on the selected file. 

Requires confirmation

Catalog Type Menu

pageŚ57

Requires confirmation

Moves up one directory level 

These 
softkeys are 

These 
softkeys 

If the file type is recognized 
the “Filename.xxx copied 
to Internal Storage” is 
displayed.
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Figure 3-8 Save and Recall Softkeys

Table 3-2 

The following information is not stored in a state file:

System Security Level Sweep lists Hostname Remote 
Language

Step increment values

System Security Level Display Pulse Train lists IP Address FTP Server ARB Files

System Security Level State Display State On/Off Subnet Mask Manual DHCP MAC

Web Server (HTTP) Files Default 
Gateway

VXI–11 SCPI User Power 
Correction

Sockets SCPI (TELNET) I/Q Calibration Data

When saved to the signal generator, instrument settings 
(states) save to instrument state memory*. Instrument 
state memory is divided into 10 sequences (0 through 9); 
each sequence comprises 100 registers (00 through 99).

Delete softkeys in the Save and Recall menus enable you 
to delete the contents of a specific register, or the contents 
of all sequences in the state file catalog. 

The signal generator requires that you confirm a deletion.

*Caution 
To avoid the loss of data, GPIB settings, or current user 
instrument states that have not been permanently saved 
to non-volatile memory, the instrument should always be 
powered down either via the instrument's front panel 
power button or the appropriate SCPI command. 
instrument's installed in rack systems and powered down 
with the system rack power switch, rather than the 
instrument's front panel switch display a Error -310 due to 
the instrument not being powered down correctly.For details on each key, use key help 

as described on pageŚ40.
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Saving an Instrument State

1. Preset the signal generator and set the following:

2. (Optional, vector models only) Associate a waveform file with these settings: 

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired file and press Select Waveform. If the file is not listed, you must first 

move it from internal or external media to BBG media, see page 153. 

3. Select the desired memory sequence (for this example, 1): Press Save > Select Seq > 1 > 
Enter.

4. Select the desired register (in this example, 01): Press Select Reg > 1 > Save Reg. 

If a waveform is currently selected, saving the instrument state also saves a pointer to the 
waveform file name. 

5. Add a descriptive comment to sequence 1 register 01: 

Press Add Comment to Seq[1] Reg[01], enter the comment and press Enter. The comment 
appears in the Saved States list when you press Recall. If the instrument state has an 
associated waveform, entering the waveform name in the comment makes it easy to identify 
which instrument state applies to which waveform. 

Saving a User Preset

A user preset is a special type of instrument state file.

1. Preset the signal generator and set as desired.

2. Press User Preset > Save User Preset.

This saves a state file named USER_PRESET, which the signal generator recognizes as 
containing user preset information.

You can set up several preset conditions under different names:

1. After you save a user preset, rename it to something other than USER_PRESET (see page 66). 

2. Save as many user presets as you wish, renaming the USER_PRESET file each time.

3. Give the desired file the name USER_PRESET.

Recalling an Instrument State

1. Preset the signal generator.

2. Press Recall.

The Select Seq softkey shows the last sequence used, and the display lists any states stored 
in the registers in that sequence; RECALL Reg is the active entry. 

3. Select the desired instrument state: 

• Frequency: 800 MHz • Amplitude: 0 dBm • RF: on
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If the desired state is listed in the currently selected sequence, press desired number > Enter. 
If not, press Press Select Seq > desired number > Enter > RECALL Reg > desired number > 
Enter.

Recalling an Instrument State and Associated Waveform File 

1. Ensure that the desired waveform file exists, and that it is in BBG media (page 153). 

If the waveform file is not in BBG media, this procedure generates an error.

Recalling an instrument state with an associated waveform file recalls only the waveform 
name. It does not recreate the waveform file if it was deleted, or load the file into BBG media if 
it is in internal or USB media.

2. Recall the desired instrument state (see previous example).

3. View the waveform file name recalled with the instrument state: press Mode > Dual ARB.

The name is displayed as the selected waveform. 

4. Turn on the waveform file: Press Mode > Dual ARB > ARB Off On.

Recalling an Instrument State and Associated List File 

Recalling an instrument state recalls only the list sweep setup. It does not recall the frequency 
and/or amplitude values. Because you must load the list file from the file catalog, when you store a 
list file, be sure to give it a descriptive name (up to 25 characters).

1. Recall the desired instrument state (see previous example).

2. Load the desired list file: 

a. Press Sweep > More > Configure List Sweep > More > Load/Store.

b. Highlight the desired file and press Load From Selected File > Confirm Load From File.

Editing The Comment on an Instrument Comment

Use the following steps to change a comment on an instrument state saved using the Save key. 
This is not the file name that appears in the State catalog (which is the file’s memory location).

1. Press Save

2. Highlight the desired register

3. Press Edit Comment In Seq[n] Reg [nn].

4. Press Re–SAVE Seq[n] Reg[nn]. 

This overwrites previously saved instrument state settings with the new comment. 
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Moving or Copying a Stored Instrument State

Figure 3-9 Instrument State File Catalog

A user–created state file’s default name is its memory location (sequence and register).

To move the file, rename it to the desired sequence and register; you can not give a file the same 
name as an existing file. If you rename a state file to something other than a valid sequence/register 
name, the file does not appear in either the Save or Recall menu.

Sequence Register

The signal generator recognizes only the file named USER_PRESET as user preset information (pageŚ64). 
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Selecting the Default Storage Media

You can configure the signal generator to store user files to either the internal storage or to external 
USB media. To automatically switch between USB media and internal storage, depending on 
whether USB media is attached, select Automatically Use USB Media If Present. To avoid storing 
any confidential information in the instrument, select Use Only USB Media. To avoid storing any 
confidential information to USB media, select Use Only Internal Storage.

This selection is unaffected by power

-

cycle or preset.

File > More > 

Current 
selection

Memory in the instrument is used, and USB media is ignored.

Media attached to the front panel USB connector is used, and no user 
data is stored to internal storage.

This is the recommended selection. When USB media is attached to the 
front panel, it is the selected media; when USB media is not attached, 
internal storage is used.

For details on each key, use key help as described on pageŚ40.

Select the directory on the USB media to be used for all file operations 
when USB media is attached and enabled.
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Reading Error Messages
If an error condition occurs, the signal generator reports it to both the front panel display error 
queue and the SCPI (remote interface) error queue. These two queues are viewed and managed 
separately; for information on the SCPI error queue, refer to the Programming Guide.

Error Message Format

Characteristic Front Panel Display Error Queue

Capacity (#errors) 30

Overflow Handling Drops the oldest error as each new error comes in.

Viewing Entries Press: Error > View Next (or Previous) Error Page

Clearing the Queue Press: Error > Clear Error Queue(s)

Unresolved Errorsa

a. Errors that must be resolved. For example, unlock.

Re–reported after queue is cleared.

No Errors
When the queue is empty (every error in the queue has been read, or the queue is cleared), the 
following message appears in the queue: 
No Error Message(s) in Queue    0 of  0

Error Number Error Message
Error Description 
(May be truncated on the 

−222        Data out of range;   value clipped to lower limit.

Indicates that the user has entered a deviation, depth, or internal 
source frequency that is beyond the specific limits 

Explanation is provided in the Error Message file (see pageŚ387) 
(This is not displayed on the instrument)

Message number and longer description

new indicates a message generated 
since messages were last viewed.

The annunciator indicates an unviewed message.

Error messages appear in the lower left corner 
of the display as they occur.
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4 Optimizing Performance

Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting the power level and frequency, 
refer to Chapter 3, “Basic Operation”, on page  39 and familiarize yourself with the information in 
that chapter.

— Using the Dual Power Meter Display on page 70

— Using the USB Pass Through Commands on page 77

— Using the Power Meter Servo on page 79

— Using Flatness Correction on page 82

— Using Internal Channel Correction (N5172B/82B Only) on page 91

— Using External Leveling (N5173B/83B Only) on page 95

— Using Unleveled Operating Modes on page 102

— Using an Output Offset, Reference, or Multiplier on page 106

— Using Free Run, Step Dwell, and Timer Trigger on page 110

— Using a USB Keyboard on page 112
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Using the Dual Power Meter Display
The dual power meter display can be used to display the current frequency and power of either one 
or two power sensors. The display outputs the current frequency and power measured by the power 
sensors in the larger center display and in the upper right corner of the display. Refer to Figure 4-2, 
Figure 4-2, and Figure 4-3.

Figure 4-1 Dual Power Meter Display with Power Sensors A and B Calibrated

Figure 4-2 Dual Power Meter Display Menu

Once turned on, the 
power meter 
readings are always 
visible, even if 
another instrument 
feature is selected 
(i.e. Sweep, AM, 
etc.).

This area is the main 
display for the dual 
power meter 
calibration frequency 
and current power 
measured.
If channel A or 
channel B power 
sensors or both are 
displayed, and the 
AMPTD or the FREQ 
softkeys are pressed, 
the large power 
meter measurements 
remains displayed.
After the first 
connection, if the 
connection is 
successful, the 
model number and 
serial number of the 
power sensor is 
displayed.

For details on each key, use key help as described on pageŚ40.

See pageŚ71

Enables the power sensor on  
channel A.

Enables the power sensor on 
channel B.

Channel B is configured similarly to 
channel A. See pageŚ71

For details on each key, use key help 
as described on pageŚ40.
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Figure 4-3 Configuring the Power Sensor Channels

Example: Dual Power Meter Calibration

In the following example a U2004A USB Power Sensor is connected to channel A and a N1912A 
P–Series Power Meter and 8482A Power Sensor are connected to channel B and are zeroed and 
calibrated, as required.

On the signal generator:

AUX Fctn > Power Meter 
Measurements 

Sockets LAN: Sets the 
IP port to 5025 (standard) 
or 5023 (telnet) 
programming.

Sets the power meter’s IP 
address or LAN–GPIB 
gateway’s IP address (Sockets 
LAN and VXI–11 LAN only).

Whether a softkey is available 
depends on the selected 
Connection Type. 

VXI–11 LAN: Opens a menu for 
entering a device name for the 
power meter being used.

Enables the power meter 
connection type: Sockets 
LAN, VXI–11 LAN, or USB.

Note: The VXI–11 softkey is 
used to communicate 
remotely with a power meter 
that has a GPIB connector 
via LAN–GPIB gateway.

USB U2000A Series Power 
Sensors do not require the 
sensor to be calibrated.

The MXG/EXG use the 
USB U2000A Series Power 
Sensor’s “Internal” zero. 
Refer to the USB U2000A 
Series Power Sensor’s 
documentation.

Zero Sensor and Calibrate 
Sensor softkeys are 
inactive during a 
measurement.

Selects the frequency that channel A has 
been calibrated to.

Selects the channel on the external 
power meter that the power sensor 
is connected to.

Enables a power offset in dB for 
the current channel.

Enables averaging. Instrument 
default is Auto with 1024 points.

Note: This figure illustrates channel A. Channel B is similar.

For details on each key, use key help as 
described on pageŚ40.
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1. Setup for Step Sweep. “Configuring a Swept Output” on page 46.

2. Connecting the Channel A power sensor: Connect USB sensor to the signal generator. The 
MXG/EXG should display a message across the bottom that reads similar to:  
USB TMC488 device (USB POWER SENSOR,MY47400143) connected

Figure 4-4    MXG/EXG Displays Connection to U2000 USB Power Sensor

3. Press Aux Fctn > Power Meter Measurements > Channel A Setup > Connection Settings > 
Connection Type > USB Device (None) > USB POWER SENSOR (MY47400143)

4. Press Return > Zero Sensor

A diagnostic dialog box appears the initial time that a U2000 Series power sensor with a 
different serial number is connected to the signal generator (refer to Figure 4-5). After the 
U2000 has been recognized by the signal generator, the U2000 power sensor is saved as a 
softkey in the instrument and the dialog box in Figure 4-5 won’t be displayed (press DONE, if 
you see this message).

Figure 4-5    Diagnostic Dialog Box for USB Sensor 

A Running Calibration(s) bar is displayed on the signal generator. Refer to Figure 4-6 on 
page 73.

Verify RF Output power is off before continuing.
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Figure 4-6    Running Calibration(s) Bar (Zeroing Sensor)

Figure 4-7    Diagnostic Dialog Box Displayed for U2000 Power Sensor

5. Press Return > Return > Channel A to On

The current power meter sensor reading should be displayed in the ChA portion of the 
instrument's display and in the upper right portion of the display under Power Meter. Refer to 
Figure 4-8.

Figure 4-8    Channel A Power Sensor Displayed on MXG/EXG

The U2000 Series USB Power Sensor, does not require a 50 MHz 
calibration. If a calibration is attempted with the U2000 Series Power 
Sensors, the signal generator displays a message reading:  
The U2000 series power sensor does not require a 50 MHz 
calibration. Refer to Figure 4-7 on page 73.

For details on 
each key, use key 
help as described 
on pageŚ40.

For details on 
each key, use key 
help as described 
on pageŚ40.

For details on 
each key, use key 
help as described 
on pageŚ40.
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6. On the N1912A P–Series Power Meter (Channel B power sensor): Connect the N1912A 
P–Series Power Meter to the LAN.

7. Connect the power meter sensor to channel B of the power meter.

8. Connect the power sensor input to the 50 MHz reference of the power meter.

9. Press Channel B Setup

10.Press Connection Settings > Sockets

11.Press IP Address > IP address > Enter

Figure 4-9    Channel B Power Sensor with IP Address Entered

12.Press Return > Channel Settings > External Power Meter Channel to B.

It is recommended, but not required to use the channel B on the N1912A. 
This provides continuity with the signal generator’s dual display. For this 
example, the U2004A has already used up the channel A position on the 
signal generator.

The IP address of the power meter should be displayed in the ChB section 
of the display.

For details on 
each key, use key 
help as described 
on pageŚ40.



Keysight EXG and MXG X-Series Signal Generators User’s Guide                                                                      75

Optimizing Performance

Using the Dual Power Meter Display

13.On the signal generator: Press Channel B to On and then back to Off again. This initializes the 
signal generator to the external power meter.

14.Press Return > Zero Sensor

A diagnostic dialog box is displayed each time an external power meter is being used and the 
Zero Sensor or Calibrate Sensor softkey is pressed (refer to Figure 4-10 on page 75). 

Verify the power sensor is connected to the 50 MHz reference of the power meter.

Figure 4-10    Diagnostic Dialog Box for Channel B

15.Press Done

The Running Calibration(s) bar is displayed: Zeroing Sensor Please wait.... 

16.After Running Calibration(s) bar disappears: Press Calibrate Sensor 

Diagnostic Dialog box is displayed that prompts for verifying the connection of the power 
sensor to the power meter 50 MHz reference (refer to Figure 4-11 on page 75).

Figure 4-11    Diagnostic Dialog Box for Calibration

For details on 
each key, use key 
help as described 
on pageŚ40.

For details on 
each key, use key 
help as described 
on pageŚ40.
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17.Press Done

Calibration progress bar is displayed. Refer to Figure 4-12 on page 76.

Figure 4-12    Running Calibration(s) Bar (Calibrating Sensor)

18.Press Return > Channel B to On

19.The current power meter sensor reading should be displayed on the signal generator in the 
ChB portion of the display and in the upper right corner of the display under Power Meter and 
to the left of the Power Meter power sensor reading.

Figure 4-13    Channel B Power Sensor Displayed on MXG/EXG

20.The power sensors are now ready to be connected in a measurement setup.

For details on 
each key, use key 
help as described 
on pageŚ40.

For details on 
each key, use key 
help as described 
on pageŚ40.
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Using the USB Pass Through Commands
The USB pass through SCPI commands are used remotely and or to program your system setup 
and power meter sensor setup.

This section applies to the following USB power sensors:

— U2040 X-Series

— U2020 X-Series

— U8480 Series

— U2000 Series

—

This section contains the following: 

— Table 4-1, “SCPI Pass Through Commands” 

— “Procedure”

Procedure

If the power sensor is configured to return peak power, then the MXG 
displays peak power (i.e., Use the :fetch? and :measure? power sensor 
SCPI commands, which returns a value based on the configuration). Refer 
to the X-Series Signal Generators SCPI Command Reference.

Table 4-1 SCPI Pass Through Commands

:SYSTem:PMETer[1]|2:PASSthrough <"scpiCommand">

:SYSTem:PMETer[1]|2:PASSthrough? <"scpiQuery">

:SYSTem:PMETer[1]|2:PASSthrough:ENABle 0|1

:SYSTem:PMETer[1]|2:PASSthrough:ENABle?

:SYSTem:PMETer[1]|2:PASSthrough:TIMeout <valueInSeconds>

:SYSTem:PMETer[1]|2:PASSthrough:TIMeout?

Step Substeps Resul ts/Notes

1. Setup equipment.

2. Enable the pass 
through capability in 
the MXG.

a. Enter:

:SYSTem:PMETer:PAS
Sthrough:ENABle 1

3. Query the instrument 
and verify pass 
through status.

a. Enter:

:SYSTem:PMETer:PAS
Sthrough:ENABle?

The instrument should return a 1, indicating that the 
pass through feature has been enabled.
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4. Sending additional 
SCPI commands.

If you are sending a 
query, go to step 5.

Else, repeat steps 4 and 
or 5 as needed.

a. Enter:

:SYSTem:PMETer:PAS
Sthrough "SCPI 
command"

Where "SCPI command" is any SCPI pass through 
command. Refer to Table 4-1 on page 77.

5. Sending additional 
SCPI queries.

If you are sending a 
command, go to step 4.

Else, repeat steps 4 and 
or 5as needed.

a. Enter:

:SYSTem:PMETer:PAS
Sthrough? “*IDN?”

The power sensor model and serial number should be 
returned.

Step Substeps Resul ts/Notes
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Using the Power Meter Servo
The Power Meter Servo mode uses power meter readings to adjust the output power of the source, 
maintaining a constant DUT output power.

The servo loop measures the output power of the DUT, compares it to the user-provided reference 
power, and adjusts the output of the source to achieve the user-provided power level within the 
settling error. The servo loop will abort after twenty unsuccessful attempts to achieve the 
user-provided power level.

Figure 4-14 Power Meter Servo Menus

For details on each key, use key help as 
described on see pageŚ40.

See pageŚ71

Sets the allowed 
settling error.

The system automatically adjusts 
power level according to the power 
meter reading.

Once performs the adjustment only at 
the end of any transition (amplitude or 
frequency change). After the 
adjustment is performed and the 
power error is corrected, no further 
adjustments are performed until the 
next transition.

Continuous performs the adjustment 
as in Once mode, and continues to 
adjust the power periodically if the 
value differs by more than the 
specified Settling Error.

N5173B/83B only

N5173B/83B 
only

Sets the relative initial power 
when leveling with the Power 
Meter Servo mode. The 
default of 0 dB means that the 
system starts with the power 
it thinks is needed (based on 
output power, offset and 
reference) but this might lead 
to power overshoots in certain 
cases (especially when the 
offset is not set up correctly). 
This value allows to specify 
an additional safe-margin to 
start the measure/adjust 
cycles lower than the target 
power to protect the device 
from power overshoots.
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Power Meter Servo Configuration

The following procedure is a basic configuration for using the signal generator’s Power Meter Servo 

mode. 

1. Connect the equipment as shown in Figure 4-15.

Figure 4-15    Power Meter Servo Configuration

2. Set the signal generator frequency and amplitude to the desired settings for your device. 

3. On the signal generator, press AMPTD > Leveling Control > Power Meter Servo Configuration.

4. Press Channel A Setup and configure the power meter. Refer to Configuring the Power Sensor 
Channels on page 71.

5. Press Return > Return > Settling Error. Set the Settling Error value. 

6. Press Return > Return > Leveling Mode. Select the leveling mode. 
 
Power Meter Once performs the adjustment only at the end of any transition (amplitude or 
frequency change). After the adjustment is performed and the power is corrected, no further 
adjustments are performed until the next transition. 

The configuration described below is one possible setup example. 
Consider the limits of your DUT and use caution to protect the DUT from 
being exposed to too much power.

To get the best results and reduce stress on the DUT, the amplitude offset 
should be set to match the approximate gain of the device. For example, if 
the DUT is an amplifier with 20 dB of gain, set the amplitude offset to 20 
dB. 
 
Press AMPTD > More > Amptd Offset, then enter a value.

For details on each key, use 
key help as described on 
pageŚ40.

Power Sensor

Directional Coupler
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Power Meter Continuous performs the adjustment as in Once mode, and continues to adjust 
the power periodically if the value differs by more than the specified Settling Error.

Once these parameters are set, the servo loop engages and levels the DUT’s output power. 

Example

The following example emphasizes the importance of setting the amplitude offset, as it protects the 
DUT from being exposed to too much power.

For this example, the source amplitude offset is 20 dB and the source amplitude is programmed to 
25 dBm. The offset is subtracted from the programmed level, making the actual source output 
power 5 dBm. If the power meter measures 24.5 dBm, for example, the output power will be 
adjusted by 0.5 dBm since the power meter measurement is 0.5 dBm lower than the desired 25 
dBm. The new source output power is 5.5 dBm. If the power meter then measures 24.97 dBm, no 
further adjustments will be made since the measured value is within half of the settling error of 0.2 
dB. 

If using the continuous leveling mode, the power meter readings are monitored and the output 
power of the source will be adjusted if the measurement drifts outside the specified settling error.

Continuing with this example, if the amplitude offset remained at the default of 0 dB, the output 
power would have been 25 dBm, resulting in a power meter measurement of 40 dBm (assuming the 
amplifier already went into compression). The algorithm would have reduced the source power by 
15 dB, thus outputting 10 dBm and resulting in a measurement of maybe 29.5 dBm. The additional 
reduction of another 4.5 dB would have lead to the same outcome as with the 20 dB amplitude 
offset (source output power of 5.5 dBm). However, in-between, the DUT was stressed possibly past 
its specified operating range.
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Using Flatness Correction
User flatness correction allows the digital adjustment of RF output amplitude for up to 1601 
sequential linearly or arbitrarily spaced frequency points to compensate for external losses in 
cables, switches, or other devices. Using an Keysight N1911A/12A, E4419A/B, or U2000 Series 
power meter/sensor to calibrate the measurement system, a table of power level corrections can 
automatically be created for frequencies where power level variations or losses occur. Supported 
connection types to the power meter/sensor are Sockets LAN, VXI–11 LAN, USB, and GPIB via 
VXI–11 LAN using a LAN–GPIB gateway (e.g. E5810A Gateway or equivalent).

If you do not have an Keysight N1911A/12A or E4419A/B power meter, or U2000A/01A/02A/04A 
power sensor, or if your power meter does not have a LAN, GPIB, or USB interface, the correction 
values can be manually entered into the signal generator.

To allow different correction arrays for different test setups or different frequency ranges, you may 
save individual user flatness correction tables to the signal generator’s memory catalog and recall 
them on demand.

Follow the steps in the next sections to create and apply user flatness correction to the signal 
generator’s RF output (see page 86).

Afterward, follow the steps in “Recalling and Applying a User Flatness Correction Array” on 
page 90 to recall a user flatness file from the memory catalog and apply it to the signal generator’s 
RF output.

A power meter with GPIB requires using the Connection Type VXI–11 
softkey, as well as a LAN–GPIB gateway, to control a power meter. Refer to 
the Keysight Connectivity Guide USB/LAN/GPIB Connectivity Guide 
(E2094–90009), Keysight X-Series FAQs “How do I connect to the LAN?”, 
and to the E5810A User’s Guide or equivalent, LAN/GPIB gateway device.
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Figure 4-16 User Flatness Correction Softkeys

Confirm

For details on each key, use key help 
as described on pageŚ40.

See 
pageŚ85

Starts the 
user  
flatness 
calibration.
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Creating a User Flatness Correction Array

In this example, you will create a user flatness correction array. The flatness correction array 
contains ten frequency correction pairs (amplitude correction values for each specified frequency), 
from 500 MHz to 1 GHz. 

An Keysight N1911A/12A or E4419A/B power meter and E4413A power sensor are used to 
measure the RF output amplitude at the specified correction frequencies and transfer the results to 
the signal generator. (A U2000 Series power meter/sensor could be used in lieu of the power meter 
and E4413A power sensor.) The signal generator reads the power level data from the power meter, 
calculates the correction values, and stores the correction pairs in the user flatness correction 
array.

If you do not have the required Keysight power meter, or if your power meter does not have a LAN, 
GPIB, or USB interface, you can enter correction values manually. 

Required Equipment

— Keysight N1911A/12A or E4419A/B power meter (a power meter is not required with the 
U2000A/01A/02A/04A Power Sensor)

— Keysight E4413A E Series CW power sensor or U2000A/01A/02A/04A Power Sensor

— GPIB, LAN, or USB interface cables, as required

— adapters and cables, as required

Connect the Equipment

Connect the equipment as shown in “Connect the Equipment” on page 85.

For operating information on a particular power meter/sensor, refer to its 
operating guide.

During the process of creating the user flatness correction array, the power 
meter is remotely controlled by the signal generator.
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Connect the Equipment

Figure 4-17 Configure Power Meter Menu Softkeys

— Keysight N1911A/12A or E4419A/B 
power metera

— Keysight U2000A/01A/02A/04A power 

Sensora

a. For operating information, refer to the power meter/sensor documentation.

— LAN, GPIB, or USB interface 
cables, as required

— adapters and cables, as 
required

The LAN, GPIB*, and USB connections are for 
convenience. If your power meter does not have 
LAN, GPIB, or USB, then manually enter corrections 
as described in the correction entry step in this 
section.

*GPIB control of a power meter requires a 
LAN–GPIB gateway and use of the connection type 
VXI–11. Refer to the Keysight Connectivity Guide 
USB/LAN/GPIB Connectivity Guide (E2094–90009), 
Keysight X-Series FAQs “How do I connect to the 
LAN?”, and to the E5810A User’s Guide or 
equivalent LAN/GPIB gateway device.

Power Sensor

Power Meter  
(if applicable)

Signal 
Generator

Device Under Test

Out In

Input Port

RF Output

Cables 
and other 
Devices

Flatness 
Corrected 
Output 

LAN/ 

Note: Keysight U2000 Series USB 
Power Sensors connect directly to the 
signal generator’s front panel USB 
port (i.e. the power meter is not 
applicable).

USB port for connecting 
USB–compatible power 
meters/sensors (e.g. 
N1911A/12A Power Meters 
and U2000A Series USB 
Power Sensors).

GPIB E5810A 

AMPTD > More > User Flatness > 
Configure Power Meter

Sockets LAN: Sets the IP 
port to 5025 (standard) or 
5023 (telnet) programming.

Sets the power meter’s IP 
address or LAN–GPIB 
gateway’s IP address 
(Sockets LAN and VXI–11 

VXI–11 LAN: Opens a menu 
for entering a device name 
for the power meter being 
used.

Enables the power meter 
connection type: Sockets 
LAN, VXI–11 LAN, or USB.

Note: The VXI–11 softkey is 
used to communicate 
remotely with a power meter 
that has a GPIB connector 
via LAN–GPIB gateway.

USB U2000A Series Power 
Meters do not require the 
sensor to be calibrated.

For details on each key, use key help as 
described on pageŚ40.

Open a menu 
to enter the 
USB device 
name.

This softkey is dependent 
on the selected 
Connection Type.

Attempts to connect to the 
specified external power 
meter and execute a 
“*IDN?” command. If the 
result is “Connected, but no 
*IDN? response”, then the 
IP address connected to 
something, but the socket 
port or VXI-11 device name 
was not correct.



 86                                                                     Keysight EXG and MXG X-Series Signal Generators User’s Guide

Optimizing Performance
Using Flatness Correction

Basic Procedure

1. Create a user flatness array.

a. Configure the power meter/sensor

b. Connect the equipment

c. Configure the signal generator

d. Enter the user flatness correction values

2. Optionally, save the user flatness correction data.

3. Apply user flatness correction to the RF Output.

Configure the U2000A/01A/02A/04A Power Sensor

1. Connect the power sensor to the signal generator’s front panel USB port. Refer to “Connect 
the Equipment” on page 85.

2. Zero the power sensor using the signal generator softkeys.

Configure the E4419A/B and N1911A/12A Power Meter

1. Select SCPI as the remote language for the power meter.

2. Zero and calibrate the power sensor to the power meter, using the softkeys on the signal 
generator or the front panel of the power meter.

3. Enter the power sensor calibration factors into the power meter as required.

Verify the signal generator RF Output power is set to the desired amplitude 
before performing the power meter zero. No RF Output amplitude check is 
done by the signal generator during zero.

The signal generator’s RF Output LED remains unchanged during zeroing 
of the power sensor (e.g. if the RF Output LED was on prior to starting the 
Zeroing of the power sensor, the LED remains on throughout the 
zero/calibration). But, actually the instrument’s firmware has turned off 
the RF Output’s power. 

For operating information on your particular power sensor, refer to its 
operation guide.
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4. Enable the power meter’s cal factor array.

Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction Values

Create the User Flatness Array

1. Configure the signal generator:

a. Preset the signal generator.

b. Set the signal generator’s connection type to the power meter/sensor:

i. Press AMPTD > More > User Flatness > Configure Power Meter > Connection Settings > 
Connection Type > connection type.

ii. If connection type is USB:

1. Zero Sensor

2. Go to step c.

else 
 
If Sockets LAN or VXI–11 LAN: Press Power Meter IP Address > power meter’s or 
LAN–GPIB gateway IP address > Enter.

iii. If Sockets LAN: Press Power Meter IP Port > IP port > Enter.

else

If VXI–11: Press PM VXI–11 Device Name > device name > Enter.

When connecting directly to the power meter, enter the device name as specified in the 
power meter’s documentation. Typically, this is “inst0” and is case sensitive for some 
power meters. Refer to your power meter’s documentation, the Keysight Connectivity 
Guide USB/LAN/GPIB Connectivity Guide (E2094–90009), and Keysight X-Series FAQs 
“How do I connect to the LAN?”

When connecting via a LAN–GPIB gateway, enter the SICL address of the power meter. 
Typically, this is “gpib0,13”, where “gpib0” is the GPIB SICL interface name of the 
gateway and “13” is the GPIB address of the power meter. Refer to the Keysight 
Connectivity Guide USB/LAN/GPIB Connectivity Guide (E2094–90009), Keysight 
X-Series FAQs “How do I connect to the LAN?”, and to the E5810A User’s Guide or 
equivalent, LAN/GPIB gateway device.

The signal generator’s RF Output LED remains unchanged during zeroing 
of the power sensor (e.g. if the RF Output LED was on prior to starting the 
Zeroing of the power sensor, the LED remains on throughout the 
zero/calibration). But, actually the instrument’s firmware has turned off 
the RF Output’s power.

For operating information on your particular power meter/sensor, refer to 
its operating guide.
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c. Open the User Flatness table editor and preset the cal array: 
Press Return > Configure Cal Array > More > Preset List > Confirm Preset with Defaults.

d. In the Step Array menu, enter the desired flatness–corrected start and stop frequencies, 
and the number of points: 

e. Populate the user flatness correction array with the step array configured in the previous 
step: 

Press Return > Load Cal Array From Step Array > Confirm Load From Step Data.

f. Set the output amplitude to 0 dBm.

g. Turn on the RF output.

Press More > Configure Step 
Array > 

Freq Start > 500 > MHz >

Freq Stop > 1 > GHz >

# of Points > 10 > Enter
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2. Connect the power meter to the RF output and enter the correction values:

The user flatness correction array title displays User Flatness: (UNSTORED), without a 
name, indicating that the current user flatness correction array data has not been saved to the 
file catalog.

Optional: Save the User Flatness Correction Data

1. Press Load/Store > Store to File.

2. Enter a file name (for this example, FLATCAL1) and press Enter.

The user flatness correction array file is now stored in the file catalog as a USERFLAT file. Any 
user flatness correction files saved to the catalog can be recalled, loaded into the correction 
array, and applied to the RF output to satisfy specific RF output flatness requirements.

3. Press Return.

Enable the Flatness Correction at the RF Output

— Press Return > Flatness Off On.

With a Power Meter Over LAN, GPIB, or USB Manually

i. Create the correction values: 

Press More > User Flatness > Do Cal.

The signal generator begins the user  
flatness calibration, and displays a 
progress bar.

The amplitude correction values load 
automatically into the  
user flatness correction array.

ii. View the stored amplitude correction 
values: 
Press Configure Cal Array. 

i. Open the User Flatness table editor and 
highlight  
the frequency value in row 1:  
Press More > User Flatness > Configure Cal 
Array.

The RF output changes to the frequency value 
of  
the table row containing the cursor. 

ii. Note the value measured by the power meter.

iii. Change the sign on the delta value (e.g. the 
delta value of the 0 dBm reference value (step 
f), and the measured value from ii is –.34, 
change the value to +.34).

iv. Highlight the correction value in row 1.

v. Press  
Select > enter the delta calculated in step iii > 
dB.

(e.g. For this example enter +.34)

The signal generator adjusts the output 
amplitude  
based on the correction value entered.

vi. Repeat steps ii - v until the power meter 
reads 0 dBm.

vii. Highlight the frequency value in the next row. 

viii.Repeat steps ii through vii for the remaining 
rows.
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The UF annunciator appears in the AMPLITUDE area of the display, and the correction data in the 
array is applied to the RF output.

Recalling and Applying a User Flatness Correction Array

The following example assumes that a user flatness correction array has been created and stored. If 
not, perform the Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction 
Values on page 87.

1. Preset the signal generator.

2. Recall the desired User Flatness Correction file:

a. Press AMPTD > More > User Flatness > Configure Cal Array > More > Preset List > Confirm 
Preset.

b. Press Load/Store.

c. Highlight the desired file.

d. Populate the user flatness correction array with the data contained in the selected file:  
Press Load From Selected File > Confirm Load From File.

The user flatness correction array title displays User Flatness: Name of File.

3. Apply the correction data in the array to the RF output: Press Return > Flatness Off On to On.
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Using Internal Channel Correction (N5172B/82B Only)

The internal channel correction feature flattens the system magnitude and phase response across 
the maximum bandwidth supported by the instrument (up to 160 MHz BW, depending on the 
option). This performance improvement is available at any arbitrary center frequency or amplitude 
level.

Correction filter generation and application is performed internally. The correction filtering occurs 
in real time and is applied to live data.

There are two correction types: factory and user. The Factory Calibration optimizes the performance 
at the front panel RF output connector into a precision 50 ohm load. The User Calibration can 
extend this performance to a new calibration reference plane and deliver the highest signal quality 
to the user’s DUT.

This feature also minimizes unwanted baseband images by flattening (and matching) the 
magnitude and phase response of the I and Q channels from the signal DACs to the IQ modulator.

This calibration should be run when the ambient temperature has varied by at least ±5 degrees 
Celsius from the ambient temperature at which the previous calibration was run.

When this feature is off, the box will behave as it always has. When this feature is on, the internal 
I/Q path is active, the I/Q Correction Optimized Path is RF Output, and the frequency is changed by 
more than 1 kHz, the firmware will calculate a channel correction filter. For List/Sweep, the 
calculation will be done prior to the first sweep using the specified frequencies when either 
waveform sweep is active or the baseband is on and the instrument is optimized for the internal 
path. This calculation will cache corrections for up to the maximum number of cache points (256). 
For list/sweep, the sweep will pause and recalculate the correction caches before running again.

Additional characteristics of the internal channel correction:

— When the internal channel correction is on, arbitrary frequency switching while the baseband is 
on will take up to an additional 290 ms (72 ms typical) the first time that frequency is specified. 
After the first time that a frequency is selected, switching to that frequency again takes an 
additional 1 ms.

There is an internal calibration routine (Factory Calibration) that collects 
correction data for both the baseband and RF magnitude and phase errors 
over the entire RF frequency and power level range on any unit with 
options 653, 655, 656, and 657. The internal channel correction cannot be 
turned on until after the Enhanced Factory Calibration has been executed 
once. See “Perform Enhanced Factory Calibration” on page 94.

In the case of arbitrary frequency switching, once the correction cache is 
full (256 unique frequency points), the oldest frequency corrections will be 
forgotten as new frequencies are selected. 

Whenever I/Q Timing Skew, I/Q Delay, Quadrature Angle Adjustment, or 
the Int Equalization Filter is adjusted, all caches are forgotten.
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— If a frequency sweep is activated, then the calculation and caching will occur up front for the 
first 256 unique frequencies, and all additional unique frequencies will have the characteristics 
of arbitrary frequency switching.

— If the I/Q Correction Optimized Path softkey is set to Ext I/Q, then only the baseband corrections 
will be applied and the frequency switching will be unaffected.

— If active, the ACP Internal I/Q Channel Optimization filter and the Equalization filter, will be 
convolved with the internal channel correction filter. A hamming window is applied and the 
resulting filter will be truncated to 256 taps.
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Figure 4-18 Internal Channel Correction Softkeys

SCPI Commands:
[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe] ON|OFF|1|0
[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe]?
:CALibration:BBG:CHANnel

:MEMory:LOAD:CHANnel <"filename"> 
:MEMory:STORe:CHANnel <"filename">

For details on each key, use key help as described on pageŚ40.

I/Q > More

Toggles on or off the application of the 
internal baseband generator RF and 
baseband magnitude and phase 
corrections across the 160MHz 
baseband bandwidth at the current RF 
frequency.
When this feature is on, arbitrary 
frequency switching while the 
baseband is on will take up to an 
additional 3.3ms (typical) to 6.8ms the 
first time that frequency is specified. 
After that, switching to that frequency 
will take up to an additional 1.3ms. 
Up to 1024 unique frequencies can be 
cached before the oldest cache will be 
forgotten. If a frequency sweep is 
activated, then the calculation and 
caching will occur up front for the first 
1024 unique frequencies, and all 
further unique frequencies will have 
the characteristics of arbitrary 
frequency switching.
If the I/Q Correction Optimized Path is 
set to Ext I/Q Output then only the 
baseband corrections will be applied 
and the frequency switching speed will 
be unaffected.
This correction will be convolved with 
the ACP Internal I/Q Channel 
Optimization filter and the Equalization 
filter if they are active. The resulting 
filter will be truncated to 256 taps.
NOTE: The Enhanced Factory 
Calibration must be executed once 
before the Factory correction type can 
be turned on. See pageŚ94.

Provides additional correction to the 
DUT.
Specify the start and stop frequencies, 
configure the power meter, then 
execute the calibration.

Displays a menu that controls the 
calibration and application of the 
internal baseband generator RF and 
baseband magnitude and phase 
corrections across the entire 
baseband bandwidth.

Toggles on or off the application 
of Factory or User I/Q channel 
correction. 

Factory optimizes the 
performance to the RF output 
connector.

User extends the correction to 
the DUT.

NOTE: The Enhanced Factory 
Calibration must be executed 
once before the Factory 
correction type can be turned on. 
See Perform Enhanced 
Factory Calibration.

To perform the Factory 
calibration, press Utility > More 
> Service > I/Q Int Channel 
Correction Calibrations.

Select either Factory 
Calibration or Enhanced 
Factory Calibration. Follow the 
instructions on the signal 
generator display.
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Configure Internal Channel Correction

The following is a basic configuration for using the signal generator’s internal channel correction. 
Refer to Figure 4-18.

On the signal generator:

1. Set the center frequency:

Press Freq > 3 > GHz

2. Set the I/Q to internal (default):

Press I/Q > I/Q Source > Internal

3. Press I/Q to On

4. Perform internal channel correction:

Press More > Int Channel Correction Off On to On

Using User Corrections

Use a USB power sensor to perform a User Channel Corrections calibration to correct the response 
of the DUT/poor matching network. And, verify the EVM of the DUT with the new User Channel 
Corrections calibration.

Perform Enhanced Factory Calibration

For instruments with firmware prior to B.01.10, the Enhanced Factory Calibration must be run once 
before you can turn on the I/Q Internal Channel Corrections (Factory Correction Type). Optionally, 
this calibration procedure can be run anytime for new calibration data.

On the signal generator:

1. Press Utility > More > Service > I/Q Int Channel Correction Calibrations > Enhanced Factory 
Calibration.

2. Follow the instructions on the signal generator display to complete the calibration.

There is an internal calibration routine (Enhanced Factory Calibration) that 
collects correction data for both the baseband and RF magnitude and 
phase errors over the entire RF frequency and power level range on any 
unit with options 653, 655, 656, and 657. The internal channel correction 
cannot be turned on until after the Enhanced Factory Calibration has been 
executed once.

Depending on the equipment you use, the Enhanced Factory Calibration 
may take up to four hours to complete.
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Using External Leveling (N5173B/83B Only)

External leveling lets you move the ALC feedback source closer to the device under test (DUT) so 
that it accounts for most of the power uncertainties inherent to the cabling and components in a 
test setup. Refer to Figure 4-19.

While operating in external leveling mode, if either the RF or the DC 
connection between the signal generator and the detector is broken, 
maximum signal generator power can occur. This maximum power may 
overstress a power–sensitive device under test.

Atten Hold sets to On and grays out (inactive) with Ext Detector selection. When 
re–selecting Internal, the softkey becomes active, but attenuator hold remains on. If 
desired, manually set it to off.

With the Ext Detector selection, Set Atten has no effect on the output power level. 
During external detector use, use the attenuator to keep the ALC power level at 

approximately 0 dBm when using negative dBm power levels. See pageŚ98.

These settings do not 
change the output power 
amplitude of the signal 
generator, they only let 
you modify the front panel 
display amplitude value so 
it closely approximates the 
power level measured at 
the output of the 
coupler/splitter. See 

pageŚ101.

This softkey works with only the Ext Detector selection. It uses 16 dB as its zero 
reference point.

See page pageŚ70.

Opens a menu in which you can specify the manner in which power is set. 
Power setting can be optimized for different parameters.

Select Optimize S/N to maximize the signal to noise performance in the 
resulting signal.
Select Optimize Harmonics to minimize the amplitude of harmonics in the 
resulting signal.
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Figure 4-19 ALC Circuity

The external detector outputs a negative voltage to the signal generator’s rear panel ALC INPUT 
connector based on the power level at the detector. As the RF power level at the coupler’s/power 
splitter input changes, the external detector returns a compensating negative voltage. The ALC 
circuit uses this negative voltage to level the RF output power by raising and lowering the signal’s 
power, thus ensuring a constant power level at the point of detection (external detector). Since the 
point of detection does not occur at the output of the device to which the detector is connected, 
there is some power loss that is not compensated for by the external detector. For example on a 
coupler, the coupled port siphons some of the signal’s energy to drive the external detector. In 
addition the coupler experiences some insertion loss between the coupled port and the output. 
Figure 4-21 on page 97 shows the input power versus output voltage characteristics for typical 
Keysight Technologies diode detectors. Using this chart, you can determine the leveled power at 
the diode detector input by measuring the external detector output voltage. For a coupler, you 
must then add the coupling factor to determine the leveled output power.

When using an external detector, the signal generator’s power range may vary from the values 
shown in the data sheet. This is primarily due to the efficiency of the detector. Always ensure that 
the detector, coupler/power splitter are specified for the power and frequency range of interest. To 
determine the signal generator’s actual power range during external leveling, see “Determining the 
Signal Generator’s Amplitude Range” on page  100.

With external leveling, the displayed amplitude value can vary significantly from the actual output 
power of the coupler/power splitter to which the external detector is connected (see Figure 4-20). 
This is because the coupler/power splitter has it own signal characteristics (insertion loss, coupling 
factor, and so forth), which are unknown to the signal generator, so it is typically unable to display 
an accurate amplitude value. Also components between the signal generator and the external 
detector can affect the output power of the coupler/power splitter. You can compensate for this 
power display difference by using the  
Ext Leveling Amptd Offset softkey or the Amptd Offset softkey. The difference between the two 
softkeys is that the Ext Leveling Amptd Offset functions only while external leveling is active. For 
more information on using the external leveling offset feature, see “Adjusting the Signal Generator 
Display’s Amplitude Value” on page 101.

External Detector

Power Splitter

Component
DUT

RF

Cabling

OUTPUT

ALC INPUT

ALC Modulator

ALC Internal Detector
Driver

Signal Generator

Leveled Output

(Amp, Filter,
Atten, etc.)

(Negative output)

or Coupler

Opt 1E1 Output 
Attenuator 
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Figure 4-20 Power Value Differences with External Leveling

Figure 4-21 Typical Diode Detector Response at 25° C

Measured output power 
of a coupler

Signal generator set power level
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Option 1E1 Output Attenuator Behavior and Use

When using the internal detector, the Option 1E1 output attenuator enables signal generator 
power levels down to -130 dBm at the RF Output connector. It accomplishes this by adding 
attenuation to the output signal after the ALC detection circuit. The output power value (shown in 
the Amplitude area of the display) is the resultant of the Set Atten and Set ALC Level values (see 
page 95). With the external detector selected, the output attenuator no longer attenuates the 
output signal since the feedback for the detection circuit has been moved beyond the output 
attenuator. Because the attenuator no longer affects the amplitude of the output signal, the output 
amplitude is determined by only the Set ALC Level softkey.

With external leveling selected, the signal generator enables attenuator hold and the power range 
approximates the range of a standard option (no attenuator) signal generator (see the Data Sheet). 
As stated earlier, the actual output power may vary due to the external detector and the 
coupler/power splitter performance characteristics.

Even though the output attenuator no longer affects the output power, it is still useful to drive the 
ALC circuit to its mid–power point of approximately 0 dBm, which is optimal for the internal leveling 
circuitry and typically provides the best amplitude flatness results. This is useful with power values 
of -5 dBm or less. For example, to drive the ALC to approximately mid–power with a -20 dBm 
power setting, add 25 dB of attenuation. This sets the ALC circuit to 5 dBm (-20 + 25).

Configure External Leveling

Basic Setup Process

— If working with a single frequency signal, perform Steps 1 through 5.

— If working with multiple frequencies:

a. Perform Steps 1 through 4.

b. Perform a user flatness correction, see “Using Flatness Correction” on page 82.

— If working with a sweep:

a. Perform Steps 1 through 4.

b. Setup the sweep, see “Configuring a Swept Output” on page 46.

1. Setup the equipment, see “Equipment Setup” on page 99

2. Configure the carrier signal, see “Configuring the Carrier” on page  99

3. Select external leveling, see “Selecting External Leveling” on page 99.

When the internal detector (Internal selection) is reselected, the signal 
generator does not turn the attenuator hold off.

If there is too much attenuation, it will drive the ALC circuit too high and 
cause the signal generator to go unleveled. Ensure that you decrease the 
attenuation as you increase the power level.
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4. Determine the output amplitude range, see “Determining the Signal Generator’s Amplitude 
Range” on page 100

5. Set the displayed power value, see “Adjusting the Signal Generator Display’s Amplitude 
Value” on page 101

Equipment Setup

Set up the equipment as shown in Figure 4-22 on page 99. Place the external detector (detector 
and coupler/power splitter) as close as possible to the DUT.

Recommended Equipment

— Keysight 8474E negative detector

— Keysight 87301D directional coupler

— cables and adapters, as required

Figure 4-22 Typical External Leveling Setup using a Directional Coupler

Configuring the Carrier 

1. Press Preset.

2. Set the carrier frequency.

3. Set the power level to 0 dBm:

— If the signal generator has Options 1E1 and 520, set the output attenuator to zero dBm:

a. Press AMPTD > Atten/ALC Control > Atten Hold Off On to On.

b. Press Set Atten > 0 > dB.

c. Press Set ALC Level > 0 > dBm.

Selecting External Leveling

Press AMPTD > Leveling Control > Leveling Mode > Pwr Meter Cont.

Leveled Signal

Signal Generator CouplerAmplifier

Negative Detector

RF OUTPUT

ALC INPUT
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Determining the Signal Generator’s Amplitude Range

The maximum output amplitude is frequency dependent. So if you are using multiple frequency 
points and there is a need to know the maximum output amplitude for each frequency point, refer 
to the “Amplitude” section of the X-Series Data Sheet. Then use this procedure to determine the 
maximum amplitude for each band.

With external leveling and Option 1E1, the signal generator’s power range approximates that of a 
standard option instrument (no Option 1E1). But Option 1E1 does let you use the attenuator to 
drive the ALC to its mid–power point when using amplitude values less than 0 dBm. However 
adding attenuation does decrease the upper range limit. For more information, see “Option 1E1 
Output Attenuator Behavior and Use” on page  98.

1. If Option 1E1 is installed, adjust the attenuator to the desired level.

a. Press AMPTD > Atten/ALC Control > Atten Hold On > Set Atten.

b. Enter the attenuator value.

2. Turn on the RF output: Press RF On/Off to On

3. Set the AMPTD step increment value to one dB.

— Press AMPTD > Incr Set > 1 > dB.

4. Determine the minimum amplitude value:

a. Set the amplitude to -25 dBm.

b. Using the down arrow key, decrease the amplitude until the UNLEVEL annunciator appears.

c. Using the up arrow key, increase the amplitude until the UNLEVEL annunciator is gone.

The value showing when the UNLEVEL annunciator is gone is the minimum amplitude range 
value.

5. Determine the maximum amplitude value:

a. Set the amplitude to a value that does not cause the signal generator to go unleveled.

b. Using the up arrow key, increase the amplitude until it goes unleveled or an error message 
indicating that the upper limit has been reached shows at the bottom of the display.

c. Decrease the amplitude value:

— If the unleveled annunciator appeared, decrease the amplitude until the annunciator is 
gone. The value where the annunciator disappears is the maximum upper range value.

— If the signal generator displays Error: 501, Attenuator hold setting over 
range at the bottom of the display, the value showing is the maximum upper range 
value. 

If the Option 1E1 output attenuator value is too high (approximately 

³ 55 dB), it will cause an unlevel condition to occur when the RF output is 
turned on.
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To remove the error message, press the down arrow key until the message is gone. The 
error appears when an attempt is made to increase the amplitude beyond the maximum 
value as it relates to the current attenuator setting.

Adjusting the Signal Generator Display’s Amplitude Value

When using external leveling, the signal generator’s displayed amplitude value will not match the 
leveled power of the signal at the output of the coupler/splitter. To compensate for this difference, 
the signal generator provides two methods for configuring the displayed power value so that it 
closely matches the measured value at the output of the coupler/splitter. 

1. Connect and configure a measurement instrument:

a. Connect the output of the coupler/splitter to either a power meter or a signal analyzer.

b. Configure the power meter/signal analyzer for measuring the power level of the signal.

2. Adjust the signal generator’s displayed amplitude value:

— If using the Ext Leveling Amptd Offset Softkey:

This softkey uses 16 dB as its zero reference. The 16dB is the coupling factor of the internal 
detector.

a. On the signal generator, press AMPTD > Leveling Control > Ext Leveling Amptd Offset.

b. While viewing the carrier amplitude value on the signal generator display, use the RPG 
knob (detent knob) to adjust the offset value until the integer part of the displayed 
amplitude value is the same as the integer portion of the measured value.

Each detent position adjusts the value by 1 dB. 

c. Using the number keypad, make the necessary fractional adjustments to the display 
amplitude value.

— If using the Amptd Offset Softkey:

a. On the signal generator, press AMPTD > More > Amptd Offset.

b. Calculate the difference between the signal generators displayed Amplitude value and 
the measured value.

c. Using the numeric keypad, enter this difference as the Amptd Offset softkey value.
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Using Unleveled Operating Modes

Figure 4-23 Power Search and ALC Off Softkeys

ALC Off Mode

Turning ALC off deactivates the signal generator’s automatic leveling circuitry. Turning ALC off is 
useful when the modulation consists of very narrow pulses that are below the pulse width 
specification of the ALC or when up converting external IQ signals and the modulation consists of 

Available only when
ALC = Off

Available only when
Power Search Reference =

Available only when 
Power Search = Span 

Auto: The calibration routine executes whenever 
output frequency or amplitude changes.

Span: Pressing Do Power Search executes the 
power search calibration routine once over a 
selected frequency range.
The corrections are stored and used whenever you 
tune the signal generator to within the calibrated 
frequency range.

For details on each key, use key help as described on pageŚ40.

RMS: Value is a DC 
bias equivalent to the 
value derived from the 
file header or the 
calculated value from 
the current I/Q data.
Fixed: Uses a fixed 0.5 
Vrms value (Same 
value is used with Ext 
I/Q data).
Manual: Allows user to 
specify the DC bias 
voltage value  
(0–1.414 Vrms).
Modulated: Uses the 
AC bias from the actual 
modulating signal.

Manual

User: Enables the 
user to set the 
signal generator 
frequency settings.
Full: The signal 
generator selects 
its full frequency 
range for the power 
search.

Only available when 
I/Q is on. 

These 
softkeys are 
only active 
when an ARB 
waveforms is 
playing in 
memory.

Manual: User must explicitly execute a power 
search to calibrate the open loop ALC level.  

See pageŚ85

Sets the allowed 
settling error.

Only available when 
I/Q is on. 

N5173B/83B only

N5173B/83B only
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slow amplitude variations or bursts that the automatic leveling would remove or distort. When 
using the internal IQ baseband generator, the best technique is to use the ALC hold marker 
function vs. ALC off for the types of signals just described.

Power Search Mode

The MXG/EXG has three power search modes (for internal and external I/Q modulation) and four 
power search references (for external I/Q modulation only). Refer to Figure 4-23 on page 102.

Power search executes a routine that temporarily activates the ALC, calibrates the power of the 
current RF output, and then disconnects the ALC circuitry.

Power Search Modes (Applies to External and Internal I/Q Modulation)

— Auto — A power search is executed at each frequency or power change, and at each change to 
the AM, burst, pulse, or I/Q modulation state.

— Span — When Power Search is set to Span, pressing Do Power Search executes the power 
search calibration routine over a range of user-defined frequencies. The power search is stored 
and used when the signal generator is tuned within a user-defined range. After the Span softkey 
is pressed, select either Full or User. If User is selected, then the start and stop frequencies need 
to be selected.

— Manual — When Power Search is set to Manual, pressing Do Power Search executes the power 
search calibration routine for the current RF frequency and amplitude. In this mode, if there is a 
change in RF frequency or amplitude, you will need to press Do Power Search again.

Power Search References (Only applies to Internal I/Q Modulation)

The four Power Search References control the power search function. These four references select 
the reference voltage used while the RF signal is being I/Q modulated. (Power search references are 

not used for analog modulation: FM, fM, or pulse modulation.)

After the ALC has been turned off, power search must be executed to set 
the proper output power level requested on the front panel. Power search 
is executed automatically by default, but the these settings can be 
overridden by using the Manual mode.

The power search mode cannot be used with bursted signals input via the 
external IQ inputs.

If the power search reference has the incorrect RMS voltage, the output 
power will be incorrect. Refer to Figure 4-24, "Calculating the Output 
Power Error for a Single Waveform Sample Point" and Figure 4-25, 
“Calculating the RMS Voltage of the Waveform.”

A successful power search is dependent on a valid power search reference.
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— Fixed – Reference level is 0.5 Vrms. 

This reference functions with internal, external IQ and bursted signals. This is the instrument’s 
default setting. 

— RMS – User provided reference level 0–1.414 Vrms placed in the Waveform Header. Refer to 
“Saving a Waveform’s Settings & Parameters” on page 161.

This reference functions with internal IQ and bursted signals.

— Manual – User provided reference level 0–1.414 Vrms. 

This reference functions with internal, external IQ and bursted signals. 

— Modulated – Uses the I/Q modulation signal as the reference level.

This reference functions with internal or external IQ. It is not functional with bursted signals or a 
signal with varying Vrms.

Figure 4-24 Calculating the Output Power Error for a Single Waveform Sample Point

Figure 4-25 Calculating the RMS Voltage of the Waveform

The RMS and MANUAL references are the most powerful selections. The user provides the reference 
level. The IQ signal can be bursted (radar) or have different RMS levels (Wireless Signals). Once the 
RMS/MANUAL reference level is set, the power search runs independent of the current Vrms value 
of the waveform. 

The RMS and MANUAL references, with a reference level of 1.0 Vrms are equivalent to a calculated 
rms value of 1 and can be measured using SINE_TEST_WFM. 

20 10 V1( ) V2( )⁄( )log×=

Where:

V1 is the actual waveform RMS voltage

V2 is the entered RMS voltage

The Output Power Error

Note: If the RMS voltage value entered is lower than the actual RMS voltage, the output power will be higher than desired. If the RMS 
voltage value entered is higher than the actual RMS voltage, the output power will be lower than desired.

The signal generator can calculate the RMS value automatically.if more 
than two contiguous IQ data points are zero, the signal generator 
calculation ignores those zero points. Also, because the RMS calculation, 
that is done by the signal generator, is slow and may not be appropriate for 
your application, it is recommended that the user calculate and enter in 
their measured RMS value for the waveform file.

RMS value for the waveform =

SCPI Commands:

[:SOURce]:RADio:ARB:HEADER:RMS <"file_name">,<val>|UNSPecified 
[:SOURce]:RADio:ARB:HEADER:RMS? <"file_name">

For a programming example of determining the RMS voltage of a waveform, refer to the Programming Guide and to the Documentation 
CD that came with this instrument.
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The FIXED, RMS, and MANUAL references use a DAC to apply the reference voltage and do not 

require the IQ signal to be present.

Power Search Settings

For the power search routine to execute, the instrument must be in the following conditions:

— The I/Q modulation enabled On.

— The RF output enabled On.

— The Automatic Leveling Circuitry deactivated (Off).

— The RF Blanking set to On. 

This function prevents power spikes during the power search (refer to “Using the RF Blanking 
Marker Function” on page 178.)

— When using summing for the internal Arb and the external I/Q, all four power reference modes 
are available (e.g. Fixed, RMS, Manual, and Modulated).

— When using the external IQ inputs, use the MANUAL reference mode, and make sure the 
external I/Q signal is present when executing a power search. If the external I/Q signal is not 
present, the power search will fail.

Example: Automatic Power Search

1. Preset the signal generator.

2. Set the desired frequency.

3. Set the desired amplitude.

4. Turn the RF output on.

5. Deactivate the signal generator’s automatic : 

Press AMPTD > ALC Off On to highlight Off

Deactivating the signal generator’s automatic leveling control is a significant instrument 
change that automatically initiates a power search.

The MXG/EXG reference voltage is designed to operate between 0.1 Vrms 
to 1 Vrms nominally, but it can overrange to 1.414 Vrms. (The RMS can 
overrange to 1.414, if the constant values are loaded manually and all “1”s 
are entered for the I and Q values.) See also “Saving a Waveform’s Settings 
& Parameters” on page 161.

The minimum reference level that results in a successful power search is 
dependent on RF Frequency, RF Amplitude, and Temperature. An 
MXG/EXG power search using a reference level of 0.1 Vrms for 0 dBm at 1 
GHz may fail.
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When set to Auto, power search automatically executes when a significant instrument setting 
changes. The Do Power Search feature enables you to decide when to execute a power search to 
compensate for changes, such as temperature drift or a change in the external input.

Using an Output Offset, Reference, or Multiplier

Setting an Output Offset

Using an output offset, the signal generator can output a frequency or amplitude that is offset 
(positive or negative) from the entered value.

RF Output = entered value – offset value

Displayed Value = output frequency + offset value

To set an offset:

— Frequency: Press Freq > Freq Offset > offset value > frequency unit.

— Amplitude: Press Amptd > More > Amptd Offset > offset value > dB.

Examples

When using the signal generator as a local oscillator (LO), you can use the offset to display the 
frequency of interest, as illustrated below:

Parameter
Example

#1
Example

#2
Example

#3
Comments

Entered (and displayed) 
Value:

300 MHz 300 MHz 2 GHz The entered value must be positive.

Offset: 50 MHz −50 MHz −1 GHz An offset value can be positive or negative.

Output Frequency: 250 MHz 350 MHz 3 GHz
The signal generator alerts you if the  
output frequency or amplitude is out of range.

Indicates that an offset is on
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Setting an Output Reference

Using an output reference, the signal generator can output a frequency or amplitude that is offset 
(positive or negative) by the entered value from a chosen reference value. 

RF Output = reference value + entered value

To set a reference:

1. Set the frequency or amplitude to the value you want as the output reference level.

2. Frequency: Press Frequency > Freq Ref Set  
The frequency displays 0.00 Hz, indicating that this is the RF output frequency “zero level.”  
All frequencies entered are interpreted as being relative to this reference frequency.

Amplitude: Press Amptd > More > Amptd Ref Set 
The amplitude displays 0.00 dB, indicating that this is the RF output amplitude “zero level.” 
All amplitudes entered are interpreted as being relative to this reference amplitude.

Examples

Parameter
Example

#1
Example

#2
Example

#3
Comments

Reference: 50 MHz 50 MHz 2 GHz A reference value must be positive.

Entered (and displayed) 
Value:

2 MHz −2 MHz −1 GHz The entered value can be positive or negative.

Output Frequency: 52 MHz 48 MHz 1 GHz
The signal generator alerts you if the output frequency or 
amplitude is out of range.

IF AmplifierRF Amplifier Mixer Filter

Signal Generator
(local oscillator)

Output Frequency = 1000 MHz

IF = 321 MHz

Antenna tuned to 1321 MHz

Selected Offset

321 MHz

−679 MHz

SIgnal Generator Display

1321 MHz  (Antenna 
Frequency)

  321  MHz (IF Output)

IF Output
321 MHz

Indicates that a reference is on
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To set a new frequency or amplitude reference, turn the frequency reference off, and then follow the 
steps above.

Setting a Frequency Multiplier

Using a frequency multiplier, the signal generator can display a frequency that is the multiple 
(positive or negative) of the output value. 

Displayed Value = multiplier value ´ output frequency

Output Frequency = displayed value ¸ multiplier value

To set a frequency multiplier:

1. Press Frequency > Freq Multiplier > multiplier value > x.

2. Set the desired frequency. 
The display equals the output frequency times the multiplier value.

Examples

Parameter
Example

#1
Example

#2
Example

#3
Comments

Frequency Multiplier: 3 −3 4 The multiplier range can be set from:

 +0.001 to +1000

 –1000 to –0.001

Entered (and displayed) 
Value:

600 MHz −600 
MHz

8 GHz

Output Frequency: 200 MHz 200 MHz 2 GHz
The signal generator alerts you if the output frequency is 
out of range.

Indicates that a frequency multiplier is on
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Using the Frequency and Phase Reference Softkeys

When using the signal generator as the input to a system, you can set the frequency multiplier so 
that the signal generator displays the output of the system, as illustrated below using a doubler:

When measuring mixers, the frequency multiplier and frequency offset are often used together. In 
the upconverter example below, the multiplier is set to 

-1 and the offset is set to 3 GHz so that the signal generator displays fRF.

Using the Frequency and Phase Reference Softkeys
The MXG/EXG can be set to have either a user-determined frequency or phase reference.

Figure 4-26 Frequency Reference and Frequency Offset Softkeys

Signal Generator Doubler

Output = 4 GHz
X2

Input = 2 GHz Selected 
Multiplier
2

Signal Generator 
Output
2 GHz

Entered/Displayed 
Frequency
4 GHz

Mixer

Signal Generator
(local oscillator)

fLO = 800 − 600 MHz

fIF = 3000 MHz

Selected 
Multiplier 

−1
−1

Signal Generator 
Output (fLO) 

800 MHz
600 MHz

fRF = 2200  2400 MHz

Selected 
Offset 

3000 MHz
3000 MHz

Entered/Displayed 
Frequency 
(fRF)
2200 MHz
2400 MHz
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Using Free Run, Step Dwell, and Timer Trigger
Free Run, Step Dwell (time), and Timer Trigger can be used to adjust the time spent at any point in 
a Step Sweep or a List Sweep. There are two possible measurement combinations:

Free Run with Step Dwell time (Figure 4-27 on page 111) the signal generator waits for the signal 
to settle and then waits for the Step Dwell time, then it jumps to the next frequency point. In 
addition, the time to complete the entire sweep can vary. There is always a minimum value of Step 
Dwell for each frequency point. The minimum Step Dwell timing for any point is fixed at a value of 
100 us. The time between frequency points is the sum of the settling time, plus the Step Dwell time. 
The settling time is dependent on frequency, amplitude, band crossings, and other factors, so the 
time between frequency points can vary. 

Timer Trigger instead of Free Run (Figure 4-27 on page 111) the signal generator generates 
equally spaced triggers, and it moves to the next point at each trigger. This has the advantage that 
the time between points is consistent and the overall sweep time is consistent. But, if the trigger is 
too fast, the signal may not have time to settle before jumping to the next point.

Understanding Free Run, Step Dwell, and Timer Trigger Setup

If the signal is to be settled for a minimum specific time at each point and it is not important if the 
point to point time is consistent, use Free Run and Set Dwell time.

If the signal’s point to point time requires consistency but the specific settling time at each point 
can vary, then use the Timer Trigger. Avoid using too fast of a sweep which does not allow the 
signal generator to settle.

If the signal needs to be settled for a specific minimum time and consistent point to point time is 
required, then you should set the Timer Trigger to be the sum of the switching time (900 us or 5 ms, 
depending on options) plus the minimum settled time that is needed to make the measurement.

If the measurement requires external equipment synchronization, consider using hardware triggers. 
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Using Free Run, Step Dwell, and Timer Trigger

Figure 4-27 Free Run, Set Dwell, and Timer Trigger Softkeys
Sweep > Configure Step 
Sweep > More 

Use Step Dwell with Free Run when additional measurement wait time is 
desired after settling.
If the signal is to be settled for a minimum specific time at each point and it is 
not important if the point to point time is consistent, use Step Dwell and Free 
Run time.

Sweep > 

If the signal’s point to point time requires 
consistency but the specific settling time 
at each point can vary, then use the 
Timer Trigger. Avoid using too fast of a 
sweep which does not allow the signal 
generator to settle.  
If the signal needs to be settled for a 
specific minimum time and consistent 
point to point time is required, then you 
should set the Timer Trigger to be the 
sum of the switching time (900 us (Option 
UNZ) or 5 ms (Standard)) plus the 
minimum settled time that is needed to 
make the measurement. 
Example: If you need the signal to remain 
settled for 3 ms, and you have Option 
UNZ which settles in 0.9 ms, then set the 
time trigger to the sum which is 3.9 ms.

For details on each key, use key help as described on see pageŚ40.

N5173B/83B only
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Using a USB Keyboard
You can use a USB keyboard to remotely control the RF output state, the modulation state, and to 
select a memory sequence and register. 

The register selection, RF output state, and modulation state are affected by power cycle or preset, 

but the USB keyboard control state and the sequence selection are not.

To avoid the loss of data, GPIB settings, or current user instrument states 
that have not been permanently saved to non-volatile memory, the signal 
generator should always be powered down either via the instrument’s 
front panel power button or the appropriate SCPI command. Signal 
generators installed in rack systems and powered down with the system 
rack power switch rather than the instrument’s front panel switch display a 
Error –310 due to the instrument not being powered down correctly.

Turning the USB keyboard control off disables the USB 
keyboard; it has no effect on the Auto Recall softkeys.

For details on each key, use key help as described on pageŚ40.

USB Keyboard Key
Delete, Enter
Insert
Home, Right Arrow
End, Left Arrow
Page Up, Up Arrow, +
Page Down, Down Arrow, –

Signal Generator Function
RF On/Off
Mod On/Off
Next Sequence
Previous Sequence
Recall Next State Register
Recall Previous State Register

Deletes every register in every sequence.

NOTE: You cannot recover the registers after 
deleting them.
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5 Avionics, Option 302, requires Option UNT  
(Serial Prefixes Ř MY/SG/US5620xxxx)

Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting the power level and frequency, 
refer to Chapter 3, “Basic Operation”, on page 39 and familiarize yourself with the information in 
that chapter.

The Auxiliary Function key (see Figure 5-1) provides access to the Avionics menu and settings:

Figure 5-1 Auxiliary Function key

This feature is available only in Keysight X-Series signal generators N5171/72B and N5181/82B. 

Serial numbers prior to MY/SG/US5620xxxx require a return to Keysight Service Center for 
installation of Option 302. For Keysight contact information see “Contacting Keysight 
Technologies”.

page 114

page 118

page 116

page 120
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VHF Omnidirectional Range (VOR)
The VOR system provides directional information for aircraft in flight. A VOR transmitter radiates a 
carrier that is modulated to provide aircraft bearing information relative to the transmitter location. 
This modulation comprises a reference signal and a variable phase signal. 

The reference signal is modulated onto the carrier such that its phase is independent of the bearing 
at the point of reception. The variable phase signal is modulated such that its phase differs from 
that of the reference signal by an angle equal to the compass bearing from the point of reception to 
the VOR station. The aircraft receiver demodulates and compares the phases of these signals to 
determine the compass bearing to the VOR station. Using the bearing angle from two or more VOR 
stations, pilots can triangulate their exact location.

Figure 5-2 VOR Softkeys

Turns on all VOR signals.

Turns on the sub-carrier modulated with 
the reference tone. 

Turns on only the sub-carrier.

Turns on the carrier and the variable 
phase tone.

Turns VOR modulation off.

Sets the frequency of the  
reference tone and 
the variable phase tone.

Sets AM depth of the variable phase tone.

Sets the FM deviation that the 
reference tone causes on the sub-carrier.

Sets the sub-carrier AM depth as it modulates the main carrier.

Aux Fctn > Avionics > VOR >

Select standard VOR 
carrier frequency. 

Resets only 
VOR parameters.

Does not reset 
Com/ID 
parameters.

Sets the frequency of the sub-carrier.

The reference signal is frequency modulated onto a subcarrier. The modulated subcarrier 
is then amplitude modulated onto the VOR carrier. In essence, the reference signal is an 
FM/AM multiplex signal.

Aircraft receives a signal that is, in effect, an amplitude modulated signal with a phase 
proportional to the bearing of the transmitter.

Sets the frequency of the Com/ID.

Sets COM/ID tone AM depth.

Allows the user to set the 
code to be played by the 
Com/ID generator.
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VHF Omnidirectional Range (VOR)

Example

The following procedure is an example of setting values in the VOR menu.

1. Preset the signal generator.

2. Ensure that all normal VOR signals are on (no suppressed signals):  
Press Aux Fctn > Avionics > VOR > More > Recall Default Settings > VOR Mode > Norm.

3. Set the VOR carrier frequency to 110.635 MHz:  
Press Freq > 110.635 > MHz.

4. Set the desired RF power level: 

a. Press Amptd.
b. Using the numeric keypad enter the amplitude value and press dBm.

5. Select a Bearing angle of 10 degrees in the To direction:

a. Press Aux Fctn > Avionics > VOR.
b. Press Bearing > Angle > 10 > deg.
c. Press Direction > To.

6. Set the modulation depth of the variable phase tone to 25%: 
Press Return > REF/VAR > VAR Depth > 25 > %.

7. Suppress the main carrier signal, sending only the unmodulated subcarrier to the receiver:  
Press Return > VOR Mode > Sub-Carrier.

8. Turn on the RF output:  
Press the front panel RF On/Off key until the LED lights.

9. Modulate the RF output:  
Verify on the front panel that the MOD On/Off LED is illuminated, indicating that it is on 
(default).

10. Verify that the measurements shown on the receiver match that of the signal generator.
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Instrument Landing System (ILS)

Instrument Landing System (ILS)
The signal generator provides control of all aspects of ILS testing (localizer, below; glide slope, on 
page 118; and marker beacons, on page 120).

ILS Localizer

The localizer radiates a directional field pattern directly down the center of the runway to indicate 
whether an aircraft is to the left of, to the right of, or in-line with the runway. The localizer’s carrier 
is modulated by two tones: 90 Hz and 150 Hz (default settings). Each of the resulting modulated 
carriers is sent to a separate directional antenna system; this array is arranged so that on the left 
side of the runway the 90 Hz signal is stronger, and on the right side of the runway the 150 Hz 
carrier is stronger. The difference in depth of modulation (DDM) provides the pilot with “on course” 
information.

Figure 5-3 Localizer Softkeys

Select standard VOR 
carrier frequency. 

Turns on both ILS Localizer signals.

Turns off the Right signal.

Turns off the Left signal.

Sets DDM polarity:
    Left = positive 
    Right = negative

Sum of depth of modulation.

Difference in depth of modulation.

Sets the phase of the right signal  
relative to the left signal

Sets the frequency of the 
Com/ID.

Allows the user to set the 
code to be played by the 
Com/ID generator.

Sets COM/ID tone AM depth.

Aux Fctn > Avionics > ILS Localizer >

Resets only 
ILS Localizer 
parameters.

Does not reset 
Com/ID 
parameters.
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Instrument Landing System (ILS)

Example

The following procedure is an example of setting values in the ILS Localizer menu.

1. Preset the signal generator.

2. Ensure that both ILS modulation signals are on (neither signal suppressed):  
Press Aux Fctn > Avionics > ILS Localizer > ILS LOC Mode > Norm.

3. Set the ILS Localizer carrier frequency to 108.10 MHz:  
Press Freq > 108.10 > MHz.

4. Set the desired RF power level: 

a. Press Amptd.
b. Using the numeric keypad enter the amplitude value and press dBm.

5. Set the left frequency to 89 Hz:  
Press Aux Fctn > Avionics > ILS Localizer > Left/Right > Left Frequency > 89 > Hz.

6. Set Difference in Depth of Modulation to 20%:  
Press Return > DDM/SDM > DDM > 20 > %.

7. Suppress the left signal:  
Press Return > ILS LOC Mode > Suppress Left.

8. Turn on the RF output:  
Press the front panel RF On/Off key until the LED lights.

9. Modulate the RF output:  
Verify on the front panel that the MOD On/Off LED is illuminated, indicating that it is on 
(default).

10. Verify that the measurements shown on the receiver match that of the signal generator.
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Instrument Landing System (ILS)

ILS Glide Slope

The glide slope provides signals that indicate whether an aircraft is above, below, or on the glide 
path to the runway. This is the same type of information as provided by the localizer, but for vertical 
reference rather than horizontal reference; the same modulation and antenna techniques are used.

Figure 5-4 Glide Slope Softkeys

Sets DDM polarity:
    Up = positive 
    Down = negative

Sets the phase of the Down signal 
relative to the Up signal.

Sum of Depth of Modulation.

Turns on both glide slope 
signals.

Turns off the Up signal.

Turns off the Down signal.

Difference in Depth of Modulation. 

Aux Fctn > Avionics > ILS Glide Slope >

Resets only 
ILS Glide Slope 
parameters.

Does not reset 
Com/ID 
parameters.

Select standard ILS glide slope 
carrier frequency. 

Sets the frequency of the 
Com/ID.

Allows the user to set the 
code to be played by the 
Com/ID generator.

Sets COM/ID tone AM depth.



Keysight EXG and MXG X-Series Signal Generators User’s Guide                                                                    119

Avionics, Option 302, requires Option UNT (Serial Prefixes Ř MY/SG/US5620xxxx)

Instrument Landing System (ILS)

Example

The following procedure is an example of setting values in the ILS Glide Slope menu.

1. Preset the signal generator.

2. Ensure that both ILS Glide Slope modulation signals are on (neither signal suppressed):  
Press Aux Fctn > Avionics > ILS Glide Slope > ILS GS Mode > Norm.

3. Set the ILS Glide Slope carrier frequency to 331.79 MHz:  
Press Freq > 331.79 > MHz.

4. Set the desired RF power level: 

a. Press Amptd.
b. Using the numeric keypad enter the amplitude value and press dBm.

5. Set the frequency of the down signal to 149 Hz:  
Press Aux Fctn > Avionics > ILS Glide Slope > Up/Down > Down Frequency > 149 Hz.

6. Set Difference in Depth of Modulation to 20%:  
Press Return > DDM/SDM > DDM > 20 > %.

7. Suppress the down signal:  
Press Return > ILS GS Mode > Suppress Down.

8. Turn on the RF output:  
Press the front panel RF On/Off key until the LED lights.

9. Modulate the RF output:  
Verify on the front panel that the MOD On/Off LED is illuminated, indicating that it is on 
(default).

10. Verify that the measurements shown on the receiver match that of the signal generator.
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Marker Beacons
Marker beacons indicates the distance of an aircraft from the runway threshold: 

— outer marker = five miles
— middle marker = 3500 feet
— inner marker = at the threshold

Figure 5-5 Marker Beacon Softkeys

Sets the amplitude modulation depth 
on the marker beacon carrier.

Simulates the inner marker 
(3000 Hz modulation).

Simulates the middle marker. 
(1300 Hz modulation).

Simulates the outer marker. 
(400 Hz modulation).

Aux Fctn > Avionics > Marker Beacon >

Enables you to adjust the selected 
marker frequency away from nominal.

Select standard marker beacon 
carrier frequency. 

Sets the frequency of the Com/ID.

Allows the user to set the 
code to be played by the 
Com/ID generator.

Sets COM/ID tone AM depth.

Resets only 
Marker Beacon 
parameters.

Does not reset 
Com/ID 
parameters.
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Marker Beacons

Example

The following procedure is an example of how to test the outer, middle, and inner marker beacon 
with an AM depth of 85%.

1. Preset signal generator. 

2. Turn on the inner marker:  
Press Aux Fctn > Avionics > Marker Beacon > Marker Beacon > Inner.

3. Set the Marker Beacon carrier frequency to 74.6 MHz:  
Press Freq > 74.6 > MHz.

4. Set the desired RF power level: 

a. Press Amptd.
b. Using the numeric keypad enter the amplitude value and press dBm.

5. Set marker AM depth to 85%:  
Press Aux Fctn > Avionics > Marker Beacon > Marker Depth > 85 > %.

6. Select the middle marker:  
Press Marker Beacon > Middle.

7. Select the outer marker:  
Press Marker Beacon > Outer.

8. Turn on the RF output:  
Press the front panel RF On/Off key until the LED lights.

9. Modulate the RF output:  
Verify on the front panel that the MOD On/Off LED is illuminated, indicating that it is on 
(default).

10. Verify that the measurements shown on the receiver match that of the signal generator.
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Parameter Defaults

Parameter Defaults
Default (preset) settings provide quick, standard setups.

Table 5-1 

Parameter State Parameter State

VOR Off Marker Beacon Off

Bearing Angle 0.00 degrees Marker 
Frequency

400.00 Hz

Direction From Marker Depth 95.0%

REF Frequency 30.00 Hz COM/ID State Off

VAR Frequency 30.00 Hz COM/ID 
Frequency

1.02000 kHz

REF Deviation 480.0 Hz COM/ID Depth 10.0%

VAR Depth 30.0%

Sub-carrier 
Frequency

9.96.000 kHz

Sub-carrier Depth 30.0%

ILS Localizer Off

Left Frequency 90.00 Hz

Right Frequency 150.00 Hz

Left/Right Phase 0.00 degrees

Fly Left

DDM 0.0%

SDM 40.0%

ILS Glide Slope Off

Up Frequency 90.00 Hz

Down Frequency 150.00 Hz

Up/Down Phase 0.00 degrees

Fly Up

DDM 0.0%

SDM 80.0%
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6 Using Analog Modulation (Option UNT)

Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting the power level and frequency, 
refer to Chapter 3, “Basic Operation”, on page  39 and familiarize yourself with the information in 
that chapter.

— Using an Internal Modulation Source on page 126

— Using an External Modulation Source on page 127

— Removing an External Source DC Offset on page 127

— Using Wideband AM on page 128

— Configuring the LF Output (Option 303) on page 129

The Mod On/Off hardkey and LED functionality are only valid for signal generators with Option 
UNT installed.
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Analog Modulation Waveforms

Analog Modulation Waveforms
The signal generator can modulate the RF carrier with four types of analog modulation: amplitude, 
frequency, phase, and pulse. For pulse modulation information, refer to Chapter 7, “Using Pulse 
Modulation (Option UNW or 320)”, on page  133.

Available internal waveforms include:

Sine  sine wave with adjustable amplitude and frequency

Triangle  triangle wave with adjustable amplitude and frequency

Square  square wave with adjustable amplitude and frequency

Pos Ramp  positive going ramp with adjustable amplitude and frequency

Neg Ramp  negative going ramp with adjustable amplitude and frequency

Analog Modulation Sources
The signal generator provides the following internal and external modulation input sources. Internal 
modulation sources generate the five waveforms listed above unless noted otherwise.

Ext1 & Ext2  an externally applied signal is used as the modulation input. Connect the signal to 
the EXT 1 or EXT 2 connector on the rear panel of the instrument.

Func Gen 1  sine wave from the internal function generator. Instruments with Option 303 have 
additional waveform choices listed above.

Func Gen 2  Func Gen 2 has the same capability as Func Gen 1. Available on instruments with 
Option 303.

Dual Func Gen  dual waveforms with individually adjustable frequencies and a percent-of- 
peak-amplitude setting for the second tone. Available on instruments with Option 
303. 

Swept Func Gen  swept waveforms with adjustable start and stop frequencies, sweep time, and 
sweep trigger settings. Available on instruments with Option 303.

Noise Gen 1 & 2  noise with adjustable amplitude generated as a peak-to-peak value (RMS value is 
approximately 80% of the displayed value). Uniform and Gaussian distribution is 
available. Available on instruments with Option 303.
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Analog Modulation Sources

Figure 6-1 Analog Modulation Softkeys

pageŚ126pageŚ126 pageŚ126

For details on each key, use key help 
as described on pageŚ40.
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Using an Internal Modulation Source

Using an Internal Modulation Source

1. Preset the signal generator.

2. Set the carrier (RF) frequency.

3. Set the RF amplitude.

4. Configure the modulation:

5. Turn on the modulation:

The appropriate modulation annunciator displays, indicating that you enabled modulation.

6. Turn on the RF output.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output” 
on page 381.

See also “Modulating the Carrier Signal” on page 54.

AM FM  ΦM

a. Press AM
b. Set the AM type (Linear or Exponential):  
   AM Type to highlight desired type.

c. Set the AM Mode (Normal or Deep). 
Default is Deep. To select Normal 
enable More to highlight 
desired type.   

d. Set the AM Depth:    AM Depth > 
value > unit
e. Set the rate:  
   More > Setup AM Source > 
AM Rate > value > frequency unit

a. Press FM/ƇM

b. Set the deviation:  
   FM Dev > value > 
frequency unit

c. Set the rate:  
   More > Setup FM 
Source > FM Rate > 
value > frequency unit

a. Press FM/ƇM > FM/ƇM 
(ƇM is highlighted)

b. Set the BW (normal or high): 
   FM ƇM to highlight desired 
type

c. Set the deviation:  
   ƇM Dev > value > pi rad

d. Set the rate:  
   More > Setup ƇM 
Source > ƇM Rate > 
value > frequency unit

AM FM  ΦM

AM Off On softkey to On FM Off On softkey to On  ƇM Off On softkey to On
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Using an External Modulation Source 

Removing an External Source DC Offset

To eliminate an offset in an externally applied FM or ΦM signal, perform an external DC calibration 
(Ext DC Cal).

1. Set up and turn on the desired modulation.

2. Press FM/ΦM > FM Source > Ext1 or Ext2 > More > Setup FM Source.

3. Ensure that Ext Coupling is set to DC. 
- If not, press Ext Coupling DC AC until DC is highlighted.

4. Press Ext DC Cal. 

This begins the calibration.

Performing the calibration with a DC signal applied removes any deviation caused by the DC signal, 
and the applied DC level becomes the new zero reference point. When you disconnect the DC 
signal, perform the calibration again to reset the carrier to the correct zero reference.

Rear panel inputs are described on pageŚ12

AM, FM or ΦM inputs
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Using Wideband AM

Wideband AM uses the I input of the I/Q modulation system. When the wideband AM is turned on, 
the I/Q is turned on and the I/Q source is set to external. If the I/Q is turned off or the I/Q source is 
set to internal, then the wideband AM turns off.

Figure 6-2 Wideband AM Softkey Menu

Setting the Wideband AM

1. Set up and enable the desired modulation type.

2. Press AM > AM Path 1 2 WB to WB.

For frequencies between 9 kHz and 5 MHz, Wideband AM turns off.

AM > AM Path 1 2 WB

Enables and disables the 
wideband AM feature.
Note: If the I/Q is turned off or 
the I/Q source is set to 
internal, then the wideband 
AM turns off.

For details on each key, use key help 
as described on pageŚ40.

When the Wideband AM is enabled, these fields are active.
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Configuring the LF Output (Option 303)
The signal generator has a low frequency (LF) output. The LF output’s source can be switched 
between an internal modulation source or an internal function generator.

Using internal modulation (Int Monitor) as the LF output source, the LF output provides a replica of 
the signal from the internal source that is being used to modulate the RF output. The specific 
modulation parameters for this signal are configured through the AM, FM, or ΦM menus. The 
internal source (AM, FM, or ΦM) must be configured for the LF Out to provide a signal.

Using function generator as the LF output source, the function generator section of the internal 
modulation source drives the LF output directly. Frequency and waveform are configured from the 
LF output menu, not through the AM, FM, or ΦM menus. You can select the waveform shape from 
the following choices:

Available internal waveforms include:

Sine  sine wave with adjustable amplitude and frequency

Triangle  triangle wave with adjustable amplitude and frequency

Square  square wave with adjustable amplitude and frequency

Pos Ramp  positive going ramp with adjustable amplitude and frequency

Neg Ramp  negative going ramp with adjustable amplitude and frequency

Pulse  pulse with adjustable period and width

LF Out Modulation Sources

The signal generator provides the following modulation input sources. Internal modulation sources 
generate the five waveforms listed above unless noted otherwise.

Int Monitor  uses AM, FM or ΦM settings.

Func Gen 1  waveforms from the internal function generator

Func Gen 2  waveforms from the internal function generator

Dual Func Gen  dual waveforms with individually adjustable frequencies and a percent-of- 
peak-amplitude setting for the second tone. Available on instruments with Option 
303. 

Swept Func Gen  swept waveforms with adjustable start and stop frequencies, sweep time, and 
sweep trigger settings. Available on instruments with Option 303.

Noise Gen 1 & 2  noise with adjustable amplitude generated as a peak-to-peak value (RMS value is 
approximately 80% of the displayed value). Uniform and Gaussian distribution is 
available. Available on instruments with Option 303.
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DC  selects a DC voltage level as the LF output BNC source.

Configuring the LF Output with an Internal Modulation Source

In this example, the internal FM modulation is the LF output source. See Figure 6-3 on page 131.

Configuring the Internal Modulation as the LF Output Source

1. Press Preset.

2. Press the FM/ΦM hardkey.

3. Press FM Dev > 75 > kHz.

4. Press More > Setup FM Source > FM Rate > 10 > kHz. 

5. Press Return > Return > FM Off On. 

You have set up the FM signal with a rate of 10 kHz and 75 kHz of deviation. The FM annunciator is 
activated indicating that you have enabled frequency modulation.

Configuring the Low Frequency Output

1. Press the LF Out hardkey.

2. Press LF Out Amplitude > 3 > V. 

3. Press LF Out Off On.

You have configured the LF output signal for a 3 volt sine wave (default wave form) output which is 
frequency modulated using the Int Monitor source selection (default source).

The LF Out Off On softkey controls the operating state of the LF output. However when the LF 
output source selection is Int Monitor, you have three ways of controlling the output. You can 
use the modulation source (AM, FM, or ΦM) on/off key, the LF output on/off key, or the Mod 
On/Off softkey.

The RF On/Off hardkey does not apply to the LF OUTPUT connector.

Internal modulation (Int Monitor) is the default LF output source.
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Figure 6-3 Configure the LF Out Source with FM

Configuring the LF Output with a Function Generator Source

In this example, the function generator is the LF output source.

Configuring the Function Generator as the LF Output Source

1. Press Preset.

2. Press the LF Out hardkey.

3. Press LF Out Source > Func Gen 1.

Configuring the Waveform

1. Press Setup LF Out Source > LF Out Waveform > Sine.

2. Press LF Out Freq > 500 > Hz.

3. Press Return.

This returns you to the top LF Output menu. 

Configuring the Low Frequency Output

1. Press LF Out Amplitude > 3 > V.

This sets the LF output amplitude to 3 V.

2. Press LF Out Off On.

Figure 6-4 on page 132 shows that the LF output is now transmitting a signal using the function 
generator that is providing a 3 V sine waveform. 

For details on each key, use key help LF Out using the Int Monitor source (default selection).

FM Modulation as the LF Out Source

FM and LF annunciators indicate Frequency Modulation is the LF Out source
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Figure 6-4 LF Out Status Display

For details on each key, use key help 
as described on pageŚ40.

LF Out configuration

LF Out annunciator
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7 Using Pulse Modulation (Option UNW or 320)

Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting the power level and frequency, 
refer to Chapter 3, “Basic Operation”, on page  39 and familiarize yourself with the information in 
that chapter.

— Pulse Characteristics on page 135

— The Basic Procedure on page 137

— Example on page 138

— Pulse Train (Option 320 – Requires: Option UNW) on page 139
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Figure 7-1 Pulse Softkeys

pageŚ137

pageŚ137

Latency from the external 
pulse input to the pulse 
sync output ≈ 50−60 ns.
Width      Period
50 ns       > 50 ns
20 ns       ≤ 50 ns

For details on each key, use key help 
as described on pageŚ40.

Determines how the signal generator 
responds to an external pulse signal.
Normal = high state.
Invert = low state.

Low = settled

TTL signal

See also, pageŚ13 and 
pageŚ15

Select the signal 
routed to each 
output connector.

Available on vector 
instruments with 
BBG.

These softkeys are 
only available when 
the Pulse–Source is 
set to Adjustable 
Doublet.

pageŚ139

Note: Pulse Period 
and Pulse Width are 
not available when 
Pulse Train is selected 
as the Pulse Source.
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Pulse Characteristics

Pulse Characteristics

When using very narrow pulses that are below the signal generator’s ALC 
pulse width specification, or leveled pulses with an unusually long duty 
cycle, it is often useful to turn ALC off (see page 102).

Pulse Sour
ce

Type Perioda

a. All delays, widths, and periods have a resolution of 10 ns.

Wid th & Delaya Uses Trigger Eventb

,

b. A signal at the rear panel pulse connector must be held high for at least 20 ns to trigger an 
internally generated pulse.

Square
Internal free run pulse train with 
50% duty cycle.

Determined by 
user defined 
rate.

⎯ ⎯

Free Run  
(default)

Internal free run pulse train User Defined User Defined ⎯

Triggered Internal pulse train ⎯ User Defined ?

Adjustable  
Doublet

Two internal pulse trains for each 
trigger event.

⎯

User Defined:

First pulse is relative to the 
rising edge of trigger signal.

Second pulse is relative to 
the rising edge of first pulse.

See Figure 7-2 on 
pageŚ136

?

Trigger  
Doublet

Two internal pulse trains for each 
trigger event.

⎯

The first pulse follows the 
trigger signal.

Second pulse is user defined.

See Figure 7-3 on 
pageŚ136

?

Gated Internal gated pulse train ⎯ User Defined ?

External
External pulse signal at the rear 
panel Pulse connector

⎯ ⎯ ⎯

Pulse Train Internal pulse train

User Defined

User Defined:

See Figure 7-4 on 
pageŚ139

?
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Figure 7-2 Adjustable Doublet

Figure 7-3 Trigger Doublet

 

Rear panel inputs are described on pageŚ12

External pulse input

The delay of the first pulse is measured from 
the leading edge of the external trigger signal.

Delay Width

RF Output

External 
Trigger

The delay of the second pulse is measured from 
the leading edge of the first pulse.

Delay Width
PulsPuls

PulsPuls

The delay of the second pulse is measured from 
the leading edge of the external trigger signal.

Delay Width

RF Output

External 
Trigger

The first pulse follows the 
external trigger signal.

Puls Puls
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The Basic Procedure

The Basic Procedure

1. Preset the signal generator.

2. Set the carrier (RF) frequency.

3. Set the RF amplitude.

4. Configure the modulation:

a. Set the pulse source: Press Pulse > Pulse Source > selection

b. Set the parameters for the selected pulse source:

5. Turn on the modulation: Pulse Off On softkey to On.

The the PULSE annunciator lights, indicating that you enabled modulation.

6. Output the modulated signal from the signal generator: Press the front panel RF On Off key.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

See also, “Modulating the Carrier Signal” on page 54.

Square Free Run 
(defaul t)

Triggered Adjustable Doublet Trigger Doublet Gated Pulse 
Traina

a.  Requires Option 320.

External

Pulse 
Rate

⎯ ⎯ ⎯ ⎯ ⎯ ⎯ ⎯

⎯ Pulse 
Period

⎯ ⎯ ⎯ Pulse 
Period

⎯ ⎯

⎯ Pulse 
Delay

Pulse 
Delay

Pulse Delay Pulse Delay ⎯ Pulse 
Delay

⎯

⎯ Pulse 
Width

Pulse 
Width

Pulse Width Pulse Width Pulse 
Width

⎯ ⎯

⎯ ⎯ ⎯ Pulse 2 Delay ⎯ ⎯ ⎯ ⎯

⎯ ⎯ ⎯ Pulse 2 Width ⎯ ⎯ ⎯ ⎯

⎯ ⎯ ⎯ ⎯ ⎯ ⎯ Pulse Onb

b.  Up to 2047 pulse cycles (elements) composed of both Pulse On and Pulse Off can be user 
defined.

⎯

⎯ ⎯ ⎯ ⎯ ⎯ ⎯ Pulse Offb ⎯
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Example
The following example uses the factory preset pulse source and delay.

1. Preset the signal generator.

2. Set the frequency to 2 GHz.

3. Set the amplitude to 0 dBm.

4. Set the pulse period to 100 microseconds: Press Pulse > Pulse Period > 100 > usec.

5. Set the pulse width to 24 microseconds: Press Pulse > Pulse Wid th > 24 > usec

6. Turn on both the pulse modulation and the RF output. 

The PULSE annunciator displays and the RF output LED lights.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output” 
on page 381. 

Output: A 2 GHz, 0 dBm carrier modulated by a 24 μs pulse that has a period of 100 μs.
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Pulse Train (Option 320 – Requires: Option UNW)

Pulse Train (Option 320 – Requires: Option UNW) 
The Option 320 Pulse Train feature enables the specification of up to 2047 independent pulse 
cycles, each of which has an “On Time”, during which the RF output is measurable at the RF output 
connector, and an "Off Time", during which the RF output is attenuated. Each pulse cycle is similar 
in function to other X-Series signal generator Pulse modes—the Pulse Train feature has up to 2047 
cycles, instead of only a maximum of two (with Doublets). There are also repeat counts available for 
each pulse. These repetitions count against the total count of 2047 cycles.

The instrument can import pulse trains from a .csv (comma separated values) file or some other 
common ASCII format. It can also export to ASCII/CSV files as well. Export allows specification of 
the decimal separator and a column separator. The import allows specification of the decimal 
separator (to allow for ","), but the column separator is auto-detected. Refer to “Pulse Train Menu 
Softkeys” on page 139 and “Display Pulse Train Menu Softkeys” on page 141.

Figure 7-4 Pulse Train Menu Softkeys
Pulse > Pulse Source > More > Pulse Train 

Free-Run continuously plays 
the pulse train, ignoring all 
triggers.
Triggered runs the pulse 
train (after waiting the Pulse 
Delay) each time an external 
trigger is supplied to the 
PULSE BNC, the Trigger 
Immediately softkey is 
pressed, or the Trigger SCPI 
command is sent.
Gated runs the pulse train 
while an external trigger is 
supplied (level triggered) to 
the PULSE BNC connector. 
The state of the GATEd 
trigger is detected only when 
the playback is transitioning 
to or in idle. This means that, 
once started, playback is 
always completed, even if 
the GATE trigger changes to 
the inactive state.

For details on each key, use key help as 
described on pageŚ40.

Display area indicates Pulse Train is the current pulse 
source.

Trigger Immediately causes 
the pulse train to run once.

SCPI Commands:

[:SOURce]:PULM:INTernal:TRAin:TRIGger FRUN|{TRIGgered}|GATEd
[:SOURce]:PULM:INTernal:TRAin:TRIGger:IMMediate  

Refer to the SCPI Command Reference.
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Figure 7-5 Edit Pulse Train Menu Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train

pageŚ141

This column indicates the 
row of a each pulse train 
cycle.
Note: When the cycles 
(elements) are repeated, 
the row numbers are 
skipped in the displayed 
count for the number of 
pulse cycles repeated.
Example: For the pulse 
train displayed above, in 
row 2, the 3 us On Time 
and 2 us Off Time pulse 
cycle is repeated twice. 
But, only row 2 is 
displayed for that pulse 
cycle (i.e. row 3 is not 
displayed). 

This column 
displays the on 
times for each 
pulse cycle 
(element) in the 
pulse train.

This column 
displays the off 
times for each 
pulse cycle 
(element) in the 
pulse train.

This column 
displays the repeat 
times for each 
pulse cycle 
(element) in the 
pulse train.

These softkeys provide 
ease of use in changing 
the pulse cycle settings 
in the pulse train.

SCPI Commands:
[:SOURce]:PULM:INTernal:TRAin:LIST:PRESet
[:SOURce]:PULM:INTernal:TRAin:OFFTime <20ns - 42sec>
[:SOURce]:PULM:INTernal:TRAin:OFFTime?
[:SOURce]:PULM:INTernal:TRAin:OFFTime:POINts?
[:SOURce]:PULM:INTernal:TRAin:ONTime <20ns - 42sec>
[:SOURce]:PULM:INTernal:TRAin:ONTime?
[:SOURce]:PULM:INTernal:TRAin:ONTime:POINts?
[:SOURce]:PULM:INTernal:TRAin:REPetition <1-2047>
[:SOURce]:PULM:INTernal:TRAin:REPetition?
[:SOURce]:PULM:INTernal:TRAin:REPetition:POINts? 

Refer to the SCPI Command Reference.

SCPI Commands (continued):
:MEMory:CATalog:PTRain? 
:MEMory:DELete:PTRain
:MEMory:EXPort[:ASCii]:PTRain <"filename">
:MEMory:EXPort[:ASCii]:SEParator:COLumn 
TAB|SEMicolon|{COMMa}|SPACe
:MEMory:EXPort[:ASCii]:SEParator:COLumn?
:MEMory:EXPort[:ASCii]:SEParator:DECimal {DOT}|COMMa
:MEMory:EXPort[:ASCii]:SEParator:DECimal?
:MEMory:IMPort[:ASCii]:PTRain <"filename">
:MEMory:IMPort[:ASCii]:SEParator:DECimal {DOT}|COMMa
:MEMory:IMPort[:ASCii]:SEParator:DECimal?
:MMEMory:LOAD:PTRain <"filename">
:MMEMory:STORe:PTRain <"filename">

For details on each key, use key help as described on pageŚ40.

pageŚ142
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Pulse Train (Option 320 – Requires: Option UNW)

Figure 7-6 Display Pulse Train Menu Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > Display Pulse Train

Use these softkeys to optimize 
the view of the different 
characteristics of the pulse 
train.

This softkey shifts the time 
offset from the left hand side 
of the display to the one 
specified. Increments and 
decrements are 1/20th of 
the visible pulse train.

This value can be 
adjusted with the 
Time Offset softkey.

These are the division markers currently 
set at 10.00 us/div for the currently 
displayed view. Use the zoom softkeys 
to change the time/div value.

This is the initial 
pulse cycle (row 1) 
note that the On 
Time portion of this 
pulse is not showing 
due to the  
2 us offset.

5th, 6th, and 7th 
pulse cycles 
(elements) or rows 

Final pulse cycle 
(element) in the 
displayed pulse 
train above. 8th 
pulse cycle or row. 

2nd and 3rd 
pulse cycles 
(elements) or 
rows 2 and 3.

4th pulse cycle 
(element) or row 4.

For details on each key, use key help as described on pageŚ40.
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Figure 7-7 Pulse Train: Import From Selected File Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > More

pageŚ60

These softkeys delete 
individual On Time or Off 
Time elements as well as the 
Repeat cycle counts.

This file’s data structure uses decimals in the numbers 
and so requires the Import Decimal Separator to be set to 
Dot.

Selects whether the decimal point 
is a "." or a "," during import of 
CSV/ASCII files.
This value is persistent across 
preset/recall and power cycles.

SCPI Commands:
:MEMory:IMPort[:ASCii]:SEParato
r:DECimal DOT|COMMa
:MEMory:IMPort[:ASCii]:SEParato
r:DECimal?

After confirming import of the file 
the new file’s pulse train values 
are displayed.

Deleting all Pulse Cycle rows 
(elements) must be 
confirmed.

For details on each key, use key help as described on pageŚ40.

Note: Column 
separated values are 
auto-detected by the 
instrument.

pageŚ143

pageŚ143
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Pulse Train (Option 320 – Requires: Option UNW)

Figure 7-8 Pulse Train: Export to File Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > More

pageŚ142

Use the text editor keys to 
rename the file to be exported 
to the BIN (Binary) folder. 

The Export to File softkey menu, 
writes out a CSV/ASCII file to the 
BINARY directory. You may supply 
your own extender as part of the 
filename.
Example: 
MEM:EXP:PTR "myfile.csv".
SCPI Command:
:MEMory:EXPort[:ASCii]:PTRAin 
<"filename">

Note: Files can be FTP’d to the BIN (Binary) folder in the instrument, or a USB 
stick can be used to download the files to the instrument. Refer to pageŚ61.

For details on each key, use key help as described on pageŚ40.

Note: Since there is already a file named PTRAIN.CSV the new 
filename should be different, to avoid overwriting the original 
PTRAIN.CSV file.

Selects whether the column 
separator is a tab, “;”, “,” or “a “ ” 
during export of the CSV/ASCII 
files. This value is persistent 
across preset/recall and power 
cycles.
SCPI Commands: 
:MEMory:EXPort[:ASCii]:SEParato
r:COLumn 
TAB|SEMicolon|COMMa|SPACe
:MEMory:EXPort[:ASCii]:SEParato
r:COLumn?

Selects whether the 
decimal point is a “.” 
or “, “ ” during export 
of the CSV/ASCII 
files. This value is 
persistent across 
preset/recall and 
power cycles.
SCPI Commands: 
:MEMory:EXPort[:AS
Cii]:SEParator:DECi
mal DOT|COMMa
:MEMory:EXPort[:AS
Cii]:SEParator:DECi
mal?
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8 Basic Digital Operation—No BBG Option Installed

Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting power level and frequency, refer 
to Chapter 3, “Basic Operation”, on page  39 and familiarize yourself with the information in that 
chapter.

See also “Adding Real–Time Noise to a Dual ARB Waveform” on page 250.
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I/Q Modulation
The following factors contribute to the error vector magnitude:

— Differences in amplitude, phase, and delay between the I and Q channels

— DC offsets

The I/Q menu provides adjustments and calibration to compensate for some of the differences in 
the I and Q signals or to add impairments. See I/Q Modulation on page 209 for additional 
information.

See also “Modulating the Carrier Signal” on page 54.

Figure 8-1 I/Q Display and Softkeys

The following table shows common uses for the adjustments.

Table 8-1 I/Q Adjustments Uses

I/Q Ad justment Effect Impairment

Offset Carrier Feedthrough dc offset

This panel displays the external 
I/Q signal routing.

This panel displays the current status and settings 
of the I/Q adjustments. Grey text indicates I/Q 
adjustments are off.

For details on each key, use key help 
as described on pageŚ40.

Offsets the phase of the Q signal relative to the 
phase of the I signal. The quadrature adjustment 
key is in units of degrees. This adjustment is not 
calibrated. 

Sets the dc 
offset

Toggles between DC, User, and Full IQ calibration types. 

DC: Calibrates I/Q offset, gain and quadrature error for a single 
frequency at the current signal generator settings. 

This calibration requires that the I/Q be on, the optimized path be set to 
RF Out, and the source be set to the internal baseband generator. 
Changing any instrument setting except for I/Q adjustments after 
performing a DC calibration voids the DC calibration and causes the 
signal generator to revert to the factory supplied calibration data. 

User: Calibrates I/Q offset, gain, and quadrature error for all signal 
generator settings over a range of frequencies that you define. 

Full: Calibrates I/Q offset, gain, and quadrature error for all settings 
over the full frequency range of the signal generator.

Starts the I/Q calibration routine for the 
selected frequency range. (Use the 
Calibration Type softkey to select the 
frequency range.) You can abort the 
calibration by pressing the Abort Cal 
softkey or the Local Cancel/(Esc) 
hardkey. If you abort the calibration, the 
previous calibration data is restored.

This calibration should be run when the 
ambient temperature has varied by at 
least +/-5 degrees Celsius from the 
ambient temperature at which the 
previous calibration was run.
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I/Q Modulation

Configuring the Front Panel Inputs

The MXG/EXG accepts externally supplied analog I and Q signals through the front panel I Input 
and Q Input for modulating onto the carrier.

1. Connect I and Q signals to the front panel connectors. For voltage levels, refer to “Front Panel 
Overview” on page 5. 

a. Connect an analog I signal to the signal generator’s front panel I Input.

b. Connect an analog Q signal to the signal generator’s front panel Q Input.

2. Turn on the I/Q modulator: Press I/Q Off On to On.

3. Configure the RF output:

a. Set the carrier frequency.

b. Set the carrier amplitude.

c. Turn the RF output on.

4. Make adjustments to the I/Q signals (page 146) as needed.

Quadrature Angle
EVM error phase skew

I/Q Images I/Q path delay

Table 8-1 I/Q Adjustments Uses

I/Q Ad justment Effect Impairment



 148                                                                     Keysight EXG and MXG X-Series Signal Generators User’s Guide

Basic Digital Operation—No BBG Option Installed
I/Q Modulation



 149

Keysight X-Series Signal Generators

N5171B/72B/73B EXG and N5181B/82B/83B MXG

User’s Guide

9 Basic Digital Operation (Option 653/655/656/657)

Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting power level and frequency, refer 
to Chapter 3, “Basic Operation”, on page  39 and familiarize yourself with the information in that 
chapter.

The features described in this chapter are available only in vector signal generators with Option 653 
or 655 (N5172B) or Option 656 or 657 (N5182B).

— Waveform File Basics on page 151

— Storing, Loading, and Playing a Waveform Segment on page 153

— Waveform Sequences on page 156

— Saving a Waveform’s Settings & Parameters on page 161

— Using Waveform Markers on page 167

— Triggering a Waveform on page 183

— Clipping a Waveform on page 190

— Scaling a Waveform on page 199

— Setting the Baseband Frequency Offset on page 205

— I/Q Modulation on page 209

— I/Q Adjustments on page 213

— I/Q Calibration on page 214

— Using the Equalization Filter on page 216

— Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter on 
page 218

— Modifying a FIR Filter Using the FIR Table Editor on page 224

— Setting the Real-Time Modulation Filter on page 227

— Multiple Baseband Generator Synchronization on page 229

— Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple Baseband Generator 
Synchronization on page 235
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— Waveform Licensing on page 240

See Also: 

— Adding Real–Time Noise to a Dual ARB Waveform on page 250

— Real–Time Phase Noise Impairment on page 310

— Multitone and Two-Tone Waveforms (Option 430) on page 367
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Waveform File Basics
There are two types of waveform files: 

— A segment is a waveform file that you download to the signal generator.

For information on creating and downloading waveform files, refer to the Programming Guide. 

— A sequence is a file you create in the signal generator that contains pointers to one or more 
waveform files (segments, other sequences, or both). 

For information on creating sequences, see page 156.

Signal Generator Memory

The signal generator has two types of memory:

— Volatile memory, baseband generator (BBG) media, where waveform files are played from or 
edited.

— Non–volatile memory, either internal (int) or external (USB) media, where waveform files are 
stored.

Dual ARB Player

The dual ARB waveform player enables you to play, rename, delete, store, and load (external or 
internal) waveform files in addition to building waveform sequences. The dual ARB waveform player 
also provides markers (page 167), triggering (page 183), clipping (page 190), and scaling 
(page 199) capabilities.

Most procedures in this section start from the Dual ARB menu, shown below. 

The MXG/EXG’s ARB Waveform File Cache is limited (see the Data Sheet). 
Consequently, once the file cache limit has been reached, the waveform 
switching speed is much slower for additional files loaded into the volatile 
waveform memory (BBG).
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Figure 9-1 Dual ARB Softkeys

pageŚ250

pageŚ190

pageŚ199

pageŚ190

pageŚ153

If you set the ARB sample clock when the dual ARB 
is off, the new setting is applied when the dual ARB 
player is turned on; this setting survives toggling 
the Dual ARB player off and on.

pageŚ47

pageŚ161

pageŚ183

For details on each key, use key help 
as described on pageŚ40.

Note: This is second of 
           two Arb menus.

pageŚ156

pageŚ205

pageŚ199

pageŚ199

pageŚ208

pageŚ229

These softkeys are 
only available in the Dual 
ARB’s Arb Setup 
menu.

pageŚ167

Available on  
vector models with 
opt 2xx.

pageŚ240

pageŚ229
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Storing, Loading, and Playing a Waveform Segment

Before using this information, you should be familiar with the signal generator’s file menus. If you 
are not, refer to “Working with Files” on page 56 and familiarize yourself with that information.

See also: “Waveform Sequences” on page 156.

The signal generator has two types of waveform media: non–volatile (internal or USB), and volatile 
(BBG). BBG media is also called “working” media, because before you can play, edit, or include a 
waveform file in a sequence, the waveform file must be loaded into BBG media.

Figure 9-2 Waveform Segment Softkeys

Loading a Waveform Segment into BBG Media

Waveforms must reside in BBG media before they can be played, edited, or included in a sequence. 
Cycling power or rebooting the signal generator deletes the files in BBG media.

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

2. Press Load Store to highlight Load, then use the arrow keys to highlight the desired waveform 
segment.

he MXG/EXG’s ARB Waveform File Cache is limited to 128 files. 
Consequently, once the 128 file cache limit has been reached, the 
waveform switching speed will be much slower for additional files loaded 
into the volatile waveform memory (BBG).

Each time the instrument powers up, two factory–supplied segments are 
automatically created in BBG media: RAMP_TEST_WFM and 
SINE_TEST_WFM.

pageŚ167

For details on each key, use key help 
as described on pageŚ40.

Note: When a sequence is selected, this key name 
changes to Show Waveform Sequence Contents.

Use the arrow keys or knob to 
highlight a letter or character.

These keys change to indicate the default media.  
For information on selecting the default media,  
see pageŚ67.
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3. If there is already a copy of this segment in the currently selected media and you do not want 
to overwrite it, rename the waveform segment before you load it (refer to the previous 
procedure).

4. Press Load Segment From currently selected Media.

To load all files from the currently selected media into BBG media, press 
Load All From currently selected Media. 

Storing/Renaming a Waveform Segment to Internal or USB Media

Use the following steps to store a copy of a file in BBG memory to the currently selected media 
(page 67). If you have not downloaded a waveform segment, either refer to the Programming 
Guide, or use one of the factory–supplied segments. 

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

2. Press Load Store to highlight Store.

3. Using the arrow keys, highlight the waveform segment you want to store.

4. Optionally, rename the segment.

If there is already a copy of this segment in the currently selected media and you do not want 
to overwrite it, rename the waveform segment before you store it:

a. Press More > Rename Segment > Clear Text.
b. Enter a name for the waveform segment.
c. Press Enter > More.
d. Highlight the waveform segment that was renamed.

5. Press Store Segment to currently selected Media.

6. Repeat StepŚ3 through StepŚ5 for all segments that you want to store.

To save all segments from BBG media to the currently selected media, press 
Store All to currently selected Media.

Playing a Waveform Segment

1. Press Mode > Dual ARB > Select Waveform.

2. In the Segment on BBG Media column, highlight the waveform segment you want to play.

3. Press Select Waveform.

4. Set ARB Off On to On.

This plays the selected waveform segment. Both the I/Q and ARB annunciators turn on, and 
the waveform modulates the RF carrier. 
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5. Configure the RF Output: 

Set the RF carrier frequency and amplitude, and turn on the RF output.

The waveform segment is now available at the signal generator’s RF Output connector. 

Current waveform selection

Annunciators display with active waveform (ARB On)
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Waveform Sequences

Figure 9-3 Waveform Sequence Softkeys

A waveform sequence is a file that contains pointers to one or more waveform segments or other 
waveform sequences, or both. This lets the signal generator play multiple waveform segments, or 
other sequences, or both thereby eliminating the need to stop waveform playback just to select 
another waveform.

The segments that a waveform sequence points to are not automatically stored when you store the 
sequence; you must also store the individual segments or they are lost when you turn off or reboot 
the signal generator. If the segments are located in internal/external media, you must load them 
into BBG media prior to selecting a waveform sequence (see page 153). If you attempt to play a 
sequence without the segments loaded into BBG media, the signal generator reports: ERROR: 
629, File format invalid. If this happens and the segments are not stored in internal/external 
media, you must recreate the segments using the same file names that the sequence points to 
before you can play the sequence. 

Creating a Sequence

A waveform sequence can contain up to 1,024 segments and have both segments and other 
sequences (nested sequences). The signal generator lets you set the number of times the segments 
and nested sequences repeat during play back. But there is a difference between repeating a 

For details on each key, use key help 
as described on pageŚ40.

Mode > 
Dual ARB

Sequence name

Sequence contents

see pageŚ179

To display this softkey, select a waveform sequence.
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segment versus repeating a nested sequence. Each segment can repeat up to 65,535 times, but no 
matter how many times a segment repeats, it counts as a single segment. However each repetition 
of a nested sequence counts as additional segments.

The maximum number of times that a nested sequence can repeat is based on the number of 
segments in the nested sequence and the remaining number of allowed segments (1,024). For 
example, with a sequence that contains 24 segments and one nested sequence with 4 segments, 
the nested sequence is limited to 250 repetitions:

24 + (4 ´ 250) = 1,024 maximum number of segments per sequence

Even though there is a limiting factor on the maximum number of times that a nested sequence can 
repeat, each segment within the nested sequence can repeat up to 65,535 times.

Example

Use the following procedure to create and store a waveform sequence using one repetition each of 
two different segments.

Assumption: The waveform segments are in BBG media (volatile memory). For information on 
loading waveform segments into BBG media, see page 153. 

1. Select the first segment:

a. Press Mode > Dual ARB > More > Waveform Sequences > Build New Waveform Sequence 
> Insert Waveform.

b. Highlight the desired waveform segment and press Insert.

2. Select the second segment:

a. Highlight the next desired waveform segment and press Insert.

b. Press Done Inserting

Waveform 
Sequence

Sequence A

Sequence B

Sequence A 
repeated 4x

Segment 1

Segment 2

Segment 3

2 segments

9 segments

11 segments

8 Segments
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3. Name and store the waveform sequence to the Seq file catalog:

a. Press More > Name and Store.

b. Enter a file name and press Enter.

See also, “Viewing the Contents of a Sequence” on page 158 and “Setting Marker Points in a 
Waveform Segment” on page 174.

Viewing the Contents of a Sequence

There are two ways to view the contents of a waveform sequence:

Through the Waveform Sequences Softkey

1. Press Mode > Dual ARB > More > Waveform Sequences.

2. Highlight the desired sequence.

3. Press Show Waveform Sequence Contents.

Using the Select Waveform Softkey

1. Press Mode > Dual ARB > Select Waveform.

2. In the Sequence On column, highlight the desired waveform sequence.

3. Press Show Waveform Sequence Contents.

Editing a Sequence

When editing a waveform sequence, you can:

— change the number of times each segment or nested sequence plays

— delete segments or nested sequences from the sequence

— add segments or nested sequences to the sequence

— toggle markers on and off (described on page 179)

— save changes either to the current waveform sequence or as a new sequence

If you exit the sequence editing menu before saving changes, the changes are lost.

Sequences save to the Seq file catalog.

Use the following steps to edit a sequence that has two different segments so that the first 
segment repeats 100 times and the second segment repeats 200 times, then save the changes.

If you edit and resave a segment used in a sequence, the sequence does 
not automatically update the RMS value in its header. You must select and 
update the sequence header information (page 161).
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Assumption: A waveform sequence that has two different segments has been created and stored 
(see previous example on page 157).

1. Select the sequence:  
Press Mode > Dual ARB > More > Waveform Sequences > highlight the desired sequence > 
Edit Selected Waveform Sequence.

2. Change the first segment so that it repeats 100 times:  
Highlight the first segment entry and press Edit Repetitions > 100 > Enter.

The cursor moves to the next entry. 

3. Change the repetition for the selected entry to 200:  
Press Edit Repetitions > 200 > Enter.

4. Save the changes made in the previous steps:  
Press More > Name and Store > Enter.

To save the changes as a new sequence: 

a. Press More > Name and Store > Clear Text.
b. Enter a file name (for example, SINE100+RAMP200).
c. Press Enter.

The edited sequence saves as a new waveform sequence. 

Playing a Sequence

If you have not created a waveform sequence, refer to “Creating a Sequence” on page 156.

1. Select a waveform sequence:

a. Press Mode > Dual ARB > Select Waveform.

b. Highlight a waveform sequence (for this example, SINE100+RAMP200) from the Sequence 
On column.

c. Press Select Waveform.

The display shows the currently selected waveform (for example, Selected Waveform: 
SEQ:SINE100+RAMP200).

To play a waveform segment individually or as part of a waveform 
sequence, the segment must reside in BBG media. See also, “Loading a 
Waveform Segment into BBG Media” on pageŚ153.
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2. Generate the waveform:  
Press ARB Off On to On. 

This plays the selected waveform sequence. During the waveform sequence generation, both 
the I/Q and ARB annunciators turn on, and the waveform modulates the RF carrier. 

3. Configure the RF output: 

a. Set the RF carrier frequency.
b. Set the RF output amplitude.
c. Turn on the RF output.

The waveform sequence is now available at the signal generator’s RF OUTPUT connector. 

Current waveform selection

Annunciators display with active waveform (ARB On)
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Saving a Waveform’s Settings & Parameters
This section describes how to edit and save a file header. When you download only a waveform file 
(I/Q data, which the signal generator treats as a waveform segment), the signal generator 
automatically generates a file header and a marker file with the same name as the waveform file. 
Initially the file header has no signal generator settings saved to it, and the marker file consists of 
all zeros. For a given waveform, you can save signal generator settings and parameters in its file 
header and marker settings in its marker file (page 167); when you load a stored waveform file into 
BBG media, the file header and marker file settings automatically apply to the signal generator so 
that the dual ARB player sets up the same way each time the waveform file plays. 

Figure 9-4 Header Utilities Softkeys

When you create a waveform sequence (as described on page 156), the signal generator 
automatically creates a waveform sequence header that takes priority over the individual waveform 
segment headers. During a waveform sequence playback, the segment headers are ignored, except 
to verify that all required options are installed. Storing a waveform sequence also stores its file 
header. 

Some of the current signal generator settings shown in the file header appear as part of the softkey 
labels, and others appear in the dual ARB summary display, shown in the following example.

pageŚ164

Mode > Dual ARB >  
More > 
Header Utilities

For details on each key, 
use key help 
as described on 
pageŚ40.



 162                                                                     Keysight EXG and MXG X-Series Signal Generators User’s Guide

Basic Digital Operation (Option 653/655/656/657)
Saving a Waveform’s Settings & Parameters

Table 9-1 File Header Entries

32–Character 
Description

A description entered for the header, such as a the waveform’s function (saved/edited with the 
Edit Description softkey, see Figure 9-4 on pageŚ161).

Sample Rate The waveform playback rate. This is the ARB sample clock rate, set in the Arb Setup menu (shown 
in “Dual ARB Softkeys” on pageŚ152).

Runtime Scaling The Runtime scaling value is applied in real–time while the waveform is playing. This setting can be 
changed only for files playing in the dual ARB player (see pageŚ202).

RMS When the modulator attenuation setting (see pageŚ152) is set to Auto, this value is used to calculate 
the I/Q modulator attenuation setting to optimize ACPR. Value: 0 to 1.414213562.

Marker 1...4 Polarity Marker polarity can be positive or negative (described on pageŚ179). 

ALC Hold Routing Which marker, if any, implements the ALC hold function (described on pageŚ169), which holds the 
ALC at its current level when the marker signal is low. All waveforms generated in the signal 
generator have a marker on the first sample point. To see the results from the three routing 
selections, you may need to select a range of sample (marker) points (see “Setting Marker 
Points in a Waveform Segment” on pageŚ174). 

RF Blank Routing Which marker, if any, implements the RF blanking function (described on pageŚ178) when the 
marker signal is low. RF blanking also uses ALC hold. There is no need to select the ALC Hold 
Routing for the same marker when you are using the RF Blank Routing function. When the marker 
signal goes high, RF blanking discontinues. 

Mod Attenuation The I/Q modulator attenuation setting (set in the Arb Setup menu shown in Figure 9-1 on 
pageŚ152).

BB Freq Offset The baseband frequency offset, in Hz (see pageŚ205).

ARB summary, file
header settings

Softkey labels,
file header
settings

Softkey label,
file header
setting

All settings in this menu can be stored 
to thefile header 
(Table 9-1 on pageŚ162 lists all 
settings stored in a file header)

The Runtime 
Scaling softkey is 
only available under 
the Dual ARB menu.

see pageŚ205
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Viewing and Modifying Header Information 

The following example uses the factory–supplied waveform file RAMP_TEST_WFM.

1. From BBG media, select the waveform RAMP_TEST_WFM: 

a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On column, highlight the waveform RAMP_TEST_WFM.

c. Press Select Waveform.

2. Open the Header Utilities menu:

Press More > Header Utilities

The Figure 9-5 shows the default file header for the factory–supplied waveform 
RAMP_TEST_WFM. The Header Field column lists the file header parameters; use the Page 
Down key to see them all.

The Saved Header Settings column shows that most of the settings are Unspecified. 
Unspecified means that there is no setting saved for that particular parameter.

The Current Inst. Settings column shows the current signal generator settings. In this 
example, these are the settings that you will save to the file header. 

AWGN: State Indicated whether real–time noise is on (1) or off (0) (see pageŚ249).

AWGN: C/N Ratio Carrier to noise ration, in dB (see pageŚ254).

AWGN: Carrier BW Bandwidth over which the noise power is integrated, in Hz (see pageŚ254).

AWGN: Noise BW Bandwidth of the noise, in Hz (see pageŚ254).

AWGN: Carrier RMS The carrier RMS across the carrier bandwidth (see pageŚ254).

Phase Noise State Indicated whether phase noise is on (1) or off (0) (see pageŚ310).

Phase Noise F1 The start frequency for the level mid–frequency characteristics (see pageŚ310).

Phase Noise F2 The end frequency for the level mid–frequency characteristics (see pageŚ310).

Phase Noise Lmid The amplitude for the level mid–frequency characteristics (see pageŚ310).

Modulation Filter The real-time modulation filter type selected (see pageŚ227).

Over–Range Protect Indicated whether DAC Over–Range Protection is on (1) or off (0) (see pageŚ314).

Unique Waveform Id 0 = no Id; once an Id is assigned, it cannot be changed.

License Required Indicates whether a license is required to play the waveform. See also: “Viewing Options and 
Licenses” on pageŚ36

Can be Read Out Indicates whether the waveform can be queried through SCPI or FTP.

Table 9-1 File Header Entries
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Figure 9-5 Example File Header

3. Save the information in the Current Inst. Settings column to the file header:

Press Save Setup To Header.

Both the Saved Header Settings column and the Current Inst. Settings column now 
display the same values; the Saved Header Settings column lists the settings saved in the 
file header.

4. Edit and Update Settings

a. Return to the ARB Setup menu:  
Press Return > More > ARB Setup.

From this menu you can access some of the signal generator settings that are saved to the 
file header. Figure 9-1 on page 152 shows the ARB Setup softkeys used in the following 
steps.

b. Set the ARB sample clock to 5 MHz:  
Press ARB Sample Clock > 5 > MHz.

c. Set waveform runtime scaling to 60%: 
Press Waveform Runtime Scaling > 60 > %.

d. Return to the Header Utilities menu:  
Press Return > More > Header Utilities.

If a setting is unspecified in the file header, the signal generator uses its 
current value for that setting when you select and play the waveform.

The name of the waveform file.

The description can be up to 
32–characters.

Mode > Dual ARB > More > Header Utilities

Default header settings Current signal generator settings

Resets the saved 
header settings 
entries to default 
settings

To calculate the RMS waveform voltage: 
Press Calculate
Then refer to Header Field information.
Note: For greater accuracy, if the waveform has long rise/fall times, a DC 
offset, or noise* already added to the waveform (for a bursted signal), it 
is recommended that the Edit RMS and Edit AWGN RMS Override 
softkeys are used for the best measurement accuracy. 
*Option 403 Real–time AWGN does not affect the Header Field RMS 
value. But, noise added to the waveform prior to downloading and 
playing in the signal generator does affect the Header Field RMS value.

Opens a menu for manually 
defining the carrier RMS value 
to use for calculating the 
AWGN: Carrier RMS value in 
the Header Field. 
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As shown in the following figure, the Current Inst. Settings column now reflects the 
changes to the current signal generator setup, but the saved header values have not 
changed.

e. Save the current settings to the file header:  
Press the Save Setup To Header softkey.

The settings from the Current Inst. Settings column now appear in the Saved 
Header Settings column. This saves the new current instrument settings to the file 
header.

If you change any of the signal generator settings listed in the file header after you select the 
waveform file, the changed setting(s) appear in the file header’s Current Inst. Settings 
column and are used instead of the saved header settings. To reapply the saved header settings, 
reselect the waveform for playback.

Viewing & Editing a Header without Selecting the Waveform

As described on page 163, you can view and edit a waveform’s header information after you select 
the waveform; you can also edit waveform header information without selecting a waveform, or for 
another waveform than the one that is currently selected.

1. Access the file header utilities menu: 
Press Mode > Dual ARB > More > Header Utilities > More > Select Different Header.

The signal generator displays an alphabetical list of the waveform files in the media that was 
last selected. The following figure shows an example of the factory–supplied waveforms in 
BBG media.

Values differ between  
the two columns
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2. If the desired catalog is not displayed, select it. 

3. Highlight the desired waveform file and press Select Header.

The signal generator displays the file header for the selected waveform file. 

4. To edit the header, press More, and proceed as described in StepŚ4Śon pageŚ164 (Viewing and 
Modifying Header Information section).

Active waveform catalog

Active media

Type:
WFM1 = Volatile Segment
NVWFM = Non–Volatile Segment
SEQ = Sequence

Active catalog

For details on each key, use key help 
as described on pageŚ40.

Catalogs that enable you to 
view files in the active media.
For details on selecting the 
active media, see pageŚ58.

Files in BBG media
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Using Waveform Markers
The signal generator provides four waveform markers to mark specific points on a waveform 
segment. When the signal generator encounters an enabled marker, an auxiliary signal is routed to 
a rear panel event output that corresponds to the marker number.

— Event 1 is available at both the EVENT 1 BNC connector (see page 15), and a pin on the 
AUXILIARY I/O connector (see page 17).

— Event 2 is available at the TRIG 1 & TRIG 2 connectors (see page 13), and a pin on the 
AUXILIARY I/O connector (see page 17).

— Events 3 and 4 are available at pins on the AUXILIARY I/O connector (see page 17).

You can use an auxiliary output signal to synchronize another instrument with the waveform, or as a 
trigger signal to start a measurement at a given point on a waveform.

You can also configure markers to initiate ALC hold or RF Blanking (which includes ALC hold). Refer 
to “Using Waveform Markers” on pageŚ167 for details.

When you download a waveform file that does not have a marker file associated with it, the signal 
generator creates a marker file without any marker points. Factory–supplied segments 
(RAMP_TEST_WFM and SINE_TEST_WFM) have a marker point on the first sample for all four 
markers.

The following procedures demonstrate how to use markers while working in the dual ARB player. 
These procedures also discuss two types of points: a marker point and a sample point. A marker 
point is a point at which a given marker is set on a waveform; you can set one or more marker 
points for each marker. A sample point is one of the many points that compose a waveform.

There are three basic steps to using waveform markers:

Clearing Marker Points from a Waveform Segment on page 173

Setting Marker Points in a Waveform Segment on page 174

Controlling Markers in a Waveform Sequence on page 179

This section also provides the following information:

— Waveform Marker Concepts on page 168

— Accessing Marker Utilities on page 172

— Viewing Waveform Segment Markers on page 173

— Viewing a Marker Pulse on page 176

— Using the RF Blanking Marker Function on page 178

— Setting Marker Polarity on page 179
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Waveform Marker Concepts

The signal generator’s Dual ARB provides four waveform markers for use on a waveform segment. 
You can set each marker’s polarity and marker points (on a single sample point or over a range of 
sample points). Each marker can also perform ALC hold, or RF Blanking and ALC hold.

Marker Signal Response

The signal generator aligns the marker signals with the I and Q signals at the baseband generator. 
However some settings such as amplitude, filters, and so forth within the RF output path can create 
delays between the marker EVENT output signal and the modulated RF output. When using the 
marker EVENT output signal, observe the signals (marker relative to modulated RF) for any latency, 
and if needed, reset the marker point positions, include delay (page 213), or both.

Marker File Generation

Downloading a waveform file (as described in the Programming Guide) that does not have a marker 
file associated with it causes the signal generator to automatically create a marker file, but does 
not place any marker points.

Marker Point Edit Requirements

Before you can modify a waveform segment’s marker points, the segment must reside in BBG 
media (see “Loading a Waveform Segment into BBG Media” on pageŚ153).

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset the signal generator, 
or cycle power. To ensure that a waveform uses the correct settings when it is played, set the 
marker polarities or routing (RF Blanking and ALC Hold) and save the information to the file header 
(page 161). 

When you use a waveform that does not have marker routings and polarity 
settings stored in the file header, and the previously played waveform used 
RF Blanking, ensure that you set RF Blanking to None. Failure to do so can 
result in no RF output or a distorted waveform.

Marker 
File
Bit N

Marker
Polarity

Marker N 
RF Blank Off On

Marker N
Blanks RF when 
Marker is Low

EVENT N

Negative

Positive

Set Marker
On Off

Marker N 
ALC Hold Off On

Marker N
Holds ALC when 

Marker is Low

When the signal generator encounters an enabled marker (described on pageŚ179), an 
auxiliary output signal is generated and routed to the rear panel. 

Event 1 is available at the EVENT 1 BNC connector (see pageŚ15), and at a pin on the 
AUXILIARY I/O connector (see pageŚ17).

Events 2 through 4 are available at pins on the AUXILIARY I/O connector 

RF Blank Only: includes ALC Hold
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ALC Hold Marker Function

While you can set a marker function (described as Marker Routing on the softkey label) either 
before or after you set marker points (page 174), setting a marker function before setting marker 
points may cause power spikes or loss of power at the RF output.

Use the ALC hold function by itself when you have a waveform signal that incorporates idle periods, 
burst ramps, or when the increased dynamic range encountered with RF blanking (page 178) is not 
desired. 

The ALC hold marker function holds the ALC circuitry at the average value of the sampled points 
set by the marker(s). For both positive and negative marker polarity, the ALC samples the RF output 
signal (the carrier plus any modulating signal) when the marker signal goes high:

Positive: The signal is sampled during the on marker points.

Negative The signal is sampled during the off marker points.

Because it can affect the waveform’s output amplitude, do not use the ALC 
hold for longer than 100 ms. For longer time intervals, refer to “Power 
Search Mode” on page 103.

Incorrect ALC sampling can create a sudden unleveled condition that may 
create a spike in the RF output, potentially damaging a DUT or connected 
instrument. To prevent this condition, ensure that you set markers to let 
the ALC sample over an amplitude that accounts for the higher power 
levels encountered within the signal.

Positive 
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Close–up of averaging

The ALC samples the waveform when the marker 
signal goes high, and uses the average of the 
sampled waveform to set the ALC circuitry.

Here the ALC samples during the on marker points 
(positive polarity).

Marker Marker

MarkerMarker

Example of Correct Use

Waveform: 1022 points 
Marker range: 95–97 
Marker polarity: Positive

This example shows a marker set to sample the 
waveform’s area of highest amplitude. Note that the 
marker is set well before the waveform’s area of lowest 
amplitude. This takes into account any response 
difference between the marker and the waveform signal.

Pulse Unleveled

Example of Incorrect Use

Waveform: 1022 points 
Marker range: 110–1022 
Marker polarity: Positive

This example shows a marker set to sample the low 
part of the same waveform, which sets the ALC 
modulator circuitry for that level; this usually results 
in an unleveled condition for the signal generator 
when it encounters the high amplitude of the pulse.

MarkerMarker
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Sample range begins on first point of signal

Negative range set between signal and  
off time

Example of Incorrect Use

Waveform: 1022 points 
Marker range: 110–1022 
Marker polarity: Negative

This figure shows that a negative polarity marker goes 
low during the marker on points; the marker signal goes 
high during the off points. The ALC samples the 
waveform during the off marker points.

Marker On Marker On

Sampling both on and off time sets the modulator 
circuitry incorrectly for higher signal levels. Note the 
increased amplitude at the beginning of the pulse.

Marker
Off

Marker On
MarkerMarker

Off On
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Accessing Marker Utilities
Mode > Dual ARB > More > Marker Utilities

Note: This is the 
second Arb menu.

The display below shows the I 
and Q components of the waveform, and the 
marker points set in a factory–supplied segment.

First sample point 
shown on display

These softkeys change 
the range of waveform 
sample points shown 
on the marker display.

Each press of the 
softkey changes the 
sample range by 
approximately a factor 
of two.Marker points 

on first  
sample point

For details on each key, use key help 
as described on pageŚ40.

The settings in these menus 
can be stored to the file 
header, see pageŚ161.

pageŚ47
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Viewing Waveform Segment Markers

Markers are applied to waveform segments. Use the following steps to view the markers set for a 
segment (this example uses the factory–supplied segment, SINE_TEST_WFM).

1. In the second Arb menu (page 172), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment (in this example, SINE_TEST_WFM).
3. Press Display Waveform and Markers > Zoom in Max. 

The maximum zoom in range is 28 points.

Experiment with the Zoom functions to see how they display the markers.

The display can show a maximum of 460 points; displayed waveforms with a sample point range 
greater than 460 points may not show the marker locations.

Clearing Marker Points from a Waveform Segment

When you set marker points they do not replace points that already exist, but are set in addition to 
existing points. Because markers are cumulative, before you set points, view the segment 
(page 173) and remove any unwanted points. With all markers cleared, the level of the event output 
signal is 0V. To clear marker points on a segment, the segment must reside in BBG media 
(page 153).

Clearing All Marker Points

1. In the second Arb menu (page 172), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment (in this example, SINE_TEST_WFM).

3. Highlight the desired marker number: Press Marker 1 2 3 4.

4. For the selected marker number, remove all marker points in the selected segment:

a. Press Set Marker Off Range of Points.

Notice that the softkeys for the first and last marker points correspond with the length of 
the waveform. The factory–supplied waveform (SINE_TEST_WFM) contains 200 samples. To 
clear all set marker points, the range must equal to the length of the waveform.

b. Press Apply To Waveform > Return.

5. Repeat from StepŚ3 for any remaining marker points that you want to remove from the other 
markers.

Clearing a Range of Marker Points

The following example uses a waveform with marker points (Marker 1) set across points 10−20. This 
makes it easy to see the affected marker points. The same process applies whether the existing 
points are set over a range or as a single point (page 174).‘

1. In the second Arb menu (page 172), press Marker Utilities > Set Markers, then select Marker 
1.

2. Set the first sample point that you want off (for this example, 13): 
Press Set Marker Off Range Of Points > First Mkr Point > 13 > Enter.
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3. Set the last marker point in the range that you want off to a value less than or equal to the 
number of points in the waveform, and greater than or equal to the value set in Step 2 (for this 
example, 17): 

Press Last Mkr Point > 17 > Enter > Apply To Waveform > Return.

 
This turns off all marker points for the 
active marker within the range set in 
Steps 2 and 3, as shown at right.

How to view markers is described on 
page 173.

Clearing a Single Marker Point

Use the steps described in “Clearing a Range of Marker Points” on page 173, but set both the first 
and last marker point to the value of the point you want to clear. For example, if you want to clear a 
marker on point 5, set both the first and last value to 5.

Setting Marker Points in a Waveform Segment

To set marker points on a segment, the segment must reside in BBG media (page 153).

When you set marker points, they do not replace points that already exist, but are set in addition to 
existing points. Because markers are cumulative, before you set marker points within a segment, 
view the segment (page 173) and remove any unwanted points (page 173).

Placing a Marker Across a Range of Points

1. In the second Arb menu (page 172), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment.

3. Select the desired marker number: Press Marker 1 2 3 4

4. Set the first sample point in the range (in this example, 10):

Press Set Marker On Range Of Points > First Mkr Point > 10 > Enter.

5. Set the last marker point in the range to a value less than or equal to the number of points in 
the waveform, and greater than or equal to the first marker point (in this example, 20):

Press Last Mkr Point > 20 > Enter.

6. Press Apply To Waveform > Return.

This sets a range of waveform marker points. The marker signal starts on sample point 10, and ends 
on sample point 20, as shown in the following figure.
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Placing a Marker on a Single Point

On the First Point

1. In the second Arb menu (page 172), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment.

3. Select the desired marker number: 
Press Marker 1 2 3 4.

4. Press  Set Marker On First Point.

This sets a marker on the first point in the segment for the marker number selected in StepŚ3.

On Any Point

Use the steps described in “Placing a Marker Across a Range of Points” on pageŚ174, but set both 
the first and last marker point to the value of the point you want to set. For example, if you want to 
set a marker on point 5, set both the first and last value to 5.

Placing Repetitively Spaced Markers

The following example sets markers across a range of points and specifies the spacing (skipped 
points) between each marker. You must set the spacing before you apply the marker settings; you 
cannot apply skipped points to a previously set range of points.

1. Remove any existing marker points (page 168).

2. In the second Arb menu (page 172), press Marker Utilities > Set Markers.

3. Highlight the desired waveform segment. 

4. Select the desired marker number:  
Press Marker 1 2 3 4.

5. Set the first sample point in the range (in this example, 5): 
Press Set Marker On Range Of Points > First Mkr Point > 5 > Enter.

6. Set the last marker point in the range. (The last marker point value must always be less than 
or equal to the number of points in the waveform, and greater than or equal to the first marker 
point, in this example, 25): 
Press Last Mkr Point > 25 > Enter.

The skipped points value is limited to the size of the range of points.

How to view markers is described on pageŚ173
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7. Enter the number of sample points that you want skipped (in this example, 1): 
Press # Skipped Points > 1 > Enter.

8. Press Apply To Waveform > Return.

This causes the marker to occur on every 
other point (one sample point is skipped) 
within the marker point range, as shown at 
right.

How to view markers is described on 
page 173.

One application of the skipped point feature is the creation of a clock signal as the EVENT output.

Viewing a Marker Pulse

When a waveform plays (page 159), you can detect a set and enabled marker’s pulse at the rear 
panel event connector/Aux I/O pin that corresponds to that marker number. This example 
demonstrates how to view a marker pulse generated by a waveform segment that has at least one 
marker point set (page 174). The process is the same for a waveform sequence.  

This example uses the factory–supplied segment, SINE_TEST_WFM in the dual ARB Player. 
Factory–supplied segments have a marker point on the first sample point for all four markers, as 
shown.

1. In the first Arb menu (page 152), press Select Waveform.

2. Highlight the SINE_TEST_WFM segment and press Select Waveform.

3. Press ARB Off On to On.

4. Connect the signal generator’s rear panel Q OUT output to the oscilloscope’s channel 1 input.

5. Connect the signal generator’s rear panel EVENT 1 output to the oscilloscope’s channel 2 
input. 

Marker points on 
first sample point of 
waveform segment

How to view markers is described on pageŚ173
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When marker 1 is present, the Keysight MXG/EXG outputs a signal through EVENT 1 as shown 
in the following example.

Q OUT

Marker pulse on the Event 1 signal.
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Using the RF Blanking Marker Function

While you can set a marker function (described as Marker Routing on the softkey label in the 
Marker Utilities menu) either before or after setting the marker points (page 174), setting a marker 
function before you set marker points may change the RF output. RF Blanking includes ALC hold 
(described on page 169, note Caution regarding unleveled power). The signal generator blanks the 
RF output when the marker signal goes low. This example is a continuation of the previous example, 
Viewing a Marker Pulse.

1. Using the factory–supplied segment SINE_TEST_WFM, set Marker 1 across points 1−180 
(page 174).

2. From the Marker Routing softkey menu, assign RF Blanking to Marker 1:  
In the second Arb menu (page 172), press Marker Utilities > Marker Routing > Pulse/RF 
Blank > Marker 1.

Marker Polarity = Positive
When marker polarity is positive (the default 
setting), the RF output is blanked during the off 
marker points.

200180Point 1
Marker

Segment

RF Signal

200180Point 1
Marker

Segment

Marker Polarity = Negative
When marker polarity is negative, the 
RF output is blanked during the on marker 
points

≈3.3V

0V

≈3.3V

0V

RF SignalRF Signal

RF Signal
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Setting Marker Polarity

Setting a negative marker polarity inverts the marker signal.

1. In second Arb menu (page 172), press Marker Utilities > Marker Polarity.

2. For each marker, set the marker polarity as desired.

— The default marker polarity is positive.

— Each marker polarity is set independently.

See also, “Saving Marker Polarity and Routing Settings” on pageŚ168.

As shown on page 178:

Positive Polarity:  On marker points are high (≈3.3V). 

Negative Polarity:  On marker points are low (0V).

RF blanking always occurs on the low part of the signal regardless of the polarity setting.

Controlling Markers in a Waveform Sequence

In a waveform segment, an enabled marker point generates an auxiliary output signal that is routed 
to the rear panel EVENT output (described in “Rear Panel Overview (N5171B, N5172B, N5181B, & 
N5182B)” on page 12) corresponding to that marker number. For a waveform sequence, you 
enable or disable markers on a segment–by–segment basis; this enables you to output markers for 
some segments in a sequence, but not for others. Unless you change the sequence marker settings 
or cycle the power, the marker setting for the last segment edited in the sequence applies to all 
segments in the next sequence that you build. For information on building a waveform sequence, 
see “Creating a Sequence” on pageŚ156.
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Figure 9-6 Waveform Sequence Menus for Enabling/Disabling Segment Markers

Mode > Dual ARB > 
More 

Note: This is the second Arb menu.

For details on each key, use key help 
as described on pageŚ40.

Enable/Disable markers while 
creating a waveform sequence

Edit a sequence to 
enable/disable markers
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Enabling and Disabling Markers in a Waveform Sequence

Select the waveform segments within a waveform sequence to enable or disable each segment’s 
markers independently. You can enable or disable the markers either at the time of creating the 
sequence or after the sequence has been created and stored. If the sequence has already been 
stored, you must store the sequence again after making any changes. Enabling a marker that has 
no marker points has no effect on the auxiliary outputs. To set marker points on a segment, see 
“Setting Marker Points in a Waveform Segment” on pageŚ174. This example assumes that a 
waveform sequence exists.

1. Ensure that all waveform segments for the sequence reside in BBG media (see page 153).

2. From the second Arb menu, press Waveform Sequences.

3. Highlight the desired waveform sequence.

4. Press Edit Selected Waveform Sequence > Enable/Disable Markers.

5. Toggle the markers: 

a. Highlight the first waveform segment.

b. As desired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 
4.

An entry in the Mkr column (see figure below) indicates that the marker is enabled for that 
segment; no entry in the column means that all markers are disabled for that segment.

c. In turn, highlight each of the remaining segments and repeat StepŚb.

6. Press Return > More > Name and Store.

7. Either rename the sequence using the text entry keys (see page 154) or just press Enter to 
save the sequence with the existing name.

The markers are enabled or disabled per the selections, and the changes saved to the sequence 
file.

The following figure shows a sequence built using one of the factory–supplied waveform segments; 
a factory–supplied segment has a marker point on the first sample for all four markers. In this 
example, marker 1 is enabled for the first segment, marker 2 is enable for the second segment, and 
markers 3 and 4 are enabled for the third segment.

For each segment, only the markers enabled for that segment produce a rear panel auxiliary output 
signal. In this example, the marker 1 auxiliary signal appears only for the first segment, because it is 
disabled for the remaining segments. The marker 2 auxiliary signal appears only for the second 
segment, and the marker 3 and 4 auxiliary signals appear only for the third segment.

Sequence marker column

This entry shows that markers 
3 and 4 are enabled for this 
segment.
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Using the EVENT Output Signal as an Instrument Trigger

 
One of the uses for the EVENT output 
signal (marker signal) is to trigger a 
measurement instrument. You can set 
up the markers to start the 
measurement at the beginning of the 
waveform, at any single point in the 
waveform, or on multiple points in the 
waveform. To optimize the use of the 
EVENT signal for measurements, you 
may also need to adjust the sample 
rate. The location of the sample rate setting is shown in the figure at right.

The EVENT output signal can exhibit jitter of up to ±4 ns on the rising and falling edge. This jitter 
can be minimized in either of two ways. 

Method 1: Use a sample clock of 125 MHz/N where N is a positive integer and where 125 MHz/N 
can be represented exactly on the display.  
For example: 125 MHz, 62.5 MHz, 31.25 MHz, 25 MHz, and so on. 

If the result cannot be represented exactly on the display, jitter will be present. 
For example: N = 6 will result in jitter, because 125 MHz/6 = 20.833 Mhz, which is truncated when 
displayed.

Method 2: Select a sample clock and waveform length that spaces the markers by a multiple of 8 
ns. For example: A 200 point waveform with a marker on the first point and a sample clock of 50 
MHz provides a marker every 4 µs. Because 4 µs is a multiple of 8 ns, the jitter is minimized.

When the EVENT output signal exhibits jitter and it is used as a measurement trigger, it can cause 
the waveform to falsely appear as having jitter. If this condition occurs, you can adjust the sample 
rate to a value (see above) that does not cause the jitter appearance. To maintain the integrity of 
the original waveform with a sample rate change, you will have to also recalculate the sample 
values. The following figures illustrate the marker signal jitter and its affect on the waveform.

Sample 
rate  
setting

The settings in this menu 
can be stored to the file 
header, see pageŚ161.

For details on each key, use key help as described on pageŚ40.

The jitter is gone with
an optimal sample rate

Waveform appears to exhibit jitter when
triggered using EVENT signal with jitter.

Oscilloscope triggering on waveform Oscilloscope triggering on EVENT signal Oscilloscope triggering on EVENT signal

EVENT output signal exhibits jitter
due to a non–optimal sample rate
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Triggering a Waveform

Figure 9-7 Triggering Softkeys

Triggers control data transmission by controlling when the signal generator transmits the 
modulating signal. You can configure trigger settings so that data transmission occurs once (Single 
mode), continuously (Continuous mode), or starts and stops repeatedly (Gated and Segment 
Advance modes).

A trigger signal contains both positive and negative states; you can use either for triggering.

When you initially select a trigger mode or when you change from one triggering mode to another, 
you may lose the carrier signal at the RF output until the modulating signal is triggered. This is 
because the signal generator sets the I and Q signals to zero volts prior to the first trigger event. To 
maintain the carrier signal at the RF output, create a data pattern with the initial I and Q voltages 
set to values other than zero. 

When you initially turn the Arb ON or select a trigger mode or when you change from one triggering 
mode to another, you may temporarily lose the carrier signal for a few tens of milliseconds at the RF 
output. The Arb will present the idle IQrms value of the next Arb waveform to the IQ modulator. This 
ensures that the RF carrier output is at the correct amplitude level while the Arb waits for a trigger. 
When that trigger is received, the Arb begins playing the waveform and the modulated RF carrier 
exhibits no undesirable transients.

There are two parts to configuring a waveform trigger:

— Type determines the behavior of the waveform when it plays (see Trigger Type on page 184).

— Source determines how the signal generator receives the trigger that starts the modulating 
waveform playing (see Trigger Source on page 185).

Mode > Dual ARB

pageŚ184

pageŚ185

For details on each key, use key help 
as described on pageŚ40.
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Trigger Type

Type defines the trigger mode: how the waveform plays when triggered. 

— Continuous mode repeats the waveform until you turn the signal off or select a different 
waveform, trigger mode, or response (Free Run, Trigger & Run, Reset & Run).

— Single mode plays the waveform once. 

No Retrigger: If a trigger is received early it will be ignored. The gap in your playback is 
dependent on the trigger period, after which time the RF will start up again where it is expected.

Buffered Trigger: An early trigger will cause the waveform to play to the end and then start 
again. The RF will not be aligned with this early trigger.

Restart on Trigger: The ARB will reset itself and trigger again but there will some gap in the 
playback while this is occurring. It will reset itself for every trigger it receives.

The example above shows Dual ARB Mode, but trigger functionality is 
similar for other modulation modes. Available trigger types vary 
depending on the modulation mode selected.

In Single No Retrigger, do not use Continuous Reset & Run mode due to 
the variable latency of this setup.

Mode > 
Dual ARB > 
Trigger Type

Immediately triggers and plays the waveform; triggers 
received while the waveform is playing are ignored.

Plays the waveform when a trigger is received; 
subsequent triggers are ignored.

Plays the waveform when a trigger is received; subsequent 
triggers restart the waveform.

The waveform stops during the inactive 
state of the trigger source, and plays 
during the active state.

Ignores an early trigger 
received while a 
waveform is playing.

An early trigger received 
while a waveform is 
playing waits until the 
current waveform 
completes, then plays 
the waveform once 
more.

An early trigger received 
while the waveform is 
playing immediately 
restarts the waveform.

A segment in a sequence plays 
once, ignoring the repetition 
setting, after which the dual ARB 
player stops and waits for a 
trigger before advancing to the 
next segment. The next segment 
then plays to completion.  
 
If a trigger is received while a 
segment is playing, the segment 
plays to completion. The dual 
ARB player then advances to the 
next segment and plays that 
segment to completion.

A segment in a sequence plays continuously until the waveform receives another trigger.  
 
If a trigger is received while a segment is playing, the segment plays to completion. The 
dual ARB player then advances to the next segment and plays that segment continuously. 

For details on each key, use key help 
as described on pageŚ40.
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— Segment Ad vance mode plays a segment in a sequence only if triggered. The trigger source 
controls segment–to–segment playing (see Example: Segment Advance Triggering on page 
186). A trigger received during the last segment loops play to the first segment in the sequence.

— Gated mode triggers the waveform at the first active triggering state, then repeatedly starts and 
stops playing the waveform in response to an externally applied gating signal. See Example: 
Gated Triggering on page 187.

Trigger Source

External Trigger Polarity

— In Continuous, Single, and Segment Advance modes, use the Ext Polarity softkey to set the 
external trigger polarity.

— In Gated mode, the Active Low and Active High softkeys (page 184) determine the external 
trigger polarity. 

Mode > 
Dual ARB > 
Trigger Source

Patt Trig In BNC connector  
(see pageŚ16)

Aux I/O connector  
(see pageŚ17)

Neg = the signal generator 
responds during the trigger signal 
low state.

Pos = the signal generator 
responds during the trigger signal 
high state.

For details on each key, use key help 
as described on pageŚ40.

Key inactive until Ext 
Delay is enabled On.
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Example: Segment Advance Triggering

Segment advance triggering enables you to control the segment playback within a waveform 
sequence. This type of triggering ignores the repetition value (page 158). For example if a segment 
has repetition value of 50 and you select Single as the segment advance triggering mode, the 
segment still plays only once. The following example uses a waveform sequence that has two 
segments.

If you have not created and stored a waveform sequence, refer to “Creating a Sequence” on 
page 156.

1. Preset the signal generator.

2. Configure the RF output:

— Set the desired frequency.

— Set the desired amplitude.

— Turn on the RF output.

3. Select a waveform sequence for playback:

a. Press Mode > Dual ARB > Select Waveform.

b. In the Sequence On column, highlight a waveform sequence file.

c. Press Select Waveform.

4. Set the triggering as follows:

— Trigger Type: continuous Segment Advance 
Press Trigger Type > Segment Ad vance > Continuous.

— Trigger source: Trigger hardkey 
Press Trigger Source > Trigger Key.

5. Generate the waveform sequence:  
Press ARB Off On until On highlights.

6. (Optional) Monitor the waveform:

Connect the RF OUTPUT of the signal generator to the input of an oscilloscope, and configure 
the oscilloscope so that you can see the signal.

7. Trigger the first waveform segment to begin playing continuously:  
Press the Trigger hardkey.

8. Trigger the second segment:  
Press the Trigger hardkey.

Pressing the Trigger hardkey causes the currently playing segment to finish and the next 
segment to start.

If the last segment in the sequence is playing, pressing the Trigger hardkey causes the first 
segment in the waveform sequence to start when the last segment finishes.



Keysight EXG and MXG X-Series Signal Generators User’s Guide                                                                      187

Basic Digital Operation (Option 653/655/656/657)

Triggering a Waveform

Example: Gated Triggering

Gated triggering enables you to define the on and off states of a modulating waveform.

1. Connect the output of a function generator to the signal generator’s rear panel PAT TRIG IN 
connector, as shown in the following figure. This connection is applicable to all external 
triggering methods. The optional oscilloscope connection enables you to see the effect that 
the trigger signal has on the RF output.

2. Preset the signal generator.

3. Configure the RF output:

— Set the desired frequency.

— Set the desired amplitude.

— Turn on the RF output.

4. Select a waveform for playback (sequence or segment):

a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On or Sequence On column, highlight a waveform.

c. Press Select Waveform.

5. Set the triggering as follows:

— Trigger type: Gated 
Press Trigger Type > Gated.

— Active state: Low 
Press Active Low.

— Trigger source: External 
Press Trigger Source > Ext.

— Input connector: Rear panel Patt Trig In BNC 
Press Ext Source > Patt Trig In 1.

6. Generate the waveform: Press Return > ARB Off On until On highlights.

7. On the function generator, configure a TTL signal for the external gating trigger.
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8. (Optional) Monitor the waveform:

Configure the oscilloscope to display both the output of the signal generator, and the external 
triggering signal. You will see the waveform modulating the output during the gate active 
periods (low in this example).

The following figure shows an example display.

RF Output

Externally Applied Gating Signal 
Gate Active = Low

Modulating Waveform
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Example: External Triggering

Use the following example to set the signal generator to output a modulated RF signal 
100 milliseconds after a change in TTL state from low to high occurs at the PATT TRIG IN rear panel 
BNC connector

1. Connect the signal generator to the function generator as shown above.

2. Configure the RF output:

— Set the desired frequency.
— Set the desired amplitude.
— Turn on the RF output.

3. Select a waveform for playback (sequence or segment):

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On or Sequence On column, highlight a waveform.
c. Press Select Waveform.

4. Generate the waveform:  
Press ARB Off On until On highlights.

5. Set the waveform trigger as follows:

a. Trigger Type: single 
Press Trigger Type > Single > No Retrigger

b. Trigger Source: external 
Press Trigger Source > Ext

c. Input connector: Rear panel Patt Trig In BNC 
Press Ext Source > Patt Trig In 1.

d. External Trigger Polarity: positive 
Press Ext Polarity until Pos highlights

e. External Delay: 100 ms 
Press More > Ext Delay until On highlights 
Press Ext Delay Time > 100 > msec

6. Configure the Function Generator:

— Waveform: 0.1 Hz square wave
— Output Level: 3.5V to 5V. 
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Clipping a Waveform
Digitally modulated signals with high power peaks can cause intermodulation distortion, resulting 
in spectral regrowth that can interfere with signals in adjacent frequency bands. The clipping 
function enables you to reduce high power peaks by clipping the I and Q data to a selected 
percentage of its highest peak, thereby reducing spectral regrowth.

— How Power Peaks Develop on page 191

— How Peaks Cause Spectral Regrowth on page 193

— How Clipping Reduces Peak–to–Average Power on page 194

— Configuring Circular Clipping on page 197

— Configuring Rectangular Clipping on page 198

Figure 9-8 Clipping Softkeys

Mode > Dual ARB > More 

Available only when  
clipping type = |I|, |Q|

For details on each key, use key help 
as described on pageŚ40.
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How Power Peaks Develop

To see how clipping reduces high power peaks, it is important to understand how the peaks 
develop as you construct a signal.

Multiple Channel Summing

I/Q waveforms can be the summation of multiple channels, as shown in the following figure. If a bit 
in the same state (high or low) occurs simultaneously in several individual channel waveforms, an 
unusually high power peak (positive or negative) occurs in the summed waveform. 

Because the high and low states of the bits in channel waveforms are random and generally result 
in a canceling effect, high power peaks occur infrequently with multiple channel summing.
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Combining the I and Q Waveforms

When the I and Q waveforms combine in the I/Q modulator to create an RF waveform, the 

magnitude of the RF envelope is , where the squaring of I and Q always results in a positive 
value.

As shown in the following figure, simultaneous positive and negative peaks in the I and Q 
waveforms do not cancel each other, but combine to create an even greater peak.
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How Peaks Cause Spectral Regrowth

In a waveform, high power peaks that occur infrequently cause the waveform to have a high 
peak–to–average power ratio, as illustrated in the following figure. 

Because the gain of a transmitter’s power amplifier is set to provide a specific average power, high 
peaks can cause the power amplifier to move toward saturation. This causes the intermodulation 
distortion that generates spectral regrowth. Spectral regrowth is a range of frequencies that 
develops on each side of the carrier (similar to sidebands) and extends into the adjacent frequency 
bands (see the following figure). Clipping provides a solution to this problem by reducing the 
peak–to–average power ratio.
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How Clipping Reduces Peak–to–Average Power

You can reduce peak–to–average power, and consequently spectral regrowth, by clipping the 
waveform. Clipping limits waveform power peaks by clipping the I and Q data to a selected 
percentage of its highest peak. The Signal Generator provides two methods of clipping:

— Circular clipping is applied to the composite I/Q data (I and Q data are equally clipped).

As shown in Figure 9-9, the clipping level is constant for all phases of the vector and appears as 
a circle in the vector representation.

— Rectangular clipping is independently applied the I and Q data.

 As shown in Figure 9-10 on page 195, the clipping level is different for I and Q, and appears as 
a rectangle in the vector representation.

In both circular and rectangular clipping, the objective is to clip the waveform to a level that 
reduces spectral regrowth but does not compromise the integrity of the signal. The two 
complementary cumulative distribution plots in Figure 9-11 on page 196 show the reduction in 
peak–to–average power that occurs after applying circular clipping to a waveform.

The lower the clipping value, the lower the peak power that is passed (the more the signal is 
clipped). The peaks can often be clipped without substantially interfering with the rest of the 
waveform. In many cases, data that might otherwise be lost in the clipping process is retained 
because of the error correction inherent in the coded systems. If you apply excessive clipping, 
however, lost data cannot be recovered. Experiment with clipping settings to find a percentage that 
reduces spectral regrowth while retaining needed data.

Figure 9-9 Circular Clipping
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Figure 9-10 Rectangular Clipping
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Figure 9-11 Reduction of Peak–to–Average Power
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Configuring Circular Clipping

Use this example to configure circular clipping and observe its affect on the peak–to–average 
power ratio of a waveform. Circular clipping clips the composite I/Q data (I and Q data are clipped 
equally). For more information about circular clipping, refer to “How Clipping Reduces 

Peak–to–Average Power” on page 194.

Copy a Waveform File

1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

4. Name the copy (in this example, the name is MY_TEST_CIRC) and press Enter.

Apply Circular Clipping to the Copied Waveform File

1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform 
Utilities.

2. In the list of files, highlight the copied file (in this example, MY_TEST_CIRC).

3. Create the CCDF plot: Press Plot CCDF. 

4. Observe the shape and position of the 
waveform’s curve (the dark line in the 
example at right).

5. Activate circular clipping: Press Return > 
Clipping > Clipping Type until |I+jQ| 
highlights.

6. Set circular clipping to 80%:  
Press Clip |I+jQ| To > 80 > %.

7. Apply 80% clipping to the I and Q data: Press Apply to Waveform.

8. Create the CCDF plot (see the example 
at right): Press Plot CCDF. 

9. Observe the waveform’s curve after 
clipping. 

Note the reduction in peak–to–average 
power relative to the previous plot.

Clipping is non–reversible and cumulative. Save a copy of the waveform 
file before you apply clipping.

Example waveform curve before clipping 

Example waveform curve after circular clipping



 198                                                                     Keysight EXG and MXG X-Series Signal Generators User’s Guide

Basic Digital Operation (Option 653/655/656/657)
Clipping a Waveform

Configuring Rectangular Clipping

Use this example to configure rectangular clipping. Rectangular clipping clips the I and Q data 
independently. For more information about rectangular clipping, refer to “How Clipping Reduces 

Peak–to–Average Power” on page 194.

Copy a Waveform File

1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

4. Name the copy (in this example, the name is MY_TEST_REC) and press Enter.

Apply Rectangular Clipping to the Copied Waveform File

1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform 
Utilities.

2. In the list of files, highlight the copied file (in this example, MY_TEST_REC).

3. Create the CCDF plot: Press Plot CCDF. 

4. Observe the shape and position of the 
waveform’s curve (the dark line in the 
example at right).

5. Activate rectangular clipping: Press 
Return > Clipping > Clipping Type until 
|I|,|Q| highlights.

6. Set 80% clipping for the I data: Press 
Clip |I| To > 80 > %.

7. Set 40% clipping for the Q data: Press Clip |Q| To > 40 > %.

8. Apply the rectangular clipping to the waveform: Press Apply to Waveform.

9. Create the CCDF plot (see the example 
at right): Press Plot CCDF. 

10.Observe the waveform’s curve after 
clipping. 

Note the reduction in peak–to–average 
power relative to the previous plot.

Clipping is non–reversible and cumulative. Save a copy of the waveform 
file before you apply clipping.

Example waveform curve before clipping 

Example waveform curve after rectangular 
clipping
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Scaling a Waveform
The signal generator uses an interpolation algorithm (sampling between the I/Q data points) when 
reconstructing a waveform. For common waveforms, this interpolation can cause overshoots, which 
may create a DAC over–range error condition. This chapter describes how DAC over–range errors 
occur and how you can use waveform scaling to eliminate these errors.

— How DAC Over–Range Errors Occur on page 200

— How Scaling Eliminates DAC Over–Range Errors on page 201

— Keysight MXG/EXG waveform scaling on page 202 and page 203:

— Waveform runtime scaling to scale a currently–playing waveform

— Waveform scaling to permanently scale either the currently playing waveform, or a 
non–playing waveform file in BBG media

Figure 9-12 Scaling Softkeys

For details on each key, use key help 
as described on pageŚ40.

The settings in this menu can 
be stored to the file header, 
see pageŚ161.

Waveform Runtime Scaling, see pageŚ202.

Waveform Scaling, see pageŚ203.
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How DAC Over–Range Errors Occur

The signal generator uses an interpolator 
filter when it converts digital I and Q 
baseband waveforms to analog 
waveforms. Because the clock rate of the 
interpolator is four times that of the 
baseband clock, the interpolator 
calculates sample points between the 
incoming baseband samples and smooths 
the waveform as shown in the figure at 
the right.

The interpolation filters in the DACs 
overshoot the baseband waveform. If a 
baseband waveform has a fast–rising 
edge, the interpolator filter’s overshoot 
becomes a component of the interpolated 
baseband waveform. This response 
causes a ripple or ringing effect at the 
peak of the rising edge. If this ripple 
overshoots the upper limit of the DAC 
range, the interpolator calculates 
erroneous sample points and is unable to 
replicate the true form of the ripple (see 
the figure at the right). As a result, the 
signal generator reports a DAC 
over–range error.
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How Scaling Eliminates DAC Over–Range Errors

Scaling reduces the amplitude of the baseband 
waveform while maintaining its basic shape and 
characteristics, such as peak–to–average power 
ratio. If the fast–rising baseband waveform is 
scaled enough to allow an adequate margin for 
the interpolator filter overshoot, the interpolator 
filter can calculate sample points that include the 
ripple effect and eliminate the over–range error 
(see the figure at the right).

Although scaling maintains the basic shape of the 
waveform, excessive scaling can compromise 
waveform integrity. For example, if the bit 
resolution becomes too low the waveform 
becomes corrupted with quantization noise. To 
achieve maximum accuracy and optimize 
dynamic range, scale the waveform no more than 
is required to remove the DAC over–range error. 
Optimum scaling varies with waveform content.
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Setting Waveform Runtime Scaling

Runtime scaling scales the waveform data during playback; it does not affect the stored data. You 
can apply runtime scaling to either a segment or sequence, and set the scaling value either while 
the ARB is on or off. This type of scaling is well suited for eliminating DAC over–range errors. 
Runtime scaling adjustments are not cumulative; the scaling value is applied to the original 
amplitude of the waveform file. There are two ways to save the runtime scaling setting: by using the 
save function (page 64) and by saving the setting to the file header (page 163). Saving to the file 
header saves the value with the waveform file, saving with the Save function stores the value as the 
current instrument setting.

Use this example to learn how to scale the currently selected waveform. 

1. Select the waveform to which you want to apply scaling:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired waveform (segment or sequence).
c. Press Select Waveform.

2. Play the selected waveform: Press ARB Off On until On highlights.

3. Set the Waveform Runtime Scaling value: 

a. Press ARB Setup > Waveform Runtime Scaling. 

b. Enter a scaling value.

The signal generator automatically applies the new scaling value to the waveform. There is 
no single value that is optimal for all waveforms. To achieve the maximum dynamic range, 
use the largest scaling value that does not result in a DAC over–range error. 

c. Press Return. 
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Setting Waveform Scaling

Waveform scaling differs from waveform runtime scaling in that it permanently affects waveform 
data and only applies to waveform segments stored in BBG media. You scale the waveform either 
up or down as a percentage of the DAC full scale (100%). If you scale your waveforms using this 
method, you may also need to change the waveform runtime scaling value to accommodate this 
scaling.

When you scale, the signal generator permanently modifies the waveform file’s sample values so 
that they conform to the desired scaling value. When you initiate scaling, the signal generator 
performs the following actions:

— locates the waveform file’s absolute peak sample value
— determines its current percentage of full scale
— calculates the ratio of the desired scale value to the determined absolute peak sample scale 

value
— multiplies each sample in the waveform file by this ratio

When you scale a waveform, you can create fractional data, lose data, or both. Fractional data 
occurs almost every time you reduce or increase the scaling value, and causes quantization errors. 
Quantization errors are more noticeable when scaling down, since you are closer to the noise floor. 
You lose data when either the signal generator rounds fractional data down or the scaling value is 
derived using the results from a power of two. This means that scaling a waveform in half (power of 
two: 21 = 2) causes each waveform sample to lose one bit. The waveform data modifications are not 
correctable and may cause waveform distortion. It is always best to make a copy of the original file 
prior to applying scaling.

Use the following examples to apply waveform scaling to a waveform file. While this process uses 
the factory–supplied waveform RAMP_TEST_WFM, it is the same for any waveform file.

Copy a Waveform File

1. Display the waveform files in BBG media: Press File > Catalog Type > More > Volatile 
Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

Peak sample

85% of full scale—Prescaling

60% of full scale–Post scaling

DAC full scale 100%

Scaled sample value = scaling ratio × prescale sample val

Scaling ratio = desired scale val / current scale val
                     = 60 / 85
                     = 0.70588

Each sample in the waveform is multiplied by 0.70588 to
reach the 60% post scaling waveform amplitude.

Original ramp waveform Scaled ramp waveform

= Samples
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4. Name the copy (this example uses the name MY_TEST_SCAL) and press Enter.

Apply Scaling to the Copied Waveform File

1. Open the DUAL ARB Waveform Utilities menu: 

Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of BBG Media segment files, highlight the copied file (in this example, 
MY_TEST_SCAL).

3. Set and apply a scaling value (in this example 70% scaling is applied): 

Press Scale Waveform Data > Scaling > 70 > % > Apply to Waveform.

This type of scaling is non–reversible. Any data lost in the scaling 
operation cannot be restored. Save a copy of the waveform file before 
scaling.
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Setting the Baseband Frequency Offset
The baseband frequency offset specifies a value to shift the baseband frequency up to ±50 MHz 
within the BBG 100 MHz signal bandwidth, depending on the signal generator’s baseband 
generator option. While the following figure shows how to access the control using the Dual ARB 
player, the location of the Baseband Frequency Offset softkey within each ARB format, through the 
ARB Setup softkey, is the same as for the Dual ARB player.

When the Baseband Frequency Offset is non–zero, the hardware rotator accumulates phase–shift 
of the baseband signal. This residual phase remains even after the offset value is returned to zero. 
To remove this phase accumulation, either restart the personality or select the Baseband 
Frequency Offset Phase Reset softkey. This softkey will grey out whenever the phase, due to the 
frequency offset, is zero. In addition, while there is a non–zero residual phase present in the signal, 
the DAC Over–Range Protection feature will automatically ensure that the reduced internal scaling 
is applied. This reduced scaling will be removed when both the frequency offset is returned to zero 
and the phase is reset. 

Figure 9-13 Baseband Frequency Offset Softkey for the Dual ARB Player

Common uses for the offset feature include:

— offsetting the carrier from any LO feedthrough (carrier signal spur at the carrier frequency)
— sum the baseband signal with external I and Q inputs to create a multicarrier signal
— use the signal generator’s I/Q signal as an IF

pageŚ250

Sets the Baseband 
Frequency Offset value 
entered in the signal to 
baseband.

Clears the phase 
accumulation and so zeros 
the phase shift. Causes a 
sudden phase shift 
discontinuity of the 
baseband signal.

The settings in this menu can 
be stored to the file header, 
see pageŚ161.

For details on each key, use key help 
as described on pageŚ40.

pageŚ250

pageŚ207

pageŚ229

pageŚ199

pageŚ229
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The baseband frequency offset value is one of the file header parameters (page 161), which means 
you can store this value with the waveform. When you select a waveform with a stored frequency 
offset value, the signal generator changes the current value to match the stored file header value. If 
there is no stored baseband offset frequency value for the current waveform, the signal generator 
uses the last set frequency offset value. 

You can also use the Save function (page 64) to store this value as part of the signal generator 
setup. When you Recall a setup stored with the Save function, the baseband frequency offset value 
becomes the current instrument setting value, disregarding the stored file header value.

Use the following steps to offset the carrier from LO/carrier feedthrough. This example uses the 
factory supplied waveform, SINE_TEST_WFM available in the Dual ARB Player. To view the output 
for this example, connect the RF OUTPUT of the signal generator to the input of a spectrum 
analyzer.

1. Select and play the waveform.

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On BBG Media column, select SINE_TEST_WFM.
c. Press Select Waveform.

2. Generate the waveform: Press ARB Off On to On.

3. Configure the carrier signal:

a. Set the carrier signal to 1 GHz.
b. Set the amplitude to 0 dBm.
c. Turn on the RF OUTPUT.

4. Press Mode > Dual Arb > ARB Setup > More > Baseband Frequency Offset > 20 MHz.

The modulated RF signal is now offset from the carrier frequency by 20 MHz as shown in the 
following figures.

Changing the baseband frequency offset may cause a DAC over range 
condition that generates error 628, Baseband Generator DAC over 
range. The signal generator incorporates an automatic scaling feature to 
minimize this occurrence. For more information, see “DAC Over–Range 
Conditions and Scaling” on page  207.
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DAC Over–Range Conditions and Scaling

When using the baseband frequency offset (at a setting other than 0 Hz), it is possible to create a 
DAC over–range condition, which causes the Keysight MXG/EXG to generate an error. To minimize 
this condition with the frequency offset feature, the Keysight MXG/EXG incorporates an automatic 
DAC over–range protection feature that scales down the I/Q data by 1/square root of 2 when the 
offset is something other than zero. Because it can scale the data by more than what is actually 
need, it typically decreases the dynamic range of the waveform. This is especially noticeable when 
using a constant amplitude signal such as GSM.

For the Dual ARB Player, this automatic over–range feature can be turned off. When on, it is active 
for the Dual ARB signal only when the offset is something other than 0 Hz. The control for the Dual 
ARB DAC over–range protection feature is located in the key path as shown in Figure 9-14.

Modulated carrier with 0 Hz 
baseband frequency offset

Modulated carrier with 20 MHz 
baseband frequency offset Modulated RF signal

LO/carrier feedthrough

Spectrum analyzer set to a span of 100 MHz
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Figure 9-14 Dual ARB DAC Over–Range Protection Softkey Location

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the 
feature off and use the Waveform Runtime Scaling softkey to eliminate DAC over–range 
conditions.

For details on each key, use key help 
as described on pageŚ40.

Default setting is On. Available only 
when Phase Noise or AWGN are on 
(see pageŚ309), or when the 
baseband frequency offset is set to a 
value other than zero.
Turn off when you want to manually 
control scaling while using the 
baseband frequency offset feature. 
Manually adjust the scaling using the 
Waveform Runtime Scaling softkey 
above.
Enables or disables the automatic 
internal scaling used to keep DAC 
over-range errors from occuring with 
the Phase Noise, AWGN and 
Frequency Offset features. This 
automatic scaling can be excessive 
(particularly for a constant amplitude 
signal) and thus reduce the dynamic 
range more than is necessary.
When the protection is disabled, no 
automatic scaling occurs, so the 
Runtime Scaling feature must be 
used to adjust for the highest scaling 
value that does not cause DAC 
overranges.
Since the over-range protection 
works with only three features, this 
key grays out until one of the three 
features is active even when the 
protection is on. 

When the DAC over–range protection is off, 
eliminate over–range conditions by 
decreasing the scaling value (see “Setting 
Waveform Runtime Scaling” on 
pageŚ202).

pageŚ229
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I/Q Modulation
The following factors contribute to the error vector magnitude:

— Differences in amplitude, phase, and delay between the I and Q channels

— DC offsets

The I/Q menu not only enables you to select the I/Q signal source and output, it also provides 
adjustments and calibrations to compensate for differences in the I and Q signals.

See also, “Modulating the Carrier Signal” on page 54.
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Figure 9-15 I/Q Display and Softkeys

These selections are 
reflected in the  
I/Q Routing & 
Optimization graphic.pageŚ213

This panel displays the current 
settings for the I/Q signal routing 
and I/Q correction optimized path.

This panel displays the current status and settings 
of the I/Q adjustments. Use the Page Up and 
Page Down keys to scroll through these 
parameters. Grey indicates an inactive (off) 
adjustment.

Used only with internally generated, bursted modulation 
formats. Enables/disables the RF burst modulator.

For details on each key, use key help 
as described on pageŚ40.

Each path requires different optimization values; 
when you select a path, you are selecting the 
unique optimization values required by that path. 
The signal generator applies the selected 
optimization values to all paths, which impairs the 
unselected paths.

Inverts an internally generated Q signal, so that the I component lags the 
Q component by 90 degrees.

Opens the internal I/Q Equalization Filter which can be used 
to correct and/or impair the RF and External I/Q outputs for 
the internal I/Q source.

Selects between optimizing the internal I/Q channel for EVM (in channel 
performance) at the expense of ACP (out of channel performance) or 
optimizing for ACP at the expense of EVM.
EVM is an 80% nyquist filter (100Mhz wide) with a wide transition band. 
When an equalization filter is active, this filter is not active.
ACP is also an 80% nyquist filter (100Mhz wide), but the transition band 
is very narrow, thus reducing images for wide-band signals. This filter will 
be convolved with the active equalization filter and the Int Channel 
Correction filter (if it is on), the result of which will be truncated to the 
center 256 taps.
SCPI Commands:
[:SOURce]:DM:INTernal:CHANnel:OPTimization EVM|ACP
[:SOURce]:DM:INTernal:CHANnel:OPTimization?

Toggles on or off the application of the internal baseband generator RF, and baseband magnitude and 
phase corrections across the 160MHz baseband bandwidth at the current RF frequency.
When this feature is on, arbitrary frequency switching while the baseband is on will take up to an 
additional 3.3ms (typical) to 6.8ms the first time that frequency is specified. After that, switching to 
that frequency will take up to an additional 1.3ms.
Up to 1024 unique frequencies can be cached before the oldest cache will be forgotten. If a frequency 
sweep is activated, then the calculation and caching will occur up front for the first 1024 unique 
frequencies, and all further unique frequencies will have the characteristics of arbitrary frequency 
switching.
If the I/Q Correction Optimized Path is set to Ext I/Q Output, then only the baseband corrections will be 
applied and the frequency switching speed will be unaffected.
This correction will be convolved with the ACP Internal I/Q Channel Optimization filter and the 
Equalization filter if they are active. The resulting filter will be truncated to 256 taps.
SCPI Commands:
[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe] ON|OFF|1|0
[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe]?

pageŚ214
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I/Q Modulation

Using the Rear Panel I and Q Outputs

In addition to modulating the carrier, the signal generator also routes the internally generated I and 
Q signals to the rear panel I and Q connectors. These output signals are post DAC, so they are in 
analog form. You can use these rear panel I and Q signals to:

— drive a system’s transmitter stage
— test individual analog I and Q components such as an I/Q modulator
— route the I and Q signals into another signal generator

The factory default setting routes the internally generated I and Q signals to the I/Q modulator and 
the rear panel I and Q output connectors. However to optimize (apply calibration factors) the rear 
panel signals, you need to select the external I/Q output path.

Select and Play a Waveform

1. Press Mode > Dual ARB > Select Waveform.
2. Highlight the desired waveform.
3. Press Select Waveform > ARB Off On to On.

Optimize the Signal Path

1. Connect cables from the rear panel I and Q connectors to either a DUT or another signal 
generator.

When you turn the ARB on, the signal generator automatically outputs the I and Q signals to 
the rear panel connectors. You can use the rear panel I and Q signals as I and Q inputs to 
another signal generator. The MXG/EXG has front panel connectors, I Input and Q Input, for 
this purpose.

2. Press I/Q > I/Q Correction Optimized Path > Ext I/Q Output.

When you optimize a path, the path indicator turns green.

The rear panel I and Q connectors only output a signal while using the 
internal BBG.

Factory default setting—RF Output path optimized

Rear panel I/Q path optimized
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I/Q Modulation

Configuring the Front Panel Inputs

The signal generator accepts externally supplied analog I and Q signals through the front panel I 
Input and Q Input. You can use the external signals as the modulating source, or sum the external 
signals with the internal baseband generator signals.

1. Connect I and Q signals to the front panel connectors.

a. Connect an analog I signal to the signal generator’s front panel I Input.

b. Connect an analog Q signal to the signal generator’s front panel Q Input.

2. Set the signal generator to recognize the front panel input signals: 

— To Modulate onto the Carrier

Press I/Q > I/Q Source > External.

— To Sum and Modulate onto the Carrier

Press I/Q > I/Q Source > Sum.

To select and play a waveform for the BB GEN path, see page 154.

Notice that only the internal BBG (BB GEN) routes I and Q signals to the rear panel I and Q 
outputs.

3. If you are using only the external I and Q signals (no summing), turn on the I/Q modulator:  
Press I/Q Off On to On.

4. Configure the RF output:

a. Set the carrier frequency.

b. Set the carrier amplitude.

c. Turn the RF output on.

Signal generator display: both paths are calibrated 
when the I/Q Correction Optimized Path is set to 
Ext I/Q Output (see pageŚ211)

Note: when the optimized path is set to RF, only the 
RF Out path is calibrated.

Signal generator display: both RF paths are calibrated 
when the I/Q Correction Optimized Path is set to 
RF Output (see pageŚ211)
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I/Q Adjustments

I/Q Adjustments
Use the I/Q Adjustments to compensate for or add impairments to the I/Q signal.

I/Q > I/Q Adjustments

Available only when a 
waveform is playing.

Adjusts the I signal amplitude relative to the Q 
signal amplitude. Use this as an internal 
impairment, or to compensate for differences in 
signal path loss that occur due to path irregularities 
in the external I and Q output cabling.

Offsets the phase of the Q signal 
relative to the phase of the I signal. 
The baseband quadrature 
adjustment key is calibrated in units 
of degrees. The external input 
quadrature adjustment is not 
calibrated. 
The function provided by this key is 
not the same as the function 
provided by the I/Q Skew key.

Skew is typically used either to create 
impairments, or to reduce error vectors on large 
bandwidth signals.
Provides a relative time delay correction between 
the I and Q signals. The different signal paths 
traveled by the I and Q signals result in time delay 
differences that show up as an EVM error in large 
bandwidth modulated signals. 
Adding an equal and opposite time delay (skew) in 
the I/Q signals during baseband generation 
eliminates the time delay error, correcting for any 
delays in signals that are generated in the internal 
baseband generator. 

Changes the absolute phase of 
both the I and Q signals with 
respect to triggers and markers. 
Positive values add delay and 
negative values advance the 
signals. This value affects both 
the baseband signal modulated 
onto the RF and the external 
output signals (I and Q). This 
setting cannot be used with 
constant envelope modulation 
and it does not affect external I 
and Q inputs.

Offsets are typically used to either reduce carrier leakage, or to create an impairment that simulates carrier leakage.

Common Mode I/Q Offset Range
This changes the adjustment range of the Common Mode I/Q Offset from Coarse (Default) to fine or vice versa. The Coarse 
range corresponds to the default value of ± 2.5V. The Fine range corresponds to a value of ± 100 mV.
Common Mode I/Q Offset
This adjusts the DC offset of both I and Q signals simultaneously.
Diff Mode I Offset
This adjusts the DC offset level of the I and I–bar output signal. I and I–bar cannot be adjusted independently.
Diff Mode Q Offset
This adjusts the DC offset level of the I and I–bar output signal. I and I–bar cannot be adjusted independently.

The DC offset values are calibrated relative to 
the RMS waveform voltage being played out of 
the ARB. See pageŚ164.

The I/Q Attenuator softkey affects the I/Q signal to the 
RF Output and the External I/Q Outputs.

This softkey is active when the I/Q optimized path is set 
to Ext I/Q Output and a digital modulation personality 
is on. This attenuation is also adjustable using the Mod 
Attenuator key located in the Arb Setup menus in each 
personality. This adjustment is not affected by the I/Q 
Adjustments On/Off key. 

When Auto mode is selected, the signal generator 
automatically optimizes I/Q attenuation for the current 
conditions. When the Manual mode is selected, I/Q 
Attenuation is the active function. The value you enter 
sets the attenuation level of the I/Q signal.

SCPI Commands (Refer to the commands for each 
personality):
[:SOURce]:RADio:<personality>:IQ:MODulation:ATTen

This feature allows adjustment of the absolute phase of the internal I/Q channel by 
rotating both I and Q, thus adjusting the relative phase of the RF carrier. For option 
012, this is the only way to adjust the RF phase for a unit with an external LO.

Note: The I/Q signal will be 
scaled down by 0.7071 for all 
phase offsets except 0. Use 
-360 or +360, if it is desirable 
to maintain a constant power 
level with the ALC off while 
adjusting the I/Q phase.
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The I/Q adjustment, I/Q Delay, is not for adding impairments; its function is to compensate for any 
latency between the EVENT output signals (marker signals) and the RF output.

I/Q Calibration
Use the I/Q calibration for I and Q signal corrections. What aspects of the I and Q signal is corrected 
depends on whether the signal is internally or externally generated.

When you perform an I/Q calibration, that calibration data takes precedence over the 
factory–supplied calibration data. The calibration routines improve performance that may degrade 
over time or due to temperature changes. An I/Q calibration should be run when the ambient 
temperature has varied by at least ±5 degrees Celsius from the ambient temperature at which the 
previous calibration was run.

— The user I/Q calibration is persistent (i.e. Pressing instrument preset or cycling power does not 
remove the user I/Q calibration from memory).

— If the start and stop frequencies are set to the same value, then the calibration will be performed 
exactly at that frequency and the data will be persisted in the bounding calibration array 
elements.

Table 9-2 I/Q Adjustments Uses

I/Q Ad justment Effect Impairment

Offset Carrier feedthrough dc offset

Quadrature Angle
EVM error phase skew

I/Q images I/Q path delay

I/Q Skew EVM error
high sample rate phase 
skew or I/Q path delay

I/Q Gain Balance I/Q amplitude difference I/Q gain ratio

I/Q Phase I/Q phase rotation RF phase adjustment

Correction Internal I and Q External I and Q

Offset X X

Gain Balance X X

Quadrature 
Error

X X
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I/Q Calibration

I/Q > I/Q Calibration

Available only when 
Calibration type = User

DC optimizes the I/Q performance for the current 
instrument settings, and typically completes in several 
seconds. Changing any instrument setting after performing 
a DC calibration voids the DC calibration and causes the 
signal generator to revert to the user calibration data (or 
factory-supplied calibration data, if no user calibration data 
exists)
User provides a quicker calibration when a full calibration 
is not required. You can limit the calibration by specifying 
the calibration start and stop frequencies. 
When you limit the calibration to less than the instrument’s 
full frequency range, the factory−supplied calibration data 
is used for the rest of the range. If the start and stop 
frequencies are set to the same value, then the calibration 
will be performed exactly at that frequency and the data will 
be persisted in the bounding calibration array elements. 
Information is retained through a preset or power cycle*.
Full takes approximately a minute, executing 
measurements over the instrument’s entire frequency 
range. 
Information is retained through a preset or power cycle*.
*Caution: 
To avoid the loss of data, GPIB settings, or current user 
instrument states that have not been permanently saved to 
non-volatile memory, the signal generator should always be 
powered down either via the Instrument’s front panel power 
button or the appropriate SCPI command. Signal 
generators installed in rack systems and powered down 
with the system rack power switch rather than the 
instrument’s front panel switch display an Error -310 due to 
the instrument not being powered down correctly.

Deletes any user–generated 
calibration data and restores 
the factory−supplied 
calibration data.

Note
A DC calibration requires the following settings:
• I/Q: On

• Optimized Path: RF Output

• Source: Internal

For details on each key, use key help 
as described on pageŚ40.
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