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Overview 
The Deltek Open Plan 8.5 Release Notes contain a summary of the following: 

 Pre-Installation Information 

 New Features and Enhancements 

 Database Changes 

 Software Issues Resolved 
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Upgrade from an Earlier Version of Open Plan 
When upgrading from an earlier version of Open Plan, you must install Open Plan 8.5 in a new folder 
rather than attempting to overwrite/upgrade an existing Open Plan installation. Open Plan supports 
concurrent installations with previous versions of Open Plan, provided that: 

 The user has Administrator rights (This is necessary to enable Open Plan to update OLE 
Automation Server registration when different versions are used.) 

 The two versions do not share the same database 

 The two versions are installed to different folders 

If you are using a server and workstation installation, it is necessary to perform a new Workstation 
installation for users that access Open Plan from a shared server installation. The Workstation setup 
application is available in the Workstation Setup folder of the server installation folder. 

 

Attention: For more information about upgrading, see Upgrade from Earlier Versions of Open Plan in 
the Deltek Open Plan Installation Guide. 



Pre-Installation Information 

 3 

 

Pre-Installation Information 
Software Requirements 
The supported minimum software requirements for a complete installation of Deltek Open Plan are listed 
below. 

 

Supported Deployment Technology 

 

Supported Deployment Technology 

Operating System  Windows Server 2012 R2 

 Windows Server 2016 

 Windows Server 2019 

 Windows 8.1  

 Windows 10  

Citrix  XenApp 7.* (Windows Server 2012 R2) 

 XenApp 7.* (Windows Server 2016) 

 Citrix Virtual Apps and Desktop 7 (Windows Server 2019) 

VMWare Horizon  VMWare Horizon 7 

Database Platform Microsoft SQL Server 
 SQL Server 2016 

 SQL Server 2017 (also supported on Linux and Unix) 

 SQL Server 2019 (also supported on Linux and Unix) 

 SQL Server Express 2016 

 SQL Server Express 2017 

 SQL Server Express 2019 

Oracle 
 Oracle 12.2 

 Oracle 18.3 

Attention: For a complete list of the recommended minimum software requirements, see the Deltek 
Product Support Compatibility Matrix document that you can download from the Deltek Customer 
Care Connect site. 

Note: Supported versions are the current actively tested versions of technologies used to deploy 
Open Plan. Except for the Deltek Integrated Products, these technologies are not directly supported 
by Deltek. Changes to these technologies occur at the discretion of the individual technology vendors. 

https://deltek.custhelp.com/app/answers/detail/a_id/38499
https://deltek.custhelp.com/app/answers/detail/a_id/38499
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Supported Deployment Technology 

 Oracle 19.3 

Oracle is supported on Linux, Unix, and Exadata 

Microsoft Access 
 Microsoft Access 2013 

 Microsoft Access 2016 

 Microsoft Access 2019 

Database Driver Open Plan supports Access, Oracle, and SQL Server databases 
through an OLEDB 2.1 compliant provider. The data source providers 
to use for each database type are listed below. 

 Oracle Provider for OLE DB 

 MS SQL Server 2012 Native Client, version 11.4.7001.0 or 
higher 

 MS OLE DB Driver for SQL Server, version 18.2.2.0 or higher 

 Microsoft OLE DB Provider for Jet 

 Microsoft Office 12.0 Access Database Engine OLEDB 
Provider 

 Microsoft Office 15.0 Access Database Engine OLEDB 
Provider 

 Microsoft Office 16.0 Access Database Engine OLEDB 
Provider 

 

Scheduling Tools Microsoft Project Standard 
 Microsoft Project Standard 2013 SP1 (Nov 10, 2015 update) 

 Microsoft Project Standard 2016 

 Microsoft Project Standard 2019 

Microsoft Project Professional 
 Microsoft Project Professional 2013 SP1 (Nov 10, 2015 

update) 

 Microsoft Project Professional 2016 

 Microsoft Project Professional 2019 

Note: The 64-bit version of Open Plan requires the 64-bit version 
of the Microsoft Access Database Engine. 

The 64-bit Microsoft Access Database Engine can be obtained 
from the Microsoft Download Center at the following location: 
https://www.microsoft.com/en-
us/download/details.aspx?id=13255. 

https://www.microsoft.com/en-us/download/details.aspx?id=13255
https://www.microsoft.com/en-us/download/details.aspx?id=13255
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Supported Deployment Technology 

Microsoft Project Server 
 Microsoft Project Server 2013 SP1 (with update applied from 

KB 3115456) 

 Microsoft Project Server 2016 SP1 (with update applied from 
KB 4461598) 

 Microsoft Project Server 2019 

Oracle Primavera 
 Primavera P6 8.4 

 Primavera P6 17.12 

 Primavera P6 18.8 

 Primavera P6 19.2 

Kidasa 
 Kidasa Milestones 2017 

 Kidasa Milestones 2019 

Deltek Integrated Products The versions listed below are the minimum supported versions. 
Subsequent cumulative update (CU) releases within the listed 
major/minor release will be supported unless otherwise noted in the 
Technology No Longer Supported with this Release table. 
Subsequent major/minor releases are not supported. 
Deltek Cobra 

 Cobra 8.2 
 Cobra 8.3 
 Cobra 8.4  

When Cobra 8.4 is released, check Cobra 8.4 Compatibility Matrix. 
Deltek Acumen 

 Acumen 8.5 
 Acumen 8.6 
 Acumen 8.7 

When Acumen 8.7 is released, check Acumen 8.7 Compatibility 
Matrix. 
Deltek PM Compass 

 PM Compass 8.2 
When PM Compass 8.2 is released, check PM Compass 8.2 
Compatibility Matrix. 

 
Deltek wInsight Analytics 

Note: If you are integrating with PM Compass, you must use the 
32-bit version of Open Plan. 
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Supported Deployment Technology 

 wInsight Analytics 8.2 
 wInsight Analytics 8.3  

Embedded Technology  Visual C++ 2013 Redistributable Package (x86) 
 Visual C++ 2017 Redistributable Package (x86) 

.NET Framework  Microsoft .NET Framework 4.5.2 
 Microsoft .NET Framework 4.6 
 Microsoft .NET Framework 4.6.1 
 Microsoft .NET Framework 4.6.2 
 Microsoft .NET Framework 4.7 
 Microsoft .NET Framework 4.7.1 
 Microsoft .NET Framework 4.7.2 
 Microsoft .NET Framework 4.8 

Compatible Deployment Technology  

 

Compatible Deployment Technology 

Database Platform Microsoft SQL Server 
 SQL Server 2014 

 SQL Server Express 2014 

Oracle 
 Oracle 11.2 

Microsoft Access 
 MS Access 2010 

Citrix  XenApp 7.* (Windows Server 2012) 

Scheduling Tool Oracle Primavera 
 P6 15.2 

 P6 16.2 

Kidasa 
 Kidasa Milestones 2015 

Note: Compatible versions are the recent previously supported and tested technologies used to 
deploy Open Plan. These are not actively being tested but are believed to be compatible with Open 
Plan. Deltek does not recommend these technologies for new deployments but will make its best 
effort to answer questions concerning these technologies. These technologies may not be available 
for troubleshooting at Deltek. 
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Custom Programming 
Before you upgrade: 

 Review all existing custom work at least eight weeks prior to your intended go-live date. 

 Compare your custom work to the new functionality being provided in this release. 

 If this new version possesses the functionality contained in your custom work, these custom 
programs may no longer be needed. If the functionality contained in your custom work is not 
provided in this release, you must ensure that the custom work remains intact through the 
upgrade process. 

 Identify any hot fixes or patches that you plan to deploy with your Open Plan upgrade. Ensure 
that, following the hot fix or patch deployment, you retain all custom functionality. 

 Deltek strongly recommends that when upgrading, you first deploy an instance of Open Plan in 
your test environment. This allows for functional UAT (User Acceptance Testing) to ensure that all 
mission-critical custom features are still available to the user community. Typical deployments call 
for a 30 – 45 day test period before upgrading into your production environment. 

 

Running Custom Applications That Use Open Plan Automation 
Custom applications that use Open Plan Automation work with both 32-bit and 64-bit versions of Open 
Plan with the following conditions: 

 A 32-bit custom application first tries to connect to a 32-bit version of Open Plan. If the 32-bit 
version of Open Plan is not available, the application connects to the 64-bit version of Open Plan. 
If both 32-bit and 64-bit versions of Open Plan are installed on the same computer, a 32-bit 
custom application will only work on the 32-bit version of Open Plan.  

 A 64-bit custom application first tries to connect to a 64-bit version of Open Plan. If the 64-bit 
version of Open Plan is not available, the application connects to the 32-bit version of Open 
Plan. If both 32-bit and 64-bit versions of Open Plan are installed on the same computer, a 64-bit 
custom application will only work on the 64-bit version of Open Plan. 

 

Note: The Deltek Technical Services team is available to support you as you plan for this 
upgrade. We offer both technical and custom services, ensuring the best possible Deltek 
experience. If you would like consulting assistance, contact your Deltek account 
representative. 

Note: Deltek recommends that you only install one version of Open Plan on a machine if you plan to 
use custom applications that use Open Plan Automation. 
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New Features and Enhancements 
Set the Level of Resource Assignment Data you want to Include in 
Microsoft Project Import or Export 

Imports 
You can use the Microsoft Project Import Wizard Options page to set the parameters for your Open Plan 
project imports or Open Plan file updates. Use the Assignment Granularity option to specify the time 
period to use to calculate the resource assignment data you want to examine in the import.  

In addition to Daily and Single Period (renamed to Total), the Assignment Granularity drop-down list 
now includes the following options: 

 Weekly: Use this option when you want Open Plan to import weekly time-phased records from 
MSP. 

 Monthly: Use this option when you want Open Plan to import monthly time-phased records from 
MSP.  

Single Period is renamed to Total and is used in cases where resources are applied as totals in MSP 
and not manually time-phased. The generation of OP assignments and baseline usage records from time-
scaled records may cause unacceptable import times for a large project. With this option, Open Plan 
generates one OP assignment for each MSP assignment, using the total level for the assignment and 
spreading it linearly over the owner activity's duration. 

The finer the granularity, the more accurate the data; however, time-phased granularity also increases the 
processing time. If the granularity is too fine, MSP may not be able to generate the data and may even 
display an error.  

 



New Features and Enhancements 

 9 

 

Exports 
You can use the new Assignment Granularity option to control resource assignment granularity and 
time-phased values you want to include in your export.  

The new field is enabled when the following are true: 

 The project is not being exported to Project Server 

 The Export Resources option is selected 

 The MSPRIF Compatibility option is disabled 

When the above conditions are not met, the field is set to Total and disabled. 

The Assignment Granularity drop-down menu is available on the Microsoft Project Export Wizard 
Options page and provides the following time-phased options: 

 Total: Use this option when resources are applied as totals in MSP and not manually time-
phased. The generation of OP assignments from time-phased records may cause unacceptable 
export times for a large project. When you use this option, the total work is spread evenly over the 
task’s duration without regard for offsets and periods. There is no timephasing performed in MSP 
and the export requires much less processing time. 
 
If you manually time-phased in Open Plan and want to maintain that level of granularity in MSP, 
you should select one of the other options. 

 Daily: Use this option when you want Open Plan to generate and export daily time-phased 
records to MSP to model the original records accurately. 

 Weekly: Use this option when you want Open Plan to generate and export weekly time-phased 
records to MSP. 

 Monthly: Use this option when you want Open Plan to generate and export monthly time-phased 
records to MSP. 

Open Plan sets the default granularity to Total. The finer the granularity, the more accurate the data; 
however, time-phased granularity also increases processing time as Open Plan needs to create individual 
time-phased records for each work period. 

Using a coarser granularity (for example, weekly instead of daily) allows the resource assignment export 
to complete successfully and with less processing time even though it may be slightly less accurate (that 
is, the level will spread evenly across a given week and will not show daily fluctuations). 

When timephasing is requested for large projects containing tasks with extended durations (for example, 
when a task duration spans more than a few weeks) and you select a Daily granularity, MSP may fail 
during the process and the integration log might contain an error, for example, “An exception occurred in 
ExportCalendarDetailMSP: No more threads can be created in the system.” If you experience this 
behavior, Deltek recommends using a coarser assignment granularity. 
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Close All Files at the Same Time 
Use the new Close All feature to close all projects, ancillary files, and dialog boxes at the same time 
instead of having to close each one separately.  

To close all open projects, ancillary files, and dialog boxes, click File » Close All. If you have unsaved 
changes, a message prompts you to save your changes. After closing everything, the Open Plan Explorer 
view displays.   
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Time-Phased Reporting by Activity Count and Value 
Open Plan includes time-phased schedule progress charts that you can use to report by activity count or 
values. You can use these charts to view, for example, early/late activity completion curves with actuals 
as well as time-phased task completions vs baseline plan. 

Open Plan includes the following time-phased sample views: 

 TP Completions to report by activity count. Activity counts are charts based on aggregating 
counts of activities on various dates. For example, the number of activities planned to finish by 
Baseline Finish date versus the Actual Finish date.  

 TP Cash Flow to report by activity value. A value chart is the aggregated value of a specified 
field over a date range. 

TP Completions: Reporting by Activity Count  
The chart displays cumulative (s-curve) or period (histogram) data for a project plotted against time and is 
used to track the progress of a project. The data in the charts can count activities over time based on any 
date fields. 

You can view the number of activities that are planned to finish (Baseline) versus the activities that were 
scheduled to finish (Actual/Early/Late Finish) within a certain date period.  

In the example below, there are 21 activities in January planned for completion (Baseline Finish Cum); 
however, only 10 were completed (Actual Finish Cum). The early and late lines represent the range of 
possibilities that the project can expect if it is to be completed on time. 

Having the ability to see these trends allows you to mitigate early on in the project cycle. 

By default this chart filters out summary activities. You can use activity filters to include or exclude 
activities to report on. 
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This reporting also supports the concept of Earned Schedule reporting. The count of baseline finish dates 
represents the BCWS Schedule and the actual finish dates represent the BCWP values. 

 

TP Cash Flow: Reporting by Activity Value  
Use this chart to view, for example, the budget at complete spread between the early start and early 
finish. In addition, you can use user-defined values. You might want to use it to look at cash flow– what 
you are planning to spend versus what you actually spent - at the WBS level or the total project level. You 
could use a user-defined field to view the monthly and cumulative values. 

 

Time-Phased View Options Dialog Box 
Use the Time-Phased View Options dialog box to set the time-phased view parameters. 
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 Options tab — Use this tab to specify whether to display the data by count or value and specify 
how the view displays. 

 
 Counts tab — Use this tab to select the attributes that you want to use when you display the 

activities by count. 
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 Values tab — Use this tab to select the From and To dates and the field to spread across those 
dates. 

 

Project Analysis Barchart View 
The new Project Analysis Barchart view is a hierarchical arrangement of projects with spreadsheet and 
barchart components.  

 
You can include Time Now on the barchart as a solid line for each project. You can also add a line to 
indicate the System Date. Use the Project Barchart Preferences dialog box to specify the Time Now and 
System Date display preferences (right-click on the barchart and click Preferences).  

Right-click on the spreadsheet and select Preferences to display the Spreadsheet Preferences dialog box 
where you can select grouping and color options. The Outlining and Define Link tabs are not available in 
this view. 

 

Note: For more information about this view, see the Open Plan 8.5 online help (Views and Reports » 
Barchart View » Project Analysis Barchart View) 
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Automatically Run Time Analysis for New Activities 
You can now set Open Plan to automatically run Time Analysis when you create new activities. Open 
Plan calculates the dates using a start date of Time Now and adds an activity bar to the Gantt chart.  

You can find this feature on the Project tab of the Options dialog box (File » Preferences » Application). 

 

 

Activity Redundancy Analysis 
A redundant link occurs when, in addition to the link in question, there is a more detailed logic link 
between the same two activities. For example, a link from Activity A to Activity C is made redundant by an 
existing link from Activity A to Activity B and another one from Activity B to Activity C. 

 
The new Redundancy Analysis feature in Open Plan checks the entire schedule and sets a flag on 
relationships that are redundant. After you run the process, Open Plan displays the Relationship 
Spreadsheet view where the new Redundant Flag column indicates the redundant relationships. If 
needed, you can filter on this flag.  

You can right-click in the view and select Redundant Logic to display the Redundant Logic dialog box. 
The top grid includes the redundant relationship that was identified by the analysis and the bottom grid 
includes the relationships that make that relationship redundant. Click Delete to delete the relationship. 
You cannot edit or change relationships in this grid. 

Select to automatically 
run time analysis for 

new activities. 

Note: For steps, see Automatically Run Time Analysis for New Activities in the Open Plan online help 
(Working with Projects » Project Analysis » Time Analysis » Related Procedures). 
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To run the analysis, navigate to the Processes tab and click Redundancy Analysis in the Tools menu 
group. 

Set the Default Duration for New Activities  
You can now specify a default activity duration at the system and/or project level.  

Set the Default Activity Duration at the System Level 
Set the default activity duration at the system level so that all new projects default to this value. You can 
enter a number in the Default Duration field on the Options dialog box Project tab with or without a unit 
(for example 1w for 1 week). If you don’t include a unit, Open Plan assumes that the unit is Days.  

Open Plan populates the Default Activity Duration field on the Project Properties Preferences tab with 
this value when you create a new project.  
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Set the Default Activity Duration at the Project Level 
Although you can set the default activity duration at the system level, this is for new projects. There may 
be times when you need to change it for a specific project.  

You can specify the default activity duration for an existing project in the Default Activity Duration field 
on the Project Properties Preferences tab. For a new project, you can change the default activity duration 
in the Default Activity Duration field on the New File Wizard – Preferences page. 

The Default Activity Duration fields in Project Properties and the New File Wizard initially get their value 
from the Default Duration field on the Options dialog box; however, when you overwrite the value, all 
activities created after the value is changed default to the new value. You can enter a number with a unit 
(for example 1w for 1 week) or you can enter a number without a unit. If you don’t include a unit, Open 
Plan assumes that the unit is Days. 

Project Properties 

 

The default activity 
duration is applied to 

all new projects. 
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New File Wizard 

 

Move Activities From One External Subproject to Another 
Open Plan now allows you to move activities from one external subproject to another, or from an external 
project to a master project. You typically need to do this when activities have changed or you have 
additional planners and need to split up the work. Moving activities maintains relationships from the 
activities you move to other activities. 

You can move activities when all of the following are true: 

 The activity table is the driving table for the view. 

 The master project contains one or more open external subprojects. 

 The master project and its external subprojects are open in Exclusive mode or you (the current 
user) have used a shared-mode lock. 

In the Spreadsheet view, select the activities that you want to move, right-click, and select Move 
Activities… on the context menu. 



New Features and Enhancements 

 19 

 

 
The Target External Subproject group on the left displays the master project and a hierarchical list of 
open external subprojects. Open Plan excludes the source external subproject(s) or master project for the 
selected activities from this list.  

 
After you select a project, the Target Parent Activity group on the right displays the subprojects activities 
within the selected external subproject, excluding any projects/activities that are parents of the source 
activities.  

You can either select the subproject under which you want to move the activities or select <None> to 
move and place the activities as the topmost children of the selected project on the left. 

When you select Move Baseline Activities and Usage Open Plan copies the baseline activities and 
usage records when their corresponding activities are moved. Open Plan does not delete the previous 
baseline activity records as those records are vital to preserving baseline history.  That baseline activity 
record displays with an Activity ID value of "ID Unavailable" since the original activity to which it points no 
longer exists.  Similarly, baseline usage records related to the old baseline activity record are not deleted 
(and are in fact still valid since the old baseline activity record has not been deleted).  In the baseline 
usage spreadsheet, Open Plan displays the baseline usage records that point to the old name of the 
baseline activity ID as well as the new (copied) baseline usage records that point to the new (moved) 
baseline activity record.   

Select to move 
activities to a 

different subproject. 

Copy the baseline 
activities and 
usage records 

Subprojects within 
the selected 

external subproject 

Hierarchical list 
of open external 

subprojects 
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The Move Baseline Activities and Usage option is enabled when you have update baseline rights and 
there are baselines available on the project.  

If you want to remove the old baseline records, update the baseline choosing the option to Delete All 
Activities No Longer in Current Project. 

Create and Update Activity Steps in a Spreadsheet View  
Open Plan now allows you to create, edit, delete, copy and paste activity steps into a Spreadsheet View 
of a project provided that the required key fields (such as Activity ID and Name) exist. This enhancement 
allows you to update steps to an existing project that has a large number of activities with multiple steps 
efficiently. In the previous version, Activity Steps in a Spreadsheet View were read-only. 

Moreover, the displayed details in the Spreadsheet View and in the grid on the Steps tab of both the 
Activity Details and Activity Progress dialog boxes are in sync with one another other.  

 
 When you select an activity in the spreadsheet, the steps associated with that activity display in 

the grid. Selecting another activity in the spreadsheet updates the displayed steps in the grid 
accordingly.  

 When you update an activity step in the spreadsheet, the displayed data in the grid also updates, 
and vice versa. For example, adding a step in the spreadsheet also adds the step in the grid or 
updating the % Complete value and applying the change in the grid also updates its 
corresponding column in the spreadsheet. 

 

Resizable Dialog Boxes 
The following Open Plan dialog boxes are now resizable: 

 Conditional Formatting dialog box: On the View tab, click Conditional Formatting in the 
Table menu group in spreadsheet view or click Conditional Formatting in the Network menu 
group in network view.  

 Title Blocks dialog box: On the View tab, click Title Blocks in the Printing menu group. 

 Histogram Preferences dialog box: On the View tab, click Preferences in the Histogram menu 
group in barchart view or click Preferences in the General menu group in histogram view.  

Note: When copying an existing step, the pasted step uses the original activity name plus an 
underscore (_) and a three-digit number appended to it. For example, copying Activity Step 2 adds 
Activity Step 2_001. 
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 Time-Phased View Options dialog box: When you are in the Time-Phased Completions or Cash Flow view, right-click in 
the view and click Preferences. 

A grabber pad in the bottom right corner of a dialog box indicates that the dialog box is resizable. Click 
and drag the sides of the dialog box to resize.  

 

 

GoTo Enhancement 
The GoTo option now allows you to display an activity that is hidden from a view by a filter. Previously, 
this option only worked for activities that were not filtered out.  

For more information and steps, see Display a Filtered Activity in a View in the Open Plan online help. 

 

Grouping Hierarchical Structure Enhancements  
Open Plan has always supported grouping (sub-sectioning) by codes. Version 8.5 includes the following 
enhancements relating to grouping on hierarchical structures: 

When you assign a hierarchy code file on the Spreadsheet Preferences Grouping tab with Break Level = 
0, Open Plan now automatically indents the hierarchy structure in the spreadsheet and color codes the 
levels as follows:  

Click GoTo to add a 
filtered activity to 

the view.  
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 Levels 1 through 5 = Blue 

 Levels 6 through 10 = Green 

 Levels 11 through 15 = Gold 

 Levels 16 through 20 = Purple 

The colors repeat after level 20.  

A view can include up to 40 indented levels in a hierarchy. 

The advantage of doing it this way is that you don’t have to manually enter each level of the hierarchy into 
the Grouping tab grid. When you use Break Level = 0, Open Plan automatically aligns and colors each 
level in the view. 

Although you cannot select colors when you use Break Level = 0, you can still manually select colors 
when you use any other Break Level. 

  

  

Renamed Tabs and Options 
On the Spreadsheet Preferences dialog box: 

 The Subsections tab is renamed to Grouping tab. 
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 The Enable Subsection radio button on the Options tab is renamed to Enable Grouping. 

 The Disable Subsection and Outlining radio button on the Options tab is renamed to Disable 
Grouping and Outlining. 

 The Show Summary Bars when there are no Subsection Summary Rows option on the 
Subsection tab (now Grouping tab) is renamed to Show Summary Bars when there are no 
Grouping Summary Rows.  

 

Delete Projects Using Internal or Multi-Instance Batch 
Over time, in a large user environment, the list of projects can grow very large. Users might create several 
copies of their projects (What Ifs, Month End Copies, SRAs, etc.) that do not need to be retained long-
term. It can be very time-consuming for Administrators to manual delete these projects and can also open 
up the possibility of unintentionally deleting an in-use project. 

Open Plan now allows you to delete projects using internal or multi-instance batches. 

DROPPROJECT 
Syntax: DROPPROJECT [ProjectName] [ProjectName…] 

Description: This command deletes one or more projects. Ancillary files are not affected. If multiple 
projects are referenced and an error occurs, the process is aborted and the remaining projects are not 
deleted.  

Valid Parameters are: 
ProjectName – Name of project to delete, for example, CLEAN. 

Example: 
DROPPROJECT CLEAN CONSTR MOVIE SHIP 

 
Note: The above information is also located in the Open Plan Batch Processor Guide. 
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IPMDR Renamed to IPMDAR 
The Department of Defense contractor reporting format IPMDR is renamed to Integrated Program 
Management Data Analysis Report (IPMDAR).  

Expand and Collapse (+/-) Indicator Color Enhancement 
Previously, when you changed the background color of the row and column headers to a dark color in 
Spreadsheet Preferences, the expand and collapse indicators (+/-) became almost invisible.  

The expand and collapse indicators now use the font color that is assigned to the spreadsheet heading 
text. 

 

Performance Improvements 

Large Multi-Project Notes 
Performance has been improved when backing up multi-projects that include a large number of notes.  

Upgrade Scripts Unicode Setting 
The default setting in the upgrade scripts has changed to enable the Unicode option by default. 

 

  

Indicators use the 
spreadsheet heading 

font color  

Note: For more information about upgrading, see Upgrade from Earlier Versions of Open Plan in the 
Deltek Open Plan Installation Guide. 
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Ability to Not Concatenate the Control Account ID and Work 
Package ID When Exporting an IPMDAR File 
A new System Preferences option called USEUNIQUEWPCOSTDATAPROCESS allows you to enable or 
disable concatenation of Control Account key fields and the Work Package ID when creating an 
Integrated Program Management Data and Analysis Report (IPMDAR) file during the Schedule Data 
Export process. 

 If USEUNIQUEWPCOSTDATAPROCESS is not present or is set to 0, Open Plan performs 
concatenation of CA ID and the WP ID when exporting to IPMDAR format. This is the default 
value. 

Example: WorkPackageID: "1.1.1.2 / 1420 / 01" 

  If USEUNIQUEWPCOSTDATAPROCESS is set to 1, Open Plan does not perform concatenation 
of CA ID and the WP ID when exporting to IPMDAR format. 

Example: WorkPackageID: "01" 

Ability to Use a Local Folder for Creating or Restoring a Backup 
File 
A new User Preference option called UseLocalFileForBackup allows you to enable or disable the use of 
a local folder in creating or restoring a backup file. 

 If UseLocalFileForBackup is set to 0, Open Plan creates a backup file in the original location 
that you have specified and reads the backup file directly from the original location when 
restoring. This is the default value. 

 If UseLocalFileForBackup is set to 1: 

 For backup, if Open Plan determines that the original target folder is on a network drive, it 
creates the backup file first on your local drive. Then, it copies the backup file to the target 
location, replacing the existing backup file (if applicable) with the newly created file. 

 For restore, if Open Plan determines that the original folder containing the backup is on a 
network drive, it copies the file from the network drive and saves it into a temporary folder on 
your local drive, where it reads that file. 
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Sources for Critical Path and Driving Path Fields 
You can now select the sources for Critical Path Field and Driving Path Field on the IPMDAR 
Configure Activity Fields dialog box. These fields are mapped to specific files or user-defined fields 
(UDFs) that contain the appropriate information for each Activity ID.  

 

 

           

Note: The options for these two new fields include numeric UDFs (whose value is 0 or 1), text UDFs 
(whose value is true, 1, 0, or false), and filters. For Critical Path Field, it also accepts the following 
values: Critical, Not Critical, Controlling Critical, and Most Critical. 

You cannot leave Critical 
Path Field blank. It displays 

Critical Flag by default. 

 

Driving Path Field is 
optional. It displays 
<None> by default. 
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Software Issues Resolved 
Add-Ins » Resource Management Wallchart 

Defect 1373740 
Description: When you opened the Resource Management Wall Chart add-in tool from any 
barchart views for a project, the default dates on the Wall Chart Options dialog box would always 
be in the US format (M-D-Y) regardless of the default date format set in the computer you were 
using (for example, D-M-Y). 

Customers Impacted: Open Plan customers who were not using the D-M-Y format by default. 

Workaround Before Fix: Enter dates in D-M-Y format. 

Edit » Activity Progress 
Defect 1326897 
Description: When the system preference AllowEditPPC was set to 1 (enabled) and the EVT 
type was not Steps, you could not edit the Activity Physical % Complete field on the Resources 
tab of the Progress dialog box. 

Customers Impacted: Open Plan customers editing Activity Physical % Complete. 

Workaround Before Fix: None. 

 

Defect 1280067 

Description: When activities using certain EVT types had Actual Finish date that was equal to 
or later than Time Now, Open Plan would set the activity PPC column to 0 instead of 100% even 
after you ran Time Analysis with the Observe Actual Future Dates option selected. 
Customers Impacted: Open Plan customers using the Observe Actual Future 
Dates option. 
Workaround Before Fix: Set the system preference AllowEditPPC to 1 and then set the PPC 
values to 100% manually. 

 
Defect 463319 
Description: When you entered an Actual Finish date on the Activity Progress dialog box, 
pressing Tab on your keyboard would select the Complete option. Pressing Enter or clicking any 
other fields would clear the selected option.  

Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None. 
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File » Backup - Restore 
Defect 1348826 
Description: When the project you were trying to back up contained invalid baseline dates, the 
backup process failed. 

Customers Impacted: Open Plan customers backing up a project with invalid dates. 

Workaround Before Fix: Correct the invalid dates. 

 

Defect 1226190 

Description: When you restored a .bk3 file where Activity Description length was longer than 
the database maximum limit for that field, Open Plan did not populate the Activity 
Description field. 

Customers Impacted: All Open Plan customers with Activity Description longer than the 
database maximum field limit.  

Workaround Before Fix: None. 

Edit » Cut – Copy - Paste 
Defect 1145587 
Description: When you copied a number of rows from a tool outside of Open Plan and tried to 
paste them, Open Plan pasted all rows except for the last one. For example, when you copied 
rows 01 through 03, it only pasted rows 01 and 02. 

Customers Impacted: All Open Plan customers. 

Workaround Before Fix: Copy and paste an extra row. 

Edit » Resource Details 
Defect 1285793 
Description: When you selected a project for which a resource would be reserved on the 
Resource Details dialog box, saved the change, and opened the dialog box again, Open Plan did 
not save the selected project. 

Customers Impacted: Open Plan customers reserving a resource for a project. 
 
Workaround Before Fix: None. 
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File » Import – Export » MS Project 
Defect 1324809 
Description: When you imported a file that contained hours per day, hours per week, or days per 
month with fractional values from Microsoft Project (MS Project), Open Plan did not import the 
values correctly. For example, 7.5 hours per day displayed as 8.0 hours instead of 7 hours 30 
minutes. 

Customers Impacted: Open Plan users importing file containing work unit with fractional values 
from MS Project. 

Workaround Before Fix: After import, change the default units manually on the Project 
Properties dialog box. 

 
Defect 1368174 

Description: When you exported a project that contained hours per day with minutes value 
greater than 0, (for example 7 hrs 30 mins), Open Plan did not export the time units to MS Project 
correctly. 

Customers Impacted: Open Plan customers exporting projects with partial time units to MS 
Project. 

Workaround Before Fix: After export, adjust time units manually in MS Project following export. 

 

Defect 1255088 
Description: When you imported a file from MS Project, Open Plan did not import calendar 
exceptions, such as holidays and extra work days. 

Customers Impacted: Open Plan customers importing files from MS Project. 

Workaround Before Fix: None. 

File » Manage Files » Owner and Access Rights 
Defect 1243805 
Description: When you reassigned or changed the owner of all objects using the Change 
Owner option on the Change Ownership and Access Rights dialog box, Open Plan did not 
immediately reflect the change in ownership for the Batch Global Edits, Filters, Global Edits, and 
Sorts objects to the new owner.   

Customers Impacted: Open Plan customers reassigning or changing the owner of objects using 
the Change Owner button on the Ownership and Access rights dialog box. 

Workaround Before Fix: Take the following actions: 

1. Exit Open Plan, and log on again. 

2. Access the Change Access Rights dialog box to see the changes were made. 
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File » Preferences 
Defect 1321956 
Description: When you tried to add a logo on the Symbols dialog box, you encountered an error 
message. 

Customers Impacted: Open Plan customers adding logos. 
Workaround Before Fix: None. 

File » Shared Mode 
Defect 1335765 
Description: When you opened a master project in Shared mode, and another user has one of 
the external subprojects opened shared and locked, you might encounter several issues, such as 
the following: 

 Still allowed to edit activities, assignments, relationships, steps, and related details that 
belonged to the locked subproject. . 

 Not get a notification when User2 made changes to and unlocked the project. 

 Unable to view all changes that User2 made during the lock following a refresh. 

Customers Impacted: Open Plan customers opening projects in Shared mode. 

Workaround Before Fix: None. 

 

Defect 1375136 

Description: When you opened a project in Shared mode and deleted an activity or other related 
record, the LASTUPDATE field did not change. 

Customers Impacted: Open Plan customers working on a project in Shared mode. 

Workaround Before Fix: Close the project and open it again. 

Project » Multi-Project 
Defect 1235003 
Description: When you opened a project, sometimes Open Plan would report that it could not 
resolve field. You would see  the error, which was related to fields that could not be resolved, in 
the opwin.log. 

Customers Impacted: All Open Plan customers. 
 
Workaround Before Fix: None. 

Project » Resource Scheduling 
Defect 427754 
Description: When you tried to run Resource Scheduling, Open Plan crashed unexpectedly.  

Customers Impacted: Open Plan customers running Resource Scheduling.   

Workaround Before Fix: None. 
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Defect 866397 
Description: After you ran Resource Scheduling, the Used value did not match the Level value 
on the Activity Resource Allocation dialog box. 

Customers Impacted:  Open Plan customers running Resource Scheduling. 

Workaround Before Fix: None. 

 
Defect 1169214 
Description: When you assigned a resource to an activity and then ran resource-limited 
Resource Scheduling with the Hard Zeros option selected, Open Plan still scheduled an activity 
for a period when the resource was not available.  

Customers Impacted: Open Plan customers running resource-limited Resource Scheduling 
with Hard Zeros selected. 
 
Workaround Before Fix: None. 

 
Defect 1169735 
Description: When you ran a resource-limited Resource Scheduling and the resource assigned 
was based on Skills, Open Plan displayed incorrect schedule dates. 

Customers Impacted: Open Plan users running Resource Scheduling with skills. 

Workaround Before Fix: None. 

Project » Schedule Driver Analysis 
Defect 845348 
Description: When the role assigned to you had the Time Analysis item set to disabled in EPM 
Security Administrator (EPM SA) and you ran Schedule Driver Analysis, Open Plan would display 
incorrect results.  

Customers Impacted: Open Plan customers running Schedule Driver Analysis and whose role 
has Time Analysis disabled in EPM SA.  

Workaround Before Fix: In EPM SA, enable Processes » Time Analysis on the Open Plan 
Professional tab of the Roles Details form. 

 

Defect 1224691 
Description: When you ran Schedule Driver Analysis before Time Analysis on a large 
project, Open Plan took a long time to complete the Schedule Driver Analysis process.  

Customers Impacted: Open Plan customers running Schedule Driver Analysis on large projects. 

Workaround Before Fix: Run Time Analysis first before Schedule Driver Analysis. 

  



Software Issues Resolved 

 32 

 

Project » Time Analysis 
Defect 1262836 
Description: When the role assigned to you had the Time Analysis item set to disabled in EPM 
SA, Open Plan still allowed you to select the Time Analysis option on the Risk Analysis and Cost 
Calculation dialog boxes. 

Customers Impacted: Open Plan customers whose role has Time Analysis disabled in EPM 
SA. 
Workaround Before Fix: None. 
Additional Notes: When you try to run other processes with Time Analysis selected, an error 
message displays in the log file. 

Tools » Calculated Fields 
Defect 339797 
Description: When you rounded negative numbers, Open Plan displayed incorrect results. For 
example, it rounded -4.3 to -3 instead of -4. 

Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None. 

Views  
Defect 1283880 
Description: When you right-click a relationship in the relationship spreadsheet, the Edit 
Relationship option did not display on the context menu. 

Customers Impacted: Open Plan customers editing relationships. 
 
Workaround Before Fix: None. 

Views » Barchart View » Bar Sets 
Defect 372811 
Description: When you tried to open a project using a view with a custom bar set, you 
encountered an error message. 

Customers Impacted: Open Plan customers opening a project using a view with a custom bar 
set.  

Workaround Before Fix: None. 

Views » Barchart View 
Defect 1341489 
Description: When you clicked a cell in the spreadsheet part of a Barchart view while the Steps 
tab on the Activity Progress dialog box was active, Open Plan could not set the focus on the 
selected cell. 

Customers Impacted: Open Plan customers using the Steps tab on the Activity Progress dialog 
box in a Barchart view. 

Workaround Before Fix: None. 
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Views » Code Views 
Defect 1343716 
Description: When you opened a code spreadsheet, the child rows used the default font, 
foreground, and background colors specified for outline rows. 

Customers Impacted: All Open Plan customers. 

Workaround Before Fix: Use conditional formatting to override the font and color settings for 
child rows. 

View » Conditional Formatting 
Defect 1198093 
Description: When the role assigned to you had the Conditional Formatting item set to 
disabled in EPM SA, you could still view and select the Conditional Formatting option in Open 
Plan. 

Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None. 

Views » Histogram View 
Defect 987132 
Description: When you applied a filter to a project in a Histogram view (HISTVW), the Status bar 
displayed <no filter> instead of the applied filter. 

Customers Impacted: Open Plan customers using filter for a project in a Histogram view. 

Workaround Before Fix: None. 

Views » Spreadsheet View 
Defect 1279210 
Description: When an activity had Actual Finish date on the Activity Progress dialog box, you 
could still modify the Physical % Complete column in a spreadsheet view. 

Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None. 
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Database Changes  
This section includes the changes made to the database for this release. 

Tables 

New Tables 

Table Name Description 

None  

Modified Tables 

Table Name Description 

None  

Removed Tables 

Table Name 

None 

Columns 

New Columns in Existing Tables 

Table Name Column Name Data Type Description 

OPP_PRJ ESDATE DATE The early start date for a project. 

OPP_PRJ DEFACTDUR DURATION The default duration assigned to a new 
activity in a project 

OPP_PRJ LSDATE DATE The late start date for a project. 

OPP_PRJ SSDATE DATE The schedule start date for a project. 

Changes to Existing Columns 

Table Name Column Name Notes 

None   
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Removed Columns  

Table Name Column Name Data Type 

None   

Objects 
This section includes changes to functions, stored procedures, views, indexes, and objects.  

New Objects 

Object Name Object Type 

None  

Modified Objects 

Object Name Object Type 

None  

Deleted Objects 

Object Name Object Type 

None  

Data 
This section includes changes to data applied by scripts. 

Data Change 

None 



Appendix A: For Additional Information 

 36 

 

Appendix A: For Additional Information 
Deltek Support Center 
The Deltek Support Center is a support Web site for Deltek customers who purchase an Ongoing Support 
Plan (OSP).  

The following are some of the many options that the Deltek Support Center provides: 
 Search for product documentation, such as release notes, install guides, technical information, 

online help topics, and white papers 

 Ask questions, exchange ideas, and share knowledge with other Deltek customers through the 
Deltek Support Center Community 

 Access Cloud-specific documents and forums 

 Download the latest versions of your Deltek products 

 Search Deltek’s knowledge base 

 Submit a support case and check on its progress 

 Transfer requested files to a Customer Care analyst 

 Subscribe to Deltek communications about your products and services 

 Receive alerts of new Deltek releases and hot fixes 

 Initiate a Chat to submit a question to a Customer Care analyst online 

 

Access Deltek Support Center 
To access the Deltek Support Center:  

1. Go to https://deltek.custhelp.com. 

2. Enter your Deltek Support Center Username and Password. 

3. Click Login. 

 

Attention: For more information regarding Deltek Support Center, refer to the online help available 
from the Web site. 

Note: If you forget your username or password, you can click the Need Help? button on the login 
screen for help. 

https://deltek.custhelp.com/
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Available Documentation for this Release 
The following table lists the Deltek documentation available for this release. Except where noted, all the 
user guides and quick reference guides listed in this table are available for download from the Deltek 
Support Center. 

Document Name Description 

Deltek Open Plan Batch Processor Guide This document contains information about running 
the Open Plan multi-instance batch processor. 

Deltek Open Plan Developer’s Guide This document is meant to serve as a reference 
manual for more technical topics in Open Plan. 

Deltek Open Plan Guided Tour This document introduces you to the basic Open 
Plan operations using sample project data that 
comes with your installation. 

Deltek Open Plan Installation Guide This document is meant to serve as a guideline for 
hardware and software requirements and provide 
your firm’s IT department with information about 
the technical deployment architecture. 

Deltek Open Plan Milestone Professional 
Interface Add-In Module 

This document is meant to serve as a guideline for 
using the Milestones Link tool. 

Deltek Open Plan Technical Overview and 
System Requirements 

This document is meant to serve as a guideline for 
hardware and software requirements and provide 
your firm’s IT department with information about 
the technical deployment architecture. 

 

 



 

 

About Deltek 
Better software means better projects. Deltek delivers software and information solutions that enable 
superior levels of project intelligence, management and collaboration. Our industry-focused expertise 
makes your projects successful and helps you achieve performance that maximizes productivity and 
revenue. www.deltek.com 
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