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• CodeWarrior Development Studio 

− Features, Suites, Pricing, Downloads, Upgrade Policy 

• Basic Processor Expert Concepts & Terms 

• Lab 1: FRDM-KL46Z Board Project 

− Create a new project with the New Project Wizard 

− Import existing components and files 

− Build the project 

− Test the application’s functionality 
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• CodeWarrior Development Studio for Microcontrollers v10.4 
integrates the development tools for ColdFire, ColdFire+, DSC, 
Kinetis L Series, Kinetis K Series, Qorivva, PX Series, RS08, S08 and 
S12Z architectures into a single product based on the Eclipse open 
development platform. 
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• Special Edition – Available at no charge and allows projects to be 

developed with code size limitations 

• New Project Wizard – Allows a project to be created in as few as six 

clicks 

• LiveView – Allows registers, memory and global variables to be 

monitored without stopping the processor 

• Processor Expert – Creates tested, optimized initialization code and 

low-level drivers tuned to application needs and selected Freescale 

derivative 

− Built-in knowledge base immediately flags resource conflicts and incorrect 

settings, so errors are caught early in design cycle  

− Processor Expert for ColdFire+ and Kinetis works with and extends the 

capabilities of MQX 

• Trace and Profile support for on-chip trace buffer – provides 

sophisticated emulator-like debug capability without additional trace 

capture hardware 
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Special Editions 

Standard Suite 

Professional Suite 

$2495 
TS-$495 

$4995 
TS-$995 

Basic Suite 

$995 
TS-$195 

FREE 

$995 

$1995 

$395 

Perpetual 
Includes perpetual use of product suite, 

plus technical support and maintenance 

for 12 months 
Additional years of technical support indicated 

by “TS” 

 

Annual Subscription 
Includes use of product suite, plus 

technical support and maintenance,  

for 12 months 
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Special Edition Basic Edition Standard Edition Professional 

Edition 

Key Features 

Unlimited Project Files X X X X 

Unlimited Assembler X X X X 

Processor Expert Software X X X X 

Component Development Environment Non-commercial Non-commercial Non-commercial Commercial 

Task Aware Debug X 

C++ X 

Licensing:  Annual or Permanent X X X 

1 Year Support X X X 

Code/Debug Size Limits 

RS08, S08 64K 128K None None 

S12Z 64K 128K None None 

Coldfire V1, Coldfire+ 64K 128K None None 

Coldfire V2-V4 128K 512K None None 

DSC 64K 256K None None 

Kinetis L 64K 128K None None 

Kinetis K 128K 512K None None 

Qorrivva, PX 512K 1M None None 

Pricing 

Pricing: Annual License/Support Free $395 $995 $1995 

Pricing: Permanent License Free $995 $2495 $4995 

Pricing: Annual Support Permanent License Free $195 $495 $995 
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Annual Subscription License 

• If you have an active annual subscription license, you can download CodeWarrior MCU 

v10.4 at no cost 

• If your annual subscription license has expired, you must purchase another license 

before downloading CodeWarrior MCU v10.4 

− Basic Suite: $395 

− Standard Suite: $995 

− Professional Suite: $1,995 

Perpetual License 

• If you purchased a perpetual license within the last 12 months, you can download 

CodeWarrior MCU v10.4 at no cost 

• If you have an active technical support agreement (after the first 12 months), you can 

download CodeWarrior  MCU v10.4 at no cost 

• If your technical support agreement has expired, you must purchase another technical 

support agreement before downloading CodeWarrior  MCU v10.4 

− Basic Suite: $195 

− Standard Suite: $495 

− Professional Suite: $995 

Valid technical support agreement equals 

NO cost to upgrade 
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A new license is required for CW MCU v10.4. Licenses for previous 

versions will NOT work.  

• New purchase: If you just purchased a CodeWarrior Suite, the process to activate and 

license your product is simple: 

− Log in to “My Freescale”  

− Select “ CodeWarrior Licensing”  

− Navigate to your product in “Products you are entitled to license” 

− Click the “Get License” button to retrieve your license 

• Existing customer: If you already own a CodeWarrior suite and have obtained 

previous versions of CodeWarrior for Microcontrollers (e.g., 10.0, 10.1, 10.2 or 10.3), 

the process is a little different: 

− Log in to “My Freescale”  

− Select “ CodeWarrior Licensing”  

− Navigate to your product in “Products that you have licensed” 

− Click the “Version Renewal” button next to your existing CodeWarrior for Microcontrollers product 

to retrieve your license 
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Processor Expert Software is a development system to create, 

configure, optimize, migrate, and deliver software components that 

generate source code for Freescale silicon.  

• Features 

− Extensive and comprehensive knowledgebase for all supported silicon encapsulating 

all pins, registers, etc.  

− Silicon resource conflicts flagged at design time, allowing early correction  

− Simple creation of optimized peripheral drivers without reading silicon documentation  

− Easy integration of an RTOS with peripheral drivers using RTOS adaptor component  

− Enables straightforward migration to new hardware  

− Can configure, package, and deliver components to your team  

− Available as part of the CodeWarrior tool suite or as an Eclipse-based plug-in feature 

for installation into an independent Eclipse environment. 

− Support for CodeWarrior, IAR, Keil and gcc build environments (Red Suite) 
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• Embedded Components encapsulate the functionality of basic elements of 

embedded systems.  

− CPU core  

− CPU on-chip peripherals  

− Standalone peripherals 

− Virtual devices 

− Software – an RTOS, a library (e.g. FSL’s touch sensing library)  

• Processor components include support for the following architectures 

− ColdFire/ColdFire+ 

− 56800/E (DSC) 

− Kinetis 

− RS08/S08 

− S12Z 
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Processor Expert Project       Design Timeline 

Create Project 

• Create a new project 
with Processor Expert 

Add Components 
• Select components required 

in the project from 
Components Library 

Configure Components 

• Use Inspector to set all 
component settings 

Verify Settings 
• Make sure there are no 

design-time errors in the 
project 

Generate Code 

• Let Processor Expert 
generate all components 
drivers code 

Write Code 
• Write application code using 

code generated for 
components 

Build and Debug 
• Build the application common way 

• Debug the application with 
CodeWarriror 
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Components Library 

Component 

Inspector 
Projects View 

Problems View 

Components 

View 
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Component 

Inspector 

Problems View 

Processor View 

Configuration 

Registers View 
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• Available components are displayed in 

Components Library 

• Select appropriate TAB to change how 

components are organized and displayed  

− Categories 

− Alphabetical 

− Assistant 

− Processors 

• Select filter to toggle displayed components 

− Show only components available for selected  

processor. 

−  Show all components available . 
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Properties 

Recently 

changed items 

are highlighted 

Property Value 

Details 

Select level of  

information 

displayed 
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• Properties define design-time 

settings 

• Code is generated based on the 

property settings 

• Recently changed properties are 

highlighted 

• Properties that are undefined will be 

displayed in red text 

• Properties with resource conflicts 

will be displayed in red text and 

tagged with an exclamation mark. 

• Errors will be displayed in the 

Problems View and must be 

resolved before code can be 

generated. 

 

 



18 TM 

• Select the Methods TAB  

• Select “generate code” for each 
function required in the 
application 

• Code will only be generated for 
the functions selected 

 

 

 

 

 

 

• To enable code generation for a 
method in the Components 
View, right-click on the method.  

• Select “Toggle Enable/Disable” 

Change Tab 

to see 

Methods 

Select “generate 

code” for each 

function needed in 

application 
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• Select the Events TAB  

• Select “generate code” for each 

event required in the application 

• Code will only be generated for 

the events selected 

 

 

 

 

 

 

• To enable code generation for 

an event in the Components 

View, right-click on the event.  

• Select “Toggle Enable/Disable” 

 

 

Change Tab 

to see 

Events 

Select “generate 

code” for each event 

needed in application 
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Operating Systems 
Configurations 

Processors Components 

Methods 

Generate Code  
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• To generate code  

− Select Generate Code icon in the 

Components View 

• To turn off code generation for a 

component 

− Right-click on component 

− Select Code Generation 

− Select Don’t write Generated 

Component Modules 
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• Board Support  

− Configuration file (template) including 

 CPU component  
 One or more pre-configured peripheral components 

• CPU External Devices  

− Embedded Component support for Console I/O, 
LED displays, etc. 

• CPU Internal Peripherals (High level) 

− Embedded Component support for internal 
peripherals 

− Standard API ensures generated code is 
portable 

− Generates initialization code and low level device 
drivers. 

• Peripheral Initialization  

− Hardware specific support, which is not portable  

− Generates initialization code only 
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• Logical Device Drivers  

− Embedded Component support for internal 
peripherals 

− Uses a standard API, which allows generated 
device drivers to be adapted for used with bare-
metal applications as well as RTOS 
applications. 

• Operating Systems  

− RTOS adapter components 

− Adapter defines the RTOS API 

 How memory is allocated 
 How a critical section is created 
 How interrupt vectors are allocated 

− Generated device drivers are adapted to work 
with the RTOS API 

• Software  

− Encapsulate software algorithms 

− Add functionality to an existing component  
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• Right-click on the Component in 

the Components Library 

• Select Help on Component in the 

pop-up menu 

• Component documentation will be 

displayed with the following topics 

− General Info 

− Properties 

− Methods 

− Events 

− Typical Usage 
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• Peripheral drivers… 

− Always include Physical Device Driver (PDD) layer. PDD uses base 

address and control registers to interface with the device. 

− May include Logical Device Driver (LDD) component. LDD handles 

buffering and state machine type logic. 

− May include interrupt or deferred service (ISR) routine. ISR provides 

callback functionality. 

UART

LDD
Logical Device Driver

PDD
Physical Device Driver

ISR
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• With an RTOS adapter… 

− ISRs are linked into kernel’s 
service handler functionality 

− PDD functionality is available as 
set of header files 

− LDDs encapsulate device-specific 
functions into a system API 

UART

LDD
Logical Device Driver

PDD
Physical Device Driver

ISR

ISR

LDD

PDD

ISR

LDD

PDD

OS

Interrupt

Service

Handler

ISR

ISR

<device>_pdd.h PDDPDD

LDD LDD

Processor 

Expert 

Components



30 TM 

• Every component has Init() method  

− Only one parameter - UserDataPtr.  

− Initializes appropriate peripheral and driver.  

• Every component has Deinit() method  

− De-initializes appropriate peripheral and driver.  

• First parameter for every method is pointer to device structure 
returned from Init() method.  

• Code generation is based on information in RTOS adapter  

• Events can be enabled/disabled at runtime. 

• Components can be disabled in Low Power Modes.  

• CPU component 

− Does not automatically initialize components by default.  

− Auto-initialization can be enabled/disabled. 
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• Designed to provide standard API to functionality 

• Component categories include: 

− Port I/O (i.e. BitIO, BitsIO, ByteIO)  

− Timers (i.e. TimerInt, PWM, Capture)  

− Communication (i.e. AsynchroSerial, SynchroMaster, SynchroSlave, I2C)  

− ADC 

− Internal memories 

• Eases porting to another microcontroller supported by Processor Expert 

software  

• Sets functionality based on application needs and does not require 

knowledge of hardware registers 

• MCU specific features are supported as CPU specific settings or methods 

and are not portable 
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• Developed high level software components, which inherit from 

PDD or LDD, to migrate S08 projects to Kinetis L Series 

devices  

− Provides same application program interface (API) 

− Software wrapper at the level required to provide the necessary functionality 

• High level components available for Kinetis 

− AsynchroSerial 

− SynchroMaster 

− SynchroSlave 

− ADC 

− ExtInt 

− FreescaleAnalogComp 

 

 

 

- IntFlash 

– BitIO 

– BitsIO 

– PWM 

– TimerInt 
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• Unplug the USB cable 

• Press and hold the Reset button 

• Plug in the USB Cable 

 

 

 

 

• Release the Reset button 

• Green LED Blinking 

• A removable drive should now be visible in the Windows 

Explorer with a volume label of BOOTLOADER  

Reset Button 

Open SDA USB Connection 

Green LED Blinking  



35 TM 

• Drag & Drop the DEBUG-APP-Pemicro_v10x.SDA to the 

BOOTLOADER  

• C:\Freescale\CW MCU v10.5\OpenSDA\firmware 
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• You will now see the “debug 
app” on the drive. 

• Unplug the USB  

• Re-Plug the USB 

• BOOTLOADER  Disappears 

• Check for “solid” Green LED 

• You are ready to go! 

Green LED ON  

Before 

After 
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• Check for “solid” Green LED 

• You are ready to go! 

Green LED ON  



TM 



39 TM 

• This hands-on lab shows you how to…  

− Create a new project with the New Project Wizard 

− Configure Components with the Component Inspector 

− Use High Level Device functions 

− Import existing files 

− Build the project 

− Test the application’s functionality 

− Trace the Code 

• The lab uses the FRDM-KL46Z board 

• The application will blink an LED periodically, and light a LED 

with button presses. 
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• This hands-on lab shows you how to…  

− Create a new project with the New Project Wizard  

−  Select & Configure Components 

− Configure Components with the Component Inspector 

− Use High Level Device functions 

− Import existing components 

− Build the project  

− Test the application’s functionality 

− Trace the Code 

 

 

Next up! 
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Click “Next” 

Enter “project_1” 

You can change the project 

location to another directory. 

Default location is used. 

Click “New MCU project” 
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Select “MKL46Z256” 

Click “Next” 

Enter “kl46” in filter 

Click “Next” 

De - Select: 

“P&E USB 

MultiLink 

Universal…” 

Select “Open 

Source SDA” 
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Click “Next” 

 Leave  default 

selections:  

C, Software, 

UART, GCC  

Click “Finish” 

Select  

“Processor Expert” 

Select  

“Hardware Configuration” 
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Component 

Inspector 

Component View 

Register View 
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• Select C++ Perspective 

Click “C/C++” 

Click “>>” 
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Component Inspector 

Component View 

Project View 
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• This hands-on lab shows you how to…  

− Create a new project with the New Project Wizard  

−  Select & Configure Components 

− Configure Components with the Component Inspector 

− Use High Level Device functions 

− Import existing components 

− Build the project  

− Test the application’s functionality 

− Trace the Code 

 

 

Next up! 
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• Components Needed:  

− Processor: CPU: MKL46Z256VMC4 (Preselected based on project wizard 

information) 

• Peripheral Initialization: 

− GPIO: Init_GPIO 

• Other components needed for project (High Level Components) 

− GPIO: BitIO: for SW1 

− GPIO: BitIO: for SW2 

− GPIO: BitIO: for Red LED 

− GPIO: BitIO: for Green LED 

− Timer: TimerInt: Flashing the LED 

− AsynchroSerial: Serial UART for debug output 
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Drag Down 
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• Switch to Component Library 

Click on  

“Component Library”  

to bring up the library 
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• Double Click on “Init_GPIO” 

Double Click 

on Init_GPIO 

Double Click on 

BITIO 4 Times 
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Init_GPIO 

BITIO (x4) 



54 TM 

Double Click on 

TimerInt 

Double Click on 

AsynchroSerial 
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• The component list should look like this: 

TimerInt 

AsynchroSerial 
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• 8.0 MHz External Clock Input 

− EXTAL0 – pin 50 

− XTAL0 – pin 51 
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• Configure the CPU component as follows: 

− Package 100 pin LQFP 

− System Oscillator Enabled 

− External Clock 8MHz input 

− MCG Mode PEE  

− PLL Output 96MHz 

− Core Clock 48MHz 

− Bus Clock 24MHz 
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Select “Component Inspector” 

Select “Cpu” 
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Select “LQFP 100-pin package” 

Click on far left edge 
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Expand 

“Clock Settings” 
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Select 

“Enable” 
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Select  

“PEE” 
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Enter “96” 
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Enter “48” 

Enter “24” 
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48 

24 

Enabled 

PEE 

96 
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• Change to “Advanced” Mode 

Click on “Advanced” 
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• Configure the AsynchroSerial component as follows: 
− Baud rate 115200 

− Receiver RxD UART0 

− Transmitter TxD UART0 

− Leave all other settings at their default settings 

 Channel: UART0  

 Parity: none  
 Width: 8 bits  
 Stop bit: 1  
 Receiver: Enabled  
 RxD: TSIO_CH2/… 
 Transmitter: Enabled  
 TxD: TSIO_CH3/…  
 Stop in wait mode: no 
 Idle line mode: starts after start bit  
 Enable in init code: yes 
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Select “AsynchroSerial” 
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Select 

“115200” 

Select  

“UART 0” 

Select 

“UART 0” 
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Select “TI1:TimerInt” 
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Enter “25Hz” 

Select 

“LED_TMR” 
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• LED1(green) on PTD5 

• LED2 (red) on PTE29 
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Select “Bit4:BitIO” 
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Enter 

“LED_RED” 

Select 

“CMP0_IN5/…” 

Select “Output” 

Enter “1” 
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Click on “Methods” 

Change “Value” to 

“Generate code” 



78 TM 

Select “Bit3:BitIO” 
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Enter 

“LED_GRN” 

Select 

“LCD_P45/…” 

Select “Output” 

Enter “1” 
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Select “Bit2:BitIO” 
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Enter “SW2” 

Select 

“LCD_P32/…” 

Select “Input” 
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Select “Bit1:BitIO” 
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Enter “SW1” 

Select 

“LCD_P23/…” 

Select “Input” 
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Select “PTA:Init_GPIO” 
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Select “PTC” 

Expand “Pins” 
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Select 

“Pin 3” 

Select “Enabled” 
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Right 

Click 

Select “Pin 

Sharing Enabled” 
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Pin sharing 

is enabled 
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Select 

“Enable” 
Expand  

“Pin 12” 
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Notice  error 

message.  

This pin must 

be “shared” 
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Right 

Click 

Select “Pin Sharing Enabled” 
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Close 

“Pins” 
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Expand 

“Setting” 

Expand 

“Pin 3” 



94 TM 

Click  Down Arrow 
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Select “Initialize” 
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Select “Input” 

Select “Enabled” 

Select “Pull Up” 
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Select “Input”  

Select “Enabled” 

Select “Pull Up” 

Select “Initialize” Expand 

“Pin 12” 
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No Errors 
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• This hands-on lab shows you how to…  

− Create a new project with the New Project Wizard  

− Select and setup High Level Components  

− Generate Processor Expert Code 

− Import existing files 

− Build the project  

− Test the application’s functionality 

 

 

Next up! 
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• Now that the components have been setup, its time to generate 

code. This can be done in one of two ways… 

Right  

click 

Select  

Generate 

Code Icon 
Select  

Generate 

Code 
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Minimize  

Processor Expert View 

Expand  

Project_1 
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Double Click  

“Events.c” 
Opens 

“Events.c” 

Scroll down to 

“LED_TMR_OnInterrupt 
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• Add code to the Timer Interrupt - LED_TMR_OnInterrupt() 

Expand  

“LED_GRN:BitIO 
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• Add code to the Timer Interrupt - LED_TMR_OnInterrupt() 

Drag & Drop 

“NegVal” 
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• This hands-on lab shows you how to…  

− Create a new project with the New Project Wizard  

− Select and setup High Level Components  

− Generate Processor Expert Code  

− Import existing files 

− Build the project  

− Test the application’s functionality 

 

 

Next up! 
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Use Windows Explorer to  navigate to: 
 

..\Desktop\PEx_MCU Training\Lab_1 
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Click “OK” 

Select “Copy Files” 
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Double click “my_main.c” 
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Click  “Minimize” 
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• Open “Processor Expert.c to add our code 

Add declaration here 

Add call here 
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• This hands-on lab shows you how to…  

− Create a new project with the New Project Wizard  

− Select and setup High Level Components  

− Generate Processor Expert Code  

− Import existing files  

− Build the project 

 Select the project 

 Clean 

 Build  

− Test the application’s functionality 

 

 

Next up! 
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Select 

“project_1” 

 Select “Clean” 



117 TM 



118 TM 

 Select “Build” 
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PEx #includes  here 
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Your declarations here 

Main.c 

Hardware initializations 

Your code goes here 
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Timer Interrupt code goes here 
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#includes copied from 

ProcessorExpert.c 

Declarations needed for our code  
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Main loop – watch for switch presses 

Switch press routine 

Delay loop 
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• This hands-on lab shows you how to…  

− Create a new project with the New Project Wizard  

− Select and setup High Level Components  

− Generate Processor Expert Code  

− Import existing files  

− Build the project   

− Test the application’s functionality 

 Download and debug 

 Inspect the registers 

 Setting breakpoints 

 

 

Next up! 
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 Select “Debug” 

 Select “project_1” 
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Progress Bar 
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Console View Stack 

Editor 

Debug View 

Variable View Stack 

 Breakpoint 

Disassembly 

View 

Commander View 
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 Reset  Suspend  Disconnect  Step Into  Step Return 

 Resume  Terminate  Restart  Step Over 
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 The application uses the uart to “print” 

data. An easy way to see this is to use 

the built in “terminal” in CodeWarrior. 

 Select “Window” 

 Select “Show Views” 

 Select “Other” 
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 Expand “Terminal” 

 Select “Terminal” 

 Click “OK” 
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• Connection Type: Serial 

• Port – See your Device Manager 

• Baud Rate: 115200 

• 8,1, none, none 

 Select “Settings” 

Setup the parameters 
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 Click “Step Over” 

 Editor moves 

to next line 
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 Click “Step Into” 

 Editor moves 

to next line 
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 Editor moves 

to next line 

 Click “Step Into” 
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 Editor moves to line 

after the called routine 

 Click “Step Return” 
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 Click “Step Into” 
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UART “prints” 

message to 

Terminal View 
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 Click “Suspend” 
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 Select “Register View”  

 Expand “User/System 

Mode Registers” 



141 TM 

 Click “Step Over” 

 Changed registers 

are highlighted 
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 Click “Terminate” to stop debug session 
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 Double click  

at line 38  

and line 41  

to set breakpoints 
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 Click “Debug” to restart 

the debug session 
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• This error occurs because the number of break points set exceeds 
the number of breakpoints available on the chip. 

• The KL46 only has 2 breakpoints available. 

• There are 3 breakpoints set 

− At main 

− At line 38 

− At line 41 

 Click “OK” 

to continue  

debug session 
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• Code stopped at first user breakpoint and not at the system set 

breakpoint at “main”. 

 

 

 

 

 

 

 

• Click “Resume”  
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 Stopped at the 

next Break Point 

• Click “Step Return” 
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• This error message is displayed since there are too many 

break points. 

 Click “OK” 

to continue  

debug session 
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• Click “Resume” 
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 Stops at next  

breakpoint 
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 Click “Terminate” 

 Click “>>” 

 Click “C/C”++ 



152 TM 

• This hands-on lab shows you how to…  

− Create a new project with the New Project Wizard  

− Select and setup High Level Components  

− Generate Processor Expert Code  

− Import existing files  

− Build the project   

− Test the application’s functionality  

− This concludes our Lab session 

− Question? 
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• Workbench = desktop development environment 

− Contains all C/C++ development-related tools 

− Shows different perspectives of the working environment 

− Main window that appears when CodeWarrior Eclipse starts: 
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• Workspace = directory that stores the source code, files and 

settings related to your work 

− Specify the workspace on startup 

− More than one project can be in a workspace 

− To switch workspaces select File > Switch Workspace  
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• Project = container for organizing files and folders 

− All C/C++ work is done in the context of projects 

− CodeWarrior creates projects in new folders by default 

− New files and folders can be added to a project 

 File > New > File: Creates a new file in project directory within the workspace directory 

  File > New > Folder: Creates a new directory in project directory within the workspace 
directory. 

 Files dragged into a project are physically copied into the project directory   

− Files outside the project folder (or outside the workspace) can be linked to a 
project 

 File > New >  File > Advanced > Link to File System: Creates new link in project 
directory within the workspace, which refers to a file in the file system 

 File > New > Folder > Advanced > Link to File System: Creates new link to a directory 
in project folder within the workspace.  The link points to a directory in the user’s file 
system.  Creating this link will pull the directory and all sub-components into the 
CodeWarrior project. 
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• View = a “visual” panel in the Workbench 

− Displays information about the contents of your workbench 

− Different views are provided for different tasks 

 Problems – Compile or other problems 

 Console – Standard run window console 

 C/C++ Projects – View of projects in workspace 

 Breakpoints – Debugging breakpoints in open projects 

− Editors are special “views” for editing files 
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• Perspective = collection of Eclipse views and action sets 
organized into a layout that suits an assigned task   

− Current perspective is highlighted at the top of the perspective window 

− Perspectives are shown on perspective shortcut bar (top right) 

 
 

− Click the perspective icon to switch among open perspectives 

− To open a perspective: 

 Select Window > Open Perspective > [select -or- Other] 

 On the perspective view, choose Open Perspective > [select -or- Other] 

 

 

− To close a perspective: 

 Select Window > Close Perspective 

Open Perspective Icon 
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• Default views: 

− CodeWarrior Projects View 

− Editor (Area) 

− Problems View 

− Console View 

− Commander View 

 

 

 

 

 

 

 

• Each view has an optional toolbar and menu that is separate from 
those on the main workbench window.   
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• File space (folder) organization for source and object files 

• Project folders are at the top level, but you can drill down: 

Right-click folder > Go Into 

• Filters types/status of resources to show (Toolbar menu > 

Filters) 

• Other folders include: 

− Debug  

− Includes (compiler dependent) - contains makefiles 

− Binaries (generated by the compiler) 

 

 



164 TM 

• There are multiple editors for multiple file types 
− C/C++ editor for source code 

− Text editor for text files 

• To open a file: 
− Double click on the file in CodeWarrior Projects or Navigator view  

 - or - 

− Select File > Open File 

• Each file opens up in a new tab in editor area 

• Editors show changes in files since last save 
− See the change bar (left side of text) 

− Additions and modifications are color coded 

− Hover cursor over change bar to see previous text 

− Dirty file – indicated by * in editor tab. 

• Marker area on left side of  
editor indicates task,  
bookmarks or breakpoint 
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• To configure editors: 

− Select Window > Preferences 

 Expand General folder 

 Select Editors > Text Editors 

− Configure options: 

 Show line numbers 

 Highlight current line  

 Color options 

 Etc. 
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• Shows errors and warnings 

− Filters on problems to display:  

 Location of defective resource 

 Type of defect 

 Type of problem 

− Double click an error/warning message to navigate to offending source 

code 
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• Displays standard I/O 

• Echoes Make files 

• Displays program output 

• Console toolbar: 

− Scroll Lock 

− Clear Console 

− Pin Console (save this console in separate view) 

− Display Selected Console 

− Open Console 
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• One click access to most common operations  

− Project Creation 

− Build/Debug 

− Settings 

− Miscellaneous 
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Debug Perspective

• Default views: 

− Debug View 

− Variables View 

− Breakpoints View 

− Memory View 

− Modules View 

− Editor (Area) 

− Disassembly View 

− Problems View 

− Console View 

− Commander View 

 

 

• Each view has an optional toolbar and menu that is separate 
from those on the main workbench window.   
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• Shows the target debugging information in a tree hierarchy 

 

 

 

 

 

 

 

 

• Use this view to perform the following tasks:  

− Clear all terminated processes  

− Start a new debug session for the selected process  

− Resume execution of the currently suspended debug target 

− Halt execution of the currently selected thread in a debug target 

− Terminate the selected debug session and/or process 

− Detach the debugger from the selected process  

− Execute the current line, including any routines, and proceed to the next statement  

− Execute the current line, following execution inside a routine  

− Re-enter the selected stack frame  

− Examine a program as it steps into disassembled code  
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• Lists all global and static variables for each process 

 

 

 

 

 

 

•  Variables changed since last update are highlighted 

• To add a global variable: 

− Select         in the Variable View 

− Select the global variables from the Global Variable dialog box 
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• Lists all breakpoints set in the workbench projects  

• Allows breakpoints to be grouped by type, project, file, or 

working sets 

• A breakpoint can temporarily be disabled without losing the 

information it contains 
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• Allows memory to be monitored  and modified 

• Contains two panes:  

− Monitors panel - Displays the list of memory monitors added to the 

debug session currently selected in the Debug view  

− Renderings panel - Displays memory renderings.  

 Content is controlled by the selection in the Monitors panel.  

 Can be configured to display two renderings simultaneously.  
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• Displays information about the modules loaded in the current debug 
session 

− Executables  

− Shared libraries 

• View consists of  
two areas: 

− Modules tree  

− Detail pane 

• Detail pane displays the detail information for the module selected in 
the modules tree 

• Expanding a module enables users to view the module's internals  

− Functions 

− Global variables  

− Associated source files 
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• There are multiple editors for multiple file types 

− C/C++ editor for source code 

− Text editor for text files 

• To open a file: 

− Double click on the file in CodeWarrior Projects or Navigator view  

 - or - 

− Select File > Open File 

• Each file opens up in a new tab in editor area 

• Editors show changes in files since last save 

− See the change bar (left side of text) 

− Additions and modifications color  

 coded. 

− Hover cursor over change bar to see  

 previous text 

− Dirty file – indicated by * in editor tab 

• Marker area on left side of editor indicates task, bookmarks, or breakpoint  
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• Shows the loaded program as assembler instructions mixed 
with source code for comparison  

• The currently executing line is indicated by an arrow marker 
and highlighted in the view 

• The following tasks can be performed: 

− Set breakpoints at the start of any  
 assembler instruction  

− Enable and disable  
breakpoints and set their  
properties  

− Step through the disassembly  
 instructions of the program  

− Jump to specific instructions  

 in the program  
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• Shows errors and warnings 

− Filters on problems to display:  

 Location of defective resource 

 Type of defect 

 Type of problem 

− Double click an error/warning message to navigate to offending source 

code 
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• Displays standard I/O 

• Echoes Make files 

• Displays program output 

• Console toolbar: 

− Scroll Lock 

− Clear Console 

− Pin Console (save this console in separate view) 

− Display Selected Console 

− Open Console 
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