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Customer Support

Technical Assistance
To search our knowledge base for a solution or to log in to the Technical Support 
portal and report a problem, go to www.hsmcontactsupport.com.

For our latest contact information, see www.honeywellaidc.com/locations.

Product Service and Repair
Honeywell International Inc. provides service for all of its products through service 
centers throughout the world. To obtain warranty or non-warranty service, return 
your product to Honeywell  (postage paid) with a copy of the dated purchase 
record. To learn more, go to www.honeywellaidc.com and select Service & Repair at 
the bottom of the page.

Limited Warranty
For warranty information, go to www.honeywellaidc.com and click Get Resources > 
Product Warranty.
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1

IF1C Fixed RFID R
GET STARTED
The IF1C is a family of RFID Readers having options with Integrated Antenna 
(Linear or Circular Polarized) or Two External-Antenna Ports with Honeywell-
designed radio frequency (RF) platform offering superior read performance.

Features of the RFID reader include:

• 64 MB of storage space for your RFID applications

• A web browser interface for easy configuration

• Support for EPCglobal Gen-2 and Gen 2v2 (ISO) tag types

• IP66 seal rating for outdoor installations

• Support for Power Over Ethernet

• VESA mount compatibility

• USB and sealed Power Over Ethernet ports

• Interfaces Supported: GPI's, GPO's/Wiegand & RS-232 
eader User Guide 1



RFID Reader Ports
Depending on your configuration, the ports that are available on the RFID reader 
may be different.

LED Indicators
The LED indicators on the reader light up to indicate the status of the reader 
during operation.

Callout Port Description

1 Ethernet 10Base/100Base-T port that connects the reader to your Ethernet 
network. The reader auto-negotiates with the server to set the best 
data rate. This port uses MDI/MDI-X auto-switching so you can 
connect either a standard Ethernet cable or a crossover cable.
The port also supports Power Over Ethernet (POE). To power the 
reader, you need an 802.3af-compliant power supply.

2 GPIO General purpose input/output (GPIO) port that connects the reader to 
industrial controls such as relays or indicators. It also supports 
RS-232 and Wiegand Interface multiplexed with GPOs

3 USB Connects the reader to a desktop PC for configuration. 

4 Antenna Connects an external antenna to your reader. The antenna port uses 
Reverse TNC connectors.

1

2

3
4

Caution:  Professional Installation Required: Government regulatory 
agencies require this RFID reader to use only approved 
antennas and cables. 
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Wall Mounting Kit
The wall mounting or VESA mounting kit allows you to mount the reader to a flat 
surface. It is sold and ordered separately. To order accessories, contact your local 
sales representative.

Install the Wall Mount
To maintain the IP66 rating of the reader, you must mount the reader correctly. 

1. Choose a mounting location.

2. Connect an earth ground cable to the RFID reader.

Icon Name Color Description

RFID 
antenna

Solid green RF field is active

Blinking green A tag is being interrogated.

Blinking red The reader cannot output the requested RF power level, 
or an RF fault is detected.

Off The RFID radio is not powered.

Ethernet Solid green The reader is powered, an Ethernet link is established, 
and the host is connected.

Flickering green Packets of information are being sent through the 
Ethernet port.

Blinking green 
and orange

An Ethernet link is established, but there is no host 
connection.

Blinking red The reader is powered, but an Ethernet link is not 
established.

Off The reader is not powered.
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3. Secure the wall mount to the RFID reader with the washers and screws
provided.

4. Secure three screws (not provided) to the wall, and place the mounting bracket
on to the screws.

5. Secure three screws (not provided) to the bottom of the wall mount bracket.

(x4)
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How to Communicate with the RFID reader
The reader is configured to be a DHCP client and accepts offers from any DHCP 
server by default. Therefore, the reader works out of the box if you connect it to your 
network and use a DHCP server to assign it an IP address. As a default IP address, 
this equipment can be accessed through HTTP on 169.254.1.1 if no other device 
on the network has already been assigned for this IP address.

If you are not using a DHCP server to assign an IP address, you need to use a serial 
communications program such as HyperTerminal or Tera Term to assign a static IP 
address.

After the reader has been assigned an IP address, connect it to your network and 
then complete the configuration by using the web browser interface.

Assign an IP Address
You need to assign an IP address to the reader before you can connect the reader 
to your network to use the web browser interface to complete the configuration.

1. Download the USB drivers for the reader from the Technical Support Down-
loads Portal at https://hsmftp.honeywell.com.

2. Go to:
Software
- RFID

- RFID Fixed Readers
- IF1

When prompted, click on Open Honeywell Software Downloader. 

3. Extract the installation files that you downloaded.

(x3)
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4. Connect a USB cable from the RFID reader to your desktop PC.

5. When the USB Driver Installation Wizard appears, click Browse my computer
for driver software.

6. In Search for driver software in this location, click Browse, select the folder
where you extracted the reader installation files, and click OK.

7. Click the Windows icon > Control Panel > Device Manager and see which COM
port the reader was assigned.

8. Click Next to install the drivers.

9. If you are using Windows 8 or Windows 10 operating system, a warning may be
displayed. Click on Install this driver to proceed with the installation.

10. When the installation is finished, click Close.

11. Open a serial communications program to connect to the reader.

12. Type config and press Enter, and then type config again in the Password
field and press Enter.

13. By default, DHCP is enabled and the IP address to configure the reader
appears. Use the IP address to configure the reader through the web browser
interface.

14. If you are not using DHCP, press D. DHCP is disabled and the Ethernet
Configuration Options screen appears.
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15. To set the IP address, press 1, type in the IP address, and press Enter.

16. To set the subnet mask, press 2, type in the subnet mask, and press Enter.

17. To set the IP router, press 3, type in the IP address, and press Enter.

18. (Optional) To change the Ethernet link speed, press L, and choose the link
speed.

19. Press Q to close the Initial Configuration screen.

20. Remove the USB cable from the reader. The reader is ready to be configured
and connected to your network.

Log In to the Web Browser Interface
After the reader is assigned an IP address, you can configure the reader through 
the web browser interface. Before you log in, make sure an IP address has been 
assigned to the reader, and the reader is connected to your network.

1. Start a web browser.

2. In the browser address field, enter the IP address, and press Enter.

3. (Optional) For a secure session, click A secure session is available.
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4. Enter your Username and Password. The default user name is intermec and
the default password is intermec.

5. Click Non-Secure Login, or Secure Login. The Ethernet screen appears and
you are logged in to the web browser interface.

Set the Date and Time
Set the date and time through the web browser interface.

1. From the Main Screen of the web browser interface, click the date and time in
the upper right corner.

2. Select your time zone from the drop-down list, and then click Activate
Changes.

3. Enter the current year, month, and day in the entry fields.

4. Enter the current hour, minutes, and seconds in the entry fields.

5. Click Activate Changes. The new time and date are set.
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IF1C Fixed RFID R
CONFIGURE THE READER
Configure Ethernet Settings
To use the reader, you need to configure Ethernet settings such as your IP address 
and subnet mask.

Note: If DHCP is enabled, you may not need to configure Ethernet settings. For more 
information, contact your network administrator.

1. Log in to the web browser interface and click Network Configuration or Ether-
net.

2. Configure the settings.

3. When you are finished, click Activate Changes to save your changes.

Ethernet Settings
You can configure these Ethernet settings for your reader to communicate with 
your network.

Setting Description

Enable DHCP Select this field if you want the reader to get its IP address from a DHCP 
server.
If this field is not selected, you need to specify the IP address, subnet 
mask, and IP router for your network.

IP Address The IP address of the reader. The IP address has the form x.x.x.x, where x 
is a number from 0 to 255. The default MAC address is on the label on the 
side of the reader.
If DHCP is enabled, the currently assigned IP address appears in this 
field.
If DHCP is disabled, specify the IP address in the entry field.

Subnet Mask The subnet mask for this network. The subnet mask has the form x.x.x.x, 
where x is a number from 0 to 255.
If DHCP is enabled, the currently assigned subnet mask appears in this 
field.
If DHCP is disabled, specify the subnet mask in the entry field.
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Configure Common Network Settings
You can configure the common network settings that apply to the reader network 
interface.

1. Log in to the web browser interface and click Network Configuration >
Common.

2. Configure the settings.

3. Click Activate Changes to save your changes.

Common Network Settings
You can configure these common network settings that apply to the reader net-
work interface.

Router Default The IP address of the router. The IP address has the form x.x.x.x, where x is 
a number from 0 to 255.
If DHCP is enabled, the currently assigned router address appears in this 
field.
If DHCP is disabled, specify the router address in the entry field.

Link Local IP Address The IP address of the reader is only routable on the local IP subnet. The 
reader auto-negotiates with other devices on its Ethernet segment to 
obtain a unique address, so no user configuration of the Link Local IP 
Address is necessary. The reader always has a Link Local IP Address, 
even if another address is assigned through DHCP or statically via user-
configuration.

IPv6 Autoconfigure Enables IPv6 automatic configuration.
Auto-configuration is enabled by default. If you disable auto-
configuration, you need to specify an IPv6 address, subnet mask, and 
router.

IPv6 Address 128-bit IPv6 address for the reader.

IPv6 Router 128-bit address for the IPv6 router.

Setting Description

Setting Description

Hostname Name for this reader. The default is “IF1<serial number of the reader>”.
The host name can be either a simple host name, or a qualified domain 
name (FQDN). If this reader obtains its IP address via DHCP, this 
parameter is sent to the DHCP server. If the server supports it, this field is 
used for dynamic DNS updates.

DNS Server 1 IP address of a domain name server that the reader uses to resolve DNS 
names.

DNS Server 2 IP address of a second domain name server that the reader uses to 
resolve DNS names.

DNS Suffix 1 Primary DNS suffix to be appended to unqualified names.

DNS Suffix 2 Secondary DNS suffix to be appended to unqualified names.

SNTP Server Name 1 DNS name or IP address of an SNTP or NTP server.
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Device Configuration Web Service
The Device Configuration web service provides a way to configure the reader over 
your network. This SOAP-based service provides a configuration API that allows 
you to specify a variety of network, RFID, and system settings.

For more information on the Device Configuration web service, see the Device Con-
figuration Web Service Command Reference Manual.

Device Configuration Web Service
Enable the device configuration web service to specify a variety of network, RFID, 
and system settings.

1. Log in to the web browser interface and click Network Configuration > Device
Management.

2. By default, Device Configuration web services are enabled for either secure or
insecure connections.

3. To disable web services over a secure connection, clear the Enable Device Web
Services (Secure) check box, and then click Activate Changes.

4. To disable web services over an insecure connection, clear the Enable Device
Web Services (Insecure) check box, and then click Activate Changes.

Download the Device Configuration WSDL Document
Download the device configuration web service description language (WSDL) doc-
ument to help you configure your system settings.

1. Log in to the web browser interface and click Network Configuration > Device
Management.

2. Click DeviceConfiguration.wsdl. The document opens in the browser window.

SNTP Server Name 2 DNS name or IP address of a second SNTP or NTP server.

Time Zone Time zone for this reader. Choose the time zone from the drop-down list. 
Default is GMT.

SYSLOG Destination Domain name or IP address of the SYSLOG server. 

Setting Description
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Configure Services
Configure the way users (such as developers) can access and configure the reader.

1. Log in to the web browser interface and click Network Configuration > Ser-
vices.

2. Enable or disable the services by selecting or clearing the check boxes, or by
selecting options from the drop-down list.

3. Click Activate Changes to save your changes.

Services Settings
Service settings control the way users access the reader.

RFID Services
The RFID services set the protocol your application uses to communicate with the 
RFID module. There are two RFID services available:

Service Description

Enable Web Server 
(Insecure)

Enables access to the web browser interface. An insecure connection 
only allows users to log in to web browser interface from HTTPS through 
port 80.

Enable Web Server 
(Secure)

Enables access to the web browser interface. A secure connection only 
allows users to log in to web browser interface from HTTPS through port 
443.

Enable SSH Server Enables Secure Shell (SSH) access to the Linux system console using 
the same login and password as the web browser interface (default is 
intermec). SSH access is disabled by default.

Enable FTP Server Enables access to the reader through its FTP server. 

Enable Telnet Server Enables access to the Linux system console via standard Telnet, using 
the same login and password as the web browser interface. The default 
login and password is intermec. The Telnet server is disabled by default.

Enable CIFS/SMB 
Service

Enables the Common Internet File System service, which creates a file 
sharing connection from a Windows PC to the /home/developer 
directory on the IF1C. CIFS/SMB is disabled by default.
When you enable the CIFS/SMB service, entry fields for a username and 
password appear. Enter these settings and then click Activate Changes.

Enable Bonjour Service 
Advertisement

Enables the reader to advertise services and be discovered by Bonjour 
zero-configuration networking. Bonjour is enabled by default.
To prevent errors when using Bonjour, make sure the reader hostname 
does not include spaces.

Enable UPnP Discovery Enables the reader to be discovered by Universal Plug and Play 
protocols. UPnP is enabled by default.
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• BRI (Basic Reader Interface)
Honeywell proprietary protocol for controlling the reader. For information about 
the BRI, see the Basic Reader Interface Programmer Reference Manual 
available on the Honeywell website.

• LLRP (Low-Level Reader Protocol)
EPCglobal standard for network interfaces between the RFID reader and its 
controlling software. The RFID reader supports version 1.0.1 of the EPCglobal 
LLRP. For information on LLRP, see go to https://www.gs1.org/standards/epc-
rfid/llrp/1-1-0. An open source LLRP Toolkit can be downloaded at http://
sourceforge.net/projects/llrp-toolkit. 

Configure the BRI Server Settings
Configure the BRI Server to handle communications between your application and 
the RFID module. 

1. Log in to the web browser interface and click RFID Services > BRI > BRI Server.

2. Configure the BRI Server settings.

3. Click Activate Changes to save your changes.

BRI Server Settings
BRI Server settings handle communications between your application and the 
RFID module.

View the BRI Server Log
If you enable logging, you can see a list of BRI server events, and save the logfile as 
a .txt file.

1. Log in to the web browser interface and enable logging.

2. Click RFID Services > BRI > BRI Log.

Setting Description

Enable External BRI 
Connections

Enables external TCP connections to the BRI server. If this is not enabled, 
BRI applications will not be able to connect to the reader.

BRI TCP Port Specifies the TCP port used for incoming connections to the BRI server. 
This port must be unique for all TCP services running on the reader. Valid 
range is 2189 to 65535. Default is 2189.

Enable Logging Enables logging of BRI server events.
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3. To save the log file, click Export log to text file and then choose File > Save As.
Follow the prompts to save the log file to your desktop PC.

BRI Server Event Settings
You can view BRI Server Events when you enable logging.

Configure the BRI Attribute Settings
Configure the BRI Attribute settings to control how the reader operates and reads 
tags.

1. Log in to the web browser interface and click RFID Services > BRI >
BRI Attributes.

2. Configure the BRI Attribute settings.

3. Click Activate Changes to save your changes.

BRI Attribute Settings
BRI Attribute settings control how the reader operates and reads tags. For more 
information, see the Basic Reader Interface Programmer Reference Manual avail-
able on the Honeywell website.

Event Name Description

Time/Date Time and date of the event.

Connection Session ID of the client communicating with the BRI server.

Type Message type of the event, generally indicating which system sent the message:
1 = Command received by BRI server
2 = Response sent by BRI server
3 = BRI server connection message

Message Text of the message, including responses.

Setting Description

Tag Type Select the tag types you want the RFID reader to read:

• EPC Class 1 Gen 2 (default)

This setting is equivalent to the TAGTYPE BRI attribute. 

Read Tries The maximum number of times the read algorithm is executed before 
a response is returned to a Read command. Valid range is 1 to 254. 
Default is 3.
In practice, this is the number of times an identified tag is read until 
the Read is successful.
This setting is equivalent to the RDTRIES BRI attribute.
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Write Tries The maximum number of times the read algorithm is executed before 
a response is returned to a Write command. Valid range is 1 to 254. 
Default is 5.
In practice, this is the number of times an identified tag is written until 
the Write is successful.
This setting is equivalent to the WRTRIES BRI attribute.

Lock Tries The maximum number of times the lock algorithm is executed before 
a response is returned to a Lock command. Valid range is 1 to 254. 
Default is 3.
This setting is equivalent to the LOCKTRIES BRI attribute.

Field Separator The character used for separating fields in tag data. Choose from 
space ( ), comma (,), colon (:), semicolon (;), tab, caret (^), or tilde (~). 
Default is space ( ).
This setting is equivalent to the FIELDSEP BRI attribute.

ID Report Enables tag ID reporting after a Read, Write, or Lock command is 
executed:

• For ISO tags, the tag identifier corresponds to TAGID

• For EPC tags, the identifier corresponds to EPCID
Default is enabled.
This setting is equivalent to the IDREPORT BRI attribute.

No Tag Report Enables a NOTAG message, which is sent when no tags are found 
during execution of a Read, Write, or Lock command. Default is 
enabled.
This setting is equivalent to the NOTAGRPT BRI attribute.

Report Timeout The timeout (in ms) for delays in tag reporting when the RFID reader 
is in continuous read mode. Valid range is 0 to 65534. Default is 0.
This setting is equivalent to the RPTTIMEOUT BRI attribute.

Timeout Configuration 
Mode

Establishes whether to use the Timeout or Tries attributes. Default is 
off.
This setting is equivalent to the TIMEOUTMODE BRI attribute.

Session The command session parameter to a corresponding EPCglobal 
Class 1 Gen 2 air protocol command. Valid range is 0 to 3. Default is 3. 
This setting is equivalent to the SESSION BRI attribute.

Initial Q (EPCglobal Class 1 Gen 2 tags only) The initial Q parameter value 
used by the Query command. Valid range is 1 to 254. Default is 4.
If you know there is only one tag in the field, set this attribute to 0 for 
best performance.
This setting is equivalent to the INITIALQ BRI attribute.

Initialization Tries The maximum number of times the reader attempts to initialize a tag. 
Valid range is 1 to 254. Default is 1.
This setting is equivalent to the INITTRIES BRI attribute.

Setting Description
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Configure LLRP Settings
Configure the LLRP settings to establish an interface method between the reader 
and a client. For more information on LLRP, see https://www.gs1.org/standards/
epc-rfid/llrp/1-1-0.  

1. Log in to the web browser interface and click RFID Services > LLRP.

2. Configure the LLRP settings.

3. Click Activate Changes to save your changes.

LLRP Settings
LLRP settings establish an interface method between the reader and a client.

Schedule Option Determines how antennas are switched during the inventory process:
0 - Legacy BRI operations
1 - Simplified BRI operations
2 - Simplified BRI operations with EPCC1G2 A/B toggling.
Default is 0.
This setting is equivalent to the SCHEDULEOPT BRI attribute.

ID Tries The maximum number of times the reader executes the identify 
algorithm before a response is returned to a Read or Write command. 
Valid range is 1 to 254. Default is 1.
In practice, this is the number of times a tag identification attempt is 
made for the antenna. 
This setting is equivalent to the IDTRIES BRI attribute.

Antenna Tries The number of times the antenna is used for a Read or Write 
command. Valid range is 1 to 254. Default is 1.
This setting is equivalent to the ANTTRIES BRI attribute.

EPCC1G2 Advance 
Medium Access Mode

Dense Reader Mode settings used with EPCC1G2 parameters.
This setting is equivalent to EPCC1G2PARAMETERS BRI attribute.

Dense Reader Mode Allows the reader to hop between channels within a certain frequency 
spectrum to prevent other readers in the area from interfering with 
one another. Default is enabled.
This setting is equivalent to the DENSEREADERMODE or DRM BRI 
attribute.

Field Strength dB 1-4 The RF power level (in dBm). Valid range is 1 to 30. Default is 30.
Use this setting to attenuate the antenna field strength. In some 
situations, full output power can cause unnecessary interference. For 
example, if the tag is close to the antenna, full output power might 
overload the tag and cause unreliable behavior.
This setting is equivalent to the FIELDSTRENGTH BRI attribute.

Antenna Sequence 1-8 The antenna sequence to be used during READ and WRITE 
commands. 
This setting is valid for two antennas only, and is equivalent to the 
ANTS BRI attribute.

Setting Description
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Configure Security
To make sure the reader is secure, change your security settings when you set up 
your reader. You can secure the reader by:

• Changing user credentials

• Enabling a RADIUS server

• Enabling or disabling serial configuration

Change User Credentials
If you are not using a password server to authorize user logins to the reader, 
change the default user name and password.

1. Log in to the web browser interface and click Security > Passwords.

2. Configure the User Credential settings.

3. Click Activate Changes to save your changes.

User Credential Settings
User Credential settings control the user name and password you use to log in to 
the reader.

Setting Description

Secure Server Enable Allows connections to the secure LLRP server on port 5085.

Unsecure Server Enable Allows connections to the unsecure LLRP sever on port 5084.

Download Intermec 
Extensions Definition

Downloads an XML file that describes Honeywell-specific extensions for 
the LLRP protocol.

Reader Initiated 
Connections

For reader-initiated TCP/IP connections to a remote LLRP client.

• Client address - The IP address of the remote LLRP client.

• TCP port - Port number for the TCP/IP socket connection.

• Enable security (TLS) - Select this option to enable Transport Layer
Security for this TCP/IP connection.

Setting Description

Username The user name to log in to the reader. The user name can be from 1 
to 32 characters long. You must always specify a user name. Default 
is intermec.

Password The password to log in to the reader. This password gives you both 
read and write access to the reader configuration. The password can 
be from 8 to 32 characters long. You must always specify a 
password. Default is intermec.
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Configure the RADIUS Server
If you are using a password server to manage users who log in to the reader, you 
need to enable and configure the RADIUS server.

1. Log in to the web browser interface and click Security > Passwords.

2. Click Enable RADIUS.

3. Configure the RADIUS server settings.

4. Click Activate Changes to save your changes.

RADIUS Server Settings
You can configure RADIUS Server settings to manage how users log in to the 
reader.

Disable Serial Port Access
To enhance security, or allow an external application to communicate with the 
serial port, disable serial port access to the reader.

1. Log in to the web browser interface and click Security > Passwords.

2. Clear the Enable Serial Configuration check box.

3. Click Activate Changes to save your changes.

Read-only password The password to log in to the reader. This password gives a user 
read-only access. The user can view the configuration of the reader 
and execute diagnostics, but cannot perform any tasks that affect 
the reader operation. Default is read only.
The read-only password cannot be deleted. To disable read-only 
access, you need to enable the RADIUS server.

Setting Description

Setting Description

Enable RADIUS Enables RADIUS authentication for the reader.

Primary RADIUS Server IP address or DNS name of the RADIUS server. If this is left blank, the 
RADIUS client does not use this entry.

Secret Secret key for the RADIUS server.

Port Port number of the primary RADIUS server. Default is 1812.

Secondary RADIUS 
Server

IP address or DNS name of the RADIUS server to use if there is no 
response from the primary RADIUS server. 

Secret Secret key for the secondary RADIUS server.

Port Port number of the secondary RADIUS server. Default is 1812.
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Certificates
The default server certificate on the reader (ValidforHTTPSOnly) provides support 
for secure network applications, such as the secure web browser interface and 
secure LLRP client connections. You can also use a third-party CA to issue unique 
client certificates and a root certificate.

Import a Certificate
To enhance security, import a certificate to the reader. 

1. Log in to the web browser interface and click Security > Import Certificate.

2. Select the type of certificate.

3. Click Browse and select the certificate.

4. If you selected a server certificate to import, enter the passphrase for the
certificate.

5. Click Import Certificate. The certificate is imported.

View Certificates
Use the web browser interface to view the certificates loaded on to the reader. Log 
in to the web browser interface and click Security > Certificate Details. The Certifi-
cate Details screen appears.
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DEVELOP AND INSTALL RFID 
APPLICATIONS
RFID Applications 
RFID applications that you develop communicate through one of two RFID ser-
vices:

• BRI (Basic Reader Interface)
Honeywell proprietary protocol for controlling the reader. For information about 
the BRI, see the Basic Reader Interface Programmer Reference Manual 
available on the Honeywell website.

• LLRP (Low-Level Reader Protocol)
EPCglobal standard for network interfaces between the RFID reader and its 
controlling software. The RFID reader supports version 1.0.1 of the EPCglobal 
LLRP. For information on LLRP, see go to https://www.gs1.org/standards/epc-
rfid/llrp/1-1-0. An open source LLRP Toolkit can be downloaded at http://
sourceforge.net/projects/llrp-toolkit. 

RFID Resource Kit
To create an application, use the RFID Resource Kit. The Honeywell Developer 
Library RFID Resource Kit includes Java and C# tools you can use to develop appli-
cations that enable control of the reader and data management. To learn more 
about the RFID Resource Kit, 

1. Download the RFID Resource Kit from the Technical Support Downloads Portal
at https://hsmftp.honeywell.com.

2. Go to:
Software
- RFID

- RFID Fixed Readers
- IF1
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Microsoft® .NET™ Support
The reader supports applications based on the .NET Framework 1.0, 1.1, 2.0 and 
4.0. The reader uses Mono open source software to provide support for .NET 
applications deployed on the Linux operating system of the reader.

Java™ Support
The reader comes with a JDBC driver you can use to create applications that writes 
data directly from the reader to a remote database.

For more sophisticated Java development, the reader supports the open standard 
OSGi service-oriented architecture. This architecture allows system administrators 
to install, uninstall, enable, and disable system services (also known as bundles) 
without having to reboot the reader each time. To use OSGI, download packages 
from osgi.org.

Execute Java Applications
To execute a Java application on the reader, use this command:

$JAVA_HOME/bin/java myJAVAClass

Execute .JAR Files
To execute .jar files, use this command:

$JAVA_HOME/bin/java myApplication.jar

When you create a .jar file, you need to include manifest files:

• The manifest needs to include an attribute called “Main-Class” to specify the
application’s entry point (for example, Main-Class: MyJavaClass).

• If the executable .jar needs to reference other .jar files, specify the files in the
manifest file using the “Class-Path” attribute.

Enable the Java Just-In-Time Compiler
To enable the Java just-in-time (JIT) compiler for maximum performance, use this 
command:

$JAVA_HOME/bin/java -jit java -jar MyJar.jar
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where:

$JAVA_HOME is an environment variable that indicates the Java runtime installa-
tion path (/usr/java). Always use this variable for simplicity and to make sure that 
the correct runtime files are used.

$JAVA is the name of the Java runtime executable installed in the reader.

Specify the Class Path for the Java Virtual Machine
If your application references third party Java libraries, such as the components 
from the Honeywell RFID Resource Kit, you must include the -cp option to specify 
the class path for the JVM to find the Java classes. Make sure to include the current 
path so classes in the current directory can be found as shown in this example:

$JAVA_HOME/bin/java -cp .:./BasicRFID.jar MyClass

Java Support for Microsoft SQL Server and Sybase
The reader jTDS driver (version 1.2) provides JDBC capabilities to Java applications 
running on the reader. You need to include the location of the JDBC drivers in the 
class path with the environmental variable $JDBC_HOME. The JDBC drivers support 
JDBC 1.0 and:

• Microsoft SQL Server versions 6.5, 7, 2000, and 2005

• Sybase versions 10,11, 12, and 15

For more information, go to http://jtds.sourceforge.net.

Create an Installation Package
Before you can install your RFID application, you must create an installation pack-
age.

1. Create a configuration file.

2. Archive the installation files.

Create a Configuration File
When you create an application for the reader, you need to include a configuration 
file in the root directory of the archive so that the application can run on the reader. 

1. Open a text editor and type this syntax:

AUTOSTART=true|false

RUNAFTERINSTALL=true|false

CMDLINE=<Command line to start the application>
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where:

AUTOSTART specifies whether the application automatically starts when the 
reader boots.

RUNAFTERINSTALL specifies whether the application starts immediately after 
installation.

CMDLINE specifies the application name and optional parameters it accepts. 
Specify command line parameters as if the application is being executed from 
inside the directory containing the application.

2. Save the configuration file with the name userapp.conf.

Configuration File Example
This example auto-starts an application when the reader boots and runs an appli-
cation named testapp.exe:

AUTOSTART=true

RUNAFTERINSTALL=false

CMDLINE=./testapp.exe

Note: The reader executes applications from their installation directories, so the 
userapp.conf file does not need to include path information.

Archive the Installation Files
To install an RFID application on the reader, you need to package the configuration 
file and application.

1. Create a configuration file named userapp.conf.

2. Package the userapp.conf file and your application into one of these formats:
.zip, .tar/bz2, or .tar/gz file. Your application can now be installed on the reader.

Install RFID Applications
There are two ways to install your RFID application:

• Run the application on a remote server through TCP port 2189. All processing is
performed by the server.

• Run the application locally on the reader. The application resides on the reader,
and much of the processing occurs on the reader.

Install your application on the reader to improve system scalability by minimizing 
network traffic, so reader can handle processing tasks such as data filtering.
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Install Applications On the Reader
The reader provides up to 64 MB of storage for your applications. Use the web 
browser interface to install applications on the reader.

1. Log in to the web browser interface and click Edgeware Applications > Install
User Application.

2. Click Browse and follow the prompts to navigate to the location of the
application file.

3. Click Upload. The application is uploaded to the reader, placed in the /home/
developer/edgeware/userapp0 directory, and the application name appears in
the Edgeware Applications list.

Manage Applications
To maximize resources, you can start, stop, or uninstall applications on the reader.

Start an Application
By default, an application is stopped. You can start the application from the web 
browser interface.

1. Log in to the web browser interface and click Edgeware Applications > Appli-
cation Control. The Application Control screen appears.

2. Click  to start an application.

Stop an Application
Stop an application from running to reduce the amount of resources that the 
reader is using.

1. Log in to the web browser interface and click Edgeware Applications > Appli-
cation Control. The Application Control screen appears.

2. Click  to stop an application.

Uninstall an Application
Uninstall an application that you are not using to free up storage space on the 
reader.

1. Log in to the web browser interface and click Edgeware Applications > Appli-
cation Control. The Application Control screen appears.

2. Click  to uninstall an application.
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Auto-Start an Application at Boot Time
There are two ways to configure your application to auto-start when the reader 
boots:

• Through the web browser

• Through the configuration file you deliver with the application

Auto-Start an Application with the Web Browser
After an application is installed, you can easily configure the application to auto-
start through the web browser interface.

1. Log in to the web browser interface and click Edgeware Applications > Appli-
cation Control. The Application Control screen appears.

2. Click the Auto-Start check box and then click Activate Changes.

Auto-Start an Application with the Configuration File
When you package an application for installation on the reader, you need to 
include a configuration file. You can specify Auto-Start in the configuration file.

1. With a text editor, open the userapp.conf configuration file packaged with your
application.

2. In the command syntax, make sure AUTOSTART=true.

3. Save the userapp.conf file.

4. Repackage the updated configuration file with your application.

5. Upload the application to the reader through the web browser interface.

Edgeware Applications
Edgeware applications are supplied by Honeywell and its partner developers, and 
provide immediate functionality for your RFID system. 

Name Description

Developer Tools Used for basic testing of your RFID system. You can read RFID tags, send BRI 
commands, and run BRI scripts through these tools.

.NET Mono Are part of the firmware so that user can write Edgeware Apps related to .NET
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Install or Upgrade Edgeware Applications
Some Edgeware applications, such as the JamVM, are not installed on your reader. 
You can easily download, install, or upgrade your Edgeware appli-cations through 
the web browser interface.

1. Log in to the web browser interface and click Edgeware Applications > Install
Edgeware.

2. Click Browse to browse to the location of the firmware file, and then double-
click the file.

3. Click Install. The Edgeware application is installed on the reader. When the
installation is complete, the reader reboots.

Developer Tools
Developer Tools are used for basic testing of your RFID system. You can:

• Read RFID tags through the demo application

• Send BRI commands

• Run BRI scripts

Read RFID Tags through the Demo Application
Use the demo application to verify that your reader can read RFID tags.

1. Log in to the web browser interface and click Edgeware Applications > Appli-
cation Control. The Application Control screen appears.

2. If the Developer Tools are not enabled, click  .

3. Click Developer Tools > Reader Demo.

4. Place a tag near the antenna and then click Start.

Send BRI Commands
Use the Developer Tools to easily send BRI commands through the web browser 
interface.

1. Log in to the web browser interface and click Edgeware Applications > Appli-
cation Control. The Application Control screen appears.

2. If the Developer Tools are not enabled, click  .

3. Click Developer Tools > BRI Commands.

4. Enter a BRI command in the Command field and then click Run. The command
is executed and a value is returned.
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Run BRI Scripts
Run a BRI script to send multiple BRI commands to the reader.

1. Log in to the web browser interface and click Edgeware Applications > Appli-
cation Control. The Application Control screen appears.

2. If the Developer Tools are not enabled, click  .

3. Click Developer Tools > BRI Commands.

4. Click Browse and browse to the location of the BRI script.

5. Double-click the BRI script file.

6. Click Load. The script is loaded and run, and values are returned.
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GPIO PORTS
GPIO Interfaces
The reader has two general purpose input and output (GPIO) interfaces. You con-
nect external controls such as motion sensors or indicator lamps to the GPIO inter-
faces, which can then trigger reader operations.

Each interface is electrically isolated from the reader and designed for low voltage 
DC loads. The reader can also supply 5Vdc at 0.30 A to external devices.

The output interfaces (GPO1, GPO2) interfaces are limited to a maximum of 
150mWatts.

How the inputs and outputs are used depends on the RFID application software 
being used in the system. You need to coordinate input and output control wiring 
with the software developer.

Input Interfaces
Each of the two inputs is compatible with input signals of 4.5 to 28Vdc. Both the 
high and low signal contacts are exposed and isolated to 1500V. Input 
impedance is 1.8K ohms minimum.

In a typical application, the reader senses input from an external control like a 
switch and then starts a tag read operation.

There are three basic ways to connect input controls to the reader input interfaces:

• Supply the input interface with power from the reader

• Isolate the reader from the input power source.

• Use an open collector solid state drive from a remote device to control the
inputs.

Signal Description Min. Typical Max.

Vin (High) High input voltage 4.5V 24V 28V

Vin (Low) Low input voltage -1V 0V .8V
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Powered Input Example
The reader powered input the simplest way to connect a control to a reader input 
interface. If the external control device is a switch, you can connect one side of the 
switch to a reader +Input pin and the other side of the switch to one of the +5Vdc 
sources.

Reader Powered Input

Isolated Input Interface Example
Isolate the input interface to minimize noise induced by distance or grounding 
characteristics. The isolated input avoids induced noise by referencing a remote 
input to chassis return of the reader. 

Isolated Input Interface

Open Collector Input Interface Example
The input can be connected to an open collector interface of an external device. 
This open collector input interface typically implies that the grounds are tied 
together for the two systems. The common ground can be a source of input noise, 
so you should follow good grounding practices for both the reader and the input 
device.

In this situation, the reader provides power to the pull-up resistor for the open col-
lector. Connect the +Input pin to the +5Vdc source.

External
input
switch 

+Input

+5 V

Ground

- Input

+-

External 
input 
switch 

4.5 to 28 VDC
Twisted 
pair 

-Input

+Input
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Open Collector Input Interface

Each reader output interface is optically isolated from the reader, polarized, and 
rated 5 to 24VDC at 5mA. 

Because the outputs are optically isolated, each one can be configured to switch 
the high side or the low side of the load. You can power the load directly from the 
reader or from an external power supply.

In a typical application, the outputs control indicator lamps that signal good reads 
or errors. The basic methods for connecting external devices to the GPIO outputs 
include:

• Switching the high side, with the load powered by the reader

• Switching the low side, with the load powered by the reader

• Switching the high side, with the load powered externally

• Driving a DC relay that controls an AC load

These methods are shown in the following examples.

Switch the High Side with Reader Power
In this example, an external indicator lamp (0.25A maximum current) is connected 
to the -Output and Ground pins, and the corresponding +Output pin is connected 
to the +5VdC source.

+Input

+5 V

Ground

- Input

Signal Description Min. Typic
al

Max.

Leakage 
current 
(High)

Switch output, high leakage current 0mA 1mA 10mA

Vsat (Low)
Switch output on, saturation voltage with 5mA 
maximum current 0 V 1V 1.5V

Output Interfaces
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 Switching the High Side

Switch the Low Side with Reader Power
For low side switching applications, the lamp power is routed to all the lamps in 
common and the low side of the load is routed to the switch.

Connect the external indicator lamp to the +Output and +5Vdc pins, and short 
the corresponding -Output pin to ground.

 Switching the Low Side of the Output Load

Switch the High Side with External Power
To use external power (5 to 24Vdc) to switch the high side, connect the Ground 
pin to the ground system of the external power supply, and connect the positive 
side of the external supply to the +Output pin. The external indicator LED is 
connected to the corresponding -Output and Ground pins. 

External  
indicator lamp 
5mA maximum

+Output

+5 V

Ground

- Output

External  
indicator lamp 
5mA maximum

Ground

- Output

+Output

+5 V
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 Switching the High Side with External Power

Drive a DC Relay to Control an AC Load
While the reader outputs are designed to switch DC loads, they can also drive 
relays that control AC loads. 

Driving a DC Relay. The external relay provides dry contacts to the AC motor.

Note: In many installations, the relay and AC wiring must be placed in an enclosure that 
meets local fire code regulations.

External
indicator 
lamp

External
power
5-24 VDC

+ -

Ground

+Output

- Output

AC motor 

120-230
VAC

External 
relay 

+ Output

+ 5 V

Ground

- Output

Wiegand Support
The reader outputs can be used to provide Wiegand support for reading of tags.

The user App “myapp.zip” should be downloaded from the ftp site, 
https://hsmftp.honeywell.com.

The App should be installed on the Web interface. Log in to the web browser 
interface and click Edgeware Applications > Install User Application > choose 
file > upload
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Power Interface
The reader GPIO interface provides 5Vdc at 5mA for powering external inputs and 
loads, eliminating the need for an external DC supply and simplifying the system 
installation.

The GPIO interface power has an internal thermal fuse that trips if the load 
exceeds 0.5A. The fuse is self-recovering after the excessive load is removed. 

The total load on the GPIO interface power must stay within the 5mA limit. When 
you design a system that uses the GPIO interface power, make sure to complete 
a power budget assessment to ensure that the supply is adequate for the system. 
If your system needs more than 5Vdc at 5mA, you can connect an external power 
supply to the +5V and Ground pins. The external supply powers the external 
loads, and that power is available at all +5V pins on the GPIO port. 

ISO_V+

+5 V

ISO_V-

GND

GP output 0+

GP output 1+

Wiegand Data0

Wiegand Data1
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Upgrade Firmware
Upgrade the firmware on the reader through the web browser interface.

1. Download the firmware file for the reader from the Technical Support Down-
loads Portal at https://hsmftp.honeywell.com.

2. Go to:
Software
- RFID

- RFID Fixed Readers
- IF1

3. Double-click the file you downloaded and follow the prompts to extract the file
to your PC.

4. Log in to the web browser interface and click Maintenance > Firmware.

5. Click Browse to browse to the location of the firmware file, then double-click
the file.

6. Click Upgrade IF1 RFID Reader.

The upgrade process begins and the firmware is transferred to the reader.

Once the upgrade is complete, the login screen appears.

During the upgrade, the web browser interface screen does not auto-refresh.

To see Firmware Upgrade progress status, Go to Maintenance > System Log

(Click Refresh in the web browser to see the current progress of the upgrade).

Caution:  Make sure the reader is connected to a reliable power source before 
you upgrade the firmware. Do not cycle power to the reader during the 
upgrade. If power is lost during the upgrade, the reader may require 
factory repair.
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View the System Log
The system log shows events logged by the reader. You may need this information 
to troubleshoot the reader or when you call Product Support.

1. Log in to the web browser interface and click Maintenance > System Log.

2. (Optional) Click Export log to text file and follow the prompts to save the log
file to your desktop PC.

Restore Default Settings
If you have problems with the reader, use the web browser interface to restore the 
default settings.

1. Log in to the web browser interface and click Maintenance > Configuration.

2. Click Restore Defaults, and then click OK. The reader reboots and restores the
default configuration.

Reboot the Reader
If the reader or an application locks up, or if the reader does not respond, you may 
need to restart the reader.

1. Log in to the web browser interface and click Maintenance > Reboot.

2. Click Reboot, and follow the prompts to reboot the reader. The reader reboots
and restores the default configuration.

View Device Information
View the device information page to see the installed software versions, serial 
numbers, and other reader-specific information.

Log in to the web browser interface and click About.

Call Product Support
If you are having trouble using your reader, you can:

• Refer to Troubleshoot the Reader on page 37 to find your problem and possible
solutions.

• Refer to Technical Assistance (see page v).
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Troubleshoot the Reader 

Problems with RFID
You can solve many problems you may encounter when working with your RFID 
system by carefully checking the RFID settings and changing them accordingly. 

Problems with Connectivity
When you troubleshoot problems with connectivity, make sure you know your:

• TCP/IP settings

• COM port settings for serial connections

You should also make sure all physical network connectors and cables are in good 
working order.

Problem Solution

The reader is unable to read 
RFID tags, or seems to read tags 
slowly or inconsistently.

• Make sure your RFID antennas are connected correctly to
the reader and mounted in optimum locations. Make sure all
antenna connections are tight and that the cables are in
good condition. For help, contact your RFID system
consultant.

• Make sure you selected the correct tag types for your
application.

The reader does not respond to 
your RFID application.

• Your application may not be communicating with the reader
BRI server.

• You may need to change BRI server settings to communicate
with your application. For example, if your application is
running on a desktop PC, you need to enable external BRI
connections to the reader.

Problem Solution

You cannot connect to the reader 
through the USB port

• Make sure you downloaded the reader USB drivers.

• Verify that your serial connection is configured to 115200,
N, 8, none, no flow control.

You cannot connect to the reader 
using a web browser.

• Verify that you have the correct IP address for the reader.

• If you access the Internet through a proxy server, make sure
you add the IP address of the reader to the Exceptions list.

You cannot load a security 
certificate.

You must use a secure web browser connection to load 
certificates. 

You assigned a static IP address 
to the reader but cannot connect 
the reader over your network.

Make sure that DHCP is disabled and that your TCP/IP 
parameters are set correctly. 

Note: For Toll Application related troubleshooting, refer to Appendix A.
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IF1C Specifications

Note: Specifications listed may be different due to individual country regulations.

MECHANICAL

DIMENSIONS (LXWXH)

WEIGHT

Integrated antenna option: 265 mm x 186 mm x 75 mm (10.2” x 7.3” x 3.0”) 
2-port option: 265 mm x 186 mm x 59 mm (10.2” x 7.3” x 2.3”)

1.6 kg (3.5 lb)

ELECTRICAL

INPUT POWER 802.3af Power over Ethernet

DC ELECTRICAL RATING 44V, 0.35A

GENERAL PURPOSE INPUT/OUTPUT (GPIO) 2 inputs, 2 outputs (configurable to Wiegand outputs)

COMMUNICATIONS 10/100 BaseT Ethernet, Wiegand, USB & RS-232 for configuration

ENVIRONMENTAL

ENVIRONMENTAL SEALING IP66 with Ethernet cable housing kit and IP66 compliant DB15 connector cable when in use

OPERATING TEMPERATURE

STORAGE TEMPERATURE

HUMIDITY

-20 °C to 65 °C (-13 °F to 149 °F)

-30 °C to 75 °C (-22 °F to 167 °F)

10% to 95% relative humidity, non-condensing

RF CHARACTERISTICS

FREQUENCY RANGE

READ RANGE

TRANSMIT POWER

865-867 MHz, factory configured

Around 10m*

Up to 30 dBm (1 W)

INTERNAL ANTENNA 7 dBiL integrated linear antenna
6.5 dBiC integrated circular antenna

SOFTWARE

UHF TAG PROTOCOLS EPCglobal UHF Class 1 Gen 2 (Versions 1.x and 2), ISO 18000-6C, 128-bit AES/ GRAIN cryptographic 
security extensions

OPERATING SYSTEM Linux

APPLICATION INTERFACE Basic Reader Interface (BRI), EPCglobal Low-Level Reader Protocol (LLRP)

APPLICATION SUPPORT Java, C#, .NET Resource Kit for BRI

USER MEMORY 64 MB

*Note : Depends on RFID Tag Type and Installation conditions.
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Port Pin Assignments
Use this section to understand the port pin assignments for the ports located on 
the reader.

GPIO Port
The GPIO port allows GPIO communications with your reader. 

Pin Function Description

1 +5Vdc +/-10% Non-isolated wetting supply, 300mA max

2 H O S T _ R X

3 H O S T _ T X

4 NC

5 GND Non-isolated signal ground

6 NC

7 NC

8 NC

9 ISO_V- Isolated common return for GPIO input and outputs

10 ISO_V- Isolated common return for GPIO input and outputs

11 GP output 0+ Isolated GP output (open collector, 5 - 28V max, 5mA maximum 
continuous)

12 GP output 1+ Isolated GP output (open collector, 5-28V max, 5mA maximum 
continuous) 

13 GP input 0+ Isolated GP input Vin low = -1V to 0.8V max; Vin high = 4.5V to 
28V max 

14 GP input 1+ Isolated GP input Vin low = -1V to 0.8V max; Vin high = 4.5V 
to 28V max

15 ISO_V+ Isolated external power for GP out pullups 
(28Vdc max) 

1

11

10

5

15

6

RS232 Receive

RS232 Transmit
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Ethernet Port
The Ethernet port allows Ethernet communications and Power-Over-Ethernet. Use 
the illustration to understand the port pin assignments.

Pin Description

1 Ethernet TX+/Spare POE return

2 Ethernet TX-/Spare POE return

3 Ethernet RX+/Spare POE 48Vdc

4 POE 48Vdc

5 POE 48Vdc

6 Ethernet RX-/Spare POE 48Vdc

7 POE return

8 POE return

Pin 1
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Appendix A: Troubleshooting Guide for Toll Application 
The below-mentioned troubleshooting steps help to improve the performance of the IF1C reader in the 
customer field. (Electronic toll collection). 

1. Steps to change the channel number
2. Steps to make duty cycle off
3. Steps to update EPCC1G2 Parameter Set

*The RFID performance could vary depends on the environment where it is used and the type of tag 
used.

Steps to change the channel number 

1) Connect Putty session using the reader IP Address.
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3) Give “attrib” command

4) Give attrib command to update channel
“attrib channel=4
OK>”

If the reader gives problem in reading the tags in the default channel, then the user can follow the above steps to change 
to different channel to check the readability. 
Note: This channel setting is instance specific. i.e. The changed channel valid only to that particular instance of the 
connection, other client connections takes the default channel value set in the webpage. (Webpage channel settings 
options has been introduced on/after FW-247) 

2) You will get BRI prompt with “OK>”



Steps to make duty cycle off 
1) Connect Putty session

2) You will get BRI prompt with “OK>”



Steps to update EPCC1G2 Parameter Set 

1) Navigate to BRI Attributes

3) Update the duty cycle to “OFF” by using following util commands



3) Select Antenna 1, in case only integrated antenna is used.

2) Enable EPCC1G2 Advance Medium Access Mode & Select ID as 18 or 27 in drop down menu in
below field. Example shows Select ID as 18.



4) Navigate to maintenance & press reboot to reboot the reader.
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