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Support information  

For technical information and assistance about Connected Components Workbench (CCW): 

Support phone: +1-440-646-3434 

Website: http://support.rockwellautomation.com 

For information about additional support options you can access from the Help menu, see 
Access user assistance. 
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New features and enhancements Back to top 

Extended device support: Powerflex 523 

PanelView Component enhancements 

Usability enhancements 

Extended device support: Powerflex 523 
This release of Connected Components Workbench supports a new PowerFlex 520-series 
drive while continuing to support all controllers and devices from previous releases. The 
PowerFlex 523 provides embedded EtherNet/IP™ communications, USB programming, and 
standard safety features. Add the PowerFlex 523 to your project from the Drives folder in 
the Device Toolbox. 

PanelView Component enhancements 
PanelView Component DesignStation 5.0 includes enhanced drawing tools, report generation 
and a new undo/redo feature. See the Release Notes (2711C-RN010-EN-E) for details. Go to 
Resources available from the Literature Library for information on obtaining the latest 
version of the Release Notes.  

Usability enhancements 
This release includes the following additional folders in the Device Toolbox. 

 Safety 

 Motor Control 

 Soft Starters(under Motor Control) 

The following devices are available in the new folders and can now be added to your project 
from the Device Toolbox.  

Device Description 

MSR57 Available in the Safety folder 
Speed monitoring safety relay provides standard outputs to control 
drive speed and safety outputs to control the outputs of the drive.  

SMC-50 Available in the Motor Control > Soft Starters folder 
Smart motor controller provides microprocessor-controlled, solid-state 
(SCR, no bypass) starting for standard three-phase squirrel-cage 
induction or Wye-Delta (6-lead) motors.  

SMC Flex Available in the Motor Control > Soft Starters folder  
Smart motor flex controller provides microprocessor-controlled starting 
for standard 3-phase squirrel-cage induction or Wye-Delta (6-lead) 
motors. 
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System requirements Back to top 

Hardware requirements 

Operating system requirements 

VMWare compatibility 

For additional Rockwell Automation product compatibility information 

Micro800 firmware requirements 

Hardware requirements 
To use this release effectively, your personal computer should meet the following minimum 
hardware requirements:  
 

Component Minimum requirement Recommended 

Processor Pentium 3 or better Pentium 4 or better 

RAM memory 1 GB 2.0 GB or more 

Hard disk space 9.0 GB free 10.0 GB free or more 

Optical drive DVD-ROM DVD-ROM 

Pointing device Any Windows-compatible 
pointing device 

Any Windows-compatible pointing 
device 

Operating system requirements 
This release is supported on the following operating systems:  

 Microsoft Windows 7® (32-bit and 64-bit) 

VMWare compatibility 
Compatibility with VMware® has not been formally tested, but it has been used extensively 
with Connected Components Workbench.  

 If you use Connected Components Workbench with VMware, you may have to 
manually switch USB connections between the guest and the host.  

 If you experience poor performance using VMware with a Window 7 guest, you may 
need to upgrade VMware or run Connected Components Workbench on the host 
operating system. Connected Components Workbench and other software may try to 
access the networks, to ensure optimal system performance, you may need to disable 
network adapters. 
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Rockwell Automation® software compatibility 
This release has been successfully tested with the Rockwell Automation software products 
listed in the following table. 
 

Software Tested version 

RSLinx® Classic 3.60 

ControlFLASH™ 12.00 

Specific software compatibility requirements 
RSLinx Classic v3.60, Logix Designer v21.00, and the device profiles that ship with Logix 
Designer v21.00 are not compatible with the following: 

 RSNetWorx v11.00 or earlier 

 DeviceNet Tag Generator v11.0 or earlier 

RSNetWorx and the DeviceNet Tag Generator must be upgraded prior to installing these 
products. If the computer does not meet the requirements, you will receive a message 
describing the deficiency, and the installation will stop. The following table summarizes the 
requirements and installation results. 

Requirement Installation results 

RSLinx Classic 

Must be installed on 
the computer. 

The installed version 
must be v2.59.01 or 
later.  

If the RSLinx Classic v3.60.00 install option is selected 
(default) it will install in the following circumstances, and the 
installation will continue: 

• If an incompatible version of RSLinx (v2.59.00 or earlier) is 
detected. 

• If no version of RSLinx is detected.  

RSNetWorx 

The installed version 
must be v2.59.01 or 
later. 

If an incompatible version of RSNetworx (v11.00 or earlier) is 
detected, the installation will stop, and you will need to do one of 
the following to successfully install CCW: 

• Remove the incompatible version of RSNetworx. 

• Upgrade the incompatible version of RSNetWorx to v21.00 or 
later.  
 
Tip: RSNetWorx v21.00 is available in Studio Professional 
v21.00 

After you resolve the incompatibility, restart the CCW installation.  
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For additional Rockwell Automation product compatibility information 
Connected Components Workbench has been tested to interoperate with most Rockwell 
Automation software.  

For the latest information about software platform support refer to 
http://www.rockwellautomation.com/rockwellautomation/support/pcdc.page. 

For the latest drivers and firmware updates refer to 
http://www.rockwellautomation.com/rockwellautomation/support/overview.page.  

Micro800 firmware requirements 
Following are the Micro800 firmware selections for the current release: 

 Micro810 controllers – major revisions 1.xxx, and 2.xxx 

 Micro830 controllers – major revisions 1.xxx, 2.xxx, and 4.xxx 

 Micro850 controllers - major revisions 2.xxx and 4.xxx. 

To view the latest Micro800 controller firmware information, see Micro800 Programmable 
Controllers Release Notes (2080-RN001_.pdf) located in the following locations: 

 The Release Notes folder on your installation media, or  

 In the Program Files\Common Files\Rockwell\Help folder after you install Connected 
Components Workbench.  
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Installation and upgrades  Back to top 

Using existing projects in current release 

Install Connected Components Workbench 

Upgrade Connected Components Workbench Release 

Convert a project to the current release 

Remove Connected Components Workbench 

Install a different language edition of Connected Components Workbench 

Install Ultraware 

PanelView Component firmware requirements 

Components installed with Standard Edition and Developer Edition 

Components installed only with Developer Edition 

Using existing projects in current release 
You can open projects created in previous releases without updating the controller firmware 
or performing a manual project conversion. However, if you want to use the most current 
features with your existing projects, you must perform additional tasks to convert the 
project to the current release after you upgrade Connected Components Workbench. If you 
do not need new features, your controller project may remain at its current major revision.  

We recommend you record device configuration information related to Modbus mapping, 
Interrupts, Serial Port settings and Embedded I/O for any existing projects before you 
upgrade. 

If you open a controller project created in a previous release, and then save it, you will not 
be able to open the project using the previous release. If it is a shared project, all users 
must upgrade to the current release of Connected Components Workbench.  

See Convert a project to the current release for project conversion tasks.  

Install Connected Components Workbench 
Follow these steps to install Connected Components Workbench.  

1. Obtain the full installation of Connected Components Workbench. (Standard Edition 
or Developer Edition). 

2. Launch CCWSetup.exe. 

3. Follow the prompts in the Connected Components Workbench Setup window.  
Note: CCW determines the correct components to upgrade and/or install. If there is 
a reboot requirement, reboot the operating system so the install can complete 
successfully. 

4. When the installation is complete, click Finish.  

Note: If you install the Standard Edition, you can later upgrade to the Developer Edition 
using the Upgrade To Developer option. However, the Developer Edition requires activation.  
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Upgrade Connected Components Workbench Release 
Use this procedure to perform any of the following upgrade types. 

• Upgrade from an earlier release to the current release.  
• Upgrade to an English version - obtain the ENG version (Standard Edition or Developer 

Edition). From where? 
• Upgrade from the Standard Edition to the Developer Edition - select the 

UpgradeToDeveloper option during installation. 

Before you begin 

Record device configuration information related to Modbus mapping, Interrupts, Serial Port 
settings and Embedded I/O for all existing projects. 

To upgrade 

1. Launch CCWSetup.exe. 

2. Follow the prompts in the Connected Components Workbench Setup 5.0 window. 
Note: Connected Components Workbench determines the correct components to 
upgrade.  

3. Click Finish when the upgrade is complete. 

4. If you are prompted to select Online or Local Help the first time you launch the Help, 
select Local.  

5. If you want to use the most current features on projects created in previous 
releases, follow the steps in Convert a project to the current release.  

Note: After you open and save an existing controller project, you will not be able to 
open it with a previous release. 

Convert a project to the current release 
When you open a project that was created in a previous release, the project database is 
automatically updated to the current release. To use current features, however, you must 
complete the following additional tasks. 

• Open the project in the current release and export files 

• Create a new project in the current release and import files 

• Reconfigure devices 
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Open the project in the current release and export files 

Follow these steps to convert the project database from an earlier release to a current 
project database, and to export the project elements and global variables.  

1. Start the current release of Connected Components Workbench. 

2. Click File > Open and navigate to the prior release project location. 

3. Click the project created in a previous release and then click Open to start the 
Project Updater. 

Note: The project database updates to the current release, but does not yet include 
features available in the current release.  

4. Click Save. 

5. In the Project Organizer, right-click the Micro800 controller, and then click Export 
> Export Device. 

6. Export the project elements: 

• On the Import Export dialog box, click the Export Exchange File tab. 

• Verify all checkboxes are cleared. 

• Click Export. 

• From the Save As dialog box, navigate to the export location, type in a new 
file name (optional) and click Save.  

• Close the Import Export dialog box. 

7. In the Project Organizer, right-click the Micro800 controller, and click Export > 
Export Device. 

8. Export the global variables: 

• On the Import Export dialog box, click the Export Exchange File tab. 

• Select Export Variables Only. 

• Click Export.  

• From the Save As dialog box, navigate to the export location, type in a new 
file name (optional) and click Save. Note: By default, the word “Variables” is 
added to a variables only file name. 

• Close the Import Export dialog box. 

9. To create a new project in the current release, go to Create a new project in the 
current release and import files. 
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Create a new project in the current release and import files 

Follow these steps to create a new project in the current release and then import the project 
elements and global variables you previously exported. 

1. Click File > New to create a new project. 

2. On the Device Toolbox, double click the same type of Micro800 controller that was 
used in your project from the previous Release.  

3. On the dialog box, select the most current Micro800 controller revision in the Major 
Revision field, and then click OK.  

4. On the Project Organizer, right-click the controller, and then click Import > 
Import Exchange File. 

5. Click Browse, and then navigate to the location of the device file you previously 
exported. 

6. On the Select Import Exchange File dialog box, click the file and then click Open. 
Note: An Import Export error indicating the target device does not match the file 
device appears because the devices have different major firmware revisions. This is 
expected behavior.  

7. Click OK to continue. 

8. Import program elements and local variables only: 

• Expand all the elements under the Micro800 controller, and clear the 
Micro800 check boxes. 

• Verify the program element check boxes are selected, and click Import.  

• Close the Import Export dialog box. 

9. Click Save. 

10. From the Project Organizer, right-click the controller, and then click Import > 
Import Exchange File. 

11. Import global variables: 

• Click Browse and navigate to the location of the global variables only file you 
previously exported. 

• On the Select Import Exchange File dialog box, click the file and then click 
Open.  

• On the Import Exchange File tab, verify the Variables checkbox is 
selected, and click Import.  

• Close the Import Export dialog box. 

12. Click Save. 
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Reconfigure devices 

To complete the conversion of projects created in a previous release, you will need to 
manually configure the following devices and options that were used in the project. 

• Modbus mapping 

• Interrupts 

• Serial Port setting 

• Embedded I/O 

Note: Modbus mapping information is stored in the MbSrvConf.XML file located in the CCW 
project structure: CCW\<projectname>\controller\controller. 

Remove Connected Components Workbench 
Follow these steps to remove Connected Components Workbench components. To remove 
non-CCW components installed with Connected Components Workbench, remove each 
component separately after removing Connected Components Workbench.  

1. Go to Control Panel > Programs and Features. 

2. Right-click Connected Components Workbench and click Uninstall.  

3. Remove other components as necessary. See Components installed with Connected 
Components Workbench. 

Install a different language edition of Connected Components Workbench 
Follow these steps to install a language edition of Connected Components Workbench that is 
different from the one currently or previously installed. For example, to install Connected 
Components Workbench (English) on a computer that previously had Connected 
Components Workbench (French) installed. 

Important: Remove CCW before you remove Microsoft Visual Studio Shell or you will not 
be able to remove CCW. 

1. Remove Connected Components Workbench, and then verify Connected Components 
Workbench does not appear in the list of installed programs. 

2. Remove the current language edition of Microsoft Visual Studio Shell 2008 Service 
Pack 1. 

3. Obtain the full installation of the Connected Components Workbench edition you wish 
to install.  

4. Launch CCWSetup.exe, which will re-install Connected Components Workbench and 
the correct version of Microsoft Visual Studio Shell.  

5. Follow the prompts in the Connected Components Workbench Setup window.  

6. When the installation is complete, click Finish.  
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Install Ultraware 
Connected Components Workbench installation media includes Ultraware software, which 
you can use to configure, monitor and diagnose Kinetix drives. Follow these steps to install 
Ultraware. 

1. Browse to \Other Software\Ultraware in the Connected Components installation 
folder.  

2. Double-click Ultraware_1_8x.exe.  

3. Follow the installation wizard to complete the installation. 

PanelView Component firmware requirements 
PanelView Component DesignStation is installed with Connected Components Workbench 
and can be accessed from the Project Organizer after you add a Graphic Terminal device. 
To use the newest PanelView features in Connected Components Workbench, you may need 
to upgrade the PanelView component firmware. 

To determine the latest available PanelView firmware: 

1. Access the latest PanelView Release Notes: 

• Go to http://literature.rockwellautomation.com. 

• Type PanelView Release Notes in the search box in the top right corner, and click 
the search icon. 

2. Open the release notes, and review the information in the “Firmware Requirements” 
topic. 

To access PanelView firmware: 

• Go to the PanelView Component C400 Terminals website: 

http://ab.rockwellautomation.com/Graphic-Terminals/2711C-PanelView-Component-C400-
Terminals#/tab6 
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Components installed with Standard Edition and Developer Edition 
The following additional components are installed with both the Standard Edition and the 
Developer Edition. If you uninstall Connected Components Workbench, these components 
will not be removed because other software may be using them. 

Type Includes 

Rockwell 
Automation 

• ControlFLASH™ 12.00  
• Rockwell Windows Firewall Configuration Utility 1.00 
• Rockwell Automation USB CIP Driver Package (x86) or 

Rockwell Automation USB Driver Package (x64) 
• RSLinx Classic 3.60 
• Unified Device Configuration 

Microsoft .NET 
Framework 4 

• Microsoft .NET Framework 4 Client Profile 
• Microsoft .NET Framework 4 Extend 

Microsoft Visual 
Studio 2010 
Isolated Shell - 
ENU 

• Microsoft .NET Framework 4 Multi-Targeting Pack 
• Microsoft SQL Server 2008 R2 Management Objects 
• Microsoft SQL Server System CLR Types 
• Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729 
• Microsoft Visual C++ 2010 X86 Runtime - 10.0.30319 

Microsoft - 
other 

• MSXML 4.0 SP2 Parser and SDK 
• Microsoft Help Viewer 1.1 (Standard Edition only) 
• Microsoft SQL Server Compact 4.0.8482.1 

OPC • OPC Core Components Redistributable (x86) 101.2, or 
• OPC Core Components Redistributable (x64) 101.2 (if the 

operating system is 64-bit) 

Other • Virtual COM Port Device Driver 6.3a 
• Adobe Reader 11.0 

Components installed only with Developer Edition 
The following additional components are installed only with Connected Components 
Workbench Developer Edition. If you uninstall Connected Components Workbench, these 
components will not be removed because other software may be using them.  

Type Includes 

Microsoft Visual 
Studio 2010 
SP1 

• Microsoft Visual Studio 2010 Tools for Office Runtime (x86) 
• Microsoft Visual Studio 2010 Service Pack 1 

FactoryTalk • FactoryTalk Activation Manager v3.60.00 (CPR 9 SR 6) 
• FactoryTalk Diagnostics v2.60.00 (CPR 9 SR 6) 

 

Publication CC-RN001D-EN-P – September 2013 



Connected Components Workbench Release 5.00.00 13 

Helpful resources Back to top 

User assistance available from the Help menu 

Technotes available from the Rockwell Automation Knowledgebase 

Resources available from the Literature Library 

User assistance available from the Help menu 
From the Help menu, you can access online information such as user manuals, user forums, 
support e-mail, and the Rockwell Automation Knowledgebase.  

To access Rockwell Automation support websites, register (Become a Member) at 
http://ab.rockwellautomation.com/. 

Tip: Many of the application elements have context-sensitive help available (F1). If context-
sensitive help is not available, click Help > Search and enter the topic in the search box.  

Technotes available from the Rockwell Automation Knowledgebase 
The Rockwell Automation Knowledgebase contains Micro800-specific technotes. You will 
need to log into the Knowledgebase to view technotes.  

http://www.rockwellautomation.com/rockwellautomation/support/americas/us.page  

Micro800 technotes 

• Micro800 basic FAQ - answer ID 116930 

• Micro800 extended technical FAQ - answer ID 118815 

Tip: You can also access technotes by typing in the Rockwell Knowledgebase answer ID (for 
example: 116930 - this is also the technote number) in the Search box. 
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Resources available from the Literature Library 
You can view or download publications from the Rockwell Automation Literature Library, 
including the following: 

• PanelView Component DesignStation Release Notes 

• Ultraware Software User Manual 

• Kinetix 3 user manuals and Kinetix Rotary Motion Specifications  

• Non-English language versions of user manuals 

To access manuals from the Rockwell Automation Literature Library: 

1. Go to http://literature.rockwellautomation.com. 

2. Click Advanced Search.  

3. Enter the product information and other search criteria, and click Search. 
For example, type PanelView Component in the search box and click the search icon 
to find relevant user documents, including the latest release notes.  

To access non-English language versions of user manuals: 

1. Go to http://literature.rockwellautomation.com. 

2. Select the language from the Publication Language drop-down box (right corner). 

3. Enter the full or partial device catalog number the Search box. For example, enter 
2080-LC30 to view Micro830 user manuals.  
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Important considerations Back to top 

IEC-61131 standards 

Programming, configuring and debugging 

Uploading, downloading and building 

IEC-61131 standards 
Connected Components Workbench adheres to the IEC-61131 standards for programming. 
If you do not have previous experience with IEC-style concepts and programming, we 
recommend you review the “Getting Started with Developing” section in the software help. 
The topics, which step you through the process of creating a basic sample application, are 
intended to introduce you to IEC-style programming within the Connected Components 
Workbench environment. 

Programming, configuring and debugging 
 Unless specifically stated in user documentation, do not change attributes in Property 

dialogs. 

 Some features that should be disabled appear available while the debugger is 
operating. A small subset of these features may cause Connected Components 
Workbench to close unexpectedly. If you recently started the debugger, ensure you 
stop it before performing other software operations. 

 Connected Components Workbench does not automatically update the instances of 
UDFBs (User-Defined Function Blocks) referenced in existing programs. To update 
every instance of the UDFB, search for it and update each one manually. 

Uploading, downloading and building 
 When you build a controller project with Connected Components Workbench, all 

changes are immediately committed to your hard drive or to your designated storage 
device so you will not be able to undo any changes. To ensure you can return your 
project to a prior state, save the project using a different name after making changes. 

 If the Upload or Download options are not available in the Device Configuration 
toolbar, select the Micro800 controller from the Project Organizer, and then click 
Upload or Download. If this does not activate upload/download, rebuild the project 
by right-clicking the controller in the Project Organizer and selecting Build. 
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Resolved anomalies Back to top 

Resolved controller, devices and project anomalies  

This section identifies anomalies that have been resolved since the last release of Connected 
Components Workbench. 
 

Resolved controller, device and project anomalies Back to top 

If you configure the appearance of an object in a PVc application using the transparency 
background color, it does not appear as transparent in the DesignStation in Connected 
Components Workbench but the object background is transparent when the application runs 
on the terminal. [APBC00014590] 
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Known anomalies Back to top 

Installation 

Projects, documentation and tools 

Controllers and devices 

Variables 

Instruction blocks 

Programs 

Import and export 

Build, debug, download and upload 

 

This section describes known anomalies in this release and, if needed, provides 
workarounds. 

Installation Back to top 

If you attempt to upgrade CCW Release 2 to CCW Release 5, you may receive the following 
Microsoft error: 

“Error 1935. An error occurred during the installation of assembly component.” 
[APBC00017007] 

Workaround: If this error occurs, restart the computer, and then restart the CCW 
installation. If the problem persists, see Article 926804 in the Microsoft Knowledgebase: 

http://support.microsoft.com/kb/926804.  

If you install Connected Components Workbench in a folder that uses special characters (for 
example, 's@#') in the name, the installation may fail. If the installation is successful, you 
still may receive a ReportFatalError message when you first create a project. 
[APBC00011700] 

Workaround: Install CCW in the default folder. If you create a new installation folder, do 
not use special characters in the name.  

If you install Connected Components Workbench without installing RSLinx, the Micro830 
and Micro850 controllers with firmware revision 4.x are not recognized when you open 
RSLinx Classic. In CCW you can connect, upload, download, and debug functions using the 
unrecognized device.[APBC00015286] 

Workaround: If this happens, you can register the Electronic Data Sheets (EDS) files for 
the controllers with firmware revision 4.x so they are recognized in RSLinx Classic.  

1. Navigate to: 
C:\Program Files\Rockwell Software\RSCommon 

2. Use the RSHWare.exe to register the EDS files. 
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Installation Back to top 

If Connected Components Workbench does not install completely, restart the computer and 
then re-install CCW. After the restart, the installation will complete successfully. Some 
Microsoft components may require a restart before the full CCW installation is complete. If 
this happens, restart CCW. [APBC00015137] 

If you choose to install only some of the Connected Components Workbench components, 
the numerical value in the Hard drive space required to install field may not update and 
reflect the true values. [APBC00005174] 

If you install Connected Components Workbench on a Microsoft Windows operating system 
using a non-Administrator user account, the following message appears:  

"Do you want to allow the following program to make changes to this computer?”  

To continue the installation, you must enter a user name and password with Administrator 
privileges and then click OK. 

When the installation is complete, note the "CCW", "CHMI", "Rockwell Automation" and 
"Visual Studio 2010" folders are all created in the Administrator user path. 
"\Users\<administrator name>\Documents" 

These folders should be created in the standard user path: 
"\Users\<standard username>\Documents" [APBC00012930] 

If you open Connected Components Workbench with a user account that is different than 
the one used when it was installed, the display settings for the Global Variables grid will 
be different than the default settings in the original user account. [APBC000010625] 

Workaround: To return the display settings to the default values: 

• Click Tools > Options > IEC Languages > Ladder Diagram. 

• Under View Settings, enter the following options: Default Cell Height – 50, Default 
Cell Width – 100, Display Grid – False.  
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Installation Back to top 

If you install Connected Components Workbench as an Administrator and then log in as a 
Guest user, you are unable to open or create new projects in CCW. [APBC0007247], 
[APBC00011371] 

Workaround: To use the Guest user account follow these steps: 

1. Navigate to: 
:\\Program Files > Rockwell Automation > CCW 

2. Right-click CCW.Shell.exe, select Run as..., select Administrator user.  

3. Click OK. 

Or, create a new Guest user account to open and create new projects in CCW: 

1. Open Control Panel ->Administrative Tools-> Computer Management->Users. 

2. Right-click Users and then select New User. 

3. In the New User dialog box, enter the new user name and password and click 
Create. 

4. From the list of users, right-click <new user name> and select Properties. 

5. Select the tab, Member of, and then remove "Users" and add "Guests" to the list. 

6. Click OK. 

When Connected Components Workbench is installed on a computer where Visual Studio 
2010 Service Pack 1 was installed previously, an error message appears when you launch 
the CCW application. [APBC00012880]  

Workaround: If this happens follow these steps: 

1. Close all Visual Studio products. 

2. Install Visual Studio 2010 Service Pack 1.  

3. If the Setup starts in Maintenance mode, select Repair.  

When ControlFLASH 12.00 is installed on a PC and an older firmware kit is accessed an 
error message appears:  

“There is a problem with this Windows installer package. A script required for this install to 
complete could not be run. Contact your support personnel or package vendor.” 
[APBC00015312]  

Workaround: If this happens follow these steps: 

1. Click OK. 

2. Navigate to: 
C:\Program Files\Common Files\Rockwell\CFOldKits\CFBinaries\README.TXT 

3. Right-click README.txt and select Properties. 

4. Clear the Read-Only check box. 

5. Click OK. 

6. Continue to uninstall ControlFLASH. 
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Projects, documentation and tools Back to top 

Some help topics related to new devices have not been updated in this release. The new 
information, which is minimal, related to the changes includes the following: 

• The USB Import/Export tab in the device Properties dialog box has been renamed to 
Import/Export and the procedure steps have changed. See Import/Export drive 
configurations. 

• The Device Toolbox Catalog contains additional folders and devices. See Extended 
device support for a list and description of the new devices. [APBC00017010] 

In the Block Selector, when you select the ‘*’ or ‘+’ operator from the list, the Inputs 
field appears. If you increase or decrease the value in the Inputs field and click OK, the 
change in the number of inputs display in the FB-POU. If you click Show Parameters in 
the Block Selector and change the number of inputs, the number of inputs shown in the 
image does not change. The inputs will display correctly in the editor and in any subsequent 
use of the variable selector. [APBC00014948]  

If you open an earlier project with a newer major version of Connected Components 
Workbench, even if you target a Micro800 device to an older project version, the overall 
project will be updated to the newer version of CCW. Although the new project can be 
downloaded to the specified target Micro800 version, any subsequent attempt to upload or 
open the project will require the newer Connected Components Workbench version. 

If you try to open a project created in a release later than the currently installed release, 
you may not get a specific warning message to upgrade to the latest version. [APBC00012533] 

Workaround: Upgrade the version of CCW from the support website 
http://www.rockwellautomation.com/rockwellautomation/support/overview.page  

If you configure the appearance of an object in a PVc application using the transparency 
background color, it does not appear as transparent in the DesignStation in Connected 
Components Workbench but the object background is transparent when the application runs 
on the terminal. [APBC00014590] 

When a project is renamed in Connected Components Workbench the spy lists are re-
created but system variables such as __SYSVA_CYCLEDATA are removed. If this happens 
add any missing system variables to the spy lists in the renamed project. [APBC00014923 ] 

If you open multiple projects on a network drive using File > Recent Projects, and then 
exit or close CCW, the application may not close immediately. [APBC00014847] 

If you import or open a project that was created in an earlier release and Build the project, 
the embedded file size increases. For large projects the embedded file size may exceed the 
limit which results in a build error. [APBC00014949] 

The Control Line parameter option, Half Duplex With continuous carrier, was 
removed. If you import or open a project that was created in an earlier release, the Half 
Duplex With continuous carrier parameter is changed to Half Duplex w/o continuous 
carrier (RTS/CTS). This change has no impact on program execution. [APBC00013138] 
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Projects, documentation and tools Back to top 

If you press the F1 key, and it is the first time the Help is launched, the Online Help 
Consent dialog box appears. If you click Yes, the setting for the Help is set to “I want to 
use online help” and the Help topic does not appear. [APBC00015166] 

Workaround: If the Online Help Consent dialog box appears the first time you launch 
the Help after pressing F1, click No. The setting for the Help is set to “I want to use local 
help” and the CCW Help topic will appear as expected. 

Content for the following features appears in English in the non-English versions of 
Connected Components Workbench 3.0: Tooltips for the Instructions; DeviceLogix 
Editor information; information in the Category and Comment columns of the 
Instruction Block Selector. [APBC00013270] [APBC0012299] [APBC00012607] 

If you add a Block element to a Program (POU) in the non-English versions of Connected 
Components Workbench 3.0, rename the POU in the Project Organizer and then click 
Save or Build a “Detected… modification” error may appear. [APBC00013784]  

Workaround: Close the error dialog and continue.  

If you use the Document Generator to create documentation for Programs (POU) that 
contain large Ladder Diagrams, the generated document might incorrectly display the 
picture of the Ladder Diagram as a black image. If you encounter this issue, possible 
workarounds include using a different document viewer or creating partial reports by 
selecting individual sections of the project to generate. [APBC00013865] 

The following content in the Document Generator appears in English in the non-English 
versions of Connected Components Workbench 3.0: ToolTips for None and Scale. 
[APBC00013946] 

The labels for Browse and No header or footer in the Document Generator for the 
non-English versions of Connected Components Workbench 3.0 may be truncated. For 
example, the label ‘Durchsuchen’ appears as ‘Durchsuche’. [APBC00013944] 

The Quick Find and Quick Replace features (Ctrl+F and Ctrl+H) are limited to programs. 
They do not work with devices, global variables or UDFBs. Additionally, Quick Find has the 
following limitations:  

 It does not find any items when the Look In selection is Current Project or Entire 
Solution.  

Workaround: To find items in the project, click Edit > Find and Replace > Quick 
Find, and click Current Document or All Open Documents in the Look In drop-
down box. 

 It may not locate all instruction blocks within all containers in the project. 

 It does not find all instances of the same Array element variable in all the programs 
within a project.  

The Quick Find and Quick Replace features will be enhanced in a future release. 
[APBC00011723] [APBC00011079] [APBC00011080] [APBC00011462] 
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Projects, documentation and tools Back to top 

If the appearance settings in your operating system use a high-contrast color theme, some 
workspace elements will display incorrectly. For example, ladder rungs and connectors in 
the program editors, graphics and toolbar in the Controller Details view, and the Device 
Toolbox. [APBC00011574] [APBC00011577] [APBC00011578] 

Workaround: Do not use a high-contrast color scheme. 

Context-sensitive help is not available for some elements in the Structured Text editor. 
[APBC00011459] 

Workaround: To find information on a specific topic, click View Help and then enter the 
topic in the search box. 

If you select View > Document Overview while in the Structured Text language editor, 
the Document Overview displays a blank page. [APBC00004685] 
 

Controllers and devices Back to top 

If you attempt to upload a project file that contains a user-defined type array while the 
Structure elements are expanded in the Data Type window, the Upload may not complete 
as expected. [APBC00015210] 

Workaround: If this happens close the Data Type window, and then upload the project 
file. 

If you remove all the characters in the Name textbox in the Controller Configuration 
pane, you might receive the following error message: 

“Controller name cannot be empty,” even though the focus is still in the Name textbox. 
[APBC00011369] 

An interrupt may still display in the Controller - Interrupts page even after you delete the 
program in which the interrupt was configured. [APBC00011541] 

Workaround: Click on any other node other than Interrupt in the Controller tree. Or, 
build the project. 

After you save a project using Save As, the controller changes from connected to 
disconnected. [APBC00007400] 

When you configure an Event Input Interrupt (EII), you can specify which input to use from 
the Configure Event Input Interrupt (EII) dialog box. You cannot, however, specify the 
edge triggering type (rising or falling edge) from the same dialog box. [APBC00005579] 

Workaround: To specify the EII edge triggering type (rising or falling edge), click 
Embedded I/O in the controller tree and configure the Properties in Input Latch and 
EII Edge. 
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Controllers and devices Back to top 

You cannot view or configure parameters for LCD modules within Connected Components 
Workbench. [APBC00005458] 

Workaround: To configure LCD module setup parameters:  

1. Download the program to the controller. 

2. Configure the setup parameters using the LCD module. 

3. Upload the program to Connected Components Workbench. 

4. Save the program. 

While in PanelView, if you create decimal values while the regional setting is set to English, 
and then change the setting to Spanish, the PanelView Component incorrectly displays 
integer values. [APBC00005484] [APBC00005485] 

Workaround: Change the regional settings before making any application changes. 

Assigning initial values for parameters in UDFBs has limitations in this release.  

If you assign an initial value for a UDFB parameter, and then create an instance of the 
UDFB, the variable’s initial value will not be copied to the UDFB instance. [APBC00011728] 

Workaround: Assign initial values to individual UDFB instances. 

If you modify system variables while the controller is in run mode, you will not be able to 
exit the edit status. [APBC00011076] 

Workaround: Do not modify system variables while in run mode. To exit the edit status, 
press the Esc key. 

The Alias attribute of a variable is actually just a description of the variable. [APBC00010009] 

This capability will be changed in the next release to allow the alias to be referenced in 
addition to the variable name. 

If you create a string array using the Global Variables grid, the maximum length is 252 
characters. If you create a string array using the Data Types grid, the maximum length is 
255 characters. [APBC00010227] 

Workaround: Make all string arrays 252 characters or less. 

If you enter a DINT constant in a hexadecimal, octal or binary base you might receive an 
error message similar to the following: 

“Expecting a DINT type variable or constant.” [APBC00008422]  

  Publication CC-RN001D-EN-P – September 2013 



24 Connected Components Workbench Release 5.00.00 

Controllers and devices Back to top 

In a Ladder Diagram or a Function Block Diagram program, if you create a global or local 
variable (any data type, format of name.number, for example dd.0) and use the variable as 
a BOOL input or output in an instruction with at least one BOOL parameter, the value for 
the other variables may appear as OFFLINE in the Variable Monitoring window while in 
debug mode. [APBC00011612] 

Workaround: Right-click anywhere in the Variable Monitoring window, click Reset 
Settings, and then refresh the window (drag to enlarge the window size, or expand any 
instance variable within the window). 

The SAFEBOOL data type appears as an option in the Arrays grid, but SAFEBOOL is not 
supported by Micro800 controllers. [APBC00010414] 

Workaround: Do not select SAFEBOOL as a data type. 

The maximum number of words for the MSG_MODBUS ElementCnt parameter is 123 even 
though the LocalAddr specifies 125 words. If you use a value of 124 or 125 for the 
ElementCnt you will receive an error indicating a bad MSG file parameter exists. 
[APBC00003889] 

Workaround: Verify the ElementCnt variable uses a value of 123 words or less. 

System variables may not display properly within the Cross Reference Browser. 
[APBC00010624] 

Workaround: Close and reopen the project to display elements within the Cross Reference 
Browser properly. 

After adding a new array element variable and assigning it a value, you might not be able 
to use the up or down arrow key to change focus in the Variables grid. [APBC00007299] 

Workaround: Select individual array elements to assign their initial values. 

Variables Back to top 

In the Variable Editor, when viewing a user-defined function block that contains multiple 
nested functions or function blocks, the nested variables may not align correctly within the 
Logical Value column. If you hide the Logical Value column and then show the column, it 
is moved to the rightmost position in the Variable Editor and the values for the nested 
variables may not show in the column. [APBC00014339] 

The Retained and Address columns are displayed in the Global Variables and Local 
Variables Editors after discovering a Micro830 or Micro850 controller. These columns should 
not display in the Variable Editors. [APBC00015319] 

Workaround: Save, close, and then re-open the project to refresh the Variables Editors. 
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Controllers and devices Back to top 

In the Variable Editor, if you copy and paste the initial value of a nested array or nested 
structure with a sub array type, and then try to Build the project, it results in a syntax 
error. [APBC00015104] 

Workaround: To correct the syntax error, delete the pasted value and re-enter it without 
pasting.  

If you create a local variable and a global variable with the same name and reference both 
variables in a Ladder Diagram program, when you Build the program you may get an error. 
In this case, the local variable has precedence over the global variables. Rename one of the 
variables to prevent a name conflict. [APBC00014707] 

If you give a variable the same name as an existing function block parameter, the value of 
the variable may be incorrect after you Build, Download and Run your program. For 
example, if you create a variable named Q in a program that uses the Ton function block, 
which has a Q parameter, the program may confuse the two values. [APBC00012188] 

Workaround: Verify variable names are not the same as parameter names. 

If you use single quotes in a variable within an array element even when the data type is 
String, the build may fail. [APBC00011206] 

Workaround: Do not use single quotes in array element variables even though they are 
allowed according to IEC 61131-3 standards.  
 

Instruction blocks Back to top 

If a UDFB contains a timer, and the UDFB does not have an input parameter assigned to it, 
the timer in the UDFB may not work correctly. [APBC00017056] 

If you create a Ladder Diagram and add an instance of a COP instruction block with string 
type input variables assigned to the Scr and Dest parameters, the yellow warning images 
may not disappear as expected after you build the program. [APBC00015311] 

Workaround: Save, close, and then re-open the project to refresh the display. 

If you create an instance of a function block and assign a Structure data type to one of the 
variables, when you build the program the Error List displays the following message: 

“<StructureName>: This assignment is not implemented.”  

The message should not display while building the program. [APBC00015266] 

In the Variable Editor, when viewing a user-defined function block that contains multiple 
nested functions or function blocks, the nested variables may not align correctly within the 
Logical Value column. [APBC00014339] 

Workaround: Increase the width of the name column. 
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Instruction blocks Back to top 

The EN/ENO check box may not appear in the Block Selector window after uploading a 
project to a Micro800 controller. [APBC00014922] 

Workaround: Save, Close, and then reopen the project to refresh the display. 

In the Block Selector, if you click the Show Parameters button and then resize the 
Block Selector window, the Instructions and the Parameters will no longer display 
together in the window. [APBC00014821] 

Workaround: In the Block Selector window, if the Instructions and Parameters do not 
appear together in the window: 

 Use the Show Parameters button to toggle between the Instructions view and the 
Parameters view or  

 Save, Close the project, and restart Connected Components Workbench, to refresh 
the display. 

The MOV instruction block does not display when the Block Selector is launched from a 
ST POU. This is expected behavior, the MOV instruction only displays in the Block 
Selector when it is launched from a LD POU or a FBD POU. [APBC00014308] 

If you save and then download a project without first building the project, any initial values 
you have configured for input parameters will be discarded. [APBC00011608] 

Workaround: Always build your project before downloading it.  

If a UDFB parameter has the same name as a global variable, you might receive an error 
when you build your project. [APBC000011074] 

Workaround: Do not add a UDFB variable that has the same name as a global variable. 

If the project contains a UDFB with too many total parameters, you might receive a build 
error even though the total number of input and output parameters is within range. 
[APBC00011544] 

Workaround: Verify all the UDFBs do not have more than 128 total parameters. 

The Retained column is not available in the Local Variables grid for a UDFB. 
[APBC00007026] 

Workaround: Add the Retained variable to the main POU and set the Retained flag to true. 
Then add a parameter to the UDFB to pass in the Retained variable. 

After building a program that uses an ANY_TO_WORD, ANY_TO_DWORD, or 
ANY_TO_LWORD operator that does not have the correct data type defined for the output 
variable, you might receive the following error message: 

“Expecting a UINT type variable,” even though the output parameters all use a WORD data 
type. [APBC00007106] 

Note: The error message should state that a WORD type variable is expected. 
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Instruction blocks Back to top 

After completing a successful build, a yellow warning icon may appear on the instruction 
block. [APBC00007405] 

Workaround: The warning does not impact program execution. It is a warning to identify 
potential problems due to lack of assignments to input parameters. 

In a Function Block Diagram program, if you connect the output of an ANY_TO_WORD 
operator to the input of a UDFB, the compiler will display an error. [APBC00005062] 

Workaround: Use an intermediary variable to transfer a value between the instructions. 
 

Programs Back to top 

If you add an HSC instruction block to a Ladder Diagram rung, and then cut and paste the 
entire rung (including the HSC instruction block) to a new rung, an _ADI_plsData 
parameter may unexpectedly appear on the second HSC instruction block. [APBC00011375] 

Workaround: The added parameter is an internal parameter, which is normally hidden. It 
does not impact functionality. To remove the _ADI_plsData parameter, save the project, 
close the language editor, and then reopen the project to remove the _ADI_plsData 
parameter.  

If you enter more than the maximum allowed number of characters in the comment area 
for a Ladder Diagram program, and then save or build the project, the extra characters will 
not be removed, and a yellow warning icon will continue to display in the language editor. 
[APBC00011542] 

Workaround: Close and reopen the Ladder Diagram view to refresh the display.  
 

Import and export Back to top 

If you attempt to import a project file that contains a Structure defined with a user-defined 
type array, while Structure elements are expanded in the Data Type window, the import 
may not complete as expected. [APBC00015210] 

 Workaround: If this happens follow these steps: 

1. Close the Import Export window.  

2. Close the Data Type window.  

3. Import the project file.  
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Import and export Back to top 

In the Import and Export Setting Wizard, if you reset all settings and select the option, No, 
just reset settings, overwriting my current settings, some items may not appear in 
the File and Help menus as expected. [APBC00015185] 

Workaround: If this happens follow these steps:  

1. Save your project. 

2. Close, and reopen Connected Components Workbench to display all the menu 
items. 

If you try to Import a Micro800 program that contains a password and the program is not 
compatible with the version of Connect Components Workbench that you are using, the 
Password required dialog box appears. After you enter the password, the Unable to 
start importing dialog appears. If a Micro800 program is not compatible for importing, 
users should not be prompted to enter a password. [APBC00014022] 

If you attempt to import an incompatible exchange file, you will see the following error 
message, which is expected behavior: 

“The target used in exchange file must match the one used by the project.” 

If you then attempt to import a compatible exchange file, you might still receive the same 
error message. [APBC00011731] 

Workaround: Click OK on the error message dialog box to display the Import Export 
dialog box.  
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Build, debug, download and upload Back to top 

If you import a POU that contains an instruction that is not supported in the current project, 
you will receive an error when you build the project, which is expected behavior. However, 
if you double-click the error item, it will not navigate to the error location in the project. 
[APBC00014443] 

An anomaly was resolved in a previous release that allowed the CIP driver option to be 
chosen when it was not supported in that version. A controller change feature will be 
available in the next release of CCW that will resolve the following issue. [APBC00015097]  

If you Upload a project that was created in an earlier release, and CIP was configured but 
not supported, the CIP driver is changed to ASCII. If you Build and then try to Debug the 
program, you will see the following error message:  

“The current project contents do not match the contents running on the controller.  

Ensure the controller contents match the project contents by building and downloading to 
the controller.” 

Workaround: Follow these steps to download the project:  

1. From the Build menu, select Build. 

2. Click Download.  

If you view an array variable in a language editor, the value may not update correctly. 
[APBC00015320] 

Workaround: Use the Variable editor to view values for array variables. 

If you attempt to download embedded files that exceed 56 kB to a Micro800 controller, you 
receive an error message similar to the following: 

"The size of embedded files for device Micro810 is too large: 56190>56000." 

This is expected behavior even though the value in the Controller > Memory pane 
indicates memory and steps are still available. This happens because the size of the 
compressed controller project to be stored on the Micro800 cannot be precisely determined. 
[APBC00009725, APBC00014937]  

If you attempt to build a project that has an invalid Motion Engine Execution Time, you will 
receive a build error, which is expected behavior. If you then delete the Motion Axis without 
first correcting the Engine Execution Time and build the project again, the build will still fail. 
Note: When you enter an invalid value, the field is outlined in red indicating an error. 
[APBC00011576] 

Workaround: Follow these steps to resolve the error: 

1. Add an Axis, and enter a valid Motion Engine Execution Time. 

2. Save the project.  

3. Delete the Axis and then save the project again.  

4. Re-build the project. 
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Build, debug, download and upload Back to top 

If you build and download a project that contains invalid configuration information, you 
might continue to receive error messages when you build and download the project even, 
after entering valid configuration information. [APBC00009263, APBC00009321] 

Workaround: Follow these steps to resolve the error: 

1. Close Connected Components Workbench and then restart it.  

2. Update the configuration information, and save the project. 

3. Rebuild and download your project again. 

If you change the controller mode while in debug mode, Connected Components Workbench 
may unexpectedly close. [APBC00011465] 

Workaround: Do not change the controller mode while in debug mode. 

If you attempt to build a project and the build fails, you might not be able to upload the 
project. [APBC00010402] 

Workaround: Close Connected Components Workbench and upload to a new project. 

If you keep the cursor focused on any cell within a variables editor, and then build the 
project, the Start Debugging and/or Download options may not be available. 
[APBC00005218] 

Workaround: Press Enter after you add variable information before you begin 
downloading or debugging. 

If, while downloading, you disconnect the controller cable, and then reconnect it, the 
controller may be left in an indeterminate state. When you upload the project, you might 
receive an exception error. [APBC00004904] 

Workaround: Ensure you have a good connection between the Micro800 while 
downloading. To recover, download the application again.  

When you add a block instruction to a Ladder Diagram, yellow triangle warnings appears in 
the image of the Function Block Instance until variables are assigned to the inputs and 
outputs. If you Build, Download and then Debug the program, the yellow triangle warnings 
are no longer visible. [APBC00013395]  

Work Around: To show the yellow warnings after you stop debugging, close and reopen 
the Ladder Diagram.  

BC80] 
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Application notes Back to top 

Establish communications to a Micro800 controller 

Connected Components Workbench sample projects 

Access projects remotely 

Modify existing UDFBs 

Import/Export drive configurations 

Establish communications to a Micro800 controller  
If you install RSLinx Classic on a virtual machine (for example, VMWare), disable RSLinx 
Classic on your host computer before plugging the USB cable that is attached to your 
Micro800 controller into the host computer. If you ignore this step, the host computer will 
obtain the driver for the Micro800 controller, and the Micro800 controller may not be 
detected by the virtual machine. 

Connected Components Workbench sample projects 
This release includes several Micro800 controller sample projects that are installed in the 
following folder.  

 Microsoft Windows 7: 
\Users\current user\Documents\CCW\Sample Projects 

Access projects remotely 
If you create or open projects on a remote mapped drive, or on a network PC Sharename, 
you may receive any of the following Catalog errors unless you configure remote access for 
the computer:  

 IDF Catalog Error 

 Failed to find or create a project for the device 

 The catalog failed to match the selection to a provider 

Access CCW projects on a network PC Sharename 

If you are using a network PC Share name, establish a Full Trust relationship with the PC 
and the shared location. For detailed information, see Microsoft KB article: 

http://support.microsoft.com/kb/320268/ 

To establish a trust relationship (excerpt from the KB article):  

Use the following command shell (Start Menu/Run cmd) command to establish the needed 
trust relationship: 

drive_letter:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\caspol.exe -m -ag 1 -url 
"file:////\\network_pc_name\share_name\*" FullTrust -exclusive on 

For example:  

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\caspol.exe -m -ag 1 -url 
"file:////\\devlabpc\CCWInstall\*" FullTrust -exclusive on 

  Publication CC-RN001D-EN-P – September 2013 

http://support.microsoft.com/kb/320268/


32 Connected Components Workbench Release 5.00.00 

Modify existing UDFBs 
Connected Components Workbench does not automatically update the instances of the 
modified UDFBs referenced in existing programs.  

To update every instance of a UDFB 

• Search for each UDFB in the program, and update the instance for each one. 

Import/Export drive configurations 
Use the Import/Export tab from the Properties dialog box to import or export drive 
configuration files. 

Supported import and export file types 

Import file types 

• CCW device files (*.iuu, *.iuux) 

• DriveExplorer configuration storage files (*.csf) 

• DriveTools device node files (*.dno) 

• PowerFlex 520-Series drive USB files (*.pf5).  

Export file types 

The types of files you can export include the following: 

• CCW device files (*.iuux) 

• PowerFlex 520-Series drive USB files (*.pf5). 

Import a drive configuration file 

Follow these steps to import a drive configuration file. You can only import a configuration 
file when disconnected from the drive. 

To import a file 

1. On the Import/Export tab of the Properties dialog box for the drive, click Import 
to display the Open dialog box. 

2. If you want to locate a specific file type, select the file type in the Files of type box. 

3. Browse to the location where the configuration file is saved and select the file. 

4. Click Open to display the Import confirmation dialog box. 

5. If you want to select a different file to import, click Change and select a different 
file. 

6. Select one of the following options:  

• To overwrite the configuration for the drive in your project and any connected 
peripherals, click Import Entire Device.  

• To overwrite the configuration for just the drive in your project, click Import 
Only Port 0. 
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Export a drive configuration file 

You can export a drive configuration file from your project to your computer. For PowerFlex 
520-Series drives only, if a *.pf5 file is exported, you can download the file to a PowerFlex 
520-Series drive using the on-board USB application. 

To export a file 

1. On the Import/Export tab of the Properties dialog box for the drive, click Export. 

2. If you are connected to the drive, a Connecting dialog box opens, followed by the 
Upload dialog box. Click Upload Entire Device. The configuration is uploaded from 
the drive and the Save As dialog box opens. 

3. If you are disconnected from the drive, the Save As dialog box opens. 

4. Browse to the location where you want to save the configuration file. 

5. Type the file name in the File name box. 

6. If necessary, select the file type in the Save as type box. 

7. Click Save. 
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