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Welcome
 

 

DDR (Dual Data Rate) is a dominant and fast-growing memory technology. It
offers high data transfer rates required for virtually all computing applications,
from consumer products to the most powerful servers. The high speeds of these
signals require high performance measurement tools.

The Tektronix TekExpress DDR Tx is an automated test application to validate
and debug DDR5 design of the DUT as per the latest JEDEC specification. The
solution enables you to achieve new levels of productivity, efficiency, and
measurement reliability.
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Key features
1. Total 52 Measurements of DDR5 System Transmitter Tests as per DDR5

JEDEC Specification

a. 21 Clock Measurements
b. 9 Write Burst Measurements
c. 1 Write Data Eye Measurement
d. 13 Read Burst Measurements
e. 8 Command and Address Measurements

2. User defined acquisition mode for Clock, Command Address, Data Strobe,
and Data for both Write and Read traffic (or bursts)

3. De-embedding support for Clock, Command Address, Data Strobe, and Data
for both Write and Read traffic (or bursts)

4. Number of UIs support for Clock and Read/Write Data measurements
5. Deploys 'DDR DFE' Standalone application, that can be launched from

TekScope > Analyze > DDR DFE
6. Support DFE for Write Data Eye measurements
7. User friendly measurement configurations
8. Test Report to reflect all the statistics of the measurement
9. User can select the source and channel in acquisition panel
10. Multiple Burst Detection Method supported - Read and Write, Write Only,

Read Only, Visual Search
11. Diamond shape mask and margin analysis for Write Data Eye measurement

Welcome  
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Getting help and support

Related documents
The following manuals are available as part of the TekExpress DDR Tx
Automated Solution documentation set.

Table 1: Product documentation

Item Purpose Location
Online Help In-depth operation and

UI help.

PDF of the Online Help
(077-1648-XX)

In-depth operation and
UI help.

Conventions
Help uses the following conventions:

■ The term "Application," and "Software" refers to the TekExpress DDR Tx
application.

■ The term “DUT” is an abbreviation for Device Under Test.

■ The term “select” is a generic term that applies to the two methods of
choosing a screen item (button control, list item): using a mouse or using the
touch screen.

■ A Note identifies important information.

Table 2: Icon descriptions

Icon Meaning
This icon identifies important information.

This icon identifies conditions or practices that could result in loss
of data.

This icon identifies additional information that will help you use
the application more efficiently.
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Technical Support
Tektronix values your feedback on our products. To help us serve you better,
please send us your suggestions, ideas, or comments on your application or
oscilloscope. Contact Tektronix through mail, telephone, or the Web site. See 
www.tek.com at the front of this document for contact information.

When you contact Tektronix Technical Support, please include the following
information (be as specific as possible):

General information ■ All instrument model numbers
■ Hardware options, if any
■ Modules used
■ Your name, company, mailing address, phone number, FAX number
■ Please indicate if you would like to be contacted by Tektronix about your

suggestion or comments.

Application specific
information

■ Software version number
■ Description of the problem such that technical support can duplicate the

problem
■ If possible, save the setup files for all the instruments used and the

application
■ If possible, save the TekExpress setup files, log.xml, *.TekX (session files

and folders), and status messages text file
■ If possible, save the waveform on which you are performing the

measurement as a .wfm file

Getting help and support  
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Getting started

Supported oscilloscope models
■ DPO71604SX, DPO72304SX, DPO73304SX

■ MSO72304DX, MSO72504DX, MSO73304DX, DPO72304DX,
DPO72504DX, DPO73304DX

Recommended probes
Active probes:

■ P7720 20 GHz Trimode Probe with TekFlex connector technology

■ P7716 16 GHz Trimode Probe with TekFlex connector technology

Probe tips:

■ P77STFLXA / P77STCABL : Active, Solder-in Tip with TekFlex connector
technology; probe tips to probe directly on the motherboard or vias.

■ P77STFLXB / P77STCABL: Active, Solder-in Tip with TekFlex connector
technology; probe tips to probe CLK, DQS, DQ, and CA/CKE/CS on the
Nexus XH Series SI Interposer.

■ Edge interposer NEX-DDR5MCI78XHEPTD : Order from Nexus. Please
also request the s-par files for all individual signals on the interposer instead
of getting a generic nominal s-par model.

■ SI Interposer : Edge Probe, Direct Attach, Socketed interposer available
from Nexus. Please order directly from Nexus. Please request the s-par files
for all individual signals on the interposer instead of getting a generic
nominal s-par model.

Refer the Nexus's page for more information: http://
www.nexustechnology.com/products/memory-interposers/ddr5-main-
memory-interposers/.

TekExpress® DDR Tx Printable Application Help 3
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Required software
■ DDR5SYS: DDR5 Memory Bus Electrical Validation and Analysis

Oscilloscope Software.

■ SDLA64: Serial Data Link Analysis for Win 64-bit Scopes.

■ DJA: DPOJET Jitter Analysis.

■ VET: VET – Visual Trigger.

Downloading and installing the software
Complete the following steps to download and install the latest DDR Tx
application. 

1. Go to www.tek.com.

2. Click Downloads. In the Downloads menu, select DOWNLOAD TYPE as
Software and enter DDR Tx in the MODEL OR KEYWORD field and click
SEARCH.
 

 

3. Select the latest version of software and follow the instructions to download.
Copy the executable file to the oscilloscope.

4. Double-click the executable and follow the on-screen instructions. The
software is installed at C:\Program Files\Tektronix\TekExpress\TekExpress
DDR Tx.

5. Select Application > TekExpress DDR Tx from the Oscilloscope menu to
launch the application.

Getting started  
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Activate the license
Activate the license using the Option Installation wizard in the TekScope
application:

1. In the TekScope application menu bar, click Utilities > Option Installation.

The TekScope Option Installation wizard opens.

2. Push the F1 key on the oscilloscope keyboard to open the Option Installation
help topic.

3. Follow the directions in the help topic to activate the license.

View software version
To view version information for DDR Tx, click Options > About TekExpress.
 

 

 Getting started

TekExpress® DDR Tx Printable Application Help 5



Application directories
The TekExpress DDR Tx application files are installed at the following location:

C:\Program Files\Tektronix\TekExpress\TekExpress DDR Tx

The application directory and associated files are organized as follows:
 

 

The following table lists the default directory names and their usage:

Table 3: Application directories and usage

Directory names Usage
Bin Contains application libraries
Compliance Suites Contains test suite specific files
ICP Contains instrument and application specific interface libraries
Licenses
Images Contains images of the application
Lib Contains utility files specific to the application
Report Generator Contains style sheets for report generation
Tools Contains instrument and application specific files

Getting started  
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File name extensions
The TekExpress DDR Tx software uses the following file name extensions:

Table 4: File name extension

File name extension Description
.TekX Application session files (the extensions may not be displayed)
.py Python sequence file
.xml Test-specific configuration information (encrypted) files

Application log files
.csv Test result reports

Plot data
.mht Test result reports (default)

Test reports can also be saved in HTML format
.pdf Test result reports

Application help document
.xslt Style sheet used to generate reports
.png Captured images

 Getting started
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Operating basics

Launch the application
To launch the TekExpress DDR Tx application, select Analyze > TekExpress
DDR Tx from the oscilloscope menu.
 

 

After first launch of Tekexpress DDR Tx application following changes take
place on the oscilloscope.

During launch, "My TekExpress" folder is created in the Documents folder of the
current user and gets mapped to "X" drive. When the application is closed
properly, the "X" drive will get unmapped.

NOTE. If a user with new login ID launches "TekExpress DDR Tx.exe", "My
TekExpress" folder is created in the Documents folder of the new user.

When you first run the application after installation, the application checks for
Resources.xml located in the X:\ folder. The Resources.xml file gets created into
X: drive, if the file is not found, then the application creates file with equipment
details. Session files are then stored inside the X:\DDR Tx folder. If this file is
not found, the application runs an instrument discovery program to detect
connected instruments before launching TekExpress DDR Tx.
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To keep the TekExpress DDR Tx application window on top, select Keep On
Top from the Options menu overview on page 13. If the application goes behind
the oscilloscope application, click Application > TekExpress DDR Tx to move
the application to be in front.

NOTE. When Keep on Top is selected, you cannot access the combo boxes in the
application panels.

See also  

Exit the application on page 10

Exit the application

To exit the application, click    on the application title bar. Follow on-screen
prompts to save any unsaved session, save test setup files, or exit the application.

NOTE. Using other methods to exit the application can result in abnormal
termination of the application.

Operating basics  
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Application controls
This section describes the application controls.

Table 5: Application control description

Item Description
Options menu overview on
page 13
 

 

Menu to display global application controls.

Test panel
 

 

Controls that open tabs for configuring test settings and options.

Start / Stop button
 

 
 

 

Use the Start button to start the test run of the measurements in
the selected order. If prior acquired measurements are not
cleared, then new measurements are added to the existing set.
The button toggles to the Stop mode while tests are running. Use
the Stop button to abort the test.

Pause / Continue button
 

 

Use the Pause button to pause the acquisition. When a test is
paused, this button changes as Continue.

Clear button
 

 

Use the Clear button to clear all existing measurement results.
Adding or deleting a measurement, or changing a configuration
parameter of an existing measurement, also clears
measurements. This is to prevent the accumulation of
measurement statistics or sets of statistics that are not coherent.
This button is available only on Results panel on page 42.

NOTE. This button is visible only when there are results data on
the panel.

 Operating basics
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Item Description
Application window move icon
 

 

Place the cursor over the top of the application window to move
the application window to the desired location

Minimize icon
 

 

Minimizes the application.

Close icon
 

 

Close the application.

Mini view / Normal view
 

 
 

 

Toggles the application between mini view and normal view.
Mini view displays the run messages with the time stamp,
progress bar,
Start / Stop button, and Pause / Continue button.
The application moves to mini view when you click the Start
button.
 

 

Operating basics  
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Global application controls
The menus and controls that appear outside the individual tabs are called “Global
Controls”. These are used to specify the devices to be tested and are listed below.

■ Options menu overview on page 13

■ TekExpress instrument control settings on page 14

■ View connected instruments on page 15

■ Configure email settings on page 16

Options menu overview To access Options menu, click  in the upper-right corner of the application. It
has the following selections:

Options menu

Menu Function
Default Test Setup Opens an untitled test setup with defaults selected
Open Test Setup Opens a saved test setup
Save Test Setup Saves the current test setup
Save Test Setup As Saves the current test setup with a different file name or file type
Open Recent Displays the recently opened test setups to open
TekExpress instrument
control settings on
page 14

Detects, lists, and refreshes the connected instruments found on
specified connections (LAN, GPIB, USB, and so on)

Keep On Top Keeps the TekExpress DDR Tx application on top of all the application

NOTE. When Keep on Top is selected, you cannot access the combo
boxes in the application panels.

Email Settings Use to configure email options for test run and results notifications

 Operating basics
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Menu Function
Help Displays the TekExpress DDR Tx help
About TekExpress ■ Displays application details such as software name, version number,

and copyright

■ Provides a link to the end-user license agreement

■ Provides a link to the Tektronix Web site

See also. Application controls on page 11

TekExpress instrument
control settings

Use TekExpress Instrument Control Settings dialog box to search the
instruments (resources) connected to the application. You can use the Search
Criteria to search the connected instruments depending on the connection type.
The details of the connected instrument is displayed in the Retrieved Instruments
window.

To access, click Options > Instrument Control Settings.
 

 

The connected instruments displayed here can be selected for use under Global
Settings in the test configuration section.

See also. Options menu overview on page 13

Operating basics  
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View connected
instruments

Use TekExpress Instrument Control Settings dialog box to search the instruments
(resources) connected to the application. The application uses TekVISA to
discover the connected instruments.

NOTE. The instruments required for the test setup must be connected and it must
be recognized by the application before running the test.

To refresh the list of connected instruments:

1. From the Options menu, select Instrument Control Settings.

2. In the Search Criteria section of the Instrument Control Settings dialog box,
select the connection types of the instruments to search.

Instrument search is based on the VISA layer, but different connections
determine the resource type, such as LAN, GPIB, and USB. For example, if
you choose LAN, the search will include all the instruments supported by
TekExpress that are communicating over the LAN.

3. Click Refresh. TekExpress searches for connected instruments.

4. After searching, the dialog box lists the instrument-related details based on
the search criteria. For example, for the Search Criteria as LAN and GPIB,
the application displays all LAN and GPIB instruments connected to the
application.

 Operating basics
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The details of the instruments are displayed in the Retrieved Instruments table.
The time and date of instrument refresh is displayed in the Last Updated field.

Configure email settings Use the Email Settings utility to get notified by email when a measurement
completes, or produces any error condition. Follow the steps to configure email
settings:

Email Settings
 

 

1. Select Options > Email Settings to open the Email Settings dialog box.

2. (Required) For Recipient email Address(es), enter one or more recipient
email addresses. To include multiple addresses, separate the addresses with
commas.

3. (Required) For Sender’s Address, enter the email address used by the
instrument. This address consists of the instrument name, followed by an
underscore, followed by the instrument serial number, then the @ symbol,
and the email server ID. For example: user@yourcompany.com.

4. (Required) In the Server Configuration section, type the SMTP Server
address of the Mail server configured at the client location, and the SMTP
Port number, in the corresponding fields.

If this server requires password authentication, enter a valid login name,
password, and host name in the corresponding fields.

NOTE. If any of the above required fields are left blank, the settings will not
be saved and email notifications will not be sent.

Operating basics  
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5. In the Email Attachments section, select from the following options:
■ Reports: Select to receive the test report with the notification email.
■ Status Log: Select to receive the test status log with the notification

email. If you select this option, then also select whether you want to
receive the full log or just the last 20 lines.

6. In the Email Configuration section:
■ Enter a maximum file size for the email message. Messages with

attachments larger than this limit will not be sent. The default is 5 MB.
■ Enter the number in the Number of Attempts to Send field, to limit the

number of attempts that the system makes to send a notification. The
default is 1. You can also specify a timeout period.

7. Select the Email Test Results When complete or on error check box. Use
this check box to quickly enable or disable email notifications.

8. To test your email settings, click Test Email.
9. To apply your settings, click Apply.
10. Click Close when finished.

Application panels overview
TekExpress DDR Tx solution uses panels to group Test Setup Configuration,
Results, and Reports settings. Click any button to open the associated panel. A
panel may have one or more tabs that list the selections available in that panel.
Controls in a tab can change depending on settings made in the same tab or
another tab.
 

 Operating basics
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Table 6: Application panels overview

Panel Name Purpose
Setup panel on
page 19

The Setup panel shows the test setup controls. Click the Setup button to
open this panel.
Use this panel to:

■ Set DUT parameters on page 19
■ Select tests on page 28
■ Set acquisition tab parameters on page 29
■ Set configuration tab parameters on page 30
■ Set preferences tab parameters on page 38

Status panel on
page 40

View the progress and analysis status of the selected tests, and view test
logs.

Results panel on
page 42

View the summary of test results and select result viewing preferences.

Reports panel on
page 45

Browse for reports, save reports as specific file types, specify report
naming conventions, select report content to include (summary
information, detailed information, user comments, setup configuration,
application configuration, etc.), and select report viewing options.

See also Application controls on page 11

Operating basics  
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Setup panel

Setup panel overview The Setup panel contains sequentially ordered tabs that help you guide through
the test setup and execution process.
 

 

Set DUT parameters Use the DUT tab to select parameters for the device under test. These settings are
global and apply to all tests of current session. DUT settings also affect the list of
available tests in the Test Selection tab.
 

 Operating basics
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Click Setup > DUT to access the DUT parameters:

Table 7: DUT tab settings

Setting Description
Acquire live waveforms Acquire active signals from the DUT for measurement and analysis.
Use pre-recorded waveform files Run tests on a saved waveform. Open load a saved test setup on page 54

Click here for details about the file names for pre-recorded waveform.
User Defined Acquisition When selected, enables user to define the acquisition settings of their choice. Gives

additional source option [MATH] for signals in acquisition panel.
DUT ID Adds an optional text label for the DUT to reports. The default value is DUT001. The

maximum number of characters is 32.
You cannot use the following characters in an ID name: (.,..,...,\,/:?”<>|*)

   Comments icon (to the right of the
DUT ID field)

Opens Comments dialog box to enter text to add to the report. Maximum size is
256 characters. To enable or disable comments appearing on the test report, see Select
report options on page 46.

Device Select Device name as DDR5 from drop-down
Device Profile
Data Rate (MT/s) Select the data rate from drop down.
Vdd (V) Vdd is the supply voltage for each DDR standard. For DDR5, it is 1.1 V.

■ Displays JEDEC value by default
■ Select Manual to change the Vdd value.

Operating basics  
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Setting Description
Vcent-DQ (V) Vcent_DQ is the voltage at which the cumulative eye of the pin DQx is widest.

■ Displays Auto value by default.
■ Select Manual to change the Vcent-DQ value from -2 V to 2 V.

Vref-CA (V) Vref_CA is voltage at widest part of the eye.

■ Displays Auto value by default.
■ Select Manual to change the Vref-CA value from -2 V to 2 V.

Burst detection method on page 25 Selects the burst detection method from drop-down.

■ Read Write Bursts
■ Write Only Bursts
■ Read Only Bursts
■ Visual search

Signal Probe Type Selects the probe type Clock and DQS to execute the tests.

■ Clock - Differential or Single Ended
■ DQS - Differential or Single Ended

You can configure the signal as per the probes you are planning to use to run the tests.
For Clock: If probes are connected in a single-ended fashion, then internally a differential
signal is created to perform clock jitter measurements.
Based on the probe type selected for Clock or DQS, the test selection panel refreshes the
measurements in clock and data group.

 Operating basics
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Setting Description
Filter Files path Select Enable or Disable from the drop-down list.

Click Setup ( ). Browse and select the filter files from the De-Embed Filter File
Path menu for Differential and Single-Ended signals. Click Close to close the menu.

Operating basics  
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Setting Description
Trimode Probe Setup With TriMode probing, one probe setup makes differential, single-ended, and common

mode measurements accurately.
Click Setup. In TriMode Probe Mode window, select A, B, or Differential from the drop-
down list.

■ A represents that probe is configured to point A and ground.
■ B represents that probe is configured to point B and ground.
■ Differential represents that the probe is configured to point A and B respectively.

Figure 1: TriMode Probe Mode window

 Operating basics
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NOTE. P7700 Series TriMode Probes

With TriMode probing, one probe setup makes differential, single-ended, and
common mode measurements accurately. This unique capability allows you to
work more effectively and efficiently, switching between differential, single-ended
and common mode measurements without moving the probe's connection points.
 

 

See also. Select tests on page 28

Operating basics  
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Burst detection method. Burst detection is applicable only for Write Bursts and
Read Bursts of the DATA group measurements. The Burst Detection Setup
controls the identification of data burst within a waveform which includes tri-
state levels. For appropriately-probed signals with good signal fidelity,
adjustment to the default values are not required. For signals with poor fidelity or
unusual properties, burst detection can be improved by switching to Manual
control and adjusting the detection levels.
 

 

The application supports the following burst detection methods:

 Operating basics
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1. Read Write Bursts: This method identifies READ and WRITE
measurements that are available in the data group. Select this method when
there is a voltage difference between READ and WRITE burst peak-to-peak
level.

NOTE.

a. When the DUT traffic is transmitting both Read + Write bursts and the
Read burst amplitude is greater than the Write burst amplitude, follow
the steps for burst detection:

a. Measure the Pk2PK for Read burst using TekScope > Measure >
Amplitude > Peak to Peak.

b. Measure the Pk-Pk for Write burst using TekScope > Measure >
Amplitude > Peak to Peak.

c. In the Read tab of Burst Detection Setup window, set the Read
Burst(pk-pk) value to be 5% lower than the value obtained from step 
 1.a.i.

d. In the Write tab of Burst Detection Setup window, set the Write
Burst(pk-pk) value to be 5% greater than the value obtained from
step  1.a.ii.

b. When the DUT traffic is transmitting both Read + Write bursts and the
Read burst amplitude is lower than the Write burst amplitude, follow the
steps for burst detection:

a. Measure the Pk2PK for Read burst using TekScope > Measure >
Amplitude > Peak to Peak.

b. Measure the Pk-Pk for Write burst using TekScope > Measure >
Amplitude > Peak to Peak.

c. In the Read tab of Burst Detection Setup window, set the Read
Burst(pk-pk) value to be 5% greater than the value obtained from
step  1.b.i.

d. In the Write tab of Burst Detection Setup window, set the Write
Burst(pk-pk) value to be 5% lower than the value obtained from step 
 1.b.ii.

2. Write Only Bursts: The method identifies only write measurements that are
available in the data group.

NOTE. Configure the DUT data traffic to ALL WRITE BURSTS mode.

Operating basics  
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3. Read Only Bursts: The method identifies only read measurements that are
available in the data group.

NOTE. Configure the DUT data traffic to ALL READ BURSTS mode.

Table 8: Burst detection parameter description

Pre-amble Length
(tCK)

Specify the Read / Write burst pre-amble length of your device here.

Post-amble Length
(tCK)

Specify the Read / Write burst pre-amble length of your device here.

Burst Length (UI) Specify the burst length of your device here. Used in case of Write
Only Bursts or Read Only Bursts as Burst Detection Method.

Write Burst(pk-pk)
(V)

Specify the DQS (pk-pk) voltage level of WRITE bursts. Used in case
of Read Write Bursts as Burst Detection Method

Read Burst(pk-pk)(V) Specify the DQS (pk-pk) voltage level of READ bursts. Used in case
of Read Write Bursts as Burst Detection Method

Margin(%) Specifies the voltage variance allowed in terms of percentage of
peak-peak voltage. Used in case of Read Write Bursts as Burst
Detection Method.

tDQS2DQ (ps) –
Auto

tDQS2DQ value is automatically set by the application. Used in case
of Read Write Bursts or Write Only Bursts for 'Write' as Burst
Detection Method.

tDQS2DQ (ps) –
Manual

tDQS2DQ value can be edited. Used in case of Read Write Bursts or
Write Only Bursts for 'Write' as Burst Detection Method.

NOTE. The High/Mid/Low levels used for burst detection have no relationship
to the reference levels used for measurement points.

a. Select the type of burst detection level for the search.

■ If you select Auto, the application calculates these levels for you. It is
recommended unless you find that manual levels are necessary for
reliable detection.

■ If you select Manual, enter both the Strobe and Data reference levels
for the signal (High, Mid, and Low). As you adjust the detection
levels, observe the search-and-mark sprites that appear above the
waveform. These sprites are dynamically updated as you adjust the
levels, helping you to identify levels that properly delimit the
selected burst type.

b. These settings need not be changed in most cases:

■ Edge Detection Hysteresis: This control configures the internal edge
finder’s hysteresis band which is used to detect read or write bursts.
In the event of noisy inputs, it can be increased to correct marks
which may be larger than appropriate.

 Operating basics

TekExpress® DDR Tx Printable Application Help 27



■ Termination Logic Margin: This value can be increased to help in
terminating marks on back-to-back writes in cases where otherwise a
continuous strobe would cause a write-mark to merge two back-to-
back writes.

4. Visual search: Capturing and analyzing the right part of the waveform can
require hours of collecting and sorting through the many acquisitions. The
Visual Trigger feature in the oscilloscope makes the identification of the
desired waveform events quick and easy by scanning through acquired
analog waveforms and graphically comparing them to geometric shapes on
the display. By discarding acquired waveforms which do not meet the
graphical definition, Visual Triggering extends the trigger capabilities of the
oscilloscope beyond the traditional hardware trigger system.

Visual Trigger can be used to separate Read Bursts from Write Bursts and
mark them. By selecting the Visual Search option in ‘Burst Detection
Method’, these marked bursts can be used for further debugging and analysis.

Select tests Use the Test Selection tab to select the tests. The test measurements available
depends on the settings selected in the DUT. tab.

Figure 2: TekExpress DDR Tx measurements
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Table 9: Test Selection tab settings

Setting Description
Deselect All
Select All

Deselect or select all tests in the list.

Tests Click on a test to select or unselect. Highlight a
test to show details in the Test Description pane.
The application automatically selects all required
tests when in Compliance mode.

Test Description Shows brief description of the highlighted test in
the test tree.

See also. Set acquisition tab parameters on page 29

Set acquisition tab
parameters

Use Acquisitions tab to view the test acquisition parameters. The contents
displayed on this tab depends on the DUT type and the tests selected.

Figure 3: Acquisition tab
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Table 10: Acquisitions tab settings

Settings Description
View Probes View the detected probe configuration. Use the

View Probes dialog box to view the connected
probes.

Acquisition and Save options
Save and Analyze Acquisition In Sequence Saves and then analyses the acquisition in

sequence.
Show Acquire Parameters Select to view the acquisition parameters.

TekExpress DDR Tx saves all acquisition waveforms to files by default.
Waveforms are saved in a unique folder for each session (a session is started
when you click the Start button). The folder path is X:\TekExpress DDR Tx
\Untitled Session\<dutid>\<date>_<time>. Images created for each analysis,
XML files with result values, reports, and other information specific to that
particular execution are also saved in this folder.

Saving a session moves the session file contents from the Untitled Session folder
to the specified folder name, and changes the session name to the specified name.

See also. use prerecorded wavwform files

Set configuration tab
parameters

Use Configuration tab to view and configure the Global Settings and the
measurement configurations. The measurement specific configurations available
in this tab depends on the selections made in the DUT panel and Test Selection
panel.
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Table 11: Configuration tab: Common parameters

Setting Description
Limits Editor Displays the upper and lower limits for the applicable

measurement using different types of comparisons.
 

 

Figure 4: Configuration tab: Global Settings
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Table 12: Configuration tab: Global settings

Setting Description
Global Settings
Instruments Detected Displays the instruments connected to this application. Click on

the instrument name to open a list of available (detected)
instruments.
Select Options > Instrument Control Settings and click
Refresh to update the instrument list.

NOTE. Verify that the LAN and GPIB search criteria (default
setting) in the Instrument Control Settings is selected when using
TekExpress DDR Tx application.

Bandwidth Select the oscilloscope bandwidth. This value will be used for all
tests.

Figure 5: Configuration tab: Measurements
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Table 13: Configuration tab: Measurements settings

Configuration Range
Measurements Displays the measurements which are

selected in the Test Selection tab. The tests
are grouped with unique acquisition type
names.

Clock Acquire Record length (M) 0.001 to 100 
Sample Rate (GS/s) 50 

Analyze Number of UI (M) 0.001 to 2000 
Save worst case
measurement
snapshot

Select, Unselect

N start 2 to 30 
N stop 2 to 30 
BER 3 to 22 

WR_Differential_Stro
be
/
RD_Differential_Strob
e
/

Acquire Record length (M) 0.001 to 100 
Sample Rate (GS/s) 50 

Analyze Number of UI (M) 0.001 to 2000 
Save worst case
measurement
snapshot

Select, Unselect

tCK (ns) 0.2 to 10 
DQS Ref Level
/
DQ Ref Level
/
Clock Ref Level

Absolute High level (V) -10 to 10 
Mid level (V) -10 to 10 
Low level (V) -10 to 10 
Hysteresis(V) 0 to 10 

Percentage High level (V) 1 to 99 
Mid level (V) 1 to 99 
Low level (V) 1 to 99 
Hysteresis(V) 0 to 50 
Auto set basetop
method

Minmax
Auto
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Configuration Range
RD_Output_level Acquire Record length (M) 0.001 to 100 

Sample Rate (GS/s) 50 
Analyze Number of UI (M) 0.001 to 2000 

Save worst case
measurement
snapshot

Select, Unselect

Analyze DQS Ref Level
/
DQ Ref Level

Absolute High level (V) -10 to 10 
Mid level (V) -10 to 10 
Low level (V) -10 to 10 
Hysteresis(V) 0 to 10 

Percentage High level (V) 1 to 99 
Mid level (V) 1 to 99 
Low level (V) 1 to 99 
Hysteresis(V) 1 to 99 
Auto set basetop
method

Minmax
Auto
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Configuration Range
WR_Data_Eye Acquire Record length (M) 0.001 to 100 

Sample Rate (GS/s) 50 
Analyze tCK (ns) 0.2 to 10 

Mask Definition Eye Width (UI) 0 to 2 
Eye Height (mV) 0 to 1000 

Superimpose DQS Select, Unselect
Apply DFE Select, Unselect
Gain(dB) -6 to 6 
Threshold(mV) 0 to 2000 
Tap1(mV) -200 to 50 
Tap2(mV) -75 to 75 
Tap3(mV) -60 to 60 
Tap4(mV) -45 to 45 
Stop on Mask Hit Select, Unselect

DQS Ref Level
/
DQ Ref Level
/
Clock Ref Level

Absolute High level (V) -10 to 10 
Mid level (V) -10 to 10 
Low level (V) -10 to 10 
Hysteresis(V) 0 to 10 

Percentage High level (V) 1 to 99 
Mid level (V) 1 to 99 
Low level (V) 1 to 99 
Hysteresis(V) 0 to 50 
Auto set basetop
method

Minmax
Auto
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Configuration Range
WR_Slew_Rate Acquire Record length (M) 0.001 to 100 

Sample Rate (GS/s) 50 
Analyze Number of UI (M) 0.001 to 2000 

Save worst case
measurement
snapshot

Select, Unselect

DQS Ref Level Absolute High level (V) -10 to 10 
Mid level (V) -10 to 10 
Low level (V) -10 to 10 
Hysteresis(V) 0 to 10 

Percentage High level (V) 1 to 99 
Mid level (V) 1 to 99 
Low level (V) 1 to 99 
Hysteresis(V) 0 to 50 
Auto set basetop
method

Minmax
Auto

Address_Command Acquire Record length (M) 0.001 to 100 
Sample Rate (GS/s) 50 

Clock/CA Reference Level Ref levels Clock/CA ■ Absolute
■ Percentage

High level Percentage
Clock/CA

1 to 99 

Mid level Percentage
Clock/CA
Low level Percentage
Clock/CA
Hysteresis
Percentage Clock/CA

0 to 50 

High level Absolute
Clock/CA (V)

-10 to 10 

Mid level Absolute
Clock/CA (V)
Low level Absolute
Clock/CA (V)
Hysteresis Absolute
Clock/CA (V)

0 to 10 

Ref Levels Autoset
Basetop Method
Clock/CA

■ MINMAX
■ AUTO
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Configuration Range
Address_Command_
Eye

Acquire Record length (M) 0.001 to 100 
Sample Rate (GS/s) 50 

Analyze tCK (ns) 0.2 to 10 
tcivw (UI) 0 to 2 
vcivw (V) 0 to 10 

Clock/CA Reference Level Ref levels Clock/CA ■ Absolute
■ Percentage

High level Percentage
Clock/CA

1 to 99 

Mid level Percentage
Clock/CA
Low level Percentage
Clock/CA
Hysteresis
Percentage Clock/CA

0 to 50 

High level Absolute
Clock/CA (V)

-10 to 10 

Mid level Absolute
Clock/CA (V)
Low level Absolute
Clock/CA (V)
Hysteresis Absolute
Clock/CA (V)

0 to 10 

Ref Levels Autoset
Basetop Method
Clock/CA

■ MINMAX
■ AUTO
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Configuration Range
Address_Command_
Slew_Rate

Acquire Record length (M) 0.001 to 100 
Sample Rate (GS/s) 50 

Slew rate ref level Auto
Manual CA Reference Level Ref levels CA ■ Absolute

■ Percentage

High level Percentage
CA

1 to 99 

Mid level Percentage
CA
Low level Percentage
CA
Hysteresis
Percentage CA

0 to 50 

High level Absolute
CA (V)

-10 to 10 

Mid level Absolute CA
(V)
Low level Absolute
CA (V)
Hysteresis Absolute
CA (V)

0 to 10 

Ref Levels Autoset
Basetop Method CA ■ MINMAX

■ AUTO

Set preferences tab
parameters

Use Preferences tab to set the application action on completion of a
measurement.
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Figure 6: Preferences tab

Table 14: Preferences tab settings

Setting Description
Actions on Test Measurement Failure
On Test Failure, stop and notify me of the failure Select to stop the test run on Test Failure, and

to get notified via email. By default, it is
unselected.
Click Configure email settings on page 16 to
configure.

NOTE. Ensure that the email settings are
configured correctly. If the settings are not done
correctly, the test will be stopped and no other
notifications will be sent.

Popup Settings
Auto close Warnings and Informations during
Sequencing
Auto close after <no> Seconds

Select to auto close warnings/informations
during sequencing. Set the Auto close time. By
default it is unselected.

NOTE. You must enter non-zero only for
seconds.
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Setting Description
Auto close Error Messages during Sequencing.
Show in Reports
Auto close after <no> Seconds

Select to auto close Error Messages during
Sequencing. Set the Auto close time. By default
it is unselected.

NOTE. You must enter non-zero only for
seconds.

Logging Options
Enable Logging Select to enable/disable the logging feature.

When enabled the application records the
actions of the user. By default, it is selected.

Status panel

Status panel overview The Status panel accesses the Test Status and Log View tabs, which provide
status on test acquisition and analysis (Test Status) and a listing of test tasks
performed (Log View tab). The application opens the Test Status tab when you
start a test run. You can select the Test Status or the Log View tab to view these
items while tests are running. 

Test Status: The tests are grouped and displayed based on the Clock and Data
lane. It displays the tests along with the Acquisition type, Acquire, and Analysis
status of the tests. In pre-recorded mode, Acquire status is not valid.

Log View: It displays the detailed execution status of the tests.
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Figure 7: Test status view in Status panel

Figure 8: Log view in Status panel
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Table 15: Status panel settings

Control Description
Message History Lists all executed test operations and timestamp

information.
Auto Scroll Enables automatic scrolling of the log view as

information is added to the log during the test
execution.

Clear Log Clears all messages from the log view.
Save Saves the log file to a text file. Use the standard

Save File window to navigate to and specify the
folder and file name to which to save the log
text.

See also. Application panels overview on page 17

Results panel

Results panel overview When a test execution is complete, the application automatically opens the
Results panel to display a summary of test results.

Figure 9: Results panel

When a test finishes, the application switches to the Results panel, which displays
a summary of test results.
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Each test result occupies a row in the Results table. By default, results are
displayed in summary format with the measurement details collapsed and with
the Pass/Fail column visible. Change the view in the following ways:

■ To remove or restore the Pass/Fail column, select Preferences > Show Pass/
Fail.

■ To collapse all expanded tests, select Preferences > View Results Summary.

■ To expand all tests listed, select View Results Details from the Preferences
menu in the upper right corner.

■ To enable or disable the wordwrap feature, select Preferences > Enable
Wordwrap.

■ To view the results grouped by lane or test, select the corresponding item
from the Preferences menu.

■ To expand the width of a column, place the cursor over the vertical line that
separates the column from the column to the right. When the cursor changes
to a double-ended arrow, hold down the mouse button and drag the column to
the desired width.

■ To clear all test results displayed, click Clear.

See also. View a report on page 47

Application panels overview on page 17

Preferences menu The Preferences menu is part of the Results panel display. Use the Preferences
menu to change how some items display in the Results panel.

■ To include pass/fail details info in the details table, select Show Pass/Fail.
■ To view the results summary, select View Results Summary.

■ To expand all tests listed, select View Results Details
■ To enable or disable the wordwrap feature, select Enable Wordwrap.

■ To group the tests by lane, select Group by Lane.

■ To group the tests, select Group by Test.

See also. Results panel overview on page 42

View test-related files Files related to tests are stored in My TekExpress\DDR Tx\Untitled session
folder . Each test setup in this folder has both a test setup file and a test setup
folder, both with the test setup name.

The test setup file is preceded by the TekExpress icon and usually has no visible
file name extension.

Inside the test setup folder is another folder named for the DUT ID used in the
test sessions. The default is DUT001.

 Operating basics

TekExpress® DDR Tx Printable Application Help 43



Inside the DUT001 folder are the session folders and files. Each session also has
a folder and file pair, both named for the test session using the naming
convention (date)_(time). Each session file is stored outside its matching session
folder:
 

 

Each session folder contains image files of any plots generated from running the
test session. If you selected to save all waveforms or ran tests using prerecorded
waveform files, these are included here.

The first time you run a new, unsaved session, the session files are stored in the
Untitled Session folder located at X:\DDR Tx. When you name and save the
session, the files are placed in a folder with the name that you specify. A copy of
the test files stay in the Untitled Session folder until you run a new test or until
you close the DDR Tx application.

See also. File name extensions on page 7
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Reports panel

Reports panel overview Use Reports panel to configure report generation settings parameters, view the
report, generate the report, browse for reports, name and save reports, select test
content to include in reports, and select report viewing options.

Figure 10: Reports panel

For information on setting up reports, see Select report options on page 46. For
information on viewing reports, see View a report on page 47.

See also. View a report on page 47

Application panels overview on page 17
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Select report options Click Reports panel and use the Reports panel controls to select which test result
information to include in the report, and the naming conventions to use for the
report. For example, always give the report a unique name or select to have the
same name increment each time you run a particular test.

Select report options before running a test or when creating and saving test
setups. Report settings are included in saved test setups.

In the Reports panel, select from the following report options:

Table 16: Report options

Setting Description
Report Update Mode
Generate new report Creates a new report. The report can be in either .mht or .pdf file formats.
Append with previous run session Appends the latest test results to the end of the current test results report.
Include header in appended reports Select to include header in appended reports
Replace current test in previous run session Replaces the previous test results with the latest test results. Results from newly added

tests are appended to the end of the report.
In previous run, current session Select to replace current test results in the report with the test result(s) of previous run in

current session.
In any run, any session Select to replace current test results in the report with the test result(s) in selected run

session’s report. Click  and select test result of any other run session.
Report Creation Settings
Report name Displays the name and location from which to open a D-PHY report. The default location is

at \My TekExpress\DDR Tx\Untitled Session. The report file in this folder gets overwritten
each time you run a test unless you specify a unique name or select to auto increment the
report name.
Change the report name or location.

Do one of the following:

 

■ In the Report Path field, type over the current folder path and name.
■ Double-click in the Report Path field and then make selections from the popup

keyboard and click the Enter button.

Be sure to include the entire folder path, the file name, and the file extension. For example:
C:\Documents and Settings\your user name\My Documents\My TekExpress\DDR Tx
\DUT001.mht.

 

NOTE. You cannot set the file location using the Browse button.

Open an existing report.
Click Browse, locate and select the report file and then click View at the bottom of the
panel.
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Setting Description
Save as type Saves a report in the specified file type, selected from the drop-down list. The report are

saved in .csv, .pdf or .mht.
 

NOTE. If you select a file type different from the default, be sure to change the report file
name extension in the Report Name field to match.

Auto increment report name if duplicate Sets the application to automatically increment the name of the report file if the application
finds a file with the same name as the one being generated. For example: DUT001,
DUT002, DUT003. This option is enabled by default.

Create report automatically at the end of the
run

Creates report at the end of the run.

Contents To Save
Include pass/fail info in details table Includes pass/fail info in the details table of the report.
Include plot images Includes the plot images in the report.
Include detailed results Includes detailed results in the report.
Include setup configuration Sets the application to include hardware and software information in the summary box at

the top of the report. Information includes: the oscilloscope model and serial number, the
oscilloscope firmware version, and software versions for applications used in the
measurements.

Include complete application configuration Select to complete application configurtion.
Include user comments Select to include any comments about the test that you or another user added in the DUT

tab of the Setup panel. Comments appear in the Comments section, under the summary
box at the beginning of each report.

View report after generating Automatically opens the report in a Web browser when the test completes. This option is
selected by default.

View Click to view the most current report.
Generate Report Generates a new report based on the current analysis results.
Save As Specify a name for the report.

View a report The application automatically generates a report when test execution is complete
and displays the report in your default Web browser (unless you cleared the View
Report After Generating check box in the Reports panel before running the
test). If you cleared this check box, or to view a different test report, do the
following: 

1. Click the Reports button.

2. Click the Browse button and locate and select the report file to view.

3. In the Reports panel, click View.

NOTE. Iteration column will be displayed only when more than one test run is
selected.
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For information on changing the file type, file name, and other report options, see 
Select report options on page 46.

Report content A report shows detailed results and plots, as set in the Reports panel.
 

 

Setup configuration information

The summary box at the beginning of the report lists setup configuration
information. This information includes the oscilloscope model and serial number,
optical module model and serial number, and software version numbers of all
associated applications.

To exclude this information from a report, clear the Include Setup
Configuration check box in the Reports panel before running the test.

User comments

If you selected to include comments in the test report, any comments you added
in the DUT tab are shown at the top of the report.

See also. Results panel overview on page 42

View test-related files on page 43
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Running tests

Compensate the signal path (Prerequisite)
Use the following procedure to compensate the internal signal acquisition path.
Perform this procedure if the ambient temperature has changed more than 5 °C
(9 °F) since you performed the last signal path compensation. Perform the signal
path compensation once a week. Failure to do so may result in the instrument not
meeting warranted performance levels. 

1. Power on and wait for the instrument to complete its warm up period before
continuing with this procedure.

2. Disconnect any probes you have connected to the input channels.

3. Set the instrument to Menu mode.

4. Select Instrument Calibration from the Utilities menu.

5. Note any instructions that appear in the resulting control window.

6. Click Run SPC to begin the procedure. The procedure may take several
minutes to complete.

7. Verify that the Status changes to Compensated after the procedure is
complete. If the Calibration Status field indicates anything other than
Compensated, see Signal Path Compensation Status for information on the
readout and recommended action.

NOTE. When making measurements at vertical scale settings less than or equal to
5 mV, you should perform the signal path compensation at least once a week.
Failure to do so may result in the instrument not meeting warranted performance
levels at those volts/div settings.
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Running tests
Set DUT parameters on page 19, Select tests on page 28, Set acquisition tab
parameters on page 29, Set configuration tab parameters on page 30, Set
preferences tab parameters on page 38, and click Start to run the tests. While
tests are running, you cannot access the Setup or Reports panels. To monitor the
test progress, switch between the Status panel and the Results panel. 

While tests are running, the other applications will be displayed at the
background. If you want the TekExpress DDR Tx application to run in the
foreground select Keep On Top from the TekExpress Options menu.

The application displays report when the tests execution is complete.

Pre-run checklist 1. Make sure that the instruments are warmed up (approximately 20 minutes)
and stabilized.

2. Perform compensation: In the oscilloscope main menu, select Utilities >
Instrument Compensation. Click Help in the compensation window for
steps to perform instrument compensation.

View test results
When a test completes, the application switches to the Results panel, which
shows a summary of test results.

Each test result occupies a row in the Results table. By default, results are
displayed in summary format, with the measurement details collapsed. You can
change the view in the following ways:

■ To view the results grouped by lane, test, or data rate, select the
corresponding item from the Preferences menu.

■ To expand all tests listed, select View Results Details from the Preferences
menu.

■ To expand and collapse tests, use the plus and minus buttons to the left of the
test rows.

■ To collapse all expanded tests, select Preferences > View Results
Summary.

■ To enable or disable the wordwrap feature, select Preferences > Enable
Wordwrap.

■ To expand the width of a column, place the cursor over the vertical line that
separates the column from the one to the right. When the cursor changes to a
double-ended arrow, hold down the mouse button and drag the column to the
desired width.
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■ To sort the test information by column, click the column head. When sorted
in ascending order, a small up arrow is displayed. When sorted in descending
order, a small down arrow is displayed.

■
To clear all test results displayed, click Clear ( ).
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Saving and recalling test setup

Test setup files overview
Saved test setup information (such as the selected oscilloscope, general
parameters, acquisition parameters, measurement limits, waveforms (if
applicable), and other configuration settings) are saved under the setup name at
X:\DDR Tx.

Use test setups to:

■ Run a new session, acquiring live waveforms, using a saved test
configuration.

■ Create a new test setup using an existing one.

■ View all the information associated with a saved test, including the log file,
the history of the test status as it executed, and the results summary.

■ Run a saved test using saved waveforms.

See also Save a test setup

Open (load) a saved test setup

Save a test setup
You can save a test setup before or after running a test. You can create a test
setup from already created test setup, or using default test setup. When you
select the default test setup, the parameters are set to the application’s default
value.

Select Options > Save Test Setup to save the opened setup.

Select Options > Save Test Setup As to save the setup with different name.
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Open load a saved test setup
To Open (load) a saved test setup, do the following:

1. Select Options > Open Test Setup.

2. Select the setup from the list and click Open. Setup files are located at X:
\DDR Tx\.

See also About test setups

Create a test setup using an existing one

Create a test setup from default settings

Create a test setup using an existing one
To create a test setup using an existing one, follow the steps:

1. Select Options > Open Test Setup

2. Select a setup from the list and then click Open

3. Click application setup and modify the parameters

4. Click application reports and modify the report options

5. Select Options > Save Test Setup As

6. Enter test setup name, and click Save.

Create a test setup from default settings
To create a test setup using default settings, follow the steps:

1. Select Options > Default Test Setup. For default test setup, the parameters
are set to the application’s default value.

2. Click application Setup and set the parameters

3. Click application Reports and set the report options

4. Optional: Click Start to run the test and verify that it runs correctly and
captures the specified test information and reports. If it does not, then edit the
parameters and repeat this step until the test runs to your satisfaction

5. Select Options > Save Test Setup. Enter the file name and click Save. The
application saves the file to X:\DDR Tx\<session_name>
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SCPI commands

About SCPI command
You can use Standard Commands for Programmable Instruments (SCPI) to
communicate with the TekExpress application.

Socket configuration for SCPI commands
This section describes the steps for TCPIP socket configuration and TekVISA
configuration to execute the SCPI commands.

TCPIP socket
configuration

1. Click Start > Control Panel > System and Security > Windows Firewall >
Advanced settings.
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2. In Windows Firewall with Advanced Security menu, select Windows
Firewall with Advanced Security on Local Computer > Inbound Rules
and click New Rule…
 

 
3. In New Inbound Rule Wizard menu

a. Select Port and click Next.
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b. Select TCP as rule apply and enter 5000 for Specific local ports and
click Next.
 

 
c. Select Allow the connection and click Next.
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d. Select Domain, Private, Public and click Next.
 

 
e. Enter Name, Description (optional), and click Finish.
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4. Check whether the Rule name is displayed in Windows Firewall with
Advanced Security menu > Inbound Rules.
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TekVISA configuration 1. Click Start > All Programs > TekVISA > OpenChoice Instrument
Manager.
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2. Click Search Criteria. In Search Criteria menu, click LAN to Turn-on.
Select Socket from the drop-down list, enter the IP address of the

TekExpress device in Hostname and type Port as 5000. Click  to
configure the IP address with Port.

Enter the Hostname as 127.0.0.1 if the TekVISA and TekExpress application
are in the same system, else enter the IP address of the TekExpress
application system.
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3. Click Search to setup the TCPIP connection with the host. Check whether
the TCPIP host name is displayed in OpenChoice Instrument Manager >
Instruments.
 

 
4. Double-click OpenChoice Talker Listener and enter the Command *IDN?

in command entry field and click Query. Check that the Operation is
successful and Talker Listener Readout displays the Command / Data.
 

 

SCPI commands  

62  TekExpress® DDR Tx Printable Application Help



TEKEXP:*IDN?
This command queries the active TekExpress application name running on the
oscilloscope. 

Syntax TEKEXP:*IDN?\n

Inputs NA

Outputs Returns active TekExpress application name running on the oscilloscope.

TEKEXP:*OPC?
This command queries the execution status of the last executed command. 

Syntax TEKEXP:*OPC?\n

Inputs NA

Outputs 0 - last command execution is not complete

1 - last command execution is complete
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TEKEXP:ACQUIRE_MODE
This command sets the acquire mode as live or pre-recorded.

Syntax TEKEXP:ACQUIRE_MODE {LIVE | PRE-RECORDED}\n

Inputs {LIVE | PRE-RECORDED}

Outputs NA

TEKEXP:ACQUIRE_MODE?
This command queries the acquire mode type.

Syntax TEKEXP:ACQUIRE_MODE?\n

Inputs NA

Outputs {LIVE | PRE-RECORDED}
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TEKEXP:EXPORT
This command returns all the bytes of data to the specified file. 

Syntax Outputs
TEKEXP:EXPORT REPORT\n Returns the report file in bytes
TEKEXP:EXPORT WFM,"<FileName>"\n Returns the specified waveform file in bytes
TEKEXP:EXPORT IMAGE,"<FileName>"\n Returns the specified image file in bytes

Inputs FileName - Specifies the file name

TEKEXP:INFO?
This command queries the information about the file(s).

Syntax Outputs
TEKEXP:INFO?
REPORT\n

<ReportFileSize>,"<ReportFileName.mht>"

TEKEXP:INFO? WFM
\n

<WfmFile1Size>,"<WfmFileName1.wfm>";<WfmFile2Size>,"<WfmFileNa
me2.wfm>";...

TEKEXP:INFO?
IMAGE\n

<Image1FileSize>,"<Image1FileName>";<Image2FileSize>,"<Image2File
Name>" ;...
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TEKEXP:INSTRUMENT
This command sets the value for the selected instrument type. 

Syntax TEKEXP:INSTRUMENT "<InstrumentType>",<Value>"\n

Inputs InstrumentType

Value

TIP. Check Command parameters list section for InstrumentType and Value
parameters.

Outputs NA

TEKEXP:INSTRUMENT?
This command queries the instrument selected for the specified instrument type. 

Syntax TEKEXP:INSTRUMENT? "<InstrumentType>"\n

Inputs InstrumentType

TIP. Check Command parameters list section for InstrumentType parameters.

Outputs Returns the instrument selected for the specified instrument type

SCPI commands  

66  TekExpress® DDR Tx Printable Application Help



TEKEXP:LASTERROR?
This command queries the last error string occurred for the current TCP session.
If there are no errors since startup, or since the last call to
TEKEXP:LASTERROR?\n, this command returns an empty string.

Syntax TEKEXP:LASTERROR?\n

Inputs NA

Outputs <string>

TEKEXP:LIST?
This command queries the list of available device, suite, test, version or
instrument. 

Syntax Outputs
TEKEXP:LIST? DEVICE\n Returns the list of available device(s) as comma

separated values.
TEKEXP:LIST? SUITE\n Returns the list of available suite(s) as comma

separated values.
TEKEXP:LIST? TEST\n Returns the list of available test(s) as comma

separated values.
TEKEXP:LIST? VERSION\n Returns the list of available version(s) as comma

separated values.
TEKEXP:LIST?
INSTRUMENT,"<InstrumentType>"\n

Returns the list of available instruments' for the
given Instrument type as comma separated
values.

NOTE. This command returns the list of items within double quotes (""). Iterate
the receive procedure until the list ends with double quotes otherwise the next
query commands won’t work as expected.
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Inputs InstrumentType

TIP. Check Command parameters list section for InstrumentType parameters.

TEKEXP:MODE
This command sets the execution mode as compliance or user defined. 

Syntax TEKEXP:MODE {COMPLIANCE | USER-DEFINED}\n

Inputs {COMPLIANCE | USER-DEFINED}

Outputs NA

TEKEXP:MODE?
This command queries the execution mode type. 

Syntax TEKEXP:MODE?\n

Inputs NA

Outputs {COMPLIANCE | USER-DEFINED}
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TEKEXP:POPUP
This command sets the response to the active popup shown in the application.

Syntax TEKEXP:POPUP “<PopupResponse>”\n

Inputs PopupResponse

Outputs NA

TEKEXP:POPUP?
This command queries the active popup information shown in the application.

Syntax TEKEXP:POPUP?\n

Inputs NA

Outputs Returns the active popup information in the application.
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TEKEXP:REPORT
This command generates the report for the current session. 

Syntax TEKEXP:REPORT GENERATE\n

Inputs GENERATE

Outputs NA

TEKEXP:REPORT?
This command queries the queried header field value in the report.

Syntax TEKEXP:REPORT? “<HeaderField>”\n

Inputs HeaderField - Specifies to return the measured value for the indicated test.

TIP. Check Report for HeaderField parameters.

Outputs Returns the queried header field value in the report
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TEKEXP:RESULT?
This command queries the result available in report summary/details table.

Syntax Outputs
TEKEXP:RESULT? "<TestName>"\n Return Pass/Fail status of the test.
TEKEXP:RESULT?
"<TestName>","<ColumnName>"\n

Returns all the row values of the specified
column for the test.

TEKEXP:RESULT?
"<TestName>","<ColumnName>",<RowNumber
>\n

Returns the column value for the specified row
number  1

Inputs TestName - Specifies the name of the test for which to obtain the test result
value.

ColumnName - Specifies the column name for the measurement

RowNumber - Specifies the row number of the measurement

TIP. Check Results panel for TestName, ColumnName, and RowNumber
parameters.

1 Row number starts from zero.
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TEKEXP:SELECT
This command selects the device, suite, version, or test. 

Syntax TEKEXP:SELECT <string1>,<string2>,<string4>\n

TEKEXP:SELECT TEST,<string3>,<string4>\n

Inputs <string1> = {DEVICE | SUITE | VERSION}

<string2> = {DeviceName | SuiteName | VersionName}

<string3> = {“<TestName>"| ALL| REQUIRED }

<string4> = {TRUE | FALSE}

TIP. Check Command parameters list section for DeviceName, SuiteName,
VersionName, and TestName parameters.

Outputs NA

TEKEXP:SELECT?
This command queries the name of the selected device, suite, version, or test. 

Syntax TEKEXP:SELECT? {DEVICE | SUITE | TEST | VERSION}\n

Inputs {DEVICE | SUITE | TEST | VERSION}
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Outputs Returns the name of the selected device, suite, version, or test.

TEKEXP:SETUP
This command sets the value of the current setup.

Syntax Outputs
TEKEXP:SETUP DEFAULT\n Restore to default Setup
TEKEXP:SETUP OPEN,"<SessionName>"\n Open the session
TEKEXP:SETUP SAVE\n Saves the already existing modified session
TEKEXP:SETUP SAVE,"<SessionName>"\n Save the session

Inputs SessionName - The name of the session

TEKEXP:STATE
This command sets the execution state of the application.

Syntax TEKEXP:STATE {RUN | STOP | PAUSE | RESUME}\n

Inputs {RUN | STOP | PAUSE | RESUME}

Outputs NA
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TEKEXP:STATE?
This command queries the current setup state. 

Syntax Outputs
TEKEXP:STATE? RUNNING | PAUSED | WAIT | ERROR | READY
TEKEXP:STATE? SETUP SAVED | NOT_SAVED

TEKEXP:VALUE
This command sets the value of parameters of type General, Acquire, Analyze, or
DUTID. 

Syntax TEKEXP:VALUE GENERAL,"<ParameterName>",“<Value>”\n

TEKEXP:VALUE ACQUIRE,“<TestName>","<AcquireType>",
"<ParameterName>",“<Value>”\n

TEKEXP:VALUE ANALYZE,“<TestName>","<ParameterName>".“<Value>”
\n

TEKEXP:VALUE DUTID,“<Value>”\n

TEKEXP:VALUE VERBOSE,{TRUE | FALSE}\n

TEKEXP:VALUE
WFMFILE,<Test_Name>,<Aquire_Type>,<FilesName1$FileName2>\n

Inputs ParameterName - Specifies the parameter name

TestName - Specifies the test name

AcquireType - Specifies the acquire type

Value - Specifes the value to set

FilesName1$FileName2 - Specifies the waveform file name

TRUE - Pop-ups are enabled

FALSE - Pop-ups are disabled

TIP. Check Command parameters list section for ParameterName, AcquireType,
and Value parameters.
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Outputs NA

TEKEXP:VALUE?
This command queries the value of the parameter for type General, Acquire,
Analyze, or DUTID.

Syntax Outputs
TEKEXP:VALUE?
GENERAL,"<ParameterName>"\n

Returns the value of Parameter for type
GENERAL

TEKEXP:VALUE? ACQUIRE,“<TestName>",
"<AcquireType>","<ParameterName>"\n

Returns the value of Parameter for type
ACQUIRE

TEKEXP:VALUE? ANALYZE,
“<TestName>","<ParameterName>"\n

Returns the value of Parameter for type
ANALYZE

TEKEXP:VALUE? DUTID\n Returns the DUTID value
TEKEXP:VALUE?
WFMFILE,<Test_Name>,<Aquire_Type>\n

Returns the waveform file name

TEKEXP:VALUE? VERBOSE Returns the verbose mode type

Inputs ParameterName - Specifies the parameter name

TestName - Specifies the test name

AcquireType - Specifies the acquire type

TRUE - Pop-ups are enabled

FALSE - Pop-ups are disabled

TIP. Check Command parameters list section for ParameterName and
AcquireType parameters.

Outputs Returns the value of Parameter for type GENERAL | ACQUIRE | ANALYZE |
DUTID.
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Command parameters list
This section provides the parameters list for the SCPI commands.

Specifies the Parameter Name and Value for DUT, Test selection, Acquisition,
Configuration and Preferences tabs.

Table 17: ParameterName and Value for DUT tab

Parameters Description
DUT ID Specifies the value parameters For DUTID, valid value is: Comment
Acquiremode Specifies the acquire mode parameter: Acquire live waveforms
Use pre-recorded mode Specifies the pre-recorded parameter: Use pre-recorded waveform files
Device DDR5
User Defined Acquisition Enables user to define the acquisition settings of their choice.
TriMode Probe Setup With TriMode probing, one probe setup makes differential, single-ended, and common

mode measurements accurately.
Device Profile
Data Rate Specifies the different data rates supported(3200>=DR<=8400).

Valid values are:

■ 3200 
■ 3600 
■ 4000 
■ 4400 
■ 4800 
■ Custom

Vdd Specifies the Vdd mode.
Valid values are:

■ JEDEC Default
■ Manual

Vdd Display Displays the Vdd value in Volts. To set the Vdd a valid Double value can be specified.

NOTE. Set Vdd to Manual Mode before setting its value.

Vcent-DQ Modes supported for setting Vcent_DQ value.
Valid values are:

■ Auto
■ Manual

Vcent_DQ Display Specifies the Vcent_DQ value in Volts. To set the Vcent_DQ a valid Double value can be
specified.

NOTE. Set Vcent_DQ to Manual Mode before setting its value.
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Parameters Description
Vref-CA Modes supported for setting Vref_CA value.

Valid values are:

■ Auto
■ Manual

Vref-CA Display Specifies the Vref-CA value in Volts. To set the Vref-CA a valid Double value can be
specified.

NOTE. Set Vref-CA to Manual Mode before setting its value.

Burst Detection Method Specifies the modes of burst detection for Data signals.
Valid values are:

■ Read Write Bursts
■ Write Only Bursts
■ Read Only Bursts
■ Visual Search

Clock Signal Probe Type Specifies the signal type for clock and Data.
Valid values are:

■ Differential
■ Single Ended

Data Signal Probe Type Specifies the type of Data signals.
Valid values are:

■ Differential
■ Single Ended

DeEmbed Filter Files Specifies the DeEmbed Filter file settings.
Valid values are:

■ Enabled
■ Disabled

DQS Probe Mode Specifies the Trimode Probe Settings for DQS signal.
Valid values are:

■ A
■ B
■ Differential

Clock Probe Mode Specifies the Trimode Probe Settings for Clock signal.
Valid values are:

■ A
■ B
■ Differential
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Parameters Description
DQSPositive Probe Mode Specifies the Trimode Probe Settings for DQS (+) signal.

Valid values are:

■ A
■ B
■ Differential

DQ Probe Mode Specifies the Trimode Probe Settings for DQ signal.
Valid values are:

■ A
■ B
■ Differential

ADDR CMD Probe Mode Specifies the Trimode Probe Settings for Command and Address signal.
Valid values are:

■ A
■ B
■ Differential

Clock Positive Probe Mode Specifies the Trimode Probe Settings for Clock (+) signal.
Valid values are:

■ A
■ B
■ Differential

Clock Negative Probe Mode Specifies the Trimode Probe Settings for Clock (-) signal.
Valid values are:

■ A
■ B
■ Differential

DQSNegative Probe Mode Specifies the Trimode Probe Settings for DQS (-) signal.
Valid values are:

■ A
■ B
■ Differential

DQS_Write Connected to Filter File Mention the path for filter file for DQS Write signal
Clock Connected to Filter File Mention the path for filter file for Clock signal
DQS(+)_Write Connected to Filter File Mention the path for filter file for Strobe Positive for Data signal
DQS(-)_Write Connected to Filter File Mention the path for filter file for Strobe Negative for Data signal
DQ_Read Connected to Filter File Mention the filter file path for Data Read Signal
DQ_Write Connected to Filter File Mention the filter file path for Data Write Signal

SCPI commands  

78  TekExpress® DDR Tx Printable Application Help



Parameters Description
CA Connected to Filter File Mention the filter file path for Command and Address Signal
Clock(+) Connected to Filter File Mention the filter file path for Clock Positive Signal
Clock(-) Connected to Filter File Mention the filter file path for Clock Positive Signal
RB:DQ/DQS Phase Alignment:Pre-amble
Length (tCK)

Specifies the Read Data signal’s preamble-length, for Read Write Burst Detection Method.
Valid Values are 1, 2, 3, 4.

RB:DQ/DQS Phase Alignment:Post-amble
Length (tCK)

Specifies the Read Data signal’s postamble-length, for Read Write Burst Detection Method.
Valid Values are 0.5 and 1.5.

RB:DQ/DQS Phase Alignment:Burst(pk-pk) Specifies the Pk-Pk amplitude value of the Read traffic, in Read Write Burst detection
method. Valid Range is 0-5.

RB:DQ/DQS Phase Alignment:Margin(%) Specifies the Margin for Read traffic in Read Write Burst Detection method. Valid Range is
0-100.

RB:DQ/DQS Phase
Alignment:IsReadWriteGreater

Specifies if the Read Data’s amplitude is greater than the Write Data’s amplitude. Valid
values are Yes and No.

RB:DQ/DQS Phase Alignment:Strobe High Specifies the High Reference level for Strobe signal for Read traffic, in Read Write Burst
Detection method. Valid range is -5 to 5.

RB:DQ/DQS Phase Alignment:Strobe Mid Specifies the Mid Reference level for Strobe signal for Read traffic, in Read Write Burst
Detection method. Valid range is -5 to 5.

RB:DQ/DQS Phase Alignment:Strobe Low Specifies the Mid Reference level for Strobe signal for Read traffic, in Read Write Burst
Detection method. Valid range is -5 to 5.

RB:DQ/DQS Phase Alignment:Data High Specifies the High Reference level for Data Read signal, in Read Write Burst Detection
method. Valid range is -5 to 5.

RB:DQ/DQS Phase Alignment:Data Mid Specifies the Mid Reference level for Data Read signal, in Read Write Burst Detection
method. Valid range is -5 to 5.

RB:DQ/DQS Phase Alignment:Data Low Specifies the Low Reference level for Data Read signal, in Read Write Burst Detection
method. Valid range is -5 to 5.

RB:DQ/DQS Phase Alignment:Hysteresis Specifies Hysteresis value for Data Read signal, in Read Write Burst Detection method.
Valid range is 0 to 50.

RB:DQ/DQS Phase Alignment:Margin Specifies Margin value for Data Read signal, in Read Write Burst Detection method. Valid
range is 0 to 100.

WB:DQ/DQS Phase Alignment:tDQS2DQ
Type

Specifies the tDQS2DQ type, in Read Write Burst Detection Method. Valid Values are Auto
and Manual.

WB:DQ/DQS Phase Alignment:tDQS2DQ
Value (ps)

Specifies the tDQS2DQ value, in Read Write Burst Detection Method. Valid Range is 0 to
1875ps.

WB:DQ/DQS Phase Alignment:Pre-amble
Length (tCK)

Specifies the Write Data signal’s preamble-length, for Read Write Burst Detection Method.
Valid Values are 2, 3, and 4.

WB:DQ/DQS Phase Alignment:Post-amble
Length (tCK)

Specifies the Write Data signal’s postamble-length, for Read Write Burst Detection Method.
Valid Values are 0.5 and 1.5.

WB:DQ/DQS Phase Alignment:Burst(pk-pk) Specifies the Pk-Pk amplitude value of the Write traffic, in Read Write Burst detection
method. Valid Range is 0-5.

WB:DQ/DQS Phase Alignment:Margin(%) Specifies the Margin for Write traffic in Read Write Burst Detection method. Valid Range is
0-100.
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Parameters Description
WB:DQ/DQS Phase
Alignment:IsReadWriteGreater

Specifies if the Read Data’s amplitude is greater than the Write Data’s amplitude. Valid
values:

■ Yes
■ No

WB:DQ/DQS Phase Alignment:Strobe High Specifies the High Reference level for Strobe signal for Write traffic, in Read Write Burst
Detection method. Valid range is -5 to 5.

WB:DQ/DQS Phase Alignment:Strobe Mid Specifies the Mid Reference level for Strobe signal for Write traffic, in Read Write Burst
Detection method. Valid range is -5 to 5.

WB:DQ/DQS Phase Alignment:Strobe Low Specifies the Mid Reference level for Strobe signal for Write traffic, in Read Write Burst
Detection method. Valid range is -5 to 5.

WB:DQ/DQS Phase Alignment:Data High Specifies the High Reference level for Data Write signal, in Read Write Burst Detection
method. Valid range is -5 to 5.

WB:DQ/DQS Phase Alignment:Data Mid Specifies the Mid Reference level for Data Write signal, in Read Write Burst Detection
method. Valid range is -5 to 5.

WB:DQ/DQS Phase Alignment:Data Low Specifies the Low Reference level for Data Write signal, in Read Write Burst Detection
method. Valid range is -5 to 5.

WB:DQ/DQS Phase Alignment:Hysteresis Specifies Hysteresis value for Data Write signal, in Read Write Burst Detection method.
Valid range is 0 to 50.

WB:DQ/DQS Phase Alignment:Margin Specifies Margin value for Data Write signal, in Read Write Burst Detection method. Valid
range is 0 to 100.

Read Burst:Pre-amble Length (tCK) Specifies the Read Data signal’s preamble-length, for Read Only Burst Detection Method.
Valid Values are 1, 2, 3, and 4.

Read Burst:Post-amble Length (tCK) Specifies the Read Data signal’s postamble-length, for Read Only Burst Detection Method.
Valid Values are 0.5 and 1.5.

Read Burst:Burst Length Specifies the length of the Read burst, in Read Only Burst Detection method. Valid values
are 16 and 32.

Read Burst:Strobe High Specifies the High Reference level for Strobe signal for Read traffic, in Read Only Burst
Detection method. Valid range is -1.1 to 1.1.

Read Burst:Strobe Mid Specifies the Mid Reference level for Strobe signal for Read traffic, in Read Only Burst
Detection method. Valid range is -1.1 to 1.1.

Read Burst:Strobe Low Specifies the Low Reference level for Strobe signal for Read traffic, in Read Only Burst
Detection method. Valid range is -1.1 to 1.1.

Read Burst:Data High Specifies the High Reference level for Data Read signal, in Read Only Burst Detection
method. Valid range is -1.1 to 1.1.

Read Burst:Data Mid Specifies the Mid Reference level for Data Read signal, in Read Only Burst Detection
method. Valid range is -1.1 to 1.1.

Read Burst:Data Low Specifies the Low Reference level for Data Read signal, in Read Only Burst Detection
method. Valid range is -1.1 to 1.1.

Read Burst:Hysteresis Specifies the Hysteresis value for Read Data signal, in Read Only burst detection method.
Valid range is 0 to 20.

Read Burst:Margin Specifies the Margin value for Read Data signal, in Read Only burst detection method.
Valid range is 0 to 100.
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Parameters Description
Write Burst:tDQS2DQ Type Specifies the tDQS2DQ type, in Write Only Burst Detection Method. Valid Values are Auto

and Manual.
Write Burst:tDQS2DQ Value (ps) Specifies the tDQS2DQ value, in Write Only Burst Detection Method. Valid Range is 0 to

1875ps.
Write Burst:Pre-amble Length (tCK) Specifies the Write Data signal’s preamble-length, for Write Only Burst Detection Method.

Valid Values are 2, 3, and 4.
Write Burst:Post-amble Length (tCK) Specifies the Write Data signal’s postamble-length, for Write Only Burst Detection Method.

Valid Values are 0.5 and 1.5.
Write Burst:Burst Length Specifies the length of the Write burst, in Write Only Burst Detection method. Valid values

are 16 and 32.
Write Burst:Strobe High Specifies the High Reference level for Strobe signal for Write traffic, in Write Only Burst

Detection method. Valid range is -1.1 to 1.1.
Write Burst:Strobe Mid Specifies the Mid Reference level for Strobe signal for Write traffic, in Write Only Burst

Detection method. Valid range is -1.1 to 1.1.
Write Burst:Strobe Low Specifies the Low Reference level for Strobe signal for Write traffic, in Write Only Burst

Detection method. Valid range is -1.1 to 1.1.
Write Burst:Data High Specifies the High Reference level for Data Write signal, in Write Only Burst Detection

method. Valid range is -1.1 to 1.1.
Write Burst:Data Mid Specifies the Mid Reference level for Data Read signal, in Read Only Burst Detection

method. Valid range is -1.1 to 1.1.
Write Burst:Data Low Specifies the Low Reference level for Data Read signal, in Read Only Burst Detection

method. Valid range is -1.1 to 1.1.
Write Burst:Hysteresis Specifies the Hysteresis value for Write Data signal, in Write Only burst detection method.

Valid range is 0 to 20.
Write Burst:Margin Specifies the Margin value for Write Data signal, in Write Only burst detection method. Valid

range is 0 to 100.
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Table 18: ParameterName and Value for Test Selection tab

Parameters Description
Test Name Specifies the test measurement name.

Clock Group measurements

■ tCK
■ tCK_Duty_UI_Error
■ tCK_1UI_Rj_NoBUJ
■ tCK_1UI_Dj_NoBUJ
■ tCK_1UI_Tj_NoBUJ
■ tCK_2UI_Rj_NoBUJ
■ tCK_2UI_Dj_NoBUJ
■ tCK_2UI_Tj_NoBUJ
■ tCK_3UI_Rj_NoBUJ
■ tCK_3UI_Dj_NoBUJ
■ tCK_3UI_Tj_NoBUJ
■ tCK_nUI_Rj_NoBUJ
■ tCK_nUI_Dj_NoBUJ
■ tCK_nUI_Tj_NoBUJ
■ VIHdiff.CK(AC)
■ VIHdiff.CK(DC)
■ VILdiff.CK(AC)
■ VILdiff.CK(DC)
■ SRIdiff-Rise
■ SRIdiff-Fall
■ VIX_CK_Ratio

Write Burst measurements

■ tWPRE
■ tWPST
■ tDQS2DQ
■ tDQSS
■ tDSS
■ tDSH
■ RxMask
■ InputSlew-Diff-Rise(DQS)
■ InputSlew-Diff-Fall(DQS)
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Parameters Description

■ VIX_DQS_Ratio

Read Burst measurements

■ tRPRE
■ tRPST
■ tDQSCK
■ VOHdiff(AC)
■ VOLdiff(AC)
■ VOH(AC)
■ VOH(DC)
■ VOL(AC)
■ VOL(DC)
■ SRQdiff-Rise(DQS)
■ SRQdiff-Fall(DQS)
■ SRQse-Rise(DQ)
■ SRQse-Fall(DQ)

Address Command measurements

■ VIHL_AC
■ RxMask_CA
■ VciVW
■ TciVW
■ TciPW_Positive
■ TciPW_Negative
■ SRIN_cIVW_Rise
■ SRIN_cIVW_Fall
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Table 19: ParameterName and Value for Acquisition tab

Parameters Description
DQ Connected to : Signal Selected Enables/ disables the DQ source channel.

Valid values are:

■ True
■ False

DQ Connected to Specifies the source channel to which the Data signal is connected.
Valid Values are:

■ CH1
■ CH2
■ CH3
■ CH4

DQS Connected to : Signal Selected Enables/ disables the DQS source channel.
Valid values are:

■ True
■ False

DQS Connected to Specifies the source channel to which the Data Strobe signal is connected.
Valid Values are:

■ CH1
■ CH2
■ CH3
■ CH4

CA Connected to : Signal Selected Enables/ disables the CA source channel.
Valid values are:

■ True
■ False

CA Connected to Specifies the source channel to which the Address command signal is connected.
Valid Values are:

■ CH1
■ CH2
■ CH3
■ CH4

Clock Connected to : Signal Selected Enables/ disables the Clock signal source when clock signal probe type is set to
"Differential".
Valid values are:

■ True
■ False
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Parameters Description
Clock Connected to Specifies the source channel to which the Clock signal is connected.

Valid Values are:

■ CH1
■ CH2
■ CH3
■ CH4

Clock(+) Connected to : Signal Selected Enables/ disables the Clock signal source when clock signal probe type is set to "Single-
Ended".
Valid values are:

■ True
■ False

Clock(+) Connected to Specifies the source channel to which the clock signal (Positive) is connected to, when the
Clock Signal Probe Type is selected as single ended.
Valid Values are:

■ CH1
■ CH2
■ CH3
■ CH4

Clock(-) Connected to : Signal Selected Enables/ disables the Clock signal source when clock signal probe type is set to "Single-
Ended".
Valid values are:

■ True
■ False

Clock(-) Connected to Specifies the source channel to which the clock signal (Negative) is connected to, when the
Clock Signal Probe Type is selected as single ended.
Valid Values are:

■ CH1
■ CH2
■ CH3
■ CH4

Show Acquire Parameters ■ True
■ False

DQS(+) Connected to : Signal Selected Specifies if the Strobe Positive signal is selected in the acquisition panel. Valid Values are:

■ True
■ False
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Parameters Description
DQS(-) Connected to : Signal Selected Specifies if the Strobe Negative signal is selected in the acquisition panel. Valid Values are:

■ True
■ False

DQS(+) Connected to Specifies the source channel to which the Data strobe positive is connected.
Valid Values are:

■ CH1
■ CH2
■ CH3
■ CH4

DQS(-) Connected to Specifies the source channel to which the Data strobe negative is connected.
Valid Values are:

■ CH1
■ CH2
■ CH3
■ CH4

Table 20: ParameterName and Value for Configuration tab

Parameters Description
Bandwidth20GHz Specifies the bandwidth to be set on the oscilloscope. Valid Range is 8 to 20.
Bandwidth16GHz Specifies the bandwidth to be set on the oscilloscope. Valid Range is 8 to 16.

Table 21: ParameterName and Value for Preferences tab

Parameters Description
On Test Failure, stop and notify me of the
failure ■ True

■ False

Email Settings ■ Recipient e-mail Address
■ Sender's Address

Timer Warning Info Message Popup Specifies the behavior of Warning message pop-ups.
Valid Values are:

■ True
■ False
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Parameters Description
Timer Warning Info Message Popup Duration Sets the time duration for which the Warning message pop up is displayed.

Valid Values are:

■ -2 
■ 2 

Timer Error Message Popup Specifies the behavior of Error message pop-ups.
Valid Values are:

■ True
■ False

Timer Error Message Popup Duration Sets the time duration for which the Error message pop up is displayed.
Valid Values are:

■ -2 
■ 2 

Enable Logging Specifies if additional logs are to be captured. Valid values are:

■ True
■ False

Table 22: ParameterName and Value for Acquire

Acquire Type Parameter name Value
Clock
Clock_Slew_Rate
WR_Differential_Strobe
WR_Data_Eye
WR_Slew_Rate
RD_Differential_Strobe
RD_Output_Level
RD_Slew_Rate
Address_Command
Address_Command_Eye
Address_Command_Slew_Rate

Sample Rate (GS/s) 50 
Record Length (M) 0.001 to 100 

Table 23: ParameterName and Value for Analyze

Acquire Type Parameter name Value
Clock Target BER 3 to 22 

N value Start 4 to 30 
N value Stop 4 to 30 
Number of UI state ■ TRUE

■ FALSE

Number of UI value 0.001 to 2000 
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Acquire Type Parameter name Value
Worst Case Logging ■ TRUE

■ FALSE

WR_Data_Eye tCK Value 0.2 to 10 
Eye Width (UI) 0 to 2 
Eye Height (mV) 0 to 1000 
DQS/DQ/Clock Reference Level Ref levels DQS/DQ/Clock ■ Absolute

■ Percentage

High level Percentage DQS/DQ/
Clock

1 to 99 

Mid level Percentage DQS/DQ/
Clock
Low level Percentage DQS/DQ/
Clock
Hysteresis Percentage DQS/DQ/
Clock

0 to 50 

High level Absolute DQS/DQ/
Clock

-10 to 10 

Mid level Absolute DQS/DQ/
Clock
Low level Absolute DQS/DQ/
Clock
Hysteresis Absolute DQS/DQ/
Clock

0 to 10 

Ref Levels Autoset Basetop
Method DQ/Clock ■ MINMAX

■ AUTO

Apply DFE ■ TRUE
■ FALSE

Superimpose DQS ■ TRUE
■ FALSE

Gain(dB) -6 to 6 
Threshold(mV) 0 to 2000 
Tap1(mV) -200 to 50 
Tap2(mV) -75 to 75 
Tap3(mV) -60 to 60 
Tap4(mV) -45 to 45 

SCPI commands  

88  TekExpress® DDR Tx Printable Application Help



Acquire Type Parameter name Value
Stop on Mask Hit ■ TRUE

■ FALSE

Clock_Slew_Rate Slew Rate ref level ■ AUTO
■ Manual

Number of UI state ■ TRUE
■ FALSE

Number of UI value 0.001 to 2000 
Worst Case Logging ■ TRUE

■ FALSE

Clock Reference Level Ref levels Clock ■ Absolute
■ Percentage

High level Percentage Clock 1 to 99 
Mid level Percentage Clock
Low level Percentage Clock
Hysteresis Percentage Clock 0 to 50 
High level Absolute Clock -10 to 10 
Mid level Absolute Clock
Low level Absolute Clock
Hysteresis Absolute Clock 0 to 10 
Ref Levels Autoset Basetop
Method Clock ■ MINMAX

■ AUTO

WR_Slew_Rate
Address_Command_Slew_Rate
RD_Slew_Rate

Slew Rate ref level ■ AUTO
■ Manual

DQS/DQ/CA/Clock Reference
Level

Ref levels DQS/DQ/CA/Clock ■ Absolute
■ Percentage

High level Percentage DQS/DQ/
CA/Clock

1 to 99 

Mid level Percentage DQS/DQ/
CA/Clock
Low level Percentage DQS/DQ/
CA/Clock
Hysteresis Percentage DQS/DQ/
CA/Clock

0 to 50 
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Acquire Type Parameter name Value
High level Absolute DQS/DQ/CA/
Clock

-10 to 10 

Mid level Absolute DQS/DQ/CA/
Clock
Low level Absolute DQS/DQ/CA/
Clock
Hysteresis Absolute DQS/DQ/
CA/Clock

0 to 10 

Ref Levels Autoset Basetop
Method DQ/CA/Clock ■ MINMAX

■ AUTO

Address_Command Clock/CA Reference Level Ref levels Clock/CA ■ Absolute
■ Percentage

High level Percentage Clock/CA 1 to 99 
Mid level Percentage Clock/CA
Low level Percentage Clock/CA
Hysteresis Percentage Clock/CA 0 to 50 
High level Absolute Clock/CA -10 to 10 
Mid level Absolute Clock/CA
Low level Absolute Clock/CA
Hysteresis Absolute Clock/CA 0 to 10 
Ref Levels Autoset Basetop
Method Clock/CA ■ MINMAX

■ AUTO

Address_Command_Eye tCK Value CA 0.2 to 10 
tcivw Value 0 to 2 
vcivw Value 0 to 10 
Clock/CA Reference Level Ref levels Clock/CA ■ Absolute

■ Percentage

High level Percentage Clock/CA 1 to 99 
Mid level Percentage Clock/CA
Low level Percentage Clock/CA
Hysteresis Percentage Clock/CA 0 to 50 
High level Absolute Clock/CA -10 to 10 
Mid level Absolute Clock/CA
Low level Absolute Clock/CA
Hysteresis Absolute Clock/CA 0 to 10 
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Acquire Type Parameter name Value
Ref Levels Autoset Basetop
Method Clock/CA ■ MINMAX

■ AUTO

WR_Differential_Strobe
RD_Differential_Strobe
RD_Output_Level

DQS/DQ/Clock Reference Level Ref levels DQS/DQ/Clock ■ Absolute
■ Percentage

High level Percentage DQS/DQ/
Clock

1 to 99 

Mid level Percentage DQS/DQ/
Clock
Low level Percentage DQS/DQ/
Clock
Hysteresis Percentage DQS/DQ/
Clock

0 to 50 

High level Absolute DQS/DQ/
Clock

-10 to 10 

Mid level Absolute DQS/DQ/
Clock
Low level Absolute DQS/DQ/
Clock
Hysteresis Absolute DQS/DQ/
Clock

0 to 10 

Ref Levels Autoset Basetop
Method DQ/Clock ■ MINMAX

■ AUTO

Table 24: ParameterName and Value for Reports tab

ParameterName Value
Report Update Mode ■ New

■ Append
■ Replace

Report Path Mention the path where the report shall be saved.
Save As Type ■ Web Archive (*.mht;*.mhtml)

■ PDF (*.pdf;)
■ CSV (*.csv;)

Auto increment report name if
duplicate

TRUE or FALSE

Create report at the end ■ Included
■ Excluded
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ParameterName Value
Include Pass/Fail Results
Summary

TRUE or FALSE

Include Detailed Results TRUE or FALSE
Include Plot Images TRUE or FALSE
Include Setup Configuration TRUE or FALSE
Include Complete Application
Configuration

TRUE or FALSE

Include User Comments TRUE or FALSE
Report Settings:Include Header
In Appended Reports

TRUE or FALSE

View Report After Generating TRUE or FALSE
Report Group Mode ■ Test Name

■ Test Result
■ Measurement Group

Append Report TRUE or FALSE

Examples
This section provides the examples for the SCPI commands.

Example Description
TEKEXP:*IDN?\n It returns the active TekExpress application

name running on the scope.
TEKEXP:*OPC?\n It returns the last command execution status.
TEKEXP:ACQUIRE_MODE PRE-RECORDED\n It sets the acquire mode as pre-recorded.
TEKEXP:ACQUIRE_MODE?\n It returns LIVE when acquire mode is set to

live.
TEKEXP:EXPORT REPORT\n It returns the report file in bytes. This can be

written into another file for further analysis.
TEKEXP:INFO? REPORT\n It returns “100,”ReportFileName.mht”", when

100 is the file size in bytes for the filename
ReportFileName.

TEKEXP:INFO? WFM\n It returns “100,“WfmFileName1.wfm”";“200,
“WfmFileName2.wfm”" when 100 is the
filesize in bytes for the filename
WfmFileName1.wfm and 200 is the file size
in bytes for the filename
WfmFileName2.wfm.

TEKEXP:VALUE ANALYZE,"RxMask","Superimpose DQS","True" It enables Superimpose DQS.
TEKEXP:VALUE GENERAL,"Bandwidth20GHz",19 It sets the bandwidth to 19 GHz.

SCPI commands  

92  TekExpress® DDR Tx Printable Application Help



Example Description
TEKEXP:VALUE? GENERAL,"Bandwidth20GHz" It queries the Bandwidth set and returns the

value in GHz.
TEKEXP:INSTRUMENT "Real Time Scope",MSO58 ( GPIB8::1::INSTR )\n It sets the instrument value as MSO58

( GPIB8::1::INSTR ) for the selected
instrument type Real Time Scope.

TEKEXP:INSTRUMENT? “Real Time Scope”\n It returns "MSO56 ( GPIB8::1::INSTR ), when
MSO56 ( GPIB8::1::INSTR )" is the selected
instrument for the instrument type Real Time
Scope.

TEKEXP:LASTERROR?\n It returns ERROR:
INSTRUMENT_NOT_FOUND, when no
instrument is found.

TEKEXP:LIST? DEVICE\n It returns "TX-Device,RX-Device" when TX-
Device, RX-Device are the available device.

TEKEXP:LIST? INSTRUMENT,"Real Time Scope"\n It returns "MSO58
( GPIB8::1::INSTR ),MSO56 ( TCPIP::
134.64.248.91::INSTR )" when MSO58
( GPIB8::1::INSTR ), MSO56 ( TCPIP::
134.64.248.91::INSTR ) are the list of
available instruments.

TEKEXP:MODE COMPLIANCE\n It sets the execution mode as compliance.
TEKEXP:MODE?\n It returns COMPLIANCE when the execution

mode is compliance.
TEKEXP:POPUP “OK”\n It sets OK as the response to active popup in

the application.
TEKEXP:POPUP?\n It returns "OK", when OK is the active popup

information shown in the application.
TEKEXP:REPORT GENERATE\n It generates report for the current session.
TEKEXP:REPORT? “Scope Model”\n It returns "MSO54" when MSO54 is the

scope model.
TEKEXP:REPORT? “DUT ID”\n It returns "DUT001" when DNI_DUT001 is

the DUT ID.
TEKEXP:RESULT? "tCK_NUI_RJ_NoBUJ"\n It returns Pass when the test result is Pass.
TEKEXP:SELECT DEVICE, TX_Device, TRUE\n It selects TX_Device
TEKEXP:SELECT? DEVICE\n It returns "TX-Device" when TX-Device is the

selected device type.
TEKEXP:SETUP DEFAULT\n It restores the application to default setup.
TEKEXP:STATE STOP\n It stops the test execution.
TEKEXP:STATE?\n It returns as READY when the application is

ready to run next measurement.
TEKEXP:STATE? SETUP\n It returns as NOT_SAVED when the current

setup is not saved.
TEKEXP:VALUE GENERAL," Test Mode", "Escape"\n It sets the Test Mode parameter value to

Escape
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Example Description
TEKEXP:VALUE? GENERAL,"Test Mode"\n It returns "Escape" when Escape is the Test

Mode value.
TEKEXP:VALUE GENERAL,"DataRate", 3600 It sets the data rate to 3600.
TEKEXP:VALUE? GENERAL,"DataRate" It returns the data rate that is currently set.
TEKEXP:VALUE GENERAL, "Clock Signal Probe Type", "Single Ended" It sets the clock signal probe type to single

ended.
TEKEXP:VALUE? GENERAL, "Clock Signal Probe Type" It returns the clock signal probe type as

Differential or Single Ended.
TEKEXP:VALUE ANALYZE, "tCK_NUI_RJ_NoBUJ", "N value Start", 2 It sets the analyze parameter's low range for

N value to 2 for the specified measurement.
TEKEXP:VALUE? ANALYZE, "tCK_NUI_RJ_NoBUJ", "N value Start" It returns the value of the analyze parameter

Start N Value for the specified measurement.
TEKEXP:SELECT TEST ,"tck",True It selects the measurement "tCK".
TEKEXP:VALUE? ACQUIRE, "tRPRE", "RD_Differential_Strobe", "Record Length (mpts)" It returns the record length set for the

Acquisition Type RD_Differential_strobe.
TEKEXP:VALUE ACQUIRE, "tRPRE", "RD_Differential_Strobe", "Record Length (mpts)",
0.5

It sets the Record length for the Acquisition
type RD_Differential_Strobe to 0.5 mpts.

TEKEXP:VALUE? ANALYZE, "tCK_NUI_RJ_NoBUJ", "N value Start" It returns the value of the analyze parameter
Start N Value for the specified measurement.

TEKEXP:VALUE ANALYZE, "tCK_NUI_RJ_NoBUJ", "N value Start", 2 It sets the Analyze parameter's low range for
N value to 2 for the specified measurement.

TEKEXP:VALUE GENERAL,"DQS Probe Mode","A" It sets the Trimode probe type for DQS
signal.

TEKEXP:VALUE? GENERAL,"DQS Probe Mode" It queries the Trimode probe type set.
TEKEXP:VALUE GENERAL "DQ_Write Connected to Filter File","C:\Users\Public
\Automation\FilterFiles\Clock_50GSs.flt"

It sets the filter file for DQ Write signal.

TEKEXP:VALUE? GENERAL "DQ_Write Connected to Filter File" It queries the filter file used for Write DQ
signal.

TEKEXP:USER_DEF_ACQ? It queries the User Defined Acquisition
status.

TEKEXP:USER_DEF_ACQ TRUE It enables User Defined Acquisition.
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References

DDR DFE standalone application

DDR5 DFE Overview DDR5 supports data rates from 3200 MT/s to 6400 MT/s. This increase in the
data rate is realized without the need for differential signaling at the DQ pins i.e.
the DQ bus is single-ended – same as DDR3/4.

However, due to the many impedance mismatched points that exist along the
memory subsystem, ISI due to reflections are expected to increase. At data rates
>= 4800MT/s, the data eye at the DRAM ball is expected to be closed. A 4-tap
DFE is implemented in the DDR5 DRAM Rx to help equalize the DQ signals and
open the data eyes after the data is latched by the receiver.

DDR DFE Introduction The DDR DFE is a standalone software application in Tektronix’s performance
scopes. It is used to perform 4 tap DFE operation on the DDR5 write burst
signals coming from the DDR5 DUTs.

How to launch Install TekExpress DDR Tx on the oscilloscope. Click TekScope > Analyze
Menu > DDR DFE.

DDR DFE Application Burst Detection Settings

Once the “DDR DFE” is launched, in the ‘Burst Detection Settings’ tab, user
must select ‘Strobe DQS’ and ‘Data DQ’ signals coming from the DUT
connected to the oscilloscope channels. The user must configure the ‘DFE
Output’ to the required Math channel. The user must set the ‘Data Rate’ of the
DDR5 of the DUT. The waveform edges are selected based on ‘Ref Levels’
[High, Mid, and Low]. The application will calculate the reference level
automatically when ref levels are set to “Auto”. The application will calculate
separate High, Mid, Low values for ‘Data DQ’ and ‘Strobe DQS’.
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When the ‘Ref Levels’ are modified from Auto to Custom, they can be modified
as per user choice. The application will use the reference level set by the user
when input levels are set to “Custom”. Similarly, ‘Clock Delay’ can be modified
as per user choice. The clock delay is timing delay between DQS to DQ, the
delay is used in clock recovery.
DFE Settings tab

The DFE Setting tab will allow the user to define the Gain and Tap values for
Tap1, Tap2, Tap3, and Tap4. The gain control of the front end is used to ensure
that the cursor or the current bit is in a congruent relationship with the ISI
correction required for the channel. The taps T1, T2, T3, T4 coefficients provide
the corrections needed to the current bit by adding or subtracting the effects of
ISI of the previous bits.
 

 

The Gain is applied to the waveform along the 4 tap DFE tap values. The limits
of the Gain and tap values are shown below. Note: Initial Gain and DFE taps are
each individually limited to the below range. Exact values (TBD) as will be
determined upon release of JEDEC specification.
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Threshold is the middle voltage level of the signal, which may be the transition
between logic levels. For biased signals, enter the mid-level value.

Description Min Max Unit
DFE Gain -6 6 dB
DFE Tap 1 -200 50 mV
DFE Tap 2 -75 76 mV
DFE Tap 3 -60 60 mV
DFE Tap 4 -45 45 mV

Description Typical Unit
DFE Gain Avg Step Size 2 dB
DFE Tap Avg Step Size 5 mV

Apply the DFE Settings to Math

Click Apply to configure the Gain and Tap values configured in the Burst
Detections Settings tab to the DFE Output. You can find the Math output
generating the DFE applied DQ waveform, which you can use with Strobe DQS
for any of the measurements of your choice.

NOTE. Do not use DDR DFE while executing the Write Eye measurements in the
TekExpress DDR Tx application.
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SDLA DDR5 Tutorial
This tutorial provides details on how to setup SDLA to model a DDR5 memory
system test configuration. The DQS and DQ signals are acquired through the
oscilloscope probes that are soldered onto an interposer that fits between the
memory chip and the circuit board. The user can then setup S-parameter models
for the probe, and interposer, and the memory system loading and transmission
lines. The goal is to create filters, that when applied to the acquired waveforms,
de-embeds the effects of interposer and probe. Thus, accounting for impedance
mis-match and reflections.

SDLA overview

The overall purpose of SDLA is to allow the user to setup S-parameter models
for the measurement system used to acquire signals on an oscilloscope and for
the simulation system. It will compute filters to apply to the input waveforms of
the oscilloscope and provide waveforms that would be represented by the various
test points in the SDLA system model. SDLA also provides an Rx block model
that allows for simulation of CTLE, clock recovery, and FFE and DFE
equalization filters.

Steps to install and launch SDLA application

1. Install the latest SDLA version on the oscilloscope.

2. To launch the application, select TekScope > Analyze > Serial Data Link
Analysis

Follow the steps to launch the SDLA DDR5 Modeling Tutorial document.

1. To launch the application, select TekScope > Analyze > Serial Data Link
Analysis

2. Click Rx in the SDLA menu.

Figure 11: SDLA Visualizer
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3. In the SDLA Visualizer - Rx Configuration, select User and click the Config
tab.

Figure 12: SDLA Visualizer - Rx Configuration

4. Select DDR5 from the CTLE Type drop-down menu.

5. Click ? button to open the SDLA help file.

Pre-recorded waveform file names for test measurements
The following table specifies the waveforms to load for the selected Acquire
Type.

Acquire Type Waveforms to be loaded
Clock ■ For differential signal probe type

DDR5_<DataRate>_Clock_Clock_<RecordLength>_<SourceChannel>.wfm
■ For Single Ended Probe Type

DDR5_<DataRate>_Clock_Clock-_<RecordLength>_<SourceChannel>.wfm

DDR5_<DataRate>_Clock_Clock+_<RecordLength>_<SourceChannel>.wfm

Clock_Slew_Rate ■ DDR5_<DataRate>_Clock_Slew_Rate_Clock_<RecordLength>_<SourceChannel>.wfm

WR_Differential_Strobe For differential signal probe type:

■ DDR5_<DataRate>_WR_Differential_Strobe_Clock_<RecordLength>_<SourceChannel>.wfm
■ DDR5_<DataRate>_WR_Differential_Strobe_DQ_<RecordLength>_<SourceChannel>.wfm
■ DDR5_<DataRate>_WR_Differential_Strobe_DQS_<RecordLength>_<SourceChannel>.wfm

For single-ended probe type:

■ DDR5_<DataRate>_WR_Differential_Strobe_DQS+_<RecordLength>_<SourceChannel>.wfm
■ DDR5_<DataRate>_WR_Differential_Strobe_DQS-_<RecordLength>_<SourceChannel>.wfm

WR_Data_Eye ■ DDR5_<DataRate>_WR_Data_Eye_DQS_<RecordLength>_<SourceChannel>.wfm
■ DDR5_<DataRate>_WR_Data_Eye_DQ_<RecordLength>_<SourceChannel>.wfm

WR_Slew_Rate ■ DDR5_3200_WR_Slew_Rate_DQ_<RecordLength>_<SourceChannel>.wfm
■ DDR5_3200_WR_Slew_Rate_DQS_<RecordLength>_<SourceChannel>.wfm
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Acquire Type Waveforms to be loaded
RD_Differential_Strobe ■ DDR5_<DataRate>_RD_Differential_Strobe_Clock_<RecordLength>_<SourceChannel>.wfm

■ DDR5_<DataRate>_RD_Differential_Strobe_DQ_<RecordLength>_<SourceChannel>.wfm
■ DDR5_<DataRate>_RD_Differential_Strobe_DQS_<RecordLength>_<SourceChannel>.wfm

RD_Output_Level ■ DDR5_3200_RD_Output_Level_DQ_<RecordLength>_<SourceChannel>.wfm
■ DDR5_3200_RD_Output_Level_DQS_<RecordLength>_<SourceChannel>.wfm

RD_Slew_Rate ■ DDR5_3200_RD_Slew_Rate_DQ_<RecordLength>_<SourceChannel>.wfm
■ DDR5_3200_RD_Slew_Rate_DQS_<RecordLength>_<SourceChannel>.wfm

Address_Command ■ DDR5_<DataRate>_Address_Command_CA_<RecordLength>_<SourceChannel>.wfm
■ DDR5_<DataRate>_Address_Command_Clock_<RecordLength>_<SourceChannel>.wfm

Address_Command_Eye ■ DDR5_<DataRate>_Address_Command_Eye_CA_<RecordLength>_<SourceChannel>.wfm
■ DDR5_<DataRate>_Address_Command_Eye_Clock_<RecordLength>_<SourceChannel>.wfm

Address_Command_Slew
_Rate ■ DDR5_<DataRate>_Address_Command_Slew_Rate_CA_<RecordLength>_<SourceChannel>.wfm
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Opening a saved test setup, 54
Options menu

Instrument control settings, 14
Oscilloscope compensation, 49

P
Panels, 17
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Pre-recorded waveform file names for test

measurements, 99
Preferences menu, 42, 45
Preferences tab

send an Email, 38
setup panel, 38

R
Recalling a test setup, 54
Related Documentation, 1
Report contents, 48
Report name, 46
Report options, 46
Report sections, 47
Reports

receiving in email notifications, 16
Reports panel, 17
Results panel

summary of test results, 42, 45
test name, 42, 45

Results Panel, 50
Run button, 13
Running tests, 50

S
Save log file, 40
Saving tests, 44
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Selecting test report contents, 46
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Setup

acquisition tab, 29
Setup files, 53
Setup panel, 17
Show acquire parameters, 29
Software installation

switch matrix application, 4
Source, 20
Status panel

log view, 40
message history, 40
test status tab, 40

Support, 2

T
Technical support, 2
Tek Link, 14
Test Name, 29
Test reports, 47
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Test results
send by email, 16

Test Results
clearing displayed, 50

Test selection
TekExpress DDR Tx, 28
test description, 28

Test selection controls, 28
Test setup files, 44, 53
Test setups

load, 54
open, 54
recalling, 54

Test status
acquire status, 40
analysis status, 40
auto scroll, 40

Test-related files, 44

Tests
running, 50
selecting, 28

U
User Comments

including in reports, 47

V
View a report, 47

W
Waveform files

locating and storing, 44
Wavelength, 20
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