
proNX Service Manager User Guide

Release

7.8

Modified: 2019-01-29

Copyright © 2019, Juniper Networks, Inc.



Juniper Networks, Inc.
1133 InnovationWay
Sunnyvale, California 94089
USA
408-745-2000
www.juniper.net

Juniper Networks, the Juniper Networks logo, Juniper, and Junos are registered trademarks of Juniper Networks, Inc. in the United States
and other countries. All other trademarks, service marks, registeredmarks, or registered service marks are the property of their respective
owners.

Juniper Networks assumes no responsibility for any inaccuracies in this document. Juniper Networks reserves the right to change, modify,
transfer, or otherwise revise this publication without notice.

proNX Service Manager User Guide
7.8
Copyright © 2019 Juniper Networks, Inc. All rights reserved.

The information in this document is current as of the date on the title page.

YEAR 2000 NOTICE

Juniper Networks hardware and software products are Year 2000 compliant. Junos OS has no known time-related limitations through the
year 2038. However, the NTP application is known to have some difficulty in the year 2036.

ENDUSER LICENSE AGREEMENT

The Juniper Networks product that is the subject of this technical documentation consists of (or is intended for use with) Juniper Networks
software. Use of such software is subject to the terms and conditions of the End User License Agreement (“EULA”) posted at
https://support.juniper.net/support/eula/. By downloading, installing or using such software, you agree to the terms and conditions of
that EULA.

Copyright © 2019, Juniper Networks, Inc.ii

https://support.juniper.net/support/eula/


Table of Contents

About the Documentation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xxi

Documentation and Release Notes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xxi

Documentation Conventions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xxi

Documentation Feedback . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xxiii

Requesting Technical Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xxiv

Self-Help Online Tools and Resources . . . . . . . . . . . . . . . . . . . . . . . . . . xxiv

Creating a Service Request with JTAC . . . . . . . . . . . . . . . . . . . . . . . . . . . xxv

Chapter 1 proNX Service Manager . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

About PSM . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

PSM Client . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

PSM Dashboard . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

PSM Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

Red Hat (CentOS) Linux . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

Support for RADIUS Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

PSM Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

Running with Multiple Servers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29

Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29

Running Multiple Servers Without Server Replication . . . . . . . . . . . . . . . . . . . 30

Running Multiple Servers with Server Replication . . . . . . . . . . . . . . . . . . . . . . 30

Supported Network Elements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

Chapter 2 Getting Started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

Starting the PSM Client . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

PSM Client Navigation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

Working with the PSM Client Window System . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

Customizing the Quick Access Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38

Displaying the Online Help . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40

Viewing the List Of Supported Devices . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40

Chapter 3 Managing PSM Users . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Adding a User . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44

Modifying a User . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46

Deleting a User . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49

Editing User Attributes on the Local RADIUS Server . . . . . . . . . . . . . . . . . . . . . . . 49

Chapter 4 Managing Network Discovery and Ethernet Domains . . . . . . . . . . . . . . . . . . . 51

Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51

Discovering Network Elements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51

Undiscovering a Network Element . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55

iiiCopyright © 2019, Juniper Networks, Inc.



Rediscovering a Network Element . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55

Polling Discovered Network Elements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55

Ethernet Network Domains . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56

Creating an Ethernet Domain . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56

Checking Domain Membership for a Network Element . . . . . . . . . . . . . . . . . . 57

Scheduling Network Element Discoveries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

Scheduling a Network Element Discovery Task . . . . . . . . . . . . . . . . . . . . . . . . 58

Viewing Scheduled Tasks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61

Deleting Scheduled Tasks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62

Chapter 5 Managing Network Topology . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

Icons and Definitions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

Understanding the Network Topology View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65

Layer Views . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67

Network Element and Link Details . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68

Learning the Network Topology . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72

Deriving Optical Topology Using DOL or ROADM Data . . . . . . . . . . . . . . . . . . 73

Deriving Layer 1 Topology Using Snooped LLDP Data . . . . . . . . . . . . . . . . . . . 73

Deriving Ethernet Topology Using LLDP Data . . . . . . . . . . . . . . . . . . . . . . . . . 74

Deriving Topology Using Remote IDs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74

Remote ID Format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75

Remote ID Configuration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78

Setting the Remote ID . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79

Setting the Remote ID on a Multiplexer/Demultiplexer . . . . . . . . . . . . . . 80

Setting the Remote ID on a ROADM C2 Port . . . . . . . . . . . . . . . . . . . . . . 82

Deleting the Remote ID . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83

Interactions with LLDP . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83

Viewing External Devices . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

Detecting Remote ID Errors . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

Network Element Groups and Sites . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 86

Creating a New Group . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87

Moving Network Elements, Groups, And/or Sites to a Different Group . . . . . 88

Adding Network Elements to a New Group or Site . . . . . . . . . . . . . . . . . . . . . 88

Adding Groups And/or Sites to a New Group . . . . . . . . . . . . . . . . . . . . . . . . . 89

Navigating Between Parent and Child Groups . . . . . . . . . . . . . . . . . . . . . . . . 89

Changing the Background View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 91

Chapter 6 Working with Network Elements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95

Editing Notes for a Network Element . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95

Identifying Services Associated with a Network Element . . . . . . . . . . . . . . . . . . . 96

Viewing Network Element Inventory Information . . . . . . . . . . . . . . . . . . . . . . . . . . 97

Searching for a Network Element . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99

Managing Information for a Network Element . . . . . . . . . . . . . . . . . . . . . . . . . . . 100

Enabling or Disabling Network Element Maintenance Modes . . . . . . . . . . . . . . . . 111

Marking or Unmarking a Network Element . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 112

Enabling or Disabling Provisioning Mode on a Network Element . . . . . . . . . . . . . 113

Copyright © 2019, Juniper Networks, Inc.iv

proNX Service Manager User Guide



Connecting to the CLI on a Network Element . . . . . . . . . . . . . . . . . . . . . . . . . . . . 114

Provisioning OSPF on a BTI7000 Series Management Network . . . . . . . . . . . . . . 114

Adding OSPF Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 114

Editing OSPF Management Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115

Deleting OSPF Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 116

Adding an OSPF Management Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 117

Editing an OSPF Management Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119

Deleting an OSPF Management Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121

Configuring In-Band Management on a BTI7800 Network Element . . . . . . . . . . 122

Chapter 7 Working with the Shelf View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 125

Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 125

Displaying Network Elements in the Shelf View . . . . . . . . . . . . . . . . . . . . . . . . . . 125

Displaying Alarms from the Shelf View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129

Setting the Remote ID from the Shelf View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129

Deleting the Remote ID from the Shelf View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 130

Chapter 8 Nodal Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133

Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133

Nodal Management for BTI7000 Series Network Elements . . . . . . . . . . . . . . . . 134

Launching the proNX 900 Node Controller . . . . . . . . . . . . . . . . . . . . . . . . . . 134

Provisioning a BTI7000 Series Shelf . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135

Adding a Shelf . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135

Deleting a Shelf . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

Provisioning a Slot on a BTI7000 Series Shelf . . . . . . . . . . . . . . . . . . . . . . . . 137

Adding a Module . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

Deleting a Module . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 139

Provisioning a Transponder on a BTI7000 Series Shelf . . . . . . . . . . . . . . . . . 139

Provisioning Ports on a BTI7000 Series Transponder . . . . . . . . . . . . . . 139

Provisioning Cross-connects on a BTI7000 Series Transponder . . . . . . 143

Provisioning Line Protection Groups on a BTI7000 Series

Transponder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 145

Provisioning Client Protection Groups on a BTI7000 Series

Transponder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 148

Provisioning a Muxponder on a BTI7000 Series Shelf . . . . . . . . . . . . . . . . . . 150

Provisioning Ports on a BTI7000 Series Muxponder . . . . . . . . . . . . . . . . 151

Provisioning Virtual Concatenation Groups on a BTI7000 Series

Muxponder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 155

Provisioning Cross-connects on a BTI7000 Series Muxponder . . . . . . . 158

Provisioning Protection Groups on a BTI7000 Series Muxponder . . . . . 160

Provisioning Synchronization on a BTI7000 Series Muxponder . . . . . . . 162

Provisioning a multiplexer/demultiplexer on a BTI7000 Series Shelf . . . . . . 163

Adding or Viewing a multiplexer/demultiplexer . . . . . . . . . . . . . . . . . . . 163

Deleting a multiplexer/demultiplexer . . . . . . . . . . . . . . . . . . . . . . . . . . . 165

Provisioning GCC on a BTI7000 Series Network Element . . . . . . . . . . . . . . . 165

Provisioning GCC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 165

Deleting GCC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 166

Viewing Port PMs on a BTI7000 Series Network Element . . . . . . . . . . . . . . 166

vCopyright © 2019, Juniper Networks, Inc.

Table of Contents



Provisioning the BTI7000 Series Dynamic Optical Layer (DOL) . . . . . . . . . . 168

Provisioning Optical Groups . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 168

Editing WDM Parameters in an Optical Group . . . . . . . . . . . . . . . . . . . . . 171

Adding and Deleting the C2 Port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 173

Editing Optical Port Parameters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 174

Configuring a Split ROADM Node . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 176

Editing OSC Parameters in an Optical Group . . . . . . . . . . . . . . . . . . . . . 177

Enabling or Disabling a Port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 180

Nodal Management for BTI7800 Series Network Elements . . . . . . . . . . . . . . . . . 181

Provisioning a BTI7800 Chassis . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 181

Adding a Shelf . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 181

Editing a Shelf . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 183

Deleting a Shelf . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 184

Provisioning a Universal Forwarding Module on a BTI7800 . . . . . . . . . . . . . 184

Adding a UFM . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 185

Editing a UFM . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 187

Deleting a UFM . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 188

Adding a BIC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 188

Editing a BIC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 190

Cloning a BIC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 191

Deleting a BIC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 192

Adding a Transceiver . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 193

Editing a Transceiver . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 195

Cloning a Transceiver . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 196

Deleting a Transceiver . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 197

Adding an Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 198

Editing an Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 205

Configuring a Multiplexed Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 211

Cloning an Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 213

Deleting an Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 214

Viewing Interface PMs on a UFM . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 215

Provisioning a ROADM Node on a BTI7800 . . . . . . . . . . . . . . . . . . . . . . . . . . 216

General Provisioning Procedure . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 217

Adding a ROADM or an ILA Module . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 218

Editing a ROADM or an ILA Module . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 219

Deleting a ROADM or an ILA Module . . . . . . . . . . . . . . . . . . . . . . . . . . . 220

Adding a PRE Module . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 220

Editing a PRE Module . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 221

Deleting a PRE Module . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 222

Adding or Viewing a multiplexer/demultiplexer . . . . . . . . . . . . . . . . . . . 222

Deleting a multiplexer/demultiplexer . . . . . . . . . . . . . . . . . . . . . . . . . . . 225

Editing a Port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 225

Editing the OMS . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 226

Editing the OSC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 227

Adding a Fiber Connection on a ROADM or an ILA Client Port . . . . . . . . 227

Editing a Fiber Connection on a ROADM or an ILA Client Port . . . . . . . . 228

Deleting a Fiber Connection on a ROADM or an ILA Client Port . . . . . . 229

Adding a Fiber Connection on a ROADM or an ILA Line Port . . . . . . . . . 230

Editing a Fiber Connection on a ROADM or an ILA Line Port . . . . . . . . . 231

Copyright © 2019, Juniper Networks, Inc.vi

proNX Service Manager User Guide



Deleting a Fiber Connection on a ROADM or an ILA Line Port . . . . . . . . 231

Adding a Fiber Connection on a UFM Interface . . . . . . . . . . . . . . . . . . . 232

Editing a Fiber Connection on a UFM Interface . . . . . . . . . . . . . . . . . . . . 233

Deleting a Fiber Connection on a UFM Interface . . . . . . . . . . . . . . . . . . 233

Viewing Fiber Connections . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 234

Adding an Optical Channel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 234

Bulk Adding Optical Channels . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 235

Editing an Optical Channel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 237

Deleting an Optical Channel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 238

Viewing Port PMs on a ROADM Element . . . . . . . . . . . . . . . . . . . . . . . . 238

Viewing OMS PMs on a ROADM Element . . . . . . . . . . . . . . . . . . . . . . . . 239

Viewing OSC PMs on a ROADM Element . . . . . . . . . . . . . . . . . . . . . . . . 240

Viewing Optical Channel PMs on a ROADM Element . . . . . . . . . . . . . . 240

Provisioning a 96-Channel Amplifier on a BTI7800 . . . . . . . . . . . . . . . . . . . 241

Adding an Amplifier . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 241

Creating an Optical Group for a BTI7800 Series Amplifier . . . . . . . . . . 242

Assigning or Unassigning an Amplifier . . . . . . . . . . . . . . . . . . . . . . . . . . 244

Editing an Amplifier Port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 245

Editing WDM Parameters for an Amplifier . . . . . . . . . . . . . . . . . . . . . . . 246

Editing OSC Parameters for an Amplifier . . . . . . . . . . . . . . . . . . . . . . . . 248

Changing an Amplifier's Group . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 250

Viewing Port PMs on a 96-Channel Amplifier . . . . . . . . . . . . . . . . . . . . . 251

Provisioning a Wavelength Protection Switch Module on a BTI7800 . . . . . . 251

Adding a WPS Module . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 251

Adding a Protection Group . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 252

Editing a Protection Group . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 254

Deleting a Protection Group . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 255

Editing a Port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 255

Enabling or Disabling a Port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 257

Nodal Management for Juniper Networks Routers and Switches . . . . . . . . . . . . 257

Editing an Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 258

Enabling or Disabling a Port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 262

Viewing Interface PMs on an MX Series or PTX Series Router or QFX Series

Switch . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 263

Nodal Management for BTI800 Series Network Elements . . . . . . . . . . . . . . . . . 265

Enabling or Disabling a Port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265

Chapter 9 Configuring PSM Client Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 267

Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 267

Configuring General Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 267

Setting Auto-logout . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 267

Configuring Alerts Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 268

Setting Alarm Alerts Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 268

Configuring Display Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 269

Setting Alarm Display Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 269

Setting Auto-categorization Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 270

Setting Device Display Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 274

Setting Overlay Display Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 274

Setting Service Display Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 275

viiCopyright © 2019, Juniper Networks, Inc.

Table of Contents



Setting Topology Display Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 276

Configuring Performance Monitoring Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . 277

Setting Historical PM Graphing Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 277

Setting Optical Graphing Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 278

Setting Real-time Collections Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 278

Configuring Utilities . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 279

Setting Utility Executables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 280

Configuring the proNX 900 Node Controller . . . . . . . . . . . . . . . . . . . . . . . . . 282

Chapter 10 Bulk Configuration Of Network Elements . . . . . . . . . . . . . . . . . . . . . . . . . . . 287

Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 287

Creating New Users on Multiple Network Elements . . . . . . . . . . . . . . . . . . . . . . . 287

Configuring RADIUS Server Parameters on Multiple Network Elements . . . . . . . 291

Configuring NTP Server Parameters on Multiple Network Elements . . . . . . . . . . 297

Chapter 11 Managing Optical and Transport Services . . . . . . . . . . . . . . . . . . . . . . . . . . . 301

Optical Services . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 301

Visualizing an Optical Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 301

Activating an Optical Service in a BTI7000 Network . . . . . . . . . . . . . . . . . . 306

Activating an Optical Service Between BTI7000 Optical Port

Endpoints . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 306

Activating an Optical Service Between Transponder Interface

Endpoints . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 308

Examples Of Path Selection in a BTI7000 Optical Network . . . . . . . . . 316

Activating an Optical Service in a BTI7800 Network . . . . . . . . . . . . . . . . . . . 319

Viewing the Cross-Connects in an Optical Service . . . . . . . . . . . . . . . . . . . . . 321

Updating an Optical Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 321

Deleting an Optical Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 321

Viewing the Optical Services Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 322

Viewing the Optical Services Per Span Table . . . . . . . . . . . . . . . . . . . . . . . . 322

Viewing the Optical Topology Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 323

Transport Services . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 323

Visualizing a Transport Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 324

Activating a Transport Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 328

Updating a Transport Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 332

Deleting a Transport Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 332

Viewing the Transport Services Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 332

Viewing the Transport Services Per Span Table . . . . . . . . . . . . . . . . . . . . . . 333

Viewing the Transport Topology Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 333

Viewing the Transponder Tuning Grid . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 334

Working with Optical/Transport Services and Topology Tables . . . . . . . . . . . . . 334

Sorting the Tables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 334

Filtering the Tables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 335

Saving a Service Image . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 336

Chapter 12 Managing Ethernet Services . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 337

Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 337

Service Visualization . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 337

Visualizing an Ethernet Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 337

Service Visualization Scheme . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 341

Copyright © 2019, Juniper Networks, Inc.viii

proNX Service Manager User Guide



Understanding Ethernet Service States . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 342

Service Activation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 344

Service Types . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 346

Auto-provisioning NNIs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 347

Activating an Ethernet Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 348

Example: Activating an EVPLINE Service . . . . . . . . . . . . . . . . . . . . . . . . . . . 364

Part 1: Setting Up the EVPLINE Service with CVLAN Translation . . . . . 364

Part 2: Setting Up the EVPLINE Service with the Virtual Untagged

Option . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 370

Example: Activating an Ethernet Service on a Multi-chassis LAG . . . . . . . . . 377

Example: Activating EVPLANand EVPLINEServices Using ServiceMaps for

Flow Redirection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 381

Part 1: Setting Up the Service Maps . . . . . . . . . . . . . . . . . . . . . . . . . . . . 383

Part 2: Setting Up the EVPLINE Services . . . . . . . . . . . . . . . . . . . . . . . . 390

Setting Up the EVPLAN Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 395

Modifying a Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 399

Modifying a Port in a Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 399

Adding a Port to a Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 400

Removing a Port from a Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 401

Deleting a Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 402

Adding SLA/CFM to a Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 402

Running a Y.1731 Link Trace . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 408

Running a Y.1731 Loopback . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 409

Running an RFC 2544 Benchmarking Test . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 410

Ethernet Ring Protection Switching (ERPS) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 414

Visualizing an ERPS Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 414

Effect Of Link Failure on ERPS States . . . . . . . . . . . . . . . . . . . . . . . . . . . 417

Viewing the ERPS Services Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 418

Adding VLANs to an ERPS Ring . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 419

Routing Considerations in Mixed Networks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 421

GVRP - GARP VLAN Registration Protocol . . . . . . . . . . . . . . . . . . . . . . . . . . . 421

Mixed Networks - BTI7000 Series with BTI700 Series or BTI800 Series

Elements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 422

Creating Services in BTI7000 Series packetVX Only Networks . . . . . . . 422

Creating Services Over BTI700 Series And/or BTI800 Series Only

Networks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 423

Activating Services Over Combinations Of BTI7000 Series packetVX

and BTI700 Series or BTI800 Series Networks . . . . . . . . . . . . . . . 424

Managing Profiles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 426

About Profile Manager . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 426

Selecting a Profile During Service Activation . . . . . . . . . . . . . . . . . . . . . 427

Managing Profile Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 428

Creating a Profile Template . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 428

Editing an Existing Profile Template . . . . . . . . . . . . . . . . . . . . . . . . . . . . 430

Creating a Profile Template Through Cloning . . . . . . . . . . . . . . . . . . . . . 431

Deleting a Profile Template . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 431

Bandwidth Profile Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 431

TCM Bandwidth Profiles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 432

Two-rate TCM . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 433

ixCopyright © 2019, Juniper Networks, Inc.

Table of Contents



Single-rate TCM . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 433

CAR Bandwidth Profile Template . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 433

Color Mode and Actions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 433

Setting DEI on Exceed Traffic . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 434

Internal Priority for Bandwidth Profile Templates . . . . . . . . . . . . . . . . . 434

Class Map Profile Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 434

Service Policy Profile Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 436

Service Map Profile Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 438

SLA Measurement Profile Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 439

Chapter 13 Managing Pseudowire Services . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 441

Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 441

Visualizing a Pseudowire Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 441

Service Activation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 444

Activating a Pseudowire Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 445

Modifying a Pseudowire Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 450

Deleting a Pseudowire Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 451

Chapter 14 Managing Customers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 453

Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 453

Adding a Customer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 454

Modifying a Customer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 455

Deleting a Customer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 456

Chapter 15 Managing Network Element Alarms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 457

Supported Network Elements and Devices . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 457

MX Series, PTX Series, and QFX Series Alarms . . . . . . . . . . . . . . . . . . . . . . . 457

Alarm Visualization . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 458

Viewing Current Alarms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 460

Understanding Alarm Timestamps . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 461

How the PSM Server Timestamps the Alarms . . . . . . . . . . . . . . . . . . . . 462

How the PSM Server Timestamps the Clears . . . . . . . . . . . . . . . . . . . . 462

How the PSM Client Displays Timestamps . . . . . . . . . . . . . . . . . . . . . . 462

Working with the Alarms Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 462

Sorting the Alarms Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 462

Filtering the Alarms Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 463

Using Service/alarm Correlation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 466

Suspending Alarm Notification . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 466

Understanding the Alarms Summary Bar . . . . . . . . . . . . . . . . . . . . . . . . . . . 466

Resetting the Deltas . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 467

Interpreting the Deltas . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 468

Filtering Based on Alarm Severity . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 468

Acknowledging, Emailing, and Clearing Alarms . . . . . . . . . . . . . . . . . . . . . . . . . . 469

Assigning an Alarm to a User . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 470

Viewing Historical Alarms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 470

Viewing Alarms Through an RSS Feed . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 472

Sending Traps on the Northbound Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 473

Adding a Trap Receiver for Alarms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 473

Modifying a Trap Receiver for Alarms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 475

Deleting a Trap Receiver for Alarms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 475

Copyright © 2019, Juniper Networks, Inc.x

proNX Service Manager User Guide



Chapter 16 Managing Network Element System Software and FTP Servers . . . . . . . . 477

Adding an FTP or SFTP Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 477

Modifying the Configuration for an FTP or SFTP Server . . . . . . . . . . . . . . . . . . . . 479

Deleting an FTP or SFTP Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 480

Manually Backing Up a Network Element Configuration Database . . . . . . . . . . . 481

Restoring a Configuration Database to a Network Element . . . . . . . . . . . . . . . . 482

Upgrading System Software for a Network Element . . . . . . . . . . . . . . . . . . . . . . 484

Restoring a Database to Factory Defaults on a BTI7800 Network Element . . . . 487

Chapter 17 Managing Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 489

Generating Alarms Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 489

Generating an Active Alarms Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 489

Generating a Historical Alarms Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 490

Generating Ethernet Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 493

Generating Pseudowire Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 494

Generating Transport Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 495

Generating NE Logs Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 496

Generating Optical Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 498

Generating Inventory Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 499

Generating Task History Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 501

Changing the Report Generation Timeout . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 504

Chapter 18 Performance Monitoring . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 507

Viewing Current Port, Interface, and Channel PMs . . . . . . . . . . . . . . . . . . . . . . . . 507

Viewing Real-time Optical Service PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 507

Viewing Real-time Transport Service PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 515

Viewing Real-time Ethernet PMs and SLAs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 520

Viewing Real-time Pseudowire PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 528

Collecting and Viewing Historical PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 531

Chapter 19 Troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 537

Managing Task Status . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 537

Discovering Task Status . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 539

Clearing Completed Tasks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 539

Exporting Client and Server Logs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 539

Performing Diagnostics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 540

Viewing the PSM Client Log . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 540

Testing Network Element Connectivity . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 541

Verifying PSM Client-server Connectivity . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 542

Collecting and Viewing NE Logs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 542

Saving Network Element Configuration Information . . . . . . . . . . . . . . . . . . . . . . 545

Troubleshooting Server Replication . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 545

Loss Of Connectivity to the Cluster . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 545

Loss Of Synchronization with a Cluster Member . . . . . . . . . . . . . . . . . . . . . 546

Re-establishment Of Connectivity to the Cluster . . . . . . . . . . . . . . . . . . . . . 546

Synchronizing Replicated Data Manually . . . . . . . . . . . . . . . . . . . . . . . . . . . 546

Restarting the Cluster . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 547

xiCopyright © 2019, Juniper Networks, Inc.

Table of Contents



Chapter 20 Appendix . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 549

Service Activation Error Messages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 549

PSM Alarms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 550

BTI7800 Alarm Details . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 554

Installing Net-SNMP . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 555

Configuring Historical PM Collection on BTI800 Series Network Elements . . . . 558

PM Counters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 560

PM Counters for BTI7000 Series Transponders and Muxponders . . . . . . . . 560

PM Counters for BTI7000 Series DOL Modules . . . . . . . . . . . . . . . . . . . . . . 565

PM Counters for BTI7000 Series packetVX Modules . . . . . . . . . . . . . . . . . . 567

PM Counters for BTI718E Modules . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 573

PM Counters for BTI800 Series Modules . . . . . . . . . . . . . . . . . . . . . . . . . . . . 574

PM Counters for Optical Interfaces on MX Series and PTX Series Routers

and QFX Series Switches . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 576

Regular Expressions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 578

Copyright © 2019, Juniper Networks, Inc.xii

proNX Service Manager User Guide



List of Figures

Chapter 1 proNX Service Manager . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

Figure 1: PSM Managed Network . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29

Chapter 2 Getting Started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

Figure 2: Top Level Screen Layout for proNX Service Manager . . . . . . . . . . . . . . . 36

Chapter 5 Managing Network Topology . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

Figure 3: Hovering Over a Network Element . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68

Figure 4: Hovering Over a PSM Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

Figure 5: Hovering Over a Network Element Group . . . . . . . . . . . . . . . . . . . . . . . . 69

Figure 6: Show Link Details . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

Figure 7: Link Details Data Widget Title Bar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

Figure 8: Link Details Data Widget Window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70

Figure 9: BTI7000 Series DOL-DOL Link Details Data Widget . . . . . . . . . . . . . . . . 71

Figure 10: BTI7000 Series PVX-PVX Link Details Data Widget . . . . . . . . . . . . . . . . 71

Figure 11: BTI7000 Series Transponder-Transponder Link Details Data

Widget . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71

Figure 12: BTI7000 Series Muxponder-Muxponder Link Details Data Widget . . . . 72

Figure 13: MX Series Router Transponder to BTI7000 Series DOL Link Details

Data Widget . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72

Figure 14: External Device to BTI7000 Series PVX Link Details DataWidget . . . . . 72

Figure 15: Hide Link Details . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72

Figure 16: Provision Remote Port ID . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78

Figure 17: Selecting the C2 Port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82

Figure 18: Map View Of Group Contents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90

Figure 19: Map View Of Parent . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 91

Chapter 6 Working with Network Elements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95

Figure 20: Network Inventory . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 98

Figure 21: Network Inventory for PSM Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 98

Figure 22: Searching for an IP Address . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100

Figure 23: Selecting the Search Category . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100

Figure 24: Searching for a Service Type . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100

Chapter 7 Working with the Shelf View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 125

Figure 25: Shelf View for a BTI7814 Network Element . . . . . . . . . . . . . . . . . . . . . 126

Figure 26: Shelf View for an MX240 Router . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127

Figure 27: Shelf View for a BTI7200 Network Element . . . . . . . . . . . . . . . . . . . . . 127

Figure 28: Shelf View for a BTI718E Network Element . . . . . . . . . . . . . . . . . . . . . . 127

Figure 29: Shelf View for a BTI805 Network Element . . . . . . . . . . . . . . . . . . . . . . 128

Figure 30: Shelf View for a BTI810 Network Element . . . . . . . . . . . . . . . . . . . . . . 128

Figure 31: Shelf View for a BTI821 Network Element . . . . . . . . . . . . . . . . . . . . . . . 128

xiiiCopyright © 2019, Juniper Networks, Inc.



Figure 32: Shelf View for a BTI822 Network Element . . . . . . . . . . . . . . . . . . . . . . 128

Chapter 8 Nodal Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133

Figure 33: BTI7000 Series Provision Shelf . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 136

Figure 34: BTI7000 Series Provision Slot . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 138

Figure 35: BTI7000 Series Provision/Edit Transceiver . . . . . . . . . . . . . . . . . . . . . 140

Figure 36: BTI7000 Series Provision Port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 151

Figure 37: Provision Optical Group . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 169

Figure 38: Edit WDM Dialog for a BTI7000 Series ROADM Module . . . . . . . . . . . 172

Figure 39: Edit Optical Layer Port Dialog for a BTI7000 Series ROADM Line

Port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 175

Figure 40: Edit OSC Dialog for a BTI7000 Series ROADMModule . . . . . . . . . . . . 178

Figure 41: BTI7800 Series Provision Shelf . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 182

Figure 42: BTI7800 Series Provision Shelf . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 183

Figure 43: BTI7800 Series Provision Slot . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 186

Figure 44: BTI7800 Series Edit Slot (UFM) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 187

Figure 45: BTI7800 Series Provision BIC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 189

Figure 46: BTI7800 Series Edit BIC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 190

Figure 47: BTI7800 Series Clone Equipment (BIC) . . . . . . . . . . . . . . . . . . . . . . . . 192

Figure 48: BTI7800 Series Provision Transceiver . . . . . . . . . . . . . . . . . . . . . . . . . 194

Figure 49: BTI7800 Series Edit Transceiver . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 195

Figure 50: BTI7800 Series Clone Equipment (transceiver) . . . . . . . . . . . . . . . . . 197

Figure 51: BTI7800 Series Provision Interface (OTU4) . . . . . . . . . . . . . . . . . . . . . 199

Figure 52: BTI7800 Series Provision Interface (Optical Channel) . . . . . . . . . . . . 200

Figure 53: BTI7800 Series Edit Interface (OTU4) . . . . . . . . . . . . . . . . . . . . . . . . 206

Figure 54: BTI7800 Series Edit Interface (Optical Channel) . . . . . . . . . . . . . . . . 207

Figure 55: BTI7800 Series Edit Interface (ODU4) . . . . . . . . . . . . . . . . . . . . . . . . . 212

Figure 56: ODU4 Interface with 10 ODU2 Sub-interfaces . . . . . . . . . . . . . . . . . . . 213

Figure 57: BTI7800 Series Clone Equipment (interface) . . . . . . . . . . . . . . . . . . . . 214

Figure 58: Provision Optical Group . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 243

Figure 59: Edit WDM Dialog for a BTI7800 96-Channel Amplifier Module . . . . . 247

Figure 60: Edit OSC Dialog for a BTI7800 96-Channel Amplifier Module . . . . . 249

Figure 61: Edit Interface (OTU4) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 261

Chapter 9 Configuring PSM Client Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 267

Figure 62: Customers Branch Without Auto-categorization . . . . . . . . . . . . . . . . . 272

Figure 63: Customers Branch with Auto-categorization Using Default

Categories . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 272

Chapter 10 Bulk Configuration Of Network Elements . . . . . . . . . . . . . . . . . . . . . . . . . . . 287

Figure 64: Configure Radius Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 293

Figure 65: Configure Radius Server (BTI718E) . . . . . . . . . . . . . . . . . . . . . . . . . . . 293

Chapter 11 Managing Optical and Transport Services . . . . . . . . . . . . . . . . . . . . . . . . . . . 301

Figure 66: Optical Service Between Transponder Endpoints . . . . . . . . . . . . . . . . 312

Figure 67: Selecting the First Path and Channel . . . . . . . . . . . . . . . . . . . . . . . . . . 317

Figure 68: Selecting the Second Path and Channel . . . . . . . . . . . . . . . . . . . . . . . 317

Figure 69: Selecting a Path with No Decision Points . . . . . . . . . . . . . . . . . . . . . . . 318

Figure 70: Selecting a Path with One Decision Point . . . . . . . . . . . . . . . . . . . . . . . 318

Figure 71: Selecting a Path with Two Decision Points . . . . . . . . . . . . . . . . . . . . . . 319

Copyright © 2019, Juniper Networks, Inc.xiv

proNX Service Manager User Guide



Figure 72: Hovering Over a Transport Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . 325

Figure 73:HoveringOver theTransportServiceComponentofaBTI7000Optical

Service . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 325

Figure 74: Optical Topology Column Selection . . . . . . . . . . . . . . . . . . . . . . . . . . . 335

Chapter 12 Managing Ethernet Services . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 337

Figure 75: Hovering Over a Switch . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 342

Figure 76: Hovering Over a UNI . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 342

Figure 77: Hovering Over a Link . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 342

Figure 78: Example: EVPLINE Services . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 364

Figure 79: Example: EVPLINE and EVPLAN Services . . . . . . . . . . . . . . . . . . . . . . 382

Figure 80: Creating Services in BTI7000 Series packetVX Only Networks . . . . . 422

Figure 81: Creating Services in BTI7000 Series packetVX-only Networks . . . . . . 423

Figure 82: Creating Services Over BTI700 Series And/or BTI800 Series Only

Networks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 423

Figure 83: Creating Services Over BTI700 Series And/or BTI800 Series Only

Networks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 424

Figure84: ActivatingServicesOver aCombinationOfBTI7000Series packetVX,

BTI700 Series, and BTI800 Series Networks . . . . . . . . . . . . . . . . . . . . . . . . 425

Figure 85: Bandwidth Profile Template Parameters . . . . . . . . . . . . . . . . . . . . . . . 432

Figure 86: Class Map Profile Template . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 435

Figure 87: Service Policy Profile Template . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 437

Figure 88: Service Map Profile Template . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 438

Figure 89: SLA Measurement Profile Template . . . . . . . . . . . . . . . . . . . . . . . . . . 439

Chapter 13 Managing Pseudowire Services . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 441

Figure 90: BTI800 Series Component Model . . . . . . . . . . . . . . . . . . . . . . . . . . . 444

Figure 91: Activate Pseudowire Service (CESOP) . . . . . . . . . . . . . . . . . . . . . . . . . 446

Chapter 15 Managing Network Element Alarms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 457

Figure 92: Alarm Table View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 458

Chapter 17 Managing Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 489

Figure 93: PSM Client Communication Timeout . . . . . . . . . . . . . . . . . . . . . . . . . 504

Chapter 18 Performance Monitoring . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 507

Figure 94: Real-time PMs Port View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 511

Figure 95: Real-time PMs OSC View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 511

Figure 96: Real-time PMs Service Channel View . . . . . . . . . . . . . . . . . . . . . . . . . . 512

Figure 97: Real-time PMs All Channels View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 512

Figure 98: Real-time PMs Port View Graph . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 513

Figure 99: Real-time PMs OSC View Graph . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 513

Figure 100: Real-time PMs Service Channel View Graph . . . . . . . . . . . . . . . . . . . 513

Figure 101: Real-time PMs All Channels View Graph . . . . . . . . . . . . . . . . . . . . . . . 514

Figure 102: Real-time PMs Simple View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 518

Figure 103: Real-time PMs Simple View Graph . . . . . . . . . . . . . . . . . . . . . . . . . . . 519

Figure 104: Real-time PMs Detailed View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 523

Figure 105: Real-time PMs Simple View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 524

Figure 106: Real-time PMs SLA View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 524

Figure 107: Real-time PMs Port Utilization View . . . . . . . . . . . . . . . . . . . . . . . . . . 524

Figure 108: Real-time PMs Bandwidth Utilization View . . . . . . . . . . . . . . . . . . . . 525

xvCopyright © 2019, Juniper Networks, Inc.

List of Figures



Figure 109: Real-time PMs Detailed View Graph . . . . . . . . . . . . . . . . . . . . . . . . . 525

Figure 110: Real-time PMs Simple View Graph . . . . . . . . . . . . . . . . . . . . . . . . . . . 525

Figure 111: Real-time SLAs View Graph . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 526

Figure 112: Real-time PMs Port Utilization View Graph . . . . . . . . . . . . . . . . . . . . . 526

Figure 113: Real-time PMs Bandwidth Utilization Graph . . . . . . . . . . . . . . . . . . . . 527

Figure 114: Real-time PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 530

Chapter 20 Appendix . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 549

Figure 115: BTI7800 Detailed Alarm Information Window (example) . . . . . . . . . 555

Copyright © 2019, Juniper Networks, Inc.xvi

proNX Service Manager User Guide



List of Tables

About the Documentation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xxi

Table 1: Notice Icons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xxii

Table 2: Text and Syntax Conventions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xxii

Chapter 1 proNX Service Manager . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

Table 3: Replicated Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

Chapter 2 Getting Started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

Table 4: Quick Access Toolbar Buttons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38

Chapter 3 Managing PSM Users . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Table 5: PSM Privilege Equivalencies . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44

Table 6: PSM Privilege Equivalencies . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47

Chapter 4 Managing Network Discovery and Ethernet Domains . . . . . . . . . . . . . . . . . . . 51

Table 7: Discovery Criteria . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52

Table 8: Scheduler Tab . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62

Chapter 5 Managing Network Topology . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

Table 9: Topology Map Icons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

Table 10: Service Icons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64

Table 11: Link Details . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70

Table 12: When LLDP is Enabled and Remote ID is Configured . . . . . . . . . . . . . . . 84

Chapter 6 Working with Network Elements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95

Table 13: System Info Tab for BTI7000 Series NE . . . . . . . . . . . . . . . . . . . . . . . . . 102

Table 14: System Info Tab for BTI7800 Series NE . . . . . . . . . . . . . . . . . . . . . . . . . 105

Table 15: System Info Tab for BTI800 Series NE . . . . . . . . . . . . . . . . . . . . . . . . . . 106

Table 16: System Info Tab for MX Series and PTX Series Routers and QFX Series

Switches . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108

Table 17: System Info Tab for BTI700 Series NE . . . . . . . . . . . . . . . . . . . . . . . . . . 108

Table 18: System Info Tab for OPS, EDFA, and RAMAN Devices . . . . . . . . . . . . . . 110

Table 19: System Info Tab for PSM Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110

Chapter 8 Nodal Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133

Table 20: OTU Protocol Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 202

Table 21: ODU Protocol Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 202

Table 22: SONET/SDH Protocol Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 202

Table 23: Ethernet Protocol Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 203

Table 24: Fibre Channel Protocol Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 203

Table 25: Physical Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 203

Table 26: UFM6 Optical Channel (OCH) Attributes . . . . . . . . . . . . . . . . . . . . . . . 204

Table 27: OTU Protocol Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 208

xviiCopyright © 2019, Juniper Networks, Inc.



Table 28: ODU Protocol Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 208

Table 29: SONET/SDH Protocol Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 208

Table 30: Ethernet Protocol Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 209

Table 31: Fibre Channel Protocol Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 209

Table 32: Physical Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 209

Table 33: UFM6 Optical Channel (OCH) Attributes . . . . . . . . . . . . . . . . . . . . . . . 210

Chapter 11 Managing Optical and Transport Services . . . . . . . . . . . . . . . . . . . . . . . . . . . 301

Table 34: Fields in the Activate Optical Service Dialog . . . . . . . . . . . . . . . . . . . . . 307

Table 35: Supported Interface Endpoints for the BTI7000 Optical Service . . . . 308

Table 36: Fields in the Activate Optical Service Panel . . . . . . . . . . . . . . . . . . . . . . 315

Table 37: Fields in the Activate Optical Service Panel . . . . . . . . . . . . . . . . . . . . . 320

Table 38: Supported Service Activation Endpoint . . . . . . . . . . . . . . . . . . . . . . . . 328

Table 39: Fields in the Activate Transport Service Dialog . . . . . . . . . . . . . . . . . . . 331

Chapter 12 Managing Ethernet Services . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 337

Table 40: Service Types . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 346

Table 41: Fields in the Service Attributes Pane . . . . . . . . . . . . . . . . . . . . . . . . . . . . 351

Table 42: Port-based Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 357

Table 43: Advanced Switch Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 359

Table 44: Advanced Port Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 359

Table 45: Advanced LAG Port Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 362

Table 46: Advanced LAG Member Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . 363

Table 47: SLA Provisioning Constraints . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 403

Chapter 13 Managing Pseudowire Services . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 441

Table 48: Fields in the Service Attributes Pane . . . . . . . . . . . . . . . . . . . . . . . . . . . 447

Table 49: TDM Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 448

Table 50: Physical Interface Attributes (T1/E1 Card Only) . . . . . . . . . . . . . . . . . . 448

Table 51: CESOP Payload Sizes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 448

Chapter 15 Managing Network Element Alarms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 457

Table 52: Alarm Severity Mapping for Chassis Alarms . . . . . . . . . . . . . . . . . . . . . 458

Table 53: Alarms Summary Bar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 467

Table 54: Interpreting the Alarms Summary . . . . . . . . . . . . . . . . . . . . . . . . . . . . 468

Chapter 18 Performance Monitoring . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 507

Table 55: BTI7000 Series Optical Service PMs . . . . . . . . . . . . . . . . . . . . . . . . . . 508

Table 56: BTI7800 Series Optical Service PMs . . . . . . . . . . . . . . . . . . . . . . . . . . 509

Table 57: BTI7800 Series Transport Service PMs . . . . . . . . . . . . . . . . . . . . . . . . . 515

Table 58: BTI7000 Series PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 520

Table 59: BTI700 Series PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 521

Table 60: BTI800 Series PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 522

Table 61: BTI7000 Series, BTI700 Series, BTI800 Series SLAs . . . . . . . . . . . . . . 522

Chapter 20 Appendix . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 549

Table 62: BTI7000 Series Error Messages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 549

Table 63: BTI700 Series Error Messages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 550

Table 64: PSM Alarms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 551

Table 65: BTI7800 Alarm Fields . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 554

Table 66: Physical PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 560

Copyright © 2019, Juniper Networks, Inc.xviii

proNX Service Manager User Guide



Table 67: SONET PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 561

Table 68: SDH PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 562

Table 69: OTN PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 563

Table 70: GE/FC/10GELAN PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 563

Table 71: Port PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 565

Table 72: OSC PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 566

Table 73: Wavelength Channel PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 567

Table 74: Physical PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 567

Table 75: OTN PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 568

Table 76: GE/10GE PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 569

Table 77: Ethernet L2 PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 569

Table 78: LAG PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 571

Table 79: ERPS PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 571

Table 80: Ethernet L2 PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 573

Table 81: Physical PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 574

Table 82: GE Layer 1 PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 575

Table 83: Ethernet L2 PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 575

Table 84: Optics PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 576

Table 85: OTU PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 577

Table 86: ODU PMs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 577

Table 87: Common Regex Constructs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 578

xixCopyright © 2019, Juniper Networks, Inc.

List of Tables



Copyright © 2019, Juniper Networks, Inc.xx

proNX Service Manager User Guide



About the Documentation

• Documentation and Release Notes on page xxi

• Documentation Conventions on page xxi

• Documentation Feedback on page xxiii

• Requesting Technical Support on page xxiv

Documentation and Release Notes

To obtain the most current version of all Juniper Networks
®
technical documentation,

see the product documentation page on the Juniper Networks website at

https://www.juniper.net/documentation/.

If the information in the latest release notes differs from the information in the

documentation, follow the product Release Notes.

Juniper Networks Books publishes books by Juniper Networks engineers and subject

matter experts. These books go beyond the technical documentation to explore the

nuances of network architecture, deployment, and administration. The current list can

be viewed at https://www.juniper.net/books.

Documentation Conventions

Table 1 on page xxii defines notice icons used in this guide.
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Table 1: Notice Icons

DescriptionMeaningIcon

Indicates important features or instructions.Informational note

Indicates a situation that might result in loss of data or hardware damage.Caution

Alerts you to the risk of personal injury or death.Warning

Alerts you to the risk of personal injury from a laser.Laser warning

Indicates helpful information.Tip

Alerts you to a recommended use or implementation.Best practice

Table 2 on page xxii defines the text and syntax conventions used in this guide.

Table 2: Text and Syntax Conventions

ExamplesDescriptionConvention

To enter configuration mode, type the
configure command:

user@host> configure

Represents text that you type.Bold text like this

user@host> show chassis alarms

No alarms currently active

Represents output that appears on the
terminal screen.

Fixed-width text like this

• A policy term is a named structure
that defines match conditions and
actions.

• Junos OS CLI User Guide

• RFC 1997,BGPCommunities Attribute

• Introduces or emphasizes important
new terms.

• Identifies guide names.

• Identifies RFC and Internet draft titles.

Italic text like this

Configure themachine’s domain name:

[edit]
root@# set system domain-name
domain-name

Represents variables (options for which
you substitute a value) in commands or
configuration statements.

Italic text like this
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Table 2: Text and Syntax Conventions (continued)

ExamplesDescriptionConvention

• To configure a stub area, include the
stub statement at the [edit protocols
ospf area area-id] hierarchy level.

• Theconsoleport is labeledCONSOLE.

Represents names of configuration
statements, commands, files, and
directories; configurationhierarchy levels;
or labels on routing platform
components.

Text like this

stub <default-metricmetric>;Encloses optional keywords or variables.< > (angle brackets)

broadcast | multicast

(string1 | string2 | string3)

Indicates a choice between themutually
exclusive keywords or variables on either
side of the symbol. The set of choices is
often enclosed in parentheses for clarity.

| (pipe symbol)

rsvp { # Required for dynamicMPLS onlyIndicates a comment specified on the
same lineas theconfiguration statement
to which it applies.

# (pound sign)

community namemembers [
community-ids ]

Encloses a variable for which you can
substitute one or more values.

[ ] (square brackets)

[edit]
routing-options {
static {
route default {
nexthop address;
retain;

}
}

}

Identifies a level in the configuration
hierarchy.

Indention and braces ( { } )

Identifies a leaf statement at a
configuration hierarchy level.

; (semicolon)

GUI Conventions

• In the Logical Interfaces box, select
All Interfaces.

• To cancel the configuration, click
Cancel.

Representsgraphicaluser interface(GUI)
items you click or select.

Bold text like this

In the configuration editor hierarchy,
select Protocols>Ospf.

Separates levels in a hierarchy of menu
selections.

> (bold right angle bracket)

Documentation Feedback

We encourage you to provide feedback so that we can improve our documentation. You

can use either of the following methods:

• Online feedback system—Click TechLibrary Feedback, on the lower right of any page

on the Juniper Networks TechLibrary site, and do one of the following:
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• Click the thumbs-up icon if the information on the page was helpful to you.

• Click the thumbs-down icon if the information on the page was not helpful to you

or if you have suggestions for improvement, and use the pop-up form to provide

feedback.

• E-mail—Sendyourcommentsto techpubs-comments@juniper.net. Includethedocument

or topic name, URL or page number, and software version (if applicable).

Requesting Technical Support

Technical product support is available through the JuniperNetworksTechnicalAssistance

Center (JTAC). If you are a customer with an active J-Care or Partner Support Service

support contract, or are covered under warranty, and need post-sales technical support,

you can access our tools and resources online or open a case with JTAC.

• JTAC policies—For a complete understanding of our JTAC procedures and policies,

review the JTAC User Guide located at

https://www.juniper.net/us/en/local/pdf/resource-guides/7100059-en.pdf.

• Product warranties—For product warranty information, visit

https://www.juniper.net/support/warranty/.

• JTAC hours of operation—The JTAC centers have resources available 24 hours a day,

7 days a week, 365 days a year.

Self-Help Online Tools and Resources

For quick and easy problem resolution, Juniper Networks has designed an online

self-service portal called the Customer Support Center (CSC) that provides youwith the

following features:

• Find CSC offerings: https://www.juniper.net/customers/support/

• Search for known bugs: https://prsearch.juniper.net/

• Find product documentation: https://www.juniper.net/documentation/

• Find solutions and answer questions using our Knowledge Base: https://kb.juniper.net/

• Download the latest versions of software and review release notes:

https://www.juniper.net/customers/csc/software/

• Search technical bulletins for relevant hardware and software notifications:

https://kb.juniper.net/InfoCenter/
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• Join and participate in the Juniper Networks Community Forum:

https://www.juniper.net/company/communities/

• Create a service request online: https://myjuniper.juniper.net

Toverify serviceentitlementbyproduct serial number, useourSerialNumberEntitlement

(SNE) Tool: https://entitlementsearch.juniper.net/entitlementsearch/

Creating a Service Request with JTAC

You can create a service request with JTAC on theWeb or by telephone.

• Visit https://myjuniper.juniper.net.

• Call 1-888-314-JTAC (1-888-314-5822 toll-free in the USA, Canada, and Mexico).

For international or direct-dial options in countries without toll-free numbers, see

https://support.juniper.net/support/requesting-support/.
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CHAPTER 1

proNX Service Manager

• About PSM on page 27

• PSMOverview on page 28

• Running with Multiple Servers on page 29

• Supported Network Elements on page 32

About PSM

The proNX Service Manager (PSM) provides comprehensive service provisioning,

monitoring, and troubleshooting tools to allow you to efficiently manage network

resources in a packet optical network. With its service-centric focus, PSM simplifies

network operations and increases operational efficiency in tasks such as visualization

and activation of services to troubleshooting and supporting end customers.

PSM is Java-based and uses a client-server architecture.

PSMClient

The PSM client is a Java-based GUI that communicates with the PSM server using an

HTTPS-based protocol to provide the full functionality of the proNX Service Manager.

The PSM client software runs on the desktop or laptop of the technician or NOC staff.

PSMDashboard

The PSM Dashboard is a thin HTTPSWeb-based client that is used to provide a quick

view of the health of the managed network. It offers a subset of the functionality of the

PSM client and runs on the desktop or laptop of the technician or NOC staff. The PSM

Dashboard runs on supported browsers and does not require client software. For more

information on the PSM Dashboard, see the proNX Service Manager Dashboard User

Guide.

PSMServer

The PSM server communicates with network elements using SNMP or NETCONF and

runs on Red Hat (CentOS) Linux on standard x86-64 servers. PSM clients and PSM

Dashboard users connect to the PSM server to manage the network elements in the

network.
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The number of clients and nodes supported is determined by the hardware, and a

calculator is available to determine the correct hardware for specific deployments.

The PSM server has the following components:

• One or more Java-based processes (depending on the performance requirements of

the platform)

• MySQL database (automatically backed up daily)

Red Hat (CentOS) Linux

The PSM server is supported on Red Hat (CentOS) Linux. To facilitate configuration of

the operating system, the PSM ISO includes a setup script that configures Red Hat

(CentOS) Linux and installs the software packages required by the PSM server. For

information on how to use this setup script to configure Red Hat (CentOS) Linux, see

Installing and Configuring Red Hat (CentOS) Linux.

Support for RADIUS Server

Included in the PSM server software package is a local instance of a RADIUS server

implementation. When PSM is installed, the PSM server is configured by default to use

this local RADIUS server to provide authentication and authorization mechanisms for

access to PSM features.

PSMOverview

The PSM servermanages network elements using SNMP andNETCONF. The PSM client

and the PSM Dashboard provide you with the user interface to interact with the PSM

server.

In the PSM paradigm, network element configuration data resides solely on the network

elements themselves. The PSM server does not keep a separate network element

configuration database. This absence of a centralized database allows PSM to achieve

better scaling and better concurrency.

Whenmanagement systemsoperatedirectlyonconfigurationdatastoredon thenetwork

elements, there is added assurance that the data is accurate and up to date. Because

there is only one set of data, issues with synchronizing an external copy of the data with

the actual data on the network element do not exist. Furthermore, since the actual data

ismanipulated directly, it is a simplematter for themanagement software to detect and

handle situations where multiple users attempt to make conflicting changes, regardless

of whether the conflicting users are using the CLI, a separate nodal manager, or other

PSM servers.

Figure 1 on page 29 shows a network managed by two PSM servers andmultiple clients,

along with an external RADIUS server.
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Figure 1: PSMManaged Network

When a server comes up, it registers itself as a trap listener on all network elements it is

told to discover. It then receives traps from, and reports on, these network elements, and

draws topology and discovers services based on configuration and operational data it

reads from these network elements. This information is thenmade available to PSM

clients that log in to this server. Clients logging in to a different server might see different

network elements altogether, depending on what this other server is configured to

discover.

Running withMultiple Servers

• Overview on page 29

• Running Multiple ServersWithout Server Replication on page 30

• Running Multiple Servers with Server Replication on page 30

Overview

To provide a level of redundancy, PSM supports the use of multiple servers to manage

a network.

Inamulti-server configuration, eachserver receives traps from,and reportson, thenetwork

elements that it has discovered. The set of discovered network elements can be the

same or can be different from server to server, depending purely on how you choose to

divide your network formanagement. The servers canbegeographically distinct for better

disaster recovery or be part of a geographically-basedmanagement scheme.

NOTE: SomeBTISeries network elementshave limits on thenumber ofPSM
servers that can be used tomanage them. See PSM Server Requirements for
details.

Since the servers operate directly on configuration data stored on the network elements

themselves, each server has the latest view, and is able to detect and recover from
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conflicts (in the unlikely event that two or more servers are changing the same set of

attributes on the same network element).

While the PSM server does not store network element configuration data, it does store

configuration data associated with the PSM server itself. This PSM configuration data

relates to user interface interactions and the presentation of information, and includes

the following:

• users for the server

• the list of network elements to discover and domain/groupmembership, which relate

to what network elements to manage and how they are organized

• alarm assignment/acknowledgment andmaintenancemodes, which relate to

management actions that a user can take

• customerdetails andassociation,whichcanbeoptionally definedandassociatedwith

services

• profiles, which are network-wide to provide consistency across network elements

• variousoptions related to thedisplayofdata, the locationsof tools, andother attributes

specific to the server

The PSM server stores this set of information in the local MySQL database, which is set

up and initialized during the PSM server installation process, and which persists through

PSM server software upgrades.

How this data behaves when you run with multiple servers depends on whether you

choose to run these servers independently (without server replication), or loosely coupled

(with server replication).

RunningMultiple ServersWithout Server Replication

When you runmultiple servers without server replication, each server is unaware of the

other servers, and each has its own set of PSM configuration data.

The PSM configuration data that resides on the PSM server is not replicated nor

synchronized with the PSM configuration data on the other servers.

For example, network element groups created on one server are not visible to the other

servers, alarm assignment on one server is not visible to the other servers, and so forth.

With this approach,while you still achieve redundancy, youmight have to recreate and/or

reconcile your PSM configuration data when a server goes down.

RunningMultiple Servers with Server Replication

When you runmultiple servers with server replication, some of the PSM configuration

data is synchronized among all servers within the same server replication cluster. This

data subset is called the replicated data.

Updates to the replicated data on one server are automatically conveyed to all other

servers in the same cluster. For example, a network element group created on one server

automatically appears on the other servers, an alarm assignment on one server
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automatically appears on the other servers, and so forth. In this way, when a server goes

down, you can simply log in to another server and continue working.

Whenenabling server replication ona server, youmust explicitly specify the list of servers

that belong to the same server replication cluster. A server replication cluster is a group

of servers whose replicated data is synchronized among all its members. Not all servers

in the network need to belong to the same server replication cluster. You can havemore

than one server replication cluster in the network.

When a server configured for server replication comes up, it seeks out other members in

thecluster and retrieves their replicateddata.Theserver thenoverwrites itsown replicated

data with the retrieved replicated data. In other words, the first server that comes up is

assumed to possess the correct replicated data. Servers that come up subsequently

acquire and adopt this replicated data, which ultimately comes from the first server.

Once all servers are up, the relationship between servers is peer-to-peer. Changesmade

on one server are automatically multicasted to the other servers. Each server will always

have the up-to-date view.

Table 3onpage31 presents ahigh level viewofwhatPSMconfigurationdata is replicated

and what is not replicated. Items not in this list are also not replicated. More details on

this replicated data are provided in the respective sections of this guide.

Table 3: Replicated Data

ReplicatedPSM configuration data

No

To support geographically-basedmanagement schemes, NE
discovery is not replicated.

NEs to discover

YesNEmaintenancemode

YesNE groupmembership and group attributes

YesEthernet domain membership

YesAcknowledged and/or assigned alarms

YesCustomer information and customer-to-service mapping

YesProfile templates

Yes

In order for user replication to work correctly, all servers in a
cluster must use the same RADIUS server for authentication.

Users

NoVarious PSM user preferences and options that relate to the
display and presentation of information

For information on how to configure server replication, seeConfiguring Server Replication.
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Supported Network Elements

You can use the proNX Service Manager to manage the following Juniper Networks

devices:

• BTI7800 Series

• BTI7000 Series

• BTI800 Series

• BTI700 Series

• MX Series and PTX Series routers (basic support)

• QFX Series switches (basic support)

Management capabilities anddevice response varydependingon thedevice.Differences

in support or behavior are stated in the respective procedures in this document.

The proNX Service Manager provides basic support for Juniper Networks MX Series and

PTX Series routers and QFX Series switches. This includes basic discovery and retrieval

of system information, alarmmanagement, inventory, log collection, report generation,

performancemonitoring, and software configuration backup and restore.

Additionally, the proNX Service Manager supports the ability to configure a BTI7000

Series optical service with endpoints on select interfaces on MX Series and PTX Series

routers andQFXSeries switches. Formore information, see “ActivatinganOpticalService

Between Transponder Interface Endpoints” on page 308.

To obtain a detailed list of all supported devices, see “Viewing the List Of Supported

Devices” on page 40.

To see what network element software releases are supported, see the proNX Service

Manager Release Notes.
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CHAPTER 2

Getting Started

• Starting the PSM Client on page 33

• PSM Client Navigation on page 36

• Working with the PSM Client Window System on page 36

• Customizing the Quick Access Toolbar on page 38

• Displaying the Online Help on page 40

• Viewing the List Of Supported Devices on page 40

Starting the PSMClient

Use this procedure to start the PSM client onWindows, Linux, or OS X.

Before you can perform this procedure, youmust install the client software. Refer to

Installing the PSM Client Using theWizard or Installing the PSM Client Manually for

instructions on installing the client.
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1. Launch the psmclient executable file as follows:

• Windows: navigate to the bin folder within the PSM client installation folder and

double-click the psmclient.exe file. Alternatively launch the client from the Desktop

icon or Start menu entry created by the PSM client installer.

• OS X or Linux: open a terminal window, navigate to the PSM client installation

directory and launch from the command line: bin/psmclient. Alternatively launch

the client from the Desktop icon created by the PSM client installer.

The PSM installation starts by displaying the splash screen.

Then PSM displays the login screen.

2. In theServer field, enter the IP address for the PSMserver, or choose a previously used

server from the drop-downmenu.

3. Enter the Username and Password.

4. Click Login.

After successful login, the PSM client navigation window is displayed. The following

screen shows a newly installed server with no pre-discovered network elements.
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A"Connected toServer" indication is displayed in the lower right corner of thewindow.

If connectivity to the server is lost, this changes to a "Connection to Server Lost"

indication.

NOTE: Dependingon the frequencywithwhich theclientandserver check
the path, it might take several minutes for a loss of connectivity to be
detected and displayed.

If JuniperNetworkshasupdated theutility software, youmight see the followingdialog

in certain situations:

The utility software is the software defined in Tools >Options >Utilities. Choose:

• Overwrite if you have not changed any of the Type or Version Default settings.

Choosing this option only overwrites the Default settings, and does not affect or

overwrite the Type or Version-specific settings.

• NotNow if you have changed theDefault settings and youwant to save thembefore

you overwrite them. To save the current Default settings, select Tools >Options

>Utilities and click Export to save the settings (including the Default settings) to a

zipped file. The Default settings can be found in

config\Preferences\com\btisystems\pronx\ems\client\preferences.properties in

the exported file. After you save the Default settings, re-launch the PSM client and

chooseOverwrite in the dialog.

• Skip Versions only if instructed to do so by Juniper Networks Support.

This procedure is complete.
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PSMClient Navigation

The proNX Service Manager client offers point-and-click navigation. Themain entry

screen is structured as shown in the following figure.

Figure 2: Top Level Screen Layout for proNX Service Manager

• Panel A provides information in a tree. Selecting an item from the tree has the effect

of placing the information inother panels in context of the selection. Inmost situations,

you will work with the Network tree panel, which lists network elements under

management, services, and other information. You can expand the network elements

in the tree to see their components. If theNetwork treepanel is closed, you can re-open

it by selecting View >Network >Network.

• Panel B is themain panelwhere you performmost of your tasks. It provides a graphical

view of network elements, services, and topology, and presents the configuration

screens needed for your task.

• PanelCprovidesadetailed list ofalarms, tasksoroutput (generated reports)depending

on which tab in the lower left corner you select.

• PanelDprovidesamenu-based tool bar toaccessall of thePSMfunctions, andaquick

access tool bar with buttons to access the common functions.

NOTE: The panels can be resized, minimized, closed, undocked, or moved.
To return to the initial view, selectWindow >ResetWindows.

Working with the PSMClientWindow System

Use this procedure to dock, float (undock), maximize, minimize, drag-and-drop, or

manipulate a window.

ThePSMwindow system lets youmaximize/minimize, dock/undock, and drag-and-drop

windows. The PSM client leverages Java Swing, which is the standard UI toolkit on the

Java desktop, and is used throughout the PSM client platform. This solution allows the

portability of GUI components across all operating systems allowing Juniper Networks

to offer the PSM client on common operating systems.
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1. To dock, float, maximize or minimize a window, click inside the window and select

Window >ConfigureWindow from themain menu.

a. SelectMaximize to maximize the window. Clear it to restore the window to its

regular size.

b. Select Float to undock the window. If the window has tabs, then this undocks the

current tab.

c. Select Float Group to undock the windowwith all tabs intact.

d. SelectMinimize to minimize the window.

e. Select Dock to dock the window.

f. Select Dock Group to dock the windowwith all tabs intact.

g. Select NewDocument Tab Group to create a new tab group in the current window.

The current window is split into two side-by-side panels, with each panel having

its own set of tabs.

h. SelectCollapseDocument TabGroup to combine the two tab groups back into one

panel.

2. To drag-and-drop a window, click the tab that you want to move, and drag and drop

it in another window.

As you drag the tab, you will see a changing red outline showing the target window.

Once the desired destination is outlined in red, release the mouse.

3. To reset thewindowsback to their initial configuration, selectWindow>ResetWindows.

4. To close the current window, selectWindow >CloseWindow, or simply click the x on

the right side of the tab.

5. To close the current window and all its tabs, selectWindow >Close All Documents.
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6. To close all tabs in the current window except for the current tab, selectWindow

>Close Other Documents.

7. To bring up the Documents dialog, selectWindow >Documents....

a. To switch to a specific window, highlight its entry and select Switch to Document.

b. To close a specific window, highlight its entry and select Close Document(s).

Customizing the Quick Access Toolbar

Use this procedure to customize the quick access toolbar.

The quick access toolbar is found at the top of the client display, and can be used to

launch common tasks.

The following table lists the initial shortcut buttons on the toolbar. The toolbar can be

customized with more or fewer buttons. The buttons provide a way to quickly access

functions that are also available from themenu toolbar. A tool tip and in some cases, a

shortcut key sequence, are displayed when you hover the mouse over a button.

Table 4: Quick Access Toolbar Buttons

FunctionButton

Refresh from Server

The PSM client and the PSM server communicate at regular intervals to
ensure the client has the most recent view of the network. Additionally, the
server updates the client automatically when the server detects changes in
the managed network. The Refresh from Server button provides amanual
way for you to force the PSM client to request (and refresh itself with) the
latest PSM server data.
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Table 4: Quick Access Toolbar Buttons (continued)

FunctionButton

Resync Network

The PSM server and the network elements that it manages communicate at
regular intervals toensure the server has themost recent viewof thenetwork.
Additionally, themanagednetworkelementsupdate theserver automatically
when changes occur. The Resync Network button provides amanual way for
you to force thePSMserver to resynchronize itselfwith themanagednetwork
elements.

Network Element Discovery

“Discovering Network Elements” on page 51

Service Activation

“Activating an Optical Service in a BTI7000 Network” on page 306

“Activating an Optical Service in a BTI7800 Network” on page 319

“Activating a Transport Service” on page 328

“Activating an Ethernet Service” on page 348

“Activating a Pseudowire Service” on page 445

Profile Manager

“Managing Profiles” on page 426

Add Customer

“Adding a Customer” on page 454

Schedule List

“Scheduling Network Element Discoveries” on page 57

Save Configuration

“Saving Network Element Configuration Information” on page 545

Archive Logs

“Exporting Client and Server Logs” on page 539

Suspend Alarm Notifications

“Working with the Alarms Table” on page 462

Historical PMs

“Collecting and Viewing Historical PMs” on page 531
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To customize the quick access toolbar:

1. SelectWindow >Toolbars from themain menu, or right-click the area to the right of

the quick access toolbar.

a. Click to toggle entries from the list of standard quick access buttons.

b. To use the smaller toolbar icons, select Small Toolbar Icons. To use the regular

toolbar icons, clear Small Toolbar Icons.

c. To reset the toolbar to the initial setting, choose Reset Toolbars.

d. To add other buttons or to create a new toolbar, choose Customize and select the

buttons you want to be shown.

Displaying the Online Help

Use this procedure to display the PSM online Help.

1. Select Help >Open Help.

The online Help is launched in your default Web browser.

Viewing the List Of Supported Devices

Use this procedure to view the list of devices supported by the proNX Service Manager.

1. From the topmenu bar, select Help >Server Info.

The list of supported devices and their software releases are shown in the Supported

Network Elements pane. For example:
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2. To see the list of software versions supported for each device, expand the device type

in the Supported Network Elements pane.

NOTE: See the proNX Service Manager Release Notes for themost
up-to-date list of device software releases supported.

3. Use the scroll bar on the right side of the pane to scroll through the list of devices and

versions supported.
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CHAPTER 3

Managing PSM Users

• Introduction on page 43

• Adding a User on page 44

• Modifying a User on page 46

• Deleting a User on page 49

• Editing User Attributes on the Local RADIUS Server on page 49

Introduction

PSM performs user authentication using either the local pre-packaged RADIUS server

or external RADIUS servers. By default, PSM is configured to use the local pre-packaged

RADIUS server.

To help you work with the local RADIUS server, PSM provides you with an interface to

add, modify and delete users from the local RADIUS server database. This capability to

make changes to the local RADIUS server database is supported even if you are not using

the local RADIUS server for authentication. In this latter case, the changes have no effect

on authentication, but are still applicable for creating users for tasks like assigning an

alarm to a user.

You cannot use PSM to add, modify, or delete users from external RADIUS servers. An

external RADIUS server is any RADIUS server that is not the local, co-resident RADIUS

server. Note that the local, co-resident RADIUS server can act as an external RADIUS

server to other PSM servers.

The above is true even if you run with server replication. When you run with server

replication, you also cannot add, modify, or delete users from external RADIUS servers.

In order to add,modify, or delete users, youmust be logged in to the PSMserver onwhich

the RADIUS server is running.

NOTE: It is recommended that the same PSM login credentials (username
andpassword)beaddedto thenetworkelementsundermanagement.Some
PSM tasks (including using the network element CLI) require the server to
log in to the network element using the PSM user’s login credentials.
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For information on configuring PSM to work with RADIUS servers (local or external), see

RADIUS on PSM.

Adding a User

Use this procedure to add a user to the local RADIUS server database.

PSM provides you with an interface to add users to the local RADIUS server database.

You cannot use this procedure to add a user to an external RADIUS server database. An

external RADIUS server is any RADIUS server that is not the local, co-resident RADIUS

server. Note that the local, co-resident RADIUS server can act as an external RADIUS

server to other PSM servers.

The local co-resident RADIUS server can be used by both PSM and network elements

for authentication and authorization of the same users. Since the privilege definitions for

PSMand the network elementsmight differ, PSMautomatically adds a set of equivalent

privileges to the RADIUS database for that user (Table 5 on page 44). For example, if

you add a user with the NOC privilege, PSM automatically configures the user with the

equivalent surveillance and viewer privileges as well.

Table 5: PSM Privilege Equivalencies

BTI800 privilegesBTI7000, BTI7800 privilegesPSM privileges

adminsuperuserAdministrator

operatorprovisioningService Provider

viewersurveillanceNOC

NOTE: You can always bypass PSM and add users to the local RADIUS
database directly through the interface provided by theRADIUS server. If you
do this, the users can still bemodified in PSM.
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To add a user:

1. Choose Edit >User Management from themain menu.

The User Managementwindow appears.

The Locally Managed User column indicates whether the user is in the local RADIUS

server database (yes) or in another RADIUS server database (no). Users configured

in an external RADIUS server appear in this list if PSM is using an external RADIUS

server for authentication.

2. Right-click the Users row and choose Add User.

The Add User dialog box is displayed.

3. In the Add User dialog box, specify the following information.

• Username

• Password, can consist of alphanumeric characters and the following special

characters:

! @ # $ % ^ & ( ) _ + [ ] { } . ~
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• Confirm Password

• Role, one of:

• Administrator - this role has complete access to all functions

• ServiceProvider - this roleallows theuser tocreate services, andhas the following

limitations:

• TheServiceProvider role can read, create, andupdateeverything, exceptdevice

discoveries and scheduled device discoveries

• The Service Provider role cannot create new users.

• The Service Provider role can update its own user record, but no other user

records. It also cannot change its own role.

• The Service Provider role cannot move network element groupmembers.

• The Service Provider role cannot delete anything except for Bandwidth Profile

Templates, Class Map Profile Templates, Service Policy (and Map) Profile

Templates, and Customers.

• NOC - this role provides read-only access

• First name of the user (optional)

• Last name of the user(optional)

• Email address for the user (optional)

• Telephone number for the user (optional)

4. ClickOK.

The user is added to the local RADIUS server database.

Modifying a User

Use this procedure to edit a user in the local RADIUS server database.

PSMprovides youwith an interface tomodify users in the local RADIUS server database.

You cannot use this procedure to add a user to an external RADIUS server database. An

external RADIUS server is any RADIUS server that is not the local, co-resident RADIUS

server. Note that the local, co-resident RADIUS server can act as an external RADIUS

server to other PSM servers.

The local co-resident RADIUS server can be used by both PSM and network elements

for authentication and authorization of the same users. Since the privilege definitions for

PSMand the network elementsmight differ, PSMautomatically adds a set of equivalent

privileges to the RADIUS database for that user (Table 6 on page 47). For example, if

you set a user's privilege to NOC, PSM automatically configures the RADIUS server with

the equivalent surveillance and viewer privileges as well.
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Table 6: PSM Privilege Equivalencies

BTI800 privilegesBTI7000, BTI7800 privilegesPSM privileges

adminsuperuserAdministrator

operatorprovisioningService Provider

viewersurveillanceNOC

NOTE: You canalways bypassPSMandedit users in the local RADIUS server
database directly through the interface provided by the RADIUS server.

Tomodify a user:

1. Choose Edit >User Management from themain menu.

The User Managementwindow appears.

The Locally Managed User column indicates whether the user is in the local RADIUS

server database (yes) or in another RADIUS server database (no). Users configured

in an external RADIUS server appear in this list if PSM is using an external RADIUS

server for authentication. You can use this procedure to edit locally managed users

only.

2. Right-click the desired user's row and choose Edit User.

The Edit User dialog box is displayed.

47Copyright © 2019, Juniper Networks, Inc.

Chapter 3: Managing PSMUsers



3. In the Edit User dialog box, specify the following information as necessary.

• Username - this cannot be changed. To change the user name, youmust create a

new user with the desired name.

• Password, can consist of alphanumeric characters and the following special

characters:

! @ # $ % ^ & ( ) _ + [ ] { } . ~

• Confirm Password

• Role, one of:

• Administrator - this role has complete access to all functions

• ServiceProvider - this roleallows theuser tocreate services, andhas the following

limitations:

• TheServiceProvider role can read, create, andupdateeverything, exceptdevice

discoveries and scheduled device discoveries

• The Service Provider role cannot create new users.

• The Service Provider role can update its own user record, but no other user

records. It also cannot change its own role.

• The Service Provider role cannot move network element groupmembers.

• The Service Provider role cannot delete anything except for Bandwidth Profile

Templates, Class Map Profile Templates, Service Policy (and Map) Profile

Templates, and Customers.

• NOC - this role provides read-only access

• First name of the user (optional)

• Last name of the user(optional)
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• Email address for the user (optional)

• Telephone number for the user(optional)

4. ClickOK.

Deleting a User

Use this procedure to delete a user from the local RADIUS server database.

You cannot use this procedure to delete users from an external RADIUS server database.

An external RADIUS server is anyRADIUS server that is not the local, co-resident RADIUS

server. Note that the local, co-resident RADIUS server can act as an external RADIUS

server to other PSM Servers.

To delete a user:

1. Choose Edit >User Management from themain menu.

The User Managementwindow appears.

NOTE: The Locally Managed User column indicates whether the user is in

the local RADIUS server database (yes) or in an external RADIUS server

database (no). You can only delete locally managed users.

2. Right-click the desired user's row and choose Delete User.

3. In the Confirm User Deletion dialog box, clickOK.

The user is deleted from the local RADIUS server database.

Editing User Attributes on the Local RADIUS Server

Use this procedure to set the idle timeout value for the user's CLI session.
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If the user's CLI session is idle for the specified time, the user is automatically logged out.

This attribute governs the CLI session only, and does not affect the user's PSM client

session.

1. Select Edit >Radius Attributes from themain menu bar.

The Radius Attributeswindow appears.

2. Right-click the user you want to edit and select Edit Radius Attribute.

The Edit Radius Attribute dialog appears.

3. Set the idle timeout value.

4. ClickOK.
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CHAPTER 4

ManagingNetworkDiscoveryandEthernet
Domains

• Introduction on page 51

• Discovering Network Elements on page 51

• Undiscovering a Network Element on page 55

• Rediscovering a Network Element on page 55

• Polling Discovered Network Elements on page 55

• Ethernet Network Domains on page 56

• Scheduling Network Element Discoveries on page 57

Introduction

The first step to managing a network is to discover the network elements you want to

manage. During discovery, PSM registers itself as a trap receiver and reads configuration

andoperational data fromthenetworkelement.Discoverednetworkelementsare shown

in the topologyMapview.PSMusesSNMP(andNETCONF ifapplicable) tocommunicate

with discovered network elements.

PSM supports the discovery of the following network elements:

• BTI7800 Series network elements

• BTI7000 Series network elements

• BTI800 Series network elements

• BTI700 Series network elements

• MX Series and PTX Series routers

• QFX Series switches

Additionally, PSM can discover any SNMPMIB-II compliant device.

Discovering Network Elements

Use this procedure to discover network elements in the network you want to manage.
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1. Select theNetworkElementDiscoverybuttonon the toolbar or chooseTools>Network

Element Discovery from themenu.

The Network Element Discoverywindow is displayed, as shown below.

2. Enter the criteriawithwhich to discover the network elements in theDiscoveryCriteria

field.

Table 7: Discovery Criteria

ExampleFormatCriteria

Belfast

The use of the group name as part of the
network element discovery criteria allows you
to specify a group of network elements for
discovery. The group of network elements
must have been previously created. See
“Creating a New Group” on page 87.

NOTE: Using thegroupname isnotapplicable
when discovering network elements for the
first time.

AlphanumericGroup Name

OTT-204-3AlphanumericHost Name (DNS)
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Table 7: Discovery Criteria (continued)

ExampleFormatCriteria

172.27.1.1, 172.27.1.2List separated by comma or single entryIP address

172.27.7.100-110Address range

172.27.7.255All devices in a subnet

3. Optionally, specify the EthernetManagement Domain.

Domains are usedwhencreating Ethernet services. Formore informationondomains,

see “Ethernet Network Domains” on page 56.

If you do not plan on creating Ethernet services, you do not need to specify a domain.

4. Optionally, select Automatically Configure JUNOS if you want PSM to automatically

configure a Juniper Networks router or switch for NETCONF and SNMP access from

PSM.

When selected, PSM configures the router or switch to accept NETCONF requests

from the specified Port and sets the SNMPwrite community string to private.

5. Optionally, specify the NETCONF parameters if the network element you are

discovering supports NETCONF.

You can specify the NETCONF Username, Password, and Port, or you can leave them

blank to use the defaults. The defaults are set to match the defaults on the devices

being managed.

6. Optionally, specify the SNMP parameters.

You can specify an SNMPWrite Community string and a Port, or you can leave them

blank to use the defaults. The default write community string is private. The default
port is 161.

NOTE: Because PSM uses SNMP for the initial communications with the
network element, the SNMP parameters must be correct even if PSM is
using NETCONF tomanage the network element. Additionally, some
devices require SNMP for trap server registration.

7. Optionally, select Auto-Discovery of Connected Devices if you want PSM to

automatically discover all network elements connected to the network element you

are discovering.
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If you select this option, PSMwill automatically discover all connected network

elements in a BTI7000 Series DOL network, and all connected network elements in

a BTI7800 Series ROADM network or a BTI7800 Series transport network .

8. Optionally, select Configure Topology Discovery if youwant to enable LLDP on the NE.

If you select this option, PSMwill enable LLDP on the NE after the NE is discovered.

If you do not select this option, PSMwill not enable LLDP on the NE after the NE is

discovered. In this latter case, the LLDP setting on the NE is left unchanged.

This setting applies to BTI7000, BTI800, and BTI700 network elements only.

9. ClickOK to start device discovery.

The following figure shows PSMwhen network elements are discovered successfully.

TheElementsbranch in theNetwork treecanbeexpanded toshowall thecomponents

on the network element.

If PSM is unsuccessful in discovering a network element, the font below the network

element icon is red. Common reasons for failure include invalid credentials or port

numbers, or if the network element cannot be reached.

NOTE: The first discovery of a newnetwork element typeor versionmight
take longer than subsequent discoveries. The reason for this is that PSM
builds a database schema for each new network element type or version
it encounters.
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Undiscovering a Network Element

Use this procedure to undiscover a network element.

Discovered network elements can be undiscovered, which deregisters PSM as a trap

receiver and removes the network element fromunder PSMmanagement. Undiscovered

network elements continue to appear in PSM, but with a distinctive icon.

1. Right-click the network element you want to undiscover and select Discovery

>Undiscover.

The Undiscover confirmation dialog appears:

2. ClickOK to confirm.

The network element is no longer under PSMmanagement, and is shown with a

icon. You can leave the network element as is, or you can completely remove it from

view.

3. To remove the NE completely from view, right-click the NE and select Remove from

Group.

Rediscovering a Network Element

Use this procedure to rediscover a network element.

Discoverednetworkelements canbe rediscovered,whichmanually forcesPSMto retrieve

information from the network elements being rediscovered. Rediscovering a network

element is usually not required under normal situations because the network element

updates PSM asynchronously with any changes as they occur.

1. Right-click the network element you want to rediscover and select Discovery

>Rediscover.

PSM rediscovers the network element.

Polling Discovered Network Elements

PSMsupports anautomaticNEpolling operation that is not user configurable. The server

checks IP, SNMP and/or NETCONF connectivity with each network element every 2

minutes. If the checks fail, the text beside the NE in the Network tree, and beneath the

NE in the Topology Map view, turns red and the NE is declared unreachable.
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Ethernet Network Domains

PSMuses theconceptofEthernetnetworkdomains to support onePSMservermanaging

more than one Ethernet network. A domain is a mechanism used to segregate network

elements in diverse networks that are not interconnected, and where there is reuse of

serviceVLAN IDs.Thisallows for theproperhandlingof reusedserviceVLAN IDs in service

visualization and activation operations.

NetworkelementscanbeaddedtoanEthernetdomainduringnetworkelementdiscovery.

Ethernet domains are not used and do not need to be defined for optical networks.

NOTE: Ethernet domains are part of the replicated data set when running
withmultiple servers. Formore information on replicated data, see “Running
Multiple Servers with Server Replication” on page 30.

• Creating an Ethernet Domain on page 56

• Checking Domain Membership for a Network Element on page 57

Creating an Ethernet Domain

Use this procedure to create an Ethernet domain for an Ethernet network.

During a discovery operation, if the specified domain does not already exist, it is created,

and all devices discovered during that operation are added to it. Domains appear in the

Ethernet branch of the network tree when Ethernet services are created.

If you do not explicitly specify a domain, all devices discovered during this operation will

be assigned to the Default domain.

1. From themain menu, choose Tools >Network Element Discovery.

2. Enter a name for the domain in the Domain field of the Network Element Discovery

window.

The domain name is case insensitive. Youmust not create multiple domains where

the domain names differ only in the case. For example, if you create a domain called

Belfast, you must not create a new domain called belfast as this differs only in case
with the existing Belfast domain name.

3. Enter the discovery criteria.

4. ClickOK.

The discovered network elements are added to the new domain.

NOTE: Once a new domain is created, it cannot be deleted.
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NOTE: Tomove a network element from one domain to another, simply
discover the network element again and specify the desired domain.
MovingNEs betweendomainsmight causeVLAN ID conflicts. If the same
VLAN ID exists in two domains and an NEwith one of those VLAN IDs in
one domain is moved to the other domain, the services associated with
the VLAN ID on the NE beingmoved are no longer recognized. Conflicting
VLAN IDs should be resolved before NEs aremoved between domains.

Checking DomainMembership for a Network Element

Use this procedure to check what domain a network element belongs to.

1. Hover over the network element in the Network tree.

For example:

2. Alternatively, hover over the network element in the Topology view.

For example:

Scheduling Network Element Discoveries

Youcanschedule theproNXServiceManager to rediscovernetworkelementsperiodically.
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NOTE: Youdonotnormallyneedtoschedulediscoveriesbecausethenetwork
elements automatically update PSM of any changes.

• Scheduling a Network Element Discovery Task on page 58

• Viewing Scheduled Tasks on page 61

• Deleting Scheduled Tasks on page 62

Scheduling a Network Element Discovery Task

Use this procedure to schedule a discovery task for a network element.

1. From themain menu, choose Edit >Schedules.

The Schedulerwindow is displayed.

2. In the Schedulerwindow, right-click the Discovery Schedules entry in the table and

choose Add Schedule. The Scheduling dialog window is displayed.

3. Specify the discovery criteria as described in “Discovering Network Elements” on

page 51.
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4. Specify the start date and time using the calendar drop-down list shown below.

a. Select the current day or a date in the future in the calendar. If you select a date in

the past, the discovery runs immediately.

b. Specify the start time in the Time field below the calendar.

5. An end date is optional. To set an end date, use the buttons in the lower left corner

of the Schedule section to set a specific end date, or to set the schedule to end after

a defined number of occurrences.

6. The Recurrence Pattern panel lets you set a schedule to recur at a specific interval, as

follows:

a. Hourly–Thescheduleexecutesat the start timeselectedand recurs for thenumber

of hours specified, until the end date is reached.

b. Daily – The schedule executes at the start time selected and recurs for the number

of days specified, until the end date is reached.
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c. Weekly – The schedule executes at the start time selected and recurs for the

number of weeks specified, on the specific day of the week selected, until the end

date is reached.

d. Monthly – The schedule executes at the start time selected and recurs for the

number of months specified, on the specific day of the month selected, until the

end date is reached.
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e. By the Minute – The schedule executes at the start time selected and recurs for

the number of minutes specified, until the end date is reached.

CAUTION: Use this feature sparingly as it could overload the server
needlessly depending on the frequency chosen and the task to be
executed.

7. When you are done, clickOK.

The new discovery task is added to the Schedules table.

Viewing Scheduled Tasks

To view a scheduled task for a network element:
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1. Access the Scheduler screen using the toolbar button, or from themainmenu choose

Edit >Schedules.

The Scheduler tab is displayed:

2. In the Scheduler tab, expand the entries in the schedule list to view all the tasks

currently scheduled on the server.

The following table describes the scheduler parameters.

Table 8: Scheduler Tab

DescriptionColumn name

Displays the scheduled task criteriaSchedules

Displays the domain within which the task should executeDomain

Displays a summary of the schedule details for the task that was set upSchedule

Deleting Scheduled Tasks

To delete a scheduled task for a network element:

1. Click the Schedules icon. The Scheduler tab appears.

2. Expand the Discovery Schedules entry to display the schedule you want to delete.

3. Right-click the schedule you want to delete, and choose Delete Schedule. A

confirmation dialog appears.

4. ClickOK. The scheduled task is deleted.
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CHAPTER 5

Managing Network Topology

• Introduction on page 63

• Icons and Definitions on page 63

• Understanding the Network Topology View on page 65

• Learning the Network Topology on page 72

• Network Element Groups and Sites on page 86

• Changing the Background View on page 91

Introduction

The proNX Service Manager provides a view of the network, including topology for

supported network elements. The topology window is the main window you see when

logging on to PSM. PSM displays all discovered network elements and, additionally,

displays topology for the following:

• BTI7800 Series network elements

• BTI7000 Series network elements

• BTI800 Series network elements

• BTI700 Series network elements

• MX Series and PTX Series routers and QFX Series switches attached to a BTI7000

Seriesoptical networkusingmanual topology specification (Remote IDs)onsupported

interfaces. See “Nodal Management for Juniper Networks Routers and Switches” on

page 257 for the list of supported interfaces.

Icons and Definitions

Topologymap iconsappear in the topologyMapview.Service iconsappear in thedifferent

service views.

Table 9: Topology Map Icons

DescriptionIcon

A network element.
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Table 9: Topology Map Icons (continued)

DescriptionIcon

A router.

Multiple connections (links) between network elements. To determine whether to display this icon,
PSM counts the connections for all layers currently being displayed. For this icon to bemeaningful,
ensure that youonly select a single layer in the topologyMapview.Otherwise, PSMdisplays thismulti-link
icon when there is a single connection at more than one layer (e.g. a connection at layer 0 and a
connection at layer 1).

A link down-up indication next to a link to indicate that the link has recently gone down and come back
up. The lengthof time that this indication is displayed is configurable (“SettingTopologyDisplayOptions”
on page 276).

A link connecting network elements in a split ROADM node configuration.

A replication cluster member. When server replication is enabled and working, this is found on the PSM
server you are logged on to, and on all members of the same server replication cluster.

A network element that has beenmarked. See “Marking or Unmarking a Network Element” on page 112.

Table 10: Service Icons

DescriptionIcon

General service icons

A network element.

A module, appears when expanding a network element in a service.
name>

<mod-

A service endpoint.

This is also used to indicate a Transport or Ethernet service in the Transport or Ethernet branches of
the Network tree.

A multi-layer service.

Logical connection between an endpoint and the network element or module.

Optical service icons

ROADMNode: a collection of modules providing add/drop/passthrough capability.
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Table 10: Service Icons (continued)

DescriptionIcon

Line Amplifier Node: a collection of modules providing line amplification between two spans.

Line Equalizing Node: a collection of modules providing channel equalization between two spans.

ROADMTerminalNode:acollectionofmodulesprovidingadd/dropcapabilitywithchannel equalization
in a linear span.

An optical service endpoint.

This is also used to indicate an Optical service in the Optical or Transport branches of the Network tree.
In the Transport branch, this indicates the transport service component of an optical service with
transponder interface endpoints. See “Activating an Optical Service Between Transponder Interface
Endpoints” on page 308.

Fiber connection between nodes (with span length displayed in kilometers).

A link connecting network elements in a split ROADM node configuration.

Ethernet service icons

A UNI endpoint.

An NNI endpoint.

An RPL link passing traffic in an ERPS service.

A blocked RPL link in an ERPS service.

A failed link in an ERPS service.

Understanding the Network Topology View

PSM provides amain Topologywindow that displays network elements and links in the

managed network. The topology overlays a background image that can be changed to

suit your particular needs. The Topologywindow is the initial view you see when first

logging on to the PSMserver. You can always go back to theTopologywindow fromother

windows by choosing View >Network >Topology.
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In the upper left corner, you can select from the following topology views:

• Map: The topologyMap view is used to display the topology of the network. PSMbuilds

the topology map based on discovered information as well as throughmanual

specification. Manual specification allows you to supplement the discovered view to

suit your needs.

• Ethernet: TheEthernet servicesview isused todisplay the topologyofaspecificEthernet

service. To see a service, select the desired Ethernet service from the Network tree. For

more information on the Ethernet services view, see “Managing Ethernet Services” on

page 337.

• Transport: The Transport services view is used to display the topology of a specific

transport service. To seeaservice, select thedesired transport service fromtheNetwork

tree. For more information on the Transport services view, see “Transport Services” on

page 323.

• Optical: The Optical services view is used to display the topology of a specific optical

service. To see a service, select the desired optical service from the Network tree. For

more information on the Optical services view, see “Optical Services” on page 301.

• Pseudowire: The Pseudowire services view is used to display the topology of a specific

pseudowire service. To see a service, select the desired pseudowire service from the

Network tree. For more information on the Pseudowire services view, see “Managing

Pseudowire Services” on page 441.

The topologyMap view shows the following:

• discovered network elements

• network element groups that have been created previously (see “Network Element

Groups and Sites” on page 86)

• external devices that have links to discovered network elements

• links provisioned between any of the following: NEs, NE groups, or external devices
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NOTE: An external device is a device that is unmanaged by PSM. PSM
provides the capability to display such devices in the topologyMap view.

Additionally, the view provides various visual cues, as follows:

• The color of the link indicates whether the link is up or down. Green indicates that the

link is up. Red indicates that the link is down.

• A link between amanaged device and an external (unmanaged) device is grey if the

port status on themanaged device is up. It is red if the port status on themanaged

device is down.

• In a multi-link representation where multiple connections are represented by a single

link, red takes precedence over green which takes precedence over grey.

• The color of the font below the NE icon indicates whether the NE is reachable or not.

Black indicates the NE is reachable. Red indicates the NE is not reachable.

• The presence of a dot on the upper left corner of the NE icon indicates the existence

of outstanding alarms. Red indicates the existence of outstanding critical alarms.

Amber indicates the existence of outstanding major alarms. Yellow indicates the

existence of outstanding minor alarms. Whenmultiple levels of alarm severity exist,

the color reflects the level of the most severe alarm. The absence of a dot indicates

no outstanding alarms.

Layer Views

You can select which layer to view in the topology map.

Fromtheupper right corner of the topologyMap view, click toenableordisable thedesired

layer . The selections are not mutually exclusive. You can select multiple layers to view

concurrently.

• Physical: This view shows all the physical layer connectivity (that is, fibers). This is the

default view.

• Layer 0: This view shows the fibers connected to optical layer equipment. Optical layer

equipment consists of ROADMmodules, multiplexer/demultiplexers, and DWDM line

amplifiers. This view is the same as the Physical layer view for the network elements

shown.

• Layer 1: This view shows transport layer connectivity (for example, SONET/SDH

connectivity). This viewmight be different from the Physical layer view.
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• Layer 2: This view shows Ethernet layer connectivity. This viewmight be different from

the Physical layer view.

• Layer 3: This view is not supported.

Only the connectivity for the selected layer(s) is shown.

You can also control whether connectivity to external devices is shown for the selected

layer(s). To show or hide connectivity to external devices, right-click the background in

the topology Map view and toggle between ShowUnknown Links and Hide Unknown

Links.

Network Element and Link Details

Information can be obtained by hovering over or right-clicking certain objects in the view.

Whenhoveringoveranetworkelement, the informationdisplayed includes the IPaddress,

the nameand typeof network element, the software version it is running, notes, an alarm

summary, and other information. Details on how to interpret the alarm summary can be

found in “Understanding the Alarms Summary Bar” on page 466.

Figure 3: Hovering Over a Network Element

When hovering over a PSM server, similar information is displayed. In addition to

information found when hovering over a network element, there is an indication to show

whether this server is part of a server replication cluster. If this server is part of a server

replication cluster, and this is the server to which you are currently logged in, the display

includes a listing of the other cluster member(s) (Figure 4 on page 69). If this server is

part of a server replication cluster, but is not the server to which you are currently logged

in, the display indicates that the server is a cluster member (with no IP addresses

displayed). See “RunningMultiple Serverswith Server Replication” on page 30 for details

on server replication.
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Figure 4: Hovering Over a PSM Server

When hovering over a network element group, an alarm summary is displayed.

Figure 5: Hovering Over a Network Element Group

When right-clicking on a link, an option is presented to Show Link Details.

Figure 6: Show Link Details

When selecting that option, a Link Details data widget title bar is presented.

Figure 7: Link Details DataWidget Title Bar
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When clicking on the Link Details title bar, a Link Detailswindow is presented.

Figure 8: Link Details DataWidgetWindow

Each connection can be expanded to show detailed link information. Table 11 on page 70

shows the type of information that can be displayed. The actual information displayed

depends on the type of network element and port. Not all attributes are supported on

every network element. Figure 9 on page 71 through Figure 14 on page 72 show examples

of the link information provided. Some attributes are optional and are only shown if they

are configured.

Table 11: Link Details

DescriptionAttribute

General

The network element name or IP addressNetwork Element

The port identifier (in the native syntax for the network
element)

Port

The optional port identifier (freeform text)ID

The optional custom fields for the port (freeform text)Custom

Theport state (available formanageddevices only). The state
is shown as UNKNOWN if the device does not provide state
information, such as is the case with
multiplexers/demultipexers, which are passive devices.

State

Optical

The span length of the fiberSpan Length

Themaximum span loss supported on the fiberMax Span Loss

Themaximum span loss alarm threshold on the fiberMax Span Loss Alarm Threshold

The number of optical channels provisioned on the fiberChannel Count

Copyright © 2019, Juniper Networks, Inc.70

proNX Service Manager User Guide



Table 11: Link Details (continued)

DescriptionAttribute

Transponding andMuxponding

The protocolProtocol

The wavelengthWavelength

The line mapping (muxponding)Line Mapping

Figure 9: BTI7000 Series DOL-DOL Link Details DataWidget

Figure 10: BTI7000 Series PVX-PVX Link Details DataWidget

Figure 11: BTI7000 Series Transponder-Transponder Link Details DataWidget
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Figure 12: BTI7000 Series Muxponder-Muxponder Link Details DataWidget

Figure 13:MXSeriesRouterTransponder toBTI7000SeriesDOLLinkDetailsDataWidget

Figure 14: External Device to BTI7000 Series PVX Link Details DataWidget

Youcanhide LinkDetailsby right-clicking on the same link and selectingHideLinkDetails,

or optionally, right-clickinganywhere in thebackgroundandselectingHideAll LinkDetails.

Figure 15: Hide Link Details

Learning the Network Topology

PSM learns the topology of the network in different ways:
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• For optical links onROADMnodes, PSM learns theoptical topologyautomatically from

theDOLorROADMneighbor information tables retrieved fromthenodes.See “Deriving

Optical Topology Using DOL or ROADMData” on page 73.

• For layer 1 (physical) Ethernet links onBTI7800NEswith LLDPsnooping enabled, PSM

learns the layer 1 topology automatically from the snooped LLDP information retrieved

from the NEs. See “Deriving Layer 1 Topology Using Snooped LLDP Data” on page 73.

• For layer 2 Ethernet links onNEswith LLDP enabled, PSM learns the Ethernet topology

automatically from the LLDP neighbor tables retrieved from the NEs. See “Deriving

Ethernet Topology Using LLDP Data” on page 74.

• Additionally, PSM supports a manual specification method that allows you to specify

the topology directly for BTI7000 Series and BTI800 Series network elements. See

“Deriving Topology Using Remote IDs” on page 74. This is the method you use for

specifying the transport topology in a BTI7000 Series network.

• Deriving Optical Topology Using DOL or ROADMData on page 73

• Deriving Layer 1 Topology Using Snooped LLDP Data on page 73

• Deriving Ethernet Topology Using LLDP Data on page 74

• Deriving Topology Using Remote IDs on page 74

Deriving Optical Topology Using DOL or ROADMData

BTI Series ROADMnodes advertise and identify themselves to their optical neighbors by

exchanging information over the optical service channel (OSC). Each node builds a table

of its neighbors. PSM uses this information to build and display an accurate, up-to-date

optical topology of the network.

Deriving Layer 1 Topology Using Snooped LLDP Data

LLDP snooping allows transport equipment to snoop LLDP frames on Ethernet links.

Some Ethernet devices discover their Ethernet neighbors using the Link Layer Discovery

Protocol (LLDP). LLDP runs over Ethernet and allows devices to advertise and identify

themselves to their peers.

When these devices are connected across a transport network, the transport equipment

can snoop passing LLDP frames to determine the identity of the attached devices. If the

transport equipment is managed by PSM, PSM can then use this information to show

connectivity between the transport equipment and the attached Ethernet device.

This capability to snoop LLDP frames is supported for network elements running the

following releases:

• BTI7800 release 4.1 or higher

NOTE: LLDP snoopingmust be enabled on the Ethernet interface on the
device.See“Editingan Interface”onpage205for informationonhowtoenable
LLDP snooping on a BTI7800 UFM interface.
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Deriving Ethernet Topology Using LLDP Data

SomeBTISeriesnetworkelements canbeconfigured todiscover their Ethernetneighbors

using the Link Layer Discovery Protocol (LLDP). LLDP runs over Ethernet, and allows

network elements to advertise and identify themselves to their peers. Each NE builds a

table of its Ethernet neighbors that PSM can retrieve. PSM uses this information to build

and display an accurate, up-to-date Ethernet topology of the network.

This capability is supported in PSM for network elements running the following releases:

• BTI7000 Series release 10.3 or higher

• BTI700 Series release 1.5 or higher (BTI718E all releases)

• BTI800 Series release 1.1 or higher

PSM can only display this topology if the NEs have been configured to use LLDP. You can

configure LLDP on the NEs directly using the proNX900 or the CLI. Alternatively, you can

use PSM to enable LLDP on the NEs during initial NE discovery. For information on how

to do this, see “Discovering Network Elements” on page 51.

Be aware that this method produces an Ethernet topology of the network, which might

not necessarily reflect the physical topology. Where the two topologies do not align, you

can usemanual specification (that is, Remote IDs) to change the discovered Ethernet

topology to align with the physical topology if desired.

Deriving Topology Using Remote IDs

PSM allows you to specify the topology manually hop by hop through the use of the

Remote ID, a parameter that you configure on a supported port to indicate the identity

of the port attached to the other end of the fiber. There are a number of reasons for

specifying the topology in this manner:

1. To include topology that is notautomatically discovered, suchasconnectionsbetween

transport equipment (for example, transponder to transponder for BTI7000 Series

equipment) and connections between transport equipment and optical equipment

(for example, transponder to multiplexer/demultiplexer)

2. To change an automatically-discovered topology to align with the actual physical

topology, such as changing the discovered Ethernet topology to show connectivity to

transport or optical equipment

3. To include topology to external equipment

The ability to configure Remote IDs is supported in PSM for network elements running

the following releases:

• BTI7000 Series release 9.2.0 or higher

• BTI800 Series release 1.1 or higher

The Remote ID is a string that references the remote end of the connection (fiber). The

string is not used by the NE itself, but is read and correlated by PSM to determine the

connection endpoints. For this reason, the accuracywithwhichPSMderives the topology
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is dependent on proper configuration of this field. If improperly configured, the topology

shown by PSMmight not reflect the actual topology.

The NE treats the configuration of the Remote ID as an opaque string and does not

otherwise perform any syntactical or semantic checking on the configured value. All

syntactical and semantic checking is performed by PSM.

Remote ID configuration can be bookended or singled-ended:

• Bookended: the Remote ID is configured at both ends of the connection (to point to

each other). This ismandatorywhenboth endpoints support Remote ID configuration.

PSM validates the Remote ID configuration and raises an alarm if the validation fails.

See “Detecting Remote ID Errors” on page 85 for more information.

• Single-ended: the remote ID is configured at only one end of the connection (to point

to the other end). This is the only possible method when only one endpoint supports

Remote ID configuration. In this situation, PSM uses the Remote ID configured at one

end to derive the topology. PSM does not require information from the other endpoint

except to perform limited validation in specific situations. See “Detecting Remote ID

Errors” on page 85 for more information.

Because the Remote ID is used to specify the physical fiber connectivity, you should

typically configure the Remote IDs when the actual fibers are installed. Not only will this

allowPSMtodisplay the topologycorrectly, but itwill alsoallowyou toactivate supported

services with endpoints referenced by the Remote IDs.

The following table shows where the Remote ID can be configured and what endpoint

it can reference.

Remote ID can reference:Remote ID can be configured on:

BTI7000 Series muxponder, transponder, DOL, and packetVX
ports, and BTI700 Series, BTI800 Series, BTI7800 Series, and
supported interfaces onMXSeries andPTXSeries routers and
QFX Series switches, and external device ports

For the list of supported interfaceson JuniperNetworks routers
and switches, see “Nodal Management for Juniper Networks
Routers and Switches” on page 257.

For information on connecting to an external device port, see
“Viewing External Devices” on page 85.

BTI7000 Series muxponder, transponder, DOL, and packetVX
ports, and BTI800 Series ports

For DOL ports, the Remote ID can be configured as follows:

• You can configure the Remote ID on a BTI7000 Series DOL
multiplexer/demultiplexer channel port or on a BTI7000
Series DOL ROADMmodule Alien/C2 port to point to
attached equipment (for example, PVXorMXSeries or PTX
Series or QFX Series port). This configures the connectivity
from the attached equipment to the DOL network.

• Addtionally, you can configure the Remote ID on the
BTI7000SeriesDOLROADMmoduleAlien/C2port to show
a split ROADM node. In this situation, you cannot use the
ROADMmodule C2 port as an optical service endpoint. See
“Configuring a Split ROADMNode” on page 176.

Remote ID Format

PSM provides great flexibility on how you build your topology with Remote IDs. As long

as the Remote ID configuration conforms to the required syntax, and as long as the

Remote IDs at each end refer to each other (for bookended configurations), PSMwill

75Copyright © 2019, Juniper Networks, Inc.

Chapter 5: Managing Network Topology



display the connection. Therefore, youmust provision the Remote ID with great care or

the topology might not turn out as you intend.

The general format of the Remote ID is as follows:

<IP Address>-<Circuit Pack Type>-<Shelf>-<Slot>-<Port>

where the <IP Address> is the remote IP address of the connection in dotted decimal

notation, the <Circuit PackType> is the type of card at the remote location, and <Shelf>

, <Slot> , and <Port> represent the shelf, slot, and port identifiers of the remote end.

The following table shows how the Remote ID is constructed for the different types of

endpoints. All characters in the syntax are case-insensitive.

NOTE: This table lists the values that PSM considers to be valid (for the
purposeofdeterminingwhetherornot to raisean"InvalidRemote ID"alarm).
PSM does not check the specified Remote ID against the actual NE being
referenced for this alarm. Not all values that PSM considers to be valid are
applicable for certain circuit pack types. See “Detecting Remote ID Errors”
onpage85 formore information onhowPSMdetermineswhat is considered
valid.

ExampleShelf-Slot-Port
Circuit Pack
TypeRemote IP

Remote
Endpoint

10.1.121.24-MXP-11-3-L2

10.1.121.24-MXP-11-3-C2

<shelf>-<slot>-L<n>

<shelf>-<slot>-C<n>

MXPIP address in dotted
decimal notation

NOTE: The remote NE
must be a discovered
network element.

BTI7000Series
muxponder

10.1.121.24-TPR-1-3-3<shelf>-<slot>-<port>TPR, WM,WR,
WT

IP address in dotted
decimal notation

NOTE: The remote NE
must be a discovered
network element.

BTI7000Series
transponder

10.1.121.24-PVX-21-3-X2

10.1.121.24-PVX-21-3-G7

<shelf>-<slot>-X<n>

<shelf>-<slot>-G<n>

PVXIP address in dotted
decimal notation

NOTE: The remote NE
must be a discovered
network element.

BTI7000Series
packetVX
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ExampleShelf-Slot-Port
Circuit Pack
TypeRemote IP

Remote
Endpoint

10.1.121.24-D40MD-0-1-CH280<shelf>-<slot>-CH<n>D32MD1 to
D32MD4

D40MD

D96MD

IP address in dotted
decimal notation

NOTE: The remote NE
must be a discovered
network element.

BTI7000Series
multiplexer/
demultiplexer

10.1.121.24-ROB-1-3-C2

For information on where to use this, see
“Configuring a Split ROADMNode” on
page 176.

<shelf>-<slot>-C2ROBIP address in dotted
decimal notation

NOTE: The remote NE
must be a discovered
network element.

BTI7000Series
ROADM

10.228.220.71-OTU4-1-5-1-1

10.228.220.71-OCH-1-14-2-1-2.1

<shelf>-<slot>-<BIC>-<port>

<shelf>-<slot>-<Port
Group>-<Xcvr
Port>-<Fiber
Port>.<OCH>

OTU4

OCH

IP address in dotted
decimal notation

NOTE: The remote NE
must be a discovered
network element.

BTI7800Series
UFM

10.1.111.4-BTI800-1-2-G3<shelf>-<slot>-G<n>BTI800IP address in dotted
decimal notation

NOTE: The remote NE
must be a discovered
network element.

BTI800 Series

10.1.111.5-JUNOS-1-0-0<FPC>-<PIC/MIC>-<port>JUNOSIP address in dotted
decimal notation

NOTE: The remote NE
must be a discovered
network element.

MX Series or
PTX Series or
QFX Series

10.1.121.24-BTI700-1-1-6-X

A BTI700 Series NE is treated like an
external device and requires a trailing -X
or -x in the Remote ID. See “Viewing
External Devices” on page 85 for more
details on external devices.

not validatedBTI700IP address in dotted
decimal notation

BTI700 Series

10.1.121.24-EXT-2-3-6-X

An external device requires a trailing -X or
-x in theRemote ID. See “ViewingExternal
Devices” on page 85 for more details on
external devices.

not validatedEXTIP address in dotted
decimal notation

External
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Remote ID Configuration

PSM provides a GUI-driven method to configure the Remote ID. The benefit of this

approach is that you do not need to know the remote ID syntax in order to construct the

remote ID. Figure 16 on page 78 shows the Remote ID configuration dialog:

Figure 16: Provision Remote Port ID

NOTE: The Remote ID configuration attributesmight change depending on
the CP Type that you select.

Themeanings of the attributes are as follows:

• Local Port ID This displays the local port identifier. This attribute cannot be changed.

• Remote Id This is the Remote ID that is currently set. This field cannot be changed

directly. It is changed by editing the individual components of the Remote ID through

the various drop-downmenus.

• Hostname/IP Address Set the hostname or IP address of the remote endpoint. For

convenience, completion suggestions are provided based on the discovered network

elements.

• CPTypeSet thecircuitpack type(orBTI7800UFM interfacename) fromthedrop-down

menu.

NOTE: Only the circuit pack types described in “Remote ID Format” on
page 75 are supported.
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• Shelf, Slot, Port Set the shelf, slot, and port indexes respectively.

• BIC Set the BIC (subslot) if referencing an OTU4 interface on a BTI7800UFM.

• Fiber Port,OCH Set the Fiber Port (subport) and OCH (channel) if referencing an OCH

interface on a BTI7800UFM.

• Alien This specifies whether the remote ID refers to an external device. This is usually

used when configuring a Remote ID to point to a BTI700 Series or third-party device.

Selecting this attribute causes an -X to be appended to the end of the Remote ID.

• BidirectionalThis option allows you to specifywhether youwant PSM to automatically

set the remote ID on the remote port to point back to this local port. This attribute

should only be selected if the circuit pack type is one ofMXP, TPR,WR,WM,WT, PVX,

ROB, BTI800. You cannot select both Alien and Bidirectional at the same time.

Thisdialogcanbe reached through theNetwork tree (“Setting theRemote ID”onpage79,

“Setting theRemote IDonaMultiplexer/Demultiplexer” onpage80, “Setting theRemote

ID on a ROADMC2 Port” on page 82) or through the NE Shelf view (“Setting the Remote

ID from the Shelf View” on page 129).

If you are familiar with the Remote ID syntax, you can set the Remote ID in a freeform

mannerwithin certainnodalprovisioningwindows forBTI7000Seriesports. This is shown

in various places in “Nodal Management for BTI7000 Series Network Elements” on

page 134.

Setting the Remote ID

Use this procedure to set the Remote ID on the following ports from the Network tree:

• a BTI7000 Series transponder, muxponder, or packetVX port

• a BTI800 Series port

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand amodule to show the ports in that module.

4. Right-click a provisioned port and select Remote ID >Provision.

The Provision Remote Port ID dialog appears.

5. Configure the Remote ID as described in “Remote ID Configuration” on page 78.

6. ClickOK.

NOTE: If you selectBidirectional and you specify a Remote ID that cannot

be reconciled, PSMwill be unable to configure the remote endpoint, and
the task will fail.
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NOTE: The taskmight fail if you try to use this procedure on a card that
has not been provisioned.

Setting the Remote ID on aMultiplexer/Demultiplexer

Use this procedure to set the Remote ID on a BTI7000 Series multiplexer/demultiplexer

port from the Network tree.

1. Expand the network element in the Network tree to show the equipment in that NE.

2. Expand the Optical Groups branch to see the configured optical groups.

3. Expand an optical group to show the degrees in that optical group.

4. Expand a degree to show themultiplexer/demultiplexer for that degree.

5. Expand themultiplexer/demultiplexer to show the ports/channels on that

multiplexer/demultiplexer.

Each port on themultiplexer/demultiplexer is named by its frequency. For example,

channel 235 on themultiplexer/demultiplexer represents the port with frequency

192.35 THz (1558.58 nm).
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6. Right-click a port/channel and select Remote ID >Provision.

The Provision Remote Port ID dialog appears.

7. Configure the Remote ID as described in “Remote ID Configuration” on page 78.

8. ClickOK.

NOTE: If you selectBidirectional and you specify a Remote ID that cannot

be reconciled, PSMwill be unable to configure the remote endpoint, and
the task will fail.

NOTE: The taskmight fail if you try to use this procedure on a card that
has not been provisioned.
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Setting the Remote ID on a ROADMC2 Port

Use this procedure to set the Remote ID on a BTI7000 Series ROADM C2 port from the

Network tree. This procedure can be used to create a split ROADM node. For more

information, see “Configuring a Split ROADMNode” on page 176.

1. Expand the network element in the Network tree.

2. Expand the Optical Groups branch to see the configured optical groups.

3. Expand an optical group to see the degrees in that group.

4. Expand a degree to see the ROADMmodule in that degree.

5. Expand the ROADMmodule to see the ports in that module.

6. Right-click the Client: 2 port and select Remote ID >Provision.

Figure 17: Selecting the C2 Port

The Provision Remote Port ID dialog appears.

7. Configure the Remote ID as described in “Remote ID Configuration” on page 78.

8. ClickOK.

NOTE: If you selectBidirectional and you specify a Remote ID that cannot

be reconciled, PSMwill be unable to configure the remote endpoint, and
the task will fail.

NOTE: The taskmight fail if you try to use this procedure on a card that
has not been provisioned.
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Deleting the Remote ID

Use this procedure to delete the Remote ID from an existing port on a BTI7000 Series or

BTI800 Series network element.

There are different ways by which you can delete the Remote ID. You can delete the

Remote ID from the Network tree or from the NE shelf view or from nodal provisioning

windows. This procedure describes how to delete the Remote ID from the Network tree.

For information on deleting the Remote ID from the shelf view, see “Deleting the Remote

ID from the Shelf View” on page 130. The Remote ID can also be deleted in a freeform

manner within certain nodal provisioning windows. This is shown in various places in

“Nodal Management for BTI7000 Series Network Elements” on page 134.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand amodule to show the ports in that module.

4. Right click a provisioned port and select Remote ID >Delete.

The Delete Remote Port ID dialog appears.

5. To delete the remote ID at both endpoints, select bidirectional deletion.

6. ClickOK.

Interactions with LLDP

PSM can display Ethernet connections using either LLDP or Remote ID. This section only

applies to those BTI Series network elements that support LLDP and Remote IDs. See

“DerivingEthernetTopologyUsingLLDPData”onpage74 for the list of supportednetwork

elements.
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In general, LLDP provides amore accurate representation of the Ethernet topology

because LLDP-derived topology is learned rather thanmanually provisioned. However,

since LLDP provides the Ethernet topology rather than the physical topology, you can

use remote IDs to change the topology view to reflect the physical topology if desired.

When LLDP is enabled and the Remote ID is configured, the following rules apply:

NOTE: An incorrect Remote ID in the table refers to either a
syntactically-invalid Remote ID or a Remote ID that leads to a Remote ID
mismatch condition.

Table 12: When LLDP is Enabled and Remote ID is Configured

Explanation
Topology
ShownConfiguration Scenario

This situationoccurswhenyouwant to representadirect connection
(fiber) between two Ethernet devices. In such a case, LLDP should
have provided the correct information, and therefore PSM assumes
the LLDP topology is correct. If the Remote ID topology differs from
the LLDP topology, PSM raises an "NE Link Mismatch" alarm.

LLDPThe Remote IDs at both ends correctly
point to a BTI7000 Series packetVX,
BTI700Seriesdevice, oraBTI800Series
device.

This situation occurs when you want to change the LLDP view to
align with the physical topology. This is the primary use case for
configuring remote IDs when LLDP is enabled.1

NOTE: 1Be aware that youmight run into situations where PSM
displays a broken path due to incorrect Remote ID configuration on
thesecondor subsequenthops, up toand including thepenultimate
hop.

Remote IDThe Remote IDs at both ends correctly
point to amuxponder, a transponder, a
multiplexer/demultiplexer, or anexternal
device (that is, MXP, TPR, WM,WR,WT,
D32MD1, D32MD2, D32MD3, D32MD4,
D40MD, D96MD, EXT).

PSM cannot determine which is the actual physical topology, so it
displays both as best as it can.

LLDP and
Remote ID

The Remote ID at one end correctly
points to amuxponder, a transponder, a
multiplexer/demultiplexer, or anexternal
device (that is, MXP, TPR, WM,WR,WT,
D32MD1, D32MD2, D32MD3, D32MD4,
D40MD, D96MD, EXT) but the Remote
ID at the other end does not, either
because it is incorrect, or because it
points correctly to a packetVX, BTI700
Series device, or a BTI800Series device.

PSMassumes theLLDP topology is thephysical topology, and raises
an "NE Link Mismatch" alarm.

LLDPThe Remote ID at one end correctly
points to a packetVX, BTI700 Series
device, or a BTI800 Series device, but
the Remote ID at the other end is
incorrect.

PSMcannot resolve theRemote IDs,andassumestheLLDPtopology
is the physical topology.

LLDPThe Remote IDs at both ends are
incorrect.
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Viewing External Devices

PSM provides the capability to display external devices in the topologyMap view if the

external device is connected to a network element that supports remote IDs. An external

device is any device that is unmanaged by PSM.

PSM displays an external device whenever an EXT-formatted Remote ID has been

provisioned on a discovered network element. A Remote ID in the form <IP

Address>-EXT-<Shelf>-<Slot>-<Port>-<X|x> denotes an external device at the remote

end of the connection. The trailing X is case-insensitive.

When PSM encounters an EXT-formatted Remote ID (for example,

10.1.121.24-EXT-1-3-2-x), it creates an icon for the specified IP address if one does not

already exist, and draws a link from the network element in which this Remote ID has

been provisioned to the external device.

NOTE: PSM has no way of verifying if the Remote ID is properly referencing
the external device.

The external device is displayed as an undiscovered network element. Youmanipulate

the external device in the same way youmanipulate an undiscovered network element,

such as editing notes or adding or removing the device from groups.

You can delete an external device as you delete an undiscovered network element, but

theexternal devicewill reappearwhenPSMperformsa topology refreshand reprocesses

all the configured Remote IDs. To delete an external device permanently, youmust first

delete it from the Remote ID on all network elements that reference this external device.

You can then proceed to delete the external device by right-clicking the device and

selecting delete.

Detecting Remote ID Errors

PSM performs validation of the Remote ID during topology discovery.

The following errors are detected:

• PSM raises an "Invalid Remote ID" alarm upon detection of malformed fields. The

alarm is raised against the port where the invalid Remote ID was found. Specifically,

PSM performs the following (case-insensitive) syntax checks:

• ensures the IP address is of the form <0-255>.<0-255>.<0-255>.<0-255>

• ensures the circuit pack type is <MXP | TPR |WR |WM |WT | D32MD1 | D32MD2 |

D32MD3 | D32MD4 | D40MD | D96MD | PVX | BTI800 | JUNOS | BTI700 | EXT>

• ensures thatbothBTI700andEXTcircuitpack typescontaina trailingcase-insensitive

-x

• ensures the shelf index is <0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 11 | 21 | 31> for all devices other than

for BTI700 and EXT devices

• ensures theslot index is<0-20> forall devicesother than forBTI700andEXTdevices
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This alarm does not identify contextual errors, such as a Remote ID referring to an

impossible port identifier for that circuit pack type (for example, port 24 on a device

with only two ports).

• PSM raises a "Remote ID Mismatch" alarm as follows:

• Bookended: PSM correlates both ends of the connection and raises this alarm if the

Remote IDs at the two ends are not referring to each other. This alarm implicitly

identifies contextual errors such as when a Remote ID refers to an impossible port.

• Single-ended: In the specific situation where the Remote ID is configured on a

BTI7000 Series DOLmultiplexer/demultiplexer channel port and points to a

supportedUFM interfaceonadiscoveredBTI7800or points to a supported interface

on a discovered MX Series or PTX Series router or QFX Series switch, PSM checks

the wavelength at the remote endpoint as follows:

If the supported interface is on a tunable transceiver, PSM validates the wavelength

configured on the interface with the wavelength associated with the

multiplexer/demultiplexer port. If the wavelengths do not match, PSM raises an

alarm and does not display the link in the topology view.

In all other cases, including configurations where the supported interface is on a

fixed-wavelength transceiver or where the Remote ID is configured on a port that is

not a BTI7000 Series DOLmultiplexer/demultiplexer channel port, PSM does not

validate the wavelength at the remote endpoint.

NOTE: Forbookendedconfigurations,PSMcannotdetectconfigurationerrors
where the Remote IDs are properly formed and referencing each other, but
where no connection is actually provisioned between the stated endpoints.

NOTE: For single-ended configurations, PSM cannot detect configuration
errors where the same Remote ID is configured onmore than one port (in
other words, wheremultiple ports point to the same remote port).

Network Element Groups and Sites

A large network might consist of hundreds of network elements. Working with these

network elements in a single flat topologyMapmight be impractical. To reduce clutter

in theMap view, the proNX Service Manager allows you to arrange network elements

into hierarchical groups. A group is represented by a single icon.

Network elements not belonging to any user-created group are placed in a default top

level group. This top level container group is represented by the Elements entry in the

Network tree view. All network elements contained at this level in the hierarchy are

displayed in the top levelMap view. You can assign network elements to groups during

discovery, or you canmove network elements to groups that you have created at a later

stage.
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PSM stores group associations in its database. This allows group associations to persist

across PSM software upgrades.

Groups are hierarchical. For example, you can create a group calledWALL_ST that is

inside a group called LOWER_MANHATTAN that in turn is inside a group called

MANHATTAN.

The lowest formofagroup is calledasite.A site is intended to representnetworkelements

at the same location. For example, you can create a site calledNYSE inside theWALL_ST

group. A site can be inside a group but a site cannot be nested in another site. Groups

and sites share the same namespace.

The namespace for a group or a site is local to its location in the Network tree. In other

words, you can createmultipleWALL_ST groups in different parts of the tree, but at each

location in the tree, you can only have one group or site calledWALL_ST.

NOTE: Network element groups and sites are part of the replicated data set
when runningwithmultiple servers. Formore information on replicateddata,
see “Running Multiple Servers with Server Replication” on page 30.

• Creating a New Group on page 87

• Moving Network Elements, Groups, And/or Sites to a Different Group on page 88

• Adding Network Elements to a New Group or Site on page 88

• Adding Groups And/or Sites to a New Group on page 89

• Navigating Between Parent and Child Groups on page 89

Creating a NewGroup

Use this procedure to create a new group.

1. In the Elements branch in theNetwork tree view, perform one of the following actions:

• Right click the Elements entry and select Create Group to create a new group at the

top level of the tree.

• Right click an existing group and select Create Group to create a new group nested

inside that existing group.

You can also create a new group by right clicking an existing group in the topology

Map view and selecting Create Group.

2. A pop-up dialog appears in which you can enter a name for the new group.
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Enter a name and selectOK. The namemust be unique for all groups and sites at that

location in the tree.

NOTE: Network element groups and sites are part of the replicated data
set when running withmultiple servers.

Moving Network Elements, Groups, And/or Sites to a Different Group

Use this procedure to move network elements, groups, and/or sites to a different group.

1. Select the network elements, groups, and/or sites in the Elements branch of the

Network tree view.

2. Click and drag the selections to the desired group as shown below.

NOTE: If you no longer want a network element to be part of any
user-defined group, move it back to the top level Elements group.

NOTE: Network element groups and sites are part of the replicated data
set when running withmultiple servers. If a server in the cluster has not
discovered the network elements beingmoved, that server will show the
destination group with these network elements undiscovered.

Adding Network Elements to a NewGroup or Site

Use this procedure to add network elements to a new group or to a new site.

This procedure creates a group or a site, and populates it with network elements in one

step. You cannot use this procedure to add network elements to an existing group or site.
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1. Select one or more network elements from the same level in the topologyMap view

or in the Elements branch of the Network tree view. Right click and choose Add to...

>Group or Add to... >Site as desired.

2. A pop-up dialog appears in which you can enter a name for the group or site. Enter

the name and clickOK. The namemust be unique for all groups and sites at that

location in the tree.

The new group or site is created at that location and the selected network elements

are moved into it.

NOTE: Network element groups and sites are part of the replicated data
set when running withmultiple servers. If a server in the cluster has not
discovered the network elements being added, that server will show the
new group or site with these network elements undiscovered.

Adding Groups And/or Sites to a NewGroup

Use this procedure to add groups and/or sites to a new group.

This procedure creates a group and populates it with other groups and/or sites in one

step. You cannot use this procedure to add groups and/or sites to an existing group.

1. Select one or more groups and/or sites from the same level in the topologyMap view

or in the Elements branch of theNetwork tree view. Right click and chooseAdd toNew

Group.

2. Apop-up dialog appears inwhich you can enter a name for the group. Enter the name

and clickOK. The namemust be unique for all groups and sites at that location in the

tree.

The new group is created at that location and the selected groups and/or sites are

moved into it.

NOTE: Network element groups and sites are part of the replicated data
set when running withmultiple servers.

Navigating Between Parent and Child Groups

Use this procedure to navigate between a child view of network elements inside a group

and a parent view of the group itself.

1. To view the contents of a group in the topologyMap view, select the group in the

Elements branch of the Network tree view or double-click the group in the topology

Map view.

89Copyright © 2019, Juniper Networks, Inc.

Chapter 5: Managing Network Topology



Figure 18: Map ViewOf Group Contents

NOTE: Network element groups are part of the replicated data set when
running withmultiple servers. Youmight see undiscovered network
elements in this view if this group was created on another server and if
your server has not been configured to discover the network elements in
that group.

2. To go back to the parent, right-click in the background of the child and select Show

Parent.
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Figure 19: Map ViewOf Parent

Changing the Background View

Use this procedure to change the background view in the topology window.

NOTE: The background view is part of the replicated data set when running
withmultiple servers. Formore information on replicated data, see “Running
Multiple Servers with Server Replication” on page 30.

1. Tochangemapviewelements, right-clickanywhereon thebackgroundmap todisplay

the menu as shown.
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2. To change the default backgroundmap:

a. Create a .gif, .jpg or .png image that you want as your background.

b. ClickChangeBackground in themenu shown above and navigate to the image you

want as your background.

c. ClickOpen. The new background image displays in the map view. The tool

automatically saves thenew image file in thebackgrounds folder in yourPSMClient

installation directory chain.

3. Changing the default backgroundmapmight also require changing the default text

color of the elements. To change the color of the text under each element in themap

view:
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a. ClickChangeLabelColor. The "SelectNewLabelColor"windowappears as shown.

b. Choose a color category using the tabs Swatches, HSB or RGB.

c. Clicka text color andclickOK. The textundereachelement in themapviewchanges

to the selected color.

d. To revert to the default text color, click Reset.

93Copyright © 2019, Juniper Networks, Inc.

Chapter 5: Managing Network Topology



Copyright © 2019, Juniper Networks, Inc.94

proNX Service Manager User Guide



CHAPTER 6

Working with Network Elements

• Editing Notes for a Network Element on page 95

• Identifying Services Associated with a Network Element on page 96

• Viewing Network Element Inventory Information on page 97

• Searching for a Network Element on page 99

• Managing Information for a Network Element on page 100

• Enabling or Disabling Network Element Maintenance Modes on page 111

• Marking or Unmarking a Network Element on page 112

• Enabling or Disabling Provisioning Mode on a Network Element on page 113

• Connecting to the CLI on a Network Element on page 114

• Provisioning OSPF on a BTI7000 Series Management Network on page 114

• Configuring In-Band Management on a BTI7800 Network Element on page 122

Editing Notes for a Network Element

Use this procedure to add, delete, or modify notes on a discovered or undiscovered

network element.

Notes are informational text that can be used to describe a network element.
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1. To access the Notes window for an NE, right-click the NE in the Network tree or in the

Topology Map view and choose Node >Notes >Edit.

The Notes window is displayed.

2. As desired, enter values for the existing note types (Longitude, Latitude, Postal Code)

by clicking in the Note field and typing your data.

3. To add a new note, right-click the window and choose New.

A new row named NewMeta Key is displayed. Click inside the NewMeta Key box and

enter a name for the new note. In the Note column, enter the applicable information.

The new note is stored on the server.

4. To delete a note, right-click the note and choose Delete.

Identifying Services Associatedwith a Network Element

Use this procedure todetermine the services that are associatedwith anetwork element.

proNX Service Manager allows the user to identify which services are associated with a

network element, and copy the names of the services to a clipboard on their local drive.

This feature is useful when alarms are raised against an NE and you want to identify

which services are affected. It is also useful when performing maintenance on an NE to

knowwhich services the NE is part of to prevent a disruption of service.

1. To identify the services that an NE is part of, right-click the NE in the Network tree or

in the Topology Map view, and choose Select Services.

The services that the NE is a member of are highlighted in the Services section of the

Network tree view as shown in the following image. The first service highlighted in the

tree view is also displayed in the Topology view.
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2. To copy the names of the services associated with an NE to a clipboard on your local

drive, right-click one of the highlighted services in the Network tree view and choose

Copy Name.

3. Open the notepad or clipboard application on your local drive, and select paste.

Viewing Network Element Inventory Information

Use this procedure to display inventory information for the managed network.

1. To view inventory information for the devices in your network, from themain menu

choose View>Network->Inventory.
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Figure 20: Network Inventory

Figure 21: Network Inventory for PSM Server

2. To select what inventory information to show, right-click the title bar and select or

clear the headings to obtain the view that you desire.
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Searching for a Network Element

Use this procedure to search for a network element.
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1. Type a search string in the Search field in the toolbar. The results are displayed as you

type.

You can search based on NE name, IP address, group, site, or service type. You can

also search for unreachable network elements by typing in unreachable in the text

box.

Figure 22: Searching for an IP Address

Figure 23: Selecting the Search Category

Figure 24: Searching for a Service Type

The search results are highlighted in the Network tree and Topology Map view.

Managing Information for a Network Element

Use thisprocedure to vieworupdate system-related information for an individual network

element.

1. Right-click a network element in the Network tree or in the Topology Map view, and

then select System Info.

The System Info tab appears.
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2. Click one of the following tabs to view or change information for the selected topic.

• System

• Management

• SNMP

• Time/Date/NTP

• Craft Eth/Serial

NOTE: Dependingonthenetworkelement type, somefieldscanbeedited,
some cannot be edited, and some do not apply to that type. The
information that cannot be edited, or that is not applicable, is greyed out.
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Table 13: System Info Tab for BTI7000 Series NE

ParametersDescriptionPanel Name

• SystemSettings

• Name

• Location

• Uptime - not editable

• Vendor - not editable

• Model - not editable

• Active SWVersion - not editable

• Inactive SWVersion - not editable

• Serial Number - not editable

• Element Number

• Site Number

• Contact

• SystemWide Settings

• Auto-Provisioning Mode - this is the AINSmode

• Auto-In Service Timer

• Auto Deprovisioning Timer - not applicable for NEs
running release 8.2 and higher

• Filler Plate Detection

• Customer Logging Facility ID

Providesaccess togeneral information.System

Copyright © 2019, Juniper Networks, Inc.102

proNX Service Manager User Guide



Table 13: System Info Tab for BTI7000 Series NE (continued)

ParametersDescriptionPanel Name

• Management Settings

• Outband IP Address

• Outband IP Mask

• System Gateway

• Mac Address - not editable

• OSC Settings

• Enable OSC 1 Port

• Enable OSC 2 Port

• Secondary Gateway

• OSPFManagement: OSPF

• Router ID

• Route Redistribution

• Area ID

• State

• Delete OSPF

• Add OSPF

• OSPFManagement: OSPF Interfaces

• This is the list of OSPF interfaces configured on the
network element.

• Add, edit, or delete interfaces as desired.

• OSPFManagement: LSDB

• This is the link state database. It is read-only.

• OSPFManagement: Neighbors

• This is the list of OSPF neighbors. It is read-only.

NOTE: For more information on provisioning OSPF, see
“Provisioning OSPF on a BTI7000 Series Management
Network” on page 114

Provides access to management
information.

NOTE: WhenManagement information
for an NE is modified, the NE is deleted
from PSM and rediscovered using the
updated settings.

Management

• Communities

• Private - not editable

• Public - not editable

• Trap Receivers

• Trap Receivers - not editable

• IP Address - not editable

• Community - not editable

• Version - not editable

• Port - not editable

• Notification - not editable

Provides access to read-only
community and trap receiver
information.

SNMP
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Table 13: System Info Tab for BTI7000 Series NE (continued)

ParametersDescriptionPanel Name

• Time and Date Settings

• Adjust time for daylight savings changes

• Time

• Time Zone

• Date

• NTP Settings

• Poll Period

• Authorization Key (0 to 65535)

• Sync State - not editable

• Stratum - not editable

• Reference IP - not editable

• NTP Associations (NTP Client IP addresses)

Provides access to time, date, andNTP
(Network Timing Protocol) settings.

Time/Date/NTP

• Craft Serial Settings

• Baud Rate

• Data Bits

• Parity

• Stop Bits

• Craft Ethernet Settings

• Craft IP Address

• Craft Mask

• Media Rate - not editable

• Custom

• Craft MAC Address - not editable

• Broadcast Address - not editable

• Interface Speed - not editable

• MTU Size - not editable

Provides access to Craft Ethernet and
Craft Serial information.

Craft Eth/Serial
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Table 14: System Info Tab for BTI7800 Series NE

ParametersDescriptionPanel Name

• SystemSettings

• Name

• Location

• Uptime - not editable

• Vendor - not editable

• Model - not editable

• Active SWVersion - not editable

• Inactive SWVersion - not applicable

• Serial Number - not applicable

• Element Number - not applicable

• Site Number - not applicable

• Contact

• SystemWide Settings

• Auto-Provisioning Mode - this is the AINSmode

• Auto-In Service Timer

• Auto Deprovisioning Timer - not applicable

• Filler Plate Detection - not applicable

• Customer Logging Facility ID

Providesaccess togeneral information.System

• Management Settings

The followingare theout-of-bandmanagement settings:

• Outband IP Address - not editable

• Outband IP Mask - not editable

• System Gateway - not editable

• Mac Address - not applicable

• In-bandManagement Settings

This panel displays the in-bandmanagement interfaces.

• Add or delete interfaces as desired.

• Proxy ARP

• IS-IS and NET

NOTE: For more information on provisioning in-band
management, see “Configuring In-BandManagement on
a BTI7800 Network Element” on page 122

Provides access to management
information.

NOTE: WhenManagement information
for an NE is modified, the NE is deleted
from PSM and rediscovered using the
updated settings.

Management

• Communities

• Private - not editable

• Public - not editable

• Trap Receivers

• Trap Receivers - not editable

• IP Address - not editable

• Community - not editable

• Version - not editable

• Port - not editable

• Notification - not editable

Provides access to read-only
community and trap receiver
information.

SNMP
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Table 14: System Info Tab for BTI7800 Series NE (continued)

ParametersDescriptionPanel Name

• Time and Date Settings

• Adjust time for daylight savings changes - not editable

• Time - not editable

• Time Zone - not editable

• Date - not editable

• NTP Settings

• NTP Status - not editable

• NTP Servers - not editable

Provides access to time, date, andNTP
(Network Timing Protocol) settings.

Time/Date/NTP

Table 15: System Info Tab for BTI800 Series NE

ParametersDescriptionPanel Name

• SystemSettings

• Name

• Location

• Uptime - not editable

• Vendor - not editable

• Model - not editable

• Active SWVersion - not editable

• Inactive SWVersion - not applicable

• Serial Number - not applicable

• Element Number - not applicable

• Site Number - not applicable

• Contact

• SystemWide Settings - not applicable

Providesaccess togeneral information.System

• Management Settings

• Outband IP Address - not editable

• Outband IP Mask - not editable

• System Gateway - not editable

• Mac Address - not editable

• In-band Settings

• IP Address - not editable

• IP Mask - not editable

• Outer VLAN Name - not editable

• Inner VLAN Name - not editable

• Network Address - not editable

• Mac Address - not editable

• Outer VLAN Id (Priority) - not editable

• Inner VLAN Id (Priority) - not editable

Provides read-only access to
management information.

Management
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Table 15: System Info Tab for BTI800 Series NE (continued)

ParametersDescriptionPanel Name

• Communities

• Private - not editable

• Public - not editable

• Trap Receivers

• Trap Receivers - not editable

• IP Address - not editable

• Community - not editable

• Port - not editable

Provides access to read-only
community and trap receiver
information.

SNMP

• Time and Date Settings

• Time

• Time Zone

• Date

• NTP Settings

NOTE: Youmust disable NTP on the BTI810 prior to
making any changes.

NOTE: NTP is always enabled on the BTI805, BTI821,
and BTI822 devices.

• Poll Period - read-only for the BTI805, BTI821, and
BTI822.

• Status - read-only for theBTI805, BTI821, andBTI822.

• Preferred Server

• Server1 IP Address

• Server2 IP Address

• Server3 IP Address

Provides access to time and date
settings.

Time/Date/NTP

• Craft Serial Settings

• Baud Rate - not editable

• Data Bits - not editable

• Parity - not editable

• Stop Bits - not editable

Provides read-only access to Craft
Serial information.

Craft Eth/Serial
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Table 16: System Info Tab for MX Series and PTX Series Routers and QFX Series Switches

ParametersDescriptionPanel Name

• SystemSettings

• Name

• Location

• Uptime - not applicable

• Vendor - not applicable

• Model - not applicable

• Active SWVersion - not applicable

• Inactive SWVersion - not applicable

• Serial Number - not applicable

• Element Number - not applicable

• Site Number - not applicable

• Contact

Providesaccess togeneral information.System

Not supported.Management

Not supported.SNMP

Not supported.Time/Date/NTP

Not supported.Craft Eth/Serial

Table 17: System Info Tab for BTI700 Series NE

ParametersDescriptionPanel Name

• SystemSettings

• Name

• Location

• Uptime - not editable

• Vendor - not editable

• Model - not editable

• Active SWVersion - not editable

• Inactive SWVersion - not applicable

• Model - not editable

• Serial Number - not editable

• Element Number - not applicable

• Site Number - not applicable

• Contact

• SystemWide Settings - not applicable

Providesaccess togeneral information.System

• Management Settings

• Outband IP Address - not editable

• Outband IP Mask - not editable

• System Gateway - not editable

• Mac Address - not editable

Provides read-only access to
management information.

Management

Copyright © 2019, Juniper Networks, Inc.108

proNX Service Manager User Guide



Table 17: System Info Tab for BTI700 Series NE (continued)

ParametersDescriptionPanel Name

• Communities

• Private - not editable

• Public - not editable

• Trap Receivers

• Trap Receivers - not editable

• IP Address - not editable

• Community - not editable

• Version - not editable

• Port - not editable

• Notification - not applicable

Provides access to read-only
community and trap receiver
information.

SNMP

• Time and Date Settings

• Adjust time for daylight savings changes - not
applicable

• Time

• Time Offset - not editable

• Date

• NTP Settings (BTI700 Series except for BTI718E)

• NTP VLANs - with Mode set to Client
• Mode set to Client

• NTP Server IP

• Static IP Address in CIDR notation (e.g. 10.0.0.1/24)

• Time Flag

• Time Offset

• Non NTP VLANs - with Mode set to None
• Mode set to None

• NTP Server IP - not applicable

• Static IP Address in CIDR notation (e.g. 10.0.0.1/24)

• Time Flag - not applicable

• Time Offset - not applicable

• NTP Settings (BTI718E)

• Sntp Master - not editable

• Sntp Stratum - not editable

• Sntp Server Send Interval - enter the power (of 2)
seconds (e.g. enter 4 for 24 seconds)

• Sntp Client Send Interval - enter the power (of 2)
seconds

• Peer - can add or delete a peer; cannot edit an existing
peer

• PeerWork Mode - not editable

• Peer IP - specify for a new peer; not editable for an
existing peer

• Peer SNTP Version - not editable

• Peer ReceivedTime - not editable

Provides access to time, date, andNTP
(Network Timing Protocol) settings.

Time/Date/NTP
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Table 18: System Info Tab for OPS, EDFA, and RAMANDevices

ParametersDescriptionPanel Name

• SystemSettings

• Name

• Location

• Uptime - not editable

• Vendor - not editable

• Model - not editable

• Active SWVersion - not editable

• Inactive SWVersion - not applicable

• Model - not editable

• Serial Number - not editable

• Element Number - not applicable

• Site Number - not applicable

• Contact

• SystemWide Settings - not applicable

Providesaccess togeneral information.System

• Management Settings

• Outband IP Address - not editable

• Outband IP Mask - not editable

• System Gateway - not editable

• Mac Address - not editable

Provides read-only access to
management information.

Management

• Communities - not editable

• Trap Receivers - not editable

Provides read-only access to
community and trap receiver
information.

SNMP

• Time and Date Settings - not editableProvides read-only access to time and
date settings.

Time/Date/NTP

Table 19: System Info Tab for PSM Server

ParametersDescriptionPanel Name

• SystemSettings

• Name - not editable

• Location - not editable

• Uptime - not editable

• Vendor - not editable

• Model - not editable

• Active SWVersion - not editable

• Element Number - not editable

• Site Number - not editable

• Contact - not editable

Providesaccess togeneral information.System
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Table 19: System Info Tab for PSM Server (continued)

ParametersDescriptionPanel Name

• Management Settings

• Outband IP Address - not editable

• Outband IP Mask - not editable

• System Gateway - not editable

• Mac Address - not editable

Provides read-only access to IP
information.

Management

Not supported.SNMP

Not supported.Time/Date/NTP

Not supported.Craft Eth/Serial

3. Click Apply Changes to save the settings or Discard Edits to revert to the previous

settings.

Enabling or Disabling Network Element MaintenanceModes

Use this procedure to enable or disable maintenancemodes for a network element.

Network elements can be placed into one of three maintenancemodes:

• Maintenance -When a network element is placed into Maintenancemode, all

communications between PSM and the network element are disabled with the

exception of alarms, which continue to be processed.

• Out of Service -When a network element is placed in Out of Service mode, all

communications between PSM and the network element are disabled (including

alarms).

• Quiet -When a network element is placed into Quietmode, alarms are not processed.

NOTE: Thesemodes are internal to PSM, and govern how PSM responds to
and acts on network elementmessages. Thesemodes are not set on the
actual network elements themselves.

NOTE: Maintenancemodes are part of the replicated data set when running
withmultiple servers. Formore information on replicated data, see “Running
Multiple Servers with Server Replication” on page 30.

1. To place one or more network elements into amaintenancemode:
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a. Select the network element(s) in the Network tree or in the Topology Map view,

then right-click and chooseMode >MaintenanceMode,Mode >Out of Service, or

Mode >Quiet.

NOTE: Modes aremutually exclusive. Only onemode can be selected
at a time.

b. ClickOK in the ensuing dialog to confirm the action.

The NE(s) is placed in the specified mode and shown in a lighter shade.

2. To confirm that the NE(s) is in the desired mode, hover over the NE.

In the tooltip that appears, check the setting under Mode.

3. To disable a maintenancemode on one or more network elements:

a. Select the network element(s) in the Network tree or in the Topology Map view,

then right-click and selectMode >Disable MaintenanceMode,Mode >Disable Out

of Service, orMode >Disable Quiet, as applicable.

The NE(s) is shown back in its regular shade.

Marking or Unmarking a Network Element

Use this procedure to mark or unmark a network element. A marked network element

allows you to visually distinguish that network element from other network

elements, such as to highlight an important node or nodes in the network, or to flag a

node to other users in the system.

NOTE: Marking is implemented as amode, which is part of the replicated
data set when running withmultiple servers. For more information on
replicated data, see “Running Multiple Servers with Server Replication” on
page 30.

1. Tomark one or more network elements:

a. Select the network element(s) in the Network tree or in the Topology Map view,

then right-click and chooseMode >Marked.

NOTE: Modes aremutually exclusive. Only onemode can be selected
at a time.

b. ClickOK in the ensuing dialog to confirm the action.

Copyright © 2019, Juniper Networks, Inc.112

proNX Service Manager User Guide



The NE(s) is now shown with amark in the Topology Map view and in the Network

tree.

2. To remove amark on one or more network elements:

a. Select the network element(s) in the Network tree or in the Topology Map view,

then right-click and selectMode >Disable Marked.

The NE(s) is shown with the mark removed.

Enabling or Disabling ProvisioningMode on a Network Element

Use this procedure to enable or disable provisioning mode on a network element. If you

configure a network element while provisioning mode is enabled, you will be able to see

the new configuration data in PSM very quickly (without having to wait for the

asynchronous update from the NE). Note that youmight have to Refresh from Server to

update the client view if you do not want to wait for the client view to be updated

automatically.

In general, only one NE in the managed network should be in provisioning mode at any

given time.

NOTE: Provisioningmode is part of the replicated data set when running
withmultiple servers. Formore information on replicated data, see “Running
Multiple Servers with Server Replication” on page 30.

1. To enable provisioning mode on a network element:

a. Select the network element in the Network tree or in the Topology Map view, then

right-click and chooseMode >Provisioning >5Minutes, 10Minutes, or 15 Minutes.

NOTE: Provisioningmode settings aremutually exclusive. Only one
time period can be selected.

b. ClickOK in the ensuing dialog to confirm the action.

PSM enables provisioning mode for the selected NE for the specified time period.

2. To disable provisioning mode on a network element:

a. Select the network element in the Network tree or in the Topology Map view, then

right-click and selectMode >Provisioning >Disable 5Minutes, Disable 10Minutes,

or Disable 15Minutes, as applicable.

PSM disables provisioning mode for the selected NE.
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Connecting to the CLI on a Network Element

Use this procedure to connect to the CLI on a network element.

NOTE: Toconnect to theCLI, youmust first set up theappropriate command
and command parameters. See “Setting Utility Executables” on page 280.

1. Right-click a network element in the Network tree or in the topology Map view and

select Utilities >CLI.

The CLI is launched using the application specified in “Setting Utility Executables” on

page 280.

Provisioning OSPF on a BTI7000 Series Management Network

• Adding OSPF Management on page 114

• Editing OSPF Management Settings on page 115

• Deleting OSPF Management on page 116

• Adding an OSPFManagement Interface on page 117

• Editing an OSPFManagement Interface on page 119

• Deleting an OSPFManagement Interface on page 121

Adding OSPFManagement

Use thisprocedure toaddOSPFto themanagementnetworkofaBTI7000Seriesnetwork

element.

1. Right-click a network element in the Network tree or in the Topology Map view, and

then select System Info.

The System Infowindow appears.

2. Click theManagement tab to see themanagement parameters.

The Management panel appears.
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3. Select AddOSPF to add OSPF.

NOTE: If OSPF has previously been added, the AddOSPF button is not

available for selection.

4. Configure OSPF parameters as follows:

• Router ID: Specify the OSPF router identifier.

• Route Redistribution: Use the drop-downmenu to specify how routes are

redistributed.

• Area ID: Specify the OSPF area identifier.

• State: Set to Enabled or Disabled.

5. When you are finished, click Apply Changes.

Editing OSPFManagement Settings

Use this procedure to edit OSPFmanagement settings on a BTI7000 Series network

element.
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1. Right-click a network element in the Network tree or in the Topology Map view, and

then select System Info.

The System Infowindow appears.

2. Click theManagement tab to see themanagement parameters.

The Management panel appears.

3. Configure OSPF parameters as follows:

• Router ID: Specify the OSPF router identifier.

• Route Redistribution: Use the drop-downmenu to specify how routes are

redistributed.

• Area ID: The OSPF area identifier is read-only. It is set when you initially add OSPF

management.

• State: Set to Enabled or Disabled.

4. When you are finished, click Apply Changes.

Deleting OSPFManagement

Use this procedure to delete OSPF from themanagement network on a BTI7000 Series

network element.
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1. Right-click a network element in the Network tree or in the Topology Map view, and

then select System Info.

The System Infowindow appears.

2. Click theManagement tab to see themanagement parameters.

The Management panel appears.

3. Click Delete OSPF.

4. Click Yes in the confirmation dialog.

5. When you are finished, click Apply Changes.

Adding an OSPFManagement Interface

Use this procedure to add an OSPFmanagement interface to a BTI7000 Series network

element.

Prerequisites:
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• ThedesiredGCCandODCC interfaces are created. See “ProvisioningGCC” onpage 165

and “Editing OSC Parameters in an Optical Group” on page 177 respectively.

1. Right-click a network element in the Network tree or in the Topology Map view, and

then select System Info.

The System Infowindow appears.

2. Click theManagement tab to see themanagement parameters.

The Management panel appears.

3. Select theOSPF Interfaces tab.

A list of OSPF interfaces is shown.

4. Click Add to add a newOSPF interface.

The AddOSPF Interface dialog appears.
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5. Configure the OSPF interface parameters as follows:

• Source: Specify the interface from the drop-downmenu. Only interfaces that can

be configured for OSPF are shown.

• Hello Interval: Set the OSPF hello interval.

• Retransmit Interval: Specify the OSPF retransmit interval.

• Priority: Set the priority.

• Dead Interval: Set the dead interval.

• Transmit Delay: Set the transmit delay.

• State: Set to Enabled or Disabled.

6. When you are finished, click Apply Changes.

Editing an OSPFManagement Interface

Use this procedure to edit anOSPFmanagement interface on a BTI7000Series network

element.

1. Right-click a network element in the Network tree or in the Topology Map view, and

then select System Info.

The System Infowindow appears.

2. Click theManagement tab to see themanagement parameters.

The Management panel appears.
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3. Select theOSPF Interfaces tab.

A list of OSPF interfaces is shown.

4. Right-click an interface and select Edit.

The Edit OSPF Interface dialog appears.

5. Configure the OSPF interface parameters as follows:

• Source: This is the identifier of the interface being edited. It is read-only.

• Hello Interval: Set the OSPF hello interval.

• Retransmit Interval: Specify the OSPF retransmit interval.

• Priority: Set the priority.

• Dead Interval: Set the dead interval.
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• Transmit Delay: Set the transmit delay.

• State: Set to Enabled or Disabled.

ClickOK to close the Edit OSPF Interface dialog.

6. When you are finished, click Apply Changes.

Deleting an OSPFManagement Interface

Usethisprocedure todeleteanOSPFmanagement interfaceonaBTI7000Seriesnetwork

element.

1. Right-click a network element in the Network tree or in the Topology Map view, and

then select System Info.

The System Infowindow appears.

2. Click theManagement tab to see themanagement parameters.

The Management panel appears.

3. Select theOSPF Interfaces tab.

A list of OSPF interfaces is shown.

4. Select an interface and click Delete.
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5. Click Yes in the confirmation dialog.

6. When you are finished, click Apply Changes.

Configuring In-BandManagement on a BTI7800Network Element

Use this procedure to configure in-bandmanagement on a BTI7800 network element.

Prerequisites:

• Ensure there is at leastoneoptical interfaceconfigured.TheBTI7800supports in-band

management on its optical interfaces only.

1. Right-click a network element in the Network tree or in the Topology Map view, and

then select System Info.

The System Infowindow appears.

2. Click theManagement tab to see themanagement parameters.

The Management panel appears.

3. To add amanagement interface:
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a. Click Add to bring up the Add In-band Management Interface dialog.

b. Use the drop-downmenu to specify the Name of the management interface you

want to add.

c. Use the drop-downmenu to specify the actual Interface for this management

interface.

NOTE: TheBTI7800 supports in-bandmanagement connectivity over
the ODCC Channel only.

d. ClickOK.

The Add In-band Management Interface dialog closes and the new interface is

shown in the in-bandmanagement interface list.

Repeat this step as necessary to add additional management interfaces.

4. To delete amanagement interface:

a. Select an interface fromthe list of in-bandmanagement interfacesandclickDelete.

b. Click Yes in the confirmation dialog.
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The selected interface is removed from the in-bandmanagement interface list.

Repeat this step as necessary to delete additional management interfaces.

5. Select or clear Proxy ARP to enable or disable proxy ARP.

Proxy ARP allows the BTI7800 to respond to ARP requests on the external system

management interfaceonbehalfof same-subnetnetworkelements reachable through

in-band channels.

6. Select or clear IS-IS to enable or disable IS-IS routing on themanagement interfaces.

NOTE: IS-IS is supported on BTI7800 release 4.1 and higher.

7. If you enable IS-IS, then specify the network entity title (NET).

The network entity title consists of a 3-octet area address, a 6-octet system identifier,

and a 1-octet NSAP selector (which must be 00): aa.aaaa.ssss.ssss.ssss.00

• aa.aaaa - 6 hexadecimal digits for the area (consisting of a 2- digit format identifier

followed by a domain)

• ssss.ssss.ssss - 12hexadecimaldigits for the system identifier,whichmustbeunique

to the area

8. When you are finished, click Apply Changes.
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CHAPTER 7

Working with the Shelf View

• Introduction on page 125

• Displaying Network Elements in the Shelf View on page 125

• Displaying Alarms from the Shelf View on page 129

• Setting the Remote ID from the Shelf View on page 129

• Deleting the Remote ID from the Shelf View on page 130

Introduction

PSM can display a visual representation of a discovered network element, along with

visual indications of alarmed ports or components on that shelf. If the selected network

element is unreachable, PSM displays the last known state for that element.

PSM supports the Shelf view for the following:

• BTI7800 Series network elements

• BTI7000 Series network elements

• BTI800 Series network elements

• BTI700 Series network elements

• MX Series and PTX Series routers

• QFX Series switches

Displaying Network Elements in the Shelf View

Use this procedure to display the shelf view for a network element.

1. To display the shelf view of an NE, right-click the NE in either the Network tree or the

topology Map view and choose Node >View.

If one or more alarms exist on a component, the component is colored red (critical),

amber (major), or yellow (minor) to indicate the highest severity alarm on that

component.

The following figures show the shelf view for various network elements.
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Figure 25: Shelf View for a BTI7814 Network Element
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Figure 26: Shelf View for anMX240 Router

Figure 27: Shelf View for a BTI7200 Network Element

Figure 28: Shelf View for a BTI718E Network Element
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Figure 29: Shelf View for a BTI805 Network Element

Figure 30: Shelf View for a BTI810 Network Element

Figure 31: Shelf View for a BTI821 Network Element

Figure 32: Shelf View for a BTI822 Network Element

NOTE: YoucanalsouseQuickView tobring up theShelf view. First, select
the network element in the Network tree, and then depress <ctl> <alt> v.

The shelf view comes up in amodal window. To close themodal window,
click anywhere outside themodal window.

2. Hover over the alarmed component to see an alarm summary.
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Displaying Alarms from the Shelf View

Use this procedure to display the outstanding alarms on the selected component in the

Shelf view.

1. To display alarm details for the alarmed component from the Shelf view, right-click

the alarmed component and choose Select or Filter.

When Select is chosen, the alarms pane appears with the alarm(s) for the selected

component highlighted.When Filter is chosen, PSMapplies a filter to the alarmspane

to showonlyalarms for the selectedcomponent. For informationonmanagingalarms,

see Introduction.

Setting the Remote ID from the Shelf View

Use this procedure to set the Remote ID on an existing port in the Shelf view.

This is supported on BTI7000 Series and BTI800 Series NEs only. For more information

on Remote IDs, see “Deriving Topology Using Remote IDs” on page 74.

NOTE: PSMconnects to theNE using the login credentials that you supplied
whenyouconnected to thePSMserver. Therefore thisNEmustbeconfigured
with those same login credentials for this procedure to be successful.

To use this procedure, the cards and ports must already be provisioned.

1. To set theRemote IDonaport, right-click theport and chooseRemote Id>SetRemote

Port Id.
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The Set Remote Port ID dialog appears.

2. Configure theRemote ID.See “Remote IDConfiguration”onpage78 foranexplanation

of the attributes.

3. ClickOK.

NOTE: If you selectBidirectional and you specify a Remote ID that cannot

be reconciled, PSMwill be unable to configure the remote endpoint, and
the task will fail.

NOTE: The taskmight fail if you try to use this procedure on a card that
has not been provisioned.

Deleting the Remote ID from the Shelf View

Use this procedure to delete the Remote ID from a port in the Shelf view.
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This is supported on BTI7000 Series and BTI800 Series NEs only.

NOTE: PSMconnects to theNE using the login credentials that you supplied
when you connected to thePSMserver. Therefore theNEmust be configured
with those same login credentials for this procedure to be successful.

1. To delete the Remote ID, right-click the port and choose Remote Id >Delete Remote

Port Id.

The Delete Remote Port ID dialog appears.

2. To delete the remote ID at both endpoints, select bidirectional deletion.

3. ClickOK.
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CHAPTER 8

Nodal Management

• Introduction on page 133

• Nodal Management for BTI7000 Series Network Elements on page 134

• Nodal Management for BTI7800 Series Network Elements on page 181

• Nodal Management for Juniper Networks Routers and Switches on page 257

• Nodal Management for BTI800 Series Network Elements on page 265

Introduction

PSM supports nodal management for the BTI7000 Series, BTI7800 Series, and BTI800

Series (enable/disable only) equipment, and limitedmanagement ofMXSeries andPTX

Series routers and QFX Series switches.

When a network element is discovered, PSM displays the network element and all of its

components in theNetwork tree. This includesall provisionedand installed components,

all auto-provisioned components, and all pre-provisioned components (when operators

provision equipment in advance of hardware installation).

The Network tree lists the components hierarchically. You can expand a component to

see contained components, or minimize a component to hide its contents.
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PSM provides an indication of whether a component has been provisioned and/or has

been installed. A provisioned component has its mnemonic displayed (e.g. TPR) . An

unprovisioned component is shown with a none indication. A component that has been

physically installed is shown with its hardware mnemonic in parentheses (e.g. (DTPR)).

A component that has not been installed is displayed with an (empty) indication.

You can use PSM to provision installed components or to pre-provision components.

There is a short delay from the time you finish configuring a component to the timewhen

the configuration appears in the Network tree. PSM only displays the new configuration

in the Network tree when the network element reports its changes to PSM as part of the

regular notification process. To see the changes in PSM immediately, place the network

element into provisioning mode before making the changes. See “Enabling or Disabling

Provisioning Mode on a Network Element” on page 113.

NOTE: This document only provides a cursory explanation of the various
configuration parameters. For amore detailed explanation, consult the
documentation suite for the respective products.

Nodal Management for BTI7000 Series Network Elements

Nodal management for the BTI7000 Series network elements is generally performed

using the proNX 900. In some situations, however, it might be possible for you to use

PSM to configure the BTI7000 Series network elements directly.

This section describes how to launch the proNX 900 from PSM, and then describes the

nodal provisioning that you can perform directly using PSM.

• Launching the proNX 900 Node Controller on page 134

• Provisioning a BTI7000 Series Shelf on page 135

• Provisioning a Slot on a BTI7000 Series Shelf on page 137

• Provisioning a Transponder on a BTI7000 Series Shelf on page 139

• Provisioning a Muxponder on a BTI7000 Series Shelf on page 150

• Provisioning amultiplexer/demultiplexer on a BTI7000 Series Shelf on page 163

• Provisioning GCC on a BTI7000 Series Network Element on page 165

• Viewing Port PMs on a BTI7000 Series Network Element on page 166

• Provisioning the BTI7000 Series Dynamic Optical Layer (DOL) on page 168

• Enabling or Disabling a Port on page 180

Launching the proNX 900Node Controller

Use this procedure to launch the proNX 900 Node Controller.

The proNX 900 Node Controller is the nodal manager for the BTI7000 Series network

elements.
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NOTE: The proNX 900 Node Controller might not be supported on all PSM
Client platforms. See the BTI7000 Series Common Equipment Installation
Guide for a list of platforms that support the proNX 900 Node Controller.

Prerequisites:

• TheproNX900NodeController software that is compatiblewith thenetworkelements

in your network must be installed on your local computer.

1. To launch the proNX 900, right-click a network element in the Network tree view or

Topology Map view, and choose Node Controller.

The proNX 900 Node Controller splash screen displays. This procedure is complete.

If you get an errormessage indicating that the PSMClient cannot find the proNX 900

application software (executable file) on your local computer, configure the proNX

900 as described in “Configuring the proNX 900 Node Controller” on page 282.

NOTE: Information on how to use the proNX 900 can be found in the
BTI7000 Series documentation suite.

Provisioning a BTI7000 Series Shelf

Adding a Shelf

Use this procedure to add a new shelf on a BTI7000 Series network element.
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1. Right-click a network element in the Network tree view or in the topology Map view

and select Node >Shelf >Provision.

The Provision Shelf dialog appears:

Figure 33: BTI7000 Series Provision Shelf

2. Configure the shelf as follows:

• PEC Select the PEC from the list of available PECs in the drop-downmenu.

• Shelf Number Select the shelf number from the drop-downmenu. The drop-down

menu only displays the shelf numbers that are available and not already in use.

• IDOptionally, enter a string identifying the shelf.

• Initial State Specify whether the initial state of the shelf is IS (in-service) orOOS

(out-of-service).

3. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the CustomSettings tab.

b. In theCustomSettingspanel, specify theCustom1,Custom2, andCustom3settings

as desired.

4. When you are finished, clickOK.
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The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Deleting a Shelf

Use this procedure to delete a shelf on a BTI7000 Series network element.

Prerequisites:

All components on the shelf must be deleted before you can delete the shelf.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Right-click a shelf and select Shelf >Delete.

3. ClickOK in the Delete Shelf confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Provisioning a Slot on a BTI7000 Series Shelf

Adding aModule

Use this procedure to add a newmodule on a BTI7000 Series shelf.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right-click an unprovisioned slot and select Slot >Provision to add amodule in that

slot.

The Provision Slot dialog appears:
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Figure 34: BTI7000 Series Provision Slot

4. Configure the slot as follows:

• Name Select the module type from the list of available module types in the

drop-downmenu.

• PEC/CLEI Code Select the PEC from the list of available PECs for the selected

module type.

• Shelf Number and Slot Number- These read-only fields display the shelf and slot

numbers for the slot you selected.

• IDOptionally, specify an identifier for the module.

• Initial State Specify the initial state of the module.

5. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the CustomSettings tab.

b. In theCustomSettingspanel, specify theCustom1,Custom2, andCustom3settings

as desired.

6. When you are finished, clickOK.
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The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Deleting aModule

Use this procedure to delete a module on a BTI7000 Series shelf.

Prerequisites:

All components in the module must be deleted before you can delete the module.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right-click a provisioned slot and select Slot >Delete.

4. ClickOK in the Delete Slot confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Provisioning a Transponder on a BTI7000 Series Shelf

PSM supports provisioning of the Dual 2.5G, Dual 4G, 10G, and Dual 10Gmultiprotocol

transponders.

This section contains the following topics:

• Provisioning Ports on a BTI7000 Series Transponder on page 139

• Provisioning Cross-connects on a BTI7000 Series Transponder on page 143

• Provisioning Line Protection Groups on a BTI7000 Series Transponder on page 145

• Provisioning Client Protection Groups on a BTI7000 Series Transponder on page 148

To add a transponder, follow the steps in “Adding a Module” on page 137 and select the

desired transponder from the PEC drop-down list.

Provisioning Ports on a BTI7000 Series Transponder

BTI7000 Series transponders consist of 2 or 4 ports divided equally between client and

line ports.

Adding a Transponder Port

Use this procedure to add a new port on a BTI7000 Series transponder.
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1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a transponder to show the ports in that transponder.

4. Right click an unprovisioned port and select Transceiver >Provision to add a port on

that transponder.

The Provision/Edit Transceiver dialog appears:

Figure 35: BTI7000 Series Provision/Edit Transceiver

5. Configure the port as follows:

• Protocol Select the protocol from the list of available protocols in the drop-down

menu.

• Phy PMThldMon Enable or disable monitoring of PM thresholds.

• SD Bit Error RateOptionally, select the signal degrade bit error rate.

• Vendor Part Number 1 to 3Optionally, specify the vendor part numbers.
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• Laser Control Select Auto to let software control the laser. SelectManual On to turn

on the laser. SelectManual Off to turn off the laser.

• Wavelength Specify the wavelength to use. Set to NONE for copper.

• Fault Propagation Shutdown Enable or disable FPSD. If you enable FPSD, youmust

also set Laser Control to Auto andWavelength to a value other than NONE.

• Loopback Status This attribute cannot be set when adding a port.

• Loopback Action This attribute cannot be set when adding a port.

• Transceiver PECOptionally, specify the transceiver PEC.

• Tx Trace IdOptionally, specify the transmit trace ID (only available on certain

modules).

• ExpectedTrace IdOptionally, specify theexpected trace ID (only availableoncertain

modules).

• Rx Trace Id This attribute is read only.

• Auto-In Service TimerOptionally, specify the AINS timer. This attribute is only

applicable if the Admin State is AINS.

• Admin State Specify the initial state of the module.

6. Optionally, click the Custom Info tab to see the Custom Info panel.

a. Specify the port identifiers ID 1 and ID 2.

b. Specify the Fiber Type.

c. Specify the Custom 1, Custom 2, and Custom 3 settings as desired.

d. Specify the Remote Id. For information on how to use this field, see “Deriving

Topology Using Remote IDs” on page 74.

7. ClickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Editing a Transponder Port

Use this procedure to edit a port on a BTI7000 Series transponder.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a transponder to show the ports for that transponder.

4. Right click a provisioned port and select Transceiver >Edit.
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The Provision/Edit Transceiver dialog appears.

5. Change one or more port settings as follows:

• Protocol Select the protocol from the list of available protocols in the drop-down

menu.

• Phy PMThldMon Enable or disable monitoring of PM thresholds.

• SD Bit Error Rate Select the signal degrade bit error rate.

• Vendor Part Number 1 to 3 Specify the vendor part numbers.

• Laser Control Select Auto to let software control the laser. SelectManual On to turn

on the laser. SelectManual Off to turn off the laser.

• Wavelength Specify the wavelength to use. Set to NONE for copper.

• Fault Propagation Shutdown Enable or disable FPSD. If you enable FPSD, youmust

also set Laser Control to Auto andWavelength to a value other than NONE.

• Loopback Status This field is read only, and indicates what kind of loopback, if any,

is in effect.

• LoopbackActionThis is anactioncommand. Itwill alwaysdefault to<nooperation>,

meaning that no command is issued. Set to Terminal or Facility to set the port to

terminal or facility loopback respectively.

• Transceiver PEC Specify the transceiver PEC.

• Tx Trace Id Specify the transmit trace ID (only available on certain modules).

• ExpectedTrace IdSpecify the expected trace ID (only available on certainmodules).

• Rx Trace Id This attribute is read only.

• Auto-In Service Timer Specify the AINS timer. This attribute is only applicable if the

Admin State is AINS.

• Active Auto-In Service Timer This attribute is read only.

• Admin State Set the admin state of the module.

• Operational State This attribute is read only.

• Secondary State This attribute is read only.

• Laser Status This attribute is read only.

6. To change the Custom Info settings , click the Custom Info tab.

a. Specify the port identifiers ID 1 and ID 2.

b. Specify the Fiber Type.

c. Specify the Custom 1, Custom 2, and Custom 3 settings as desired.

d. Specify the Remote Id. For information on how to use this field, see “Deriving

Topology Using Remote IDs” on page 74.

7. Click Apply.
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The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Deleting a Transponder Port

Use this procedure to delete a port on a BTI7000 Series transponder.

Before a port can be deleted, it must be removed from any protection groups and

cross-connects.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a transponder to show the ports for that transponder.

4. Right click a provisioned port and select Transceiver >Delete.

5. ClickOK in the Delete Transceiver confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Provisioning Cross-connects on a BTI7000 Series Transponder

There are various rules that govern what ports and protocols can be cross-connected.

See the BTI7000 Series Transponder Solutions Guide for information.

Adding a Transponder Cross-connect

Use this procedure to add a cross-connect on a BTI7000 Series transponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a transponder and select Cross Connects >Edit.

The Cross Connections dialog appears, displaying the existing cross-connects.
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4. Click Add... to add a cross-connect.

The Add Cross Connection dialog appears.

5. Specify the Source port, the Destination port, and the Direction.

6. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Deleting a Transponder Cross-connect

Use this procedure to delete a cross-connect on a BTI7000 Series transponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a transponder and select Cross Connects >Edit.

The Cross Connections dialog appears.

4. Select the cross-connect you want to delete and click Delete.

The Deleting Cross Connection confirmation dialog appears.

5. ClickOK to confirm the deletion.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new
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provisioning appears in the Network tree view a short while after the task completes

successfully.

Provisioning Line Protection Groups on a BTI7000 Series Transponder

A line protection group is a pairing of a working line port and a protecting line port. There

are various rules that govern the configuration of line port protection. See the BTI7000

Series Transponder Solutions Guide for information.

Adding a Transponder Protection Group

Use this procedure to add a line protection group on a BTI7000 Series transponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a transponder and select Protection Groups >Edit.

The Protection Group dialog appears.

4. Click Add... to add a protection group.

The Add/Edit Protection Group dialog appears.

5. Specify theWorking Port, the Protecting Port, and optionally, the Protection Id.

6. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.
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Editing a Transponder Protection Group

Use this procedure to edit a line protection group on a BTI7000 Series transponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a transponder and select Protection Groups >Edit.

The Protection Group dialog appears, displaying the existing protection group.

4. Select a protection group and click Edit.

The Add/Edit Protection Group dialog appears.

5. Edit the Protection Id.

6. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Deleting a Transponder Protection Group

Use this procedure to delete a protection group on a BTI7000 Series transponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a transponder and select Protection Groups >Edit.

The Protection Group dialog appears, displaying the existing protection group.

4. Select the protection group you want to delete and click Delete.

The Deleting Protection Group confirmation dialog appears.

5. ClickOK to confirm the deletion.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree a short while after the task completes

successfully.
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Executing a Protection Switch Command

Use this procedure to execute a protection switch command on a BTI7000 Series

transponder port.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a transponder and select Protection Groups >Edit.

The Protection Group dialog appears, displaying the existing protection group.

4. Select a protection group and click Protection Switch....

The Protection Switch dialog appears.

5. Select the port on which you want to apply the command.

6. Select from the following actions:

• Manual Switch Switch the working and protecting ports. This is only allowed when

the protecting port is free of faults.

• Forced Switch Switch the working and protecting ports even if the protecting port

has a Signal Degrade condition.

• LockoutMake the specifiedport unavailable. If the specifiedport is theworkingport,

a protection switch occurs. If the specified port is the protecting port, the port is no

longer available for protecting.

• Release Release the lockout.

7. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree a short while after the task completes

successfully.
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Provisioning Client Protection Groups on a BTI7000 Series Transponder

A client protection group is a pairing of a working client port and a protecting client port.

There are various rules that govern the configuration of client port protection. See the

BTI7000 Series Transponder Solutions Guide for information.

NOTE: Not all transponders support client protection.

Adding a Client Protection Group

Use this procedure to add a client protection group on a BTI7000 Series transponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. To add a group across shelves, right click a network element and select Client

Protection Groups >Edit. To add a group within a shelf, right click a shelf and select

Client Protection Groups >Edit.

The Protection Group dialog appears.

3. Click Add... to add a client protection group.

The Add/Edit Protection Group dialog appears.

4. Specify theWorking Port, the Protecting Port, and optionally, the Protection Id.

5. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.
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Editing a Client Protection Group

Use this procedure to edit a client protection group on a BTI7000 Series transponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Right click the network element or a shelf and select Client Protection Groups >Edit.

The Protection Group dialog appears, displaying the existing protection groups.

3. Select a protection group and click Edit.

The Add/Edit Protection Group dialog appears.

4. Edit the Protection Id.

5. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree a short while after the task completes

successfully.

Deleting a Client Protection Group

Use this procedure to delete a client protection group on a BTI7000 Series transponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Right click the network element or shelf and select Client Protection Groups >Edit.

The Protection Group dialog appears, displaying the existing protection groups.

3. Select the protection group you want to delete and click Delete.

The Deleting Protection Group confirmation dialog appears.

4. ClickOK to confirm the deletion.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree a short while after the task completes

successfully.

Executing a Client Protection Switch Command

Use this procedure to execute a client protection switch command on a BTI7000 Series

transponder port.

149Copyright © 2019, Juniper Networks, Inc.

Chapter 8: Nodal Management



1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Right click the network element or a shelf and select Client Protection Groups >Edit.

The Protection Group dialog appears, displaying the existing protection group.

3. Select a protection group and click Protection Switch....

The Protection Switch dialog appears.

4. Select the port on which you want to apply the command.

5. Select from the following actions:

• Manual Switch Switch the working and protecting ports. This is only allowed when

the protecting port is free of faults.

• Forced Switch Switch the working and protecting ports even if the protecting port

has a Signal Degrade condition.

• LockoutMake the specifiedport unavailable. If the specifiedport is theworkingport,

a protection switch occurs. If the specified port is the protecting port, the port is no

longer available for protecting.

• Release Release the lockout.

6. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree a short while after the task completes

successfully.

Provisioning aMuxponder on a BTI7000 Series Shelf

PSM supports provisioning of the 2-port, 8-port, and 10-port muxponders.

This section contains the following topics:

• Provisioning Ports on a BTI7000 Series Muxponder on page 151

• ProvisioningVirtualConcatenationGroupsonaBTI7000SeriesMuxponderonpage 155

• Provisioning Cross-connects on a BTI7000 Series Muxponder on page 158

• Provisioning Protection Groups on a BTI7000 Series Muxponder on page 160

• Provisioning Synchronization on a BTI7000 Series Muxponder on page 162
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To add amuxponder, follow the steps in “Adding a Module” on page 137 and select the

desired muxponder from the PEC drop-down list.

Provisioning Ports on a BTI7000 Series Muxponder

BTI7000 Series muxponders consist of a set of client ports and 2 line ports.

Adding aMuxponder Port

Use this procedure to add a new port on a BTI7000 Series muxponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand amuxponder to show the ports in that muxponder.

4. Right click an unprovisioned port and select Port >Provision to add a port on that

muxponder.

The Provision Port dialog appears:

Figure 36: BTI7000 Series Provision Port
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5. Configure the port as follows:

NOTE: Some fields appear only for certain protocols, ports, and cards.
See the BTI7000 Series Muxponder Solutions Guide for details.

• Protocol Select the protocol from the list of available protocols in the drop-down

menu.

• Wavelength Specify the wavelength to use. Set to NONE for copper.

• Phy PMThldMon Enable or disable monitoring of PM thresholds.

• Fault Propagation Shutdown Enable or disable FPSD. If you enable FPSD, youmust

also set Laser Control to Auto andWavelength to a value other than NONE.

• SD Bit Error Rate Select the signal degrade bit error rate.

• TOH Transparency Choose whether you want to have Transport Overhead

transparency in the signal or not.

• DCCTransparencyChoosewhether youwant tohaveDataCommunicationsChannel

transparency in the signal or not. If selected, youmust specify the channel to

transport the DCC bytes. This option is automatically selected if TOHTransparency

is selected.

• Laser Control Select Auto to let software control the laser. SelectManual On to turn

on the laser. SelectManual Off to turn off the laser.

• LineMapping Specify the line mapping for line ports.

• Transceiver PECOptionally, specify the transceiver PEC.

• FPSD Recover Timer If Fault Propagation Shutdown is set to Enabled and GFPMode

is set to Framed, specify the time that the client port takes to turn the laser back on

after the link has recovered. If a link failure occurs on a client port at the near end,

FPSD behavior causes the client port at the near end and the client port at the far

end to turn off their lasers. After the link recovers, the client port at the near end

waits for the time specified in this field before turning its laser back on and before

notifying the far end that the link has recovered. A shorter time period enables the

port to detect that the link is back upmore quickly. A longer time period allows the

port to ignore link flapping situations. This timer is supported on client ports on the

BT7A48AA-I02 and BT7A48BA-I02 cards only.

• Vendor Part Number 1 to 3Optionally, specify the vendor part numbers.

• Loopback This attribute cannot be set when adding a port.

• GFPMode Set the Generic Framing Procedure mapping mode.

• Media Rate Set the media rate.

• Flow Control Set the flow control mode.
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• Admin State Specify the initial state of the port.

• Auto-In Service Timer Specify the AINS timer. This attribute is only applicable if the

Admin State is AINS.

6. Optionally, click the Custom Info tab to see the Custom Info panel.

a. Specify the port identifier ID 1.

b. Specify the Fiber Type.

c. Specify the Custom 1 field as desired.

d. Specify the Remote Id. For information on how to use this field, see “Deriving

Topology Using Remote IDs” on page 74.

7. ClickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Editing aMuxponder Port

Use this procedure to edit a port on a BTI7000 Series muxponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand amuxponder to show the ports for that muxponder.

4. Right click a provisioned port and select Port >Provision.

The Provision Port dialog appears.

5. Change one or more port settings as follows:

NOTE: Some fields appear only for certain protocols, ports, and cards.
See the BTI7000 Series Muxponder Solutions Guide for details.

• Protocol This attribute cannot be changed.

• Wavelength Specify the wavelength to use. Set to NONE for copper.

• Phy PMThldMon Enable or disable monitoring of PM thresholds.

• Fault Propagation Shutdown Enable or disable FPSD. If you enable FPSD, youmust

also set Laser Control to Auto andWavelength to a value other than NONE.

• SD Bit Error Rate Select the signal degrade bit error rate.
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• TOH Transparency Choose whether you want to have Transport Overhead

transparency in the signal or not.

• DCCTransparencyChoosewhether youwant tohaveDataCommunicationsChannel

transparency in the signal or not. If selected, youmust specify the channel to

transport the DCC bytes. This option is automatically selected if TOHTransparency

is selected.

• Laser Control Select Auto to let software control the laser. SelectManual On to turn

on the laser. SelectManual Off to turn off the laser.

• LineMapping Specify the line mapping for line ports.

• Transceiver PECOptionally, specify the transceiver PEC.

• FPSD Recover Timer If Fault Propagation Shutdown is set to Enabled and GFPMode

is set to Framed, specify the time that the client port takes to turn the laser back on

after the link has recovered. If a link failure occurs on a client port at the near end,

FPSD behavior causes the client port at the near end and the client port at the far

end to turn off their lasers. After the link recovers, the client port at the near end

waits for the time specified in this field before turning its laser back on and before

notifying the far end that the link has recovered. A shorter time period enables the

port to detect that the link is back upmore quickly. A longer time period allows the

port to ignore link flapping situations. This timer is supported on client ports on the

BT7A48AA-I02 and BT7A48BA-I02 cards only.

• Vendor Part Number 1 to 3Optionally, specify the vendor part numbers.

• Loopback Set to Terminal for terminal loopback, Facility for facility loopback, or

Disabled. The port must be out of service before you can set this option.

• GFPMode Set the Generic Framing Procedure mapping mode.

• Media Rate Set the media rate.

• Flow Control Set the flow control mode.

• Admin State Set the admin state of the port.

• Operational State This attribute is read only.

• Secondary State This attribute is read only.

• Laser Status This attribute is read only.

• Auto-In Service Timer Specify the AINS timer. This attribute is only applicable if the

Admin State is AINS.

6. To change the Custom Info settings , click the Custom Info tab.

a. Specify the port identifiers ID 1 and ID 2.

b. Specify the Fiber Type.
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c. Specify the Custom 1, Custom 2, and Custom 3 settings as desired.

d. Specify the Remote Id. For information on how to use this field, see “Deriving

Topology Using Remote IDs” on page 74.

7. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Deleting aMuxponder Port

Use this procedure to delete a port on a BTI7000 Series muxponder.

Before a port can be deleted, it must be removed from any protection groups and

cross-connects.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand amuxponder to show the ports for that muxponder.

4. Right click a provisioned port and select Port >Delete.

5. ClickOK in the Delete Port confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Provisioning Virtual Concatenation Groups on a BTI7000 Series Muxponder

A virtual concatenation group (VCG) is a collection of virtual tributaries that are

concatenated to create a higher bit rate stream. The tributaries in a VCG do not need to

be contiguous.

Adding aMuxponder Virtual Concatenation Group

Use this procedure to add a virtual concatenation group (VCG) on a BTI7000 Series

muxponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a muxponder and select Virtual Concatenation Groups >Edit.
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The Virtual Concatenation Groups dialog appears, displaying the existing virtual

concatenation groups.

The BTI7000 Series muxponder has number of default VCGs automatically created.

4. Click Add to add a virtual concatenation group.

The Provision VCG dialog appears.

5. Specify the Port and Index from the available ports and indices.

6. Specify the Format of the concatenated signal.

Based on your selection, the number of time slots shownmight change.

7. Set Ascending STS Selection if you want to auto-select the contiguous number of

time slots required.

With this option, all you have to do is to select the first time slot.

8. Select the time slots that make up this VCG.
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Click a time slot to select. Click again to clear. The Remaining Slots counter at the

bottom shows the number of time slots that are available for selection based on the

specified concatenation format.

9. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Editing aMuxponder Virtual Concatenation Group

Use this procedure to edit a virtual concatenationgrouponaBTI7000Seriesmuxponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a muxponder and select Virtual Concatenation Groups >Edit.

The Virtual Concatenation Groups dialog appears, displaying the existing virtual

concatenation groups.

4. Select a virtual concatenation group and click Edit.

The Provision VCG dialog appears.

5. Specify the Format of the concatenated signal.

Based on your selection, the number of time slots shownmight change.

6. Set Ascending STS Selection if you want to auto-select the contiguous number of

time slots required.

With this option, all you have to do is to select the first time slot.

7. Select the time slots that make up this VCG.

Click a time slot to select. Click again to clear. The Remaining Slots counter at the

bottom shows the number of time slots that are available for selection based on the

specified concatenation format.

8. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.
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Deleting aMuxponder Virtual Concatenation Group

Use this procedure to delete a virtual concatenation group on a BTI7000 Series

muxponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a muxponder and select Virtual Concatenation Groups >Edit.

The Virtual Concatenation Groups dialog appears, displaying the existing groups.

4. Select the virtual concatenation group you want to delete and click Delete.

The Delete VCG confirmation dialog appears.

5. ClickOK to confirm the deletion.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Provisioning Cross-connects on a BTI7000 Series Muxponder

There are various rules that govern what ports and protocols can be cross-connected.

See the BTI7000 Series Muxponder Solutions Guide for information.

Adding aMuxponder Cross-connect

Use this procedure to add a cross-connect on a BTI7000 Series muxponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a muxponder and select Cross Connects >Edit.

TheManage Cross Connects dialog appears, displaying the existing cross-connects.
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4. Click Add to add a cross-connect.

The Provision Cross Connect dialog appears.

5. Specify the concatenation Type.

If you specify contiguous concatenation (CCAT), then you will select the timeslot

using Set Time Slot and the CCAT type using the CRS Type pulldownmenu. If you

specify virtual concatenation (VCAT), then you will select the virtual concatenation

group through theSourcepulldownmenu. The timeslots andVCAT type for the virtual

concatenation group are set when you create the virtual concatenation group. See

“Provisioning Virtual Concatenation Groups on a BTI7000 Series Muxponder” on

page 155.

6. Specify the Source, the Destination, and the Direction.

7. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Deleting aMuxponder Cross-connect

Use this procedure to delete a cross-connect on a BTI7000 Series muxponder.
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1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a muxponder and select Cross Connects >Edit.

TheManage Cross Connects dialog appears.

4. Select the cross-connect you want to delete and click Delete.

The Delete Cross Connect confirmation dialog appears.

5. ClickOK to confirm the deletion.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Provisioning Protection Groups on a BTI7000 Series Muxponder

A protection group is a pairing of a working line port and a protecting line port. There are

various rules that govern the configuration of line port protection. See theBTI7000Series

Muxponder Solutions Guide for information.

Adding aMuxponder Protection Group

Use this procedure to add a line protection group on a BTI7000 Series muxponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a muxponder and select Protection Groups >Edit.

TheManage Protection Groups dialog appears.

4. Click Add to add a protection group.

The Provision 1+1 Protection Group dialog appears.
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TheWorking port, the Protecting port, and the wavelengths are automatically set.

5. Optionally, specify the protection group Id.

6. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Editing aMuxponder Protection Group

Use this procedure to edit a line protection group on a BTI7000 Series muxponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a muxponder and select Protection Groups >Edit.

TheManageProtectionGroupsdialogappears, displaying theexistingprotectiongroup.

4. Select a protection group and click Edit.

The Provision 1+1 Protection Group dialog appears.

5. Edit the protection Id.

6. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Deleting aMuxponder Protection Group

Use this procedure to delete a protection group on a BTI7000 Series muxponder.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.
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3. Right click a muxponder and select Protection Groups >Edit.

TheManageProtectionGroupsdialogappears, displaying theexistingprotectiongroup.

4. Select the protection group you want to delete and click Delete.

The Delete Line Protection confirmation dialog appears.

5. ClickOK to confirm the deletion.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Provisioning Synchronization on a BTI7000 Series Muxponder

Client traffic must be properly synchronized whenmultiplexing into a SONET/SDH

network. This procedure shows how synchronization can be configured.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click a muxponder and select Synchronization >Edit.

TheManage Synchronization dialog appears.

4. Configure synchronization as follows:

• TimingMode Set to Internal for internal timing, or set to Line for line timing. Internal

timing can only be used for limited configurations.

• Primary ReferenceWhen using line timing, set the primary reference to the desired

timing source.

• Secondary ReferenceWhen using line timing, set the secondary reference to the

desired timing source.

• SSMWhen using line timing, specify whether synchronization status messaging is

enabled. SSM prevents timing loops from occurring as a result of failures or
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misconfiguration. There is a separate SSM setting for the primary and secondary

references.

• StatusWhen using line timing, the status' of the primary and secondary references

are shown.

5. Click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Provisioning amultiplexer/demultiplexer on a BTI7000 Series Shelf

Amultiplexer/demultiplexer is a passive module that provides access to add/drop

wavelengths in a DOL nodal configuration.

Adding or Viewing amultiplexer/demultiplexer

Use this procedure to view existing multiplexer/demultiplexers or to add a new one on

a BTI7000 Series network element.

1. Right click a network element in the Network tree and select Node >Passive

>Mux/Demux >Edit

TheMux/Demuxwindow appears. This window shows a listing of the existing

multiplexer/demultiplexers on the shelf, and the group/degree to which each

multiplexer/demultiplexer is assigned (if any).

2. Click on the plus icon to add a newmultiplexer/demultiplexer.
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The ProvisionMux/Demuxwindow appears.

3. Specify the Slot for the multiplexer/demultiplexer.

4. Select a PEC from the list of available PECs.

5. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the Custom tab.

b. In the Custom panel, specify the Id, Custom 1, Custom 2, and Custom 3 settings as

desired.

6. When you are finished, click Apply.

The newly addedmultiplexer/demultiplexer appears in theMux/Demuxwindow. To

assign the multiplexer/demultiplexer to an optical group and degree, see “Assigning

or Unassigning Equipment” on page 170.

7. ClickOK.
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The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Deleting amultiplexer/demultiplexer

Use this procedure to delete amultiplexer/demultiplexer fromaBTI7000Series network

element.

1. Right click a network element in the Network tree and select Node >Passive

>Mux/Demux >Edit

TheMux/Demuxwindow appears.

2. Select a multiplexer/demultiplexer and click on theminus icon to delete it.

The selectedmultiplexer/demultiplexer disappears from the window.

3. ClickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning takes effect a short while after the task completes successfully.

Provisioning GCC on a BTI7000 Series Network Element

Provisioning GCC

Use this procedure to provision GCC on a transponder, muxponder, or PVX port on a

BTI7000 Series network element. GCC is used to carry management traffic inband.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a transponder, muxponder, or PVX to see the ports on that module.

4. Right click a provisioned port and select GCC >Provision.

NOTE: GCC is only available for selection when the transceiver is
configured for certain protocols.

TheManage GCC dialog appears.

5. Configure GCC as follows:

• Mode: The mode is set at Full Rate and cannot be changed.

• Admin State: Select Enabled or Disabled.
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• Operational State: The operational state is read-only.

• Secondary State: The secondary state is read-only.

6. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Deleting GCC

Use this procedure to delete GCC from a transponder, muxponder, or PVX port on a

BTI7000 Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a transponder, muxponder, or PVX to see the ports on that module.

4. Right click a provisioned port and select GCC >Delete.

5. ClickOK in the confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Viewing Port PMs on a BTI7000 Series Network Element

Use this procedure to view current port PMs on transponder, muxponder, and packetVX

modules on a BTI7000 Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right-click a transponder,muxponder, or packetVXmodule and selectPort PM>View

The Port PMwindow appears. By default, the current 15-minute bin is displayed. Here

is an example of the window for a transponder module:
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Thecountsarecolor-coded toshowvalid, partial, and invalid counts. Inmost situations,

the running counters will be partial counts because you are retrieving the counts in

themiddleof abinperiod.An invalid count indicates that thecount cannotbe retrieved

and thereforecannotbe trusted.Ann/adesignation indicates that theparticular count

is not applicable to this port and protocol.

NOTE: This window shows a snapshot of the PM counts. The counts do
not update automatically in this window. To see the latest counts, click
the Refresh button.

4. To see the 1-day bin or the untimed bin, select the desired bin from theBin drop-down

menu in the lower left corner, and click the Refresh button.

The PM counts for the selected bin appears shortly.

5.
To select what columns to display, click the icon in the upper right corner to bring

up the Change Visible Columnswindow. Alternatively, if you are only making a single

change, right-click anywhere in the headings row to bring up a column selection

window that disappears after youmake a single change.

Check or uncheck column headings as desired.

6. To sort the PMs based on column values, click on the column heading that you want

to sort.

7. To export the PM data to a CSV file, click Export and save the file.
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Provisioning the BTI7000 Series Dynamic Optical Layer (DOL)

The BTI7000 Series Dynamic Optical Layer provides reconfigurable optical add/drop

multiplexing, reach extension, and end-to-end service management for the BTI7000

Series optical network. The Dynamic Optical Layer consists of ROADMmodules that

provide wavelength routing, line amplifier modules that provide reach extension, and

passivemultiplexer/demultiplexermodules that providewavelength access. ADOLnode

can be configured to be a channel equalizing terminal, a channel equalizing line node, a

line amplifier node, or a ROADM node.

Before you can provision DOL, youmust first add optical modules to the shelf. To add a

module, follow the steps in “Adding aModule” on page 137 and select the desiredmodule

from the PEC drop-down list. Once all themodules are added, use the procedures in this

section to create the desired optical nodal function.

Once the nodal function is created, you can activate DOL services using the procedures

described in “Optical Services” on page 301.

Provisioning Optical Groups

An optical group is a representation of an optical node (i.e. a collection of modules that

together provide a specific nodal function in the optical network). An optical node can

be a DOL or a non-DOL node.

The following optical group types are supported:

• NON_EQUALIZING_TERM - This is a non-channel equalizing terminal that consists of

non-equalizing amplifiers that do not support DOL.

• CHANNEL_EQUALIZING_TERMINAL -This isachannel equalizing terminal thatconsists

of DOL equipment.

• LINE_AMPLIFIER_NODE - This is a non-channel equalizing line node that consists of

DOL equipment.

• CHANNEL_EQUALIZING_LINE_NODE -This is achannel equalizing terminal that consists

of DOL equipment.

• ROADM - This is a ROADM node that consists of DOL equipment.

Creating an Optical Group

Use this procedure to create an optical group on a BTI7000 Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Right-click onOptical Groups and select Group/Degree >Provision.

The Provision Optical Group dialog appears:
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Figure 37: Provision Optical Group

3. Configure the group as follows:

• Group ID Specify the Group ID to distinguish the new group from the other optical

groups on the node.

• Group Type Specify the function for the group from the drop-downmenu.

4. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the CustomSettings tab.

b. In the CustomSettings panel, specify the Id, Custom 1, Custom 2, and Custom 3

settings as desired.

5. When you are finished, clickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

optical group appears in the Network tree a short while after the task completes

successfully.
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Assigning or Unassigning Equipment

Use this procedure to assign or unassign equipment to or from an optical group on a

BTI7000Seriesnetworkelement.Anoptical group isacollectionofmodules that together

provide a specific nodal function in the optical network. Modules must belong to an

optical group in order to provide the nodal function.

1. Expand the network element in the Network tree.

2. Expand theOptical Groups to see the optical groups on that NE.

3. Right-click the optical group in which you want to assign equipment, and select

Group/Degree >Edit.

The Update Optical Group dialog appears.

The Group ID is set during optical group creation, and cannot be edited.

4. Assign or unassign equipment from the group.

• Toassignequipment to thegroup, click on theplus icon. This brings you to theAssign

OpticalEquipmentwindowwhereyoucanassignequipmentbyselecting thedegree
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and the equipment. ClickApplywhen you are done. The newly assigned equipment

appears in the Equipment list.

NOTE: If the degree that you select does not yet exist, the degree is
created and will appear in the Network tree.

• To unassign equipment, select the equipment from the list and then click on the

minus icon. The unassigned equipment is removed from the Equipment list.

5. Configure the Custom fields. These fields are for operator use and are opaque to the

system.

a. Click the CustomSettings tab.

b. In theCustomSettingspanel, edit the Id,Custom1,Custom2, andCustom3 settings

as desired.

6. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The

changes appear in PSM a short while after the task completes successfully.

Deleting an Optical Group

Use this procedure to delete an optical group on a BTI7000 Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. ExpandOptical Groups to show the optical groups in that NE.

3. Right-click an optical group and select Group/Degree >Delete.

4. ClickOK in the confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The

deletedgroupdisappears fromtheNetwork treeashortwhileafter the taskcompletes

successfully.

EditingWDMParameters in an Optical Group

Use this procedure toeditWDMparametersonaBTI7000Series network element.WDM

parameters apply to the respective line span for equipment in optical groups.

1. Expand the network element in the Network tree.

2. ExpandOptical Groups to see the optical groups on that NE.

3. Expand an optical group to see the degrees in that group.
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4. Expand a degree to see the equipment in that degree.

5. Right-click on themodule you want to edit and selectWDM>Edit.

The EditWDM dialog appears.

Figure 38: Edit WDMDialog for a BTI7000 Series ROADMModule

The dialog (and/or tabs) might differ depending on themodule selected.

6. Configure theWDM parameters as follows:

NOTE: Not all of the parameters below appear in all dialogs.

• Administrative State Select the state from the list of available states in the

drop-downmenu.

• State This is the operational state. It is read-only.

• Secondary State This is the secondary operational state. It is read-only.

• FiberTypeSpecify the fiber type fromthe list ofavailable fiber types in thedrop-down

menu.
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• MeasuredSpanLengthThespan length ismeasuredautomatically. This is read-only.

• Measured Span Loss The span loss is measured automatically. This is read-only.

• Max. Supported Span Loss Themaximum supported span loss is calculated

automatically. This is read-only.

• Max. Span Loss Alarm Threshold Specify the span loss threshold beyond which an

alarm is raised. This field can only be edited if Enable Alarm is selected.

• LossRxHighThreshold-Similar toMax.SpanLossAlarmThreshold. Specify the span

loss threshold beyond which an alarm is raised. Set to 0 to disable.

• Enable Alarm Select to enable the span loss threshold alarm.

• Provisioned Channels This is the number of channels that can be carried. This is

read-only.

• Amp Tilt Trim Set to fine tune the system gain tilt.

• Post AmpGain Set the system gain.

• Auto-In Service TimerOptionally, specify the AINS timer. This attribute is only

applicable if the Administrative State is Auto-In-Service.

• Active Countdown This is the countdown for the AINS timer. It is read-only.

7. Configure the Custom fields. These fields are for operator use and are opaque to the

system.

a. Click the CustomSettings tab.

b. In theCustomSettingspanel, edit the Id,Custom1,Custom2, andCustom3 settings

as desired.

8. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The

changes appear in PSM a short while after the task completes successfully.

Adding and Deleting the C2 Port

In someBTI7000Seriesnodal configurations, theC2port of aROADMmodule is optional.

In these situations, PSM does not automatically create the C2 port, but leaves it up to

the user to create it manually.

Use this procedure to create and/or delete the optional C2 port on a BTI7000 Series

ROADMmodule for the optical group type CHANNEL_EQUALIZING_TERMINAL. In this

configuration, the C2 port can be used to connect to alienwavelengths. See theBTI7000

Series Dynamic Optical Layer Engineering Guideline for details.

1. Expand the network element in the Network tree.

2. Expand theOptical Groups to see the optical groups on that NE.
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3. Expand an optical group to see the degrees in that group.

4. Expand a degree to see the equipment in that degree.

5. To add the C2 port, right-click on the ROADMmodule and select C2 >Provision.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The C2

port is added to the ROADM in that degree a short while after the task completes

successfully.

6. To delete a previously-added optional C2 port, right-click on the ROADMmodule and

select C2 >Delete.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The C2

port is deleted from the ROADM in that degree a short while after the task completes

successfully.

Editing Optical Port Parameters

Use this procedure to edit optical port parameters onaBTI7000Series network element.

An optical port can be a line port, a client port, or a DCM port.

1. Expand the network element in the Network tree.

2. Expand theOptical Groups to see the optical groups on that NE.

3. Expand an optical group to see the degrees in that group.

4. Expand a degree to see the equipment in that degree.

5. Expand amodule to see the ports on that module.

6. Right-click on an optical port you want to edit and selectOptical Port >Edit.

The Edit Optical Layer Port dialog appears.
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Figure 39: Edit Optical Layer Port Dialog for a BTI7000 Series ROADM Line Port

The dialog (and/or tabs) might differ depending on themodule and port selected.

7. Configure the optical port parameters as follows:

NOTE: Not all of the parameters below appear in all dialogs.

• State This is the operational state. It is read-only.

• Secondary State This is the secondary operational state. It is read-only.

• DWDMType This is the type of DWDM composite signal expected on the port. It is

set to nativewhen connected to DOL equipment. It is set to alienwhen connected

to other equipment. This is read-only.

• GridTypeThis is theDWDMgrid spacing for the port. If the equipment only supports

a specific grid spacing, then this field is read-only.

• FiberConnectionThis shows theequipmentat theother endof the fiber connection.

This is read-only.

• Wavelength The wavelength for the port. This is read-only.

• Frequency The frequency for the port. This is read-only.
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• Tx Loss Specify the optical loss in the transmit direction. Set to 0 for no loss.

• Auto-In Service TimerOptionally, specify the AINS timer.

• Active Countdown This is the countdown for the AINS timer. It is read-only.

8. Optionally, configure the Custom fields. These fields are for operator use and are

opaque to the system (with the exception of the Remote ID).

a. Click the CustomSettings tab.

b. In theCustomSettingspanel, edit the Id,Custom1,Custom2, andCustom3 settings

as desired.

c. Set the Remote Id to describe the equipment at the other end of the fiber. PSM

uses the Remote Idwhen determining topology.

9. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The

changes appear in PSM a short while after the task completes successfully.

Configuring a Split ROADMNode

Use this procedure to configure a split ROADM node on a BTI7000 Series system.

A split ROADM node is a highly survivable configuration where each ROADMmodule in

a BTI7000 Series ROADM node is located in a separate network element, managed by

a separate management module. While these network elements are distinct in every

other aspect, PSM treats this combination as a singleROADMnodeduring optical service

activation.

Creating a split ROADM node is essentially a hardware installation function where the

ROADMmodules are installed on separate network elements and connected together

by fiber over their C2 ports. There is no provisioning required except to enable PSM to

recognize the split ROADM node. In order for PSM to recognize the split ROADM node as

asingleROADMnode, theRemote IDconfigurationon theC2portsof theROADMmodules

must point to each other. This is shown in the following figure. By configuring the Remote

IDs on the C2 ports in this manner, PSM is able to recognize this as a split ROADM node

configuration.

A split ROADM node can be configured for the CHANNEL_EQUALIZING_LINE_NODE and

ROADM optical group types.
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1. Follow the procedure in “Setting the Remote ID on a ROADM C2 Port” on page 82 to

set the Remote ID on a ROADM C2 port.

Configure the Remote ID to point to the C2 port of the second ROADMmodule. For

example:

By selecting the Bidirectional option, PSM automatically configures the C2 port at the

other end to point back to this C2 port.

Editing OSC Parameters in an Optical Group

Use this procedure to edit OSC parameters on a BTI7000 Series network element. The

optical service channel (OSC) is used as a communications medium for control

information between optical equipment at both ends of a line span. Through the OSC,

optical elements share information and automatically measure span loss, adjust the

system gain, and leverage amulti-span feedback loop that enables per-channel

pre-emphasis to address wavelength tilt and ripple.

1. Expand the network element in the Network tree.

2. Expand theOptical Groups to see the optical groups on that NE.

3. Expand an optical group to see the equipment in that group.

4. Right-click on themodule you want to edit and selectOSC >Edit.

The Edit OSC dialog appears.
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Figure 40: Edit OSC Dialog for a BTI7000 Series ROADMModule

The dialog (and/or tabs) might differ depending on themodule selected.

5. In the General tab, configure the OSC parameters as follows:

NOTE: Not all of the parameters below appear in all dialogs.

• AdministrativeStateorAdminStatusSelect the state fromthe list of available states

in the drop-downmenu.

• State orOper Status This is the operational state. It is read-only.

• Secondary State This is the secondary operational state. It is read-only.

• AINSTimerOptionally, specify the AINS timer. This attribute is only applicable if the

Administrative State is Auto-In-Service.

• Active Countdown This is the countdown for the AINS timer. It is read-only.

6. In theOSC Info tab, configure the OSC parameters as follows:

NOTE: Not all of the parameters below appear in all dialogs.
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• Admin Status Select the state from the list of available states in the drop-down

menu.

• Oper Status This is the operational state. It is read-only.

• FE IMMonSelect if youwant the near end to validate the identity of the far endwith

the expected far end parameters. If the identity does not match, the systemwill

raise an alarm or condition.

• SystemName (actual) This is the actual system name of the far end. It is read-only.

• IP Address (actual) This is the actual NMS IP address of the far end. It is read-only.

• Group(actual)This is theactual optical group identifier of the far end. It is read-only.

• Degree (actual) This is the actual optical degree of the far end. It is read-only.

• Group Type (actual)- This is the actual group type of the far end. It is read-only.

• SystemName (expected) Set to the expected system name of the far end.

• IP Address (expected) Set to the expected NMS IP address of the far end.

• Group (expected) Set to the expected optical group identifier of the far end.

• Degree (expected) Set to the expected optical degree of the far end.

7. In the FarEnd tab, configure the OSC parameters as follows:

NOTE: Not all of the parameters below appear in all dialogs.

• Far-EndMonitoring Select if you want the near end to validate the identity of the

far end with the expected far end parameters. If the identity does not match, the

systemwill raise an alarm or condition.

• SystemName (actual) This is the actual system name of the far end. It is read-only.

• NMS IP Address (actual) This is the actual NMS IP address of the far end. It is

read-only.

• Optical Group (actual) This is the actual optical group identifier of the far end. It is

read-only.

• OpticalDegree(actual)This is theactual optical degreeof the far end. It is read-only.

• Group Type (actual)- This is the actual group type of the far end. It is read-only.

• SystemName (expected) Set to the expected system name of the far end.

• NMS IP Address (expected) Set to the expected NMS IP address of the far end.

• Optical Group (expected)Set to the expected optical group identifier of the far end.

• Optical Degree (expected) Set to the expected optical degree of the far end.

8. In theODCC tab, configure the ODCC parameters as follows:

NOTE: Not all of the parameters below appear in all dialogs.
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The optical data communications channel (ODCC) is used to carry inband

management traffic between Juniper Networks network elements.

• Enable Select to enable ODCCwithin the OSC.

• Admin Status Select the state from the list of available states in the drop-down

menu.

• Oper Status This is the operational state of the ODCC. It is read-only.

9. Optionally, configure the Custom fields. These fields are for operator use and are

opaque to the system.

a. Click the CustomSettings tab.

b. In theCustomSettingspanel, edit the Id,Custom1,Custom2, andCustom3 settings

as desired.

10.When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The

changes appear in the Network tree (if applicable) a short while after the task

completes successfully.

Enabling or Disabling a Port

Use this procedure to administratively enable or disable a port on a BTI7000 Series

network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand amodule to show the ports on that module.

4. Enable or disable a port as follows.

a. To enable a provisioned port, right click the port and select Admin State >Enable.

For PVX ports, you have the option of enabling the port at layer 1 or at layer 2.

b. To disable a provisioned port, right click the port and select Admin State >Disable.

For PVX ports, you have the option of disabling the port at layer 1 or at layer 2.
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Nodal Management for BTI7800 Series Network Elements

NOTE: TheBTI7800 typically provisions equipment automatically when the
modules are physically installed. This is called auto-provisioning. See the
BTI7800 Series Software Configuration Guide for details.

• Provisioning a BTI7800 Chassis on page 181

• Provisioning a Universal Forwarding Module on a BTI7800 on page 184

• Provisioning a ROADMNode on a BTI7800 on page 216

• Provisioning a 96-Channel Amplifier on a BTI7800 on page 241

• Provisioning aWavelength Protection Switch Module on a BTI7800 on page 251

• Enabling or Disabling a Port on page 257

Provisioning a BTI7800 Chassis

Adding a Shelf

Use this procedure to add a new chassis on a BTI7800 Series network element.
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1. Right-click a network element in the Network tree or in the Topology Map view and

select Node >Shelf >Provision.

The Provision Shelf dialog appears:

Figure 41: BTI7800 Series Provision Shelf

2. Configure the shelf as follows:

• PEC Select the PEC from the list of available PECs in the drop-downmenu.

• Shelf Number Select the shelf number from the drop-downmenu. The drop-down

menu only displays the shelf numbers that are available and not already in use.

• AliasOptionally, enter a string identifying the shelf.

• LocationOptionally, enter a string describing the location of the NE.

• Chassis Type The chassis type is automatically populated based on the PEC.

• Admin Status Specify whether the initial state of the shelf is Up or Down or Testing.

3. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the CustomSettings tab.
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b. In theCustomSettingspanel, specify theCustom1,Custom2, andCustom3settings

as desired.

4. When you are finished, clickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Editing a Shelf

Use this procedure to edit a chassis on a BTI7800 Series network element.

1. Expand a network element in the Network tree view to show the shelves on that

network element.

2. Right-click a shelf and select Shelf >Edit.

The Edit Shelf dialog appears:

Figure 42: BTI7800 Series Provision Shelf

3. Edit the shelf as follows:
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• PEC This field is read-only.

• Shelf Number This field is read-only.

• Alias Enter a string identifying the shelf.

• Location Enter a string describing the location of the NE.

• Chassis Type This field is read-only.

• Admin Status Specify whether the state of the shelf is Up or Down or Testing.

4. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the CustomSettings tab.

b. In theCustomSettingspanel, specify theCustom1,Custom2, andCustom3settings

as desired.

5. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Deleting a Shelf

Use this procedure to delete a chassis on a BTI7800 Series network element.

Prerequisites:

All components on the shelf must be deleted before you can delete the shelf.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Right-click a shelf and select Shelf >Delete.

3. ClickOK in the Delete Shelf confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Provisioning a Universal ForwardingModule on a BTI7800

• Adding a UFM on page 185

• Editing a UFM on page 187

• Deleting a UFM on page 188

• Adding a BIC on page 188

• Editing a BIC on page 190
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• Cloning a BIC on page 191

• Deleting a BIC on page 192

• Adding a Transceiver on page 193

• Editing a Transceiver on page 195

• Cloning a Transceiver on page 196

• Deleting a Transceiver on page 197

• Adding an Interface on page 198

• Editing an Interface on page 205

• Configuring a Multiplexed Interface on page 211

• Cloning an Interface on page 213

• Deleting an Interface on page 214

• Viewing Interface PMs on a UFM on page 215

Adding a UFM

Use this procedure to add a new UFM on a BTI7800 Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right-click an unprovisioned slot and select Slot >Provision to add amodule in that

slot.

The Provision Slot dialog appears:
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Figure 43: BTI7800 Series Provision Slot

4. Configure the slot as follows:

• PEC Select a UFM PEC from the list of available PECs in the drop-downmenu.

• UFMType This read-only field is automatically populated, and shows the BIC

configuration supported for the UFM selected.

• AdminStatusSpecifywhether the initial stateof themodule isUporDownorTesting.

5. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the CustomSettings tab.

b. In the CustomSettings panel, specify the Id, Custom 1, Custom 2, and Custom 3

settings as desired.

6. When you are finished, clickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.
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Editing a UFM

Use this procedure to edit an existing UFM on a BTI7800 Series network element.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right-click a UFM and select Slot >Edit to edit the module in that slot.

The Edit Slot dialog appears.

Figure 44: BTI7800 Series Edit Slot (UFM)

4. Edit the slot as follows:

• PEC This field is read-only.

• UFMType This field is read-only.

• Admin Status Change the state of the module to Up or Down or Testing.

5. Optionally, edit the Custom fields. These fields are for operator use and are opaque

to the system.
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a. Click the CustomSettings tab.

b. In the CustomSettings panel, specify the Id, Custom 1, Custom 2, and Custom 3

settings as desired.

6. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Deleting a UFM

Use this procedure to delete a UFM on a BTI7800 Series network element.

Prerequisites:

All components in the UFMmust be deleted before you can delete the UFM.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right-click a UFM and select Slot >Delete.

4. ClickOK in the Delete Slot confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Adding a BIC

Use this procedure to add a BTI Interface Card (BIC) to a UFM on a BTI7800 Series

network element.

NOTE: Not all UFMs support BICs.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs in that UFM.

4. Right-click an unprovisioned BIC and select BIC >Provision.

The Provision BIC dialog appears:
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Figure 45: BTI7800 Series Provision BIC

5. Configure the BIC as follows:

• Type Specify the type of BIC.

• PEC Select the PEC from the list of available PECs in the drop-downmenu. Only

the list of PECs for the specified type is shown.

• AdminStatusSpecifywhether the initial stateof themodule isUporDownorTesting.

6. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the CustomSettings tab.

b. In the CustomSettings panel, specify the Id, Custom 1, Custom 2, and Custom 3

settings as desired.

7. When you are finished, clickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.
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Editing a BIC

Use this procedure to edit an existing BTI Interface Card (BIC) on a UFM on a BTI7800

Series network element.

NOTE: Not all UFMs support BICs.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs in that UFM.

4. Right-click an existing BIC and select BIC >Edit.

The Edit BIC dialog appears.

Figure 46: BTI7800 Series Edit BIC

5. Edit the BIC as follows:
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• Type This field is read-only.

• PEC This field is read-only.

• Admin Status Change the state of the BIC to Up or Down or Testing.

6. Optionally, edit the Custom fields. These fields are for operator use and are opaque

to the system.

a. Click the CustomSettings tab.

b. In theCustomSettingspanel, edit the Id,Custom1,Custom2, andCustom3 settings

as desired.

7. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Cloning a BIC

Use this procedure to cloneanexistingBTI InterfaceCard (BIC) alongwith its provisioned

transceivers and interfaces on a UFM on a BTI7800 Series network element.

NOTE: Not all UFMs support BICs.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs in that UFM.

4. Right-click a provisioned BIC and select BIC >Clone.

The Clone Equipment dialog appears.
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Figure 47: BTI7800 Series Clone Equipment (BIC)

The Candidates pane shows the list of possible destinations to which the source BIC

can be cloned. Only those destinations that are unprovisioned and compatible with

the source BIC are shown. To be compatible, the target module must support the

cloned BIC type.

5. From the list of Candidates, use the arrow buttons to move one or more interfaces to

the Destinations pane.

NOTE: All provisioned transceivers and interfaces that belong to the
selected source BIC will be cloned as well.

6. When you are finished, click Apply.

The PSM server sends the configuration requests to the network element. You can

monitor the status of the requests through theView>Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the tasks complete

successfully.

Deleting a BIC

Use this procedure to delete a BTI Interface Card (BIC) on a UFM on a BTI7800 Series

network element.

Prerequisites:

All transceivers and interfaces for that BICmust be deleted before you can delete the

BIC.

NOTE: Not all UFMs support BICs.
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1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs in that UFM.

4. Right-click a provisioned BIC and select BIC >Delete.

5. ClickOK in the Delete BIC confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Adding a Transceiver

Use this procedure to add a transceiver to a BIC on a UFM or to a UFM directly.

NOTE: Integrated transceivers on some UFMs are added automatically.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs and/or ports in that UFM.

NOTE: Not all UFMs support BICs.

4. If you are adding a transceiver to a BIC, expand the BIC to show the ports for that BIC.

5. Right-click an unprovisioned port and select Transceiver >Provision.

The Provision Transceiver dialog appears:
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Figure 48: BTI7800 Series Provision Transceiver

6. Configure the transceiver as follows:

• Type Specify the type of transceiver from the drop-downmenu. This selection is

greyed out if it has already been pre-determined by the BIC type.

• Optical Format Select the optical format from the drop-downmenu.

• AdminStatusSpecifywhether the initial stateof themodule isUporDownorTesting.

7. Optionally, specify the Custom fields.

a. Click the CustomSettings tab. These fields are for operator use and are opaque to

the system.

b. In the CustomSettings panel, specify the Id, Custom 1, Custom 2, and Custom 3

settings as desired.

8. When you are finished, clickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.
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Editing a Transceiver

Use this procedure to edit an existing transceiver on a UFM port on a BTI7800 Series

network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs and/or ports in that UFM.

NOTE: Not all UFMs support BICs.

4. If you are editing a transceiver on a BIC, expand the BIC to show the ports for that BIC.

5. Right-click an existing port and select Transceiver >Edit.

The Edit Transceiver dialog appears.

Figure 49: BTI7800 Series Edit Transceiver
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6. Edit the transceiver as follows:

• Type This field is read-only.

• Optical Format This field is read-only.

• Admin Status Change the state of the module to Up or Down or Testing.

7. Optionally, edit the Custom fields.

a. Click the CustomSettings tab. These fields are for operator use and are opaque to

the system.

b. In theCustomSettingspanel, edit the Id,Custom1,Custom2, andCustom3 settings

as desired.

8. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Cloning a Transceiver

Use this procedure to clone an existing transceiver along with its provisioned interfaces

on a UFM on a BTI7800 Series network element.

NOTE: Integrated transceivers cannot be cloned.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs and/or ports in that UFM.

NOTE: Not all UFMs support BICs.

4. If you are cloning a transceiver on a BIC, expand the BIC to show the ports for that BIC.

5. Right-click a provisioned port and select Transceiver >Clone.

The Clone Equipment dialog appears:
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Figure 50: BTI7800 Series Clone Equipment (transceiver)

The Candidates pane shows the list of possible destinations to which the source

transceiver can be cloned. Only those destinations that are unprovisioned and

compatible with the source transceiver are shown. To be compatible, the source and

target transceiver must have the same BIC type.

6. From the list of Candidates, use the arrow buttons to move one or more interfaces to

the Destinations pane.

NOTE: All provisioned interfaces that belong to the selected source
transceiver will be cloned as well.

7. When you are finished, click Apply.

The PSM server sends the configuration requests to the network element. You can

monitor the status of the requests through theView>Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the tasks complete

successfully.

Deleting a Transceiver

Use thisprocedure todeletea transceiveronaUFMonaBTI7800Seriesnetworkelement.

Prerequisites:

All interfaces for that transceiver must be deleted before you can delete the transceiver.

NOTE: You cannot delete an integrated transceiver.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.
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3. Expand a UFM to show the BICs and/or ports in that UFM.

NOTE: Not all UFMs support BICs.

4. If you are deleting a transceiver on a BIC, expand the BIC to show the ports for that

BIC.

5. Right-click a provisioned port and select Transceiver >Delete.

6. ClickOK in the Delete Transceiver confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Adding an Interface

Use this procedure to add an interface to a UFM port on a BTI7800 Series network

element.

Before you can add an interface, youmust add the associated transceiver first.

NOTE: Interfaceparametersvarybetween interface types.Someparameters
appear only for some interface types.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs and/or ports in that UFM.

NOTE: Not all UFMs support BICs.

4. If you are adding an interface to a BIC, expand the BIC to show the ports for that BIC.

5. Right-click a provisioned port and select Interface >Provision.

The Provision Interface dialog appears. For example:
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Figure 51: BTI7800 Series Provision Interface (OTU4)

199Copyright © 2019, Juniper Networks, Inc.

Chapter 8: Nodal Management



Figure 52: BTI7800 Series Provision Interface (Optical Channel)

NOTE: UFM6 client interfaces:

The UFM6QSFP+ client-side transceiver supports up to four 10G client
interfaces. Client interfaces are created sequentially. To create the next
client interface, repeat step 5 on the same client port.

The UFM6QSFP28 client-side transceiver supports a single 100G client
interface.

There are restrictions on how client-side transceivers are installed and
consequently how interfaces can be configured on the UFM6. See the
BTI7800 Series Software Configuration Guide for details.
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NOTE: UFM6 line interfaces:

TheUFM6400GCoherentMSAXCVRsupports up to twooptical channel
(OCH) interfaces. Each OCH interface is associated with a physical line
port on the faceplate. When you create an OCH interface, you specify the
association to this line port (also known as a Fiber Port or subport). To

create the other OCH interface, repeat step 5 and associate the OCH
interface to the other line port. Each OCH interface (that is, each physical
line port you see on the faceplate) supports up to two OTU4 tributary
interfaces. To create anOTU4 tributary interface, right-click a provisioned
OCH interfaceandselect Interface>Provision. Repeat tocreate thesecond

OTU4 tributary interface.

There are restrictions on how line interfaces can be configured on the
UFM6. See the BTI7800 Series Software Configuration Guide for details.

NOTE: TheUFM6OTU4 tributary interface configuration is different from
theOTU4 interface configuration on the other UFMs. Some physical layer
parameters can only be configured on the containing OCH interface and
noton the individualOTU4tributary interfaces.This isbecausebothOTU4
tributary interfaces are driven from the same set of optics.

6. Configure the general interface attributes:

• Type Specify the interface type from the drop-downmenu.

NOTE: When you add an OTU interface, the BTI7800 automatically
creates a corresponding ODU interface. You cannot add an ODU
interface directly.

• Enabled Select to enable the interface after provisioning.

• IfIndex This is read-only. It is displayed after you add the interface.

7. Configure the auto in-service attributes:

• Enabled Enable or disable the auto in-service timer.

• Timer Specify the timer value.

8. Configure the protocol attributes. Protocol attributes vary depending on the protocol.
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Table 20: OTU Protocol Attributes

DescriptionAttribute

Specify the type of Forward Error Correction (FEC) from the drop-downmenu.
For UFM6 OTU interfaces within an optical channel, the FEC is set within the
optical channel (OCH) interface configuration.

FEC

Specify the delta Q factor difference threshold (dB) between X and Y
polarization states.

This attribute represents the threshold at which the Transmitter Degrade
(transmitterDegrade) alarm is raised for OTU4 interfaces.

Delta-Q

Set the signal degrade threshold for a 1-second interval. When the percentage
of errored blocks within a 1-second interval reaches this value, the interval is
considered a degraded interval. The valid range is 1 to 100 (percent) inclusive.

Degraded Threshold Per Second

Set the signal degrade fault threshold. When the number of consecutive
degraded 1-second intervals reaches this value, a signal degrade fault is raised.
Valid values are 0 (no fault is raised) and 2 through 10 (seconds) inclusive.

Seconds Degraded For Fault

Specify the trace message that is expected to be received.Expected Trace

This is the trace message that is to be transmitted. It cannot be changed.Tx Trace

This is the trace message that has been received. It cannot be changed. This
attribute is only available on some transceivers.

Rx Trace

Table 21: ODU Protocol Attributes

DescriptionAttribute

Specify GMP_CAPABLE if you want the interface to bemultiplexed, or specify
NO_MULTIPLEX if you do not want multiplexing. For more information, see
“Configuring a Multiplexed Interface” on page 211.

This attribute can only be changed for ODU4 interfaces. For other ODU
interfaces, this attribute is set to NO_MULTIPLEX and cannot be changed.

Multiplex

Table 22: SONET/SDH Protocol Attributes

DescriptionAttribute

Specify the trace message that is expected to be received.Expected Trace

Set the signal degrade fault threshold. When the threshold is set to x, a signal
degrade fault is raised when the bit error rate exceeds 10 x 10-x. Valid values
are 0 (no fault is raised) and 3 through 11 inclusive.

SD-THR

Specify either ASYNCHRONOUS or BIT_SYNCHRONOUS to indicate how the
SONET/SDH signal maps into the ODU payload.

Mapping
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Table 23: Ethernet Protocol Attributes

DescriptionAttribute

There are no protocol attributes specific to Ethernet.

Table 24: Fibre Channel Protocol Attributes

DescriptionAttribute

There are no protocol attributes specific to fibre channel.

9. Configure the physical or OCH attributes.

Someof theseattributes canonlybeconfigured if theEnabledcheckbox is unchecked

in the General attributes section.

Table 25: Physical Attributes

DescriptionAttribute

Specify the grid spacing from the drop-downmenu. The grid spacing can only
be specified for tunable transceivers.

If you are editing an existing interface, youmust disable the interface before
you can change this attribute.

Grid

Specify either thedesiredwavelengthor thedesired frequency. Thewavelength
or frequency can only be specified for tunable transceivers.

If you are editing an existing interface, youmust disable the interface before
you can change this attribute.

Wavelength or Frequency

Select the type of loopback, if any, from the drop-downmenu. This attribute
can only be set if the Enabled check box is unchecked in the General attributes
section. If the Enabled check box is selected, this value automatically changes
to NO_LOOPBACK.

Loopback

Select the carrier phase recovery window size from the drop-downmenu. This
attribute is not applicable to all transceiver types.

If you are editing an existing interface, youmust disable the interface before
you can change this attribute.

CPRWS

Select to enable the transmit laser after provisioning. Uncheck to disable the
transmit laser.

Laser Enabled

Select to enable Fault Propagation Shutdown (FPSD). When a failure occurs
and FPSD is enabled, the interface shuts down its laser instead of transmitting
amaintenance signal.

This attribute is only available for selection for Ethernet interfaces.

FPSD
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Table 26: UFM6Optical Channel (OCH) Attributes

DescriptionAttribute

Specify the grid spacing from the drop-downmenu.

If you are editing an existing interface, youmust disable the interface before
you can change this attribute.

Grid

Specify the channel, the desired wavelength, or the desired frequency. The
channel number automatically determines the wavelength and frequency.

If you are editing an existing interface, youmust disable the interface before
you can change this attribute.

Channel Name orWavelength or Frequency

Select the fiber port (also known as the subport).

This attribute can only be selected when adding an interface. You cannot
change this attribute for an existing interface.

Fiber Port

Select the carrier phase recovery window size from the drop-downmenu.

If you are editing an existing interface, youmust disable the interface before
you can change this attribute.

CPRWS

Select either 16-qam or qpskmodulation. If you select 16-qam, the optical
channel containsup to twoOTU4signals. If you selectqpsk, theoptical channel
contains one OTU4 signal.

This attribute can only be selected when adding an interface. You cannot
change this attribute for an existing interface.

NOTE: In order to interwork with OTU4 signals on UFM3 and UFM4 line ports,
youmust configure the UFM6 optical channel for qpskmodulation.

Modulation

Specify the transmit power.Tx-Power

Specify the type of Forward Error Correction (FEC) from the drop-downmenu.

The line coding is automatically set based on the FEC setting. If you select
SDFEC_25, the line coding is automatically set to non-differential. If you select
SDFEC, the line coding is automatically set to differential.

FEC

Specify the delta Q factor difference threshold (dB) between X and Y
polarization states.

This attribute represents the threshold at which the Transmitter Degrade
(transmitterDegrade) alarm is raised for OCH interfaces.

Delta-Q

10. Optionally, select LLDP snooping. LLDP snooping allows the BTI7800 to snoop LLDP

frames on an Ethernet interface to determine the identity of the attached device.

11. Optionally, configure PRBS (pseudorandom binary sequence) generation.
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Set PRBSMode to NO_PRBS or EGRESS or INGRESS as desired. Not all options are

supported for some protocols. This attribute can only be set to EGRESS or INGRESS

if the Enabled check box is unchecked in the General attributes section.

12. Optionally, specify the Custom fields.

a. Click the Custom tab. These fields are for operator use and are opaque to the

system.

b. In the Custom panel, specify the Id, Custom 1, Custom 2, and Custom 3 settings as

desired.

13. When you are finished, clickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Editing an Interface

Use this procedure to edit an existing interface on a UFM on a BTI7800 Series network

element.

NOTE: Interfaceparametersvarybetween interface types.Someparameters
appear only for some interface types.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs and/or ports in that UFM.

NOTE: Not all UFMs support BICs.

4. If you are editing an interface on a BIC, expand the BIC to show the ports for that BIC.

5. Expand a port to show the interfaces for that port.

6. If applicable, expand an interface to show the sub-interfaces for that interface.

7. Right-click a provisioned interface (or sub-interface) and select Interface >Edit.

The Edit Interface dialog appears. For example:
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Figure 53: BTI7800 Series Edit Interface (OTU4)
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Figure 54: BTI7800 Series Edit Interface (Optical Channel)

NOTE: In order to view or edit an OTU4 tributary interface on a UFM6 line
port, expand the OCH interface to show the OTU4 tributary interfaces on
that OCH interface.

8. Edit the general interface attributes:

• Type This field can only be changed if you are changing between amultiplexed

ODU2 sub-interface and amultiplexed ODU2e sub-interface on supported UFMs.

Otherwise it is read-only.

• Enabled Select to enable the interface. Uncheck to disable the interface.

• IfIndex This is read-only.

9. Edit the auto in-service attributes:

• Enabled Enable or disable the auto in-service timer.

• Timer Edit the timer value.

10. Edit the protocol attributes. Protocol attributes vary depending on the protocol.
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Table 27: OTU Protocol Attributes

DescriptionAttribute

Specify the type of Forward Error Correction (FEC) from the drop-downmenu.
For UFM6 OTU interfaces within an optical channel, the FEC is set within the
optical channel (OCH) interface configuration.

FEC

Specify the delta Q factor difference threshold (dB) between X and Y
polarization states.

This attribute represents the threshold at which the Transmitter Degrade
(transmitterDegrade) alarm is raised for OTU4 interfaces.

Delta-Q

Set the signal degrade threshold for a 1-second interval. When the percentage
of errored blocks within a 1-second interval reaches this value, the interval is
considered a degraded interval. The valid range is 1 to 100 (percent) inclusive.

Degraded Threshold Per Second

Set the signal degrade fault threshold. When the number of consecutive
degraded 1-second intervals reaches this value, a signal degrade fault is raised.
Valid values are 0 (no fault is raised) and 2 through 10 (seconds) inclusive.

Seconds Degraded For Fault

Specify the trace message that is expected to be received.Expected Trace

This is the trace message that is to be transmitted. It cannot be changed.Tx Trace

This is the trace message that has been received. It cannot be changed. This
attribute is only available on some transceivers.

Rx Trace

Table 28: ODU Protocol Attributes

DescriptionAttribute

Specify GMP_CAPABLE if you want the interface to bemultiplexed, or specify
NO_MULTIPLEX if you do not want multiplexing. For more information, see
“Configuring a Multiplexed Interface” on page 211.

This attribute can only be changed for ODU4 interfaces. For other ODU
interfaces, this attribute is set to NO_MULTIPLEX and cannot be changed.

Multiplex

Table 29: SONET/SDH Protocol Attributes

DescriptionAttribute

Specify the trace message that is expected to be received.Expected Trace

Set the signal degrade fault threshold. When the threshold is set to x, a signal
degrade fault is raised when the bit error rate exceeds 10 x 10-x. Valid values
are 0 (no fault is raised) and 3 through 11 inclusive.

SD-THR

Specify either ASYNCHRONOUS or BIT_SYNCHRONOUS to indicate how the
SONET/SDH signal maps into the ODU payload.

Mapping
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Table 30: Ethernet Protocol Attributes

DescriptionAttribute

There are no protocol attributes specific to Ethernet.

Table 31: Fibre Channel Protocol Attributes

DescriptionAttribute

There are no protocol attributes specific to fibre channel.

11. Edit the physical or OCH attributes.

Some of these attributes can only be configured if the interface is disabled. When

changing an attribute that requires the interface to be disabled, follow these steps:

• Disable the interface by unchecking Enabled in the General attributes section.

• Change the desired attributes and click Apply to apply the changes to the network

element.

• After the changes are reflected in PSM, edit the interface again, re-select Enabled

in the General attributes section, and click Apply.

Table 32: Physical Attributes

DescriptionAttribute

Specify the grid spacing from the drop-downmenu. The grid spacing can only
be specified for tunable transceivers.

If you are editing an existing interface, youmust disable the interface before
you can change this attribute.

Grid

Specify either thedesiredwavelengthor thedesired frequency. Thewavelength
or frequency can only be specified for tunable transceivers.

If you are editing an existing interface, youmust disable the interface before
you can change this attribute.

Wavelength or Frequency

Select the type of loopback, if any, from the drop-downmenu. This attribute
can only be set if the Enabled check box is unchecked in the General attributes
section. If the Enabled check box is selected, this value automatically changes
to NO_LOOPBACK.

Loopback

Select the carrier phase recovery window size from the drop-downmenu. This
attribute is not applicable to all transceiver types.

If you are editing an existing interface, youmust disable the interface before
you can change this attribute.

CPRWS

Select to enable the transmit laser after provisioning. Uncheck to disable the
transmit laser.

Laser Enabled
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Table 32: Physical Attributes (continued)

DescriptionAttribute

Select to enable Fault Propagation Shutdown (FPSD). When a failure occurs
and FPSD is enabled, the interface shuts down its laser instead of transmitting
amaintenance signal.

This attribute is only available for selection for Ethernet interfaces.

FPSD

Table 33: UFM6Optical Channel (OCH) Attributes

DescriptionAttribute

Specify the grid spacing from the drop-downmenu.

If you are editing an existing interface, youmust disable the interface before
you can change this attribute.

Grid

Specify the channel, the desired wavelength, or the desired frequency. The
channel number automatically determines the wavelength and frequency.

If you are editing an existing interface, youmust disable the interface before
you can change this attribute.

Channel Name orWavelength or Frequency

Select the fiber port (also known as the subport).

This attribute can only be selected when adding an interface. You cannot
change this attribute for an existing interface.

Fiber Port

Select the carrier phase recovery window size from the drop-downmenu.

If you are editing an existing interface, youmust disable the interface before
you can change this attribute.

CPRWS

Select either 16-qam or qpskmodulation. If you select 16-qam, the optical
channel containsup to twoOTU4signals. If you selectqpsk, theoptical channel
contains one OTU4 signal.

This attribute can only be selected when adding an interface. You cannot
change this attribute for an existing interface.

NOTE: In order to interwork with OTU4 signals on UFM3 and UFM4 line ports,
youmust configure the UFM6 optical channel for qpskmodulation.

Modulation

Specify the transmit power.Tx-Power

Specify the type of Forward Error Correction (FEC) from the drop-downmenu.

The line coding is automatically set based on the FEC setting. If you select
SDFEC_25, the line coding is automatically set to non-differential. If you select
SDFEC, the line coding is automatically set to differential.

FEC
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Table 33: UFM6Optical Channel (OCH) Attributes (continued)

DescriptionAttribute

Specify the delta Q factor difference threshold (dB) between X and Y
polarization states.

This attribute represents the threshold at which the Transmitter Degrade
(transmitterDegrade) alarm is raised for OCH interfaces.

Delta-Q

12. Optionally, select LLDP snooping. LLDP snooping allows the BTI7800 to snoop LLDP

frames on an Ethernet interface to determine the identity of the attached device.

13. Optionally, configure PRBS (pseudorandom binary sequence) generation.

Set PRBSMode to NO_PRBS or EGRESS or INGRESS as desired. Not all options are

supported for some protocols. This attribute can only be set to EGRESS or INGRESS

if the Enabled check box is unchecked in the General attributes section.

14. Optionally, edit the Custom fields.

a. Click the Custom tab. These fields are for operator use and are opaque to the

system.

b. In the Custom panel, edit the Id, Custom 1, Custom 2, and Custom 3 settings as

desired.

15. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Configuring aMultiplexed Interface

Use this procedure to configure a multiplexed ODU interface on a UFM on a BTI7800

Series network element.

Prerequisites:

• The corresponding OTU interface is created.

NOTE: You do not need to create an ODU interface explicitly. An ODU
interface is automatically created when you create the corresponding OTU
interface.

Only some ODU interfaces can be configured for multiplexing.
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1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs and/or ports in that UFM.

NOTE: Not all UFMs support BICs.

4. If you are adding an interface to a BIC, expand the BIC to show the ports for that BIC.

5. Expand a port to show the OTU interfaces for that port.

6. Expand an OTU interface to see the corresponding ODU interface.

7. Right-click the ODU interface and select Interface >Edit.

The Edit Interface dialog appears.

Figure 55: BTI7800 Series Edit Interface (ODU4)
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8. To specify that this ODU interface can bemultiplexed into, select GMP-CAPABLE in

the ODUMultiplex field.

9. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Figure 56: ODU4 Interface with 10 ODU2 Sub-interfaces

NOTE: If you want to change one or more of the automatically-created
subinterfacesbetweenanODU2andanODU2e, thenedit thesubinterface
and change the interface type. For more information, see “Editing an
Interface” on page 205

Cloning an Interface

Use this procedure to clone an existing interface on a UFM on a BTI7800 Series network

element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs and/or ports in that UFM.

NOTE: Not all UFMs support BICs.

4. If you are adding an interface to a BIC, expand the BIC to show the ports for that BIC.

5. Expand a port to show the interfaces.

6. Right-click a provisioned interface and select Interface >Clone.

The Clone Equipment dialog appears:
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Figure 57: BTI7800 Series Clone Equipment (interface)

The Candidates pane shows the list of possible destinations to which the source

interfacecanbecloned.Only thosedestinations thatareunprovisionedandcompatible

with the source interfaceare shown.Tobecompatible, the sourceand target interfaces

must have the same BIC type and the same optical format (fixed/tunable).

7. From the list of Candidates, use the arrow buttons to move one or more interfaces to

the Destinations pane.

8. When you are finished, click Apply.

The PSM server sends the configuration requests to the network element. You can

monitor the status of the requests through theView>Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the tasks complete

successfully.

Deleting an Interface

Use thisprocedure todeletean interfaceonaUFMonaBTI7800Seriesnetworkelement.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs and/or ports in that UFM.

NOTE: Not all UFMs support BICs.

4. If you are deleting an interface on a BIC, expand the BIC to show the ports for that

BIC.

5. Expand a port to show the interfaces for that port.
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NOTE: In order to delete anOTU4 tributary interface on aUFM6 line port,
expand the OCH interface to show the OTU4 tributary interfaces on that
OCH interface.

6. Right-click a provisioned interface and select Interface >Delete.

7. ClickOK in the Delete Interface confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree view a short while after the task completes

successfully.

Viewing Interface PMs on a UFM

Use this procedure to view current interface PMs on a UFM on a BTI7800 Series network

element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs and/or ports in that UFM.

NOTE: Not all UFMs support BICs.

4. If you are adding an interface to a BIC, expand the BIC to show the ports for that BIC.

5. Expand a port to show the interfaces.

6. Right-click a provisioned interface and select Interface PMs >View.

The Interface Current PMwindow appears:
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The PMs are listed for the interface selected.

NOTE: This window shows a snapshot of the PM counts. The counts do
not update automatically in this window. To see the latest counts, click
the Refresh button.

7. To select what columns to display, right-click anywhere in the headings row to bring

up a column selection window.

Check or uncheck column headings as desired.

8. To sort the PMs based on column values, click on the column heading that you want

to sort.

9. To export the PM data to a CSV file, click Export and save the file.

Provisioning a ROADMNode on a BTI7800

The following sections describe how to provision a ROADM node and how to perform

other ROADM-related tasks on a BTI7800.

• General Provisioning Procedure on page 217

• Adding a ROADM or an ILA Module on page 218

• Editing a ROADM or an ILA Module on page 219

• Deleting a ROADM or an ILA Module on page 220

• Adding a PREModule on page 220

• Editing a PREModule on page 221

• Deleting a PREModule on page 222

• Adding or Viewing amultiplexer/demultiplexer on page 222

• Deleting amultiplexer/demultiplexer on page 225

• Editing a Port on page 225
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• Editing the OMS on page 226

• Editing the OSC on page 227

• Adding a Fiber Connection on a ROADM or an ILA Client Port on page 227

• Editing a Fiber Connection on a ROADM or an ILA Client Port on page 228

• Deleting a Fiber Connection on a ROADM or an ILA Client Port on page 229

• Adding a Fiber Connection on a ROADM or an ILA Line Port on page 230

• Editing a Fiber Connection on a ROADM or an ILA Line Port on page 231

• Deleting a Fiber Connection on a ROADM or an ILA Line Port on page 231

• Adding a Fiber Connection on a UFM Interface on page 232

• Editing a Fiber Connection on a UFM Interface on page 233

• Deleting a Fiber Connection on a UFM Interface on page 233

• Viewing Fiber Connections on page 234

• Adding an Optical Channel on page 234

• Bulk Adding Optical Channels on page 235

• Editing an Optical Channel on page 237

• Deleting an Optical Channel on page 238

• Viewing Port PMs on a ROADM Element on page 238

• Viewing OMS PMs on a ROADM Element on page 239

• Viewing OSC PMs on a ROADM Element on page 240

• Viewing Optical Channel PMs on a ROADM Element on page 240

General Provisioning Procedure

The procedure for provisioning a ROADM node can be summarized as follows:

1. Provision all requiredmodules. This is covered in sections “Adding a ROADMor an ILA

Module” onpage218 through “Editing theOSC”onpage227. It is usually not necessary

for you to perform this step explicitly because the BTI7800 automatically provisions

modules when themodules are physically installed. This is called auto-provisioning.

2. Provision all required fiber connections. This is covered in sections “Adding a Fiber

Connection on a ROADM or an ILA Client Port” on page 227 through “Viewing Fiber

Connections” onpage234. Fiber connections represent thephysical fiber connectivity

within a ROADM node and across ROADM nodes. Auto-provisioning provisions fiber

connections when the fibers are physically installed, so it is usually not necessary for

you to perform this step explicitly either.

3. Provision the optical channels that make up the optical service. This is covered in

sections“AddinganOpticalChannel”onpage234through“DeletinganOpticalChannel”

on page 238. An optical channel is a user-traffic-bearing bidirectional channel that is

defined by its central frequency (wavelength) and bandwidth. It is cross-connected

within the node as part of an overall optical service. Optical channels exist on both
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ROADMmodule line ports and ROADMmodule client ports, but you only need to

explicitly create optical channels on the ROADMmodule line ports.

4. Provision the optical channel cross-connects. This is part of service activation and is

covered in “Activating an Optical Service in a BTI7800 Network” on page 319. When

using PSM service activation, you just select the endpoints. PSMwill create all the

necessary cross-connects in the service path from end to end.

For information on auto-provisioning, see the BTI7800 Series Software Configuration

Guide.

Adding a ROADMor an ILAModule

Use this procedure to add a new ROADM or ILAmodule on a BTI7800 Series network

element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right-click an unprovisioned slot and select Slot >Provision to add amodule in that

slot.

The Provision Slot dialog appears.

4. Configure the slot as follows:

• PECSelect aROADMor an ILAPEC from the list of available PECs in the drop-down

menu.

• Admin Status Specify the initial state of the module as Up or Down or Testing.

5. Optionally, specify the Custom fields. These fields are for operator use and are not

used by the system.

a. Click the Custom tab.

b. In the Custom panel, specify the Custom 1, Custom 2, and Custom 3 settings as

desired.

6. When you are finished, clickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree a short while after the task completes

successfully.

Themodule is added along with its client, line, and PRE ports, and the respective OMS

and OSCwhere applicable.
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NOTE: The PREmodule itself is not automatically added. To add the PRE
module, see “Adding a PREModule” on page 220.

Editing a ROADMor an ILAModule

Use this procedure to edit a ROADM or an ILAmodule on a BTI7800 Series network

element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right-click a ROADM or an ILAmodule and select Slot >Edit.

The Edit Slot dialog appears.

4. Configure the slot as follows:

• PEC This is read only.

• Admin Status Set the state of the module to Up, Down, or Testing.

5. Optionally, specify the Custom fields. These fields are for operator use and are not

used by the system.

a. Click the Custom tab.

b. In the Custom panel, specify the Custom 1, Custom 2, and Custom 3 settings as

desired.

6. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.
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Deleting a ROADMor an ILAModule

Use this procedure to delete a ROADM or an ILAmodule on a BTI7800.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right-click a ROADM or ILAmodule and select Slot >Delete.

4. ClickOK in the confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Adding a PREModule

Use this procedure to add a new PREmodule to a ROADM or ILA on a BTI7800 Series

network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right-click a ROADM or ILAmodule and select Preamplifier >Provision to add a PRE

module to the ROADM or ILA.

In the ensuing dialog, the PEC andOper Status cannot be changed.

4. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the Custom tab.

b. In the Custom panel, specify the Custom 1, Custom 2, and Custom 3 settings as

desired.

5. When you are finished, clickOK to add the PREmodule.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree a short while after the task completes

successfully.

The PREmodule and its port are added.
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Editing a PREModule

Use this procedure to edit a PREmodule on a BTI7800 Series network element.

Prerequisites:

• The PREmodule is created.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module is

Preamplifier: index, where the index is 1.

4. Right-click the preamplifier and select Preamplifier >Edit.

In the ensuing dialog, the PEC andOper Status cannot be changed.

5. Set the Custom fields as desired. These fields are for operator use and are opaque to

the system.

a. Click the Custom tab.

b. In the Custom panel, specify the Custom 1, Custom 2, and Custom 3 settings as

desired.

6. When you are finished, click Apply to apply the changes.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.
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Deleting a PREModule

Use this procedure to delete a PREmodule on a ROADM or ILA.

Prerequisites:

• The PREmodule is created.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module is

Preamplifier: index, where the index is 1.

4. Right-click the preamplifier and select Preamplifier >Delete.

5. ClickOK in the confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Adding or Viewing amultiplexer/demultiplexer

Use this procedure to view existing multiplexer/demultiplexers or to add a new one on

a BTI7800 Series network element.
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1. Right click a network element in the Network tree and select Node >Passive

>Mux/Demux >Edit

TheMux/Demuxwindow appears. This window shows a listing of the existing

multiplexer/demultiplexers on the shelf.

NOTE: The Group/Degree is not applicable to BTI7800 ROADM nodes.

2. Click on the plus icon to add a newmultiplexer/demultiplexer.

The ProvisionMux/Demuxwindow appears.
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3. Specify the Slot for the multiplexer/demultiplexer.

4. Select a PEC from the list of available PECs.

5. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the Custom tab.

b. In the Custom panel, specify the Id, Custom 1, Custom 2, and Custom 3 settings as

desired.

6. When you are finished, click Apply.

The newly addedmultiplexer/demultiplexer appears in theMux/Demuxwindow.

7. ClickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.
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Deleting amultiplexer/demultiplexer

Use this procedure to delete a multiplexer/demultiplexer on a BTI7000 Series network

element.

1. Right click a network element in the Network tree and select Node >Passive

>Mux/Demux >Edit

TheMux/Demuxwindow appears.

2. Select a multiplexer/demultiplexer and click on theminus icon to delete it.

The selectedmultiplexer/demultiplexer disappears from the window.

3. ClickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Editing a Port

Use this procedure to edit a port on a ROADM, ILA, or PREmodule on a BTI7800 Series

network element.

All ports on amodule are automatically added when you add themodule.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module, or expand the

preamplifier to see the port on the PREmodule.

5. Expand thedesired client, line, orPREport container, right-clickPortandselectOptical

Port >Edit

6. Specify the Id and Custom fields as desired. These fields are for operator use and are

opaque to the system.

7. When you are finished, click Apply to apply the changes.
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The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Editing the OMS

Use this procedure to edit the Optical Multiplex Section (OMS) on a ROADM or an ILA

client or line port on a BTI7800 Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Expand the desired client or line port container to see the OMS for that port.

6. Right-clickOMS and selectOMS>Edit

The Edit OMS dialog appears.

7. Configure the OMS as follows:

• Oper Status The operational status is read only.

• Admin Status Specify whether the OMS state is In-Service orOut-Of-Service or

Testing.

• Preamplifier State Specify whether the preamplifier is Enabled or Disabled. This is

only applicable for line ports. Client ports do not have a preamplifier.

8. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the Custom tab.

b. In the Custom panel, specify the Id, Custom 1, Custom 2, and Custom 3 settings as

desired.

9. When you are finished, click Apply to apply the changes.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.
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Editing the OSC

Use this procedure to edit the Optical Service Channel (OSC) on a ROADM or an ILA

client or line port on a BTI7800 Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Expand the desired client or line port container to see the OSC for that port.

6. Right-clickOSC and selectOSC >Edit

The Edit OSC dialog appears.

7. Configure the OSC as follows:

• Oper Status The operational status is read only.

• Admin Status Specify whether the OSC state is In-Service orOut-Of-Service.

8. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the Custom tab.

b. In the Custom panel, specify the Id, Custom 1, Custom 2, and Custom 3 settings as

desired.

9. When you are finished, click Apply to apply the changes.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Adding a Fiber Connection on a ROADMor an ILA Client Port

Use this procedure to add a fiber connection on a ROADM or an ILA client port on a

BTI7800 Series network element.

Fiber connections are mandatory. All fiber connections must exist before you can create

an optical service.
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1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Right-click the desired client port container and select Fiber Connection >Provision.

The Provision Fiber Connection dialog appears, listing all client ports in the network.

6. Select the other end of the fiber connection.

For a ROADM client port, the other end can be amultiplexer/demultiplexer line port

or another ROADM client port. To create a split ROADM node, configure a fiber

connection between ROADM client ports on two different network elements.

For an ILA client port, the other end can be another ILA client port.

7. When you are finished, clickOK to create the fiber connection.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Editing a Fiber Connection on a ROADMor an ILA Client Port

Use this procedure to edit a fiber connection on a ROADM or an ILA client port on a

BTI7800 Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.
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3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Right-click the desired client port container and select Fiber Connection >Edit.

6. Configure the fiber connection as follows:

• Port The port at the other end of the fiber connection. This is read only.

• IP Address The IP address of the NE at the other end of the fiber connection. For a

regular ROADM node, this is the local IP address. For a split ROADM node, this is

the IP address of the NE at the other end of the fiber.

• FEMonitoring Check to enable far endmonitoring. Uncheck to disable far end

monitoring. When far endmonitoring is enabled, the BTI7800 checks to see if the

configured fiber connection matches the actual physical fiber connection. If there

is a mismatch, an alarm is raised.

• Fiber Type This is not applicable to client ports.

7. When you are finished, clickOK to apply the changes.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Deleting a Fiber Connection on a ROADMor an ILA Client Port

Use this procedure to delete a fiber connection on a ROADM or an ILA client port on a

BTI7800 Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Right-click the desired client port container and select Fiber Connection >Delete.

6. ClickOK in the confirmation dialog.
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The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Adding a Fiber Connection on a ROADMor an ILA Line Port

Use thisprocedure toadda fiber connectiononaROADMoran ILA lineport onaBTI7800

Series network element.

Fiber connections are mandatory. All fiber connections must exist before you can create

an optical service.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Right-click the line port container and select Fiber Connection >Provision.

The Provision Fiber Connection dialog appears, listing all line ports in the network.

6. Select the other end of the fiber connection.

For a ROADM line port, the other end can be a ROADM or ILA line port.

For an ILA line port, the other end can be a ROADM or ILA line port.

7. When you are finished, clickOK to create the fiber connection.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.
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Editing a Fiber Connection on a ROADMor an ILA Line Port

Use thisprocedure toedit a fiber connectiononaROADMoran ILA lineport onaBTI7800

Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Right-click the line port container and select Fiber Connection >Edit.

6. Configure the fiber connection as follows:

• Port The port at the other end of the fiber connection. This is read only.

• IP Address The IP address of the NE at the other end of the fiber connection.

• FEMonitoring Check to enable far endmonitoring. Uncheck to disable far end

monitoring. When far endmonitoring is enabled, the BTI7800 checks to see if the

configured fiber connection matches the actual physical fiber connection. If there

is a mismatch, an alarm is raised.

• Fiber Type Select the fiber type from the pulldownmenu.

7. When you are finished, clickOK to apply the changes.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Deleting a Fiber Connection on a ROADMor an ILA Line Port

Use this procedure to delete a fiber connection on a ROADM or an ILA line port on a

BTI7800 Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.
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4. Expand themain module to see the ports on themain module.

5. Right-click the line port container and select Fiber Connection >Delete.

6. ClickOK in the confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Adding a Fiber Connection on a UFM Interface

Use this procedure to add a fiber connection on a UFM interface on a BTI7800 Series

network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to see the BICs on the UFM.

4. Expand a BIC to see the ports on the BIC.

5. Expand a port to see the interface on the port.

6. Right-click an interface and select Fiber Connection >Provision.

The Fiber Connection dialog appears.

7. From the pulldownmenu, select the other end of the fiber connection.

Theotherendshouldbeamultiplexer/demultiplexer clientportat thesamefrequency

as the interface.

8. When you are finished, clickOK to create the fiber connection.
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The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Editing a Fiber Connection on a UFM Interface

Use this procedure to edit a fiber connection on a UFM interface on a BTI7800 Series

network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to see the BICs on the UFM.

4. Expand a BIC to see the ports on the BIC.

5. Expand a port to see the interface on the port.

6. Right-click an interface and select Fiber Connection >Edit.

7. Configure the fiber connection as follows:

• Port The port at the other end of the fiber connection. This is read only.

• IP Address The IP address of the NE at the other end of the fiber connection. For a

UFM interface, this is the local IP address since the other end is on the same node.

• FEMonitoring Check to enable far endmonitoring. Uncheck to disable far end

monitoring. When far endmonitoring is enabled, the BTI7800 checks to see if the

configured fiber connection matches the actual physical fiber connection. If there

is a mismatch, an alarm is raised.

• Fiber Type This is not applicable to UFM interfaces.

8. When you are finished, clickOK to apply the changes.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Deleting a Fiber Connection on a UFM Interface

Use this procedure to delete a fiber connection on a UFM interface on a BTI7800 Series

network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.
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3. Expand a UFM to see the BICs on the UFM.

4. Expand a BIC to see the ports on the BIC.

5. Expand a port to see the interface on the port.

6. Right-click an interface and select Fiber Connection >Delete.

7. ClickOK in the confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Viewing Fiber Connections

Use this procedure to view all fiber connections on a network element.

1. Right-click a network element in the Network tree or in the Topology Map view and

select Node >Fiber Connection >View.

The Fiber Connectionwindow appears:

2. ClickOK to close the window.

Adding an Optical Channel

Use this procedure to add an optical channel on a ROADM line port on a BTI7800 Series

network element.

You only add optical channels to line ports. Optical channels on client ports are

automatically added when you create and activate an optical service.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.
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3. Expand a ROADMmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Expand the line port container.

6. Right-click Channel and select Provision >Single

The och dialog appears.

7. Configure the optical channel as follows:

• ID Specify the channel identifier. This must be unique for the port.

• Bandwidth Specify the bandwidth of the channel. This is the grid spacing.

• Channel Name Specify the channel name. When this field is changed, Frequency

andWavelength are automatically changed to be consistent with this value.

• Wavelength Specify the central wavelength of the channel. When this field is

changed, FrequencyandChannelNameare automatically changed to be consistent

with this value.

• FrequencySpecify the central frequency of the channel.When this field is changed,

Channel Name andWavelength are automatically changed to be consistent with

this value.

• Enable Check to enable the ODCC. Uncheck to disable the ODCC.

• Admin Status Specify whether the optical channel state is In-Service or

Out-Of-Service or Testing.

• Oper Status The operational status is read only.

8. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the Custom tab.

b. In the Custom panel, specify the Id, Custom 1, Custom 2, and Custom 3 settings as

desired.

9. When you are finished, click Apply to apply the changes.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Bulk Adding Optical Channels

Use this procedure to add optical channels in bulk on a ROADM line port on a BTI7800

Series network element.

235Copyright © 2019, Juniper Networks, Inc.

Chapter 8: Nodal Management



Whenyouuse thismethodtocreateoptical channels,PSMautomatically sets theChannel

ID for the created optical channels to the Channel Name, which is derived from the

frequency that you specify. Addtionally, PSMsets theAdminStatusof the createdoptical

channels to In-Service.

If you want to set a different Channel ID or Admin Status, then you should not use this

method to create optical channels.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADMmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Expand the line port container.

6. Right-click Channel and select Provision >Bulk

The Bulk OCH Provisioning dialog appears.

7. Select from the Available frequencies list andmove to the Destinations list.

You can select one, multiple, or all frequencies.

8. When you are finished, click Apply to create the optical channels.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.
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Editing an Optical Channel

Use this procedure to edit an optical channel on a ROADM line port on a BTI7800 Series

network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADMmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Expand the line port container.

6. Expand Channel to see the channels.

7. Right-click a channel and select Channel >Edit

8. Configure the optical channel as follows:

• ID This is read only.

• Bandwidth This is read only.

• Channel Name This is read only.

• Wavelength This is read only.

• Frequency This is read only.

• Enable Check to enable the ODCC. Uncheck to disable the ODCC.

• Admin Status Specify whether the optical channel state is In-Service or

Out-Of-Service or Testing.

• Oper Status This is read only.

9. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the Custom tab.

b. In the Custom panel, specify the Id, Custom 1, Custom 2, and Custom 3 settings as

desired.

10.When you are finished, click Apply to apply the changes.
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The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Deleting an Optical Channel

Use this procedure to delete an optical channel on a ROADM line port on a BTI7800

Series network element.

Optical channels that are part of an existing service cannot be deleted.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADMmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Expand the line port container.

6. Expand Channel to see the channels.

7. Right-click a channel and select Channel >Delete

8. ClickOK in the confirmation dialog.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Viewing Port PMs on a ROADMElement

Use thisprocedure toviewPMsonaROADM, ILA,orPREportonaBTI7800Seriesnetwork

element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.
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4. Expand themain module to see the ports on themain module, or expand the

preamplifier module to see the port on the PREmodule.

5. Expand thedesired client, line, orPREport container, right-clickPortandselectOptical

Port PMs >View

A snapshot of the current PMs is displayed.

6. To refresh the counters, click Refresh.

7. To select what columns to display, right-click anywhere in the headings row to bring

up a column selection window.

Check or uncheck column headings as desired.

8. To sort the PMs based on column values, click on the column heading that you want

to sort.

9. To save the counters to a CSV file, click Export.

Viewing OMSPMs on a ROADMElement

Use this procedure to view Optical Multiplexing Section (OMS) PMs on a ROADM or an

ILA client or line port on a BTI7800 Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Expand the desired client or line port container to see the OMS for that port.

6. Right-clickOMS and selectOMSPMs >View.

A snapshot of the current PMs is displayed.

7. To refresh the counters, click Refresh.

8. To select what columns to display, right-click anywhere in the headings row to bring

up a column selection window.
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Check or uncheck column headings as desired.

9. To sort the PMs based on column values, click on the column heading that you want

to sort.

10. To save the counters to a CSV file, click Export.

Viewing OSC PMs on a ROADMElement

Use this procedure to view Optical Service Channel (OSC) PMs on a ROADM or an ILA

client or line port on a BTI7800 Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADM or ILAmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Expand the desired client or line port container to see the OSC for that port.

6. Right-clickOSC and selectOSC PMs >View.

A snapshot of the current PMs is displayed.

7. To refresh the counters, click Refresh.

8. To select what columns to display, right-click anywhere in the headings row to bring

up a column selection window.

Check or uncheck column headings as desired.

9. To sort the PMs based on column values, click on the column heading that you want

to sort.

10. To save the counters to a CSV file, click Export.

Viewing Optical Channel PMs on a ROADMElement

Use this procedure to view optical channel PMs on a ROADM line port on a BTI7800

Series network element.
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1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a ROADMmodule.

Themain module isModule: index, where the index is0. The preamplifier module (if

present) is Preamplifier: index, where the index is 1.

4. Expand themain module to see the ports on themain module.

5. Expand line port container.

6. Expand Channel to see the channels.

7. Right-click a channel and select Channel PMs >View

A snapshot of the current PMs is displayed.

8. To refresh the counters, click Refresh.

9. To select what columns to display, right-click anywhere in the headings row to bring

up a column selection window.

Check or uncheck column headings as desired.

10. To sort the PMs based on column values, click on the column heading that you want

to sort.

11. To save the counters to a CSV file, click Export.

Provisioning a 96-Channel Amplifier on a BTI7800

The BTI7800 96-Channel Amplifier is provisioned as follows:

1. Add the amplifier module.

2. Create an optical group for the amplifier if the desired optical group does not already

exist.

3. Assign the amplifier to the optical group.

4. Edit the amplifier's port, WDM and OSC settings .

Adding an Amplifier

Use this procedure to adda96-Channel Amplifier on aBTI7800Series network element.
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1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right-click an unprovisioned slot and select Slot >Provision to add amodule in that

slot.

The Provision Slot dialog appears. This dialog might change depending on the PEC

that you select in the next step.

4. Configure the slot as follows:

• PEC Select the 96-Channel Amplifier PEC from the list of available PECs in the

drop-downmenu.

• AdminStatusSpecifywhether the initial stateof themodule isUporDownorTesting.

5. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the CustomSettings tab.

b. In the CustomSettings panel, specify the Id, Custom 1, Custom 2, and Custom 3

settings as desired.

6. When you are finished, clickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree a short while after the task completes

successfully.

You can now assign this amplifier to an existing optical group or create a new optical

group for this amplifier.

Creating an Optical Group for a BTI7800 Series Amplifier

Use this procedure to create an optical group for a 96-Channel Amplifier on a BTI7800

Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Right-click onOptical Groups and select Group/Degree >Provision.

The Provision Optical Group dialog appears:
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Figure 58: Provision Optical Group

3. Configure the group as follows:

• Group ID Specify the Group ID to distinguish the new group from the other optical

groups on the node.

• Group Type Specify the function for the group from the drop-downmenu. The only

group type supported for the BTI7800 is NON_EQUALIZING_TERM.

4. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the CustomSettings tab.

b. In the CustomSettings panel, specify the Id, Custom 1, Custom 2, and Custom 3

settings as desired.

5. When you are finished, clickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

optical group appears in the Network tree a short while after the task completes

successfully.
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Assigning or Unassigning an Amplifier

Use this procedure to assign a 96-Channel Amplifier to an optical group or to unassign

a 96-Channel Amplifier from an optical group on a BTI7800 Series network element.

1. Expand the network element in the Network tree.

2. Expand theOptical Groups to see the optical groups on that NE.

3. Right-click the optical group in which you want to assign the amplifier, and select

Group/Degree >Edit.

The Update Optical Group dialog appears.

The Group ID is set during optical group creation, and cannot be edited. The Group

Typemust be set to NON_EQUALIZING_TERM.

4. Assign or unassign amplifiers from the group.

• To assign an amplifier to the group, click on the plus icon. This brings you to the

Assign Optical Equipmentwindowwhere you can assign an amplifier. Click Apply

when you are done. The newly assigned amplifier appears in the Equipment list.
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• To unassign an amplifier, select the amplifier from the list and then click on the

minus icon. The unassigned amplifier is removed from the Equipment list.

5. Configure the Custom fields. These fields are for operator use and are opaque to the

system.

a. Click the CustomSettings tab.

b. In theCustomSettingspanel, edit the Id,Custom1,Custom2, andCustom3 settings

as desired.

6. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The

changes appear in PSM a short while after the task completes successfully.

Editing an Amplifier Port

Use this procedure to edit an amplifier port on a 96-Channel Amplifier on a BTI7800

Series network element.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. ExpandOptical Groups to show the optical groups in that NE.

3. Expand an optical group to show the degree in that group.

4. Expand a degree to show the amplifier associated with that degree.

5. Expand an amplifier to show the ports on that amplifier.

6. Right-click a port and selectOptical Port >Edit.

The Edit Optical Layer Port dialog appears.

7. Configure the optical port parameters as follows:

• State This is the operational state. It is read-only.

• DWDMType This is the type of DWDM composite signal expected on the port. It is

set to native. This is read-only.

• GridTypeThis is theDWDMgrid spacing for the port. If the equipment only supports

a specific grid spacing, then this field is read-only.

• Tx Loss Specify the optical loss in the transmit direction. Set to 0 for no loss.
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• AINS TimerOptionally, specify the auto-in-service timer.

• Active Countdown This is the countdown for the AINS timer. It is read-only.

8. Optionally, configure the Custom fields. These fields are for operator use and are

opaque to the system.

a. Click the CustomSettings tab.

b. In theCustomSettingspanel, edit the Id,Custom1,Custom2, andCustom3 settings

as desired.

9. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The

changes appear in PSM a short while after the task completes successfully.

EditingWDMParameters for an Amplifier

Use this procedure to edit WDM parameters on the line port of a 96-Channel Amplifier

on a BTI7800 Series network element.

1. Expand the network element in the Network tree.

2. ExpandOptical Groups to see the optical groups on that NE.

3. Expand an optical group to see the degree in that group.

4. Expand the degree to see the amplifier in that degree.

5. Right-click the amplifier and selectWDM>Edit.

The EditWDM dialog appears.
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Figure 59: Edit WDMDialog for a BTI7800 96-Channel Amplifier Module

6. Configure theWDM parameters as follows:

• Admin Status Select the state from the list of available states in the drop-down

menu.

• Oper Status This is the operational state. It is read-only.

• FiberTypeSpecify the fiber type fromthe list ofavailable fiber types in thedrop-down

menu.

• Loss Rx High Threshold Specify the span loss threshold beyond which an alarm is

raised. Set to 0 to disable.

• Length The span length is measured automatically. This is read-only.

• Amp Tilt Trim Set to fine tune the system gain tilt.

• Post AmpGain Set the system gain.

7. Configure the Custom fields. These fields are for operator use and are opaque to the

system.

a. Click the CustomSettings tab.
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b. In theCustomSettingspanel, edit the Id,Custom1,Custom2, andCustom3 settings

as desired.

8. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The

changes appear in PSM a short while after the task completes successfully.

Editing OSC Parameters for an Amplifier

Use this procedure to edit OSC parameters on the line port of a 96-Channel Amplifier

on a BTI7800 Series network element. The optical service channel (OSC) is used as a

communications medium for control information between amplifiers at both ends of a

line span.

1. Expand the network element in the Network tree.

2. Expand theOptical Groups to see the optical groups on that NE.

3. Expand an optical group to see the degree in that group.

4. Expand the degree to see the amplifier in that degree.

5. Right-click the amplifier and selectOSC >Edit.

The Edit OSC dialog appears.
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Figure 60: Edit OSC Dialog for a BTI7800 96-Channel Amplifier Module

6. Configure the OSC parameters as follows:

• Admin Status Select the state from the list of available states in the drop-down

menu.

• Oper Status This is the operational state. It is read-only.

• FE IMMonSelect if youwant the near end to validate the identity of the far endwith

the expected far end parameters. If the identity does not match, the systemwill

raise an alarm or condition.

• SystemName (expected) Set to the expected system name of the far end.

• IP Address (expected) Set to the expectedmanagement IP address of the far end.

• Group (expected) Set to the expected optical group identifier of the far end.

• Degree (expected) Set to the expected optical degree of the far end.

• SystemName (actual) This is the actual system name of the far end. It is read-only.

• IP Address (actual) This is the actual management IP address of the far end. It is

read-only.

• Group(actual)This is theactual optical group identifier of the far end. It is read-only.
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• Degree (actual) This is the actual optical degree of the far end. It is read-only.

• Group Type (actual)- This is the actual group type of the far end. It is read-only.

7. Optionally, configure the Custom fields. These fields are for operator use and are

opaque to the system.

a. Click the CustomSettings tab.

b. In theCustomSettingspanel, edit the Id,Custom1,Custom2, andCustom3 settings

as desired.

8. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The

changes appear in PSM a short while after the task completes successfully.

Changing an Amplifier's Group

Use this procedure to change an amplifier's grouponaBTI7800Series network element.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. ExpandOptical Groups to show the optical groups in that NE.

3. Expand an optical group to show the degrees in that group.

4. Expand a degree to show the amplifier associated with that degree.

5. Right-click an amplifier and select Equipment >Edit.

The Change Group/Degree dialog appears.

6. Edit the Group.

The Degreemust be 1 and cannot be changed.

7. When you are finished, click Apply.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The

changes appear in PSM a short while after the task completes successfully.
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Viewing Port PMs on a 96-Channel Amplifier

Use this procedure to view the port PMs on a 96-Channel Amplifier on a BTI7800 Series

network element.

1. Expand the network element in the Network tree view to show the shelves in that NE.

2. ExpandOptical Groups to show the optical groups in that NE.

3. Expand an optical group to show the degree in that group.

4. Expand a degree to show the amplifier associated with that degree.

5. Expand an amplifier to show the ports on that amplifier.

6. Right-click a port and selectOptical Port PMs >View.

A snapshot of the current PMs is displayed.

7. To refresh the counters, click Refresh.

8. To select what columns to display, right-click anywhere in the headings row to bring

up a column selection window.

Check or uncheck column headings as desired.

9. To sort the PMs based on column values, click on the column heading that you want

to sort.

10. To save the counters to a CSV file, click Export.

Provisioning aWavelength Protection SwitchModule on a BTI7800

Adding aWPSModule

Use this procedure to add a newWavelength Protection Switch (WPS)module on a

BTI7800 Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.
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3. Right-click an unprovisioned slot and select Slot >Provision to add amodule in that

slot.

The Provision Slot dialog appears. This dialog might change depending on the PEC

that you select in the next step.

4. Configure the slot as follows:

• PEC Select theWPS PEC from the list of available PECs in the drop-downmenu.

• AdminStatusSpecifywhether the initial stateof themodule isUporDownorTesting.

5. Optionally, specify theCustom fields. These fields are for operator useandareopaque

to the system.

a. Click the CustomSettings tab.

b. In theCustomSettingspanel, specify theCustom1,Custom2, andCustom3settings

as desired.

6. When you are finished, clickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree a short while after the task completes

successfully.

7. After the newWPSmodule appears in the Network tree, add aWPS protection group

by following the steps in “Adding a Protection Group” on page 252.

Protection ports are automatically added to theWPS group.

8. Configureprotectionport settingsby following thesteps in “EditingaPort” onpage255.

Adding a Protection Group

Use this procedure toaddaWPSprotectiongrouponaBTI7800Series network element.

When you add a protection group, the client and line ports are automatically added.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Right click aWPSmodule and selectProtectionGroups>Provision to add aprotection

group on the selectedWPSmodule.

The ProvisionWavelength Protection Group dialog appears:
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4. Configure the protection group as follows:

• Group Id - Select the protection group identifier from the drop-downmenu. Only

available identifiers are listed.

• Revertive-Type - SelectNON_REVERTIVEorREVERTIVE from the drop-downmenu.

• Remote Id - This field is for operator use and is opaque to the system. PSM does

not use this field for topology.

• Prot Id - This is an alternative name for the protection group, and is opaque to the

system.

• Custom - This field is for operator use and is opaque to the system.

5. When you are finished, clickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree a short while after the task completes

successfully. For example:
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Editing a Protection Group

Use this procedure toedit aWPSprotectiongrouponaBTI7800Series network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand aWPSmodule to show the protection groups on that module.

4. Right click a protection group and select Group >Edit.

The EditWavelength Protection Group dialog appears:

5. Edit the protection group as follows:
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• Group Id - This is the protection group identifier. It cannot be changed.

• Revertive-Type - SelectNON_REVERTIVEorREVERTIVE from the drop-downmenu.

• Remote Id - This field is for operator use and is opaque to the system. PSM does

not use this field for topology.

• Prot Id - This is an alternative name for the protection group, and is opaque to the

system.

• Custom - This field is for operator use and is opaque to the system.

6. When you are finished, clickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree a short while after the task completes

successfully.

Deleting a Protection Group

Use this procedure to delete aWPS protection group on a BTI7800 Series network

element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand aWPSmodule to show the protection groups on that module.

4. Right click a protection group and select Group >Delete.

The DeleteWavelength Protection Group confirmation dialog appears.

5. ClickOK to delete the group.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree a short while after the task completes

successfully.

Editing a Port

Use this procedure to edit aWPS protection group port on a BTI7800 Series network

element.

WPSprotection group ports are automatically createdwhen you add a protection group.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.
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3. Expand aWPSmodule to show the protection groups on that module.

4. Expand a protection group to show the ports in that group.

5. Right click a port and select Port >Edit.

The EditWavelength Protection Port dialog appears:

6. Edit the protection port as follows:

• Port Name- This field is automatically assigned and cannot be changed.

• Status - This read-only field shows the operational status of a line port. It is not

applicable to a client port.

• Threshold (dB) - Select the threshold at which a loss of light condition is declared.

This field applies to both client and line ports. Additionally, on line ports, when the

receive power drops below this threshold, an automatic protection switch might

take place.

• Remote Id - This field is for operator use and is opaque to the system. PSM does

not use this field for topology.
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• Prot Id - This is an alternative name for the protection group, and is opaque to the

system.

• Custom - This field is for operator use and is opaque to the system.

7. When you are finished, clickOK.

The PSM server sends the configuration request to the network element. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in the Network tree a short while after the task completes

successfully.

Enabling or Disabling a Port

Use this procedure to administratively enable or disable a port on a BTI7800 Series

network element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.

3. Expand a UFM to show the BICs on that UFM.

4. Expand a BIC to show the ports on that BIC.

5. Enable or disable a port as follows.

a. To enable a provisioned port, right click the port and select Admin State >Enable.

b. To disable a provisioned port, right click the port and select Admin State >Disable.

Nodal Management for Juniper Networks Routers and Switches

PSM supports management of the following interfaces on Juniper Networks routers and

switches:

• MX Series router

• 100GE interface on the 100-Gigabit DWDMOTNMIC with CFP2-ACO

(MIC3-100G-DWDM)

• 100GE interface on the CFP2-DCO (CFP2-DCO-T-WDM-1) transceiver on the

100-Gigabit Ethernet MIC with CFP2 (MIC6-100G-CFP2 )

• 100GE interfaceontheCFP2-DCO(CFP2-DCO-T-WDM-1) transceiveronthe2x100GE

+ 4x10GEMPC5E (MPC5E-100G10G)

• 10GE interfaces on the 6x40GE + 24x10GEMPC5E (MPC5E-40G10G)

• 10GE interfaces on the 6x40GE + 24x10GEMPC5EQ (MPC5EQ-40G10G)

• 10GE interfaces on the 2x100GE + 4x10GEMPC5E (MPC5E-100G10G)

• 10GE interfaces on the 2x100GE + 4x10GEMPC5EQ (MPC5EQ-100G10G)
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• PTX Series router

• 100GE interfaces on the 100-Gigabit DWDMOTN PIC with CFP2-ACO

(PTX-5-100G-WDM)

• 100GE interface on the CFP2-DCO (CFP2-DCO-T-WDM-1) transceiver on the

100-Gigabit Ethernet OTN PIC with CFP2 (P2-100GE-OTN)

• QFX Series switch

• Ports on the QFX10K DWDM 1.2T Line Card (QFX10K-12C-DWDM)

PSMsupports this samesetof interfaces for serviceactivation. See “ActivatinganOptical

Service Between Transponder Interface Endpoints” on page 308 for more information.

NOTE: These interfacesmust already exist. You cannot use PSM to create
these interfaces.

The following management functions are supported:

• Editing an Interface on page 258

• Enabling or Disabling a Port on page 262

• Viewing Interface PMs on an MX Series or PTX Series Router or QFX Series

Switch on page 263

Editing an Interface

Use this procedure to edit an interface on a port on an MX Series or PTX Series router or

QFX Series switch.

This procedure uses theMXSeries router as an example but applies equally toMXSeries

and PTX Series routers and QFX Series switches. There might be slight differences

between devices but the general procedure is the same.

1. Expand an MX Series or PTX Series router or QFX Series switch in the Network tree

to show the shelves in that router or switch.

2. Expand a shelf to show the slots in that shelf.
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3. Expand a slot to show the MICs/PICs in the MPC/FPC in that slot.

4. Expand a MIC/PIC to show the ports for that MIC/PIC.

5. If youare configuring aQFX10KDWDM1.2TLineCard (QFX10K-12C-DWDM)onaQFX

Series switch, you need to configure the modulation scheme and the optical signal

parameters at the port level because the OTU4 signals are modulated within the

optical signal on the containing port.

If you are configuring any other interface, go to 7.

To configure the modulation scheme and the optical signal parameters on the port,

right click the port and selectOptical>Edit.

The following window appears:
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6. Configure the physical attributes:

• Modulation - Select the modulation scheme.

• For the other physical parameters, see 10 and 11.

NOTE: For some transceivers, you can configure the line encoding.

Proceed to the next step to configure the interface parameters.

7. Expand a port to show the interfaces for that port.

8. Right-click a provisioned interface and select Interface >Edit.

The Edit Interface dialog appears.
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Figure 61: Edit Interface (OTU4)

NOTE: The Physical panel does not appear here for interfaces where the
optical signal is configured at the port level.

9. Configure the general interface attributes:

• Type - The type is automatically set based on the interface and cannot be changed.

10. Configure the protocol attributes. Protocol attributes vary depending on the protocol.

• FEC -Specify the typeof ForwardErrorCorrection (FEC) fromthedrop-downmenu.

• Transmitted SAPI - Specify the transmit Source Access Point Identifier in the Trail

Trace Identifier (TTI) panel or click the Auto Set button. When you click the Auto

Setbutton,PSMautomatically configures theSAPIwith the IPaddressand interface

nameencoded inhexadecimal format. Forexample, aSAPIof 10.161.33.106-et-1/0/0

is automatically encoded and stored on the device as 0AA1216A010000, where:

• characters 1 through 8 (0AA1216A) represent the IP address

• characters 9 and 10 (01) represent the slot

• characters 11 and 12 (00) represent the PIC/MIC

• characters 13 and 14 (00) represent the port
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NOTE: If you specify the SAPI explicitly without using Auto Set and the

SAPI is in the IPaddress and interfacename format, PSMautomatically
encodes the SAPI in hexadecimal format and stores the resulting string
on the device. If the SAPI is not in the IP address and interface name
format, PSM stores the string as entered without encoding.

• Expected Receive SAPI - Specify the expected receive SAPI in the TTI panel.

NOTE: If the SAPI is in the IP address and interface name format,PSM
automatically encodes the SAPI in hexadecimal format and stores the
resulting string on the device. If the SAPI is not in the IP address and
interface name format, PSM stores the string as entered without
encoding.

11. Configure the physical attributes.

• Grid - Specify the frequency grid. This cannot be changed for most transceivers.

• Channel Name,Wavelength, or Frequency - Specify the desired channel, the desired

wavelength, or thedesired frequency.Settingone fieldautomatically sets theothers.

This can only be specified for tunable transceivers.

• Loopback - Not supported.

• Laser Enabled - Not supported.

• TX Power - Specify the transmit power of the laser.

• LOS Alarm Threshold - Specify the Loss of Signal (LOS) threshold above which an

alarm is raised.

• LOSWarning Threshold Specify the LOS threshold abovewhich awarning is issued.

12. When you are finished, clickOK.

The PSM server sends the configuration request to the router or switch. You can

monitor the status of the request through the View >Server >Taskswindow. The new

provisioning appears in PSM a short while after the task completes successfully.

Enabling or Disabling a Port

Use thisprocedure toadministratively enableordisablea supportedport onanMXSeries

or PTX Series router or QFX Series switch.

This procedure uses theMXSeries router as an example but applies equally toMXSeries

and PTX Series routers and QFX Series switches. There might be slight differences

between devices but the general procedure is the same.
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1. Expand an MX Series or PTX Series router or QFX Series switch in the Network tree

to show the shelves in that router or switch.

2. Expand a shelf to show the slots in that shelf.

3. Expand a slot to show the PICs or MICs in that slot.

4. Expand a PIC or MIC to show the ports.

5. Enable or disable a port as follows.

a. To enable a provisioned port, right click the port and select Admin State >Enable.

b. To disable a provisioned port, right click the port and select Admin State >Disable.

Viewing Interface PMs on anMX Series or PTX Series Router or QFX Series Switch

Use this procedure to view current interface PMs on an MX Series or PTX Series router

or QFX Series switch.

This procedure uses theMXSeries router as an example but applies equally toMXSeries

and PTX Series routers and QFX Series switches. There might be slight differences

between devices but the general procedure is the same.

263Copyright © 2019, Juniper Networks, Inc.

Chapter 8: Nodal Management



1. Expand an MX Series or PTX Series router or QFX Series switch in the Network tree

to show the shelves in that router or switch.

2. Expand a shelf to show the slots in that shelf.

3. Expand a slot to show the PICs or MICs in that slot.

4. Expand a PIC or MIC to show the ports.

5. Expand a port to show the interfaces for that port.

6. Right-click a provisioned interface and select Interface PMs >View.

The Interface Current PMwindow appears:
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The PMs are listed for the interface selected.

NOTE: This window shows a snapshot of the PM counts. The counts do
not update automatically in this window. To see the latest counts, click
the Refresh button.

7. To select what columns to display, right-click anywhere in the headings row to bring

up a column selection window.

Check or uncheck column headings as desired.

8. To sort the PMs based on column values, click on the column heading that you want

to sort.

9. To export the PM data to a CSV file, click Export and save the file.

Nodal Management for BTI800 Series Network Elements

This section covers the following topics:

• Enabling or Disabling a Port on page 265

Enabling or Disabling a Port

Use thisprocedure toadministratively enableordisableaportonaBTI800Seriesnetwork

element.

1. Expand the network element in the Network tree to show the shelves in that NE.

2. Expand a shelf to show the slots in that shelf.
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3. Expand amodule to show the ports on that module.

4. Enable or disable a port as follows.

a. To enable a provisioned port, right click the port and select Admin State >Enable.

b. To disable a provisioned port, right click the port and select Admin State >Disable.
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CHAPTER 9

Configuring PSM Client Options

• Introduction on page 267

• Configuring General Options on page 267

• Configuring Alerts Options on page 268

• Configuring Display Options on page 269

• Configuring Performance Monitoring Options on page 277

• Configuring Utilities on page 279

Introduction

PSM client options control the behavior of the specific PSM client in which the options

are set, and the settings are stored on the computer in which the client is running.

Therefore, the options that you set are not applicable if you log in on another PSM client.

Client options control a variety of behaviors, including the specification of external

executables to launch from the client for tasks suchas connecting to theCLI of a network

element.

NOTE: This chapter describes procedures to change PSM options on a
Windows client. If you are running on OS X, the options wndow is accessed
by psmclient >Preferences....

Configuring General Options

The PSM client gives you options to control general behavior. This section covers the

following topics:

• Setting Auto-logout on page 267

Setting Auto-logout

The PSM Client allows you to automatically log out a user after a specified idle period.

This setting applies to all users logging in on the PSM Client in which this option is set.

This setting does not apply to users logging in on a different PSM Client.
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1. From themain menu, choose Tools >Options.

The Options window is displayed.

2. Click the General tab.

3. To enable auto-logout, select the Enable Auto-Logout checkbox.

4. Specify the Auto-Logout time.

The PSM Client automatically logs a user out if the user is idle for the specified time.

5. ClickOK.

Configuring Alerts Options

The PSM client gives you options to control various audible alerts. This section covers

the following topics:

• Setting Alarm Alerts Options on page 268

Setting Alarm Alerts Options

ThePSMClient gives youoptions for the alerting of newalarms. Tomodify these options,

use the following procedure.

1. From themain menu, choose Tools>Options.

TheOptionswindow is displayed.

2. Click the Alerts tab.

• To enable audible alerts, select Play alert on new alarm.

• Browse to and select the audio file that contains the desired alert tone.

• Select the Number of times to play the tone.
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3. ClickOK.

Configuring Display Options

The PSM client allows you to control various display options. This section covers the

following topics:

• Setting Alarm Display Options on page 269

• Setting Auto-categorization Options on page 270

• Setting Device Display Options on page 274

• Setting Overlay Display Options on page 274

• Setting Service Display Options on page 275

• Setting Topology Display Options on page 276

Setting AlarmDisplay Options

The PSMClient gives you options for the display of alarms. Tomodify these options, use

the following procedure.

1. From themain menu, choose Tools>Options.

TheOptionswindow is displayed.

2. In theOptionswindow, click Display.

3. Click the Alarms tab.

• Todisplayacknowledgedalarms in thealarmspane, check theDisplayAcknowledged

Alarms check box.

• To filter thealarms in thealarmspane toonlydisplayalarms that relate toaselected

device when that device is selected in the Topology view or in the Tree view, check

the Filter Alarms on Device Selection check box.

• To filter thealarms in thealarmspane toonlydisplayalarms that relate toaselected

servicewhen that service is selected in the Topology view or in the Tree view , check

the Filter Alarms on Service Selection check box.
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• To filter the alarms in the alarms pane to only display alarms that relate to a

particular group when that group is selected in the Topology view or in the Tree

view, check the Filter Alarms on Group Selection check box.

• To automatically resume alarm notifications after alarm notifications have been

suspended, check the Expire AlarmPausing check box and specify the AlarmPause

Duration to wait for before resuming.

• To Show deltas for alarms in the alarms summary bar, select the alarm severities

forwhichdeltasare tobeshown.Deltasare incremental alarmcounters thatprovide

an indication of howmany new alarms have been raised since the counters were

last cleared.

• To specify how long to keep cleared alarms in the alarms pane, enter the Delay

before removing cleared alarms in seconds. A setting of 0 causes the alarm to be

removed from the table immediately once it is cleared. Changes to this setting take

effect for newly-raised alarms only. Existing alarms continue to use the

previously-configured delay value.

4. ClickOK.

Setting Auto-categorization Options

Use this procedure to set the auto-categorization options.

When there aremany services or customers, theNetwork tree canbedifficult to navigate.

To reduce the visual clutter, PSM can automatically categorize and aggregate services
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and customers in the tree. You can let PSM choose default category names for you, or

you can customize how PSM chooses the category names.

1. From themain menu, choose Tools >Options.

TheOptionswindow is displayed.

2. Click the Auto-Categorization tab.

The auto-categorization options appear. There is a general Default section followed

by a section for each branch of the tree that supports customized categorization.

3. To enable auto-categorization, select the Enable Auto-Categorization check box.

This enables auto-categorization for items in the Network tree.

4. Specify the Auto-Categorization Threshold.

When the number of items in a branch exceeds this threshold, PSM begins

auto-categorization for that branch.

5. To use the default PSM categories, clickOK. Otherwise go to 6.

The Network tree is updated to show the new categorization. The default categories

are based on alphabetical categorization. For example:
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Figure 62: Customers BranchWithout Auto-categorization

Figure 63: Customers Branch with Auto-categorization Using Default Categories

6. To customize the categorization, use regular expressions to specify how youwant the

categories to be created.

The idea is to use regular expressions to match parts of the name of each entry. The

matched parts then become the category names to which the entries are assigned.

a. Select the Enabled check box for the branch that you want to customize.

b. Type the regular expression in the Regex field. For example:
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The regular expression (?<=-)\w\w\w?$ looks at the end of each name for two

or three alphanumeric characters prefixed by a hyphen. The two or three

alphanumeric characters then form the category to which this entry belongs.

c. To test your regular expression, enter a string in the Example field.

PSMwill test your regular expression against the example string. For example:

Thematched part of the string is shown in green. This green part represents the

category name to which the example string belongs. You can repeatedly test your

regular expression by entering different strings in the Example field.

d. ClickApply to apply your regular expression against the respective branch in the

tree.

This results in a set of matched strings. Some namesmight havematched strings

while others do not. The first matched string in a name defines the category that

the entry belongs to. If the category does not exist in the branch, PSMwill create

the category. Names that do not have anymatched strings are placed in theOther

category. Here is the resulting Customers branch for the regular expression above.
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For a basic introduction to regular expressions, see “Regular Expressions” on

page 578.

e. Repeat for all branches that you want to customize.

7. ClickOK to exit when you are done.

Setting Device Display Options

The PSM Client gives you options for the display of NEs. Tomodify these options, use

the following procedure.

1. From themain menu, choose Tools>Options.

TheOptionswindow is displayed.

2. Click the Devices tab.

If you want to display the IP address in addition to the device name in the Tree view

and/or theMap view, then select the applicable check boxes.

NOTE: If you select the Tree view, the IP address is also displayed in the

NE column in the Alarms window.

3. ClickOK.

Setting Overlay Display Options

Use this procedure to modify the appearance of how data widgets are overlaid on the

background window.

This setting affects the appearance of the real-timePMdatawidgets and the link details

widgets.

1. From themain menu, choose Tools>Options.

TheOptionswindow is displayed.

2. In theOptionswindow, click Display.
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3. Click theOverlays tab.

Adjust the transparency of the data widgets. Choose any value from "0%" for

completely transparent to "100%" for completely opaque.

4. ClickOK.

Setting Service Display Options

Tomodify the appearance of how Ethernet services are shown, use the following

procedure.

1. From themain menu, choose Tools>Options.

TheOptionswindow is displayed.

2. In theOptionswindow, click Display.

3. Click the Services tab.

Todisplay a visual representationof theERPSstatus in theEthernet services topology

view, select Display ERPS status on links.
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The ERPS status is represented by a , , or a . For more information, see

“Visualizing an ERPS Service” on page 414.

4. ClickOK.

Setting Topology Display Options

Tomodify the appearance of how links are displayed in the topology view, use the

following procedure.

1. From themain menu, choose Tools>Options.

TheOptionswindow is displayed.

2. In theOptionswindow, click Display.

3. Click the Topology tab.

a. To exclude MXP client port to MXP client port connections when determining

whether to display the multi-link icon in the topology view, select Hidemultilink

icon for MXP client port.

This is useful when you are viewing the topology for MXP links and you only want

to see themulti-link icon for line port connections.

b. To disregard the port status of MXP client ports when determining the link color

to display in the topology view, select Hide port status for MXP client port.

This is useful when you want the color of the MXP link to reflect the state of the

line port connections only. If you select this option, and theMXP link only contains

client port connections, then the color of the link is grey.

c. To allow the link down indication to persist for a period of time, specify the Delay

before removing link down indication (seconds).

This setting allows you to see when a link goes down and comes back up. When

a link goes down and comes back up, the link down indication is shown in the

topology Map view for the specified number of seconds before being removed.

4. ClickOK.
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NOTE: Forchanges to theseoptions to takeeffect forexistingconnections,
youmust click the Refresh from Server icon.

Configuring PerformanceMonitoring Options

The PSM Cclient allows you to control the display and collection of performance

monitoring counters (PMs). This section covers the following topics:

• Setting Historical PM Graphing Options on page 277

• Setting Optical Graphing Options on page 278

• Setting Real-time Collections Options on page 278

Setting Historical PMGraphing Options

To set the graphing options for historical PMs, use the following procedure:

1. From themain menu, choose Tools>Options.

TheOptionswindow is displayed.

2. In theOptionswindow, click PMs.

3. Click the Historical tab.

• In theMax number of PMPoints selectable box, specify the maximum number of

PMmetrics to display in the graph.

4. ClickOK.
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Setting Optical Graphing Options

Tomodify the information shown in the "All Channels"opticalPMgraph, use the following

procedure:

1. From themain menu, choose Tools>Options.

TheOptionswindow is displayed.

2. In theOptionswindow, click PMs.

3. Click theOptical tab.

• Todisplay the channel number in the domain (horizontal) axis of the "All Channels"

graph, select the Channel Number check box.

• To display the channel (32+8 Plan) number in the domain (horizontal) axis of the

"All Channels" graph, select the Channel(32+8 Plan) check box.

• To display the wavelength in the domain (horizontal) axis of the "All Channels"

graph, select theWavelength check box.

• Todisplay the frequency in thedomain (horizontal) axis of the "All Channels" graph,

select the Frequency check box.

Multiple check boxes can be selected.

4. ClickOK.

Setting Real-time Collections Options

Tomodify how long real-time PM data is collected and how frequently the counts are

updated, use the following procedure.
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1. From themain menu, choose Tools>Options.

TheOptionswindow is displayed.

2. In theOptionswindow, click PMs.

3. Click the Realtime Collections tab.

• Select the Duration over which the real-time PM data is to be collected.

• Select the Interval or frequency with which the real-time PM data is updated.

4. ClickOK.

Configuring Utilities

The PSM client makes use of external executables for the following utilities:

• CLI

• Node Controller

• Ping

• SNMP Ping

• Traceroute

The PSM client is preconfigured to provide these utilities using specific executables on

your computer. You can customize where the PSM client looks for these executables. If

the network element being managed requires a specific node controller executable, you

can also specify where that node controller executable can be found.

• Setting Utility Executables on page 280

• Configuring the proNX 900 Node Controller on page 282
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Setting Utility Executables

Use this procedure to configure the CLI, Ping, SNMP Ping, and Traceroute utility

executables and parameters.

NOTE: To use SNMP Ping onWindows, net-snmp or a similar application
must be installed. See “Installing Net-SNMP” on page 555.

1. Select Tools >Options.

The Options window is displayed.

2. Click the Utilities tab.

The Utilities panel is displayed.

3. For each tab in the Utilities panel, specify the desired executables and parameters.

a. Select the utility that you want to configure (CLI, Ping, SNMPPing, Traceroute).

b. Select the Network Element Type from the drop-downmenu.

If you want to apply your changes to all network element types, then leave the

Type at Default. If you want to tailor the executable to a particular type of network

element, then select the specific type from the drop-downmenu.

NOTE: Once youmake a change to the parameters of a specific type
of network element, the Default parameters no longer apply for that

type of network element.
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c. Select the Network Element Version from the drop-downmenu.

If you want to apply your changes to all versions of the selected network element

type, then leave the Version at Default. If you want to tailor the executable to a

particular version of the selected network element type, then select the specific

version from the drop-downmenu.

NOTE: Onceyoumakeachange to theparametersofaspecific version,
the Default parameters no longer apply for that version of network

element.

d. Specify the command syntax for the selected utility.

You can specify the name and path to the executable and the parameters to use.

For example, the command to launch the CLI (C:\Users\user\Desktop\putty.exe

-ssh-P22<login_username>@<IP_address_of_selected_NE>) is representedby this

configuration:

The<username>construct is a variable that represents theusernameof thecurrent

PSM user (that is, the username you used to log in to the current PSM client

session). The <address> construct is a variable that represents the IP address of

the selected NE. The above configuration launches the putty.exe executable from

the specified path and sets up an SSH connection to the selected NE using the

username of the current PSM user.

If you are running putty.exe onWindows and you want to explicitly specify the

username when launching the CLI, then remove the <username> construct. For

example:
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This forces putty.exe to prompt you for the username to use when you launch the

CLI.

NOTE: Theaboveareexamplesofapplicationsandparameters touse.
The validity of the parameters depends on the application chosen.

4. When you are done, clickOK.

This procedure is complete.

NOTE: To connect to the CLI, see “Connecting to the CLI on a Network
Element” on page 114. To launch the Node Controller on the BTI7000, see
“Launching the proNX 900 Node Controller” on page 134. To launch the
other utilities, see “Performing Diagnostics” on page 540.

Configuring the proNX 900Node Controller

Use this procedure to configure how to launch the proNX 900 Node Controller.

The proNX 900 Node Controller is the nodal manager for the BTI7000 Series network

elements.

NOTE: The proNX 900 Node Controller might not be supported on all PSM
client platforms. See the BTI7000 Series Common Equipment Installation
Guide for a list of platforms that support the proNX 900 Node Controller.

Prerequisites:
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• TheproNX900NodeController software that is compatiblewith thenetworkelements

in your network must be installed on your local computer.

1. From themain menu, choose Tools>Options.

The Options window is displayed.

2. Click the Utilities button and then click the Node Controller tab.

3. There are several methods by which you can specify the path to the proNX 900

application software on your local computer:

• If all of your versions of proNX 900 are in one directory, you can browse to that

directory and select it. Afterwards, when you launch proNX 900, PSM chooses the

correct version of the proNX 900 for the selected NE and launches it. If it cannot

find an exact match, PSM chooses the best match and prompts you to confirm.

Continue at 4.

• Manually determine the path to the executable file for each NE type and version,

and then copy and paste the path into the proNX 900 Node Controller tab for that

version. Continue at 5.

4. To browse to and select the directory that contains the desired proNX900 version(s),

click the Install tab and perform the following steps.

a. Click Browse and navigate to the proNX 900 installation directory, for example:

C:\Program Files (x86)\BTI\

NOTE: If youare running thePSMClientona32-bitWindowsoperating
system, youmight need to specify a different path for the installation
directory, for example: C:\Program Files\BTI .
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b. Select the directory and clickOpen.

The path to the directory is pasted into the Install Directory field.

c. ClickOK.

This procedure is complete. You can now launch the proNX 900 as instructed in the

first step.

5. Tomanually cut and paste the path to the executable file, click the Command tab

and perform the following steps.

a. Select the NE Type and proNX 900 Version that you want to launch from the

drop-downmenus.

b. In your file system, navigate to the proNX 900 executable file, for example

C:\ProgramFiles(x86)\BTI\proNX900_9.3.0_C001\proNX900.exe . Copy theentire

path.

NOTE: If youare running thePSMClientona32-bitWindowsoperating
system, youmight need to specify a different path for the installation
directory, for example: C:\Program Files\BTI .

c. In the first line of the Commandwindow, paste the new path to the proNX 900

application executable file over the existing path shown. The first image shows an

unaltered command string in the first line, and the second image shows the

command string after the path to the executable file has been pasted in.
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d. In the same command window, scroll down and check the user ID (uid) and

password (pid) as follows:

• if you want to launch the proNX 900without requiring the user to log in, ensure

that the user ID (uid) and password (pid) are the same as the NE user ID and

password.

• alternatively, youcan remove theuser IDandpassword in the commandwindow,

forcing the user to log in when the proNX 900 launches.

e. As desired, repeat these steps for each NE Type and Version of proNX 900. When

you are finished clickOK.

This procedure is complete.
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CHAPTER 10

Bulk Configuration Of Network Elements

• Introduction on page 287

• Creating New Users on Multiple Network Elements on page 287

• Configuring RADIUS Server Parameters on Multiple Network Elements on page 291

• Configuring NTP Server Parameters on Multiple Network Elements on page 297

Introduction

PSM allows you to perform configuration operations onmultiple network elements

concurrently. This is usefulwhenyou intend toconfigure the same informationonmultiple

networkelements, suchasconfiguringuser accountsandRADIUSandNTPserver access,

which typically are the same across multiple network elements.

This bulk configuration capability makes use of PSM server scripts to communicate with

and configure the network elements.

Creating NewUsers onMultiple Network Elements

Use this procedure to add the same set of new users to multiple network elements.

NOTE: The PSM server treats each network element separately, launching
individual tasks to communicate with and configure each NE. A task failure
for one NE does not affect tasks for the other NEs.

NOTE: PSMconnects toeachNEusing the logincredentials thatyousupplied
whenyouconnectedto thePSMserver.ThereforeeachNEmustbeconfigured
with these same login credentials for this procedure to be successful.
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NOTE: PSM connects to each NE using the applicable protocol for that NE
type. When connecting to an NE over SSH (e.g. BTI7800), the SSH key
provided by the NEmust match the expected key (if the key was previously
stored). If the key supplied by the NE does not match the expected key, the
task times out and fails. Under normal situations, the supplied keymatches
the expected key. However, if the NE operating system has been re-installed,
the keysmight not match. In this situation, you will need to remove the
expected key from the PSM server machine's ~/.ssh/known_hosts file. One

method of doing this is to issue the following Linux command from a Linux
shell on the PSM server machine:

# sed -i '/NE_IP_address/d' ~/.ssh/known_hosts

where NE_IP_address is the IP address of the NE.

This procedure is supported on BTI7000 Series, BTI7800 Series, BTI800 Series, and

BTI700 Series (excluding BTI718E) NEs.

1. To create one ormore newusers, select one ormore network elements from themain

topology window or from the tree view.

2. Right-click and select Scripts>Network Elements>Create NewUsers.

The "Create NewUsers" dialog appears with the list of selected network elements at

the top:
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NOTE: The "Selected Network Element(s)" box has limited space to
display network elements. In situations where the number of selected
networkelements is large, somenetworkelementsmightnotbedisplayed.
This is normal behavior and does not affect script execution, which runs
for all selected network elements, regardless of whether they appear in
the list or not.

3. Click Add to add a user.

A new row appears.

4. Click inside each field and add the necessary information. Select the "Role" from a

pull-downmenu.

• Username - the username for the new user. It must be unique on the NEs that are

being configured. After entering the Username, make sure you click outside of the

Username box to exit Username entry mode.

• Password - the passwordmust be at least six characters long and nomore than

ten characters long, even though this constraint might not exist when adding users

to the NEs directly (using the CLI). Allowable characters are a-z, A-Z, 0-9, and the

following special characters: !@#$%^&()_+[]{}.~`<>. After entering the password,

make sure you click outside of the Password box to exit Password entry mode.
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• Role - the privileges that the new user will have. Themapping of roles on the NE is

below:

Mapped to role on BTI7000 SeriesCreate NewUsers Role

superusersuperuser

provisioningprovisioning

maintenancemaintenance

surveillancesurveillance

Mapped to role on BTI7800 SeriesCreate NewUsers Role

superusersuperuser

provisioningprovisioning

surveillancesurveillance

Mapped to role on BTI800 SeriesCreate NewUsers Role

adminsuperuser

operatorprovisioning

viewersurveillance

Mapped to role on BTI700 SeriesCreate NewUsers Role

administratorssuperuser

operatorsprovisioning

usersmaintenance

guestssurveillance

• Timeout - the idle timeout before automatically logging the user out. This only

applies to the BTI7000 Series NEs, and has no effect on the other NE types.

5. Add asmany users as desired. You can delete a row by selecting it and clickingDelete.

6. When you are finished, clickOK.
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The PSM server launches a task for each NE being configured.

7. Look at the Tasks window to verify that each task has completed successfully. A

"Create NewUsers" task can fail for an NE if a user being added already exists on that

NE.

In the following example, the "Create New Users" task was successful for 10.1.205.9

but failed for 10.1.205.8.

NOTE: A failure usually indicates that at least one usernamebeing added
already exists on the NE. The script does not add duplicate usernames,
but continues to add all non-duplicate usernames. It is good practice to
log in to each failed NE (using the proNX 900) to verify which users have
been added successfully and which failed.

This procedure is now complete.

Configuring RADIUS Server Parameters onMultiple Network Elements

Use this procedure to configure the same RADIUS server parameters across multiple

network elements.

NOTE: The PSM server treats each network element separately, launching
individual tasks to communicate with and configure each NE. A task failure
for one NE does not affect tasks for the other NEs.

NOTE: PSMconnects toeachNEusing the logincredentials thatyousupplied
whenyouconnectedto thePSMserver.ThereforeeachNEmustbeconfigured
with these same login credentials for this procedure to be successful.
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NOTE: PSM connects to each NE using the applicable protocol for that NE
type. When connecting to an NE over SSH (e.g. BTI7800), the SSH key
provided by the NEmust match the expected key (if the key was previously
stored). If the key supplied by the NE does not match the expected key, the
task times out and fails. Under normal situations, the supplied keymatches
the expected key. However, if the NE operating system has been re-installed,
the keysmight not match. In this situation, you will need to remove the
expected key from the PSM server machine's ~/.ssh/known_hosts file. One

method of doing this is to issue the following Linux command from a Linux
shell on the PSM server machine:

# sed -i '/NE_IP_address/d' ~/.ssh/known_hosts

where NE_IP_address is the IP address of the NE.

This procedure is supported on BTI7000 Series, BTI7800 Series, BTI800 Series, and

BTI700 Series NEs.

1. To configure RADIUS server parameters, select one or more network elements from

themain topology window or from the tree view. Only compatible network elements

can be selected together.

2. Right-click and select Scripts>Network Elements>Configure Radius Server.

The "Create Radius Server" dialog appearswith the list of selected network elements

at the top. Depending on the type of network element selected, you will see one of

the following two dialogs:
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Figure 64: Configure Radius Server

Figure 65: Configure Radius Server (BTI718E)

For BTI7000Series, BTI7800Series, BTI800Series andBTI700Series (excluding the

BTI718E) NEs, you are adding a single RADIUS server in this procedure. Repeat the

entire procedure to add a second RADIUS server.
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For theBTI718E, youareadding theprimary and the secondary servers simultaneously

in thisprocedure.Click theAddbutton toexpand thedialog tospecify up toamaximum

of two secondary servers.

NOTE: For both dialogs, the "Selected Network Element(s)" box has
limited space to display network elements. In some situations where the
number of selected network elements is large, some network elements
might not be displayed. This is normal behavior and does not affect script
execution, which runs for all selected network elements, regardless of
whether they appear in the list or not.

3. Configure the RADIUS parameters:

BTI7000 SeriesAttribute

Not applicable.Radius Server Name

Sets the IP address.Radius Server IP Address

Radius Server Role:

Sets the Role attribute to primary.primary

Sets the Role attribute to secondary.secondary

Sets the Role attribute to disabled. The specified server is
configured but not used.

disabled

Sets the Port attribute to the specified value.Radius Server Port

Sets the Key (shared secret) attribute to the specified value.Radius Server Key

Radius Server Priority

Sets theAuthentication Priority attribute to disabled. The NE uses
local database authentication only.

disabled

Sets the Authentication Priority attribute to local. The NE uses
local database authentication first, then RADIUS server
authentication.

local

Sets the Authentication Priority attribute to remote. The NE uses
RADIUS server authentication first, then local database
authentication.

remote

BTI7800 SeriesAttribute

Not applicable.Radius Server Name

Copyright © 2019, Juniper Networks, Inc.294

proNX Service Manager User Guide



BTI7800 SeriesAttribute

Sets the IP address.Radius Server IP Address

Not applicable.Radius Server Role

Sets the authentication port to the specified value.Radius Server Port

Sets the shared secret to the specified value.Radius Server Key

Not applicable.Radius Server Priority

BTI800 SeriesAttribute

Not applicable.Radius Server Name

Sets the IP address.Radius Server IP Address

Radius Server Role:

Specifies that this is the primary server for the BTI810. Not
applicable for the BTI805, BTI821, BTI822.

primary

Specifies that this is the secondary server for the BTI810. Not
applicable for the BTI805, BTI821, BTI822.

secondary

Not applicable.disabled

Sets the authentication port.Radius Server Port

Sets the shared secret.Radius Server Key

Radius Server Priority

Not applicable.disabled

Sets the auth-orderattribute to local. TheNEuses local database
authentication first, then RADIUS server authentication.

local

Sets theauth-orderattribute to radius. TheNEusesRADIUSserver
authentication first, then local database authentication.

remote

BTI700 SeriesAttribute

Sets the NAME attribute to the specified value.Radius Server Name

Sets the IP address.Radius Server IP Address

Radius Server Role:
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BTI700 SeriesAttribute

Sets themode attribute tomain and the state to active.primary

Sets themodeattribute tobackup, and thestate toactive.secondary

Sets the state to suspend.disabled

Sets the auth-port attribute to the specified value.Radius Server Port

Sets the SECRET attribute to the specified value.Radius Server Key

Radius Server Priority

Sets line vty 1 2 login local. The NE uses local
authentication for the first two sessions.

disabled

Sets line vty 1 2 login local. The NE uses local
authentication for the first two sessions.

local

Sets line vty 1 2 login radius. The NE uses RADIUS
authentication for the first two sessions.

remote

4. When you are finished, clickOK.

The PSM server launches a task for each NE being configured.

5. Look at the Tasks window to verify that each task has completed successfully.

In this example, the "Configure Radius Server" task was successful for 10.1.205.8.

A task might fail under these conditions:

• YouareaddingaRADIUSserver toaBTI7000SeriesNE thatalreadyhas twoRADIUS

servers defined. The task fails and no changes take effect.

• You are adding a RADIUS server to a BTI7000 Series NE that has that particular

RADIUSserver alreadydefined (regardlessof the role). The task fails andnochanges

take effect.

NOTE: Other failure conditions exist. Expand the task details of any failed
task to see why the task has failed. Since a failed taskmight still lead to
changes on the NE, you will also need to check the NE on task failure.
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This procedure is now complete.

Configuring NTP Server Parameters onMultiple Network Elements

Use this procedure to configure the same NTP server parameters onmultiple network

elements. It is highly recommended that PSMand all NEs in the network useNTP servers

for obtaining the time in order to avoid time discrepancies.

NOTE: The PSM server treats each network element separately, launching
individual tasks to communicate with and configure each NE. A task failure
for one NE does not affect tasks for the other NEs.

NOTE: PSMconnects toeachNEusing the logincredentials thatyousupplied
whenyouconnectedto thePSMserver.ThereforeeachNEmustbeconfigured
with these same login credentials for this procedure to be successful.

NOTE: PSM connects to each NE using the applicable protocol for that NE
type. When connecting to an NE over SSH (e.g. BTI7800), the SSH key
provided by the NEmust match the expected key (if the key was previously
stored). If the key supplied by the NE does not match the expected key, the
task times out and fails. Under normal situations, the supplied keymatches
the expected key. However, if the NE operating system has been re-installed,
the keysmight not match. In this situation, you will need to remove the
expected key from the PSM server machine's ~/.ssh/known_hosts file. One

method of doing this is to issue the following Linux command from a Linux
shell on the PSM server machine:

# sed -i '/NE_IP_address/d' ~/.ssh/known_hosts

where NE_IP_address is the IP address of the NE.

This procedure is supported for the BTI7000Series, the BTI7800Series, and the BTI800

Series NEs.

1. To configure NTP server parameters, select one or more network elements from the

main topology window or from the tree view.

2. Right-click and select Scripts>Network Elements>Configure NTP.

The "Configure NTP" dialog appearswith the list of selected network elements at the

top:
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NOTE: The "Selected Network Element(s)" box has limited space to
displaynetworkelements. Insomesituationswherethenumberofselected
networkelements is large, somenetworkelementsmightnotbedisplayed.
This is normal behavior and does not affect script execution, which runs
for all selected network elements, regardless of whether they appear in
the list or not.

3. Configure the IP address of the Primary NTP Server and the Secondary NTP Server as

desired.

NOTE: Not all network elements under management use the concept of
primary and secondary NTP servers.

The BTI7000 Series network element keeps a list of up to five NTP servers to use.

This procedure appends the new NTP servers to the existing list, with the specified

Primary NTP Server added ahead of the specified Secondary NTP Server. From this

list, the NE uses the server with the best stratum value. If you try to add anNTP server

when the number of NTP servers is at the maximum number, the task will fail.

The BTI7800 Series network elementmanages a list of NTP servers with no arbitrary

limit. Thisprocedureappends thenewNTPservers to theexisting list,with thespecified

Primary NTP Server added ahead of the specified Secondary NTP Server. The NE tries

to use the NTP server at the beginning of this list first. If it fails, then the next NTP

server in the list is tried, and so on.

The BTI800 Series network element keeps a list of up to three NTP servers to use.

This procedure appends the new NTP servers to the existing list, with the specified

Primary NTP Server added ahead of the specified Secondary NTP Server. The NE tries

to use the NTP server that is specified as the Preferred Server. The Preferred Server is
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designated in the System Information panel. If you try to add an NTP server when the

number of NTP servers is at the maximum number, the task will fail.

4. When you are finished, clickOK.

The PSM server launches a task for each NE being configured.

5. Look at the Tasks window to verify that each task has completed successfully. A

"Configure NTP" taskmight fail if the NTP server being added is already on the NE list

of servers to use.

In this example, the "Configure NTP" task was successful for 10.1.205.8.

NOTE: Ataskmight fail if theprimaryorsecondaryNTPserverbeingadded
already exists in the NTP server list on that NE. No configuration changes
take effect on any failed NE.

This procedure is now complete.
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CHAPTER 11

Managing Optical and Transport Services

• Optical Services on page 301

• Transport Services on page 323

• Working with Optical/Transport Services and Topology Tables on page 334

• Saving a Service Image on page 336

Optical Services

An optical service provides optical (wavelength) connectivity between optical service

endpoints. An optical service endpoint can be a transponder interface that connects to

the optical network or it can be an optical port on equipment within the optical network.

PSM allows users to manage optical services in a BTI7000 or BTI7800 optical network.

In a BTI7000optical network, the transponder interface endpoints can be BTI7800UFM

interfaces or select interfaces onMXSeries or PTXSeries routers or QFXSeries switches.

In a BTI7800 optical network, the transponder interface endpoints can be BTI7800UFM

interfaces only.

• Visualizing an Optical Service on page 301

• Activating an Optical Service in a BTI7000 Network on page 306

• Activating an Optical Service in a BTI7800 Network on page 319

• Viewing the Cross-Connects in an Optical Service on page 321

• Updating an Optical Service on page 321

• Deleting an Optical Service on page 321

• Viewing the Optical Services Table on page 322

• Viewing the Optical Services Per Span Table on page 322

• Viewing the Optical Topology Table on page 323

Visualizing an Optical Service

PSM allows users several ways to visualize an optical service. An optical service can be

visualized at the network, service, group, andmodule levels. Service paths can be

highlighted and detailed information can be displayed through tool tips or in table form.

The examples in this section are taken from a BTI7000 DOL service.
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1. To see a summary of an optical service, hover over the service in the Network tree

under the Optical branch.

2. Toseeanoptical service in its ownpanel, select it in theNetwork treeunder theOptical

branch.

PSM displays the network elements that this service spans along with the service

endpoints indicating the endpoint ports and wavelength.

If the service endpoint has a Remote ID configured, the Remote ID is shown in

parentheses.

If the service includes a split ROADM node, the link connecting the two network

elements comprising the ROADM node is shown with a icon. For example, in the

following figure, 10.1.220.33 and 10.1.220.37 are both part of a single ROADM node,

with each NE providing a degree:

Formore informationonhowPSMrecognizes splitROADMnodesonBTI7000network

elements, see “Configuring a Split ROADMNode” on page 176. .

Formore informationonhowPSMrecognizes splitROADMnodesonBTI7800network

elements, see “Adding a Fiber Connection on a ROADM or an ILA Client Port” on

page 227.
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NOTE: If this is your first time visualizing this service, you will see the
administratively-defined default layout if it exists. If a default layout does
not exist for this service, then you will see the layout that PSM
automatically generates. See 13.

NOTE: If this is your second or subsequent time visualizing this service,
you will see the layout that existed when you last exited this service view.

3. To see a complete service view, right-click the background and select ShowAll

Topology .

4. To see a service path:

a. Right-click the endpoint and select Highlight Service.

Only groups that are part of the service are highlighted.

b. To clear the highlighting, right-click the background and select Clear Highlighting.

5. To see the optical port or interface associated with the service endpoint, right-click

the endpoint and select Navigate >Optical Port or Navigate >Interface.
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Theoptical port or interfaceassociatedwith theendpoint is highlighted in theNetwork

tree.

6. To see the physical equipment in a group, double-click the optical group icon:

The physical equipment and connections within the group are shown in a zoomed-in

view.

7. To change the size of the service view:

a. Right-click the background and select Zoom In to increase the view size

b. Right-click the background and select ZoomOut to decrease the view size

c. Right-click the background and select Reset Zoom to return the view size to its

original size

Alternatively, you can use your mouse scroll wheel.

8. To show port labels:

a. Select an optical group icon. Right-click and choose ShowPort Labels.
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b. Right-click and clear ShowPort Labels to hide port labels.

9. To see details on a link, hover over the link.

10. Right-click anetwork elementandselectNetworkElement to see the regularNEmenu

options.

11. Tomove elements in this view, drag elements to the desired location.

12. Tomove all of the ports and switches in the service, choose Select All and drag the

service within the window.

13. You can save the current layout as the default, or revert to the default, or revert to the

layout that PSM automatically generates.

a. To save the current layout as the default layout for this service, right-click the

background and select Save Layout as Default.

NOTE: Youmust have administrator privileges to execute this
command.

Once the current layout is saved as the default, subsequent users who visualize

this service will be able to see the current layout.

b. To reset the current layout to the default, right-click the background and select

Reset Layout to Default.

c. To reset the current layout to the layout that PSM automatically generates,

right-click the background and select Reset Layout.

14. To save the service screen view as an image:
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a. Select Save Service Image.

The Save Service Image dialog appears.

b. Navigate to the desired folder and enter the filename.

The default file format is png. To save the file in jpg format, enter .jpg at the end

of the filename.

c. Click Save.

You have successfully completed this procedure.

Activating an Optical Service in a BTI7000Network

• Activating an Optical Service Between BTI7000 Optical Port Endpoints on page 306

• Activating an Optical Service Between Transponder Interface Endpoints on page 308

• Examples Of Path Selection in a BTI7000 Optical Network on page 316

Activating an Optical Service Between BTI7000Optical Port Endpoints

Use this procedure to configure and activate an optical service betweenBTI7000optical

ports across a BTI7000 network. The BTI7000 optical network is called the BTI7000

Series Dynamic Optical Layer (DOL).

1. Select Tools >Service Activation >Optical >Ports. Alternatively, click the Service

Activation button on the toolbar, and selectOptical >Ports.

Optical ports service activation is used when the specified endpoints are ports on

optical equipment, such as a service between BTI7000 DOL endpoints.

The Activate Optical Service panel opens.

2. In the Service tab, enter the required information as described in the following table.
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Table 34: Fields in the Activate Optical Service Dialog

Required
field?DescriptionField

YesUser-defined name that uniquely identifies the service.Service
Name

OptionalSelect from the drop-down list. To add a customer to the list, select Edit>Add Customer from
themain menu. For more information on adding customers, see Adding a Customer.

Customer

YesChoose from a drop-downmenu of existing sites.Site A

YesChoose from a drop-downmenu of existing sites.Site Z

OptionalWhen selected, the service is not provisioned to add or drop on themultiplexer/demultiplexer,
but on the Alien/C2 port of the ROADMmodule.

NOTE: This option is not available for selection in a split ROADM node. In a split ROADM node,
theAlien/C2 interface is used toconnect theROADMmodules together andcannotbeconfigured
for Add/Drop wavelengths.

Alien/C2

YesChoose fromadrop-down list of possible paths fromSiteA toSite Z. Eachpathhas the following
format:

<Site A> to <Site Z> [via <Site N1>[; <Site N2>[;...]]]

where <Site Nx> represents a decision point for a ROADMwith more than two degrees. Each
decision point specifies the incoming and outgoing degrees for the path through that NE. See
“Examples Of Path Selection in a BTI7000 Optical Network” on page 316 .

NOTE: Bydefault, themaximumnumber of spans that apath canhave is 10. If your path requires
more than 10 spans, contact Juniper Networks Support to increase this limit.

Path

YesChoose from a drop-down list of existing channels.Channel

OptionalWhen selected, the Path and Channel for the protected path can be specified. This selection is
greyed out if no alternative path exists.

Second
Path

3. Click Activate.

ThePSMserver sends theactivation request to thenetwork element. You canmonitor

the status of the request through the View >Server >Taskswindow. The new service

appears in the Network tree a short while after the task completes successfully. As

part of service activation, PSMcreates all the necessary optical cross-connects along

the path between the specified endpoints.

Youmust wait for the activation tasks to complete before performing any other

operation on the NEs affected by this activation.

You have successfully completed this procedure.
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Activating an Optical Service Between Transponder Interface Endpoints

Use this procedure to set up a BTI7000 optical service between transponder interfaces

residing on BTI7800 Series network elements, MX Series or PTX Series routers, or QFX

Series switches.

This procedure creates a new service that can be viewed in PSM as either a transport

service or an optical service. The transport service component shows the transponder

endpoints connectedacross the transport network.Theoptical servicecomponent shows

the underlying optical network between themultiplexer/demultiplexer endpoints.

Prerequisites:

• The BTI7000 optical network must be set up and an optical channel (wavelength)

must be available between the two endpoints across the network.

• If an interface endpoint is on an MX Series or PTX Series router or QFX Series switch,

the interface endpoint must already exist. You cannot use PSM to create an interface

endpoint on a router or switch.

• The interface endpoints must be configured properly with the samemodulation, FEC,

and line encoding, and use the same wavelength. To configure an interface on a

BTI7800 UFM, see “Editing an Interface” on page 205. To configure an interface on an

MXSeriesorPTXSeries routerorQFXSeries switchusingPSM, see “Editingan Interface”

on page 258.

Table 35 on page 308 shows the optical service endpoint pairings that PSM supports.

NOTE: PSM does not perform compatibility validation of the interface
endpoints prior to service activation other than to ensure that the endpoints
are allowed according to Table 35 on page 308 and that the wavelengths
configured at both interface endpoints are the same.

If you configure the interface endpoints to have incompatible modulation schemes or

FECsettings, PSMwill set up theoptical servicebutwill not beable to set up the transport

service. PSMwill show the unsuccessful transport service as semi-stranded (with

incompatibleendpoints). This is nodifferent than if youwere toconnect themisconfigured

endpoints together directly instead of through an optical network.

Table 35: Supported Interface Endpoints for the BTI7000Optical Service

NotesSite Z (interface)Site A (interface)

Site A and Site Z are interfaces on the
UFM3 andUFM4.

BTI7800 UFM otu4BTI7800 UFM otu4

Site A and Site Z are interfaces on the
UFM3.

BTI7800 UFM 100geBTI7800 UFM 100ge

Site A and Site Z are line interfaces on
the UFM6.

BTI7800 UFM6 ochBTI7800 UFM6 och
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Table 35: Supported Interface Endpoints for the BTI7000Optical Service (continued)

NotesSite Z (interface)Site A (interface)

Site A and Site Z are interfaces on the
following:

MX Series router:

• 100-Gigabit DWDMOTNMIC with
CFP2-ACO (MIC3-100G-DWDM)

• 100-Gigabit Ethernet MICwith CFP2
(MIC6-100G-CFP2 ) with a
CFP2-DCO

• 2x100GE + 4x10GEMPC5E
(MPC5E-100G10G)withaCFP2-DCO

PTX Series router:

• 100-Gigabit DWDMOTN PIC with
CFP2-ACO (PTX-5-100G-WDM)

• 100-Gigabit Ethernet OTN PIC with
CFP2 (P2-100GE-OTN) with
CFP2-DCO

MX Series or PTX Series etMX Series or PTX Series et

SiteAandSite Z are 10GE interfaces on
the following MPCs on an MX Series
router:

• 6x40GE + 24x10GEMPC5E
(MPC5E-40G10G)

• 6x40GE + 24x10GEMPC5EQ
(MPC5EQ-40G10G)

• 2x100GE + 4x10GEMPC5E
(MPC5E-100G10G)

• 2x100GE + 4x10GEMPC5EQ
(MPC5EQ-100G10G)

MX Series xeMX Series xe

Site A and Site Z are line interfaces on
the QFX10K DWDM 1.2T Line Card
(QFX10K-12C-DWDM) on a QFX series
switch.

QFX Series otQFX Series ot

Site A is a line interface on the UFM6.

Site Z is a line interface on the QFX10K
DWDM 1.2T Line Card
(QFX10K-12C-DWDM) on a QFX series
switch.

QFX Series otBTI7800 UFM6 och

Site A is a line interface on the UFM6.

Site Z is an interface on the UFM3
orUFM4.

BTI7800 UFM otu4BTI7800 UFM6 och
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Table 35: Supported Interface Endpoints for the BTI7000Optical Service (continued)

NotesSite Z (interface)Site A (interface)

Site A is a line interface on the UFM6.

Site Z is an interface on the following:

MX Series router:

• 100-Gigabit DWDMOTNMIC with
CFP2-ACO (MIC3-100G-DWDM)

• 100-Gigabit Ethernet MICwith CFP2
(MIC6-100G-CFP2 ) with a
CFP2-DCO

• 2x100GE + 4x10GEMPC5E
(MPC5E-100G10G)withaCFP2-DCO

PTX Series router:

• 100-Gigabit DWDMOTN PIC with
CFP2-ACO (PTX-5-100G-WDM)

• 100-Gigabit Ethernet OTN PIC with
CFP2 (P2-100GE-OTN) with
CFP2-DCO

MX Series or PTX Series etBTI7800 UFM6 och

Site A is an interface on the UFM3.

Site Z is an interface on the following:

MX Series router:

• 100-Gigabit DWDMOTNMIC with
CFP2-ACO (MIC3-100G-DWDM)

• 100-Gigabit Ethernet MICwith CFP2
(MIC6-100G-CFP2 ) with a
CFP2-DCO

• 2x100GE + 4x10GEMPC5E
(MPC5E-100G10G)withaCFP2-DCO

PTX Series router:

• 100-Gigabit DWDMOTN PIC with
CFP2-ACO (PTX-5-100G-WDM)

• 100-Gigabit Ethernet OTN PIC with
CFP2 (P2-100GE-OTN) with
CFP2-DCO

MX Series or PTX Series etBTI7800 UFM otu4

Site A is a line interface on the QFX10K
DWDM 1.2T Line Card
(QFX10K-12C-DWDM) on a QFX series
switch.

Site Z is an interface on the UFM3
orUFM4.

BTI7800 UFM otu4QFX Series ot
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Table 35: Supported Interface Endpoints for the BTI7000Optical Service (continued)

NotesSite Z (interface)Site A (interface)

Site A is a line interface on the QFX10K
DWDM 1.2T Line Card
(QFX10K-12C-DWDM) on a QFX series
switch.

Site Z is an interface on the following:

MX Series router:

• 100-Gigabit DWDMOTNMIC with
CFP2-ACO (MIC3-100G-DWDM)

• 100-Gigabit Ethernet MICwith CFP2
(MIC6-100G-CFP2 ) with a
CFP2-DCO

• 2x100GE + 4x10GEMPC5E
(MPC5E-100G10G)withaCFP2-DCO

PTX Series router:

• 100-Gigabit DWDMOTN PIC with
CFP2-ACO (PTX-5-100G-WDM)

• 100-Gigabit Ethernet OTN PIC with
CFP2 (P2-100GE-OTN) with
CFP2-DCO

MX Series or PTX Series etQFX Series ot

NOTE: The Site A and Site Z designations in the table above are used only
to distinguish between the two interface endpoints. They are assigned
arbitrarily and are interchangeable.

Figure 66 on page 312 shows devices with transponder interfaces connected across a

BTI7000 optical network. The transponder interfaces attach to the optical network

through a port on a BTI Series multiplexer/demultiplexer. Each port on the

multiplexer/demultiplexer is associated with a different wavelength. Therefore, the

attachment point on themultiplexer/demultiplexer determines the optical channel to

use through the network.

311Copyright © 2019, Juniper Networks, Inc.

Chapter 11: Managing Optical and Transport Services



Figure 66: Optical Service Between Transponder Endpoints
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NOTE: The connection between themultiplexer/demultiplexer port and the
locally-attached interfacemust bemanually configured. This connection is
not automatically learned. See step 1.

Alternatively, you can activate an optical service where one or both router endpoints

connect to the C2 port of a BTI7000 DOL ROADMmodule. This is not shown. In this

situation, because the C2 port is not associated with a specific wavelength, PSM can

only activate this type of service if it can determine the desired wavelength. PSM can

determine the desired wavelength if the device interface endpoint has a configured

wavelength or if the other service endpoint is connected to amultiplexer/demultiplexer.

For more information on this special configuration, contact Juniper Networks Support.
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1. Before youcanactivate this service, youmust configure theactual connectionbetween

themultiplexer/demultiplexer port and the locally-attached interface endpoint if you

have not already done so.

This is performed by configuring the Remote ID on the respective

multiplexer/demultiplexer port. For information on how to do this, see “Setting the

Remote ID on a Multiplexer/Demultiplexer” on page 80.

NOTE: Each port on themultiplexer/demultiplexer is associated with a
specific wavelength. Themultiplexer/demultiplexer port on which you
configure theRemote IDmust be at the samewavelength as the interface
endpoint to which it is connected.

For example, this configures the Remote ID on channel 570 (195.70 THz) on the

multiplexer/demultiplexer to point to a locally-attached BTI7800 UFM interface at

10.228.220.104, slot 2, subslot 1, port 1. Note that the UFM interface must also be

configured for the 195.70 THz frequency.

The following example configures the Remote ID on channel 185 (191.85 THz) on the

multiplexer/demultiplexer to point to a locally-attached router interface at

192.168.7.50, slot 1, MIC 0, port 0. Note that the interface must also be configured for

the 191.85 THz frequency.
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ClickOK. The PSM server sends the configuration request to the network element.

You canmonitor the status of the request through the View >Server >Taskswindow.

2. Repeat step 1 toconfigure theconnectionbetween theothermultiplexer/demultiplexer

and the other router. Youmust use the same channel number.

3. Verify that the Remote ID configuration has taken effect.

Right-click themultiplexer/demultiplexer port/channel at eachendandselectRemote

ID >Edit and confirm that the settings are correct in the resulting Provision Remote

Port IDdialog. Do not proceed to the next step until theRemote IDs are correct at both

ends.

4. Create the service.

Select Tools >Service Activation >Optical >Interfaces. Alternatively, click the Service

Activation button on the toolbar, and selectOptical >Interfaces.
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Optical interfacesserviceactivation isusedwhen thespecifiedendpointsare interfaces

that connect to the optical network, such as a service between transponder interface

endpoints across a BTI7000 DOL network.

The Activate Optical Service panel appears.

5. In theOptical tab, enter the required information as described in the following table.

Table 36: Fields in the Activate Optical Service Panel

Required
field?DescriptionField

YesUser-defined name that uniquely identifies the service.Service
Name

OptionalSelect from the drop-down list. To add a customer to the list, select Edit>Add Customer from
themain menu. For more information on adding customers, see Adding a Customer.

Customer

YesChoose the interfaceendpoint fromthedrop-downmenu.Thedrop-downmenu listsall possible
endpoints. It does not matter which end you choose as Site A.

Site A

YesChoose the other interface endpoint from the drop-downmenu. The drop-downmenu lists all
possible endpoints for Site A. PSM creates this list based on the Remote ID configurations and
the availability and compatibility of Site Z.

Site Z

YesChoose from a drop-down list of possible paths from Site A to Site Z. Depending on the optical
network topology, there might bemore than one path through the network.

NOTE: Bydefault, themaximumnumber of spans that apath canhave is 10. If your path requires
more than 10 spans, contact Juniper Networks Support to increase this limit.

Path

6. Click Activate.

ThePSMserver sends the activation request to thedevice. You canmonitor the status

of the request through the View >Server >Taskswindow. The new service appears in

theNetwork tree a shortwhile after the task completes successfully. As part of service

activation, PSM creates all the necessary optical cross-connects along the path

between the specified endpoints.
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Youmust wait for the activation tasks to complete before performing any other

operation on the NEs affected by this activation.

NOTE: This procedure creates a new service that can be viewed in PSM as
either a transport service or an optical service. The transport service
componentshowsthetransponderendpointsconnectedacross thetransport
network.Theoptical servicecomponentshowstheunderlyingopticalnetwork
between themultiplexer/demultiplexer endpoints. For information on how
to view these services, see “Visualizing a Transport Service” on page 324 and
“Visualizing an Optical Service” on page 301 respectively.

NOTE: If an optical service already exists between the
multiplexer/demultiplexer ports andyou subsequently configure theRemote
IDs on those ports, then PSM automatically creates the accompanying
transport service.

Examples Of Path Selection in a BTI7000Optical Network

When you activate an optical service, you need to select the first (primary) path and

channel, and optionally the second (protected) path and channel between the service

endpoints. All paths and channels are selected from drop-downmenus in theActivate

OpticalServicedialog. Thedrop-downmenus list all the valid possibilities. A secondpath

can only be selected if an alternative path exists. Otherwise the Second Path check box

is greyed out and cannot be selected.

The path itself might contain decision points. A decision point refers to the decision that

needs to bemadewhen traversing ROADMnodeswithmore than 2 degrees.Whenmore

than 2 degrees exist, there can bemultiple outgoing degrees for each incoming degree.

The decision point qualifies the path by specifying the incoming and outgoing degrees

through these nodes.

Selecting Paths and Channels

Figure 67 on page 317 shows the selection of the first path and channel for a service

between NEW-YORK and MIAMI. The topology is a ring with 2-degree ROADMs in

NEW-YORK, MIAMI, and DALLAS, and a line amplifier node in CHICAGO. The first path

is chosen to be the shortest path around the ring.
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Figure 67: Selecting the First Path and Channel

Figure68onpage317 shows theselectionof thesecondpathandchannel. In this topology,

a second path is possible via CHICAGO and DALLAS.

Figure 68: Selecting the Second Path and Channel

Selecting a Path with No Decision Points

Figure69onpage318 shows the selectionof apathwithnodecisionpoints. The topology

is a ring with 2-degree ROADMs in NEW-YORK, MIAMI, and DALLAS, and a line amplifier

node in CHICAGO. The path merely specifies the start and end points.
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Figure 69: Selecting a Path with No Decision Points

Selecting a Path with One Decision Point

Figure 70 on page 318 shows the selection of a path with one decision point. A 4-degree

ROADM is at 10.1.207.9while the other sites contain 2-degree ROADMs. The decision

point is at 10.1.207.9 going from degree 1 to degree 2, representing the most direct path

between 10.1.207.1 and 10.1.207.2.

Figure 70: Selecting a Path with One Decision Point
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Selecting a Path with Two Decision Points

Figure 71 on page 319 shows the selection of a path with two decision points. The first

decision point is at 10.1.207.9 going from degree 1 to degree 4 traversing the ring in one

direction, and the second decision point is at 10.1.207.9 going from degree 3 to degree 2,

re-entering the 4-degree ROADM from the other side of the ring.

Figure 71: Selecting a Path with Two Decision Points

Activating an Optical Service in a BTI7800Network

Use this procedure to configure and activate an optical service on a BTI7800 network.

Prerequisites

• All required intra-node fiber connections are created. These are the fiber connections

that connect the endpoint to the ROADMmodule and between ROADMmodules.

• All required inter-node fibers are physically connected. These are the line span fibers

that connect ROADM nodes together.

• All required lineport optical channels are createdonall nodes that the service traverses.

1. Select Tools >Service Activation >Optical >Interfaces. Alternatively, click the Service

Activation button on the toolbar, and selectOptical >Interfaces.

Optical interfacesserviceactivation isusedwhen thespecifiedendpointsare interfaces

thatconnect to theopticalnetwork, suchasaservicebetweenUFM interfaceendpoints

across a BTI7800 Series optical network.

The Activate Optical Service panel appears.
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2. In theOptical tab, enter the required information as described in the following table.

Table 37: Fields in the Activate Optical Service Panel

Required
field?DescriptionField

YesUser-defined name that uniquely identifies the service.Service
Name

OptionalSelect from the drop-down list. To add a customer to the list, select Edit>Add Customer from
themain menu. For more information on adding customers, see Adding a Customer.

Customer

YesChoose fromadrop-downmenuof existing sitesandchannels. PSMprovidesa list of all possible
endpoints. TheSiteAendpoint canbean interfaceonaUFMor, if configuringanalienwavelength,
an optical channel on a ROADM client port.

An alien wavelength is a wavelength that is added and dropped to a local external endpoint.
The external endpoint can be on a UFM on a different BTI7800, or on other vendors' equipment.
Since the endpoint is external and beyond themanagement of PSM, the endpoint you select for
an alien wavelength is an optical channel on the ROADM client port.

Site A

YesChoose fromadrop-downmenuof existing sitesandchannels. PSMprovidesa list of all possible
endpoints that can be reached from Site A. PSM creates this list based on the fiber connections
and the existence and availability of the optical channel from Site A all along the path to Site Z.

TheSiteZendpoint canbean interfaceonaUFMor, if theendpoint is external (alienwavelength),
an optical channel on a ROADM client port.

Site Z

YesChoose from a drop-down list of possible paths from Site A to Site Z.

NOTE: Bydefault, themaximumnumber of spans that apath canhave is 10. If your path requires
more than 10 spans, contact Juniper Networks Support to increase this limit.

Path

3. Click Activate.

ThePSMserver sends theactivation request to thenetwork element. You canmonitor

the status of the request through the View >Server >Taskswindow. The new service

appears in the Network tree a short while after the task completes successfully. As
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part of service activation, PSMcreates all the necessary optical cross-connects along

the path between the specified endpoints.

Viewing the Cross-Connects in an Optical Service

Use this procedure to view the cross-connects in an activated optical service.

1. In the Network tree, double-click the service you want to view. Alternatively, select

the service, right-click and choose View.

The Service Attributes window opens.

2. Click on the Cross Connects tab to see the cross-connects that make up the service

on all network elements .

Updating an Optical Service

Use this procedure to change the service name and customer of an activated optical

service.

1. On theNetwork tree, double-click the service youwant to update. Alternatively, select

the service, right-click and choose View.

The Service Attributes window opens.

2. Modify the Customer or Service Name.

3. Click Apply.

The optical service is updated. If you update an optical service that is supporting a

transport service with BTI7800, MX Series , PTX Series, or QFX Series endpoints, the

transport service is updated implicitly.

Deleting an Optical Service

Use this procedure to delete an optical service.

When a service is deleted, the associatedmodules and ports remain in the UP state.

1. In the Network tree, right-click an optical service and choose Delete.

An information window opens asking for confirmation.
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2. ClickOK.

The optical service is deleted from the network elements and the PSM server. If you

delete an optical service that is supporting a transport service with BTI7800, MX

Series, PTX Series, or QFX Series endpoints, the transport service is deleted implicitly.

Viewing the Optical Services Table

You can view a list of the optical services with information such as Customer, Service

Name, Channel, Site A, Site Z, End-To-End State, Intermediate Nodes, andmore.

1. Toviewtheoptical services table, fromthemainmenuchooseView>Optical>Services.

The Optical Services tab is displayed.

NOTE: To apply filters to this table, see “Working with Optical/Transport
Services and Topology Tables” on page 334

2. Use the scroll bar on the right side of the window to scroll through the list of services.

Viewing the Optical Services Per Span Table

You can viewa list of the optical services per spanwith information such asSpanSource,

Span Far-End, Channel, Service Name, Customer Name, Service Site A, Service Site Z,

Source Port State, Source Port Admin State, Far-End Port State, Far-End Port Admin

State information, andmore.

1. Toview theoptical services per span table, from themainmenuchooseView>Optical

>Services per Span.

The Optical Services per Span tab is displayed.

NOTE: To apply filters to this table, see “Working with Optical/Transport
Services and Topology Tables” on page 334
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2. Use the scroll bar on the right side of the window to scroll through the list of services

per span.

Viewing the Optical Topology Table

You can viewa table of the optical topologywith information such asSourceSite, Source

Degree, Source Port, Far-End Site, Far-End Degree, Administrative Status, State, Span

Length (km), Max. Span Loss (dB), Channel Count information, andmore.

The optical topology table has a row for each end of the link (that is, for each connection

shown in the topology view, there are two rows in the table). If only one end of the link

is discovered, only one row is displayed. This table contains the same information shown

in the tool tip, but canbemanipulatedwith the sortingand filtering functionality available

for all tables.

1. To view the optical topology table, from themain menu choose View >Optical

>Topology.

The Optical Topology tab displays.

NOTE: To apply filters to this table, see “Working with Optical/Transport
Services and Topology Tables” on page 334

2. Use the scroll bar on the right sideof thewindowto scroll through theoptical topology

details.

Transport Services

Atransport serviceprovidesSONET/SDH,OTN,orphysical Ethernet connectivitybetween

transport serviceendpoints. A transport serviceendpoint is a client interfaceon transport

equipment.

PSMallows you tomanage transport services for BTI7800Series network elements. The

service spans between UFM client interfaces through a series of cross-connects across

the network.
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Additionally, PSM allows you to manage the transport service component of a BTI7000

optical service that has BTI7800, MX Series or PTX Series router or QFX Series switch

endpoints.

• Visualizing a Transport Service on page 324

• Activating a Transport Service on page 328

• Updating a Transport Service on page 332

• Deleting a Transport Service on page 332

• Viewing the Transport Services Table on page 332

• Viewing the Transport Services Per Span Table on page 333

• Viewing the Transport Topology Table on page 333

• Viewing the Transponder Tuning Grid on page 334

Visualizing a Transport Service

Use this procedure to visualize a transport service in a BTI7800 network or a transport

service with BTI7800, MX Series, PTX Series, or QFX Series endpoints across a BTI7000

optical network.

NOTE: Notall transport servicesareexplicitly created. If youcreateanoptical
servicewith BTI7800,MXSeries, PTXSeries, orQFXSeries endpoints across
aBTI7000opticalnetwork,PSMautomaticallycreates the resulting transport
service between the interface endpoints. If you create an optical service
across a BTI7000 optical network and subsequently configure the Remote
IDs to point to supported interfaces on BTI7800, MX Series, PTX Series, or
QFXSeriesendpoints,PSMalsoautomatically creates the resulting transport
service between the interface endpoints.
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1. To see a summary of a transport service, hover over the service in the Network tree

under the Transport branch (Figure 72 on page 325 and Figure 73 on page 325).

Figure 72: Hovering Over a Transport Service

Figure 73:HoveringOver theTransport ServiceComponent of aBTI7000Optical Service

2. To see a transport service in its own panel, select it in the Network tree under the

Transport branch.

NOTE: If this is your first time visualizing this service, you will see the
administratively-defined default layout if it exists. If a default layout does
not exist for this service, then you will see the layout that PSM
automatically generates. See 11.

NOTE: If this is your second or subsequent time visualizing this service,
you will see the layout that existed when you last exited this service view.

3. If a link in the transport service is running over an underlying optical service, the link is

shown with a icon. This is how the transport service component of a BTI7000

optical service with transponder interface endpoints is displayed.

For example:
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If you right-click the link and selectOptical Service (or right-click the service in the

Network tree and select Navigate >Optical Service), PSM displays the underlying

optical service in the Optical service view:

To go back to the Transport service view, select the Transport tab as you normally do

when you navigate between views. For more information on the Optical service view,

see “Visualizing an Optical Service” on page 301.

4. To see the interface associated with a service endpoint, right-click the endpoint and

select Navigate >Interface.

The interface associated with the endpoint is highlighted in the Network tree.

5. To see details on a network element, link, or port, hover over the network element,

link, or port.

6. To see the equipment on a network element, double-click the NE.

The equipment and connections are shown in a zoomed-in view.
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7. To change the size of the service view:

a. Right-click the background and select Zoom In to increase the view size

b. Right-click the background and select ZoomOut to decrease the view size

c. Right-click the background and select Reset Zoom to return the view size to its

original size

Alternatively, you can use your mouse scroll wheel.

8. Right-click anetwork elementandselectNetworkElement to see the regularNEmenu

options.

9. Tomove elements in this view, drag elements to the desired location.

10. Tomove all of the ports and switches in the service, choose Select All and drag the

service within the window.

11. You can save the current layout as the default, or revert to the default, or revert to the

layout that PSM automatically generates.

a. To save the current layout as the default layout for this service, right-click the

background and select Save Layout as Default.

NOTE: Youmust have administrator privileges to execute this
command.

Once the current layout is saved as the default, subsequent users who visualize

this service will be able to see the current layout.

b. To reset the current layout to the default, right-click the background and select

Reset Layout to Default.
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c. To reset the current layout to the layout that PSM automatically generates,

right-click the background and select Reset Layout.

12. To save the service screen view as an image:

a. Select Save Service Image.

The Save Service Image dialog appears.

b. Navigate to the desired folder and enter the filename.

The default file format is png. To save the file in jpg format, enter .jpg at the end

of the filename.

c. Click Save.

You have successfully completed this procedure.

Activating a Transport Service

Use this procedure to configure and activate a transport service for BTI7800 Series

network elements.

In general, a transport service connects two client interfaces together through a series

of cross-connects across a network. However, a service can also consist of a single

cross-connect where both ends of the service reside on a single UFM.

You can configure and activate a transport service between BTI7800 Series network

elements only. See Table 38 on page 328 for the supported client interface endpoints.

TheAandZdesignations in the tableareusedonly todistinguishbetween the twoservice

endpoints. They are assigned arbitrarily and are interchangeable. For more information

on cross-connects, refer to the BTI7800 Series Software Configuration Guide.

Table 38: Supported Service Activation Endpoint

Site ZSite A

ClientModuleLineLineModuleClient

10geUFM3

UFM4

otu2otu2UFM3

UFM4

10ge

10geUFM3otu2eotu2eUFM310ge

10geUFM3

UFM4

odu2/otu4odu2/otu4UFM3

UFM4

10ge

10geUFM3odu2e/otu4odu2e/otu4UFM310ge

10geUFM6odu2e/otu4/ochodu2e/otu4/ochUFM610ge

oc192UFM3

UFM4

otu2otu2UFM3

UFM4

oc192
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Table 38: Supported Service Activation Endpoint (continued)

Site ZSite A

ClientModuleLineLineModuleClient

oc192UFM3

UFM4

odu2/otu4odu2/otu4UFM3

UFM4

oc192

oc192UFM6odu2/otu4/ochodu2/otu4UFM3

UFM4

oc192

oc192UFM6odu2/otu4/ochodu2/otu4/ochUFM6oc192

stm64UFM3

UFM4

otu2otu2UFM3

UFM4

stm64

stm64UFM3

UFM4

odu2/otu4odu2/otu4UFM3

UFM4

stm64

stm64UFM6odu2/otu4/ochodu2/otu4UFM3

UFM4

stm64

stm64UFM6odu2/otu4/ochodu2/otu4/ochUFM6stm64

wanoc192UFM3

UFM4

otu2otu2UFM3

UFM4

wanoc192

wanoc192UFM3

UFM4

odu2/otu4odu2/otu4UFM3

UFM4

wanoc192

wanstm64UFM3

UFM4

otu2otu2UFM3

UFM4

wanstm64

wanstm64UFM3

UFM4

odu2/otu4odu2/otu4UFM3

UFM4

wanstm64

8gfcUFM6odu2/otu4/ochodu2/otu4/ochUFM68gfc

10gfcUFM6odu2e/otu4/ochodu2e/otu4/ochUFM610gfc

otu2UFM3

UFM4

otu2otu2UFM3

UFM4

otu2
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Table 38: Supported Service Activation Endpoint (continued)

Site ZSite A

ClientModuleLineLineModuleClient

otu2UFM3

UFM4

odu2/otu4odu2/otu4UFM3

UFM4

otu2

otu2UFM6odu2/otu4/ochodu2/otu4UFM3

UFM4

otu2

otu2UFM6odu2/otu4/ochodu2/otu4/ochUFM6otu2

otu2eUFM3otu2eotu2eUFM3otu2e

otu2eUFM3odu2e/otu4odu2e/otu4UFM3otu2e

otu2eUFM6odu2e/otu4/ochodu2e/otu4UFM3otu2e

otu2eUFM6odu2e/otu4/ochodu2e/otu4/ochUFM6otu2e

40geUFM6odu3/otu4/ochodu3/otu4/ochUFM640ge

100geUFM3

UFM4

otu4otu4UFM3

UFM4

100ge

100geUFM6otu4/ochotu4UFM3

UFM4

100ge

100geUFM6otu4/ochotu4/ochUFM6100ge

otu4UFM3

UFM4

otu4otu4UFM3

UFM4

otu4

otu4UFM6otu4/ochotu4UFM3

UFM4

otu4

otu4UFM6otu4/ochotu4/ochUFM6otu4

NOTE: The UFM6 line port is represented by an optical channel (och)
interface. The optical channel can contain up to two OTU4 signals. In order
to interwork with UFM3 and UFM4OTU4 line interfaces, youmust configure
the optical channel interface on the UFM6 for a single OTU4 signal using
QPSKmodulation.Formore information,see“AddinganInterface”onpage198.
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1. Select Tools >Service Activation >Transport. Alternatively, click the Service Activation

button on the toolbar, and select Transport, or right-click Transport in the Network

tree and select Service Activation.

The Activate Transport Service dialog opens.

2. Enter the required information as described in the following table.

Table 39: Fields in the Activate Transport Service Dialog

Required
field?DescriptionField

YesUser-defined name that uniquely identifies the service.Service
Name

OptionalSelect from the drop-down list. To add a customer to the list, select Edit>Add Customer from
themain menu. For more information on adding customers, see Adding a Customer.

Customer

YesClick and choose from a drop-downmenu of existing sites. See Table 38 on page 328 for the
supported client interface endpoints.

Site A

YesClick and choose from a drop-downmenu of existing sites. See Table 38 on page 328 for the
supported client interface endpoints. Only those endpoints that can be reached from Site A are
shown.

Site Z

YesChoose from a drop-down list of possible paths from Site A to Site Z.Path

3. Click Activate.

ThePSMserver sends theactivation request to thenetwork element. You canmonitor

the status of the request through the View >Server >Taskswindow. The new service

appears in the Network tree a short while after the task completes successfully. As

part of service activation, PSM creates all the necessary transport cross-connects

along the path between the specified endpoints.
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You have successfully completed this procedure.

Updating a Transport Service

Use this procedure to change the service name and customer of an activated transport

service.

1. In the Network tree, double-click the service you want to update. Alternatively, select

the service, right-click, and choose View.

The Service Attributes window opens.

2. Modify the Customer or Service Name. Click Update.

The transport service is updated. If you update a transport service with BTI7800, MX

Series, PTX Series, or QFX Series endpoints across a BTI7000 optical network, the

underlying optical service is updated implicitly.

Deleting a Transport Service

Use this procedure to delete a transport service.

When a service is deleted, the state of the associatedmodules and ports remains

unchanged.

1. In the Network tree, right-click a transport service and choose Delete.

A dialog opens asking for confirmation.

2. ClickOK.

The transport service is deleted from the network elements and the PSM server. If

you delete a transport service with BTI7800, MX Series, PTX Series, or QFX Series

endpoints across a BTI7000 optical network, the underlying optical service is deleted

implicitly.

Viewing the Transport Services Table

Use this procedure to view the transport services table for BTI7800 Series network

elements.

1. From themain menu choose View >Transport >Services.

The Transport Services tab is displayed.
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NOTE: To apply filters to this table, see “Working with Optical/Transport
Services and Topology Tables” on page 334

2. Use the scroll bar on the right side of the window to scroll through the list of services.

Viewing the Transport Services Per Span Table

Use this procedure to view the transport services per span table for BTI7800 Series

network elements.

1. From themain menu choose View >Transport >Services per Span.

The Transport Services per Span tab is displayed.

NOTE: To apply filters to this table, see “Working with Optical/Transport
Services and Topology Tables” on page 334

2. Use the scroll bar on the right side of the window to scroll through the list of services

per span.

Viewing the Transport Topology Table

Use this procedure to view the transport topology table for BTI7800 Series network

elements.

1. From themain menu choose View >Transport >Topology.

The Transport Topology tab displays.
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NOTE: To apply filters to this table, see “Working with Optical/Transport
Services and Topology Tables” on page 334

2. Use the scroll bar on the right sideof thewindowto scroll through theoptical topology

details.

Viewing the Transponder Tuning Grid

Use this procedure to viewandoptionally export the transponder tuning grid for BTI7000

Series, BTI7800 Series, and BTI800 Series network elements.

The transponder tuninggrid showsthewavelengths, real-timeopticalPMdata,andother

information on transponder ports for the selected network element.

1. In theNetwork treeor theTopologyMapview, right-clickanetworkelementandselect

Node >Tuning Grid >View. Alternatively, right-click a shelf in the Network tree and

select Tuning Grid >View. This option is greyed out if the network element (or shelf)

does not contain at least one transponder card with at least one provisioned port

containing an XFP.

The Tuning Gridwindow appears.

2. To export the tuning grid in CSV format, select Export and enter the name of the file.

3. To refresh the real-time optical PM data, select Refresh.

Working with Optical/Transport Services and Topology Tables

PSM can display optical/transport services, optical/transport services per span, and

optical/transport topology information in table format. These tables canbemanipulated

to show information in different forms, depending on the need.

Sorting the Tables

The tables can be sorted in the following ways:

• To sort the tables by a column, click the column title.
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• To change the order (ascending or descending) of a column, click the column heading

until the arrow shows ascending or descending order as desired.

• To show or hide columns, right-click the table title bar and check the column names

youwant to show, and uncheck the column names youwant to hide in the drop-down

menu. Different tables have different column selections. Figure 74 on page 335 shows

the column selections for the optical topology table.

Figure 74: Optical Topology Column Selection

Filtering the Tables

The optical information tables behave as follows:

• If there is no filtering applied, the window title reflects the table being displayed, for

example "Optical Topology".

• If a filter is applied, the title changes to indicate the presence of the filter, for example

"Optical Topology (Filtered)".

• Each time a newentity or filter is chosen, the previous filtering is cleared and the tables

display the entries that pertain to the newly chosen criteria.

To filter the tables to show only a particular set of entries, right-click a cell in the column

of the table that has the data you want to filter with, and choose the filter option Show

only rowswhere to filter out (hide) all other entries from the table. In the following screen

for the optical services per span table, the filter chosen is to show only entries using

channel 230.
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NOTE: The View and Delete options in the right-click menu are not filtering

options.Viewbringsup the "ServiceAttributes"and"ServiceDetails"panels,

and Delete deletes the optical service.

To remove filtering, right-click any cell in the table and choose Showonly rowswhere>No

Filter.

Saving a Service Image

Use this procedure to save the service screen view to either a jpg or png image file. The

default file format is .png. To save the file in jpg format, enter .jpg at the end of the file

name.

1. In the main window, right-click and choose Save Service Image.

The windows file explorer window appears.

2. Navigate to the desired folder, specify a file name, and click Save.

Your service view is saved as an image.
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CHAPTER 12

Managing Ethernet Services

• Introduction on page 337

• Service Visualization on page 337

• Understanding Ethernet Service States on page 342

• Service Activation on page 344

• Modifying a Service on page 399

• Deleting a Service on page 402

• Adding SLA/CFM to a Service on page 402

• Running a Y.1731 Link Trace on page 408

• Running a Y.1731 Loopback on page 409

• Running an RFC 2544 Benchmarking Test on page 410

• Ethernet Ring Protection Switching (ERPS) on page 414

• Routing Considerations in Mixed Networks on page 421

• Managing Profiles on page 426

Introduction

An Ethernet service provides Ethernet connectivity between Ethernet service endpoints.

An Ethernet service endpoint can be a UNI, NNI, or ENNI on a packet-aware module.

PSMcanbeused tomanageEthernet services on theBTI7000Series, theBTI700Series,

and the BTI800 Series network elements.

Service Visualization

PSM automatically discovers all Ethernet services in the network and displays them in

a graphical view.

• Visualizing an Ethernet Service on page 337

• Service Visualization Scheme on page 341

Visualizing an Ethernet Service

Use some or all of the techniques in this procedure to visualize an Ethernet service.
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1. In the Network tree, select the desired Ethernet service.

The selected Ethernet service opens in the main Topology window. If the service is

protected by ERPS, the service is shown connected to an ERPS icon. The ERPS icon

represents an ERPS ring. The green indicates that the ERPS ring is blocking its RPL

link, which is normal.

See “Service Visualization Scheme” on page 341 for details on this view, and see

“Ethernet Ring Protection Switching (ERPS)” on page 414 for details on ERPS.

NOTE: If this is your first time visualizing this service, you will see the
default layout that PSM automatically generates. The default layout can
be changed. See 9.

NOTE: If this is your second or subsequent time visualizing this service,
you will see the layout that existed when you last exited this service view.

2. Double-click the ERPS icon to zoom in to see the network elements comprising the

ERPS ring. Double-click again to zoom back out.

NOTE: Double-clicking to zoomworks only on the default PSM layout or
a smaller (more zoomed out) layout.
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The green indicates the RPL link that is blocked.

NOTE: The ERPS service itself can be visualized as well. For more
information, see “Visualizing an ERPS Service” on page 414.

3. Alternatively, right-click the ERPS icon and choose Expand ERPS Ring.

4. To change the size of the service view:

a. Right-click the background and select Zoom In to increase the view size.

Alternatively, you can zoom in by scrolling the mouse scroll wheel away from you.

b. Right-click the background and select ZoomOut to decrease the view size.

Alternatively, you can zoom out by scrolling the mouse scroll wheel towards you.

c. Right-click the background and select Reset Zoom to return the view size to its

original size.

5. Right-click anetwork elementandselectNetworkElement to see the regularNEmenu

options.
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6. Tomove elements in this view, click and drag elements to the desired location.

7. Tomove all of the ports and switches in the service, right-click the background and

choose Select All and drag the service within the window.

8. Bydefault, theconnectedNNIportsarehidden.Toviewtheconnectedports, right-click

the background and choose ShowConnected Ports. The screenshot below shows a

service with connected NNI ports displayed.

NOTE: Choosing ShowConnected Ports again toggles the setting.
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9. You can save the current layout as the default, or revert to the default, or revert to the

layout that PSM automatically generates.

a. To save the current layout as the default layout for this service, right-click the

background and select Save Layout as Default.

NOTE: Youmust have administrator privileges to execute this
command.

Once the current layout is saved as the default, subsequent users who visualize

this service will see the current layout.

b. To reset the current layout to the default, right-click the background and select

Reset Layout to Default.

c. To reset the current layout to the layout that PSM automatically generates,

right-click the background and select Reset Layout.

10. To save the service screen view as an image:

a. Select Save Service Image.

The Save Service Image dialog appears.

b. Navigate to the desired folder and enter the filename.

The default file format is png. To save the file in jpg format, enter .jpg at the end

of the filename.

c. Click Save.

11. To select all NEs in the service, click Select Network Elements.

This brings you back to themain Topology Map view and shows all NEs in the service

selected.

Service Visualization Scheme

The service visualization scheme provides visual details about the service, as shown in

the screens below and explained as follows:

• Grey indicates ports (UNI or NNI) added by the user.

• Faded grey indicates NNI ports added by the system using GVRP.

• Dashed black lines indicate logical connections on the switch showingwhich ports are

members of the switch.

• Solid blue lines indicate physical connections (fiber optic or Ethernet cables).

• The name of the NE (e.g. MIAMI) and the name of the switch (e.g. Switch Server_Sw):
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If the name of the NE has not been defined, the IP address is shown instead.

• Detailed information about a switch or port or link appear by simply hovering over the

icon in the Ethernet service topology view, as shown below:

Figure 75: Hovering Over a Switch

Figure 76: Hovering Over a UNI

Figure 77: Hovering Over a Link

Understanding Ethernet Service States

PSM provides information on the state of an Ethernet service.
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Each switchmaintains a state for every service configured on the switch. This state (one

per service) represents the state of the network connections to the remote MEPs, and

does not include the state of the endpoint UNIs. This state behaves as follows:

• Up - all remote MEPs are Up

• Down - one or more remote MEPs are Down

• Unknown - no remote MEPs exist

This state is shown in PSM by hovering over an NE in the Ethernet service topology view.

Additionally, PSMmaintains an End-to-End service state, which is an overall state that

considers the service states on all switches that have UNIs belonging to this service. The

End-to-End service state behaves as follows:

• Up - all service states for this service are Up

• Down - all service states for this service are Down

• Troubled - a mix of service states that are Up and Down

• Unknown - all service states for this service are Unknown

The End-to-End service state is shown in PSM by hovering over an NE in the Ethernet

service tree view. It is also recorded in the Ethernet services report (“Generating Ethernet

Reports” on page 493).
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Service Activation

PSM supports theMetro Ethernet Forum (MEF) paradigm for activating Layer 2 Ethernet

services in thenetwork. Aspart of service activation, youdefine the service and you select

the endpoints (and in some cases, the internal NNIs) that make up the service.

NOTE: Unless otherwise specified, all references to UNI include UNI LAG, all
references to NNI include NNI LAG, and all references to ENNI include ENNI
LAG.

An endpoint can be one of the following:

• An Ethernet UNI, which is an Ethernet user-to-network interface.

• An Ethernet ENNI, which is an external Ethernet network-to-network interface.

• An Ethernet NNI, which can be an internal or external Ethernet network-to-network

interface. An external NNI is an endpoint, but an internal NNI is not. If PSMdetects (via

LLDP discovery) that the NNI is connected to Juniper Networks equipment, PSM

considers that the NNI is internal. Otherwise, PSM considers the NNI is external, and

treats it as an endpoint. An NNI that is determined to be external is similar to an ENNI.

To avoid confusion, it is best to use ENNIs for external NNIs where possible. For those

network elements that do not support ENNI functionality, PSM continues to support

the ability to treat the regular NNI as an external endpoint where applicable.

NOTE: ENNI is supported on BTI7000 Series network elements starting in
Release 13.2 only. ENNI is not supported on any other network elements.

Before using PSM for service activation, you need to configure the packetVX cards on

the appropriate network elements, and create the virtual switches that represent those

cards. You should also create the necessary internal NNIs, but you do not need to create

the endpoints as you have the option of creating endpoints in PSMwhen you activate

the service. You can create internal NNIs in PSM as well, but if you create the internal

NNIs beforehand, PSMwill be able to query the network and use the discovered LLDP

topology to automatically select the appropriate internal NNIs as you add endpoints to

theservice. Theability toautomatically select the internalNNIs is called theAuto-Provision

NNIs feature.

NOTE: For the Auto-Provision NNIs feature to work properly, youmust create

all internal NNIs and bring up their links beforehand. In this situation, all NNIs
that you create as part of service activation are external endpoint NNIs.

Creating a UNI, NNI, or ENNI refers to the initial configuration needed to transform an

unprovisioned port to a UNI, NNI, or ENNI port.
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Selecting a UNI, NNI, or ENNI refers to choosing that UNI, NNI, or ENNI port to be part of

the service. When you select a UNI, NNI, or ENNI and you activate the service, PSM

performs the necessary configuration to include that port in the service.

NOTE: In PSM, if youuse theProvisionAs ... feature, you can create and select

a UNI, NNI, or ENNI in a single step.

Not all internal NNIs need to be selectedmanually. If the network is running GVRP, then

the network can select the internal NNIs automatically after the service is activated. In

other situations, PSM can automatically select and configure the internal NNIs that are

needed for the service. This is shown in the following table:

NNI SelectionNetwork Composition

You do not need to manually select the internal NNIs. The
BTI7000 Series network elements use GVRP to select and
configure the required internal NNIs. For more information on
GVRP, see “GVRP - GARP VLAN Registration Protocol” on
page 421.

The domain contains only BTI7000 Series network elements.

If all network elements in thedomain are running the following
minimum levels of software:

• BTI7000 Series - Release 10.3 or higher

• BTI700 Series - Release 1.5 or higher

• BTI718E - Any release

• BTI800 Series - Release 1.1 or higher

then you can use the Auto-Provision NNIs feature to instruct
PSM to automatically select the required internal NNIs.

NOTE: PSM uses topology information gathered from LLDP
to select the required NNIs. Only those NNIs that cannot be
configured using GVRP are selected.

Otherwise, youmustmanually select someorall of the internal
NNIs thatmake up the service. Formore information onwhich
internal NNIs you need to select, see “Mixed Networks -
BTI7000SerieswithBTI700SeriesorBTI800SeriesElements”
on page 422.

The domain contains one or more BTI700 Series network
elements or one or more BTI800 Series network elements.

• Service Types on page 346

• Auto-provisioning NNIs on page 347

• Activating an Ethernet Service on page 348

• Example: Activating an EVPLINE Service on page 364

• Example: Activating an Ethernet Service on a Multi-chassis LAG on page 377

• Example: Activating EVPLAN and EVPLINE Services Using Service Maps for Flow

Redirection on page 381
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Service Types

NOTE: Unless otherwise specified, all references to UNI include UNI LAG, all
references to NNI include NNI LAG, and all references to ENNI include ENNI
LAG.

The service types supported are listed in the table below. The Service Type selected in

the Service Attributes panel determines how UNIs can be used, and should be based on

the UNIs you have or expect to have in the service. The service type cannot be changed

once the service is activated. If the service does not and will not include any UNIs, then

you can set the service type to any value.

Table 40: Service Types

DescriptionService type

Used to replace TDM private lines.

A port-based service with a point-to-point EVC (Ethernet Virtual Connection)
between dedicated UNIs (that is, only a single EVC per UNI).

User can select a maximum of two endpoints.

EPLINE

(Ethernet Private Line)

Used to replace Frame Relay or ATM services.

A multiplexed service with a point-to-point EVC between service-multiplexed
endpoints (that is, multiple EVCs per endpoint).

User can select a maximum of two endpoints.

Allows a single physical connection to the attached equipment with multiple
virtual connections.

EVPLINE

(Ethernet Virtual Private Line)

Used to support transparent LAN services andmultipoint Layer 2 VPNs.

A port-based service with amultipoint-to-multipoint EVC across dedicated
endpoints (that is, only a single EVC per endpoint).

User can select more than two UNIs.

EPLAN

(Ethernet Private LAN)

Used to support transparent LAN services andmultipoint Layer 2 VPNs.

Amultiplexed service with amultipoint-to-multipoint EVC across
service-multiplexed endpoints (that is, multiple EVCs per endpoint).

User can select more than two endpoints.

EVPLAN

(Ethernet Virtual Private LAN)
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Table 40: Service Types (continued)

DescriptionService type

Used to support a multipoint service consisting of leaf endpoints and root
endpoints. Leaf endpoints and root endpoints can send and receive packets from
(other) root endpoints, but leaf endpoints cannot send and receive packets from
other leaf endpoints.

A port-based service with a rooted-multipoint EVC across dedicated endpoints
(that is, only a single EVC per endpoint).

User can select more than two endpoints.

This service type is only supported on BTI7000 Series network elements.

EPTREE

(Ethernet Private TREE)

Used to support a multipoint service consisting of leaf endpoints and root
endpoints. Leaf endpoints and root endpoints can send and receive packets from
(other) root endpoints, but leaf endpoints cannot send and receive packets from
other leaf endpoints.

A port-based service at the leaf nodes and amultiplexed service at the root node,
using a rooted-multipoint EVC across endpoints (that is, only a single EVC at the
leaf endpoint, andmultiple EVCs at the root endpoint).

User can select more than two endpoints.

This service type is only supported on BTI7000 Series network elements.

EVPTREE

(Ethernet Virtual Private TREE)

See the BTI7000 Series packetVX Solutions Guide for more details on Ethernet services

and Ethernet VCs.

Auto-provisioning NNIs

NOTE: Unless otherwise specified, all references to UNI include UNI LAG, all
references to NNI include NNI LAG, and all references to ENNI include ENNI
LAG.

PSM has the capability of selecting the necessary internal NNIs to add to the service.

Internal NNIs are the NNIs that connect the service endpoints together.

You should only choose this option if all network elements in the domain are running the

following minimum levels of software:

• BTI7000 Series - Release 10.3 or higher

• BTI700 Series - Release 1.5 or higher

• BTI718E - Any release

• BTI800 Series - Release 1.1 or higher

Additionally, all the required internal NNIs must already exist and their links brought up,

and LLDP enabled.
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When this option is selected, PSM uses topology information gathered from LLDP to

select and configure those required internal NNIs that do not haveGVRP enabled. If PSM

determines that GVRP is enabled on a particular NNI, it will let GVRP configure that NNI.

PSM selects internal NNIs differently depending on whether the required NNI is part of

anERPS ring or not. If theNNI is part of anERPS ring, thenPSMhas sufficient information

to determinewhether the NNI should be selected or not. If the NNI is not part of an ERPS

ring, then PSMuses amore liberal set of selection criteria andmight selectmore internal

NNIs than is necessary. In such a case, you canmanually delete the unnecessary NNIs

from the service.

As an alternative, you can force PSM to select a single path through non-ERPS nodes

when Auto-Provision NNIs is enabled. See the proNX Service Manager Installation and

Administration Guide for details.

Activating an Ethernet Service

Use this procedure to configure and activate an Ethernet service.

Prerequisites:

• All the necessary packetVX cards and virtual switches have been configured.

• ERPS rings (orMSTP) have been configured, as applicable. This prevents routing loops

whenmultiple paths exist through the network.

NOTE: Unless otherwise specified, all references to UNI include UNI LAG, all
references to NNI include NNI LAG, and all references to ENNI include ENNI
LAG.

Additionally:

NotesPrerequisiteIf you want to ...

When you activate a service, you
manually select (and/or create) all the
UNIs, NNIs, andENNIs thatmakeup that
service.

NOTE: After you activate, GVRP, if
enabled, might cause other NNIs to be
selected as well, but this is performed
outside of PSM.

There is no additional prerequisite.Select all UNIs, NNIs, and ENNIs
manually during service activation.

Copyright © 2019, Juniper Networks, Inc.348

proNX Service Manager User Guide



NotesPrerequisiteIf you want to ...

In a network that only contains BTI7000
Series network elements, GVRP can be
used to propagate VLANmembership
information to all the NNIs, making it
unnecessary toselectandconfigureeach
internal NNI individually from PSM. Just
select the endpoints and let GVRP
configure the required internal NNIs
(outside of PSM). PSM automatically
discovers and displays the internal NNIs
as soon as you select the service
endpoints.

If the internal NNIs are down or not yet
created, GVRPwill not be able to
configure the required internal NNIs. You
can activate the service but the service
will be disconnected. Once the internal
NNIshavebeencreatedand/or their links
broughtup, thepath through thenetwork
will beestablishedasVLANmembership
informationpropagates toall the internal
NNIs through GVRP.

In a mixed network that contains
BTI7000 Series, BTI700 Series, and/or
BTI800 Series network elements, you
might need to manually select internal
NNIs because not all of these devices
support GVRP. See “Activating Services
Over Combinations Of BTI7000 Series
packetVX and BTI700 Series or BTI800
Series Networks” on page 424

EnableGVRPonBTI7000Seriesnetwork
elements where possible.

Select endpoints manually and let the
network select internalNNIsusingGVRP.

This lets GVRP configure the required
internal NNIs where possible. If GVRP is
not enabled or not supported, then PSM
uses topological information gathered
by the NEs through LLDP, and
automatically selects the necessary
internal NNIs. PSM only selects those
internal NNIs that cannot be configured
using GVRP.

Ensure all network elements in the
domain are at the following minimum
levels of software:

• BTI7000 Series - Release 10.3 or
higher

• BTI700 Series - Release 1.5 or higher

• BTI718E - Any release

• BTI800 Series - Release 1.1 or higher

Enable LLDP on all network elements in
the domain.

Create all the required internal NNI ports
and bring their links up.

EnableGVRPonBTI7000Seriesnetwork
elements.

Select endpoints manually and let the
network select internalNNIsusingGVRP,
and let PSM select internal NNIs using
the Auto-Provision NNIs option.

The general service activation workflow is as follows:
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1. Create the Ethernet service and set the service-wide attributes.

2. Select ports to be added to the service.

3. Set the port-based attributes (optional).

4. Set the advanced switch-based and the advanced port-based attributes (optional).

5. Activate the service.

NOTE: ENNI is supported on BTI7000 Series network elements starting in
Release 13.2 only. ENNI is not supported on any other network elements.
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1. Create the Ethernet service and set the service-wide attributes.

a. Click the Service Activation button on the toolbar and choose Ethernet from the

drop-downmenu.

b. If you havemultiple domains, a Service Activation pop-up dialog box is displayed,

as shown.

From the Select Domain drop-downmenu, select a domain in which to create the

service. Each domain has its own S-VLAN ID namespace, allowing you to re-use

S-VLAN IDs across domains. ClickOK.

c. The Activate Ethernet Servicewindow appears, as shown.

In the Service Attributes pane of the Activate Ethernet Service window, enter the

required information as listed in the following table.

Table 41: Fields in the Service Attributes Pane

Required field?DescriptionField

YesUser-defined name that identifies the service. Must be unique to the
domain.

Service Name
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Table 41: Fields in the Service Attributes Pane (continued)

Required field?DescriptionField

YesAuto-populated with the next available value. Must be unique to the
domain. A value of -1 is shown if there are no SVLAN identifiers
available.

The auto-populated value can be overridden.

SVLAN

YesThemaximumframesize (inbytes) for theEthernet service. Applicable
to UNI ports on BTI7000 Series NEs only.

Default: 1522

For BTI7000 Series NEs, this value is used at each UNI port in the
service, andsupersedes (butmustnotbegreater than) the "MaxFrame
Size" setting configured on those ports. If this value is greater than the
"Max Frame Size" configured on any port in the service, an error
message appears.

For BTI700 Series and BTI800 Series NEs, this value is ignored. The
"Max Frame Size" configured on each port is used instead.

Max Frame Size

YesSee “Service Types” on page 346.

Default: EPLINE

NOTE: TheBTI700Seriesnetworkelementdoesnotmakeadistinction
between E(V)PLINE and E(V)PLAN service types. Consequently, PSM
might display a service type of an existing BTI700 Series service as
E(V)PLAN regardless of how it was originally configured.

NOTE: EPTREE and EVPTREE services are supported on BTI7000
Series NEs only.

Service Type

OptionalUser-defined. See “Adding a Customer” on page 454.Customer

OptionalSpecify whether you want PSM to select internal NNIs automatically.
This check box is selected by default. See “Auto-provisioning NNIs” on
page 347.

If you do not select this option, you will need to manually select the
required internal NNIs in a mixed network. For more information on
mixed networks, see “Mixed Networks - BTI7000 Series with BTI700
Series or BTI800 Series Elements” on page 422.

Auto-Provision NNIs

2. Select ports to be added to the service.

These ports can be endpoints and/or internal NNIs. Youmust always select the

endpoints.

Depending on configuration, youmight need to select internal NNIs. The rules for

internal NNI selection are as follows:

• Youmust not select internal NNIs if Auto-Provision NNIs is enabled.
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• Youmust select internalNNIs ifAuto-ProvisionNNIs is disabledandGVRP isdisabled

on theNNI ports being selected.GVRP is configuredon theNNI port using theproNX

900 or the CLI directly.

• If Auto-Provision NNIs is disabled and GVRP is enabled on the NNI ports being

selected, you can select internal NNIs but there is generally no added benefit to

doing so. GVRPwill select the appropriate internal NNIs for you.

NOTE: WhenyouselectanNNIport, youdonotmakeadistinctionbetween
an endpoint NNI and an internal NNI. PSMmakes that determination
automatically based on topology. If PSM detects (via LLDP discovery)
that theNNI is connected to Juniper Networks equipment, PSM considers
that the NNI is internal. Otherwise, PSM considers the NNI is external
(endpoint).

a. In the Service tab of the UNI/NNI/ENNI Ports panel, click on the icon.

The following dialog appears.

This dialog lets you specify UNI/NNI/ENNI ports to include in the service. These

ports are MEF interface ports on network elements within the selected domain.

Selecting an NE from the list auto-populates the switch members and ports that

are available for the Service Type chosen in the Service Attributes pane.

b. Select a network element, card and port. The port can be UNI or UNI LAG, NNI or

NNI LAG, ENNI or ENNI LAG, or Unprovisioned. You canmulti-select ports by using

the <ctrl> or <shift> keys, but you cannot multi-select a mix of provisioned and

unprovisioned ports. You will need to add these separately.

NOTE: If you did not selectAuto-ProvisionNNIs, youmight have to add

a number of internal NNIs to the service in order for traffic to be carried
through the network. See “Routing Considerations inMixed Networks”
on page 421.
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If you select an unprovisioned port in the Ports field, the Provision As field is

activated, allowing you to provision it as a UNI or UNI LAG, NNI or NNI LAG, ENNI or

ENNI LAG.

If you use the Provision As option to create a UNI LAG, an NNI LAG, or an ENNI LAG,

then all ports youmulti-select will be added to the LAG.

NOTE: If you use the Provision As field to create a newNNI port on a

BTI700 Series network element, you cannot use the proNX 900 to
reconfigure any of the settings on that port. If you want to be able to
use the proNX 900 to reconfigure the settings on that port, youmust
create the NNI port using the proNX 900 instead of using the Provision

As option.

c. Click Add UNI or Add UNI LAG, Add NNI or Add NNI LAG, or Add ENNI or Add ENNI

LAG depending on the type of port chosen.

PSMadds the port and any auto-selected internal NNI ports required. Additionally,

if the port that you are adding is a multi-chassis LAGmember, PSM automatically

addsallmembersof thatmulti-chassis LAGto theservice.See “Example:Activating

an Ethernet Service on a Multi-chassis LAG” on page 377 for a service activation

example involving amutli-chassis LAG.

d. After you have finished adding ports, click on the Service tab to view the added

ports.
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NOTE: PSMdisplaysawarningmessage if it cannot findall the internal
NNIs necessary for the service. This can occur if an internal NNI port is
down, for example. In this situation, you can still activate the service
but the servicemight not work.

e. To view the added ports, click on the Details tab.

The Details window displays the added ports, showing the containing NE, switch,

and LAG (if applicable). PSM displays the ports youmanually specified, and the

internal NNI ports that PSM has selected through the Auto-Provision NNIs feature.

f. To filter your view, click the All, Endpoints, or NNI tabs to view all ports, view only

UNIandENNIports, or viewonlyNNIports (both internal andendpoint) respectively.

g. To edit the list of ports, proceed as follows:

• To remove a port from the service, right-click the port or LAG entry and select

Remove Port, or select the port or LAG entry and click .
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• If you remove an auto-selected NNI port from the list, a Revert NNIs option

appears. This option allows you to add the NNI back to the list.

NOTE: Reverting only addsback the auto-provisionedNNIs to this
list. Any change you previously made to the NNI port, such as
changing the serviceprofiles, remain in effect andarenot reverted.

• If you remove a UNI or ENNI port, all internal NNI ports that have been

auto-selected due to that UNI or ENNI port are also removed.

• To addmembers to a LAG, right-click the LAG entry and select Add LAG

Member(s).

• To removeamember fromaLAG, right-click theLAGmemberandselectRemove

LAGMember.

• To addmore ports, repeat 2.

NOTE: By adding or removing internal NNIs, you have full control over
what NNIs (auto-selected or otherwise) are included in the service. In
some situations, it might be necessary for you tomanually delete
internal NNIs in this manner. For more information, see
“Auto-provisioning NNIs” on page 347.

NOTE: Any internalNNIs thatwill beaddedduetoGVRParenotshown,
as this is performed outside of PSM.

3. Set the port-based attributes (optional).

a. Click on the Details tab.

b. Set the port-based attributes by clicking in the appropriate box.
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Table 42: Port-based Attributes

DefaultRangeDescriptionAttribute

NoneUNI: 1 to 4094

ENNI: 2 to 4094

ForaUNIport, this specifies thecustomerVLAN ID(s) thatmap
to the service, and only applies to virtual services:

• For the Virtual Single service type, specify a single VLAN ID.

• For the Virtual Multiple service type, specify one or more
VLAN IDs as a comma-separated list (e.g. 2000, 2200) or
a range (e.g. 2000-2100) or both.

• For the Virtual Untagged service type, PSM populates this
field with the C-PVID that has been set for the port.

NOTE: If CVLAN Translation is enabled, only one customer
VLAN IDmapping can be specified.

For anENNI port, this specifies the external VLAN ID thatmaps
to the service. Only one VLAN ID can be specified. This field is
mandatory.

This field is not applicable to NNI ports.

VLANMappings

NoneNot applicableThis is the service or bandwidth policy to apply at the ingress.
Select the available policies using the drop-down list or click
on the ellipsis to seemore details. See “Managing Profile
Templates”onpage428 formore informationonhowtocreate
profiles.

NOTE: Service policies are not supported on the BTI805,
BTI821, and BTI822.

Ingress Service
Profile

NoneNot applicableThis is the service or bandwidth policy to apply at the egress.
Select the available policies using the drop-down list or click
on the ellipsis to seemore details. See “Managing Profile
Templates”onpage428 formore informationonhowtocreate
profiles.

NOTE: Service policies are not supported on the BTI805,
BTI821, and BTI822.

NOTE: This field is not supported on NNI ports on BTI800
Series network elements.

Egress Service
Profile

0x88a8Not applicableThis shows theouterTPIDusedat theNNIor ENNI for a stacked
Ethernet frame. This field cannot be changed.

This field is not applicable to UNI ports.

TPID
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Table 42: Port-based Attributes (continued)

DefaultRangeDescriptionAttribute

UNI: 1522

NNI, ENNI: 9600

UNI: 1522 to 9600

NNI, ENNI: 1526 to
9600

This is the maximum frame size (in bytes) for the port.

For UNI ports on BTI7000 Series NEs, this value is not used.
The "Max Frame Size" defined for the service is used instead.
However, the service "Max Frame Size" must still be less than
or equal to this value.

For UNI ports on BTI700 Series and BTI800 Series NEs, this
value is used instead of the service "Max Frame Size".

For NNI ports, this value is always used.

If the "Max Frame Size" is already set for this port on the NE,
and if the value is not within the valid range, PSMwill set the
"Max Frame Size" on the port to the default value.

Max Frame

AutoAuto

Full 10 Mb/s

Half 10 Mb/s

Full 100 Mb/s

Half 100 Mb/s

Full 1000Mb/s

Half 1000Mb/s

This specifies the Ethernet mode andmedia rate.Media Rate

EPTREE and EVPTREE services (BTI7000 Series only)

NormalNormal (root) or
Leaf

This indicates whether the UNI or ENNI port is a root node or a
leaf node. There can bemultiple root and leaf nodes. If all
nodes are root nodes, the resulting service is a LAN.

This field is not applicable for NNI ports.

Forwarding

4. Set the advanced switch and port attributes.

NOTE: Not all attributes are supported on every device.
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a. To configure advanced switch attributes, click the ellipsis in theAdvancedSettings

column for the switch entry.

Configure the switch attributes according to the following table.

Table 43: Advanced Switch Attributes

Description

Applicable
to:

Range of
ValuesAttributes BTI7000BTI800BTI700

Service Settings (switch)

Allows the customer VLAN ID to be remapped
for all ports on the switch with virtual services.

This attribute has the opposite meaning of the
MEF CE-VLAN ID Preservation attribute.

YesYesBTI712

BTI718

BTI718E

On or OffCVLAN
Translation

Applies to UNI ports. This attribute can only be
set after the service has been activated and
MEPs have been created.

YesNoNoProvisioned
profiles

SLA
Measurement
Profile

Sets the L2CP EVC profile.

Read/write for BTI805, BTI821, BTI822.

Read-only for BTI810.

NoYesNoProvisioned
profiles

Control Frame
Profile

When you are finished configuring the advanced switch settings, clickOK.

b. Toconfigureadvancedport attributes for a regular (non-LAG)port, click theellipsis

in the Advanced Settings column for the port entry.

Table 44: Advanced Port Attributes

Description

Applicable
to:

Range of
ValuesAttributes BTI7000BTI800BTI700

Service

Applies toopticalUNIports for EPLINEservices.

ForBTI800Seriesequipment, this attributecan
only be set after the service has been activated
and MEPs have been created.

YesYesNoOn or OffE-FPSD

Applies to UNI ports for EPLINE and EPLAN
services.

YesNoNoNone, Aware,
Blind

TPID Action
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Table 44: Advanced Port Attributes (continued)

Description

Applicable
to:

Range of
ValuesAttributes BTI7000BTI800BTI700

List of provisioned templates and service map
profiles. Applies to UNI ports with virtual
services.

YesNoBTI712

BTI718

Provisioned
templates and
service map
profiles

Service Map
Profile

The sequence number of the service map. A
servicemapwitha lower sequence is evaluated
first. Applies to UNI ports with virtual services.

YesNoBTI712

BTI718

1-100, default
50

Service Map
Sequence

Layer 1

The wavelength of the transceiver in nm, or a
copper SFP or port. This attribute can only be
changed if you are creating the port as part of
this service activation. If the port already exists,
and you are including it as part of this service
activation, you cannot change its value.

YesNoNoCopper SFP,
850nm to
1560.61nm

Wavelength

The circuit identifier of the port.YesNoNo1 to 32
alphanumeric
characters

Circuit ID

User-defined description for the circuit ID.YesYesNoStringDescription

Layer 2

The UNI service type:

• Private - service multiplexing is off, bundling
is on, all-to-one bundling is on

• Virtual Single - service multiplexing is on,
bundling is off, all-to-one bundling is off

• Virtual Multiple - service multiplexing is on,
bundling is on, all-to-one bundling is off

• Virtual Untagged - a special setting to
support the situation where the local UNI is
untagged and the remote UNI is tagged

NOTE: This is not the same attribute as the
Ethernet service type in “Service Types” on
page 346.

YesYesBTI718EPrivate

Virtual Single

Virtual
Multiple

Virtual
Untagged

Service Type

Specifies the customer's default VLAN ID. This
attribute is required on UNI ports running a
virtual untaggedservice, but isoptional forother
service types.

YesYesBTI718E1 to 4094,
default is
unselected

C-PVID
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Table 44: Advanced Port Attributes (continued)

Description

Applicable
to:

Range of
ValuesAttributes BTI7000BTI800BTI700

Sets the L2CP UNI profile. See the
documentation for the respective devices for
details. Applies to UNI ports.

Read/write for BTI805, BTI821, BTI822, and
BTI7000 equipment.

Read-only for BTI810.

YesYesNoProvisioned
profiles

Control Frame
Profile

Select to enable MSTP. Applies to UNI ports.YesNoNoOn or OffMSTPEnabled

Select to enable CCMs. Applies to UNI ports.YesNoNoOn or OffCCM Enabled

Specify the external SVLAN ID. This SVLAN ID
is mapped to the internal SVLAN ID from
Table 41 on page 351. Applies to NNI ports only.

NOTE: To specify the external VLANmapping
for ENNI ports, see Table 42 on page 357

This attribute can only be configured when you
first add the NNI to the service. You cannot
change theconfigurationafter theNNIhasbeen
added to the service. To change the
configurationafter theNNIhasbeenadded, you
must first remove the NNI and then add it back
to the service.

This mapping is 1:1. You cannot specify an
external SVLAN ID that is mapped to another
service on this same port.

If SVLAN Translation is enabled, untagged
frames will be discarded on ingress.

SVLAN translation cannot co-exist with GVRP
and MSTP. If SVLAN translation is enabled on
an NNI that has GVRP and/or MSTP also
enabled, PSMwill automatically disable GVRP
and/orMSTP.When the last SVLAN translation
is removed fromtheNNI,PSMwill automatically
enableGVRPand/orMSTP if eitherorbothwere
originally enabled.

YesNoNoOn or Off,
default is Off.

If On, specify
the external
SVLAN ID from
2 to 4094.

SVLAN
Translation

When you are finished configuring the advanced port settings, clickOK.

c. To configure port-based attributes for a LAGport, click the ellipsis in the Advanced

Settings column for the LAG port entry.
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Table 45: Advanced LAG Port Attributes

Description

Applicable
to:

Range of
ValuesAttributes BTI7000BTI800BTI700

Service

Same asTable 44 on page 359.

Layer 2

Same as Table 44 on page 359.

LAG

The LAG distribution method.YesYesYesSource MAC

Destination
MAC

Source and
Destination
MAC

Source IP

Destination IP

Source and
Destination IP

Source Port

Destination
Port

Distribution
Method

The LACPmode. This sets the LACPmode for
all members of the LAG. A setting of Active
(LACP)means that the port will initiate LACP
negotiation. A setting of Passivemeans that the
port will not initiate LACP negotation but will
respond to it. A setting of On (Static) means
that the port will neither initiate nor respond to
LACP negotiation.

YesNoBTI718EBTI7000:

Active,
Passive, On

BTI718E:

LACP, Static

LACPMode

Themaximum number of links permitted in the
LAG.

YesNoYes1-8Max Links

Theminimum number of links that must be up
before the LAG is considered up.

NoNoBTI718E1-8Min Links
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When you are finished configuring the advanced LAG port settings, clickOK.

d. To configure port-based attributes for a LAGmember, click the ellipsis in the

Advanced Settings column for the LAGmember entry.

Table 46: Advanced LAGMember Attributes

Description

Applicable
to:

Range of
ValuesAttributes BTI7000BTI800BTI700

Layer 1

Same as Table 44 on page 359.

LAGMember

The LACP port priority.YesNoYes0-65535LACP Port
Priority

The LACPwait time.YesNoNo0-10 secondsLACPWait
Time

The LACPmode. This sets the LACPmode for
individual members of the LAG.

YesNoNoActive,
Passive, On

LACPMode

The LACP timeout period.YesNoNoLong, ShortLACPTimeout

When you are finished configuring the advanced LAGmember settings, clickOK.

5. Click Activate. The service is activated.

For information about error messages, see “Service Activation Error Messages” on

page 549.

NOTE: Youmust wait for the activation tasks to complete before
performing any other operation on the NEs affected by this activation.
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Example: Activating an EVPLINE Service

This is anexampleof how tousePSMtoactivate twodifferent typesof EVPLINEservices.

The first service, between NEWYORK andMIAMI, requires CVLAN translation and no

bundling. The second service, between NEWYORK and DALLAS, requires connectivity

between a tagged and an untagged interface, also with no bundling. This is shown in

Figure 78 on page 364 along with the desired service policies.

Figure 78: Example: EVPLINE Services

NOTE: Before configuring the service, ensure that the PVX cards, virtual
switches, and the NNIs have all been created on the appropriate network
elements. For information on how to do this, refer to the BTI7000
SeriespacketVX Solutions Guide.

This example isdivided into twoparts, settingup theEVPLINEservicebetweenNEWYORK

andMIAMIwith CVLAN translation, and setting up the service between NEWYORK and

DALLASwith the virtual untagged option.
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Part 1: Setting Up the EVPLINE Service with CVLAN Translation

The service between NEWYORK (10.1.212.1:1-1-13-10) andMIAMI (10.10.20.99:1-1-5-10)

requires CVLAN translation and no bundling. CVLAN ID 201 is mapped to the service at

theNEWYORKUNI and CVLAN ID 101 ismapped to the service at theMIAMIUNI. TheUNI

ports are initially unprovisioned in this example.

1. On the PSM Client, click the Service Activation button on the toolbar, as shown.

Choose Ethernet from the pulldownmenu.

The Activate Service panel is displayed.

2. Enter the service attributes and click on the plus sign to start adding interfaces.

3. Add theNEWYORKUNI to theservicebyhighlighting the "Unprovisioned 1:1:13:GIGE:10"

port and selecting Provision As:UNI.

NOTE: The switches and ports only appear in thismenu if they have been
properly configuredon theNE.See theBTI7000SeriespacketVXSolutions
Guide for information on how to add and configure a switch.

When you are done, clickAdd UNI.
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4. Add theMIAMI UNI to the service by highlighting the "Unprovisioned 1:1:5:GIGE:10"

port and selecting Provision As:UNI.

When you are done, clickAdd UNI.

The result is the following topology.

NOTE: TheNNIsdonotneedtobeexplicitlyadded if thenetworkelements
are running GVRP.When working with network elements that do not
support GVRP such as the BTI700 Series or BTI800 Series devices, you
will need to add the appropriate NNIs to the service or use the
Auto-Provision NNIs feature.

5. Select the Details tab in the UNI/NNI Ports pane to enter more detailed information

for each UNI.
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6. Set theCVLANmappingsby clicking in theboxandentering thedesiredCVLANvalues

for each UNI. In this example, theMIAMI UNI maps CVLAN ID 101 to the service, and

the NEWYORK UNI maps CVLAN ID 201 to the service.

7. Click on the pulldownmenu or the ellipsis in the Ingress Service Profile column for the

MIAMI UNI.
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8. Select the desired ingress service profile by highlighting it and clickingOK. When a

profile is highlighted, the profile details are displayed in the Selected Profile pane. In

this example, the desired policy has already been defined.

9. Repeat for the NEWYORK UNI.

10. Open the Advanced Settings menu for theMIAMI UNI by clicking on the ellipsis.
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11. Select the service type from the pulldownmenu and clickOK.

In this example, the Service Type is Virtual Single, meaning that service multiplexing

is on, bundling is off and all-to-1 bundling is off. Leave the C-PVID unchecked.

12. Open the Advanced Settings menu for theMIAMI switch by clicking on the ellipsis.
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13. Select CVLAN Translation and clickOK. This attribute has the opposite meaning of

the Metro Ethernet Forum CE-VLAN ID Preservation attribute. In other words, CVLAN

Translation = yes is equivalent to CE-VLAN ID Preservation = no.

14. Repeat steps 10 through 13 for the NEWYORK UNI.

15. ClickActivate.

It is good practice to check whether the activate completes successfully. Open the

Tasks panel to check.

For information about error messages, see “Service Activation Error Messages” on

page 549

Part 2: Setting Up the EVPLINE Service with the Virtual Untagged Option

The service between NEWYORK (10.1.212.1:1-1-13-10) and DALLAS (10.1.213.1:1-1-5-10)

requires connectivity between a tagged and an untagged interface. CVLAN ID 202 is

mapped to the service at the NEWYORK UNI, while the DALLAS UNI is an untagged

interface. In this example, the NEWYORK UNI port has already been provisioned but the

DALLAS UNI port is unprovisioned.
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1. On the PSM Client, click the Service Activation button on the toolbar, as shown.

Choose Ethernet from the pulldownmenu.

The Activate Service window is displayed.

2. Enter the service attributes and click on the plus sign to start adding interfaces.

3. Add the NEWYORK UNI to the service by highlighting the "UNI 1:1:13:GIGE:10" port.

NOTE: The switches and ports only appear in thismenu if they have been
properly configuredon theNE.See theBTI7000SeriespacketVXSolutions
Guide for information on how to add and configure a switch.
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When you are done, clickAdd UNI.

4. Add the DALLAS UNI to the service by highlighting the "Unprovisioned 1:1:5:GIGE:10"

port and selecting Provision As:UNI.

When you are done, clickAdd UNI.

The result is the following topology.
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NOTE: TheNNIsdonotneedtobeexplicitlyadded if thenetworkelements
are running GVRP.When working with network elements that do not
support GVRP such as the BTI700 Series or BTI800 Series devices, you
will need to add the appropriate NNIs to the service or use the
Auto-Provision NNIs feature.

5. Select the Details tab in the UNI/NNI Ports pane to enter more detailed information

for each UNI.

6. Set theCVLANmappingsby clicking in theboxandentering thedesiredCVLANvalues

for each UNI. In this example, the NEWYORK UNI maps CVLAN ID 202 to the service

while the DALLAS UNI has nomapping.
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7. Click on the pulldownmenu or the ellipsis in the Ingress Service Profile column for the

DALLAS UNI. Select the desired bandwidth profile. In this example, the desired

bandwidth profile has already been defined.

8. Repeat for the NEWYORK UNI.
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9. Open the Advanced Settings menu for the DALLAS UNI by clicking on the ellipsis.

10. Select the service type from the pulldownmenu and clickOK.

The Service Type should be Virtual Untagged, with C-PVID set to the value used at

the remote endpoint, in this case, 202. Ingress traffic at the DALLAS site will be

automatically tagged with this value, while egress traffic will automatically have this

tag stripped.
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11. Open the Advanced Settings menu for the DALLAS switch by clicking on the ellipsis.

12. Ensure CVLAN Translation is unchecked and clickOK. This attribute has the opposite

meaning of the Metro Ethernet Forum CE-VLAN ID Preservation attribute. In this

example, the DALLAS site only expects untagged traffic, so this parameter is not

applicable.
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13. Modify the Advanced Settings attributes for the NEWYORK UNI. Ensure the Service

Type is set toVirtualSingle, C-PVID is unchecked, andCVLANTranslation is unchecked,

meaning that CE-VLAN ID preservation is on, service multiplexing is on, bundling is

off, and all-to-1 bundling is off.

14. ClickActivate.

It is good practice to check whether the activate completes successfully. Open the

Tasks panel to check.

For information about error messages, see “Service Activation Error Messages” on

page 549

Example: Activating an Ethernet Service on aMulti-chassis LAG

This is an example of how to activate an Ethernet service on amulti-chassis LAG UNI. A

multi-chassis LAG UNI has member links that terminate on two different network

elements. If one link or network element fails, the service continues to operate over the

other link. Serviceactivation for amulti-chassis LAGUNI is very similar to serviceactivation

on a regular UNI.

This example focuses on details that are specifc tomulti-chassis LAG service activation.
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1. Select Tools >Service Activation >Ethernet.

The Activate Ethernet Service panel is displayed.

NOTE: If multiple domains exist, you will need to select the domain first.

2. Enter the service attributes and click on the plus symbol to start adding UNI ports.

a. Select a multi-chassis LAG port and click Add UNI LAG.

You can select any member of the multi-chassis LAG as the UNI endpoint. When

you select a multi-chassis LAGmember, PSM automatically adds all members of

that samemulti-chassis LAG to the service.

You can distinguish between different multi-chassis LAGs by the MLAG index. For

example, to select MLAG 1, simply select a member belonging to MLAG 1.

b. Add the other UNI endpoint as you normally do.
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For example:

The result is the following topology.

3. Select the Details tab to enter more detailed information for each UNI.
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Only parameters for the active multi-chassis LAGmember can be configured. PSM

automatically copies the parameters from the active member to the non-active

members. You cannot change the parameters for the non-active members directly.

In the figure below, the active multi-chassis LAGmember is on SA-821-80, and the

standbymulti-chassis LAGmember is on SA-822-83.

4. Click Activate.

ThePSMserver sends theactivation request to thenetwork element. You canmonitor

the status of the request through the View >Server >Taskswindow. The changes are

shown in PSM a short while after the task completes successfully.

For informationabouterrormessages, see “ServiceActivationErrorMessages”onpage549
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Example: Activating EVPLAN and EVPLINE Services Using Service Maps for Flow Redirection
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This is an example of how to use PSM to activate two different types of services for three

endpoints. The first is a typicalmultipoint-to-multipoint EVPLAN service for regular data

connectivityand thesecond isasetof separateEVPLINEpoint-to-point services for voice

connections. This models a corporate network where regular intranet traffic between

sites use the EVPLAN service, while the lower latency, more stringent quality-of-service

site-to-site voice traffic uses a special EVPLINE service. The assumption is that the

network provider has set up low latency pathways for the EVPLINE traffic, perhaps with

little or no CIR oversubscription on any of the network segments that comprise the path.

NOTE: Although the interfacesareuntagged, theservicesare still considered
virtual sincemore than one service is provided at each UNI. Therefore the
services are EVPLINE and EVPLAN rather than EPLINE and EPLAN.

Figure79onpage382shows thedesirednetworkconfigurationalongwith thebandwidth

policies.

Figure 79: Example: EVPLINE and EVPLAN Services

NOTE: Before configuring the service, ensure that the PVX cards, virtual
switches, and the NNIs have all been created on the appropriate network
elements. For information on how to do this, refer to the BTI7000 Series
packetVX Solutions Guide.
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This example is divided into three parts: setting up the service maps, setting up the

EVPLINE services, and setting up the EVPLAN service. The service maps are used to

classify voice traffic for the EVPLINE services. Data traffic for the EVPLAN service do not

require classification. Instead, CVLAN IDmapping and C-PVIDs are used to map data

traffic to the EVPLAN service.

To keep this example short, some details covered in previous examples are omitted.

Part 1: Setting Up the Service Maps

Aservicemapmustbecreatedat eachsite to classify ingresspackets for the voice service.

In this example, voice traffic needs to be diverted to the EVPLINE service while all other

traffic remains on the EVPLAN service. This is performed using a combination of class

maps and service maps. A class map is a specific filter used to classify traffic, such as

matching a destination port number. A service map is a collection of class maps, or in

other words, a collection of filters. A match is declared in the service map if the ingress

packet matches any of the filters specified in the collection of class maps.

NOTE: The terminology used by PSM differs slightly from that used by the
CLI.Specifically, theCLI expands thenotionof servicepolicy to includeservice
maps, while PSM treats the servicemap as distinct from service policy. The
general configuration approach, however, remains the same.

In this example, all ingress SIP, RTP, and RTCP packets are considered to be voice traffic.

The approach is therefore to create class maps to identify each of these protocols, and

then group these classmaps together into a servicemap thatmaps these packets to the

EVPLINE service. The remaining traffic will be mapped to the EVPLAN service using

CVLANmapping.

1. Open the Profiles panel.

2. Create classmapprofiles to identifySIP,RTP, andRTCP traffic destined forNEWYORK.

NOTE: The port numbers used below are for illustration purposes only.
Actual port numbers might differ andmight likely include a range.
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a. Right-click and select Create Class Map Profile.

b. In the Selected Profile pane, enter the criteria for determining SIP traffic destined

for the NEWYORK site. This is UDP traffic heading to the 10.1.212.x subnet with a

destination port of 5060. Click Apply.

c. Repeat to create a class map for RTP traffic destined for the NEWYORK site. This

is UDP traffic heading to the 10.1.212.x subnetwith a destination port of 5004. Click

Apply.
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d. Repeat to create a classmap for RTCP traffic destined for theNEWYORK site. This

is UDP traffic heading to the 10.1.212.x subnetwith a destination port of 5005. Click

Apply.

This results in three class maps, classifying SIP, RTP, and RTCP traffic destined for

NEWYORK.

3. Repeat to create class maps for SIP, RTP, and RTCP traffic destined theMIAMI site.
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4. Repeat to create class maps for SIP, RTP, and RTCP traffic destined for the DALLAS

site.
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5. Group theclassmapsbycreatinga servicemapprofile to identify voice traffic destined

for the NEWYORK site.

a. Right-click and select Create Service Map Profile.
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b. In the Selected Profile pane, add the three TO_NEWYORK_xxx class maps created

in the previous step. Click Apply.

The result is a service map that identifies voice traffic destined for NEWYORK.

6. Repeat to create the service map for voice traffic destined for theMIAMI site.

7. Repeat to create the service map for voice traffic destined for the DALLAS site.
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The required service maps have now been created.

Part 2: Setting Up the EVPLINE Services

All three EVPLINE services are identical.

1. Create the NEWYORK toMIAMI EVPLINE service.

a. On the PSM Client, click the Service Activation button on the toolbar and choose

Ethernet.

b. If you have definedmultiple Ethernet domains, a dialog appears allowing you to

select the Ethernet domain in which you want to create this service. Use the

pulldownmenu to select the desired domain and clickOK.

c. Enter the service attributes and click on the plus sign to start adding interfaces.
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d. Add the NEWYORK UNI on "1:1:13:GIGE:10" and theMIAMI UNI on "1:1:5:GIGE:10".

NOTE: The switchesandports only appear in theAddUNImenu if they
have been properly configured on the NE. See the BTI7000 Series
packetVX Solutions Guide for information on how to add and configure
a switch.

NOTE: The NNIs do not need to be explicitly added if the network
elementsare runningGVRP.Whenworkingwithnetworkelements that
do not support GVRP such as the BTI700 Series or BTI800 Series
devices, youwill need to add the appropriateNNIs to the service or use
the Auto-Provision NNIs feature.

e. Click the Details tab in the UNI/NNI Ports pane to enter more detailed information

for each UNI.

There is noneed tospecify anyCVLANmappings since the interfacesareuntagged.

f. Select the ingress service profile for both sites by clicking on the pulldownmenu

or the ellipsis.
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g. Open the Advanced Settings menu for theMIAMI UNI by clicking on the ellipsis.

h. Select the service map from the pulldownmenu and clickOK.
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The Service Type is not applicable. Ensure the C-PVID is unchecked. The Service

Map sequence is also not applicable.

i. Open the Advanced Settingsmenu for theMIAMI switch by clicking on the ellipsis.

j. Ensure CVLAN Translation is unchecked and clickOK.

k. Repeat substeps f through i for theNEWYORKUNI but select the TO_MIAMI_VOICE

service map.

393Copyright © 2019, Juniper Networks, Inc.

Chapter 12: Managing Ethernet Services



l. ClickActivate.

It is good practice to checkwhether the activate completes successfully. Open the

Tasks panel to check that the task has finished.

For information about error messages, see “Service Activation Error Messages” on

page 549

2. Repeat for theNEWYORK toDALLAS EVPLINE service, with the following differences:

• Service Name - NEWYORK_DALLAS_1051

• SVLAN - 1051

• UNI ports - NEWYORK UNI on "1:1:13:GIGE:10" and DALLAS UNI on "1:1:5:GIGE:10"

• Service Map - TO_DALLAS_VOICE service map at the NEWYORK UNI and

TO_NEWYORK_VOICE service map at the DALLAS UNI.

3. Repeat for the DALLAS toMIAMI EVPLINE service, with the following differences:

• Service Name - DALLAS_MIAMI_1053

• SVLAN - 1053

• UNI ports - DALLAS UNI on "1:1:5:GIGE:10" andMIAMI UNI on "1:1:5:GIGE:10"

• ServiceMap-TO_DALLAS_VOICEservicemapat theMIAMIUNIandTO_MIAMI_VOICE

service map at the DALLAS UNI.
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Setting Up the EVPLAN Service

1. On the PSM Client, click the Service Activation button on the toolbar and choose

Ethernet.

2. If youhavedefinedmultiple Ethernet domains, a dialogappears allowing you to select

the Ethernet domain inwhich youwant to create this service. Use the pulldownmenu

to select the desired domain and clickOK.

3. Enter the service attributes and click on the plus sign to start adding interfaces.

4. Add the NEWYORK UNI on "1:1:13:GIGE:10", theMIAMI UNI on "1:1:5:GIGE:10", and the

DALLAS UNI on "1:1:5:GIGE:10".

NOTE: The switches and ports only appear in the Add UNI menu if they
havebeenproperlyconfiguredontheNE.See theBTI7000SeriespacketVX
Solutions Guide for information on how to add and configure a switch.

NOTE: TheNNIsdonotneedtobeexplicitlyadded if thenetworkelements
are running GVRP.When working with network elements that do not
support GVRP such as the BTI700 Series or BTI800 Series devices, you
will need to add the appropriate NNIs to the service or use the
Auto-Provision NNIs feature.

5. Click the Details tab in the UNI/NNI Ports pane to entermore detailed information for

each UNI.
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6. Configure the Advanced settings for each UNI.

a. Open the Advanced Settings menu for the each UNI by clicking on the ellipsis.

b. Set the C-PVID to an arbitrary value and clickOK. For simplicity, set the C-PVID to

the same value for all three UNIs.
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By setting the C-PVID value, all untagged traffic arriving at the UNI will be treated

as if it contained a CVLAN ID equal to the C-PVID value. This value can then be

used in the CVLANmapping table. The Service Type is not applicable. The Service

Map sequence is also not applicable.

7. Configure the Advanced Settings attributes for each switch.

a. Open the Advanced Settings menu for each switch by clicking on the ellipsis.

b. Ensure CVLAN Translation is unchecked and clickOK.

397Copyright © 2019, Juniper Networks, Inc.

Chapter 12: Managing Ethernet Services



8. Set the CVLANmapping for each UNI, using the C-PVID value configured earlier.

9. Select the ingress service profile by clicking on the pulldownmenu or the ellipsis.
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10. ClickActivate.

It is good practice to check whether the activate completes successfully. Open the

Tasks panel to check that the task has finished.

For information about error messages, see “Service Activation Error Messages” on

page 549

Modifying a Service

PSM allows users to modify existing Ethernet Services in the network by editing, adding

and removing ports.

• Modifying a Port in a Service on page 399

• Adding a Port to a Service on page 400

• Removing a Port from a Service on page 401

Modifying a Port in a Service

CAUTION: Modifying a port in a servicemight affect the service or the data
traffic running on the service.
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1. Double-click a service in the Network tree.

The Ethernet Service Activationwindow for that service appears.

2. Select the Details tab to display the port settings.

3. Click the port you want tomodify, and then click the ellipsis in the Advanced settings

column. The text in the editable fields is black; fields that cannot be changed are grey.

NOTE: For multi-chassis LAGs, you can only modify the active LAG
member. PSM automatically copies themodifications to the non-active
LAGmembers.

4. To implement the port modifications, click Apply. The port is changed.

Adding a Port to a Service

1. Double-click a service in the Network tree.

The Ethernet Service Activationwindow for that service appears.

2. In the Service tab of the UNI/NNI/ENNI Ports panel, click the icon.

3. Select the network element where the port is to be added, then select a switch from

the Switch Members list. This populates the ports panel with a list of ports that can

be added to the selected service, as shown below.
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4. Select the port or group of ports to be added to the service.

5. Click Add UNI or Add UNI LAG, Add NNI or Add NNI LAG, or Add ENNI or Add ENNI LAG

depending on the type of port chosen.

6. Click Apply. The port or group of ports is added as shown below.

Removing a Port from a Service

CAUTION: Removing a port from a servicemight affect the service or the
data traffic running on the service.

1. Double-click a service in the Network tree.

The Ethernet Service Activationwindow for that service appears.

2. In the UNI/NNI/ENNI Ports section, remove a port using one of the following options:

a. In the Details tab, select the port from the list and click the subtract button to

remove the port, or right-click the port and click Remove Port(s).
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b. In the Service tab, select the port icon and click the subtract button to remove the

port.

NOTE: When you remove onemember of amulti-chassis LAG from a
service, PSM automatically removes all other members of that
multi-chassis LAG from the service.

3. To implement the port removal, click Apply. The port is removed.

Deleting a Service

1. To delete a service, right-click on the service in the tree view and choose Delete.

An information window opens asking for confirmation.

2. ClickOK.

The service is deleted from the network elements and the proNX Service Manager

server.

The NE data stored in the proNX Service Manager server is automatically updated

after the deletion completes when it re-discovers the affected nodes.

Adding SLA/CFM to a Service

Use this procedure to add SLA/CFM to UNI ports in an Ethernet service.

CFM provisioning

In an Ethernet network consisting only of BTI7000Series network elements, Y.1731 setup

is performed automatically by the NEs. You do not need to use PSM to configure CFM.

In amixedEthernet network consisting of BTI7000Series, BTI700Series, and/or BTI800

Series network elements, or in an Ethernet network consisting of non-Juniper Networks

network elements, Y.1731 setup is partially performed by the NEs. You can use PSM to

complete the CFM provisioning.

In all cases, you cannot use PSM to change the settings for the Local MEG and MEP, but

you can use PSM tomanually add and/or remove remoteMEPs. Manually adding and/or

removing remoteMEPs is requiredwhen interworkingwithnon-JuniperNetworksnetwork
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elements. Where applicable, PSM automatically sets the MEG name, MEG level, and

MEP IDs for each MEP provisioned on a UNI.

There is a single MEP per switch in the BTI7000 Series and BTI700 Series equipment,

and a single MEP per port in the BTI800 Series equipment. The single MEP per switch

limits you to having only one UNI on the switch belonging to an SLA pair. See

Table 47 on page 403.

NOTE: There isa limit to thenumberofMEPsandMIPssupportedonaBTI810
network element. See the BTI800 Series Technical Product Guide for details.
A single MIP counts as 2 towards that limit.

WhenaUNI is removed froma service, the correspondingMEP is automatically removed.

When an NNI is removed from a service, the corresponding MIP is removed. When a

service is deleted, the MEG is automatically removed.

SLA provisioning

SLAprovisioning isperformedbyspecifyingSLA Initiator/Responderpairs in theSLA/CFM

tab in theEthernetServiceActivation screen.Table47onpage403shows theconstraints

when configuring SLAs on different endpoints.

Table 47: SLA Provisioning Constraints

NotesNE Type

A UNI port can be configured as either an initiator or a
responder.

A UNI port can be the initiator for up to 4 responder ports.

Only oneUNI port per switch canbe configured on anSLApair.

A UNI port that is an initiator cannot be a responder for the
same remoteport, but it canbea responder for another remote
port.

BTI7000 Series

A UNI port can only be configured as a responder, not an
initiator.

Only oneUNI port per switch canbe configured on anSLApair.

BTI700 Series excluding the BTI718E

A UNI port can be configured as either an initiator or a
responder.

A UNI port can be the initiator for multiple responders.

Only oneUNI port per switch canbe configured on anSLApair.

A UNI port that is an initiator cannot be a responder for the
same remoteport, but it canbea responder for another remote
port.

BTI718E
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Table 47: SLA Provisioning Constraints (continued)

NotesNE Type

A UNI port can be configured as either an initiator or a
responder.

A UNI port can be the initiator for only one responder port.

Multiple UNI ports per switch can be configured for SLA pairs.

A UNI port that is an initiator can only be a responder for the
sameremoteport. It cannotbea responder foranother remote
port.

For the BTI805, BTI821, and BTI822, when you add one SLA
pair, a second SLA pair is automatically added in the opposite
direction between the same two endpoints.

NOTE: If you plan to use the link trace and loopback
capabilities on a BTI810, you should enable automatic MIP
creation. For information on how to do this, see the proNX
Service Manager Installation and Administration Guide. By
default, automatic MIP creation is disabled for the BTI810.

BTI800 Series

PSM reports an error in the SLA/CFM dialog for the following reasons:

• Only one end of the SLA pair has been provisioned (one initiator or one responder).

• MismatchedMEPs (aMEP ID that does not exist has been pairedwith aMEP ID on the

service).

NOTE: The SLAMeasurement Profile is provisionable in the Advanced
Settings of each Switch in the Details tab of the activation view. You can
select either an existing profile or a template, and you are able to view the
profile’s contents.

Copyright © 2019, Juniper Networks, Inc.404

proNX Service Manager User Guide



1. OpentheServiceAttributeswindowforanEthernet service, and thenclick theSLA/CFM

tab.

PSM automatically populates the CFM Details table with the MEPs on the BTI7000

Series NEs.

2. Optionally, set theMEGName.

The MEGName can be up to 6 characters long. By default, it is the SVLAN ID prefixed

by one or more "v"s (padded up to 6 characters).

3. Click Auto-Configure CFM to add MEPs on BTI700 Series and BTI800 Series devices.

PSM responds with a dialog box detailing the MEPs that it has added. ClickOK to

close the dialog box.

Clicking Auto-Configure CFM configures CFM for BTI700 Series and BTI800 Series

devices. Once clicked, the system goes through the service and automatically adds

MEPs, Remote MEPs, and MIPs to the service. If the Activate or Apply button is then

clicked, the MEPs/MIPs are provisioned on the devices.

If the service includes BTI7000 Series UNIs, then this step also adds Remote MEPs

to and from the BTI7000 Series UNIs so that CFM is properly configured on all

equipment. If a service ismodified, then clicking the Auto-Configure CFM button adds

the proper CFM to whatever has beenmodified.

When the configuration is complete, a list of the entities added is displayed in the

CFM Details table.

4. Tomanually add Remote MEPs to the CFM Details table, click Add RemoteMEP and

specify the remoteMEP ID.
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Use the pop-up dialog box to configure the remote MEP. MEPs on BTI700 Series and

BTI800Seriesdevices require that theMACaddressof thedevicebeenteredmanually.

Once you are finished configuring the remote MEP, clickOK.

The Remote MEP is added to the CFM Details table. Repeat this step to add further

MEPs.

5. To change the CCM interval, select the new interval in the Crosscheck dropdown

menu.

6. To add SLA pairs to the service, click Add SLA Pair and specify the initiator and

responder.

Use the pop-up dialog box to configure the SLA pair.

Once you are finished configuring the SLA pair, clickOK. The SLA pair is added to the

SLA Details table. Repeat this step to add further SLA pairs.
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7. To change the SVLAN priority of the SLA pair, select the new priority from the SVLAN

Priority dropdownmenu.

8. To enable or disable the SLA pair, select the new state from the State dropdown

menu.

9. When you are done adding SLAs/CFMs to the service, click Activate to activate a new

service or Apply to apply changes to an existing service.

NOTE: WhenyouperformaCFMupdateonapre-1.5 releaseBTI700Series
device, youmust manually rediscover the device in order for the update
to be reflected in PSM.
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This procedure is complete.

Running a Y.1731 Link Trace

Use this procedure to run a Y.1731 link trace from one UNI to another UNI.

Prerequisites:

• MEPs and MIPs have been configured for the service.

A Y.1731 link trace request at the local MEP causes a Link Trace Message (LTM) to be

sent to the remote MEP. All MIPs between the local and remote MEPs respond to the

LTMwith a Link Trace Reply (LTR). PSM uses information from the LTRs to display the

path between the two endpoints.

1. In the Network tree view, click on the Ethernet service where you want to run the link

trace.

The Ethernet service appears in the Topologywindow.

2. Right-click the UNI port that you want to be the initiator, select CFMTests >Linktrace

to , and pick the responder port from the drop down list. If you want the responder

port to be shown with its IP address in this list, see “Setting Device Display Options”

on page 274.

The initiator UNI port must be on a BTI7000 Series, a BTI800 Series, or a BTI718E

device. The responder UNI port can be a port on any compliant device.

After the link trace is finished, the path between the two UNIs is highlighted.

NOTE: The link tracemight take some time to complete. You can watch
its progress in the View >Server >Taskswindow.
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3. Toclear thehighlightingof thepath, right-click thebackground in theTopologywindow

and select Clear Highlighting.

Running a Y.1731 Loopback

Use this procedure to run a Y.1731 loopback from one UNI to another UNI.

Prerequisites:

• MEPs and MIPs have been configured for the service.

A Y.1731 loopback request at the local MEP causes a Loopback Message (LBM) to be

sent to the remote MEP. The remote MEP responds to the LBMwith a Loopback Reply

(LBR). Unlike link trace messages, only the target MEP responds to the LBM.

1. In the Network tree view, click on the Ethernet service where you want to perform the

loopback.

The Ethernet service appears in the Topologywindow.

2. Right-click the UNI port that you want to be the initiator, select CFMTests >Loopback

to, and pick the responder port and then the number of LBMs to send. If youwant the

responder port to be shownwith its IP address in this list, see “Setting Device Display

Options” on page 274.

The initiator UNI port must be on a BTI7000 Series, a BTI800 Series, or a BTI718E

device. The responder UNI port can be a port on any compliant device.

Whena loopback is initiatedonaBTI7000SeriesoraBTI800Seriesnetworkelement,

a window appears showing the ongoing results of the loopback. When a loopback is

initiated on a BTI718E device, the window only appears after the loopback test has

completed. In all cases, the window stays open for a period of time after the test has

finished.

The window shows the number of LBMs transmitted by the initiator and the number

of LBRs received from the responder. For the BTI7000 Series network elements, the

counts are reset to 0 each time a loopback test is run. For the BTI800 Series and

BTI718E devices, the counts are not reset, and represent the loopback counts from

the time the service was started.
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Running an RFC 2544 Benchmarking Test

Use this procedure to run an RFC 2544 benchmarking test on the BTI805, BTI821, or

BTI822 devices.

The tests specified in RFC 2544 are useful to determine whether an Ethernet service

complieswithservice levelagreements.These testsapply toEPLINEandEVPLINEservices

only.

1. Right-click a service in the Network tree and select RFC 2544 >Run Tests.

The Rfc 2544 dialog appears.

2. Select the test parameters as follows:

• Throughput—This is always selected. The other tests require the throughput test

to be enabled. The throughput test measures the maximum rate that can be

processed within the specified Acceptable Loss constraint.

• Frame Loss Ratio—Select to run the frame loss ratio test. This test measures the

frame loss ratios for different ingress traffic rates.

• Latency—Select to run the Latency test.

• Endpoint—Select the endpoint of the circuit where the test is to be initiated.

• Frame Size 1 through Frame Size 6—Select the six different frame sizes to use for

the test(s).
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• Cos Type—Select the class of service type from the pulldownmenu. Select EPU

(EVC per UNI) if you want to use the EVC class of service. SelectMANUAL if you

want to manually specify the class of service.

• Cos Level—Select the class of service level if the Cos Type is set toMANUAL.

3. Select the Details tab to configure the detailed test settings.

4. Select the throughput test parameters as follows:

• Oper-Way—Select DUAL_ENDED to generate test traffic from both ends, or

LOOPBACK to loop back the test traffic at the remote end.

• Max.TrialTimes—Specify themaximumnumberof trials to run.Theminimumvalue

for this parameter is 5.

• Acceptable Loss—Specify the percentage of frames that can be lost (and the

outcome still considered to be acceptable). If this is set to 0, the throughput test

measures the maximum rate that can be processed with no loss of frames.

• Max. Rate—Specify the starting traffic rate (Mbps) for the test.

• Duration—Specify the duration of the test in seconds.

• S. Trial—Specify the number of successive trials that must be successful before

the test at the current frame size is stopped. A trial is successful if the number of

lost frames is within the Acceptable Loss constraint.

5. Select the frame loss ratio test parameters as follows:
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• Oper-Way—Select DUAL_ENDED to generate test traffic from both ends, or

SINGLE_ENDED to generate test traffic from one end, or LOOPBACK to loop back

the test traffic at the remote end.

• Granularity—Specify the percentage of the maximum frame rate to step down for

each successive trial. Themaximum frame rate is the frame rate that achieves

100% link utilization for the frame size being used. The rate is stepped down from

themaximum frame rate successively if frame loss occurs.

• Duration—Specify the duration of the test in seconds.

• S. Trial—Specify the number of successive trials that have no lost frames before

the test at the current frame size is stopped.

6. Select the latency test parameters as follows:

• Oper-Way—Select DUAL_ENDED to generate test traffic from both ends, or

LOOPBACK to loop back the test traffic at the remote end.

• Duration—Specify the duration of the test in seconds.

7. Select Background Traffic to enable background traffic in the latency tests.

8. Click Run.

You canmonitor the status of the test through the View >Server >Taskswindow.

9. View the test results when the test is finished.
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a. Right click the service in the Network tree and select RFC 2544 >ShowResults.

This command retrieves the most recent, completed RFC 2544 tests from the NE

and lists them in the Rfc Test Result List.

NOTE: Once PSM retrieves the test results, it stores them in its local
databaseandmakes themavailable for display (even if the test results
are subsequently deleted from the NE).

b. Select the test you want to view and clickOpen.

A new tab opens showing the test that you have selected.

c. Click the chevron in the upper right corner to view the test results.

The test results are organized as shown in the following figure:
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d. To see the results of a specific test, click the associated chevron.

For example, these are the results of the throughput test:

10. To export the test data to an Excel file, click Export and save the file.

Ethernet Ring Protection Switching (ERPS)

ERPS is a ring protection scheme for Ethernet networks, and is supported on BTI7000

Series, BTI800 Series, and BTI700 Series equipment.

The network operator creates the ERPS service directly on the network element using

either the proNX 900 or the CLI, and can use PSM to view the service graphically. PSM

automatically discovers anddisplays ERPSservices in the network but does not currently

support creating ERPS services.

• Visualizing an ERPS Service on page 414

• Viewing the ERPS Services Table on page 418

• Adding VLANs to an ERPS Ring on page 419

Visualizing an ERPS Service

Use this procedure to view the ERPS service and its states.

Copyright © 2019, Juniper Networks, Inc.414

proNX Service Manager User Guide



Under normal (non-failure) conditions, the ERPS service blocks the RPL link to prevent

looping of traffic for the Ethernet services it is protecting. On link failure, the ERPS service

enables theblockedport to allow traffic from thoseEthernet services to continue to flow.

1. In the Network tree view, select the desired ERPS service.

The ERPS service view opens in the main map window. If PSM is configured to show

the ERPS link icons (“Setting Service Display Options” on page 275), a green is

displayed to indicate the RPL link being blocked.

2. Right click the service view and select ShowConnected Ports.

The ERPS service view is expanded to show the ports.

3. Hover over the network elements to see information on the ERPS service.
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For thepurposesof illustration, themouse-over information for twonetworkelements

is shown simultaneously.

4. Hover over the NNI ports to see ERPS information for the NNI ports.

For the purposes of illustration, the mouse-over information for two NNI ports are

shown simultaneously.
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NOTE: The same ERPS state information can be viewed from the Details

tab in the UNI/NNI Ports pane of the Ethernet Service Activationwindow.
Simply double-click on an existing ERPS service in the Network tree view
and select the Details tab.

Effect Of Link Failure on ERPS States

If a link goes down, the RPL port becomes unblocked and the ERPS states change to

show that it is in protecting mode. If PSM is configured to show the ERPS link icons

(“SettingServiceDisplayOptions”onpage275), a red isdisplayed to indicate the failed

link, and a green is displayed on the RPL link to show that it is passing traffic.

For the purposes of illustration, the mouse-over information for various elements and

ports are shown simultaneously.
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Viewing the ERPS Services Table

Use this procedure to view the ERPS services table.

TheERPSservices tabledisplays informationonall ERPSservices running in thenetwork.
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1. Select View >Ethernet >ERPS.

The ERPS services table opens in the main Map window. The table shows the ERPS

services in the network along with their port states and other information.

Adding VLANs to an ERPS Ring

Use this procedure to add VLANs to a node in an ERPS ring.

PSM can be used to add VLAN IDs to a node in an ERPS ring. The typical use case for this

procedure is to help with ERPS node insertion. Node insertion refers to breaking the NNI

between twoadjacent nodes in a ring, and reattaching the sameNNI ports to anewnode.

When a node is inserted into an ERPS ring, the list of VLANsmust be configured on the

new node, as follows:

• Associate the list of VLANs to the ERPS ring NNIs on the new node. This is not needed

if GVRP is enabled on the ring.

• Add the list of VLANs to the ERPS protected VLAN list on the new node.

• Create the Ethernet services represented by these VLANs on the new node.

This procedure performs the above 3 tasks and runs an audit of the ERPS ring. The audit

checks to make sure the existing configuration is consistent across all the nodes, and

highlights any inconsistencies that it finds. Although the audit results are purely

informational, anddonotblock theuser fromproceeding, you shouldexamine the results

for potential issues.

Additionally, PSMcreatesMIPs on the ERPS ringNNIs on the newnode ifMIPs have been

configured on the ERPS ring NNIs on the existing nodes.

The following are the constraints for this procedure:

• This procedure should only be used on non-interconnect nodes. A non-interconnect

node is a node that is not simultaneously part of a main ring and a sub-ring.

• This procedure should only be used when there is a single ERPS ring on the physical

topology. Running this procedure in a configuration where there are multiple ERPS

rings on the same physical ring is not supported.
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• This procedure should only be run when a single node is inserted. When inserting

multiple nodes in a ring, you should insert and repair one node at a time.

NOTE: This procedure supplements the ERPS node insertion procedures on
the network elements. Refer to the ERPS node insertion procedures in the
respectivedocumentation for thedifferentnetworkelements formoredetails.

1. Select the desired ERPS service in the tree view.

2. In the Ethernet services topology window, identify the node that you want to add the

VLANs to.

This is typically the newly inserted node.

3. Right click that node and select Repair VLANs.

PSM audits the ERPS service, treats the existing nodes as the baseline, and prepares

to configure the selected node to be consistent with the baseline. The audit results

and the list of VLANs to be added are presented. For example:

Here is an example of an audit that has uncovered underlying issues:
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TIP: You can use this procedure purely to audit the ERPS ring.

4. Add the VLANs to the selected node.

If the audit shows that the ERPS ring is healthy, selectOK to add the VLANs to Repair

list to the selected node.

If the audit shows issues with the existing ERPS ring configuration, select Cancel, fix

the issues, and repeat 3.

NOTE: You are advised, but not required, to fix the audit issues before
selectingOK to add the VLANs.

Once you clickOK, PSM associates the list of VLANs to the ERPS ring NNIs on the

selected node, adds the list of VLANs to the protected VLAN list for the ERPS service

on the selected node, creates the Ethernet services represented by these VLANs, and

finally, creates the MIPs as necessary.

Routing Considerations in Mixed Networks

Depending on the topology of the network, there are certain considerations to take into

account when activating services. This section highlights the main concerns and steps

required to successfully activate services within different network configurations.

• GVRP - GARP VLAN Registration Protocol on page 421

• Mixed Networks - BTI7000 Series with BTI700 Series or BTI800 Series

Elements on page 422

GVRP - GARP VLANRegistration Protocol

The Generic Attributes Registration Protocol (GARP) is defined in 802.1D as ameans for

bridges to distribute information amongst themselves about membership in various

groups. 802.1D defines GMRP (GARPMulticast Registration Protocol) to distribute

multicast groupmembership. 802.1Q defines GVRP (GARP VLAN Registration Protocol)

to distribute information about VLANmembership.

GVRP addresses the problem of determining which inter-bridge links (NNIs) must be

members of which VLANs. In a VLAN-bridge, packets in VLAN x can only be transmitted

on links that are members of VLAN x. VLAN x subscriber interfaces (UNIs) are manually

configured, but it can be cumbersome to define a VLANmember for all VLANs across all

NNIs. One fall-backwould be to simply define all VLANs on NNIs, but thismeans that all

flooded packets will be flooded everywhere, which is a large waste of bandwidth.

GVRP, in effect, advertises VLANmembership backwards through the network. If a node

must receive packets in VLAN x, it sends a registration for VLAN x to all of its neighbors.

Eachof thoseneighbors adds the receiving link toVLANxand then forwardsa registration

to all of its neighbors.
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Using GVRP lets you dynamically route VLAN traffic through the network and create

services without specifying the NNI ports needed for the service.

Mixed Networks - BTI7000 Series with BTI700 Series or BTI800 Series Elements

When a network includes BTI7000Series packetVX and BTI700Series or BTI800Series

devices, the topology of the network dictates the NNIs that must be explicitly added to

successfully activate a service, regardless of the type of Ethernet service selected. The

rule of thumb is that all NNIs on BTI700 Series devices must be added, and all NNIs on

BTI7000 Series switches that are facing BTI700 Series devices must be added in order

for traffic to flow. Some examples follow.

NOTE: This section only applies if the Auto-Provision NNIs feature is not

selected.

Creating Services in BTI7000 Series packetVXOnly Networks

Figure 80: Creating Services in BTI7000 Series packetVXOnly Networks

In this case, all network elements areBTI7000Series packetVXnodes.Only the endpoint

UNIs need to be added to the service, as the NNIs will all be GVRP-enabled and the

dynamic VLAN creation will automatically route the traffic.

Example PortExample IPEquipment

UNI 1: GIGE 12 on Switch 2172.27.7.106NE 1

UNI 1: GIGE 4 on Switch 1172.27.7.110NE 4
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Figure 81: Creating Services in BTI7000 Series packetVX-only Networks

Creating Services Over BTI700 Series And/or BTI800 Series Only Networks

Figure 82: Creating Services Over BTI700 Series And/or BTI800 Series Only Networks

In this case, all network elements are either BTI700 Series or BTI800 Series devices. If

theAuto-ProvisionNNIs feature is disabled, youmust explicitly add theNNIs that are part

of the service. To avoid single points of failure, it is the user's responsibility to add all NNIs

that can form possible paths.

Example PortsExample IPEquipment

UNI 1: GIGE 3 on Switch 1

NNI 1: GIGE 15 on Switch 1

NNI 2: GIGE 16 on Switch 1

172.27.7.101NE 1
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Example PortsExample IPEquipment

NNI 1: GIGE 15 on Switch 1

NNI 2: GIGE 16 on Switch 1

172.27.7.104NE 2

NNI 1: GIGE 15 on Switch 1

NNI 2: GIGE 16 on Switch 1

10.1.100.55NE 3

UNI 1: GIGE 3 on Switch 1

NNI 1: GIGE 15 on Switch 1

NNI 2: GIGE 16 on Switch 1

10.1.100.56NE 4

Figure 83: Creating Services Over BTI700 Series And/or BTI800 Series Only Networks

ActivatingServicesOverCombinationsOfBTI7000Series packetVXandBTI700
Series or BTI800 Series Networks

This is a combination of the two previous cases. If the Auto-Provision NNIs feature is

disabled, youmust add all theNNIs that do not face theGVRP ring (see the table below).
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Figure84:ActivatingServicesOver aCombinationOfBTI7000Series packetVX,BTI700
Series, and BTI800 Series Networks

In this example, NE 1 andNE 2 are BTI700Series devices, NE 3 throughNE6 are BTI7000

Series packetVX devices, and NE 7 and NE 8 are BTI800 Series devices.

Example PortsExample IPEquipment

NNI 1: GIGE 15 on Switch 1

NNI 2: GIGE 16 on Switch 1

172.27.7.101NE 1

UNI 1: GIGE 3 on Switch 1

NNI 1: GIGE 15 on Switch 1

NNI 2: GIGE 16 on Switch 1

172.27.7.104NE 2

NNI 3: GIGE 16 on Switch 1172.27.7.105NE 3

NNI 3: GIGE 16 on Switch 1172.27.7.106NE 4

NNI 3: GIGE 16 on Switch 110.1.100.54NE 5

NNI 3: GIGE 16 on Switch 110.1.100.52NE 6

NNI 1: GIGE 15 on Switch 1

NNI 2: GIGE 16 on Switch 1

10.1.100.55NE 7

UNI 1: GIGE 3 on Switch 1

NNI 1: GIGE 15 on Switch 1

NNI 2: GIGE 16 on Switch 1

10.1.100.56NE 8
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Managing Profiles

• About Profile Manager on page 426

• Managing Profile Templates on page 428

• Bandwidth Profile Templates on page 431

• Class Map Profile Templates on page 434

• Service Policy Profile Templates on page 436

• Service Map Profile Templates on page 438

• SLAMeasurement Profile Templates on page 439

About Profile Manager

PSM allows users to create or clone profiles that can be used to configure Ethernet

services.

The Profile Manager provides an easy way for you to create new profiles, as well as to

manage the various profiles already associated with devices in the network. PSM

automatically discovers existing profiles in the network, andmakes them visible in the

Profile Manager, organized by network element.

A profile can exist in the following forms:

• as a profile stored in PSM

• as a profile stored on the network element

Aprofile that is stored inPSM is calledaprofile template. Youcanuse theProfileManager

to create profile templates:

• by specifying all parameters explicitly

• by cloning from another profile template

• by cloning from a profile associated with an actual device in the network

Profile templates are stored in PSM and are applied to the specified network elements

during a service activation operation. Applying a profile template to a network element

causes that profile to be created and stored on the network element using the same

name as the template. After service activation, the profile exists both as a template in

PSM and as an actual profile on the network element.

You can create, edit, or delete profile templates on PSM. You cannot use PSM to edit or

delete profiles discovered on the network elements.

NOTE: There is no synchronization between the profile templates defined in
PSM and the network. Changes to the templates are not reflected in the
network, and changes in the network are not automatically copied back to
the respective profile template. Changes in the network, however, are
reflected in the discovered profiles for the respective network elements.
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NOTE: Profile templates are part of the replicated data set when running
withmultiple servers. Formore information on replicated data, see “Running
Multiple Servers with Server Replication” on page 30.

TheProfileManager screen is accessible via theEditmenu itemProfiles, or via the toolbar

button shown below.

The Profile Manager screen is shown below.

Selecting a Profile During Service Activation

When you activate an Ethernet service, you have the ability to specify which profile to

use on a port. The possible profiles include the list of profile templates in PSM, and the

list of profiles discovered on the network element to which the port belongs. If you want

to use a profile found on another network element, youmust first clone that profile into

PSM so that it appears in the list of profile templates.

Note that it is normal for a profile template in PSM and a profile on a device to have the

same name. The reason is that when you activate a service and you specify a profile

template, PSM creates a profile on the device with the same name as the template.

During service activation, when confronted with a choice between a profile template on

PSMand the equivalent profile on the device, you should always select the profile on the

device. If you select the profile template instead, you are in effect requesting PSM to

create a new profile on the device with the same name as the profile template, which

will result in an error because that profile already exists.

For example, in the followingprofile selectiondialog (during serviceactivation), theprofile

GOLD appears as both a profile template and a profile:
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In such situations, you should always select the GOLD profile on the device (i.e. where

the Source is DEVICE) rather than the GOLD profile template (i.e. where the Source is

TEMPLATE). In fact, PSMwill not allow you to select the GOLD profile template because

doing someans that you are requesting PSM to create a newGOLD profile on the device,

but the GOLD profile already exists on the device.

Managing Profile Templates

Creating a Profile Template

1. From themain menu choose Edit>Profiles, or click the Profile Manager button in the

toolbar.

The Profiles window displays.

2. In the left panel, right-click on Templates and choose a profile type from the pop-up

menu, as shown below.
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The parameters for the selected profile type display in the right panel. The screen

below shows the Bandwidth Profile parameters.

For information on setting parameters for the Bandwidth, Service Policy, Class Map,

or Service Map profiles, see:

• Bandwidth Profile Templates on page 431

• Class Map Profile Templates on page 434

• Service Policy Profile Templates on page 436

• Service Map Profile Templates on page 438

3. Enter a unique name for the profile in the Name field, and set the other parameters

using the drop-downmenu.

4. Click Apply.

The newly-created profile appears under Templates in the left panel of the Profiles

window.
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Editing an Existing Profile Template

Only profile templates can be edited. Auto-discovered profiles from network elements

cannot be edited using PSM.

1. From themain menu choose Edit>Profiles. The Profiles window displays.

2. Expand the Templates tree and select a profile to edit from the profile Templates list.

The profile parameters are displayed in the Selected Profile section on the right side

of the screen, as shown below.

3. To enable editing of the attributes, click the Edit button.

NOTE: Thenameoftheprofile templatealongwithsomeotherparameters
cannot be changed this way. See “Creating a Profile Template Through
Cloning” on page 431 for this type of operation.

4. Modify the parameters.

5. Click Apply to save the changes.
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Creating a Profile Template Through Cloning

You can clone from an existing profile (discovered from a network element) or from a

profile template. Cloning creates a new template with all the same parameter values as

the original. Cloned templates let users deploy proven profiles, thus reducing user input

error.

1. From themain menu choose Edit>Profiles. The Profiles window is displayed.

2. Expand the profile or profile template list so that the profile or profile template you

want to use as the source is displayed.

3. Right-click the profile or profile template that you want to be the source, and choose

Clone from the pop-upmenu.

The profile parameters are displayed in the Selected Profile section on the right panel

with the Name field blank.

4. Enter a name, edit the parameters as required, and click the Apply button.

The clonedprofile template is created anddisplayed in the expandedprofile template

list, and the original profile or profile template is left unmodified.

Deleting a Profile Template

Only profile templates can be deleted. Auto-discovered profiles from network elements

cannot be deleted using PSM.

1. From themain menu choose Edit>Profiles. The Profiles window displays.

2. In the Profiles area, right-click a profile Template from the expanded list, and choose

Delete from the pop-upmenu

A confirmation dialog displays.

3. SelectOK to delete profile template, or Cancel to keep the profile template.

Bandwidth Profile Templates

Bandwidth Profiles are used for policing traffic to:

• control the maximum rate of traffic sent or received on an interface.

• partition a network into multiple priority levels or classes of service.

A bandwidth profile is the starting point of any policing function and can be configured

for use at theCoSqueue, logical interface, or Layer 2 (MAC) level. The figure belowshows

the parameters for a bandwidth profile.
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Figure 85: Bandwidth Profile Template Parameters

There are three modes supported for Bandwidth Profile Templates:

• Two-Rate TCM (TriColor Marker)

• Single-Rate TCM

• CAR

For information about configuring CIR, CBS, EIR and EBS and Quality of Service / Class

of Service , see the BTI7000 Series packetVX Solutions Guide.

NOTE: Pre-10.3 BTI7000 Series network elements and all BTI700 Series
network elements use peak information rate and peak burst size instead of
excess information rateandexcessburstsize.Whenmanagingthosedevices,
PSM internally converts the EIR and EBS to the peak information rate and
peak burst size. This conversion is performed transparently to the operator.
ThevaluesshownonPSMcontinue tobe theEIRandEBS,whereas thevalues
shown on the CLI on those devices are the peak information rate and peak
burst size.

TCMBandwidth Profiles

The Three Color (or Tricolor) Marking (TCM) scheme classifies packets as green, yellow

or red based on user-defined rates and burst size values.

1. To create this type of Bandwidth Profile template, click the New button and select

Bandwidth from the popup dialog.

2. In the Selected Profile attributes pane on the right side, select Two-Rate TCM or

Single-Rate TCM from the Mode attribute.
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Youmust provide a name for the profile template a number of rate values along with

Color Mode and Action attributes.

3. Click Apply to accept the changes, or Discard to cancel.

Two-rate TCM

Two-Rate TCM classifies packets based on two rates and two burst sizes. Two-Rate

TCM is useful when the peak rate needs to be enforced.

The two rate values are Committed Information Rate (CIR) and Excess Information Rate

(EIR).

The two burst size values are Committed Burst Size (CBS) and Excess Burst Size (EBS).

Traffic is marked green, yellow or red based on whether the packets arriving are below

the CIR (green), exceed the CIR but not the EIR (yellow), or exceed the EIR (red).

Single-rate TCM

Single-RateTCMclassifiespacketsbasedonasingle rateand twoburst sizes. Single-Rate

TCM is useful when only the burst size matters.

The rate value is Committed Information Rate (CIR).

The two burst size values are Committed Burst Size (CBS) and Excess Burst Size (EBS).

Traffic is marked green, yellow or red based on whether the packets arriving are below

the CBS (green), exceed the CBS but not the EBS (yellow), or exceed the EBS (red).

CAR Bandwidth Profile Template

Committed Access Rate (CAR) allows you to configure a value above which any traffic

is discarded.

To create this type of Bandwidth Profile template, click theNewbutton and select “CAR”

from the Mode attribute. Enter a name for the profile template and a CAR value. Click

Apply to commit the changes or Discard to cancel.

NOTE: This type of Bandwidth Profile can be used only on the BTI700Series
network elements.

Color Mode and Actions

The colormode for both Two-Rate and Single-Rate TCM is the same, either Color Aware

or Color Blind. Color aware indicates that the existing color of the packet is taken into

considerationwhenapplying thebandwidthprofile. Color blind indicates that theexisting

classification is ignored. The color (green or yellow) of a packet can be determined from

the DEI bit in the VLAN tag.
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Each color has an associated action that can be performed. The Conform Action applies

to packets that are colored green and the Exceed Action applies to packets that are

colored yellow. Incoming traffic that violates the profile is dropped. The options for

assigning actions are as follows:

• None: no action is taken

• Remark DSCP: Sets the IP DSCP (differentiated service code point) value. The value

can be in the range 0-63.

In addition, the Conform Action has the following option:

• Set ToS fromPriority: Sets the IP type of service field

Setting DEI on Exceed Traffic

Traffic that is classified as yellow can have the DEI bit set in the frame.

To select this option, choose Exceed Set DEI.

NOTE: This is only applicable for the BTI7000 Series network elements.

Internal Priority for Bandwidth Profile Templates

The internal priority is the primary determinant of the QoS for the flow. It is a value from

0 to 7 (inclusive) and is used to select the appropriate transmit queue for the packet

when a bandwidth profile is used. If the bandwidth profile is assigned to aUNI, all frames

received on the UNI will be assigned the indicated internal priority.

See the BTI7000 Series documentation for more details.

ClassMap Profile Templates

NOTE: Classmaps are not supported on the BTI805, BTI821, and BTI822.

Class Map Profiles specify the fields of a packet to bematched in order to determine the

packets to classify.
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Figure 86: Class Map Profile Template

In Class Map profiles, at least onematch criteria must be added. All criteria added to the

profilemustmatch in order for a packet to be classified by a particular ClassMap Profile.

1. From themain menu choose Edit>Profiles. The Profileswindow is displayed.

2. Right-click beside Templates and choose Create Class Map Profile.

Class Map fields are added to the Selected Profile window on the right.

3. Enter a name for the class map in the Name field.

4. From the type drop-downmenu, select a class map type:

• Ingress per Cos

• Egress per CoS

• Service Map

5. From the NewMatch drop-down list, select the criteria to match.

6. Click Add.
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A new attribute is displayed based on the selection and a valuewill be required. An Xwill

be displayed next to the attribute allowing the match criteria to be removed if desired.

NOTE: TheBTI700Seriesdevicesonlysupport the followingsubsetofMatch
criteria:

• C-VLAN

• C-VLAN Priority

• S-VLAN Priority

• Source MAC

• Destination MAC

Class Map profile templates work in conjunction with Service Policy Profile Templates.

See “Example: Activating EVPLAN and EVPLINE Services Using Service Maps for Flow

Redirection” on page 381 for an example on how to configure class maps.

Service Policy Profile Templates

NOTE: ServicepoliciesarenotsupportedontheBTI805,BTI821,andBTI822.

Service Policy Profile Templates are used to pair Bandwidth Profiles with Class Map

Profiles.
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Figure 87: Service Policy Profile Template

Anynumberof IngressorEgressClassMapProfiles canbepairedwithBandwidthProfiles

in a Service Policy Profile provided that:

• all pairings are of the same type, either Ingress or Egress

• a Class Map profile can appear only once in a given Service Policy profile

To create a Service Policy Profile Template:

1. Create at least one Bandwidth Profile Template and one Class Map Profile Template.

See “Bandwidth Profile Templates” on page 431 and “Class Map Profile Templates”

on page 434.

2. From themain menu choose Edit>Profiles. The Profileswindow is displayed.

3. Right-click beside Templates and choose Create Service Policy Profile. The Selected

Profile fields display on the right.
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4. In the Name field, enter a unique name for the Service Policy.

5. FromtheClassMapandBandwidthdrop-downmenusselectaClassMap/Bandwidth

pairing.

6. To add subsequent pairings to the Service Policy Profile, click Add and select the

desired Class Map(s) and Bandwidth Profile(s).

7. When you are done, click Apply.

See “Example: Activating EVPLAN and EVPLINE Services Using Service Maps for Flow

Redirection” on page 381 for an example on how to configure service policies.

Service Map Profile Templates

Service Map Profile templates are used to associate Class Map Profiles with Service

Policies.

Figure 88: Service Map Profile Template

Any number of Class Map Profiles can be specified provided that each Class Map Profile

appears only once in a given Service Map Profile.

To create a Service Map Profile Template:
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1. Create at least one Class Map Profile Template of type Service Map. See “Class Map

Profile Templates” on page 434.

2. From themain menu choose Edit>Profiles. The Profileswindow is displayed.

3. Right-click beside Templates and chooseCreateServiceMapProfile. The ServiceMap

Profile window is displayed on the right.

4. In the Name field, enter a unique name for the Service Map Profile.

5. From the Class Map drop-downmenu select a Class Map.

6. To addmore Class Maps to this Service Map Profile, click Add and select the desired

Class Map(s).

7. When you are done, click Apply.

See “Example: Activating EVPLAN and EVPLINE Services Using Service Maps for Flow

Redirection” on page 381 for an example on how to configure service maps.

SLAMeasurement Profile Templates

Use this procedure to create Y.1731-based SLA (service level agreement) Measurement

Profile Templates which can be assigned to Ethernet services.

Figure 89: SLAMeasurement Profile Template
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To create an SLAMeasurement Profile Template:

1. From themain menu choose Edit>Profiles. The Profileswindow is displayed.

2. Right-click beside Templates and choose Create SLAMeasurement Profile. The

Selected Profile fields display on the right.

3. In the Name field, enter a unique name for the SLAMeasurement Policy.

4. Specify the attributes as desired.

5. When you are done, click Apply.
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CHAPTER 13

Managing Pseudowire Services

• Introduction on page 441

• Visualizing a Pseudowire Service on page 441

• Service Activation on page 444

• Modifying a Pseudowire Service on page 450

• Deleting a Pseudowire Service on page 451

Introduction

A pseudowire service provides pseudowire connectivity between pseudowire endpoints.

A pseudowire endpoint is a TDM DS1/E1 interface on a pseudowire-capable module.

The incoming bitstream on the TDM interface is encapsulated within Ethernet frames

and transportedacross thenetworkas regularEthernet traffic. At theegress, thebitstream

is extracted from the Ethernet frames and transmitted out the DS1/E1 interface at the

far end.

PSM can be used to manage pseudowire services on the BTI810.

Visualizing a Pseudowire Service

Use some or all of the techniques in this procedure to visualize a pseudowire service.
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1. In the Network tree, select the desired pseudowire service.

The selected pseudowire service topology view opens in the main map window.

NOTE: If this is your first time visualizing this service, you will see the
administratively-defined default layout if it exists. If a default layout does
not exist for this service, then you will see the layout that PSM
automatically generates. See 8.

NOTE: If this is your second or subsequent time visualizing this service,
you will see the layout that existed when you last exited this service view.

2. To see details on a network element, link, or port, hover over the network element,

link, or port.

3. To see the equipment on a network element, double-click the NE.

The equipment and connections are shown in a zoomed-in view.

4. To change the size of the service view:

a. Right-click the background and select Zoom In to increase the view size

b. Right-click the background and select ZoomOut to decrease the view size

c. Right-click the background and select Reset Zoom to return the view size to its

original size

5. Right-click anetwork elementandselectNetworkElement to see the regularNEmenu

options.
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6. Tomove elements in this view, drag elements to the desired location.

7. Tomove all of the ports and switches in the service, choose Select All and drag the

service within the window.

8. You can save the current layout as the default, or revert to the default, or revert to the

layout that PSM automatically generates.

a. To save the current layout as the default layout for this service, right-click the

background and select Save Layout as Default.

NOTE: Youmust have administrator privileges to execute this
command.

Once the current layout is saved as the default, subsequent users who visualize

this service will be able to see the current layout.

b. To reset the current layout to the default, right-click the background and select

Reset Layout to Default.

c. To reset the current layout to the layout that PSM automatically generates,

right-click the background and select Reset Layout.

9. To save the service screen view as an image:

a. Select Save Service Image.

The Save Service Image dialog appears.

b. Navigate to the desired folder and enter the filename.

The default file format is png. To save the file in jpg format, enter .jpg at the end

of the filename.

c. Click Save.

10. To select all NEs in the service, click Select Network Elements.

443Copyright © 2019, Juniper Networks, Inc.

Chapter 13: Managing Pseudowire Services



This brings you back to themain Topology Map view and shows all NEs in the service

selected.

Service Activation

PSM supports the Metro Ethernet Forum (MEF) paradigm for activating T1/E1 TDM

(pseudowire) services inaBTI810network.Serviceactivation isperformedby first creating

a regular Ethernet service and then creating a pseudowire service that uses that Ethernet

service.

Figure90onpage444shows thecomponentmodel for aBTI810switchwithaT1/E1 card

residing in slot 1 and an OC3/STM1 card residing in slot 2.

Figure 90: BTI800 Series Component Model

Each card consists of a set of TDM and logical pseudowire interfaces. The pseudowire

interfaces are logically connected to the UNI, and are distinguishable from each other

through different CVLANs. Each card is automatically associated with its own UNI, with

theUNI in logical slot 2 port 1 (2/1) associatedwith the card in physical slot 1, and theUNI

in logical slot 3 port 1 (3/1) associatedwith the card in physical slot 2. These associations

are hardcoded and cannot be changed.

The incoming bitstream on the TDM interface is processed on the card, encapsulated

inside an Ethernet frame (with a destinationMAC address of the remote TDM card), and

passed to the local UNI. From there, the TDM traffic is transported across the network

as regular Ethernet traffic.
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NOTE: When configuring the underlying Ethernet service, you should take
into consideration the delay variation requirements for a TDM circuit.

Although a TDM service is point-to-point, the Ethernet service (or EVC) that transports

the TDM traffic can be EVPLINE or EVPLAN. If EVPLINE is used, then each TDM service

uses its own point-to-point EVC. If EVPLAN is used, thenmore than one TDMservice can

share the same EVC. In the previous figure, all TDM services on the switch share a single

EVC. Note that each TDM service is still point-to-point. The network routes the Ethernet

frames based on the destination MAC address and CVLANmembership, so only the

intended destination will receive the traffic.

TIP: For convenience, you can share a single EVC acrossmultiple TDM
services. In this way, you do not need to create an Ethernet service for each
TDM service.

• Activating a Pseudowire Service on page 445

Activating a Pseudowire Service

Use this procedure to configure and activate a pseudowire service on a BTI800 Series

network.

Prerequisites:

• All the necessary Ethernet NNIs have been configured in the network. If this network

includesBTI7000SeriesNEs, thenall thenecessarypacketVXcardsandvirtual switches

have been configured.

• The Ethernet service connecting the two TDM endpoints has been configured.

• The TDM endpoint interfaces have been configured.

• ERPS has been configured, as applicable. This prevents routing loops whenmultiple

paths exist through the network.
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1. Click the Service Activation button on the toolbar and choose Pseudowire from the

drop-downmenu.

If youhaveoneEthernetdomainonly, theActivatePseudowireServicewindowappears,

as shown. Proceed to 3.

Figure 91: Activate Pseudowire Service (CESOP)

If you havemultiple domains, a Pseudowire Service Activation pop-up dialog box is

displayed, as shown. Proceed to 2.

2. From the Select Domain drop-downmenu, select a domain in which to create the

service. ClickOK.

Although you are creating a pseudowire service, you still need to select the Ethernet

domain in which you are running the service because you will need to associate the

pseudowire service to an Ethernet service later.
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3. In the Service Attributes pane of the Activate Pseudowire Servicewindow, enter the

required information as listed in the following table.

Table 48: Fields in the Service Attributes Pane

Required field?DescriptionField

YesUser-defined name that identifies the service. Must be unique to all
pseudowire services in the domain.

Service Name

YesEmulated circuit identifier. Must be unique to all pseudowire services
in the domain.

The auto-populated value can be overridden.

ECID

OptionalUser-defined. See “Adding a Customer” on page 454.Customer

YesThe service type can be SATOP or CESOP. By default, the service type
is SATOP. When you select CESOP, additional fields are available for
configuration.

Service Type

4. Configure the Interface A endpoint.

a. In the Service Details pane, use the pulldownmenu to select the Network Element

for the Interface A endpoint.

The pulldownmenu is populated with all BTI800 Series nodes that have TDM

cards inserted.

b. Select the Slot and Interface from the pulldownmenus.

Thepulldownmenusarepopulatedwithall possible selections.Only the interfaces

(or timeslots) not already in use can be selected. Interfaces or timeslots that are

part of an existing service are greyed out.

NOTE: Only ports that have been configured on the device as framed
and enabled are selectable for a CESOP service.

NOTE: Entries with an (M) designation can be configured as clock

masters. Entries without that designation can only be configured as
slaves (or use internal clocking).

c. Select the Clock Reference.

d. For CESOP, specify the Channels that make up the service.

You can specify a single channel (e.g. 5), a range of contiguous channels (e.g.
5-20), non-contiguous channels (e.g. 5,9), or a mix (e.g. 3,5-20). For T1, the
available channels are 1 to 24. For E1, the available channels are 1 to 31. A channel

cannot belong to more than one service.
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NOTE: If the Clock Reference is set to Adaptive Master, then youmust

select one, two, four, or eight channels.

NOTE: Channelized services can only be configured for T1/E1 cards.

e. Configure the TDM and physical interface settings (optional).

Click on the Settings tab and set the TDM and physical interface (T1/E1 card only)

attributes by clicking in the appropriate box.

Table 49: TDMAttributes

DefaultRangeDescriptionAttribute

60 to 7This specifies the priority to assign to the service.Customer VLAN
Priority

50002000 to 32000This specifies the size of the jitter buffer in microseconds.PDV (Jitter Buffer)

SATOP: 192

CESOP: None.

SATOP: 192, 384,
576, 768, 960

CESOP: Depends
on the number of
channels. See
Table51onpage448.

This specifies the payload size of the packetized bitstream in
bytes. Both endpoints must have the same payload size.

Payload Size

Table 50: Physical Interface Attributes (T1/E1 Card Only)

DefaultRangeDescriptionAttribute

0 to 1330 to 133, 134 to
266, 267 to 399,
400 to 533, 534 to
655 feet

This specifies the line build out (in feet) for the interface.Line Build Out

B8ZS (T1)

HDB3 (E1)

AMI or B8ZS (T1)
or HDB3 (E1)

This specifies the line coding for the interface.Line Code

Table 51: CESOP Payload Sizes

Allowed payload sizesNumber of channels

641

64,96,128,160,192,224,2562

96,120,144,168,192,2163
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Table 51: CESOP Payload Sizes (continued)

Allowed payload sizesNumber of channels

64,96,128,160,192,224,2564

40,80,120,160,200,240,280,3205

48,96,144,192,240,288,3366

56,112,168,224,280,3367

64,128,192,256,3208

72,144,216,2889

80,160,240,32010

88,176,264,35211

96,192,28812

104,208,31213

112,224,33614

120,24015

128,25616

136,27217

144,28818

152,40319

160,32020

168,33621

176,35222

18423

19224

20025

20826

21627
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Table 51: CESOP Payload Sizes (continued)

Allowed payload sizesNumber of channels

22428

23229

24030

24831

5. Repeat 4 for Interface Z.

NOTE: Unlike the BTI800 Series CLI, you do not need to enter the
destinationMACaddress.PSMautomaticallydetermines theMACaddress
at both ends of the service.

6. Select the Ethernet Service to use from the pulldownmenu.

Only the Ethernet services that include the UNIs at both ends are shown.

7. Specify the CVLAN to use for the service. This is the CVLAN that exists between the

pseudowire endpoint and the Ethernet UNI.

The same CVLAN is used at both endpoints. The value itself is not important but it

must be unique at each UNI.

8. Click Activate. The service is activated.

NOTE: Youmust wait for the activation tasks to complete before
performing any other operation on the NEs affected by this activation.

Modifying a Pseudowire Service

CAUTION: Modifying a servicemight affect the service or the data traffic
running on the service.

A stranded or semi-stranded service cannot bemodified. A stranded or semi-stranded

service refers to a service that has incomplete configuration that results in the absence

of end-to-end connectivity.
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1. In the Network tree view, expand the Pseudowire branch and double-click the service

you want to modify.

The selected service appears in the main panel.

2. Tomodify the customer associated with this service, select a different customer in

the Customer pulldownmenu in the Service Attributes pane.

3. Tomodify the TDM or physical interface settings, select Settings... for Interface A or

Interface B as desired.

4. Make changes to theCustomerVLANPriority, thePDV (Jitter Buffer), thePayloadSize,

and/or the physical interface attributes and clickOK.

5. After making all your changes, click Apply.

Deleting a Pseudowire Service

1. To delete a service, right-click on the service in the Network tree view and choose

Delete.

A dialog opens asking for confirmation.

2. ClickOK.

The service is deleted, and is subsequently removed from the Network tree view the

next time the node updates the proNX Service Manager.
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CHAPTER 14

Managing Customers

• Introduction on page 453

• Adding a Customer on page 454

• Modifying a Customer on page 455

• Deleting a Customer on page 456

Introduction

PSM allows you to add, modify and delete data about your customers. Customer data

includes a company name, company reference, a list of employees specifying who is the

primary andmaintenance contact, and a notes section.

Customerscanbeassociatedwithservicesduringserviceactivation.Whenthisassociation

is made, you will be able to see which services belong to which customers, and which

alarms affect which customers.

NOTE: Customer dataand service association arepart of the replicateddata
set when running withmultiple servers. For more information on replicated
data, see “Running Multiple Servers with Server Replication” on page 30.
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Adding a Customer

1. To add a customer, click the Add Customer icon in the toolbar as shown below.

You can also right-click Customers in the Network tree and choose Add Customer as

shown below.

The Customer screen displays.

2. In the Company Name field (required), enter a unique name for the customer.

3. In the Company Reference field (optional), enter additional customer identification

information.

4. In the Employees table, click Add.

The Add Employee window displays. Enter a Name, Email and Telephone number,

then click OK.
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NOTE: Entering data in the Employee Details fields is optional; however,
it is recommended that at least one field be completed.

5. To edit employee details, select an employee from the Employees window and click

Edit. The Edit Employee window displays where you can change data.

6. To delete an employee record, select an employee from the Employees window and

click Delete. You are prompted to confirm the deletion.

7. You can also designate employees listed in the Employees window to be a Primary

Contact or a Maintenance Contact, and add text in the Notes fields:

• In the Primary Contact field, choose an employee from the drop-down, or select

<none>

• In the Maintenance Contact field, choose an employee from the drop-down, or

select <none>

• In the Notes field, enter any additional text.

8. Click Save.

Modifying a Customer

1. In the Customers area of the Network tree view, right-click the customer name and

choose Edit Customer from the pop-upmenu, as shown below.
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TheCustomerDetails screendisplays.All fields incanbemodifiedexcept theCompany

Name field.

2. To save the changes, click Save. To discard the changes, click Discard Edits.

Deleting a Customer

1. In the Customers area of the Network tree view, right-click the customer name and

choose Delete Customer.

A confirmation dialog is displayed.

2. ClickOK to delete the customer or Cancel to cancel.
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CHAPTER 15

Managing Network Element Alarms

• Supported Network Elements and Devices on page 457

• Alarm Visualization on page 458

• Acknowledging, Emailing, and Clearing Alarms on page 469

• Assigning an Alarm to a User on page 470

• Viewing Historical Alarms on page 470

• Viewing Alarms Through an RSS Feed on page 472

• Sending Traps on the Northbound Interface on page 473

Supported Network Elements and Devices

PSM supports the display and processing of alarms for the following:

• BTI7800 Series network elements

• BTI7000 Series network elements

• BTI800 Series network elements

• BTI700 Series network elements

• MX Series and PTX Series routers

• QFX Series switches

MXSeries, PTX Series, and QFX Series Alarms

Not all MX Series and PTX Series and QFX Series alarms are reported by PSM. PSM

reports the following alarms for these devices:

• Chassis alarms

• Link down

• Optical diagnostics (from JUNIPER-DOM-MIB)

• OTN (from JUNIPER-OTN-MIB)

Addtionally, severities for chassis alarms are mapped as follows:
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Table 52: Alarm Severity Mapping for Chassis Alarms

PSM alarm severityMX Series, PTX Series, QFX Series chassis alarm severity

CriticalMajor

MajorMinor

Minor-

Alarm Visualization

PSM displays alarms reported by discovered network elements in the Alarms panel, and

provides an alarms summary at the bottomof thewindow. Alarms are displayed in table

formatasshown in the figurebelow.Whenyouhover thecursoroveranalarmdescription,

a tool tip appears and provides more information on the alarm.

Figure 92: Alarm Table View

NOTE: Alarm times from each NE are translated into the current PSM server
time, so variances in timezones are handled automatically when being
displayed in the table. It is highly recommended that PSM and all NEs in the
network use NTP servers for obtaining the time in order to avoid time
discrepancies.

Alarms in the alarms table and in the alarms summary are color-coded by severity:

• Red - critical alarms

• Amber - major alarms

• Yellow - minor alarms

• Grey - acknowledged alarms

• Green - cleared alarms

An alarm remains in the table until it is cleared, at which time the alarm is removed from

the table, either immediately or after a configurable delay. If no delay is configured, the

alarm just disappears from the table, with no indication that the alarm has been cleared,

save for its absence. If a delay is configured, the alarm changes color to green to signify

that it has been cleared, and remains in the table for the delay period. At the end of this

period, the alarm is removed from the table. For details on how to configure this option,

see “SettingAlarmDisplayOptions”onpage269.Regardlessofwhichoption is configured,
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when an alarm is cleared, the cleared alarms counters are incremented in the alarms

summary bar at the bottom of the window. For information on the alarms summary bar,

see “Understanding the Alarms Summary Bar” on page 466

Alarms are automatically retrieved from NEs and added to the alarms table upon initial

nodediscoveryandare kept synchronizedusingSNMPtraps.Whenadevice is discovered,

the PSM server registers itself as a trap listenerwith the network element, which enables

the application to receive notification of new or cleared alarms.

When you first log in to the PSM server , the PSM server retrieves outstanding alarms

from discovered network elements, and populates the alarms table. Previously

acknowledged alarms continue to be acknowledged, but previously cleared alarms are

not remembered.

When a network element is deleted, the following occurs:

• Outstanding alarms raised by the deleted network element are removed from the

alarms table, and thealarmscounters in thesummarybararedecrementedaccordingly.

• Acknowledged alarms for the deleted network element are removed from the alarms

table, and the acknowledged alarms counters in the summary bar are decremented

accordingly.

NOTE: Cleared alarms from the deleted network element are not removed
and cleared alarms counters in the summary bar do not change from this
deletion.

• Viewing Current Alarms on page 460

• Understanding Alarm Timestamps on page 461

• Working with the Alarms Table on page 462

• Understanding the Alarms Summary Bar on page 466

459Copyright © 2019, Juniper Networks, Inc.

Chapter 15: Managing Network Element Alarms



Viewing Current Alarms

1. To view current alarms, from themain menu choose View>Alarms > Alarms.

The current alarms are displayed in table form in the Alarms pane.

2. To filter the list of current alarms, see “Working with the Alarms Table” on page 462.

3. To view details of an alarm:

a. Right-click the alarm and select AlarmDetails >View.

The Detailed Alarm Informationwindow appears.
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NOTE: Not all fields apply to all network elements. For an explanation
of these fields, see “BTI7800 Alarm Details” on page 554.

b. To copy to clipboard, click Copy.

You can now paste the alarms details text into another application.

c. ClickOK to close the window.

4. To suspend alarm notifications, right-click in the Alarms pane title bar and select

Suspend AlarmNotifications.

Alarms continue to be collected in the backgroundbut the alarms table and summary

bar are not updated with newly-raised alarms, newly-cleared alarms, or

newly-acknowledged alarms. The delay timer for existing cleared alarms continues

to count down but the cleared alarms remain in the table even after the delay period

expires.

Only after alarmnotifications have resumed, either fromoperator intervention or from

configured timeout, are the alarms table and summary bar updated. Newly-raised

alarms are now added to the table. Cleared alarms that timed out while alarms were

suspended are now removed from the table. Alarms that were cleared while alarms

were suspended now change color to green and the delay timer started. Alarms that

were acknowledged while alarms were suspended now change color to grey. The

counters in the alarms summary bar are now updated accordingly.

5. To see an alarms summary for individual NEs or network element groups, hover over

the element in the navigation pane.

Understanding Alarm Timestamps

The timestamp of an alarmmight undergomultiple time zone adjustments by the time

thePSMClient displays the alarm to the user. The network element that raises the alarm,

the PSM Server that receives the alarm, and the PSM Client that displays the alarm can

all be in different time zones. In order to be able to correlate alarms, it is important to

understand how PSM performs alarm timestamping.
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How the PSMServer Timestamps the Alarms

When an alarm condition occurs, the network element sends a trap to the PSM Server.

The server timestamps the alarm based on when the server receives the trap. This

timestamp is relative to the server's local time zone. Some network elements include a

network element timestamp in the trap. In this situation, thePSMServer uses thenetwork

element timestamp (converted to the local server time zone) instead of the time when

the server receives the trap.

NOTE: Some network elementsmight lose the original alarm timestamp
whenthenetworkelement is rebooted. In this situation, thealarmtimestamp
shownusingthenetworkelement'sCLImightbedifferent fromthetimestamp
shownonthePSMServer.ThePSMServercontinues touse theoriginalalarm
timestamp.

How the PSMServer Timestamps the Clears

When an alarm condition is cleared, the network element sends a clear trap to the PSM

Server. The server timestamps the clear based onwhen the server receives the clear trap.

This timestamp is relative to theserver's local timezone.Networkelementsdonot include

a network element timestamp in the clear trap, so the PSM Server always uses the time

when the clear trap is received.

How the PSMClient Displays Timestamps

The PSM Client converts the timestamp reported by the PSM Server to the client's local

time zone. All timestamps displayed by the client are therefore local to the client's time

zone.

Working with the Alarms Table

The PSM client displays alarms in table format so you can sort alarms by column, and

filter alarms by type.

Sorting the Alarms Table

The alarms table can be sorted in the following ways:

• To sort the Alarms table by a column, click the column title.

• To change the order (ascending or descending) of a column, click the column heading

until the arrow shows ascending or descending order as desired.

• To hide a column, right-click any column title and uncheck the column name youwant

tohide in thedrop-downmenu.TheNetworkElement/Alarmcolumncannotbehidden.

• To showor hide columns in the alarms table, right-click theAlarmsDescription column

header and from the drop-downmenu select the columns that you want to show or

hide.
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Filtering the Alarms Table

The alarms table behaves as follows:

• If there is no alarm filtering applied, the alarms window title is displayed as "Alarms".

• If a filter is applied, the title changes to indicate the applied filter, for example "Alarms

(Devices - 10.1.103.6)".

• If the filter description is too long to display completely, the title changes to "Alarms

(filtered)".

• By hovering over the alarms table title bar, a tool tip is displayed listing the applied

filter attributes.

• Each timeanewentity or filter is chosen, theprevious filtering is clearedand thealarms

table displays the alarms that pertain to the chosen criteria.

The alarms table can be filtered in the following ways:
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• From themain menu, choose Tool>Options. Click Display, and then click Alarms and

configure the alarm display options as desired.

See “Setting Alarm Display Options” on page 269 for an explanation of these fields

• To filter the table to showonly a particular set of alarms, right-click a cell in the column

of thealarms table thathas thedatayouwant to filterwith, andchoose the filter option

Showonly rowswhere to filter out (hide)all other entries fromthe table. In the following

screen, the filter chosen is to show only XFP failure alarms.

• To filter the table to show alarms that pertain only to a particular NE, service, or group,

in the tree view right-click the entity and choose Alarms>Filter.
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• To quickly filter alarms based on severity, click a severity in the alarms summary bar

to apply a filter for that severity. For example, clicking in the critical alarms section of

the summary bar applies a Severity = CRITICAL filter to alarms in the alarms pane.

• To remove filtering, right-click the alarms table header, and choose Clear Filter from

the drop downmenu.

Alternatively, right-click any cell in the alarms table and choose Show only rows

where>No Filter.
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Using Service/alarm Correlation

PSM provides the capability to view the alarms that pertain to a particular service, or to

view the services that are affected by a given alarm.

• To view the alarms that pertain to a service, in the Service tree view, select the service,

right-click a service andchooseAlarms>Select. Thealarms that pertain to the selected

service are highlighted in blue. In the following illustration, there is a single alarm

affecting the selected service.

• To determine the service(s) affected by an alarm, in the Alarms window select the

alarm, right-click and choose Select Affected Services.

The affected service is highlighted in the Services tree.

• To see an alarm summary for the service, hover over the service name.

A summary of the number of critical, major, minor, and acknowledged alarms is

displayed beneath the service name.

Suspending AlarmNotification

If thenetwork isundergoinga lotofalarmactivity, youcansuspendchanges to thealarms

table.

• To suspend alarm notification, from themain menu click the Suspend Alarm

Notifications icon, or, alternatively, right-click the alarms table header, and choose

SuspendAlarmNotifications fromthedrop-downmenu. In this case thealarmswindow

title is displayed as "Alarms (Suspended)" and the alarmswindow does not show any

new alarms changes.

• To resumealarmnotification, fromthemainmenuclick theResumeAlarmNotifications

icon, or, alternatively, right-click the alarms table header, and choose Resume Alarm

Notifications from the drop-downmenu. The PSM client asks the PSM Server for the

latest active alarms list (including alarm clear requests) and updates the alarms

window appropriately. The alarms window title changes back to "Alarms".

Understanding the Alarms Summary Bar

ThePSMClient displays an alarms summary at the bottomof thewindow, and in various

summary views, color-coded by severity.
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Table 53: Alarms Summary Bar

NotesTypeColor

The value outside the parentheses represents the current number of outstanding
alarmsat the indicatedseverity, and is equivalent to thenumberofoutstandingalarms
in the alarms table for that severity. This counter is not resettable.

Thevalue inside theparentheses isan incremental value that represents thedifference
(or delta) between the current number of outstanding alarms and the number of
outstanding alarms when the counter was last reset. A positive value indicates that
the number of outstanding alarms has increased. A negative value indicates that the
numberofoutstandingalarmshasdecreased.This value isnot individually resettable,
and can only be reset together with the deltas for the other alarms.

Both values are incremented for any alarms retrieved when a new network element
is discovered.

Both values are decremented for any alarms removed when a network element is
deleted.

CriticalRed

MajorAmber

MinorYellow

The value outside the parentheses represents the current number of acknowledged
alarms, and is equivalent to the number of acknowledged alarms in the alarms table.
This counter is not resettable.

Thevalue inside theparentheses isan incremental value that represents thedifference
(or delta) between the current number of acknowledged alarms and the number of
acknowledged alarms when the counter was last reset. A positive value indicates
that the number of acknowledged alarms has increased. A negative value indicates
that the number of acknowledged alarms has decreased (through an operator
unacknowledgeaction). This value is not individually resettable, andcanonlybe reset
together with the deltas for the other alarms.

Bothvaluesaredecremented for anyacknowledgedalarms removedwhenanetwork
element is deleted.

AcknowledgedGrey

The value outside the parentheses is an incremental value that represents the
difference between the current number of cleared alarms and the number of cleared
alarmswhen the counter was last reset. This number can only increment and cannot
decrement. There is no correlation between this value and the number of cleared
alarms in the alarms table. Cleared alarms are automatically purged from the alarms
table after a configurable time period. This value is individually resettable.

Thevalue inside theparentheses isan incremental value that represents thedifference
(or delta) between the current number of cleared alarms and the number of cleared
alarmswhen the counter was last reset. This number can only increment and cannot
decrement. This value is not individually resettable, and can only be reset together
with the deltas for the other alarms.

Both values are unaffected by the addition or deletion of any network elements.

ClearedGreen

Resetting the Deltas

When you first log in to the PSM server, the delta values (including both cleared alarms

counters) are reset to 0. Subsequently, the delta values can be reset as follows:
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• To reset thevalues inside theparentheses, right-clickanywhere in thealarmssummary

bar or in the Alarms pane title bar and select Reset Summary Deltas. This resets all

deltas concurrently.

• To reset the cleared alarms value outside the parentheses, right-click anywhere in the

alarms summary bar or in the Alarms pane title bar and select Reset Clear Summary.

Interpreting the Deltas

Thealarmssummaryprovideshints onwhat is happening in thenetwork. Youmight need

to interpret the summary holistically rather than as independent counters.

Table 54 on page 468 lists general guidelines on how to interpret the summary, and

describes somecommoncauses that could precipitate the observed situations. Because

other causes are possible, you should investigate further to confirm what is indeed

transpiring.

Table 54: Interpreting the Alarms Summary

Might indicate ...Observed situation

Flapping port or frequent intermittent failure and restoration, together with a
failure of a shared component, network element, or link.

High critical/major/minor alarms delta, high
cleared alarms delta

Failure of a shared component, network element, or link.High critical/major/minor alarms delta, low
cleared alarms delta

Flapping port or frequent intermittent failure and restoration.Low critical/major/minor alarms delta, high
cleared alarms delta

No change.Low critical/major/minor alarms delta, low
cleared alarms delta

Restoration of a shared component, network element, or link, and a possible
flapping port or frequent intermittent failure and restoration.

High (negative) critical/major/minor alarms
delta, high cleared alarms delta

Filtering Based on Alarm Severity

The alarms summary bar provides a quick way to filter alarms based on alarm severity.

Simply click on a severity to apply a filter for that severity. For example, clicking in the

critical alarms section of the summary bar applies aSeverity =CRITICAL filter to alarms
in the alarms pane.
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Acknowledging, Emailing, and Clearing Alarms

1. To acknowledge an alarm, select the alarm from the table, right-click and select

Acknowledge.

The alarm is set to "Acknowledged" and turns grey, or, if "Hide Acknowledged" has

been selected, is removed from the list.

NOTE: Alarmacknowledgementsarepartof the replicateddatasetwhen
running withmultiple servers. For more information on replicated data,
see “Running Multiple Servers with Server Replication” on page 30.

2. To hide acknowledged alarms, right-click on the Alarms tab and choose Hide

Acknowledged. All alarms that are set to "Acknowledged" are removed from the

alarms list. The alarms remain in the server and are available to other clients.

3. To show acknowledged alarms, right-click on the Alarms tab and choose Show

Acknowledged. Acknowledged alarms are displayed and are grey in color.

4. To unacknowledge all alarms on the client, right-click the Alarms view heading and

select Unacknowledge All.

5. To email details about one ormore alarms, select one ormore alarms (by holding the

Shift or Ctrl key on the keyboard) from the list, right-click and select AlarmDetails

>Email. A new email is created in your local email application with the details of all

the selected alarms populated in the body of the email.

6. You cannot clear an NE-generated alarm. You can only clear alarms that have been

generated by the PSM. Tomanually clear a PSM-generated alarm, right-click on the
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alarm and choose Clear NMSGenerated Alarm. Once cleared, you cannot restore an

alarm.

Assigning an Alarm to a User

By assigning an alarm to a user, alarms can be filtered by user name.

1. In the alarmwindow, right-click on an alarm and choose Assign Alarm to User and

choose the desired user from the list.

NOTE: Alarmassignmentsarepartof the replicateddatasetwhen running
withmultiple servers. For more information on replicated data, see
“Running Multiple Servers with Server Replication” on page 30.

2. To filter the list of current alarms by assigned user, the "User Assigned" columnmust

be displayed. Do this by right-clicking beside one of the column headers to display

the drop-downmenu and ensure that the "User Assigned:..." attribute is checked.

For more information on filtering options, see “Working with the Alarms Table” on

page 462.

Viewing Historical Alarms

Use this procedure to view the historical alarms table.

Historical Alarms provides youwith a view of all resolved and unresolved alarms. To help

youmanage this list, PSM allows you to apply filters to narrow down the view to the

desired subset.

PSM builds the historical alarms list from active alarms as they are raised (and when

NEs are discovered).

Additionally, for the BTI7000 Series NEs, PSM reads the Alarm Logs table available on

the NE, and supplements the historical alarms list with any alarms that are found in that

table but missing from PSM's historical alarms list. The PSM server reads that table
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during NE discovery, and periodically thereafter to ensure the lists are synchronized. The

timestamps for theaddedalarmsarebasedonthe timestamps retrieved fromthenetwork

element, adjusted for the local PSM server's time zone.

For the other types of NEs (including the BTI7800 Series NEs), PSM builds the historical

alarms list based solely on alarms it sees. Consequently, for those NEs, historical alarms

do not contain alarms that were raised and cleared prior to PSMmanaging the device.

NOTE: In somecases, youmight seeduplicatealarms in thehistorical alarms
table. If you delete and then rediscover a network element, PSMmight insert
the same alarm into the table as it reprocesses the outstanding alarms for
the rediscovered NE.

To access Historical Alarms:

1. From themain menu choose View>Alarms > Historical Alarms.

2. To see the full alarm list, select PerformQuerywith no filters chosen.
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3. To filter historical alarms, select thedesired filteringoptions fromtheFilter andSorting

Options dialog. You can order results by a specific field and with a set number of

alarms displayed per page specified.

Viewing Alarms Through an RSS Feed

The proNX Service Manager Client allows the user to view active alarms on their web

browser through an RSS feed. To activate this way of viewing alarms, type the following

URL into your web browser:

https:<IP address of PSM server host>:<port>/AlarmsFeed

You can also filter the alarms sent to your browser by adding an alarm severity to the

URL, such as:

https:<IP address of PSM server host>:<port>/AlarmsFeed/major

The port number is specified by the resources.address.port attribute in the

common.properties file.

The screen below shows a list of active alarms displayed in a web browser.
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Sending Traps on the Northbound Interface

The PSM northbound interface refers to communications between PSM and a higher

level network management system, such as from the PSM server to a network

management system in the NOC.

You can add trap receivers to transmit traps northbound from the PSM server. To limit

the information that is forwarded, you can specify filtering parameters, such as Date

Raised, Severity, and Service Affecting for each trap receiver.

When the PSMserver receives anNE trap, PSMmaps theNE trap information into a PSM

trap before sending the resulting PSM trap to northbound trap receivers. This mapping

is described in the PSMMIB (bti-psm.my). The northbound NMSmust be able to parse

the resulting PSM trap.

NOTE: The OID of the northbound trap is the
BTI-PSM-MIB::notificationAlarms OID.

• Adding a Trap Receiver for Alarms on page 473

• Modifying a Trap Receiver for Alarms on page 475

• Deleting a Trap Receiver for Alarms on page 475

Adding a Trap Receiver for Alarms

1. From the Editmenu, choose Trap Receivers.

2. On the Trap Receivers tab, right-click Right-Click to Add, and then click Add Trap

Receiver.
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3. In the New Trap Receiver dialog, specify the following settings:

• IP Address

• Port

• Community

4. Optionally, choose values from the Filters drop-down lists to limit (filter) the

information that is forwarded. Information can be filtered according to one or more

of the following alarm-related parameters:

• Alarm Description

• IP Address

• Source

• Time Raised

• Time Cleared

• Severity

• Service Affecting

• Acknowledged

• System Name

• Domain Name

• User Assigned

• Category

• Condition Type

5. Click Apply.
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The trap receiver appears in the list on the Trap Receivers tab.

6. Repeat 2 to 5 for each trap receiver to be added.

Modifying a Trap Receiver for Alarms

1. From the Editmenu, choose Trap Receivers.

2. On the TrapReceivers tab, right-click a trap-receiver, and then click Edit TrapReceiver.

3. In the Edit Trap Receiver dialog, modify settings as required, and then click Apply.

The modifications are applied and the Edit Trap Receiver dialog closes.

4. Repeat 2 and 3 for each trap receiver to bemodified.

Deleting a Trap Receiver for Alarms

1. From the Editmenu, choose Trap Receivers.

2. OntheTrapReceivers tab, right-click a trap receiver, and thenclickDeleteTrapReceiver.
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3. In the confirmation dialog, clickOK.

The trap receiver is removed from the list on the Trap Receivers tab.

4. Repeat 2 and 3 for each trap receiver to be deleted.
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CHAPTER 16

Managing Network Element System
Software and FTP Servers

• Adding an FTP or SFTP Server on page 477

• Modifying the Configuration for an FTP or SFTP Server on page 479

• Deleting an FTP or SFTP Server on page 480

• Manually Backing Up a Network Element Configuration Database on page 481

• Restoring a Configuration Database to a Network Element on page 482

• Upgrading System Software for a Network Element on page 484

• Restoring aDatabase to Factory Defaults on a BTI7800Network Element on page 487

Adding an FTP or SFTP Server

Use this procedure to add an FTP or SFTP server to the list of servers that PSM can use.

PSM tests the connectivity to the newly-added server and posts a status indicating

whether the server can be reached and whether the specified subdirectory can be used.

The PSM server installation includes a local (S)FTP server that is configured and used

by default for NE database backup and restore, and NE system software upgrades. The

local (S)FTP server is accessible using the following credentials:

• username: ftpadmin

• password: ftpadmin

Thedefault subdirectories created for databasebackups and software loads on the local

(S)FTP server are NeDbBackups and NeSoftware respectively. The paths are relative to

the FTP root directory, which, in the case of the local (S)FTP server, is /home/ftpadmin.

You can choose to use external (S)FTP servers. For the list of third party (S)FTP servers

that have been verifiedwithPSMand JuniperNetworks network elements, see theproNX

Service Manager Installation and Administration Guide.
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1. From themain menu choose Edit>FTP Servers.

2. On the FTP Servers tab, right-click Right-Click to Add a File Server, and then click Add

File Server.

3. In the File Server Configuration dialog, enter valid values in the IP Address, Port,

Username, Password, and Confirm Password fields. For an SFTP server, select SFTP

on the Protocol drop-downmenu.

The (S)FTP server connection is tested. If the server is unreachable, an Inactive

indication appears. If the server is reachable but the supplied password is incorrect,

an Invalid Credentials indication appears, and you will not be able to add the server.

4. Specify the directory you want to use as the subdirectory by typing in the directory

name or by browsing. The subdirectory path is relative to the (S)FTP root directory.

The directory must already exist.
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If the server is reachable and the password is correct but the directory is invalid, an

Invalid Directory indication appears, and youwill not be able to add the server. To add

the server, you must enter or browse to a valid directory, or leave this field blank

(indicating the FTP root directory).

5. ClickOK.

The (S)FTP server is added to the list on the FTP Servers tab. If there are no errors

when configuring the server, the Server Status should beActive and the Directory

Status should beValid.

NOTE: Youare allowed to add the server even if the server is unreachable.

6. Repeat 2 to 5 for each FTP server to be added.

Modifying the Configuration for an FTP or SFTP Server

1. From themain menu choose Edit>FTP Servers.

2. On the FTP Servers tab, right-click an FTP server, and then click Edit File Server.
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NOTE: The pre-installed server entries (<PSM server

host>:ftpadmin:NeDbBackupsand<PSMserverhost>:ftpadmin:NeSoftware)

cannot be edited. If you try to edit these entries, you will receive an error
and the changes do not take effect.

3. In the File Server Configuration dialog, modify settings as required, and then clickOK.

The modifications are applied and the File Server Configuration dialog closes.

4. Repeat 2 and 3 for each FTP server configuration to bemodified.

Deleting an FTP or SFTP Server

1. From themain menu choose Edit>FTP Servers.

2. On the FTP Servers tab, right-click an FTP server, and then click Delete File Server.

NOTE: The pre-installed server entries (<PSM server

host>:ftpadmin:NeDbBackupsand<PSMserverhost>:ftpadmin:NeSoftware)

cannot be deleted. If you try to delete these entries, you will receive an
error and the deletion does not take effect.

3. In the confirmation dialog, clickOK.
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The FTP server is removed from the list on the File Server Configuration tab.

4. Repeat 2 and 3 for each FTP server to be deleted.

Manually Backing Up a Network Element Configuration Database

Use this procedure to back up a network element configuration database.

The (S)FTP server must be set up and active prior to backing up an NE's database to it.

See “Adding an FTP or SFTP Server” on page 477 for information about setting up an

(S)FTP server.

PSM supports network element database backup for the following:

• BTI7800 Series network elements

• BTI7000 Series network elements

• BTI800 Series network elements (FTP only)

• BTI700 Series network elements (FTP only)

• MX Series and PTX Series routers (FTP only)

• QFX Series switches (FTP only)

NOTE: To protect network and server resources, limits are placed on the
numberofbackups thatcanbe runconcurrently.See “ManagingTaskStatus”
on page 537 for more details.

1. Right-click a network element (or selectmultiple NEs), and choose Backup&Restore

>NE DB Backup.

The NEDB Backup dialog is displayed.

2. Select whether you want to back up the database to Local or Remote storage.

The Local option is only available for selection if the NE supports local storage.

3. If you choose Remote storage, select an active FTP server from the pulldownmenu.

4. ClickOK.
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TheNE's database is backedup to local storage or to the configuredSFTP/FTP server.

Use the View >Server >Tasks command tomonitor the progress of the database

backup task. For some network elements, this might take 15 minutes or more to

complete.

NOTE: PSM-generated NE database backup related alarms are not
automatically cleared once the problem has been resolved. Youmust
clear PSM-generatedNE database backup alarmsmanually. Tomanually
clear a PSM-generated alarm, right click the alarm and choose Clear NMS

Generated Alarm. Once cleared, you cannot restore an alarm.

Restoring a Configuration Database to a Network Element

Use this procedure to restore a configuration database to a network element.

Prerequisites:

The (S)FTP server must be set up and active. See “Adding an FTP or SFTP Server” on

page 477 for information about setting up an (S)FTP server.

PSM supports network element database restore for the following:

• BTI7800 Series network elements

• BTI7000 Series network elements

• BTI800 Series network elements (FTP only)

• BTI700 Series network elements (FTP only)

• MX Series and PTX Series routers (FTP only)

• QFX Series switches (FTP only)

NOTE: To protect network and server resources, limits are placed on the
numberof restores that canbe runconcurrently. See “ManagingTaskStatus”
on page 537 for more details.

NOTE: For the BTI7000 Series network elements, PSM performs both the
Load/Invoke and Commit phases. The NE cannot be viewed between the
invokeand commit stages (to verify thedatabefore committing the restore).
To verify the data before restoring, use the proNX 900 to perform each of
the individual operations.

Copyright © 2019, Juniper Networks, Inc.482

proNX Service Manager User Guide



NOTE: For the MX Series and PTX Series routers and QFX Series switches,
PSM downloads the configuration to the router as the candidate version.
PSM does not perform the commit. You have to log in to the router CLI to
perform the commit.

1. Right-click a network element, and choose Backup & Restore >NE DB Restore.

The NEDB Restore dialog is displayed.

2. Select whether you want to restore the database from Local or Remote storage.

The Local option is only available for selection if the NE supports local storage.

3. If you choose Remote storage, select an active FTP server and subdirectory from the

pulldownmenu and click Browse to navigate to and select the backup file fromwhich

you want to restore the database.
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NOTE: You can only browse within the starting directory and its
subdirectories. The starting directory is the directory you specified when
adding the (S)FTP server.

The file you select appears in the Restore File field of the NEDB Restore dialog.

4. ClickOK.

Use the View >Server >Tasks command tomonitor the progress of the database

restore task. For some network elements, this might take 15 minutes or more to

complete.

NOTE: PSM-generated NE database backup related alarms are not
automatically cleared once the problem has been resolved. Youmust
clear PSM-generatedNE database backup alarmsmanually. Tomanually
clear a PSM-generated alarm, right click the alarm and choose Clear NMS

Generated Alarm. Once cleared, you cannot restore an alarm.

NOTE: If you are using inbandmanagement communications for PSM
through a BTI7000 Series NE, then you will not receive a response from
the NE indicating the successful completion of the database restore.

Upgrading SystemSoftware for a Network Element

Use this procedure to upgrade the system software for a network element.

The (S)FTP server must be selected, set up, and active prior to downloading system

software toanNE.See “AddinganFTPorSFTPServer” onpage477 for informationabout

setting up an (S)FTP server.

PSM supports network element software upgrade for the following:

• BTI7800 Series network elements

• BTI7000 Series network elements

• BTI800 Series network elements (FTP only)

• BTI700 Series network elements (FTP only)

NOTE: A software upgrade to a previous software version is not supported.

Copyright © 2019, Juniper Networks, Inc.484

proNX Service Manager User Guide



NOTE: To protect network and server resources, limits are placed on the
numberofupgrades thatcanbe runconcurrently.See“ManagingTaskStatus”
on page 537 for more details.

1. Right-click a network element in the Network tree view, and then click Software

Upgrade.

The Software Upgrade dialog is displayed.

Alternatively, select multiple NEs, right-click and choose Software Upgrade. In this

case the following dialog is displayed. If a combination ofmixedNE types are selected

then the Select Device pulldown contains the various NE types available for upgrade,

and youmust select a single NE type to upgrade.

NOTE: Exercise caution when upgradingmultiple NEs concurrently. This
feature has been provided for convenience and should only be used after
you have performed a limited rollout of the new software and resolved
any deployment issues.

2. In the Software Upgrade dialog, select an active FTP server from the pulldownmenu.
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3. ClickBrowse tonavigate toandselect the software version that youwant todownload.

For BTI7000 Series software, select the directory of the release. For BTI700 Series

and BTI800 Series software, select the compressed file with the correct device type

and extension.

NOTE: You can only browse within the starting directory and its
subdirectories. The starting directory is the directory you specified when
adding the (S)FTP server.

The version you selectedappears in theSoftware field of theSoftwareUpgradedialog.

4. For BTI7000 Series devices, select one or more check boxes as desired. Only valid

combinations are allowed to be selected. The general sequence is to check, load,

invoke, and then commit the upgrade. You can choose to perform all of this in one

step or in multiple steps at different times.

• Check - This selection verifies that the system is ready for the upgrade process, and

that the load files on the server are accessible.

• Load - This selection downloads the software images from the server to the SCP.

• Invoke - This selection installs the new load on all circuit packs in the system and

reboots each card in the system.
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NOTE: If you are using inbandmanagement communications for PSM
through a BTI7000Series NE, then youwill not receive a response from
the NE indicating success when performing the Invoke phase of a
software upgrade. In this case the upgrade process can be completed
by using the proNX 900.

• Commit - This selection completes the upgrade procedure, and can only be

performed after an Invoke has taken place, either in a previous step, or with Invoke

concurrently selected with Commit.

• Cancel - This selection cancels the upgrade procedure and rolls the system back

to the previous set of loads. It can only be selected after an Invoke has taken place

previously and prior to a Commit.

For BTI700 Series and BTI800 Series devices, select the desired check boxes:

• Load - This selection downloads the software image from the server.

• Commit - This selection activates the new image.

PSM attempts to validate the BTI700 Series file using the selected filename. If the

filename does not indicate a BTI700 Series-specific device, a warning is displayed.

5. ClickOK.

Use theTasks tab in themainwindowtomonitor theprogressof the softwareupgrade.

NOTE: PSM-generated NE software upgrade related alarms are not
automatically cleared once the problem has been resolved. Any
PSM-generatedNEsoftwareupgradealarmsthatoccurmustbemanually
cleared. Tomanually clear a PSM-generated alarm, right-click on the
alarm and choose Clear NMSGenerated Alarm. Once cleared, you cannot

restore an alarm.

Restoring a Database to Factory Defaults on a BTI7800Network Element

Use this procedure to restore the configuration database back to factory defaults on a

BTI7800 network element.

1. Right click a network element in the Network tree or in the Topology Map view and

select Node >Database >Factory Restore.

2. ClickOK in the confirmation dialog.

The factory database is restored on the selected network element.
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CHAPTER 17

Managing Reports

• Generating Alarms Reports on page 489

• Generating Ethernet Reports on page 493

• Generating Pseudowire Reports on page 494

• Generating Transport Reports on page 495

• Generating NE Logs Reports on page 496

• Generating Optical Reports on page 498

• Generating Inventory Reports on page 499

• Generating Task History Reports on page 501

• Changing the Report Generation Timeout on page 504

Generating Alarms Reports

PSM supports alarm report generation for the following:

• BTI7800 Series network elements

• BTI7000 Series network elements

• BTI800 Series network elements

• BTI700 Series network elements

• MX Series and PTX Series routers

• QFX Series switches

• Generating an Active Alarms Report on page 489

• Generating a Historical Alarms Report on page 490

Generating an Active Alarms Report

Use this procedure to generate an active alarms report in spreadsheet format, and save

it to the local drive.
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1. From themain menu, choose Tools >Reports >Alarms >Active.

2. Wait while the report generates. The bottom of the GUI shows "Requesting Report:"

followed by the selected report type.

NOTE: If the report fails to generate, see if “Changing the Report
Generation Timeout” on page 504 applies to your situation.

3. When the report has been generated, the tool automatically launches your web

browser and points it to the location of the report (report URL) on the PSM Server.

Log in using your PSM user name and password.

NOTE: The report is stored indefinitely on the server at the location
specifiedby the reportURL, and isaccessible fromanybrowser. Toprevent
unauthorized access to this possibly sensitive data, the report location is
password protected. If you have generated reports previously, your web
browsermight have cached your user name and password, andmight log
in automatically for you.

NOTE: Your browser might require you to explicitly verify and accept the
server certificate before you can have access to the report. This is normal
because communication between the browser and the server is through
HTTPS.

After logging in, a file download dialog box opens.

4. Open or save the report.

The following is an example of an Active Alarms report:

Generating a Historical Alarms Report

Use this procedure to generate a historical alarms report in spreadsheet format, and save

it to the local drive.
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1. From themain menu, choose Tools >Reports >Alarms >Historical.

The Historical Alarms Report dialog appears:

2. Specify the alarms you want to include in the report.

• Description Contains Include alarms with the specified text string in the alarm

description.

• Device Address StartsWith Include alarms raised by a node with the specified IP

address prefix.

• SourceContains Includealarmswith thespecified text string in thesourcedescription.

• Raised Time After Include alarms raised after the specified time.

• (Raised Time) Before Include alarms raised prior to the specfiied time.
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• Cleared Time After Include alarms cleared after the specified time.

• (Cleared Time) Before Include alarms cleared prior to the specified time.

• Severity Include alarms at the indicated alarm severity. If no severity is selected,

alarms at all severities are included.

• Service Affecting Include alarms that are service affecting, non-service affecting,

or either.

• Acknowledged Include alarms that are acknowledged, unacknowledged, or either.

• Assigned User Contains Include alarms with the specified text string in the user

assignment.

• SystemName Contains Include alarms with the specified text string in the system

name.

• Domain Name Contains Include alarms with the specified text string in the domain

name.

3. Click Run to generate the report based on the filters you specify.

4. Wait while the report generates. The bottom of the GUI shows "Requesting Report:"

followed by the selected report type.

NOTE: If the report fails to generate, see if “Changing the Report
Generation Timeout” on page 504 applies to your situation.

5. When the report has been generated, the tool automatically launches your web

browser and points it to the location of the report (report URL) on the PSM Server.

Log in using your PSM user name and password.

NOTE: The report is stored indefinitely on the server at the location
specifiedby the reportURL, and isaccessible fromanybrowser. Toprevent
unauthorized access to this possibly sensitive data, the report location is
password protected. If you have generated reports previously, your web
browsermight have cached your user name and password, andmight log
in automatically for you.

NOTE: Your browser might require you to explicitly verify and accept the
server certificate before you can have access to the report. This is normal
because communication between the browser and the server is through
HTTPS.

After logging in, a file download dialog box opens.

6. Open or save the report.
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The following is an example of a Historical Alarms report:

Generating Ethernet Reports

Ethernet report generation is supported for theBTI7000Series, BTI700Series (excluding

BTI718E), and BTI800 Series devices.

The proNX Service Manager allows the user to generate Ethernet reports in spreadsheet

format, and save them to their local drive.

1. From themain menu, choose Tools >Reports >Ethernet and select either Network

Elements or Services.

2. Wait while the report generates. The bottom of the GUI shows "Requesting Report:"

followed by the selected report type.

NOTE: If the report fails to generate, see if “Changing the Report
Generation Timeout” on page 504 applies to your situation.

3. When the report has been generated, the tool automatically launches your web

browser and points it to the location of the report (report URL) on the PSM Server.

Log in using your PSM user name and password.

NOTE: The report is stored indefinitely on the server at the location
specifiedby the reportURL, and isaccessible fromanybrowser. Toprevent
unauthorized access to this possibly sensitive data, the report location is
password protected. If you have generated reports previously, your web
browsermight have cached your user name and password, andmight log
in automatically for you.
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NOTE: Your browser might require you to explicitly verify and accept the
server certificate before you can have access to the report. This is normal
because communication between the browser and the server is through
HTTPS.

After logging in, a file download dialog box opens.

4. Open or save the report.

The following is an example of an Ethernet Services report.

Generating Pseudowire Reports

Pseudowire report generation is supported for the BTI810 devices.

TheproNXServiceManagerallows theuser togeneratepseudowire reports in spreadsheet

format, and save them to the local drive.

1. From themain menu, choose Tools >Reports >Ethernet >Pseudowire.

2. Wait while the report generates. The bottom of the GUI shows "Requesting Report:"

followed by the selected report type.

NOTE: If the report fails to generate, see if “Changing the Report
Generation Timeout” on page 504 applies to your situation.

3. When the report has been generated, the tool automatically launches your web

browser and points it to the location of the report (report URL) on the PSM Server.

Log in using your PSM user name and password.

NOTE: The report is stored indefinitely on the server at the location
specifiedby the reportURL, and isaccessible fromanybrowser. Toprevent
unauthorized access to this possibly sensitive data, the report location is
password protected. If you have generated reports previously, your web
browsermight have cached your user name and password, andmight log
in automatically for you.
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NOTE: Your browser might require you to explicitly verify and accept the
server certificate before you can have access to the report. This is normal
because communication between the browser and the server is through
HTTPS.

After logging in, a file download dialog box opens.

4. Open or save the report.

The following is an example of a Pseudowire report.

Generating Transport Reports

Transport report generation is supported for transport services on a BTI7800 network

and for transport services with BTI7800, MX Series, PTX Series, or QFX Series endpoints

over a BTI7000 optical network.

The proNXServiceManager allows the user to generate transport reports in spreadsheet

format, and save them to their local drive. There are four transport report types available:

Transport Services, Transport Services per Span, Transport Topology, and Transport

Cross-Connects.

1. From themain menu, choose Tools >Reports >Transport and one of Services,

Cross-Connects, Services per Span, Topology.

2. Wait while the report generates. The bottom of the GUI shows "Requesting Report:"

followed by the selected report type.

NOTE: If the report fails to generate, see if “Changing the Report
Generation Timeout” on page 504 applies to your situation.

3. When the report has been generated, the tool automatically launches your web

browser and points it to the location of the report (report URL) on the PSM Server.

Log in using your PSM user name and password.
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NOTE: The report is stored indefinitely on the server at the location
specifiedby the reportURL, and isaccessible fromanybrowser. Toprevent
unauthorized access to this possibly sensitive data, the report location is
password protected. If you have generated reports previously, your web
browsermight have cached your user name and password, andmight log
in automatically for you.

NOTE: Your browser might require you to explicitly verify and accept the
server certificate before you can have access to the report. This is normal
because communication between the browser and the server is through
HTTPS.

After logging in, a file download dialog box opens.

4. Open or save the report.

The following is an example of a Transport Services report.

Generating NE Logs Reports

The proNX Service Manager allows the user to generate NE logs reports in spreadsheet

format, and save them to their local drive.

PSM supports NE log report generation for the following:

• BTI7800 Series network elements

• BTI7000 Series network elements

• MX Series and PTX Series routers

• QFX Series switches
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1. From themain menu, choose Tools>Reports>NE Logs.

The Network Elements Logs Report window is displayed.

2. Using theoptions in theNetworkElements LogsReportwindow, specify theattributes

of the report. The bottom of the GUI shows "Requesting Report:" followed by the

selected report type.

3. Click Run.

4. Wait while the report generates. The bottom of the GUI shows "Requesting Report:"

followed by the selected report type.

NOTE: If the report fails to generate, see if “Changing the Report
Generation Timeout” on page 504 applies to your situation.
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5. When the report has been generated, the tool automatically launches your web

browser and points it to the location of the report (report URL) on the PSM Server.

Log in using your PSM Client user name and password.

NOTE: The report is stored indefinitely on the server at the location
specifiedby the reportURL, and isaccessible fromanybrowser. Toprevent
unauthorized access to this possibly sensitive data, the report location is
password protected. If you have generated reports previously, your web
browsermight have cached your user name and password, andmight log
in automatically for you.

NOTE: Your browser might require you to explicitly verify and accept the
server certificate before you can have access to the report. This is normal
because communication between the browser and the server is through
HTTPS.

6. A file downloaddialog box opens asking "Do youwant to open or save this file?". Click

Save as.

7. Choose where to save the report on your local drive, then click Save to download the

file.

The following image is an example of an NE Logs report file.

Generating Optical Reports

Optical reportgeneration is supported for theBTI7000SeriesandBTI7800Seriesnetwork

elements.

The proNX Service Manager allows the user to generate optical reports in spreadsheet

format, and save them to their local drive. There are four optical report types available:

Optical Services, Optical Services per Span, Optical Topology, and Optical

Cross-Connects.
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1. From themain menu, choose Tools >Reports >Optical and one of Services, Topology,

Cross-Connects, Services per Span.

2. Wait while the report generates. The bottom of the GUI shows "Requesting Report:"

followed by the selected report type.

NOTE: If the report fails to generate, see if “Changing the Report
Generation Timeout” on page 504 applies to your situation.

3. When the report has been generated, the tool automatically launches your web

browser and points it to the location of the report (report URL) on the PSM Server.

Log in using your PSM user name and password.

NOTE: The report is stored indefinitely on the server at the location
specifiedby the reportURL, and isaccessible fromanybrowser. Toprevent
unauthorized access to this possibly sensitive data, the report location is
password protected. If you have generated reports previously, your web
browsermight have cached your user name and password, andmight log
in automatically for you.

NOTE: Your browser might require you to explicitly verify and accept the
server certificate before you can have access to the report. This is normal
because communication between the browser and the server is through
HTTPS.

After logging in, a file download dialog box opens.

4. Open or save the report.

The following is an example of an Optical Topology report.

Generating Inventory Reports

The proNXServiceManager allows the user to generate inventory reports in spreadsheet

format, and save them to their local drive. The inventory report contains the same

information as in the network element inventory view (see “Viewing Network Element

Inventory Information” on page 97).
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PSM supports inventory report generation for the following:

• BTI7800 Series network elements

• BTI7000 Series network elements

• BTI800 Series network elements

• BTI700 Series network elements

• MX Series and PTX Series routers

• QFX Series switches

1. From themain menu, choose Tools>Reports>Inventory.

2. Wait while the report generates. The bottom of the GUI shows "Requesting Report:"

followed by the selected report type.

NOTE: If the report fails to generate, see if “Changing the Report
Generation Timeout” on page 504 applies to your situation.

3. When the report has been generated, the tool automatically launches your web

browser and points it to the location of the report (report URL) on the PSM Server.

Log in using your PSM user name and password.

NOTE: The report is stored indefinitely on the server at the location
specifiedby the reportURL, and isaccessible fromanybrowser. Toprevent
unauthorized access to this possibly sensitive data, the report location is
password protected. If you have generated reports previously, your web
browsermight have cached your user name and password, andmight log
in automatically for you.

NOTE: Your browser might require you to explicitly verify and accept the
server certificate before you can have access to the report. This is normal
because communication between the browser and the server is through
HTTPS.

After logging in, a file download dialog box opens.

4. Open or save the report.

The following is an example of an Inventory report.
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Generating Task History Reports

TheproNXServiceManagerallows theuser togenerate taskhistory reports in spreadsheet

format, and save them to their local drive. The task history shows a record of tasks

performed by users as well as scheduled tasks by the system.

PSM supports task history report generation for the following:

• BTI7800 Series network elements

• BTI7000 Series network elements

• BTI800 Series network elements

• BTI700 Series network elements

1. From themain menu, choose Tools >Reports >Task History.

The Task History Reportwindow is displayed.

2. Select the task history filtering criteria as follows:
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• Network Element: Specify the IP address or IP address prefix of the network

element(s) that you want to be included in the task history report. The address is

in standard dotted decimal notation. By specifying a prefix, you can include a set

of prefixes. For example, 10.1. returns all network elementswithin the address range

10.1.0.0 to 10.1.255.255. A 10.1.210.71 address returns the 10.1.210.71 network element

as well as network elements in the address range 10.1.210.710 to 10.1.210.719.

• Task Type: Specify the task type of the tasks you want to be included in the task

history report. When you type in the box, a drop-downmenu appears that shows

the task types that match what you have typed so far. Thematches are based on

a simple unanchoredpatternmatch of the typed string against the set of supported

PSM task types. In other words, all matching task types contain the typed string.

You can choose a specific task type from the drop-downmenu, or keep typing to

narrow down your selections further, or simply keep the string that you have typed

so far to include all current task types in the drop-downmenu.

• Username: Specify the user youwant to be included in the task history report.When

you type in the box, a drop-downmenu appears that shows the user names that

matchwhat you have typed so far. Thematches are based on a simple unanchored

pattern match of the typed string against the set of PSM users. In other words, all

matching user names contain the typed string. You can choose a specific user from

the drop-downmenu, or keep typing to narrow down your selections further, or

simply keep the string that you have typed so far to include all current user names

in the drop-downmenu.

• Start Time: Specify the start time of the report period.

• End Time: Specify the end time of the report period.

NOTE: If you leaveanyboxblank, thenno filter isapplied for theassociated
criterion.

3. Click Run.

4. Wait while the report generates. The bottom of the GUI shows "Requesting Report:"

followed by the selected report type.

NOTE: If the report fails to generate, see if “Changing the Report
Generation Timeout” on page 504 applies to your situation.

5. When the report has been generated, the tool automatically launches your web

browser and points it to the location of the report (report URL) on the PSM Server.

Log in using your PSM user name and password.
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NOTE: The report is stored indefinitely on the server at the location
specifiedby the reportURL, and isaccessible fromanybrowser. Toprevent
unauthorized access to this possibly sensitive data, the report location is
password protected. If you have generated reports previously, your web
browsermight have cached your user name and password, andmight log
in automatically for you.

NOTE: Your browser might require you to explicitly verify and accept the
server certificate before you can have access to the report. This is normal
because communication between the browser and the server is through
HTTPS.

After logging in, a file download dialog box opens.

6. Open or save the report.

The following is an example of a Task History report.
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Changing the Report Generation Timeout

Use this procedure to change the time that the PSM client waits for the PSM server to

finish generating a report.

Report generation might require the PSM server to collect information from all network

elements in the network. This might take some time, especially In slow networks. If the

PSM client times out while waiting for report generation to complete, you can adjust the

PSM client timeout value to bemore appropriate for your network.

You do not need to change the timeout value if report generationworks for your network.

When report generation fails due to a timeout, youwill see an error icon in the lower right

corner of the PSM client window. If you click on the error icon, you will see the following

generic error indicating PSM client-server communication problems:

Figure 93: PSMClient Communication Timeout

The parameter that dictates how long the PSM client waits for the report is found on the

PSM client machine.

1. Locate the ems.properties file in the<PSM_client_installation_folder>/psmclient folder.

2. Open the ems.properties file using a text editing application such asWordPad and

change theems.client.reports.socket.timeoutparameter. Theunitsare inmilliseconds.

For example, this sets the timeout to 900000milliseconds or 15 minutes:

ems.client.reports.socket.timeout = 900000

NOTE: If you installed the PSM client using the supplied installer, you
might need to edit this file as an administrator. InWindows 10, click on
the Startmenu and go to All apps>Windows Accessories and scroll down

toWordPad, right-click and selectMore>Run as administrator. Then open

the ems.properties file fromwithin theWordPad application.

3. Save and close the ems.properties file.
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NOTE: Theupdatedsetting takeseffect thenext timeyou launch thePSM
client.

4. Close and relaunch the PSM client.
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CHAPTER 18

Performance Monitoring

• Viewing Current Port, Interface, and Channel PMs on page 507

• Viewing Real-time Optical Service PMs on page 507

• Viewing Real-time Transport Service PMs on page 515

• Viewing Real-time Ethernet PMs and SLAs on page 520

• Viewing Real-time Pseudowire PMs on page 528

• Collecting and Viewing Historical PMs on page 531

Viewing Current Port, Interface, and Channel PMs

To view current port, interface, and channel PMs, follow the applicable procedures in the

Nodal Management chapter:

• Viewing Port PMs on a BTI7000 Series Network Element on page 166

• Viewing Interface PMs on a UFM on page 215

• Viewing Port PMs on a ROADM Element on page 238

• Viewing OMS PMs on a ROADM Element on page 239

• Viewing OSC PMs on a ROADM Element on page 240

• Viewing Optical Channel PMs on a ROADM Element on page 240

• Viewing Port PMs on a 96-Channel Amplifier on page 251

• Viewing Interface PMs on an MX Series or PTX Series Router or QFX Series Switch on

page 263

Viewing Real-time Optical Service PMs

Use this procedure to enable and view real-time PMs for optical services on BTI7000

Series and BTI7800Series network elements. The PMs are displayed in both textual and

graphical formats.

PSM supports the following BTI7000 Series optical service PMs:
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Table 55: BTI7000 Series Optical Service PMs

Service Channel PMsOSC PMsPort PMsDescription

NoNoYesInstantaneous optical power received

NoNoYesMinimum optical power received

NoNoYesMaximum optical power received

NoNoYesAverage optical power received

NoNoYesOptical power loss received

NoNoYesStandard deviation power received

NoNoYesInstantaneous optical power transmitted

NoNoYesMinimum optical power transmitted

NoNoYesMaximum optical power transmitted

NoNoYesAverage optical power transmitted

NoNoYesOptical power loss transmitted

NoNoYesStandard deviation power transmitted

NoYesNoOSC optical power received

NoYesNoOSC optical power transmitted

NoYesNoCode violations

NoYesNoErrored seconds

NoYesNoOSC optical back-reflected power

NoYesNoSeverely errored framing seconds

NoYesNoSeverely errored seconds

NoYesNoUnavailable seconds

YesNoNoInstantaneous channel power received

YesNoNoMinimum channel power received

YesNoNoMaximum channel power received

YesNoNoInstantaneous channel power transmitted
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Table 55: BTI7000 Series Optical Service PMs (continued)

Service Channel PMsOSC PMsPort PMsDescription

YesNoNoMinimum channel power transmitted

YesNoNoMaximum channel power transmitted

PSM supports the following BTI7800 Series optical PMs:

Table 56: BTI7800 Series Optical Service PMs

Service Channel PMsOSC PMsOMS PMsPort PMsDescription

NoNoYesYesInstantaneous optical power received

NoNoYesYesMinimum optical power received

NoNoYesYesMaximum optical power received

NoNoYesYesAverage optical power received

NoNoNoYesStandard deviation power received

NoNoYesYesInstantaneousopticalpower transmitted

NoNoYesYesMinimum optical power transmitted

NoNoYesYesMaximum optical power transmitted

NoNoYesYesAverage optical power transmitted

NoNoNoYesStandard deviation power transmitted

NoYesNoNoOSC optical power received

NoYesNoNoOSC optical power transmitted

YesNoNoNoInstantaneous channel power received

YesNoNoNoMinimum channel power received

YesNoNoNoMaximum channel power received

YesNoNoNoInstantaneous channel power
transmitted

YesNoNoNoMinimum channel power transmitted

YesNoNoNoMaximum channel power transmitted
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Table 56: BTI7800 Series Optical Service PMs (continued)

Service Channel PMsOSC PMsOMS PMsPort PMsDescription

NoNoYesNoInstantaneous optical back reflection
ratio

NoNoYesNoMinimum optical back reflection ratio

NoNoYesNoMaximum optical back reflection ratio

NoNoYesNoAverage optical back reflection ratio

NoNoYesNoStandard deviation optical back
reflection ratio

1. To enable real-time PMs, right-click on an optical service in the tree view or in the

background of an optical service topology view, and choose one of the following:

• Enable Realtime PMs>Port

• Enable Realtime PMs>OMS for BTI7800 Series

• Enable Realtime PMs>OSC

• Enable Realtime PMs>Service Channel

• Enable Realtime PMs>All Channels

Real-time PM collection for the optical service is started, and a PM data widget title

bar is displayed for each PM collection point. Additionally, a graphical view displaying

the instantaneous power along with the detected power range is provided at the

bottom of the screen.

NOTE: When you enable PMs on a stranded service1, youmight see PM

data widgets that do not have lines connecting them to the network
elements. This behavior is normal.

NOTE:
1Aservice is stranded if oneormore segments in thepathbetween

the service endpoints has not been configured.

2. Click the PM data widget title bar to show or hide the PM data.
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Figure 94: Real-time PMs Port View

Figure 95: Real-time PMs OSC View
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Figure 96: Real-time PMs Service Channel View

Figure 97: Real-time PMs All Channels View

3. To undock the graph to its own window, right-click on the tab in the graph window

and select Undock.

The graph appears in a window that you can reposition and resize.
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Figure 98: Real-time PMs Port View Graph

Figure 99: Real-time PMs OSC View Graph

Figure 100: Real-time PMs Service Channel View Graph
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Figure 101: Real-time PMs All Channels View Graph

NOTE: The information displayed on the domain (horizontal) axis of the
real-time PMs all channels graph is selectable. See “Setting Optical
GraphingOptions”onpage278 fordetails onhowtoselectwhat is shown.

4. To change the range (vertical) scale of the graphs, highlight the desired area by

left-clicking and dragging the mouse to highlight the area of focus, and release.

Repeat until the desired magnification is achieved.
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NOTE: You can also change the scale by right-clicking on a graph, and
selecting Zoom In or ZoomOut.

5. To turn off real-time PMs, right-click in the optical services topology window and

choose Disable Realtime PMs.

Viewing Real-time Transport Service PMs

Use this procedure to enable and view real-timePMs for transport services on aBTI7800

network and transport services with BTI7800, MX Series, PTX Series, or QFX Series

endpoints connected across a BTI7000 optical network. The PMs are displayed in both

textual and graphical formats.

PSM supports the following BTI7800 transport service PMs:

Table 57: BTI7800 Series Transport Service PMs

DetailedSimpleDescription

Optical and physical layer PMs

YesYesOptical power received

YesNoMinimum optical power received

YesNoMaximum optical power received

YesNoAverage optical power received

YesYesOptical power transmitted

YesNoMinimum optical power transmitted

YesNoMaximum optical power transmitted

YesNoAverage optical power transmitted

ODUPMs

YesYesODU errored blocks

YesYesODU background block errors

YesYesODU errored seconds

YesYesODU severely errored seconds

YesYesODU bit error ratio
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Table 57: BTI7800 Series Transport Service PMs (continued)

DetailedSimpleDescription

YesNoODUminimum bit error ratio

YesNoODUmaximum bit error ratio

YesNoODU average bit error ratio

OTUPMs

YesYesFEC bit error ratio

YesNoFECminimum bit error ratio

YesNoFECmaximum bit error ratio

YesNoFEC average bit error ratio

YesYesOTU errored blocks

YesYesOTU background block errors

YesYesOTU errored seconds

YesYesOTU severely errored seconds

YesYesOTU out of frame seconds

YesYesOTU bit error ratio

YesNoOTUminimum bit error ratio

YesNoOTUmaximum bit error ratio

YesNoOTU average bit error ratio

Ethernet PMs

YesYesOctets received

YesNoOctets OK received

YesNoOctets OK transmitted

YesYesPackets received

YesYesPackets transmitted

YesNoPackets OK received
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Table 57: BTI7800 Series Transport Service PMs (continued)

DetailedSimpleDescription

YesNoPackets OK transmitted

YesNoBroadcast packets received

YesNoBroadcast packets transmitted

YesNoMulticast packets received

YesNoMulticast packets transmitted

Fibre Channel PMs

YesYesOptical power transmitted

YesYesOptical power received

The MX Series and PTX Series routers and QFX Series switches support the following

Simple PMs: optical power transmit (current/average/minimum/maximum) and optical

power receive (current/average/minimum/maximum). For the list of Detailed PMs

supported on an MX Series or PTX Series router or QFX Series switch, see “PM Counters

for Optical Interfaces on MX Series and PTX Series Routers and QFX Series Switches”

on page 576.

1. To enable real-time PMs, right-click a transport service in the tree view or in the

background of a transport service topology view, and choose one of the following:

• Enable Realtime PMs >Simple

• Enable Realtime PMs >Detailed

Real-time PM collection for the transport service is started, and a PM data widget

title bar is displayed in the main window for each PM collection point. Additionally, a

graphical view is displayed in the bottomwindow.

NOTE: When you enable PMs on a stranded service1, youmight see PM

data widgets that do not have lines connecting them to the network
elements. This behavior is normal.

NOTE:
1Aservice is stranded if oneormore segments in thepathbetween

the service endpoints has not been configured.

2. Click the PM data widget title bar to show or hide the PM data.
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Figure 102: Real-time PMs Simple View

3. To undock the graph to its own window, right-click on the tab in the graph window

and select Undock.

The graph appears in a window that you can reposition and resize.
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Figure 103: Real-time PMs Simple View Graph

4. To change the scale of the graphs, highlight the desired area by left-clicking and

dragging the mouse to highlight the area of focus, and release.

Repeat until the desired magnification is achieved.
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NOTE: You can also change the scale by right-clicking on a graph, and
selecting Zoom In or ZoomOut.

5. To turn off real-time PMs, right-click in the optical services topology window and

choose Disable Realtime PMs.

Viewing Real-time Ethernet PMs and SLAs

Use this procedure to enable and view real-time Ethernet PMs and SLAs on BTI7000

Series, BTI700 Series, and BTI800 Series network elements.

PSM supports the following Layer 2 Ethernet PMs for UNIs:

Table 58: BTI7000 Series PMs

Bandwidth UtilizationPort UtilizationSimpleDetailedCounter

--YesYesTFRCRX - Received Packets

--YesYesTFRCTX - Transmitted Packets

-Yes-YesTBYCRX - Received Byte Count

-Yes-YesTBYCTX - Transmitted Byte Count

---YesFRDR - Discarded Packets

---YesBCST - Broadcast Packets

---YesMCST - Multicast Packets
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Table 58: BTI7000 Series PMs (continued)

Bandwidth UtilizationPort UtilizationSimpleDetailedCounter

Per bandwidth profile, either at
the interface or for each class
map

---Bandwidth Utilization

Table 59: BTI700 Series PMs

Bandwidth UtilizationPort UtilizationSimpleDetailedCounter

--YesYesRxPkts - Received Packets

--YesYesTxPkts - Transmitted Packets

-Yes-YesRxOctets - Received Octets

-Yes-YesTxOctets - Transmitted Octets

---YesRxUnicastPkts -ReceivedUnicastPackets

---YesTxUnicastPkts - Transmitted Unicast
Packets

---YesRxMulticastPkts - Received Multicast
Packets

---YesTxMulticastPkts - Transmitted Multicast
Packets

---YesRxBroadcastPkts - Received Broadcast
Packets

---YesTxBroadcastPkts - TransmittedBroadcast
Packets

---YesLast5MinsRxPkts - Last 5 minutes
(Received) Packets

---YesLast5MinsTxPkts - Last 5 minutes
(Transmitted) Packets

---YesLast5MinsRxUtilizationRate - Last 5
minutes (Received) Utilization

---YesLast5MinsTxUtilizationRate - Last 5
minutes (Transmitted) Utilization

---YesRxDiscard - Received Discard Packets

---YesDropEvent - Drop Events
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Table 60: BTI800 Series PMs

Bandwidth UtilizationPort UtilizationSimpleDetailedCounter

--YesYesRxPkts - Received Packets

--YesYesTxPkts - Transmitted Packets

-Yes-YesRxOctets - Received Octets

-Yes-YesTxOctets - Transmitted Octets

---YesRxUnicastPkts -ReceivedUnicastPackets

---YesTxUnicastPkts - Transmitted Unicast
Packets

---YesRxMulticastPkts - Received Multicast
Packets

---YesTxMulticastPkts - Transmitted Multicast
Packets

---YesRxBroadcastPkts - Received Broadcast
Packets

---YesTxBroadcastPkts - TransmittedBroadcast
Packets

PSM supports the following SLAs for UNIs:

Table 61: BTI7000 Series, BTI700 Series, BTI800 Series SLAs

BTI800 SeriesBTI700 SeriesBTI7000 Series

YesYes1

NOTE: 1TheBTI718E
reports framecounts
instead of ratios.

YesNearEndFrameLoss - Near End Frame Loss Ratio

YesYes¹YesFarEndFrameLoss - Far End Frame Loss Ratio

YesYesYes2WayDelayMinimum - MinimumDelay

YesYesYes2WayDelayMaximum - MaximumDelay

YesYesYes2WayDelayAverage - Average Delay

YesYesYes2WayDelayVariationMinimum-MinimumDelayVariation

YesYesYes2WayDelayVariationMaximum - MaximumDelay
Variation
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Table 61: BTI7000 Series, BTI700 Series, BTI800 Series SLAs (continued)

BTI800 SeriesBTI700 SeriesBTI7000 Series

YesYesYes2WayDelayVariationAverage - Average Delay Variation

1. To enable real-time PMs or SLAs, right-click on an Ethernet service in the tree view or

in an Ethernet topology view, and choose one of the following:

• Enable realtime PMs>Detailed

• Enable realtime PMs>Simple

• Enable realtime PMs>SLA

• Enable realtime PMs>Port Utilization

• Enable realtime PMs>Bandwidth Utilization

Real-timePM/SLA collection for the Ethernet service is started, and for each PM/SLA

collectionpoint in theservice, aPMdatawidget isdisplayedwith thecurrentPMs/SLAs

for that collection point (the statistics displayed for a given collection point are the

total statistics for that point, and not just the totals for the selected service).

Additionally, a graphical view is provided at the bottom of the screen.

NOTE: ForSLAPMs,anSLApairneeds tohavebeencreatedontheservice
view and applied.

2. Click the PM data widget title bar to show or hide the PM data.

PM/SLA absolute values (and their change from the previous collection) are shown.

Figure 104: Real-time PMs Detailed View
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Figure 105: Real-time PMs Simple View

Figure 106: Real-time PMs SLA View

Figure 107: Real-time PMs Port Utilization View
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Figure 108: Real-time PMs Bandwidth Utilization View

3. To expand the graphical view to full screen, right-click on the graph window title bar

and selectMaximizeWindow.

Figure 109: Real-time PMs Detailed View Graph

Figure 110: Real-time PMs Simple View Graph
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Figure 111: Real-time SLAs View Graph

Figure 112: Real-time PMs Port Utilization View Graph
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Figure 113: Real-time PMs Bandwidth Utilization Graph

4. To change the scale of the graphs, highlight the desired area by left-clicking and

dragging themouse to highlight the area of focus, and release. The scale for both the

domain (horizontal) axis and the range (vertical) axis can be changed.

Repeat until the desired magnification is achieved.
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NOTE: You can also change the scales by right-clicking on a graph, and
selecting Zoom In>Range Axis, ZoomOut>Range Axis, Zoom In>Domain

Axis, andZoomOut>DomainAxis. This changes the respectivescaleswhile

keeping the center of the range and/or domain as the area of focus.

5. To turn off real-time PMs, right-click in the Ethernet topology window and choose

Disable Realtime PMs.

Viewing Real-time Pseudowire PMs

Use this procedure to enable and view real-time PMs for pseudowire services on BTI800

Series network elements. The PMs are displayed in both textual and graphical formats.

PSM supports the following PMs for the pseudowire service:

SATOP PMsSDH PMsSONET PMsE1 PMsT1 PMs

SATOP Transmitted Byte
Count (Total)

Code Violations -
Regenerator Section

Code Violations - LineErrored SecondsCode
Violations -
Line

SATOP Received Byte
Count (Total)

Errored Seconds -
Regenerator Section

Errored Seconds - LineSeverely Errored SecondsErrored
Seconds -
Line

SATOP Byte Loss (Total)Severely Errored Seconds
- Regenerator Section

Severely Errored Seconds
- Line

Background Block Error
count

Severely
Errored
Seconds -
Line
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SATOP PMsSDH PMsSONET PMsE1 PMsT1 PMs

Unavailable Seconds -
Regenerator Section

Unavailable Seconds -
Line

Unavailable SecondsCode
Violations -
Path

Code Violations -
Multiplex Section

Code Violations - PathErrored Second RatioErrored
Seconds -
Path

Errored Seconds -
Multiplex Section

Errored Seconds - PathSeverely Errored Second
Ratio

Severely
Errored
Seconds -
Path

Severely Errored Seconds
- Multiplex Section

Severely Errored Seconds
- Path

Background Block Error
Ratio

Severely
Errored
Frame
Seconds -
Path

Unavailable Seconds -
Multiplex Section

Unavailable Seconds -
Path

Unavailable
Seconds -
Path

Code Violations - VC4
(AU4mode only)

Code Violations - Section

Errored Seconds - VC4
(AU4mode only)

ErroredSeconds -Section

Severely Errored Seconds
- VC4 (AU4mode only)

Severely Errored Seconds
- Section

Unavailable Seconds -
VC4 (AU4mode only)

Severely Errored Frame
Seconds - Section

Code Violations - VC3
(AU3mode only)

Code Violations - VT

Errored Seconds - VC3
(AU3mode only)

Errored Seconds - VT

Severely Errored Seconds
- VC3 (AU3mode only)

Severely Errored Seconds
- VT

Unavailable Seconds -
VC3 (AU3mode only)

UnavailableSeconds -VT

Code Violations - PathProtection Switch Count

Errored Seconds - Path
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SATOP PMsSDH PMsSONET PMsE1 PMsT1 PMs

Severely Errored Seconds
- Path

Unavailable Seconds -
Path

Protection Switch Count

1. To enable real-time PMs, right-click on a pseudowire service in the tree view or in the

background of a pseudowire service topology view, and select Enable Realtime PMs

>Pseudowire

Real-time PM collection for the pseudowire service is started, and a PM data widget

title bar is displayed for each PM collection point. Additionally, a graphical view

displaying the PMs pops up on the screen.

2. Click the PM data widget title bar to show or hide the PM data.

Figure 114: Real-time PMs
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3. To change the domain (horizontal) scale of the graphs, highlight the desired area by

left-clicking and dragging the mouse to highlight the area of focus, and release.

Repeat until the desired magnification is achieved.

NOTE: You can also change the scale by right-clicking on a graph, and
selecting Zoom In>Domain Axis or ZoomOut>Domain Axis. This changes

the horizontal scale while keeping the center of the range as the area of
focus.

4. To turn off real-time PMs, right-click the background in the pseudowire services

topology window and choose Disable Realtime PMs.

Collecting and Viewing Historical PMs

Use this procedure to collect andviewhistorical PMs forBTI7000Series, BTI7800Series,

BTI800 Series, and BTI718E network elements, and supported interfaces on MX Series

and PTX Series routers and QFX Series switches. See “Nodal Management for Juniper

Networks Routers and Switches” on page 257 for the list of supported interfaces.

Prerequisites:
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• For scheduled collections, ensure the scheduled historical PM retrieval capability is

enabled and the retrieval schedule is set up. For information on how to do this, see the

proNX Service Manager Installation and Administration Guide. By default, scheduled

historical PM collection is disabled.

NOTE: WhenusingPSMtocollecthistoricalPMsfromBTI800Seriesnetwork
elements, youmust perform additional steps on the network element itself.
See “Configuring Historical PM Collection on BTI800 Series Network
Elements” on page 558 for information.

Historical PMs are PMs that are collected and binned (aggregated over a measurement

interval, timestamped, and discretely stored) by the network element.

You can use PSM to retrieve these historical PMs on demand and/or on a regular,

pre-definedschedule.Whenyouenable scheduledhistoricalPMcollection, PSMretrieves

historical PMs every 12 hours by default, which allows you time to correct any retrieval

failures for the 1-day bin while minimizing unnecessary processing.

PSM stores these collected PMs in a database for 30 days andmakes them available

for viewing. PM data points older than 30 days are purged from the database.

Both 15-minuteand 1-daybinsarecollected.PMpoints in 15-minutebinsare timestamped

on the hour and at every 15 minutes thereafter. PM points for the 1-day bin are

timestamped at midnight (local time of the PSM Client).

For the list of historical PMs that PSM collects for BTI7000 Series, BTI800 Series, and

BTI718E network elements andMX Series and PTX Series routers, see “PM Counters” on

page 560. For information on BTI7800 Series historical PMs, see the BTI7800 Series

documentation.

1. Retrieve historical PMs from the NE.

This is performed automatically based on the collection schedule (default every 12

hours). Optionally, you can direct PSM to retrieve historical PMs on demand by

right-clicking a network element in the Network tree or in the TopologyMap view and

selecting Retrieve Historical PMs. If you do this, youmust wait for the retrieval task to

complete before proceeding to the next step.

NOTE: It is recommended that you always run scheduled collections.
Depending solely on on-demand PM retrieval will limit the collected data
to what is stored on the NEs at the time of the on-demand retrievals.

2. From themainmenu, choose View>Historical PMs, or click on theHistorical PMs icon

.

The Historical PMs window appears:

Copyright © 2019, Juniper Networks, Inc.532

proNX Service Manager User Guide



3. Expand theHistorical PMs tree and select thePMs youwant to display. You can select

PM points frommore than one network element.

NOTE: You can select which PMs youwant to view but you cannot select
which historical PMs youwantPSMto retrieve. PSM retrieves all historical
PMs from all discovered NEs.

Discovered and reachable network elements are shown in black. Discovered and

unreachable network elements are shown in red. Undiscovered network elements are

shown in grey.

NOTE: This list might contain network elements (in grey) that no longer
appear in themain Topology view. This can occur if the network elements
are removed from the Topology view, but still have historical PM data
associated with them.
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NOTE: When a port is reconfigured (e.g. with a different protocol), you
will see PM points in the Historical PMs tree for both the old and the new
protocol. This is normal behavior. PSM stores historical PM data for 30
days, at which time the data for the old protocol is purged.

4. Select the time range you want to view by using the drop-downmenus in the

Date-Time Selection pane.

5. Click Plot to plot the graph.

The data is plotted and displayed in the Chart pane.

NOTE: In the likely event that the From: and To: times do not fall on

monitoring period boundaries at the NE, the time of the first and last
collections shownmight not match exactly the start and end times
requested.

6. Tozoom inon thegraph, click anddrag theportion youwant to zoom,and then release.
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The zoomed portion of the graph is displayed.

7. To select other PM counters to display in the same date and time range, go back to

step 3. Remember to deselect the PM counters from the current run first.

Alternatively, you can close and re-open the Historical PMswindow, but youwill need

to set the date and time range again.
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CHAPTER 19

Troubleshooting

• Managing Task Status on page 537

• Exporting Client and Server Logs on page 539

• Performing Diagnostics on page 540

• Viewing the PSM Client Log on page 540

• Testing Network Element Connectivity on page 541

• Verifying PSM Client-server Connectivity on page 542

• Collecting and Viewing NE Logs on page 542

• Saving Network Element Configuration Information on page 545

• Troubleshooting Server Replication on page 545

Managing Task Status

The proNX Service Manager provides a Tasks status screen that allows you to view the

progress and status of running tasks. The Tasks status screen shows the list of tasks that

this client has requested the server to execute. Tasks launched by other clients or

scheduled tasks which are run by the server itself are not shown in this view.

NOTE: When performing a task on a network element, you should wait until
that task completes before starting a new task on that network element.

Some tasks are displayedwith a ‘parent’ or ‘top level’ task that can be expanded to show

all the subtasks that the server will execute to fulfill the user request.

In the following example, Task13881 is made up of two subtasks.
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The State column displays the current status of the tasks as RUNNING or FINISHED as

reported by the server. The possible subtask states are RUNNING, SUCCESS, or FAILURE.

When all subtasks are complete, the task State will transition to FINISHED. The Details

column provides additional details about a task or subtask.

In an effort to protect network and server resources, the server might queue tasks that

it is unable to service at the requested time. These queued tasks are not shown in the

Tasks status window.

• If the server isbusy, newtask requestsareplacedontoaqueue.Thesenewtask requests

are dequeued for servicing as the server completes existing tasks. If a client requests

a task that is identical to a task already queued, PSM returns an error and does not

queue the new task. The error can be for a subtask if the subtask is a duplicate, or a

top level task if the top level task is a duplicate.

• Limits are placed on the number of tasks that can be started by the server. These limits

apply for each type of task and span across all clients. See

/usr/local/ems9001/resources/serverConfigurations/workers.xml for the specific limits.

NOTE: This file must not be changed or unintended consequencesmight
occur.

Once a specific task limit is reached, any additional requests for that same type of task

by any client are queued by the server. Once a running task of that type is completed,
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the server dequeues the next task from that queue, and only then starts and places

this new task in the respective client's Tasks status window.

• Discovering Task Status on page 539

• Clearing Completed Tasks on page 539

Discovering Task Status

1. To access the Tasks status screen, click the Tasks tab, or, from themainmenu choose

View>Server>Tasks .

The Tasks screen is displayed in the lower right corner of the main client window.

Clearing Completed Tasks

1. To clear the completed tasks from the Tasks status screen, right-click the title bar

and select Clear Completed Tasks.

Completed tasks are removed from the Tasks screen.

Exporting Client and Server Logs

Users can export client and server log files, and save them to a zip file on the local drive

where the client resides. Client and server logs are useful in providing information to

Juniper Networks Support for issue resolution.

1. To export files, click on the Archive Logs button on the toolbar shown below.

2. In the resulting pop-up dialog, enter the location of the directory in which you want

to store the archive and clickOK.

The filename format is psmLogs-<date-time>.zip. By default, the file is stored in the

following locations in the user's home directory.

• Windows XP and Linux

Application Data\.psmclient\dev\Archivedlogs

• Windows 7

AppData\Roaming\.psmclient\dev\ArchivedLogs
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• MACOS X

Library/Application Support/psmclient/dev/ArchivedLogs

NOTE: These paths are relative to the user's home directory, which varies
depending on the operating system. ForWindows 7, the directory is
C:\Users\<user_name>\AppData\Roaming\.psmclient\dev\ArchivedLogs.

Performing Diagnostics

Youcan request thePSMclient toperformthe followingdiagnosticoperationsondemand

to troubleshoot active issues:

• Save Configuration - saves an xml file of the network element configuration details to

your local computer (formore information, see “SavingNetworkElementConfiguration

Information” on page 545).

• Ping - performs an ICMP ping on the network element.

• Traceroute - performs a traceroute on the network element.

• SNMP Ping - performs an on-demand SNMP Ping.

1. In the Map view or Network tree, right-click a network element and choose

Utilities>Diagnostics and the type of diagnostic operation youwant the PSM client to

perform (Save Configuration, Ping, Traceroute, or SNMP Ping).

Viewing the PSMClient Log

Use this procedure to view the active PSMClient logwhen troubleshooting active issues.
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1. From themain menu choose View>Log.

The active client log tab is displayed.

Testing Network Element Connectivity

Use this procedure to checkconnectivity toadiscoverednetworkelement. This procedure

tests IP, SNMP, and NETCONF (where applicable) connectivity to the network element.
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1. Right-click the network element in the Network tree or in the Topology Map view and

select Node >Connectivity Test.

PSM pings the NE, and checks SNMP and NETCONF connectivity where applicable.

You can see the results of the test through the View >Server >Taskswindow.

If the ping fails, PSM runs a traceroute command and displays the results. The

traceroute task shows SUCCESS if the traceroute command can be run. A successful

traceroute task does not mean that the destination is reachable. To see the results

of the traceroute, click in the Details column of the task.

NOTE: PSM also runs this test automatically when log collection or NE
database backup/restore fails. In this case, the results are provided in the
logs.

Verifying PSMClient-server Connectivity

Use this procedure after installation or at any other time to verify that the PSM client is

receiving asynchronous events from the PSM server.

1. Click Tools >Network Element Discovery.

2. In theDeviceDiscoverywindow, enter anon-existent IPaddress in theDiscoveryCriteria

box.

3. ClickOK.

Look in the Tasks window andmake sure you see the NE Discovery task for the

non-existent IP address being launched and subsequently failing. If you do not see

this task failing, check and fix your firewall settings and repeat this procedure.

Collecting and Viewing NE Logs

Use thisprocedure tocollect andview logs fromaBTI7000SeriesNEoraBTI7800Series

NE or an MX Series or PTX Series router or QFX Series switch on demand.
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NOTE: The PSM server does not keep track of what logs have been retrieved
from previous collections. Each time a new log collection request is made,
the PSM server retrieves the full set of logs from the specified network
element(s).

For information on how to set up NE log collection, including how to set up scheduled

NE log collection, see the proNX Service Manager Installation and Administration Guide.

1. To collect the latest logs for an NE, right-click on the NE, either in the Network tree or

on the Topology Map view, and choose Retrieve Logs.

The Log Collection dialog box is displayed.

2. In the Log Collection dialog box, clickOK.

The logs for the NE are collected.

NOTE: The time that it takes for logs to be collected from a network
element depends largely on the speed of the network connection. For
slower connections, monitor the Tasks window for completion before
viewing the logs.

3. Toview the logs that havebeen collected, from themainmenuchooseView>Network

>NE Logs.

The Log Collection tab is displayed.
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4. In the Log Collection tab, specify the log filtering options as desired, and then click

PerformQuery.

Thecollected logsare filtered, sorted, anddisplayedaccording to theoptions specified.

NOTE: The Log Idmight not be a unique number. When filtering, use a
combination of fields to locate the desired log entries.
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NOTE: PSM-generated NE log collection related alarms are not
automatically cleared once the problem has been resolved. Any
PSM-generated NE log collection alarms that occur must bemanually
cleared. Tomanually clear a PSM-generated alarm, right-click the alarm
and choose Clear NMSGeneratedAlarm. Once cleared, you cannot restore

an alarm.

Saving Network Element Configuration Information

Use this procedure to save network element configuration data learned through SNMP

to your local computer.

PSM lets you save an XML-formatted set of configuration data for a selected NE to your

local computer. This configuration data is learned through SNMP. You can view the

configuration data to troubleshoot issues, or attach the XML document to an e-mail to

send to your support organization.

1. To save the configuration data for an NE, right-click the NE and select Utilities

>Diagnostics >Save Configuration

2. In the Save window, select a path in the Save in: field where you want to save the file.

The tool automatically assigns a .xml file extension to the file name.

Troubleshooting Server Replication

This section describes how to troubleshoot server replication.

• Loss Of Connectivity to the Cluster on page 545

• Loss Of Synchronization with a Cluster Member on page 546

• Re-establishment Of Connectivity to the Cluster on page 546

• Synchronizing Replicated Data Manually on page 546

• Restarting the Cluster on page 547

Loss Of Connectivity to the Cluster

When the PSM server loses connectivity with another member in the cluster, the server

raises a 'PSM cluster node connection lost' alarm, identifying the member with which

connectivity has been lost. Typically, the servers at both ends of the connectionwill raise

the alarm, signifying a loss of connectivity with their counterpart.

When this occurs, it is best that you do not change any replicated data on the local server

or onany serverwithwhich connectivity hasbeen lost. If youdomake changes, youmight

have to manually reconcile these changes later. This becomes particularly complicated

if there are more than two servers in the cluster.
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Loss Of Synchronization with a Cluster Member

When the PSM server loses synchronization with another member in the cluster, the

server raisesa 'Synchronization failedagainst cluster node' alarm, identifying themember

with which synchronization has been lost. Synchronization is declared lost when the

remote member does not respond to a synchronization request. A server sends out

synchronization requests on restart and onmanual command.

When thisproblemoccurs, performamanual synchronization (“SynchronizingReplicated

Data Manually” on page 546).

Re-establishment Of Connectivity to the Cluster

When the PSM Server re-establishes connectivity with the other member(s), the server

clears the 'PSM cluster node connection lost' alarm(s).

If you did not make any changes to the replicated data on the local server or on any of

the servers for which connectivity was lost, then you do not need to take any action. All

servers have the correct replicated data and are synchronized.

If you did make changes to the replicated data on the local server and/or on any of the

other servers for which connectivity was lost, then you will need to take the following

action:

• If thereareonly twomembers in thecluster, then follow theprocedure in “Synchronizing

Replicated Data Manually” on page 546.

• If there are more than twomembers in the cluster, then follow the procedure in

“Restarting the Cluster” on page 547.

Synchronizing Replicated DataManually

Use thisprocedure tomanually synchronize replicateddatawithother servers inacluster.

Before executing this command, ensure the following:

• When running with two servers in the cluster, ensure the other server has the correct

replicated data.

• When running with more than two servers in the cluster, ensure all other servers have

the correct replicated data. If not all of the other servers have the correct replicated

data, then do not run this command.

Performmanual synchronization of replicated data on the local server when you want

the local server to retrieve and adopt replicated data from the other servers. This is

typically performed after recovering from a loss of connectivity, but can be done at any

time.

Servers in a cluster do not automatically resynchronize with each other after recovering

froma loss of connectivity because the servers have noway of knowingwhich server has

the correct replicated data. Instead, you have to decide which server has the correct

replicated data, and thenmanually resynchronize all the other servers with that server.
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1. To force the local PSM server to manually synchronize with all servers in the cluster,

select Tools >Synch Replication.

NOTE: This option is not available for selection if server replication is
disabled. See the proNX Service Manager Installation and Administration
Guide for information on how to enable server replication.

The local PSM server retrieves replicated data from all other servers in the cluster,

and overwrites its own replicated data with the retrieved data.

Restarting the Cluster

Use this procedure to restart the cluster with the correct replicated data.

In order to execute this procedure, youmust have access to the Linux operating system

shell on the PSM Server.

1. Decide which server in the cluster has the correct replicated data. Leave this server

running.

2. Stop the PSM server application on all the other servers.

3. Start the PSM server application on each server one by one.

NOTE: Ensure each server is upandhas the correct replicateddatabefore
bringing up the next server.

4. Proceed until all the servers are up and have the correct replicated data.

NOTE: For information on how to stop and start the PSM Server, see the
proNX Service Manager Installation and Administration Guide.
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CHAPTER 20

Appendix

• Service Activation Error Messages on page 549

• PSM Alarms on page 550

• BTI7800 Alarm Details on page 554

• Installing Net-SNMP on page 555

• ConfiguringHistorical PMCollection onBTI800SeriesNetwork Elements on page 558

• PM Counters on page 560

• Regular Expressions on page 578

Service Activation Error Messages

The following tables list the error messages that are sent when a subtask fails during a

service activation task. For the BTI7000 Series network elements, all errors are

accompanied by the error code and string retrieved from the node at the time of failure.

If the error occurs on a specific port, the error message will also include the port index.

For the BTI700 Series devices, all error messages originate within PSM.

Table 62: BTI7000 Series Error Messages

Error messageTask

Failure adding Service to SwitchCreate Service

Failure updating Max Frame Size on [L2 Port Type]

Failure provisioning Bandwidth Profile

Failure provisioning Class Map Profile

Failure provisioning Service Policy Profile

Failure provisioning Port as [L2 Port Type]

Failure associating [L2 Port Type] to Service

Failure adding CVLANMapping to UNI
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Table 62: BTI7000 Series Error Messages (continued)

Error messageTask

Failure updating Profiles on [L2 Port Type]Update Service

(Includes all of the Create Service error
messages, and these error messages)

Failure removing CVLANMapping on UNI

Failure removing [L2 Port Type] from Service

Failure removing Service from Switch

Failure removing [L2 Port Type] from ServiceDelete Service

Failure removing CVLANMapping on UNI

Failure removing Service from Switch

Table 63: BTI700 Series Error Messages

Error messageTask

Failure adding Service to SwitchCreate Service

Failure adding Ports to Service

Failure provisioning [L2 Port Type]

Failure adding CVLANMappings to UNI

Failure adding VLAN 4094 for PVID on UNI

Failure setting PVID on UNI

Failure setting Profiles on [L2 Port Type]

Failure removing CVLANMappings from UNIUpdate Service

(Includes all of the Create Service error
messages, and these error messages)

Failure removing [L2 Port Type] from Service

Failure removing CVLANMappings from UNIDelete Service

Failure removing Profiles from [L2 Port Type]

Failure removing Service from Switch

PSMAlarms

The following table lists the alarms that are raised by PSM.
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NOTE: You canmodify the severity of a PSM alarm. See the proNX Service
Manager Installation and Administration Guide for details. Modifying the
severity of an alarm only affects new alarms raised after themodification
takes effect. Existing alarms continue to show the unmodified severity.

Table 64: PSMAlarms

ExampleDescriptionAlarm

Client cores available (1) lower than
minimum (2).

Thisalarm indicates that thenumberofprocessors
available on themachine running the PSM Client
is less than the recommendedminimum. ThePSM
Client compares the number of available
processors on the client machine with the
“client.minimumCores” value configured in
common.properties.

Client cores

Client RAM available (2048MB) lower than
minimum (4000MB).

This alarm indicates that the amount of RAM
available on themachine running the PSM Client
is less than the recommendedminimum. ThePSM
Client compares the amount of RAM on the client
machine with the “client.minimumRAMSizeMb”
value configured in common.properties.

Client RAM

Client ->Server latency(850ms)higher than
maximum (700ms).

This alarm indicates that the client/server latency
is more than the recommendedmaximum. The
PSM Client compares the last measured latency
time between the client and server with the
“client.maximumLatencyMs” value configured in
common.properties.

Client - server latency

Coresavailable (6) lower thanminimum(8).Thisalarm indicates that thenumberofprocessors
available on themachine running the PSM server
is less than the recommendedminimum. ThePSM
server compares the number of processors on the
server machine with the
“widecastOS.minimumCores” value configured in
common.properties.

Server cores

RAM available (3964MB) lower than
minimum (8000MB).

This alarm indicates that the amount of RAM
available on themachine running the PSM server
is less than the recommendedminimum. ThePSM
server compares the amount of RAMon the server
machine with the
“widecastOS.minimumRAMSizeMb” value
configured in common.properties.

Server RAM

HD available (24568MB) lower than
minimum (150000MB).

This alarm indicates that the amount of free Hard
Disk space available on themachine running the
PSM server is less than the recommended
minimum. The PSM server compares the amount
of HDD space on the server machine with the
“widecastOS.minimiumDiskSizeMb” value
configured in common.properties.

Server hard disk
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Table 64: PSMAlarms (continued)

ExampleDescriptionAlarm

Network element 10.10.10.10 is unreachable.This alarm is raised when an attempt to discover
adevice fails. Thedevicewill bepingedperiodically
to test whether it has become reachable again. If
the device becomes reachable then the alarm is
cleared.

Unreachable network
element

Notifications stopped for 10.53.4.32 on
stream StatusChange

Connectivity to the indicated network element for
receiving notifications has gone down and cannot
be re-established. The NE is placed into an AUTO
out-of-service mode.

If this occurs, fix the underlying problem and
rediscover the network element with the correct
credentials.

Notifications stopped

NE Database backup on PSM Server has
invalid FTP server configured:
10.10.10.10:21:ftpuser

This alarm is raisedwhen the server fails to retrieve
the FTP server configuration information based on
the ID it is supplied from the request to perform an
NE DB Backup task.

Invalid FTP server
configured

Invalid Remote ID format found
[PVX-1-5-G2] PSM NE Invalid Remote ID

This alarm is raisedwhen the server encounters an
incorrectly-formatted Remote ID during topology
discovery.

Invalid Remote ID

Remote IDmismatch found [PVX-1-5-G2]
PSM NE Farend Mismatch

This alarm is raised when the server detects a
Remote IDmismatchwhere the two endpoints are
not referring to each other in bookended
configurations. One alarm is raised at each
endpoint.

This alarm is also raised in single-ended
configurations where the frequency/wavelength
associated with the multiplexer/demultiplexer
channel port does not match the
frequency/wavelength at the other end.

Remote IDmismatch

This alarm is raised when the server detects a
mismatch in topology between the LLDP data and
the Remote ID configuration. The server ignores
the Remote ID and shows the LLDP topology.

NE Link mismatch

NE DB Backup Failure. [Timed out after
300000ms waiting for 7000’s trap.]. Last
failure at Tue Aug 14 04:25:23 BST 2012.

NE DB Backup Failure. NE is unreachable.
Last failure at Tue Aug 14 04:15:11 BST 2012.

Thisalarm is raisedwhenanNEDBbackupprocess
fails (either scheduled or startedmanually). The
cause of the alarm can be attributed with any
number of PSM server or NE issues, e.g. the NE DB
backup process might have exceeded the
maximum time allowed (300s), communication
to theNEwas interrupted, or theNE is unreachable.
This alarmmust be clearedmanually.

NE DB backup failure
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Table 64: PSMAlarms (continued)

ExampleDescriptionAlarm

NE DB Restore Failure. [Timed out after
300000ms waiting for 7000’s trap.]. Last
failure at Tue Aug 14 04:25:23 BST 2012.

NE DB Restore Failure. NE is unreachable.
Last failure at Tue Aug 14 04:15:11 BST 2012.

This alarm is raisedwhenanNEDB restoreprocess
fails. The causeof thealarmcanbeattributedwith
any number of PSM server or NE issues, e.g. theNE
DB restore process might have exceeded the
maximum time allowed (300s), communication
to theNEwas interrupted, or theNE is unreachable.
This alarmmust be clearedmanually.

NE DB restore failure

Log Collection Failure. NE is unreachable.
Last failure at Fri Jul 13 02:00:03 BST 2012.

This alarm is raised when an NE Log Collection
process fails. The cause of the alarm can be
attributed with any number of PSM server or NE
issues, e.g. the NE Log Collection process might
haveexceededthemaximumtimeallowed(500s),
communication to the NE was interrupted, or the
NE is unreachable. This alarmmust be cleared
manually.

NE log collection failure

This alarm is raisedwhenanNESoftwareUpgrade
process fails. The cause of the alarm can be
attributed with any number of server or NE issues,
e.g. the NE S/WUpgrade process times out, a
failure of one of the upgrade steps on theNEor the
NE is unreachable. This alarmmust be cleared
manually.

NE software upgrade
failure

ERPS Ring SUB_ERPS (SVLAN 4089) is in
Protection State

ERPS Ring MAIN_RING (SVLAN 200) is in
Pending State in Domain Ottawa

This alarm is raised when an ERPS ring goes into
protecting, pending, forced protecting, or manual
protecting state. Although this alarm is raised by
PSM, this alarm is also associated with the ERPS
service. A change to protecting state is a major
alarm, while a change to other states is a minor
alarm.

ERPS state change

ERPS Ring MAIN_RING (SVLAN 200) has
Dynamically Added Ports

ERPS Ring MAIN_RING (SVLAN 200) has
DynamicallyAddedPorts inDomainOttawa

If GVRP has added ports dynamically to any ERPS
rings in the network, these ports are removed from
viewwhen the ring is visualized. A minor alarm is
raised indicating their presence.

ERPS dynamic port

PSMclusternode 10.53.4.32connection lostWhen running with server replication, this alarm is
raised if a connection to amember of a server
replication cluster is lost. The IP address of the
remote member is identified in the alarm. This
alarm is cleared once connection to the remote
member is re-established.

PSM cluster node
connection lost

Replication processing against cluster node
10.53.4.32 failed for GROUPS

When running with server replication, this alarm is
raised if the server encounters problems while
processing the replication message from another
server in the cluster. The IP address of the remote
member is identified in the alarm. This alarm can
only be clearedmanually.

Replication processing
against cluster node failed
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Table 64: PSMAlarms (continued)

ExampleDescriptionAlarm

Synchronization failed against cluster node
10.53.4.32

When running with server replication, this alarm is
raised if the server fails to synchronizewithanother
server in the cluster. The IP address of the remote
member is identified in the alarm. This alarm is
cleared when a successful synchronization with
the remote member occurs. This alarm can also
be clearedmanually.

Synchronization failed
against cluster node

BTI7800 AlarmDetails

Table 65: BTI7800 Alarm Fields

Description
Corresponding psmNotificationAlarm
objects (SNMP northbound interface)

Detailed Alarm Information
fields

A combination of the system name and
the network element IP address.

psmNotificationAlarmSysName,
psmNotificationAlarmResourceIp

Network Element

A description of the alarm.psmNotificationAlarmDescriptionDescription

The component raising the alarm.psmNotificationAlarmSourceSource

An internal PSM identifier.psmNotificationAlarmIdReference

The time the alarmwas raised.psmNotificationAlarmCreateTimeTime Raised

The alarm severity.psmNotificationAlarmSeveritySeverity

An indication of whether services are
affected.

psmNotificationAlarmServiceAffectingService Affecting

An indication of whether the alarm has
been acknowledged.

psmNotificationAlarmAckedAcknowledged

The PSM user assigned to this alarm.Not applicable.Assigned User

The category or type of alarm (e.g.
SYSTEM, EQPT).

psmNotificationAlarmCategoryCategory

The alarmmnemonic.psmNotificationAlarmCodeTypeCondition Type

Not applicable.psmNotificationAlarmIdentifierIdentifier

The number of times this alarm has been
raised (within the time boundaries of the
historical alarms report).

Not applicable.Alarm Count
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Table 65: BTI7800 Alarm Fields (continued)

Description
Corresponding psmNotificationAlarm
objects (SNMP northbound interface)

Detailed Alarm Information
fields

The first time the alarmwas raised (within
the time boundaries of the historical
alarms report).

Not applicable.First Time

The last time the alarmwas raised (within
the time boundaries of the historical
alarms report).

Not applicable.Last Time

The alarm has been cleared.psmNotificationAlarmClearedNot applicable.

The alarm can be clearedmanually using
PSM.

psmNotificationAlarmManuallyClearableNot applicable.

The time the alarmwas last updated. If
the alarm has been cleared, then this
object indicates the time the alarmwas
cleared.

psmNotificationAlarmUpdateTimeNot applicable.

Figure 115: BTI7800 Detailed Alarm InformationWindow (example)

Installing Net-SNMP

Use this procedure to install Net-SNMP.
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The Simple Network Management Protocol (SNMP) is a messaging protocol used by

the switch to communicate configuration and status information with a network

management system.SNMPmessagesare exchangedwithin aSNMPcommunity,which

consistsofoneormoreswitchesandoneormoremanagementworkstations.Membership

in a community is controlled by community strings, which function as passwords for the

community. The community strings are embedded in every SNMP packet exchanged

between themembers of the community to authenticate access to the Management

Information Base (MIB) on the switch.

Net-SNMP is a suite of applications used to implement SNMP using IPv4 or IPv6. PSM

uses Net-SNMP to deliver functionality offered in the CLI utilities. See “Setting Utility

Executables” on page 280.

Fordetailed informationandNet-SNMPdownloadexecutables, go towww.net-snmp.org.

1. Navigate to and download the latest version of Net-SNMP at

www.net-snmp.org/download.html.

2. Install Net-SNMP following the installation instructions. Use the suggested default

settings.

3. To confirm that Net-SNMP is installed, use proNX Service Manager to execute an

SNMP ping against a network element.

a. Right-click a network element and selectUtilities>Diagnostics>SNMPPing.

A command window should pop up with the output of the SNMP ping command:
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b. If this is unsuccessful, confirm the Net-SNMP installation directory is correct in the

proNX Service Manager Options dialog.
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Configuring Historical PMCollection on BTI800 Series Network Elements

In order for PSM to retrieve historical PMs from BTI800 Series network elements, you

must configure the BTI800Series network elements to transfer the historical PM counts

to the PSM server. Unlike historical PM collection for the other NE types, BTI800 Series

network elements store historical PM counts in CSV files that must be transferred to the

PSM server.

Thisprocedure is required regardlessofwhether youare running scheduledoron-demand

historical PMs.

NOTE: The generated CSV files are named using the NE name. Therefore
eachBTI800Seriesnetworkelementmustbeconfiguredwithauniquename
to ensure the CSV files that it generates have unique nameswhen placed on
the PSM server.

NOTE: Ensure the BTI800 Series network element is not also reporting
statistics to the SLA Portal. You cannot use both PSM and the SLA Portal to
retrieve counts from BTI800 Series network elements at the same time.

The following steps are performed using the CLI on the BTI800 Series network element:

1. Configure the NTP server if one is not already configured.

The following specifies the NTP server to use, and sets the time zone to EST.
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configure ntp del-server 1
configure ntp add-server <ntp_server_ip>
configure ntp enable
configure timezone est

2. Disable any existing PM collection and file transfer.

configure pm file-transfer disable
configure pm sys disable
configure pm eth disable
configure pm oam disable
configure pm eservice disable
configure pm eservice last5m disable
configure interface average-rate disable

3. Enable Ethernet PM collection.

configure pm eth enable

4. Configure PM file transfer.

The following configures the BTI800 Series switch to transfer 15-minute and 1-day

EthernetPMs to thePSMserver everyhour,which is thehighest recommendedupload

frequency. To change/decrease the frequency of the file transfer, change the setting

of the upload-mode parameter.

configure pm file-transfer mode sftp
configure pm file-transfer target <server_ip> <username> <password> 
<dest_dir> <sftp_port>
configure pm file-transfer upload-bin group del all
configure pm file-transfer upload-bin group add 15m
configure pm file-transfer upload-bin group add 24h
configure pm file-transfer upload-mode frequency 0 0 60
configure pm file-transfer upload-group add eth
configure pm file-transfer enable

where

• <server_ip> is the IP address of the PSM server.

• <username> and <password> are the login credentials used to log in to the PSM

server.

• <dest_dir> is the destination directory where the historical PM CSV files are to be

placed, and consequently where PSM retrieves the historical PM CSV files. This

directory is specified relative to the FTP user's home directory, and should be set

to HistoricalPMs/ne800.

• <sftp_port> is the port number (typically 22) to use.

With these settings, theBTI800Series network element transfers a historical PMCSV

file to the PSM server once every hour. The file name includes the name of the NE (or

IP address), and the GMT time and date.
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NOTE: If you are running on-demand historical PMs, be aware of the file
transfer frequency. Theon-demandhistorical PMdata reflects the counts
from the last update.

PMCounters

PSMsupports the retrieval anddisplayofPMs for various interfacesonvariousequipment.

• PM Counters for BTI7000 Series Transponders and Muxponders on page 560

• PM Counters for BTI7000 Series DOLModules on page 565

• PM Counters for BTI7000 Series packetVXModules on page 567

• PM Counters for BTI718E Modules on page 573

• PM Counters for BTI800 Series Modules on page 574

• PM Counters for Optical Interfaces on MX Series and PTX Series Routers and QFX

Series Switches on page 576

PMCounters for BTI7000 Series Transponders andMuxponders

PSM supports the retrieval and display of PMs from BTI7000 Series transponders and

muxponders. The actual PMs supported depend on the configuration and the software

running on the network element, andmight include some of the following:

Table 66: Physical PMs

UnitsDescriptionName (abbreviated)

mAThe laser bias current.LBC

dBmThe average optical power received on
the input.

OPRAvg

dBmThemaximumoptical power receivedon
the input.

OPRMax

dBmTheminimumoptical power received on
the input.

OPRMin

dBmThe instantaneous optical power
received on the input.

OPR

dBmThe average optical power transmitted
at the output.

OPTAvg

dBmThemaximumopticalpower transmitted
at the output.

OPTMax

dBmTheminimumoptical power transmitted
at the output.

OPTMin
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Table 66: Physical PMs (continued)

UnitsDescriptionName (abbreviated)

dBmThe instantaneous optical power
transmitted at the output.

OPT

mVA second supply voltageSupplyVoltage2

mVThe supply voltageSupplyVoltage

CelciusThe temperature measured at the
transceiver or port.

Temp

Table 67: SONET PMs

UnitsDescriptionName (abbreviated)

Section Layer

noneCoding violations at the section layer.CVS

secondsErrored seconds at the section layer.ESS

secondsSeverely errored framing seconds at the
section layer.

SEFSS

secondsSeverely errored seconds at the section
layer.

SESS

secondsUnavailable secondsat thesection layer.UASS

Line Layer

noneCoding violations at the line layer.CVL

secondsErrored seconds at the line layer.ESL

secondsSeverely erroredsecondsat the line layer.SESL

secondsUnavailable seconds at the line layer.UASL

Path Layer

noneCoding violations at the path layer.CVP

secondsErrored seconds at the path layer.ESP

noneFailure count at the path layer.FCP

secondsSeverely errored seconds at the path
layer.

SESP
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Table 67: SONET PMs (continued)

UnitsDescriptionName (abbreviated)

secondsUnavailable seconds at the path layer.UASP

Table 68: SDH PMs

UnitsDescriptionName (abbreviated)

Regenerator Section

noneRegenerator section background block
errors.

RSBBE

noneRegenerator section errored blocks.RSEB

secondsRegenerator section errored seconds.RSES

secondsRegenerator section out-of-frame
seconds.

RSOFS

secondsRegenerator section severely errored
seconds.

RSSES

secondsRegenerator section unavailable
seconds.

RSUAS

Multiplex Section

noneMultiplex section background block
errors.

MSBBE

noneMultiplex section errored blocks.MSEB

secondsMultiplex section errored seconds.MSES

secondsMultiplex section severely errored
seconds.

MSSES

secondsMultiplex section unavailable seconds.MSUAS

High Order Path

noneHighorderpathbackgroundblockerrors.HPBBE

noneHigh order path errored blocks.HPEB

secondsHigh order path errored seconds.HPES

secondsHighorderpathseverelyerroredseconds.HPSES
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Table 68: SDH PMs (continued)

UnitsDescriptionName (abbreviated)

secondsHigh order path unavailable seconds.HPUAS

Table 69: OTN PMs

UnitsDescriptionName (abbreviated)

noneBits corrected, 64-bit value.NBITCR64Bit

noneBits corrected.NBITCR

noneBytes corrected, 64-bit value.NBYTCR64Bit

noneBytes corrected.NBYTCR

noneAverage BER.OTNAVGBER

noneInstantaneous BER.OTNBER

noneBackground block errors at the OTN
digital wrapper layer.

OTUBBE

noneErroredblocksat theOTNdigitalwrapper
layer.

OTUEB

secondsErrored seconds at the OTN digital
wrapper layer.

OTUES

secondsOut-of-framesecondsat theOTNdigital
wrapper layer.

OTUOFS

secondsSeverely errored seconds at the OTN
digital wrapper layer.

OTUSES

secondsUnavailable seconds at the OTN digital
wrapper layer.

OTUUAS

noneUncorrectable codewords.UNCRCDW

Table 70: GE/FC/10GELAN PMs

UnitsDescriptionName (abbreviated)

noneCoding violations.CV

secondsErrored seconds.ES

noneInvalid blocks.INVBLK
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Table 70: GE/FC/10GELAN PMs (continued)

UnitsDescriptionName (abbreviated)

secondsSeverely errored seconds.SES

secondsUnavailable seconds.UAS

noneValid frames received thatwere directed
to the broadcast address.

BCST

noneFrames with a bad Frame Check
Sequence (FCS) or frames with an
alignment error (non-integral number of
octets).

FCSE

noneFrames dropped.FRDR

noneFrames received that were less than 64
octets in length and that had an FCS
error or an alignment error.

FRGT

noneFrames received longer than the
maximumMTU size, including frames
with FCS errors or alignment errors.

JABR

noneValid frames received thatwere directed
to amulticast address.

MCST

noneFrames received that were greater than
9600 octets in length, but were
otherwise valid.

OSIZE

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZE64

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZE65To127

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZE128To255

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZE256To511

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZE512To1023
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Table 70: GE/FC/10GELAN PMs (continued)

UnitsDescriptionName (abbreviated)

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZE1024To1518

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZEOver1518

noneTotal bytes of data received from valid
and invalid frames.

TBYCRX

noneTotal bytes of data transmitted.TBYCTX

noneTotal frames received including validand
invalid frames, broadcast frames, and
multicast frames.

TFRCRX

noneTotal frames transmitted.TFRCTX

noneTotal PAUSE frames received.TPFCRX

noneTotal PAUSE frames transmitted.TPFCTX

noneFrames received that were less than 64
octets in length, butwereotherwisevalid.

USIZE

For information onwhat ports and protocols support these PMs, see the BTI7000 Series

Transponder Solutions Guide and the BTI7000 Series Muxponder Solutions Guide.

PMCounters for BTI7000 Series DOLModules

PSM supports the retrieval and display of PMs from BTI7000 Series DOLmodules. The

actual PMs supported depend on the configuration and the software running on the

network element, andmight include some of the following:

Table 71: Port PMs

UnitsDescriptionName (abbreviated)

dBmThe optical power lossmeasured on the
port in the receive direction. For a line
port, this represents the span loss. For a
DCM port, this is the DCM loss. For a
client port, this is the loss of the receive
interconnection fiber.

LossRx
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Table 71: Port PMs (continued)

UnitsDescriptionName (abbreviated)

dBmThe optical power lossmeasured on the
port in the transmit direction. For a line
port, this represents the far-end span
loss. For a client port, this is the loss of
the transmit interconnection fiber.

LossTx

dBmThe average optical power received on
the input.

OPRAvg

dBmThemaximumoptical power receivedon
the input.

OPRMax

dBmTheminimumoptical power received on
the input.

OPRMin

dBmThestandarddeviation fromtheaverage
optical power received on the input.

OPRStdDev

dBmThe instantaneous optical power
received on the input.

OPR

dBmThe average optical power transmitted
at the output.

OPTAvg

dBmThemaximumopticalpower transmitted
at the output.

OPTMax

dBmTheminimumoptical power transmitted
at the output.

OPTMin

dBmThestandarddeviation fromtheaverage
optical power transmittedon theoutput.

OPTStdDev

dBmThe instantaneous optical power
transmitted at the output.

OPT

Table 72: OSC PMs

UnitsDescriptionName (abbreviated)

noneCoding violations at the section layer.CVS

secondsErrored seconds at the section layer.ESS

dBmThe optical back-reflected power.OBR

dBmThe instantaneous optical power
received on the input.

OPR
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Table 72: OSC PMs (continued)

UnitsDescriptionName (abbreviated)

dBmThe instantaneous optical power
transmitted at the output.

OPT

secondsSeverely errored framing seconds at the
section layer.

SEFSS

secondsSeverely errored seconds at the section
layer.

SESS

secondsUnavailable secondsat thesection layer.UASS

Table 73: Wavelength Channel PMs

UnitsDescriptionName (abbreviated)

dBmThemaximumoptical power receivedon
the input.

OPRMax

dBmTheminimumoptical power received on
the input.

OPRMin

dBmThe instantaneous optical power
received on the input.

OPR

dBmThemaximumopticalpower transmitted
at the output.

OPTMax

dBmTheminimumoptical power transmitted
at the output.

OPTMin

dBmThe instantaneous optical power
transmitted at the output.

OPT

For information onwhat ports and protocols support these PMs, see the BTI7000 Series

Dynamic Optical Layer Engineering Guideline.

PMCounters for BTI7000 Series packetVXModules

PSM supports the retrieval and display of PMs from PVXmodules. The actual PMs

supporteddependon theconfigurationand thesoftware runningon thenetworkelement,

andmight include some of the following:

Table 74: Physical PMs

UnitsDescriptionName (abbreviated)

mAThe laser bias current.LBC
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Table 74: Physical PMs (continued)

UnitsDescriptionName (abbreviated)

dBmThe average optical power received on
the input.

OPRAvg

dBmThemaximumoptical power receivedon
the input.

OPRMax

dBmTheminimumoptical power received on
the input.

OPRMin

dBmThe instantaneous optical power
received on the input.

OPR

dBmThe average optical power transmitted
at the output.

OPTAvg

dBmThemaximumopticalpower transmitted
at the output.

OPTMax

dBmTheminimumoptical power transmitted
at the output.

OPTMin

dBmThe instantaneous optical power
transmitted at the output.

OPT

mVA second supply voltageSupplyVoltage2

mVThe supply voltageSupplyVoltage

CelciusThe temperature measured at the
transceiver or port.

Temp

Table 75: OTN PMs

UnitsDescriptionName (abbreviated)

noneBits corrected, 64-bit value.NBITCR64Bit

noneBits corrected.NBITCR

noneBytes corrected, 64-bit value.NBYTCR64Bit

noneBytes corrected.NBYTCR

noneAverage BER.OTNAVGBER

noneInstantaneous BER.OTNBER

noneBackground block errors at the OTN
digital wrapper layer.

OTUBBE
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Table 75: OTN PMs (continued)

UnitsDescriptionName (abbreviated)

noneErroredblocksat theOTNdigitalwrapper
layer.

OTUEB

secondsErrored seconds at the OTN digital
wrapper layer.

OTUES

secondsOut-of-framesecondsat theOTNdigital
wrapper layer.

OTUOFS

secondsSeverely errored seconds at the OTN
digital wrapper layer.

OTUSES

secondsUnavailable seconds at the OTN digital
wrapper layer.

OTUUAS

noneUncorrectable codewords.UNCRCDW

Table 76: GE/10GE PMs

UnitsDescriptionName (abbreviated)

none8B/10B coding violations for GE ports.CV

secondsErrored seconds.ES

dBmInvalid blocks on 10GE ports.INVBLK

secondsSeverely errored seconds.SES

secondsUnavailable seconds for GE ports.UASS

Table 77: Ethernet L2 PMs

UnitsDescriptionName (abbreviated)

noneValid frames received thatwere directed
to the broadcast address.

BCST

noneFrames with a bad Frame Check
Sequence (FCS) or frames with an
alignment error (non-integral number of
octets).

FCSE

noneFrames dropped.FRDR

noneFrames received that were less than 64
octets in length and that had an FCS
error or an alignment error.

FRGT
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Table 77: Ethernet L2 PMs (continued)

UnitsDescriptionName (abbreviated)

noneValid frames received thatwere directed
to amulticast address.

MCST

noneFrames received that were greater than
9600 octets in length, but were
otherwise valid.

OSIZE

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZE64

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZE65To127

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZE128To255

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZE256To511

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZE512To1023

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZE1024To1518

noneFrames received with the specified
length or range (excluding framing bits
but including FCS).

SIZEOver1518

noneTotal bytes of data received from valid
and invalid frames.

TBYCRX

noneTotal bytes of data transmitted.TBYCTX

noneTotal frames received including validand
invalid frames, broadcast frames, and
multicast frames.

TFRCRX

noneTotal frames transmitted.TFRCTX

noneTotal PAUSE frames received.TPFCRX

noneTotal PAUSE frames transmitted.TPFCTX
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Table 77: Ethernet L2 PMs (continued)

UnitsDescriptionName (abbreviated)

noneFrames received that were less than 64
octets in length, butwereotherwisevalid.

USIZE

Table 78: LAG PMs

UnitsDescriptionName (abbreviated)

noneThe count of invalid Link Access Control
frames received on the LAG port.

INVLACFRRX

noneThe total Link Access Control PDUs
received on the LAG port.

LACPDURX

noneThe total Link Access Control PDUs
transmitted on the LAG port.

LACPDUTX

noneThe count of Marker PDUs received on
the LAG port.

MRKPDURX

noneThe count of Marker PDUs transmitted
on the LAG port.

MRKPDUTX

noneThe count of Marker Response PDUs
received on the LAG port.

MRKRSPPDURX

noneThe count of Marker Response PDUs
transmitted on the LAG port.

MRKRSPPDUTX

Table 79: ERPS PMs

UnitsDescriptionName (abbreviated)

noneThe number of times this port has
transitioned to blocked state.

Blocked

noneThe number of Event PDUs received on
this port.

EventPduRx

noneThe number of Event PDUs transmitted
on this port.

EventPduTx

noneThe number of times this port has
transitioned to failed state.

Failures

noneThe number of FS PDUs received on this
port.

FsPduRx

noneThe number of FS PDUs transmitted on
this port.

FsPduTx
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Table 79: ERPS PMs (continued)

UnitsDescriptionName (abbreviated)

noneThenumberofMSPDUs receivedon this
port.

MsPduRx

noneThe number ofMSPDUs transmitted on
this port.

MsPduTx

noneThenumber ofNRPDUs receivedon this
port.

NrPduRx

noneThe number of NR PDUs transmitted on
this port.

NrPduTx

noneThe number of NRRB PDUs received on
this port.

NrrbPduRx

noneThe number of NRRB PDUs transmitted
on this port.

NrrbPduTx

noneThe number of PDUs discarded on this
port.

PduDiscard

noneThe number of PDUs received on this
port.

PduRx

noneThenumber of PDUs transmittedon this
port.

PduTx

noneThe number of times this port has
recovered from a failed state.

Recoveries

noneThe number of SF PDUs received on this
port.

SfPduRx

noneThe number of SF PDUs transmitted on
this port.

SfPduTx

noneThe number of times this port has
transitioned to unblocked state.

Unblocked

noneThenumber ofPDUs versiondiscardson
this port.

VersionDiscard

For information onwhat ports and protocols support these PMs, see the BTI7000 Series

packetVX Solutions Guide.
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PMCounters for BTI718EModules

PSM supports the retrieval and display of PMs from BTI718E devices. The actual PMs

supporteddependon theconfigurationand thesoftware runningon thenetworkelement,

andmight include some or all of the following:

Table 80: Ethernet L2 PMs

UnitsDescription
Name
(abbreviated)

noneTotal number of dropped packets due to lack of resources or
otherwise.

NOTE: This number is not necessarily the number of frames
dropped. It is just the number of times that the drop is detected.

DropEvts

noneTotal number of received packets that had a valid length but had
either a bad Frame Check Sequence (FCS) or a bad FCS with a
non-integral number of octets (alignment errors).

FcsErrs

noneTotal number of received packets that were less than 64 octets
long (excluding framing bits, but including FrameCheck Sequence
(FCS) octets) and had either a bad FCS with a integral number of
octets (FCS error) or a bad FCS with a non-integral number of
octets (alignment error).

Fragments

noneJumbo

noneTotal number of received packets that were longer than 9600
octets (excluding framingbits,but includingFrameCheckSequence
(FCS) octets) and had either a bad FCS with an integral number
of octets (FCS error) or a bad FCS with a non-integral number of
octets (alignment error).

Oversize

bytes per secondLast 5 minutes received bytes per second rate.Rx5mBps

packets per secondLast 5 minutes received packets per second rate.Rx5mPps

noneTotal number of good packets received that were directed to the
broadcast address.

RxBroadcast

noneTotal number of octets of data (including those in bad packets)
received on the network (excluding framing bits but including FCS
octets).

RxBytes

noneTotal number of good packets received that were directed to a
multicast address.

RxMulticast

noneTotal number of pause frames received.RxPause

noneTotal number of packets (including bad packets, broadcast
packets, andmulticast packets) received.

RxPkts
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Table 80: Ethernet L2 PMs (continued)

UnitsDescription
Name
(abbreviated)

noneTotal number of unicast packets received on the interface and
delivered to a higher-layer protocol.

RxUnicast

bytes per secondLast 5 minutes transmitted bytes per second rate.Tx5mBps

packets per secondLast 5 minutes transmitted packets per second rate.Tx5mPps

noneTotal number of packets transmitted that were directed to the
broadcast address.

TxBroadcast

noneTotal number of octets of data transmitted on the network
(excluding framing bits but including FCS octets).

TxBytes

noneTotal number of packets transmitted that were directed to a
multicast address.

TxMulticast

noneTotal number of pause frames transmitted.TxPause

noneTotal number of packets (including broadcast packets and
multicast packets) transmitted.

TxPkts

noneTotal number of packets that higher-layer protocols requested to
be transmitted to a unicast address, including those that were
discarded or not sent.

TxUnicast

noneTotal number of packets received that were less than 64 octets
long (excluding framing bits, but including FrameCheck Sequence
(FCS) octets) and were otherwise well formed.

Undersize

For information on these PMs, see the BTI718E Ethernet Access Device Technical Product

Guide.

PMCounters for BTI800 Series Modules

PSM supports the retrieval and display of PMs from BTI800 Series devices. The actual

PMs supported depend on the configuration and the software running on the network

element, andmight include some or all of the following:

Table 81: Physical PMs

UnitsDescription
Name
(abbreviated)

mALaser Bias CurrentLBC

dBmOptical Power Received.OPR

dBmOptical Power Transmitted.OPT
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Table 81: Physical PMs (continued)

UnitsDescription
Name
(abbreviated)

CelciusTemperatureTemp

VoltsVoltageVoltage

Table 82: GE Layer 1 PMs

UnitsDescriptionName (abbreviated)

noneCoding violationsCV

secondsErrored seconds.ES

secondsSeverely errored seconds.SES

Table 83: Ethernet L2 PMs

UnitsDescription
Name
(abbreviated)

noneNumber of received packets discarded.Discard

noneNumber of received packets with CRC error.FCS

noneNumber of received packets that were less than 64 octets long
and had either a bad FCS with an integral number of octets (FCS
error)orabadFCSwithanon-integral numberofoctets (alignment
error).

Fragment

noneNumber of received packets that were more than 9600 octets
long and had either a bad FCS with an integral number of octets
(FCS error) or a bad FCS with a non-integral number of octets
(alignment error).

Jabber

noneNumber of received packets greater than 9600 octets.Oversize

noneNumber of broadcast packets received.RXBCAST

noneNumber of frames received.RXFrame

noneNumber of multicast packets received.RXMCAST

noneNumber of octets received.RXOctet

noneNumber of unicast packets received.RXUCAST

noneNumber of broadcast packets transmitted.TXBCAST
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Table 83: Ethernet L2 PMs (continued)

UnitsDescription
Name
(abbreviated)

noneNumber of frames transmitted.TXFrame

noneNumber of multicast packets transmitted.TXMCAST

noneNumber of octets transmitted.TXOctet

noneNumber of unicast packets transmitted.TXUCAST

noneNumber of received packets less than 64 octets.Undersize

For information on these PMs, see the BTI800 Series Technical Product Guide.

PMCounters for Optical Interfaces onMX Series and PTX Series Routers and QFX Series
Switches

PSM supports the retrieval and display of PMs from supported optical interfaces on MX

Series and PTX Series routers and QFX Series switches. See “Nodal Management for

Juniper Networks Routers and Switches” on page 257 for the list of supported interfaces.

The actual PMs supported depend on the interface, the configuration, and the software

running on the router or switch, and can include some or all of the following:

NOTE: Whenviewing historical PMs for thePMs in Table84onpage576, the
current values are not displayed.

Table 84: Optics PMs

UnitsDescriptionName (abbreviated)

ps/nmResidual chromatic dispersion,
current/average/minimum/maximum

CD, CD-Avg, CD-Min, CD-Max

MHzCarrier frequency offset,
current/average/minimum/maximum

CFO, CFO-Avg, CFO-Min, CFO-Max

psDifferential group delay,
current/average/minimum/maximum

DGD, DGD-Avg, DGD-Min, DGD-Max

0.01 dBmOptical power receive,
current/average/minimum/maximum

Pwr-Rx, Pwr-Rx-Avg, Pwr-Rx-Min,
Pwr-Rx-Max

0.01 dBmOptical power transmit,
current/average/minimum/maximum

Pwr-Tx, Pwr-Tx-Avg, Pwr-Tx-Min,
Pwr-Tx-Max

0.1 dBQ factor,
current/average/minimum/maximum

Q, Q-Avg, Q-Min, Q-Max
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Table 84: Optics PMs (continued)

UnitsDescriptionName (abbreviated)

0.1 dBSignal-to-noise ratio,
current/average/minimum/maximum

SNR, SNR-Avg, SNR-Min, SNR-Max

°CTransceiver temperature,
current/average/minimum/maximum

Temp,Temp-Avg,Temp-Min,Temp-Max

Table 85: OTU PMs

UnitsDescriptionName (abbreviated)

noneFEC bit error rate,
average/minimum/maximum

FEC-BER-Avg-NearEnd,
FEC-BER-Min-NearEnd,
FEC-BER-Max-NearEnd

noneFEC corrected errorsFEC-CorrectedErr-NearEnd

noneFEC uncorrected wordsFEC-UncorrectedWords-NearEnd

noneOTU background block errors, near end,
far end

OTU-BBE-NearEnd, OTU-BBE-FarEnd

secondsOTU errored seconds, near end, far endOTU-ES-NearEnd, OTU-ES-FarEnd

secondsOTU severely errored seconds, near end,
far end

OTU-SES-NearEnd, OTU-SES-FarEnd

secondsOTU unavailable seconds, near end, far
end

OTU-UAS-NearEnd, OTU-UAS-FarEnd

Table 86: ODU PMs

UnitsDescriptionName (abbreviated)

noneODU background block errors, near end,
far end

ODU-BBE-NearEnd, ODU-BBE-FarEnd

secondsODU errored seconds, near end, far endODU-ES-NearEnd, ODU-ES-FarEnd

secondsODU severely errored seconds, near end,
far end

ODU-SES-NearEnd, ODU-SES-FarEnd

secondsODU unavailable seconds, near end, far
end

ODU-UAS-NearEnd, ODU-UAS-FarEnd
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NOTE: PSM displays all counters reported by the router or switch, which
might include counters not listed above. Counters not listed abovemight not
be supported. For the definitive list of the supported PM counters, consult
the appropriate Juniper Networks documentation for the router or switch.

Regular Expressions

Regular expressions (regex) is a highly descriptive language commonly used to search

throughasetofdata.Therearedifferent variantsof regexbutmost shareasimilar syntax.

This section describes regex in the context of PSM. PSM allows you to use regular

expressions to control how entries in the Network tree are categorized.

A regular expression is created using one or more constructs. The expression is then

compared against a set of data, which, in the case of a branch in the Network tree, is the

set of entries or names in that branch. The simplest way to envision this is to imagine a

scanner that scans through the set of names one character at a time looking formatches

to the given expression.
1

NOTE:
1 In reality, the regex engine uses algorithmicmethods to look for

matches.

Table 87: Common Regex Constructs

ExampleDescriptionConstruct

Characters and character classes

amatches abcLiteral. Matches if the specified char
matches the character at the current
position in the data set.

char

ab.dmatches abcd and abddWildcard. Matches any single character
at the current position in the data set.
Does not match if there is no character
at the current position (e.g. at the end of
a name).

. (dot)

[a]matches abc

[abc]matches abc, abc, and abc

[a-zA-Z]matches any lowercase or
uppercase letter

[^a0-9]matches any character that is
not an a or a digit

Character class. Matches if any single
charwithin the square parentheses
matches the character at the current
position in the data set.

The characters in the parentheses can
be a list of characters or a range of
characters, or a negation.

[chars]

\wmatches !@#-a-%$#Word character, shorthand for
[a-zA-Z0-9_].

\w
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Table 87: Common Regex Constructs (continued)

ExampleDescriptionConstruct

\dmatches abc2defDigit character, shorthand for [0-9].\d

\.comoutside a character classmatches
mycompany.com

Escape character.

When immediately preceding one of the
following special characters,
[\^$.|?*+(){} outside a character class,
the \ suppresses the special character's
meaning, and the special character is
treated as a literal.

When immediately preceding one of the
following special characters, ^-]\ inside
a character class, the \ suppresses the
special character's meaning, and the
special character is treated as a literal.

\ (backslash)

ExampleDescriptionConstruct

Anchors

If the string is network_subnet, then:

^netmatches network_subnet

Match at the start of the string or after a
newline.1

NOTE: A starting ^ inside a character
class is a negation.

NOTE: 1Each name in the branch is
separated by the newline character.

^ (caret)

If the string is network_subnet, then:

net$matches network_subnet

Match at the end of the string or before
a newline.

$ (dollar)

ExampleDescriptionConstruct

Quantification

om*matches optical

om*matches commissioning

Match the preceding item 0 or more
times, asmany timesaspossible (greedy
match).

* (asterisk)

om+matches commissioningMatch the preceding item 1 or more
times, asmany timesaspossible (greedy
match).

+

om?matches optical

om?matches commissioning

Match the preceding item 0 or 1 time, as
many times as possible (greedymatch).

?
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Table 87: Common Regex Constructs (continued)

ExampleDescriptionConstruct

Groupings

(aaa|bbb)matches aaa or bbbAlternation. Matches if any of the
expressionsmatches.

(expression1|expression2|...)

(?<=www.)\w*\.commatches
www.mycompany.com

The resulting matched string is
mycompany.com.

Lookbehind. Matches if the main
expressionand thepreceding lookbehind
expressionmatch. Thepart of thematch
due to lb_expression is not included in the
matched result. Thematched result
consists of the match resulting from
expression only.

This is useful when you want to search
for a string and you want to exclude the
first part of that string from thematched
result itself.

(?<=lb_expression)expression

\w*(?=@)matches
john@mycompany.com

The resulting matched string is john.

Lookahead. Matches if the main
expression and the following lookahead
expressionmatch. Thepart of thematch
due to la_expression is not included in the
matched result. Thematched result
consists of the match resulting from
expression only.

This is useful when you want to search
for a string and you want to exclude the
latter part of that string from the
matched result itself.

expression(?=la_expression)

Copyright © 2019, Juniper Networks, Inc.580

proNX Service Manager User Guide


	Table of Contents
	List of Figures
	List of Tables
	About the Documentation
	Documentation and Release Notes
	Documentation Conventions
	Documentation Feedback
	Requesting Technical Support
	Self-Help Online Tools and Resources
	Creating a Service Request with JTAC


	Chapter 1: proNX Service Manager
	About PSM
	PSM Client
	PSM Dashboard
	PSM Server
	Red Hat (CentOS) Linux
	Support for RADIUS Server

	PSM Overview
	Running with Multiple Servers
	Overview
	Running Multiple Servers Without Server Replication
	Running Multiple Servers with Server Replication

	Supported Network Elements

	Chapter 2: Getting Started
	Starting the PSM Client
	PSM Client Navigation
	Working with the PSM Client Window System
	Customizing the Quick Access Toolbar
	Displaying the Online Help
	Viewing the List Of Supported Devices

	Chapter 3: Managing PSM Users
	Introduction
	Adding a User
	Modifying a User
	Deleting a User
	Editing User Attributes on the Local RADIUS Server

	Chapter 4: Managing Network Discovery and Ethernet Domains
	Introduction
	Discovering Network Elements
	Undiscovering a Network Element
	Rediscovering a Network Element
	Polling Discovered Network Elements
	Ethernet Network Domains
	Creating an Ethernet Domain
	Checking Domain Membership for a Network Element

	Scheduling Network Element Discoveries
	Scheduling a Network Element Discovery Task
	Viewing Scheduled Tasks
	Deleting Scheduled Tasks


	Chapter 5: Managing Network Topology
	Introduction
	Icons and Definitions
	Understanding the Network Topology View
	Layer Views
	Network Element and Link Details

	Learning the Network Topology
	Deriving Optical Topology Using DOL or ROADM Data
	Deriving Layer 1 Topology Using Snooped LLDP Data
	Deriving Ethernet Topology Using LLDP Data
	Deriving Topology Using Remote IDs
	Remote ID Format
	Remote ID Configuration
	Setting the Remote ID
	Setting the Remote ID on a Multiplexer/Demultiplexer
	Setting the Remote ID on a ROADM C2 Port
	Deleting the Remote ID
	Interactions with LLDP
	Viewing External Devices
	Detecting Remote ID Errors


	Network Element Groups and Sites
	Creating a New Group
	Moving Network Elements, Groups, And/or Sites to a Different Group
	Adding Network Elements to a New Group or Site
	Adding Groups And/or Sites to a New Group
	Navigating Between Parent and Child Groups

	Changing the Background View

	Chapter 6: Working with Network Elements
	Editing Notes for a Network Element
	Identifying Services Associated with a Network Element
	Viewing Network Element Inventory Information
	Searching for a Network Element
	Managing Information for a Network Element
	Enabling or Disabling Network Element Maintenance Modes
	Marking or Unmarking a Network Element
	Enabling or Disabling Provisioning Mode on a Network Element
	Connecting to the CLI on a Network Element
	Provisioning OSPF on a BTI7000 Series Management Network
	Adding OSPF Management
	Editing OSPF Management Settings
	Deleting OSPF Management
	Adding an OSPF Management Interface
	Editing an OSPF Management Interface
	Deleting an OSPF Management Interface

	Configuring In-Band Management on a BTI7800 Network Element

	Chapter 7: Working with the Shelf View
	Introduction
	Displaying Network Elements in the Shelf View
	Displaying Alarms from the Shelf View
	Setting the Remote ID from the Shelf View
	Deleting the Remote ID from the Shelf View

	Chapter 8: Nodal Management
	Introduction
	Nodal Management for BTI7000 Series Network Elements
	Launching the proNX 900 Node Controller
	Provisioning a BTI7000 Series Shelf
	Adding a Shelf
	Deleting a Shelf

	Provisioning a Slot on a BTI7000 Series Shelf
	Adding a Module
	Deleting a Module

	Provisioning a Transponder on a BTI7000 Series Shelf
	Provisioning Ports on a BTI7000 Series Transponder
	Adding a Transponder Port
	Editing a Transponder Port
	Deleting a Transponder Port

	Provisioning Cross-connects on a BTI7000 Series Transponder
	Adding a Transponder Cross-connect
	Deleting a Transponder Cross-connect

	Provisioning Line Protection Groups on a BTI7000 Series Transponder
	Adding a Transponder Protection Group
	Editing a Transponder Protection Group
	Deleting a Transponder Protection Group
	Executing a Protection Switch Command

	Provisioning Client Protection Groups on a BTI7000 Series Transponder
	Adding a Client Protection Group
	Editing a Client Protection Group
	Deleting a Client Protection Group
	Executing a Client Protection Switch Command


	Provisioning a Muxponder on a BTI7000 Series Shelf
	Provisioning Ports on a BTI7000 Series Muxponder
	Adding a Muxponder Port
	Editing a Muxponder Port
	Deleting a Muxponder Port

	Provisioning Virtual Concatenation Groups on a BTI7000 Series Muxponder
	Adding a Muxponder Virtual Concatenation Group
	Editing a Muxponder Virtual Concatenation Group
	Deleting a Muxponder Virtual Concatenation Group

	Provisioning Cross-connects on a BTI7000 Series Muxponder
	Adding a Muxponder Cross-connect
	Deleting a Muxponder Cross-connect

	Provisioning Protection Groups on a BTI7000 Series Muxponder
	Adding a Muxponder Protection Group
	Editing a Muxponder Protection Group
	Deleting a Muxponder Protection Group

	Provisioning Synchronization on a BTI7000 Series Muxponder

	Provisioning a multiplexer/demultiplexer on a BTI7000 Series Shelf
	Adding or Viewing a multiplexer/demultiplexer
	Deleting a multiplexer/demultiplexer

	Provisioning GCC on a BTI7000 Series Network Element
	Provisioning GCC
	Deleting GCC

	Viewing Port PMs on a BTI7000 Series Network Element
	Provisioning the BTI7000 Series Dynamic Optical Layer (DOL)
	Provisioning Optical Groups
	Creating an Optical Group
	Assigning or Unassigning Equipment
	Deleting an Optical Group

	Editing WDM Parameters in an Optical Group
	Adding and Deleting the C2 Port
	Editing Optical Port Parameters
	Configuring a Split ROADM Node
	Editing OSC Parameters in an Optical Group

	Enabling or Disabling a Port

	Nodal Management for BTI7800 Series Network Elements
	Provisioning a BTI7800 Chassis
	Adding a Shelf
	Editing a Shelf
	Deleting a Shelf

	Provisioning a Universal Forwarding Module on a BTI7800
	Adding a UFM
	Editing a UFM
	Deleting a UFM
	Adding a BIC
	Editing a BIC
	Cloning a BIC
	Deleting a BIC
	Adding a Transceiver
	Editing a Transceiver
	Cloning a Transceiver
	Deleting a Transceiver
	Adding an Interface
	Editing an Interface
	Configuring a Multiplexed Interface
	Cloning an Interface
	Deleting an Interface
	Viewing Interface PMs on a UFM

	Provisioning a ROADM Node on a BTI7800
	General Provisioning Procedure
	Adding a ROADM or an ILA Module
	Editing a ROADM or an ILA Module
	Deleting a ROADM or an ILA Module
	Adding a PRE Module
	Editing a PRE Module
	Deleting a PRE Module
	Adding or Viewing a multiplexer/demultiplexer
	Deleting a multiplexer/demultiplexer
	Editing a Port
	Editing the OMS
	Editing the OSC
	Adding a Fiber Connection on a ROADM or an ILA Client Port
	Editing a Fiber Connection on a ROADM or an ILA Client Port
	Deleting a Fiber Connection on a ROADM or an ILA Client Port
	Adding a Fiber Connection on a ROADM or an ILA Line Port
	Editing a Fiber Connection on a ROADM or an ILA Line Port
	Deleting a Fiber Connection on a ROADM or an ILA Line Port
	Adding a Fiber Connection on a UFM Interface
	Editing a Fiber Connection on a UFM Interface
	Deleting a Fiber Connection on a UFM Interface
	Viewing Fiber Connections
	Adding an Optical Channel
	Bulk Adding Optical Channels
	Editing an Optical Channel
	Deleting an Optical Channel
	Viewing Port PMs on a ROADM Element
	Viewing OMS PMs on a ROADM Element
	Viewing OSC PMs on a ROADM Element
	Viewing Optical Channel PMs on a ROADM Element

	Provisioning a 96-Channel Amplifier on a BTI7800
	Adding an Amplifier
	Creating an Optical Group for a BTI7800 Series Amplifier
	Assigning or Unassigning an Amplifier
	Editing an Amplifier Port
	Editing WDM Parameters for an Amplifier
	Editing OSC Parameters for an Amplifier
	Changing an Amplifier's Group
	Viewing Port PMs on a 96-Channel Amplifier

	Provisioning a Wavelength Protection Switch Module on a BTI7800
	Adding a WPS Module
	Adding a Protection Group
	Editing a Protection Group
	Deleting a Protection Group
	Editing a Port

	Enabling or Disabling a Port

	Nodal Management for Juniper Networks Routers and Switches
	Editing an Interface
	Enabling or Disabling a Port
	Viewing Interface PMs on an MX Series or PTX Series Router or QFX Series Switch

	Nodal Management for BTI800 Series Network Elements
	Enabling or Disabling a Port


	Chapter 9: Configuring PSM Client Options
	Introduction
	Configuring General Options
	Setting Auto-logout

	Configuring Alerts Options
	Setting Alarm Alerts Options

	Configuring Display Options
	Setting Alarm Display Options
	Setting Auto-categorization Options
	Setting Device Display Options
	Setting Overlay Display Options
	Setting Service Display Options
	Setting Topology Display Options

	Configuring Performance Monitoring Options
	Setting Historical PM Graphing Options
	Setting Optical Graphing Options
	Setting Real-time Collections Options

	Configuring Utilities
	Setting Utility Executables
	Configuring the proNX 900 Node Controller


	Chapter 10: Bulk Configuration Of Network Elements
	Introduction
	Creating New Users on Multiple Network Elements
	Configuring RADIUS Server Parameters on Multiple Network Elements
	Configuring NTP Server Parameters on Multiple Network Elements

	Chapter 11: Managing Optical and Transport Services
	Optical Services
	Visualizing an Optical Service
	Activating an Optical Service in a BTI7000 Network
	Activating an Optical Service Between BTI7000 Optical Port Endpoints
	Activating an Optical Service Between Transponder Interface Endpoints
	Examples Of Path Selection in a BTI7000 Optical Network
	Selecting Paths and Channels
	Selecting a Path with No Decision Points
	Selecting a Path with One Decision Point
	Selecting a Path with Two Decision Points


	Activating an Optical Service in a BTI7800 Network
	Viewing the Cross-Connects in an Optical Service
	Updating an Optical Service
	Deleting an Optical Service
	Viewing the Optical Services Table
	Viewing the Optical Services Per Span Table
	Viewing the Optical Topology Table

	Transport Services
	Visualizing a Transport Service
	Activating a Transport Service
	Updating a Transport Service
	Deleting a Transport Service
	Viewing the Transport Services Table
	Viewing the Transport Services Per Span Table
	Viewing the Transport Topology Table
	Viewing the Transponder Tuning Grid

	Working with Optical/Transport Services and Topology Tables
	Sorting the Tables
	Filtering the Tables

	Saving a Service Image

	Chapter 12: Managing Ethernet Services
	Introduction
	Service Visualization
	Visualizing an Ethernet Service
	Service Visualization Scheme

	Understanding Ethernet Service States
	Service Activation
	Service Types
	Auto-provisioning NNIs
	Activating an Ethernet Service
	Example: Activating an EVPLINE Service
	Part 1: Setting Up the EVPLINE Service with CVLAN Translation
	Part 2: Setting Up the EVPLINE Service with the Virtual Untagged Option

	Example: Activating an Ethernet Service on a Multi-chassis LAG
	Example: Activating EVPLAN and EVPLINE Services Using Service Maps for Flow Redirection
	Part 1: Setting Up the Service Maps
	Part 2: Setting Up the EVPLINE Services
	Setting Up the EVPLAN Service


	Modifying a Service
	Modifying a Port in a Service
	Adding a Port to a Service
	Removing a Port from a Service

	Deleting a Service
	Adding SLA/CFM to a Service
	Running a Y.1731 Link Trace
	Running a Y.1731 Loopback
	Running an RFC 2544 Benchmarking Test
	Ethernet Ring Protection Switching (ERPS)
	Visualizing an ERPS Service
	Effect Of Link Failure on ERPS States

	Viewing the ERPS Services Table
	Adding VLANs to an ERPS Ring

	Routing Considerations in Mixed Networks
	GVRP - GARP VLAN Registration Protocol
	Mixed Networks - BTI7000 Series with BTI700 Series or BTI800 Series Elements
	Creating Services in BTI7000 Series packetVX Only Networks
	Creating Services Over BTI700 Series And/or BTI800 Series Only Networks
	Activating Services Over Combinations Of BTI7000 Series packetVX and BTI700 Series or BTI800 Series Networks


	Managing Profiles
	About Profile Manager
	Selecting a Profile During Service Activation

	Managing Profile Templates
	Creating a Profile Template
	Editing an Existing Profile Template
	Creating a Profile Template Through Cloning
	Deleting a Profile Template

	Bandwidth Profile Templates
	TCM Bandwidth Profiles
	Two-rate TCM
	Single-rate TCM
	CAR Bandwidth Profile Template
	Color Mode and Actions
	Setting DEI on Exceed Traffic
	Internal Priority for Bandwidth Profile Templates

	Class Map Profile Templates
	Service Policy Profile Templates
	Service Map Profile Templates
	SLA Measurement Profile Templates


	Chapter 13: Managing Pseudowire Services
	Introduction
	Visualizing a Pseudowire Service
	Service Activation
	Activating a Pseudowire Service

	Modifying a Pseudowire Service
	Deleting a Pseudowire Service

	Chapter 14: Managing Customers
	Introduction
	Adding a Customer
	Modifying a Customer
	Deleting a Customer

	Chapter 15: Managing Network Element Alarms
	Supported Network Elements and Devices
	MX Series, PTX Series, and QFX Series Alarms

	Alarm Visualization
	Viewing Current Alarms
	Understanding Alarm Timestamps
	How the PSM Server Timestamps the Alarms
	How the PSM Server Timestamps the Clears
	How the PSM Client Displays Timestamps

	Working with the Alarms Table
	Sorting the Alarms Table
	Filtering the Alarms Table
	Using Service/alarm Correlation
	Suspending Alarm Notification

	Understanding the Alarms Summary Bar
	Resetting the Deltas
	Interpreting the Deltas
	Filtering Based on Alarm Severity


	Acknowledging, Emailing, and Clearing Alarms
	Assigning an Alarm to a User
	Viewing Historical Alarms
	Viewing Alarms Through an RSS Feed
	Sending Traps on the Northbound Interface
	Adding a Trap Receiver for Alarms
	Modifying a Trap Receiver for Alarms
	Deleting a Trap Receiver for Alarms


	Chapter 16: Managing Network Element System Software and FTP Servers
	Adding an FTP or SFTP Server
	Modifying the Configuration for an FTP or SFTP Server
	Deleting an FTP or SFTP Server
	Manually Backing Up a Network Element Configuration Database
	Restoring a Configuration Database to a Network Element
	Upgrading System Software for a Network Element
	Restoring a Database to Factory Defaults on a BTI7800 Network Element

	Chapter 17: Managing Reports
	Generating Alarms Reports
	Generating an Active Alarms Report
	Generating a Historical Alarms Report

	Generating Ethernet Reports
	Generating Pseudowire Reports
	Generating Transport Reports
	Generating NE Logs Reports
	Generating Optical Reports
	Generating Inventory Reports
	Generating Task History Reports
	Changing the Report Generation Timeout

	Chapter 18: Performance Monitoring
	Viewing Current Port, Interface, and Channel PMs
	Viewing Real-time Optical Service PMs
	Viewing Real-time Transport Service PMs
	Viewing Real-time Ethernet PMs and SLAs
	Viewing Real-time Pseudowire PMs
	Collecting and Viewing Historical PMs

	Chapter 19: Troubleshooting
	Managing Task Status
	Discovering Task Status
	Clearing Completed Tasks

	Exporting Client and Server Logs
	Performing Diagnostics
	Viewing the PSM Client Log
	Testing Network Element Connectivity
	Verifying PSM Client-server Connectivity
	Collecting and Viewing NE Logs
	Saving Network Element Configuration Information
	Troubleshooting Server Replication
	Loss Of Connectivity to the Cluster
	Loss Of Synchronization with a Cluster Member
	Re-establishment Of Connectivity to the Cluster
	Synchronizing Replicated Data Manually
	Restarting the Cluster


	Chapter 20: Appendix
	Service Activation Error Messages
	PSM Alarms
	BTI7800 Alarm Details
	Installing Net-SNMP
	Configuring Historical PM Collection on BTI800 Series Network Elements
	PM Counters
	PM Counters for BTI7000 Series Transponders and Muxponders
	PM Counters for BTI7000 Series DOL Modules
	PM Counters for BTI7000 Series packetVX Modules
	PM Counters for BTI718E Modules
	PM Counters for BTI800 Series Modules
	PM Counters for Optical Interfaces on MX Series and PTX Series Routers and QFX Series Switches

	Regular Expressions


